Sitecore Namespace

Sitecore 6.1.0 rev. 090630 API
Sitecore Namespace
Namespaces ► Sitecore
Declaration Syntax
C#
namespace Sitecore
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | AllowNullAttribute | Implements the AllowNullAttribute class.
 | ItemIDs..::.Analytics | Defines the analytics class.
 | ArchivedItemFieldIDs | Fields of the Tasks/Command template.
 | AssertionConditionAttribute |
 | AssertionConditionType |
 | AssertionMethodAttribute | Implements the NullableAttribute.
 | BaseTypeRequiredAttribute |
 | BlockedPage |
 | CachePrefix | Implements a static class for holding string prefixes for cache operations.
 | CanBeNullAttribute | Implements the CanBeNullAttribute.
 | CannotApplyEqualityOperatorAttribute |
 | Client |
 | CommandFieldIDs | Fields of the Tasks/Command template.
 | CommandsCommandFieldIDs | Fields of the Commands/Command template.
 | Constants | Implements a static class for holding miscellaneous constantvalues.
 | Context | Represents the current state for this request. Represents the current state for this request. Context class Represents the current state for this request.
 | Context..::.ContextData | Represents the context data.
 | Convert | Provides conversion utility functions for a number of types.
 | DateUtil | Implements a utility class for manipulating dates.
 | DaysOfWeek | Specifies a days of week enumeration.
 | DefaultPage | Defines the default page class.
 | DeviceFieldIDs | Fields of the Layout/Device template.
 | Disposable | Provides a base class for implementing classes that must be disposed.
 | EventHandlerInfo | Information about event handler.
 | FieldIDs | Implements a static class for holding well-known GUIDs relating to fields.
 | Globals | Represents the globals.
 | Handle | Represents a handle.
 | ImplicitUseFlags |
 | InvokerParameterNameAttribute |
 | IPublishingRequest | Represents a publishing request.
 | IPublishingStatus | Represents a publishing status.
 | ItemIDs | Implements a static class for holding assorted well-known GUID values.
 | LayoutFieldIDs | Fields of the Layout/Layout template.
 | MainUtil | Implements a library of standard utility functions.
 | ItemIDs..::.Analytics..::.MarketingCenter | Defines the reports class.
 | MeansImplicitUseAttribute | Should be used on attributes and causes ReSharper to not mark symbols marked with such attributes as unused (as well as by other usage inspections)
 | NotNullAttribute | Implements the NotNullAttribute.
 | PackageRegistrationFieldIDs | Fields of the 'Packages/Package registration' template.
 | Context..::.PageDesigner | Represents the Page Designer.
 | Context..::.PageMode | Retrieves information about the current page mode.
 | RenderingIDs | Implements a static class for holding assorted well-known GUID values.
 | ItemIDs..::.Analytics..::.Reports | Defines the reports class.
 | RoleFieldIDs | Fields of the Security/Role template.
 | ScheduleFieldIDs | Fields of the Tasks/Schedule template.
 | SecurityDatabaseTemplateIDs | Implements a static class for holding well-known GUIDs relating to templates.
 | ShellFieldIDs | Implements a static class for holding assorted well-known GUID values.
 | SitecoreDataContext |
 | StringFormatMethodAttribute |
 | StringUtil | Implements a utility class for manipulating strings.
 | SystemFieldIDs | Obsolete. Implements a static class for holding well-known GUIDs relating to system fields.
 | TemplateFieldIDs | Implements a static class for holding well-known GUIDs relating to template fields.
 | TemplateIDs | Implements a static class for holding well-known GUIDs relating to templates.
 | TemplateSectionFieldIDs | Implements a static class for holding well-known GUIDs relating to template sections.
 | TerminatesProgramAttribute |
 | Todo | Todo marker
 | Tristate | Represents a tristate.
 | UIUtil | Implements helper functions.
 | UsedImplicitlyAttribute | Indicates that the marked symbol is used implicitly (ex. reflection, external library), so this symbol will not be marked as unused (as well as by other usage inspections)
 | UserFieldIDs | Fields of the Security/User template.
 | WorkflowFieldIDs | Implements a static class for holding assorted well-known GUID values.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.


AllowNullAttribute Class

AllowNullAttribute Class
Namespaces ► Sitecore ► AllowNullAttribute
Implements the AllowNullAttribute class.
Declaration Syntax
C#
public sealed class AllowNullAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AllowNullAttribute(String) | Initializes a new instance of the AllowNullAttribute class.
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | AllowNullAttribute

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Kernel (Module: Sitecore.Kernel) Version: 6.0.0.0 (6.1.0.3011)


AllowNullAttribute Constructor (name)

AllowNullAttribute Constructor (name)
Namespaces ► Sitecore ► AllowNullAttribute ► AllowNullAttribute(String)
Initializes a new instance of the AllowNullAttribute class.
Declaration Syntax
C#
public AllowNullAttribute(
    string name
)
Parameters
name (String)
The name.


Name Property

Name Property
Namespaces ► Sitecore ► AllowNullAttribute ► Name
Gets or sets the name.
Declaration Syntax
C#
public string Name { get; set; }
Value
The name.


ArchivedItemFieldIDs Class

ArchivedItemFieldIDs Class
Namespaces ► Sitecore ► ArchivedItemFieldIDs
Fields of the Tasks/Command template.
Declaration Syntax
C#
public static class ArchivedItemFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ArchiveDate | The ID of the 'Archive date' field.
 | Completed | The ID of the 'Completed' field.
 | DatabaseName | The ID of the 'Database name' field.
 | ItemID | The ID of the 'Item ID' field.
 | ItemXml | The ID of the 'Item data' field.
 | ParentID | The ID of the 'Parent ID' field.
 | UserName | The ID of the 'User' field.
Inheritance Hierarchy
Object
ArchivedItemFieldIDs


ArchiveDate Field

ArchiveDate Field
Namespaces ► Sitecore ► ArchivedItemFieldIDs ► ArchiveDate
The ID of the 'Archive date' field.
Declaration Syntax
C#
public static ID ArchiveDate


Completed Field

Completed Field
Namespaces ► Sitecore ► ArchivedItemFieldIDs ► Completed
The ID of the 'Completed' field.
Declaration Syntax
C#
public static ID Completed


DatabaseName Field

DatabaseName Field
Namespaces ► Sitecore ► ArchivedItemFieldIDs ► DatabaseName
The ID of the 'Database name' field.
Declaration Syntax
C#
public static ID DatabaseName


ItemID Field

ItemID Field
Namespaces ► Sitecore ► ArchivedItemFieldIDs ► ItemID
The ID of the 'Item ID' field.
Declaration Syntax
C#
public static ID ItemID


ItemXml Field

ItemXml Field
Namespaces ► Sitecore ► ArchivedItemFieldIDs ► ItemXml
The ID of the 'Item data' field.
Declaration Syntax
C#
public static ID ItemXml


ParentID Field

ParentID Field
Namespaces ► Sitecore ► ArchivedItemFieldIDs ► ParentID
The ID of the 'Parent ID' field.
Declaration Syntax
C#
public static ID ParentID


UserName Field

UserName Field
Namespaces ► Sitecore ► ArchivedItemFieldIDs ► UserName
The ID of the 'User' field.
Declaration Syntax
C#
public static ID UserName


AssertionConditionAttribute Class

AssertionConditionAttribute Class
Namespaces ► Sitecore ► AssertionConditionAttribute
Declaration Syntax
C#
public class AssertionConditionAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssertionConditionAttribute(AssertionConditionType) | Initializes a new instance of the AssertionConditionAttribute class.
 | ConditionType | Gets the type of the condition.
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | AssertionConditionAttribute


AssertionConditionAttribute Constructor (conditionType)

AssertionConditionAttribute Constructor (conditionType)
Namespaces ► Sitecore ► AssertionConditionAttribute ► AssertionConditionAttribute(AssertionConditionType)
Initializes a new instance of the AssertionConditionAttribute class.
Declaration Syntax
C#
public AssertionConditionAttribute(
    AssertionConditionType conditionType
)
Parameters
conditionType (AssertionConditionType)
Type of the condition.


ConditionType Property

ConditionType Property
Namespaces ► Sitecore ► AssertionConditionAttribute ► ConditionType
Gets the type of the condition.
Declaration Syntax
C#
public AssertionConditionType ConditionType { get; }
Value
The type of the condition.


AssertionConditionType Enumeration

AssertionConditionType Enumeration
Namespaces ► Sitecore ► AssertionConditionType
Declaration Syntax
C#
public enum AssertionConditionType
Members
Member | Description
IS_TRUE |
IS_FALSE |
IS_NULL |
IS_NOT_NULL |


AssertionMethodAttribute Class

AssertionMethodAttribute Class
Namespaces ► Sitecore ► AssertionMethodAttribute
Implements the NullableAttribute.
Declaration Syntax
C#
public sealed class AssertionMethodAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssertionMethodAttribute()()() | Initializes a new instance of the AssertionMethodAttribute class
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | AssertionMethodAttribute


AssertionMethodAttribute Constructor

AssertionMethodAttribute Constructor
Namespaces ► Sitecore ► AssertionMethodAttribute ► AssertionMethodAttribute()()()
Initializes a new instance of the AssertionMethodAttribute class
Declaration Syntax
C#
public AssertionMethodAttribute()


BaseTypeRequiredAttribute Class

BaseTypeRequiredAttribute Class
Namespaces ► Sitecore ► BaseTypeRequiredAttribute
Declaration Syntax
C#
public class BaseTypeRequiredAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseTypeRequiredAttribute(Type) | Initializes a new instance of the BaseTypeRequiredAttribute class.
 | BaseTypeRequiredAttribute(array<Type>[]()[]) | Initializes a new instance of the BaseTypeRequiredAttribute class.
 | BaseTypes | Gets the base types.
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | BaseTypeRequiredAttribute


BaseTypeRequiredAttribute Constructor

BaseTypeRequiredAttribute Constructor
Namespaces ► Sitecore ► BaseTypeRequiredAttribute ► BaseTypeRequiredAttribute()()()
Members
Icon | Member | Description
 | BaseTypeRequiredAttribute(Type) | Initializes a new instance of the BaseTypeRequiredAttribute class.
 | BaseTypeRequiredAttribute(array<Type>[]()[]) | Initializes a new instance of the BaseTypeRequiredAttribute class.


BaseTypeRequiredAttribute Constructor (baseType)

BaseTypeRequiredAttribute Constructor (baseType)
Namespaces ► Sitecore ► BaseTypeRequiredAttribute ► BaseTypeRequiredAttribute(Type)
Initializes a new instance of the BaseTypeRequiredAttribute class.
Declaration Syntax
C#
public BaseTypeRequiredAttribute(
    Type baseType
)
Parameters
baseType (Type)
Type of the base.


BaseTypeRequiredAttribute Constructor (baseTypes)

BaseTypeRequiredAttribute Constructor (baseTypes)
Namespaces ► Sitecore ► BaseTypeRequiredAttribute ► BaseTypeRequiredAttribute(array<Type>[]()[])
Initializes a new instance of the BaseTypeRequiredAttribute class.
Declaration Syntax
C#
public BaseTypeRequiredAttribute(
    Type[] baseTypes
)
Parameters
baseTypes (array< Type >[]()[])
The base types.


BaseTypes Property

BaseTypes Property
Namespaces ► Sitecore ► BaseTypeRequiredAttribute ► BaseTypes
Gets the base types.
Declaration Syntax
C#
public Type[] BaseTypes { get; }
Value
The base types.


BlockedPage Class

BlockedPage Class
Namespaces ► Sitecore ► BlockedPage
Declaration Syntax
C#
public class BlockedPage : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BlockedPage()()() | Initializes a new instance of the BlockedPage class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 | form1 control.
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) | Handles the Load event of the Page control.
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | BlockedPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


BlockedPage Constructor

BlockedPage Constructor
Namespaces ► Sitecore ► BlockedPage ► BlockedPage()()()
Initializes a new instance of the BlockedPage class
Declaration Syntax
C#
public BlockedPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


form1 Field

form1 Field
Namespaces ► Sitecore ► BlockedPage ► form1
form1 control.
Declaration Syntax
C#
protected HtmlForm form1
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore ► BlockedPage ► Page_Load(Object, EventArgs)
Handles the Load event of the Page control.
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CachePrefix Class

CachePrefix Class
Namespaces ► Sitecore ► CachePrefix
Implements a static class for holding string prefixes for cache operations.
Declaration Syntax
C#
public class CachePrefix
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CachePrefix()()() | Initializes a new instance of the CachePrefix class
 | Base | The base Sitecore cache prefix.
 | ClientData | The cache prefix for client data.
 | CoreItem | the cache prefix for core items.
 | DatabaseCache | The cache prefix for database objects.
 | DomainUser | The cache prefix for domain users.
 | DomainUserData | The cache prefix for domain user data.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Html | The cache prefix for HTML operations.
 | IndexCache | The cache prefix for index objects.
 | ItemDefinition | the cache prefix for item definitions.
 | ItemVersion | the cache prefix for item versions.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RenderingList | The cache prefix for rendering lists.
 | SubDatabases | The cache prefix for subdatabase objects.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Xsl | the cache prefix for XSL files.
Remarks
The class does not contain any functionality, but serves as a placeholder for a number of string values.
Inheritance Hierarchy
Object
CachePrefix


CachePrefix Constructor

CachePrefix Constructor
Namespaces ► Sitecore ► CachePrefix ► CachePrefix()()()
Initializes a new instance of the CachePrefix class
Declaration Syntax
C#
public CachePrefix()


Base Field

Base Field
Namespaces ► Sitecore ► CachePrefix ► Base
The base Sitecore cache prefix.
Declaration Syntax
C#
public const string Base
Remarks
Other cache prefixes starts with this base prefix.


ClientData Field

ClientData Field
Namespaces ► Sitecore ► CachePrefix ► ClientData
The cache prefix for client data.
Declaration Syntax
C#
public const string ClientData


CoreItem Field

CoreItem Field
Namespaces ► Sitecore ► CachePrefix ► CoreItem
the cache prefix for core items.
Declaration Syntax
C#
public const string CoreItem


DatabaseCache Field

DatabaseCache Field
Namespaces ► Sitecore ► CachePrefix ► DatabaseCache
The cache prefix for database objects.
Declaration Syntax
C#
public const string DatabaseCache


DomainUser Field

DomainUser Field
Namespaces ► Sitecore ► CachePrefix ► DomainUser
The cache prefix for domain users.
Declaration Syntax
C#
public const string DomainUser


DomainUserData Field

DomainUserData Field
Namespaces ► Sitecore ► CachePrefix ► DomainUserData
The cache prefix for domain user data.
Declaration Syntax
C#
public const string DomainUserData


Html Field

Html Field
Namespaces ► Sitecore ► CachePrefix ► Html
The cache prefix for HTML operations.
Declaration Syntax
C#
public const string Html


IndexCache Field

IndexCache Field
Namespaces ► Sitecore ► CachePrefix ► IndexCache
The cache prefix for index objects.
Declaration Syntax
C#
public const string IndexCache


ItemDefinition Field

ItemDefinition Field
Namespaces ► Sitecore ► CachePrefix ► ItemDefinition
the cache prefix for item definitions.
Declaration Syntax
C#
public const string ItemDefinition


ItemVersion Field

ItemVersion Field
Namespaces ► Sitecore ► CachePrefix ► ItemVersion
the cache prefix for item versions.
Declaration Syntax
C#
public const string ItemVersion


RenderingList Field

RenderingList Field
Namespaces ► Sitecore ► CachePrefix ► RenderingList
The cache prefix for rendering lists.
Declaration Syntax
C#
public const string RenderingList


SubDatabases Field

SubDatabases Field
Namespaces ► Sitecore ► CachePrefix ► SubDatabases
The cache prefix for subdatabase objects.
Declaration Syntax
C#
public const string SubDatabases


Xsl Field

Xsl Field
Namespaces ► Sitecore ► CachePrefix ► Xsl
the cache prefix for XSL files.
Declaration Syntax
C#
public const string Xsl


CanBeNullAttribute Class

CanBeNullAttribute Class
Namespaces ► Sitecore ► CanBeNullAttribute
Implements the CanBeNullAttribute.
Declaration Syntax
C#
public sealed class CanBeNullAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CanBeNullAttribute()()() | Initializes a new instance of the CanBeNullAttribute class
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | CanBeNullAttribute


CanBeNullAttribute Constructor

CanBeNullAttribute Constructor
Namespaces ► Sitecore ► CanBeNullAttribute ► CanBeNullAttribute()()()
Initializes a new instance of the CanBeNullAttribute class
Declaration Syntax
C#
public CanBeNullAttribute()


CannotApplyEqualityOperatorAttribute Class

CannotApplyEqualityOperatorAttribute Class
Namespaces ► Sitecore ► CannotApplyEqualityOperatorAttribute
Declaration Syntax
C#
public class CannotApplyEqualityOperatorAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CannotApplyEqualityOperatorAttribute()()() | Initializes a new instance of the CannotApplyEqualityOperatorAttribute class
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | CannotApplyEqualityOperatorAttribute


CannotApplyEqualityOperatorAttribute Constructor

CannotApplyEqualityOperatorAttribute Constructor
Namespaces ► Sitecore ► CannotApplyEqualityOperatorAttribute ► CannotApplyEqualityOperatorAttribute()()()
Initializes a new instance of the CannotApplyEqualityOperatorAttribute class
Declaration Syntax
C#
public CannotApplyEqualityOperatorAttribute()


Client Class

Client Class
Namespaces ► Sitecore ► Client
Declaration Syntax
C#
public static class Client
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AjaxScriptManager | Gets the current ajax script manager, asserts its presence.
 | ContentDatabase | Gets the content database.
 | CoreDatabase | Gets the core database.
 | Device | Gets the device.
 | GetDatabaseNotNull(String) | Gets the database.
 | GetItemNotNull(String) | Gets the item not null.
 | GetItemNotNull(String, Database) | Gets the item not null.
 | GetItemNotNull(String, Language) | Gets the item not null.
 | GetItemNotNull(String, Language, Version) | Gets the item not null.
 | GetItemNotNull(String, Language, Version, Database) | Gets the item not null.
 | GetItemNotNull(ID) | Gets the item ensuring that it is not null.
 | GetItemNotNull(ID, Language) | Gets the item ensuring that it is not null.
 | GetItemNotNull(ID, Language, Version) | Gets the item not null.
 | GetItemNotNull(ID, Language, Version, Database) | Gets the item ensuring that it is not null.
 | GetItemNotNull(ItemUri) | Gets the item ensuring that it is not null.
 | Page | Gets the page.
 | Site | Gets the site.
Inheritance Hierarchy
Object
Client


AjaxScriptManager Property

AjaxScriptManager Property
Namespaces ► Sitecore ► Client ► AjaxScriptManager
Gets the current ajax script manager, asserts its presence.
Declaration Syntax
C#
public static AjaxScriptManager AjaxScriptManager { get; }


ContentDatabase Property

ContentDatabase Property
Namespaces ► Sitecore ► Client ► ContentDatabase
Gets the content database.
Declaration Syntax
C#
public static Database ContentDatabase { get; }
Value
The content database.
Exceptions
Exception | Condition
InvalidOperationException | The Sitecore.Client.ContentDatabase is null.


CoreDatabase Property

CoreDatabase Property
Namespaces ► Sitecore ► Client ► CoreDatabase
Gets the core database.
Declaration Syntax
C#
public static Database CoreDatabase { get; }
Value
The core database.
Exceptions
Exception | Condition
InvalidOperationException | The Sitecore.Client.CoreDatabase is null.


Device Property

Device Property
Namespaces ► Sitecore ► Client ► Device
Gets the device.
Declaration Syntax
C#
public static DeviceItem Device { get; }
Value
The device.
Exceptions
Exception | Condition
InvalidOperationException | The Sitecore.Client.Device is null.


GetDatabaseNotNull Method (databaseName)

GetDatabaseNotNull Method (databaseName)
Namespaces ► Sitecore ► Client ► GetDatabaseNotNull(String)
Gets the database.
Declaration Syntax
C#
public static Database GetDatabaseNotNull(
    string databaseName
)
Parameters
databaseName (String)
Name of the database.
Return Value
The database.
Exceptions
Exception | Condition
DatabaseNullException | DatabaseNullException.


GetItemNotNull Method

GetItemNotNull Method
Namespaces ► Sitecore ► Client ► GetItemNotNull()()()
Members
Icon | Member | Description
 | GetItemNotNull(String) | Gets the item not null.
 | GetItemNotNull(String, Database) | Gets the item not null.
 | GetItemNotNull(String, Language) | Gets the item not null.
 | GetItemNotNull(String, Language, Version) | Gets the item not null.
 | GetItemNotNull(String, Language, Version, Database) | Gets the item not null.
 | GetItemNotNull(ID) | Gets the item ensuring that it is not null.
 | GetItemNotNull(ID, Language) | Gets the item ensuring that it is not null.
 | GetItemNotNull(ID, Language, Version) | Gets the item not null.
 | GetItemNotNull(ID, Language, Version, Database) | Gets the item ensuring that it is not null.
 | GetItemNotNull(ItemUri) | Gets the item ensuring that it is not null.


GetItemNotNull Method (itemId)

GetItemNotNull Method (itemId)
Namespaces ► Sitecore ► Client ► GetItemNotNull(ID)
Gets the item ensuring that it is not null.
Declaration Syntax
C#
public static Item GetItemNotNull(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value
The item.


GetItemNotNull Method (itemId, language)

GetItemNotNull Method (itemId, language)
Namespaces ► Sitecore ► Client ► GetItemNotNull(ID, Language)
Gets the item ensuring that it is not null.
Declaration Syntax
C#
public static Item GetItemNotNull(
    ID itemId,
    Language language
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
Return Value
The item.


GetItemNotNull Method (itemId, language, version)

GetItemNotNull Method (itemId, language, version)
Namespaces ► Sitecore ► Client ► GetItemNotNull(ID, Language, Version)
Gets the item not null.
Declaration Syntax
C#
public static Item GetItemNotNull(
    ID itemId,
    Language language,
    Version version
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
version (Version)
The version.
Return Value
The item not null.


GetItemNotNull Method (itemId, language, version, database)

GetItemNotNull Method (itemId, language, version, database)
Namespaces ► Sitecore ► Client ► GetItemNotNull(ID, Language, Version, Database)
Gets the item ensuring that it is not null.
Declaration Syntax
C#
public static Item GetItemNotNull(
    ID itemId,
    Language language,
    Version version,
    Database database
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
version (Version)
The version.
database (Database)
The database.
Return Value
The item.
Exceptions
Exception | Condition
ItemNullException | Item not found.


GetItemNotNull Method (uri)

GetItemNotNull Method (uri)
Namespaces ► Sitecore ► Client ► GetItemNotNull(ItemUri)
Gets the item ensuring that it is not null.
Declaration Syntax
C#
public static Item GetItemNotNull(
    ItemUri uri
)
Parameters
uri (ItemUri)
The URI.
Return Value
The item.
Exceptions
Exception | Condition
ItemNullException | ItemNullException.


GetItemNotNull Method (itemPath)

GetItemNotNull Method (itemPath)
Namespaces ► Sitecore ► Client ► GetItemNotNull(String)
Gets the item not null.
Declaration Syntax
C#
public static Item GetItemNotNull(
    string itemPath
)
Parameters
itemPath (String)
The item path.
Return Value
The item not null.


GetItemNotNull Method (itemPath, database)

GetItemNotNull Method (itemPath, database)
Namespaces ► Sitecore ► Client ► GetItemNotNull(String, Database)
Gets the item not null.
Declaration Syntax
C#
public static Item GetItemNotNull(
    string itemPath,
    Database database
)
Parameters
itemPath (String)
The item path.
database (Database)
The database.
Return Value
The item not null.


GetItemNotNull Method (itemPath, language)

GetItemNotNull Method (itemPath, language)
Namespaces ► Sitecore ► Client ► GetItemNotNull(String, Language)
Gets the item not null.
Declaration Syntax
C#
public static Item GetItemNotNull(
    string itemPath,
    Language language
)
Parameters
itemPath (String)
The item path.
language (Language)
The language.
Return Value
The item not null.


GetItemNotNull Method (itemPath, language, version)

GetItemNotNull Method (itemPath, language, version)
Namespaces ► Sitecore ► Client ► GetItemNotNull(String, Language, Version)
Gets the item not null.
Declaration Syntax
C#
public static Item GetItemNotNull(
    string itemPath,
    Language language,
    Version version
)
Parameters
itemPath (String)
The item path.
language (Language)
The language.
version (Version)
The version.
Return Value
The item not null.


GetItemNotNull Method (itemPath, language, version, database)

GetItemNotNull Method (itemPath, language, version, database)
Namespaces ► Sitecore ► Client ► GetItemNotNull(String, Language, Version, Database)
Gets the item not null.
Declaration Syntax
C#
public static Item GetItemNotNull(
    string itemPath,
    Language language,
    Version version,
    Database database
)
Parameters
itemPath (String)
The item path.
language (Language)
The language.
version (Version)
The version.
database (Database)
The database.
Return Value
The item not null.
Exceptions
Exception | Condition
ItemNullException | Item is null.


Page Property

Page Property
Namespaces ► Sitecore ► Client ► Page
Gets the page.
Declaration Syntax
C#
public static PageContext Page { get; }
Value
The page.
Exceptions
Exception | Condition
InvalidOperationException | The Sitecore.Client.Page is null.


Site Property

Site Property
Namespaces ► Sitecore ► Client ► Site
Gets the site.
Declaration Syntax
C#
public static SiteContext Site { get; }
Value
The site.
Exceptions
Exception | Condition
InvalidOperationException | The Sitecore.Client.Site is null.


CommandFieldIDs Class

CommandFieldIDs Class
Namespaces ► Sitecore ► CommandFieldIDs
Fields of the Tasks/Command template.
Declaration Syntax
C#
public static class CommandFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Method | The ID of the 'Method' field.
 | Type | The ID of the 'Type' field.
Inheritance Hierarchy
Object
CommandFieldIDs


Method Field

Method Field
Namespaces ► Sitecore ► CommandFieldIDs ► Method
The ID of the 'Method' field.
Declaration Syntax
C#
public static ID Method


Type Field

Type Field
Namespaces ► Sitecore ► CommandFieldIDs ► Type
The ID of the 'Type' field.
Declaration Syntax
C#
public static ID Type


CommandsCommandFieldIDs Class

CommandsCommandFieldIDs Class
Namespaces ► Sitecore ► CommandsCommandFieldIDs
Fields of the Commands/Command template.
Declaration Syntax
C#
public static class CommandsCommandFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Type | The ID of the 'Type' field.
Inheritance Hierarchy
Object
CommandsCommandFieldIDs


Type Field

Type Field
Namespaces ► Sitecore ► CommandsCommandFieldIDs ► Type
The ID of the 'Type' field.
Declaration Syntax
C#
public static ID Type


Constants Class

Constants Class
Namespaces ► Sitecore ► Constants
Implements a static class for holding miscellaneous constantvalues.
Declaration Syntax
C#
public class Constants
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Constants()()() | Initializes a new instance of the Constants class
 | AnonymousUserName | Name of the 'anonymous' user.
 | AshxExtension | ASHX extension.
 | AspxExtension | ASPX extension.
 | CONTENT_EDITOR_SKIN_NAMESPACE_URI | URI of the Content Editor skin namespace
 | ContentPath | Path to the content.
 | CoreDatabaseName | Name of the 'core' database.
 | CreatorOwnerRoleName | Name of the owner/creator role.
 | DefaultArchiveName | Name of the default archive for a database.
 | DefaultAspNetSessionIdCookieName | Default name of the ASP.NET session id cookie.
 | DefaultCulture | Name of the default culture.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EveryoneRoleName | Name of the 'everyone' role.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GuidLength | Length of a GUID.
 | HttpRequestAbortedKey | Items key for aborted http requests.
 | IconRequestPrefix | Prefix of icon request URLs.
 | IsoDateLength | Length of an iso date.
 | IsoDateTimeLength | Length of an iso datetime.
 | IsoTimeLength | Length of an iso time.
 | LinkPrefix | Prefix of links.
 | LinkTerminator | Terminator of links
 | MaxItemLevel | Maximum length of an item name.
 | MediaLibraryPath | Path to the media library.
 | MediaRequestPrefix | Prefix of media request URLs.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimalPageEditorRoleName | Defines name of the Minimal Page Editor role.
 | ModulesShellSiteName | Name of the 'modules_shell' site.
 | NullDate |
 | PerformanceCounterCategory | Obsolete. General performance counter category name.
 | PreviewDateCookieName | Name of the Preview Date Cookie.
 | PreviewShellUserCookieName | Name of the Preview Shell User Cookie.
 | PublishingSiteName | Name of the site used when publishing.
 | PublishReplacerName | Name of the 'publish' replacer.
 | RecycleBinArchiveName | Name of the 'recyclebin' archive for a database.
 | RequiredDatabaseVersion | The currently required database version.
 | RestRequestPrefix | Prefix of Rest request URLs.
 | ShellSiteName | Name of the 'shell' site.
 | ShortGuidLength | Length of a short GUID.
 | ShortIdLength | Length of a ShortID.
 | SitecoreClientUsersRole | Name of the Sitecore Client Users role
 | SitecorePath | Path to the root of the tree.
 | SitecorePipelinesOnKey | Key name in Items collection of Context.Items
 | SitecoreShellPath | Path to the shell.
 | StandardValuesItemName | The name of the standard values item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | XamlRequestPrefix | Prefix of Xaml request URLs.
Inheritance Hierarchy
Object
Constants


Constants Constructor

Constants Constructor
Namespaces ► Sitecore ► Constants ► Constants()()()
Initializes a new instance of the Constants class
Declaration Syntax
C#
public Constants()


AnonymousUserName Field

AnonymousUserName Field
Namespaces ► Sitecore ► Constants ► AnonymousUserName
Name of the 'anonymous' user.
Declaration Syntax
C#
public const string AnonymousUserName


AshxExtension Field

AshxExtension Field
Namespaces ► Sitecore ► Constants ► AshxExtension
ASHX extension.
Declaration Syntax
C#
public const string AshxExtension


AspxExtension Field

AspxExtension Field
Namespaces ► Sitecore ► Constants ► AspxExtension
ASPX extension.
Declaration Syntax
C#
public const string AspxExtension


CONTENT_EDITOR_SKIN_NAMESPACE_URI Field

CONTENT_EDITOR_SKIN_NAMESPACE_URI Field
Namespaces ► Sitecore ► Constants ► CONTENT_EDITOR_SKIN_NAMESPACE_URI
URI of the Content Editor skin namespace
Declaration Syntax
C#
public const string CONTENT_EDITOR_SKIN_NAMESPACE_URI


ContentPath Field

ContentPath Field
Namespaces ► Sitecore ► Constants ► ContentPath
Path to the content.
Declaration Syntax
C#
public const string ContentPath


CoreDatabaseName Field

CoreDatabaseName Field
Namespaces ► Sitecore ► Constants ► CoreDatabaseName
Name of the 'core' database.
Declaration Syntax
C#
public const string CoreDatabaseName


CreatorOwnerRoleName Field

CreatorOwnerRoleName Field
Namespaces ► Sitecore ► Constants ► CreatorOwnerRoleName
Name of the owner/creator role.
Declaration Syntax
C#
public const string CreatorOwnerRoleName


DefaultArchiveName Field

DefaultArchiveName Field
Namespaces ► Sitecore ► Constants ► DefaultArchiveName
Name of the default archive for a database.
Declaration Syntax
C#
public const string DefaultArchiveName


DefaultAspNetSessionIdCookieName Field

DefaultAspNetSessionIdCookieName Field
Namespaces ► Sitecore ► Constants ► DefaultAspNetSessionIdCookieName
Default name of the ASP.NET session id cookie.
Declaration Syntax
C#
public const string DefaultAspNetSessionIdCookieName


DefaultCulture Field

DefaultCulture Field
Namespaces ► Sitecore ► Constants ► DefaultCulture
Name of the default culture.
Declaration Syntax
C#
public const string DefaultCulture


EveryoneRoleName Field

EveryoneRoleName Field
Namespaces ► Sitecore ► Constants ► EveryoneRoleName
Name of the 'everyone' role.
Declaration Syntax
C#
public const string EveryoneRoleName


GuidLength Field

GuidLength Field
Namespaces ► Sitecore ► Constants ► GuidLength
Length of a GUID.
Declaration Syntax
C#
public const int GuidLength


HttpRequestAbortedKey Field

HttpRequestAbortedKey Field
Namespaces ► Sitecore ► Constants ► HttpRequestAbortedKey
Items key for aborted http requests.
Declaration Syntax
C#
public const string HttpRequestAbortedKey


IconRequestPrefix Field

IconRequestPrefix Field
Namespaces ► Sitecore ► Constants ► IconRequestPrefix
Prefix of icon request URLs.
Declaration Syntax
C#
public const string IconRequestPrefix


IsoDateLength Field

IsoDateLength Field
Namespaces ► Sitecore ► Constants ► IsoDateLength
Length of an iso date.
Declaration Syntax
C#
public const int IsoDateLength


IsoDateTimeLength Field

IsoDateTimeLength Field
Namespaces ► Sitecore ► Constants ► IsoDateTimeLength
Length of an iso datetime.
Declaration Syntax
C#
public const int IsoDateTimeLength


IsoTimeLength Field

IsoTimeLength Field
Namespaces ► Sitecore ► Constants ► IsoTimeLength
Length of an iso time.
Declaration Syntax
C#
public const int IsoTimeLength


LinkPrefix Field

LinkPrefix Field
Namespaces ► Sitecore ► Constants ► LinkPrefix
Prefix of links.
Declaration Syntax
C#
public const string LinkPrefix


LinkTerminator Field

LinkTerminator Field
Namespaces ► Sitecore ► Constants ► LinkTerminator
Terminator of links
Declaration Syntax
C#
public const string LinkTerminator


MaxItemLevel Field

MaxItemLevel Field
Namespaces ► Sitecore ► Constants ► MaxItemLevel
Maximum length of an item name.
Declaration Syntax
C#
public const int MaxItemLevel


MediaLibraryPath Field

MediaLibraryPath Field
Namespaces ► Sitecore ► Constants ► MediaLibraryPath
Path to the media library.
Declaration Syntax
C#
public const string MediaLibraryPath


MediaRequestPrefix Field

MediaRequestPrefix Field
Namespaces ► Sitecore ► Constants ► MediaRequestPrefix
Prefix of media request URLs.
Declaration Syntax
C#
public const string MediaRequestPrefix


MinimalPageEditorRoleName Field

MinimalPageEditorRoleName Field
Namespaces ► Sitecore ► Constants ► MinimalPageEditorRoleName
Defines name of the Minimal Page Editor role.
Declaration Syntax
C#
public const string MinimalPageEditorRoleName


ModulesShellSiteName Field

ModulesShellSiteName Field
Namespaces ► Sitecore ► Constants ► ModulesShellSiteName
Name of the 'modules_shell' site.
Declaration Syntax
C#
public const string ModulesShellSiteName


NullDate Field

NullDate Field
Namespaces ► Sitecore ► Constants ► NullDate
Declaration Syntax
C#
public static DateTime NullDate


PerformanceCounterCategory Field

PerformanceCounterCategory Field
Namespaces ► Sitecore ► Constants ► PerformanceCounterCategory
General performance counter category name.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated", false)]
public const string PerformanceCounterCategory


PreviewDateCookieName Field

PreviewDateCookieName Field
Namespaces ► Sitecore ► Constants ► PreviewDateCookieName
Name of the Preview Date Cookie.
Declaration Syntax
C#
public const string PreviewDateCookieName


PreviewShellUserCookieName Field

PreviewShellUserCookieName Field
Namespaces ► Sitecore ► Constants ► PreviewShellUserCookieName
Name of the Preview Shell User Cookie.
Declaration Syntax
C#
public const string PreviewShellUserCookieName


PublishingSiteName Field

PublishingSiteName Field
Namespaces ► Sitecore ► Constants ► PublishingSiteName
Name of the site used when publishing.
Declaration Syntax
C#
public const string PublishingSiteName


PublishReplacerName Field

PublishReplacerName Field
Namespaces ► Sitecore ► Constants ► PublishReplacerName
Name of the 'publish' replacer.
Declaration Syntax
C#
public const string PublishReplacerName


RecycleBinArchiveName Field

RecycleBinArchiveName Field
Namespaces ► Sitecore ► Constants ► RecycleBinArchiveName
Name of the 'recyclebin' archive for a database.
Declaration Syntax
C#
public const string RecycleBinArchiveName


RequiredDatabaseVersion Field

RequiredDatabaseVersion Field
Namespaces ► Sitecore ► Constants ► RequiredDatabaseVersion
The currently required database version.
Declaration Syntax
C#
public const int RequiredDatabaseVersion


RestRequestPrefix Field

RestRequestPrefix Field
Namespaces ► Sitecore ► Constants ► RestRequestPrefix
Prefix of Rest request URLs.
Declaration Syntax
C#
public const string RestRequestPrefix


ShellSiteName Field

ShellSiteName Field
Namespaces ► Sitecore ► Constants ► ShellSiteName
Name of the 'shell' site.
Declaration Syntax
C#
public const string ShellSiteName


ShortGuidLength Field

ShortGuidLength Field
Namespaces ► Sitecore ► Constants ► ShortGuidLength
Length of a short GUID.
Declaration Syntax
C#
public const int ShortGuidLength


ShortIdLength Field

ShortIdLength Field
Namespaces ► Sitecore ► Constants ► ShortIdLength
Length of a ShortID.
Declaration Syntax
C#
public const int ShortIdLength


SitecoreClientUsersRole Field

SitecoreClientUsersRole Field
Namespaces ► Sitecore ► Constants ► SitecoreClientUsersRole
Name of the Sitecore Client Users role
Declaration Syntax
C#
public static string SitecoreClientUsersRole


SitecorePath Field

SitecorePath Field
Namespaces ► Sitecore ► Constants ► SitecorePath
Path to the root of the tree.
Declaration Syntax
C#
public const string SitecorePath


SitecorePipelinesOnKey Field

SitecorePipelinesOnKey Field
Namespaces ► Sitecore ► Constants ► SitecorePipelinesOnKey
Key name in Items collection of Context.Items
Declaration Syntax
C#
public const string SitecorePipelinesOnKey


SitecoreShellPath Field

SitecoreShellPath Field
Namespaces ► Sitecore ► Constants ► SitecoreShellPath
Path to the shell.
Declaration Syntax
C#
public const string SitecoreShellPath


StandardValuesItemName Field

StandardValuesItemName Field
Namespaces ► Sitecore ► Constants ► StandardValuesItemName
The name of the standard values item.
Declaration Syntax
C#
public const string StandardValuesItemName


XamlRequestPrefix Field

XamlRequestPrefix Field
Namespaces ► Sitecore ► Constants ► XamlRequestPrefix
Prefix of Xaml request URLs.
Declaration Syntax
C#
public const string XamlRequestPrefix


Context Class

Context Class
Namespaces ► Sitecore ► Context
Represents the current state for this request.
Represents the current state for this request.
Context class
Represents the current state for this request.
Declaration Syntax
C#
public class Context
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Context()()() | Initializes a new instance of the Context class
 | Access | Provides access to the Security/Workflow framework.
 | ClientData | Gets the client data.
 | ClientPage | Gets the current Sheer client page object.
 | ContentDatabase | Gets the current content database.
 | ContentLanguage | Gets the language used by the client to display content.
 | Culture | Gets a CultureInfo object that represents the current language.
 | Data | Gets the data.
 | Database | Gets the current database.
 | Device | Gets the current layout device.
 | Diagnostics | Provides access to the Diagnostics framework.
 | Domain | Gets the current security domain.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDeviceName()()() | Gets the name of the current device.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSiteName()()() | Gets the name of the current site.
 | GetTaskStack()()() | Gets the task stack.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserName()()() | Gets the name of the current user.
 | IsAdministrator | Gets a value that indicates if the current user is an administrator.
 | IsBackgroundThread | Gets a boolean that indicates if the current thread is a background thread.
 | IsLoggedIn | Gets a value indicating whether this instance is logged in.
 | IsUnitTesting | Reserved - for internal use
 | Item | Gets or sets the current item.
 | Items | Gets the items.
 | Job | Gets the current job.
 | Language | Gets the current language.
 | Logout()()() | Logs the current user out.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Notifications | Provides access to the Notification framework.
 | Page | Provides access to the current ASP.NET Page object.
 | ProxiesActive | Gets or sets a value indicating whether the proxies are active.
 | RawUrl | Gets a normalized copy of the raw URL of the current request.
 | Request | Provides access to the current ASP.NET HttpRequest object.
 | RequestID | Gets the request ID.
 | Resources | Provides access to the Resource framework.
 | Security | Provides access to the Security framework.
 | SetActiveSite(String) | Sets the active site.
 | SetLanguage(Language, Boolean) | Sets the current language.
 | SetTraceBuffer(StringBuilder) | Sets the active trace buffer.
 | Site | Represents the current site.
 | SkipSecurityInUnitTests | Reserved - for internal use
 | State | Gets the state.
 | Task | Gets current task (if any).
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace(String, array<Object>[]()[]) | Traces the specified message to the active trace buffer.
 | User | Gets the current user.
 | Workflow | Provides access to the current workflow framework.
Remarks

The Context object holds information about the current state such as current database, current language, current domain etc.

Many of these properties are resolved in the HttpRequest pipeline which determines the current site. The site usually specifies the current database, language and domain.

The current item is also resolved in the HttpRequest pipeline.

Remarks

The Context object holds information about the current state such as current database, current language, current domain etc.

Many of these properties are resolved in the HttpRequest pipeline which determines the current site. The site usually specifies the current database, language and domain.

The current item is also resolved in the HttpRequest pipeline.

Remarks

The Context object holds information about the current state such as current database, current language, current domain etc.

Many of these properties are resolved in the HttpRequest pipeline which determines the current site. The site usually specifies the current database, language and domain.

The current item is also resolved in the HttpRequest pipeline.

Inheritance Hierarchy
Object
Context


Context Constructor

Context Constructor
Namespaces ► Sitecore ► Context ► Context()()()
Initializes a new instance of the Context class
Declaration Syntax
C#
public Context()


Access Property

Access Property
Namespaces ► Sitecore ► Context ► Access
Provides access to the Security/Workflow framework.
Declaration Syntax
C#
public static AccessContext Access { get; }
Value
The access.


ClientData Property

ClientData Property
Namespaces ► Sitecore ► Context ► ClientData
Gets the client data.
Declaration Syntax
C#
public static ClientDataStore ClientData { get; }
Value
The client data.


ClientPage Property

ClientPage Property
Namespaces ► Sitecore ► Context ► ClientPage
Gets the current Sheer client page object.
Declaration Syntax
C#
public static ClientPage ClientPage { get; set; }
Value
The client page.
Remarks

If the current page does not inherit from the Sitecore.Web.UI.Sheer.ClientPage class, this property is null.

The ClientPage property provides access to the Sheer framework.


ContentDatabase Property

ContentDatabase Property
Namespaces ► Sitecore ► Context ► ContentDatabase
Gets the current content database.
Declaration Syntax
C#
public static Database ContentDatabase { get; }
Value
The content database.
Remarks

This property specifies which database is being edited by the client. Usually this is the Master database.

Normally this property is only accessed from within the client.

The value is specified in the Sites section in the web.config.


ContentLanguage Property

ContentLanguage Property
Namespaces ► Sitecore ► Context ► ContentLanguage
Gets the language used by the client to display content.
Declaration Syntax
C#
public static Language ContentLanguage { get; }
Value
The content language.
Remarks

This property specifies the language which the client displays content in by default.

Normally this property is only accessed from within the client.

The value is specified in the Sites section in the web.config.


Culture Property

Culture Property
Namespaces ► Sitecore ► Context ► Culture
Gets a CultureInfo object that represents the current language.
Declaration Syntax
C#
public static CultureInfo Culture { get; }
Value
The culture.


Data Property

Data Property
Namespaces ► Sitecore ► Context ► Data
Gets the data.
Declaration Syntax
C#
public static Context..::.ContextData Data { get; }
Value
The data.


Database Property

Database Property
Namespaces ► Sitecore ► Context ► Database
Gets the current database.
Declaration Syntax
C#
public static Database Database { get; set; }
Value
The database.
Remarks

This property returns the current database. For websites this is usually the Web database. In the client, this is the Core database.

The property is resolved in the HttpRequest pipeline and is obtained from the Sites section in the web.config.


Device Property

Device Property
Namespaces ► Sitecore ► Context ► Device
Gets the current layout device.
Declaration Syntax
C#
public static DeviceItem Device { get; set; }
Value
The device.
Remarks
The device is resolved in the HttpRequest pipeline by analyzing the incoming request and the items in /sitecore/layout/devices. The best match is selected as the current device.


Diagnostics Property

Diagnostics Property
Namespaces ► Sitecore ► Context ► Diagnostics
Provides access to the Diagnostics framework.
Declaration Syntax
C#
public static DiagnosticContext Diagnostics { get; }
Value
The diagnostics.


Domain Property

Domain Property
Namespaces ► Sitecore ► Context ► Domain
Gets the current security domain.
Declaration Syntax
C#
public static Domain Domain { get; }
Value
The domain.
Remarks
This property is resolved in the HttpRequest pipeline. The value is specified in the Sites section in the web.config.


GetDeviceName Method

GetDeviceName Method
Namespaces ► Sitecore ► Context ► GetDeviceName()()()
Gets the name of the current device.
Declaration Syntax
C#
public static string GetDeviceName()
Return Value
The String.


GetSiteName Method

GetSiteName Method
Namespaces ► Sitecore ► Context ► GetSiteName()()()
Gets the name of the current site.
Declaration Syntax
C#
public static string GetSiteName()
Return Value


GetTaskStack Method

GetTaskStack Method
Namespaces ► Sitecore ► Context ► GetTaskStack()()()
Gets the task stack.
Declaration Syntax
C#
public static Stack<TaskContext> GetTaskStack()
Return Value
The task stack.


GetUserName Method

GetUserName Method
Namespaces ► Sitecore ► Context ► GetUserName()()()
Gets the name of the current user.
Declaration Syntax
C#
public static string GetUserName()
Return Value
The String.


IsAdministrator Property

IsAdministrator Property
Namespaces ► Sitecore ► Context ► IsAdministrator
Gets a value that indicates if the current user is an administrator.
Declaration Syntax
C#
public static bool IsAdministrator { get; }
Value
true if this instance is administrator; otherwise, false.
Remarks
If this property is set, all privileges are granted.


IsBackgroundThread Property

IsBackgroundThread Property
Namespaces ► Sitecore ► Context ► IsBackgroundThread
Gets a boolean that indicates if the current thread is a background thread.
Declaration Syntax
C#
public static bool IsBackgroundThread { get; }
Value
True, if the current thread is a background thread, otherwise false.
Remarks

Sitecore may handle requests that are not part of a web request. Such requests are considered background or worker threads. An example is the scheduler which uses the API to perform certain tasks. When the scheduler executes, it does not run as a web request.

A developer may use this flag to take certain actions when the current thread is a background thread.

A background thread is defined by the current HttpContext is null:

CopyC#
HttpContext.Current == null


IsLoggedIn Property

IsLoggedIn Property
Namespaces ► Sitecore ► Context ► IsLoggedIn
Gets a value indicating whether this instance is logged in.
Declaration Syntax
C#
public static bool IsLoggedIn { get; }
Value
true if this instance is logged in; otherwise, false.


IsUnitTesting Property

IsUnitTesting Property
Namespaces ► Sitecore ► Context ► IsUnitTesting
Reserved - for internal use
Declaration Syntax
C#
public static bool IsUnitTesting { get; set; }


Item Property

Item Property
Namespaces ► Sitecore ► Context ► Item
Gets or sets the current item.
Declaration Syntax
C#
public static Item Item { get; set; }
Value
The Item identified by the "path" query string parameter, or null if the item was not found.
Remarks

The current item is the context item from which the web page is rendered. For instance if the current item points to the Home item, the web engine will render the layout associated with the Home item.

The current web item is by default obtained by parsing the Path argument on the request query string.

The scope of the value is page and it is stored in the Items variable sc_CurrentItem.

Examples
The following example redirects the page, if the current item has a specific name.
CopyC#
public void Redirect(string name, string url) {
Item item = State.CurrentItem;
if (item.Name == name) {
Response.Redirect(url);
}
}


Items Property

Items Property
Namespaces ► Sitecore ► Context ► Items
Gets the items.
Declaration Syntax
C#
public static ItemsContext Items { get; }
Value
The items.


Job Property

Job Property
Namespaces ► Sitecore ► Context ► Job
Gets the current job.
Declaration Syntax
C#
public static Job Job { get; set; }
Value
The job.
Remarks
If a background job is running, this property points to it.


Language Property

Language Property
Namespaces ► Sitecore ► Context ► Language
Gets the current language.
Declaration Syntax
C#
public static Language Language { get; set; }
Value
The language.


Logout Method

Logout Method
Namespaces ► Sitecore ► Context ► Logout()()()
Logs the current user out.
Declaration Syntax
C#
public static void Logout()


Notifications Property

Notifications Property
Namespaces ► Sitecore ► Context ► Notifications
Provides access to the Notification framework.
Declaration Syntax
C#
public static NotificationContext Notifications { get; }
Value
The notifications.


Page Property

Page Property
Namespaces ► Sitecore ► Context ► Page
Provides access to the current ASP.NET Page object.
Declaration Syntax
C#
public static PageContext Page { get; }
Value
The page.


ProxiesActive Property

ProxiesActive Property
Namespaces ► Sitecore ► Context ► ProxiesActive
Gets or sets a value indicating whether the proxies are active.
Declaration Syntax
C#
public static bool ProxiesActive { get; set; }
Value
true if the proxies are active; otherwise, false.


RawUrl Property

RawUrl Property
Namespaces ► Sitecore ► Context ► RawUrl
Gets a normalized copy of the raw URL of the current request.
Declaration Syntax
C#
public static string RawUrl { get; }
Value
The raw URL.
See Also
NormalizeUrl(String)


Request Property

Request Property
Namespaces ► Sitecore ► Context ► Request
Provides access to the current ASP.NET HttpRequest object.
Declaration Syntax
C#
public static SiteRequest Request { get; }
Value
The request.


RequestID Property

RequestID Property
Namespaces ► Sitecore ► Context ► RequestID
Gets the request ID.
Declaration Syntax
C#
public static string RequestID { get; }
Value
The request ID.


Resources Property

Resources Property
Namespaces ► Sitecore ► Context ► Resources
Provides access to the Resource framework.
Declaration Syntax
C#
public static ResourceContext Resources { get; }
Value
The resources.


Security Property

Security Property
Namespaces ► Sitecore ► Context ► Security
Provides access to the Security framework.
Declaration Syntax
C#
public static SecurityContext Security { get; }
Value
The security.


SetActiveSite Method (siteName)

SetActiveSite Method (siteName)
Namespaces ► Sitecore ► Context ► SetActiveSite(String)
Sets the active site.
Declaration Syntax
C#
public static void SetActiveSite(
    string siteName
)
Parameters
siteName (String)
Name of the site.
Remarks

The current site is normally determined by the HttpRequest module. However if the API is instantiated outside a Http request, it is possible to specify the current site using this methods.

This method is rarely used and should be used with caution.

Situations where this method can be used are: an event from a FileWatcher object or a background thread.


SetLanguage Method (language, persistent)

SetLanguage Method (language, persistent)
Namespaces ► Sitecore ► Context ► SetLanguage(Language, Boolean)
Sets the current language.
Declaration Syntax
C#
public static void SetLanguage(
    Language language,
    bool persistent
)
Parameters
language (Language)
The language.
persistent (Boolean)
if set to true, the value will be persisted (in a cookie).


SetTraceBuffer Method (buffer)

SetTraceBuffer Method (buffer)
Namespaces ► Sitecore ► Context ► SetTraceBuffer(StringBuilder)
Sets the active trace buffer.
Declaration Syntax
C#
public static void SetTraceBuffer(
    StringBuilder buffer
)
Parameters
buffer (StringBuilder)
The buffer.


Site Property

Site Property
Namespaces ► Sitecore ► Context ► Site
Represents the current site.
Declaration Syntax
C#
public static SiteContext Site { get; set; }
Value
The site.
Remarks

The Site object contains information about the current site, e.g. database, language and domain.

A site is configured in the Sites section in web.config.


SkipSecurityInUnitTests Property

SkipSecurityInUnitTests Property
Namespaces ► Sitecore ► Context ► SkipSecurityInUnitTests
Reserved - for internal use
Declaration Syntax
C#
public static bool SkipSecurityInUnitTests { get; set; }


State Property

State Property
Namespaces ► Sitecore ► Context ► State
Gets the state.
Declaration Syntax
C#
public static StateContext State { get; }
Value
The state.


Task Property

Task Property
Namespaces ► Sitecore ► Context ► Task
Gets current task (if any).
Declaration Syntax
C#
public static TaskContext Task { get; }
Value
The task (or null).


Trace Method (message, parameters)

Trace Method (message, parameters)
Namespaces ► Sitecore ► Context ► Trace(String, array<Object>[]()[])
Traces the specified message to the active trace buffer.
Declaration Syntax
C#
public static void Trace(
    string message,
    params Object[] parameters
)
Parameters
message (String)
The message.
parameters (array< Object >[]()[])
The parameters (if the message is a format string).


User Property

User Property
Namespaces ► Sitecore ► Context ► User
Gets the current user.
Declaration Syntax
C#
public static User User { get; }
Value
The user.
Remarks
The current user is either the logged in user, a user that has been switched to or the Anonymous user, if no other user has been specified.


Workflow Property

Workflow Property
Namespaces ► Sitecore ► Context ► Workflow
Provides access to the current workflow framework.
Declaration Syntax
C#
public static WorkflowContext Workflow { get; }
Value
The workflow.


Context.ContextData Class

Context..::.ContextData Class
Namespaces ► Sitecore ► Context ► Context..::.ContextData
Represents the context data.
Declaration Syntax
C#
public class ContextData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Context..::.ContextData()()() | Initializes a new instance of the Context..::.ContextData class.
 | Access | Gets the access.
 | Database | Gets or sets the database.
 | Device | Gets or sets the device.
 | Diagnostics | Gets the diagnostics.
 | Domain | Gets the domain.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePathLanguage | Gets or sets the language that was embedded in the file path of the current request.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAdministrator | Gets a value indicating whether if the current user is an administrator.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RawUrl | Gets or sets the raw URL.
 | RequestID | Gets the request ID.
 | Security | Gets the security.
 | Site | Gets or sets the site.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | User | Gets or sets the user.
 | Workflow | Gets the workflow.
Inheritance Hierarchy
Object
Context..::.ContextData


Context.ContextData Constructor

Context..::.ContextData Constructor
Namespaces ► Sitecore ► Context..::.ContextData ► Context..::.ContextData()()()
Initializes a new instance of the Context..::.ContextData class.
Declaration Syntax
C#
public ContextData()


Access Property

Access Property
Namespaces ► Sitecore ► Context..::.ContextData ► Access
Gets the access.
Declaration Syntax
C#
public AccessContext Access { get; }
Value
The access.


Database Property

Database Property
Namespaces ► Sitecore ► Context..::.ContextData ► Database
Gets or sets the database.
Declaration Syntax
C#
public Database Database { get; set; }
Value
The database.


Device Property

Device Property
Namespaces ► Sitecore ► Context..::.ContextData ► Device
Gets or sets the device.
Declaration Syntax
C#
public DeviceItem Device { get; set; }
Value
The device.


Diagnostics Property

Diagnostics Property
Namespaces ► Sitecore ► Context..::.ContextData ► Diagnostics
Gets the diagnostics.
Declaration Syntax
C#
public DiagnosticContext Diagnostics { get; }
Value
The diagnostics.


Domain Property

Domain Property
Namespaces ► Sitecore ► Context..::.ContextData ► Domain
Gets the domain.
Declaration Syntax
C#
public Domain Domain { get; }
Value
The domain.


FilePathLanguage Property

FilePathLanguage Property
Namespaces ► Sitecore ► Context..::.ContextData ► FilePathLanguage
Gets or sets the language that was embedded in the file path of the current request.
Declaration Syntax
C#
public Language FilePathLanguage { get; set; }
Value
The language (might be null, if no language was embedded or the parser has not been run).
Remarks
The language is parsed out by the StripLanguage processor.


IsAdministrator Property

IsAdministrator Property
Namespaces ► Sitecore ► Context..::.ContextData ► IsAdministrator
Gets a value indicating whether if the current user is an administrator.
Declaration Syntax
C#
public bool IsAdministrator { get; }
Value
true if the current user is administrator; otherwise, false.
Remarks
If this property is set, all privileges are granted.


RawUrl Property

RawUrl Property
Namespaces ► Sitecore ► Context..::.ContextData ► RawUrl
Gets or sets the raw URL.
Declaration Syntax
C#
public string RawUrl { get; set; }
Value
The raw URL.


RequestID Property

RequestID Property
Namespaces ► Sitecore ► Context..::.ContextData ► RequestID
Gets the request ID.
Declaration Syntax
C#
public string RequestID { get; }
Value
The request ID.


Security Property

Security Property
Namespaces ► Sitecore ► Context..::.ContextData ► Security
Gets the security.
Declaration Syntax
C#
public SecurityContext Security { get; }
Value
The security.


Site Property

Site Property
Namespaces ► Sitecore ► Context..::.ContextData ► Site
Gets or sets the site.
Declaration Syntax
C#
public SiteContext Site { get; set; }
Value
The site object.


User Property

User Property
Namespaces ► Sitecore ► Context..::.ContextData ► User
Gets or sets the user.
Declaration Syntax
C#
public User User { get; set; }
Value
The user object.


Workflow Property

Workflow Property
Namespaces ► Sitecore ► Context..::.ContextData ► Workflow
Gets the workflow.
Declaration Syntax
C#
public WorkflowContext Workflow { get; }
Value
The workflow.


Context.PageDesigner Class

Context..::.PageDesigner Class
Namespaces ► Sitecore ► Context ► Context..::.PageDesigner
Represents the Page Designer.
Declaration Syntax
C#
public static class PageDesigner
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsDesigning | Gets a value indicating whether this instance is designing.
 | IsLayouting | Gets a value indicating whether this instance is layouting.
 | IsLayoutViewing | Gets a value indicating whether this instance is viewing.
 | LayoutHandle | Gets the handle.
 | PageDesignerHandle | Gets the handle.
Inheritance Hierarchy
Object
Context..::.PageDesigner


IsDesigning Property

IsDesigning Property
Namespaces ► Sitecore ► Context..::.PageDesigner ► IsDesigning
Gets a value indicating whether this instance is designing.
Declaration Syntax
C#
public static bool IsDesigning { get; }
Value
true if this instance is designing; otherwise, false.


IsLayouting Property

IsLayouting Property
Namespaces ► Sitecore ► Context..::.PageDesigner ► IsLayouting
Gets a value indicating whether this instance is layouting.
Declaration Syntax
C#
public static bool IsLayouting { get; }
Value
true if this instance is layouting; otherwise, false.


IsLayoutViewing Property

IsLayoutViewing Property
Namespaces ► Sitecore ► Context..::.PageDesigner ► IsLayoutViewing
Gets a value indicating whether this instance is viewing.
Declaration Syntax
C#
public static bool IsLayoutViewing { get; }
Value
true if this instance is viewing; otherwise, false.


LayoutHandle Property

LayoutHandle Property
Namespaces ► Sitecore ► Context..::.PageDesigner ► LayoutHandle
Gets the handle.
Declaration Syntax
C#
public static string LayoutHandle { get; }
Value
The handle.


PageDesignerHandle Property

PageDesignerHandle Property
Namespaces ► Sitecore ► Context..::.PageDesigner ► PageDesignerHandle
Gets the handle.
Declaration Syntax
C#
public static string PageDesignerHandle { get; }
Value
The handle.


Context.PageMode Class

Context..::.PageMode Class
Namespaces ► Sitecore ► Context ► Context..::.PageMode
Retrieves information about the current page mode.
Declaration Syntax
C#
public static class PageMode
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsDebugging | Gets a value indicating whether this instance is debugging.
 | IsNormal | Gets a value indicating whether the page mode is normal.
 | IsPageEditor | Gets a value indicating whether this instance is page editor.
 | IsPageEditorClassic | Gets a value indicating whether this instance is page editor classic.
 | IsPageEditorDesigning | Gets a value indicating whether this instance is page designer.
 | IsPageEditorEditing | Gets a value indicating whether this instance is page editor editing.
 | IsPageEditorNavigating | Gets a value indicating whether this instance is page editor navigating.
 | IsPreview | Gets a value indicating whether this instance is preview.
 | IsProfiling | Gets a value indicating whether this instance is profiling.
Inheritance Hierarchy
Object
Context..::.PageMode


IsDebugging Property

IsDebugging Property
Namespaces ► Sitecore ► Context..::.PageMode ► IsDebugging
Gets a value indicating whether this instance is debugging.
Declaration Syntax
C#
public static bool IsDebugging { get; }
Value
true if this instance is debugging; otherwise, false.


IsNormal Property

IsNormal Property
Namespaces ► Sitecore ► Context..::.PageMode ► IsNormal
Gets a value indicating whether the page mode is normal.
Declaration Syntax
C#
public static bool IsNormal { get; }
Value
true if the page mode is normal; otherwise, false.


IsPageEditor Property

IsPageEditor Property
Namespaces ► Sitecore ► Context..::.PageMode ► IsPageEditor
Gets a value indicating whether this instance is page editor.
Declaration Syntax
C#
public static bool IsPageEditor { get; }
Value
true if this instance is page editor; otherwise, false.


IsPageEditorClassic Property

IsPageEditorClassic Property
Namespaces ► Sitecore ► Context..::.PageMode ► IsPageEditorClassic
Gets a value indicating whether this instance is page editor classic.
Declaration Syntax
C#
public static bool IsPageEditorClassic { get; }
Value
true if this instance is page editor classic; otherwise, false.


IsPageEditorDesigning Property

IsPageEditorDesigning Property
Namespaces ► Sitecore ► Context..::.PageMode ► IsPageEditorDesigning
Gets a value indicating whether this instance is page designer.
Declaration Syntax
C#
public static bool IsPageEditorDesigning { get; }
Value
true if this instance is page designer; otherwise, false.


IsPageEditorEditing Property

IsPageEditorEditing Property
Namespaces ► Sitecore ► Context..::.PageMode ► IsPageEditorEditing
Gets a value indicating whether this instance is page editor editing.
Declaration Syntax
C#
public static bool IsPageEditorEditing { get; }
Value
true if this instance is page editor editing; otherwise, false.


IsPageEditorNavigating Property

IsPageEditorNavigating Property
Namespaces ► Sitecore ► Context..::.PageMode ► IsPageEditorNavigating
Gets a value indicating whether this instance is page editor navigating.
Declaration Syntax
C#
public static bool IsPageEditorNavigating { get; }
Value
true if this instance is page editor navigating; otherwise, false.


IsPreview Property

IsPreview Property
Namespaces ► Sitecore ► Context..::.PageMode ► IsPreview
Gets a value indicating whether this instance is preview.
Declaration Syntax
C#
public static bool IsPreview { get; }
Value
true if this instance is preview; otherwise, false.


IsProfiling Property

IsProfiling Property
Namespaces ► Sitecore ► Context..::.PageMode ► IsProfiling
Gets a value indicating whether this instance is profiling.
Declaration Syntax
C#
public static bool IsProfiling { get; }
Value
true if this instance is profiling; otherwise, false.


Convert Class

Convert Class
Namespaces ► Sitecore ► Convert
Provides conversion utility functions for a number of types.
Declaration Syntax
C#
public static class Convert
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Base64ToHashtable(String) | Converts a Base64 encoded string to a Hashtable.
 | Base64ToObject(String) | Converts a Base64 encoded string to an object.
 | HashtableToBase64(Hashtable) | Converts a Hashtable to a Base64 encoded string.
 | ObjectToBase64(Object) | Converters an object to a Base64 encoded string.
Inheritance Hierarchy
Object
Convert


Base64ToHashtable Method (data)

Base64ToHashtable Method (data)
Namespaces ► Sitecore ► Convert ► Base64ToHashtable(String)
Converts a Base64 encoded string to a Hashtable.
Declaration Syntax
C#
public static Hashtable Base64ToHashtable(
    string data
)
Parameters
data (String)
The data.
Return Value
The to hashtable.


Base64ToObject Method (data)

Base64ToObject Method (data)
Namespaces ► Sitecore ► Convert ► Base64ToObject(String)
Converts a Base64 encoded string to an object.
Declaration Syntax
C#
public static Object Base64ToObject(
    string data
)
Parameters
data (String)
The data.
Return Value
The to object.


HashtableToBase64 Method (data)

HashtableToBase64 Method (data)
Namespaces ► Sitecore ► Convert ► HashtableToBase64(Hashtable)
Converts a Hashtable to a Base64 encoded string.
Declaration Syntax
C#
public static string HashtableToBase64(
    Hashtable data
)
Parameters
data (Hashtable)
The data.
Return Value
The to base64.


ObjectToBase64 Method (data)

ObjectToBase64 Method (data)
Namespaces ► Sitecore ► Convert ► ObjectToBase64(Object)
Converters an object to a Base64 encoded string.
Declaration Syntax
C#
public static string ObjectToBase64(
    Object data
)
Parameters
data (Object)
The data.
Return Value
The to base64.


DateUtil Class

DateUtil Class
Namespaces ► Sitecore ► DateUtil
Implements a utility class for manipulating dates.
Declaration Syntax
C#
public sealed class DateUtil
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DateUtil()()() | Initializes a new instance of the DateUtil class
 | DateTimeToMilitary(DateTime) | Converts a DateTime class to an military formatted date/time string.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatIsoDate(String) | Formats an ISO formatted date/time string to long date/time string.
 | FormatIsoDate(String, String) | Formats an ISO formatted date/time string using a specified format.
 | FormatLongDateTime(DateTime) | Formats a date in a long format.
 | FormatLongDateTime(DateTime, CultureInfo) | Formats a date in a long format.
 | FormatLongTime(TimeSpan) | Formats a time span to a string showing hours, minutes and seconds.
 | FormatShortDateTime(DateTime) | Formats a date in a short format.
 | FormatShortDateTime(DateTime, CultureInfo) | Formats a date in a short format.
 | FormatShortTime(TimeSpan) | Formats a time span to a string showing hours and minutes.
 | FormatTime(TimeSpan, String, CultureInfo) | Formats the time.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetShortIsoDateTime(DateTime) | Gets the short iso date time.
 | GetShortIsoDateTime(String) | Gets the short iso date time.
 | GetTimeSpanFromMilliseconds(Double) | Gets a time span from milliseconds.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsIsoDate(String) | Determines if a string is an Iso date.
 | IsoDateToDateTime(String) | Converts an ISO formatted date/time string to a DateTime class.
 | IsoDateToDateTime(String, DateTime) | Converts an ISO formatted date/time string to a DateTime class.
 | IsoNow | Gets the current time formatted as ISO date/time string.
 | IsoNowDate | Gets the current date formatted as ISO date string.
 | IsoNowTime | Gets the current time formatted as ISO time string.
 | IsoNowWithTicks | Gets the current time formatted as ISO date/time string with ticks appended.
 | Max(DateTime, DateTime) | Gets the largest of the specified date/times.
 | Max(array<DateTime>[]()[]) | Gets the largest of the specified date/times.
 | Max(TimeSpan, TimeSpan) | Gets the largest of the specified time spans.
 | Max(array<TimeSpan>[]()[]) | Gets the largest of the specified time spans.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Min(DateTime, DateTime) | Gets the smallest of the specified date/times.
 | Min(array<DateTime>[]()[]) | Gets the smallest of the specified date/times.
 | Min(TimeSpan, TimeSpan) | Gets the smallest of the specified time spans.
 | Min(array<TimeSpan>[]()[]) | Gets the smallest of the specified time spans.
 | ParseDateTime(String, DateTime) | Parses a string into a DateTime structure.
 | ParseDateTime(String, DateTime, CultureInfo) | Parses a string into a DateTime structure.
 | ParseTimeSpan(String) | Parses a time string representing a time span.
 | ParseTimeSpan(String, TimeSpan) | Parses a time string representing a time span.
 | ParseTimeSpan(String, TimeSpan, CultureInfo) | Parses a time string representing a time span.
 | TicksPerMillisecond | Gets the number of ticks per millisecond.
 | TimeSpanToIsoTime(TimeSpan) | Converts a TimeSpan into a Iso date string.
 | ToIsoDate(DateTime) | Converts a DateTime class to an ISO formatted date/time string.
 | ToIsoDate(DateTime, Boolean) | Converts a DateTime class to an ISO formatted date/time string.
 | ToIsoTime(DateTime) | Converts a DateTime class to an ISO formatted time string.
 | ToIsoTime(DateTime, Boolean) | Converts a DateTime class to an ISO formatted date/time string.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
The DateUtil operates on ISO formatted date/times for the most part. An ISO formatted date/time string is formatted as yyyyMMddTHHmmss.
Inheritance Hierarchy
Object
DateUtil
See Also
FileUtil
MainUtil
HtmlUtil
StringUtil
WebUtil
XmlUtil


DateUtil Constructor

DateUtil Constructor
Namespaces ► Sitecore ► DateUtil ► DateUtil()()()
Initializes a new instance of the DateUtil class
Declaration Syntax
C#
public DateUtil()


DateTimeToMilitary Method (datetime)

DateTimeToMilitary Method (datetime)
Namespaces ► Sitecore ► DateUtil ► DateTimeToMilitary(DateTime)
Converts a DateTime class to an military formatted date/time string.
Declaration Syntax
C#
public static string DateTimeToMilitary(
    DateTime datetime
)
Parameters
datetime (DateTime)
A DateTime class to be formatted.
Return Value
The military formatted date/time equivalent of the DateTime class.
Remarks
The date/time string is formatted as "yyyyMMddTHHmmss".
Examples
The following example returns Now formatted as an military date.
CopyC#
return DateUtil.DateTimeToMilitary(DateTime.Now);


FormatIsoDate Method

FormatIsoDate Method
Namespaces ► Sitecore ► DateUtil ► FormatIsoDate()()()
Members
Icon | Member | Description
 | FormatIsoDate(String) | Formats an ISO formatted date/time string to long date/time string.
 | FormatIsoDate(String, String) | Formats an ISO formatted date/time string using a specified format.


FormatIsoDate Method (isoDate)

FormatIsoDate Method (isoDate)
Namespaces ► Sitecore ► DateUtil ► FormatIsoDate(String)
Formats an ISO formatted date/time string to long date/time string.
Declaration Syntax
C#
public static string FormatIsoDate(
    string isoDate
)
Parameters
isoDate (String)
An ISO formatted date/time string.
Return Value
The date/time in equivalent culture dependant long format.
Remarks
If the time part is omitted from the input parameter, only the date part is formatted.

The date/time string is formatted as "yyyyMMddTHHmmss".

Examples
The following example returns Now formatted as a long ISO date.
CopyC#
string isoNow = DateUtil.IsoNow;
return DateUtil.FormatIsoDate(isoNow);


FormatIsoDate Method (isoDate, format)

FormatIsoDate Method (isoDate, format)
Namespaces ► Sitecore ► DateUtil ► FormatIsoDate(String, String)
Formats an ISO formatted date/time string using a specified format.
Declaration Syntax
C#
public static string FormatIsoDate(
    string isoDate,
    string format
)
Parameters
isoDate (String)
A ISO formatted date/time string.
format (String)
The target format.
Return Value
The formatted date/time. If the date/time string is not valied, blank is returned.
Remarks
The format is specified using .NET formatting codes. See here for more information.

The date/time string is formatted as "yyyyMMddTHHmmss".

Examples
The following example returns Now formatted as a short date pattern.
CopyC#
string isoNow = DateUtil.DateTimeToIsoDate(DateTime.Now);
return DateUtil.FormatIsoDate(isoNow, "d");


FormatLongDateTime Method

FormatLongDateTime Method
Namespaces ► Sitecore ► DateUtil ► FormatLongDateTime()()()
Members
Icon | Member | Description
 | FormatLongDateTime(DateTime) | Formats a date in a long format.
 | FormatLongDateTime(DateTime, CultureInfo) | Formats a date in a long format.


FormatLongDateTime Method (dateTime)

FormatLongDateTime Method (dateTime)
Namespaces ► Sitecore ► DateUtil ► FormatLongDateTime(DateTime)
Formats a date in a long format.
Declaration Syntax
C#
public static string FormatLongDateTime(
    DateTime dateTime
)
Parameters
dateTime (DateTime)
The date time.
Return Value


FormatLongDateTime Method (dateTime, culture)

FormatLongDateTime Method (dateTime, culture)
Namespaces ► Sitecore ► DateUtil ► FormatLongDateTime(DateTime, CultureInfo)
Formats a date in a long format.
Declaration Syntax
C#
public static string FormatLongDateTime(
    DateTime dateTime,
    CultureInfo culture
)
Parameters
dateTime (DateTime)
The date time.
culture (CultureInfo)
The culture.
Return Value


FormatLongTime Method (time)

FormatLongTime Method (time)
Namespaces ► Sitecore ► DateUtil ► FormatLongTime(TimeSpan)
Formats a time span to a string showing hours, minutes and seconds.
Declaration Syntax
C#
public static string FormatLongTime(
    TimeSpan time
)
Parameters
time (TimeSpan)
The time.
Return Value


FormatShortDateTime Method

FormatShortDateTime Method
Namespaces ► Sitecore ► DateUtil ► FormatShortDateTime()()()
Members
Icon | Member | Description
 | FormatShortDateTime(DateTime) | Formats a date in a short format.
 | FormatShortDateTime(DateTime, CultureInfo) | Formats a date in a short format.


FormatShortDateTime Method (dateTime)

FormatShortDateTime Method (dateTime)
Namespaces ► Sitecore ► DateUtil ► FormatShortDateTime(DateTime)
Formats a date in a short format.
Declaration Syntax
C#
public static string FormatShortDateTime(
    DateTime dateTime
)
Parameters
dateTime (DateTime)
The date time.
Return Value


FormatShortDateTime Method (dateTime, culture)

FormatShortDateTime Method (dateTime, culture)
Namespaces ► Sitecore ► DateUtil ► FormatShortDateTime(DateTime, CultureInfo)
Formats a date in a short format.
Declaration Syntax
C#
public static string FormatShortDateTime(
    DateTime dateTime,
    CultureInfo culture
)
Parameters
dateTime (DateTime)
The date time.
culture (CultureInfo)
The culture.
Return Value


FormatShortTime Method (time)

FormatShortTime Method (time)
Namespaces ► Sitecore ► DateUtil ► FormatShortTime(TimeSpan)
Formats a time span to a string showing hours and minutes.
Declaration Syntax
C#
public static string FormatShortTime(
    TimeSpan time
)
Parameters
time (TimeSpan)
The time.
Return Value


FormatTime Method (time, format, culture)

FormatTime Method (time, format, culture)
Namespaces ► Sitecore ► DateUtil ► FormatTime(TimeSpan, String, CultureInfo)
Formats the time.
Declaration Syntax
C#
public static string FormatTime(
    TimeSpan time,
    string format,
    CultureInfo culture
)
Parameters
time (TimeSpan)
The time.
format (String)
The format.
culture (CultureInfo)
The culture.
Return Value
The time.


GetShortIsoDateTime Method

GetShortIsoDateTime Method
Namespaces ► Sitecore ► DateUtil ► GetShortIsoDateTime()()()
Members
Icon | Member | Description
 | GetShortIsoDateTime(DateTime) | Gets the short iso date time.
 | GetShortIsoDateTime(String) | Gets the short iso date time.


GetShortIsoDateTime Method (date)

GetShortIsoDateTime Method (date)
Namespaces ► Sitecore ► DateUtil ► GetShortIsoDateTime(DateTime)
Gets the short iso date time.
Declaration Syntax
C#
public static string GetShortIsoDateTime(
    DateTime date
)
Parameters
date (DateTime)
The date.
Return Value


GetShortIsoDateTime Method (isoDateTime)

GetShortIsoDateTime Method (isoDateTime)
Namespaces ► Sitecore ► DateUtil ► GetShortIsoDateTime(String)
Gets the short iso date time.
Declaration Syntax
C#
public static string GetShortIsoDateTime(
    string isoDateTime
)
Parameters
isoDateTime (String)
The iso date time.
Return Value


GetTimeSpanFromMilliseconds Method (milliseconds)

GetTimeSpanFromMilliseconds Method (milliseconds)
Namespaces ► Sitecore ► DateUtil ► GetTimeSpanFromMilliseconds(Double)
Gets a time span from milliseconds.
Declaration Syntax
C#
public static TimeSpan GetTimeSpanFromMilliseconds(
    double milliseconds
)
Parameters
milliseconds (Double)
The milliseconds.
Return Value


IsIsoDate Method (value)

IsIsoDate Method (value)
Namespaces ► Sitecore ► DateUtil ► IsIsoDate(String)
Determines if a string is an Iso date.
Declaration Syntax
C#
public static bool IsIsoDate(
    string value
)
Parameters
value (String)
The value.
Return Value
true if [is iso date] [the specified value]; otherwise, false.


IsoDateToDateTime Method

IsoDateToDateTime Method
Namespaces ► Sitecore ► DateUtil ► IsoDateToDateTime()()()
Members
Icon | Member | Description
 | IsoDateToDateTime(String) | Converts an ISO formatted date/time string to a DateTime class.
 | IsoDateToDateTime(String, DateTime) | Converts an ISO formatted date/time string to a DateTime class.


IsoDateToDateTime Method (isoDate)

IsoDateToDateTime Method (isoDate)
Namespaces ► Sitecore ► DateUtil ► IsoDateToDateTime(String)
Converts an ISO formatted date/time string to a DateTime class.
Declaration Syntax
C#
public static DateTime IsoDateToDateTime(
    string isoDate
)
Parameters
isoDate (String)
An ISO formatted date/time string.
Return Value
The DateTime class equivalent of the date/time string. If the date/time is not valid, DateTime.MinValue is returned.
Remarks
The date/time string is formatted as "yyyyMMddTHHmmss".
Examples
The following example converts an ISO formatted date/time string to a DateTime class.
CopyC#
string isoNow = DateUtil.IsoNow;
DateTime now = DateUtil.IsoDateToDateTime(isoNow);


IsoDateToDateTime Method (isoDate, defaultValue)

IsoDateToDateTime Method (isoDate, defaultValue)
Namespaces ► Sitecore ► DateUtil ► IsoDateToDateTime(String, DateTime)
Converts an ISO formatted date/time string to a DateTime class.
Declaration Syntax
C#
public static DateTime IsoDateToDateTime(
    string isoDate,
    DateTime defaultValue
)
Parameters
isoDate (String)
An ISO formatted date/time string.
defaultValue (DateTime)
Default value to use if isoDate can not be converted to a date/time.
Return Value
The DateTime class equivalent of the date/time string. If the date/time is not valid, DateTime.MinValue is returned.
Remarks
The date/time string is formatted as "yyyyMMddTHHmmss".
Examples
The following example converts an ISO formatted date/time string to a DateTime class.
CopyC#
string isoNow = DateUtil.IsoNow;
DateTime now = DateUtil.IsoDateToDateTime(isoNow);


IsoNow Property

IsoNow Property
Namespaces ► Sitecore ► DateUtil ► IsoNow
Gets the current time formatted as ISO date/time string.
Declaration Syntax
C#
public static string IsoNow { get; }
Value
Now formatted as a ISO formatted date/time string.
Remarks
The date/time string is formatted as "yyyyMMddTHHmmss".
Examples
The following example sets isoNow to now in ISO format.
CopyC#
string isoNow = DateUtil.IsoNow;


IsoNowDate Property

IsoNowDate Property
Namespaces ► Sitecore ► DateUtil ► IsoNowDate
Gets the current date formatted as ISO date string.
Declaration Syntax
C#
public static string IsoNowDate { get; }
Value
Now formatted as a ISO formatted date string.
Remarks
The date string is formatted as "yyyyMMdd".
Examples
The following example sets isoNow to the current date in ISO format.
CopyC#
string isoNow = DateUtil.IsoNowDate;


IsoNowTime Property

IsoNowTime Property
Namespaces ► Sitecore ► DateUtil ► IsoNowTime
Gets the current time formatted as ISO time string.
Declaration Syntax
C#
public static string IsoNowTime { get; }
Value
Now formatted as a ISO formatted time string.
Remarks
The time string is formatted as "HHmmss".
Examples
The following example sets isoNow to the ciurrent time in ISO format.
CopyC#
string isoNow = DateUtil.IsoNowTime;


IsoNowWithTicks Property

IsoNowWithTicks Property
Namespaces ► Sitecore ► DateUtil ► IsoNowWithTicks
Gets the current time formatted as ISO date/time string with ticks appended.
Declaration Syntax
C#
public static string IsoNowWithTicks { get; }
Value
Now formatted as a ISO formatted date/time string.
Remarks
The date/time string is formatted as "yyyyMMddTHHmmss" and ":{ticks}" is appended.
Examples
The following example sets isoNow to now in ISO format.
CopyC#
string isoNow = DateUtil.IsoNowWithTicks;  // might return 20012008T102817:2382193728213


Max Method

Max Method
Namespaces ► Sitecore ► DateUtil ► Max()()()
Members
Icon | Member | Description
 | Max(DateTime, DateTime) | Gets the largest of the specified date/times.
 | Max(array<DateTime>[]()[]) | Gets the largest of the specified date/times.
 | Max(TimeSpan, TimeSpan) | Gets the largest of the specified time spans.
 | Max(array<TimeSpan>[]()[]) | Gets the largest of the specified time spans.


Max Method (dateTime1, dateTime2)

Max Method (dateTime1, dateTime2)
Namespaces ► Sitecore ► DateUtil ► Max(DateTime, DateTime)
Gets the largest of the specified date/times.
Declaration Syntax
C#
public static DateTime Max(
    DateTime dateTime1,
    DateTime dateTime2
)
Parameters
dateTime1 (DateTime)
The date time1.
dateTime2 (DateTime)
The date time2.
Return Value


Max Method (dateTimes)

Max Method (dateTimes)
Namespaces ► Sitecore ► DateUtil ► Max(array<DateTime>[]()[])
Gets the largest of the specified date/times.
Declaration Syntax
C#
public static DateTime Max(
    params DateTime[] dateTimes
)
Parameters
dateTimes (array< DateTime >[]()[])
The date times.
Return Value


Max Method (time1, time2)

Max Method (time1, time2)
Namespaces ► Sitecore ► DateUtil ► Max(TimeSpan, TimeSpan)
Gets the largest of the specified time spans.
Declaration Syntax
C#
public static TimeSpan Max(
    TimeSpan time1,
    TimeSpan time2
)
Parameters
time1 (TimeSpan)
The time1.
time2 (TimeSpan)
The time2.
Return Value


Max Method (times)

Max Method (times)
Namespaces ► Sitecore ► DateUtil ► Max(array<TimeSpan>[]()[])
Gets the largest of the specified time spans.
Declaration Syntax
C#
public static TimeSpan Max(
    params TimeSpan[] times
)
Parameters
times (array< TimeSpan >[]()[])
The times.
Return Value


Min Method

Min Method
Namespaces ► Sitecore ► DateUtil ► Min()()()
Members
Icon | Member | Description
 | Min(DateTime, DateTime) | Gets the smallest of the specified date/times.
 | Min(array<DateTime>[]()[]) | Gets the smallest of the specified date/times.
 | Min(TimeSpan, TimeSpan) | Gets the smallest of the specified time spans.
 | Min(array<TimeSpan>[]()[]) | Gets the smallest of the specified time spans.


Min Method (dateTime1, dateTime2)

Min Method (dateTime1, dateTime2)
Namespaces ► Sitecore ► DateUtil ► Min(DateTime, DateTime)
Gets the smallest of the specified date/times.
Declaration Syntax
C#
public static DateTime Min(
    DateTime dateTime1,
    DateTime dateTime2
)
Parameters
dateTime1 (DateTime)
The date time1.
dateTime2 (DateTime)
The date time2.
Return Value


Min Method (dateTimes)

Min Method (dateTimes)
Namespaces ► Sitecore ► DateUtil ► Min(array<DateTime>[]()[])
Gets the smallest of the specified date/times.
Declaration Syntax
C#
public static DateTime Min(
    params DateTime[] dateTimes
)
Parameters
dateTimes (array< DateTime >[]()[])
The date times.
Return Value


Min Method (time1, time2)

Min Method (time1, time2)
Namespaces ► Sitecore ► DateUtil ► Min(TimeSpan, TimeSpan)
Gets the smallest of the specified time spans.
Declaration Syntax
C#
public static TimeSpan Min(
    TimeSpan time1,
    TimeSpan time2
)
Parameters
time1 (TimeSpan)
The time1.
time2 (TimeSpan)
The time2.
Return Value


Min Method (times)

Min Method (times)
Namespaces ► Sitecore ► DateUtil ► Min(array<TimeSpan>[]()[])
Gets the smallest of the specified time spans.
Declaration Syntax
C#
public static TimeSpan Min(
    params TimeSpan[] times
)
Parameters
times (array< TimeSpan >[]()[])
The times.
Return Value


ParseDateTime Method

ParseDateTime Method
Namespaces ► Sitecore ► DateUtil ► ParseDateTime()()()
Members
Icon | Member | Description
 | ParseDateTime(String, DateTime) | Parses a string into a DateTime structure.
 | ParseDateTime(String, DateTime, CultureInfo) | Parses a string into a DateTime structure.


ParseDateTime Method (value, defaultValue)

ParseDateTime Method (value, defaultValue)
Namespaces ► Sitecore ► DateUtil ► ParseDateTime(String, DateTime)
Parses a string into a DateTime structure.
Declaration Syntax
C#
public static DateTime ParseDateTime(
    string value,
    DateTime defaultValue
)
Parameters
value (String)
The value.
defaultValue (DateTime)
The default value.
Return Value


ParseDateTime Method (value, defaultValue, info)

ParseDateTime Method (value, defaultValue, info)
Namespaces ► Sitecore ► DateUtil ► ParseDateTime(String, DateTime, CultureInfo)
Parses a string into a DateTime structure.
Declaration Syntax
C#
public static DateTime ParseDateTime(
    string value,
    DateTime defaultValue,
    CultureInfo info
)
Parameters
value (String)
The value.
defaultValue (DateTime)
The default value.
info (CultureInfo)
The info.
Return Value


ParseTimeSpan Method

ParseTimeSpan Method
Namespaces ► Sitecore ► DateUtil ► ParseTimeSpan()()()
Members
Icon | Member | Description
 | ParseTimeSpan(String) | Parses a time string representing a time span.
 | ParseTimeSpan(String, TimeSpan) | Parses a time string representing a time span.
 | ParseTimeSpan(String, TimeSpan, CultureInfo) | Parses a time string representing a time span.


ParseTimeSpan Method (time)

ParseTimeSpan Method (time)
Namespaces ► Sitecore ► DateUtil ► ParseTimeSpan(String)
Parses a time string representing a time span.
Declaration Syntax
C#
public static TimeSpan ParseTimeSpan(
    string time
)
Parameters
time (String)
The time in the format "00:00:00" or "00:00:00:00".
Return Value
A TimeSpan class representing the Itime string.
Remarks
Format must be 00:00:00 representing hours, minutes and seconds. A fourth optional part may be added, representing milliseconds (ie. 00:00:00:00)
Examples
The following example returns the TimeSpan eqivalent of the time string.
CopyC#
string timeString = "13:45:00";
TimeSpan timeSpan = DateUtil.ParseTimeSpan(timeString);


ParseTimeSpan Method (time, defaultValue)

ParseTimeSpan Method (time, defaultValue)
Namespaces ► Sitecore ► DateUtil ► ParseTimeSpan(String, TimeSpan)
Parses a time string representing a time span.
Declaration Syntax
C#
public static TimeSpan ParseTimeSpan(
    string time,
    TimeSpan defaultValue
)
Parameters
time (String)
The time in the format "00:00:00" or "00:00:00:00".
defaultValue (TimeSpan)
Default value to return if time can not be parsed.
Return Value
A TimeSpan class representing the Itime string.
Remarks
Format must be 00:00:00 representing hours, minutes and seconds. A fourth optional part may be added, representing milliseconds (ie. 00:00:00:00)
Examples
The following example returns the TimeSpan eqivalent of the time string.
CopyC#
string timeString = "13:45:00";
TimeSpan timeSpan = DateUtil.ParseTimeSpan(timeString);


ParseTimeSpan Method (time, defaultValue, cultureInfo)

ParseTimeSpan Method (time, defaultValue, cultureInfo)
Namespaces ► Sitecore ► DateUtil ► ParseTimeSpan(String, TimeSpan, CultureInfo)
Parses a time string representing a time span.
Declaration Syntax
C#
public static TimeSpan ParseTimeSpan(
    string time,
    TimeSpan defaultValue,
    CultureInfo cultureInfo
)
Parameters
time (String)
The time in the format "00:00:00" or "00:00:00:00".
defaultValue (TimeSpan)
Default value to return if time can not be parsed.
cultureInfo (CultureInfo)
The culture info.
Return Value
A TimeSpan class representing the Itime string.
Remarks
Format must be 00:00:00 representing hours, minutes and seconds. A fourth optional part may be added, representing milliseconds (ie. 00:00:00:00)
Examples
The following example returns the TimeSpan eqivalent of the time string.
CopyC#
string timeString = "13:45:00";
TimeSpan timeSpan = DateUtil.ParseTimeSpan(timeString);


TicksPerMillisecond Property

TicksPerMillisecond Property
Namespaces ► Sitecore ► DateUtil ► TicksPerMillisecond
Gets the number of ticks per millisecond.
Declaration Syntax
C#
public static long TicksPerMillisecond { get; }
Value
The ticks per millisecond.


TimeSpanToIsoTime Method (interval)

TimeSpanToIsoTime Method (interval)
Namespaces ► Sitecore ► DateUtil ► TimeSpanToIsoTime(TimeSpan)
Converts a TimeSpan into a Iso date string.
Declaration Syntax
C#
public static string TimeSpanToIsoTime(
    TimeSpan interval
)
Parameters
interval (TimeSpan)
The interval.
Return Value


ToIsoDate Method

ToIsoDate Method
Namespaces ► Sitecore ► DateUtil ► ToIsoDate()()()
Members
Icon | Member | Description
 | ToIsoDate(DateTime) | Converts a DateTime class to an ISO formatted date/time string.
 | ToIsoDate(DateTime, Boolean) | Converts a DateTime class to an ISO formatted date/time string.


ToIsoDate Method (datetime)

ToIsoDate Method (datetime)
Namespaces ► Sitecore ► DateUtil ► ToIsoDate(DateTime)
Converts a DateTime class to an ISO formatted date/time string.
Declaration Syntax
C#
public static string ToIsoDate(
    DateTime datetime
)
Parameters
datetime (DateTime)
A DateTime class to be formatted.
Return Value
The ISO formatted date/time equivalent of the DateTime class.
Remarks
The date/time string is formatted as "yyyyMMddTHHmmss".
Examples
The following example returns Now formatted as an ISO date.
CopyC#
return DateUtil.DateTimeToIsoDate(DateTime.Now);


ToIsoDate Method (datetime, includeTicks)

ToIsoDate Method (datetime, includeTicks)
Namespaces ► Sitecore ► DateUtil ► ToIsoDate(DateTime, Boolean)
Converts a DateTime class to an ISO formatted date/time string.
Declaration Syntax
C#
public static string ToIsoDate(
    DateTime datetime,
    bool includeTicks
)
Parameters
datetime (DateTime)
A DateTime class to be formatted.
includeTicks (Boolean)
if set to true [include ticks].
Return Value
The ISO formatted date/time equivalent of the DateTime class.
Remarks
The date/time string is formatted as "yyyyMMddTHHmmss".
Examples
The following example returns Now formatted as an ISO date.
CopyC#
return DateUtil.DateTimeToIsoDate(DateTime.Now);


ToIsoTime Method

ToIsoTime Method
Namespaces ► Sitecore ► DateUtil ► ToIsoTime()()()
Members
Icon | Member | Description
 | ToIsoTime(DateTime) | Converts a DateTime class to an ISO formatted time string.
 | ToIsoTime(DateTime, Boolean) | Converts a DateTime class to an ISO formatted date/time string.


ToIsoTime Method (datetime)

ToIsoTime Method (datetime)
Namespaces ► Sitecore ► DateUtil ► ToIsoTime(DateTime)
Converts a DateTime class to an ISO formatted time string.
Declaration Syntax
C#
public static string ToIsoTime(
    DateTime datetime
)
Parameters
datetime (DateTime)
A DateTime class to be formatted.
Return Value
The ISO formatted time equivalent of the DateTime class.
Remarks
The time string is formatted as "HHmmss".
Examples
The following example returns Now formatted as an ISO time.
CopyC#
return DateUtil.ToIsoTime(DateTime.Now);


ToIsoTime Method (datetime, includeTicks)

ToIsoTime Method (datetime, includeTicks)
Namespaces ► Sitecore ► DateUtil ► ToIsoTime(DateTime, Boolean)
Converts a DateTime class to an ISO formatted date/time string.
Declaration Syntax
C#
public static string ToIsoTime(
    DateTime datetime,
    bool includeTicks
)
Parameters
datetime (DateTime)
A DateTime class to be formatted.
includeTicks (Boolean)
if set to true [include ticks].
Return Value
The ISO formatted date/time equivalent of the DateTime class.
Remarks
The date/time string is formatted as "yyyyMMddTHHmmss".
Examples
The following example returns Now formatted as an ISO date.
CopyC#
return DateUtil.DateTimeToIsoDate(DateTime.Now);


DaysOfWeek Enumeration

DaysOfWeek Enumeration
Namespaces ► Sitecore ► DaysOfWeek
Specifies a days of week enumeration.
Declaration Syntax
C#
[FlagsAttribute]
public enum DaysOfWeek
Members
Member | Description
None | No date.
Sunday | Sunday.
Monday | Monday.
Tuesday | Tuesdaэ.
Wednesday | Wednesday.
Thursday | Thursday.
Friday | Friday.
Saturday | Saturday.


DefaultPage Class

DefaultPage Class
Namespaces ► Sitecore ► DefaultPage
Defines the default page class.
Declaration Syntax
C#
public class DefaultPage : Page
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultPage()()() | Initializes a new instance of the DefaultPage class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Overrides Page.OnInit(EventArgs).)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) | Handles the Load event of the Page control.
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | DefaultPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DefaultPage Constructor

DefaultPage Constructor
Namespaces ► Sitecore ► DefaultPage ► DefaultPage()()()
Initializes a new instance of the DefaultPage class
Declaration Syntax
C#
public DefaultPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnInit Method (e)

OnInit Method (e)
Namespaces ► Sitecore ► DefaultPage ► OnInit(EventArgs)
Raises the Init event to initialize the page.
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore ► DefaultPage ► Page_Load(Object, EventArgs)
Handles the Load event of the Page control.
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DeviceFieldIDs Class

DeviceFieldIDs Class
Namespaces ► Sitecore ► DeviceFieldIDs
Fields of the Layout/Device template.
Declaration Syntax
C#
public static class DeviceFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Agent | The ID of the 'Agent' field.
 | Default | The ID of the 'Default' field.
 | FallbackDevice | The ID of the 'Fallback device' field.
 | QueryString | The ID of the 'Query string' field.
Inheritance Hierarchy
Object
DeviceFieldIDs


Agent Field

Agent Field
Namespaces ► Sitecore ► DeviceFieldIDs ► Agent
The ID of the 'Agent' field.
Declaration Syntax
C#
public static ID Agent


Default Field

Default Field
Namespaces ► Sitecore ► DeviceFieldIDs ► Default
The ID of the 'Default' field.
Declaration Syntax
C#
public static ID Default


FallbackDevice Field

FallbackDevice Field
Namespaces ► Sitecore ► DeviceFieldIDs ► FallbackDevice
The ID of the 'Fallback device' field.
Declaration Syntax
C#
public static ID FallbackDevice


QueryString Field

QueryString Field
Namespaces ► Sitecore ► DeviceFieldIDs ► QueryString
The ID of the 'Query string' field.
Declaration Syntax
C#
public static ID QueryString


Disposable Class

Disposable Class
Namespaces ► Sitecore ► Disposable
Provides a base class for implementing classes that must be disposed.
Declaration Syntax
C#
public abstract class Disposable : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Disposable()()() | Initializes a new instance of the Disposable class
 | Destroy()()() | Destroys this instance.
 | DestroyUnmanagedResources()()() | Destroys the unmanaged resources.
 | Dispose()()() | Disposes the object.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Releases unmanaged resources and performs other cleanup operations before the Disposable is reclaimed by garbage collection. (Overrides Object.Finalize()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Disposable
 |  | MediaInfo


Disposable Constructor

Disposable Constructor
Namespaces ► Sitecore ► Disposable ► Disposable()()()
Initializes a new instance of the Disposable class
Declaration Syntax
C#
protected Disposable()


Destroy Method

Destroy Method
Namespaces ► Sitecore ► Disposable ► Destroy()()()
Destroys this instance.
Declaration Syntax
C#
protected virtual void Destroy()


DestroyUnmanagedResources Method

DestroyUnmanagedResources Method
Namespaces ► Sitecore ► Disposable ► DestroyUnmanagedResources()()()
Destroys the unmanaged resources.
Declaration Syntax
C#
protected virtual void DestroyUnmanagedResources()


Dispose Method

Dispose Method
Namespaces ► Sitecore ► Disposable ► Dispose()()()
Disposes the object.
Declaration Syntax
C#
public void Dispose()


Finalize Method

Finalize Method
Namespaces ► Sitecore ► Disposable ► Finalize()()()
Releases unmanaged resources and performs other cleanup operations before the Disposable is reclaimed by garbage collection.
Declaration Syntax
C#
protected override void Finalize()


EventHandlerInfo Class

EventHandlerInfo Class
Namespaces ► Sitecore ► EventHandlerInfo
Information about event handler.
Declaration Syntax
C#
public class EventHandlerInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EventHandlerInfo(Object, NameValueCollection) | Constructor
 | ConfigSettings | Gets the config settings for event handler.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Handler | Gets the handler object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
EventHandlerInfo


EventHandlerInfo Constructor (handler, configSettings)

EventHandlerInfo Constructor (handler, configSettings)
Namespaces ► Sitecore ► EventHandlerInfo ► EventHandlerInfo(Object, NameValueCollection)
Constructor
Declaration Syntax
C#
public EventHandlerInfo(
    Object handler,
    NameValueCollection configSettings
)
Parameters
handler (Object)
The handler.
configSettings (NameValueCollection)
The config settings.


ConfigSettings Property

ConfigSettings Property
Namespaces ► Sitecore ► EventHandlerInfo ► ConfigSettings
Gets the config settings for event handler.
Declaration Syntax
C#
public NameValueCollection ConfigSettings { get; }
Value
The config settings.


Handler Property

Handler Property
Namespaces ► Sitecore ► EventHandlerInfo ► Handler
Gets the handler object.
Declaration Syntax
C#
public Object Handler { get; }
Value
The handler.


FieldIDs Class

FieldIDs Class
Namespaces ► Sitecore ► FieldIDs
Implements a static class for holding well-known GUIDs relating to fields.
Declaration Syntax
C#
public static class FieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ArchiveDate | The ID of the 'Archive date' field.
 | BaseTemplate | The ID of the 'Base template' field.
 | Branches | The ID of the 'Branches' field.
 | Command | The ID of the 'Command' field.
 | ContextMenu | The ID of the 'Context Menu' field.
 | Created | The ID of the 'Created' field.
 | CreatedBy | The ID of the 'Created by' field.
 | DefaultDomain | The ID of the 'Default domain' field of the 'Domain folder' template.
 | DefaultWorkflow | The ID of the 'Initial workflow' field.
 | DisplayName | The ID of the 'DisplayName' field.
 | DomainMembershipProvider | The ID of the 'MembershipProvider' field of the 'Domain' template.
 | DomainRoleNameTemplate | The ID of the 'RoleNameTemplate' field of the 'Domain' template.
 | DomainUniqueName | The ID of the 'UniqueName' field of the 'Domain' template.
 | DomainUserNameTemplate | The ID of the 'UserNameTemplate' field of the 'Domain' template.
 | EditorPath | The ID of the 'Editor path' field.
 | Hidden | The ID of the '__Hidden' field.
 | HideVersion | The ID of the 'Hide version' field.
 | Icon | The GUID of the 'Icon' field.
 | InheritSecurity | The ID of the 'Inherit security' field.
 | LanguageIso | The ID of the 'Iso' field of the 'Language' template.
 | Layout | Obsolete. The ID of the 'Layout' field.
 | LayoutField | The ID of the 'LayoutField' field.
 | Lock | The ID of the 'Lock' field.
 | Masters | Obsolete. The ID of the 'Masters' field.
 | NeverPublish | The ID of the 'Never publish' field.
 | Originator | The ID of the '__Originator' field.
 | Owner | The ID of the 'Owner' field
 | PageDefinition | The ID of the 'Page definition' field.
 | Presentation | The ID of the 'Presentation' field.
 | ProxyInsertionType | The ID of the 'Insertion Type' field of the 'Proxy' template.
 | ProxySourceDatabase | The ID of the 'Source database' field of the 'Proxy' template.
 | ProxySourceItem | The ID of the 'Target item' field of the 'Proxy' template.
 | ProxyTargetItem | The ID of the 'Parent item' field of the 'Proxy' template.
 | PublishDate | The ID of the 'Publish' field.
 | PublishingTargetDatabase | The ID of the 'Target database' field in a publishing target.
 | PublishingTargets | The ID of the 'Publishing targets' field.
 | ReadOnly | The ID of the 'Read Only' field.
 | Reference | The ID of the 'Reference' field.
 | ReminderDate | The ID of the 'Reminder date' field.
 | ReminderRecipients | The ID of the 'Reminder recipients' field.
 | ReminderText | The ID of the 'Reminder text' field.
 | Renderers | The ID of the 'Renderers' field.
 | Revision | The ID of the 'Revision' field.
 | Ribbon | The ID of the 'Ribbon' field.
 | Security | The ID of the 'Security' field.
 | Skin | The ID of the 'Skin' field.
 | Sortorder | The ID of the 'Sortorder' field.
 | StandardValueHolderId | The ID of the 'StandardValueHolderId' field.
 | StandardValues | The ID of the 'StandardValues' field.
 | State | The ID of the State field.
 | Style | The ID of the Style field.
 | SubitemsSorting | The ID of the 'Child Sorting' field.
 | UnpublishDate | The ID of the 'Unpublish' field.
 | Updated | The ID of the 'Updated' field.
 | UpdatedBy | The ID of the 'Updated by' field.
 | UserMembership | The ID of the 'Membership' field of the User template.
 | ValidFrom | The ID of the 'Valid from' field.
 | ValidTo | The ID of the 'Valid to' field.
 | Workflow | The ID of the 'Workflow' field.
 | WorkflowState | The ID of the 'Workflow state' field.
Remarks
The class does not contain any functionality, but serves only as a placeholder for a predefined GUIDs.
Inheritance Hierarchy
Object
FieldIDs


ArchiveDate Field

ArchiveDate Field
Namespaces ► Sitecore ► FieldIDs ► ArchiveDate
The ID of the 'Archive date' field.
Declaration Syntax
C#
public static ID ArchiveDate


BaseTemplate Field

BaseTemplate Field
Namespaces ► Sitecore ► FieldIDs ► BaseTemplate
The ID of the 'Base template' field.
Declaration Syntax
C#
public static ID BaseTemplate


Branches Field

Branches Field
Namespaces ► Sitecore ► FieldIDs ► Branches
The ID of the 'Branches' field.
Declaration Syntax
C#
public static ID Branches


Command Field

Command Field
Namespaces ► Sitecore ► FieldIDs ► Command
The ID of the 'Command' field.
Declaration Syntax
C#
public static ID Command


ContextMenu Field

ContextMenu Field
Namespaces ► Sitecore ► FieldIDs ► ContextMenu
The ID of the 'Context Menu' field.
Declaration Syntax
C#
public static ID ContextMenu


Created Field

Created Field
Namespaces ► Sitecore ► FieldIDs ► Created
The ID of the 'Created' field.
Declaration Syntax
C#
public static ID Created


CreatedBy Field

CreatedBy Field
Namespaces ► Sitecore ► FieldIDs ► CreatedBy
The ID of the 'Created by' field.
Declaration Syntax
C#
public static ID CreatedBy


DefaultDomain Field

DefaultDomain Field
Namespaces ► Sitecore ► FieldIDs ► DefaultDomain
The ID of the 'Default domain' field of the 'Domain folder' template.
Declaration Syntax
C#
public static ID DefaultDomain


DefaultWorkflow Field

DefaultWorkflow Field
Namespaces ► Sitecore ► FieldIDs ► DefaultWorkflow
The ID of the 'Initial workflow' field.
Declaration Syntax
C#
public static ID DefaultWorkflow


DisplayName Field

DisplayName Field
Namespaces ► Sitecore ► FieldIDs ► DisplayName
The ID of the 'DisplayName' field.
Declaration Syntax
C#
public static ID DisplayName


DomainMembershipProvider Field

DomainMembershipProvider Field
Namespaces ► Sitecore ► FieldIDs ► DomainMembershipProvider
The ID of the 'MembershipProvider' field of the 'Domain' template.
Declaration Syntax
C#
public static ID DomainMembershipProvider


DomainRoleNameTemplate Field

DomainRoleNameTemplate Field
Namespaces ► Sitecore ► FieldIDs ► DomainRoleNameTemplate
The ID of the 'RoleNameTemplate' field of the 'Domain' template.
Declaration Syntax
C#
public static ID DomainRoleNameTemplate


DomainUniqueName Field

DomainUniqueName Field
Namespaces ► Sitecore ► FieldIDs ► DomainUniqueName
The ID of the 'UniqueName' field of the 'Domain' template.
Declaration Syntax
C#
public static ID DomainUniqueName


DomainUserNameTemplate Field

DomainUserNameTemplate Field
Namespaces ► Sitecore ► FieldIDs ► DomainUserNameTemplate
The ID of the 'UserNameTemplate' field of the 'Domain' template.
Declaration Syntax
C#
public static ID DomainUserNameTemplate


EditorPath Field

EditorPath Field
Namespaces ► Sitecore ► FieldIDs ► EditorPath
The ID of the 'Editor path' field.
Declaration Syntax
C#
public static ID EditorPath


Hidden Field

Hidden Field
Namespaces ► Sitecore ► FieldIDs ► Hidden
The ID of the '__Hidden' field.
Declaration Syntax
C#
public static ID Hidden


HideVersion Field

HideVersion Field
Namespaces ► Sitecore ► FieldIDs ► HideVersion
The ID of the 'Hide version' field.
Declaration Syntax
C#
public static ID HideVersion


Icon Field

Icon Field
Namespaces ► Sitecore ► FieldIDs ► Icon
The GUID of the 'Icon' field.
Declaration Syntax
C#
public static ID Icon


InheritSecurity Field

InheritSecurity Field
Namespaces ► Sitecore ► FieldIDs ► InheritSecurity
The ID of the 'Inherit security' field.
Declaration Syntax
C#
public static ID InheritSecurity


LanguageIso Field

LanguageIso Field
Namespaces ► Sitecore ► FieldIDs ► LanguageIso
The ID of the 'Iso' field of the 'Language' template.
Declaration Syntax
C#
public static ID LanguageIso


Layout Field

Layout Field
Namespaces ► Sitecore ► FieldIDs ► Layout
The ID of the 'Layout' field.
Declaration Syntax
C#
[ObsoleteAttribute("This field is no longer used - please use LayoutField instead.")]
public static ID Layout


LayoutField Field

LayoutField Field
Namespaces ► Sitecore ► FieldIDs ► LayoutField
The ID of the 'LayoutField' field.
Declaration Syntax
C#
public static ID LayoutField


Lock Field

Lock Field
Namespaces ► Sitecore ► FieldIDs ► Lock
The ID of the 'Lock' field.
Declaration Syntax
C#
public static ID Lock


Masters Field

Masters Field
Namespaces ► Sitecore ► FieldIDs ► Masters
The ID of the 'Masters' field.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Branches instead.")]
public static ID Masters


NeverPublish Field

NeverPublish Field
Namespaces ► Sitecore ► FieldIDs ► NeverPublish
The ID of the 'Never publish' field.
Declaration Syntax
C#
public static ID NeverPublish


Originator Field

Originator Field
Namespaces ► Sitecore ► FieldIDs ► Originator
The ID of the '__Originator' field.
Declaration Syntax
C#
public static ID Originator


Owner Field

Owner Field
Namespaces ► Sitecore ► FieldIDs ► Owner
The ID of the 'Owner' field
Declaration Syntax
C#
public static ID Owner


PageDefinition Field

PageDefinition Field
Namespaces ► Sitecore ► FieldIDs ► PageDefinition
The ID of the 'Page definition' field.
Declaration Syntax
C#
public static ID PageDefinition


Presentation Field

Presentation Field
Namespaces ► Sitecore ► FieldIDs ► Presentation
The ID of the 'Presentation' field.
Declaration Syntax
C#
public static ID Presentation


ProxyInsertionType Field

ProxyInsertionType Field
Namespaces ► Sitecore ► FieldIDs ► ProxyInsertionType
The ID of the 'Insertion Type' field of the 'Proxy' template.
Declaration Syntax
C#
public static ID ProxyInsertionType


ProxySourceDatabase Field

ProxySourceDatabase Field
Namespaces ► Sitecore ► FieldIDs ► ProxySourceDatabase
The ID of the 'Source database' field of the 'Proxy' template.
Declaration Syntax
C#
public static ID ProxySourceDatabase


ProxySourceItem Field

ProxySourceItem Field
Namespaces ► Sitecore ► FieldIDs ► ProxySourceItem
The ID of the 'Target item' field of the 'Proxy' template.
Declaration Syntax
C#
public static ID ProxySourceItem


ProxyTargetItem Field

ProxyTargetItem Field
Namespaces ► Sitecore ► FieldIDs ► ProxyTargetItem
The ID of the 'Parent item' field of the 'Proxy' template.
Declaration Syntax
C#
public static ID ProxyTargetItem


PublishDate Field

PublishDate Field
Namespaces ► Sitecore ► FieldIDs ► PublishDate
The ID of the 'Publish' field.
Declaration Syntax
C#
public static ID PublishDate


PublishingTargetDatabase Field

PublishingTargetDatabase Field
Namespaces ► Sitecore ► FieldIDs ► PublishingTargetDatabase
The ID of the 'Target database' field in a publishing target.
Declaration Syntax
C#
public static ID PublishingTargetDatabase


PublishingTargets Field

PublishingTargets Field
Namespaces ► Sitecore ► FieldIDs ► PublishingTargets
The ID of the 'Publishing targets' field.
Declaration Syntax
C#
public static ID PublishingTargets


ReadOnly Field

ReadOnly Field
Namespaces ► Sitecore ► FieldIDs ► ReadOnly
The ID of the 'Read Only' field.
Declaration Syntax
C#
public static ID ReadOnly


Reference Field

Reference Field
Namespaces ► Sitecore ► FieldIDs ► Reference
The ID of the 'Reference' field.
Declaration Syntax
C#
public static ID Reference


ReminderDate Field

ReminderDate Field
Namespaces ► Sitecore ► FieldIDs ► ReminderDate
The ID of the 'Reminder date' field.
Declaration Syntax
C#
public static ID ReminderDate


ReminderRecipients Field

ReminderRecipients Field
Namespaces ► Sitecore ► FieldIDs ► ReminderRecipients
The ID of the 'Reminder recipients' field.
Declaration Syntax
C#
public static ID ReminderRecipients


ReminderText Field

ReminderText Field
Namespaces ► Sitecore ► FieldIDs ► ReminderText
The ID of the 'Reminder text' field.
Declaration Syntax
C#
public static ID ReminderText


Renderers Field

Renderers Field
Namespaces ► Sitecore ► FieldIDs ► Renderers
The ID of the 'Renderers' field.
Declaration Syntax
C#
public static ID Renderers


Revision Field

Revision Field
Namespaces ► Sitecore ► FieldIDs ► Revision
The ID of the 'Revision' field.
Declaration Syntax
C#
public static ID Revision


Ribbon Field

Ribbon Field
Namespaces ► Sitecore ► FieldIDs ► Ribbon
The ID of the 'Ribbon' field.
Declaration Syntax
C#
public static ID Ribbon


Security Field

Security Field
Namespaces ► Sitecore ► FieldIDs ► Security
The ID of the 'Security' field.
Declaration Syntax
C#
public static ID Security


Skin Field

Skin Field
Namespaces ► Sitecore ► FieldIDs ► Skin
The ID of the 'Skin' field.
Declaration Syntax
C#
public static ID Skin


Sortorder Field

Sortorder Field
Namespaces ► Sitecore ► FieldIDs ► Sortorder
The ID of the 'Sortorder' field.
Declaration Syntax
C#
public static ID Sortorder


StandardValueHolderId Field

StandardValueHolderId Field
Namespaces ► Sitecore ► FieldIDs ► StandardValueHolderId
The ID of the 'StandardValueHolderId' field.
Declaration Syntax
C#
public static ID StandardValueHolderId


StandardValues Field

StandardValues Field
Namespaces ► Sitecore ► FieldIDs ► StandardValues
The ID of the 'StandardValues' field.
Declaration Syntax
C#
public static ID StandardValues


State Field

State Field
Namespaces ► Sitecore ► FieldIDs ► State
The ID of the State field.
Declaration Syntax
C#
public static ID State


Style Field

Style Field
Namespaces ► Sitecore ► FieldIDs ► Style
The ID of the Style field.
Declaration Syntax
C#
public static ID Style


SubitemsSorting Field

SubitemsSorting Field
Namespaces ► Sitecore ► FieldIDs ► SubitemsSorting
The ID of the 'Child Sorting' field.
Declaration Syntax
C#
public static ID SubitemsSorting


UnpublishDate Field

UnpublishDate Field
Namespaces ► Sitecore ► FieldIDs ► UnpublishDate
The ID of the 'Unpublish' field.
Declaration Syntax
C#
public static ID UnpublishDate


Updated Field

Updated Field
Namespaces ► Sitecore ► FieldIDs ► Updated
The ID of the 'Updated' field.
Declaration Syntax
C#
public static ID Updated


UpdatedBy Field

UpdatedBy Field
Namespaces ► Sitecore ► FieldIDs ► UpdatedBy
The ID of the 'Updated by' field.
Declaration Syntax
C#
public static ID UpdatedBy


UserMembership Field

UserMembership Field
Namespaces ► Sitecore ► FieldIDs ► UserMembership
The ID of the 'Membership' field of the User template.
Declaration Syntax
C#
public static ID UserMembership


ValidFrom Field

ValidFrom Field
Namespaces ► Sitecore ► FieldIDs ► ValidFrom
The ID of the 'Valid from' field.
Declaration Syntax
C#
public static ID ValidFrom


ValidTo Field

ValidTo Field
Namespaces ► Sitecore ► FieldIDs ► ValidTo
The ID of the 'Valid to' field.
Declaration Syntax
C#
public static ID ValidTo


Workflow Field

Workflow Field
Namespaces ► Sitecore ► FieldIDs ► Workflow
The ID of the 'Workflow' field.
Declaration Syntax
C#
public static ID Workflow


WorkflowState Field

WorkflowState Field
Namespaces ► Sitecore ► FieldIDs ► WorkflowState
The ID of the 'Workflow state' field.
Declaration Syntax
C#
public static ID WorkflowState


Globals Class

Globals Class
Namespaces ► Sitecore ► Globals
Represents the globals.
Declaration Syntax
C#
public static class Globals
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DefaultCulture | Gets the default culture.
 | LinkDatabase | Gets the link database.
 | Load()()() | Loads this instance.
 | Server | Gets the server.
 | ServerUrl | Gets the server URL.
 | TaskDatabase | Gets the task database.
Inheritance Hierarchy
Object
Globals


DefaultCulture Property

DefaultCulture Property
Namespaces ► Sitecore ► Globals ► DefaultCulture
Gets the default culture.
Declaration Syntax
C#
public static CultureInfo DefaultCulture { get; }
Value
The default culture.


LinkDatabase Property

LinkDatabase Property
Namespaces ► Sitecore ► Globals ► LinkDatabase
Gets the link database.
Declaration Syntax
C#
public static LinkDatabase LinkDatabase { get; }
Value
The link database.


Load Method

Load Method
Namespaces ► Sitecore ► Globals ► Load()()()
Loads this instance.
Declaration Syntax
C#
public static void Load()


Server Property

Server Property
Namespaces ► Sitecore ► Globals ► Server
Gets the server.
Declaration Syntax
C#
public static HttpServerUtility Server { get; }
Value
The server.


ServerUrl Property

ServerUrl Property
Namespaces ► Sitecore ► Globals ► ServerUrl
Gets the server URL.
Declaration Syntax
C#
public static string ServerUrl { get; }
Value
The server URL.


TaskDatabase Property

TaskDatabase Property
Namespaces ► Sitecore ► Globals ► TaskDatabase
Gets the task database.
Declaration Syntax
C#
public static TaskDatabase TaskDatabase { get; }
Value
The task database.


Handle Class

Handle Class
Namespaces ► Sitecore ► Handle
Represents a handle.
Declaration Syntax
C#
[SerializableAttribute]
public class Handle
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Handle()()() | Initializes a new instance of the Handle class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Null | The Null handle.
 | Parse(String) | Parses the specified value.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
Handle


Handle Constructor

Handle Constructor
Namespaces ► Sitecore ► Handle ► Handle()()()
Initializes a new instance of the Handle class.
Declaration Syntax
C#
public Handle()


Equals Method (obj)

Equals Method (obj)
Namespaces ► Sitecore ► Handle ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C#
public override bool Equals(
    Object obj
)
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.


GetHashCode Method

GetHashCode Method
Namespaces ► Sitecore ► Handle ► GetHashCode()()()
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
Declaration Syntax
C#
public override int GetHashCode()
Return Value
A hash code for the current Object.


Null Field

Null Field
Namespaces ► Sitecore ► Handle ► Null
The Null handle.
Declaration Syntax
C#
public static readonly Handle Null


Parse Method (value)

Parse Method (value)
Namespaces ► Sitecore ► Handle ► Parse(String)
Parses the specified value.
Declaration Syntax
C#
public static Handle Parse(
    string value
)
Parameters
value (String)
The value.
Return Value
The parse.


ToString Method

ToString Method
Namespaces ► Sitecore ► Handle ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


ImplicitUseFlags Enumeration

ImplicitUseFlags Enumeration
Namespaces ► Sitecore ► ImplicitUseFlags
Declaration Syntax
C#
[FlagsAttribute]
public enum ImplicitUseFlags
Members
Member | Description
STANDARD |
ALL_MEMBERS_USED |


InvokerParameterNameAttribute Class

InvokerParameterNameAttribute Class
Namespaces ► Sitecore ► InvokerParameterNameAttribute
Declaration Syntax
C#
public class InvokerParameterNameAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InvokerParameterNameAttribute()()() | Initializes a new instance of the InvokerParameterNameAttribute class
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | InvokerParameterNameAttribute


InvokerParameterNameAttribute Constructor

InvokerParameterNameAttribute Constructor
Namespaces ► Sitecore ► InvokerParameterNameAttribute ► InvokerParameterNameAttribute()()()
Initializes a new instance of the InvokerParameterNameAttribute class
Declaration Syntax
C#
public InvokerParameterNameAttribute()


IPublishingRequest Interface

IPublishingRequest Interface
Namespaces ► Sitecore ► IPublishingRequest
Represents a publishing request.
Declaration Syntax
C#
public interface IPublishingRequest
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Groups | Gets the groups to publish,
 | Handle | Gets the request handle (guid).
 | MarkDone()()() | Marks the request as being done (ie. processed).
 | PublishAll | Gets a value indicating whether the IPublishingRequest publishes all.
 | PublishDate | Gets the publish date/time.
 | PublishIsoDate | Gets the publish date/time in iso format.
 | ServerUrl | Gets the Url of server that initiated the request.
 | Status | Gets the current status.
 | UserName | Gets the name of the user that initiated the publish operation.
 | WorkFile | Gets the path to the work file.


Groups Property

Groups Property
Namespaces ► Sitecore ► IPublishingRequest ► Groups
Gets the groups to publish,
Declaration Syntax
C#
ArrayList Groups { get; }
Value
The groups.


Handle Property

Handle Property
Namespaces ► Sitecore ► IPublishingRequest ► Handle
Gets the request handle (guid).
Declaration Syntax
C#
string Handle { get; }
Value
The handle.


MarkDone Method

MarkDone Method
Namespaces ► Sitecore ► IPublishingRequest ► MarkDone()()()
Marks the request as being done (ie. processed).
Declaration Syntax
C#
void MarkDone()


PublishAll Property

PublishAll Property
Namespaces ► Sitecore ► IPublishingRequest ► PublishAll
Gets a value indicating whether the IPublishingRequest publishes all.
Declaration Syntax
C#
bool PublishAll { get; }
Value
true if the IPublishingRequest publishes all; otherwise, false.
Remarks
If false, only changed items will be published


PublishDate Property

PublishDate Property
Namespaces ► Sitecore ► IPublishingRequest ► PublishDate
Gets the publish date/time.
Declaration Syntax
C#
DateTime PublishDate { get; }
Value
The publish date.


PublishIsoDate Property

PublishIsoDate Property
Namespaces ► Sitecore ► IPublishingRequest ► PublishIsoDate
Gets the publish date/time in iso format.
Declaration Syntax
C#
string PublishIsoDate { get; }
Value
The publish iso date.


ServerUrl Property

ServerUrl Property
Namespaces ► Sitecore ► IPublishingRequest ► ServerUrl
Gets the Url of server that initiated the request.
Declaration Syntax
C#
string ServerUrl { get; }
Value
The server URL.


Status Property

Status Property
Namespaces ► Sitecore ► IPublishingRequest ► Status
Gets the current status.
Declaration Syntax
C#
IPublishingStatus Status { get; }
Value
The status.


UserName Property

UserName Property
Namespaces ► Sitecore ► IPublishingRequest ► UserName
Gets the name of the user that initiated the publish operation.
Declaration Syntax
C#
string UserName { get; }
Value
The name of the user.


WorkFile Property

WorkFile Property
Namespaces ► Sitecore ► IPublishingRequest ► WorkFile
Gets the path to the work file.
Declaration Syntax
C#
string WorkFile { get; }
Value
The work file.


IPublishingStatus Interface

IPublishingStatus Interface
Namespaces ► Sitecore ► IPublishingStatus
Represents a publishing status.
Declaration Syntax
C#
public interface IPublishingStatus
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Error | Gets the error.
 | EstimatedTimeLeft | Gets the estimated time left (ms).
 | ProcessedItems | Gets the number of items processed up until now.
 | ProcessingTime | Gets the time spent processing up until now (ms).
 | QueueIndex | Gets the index in queue.
 | QueueTime | Gets the time spent waiting in queue (ms).
 | RemainingItems | Gets the number of items still to be processed.
 | Status | Gets the current status description.
 | TotalItems | Gets the total number of items to be processed.


Error Property

Error Property
Namespaces ► Sitecore ► IPublishingStatus ► Error
Gets the error.
Declaration Syntax
C#
string Error { get; }
Value
The error.


EstimatedTimeLeft Property

EstimatedTimeLeft Property
Namespaces ► Sitecore ► IPublishingStatus ► EstimatedTimeLeft
Gets the estimated time left (ms).
Declaration Syntax
C#
double EstimatedTimeLeft { get; }
Value
The estimated time left.


ProcessedItems Property

ProcessedItems Property
Namespaces ► Sitecore ► IPublishingStatus ► ProcessedItems
Gets the number of items processed up until now.
Declaration Syntax
C#
uint ProcessedItems { get; }
Value
The processed items.


ProcessingTime Property

ProcessingTime Property
Namespaces ► Sitecore ► IPublishingStatus ► ProcessingTime
Gets the time spent processing up until now (ms).
Declaration Syntax
C#
double ProcessingTime { get; }
Value
The processing time.


QueueIndex Property

QueueIndex Property
Namespaces ► Sitecore ► IPublishingStatus ► QueueIndex
Gets the index in queue.
Declaration Syntax
C#
int QueueIndex { get; }
Value
The index of the queue.
Remarks
Returns -1 if not in queue.


QueueTime Property

QueueTime Property
Namespaces ► Sitecore ► IPublishingStatus ► QueueTime
Gets the time spent waiting in queue (ms).
Declaration Syntax
C#
double QueueTime { get; }
Value
The queue time.


RemainingItems Property

RemainingItems Property
Namespaces ► Sitecore ► IPublishingStatus ► RemainingItems
Gets the number of items still to be processed.
Declaration Syntax
C#
uint RemainingItems { get; }
Value
The remaining items.


Status Property

Status Property
Namespaces ► Sitecore ► IPublishingStatus ► Status
Gets the current status description.
Declaration Syntax
C#
string Status { get; }
Value
The status.


TotalItems Property

TotalItems Property
Namespaces ► Sitecore ► IPublishingStatus ► TotalItems
Gets the total number of items to be processed.
Declaration Syntax
C#
uint TotalItems { get; }
Value
The total items.


ItemIDs Class

ItemIDs Class
Namespaces ► Sitecore ► ItemIDs
Implements a static class for holding assorted well-known GUID values.
Declaration Syntax
C#
public static class ItemIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AnonymousUser | The Anonymous user ID.
 | BranchesRoot | The ID of "/sitecore/templates/branches"
 | ConditionalRenderingsGlobalRules | The ID of the /sitecore/system/Settings/Rules/Conditional Renderings/Global Rules.
 | ContentRoot | The ID of "/sitecore/content"
 | DefaultRibbon | The ID of "/sitecore/content/Applications/Content Editor/Ribbons/Ribbons/Default"
 | DevicesRoot | The ID of "/sitecore/layout/Devices"
 | EveryoneRoleID | The ID of the 'Everyone' role.
 | LanguageRoot | The ID of the '/sitecore/system/language' item.
 | LayoutRoot | The ID of "/sitecore/layout"
 | Layouts | The ID of "/sitecore/layout/layouts"
 | MastersRoot | Obsolete. The ID of "/sitecore/templates/branches"
 | MediaLibraryRoot | The ID of "/sitecore/media library"
 | Null | The Null ID.
 | PlaceholderSettingsRoot | The ID of "/sitecore/layout/Placeholders"
 | Policies | The ID of the root item of the system/policies section
 | RootID | The ID of the Sitecore root item.
 | Shell | The ID of the /sitecore/content/System/Shell item in the core database
 | ShellAll | The ID of the /sitecore/content/System/Shell/__All in the core database
 | ShellDefault | The ID of the /sitecore/content/System/Shell/__Default in the core database
 | SystemRoot | The ID of "/sitecore/system"
 | TemplateRoot | The ID of the root item of the templates section
 | Undefined | ID indicating 'undefined' value.
 | VirtualStructures | Obsolete. The ID of the "/sitecore/system/Virtual Structures" item
 | WorkflowRoot | The ID of the root item of the system/workflows section
Remarks
The class does not contain any functionality, but serves as a placeholder for a predefined GUIDs.
Inheritance Hierarchy
Object
ItemIDs


AnonymousUser Field

AnonymousUser Field
Namespaces ► Sitecore ► ItemIDs ► AnonymousUser
The Anonymous user ID.
Declaration Syntax
C#
public static ID AnonymousUser


BranchesRoot Field

BranchesRoot Field
Namespaces ► Sitecore ► ItemIDs ► BranchesRoot
The ID of "/sitecore/templates/branches"
Declaration Syntax
C#
public static ID BranchesRoot


ConditionalRenderingsGlobalRules Field

ConditionalRenderingsGlobalRules Field
Namespaces ► Sitecore ► ItemIDs ► ConditionalRenderingsGlobalRules
The ID of the /sitecore/system/Settings/Rules/Conditional Renderings/Global Rules.
Declaration Syntax
C#
public static ID ConditionalRenderingsGlobalRules


ContentRoot Field

ContentRoot Field
Namespaces ► Sitecore ► ItemIDs ► ContentRoot
The ID of "/sitecore/content"
Declaration Syntax
C#
public static ID ContentRoot


DefaultRibbon Field

DefaultRibbon Field
Namespaces ► Sitecore ► ItemIDs ► DefaultRibbon
The ID of "/sitecore/content/Applications/Content Editor/Ribbons/Ribbons/Default"
Declaration Syntax
C#
public static ID DefaultRibbon


DevicesRoot Field

DevicesRoot Field
Namespaces ► Sitecore ► ItemIDs ► DevicesRoot
The ID of "/sitecore/layout/Devices"
Declaration Syntax
C#
public static ID DevicesRoot


EveryoneRoleID Field

EveryoneRoleID Field
Namespaces ► Sitecore ► ItemIDs ► EveryoneRoleID
The ID of the 'Everyone' role.
Declaration Syntax
C#
public static ID EveryoneRoleID


LanguageRoot Field

LanguageRoot Field
Namespaces ► Sitecore ► ItemIDs ► LanguageRoot
The ID of the '/sitecore/system/language' item.
Declaration Syntax
C#
public static ID LanguageRoot


LayoutRoot Field

LayoutRoot Field
Namespaces ► Sitecore ► ItemIDs ► LayoutRoot
The ID of "/sitecore/layout"
Declaration Syntax
C#
public static ID LayoutRoot


Layouts Field

Layouts Field
Namespaces ► Sitecore ► ItemIDs ► Layouts
The ID of "/sitecore/layout/layouts"
Declaration Syntax
C#
public static ID Layouts


MastersRoot Field

MastersRoot Field
Namespaces ► Sitecore ► ItemIDs ► MastersRoot
The ID of "/sitecore/templates/branches"
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use BranchesRoot instead.")]
public static ID MastersRoot


MediaLibraryRoot Field

MediaLibraryRoot Field
Namespaces ► Sitecore ► ItemIDs ► MediaLibraryRoot
The ID of "/sitecore/media library"
Declaration Syntax
C#
public static ID MediaLibraryRoot


Null Field

Null Field
Namespaces ► Sitecore ► ItemIDs ► Null
The Null ID.
Declaration Syntax
C#
public static ID Null


PlaceholderSettingsRoot Field

PlaceholderSettingsRoot Field
Namespaces ► Sitecore ► ItemIDs ► PlaceholderSettingsRoot
The ID of "/sitecore/layout/Placeholders"
Declaration Syntax
C#
public static ID PlaceholderSettingsRoot


Policies Field

Policies Field
Namespaces ► Sitecore ► ItemIDs ► Policies
The ID of the root item of the system/policies section
Declaration Syntax
C#
public static ID Policies


RootID Field

RootID Field
Namespaces ► Sitecore ► ItemIDs ► RootID
The ID of the Sitecore root item.
Declaration Syntax
C#
public static ID RootID


Shell Field

Shell Field
Namespaces ► Sitecore ► ItemIDs ► Shell
The ID of the /sitecore/content/System/Shell item in the core database
Declaration Syntax
C#
public static ID Shell


ShellAll Field

ShellAll Field
Namespaces ► Sitecore ► ItemIDs ► ShellAll
The ID of the /sitecore/content/System/Shell/__All in the core database
Declaration Syntax
C#
public static ID ShellAll


ShellDefault Field

ShellDefault Field
Namespaces ► Sitecore ► ItemIDs ► ShellDefault
The ID of the /sitecore/content/System/Shell/__Default in the core database
Declaration Syntax
C#
public static ID ShellDefault


SystemRoot Field

SystemRoot Field
Namespaces ► Sitecore ► ItemIDs ► SystemRoot
The ID of "/sitecore/system"
Declaration Syntax
C#
public static ID SystemRoot


TemplateRoot Field

TemplateRoot Field
Namespaces ► Sitecore ► ItemIDs ► TemplateRoot
The ID of the root item of the templates section
Declaration Syntax
C#
public static ID TemplateRoot


Undefined Field

Undefined Field
Namespaces ► Sitecore ► ItemIDs ► Undefined
ID indicating 'undefined' value.
Declaration Syntax
C#
public static ID Undefined


VirtualStructures Field

VirtualStructures Field
Namespaces ► Sitecore ► ItemIDs ► VirtualStructures
The ID of the "/sitecore/system/Virtual Structures" item
Declaration Syntax
C#
[ObsoleteAttribute("This ID has been deprecated.")]
public static ID VirtualStructures


WorkflowRoot Field

WorkflowRoot Field
Namespaces ► Sitecore ► ItemIDs ► WorkflowRoot
The ID of the root item of the system/workflows section
Declaration Syntax
C#
public static ID WorkflowRoot


ItemIDs.Analytics Class

ItemIDs..::.Analytics Class
Namespaces ► Sitecore ► ItemIDs ► ItemIDs..::.Analytics
Defines the analytics class.
Declaration Syntax
C#
public static class Analytics
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Criteria | ID indicating '/sitecore/system/Settings/Analytics/Filters/Criteria' value.
 | GlobalReports | ID indicating '/sitecore/system/Settings/Analytics/Reports/Reports' value.
 | Macros | ID indicating '/sitecore/system/settings/Analytics/Filters/Macros' value.
 | MarketingCenterItem | ID indicating '/sitecore/system/Marketing Center' value.
 | PageEvents | ID indicating '/sitecore/system/settings/Analytics/Page Events' value.
 | Profiles | ID indicating '/sitecore/system/settings/Analytics/Profiles' value.
 | VisitorIdentifications | ID indicating '/sitecore/system/settings/Analytics/Visitor Identifications' value.
 | VisitorIdentificationTypes | ID indicating '/sitecore/system/settings/Analytics/Visitor Identification Types' value.
Inheritance Hierarchy
Object
ItemIDs..::.Analytics


Criteria Field

Criteria Field
Namespaces ► Sitecore ► ItemIDs..::.Analytics ► Criteria
ID indicating '/sitecore/system/Settings/Analytics/Filters/Criteria' value.
Declaration Syntax
C#
public static ID Criteria


GlobalReports Field

GlobalReports Field
Namespaces ► Sitecore ► ItemIDs..::.Analytics ► GlobalReports
ID indicating '/sitecore/system/Settings/Analytics/Reports/Reports' value.
Declaration Syntax
C#
public static ID GlobalReports


Macros Field

Macros Field
Namespaces ► Sitecore ► ItemIDs..::.Analytics ► Macros
ID indicating '/sitecore/system/settings/Analytics/Filters/Macros' value.
Declaration Syntax
C#
public static ID Macros


MarketingCenterItem Field

MarketingCenterItem Field
Namespaces ► Sitecore ► ItemIDs..::.Analytics ► MarketingCenterItem
ID indicating '/sitecore/system/Marketing Center' value.
Declaration Syntax
C#
public static ID MarketingCenterItem


PageEvents Field

PageEvents Field
Namespaces ► Sitecore ► ItemIDs..::.Analytics ► PageEvents
ID indicating '/sitecore/system/settings/Analytics/Page Events' value.
Declaration Syntax
C#
public static ID PageEvents


Profiles Field

Profiles Field
Namespaces ► Sitecore ► ItemIDs..::.Analytics ► Profiles
ID indicating '/sitecore/system/settings/Analytics/Profiles' value.
Declaration Syntax
C#
public static ID Profiles


VisitorIdentifications Field

VisitorIdentifications Field
Namespaces ► Sitecore ► ItemIDs..::.Analytics ► VisitorIdentifications
ID indicating '/sitecore/system/settings/Analytics/Visitor Identifications' value.
Declaration Syntax
C#
public static ID VisitorIdentifications


VisitorIdentificationTypes Field

VisitorIdentificationTypes Field
Namespaces ► Sitecore ► ItemIDs..::.Analytics ► VisitorIdentificationTypes
ID indicating '/sitecore/system/settings/Analytics/Visitor Identification Types' value.
Declaration Syntax
C#
public static ID VisitorIdentificationTypes


ItemIDs.Analytics.MarketingCenter Class

ItemIDs..::.Analytics..::.MarketingCenter Class
Namespaces ► Sitecore ► ItemIDs..::.Analytics ► ItemIDs..::.Analytics..::.MarketingCenter
Defines the reports class.
Declaration Syntax
C#
public static class MarketingCenter
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Campaigns | ID indicating '/sitecore/system/Marketing Center/Campaigns' value.
 | Policies | ID indicating '/sitecore/system/Marketing Center/Presentation/Policies' value.
 | ReportFilters | ID indicating "/sitecore/system/Marketing Center/Reports/Report Filters" value.
 | TestLaboratory | ID indicating '/sitecore/system/Marketing Center/Test Laboratory' value.
Inheritance Hierarchy
Object
ItemIDs..::.Analytics..::.MarketingCenter


Campaigns Field

Campaigns Field
Namespaces ► Sitecore ► ItemIDs..::.Analytics..::.MarketingCenter ► Campaigns
ID indicating '/sitecore/system/Marketing Center/Campaigns' value.
Declaration Syntax
C#
public static ID Campaigns


Policies Field

Policies Field
Namespaces ► Sitecore ► ItemIDs..::.Analytics..::.MarketingCenter ► Policies
ID indicating '/sitecore/system/Marketing Center/Presentation/Policies' value.
Declaration Syntax
C#
public static ID Policies


ReportFilters Field

ReportFilters Field
Namespaces ► Sitecore ► ItemIDs..::.Analytics..::.MarketingCenter ► ReportFilters
ID indicating "/sitecore/system/Marketing Center/Reports/Report Filters" value.
Declaration Syntax
C#
public static ID ReportFilters


TestLaboratory Field

TestLaboratory Field
Namespaces ► Sitecore ► ItemIDs..::.Analytics..::.MarketingCenter ► TestLaboratory
ID indicating '/sitecore/system/Marketing Center/Test Laboratory' value.
Declaration Syntax
C#
public static ID TestLaboratory


ItemIDs.Analytics.Reports Class

ItemIDs..::.Analytics..::.Reports Class
Namespaces ► Sitecore ► ItemIDs..::.Analytics ► ItemIDs..::.Analytics..::.Reports
Defines the reports class.
Declaration Syntax
C#
public static class Reports
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemReports | ID indicating '/sitecore/system/settings/Analytics/Reports/Item reports' value.
Inheritance Hierarchy
Object
ItemIDs..::.Analytics..::.Reports


ItemReports Field

ItemReports Field
Namespaces ► Sitecore ► ItemIDs..::.Analytics..::.Reports ► ItemReports
ID indicating '/sitecore/system/settings/Analytics/Reports/Item reports' value.
Declaration Syntax
C#
public static ID ItemReports


LayoutFieldIDs Class

LayoutFieldIDs Class
Namespaces ► Sitecore ► LayoutFieldIDs
Fields of the Layout/Layout template.
Declaration Syntax
C#
public static class LayoutFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Path | The ID of the 'Path' field.
Inheritance Hierarchy
Object
LayoutFieldIDs


Path Field

Path Field
Namespaces ► Sitecore ► LayoutFieldIDs ► Path
The ID of the 'Path' field.
Declaration Syntax
C#
public static ID Path


MainUtil Class

MainUtil Class
Namespaces ► Sitecore ► MainUtil
Implements a library of standard utility functions.
Declaration Syntax
C#
public sealed class MainUtil
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MainUtil()()() | Initializes a new instance of the MainUtil class
 | AcquireLock(String) | Obsolete. Acquires a named lock.
 | AddArrays(Array, Array, Type) | Concatenates two arrays.
 | AppendMissingIDBrace(String) | Appends a mssing closing brace "}" if a path starts with a brace "{".
 | BoolToString(Boolean) | Converts a boolean to "true" or "false".
 | BuildHashtable(array<Object>[]()[]) | Builds the hashtable.
 | Capitalize(String) | Obsolete. Uppercases the first letter of a string and lowercases the remaining letters.
 | ClearBit(Int32, Int32) | Resets a bit in an integer.
 | ColorToString(Color) | Converts a color to a string.
 | CombineArrays<(Of <(T>)>)(array<T>[]()[], T) | Combines an array and a value.
 | CombineArrays<(Of <(T>)>)(array<T>[]()[], array<T>[]()[]) | Combines two arrays.
 | CompactArray(array<Object>[]()[], Type) | Compacts an object array by removing null values.
 | CompactArray(array<String>[]()[]) | Compacts a string array by removing empty strings.
 | CompareVersionNumbers(String, String) | Compares two Sitecore version numbers.
 | ContainsUnicodeCharacters(String) | Determines whether the specified string contains unicode characters.
 | ConvertArray(array<Object>[]()[], Type) | Converts an array to another type.
 | ConvertToHashtable(ArrayList) | Converts an array list to a hashtable.
 | ConvertToNameValues(ArrayList) | Converts an array list to a name/value collection.
 | ConvertToNameValues(String, Char) | Converts a string to name/value collection.
 | ConvertToString(ArrayList, Char) | Converts an array list of strings to a single string.
 | ConvertToString(NameValueCollection, Char) | Converts a name/value collection to a single string.
 | ConvertToString(NameValueCollection, String, String) | Converts a name/value collection to a single string.
 | CopyArray(Array, Array, Int32, Int32) | Inserts an array into another array.
 | CreateObject(String, String, array<Object>[]()[]) | Creates an instance of an object.
 | CreateObject(Type) | Creates an instance of an object.
 | CreateObject(Type, array<Object>[]()[]) | Creates an instance of an object.
 | DecodeName(String) | Decodes an item name.
 | EncodeName(String) | Encodes an item name.
 | EncodeNameReplacements | Gets item name encodings.
 | EncodePath(String, Char) | Encodes an item path.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EscapePling(String) | Escapes plings (') or quotes (") in a HTML tag attribute value.
 | ExpandArray(Array, Type) | Expands the array.
 | ExpandArray(Array, Type, Int32) | Expands the array.
 | ExpandSitecorePath(String) | Expands the sitecore path.
 | False()()() | Returns false.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindStartTag(String, String) | Finds an end tag in a string.
 | FormatDouble(Double) | Formats a double.
 | FormatLong(Int64) | Formats a long.
 | FormatSize(Int64) | Formats a number into a size string.
 | GarbageCollect()()() | Performs garbage collection to keep memory usage down.
 | GenerateShortID()()() | Generates a short unique ID.
 | GetArrayList(array<String>[]()[]) | Gets an array list of strings.
 | GetAssemblyName(Type) | Gets the name of the assembly containing a type.
 | GetBackupFilename(String, String, String) | Gets a filename for a backup file.
 | GetBool(Object, Boolean) | Gets the bool.
 | GetBool(String, Boolean) | Gets the boolean value of a string.
 | GetBool(Tristate, Boolean) | Gets a boolean value from a Tristate.
 | GetCallerMethod(Int32) | Gets a reference to a method on the call stack.
 | GetCallerName(Int32) | Gets name of the calling method.
 | GetCallerName()()() | Gets name of the calling method.
 | GetCallerType(Int32) | Gets the type of the caller.
 | GetCallStack()()() | Gets the current call stack.
 | GetCallStack(Int32) | Gets the current call stack.
 | GetCurrentProcessThread()()() | Gets the current process thread.
 | GetDotNetFolder()()() | Gets the root folder of the current .NET Framework.
 | GetDotNetVersion()()() | Gets the version of the current .NET Framework.
 | GetEnumerator<(Of <(T>)>)(IEnumerable<(Of <(T>)>), T) | Combines two enumerators.
 | GetEnumerator<(Of <(T>)>)(IEnumerable<(Of <(T>)>), IEnumerable<(Of <(T>)>)) | Combines two enumerators.
 | GetEnumerator<(Of <(T>)>)(T, IEnumerable<(Of <(T>)>)) | Combines two enumerators.
 | GetEnumerator<(Of <(T>)>)(array<T>[]()[]) | Combines two enumerators.
 | GetExceptionMessage(Exception) | Gets the message from an exception.
 | GetExtraEntries(Hashtable, Hashtable) | Gets the extra entries in one hashtable compared to another.
 | GetFileLock(String) | Obsolete. Gets file specific lock object.
 | GetFileTime(String) | Obsolete. Gets the last modified time of a file.
 | GetFileWriteTime(String) | Obsolete. Gets the last modified time of a file.
 | GetFloat(String, Single) | Gets the float value of a string.
 | GetGuid(Object) | Gets a guid from a string.
 | GetGuid(Object, Guid) | Gets a guid from a string.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHashtable(array<Object>[]()[], Boolean) | Gets a Hashtable from a list of objects.
 | GetID(Object) | Gets the ID.
 | GetID(Guid) | Gets the ID.
 | GetID(Object, ID) | Gets the ID.
 | GetID(String, ID) | Gets the ID.
 | GetImage(String) | Gets an image HTML tag.
 | GetImage(String, Boolean) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Int32, Int32) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Boolean) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Int32, Int32, Boolean, Boolean) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean) | Gets an image HTML tag.
 | GetInt(Object, Int32) | Gets the integer value of a string.
 | GetInt(String, Int32) | Gets the integer value of a string.
 | GetInt(Int32, Int32) | Gets an int different from zero.
 | GetLong(Object, Int64) | Gets the integer long value of a string.
 | GetMD5Hash(String) | Gets the MD5 hash.
 | GetNameValues(String) | Obsolete. Converts a string to a name/value collection.
 | GetNameValues(String, Char, Char) | Obsolete. Converts a string to a name/value collection.
 | GetNameValues(array<String>[]()[]) | Obsolete. Gets a name/value collection from a string array.
 | GetNewID()()() | Generates a new GUID.
 | GetNextSequence()()() | Gets next value of the sequencer.
 | GetNextVarNameSequence(Int32) | Gets next value of the variable name sequencer, optionally resetting it if it has reached a certain maximum.
 | GetObject(Object, Object) | Gets an object reference.
 | GetPrivateBytesUsed()()() | Gets the memory used.
 | GetProcessID()()() | Get current process info.
 | GetProcessInfo()()() | Obsolete. Get current process info.
 | GetProcessName()()() | Gets the name of the current process.
 | GetRequestFlag(String, Boolean) | Gets a boolean flag from the query string.
 | GetRequestInt(String, Int32) | Gets an integer from the query string.
 | GetSequencer()()() | Gets the current sequencer value.
 | GetSingleton<(Of <(T>)>)(T%, Func<(Of <(T>)>)) | Gets a singleton.
 | GetSortKey(String) | Generates a unique sort key.
 | GetSortKey(String, String) | Generates a unique sort key.
 | GetSpacer(Int32, Int32) | Obsolete. Gets an image HTML tag with a blank image.
 | GetSpacer(Int32, Int32, Boolean) | Obsolete. Gets an image HTML tag with a blank image.
 | GetString(Object) | Obsolete. Gets the string value of an object.
 | GetString(Object, String) | Obsolete. Gets the string value of an object.
 | GetStringList(Boolean, array<String>[]()[]) | Gets an array list of strings.
 | GetThreadID()()() | Gets the current thread ID.
 | GetTicks()()() | Gets the ticks.
 | GetTristate(Object, Tristate) | Gets the tristate.
 | GetTristate(Boolean) | Gets a tristate from a bool.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniqueID()()() | Generates a unique ID.
 | GetWebItemSource()()() | Gets the web item data source from the query string.
 | GetWebItemSource(String) | Gets the web item data source from the query string.
 | GetWord(String, Int32, array<Char>[]()[]) | Gets n'th word from a string.
 | GetWorkFileName(String, String, String) | Gets a unique filename.
 | GetWorkingSetSize()()() | Gets size of current working set.
 | GuidToString(Guid) | Converts guid to string.
 | GuidToString(Guid, String) | Converts guid to string.
 | HexToColor(String) | Converts a hex string to a color.
 | HexToInt(String, Int32) | Converts a hex string to an integer.
 | Html(String) | Writes a line of HTML to the Response output stream.
 | Ignore(array<Object>[]()[]) | Ignores the specified parameters.
 | IndexOf(Object, array<Object>[]()[]) | Gets the index of an object in an array.
 | IntToHex(Int32) | Converts an integer to a hex string.
 | IsBitSet(Int32, Int32) | Determines whether the specified bit is set.
 | IsEmpty(String) | Determines whether the specified string is empty.
 | IsFullPath(String) | Determines whether the specified path is a full path.
 | IsID(String) | Checks if string is a valid GUID.
 | IsType(Object, Type) | Checks if an object is of a given type
 | IsType(Type, Type) | Checks if an object is of a given type
 | IsXPath(String) | Checks if a string contains an XPath expression.
 | Join(String, String, String) | Joins two strings excluding any empty string from the result.
 | Join(String, array<String>[]()[]) | Joins an array of strings excluding any empty string from the result.
 | MakeFilePath(String, String) | Builds a file path from a folder and a file.
 | MakeFilePath(String, String, Boolean) | Builds a file path from a folder and a file.
 | MakePath(String, String, Char) | Obsolete. Makes a path from two filename parts.
 | MapPath(String) | Maps a virtual file path to a physical file path.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MsgBox(String) | Shows a message box.
 | MsgBox(String, String) | Shows a message box.
 | Nop(array<Object>[]()[]) | No-op
 | NormalizeGuid(Guid) | Normalizes a GUID.
 | NormalizeGuid(String) | Normalizes a GUID.
 | NormalizeItemName(String) | Normalizes an item name.
 | Out(String) | Writes a line of HTML to the Response output stream.
 | Out(String, Boolean) | Writes a line of HTML to the Response output stream.
 | RaiseEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Fires an event
 | ReadFromFile(String) | Obsolete. Reads a text file.
 | ReleaseLock(String) | Obsolete. Release a named lock
 | RemoveEmptyStrings(array<String>[]()[]) | Removes the empty strings.
 | RemoveEnd(String, Int32) | Removes a number of characters from the end of a string.
 | RemoveFromArray(Array, Int32) | Removes from array.
 | RemoveStart(String, Int32) | Remove the first characters from a string.
 | ReplaceItemIDs(XmlDocument) | Replaces all item IDs in an XML document with new GUIDs.
 | ReplacePostfix(String, String, String) | Replaces the postfix of a string.
 | ReplacePrefix(String, String, String) | Replaces the prefix of a string.
 | SendMail(MailMessage) | Obsolete. Sends the mail.
 | SendMail(MailMessage) | Sends the mail.
 | SetBit(Int32, Int32) | Sets the bit.
 | ShortenGuid(String) | Shortens a GUID by removing braces and hyphens.
 | ShrinkArray(Array, Type) | Shrinks the array.
 | ShrinkArray(Array, Type, Int32) | Compacts an object array by removing nulls.
 | SilentCatch()()() | Method to call when doing silent catches. Causes the Resharper warning to disappear.
 | Split(String, Char) | Splits a string into an array of strings.
 | Split(String, Char, Boolean) | Splits a string into an array of strings.
 | Split(String, String) | Splits a string into an array of strings.
 | Split(String, String, Boolean) | Splits a string into an array of strings.
 | SplitPath(String, Boolean) | Splits a Sitecore path into parts, optionally expanding it to include the root.
 | StringToBool(String, Boolean) | Converts a string to boolean.
 | StringToColor(String) | Converts a string to a color.
 | Substring(String, Int32, Int32) | Retrieves a substring from a string. The substring starts at a specified character position and has a specified length.
 | Substring(String, Int32, Boolean) | Gets a substring of maximum length of a string.
 | TerminateAspNet()()() | Terminates the ASP.NET worker process.
 | TerminateAspNet(String) | Terminates the ASP.NET worker process.
 | ThemedImage(String) | Gets a themed image path.
 | ThemedImage(String, ImageDimension) | Gets a themed image path.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Touch(array<Object>[]()[]) | Touch
 | Trace(String) | Writes a message to the trace.
 | TraceIf(Boolean, String) | Conditionally writes a message to the trace.
 | TristateToString(Tristate) | Converts a Tristate to a string.
 | True()()() | Returns true.
 | UnmapPath(String) | Maps a physical path to a virtual path.
 | Unquote(String) | Obsolete. Removes enclosing single and double quotes from a string.
 | VerifyCallLevel(Int32, String) | Verifies that a call level has not exceeded the maximum specified in the setting 'MaxCallLevel'.
 | Warn(String) | Writes a warning message to the trace.
 | WriteToFile(String, array<Byte>[]()[]%) | Obsolete. Writes a byte array to a file.
 | WriteToFile(String, String) | Obsolete. Writes a string to a file.
 | WriteToFile(String, String, Boolean) | Obsolete. Write or appends a atring to a file.
Remarks
The MainUtil library covers both string and file utility functions. These function at a later point be moved to the StringUtil and FileUtil classes.
Inheritance Hierarchy
Object
MainUtil
See Also
DateUtil
FileUtil
HtmlUtil
StringUtil
WebUtil
XmlUtil


MainUtil Constructor

MainUtil Constructor
Namespaces ► Sitecore ► MainUtil ► MainUtil()()()
Initializes a new instance of the MainUtil class
Declaration Syntax
C#
public MainUtil()


AcquireLock Method (name)

AcquireLock Method (name)
Namespaces ► Sitecore ► MainUtil ► AcquireLock(String)
Acquires a named lock.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static CounterLock AcquireLock(
    string name
)
Parameters
name (String)
The name.
Return Value


AddArrays Method (array1, array2, elementType)

AddArrays Method (array1, array2, elementType)
Namespaces ► Sitecore ► MainUtil ► AddArrays(Array, Array, Type)
Concatenates two arrays.
Declaration Syntax
C#
public static Array AddArrays(
    Array array1,
    Array array2,
    Type elementType
)
Parameters
array1 (Array)
The array1.
array2 (Array)
The array2.
elementType (Type)
Type of the element.
Return Value


AppendMissingIDBrace Method (sPath)

AppendMissingIDBrace Method (sPath)
Namespaces ► Sitecore ► MainUtil ► AppendMissingIDBrace(String)
Appends a mssing closing brace "}" if a path starts with a brace "{".
Declaration Syntax
C#
public static string AppendMissingIDBrace(
    string sPath
)
Parameters
sPath (String)
A path.
Return Value
The path ending with a closing brace "}".
Remarks
This function is usually called to ensure that a GUID ends with a closing brace "}". This can occur if a web page is opened from Outlook by a pasted link as Outlook does not automatically include the ending brace "}".
Examples
CopyC#
string path = StringUtil.GetString(Request.QueryString["path"]);
string id = MainUtil.AppendMissingIDBrace(path);


BoolToString Method (b)

BoolToString Method (b)
Namespaces ► Sitecore ► MainUtil ► BoolToString(Boolean)
Converts a boolean to "true" or "false".
Declaration Syntax
C#
public static string BoolToString(
    bool b
)
Parameters
b (Boolean)
A boolean value.
Return Value
If the boolean is true, "true", otherwise "false".
Examples
CopyC#
string trueString = MainUtil.BoolToString(1 = 1); // "true"
string falseString = MainUtil.BoolToString(1 = 0); // "false"


BuildHashtable Method (objects)

BuildHashtable Method (objects)
Namespaces ► Sitecore ► MainUtil ► BuildHashtable(array<Object>[]()[])
Builds the hashtable.
Declaration Syntax
C#
public static Hashtable BuildHashtable(
    params Object[] objects
)
Parameters
objects (array< Object >[]()[])
The objects.
Return Value


Capitalize Method (text)

Capitalize Method (text)
Namespaces ► Sitecore ► MainUtil ► Capitalize(String)
Uppercases the first letter of a string and lowercases the remaining letters.
Declaration Syntax
C#
[ObsoleteAttribute("Use StringUtil.Capitalize instead.")]
public static string Capitalize(
    string text
)
Parameters
text (String)
A string.
Return Value
The capitalized string.
Remarks
Sentences are not taken into account.
Examples
CopyC#
string text = MainUtil.Capitalize("HELLO WORLD."); // "Hello world"
string text = MainUtil.Capitalize("HELLO. HOW ARE YOU?"); // "Hello. how are you?"


ClearBit Method (bit, bits)

ClearBit Method (bit, bits)
Namespaces ► Sitecore ► MainUtil ► ClearBit(Int32, Int32)
Resets a bit in an integer.
Declaration Syntax
C#
public static int ClearBit(
    int bit,
    int bits
)
Parameters
bit (Int32)
The bit.
bits (Int32)
The bits.
Return Value


ColorToString Method (color)

ColorToString Method (color)
Namespaces ► Sitecore ► MainUtil ► ColorToString(Color)
Converts a color to a string.
Declaration Syntax
C#
public static string ColorToString(
    Color color
)
Parameters
color (Color)
The color.
Return Value


CombineArrays Method

CombineArrays Method
Namespaces ► Sitecore ► MainUtil ► CombineArrays()()()
Members
Icon | Member | Description
 | CombineArrays<(Of <(T>)>)(array<T>[]()[], T) | Combines an array and a value.
 | CombineArrays<(Of <(T>)>)(array<T>[]()[], array<T>[]()[]) | Combines two arrays.


CombineArrays Method (values, value)

CombineArrays<(Of <(T>)>) Method (values, value)
Namespaces ► Sitecore ► MainUtil ► CombineArrays<(Of <(T>)>)(array<T>[]()[], T)
Combines an array and a value.
Declaration Syntax
C#
public static T[] CombineArrays<T>(
    T[] values,
    T value
)
Generic Template Parameters
T
The type of the arrrays.
Parameters
values (array< T >[]()[])
The values.
value (T)
The value.


CombineArrays Method (values1, values2)

CombineArrays<(Of <(T>)>) Method (values1, values2)
Namespaces ► Sitecore ► MainUtil ► CombineArrays<(Of <(T>)>)(array<T>[]()[], array<T>[]()[])
Combines two arrays.
Declaration Syntax
C#
public static T[] CombineArrays<T>(
    T[] values1,
    T[] values2
)
Generic Template Parameters
T
The type of the arrrays.
Parameters
values1 (array< T >[]()[])
The first array of values.
values2 (array< T >[]()[])
The second array of values.


CompactArray Method

CompactArray Method
Namespaces ► Sitecore ► MainUtil ► CompactArray()()()
Members
Icon | Member | Description
 | CompactArray(array<Object>[]()[], Type) | Compacts an object array by removing null values.
 | CompactArray(array<String>[]()[]) | Compacts a string array by removing empty strings.


CompactArray Method (array, elementType)

CompactArray Method (array, elementType)
Namespaces ► Sitecore ► MainUtil ► CompactArray(array<Object>[]()[], Type)
Compacts an object array by removing null values.
Declaration Syntax
C#
public static Object CompactArray(
    Object[] array,
    Type elementType
)
Parameters
array (array< Object >[]()[])
An array of object.
elementType (Type)
Type of the element.
Return Value
The compacted array of object.


CompactArray Method (array)

CompactArray Method (array)
Namespaces ► Sitecore ► MainUtil ► CompactArray(array<String>[]()[])
Compacts a string array by removing empty strings.
Declaration Syntax
C#
public static string[] CompactArray(
    string[] array
)
Parameters
array (array< String >[]()[])
An array of string.
Return Value
The compacted array of string.
Examples
CopyC#
string[] texts = new string[] {"My", "", "Text, ""};
string[] compact = MainUtil.CompactArray(texts): // { "My", "Text" }


CompareVersionNumbers Method (ver1, ver2)

CompareVersionNumbers Method (ver1, ver2)
Namespaces ► Sitecore ► MainUtil ► CompareVersionNumbers(String, String)
Compares two Sitecore version numbers.
Declaration Syntax
C#
public static int CompareVersionNumbers(
    string ver1,
    string ver2
)
Parameters
ver1 (String)
A version number, e.g. "x.x.x"
ver2 (String)
A version number, e.g. "x.x.x"
Return Value
0 if the versions numbers are identical, -1 if ver1 < ver2, 1 if ver1 > ver2.
Examples
CopyC#
int compare0 = MainUtil.CompareVersionNumbers("1.0.1", "1.1.0"); // -1
int compare1 = MainUtil.CompareVersionNumbers("1.0.1", "1.0.0"); // 1


ContainsUnicodeCharacters Method (str)

ContainsUnicodeCharacters Method (str)
Namespaces ► Sitecore ► MainUtil ► ContainsUnicodeCharacters(String)
Determines whether the specified string contains unicode characters.
Declaration Syntax
C#
public static bool ContainsUnicodeCharacters(
    string str
)
Parameters
str (String)
The string.
Return Value
true if the specified string contains unicode characters; otherwise, false.


ConvertArray Method (array, elementType)

ConvertArray Method (array, elementType)
Namespaces ► Sitecore ► MainUtil ► ConvertArray(array<Object>[]()[], Type)
Converts an array to another type.
Declaration Syntax
C#
public static Object ConvertArray(
    Object[] array,
    Type elementType
)
Parameters
array (array< Object >[]()[])
An array of objects.
elementType (Type)
Type of the element.
Return Value
The converted array of objects.


ConvertToHashtable Method (list)

ConvertToHashtable Method (list)
Namespaces ► Sitecore ► MainUtil ► ConvertToHashtable(ArrayList)
Converts an array list to a hashtable.
Declaration Syntax
C#
public static Hashtable ConvertToHashtable(
    ArrayList list
)
Parameters
list (ArrayList)
An array list of values.
Return Value
A hashtable.
Remarks
The hashtable collection is built by using values from the array list in pairs. An array list consisting of { "Name1", "Value1", "Name2", "Value2" } are converted to ("Name1", "Value1"), ("Name2", "Value2").
Examples
CopyC#
ArrayList list = new ArrayList(new string[] {"Name1", "Value1", "Name2", "Value2"});
Hashtable collection = MainUtil.ConvertToHashtable(list);


ConvertToNameValues Method

ConvertToNameValues Method
Namespaces ► Sitecore ► MainUtil ► ConvertToNameValues()()()
Members
Icon | Member | Description
 | ConvertToNameValues(ArrayList) | Converts an array list to a name/value collection.
 | ConvertToNameValues(String, Char) | Converts a string to name/value collection.


ConvertToNameValues Method (list)

ConvertToNameValues Method (list)
Namespaces ► Sitecore ► MainUtil ► ConvertToNameValues(ArrayList)
Converts an array list to a name/value collection.
Declaration Syntax
C#
public static NameValueCollection ConvertToNameValues(
    ArrayList list
)
Parameters
list (ArrayList)
An array list of values.
Return Value
A name/value collection.
Remarks
The name/value collection is built by using values from the array list in pairs. An array list consisting of { "Name1", "Value1", "Name2", "Value2" } are converted to ("Name1", "Value1"), ("Name2", "Value2").
Examples
CopyC#
ArrayList list = new ArrayList(new string[] {"Name1", "Value1", "Name2", "Value2"});
NameValueCollection collection = MainUtil.ConvertToNameValues(list);


ConvertToNameValues Method (values, separator)

ConvertToNameValues Method (values, separator)
Namespaces ► Sitecore ► MainUtil ► ConvertToNameValues(String, Char)
Converts a string to name/value collection.
Declaration Syntax
C#
public static NameValueCollection ConvertToNameValues(
    string values,
    char separator
)
Parameters
values (String)
A string of seperated values.
separator (Char)
A separator character.
Return Value
A name/value collection.
Remarks
The name/value collection is built by using values from the string in pairs. A string consisting of "Name1|Value1|Name2|Value2" are converted to ("Name1", "Value1"), ("Name2", "Value2").
Examples
CopyC#
NameValueCollection collection = MainUtil.ConvertToNameValues("Name1|Value1|Name2|Value2", '|');


ConvertToString Method

ConvertToString Method
Namespaces ► Sitecore ► MainUtil ► ConvertToString()()()
Members
Icon | Member | Description
 | ConvertToString(ArrayList, Char) | Converts an array list of strings to a single string.
 | ConvertToString(NameValueCollection, Char) | Converts a name/value collection to a single string.
 | ConvertToString(NameValueCollection, String, String) | Converts a name/value collection to a single string.


ConvertToString Method (list, separator)

ConvertToString Method (list, separator)
Namespaces ► Sitecore ► MainUtil ► ConvertToString(ArrayList, Char)
Converts an array list of strings to a single string.
Declaration Syntax
C#
public static string ConvertToString(
    ArrayList list,
    char separator
)
Parameters
list (ArrayList)
An array list.
separator (Char)
A separator character.
Return Value
A string containing the list seperated by the separator character.
Remarks
If the array list is null, blank is returned.
Examples
CopyC#
ArrayList list = new ArrayList(new string[] {"Name1", "Value1", "Name2", "Value2"});
string s = MainUtil.ConvertToString(list, '|'); // "Name1|Value1|Name2|Value2"


ConvertToString Method (col, separator)

ConvertToString Method (col, separator)
Namespaces ► Sitecore ► MainUtil ► ConvertToString(NameValueCollection, Char)
Converts a name/value collection to a single string.
Declaration Syntax
C#
public static string ConvertToString(
    NameValueCollection col,
    char separator
)
Parameters
col (NameValueCollection)
A name/value collection.
separator (Char)
A separator character.
Return Value
A string containing the name/value collection separated by the separator character.
Remarks
If the collection is null, blank is returned.
Examples
CopyC#
ArrayList list = new ArrayList(new string[] {"Name1", "Value1", "Name2", "Value2"});
NameValueCollection collection = MainUtil.ConvertToNamevalues(list);
string s = MainUtil.ConvertToString(collection, '|'); // "Name1|Value1|Name2|Value2"


ConvertToString Method (col, sep1, sep2)

ConvertToString Method (col, sep1, sep2)
Namespaces ► Sitecore ► MainUtil ► ConvertToString(NameValueCollection, String, String)
Converts a name/value collection to a single string.
Declaration Syntax
C#
public static string ConvertToString(
    NameValueCollection col,
    string sep1,
    string sep2
)
Parameters
col (NameValueCollection)
A name/value collection.
sep1 (String)
The separator between values.
sep2 (String)
The separator between values paits.
Return Value
A string containing the name/value collection seperated by the separator characters.
Remarks
If the collection is null, blank is returned.
Examples
CopyC#
ArrayList list = new ArrayList(new string[] {"Name1", "Value1", "Name2", "Value2"});
NameValueCollection collection = MainUtil.ConvertToNamevalues(list);
string s = MainUtil.ConvertToString(collection, ", ", " and "); // "Name1, Value1 and Name2, Value2"


CopyArray Method (source, destination, startIndex, count)

CopyArray Method (source, destination, startIndex, count)
Namespaces ► Sitecore ► MainUtil ► CopyArray(Array, Array, Int32, Int32)
Inserts an array into another array.
Declaration Syntax
C#
public static void CopyArray(
    Array source,
    Array destination,
    int startIndex,
    int count
)
Parameters
source (Array)
The source.
destination (Array)
The destination.
startIndex (Int32)
The start index.
count (Int32)
The count.


CreateObject Method

CreateObject Method
Namespaces ► Sitecore ► MainUtil ► CreateObject()()()
Members
Icon | Member | Description
 | CreateObject(String, String, array<Object>[]()[]) | Creates an instance of an object.
 | CreateObject(Type) | Creates an instance of an object.
 | CreateObject(Type, array<Object>[]()[]) | Creates an instance of an object.


CreateObject Method (assembly, className, parameters)

CreateObject Method (assembly, className, parameters)
Namespaces ► Sitecore ► MainUtil ► CreateObject(String, String, array<Object>[]()[])
Creates an instance of an object.
Declaration Syntax
C#
public static Object CreateObject(
    string assembly,
    string className,
    params Object[] parameters
)
Parameters
assembly (String)
An assembly file name.
className (String)
A class name.
parameters (array< Object >[]()[])
Parameters.
Return Value
The instantiated object or null if the object could not be instantiated.
Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).
Examples
CopyC#
object MyObject = MainUtil.CreateObject("/bin/MyAssembly.dll", "MyNamespace.MyObject");
object MyObject2 = MainUtil.CreateObject("MyAssembly", "MyNamespace.MyObject2", parameter1, parameter2);


CreateObject Method (type)

CreateObject Method (type)
Namespaces ► Sitecore ► MainUtil ► CreateObject(Type)
Creates an instance of an object.
Declaration Syntax
C#
public static Object CreateObject(
    Type type
)
Parameters
type (Type)
Name of both assembly and class of the object.
Return Value
The instantiated object or null if the object could not be instantiated.
Remarks
If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).
Examples
CopyC#
object MyObject = MainUtil.CreateObject(myType);


CreateObject Method (type, parameters)

CreateObject Method (type, parameters)
Namespaces ► Sitecore ► MainUtil ► CreateObject(Type, array<Object>[]()[])
Creates an instance of an object.
Declaration Syntax
C#
public static Object CreateObject(
    Type type,
    Object[] parameters
)
Parameters
type (Type)
Name of both assembly and class of the object.
parameters (array< Object >[]()[])
Parameters.
Return Value
The instantiated object or null if the object could not be instantiated.
Remarks
If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).
Examples
CopyC#
object MyObject = MainUtil.CreateObject("MyAssembly.MyObject", parameter1, parameter2);


DecodeName Method (name)

DecodeName Method (name)
Namespaces ► Sitecore ► MainUtil ► DecodeName(String)
Decodes an item name.
Declaration Syntax
C#
public static string DecodeName(
    string name
)
Parameters
name (String)
An item name.
Return Value
The decoded name.
Remarks

It can be necessary to encode item names to ensure working friendly URLs. For instance the item name "Bruun & Rasmussen" contains the character "&" which is URL automatically escaped by most browsers.

The encoding is configured in the web.config section <encodeNameReplacements>.

Examples
CopyC#
IMasterItem item = MasterFactory.GetItem("/sitecore/content/Home/Bruun & Rasmussen");
string encodedName = MainUtil.EncodeName(item.Name); // "Bruun --a-- Rasmussen"
string decodedName = MainUtil.DecodeName(encodedName); // "Bruun & Rasmussen"
See Also
EncodeName(String)


EncodeName Method (name)

EncodeName Method (name)
Namespaces ► Sitecore ► MainUtil ► EncodeName(String)
Encodes an item name.
Declaration Syntax
C#
public static string EncodeName(
    string name
)
Parameters
name (String)
An item name.
Return Value
The encoded name.
Remarks

It can be necessary to encode item names to ensure working friendly URLs. For instance the item name "Bruun & Rasmussen" contains the character "&" which is URL automatically escaped by most browsers.

The encoding is configured in the web.config section <encodeNameReplacements>.

Examples
CopyC#
IMasterItem item = MasterFactory.GetItem("/sitecore/content/Home/Bruun & Rasmussen");
string encodedName = MainUtil.EncodeName(item.Name); // "Bruun ,-a-, Rasmussen"
string decodedName = MainUtil.DecodeName(encodedName); // "Bruun & Rasmussen"
See Also
DecodeName(String)


EncodeNameReplacements Property

EncodeNameReplacements Property
Namespaces ► Sitecore ► MainUtil ► EncodeNameReplacements
Gets item name encodings.
Declaration Syntax
C#
public static string[] EncodeNameReplacements { get; }
Value
The encode name replacements.


EncodePath Method (path, separator)

EncodePath Method (path, separator)
Namespaces ► Sitecore ► MainUtil ► EncodePath(String, Char)
Encodes an item path.
Declaration Syntax
C#
public static string EncodePath(
    string path,
    char separator
)
Parameters
path (String)
An item path.
separator (Char)
The separator used between elements of the path
Return Value
The encoded path.
Remarks

It can be necessary to encode item names to ensure working friendly URLs. For instance the item name "Bruun & Rasmussen" contains the character "&" which is URL automatically escaped by most browsers.

The encoding is configured in the web.config section <encodeNameReplacements>.

Examples
CopyC#
string encodedPath = MainUtil.EncodePath("/home/Bruun & Rasmussen"); // "/home/Bruun ,-a-, Rasmussen"
See Also
DecodeName(String)


EscapePling Method (attribute)

EscapePling Method (attribute)
Namespaces ► Sitecore ► MainUtil ► EscapePling(String)
Escapes plings (') or quotes (") in a HTML tag attribute value.
Declaration Syntax
C#
public static string EscapePling(
    string attribute
)
Parameters
attribute (String)
An attribute value.
Return Value
The escaped value.
Remarks
When adding attribute values to an HTML tag, it can be necessaty to escaping single quotes (plings or "'") in the value.
Examples
CopyC#
string attr = MainUtil.EscapePling("Allan's attribute"); // "Allan&#39;s attribute"


ExpandArray Method

ExpandArray Method
Namespaces ► Sitecore ► MainUtil ► ExpandArray()()()
Members
Icon | Member | Description
 | ExpandArray(Array, Type) | Expands the array.
 | ExpandArray(Array, Type, Int32) | Expands the array.


ExpandArray Method (array, elementType)

ExpandArray Method (array, elementType)
Namespaces ► Sitecore ► MainUtil ► ExpandArray(Array, Type)
Expands the array.
Declaration Syntax
C#
public static Array ExpandArray(
    Array array,
    Type elementType
)
Parameters
array (Array)
The array.
elementType (Type)
Type of the element.
Return Value


ExpandArray Method (array, elementType, newSize)

ExpandArray Method (array, elementType, newSize)
Namespaces ► Sitecore ► MainUtil ► ExpandArray(Array, Type, Int32)
Expands the array.
Declaration Syntax
C#
public static Array ExpandArray(
    Array array,
    Type elementType,
    int newSize
)
Parameters
array (Array)
The array.
elementType (Type)
Type of the element.
newSize (Int32)
The new size.
Return Value


ExpandSitecorePath Method (path)

ExpandSitecorePath Method (path)
Namespaces ► Sitecore ► MainUtil ► ExpandSitecorePath(String)
Expands the sitecore path.
Declaration Syntax
C#
public static string ExpandSitecorePath(
    string path
)
Parameters
path (String)
The path.
Return Value


False Method

False Method
Namespaces ► Sitecore ► MainUtil ► False()()()
Returns false.
Declaration Syntax
C#
public static bool False()
Return Value


FindStartTag Method (sTagName, sText)

FindStartTag Method (sTagName, sText)
Namespaces ► Sitecore ► MainUtil ► FindStartTag(String, String)
Finds an end tag in a string.
Declaration Syntax
C#
public static Match FindStartTag(
    string sTagName,
    string sText
)
Parameters
sTagName (String)
A tag name, e.g. "div".
sText (String)
A string.
Return Value
A regular expression Match object.
Examples
CopyC#
Match match = HtmlUtil.FindEndTag("div", "<div>This is my HTML</div>");


FormatDouble Method (value)

FormatDouble Method (value)
Namespaces ► Sitecore ► MainUtil ► FormatDouble(Double)
Formats a double.
Declaration Syntax
C#
public static string FormatDouble(
    double value
)
Parameters
value (Double)


FormatLong Method (value)

FormatLong Method (value)
Namespaces ► Sitecore ► MainUtil ► FormatLong(Int64)
Formats a long.
Declaration Syntax
C#
public static string FormatLong(
    long value
)
Parameters
value (Int64)


FormatSize Method (size)

FormatSize Method (size)
Namespaces ► Sitecore ► MainUtil ► FormatSize(Int64)
Formats a number into a size string.
Declaration Syntax
C#
public static string FormatSize(
    long size
)
Parameters
size (Int64)
Remarks
Size strings are "10 KB" or "2 MB".


GarbageCollect Method

GarbageCollect Method
Namespaces ► Sitecore ► MainUtil ► GarbageCollect()()()
Performs garbage collection to keep memory usage down.
Declaration Syntax
C#
public static void GarbageCollect()


GenerateShortID Method

GenerateShortID Method
Namespaces ► Sitecore ► MainUtil ► GenerateShortID()()()
Generates a short unique ID.
Declaration Syntax
C#
public static string GenerateShortID()
Return Value
A short unique ID like "scid12".
Remarks
The serial number is generated from a threadsafe counter.
Examples
CopyC#
string myID = MainUtil.GenerateShortID(); // "scid1"


GetArrayList Method (strings)

GetArrayList Method (strings)
Namespaces ► Sitecore ► MainUtil ► GetArrayList(array<String>[]()[])
Gets an array list of strings.
Declaration Syntax
C#
public static ArrayList GetArrayList(
    params string[] strings
)
Parameters
strings (array< String >[]()[])
Strings
Return Value
An array list containing the strings.
Examples
CopyC#
ArrayList list = MainUtil.GetArrayList("Item1", "Item2", "Item3");


GetAssemblyName Method (type)

GetAssemblyName Method (type)
Namespaces ► Sitecore ► MainUtil ► GetAssemblyName(Type)
Gets the name of the assembly containing a type.
Declaration Syntax
C#
public static string GetAssemblyName(
    Type type
)
Parameters
type (Type)
A type.
Return Value
The name of the assembly containg the type.
Examples
CopyC#
string assemblyName = MainUtil.GetAssemblyName(Sitecore.MasterFactory.GetType()); // "Sitecore.Kernel"


GetBackupFilename Method (folder, prefix, extension)

GetBackupFilename Method (folder, prefix, extension)
Namespaces ► Sitecore ► MainUtil ► GetBackupFilename(String, String, String)
Gets a filename for a backup file.
Declaration Syntax
C#
public static string GetBackupFilename(
    string folder,
    string prefix,
    string extension
)
Parameters
folder (String)
The folder of a file.
prefix (String)
The file prefix of a file (usually the filename itself).
extension (String)
The extension of a file.
Return Value
A unique filename.
Remarks
This function is deprecated - use FileUtil.GetBackupFilename instead.
See Also
GetBackupFilename(String)


GetBool Method

GetBool Method
Namespaces ► Sitecore ► MainUtil ► GetBool()()()
Members
Icon | Member | Description
 | GetBool(Object, Boolean) | Gets the bool.
 | GetBool(String, Boolean) | Gets the boolean value of a string.
 | GetBool(Tristate, Boolean) | Gets a boolean value from a Tristate.


GetBool Method (value, defaultValue)

GetBool Method (value, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GetBool(Tristate, Boolean)
Gets a boolean value from a Tristate.
Declaration Syntax
C#
public static bool GetBool(
    Tristate value,
    bool defaultValue
)
Parameters
value (Tristate)
The value.
defaultValue (Boolean)
if set to true [default value].
Return Value


GetBool Method (obj, defaultValue)

GetBool Method (obj, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GetBool(Object, Boolean)
Gets the bool.
Declaration Syntax
C#
public static bool GetBool(
    Object obj,
    bool defaultValue
)
Parameters
obj (Object)
The object.
defaultValue (Boolean)
if set to true this instance is _default.
Return Value


GetBool Method (value, defaultValue)

GetBool Method (value, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GetBool(String, Boolean)
Gets the boolean value of a string.
Declaration Syntax
C#
public static bool GetBool(
    string value,
    bool defaultValue
)
Parameters
value (String)
A string.
defaultValue (Boolean)
A default boolean value.
Return Value
The boolean value of the string.
Remarks
The boolean value is true, if the string is one of the following values (case-insensitive):
  • true
  • yes
  • 1

Otherwise the value is false.

The default value is returned if the string is blank or null.

Examples
CopyC#
bool b0 = MainUtil.BoolToString("true", false); // true
bool b1 = MainUtil.BoolToString("True", false); // true
bool b2 = MainUtil.BoolToString("yes", false); // true
bool b3 = MainUtil.BoolToString("1", false); // true
bool b4 = MainUtil.BoolToString("no", false); // false
bool b5 = MainUtil.BoolToString("false", false); // false
bool b6 = MainUtil.BoolToString("", false); // false
bool b6 = MainUtil.BoolToString("", true); // true
bool b6 = MainUtil.BoolToString(null, true); // true


GetCallerMethod Method (indexInStack)

GetCallerMethod Method (indexInStack)
Namespaces ► Sitecore ► MainUtil ► GetCallerMethod(Int32)
Gets a reference to a method on the call stack.
Declaration Syntax
C#
public static MethodBase GetCallerMethod(
    int indexInStack
)
Parameters
indexInStack (Int32)
Index of method on the stack.
Return Value
A method.
Remarks
Use 1 to get the name of the function calling GetStackMethod, 2 to get the function calling that etc.
See Also
GetCallerName()()()
GetCallerType(Int32)


GetCallerName Method

GetCallerName Method
Namespaces ► Sitecore ► MainUtil ► GetCallerName()()()
Members
Icon | Member | Description
 | GetCallerName(Int32) | Gets name of the calling method.
 | GetCallerName()()() | Gets name of the calling method.


GetCallerName Method

GetCallerName Method
Namespaces ► Sitecore ► MainUtil ► GetCallerName()()()
Gets name of the calling method.
Declaration Syntax
C#
public static string GetCallerName()
Return Value
The name of the calling method.
Examples
CopyC#
void MyFunction() {
string caller = MainUtil.GetCallerName(); // "MyCaller"
}
void MyCaller() {
MyFunction();
}
See Also
GetCallerMethod(Int32)
GetCallerType(Int32)


GetCallerName Method (indexInStack)

GetCallerName Method (indexInStack)
Namespaces ► Sitecore ► MainUtil ► GetCallerName(Int32)
Gets name of the calling method.
Declaration Syntax
C#
public static string GetCallerName(
    int indexInStack
)
Parameters
indexInStack (Int32)
The index in stack.
Return Value
The name of the calling method.
Examples
CopyC#
void MyFunction() {
string caller = MainUtil.GetCallerName(); // "MyCaller"
}
void MyCaller() {
MyFunction();
}
See Also
GetCallerMethod(Int32)
GetCallerType(Int32)


GetCallerType Method (indexInStack)

GetCallerType Method (indexInStack)
Namespaces ► Sitecore ► MainUtil ► GetCallerType(Int32)
Gets the type of the caller.
Declaration Syntax
C#
public static Type GetCallerType(
    int indexInStack
)
Parameters
indexInStack (Int32)
The index in stack.
Return Value


GetCallStack Method

GetCallStack Method
Namespaces ► Sitecore ► MainUtil ► GetCallStack()()()
Members
Icon | Member | Description
 | GetCallStack()()() | Gets the current call stack.
 | GetCallStack(Int32) | Gets the current call stack.


GetCallStack Method

GetCallStack Method
Namespaces ► Sitecore ► MainUtil ► GetCallStack()()()
Gets the current call stack.
Declaration Syntax
C#
public static string GetCallStack()
Return Value
The call stack.


GetCallStack Method (levels)

GetCallStack Method (levels)
Namespaces ► Sitecore ► MainUtil ► GetCallStack(Int32)
Gets the current call stack.
Declaration Syntax
C#
public static string GetCallStack(
    int levels
)
Parameters
levels (Int32)
Return Value
The call stack.


GetCurrentProcessThread Method

GetCurrentProcessThread Method
Namespaces ► Sitecore ► MainUtil ► GetCurrentProcessThread()()()
Gets the current process thread.
Declaration Syntax
C#
public static ProcessThread GetCurrentProcessThread()
Return Value


GetDotNetFolder Method

GetDotNetFolder Method
Namespaces ► Sitecore ► MainUtil ► GetDotNetFolder()()()
Gets the root folder of the current .NET Framework.
Declaration Syntax
C#
public static string GetDotNetFolder()
Return Value
The path to the root folder of the current .NET Framework.
Examples
CopyC#
string version = MainUtil.GetDotNetFolder();


GetDotNetVersion Method

GetDotNetVersion Method
Namespaces ► Sitecore ► MainUtil ► GetDotNetVersion()()()
Gets the version of the current .NET Framework.
Declaration Syntax
C#
public static string GetDotNetVersion()
Return Value
The version of the current .NET Framework.
Examples
CopyC#
string version = MainUtil.GetDotNetVersion();
See Also
Version


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore ► MainUtil ► GetEnumerator()()()
Members
Icon | Member | Description
 | GetEnumerator<(Of <(T>)>)(IEnumerable<(Of <(T>)>), T) | Combines two enumerators.
 | GetEnumerator<(Of <(T>)>)(IEnumerable<(Of <(T>)>), IEnumerable<(Of <(T>)>)) | Combines two enumerators.
 | GetEnumerator<(Of <(T>)>)(T, IEnumerable<(Of <(T>)>)) | Combines two enumerators.
 | GetEnumerator<(Of <(T>)>)(array<T>[]()[]) | Combines two enumerators.


GetEnumerator Method (list1, list2)

GetEnumerator<(Of <(T>)>) Method (list1, list2)
Namespaces ► Sitecore ► MainUtil ► GetEnumerator<(Of <(T>)>)(IEnumerable<(Of <(T>)>), IEnumerable<(Of <(T>)>))
Combines two enumerators.
Declaration Syntax
C#
public static IEnumerable<T> GetEnumerator<T>(
    IEnumerable<T> list1,
    IEnumerable<T> list2
)
Generic Template Parameters
T
Parameters
list1 (IEnumerable <(Of <(T>)>))
The first list.
list2 (IEnumerable <(Of <(T>)>))
The second list.
Return Value


GetEnumerator Method (list1, item)

GetEnumerator<(Of <(T>)>) Method (list1, item)
Namespaces ► Sitecore ► MainUtil ► GetEnumerator<(Of <(T>)>)(IEnumerable<(Of <(T>)>), T)
Combines two enumerators.
Declaration Syntax
C#
public static IEnumerable<T> GetEnumerator<T>(
    IEnumerable<T> list1,
    T item
)
Generic Template Parameters
T
Parameters
list1 (IEnumerable <(Of <(T>)>))
The first list.
item (T)
A single item.
Return Value


GetEnumerator Method (item, list1)

GetEnumerator<(Of <(T>)>) Method (item, list1)
Namespaces ► Sitecore ► MainUtil ► GetEnumerator<(Of <(T>)>)(T, IEnumerable<(Of <(T>)>))
Combines two enumerators.
Declaration Syntax
C#
public static IEnumerable<T> GetEnumerator<T>(
    T item,
    IEnumerable<T> list1
)
Generic Template Parameters
T
Parameters
item (T)
A single item.
list1 (IEnumerable <(Of <(T>)>))
The first list.
Return Value


GetEnumerator Method (items)

GetEnumerator<(Of <(T>)>) Method (items)
Namespaces ► Sitecore ► MainUtil ► GetEnumerator<(Of <(T>)>)(array<T>[]()[])
Combines two enumerators.
Declaration Syntax
C#
public static IEnumerable<T> GetEnumerator<T>(
    params T[] items
)
Generic Template Parameters
T
Parameters
items (array< T >[]()[])
The items.
Return Value


GetExceptionMessage Method (ex)

GetExceptionMessage Method (ex)
Namespaces ► Sitecore ► MainUtil ► GetExceptionMessage(Exception)
Gets the message from an exception.
Declaration Syntax
C#
public static string GetExceptionMessage(
    Exception ex
)
Parameters
ex (Exception)
An exception.
Return Value
The message part of the exception.
Remarks
The message includes any inner exceptions.
Examples
CopyC#
string message = MainUtil.GetExceptionMessage(exption);


GetExtraEntries Method (big, small)

GetExtraEntries Method (big, small)
Namespaces ► Sitecore ► MainUtil ► GetExtraEntries(Hashtable, Hashtable)
Gets the extra entries in one hashtable compared to another.
Declaration Syntax
C#
public static Hashtable GetExtraEntries(
    Hashtable big,
    Hashtable small
)
Parameters
big (Hashtable)
The big.
small (Hashtable)
The small.
Return Value


GetFileLock Method (path)

GetFileLock Method (path)
Namespaces ► Sitecore ► MainUtil ► GetFileLock(String)
Gets file specific lock object.
Declaration Syntax
C#
[ObsoleteAttribute("Use FileUtil.GetFileLock instead.")]
public static Object GetFileLock(
    string path
)
Parameters
path (String)
A filename path.
Return Value
The lock object.


GetFileTime Method (filePath)

GetFileTime Method (filePath)
Namespaces ► Sitecore ► MainUtil ► GetFileTime(String)
Gets the last modified time of a file.
Declaration Syntax
C#
[ObsoleteAttribute("Use FileUtil.GetFileTime instead", false)]
public static string GetFileTime(
    string filePath
)
Parameters
filePath (String)
A filename path.
Return Value
The last modified time of the file as a string.
Remarks
If the file does not have a last modified time, blank is returned.
Examples
CopyC#
string lastModified = MainUtil.GetFileTime("/robots.txt");


GetFileWriteTime Method (filePath)

GetFileWriteTime Method (filePath)
Namespaces ► Sitecore ► MainUtil ► GetFileWriteTime(String)
Gets the last modified time of a file.
Declaration Syntax
C#
[ObsoleteAttribute("Use FileUtil.GetFileWriteTime instead", false)]
public static DateTime GetFileWriteTime(
    string filePath
)
Parameters
filePath (String)
A filename path.
Return Value
The last modified time of the file as a date/time.
Remarks
If the file does not have a last modified time, DateTime.MinValue is returned.
Examples
CopyC#
DateTime lastModified = MainUtil.GetFileWriteTime("/robots.txt");


GetFloat Method (value, defaultValue)

GetFloat Method (value, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GetFloat(String, Single)
Gets the float value of a string.
Declaration Syntax
C#
public static float GetFloat(
    string value,
    float defaultValue
)
Parameters
value (String)
A string that can be converted to a float.
defaultValue (Single)
A default value.
Return Value
The float value of a string.
Remarks

The default value is returned if the string is blank, null or is not a float. No exception is thrown if the string is not a float.

Note that InvariantCulture is used for the conversion.

Examples
CopyC#
float i0 = MainUtil.GetFloat("1.2", 0); // 1.2
float i1 = MainUtil.GetFloat("", 2.3); // 2.3
float i3 = MainUtil.GetFloat("12.3abc", 0); // 0.0


GetGuid Method

GetGuid Method
Namespaces ► Sitecore ► MainUtil ► GetGuid()()()
Members
Icon | Member | Description
 | GetGuid(Object) | Gets a guid from a string.
 | GetGuid(Object, Guid) | Gets a guid from a string.


GetGuid Method (obj)

GetGuid Method (obj)
Namespaces ► Sitecore ► MainUtil ► GetGuid(Object)
Gets a guid from a string.
Declaration Syntax
C#
public static Guid GetGuid(
    Object obj
)
Parameters
obj (Object)
A string or other object that can be converted to a guid.
Return Value
The guid corresponding to the string. If the string can not be converted to a guid, GuidsOld.Null is returned.
Remarks
GuidsOld.Null is returned if the string is blank, null or is not a guid. No exception is thrown if the string is not a guid.
Examples
CopyC#
Guid g1 = MainUtil.GetGuid(""); // {00000000-0000-0000-0000-000000000000}
Guid g2 = MainUtil.GetGuid("{1930BBEB-7805-471A-A3BE-4858AC7CF696}"); // {1930BBEB-7805-471A-A3BE-4858AC7CF696}


GetGuid Method (obj, defaultValue)

GetGuid Method (obj, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GetGuid(Object, Guid)
Gets a guid from a string.
Declaration Syntax
C#
public static Guid GetGuid(
    Object obj,
    Guid defaultValue
)
Parameters
obj (Object)
A string or other object that can be converted to a guid.
defaultValue (Guid)
A default value.
Return Value
The guid corresponding to the string.
Remarks
The default value is returned if the string is blank, null or is not a guid. No exception is thrown if the string is not a guid.
Examples
CopyC#
Guid g1 = MainUtil.GetGuid("", GuidsOld.Null); // {00000000-0000-0000-0000-000000000000}
Guid g2 = MainUtil.GetGuid("{1930BBEB-7805-471A-A3BE-4858AC7CF696}", GuidsOld.Null); // {1930BBEB-7805-471A-A3BE-4858AC7CF696}


GetHashtable Method (objects, nullIfEmpty)

GetHashtable Method (objects, nullIfEmpty)
Namespaces ► Sitecore ► MainUtil ► GetHashtable(array<Object>[]()[], Boolean)
Gets a Hashtable from a list of objects.
Declaration Syntax
C#
public static Hashtable GetHashtable(
    Object[] objects,
    bool nullIfEmpty
)
Parameters
objects (array< Object >[]()[])
Objects.
nullIfEmpty (Boolean)
Indicates if the function should create a Hashtable even if there are not objects.
Return Value
A Hashtable containing the objects.
Remarks
If objects is null and nullIfEmpty is true, null is returned. If objects is null and nullIfEmpty is false, an empty Hashtable is returned.
Examples
CopyC#
Hashtable table1 = MainUtil.GetHashtable(new object[] { "Name1", "Value1", "Name2", "Value2"}, true);
Hashtable table2 = MainUtil.GetHashtable(null, true); // null
Hashtable table3 = MainUtil.GetHashtable(null, false); // Hashtable


GetID Method

GetID Method
Namespaces ► Sitecore ► MainUtil ► GetID()()()
Members
Icon | Member | Description
 | GetID(Object) | Gets the ID.
 | GetID(Guid) | Gets the ID.
 | GetID(Object, ID) | Gets the ID.
 | GetID(String, ID) | Gets the ID.


GetID Method (value)

GetID Method (value)
Namespaces ► Sitecore ► MainUtil ► GetID(Guid)
Gets the ID.
Declaration Syntax
C#
public static ID GetID(
    Guid value
)
Parameters
value (Guid)
The value.
Return Value


GetID Method (value)

GetID Method (value)
Namespaces ► Sitecore ► MainUtil ► GetID(Object)
Gets the ID.
Declaration Syntax
C#
public static ID GetID(
    Object value
)
Parameters
value (Object)
The value.
Return Value


GetID Method (value, defaultValue)

GetID Method (value, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GetID(Object, ID)
Gets the ID.
Declaration Syntax
C#
public static ID GetID(
    Object value,
    ID defaultValue
)
Parameters
value (Object)
The value.
defaultValue (ID)
The default value.
Return Value


GetID Method (value, defaultValue)

GetID Method (value, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GetID(String, ID)
Gets the ID.
Declaration Syntax
C#
public static ID GetID(
    string value,
    ID defaultValue
)
Parameters
value (String)
The value.
defaultValue (ID)
The default value.
Return Value


GetImage Method

GetImage Method
Namespaces ► Sitecore ► MainUtil ► GetImage()()()
Members
Icon | Member | Description
 | GetImage(String) | Gets an image HTML tag.
 | GetImage(String, Boolean) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Int32, Int32) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Boolean) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Int32, Int32, Boolean, Boolean) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean) | Gets an image HTML tag.


GetImage Method (sImage)

GetImage Method (sImage)
Namespaces ► Sitecore ► MainUtil ► GetImage(String)
Gets an image HTML tag.
Declaration Syntax
C#
public static string GetImage(
    string sImage
)
Parameters
sImage (String)
The source of the image.
Return Value
The image HTML tag.
Examples
CopyC#
string img = MainUtil.GetImage("/sitecore/images/blank.gif"); // <img src="/sitecore/images/blank.gif" border="0"/>


GetImage Method (sImage, bVerticalCenter)

GetImage Method (sImage, bVerticalCenter)
Namespaces ► Sitecore ► MainUtil ► GetImage(String, Boolean)
Gets an image HTML tag.
Declaration Syntax
C#
public static string GetImage(
    string sImage,
    bool bVerticalCenter
)
Parameters
sImage (String)
The source of the image.
bVerticalCenter (Boolean)
Indicates if the image is vertically centered.
Return Value
The image HTML tag.
Examples
CopyC#
string img = MainUtil.GetImage("/sitecore/images/blank.gif", true); // <img src="/sitecore/images/blank.gif" border="0" style="vertical-align: middle;"/>


GetImage Method (sImage, nWidth, nHeight)

GetImage Method (sImage, nWidth, nHeight)
Namespaces ► Sitecore ► MainUtil ► GetImage(String, Int32, Int32)
Gets an image HTML tag.
Declaration Syntax
C#
public static string GetImage(
    string sImage,
    int nWidth,
    int nHeight
)
Parameters
sImage (String)
The source of the image.
nWidth (Int32)
Width of the image.
nHeight (Int32)
Height of the image.
Return Value
The image HTML tag.
Examples
CopyC#
string img = MainUtil.GetImage("/sitecore/images/blank.gif", 20, 20); // <img src="/sitecore/images/blank.gif" border="0" width="20" height="20"/>


GetImage Method (sImage, nWidth, nHeight, bVerticalCenter)

GetImage Method (sImage, nWidth, nHeight, bVerticalCenter)
Namespaces ► Sitecore ► MainUtil ► GetImage(String, Int32, Int32, Boolean)
Gets an image HTML tag.
Declaration Syntax
C#
public static string GetImage(
    string sImage,
    int nWidth,
    int nHeight,
    bool bVerticalCenter
)
Parameters
sImage (String)
The source of the image.
nWidth (Int32)
Width of the image.
nHeight (Int32)
Height of the image.
bVerticalCenter (Boolean)
Indicates if the image is vertically centered.
Return Value
The image HTML tag.
Examples
CopyC#
string img = MainUtil.GetImage("/sitecore/images/blank.gif", 20, 20, true); // <img src="/sitecore/images/blank.gif" border="0" width="20" height="20" style="vertical-align: middle;"/>


GetImage Method (sImage, nWidth, nHeight, nHSpace, nVSpace)

GetImage Method (sImage, nWidth, nHeight, nHSpace, nVSpace)
Namespaces ► Sitecore ► MainUtil ► GetImage(String, Int32, Int32, Int32, Int32)
Gets an image HTML tag.
Declaration Syntax
C#
public static string GetImage(
    string sImage,
    int nWidth,
    int nHeight,
    int nHSpace,
    int nVSpace
)
Parameters
sImage (String)
The source of the image.
nWidth (Int32)
Width of the image.
nHeight (Int32)
Height of the image.
nHSpace (Int32)
Horizontal space.
nVSpace (Int32)
Vertical space.
Return Value
The image HTML tag.
Examples
CopyC#
string img = MainUtil.GetImage("/sitecore/images/blank.gif", 20, 20, 4, 4); // <img src="/sitecore/images/blank.gif" border="0" width="20" height="20" vspace="4" hspace="4"/>


GetImage Method (sImage, nWidth, nHeight, nHSpace, nVSpace, bVerticalCenter, bDisabled)

GetImage Method (sImage, nWidth, nHeight, nHSpace, nVSpace, bVerticalCenter, bDisabled)
Namespaces ► Sitecore ► MainUtil ► GetImage(String, Int32, Int32, Int32, Int32, Boolean, Boolean)
Gets an image HTML tag.
Declaration Syntax
C#
public static string GetImage(
    string sImage,
    int nWidth,
    int nHeight,
    int nHSpace,
    int nVSpace,
    bool bVerticalCenter,
    bool bDisabled
)
Parameters
sImage (String)
The source of the image.
nWidth (Int32)
Width of the image.
nHeight (Int32)
Height of the image.
nHSpace (Int32)
Height of the image.
nVSpace (Int32)
Vertical space.
bVerticalCenter (Boolean)
Indicates if the image is vertically centered.
bDisabled (Boolean)
Indicates if the image is grayed out.
Return Value
The image HTML tag.
Examples
CopyC#
string img = MainUtil.GetImage("/sitecore/images/blank.gif", 20, 20, 4, 4, true); // <img src="/sitecore/images/blank.gif" border="0" width="20" height="20" vspace="4" hspace="4" style="vertical-align: middle;"/>


GetImage Method (sImage, nWidth, nHeight, nHSpace, nVSpace, bVerticalCenter, bDisabled, bDropShadow)

GetImage Method (sImage, nWidth, nHeight, nHSpace, nVSpace, bVerticalCenter, bDisabled, bDropShadow)
Namespaces ► Sitecore ► MainUtil ► GetImage(String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean)
Gets an image HTML tag.
Declaration Syntax
C#
public static string GetImage(
    string sImage,
    int nWidth,
    int nHeight,
    int nHSpace,
    int nVSpace,
    bool bVerticalCenter,
    bool bDisabled,
    bool bDropShadow
)
Parameters
sImage (String)
The source of the image.
nWidth (Int32)
Width of the image.
nHeight (Int32)
Height of the image.
nHSpace (Int32)
Height of the image.
nVSpace (Int32)
Vertical space.
bVerticalCenter (Boolean)
Indicates if the image is vertically centered.
bDisabled (Boolean)
Indicates if the image is grayed.
bDropShadow (Boolean)
Indicates if a drop show is drawn.
Return Value
The image HTML tag.
Examples
CopyC#
string img = MainUtil.GetImage("/sitecore/images/blank.gif", 20, 20, 4, 4, true, false, false); // <img src="/sitecore/images/blank.gif" border="0" width="20" height="20" vspace="4" hspace="4" style="vertical-align: middle;"/>


GetInt Method

GetInt Method
Namespaces ► Sitecore ► MainUtil ► GetInt()()()
Members
Icon | Member | Description
 | GetInt(Object, Int32) | Gets the integer value of a string.
 | GetInt(String, Int32) | Gets the integer value of a string.
 | GetInt(Int32, Int32) | Gets an int different from zero.


GetInt Method (value, defaultValue)

GetInt Method (value, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GetInt(Int32, Int32)
Gets an int different from zero.
Declaration Syntax
C#
public static int GetInt(
    int value,
    int defaultValue
)
Parameters
value (Int32)
The value.
defaultValue (Int32)
The default value that wiil be returned if value is zero.
Return Value
Examples
CopyC#
int i0 = MainUtil.GetInt(12, 0); // 12
int i1 = MainUtil.GetInt(12, 13); // 12
int i2 = MainUtil.GetInt(0, 0); // 0
int i3 = MainUtil.GetInt(0, 15); // 15
int i4 = MainUtil.GetInt(-5, 15); // -5


GetInt Method (obj, defaultValue)

GetInt Method (obj, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GetInt(Object, Int32)
Gets the integer value of a string.
Declaration Syntax
C#
public static int GetInt(
    Object obj,
    int defaultValue
)
Parameters
obj (Object)
A string or other object that can be converted to an int.
defaultValue (Int32)
A default value.
Return Value
The integer value of a string.
Remarks
The default value is returned if the string is blank, null or is not an integer. No exception is thrown if the string is not an integer.
Examples
CopyC#
int i0 = MainUtil.GetInt("12", 0); // 12
int i1 = MainUtil.GetInt("", 0); // 0
int i2 = MainUtil.GetInt(null, 0); // 0
int i3 = MainUtil.GetInt("123abc", 0); // 0


GetInt Method (value, defaultValue)

GetInt Method (value, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GetInt(String, Int32)
Gets the integer value of a string.
Declaration Syntax
C#
public static int GetInt(
    string value,
    int defaultValue
)
Parameters
value (String)
A string that can be converted to an int.
defaultValue (Int32)
A default value.
Return Value
The integer value of a string.
Remarks
The default value is returned if the string is blank, null or is not an integer. No exception is thrown if the string is not an integer.
Examples
CopyC#
int i0 = MainUtil.GetInt("12", 0); // 12
int i1 = MainUtil.GetInt("", 0); // 0
int i2 = MainUtil.GetInt(null, 0); // 0
int i3 = MainUtil.GetInt("123abc", 0); // 0


GetLong Method (obj, defaultValue)

GetLong Method (obj, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GetLong(Object, Int64)
Gets the integer long value of a string.
Declaration Syntax
C#
public static long GetLong(
    Object obj,
    long defaultValue
)
Parameters
obj (Object)
A string or other object that can be converted to a long.
defaultValue (Int64)
A default value.
Return Value
The integer long value of a string.
Remarks
The default value is returned if the string is blank, null or is not an integer. No exception is thrown if the string is not an integer.
Examples
CopyC#
int i0 = MainUtil.GetInt("12", 0); // 12
int i1 = MainUtil.GetInt("", 0); // 0
int i2 = MainUtil.GetInt(null, 0); // 0
int i3 = MainUtil.GetInt("123abc", 0); // 0


GetMD5Hash Method (text)

GetMD5Hash Method (text)
Namespaces ► Sitecore ► MainUtil ► GetMD5Hash(String)
Gets the MD5 hash.
Declaration Syntax
C#
public static ID GetMD5Hash(
    string text
)
Parameters
text (String)
The text.
Return Value


GetNameValues Method

GetNameValues Method
Namespaces ► Sitecore ► MainUtil ► GetNameValues()()()
Members
Icon | Member | Description
 | GetNameValues(String) | Obsolete. Converts a string to a name/value collection.
 | GetNameValues(String, Char, Char) | Obsolete. Converts a string to a name/value collection.
 | GetNameValues(array<String>[]()[]) | Obsolete. Gets a name/value collection from a string array.


GetNameValues Method (list)

GetNameValues Method (list)
Namespaces ► Sitecore ► MainUtil ► GetNameValues(String)
Converts a string to a name/value collection.
Declaration Syntax
C#
[ObsoleteAttribute("Use StringUtil.GetNameValues instead", false)]
public static NameValueCollection GetNameValues(
    string list
)
Parameters
list (String)
A string of seperated values.
Return Value
A name/value collection.
Remarks
The format of the string must be "name=value|name=value...". The name/value collection is built by using values from the string in pairs. A string consisting of "Name1=Value1|Name2=Value2" are converted to ("Name1", "Value1"), ("Name2", "Value2").
Examples
CopyC#
NameValueCollection collection = MainUtil.GetNameValues("Name1=Value1|Name2=Value2");


GetNameValues Method (list, equal, separator)

GetNameValues Method (list, equal, separator)
Namespaces ► Sitecore ► MainUtil ► GetNameValues(String, Char, Char)
Converts a string to a name/value collection.
Declaration Syntax
C#
[ObsoleteAttribute("Use StringUtil.GetNameValues instead", false)]
public static NameValueCollection GetNameValues(
    string list,
    char equal,
    char separator
)
Parameters
list (String)
A string of seperated values.
equal (Char)
Name/value pair separator.
separator (Char)
Pair separator.
Return Value
A name/value collection.
Remarks
The name/value collection is built by using values from the string in pairs. A string consisting of "Name1=Value1|Name2=Value2" are converted to ("Name1", "Value1"), ("Name2", "Value2").
Examples
CopyC#
NameValueCollection collection = MainUtil.GetNameValues("Name1=Value1|Name2=Value2", '=', '|');


GetNameValues Method (list)

GetNameValues Method (list)
Namespaces ► Sitecore ► MainUtil ► GetNameValues(array<String>[]()[])
Gets a name/value collection from a string array.
Declaration Syntax
C#
[ObsoleteAttribute("Use StringUtil.GetNameValues instead", false)]
public static NameValueCollection GetNameValues(
    string[] list
)
Parameters
list (array< String >[]()[])
An array of strings.
Return Value
A name/value collection.
Remarks
The name/value collection is built by using values from the string array in pairs. A string array consisting of { "Name1, "Value1", "Name2", "Value2" } are converted to ("Name1", "Value1"), ("Name2", "Value2").
Examples
CopyC#
NameValueCollection collection = MainUtil.GetNameValues(new string[] {"Name1", "Value1", "Name2", "Value2" });


GetNewID Method

GetNewID Method
Namespaces ► Sitecore ► MainUtil ► GetNewID()()()
Generates a new GUID.
Declaration Syntax
C#
public static string GetNewID()
Return Value
The GUID as a string.
Examples
CopyC#
string id = MainUtil.GetNewID();


GetNextSequence Method

GetNextSequence Method
Namespaces ► Sitecore ► MainUtil ► GetNextSequence()()()
Gets next value of the sequencer.
Declaration Syntax
C#
public static long GetNextSequence()
Return Value
The next value of the sequencer.
Remarks
This function is threadsafe and can be used to generate serial numbers. The sequencer is incremented before the value is returned. The value is unique for the duration of the ASP.NET process lifetime.
Examples
CopyC#
string list = "";
for(int n = 0; n < 5; n++) {
list += "id" + MainUtil.GetSequencer().ToString() + ",";
}
// id12,id13,id14,id15,id16
See Also
GetSequencer()()()


GetNextVarNameSequence Method (max)

GetNextVarNameSequence Method (max)
Namespaces ► Sitecore ► MainUtil ► GetNextVarNameSequence(Int32)
Gets next value of the variable name sequencer, optionally resetting it if it has reached a certain maximum.
Declaration Syntax
C#
public static int GetNextVarNameSequence(
    int max
)
Parameters
max (Int32)
The max.
Return Value
The next value of the sequencer.
Remarks
This function is threadsafe and can be used to generate unique variable names. The sequencer is incremented before the value is returned.
Examples
CopyC#
string list = "";
for(int n = 0; n < 5; n++) {
list += "id" + MainUtil.GetNextVarNameSequence(10000).ToString() + ",";
}
// id12,id13,id14,id15,id16
See Also
GetNextSequence()()()


GetObject Method (obj, defaultValue)

GetObject Method (obj, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GetObject(Object, Object)
Gets an object reference.
Declaration Syntax
C#
public static Object GetObject(
    Object obj,
    Object defaultValue
)
Parameters
obj (Object)
An object.
defaultValue (Object)
A default object.
Return Value
An object.
Remarks
If the object is null, the default value is returned.
Examples
CopyC#
object obj0 = MainUtil.GetObject(myObject, null); // myObject
object obj1 = MainUtil.GetObject(null, "123"); // "123"


GetPrivateBytesUsed Method

GetPrivateBytesUsed Method
Namespaces ► Sitecore ► MainUtil ► GetPrivateBytesUsed()()()
Gets the memory used.
Declaration Syntax
C#
public static long GetPrivateBytesUsed()
Return Value


GetProcessID Method

GetProcessID Method
Namespaces ► Sitecore ► MainUtil ► GetProcessID()()()
Get current process info.
Declaration Syntax
C#
public static int GetProcessID()
Return Value


GetProcessInfo Method

GetProcessInfo Method
Namespaces ► Sitecore ► MainUtil ► GetProcessInfo()()()
Get current process info.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static ProcessInfo GetProcessInfo()
Return Value


GetProcessName Method

GetProcessName Method
Namespaces ► Sitecore ► MainUtil ► GetProcessName()()()
Gets the name of the current process.
Declaration Syntax
C#
public static string GetProcessName()
Return Value
The String.


GetRequestFlag Method (sName, bDefault)

GetRequestFlag Method (sName, bDefault)
Namespaces ► Sitecore ► MainUtil ► GetRequestFlag(String, Boolean)
Gets a boolean flag from the query string.
Declaration Syntax
C#
public static bool GetRequestFlag(
    string sName,
    bool bDefault
)
Parameters
sName (String)
The name of the query string parameter.
bDefault (Boolean)
A default value.
Return Value
The flag as a boolean.
Remarks
A query string flag is a parameter whose value is either "1" or "0", e.g. http://www.mysite.net/?myflag=1. The default value is returned if the flag is not present on the query string.
Examples
CopyC#
bool flag = MainUtil.GetRequestFlag("myflag", false);


GetRequestInt Method (sName, nDefault)

GetRequestInt Method (sName, nDefault)
Namespaces ► Sitecore ► MainUtil ► GetRequestInt(String, Int32)
Gets an integer from the query string.
Declaration Syntax
C#
public static int GetRequestInt(
    string sName,
    int nDefault
)
Parameters
sName (String)
The name of the query string parameter.
nDefault (Int32)
A default value.
Return Value
The flag as an integer.
Remarks
The default value is returned if the flag is not present on the query string.
Examples
CopyC#
int val = MainUtil.GetRequestInt("myparameter", 0);


GetSequencer Method

GetSequencer Method
Namespaces ► Sitecore ► MainUtil ► GetSequencer()()()
Gets the current sequencer value.
Declaration Syntax
C#
public static int GetSequencer()
Return Value
An integer value.
Remarks
This function is threadsafe and can be used to generate serial numbers. The sequencer is incremented before the value is returned. The value is unique for the duration of the ASP.NET process lifetime.
See Also
GetNextSequence()()()


GetSingleton Method (instance, createInstance)

GetSingleton<(Of <(T>)>) Method (instance, createInstance)
Namespaces ► Sitecore ► MainUtil ► GetSingleton<(Of <(T>)>)(T%, Func<(Of <(T>)>))
Gets a singleton.
Declaration Syntax
C#
public static T GetSingleton<T>(
    ref T instance,
    Func<T> createInstance
)
where T : class
Generic Template Parameters
T
Parameters
instance ( T %)
The instance.
createInstance (Func <(Of <(T>)>))
A delegate that can be used to create an instance of the object.
Return Value


GetSortKey Method

GetSortKey Method
Namespaces ► Sitecore ► MainUtil ► GetSortKey()()()
Members
Icon | Member | Description
 | GetSortKey(String) | Generates a unique sort key.
 | GetSortKey(String, String) | Generates a unique sort key.


GetSortKey Method (name)

GetSortKey Method (name)
Namespaces ► Sitecore ► MainUtil ► GetSortKey(String)
Generates a unique sort key.
Declaration Syntax
C#
public static string GetSortKey(
    string name
)
Parameters
name (String)
A sort key.
Return Value
A padded sort key.
Remarks
The sort order key of items needs to be padded in order to be sorted correctly. Furthermore items that start with double underscores "__" should come last. This function creates such a padded sort key.


GetSortKey Method (name, sortorder)

GetSortKey Method (name, sortorder)
Namespaces ► Sitecore ► MainUtil ► GetSortKey(String, String)
Generates a unique sort key.
Declaration Syntax
C#
public static string GetSortKey(
    string name,
    string sortorder
)
Parameters
name (String)
A sort key.
sortorder (String)
A sort order key.
Return Value
A padded sort key.
Remarks
The sort order key of items needs to be padded in order to be sorted correctly. Furthermore items that start with double underscores "__" should come last. This function creates such a padded sort key.


GetSpacer Method

GetSpacer Method
Namespaces ► Sitecore ► MainUtil ► GetSpacer()()()
Members
Icon | Member | Description
 | GetSpacer(Int32, Int32) | Obsolete. Gets an image HTML tag with a blank image.
 | GetSpacer(Int32, Int32, Boolean) | Obsolete. Gets an image HTML tag with a blank image.


GetSpacer Method (width, height)

GetSpacer Method (width, height)
Namespaces ► Sitecore ► MainUtil ► GetSpacer(Int32, Int32)
Gets an image HTML tag with a blank image.
Declaration Syntax
C#
[ObsoleteAttribute("Use Sitecore.Resources.Images.GetSpacer() instead")]
public static string GetSpacer(
    int width,
    int height
)
Parameters
width (Int32)
Width of the image.
height (Int32)
Height of the image.
Return Value
The image HTML tag.
Examples
CopyC#
string spacer = Images.GetSpacer(10, 10); // <img src="/sitecore/images/blank.gif" border="0" height="10" width="10">


GetSpacer Method (width, height, verticalCenter)

GetSpacer Method (width, height, verticalCenter)
Namespaces ► Sitecore ► MainUtil ► GetSpacer(Int32, Int32, Boolean)
Gets an image HTML tag with a blank image.
Declaration Syntax
C#
[ObsoleteAttribute("Use Sitecore.Resources.Images.GetSpacer() instead")]
public static string GetSpacer(
    int width,
    int height,
    bool verticalCenter
)
Parameters
width (Int32)
Width of the image.
height (Int32)
Height of the image.
verticalCenter (Boolean)
Indicates if the image is centered vertically.
Return Value
The image HTML tag.
Examples
CopyC#
string spacer = Images.GetSpacer(10, 10, true); // <img src="/sitecore/images/blank.gif" border="0" height="10" width="10" style="vertical-align: middle;">


GetString Method

GetString Method
Namespaces ► Sitecore ► MainUtil ► GetString()()()
Members
Icon | Member | Description
 | GetString(Object) | Obsolete. Gets the string value of an object.
 | GetString(Object, String) | Obsolete. Gets the string value of an object.


GetString Method (value)

GetString Method (value)
Namespaces ► Sitecore ► MainUtil ► GetString(Object)
Gets the string value of an object.
Declaration Syntax
C#
[ObsoleteAttribute("Please use StringUtil.GetString", false)]
public static string GetString(
    Object value
)
Parameters
value (Object)
An object.
Return Value
The string value of the object or blank if the object is null.
Examples
CopyC#
string s0 = StringUtil.GetString(myObject);
string s1 = StringUtil.GetString(Request.QueryString["id"]);


GetString Method (value, defaultValue)

GetString Method (value, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GetString(Object, String)
Gets the string value of an object.
Declaration Syntax
C#
[ObsoleteAttribute("Please use StringUtil.GetString", false)]
public static string GetString(
    Object value,
    string defaultValue
)
Parameters
value (Object)
An object.
defaultValue (String)
A default value
Return Value
The string value of the object or the default value if the object is null.
Examples
CopyC#
string s0 = StringUtil.GetString(myObject, "");
string s1 = StringUtil.GetString(Request.QueryString["id"], "");


GetStringList Method (allowEmptyStrings, strings)

GetStringList Method (allowEmptyStrings, strings)
Namespaces ► Sitecore ► MainUtil ► GetStringList(Boolean, array<String>[]()[])
Gets an array list of strings.
Declaration Syntax
C#
public static ArrayList GetStringList(
    bool allowEmptyStrings,
    params string[] strings
)
Parameters
allowEmptyStrings (Boolean)
Indicates if empty strings are added to the array.
strings (array< String >[]()[])
Strings
Return Value
An array list of the strings.
Examples
CopyC#
ArrayList list1 = StringUtil.GetStringList(true, new string[] { "Hello", "", "world"}); // "Hello", "", "world"
ArrayList list2 = StringUtil.GetStringList(false, new string[] { "Hello", "", "world"}); // "Hello", "world"


GetThreadID Method

GetThreadID Method
Namespaces ► Sitecore ► MainUtil ► GetThreadID()()()
Gets the current thread ID.
Declaration Syntax
C#
public static int GetThreadID()
Return Value


GetTicks Method

GetTicks Method
Namespaces ► Sitecore ► MainUtil ► GetTicks()()()
Gets the ticks.
Declaration Syntax
C#
public static long GetTicks()
Return Value


GetTristate Method

GetTristate Method
Namespaces ► Sitecore ► MainUtil ► GetTristate()()()
Members
Icon | Member | Description
 | GetTristate(Object, Tristate) | Gets the tristate.
 | GetTristate(Boolean) | Gets a tristate from a bool.


GetTristate Method (condition)

GetTristate Method (condition)
Namespaces ► Sitecore ► MainUtil ► GetTristate(Boolean)
Gets a tristate from a bool.
Declaration Syntax
C#
public static Tristate GetTristate(
    bool condition
)
Parameters
condition (Boolean)
if set to true [condition].
Return Value


GetTristate Method (value, defaultValue)

GetTristate Method (value, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GetTristate(Object, Tristate)
Gets the tristate.
Declaration Syntax
C#
public static Tristate GetTristate(
    Object value,
    Tristate defaultValue
)
Parameters
value (Object)
The value.
defaultValue (Tristate)
The default value.
Return Value


GetUniqueID Method

GetUniqueID Method
Namespaces ► Sitecore ► MainUtil ► GetUniqueID()()()
Generates a unique ID.
Declaration Syntax
C#
public static string GetUniqueID()
Return Value
A unique ID as a string.
Examples
CopyC#
string id = MainUtil.GetUniqueID();


GetWebItemSource Method

GetWebItemSource Method
Namespaces ► Sitecore ► MainUtil ► GetWebItemSource()()()
Members
Icon | Member | Description
 | GetWebItemSource()()() | Gets the web item data source from the query string.
 | GetWebItemSource(String) | Gets the web item data source from the query string.


GetWebItemSource Method

GetWebItemSource Method
Namespaces ► Sitecore ► MainUtil ► GetWebItemSource()()()
Gets the web item data source from the query string.
Declaration Syntax
C#
public static string GetWebItemSource()
Return Value
The value of the path parameter on the query string.
Remarks
If the query string does not contain a parameter named path, blank is returned.
Examples
CopyC#
string path = MainUtil.GetWebItemSource();
if (path != "") {
IWebItem item = WebFactory.GetItem(path);
}


GetWebItemSource Method (sDefault)

GetWebItemSource Method (sDefault)
Namespaces ► Sitecore ► MainUtil ► GetWebItemSource(String)
Gets the web item data source from the query string.
Declaration Syntax
C#
public static string GetWebItemSource(
    string sDefault
)
Parameters
sDefault (String)
A default path.
Return Value
The value of the path parameter on the query string.
Remarks
If the query string does not contain a parameter named path, the default value is returned.
Examples
CopyC#
string path = MainUtil.GetWebItemSource("/Home");
IWebItem item = WebFactory.GetItem(path);


GetWord Method (text, index, separators)

GetWord Method (text, index, separators)
Namespaces ► Sitecore ► MainUtil ► GetWord(String, Int32, array<Char>[]()[])
Gets n'th word from a string.
Declaration Syntax
C#
public static string GetWord(
    string text,
    int index,
    params char[] separators
)
Parameters
text (String)
A string.
index (Int32)
A index.
separators (array< Char >[]()[])
Separators.
Return Value
The word ar the n'th position.
Remarks
The first word has index zero (0).
Examples
CopyC#
string myWord = MainUtil.GetWord("Welcome to my world", 2, ' '); // "my"


GetWorkFileName Method (folder, prefix, extension)

GetWorkFileName Method (folder, prefix, extension)
Namespaces ► Sitecore ► MainUtil ► GetWorkFileName(String, String, String)
Gets a unique filename.
Declaration Syntax
C#
public static string GetWorkFileName(
    string folder,
    string prefix,
    string extension
)
Parameters
folder (String)
The folder of a file.
prefix (String)
The file prefix of a file (usually the filename itself).
extension (String)
The extension of a file.
Return Value
The unique filename.
Remarks
This function is deprecated - please use FileUtil.GetWorkFileName instead.


GetWorkingSetSize Method

GetWorkingSetSize Method
Namespaces ► Sitecore ► MainUtil ► GetWorkingSetSize()()()
Gets size of current working set.
Declaration Syntax
C#
public static int GetWorkingSetSize()
Return Value


GuidToString Method

GuidToString Method
Namespaces ► Sitecore ► MainUtil ► GuidToString()()()
Members
Icon | Member | Description
 | GuidToString(Guid) | Converts guid to string.
 | GuidToString(Guid, String) | Converts guid to string.


GuidToString Method (guid)

GuidToString Method (guid)
Namespaces ► Sitecore ► MainUtil ► GuidToString(Guid)
Converts guid to string.
Declaration Syntax
C#
public static string GuidToString(
    Guid guid
)
Parameters
guid (Guid)
A guid.
Return Value
The guid as a string with the format "{XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}".
Examples
CopyC#
string s = MainUtil.GuidToString(Guids.Null); // "{00000000-0000-0000-0000-000000000000}"


GuidToString Method (guid, defaultValue)

GuidToString Method (guid, defaultValue)
Namespaces ► Sitecore ► MainUtil ► GuidToString(Guid, String)
Converts guid to string.
Declaration Syntax
C#
public static string GuidToString(
    Guid guid,
    string defaultValue
)
Parameters
guid (Guid)
A guid.
defaultValue (String)
The _default.
Return Value
The guid as a string with the format "{XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}".
Examples
CopyC#
string s = MainUtil.GuidToString(Guids.Null); // "{00000000-0000-0000-0000-000000000000}"


HexToColor Method (value)

HexToColor Method (value)
Namespaces ► Sitecore ► MainUtil ► HexToColor(String)
Converts a hex string to a color.
Declaration Syntax
C#
public static Color HexToColor(
    string value
)
Parameters
value (String)
The hex string.
Return Value
Remarks
Translates a html hexadecimal definition of a color into a .NET Framework Color. The input string must start with a '#' character and be followed by 6 hexadecimal digits. The digits A-F are not case sensitive. If the conversion was not successfull the color white will be returned.


HexToInt Method (hex, defaultValue)

HexToInt Method (hex, defaultValue)
Namespaces ► Sitecore ► MainUtil ► HexToInt(String, Int32)
Converts a hex string to an integer.
Declaration Syntax
C#
public static int HexToInt(
    string hex,
    int defaultValue
)
Parameters
hex (String)
The hex.
defaultValue (Int32)
The default value.
Return Value
Remarks
This method converts a hexvalues string as 80FF into a integer. Note that you may not put a '#' at the beginning of string! There is not much error checking in this method. If the string does not represent a valid hexadecimal value it returns 0.


Html Method (text)

Html Method (text)
Namespaces ► Sitecore ► MainUtil ► Html(String)
Writes a line of HTML to the Response output stream.
Declaration Syntax
C#
public static void Html(
    string text
)
Parameters
text (String)
An HTML string.
Remarks
The string is outputted to the Response followed by a trailing <br> tag. The stream is flushed afterwards.
Examples
CopyC#
MainUtil.Html("Hello world");
See Also
Out(String)


Ignore Method (thingsToIgnore)

Ignore Method (thingsToIgnore)
Namespaces ► Sitecore ► MainUtil ► Ignore(array<Object>[]()[])
Ignores the specified parameters.
Declaration Syntax
C#
public static void Ignore(
    params Object[] thingsToIgnore
)
Parameters
thingsToIgnore (array< Object >[]()[])
The things to ignore.


IndexOf Method (obj, objects)

IndexOf Method (obj, objects)
Namespaces ► Sitecore ► MainUtil ► IndexOf(Object, array<Object>[]()[])
Gets the index of an object in an array.
Declaration Syntax
C#
public static int IndexOf(
    Object obj,
    Object[] objects
)
Parameters
obj (Object)
An object to be found.
objects (array< Object >[]()[])
An array of objects.
Return Value
The index of the object in the array. If not found, -1 is returned.
Remarks
This function performs a linear scan of the array to find the object.
Examples
CopyC#
object myObject = new object();
object[] objects = new object[] { 0, 1, myObject, 3, 4 };
int index = MainUtil.IndexOf(myObject, objects); // 2


IntToHex Method (integer)

IntToHex Method (integer)
Namespaces ► Sitecore ► MainUtil ► IntToHex(Int32)
Converts an integer to a hex string.
Declaration Syntax
C#
public static string IntToHex(
    int integer
)
Parameters
integer (Int32)
The integer.
Return Value


IsBitSet Method (bit, bits)

IsBitSet Method (bit, bits)
Namespaces ► Sitecore ► MainUtil ► IsBitSet(Int32, Int32)
Determines whether the specified bit is set.
Declaration Syntax
C#
public static bool IsBitSet(
    int bit,
    int bits
)
Parameters
bit (Int32)
The bit.
bits (Int32)
The bits.
Return Value
true if the specified bit is set; otherwise, false.


IsEmpty Method (s)

IsEmpty Method (s)
Namespaces ► Sitecore ► MainUtil ► IsEmpty(String)
Determines whether the specified string is empty.
Declaration Syntax
C#
public static bool IsEmpty(
    string s
)
Parameters
s (String)
The s.
Return Value
true if the specified string is empty; otherwise, false.


IsFullPath Method (path)

IsFullPath Method (path)
Namespaces ► Sitecore ► MainUtil ► IsFullPath(String)
Determines whether the specified path is a full path.
Declaration Syntax
C#
public static bool IsFullPath(
    string path
)
Parameters
path (String)
The path.
Return Value
true if the specified path is a full path; otherwise, false.


IsID Method (id)

IsID Method (id)
Namespaces ► Sitecore ► MainUtil ► IsID(String)
Checks if string is a valid GUID.
Declaration Syntax
C#
public static bool IsID(
    string id
)
Parameters
id (String)
A string.
Return Value
True, if the string is a GUID, otherwise false.
Remarks
The function checks that the length of the string id, starts with a starting brace ({) and ends with closing brace (}).
Examples
CopyC#
string id = StringUtil.GetString(Request.QueryString["id"]);
if (MainUtil.IsID(id)) {
IMasterItem item = MasterFactory.GetItem(id);
}


IsType Method

IsType Method
Namespaces ► Sitecore ► MainUtil ► IsType()()()
Members
Icon | Member | Description
 | IsType(Object, Type) | Checks if an object is of a given type
 | IsType(Type, Type) | Checks if an object is of a given type


IsType Method (obj, ancestorType)

IsType Method (obj, ancestorType)
Namespaces ► Sitecore ► MainUtil ► IsType(Object, Type)
Checks if an object is of a given type
Declaration Syntax
C#
public static bool IsType(
    Object obj,
    Type ancestorType
)
Parameters
obj (Object)
An object.
ancestorType (Type)
A type.
Return Value
True if the object is of the type, otherwise false.
Remarks

This function is analog to the "is" operator.

The function performs the following checks:

  1. Is the type of object equivalent to the type.
  2. Is the object a subclass of the type.
  3. If the type is an interface, does the object implement it.


IsType Method (objType, ancestorType)

IsType Method (objType, ancestorType)
Namespaces ► Sitecore ► MainUtil ► IsType(Type, Type)
Checks if an object is of a given type
Declaration Syntax
C#
public static bool IsType(
    Type objType,
    Type ancestorType
)
Parameters
objType (Type)
Type of the obj.
ancestorType (Type)
Type of the ancestor.
Return Value
True if the object is of the type, otherwise false.
Remarks

This function is analog to the "is" operator.

The function performs the following checks:

  1. Is the type of object equivalent to the type.
  2. Is the object a subclass of the type.
  3. If the type is an interface, does the object implement it.


IsXPath Method (path)

IsXPath Method (path)
Namespaces ► Sitecore ► MainUtil ► IsXPath(String)
Checks if a string contains an XPath expression.
Declaration Syntax
C#
public static bool IsXPath(
    string path
)
Parameters
path (String)
A string, possiblyh containing an XPath expression.
Return Value
True, if the string contains an XPath expression, otherwise false.
Remarks
This function can be used to differentiate between Sitecore paths and XPath expressions. A path is considered an XPaath expression if it contains "item[" or "::item".
Examples
CopyC#
bool b0 = MainUtil.IsXPath("/item[@key='sitecore']/item[@key='content']"); // true
bool b1 = MainUtil.IsXPath("/sitecore/content"); // false


Join Method

Join Method
Namespaces ► Sitecore ► MainUtil ► Join()()()
Members
Icon | Member | Description
 | Join(String, String, String) | Joins two strings excluding any empty string from the result.
 | Join(String, array<String>[]()[]) | Joins an array of strings excluding any empty string from the result.


Join Method (sSeparator, s1, s2)

Join Method (sSeparator, s1, s2)
Namespaces ► Sitecore ► MainUtil ► Join(String, String, String)
Joins two strings excluding any empty string from the result.
Declaration Syntax
C#
public static string Join(
    string sSeparator,
    string s1,
    string s2
)
Parameters
sSeparator (String)
A separator string.
s1 (String)
A string.
s2 (String)
A string.
Return Value
The two string with the separator in between.
Examples
CopyC#
string s0 = MainUtil.Join(" ", "Hello", "world"); // "Hello world"
string s1 = MainUtil.Join(",", "Hello", " ", "world"); // "Hello,world"


Join Method (sSeparator, values)

Join Method (sSeparator, values)
Namespaces ► Sitecore ► MainUtil ► Join(String, array<String>[]()[])
Joins an array of strings excluding any empty string from the result.
Declaration Syntax
C#
public static string Join(
    string sSeparator,
    string[] values
)
Parameters
sSeparator (String)
A separator string.
values (array< String >[]()[])
Strings
Return Value
The concatenated strings with the separator in between.
Examples
CopyC#
string s0 = MainUtil.Join(",", "Hello", " ", "world"); // "Hello,world"


MakeFilePath Method

MakeFilePath Method
Namespaces ► Sitecore ► MainUtil ► MakeFilePath()()()
Members
Icon | Member | Description
 | MakeFilePath(String, String) | Builds a file path from a folder and a file.
 | MakeFilePath(String, String, Boolean) | Builds a file path from a folder and a file.


MakeFilePath Method (folder, file)

MakeFilePath Method (folder, file)
Namespaces ► Sitecore ► MainUtil ► MakeFilePath(String, String)
Builds a file path from a folder and a file.
Declaration Syntax
C#
public static string MakeFilePath(
    string folder,
    string file
)
Parameters
folder (String)
A folder path.
file (String)
A file name.
Return Value
A file path.
Remarks
If the folder path does not end with a backslash (\), it is appended.
Examples
CopyC#
string filename = FileUtil.MakePath("c:\sitecore\client\images", "images.gif");
// c:\sitecore\client\images\images.gif


MakeFilePath Method (folder, file, unique)

MakeFilePath Method (folder, file, unique)
Namespaces ► Sitecore ► MainUtil ► MakeFilePath(String, String, Boolean)
Builds a file path from a folder and a file.
Declaration Syntax
C#
public static string MakeFilePath(
    string folder,
    string file,
    bool unique
)
Parameters
folder (String)
A folder path.
file (String)
A file name.
unique (Boolean)
A flag indicating that the file should be unique in the folder.
Return Value
A file path.
Remarks

If the folder path does not end with a backslash (\), it is appended.

If unique is true, a serial number is appended to the filename. This serial number is incremented until a file with that name does not exist in the folder.
Examples
CopyC#
string filename = FileUtil.MakePath("c:\sitecore\client\images", "images.gif");
// c:\sitecore\client\images\images_001.gif


MakePath Method (part1, part2, separator)

MakePath Method (part1, part2, separator)
Namespaces ► Sitecore ► MainUtil ► MakePath(String, String, Char)
Makes a path from two filename parts.
Declaration Syntax
C#
[ObsoleteAttribute("Please use FileUtil.MakePath", false)]
public static string MakePath(
    string part1,
    string part2,
    char separator
)
Parameters
part1 (String)
The first part of the filename.
part2 (String)
The second part of the filename.
separator (Char)
A separator character.
Return Value
The two parts concatenated with the separator in between.
Remarks
This function is deprecated - please use FileUtil.MakePath instead.


MapPath Method (path)

MapPath Method (path)
Namespaces ► Sitecore ► MainUtil ► MapPath(String)
Maps a virtual file path to a physical file path.
Declaration Syntax
C#
public static string MapPath(
    string path
)
Parameters
path (String)
A virtual file path.
Return Value
The physical file path.
Remarks
This function is deprecated - please use FileUtil.MapPath instead.


MsgBox Method

MsgBox Method
Namespaces ► Sitecore ► MainUtil ► MsgBox()()()
Members
Icon | Member | Description
 | MsgBox(String) | Shows a message box.
 | MsgBox(String, String) | Shows a message box.


MsgBox Method (message)

MsgBox Method (message)
Namespaces ► Sitecore ► MainUtil ► MsgBox(String)
Shows a message box.
Declaration Syntax
C#
public static void MsgBox(
    string message
)
Parameters
message (String)
A string containing a message.
Examples
CopyC#
MainUtil.MsgBox("Hello world");
See Also
MessageBox


MsgBox Method (message, caption)

MsgBox Method (message, caption)
Namespaces ► Sitecore ► MainUtil ► MsgBox(String, String)
Shows a message box.
Declaration Syntax
C#
public static void MsgBox(
    string message,
    string caption
)
Parameters
message (String)
A string containing a message.
caption (String)
A string containing the caption of the box.
Examples
CopyC#
MainUtil.MsgBox("Hello world", "Sitecore");
See Also
MessageBox


Nop Method (obj)

Nop Method (obj)
Namespaces ► Sitecore ► MainUtil ► Nop(array<Object>[]()[])
No-op
Declaration Syntax
C#
public static void Nop(
    params Object[] obj
)
Parameters
obj (array< Object >[]()[])


NormalizeGuid Method

NormalizeGuid Method
Namespaces ► Sitecore ► MainUtil ► NormalizeGuid()()()
Members
Icon | Member | Description
 | NormalizeGuid(Guid) | Normalizes a GUID.
 | NormalizeGuid(String) | Normalizes a GUID.


NormalizeGuid Method (guid)

NormalizeGuid Method (guid)
Namespaces ► Sitecore ► MainUtil ► NormalizeGuid(Guid)
Normalizes a GUID.
Declaration Syntax
C#
public static string NormalizeGuid(
    Guid guid
)
Parameters
guid (Guid)
A GUID.
Return Value
A GUID string in a normalized format.
Remarks
A normalized GUID is uppercased, starts with a opening brace ({) and ends with a closing brace (}). GUIDs that originate from an SQL server usually have to normalized.


NormalizeGuid Method (guid)

NormalizeGuid Method (guid)
Namespaces ► Sitecore ► MainUtil ► NormalizeGuid(String)
Normalizes a GUID.
Declaration Syntax
C#
public static string NormalizeGuid(
    string guid
)
Parameters
guid (String)
A string contaning a GUID..
Return Value
A GUID string in a normalized format.
Remarks
A normalized GUID is uppercased, starts with a opening brace ({) and ends with a closing brace (}). GUIDs that originate from an SQL server usually have to normalized.
Examples
CopyC#
string id = StringUtil.GetString(Request.QueryString["id"]);
id = MainUtil.NormalizeGuid(id);


NormalizeItemName Method (name)

NormalizeItemName Method (name)
Namespaces ► Sitecore ► MainUtil ► NormalizeItemName(String)
Normalizes an item name.
Declaration Syntax
C#
public static string NormalizeItemName(
    string name
)
Parameters
name (String)
A string contaning an item name.
Return Value
The normalized item name.
Remarks
To work with friendly URLs, an item name must not end with a dot or contain a double quote (").
Examples
CopyC#
string name = MainUtil.NormalizeItemName("MyCorp inc."); // "MyCorp inc"


Out Method

Out Method
Namespaces ► Sitecore ► MainUtil ► Out()()()
Members
Icon | Member | Description
 | Out(String) | Writes a line of HTML to the Response output stream.
 | Out(String, Boolean) | Writes a line of HTML to the Response output stream.


Out Method (text)

Out Method (text)
Namespaces ► Sitecore ► MainUtil ► Out(String)
Writes a line of HTML to the Response output stream.
Declaration Syntax
C#
public static void Out(
    string text
)
Parameters
text (String)
A string.
Remarks
The string is outputted to the Response followed by a trailing <br> tag. The stream is flushed afterwards.
Examples
CopyC#
MainUtil.Out("Hello world");
See Also
Html(String)


Out Method (text, lineBreak)

Out Method (text, lineBreak)
Namespaces ► Sitecore ► MainUtil ► Out(String, Boolean)
Writes a line of HTML to the Response output stream.
Declaration Syntax
C#
public static void Out(
    string text,
    bool lineBreak
)
Parameters
text (String)
A string.
lineBreak (Boolean)
If true, a line break (<br>) will be added to the text.
Remarks
The string is outputted to the Response followed by a trailing <br> tag. The stream is flushed afterwards.
Examples
CopyC#
MainUtil.Out("Hello world");
See Also
Html(String)


RaiseEvent Method (subscribers, sender, eventArgs)

RaiseEvent<(Of <(T>)>) Method (subscribers, sender, eventArgs)
Namespaces ► Sitecore ► MainUtil ► RaiseEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T)
Fires an event
Declaration Syntax
C#
public static void RaiseEvent<T>(
    EventHandler<T> subscribers,
    Object sender,
    T eventArgs
)
where T : EventArgs
Generic Template Parameters
T
Parameters
subscribers (EventHandler <(Of <(T>)>))
The subscribers.
sender (Object)
The sender.
eventArgs (T)
The event args.


ReadFromFile Method (path)

ReadFromFile Method (path)
Namespaces ► Sitecore ► MainUtil ► ReadFromFile(String)
Reads a text file.
Declaration Syntax
C#
[ObsoleteAttribute("Use FileUtil.ReadFromFile instead.")]
public static string ReadFromFile(
    string path
)
Parameters
path (String)
A file name.
Return Value
The content of the file.
Remarks
If the file is not found, an exception is written to the trace file and blank is returned.
Examples
CopyC#
string text = MainUtil.ReadFromFile("/robots.txt");


ReleaseLock Method (name)

ReleaseLock Method (name)
Namespaces ► Sitecore ► MainUtil ► ReleaseLock(String)
Release a named lock
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static void ReleaseLock(
    string name
)
Parameters
name (String)
The name.


RemoveEmptyStrings Method (values)

RemoveEmptyStrings Method (values)
Namespaces ► Sitecore ► MainUtil ► RemoveEmptyStrings(array<String>[]()[])
Removes the empty strings.
Declaration Syntax
C#
public static string[] RemoveEmptyStrings(
    string[] values
)
Parameters
values (array< String >[]()[])
The values.
Return Value


RemoveEnd Method (s, count)

RemoveEnd Method (s, count)
Namespaces ► Sitecore ► MainUtil ► RemoveEnd(String, Int32)
Removes a number of characters from the end of a string.
Declaration Syntax
C#
public static string RemoveEnd(
    string s,
    int count
)
Parameters
s (String)
A string.
count (Int32)
The number of characters to remove.
Return Value
The first characters of the string.
Remarks
If count is greater than the length of the string, blank is returned.
Examples
CopyC#
string text = "Hello world";
string s0 = MainUtil.RemoveEnd(text, 6); // "Hello"
See Also
RemoveStart(String, Int32)


RemoveFromArray Method (array, index)

RemoveFromArray Method (array, index)
Namespaces ► Sitecore ► MainUtil ► RemoveFromArray(Array, Int32)
Removes from array.
Declaration Syntax
C#
public static void RemoveFromArray(
    Array array,
    int index
)
Parameters
array (Array)
The array.
index (Int32)
The index.


RemoveStart Method (s, count)

RemoveStart Method (s, count)
Namespaces ► Sitecore ► MainUtil ► RemoveStart(String, Int32)
Remove the first characters from a string.
Declaration Syntax
C#
public static string RemoveStart(
    string s,
    int count
)
Parameters
s (String)
A string.
count (Int32)
The number of characters to remove.
Return Value
The last charcters from the string.
Remarks
If count is greater than the length of the string, blank is returned.
Examples
CopyC#
string text = "Hello world";
string s0 = MainUtil.RemoveStart(text, 6); // "world"
See Also
RemoveEnd(String, Int32)


ReplaceItemIDs Method (doc)

ReplaceItemIDs Method (doc)
Namespaces ► Sitecore ► MainUtil ► ReplaceItemIDs(XmlDocument)
Replaces all item IDs in an XML document with new GUIDs.
Declaration Syntax
C#
public static void ReplaceItemIDs(
    XmlDocument doc
)
Parameters
doc (XmlDocument)
An XML document.
Remarks
The function scans the entire document. When it encounters a "item" tag with an "id" attribute, the attribute is replaced with a new GUID.


ReplacePostfix Method (s, sFind, sReplace)

ReplacePostfix Method (s, sFind, sReplace)
Namespaces ► Sitecore ► MainUtil ► ReplacePostfix(String, String, String)
Replaces the postfix of a string.
Declaration Syntax
C#
public static string ReplacePostfix(
    string s,
    string sFind,
    string sReplace
)
Parameters
s (String)
A string.
sFind (String)
The postfix to find.
sReplace (String)
The replacement.
Return Value
A string with the postfix replaced.
Remarks
If the string does not end with the postfix, the string itself is returned.
Examples
CopyC#
string s0 = MainUtil.ReplacePostfix("Hello world", "world", "you"); // "Hello you"
string s1 = MainUtil.ReplacePostfix("Hello world", "you", "me"); // "Hello world"
See Also
ReplacePrefix(String, String, String)


ReplacePrefix Method (s, sFind, sReplace)

ReplacePrefix Method (s, sFind, sReplace)
Namespaces ► Sitecore ► MainUtil ► ReplacePrefix(String, String, String)
Replaces the prefix of a string.
Declaration Syntax
C#
public static string ReplacePrefix(
    string s,
    string sFind,
    string sReplace
)
Parameters
s (String)
A string.
sFind (String)
The prefix to find.
sReplace (String)
The replacement.
Return Value
A string with the prefix replaced.
Remarks
If the string does not start with the prefix, the string itself is returned.
Examples
CopyC#
string s0 = MainUtil.ReplacePostfix("Hello world", "Hello", "Hi"); // "Hi you"
string s1 = MainUtil.ReplacePostfix("Hello world", "Hi", "Goodday"); // "Hello world"
See Also
ReplacePostfix(String, String, String)


SendMail Method

SendMail Method
Namespaces ► Sitecore ► MainUtil ► SendMail()()()
Members
Icon | Member | Description
 | SendMail(MailMessage) | Obsolete. Sends the mail.
 | SendMail(MailMessage) | Sends the mail.


SendMail Method (message)

SendMail Method (message)
Namespaces ► Sitecore ► MainUtil ► SendMail(MailMessage)
Sends the mail.
Declaration Syntax
C#
public static void SendMail(
    MailMessage message
)
Parameters
message (MailMessage)
The message.


SendMail Method (message)

SendMail Method (message)
Namespaces ► Sitecore ► MainUtil ► SendMail(MailMessage)
Sends the mail.
Declaration Syntax
C#
[ObsoleteAttribute("Use SendMail(System.Net.Mail.MailMessage) instead")]
public static void SendMail(
    MailMessage message
)
Parameters
message (MailMessage)
The message.


SetBit Method (bit, bits)

SetBit Method (bit, bits)
Namespaces ► Sitecore ► MainUtil ► SetBit(Int32, Int32)
Sets the bit.
Declaration Syntax
C#
public static int SetBit(
    int bit,
    int bits
)
Parameters
bit (Int32)
The bit.
bits (Int32)
The bits.
Return Value


ShortenGuid Method (guid)

ShortenGuid Method (guid)
Namespaces ► Sitecore ► MainUtil ► ShortenGuid(String)
Shortens a GUID by removing braces and hyphens.
Declaration Syntax
C#
public static string ShortenGuid(
    string guid
)
Parameters
guid (String)
A string containing a GUID.
Return Value
A shortend GUID.
Examples
CopyC#
string shortID = MainUtil.ShortenGuid("{C31EAA4A-0E4B-42C9-B8A9-7AE78EB2A773}");
// "C31EAA4A0E4B42C9B8A97AE78EB2A773"


ShrinkArray Method

ShrinkArray Method
Namespaces ► Sitecore ► MainUtil ► ShrinkArray()()()
Members
Icon | Member | Description
 | ShrinkArray(Array, Type) | Shrinks the array.
 | ShrinkArray(Array, Type, Int32) | Compacts an object array by removing nulls.


ShrinkArray Method (array, elementType)

ShrinkArray Method (array, elementType)
Namespaces ► Sitecore ► MainUtil ► ShrinkArray(Array, Type)
Shrinks the array.
Declaration Syntax
C#
public static Array ShrinkArray(
    Array array,
    Type elementType
)
Parameters
array (Array)
The array.
elementType (Type)
Type of the element.
Return Value


ShrinkArray Method (array, elementType, newSize)

ShrinkArray Method (array, elementType, newSize)
Namespaces ► Sitecore ► MainUtil ► ShrinkArray(Array, Type, Int32)
Compacts an object array by removing nulls.
Declaration Syntax
C#
public static Object ShrinkArray(
    Array array,
    Type elementType,
    int newSize
)
Parameters
array (Array)
An array of object.
elementType (Type)
Type of the element.
newSize (Int32)
The new size.
Return Value
The compacted array of object.


SilentCatch Method

SilentCatch Method
Namespaces ► Sitecore ► MainUtil ► SilentCatch()()()
Method to call when doing silent catches. Causes the Resharper warning to disappear.
Declaration Syntax
C#
public static void SilentCatch()


Split Method

Split Method
Namespaces ► Sitecore ► MainUtil ► Split()()()
Members
Icon | Member | Description
 | Split(String, Char) | Splits a string into an array of strings.
 | Split(String, Char, Boolean) | Splits a string into an array of strings.
 | Split(String, String) | Splits a string into an array of strings.
 | Split(String, String, Boolean) | Splits a string into an array of strings.


Split Method (s, separator)

Split Method (s, separator)
Namespaces ► Sitecore ► MainUtil ► Split(String, Char)
Splits a string into an array of strings.
Declaration Syntax
C#
public static string[] Split(
    string s,
    char separator
)
Parameters
s (String)
A string.
separator (Char)
A separator.
Return Value
An array of strings.
Remarks
Blank strings are excluded from the array.
Examples
CopyC#
string[] strings = MainUtil.Split("Name1|Value1|Name2||Name3|Value3", '|');
// "Name1", "Value1", "Name2", "Name3", "Value3"
 Please notice that Value2 is missing.


Split Method (s, separator, trim)

Split Method (s, separator, trim)
Namespaces ► Sitecore ► MainUtil ► Split(String, Char, Boolean)
Splits a string into an array of strings.
Declaration Syntax
C#
public static string[] Split(
    string s,
    char separator,
    bool trim
)
Parameters
s (String)
A string.
separator (Char)
A separator.
trim (Boolean)
If true, individual parts of the split will be trimmed.
Return Value
An array of strings.
Remarks
Blank strings are excluded from the array.
Examples
CopyC#
string[] strings = MainUtil.Split("Name1|Value1|Name2||Name3|Value3", '|');
// "Name1", "Value1", "Name2", "Name3", "Value3"
 Please notice that Value2 is missing.


Split Method (s, separator)

Split Method (s, separator)
Namespaces ► Sitecore ► MainUtil ► Split(String, String)
Splits a string into an array of strings.
Declaration Syntax
C#
public static string[] Split(
    string s,
    string separator
)
Parameters
s (String)
A string.
separator (String)
A separator string.
Return Value
An array of strings.
Remarks
Blank strings are excluded from the array.
Examples
CopyC#
string[] strings = MainUtil.Split("Name1|Value1|Name2||Name3|Value3", "|");
// "Name1", "Value1", "Name2", "Name3", "Value3"
 Please notice that Value2 is missing.


Split Method (s, separator, trim)

Split Method (s, separator, trim)
Namespaces ► Sitecore ► MainUtil ► Split(String, String, Boolean)
Splits a string into an array of strings.
Declaration Syntax
C#
public static string[] Split(
    string s,
    string separator,
    bool trim
)
Parameters
s (String)
A string.
separator (String)
A separator.
trim (Boolean)
If true, individual parts of the split will be trimmed.
Return Value
An array of strings.
Remarks
Blank strings are excluded from the array.
Examples
CopyC#
string[] strings = MainUtil.Split("Name1|Value1|Name2||Name3|Value3", '|');
// "Name1", "Value1", "Name2", "Name3", "Value3"
 Please notice that Value2 is missing.


SplitPath Method (path, expand)

SplitPath Method (path, expand)
Namespaces ► Sitecore ► MainUtil ► SplitPath(String, Boolean)
Splits a Sitecore path into parts, optionally expanding it to include the root.
Declaration Syntax
C#
public static string[] SplitPath(
    string path,
    bool expand
)
Parameters
path (String)
A Sitecore path.
expand (Boolean)
Indicates if the path should be expanded into including the root.
Return Value
An array of parts of the path.
Examples
CopyC#
string[] parts = MainUtil.SplitPath("/Home/Menu", false); // "Home", "Menu"
string[] parts = MainUtil.SplitPath("/Home/Menu", true); // "sitecore", "content", "Home", "Menu"


StringToBool Method (value, defaultValue)

StringToBool Method (value, defaultValue)
Namespaces ► Sitecore ► MainUtil ► StringToBool(String, Boolean)
Converts a string to boolean.
Declaration Syntax
C#
public static bool StringToBool(
    string value,
    bool defaultValue
)
Parameters
value (String)
A string.
defaultValue (Boolean)
A default value.
Return Value
True, if the string is "true", false, if the string is "false", otherwise the default value.
Remarks
Only the values 'true' or 'false' are recognized. For all other values, the default will be returned. The comparison is case-insensitive.
Examples
CopyC#
bool b0 = MainUtil.StringToBool("True", true); // true
bool b1 = MainUtil.StringToBool("false", true); // false
bool b0 = MainUtil.StringToBool("", true); // true
bool b0 = MainUtil.StringToBool("abc", false); // false
bool b0 = MainUtil.StringToBool("yes", false); // false
bool b0 = MainUtil.StringToBool("1", false); // false
See Also
BoolToString(Boolean)


StringToColor Method (color)

StringToColor Method (color)
Namespaces ► Sitecore ► MainUtil ► StringToColor(String)
Converts a string to a color.
Declaration Syntax
C#
public static Color StringToColor(
    string color
)
Parameters
color (String)
The color.
Return Value


Substring Method

Substring Method
Namespaces ► Sitecore ► MainUtil ► Substring()()()
Members
Icon | Member | Description
 | Substring(String, Int32, Int32) | Retrieves a substring from a string. The substring starts at a specified character position and has a specified length.
 | Substring(String, Int32, Boolean) | Gets a substring of maximum length of a string.


Substring Method (value, max, dots)

Substring Method (value, max, dots)
Namespaces ► Sitecore ► MainUtil ► Substring(String, Int32, Boolean)
Gets a substring of maximum length of a string.
Declaration Syntax
C#
public static string Substring(
    string value,
    int max,
    bool dots
)
Parameters
value (String)
A string.
max (Int32)
The number of characters in the substring.
dots (Boolean)
If true, three dots are appended to the substring.
Return Value
A subtring starting at zero and ending a max characters of the string.
Remarks
No exception is thrown if max is greater than the length of the string.
Examples
CopyC#
string text = MainUtil.Substring("Hello world", 6, true); // "Hel..."
string text = MainUtil.Substring("Hello world", 6, false); // "Hello "


Substring Method (value, start, length)

Substring Method (value, start, length)
Namespaces ► Sitecore ► MainUtil ► Substring(String, Int32, Int32)
Retrieves a substring from a string. The substring starts at a specified character position and has a specified length.
Declaration Syntax
C#
public static string Substring(
    string value,
    int start,
    int length
)
Parameters
value (String)
A string.
start (Int32)
The index of the start of the substring.
length (Int32)
The number of characters in the substring.
Return Value
A String equivalent to the substring of length length that begins at start in the string.
Remarks
No exception is thrown if length is greater than the length of the string.
Examples
CopyC#
string text = MainUtil.Substring("Hello world", 6, 100); // "world"
string text = MainUtil.Substring("Hello world", 2, 3); // "llo"


TerminateAspNet Method

TerminateAspNet Method
Namespaces ► Sitecore ► MainUtil ► TerminateAspNet()()()
Members
Icon | Member | Description
 | TerminateAspNet()()() | Terminates the ASP.NET worker process.
 | TerminateAspNet(String) | Terminates the ASP.NET worker process.


TerminateAspNet Method

TerminateAspNet Method
Namespaces ► Sitecore ► MainUtil ► TerminateAspNet()()()
Terminates the ASP.NET worker process.
Declaration Syntax
C#
public static void TerminateAspNet()


TerminateAspNet Method (message)

TerminateAspNet Method (message)
Namespaces ► Sitecore ► MainUtil ► TerminateAspNet(String)
Terminates the ASP.NET worker process.
Declaration Syntax
C#
public static void TerminateAspNet(
    string message
)
Parameters
message (String)


ThemedImage Method

ThemedImage Method
Namespaces ► Sitecore ► MainUtil ► ThemedImage()()()
Members
Icon | Member | Description
 | ThemedImage(String) | Gets a themed image path.
 | ThemedImage(String, ImageDimension) | Gets a themed image path.


ThemedImage Method (sImage)

ThemedImage Method (sImage)
Namespaces ► Sitecore ► MainUtil ► ThemedImage(String)
Gets a themed image path.
Declaration Syntax
C#
public static string ThemedImage(
    string sImage
)
Parameters
sImage (String)
Image file name.
Return Value
A path the the themed image.
Remarks
The function takes in account the current desktop theme.
Examples
CopyC#
string image = MainUtil.ThemedImage("save20x20.gif");
// "/sitecore/client/themes/standard/save20x20.gif"


ThemedImage Method (sImage, dimension)

ThemedImage Method (sImage, dimension)
Namespaces ► Sitecore ► MainUtil ► ThemedImage(String, ImageDimension)
Gets a themed image path.
Declaration Syntax
C#
public static string ThemedImage(
    string sImage,
    ImageDimension dimension
)
Parameters
sImage (String)
Image file name.
dimension (ImageDimension)
Dimensions of the image.
Return Value
A path the the themed image.
Remarks
The function takes in account the current desktop theme. If the name of the image contains a size part, the size part is changed according to the dimensions.
Examples
CopyC#
string image = MainUtil.ThemedImage("save20x20.gif", ImageDimension.id32x32);
// "/sitecore/client/themes/standard/save32x32.gif"


Touch Method (obj)

Touch Method (obj)
Namespaces ► Sitecore ► MainUtil ► Touch(array<Object>[]()[])
Touch
Declaration Syntax
C#
public static void Touch(
    params Object[] obj
)
Parameters
obj (array< Object >[]()[])


Trace Method (message)

Trace Method (message)
Namespaces ► Sitecore ► MainUtil ► Trace(String)
Writes a message to the trace.
Declaration Syntax
C#
public static void Trace(
    string message
)
Parameters
message (String)
A message string.
Remarks
The message is written both to the Sitecore trace and to the current context trace.
Examples
CopyC#
MainUtil.Trace("Point of no return reached.");
See Also
Trace


TraceIf Method (condition, message)

TraceIf Method (condition, message)
Namespaces ► Sitecore ► MainUtil ► TraceIf(Boolean, String)
Conditionally writes a message to the trace.
Declaration Syntax
C#
public static void TraceIf(
    bool condition,
    string message
)
Parameters
condition (Boolean)
A boolean condition.
message (String)
A message string.
Remarks

The message is only written if condition is true.

The message is written both to the Sitecore trace and to the current context trace.

Examples
CopyC#
MainUtil.Trace(true, "Point of no return reached.");
See Also
Trace


TristateToString Method (state)

TristateToString Method (state)
Namespaces ► Sitecore ► MainUtil ► TristateToString(Tristate)
Converts a Tristate to a string.
Declaration Syntax
C#
public static string TristateToString(
    Tristate state
)
Parameters
state (Tristate)
The state.
Return Value


True Method

True Method
Namespaces ► Sitecore ► MainUtil ► True()()()
Returns true.
Declaration Syntax
C#
public static bool True()
Return Value


UnmapPath Method (path)

UnmapPath Method (path)
Namespaces ► Sitecore ► MainUtil ► UnmapPath(String)
Maps a physical path to a virtual path.
Declaration Syntax
C#
public static string UnmapPath(
    string path
)
Parameters
path (String)
A path.
Return Value
A virtual path.
Remarks
If the path cannot be made into a virtual path, the physical path is returned.
Examples
CopyC#
string path = MainUtil.UnmapPath(@"c:\inetpub\wwwroot\default side\sitecore\images\blank.gif");
// "/sitecore/images/blank.gif"
See Also
MapPath(String)


Unquote Method (text)

Unquote Method (text)
Namespaces ► Sitecore ► MainUtil ► Unquote(String)
Removes enclosing single and double quotes from a string.
Declaration Syntax
C#
[ObsoleteAttribute("Use StringUtil.Unquote instead")]
public static string Unquote(
    string text
)
Parameters
text (String)
A string.
Return Value
The unquoted string.
Examples
CopyC#
string s0 = MainUtil.Unquote("'Hello world'"); // "Hello world"
string s0 = MainUtil.Unquote("'Hello Andy's world'"); // "Hello Andy's world"


VerifyCallLevel Method (callLevel, methodName)

VerifyCallLevel Method (callLevel, methodName)
Namespaces ► Sitecore ► MainUtil ► VerifyCallLevel(Int32, String)
Verifies that a call level has not exceeded the maximum specified in the setting 'MaxCallLevel'.
Declaration Syntax
C#
public static bool VerifyCallLevel(
    int callLevel,
    string methodName
)
Parameters
callLevel (Int32)
The call level to verify.
methodName (String)
The name of the method being called. This should be a fully qualified name, ie. TypeName.MethodName. An example of this could be: Sitecore.Data.Templates.TemplateParser.GetTemplatePath()
Return Value
Remarks
If the call level is exceeded an error message is written to the current log and the method returns false.


Warn Method (message)

Warn Method (message)
Namespaces ► Sitecore ► MainUtil ► Warn(String)
Writes a warning message to the trace.
Declaration Syntax
C#
public static void Warn(
    string message
)
Parameters
message (String)
A message string.
Remarks
The message is written both to the Sitecore trace and to the current context trace.
Examples
CopyC#
MainUtil.Warn("System is going down in 3 minutes...");
See Also
Trace
Trace(String)


WriteToFile Method

WriteToFile Method
Namespaces ► Sitecore ► MainUtil ► WriteToFile()()()
Members
Icon | Member | Description
 | WriteToFile(String, array<Byte>[]()[]%) | Obsolete. Writes a byte array to a file.
 | WriteToFile(String, String) | Obsolete. Writes a string to a file.
 | WriteToFile(String, String, Boolean) | Obsolete. Write or appends a atring to a file.


WriteToFile Method (path, data)

WriteToFile Method (path, data)
Namespaces ► Sitecore ► MainUtil ► WriteToFile(String, array<Byte>[]()[]%)
Writes a byte array to a file.
Declaration Syntax
C#
[ObsoleteAttribute("Use FileUtil.WriteToFile instead.")]
public static void WriteToFile(
    string path,
    ref byte[] data
)
Parameters
path (String)
A file name path.
data ( array< Byte >[]()[] %)
A byte array of data.


WriteToFile Method (path, text)

WriteToFile Method (path, text)
Namespaces ► Sitecore ► MainUtil ► WriteToFile(String, String)
Writes a string to a file.
Declaration Syntax
C#
[ObsoleteAttribute("Use FileUtil.WriteToFile instead.")]
public static void WriteToFile(
    string path,
    string text
)
Parameters
path (String)
A file name path.
text (String)
A string.
Examples
CopyC#
MainUtil.WriteToString("/my.txt", "Hello world");


WriteToFile Method (path, text, append)

WriteToFile Method (path, text, append)
Namespaces ► Sitecore ► MainUtil ► WriteToFile(String, String, Boolean)
Write or appends a atring to a file.
Declaration Syntax
C#
[ObsoleteAttribute("Use FileUtil.WriteToFile instead.")]
public static void WriteToFile(
    string path,
    string text,
    bool append
)
Parameters
path (String)
A file name path.
text (String)
A string.
append (Boolean)
Indicates if the string is appended to the file.
Examples
CopyC#
MainUtil.WriteToString("/my.txt", "Hello world", true);


MeansImplicitUseAttribute Class

MeansImplicitUseAttribute Class
Namespaces ► Sitecore ► MeansImplicitUseAttribute
Should be used on attributes and causes ReSharper to not mark symbols marked with such attributes as unused (as well as by other usage inspections)
Declaration Syntax
C#
public class MeansImplicitUseAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MeansImplicitUseAttribute()()() | Initializes a new instance of the MeansImplicitUseAttribute class.
 | MeansImplicitUseAttribute(ImplicitUseFlags) | Initializes a new instance of the MeansImplicitUseAttribute class.
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flags | Gets or sets the flags.
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | MeansImplicitUseAttribute


MeansImplicitUseAttribute Constructor

MeansImplicitUseAttribute Constructor
Namespaces ► Sitecore ► MeansImplicitUseAttribute ► MeansImplicitUseAttribute()()()
Members
Icon | Member | Description
 | MeansImplicitUseAttribute()()() | Initializes a new instance of the MeansImplicitUseAttribute class.
 | MeansImplicitUseAttribute(ImplicitUseFlags) | Initializes a new instance of the MeansImplicitUseAttribute class.


MeansImplicitUseAttribute Constructor

MeansImplicitUseAttribute Constructor
Namespaces ► Sitecore ► MeansImplicitUseAttribute ► MeansImplicitUseAttribute()()()
Initializes a new instance of the MeansImplicitUseAttribute class.
Declaration Syntax
C#
public MeansImplicitUseAttribute()


MeansImplicitUseAttribute Constructor (flags)

MeansImplicitUseAttribute Constructor (flags)
Namespaces ► Sitecore ► MeansImplicitUseAttribute ► MeansImplicitUseAttribute(ImplicitUseFlags)
Initializes a new instance of the MeansImplicitUseAttribute class.
Declaration Syntax
C#
public MeansImplicitUseAttribute(
    ImplicitUseFlags flags
)
Parameters
flags (ImplicitUseFlags)
The flags.


Flags Property

Flags Property
Namespaces ► Sitecore ► MeansImplicitUseAttribute ► Flags
Gets or sets the flags.
Declaration Syntax
C#
public ImplicitUseFlags Flags { get; private set; }
Value
The flags.


NotNullAttribute Class

NotNullAttribute Class
Namespaces ► Sitecore ► NotNullAttribute
Implements the NotNullAttribute.
Declaration Syntax
C#
public sealed class NotNullAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotNullAttribute()()() | Initializes a new instance of the NotNullAttribute class
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | NotNullAttribute


NotNullAttribute Constructor

NotNullAttribute Constructor
Namespaces ► Sitecore ► NotNullAttribute ► NotNullAttribute()()()
Initializes a new instance of the NotNullAttribute class
Declaration Syntax
C#
public NotNullAttribute()


PackageRegistrationFieldIDs Class

PackageRegistrationFieldIDs Class
Namespaces ► Sitecore ► PackageRegistrationFieldIDs
Fields of the 'Packages/Package registration' template.
Declaration Syntax
C#
public static class PackageRegistrationFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PackageID | The ID of the 'Package id' field.
 | PackageName | The ID of the 'Package name' field.
 | PackageVersion | The ID of the 'Package version' field.
Inheritance Hierarchy
Object
PackageRegistrationFieldIDs


PackageID Field

PackageID Field
Namespaces ► Sitecore ► PackageRegistrationFieldIDs ► PackageID
The ID of the 'Package id' field.
Declaration Syntax
C#
public static ID PackageID


PackageName Field

PackageName Field
Namespaces ► Sitecore ► PackageRegistrationFieldIDs ► PackageName
The ID of the 'Package name' field.
Declaration Syntax
C#
public static ID PackageName


PackageVersion Field

PackageVersion Field
Namespaces ► Sitecore ► PackageRegistrationFieldIDs ► PackageVersion
The ID of the 'Package version' field.
Declaration Syntax
C#
public static ID PackageVersion


RenderingIDs Class

RenderingIDs Class
Namespaces ► Sitecore ► RenderingIDs
Implements a static class for holding assorted well-known GUID values.
Declaration Syntax
C#
public static class RenderingIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FieldRenderer | The System/FieldRenderer rendering.
 | WebEditContentEditor | The System/WebEdit/WebEdit Content Editor rendering.
 | WebEditRibbon | The System/WebEdit/WebEdit Ribbon rendering.
Remarks
The class does not contain any functionality, but serves as a placeholder for a predefined GUIDs.
Inheritance Hierarchy
Object
RenderingIDs


FieldRenderer Field

FieldRenderer Field
Namespaces ► Sitecore ► RenderingIDs ► FieldRenderer
The System/FieldRenderer rendering.
Declaration Syntax
C#
public static ID FieldRenderer


WebEditContentEditor Field

WebEditContentEditor Field
Namespaces ► Sitecore ► RenderingIDs ► WebEditContentEditor
The System/WebEdit/WebEdit Content Editor rendering.
Declaration Syntax
C#
public static ID WebEditContentEditor


WebEditRibbon Field

WebEditRibbon Field
Namespaces ► Sitecore ► RenderingIDs ► WebEditRibbon
The System/WebEdit/WebEdit Ribbon rendering.
Declaration Syntax
C#
public static ID WebEditRibbon


RoleFieldIDs Class

RoleFieldIDs Class
Namespaces ► Sitecore ► RoleFieldIDs
Fields of the Security/Role template.
Declaration Syntax
C#
public static class RoleFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Roles | The ID of the 'Roles' field.
Inheritance Hierarchy
Object
RoleFieldIDs


Roles Field

Roles Field
Namespaces ► Sitecore ► RoleFieldIDs ► Roles
The ID of the 'Roles' field.
Declaration Syntax
C#
public static ID Roles


ScheduleFieldIDs Class

ScheduleFieldIDs Class
Namespaces ► Sitecore ► ScheduleFieldIDs
Fields of the Tasks/Schedule template.
Declaration Syntax
C#
public static class ScheduleFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Async | The ID of the 'Async' field.
 | AutoRemove | The ID of the 'Auto remove' field.
 | Command | The ID of the 'Command' field.
 | Items | The ID of the 'Items' field.
 | LastRun | The ID of the 'Last run' field.
 | Schedule | The ID of the 'Schedule' field.
Inheritance Hierarchy
Object
ScheduleFieldIDs


Async Field

Async Field
Namespaces ► Sitecore ► ScheduleFieldIDs ► Async
The ID of the 'Async' field.
Declaration Syntax
C#
public static ID Async


AutoRemove Field

AutoRemove Field
Namespaces ► Sitecore ► ScheduleFieldIDs ► AutoRemove
The ID of the 'Auto remove' field.
Declaration Syntax
C#
public static ID AutoRemove


Command Field

Command Field
Namespaces ► Sitecore ► ScheduleFieldIDs ► Command
The ID of the 'Command' field.
Declaration Syntax
C#
public static ID Command


Items Field

Items Field
Namespaces ► Sitecore ► ScheduleFieldIDs ► Items
The ID of the 'Items' field.
Declaration Syntax
C#
public static ID Items


LastRun Field

LastRun Field
Namespaces ► Sitecore ► ScheduleFieldIDs ► LastRun
The ID of the 'Last run' field.
Declaration Syntax
C#
public static ID LastRun


Schedule Field

Schedule Field
Namespaces ► Sitecore ► ScheduleFieldIDs ► Schedule
The ID of the 'Schedule' field.
Declaration Syntax
C#
public static ID Schedule


SecurityDatabaseTemplateIDs Class

SecurityDatabaseTemplateIDs Class
Namespaces ► Sitecore ► SecurityDatabaseTemplateIDs
Implements a static class for holding well-known GUIDs relating to templates.
Declaration Syntax
C#
public static class SecurityDatabaseTemplateIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Folder | The ID of 'Folder' in the security database.
Remarks
The class does not contain any functionality, but serves only as a placeholder for a predefined GUIDs.
Inheritance Hierarchy
Object
SecurityDatabaseTemplateIDs


Folder Field

Folder Field
Namespaces ► Sitecore ► SecurityDatabaseTemplateIDs ► Folder
The ID of 'Folder' in the security database.
Declaration Syntax
C#
public static ID Folder


ShellFieldIDs Class

ShellFieldIDs Class
Namespaces ► Sitecore ► ShellFieldIDs
Implements a static class for holding assorted well-known GUID values.
Declaration Syntax
C#
public static class ShellFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Branch | The Branch field of the Shell/Shell association template.
 | Commands | The ID of the 'Commands' field.
 | Deep | The Deep field of the Shell/Shell association template.
 | FolderKind | The FolderKind field of the Shell/Shell task group template.
 | Master | Obsolete. The Master field of the Shell/Shell association template.
 | Path | The Path field of the Shell/Shell association template.
 | Template | The Template field of the Shell/Shell association template.
 | ToolbarIcon | The ToolbarIcon field of the Shell/Shell task group template.
 | ToolbarStylesheetClass | The ToolbarStylesheetClass field of the Shell/Shell task group template.
Remarks
The class does not contain any functionality, but serves as a placeholder for a predefined GUIDs.
Inheritance Hierarchy
Object
ShellFieldIDs


Branch Field

Branch Field
Namespaces ► Sitecore ► ShellFieldIDs ► Branch
The Branch field of the Shell/Shell association template.
Declaration Syntax
C#
public static ID Branch


Commands Field

Commands Field
Namespaces ► Sitecore ► ShellFieldIDs ► Commands
The ID of the 'Commands' field.
Declaration Syntax
C#
public static ID Commands


Deep Field

Deep Field
Namespaces ► Sitecore ► ShellFieldIDs ► Deep
The Deep field of the Shell/Shell association template.
Declaration Syntax
C#
public static ID Deep


FolderKind Field

FolderKind Field
Namespaces ► Sitecore ► ShellFieldIDs ► FolderKind
The FolderKind field of the Shell/Shell task group template.
Declaration Syntax
C#
public static ID FolderKind


Master Field

Master Field
Namespaces ► Sitecore ► ShellFieldIDs ► Master
The Master field of the Shell/Shell association template.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Branch instead.")]
public static ID Master


Path Field

Path Field
Namespaces ► Sitecore ► ShellFieldIDs ► Path
The Path field of the Shell/Shell association template.
Declaration Syntax
C#
public static ID Path


Template Field

Template Field
Namespaces ► Sitecore ► ShellFieldIDs ► Template
The Template field of the Shell/Shell association template.
Declaration Syntax
C#
public static ID Template


ToolbarIcon Field

ToolbarIcon Field
Namespaces ► Sitecore ► ShellFieldIDs ► ToolbarIcon
The ToolbarIcon field of the Shell/Shell task group template.
Declaration Syntax
C#
public static ID ToolbarIcon


ToolbarStylesheetClass Field

ToolbarStylesheetClass Field
Namespaces ► Sitecore ► ShellFieldIDs ► ToolbarStylesheetClass
The ToolbarStylesheetClass field of the Shell/Shell task group template.
Declaration Syntax
C#
public static ID ToolbarStylesheetClass


SitecoreDataContext Class

SitecoreDataContext Class
Namespaces ► Sitecore ► SitecoreDataContext
Declaration Syntax
C#
public class SitecoreDataContext : DataContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SitecoreDataContext()()() | Initializes a new instance of the SitecoreDataContext class
 | SitecoreDataContext(String) | Initializes a new instance of the SitecoreDataContext class
 | SitecoreDataContext(IDbConnection) | Initializes a new instance of the SitecoreDataContext class
 | SitecoreDataContext(String, MappingSource) | Initializes a new instance of the SitecoreDataContext class
 | SitecoreDataContext(IDbConnection, MappingSource) | Initializes a new instance of the SitecoreDataContext class
 | ChangeConflicts | Returns a collection of objects that caused concurrency conflicts when SubmitChanges()()() was called. (Inherited from DataContext.)
 | CommandTimeout | Increases the time-out period for queries that would otherwise time out during the default time-out period. (Inherited from DataContext.)
 | Connection | Returns the connection used by the framework. (Inherited from DataContext.)
 | CreateDatabase()()() | Creates a database on the server. (Inherited from DataContext.)
 | CreateMethodCallQuery<(Of <(TResult>)>)(Object, MethodInfo, array<Object>[]()[]) | Executes the table-valued database function associated with the specified CLR method. (Inherited from DataContext.)
 | DatabaseExists()()() | Determines whether the associated database can be opened. (Inherited from DataContext.)
 | DeferredLoadingEnabled | Specifies whether to delay-load one-to-many or one-to-one relationships. (Inherited from DataContext.)
 | DeleteDatabase()()() | Deletes the associated database. (Inherited from DataContext.)
 | Dispose()()() | Releases all resources used by the DataContext. (Inherited from DataContext.)
 | Dispose(Boolean) | Releases resources used by the DataContext. (Inherited from DataContext.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteCommand(String, array<Object>[]()[]) | Executes SQL commands directly on the database. (Inherited from DataContext.)
 | ExecuteDynamicDelete(Object) | Called inside delete override methods to redelegate to LINQ to SQL the task of generating and executing dynamic SQL for delete operations. (Inherited from DataContext.)
 | ExecuteDynamicInsert(Object) | Called inside insert override methods to redelegate to LINQ to SQL the task of generating and executing dynamic SQL for insert operations. (Inherited from DataContext.)
 | ExecuteDynamicUpdate(Object) | Called inside update override methods to redelegate to LINQ to SQL the task of generating and executing dynamic SQL for update operations. (Inherited from DataContext.)
 | ExecuteMethodCall(Object, MethodInfo, array<Object>[]()[]) | Executes the stored database procedure or scalar function associated with the specified CLR method. (Inherited from DataContext.)
 | ExecuteQuery<(Of <(TResult>)>)(String, array<Object>[]()[]) | Executes SQL queries directly on the database and returns objects. (Inherited from DataContext.)
 | ExecuteQuery(Type, String, array<Object>[]()[]) | Executes SQL queries directly on the database. (Inherited from DataContext.)
 | Fields |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChangeSet()()() | Provides access to the modified objects tracked by DataContext. (Inherited from DataContext.)
 | GetCommand(IQueryable) | Provides information about SQL commands generated by LINQ to SQL. (Inherited from DataContext.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTable<(Of <(TEntity>)>)()()() | Returns a collection of objects of a particular type, where the type is defined by the TEntity parameter. (Inherited from DataContext.)
 | GetTable(Type) | Returns a collection of objects of a particular type, where the type is defined by the type parameter. (Inherited from DataContext.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Items |
 | Languages |
 | LoadOptions | Gets or sets the DataLoadOptions associated with this DataContext. (Inherited from DataContext.)
 | Log | Specifies the destination to write the SQL query or command. (Inherited from DataContext.)
 | Mapping | Returns the MetaModel on which the mapping is based. (Inherited from DataContext.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ObjectTrackingEnabled | Instructs the framework to track the original value and object identity for this DataContext. (Inherited from DataContext.)
 | Refresh(RefreshMode, Object) | Refreshes an entity object according to the specified mode. (Inherited from DataContext.)
 | Refresh(RefreshMode, array<Object>[]()[]) | Refreshes an array of entity objects according to the specified mode. (Inherited from DataContext.)
 | Refresh(RefreshMode, IEnumerable) | Refreshes a collection of entity objects according to the specified mode. (Inherited from DataContext.)
 | Revisions |
 | SubmitChanges()()() | Computes the set of modified objects to be inserted, updated, or deleted, and executes the appropriate commands to implement the changes to the database. (Inherited from DataContext.)
 | SubmitChanges(ConflictMode) | Sends changes that were made to retrieved objects to the underlying database, and specifies the action to be taken if the submission fails. (Inherited from DataContext.)
 | TemplateFields |
 | TemplateFieldTypes |
 | Templates |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transaction | Sets a local transaction for the .NET Framework to use to access the database. (Inherited from DataContext.)
 | Translate<(Of <(TResult>)>)(DbDataReader) | Converts an existing DbDataReader to objects. (Inherited from DataContext.)
 | Translate(Type, DbDataReader) | Converts an existing DbDataReader to objects. (Inherited from DataContext.)
 | Versions |
Inheritance Hierarchy
Object
 | DataContext
 |  | SitecoreDataContext


SitecoreDataContext Constructor

SitecoreDataContext Constructor
Namespaces ► Sitecore ► SitecoreDataContext ► SitecoreDataContext()()()
Members
Icon | Member | Description
 | SitecoreDataContext()()() | Initializes a new instance of the SitecoreDataContext class
 | SitecoreDataContext(String) | Initializes a new instance of the SitecoreDataContext class
 | SitecoreDataContext(IDbConnection) | Initializes a new instance of the SitecoreDataContext class
 | SitecoreDataContext(String, MappingSource) | Initializes a new instance of the SitecoreDataContext class
 | SitecoreDataContext(IDbConnection, MappingSource) | Initializes a new instance of the SitecoreDataContext class


SitecoreDataContext Constructor

SitecoreDataContext Constructor
Namespaces ► Sitecore ► SitecoreDataContext ► SitecoreDataContext()()()
Initializes a new instance of the SitecoreDataContext class
Declaration Syntax
C#
public SitecoreDataContext()


SitecoreDataContext Constructor (connection)

SitecoreDataContext Constructor (connection)
Namespaces ► Sitecore ► SitecoreDataContext ► SitecoreDataContext(IDbConnection)
Initializes a new instance of the SitecoreDataContext class
Declaration Syntax
C#
public SitecoreDataContext(
    IDbConnection connection
)
Parameters
connection (IDbConnection)


SitecoreDataContext Constructor (connection, mappingSource)

SitecoreDataContext Constructor (connection, mappingSource)
Namespaces ► Sitecore ► SitecoreDataContext ► SitecoreDataContext(IDbConnection, MappingSource)
Initializes a new instance of the SitecoreDataContext class
Declaration Syntax
C#
public SitecoreDataContext(
    IDbConnection connection,
    MappingSource mappingSource
)
Parameters
connection (IDbConnection)
mappingSource (MappingSource)


SitecoreDataContext Constructor (connection)

SitecoreDataContext Constructor (connection)
Namespaces ► Sitecore ► SitecoreDataContext ► SitecoreDataContext(String)
Initializes a new instance of the SitecoreDataContext class
Declaration Syntax
C#
public SitecoreDataContext(
    string connection
)
Parameters
connection (String)


SitecoreDataContext Constructor (connection, mappingSource)

SitecoreDataContext Constructor (connection, mappingSource)
Namespaces ► Sitecore ► SitecoreDataContext ► SitecoreDataContext(String, MappingSource)
Initializes a new instance of the SitecoreDataContext class
Declaration Syntax
C#
public SitecoreDataContext(
    string connection,
    MappingSource mappingSource
)
Parameters
connection (String)
mappingSource (MappingSource)


Fields Property

Fields Property
Namespaces ► Sitecore ► SitecoreDataContext ► Fields
Declaration Syntax
C#
public Table<Field> Fields { get; }


Items Property

Items Property
Namespaces ► Sitecore ► SitecoreDataContext ► Items
Declaration Syntax
C#
public Table<Item> Items { get; }


Languages Property

Languages Property
Namespaces ► Sitecore ► SitecoreDataContext ► Languages
Declaration Syntax
C#
public Table<Language> Languages { get; }


Revisions Property

Revisions Property
Namespaces ► Sitecore ► SitecoreDataContext ► Revisions
Declaration Syntax
C#
public Table<Revision> Revisions { get; }


TemplateFields Property

TemplateFields Property
Namespaces ► Sitecore ► SitecoreDataContext ► TemplateFields
Declaration Syntax
C#
public Table<TemplateField> TemplateFields { get; }


TemplateFieldTypes Property

TemplateFieldTypes Property
Namespaces ► Sitecore ► SitecoreDataContext ► TemplateFieldTypes
Declaration Syntax
C#
public Table<TemplateFieldType> TemplateFieldTypes { get; }


Templates Property

Templates Property
Namespaces ► Sitecore ► SitecoreDataContext ► Templates
Declaration Syntax
C#
public Table<Template> Templates { get; }


Versions Property

Versions Property
Namespaces ► Sitecore ► SitecoreDataContext ► Versions
Declaration Syntax
C#
public Table<Version> Versions { get; }


StringFormatMethodAttribute Class

StringFormatMethodAttribute Class
Namespaces ► Sitecore ► StringFormatMethodAttribute
Declaration Syntax
C#
public class StringFormatMethodAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringFormatMethodAttribute(String) | Initializes a new instance of the StringFormatMethodAttribute class.
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatParameterName | Gets the name of the format parameter.
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | StringFormatMethodAttribute


StringFormatMethodAttribute Constructor (formatParameterName)

StringFormatMethodAttribute Constructor (formatParameterName)
Namespaces ► Sitecore ► StringFormatMethodAttribute ► StringFormatMethodAttribute(String)
Initializes a new instance of the StringFormatMethodAttribute class.
Declaration Syntax
C#
public StringFormatMethodAttribute(
    string formatParameterName
)
Parameters
formatParameterName (String)
Name of the format parameter.


FormatParameterName Property

FormatParameterName Property
Namespaces ► Sitecore ► StringFormatMethodAttribute ► FormatParameterName
Gets the name of the format parameter.
Declaration Syntax
C#
public string FormatParameterName { get; }
Value
The name of the format parameter.


StringUtil Class

StringUtil Class
Namespaces ► Sitecore ► StringUtil
Implements a utility class for manipulating strings.
Declaration Syntax
C#
public sealed class StringUtil
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | StringUtil()()() | Initializes a new instance of the StringUtil class
 | ArrayToString(Array, Char) | Arrays to string.
 | Capitalize(String) | Uppercases the first letter of a string and lowercases the remaining letters.
 | Clip(String, Int32, Boolean) | Clips a string at a certain length.
 | Combine(Object, Object, String) | Combines the specified parts.
 | Concat(array<Object>[]()[]) | Concats the specified values.
 | Contains(String, array<String>[]()[]) | Determines whether [contains] [the specified text].
 | CutUp(String, Int32) | Cuts a string into evenly sized parts.
 | Decode(array<Byte>[]()[]) | Decodes the specified bytes.
 | DecodeMessageParameter(String) | Decodes the message parameter.
 | DictionaryToNameValues(SafeDictionary<(Of <(String>)>)) | Dictionaries to name values.
 | Divide(String, Char, Boolean) | Divides a string using a specified separator character.
 | DivideAtDigit(String) | Divides a string in two at the first digit.
 | Encode(String) | Encodes the specified text.
 | EncodeMessageParameter(String) | Encodes the message parameter.
 | EnsurePostfix(Char, String) | Ensures that a string has a certain postfix.
 | EnsurePrefix(Char, String) | Ensures that a string has a certain prefix.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EscapeBackslash(String) | Escapes the backslash.
 | EscapeJavascriptString(String) | Escapes the javascript string.
 | EscapeJavascriptString(String, Boolean) | Escapes the javascript string.
 | EscapeQuote(String) | Escapes the quote.
 | ExtractParameter(String, String) | Extracts a parameter string from a query string formatted string.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLastPart(String, Char, String) | Gets the last part.
 | GetLastPostfix(String, Char) | Gets the last postfix part of a string.
 | GetLastPostfix(String, Char, String) | Gets the postfix part of a string.
 | GetLongestPrefix(String, Char) | Gets the longest prefix.
 | GetLongestPrefix(String, Char, String) | Gets the longest prefix.
 | GetNameValues(String) | Converts a string to a name/value collection.
 | GetNameValues(String, Char, Char) | Converts a string to a name/value collection.
 | GetNameValues(array<String>[]()[]) | Gets a name/value collection from a string array.
 | GetPostfix(String, Char) | Gets the postfix part of a string.
 | GetPostfix(String, Char, String) | Gets the postfix part of a string.
 | GetPrefix(String, Char) | Gets the prefix part of a string.
 | GetPrefix(String, Char, String) | Gets the prefix part of a string.
 | GetSizeString(Int64) | Gets the size string.
 | GetString(Object) | Gets the string.
 | GetString(Object, String) | Gets the string.
 | GetString(array<String>[]()[]) | Gets a non-empty string from a list.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(String, array<String>[]()[]) | Searches for the text and returns the zero-based index of the first occurrence within the entire string.
 | IndexOf(String, Char, Int32) | Searches for the text and returns the zero-based index of the first occurrence within the entire string.
 | IsWhiteSpace(String) | Determines whether [is white space] [the specified s].
 | Join(IEnumerable, String) | Joins the specified enumerable.
 | Join(IEnumerable, String, String) | Joins the specified enumerable.
 | Left(String, Int32) | Gets the leftmost part of a string.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Mid(String, Int32) | Gets the middle part of a string.
 | Mid(String, Int32, Int32) | Gets the middle part of a string.
 | NameValuesToDictionary(NameValueCollection) | Names the values to dictionary.
 | NameValuesToString(NameValueCollection) | Names the values to string.
 | NameValuesToString(NameValueCollection, String) | Names the values to string.
 | ParseArguments(String) | Parses an argument list into a string array.
 | ParseNameValueCollection(String, Char, Char) | Parses the name value.
 | ParseSizeString(String) | Parses a size string (10KB, 20MB, etc.).
 | ReadPhrase(String, Int32, Char, Char, Int32%) | Reads a phrase from a string.
 | RemoveLineFeeds(String) | Remove tags from a string.
 | RemovePostfix(Char, String) | Removes a postfix from a string.
 | RemovePostfix(String, String) | Removes a specific prefix from a string.
 | RemovePrefix(String, String) | Removes a specific prefix from a string.
 | RemovePrefix(Char, String) | Removes a prefix from a string.
 | RemoveTags(String) | Remove tags from a string.
 | Repeat(String, Int32) | Repeats a string a number of times.
 | Replace(String, array<Char>[]()[], array<String>[]()[]) | Replace a character array with strings.
 | Right(String, Int32) | Gets the rightmost part of a string.
 | Split(String, Char, Char) | Splits a string while protecting phrases.
 | Split(String, Char, Boolean) | Splits a string, optionally trimming parts.
 | StringArrayToNameValueCollection(array<String>[]()[]) | Strings the array to name value collection.
 | StringCollectionToString(StringCollection) | Converts a string collection to a string
 | StringCollectionToString(StringCollection, String) | Converts a string collection to a string
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimEnd(String, Int32) | Trims the end.
 | TrimStart(String, Int32) | Trims the start.
 | Unquote(String) | Removes enclosing single and double quotes from a string.
Remarks
Inheritance Hierarchy
Object
StringUtil
See Also
DateUtil
MainUtil
StringUtil


StringUtil Constructor

StringUtil Constructor
Namespaces ► Sitecore ► StringUtil ► StringUtil()()()
Initializes a new instance of the StringUtil class
Declaration Syntax
C#
public StringUtil()


ArrayToString Method (array, delimiter)

ArrayToString Method (array, delimiter)
Namespaces ► Sitecore ► StringUtil ► ArrayToString(Array, Char)
Arrays to string.
Declaration Syntax
C#
public static string ArrayToString(
    Array array,
    char delimiter
)
Parameters
array (Array)
The array.
delimiter (Char)
The delimiter.
Return Value


Capitalize Method (text)

Capitalize Method (text)
Namespaces ► Sitecore ► StringUtil ► Capitalize(String)
Uppercases the first letter of a string and lowercases the remaining letters.
Declaration Syntax
C#
public static string Capitalize(
    string text
)
Parameters
text (String)
A string.
Return Value
The capitalized string.
Remarks
Sentences are not taken into account.
Examples
CopyC#
string text = MainUtil.Capitalize("HELLO WORLD."); // "Hello world"
string text = MainUtil.Capitalize("HELLO. HOW ARE YOU?"); // "Hello. how are you?"


Clip Method (text, length, ellipsis)

Clip Method (text, length, ellipsis)
Namespaces ► Sitecore ► StringUtil ► Clip(String, Int32, Boolean)
Clips a string at a certain length.
Declaration Syntax
C#
public static string Clip(
    string text,
    int length,
    bool ellipsis
)
Parameters
text (String)
The text that will be clipped.
length (Int32)
The maximum length of the returned string.
ellipsis (Boolean)
Indicates if the string should have en ellipsis (...) appended
Return Value
The clipped string.
Examples
CopyC#
string s0 = StringUtil.Clip("Hello world", 5, false); // "Hello"
string s1 = StringUtil.Clip("Hello world", 5, true);  // "He..."


Combine Method (part1, part2, divider)

Combine Method (part1, part2, divider)
Namespaces ► Sitecore ► StringUtil ► Combine(Object, Object, String)
Combines the specified parts.
Declaration Syntax
C#
public static string Combine(
    Object part1,
    Object part2,
    string divider
)
Parameters
part1 (Object)
The part1.
part2 (Object)
The part2.
divider (String)
The divider.
Return Value


Concat Method (values)

Concat Method (values)
Namespaces ► Sitecore ► StringUtil ► Concat(array<Object>[]()[])
Concats the specified values.
Declaration Syntax
C#
public static string Concat(
    params Object[] values
)
Parameters
values (array< Object >[]()[])
The values.
Return Value


Contains Method (text, texts)

Contains Method (text, texts)
Namespaces ► Sitecore ► StringUtil ► Contains(String, array<String>[]()[])
Determines whether [contains] [the specified text].
Declaration Syntax
C#
public static bool Contains(
    string text,
    string[] texts
)
Parameters
text (String)
The text.
texts (array< String >[]()[])
The texts.
Return Value
true if [contains] [the specified text]; otherwise, false.


CutUp Method (text, chunkSize)

CutUp Method (text, chunkSize)
Namespaces ► Sitecore ► StringUtil ► CutUp(String, Int32)
Cuts a string into evenly sized parts.
Declaration Syntax
C#
public static ArrayList CutUp(
    string text,
    int chunkSize
)
Parameters
text (String)
A string.
chunkSize (Int32)
Number of characters in a parts.
Return Value
An array list of strings.
Examples
CopyC#
string text = "Hello world";
ArrayList list = StringUtil.Cut(test, 3);
// "Hel", "llo", " wo", "rld"


Decode Method (bytes)

Decode Method (bytes)
Namespaces ► Sitecore ► StringUtil ► Decode(array<Byte>[]()[])
Decodes the specified bytes.
Declaration Syntax
C#
public static string Decode(
    byte[] bytes
)
Parameters
bytes (array< Byte >[]()[])
The bytes.
Return Value


DecodeMessageParameter Method (value)

DecodeMessageParameter Method (value)
Namespaces ► Sitecore ► StringUtil ► DecodeMessageParameter(String)
Decodes the message parameter.
Declaration Syntax
C#
public static string DecodeMessageParameter(
    string value
)
Parameters
value (String)
The value.
Return Value
The message parameter.


DictionaryToNameValues Method (dictionary)

DictionaryToNameValues Method (dictionary)
Namespaces ► Sitecore ► StringUtil ► DictionaryToNameValues(SafeDictionary<(Of <(String>)>))
Dictionaries to name values.
Declaration Syntax
C#
public static NameValueCollection DictionaryToNameValues(
    SafeDictionary<string> dictionary
)
Parameters
dictionary (SafeDictionary <(Of <( String >)>))
The dictionary.
Return Value
The to name values.


Divide Method (value, separator, useLastSeparator)

Divide Method (value, separator, useLastSeparator)
Namespaces ► Sitecore ► StringUtil ► Divide(String, Char, Boolean)
Divides a string using a specified separator character.
Declaration Syntax
C#
public static string[] Divide(
    string value,
    char separator,
    bool useLastSeparator
)
Parameters
value (String)
The value.
separator (Char)
The separator.
useLastSeparator (Boolean)
if set to true this instance is use last separator.
Return Value
Examples
StringUtil.Divide("da-DK-kl", '-', false);  // returns {"da", "DK-kl"}
StringUtil.Divide("da-DK-kl", '-', true);  // returns {"da-DK", "kl"}
StringUtil.Divide("da", '-', false);  // returns {"da"}


DivideAtDigit Method (value)

DivideAtDigit Method (value)
Namespaces ► Sitecore ► StringUtil ► DivideAtDigit(String)
Divides a string in two at the first digit.
Declaration Syntax
C#
public static string[] DivideAtDigit(
    string value
)
Parameters
value (String)
The value.
Return Value
Examples
StringUtil.DivideAtDigit("da-DK12"); // returns {"da-DK", "12"} StringUtil.DivideAtDigit("da-DK"); // returns {"da-DK"}


Encode Method (text)

Encode Method (text)
Namespaces ► Sitecore ► StringUtil ► Encode(String)
Encodes the specified text.
Declaration Syntax
C#
public static byte[] Encode(
    string text
)
Parameters
text (String)
The text.
Return Value


EncodeMessageParameter Method (value)

EncodeMessageParameter Method (value)
Namespaces ► Sitecore ► StringUtil ► EncodeMessageParameter(String)
Encodes the message parameter.
Declaration Syntax
C#
public static string EncodeMessageParameter(
    string value
)
Parameters
value (String)
The value.
Return Value
The message parameter.


EnsurePostfix Method (postfix, value)

EnsurePostfix Method (postfix, value)
Namespaces ► Sitecore ► StringUtil ► EnsurePostfix(Char, String)
Ensures that a string has a certain postfix.
Declaration Syntax
C#
public static string EnsurePostfix(
    char postfix,
    string value
)
Parameters
postfix (Char)
The postfix.
value (String)
The value.
Return Value


EnsurePrefix Method (prefix, value)

EnsurePrefix Method (prefix, value)
Namespaces ► Sitecore ► StringUtil ► EnsurePrefix(Char, String)
Ensures that a string has a certain prefix.
Declaration Syntax
C#
public static string EnsurePrefix(
    char prefix,
    string value
)
Parameters
prefix (Char)
The prefix.
value (String)
The value.
Return Value


EscapeBackslash Method (test)

EscapeBackslash Method (test)
Namespaces ► Sitecore ► StringUtil ► EscapeBackslash(String)
Escapes the backslash.
Declaration Syntax
C#
public static string EscapeBackslash(
    string test
)
Parameters
test (String)
The name.
Return Value


EscapeJavascriptString Method

EscapeJavascriptString Method
Namespaces ► Sitecore ► StringUtil ► EscapeJavascriptString()()()
Members
Icon | Member | Description
 | EscapeJavascriptString(String) | Escapes the javascript string.
 | EscapeJavascriptString(String, Boolean) | Escapes the javascript string.


EscapeJavascriptString Method (text)

EscapeJavascriptString Method (text)
Namespaces ► Sitecore ► StringUtil ► EscapeJavascriptString(String)
Escapes the javascript string.
Declaration Syntax
C#
public static string EscapeJavascriptString(
    string text
)
Parameters
text (String)
The text.
Return Value


EscapeJavascriptString Method (text, surroundWithQuotes)

EscapeJavascriptString Method (text, surroundWithQuotes)
Namespaces ► Sitecore ► StringUtil ► EscapeJavascriptString(String, Boolean)
Escapes the javascript string.
Declaration Syntax
C#
public static string EscapeJavascriptString(
    string text,
    bool surroundWithQuotes
)
Parameters
text (String)
The text.
surroundWithQuotes (Boolean)
Surround with quotes.
Return Value


EscapeQuote Method (text)

EscapeQuote Method (text)
Namespaces ► Sitecore ► StringUtil ► EscapeQuote(String)
Escapes the quote.
Declaration Syntax
C#
public static string EscapeQuote(
    string text
)
Parameters
text (String)
The text.
Return Value


ExtractParameter Method (name, parameters)

ExtractParameter Method (name, parameters)
Namespaces ► Sitecore ► StringUtil ► ExtractParameter(String, String)
Extracts a parameter string from a query string formatted string.
Declaration Syntax
C#
public static string ExtractParameter(
    string name,
    string parameters
)
Parameters
name (String)
The name of the parameter to find.
parameters (String)
A query string formatted string, e.g. "a=1&b=2&myparam=3"
Return Value
The value of the named parameter.
Remarks
If the name was not found, blank is returned.
Examples
CopyC#
string parameters = "print=1&target=/sitecore/content/home&test=false";
string print = StringUtil.ExtractParameter("print", parameters); // "1"
string target = StringUtil.ExtractParameter("target", parameters); // "/sitecore/content/home"
string dummy = StringUtil.ExtractParameter("dummy", parameters); // ""


GetLastPart Method (text, delimiter, defaultValue)

GetLastPart Method (text, delimiter, defaultValue)
Namespaces ► Sitecore ► StringUtil ► GetLastPart(String, Char, String)
Gets the last part.
Declaration Syntax
C#
public static string GetLastPart(
    string text,
    char delimiter,
    string defaultValue
)
Parameters
text (String)
The text.
delimiter (Char)
The delimiter.
defaultValue (String)
The default value.
Return Value


GetLastPostfix Method

GetLastPostfix Method
Namespaces ► Sitecore ► StringUtil ► GetLastPostfix()()()
Members
Icon | Member | Description
 | GetLastPostfix(String, Char) | Gets the last postfix part of a string.
 | GetLastPostfix(String, Char, String) | Gets the postfix part of a string.


GetLastPostfix Method (text, delimiter)

GetLastPostfix Method (text, delimiter)
Namespaces ► Sitecore ► StringUtil ► GetLastPostfix(String, Char)
Gets the last postfix part of a string.
Declaration Syntax
C#
public static string GetLastPostfix(
    string text,
    char delimiter
)
Parameters
text (String)
A string
delimiter (Char)
The character delimiting the postfix from the rest of the string.
Return Value

All characters of the string starting from character after the last occurrence of delimiter.

If delimiter is not found in the string, an empty string is returned.

Examples
CopyC#
string postfix = StringUtil.GetPostfix("sc:menu:new", ':');
MainUtil.Out(postfix);
 Outputs: new
See Also
GetPostfix(String, Char)


GetLastPostfix Method (text, delimiter, defaultValue)

GetLastPostfix Method (text, delimiter, defaultValue)
Namespaces ► Sitecore ► StringUtil ► GetLastPostfix(String, Char, String)
Gets the postfix part of a string.
Declaration Syntax
C#
public static string GetLastPostfix(
    string text,
    char delimiter,
    string defaultValue
)
Parameters
text (String)
A string
delimiter (Char)
The character delimiting the postfix from the rest of the string.
defaultValue (String)
Value to return if delimiter is not found in text
Return Value

All characters of the string starting from character after the last occurrence of delimiter.

If delimiter is not found in the string, defaultValue is returned.

Examples
CopyC#
string postfix = StringUtil.GetPostfix("sc:menu:new", ':');
MainUtil.Out(postfix);
 Outputs: new
See Also
GetPostfix(String, Char, String)


GetLongestPrefix Method

GetLongestPrefix Method
Namespaces ► Sitecore ► StringUtil ► GetLongestPrefix()()()
Members
Icon | Member | Description
 | GetLongestPrefix(String, Char) | Gets the longest prefix.
 | GetLongestPrefix(String, Char, String) | Gets the longest prefix.


GetLongestPrefix Method (text, delimiter)

GetLongestPrefix Method (text, delimiter)
Namespaces ► Sitecore ► StringUtil ► GetLongestPrefix(String, Char)
Gets the longest prefix.
Declaration Syntax
C#
public static string GetLongestPrefix(
    string text,
    char delimiter
)
Parameters
text (String)
The text.
delimiter (Char)
The delimiter.
Return Value


GetLongestPrefix Method (text, delimiter, defaultValue)

GetLongestPrefix Method (text, delimiter, defaultValue)
Namespaces ► Sitecore ► StringUtil ► GetLongestPrefix(String, Char, String)
Gets the longest prefix.
Declaration Syntax
C#
public static string GetLongestPrefix(
    string text,
    char delimiter,
    string defaultValue
)
Parameters
text (String)
The text.
delimiter (Char)
The delimiter.
defaultValue (String)
The default value.
Return Value


GetNameValues Method

GetNameValues Method
Namespaces ► Sitecore ► StringUtil ► GetNameValues()()()
Members
Icon | Member | Description
 | GetNameValues(String) | Converts a string to a name/value collection.
 | GetNameValues(String, Char, Char) | Converts a string to a name/value collection.
 | GetNameValues(array<String>[]()[]) | Gets a name/value collection from a string array.


GetNameValues Method (list)

GetNameValues Method (list)
Namespaces ► Sitecore ► StringUtil ► GetNameValues(String)
Converts a string to a name/value collection.
Declaration Syntax
C#
public static NameValueCollection GetNameValues(
    string list
)
Parameters
list (String)
A string of separated values.
Return Value
A name/value collection.
Remarks
The format of the string must be "name=value|name=value...". The name/value collection is built by using values from the string in pairs. A string consisting of "Name1=Value1|Name2=Value2" are converted to ("Name1", "Value1"), ("Name2", "Value2").
Examples
CopyC#
NameValueCollection collection = StringUtil.GetNameValues("Name1=Value1|Name2=Value2");


GetNameValues Method (list, equal, separator)

GetNameValues Method (list, equal, separator)
Namespaces ► Sitecore ► StringUtil ► GetNameValues(String, Char, Char)
Converts a string to a name/value collection.
Declaration Syntax
C#
public static NameValueCollection GetNameValues(
    string list,
    char equal,
    char separator
)
Parameters
list (String)
A string of separated values.
equal (Char)
Name/value pair separator.
separator (Char)
Pair separator.
Return Value
A name/value collection.
Remarks
The name/value collection is built by using values from the string in pairs. A string consisting of "Name1=Value1|Name2=Value2" are converted to ("Name1", "Value1"), ("Name2", "Value2").
Examples
CopyC#
NameValueCollection collection = StringUtil.GetNameValues("Name1=Value1|Name2=Value2", '=', '|');


GetNameValues Method (list)

GetNameValues Method (list)
Namespaces ► Sitecore ► StringUtil ► GetNameValues(array<String>[]()[])
Gets a name/value collection from a string array.
Declaration Syntax
C#
public static NameValueCollection GetNameValues(
    string[] list
)
Parameters
list (array< String >[]()[])
An array of strings.
Return Value
A name/value collection.
Remarks
The name/value collection is built by using values from the string array in pairs. A string array consisting of { "Name1, "Value1", "Name2", "Value2" } are converted to ("Name1", "Value1"), ("Name2", "Value2").
Examples
CopyC#
NameValueCollection collection = StringUtil.GetNameValues(new string[] {"Name1", "Value1", "Name2", "Value2" });


GetPostfix Method

GetPostfix Method
Namespaces ► Sitecore ► StringUtil ► GetPostfix()()()
Members
Icon | Member | Description
 | GetPostfix(String, Char) | Gets the postfix part of a string.
 | GetPostfix(String, Char, String) | Gets the postfix part of a string.


GetPostfix Method (text, delimiter)

GetPostfix Method (text, delimiter)
Namespaces ► Sitecore ► StringUtil ► GetPostfix(String, Char)
Gets the postfix part of a string.
Declaration Syntax
C#
public static string GetPostfix(
    string text,
    char delimiter
)
Parameters
text (String)
A string
delimiter (Char)
The character delimiting the postfix from the rest of the string.
Return Value

All characters of the string starting from character after the first occurrence of delimiter.

If delimiter is not found in the string, an empty string is returned.

Examples
CopyC#
string postfix = StringUtil.GetPostfix("sc:menu", ':');
MainUtil.Out(postfix);
 Outputs: menu
See Also
Right(String, Int32)
Mid(String, Int32)


GetPostfix Method (text, delimiter, defaultValue)

GetPostfix Method (text, delimiter, defaultValue)
Namespaces ► Sitecore ► StringUtil ► GetPostfix(String, Char, String)
Gets the postfix part of a string.
Declaration Syntax
C#
public static string GetPostfix(
    string text,
    char delimiter,
    string defaultValue
)
Parameters
text (String)
A string
delimiter (Char)
The character delimiting the postfix from the rest of the string.
defaultValue (String)
Value to return if delimiter is not found in text
Return Value

All characters of the string starting from character after the first occurrence of delimiter.

If delimiter is not found in the string, defaultValue is returned.

Examples
CopyC#
string postfix = StringUtil.GetPostfix("sc:menu", ':');
MainUtil.Out(postfix);
 Outputs: menu
See Also
Right(String, Int32)
Mid(String, Int32)


GetPrefix Method

GetPrefix Method
Namespaces ► Sitecore ► StringUtil ► GetPrefix()()()
Members
Icon | Member | Description
 | GetPrefix(String, Char) | Gets the prefix part of a string.
 | GetPrefix(String, Char, String) | Gets the prefix part of a string.


GetPrefix Method (text, delimiter)

GetPrefix Method (text, delimiter)
Namespaces ► Sitecore ► StringUtil ► GetPrefix(String, Char)
Gets the prefix part of a string.
Declaration Syntax
C#
public static string GetPrefix(
    string text,
    char delimiter
)
Parameters
text (String)
A string
delimiter (Char)
The character delimiting the prefix from the rest of the string.
Return Value

All characters of the string up to the first occurrence of delimiter.

If delimiter is not found in the string, an empty string is returned.

Examples
CopyC#
string prefix = StringUtil.GetPrefix("sc:menu", ':');
MainUtil.Out(prefix);
 Outputs: sc
See Also
Right(String, Int32)
Mid(String, Int32)


GetPrefix Method (text, delimiter, defaultValue)

GetPrefix Method (text, delimiter, defaultValue)
Namespaces ► Sitecore ► StringUtil ► GetPrefix(String, Char, String)
Gets the prefix part of a string.
Declaration Syntax
C#
public static string GetPrefix(
    string text,
    char delimiter,
    string defaultValue
)
Parameters
text (String)
A string
delimiter (Char)
The character delimiting the prefix from the rest of the string.
defaultValue (String)
Value to return if delimiter is not found in text
Return Value

All characters of the string up to the first occurrence of delimiter.

If delimiter is not found in the string, defaultValue is returned.

Examples
CopyC#
string prefix = StringUtil.GetPrefix("sc:menu", ':');
MainUtil.Out(prefix);
 Outputs: sc
See Also
Right(String, Int32)
Mid(String, Int32)


GetSizeString Method (size)

GetSizeString Method (size)
Namespaces ► Sitecore ► StringUtil ► GetSizeString(Int64)
Gets the size string.
Declaration Syntax
C#
public static string GetSizeString(
    long size
)
Parameters
size (Int64)
The size.
Return Value


GetString Method

GetString Method
Namespaces ► Sitecore ► StringUtil ► GetString()()()
Members
Icon | Member | Description
 | GetString(Object) | Gets the string.
 | GetString(Object, String) | Gets the string.
 | GetString(array<String>[]()[]) | Gets a non-empty string from a list.


GetString Method (value)

GetString Method (value)
Namespaces ► Sitecore ► StringUtil ► GetString(Object)
Gets the string.
Declaration Syntax
C#
public static string GetString(
    Object value
)
Parameters
value (Object)
The value.
Return Value
The string.


GetString Method (value, defaultValue)

GetString Method (value, defaultValue)
Namespaces ► Sitecore ► StringUtil ► GetString(Object, String)
Gets the string.
Declaration Syntax
C#
public static string GetString(
    Object value,
    string defaultValue
)
Parameters
value (Object)
The value.
defaultValue (String)
The default value.
Return Value
The string.


GetString Method (values)

GetString Method (values)
Namespaces ► Sitecore ► StringUtil ► GetString(array<String>[]()[])
Gets a non-empty string from a list.
Declaration Syntax
C#
public static string GetString(
    params string[] values
)
Parameters
values (array< String >[]()[])
The values.
Return Value
The string.


IndexOf Method

IndexOf Method
Namespaces ► Sitecore ► StringUtil ► IndexOf()()()
Members
Icon | Member | Description
 | IndexOf(String, array<String>[]()[]) | Searches for the text and returns the zero-based index of the first occurrence within the entire string.
 | IndexOf(String, Char, Int32) | Searches for the text and returns the zero-based index of the first occurrence within the entire string.


IndexOf Method (text, value, occurrence)

IndexOf Method (text, value, occurrence)
Namespaces ► Sitecore ► StringUtil ► IndexOf(String, Char, Int32)
Searches for the text and returns the zero-based index of the first occurrence within the entire string.
Declaration Syntax
C#
public static int IndexOf(
    string text,
    char value,
    int occurrence
)
Parameters
text (String)
The text.
value (Char)
The value.
occurrence (Int32)
The occurrence.
Return Value


IndexOf Method (text, texts)

IndexOf Method (text, texts)
Namespaces ► Sitecore ► StringUtil ► IndexOf(String, array<String>[]()[])
Searches for the text and returns the zero-based index of the first occurrence within the entire string.
Declaration Syntax
C#
public static int IndexOf(
    string text,
    string[] texts
)
Parameters
text (String)
The text.
texts (array< String >[]()[])
The texts.
Return Value


IsWhiteSpace Method (s)

IsWhiteSpace Method (s)
Namespaces ► Sitecore ► StringUtil ► IsWhiteSpace(String)
Determines whether [is white space] [the specified s].
Declaration Syntax
C#
public static bool IsWhiteSpace(
    string s
)
Parameters
s (String)
The s.
Return Value
true if [is white space] [the specified s]; otherwise, false.


Join Method

Join Method
Namespaces ► Sitecore ► StringUtil ► Join()()()
Members
Icon | Member | Description
 | Join(IEnumerable, String) | Joins the specified enumerable.
 | Join(IEnumerable, String, String) | Joins the specified enumerable.


Join Method (enumerable, separator)

Join Method (enumerable, separator)
Namespaces ► Sitecore ► StringUtil ► Join(IEnumerable, String)
Joins the specified enumerable.
Declaration Syntax
C#
public static string Join(
    IEnumerable enumerable,
    string separator
)
Parameters
enumerable (IEnumerable)
The enumerable.
separator (String)
The separator.
Return Value
The join.


Join Method (enumerable, separator, propertyName)

Join Method (enumerable, separator, propertyName)
Namespaces ► Sitecore ► StringUtil ► Join(IEnumerable, String, String)
Joins the specified enumerable.
Declaration Syntax
C#
public static string Join(
    IEnumerable enumerable,
    string separator,
    string propertyName
)
Parameters
enumerable (IEnumerable)
The enumerable.
separator (String)
The separator.
propertyName (String)
Name of the property.
Return Value
The join.


Left Method (text, length)

Left Method (text, length)
Namespaces ► Sitecore ► StringUtil ► Left(String, Int32)
Gets the leftmost part of a string.
Declaration Syntax
C#
public static string Left(
    string text,
    int length
)
Parameters
text (String)
A string
length (Int32)
The number of character to return.
Return Value
The first length characters of the string.
Examples
CopyC#
string left = StringUtil.Left("Hello world", 5); // "Hello"
See Also
Right(String, Int32)
Mid(String, Int32)


Mid Method

Mid Method
Namespaces ► Sitecore ► StringUtil ► Mid()()()
Members
Icon | Member | Description
 | Mid(String, Int32) | Gets the middle part of a string.
 | Mid(String, Int32, Int32) | Gets the middle part of a string.


Mid Method (text, start)

Mid Method (text, start)
Namespaces ► Sitecore ► StringUtil ► Mid(String, Int32)
Gets the middle part of a string.
Declaration Syntax
C#
public static string Mid(
    string text,
    int start
)
Parameters
text (String)
A string.
start (Int32)
The starting index into the string.
Return Value
The rightmost part of the string starting at the start position.
Remarks
If start is greater than the length of the string, the blank is returned.
Examples
CopyC#
string result = StringUtil.Mid("Hello world", 6); / "world"
See Also
Left(String, Int32)
Right(String, Int32)


Mid Method (text, start, length)

Mid Method (text, start, length)
Namespaces ► Sitecore ► StringUtil ► Mid(String, Int32, Int32)
Gets the middle part of a string.
Declaration Syntax
C#
public static string Mid(
    string text,
    int start,
    int length
)
Parameters
text (String)
A string.
start (Int32)
The starting index into the string.
length (Int32)
The number of returned characters
Return Value
The rightmost part of the string starting at the start position.
Remarks
Examples
CopyC#
string result = StringUtil.Mid("Hello world", 6, 3); / "wor"
See Also
Left(String, Int32)
Right(String, Int32)


NameValuesToDictionary Method (values)

NameValuesToDictionary Method (values)
Namespaces ► Sitecore ► StringUtil ► NameValuesToDictionary(NameValueCollection)
Names the values to dictionary.
Declaration Syntax
C#
public static SafeDictionary<string> NameValuesToDictionary(
    NameValueCollection values
)
Parameters
values (NameValueCollection)
The values.
Return Value
The values to dictionary.


NameValuesToString Method

NameValuesToString Method
Namespaces ► Sitecore ► StringUtil ► NameValuesToString()()()
Members
Icon | Member | Description
 | NameValuesToString(NameValueCollection) | Names the values to string.
 | NameValuesToString(NameValueCollection, String) | Names the values to string.


NameValuesToString Method (values)

NameValuesToString Method (values)
Namespaces ► Sitecore ► StringUtil ► NameValuesToString(NameValueCollection)
Names the values to string.
Declaration Syntax
C#
public static string NameValuesToString(
    NameValueCollection values
)
Parameters
values (NameValueCollection)
The values.
Return Value


NameValuesToString Method (values, divider)

NameValuesToString Method (values, divider)
Namespaces ► Sitecore ► StringUtil ► NameValuesToString(NameValueCollection, String)
Names the values to string.
Declaration Syntax
C#
public static string NameValuesToString(
    NameValueCollection values,
    string divider
)
Parameters
values (NameValueCollection)
The values.
divider (String)
The divider.
Return Value


ParseArguments Method (arguments)

ParseArguments Method (arguments)
Namespaces ► Sitecore ► StringUtil ► ParseArguments(String)
Parses an argument list into a string array.
Declaration Syntax
C#
public static string[] ParseArguments(
    string arguments
)
Parameters
arguments (String)
The input string.
Return Value
Remarks
The input string has the format: '"String1", "String2"'. This will result in an array with two elements: String1 and String2. To escape the double quote character (") use two consequetive double quotes ("").


ParseNameValueCollection Method (text, nameSeparator, valueSeparator)

ParseNameValueCollection Method (text, nameSeparator, valueSeparator)
Namespaces ► Sitecore ► StringUtil ► ParseNameValueCollection(String, Char, Char)
Parses the name value.
Declaration Syntax
C#
public static NameValueCollection ParseNameValueCollection(
    string text,
    char nameSeparator,
    char valueSeparator
)
Parameters
text (String)
The text.
nameSeparator (Char)
The name separator.
valueSeparator (Char)
The value separator.
Return Value
The name value.


ParseSizeString Method (value)

ParseSizeString Method (value)
Namespaces ► Sitecore ► StringUtil ► ParseSizeString(String)
Parses a size string (10KB, 20MB, etc.).
Declaration Syntax
C#
public static long ParseSizeString(
    string value
)
Parameters
value (String)
The value.
Return Value


ReadPhrase Method (text, start, delimiter, quote, endPos)

ReadPhrase Method (text, start, delimiter, quote, endPos)
Namespaces ► Sitecore ► StringUtil ► ReadPhrase(String, Int32, Char, Char, Int32%)
Reads a phrase from a string.
Declaration Syntax
C#
public static string ReadPhrase(
    string text,
    int start,
    char delimiter,
    char quote,
    out int endPos
)
Parameters
text (String)
A string.
start (Int32)
Starting position into the string.
delimiter (Char)
A delimiter character.
quote (Char)
A quote character.
endPos ( Int32 %)
Returns the ending position.
Return Value
The phrase.
Remarks
A phrase is single word or words within quotes.


RemoveLineFeeds Method (text)

RemoveLineFeeds Method (text)
Namespaces ► Sitecore ► StringUtil ► RemoveLineFeeds(String)
Remove tags from a string.
Declaration Syntax
C#
public static string RemoveLineFeeds(
    string text
)
Parameters
text (String)
The text.
Return Value


RemovePostfix Method

RemovePostfix Method
Namespaces ► Sitecore ► StringUtil ► RemovePostfix()()()
Members
Icon | Member | Description
 | RemovePostfix(Char, String) | Removes a postfix from a string.
 | RemovePostfix(String, String) | Removes a specific prefix from a string.


RemovePostfix Method (postfix, value)

RemovePostfix Method (postfix, value)
Namespaces ► Sitecore ► StringUtil ► RemovePostfix(Char, String)
Removes a postfix from a string.
Declaration Syntax
C#
public static string RemovePostfix(
    char postfix,
    string value
)
Parameters
postfix (Char)
The postfix.
value (String)
The string value.
Return Value


RemovePostfix Method (postfix, value)

RemovePostfix Method (postfix, value)
Namespaces ► Sitecore ► StringUtil ► RemovePostfix(String, String)
Removes a specific prefix from a string.
Declaration Syntax
C#
public static string RemovePostfix(
    string postfix,
    string value
)
Parameters
postfix (String)
The postfix.
value (String)
The value.
Return Value


RemovePrefix Method

RemovePrefix Method
Namespaces ► Sitecore ► StringUtil ► RemovePrefix()()()
Members
Icon | Member | Description
 | RemovePrefix(String, String) | Removes a specific prefix from a string.
 | RemovePrefix(Char, String) | Removes a prefix from a string.


RemovePrefix Method (prefix, value)

RemovePrefix Method (prefix, value)
Namespaces ► Sitecore ► StringUtil ► RemovePrefix(Char, String)
Removes a prefix from a string.
Declaration Syntax
C#
public static string RemovePrefix(
    char prefix,
    string value
)
Parameters
prefix (Char)
The prefix.
value (String)
The string value.
Return Value


RemovePrefix Method (prefix, value)

RemovePrefix Method (prefix, value)
Namespaces ► Sitecore ► StringUtil ► RemovePrefix(String, String)
Removes a specific prefix from a string.
Declaration Syntax
C#
public static string RemovePrefix(
    string prefix,
    string value
)
Parameters
prefix (String)
The prefix.
value (String)
The value.


RemoveTags Method (text)

RemoveTags Method (text)
Namespaces ► Sitecore ► StringUtil ► RemoveTags(String)
Remove tags from a string.
Declaration Syntax
C#
public static string RemoveTags(
    string text
)
Parameters
text (String)
The text.
Return Value


Repeat Method (s, nCount)

Repeat Method (s, nCount)
Namespaces ► Sitecore ► StringUtil ► Repeat(String, Int32)
Repeats a string a number of times.
Declaration Syntax
C#
public static string Repeat(
    string s,
    int nCount
)
Parameters
s (String)
The string to be repeated.
nCount (Int32)
The number of times the string should be repeated.
Return Value
The string repeated the number of times.
Examples
CopyC#
string text = MainUtil.Repeat("abc", 3); // "abcabcabc"


Replace Method (text, find, replaceWith)

Replace Method (text, find, replaceWith)
Namespaces ► Sitecore ► StringUtil ► Replace(String, array<Char>[]()[], array<String>[]()[])
Replace a character array with strings.
Declaration Syntax
C#
public static string Replace(
    string text,
    char[] find,
    string[] replaceWith
)
Parameters
text (String)
The text.
find (array< Char >[]()[])
The find.
replaceWith (array< String >[]()[])
The replace.
Return Value


Right Method (text, length)

Right Method (text, length)
Namespaces ► Sitecore ► StringUtil ► Right(String, Int32)
Gets the rightmost part of a string.
Declaration Syntax
C#
public static string Right(
    string text,
    int length
)
Parameters
text (String)
A string.
length (Int32)
The number of characters to return.
Return Value
The rightmost length characters.
Examples
CopyC#
string text = StringUtil.Right("Hello world", 5); // "world"
See Also
Left(String, Int32)
Mid(String, Int32)


Split Method

Split Method
Namespaces ► Sitecore ► StringUtil ► Split()()()
Members
Icon | Member | Description
 | Split(String, Char, Char) | Splits a string while protecting phrases.
 | Split(String, Char, Boolean) | Splits a string, optionally trimming parts.


Split Method (text, delimiter, trim)

Split Method (text, delimiter, trim)
Namespaces ► Sitecore ► StringUtil ► Split(String, Char, Boolean)
Splits a string, optionally trimming parts.
Declaration Syntax
C#
public static string[] Split(
    string text,
    char delimiter,
    bool trim
)
Parameters
text (String)
A string.
delimiter (Char)
A delimiter character.
trim (Boolean)
A boolean indicating if the parts should be trimmed.
Return Value
An array list of string parts.
Examples
CopyC#
ArrayList list1 = StringUtil.Split("Hello | world", '|', true); /// "Hello", "world"
ArrayList list2 = StringUtil.Split("Hello | world", '|', false); /// "Hello ", " world"


Split Method (text, delimiter, quote)

Split Method (text, delimiter, quote)
Namespaces ► Sitecore ► StringUtil ► Split(String, Char, Char)
Splits a string while protecting phrases.
Declaration Syntax
C#
public static ArrayList Split(
    string text,
    char delimiter,
    char quote
)
Parameters
text (String)
A string.
delimiter (Char)
A delimiter character
quote (Char)
A quoute character.
Return Value
An array list of string parts.
Remarks
A phrase is a word within quotes.
Examples
CopyC#
ArrayList list = StringUtil.Split("Welcome 'Andy Parkinson' to Sitecore", ' ', '''');
// "Welcome", "Andy Parkinson", "to", "Sitecore"


StringArrayToNameValueCollection Method (strings)

StringArrayToNameValueCollection Method (strings)
Namespaces ► Sitecore ► StringUtil ► StringArrayToNameValueCollection(array<String>[]()[])
Strings the array to name value collection.
Declaration Syntax
C#
public static NameValueCollection StringArrayToNameValueCollection(
    string[] strings
)
Parameters
strings (array< String >[]()[])
The strings.
Return Value


StringCollectionToString Method

StringCollectionToString Method
Namespaces ► Sitecore ► StringUtil ► StringCollectionToString()()()
Members
Icon | Member | Description
 | StringCollectionToString(StringCollection) | Converts a string collection to a string
 | StringCollectionToString(StringCollection, String) | Converts a string collection to a string


StringCollectionToString Method (collection)

StringCollectionToString Method (collection)
Namespaces ► Sitecore ► StringUtil ► StringCollectionToString(StringCollection)
Converts a string collection to a string
Declaration Syntax
C#
public static string StringCollectionToString(
    StringCollection collection
)
Parameters
collection (StringCollection)
A collection of strings.
Return Value
The strings in collection concatenated with a pipe (|) in between.
Examples
CopyC#
StringCollection list = new StringCollection();
list.Add("1");
list.Add("2");
list.Add("3");
string result = StringUtil.StringCollectionToString(list); / "1|2|3"


StringCollectionToString Method (collection, delimiter)

StringCollectionToString Method (collection, delimiter)
Namespaces ► Sitecore ► StringUtil ► StringCollectionToString(StringCollection, String)
Converts a string collection to a string
Declaration Syntax
C#
public static string StringCollectionToString(
    StringCollection collection,
    string delimiter
)
Parameters
collection (StringCollection)
A collection of strings.
delimiter (String)
A string to put between each of the strings in the collection.
Return Value
The strings in collection concatenated with the delimiter in between.
Examples
CopyC#
StringCollection list = new StringCollection();
list.Add("1");
list.Add("2");
list.Add("3");
string result = StringUtil.StringCollectionToString(list, "|"); / "1|2|3"


TrimEnd Method (value, count)

TrimEnd Method (value, count)
Namespaces ► Sitecore ► StringUtil ► TrimEnd(String, Int32)
Trims the end.
Declaration Syntax
C#
public static string TrimEnd(
    string value,
    int count
)
Parameters
value (String)
The value.
count (Int32)
The count.
Return Value


TrimStart Method (value, count)

TrimStart Method (value, count)
Namespaces ► Sitecore ► StringUtil ► TrimStart(String, Int32)
Trims the start.
Declaration Syntax
C#
public static string TrimStart(
    string value,
    int count
)
Parameters
value (String)
The value.
count (Int32)
The count.
Return Value


Unquote Method (text)

Unquote Method (text)
Namespaces ► Sitecore ► StringUtil ► Unquote(String)
Removes enclosing single and double quotes from a string.
Declaration Syntax
C#
public static string Unquote(
    string text
)
Parameters
text (String)
A string.
Return Value
The unquoted string.
Examples
CopyC#
string s0 = StringUtil.Unquote("'Hello world'"); // "Hello world"
string s1 = StringUtil.Unquote("'Hello Andy's world'"); // "Hello Andy's world"


SystemFieldIDs Class

SystemFieldIDs Class
Namespaces ► Sitecore ► SystemFieldIDs
Implements a static class for holding well-known GUIDs relating to system fields.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static class SystemFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FieldVersioning | The id of the 'Field versioning' field.
 | MasterId | The id of the 'Master id' field.
 | Name | The id of the 'Name' field.
 | TemplateId | The id of the 'Template id' field.
Remarks
The class does not contain any functionality, but serves only as a placeholder for a predefined GUIDs.
Inheritance Hierarchy
Object
SystemFieldIDs


FieldVersioning Field

FieldVersioning Field
Namespaces ► Sitecore ► SystemFieldIDs ► FieldVersioning
The id of the 'Field versioning' field.
Declaration Syntax
C#
public static Guid FieldVersioning


MasterId Field

MasterId Field
Namespaces ► Sitecore ► SystemFieldIDs ► MasterId
The id of the 'Master id' field.
Declaration Syntax
C#
public static Guid MasterId


Name Field

Name Field
Namespaces ► Sitecore ► SystemFieldIDs ► Name
The id of the 'Name' field.
Declaration Syntax
C#
public static Guid Name


TemplateId Field

TemplateId Field
Namespaces ► Sitecore ► SystemFieldIDs ► TemplateId
The id of the 'Template id' field.
Declaration Syntax
C#
public static Guid TemplateId


TemplateFieldIDs Class

TemplateFieldIDs Class
Namespaces ► Sitecore ► TemplateFieldIDs
Implements a static class for holding well-known GUIDs relating to template fields.
Declaration Syntax
C#
public static class TemplateFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Blob | The ID of the 'Blob' field.
 | DefaultValue | The ID of the 'Default value' field.
 | Description | The ID of the Description 'Long description' field.
 | ExcludeFromTextSearch | The ID for ExcludeFromTextSearch field
 | HelpLink | The ID of the 'Help link' field.
 | ResetBlank | The ID of the 'Reset blank' field.
 | Shared | The ID of the Shared field.
 | Source | The ID of the Source field.
 | Title | The ID of the Title field.
 | ToolTip | The ID of the ToolTip ('Short description') field.
 | Type | The ID of the Type field.
 | Unversioned | The ID of the Unversioned field.
 | Validation | The ID of the Validation field.
 | ValidationText | The ID of the ValidationText field.
Remarks
The class does not contain any functionality, but serves only as a placeholder for a predefined GUIDs.
Inheritance Hierarchy
Object
TemplateFieldIDs


Blob Field

Blob Field
Namespaces ► Sitecore ► TemplateFieldIDs ► Blob
The ID of the 'Blob' field.
Declaration Syntax
C#
public static ID Blob


DefaultValue Field

DefaultValue Field
Namespaces ► Sitecore ► TemplateFieldIDs ► DefaultValue
The ID of the 'Default value' field.
Declaration Syntax
C#
public static ID DefaultValue


Description Field

Description Field
Namespaces ► Sitecore ► TemplateFieldIDs ► Description
The ID of the Description 'Long description' field.
Declaration Syntax
C#
public static ID Description


ExcludeFromTextSearch Field

ExcludeFromTextSearch Field
Namespaces ► Sitecore ► TemplateFieldIDs ► ExcludeFromTextSearch
The ID for ExcludeFromTextSearch field
Declaration Syntax
C#
public static ID ExcludeFromTextSearch


HelpLink Field

HelpLink Field
Namespaces ► Sitecore ► TemplateFieldIDs ► HelpLink
The ID of the 'Help link' field.
Declaration Syntax
C#
public static ID HelpLink


ResetBlank Field

ResetBlank Field
Namespaces ► Sitecore ► TemplateFieldIDs ► ResetBlank
The ID of the 'Reset blank' field.
Declaration Syntax
C#
public static ID ResetBlank


Shared Field

Shared Field
Namespaces ► Sitecore ► TemplateFieldIDs ► Shared
The ID of the Shared field.
Declaration Syntax
C#
public static ID Shared


Source Field

Source Field
Namespaces ► Sitecore ► TemplateFieldIDs ► Source
The ID of the Source field.
Declaration Syntax
C#
public static ID Source


Title Field

Title Field
Namespaces ► Sitecore ► TemplateFieldIDs ► Title
The ID of the Title field.
Declaration Syntax
C#
public static ID Title


ToolTip Field

ToolTip Field
Namespaces ► Sitecore ► TemplateFieldIDs ► ToolTip
The ID of the ToolTip ('Short description') field.
Declaration Syntax
C#
public static ID ToolTip


Type Field

Type Field
Namespaces ► Sitecore ► TemplateFieldIDs ► Type
The ID of the Type field.
Declaration Syntax
C#
public static ID Type


Unversioned Field

Unversioned Field
Namespaces ► Sitecore ► TemplateFieldIDs ► Unversioned
The ID of the Unversioned field.
Declaration Syntax
C#
public static ID Unversioned


Validation Field

Validation Field
Namespaces ► Sitecore ► TemplateFieldIDs ► Validation
The ID of the Validation field.
Declaration Syntax
C#
public static ID Validation


ValidationText Field

ValidationText Field
Namespaces ► Sitecore ► TemplateFieldIDs ► ValidationText
The ID of the ValidationText field.
Declaration Syntax
C#
public static ID ValidationText


TemplateIDs Class

TemplateIDs Class
Namespaces ► Sitecore ► TemplateIDs
Implements a static class for holding well-known GUIDs relating to templates.
Declaration Syntax
C#
public static class TemplateIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Alias | The ID of 'System/Alias'.
 | Application | The ID of 'Sitecore Client/Applications/Application'.
 | ArchivedItem | The ID of 'System/Archiving/Archived item'.
 | BranchTemplate | The ID of 'System/Branches/Branch'.
 | BranchTemplateFolder | The ID of 'System/Branches/Branch Folder'.
 | Command | The ID of 'Commands/Command item'.
 | CommandGroup | The ID of 'Commands/CommandGroup item'.
 | CommandMaster | The ID of 'System/Masters/Command Master'.
 | Device | The ID of 'System/Layout/Device'.
 | DictionaryEntry | The ID of 'System/Dictionary/DictionaryEntry'.
 | Domain | The ID of 'System/Security/Domain'.
 | DynamicMaster | The ID of 'System/Masters/Dynamic Master'.
 | File | The ID of all MediaItems.
 | Folder | The ID of 'Folder'.
 | Image | The ID of 'Versioned/Image'.
 | Language | The ID of 'System/Language'.
 | Layout | The ID of 'System/Layout/Layout'.
 | LayoutGroup | The ID of 'System/Layout/Layout group'.
 | LinkedDatabase | The ID of 'System/LinkedDatabase'.
 | MainSection | The ID of 'MainSection'.
 | MediaFolder | The ID of 'Media folder'.
 | MenuDivider | The ID of 'System/Menus/Menu Divider'.
 | MenuItem | The ID of 'System/Menus/Menu Item'.
 | Node | The ID of 'Node'.
 | PackageRegistration | The ID of 'Packages/Package registration'.
 | Property | The ID of 'Property'.
 | Proxy | The ID of 'System/Proxy'.
 | Reference | The ID of 'System/Reference'.
 | RenderingGroup | The ID of 'System/Layout/Rendering group'.
 | Role | The ID of the 'Security/Role'.
 | Schedule | The ID of 'System/Tasks/Schedule'.
 | StandardTemplate | The ID of 'System/Standard template'.
 | Sublayout | The ID of 'Sublayout'.
 | Template | The ID of 'System/Template'.
 | TemplateField | The ID of the 'System/Template field'.
 | TemplateFieldType | The ID of the 'System/Template field type'.
 | TemplateFolder | The ID of 'System/Template Folder'.
 | TemplateSection | The ID of the 'System/Template section'.
 | UnversionedImage | The ID of 'Unversioned/Image'.
 | User | The ID of the 'Security/User'.
 | VersionedImage | The ID of 'Versioned/Image'.
 | Workflow | The ID of the 'System/Workflow/Workflow'.
 | WorkflowCommand | The ID of the 'System/Workflow/Command'.
 | WorkflowState | The ID of the 'System/Workflow/State'.
 | XMLLayout | The ID of 'System/Layout/XML Layout'.
 | XSLRendering | The ID of the 'XSL rendering'.
Remarks
The class does not contain any functionality, but serves only as a placeholder for a predefined GUIDs.
Inheritance Hierarchy
Object
TemplateIDs


Alias Field

Alias Field
Namespaces ► Sitecore ► TemplateIDs ► Alias
The ID of 'System/Alias'.
Declaration Syntax
C#
public static ID Alias


Application Field

Application Field
Namespaces ► Sitecore ► TemplateIDs ► Application
The ID of 'Sitecore Client/Applications/Application'.
Declaration Syntax
C#
public static ID Application


ArchivedItem Field

ArchivedItem Field
Namespaces ► Sitecore ► TemplateIDs ► ArchivedItem
The ID of 'System/Archiving/Archived item'.
Declaration Syntax
C#
public static ID ArchivedItem


BranchTemplate Field

BranchTemplate Field
Namespaces ► Sitecore ► TemplateIDs ► BranchTemplate
The ID of 'System/Branches/Branch'.
Declaration Syntax
C#
public static ID BranchTemplate


BranchTemplateFolder Field

BranchTemplateFolder Field
Namespaces ► Sitecore ► TemplateIDs ► BranchTemplateFolder
The ID of 'System/Branches/Branch Folder'.
Declaration Syntax
C#
public static ID BranchTemplateFolder


Command Field

Command Field
Namespaces ► Sitecore ► TemplateIDs ► Command
The ID of 'Commands/Command item'.
Declaration Syntax
C#
public static ID Command


CommandGroup Field

CommandGroup Field
Namespaces ► Sitecore ► TemplateIDs ► CommandGroup
The ID of 'Commands/CommandGroup item'.
Declaration Syntax
C#
public static ID CommandGroup


CommandMaster Field

CommandMaster Field
Namespaces ► Sitecore ► TemplateIDs ► CommandMaster
The ID of 'System/Masters/Command Master'.
Declaration Syntax
C#
public static ID CommandMaster


Device Field

Device Field
Namespaces ► Sitecore ► TemplateIDs ► Device
The ID of 'System/Layout/Device'.
Declaration Syntax
C#
public static ID Device


DictionaryEntry Field

DictionaryEntry Field
Namespaces ► Sitecore ► TemplateIDs ► DictionaryEntry
The ID of 'System/Dictionary/DictionaryEntry'.
Declaration Syntax
C#
public static ID DictionaryEntry


Domain Field

Domain Field
Namespaces ► Sitecore ► TemplateIDs ► Domain
The ID of 'System/Security/Domain'.
Declaration Syntax
C#
public static ID Domain


DynamicMaster Field

DynamicMaster Field
Namespaces ► Sitecore ► TemplateIDs ► DynamicMaster
The ID of 'System/Masters/Dynamic Master'.
Declaration Syntax
C#
public static ID DynamicMaster


File Field

File Field
Namespaces ► Sitecore ► TemplateIDs ► File
The ID of all MediaItems.
Declaration Syntax
C#
public static readonly ID File


Folder Field

Folder Field
Namespaces ► Sitecore ► TemplateIDs ► Folder
The ID of 'Folder'.
Declaration Syntax
C#
public static ID Folder


Image Field

Image Field
Namespaces ► Sitecore ► TemplateIDs ► Image
The ID of 'Versioned/Image'.
Declaration Syntax
C#
public static ID Image


Language Field

Language Field
Namespaces ► Sitecore ► TemplateIDs ► Language
The ID of 'System/Language'.
Declaration Syntax
C#
public static ID Language


Layout Field

Layout Field
Namespaces ► Sitecore ► TemplateIDs ► Layout
The ID of 'System/Layout/Layout'.
Declaration Syntax
C#
public static ID Layout


LayoutGroup Field

LayoutGroup Field
Namespaces ► Sitecore ► TemplateIDs ► LayoutGroup
The ID of 'System/Layout/Layout group'.
Declaration Syntax
C#
public static ID LayoutGroup


LinkedDatabase Field

LinkedDatabase Field
Namespaces ► Sitecore ► TemplateIDs ► LinkedDatabase
The ID of 'System/LinkedDatabase'.
Declaration Syntax
C#
public static ID LinkedDatabase


MainSection Field

MainSection Field
Namespaces ► Sitecore ► TemplateIDs ► MainSection
The ID of 'MainSection'.
Declaration Syntax
C#
public static ID MainSection


MediaFolder Field

MediaFolder Field
Namespaces ► Sitecore ► TemplateIDs ► MediaFolder
The ID of 'Media folder'.
Declaration Syntax
C#
public static ID MediaFolder


MenuDivider Field

MenuDivider Field
Namespaces ► Sitecore ► TemplateIDs ► MenuDivider
The ID of 'System/Menus/Menu Divider'.
Declaration Syntax
C#
public static ID MenuDivider


MenuItem Field

MenuItem Field
Namespaces ► Sitecore ► TemplateIDs ► MenuItem
The ID of 'System/Menus/Menu Item'.
Declaration Syntax
C#
public static ID MenuItem


Node Field

Node Field
Namespaces ► Sitecore ► TemplateIDs ► Node
The ID of 'Node'.
Declaration Syntax
C#
public static ID Node


PackageRegistration Field

PackageRegistration Field
Namespaces ► Sitecore ► TemplateIDs ► PackageRegistration
The ID of 'Packages/Package registration'.
Declaration Syntax
C#
public static ID PackageRegistration


Property Field

Property Field
Namespaces ► Sitecore ► TemplateIDs ► Property
The ID of 'Property'.
Declaration Syntax
C#
public static ID Property


Proxy Field

Proxy Field
Namespaces ► Sitecore ► TemplateIDs ► Proxy
The ID of 'System/Proxy'.
Declaration Syntax
C#
public static ID Proxy


Reference Field

Reference Field
Namespaces ► Sitecore ► TemplateIDs ► Reference
The ID of 'System/Reference'.
Declaration Syntax
C#
public static ID Reference


RenderingGroup Field

RenderingGroup Field
Namespaces ► Sitecore ► TemplateIDs ► RenderingGroup
The ID of 'System/Layout/Rendering group'.
Declaration Syntax
C#
public static ID RenderingGroup


Role Field

Role Field
Namespaces ► Sitecore ► TemplateIDs ► Role
The ID of the 'Security/Role'.
Declaration Syntax
C#
public static ID Role


Schedule Field

Schedule Field
Namespaces ► Sitecore ► TemplateIDs ► Schedule
The ID of 'System/Tasks/Schedule'.
Declaration Syntax
C#
public static ID Schedule


StandardTemplate Field

StandardTemplate Field
Namespaces ► Sitecore ► TemplateIDs ► StandardTemplate
The ID of 'System/Standard template'.
Declaration Syntax
C#
public static ID StandardTemplate


Sublayout Field

Sublayout Field
Namespaces ► Sitecore ► TemplateIDs ► Sublayout
The ID of 'Sublayout'.
Declaration Syntax
C#
public static ID Sublayout


Template Field

Template Field
Namespaces ► Sitecore ► TemplateIDs ► Template
The ID of 'System/Template'.
Declaration Syntax
C#
public static ID Template


TemplateField Field

TemplateField Field
Namespaces ► Sitecore ► TemplateIDs ► TemplateField
The ID of the 'System/Template field'.
Declaration Syntax
C#
public static ID TemplateField


TemplateFieldType Field

TemplateFieldType Field
Namespaces ► Sitecore ► TemplateIDs ► TemplateFieldType
The ID of the 'System/Template field type'.
Declaration Syntax
C#
public static ID TemplateFieldType


TemplateFolder Field

TemplateFolder Field
Namespaces ► Sitecore ► TemplateIDs ► TemplateFolder
The ID of 'System/Template Folder'.
Declaration Syntax
C#
public static ID TemplateFolder


TemplateSection Field

TemplateSection Field
Namespaces ► Sitecore ► TemplateIDs ► TemplateSection
The ID of the 'System/Template section'.
Declaration Syntax
C#
public static ID TemplateSection


UnversionedImage Field

UnversionedImage Field
Namespaces ► Sitecore ► TemplateIDs ► UnversionedImage
The ID of 'Unversioned/Image'.
Declaration Syntax
C#
public static ID UnversionedImage


User Field

User Field
Namespaces ► Sitecore ► TemplateIDs ► User
The ID of the 'Security/User'.
Declaration Syntax
C#
public static ID User


VersionedImage Field

VersionedImage Field
Namespaces ► Sitecore ► TemplateIDs ► VersionedImage
The ID of 'Versioned/Image'.
Declaration Syntax
C#
public static ID VersionedImage


Workflow Field

Workflow Field
Namespaces ► Sitecore ► TemplateIDs ► Workflow
The ID of the 'System/Workflow/Workflow'.
Declaration Syntax
C#
public static ID Workflow


WorkflowCommand Field

WorkflowCommand Field
Namespaces ► Sitecore ► TemplateIDs ► WorkflowCommand
The ID of the 'System/Workflow/Command'.
Declaration Syntax
C#
public static ID WorkflowCommand


WorkflowState Field

WorkflowState Field
Namespaces ► Sitecore ► TemplateIDs ► WorkflowState
The ID of the 'System/Workflow/State'.
Declaration Syntax
C#
public static ID WorkflowState


XMLLayout Field

XMLLayout Field
Namespaces ► Sitecore ► TemplateIDs ► XMLLayout
The ID of 'System/Layout/XML Layout'.
Declaration Syntax
C#
public static ID XMLLayout


XSLRendering Field

XSLRendering Field
Namespaces ► Sitecore ► TemplateIDs ► XSLRendering
The ID of the 'XSL rendering'.
Declaration Syntax
C#
public static ID XSLRendering


TemplateSectionFieldIDs Class

TemplateSectionFieldIDs Class
Namespaces ► Sitecore ► TemplateSectionFieldIDs
Implements a static class for holding well-known GUIDs relating to template sections.
Declaration Syntax
C#
public static class TemplateSectionFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Control | The ID of the 'Control' field.
 | HiddenByDefault | The ID of the 'HiddenByDefault' field.
 | HideFields | The ID of the 'HideFields' field.
Remarks
The class does not contain any functionality, but serves only as a placeholder for a predefined GUIDs.
Inheritance Hierarchy
Object
TemplateSectionFieldIDs


Control Field

Control Field
Namespaces ► Sitecore ► TemplateSectionFieldIDs ► Control
The ID of the 'Control' field.
Declaration Syntax
C#
public static ID Control


HiddenByDefault Field

HiddenByDefault Field
Namespaces ► Sitecore ► TemplateSectionFieldIDs ► HiddenByDefault
The ID of the 'HiddenByDefault' field.
Declaration Syntax
C#
public static ID HiddenByDefault


HideFields Field

HideFields Field
Namespaces ► Sitecore ► TemplateSectionFieldIDs ► HideFields
The ID of the 'HideFields' field.
Declaration Syntax
C#
public static ID HideFields


TerminatesProgramAttribute Class

TerminatesProgramAttribute Class
Namespaces ► Sitecore ► TerminatesProgramAttribute
Declaration Syntax
C#
public class TerminatesProgramAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TerminatesProgramAttribute()()() | Initializes a new instance of the TerminatesProgramAttribute class
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | TerminatesProgramAttribute


TerminatesProgramAttribute Constructor

TerminatesProgramAttribute Constructor
Namespaces ► Sitecore ► TerminatesProgramAttribute ► TerminatesProgramAttribute()()()
Initializes a new instance of the TerminatesProgramAttribute class
Declaration Syntax
C#
public TerminatesProgramAttribute()


Todo Class

Todo Class
Namespaces ► Sitecore ► Todo
Todo marker
Declaration Syntax
C#
public static class Todo
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AR(array<Object>[]()[]) | Just a mark for some work to be done.
 | DDZ(array<Object>[]()[]) | Just a mark for some work to be done.
 | JC(array<Object>[]()[]) | Just a mark for some work to be done.
 | MB(array<Object>[]()[]) | Just a mark for some work to be done.
 | OT(String, Boolean) | A mark for some work to be done. Throws an exception if the second parameter equals true.
 | SMAR(array<Object>[]()[]) | Just a mark for some work to be done.
Inheritance Hierarchy
Object
Todo


AR Method (args)

AR Method (args)
Namespaces ► Sitecore ► Todo ► AR(array<Object>[]()[])
Just a mark for some work to be done.
Declaration Syntax
C#
public static void AR(
    params Object[] args
)
Parameters
args (array< Object >[]()[])
The arguments.


DDZ Method (args)

DDZ Method (args)
Namespaces ► Sitecore ► Todo ► DDZ(array<Object>[]()[])
Just a mark for some work to be done.
Declaration Syntax
C#
public static void DDZ(
    params Object[] args
)
Parameters
args (array< Object >[]()[])
The arguments.


JC Method (args)

JC Method (args)
Namespaces ► Sitecore ► Todo ► JC(array<Object>[]()[])
Just a mark for some work to be done.
Declaration Syntax
C#
public static void JC(
    params Object[] args
)
Parameters
args (array< Object >[]()[])
The args.


MB Method (args)

MB Method (args)
Namespaces ► Sitecore ► Todo ► MB(array<Object>[]()[])
Just a mark for some work to be done.
Declaration Syntax
C#
public static void MB(
    params Object[] args
)
Parameters
args (array< Object >[]()[])
The arguments.


OT Method (description, throwException)

OT Method (description, throwException)
Namespaces ► Sitecore ► Todo ► OT(String, Boolean)
A mark for some work to be done. Throws an exception if the second parameter equals true.
Declaration Syntax
C#
public static void OT(
    string description,
    bool throwException
)
Parameters
description (String)
The description.
throwException (Boolean)
if set to true [throw exception].


SMAR Method (args)

SMAR Method (args)
Namespaces ► Sitecore ► Todo ► SMAR(array<Object>[]()[])
Just a mark for some work to be done.
Declaration Syntax
C#
public static void SMAR(
    params Object[] args
)
Parameters
args (array< Object >[]()[])
The arguments.


Tristate Enumeration

Tristate Enumeration
Namespaces ► Sitecore ► Tristate
Represents a tristate.
Declaration Syntax
C#
public enum Tristate
Members
Member | Description
Undefined | Undefined.
False | False.
True | True.


UIUtil Class

UIUtil Class
Namespaces ► Sitecore ► UIUtil
Implements helper functions.
Declaration Syntax
C#
public static class UIUtil
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddContentDatabaseParameter(UrlBuilder) | Adds the content database parameter.
 | AddContentDatabaseParameter(String) | Adds the content database parameter.
 | AddContentDatabaseParameter(UrlString) | Adds the content database parameter.
 | AddMessageParameter(String, String, String) | Add a parameter to a message.
 | BrowserHeightToDialogHeight(String) | Converts from browser-reported height to internal dialog height saved in registry.
 | DialogHeightToBrowserHeight(String) | Converts from internal dialog height to browser-specific dialog height value.
 | ExpandItemMacros(String, String, String, String) | Substitudes macros from an item.
 | FindControlByType(Type) | Finds a control by the specified type.
 | FindControlByType(Control, Type) | Finds a control by the specified type.
 | FindPopupControl(Control) | Find a popup control under the parent.
 | FormatHeader(String, String) | Formats a header.
 | FormatHeader(String, String, Boolean) | Formats a header.
 | GetApplicationFromShortcut(Item) | Gets an application item from a shortcut.
 | GetBrowserClassString()()() | Gets the browser class string.
 | GetHiddenHolder(Control) | Gets the hidden holder.
 | GetHomeItem(User) | Gets the home item.
 | GetItemFromQueryString(Database) | Gets the item from query string.
 | GetUri(String) | Gets a uri.
 | GetUri(String, String) | Gets a uri.
 | GetUri(String, UrlString) | Gets a uri.
 | IsControlUri(String) | Detects if a URI is a control: protocol.
 | IsFirefox()()() | Determines whether this instance is firefox.
 | IsIE()()() | Detects if the current browser is IE.
 | IsIE(Int32) | Detects if the current browser is IE.
 | LinkToSearch(String, String) | Links to search.
 | ParseStyle(CssStyleCollection, String) | Parses a style string.
 | StripSitecoreShellPath(String) | Strips the sitecore shell path.
 | SupportsInlineEditing()()() | Supportses the inline editing.
 | UseFlashUpload()()() | Uses the flash upload.
Inheritance Hierarchy
Object
UIUtil


AddContentDatabaseParameter Method

AddContentDatabaseParameter Method
Namespaces ► Sitecore ► UIUtil ► AddContentDatabaseParameter()()()
Members
Icon | Member | Description
 | AddContentDatabaseParameter(UrlBuilder) | Adds the content database parameter.
 | AddContentDatabaseParameter(String) | Adds the content database parameter.
 | AddContentDatabaseParameter(UrlString) | Adds the content database parameter.


AddContentDatabaseParameter Method (url)

AddContentDatabaseParameter Method (url)
Namespaces ► Sitecore ► UIUtil ► AddContentDatabaseParameter(UrlBuilder)
Adds the content database parameter.
Declaration Syntax
C#
public static void AddContentDatabaseParameter(
    UrlBuilder url
)
Parameters
url (UrlBuilder)
The URL.
Return Value


AddContentDatabaseParameter Method (url)

AddContentDatabaseParameter Method (url)
Namespaces ► Sitecore ► UIUtil ► AddContentDatabaseParameter(UrlString)
Adds the content database parameter.
Declaration Syntax
C#
public static void AddContentDatabaseParameter(
    UrlString url
)
Parameters
url (UrlString)
The URL.


AddContentDatabaseParameter Method (url)

AddContentDatabaseParameter Method (url)
Namespaces ► Sitecore ► UIUtil ► AddContentDatabaseParameter(String)
Adds the content database parameter.
Declaration Syntax
C#
public static string AddContentDatabaseParameter(
    string url
)
Parameters
url (String)
The URL.
Return Value


AddMessageParameter Method (message, name, value)

AddMessageParameter Method (message, name, value)
Namespaces ► Sitecore ► UIUtil ► AddMessageParameter(String, String, String)
Add a parameter to a message.
Declaration Syntax
C#
public static string AddMessageParameter(
    string message,
    string name,
    string value
)
Parameters
message (String)
The message.
name (String)
The name.
value (String)
The value.
Return Value


BrowserHeightToDialogHeight Method (height)

BrowserHeightToDialogHeight Method (height)
Namespaces ► Sitecore ► UIUtil ► BrowserHeightToDialogHeight(String)
Converts from browser-reported height to internal dialog height saved in registry.
Declaration Syntax
C#
public static string BrowserHeightToDialogHeight(
    string height
)
Parameters
height (String)
The height.
Return Value
The height to dialog height.


DialogHeightToBrowserHeight Method (height)

DialogHeightToBrowserHeight Method (height)
Namespaces ► Sitecore ► UIUtil ► DialogHeightToBrowserHeight(String)
Converts from internal dialog height to browser-specific dialog height value.
Declaration Syntax
C#
public static string DialogHeightToBrowserHeight(
    string height
)
Parameters
height (String)
Height of the pixel.
Return Value
The height.


ExpandItemMacros Method (message, id, name, parentID)

ExpandItemMacros Method (message, id, name, parentID)
Namespaces ► Sitecore ► UIUtil ► ExpandItemMacros(String, String, String, String)
Substitudes macros from an item.
Declaration Syntax
C#
public static string ExpandItemMacros(
    string message,
    string id,
    string name,
    string parentID
)
Parameters
message (String)
The message.
id (String)
The id.
name (String)
The name.
parentID (String)
The parent ID.
Return Value


FindControlByType Method

FindControlByType Method
Namespaces ► Sitecore ► UIUtil ► FindControlByType()()()
Members
Icon | Member | Description
 | FindControlByType(Type) | Finds a control by the specified type.
 | FindControlByType(Control, Type) | Finds a control by the specified type.


FindControlByType Method (type)

FindControlByType Method (type)
Namespaces ► Sitecore ► UIUtil ► FindControlByType(Type)
Finds a control by the specified type.
Declaration Syntax
C#
public static Control FindControlByType(
    Type type
)
Parameters
type (Type)
The type.
Return Value


FindControlByType Method (parent, type)

FindControlByType Method (parent, type)
Namespaces ► Sitecore ► UIUtil ► FindControlByType(Control, Type)
Finds a control by the specified type.
Declaration Syntax
C#
public static Control FindControlByType(
    Control parent,
    Type type
)
Parameters
parent (Control)
The parent.
type (Type)
The type.
Return Value


FindPopupControl Method (parent)

FindPopupControl Method (parent)
Namespaces ► Sitecore ► UIUtil ► FindPopupControl(Control)
Find a popup control under the parent.
Declaration Syntax
C#
public static Control FindPopupControl(
    Control parent
)
Parameters
parent (Control)
The parent control to search.
Return Value
A popup control or null, if none were found.


FormatHeader Method

FormatHeader Method
Namespaces ► Sitecore ► UIUtil ► FormatHeader()()()
Members
Icon | Member | Description
 | FormatHeader(String, String) | Formats a header.
 | FormatHeader(String, String, Boolean) | Formats a header.


FormatHeader Method (header, headerStyle)

FormatHeader Method (header, headerStyle)
Namespaces ► Sitecore ► UIUtil ► FormatHeader(String, String)
Formats a header.
Declaration Syntax
C#
public static string FormatHeader(
    string header,
    string headerStyle
)
Parameters
header (String)
The header.
headerStyle (String)
The header style.
Return Value


FormatHeader Method (header, headerStyle, translate)

FormatHeader Method (header, headerStyle, translate)
Namespaces ► Sitecore ► UIUtil ► FormatHeader(String, String, Boolean)
Formats a header.
Declaration Syntax
C#
public static string FormatHeader(
    string header,
    string headerStyle,
    bool translate
)
Parameters
header (String)
The header.
headerStyle (String)
The header style.
translate (Boolean)
if set to true this instance is translate.
Return Value


GetApplicationFromShortcut Method (item)

GetApplicationFromShortcut Method (item)
Namespaces ► Sitecore ► UIUtil ► GetApplicationFromShortcut(Item)
Gets an application item from a shortcut.
Declaration Syntax
C#
public static Item GetApplicationFromShortcut(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetBrowserClassString Method

GetBrowserClassString Method
Namespaces ► Sitecore ► UIUtil ► GetBrowserClassString()()()
Gets the browser class string.
Declaration Syntax
C#
public static string GetBrowserClassString()
Return Value
The browser class string.


GetHiddenHolder Method (parent)

GetHiddenHolder Method (parent)
Namespaces ► Sitecore ► UIUtil ► GetHiddenHolder(Control)
Gets the hidden holder.
Declaration Syntax
C#
public static Control GetHiddenHolder(
    Control parent
)
Parameters
parent (Control)
The parent.
Return Value


GetHomeItem Method (user)

GetHomeItem Method (user)
Namespaces ► Sitecore ► UIUtil ► GetHomeItem(User)
Gets the home item.
Declaration Syntax
C#
public static Item GetHomeItem(
    User user
)
Parameters
user (User)
The user.
Return Value


GetItemFromQueryString Method (database)

GetItemFromQueryString Method (database)
Namespaces ► Sitecore ► UIUtil ► GetItemFromQueryString(Database)
Gets the item from query string.
Declaration Syntax
C#
public static Item GetItemFromQueryString(
    Database database
)
Parameters
database (Database)
The database.
Return Value


GetUri Method

GetUri Method
Namespaces ► Sitecore ► UIUtil ► GetUri()()()
Members
Icon | Member | Description
 | GetUri(String) | Gets a uri.
 | GetUri(String, String) | Gets a uri.
 | GetUri(String, UrlString) | Gets a uri.


GetUri Method (uri)

GetUri Method (uri)
Namespaces ► Sitecore ► UIUtil ► GetUri(String)
Gets a uri.
Declaration Syntax
C#
public static string GetUri(
    string uri
)
Parameters
uri (String)
The URI.
Return Value
Remarks
The takes the control: protocol into account.


GetUri Method (uri, parameters)

GetUri Method (uri, parameters)
Namespaces ► Sitecore ► UIUtil ► GetUri(String, UrlString)
Gets a uri.
Declaration Syntax
C#
public static string GetUri(
    string uri,
    UrlString parameters
)
Parameters
uri (String)
The URI.
parameters (UrlString)
The parameters.
Return Value
Remarks
The takes the control: protocol into account.


GetUri Method (uri, parameters)

GetUri Method (uri, parameters)
Namespaces ► Sitecore ► UIUtil ► GetUri(String, String)
Gets a uri.
Declaration Syntax
C#
public static string GetUri(
    string uri,
    string parameters
)
Parameters
uri (String)
The URI.
parameters (String)
The parameters.
Return Value
Remarks
The takes the control: protocol into account.


IsControlUri Method (uri)

IsControlUri Method (uri)
Namespaces ► Sitecore ► UIUtil ► IsControlUri(String)
Detects if a URI is a control: protocol.
Declaration Syntax
C#
public static bool IsControlUri(
    string uri
)
Parameters
uri (String)
The URI.
Return Value
true if [is control URI] [the specified URI]; otherwise, false.


IsFirefox Method

IsFirefox Method
Namespaces ► Sitecore ► UIUtil ► IsFirefox()()()
Determines whether this instance is firefox.
Declaration Syntax
C#
public static bool IsFirefox()
Return Value
true if this instance is firefox; otherwise, false.


IsIE Method

IsIE Method
Namespaces ► Sitecore ► UIUtil ► IsIE()()()
Members
Icon | Member | Description
 | IsIE()()() | Detects if the current browser is IE.
 | IsIE(Int32) | Detects if the current browser is IE.


IsIE Method

IsIE Method
Namespaces ► Sitecore ► UIUtil ► IsIE()()()
Detects if the current browser is IE.
Declaration Syntax
C#
public static bool IsIE()
Return Value
true if this instance is IE; otherwise, false.


IsIE Method (majorVersion)

IsIE Method (majorVersion)
Namespaces ► Sitecore ► UIUtil ► IsIE(Int32)
Detects if the current browser is IE.
Declaration Syntax
C#
public static bool IsIE(
    int majorVersion
)
Parameters
majorVersion (Int32)
Return Value
true if this instance is IE; otherwise, false.


LinkToSearch Method (text, query)

LinkToSearch Method (text, query)
Namespaces ► Sitecore ► UIUtil ► LinkToSearch(String, String)
Links to search.
Declaration Syntax
C#
public static string LinkToSearch(
    string text,
    string query
)
Parameters
text (String)
The text.
query (String)
The query.
Return Value


ParseStyle Method (css, style)

ParseStyle Method (css, style)
Namespaces ► Sitecore ► UIUtil ► ParseStyle(CssStyleCollection, String)
Parses a style string.
Declaration Syntax
C#
public static void ParseStyle(
    CssStyleCollection css,
    string style
)
Parameters
css (CssStyleCollection)
The CSS.
style (String)
The style.


StripSitecoreShellPath Method (url)

StripSitecoreShellPath Method (url)
Namespaces ► Sitecore ► UIUtil ► StripSitecoreShellPath(String)
Strips the sitecore shell path.
Declaration Syntax
C#
public static string StripSitecoreShellPath(
    string url
)
Parameters
url (String)
The URL.
Return Value
The sitecore shell path.


SupportsInlineEditing Method

SupportsInlineEditing Method
Namespaces ► Sitecore ► UIUtil ► SupportsInlineEditing()()()
Supportses the inline editing.
Declaration Syntax
C#
public static bool SupportsInlineEditing()
Return Value
The inline editing.


UseFlashUpload Method

UseFlashUpload Method
Namespaces ► Sitecore ► UIUtil ► UseFlashUpload()()()
Uses the flash upload.
Declaration Syntax
C#
public static bool UseFlashUpload()
Return Value
The flash upload.


UsedImplicitlyAttribute Class

UsedImplicitlyAttribute Class
Namespaces ► Sitecore ► UsedImplicitlyAttribute
Indicates that the marked symbol is used implicitly (ex. reflection, external library), so this symbol will not be marked as unused (as well as by other usage inspections)
Declaration Syntax
C#
public class UsedImplicitlyAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UsedImplicitlyAttribute()()() | Initializes a new instance of the UsedImplicitlyAttribute class
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | UsedImplicitlyAttribute


UsedImplicitlyAttribute Constructor

UsedImplicitlyAttribute Constructor
Namespaces ► Sitecore ► UsedImplicitlyAttribute ► UsedImplicitlyAttribute()()()
Initializes a new instance of the UsedImplicitlyAttribute class
Declaration Syntax
C#
public UsedImplicitlyAttribute()


UserFieldIDs Class

UserFieldIDs Class
Namespaces ► Sitecore ► UserFieldIDs
Fields of the Security/User template.
Declaration Syntax
C#
public static class UserFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Administrator | The ID of the 'Administrator' field.
 | Password | The ID of the 'Password' field.
 | Roles | The ID of the 'Roles' field.
Inheritance Hierarchy
Object
UserFieldIDs


Administrator Field

Administrator Field
Namespaces ► Sitecore ► UserFieldIDs ► Administrator
The ID of the 'Administrator' field.
Declaration Syntax
C#
public static ID Administrator


Password Field

Password Field
Namespaces ► Sitecore ► UserFieldIDs ► Password
The ID of the 'Password' field.
Declaration Syntax
C#
public static ID Password


Roles Field

Roles Field
Namespaces ► Sitecore ► UserFieldIDs ► Roles
The ID of the 'Roles' field.
Declaration Syntax
C#
public static ID Roles


WorkflowFieldIDs Class

WorkflowFieldIDs Class
Namespaces ► Sitecore ► WorkflowFieldIDs
Implements a static class for holding assorted well-known GUID values.
Declaration Syntax
C#
public static class WorkflowFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FinalState | The Final field of the Workflow/State template.
Remarks
The class does not contain any functionality, but serves as a placeholder for a predefined GUIDs.
Inheritance Hierarchy
Object
WorkflowFieldIDs


FinalState Field

FinalState Field
Namespaces ► Sitecore ► WorkflowFieldIDs ► FinalState
The Final field of the Workflow/State template.
Declaration Syntax
C#
public static ID FinalState


Sitecore.Access Namespace

Sitecore.Access Namespace
Namespaces ► Sitecore.Access
Declaration Syntax
C#
namespace Sitecore.Access
Types
All Types Classes
Icon | Type | Description
 | AccessContext | Represents the current access context.


AccessContext Class

AccessContext Class
Namespaces ► Sitecore.Access ► AccessContext
Represents the current access context.
Declaration Syntax
C#
public class AccessContext
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AccessContext(Context..::.ContextData) | Initializes a new instance of the AccessContext class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AccessContext


AccessContext Constructor (context)

AccessContext Constructor (context)
Namespaces ► Sitecore.Access ► AccessContext ► AccessContext(Context..::.ContextData)
Initializes a new instance of the AccessContext class.
Declaration Syntax
C#
public AccessContext(
    Context..::.ContextData context
)
Parameters
context (Context..::.ContextData)
The context.


Sitecore.Admin Namespace

Sitecore.Admin Namespace
Namespaces ► Sitecore.Admin
Declaration Syntax
C#
namespace Sitecore.Admin
Types
All Types Classes
Icon | Type | Description
 | Login | Defines the login class.
 | UnitTestLogin | Implements the UnitTestLogin. UnitTestLogin class.


Login Class

Login Class
Namespaces ► Sitecore.Admin ► Login
Defines the login class.
Declaration Syntax
C#
public class Login : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Login()()() | Initializes a new instance of the Login class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoLogin(String, String) | Logins the specified username.
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorMessage | ErrorMessage control.
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginClick(Object, EventArgs) | Logins the click.
 | LoginTextBox | LoginTextBox control.
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PasswordTextBox | PasswordTextBox control.
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Login

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Login Constructor

Login Constructor
Namespaces ► Sitecore.Admin ► Login ► Login()()()
Initializes a new instance of the Login class
Declaration Syntax
C#
public Login()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DoLogin Method (username, password)

DoLogin Method (username, password)
Namespaces ► Sitecore.Admin ► Login ► DoLogin(String, String)
Logins the specified username.
Declaration Syntax
C#
protected void DoLogin(
    string username,
    string password
)
Parameters
username (String)
The username.
password (String)
The password.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ErrorMessage Field

ErrorMessage Field
Namespaces ► Sitecore.Admin ► Login ► ErrorMessage
ErrorMessage control.
Declaration Syntax
C#
protected PlaceHolder ErrorMessage
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LoginClick Method (sender, e)

LoginClick Method (sender, e)
Namespaces ► Sitecore.Admin ► Login ► LoginClick(Object, EventArgs)
Logins the click.
Declaration Syntax
C#
protected void LoginClick(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The sender.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LoginTextBox Field

LoginTextBox Field
Namespaces ► Sitecore.Admin ► Login ► LoginTextBox
LoginTextBox control.
Declaration Syntax
C#
protected TextBox LoginTextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PasswordTextBox Field

PasswordTextBox Field
Namespaces ► Sitecore.Admin ► Login ► PasswordTextBox
PasswordTextBox control.
Declaration Syntax
C#
protected TextBox PasswordTextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


UnitTestLogin Class

UnitTestLogin Class
Namespaces ► Sitecore.Admin ► UnitTestLogin
Implements the UnitTestLogin.
UnitTestLogin class.
Declaration Syntax
C#
public class UnitTestLogin : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnitTestLogin()()() | Initializes a new instance of the UnitTestLogin class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 | form1 control.
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) | Handles the Load event of the Page control.
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Remarks
Auto-generated class.
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | UnitTestLogin

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


UnitTestLogin Constructor

UnitTestLogin Constructor
Namespaces ► Sitecore.Admin ► UnitTestLogin ► UnitTestLogin()()()
Initializes a new instance of the UnitTestLogin class
Declaration Syntax
C#
public UnitTestLogin()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


form1 Field

form1 Field
Namespaces ► Sitecore.Admin ► UnitTestLogin ► form1
form1 control.
Declaration Syntax
C#
protected HtmlForm form1
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore.Admin ► UnitTestLogin ► Page_Load(Object, EventArgs)
Handles the Load event of the Page control.
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Admin.DBBrowser Namespace

Sitecore.Admin.DBBrowser Namespace
Namespaces ► Sitecore.Admin.DBBrowser
Declaration Syntax
C#
namespace Sitecore.Admin.DBBrowser
Types
All Types Classes
Icon | Type | Description
 | DBBrowserPage |


DBBrowserPage Class

DBBrowserPage Class
Namespaces ► Sitecore.Admin.DBBrowser ► DBBrowserPage
Declaration Syntax
C#
public class DBBrowserPage : Page
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DBBrowserPage()()() | Initializes a new instance of the DBBrowserPage class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateAnchor(String, String) |
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Overrides Page.OnInit(EventArgs).)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | DBBrowserPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DBBrowserPage Constructor

DBBrowserPage Constructor
Namespaces ► Sitecore.Admin.DBBrowser ► DBBrowserPage ► DBBrowserPage()()()
Initializes a new instance of the DBBrowserPage class
Declaration Syntax
C#
public DBBrowserPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CreateAnchor Method (text, href)

CreateAnchor Method (text, href)
Namespaces ► Sitecore.Admin.DBBrowser ► DBBrowserPage ► CreateAnchor(String, String)
Declaration Syntax
C#
public static HtmlAnchor CreateAnchor(
    string text,
    string href
)
Parameters
text (String)
href (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnInit Method (e)

OnInit Method (e)
Namespaces ► Sitecore.Admin.DBBrowser ► DBBrowserPage ► OnInit(EventArgs)
Raises the Init event to initialize the page.
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Analytics Namespace

Sitecore.Analytics Namespace
Namespaces ► Sitecore.Analytics
Declaration Syntax
C#
namespace Sitecore.Analytics
Types
All Types Classes
Icon | Type | Description
 | AnalyticsGlobalSession |
 | AnalyticsIds |
 | AnalyticsManager |
 | AnalyticsPage |
 | AnalyticsPageEvent |
 | AnalyticsSession |
 | AnalyticsTexts |
 | AnalyticsTracker |
 | Browser |
 | Campaign |
 | CampaignEvent |
 | CampaignEventPage |
 | GlobalSession |
 | IP |
 | IPOwner |
 | Keyword |
 | MultiVarianceTestDefinition |
 | MultiVarianceTestVariable |
 | MultiVarianceTestVariableCampaignEvent |
 | MultiVarianceTestVariablePage |
 | OperatingSystem |
 | Page |
 | PageEvent |
 | PageEventDefinition |
 | Profile |
 | ProfileDefinition |
 | ProfileKey |
 | ProfileKeyDefinition |
 | ReferringSite |
 | Screen |
 | Session |
 | SitecoreAnalyticsDataContext |
 | Status |
 | Subscription |
 | AnalyticsTracker..::.Summary | Obsolete.
 | Tag |
 | TransactionHandle | Defines the transaction handle class.
 | VisitorIdentification |


AnalyticsGlobalSession Class

AnalyticsGlobalSession Class
Namespaces ► Sitecore.Analytics ► AnalyticsGlobalSession
Declaration Syntax
C#
public class AnalyticsGlobalSession
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalyticsGlobalSession()()() | Initializes a new instance of the AnalyticsGlobalSession class
 | Acquaintance |
 | CookieValue |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExternalUser |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | State |
 | Tags |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AnalyticsGlobalSession

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsGlobalSession Constructor

AnalyticsGlobalSession Constructor
Namespaces ► Sitecore.Analytics ► AnalyticsGlobalSession ► AnalyticsGlobalSession()()()
Initializes a new instance of the AnalyticsGlobalSession class
Declaration Syntax
C#
public AnalyticsGlobalSession()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Acquaintance Property

Acquaintance Property
Namespaces ► Sitecore.Analytics ► AnalyticsGlobalSession ► Acquaintance
Declaration Syntax
C#
public Guid Acquaintance { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CookieValue Property

CookieValue Property
Namespaces ► Sitecore.Analytics ► AnalyticsGlobalSession ► CookieValue
Declaration Syntax
C#
public string CookieValue { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ExternalUser Property

ExternalUser Property
Namespaces ► Sitecore.Analytics ► AnalyticsGlobalSession ► ExternalUser
Declaration Syntax
C#
public string ExternalUser { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


State Property

State Property
Namespaces ► Sitecore.Analytics ► AnalyticsGlobalSession ► State
Declaration Syntax
C#
public string State { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Tags Property

Tags Property
Namespaces ► Sitecore.Analytics ► AnalyticsGlobalSession ► Tags
Declaration Syntax
C#
public Dictionary<string, string> Tags { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsIds Class

AnalyticsIds Class
Namespaces ► Sitecore.Analytics ► AnalyticsIds
Declaration Syntax
C#
public static class AnalyticsIds
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Campaign |
 | CampaignEvent |
 | Goal |
 | MultiVarianceTest |
 | MultiVarianceTestItem |
 | PageEvent |
 | Pending |
 | Profile |
 | ProfileKey |
Inheritance Hierarchy
Object
AnalyticsIds

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Campaign Field

Campaign Field
Namespaces ► Sitecore.Analytics ► AnalyticsIds ► Campaign
Declaration Syntax
C#
public static ID Campaign

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEvent Field

CampaignEvent Field
Namespaces ► Sitecore.Analytics ► AnalyticsIds ► CampaignEvent
Declaration Syntax
C#
public static ID CampaignEvent

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Goal Field

Goal Field
Namespaces ► Sitecore.Analytics ► AnalyticsIds ► Goal
Declaration Syntax
C#
public static ID Goal

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTest Field

MultiVarianceTest Field
Namespaces ► Sitecore.Analytics ► AnalyticsIds ► MultiVarianceTest
Declaration Syntax
C#
public static ID MultiVarianceTest

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestItem Field

MultiVarianceTestItem Field
Namespaces ► Sitecore.Analytics ► AnalyticsIds ► MultiVarianceTestItem
Declaration Syntax
C#
public static ID MultiVarianceTestItem

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageEvent Field

PageEvent Field
Namespaces ► Sitecore.Analytics ► AnalyticsIds ► PageEvent
Declaration Syntax
C#
public static ID PageEvent

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Pending Field

Pending Field
Namespaces ► Sitecore.Analytics ► AnalyticsIds ► Pending
Declaration Syntax
C#
public static Guid Pending

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Profile Field

Profile Field
Namespaces ► Sitecore.Analytics ► AnalyticsIds ► Profile
Declaration Syntax
C#
public static ID Profile

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKey Field

ProfileKey Field
Namespaces ► Sitecore.Analytics ► AnalyticsIds ► ProfileKey
Declaration Syntax
C#
public static ID ProfileKey

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsManager Class

AnalyticsManager Class
Namespaces ► Sitecore.Analytics ► AnalyticsManager
Declaration Syntax
C#
public class AnalyticsManager
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalyticsManager()()() | Initializes a new instance of the AnalyticsManager class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLookupData(Boolean, Int32) |
 | GetSession(String) |
 | GetStatus(Guid, DateTime%, DateTime%) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Provider |
 | Providers |
 | SaveCampaignDefinition(Guid, String, String, String, Int32, DateTime, DateTime, Boolean, String) |
 | SaveCampaignEvent(Guid, Guid, DateTime, String) |
 | SaveMultiVarianceTestDefinition(Guid, String, String) |
 | SaveMultiVarianceTestVariable(Guid, Guid, String) |
 | SavePageEventDefinition(Guid, String, String, String, Boolean, Boolean, Boolean, Boolean) |
 | SaveProfileDefinition(Guid, String, String) |
 | SaveProfileKeyDefinition(Guid, Guid, String, String, Int32, Int32) |
 | SetStatusFailed(Guid) |
 | SetStatusSuccessful(Guid) |
 | STATUS_QUEUE_FULL |
 | STATUS_REQUEST |
 | STATUSLOOKUP |
 | Submit(AnalyticsTracker, Boolean) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateIpInformation(Guid, WhoIsInformation) |
Inheritance Hierarchy
Object
AnalyticsManager

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsManager Constructor

AnalyticsManager Constructor
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► AnalyticsManager()()()
Initializes a new instance of the AnalyticsManager class
Declaration Syntax
C#
public AnalyticsManager()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetLookupData Method (onlyBlanks, maxEntries)

GetLookupData Method (onlyBlanks, maxEntries)
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► GetLookupData(Boolean, Int32)
Declaration Syntax
C#
public static IEnumerable<LookupData> GetLookupData(
    bool onlyBlanks,
    int maxEntries
)
Parameters
onlyBlanks (Boolean)
maxEntries (Int32)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetSession Method (aspNetSessionId)

GetSession Method (aspNetSessionId)
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► GetSession(String)
Declaration Syntax
C#
public static Session GetSession(
    string aspNetSessionId
)
Parameters
aspNetSessionId (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetStatus Method (statusId, successful, failed)

GetStatus Method (statusId, successful, failed)
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► GetStatus(Guid, DateTime%, DateTime%)
Declaration Syntax
C#
public static void GetStatus(
    Guid statusId,
    out DateTime successful,
    out DateTime failed
)
Parameters
statusId (Guid)
successful ( DateTime %)
failed ( DateTime %)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Provider Property

Provider Property
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► Provider
Declaration Syntax
C#
public static AnalyticsProvider Provider { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Providers Property

Providers Property
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► Providers
Declaration Syntax
C#
public static AnalyticsProviderCollection Providers { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SaveCampaignDefinition Method (campaignId, title, type, description, cost, startDate, endDate, isActive, data)

SaveCampaignDefinition Method (campaignId, title, type, description, cost, startDate, endDate, isActive, data)
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► SaveCampaignDefinition(Guid, String, String, String, Int32, DateTime, DateTime, Boolean, String)
Declaration Syntax
C#
public static void SaveCampaignDefinition(
    Guid campaignId,
    string title,
    string type,
    string description,
    int cost,
    DateTime startDate,
    DateTime endDate,
    bool isActive,
    string data
)
Parameters
campaignId (Guid)
title (String)
type (String)
description (String)
cost (Int32)
startDate (DateTime)
endDate (DateTime)
isActive (Boolean)
data (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SaveCampaignEvent Method (campaignEventId, campaignId, dateTime, data)

SaveCampaignEvent Method (campaignEventId, campaignId, dateTime, data)
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► SaveCampaignEvent(Guid, Guid, DateTime, String)
Declaration Syntax
C#
public static void SaveCampaignEvent(
    Guid campaignEventId,
    Guid campaignId,
    DateTime dateTime,
    string data
)
Parameters
campaignEventId (Guid)
campaignId (Guid)
dateTime (DateTime)
data (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SaveMultiVarianceTestDefinition Method (multiVarianceTestId, title, description)

SaveMultiVarianceTestDefinition Method (multiVarianceTestId, title, description)
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► SaveMultiVarianceTestDefinition(Guid, String, String)
Declaration Syntax
C#
public static void SaveMultiVarianceTestDefinition(
    Guid multiVarianceTestId,
    string title,
    string description
)
Parameters
multiVarianceTestId (Guid)
title (String)
description (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SaveMultiVarianceTestVariable Method (multiVarianceTestVariableId, multiVarianceTestDefinitionId, name)

SaveMultiVarianceTestVariable Method (multiVarianceTestVariableId, multiVarianceTestDefinitionId, name)
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► SaveMultiVarianceTestVariable(Guid, Guid, String)
Declaration Syntax
C#
public static void SaveMultiVarianceTestVariable(
    Guid multiVarianceTestVariableId,
    Guid multiVarianceTestDefinitionId,
    string name
)
Parameters
multiVarianceTestVariableId (Guid)
multiVarianceTestDefinitionId (Guid)
name (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SavePageEventDefinition Method (pageEventDefinitionId, name, icon, description, isSystem, isAuthorFeedback, isGoal, isFailure)

SavePageEventDefinition Method (pageEventDefinitionId, name, icon, description, isSystem, isAuthorFeedback, isGoal, isFailure)
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► SavePageEventDefinition(Guid, String, String, String, Boolean, Boolean, Boolean, Boolean)
Declaration Syntax
C#
public static void SavePageEventDefinition(
    Guid pageEventDefinitionId,
    string name,
    string icon,
    string description,
    bool isSystem,
    bool isAuthorFeedback,
    bool isGoal,
    bool isFailure
)
Parameters
pageEventDefinitionId (Guid)
name (String)
icon (String)
description (String)
isSystem (Boolean)
isAuthorFeedback (Boolean)
isGoal (Boolean)
isFailure (Boolean)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SaveProfileDefinition Method (profileDefinitionId, name, profileType)

SaveProfileDefinition Method (profileDefinitionId, name, profileType)
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► SaveProfileDefinition(Guid, String, String)
Declaration Syntax
C#
public static void SaveProfileDefinition(
    Guid profileDefinitionId,
    string name,
    string profileType
)
Parameters
profileDefinitionId (Guid)
name (String)
profileType (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SaveProfileKeyDefinition Method (profileKeyDefinitionId, profileDefinitionId, name, control, minValue, maxValue)

SaveProfileKeyDefinition Method (profileKeyDefinitionId, profileDefinitionId, name, control, minValue, maxValue)
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► SaveProfileKeyDefinition(Guid, Guid, String, String, Int32, Int32)
Declaration Syntax
C#
public static void SaveProfileKeyDefinition(
    Guid profileKeyDefinitionId,
    Guid profileDefinitionId,
    string name,
    string control,
    int minValue,
    int maxValue
)
Parameters
profileKeyDefinitionId (Guid)
profileDefinitionId (Guid)
name (String)
control (String)
minValue (Int32)
maxValue (Int32)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SetStatusFailed Method (statusId)

SetStatusFailed Method (statusId)
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► SetStatusFailed(Guid)
Declaration Syntax
C#
public static void SetStatusFailed(
    Guid statusId
)
Parameters
statusId (Guid)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SetStatusSuccessful Method (statusId)

SetStatusSuccessful Method (statusId)
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► SetStatusSuccessful(Guid)
Declaration Syntax
C#
public static void SetStatusSuccessful(
    Guid statusId
)
Parameters
statusId (Guid)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


STATUS_QUEUE_FULL Field

STATUS_QUEUE_FULL Field
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► STATUS_QUEUE_FULL
Declaration Syntax
C#
public static Guid STATUS_QUEUE_FULL

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


STATUS_REQUEST Field

STATUS_REQUEST Field
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► STATUS_REQUEST
Declaration Syntax
C#
public static Guid STATUS_REQUEST

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


STATUSLOOKUP Field

STATUSLOOKUP Field
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► STATUSLOOKUP
Declaration Syntax
C#
public static Guid STATUSLOOKUP

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Submit Method (tracker, defer)

Submit Method (tracker, defer)
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► Submit(AnalyticsTracker, Boolean)
Declaration Syntax
C#
public static void Submit(
    AnalyticsTracker tracker,
    bool defer
)
Parameters
tracker (AnalyticsTracker)
defer (Boolean)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


UpdateIpInformation Method (ipId, whoIsInformation)

UpdateIpInformation Method (ipId, whoIsInformation)
Namespaces ► Sitecore.Analytics ► AnalyticsManager ► UpdateIpInformation(Guid, WhoIsInformation)
Declaration Syntax
C#
public static void UpdateIpInformation(
    Guid ipId,
    WhoIsInformation whoIsInformation
)
Parameters
ipId (Guid)
whoIsInformation (WhoIsInformation)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsPage Class

AnalyticsPage Class
Namespaces ► Sitecore.Analytics ► AnalyticsPage
Declaration Syntax
C#
public class AnalyticsPage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalyticsPage()()() | Initializes a new instance of the AnalyticsPage class
 | CampaignEventIds |
 | CreateCampaignEvent(Guid, String, Int32) |
 | Data |
 | DeviceId |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasCampaignEventPages |
 | HasPageEvents |
 | Item |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Navigation |
 | PageEvents |
 | TestVariableCampaignEventIds |
 | TestVariablePageIds |
 | Timestamp |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TriggerCampaignEvent(Guid) |
 | TriggerCampaignEvent(Guid, String, String) |
 | TriggerCampaignTestVariable(Guid, Guid) |
 | TriggerEvent(String) |
 | TriggerEvent(String, String) |
 | TriggerEvent(AnalyticsPageEvent) |
 | TriggerEvent(String, String, String, String) |
 | TriggerEvent(String, String, String, String, Int32) |
 | TriggerEventExpandable(String, String) |
 | TriggerTestVariable(Guid) |
 | Url |
Inheritance Hierarchy
Object
AnalyticsPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsPage Constructor

AnalyticsPage Constructor
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► AnalyticsPage()()()
Initializes a new instance of the AnalyticsPage class
Declaration Syntax
C#
public AnalyticsPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEventIds Property

CampaignEventIds Property
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► CampaignEventIds
Declaration Syntax
C#
public List<Guid> CampaignEventIds { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CreateCampaignEvent Method (campaignId, data, state)

CreateCampaignEvent Method (campaignId, data, state)
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► CreateCampaignEvent(Guid, String, Int32)
Declaration Syntax
C#
public Guid CreateCampaignEvent(
    Guid campaignId,
    string data,
    int state
)
Parameters
campaignId (Guid)
data (String)
state (Int32)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Data Property

Data Property
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► Data
Declaration Syntax
C#
public string Data { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


DeviceId Property

DeviceId Property
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► DeviceId
Declaration Syntax
C#
public Guid DeviceId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


HasCampaignEventPages Property

HasCampaignEventPages Property
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► HasCampaignEventPages
Declaration Syntax
C#
public bool HasCampaignEventPages { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


HasPageEvents Property

HasPageEvents Property
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► HasPageEvents
Declaration Syntax
C#
public bool HasPageEvents { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Item Property

Item Property
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► Item
Declaration Syntax
C#
public Item Item { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Navigation Property

Navigation Property
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► Navigation
Declaration Syntax
C#
public string Navigation { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageEvents Property

PageEvents Property
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► PageEvents
Declaration Syntax
C#
public IEnumerable<AnalyticsPageEvent> PageEvents { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TestVariableCampaignEventIds Property

TestVariableCampaignEventIds Property
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► TestVariableCampaignEventIds
Declaration Syntax
C#
public IEnumerable<KeyValuePair<Guid, Guid>> TestVariableCampaignEventIds { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TestVariablePageIds Property

TestVariablePageIds Property
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► TestVariablePageIds
Declaration Syntax
C#
public IEnumerable<Guid> TestVariablePageIds { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Timestamp Property

Timestamp Property
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► Timestamp
Declaration Syntax
C#
public DateTime Timestamp { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerCampaignEvent Method

TriggerCampaignEvent Method
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► TriggerCampaignEvent()()()
Members
Icon | Member | Description
 | TriggerCampaignEvent(Guid) |
 | TriggerCampaignEvent(Guid, String, String) |

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerCampaignEvent Method (campaignEventId)

TriggerCampaignEvent Method (campaignEventId)
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► TriggerCampaignEvent(Guid)
Declaration Syntax
C#
public void TriggerCampaignEvent(
    Guid campaignEventId
)
Parameters
campaignEventId (Guid)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerCampaignEvent Method (campaignEventId, key, data)

TriggerCampaignEvent Method (campaignEventId, key, data)
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► TriggerCampaignEvent(Guid, String, String)
Declaration Syntax
C#
public void TriggerCampaignEvent(
    Guid campaignEventId,
    string key,
    string data
)
Parameters
campaignEventId (Guid)
key (String)
data (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerCampaignTestVariable Method (campaignEventId, testVariable)

TriggerCampaignTestVariable Method (campaignEventId, testVariable)
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► TriggerCampaignTestVariable(Guid, Guid)
Declaration Syntax
C#
public void TriggerCampaignTestVariable(
    Guid campaignEventId,
    Guid testVariable
)
Parameters
campaignEventId (Guid)
testVariable (Guid)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerEvent Method

TriggerEvent Method
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► TriggerEvent()()()
Members
Icon | Member | Description
 | TriggerEvent(String) |
 | TriggerEvent(String, String) |
 | TriggerEvent(AnalyticsPageEvent) |
 | TriggerEvent(String, String, String, String) |
 | TriggerEvent(String, String, String, String, Int32) |

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerEvent Method (pageEvent)

TriggerEvent Method (pageEvent)
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► TriggerEvent(AnalyticsPageEvent)
Declaration Syntax
C#
public AnalyticsPageEvent TriggerEvent(
    AnalyticsPageEvent pageEvent
)
Parameters
pageEvent (AnalyticsPageEvent)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerEvent Method (pageEventName)

TriggerEvent Method (pageEventName)
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► TriggerEvent(String)
Declaration Syntax
C#
public void TriggerEvent(
    string pageEventName
)
Parameters
pageEventName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerEvent Method (pageEventName, text)

TriggerEvent Method (pageEventName, text)
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► TriggerEvent(String, String)
Declaration Syntax
C#
public void TriggerEvent(
    string pageEventName,
    string text
)
Parameters
pageEventName (String)
text (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerEvent Method (name, text, key, data)

TriggerEvent Method (name, text, key, data)
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► TriggerEvent(String, String, String, String)
Declaration Syntax
C#
public AnalyticsPageEvent TriggerEvent(
    string name,
    string text,
    string key,
    string data
)
Parameters
name (String)
text (String)
key (String)
data (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerEvent Method (name, text, key, data, integer)

TriggerEvent Method (name, text, key, data, integer)
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► TriggerEvent(String, String, String, String, Int32)
Declaration Syntax
C#
public AnalyticsPageEvent TriggerEvent(
    string name,
    string text,
    string key,
    string data,
    int integer
)
Parameters
name (String)
text (String)
key (String)
data (String)
integer (Int32)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerEventExpandable Method (name, value)

TriggerEventExpandable Method (name, value)
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► TriggerEventExpandable(String, String)
Declaration Syntax
C#
public AnalyticsPageEvent TriggerEventExpandable(
    string name,
    string value
)
Parameters
name (String)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerTestVariable Method (testVariable)

TriggerTestVariable Method (testVariable)
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► TriggerTestVariable(Guid)
Declaration Syntax
C#
public void TriggerTestVariable(
    Guid testVariable
)
Parameters
testVariable (Guid)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Url Property

Url Property
Namespaces ► Sitecore.Analytics ► AnalyticsPage ► Url
Declaration Syntax
C#
public string Url { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsPageEvent Class

AnalyticsPageEvent Class
Namespaces ► Sitecore.Analytics ► AnalyticsPageEvent
Declaration Syntax
C#
public class AnalyticsPageEvent
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalyticsPageEvent()()() | Initializes a new instance of the AnalyticsPageEvent class
 | Data |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Integer |
 | Item |
 | Key |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | Text |
 | Timestamp |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AnalyticsPageEvent

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsPageEvent Constructor

AnalyticsPageEvent Constructor
Namespaces ► Sitecore.Analytics ► AnalyticsPageEvent ► AnalyticsPageEvent()()()
Initializes a new instance of the AnalyticsPageEvent class
Declaration Syntax
C#
public AnalyticsPageEvent()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Data Property

Data Property
Namespaces ► Sitecore.Analytics ► AnalyticsPageEvent ► Data
Declaration Syntax
C#
public string Data { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Integer Property

Integer Property
Namespaces ► Sitecore.Analytics ► AnalyticsPageEvent ► Integer
Declaration Syntax
C#
public int Integer { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Item Property

Item Property
Namespaces ► Sitecore.Analytics ► AnalyticsPageEvent ► Item
Declaration Syntax
C#
public Item Item { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Key Property

Key Property
Namespaces ► Sitecore.Analytics ► AnalyticsPageEvent ► Key
Declaration Syntax
C#
public string Key { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Name Property

Name Property
Namespaces ► Sitecore.Analytics ► AnalyticsPageEvent ► Name
Declaration Syntax
C#
public string Name { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Text Property

Text Property
Namespaces ► Sitecore.Analytics ► AnalyticsPageEvent ► Text
Declaration Syntax
C#
public string Text { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Timestamp Property

Timestamp Property
Namespaces ► Sitecore.Analytics ► AnalyticsPageEvent ► Timestamp
Declaration Syntax
C#
public long Timestamp { get; protected set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsSession Class

AnalyticsSession Class
Namespaces ► Sitecore.Analytics ► AnalyticsSession
Declaration Syntax
C#
public class AnalyticsSession
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalyticsSession()()() | Initializes a new instance of the AnalyticsSession class
 | AspNetSessionId |
 | Browser |
 | Domain |
 | Duration |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSessionId()()() |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Ip |
 | IsNewSession |
 | Keywords |
 | Language |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultiSite |
 | OperatingSystem |
 | Profiles |
 | ReferringSite |
 | Screen |
 | SessionId |
 | Timestamp |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AnalyticsSession

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsSession Constructor

AnalyticsSession Constructor
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► AnalyticsSession()()()
Initializes a new instance of the AnalyticsSession class
Declaration Syntax
C#
public AnalyticsSession()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AspNetSessionId Property

AspNetSessionId Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► AspNetSessionId
Declaration Syntax
C#
public string AspNetSessionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Browser Property

Browser Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► Browser
Declaration Syntax
C#
public string Browser { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Domain Property

Domain Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► Domain
Declaration Syntax
C#
public string Domain { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Duration Property

Duration Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► Duration
Declaration Syntax
C#
public TimeSpan Duration { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetSessionId Method

GetSessionId Method
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► GetSessionId()()()
Declaration Syntax
C#
public Guid GetSessionId()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Ip Property

Ip Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► Ip
Declaration Syntax
C#
public string Ip { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsNewSession Property

IsNewSession Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► IsNewSession
Declaration Syntax
C#
public bool IsNewSession { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Keywords Property

Keywords Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► Keywords
Declaration Syntax
C#
public string Keywords { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Language Property

Language Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► Language
Declaration Syntax
C#
public string Language { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiSite Property

MultiSite Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► MultiSite
Declaration Syntax
C#
public string MultiSite { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatingSystem Property

OperatingSystem Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► OperatingSystem
Declaration Syntax
C#
public string OperatingSystem { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Profiles Property

Profiles Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► Profiles
Declaration Syntax
C#
public List<Profile> Profiles { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReferringSite Property

ReferringSite Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► ReferringSite
Declaration Syntax
C#
public string ReferringSite { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Screen Property

Screen Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► Screen
Declaration Syntax
C#
public string Screen { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SessionId Property

SessionId Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► SessionId
Declaration Syntax
C#
public Guid SessionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Timestamp Property

Timestamp Property
Namespaces ► Sitecore.Analytics ► AnalyticsSession ► Timestamp
Declaration Syntax
C#
public DateTime Timestamp { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsTexts Class

AnalyticsTexts Class
Namespaces ► Sitecore.Analytics ► AnalyticsTexts
Declaration Syntax
C#
public static class AnalyticsTexts
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SelectCampaign |
 | SelectItem |
 | SelectLanguage |
 | SelectTheCampaignYouWantToUseForThisRule |
 | SelectTheItemYouWantToUseForThisRule |
 | SelectTheLanguageYouWantToUseForThisRule |
Inheritance Hierarchy
Object
AnalyticsTexts

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SelectCampaign Field

SelectCampaign Field
Namespaces ► Sitecore.Analytics ► AnalyticsTexts ► SelectCampaign
Declaration Syntax
C#
public const string SelectCampaign

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SelectItem Field

SelectItem Field
Namespaces ► Sitecore.Analytics ► AnalyticsTexts ► SelectItem
Declaration Syntax
C#
public const string SelectItem

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SelectLanguage Field

SelectLanguage Field
Namespaces ► Sitecore.Analytics ► AnalyticsTexts ► SelectLanguage
Declaration Syntax
C#
public const string SelectLanguage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SelectTheCampaignYouWantToUseForThisRule Field

SelectTheCampaignYouWantToUseForThisRule Field
Namespaces ► Sitecore.Analytics ► AnalyticsTexts ► SelectTheCampaignYouWantToUseForThisRule
Declaration Syntax
C#
public const string SelectTheCampaignYouWantToUseForThisRule

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SelectTheItemYouWantToUseForThisRule Field

SelectTheItemYouWantToUseForThisRule Field
Namespaces ► Sitecore.Analytics ► AnalyticsTexts ► SelectTheItemYouWantToUseForThisRule
Declaration Syntax
C#
public const string SelectTheItemYouWantToUseForThisRule

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SelectTheLanguageYouWantToUseForThisRule Field

SelectTheLanguageYouWantToUseForThisRule Field
Namespaces ► Sitecore.Analytics ► AnalyticsTexts ► SelectTheLanguageYouWantToUseForThisRule
Declaration Syntax
C#
public const string SelectTheLanguageYouWantToUseForThisRule

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsTracker Class

AnalyticsTracker Class
Namespaces ► Sitecore.Analytics ► AnalyticsTracker
Declaration Syntax
C#
public class AnalyticsTracker
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalyticsTracker()()() | Initializes a new instance of the AnalyticsTracker class
 | CanBeRobot |
 | Cancel()()() |
 | Current |
 | CurrentGlobalSession |
 | CurrentPage |
 | CurrentSession |
 | Data |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InvalidateCachedData()()() |
 | IsActive |
 | IsCanceled |
 | IsTestCampaignEventMode |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextPage |
 | PreviousPage |
 | SetTestCampaignEventId(Guid) |
 | StartTracking()()() |
 | Submit()()() |
 | TestCampaignEventId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TriggerEvent(String) |
 | TriggerEvent(String, String) |
 | TriggerProfile(String, String, Int32) |
Inheritance Hierarchy
Object
AnalyticsTracker

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsTracker Constructor

AnalyticsTracker Constructor
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► AnalyticsTracker()()()
Initializes a new instance of the AnalyticsTracker class
Declaration Syntax
C#
public AnalyticsTracker()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CanBeRobot Property

CanBeRobot Property
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► CanBeRobot
Declaration Syntax
C#
public bool CanBeRobot { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Cancel Method

Cancel Method
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► Cancel()()()
Declaration Syntax
C#
public void Cancel()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Current Property

Current Property
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► Current
Declaration Syntax
C#
public static AnalyticsTracker Current { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CurrentGlobalSession Property

CurrentGlobalSession Property
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► CurrentGlobalSession
Declaration Syntax
C#
public AnalyticsGlobalSession CurrentGlobalSession { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CurrentPage Property

CurrentPage Property
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► CurrentPage
Declaration Syntax
C#
public AnalyticsPage CurrentPage { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CurrentSession Property

CurrentSession Property
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► CurrentSession
Declaration Syntax
C#
public AnalyticsSession CurrentSession { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Data Property

Data Property
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► Data
Declaration Syntax
C#
public AnalyticsCachedData Data { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


InvalidateCachedData Method

InvalidateCachedData Method
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► InvalidateCachedData()()()
Declaration Syntax
C#
public void InvalidateCachedData()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsActive Property

IsActive Property
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► IsActive
Declaration Syntax
C#
public static bool IsActive { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsCanceled Property

IsCanceled Property
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► IsCanceled
Declaration Syntax
C#
public bool IsCanceled { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsTestCampaignEventMode Property

IsTestCampaignEventMode Property
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► IsTestCampaignEventMode
Declaration Syntax
C#
public bool IsTestCampaignEventMode { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


NextPage Property

NextPage Property
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► NextPage
Declaration Syntax
C#
public AnalyticsPage NextPage { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PreviousPage Property

PreviousPage Property
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► PreviousPage
Declaration Syntax
C#
public AnalyticsPage PreviousPage { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SetTestCampaignEventId Method (testCampaignEventId)

SetTestCampaignEventId Method (testCampaignEventId)
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► SetTestCampaignEventId(Guid)
Declaration Syntax
C#
public void SetTestCampaignEventId(
    Guid testCampaignEventId
)
Parameters
testCampaignEventId (Guid)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StartTracking Method

StartTracking Method
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► StartTracking()()()
Declaration Syntax
C#
public static void StartTracking()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Submit Method

Submit Method
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► Submit()()()
Declaration Syntax
C#
public void Submit()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TestCampaignEventId Property

TestCampaignEventId Property
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► TestCampaignEventId
Declaration Syntax
C#
public Guid TestCampaignEventId { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerEvent Method

TriggerEvent Method
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► TriggerEvent()()()
Members
Icon | Member | Description
 | TriggerEvent(String) |
 | TriggerEvent(String, String) |

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerEvent Method (pageEventName)

TriggerEvent Method (pageEventName)
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► TriggerEvent(String)
Declaration Syntax
C#
public static void TriggerEvent(
    string pageEventName
)
Parameters
pageEventName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerEvent Method (pageEventName, text)

TriggerEvent Method (pageEventName, text)
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► TriggerEvent(String, String)
Declaration Syntax
C#
public void TriggerEvent(
    string pageEventName,
    string text
)
Parameters
pageEventName (String)
text (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TriggerProfile Method (profileName, profileKeyName, value)

TriggerProfile Method (profileName, profileKeyName, value)
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► TriggerProfile(String, String, Int32)
Declaration Syntax
C#
public void TriggerProfile(
    string profileName,
    string profileKeyName,
    int value
)
Parameters
profileName (String)
profileKeyName (String)
value (Int32)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsTracker.Summary Class

AnalyticsTracker..::.Summary Class
Namespaces ► Sitecore.Analytics ► AnalyticsTracker ► AnalyticsTracker..::.Summary
Declaration Syntax
C#
[ObsoleteAttribute("Use SummaryHtmlWriter instead.")]
public static class Summary
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Render()()() |
Inheritance Hierarchy
Object
AnalyticsTracker..::.Summary

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Render Method

Render Method
Namespaces ► Sitecore.Analytics ► AnalyticsTracker..::.Summary ► Render()()()
Declaration Syntax
C#
public static string Render()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Browser Class

Browser Class
Namespaces ► Sitecore.Analytics ► Browser
Declaration Syntax
C#
public class Browser : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Browser()()() | Initializes a new instance of the Browser class
 | BrowserId |
 | Comment |
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Link1 |
 | Link2 |
 | MajorName |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | Sessions |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserAgent |
 | Version |
 | VisitorIdentification |
Inheritance Hierarchy
Object
Browser

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Browser Constructor

Browser Constructor
Namespaces ► Sitecore.Analytics ► Browser ► Browser()()()
Initializes a new instance of the Browser class
Declaration Syntax
C#
public Browser()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


BrowserId Property

BrowserId Property
Namespaces ► Sitecore.Analytics ► Browser ► BrowserId
Declaration Syntax
C#
public Guid BrowserId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Comment Property

Comment Property
Namespaces ► Sitecore.Analytics ► Browser ► Comment
Declaration Syntax
C#
public string Comment { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Description Property

Description Property
Namespaces ► Sitecore.Analytics ► Browser ► Description
Declaration Syntax
C#
public string Description { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Link1 Property

Link1 Property
Namespaces ► Sitecore.Analytics ► Browser ► Link1
Declaration Syntax
C#
public string Link1 { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Link2 Property

Link2 Property
Namespaces ► Sitecore.Analytics ► Browser ► Link2
Declaration Syntax
C#
public string Link2 { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MajorName Property

MajorName Property
Namespaces ► Sitecore.Analytics ► Browser ► MajorName
Declaration Syntax
C#
public string MajorName { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► Browser ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► Browser ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► Browser ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► Browser ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► Browser ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► Browser ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► Browser ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sessions Property

Sessions Property
Namespaces ► Sitecore.Analytics ► Browser ► Sessions
Declaration Syntax
C#
public EntitySet<Session> Sessions { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


UserAgent Property

UserAgent Property
Namespaces ► Sitecore.Analytics ► Browser ► UserAgent
Declaration Syntax
C#
public string UserAgent { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Version Property

Version Property
Namespaces ► Sitecore.Analytics ► Browser ► Version
Declaration Syntax
C#
public string Version { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


VisitorIdentification Property

VisitorIdentification Property
Namespaces ► Sitecore.Analytics ► Browser ► VisitorIdentification
Declaration Syntax
C#
public int VisitorIdentification { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Campaign Class

Campaign Class
Namespaces ► Sitecore.Analytics ► Campaign
Declaration Syntax
C#
public class Campaign : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Campaign()()() | Initializes a new instance of the Campaign class
 | CampaignEvents |
 | CampaignId |
 | Cost |
 | Data |
 | Description |
 | EndDate |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsActive |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | StartDate |
 | Title |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type |
Inheritance Hierarchy
Object
Campaign

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Campaign Constructor

Campaign Constructor
Namespaces ► Sitecore.Analytics ► Campaign ► Campaign()()()
Initializes a new instance of the Campaign class
Declaration Syntax
C#
public Campaign()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEvents Property

CampaignEvents Property
Namespaces ► Sitecore.Analytics ► Campaign ► CampaignEvents
Declaration Syntax
C#
public EntitySet<CampaignEvent> CampaignEvents { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignId Property

CampaignId Property
Namespaces ► Sitecore.Analytics ► Campaign ► CampaignId
Declaration Syntax
C#
public Guid CampaignId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Cost Property

Cost Property
Namespaces ► Sitecore.Analytics ► Campaign ► Cost
Declaration Syntax
C#
public double Cost { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Data Property

Data Property
Namespaces ► Sitecore.Analytics ► Campaign ► Data
Declaration Syntax
C#
public string Data { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Description Property

Description Property
Namespaces ► Sitecore.Analytics ► Campaign ► Description
Declaration Syntax
C#
public string Description { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EndDate Property

EndDate Property
Namespaces ► Sitecore.Analytics ► Campaign ► EndDate
Declaration Syntax
C#
public DateTime EndDate { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsActive Property

IsActive Property
Namespaces ► Sitecore.Analytics ► Campaign ► IsActive
Declaration Syntax
C#
public int IsActive { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► Campaign ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► Campaign ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► Campaign ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► Campaign ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► Campaign ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► Campaign ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► Campaign ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StartDate Property

StartDate Property
Namespaces ► Sitecore.Analytics ► Campaign ► StartDate
Declaration Syntax
C#
public DateTime StartDate { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Title Property

Title Property
Namespaces ► Sitecore.Analytics ► Campaign ► Title
Declaration Syntax
C#
public string Title { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Type Property

Type Property
Namespaces ► Sitecore.Analytics ► Campaign ► Type
Declaration Syntax
C#
public string Type { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEvent Class

CampaignEvent Class
Namespaces ► Sitecore.Analytics ► CampaignEvent
Declaration Syntax
C#
public class CampaignEvent : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CampaignEvent()()() | Initializes a new instance of the CampaignEvent class
 | Campaign |
 | CampaignEventId |
 | CampaignEventPages |
 | CampaignId |
 | Data |
 | DateTime |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultiVarianceTestVariableCampaignEvents |
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | State |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CampaignEvent

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEvent Constructor

CampaignEvent Constructor
Namespaces ► Sitecore.Analytics ► CampaignEvent ► CampaignEvent()()()
Initializes a new instance of the CampaignEvent class
Declaration Syntax
C#
public CampaignEvent()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Campaign Property

Campaign Property
Namespaces ► Sitecore.Analytics ► CampaignEvent ► Campaign
Declaration Syntax
C#
public Campaign Campaign { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEventId Property

CampaignEventId Property
Namespaces ► Sitecore.Analytics ► CampaignEvent ► CampaignEventId
Declaration Syntax
C#
public Guid CampaignEventId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEventPages Property

CampaignEventPages Property
Namespaces ► Sitecore.Analytics ► CampaignEvent ► CampaignEventPages
Declaration Syntax
C#
public EntitySet<CampaignEventPage> CampaignEventPages { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignId Property

CampaignId Property
Namespaces ► Sitecore.Analytics ► CampaignEvent ► CampaignId
Declaration Syntax
C#
public Guid CampaignId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Data Property

Data Property
Namespaces ► Sitecore.Analytics ► CampaignEvent ► Data
Declaration Syntax
C#
public string Data { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


DateTime Property

DateTime Property
Namespaces ► Sitecore.Analytics ► CampaignEvent ► DateTime
Declaration Syntax
C#
public DateTime DateTime { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariableCampaignEvents Property

MultiVarianceTestVariableCampaignEvents Property
Namespaces ► Sitecore.Analytics ► CampaignEvent ► MultiVarianceTestVariableCampaignEvents
Declaration Syntax
C#
public EntitySet<MultiVarianceTestVariableCampaignEvent> MultiVarianceTestVariableCampaignEvents { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► CampaignEvent ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► CampaignEvent ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► CampaignEvent ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► CampaignEvent ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► CampaignEvent ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► CampaignEvent ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► CampaignEvent ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


State Property

State Property
Namespaces ► Sitecore.Analytics ► CampaignEvent ► State
Declaration Syntax
C#
public int State { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEventPage Class

CampaignEventPage Class
Namespaces ► Sitecore.Analytics ► CampaignEventPage
Declaration Syntax
C#
public class CampaignEventPage : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CampaignEventPage()()() | Initializes a new instance of the CampaignEventPage class
 | CampaignEvent |
 | CampaignEventId |
 | CampaignSessionPageId |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializing(StreamingContext) |
 | Page |
 | PageId |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CampaignEventPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEventPage Constructor

CampaignEventPage Constructor
Namespaces ► Sitecore.Analytics ► CampaignEventPage ► CampaignEventPage()()()
Initializes a new instance of the CampaignEventPage class
Declaration Syntax
C#
public CampaignEventPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEvent Property

CampaignEvent Property
Namespaces ► Sitecore.Analytics ► CampaignEventPage ► CampaignEvent
Declaration Syntax
C#
public CampaignEvent CampaignEvent { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEventId Property

CampaignEventId Property
Namespaces ► Sitecore.Analytics ► CampaignEventPage ► CampaignEventId
Declaration Syntax
C#
public Guid CampaignEventId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignSessionPageId Property

CampaignSessionPageId Property
Namespaces ► Sitecore.Analytics ► CampaignEventPage ► CampaignSessionPageId
Declaration Syntax
C#
public Guid CampaignSessionPageId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► CampaignEventPage ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Page Property

Page Property
Namespaces ► Sitecore.Analytics ► CampaignEventPage ► Page
Declaration Syntax
C#
public Page Page { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageId Property

PageId Property
Namespaces ► Sitecore.Analytics ► CampaignEventPage ► PageId
Declaration Syntax
C#
public Guid PageId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► CampaignEventPage ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► CampaignEventPage ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► CampaignEventPage ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► CampaignEventPage ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GlobalSession Class

GlobalSession Class
Namespaces ► Sitecore.Analytics ► GlobalSession
Declaration Syntax
C#
public class GlobalSession : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GlobalSession()()() | Initializes a new instance of the GlobalSession class
 | CookieValue |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExternalUser |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalSessionId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | OverriddenVisitorIdentification |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | Sessions |
 | Tags |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VisitorIdentification |
Inheritance Hierarchy
Object
GlobalSession

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GlobalSession Constructor

GlobalSession Constructor
Namespaces ► Sitecore.Analytics ► GlobalSession ► GlobalSession()()()
Initializes a new instance of the GlobalSession class
Declaration Syntax
C#
public GlobalSession()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CookieValue Property

CookieValue Property
Namespaces ► Sitecore.Analytics ► GlobalSession ► CookieValue
Declaration Syntax
C#
public string CookieValue { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ExternalUser Property

ExternalUser Property
Namespaces ► Sitecore.Analytics ► GlobalSession ► ExternalUser
Declaration Syntax
C#
public string ExternalUser { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GlobalSessionId Property

GlobalSessionId Property
Namespaces ► Sitecore.Analytics ► GlobalSession ► GlobalSessionId
Declaration Syntax
C#
public Guid GlobalSessionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► GlobalSession ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► GlobalSession ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► GlobalSession ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OverriddenVisitorIdentification Property

OverriddenVisitorIdentification Property
Namespaces ► Sitecore.Analytics ► GlobalSession ► OverriddenVisitorIdentification
Declaration Syntax
C#
public int OverriddenVisitorIdentification { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► GlobalSession ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► GlobalSession ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► GlobalSession ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► GlobalSession ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sessions Property

Sessions Property
Namespaces ► Sitecore.Analytics ► GlobalSession ► Sessions
Declaration Syntax
C#
public EntitySet<Session> Sessions { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Tags Property

Tags Property
Namespaces ► Sitecore.Analytics ► GlobalSession ► Tags
Declaration Syntax
C#
public EntitySet<Tag> Tags { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


VisitorIdentification Property

VisitorIdentification Property
Namespaces ► Sitecore.Analytics ► GlobalSession ► VisitorIdentification
Declaration Syntax
C#
public int VisitorIdentification { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IP Class

IP Class
Namespaces ► Sitecore.Analytics ► IP
Declaration Syntax
C#
public class IP : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IP()()() | Initializes a new instance of the IP class
 | AreaCode |
 | City |
 | Dns |
 | DnsVisitorIdentification |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IpAddressFrom |
 | IpAddressTo |
 | IpId |
 | IPOwner |
 | IpOwnerId |
 | IspName |
 | Latitude |
 | Longitude |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MetroCode |
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | PostalCode |
 | PropertyChanged |
 | PropertyChanging |
 | Region |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | Sessions |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VisitorIdentification |
Inheritance Hierarchy
Object
IP

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IP Constructor

IP Constructor
Namespaces ► Sitecore.Analytics ► IP ► IP()()()
Initializes a new instance of the IP class
Declaration Syntax
C#
public IP()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AreaCode Property

AreaCode Property
Namespaces ► Sitecore.Analytics ► IP ► AreaCode
Declaration Syntax
C#
public string AreaCode { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


City Property

City Property
Namespaces ► Sitecore.Analytics ► IP ► City
Declaration Syntax
C#
public string City { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Dns Property

Dns Property
Namespaces ► Sitecore.Analytics ► IP ► Dns
Declaration Syntax
C#
public string Dns { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


DnsVisitorIdentification Property

DnsVisitorIdentification Property
Namespaces ► Sitecore.Analytics ► IP ► DnsVisitorIdentification
Declaration Syntax
C#
public int DnsVisitorIdentification { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpAddressFrom Property

IpAddressFrom Property
Namespaces ► Sitecore.Analytics ► IP ► IpAddressFrom
Declaration Syntax
C#
public string IpAddressFrom { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpAddressTo Property

IpAddressTo Property
Namespaces ► Sitecore.Analytics ► IP ► IpAddressTo
Declaration Syntax
C#
public string IpAddressTo { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpId Property

IpId Property
Namespaces ► Sitecore.Analytics ► IP ► IpId
Declaration Syntax
C#
public Guid IpId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IPOwner Property

IPOwner Property
Namespaces ► Sitecore.Analytics ► IP ► IPOwner
Declaration Syntax
C#
public IPOwner IPOwner { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpOwnerId Property

IpOwnerId Property
Namespaces ► Sitecore.Analytics ► IP ► IpOwnerId
Declaration Syntax
C#
public Guid IpOwnerId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IspName Property

IspName Property
Namespaces ► Sitecore.Analytics ► IP ► IspName
Declaration Syntax
C#
public string IspName { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Latitude Property

Latitude Property
Namespaces ► Sitecore.Analytics ► IP ► Latitude
Declaration Syntax
C#
public string Latitude { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Longitude Property

Longitude Property
Namespaces ► Sitecore.Analytics ► IP ► Longitude
Declaration Syntax
C#
public string Longitude { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MetroCode Property

MetroCode Property
Namespaces ► Sitecore.Analytics ► IP ► MetroCode
Declaration Syntax
C#
public string MetroCode { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► IP ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► IP ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► IP ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PostalCode Property

PostalCode Property
Namespaces ► Sitecore.Analytics ► IP ► PostalCode
Declaration Syntax
C#
public string PostalCode { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► IP ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► IP ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Region Property

Region Property
Namespaces ► Sitecore.Analytics ► IP ► Region
Declaration Syntax
C#
public string Region { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► IP ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► IP ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sessions Property

Sessions Property
Namespaces ► Sitecore.Analytics ► IP ► Sessions
Declaration Syntax
C#
public EntitySet<Session> Sessions { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


VisitorIdentification Property

VisitorIdentification Property
Namespaces ► Sitecore.Analytics ► IP ► VisitorIdentification
Declaration Syntax
C#
public int VisitorIdentification { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IPOwner Class

IPOwner Class
Namespaces ► Sitecore.Analytics ► IPOwner
Declaration Syntax
C#
public class IPOwner : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IPOwner()()() | Initializes a new instance of the IPOwner class
 | Country |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExternalUser |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IpOwnerId |
 | IPs |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | Subscriptions |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VisitorIdentification |
Inheritance Hierarchy
Object
IPOwner

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IPOwner Constructor

IPOwner Constructor
Namespaces ► Sitecore.Analytics ► IPOwner ► IPOwner()()()
Initializes a new instance of the IPOwner class
Declaration Syntax
C#
public IPOwner()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Country Property

Country Property
Namespaces ► Sitecore.Analytics ► IPOwner ► Country
Declaration Syntax
C#
public string Country { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ExternalUser Property

ExternalUser Property
Namespaces ► Sitecore.Analytics ► IPOwner ► ExternalUser
Declaration Syntax
C#
public string ExternalUser { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpOwnerId Property

IpOwnerId Property
Namespaces ► Sitecore.Analytics ► IPOwner ► IpOwnerId
Declaration Syntax
C#
public Guid IpOwnerId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IPs Property

IPs Property
Namespaces ► Sitecore.Analytics ► IPOwner ► IPs
Declaration Syntax
C#
public EntitySet<IP> IPs { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Name Property

Name Property
Namespaces ► Sitecore.Analytics ► IPOwner ► Name
Declaration Syntax
C#
public string Name { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► IPOwner ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► IPOwner ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► IPOwner ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► IPOwner ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► IPOwner ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► IPOwner ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► IPOwner ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Subscriptions Property

Subscriptions Property
Namespaces ► Sitecore.Analytics ► IPOwner ► Subscriptions
Declaration Syntax
C#
public EntitySet<Subscription> Subscriptions { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


VisitorIdentification Property

VisitorIdentification Property
Namespaces ► Sitecore.Analytics ► IPOwner ► VisitorIdentification
Declaration Syntax
C#
public int VisitorIdentification { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Keyword Class

Keyword Class
Namespaces ► Sitecore.Analytics ► Keyword
Declaration Syntax
C#
public class Keyword : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Keyword()()() | Initializes a new instance of the Keyword class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | KeywordId |
 | Keywords |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | Sessions |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Keyword

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Keyword Constructor

Keyword Constructor
Namespaces ► Sitecore.Analytics ► Keyword ► Keyword()()()
Initializes a new instance of the Keyword class
Declaration Syntax
C#
public Keyword()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


KeywordId Property

KeywordId Property
Namespaces ► Sitecore.Analytics ► Keyword ► KeywordId
Declaration Syntax
C#
public Guid KeywordId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Keywords Property

Keywords Property
Namespaces ► Sitecore.Analytics ► Keyword ► Keywords
Declaration Syntax
C#
public string Keywords { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► Keyword ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► Keyword ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► Keyword ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► Keyword ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► Keyword ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► Keyword ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► Keyword ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sessions Property

Sessions Property
Namespaces ► Sitecore.Analytics ► Keyword ► Sessions
Declaration Syntax
C#
public EntitySet<Session> Sessions { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestDefinition Class

MultiVarianceTestDefinition Class
Namespaces ► Sitecore.Analytics ► MultiVarianceTestDefinition
Declaration Syntax
C#
public class MultiVarianceTestDefinition : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiVarianceTestDefinition()()() | Initializes a new instance of the MultiVarianceTestDefinition class
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultiVarianceTestDefinitionId |
 | MultiVarianceTestVariables |
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | Title |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MultiVarianceTestDefinition

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestDefinition Constructor

MultiVarianceTestDefinition Constructor
Namespaces ► Sitecore.Analytics ► MultiVarianceTestDefinition ► MultiVarianceTestDefinition()()()
Initializes a new instance of the MultiVarianceTestDefinition class
Declaration Syntax
C#
public MultiVarianceTestDefinition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Description Property

Description Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestDefinition ► Description
Declaration Syntax
C#
public string Description { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestDefinitionId Property

MultiVarianceTestDefinitionId Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestDefinition ► MultiVarianceTestDefinitionId
Declaration Syntax
C#
public Guid MultiVarianceTestDefinitionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariables Property

MultiVarianceTestVariables Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestDefinition ► MultiVarianceTestVariables
Declaration Syntax
C#
public EntitySet<MultiVarianceTestVariable> MultiVarianceTestVariables { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► MultiVarianceTestDefinition ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► MultiVarianceTestDefinition ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► MultiVarianceTestDefinition ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► MultiVarianceTestDefinition ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► MultiVarianceTestDefinition ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► MultiVarianceTestDefinition ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► MultiVarianceTestDefinition ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Title Property

Title Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestDefinition ► Title
Declaration Syntax
C#
public string Title { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariable Class

MultiVarianceTestVariable Class
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable
Declaration Syntax
C#
public class MultiVarianceTestVariable : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiVarianceTestVariable()()() | Initializes a new instance of the MultiVarianceTestVariable class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultiVarianceTestDefinition |
 | MultiVarianceTestDefinitionId |
 | MultiVarianceTestVariableCampaignEvents |
 | MultiVarianceTestVariableId |
 | MultiVarianceTestVariablePages |
 | Name |
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MultiVarianceTestVariable

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariable Constructor

MultiVarianceTestVariable Constructor
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable ► MultiVarianceTestVariable()()()
Initializes a new instance of the MultiVarianceTestVariable class
Declaration Syntax
C#
public MultiVarianceTestVariable()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestDefinition Property

MultiVarianceTestDefinition Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable ► MultiVarianceTestDefinition
Declaration Syntax
C#
public MultiVarianceTestDefinition MultiVarianceTestDefinition { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestDefinitionId Property

MultiVarianceTestDefinitionId Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable ► MultiVarianceTestDefinitionId
Declaration Syntax
C#
public Guid MultiVarianceTestDefinitionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariableCampaignEvents Property

MultiVarianceTestVariableCampaignEvents Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable ► MultiVarianceTestVariableCampaignEvents
Declaration Syntax
C#
public EntitySet<MultiVarianceTestVariableCampaignEvent> MultiVarianceTestVariableCampaignEvents { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariableId Property

MultiVarianceTestVariableId Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable ► MultiVarianceTestVariableId
Declaration Syntax
C#
public Guid MultiVarianceTestVariableId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariablePages Property

MultiVarianceTestVariablePages Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable ► MultiVarianceTestVariablePages
Declaration Syntax
C#
public EntitySet<MultiVarianceTestVariablePage> MultiVarianceTestVariablePages { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Name Property

Name Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable ► Name
Declaration Syntax
C#
public string Name { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariable ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariableCampaignEvent Class

MultiVarianceTestVariableCampaignEvent Class
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariableCampaignEvent
Declaration Syntax
C#
public class MultiVarianceTestVariableCampaignEvent : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiVarianceTestVariableCampaignEvent()()() | Initializes a new instance of the MultiVarianceTestVariableCampaignEvent class
 | CampaignEvent |
 | CampaignEventId |
 | Data |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultiVarianceTestVariable |
 | MultiVarianceTestVariableCampaignEventId |
 | MultiVarianceTestVariableId |
 | OnDeserializing(StreamingContext) |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MultiVarianceTestVariableCampaignEvent

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariableCampaignEvent Constructor

MultiVarianceTestVariableCampaignEvent Constructor
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariableCampaignEvent ► MultiVarianceTestVariableCampaignEvent()()()
Initializes a new instance of the MultiVarianceTestVariableCampaignEvent class
Declaration Syntax
C#
public MultiVarianceTestVariableCampaignEvent()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEvent Property

CampaignEvent Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariableCampaignEvent ► CampaignEvent
Declaration Syntax
C#
public CampaignEvent CampaignEvent { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEventId Property

CampaignEventId Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariableCampaignEvent ► CampaignEventId
Declaration Syntax
C#
public Guid CampaignEventId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Data Property

Data Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariableCampaignEvent ► Data
Declaration Syntax
C#
public string Data { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariable Property

MultiVarianceTestVariable Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariableCampaignEvent ► MultiVarianceTestVariable
Declaration Syntax
C#
public MultiVarianceTestVariable MultiVarianceTestVariable { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariableCampaignEventId Property

MultiVarianceTestVariableCampaignEventId Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariableCampaignEvent ► MultiVarianceTestVariableCampaignEventId
Declaration Syntax
C#
public Guid MultiVarianceTestVariableCampaignEventId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariableId Property

MultiVarianceTestVariableId Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariableCampaignEvent ► MultiVarianceTestVariableId
Declaration Syntax
C#
public Guid MultiVarianceTestVariableId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariableCampaignEvent ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariableCampaignEvent ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariableCampaignEvent ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariableCampaignEvent ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariableCampaignEvent ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariablePage Class

MultiVarianceTestVariablePage Class
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariablePage
Declaration Syntax
C#
public class MultiVarianceTestVariablePage : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiVarianceTestVariablePage()()() | Initializes a new instance of the MultiVarianceTestVariablePage class
 | Data |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultiVarianceTestVariable |
 | MultiVarianceTestVariableId |
 | MultiVarianceTestVariablePageId |
 | OnDeserializing(StreamingContext) |
 | Page |
 | PageId |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MultiVarianceTestVariablePage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariablePage Constructor

MultiVarianceTestVariablePage Constructor
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariablePage ► MultiVarianceTestVariablePage()()()
Initializes a new instance of the MultiVarianceTestVariablePage class
Declaration Syntax
C#
public MultiVarianceTestVariablePage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Data Property

Data Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariablePage ► Data
Declaration Syntax
C#
public string Data { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariable Property

MultiVarianceTestVariable Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariablePage ► MultiVarianceTestVariable
Declaration Syntax
C#
public MultiVarianceTestVariable MultiVarianceTestVariable { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariableId Property

MultiVarianceTestVariableId Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariablePage ► MultiVarianceTestVariableId
Declaration Syntax
C#
public Guid MultiVarianceTestVariableId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariablePageId Property

MultiVarianceTestVariablePageId Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariablePage ► MultiVarianceTestVariablePageId
Declaration Syntax
C#
public Guid MultiVarianceTestVariablePageId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariablePage ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Page Property

Page Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariablePage ► Page
Declaration Syntax
C#
public Page Page { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageId Property

PageId Property
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariablePage ► PageId
Declaration Syntax
C#
public Guid PageId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariablePage ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariablePage ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariablePage ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► MultiVarianceTestVariablePage ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatingSystem Class

OperatingSystem Class
Namespaces ► Sitecore.Analytics ► OperatingSystem
Declaration Syntax
C#
public class OperatingSystem : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OperatingSystem()()() | Initializes a new instance of the OperatingSystem class
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MajorName |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinorName |
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | OperatingSystem1 |
 | OperatingSystemId |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | Sessions |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version |
Inheritance Hierarchy
Object
OperatingSystem

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatingSystem Constructor

OperatingSystem Constructor
Namespaces ► Sitecore.Analytics ► OperatingSystem ► OperatingSystem()()()
Initializes a new instance of the OperatingSystem class
Declaration Syntax
C#
public OperatingSystem()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Description Property

Description Property
Namespaces ► Sitecore.Analytics ► OperatingSystem ► Description
Declaration Syntax
C#
public string Description { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MajorName Property

MajorName Property
Namespaces ► Sitecore.Analytics ► OperatingSystem ► MajorName
Declaration Syntax
C#
public string MajorName { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MinorName Property

MinorName Property
Namespaces ► Sitecore.Analytics ► OperatingSystem ► MinorName
Declaration Syntax
C#
public string MinorName { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► OperatingSystem ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► OperatingSystem ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► OperatingSystem ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatingSystem1 Property

OperatingSystem1 Property
Namespaces ► Sitecore.Analytics ► OperatingSystem ► OperatingSystem1
Declaration Syntax
C#
public string OperatingSystem1 { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatingSystemId Property

OperatingSystemId Property
Namespaces ► Sitecore.Analytics ► OperatingSystem ► OperatingSystemId
Declaration Syntax
C#
public Guid OperatingSystemId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► OperatingSystem ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► OperatingSystem ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► OperatingSystem ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► OperatingSystem ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sessions Property

Sessions Property
Namespaces ► Sitecore.Analytics ► OperatingSystem ► Sessions
Declaration Syntax
C#
public EntitySet<Session> Sessions { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Version Property

Version Property
Namespaces ► Sitecore.Analytics ► OperatingSystem ► Version
Declaration Syntax
C#
public string Version { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Page Class

Page Class
Namespaces ► Sitecore.Analytics ► Page
Declaration Syntax
C#
public class Page : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Page()()() | Initializes a new instance of the Page class
 | CampaignEventPages |
 | Data |
 | DeviceId |
 | Duration |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexableUrl |
 | ItemId |
 | ItemLanguage |
 | ItemVersion |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultiVarianceTestVariablePages |
 | Navigation |
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | PageEvents |
 | PageId |
 | PageNo |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | Session |
 | SessionId |
 | Timestamp |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Url |
Inheritance Hierarchy
Object
Page

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Page Constructor

Page Constructor
Namespaces ► Sitecore.Analytics ► Page ► Page()()()
Initializes a new instance of the Page class
Declaration Syntax
C#
public Page()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEventPages Property

CampaignEventPages Property
Namespaces ► Sitecore.Analytics ► Page ► CampaignEventPages
Declaration Syntax
C#
public EntitySet<CampaignEventPage> CampaignEventPages { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Data Property

Data Property
Namespaces ► Sitecore.Analytics ► Page ► Data
Declaration Syntax
C#
public string Data { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


DeviceId Property

DeviceId Property
Namespaces ► Sitecore.Analytics ► Page ► DeviceId
Declaration Syntax
C#
public Guid DeviceId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Duration Property

Duration Property
Namespaces ► Sitecore.Analytics ► Page ► Duration
Declaration Syntax
C#
public int Duration { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IndexableUrl Property

IndexableUrl Property
Namespaces ► Sitecore.Analytics ► Page ► IndexableUrl
Declaration Syntax
C#
public string IndexableUrl { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ItemId Property

ItemId Property
Namespaces ► Sitecore.Analytics ► Page ► ItemId
Declaration Syntax
C#
public Guid ItemId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ItemLanguage Property

ItemLanguage Property
Namespaces ► Sitecore.Analytics ► Page ► ItemLanguage
Declaration Syntax
C#
public string ItemLanguage { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ItemVersion Property

ItemVersion Property
Namespaces ► Sitecore.Analytics ► Page ► ItemVersion
Declaration Syntax
C#
public int ItemVersion { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariablePages Property

MultiVarianceTestVariablePages Property
Namespaces ► Sitecore.Analytics ► Page ► MultiVarianceTestVariablePages
Declaration Syntax
C#
public EntitySet<MultiVarianceTestVariablePage> MultiVarianceTestVariablePages { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Navigation Property

Navigation Property
Namespaces ► Sitecore.Analytics ► Page ► Navigation
Declaration Syntax
C#
public string Navigation { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► Page ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► Page ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► Page ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageEvents Property

PageEvents Property
Namespaces ► Sitecore.Analytics ► Page ► PageEvents
Declaration Syntax
C#
public EntitySet<PageEvent> PageEvents { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageId Property

PageId Property
Namespaces ► Sitecore.Analytics ► Page ► PageId
Declaration Syntax
C#
public Guid PageId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageNo Property

PageNo Property
Namespaces ► Sitecore.Analytics ► Page ► PageNo
Declaration Syntax
C#
public int PageNo { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► Page ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► Page ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► Page ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► Page ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Session Property

Session Property
Namespaces ► Sitecore.Analytics ► Page ► Session
Declaration Syntax
C#
public Session Session { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SessionId Property

SessionId Property
Namespaces ► Sitecore.Analytics ► Page ► SessionId
Declaration Syntax
C#
public Guid SessionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Timestamp Property

Timestamp Property
Namespaces ► Sitecore.Analytics ► Page ► Timestamp
Declaration Syntax
C#
public DateTime Timestamp { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Url Property

Url Property
Namespaces ► Sitecore.Analytics ► Page ► Url
Declaration Syntax
C#
public string Url { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageEvent Class

PageEvent Class
Namespaces ► Sitecore.Analytics ► PageEvent
Declaration Syntax
C#
public class PageEvent : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PageEvent()()() | Initializes a new instance of the PageEvent class
 | Data |
 | DataKey |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Integer |
 | ItemId |
 | ItemLanguage |
 | ItemVersion |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializing(StreamingContext) |
 | Page |
 | PageEventDefinition |
 | PageEventDefinitionId |
 | PageEventId |
 | PageId |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | Text |
 | Timestamp |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PageEvent

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageEvent Constructor

PageEvent Constructor
Namespaces ► Sitecore.Analytics ► PageEvent ► PageEvent()()()
Initializes a new instance of the PageEvent class
Declaration Syntax
C#
public PageEvent()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Data Property

Data Property
Namespaces ► Sitecore.Analytics ► PageEvent ► Data
Declaration Syntax
C#
public string Data { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


DataKey Property

DataKey Property
Namespaces ► Sitecore.Analytics ► PageEvent ► DataKey
Declaration Syntax
C#
public string DataKey { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Integer Property

Integer Property
Namespaces ► Sitecore.Analytics ► PageEvent ► Integer
Declaration Syntax
C#
public int Integer { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ItemId Property

ItemId Property
Namespaces ► Sitecore.Analytics ► PageEvent ► ItemId
Declaration Syntax
C#
public Guid ItemId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ItemLanguage Property

ItemLanguage Property
Namespaces ► Sitecore.Analytics ► PageEvent ► ItemLanguage
Declaration Syntax
C#
public string ItemLanguage { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ItemVersion Property

ItemVersion Property
Namespaces ► Sitecore.Analytics ► PageEvent ► ItemVersion
Declaration Syntax
C#
public int ItemVersion { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► PageEvent ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Page Property

Page Property
Namespaces ► Sitecore.Analytics ► PageEvent ► Page
Declaration Syntax
C#
public Page Page { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageEventDefinition Property

PageEventDefinition Property
Namespaces ► Sitecore.Analytics ► PageEvent ► PageEventDefinition
Declaration Syntax
C#
public PageEventDefinition PageEventDefinition { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageEventDefinitionId Property

PageEventDefinitionId Property
Namespaces ► Sitecore.Analytics ► PageEvent ► PageEventDefinitionId
Declaration Syntax
C#
public Guid PageEventDefinitionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageEventId Property

PageEventId Property
Namespaces ► Sitecore.Analytics ► PageEvent ► PageEventId
Declaration Syntax
C#
public Guid PageEventId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageId Property

PageId Property
Namespaces ► Sitecore.Analytics ► PageEvent ► PageId
Declaration Syntax
C#
public Guid PageId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► PageEvent ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► PageEvent ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► PageEvent ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► PageEvent ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Text Property

Text Property
Namespaces ► Sitecore.Analytics ► PageEvent ► Text
Declaration Syntax
C#
public string Text { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Timestamp Property

Timestamp Property
Namespaces ► Sitecore.Analytics ► PageEvent ► Timestamp
Declaration Syntax
C#
public long Timestamp { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageEventDefinition Class

PageEventDefinition Class
Namespaces ► Sitecore.Analytics ► PageEventDefinition
Declaration Syntax
C#
public class PageEventDefinition : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PageEventDefinition()()() | Initializes a new instance of the PageEventDefinition class
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon |
 | IsAuthorFeedback |
 | IsFailure |
 | IsGoal |
 | IsSystem |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | PageEventDefinitionId |
 | PageEvents |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PageEventDefinition

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageEventDefinition Constructor

PageEventDefinition Constructor
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► PageEventDefinition()()()
Initializes a new instance of the PageEventDefinition class
Declaration Syntax
C#
public PageEventDefinition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Description Property

Description Property
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► Description
Declaration Syntax
C#
public string Description { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Icon Property

Icon Property
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► Icon
Declaration Syntax
C#
public string Icon { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsAuthorFeedback Property

IsAuthorFeedback Property
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► IsAuthorFeedback
Declaration Syntax
C#
public int IsAuthorFeedback { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsFailure Property

IsFailure Property
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► IsFailure
Declaration Syntax
C#
public int IsFailure { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsGoal Property

IsGoal Property
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► IsGoal
Declaration Syntax
C#
public int IsGoal { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsSystem Property

IsSystem Property
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► IsSystem
Declaration Syntax
C#
public int IsSystem { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Name Property

Name Property
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► Name
Declaration Syntax
C#
public string Name { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageEventDefinitionId Property

PageEventDefinitionId Property
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► PageEventDefinitionId
Declaration Syntax
C#
public Guid PageEventDefinitionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageEvents Property

PageEvents Property
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► PageEvents
Declaration Syntax
C#
public EntitySet<PageEvent> PageEvents { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► PageEventDefinition ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Profile Class

Profile Class
Namespaces ► Sitecore.Analytics ► Profile
Declaration Syntax
C#
public class Profile : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Profile()()() | Initializes a new instance of the Profile class
 | Count |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | ProfileDefinition |
 | ProfileDefinitionId |
 | ProfileId |
 | ProfileKeys |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | Session |
 | SessionId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Total |
Inheritance Hierarchy
Object
Profile

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Profile Constructor

Profile Constructor
Namespaces ► Sitecore.Analytics ► Profile ► Profile()()()
Initializes a new instance of the Profile class
Declaration Syntax
C#
public Profile()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Count Property

Count Property
Namespaces ► Sitecore.Analytics ► Profile ► Count
Declaration Syntax
C#
public int Count { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► Profile ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► Profile ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► Profile ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileDefinition Property

ProfileDefinition Property
Namespaces ► Sitecore.Analytics ► Profile ► ProfileDefinition
Declaration Syntax
C#
public ProfileDefinition ProfileDefinition { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileDefinitionId Property

ProfileDefinitionId Property
Namespaces ► Sitecore.Analytics ► Profile ► ProfileDefinitionId
Declaration Syntax
C#
public Guid ProfileDefinitionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileId Property

ProfileId Property
Namespaces ► Sitecore.Analytics ► Profile ► ProfileId
Declaration Syntax
C#
public Guid ProfileId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeys Property

ProfileKeys Property
Namespaces ► Sitecore.Analytics ► Profile ► ProfileKeys
Declaration Syntax
C#
public EntitySet<ProfileKey> ProfileKeys { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► Profile ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► Profile ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► Profile ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► Profile ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Session Property

Session Property
Namespaces ► Sitecore.Analytics ► Profile ► Session
Declaration Syntax
C#
public Session Session { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SessionId Property

SessionId Property
Namespaces ► Sitecore.Analytics ► Profile ► SessionId
Declaration Syntax
C#
public Guid SessionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Total Property

Total Property
Namespaces ► Sitecore.Analytics ► Profile ► Total
Declaration Syntax
C#
public int Total { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileDefinition Class

ProfileDefinition Class
Namespaces ► Sitecore.Analytics ► ProfileDefinition
Declaration Syntax
C#
public class ProfileDefinition : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProfileDefinition()()() | Initializes a new instance of the ProfileDefinition class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | ProfileDefinitionId |
 | ProfileKeyDefinitions |
 | Profiles |
 | ProfileType |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProfileDefinition

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileDefinition Constructor

ProfileDefinition Constructor
Namespaces ► Sitecore.Analytics ► ProfileDefinition ► ProfileDefinition()()()
Initializes a new instance of the ProfileDefinition class
Declaration Syntax
C#
public ProfileDefinition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Name Property

Name Property
Namespaces ► Sitecore.Analytics ► ProfileDefinition ► Name
Declaration Syntax
C#
public string Name { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► ProfileDefinition ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► ProfileDefinition ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► ProfileDefinition ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileDefinitionId Property

ProfileDefinitionId Property
Namespaces ► Sitecore.Analytics ► ProfileDefinition ► ProfileDefinitionId
Declaration Syntax
C#
public Guid ProfileDefinitionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyDefinitions Property

ProfileKeyDefinitions Property
Namespaces ► Sitecore.Analytics ► ProfileDefinition ► ProfileKeyDefinitions
Declaration Syntax
C#
public EntitySet<ProfileKeyDefinition> ProfileKeyDefinitions { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Profiles Property

Profiles Property
Namespaces ► Sitecore.Analytics ► ProfileDefinition ► Profiles
Declaration Syntax
C#
public EntitySet<Profile> Profiles { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileType Property

ProfileType Property
Namespaces ► Sitecore.Analytics ► ProfileDefinition ► ProfileType
Declaration Syntax
C#
public string ProfileType { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► ProfileDefinition ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► ProfileDefinition ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► ProfileDefinition ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► ProfileDefinition ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKey Class

ProfileKey Class
Namespaces ► Sitecore.Analytics ► ProfileKey
Declaration Syntax
C#
public class ProfileKey : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProfileKey()()() | Initializes a new instance of the ProfileKey class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializing(StreamingContext) |
 | Profile |
 | ProfileId |
 | ProfileKeyDefinition |
 | ProfileKeyDefinitionId |
 | ProfileKeyId |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
ProfileKey

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKey Constructor

ProfileKey Constructor
Namespaces ► Sitecore.Analytics ► ProfileKey ► ProfileKey()()()
Initializes a new instance of the ProfileKey class
Declaration Syntax
C#
public ProfileKey()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► ProfileKey ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Profile Property

Profile Property
Namespaces ► Sitecore.Analytics ► ProfileKey ► Profile
Declaration Syntax
C#
public Profile Profile { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileId Property

ProfileId Property
Namespaces ► Sitecore.Analytics ► ProfileKey ► ProfileId
Declaration Syntax
C#
public Guid ProfileId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyDefinition Property

ProfileKeyDefinition Property
Namespaces ► Sitecore.Analytics ► ProfileKey ► ProfileKeyDefinition
Declaration Syntax
C#
public ProfileKeyDefinition ProfileKeyDefinition { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyDefinitionId Property

ProfileKeyDefinitionId Property
Namespaces ► Sitecore.Analytics ► ProfileKey ► ProfileKeyDefinitionId
Declaration Syntax
C#
public Guid ProfileKeyDefinitionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyId Property

ProfileKeyId Property
Namespaces ► Sitecore.Analytics ► ProfileKey ► ProfileKeyId
Declaration Syntax
C#
public Guid ProfileKeyId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► ProfileKey ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► ProfileKey ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► ProfileKey ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► ProfileKey ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Value Property

Value Property
Namespaces ► Sitecore.Analytics ► ProfileKey ► Value
Declaration Syntax
C#
public int Value { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyDefinition Class

ProfileKeyDefinition Class
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition
Declaration Syntax
C#
public class ProfileKeyDefinition : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProfileKeyDefinition()()() | Initializes a new instance of the ProfileKeyDefinition class
 | Control |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MaxValue |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinValue |
 | Name |
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | ProfileDefinition |
 | ProfileDefinitionId |
 | ProfileKeyDefinitionId |
 | ProfileKeys |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProfileKeyDefinition

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyDefinition Constructor

ProfileKeyDefinition Constructor
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► ProfileKeyDefinition()()()
Initializes a new instance of the ProfileKeyDefinition class
Declaration Syntax
C#
public ProfileKeyDefinition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Control Property

Control Property
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► Control
Declaration Syntax
C#
public string Control { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MaxValue Property

MaxValue Property
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► MaxValue
Declaration Syntax
C#
public int MaxValue { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MinValue Property

MinValue Property
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► MinValue
Declaration Syntax
C#
public int MinValue { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Name Property

Name Property
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► Name
Declaration Syntax
C#
public string Name { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileDefinition Property

ProfileDefinition Property
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► ProfileDefinition
Declaration Syntax
C#
public ProfileDefinition ProfileDefinition { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileDefinitionId Property

ProfileDefinitionId Property
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► ProfileDefinitionId
Declaration Syntax
C#
public Guid ProfileDefinitionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyDefinitionId Property

ProfileKeyDefinitionId Property
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► ProfileKeyDefinitionId
Declaration Syntax
C#
public Guid ProfileKeyDefinitionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeys Property

ProfileKeys Property
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► ProfileKeys
Declaration Syntax
C#
public EntitySet<ProfileKey> ProfileKeys { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► ProfileKeyDefinition ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReferringSite Class

ReferringSite Class
Namespaces ► Sitecore.Analytics ► ReferringSite
Declaration Syntax
C#
public class ReferringSite : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReferringSite()()() | Initializes a new instance of the ReferringSite class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | PropertyChanged |
 | PropertyChanging |
 | ReferringSiteId |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | Sessions |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | URL |
Inheritance Hierarchy
Object
ReferringSite

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReferringSite Constructor

ReferringSite Constructor
Namespaces ► Sitecore.Analytics ► ReferringSite ► ReferringSite()()()
Initializes a new instance of the ReferringSite class
Declaration Syntax
C#
public ReferringSite()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► ReferringSite ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► ReferringSite ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► ReferringSite ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► ReferringSite ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► ReferringSite ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReferringSiteId Property

ReferringSiteId Property
Namespaces ► Sitecore.Analytics ► ReferringSite ► ReferringSiteId
Declaration Syntax
C#
public Guid ReferringSiteId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► ReferringSite ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► ReferringSite ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sessions Property

Sessions Property
Namespaces ► Sitecore.Analytics ► ReferringSite ► Sessions
Declaration Syntax
C#
public EntitySet<Session> Sessions { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


URL Property

URL Property
Namespaces ► Sitecore.Analytics ► ReferringSite ► URL
Declaration Syntax
C#
public string URL { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Screen Class

Screen Class
Namespaces ► Sitecore.Analytics ► Screen
Declaration Syntax
C#
public class Screen : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Screen()()() | Initializes a new instance of the Screen class
 | Description |
 | Dimensions |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | PropertyChanged |
 | PropertyChanging |
 | ScreenId |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | Sessions |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Screen

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Screen Constructor

Screen Constructor
Namespaces ► Sitecore.Analytics ► Screen ► Screen()()()
Initializes a new instance of the Screen class
Declaration Syntax
C#
public Screen()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Description Property

Description Property
Namespaces ► Sitecore.Analytics ► Screen ► Description
Declaration Syntax
C#
public string Description { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Dimensions Property

Dimensions Property
Namespaces ► Sitecore.Analytics ► Screen ► Dimensions
Declaration Syntax
C#
public string Dimensions { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► Screen ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► Screen ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► Screen ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► Screen ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► Screen ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ScreenId Property

ScreenId Property
Namespaces ► Sitecore.Analytics ► Screen ► ScreenId
Declaration Syntax
C#
public Guid ScreenId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► Screen ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► Screen ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sessions Property

Sessions Property
Namespaces ► Sitecore.Analytics ► Screen ► Sessions
Declaration Syntax
C#
public EntitySet<Session> Sessions { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Session Class

Session Class
Namespaces ► Sitecore.Analytics ► Session
Declaration Syntax
C#
public class Session : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Session()()() | Initializes a new instance of the Session class
 | AspNetSessionId |
 | Browser |
 | BrowserId |
 | CurrentPage |
 | Domain |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalSession |
 | GlobalSessionId |
 | GlobalVisitNo |
 | IP |
 | IpAddress |
 | IpId |
 | Keyword |
 | KeywordId |
 | LanguageId |
 | LastPageTimestamp |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultiSite |
 | OnDeserializing(StreamingContext) |
 | OnSerialized(StreamingContext) |
 | OnSerializing(StreamingContext) |
 | OperatingSystem |
 | OperatingSystemId |
 | Pages |
 | Profiles |
 | PropertyChanged |
 | PropertyChanging |
 | ReferringSite |
 | ReferringSiteId |
 | Screen |
 | ScreenId |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | SessionId |
 | Timestamp |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Session

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Session Constructor

Session Constructor
Namespaces ► Sitecore.Analytics ► Session ► Session()()()
Initializes a new instance of the Session class
Declaration Syntax
C#
public Session()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AspNetSessionId Property

AspNetSessionId Property
Namespaces ► Sitecore.Analytics ► Session ► AspNetSessionId
Declaration Syntax
C#
public string AspNetSessionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Browser Property

Browser Property
Namespaces ► Sitecore.Analytics ► Session ► Browser
Declaration Syntax
C#
public Browser Browser { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


BrowserId Property

BrowserId Property
Namespaces ► Sitecore.Analytics ► Session ► BrowserId
Declaration Syntax
C#
public Guid BrowserId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CurrentPage Property

CurrentPage Property
Namespaces ► Sitecore.Analytics ► Session ► CurrentPage
Declaration Syntax
C#
public int CurrentPage { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Domain Property

Domain Property
Namespaces ► Sitecore.Analytics ► Session ► Domain
Declaration Syntax
C#
public string Domain { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GlobalSession Property

GlobalSession Property
Namespaces ► Sitecore.Analytics ► Session ► GlobalSession
Declaration Syntax
C#
public GlobalSession GlobalSession { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GlobalSessionId Property

GlobalSessionId Property
Namespaces ► Sitecore.Analytics ► Session ► GlobalSessionId
Declaration Syntax
C#
public Guid GlobalSessionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GlobalVisitNo Property

GlobalVisitNo Property
Namespaces ► Sitecore.Analytics ► Session ► GlobalVisitNo
Declaration Syntax
C#
public int GlobalVisitNo { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IP Property

IP Property
Namespaces ► Sitecore.Analytics ► Session ► IP
Declaration Syntax
C#
public IP IP { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpAddress Property

IpAddress Property
Namespaces ► Sitecore.Analytics ► Session ► IpAddress
Declaration Syntax
C#
public string IpAddress { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpId Property

IpId Property
Namespaces ► Sitecore.Analytics ► Session ► IpId
Declaration Syntax
C#
public Guid IpId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Keyword Property

Keyword Property
Namespaces ► Sitecore.Analytics ► Session ► Keyword
Declaration Syntax
C#
public Keyword Keyword { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


KeywordId Property

KeywordId Property
Namespaces ► Sitecore.Analytics ► Session ► KeywordId
Declaration Syntax
C#
public Guid KeywordId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LanguageId Property

LanguageId Property
Namespaces ► Sitecore.Analytics ► Session ► LanguageId
Declaration Syntax
C#
public Guid LanguageId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LastPageTimestamp Property

LastPageTimestamp Property
Namespaces ► Sitecore.Analytics ► Session ► LastPageTimestamp
Declaration Syntax
C#
public DateTime LastPageTimestamp { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiSite Property

MultiSite Property
Namespaces ► Sitecore.Analytics ► Session ► MultiSite
Declaration Syntax
C#
public string MultiSite { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► Session ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerialized Method (context)

OnSerialized Method (context)
Namespaces ► Sitecore.Analytics ► Session ► OnSerialized(StreamingContext)
Declaration Syntax
C#
public void OnSerialized(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnSerializing Method (context)

OnSerializing Method (context)
Namespaces ► Sitecore.Analytics ► Session ► OnSerializing(StreamingContext)
Declaration Syntax
C#
public void OnSerializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatingSystem Property

OperatingSystem Property
Namespaces ► Sitecore.Analytics ► Session ► OperatingSystem
Declaration Syntax
C#
public OperatingSystem OperatingSystem { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatingSystemId Property

OperatingSystemId Property
Namespaces ► Sitecore.Analytics ► Session ► OperatingSystemId
Declaration Syntax
C#
public Guid OperatingSystemId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Pages Property

Pages Property
Namespaces ► Sitecore.Analytics ► Session ► Pages
Declaration Syntax
C#
public EntitySet<Page> Pages { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Profiles Property

Profiles Property
Namespaces ► Sitecore.Analytics ► Session ► Profiles
Declaration Syntax
C#
public EntitySet<Profile> Profiles { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► Session ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► Session ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReferringSite Property

ReferringSite Property
Namespaces ► Sitecore.Analytics ► Session ► ReferringSite
Declaration Syntax
C#
public ReferringSite ReferringSite { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReferringSiteId Property

ReferringSiteId Property
Namespaces ► Sitecore.Analytics ► Session ► ReferringSiteId
Declaration Syntax
C#
public Guid ReferringSiteId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Screen Property

Screen Property
Namespaces ► Sitecore.Analytics ► Session ► Screen
Declaration Syntax
C#
public Screen Screen { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ScreenId Property

ScreenId Property
Namespaces ► Sitecore.Analytics ► Session ► ScreenId
Declaration Syntax
C#
public Guid ScreenId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► Session ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► Session ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SessionId Property

SessionId Property
Namespaces ► Sitecore.Analytics ► Session ► SessionId
Declaration Syntax
C#
public Guid SessionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Timestamp Property

Timestamp Property
Namespaces ► Sitecore.Analytics ► Session ► Timestamp
Declaration Syntax
C#
public DateTime Timestamp { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SitecoreAnalyticsDataContext Class

SitecoreAnalyticsDataContext Class
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext
Declaration Syntax
C#
public class SitecoreAnalyticsDataContext : DataContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SitecoreAnalyticsDataContext()()() | Initializes a new instance of the SitecoreAnalyticsDataContext class
 | SitecoreAnalyticsDataContext(String) | Initializes a new instance of the SitecoreAnalyticsDataContext class
 | SitecoreAnalyticsDataContext(IDbConnection) | Initializes a new instance of the SitecoreAnalyticsDataContext class
 | SitecoreAnalyticsDataContext(String, MappingSource) | Initializes a new instance of the SitecoreAnalyticsDataContext class
 | SitecoreAnalyticsDataContext(IDbConnection, MappingSource) | Initializes a new instance of the SitecoreAnalyticsDataContext class
 | Browsers |
 | CampaignEventPages |
 | CampaignEvents |
 | Campaigns |
 | ChangeConflicts | Returns a collection of objects that caused concurrency conflicts when SubmitChanges()()() was called. (Inherited from DataContext.)
 | CommandTimeout | Increases the time-out period for queries that would otherwise time out during the default time-out period. (Inherited from DataContext.)
 | Connection | Returns the connection used by the framework. (Inherited from DataContext.)
 | CreateDatabase()()() | Creates a database on the server. (Inherited from DataContext.)
 | CreateMethodCallQuery<(Of <(TResult>)>)(Object, MethodInfo, array<Object>[]()[]) | Executes the table-valued database function associated with the specified CLR method. (Inherited from DataContext.)
 | DatabaseExists()()() | Determines whether the associated database can be opened. (Inherited from DataContext.)
 | DeferredLoadingEnabled | Specifies whether to delay-load one-to-many or one-to-one relationships. (Inherited from DataContext.)
 | DeleteDatabase()()() | Deletes the associated database. (Inherited from DataContext.)
 | Dispose()()() | Releases all resources used by the DataContext. (Inherited from DataContext.)
 | Dispose(Boolean) | Releases resources used by the DataContext. (Inherited from DataContext.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteCommand(String, array<Object>[]()[]) | Executes SQL commands directly on the database. (Inherited from DataContext.)
 | ExecuteDynamicDelete(Object) | Called inside delete override methods to redelegate to LINQ to SQL the task of generating and executing dynamic SQL for delete operations. (Inherited from DataContext.)
 | ExecuteDynamicInsert(Object) | Called inside insert override methods to redelegate to LINQ to SQL the task of generating and executing dynamic SQL for insert operations. (Inherited from DataContext.)
 | ExecuteDynamicUpdate(Object) | Called inside update override methods to redelegate to LINQ to SQL the task of generating and executing dynamic SQL for update operations. (Inherited from DataContext.)
 | ExecuteMethodCall(Object, MethodInfo, array<Object>[]()[]) | Executes the stored database procedure or scalar function associated with the specified CLR method. (Inherited from DataContext.)
 | ExecuteQuery<(Of <(TResult>)>)(String, array<Object>[]()[]) | Executes SQL queries directly on the database and returns objects. (Inherited from DataContext.)
 | ExecuteQuery(Type, String, array<Object>[]()[]) | Executes SQL queries directly on the database. (Inherited from DataContext.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChangeSet()()() | Provides access to the modified objects tracked by DataContext. (Inherited from DataContext.)
 | GetCommand(IQueryable) | Provides information about SQL commands generated by LINQ to SQL. (Inherited from DataContext.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTable<(Of <(TEntity>)>)()()() | Returns a collection of objects of a particular type, where the type is defined by the TEntity parameter. (Inherited from DataContext.)
 | GetTable(Type) | Returns a collection of objects of a particular type, where the type is defined by the type parameter. (Inherited from DataContext.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalSessions |
 | IPOwners |
 | IPs |
 | Keywords |
 | LoadOptions | Gets or sets the DataLoadOptions associated with this DataContext. (Inherited from DataContext.)
 | Log | Specifies the destination to write the SQL query or command. (Inherited from DataContext.)
 | Mapping | Returns the MetaModel on which the mapping is based. (Inherited from DataContext.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultiVarianceTestDefinitions |
 | MultiVarianceTestVariableCampaignEvents |
 | MultiVarianceTestVariablePages |
 | MultiVarianceTestVariables |
 | ObjectTrackingEnabled | Instructs the framework to track the original value and object identity for this DataContext. (Inherited from DataContext.)
 | OperatingSystems |
 | PageEventDefinitions |
 | PageEvents |
 | Pages |
 | ProfileDefinitions |
 | ProfileKeyDefinitions |
 | ProfileKeys |
 | Profiles |
 | ReferringSites |
 | Refresh(RefreshMode, Object) | Refreshes an entity object according to the specified mode. (Inherited from DataContext.)
 | Refresh(RefreshMode, array<Object>[]()[]) | Refreshes an array of entity objects according to the specified mode. (Inherited from DataContext.)
 | Refresh(RefreshMode, IEnumerable) | Refreshes a collection of entity objects according to the specified mode. (Inherited from DataContext.)
 | Screens |
 | Sessions |
 | Status |
 | SubmitChanges()()() | Computes the set of modified objects to be inserted, updated, or deleted, and executes the appropriate commands to implement the changes to the database. (Inherited from DataContext.)
 | SubmitChanges(ConflictMode) | Sends changes that were made to retrieved objects to the underlying database, and specifies the action to be taken if the submission fails. (Inherited from DataContext.)
 | Subscriptions |
 | Tags |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transaction | Sets a local transaction for the .NET Framework to use to access the database. (Inherited from DataContext.)
 | Translate<(Of <(TResult>)>)(DbDataReader) | Converts an existing DbDataReader to objects. (Inherited from DataContext.)
 | Translate(Type, DbDataReader) | Converts an existing DbDataReader to objects. (Inherited from DataContext.)
 | VisitorIdentifications |
Inheritance Hierarchy
Object
 | DataContext
 |  | SitecoreAnalyticsDataContext
 |  |  | AnalyticsDataContext

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SitecoreAnalyticsDataContext Constructor

SitecoreAnalyticsDataContext Constructor
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► SitecoreAnalyticsDataContext()()()
Members
Icon | Member | Description
 | SitecoreAnalyticsDataContext()()() | Initializes a new instance of the SitecoreAnalyticsDataContext class
 | SitecoreAnalyticsDataContext(String) | Initializes a new instance of the SitecoreAnalyticsDataContext class
 | SitecoreAnalyticsDataContext(IDbConnection) | Initializes a new instance of the SitecoreAnalyticsDataContext class
 | SitecoreAnalyticsDataContext(String, MappingSource) | Initializes a new instance of the SitecoreAnalyticsDataContext class
 | SitecoreAnalyticsDataContext(IDbConnection, MappingSource) | Initializes a new instance of the SitecoreAnalyticsDataContext class

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SitecoreAnalyticsDataContext Constructor

SitecoreAnalyticsDataContext Constructor
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► SitecoreAnalyticsDataContext()()()
Initializes a new instance of the SitecoreAnalyticsDataContext class
Declaration Syntax
C#
public SitecoreAnalyticsDataContext()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SitecoreAnalyticsDataContext Constructor (connection)

SitecoreAnalyticsDataContext Constructor (connection)
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► SitecoreAnalyticsDataContext(IDbConnection)
Initializes a new instance of the SitecoreAnalyticsDataContext class
Declaration Syntax
C#
public SitecoreAnalyticsDataContext(
    IDbConnection connection
)
Parameters
connection (IDbConnection)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SitecoreAnalyticsDataContext Constructor (connection, mappingSource)

SitecoreAnalyticsDataContext Constructor (connection, mappingSource)
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► SitecoreAnalyticsDataContext(IDbConnection, MappingSource)
Initializes a new instance of the SitecoreAnalyticsDataContext class
Declaration Syntax
C#
public SitecoreAnalyticsDataContext(
    IDbConnection connection,
    MappingSource mappingSource
)
Parameters
connection (IDbConnection)
mappingSource (MappingSource)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SitecoreAnalyticsDataContext Constructor (connection)

SitecoreAnalyticsDataContext Constructor (connection)
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► SitecoreAnalyticsDataContext(String)
Initializes a new instance of the SitecoreAnalyticsDataContext class
Declaration Syntax
C#
public SitecoreAnalyticsDataContext(
    string connection
)
Parameters
connection (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SitecoreAnalyticsDataContext Constructor (connection, mappingSource)

SitecoreAnalyticsDataContext Constructor (connection, mappingSource)
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► SitecoreAnalyticsDataContext(String, MappingSource)
Initializes a new instance of the SitecoreAnalyticsDataContext class
Declaration Syntax
C#
public SitecoreAnalyticsDataContext(
    string connection,
    MappingSource mappingSource
)
Parameters
connection (String)
mappingSource (MappingSource)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Browsers Property

Browsers Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► Browsers
Declaration Syntax
C#
public Table<Browser> Browsers { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEventPages Property

CampaignEventPages Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► CampaignEventPages
Declaration Syntax
C#
public Table<CampaignEventPage> CampaignEventPages { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEvents Property

CampaignEvents Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► CampaignEvents
Declaration Syntax
C#
public Table<CampaignEvent> CampaignEvents { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Campaigns Property

Campaigns Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► Campaigns
Declaration Syntax
C#
public Table<Campaign> Campaigns { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GlobalSessions Property

GlobalSessions Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► GlobalSessions
Declaration Syntax
C#
public Table<GlobalSession> GlobalSessions { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IPOwners Property

IPOwners Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► IPOwners
Declaration Syntax
C#
public Table<IPOwner> IPOwners { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IPs Property

IPs Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► IPs
Declaration Syntax
C#
public Table<IP> IPs { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Keywords Property

Keywords Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► Keywords
Declaration Syntax
C#
public Table<Keyword> Keywords { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestDefinitions Property

MultiVarianceTestDefinitions Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► MultiVarianceTestDefinitions
Declaration Syntax
C#
public Table<MultiVarianceTestDefinition> MultiVarianceTestDefinitions { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariableCampaignEvents Property

MultiVarianceTestVariableCampaignEvents Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► MultiVarianceTestVariableCampaignEvents
Declaration Syntax
C#
public Table<MultiVarianceTestVariableCampaignEvent> MultiVarianceTestVariableCampaignEvents { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariablePages Property

MultiVarianceTestVariablePages Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► MultiVarianceTestVariablePages
Declaration Syntax
C#
public Table<MultiVarianceTestVariablePage> MultiVarianceTestVariablePages { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MultiVarianceTestVariables Property

MultiVarianceTestVariables Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► MultiVarianceTestVariables
Declaration Syntax
C#
public Table<MultiVarianceTestVariable> MultiVarianceTestVariables { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatingSystems Property

OperatingSystems Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► OperatingSystems
Declaration Syntax
C#
public Table<OperatingSystem> OperatingSystems { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageEventDefinitions Property

PageEventDefinitions Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► PageEventDefinitions
Declaration Syntax
C#
public Table<PageEventDefinition> PageEventDefinitions { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageEvents Property

PageEvents Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► PageEvents
Declaration Syntax
C#
public Table<PageEvent> PageEvents { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Pages Property

Pages Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► Pages
Declaration Syntax
C#
public Table<Page> Pages { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileDefinitions Property

ProfileDefinitions Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► ProfileDefinitions
Declaration Syntax
C#
public Table<ProfileDefinition> ProfileDefinitions { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyDefinitions Property

ProfileKeyDefinitions Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► ProfileKeyDefinitions
Declaration Syntax
C#
public Table<ProfileKeyDefinition> ProfileKeyDefinitions { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeys Property

ProfileKeys Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► ProfileKeys
Declaration Syntax
C#
public Table<ProfileKey> ProfileKeys { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Profiles Property

Profiles Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► Profiles
Declaration Syntax
C#
public Table<Profile> Profiles { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReferringSites Property

ReferringSites Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► ReferringSites
Declaration Syntax
C#
public Table<ReferringSite> ReferringSites { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Screens Property

Screens Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► Screens
Declaration Syntax
C#
public Table<Screen> Screens { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sessions Property

Sessions Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► Sessions
Declaration Syntax
C#
public Table<Session> Sessions { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Status Property

Status Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► Status
Declaration Syntax
C#
public Table<Status> Status { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Subscriptions Property

Subscriptions Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► Subscriptions
Declaration Syntax
C#
public Table<Subscription> Subscriptions { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Tags Property

Tags Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► Tags
Declaration Syntax
C#
public Table<Tag> Tags { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


VisitorIdentifications Property

VisitorIdentifications Property
Namespaces ► Sitecore.Analytics ► SitecoreAnalyticsDataContext ► VisitorIdentifications
Declaration Syntax
C#
public Table<VisitorIdentification> VisitorIdentifications { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Status Class

Status Class
Namespaces ► Sitecore.Analytics ► Status
Declaration Syntax
C#
public class Status : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Status()()() | Initializes a new instance of the Status class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | LastFailed |
 | LastSuccessful |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | OnDeserializing(StreamingContext) |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Status

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Status Constructor

Status Constructor
Namespaces ► Sitecore.Analytics ► Status ► Status()()()
Initializes a new instance of the Status class
Declaration Syntax
C#
public Status()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Id Property

Id Property
Namespaces ► Sitecore.Analytics ► Status ► Id
Declaration Syntax
C#
public Guid Id { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LastFailed Property

LastFailed Property
Namespaces ► Sitecore.Analytics ► Status ► LastFailed
Declaration Syntax
C#
public Nullable<DateTime> LastFailed { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LastSuccessful Property

LastSuccessful Property
Namespaces ► Sitecore.Analytics ► Status ► LastSuccessful
Declaration Syntax
C#
public Nullable<DateTime> LastSuccessful { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Name Property

Name Property
Namespaces ► Sitecore.Analytics ► Status ► Name
Declaration Syntax
C#
public string Name { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► Status ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► Status ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► Status ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► Status ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► Status ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Subscription Class

Subscription Class
Namespaces ► Sitecore.Analytics ► Subscription
Declaration Syntax
C#
public class Subscription : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Subscription()()() | Initializes a new instance of the Subscription class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IPOwner |
 | IpOwnerId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializing(StreamingContext) |
 | PropertyChanged |
 | PropertyChanging |
 | Recipients |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | SubscriptionId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Subscription

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Subscription Constructor

Subscription Constructor
Namespaces ► Sitecore.Analytics ► Subscription ► Subscription()()()
Initializes a new instance of the Subscription class
Declaration Syntax
C#
public Subscription()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IPOwner Property

IPOwner Property
Namespaces ► Sitecore.Analytics ► Subscription ► IPOwner
Declaration Syntax
C#
public IPOwner IPOwner { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpOwnerId Property

IpOwnerId Property
Namespaces ► Sitecore.Analytics ► Subscription ► IpOwnerId
Declaration Syntax
C#
public Guid IpOwnerId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► Subscription ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► Subscription ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► Subscription ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Recipients Property

Recipients Property
Namespaces ► Sitecore.Analytics ► Subscription ► Recipients
Declaration Syntax
C#
public string Recipients { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► Subscription ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► Subscription ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubscriptionId Property

SubscriptionId Property
Namespaces ► Sitecore.Analytics ► Subscription ► SubscriptionId
Declaration Syntax
C#
public Guid SubscriptionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Tag Class

Tag Class
Namespaces ► Sitecore.Analytics ► Tag
Declaration Syntax
C#
public class Tag : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Tag()()() | Initializes a new instance of the Tag class
 | Acquaintance |
 | Data |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalSession |
 | GlobalSessionId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializing(StreamingContext) |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | TagId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Tag

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Tag Constructor

Tag Constructor
Namespaces ► Sitecore.Analytics ► Tag ► Tag()()()
Initializes a new instance of the Tag class
Declaration Syntax
C#
public Tag()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Acquaintance Property

Acquaintance Property
Namespaces ► Sitecore.Analytics ► Tag ► Acquaintance
Declaration Syntax
C#
public Guid Acquaintance { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Data Property

Data Property
Namespaces ► Sitecore.Analytics ► Tag ► Data
Declaration Syntax
C#
public string Data { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GlobalSession Property

GlobalSession Property
Namespaces ► Sitecore.Analytics ► Tag ► GlobalSession
Declaration Syntax
C#
public GlobalSession GlobalSession { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GlobalSessionId Property

GlobalSessionId Property
Namespaces ► Sitecore.Analytics ► Tag ► GlobalSessionId
Declaration Syntax
C#
public Guid GlobalSessionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► Tag ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► Tag ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► Tag ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► Tag ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► Tag ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TagId Property

TagId Property
Namespaces ► Sitecore.Analytics ► Tag ► TagId
Declaration Syntax
C#
public Guid TagId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TransactionHandle Class

TransactionHandle Class
Namespaces ► Sitecore.Analytics ► TransactionHandle
Defines the transaction handle class.
Declaration Syntax
C#
public class TransactionHandle
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TransactionHandle()()() | Initializes a new instance of the TransactionHandle class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TransactionHandle

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TransactionHandle Constructor

TransactionHandle Constructor
Namespaces ► Sitecore.Analytics ► TransactionHandle ► TransactionHandle()()()
Initializes a new instance of the TransactionHandle class
Declaration Syntax
C#
public TransactionHandle()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


VisitorIdentification Class

VisitorIdentification Class
Namespaces ► Sitecore.Analytics ► VisitorIdentification
Declaration Syntax
C#
public class VisitorIdentification : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VisitorIdentification()()() | Initializes a new instance of the VisitorIdentification class
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserializing(StreamingContext) |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VisitorIdentification1 |
Inheritance Hierarchy
Object
VisitorIdentification

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


VisitorIdentification Constructor

VisitorIdentification Constructor
Namespaces ► Sitecore.Analytics ► VisitorIdentification ► VisitorIdentification()()()
Initializes a new instance of the VisitorIdentification class
Declaration Syntax
C#
public VisitorIdentification()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Description Property

Description Property
Namespaces ► Sitecore.Analytics ► VisitorIdentification ► Description
Declaration Syntax
C#
public string Description { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnDeserializing Method (context)

OnDeserializing Method (context)
Namespaces ► Sitecore.Analytics ► VisitorIdentification ► OnDeserializing(StreamingContext)
Declaration Syntax
C#
public void OnDeserializing(
    StreamingContext context
)
Parameters
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Analytics ► VisitorIdentification ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Analytics ► VisitorIdentification ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Analytics ► VisitorIdentification ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Analytics ► VisitorIdentification ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


VisitorIdentification1 Property

VisitorIdentification1 Property
Namespaces ► Sitecore.Analytics ► VisitorIdentification ► VisitorIdentification1
Declaration Syntax
C#
public int VisitorIdentification1 { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Configuration Namespace

Sitecore.Analytics.Configuration Namespace
Namespaces ► Sitecore.Analytics.Configuration
Declaration Syntax
C#
namespace Sitecore.Analytics.Configuration
Types
All Types Classes
Icon | Type | Description
 | AnalyticsSettings |
 | AnalyticsSettings..::.PerformLookup |


AnalyticsSettings Class

AnalyticsSettings Class
Namespaces ► Sitecore.Analytics.Configuration ► AnalyticsSettings
Declaration Syntax
C#
public static class AnalyticsSettings
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Enabled |
Inheritance Hierarchy
Object
AnalyticsSettings

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Enabled Property

Enabled Property
Namespaces ► Sitecore.Analytics.Configuration ► AnalyticsSettings ► Enabled
Declaration Syntax
C#
public static bool Enabled { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsSettings.PerformLookup Class

AnalyticsSettings..::.PerformLookup Class
Namespaces ► Sitecore.Analytics.Configuration ► AnalyticsSettings ► AnalyticsSettings..::.PerformLookup
Declaration Syntax
C#
public static class PerformLookup
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Interval |
Inheritance Hierarchy
Object
AnalyticsSettings..::.PerformLookup

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Interval Property

Interval Property
Namespaces ► Sitecore.Analytics.Configuration ► AnalyticsSettings..::.PerformLookup ► Interval
Declaration Syntax
C#
public static int Interval { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Data Namespace

Sitecore.Analytics.Data Namespace
Namespaces ► Sitecore.Analytics.Data
Declaration Syntax
C#
namespace Sitecore.Analytics.Data
Types
All Types Classes Interfaces
Icon | Type | Description
 | AnalyticsCachedData |
 | AnalyticsDataContext |
 | AnalyticsTrackerSubmitter |
 | CampaignEventSubmitter |
 | DatabaseSubmitter |
 | IDatabaseSubmittable |
 | ProfileData |
 | ProfileKeyData |
 | ProfilesDataCollection |
 | TrackingFieldProcessor |
 | UpdateVisitorIdentificationSubmitter |
 | VisitorIdentification |


AnalyticsCachedData Class

AnalyticsCachedData Class
Namespaces ► Sitecore.Analytics.Data ► AnalyticsCachedData
Declaration Syntax
C#
public class AnalyticsCachedData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalyticsCachedData()()() | Initializes a new instance of the AnalyticsCachedData class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Profiles |
 | Reload(Guid) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AnalyticsCachedData

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsCachedData Constructor

AnalyticsCachedData Constructor
Namespaces ► Sitecore.Analytics.Data ► AnalyticsCachedData ► AnalyticsCachedData()()()
Initializes a new instance of the AnalyticsCachedData class
Declaration Syntax
C#
public AnalyticsCachedData()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Profiles Property

Profiles Property
Namespaces ► Sitecore.Analytics.Data ► AnalyticsCachedData ► Profiles
Declaration Syntax
C#
public ProfilesDataCollection Profiles { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Reload Method (sessionId)

Reload Method (sessionId)
Namespaces ► Sitecore.Analytics.Data ► AnalyticsCachedData ► Reload(Guid)
Declaration Syntax
C#
public void Reload(
    Guid sessionId
)
Parameters
sessionId (Guid)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsDataContext Class

AnalyticsDataContext Class
Namespaces ► Sitecore.Analytics.Data ► AnalyticsDataContext
Declaration Syntax
C#
public class AnalyticsDataContext : SitecoreAnalyticsDataContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalyticsDataContext()()() | Initializes a new instance of the AnalyticsDataContext class
 | Browsers | (Inherited from SitecoreAnalyticsDataContext.)
 | CampaignEventPages | (Inherited from SitecoreAnalyticsDataContext.)
 | CampaignEvents | (Inherited from SitecoreAnalyticsDataContext.)
 | Campaigns | (Inherited from SitecoreAnalyticsDataContext.)
 | ChangeConflicts | Returns a collection of objects that caused concurrency conflicts when SubmitChanges()()() was called. (Inherited from DataContext.)
 | CommandTimeout | Increases the time-out period for queries that would otherwise time out during the default time-out period. (Inherited from DataContext.)
 | Connection | Returns the connection used by the framework. (Inherited from DataContext.)
 | ConnectionString |
 | CreateDatabase()()() | Creates a database on the server. (Inherited from DataContext.)
 | CreateMethodCallQuery<(Of <(TResult>)>)(Object, MethodInfo, array<Object>[]()[]) | Executes the table-valued database function associated with the specified CLR method. (Inherited from DataContext.)
 | DatabaseExists()()() | Determines whether the associated database can be opened. (Inherited from DataContext.)
 | DeferredLoadingEnabled | Specifies whether to delay-load one-to-many or one-to-one relationships. (Inherited from DataContext.)
 | DeleteDatabase()()() | Deletes the associated database. (Inherited from DataContext.)
 | Dispose()()() | Releases all resources used by the DataContext. (Inherited from DataContext.)
 | Dispose(Boolean) | Releases resources used by the DataContext. (Inherited from DataContext.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteCommand(String, array<Object>[]()[]) | Executes SQL commands directly on the database. (Inherited from DataContext.)
 | ExecuteDynamicDelete(Object) | Called inside delete override methods to redelegate to LINQ to SQL the task of generating and executing dynamic SQL for delete operations. (Inherited from DataContext.)
 | ExecuteDynamicInsert(Object) | Called inside insert override methods to redelegate to LINQ to SQL the task of generating and executing dynamic SQL for insert operations. (Inherited from DataContext.)
 | ExecuteDynamicUpdate(Object) | Called inside update override methods to redelegate to LINQ to SQL the task of generating and executing dynamic SQL for update operations. (Inherited from DataContext.)
 | ExecuteMethodCall(Object, MethodInfo, array<Object>[]()[]) | Executes the stored database procedure or scalar function associated with the specified CLR method. (Inherited from DataContext.)
 | ExecuteQuery<(Of <(TResult>)>)(String, array<Object>[]()[]) | Executes SQL queries directly on the database and returns objects. (Inherited from DataContext.)
 | ExecuteQuery(Type, String, array<Object>[]()[]) | Executes SQL queries directly on the database. (Inherited from DataContext.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChangeSet()()() | Provides access to the modified objects tracked by DataContext. (Inherited from DataContext.)
 | GetCommand(IQueryable) | Provides information about SQL commands generated by LINQ to SQL. (Inherited from DataContext.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTable<(Of <(TEntity>)>)()()() | Returns a collection of objects of a particular type, where the type is defined by the TEntity parameter. (Inherited from DataContext.)
 | GetTable(Type) | Returns a collection of objects of a particular type, where the type is defined by the type parameter. (Inherited from DataContext.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalSessions | (Inherited from SitecoreAnalyticsDataContext.)
 | IPOwners | (Inherited from SitecoreAnalyticsDataContext.)
 | IPs | (Inherited from SitecoreAnalyticsDataContext.)
 | Keywords | (Inherited from SitecoreAnalyticsDataContext.)
 | LoadOptions | Gets or sets the DataLoadOptions associated with this DataContext. (Inherited from DataContext.)
 | Log | Specifies the destination to write the SQL query or command. (Inherited from DataContext.)
 | Mapping | Returns the MetaModel on which the mapping is based. (Inherited from DataContext.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultiVarianceTestDefinitions | (Inherited from SitecoreAnalyticsDataContext.)
 | MultiVarianceTestVariableCampaignEvents | (Inherited from SitecoreAnalyticsDataContext.)
 | MultiVarianceTestVariablePages | (Inherited from SitecoreAnalyticsDataContext.)
 | MultiVarianceTestVariables | (Inherited from SitecoreAnalyticsDataContext.)
 | ObjectTrackingEnabled | Instructs the framework to track the original value and object identity for this DataContext. (Inherited from DataContext.)
 | OperatingSystems | (Inherited from SitecoreAnalyticsDataContext.)
 | PageEventDefinitions | (Inherited from SitecoreAnalyticsDataContext.)
 | PageEvents | (Inherited from SitecoreAnalyticsDataContext.)
 | Pages | (Inherited from SitecoreAnalyticsDataContext.)
 | ProfileDefinitions | (Inherited from SitecoreAnalyticsDataContext.)
 | ProfileKeyDefinitions | (Inherited from SitecoreAnalyticsDataContext.)
 | ProfileKeys | (Inherited from SitecoreAnalyticsDataContext.)
 | Profiles | (Inherited from SitecoreAnalyticsDataContext.)
 | ReferringSites | (Inherited from SitecoreAnalyticsDataContext.)
 | Refresh(RefreshMode, Object) | Refreshes an entity object according to the specified mode. (Inherited from DataContext.)
 | Refresh(RefreshMode, array<Object>[]()[]) | Refreshes an array of entity objects according to the specified mode. (Inherited from DataContext.)
 | Refresh(RefreshMode, IEnumerable) | Refreshes a collection of entity objects according to the specified mode. (Inherited from DataContext.)
 | Screens | (Inherited from SitecoreAnalyticsDataContext.)
 | Sessions | (Inherited from SitecoreAnalyticsDataContext.)
 | Status | (Inherited from SitecoreAnalyticsDataContext.)
 | SubmitChanges()()() | Computes the set of modified objects to be inserted, updated, or deleted, and executes the appropriate commands to implement the changes to the database. (Inherited from DataContext.)
 | SubmitChanges(ConflictMode) | Sends changes that were made to retrieved objects to the underlying database, and specifies the action to be taken if the submission fails. (Inherited from DataContext.)
 | Subscriptions | (Inherited from SitecoreAnalyticsDataContext.)
 | Tags | (Inherited from SitecoreAnalyticsDataContext.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transaction | Sets a local transaction for the .NET Framework to use to access the database. (Inherited from DataContext.)
 | Translate<(Of <(TResult>)>)(DbDataReader) | Converts an existing DbDataReader to objects. (Inherited from DataContext.)
 | Translate(Type, DbDataReader) | Converts an existing DbDataReader to objects. (Inherited from DataContext.)
 | VisitorIdentifications | (Inherited from SitecoreAnalyticsDataContext.)
Inheritance Hierarchy
Object
 | DataContext
 |  | SitecoreAnalyticsDataContext
 |  |  | AnalyticsDataContext

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsDataContext Constructor

AnalyticsDataContext Constructor
Namespaces ► Sitecore.Analytics.Data ► AnalyticsDataContext ► AnalyticsDataContext()()()
Initializes a new instance of the AnalyticsDataContext class
Declaration Syntax
C#
public AnalyticsDataContext()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ConnectionString Property

ConnectionString Property
Namespaces ► Sitecore.Analytics.Data ► AnalyticsDataContext ► ConnectionString
Declaration Syntax
C#
public static string ConnectionString { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsTrackerSubmitter Class

AnalyticsTrackerSubmitter Class
Namespaces ► Sitecore.Analytics.Data ► AnalyticsTrackerSubmitter
Declaration Syntax
C#
public class AnalyticsTrackerSubmitter : IDatabaseSubmittable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AnalyticsTrackerSubmitter(AnalyticsTracker) | Initializes a new instance of the AnalyticsTrackerSubmitter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Submit()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AnalyticsTrackerSubmitter

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsTrackerSubmitter Constructor (analyticsTracker)

AnalyticsTrackerSubmitter Constructor (analyticsTracker)
Namespaces ► Sitecore.Analytics.Data ► AnalyticsTrackerSubmitter ► AnalyticsTrackerSubmitter(AnalyticsTracker)
Initializes a new instance of the AnalyticsTrackerSubmitter class
Declaration Syntax
C#
public AnalyticsTrackerSubmitter(
    AnalyticsTracker analyticsTracker
)
Parameters
analyticsTracker (AnalyticsTracker)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Submit Method

Submit Method
Namespaces ► Sitecore.Analytics.Data ► AnalyticsTrackerSubmitter ► Submit()()()
Declaration Syntax
C#
public void Submit()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEventSubmitter Class

CampaignEventSubmitter Class
Namespaces ► Sitecore.Analytics.Data ► CampaignEventSubmitter
Declaration Syntax
C#
public class CampaignEventSubmitter : IDatabaseSubmittable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CampaignEventSubmitter(Guid, Guid, String, Int32) | Initializes a new instance of the CampaignEventSubmitter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Submit()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CampaignEventSubmitter

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignEventSubmitter Constructor (campaignId, campaignEventId, data, state)

CampaignEventSubmitter Constructor (campaignId, campaignEventId, data, state)
Namespaces ► Sitecore.Analytics.Data ► CampaignEventSubmitter ► CampaignEventSubmitter(Guid, Guid, String, Int32)
Initializes a new instance of the CampaignEventSubmitter class
Declaration Syntax
C#
public CampaignEventSubmitter(
    Guid campaignId,
    Guid campaignEventId,
    string data,
    int state
)
Parameters
campaignId (Guid)
campaignEventId (Guid)
data (String)
state (Int32)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Submit Method

Submit Method
Namespaces ► Sitecore.Analytics.Data ► CampaignEventSubmitter ► Submit()()()
Declaration Syntax
C#
public void Submit()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


DatabaseSubmitter Class

DatabaseSubmitter Class
Namespaces ► Sitecore.Analytics.Data ► DatabaseSubmitter
Declaration Syntax
C#
public static class DatabaseSubmitter
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Dequeue()()() |
 | Enqueue(IDatabaseSubmittable) |
 | GetSubmitters<(Of <(T>)>)()()() |
Inheritance Hierarchy
Object
DatabaseSubmitter

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Dequeue Method

Dequeue Method
Namespaces ► Sitecore.Analytics.Data ► DatabaseSubmitter ► Dequeue()()()
Declaration Syntax
C#
public static IDatabaseSubmittable Dequeue()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Enqueue Method (databaseSubmittable)

Enqueue Method (databaseSubmittable)
Namespaces ► Sitecore.Analytics.Data ► DatabaseSubmitter ► Enqueue(IDatabaseSubmittable)
Declaration Syntax
C#
public static void Enqueue(
    IDatabaseSubmittable databaseSubmittable
)
Parameters
databaseSubmittable (IDatabaseSubmittable)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetSubmitters Method

GetSubmitters<(Of <(T>)>) Method
Namespaces ► Sitecore.Analytics.Data ► DatabaseSubmitter ► GetSubmitters<(Of <(T>)>)()()()
Declaration Syntax
C#
public static IEnumerable<T> GetSubmitters<T>()
where T : class, IDatabaseSubmittable
Generic Template Parameters
T

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IDatabaseSubmittable Interface

IDatabaseSubmittable Interface
Namespaces ► Sitecore.Analytics.Data ► IDatabaseSubmittable
Declaration Syntax
C#
public interface IDatabaseSubmittable
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Submit()()() |

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Submit Method

Submit Method
Namespaces ► Sitecore.Analytics.Data ► IDatabaseSubmittable ► Submit()()()
Declaration Syntax
C#
void Submit()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileData Class

ProfileData Class
Namespaces ► Sitecore.Analytics.Data ► ProfileData
Declaration Syntax
C#
[SerializableAttribute]
public class ProfileData : ISerializable,
    IEnumerable<ProfileKeyData>, IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProfileData()()() | Initializes a new instance of the ProfileData class
 | ProfileData(SerializationInfo, StreamingContext) | Initializes a new instance of the ProfileData class
 | Add(ProfileKeyData) |
 | AddProfileKeyValue(String, Int32) |
 | Changed |
 | Count |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) |
 | GetProfileKey(String) |
 | GetProfileKeyValue(String) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProfileId |
 | ProfileName |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Total |
Inheritance Hierarchy
Object
ProfileData

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileData Constructor

ProfileData Constructor
Namespaces ► Sitecore.Analytics.Data ► ProfileData ► ProfileData()()()
Members
Icon | Member | Description
 | ProfileData()()() | Initializes a new instance of the ProfileData class
 | ProfileData(SerializationInfo, StreamingContext) | Initializes a new instance of the ProfileData class

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileData Constructor

ProfileData Constructor
Namespaces ► Sitecore.Analytics.Data ► ProfileData ► ProfileData()()()
Initializes a new instance of the ProfileData class
Declaration Syntax
C#
public ProfileData()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileData Constructor (info, context)

ProfileData Constructor (info, context)
Namespaces ► Sitecore.Analytics.Data ► ProfileData ► ProfileData(SerializationInfo, StreamingContext)
Initializes a new instance of the ProfileData class
Declaration Syntax
C#
protected ProfileData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Add Method (profileKeyData)

Add Method (profileKeyData)
Namespaces ► Sitecore.Analytics.Data ► ProfileData ► Add(ProfileKeyData)
Declaration Syntax
C#
public void Add(
    ProfileKeyData profileKeyData
)
Parameters
profileKeyData (ProfileKeyData)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AddProfileKeyValue Method (name, value)

AddProfileKeyValue Method (name, value)
Namespaces ► Sitecore.Analytics.Data ► ProfileData ► AddProfileKeyValue(String, Int32)
Declaration Syntax
C#
public int AddProfileKeyValue(
    string name,
    int value
)
Parameters
name (String)
value (Int32)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Changed Property

Changed Property
Namespaces ► Sitecore.Analytics.Data ► ProfileData ► Changed
Declaration Syntax
C#
public bool Changed { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Count Property

Count Property
Namespaces ► Sitecore.Analytics.Data ► ProfileData ► Count
Declaration Syntax
C#
public int Count { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Analytics.Data ► ProfileData ► GetEnumerator()()()
Declaration Syntax
C#
public IEnumerator<ProfileKeyData> GetEnumerator()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Analytics.Data ► ProfileData ► GetObjectData(SerializationInfo, StreamingContext)
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetProfileKey Method (name)

GetProfileKey Method (name)
Namespaces ► Sitecore.Analytics.Data ► ProfileData ► GetProfileKey(String)
Declaration Syntax
C#
public ProfileKeyData GetProfileKey(
    string name
)
Parameters
name (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetProfileKeyValue Method (name)

GetProfileKeyValue Method (name)
Namespaces ► Sitecore.Analytics.Data ► ProfileData ► GetProfileKeyValue(String)
Declaration Syntax
C#
public int GetProfileKeyValue(
    string name
)
Parameters
name (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileId Property

ProfileId Property
Namespaces ► Sitecore.Analytics.Data ► ProfileData ► ProfileId
Declaration Syntax
C#
public Guid ProfileId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileName Property

ProfileName Property
Namespaces ► Sitecore.Analytics.Data ► ProfileData ► ProfileName
Declaration Syntax
C#
public string ProfileName { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Total Property

Total Property
Namespaces ► Sitecore.Analytics.Data ► ProfileData ► Total
Declaration Syntax
C#
public int Total { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyData Class

ProfileKeyData Class
Namespaces ► Sitecore.Analytics.Data ► ProfileKeyData
Declaration Syntax
C#
[SerializableAttribute]
public class ProfileKeyData : ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProfileKeyData()()() | Initializes a new instance of the ProfileKeyData class
 | ProfileKeyData(SerializationInfo, StreamingContext) | Initializes a new instance of the ProfileKeyData class
 | Changed |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProfileKeyId |
 | ProfileKeyName |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
ProfileKeyData

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyData Constructor

ProfileKeyData Constructor
Namespaces ► Sitecore.Analytics.Data ► ProfileKeyData ► ProfileKeyData()()()
Members
Icon | Member | Description
 | ProfileKeyData()()() | Initializes a new instance of the ProfileKeyData class
 | ProfileKeyData(SerializationInfo, StreamingContext) | Initializes a new instance of the ProfileKeyData class

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyData Constructor

ProfileKeyData Constructor
Namespaces ► Sitecore.Analytics.Data ► ProfileKeyData ► ProfileKeyData()()()
Initializes a new instance of the ProfileKeyData class
Declaration Syntax
C#
public ProfileKeyData()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyData Constructor (info, context)

ProfileKeyData Constructor (info, context)
Namespaces ► Sitecore.Analytics.Data ► ProfileKeyData ► ProfileKeyData(SerializationInfo, StreamingContext)
Initializes a new instance of the ProfileKeyData class
Declaration Syntax
C#
protected ProfileKeyData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Changed Property

Changed Property
Namespaces ► Sitecore.Analytics.Data ► ProfileKeyData ► Changed
Declaration Syntax
C#
public bool Changed { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Analytics.Data ► ProfileKeyData ► GetObjectData(SerializationInfo, StreamingContext)
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyId Property

ProfileKeyId Property
Namespaces ► Sitecore.Analytics.Data ► ProfileKeyData ► ProfileKeyId
Declaration Syntax
C#
public Guid ProfileKeyId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyName Property

ProfileKeyName Property
Namespaces ► Sitecore.Analytics.Data ► ProfileKeyData ► ProfileKeyName
Declaration Syntax
C#
public string ProfileKeyName { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Value Property

Value Property
Namespaces ► Sitecore.Analytics.Data ► ProfileKeyData ► Value
Declaration Syntax
C#
public int Value { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfilesDataCollection Class

ProfilesDataCollection Class
Namespaces ► Sitecore.Analytics.Data ► ProfilesDataCollection
Declaration Syntax
C#
[SerializableAttribute]
public class ProfilesDataCollection : ISerializable,
    IEnumerable<ProfileData>, IEnumerable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProfilesDataCollection()()() | Initializes a new instance of the ProfilesDataCollection class
 | ProfilesDataCollection(SerializationInfo, StreamingContext) | Initializes a new instance of the ProfilesDataCollection class
 | Add(ProfileData) |
 | AddProfile(String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) |
 | GetProfile(String) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProfilesDataCollection

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfilesDataCollection Constructor

ProfilesDataCollection Constructor
Namespaces ► Sitecore.Analytics.Data ► ProfilesDataCollection ► ProfilesDataCollection()()()
Members
Icon | Member | Description
 | ProfilesDataCollection()()() | Initializes a new instance of the ProfilesDataCollection class
 | ProfilesDataCollection(SerializationInfo, StreamingContext) | Initializes a new instance of the ProfilesDataCollection class

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfilesDataCollection Constructor

ProfilesDataCollection Constructor
Namespaces ► Sitecore.Analytics.Data ► ProfilesDataCollection ► ProfilesDataCollection()()()
Initializes a new instance of the ProfilesDataCollection class
Declaration Syntax
C#
public ProfilesDataCollection()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfilesDataCollection Constructor (info, context)

ProfilesDataCollection Constructor (info, context)
Namespaces ► Sitecore.Analytics.Data ► ProfilesDataCollection ► ProfilesDataCollection(SerializationInfo, StreamingContext)
Initializes a new instance of the ProfilesDataCollection class
Declaration Syntax
C#
protected ProfilesDataCollection(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Add Method (profileData)

Add Method (profileData)
Namespaces ► Sitecore.Analytics.Data ► ProfilesDataCollection ► Add(ProfileData)
Declaration Syntax
C#
public void Add(
    ProfileData profileData
)
Parameters
profileData (ProfileData)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AddProfile Method (name)

AddProfile Method (name)
Namespaces ► Sitecore.Analytics.Data ► ProfilesDataCollection ► AddProfile(String)
Declaration Syntax
C#
public ProfileData AddProfile(
    string name
)
Parameters
name (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Analytics.Data ► ProfilesDataCollection ► GetEnumerator()()()
Declaration Syntax
C#
public IEnumerator<ProfileData> GetEnumerator()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Analytics.Data ► ProfilesDataCollection ► GetObjectData(SerializationInfo, StreamingContext)
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetProfile Method (name)

GetProfile Method (name)
Namespaces ► Sitecore.Analytics.Data ► ProfilesDataCollection ► GetProfile(String)
Declaration Syntax
C#
public ProfileData GetProfile(
    string name
)
Parameters
name (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TrackingFieldProcessor Class

TrackingFieldProcessor Class
Namespaces ► Sitecore.Analytics.Data ► TrackingFieldProcessor
Declaration Syntax
C#
public class TrackingFieldProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TrackingFieldProcessor()()() | Initializes a new instance of the TrackingFieldProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(Item) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TrackingFieldProcessor

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


TrackingFieldProcessor Constructor

TrackingFieldProcessor Constructor
Namespaces ► Sitecore.Analytics.Data ► TrackingFieldProcessor ► TrackingFieldProcessor()()()
Initializes a new instance of the TrackingFieldProcessor class
Declaration Syntax
C#
public TrackingFieldProcessor()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (item)

Process Method (item)
Namespaces ► Sitecore.Analytics.Data ► TrackingFieldProcessor ► Process(Item)
Declaration Syntax
C#
public void Process(
    Item item
)
Parameters
item (Item)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


UpdateVisitorIdentificationSubmitter Class

UpdateVisitorIdentificationSubmitter Class
Namespaces ► Sitecore.Analytics.Data ► UpdateVisitorIdentificationSubmitter
Declaration Syntax
C#
public class UpdateVisitorIdentificationSubmitter : IDatabaseSubmittable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UpdateVisitorIdentificationSubmitter(Guid) | Initializes a new instance of the UpdateVisitorIdentificationSubmitter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SessionId |
 | Submit()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UpdateVisitorIdentificationSubmitter

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


UpdateVisitorIdentificationSubmitter Constructor (sessionId)

UpdateVisitorIdentificationSubmitter Constructor (sessionId)
Namespaces ► Sitecore.Analytics.Data ► UpdateVisitorIdentificationSubmitter ► UpdateVisitorIdentificationSubmitter(Guid)
Initializes a new instance of the UpdateVisitorIdentificationSubmitter class
Declaration Syntax
C#
public UpdateVisitorIdentificationSubmitter(
    Guid sessionId
)
Parameters
sessionId (Guid)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SessionId Property

SessionId Property
Namespaces ► Sitecore.Analytics.Data ► UpdateVisitorIdentificationSubmitter ► SessionId
Declaration Syntax
C#
public Guid SessionId { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Submit Method

Submit Method
Namespaces ► Sitecore.Analytics.Data ► UpdateVisitorIdentificationSubmitter ► Submit()()()
Declaration Syntax
C#
public void Submit()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


VisitorIdentification Class

VisitorIdentification Class
Namespaces ► Sitecore.Analytics.Data ► VisitorIdentification
Declaration Syntax
C#
public static class VisitorIdentification
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DoNotAutoDetectVisitorAsRobot()()() |
 | UpdateVisitorIdentification(Guid) |
 | UpdateVisitorIdentifications()()() |
 | UpdateVisitorIdentifications(String, String, String) |
Inheritance Hierarchy
Object
VisitorIdentification

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


DoNotAutoDetectVisitorAsRobot Method

DoNotAutoDetectVisitorAsRobot Method
Namespaces ► Sitecore.Analytics.Data ► VisitorIdentification ► DoNotAutoDetectVisitorAsRobot()()()
Declaration Syntax
C#
public static void DoNotAutoDetectVisitorAsRobot()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


UpdateVisitorIdentification Method (ipownerId)

UpdateVisitorIdentification Method (ipownerId)
Namespaces ► Sitecore.Analytics.Data ► VisitorIdentification ► UpdateVisitorIdentification(Guid)
Declaration Syntax
C#
public static void UpdateVisitorIdentification(
    Guid ipownerId
)
Parameters
ipownerId (Guid)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


UpdateVisitorIdentifications Method

UpdateVisitorIdentifications Method
Namespaces ► Sitecore.Analytics.Data ► VisitorIdentification ► UpdateVisitorIdentifications()()()
Members
Icon | Member | Description
 | UpdateVisitorIdentifications()()() |
 | UpdateVisitorIdentifications(String, String, String) |

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


UpdateVisitorIdentifications Method

UpdateVisitorIdentifications Method
Namespaces ► Sitecore.Analytics.Data ► VisitorIdentification ► UpdateVisitorIdentifications()()()
Declaration Syntax
C#
public static void UpdateVisitorIdentifications()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


UpdateVisitorIdentifications Method (browserId, ipid, ipownerId)

UpdateVisitorIdentifications Method (browserId, ipid, ipownerId)
Namespaces ► Sitecore.Analytics.Data ► VisitorIdentification ► UpdateVisitorIdentifications(String, String, String)
Declaration Syntax
C#
public static void UpdateVisitorIdentifications(
    string browserId,
    string ipid,
    string ipownerId
)
Parameters
browserId (String)
ipid (String)
ipownerId (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Data.DataProviders Namespace

Sitecore.Analytics.Data.DataProviders Namespace
Namespaces ► Sitecore.Analytics.Data.DataProviders
Declaration Syntax
C#
namespace Sitecore.Analytics.Data.DataProviders
Types
All Types Classes Delegates
Icon | Type | Description
 | AnalyticsProvider |
 | AnalyticsProviderCollection |
 | AnalyticsProvider..::.ReadDelegate |


AnalyticsProvider Class

AnalyticsProvider Class
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider
Declaration Syntax
C#
public class AnalyticsProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalyticsProvider()()() | Initializes a new instance of the AnalyticsProvider class
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Escape(String) |
 | ExecuteCommand(String, array<Object>[]()[]) |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLookupData(Boolean, Int32) |
 | GetSession(String) |
 | GetStatus(Guid, DateTime%, DateTime%) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | Read(String, AnalyticsProvider..::.ReadDelegate) |
 | SaveCampaignDefinition(Guid, String, String, String, Int32, DateTime, DateTime, Boolean, String) |
 | SaveCampaignEvent(Guid, Guid, DateTime, String) |
 | SaveMultiVarianceTestDefinition(Guid, String, String) |
 | SaveMultiVarianceTestVariable(Guid, Guid, String) |
 | SavePageEventDefinition(Guid, String, String, String, Boolean, Boolean, Boolean, Boolean) |
 | SaveProfileDefinition(Guid, String, String) |
 | SaveProfileKeyDefinition(Guid, Guid, String, String, Int32, Int32) |
 | SetStatusFailed(Guid) |
 | SetStatusSuccessful(Guid) |
 | Submit(AnalyticsTracker, Boolean) |
 | SubmitTracker(AnalyticsTracker) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateIpInformation(Guid, WhoIsInformation) |
Inheritance Hierarchy
Object
 | ProviderBase
 |  | AnalyticsProvider

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsProvider Constructor

AnalyticsProvider Constructor
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► AnalyticsProvider()()()
Initializes a new instance of the AnalyticsProvider class
Declaration Syntax
C#
public AnalyticsProvider()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Escape Method (value)

Escape Method (value)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► Escape(String)
Declaration Syntax
C#
protected static string Escape(
    string value
)
Parameters
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ExecuteCommand Method (sql, parameters)

ExecuteCommand Method (sql, parameters)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► ExecuteCommand(String, array<Object>[]()[])
Declaration Syntax
C#
protected static int ExecuteCommand(
    string sql,
    params Object[] parameters
)
Parameters
sql (String)
parameters (array< Object >[]()[])

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetLookupData Method (onlyBlanks, maxEntries)

GetLookupData Method (onlyBlanks, maxEntries)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► GetLookupData(Boolean, Int32)
Declaration Syntax
C#
public IEnumerable<LookupData> GetLookupData(
    bool onlyBlanks,
    int maxEntries
)
Parameters
onlyBlanks (Boolean)
maxEntries (Int32)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetSession Method (aspNetSessionId)

GetSession Method (aspNetSessionId)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► GetSession(String)
Declaration Syntax
C#
public Session GetSession(
    string aspNetSessionId
)
Parameters
aspNetSessionId (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetStatus Method (id, successful, failed)

GetStatus Method (id, successful, failed)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► GetStatus(Guid, DateTime%, DateTime%)
Declaration Syntax
C#
public void GetStatus(
    Guid id,
    out DateTime successful,
    out DateTime failed
)
Parameters
id (Guid)
successful ( DateTime %)
failed ( DateTime %)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Read Method (sql, readDelegate)

Read Method (sql, readDelegate)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► Read(String, AnalyticsProvider..::.ReadDelegate)
Declaration Syntax
C#
protected static void Read(
    string sql,
    AnalyticsProvider..::.ReadDelegate readDelegate
)
Parameters
sql (String)
readDelegate (AnalyticsProvider..::.ReadDelegate)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SaveCampaignDefinition Method (campaignId, title, type, description, cost, startDate, endDate, isActive, data)

SaveCampaignDefinition Method (campaignId, title, type, description, cost, startDate, endDate, isActive, data)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► SaveCampaignDefinition(Guid, String, String, String, Int32, DateTime, DateTime, Boolean, String)
Declaration Syntax
C#
public void SaveCampaignDefinition(
    Guid campaignId,
    string title,
    string type,
    string description,
    int cost,
    DateTime startDate,
    DateTime endDate,
    bool isActive,
    string data
)
Parameters
campaignId (Guid)
title (String)
type (String)
description (String)
cost (Int32)
startDate (DateTime)
endDate (DateTime)
isActive (Boolean)
data (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SaveCampaignEvent Method (campaignEventId, campaignId, dateTime, data)

SaveCampaignEvent Method (campaignEventId, campaignId, dateTime, data)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► SaveCampaignEvent(Guid, Guid, DateTime, String)
Declaration Syntax
C#
public void SaveCampaignEvent(
    Guid campaignEventId,
    Guid campaignId,
    DateTime dateTime,
    string data
)
Parameters
campaignEventId (Guid)
campaignId (Guid)
dateTime (DateTime)
data (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SaveMultiVarianceTestDefinition Method (multiVarianceTestId, title, description)

SaveMultiVarianceTestDefinition Method (multiVarianceTestId, title, description)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► SaveMultiVarianceTestDefinition(Guid, String, String)
Declaration Syntax
C#
public void SaveMultiVarianceTestDefinition(
    Guid multiVarianceTestId,
    string title,
    string description
)
Parameters
multiVarianceTestId (Guid)
title (String)
description (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SaveMultiVarianceTestVariable Method (multiVarianceTestVariableId, multiVarianceTestDefinitionId, name)

SaveMultiVarianceTestVariable Method (multiVarianceTestVariableId, multiVarianceTestDefinitionId, name)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► SaveMultiVarianceTestVariable(Guid, Guid, String)
Declaration Syntax
C#
public void SaveMultiVarianceTestVariable(
    Guid multiVarianceTestVariableId,
    Guid multiVarianceTestDefinitionId,
    string name
)
Parameters
multiVarianceTestVariableId (Guid)
multiVarianceTestDefinitionId (Guid)
name (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SavePageEventDefinition Method (pageEventDefinitionId, name, icon, description, isSystem, isAuthorFeedback, isGoal, isFailure)

SavePageEventDefinition Method (pageEventDefinitionId, name, icon, description, isSystem, isAuthorFeedback, isGoal, isFailure)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► SavePageEventDefinition(Guid, String, String, String, Boolean, Boolean, Boolean, Boolean)
Declaration Syntax
C#
public void SavePageEventDefinition(
    Guid pageEventDefinitionId,
    string name,
    string icon,
    string description,
    bool isSystem,
    bool isAuthorFeedback,
    bool isGoal,
    bool isFailure
)
Parameters
pageEventDefinitionId (Guid)
name (String)
icon (String)
description (String)
isSystem (Boolean)
isAuthorFeedback (Boolean)
isGoal (Boolean)
isFailure (Boolean)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SaveProfileDefinition Method (profileDefinitionId, name, profileType)

SaveProfileDefinition Method (profileDefinitionId, name, profileType)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► SaveProfileDefinition(Guid, String, String)
Declaration Syntax
C#
public void SaveProfileDefinition(
    Guid profileDefinitionId,
    string name,
    string profileType
)
Parameters
profileDefinitionId (Guid)
name (String)
profileType (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SaveProfileKeyDefinition Method (profileKeyDefinitionId, profileDefinitionId, name, control, minValue, maxValue)

SaveProfileKeyDefinition Method (profileKeyDefinitionId, profileDefinitionId, name, control, minValue, maxValue)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► SaveProfileKeyDefinition(Guid, Guid, String, String, Int32, Int32)
Declaration Syntax
C#
public void SaveProfileKeyDefinition(
    Guid profileKeyDefinitionId,
    Guid profileDefinitionId,
    string name,
    string control,
    int minValue,
    int maxValue
)
Parameters
profileKeyDefinitionId (Guid)
profileDefinitionId (Guid)
name (String)
control (String)
minValue (Int32)
maxValue (Int32)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SetStatusFailed Method (id)

SetStatusFailed Method (id)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► SetStatusFailed(Guid)
Declaration Syntax
C#
public void SetStatusFailed(
    Guid id
)
Parameters
id (Guid)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SetStatusSuccessful Method (id)

SetStatusSuccessful Method (id)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► SetStatusSuccessful(Guid)
Declaration Syntax
C#
public void SetStatusSuccessful(
    Guid id
)
Parameters
id (Guid)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Submit Method (analyticsTracker, defer)

Submit Method (analyticsTracker, defer)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► Submit(AnalyticsTracker, Boolean)
Declaration Syntax
C#
public void Submit(
    AnalyticsTracker analyticsTracker,
    bool defer
)
Parameters
analyticsTracker (AnalyticsTracker)
defer (Boolean)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitTracker Method (analyticsTracker)

SubmitTracker Method (analyticsTracker)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► SubmitTracker(AnalyticsTracker)
Declaration Syntax
C#
public void SubmitTracker(
    AnalyticsTracker analyticsTracker
)
Parameters
analyticsTracker (AnalyticsTracker)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


UpdateIpInformation Method (ipid, information)

UpdateIpInformation Method (ipid, information)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► UpdateIpInformation(Guid, WhoIsInformation)
Declaration Syntax
C#
public void UpdateIpInformation(
    Guid ipid,
    WhoIsInformation information
)
Parameters
ipid (Guid)
information (WhoIsInformation)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsProvider.ReadDelegate Delegate

AnalyticsProvider..::.ReadDelegate Delegate
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProvider ► AnalyticsProvider..::.ReadDelegate
Declaration Syntax
C#
public delegate void ReadDelegate(
    SqlDataReader reader
)
Parameters
reader (SqlDataReader)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsProviderCollection Class

AnalyticsProviderCollection Class
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProviderCollection
Declaration Syntax
C#
public class AnalyticsProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalyticsProviderCollection()()() | Initializes a new instance of the AnalyticsProviderCollection class
 | Add(ProviderBase) | (Overrides ProviderCollection.Add(ProviderBase).)
 | Add(AnalyticsProvider) |
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | AnalyticsProviderCollection

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsProviderCollection Constructor

AnalyticsProviderCollection Constructor
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProviderCollection ► AnalyticsProviderCollection()()()
Initializes a new instance of the AnalyticsProviderCollection class
Declaration Syntax
C#
public AnalyticsProviderCollection()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Add Method

Add Method
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProviderCollection ► Add()()()
Members
Icon | Member | Description
 | Add(ProviderBase) | (Overrides ProviderCollection.Add(ProviderBase).)
 | Add(AnalyticsProvider) |

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Add Method (provider)

Add Method (provider)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProviderCollection ► Add(AnalyticsProvider)
Declaration Syntax
C#
public virtual void Add(
    AnalyticsProvider provider
)
Parameters
provider (AnalyticsProvider)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Add Method (provider)

Add Method (provider)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProviderCollection ► Add(ProviderBase)
Declaration Syntax
C#
public override void Add(
    ProviderBase provider
)
Parameters
provider (ProviderBase)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Analytics.Data.DataProviders ► AnalyticsProviderCollection ► Item[([(String])])
Declaration Syntax
C#
public virtual AnalyticsProvider this[
    string name
] { get; }
Parameters
name (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Data.Filters Namespace

Sitecore.Analytics.Data.Filters Namespace
Namespaces ► Sitecore.Analytics.Data.Filters
Declaration Syntax
C#
namespace Sitecore.Analytics.Data.Filters
Types
All Types Classes
Icon | Type | Description
 | ReportFilters |
 | SqlCommand |


ReportFilters Class

ReportFilters Class
Namespaces ► Sitecore.Analytics.Data.Filters ► ReportFilters
Declaration Syntax
C#
public static class ReportFilters
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ApplyFilter(Database, SqlCommand, XDocument) |
 | IsApplicable(Database, SqlCommand, XDocument) |
Inheritance Hierarchy
Object
ReportFilters

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (database, sqlCommand, filters)

ApplyFilter Method (database, sqlCommand, filters)
Namespaces ► Sitecore.Analytics.Data.Filters ► ReportFilters ► ApplyFilter(Database, SqlCommand, XDocument)
Declaration Syntax
C#
public static void ApplyFilter(
    Database database,
    SqlCommand sqlCommand,
    XDocument filters
)
Parameters
database (Database)
sqlCommand (SqlCommand)
filters (XDocument)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (database, sqlCommand, filters)

IsApplicable Method (database, sqlCommand, filters)
Namespaces ► Sitecore.Analytics.Data.Filters ► ReportFilters ► IsApplicable(Database, SqlCommand, XDocument)
Declaration Syntax
C#
public static bool IsApplicable(
    Database database,
    SqlCommand sqlCommand,
    XDocument filters
)
Parameters
database (Database)
sqlCommand (SqlCommand)
filters (XDocument)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SqlCommand Class

SqlCommand Class
Namespaces ► Sitecore.Analytics.Data.Filters ► SqlCommand
Declaration Syntax
C#
public class SqlCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlCommand(String, List<(Of <(String>)>)) | Initializes a new instance of the SqlCommand class
 | AddWhereClause(String, String, Boolean) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasPlaceholder(String) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Placeholders |
 | Sql |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SqlCommand

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SqlCommand Constructor (sql, placeholders)

SqlCommand Constructor (sql, placeholders)
Namespaces ► Sitecore.Analytics.Data.Filters ► SqlCommand ► SqlCommand(String, List<(Of <(String>)>))
Initializes a new instance of the SqlCommand class
Declaration Syntax
C#
public SqlCommand(
    string sql,
    List<string> placeholders
)
Parameters
sql (String)
placeholders (List<(Of <(String>)>))

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AddWhereClause Method (placeholderName, whereClause, isExceptCondition)

AddWhereClause Method (placeholderName, whereClause, isExceptCondition)
Namespaces ► Sitecore.Analytics.Data.Filters ► SqlCommand ► AddWhereClause(String, String, Boolean)
Declaration Syntax
C#
public void AddWhereClause(
    string placeholderName,
    string whereClause,
    bool isExceptCondition
)
Parameters
placeholderName (String)
whereClause (String)
isExceptCondition (Boolean)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


HasPlaceholder Method (variableName)

HasPlaceholder Method (variableName)
Namespaces ► Sitecore.Analytics.Data.Filters ► SqlCommand ► HasPlaceholder(String)
Declaration Syntax
C#
public bool HasPlaceholder(
    string variableName
)
Parameters
variableName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Placeholders Property

Placeholders Property
Namespaces ► Sitecore.Analytics.Data.Filters ► SqlCommand ► Placeholders
Declaration Syntax
C#
public Dictionary<string, string> Placeholders { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sql Property

Sql Property
Namespaces ► Sitecore.Analytics.Data.Filters ► SqlCommand ► Sql
Declaration Syntax
C#
public string Sql { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Data.Filters.Filters Namespace

Sitecore.Analytics.Data.Filters.Filters Namespace
Namespaces ► Sitecore.Analytics.Data.Filters.Filters
Declaration Syntax
C#
namespace Sitecore.Analytics.Data.Filters.Filters
Types
All Types Classes Interfaces
Icon | Type | Description
 | FilterBase |
 | IfExitPage |
 | IFilter |
 | IfIsNotBounce |
 | OperatorFilterBase |
 | WhereAreaCode |
 | WhereBrowser |
 | WhereCampaign |
 | WhereCity |
 | WhereCountry |
 | WhereGlobalVisitNo |
 | WhereIpBase |
 | WhereIpOwnerBase |
 | WhereIsp |
 | WhereItem |
 | WhereKeywords |
 | WhereLanguage |
 | WhereLatitude |
 | WhereLongitude |
 | WhereMetroCode |
 | WhereName |
 | WhereOperatingSystem |
 | WherePageCount |
 | WherePageNo |
 | WherePersona |
 | WherePostalCode |
 | WhereProfileKey |
 | WhereReferringSite |
 | WhereRegion |
 | WhereScreen |
 | WhereSite |
 | WhereVisitorIdentification |


FilterBase Class

FilterBase Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► FilterBase
Declaration Syntax
C#
public abstract class FilterBase : IFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FilterBase()()() | Initializes a new instance of the FilterBase class
 | ApplyFilter(SqlCommand) |
 | BuildCriteria(String, ListString) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EscapeLike(String) |
 | EscapeQuote(String) |
 | Except |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  | WhereBrowser
 |  | WhereCampaign
 |  | WhereItem
 |  | WhereKeywords
 |  | WhereLanguage
 |  | WhereOperatingSystem
 |  | WherePersona
 |  | WhereReferringSite
 |  | WhereScreen
 |  | WhereSite

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


FilterBase Constructor

FilterBase Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► FilterBase ► FilterBase()()()
Initializes a new instance of the FilterBase class
Declaration Syntax
C#
protected FilterBase()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► FilterBase ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public abstract void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


BuildCriteria Method (format, listString)

BuildCriteria Method (format, listString)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► FilterBase ► BuildCriteria(String, ListString)
Declaration Syntax
C#
protected static string BuildCriteria(
    string format,
    ListString listString
)
Parameters
format (String)
listString (ListString)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EscapeLike Method (text)

EscapeLike Method (text)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► FilterBase ► EscapeLike(String)
Declaration Syntax
C#
protected static string EscapeLike(
    string text
)
Parameters
text (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EscapeQuote Method (text)

EscapeQuote Method (text)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► FilterBase ► EscapeQuote(String)
Declaration Syntax
C#
protected static string EscapeQuote(
    string text
)
Parameters
text (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Except Property

Except Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► FilterBase ► Except
Declaration Syntax
C#
public bool Except { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► FilterBase ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public abstract bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IfExitPage Class

IfExitPage Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► IfExitPage
Declaration Syntax
C#
public class IfExitPage : OperatorFilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IfExitPage()()() | Initializes a new instance of the IfExitPage class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | IfExitPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IfExitPage Constructor

IfExitPage Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► IfExitPage ► IfExitPage()()()
Initializes a new instance of the IfExitPage class
Declaration Syntax
C#
public IfExitPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► IfExitPage ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► IfExitPage ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IFilter Interface

IFilter Interface
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► IFilter
Declaration Syntax
C#
public interface IFilter
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ApplyFilter(SqlCommand) |
 | IsApplicable(SqlCommand) |

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► IFilter ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► IFilter ► IsApplicable(SqlCommand)
Declaration Syntax
C#
bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IfIsNotBounce Class

IfIsNotBounce Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► IfIsNotBounce
Declaration Syntax
C#
public class IfIsNotBounce : OperatorFilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IfIsNotBounce()()() | Initializes a new instance of the IfIsNotBounce class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | IfIsNotBounce

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IfIsNotBounce Constructor

IfIsNotBounce Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► IfIsNotBounce ► IfIsNotBounce()()()
Initializes a new instance of the IfIsNotBounce class
Declaration Syntax
C#
public IfIsNotBounce()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► IfIsNotBounce ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► IfIsNotBounce ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatorFilterBase Class

OperatorFilterBase Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► OperatorFilterBase
Declaration Syntax
C#
public abstract class OperatorFilterBase : FilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OperatorFilterBase()()() | Initializes a new instance of the OperatorFilterBase class
 | ApplyFilter(SqlCommand) | (Inherited from FilterBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Inherited from FilterBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | IfExitPage
 |  |  | IfIsNotBounce
 |  |  | WhereGlobalVisitNo
 |  |  | WhereIpBase
 |  |  | WhereIpOwnerBase
 |  |  | WherePageCount
 |  |  | WherePageNo
 |  |  | WhereProfileKey
 |  |  | WhereVisitorIdentification

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatorFilterBase Constructor

OperatorFilterBase Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► OperatorFilterBase ► OperatorFilterBase()()()
Initializes a new instance of the OperatorFilterBase class
Declaration Syntax
C#
protected OperatorFilterBase()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetOperator Method

GetOperator Method
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► OperatorFilterBase ► GetOperator()()()
Declaration Syntax
C#
protected string GetOperator()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatorId Property

OperatorId Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► OperatorFilterBase ► OperatorId
Declaration Syntax
C#
public string OperatorId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereAreaCode Class

WhereAreaCode Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereAreaCode
Declaration Syntax
C#
public class WhereAreaCode : WhereIpBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereAreaCode()()() | Initializes a new instance of the WhereAreaCode class
 | ApplyFilter(SqlCommand) | (Inherited from WhereIpBase.)
 | ColumnName | (Inherited from WhereIpBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Inherited from WhereIpBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from WhereIpBase.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereIpBase
 |  |  |  | WhereAreaCode

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereAreaCode Constructor

WhereAreaCode Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereAreaCode ► WhereAreaCode()()()
Initializes a new instance of the WhereAreaCode class
Declaration Syntax
C#
public WhereAreaCode()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereBrowser Class

WhereBrowser Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereBrowser
Declaration Syntax
C#
public class WhereBrowser : FilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereBrowser()()() | Initializes a new instance of the WhereBrowser class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | BrowserId |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | WhereBrowser

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereBrowser Constructor

WhereBrowser Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereBrowser ► WhereBrowser()()()
Initializes a new instance of the WhereBrowser class
Declaration Syntax
C#
public WhereBrowser()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereBrowser ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


BrowserId Property

BrowserId Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereBrowser ► BrowserId
Declaration Syntax
C#
public string BrowserId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereBrowser ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereCampaign Class

WhereCampaign Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereCampaign
Declaration Syntax
C#
public class WhereCampaign : FilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereCampaign()()() | Initializes a new instance of the WhereCampaign class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Campaign |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | WhereCampaign

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereCampaign Constructor

WhereCampaign Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereCampaign ► WhereCampaign()()()
Initializes a new instance of the WhereCampaign class
Declaration Syntax
C#
public WhereCampaign()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereCampaign ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Campaign Property

Campaign Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereCampaign ► Campaign
Declaration Syntax
C#
public string Campaign { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereCampaign ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereCity Class

WhereCity Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereCity
Declaration Syntax
C#
public class WhereCity : WhereIpBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereCity()()() | Initializes a new instance of the WhereCity class
 | ApplyFilter(SqlCommand) | (Inherited from WhereIpBase.)
 | ColumnName | (Inherited from WhereIpBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Inherited from WhereIpBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from WhereIpBase.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereIpBase
 |  |  |  | WhereCity

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereCity Constructor

WhereCity Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereCity ► WhereCity()()()
Initializes a new instance of the WhereCity class
Declaration Syntax
C#
public WhereCity()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereCountry Class

WhereCountry Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereCountry
Declaration Syntax
C#
public class WhereCountry : WhereIpOwnerBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereCountry()()() | Initializes a new instance of the WhereCountry class
 | ApplyFilter(SqlCommand) | (Inherited from WhereIpOwnerBase.)
 | ColumnName | (Inherited from WhereIpOwnerBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Inherited from WhereIpOwnerBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from WhereIpOwnerBase.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereIpOwnerBase
 |  |  |  | WhereCountry

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereCountry Constructor

WhereCountry Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereCountry ► WhereCountry()()()
Initializes a new instance of the WhereCountry class
Declaration Syntax
C#
public WhereCountry()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereGlobalVisitNo Class

WhereGlobalVisitNo Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereGlobalVisitNo
Declaration Syntax
C#
public class WhereGlobalVisitNo : OperatorFilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereGlobalVisitNo()()() | Initializes a new instance of the WhereGlobalVisitNo class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalVisitNo |
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereGlobalVisitNo

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereGlobalVisitNo Constructor

WhereGlobalVisitNo Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereGlobalVisitNo ► WhereGlobalVisitNo()()()
Initializes a new instance of the WhereGlobalVisitNo class
Declaration Syntax
C#
public WhereGlobalVisitNo()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereGlobalVisitNo ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GlobalVisitNo Property

GlobalVisitNo Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereGlobalVisitNo ► GlobalVisitNo
Declaration Syntax
C#
public int GlobalVisitNo { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereGlobalVisitNo ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereIpBase Class

WhereIpBase Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereIpBase
Declaration Syntax
C#
public class WhereIpBase : OperatorFilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereIpBase()()() | Initializes a new instance of the WhereIpBase class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | ColumnName |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereIpBase
 |  |  |  | WhereAreaCode
 |  |  |  | WhereCity
 |  |  |  | WhereIsp
 |  |  |  | WhereLatitude
 |  |  |  | WhereLongitude
 |  |  |  | WhereMetroCode
 |  |  |  | WherePostalCode
 |  |  |  | WhereRegion

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereIpBase Constructor

WhereIpBase Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereIpBase ► WhereIpBase()()()
Initializes a new instance of the WhereIpBase class
Declaration Syntax
C#
public WhereIpBase()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereIpBase ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ColumnName Property

ColumnName Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereIpBase ► ColumnName
Declaration Syntax
C#
protected string ColumnName { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereIpBase ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Value Property

Value Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereIpBase ► Value
Declaration Syntax
C#
public string Value { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereIpOwnerBase Class

WhereIpOwnerBase Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereIpOwnerBase
Declaration Syntax
C#
public class WhereIpOwnerBase : OperatorFilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereIpOwnerBase()()() | Initializes a new instance of the WhereIpOwnerBase class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | ColumnName |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereIpOwnerBase
 |  |  |  | WhereCountry
 |  |  |  | WhereName

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereIpOwnerBase Constructor

WhereIpOwnerBase Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereIpOwnerBase ► WhereIpOwnerBase()()()
Initializes a new instance of the WhereIpOwnerBase class
Declaration Syntax
C#
public WhereIpOwnerBase()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereIpOwnerBase ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ColumnName Property

ColumnName Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereIpOwnerBase ► ColumnName
Declaration Syntax
C#
protected string ColumnName { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereIpOwnerBase ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Value Property

Value Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereIpOwnerBase ► Value
Declaration Syntax
C#
public string Value { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereIsp Class

WhereIsp Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereIsp
Declaration Syntax
C#
public class WhereIsp : WhereIpBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereIsp()()() | Initializes a new instance of the WhereIsp class
 | ApplyFilter(SqlCommand) | (Inherited from WhereIpBase.)
 | ColumnName | (Inherited from WhereIpBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Inherited from WhereIpBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from WhereIpBase.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereIpBase
 |  |  |  | WhereIsp

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereIsp Constructor

WhereIsp Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereIsp ► WhereIsp()()()
Initializes a new instance of the WhereIsp class
Declaration Syntax
C#
public WhereIsp()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereItem Class

WhereItem Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereItem
Declaration Syntax
C#
public class WhereItem : FilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereItem()()() | Initializes a new instance of the WhereItem class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | ItemId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | WhereItem

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereItem Constructor

WhereItem Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereItem ► WhereItem()()()
Initializes a new instance of the WhereItem class
Declaration Syntax
C#
public WhereItem()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereItem ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereItem ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ItemId Property

ItemId Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereItem ► ItemId
Declaration Syntax
C#
public string ItemId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereKeywords Class

WhereKeywords Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereKeywords
Declaration Syntax
C#
public class WhereKeywords : FilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereKeywords()()() | Initializes a new instance of the WhereKeywords class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | Keywords |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | WhereKeywords

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereKeywords Constructor

WhereKeywords Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereKeywords ► WhereKeywords()()()
Initializes a new instance of the WhereKeywords class
Declaration Syntax
C#
public WhereKeywords()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereKeywords ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereKeywords ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Keywords Property

Keywords Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereKeywords ► Keywords
Declaration Syntax
C#
public string Keywords { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereLanguage Class

WhereLanguage Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereLanguage
Declaration Syntax
C#
public class WhereLanguage : FilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereLanguage()()() | Initializes a new instance of the WhereLanguage class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | Language |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | WhereLanguage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereLanguage Constructor

WhereLanguage Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereLanguage ► WhereLanguage()()()
Initializes a new instance of the WhereLanguage class
Declaration Syntax
C#
public WhereLanguage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereLanguage ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereLanguage ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Language Property

Language Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereLanguage ► Language
Declaration Syntax
C#
public string Language { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereLatitude Class

WhereLatitude Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereLatitude
Declaration Syntax
C#
public class WhereLatitude : WhereIpBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereLatitude()()() | Initializes a new instance of the WhereLatitude class
 | ApplyFilter(SqlCommand) | (Inherited from WhereIpBase.)
 | ColumnName | (Inherited from WhereIpBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Inherited from WhereIpBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from WhereIpBase.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereIpBase
 |  |  |  | WhereLatitude

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereLatitude Constructor

WhereLatitude Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereLatitude ► WhereLatitude()()()
Initializes a new instance of the WhereLatitude class
Declaration Syntax
C#
public WhereLatitude()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereLongitude Class

WhereLongitude Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereLongitude
Declaration Syntax
C#
public class WhereLongitude : WhereIpBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereLongitude()()() | Initializes a new instance of the WhereLongitude class
 | ApplyFilter(SqlCommand) | (Inherited from WhereIpBase.)
 | ColumnName | (Inherited from WhereIpBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Inherited from WhereIpBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from WhereIpBase.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereIpBase
 |  |  |  | WhereLongitude

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereLongitude Constructor

WhereLongitude Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereLongitude ► WhereLongitude()()()
Initializes a new instance of the WhereLongitude class
Declaration Syntax
C#
public WhereLongitude()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereMetroCode Class

WhereMetroCode Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereMetroCode
Declaration Syntax
C#
public class WhereMetroCode : WhereIpBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereMetroCode()()() | Initializes a new instance of the WhereMetroCode class
 | ApplyFilter(SqlCommand) | (Inherited from WhereIpBase.)
 | ColumnName | (Inherited from WhereIpBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Inherited from WhereIpBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from WhereIpBase.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereIpBase
 |  |  |  | WhereMetroCode

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereMetroCode Constructor

WhereMetroCode Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereMetroCode ► WhereMetroCode()()()
Initializes a new instance of the WhereMetroCode class
Declaration Syntax
C#
public WhereMetroCode()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereName Class

WhereName Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereName
Declaration Syntax
C#
public class WhereName : WhereIpOwnerBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereName()()() | Initializes a new instance of the WhereName class
 | ApplyFilter(SqlCommand) | (Inherited from WhereIpOwnerBase.)
 | ColumnName | (Inherited from WhereIpOwnerBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Inherited from WhereIpOwnerBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from WhereIpOwnerBase.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereIpOwnerBase
 |  |  |  | WhereName

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereName Constructor

WhereName Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereName ► WhereName()()()
Initializes a new instance of the WhereName class
Declaration Syntax
C#
public WhereName()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereOperatingSystem Class

WhereOperatingSystem Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereOperatingSystem
Declaration Syntax
C#
public class WhereOperatingSystem : FilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereOperatingSystem()()() | Initializes a new instance of the WhereOperatingSystem class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatingSystemId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | WhereOperatingSystem

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereOperatingSystem Constructor

WhereOperatingSystem Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereOperatingSystem ► WhereOperatingSystem()()()
Initializes a new instance of the WhereOperatingSystem class
Declaration Syntax
C#
public WhereOperatingSystem()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereOperatingSystem ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereOperatingSystem ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatingSystemId Property

OperatingSystemId Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereOperatingSystem ► OperatingSystemId
Declaration Syntax
C#
public string OperatingSystemId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WherePageCount Class

WherePageCount Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePageCount
Declaration Syntax
C#
public class WherePageCount : OperatorFilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WherePageCount()()() | Initializes a new instance of the WherePageCount class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Count |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WherePageCount

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WherePageCount Constructor

WherePageCount Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePageCount ► WherePageCount()()()
Initializes a new instance of the WherePageCount class
Declaration Syntax
C#
public WherePageCount()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePageCount ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Count Property

Count Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePageCount ► Count
Declaration Syntax
C#
public int Count { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePageCount ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WherePageNo Class

WherePageNo Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePageNo
Declaration Syntax
C#
public class WherePageNo : OperatorFilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WherePageNo()()() | Initializes a new instance of the WherePageNo class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | PageNo |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WherePageNo

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WherePageNo Constructor

WherePageNo Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePageNo ► WherePageNo()()()
Initializes a new instance of the WherePageNo class
Declaration Syntax
C#
public WherePageNo()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePageNo ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePageNo ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageNo Property

PageNo Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePageNo ► PageNo
Declaration Syntax
C#
public int PageNo { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WherePersona Class

WherePersona Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePersona
Declaration Syntax
C#
public class WherePersona : FilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WherePersona(Item) | Initializes a new instance of the WherePersona class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | Item |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | WherePersona

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WherePersona Constructor (item)

WherePersona Constructor (item)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePersona ► WherePersona(Item)
Initializes a new instance of the WherePersona class
Declaration Syntax
C#
public WherePersona(
    Item item
)
Parameters
item (Item)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePersona ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePersona ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Item Property

Item Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePersona ► Item
Declaration Syntax
C#
public Item Item { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WherePostalCode Class

WherePostalCode Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePostalCode
Declaration Syntax
C#
public class WherePostalCode : WhereIpBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WherePostalCode()()() | Initializes a new instance of the WherePostalCode class
 | ApplyFilter(SqlCommand) | (Inherited from WhereIpBase.)
 | ColumnName | (Inherited from WhereIpBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Inherited from WhereIpBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from WhereIpBase.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereIpBase
 |  |  |  | WherePostalCode

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WherePostalCode Constructor

WherePostalCode Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WherePostalCode ► WherePostalCode()()()
Initializes a new instance of the WherePostalCode class
Declaration Syntax
C#
public WherePostalCode()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereProfileKey Class

WhereProfileKey Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereProfileKey
Declaration Syntax
C#
public class WhereProfileKey : OperatorFilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereProfileKey()()() | Initializes a new instance of the WhereProfileKey class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ProfileKeyId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereProfileKey

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereProfileKey Constructor

WhereProfileKey Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereProfileKey ► WhereProfileKey()()()
Initializes a new instance of the WhereProfileKey class
Declaration Syntax
C#
public WhereProfileKey()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereProfileKey ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereProfileKey ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyId Property

ProfileKeyId Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereProfileKey ► ProfileKeyId
Declaration Syntax
C#
public string ProfileKeyId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Value Property

Value Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereProfileKey ► Value
Declaration Syntax
C#
public string Value { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereReferringSite Class

WhereReferringSite Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereReferringSite
Declaration Syntax
C#
public class WhereReferringSite : FilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereReferringSite()()() | Initializes a new instance of the WhereReferringSite class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReferringSiteId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | WhereReferringSite

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereReferringSite Constructor

WhereReferringSite Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereReferringSite ► WhereReferringSite()()()
Initializes a new instance of the WhereReferringSite class
Declaration Syntax
C#
public WhereReferringSite()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereReferringSite ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereReferringSite ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReferringSiteId Property

ReferringSiteId Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereReferringSite ► ReferringSiteId
Declaration Syntax
C#
public string ReferringSiteId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereRegion Class

WhereRegion Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereRegion
Declaration Syntax
C#
public class WhereRegion : WhereIpBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereRegion()()() | Initializes a new instance of the WhereRegion class
 | ApplyFilter(SqlCommand) | (Inherited from WhereIpBase.)
 | ColumnName | (Inherited from WhereIpBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Inherited from WhereIpBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from WhereIpBase.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereIpBase
 |  |  |  | WhereRegion

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereRegion Constructor

WhereRegion Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereRegion ► WhereRegion()()()
Initializes a new instance of the WhereRegion class
Declaration Syntax
C#
public WhereRegion()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereScreen Class

WhereScreen Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereScreen
Declaration Syntax
C#
public class WhereScreen : FilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereScreen()()() | Initializes a new instance of the WhereScreen class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ScreenId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | WhereScreen

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereScreen Constructor

WhereScreen Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereScreen ► WhereScreen()()()
Initializes a new instance of the WhereScreen class
Declaration Syntax
C#
public WhereScreen()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereScreen ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereScreen ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ScreenId Property

ScreenId Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereScreen ► ScreenId
Declaration Syntax
C#
public string ScreenId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereSite Class

WhereSite Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereSite
Declaration Syntax
C#
public class WhereSite : FilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereSite()()() | Initializes a new instance of the WhereSite class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Site |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | WhereSite

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereSite Constructor

WhereSite Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereSite ► WhereSite()()()
Initializes a new instance of the WhereSite class
Declaration Syntax
C#
public WhereSite()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereSite ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereSite ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Site Property

Site Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereSite ► Site
Declaration Syntax
C#
public string Site { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereVisitorIdentification Class

WhereVisitorIdentification Class
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereVisitorIdentification
Declaration Syntax
C#
public class WhereVisitorIdentification : OperatorFilterBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhereVisitorIdentification()()() | Initializes a new instance of the WhereVisitorIdentification class
 | ApplyFilter(SqlCommand) | (Overrides FilterBase.ApplyFilter(SqlCommand).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Except | (Inherited from FilterBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | (Inherited from OperatorFilterBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Identification |
 | IsApplicable(SqlCommand) | (Overrides FilterBase.IsApplicable(SqlCommand).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | (Inherited from OperatorFilterBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterBase
 |  | OperatorFilterBase
 |  |  | WhereVisitorIdentification

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhereVisitorIdentification Constructor

WhereVisitorIdentification Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereVisitorIdentification ► WhereVisitorIdentification()()()
Initializes a new instance of the WhereVisitorIdentification class
Declaration Syntax
C#
public WhereVisitorIdentification()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ApplyFilter Method (sqlCommand)

ApplyFilter Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereVisitorIdentification ► ApplyFilter(SqlCommand)
Declaration Syntax
C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Identification Property

Identification Property
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereVisitorIdentification ► Identification
Declaration Syntax
C#
public int Identification { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsApplicable Method (sqlCommand)

IsApplicable Method (sqlCommand)
Namespaces ► Sitecore.Analytics.Data.Filters.Filters ► WhereVisitorIdentification ► IsApplicable(SqlCommand)
Declaration Syntax
C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Parameters
sqlCommand (SqlCommand)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Data.Filters.Macros Namespace

Sitecore.Analytics.Data.Filters.Macros Namespace
Namespaces ► Sitecore.Analytics.Data.Filters.Macros
Declaration Syntax
C#
namespace Sitecore.Analytics.Data.Filters.Macros
Types
All Types Classes Interfaces
Icon | Type | Description
 | BrowserMacro |
 | CampaignMacro |
 | FilterMacro |
 | IFilterMacro |
 | ItemMacro |
 | LanguageMacro |
 | OperatingSystemMacro |
 | OperatorMacro |
 | ProfileKeyMacro |
 | ReferringSiteMacro |
 | ScreenMacro |


BrowserMacro Class

BrowserMacro Class
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► BrowserMacro
Declaration Syntax
C#
public class BrowserMacro : FilterMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BrowserMacro()()() | Initializes a new instance of the BrowserMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | (Overrides FilterMacro.Execute(XElement, String, UrlString, String).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDisplayValue(String) | (Overrides FilterMacro.GetDisplayValue(String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterMacro
 |  | BrowserMacro

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


BrowserMacro Constructor

BrowserMacro Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► BrowserMacro ► BrowserMacro()()()
Initializes a new instance of the BrowserMacro class
Declaration Syntax
C#
public BrowserMacro()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► BrowserMacro ► Execute(XElement, String, UrlString, String)
Declaration Syntax
C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
name (String)
parameters (UrlString)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetDisplayValue Method (value)

GetDisplayValue Method (value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► BrowserMacro ► GetDisplayValue(String)
Declaration Syntax
C#
public override string GetDisplayValue(
    string value
)
Parameters
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignMacro Class

CampaignMacro Class
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► CampaignMacro
Declaration Syntax
C#
public class CampaignMacro : FilterMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CampaignMacro()()() | Initializes a new instance of the CampaignMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | (Overrides FilterMacro.Execute(XElement, String, UrlString, String).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDisplayValue(String) | (Inherited from FilterMacro.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterMacro
 |  | CampaignMacro

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CampaignMacro Constructor

CampaignMacro Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► CampaignMacro ► CampaignMacro()()()
Initializes a new instance of the CampaignMacro class
Declaration Syntax
C#
public CampaignMacro()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► CampaignMacro ► Execute(XElement, String, UrlString, String)
Declaration Syntax
C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
name (String)
parameters (UrlString)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


FilterMacro Class

FilterMacro Class
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► FilterMacro
Declaration Syntax
C#
public abstract class FilterMacro : IFilterMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FilterMacro()()() | Initializes a new instance of the FilterMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConnectionString()()() |
 | GetDisplayValue(String) |
 | GetFilterMacro(String) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadDisplayValue(String, String) |
 | SelectDatabaseRow(String, String) |
 | SelectDatabaseRows(String, String) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterMacro
 |  | BrowserMacro
 |  | CampaignMacro
 |  | ItemMacro
 |  | LanguageMacro
 |  | OperatingSystemMacro
 |  | OperatorMacro
 |  | ProfileKeyMacro
 |  | ReferringSiteMacro
 |  | ScreenMacro

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


FilterMacro Constructor

FilterMacro Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► FilterMacro ► FilterMacro()()()
Initializes a new instance of the FilterMacro class
Declaration Syntax
C#
protected FilterMacro()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► FilterMacro ► Execute(XElement, String, UrlString, String)
Declaration Syntax
C#
public abstract void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
name (String)
parameters (UrlString)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetConnectionString Method

GetConnectionString Method
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► FilterMacro ► GetConnectionString()()()
Declaration Syntax
C#
protected static string GetConnectionString()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetDisplayValue Method (value)

GetDisplayValue Method (value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► FilterMacro ► GetDisplayValue(String)
Declaration Syntax
C#
public virtual string GetDisplayValue(
    string value
)
Parameters
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetFilterMacro Method (control)

GetFilterMacro Method (control)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► FilterMacro ► GetFilterMacro(String)
Declaration Syntax
C#
public static IFilterMacro GetFilterMacro(
    string control
)
Parameters
control (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReadDisplayValue Method (sql, value)

ReadDisplayValue Method (sql, value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► FilterMacro ► ReadDisplayValue(String, String)
Declaration Syntax
C#
protected static string ReadDisplayValue(
    string sql,
    string value
)
Parameters
sql (String)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SelectDatabaseRow Method (sql, value)

SelectDatabaseRow Method (sql, value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► FilterMacro ► SelectDatabaseRow(String, String)
Declaration Syntax
C#
protected static void SelectDatabaseRow(
    string sql,
    string value
)
Parameters
sql (String)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SelectDatabaseRows Method (sql, value)

SelectDatabaseRows Method (sql, value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► FilterMacro ► SelectDatabaseRows(String, String)
Declaration Syntax
C#
protected static void SelectDatabaseRows(
    string sql,
    string value
)
Parameters
sql (String)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IFilterMacro Interface

IFilterMacro Interface
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► IFilterMacro
Declaration Syntax
C#
public interface IFilterMacro
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Execute(XElement, String, UrlString, String) |
 | GetDisplayValue(String) |

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► IFilterMacro ► Execute(XElement, String, UrlString, String)
Declaration Syntax
C#
void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
name (String)
parameters (UrlString)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetDisplayValue Method (value)

GetDisplayValue Method (value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► IFilterMacro ► GetDisplayValue(String)
Declaration Syntax
C#
string GetDisplayValue(
    string value
)
Parameters
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ItemMacro Class

ItemMacro Class
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► ItemMacro
Declaration Syntax
C#
public class ItemMacro : FilterMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemMacro()()() | Initializes a new instance of the ItemMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | (Overrides FilterMacro.Execute(XElement, String, UrlString, String).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDisplayValue(String) | (Inherited from FilterMacro.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterMacro
 |  | ItemMacro

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ItemMacro Constructor

ItemMacro Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► ItemMacro ► ItemMacro()()()
Initializes a new instance of the ItemMacro class
Declaration Syntax
C#
public ItemMacro()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► ItemMacro ► Execute(XElement, String, UrlString, String)
Declaration Syntax
C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
name (String)
parameters (UrlString)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LanguageMacro Class

LanguageMacro Class
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► LanguageMacro
Declaration Syntax
C#
public class LanguageMacro : FilterMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LanguageMacro()()() | Initializes a new instance of the LanguageMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | (Overrides FilterMacro.Execute(XElement, String, UrlString, String).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDisplayValue(String) | (Inherited from FilterMacro.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterMacro
 |  | LanguageMacro

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LanguageMacro Constructor

LanguageMacro Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► LanguageMacro ► LanguageMacro()()()
Initializes a new instance of the LanguageMacro class
Declaration Syntax
C#
public LanguageMacro()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► LanguageMacro ► Execute(XElement, String, UrlString, String)
Declaration Syntax
C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
name (String)
parameters (UrlString)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatingSystemMacro Class

OperatingSystemMacro Class
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► OperatingSystemMacro
Declaration Syntax
C#
public class OperatingSystemMacro : FilterMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | OperatingSystemMacro()()() | Initializes a new instance of the OperatingSystemMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | (Overrides FilterMacro.Execute(XElement, String, UrlString, String).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDisplayValue(String) | (Overrides FilterMacro.GetDisplayValue(String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterMacro
 |  | OperatingSystemMacro

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatingSystemMacro Constructor

OperatingSystemMacro Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► OperatingSystemMacro ► OperatingSystemMacro()()()
Initializes a new instance of the OperatingSystemMacro class
Declaration Syntax
C#
public OperatingSystemMacro()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► OperatingSystemMacro ► Execute(XElement, String, UrlString, String)
Declaration Syntax
C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
name (String)
parameters (UrlString)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetDisplayValue Method (value)

GetDisplayValue Method (value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► OperatingSystemMacro ► GetDisplayValue(String)
Declaration Syntax
C#
public override string GetDisplayValue(
    string value
)
Parameters
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatorMacro Class

OperatorMacro Class
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► OperatorMacro
Declaration Syntax
C#
public class OperatorMacro : FilterMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | OperatorMacro()()() | Initializes a new instance of the OperatorMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | (Overrides FilterMacro.Execute(XElement, String, UrlString, String).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDisplayValue(String) | (Inherited from FilterMacro.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterMacro
 |  | OperatorMacro

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OperatorMacro Constructor

OperatorMacro Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► OperatorMacro ► OperatorMacro()()()
Initializes a new instance of the OperatorMacro class
Declaration Syntax
C#
public OperatorMacro()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► OperatorMacro ► Execute(XElement, String, UrlString, String)
Declaration Syntax
C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
name (String)
parameters (UrlString)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyMacro Class

ProfileKeyMacro Class
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► ProfileKeyMacro
Declaration Syntax
C#
public class ProfileKeyMacro : FilterMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProfileKeyMacro()()() | Initializes a new instance of the ProfileKeyMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | (Overrides FilterMacro.Execute(XElement, String, UrlString, String).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDisplayValue(String) | (Inherited from FilterMacro.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterMacro
 |  | ProfileKeyMacro

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyMacro Constructor

ProfileKeyMacro Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► ProfileKeyMacro ► ProfileKeyMacro()()()
Initializes a new instance of the ProfileKeyMacro class
Declaration Syntax
C#
public ProfileKeyMacro()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► ProfileKeyMacro ► Execute(XElement, String, UrlString, String)
Declaration Syntax
C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
name (String)
parameters (UrlString)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReferringSiteMacro Class

ReferringSiteMacro Class
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► ReferringSiteMacro
Declaration Syntax
C#
public class ReferringSiteMacro : FilterMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ReferringSiteMacro()()() | Initializes a new instance of the ReferringSiteMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | (Overrides FilterMacro.Execute(XElement, String, UrlString, String).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDisplayValue(String) | (Overrides FilterMacro.GetDisplayValue(String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterMacro
 |  | ReferringSiteMacro

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReferringSiteMacro Constructor

ReferringSiteMacro Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► ReferringSiteMacro ► ReferringSiteMacro()()()
Initializes a new instance of the ReferringSiteMacro class
Declaration Syntax
C#
public ReferringSiteMacro()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► ReferringSiteMacro ► Execute(XElement, String, UrlString, String)
Declaration Syntax
C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
name (String)
parameters (UrlString)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetDisplayValue Method (value)

GetDisplayValue Method (value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► ReferringSiteMacro ► GetDisplayValue(String)
Declaration Syntax
C#
public override string GetDisplayValue(
    string value
)
Parameters
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ScreenMacro Class

ScreenMacro Class
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► ScreenMacro
Declaration Syntax
C#
public class ScreenMacro : FilterMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ScreenMacro()()() | Initializes a new instance of the ScreenMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | (Overrides FilterMacro.Execute(XElement, String, UrlString, String).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDisplayValue(String) | (Overrides FilterMacro.GetDisplayValue(String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FilterMacro
 |  | ScreenMacro

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ScreenMacro Constructor

ScreenMacro Constructor
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► ScreenMacro ► ScreenMacro()()()
Initializes a new instance of the ScreenMacro class
Declaration Syntax
C#
public ScreenMacro()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► ScreenMacro ► Execute(XElement, String, UrlString, String)
Declaration Syntax
C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
name (String)
parameters (UrlString)
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetDisplayValue Method (value)

GetDisplayValue Method (value)
Namespaces ► Sitecore.Analytics.Data.Filters.Macros ► ScreenMacro ► GetDisplayValue(String)
Declaration Syntax
C#
public override string GetDisplayValue(
    string value
)
Parameters
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Data.Items Namespace

Sitecore.Analytics.Data.Items Namespace
Namespaces ► Sitecore.Analytics.Data.Items
Declaration Syntax
C#
namespace Sitecore.Analytics.Data.Items
Types
All Types Classes
Icon | Type | Description
 | ItemEventHandler |


ItemEventHandler Class

ItemEventHandler Class
Namespaces ► Sitecore.Analytics.Data.Items ► ItemEventHandler
Declaration Syntax
C#
public class ItemEventHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemEventHandler()()() | Initializes a new instance of the ItemEventHandler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnItemDeleted(Object, EventArgs) |
 | OnItemSaved(Object, EventArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemEventHandler

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ItemEventHandler Constructor

ItemEventHandler Constructor
Namespaces ► Sitecore.Analytics.Data.Items ► ItemEventHandler ► ItemEventHandler()()()
Initializes a new instance of the ItemEventHandler class
Declaration Syntax
C#
public ItemEventHandler()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnItemDeleted Method (sender, args)

OnItemDeleted Method (sender, args)
Namespaces ► Sitecore.Analytics.Data.Items ► ItemEventHandler ► OnItemDeleted(Object, EventArgs)
Declaration Syntax
C#
protected void OnItemDeleted(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
args (EventArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnItemSaved Method (sender, args)

OnItemSaved Method (sender, args)
Namespaces ► Sitecore.Analytics.Data.Items ► ItemEventHandler ► OnItemSaved(Object, EventArgs)
Declaration Syntax
C#
protected void OnItemSaved(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
args (EventArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Data.Sql Namespace

Sitecore.Analytics.Data.Sql Namespace
Namespaces ► Sitecore.Analytics.Data.Sql
Declaration Syntax
C#
namespace Sitecore.Analytics.Data.Sql
Types
All Types Classes
Icon | Type | Description
 | SqlHelper |


SqlHelper Class

SqlHelper Class
Namespaces ► Sitecore.Analytics.Data.Sql ► SqlHelper
Declaration Syntax
C#
public static class SqlHelper
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Escape(String) |
 | ExecuteCommand(String, array<Object>[]()[]) |
 | Read(String, AnalyticsProvider..::.ReadDelegate) |
Inheritance Hierarchy
Object
SqlHelper

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Escape Method (value)

Escape Method (value)
Namespaces ► Sitecore.Analytics.Data.Sql ► SqlHelper ► Escape(String)
Declaration Syntax
C#
public static string Escape(
    string value
)
Parameters
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ExecuteCommand Method (sql, parameters)

ExecuteCommand Method (sql, parameters)
Namespaces ► Sitecore.Analytics.Data.Sql ► SqlHelper ► ExecuteCommand(String, array<Object>[]()[])
Declaration Syntax
C#
public static int ExecuteCommand(
    string sql,
    params Object[] parameters
)
Parameters
sql (String)
parameters (array< Object >[]()[])

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Read Method (sql, readDelegate)

Read Method (sql, readDelegate)
Namespaces ► Sitecore.Analytics.Data.Sql ► SqlHelper ► Read(String, AnalyticsProvider..::.ReadDelegate)
Declaration Syntax
C#
public static void Read(
    string sql,
    AnalyticsProvider..::.ReadDelegate readDelegate
)
Parameters
sql (String)
readDelegate (AnalyticsProvider..::.ReadDelegate)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace

Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Declaration Syntax
C#
namespace Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Types
All Types Classes
Icon | Type | Description
 | Baskets |
 | Brochures |
 | Forms |
 | Membership |
 | Newsletters |
 | Pages |
 | Polls |
 | Prints |
 | Ratings |
 | Searches |
 | Transactions |


Baskets Class

Baskets Class
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Baskets
Declaration Syntax
C#
public static class Baskets
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PutInBasket(AnalyticsPage, String, Int32, Double) |
Inheritance Hierarchy
Object
Baskets

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PutInBasket Method (page, product, amount, cost)

PutInBasket Method (page, product, amount, cost)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Baskets ► PutInBasket(AnalyticsPage, String, Int32, Double)
Declaration Syntax
C#
public static void PutInBasket(
    AnalyticsPage page,
    string product,
    int amount,
    double cost
)
Parameters
page (AnalyticsPage)
product (String)
amount (Int32)
cost (Double)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Brochures Class

Brochures Class
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Brochures
Declaration Syntax
C#
public static class Brochures
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RequestBrochures(AnalyticsPage, IEnumerable<(Of <(String>)>)) |
Inheritance Hierarchy
Object
Brochures

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RequestBrochures Method (page, brochureNames)

RequestBrochures Method (page, brochureNames)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Brochures ► RequestBrochures(AnalyticsPage, IEnumerable<(Of <(String>)>))
Declaration Syntax
C#
public static void RequestBrochures(
    AnalyticsPage page,
    IEnumerable<string> brochureNames
)
Parameters
page (AnalyticsPage)
brochureNames (IEnumerable<(Of <(String>)>))

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Forms Class

Forms Class
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Forms
Declaration Syntax
C#
public static class Forms
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ChangeFormField(AnalyticsPage, String, String) |
 | Submit(AnalyticsPage) |
Inheritance Hierarchy
Object
Forms

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ChangeFormField Method (page, fieldName, fieldValue)

ChangeFormField Method (page, fieldName, fieldValue)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Forms ► ChangeFormField(AnalyticsPage, String, String)
Declaration Syntax
C#
public static void ChangeFormField(
    AnalyticsPage page,
    string fieldName,
    string fieldValue
)
Parameters
page (AnalyticsPage)
fieldName (String)
fieldValue (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Submit Method (page)

Submit Method (page)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Forms ► Submit(AnalyticsPage)
Declaration Syntax
C#
public static void Submit(
    AnalyticsPage page
)
Parameters
page (AnalyticsPage)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Membership Class

Membership Class
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Membership
Declaration Syntax
C#
public static class Membership
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LoginUser(AnalyticsPage, String) |
 | LoginUserFailed(AnalyticsPage, String, String) |
 | LogoutUser(AnalyticsPage) |
 | RegisterUser(AnalyticsPage, String, String, String, String, String, String, String, array<String>[]()[]) |
 | RegisterUserFailed(AnalyticsPage, String, String, String, String, String, String, String, String, array<String>[]()[]) |
 | UpdateUser(AnalyticsPage, String, String, String, String, String, String, String, array<String>[]()[]) |
Inheritance Hierarchy
Object
Membership

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LoginUser Method (page, userName)

LoginUser Method (page, userName)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Membership ► LoginUser(AnalyticsPage, String)
Declaration Syntax
C#
public static void LoginUser(
    AnalyticsPage page,
    string userName
)
Parameters
page (AnalyticsPage)
userName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LoginUserFailed Method (page, userName, reason)

LoginUserFailed Method (page, userName, reason)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Membership ► LoginUserFailed(AnalyticsPage, String, String)
Declaration Syntax
C#
public static void LoginUserFailed(
    AnalyticsPage page,
    string userName,
    string reason
)
Parameters
page (AnalyticsPage)
userName (String)
reason (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LogoutUser Method (page)

LogoutUser Method (page)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Membership ► LogoutUser(AnalyticsPage)
Declaration Syntax
C#
public static void LogoutUser(
    AnalyticsPage page
)
Parameters
page (AnalyticsPage)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RegisterUser Method (page, fullName, email, address, city, state, country, phone, additional)

RegisterUser Method (page, fullName, email, address, city, state, country, phone, additional)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Membership ► RegisterUser(AnalyticsPage, String, String, String, String, String, String, String, array<String>[]()[])
Declaration Syntax
C#
public static void RegisterUser(
    AnalyticsPage page,
    string fullName,
    string email,
    string address,
    string city,
    string state,
    string country,
    string phone,
    params string[] additional
)
Parameters
page (AnalyticsPage)
fullName (String)
email (String)
address (String)
city (String)
state (String)
country (String)
phone (String)
additional (array< String >[]()[])

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RegisterUserFailed Method (page, fullName, email, address, city, state, country, phone, reason, additional)

RegisterUserFailed Method (page, fullName, email, address, city, state, country, phone, reason, additional)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Membership ► RegisterUserFailed(AnalyticsPage, String, String, String, String, String, String, String, String, array<String>[]()[])
Declaration Syntax
C#
public static void RegisterUserFailed(
    AnalyticsPage page,
    string fullName,
    string email,
    string address,
    string city,
    string state,
    string country,
    string phone,
    string reason,
    params string[] additional
)
Parameters
page (AnalyticsPage)
fullName (String)
email (String)
address (String)
city (String)
state (String)
country (String)
phone (String)
reason (String)
additional (array< String >[]()[])

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


UpdateUser Method (page, fullName, email, address, city, state, country, phone, additional)

UpdateUser Method (page, fullName, email, address, city, state, country, phone, additional)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Membership ► UpdateUser(AnalyticsPage, String, String, String, String, String, String, String, array<String>[]()[])
Declaration Syntax
C#
public static void UpdateUser(
    AnalyticsPage page,
    string fullName,
    string email,
    string address,
    string city,
    string state,
    string country,
    string phone,
    params string[] additional
)
Parameters
page (AnalyticsPage)
fullName (String)
email (String)
address (String)
city (String)
state (String)
country (String)
phone (String)
additional (array< String >[]()[])

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Newsletters Class

Newsletters Class
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Newsletters
Declaration Syntax
C#
public static class Newsletters
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RemoveFromNewsletter(AnalyticsPage, String) |
 | SignUpToNewsletter(AnalyticsPage, String, String) |
Inheritance Hierarchy
Object
Newsletters

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RemoveFromNewsletter Method (page, newsletter)

RemoveFromNewsletter Method (page, newsletter)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Newsletters ► RemoveFromNewsletter(AnalyticsPage, String)
Declaration Syntax
C#
public static void RemoveFromNewsletter(
    AnalyticsPage page,
    string newsletter
)
Parameters
page (AnalyticsPage)
newsletter (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SignUpToNewsletter Method (page, newsletter, email)

SignUpToNewsletter Method (page, newsletter, email)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Newsletters ► SignUpToNewsletter(AnalyticsPage, String, String)
Declaration Syntax
C#
public static void SignUpToNewsletter(
    AnalyticsPage page,
    string newsletter,
    string email
)
Parameters
page (AnalyticsPage)
newsletter (String)
email (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Pages Class

Pages Class
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Pages
Declaration Syntax
C#
public static class Pages
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LongRunningRequest(AnalyticsPage, Double) |
 | PageError(AnalyticsPage, String, String) |
 | PageNotFound(AnalyticsPage, String) |
 | VisitPage(AnalyticsPage) |
 | VisitPage(AnalyticsPage, String) |
Inheritance Hierarchy
Object
Pages

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LongRunningRequest Method (page, milliseconds)

LongRunningRequest Method (page, milliseconds)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Pages ► LongRunningRequest(AnalyticsPage, Double)
Declaration Syntax
C#
public static void LongRunningRequest(
    AnalyticsPage page,
    double milliseconds
)
Parameters
page (AnalyticsPage)
milliseconds (Double)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageError Method (page, url, message)

PageError Method (page, url, message)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Pages ► PageError(AnalyticsPage, String, String)
Declaration Syntax
C#
public static void PageError(
    AnalyticsPage page,
    string url,
    string message
)
Parameters
page (AnalyticsPage)
url (String)
message (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageNotFound Method (page, url)

PageNotFound Method (page, url)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Pages ► PageNotFound(AnalyticsPage, String)
Declaration Syntax
C#
public static void PageNotFound(
    AnalyticsPage page,
    string url
)
Parameters
page (AnalyticsPage)
url (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


VisitPage Method

VisitPage Method
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Pages ► VisitPage()()()
Members
Icon | Member | Description
 | VisitPage(AnalyticsPage) |
 | VisitPage(AnalyticsPage, String) |

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


VisitPage Method (page)

VisitPage Method (page)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Pages ► VisitPage(AnalyticsPage)
Declaration Syntax
C#
public static void VisitPage(
    AnalyticsPage page
)
Parameters
page (AnalyticsPage)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


VisitPage Method (page, url)

VisitPage Method (page, url)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Pages ► VisitPage(AnalyticsPage, String)
Declaration Syntax
C#
public static void VisitPage(
    AnalyticsPage page,
    string url
)
Parameters
page (AnalyticsPage)
url (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Polls Class

Polls Class
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Polls
Declaration Syntax
C#
public static class Polls
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SelectPollOption(AnalyticsPage, String, String, Int32) |
Inheritance Hierarchy
Object
Polls

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SelectPollOption Method (page, pollName, option, optionIndex)

SelectPollOption Method (page, pollName, option, optionIndex)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Polls ► SelectPollOption(AnalyticsPage, String, String, Int32)
Declaration Syntax
C#
public static void SelectPollOption(
    AnalyticsPage page,
    string pollName,
    string option,
    int optionIndex
)
Parameters
page (AnalyticsPage)
pollName (String)
option (String)
optionIndex (Int32)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Prints Class

Prints Class
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Prints
Declaration Syntax
C#
public static class Prints
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Print(AnalyticsPage) |
Inheritance Hierarchy
Object
Prints

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Print Method (page)

Print Method (page)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Prints ► Print(AnalyticsPage)
Declaration Syntax
C#
public static void Print(
    AnalyticsPage page
)
Parameters
page (AnalyticsPage)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Ratings Class

Ratings Class
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Ratings
Declaration Syntax
C#
public static class Ratings
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Rate(AnalyticsPage, String, String, Int32) |
Inheritance Hierarchy
Object
Ratings

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Rate Method (page, ratingName, ratingOption, ratingValue)

Rate Method (page, ratingName, ratingOption, ratingValue)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Ratings ► Rate(AnalyticsPage, String, String, Int32)
Declaration Syntax
C#
public static void Rate(
    AnalyticsPage page,
    string ratingName,
    string ratingOption,
    int ratingValue
)
Parameters
page (AnalyticsPage)
ratingName (String)
ratingOption (String)
ratingValue (Int32)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Searches Class

Searches Class
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Searches
Declaration Syntax
C#
public static class Searches
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddFollowHitToQueryString(String, String) |
 | FollowSearchHit(AnalyticsPage) |
 | Search(AnalyticsPage, String, Int32) |
Inheritance Hierarchy
Object
Searches

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AddFollowHitToQueryString Method (url, search)

AddFollowHitToQueryString Method (url, search)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Searches ► AddFollowHitToQueryString(String, String)
Declaration Syntax
C#
public static string AddFollowHitToQueryString(
    string url,
    string search
)
Parameters
url (String)
search (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


FollowSearchHit Method (page)

FollowSearchHit Method (page)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Searches ► FollowSearchHit(AnalyticsPage)
Declaration Syntax
C#
public static void FollowSearchHit(
    AnalyticsPage page
)
Parameters
page (AnalyticsPage)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Search Method (page, query, hits)

Search Method (page, query, hits)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Searches ► Search(AnalyticsPage, String, Int32)
Declaration Syntax
C#
public static void Search(
    AnalyticsPage page,
    string query,
    int hits
)
Parameters
page (AnalyticsPage)
query (String)
hits (Int32)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Transactions Class

Transactions Class
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Transactions
Declaration Syntax
C#
public static class Transactions
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BeginTransaction(AnalyticsPage) |
 | CancelTransaction(AnalyticsPage, TransactionHandle) |
 | EndTransaction(AnalyticsPage, TransactionHandle) |
Inheritance Hierarchy
Object
Transactions

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


BeginTransaction Method (page)

BeginTransaction Method (page)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Transactions ► BeginTransaction(AnalyticsPage)
Declaration Syntax
C#
public static TransactionHandle BeginTransaction(
    AnalyticsPage page
)
Parameters
page (AnalyticsPage)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CancelTransaction Method (page, transactionHandle)

CancelTransaction Method (page, transactionHandle)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Transactions ► CancelTransaction(AnalyticsPage, TransactionHandle)
Declaration Syntax
C#
public static void CancelTransaction(
    AnalyticsPage page,
    TransactionHandle transactionHandle
)
Parameters
page (AnalyticsPage)
transactionHandle (TransactionHandle)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EndTransaction Method (page, transactionHandle)

EndTransaction Method (page, transactionHandle)
Namespaces ► Sitecore.Analytics.Extensions.AnalyticsPageExtensions ► Transactions ► EndTransaction(AnalyticsPage, TransactionHandle)
Declaration Syntax
C#
public static void EndTransaction(
    AnalyticsPage page,
    TransactionHandle transactionHandle
)
Parameters
page (AnalyticsPage)
transactionHandle (TransactionHandle)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Lookups Namespace

Sitecore.Analytics.Lookups Namespace
Namespaces ► Sitecore.Analytics.Lookups
Declaration Syntax
C#
namespace Sitecore.Analytics.Lookups
Types
All Types Classes Enumerations
Icon | Type | Description
 | Hexillion |
 | HexillionProvider |
 | LookupData |
 | LookupManager |
 | LookupProviderBase |
 | LookupProviderCollection |
 | LookupUpdater |
 | LookupWorker |
 | MaxMindProvider |
 | UpdateOperation |
 | WhoIsInformation |


Hexillion Class

Hexillion Class
Namespaces ► Sitecore.Analytics.Lookups ► Hexillion
Declaration Syntax
C#
public class Hexillion
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Hexillion()()() | Initializes a new instance of the Hexillion class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInformationByIp(String) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAuthenticated()()() |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Hexillion

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Hexillion Constructor

Hexillion Constructor
Namespaces ► Sitecore.Analytics.Lookups ► Hexillion ► Hexillion()()()
Initializes a new instance of the Hexillion class
Declaration Syntax
C#
public Hexillion()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetInformationByIp Method (ip)

GetInformationByIp Method (ip)
Namespaces ► Sitecore.Analytics.Lookups ► Hexillion ► GetInformationByIp(String)
Declaration Syntax
C#
public WhoIsInformation GetInformationByIp(
    string ip
)
Parameters
ip (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IsAuthenticated Method

IsAuthenticated Method
Namespaces ► Sitecore.Analytics.Lookups ► Hexillion ► IsAuthenticated()()()
Declaration Syntax
C#
public bool IsAuthenticated()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


HexillionProvider Class

HexillionProvider Class
Namespaces ► Sitecore.Analytics.Lookups ► HexillionProvider
Declaration Syntax
C#
public class HexillionProvider : LookupProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HexillionProvider()()() | Initializes a new instance of the HexillionProvider class
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInformationByIp(String, String) | (Overrides LookupProviderBase.GetInformationByIp(String, String).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ReverseDnsLookup(String) | (Inherited from LookupProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | LookupProviderBase
 |  |  | HexillionProvider

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


HexillionProvider Constructor

HexillionProvider Constructor
Namespaces ► Sitecore.Analytics.Lookups ► HexillionProvider ► HexillionProvider()()()
Initializes a new instance of the HexillionProvider class
Declaration Syntax
C#
public HexillionProvider()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetInformationByIp Method (ipfrom, ipto)

GetInformationByIp Method (ipfrom, ipto)
Namespaces ► Sitecore.Analytics.Lookups ► HexillionProvider ► GetInformationByIp(String, String)
Declaration Syntax
C#
public override WhoIsInformation GetInformationByIp(
    string ipfrom,
    string ipto
)
Parameters
ipfrom (String)
ipto (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LookupData Class

LookupData Class
Namespaces ► Sitecore.Analytics.Lookups ► LookupData
Declaration Syntax
C#
public class LookupData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LookupData()()() | Initializes a new instance of the LookupData class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IpFrom |
 | IpId |
 | IpTo |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LookupData

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LookupData Constructor

LookupData Constructor
Namespaces ► Sitecore.Analytics.Lookups ► LookupData ► LookupData()()()
Initializes a new instance of the LookupData class
Declaration Syntax
C#
public LookupData()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpFrom Property

IpFrom Property
Namespaces ► Sitecore.Analytics.Lookups ► LookupData ► IpFrom
Declaration Syntax
C#
public string IpFrom { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpId Property

IpId Property
Namespaces ► Sitecore.Analytics.Lookups ► LookupData ► IpId
Declaration Syntax
C#
public Guid IpId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpTo Property

IpTo Property
Namespaces ► Sitecore.Analytics.Lookups ► LookupData ► IpTo
Declaration Syntax
C#
public string IpTo { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LookupManager Class

LookupManager Class
Namespaces ► Sitecore.Analytics.Lookups ► LookupManager
Declaration Syntax
C#
public class LookupManager
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LookupManager()()() | Initializes a new instance of the LookupManager class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInformationByIp(String, String) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Provider |
 | Providers |
 | ReverseDnsLookup(String) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LookupManager

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LookupManager Constructor

LookupManager Constructor
Namespaces ► Sitecore.Analytics.Lookups ► LookupManager ► LookupManager()()()
Initializes a new instance of the LookupManager class
Declaration Syntax
C#
public LookupManager()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetInformationByIp Method (ipFrom, ipTo)

GetInformationByIp Method (ipFrom, ipTo)
Namespaces ► Sitecore.Analytics.Lookups ► LookupManager ► GetInformationByIp(String, String)
Declaration Syntax
C#
public static WhoIsInformation GetInformationByIp(
    string ipFrom,
    string ipTo
)
Parameters
ipFrom (String)
ipTo (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Provider Property

Provider Property
Namespaces ► Sitecore.Analytics.Lookups ► LookupManager ► Provider
Declaration Syntax
C#
public static LookupProviderBase Provider { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Providers Property

Providers Property
Namespaces ► Sitecore.Analytics.Lookups ► LookupManager ► Providers
Declaration Syntax
C#
public static LookupProviderCollection Providers { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReverseDnsLookup Method (ip)

ReverseDnsLookup Method (ip)
Namespaces ► Sitecore.Analytics.Lookups ► LookupManager ► ReverseDnsLookup(String)
Declaration Syntax
C#
public static string ReverseDnsLookup(
    string ip
)
Parameters
ip (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LookupProviderBase Class

LookupProviderBase Class
Namespaces ► Sitecore.Analytics.Lookups ► LookupProviderBase
Declaration Syntax
C#
public abstract class LookupProviderBase : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LookupProviderBase()()() | Initializes a new instance of the LookupProviderBase class
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInformationByIp(String, String) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ReverseDnsLookup(String) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | LookupProviderBase
 |  |  | HexillionProvider
 |  |  | MaxMindProvider

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LookupProviderBase Constructor

LookupProviderBase Constructor
Namespaces ► Sitecore.Analytics.Lookups ► LookupProviderBase ► LookupProviderBase()()()
Initializes a new instance of the LookupProviderBase class
Declaration Syntax
C#
protected LookupProviderBase()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetInformationByIp Method (ipfrom, ipto)

GetInformationByIp Method (ipfrom, ipto)
Namespaces ► Sitecore.Analytics.Lookups ► LookupProviderBase ► GetInformationByIp(String, String)
Declaration Syntax
C#
public abstract WhoIsInformation GetInformationByIp(
    string ipfrom,
    string ipto
)
Parameters
ipfrom (String)
ipto (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReverseDnsLookup Method (ip)

ReverseDnsLookup Method (ip)
Namespaces ► Sitecore.Analytics.Lookups ► LookupProviderBase ► ReverseDnsLookup(String)
Declaration Syntax
C#
public virtual string ReverseDnsLookup(
    string ip
)
Parameters
ip (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LookupProviderCollection Class

LookupProviderCollection Class
Namespaces ► Sitecore.Analytics.Lookups ► LookupProviderCollection
Declaration Syntax
C#
public class LookupProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LookupProviderCollection()()() | Initializes a new instance of the LookupProviderCollection class
 | Add(ProviderBase) | (Overrides ProviderCollection.Add(ProviderBase).)
 | Add(LookupProviderBase) |
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | LookupProviderCollection

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LookupProviderCollection Constructor

LookupProviderCollection Constructor
Namespaces ► Sitecore.Analytics.Lookups ► LookupProviderCollection ► LookupProviderCollection()()()
Initializes a new instance of the LookupProviderCollection class
Declaration Syntax
C#
public LookupProviderCollection()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Add Method

Add Method
Namespaces ► Sitecore.Analytics.Lookups ► LookupProviderCollection ► Add()()()
Members
Icon | Member | Description
 | Add(ProviderBase) | (Overrides ProviderCollection.Add(ProviderBase).)
 | Add(LookupProviderBase) |

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Add Method (provider)

Add Method (provider)
Namespaces ► Sitecore.Analytics.Lookups ► LookupProviderCollection ► Add(LookupProviderBase)
Declaration Syntax
C#
public virtual void Add(
    LookupProviderBase provider
)
Parameters
provider (LookupProviderBase)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Add Method (provider)

Add Method (provider)
Namespaces ► Sitecore.Analytics.Lookups ► LookupProviderCollection ► Add(ProviderBase)
Declaration Syntax
C#
public override void Add(
    ProviderBase provider
)
Parameters
provider (ProviderBase)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Analytics.Lookups ► LookupProviderCollection ► Item[([(String])])
Declaration Syntax
C#
public virtual LookupProviderBase this[
    string name
] { get; }
Parameters
name (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LookupUpdater Class

LookupUpdater Class
Namespaces ► Sitecore.Analytics.Lookups ► LookupUpdater
Declaration Syntax
C#
public static class LookupUpdater
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Process(LookupData) |
Inheritance Hierarchy
Object
LookupUpdater

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (item)

Process Method (item)
Namespaces ► Sitecore.Analytics.Lookups ► LookupUpdater ► Process(LookupData)
Declaration Syntax
C#
public static void Process(
    LookupData item
)
Parameters
item (LookupData)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LookupWorker Class

LookupWorker Class
Namespaces ► Sitecore.Analytics.Lookups ► LookupWorker
Declaration Syntax
C#
public static class LookupWorker
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Start()()() |
Inheritance Hierarchy
Object
LookupWorker

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Start Method

Start Method
Namespaces ► Sitecore.Analytics.Lookups ► LookupWorker ► Start()()()
Declaration Syntax
C#
public static void Start()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MaxMindProvider Class

MaxMindProvider Class
Namespaces ► Sitecore.Analytics.Lookups ► MaxMindProvider
Declaration Syntax
C#
public class MaxMindProvider : LookupProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaxMindProvider()()() | Initializes a new instance of the MaxMindProvider class
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInformationByIp(String, String) | (Overrides LookupProviderBase.GetInformationByIp(String, String).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ReverseDnsLookup(String) | (Inherited from LookupProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | LookupProviderBase
 |  |  | MaxMindProvider

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MaxMindProvider Constructor

MaxMindProvider Constructor
Namespaces ► Sitecore.Analytics.Lookups ► MaxMindProvider ► MaxMindProvider()()()
Initializes a new instance of the MaxMindProvider class
Declaration Syntax
C#
public MaxMindProvider()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetInformationByIp Method (ipfrom, ipto)

GetInformationByIp Method (ipfrom, ipto)
Namespaces ► Sitecore.Analytics.Lookups ► MaxMindProvider ► GetInformationByIp(String, String)
Declaration Syntax
C#
public override WhoIsInformation GetInformationByIp(
    string ipfrom,
    string ipto
)
Parameters
ipfrom (String)
ipto (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


UpdateOperation Enumeration

UpdateOperation Enumeration
Namespaces ► Sitecore.Analytics.Lookups ► UpdateOperation
Declaration Syntax
C#
public enum UpdateOperation
Members
Member | Description
All |
Blanks |

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhoIsInformation Class

WhoIsInformation Class
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation
Declaration Syntax
C#
public class WhoIsInformation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhoIsInformation()()() | Initializes a new instance of the WhoIsInformation class
 | AreaCode |
 | City |
 | Country |
 | Dns |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Ip |
 | Isp |
 | Latitude |
 | Longitude |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MetroCode |
 | Name |
 | PostalCode |
 | Region |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Url |
Inheritance Hierarchy
Object
WhoIsInformation

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


WhoIsInformation Constructor

WhoIsInformation Constructor
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation ► WhoIsInformation()()()
Initializes a new instance of the WhoIsInformation class
Declaration Syntax
C#
public WhoIsInformation()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AreaCode Property

AreaCode Property
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation ► AreaCode
Declaration Syntax
C#
public string AreaCode { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


City Property

City Property
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation ► City
Declaration Syntax
C#
public string City { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Country Property

Country Property
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation ► Country
Declaration Syntax
C#
public string Country { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Dns Property

Dns Property
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation ► Dns
Declaration Syntax
C#
public string Dns { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Ip Property

Ip Property
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation ► Ip
Declaration Syntax
C#
public string Ip { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Isp Property

Isp Property
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation ► Isp
Declaration Syntax
C#
public string Isp { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Latitude Property

Latitude Property
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation ► Latitude
Declaration Syntax
C#
public string Latitude { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Longitude Property

Longitude Property
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation ► Longitude
Declaration Syntax
C#
public string Longitude { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MetroCode Property

MetroCode Property
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation ► MetroCode
Declaration Syntax
C#
public string MetroCode { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Name Property

Name Property
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation ► Name
Declaration Syntax
C#
public string Name { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PostalCode Property

PostalCode Property
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation ► PostalCode
Declaration Syntax
C#
public string PostalCode { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Region Property

Region Property
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation ► Region
Declaration Syntax
C#
public string Region { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Url Property

Url Property
Namespaces ► Sitecore.Analytics.Lookups ► WhoIsInformation ► Url
Declaration Syntax
C#
public string Url { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Media Namespace

Sitecore.Analytics.Media Namespace
Namespaces ► Sitecore.Analytics.Media
Declaration Syntax
C#
namespace Sitecore.Analytics.Media
Types
All Types Classes
Icon | Type | Description
 | MediaRequestEventHandler |


MediaRequestEventHandler Class

MediaRequestEventHandler Class
Namespaces ► Sitecore.Analytics.Media ► MediaRequestEventHandler
Declaration Syntax
C#
public class MediaRequestEventHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MediaRequestEventHandler()()() | Initializes a new instance of the MediaRequestEventHandler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnMediaRequest(Object, EventArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MediaRequestEventHandler

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MediaRequestEventHandler Constructor

MediaRequestEventHandler Constructor
Namespaces ► Sitecore.Analytics.Media ► MediaRequestEventHandler ► MediaRequestEventHandler()()()
Initializes a new instance of the MediaRequestEventHandler class
Declaration Syntax
C#
public MediaRequestEventHandler()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


OnMediaRequest Method (sender, args)

OnMediaRequest Method (sender, args)
Namespaces ► Sitecore.Analytics.Media ► MediaRequestEventHandler ► OnMediaRequest(Object, EventArgs)
Declaration Syntax
C#
public void OnMediaRequest(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
args (EventArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Pipelines Namespace

Sitecore.Analytics.Pipelines Namespace
Namespaces ► Sitecore.Analytics.Pipelines
Declaration Syntax
C#
namespace Sitecore.Analytics.Pipelines
Types
All Types Classes
Icon | Type | Description
 | SqlProcessorBase |


SqlProcessorBase Class

SqlProcessorBase Class
Namespaces ► Sitecore.Analytics.Pipelines ► SqlProcessorBase
Declaration Syntax
C#
public abstract class SqlProcessorBase
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SqlProcessorBase()()() | Initializes a new instance of the SqlProcessorBase class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Escape(String) |
 | ExecuteCommand(String, array<Object>[]()[]) |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Read(String, AnalyticsProvider..::.ReadDelegate) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | CreateSessionProcessor
 |  | SubmitProcessor
 |  | SubmitPageProcessor
 |  | SubmitTestsProcessor

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SqlProcessorBase Constructor

SqlProcessorBase Constructor
Namespaces ► Sitecore.Analytics.Pipelines ► SqlProcessorBase ► SqlProcessorBase()()()
Initializes a new instance of the SqlProcessorBase class
Declaration Syntax
C#
protected SqlProcessorBase()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Escape Method (value)

Escape Method (value)
Namespaces ► Sitecore.Analytics.Pipelines ► SqlProcessorBase ► Escape(String)
Declaration Syntax
C#
protected static string Escape(
    string value
)
Parameters
value (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ExecuteCommand Method (sql, parameters)

ExecuteCommand Method (sql, parameters)
Namespaces ► Sitecore.Analytics.Pipelines ► SqlProcessorBase ► ExecuteCommand(String, array<Object>[]()[])
Declaration Syntax
C#
protected static int ExecuteCommand(
    string sql,
    params Object[] parameters
)
Parameters
sql (String)
parameters (array< Object >[]()[])

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Read Method (sql, readDelegate)

Read Method (sql, readDelegate)
Namespaces ► Sitecore.Analytics.Pipelines ► SqlProcessorBase ► Read(String, AnalyticsProvider..::.ReadDelegate)
Declaration Syntax
C#
protected static void Read(
    string sql,
    AnalyticsProvider..::.ReadDelegate readDelegate
)
Parameters
sql (String)
readDelegate (AnalyticsProvider..::.ReadDelegate)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Pipelines.CreateSession Namespace

Sitecore.Analytics.Pipelines.CreateSession Namespace
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession
Declaration Syntax
C#
namespace Sitecore.Analytics.Pipelines.CreateSession
Types
All Types Classes
Icon | Type | Description
 | CreateSessionArgs |
 | CreateSessionPipeline |
 | CreateSessionProcessor |
 | GetBrowser |
 | GetGlobalSession |
 | GetIpAddress |
 | GetKeywords |
 | GetOperatingSystem |
 | GetReferringSite |
 | GetScreen |
 | InitializeSession |


CreateSessionArgs Class

CreateSessionArgs Class
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► CreateSessionArgs
Declaration Syntax
C#
[SerializableAttribute]
public class CreateSessionArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateSessionArgs()()() | Initializes a new instance of the CreateSessionArgs class
 | CreateSessionArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the CreateSessionArgs class
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | AnalyticsTracker |
 | CanBeRobot |
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | DataContext |
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Session |
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | CreateSessionArgs

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CreateSessionArgs Constructor

CreateSessionArgs Constructor
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► CreateSessionArgs ► CreateSessionArgs()()()
Members
Icon | Member | Description
 | CreateSessionArgs()()() | Initializes a new instance of the CreateSessionArgs class
 | CreateSessionArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the CreateSessionArgs class

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CreateSessionArgs Constructor

CreateSessionArgs Constructor
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► CreateSessionArgs ► CreateSessionArgs()()()
Initializes a new instance of the CreateSessionArgs class
Declaration Syntax
C#
public CreateSessionArgs()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CreateSessionArgs Constructor (info, context)

CreateSessionArgs Constructor (info, context)
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► CreateSessionArgs ► CreateSessionArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the CreateSessionArgs class
Declaration Syntax
C#
protected CreateSessionArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsTracker Property

AnalyticsTracker Property
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► CreateSessionArgs ► AnalyticsTracker
Declaration Syntax
C#
public AnalyticsTracker AnalyticsTracker { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CanBeRobot Property

CanBeRobot Property
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► CreateSessionArgs ► CanBeRobot
Declaration Syntax
C#
public bool CanBeRobot { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


DataContext Property

DataContext Property
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► CreateSessionArgs ► DataContext
Declaration Syntax
C#
public AnalyticsDataContext DataContext { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Session Property

Session Property
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► CreateSessionArgs ► Session
Declaration Syntax
C#
public Session Session { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CreateSessionPipeline Class

CreateSessionPipeline Class
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► CreateSessionPipeline
Declaration Syntax
C#
public class CreateSessionPipeline
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreateSessionPipeline()()() | Initializes a new instance of the CreateSessionPipeline class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(CreateSessionArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CreateSessionPipeline

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CreateSessionPipeline Constructor

CreateSessionPipeline Constructor
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► CreateSessionPipeline ► CreateSessionPipeline()()()
Initializes a new instance of the CreateSessionPipeline class
Declaration Syntax
C#
public CreateSessionPipeline()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► CreateSessionPipeline ► Run(CreateSessionArgs)
Declaration Syntax
C#
public static void Run(
    CreateSessionArgs args
)
Parameters
args (CreateSessionArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CreateSessionProcessor Class

CreateSessionProcessor Class
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► CreateSessionProcessor
Declaration Syntax
C#
public abstract class CreateSessionProcessor : SqlProcessorBase
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreateSessionProcessor()()() | Initializes a new instance of the CreateSessionProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(CreateSessionArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | CreateSessionProcessor
 |  |  | GetBrowser
 |  |  | GetGlobalSession
 |  |  | GetIpAddress
 |  |  | GetKeywords
 |  |  | GetOperatingSystem
 |  |  | GetReferringSite
 |  |  | GetScreen
 |  |  | InitializeSession

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CreateSessionProcessor Constructor

CreateSessionProcessor Constructor
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► CreateSessionProcessor ► CreateSessionProcessor()()()
Initializes a new instance of the CreateSessionProcessor class
Declaration Syntax
C#
protected CreateSessionProcessor()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► CreateSessionProcessor ► Process(CreateSessionArgs)
Declaration Syntax
C#
public abstract void Process(
    CreateSessionArgs args
)
Parameters
args (CreateSessionArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetBrowser Class

GetBrowser Class
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetBrowser
Declaration Syntax
C#
public class GetBrowser : CreateSessionProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetBrowser()()() | Initializes a new instance of the GetBrowser class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(CreateSessionArgs) | (Overrides CreateSessionProcessor.Process(CreateSessionArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | CreateSessionProcessor
 |  |  | GetBrowser

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetBrowser Constructor

GetBrowser Constructor
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetBrowser ► GetBrowser()()()
Initializes a new instance of the GetBrowser class
Declaration Syntax
C#
public GetBrowser()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetBrowser ► Process(CreateSessionArgs)
Declaration Syntax
C#
public override void Process(
    CreateSessionArgs args
)
Parameters
args (CreateSessionArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetGlobalSession Class

GetGlobalSession Class
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetGlobalSession
Declaration Syntax
C#
public class GetGlobalSession : CreateSessionProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetGlobalSession()()() | Initializes a new instance of the GetGlobalSession class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(CreateSessionArgs) | (Overrides CreateSessionProcessor.Process(CreateSessionArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | CreateSessionProcessor
 |  |  | GetGlobalSession

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetGlobalSession Constructor

GetGlobalSession Constructor
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetGlobalSession ► GetGlobalSession()()()
Initializes a new instance of the GetGlobalSession class
Declaration Syntax
C#
public GetGlobalSession()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetGlobalSession ► Process(CreateSessionArgs)
Declaration Syntax
C#
public override void Process(
    CreateSessionArgs args
)
Parameters
args (CreateSessionArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetIpAddress Class

GetIpAddress Class
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetIpAddress
Declaration Syntax
C#
public class GetIpAddress : CreateSessionProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetIpAddress()()() | Initializes a new instance of the GetIpAddress class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(CreateSessionArgs) | (Overrides CreateSessionProcessor.Process(CreateSessionArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | CreateSessionProcessor
 |  |  | GetIpAddress

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetIpAddress Constructor

GetIpAddress Constructor
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetIpAddress ► GetIpAddress()()()
Initializes a new instance of the GetIpAddress class
Declaration Syntax
C#
public GetIpAddress()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetIpAddress ► Process(CreateSessionArgs)
Declaration Syntax
C#
public override void Process(
    CreateSessionArgs args
)
Parameters
args (CreateSessionArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetKeywords Class

GetKeywords Class
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetKeywords
Declaration Syntax
C#
public class GetKeywords : CreateSessionProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetKeywords()()() | Initializes a new instance of the GetKeywords class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(CreateSessionArgs) | (Overrides CreateSessionProcessor.Process(CreateSessionArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | CreateSessionProcessor
 |  |  | GetKeywords

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetKeywords Constructor

GetKeywords Constructor
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetKeywords ► GetKeywords()()()
Initializes a new instance of the GetKeywords class
Declaration Syntax
C#
public GetKeywords()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetKeywords ► Process(CreateSessionArgs)
Declaration Syntax
C#
public override void Process(
    CreateSessionArgs args
)
Parameters
args (CreateSessionArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetOperatingSystem Class

GetOperatingSystem Class
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetOperatingSystem
Declaration Syntax
C#
public class GetOperatingSystem : CreateSessionProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetOperatingSystem()()() | Initializes a new instance of the GetOperatingSystem class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(CreateSessionArgs) | (Overrides CreateSessionProcessor.Process(CreateSessionArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | CreateSessionProcessor
 |  |  | GetOperatingSystem

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetOperatingSystem Constructor

GetOperatingSystem Constructor
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetOperatingSystem ► GetOperatingSystem()()()
Initializes a new instance of the GetOperatingSystem class
Declaration Syntax
C#
public GetOperatingSystem()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetOperatingSystem ► Process(CreateSessionArgs)
Declaration Syntax
C#
public override void Process(
    CreateSessionArgs args
)
Parameters
args (CreateSessionArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetReferringSite Class

GetReferringSite Class
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetReferringSite
Declaration Syntax
C#
public class GetReferringSite : CreateSessionProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetReferringSite()()() | Initializes a new instance of the GetReferringSite class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(CreateSessionArgs) | (Overrides CreateSessionProcessor.Process(CreateSessionArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | CreateSessionProcessor
 |  |  | GetReferringSite

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetReferringSite Constructor

GetReferringSite Constructor
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetReferringSite ► GetReferringSite()()()
Initializes a new instance of the GetReferringSite class
Declaration Syntax
C#
public GetReferringSite()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetReferringSite ► Process(CreateSessionArgs)
Declaration Syntax
C#
public override void Process(
    CreateSessionArgs args
)
Parameters
args (CreateSessionArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetScreen Class

GetScreen Class
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetScreen
Declaration Syntax
C#
public class GetScreen : CreateSessionProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetScreen()()() | Initializes a new instance of the GetScreen class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(CreateSessionArgs) | (Overrides CreateSessionProcessor.Process(CreateSessionArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | CreateSessionProcessor
 |  |  | GetScreen

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetScreen Constructor

GetScreen Constructor
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetScreen ► GetScreen()()()
Initializes a new instance of the GetScreen class
Declaration Syntax
C#
public GetScreen()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► GetScreen ► Process(CreateSessionArgs)
Declaration Syntax
C#
public override void Process(
    CreateSessionArgs args
)
Parameters
args (CreateSessionArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


InitializeSession Class

InitializeSession Class
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► InitializeSession
Declaration Syntax
C#
public class InitializeSession : CreateSessionProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InitializeSession()()() | Initializes a new instance of the InitializeSession class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(CreateSessionArgs) | (Overrides CreateSessionProcessor.Process(CreateSessionArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | CreateSessionProcessor
 |  |  | InitializeSession

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


InitializeSession Constructor

InitializeSession Constructor
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► InitializeSession ► InitializeSession()()()
Initializes a new instance of the InitializeSession class
Declaration Syntax
C#
public InitializeSession()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.CreateSession ► InitializeSession ► Process(CreateSessionArgs)
Declaration Syntax
C#
public override void Process(
    CreateSessionArgs args
)
Parameters
args (CreateSessionArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace

Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals
Declaration Syntax
C#
namespace Sitecore.Analytics.Pipelines.EvaluateConditionals
Types
All Types Classes
Icon | Type | Description
 | EvaluateConditionalsArgs |
 | EvaluateConditionalsPipeline |
 | EvaluateConditionalsProcessor |
 | EvaluateContains |
 | EvaluateEquals |


EvaluateConditionalsArgs Class

EvaluateConditionalsArgs Class
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsArgs
Declaration Syntax
C#
[SerializableAttribute]
public class EvaluateConditionalsArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EvaluateConditionalsArgs(Item, XElement, String) | Initializes a new instance of the EvaluateConditionalsArgs class
 | EvaluateConditionalsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the EvaluateConditionalsArgs class
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Element |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldName |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | Item |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Result |
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | EvaluateConditionalsArgs

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EvaluateConditionalsArgs Constructor

EvaluateConditionalsArgs Constructor
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsArgs ► EvaluateConditionalsArgs()()()
Members
Icon | Member | Description
 | EvaluateConditionalsArgs(Item, XElement, String) | Initializes a new instance of the EvaluateConditionalsArgs class
 | EvaluateConditionalsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the EvaluateConditionalsArgs class

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EvaluateConditionalsArgs Constructor (item, element, fieldName)

EvaluateConditionalsArgs Constructor (item, element, fieldName)
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsArgs ► EvaluateConditionalsArgs(Item, XElement, String)
Initializes a new instance of the EvaluateConditionalsArgs class
Declaration Syntax
C#
public EvaluateConditionalsArgs(
    Item item,
    XElement element,
    string fieldName
)
Parameters
item (Item)
element (XElement)
fieldName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EvaluateConditionalsArgs Constructor (info, context)

EvaluateConditionalsArgs Constructor (info, context)
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsArgs ► EvaluateConditionalsArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the EvaluateConditionalsArgs class
Declaration Syntax
C#
protected EvaluateConditionalsArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Element Property

Element Property
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsArgs ► Element
Declaration Syntax
C#
public XElement Element { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


FieldName Property

FieldName Property
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsArgs ► FieldName
Declaration Syntax
C#
public string FieldName { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Item Property

Item Property
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsArgs ► Item
Declaration Syntax
C#
public Item Item { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Result Property

Result Property
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsArgs ► Result
Declaration Syntax
C#
public bool Result { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Value Property

Value Property
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsArgs ► Value
Declaration Syntax
C#
public string Value { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EvaluateConditionalsPipeline Class

EvaluateConditionalsPipeline Class
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsPipeline
Declaration Syntax
C#
public class EvaluateConditionalsPipeline
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EvaluateConditionalsPipeline()()() | Initializes a new instance of the EvaluateConditionalsPipeline class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(EvaluateConditionalsArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
EvaluateConditionalsPipeline

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EvaluateConditionalsPipeline Constructor

EvaluateConditionalsPipeline Constructor
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsPipeline ► EvaluateConditionalsPipeline()()()
Initializes a new instance of the EvaluateConditionalsPipeline class
Declaration Syntax
C#
public EvaluateConditionalsPipeline()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsPipeline ► Run(EvaluateConditionalsArgs)
Declaration Syntax
C#
public static void Run(
    EvaluateConditionalsArgs args
)
Parameters
args (EvaluateConditionalsArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EvaluateConditionalsProcessor Class

EvaluateConditionalsProcessor Class
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsProcessor
Declaration Syntax
C#
public abstract class EvaluateConditionalsProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EvaluateConditionalsProcessor()()() | Initializes a new instance of the EvaluateConditionalsProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(EvaluateConditionalsArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EvaluateConditionalsProcessor
 |  | EvaluateContains
 |  | EvaluateEquals

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EvaluateConditionalsProcessor Constructor

EvaluateConditionalsProcessor Constructor
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsProcessor ► EvaluateConditionalsProcessor()()()
Initializes a new instance of the EvaluateConditionalsProcessor class
Declaration Syntax
C#
protected EvaluateConditionalsProcessor()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateConditionalsProcessor ► Process(EvaluateConditionalsArgs)
Declaration Syntax
C#
public abstract void Process(
    EvaluateConditionalsArgs args
)
Parameters
args (EvaluateConditionalsArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EvaluateContains Class

EvaluateContains Class
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateContains
Declaration Syntax
C#
public class EvaluateContains : EvaluateConditionalsProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EvaluateContains()()() | Initializes a new instance of the EvaluateContains class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(EvaluateConditionalsArgs) | (Overrides EvaluateConditionalsProcessor.Process(EvaluateConditionalsArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EvaluateConditionalsProcessor
 |  | EvaluateContains

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EvaluateContains Constructor

EvaluateContains Constructor
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateContains ► EvaluateContains()()()
Initializes a new instance of the EvaluateContains class
Declaration Syntax
C#
public EvaluateContains()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateContains ► Process(EvaluateConditionalsArgs)
Declaration Syntax
C#
public override void Process(
    EvaluateConditionalsArgs args
)
Parameters
args (EvaluateConditionalsArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EvaluateEquals Class

EvaluateEquals Class
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateEquals
Declaration Syntax
C#
public class EvaluateEquals : EvaluateConditionalsProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EvaluateEquals()()() | Initializes a new instance of the EvaluateEquals class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(EvaluateConditionalsArgs) | (Overrides EvaluateConditionalsProcessor.Process(EvaluateConditionalsArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EvaluateConditionalsProcessor
 |  | EvaluateEquals

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EvaluateEquals Constructor

EvaluateEquals Constructor
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateEquals ► EvaluateEquals()()()
Initializes a new instance of the EvaluateEquals class
Declaration Syntax
C#
public EvaluateEquals()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.EvaluateConditionals ► EvaluateEquals ► Process(EvaluateConditionalsArgs)
Declaration Syntax
C#
public override void Process(
    EvaluateConditionalsArgs args
)
Parameters
args (EvaluateConditionalsArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Pipelines.HttpRequest Namespace

Sitecore.Analytics.Pipelines.HttpRequest Namespace
Namespaces ► Sitecore.Analytics.Pipelines.HttpRequest
Declaration Syntax
C#
namespace Sitecore.Analytics.Pipelines.HttpRequest
Types
All Types Classes
Icon | Type | Description
 | EndAnalytics |
 | StartAnalytics |
 | StartDiagnostics |


EndAnalytics Class

EndAnalytics Class
Namespaces ► Sitecore.Analytics.Pipelines.HttpRequest ► EndAnalytics
Declaration Syntax
C#
public class EndAnalytics : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EndAnalytics()()() | Initializes a new instance of the EndAnalytics class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | EndAnalytics

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EndAnalytics Constructor

EndAnalytics Constructor
Namespaces ► Sitecore.Analytics.Pipelines.HttpRequest ► EndAnalytics ► EndAnalytics()()()
Initializes a new instance of the EndAnalytics class
Declaration Syntax
C#
public EndAnalytics()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.HttpRequest ► EndAnalytics ► Process(HttpRequestArgs)
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StartAnalytics Class

StartAnalytics Class
Namespaces ► Sitecore.Analytics.Pipelines.HttpRequest ► StartAnalytics
Declaration Syntax
C#
public class StartAnalytics
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | StartAnalytics()()() | Initializes a new instance of the StartAnalytics class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderLayoutArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
StartAnalytics

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StartAnalytics Constructor

StartAnalytics Constructor
Namespaces ► Sitecore.Analytics.Pipelines.HttpRequest ► StartAnalytics ► StartAnalytics()()()
Initializes a new instance of the StartAnalytics class
Declaration Syntax
C#
public StartAnalytics()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.HttpRequest ► StartAnalytics ► Process(RenderLayoutArgs)
Declaration Syntax
C#
public void Process(
    RenderLayoutArgs args
)
Parameters
args (RenderLayoutArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StartDiagnostics Class

StartDiagnostics Class
Namespaces ► Sitecore.Analytics.Pipelines.HttpRequest ► StartDiagnostics
Declaration Syntax
C#
public class StartDiagnostics : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | StartDiagnostics()()() | Initializes a new instance of the StartDiagnostics class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | StartDiagnostics

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StartDiagnostics Constructor

StartDiagnostics Constructor
Namespaces ► Sitecore.Analytics.Pipelines.HttpRequest ► StartDiagnostics ► StartDiagnostics()()()
Initializes a new instance of the StartDiagnostics class
Declaration Syntax
C#
public StartDiagnostics()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.HttpRequest ► StartDiagnostics ► Process(HttpRequestArgs)
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Pipelines.ParseReferrer Namespace

Sitecore.Analytics.Pipelines.ParseReferrer Namespace
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer
Declaration Syntax
C#
namespace Sitecore.Analytics.Pipelines.ParseReferrer
Types
All Types Classes
Icon | Type | Description
 | ParseGoogle |
 | ParseLiveSearch |
 | ParseReferrerArgs |
 | ParseReferrerPipeline |
 | ParseReferrerProcessor |
 | ParseYahoo |


ParseGoogle Class

ParseGoogle Class
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseGoogle
Declaration Syntax
C#
public class ParseGoogle : ParseReferrerProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ParseGoogle()()() | Initializes a new instance of the ParseGoogle class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ParseReferrerArgs) | (Overrides ParseReferrerProcessor.Process(ParseReferrerArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ParseReferrerProcessor
 |  | ParseGoogle

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ParseGoogle Constructor

ParseGoogle Constructor
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseGoogle ► ParseGoogle()()()
Initializes a new instance of the ParseGoogle class
Declaration Syntax
C#
public ParseGoogle()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseGoogle ► Process(ParseReferrerArgs)
Declaration Syntax
C#
public override void Process(
    ParseReferrerArgs args
)
Parameters
args (ParseReferrerArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ParseLiveSearch Class

ParseLiveSearch Class
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseLiveSearch
Declaration Syntax
C#
public class ParseLiveSearch : ParseReferrerProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ParseLiveSearch()()() | Initializes a new instance of the ParseLiveSearch class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ParseReferrerArgs) | (Overrides ParseReferrerProcessor.Process(ParseReferrerArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ParseReferrerProcessor
 |  | ParseLiveSearch

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ParseLiveSearch Constructor

ParseLiveSearch Constructor
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseLiveSearch ► ParseLiveSearch()()()
Initializes a new instance of the ParseLiveSearch class
Declaration Syntax
C#
public ParseLiveSearch()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseLiveSearch ► Process(ParseReferrerArgs)
Declaration Syntax
C#
public override void Process(
    ParseReferrerArgs args
)
Parameters
args (ParseReferrerArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ParseReferrerArgs Class

ParseReferrerArgs Class
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseReferrerArgs
Declaration Syntax
C#
[SerializableAttribute]
public class ParseReferrerArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ParseReferrerArgs()()() | Initializes a new instance of the ParseReferrerArgs class
 | ParseReferrerArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ParseReferrerArgs class
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | AnalyticsSession |
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UrlReferrer |
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ParseReferrerArgs

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ParseReferrerArgs Constructor

ParseReferrerArgs Constructor
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseReferrerArgs ► ParseReferrerArgs()()()
Members
Icon | Member | Description
 | ParseReferrerArgs()()() | Initializes a new instance of the ParseReferrerArgs class
 | ParseReferrerArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ParseReferrerArgs class

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ParseReferrerArgs Constructor

ParseReferrerArgs Constructor
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseReferrerArgs ► ParseReferrerArgs()()()
Initializes a new instance of the ParseReferrerArgs class
Declaration Syntax
C#
public ParseReferrerArgs()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ParseReferrerArgs Constructor (info, context)

ParseReferrerArgs Constructor (info, context)
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseReferrerArgs ► ParseReferrerArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the ParseReferrerArgs class
Declaration Syntax
C#
protected ParseReferrerArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsSession Property

AnalyticsSession Property
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseReferrerArgs ► AnalyticsSession
Declaration Syntax
C#
public AnalyticsSession AnalyticsSession { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


UrlReferrer Property

UrlReferrer Property
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseReferrerArgs ► UrlReferrer
Declaration Syntax
C#
public Uri UrlReferrer { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ParseReferrerPipeline Class

ParseReferrerPipeline Class
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseReferrerPipeline
Declaration Syntax
C#
public class ParseReferrerPipeline
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ParseReferrerPipeline()()() | Initializes a new instance of the ParseReferrerPipeline class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(ParseReferrerArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ParseReferrerPipeline

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ParseReferrerPipeline Constructor

ParseReferrerPipeline Constructor
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseReferrerPipeline ► ParseReferrerPipeline()()()
Initializes a new instance of the ParseReferrerPipeline class
Declaration Syntax
C#
public ParseReferrerPipeline()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseReferrerPipeline ► Run(ParseReferrerArgs)
Declaration Syntax
C#
public static void Run(
    ParseReferrerArgs args
)
Parameters
args (ParseReferrerArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ParseReferrerProcessor Class

ParseReferrerProcessor Class
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseReferrerProcessor
Declaration Syntax
C#
public abstract class ParseReferrerProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ParseReferrerProcessor()()() | Initializes a new instance of the ParseReferrerProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ParseReferrerArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ParseReferrerProcessor
 |  | ParseGoogle
 |  | ParseLiveSearch
 |  | ParseYahoo

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ParseReferrerProcessor Constructor

ParseReferrerProcessor Constructor
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseReferrerProcessor ► ParseReferrerProcessor()()()
Initializes a new instance of the ParseReferrerProcessor class
Declaration Syntax
C#
protected ParseReferrerProcessor()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseReferrerProcessor ► Process(ParseReferrerArgs)
Declaration Syntax
C#
public abstract void Process(
    ParseReferrerArgs args
)
Parameters
args (ParseReferrerArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ParseYahoo Class

ParseYahoo Class
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseYahoo
Declaration Syntax
C#
public class ParseYahoo : ParseReferrerProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ParseYahoo()()() | Initializes a new instance of the ParseYahoo class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ParseReferrerArgs) | (Overrides ParseReferrerProcessor.Process(ParseReferrerArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ParseReferrerProcessor
 |  | ParseYahoo

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ParseYahoo Constructor

ParseYahoo Constructor
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseYahoo ► ParseYahoo()()()
Initializes a new instance of the ParseYahoo class
Declaration Syntax
C#
public ParseYahoo()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.ParseReferrer ► ParseYahoo ► Process(ParseReferrerArgs)
Declaration Syntax
C#
public override void Process(
    ParseReferrerArgs args
)
Parameters
args (ParseReferrerArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Pipelines.RenderingConditions Namespace

Sitecore.Analytics.Pipelines.RenderingConditions Namespace
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions
Declaration Syntax
C#
namespace Sitecore.Analytics.Pipelines.RenderingConditions
Types
All Types Classes
Icon | Type | Description
 | EvaluateProfileKeys |
 | RenderingConditionArgs |
 | RenderingConditionPipeline |
 | RenderingConditionProcessor |


EvaluateProfileKeys Class

EvaluateProfileKeys Class
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► EvaluateProfileKeys
Declaration Syntax
C#
public class EvaluateProfileKeys : RenderingConditionProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EvaluateProfileKeys()()() | Initializes a new instance of the EvaluateProfileKeys class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderingConditionArgs) | (Overrides RenderingConditionProcessor.Process(RenderingConditionArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderingConditionProcessor
 |  | EvaluateProfileKeys

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EvaluateProfileKeys Constructor

EvaluateProfileKeys Constructor
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► EvaluateProfileKeys ► EvaluateProfileKeys()()()
Initializes a new instance of the EvaluateProfileKeys class
Declaration Syntax
C#
public EvaluateProfileKeys()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► EvaluateProfileKeys ► Process(RenderingConditionArgs)
Declaration Syntax
C#
public override void Process(
    RenderingConditionArgs args
)
Parameters
args (RenderingConditionArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RenderingConditionArgs Class

RenderingConditionArgs Class
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► RenderingConditionArgs
Declaration Syntax
C#
[SerializableAttribute]
public class RenderingConditionArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderingConditionArgs(XElement, RenderingReference) | Initializes a new instance of the RenderingConditionArgs class
 | RenderingConditionArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderingConditionArgs class
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CanRender |
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Element |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | RenderingReference |
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | RenderingConditionArgs

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RenderingConditionArgs Constructor

RenderingConditionArgs Constructor
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► RenderingConditionArgs ► RenderingConditionArgs()()()
Members
Icon | Member | Description
 | RenderingConditionArgs(XElement, RenderingReference) | Initializes a new instance of the RenderingConditionArgs class
 | RenderingConditionArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderingConditionArgs class

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RenderingConditionArgs Constructor (info, context)

RenderingConditionArgs Constructor (info, context)
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► RenderingConditionArgs ► RenderingConditionArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the RenderingConditionArgs class
Declaration Syntax
C#
protected RenderingConditionArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RenderingConditionArgs Constructor (element, renderingReference)

RenderingConditionArgs Constructor (element, renderingReference)
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► RenderingConditionArgs ► RenderingConditionArgs(XElement, RenderingReference)
Initializes a new instance of the RenderingConditionArgs class
Declaration Syntax
C#
public RenderingConditionArgs(
    XElement element,
    RenderingReference renderingReference
)
Parameters
element (XElement)
renderingReference (RenderingReference)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CanRender Property

CanRender Property
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► RenderingConditionArgs ► CanRender
Declaration Syntax
C#
public bool CanRender { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Element Property

Element Property
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► RenderingConditionArgs ► Element
Declaration Syntax
C#
public XElement Element { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RenderingReference Property

RenderingReference Property
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► RenderingConditionArgs ► RenderingReference
Declaration Syntax
C#
public RenderingReference RenderingReference { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RenderingConditionPipeline Class

RenderingConditionPipeline Class
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► RenderingConditionPipeline
Declaration Syntax
C#
public class RenderingConditionPipeline
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenderingConditionPipeline()()() | Initializes a new instance of the RenderingConditionPipeline class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(RenderingConditionArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RenderingConditionPipeline

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RenderingConditionPipeline Constructor

RenderingConditionPipeline Constructor
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► RenderingConditionPipeline ► RenderingConditionPipeline()()()
Initializes a new instance of the RenderingConditionPipeline class
Declaration Syntax
C#
public RenderingConditionPipeline()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► RenderingConditionPipeline ► Run(RenderingConditionArgs)
Declaration Syntax
C#
public static void Run(
    RenderingConditionArgs args
)
Parameters
args (RenderingConditionArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RenderingConditionProcessor Class

RenderingConditionProcessor Class
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► RenderingConditionProcessor
Declaration Syntax
C#
public abstract class RenderingConditionProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenderingConditionProcessor()()() | Initializes a new instance of the RenderingConditionProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderingConditionArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderingConditionProcessor
 |  | EvaluateProfileKeys

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RenderingConditionProcessor Constructor

RenderingConditionProcessor Constructor
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► RenderingConditionProcessor ► RenderingConditionProcessor()()()
Initializes a new instance of the RenderingConditionProcessor class
Declaration Syntax
C#
protected RenderingConditionProcessor()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.RenderingConditions ► RenderingConditionProcessor ► Process(RenderingConditionArgs)
Declaration Syntax
C#
public abstract void Process(
    RenderingConditionArgs args
)
Parameters
args (RenderingConditionArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Pipelines.StartTracking Namespace

Sitecore.Analytics.Pipelines.StartTracking Namespace
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking
Declaration Syntax
C#
namespace Sitecore.Analytics.Pipelines.StartTracking
Types
All Types Classes
Icon | Type | Description
 | ProcessItem |
 | ProcessQueryString |
 | StartTrackingArgs |
 | StartTrackingPipeline |
 | StartTrackingProcessor |


ProcessItem Class

ProcessItem Class
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► ProcessItem
Declaration Syntax
C#
public class ProcessItem : StartTrackingProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProcessItem()()() | Initializes a new instance of the ProcessItem class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(StartTrackingArgs) | (Overrides StartTrackingProcessor.Process(StartTrackingArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | StartTrackingProcessor
 |  | ProcessItem

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProcessItem Constructor

ProcessItem Constructor
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► ProcessItem ► ProcessItem()()()
Initializes a new instance of the ProcessItem class
Declaration Syntax
C#
public ProcessItem()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► ProcessItem ► Process(StartTrackingArgs)
Declaration Syntax
C#
public override void Process(
    StartTrackingArgs args
)
Parameters
args (StartTrackingArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProcessQueryString Class

ProcessQueryString Class
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► ProcessQueryString
Declaration Syntax
C#
public class ProcessQueryString : StartTrackingProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProcessQueryString()()() | Initializes a new instance of the ProcessQueryString class
 | AddTrigger(XmlNode) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(StartTrackingArgs) | (Overrides StartTrackingProcessor.Process(StartTrackingArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | StartTrackingProcessor
 |  | ProcessQueryString

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProcessQueryString Constructor

ProcessQueryString Constructor
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► ProcessQueryString ► ProcessQueryString()()()
Initializes a new instance of the ProcessQueryString class
Declaration Syntax
C#
public ProcessQueryString()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AddTrigger Method (configNode)

AddTrigger Method (configNode)
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► ProcessQueryString ► AddTrigger(XmlNode)
Declaration Syntax
C#
public virtual void AddTrigger(
    XmlNode configNode
)
Parameters
configNode (XmlNode)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► ProcessQueryString ► Process(StartTrackingArgs)
Declaration Syntax
C#
public override void Process(
    StartTrackingArgs args
)
Parameters
args (StartTrackingArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StartTrackingArgs Class

StartTrackingArgs Class
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► StartTrackingArgs
Declaration Syntax
C#
[SerializableAttribute]
public class StartTrackingArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StartTrackingArgs()()() | Initializes a new instance of the StartTrackingArgs class
 | StartTrackingArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the StartTrackingArgs class
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | StartTrackingArgs

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StartTrackingArgs Constructor

StartTrackingArgs Constructor
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► StartTrackingArgs ► StartTrackingArgs()()()
Members
Icon | Member | Description
 | StartTrackingArgs()()() | Initializes a new instance of the StartTrackingArgs class
 | StartTrackingArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the StartTrackingArgs class

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StartTrackingArgs Constructor

StartTrackingArgs Constructor
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► StartTrackingArgs ► StartTrackingArgs()()()
Initializes a new instance of the StartTrackingArgs class
Declaration Syntax
C#
public StartTrackingArgs()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StartTrackingArgs Constructor (info, context)

StartTrackingArgs Constructor (info, context)
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► StartTrackingArgs ► StartTrackingArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the StartTrackingArgs class
Declaration Syntax
C#
protected StartTrackingArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StartTrackingPipeline Class

StartTrackingPipeline Class
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► StartTrackingPipeline
Declaration Syntax
C#
public class StartTrackingPipeline
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | StartTrackingPipeline()()() | Initializes a new instance of the StartTrackingPipeline class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(StartTrackingArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
StartTrackingPipeline

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StartTrackingPipeline Constructor

StartTrackingPipeline Constructor
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► StartTrackingPipeline ► StartTrackingPipeline()()()
Initializes a new instance of the StartTrackingPipeline class
Declaration Syntax
C#
public StartTrackingPipeline()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► StartTrackingPipeline ► Run(StartTrackingArgs)
Declaration Syntax
C#
public static void Run(
    StartTrackingArgs args
)
Parameters
args (StartTrackingArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StartTrackingProcessor Class

StartTrackingProcessor Class
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► StartTrackingProcessor
Declaration Syntax
C#
public abstract class StartTrackingProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | StartTrackingProcessor()()() | Initializes a new instance of the StartTrackingProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(StartTrackingArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | StartTrackingProcessor
 |  | ProcessItem
 |  | ProcessQueryString

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StartTrackingProcessor Constructor

StartTrackingProcessor Constructor
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► StartTrackingProcessor ► StartTrackingProcessor()()()
Initializes a new instance of the StartTrackingProcessor class
Declaration Syntax
C#
protected StartTrackingProcessor()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.StartTracking ► StartTrackingProcessor ► Process(StartTrackingArgs)
Declaration Syntax
C#
public abstract void Process(
    StartTrackingArgs args
)
Parameters
args (StartTrackingArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Pipelines.Submit Namespace

Sitecore.Analytics.Pipelines.Submit Namespace
Namespaces ► Sitecore.Analytics.Pipelines.Submit
Declaration Syntax
C#
namespace Sitecore.Analytics.Pipelines.Submit
Types
All Types Classes
Icon | Type | Description
 | SubmitArgs |
 | SubmitGlobalSessionTags |
 | SubmitPages |
 | SubmitPipeline |
 | SubmitProcessor |
 | SubmitProfiles |
 | SubmitSession |


SubmitArgs Class

SubmitArgs Class
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitArgs
Declaration Syntax
C#
[SerializableAttribute]
public class SubmitArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubmitArgs()()() | Initializes a new instance of the SubmitArgs class
 | SubmitArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SubmitArgs class
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | AnalyticsTracker |
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | DataContext |
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Session |
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | SubmitArgs

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitArgs Constructor

SubmitArgs Constructor
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitArgs ► SubmitArgs()()()
Members
Icon | Member | Description
 | SubmitArgs()()() | Initializes a new instance of the SubmitArgs class
 | SubmitArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SubmitArgs class

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitArgs Constructor

SubmitArgs Constructor
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitArgs ► SubmitArgs()()()
Initializes a new instance of the SubmitArgs class
Declaration Syntax
C#
public SubmitArgs()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitArgs Constructor (info, context)

SubmitArgs Constructor (info, context)
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitArgs ► SubmitArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the SubmitArgs class
Declaration Syntax
C#
protected SubmitArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsTracker Property

AnalyticsTracker Property
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitArgs ► AnalyticsTracker
Declaration Syntax
C#
public AnalyticsTracker AnalyticsTracker { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


DataContext Property

DataContext Property
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitArgs ► DataContext
Declaration Syntax
C#
public AnalyticsDataContext DataContext { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Session Property

Session Property
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitArgs ► Session
Declaration Syntax
C#
public Session Session { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitGlobalSessionTags Class

SubmitGlobalSessionTags Class
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitGlobalSessionTags
Declaration Syntax
C#
public class SubmitGlobalSessionTags : SubmitProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitGlobalSessionTags()()() | Initializes a new instance of the SubmitGlobalSessionTags class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SubmitArgs) | (Overrides SubmitProcessor.Process(SubmitArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | SubmitProcessor
 |  |  | SubmitGlobalSessionTags

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitGlobalSessionTags Constructor

SubmitGlobalSessionTags Constructor
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitGlobalSessionTags ► SubmitGlobalSessionTags()()()
Initializes a new instance of the SubmitGlobalSessionTags class
Declaration Syntax
C#
public SubmitGlobalSessionTags()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitGlobalSessionTags ► Process(SubmitArgs)
Declaration Syntax
C#
public override void Process(
    SubmitArgs args
)
Parameters
args (SubmitArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitPages Class

SubmitPages Class
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitPages
Declaration Syntax
C#
public class SubmitPages : SubmitProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitPages()()() | Initializes a new instance of the SubmitPages class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SubmitArgs) | (Overrides SubmitProcessor.Process(SubmitArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | SubmitProcessor
 |  |  | SubmitPages

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitPages Constructor

SubmitPages Constructor
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitPages ► SubmitPages()()()
Initializes a new instance of the SubmitPages class
Declaration Syntax
C#
public SubmitPages()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitPages ► Process(SubmitArgs)
Declaration Syntax
C#
public override void Process(
    SubmitArgs args
)
Parameters
args (SubmitArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitPipeline Class

SubmitPipeline Class
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitPipeline
Declaration Syntax
C#
public class SubmitPipeline
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitPipeline()()() | Initializes a new instance of the SubmitPipeline class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(SubmitArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SubmitPipeline

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitPipeline Constructor

SubmitPipeline Constructor
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitPipeline ► SubmitPipeline()()()
Initializes a new instance of the SubmitPipeline class
Declaration Syntax
C#
public SubmitPipeline()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitPipeline ► Run(SubmitArgs)
Declaration Syntax
C#
public static void Run(
    SubmitArgs args
)
Parameters
args (SubmitArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitProcessor Class

SubmitProcessor Class
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitProcessor
Declaration Syntax
C#
public abstract class SubmitProcessor : SqlProcessorBase
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitProcessor()()() | Initializes a new instance of the SubmitProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SubmitArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | SubmitProcessor
 |  |  | SubmitGlobalSessionTags
 |  |  | SubmitPages
 |  |  | SubmitProfiles
 |  |  | SubmitSession

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitProcessor Constructor

SubmitProcessor Constructor
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitProcessor ► SubmitProcessor()()()
Initializes a new instance of the SubmitProcessor class
Declaration Syntax
C#
protected SubmitProcessor()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitProcessor ► Process(SubmitArgs)
Declaration Syntax
C#
public abstract void Process(
    SubmitArgs args
)
Parameters
args (SubmitArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitProfiles Class

SubmitProfiles Class
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitProfiles
Declaration Syntax
C#
public class SubmitProfiles : SubmitProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitProfiles()()() | Initializes a new instance of the SubmitProfiles class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SubmitArgs) | (Overrides SubmitProcessor.Process(SubmitArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | SubmitProcessor
 |  |  | SubmitProfiles

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitProfiles Constructor

SubmitProfiles Constructor
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitProfiles ► SubmitProfiles()()()
Initializes a new instance of the SubmitProfiles class
Declaration Syntax
C#
public SubmitProfiles()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitProfiles ► Process(SubmitArgs)
Declaration Syntax
C#
public override void Process(
    SubmitArgs args
)
Parameters
args (SubmitArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitSession Class

SubmitSession Class
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitSession
Declaration Syntax
C#
public class SubmitSession : SubmitProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitSession()()() | Initializes a new instance of the SubmitSession class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SubmitArgs) | (Overrides SubmitProcessor.Process(SubmitArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | SubmitProcessor
 |  |  | SubmitSession

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitSession Constructor

SubmitSession Constructor
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitSession ► SubmitSession()()()
Initializes a new instance of the SubmitSession class
Declaration Syntax
C#
public SubmitSession()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.Submit ► SubmitSession ► Process(SubmitArgs)
Declaration Syntax
C#
public override void Process(
    SubmitArgs args
)
Parameters
args (SubmitArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Pipelines.SubmitPage Namespace

Sitecore.Analytics.Pipelines.SubmitPage Namespace
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage
Declaration Syntax
C#
namespace Sitecore.Analytics.Pipelines.SubmitPage
Types
All Types Classes
Icon | Type | Description
 | SubmitCampaignEvents |
 | SubmitCampaignTestVariables |
 | SubmitPageArgs |
 | SubmitPageEvents |
 | SubmitPagePipeline |
 | SubmitPageProcessor |
 | SubmitTestVariables |


SubmitCampaignEvents Class

SubmitCampaignEvents Class
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitCampaignEvents
Declaration Syntax
C#
public class SubmitCampaignEvents : SubmitPageProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitCampaignEvents()()() | Initializes a new instance of the SubmitCampaignEvents class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SubmitPageArgs) | (Overrides SubmitPageProcessor.Process(SubmitPageArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | SubmitPageProcessor
 |  |  | SubmitCampaignEvents

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitCampaignEvents Constructor

SubmitCampaignEvents Constructor
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitCampaignEvents ► SubmitCampaignEvents()()()
Initializes a new instance of the SubmitCampaignEvents class
Declaration Syntax
C#
public SubmitCampaignEvents()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitCampaignEvents ► Process(SubmitPageArgs)
Declaration Syntax
C#
public override void Process(
    SubmitPageArgs args
)
Parameters
args (SubmitPageArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitCampaignTestVariables Class

SubmitCampaignTestVariables Class
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitCampaignTestVariables
Declaration Syntax
C#
public class SubmitCampaignTestVariables : SubmitPageProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitCampaignTestVariables()()() | Initializes a new instance of the SubmitCampaignTestVariables class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SubmitPageArgs) | (Overrides SubmitPageProcessor.Process(SubmitPageArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | SubmitPageProcessor
 |  |  | SubmitCampaignTestVariables

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitCampaignTestVariables Constructor

SubmitCampaignTestVariables Constructor
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitCampaignTestVariables ► SubmitCampaignTestVariables()()()
Initializes a new instance of the SubmitCampaignTestVariables class
Declaration Syntax
C#
public SubmitCampaignTestVariables()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitCampaignTestVariables ► Process(SubmitPageArgs)
Declaration Syntax
C#
public override void Process(
    SubmitPageArgs args
)
Parameters
args (SubmitPageArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitPageArgs Class

SubmitPageArgs Class
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPageArgs
Declaration Syntax
C#
[SerializableAttribute]
public class SubmitPageArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubmitPageArgs()()() | Initializes a new instance of the SubmitPageArgs class
 | SubmitPageArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SubmitPageArgs class
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | AnalyticsPage |
 | AnalyticsTracker |
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | DataContext |
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Page |
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | SubmitPageArgs

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitPageArgs Constructor

SubmitPageArgs Constructor
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPageArgs ► SubmitPageArgs()()()
Members
Icon | Member | Description
 | SubmitPageArgs()()() | Initializes a new instance of the SubmitPageArgs class
 | SubmitPageArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SubmitPageArgs class

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitPageArgs Constructor

SubmitPageArgs Constructor
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPageArgs ► SubmitPageArgs()()()
Initializes a new instance of the SubmitPageArgs class
Declaration Syntax
C#
public SubmitPageArgs()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitPageArgs Constructor (info, context)

SubmitPageArgs Constructor (info, context)
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPageArgs ► SubmitPageArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the SubmitPageArgs class
Declaration Syntax
C#
protected SubmitPageArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsPage Property

AnalyticsPage Property
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPageArgs ► AnalyticsPage
Declaration Syntax
C#
public AnalyticsPage AnalyticsPage { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsTracker Property

AnalyticsTracker Property
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPageArgs ► AnalyticsTracker
Declaration Syntax
C#
public AnalyticsTracker AnalyticsTracker { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


DataContext Property

DataContext Property
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPageArgs ► DataContext
Declaration Syntax
C#
public AnalyticsDataContext DataContext { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Page Property

Page Property
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPageArgs ► Page
Declaration Syntax
C#
public Page Page { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitPageEvents Class

SubmitPageEvents Class
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPageEvents
Declaration Syntax
C#
public class SubmitPageEvents : SubmitPageProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitPageEvents()()() | Initializes a new instance of the SubmitPageEvents class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SubmitPageArgs) | (Overrides SubmitPageProcessor.Process(SubmitPageArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | SubmitPageProcessor
 |  |  | SubmitPageEvents

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitPageEvents Constructor

SubmitPageEvents Constructor
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPageEvents ► SubmitPageEvents()()()
Initializes a new instance of the SubmitPageEvents class
Declaration Syntax
C#
public SubmitPageEvents()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPageEvents ► Process(SubmitPageArgs)
Declaration Syntax
C#
public override void Process(
    SubmitPageArgs args
)
Parameters
args (SubmitPageArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitPagePipeline Class

SubmitPagePipeline Class
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPagePipeline
Declaration Syntax
C#
public class SubmitPagePipeline
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitPagePipeline()()() | Initializes a new instance of the SubmitPagePipeline class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(SubmitPageArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SubmitPagePipeline

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitPagePipeline Constructor

SubmitPagePipeline Constructor
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPagePipeline ► SubmitPagePipeline()()()
Initializes a new instance of the SubmitPagePipeline class
Declaration Syntax
C#
public SubmitPagePipeline()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPagePipeline ► Run(SubmitPageArgs)
Declaration Syntax
C#
public static void Run(
    SubmitPageArgs args
)
Parameters
args (SubmitPageArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitPageProcessor Class

SubmitPageProcessor Class
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPageProcessor
Declaration Syntax
C#
public abstract class SubmitPageProcessor : SqlProcessorBase
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitPageProcessor()()() | Initializes a new instance of the SubmitPageProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SubmitPageArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | SubmitPageProcessor
 |  |  | SubmitCampaignEvents
 |  |  | SubmitCampaignTestVariables
 |  |  | SubmitPageEvents
 |  |  | SubmitTestVariables
 |  |  | SubmitTestVariables

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitPageProcessor Constructor

SubmitPageProcessor Constructor
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPageProcessor ► SubmitPageProcessor()()()
Initializes a new instance of the SubmitPageProcessor class
Declaration Syntax
C#
protected SubmitPageProcessor()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitPageProcessor ► Process(SubmitPageArgs)
Declaration Syntax
C#
public abstract void Process(
    SubmitPageArgs args
)
Parameters
args (SubmitPageArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitTestVariables Class

SubmitTestVariables Class
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitTestVariables
Declaration Syntax
C#
public class SubmitTestVariables : SubmitPageProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitTestVariables()()() | Initializes a new instance of the SubmitTestVariables class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SubmitPageArgs) | (Overrides SubmitPageProcessor.Process(SubmitPageArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | SubmitPageProcessor
 |  |  | SubmitTestVariables

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitTestVariables Constructor

SubmitTestVariables Constructor
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitTestVariables ► SubmitTestVariables()()()
Initializes a new instance of the SubmitTestVariables class
Declaration Syntax
C#
public SubmitTestVariables()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.SubmitPage ► SubmitTestVariables ► Process(SubmitPageArgs)
Declaration Syntax
C#
public override void Process(
    SubmitPageArgs args
)
Parameters
args (SubmitPageArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Pipelines.SubmitTests Namespace

Sitecore.Analytics.Pipelines.SubmitTests Namespace
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests
Declaration Syntax
C#
namespace Sitecore.Analytics.Pipelines.SubmitTests
Types
All Types Classes
Icon | Type | Description
 | SubmitTestsArgs |
 | SubmitTestsPipeline |
 | SubmitTestsProcessor |
 | SubmitTestVariables |


SubmitTestsArgs Class

SubmitTestsArgs Class
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestsArgs
Declaration Syntax
C#
[SerializableAttribute]
public class SubmitTestsArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubmitTestsArgs()()() | Initializes a new instance of the SubmitTestsArgs class
 | SubmitTestsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SubmitTestsArgs class
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | AnalyticsTracker |
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | DataContext |
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | SubmitTestsArgs

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitTestsArgs Constructor

SubmitTestsArgs Constructor
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestsArgs ► SubmitTestsArgs()()()
Members
Icon | Member | Description
 | SubmitTestsArgs()()() | Initializes a new instance of the SubmitTestsArgs class
 | SubmitTestsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SubmitTestsArgs class

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitTestsArgs Constructor

SubmitTestsArgs Constructor
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestsArgs ► SubmitTestsArgs()()()
Initializes a new instance of the SubmitTestsArgs class
Declaration Syntax
C#
public SubmitTestsArgs()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitTestsArgs Constructor (info, context)

SubmitTestsArgs Constructor (info, context)
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestsArgs ► SubmitTestsArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the SubmitTestsArgs class
Declaration Syntax
C#
protected SubmitTestsArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
context (StreamingContext)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsTracker Property

AnalyticsTracker Property
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestsArgs ► AnalyticsTracker
Declaration Syntax
C#
public AnalyticsTracker AnalyticsTracker { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


DataContext Property

DataContext Property
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestsArgs ► DataContext
Declaration Syntax
C#
public AnalyticsDataContext DataContext { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitTestsPipeline Class

SubmitTestsPipeline Class
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestsPipeline
Declaration Syntax
C#
public class SubmitTestsPipeline
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitTestsPipeline()()() | Initializes a new instance of the SubmitTestsPipeline class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(SubmitTestsArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SubmitTestsPipeline

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitTestsPipeline Constructor

SubmitTestsPipeline Constructor
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestsPipeline ► SubmitTestsPipeline()()()
Initializes a new instance of the SubmitTestsPipeline class
Declaration Syntax
C#
public SubmitTestsPipeline()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestsPipeline ► Run(SubmitTestsArgs)
Declaration Syntax
C#
public static void Run(
    SubmitTestsArgs args
)
Parameters
args (SubmitTestsArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitTestsProcessor Class

SubmitTestsProcessor Class
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestsProcessor
Declaration Syntax
C#
public abstract class SubmitTestsProcessor : SqlProcessorBase
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitTestsProcessor()()() | Initializes a new instance of the SubmitTestsProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SubmitTestsArgs) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | SubmitTestsProcessor

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitTestsProcessor Constructor

SubmitTestsProcessor Constructor
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestsProcessor ► SubmitTestsProcessor()()()
Initializes a new instance of the SubmitTestsProcessor class
Declaration Syntax
C#
protected SubmitTestsProcessor()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestsProcessor ► Process(SubmitTestsArgs)
Declaration Syntax
C#
public abstract void Process(
    SubmitTestsArgs args
)
Parameters
args (SubmitTestsArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitTestVariables Class

SubmitTestVariables Class
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestVariables
Declaration Syntax
C#
public class SubmitTestVariables : SubmitPageProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SubmitTestVariables()()() | Initializes a new instance of the SubmitTestVariables class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SubmitPageArgs) | (Overrides SubmitPageProcessor.Process(SubmitPageArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlProcessorBase
 |  | SubmitPageProcessor
 |  |  | SubmitTestVariables

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubmitTestVariables Constructor

SubmitTestVariables Constructor
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestVariables ► SubmitTestVariables()()()
Initializes a new instance of the SubmitTestVariables class
Declaration Syntax
C#
public SubmitTestVariables()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Analytics.Pipelines.SubmitTests ► SubmitTestVariables ► Process(SubmitPageArgs)
Declaration Syntax
C#
public override void Process(
    SubmitPageArgs args
)
Parameters
args (SubmitPageArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Reports Namespace

Sitecore.Analytics.Reports Namespace
Namespaces ► Sitecore.Analytics.Reports
Declaration Syntax
C#
namespace Sitecore.Analytics.Reports
Types
All Types Classes
Icon | Type | Description
 | ReportExporter |
 | ReportFactory |
 | ReportMailer |


ReportExporter Class

ReportExporter Class
Namespaces ► Sitecore.Analytics.Reports ► ReportExporter
Declaration Syntax
C#
public static class ReportExporter
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Export(StiReport, StiExportFormat, String, array<Object>[]()[]) |
Inheritance Hierarchy
Object
ReportExporter

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Export Method (report, exportFormat, reportTitle, parameters)

Export Method (report, exportFormat, reportTitle, parameters)
Namespaces ► Sitecore.Analytics.Reports ► ReportExporter ► Export(StiReport, StiExportFormat, String, array<Object>[]()[])
Declaration Syntax
C#
public static string Export(
    StiReport report,
    StiExportFormat exportFormat,
    string reportTitle,
    params Object[] parameters
)
Parameters
report (StiReport)
exportFormat (StiExportFormat)
reportTitle (String)
parameters (array< Object >[]()[])

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReportFactory Class

ReportFactory Class
Namespaces ► Sitecore.Analytics.Reports ► ReportFactory
Declaration Syntax
C#
public static class ReportFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetReport(Database, String, ID, String, DateTime, DateTime, XDocument) |
Inheritance Hierarchy
Object
ReportFactory

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetReport Method (database, reportFileName, reportItemId, email, startDate, endDate, filters)

GetReport Method (database, reportFileName, reportItemId, email, startDate, endDate, filters)
Namespaces ► Sitecore.Analytics.Reports ► ReportFactory ► GetReport(Database, String, ID, String, DateTime, DateTime, XDocument)
Declaration Syntax
C#
public static StiReport GetReport(
    Database database,
    string reportFileName,
    ID reportItemId,
    string email,
    DateTime startDate,
    DateTime endDate,
    XDocument filters
)
Parameters
database (Database)
reportFileName (String)
reportItemId (ID)
email (String)
startDate (DateTime)
endDate (DateTime)
filters (XDocument)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReportMailer Class

ReportMailer Class
Namespaces ► Sitecore.Analytics.Reports ► ReportMailer
Declaration Syntax
C#
public class ReportMailer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ReportMailer()()() | Initializes a new instance of the ReportMailer class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Mail(String, IEnumerable<(Of <(String>)>), String, Boolean, Boolean) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ReportMailer

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ReportMailer Constructor

ReportMailer Constructor
Namespaces ► Sitecore.Analytics.Reports ► ReportMailer ► ReportMailer()()()
Initializes a new instance of the ReportMailer class
Declaration Syntax
C#
public ReportMailer()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Mail Method (exportedReportFileName, recipients, reportTitle, embedFile, deleteFile)

Mail Method (exportedReportFileName, recipients, reportTitle, embedFile, deleteFile)
Namespaces ► Sitecore.Analytics.Reports ► ReportMailer ► Mail(String, IEnumerable<(Of <(String>)>), String, Boolean, Boolean)
Declaration Syntax
C#
public static bool Mail(
    string exportedReportFileName,
    IEnumerable<string> recipients,
    string reportTitle,
    bool embedFile,
    bool deleteFile
)
Parameters
exportedReportFileName (String)
recipients (IEnumerable<(Of <(String>)>))
reportTitle (String)
embedFile (Boolean)
deleteFile (Boolean)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Rules.Conditions Namespace

Sitecore.Analytics.Rules.Conditions Namespace
Namespaces ► Sitecore.Analytics.Rules.Conditions
Declaration Syntax
C#
namespace Sitecore.Analytics.Rules.Conditions
Types
All Types Classes Interfaces
Icon | Type | Description
 | AreaCodeCondition<(Of <(T>)>) |
 | CityCondition<(Of <(T>)>) |
 | CountryCondition<(Of <(T>)>) |
 | DnsCondition<(Of <(T>)>) |
 | GlobalVisitNoCondition<(Of <(T>)>) |
 | IfMultiVariateTestEnabled<(Of <(T>)>) |
 | IMultiVariateTestStrategy |
 | IpAddressCondition<(Of <(T>)>) |
 | IpBaseCondition<(Of <(T>)>) |
 | IpOwnerBaseCondition<(Of <(T>)>) |
 | IspNameCondition<(Of <(T>)>) |
 | KeywordsCondition<(Of <(T>)>) |
 | LatitudeCondition<(Of <(T>)>) |
 | LongitudeCondition<(Of <(T>)>) |
 | MetroCodeCondition<(Of <(T>)>) |
 | NameCondition<(Of <(T>)>) |
 | PageIndexCondition<(Of <(T>)>) |
 | PostalCodeCondition<(Of <(T>)>) |
 | ProcessMultiVariateTestAction<(Of <(T>)>) |
 | ProfileCondition<(Of <(T>)>) |
 | RegionCondition<(Of <(T>)>) |
 | StickyMultiVariateTestStrategy |
 | VisitorIdentificationCondition<(Of <(T>)>) |


AreaCodeCondition(T) Class

AreaCodeCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► AreaCodeCondition<(Of <(T>)>)
Declaration Syntax
C#
public class AreaCodeCondition<T> : IpBaseCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AreaCodeCondition<(Of <(T>)>)()()() | Initializes a new instance of the AreaCodeCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | (Inherited from IpBaseCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetColumnValue(IP) | (Overrides IpBaseCondition <(Of <(T>)>).GetColumnValue(IP).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from IpBaseCondition<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <(T>)>)
 |  | WhenCondition <(Of <(T>)>)
 |  |  | StringOperatorCondition <(Of <(T>)>)
 |  |  |  | IpBaseCondition <(Of <(T>)>)
 |  |  |  |  | AreaCodeCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AreaCodeCondition(T) Constructor

AreaCodeCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► AreaCodeCondition<(Of <(T>)>) ► AreaCodeCondition<(Of <(T>)>)()()()
Initializes a new instance of the AreaCodeCondition<(Of <(T>)>) class
Declaration Syntax
C#
public AreaCodeCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetColumnValue Method (ip)

GetColumnValue Method (ip)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► AreaCodeCondition<(Of <(T>)>) ► GetColumnValue(IP)
Declaration Syntax
C#
protected override string GetColumnValue(
    IP ip
)
Parameters
ip (IP)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CityCondition(T) Class

CityCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► CityCondition<(Of <(T>)>)
Declaration Syntax
C#
public class CityCondition<T> : IpBaseCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CityCondition<(Of <(T>)>)()()() | Initializes a new instance of the CityCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | (Inherited from IpBaseCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetColumnValue(IP) | (Overrides IpBaseCondition <(Of <( T >)>).GetColumnValue(IP).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from IpBaseCondition<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | StringOperatorCondition <(Of <( T >)>)
 |  |  |  | IpBaseCondition <(Of <( T >)>)
 |  |  |  |  | CityCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CityCondition(T) Constructor

CityCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► CityCondition<(Of <(T>)>) ► CityCondition<(Of <(T>)>)()()()
Initializes a new instance of the CityCondition<(Of <(T>)>) class
Declaration Syntax
C#
public CityCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetColumnValue Method (ip)

GetColumnValue Method (ip)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► CityCondition<(Of <(T>)>) ► GetColumnValue(IP)
Declaration Syntax
C#
protected override string GetColumnValue(
    IP ip
)
Parameters
ip (IP)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CountryCondition(T) Class

CountryCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► CountryCondition<(Of <(T>)>)
Declaration Syntax
C#
public class CountryCondition<T> : IpOwnerBaseCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CountryCondition<(Of <(T>)>)()()() | Initializes a new instance of the CountryCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | (Inherited from IpOwnerBaseCondition<(Of <(T>)>).)
 | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetColumnValue(IPOwner) | (Overrides IpOwnerBaseCondition <(Of <(T>)>).GetColumnValue(IPOwner).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from IpOwnerBaseCondition<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | StringOperatorCondition <(Of <( T >)>)
 |  |  |  | IpOwnerBaseCondition <(Of <(T>)>)
 |  |  |  |  | CountryCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


CountryCondition(T) Constructor

CountryCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► CountryCondition<(Of <(T>)>) ► CountryCondition<(Of <(T>)>)()()()
Initializes a new instance of the CountryCondition<(Of <(T>)>) class
Declaration Syntax
C#
public CountryCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetColumnValue Method (ip)

GetColumnValue Method (ip)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► CountryCondition<(Of <(T>)>) ► GetColumnValue(IPOwner)
Declaration Syntax
C#
protected override string GetColumnValue(
    IPOwner ip
)
Parameters
ip (IPOwner)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


DnsCondition(T) Class

DnsCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► DnsCondition<(Of <(T>)>)
Declaration Syntax
C#
public class DnsCondition<T> : IpBaseCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DnsCondition<(Of <(T>)>)()()() | Initializes a new instance of the DnsCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | (Inherited from IpBaseCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetColumnValue(IP) | (Overrides IpBaseCondition <(Of <( T >)>).GetColumnValue(IP).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from IpBaseCondition<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | StringOperatorCondition <(Of <( T >)>)
 |  |  |  | IpBaseCondition <(Of <( T >)>)
 |  |  |  |  | DnsCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


DnsCondition(T) Constructor

DnsCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► DnsCondition<(Of <(T>)>) ► DnsCondition<(Of <(T>)>)()()()
Initializes a new instance of the DnsCondition<(Of <(T>)>) class
Declaration Syntax
C#
public DnsCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetColumnValue Method (ip)

GetColumnValue Method (ip)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► DnsCondition<(Of <(T>)>) ► GetColumnValue(IP)
Declaration Syntax
C#
protected override string GetColumnValue(
    IP ip
)
Parameters
ip (IP)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GlobalVisitNoCondition(T) Class

GlobalVisitNoCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► GlobalVisitNoCondition<(Of <(T>)>)
Declaration Syntax
C#
public class GlobalVisitNoCondition<T> : OperatorCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GlobalVisitNoCondition<(Of <(T>)>)()()() | Initializes a new instance of the GlobalVisitNoCondition<(Of <(T>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) |
 | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from OperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | No |
 | OperatorId | Gets or sets the operator id. (Inherited from OperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | OperatorCondition <(Of <(T>)>)
 |  |  |  | GlobalVisitNoCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GlobalVisitNoCondition(T) Constructor

GlobalVisitNoCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► GlobalVisitNoCondition<(Of <(T>)>) ► GlobalVisitNoCondition<(Of <(T>)>)()()()
Initializes a new instance of the GlobalVisitNoCondition<(Of <(T>)>) class
Declaration Syntax
C#
public GlobalVisitNoCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (ruleContext)

Execute Method (ruleContext)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► GlobalVisitNoCondition<(Of <(T>)>) ► Execute(T)
Declaration Syntax
C#
protected virtual bool Execute(
    T ruleContext
)
Parameters
ruleContext (T)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


No Property

No Property
Namespaces ► Sitecore.Analytics.Rules.Conditions ► GlobalVisitNoCondition<(Of <(T>)>) ► No
Declaration Syntax
C#
public int No { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IfMultiVariateTestEnabled(T) Class

IfMultiVariateTestEnabled<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IfMultiVariateTestEnabled<(Of <(T>)>)
Declaration Syntax
C#
public class IfMultiVariateTestEnabled<T> : WhenCondition<T>
where T : ConditionalRenderingsRuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IfMultiVariateTestEnabled<(Of <(T>)>)()()() | Initializes a new instance of the IfMultiVariateTestEnabled<(Of <(T>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | (Overrides WhenCondition <(Of <(T>)>).Execute(T).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <(T>)>)
 |  | WhenCondition <(Of <(T>)>)
 |  |  | IfMultiVariateTestEnabled<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IfMultiVariateTestEnabled(T) Constructor

IfMultiVariateTestEnabled<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IfMultiVariateTestEnabled<(Of <(T>)>) ► IfMultiVariateTestEnabled<(Of <(T>)>)()()()
Initializes a new instance of the IfMultiVariateTestEnabled<(Of <(T>)>) class
Declaration Syntax
C#
public IfMultiVariateTestEnabled()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (ruleContext)

Execute Method (ruleContext)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IfMultiVariateTestEnabled<(Of <(T>)>) ► Execute(T)
Declaration Syntax
C#
protected override bool Execute(
    T ruleContext
)
Parameters
ruleContext (T)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IMultiVariateTestStrategy Interface

IMultiVariateTestStrategy Interface
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IMultiVariateTestStrategy
Declaration Syntax
C#
public interface IMultiVariateTestStrategy
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetTestVariableItem(Item, Item) |

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetTestVariableItem Method (item, multiVariateTest)

GetTestVariableItem Method (item, multiVariateTest)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IMultiVariateTestStrategy ► GetTestVariableItem(Item, Item)
Declaration Syntax
C#
Item GetTestVariableItem(
    Item item,
    Item multiVariateTest
)
Parameters
item (Item)
multiVariateTest (Item)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpAddressCondition(T) Class

IpAddressCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IpAddressCondition<(Of <(T>)>)
Declaration Syntax
C#
public class IpAddressCondition<T> : IpBaseCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IpAddressCondition<(Of <(T>)>)()()() | Initializes a new instance of the IpAddressCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | (Inherited from IpBaseCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetColumnValue(IP) | (Overrides IpBaseCondition <(Of <( T >)>).GetColumnValue(IP).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from IpBaseCondition<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | StringOperatorCondition <(Of <( T >)>)
 |  |  |  | IpBaseCondition <(Of <( T >)>)
 |  |  |  |  | IpAddressCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpAddressCondition(T) Constructor

IpAddressCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IpAddressCondition<(Of <(T>)>) ► IpAddressCondition<(Of <(T>)>)()()()
Initializes a new instance of the IpAddressCondition<(Of <(T>)>) class
Declaration Syntax
C#
public IpAddressCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetColumnValue Method (ip)

GetColumnValue Method (ip)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IpAddressCondition<(Of <(T>)>) ► GetColumnValue(IP)
Declaration Syntax
C#
protected override string GetColumnValue(
    IP ip
)
Parameters
ip (IP)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpBaseCondition(T) Class

IpBaseCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IpBaseCondition<(Of <(T>)>)
Declaration Syntax
C#
public abstract class IpBaseCondition<T> : StringOperatorCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IpBaseCondition<(Of <(T>)>)()()() | Initializes a new instance of the IpBaseCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | (Overrides WhenCondition <(Of <(T>)>).Execute(T).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetColumnValue(IP) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
 | RuleCondition <(Of <(T>)>)
 |  | WhenCondition <(Of <(T>)>)
 |  |  | StringOperatorCondition <(Of <(T>)>)
 |  |  |  | IpBaseCondition<(Of <(T>)>)
 |  |  |  |  | AreaCodeCondition<(Of <(T>)>)
 |  |  |  |  | CityCondition<(Of <(T>)>)
 |  |  |  |  | DnsCondition<(Of <(T>)>)
 |  |  |  |  | IpAddressCondition<(Of <(T>)>)
 |  |  |  |  | IspNameCondition<(Of <(T>)>)
 |  |  |  |  | LatitudeCondition<(Of <(T>)>)
 |  |  |  |  | LongitudeCondition<(Of <(T>)>)
 |  |  |  |  | MetroCodeCondition<(Of <(T>)>)
 |  |  |  |  | PostalCodeCondition<(Of <(T>)>)
 |  |  |  |  | RegionCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpBaseCondition(T) Constructor

IpBaseCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IpBaseCondition<(Of <(T>)>) ► IpBaseCondition<(Of <(T>)>)()()()
Initializes a new instance of the IpBaseCondition<(Of <(T>)>) class
Declaration Syntax
C#
protected IpBaseCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (ruleContext)

Execute Method (ruleContext)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IpBaseCondition<(Of <(T>)>) ► Execute(T)
Declaration Syntax
C#
protected override bool Execute(
    T ruleContext
)
Parameters
ruleContext (T)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetColumnValue Method (ip)

GetColumnValue Method (ip)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IpBaseCondition<(Of <(T>)>) ► GetColumnValue(IP)
Declaration Syntax
C#
protected abstract string GetColumnValue(
    IP ip
)
Parameters
ip (IP)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Value Property

Value Property
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IpBaseCondition<(Of <(T>)>) ► Value
Declaration Syntax
C#
public string Value { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpOwnerBaseCondition(T) Class

IpOwnerBaseCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IpOwnerBaseCondition<(Of <(T>)>)
Declaration Syntax
C#
public abstract class IpOwnerBaseCondition<T> : StringOperatorCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IpOwnerBaseCondition<(Of <(T>)>)()()() | Initializes a new instance of the IpOwnerBaseCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) |
 | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetColumnValue(IPOwner) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | StringOperatorCondition <(Of <( T >)>)
 |  |  |  | IpOwnerBaseCondition<(Of <(T>)>)
 |  |  |  |  | CountryCondition<(Of <(T>)>)
 |  |  |  |  | NameCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IpOwnerBaseCondition(T) Constructor

IpOwnerBaseCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IpOwnerBaseCondition<(Of <(T>)>) ► IpOwnerBaseCondition<(Of <(T>)>)()()()
Initializes a new instance of the IpOwnerBaseCondition<(Of <(T>)>) class
Declaration Syntax
C#
protected IpOwnerBaseCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (ruleContext)

Execute Method (ruleContext)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IpOwnerBaseCondition<(Of <(T>)>) ► Execute(T)
Declaration Syntax
C#
protected virtual bool Execute(
    T ruleContext
)
Parameters
ruleContext (T)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetColumnValue Method (ip)

GetColumnValue Method (ip)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IpOwnerBaseCondition<(Of <(T>)>) ► GetColumnValue(IPOwner)
Declaration Syntax
C#
protected abstract string GetColumnValue(
    IPOwner ip
)
Parameters
ip (IPOwner)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Value Property

Value Property
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IpOwnerBaseCondition<(Of <(T>)>) ► Value
Declaration Syntax
C#
public string Value { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IspNameCondition(T) Class

IspNameCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IspNameCondition<(Of <(T>)>)
Declaration Syntax
C#
public class IspNameCondition<T> : IpBaseCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IspNameCondition<(Of <(T>)>)()()() | Initializes a new instance of the IspNameCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | (Inherited from IpBaseCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetColumnValue(IP) | (Overrides IpBaseCondition <(Of <( T >)>).GetColumnValue(IP).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from IpBaseCondition<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | StringOperatorCondition <(Of <( T >)>)
 |  |  |  | IpBaseCondition <(Of <( T >)>)
 |  |  |  |  | IspNameCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


IspNameCondition(T) Constructor

IspNameCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IspNameCondition<(Of <(T>)>) ► IspNameCondition<(Of <(T>)>)()()()
Initializes a new instance of the IspNameCondition<(Of <(T>)>) class
Declaration Syntax
C#
public IspNameCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetColumnValue Method (ip)

GetColumnValue Method (ip)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► IspNameCondition<(Of <(T>)>) ► GetColumnValue(IP)
Declaration Syntax
C#
protected override string GetColumnValue(
    IP ip
)
Parameters
ip (IP)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


KeywordsCondition(T) Class

KeywordsCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► KeywordsCondition<(Of <(T>)>)
Declaration Syntax
C#
public class KeywordsCondition<T> : StringOperatorCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KeywordsCondition<(Of <(T>)>)()()() | Initializes a new instance of the KeywordsCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) |
 | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | StringOperatorCondition <(Of <( T >)>)
 |  |  |  | KeywordsCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


KeywordsCondition(T) Constructor

KeywordsCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► KeywordsCondition<(Of <(T>)>) ► KeywordsCondition<(Of <(T>)>)()()()
Initializes a new instance of the KeywordsCondition<(Of <(T>)>) class
Declaration Syntax
C#
public KeywordsCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (ruleContext)

Execute Method (ruleContext)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► KeywordsCondition<(Of <(T>)>) ► Execute(T)
Declaration Syntax
C#
protected virtual bool Execute(
    T ruleContext
)
Parameters
ruleContext (T)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Value Property

Value Property
Namespaces ► Sitecore.Analytics.Rules.Conditions ► KeywordsCondition<(Of <(T>)>) ► Value
Declaration Syntax
C#
public string Value { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LatitudeCondition(T) Class

LatitudeCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► LatitudeCondition<(Of <(T>)>)
Declaration Syntax
C#
public class LatitudeCondition<T> : IpBaseCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LatitudeCondition<(Of <(T>)>)()()() | Initializes a new instance of the LatitudeCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | (Inherited from IpBaseCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetColumnValue(IP) | (Overrides IpBaseCondition <(Of <( T >)>).GetColumnValue(IP).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from IpBaseCondition<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | StringOperatorCondition <(Of <( T >)>)
 |  |  |  | IpBaseCondition <(Of <( T >)>)
 |  |  |  |  | LatitudeCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LatitudeCondition(T) Constructor

LatitudeCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► LatitudeCondition<(Of <(T>)>) ► LatitudeCondition<(Of <(T>)>)()()()
Initializes a new instance of the LatitudeCondition<(Of <(T>)>) class
Declaration Syntax
C#
public LatitudeCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetColumnValue Method (ip)

GetColumnValue Method (ip)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► LatitudeCondition<(Of <(T>)>) ► GetColumnValue(IP)
Declaration Syntax
C#
protected override string GetColumnValue(
    IP ip
)
Parameters
ip (IP)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LongitudeCondition(T) Class

LongitudeCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► LongitudeCondition<(Of <(T>)>)
Declaration Syntax
C#
public class LongitudeCondition<T> : IpBaseCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LongitudeCondition<(Of <(T>)>)()()() | Initializes a new instance of the LongitudeCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | (Inherited from IpBaseCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetColumnValue(IP) | (Overrides IpBaseCondition <(Of <( T >)>).GetColumnValue(IP).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from IpBaseCondition<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | StringOperatorCondition <(Of <( T >)>)
 |  |  |  | IpBaseCondition <(Of <( T >)>)
 |  |  |  |  | LongitudeCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


LongitudeCondition(T) Constructor

LongitudeCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► LongitudeCondition<(Of <(T>)>) ► LongitudeCondition<(Of <(T>)>)()()()
Initializes a new instance of the LongitudeCondition<(Of <(T>)>) class
Declaration Syntax
C#
public LongitudeCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetColumnValue Method (ip)

GetColumnValue Method (ip)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► LongitudeCondition<(Of <(T>)>) ► GetColumnValue(IP)
Declaration Syntax
C#
protected override string GetColumnValue(
    IP ip
)
Parameters
ip (IP)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MetroCodeCondition(T) Class

MetroCodeCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► MetroCodeCondition<(Of <(T>)>)
Declaration Syntax
C#
public class MetroCodeCondition<T> : IpBaseCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MetroCodeCondition<(Of <(T>)>)()()() | Initializes a new instance of the MetroCodeCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | (Inherited from IpBaseCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetColumnValue(IP) | (Overrides IpBaseCondition <(Of <( T >)>).GetColumnValue(IP).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from IpBaseCondition<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | StringOperatorCondition <(Of <( T >)>)
 |  |  |  | IpBaseCondition <(Of <( T >)>)
 |  |  |  |  | MetroCodeCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


MetroCodeCondition(T) Constructor

MetroCodeCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► MetroCodeCondition<(Of <(T>)>) ► MetroCodeCondition<(Of <(T>)>)()()()
Initializes a new instance of the MetroCodeCondition<(Of <(T>)>) class
Declaration Syntax
C#
public MetroCodeCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetColumnValue Method (ip)

GetColumnValue Method (ip)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► MetroCodeCondition<(Of <(T>)>) ► GetColumnValue(IP)
Declaration Syntax
C#
protected override string GetColumnValue(
    IP ip
)
Parameters
ip (IP)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


NameCondition(T) Class

NameCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► NameCondition<(Of <(T>)>)
Declaration Syntax
C#
public class NameCondition<T> : IpOwnerBaseCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NameCondition<(Of <(T>)>)()()() | Initializes a new instance of the NameCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | (Inherited from IpOwnerBaseCondition<(Of <(T>)>).)
 | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetColumnValue(IPOwner) | (Overrides IpOwnerBaseCondition <(Of <( T >)>).GetColumnValue(IPOwner).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from IpOwnerBaseCondition<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | StringOperatorCondition <(Of <( T >)>)
 |  |  |  | IpOwnerBaseCondition <(Of <( T >)>)
 |  |  |  |  | NameCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


NameCondition(T) Constructor

NameCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► NameCondition<(Of <(T>)>) ► NameCondition<(Of <(T>)>)()()()
Initializes a new instance of the NameCondition<(Of <(T>)>) class
Declaration Syntax
C#
public NameCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetColumnValue Method (ip)

GetColumnValue Method (ip)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► NameCondition<(Of <(T>)>) ► GetColumnValue(IPOwner)
Declaration Syntax
C#
protected override string GetColumnValue(
    IPOwner ip
)
Parameters
ip (IPOwner)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageIndexCondition(T) Class

PageIndexCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► PageIndexCondition<(Of <(T>)>)
Declaration Syntax
C#
public class PageIndexCondition<T> : OperatorCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PageIndexCondition<(Of <(T>)>)()()() | Initializes a new instance of the PageIndexCondition<(Of <(T>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) |
 | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from OperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Index |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from OperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | OperatorCondition <(Of <( T >)>)
 |  |  |  | PageIndexCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PageIndexCondition(T) Constructor

PageIndexCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► PageIndexCondition<(Of <(T>)>) ► PageIndexCondition<(Of <(T>)>)()()()
Initializes a new instance of the PageIndexCondition<(Of <(T>)>) class
Declaration Syntax
C#
public PageIndexCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (ruleContext)

Execute Method (ruleContext)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► PageIndexCondition<(Of <(T>)>) ► Execute(T)
Declaration Syntax
C#
protected virtual bool Execute(
    T ruleContext
)
Parameters
ruleContext (T)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Index Property

Index Property
Namespaces ► Sitecore.Analytics.Rules.Conditions ► PageIndexCondition<(Of <(T>)>) ► Index
Declaration Syntax
C#
public int Index { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PostalCodeCondition(T) Class

PostalCodeCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► PostalCodeCondition<(Of <(T>)>)
Declaration Syntax
C#
public class PostalCodeCondition<T> : IpBaseCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PostalCodeCondition<(Of <(T>)>)()()() | Initializes a new instance of the PostalCodeCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | (Inherited from IpBaseCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetColumnValue(IP) | (Overrides IpBaseCondition <(Of <( T >)>).GetColumnValue(IP).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from IpBaseCondition<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | StringOperatorCondition <(Of <( T >)>)
 |  |  |  | IpBaseCondition <(Of <( T >)>)
 |  |  |  |  | PostalCodeCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


PostalCodeCondition(T) Constructor

PostalCodeCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► PostalCodeCondition<(Of <(T>)>) ► PostalCodeCondition<(Of <(T>)>)()()()
Initializes a new instance of the PostalCodeCondition<(Of <(T>)>) class
Declaration Syntax
C#
public PostalCodeCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetColumnValue Method (ip)

GetColumnValue Method (ip)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► PostalCodeCondition<(Of <(T>)>) ► GetColumnValue(IP)
Declaration Syntax
C#
protected override string GetColumnValue(
    IP ip
)
Parameters
ip (IP)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProcessMultiVariateTestAction(T) Class

ProcessMultiVariateTestAction<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► ProcessMultiVariateTestAction<(Of <(T>)>)
Declaration Syntax
C#
public class ProcessMultiVariateTestAction<T> : SetDataSource<T>,
    IMultiVariateTestStrategy
where T : ConditionalRenderingsRuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProcessMultiVariateTestAction<(Of <(T>)>)()()() | Initializes a new instance of the ProcessMultiVariateTestAction<(Of <(T>)>) class
 | Apply(T) | (Overrides RuleAction <(Of <(T>)>).Apply(T).)
 | Apply(T, String) | Executes the specified rule context. (Inherited from SetDataSource<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTestVariableItem(Item, Item) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleAction <(Of <(T>)>)
 |  | SetDataSource <(Of <(T>)>)
 |  |  | ProcessMultiVariateTestAction<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProcessMultiVariateTestAction(T) Constructor

ProcessMultiVariateTestAction<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► ProcessMultiVariateTestAction<(Of <(T>)>) ► ProcessMultiVariateTestAction<(Of <(T>)>)()()()
Initializes a new instance of the ProcessMultiVariateTestAction<(Of <(T>)>) class
Declaration Syntax
C#
public ProcessMultiVariateTestAction()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Apply Method (ruleContext)

Apply Method (ruleContext)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► ProcessMultiVariateTestAction<(Of <(T>)>) ► Apply(T)
Declaration Syntax
C#
public override void Apply(
    T ruleContext
)
Parameters
ruleContext (T)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetTestVariableItem Method (item, multiVariateTest)

GetTestVariableItem Method (item, multiVariateTest)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► ProcessMultiVariateTestAction<(Of <(T>)>) ► GetTestVariableItem(Item, Item)
Declaration Syntax
C#
public Item GetTestVariableItem(
    Item item,
    Item multiVariateTest
)
Parameters
item (Item)
multiVariateTest (Item)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileCondition(T) Class

ProfileCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► ProfileCondition<(Of <(T>)>)
Declaration Syntax
C#
public class ProfileCondition<T> : OperatorCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProfileCondition<(Of <(T>)>)()()() | Initializes a new instance of the ProfileCondition<(Of <(T>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) |
 | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from OperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from OperatorCondition<(Of <(T>)>).)
 | ProfileKeyId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | OperatorCondition <(Of <( T >)>)
 |  |  |  | ProfileCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileCondition(T) Constructor

ProfileCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► ProfileCondition<(Of <(T>)>) ► ProfileCondition<(Of <(T>)>)()()()
Initializes a new instance of the ProfileCondition<(Of <(T>)>) class
Declaration Syntax
C#
public ProfileCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (ruleContext)

Execute Method (ruleContext)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► ProfileCondition<(Of <(T>)>) ► Execute(T)
Declaration Syntax
C#
protected virtual bool Execute(
    T ruleContext
)
Parameters
ruleContext (T)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


ProfileKeyId Property

ProfileKeyId Property
Namespaces ► Sitecore.Analytics.Rules.Conditions ► ProfileCondition<(Of <(T>)>) ► ProfileKeyId
Declaration Syntax
C#
public string ProfileKeyId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Value Property

Value Property
Namespaces ► Sitecore.Analytics.Rules.Conditions ► ProfileCondition<(Of <(T>)>) ► Value
Declaration Syntax
C#
public string Value { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RegionCondition(T) Class

RegionCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► RegionCondition<(Of <(T>)>)
Declaration Syntax
C#
public class RegionCondition<T> : IpBaseCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegionCondition<(Of <(T>)>)()()() | Initializes a new instance of the RegionCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | (Inherited from IpBaseCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetColumnValue(IP) | (Overrides IpBaseCondition <(Of <( T >)>).GetColumnValue(IP).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | (Inherited from IpBaseCondition<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | StringOperatorCondition <(Of <( T >)>)
 |  |  |  | IpBaseCondition <(Of <( T >)>)
 |  |  |  |  | RegionCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


RegionCondition(T) Constructor

RegionCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► RegionCondition<(Of <(T>)>) ► RegionCondition<(Of <(T>)>)()()()
Initializes a new instance of the RegionCondition<(Of <(T>)>) class
Declaration Syntax
C#
public RegionCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetColumnValue Method (ip)

GetColumnValue Method (ip)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► RegionCondition<(Of <(T>)>) ► GetColumnValue(IP)
Declaration Syntax
C#
protected override string GetColumnValue(
    IP ip
)
Parameters
ip (IP)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StickyMultiVariateTestStrategy Class

StickyMultiVariateTestStrategy Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► StickyMultiVariateTestStrategy
Declaration Syntax
C#
public class StickyMultiVariateTestStrategy : IMultiVariateTestStrategy
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | StickyMultiVariateTestStrategy()()() | Initializes a new instance of the StickyMultiVariateTestStrategy class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTestVariableItem(Item, Item) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
StickyMultiVariateTestStrategy

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


StickyMultiVariateTestStrategy Constructor

StickyMultiVariateTestStrategy Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► StickyMultiVariateTestStrategy ► StickyMultiVariateTestStrategy()()()
Initializes a new instance of the StickyMultiVariateTestStrategy class
Declaration Syntax
C#
public StickyMultiVariateTestStrategy()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


GetTestVariableItem Method (item, multiVariateTest)

GetTestVariableItem Method (item, multiVariateTest)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► StickyMultiVariateTestStrategy ► GetTestVariableItem(Item, Item)
Declaration Syntax
C#
public Item GetTestVariableItem(
    Item item,
    Item multiVariateTest
)
Parameters
item (Item)
multiVariateTest (Item)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


VisitorIdentificationCondition(T) Class

VisitorIdentificationCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Analytics.Rules.Conditions ► VisitorIdentificationCondition<(Of <(T>)>)
Declaration Syntax
C#
public class VisitorIdentificationCondition<T> : OperatorCondition<T>
where T : RuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VisitorIdentificationCondition<(Of <(T>)>)()()() | Initializes a new instance of the VisitorIdentificationCondition<(Of <(T>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) |
 | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from OperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from OperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VisitorIdentification |
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | OperatorCondition <(Of <( T >)>)
 |  |  |  | VisitorIdentificationCondition<(Of <(T>)>)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


VisitorIdentificationCondition(T) Constructor

VisitorIdentificationCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Analytics.Rules.Conditions ► VisitorIdentificationCondition<(Of <(T>)>) ► VisitorIdentificationCondition<(Of <(T>)>)()()()
Initializes a new instance of the VisitorIdentificationCondition<(Of <(T>)>) class
Declaration Syntax
C#
public VisitorIdentificationCondition()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Execute Method (ruleContext)

Execute Method (ruleContext)
Namespaces ► Sitecore.Analytics.Rules.Conditions ► VisitorIdentificationCondition<(Of <(T>)>) ► Execute(T)
Declaration Syntax
C#
protected virtual bool Execute(
    T ruleContext
)
Parameters
ruleContext (T)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


VisitorIdentification Property

VisitorIdentification Property
Namespaces ► Sitecore.Analytics.Rules.Conditions ► VisitorIdentificationCondition<(Of <(T>)>) ► VisitorIdentification
Declaration Syntax
C#
public int VisitorIdentification { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Tasks Namespace

Sitecore.Analytics.Tasks Namespace
Namespaces ► Sitecore.Analytics.Tasks
Declaration Syntax
C#
namespace Sitecore.Analytics.Tasks
Types
All Types Classes
Icon | Type | Description
 | EmailReportsTask |
 | SubscriptionTask |


EmailReportsTask Class

EmailReportsTask Class
Namespaces ► Sitecore.Analytics.Tasks ► EmailReportsTask
Declaration Syntax
C#
public class EmailReportsTask
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EmailReportsTask()()() | Initializes a new instance of the EmailReportsTask class
 | DatabaseName |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
EmailReportsTask

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


EmailReportsTask Constructor

EmailReportsTask Constructor
Namespaces ► Sitecore.Analytics.Tasks ► EmailReportsTask ► EmailReportsTask()()()
Initializes a new instance of the EmailReportsTask class
Declaration Syntax
C#
public EmailReportsTask()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


DatabaseName Property

DatabaseName Property
Namespaces ► Sitecore.Analytics.Tasks ► EmailReportsTask ► DatabaseName
Declaration Syntax
C#
public string DatabaseName { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Run Method

Run Method
Namespaces ► Sitecore.Analytics.Tasks ► EmailReportsTask ► Run()()()
Declaration Syntax
C#
public void Run()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubscriptionTask Class

SubscriptionTask Class
Namespaces ► Sitecore.Analytics.Tasks ► SubscriptionTask
Declaration Syntax
C#
public class SubscriptionTask
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubscriptionTask()()() | Initializes a new instance of the SubscriptionTask class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Minutes |
 | Run()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SubscriptionTask

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SubscriptionTask Constructor

SubscriptionTask Constructor
Namespaces ► Sitecore.Analytics.Tasks ► SubscriptionTask ► SubscriptionTask()()()
Initializes a new instance of the SubscriptionTask class
Declaration Syntax
C#
public SubscriptionTask()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Minutes Property

Minutes Property
Namespaces ► Sitecore.Analytics.Tasks ► SubscriptionTask ► Minutes
Declaration Syntax
C#
public string Minutes { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Run Method

Run Method
Namespaces ► Sitecore.Analytics.Tasks ► SubscriptionTask ► Run()()()
Declaration Syntax
C#
public void Run()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Texts Namespace

Sitecore.Analytics.Texts Namespace
Namespaces ► Sitecore.Analytics.Texts
Declaration Syntax
C#
namespace Sitecore.Analytics.Texts
Types
All Types Classes
Icon | Type | Description
 | SummaryHtmlWriter |
 | SummaryTextWriter |


SummaryHtmlWriter Class

SummaryHtmlWriter Class
Namespaces ► Sitecore.Analytics.Texts ► SummaryHtmlWriter
Declaration Syntax
C#
public class SummaryHtmlWriter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SummaryHtmlWriter()()() | Initializes a new instance of the SummaryHtmlWriter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render()()() |
 | Render(HtmlTextWriter) |
 | Render(HtmlTextWriter, String) |
 | Render(HtmlTextWriter, Session) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SummaryHtmlWriter

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SummaryHtmlWriter Constructor

SummaryHtmlWriter Constructor
Namespaces ► Sitecore.Analytics.Texts ► SummaryHtmlWriter ► SummaryHtmlWriter()()()
Initializes a new instance of the SummaryHtmlWriter class
Declaration Syntax
C#
public SummaryHtmlWriter()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Render Method

Render Method
Namespaces ► Sitecore.Analytics.Texts ► SummaryHtmlWriter ► Render()()()
Members
Icon | Member | Description
 | Render()()() |
 | Render(HtmlTextWriter) |
 | Render(HtmlTextWriter, String) |
 | Render(HtmlTextWriter, Session) |

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Render Method

Render Method
Namespaces ► Sitecore.Analytics.Texts ► SummaryHtmlWriter ► Render()()()
Declaration Syntax
C#
public string Render()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Analytics.Texts ► SummaryHtmlWriter ► Render(HtmlTextWriter)
Declaration Syntax
C#
public void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Render Method (output, session)

Render Method (output, session)
Namespaces ► Sitecore.Analytics.Texts ► SummaryHtmlWriter ► Render(HtmlTextWriter, Session)
Declaration Syntax
C#
public void Render(
    HtmlTextWriter output,
    Session session
)
Parameters
output (HtmlTextWriter)
session (Session)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Render Method (output, aspNetSessionId)

Render Method (output, aspNetSessionId)
Namespaces ► Sitecore.Analytics.Texts ► SummaryHtmlWriter ► Render(HtmlTextWriter, String)
Declaration Syntax
C#
public void Render(
    HtmlTextWriter output,
    string aspNetSessionId
)
Parameters
output (HtmlTextWriter)
aspNetSessionId (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SummaryTextWriter Class

SummaryTextWriter Class
Namespaces ► Sitecore.Analytics.Texts ► SummaryTextWriter
Declaration Syntax
C#
public class SummaryTextWriter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SummaryTextWriter()()() | Initializes a new instance of the SummaryTextWriter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render()()() |
 | Render(TextWriter) |
 | Render(TextWriter, String) |
 | Render(TextWriter, Session) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SummaryTextWriter

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SummaryTextWriter Constructor

SummaryTextWriter Constructor
Namespaces ► Sitecore.Analytics.Texts ► SummaryTextWriter ► SummaryTextWriter()()()
Initializes a new instance of the SummaryTextWriter class
Declaration Syntax
C#
public SummaryTextWriter()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Render Method

Render Method
Namespaces ► Sitecore.Analytics.Texts ► SummaryTextWriter ► Render()()()
Members
Icon | Member | Description
 | Render()()() |
 | Render(TextWriter) |
 | Render(TextWriter, String) |
 | Render(TextWriter, Session) |

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Render Method

Render Method
Namespaces ► Sitecore.Analytics.Texts ► SummaryTextWriter ► Render()()()
Declaration Syntax
C#
public string Render()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Analytics.Texts ► SummaryTextWriter ► Render(TextWriter)
Declaration Syntax
C#
public void Render(
    TextWriter output
)
Parameters
output (TextWriter)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Render Method (output, session)

Render Method (output, session)
Namespaces ► Sitecore.Analytics.Texts ► SummaryTextWriter ► Render(TextWriter, Session)
Declaration Syntax
C#
public void Render(
    TextWriter output,
    Session session
)
Parameters
output (TextWriter)
session (Session)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Render Method (output, aspNetSessionId)

Render Method (output, aspNetSessionId)
Namespaces ► Sitecore.Analytics.Texts ► SummaryTextWriter ► Render(TextWriter, String)
Declaration Syntax
C#
public void Render(
    TextWriter output,
    string aspNetSessionId
)
Parameters
output (TextWriter)
aspNetSessionId (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Analytics.Web Namespace

Sitecore.Analytics.Web Namespace
Namespaces ► Sitecore.Analytics.Web
Declaration Syntax
C#
namespace Sitecore.Analytics.Web
Types
All Types Classes
Icon | Type | Description
 | AnalyticsSessionCookie |


AnalyticsSessionCookie Class

AnalyticsSessionCookie Class
Namespaces ► Sitecore.Analytics.Web ► AnalyticsSessionCookie
Declaration Syntax
C#
public class AnalyticsSessionCookie
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalyticsSessionCookie()()() | Initializes a new instance of the AnalyticsSessionCookie class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Load()()() |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Save()()() |
 | SC_ANALYTICS_SESSION_COOKIE |
 | SessionId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateVisitorIdentification |
Inheritance Hierarchy
Object
AnalyticsSessionCookie

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsSessionCookie Constructor

AnalyticsSessionCookie Constructor
Namespaces ► Sitecore.Analytics.Web ► AnalyticsSessionCookie ► AnalyticsSessionCookie()()()
Initializes a new instance of the AnalyticsSessionCookie class
Declaration Syntax
C#
public AnalyticsSessionCookie()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Load Method

Load Method
Namespaces ► Sitecore.Analytics.Web ► AnalyticsSessionCookie ► Load()()()
Declaration Syntax
C#
public void Load()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Save Method

Save Method
Namespaces ► Sitecore.Analytics.Web ► AnalyticsSessionCookie ► Save()()()
Declaration Syntax
C#
public void Save()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SC_ANALYTICS_SESSION_COOKIE Field

SC_ANALYTICS_SESSION_COOKIE Field
Namespaces ► Sitecore.Analytics.Web ► AnalyticsSessionCookie ► SC_ANALYTICS_SESSION_COOKIE
Declaration Syntax
C#
public const string SC_ANALYTICS_SESSION_COOKIE

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


SessionId Property

SessionId Property
Namespaces ► Sitecore.Analytics.Web ► AnalyticsSessionCookie ► SessionId
Declaration Syntax
C#
public Guid SessionId { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


UpdateVisitorIdentification Property

UpdateVisitorIdentification Property
Namespaces ► Sitecore.Analytics.Web ► AnalyticsSessionCookie ► UpdateVisitorIdentification
Declaration Syntax
C#
public bool UpdateVisitorIdentification { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Sitecore.Applications.WebEdit.Dialogs.DateSelector Namespace

Sitecore.Applications.WebEdit.Dialogs.DateSelector Namespace
Namespaces ► Sitecore.Applications.WebEdit.Dialogs.DateSelector
Declaration Syntax
C#
namespace Sitecore.Applications.WebEdit.Dialogs.DateSelector
Types
All Types Classes
Icon | Type | Description
 | SelectDateOptions | Options for select date dialog.


SelectDateOptions Class

SelectDateOptions Class
Namespaces ► Sitecore.Applications.WebEdit.Dialogs.DateSelector ► SelectDateOptions
Options for select date dialog.
Declaration Syntax
C#
public class SelectDateOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelectDateOptions()()() | Creates a new blank instance of select date options.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Header | The Title.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse()()() | Parses the query string.
 | SelectedDate | The selected date.
 | SelectedIsoDate | The selected iso date.
 | Text | The Text.
 | ToString()()() | ToString. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
SelectDateOptions

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SelectDateOptions Constructor

SelectDateOptions Constructor
Namespaces ► Sitecore.Applications.WebEdit.Dialogs.DateSelector ► SelectDateOptions ► SelectDateOptions()()()
Creates a new blank instance of select date options.
Declaration Syntax
C#
public SelectDateOptions()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Header Property

Header Property
Namespaces ► Sitecore.Applications.WebEdit.Dialogs.DateSelector ► SelectDateOptions ► Header
The Title.
Declaration Syntax
C#
public string Header { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Parse Method

Parse Method
Namespaces ► Sitecore.Applications.WebEdit.Dialogs.DateSelector ► SelectDateOptions ► Parse()()()
Parses the query string.
Declaration Syntax
C#
public static SelectDateOptions Parse()
Return Value
Select date options

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SelectedDate Property

SelectedDate Property
Namespaces ► Sitecore.Applications.WebEdit.Dialogs.DateSelector ► SelectDateOptions ► SelectedDate
The selected date.
Declaration Syntax
C#
public DateTime SelectedDate { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SelectedIsoDate Property

SelectedIsoDate Property
Namespaces ► Sitecore.Applications.WebEdit.Dialogs.DateSelector ► SelectDateOptions ► SelectedIsoDate
The selected iso date.
Declaration Syntax
C#
public string SelectedIsoDate { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Text Property

Text Property
Namespaces ► Sitecore.Applications.WebEdit.Dialogs.DateSelector ► SelectDateOptions ► Text
The Text.
Declaration Syntax
C#
public string Text { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ToString Method

ToString Method
Namespaces ► Sitecore.Applications.WebEdit.Dialogs.DateSelector ► SelectDateOptions ► ToString()()()
ToString.
Declaration Syntax
C#
public override string ToString()
Return Value

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Caching Namespace

Sitecore.Caching Namespace
Namespaces ► Sitecore.Caching
Declaration Syntax
C#
namespace Sitecore.Caching
Types
All Types Classes Interfaces Enumerations Delegates
Icon | Type | Description
 | AccessResultCache | AccessResultCache
 | Cache | Cache Class representing a cache.
 | CacheComparer | Implements the IComparer interface to compare two cache objects.
 | Cache..::.CacheEntry | Class representing a cache entry.
 | CacheItem | Represents a cache item.
 | CacheManager | Represents a cache manager.
 | CachePriority | Represents a cache priority.
 | CacheStatistics | Represents cache statistics.
 | CustomCache | CustomCache
 | DataCache | Represents a data cache.
 | DataLengthChangedDelegate |
 | EntryRemovedEventArgs | Argument for the EntryRemoved event.
 | FilteredItemsCache | FilteredItemsCache class
 | HtmlCache | Represents a html cache.
 | ICacheable | Defines the basic properties and functionality of an object that is cacheable.
 | ItemCache | ItemCache
 | ItemRelation | Represents an item relation.
 | ItemsContext |
 | PathCache | Represents a path cache.
 | RegistryCache | Represents a registry cache.
 | StandardValuesCache | StandardValuesCache class
 | ViewStateCache | Represents a view state cache.
 | XslCache | Represents a Xsl cache.


AccessResultCache Class

AccessResultCache Class
Namespaces ► Sitecore.Caching ► AccessResultCache
AccessResultCache
Declaration Syntax
C#
public class AccessResultCache : CustomCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessResultCache(Int64) | Initializes a new instance of the AccessResultCache class.
 | AddRecord(ISecurable, AccessResultCacheRecord) | Obsolete. Adds an access result record.
 | AddRecord(ISecurable, Account, AccessRight, PropagationType, AccessResult) | Adds an access result.
 | Clear()()() | Clears this instance. (Inherited from CustomCache.)
 | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from CustomCache.)
 | GetObject(Object) | Gets the object. (Inherited from CustomCache.)
 | GetRecord(ISecurable) | Obsolete. Gets an access result record.
 | GetRecord(ISecurable, Account, AccessRight, PropagationType) | Gets an access result record.
 | GetString(String) | Gets the string. (Inherited from CustomCache.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomCache.)
 | Remove(Object) | Removes the specified key. (Inherited from CustomCache.)
 | RemoveKeysContaining(String) | Removes the keys containing. (Inherited from CustomCache.)
 | RemovePrefix(String) | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
 | SetID(String, ID) | Sets the ID. (Inherited from CustomCache.)
 | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Sets the object. (Inherited from CustomCache.)
 | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
 | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomCache
 |  | AccessResultCache


AccessResultCache Constructor (maxSize)

AccessResultCache Constructor (maxSize)
Namespaces ► Sitecore.Caching ► AccessResultCache ► AccessResultCache(Int64)
Initializes a new instance of the AccessResultCache class.
Declaration Syntax
C#
public AccessResultCache(
    long maxSize
)
Parameters
maxSize (Int64)
Size of the max.


AddRecord Method

AddRecord Method
Namespaces ► Sitecore.Caching ► AccessResultCache ► AddRecord()()()
Members
Icon | Member | Description
 | AddRecord(ISecurable, AccessResultCacheRecord) | Obsolete. Adds an access result record.
 | AddRecord(ISecurable, Account, AccessRight, PropagationType, AccessResult) | Adds an access result.


AddRecord Method (entity, record)

AddRecord Method (entity, record)
Namespaces ► Sitecore.Caching ► AccessResultCache ► AddRecord(ISecurable, AccessResultCacheRecord)
Adds an access result record.
Declaration Syntax
C#
[ObsoleteAttribute("Use overloaded method instead with all parameters specified")]
public void AddRecord(
    ISecurable entity,
    AccessResultCacheRecord record
)
Parameters
entity (ISecurable)
The entity.
record (AccessResultCacheRecord)
The record.


AddRecord Method (entity, account, accessRight, propagationType, accessResult)

AddRecord Method (entity, account, accessRight, propagationType, accessResult)
Namespaces ► Sitecore.Caching ► AccessResultCache ► AddRecord(ISecurable, Account, AccessRight, PropagationType, AccessResult)
Adds an access result.
Declaration Syntax
C#
public void AddRecord(
    ISecurable entity,
    Account account,
    AccessRight accessRight,
    PropagationType propagationType,
    AccessResult accessResult
)
Parameters
entity (ISecurable)
The entity.
account (Account)
The account.
accessRight (AccessRight)
The access right
propagationType (PropagationType)
The propagation type
accessResult (AccessResult)
The access result


GetRecord Method

GetRecord Method
Namespaces ► Sitecore.Caching ► AccessResultCache ► GetRecord()()()
Members
Icon | Member | Description
 | GetRecord(ISecurable) | Obsolete. Gets an access result record.
 | GetRecord(ISecurable, Account, AccessRight, PropagationType) | Gets an access result record.


GetRecord Method (entity)

GetRecord Method (entity)
Namespaces ► Sitecore.Caching ► AccessResultCache ► GetRecord(ISecurable)
Gets an access result record.
Declaration Syntax
C#
[ObsoleteAttribute("Use overloaded method instead with all parameters specified")]
public AccessResultCacheRecord GetRecord(
    ISecurable entity
)
Parameters
entity (ISecurable)
The entity.
Return Value


GetRecord Method (entity, account, accessRight, propagationType)

GetRecord Method (entity, account, accessRight, propagationType)
Namespaces ► Sitecore.Caching ► AccessResultCache ► GetRecord(ISecurable, Account, AccessRight, PropagationType)
Gets an access result record.
Declaration Syntax
C#
public AccessResultCacheRecord GetRecord(
    ISecurable entity,
    Account account,
    AccessRight accessRight,
    PropagationType propagationType
)
Parameters
entity (ISecurable)
The entity.
account (Account)
The account.
accessRight (AccessRight)
The access right
propagationType (PropagationType)
The propagation type.
Return Value


Cache Class

Cache Class
Namespaces ► Sitecore.Caching ► Cache
Cache
Class representing a cache.
Declaration Syntax
C#
public class Cache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Cache(Int64) | Initializes a new instance of the Cache class.
 | Cache(String, String) | Initializes a new instance of the Cache class.
 | Cache(String, Int64) | Initializes a new instance of the Cache class.
 | Add(ID, ICacheable) | Adds the specified key.
 | Add(ID, String) | Adds the specified key.
 | Add(Object, Object, Int64) | Adds the specified key.
 | Add(ID, Object, Int64) | Adds the specified key.
 | Add(String, ICacheable) | Adds the specified key.
 | Add(String, ID) | Adds the specified key.
 | Add(String, String) | Adds the specified key.
 | Add(String, Object, Int64) | Adds the specified key.
 | Add(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Adds the specified key.
 | Add(String, Object, Int64, TimeSpan) | Adds the specified object.
 | Add(String, Object, Int64, DateTime) | Adds the specified object.
 | Clear()()() | Clears this instance.
 | ContainsKey(ID) | Determines whether the specified key is currently contained in the cache.
 | ContainsKey(Object) | Determines whether the specified key is currently contained in the cache.
 | Count | Gets the count.
 | DefaultPriority | Gets or sets the default priority.
 | Enabled | Gets or sets a value indicating whether this Cache is enabled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCacheKeys()()() | Gets a list of all the current cache keys.
 | GetCacheKeys(String) | Gets the cache keys.
 | GetEntry(Object, Boolean) | Gets the entry represented by key.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNamedInstance(String, Int64) | Get the instance of cache by name
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(Object) | Gets the value.
 | Id | Gets the id.
 | Item[([(Object])]) | Gets the Object with the specified key.
 | MaxSize | Gets or sets the max size.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | RemainingSpace | Gets the remaining space (in bytes).
 | Remove(Object) | Removes the specified key.
 | Remove<(Of <(TKey>)>)(Predicate<(Of <(TKey>)>)) | Remove keys by predicate
 | RemoveKeysContaining(String) | Removes the keys containing the value.
 | RemovePrefix(String) | Removes the prefix.
 | Scavengable | Gets or sets a value indicating whether this Cache is scavengable.
 | Scavenge()()() | Scavenges this cache.
 | Size | Gets the size.
 | SyncRoot | Gets the sync root.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Cache


Cache Constructor

Cache Constructor
Namespaces ► Sitecore.Caching ► Cache ► Cache()()()
Members
Icon | Member | Description
 | Cache(Int64) | Initializes a new instance of the Cache class.
 | Cache(String, String) | Initializes a new instance of the Cache class.
 | Cache(String, Int64) | Initializes a new instance of the Cache class.


Cache Constructor (maxSize)

Cache Constructor (maxSize)
Namespaces ► Sitecore.Caching ► Cache ► Cache(Int64)
Initializes a new instance of the Cache class.
Declaration Syntax
C#
public Cache(
    long maxSize
)
Parameters
maxSize (Int64)
Size of the max.


Cache Constructor (name, maxSize)

Cache Constructor (name, maxSize)
Namespaces ► Sitecore.Caching ► Cache ► Cache(String, Int64)
Initializes a new instance of the Cache class.
Declaration Syntax
C#
public Cache(
    string name,
    long maxSize
)
Parameters
name (String)
The name.
maxSize (Int64)
Size of the max.


Cache Constructor (name, maxSize)

Cache Constructor (name, maxSize)
Namespaces ► Sitecore.Caching ► Cache ► Cache(String, String)
Initializes a new instance of the Cache class.
Declaration Syntax
C#
public Cache(
    string name,
    string maxSize
)
Parameters
name (String)
The name.
maxSize (String)
Size of the max.


Add Method

Add Method
Namespaces ► Sitecore.Caching ► Cache ► Add()()()
Members
Icon | Member | Description
 | Add(ID, ICacheable) | Adds the specified key.
 | Add(ID, String) | Adds the specified key.
 | Add(Object, Object, Int64) | Adds the specified key.
 | Add(ID, Object, Int64) | Adds the specified key.
 | Add(String, ICacheable) | Adds the specified key.
 | Add(String, ID) | Adds the specified key.
 | Add(String, String) | Adds the specified key.
 | Add(String, Object, Int64) | Adds the specified key.
 | Add(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Adds the specified key.
 | Add(String, Object, Int64, TimeSpan) | Adds the specified object.
 | Add(String, Object, Int64, DateTime) | Adds the specified object.


Add Method (key, data)

Add Method (key, data)
Namespaces ► Sitecore.Caching ► Cache ► Add(ID, ICacheable)
Adds the specified key.
Declaration Syntax
C#
public void Add(
    ID key,
    ICacheable data
)
Parameters
key (ID)
The key.
data (ICacheable)
The data.


Add Method (key, data, dataLength)

Add Method (key, data, dataLength)
Namespaces ► Sitecore.Caching ► Cache ► Add(ID, Object, Int64)
Adds the specified key.
Declaration Syntax
C#
public void Add(
    ID key,
    Object data,
    long dataLength
)
Parameters
key (ID)
The key.
data (Object)
The data.
dataLength (Int64)
Length of the data.


Add Method (key, value)

Add Method (key, value)
Namespaces ► Sitecore.Caching ► Cache ► Add(ID, String)
Adds the specified key.
Declaration Syntax
C#
public void Add(
    ID key,
    string value
)
Parameters
key (ID)
The key.
value (String)
The value.


Add Method (key, data, dataLength)

Add Method (key, data, dataLength)
Namespaces ► Sitecore.Caching ► Cache ► Add(Object, Object, Int64)
Adds the specified key.
Declaration Syntax
C#
public void Add(
    Object key,
    Object data,
    long dataLength
)
Parameters
key (Object)
The key.
data (Object)
The data.
dataLength (Int64)
Length of the data.


Add Method (key, data)

Add Method (key, data)
Namespaces ► Sitecore.Caching ► Cache ► Add(String, ICacheable)
Adds the specified key.
Declaration Syntax
C#
public void Add(
    string key,
    ICacheable data
)
Parameters
key (String)
The key.
data (ICacheable)
The data.


Add Method (key, value)

Add Method (key, value)
Namespaces ► Sitecore.Caching ► Cache ► Add(String, ID)
Adds the specified key.
Declaration Syntax
C#
public void Add(
    string key,
    ID value
)
Parameters
key (String)
The key.
value (ID)
The value.


Add Method (key, data, dataLength)

Add Method (key, data, dataLength)
Namespaces ► Sitecore.Caching ► Cache ► Add(String, Object, Int64)
Adds the specified key.
Declaration Syntax
C#
public void Add(
    string key,
    Object data,
    long dataLength
)
Parameters
key (String)
The key.
data (Object)
The data.
dataLength (Int64)
Length of the data.


Add Method (key, data, dataLength, absoluteExpiration)

Add Method (key, data, dataLength, absoluteExpiration)
Namespaces ► Sitecore.Caching ► Cache ► Add(String, Object, Int64, DateTime)
Adds the specified object.
Declaration Syntax
C#
public Cache..::.CacheEntry Add(
    string key,
    Object data,
    long dataLength,
    DateTime absoluteExpiration
)
Parameters
key (String)
The key.
data (Object)
The data.
dataLength (Int64)
Length of the data.
absoluteExpiration (DateTime)
The absolute expiration.
Return Value


Add Method (key, data, dataLength, removedHandler)

Add Method (key, data, dataLength, removedHandler)
Namespaces ► Sitecore.Caching ► Cache ► Add(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>))
Adds the specified key.
Declaration Syntax
C#
public void Add(
    string key,
    Object data,
    long dataLength,
    EventHandler<EntryRemovedEventArgs> removedHandler
)
Parameters
key (String)
The key.
data (Object)
The data.
dataLength (Int64)
Length of the data.
removedHandler (EventHandler<(Of <( EntryRemovedEventArgs >)>))
The removed handler.


Add Method (key, data, dataLength, slidingExpiration)

Add Method (key, data, dataLength, slidingExpiration)
Namespaces ► Sitecore.Caching ► Cache ► Add(String, Object, Int64, TimeSpan)
Adds the specified object.
Declaration Syntax
C#
public Cache..::.CacheEntry Add(
    string key,
    Object data,
    long dataLength,
    TimeSpan slidingExpiration
)
Parameters
key (String)
The key.
data (Object)
The data.
dataLength (Int64)
Length of the data.
slidingExpiration (TimeSpan)
The sliding expiration.
Return Value


Add Method (key, data)

Add Method (key, data)
Namespaces ► Sitecore.Caching ► Cache ► Add(String, String)
Adds the specified key.
Declaration Syntax
C#
public Cache..::.CacheEntry Add(
    string key,
    string data
)
Parameters
key (String)
The key.
data (String)
The data.


Clear Method

Clear Method
Namespaces ► Sitecore.Caching ► Cache ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public void Clear()


ContainsKey Method

ContainsKey Method
Namespaces ► Sitecore.Caching ► Cache ► ContainsKey()()()
Members
Icon | Member | Description
 | ContainsKey(ID) | Determines whether the specified key is currently contained in the cache.
 | ContainsKey(Object) | Determines whether the specified key is currently contained in the cache.


ContainsKey Method (key)

ContainsKey Method (key)
Namespaces ► Sitecore.Caching ► Cache ► ContainsKey(ID)
Determines whether the specified key is currently contained in the cache.
Declaration Syntax
C#
public bool ContainsKey(
    ID key
)
Parameters
key (ID)
The key.
Return Value
true if the specified key is contained; otherwise, false.


ContainsKey Method (key)

ContainsKey Method (key)
Namespaces ► Sitecore.Caching ► Cache ► ContainsKey(Object)
Determines whether the specified key is currently contained in the cache.
Declaration Syntax
C#
public bool ContainsKey(
    Object key
)
Parameters
key (Object)
The key.
Return Value
true if the specified key is contained; otherwise, false.


Count Property

Count Property
Namespaces ► Sitecore.Caching ► Cache ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


DefaultPriority Property

DefaultPriority Property
Namespaces ► Sitecore.Caching ► Cache ► DefaultPriority
Gets or sets the default priority.
Declaration Syntax
C#
public CachePriority DefaultPriority { get; set; }
Value
The default priority.


Enabled Property

Enabled Property
Namespaces ► Sitecore.Caching ► Cache ► Enabled
Gets or sets a value indicating whether this Cache is enabled.
Declaration Syntax
C#
public bool Enabled { get; set; }
Value
true if enabled; otherwise, false.


GetCacheKeys Method

GetCacheKeys Method
Namespaces ► Sitecore.Caching ► Cache ► GetCacheKeys()()()
Members
Icon | Member | Description
 | GetCacheKeys()()() | Gets a list of all the current cache keys.
 | GetCacheKeys(String) | Gets the cache keys.


GetCacheKeys Method

GetCacheKeys Method
Namespaces ► Sitecore.Caching ► Cache ► GetCacheKeys()()()
Gets a list of all the current cache keys.
Declaration Syntax
C#
public ArrayList GetCacheKeys()
Return Value


GetCacheKeys Method (keyPrefix)

GetCacheKeys Method (keyPrefix)
Namespaces ► Sitecore.Caching ► Cache ► GetCacheKeys(String)
Gets the cache keys.
Declaration Syntax
C#
public ArrayList GetCacheKeys(
    string keyPrefix
)
Parameters
keyPrefix (String)
The key prefix.
Return Value


GetEntry Method (key, updateAccessed)

GetEntry Method (key, updateAccessed)
Namespaces ► Sitecore.Caching ► Cache ► GetEntry(Object, Boolean)
Gets the entry represented by key.
Declaration Syntax
C#
public Cache..::.CacheEntry GetEntry(
    Object key,
    bool updateAccessed
)
Parameters
key (Object)
The key.
updateAccessed (Boolean)
if set to true the update accessed counter is updated.
Return Value
The entry (or null).


GetNamedInstance Method (name, defaultMaxSize)

GetNamedInstance Method (name, defaultMaxSize)
Namespaces ► Sitecore.Caching ► Cache ► GetNamedInstance(String, Int64)
Get the instance of cache by name
Declaration Syntax
C#
public static Cache GetNamedInstance(
    string name,
    long defaultMaxSize
)
Parameters
name (String)
The name of the cache
defaultMaxSize (Int64)
Return Value


GetValue Method (key)

GetValue Method (key)
Namespaces ► Sitecore.Caching ► Cache ► GetValue(Object)
Gets the value.
Declaration Syntax
C#
public Object GetValue(
    Object key
)
Parameters
key (Object)
The key.
Return Value


Id Property

Id Property
Namespaces ► Sitecore.Caching ► Cache ► Id
Gets the id.
Declaration Syntax
C#
public ID Id { get; }
Value
The id.


Item Property (key)

Item Property (key)
Namespaces ► Sitecore.Caching ► Cache ► Item[([(Object])])
Gets the Object with the specified key.
Declaration Syntax
C#
public Object this[
    Object key
] { get; }
Parameters
key (Object)
Value


MaxSize Property

MaxSize Property
Namespaces ► Sitecore.Caching ► Cache ► MaxSize
Gets or sets the max size.
Declaration Syntax
C#
public long MaxSize { get; set; }
Value
The max size.


Name Property

Name Property
Namespaces ► Sitecore.Caching ► Cache ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


RemainingSpace Property

RemainingSpace Property
Namespaces ► Sitecore.Caching ► Cache ► RemainingSpace
Gets the remaining space (in bytes).
Declaration Syntax
C#
public long RemainingSpace { get; }
Value
The remaining space.


Remove Method

Remove Method
Namespaces ► Sitecore.Caching ► Cache ► Remove()()()
Members
Icon | Member | Description
 | Remove(Object) | Removes the specified key.
 | Remove<(Of <(TKey>)>)(Predicate<(Of <(TKey>)>)) | Remove keys by predicate


Remove Method (key)

Remove Method (key)
Namespaces ► Sitecore.Caching ► Cache ► Remove(Object)
Removes the specified key.
Declaration Syntax
C#
public void Remove(
    Object key
)
Parameters
key (Object)
The key.


Remove Method (predicate)

Remove<(Of <(TKey>)>) Method (predicate)
Namespaces ► Sitecore.Caching ► Cache ► Remove<(Of <(TKey>)>)(Predicate<(Of <(TKey>)>))
Remove keys by predicate
Declaration Syntax
C#
public void Remove<TKey>(
    Predicate<TKey> predicate
)
Generic Template Parameters
TKey
Parameters
predicate (Predicate<(Of <(TKey>)>))


RemoveKeysContaining Method (value)

RemoveKeysContaining Method (value)
Namespaces ► Sitecore.Caching ► Cache ► RemoveKeysContaining(String)
Removes the keys containing the value.
Declaration Syntax
C#
public void RemoveKeysContaining(
    string value
)
Parameters
value (String)
The value.


RemovePrefix Method (keyPrefix)

RemovePrefix Method (keyPrefix)
Namespaces ► Sitecore.Caching ► Cache ► RemovePrefix(String)
Removes the prefix.
Declaration Syntax
C#
public void RemovePrefix(
    string keyPrefix
)
Parameters
keyPrefix (String)
The key prefix.


Scavengable Property

Scavengable Property
Namespaces ► Sitecore.Caching ► Cache ► Scavengable
Gets or sets a value indicating whether this Cache is scavengable.
Declaration Syntax
C#
public bool Scavengable { get; set; }
Value
true if scavengable; otherwise, false.


Scavenge Method

Scavenge Method
Namespaces ► Sitecore.Caching ► Cache ► Scavenge()()()
Scavenges this cache.
Declaration Syntax
C#
public void Scavenge()


Size Property

Size Property
Namespaces ► Sitecore.Caching ► Cache ► Size
Gets the size.
Declaration Syntax
C#
public long Size { get; }
Value
The size.


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Caching ► Cache ► SyncRoot
Gets the sync root.
Declaration Syntax
C#
public Object SyncRoot { get; }
Value
The sync root.


Cache.CacheEntry Class

Cache..::.CacheEntry Class
Namespaces ► Sitecore.Caching ► Cache ► Cache..::.CacheEntry
Class representing a cache entry.
Declaration Syntax
C#
public class CacheEntry
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Cache..::.CacheEntry(ID, ICacheable, CachePriority, Cache) | Initializes a new instance of the Cache..::.CacheEntry class.
 | Cache..::.CacheEntry(String, ICacheable, CachePriority, Cache) | Initializes a new instance of the Cache..::.CacheEntry class.
 | Cache..::.CacheEntry(ID, String, CachePriority, Cache) | Initializes a new instance of the Cache..::.CacheEntry class.
 | Cache..::.CacheEntry(String, String, CachePriority, Cache) | Initializes a new instance of the Cache..::.CacheEntry class.
 | Cache..::.CacheEntry(ID, Object, Int64, CachePriority, Cache) | Initializes a new instance of the Cache..::.CacheEntry class.
 | Cache..::.CacheEntry(Object, Object, Int64, CachePriority, Cache) | Initializes a new instance of the Cache..::.CacheEntry class.
 | Cache..::.CacheEntry(String, Object, Int64, CachePriority, Cache) | Initializes a new instance of the Cache..::.CacheEntry class.
 | AbsoluteExpiration | Gets or sets the sliding expiration.
 | Accessed | Gets the date/time where the entry was last accessed.
 | Data | Gets the data.
 | DataLength | Gets the length of the data.
 | EntryRemoved |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Expired | Gets a value indicating whether this Cache..::.CacheEntry is expired.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Priority | Gets the priority.
 | RaiseEntryRemoved()()() | Raises the EntryRemoved event.
 | SlidingExpiration | Gets or sets the sliding expiration.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateAccessed()()() | Updates the accessed time.
Inheritance Hierarchy
Object
Cache..::.CacheEntry


Cache.CacheEntry Constructor

Cache..::.CacheEntry Constructor
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► Cache..::.CacheEntry()()()
Members
Icon | Member | Description
 | Cache..::.CacheEntry(ID, ICacheable, CachePriority, Cache) | Initializes a new instance of the Cache..::.CacheEntry class.
 | Cache..::.CacheEntry(String, ICacheable, CachePriority, Cache) | Initializes a new instance of the Cache..::.CacheEntry class.
 | Cache..::.CacheEntry(ID, String, CachePriority, Cache) | Initializes a new instance of the Cache..::.CacheEntry class.
 | Cache..::.CacheEntry(String, String, CachePriority, Cache) | Initializes a new instance of the Cache..::.CacheEntry class.
 | Cache..::.CacheEntry(ID, Object, Int64, CachePriority, Cache) | Initializes a new instance of the Cache..::.CacheEntry class.
 | Cache..::.CacheEntry(Object, Object, Int64, CachePriority, Cache) | Initializes a new instance of the Cache..::.CacheEntry class.
 | Cache..::.CacheEntry(String, Object, Int64, CachePriority, Cache) | Initializes a new instance of the Cache..::.CacheEntry class.


Cache.CacheEntry Constructor (key, data, priority, cache)

Cache..::.CacheEntry Constructor (key, data, priority, cache)
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► Cache..::.CacheEntry(ID, ICacheable, CachePriority, Cache)
Initializes a new instance of the Cache..::.CacheEntry class.
Declaration Syntax
C#
public CacheEntry(
    ID key,
    ICacheable data,
    CachePriority priority,
    Cache cache
)
Parameters
key (ID)
The key.
data (ICacheable)
The data.
priority (CachePriority)
The priority.
cache (Cache)
The cache.


Cache.CacheEntry Constructor (key, data, dataLength, priority, cache)

Cache..::.CacheEntry Constructor (key, data, dataLength, priority, cache)
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► Cache..::.CacheEntry(ID, Object, Int64, CachePriority, Cache)
Initializes a new instance of the Cache..::.CacheEntry class.
Declaration Syntax
C#
public CacheEntry(
    ID key,
    Object data,
    long dataLength,
    CachePriority priority,
    Cache cache
)
Parameters
key (ID)
The key.
data (Object)
The data.
dataLength (Int64)
Length of the data.
priority (CachePriority)
The priority.
cache (Cache)
The cache.


Cache.CacheEntry Constructor (key, value, priority, cache)

Cache..::.CacheEntry Constructor (key, value, priority, cache)
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► Cache..::.CacheEntry(ID, String, CachePriority, Cache)
Initializes a new instance of the Cache..::.CacheEntry class.
Declaration Syntax
C#
public CacheEntry(
    ID key,
    string value,
    CachePriority priority,
    Cache cache
)
Parameters
key (ID)
The key.
value (String)
The value.
priority (CachePriority)
The priority.
cache (Cache)
The cache.


Cache.CacheEntry Constructor (key, data, dataLength, priority, cache)

Cache..::.CacheEntry Constructor (key, data, dataLength, priority, cache)
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► Cache..::.CacheEntry(Object, Object, Int64, CachePriority, Cache)
Initializes a new instance of the Cache..::.CacheEntry class.
Declaration Syntax
C#
public CacheEntry(
    Object key,
    Object data,
    long dataLength,
    CachePriority priority,
    Cache cache
)
Parameters
key (Object)
The key.
data (Object)
The data.
dataLength (Int64)
Length of the data.
priority (CachePriority)
The priority.
cache (Cache)
The cache.


Cache.CacheEntry Constructor (key, data, priority, cache)

Cache..::.CacheEntry Constructor (key, data, priority, cache)
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► Cache..::.CacheEntry(String, ICacheable, CachePriority, Cache)
Initializes a new instance of the Cache..::.CacheEntry class.
Declaration Syntax
C#
public CacheEntry(
    string key,
    ICacheable data,
    CachePriority priority,
    Cache cache
)
Parameters
key (String)
The key.
data (ICacheable)
The data.
priority (CachePriority)
The priority.
cache (Cache)
The cache.


Cache.CacheEntry Constructor (key, data, dataLength, priority, cache)

Cache..::.CacheEntry Constructor (key, data, dataLength, priority, cache)
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► Cache..::.CacheEntry(String, Object, Int64, CachePriority, Cache)
Initializes a new instance of the Cache..::.CacheEntry class.
Declaration Syntax
C#
public CacheEntry(
    string key,
    Object data,
    long dataLength,
    CachePriority priority,
    Cache cache
)
Parameters
key (String)
The key.
data (Object)
The data.
dataLength (Int64)
Length of the data.
priority (CachePriority)
The priority.
cache (Cache)
The cache.


Cache.CacheEntry Constructor (key, value, priority, cache)

Cache..::.CacheEntry Constructor (key, value, priority, cache)
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► Cache..::.CacheEntry(String, String, CachePriority, Cache)
Initializes a new instance of the Cache..::.CacheEntry class.
Declaration Syntax
C#
public CacheEntry(
    string key,
    string value,
    CachePriority priority,
    Cache cache
)
Parameters
key (String)
The key.
value (String)
The value.
priority (CachePriority)
The priority.
cache (Cache)
The cache.


AbsoluteExpiration Property

AbsoluteExpiration Property
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► AbsoluteExpiration
Gets or sets the sliding expiration.
Declaration Syntax
C#
public DateTime AbsoluteExpiration { get; set; }
Value
The sliding expiration.


Accessed Property

Accessed Property
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► Accessed
Gets the date/time where the entry was last accessed.
Declaration Syntax
C#
public DateTime Accessed { get; set; }
Value
The date/time of access.


Data Property

Data Property
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► Data
Gets the data.
Declaration Syntax
C#
public Object Data { get; }
Value
The data.


DataLength Property

DataLength Property
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► DataLength
Gets the length of the data.
Declaration Syntax
C#
public long DataLength { get; }
Value
The length of the data.


EntryRemoved Event

EntryRemoved Event
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► EntryRemoved
Declaration Syntax
C#
public event EventHandler<EntryRemovedEventArgs> EntryRemoved


Expired Property

Expired Property
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► Expired
Gets a value indicating whether this Cache..::.CacheEntry is expired.
Declaration Syntax
C#
public bool Expired { get; }
Value
true if expired; otherwise, false.


Key Property

Key Property
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► Key
Gets the key.
Declaration Syntax
C#
public Object Key { get; }
Value
The key.


Priority Property

Priority Property
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► Priority
Gets the priority.
Declaration Syntax
C#
public CachePriority Priority { get; }
Value
The priority.


RaiseEntryRemoved Method

RaiseEntryRemoved Method
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► RaiseEntryRemoved()()()
Raises the EntryRemoved event.
Declaration Syntax
C#
public void RaiseEntryRemoved()


SlidingExpiration Property

SlidingExpiration Property
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► SlidingExpiration
Gets or sets the sliding expiration.
Declaration Syntax
C#
public TimeSpan SlidingExpiration { get; set; }
Value
The sliding expiration.


UpdateAccessed Method

UpdateAccessed Method
Namespaces ► Sitecore.Caching ► Cache..::.CacheEntry ► UpdateAccessed()()()
Updates the accessed time.
Declaration Syntax
C#
public void UpdateAccessed()


CacheComparer Class

CacheComparer Class
Namespaces ► Sitecore.Caching ► CacheComparer
Implements the IComparer interface to compare two cache objects.
Declaration Syntax
C#
public class CacheComparer : IComparer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CacheComparer()()() | Initializes a new instance of the CacheComparer class
 | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CacheComparer


CacheComparer Constructor

CacheComparer Constructor
Namespaces ► Sitecore.Caching ► CacheComparer ► CacheComparer()()()
Initializes a new instance of the CacheComparer class
Declaration Syntax
C#
public CacheComparer()


Compare Method (x, y)

Compare Method (x, y)
Namespaces ► Sitecore.Caching ► CacheComparer ► Compare(Object, Object)
Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Declaration Syntax
C#
public int Compare(
    Object x,
    Object y
)
Parameters
x (Object)
The first object to compare.
y (Object)
The second object to compare.
Return Value
Value Condition Less than zero x is less than y. Zero x equals y. Greater than zero x is greater than y.
Exceptions
Exception | Condition
ArgumentException | Neither x nor y implements the IComparable interface.-or- x and y are of different types and neither one can handle comparisons with the other.


CacheItem Class

CacheItem Class
Namespaces ► Sitecore.Caching ► CacheItem
Represents a cache item.
Declaration Syntax
C#
public class CacheItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CacheItem(Object, CachePriority) | Initializes a new instance of the CacheItem class.
 | Accessed | Gets the accessed.
 | Created | Gets the created.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Object | Gets the object.
 | Priority | Gets the priority.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CacheItem


CacheItem Constructor (obj, priority)

CacheItem Constructor (obj, priority)
Namespaces ► Sitecore.Caching ► CacheItem ► CacheItem(Object, CachePriority)
Initializes a new instance of the CacheItem class.
Declaration Syntax
C#
public CacheItem(
    Object obj,
    CachePriority priority
)
Parameters
obj (Object)
The object.
priority (CachePriority)
The priority.


Accessed Property

Accessed Property
Namespaces ► Sitecore.Caching ► CacheItem ► Accessed
Gets the accessed.
Declaration Syntax
C#
public DateTime Accessed { get; }
Value
The accessed.


Created Property

Created Property
Namespaces ► Sitecore.Caching ► CacheItem ► Created
Gets the created.
Declaration Syntax
C#
public DateTime Created { get; }
Value
The created.


Object Property

Object Property
Namespaces ► Sitecore.Caching ► CacheItem ► Object
Gets the object.
Declaration Syntax
C#
public Object Object { get; }
Value
The object.


Priority Property

Priority Property
Namespaces ► Sitecore.Caching ► CacheItem ► Priority
Gets the priority.
Declaration Syntax
C#
public CachePriority Priority { get; }
Value
The priority.


CacheManager Class

CacheManager Class
Namespaces ► Sitecore.Caching ► CacheManager
Represents a cache manager.
Declaration Syntax
C#
public class CacheManager
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CacheManager()()() | Initializes a new instance of the CacheManager class
 | ClearAccessResultCache()()() | Clears the access result cache.
 | ClearAll()()() | Obsolete. Clears all.
 | ClearAllCaches()()() | Clears all caches.
 | ClearIsInRoleCache(String) | Clear cache with information about is user in role
 | ClearSecurityCache(String) | Clear security cache
 | ClearUserProfileCache(String) | Clear cache with user profiles
 | Enabled | Gets or sets a value indicating whether this CacheManager is enabled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindCacheByName(String) | Finds the cache by its name
 | GetAccessResultCache()()() | Gets the access result cache.
 | GetAllCaches()()() | Gets all caches.
 | GetDataCache(Database) | Gets the data cache.
 | GetFilteredItemsCache(SiteContext) | Gets the filtered items cache for the specified site.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHtmlCache(SiteContext) | Gets the HTML cache.
 | GetIsInRoleCache()()() | Gets the is in role cache.
 | GetItemCache(Database) | Gets the item cache of a database.
 | GetPathCache(Database) | Gets the path cache.
 | GetRegistryCache(SiteContext) | Gets the registry cache.
 | GetStatistics()()() | Gets the statistics.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserProfileCache()()() | Gets the user profile cache.
 | GetViewStateCache(SiteContext) | Gets the view state cache.
 | GetXslCache(SiteContext) | Gets the XSL cache.
 | LoadFactor | Gets or sets the load factor.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CacheManager


CacheManager Constructor

CacheManager Constructor
Namespaces ► Sitecore.Caching ► CacheManager ► CacheManager()()()
Initializes a new instance of the CacheManager class
Declaration Syntax
C#
public CacheManager()


ClearAccessResultCache Method

ClearAccessResultCache Method
Namespaces ► Sitecore.Caching ► CacheManager ► ClearAccessResultCache()()()
Clears the access result cache.
Declaration Syntax
C#
public static void ClearAccessResultCache()
Return Value


ClearAll Method

ClearAll Method
Namespaces ► Sitecore.Caching ► CacheManager ► ClearAll()()()
Clears all.
Declaration Syntax
C#
[ObsoleteAttribute("Use Sitecore.Caching.CacheManager.ClearAllCaches instead.")]
public void ClearAll()


ClearAllCaches Method

ClearAllCaches Method
Namespaces ► Sitecore.Caching ► CacheManager ► ClearAllCaches()()()
Clears all caches.
Declaration Syntax
C#
public static void ClearAllCaches()


ClearIsInRoleCache Method (userName)

ClearIsInRoleCache Method (userName)
Namespaces ► Sitecore.Caching ► CacheManager ► ClearIsInRoleCache(String)
Clear cache with information about is user in role
Declaration Syntax
C#
public static void ClearIsInRoleCache(
    string userName
)
Parameters
userName (String)


ClearSecurityCache Method (userName)

ClearSecurityCache Method (userName)
Namespaces ► Sitecore.Caching ► CacheManager ► ClearSecurityCache(String)
Clear security cache
Declaration Syntax
C#
public static void ClearSecurityCache(
    string userName
)
Parameters
userName (String)


ClearUserProfileCache Method (userName)

ClearUserProfileCache Method (userName)
Namespaces ► Sitecore.Caching ► CacheManager ► ClearUserProfileCache(String)
Clear cache with user profiles
Declaration Syntax
C#
public static void ClearUserProfileCache(
    string userName
)
Parameters
userName (String)


Enabled Property

Enabled Property
Namespaces ► Sitecore.Caching ► CacheManager ► Enabled
Gets or sets a value indicating whether this CacheManager is enabled.
Declaration Syntax
C#
public static bool Enabled { get; set; }
Value
true if enabled; otherwise, false.


FindCacheByName Method (name)

FindCacheByName Method (name)
Namespaces ► Sitecore.Caching ► CacheManager ► FindCacheByName(String)
Finds the cache by its name
Declaration Syntax
C#
public static Cache FindCacheByName(
    string name
)
Parameters
name (String)
The name of the cache
Return Value
The cache


GetAccessResultCache Method

GetAccessResultCache Method
Namespaces ► Sitecore.Caching ► CacheManager ► GetAccessResultCache()()()
Gets the access result cache.
Declaration Syntax
C#
public static AccessResultCache GetAccessResultCache()
Return Value


GetAllCaches Method

GetAllCaches Method
Namespaces ► Sitecore.Caching ► CacheManager ► GetAllCaches()()()
Gets all caches.
Declaration Syntax
C#
public static Cache[] GetAllCaches()
Return Value
The all caches.


GetDataCache Method (database)

GetDataCache Method (database)
Namespaces ► Sitecore.Caching ► CacheManager ► GetDataCache(Database)
Gets the data cache.
Declaration Syntax
C#
public static DataCache GetDataCache(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The data cache.


GetFilteredItemsCache Method (site)

GetFilteredItemsCache Method (site)
Namespaces ► Sitecore.Caching ► CacheManager ► GetFilteredItemsCache(SiteContext)
Gets the filtered items cache for the specified site.
Declaration Syntax
C#
public static FilteredItemsCache GetFilteredItemsCache(
    SiteContext site
)
Parameters
site (SiteContext)
The site.
Return Value


GetHtmlCache Method (site)

GetHtmlCache Method (site)
Namespaces ► Sitecore.Caching ► CacheManager ► GetHtmlCache(SiteContext)
Gets the HTML cache.
Declaration Syntax
C#
public static HtmlCache GetHtmlCache(
    SiteContext site
)
Parameters
site (SiteContext)
The site.
Return Value
The HTML cache.


GetIsInRoleCache Method

GetIsInRoleCache Method
Namespaces ► Sitecore.Caching ► CacheManager ► GetIsInRoleCache()()()
Gets the is in role cache.
Declaration Syntax
C#
public static IsUserInRoleCache GetIsInRoleCache()
Return Value
The is in role cache.


GetItemCache Method (database)

GetItemCache Method (database)
Namespaces ► Sitecore.Caching ► CacheManager ► GetItemCache(Database)
Gets the item cache of a database.
Declaration Syntax
C#
public static ItemCache GetItemCache(
    Database database
)
Parameters
database (Database)
The database.
Return Value


GetPathCache Method (database)

GetPathCache Method (database)
Namespaces ► Sitecore.Caching ► CacheManager ► GetPathCache(Database)
Gets the path cache.
Declaration Syntax
C#
public static PathCache GetPathCache(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The path cache.


GetRegistryCache Method (site)

GetRegistryCache Method (site)
Namespaces ► Sitecore.Caching ► CacheManager ► GetRegistryCache(SiteContext)
Gets the registry cache.
Declaration Syntax
C#
public static RegistryCache GetRegistryCache(
    SiteContext site
)
Parameters
site (SiteContext)
The site.
Return Value
The registry cache.


GetStatistics Method

GetStatistics Method
Namespaces ► Sitecore.Caching ► CacheManager ► GetStatistics()()()
Gets the statistics.
Declaration Syntax
C#
public static CacheStatistics GetStatistics()
Return Value
The statistics.


GetUserProfileCache Method

GetUserProfileCache Method
Namespaces ► Sitecore.Caching ► CacheManager ► GetUserProfileCache()()()
Gets the user profile cache.
Declaration Syntax
C#
public static UserProfileCache GetUserProfileCache()
Return Value
The user profile cache.


GetViewStateCache Method (site)

GetViewStateCache Method (site)
Namespaces ► Sitecore.Caching ► CacheManager ► GetViewStateCache(SiteContext)
Gets the view state cache.
Declaration Syntax
C#
public static ViewStateCache GetViewStateCache(
    SiteContext site
)
Parameters
site (SiteContext)
The site.
Return Value
The view state cache.


GetXslCache Method (site)

GetXslCache Method (site)
Namespaces ► Sitecore.Caching ► CacheManager ► GetXslCache(SiteContext)
Gets the XSL cache.
Declaration Syntax
C#
public static XslCache GetXslCache(
    SiteContext site
)
Parameters
site (SiteContext)
The site.
Return Value
The XSL cache.


LoadFactor Property

LoadFactor Property
Namespaces ► Sitecore.Caching ► CacheManager ► LoadFactor
Gets or sets the load factor.
Declaration Syntax
C#
public static double LoadFactor { get; set; }
Value
The load factor.


CachePriority Enumeration

CachePriority Enumeration
Namespaces ► Sitecore.Caching ► CachePriority
Represents a cache priority.
Declaration Syntax
C#
public enum CachePriority
Members
Member | Description
Lowest | Lowest.
Low | Low.
BelowNormal | Below normal.
Normal | Normal.
AboveNormal | Above normal.
High | High.
Highest | Highest.
NeverRemove | Never remove.


CacheStatistics Class

CacheStatistics Class
Namespaces ► Sitecore.Caching ► CacheStatistics
Represents cache statistics.
Declaration Syntax
C#
public class CacheStatistics
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CacheStatistics(Int64, Int64) | Initializes a new instance of the CacheStatistics class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalCount | Gets the total count.
 | TotalSize | Gets the total size.
Inheritance Hierarchy
Object
CacheStatistics


CacheStatistics Constructor (totalCount, totalSize)

CacheStatistics Constructor (totalCount, totalSize)
Namespaces ► Sitecore.Caching ► CacheStatistics ► CacheStatistics(Int64, Int64)
Initializes a new instance of the CacheStatistics class.
Declaration Syntax
C#
public CacheStatistics(
    long totalCount,
    long totalSize
)
Parameters
totalCount (Int64)
The total count.
totalSize (Int64)
The total size.


TotalCount Property

TotalCount Property
Namespaces ► Sitecore.Caching ► CacheStatistics ► TotalCount
Gets the total count.
Declaration Syntax
C#
public long TotalCount { get; }
Value
The total count.


TotalSize Property

TotalSize Property
Namespaces ► Sitecore.Caching ► CacheStatistics ► TotalSize
Gets the total size.
Declaration Syntax
C#
public long TotalSize { get; }
Value
The total size.


CustomCache Class

CustomCache Class
Namespaces ► Sitecore.Caching ► CustomCache
CustomCache
Declaration Syntax
C#
public abstract class CustomCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomCache(String, Int64) | Initializes a new instance of the CustomCache class.
 | Clear()()() | Clears this instance.
 | Enabled | Gets or sets a value indicating whether this CustomCache is enabled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID.
 | GetObject(Object) | Gets the object.
 | GetString(String) | Gets the string.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerCache | Gets the inner cache.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Remove(Object) | Removes the specified key.
 | RemoveKeysContaining(String) | Removes the keys containing.
 | RemovePrefix(String) | Removes entries with keys starting with the specified prefix.
 | SetID(String, ID) | Sets the ID.
 | SetObject(ID, ICacheable) | Sets the object.
 | SetObject(String, ICacheable) | Sets the object.
 | SetObject(Object, Object, Int64) | Sets the object.
 | SetObject(ID, Object, Int64) | Sets the object.
 | SetObject(String, Object, Int64) | Sets the object.
 | SetObject(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Sets the object.
 | SetString(String, String) | Sets the string.
 | SetString(String, String, DateTime) | Sets the string.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomCache
 |  | AccessResultCache
 |  | DataCache
 |  | FilteredItemsCache
 |  | HtmlCache
 |  | IsUserInRoleCache
 |  | PathCache
 |  | RegistryCache
 |  | StandardValuesCache
 |  | UserProfileCache
 |  | ViewStateCache
 |  | XslCache


CustomCache Constructor (name, maxSize)

CustomCache Constructor (name, maxSize)
Namespaces ► Sitecore.Caching ► CustomCache ► CustomCache(String, Int64)
Initializes a new instance of the CustomCache class.
Declaration Syntax
C#
protected CustomCache(
    string name,
    long maxSize
)
Parameters
name (String)
The name.
maxSize (Int64)
Size of the max.


Clear Method

Clear Method
Namespaces ► Sitecore.Caching ► CustomCache ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public virtual void Clear()


Enabled Property

Enabled Property
Namespaces ► Sitecore.Caching ► CustomCache ► Enabled
Gets or sets a value indicating whether this CustomCache is enabled.
Declaration Syntax
C#
public virtual bool Enabled { get; set; }
Value
true if enabled; otherwise, false.


GetID Method (key)

GetID Method (key)
Namespaces ► Sitecore.Caching ► CustomCache ► GetID(String)
Gets the ID.
Declaration Syntax
C#
protected ID GetID(
    string key
)
Parameters
key (String)
The key.
Return Value


GetObject Method (key)

GetObject Method (key)
Namespaces ► Sitecore.Caching ► CustomCache ► GetObject(Object)
Gets the object.
Declaration Syntax
C#
protected Object GetObject(
    Object key
)
Parameters
key (Object)
The key.
Return Value


GetString Method (key)

GetString Method (key)
Namespaces ► Sitecore.Caching ► CustomCache ► GetString(String)
Gets the string.
Declaration Syntax
C#
protected string GetString(
    string key
)
Parameters
key (String)
The key.
Return Value


InnerCache Property

InnerCache Property
Namespaces ► Sitecore.Caching ► CustomCache ► InnerCache
Gets the inner cache.
Declaration Syntax
C#
public Cache InnerCache { get; }
Value
The inner cache.


Name Property

Name Property
Namespaces ► Sitecore.Caching ► CustomCache ► Name
Gets the name.
Declaration Syntax
C#
public virtual string Name { get; }
Value
The name.


Remove Method (key)

Remove Method (key)
Namespaces ► Sitecore.Caching ► CustomCache ► Remove(Object)
Removes the specified key.
Declaration Syntax
C#
protected void Remove(
    Object key
)
Parameters
key (Object)
The key.


RemoveKeysContaining Method (value)

RemoveKeysContaining Method (value)
Namespaces ► Sitecore.Caching ► CustomCache ► RemoveKeysContaining(String)
Removes the keys containing.
Declaration Syntax
C#
public virtual void RemoveKeysContaining(
    string value
)
Parameters
value (String)
The value.


RemovePrefix Method (prefix)

RemovePrefix Method (prefix)
Namespaces ► Sitecore.Caching ► CustomCache ► RemovePrefix(String)
Removes entries with keys starting with the specified prefix.
Declaration Syntax
C#
public virtual void RemovePrefix(
    string prefix
)
Parameters
prefix (String)
The prefix.


SetID Method (key, value)

SetID Method (key, value)
Namespaces ► Sitecore.Caching ► CustomCache ► SetID(String, ID)
Sets the ID.
Declaration Syntax
C#
protected void SetID(
    string key,
    ID value
)
Parameters
key (String)
The key.
value (ID)
The value.


SetObject Method

SetObject Method
Namespaces ► Sitecore.Caching ► CustomCache ► SetObject()()()
Members
Icon | Member | Description
 | SetObject(ID, ICacheable) | Sets the object.
 | SetObject(String, ICacheable) | Sets the object.
 | SetObject(Object, Object, Int64) | Sets the object.
 | SetObject(ID, Object, Int64) | Sets the object.
 | SetObject(String, Object, Int64) | Sets the object.
 | SetObject(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Sets the object.


SetObject Method (key, value)

SetObject Method (key, value)
Namespaces ► Sitecore.Caching ► CustomCache ► SetObject(ID, ICacheable)
Sets the object.
Declaration Syntax
C#
protected void SetObject(
    ID key,
    ICacheable value
)
Parameters
key (ID)
The key.
value (ICacheable)
The value.


SetObject Method (key, value, size)

SetObject Method (key, value, size)
Namespaces ► Sitecore.Caching ► CustomCache ► SetObject(ID, Object, Int64)
Sets the object.
Declaration Syntax
C#
protected void SetObject(
    ID key,
    Object value,
    long size
)
Parameters
key (ID)
The key.
value (Object)
The value.
size (Int64)
The size.


SetObject Method (key, value, size)

SetObject Method (key, value, size)
Namespaces ► Sitecore.Caching ► CustomCache ► SetObject(Object, Object, Int64)
Sets the object.
Declaration Syntax
C#
protected void SetObject(
    Object key,
    Object value,
    long size
)
Parameters
key (Object)
The key.
value (Object)
The value.
size (Int64)
The size.


SetObject Method (key, value)

SetObject Method (key, value)
Namespaces ► Sitecore.Caching ► CustomCache ► SetObject(String, ICacheable)
Sets the object.
Declaration Syntax
C#
protected void SetObject(
    string key,
    ICacheable value
)
Parameters
key (String)
The key.
value (ICacheable)
The value.


SetObject Method (key, value, size)

SetObject Method (key, value, size)
Namespaces ► Sitecore.Caching ► CustomCache ► SetObject(String, Object, Int64)
Sets the object.
Declaration Syntax
C#
protected void SetObject(
    string key,
    Object value,
    long size
)
Parameters
key (String)
The key.
value (Object)
The value.
size (Int64)
The size.


SetObject Method (key, value, size, removedHandler)

SetObject Method (key, value, size, removedHandler)
Namespaces ► Sitecore.Caching ► CustomCache ► SetObject(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>))
Sets the object.
Declaration Syntax
C#
protected void SetObject(
    string key,
    Object value,
    long size,
    EventHandler<EntryRemovedEventArgs> removedHandler
)
Parameters
key (String)
The key.
value (Object)
The value.
size (Int64)
The size.
removedHandler (EventHandler<(Of <( EntryRemovedEventArgs >)>))
The removed handler.


SetString Method

SetString Method
Namespaces ► Sitecore.Caching ► CustomCache ► SetString()()()
Members
Icon | Member | Description
 | SetString(String, String) | Sets the string.
 | SetString(String, String, DateTime) | Sets the string.


SetString Method (key, value)

SetString Method (key, value)
Namespaces ► Sitecore.Caching ► CustomCache ► SetString(String, String)
Sets the string.
Declaration Syntax
C#
protected void SetString(
    string key,
    string value
)
Parameters
key (String)
The key.
value (String)
The value.


SetString Method (key, value, expiry)

SetString Method (key, value, expiry)
Namespaces ► Sitecore.Caching ► CustomCache ► SetString(String, String, DateTime)
Sets the string.
Declaration Syntax
C#
protected void SetString(
    string key,
    string value,
    DateTime expiry
)
Parameters
key (String)
The key.
value (String)
The value.
expiry (DateTime)
The expiry.


DataCache Class

DataCache Class
Namespaces ► Sitecore.Caching ► DataCache
Represents a data cache.
Declaration Syntax
C#
public class DataCache : CustomCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCache(Database, Int64) | Initializes a new instance of the DataCache class.
 | AddItemInformation(ID, ItemInformation) | Adds the item information.
 | Clear(Database) | Clears the specified database.
 | Clear()()() | Clears this instance. (Inherited from CustomCache.)
 | ContainsNullItem(ID) | Determines whether [contains null item] [the specified item id].
 | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Overrides CustomCache.Enabled.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from CustomCache.)
 | GetItemInformation(ID) | Gets the item information.
 | GetObject(Object) | Gets the object. (Inherited from CustomCache.)
 | GetString(String) | Gets the string. (Inherited from CustomCache.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomCache.)
 | RegisterNullItem(ID) | Registers the null item.
 | Remove(Object) | Removes the specified key. (Inherited from CustomCache.)
 | RemoveItemInformation(ID) | Removes the item information.
 | RemoveKeysContaining(String) | Removes the keys containing. (Inherited from CustomCache.)
 | RemovePrefix(String) | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
 | SetID(String, ID) | Sets the ID. (Inherited from CustomCache.)
 | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Sets the object. (Inherited from CustomCache.)
 | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
 | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnregisterNullItem(ID) | Unregisters the null item.
Inheritance Hierarchy
Object
 | CustomCache
 |  | DataCache


DataCache Constructor (database, maxSize)

DataCache Constructor (database, maxSize)
Namespaces ► Sitecore.Caching ► DataCache ► DataCache(Database, Int64)
Initializes a new instance of the DataCache class.
Declaration Syntax
C#
public DataCache(
    Database database,
    long maxSize
)
Parameters
database (Database)
The database owning the cache.
maxSize (Int64)
The maximum size of the cache (in bytes).


AddItemInformation Method (itemID, itemInformation)

AddItemInformation Method (itemID, itemInformation)
Namespaces ► Sitecore.Caching ► DataCache ► AddItemInformation(ID, ItemInformation)
Adds the item information.
Declaration Syntax
C#
public void AddItemInformation(
    ID itemID,
    ItemInformation itemInformation
)
Parameters
itemID (ID)
The item ID.
itemInformation (ItemInformation)
The item information.


Clear Method (database)

Clear Method (database)
Namespaces ► Sitecore.Caching ► DataCache ► Clear(Database)
Clears the specified database.
Declaration Syntax
C#
public static void Clear(
    Database database
)
Parameters
database (Database)
The database.


ContainsNullItem Method (itemId)

ContainsNullItem Method (itemId)
Namespaces ► Sitecore.Caching ► DataCache ► ContainsNullItem(ID)
Determines whether [contains null item] [the specified item id].
Declaration Syntax
C#
public bool ContainsNullItem(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value
true if [contains null item] [the specified item id]; otherwise, false.


Enabled Property

Enabled Property
Namespaces ► Sitecore.Caching ► DataCache ► Enabled
Gets or sets a value indicating whether this CustomCache is enabled.
Declaration Syntax
C#
public override bool Enabled { get; }
Value
true if enabled; otherwise, false.


GetItemInformation Method (itemID)

GetItemInformation Method (itemID)
Namespaces ► Sitecore.Caching ► DataCache ► GetItemInformation(ID)
Gets the item information.
Declaration Syntax
C#
public ItemInformation GetItemInformation(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value
The item information.


RegisterNullItem Method (itemId)

RegisterNullItem Method (itemId)
Namespaces ► Sitecore.Caching ► DataCache ► RegisterNullItem(ID)
Registers the null item.
Declaration Syntax
C#
public void RegisterNullItem(
    ID itemId
)
Parameters
itemId (ID)
The item id.


RemoveItemInformation Method (itemID)

RemoveItemInformation Method (itemID)
Namespaces ► Sitecore.Caching ► DataCache ► RemoveItemInformation(ID)
Removes the item information.
Declaration Syntax
C#
public void RemoveItemInformation(
    ID itemID
)
Parameters
itemID (ID)
The item ID.


UnregisterNullItem Method (itemId)

UnregisterNullItem Method (itemId)
Namespaces ► Sitecore.Caching ► DataCache ► UnregisterNullItem(ID)
Unregisters the null item.
Declaration Syntax
C#
public void UnregisterNullItem(
    ID itemId
)
Parameters
itemId (ID)
The item id.


DataLengthChangedDelegate Delegate

DataLengthChangedDelegate Delegate
Namespaces ► Sitecore.Caching ► DataLengthChangedDelegate
Declaration Syntax
C#
public delegate void DataLengthChangedDelegate(
    ICacheable obj
)
Parameters
obj (ICacheable)


EntryRemovedEventArgs Class

EntryRemovedEventArgs Class
Namespaces ► Sitecore.Caching ► EntryRemovedEventArgs
Argument for the EntryRemoved event.
Declaration Syntax
C#
public class EntryRemovedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EntryRemovedEventArgs(Cache..::.CacheEntry) | Initializes a new instance of the EntryRemovedEventArgs class.
 | Entry | Gets the entry that triggered the evtn.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | EntryRemovedEventArgs


EntryRemovedEventArgs Constructor (entry)

EntryRemovedEventArgs Constructor (entry)
Namespaces ► Sitecore.Caching ► EntryRemovedEventArgs ► EntryRemovedEventArgs(Cache..::.CacheEntry)
Initializes a new instance of the EntryRemovedEventArgs class.
Declaration Syntax
C#
public EntryRemovedEventArgs(
    Cache..::.CacheEntry entry
)
Parameters
entry (Cache..::.CacheEntry)


Entry Property

Entry Property
Namespaces ► Sitecore.Caching ► EntryRemovedEventArgs ► Entry
Gets the entry that triggered the evtn.
Declaration Syntax
C#
public Cache..::.CacheEntry Entry { get; }
Value
The entry.


FilteredItemsCache Class

FilteredItemsCache Class
Namespaces ► Sitecore.Caching ► FilteredItemsCache
FilteredItemsCache class
Declaration Syntax
C#
public class FilteredItemsCache : CustomCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FilteredItemsCache(SiteInfo, Int64) | Initializes a new instance of the FilteredItemsCache class.
 | Clear()()() | Clears this instance. (Inherited from CustomCache.)
 | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from CustomCache.)
 | GetObject(Object) | Gets the object. (Inherited from CustomCache.)
 | GetString(String) | Gets the string. (Inherited from CustomCache.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomCache.)
 | Remove(Object) | Removes the specified key. (Inherited from CustomCache.)
 | RemoveKeysContaining(String) | Removes the keys containing. (Inherited from CustomCache.)
 | RemovePrefix(String) | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
 | SetID(String, ID) | Sets the ID. (Inherited from CustomCache.)
 | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Sets the object. (Inherited from CustomCache.)
 | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
 | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomCache
 |  | FilteredItemsCache


FilteredItemsCache Constructor (siteInfo, maxSize)

FilteredItemsCache Constructor (siteInfo, maxSize)
Namespaces ► Sitecore.Caching ► FilteredItemsCache ► FilteredItemsCache(SiteInfo, Int64)
Initializes a new instance of the FilteredItemsCache class.
Declaration Syntax
C#
public FilteredItemsCache(
    SiteInfo siteInfo,
    long maxSize
)
Parameters
siteInfo (SiteInfo)
The site info.
maxSize (Int64)
Size of the max.


HtmlCache Class

HtmlCache Class
Namespaces ► Sitecore.Caching ► HtmlCache
Represents a html cache.
Declaration Syntax
C#
public class HtmlCache : CustomCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlCache(SiteInfo, Int64) | Initializes a new instance of the HtmlCache class.
 | Clear()()() | Clears this instance. (Overrides CustomCache.Clear()()().)
 | Clear(Boolean) | Clears this instance.
 | ClearLatency | Gets the clear latency.
 | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHtml(String) | Gets the HTML.
 | GetID(String) | Gets the ID. (Inherited from CustomCache.)
 | GetObject(Object) | Gets the object. (Inherited from CustomCache.)
 | GetString(String) | Gets the string. (Inherited from CustomCache.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomCache.)
 | Remove(Object) | Removes the specified key. (Inherited from CustomCache.)
 | RemoveKeysContaining(String) | Removes the keys containing. (Inherited from CustomCache.)
 | RemovePrefix(String) | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
 | SetHtml(String, String) | Sets the HTML.
 | SetHtml(String, String, TimeSpan) | Sets the HTML.
 | SetHtml(String, String, DateTime) | Sets the HTML.
 | SetID(String, ID) | Sets the ID. (Inherited from CustomCache.)
 | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Sets the object. (Inherited from CustomCache.)
 | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
 | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomCache
 |  | HtmlCache


HtmlCache Constructor (site, maxSize)

HtmlCache Constructor (site, maxSize)
Namespaces ► Sitecore.Caching ► HtmlCache ► HtmlCache(SiteInfo, Int64)
Initializes a new instance of the HtmlCache class.
Declaration Syntax
C#
public HtmlCache(
    SiteInfo site,
    long maxSize
)
Parameters
site (SiteInfo)
The site.
maxSize (Int64)
Size of the max.


Clear Method

Clear Method
Namespaces ► Sitecore.Caching ► HtmlCache ► Clear()()()
Members
Icon | Member | Description
 | Clear()()() | Clears this instance. (Overrides CustomCache.Clear()()().)
 | Clear(Boolean) | Clears this instance.


Clear Method

Clear Method
Namespaces ► Sitecore.Caching ► HtmlCache ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public override void Clear()


Clear Method (force)

Clear Method (force)
Namespaces ► Sitecore.Caching ► HtmlCache ► Clear(Boolean)
Clears this instance.
Declaration Syntax
C#
public virtual void Clear(
    bool force
)
Parameters
force (Boolean)
if set to true, the cache will be cleared immediately. Otherwise, the cache will be cleared according to the ClearLatency property.


ClearLatency Property

ClearLatency Property
Namespaces ► Sitecore.Caching ► HtmlCache ► ClearLatency
Gets the clear latency.
Declaration Syntax
C#
public virtual TimeSpan ClearLatency { get; set; }
Value
The clear latency.


GetHtml Method (key)

GetHtml Method (key)
Namespaces ► Sitecore.Caching ► HtmlCache ► GetHtml(String)
Gets the HTML.
Declaration Syntax
C#
public string GetHtml(
    string key
)
Parameters
key (String)
The key.
Return Value
The HTML.


SetHtml Method

SetHtml Method
Namespaces ► Sitecore.Caching ► HtmlCache ► SetHtml()()()
Members
Icon | Member | Description
 | SetHtml(String, String) | Sets the HTML.
 | SetHtml(String, String, TimeSpan) | Sets the HTML.
 | SetHtml(String, String, DateTime) | Sets the HTML.


SetHtml Method (key, html)

SetHtml Method (key, html)
Namespaces ► Sitecore.Caching ► HtmlCache ► SetHtml(String, String)
Sets the HTML.
Declaration Syntax
C#
public void SetHtml(
    string key,
    string html
)
Parameters
key (String)
The key.
html (String)
The HTML.


SetHtml Method (key, html, expiryUtcDate)

SetHtml Method (key, html, expiryUtcDate)
Namespaces ► Sitecore.Caching ► HtmlCache ► SetHtml(String, String, DateTime)
Sets the HTML.
Declaration Syntax
C#
public void SetHtml(
    string key,
    string html,
    DateTime expiryUtcDate
)
Parameters
key (String)
The key.
html (String)
The HTML.
expiryUtcDate (DateTime)
The UTC date at which the cache entry will expire.


SetHtml Method (key, html, timeout)

SetHtml Method (key, html, timeout)
Namespaces ► Sitecore.Caching ► HtmlCache ► SetHtml(String, String, TimeSpan)
Sets the HTML.
Declaration Syntax
C#
public void SetHtml(
    string key,
    string html,
    TimeSpan timeout
)
Parameters
key (String)
The key.
html (String)
The HTML.
timeout (TimeSpan)
The timeout.


ICacheable Interface

ICacheable Interface
Namespaces ► Sitecore.Caching ► ICacheable
Defines the basic properties and functionality of an object that is cacheable.
Declaration Syntax
C#
public interface ICacheable
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Cacheable | Gets or sets a value indicating whether this ICacheable is cacheable.
 | DataLengthChanged |
 | GetDataLength()()() | Gets the size of the data to use when caching.
 | Immutable | Gets a value indicating whether this ICacheable is immutable.


Cacheable Property

Cacheable Property
Namespaces ► Sitecore.Caching ► ICacheable ► Cacheable
Gets or sets a value indicating whether this ICacheable is cacheable.
Declaration Syntax
C#
bool Cacheable { get; set; }
Value
true if cacheable; otherwise, false.


DataLengthChanged Event

DataLengthChanged Event
Namespaces ► Sitecore.Caching ► ICacheable ► DataLengthChanged
Declaration Syntax
C#
event DataLengthChangedDelegate DataLengthChanged


GetDataLength Method

GetDataLength Method
Namespaces ► Sitecore.Caching ► ICacheable ► GetDataLength()()()
Gets the size of the data to use when caching.
Declaration Syntax
C#
long GetDataLength()
Return Value


Immutable Property

Immutable Property
Namespaces ► Sitecore.Caching ► ICacheable ► Immutable
Gets a value indicating whether this ICacheable is immutable.
Declaration Syntax
C#
bool Immutable { get; }
Value
true if immutable; otherwise, false.


ItemCache Class

ItemCache Class
Namespaces ► Sitecore.Caching ► ItemCache
ItemCache
Declaration Syntax
C#
public class ItemCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemCache(Database, Int64) | Initializes a new instance of the DataCache class.
 | AddItem(ID, Language, Version, Item) | Adds an item to the cache.
 | Clear()()() | Clears the cache.
 | Enabled | Gets or sets a value indicating whether this ItemCache is enabled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(ID, Language, Version) | Gets an item from the cache.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveItem(ID) | Removes all versions of an item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemCache


ItemCache Constructor (database, maxSize)

ItemCache Constructor (database, maxSize)
Namespaces ► Sitecore.Caching ► ItemCache ► ItemCache(Database, Int64)
Initializes a new instance of the DataCache class.
Declaration Syntax
C#
public ItemCache(
    Database database,
    long maxSize
)
Parameters
database (Database)
The database owning the cache.
maxSize (Int64)
The maximum size of the cache (in bytes).


AddItem Method (itemId, language, version, item)

AddItem Method (itemId, language, version, item)
Namespaces ► Sitecore.Caching ► ItemCache ► AddItem(ID, Language, Version, Item)
Adds an item to the cache.
Declaration Syntax
C#
public void AddItem(
    ID itemId,
    Language language,
    Version version,
    Item item
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
version (Version)
The version.
item (Item)
The item.


Clear Method

Clear Method
Namespaces ► Sitecore.Caching ► ItemCache ► Clear()()()
Clears the cache.
Declaration Syntax
C#
public virtual void Clear()


Enabled Property

Enabled Property
Namespaces ► Sitecore.Caching ► ItemCache ► Enabled
Gets or sets a value indicating whether this ItemCache is enabled.
Declaration Syntax
C#
public virtual bool Enabled { get; set; }
Value
true if enabled; otherwise, false.


GetItem Method (itemId, language, version)

GetItem Method (itemId, language, version)
Namespaces ► Sitecore.Caching ► ItemCache ► GetItem(ID, Language, Version)
Gets an item from the cache.
Declaration Syntax
C#
public Item GetItem(
    ID itemId,
    Language language,
    Version version
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
version (Version)
The version.
Return Value


RemoveItem Method (itemId)

RemoveItem Method (itemId)
Namespaces ► Sitecore.Caching ► ItemCache ► RemoveItem(ID)
Removes all versions of an item.
Declaration Syntax
C#
public virtual void RemoveItem(
    ID itemId
)
Parameters
itemId (ID)
The item id.


ItemRelation Class

ItemRelation Class
Namespaces ► Sitecore.Caching ► ItemRelation
Represents an item relation.
Declaration Syntax
C#
public class ItemRelation : ICacheable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemRelation(ID, array<ID>[]()[]) | Initializes a new instance of the ItemRelation class.
 | ChildIDs | Gets the child I ds.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentID | Gets the parent ID.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemRelation


ItemRelation Constructor (parentID, childIDs)

ItemRelation Constructor (parentID, childIDs)
Namespaces ► Sitecore.Caching ► ItemRelation ► ItemRelation(ID, array<ID>[]()[])
Initializes a new instance of the ItemRelation class.
Declaration Syntax
C#
public ItemRelation(
    ID parentID,
    ID[] childIDs
)
Parameters
parentID (ID)
The parent ID.
childIDs (array< ID >[]()[])
The child I ds.


ChildIDs Property

ChildIDs Property
Namespaces ► Sitecore.Caching ► ItemRelation ► ChildIDs
Gets the child I ds.
Declaration Syntax
C#
public ID[] ChildIDs { get; }
Value
The child I ds.


ParentID Property

ParentID Property
Namespaces ► Sitecore.Caching ► ItemRelation ► ParentID
Gets the parent ID.
Declaration Syntax
C#
public ID ParentID { get; }
Value
The parent ID.


ItemsContext Class

ItemsContext Class
Namespaces ► Sitecore.Caching ► ItemsContext
Declaration Syntax
C#
public class ItemsContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemsContext()()() | Initializes a new instance of the ItemsContext class
 | Add(Object, Object) | Adds the specified value to the dictionary.
 | Clear()()() | Clears this instance.
 | Contains(Object) | Determines whether the dictionary contains the the specified key.
 | Count | Gets the count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets or sets the Object with the specified key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes the specified key.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemsContext


ItemsContext Constructor

ItemsContext Constructor
Namespaces ► Sitecore.Caching ► ItemsContext ► ItemsContext()()()
Initializes a new instance of the ItemsContext class
Declaration Syntax
C#
public ItemsContext()


Add Method (key, value)

Add Method (key, value)
Namespaces ► Sitecore.Caching ► ItemsContext ► Add(Object, Object)
Adds the specified value to the dictionary.
Declaration Syntax
C#
public void Add(
    Object key,
    Object value
)
Parameters
key (Object)
The key.
value (Object)
The value.


Clear Method

Clear Method
Namespaces ► Sitecore.Caching ► ItemsContext ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public void Clear()


Contains Method (key)

Contains Method (key)
Namespaces ► Sitecore.Caching ► ItemsContext ► Contains(Object)
Determines whether the dictionary contains the the specified key.
Declaration Syntax
C#
public bool Contains(
    Object key
)
Parameters
key (Object)
The key.
Return Value
true if the dictionary contains the the specified key; otherwise, false.


Count Property

Count Property
Namespaces ► Sitecore.Caching ► ItemsContext ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


Item Property (key)

Item Property (key)
Namespaces ► Sitecore.Caching ► ItemsContext ► Item[([(String])])
Gets or sets the Object with the specified key.
Declaration Syntax
C#
public Object this[
    string key
] { get; set; }
Parameters
key (String)
Value


Remove Method (key)

Remove Method (key)
Namespaces ► Sitecore.Caching ► ItemsContext ► Remove(String)
Removes the specified key.
Declaration Syntax
C#
public void Remove(
    string key
)
Parameters
key (String)
The key.


PathCache Class

PathCache Class
Namespaces ► Sitecore.Caching ► PathCache
Represents a path cache.
Declaration Syntax
C#
public class PathCache : CustomCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PathCache(Database, Int64) | Initializes a new instance of the PathCache class.
 | AddMapping(String, ID) | Adds the mapping.
 | AddMapping(String, ID, Database) | Adds the mapping.
 | Clear()()() | Clears this instance. (Overrides CustomCache.Clear()()().)
 | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Overrides CustomCache.Enabled.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from CustomCache.)
 | GetMapping(String) | Gets the mapping.
 | GetMapping(String, Database) | Gets the mapping.
 | GetObject(Object) | Gets the object. (Inherited from CustomCache.)
 | GetString(String) | Gets the string. (Inherited from CustomCache.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomCache.)
 | Remove(Object) | Removes the specified key. (Inherited from CustomCache.)
 | RemoveKeysContaining(String) | Removes the keys containing. (Inherited from CustomCache.)
 | RemoveMappingsContaining(ID) | Removes the mappings containing.
 | RemoveMappingsContaining(String) | Removes the mappings containing.
 | RemoveMappingsContaining(ID, Database) | Removes the mappings containing.
 | RemoveMappingsContaining(String, Database) | Removes the mappings containing.
 | RemovePrefix(String) | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
 | SetID(String, ID) | Sets the ID. (Inherited from CustomCache.)
 | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Sets the object. (Inherited from CustomCache.)
 | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
 | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomCache
 |  | PathCache


PathCache Constructor (database, maxSize)

PathCache Constructor (database, maxSize)
Namespaces ► Sitecore.Caching ► PathCache ► PathCache(Database, Int64)
Initializes a new instance of the PathCache class.
Declaration Syntax
C#
public PathCache(
    Database database,
    long maxSize
)
Parameters
database (Database)
The database.
maxSize (Int64)
Size of the max.


AddMapping Method

AddMapping Method
Namespaces ► Sitecore.Caching ► PathCache ► AddMapping()()()
Members
Icon | Member | Description
 | AddMapping(String, ID) | Adds the mapping.
 | AddMapping(String, ID, Database) | Adds the mapping.


AddMapping Method (itemPath, itemID)

AddMapping Method (itemPath, itemID)
Namespaces ► Sitecore.Caching ► PathCache ► AddMapping(String, ID)
Adds the mapping.
Declaration Syntax
C#
public void AddMapping(
    string itemPath,
    ID itemID
)
Parameters
itemPath (String)
The item path.
itemID (ID)
The item ID.


AddMapping Method (itemPath, itemID, database)

AddMapping Method (itemPath, itemID, database)
Namespaces ► Sitecore.Caching ► PathCache ► AddMapping(String, ID, Database)
Adds the mapping.
Declaration Syntax
C#
public static void AddMapping(
    string itemPath,
    ID itemID,
    Database database
)
Parameters
itemPath (String)
The item path.
itemID (ID)
The item ID.
database (Database)
The database.


Clear Method

Clear Method
Namespaces ► Sitecore.Caching ► PathCache ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public override void Clear()


Enabled Property

Enabled Property
Namespaces ► Sitecore.Caching ► PathCache ► Enabled
Gets or sets a value indicating whether this CustomCache is enabled.
Declaration Syntax
C#
public override bool Enabled { get; }
Value
true if enabled; otherwise, false.


GetMapping Method

GetMapping Method
Namespaces ► Sitecore.Caching ► PathCache ► GetMapping()()()
Members
Icon | Member | Description
 | GetMapping(String) | Gets the mapping.
 | GetMapping(String, Database) | Gets the mapping.


GetMapping Method (itemPath)

GetMapping Method (itemPath)
Namespaces ► Sitecore.Caching ► PathCache ► GetMapping(String)
Gets the mapping.
Declaration Syntax
C#
public ID GetMapping(
    string itemPath
)
Parameters
itemPath (String)
The item path.
Return Value
The mapping.


GetMapping Method (itemPath, database)

GetMapping Method (itemPath, database)
Namespaces ► Sitecore.Caching ► PathCache ► GetMapping(String, Database)
Gets the mapping.
Declaration Syntax
C#
public static ID GetMapping(
    string itemPath,
    Database database
)
Parameters
itemPath (String)
The item path.
database (Database)
The database.
Return Value
The mapping.


RemoveMappingsContaining Method

RemoveMappingsContaining Method
Namespaces ► Sitecore.Caching ► PathCache ► RemoveMappingsContaining()()()
Members
Icon | Member | Description
 | RemoveMappingsContaining(ID) | Removes the mappings containing.
 | RemoveMappingsContaining(String) | Removes the mappings containing.
 | RemoveMappingsContaining(ID, Database) | Removes the mappings containing.
 | RemoveMappingsContaining(String, Database) | Removes the mappings containing.


RemoveMappingsContaining Method (itemID)

RemoveMappingsContaining Method (itemID)
Namespaces ► Sitecore.Caching ► PathCache ► RemoveMappingsContaining(ID)
Removes the mappings containing.
Declaration Syntax
C#
public void RemoveMappingsContaining(
    ID itemID
)
Parameters
itemID (ID)
The item ID.


RemoveMappingsContaining Method (itemID, database)

RemoveMappingsContaining Method (itemID, database)
Namespaces ► Sitecore.Caching ► PathCache ► RemoveMappingsContaining(ID, Database)
Removes the mappings containing.
Declaration Syntax
C#
public static void RemoveMappingsContaining(
    ID itemID,
    Database database
)
Parameters
itemID (ID)
The item ID.
database (Database)
The database.


RemoveMappingsContaining Method (value)

RemoveMappingsContaining Method (value)
Namespaces ► Sitecore.Caching ► PathCache ► RemoveMappingsContaining(String)
Removes the mappings containing.
Declaration Syntax
C#
public void RemoveMappingsContaining(
    string value
)
Parameters
value (String)
The value.


RemoveMappingsContaining Method (value, database)

RemoveMappingsContaining Method (value, database)
Namespaces ► Sitecore.Caching ► PathCache ► RemoveMappingsContaining(String, Database)
Removes the mappings containing.
Declaration Syntax
C#
public static void RemoveMappingsContaining(
    string value,
    Database database
)
Parameters
value (String)
The value.
database (Database)
The database.


RegistryCache Class

RegistryCache Class
Namespaces ► Sitecore.Caching ► RegistryCache
Represents a registry cache.
Declaration Syntax
C#
public class RegistryCache : CustomCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegistryCache(SiteInfo, Int64) | Initializes a new instance of the RegistryCache class.
 | Clear()()() | Clears this instance. (Overrides CustomCache.Clear()()().)
 | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from CustomCache.)
 | GetObject(Object) | Gets the object. (Inherited from CustomCache.)
 | GetString(String) | Gets the string. (Inherited from CustomCache.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(String) | Gets the value.
 | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomCache.)
 | Remove(Object) | Removes the specified key. (Inherited from CustomCache.)
 | RemoveKeysContaining(String) | Removes the keys containing. (Inherited from CustomCache.)
 | RemovePrefix(String) | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
 | SetID(String, ID) | Sets the ID. (Inherited from CustomCache.)
 | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Sets the object. (Inherited from CustomCache.)
 | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
 | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
 | SetValue(String, String) | Sets the value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomCache
 |  | RegistryCache


RegistryCache Constructor (site, maxSize)

RegistryCache Constructor (site, maxSize)
Namespaces ► Sitecore.Caching ► RegistryCache ► RegistryCache(SiteInfo, Int64)
Initializes a new instance of the RegistryCache class.
Declaration Syntax
C#
public RegistryCache(
    SiteInfo site,
    long maxSize
)
Parameters
site (SiteInfo)
The site.
maxSize (Int64)
Size of the max.


Clear Method

Clear Method
Namespaces ► Sitecore.Caching ► RegistryCache ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public override void Clear()


GetValue Method (key)

GetValue Method (key)
Namespaces ► Sitecore.Caching ► RegistryCache ► GetValue(String)
Gets the value.
Declaration Syntax
C#
public string GetValue(
    string key
)
Parameters
key (String)
The key.
Return Value
The value.


SetValue Method (key, value)

SetValue Method (key, value)
Namespaces ► Sitecore.Caching ► RegistryCache ► SetValue(String, String)
Sets the value.
Declaration Syntax
C#
public void SetValue(
    string key,
    string value
)
Parameters
key (String)
The key.
value (String)
The value.


StandardValuesCache Class

StandardValuesCache Class
Namespaces ► Sitecore.Caching ► StandardValuesCache
StandardValuesCache class
Declaration Syntax
C#
public class StandardValuesCache : CustomCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StandardValuesCache(Database, Int64) | Initializes a new instance of the StandardValuesCache class.
 | AddStandardValues(Item, SafeDictionary<(Of <(ID, String>)>)) | Adds standard values for an item.
 | Clear()()() | Clears this instance. (Inherited from CustomCache.)
 | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from CustomCache.)
 | GetObject(Object) | Gets the object. (Inherited from CustomCache.)
 | GetStandardValues(Item) | Gets the standard values for an item.
 | GetString(String) | Gets the string. (Inherited from CustomCache.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomCache.)
 | Remove(Object) | Removes the specified key. (Inherited from CustomCache.)
 | RemoveKeysContaining(String) | Removes the keys containing. (Inherited from CustomCache.)
 | RemovePrefix(String) | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
 | SetID(String, ID) | Sets the ID. (Inherited from CustomCache.)
 | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Sets the object. (Inherited from CustomCache.)
 | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
 | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomCache
 |  | StandardValuesCache


StandardValuesCache Constructor (database, maxSize)

StandardValuesCache Constructor (database, maxSize)
Namespaces ► Sitecore.Caching ► StandardValuesCache ► StandardValuesCache(Database, Int64)
Initializes a new instance of the StandardValuesCache class.
Declaration Syntax
C#
public StandardValuesCache(
    Database database,
    long maxSize
)
Parameters
database (Database)
The database.
maxSize (Int64)
Size of the max.


AddStandardValues Method (item, values)

AddStandardValues Method (item, values)
Namespaces ► Sitecore.Caching ► StandardValuesCache ► AddStandardValues(Item, SafeDictionary<(Of <(ID, String>)>))
Adds standard values for an item.
Declaration Syntax
C#
public void AddStandardValues(
    Item item,
    SafeDictionary<ID, string> values
)
Parameters
item (Item)
The item.
values (SafeDictionary <(Of <( ID, String>)>))
The values.


GetStandardValues Method (item)

GetStandardValues Method (item)
Namespaces ► Sitecore.Caching ► StandardValuesCache ► GetStandardValues(Item)
Gets the standard values for an item.
Declaration Syntax
C#
public SafeDictionary<ID, string> GetStandardValues(
    Item item
)
Parameters
item (Item)
The item.
Return Value


ViewStateCache Class

ViewStateCache Class
Namespaces ► Sitecore.Caching ► ViewStateCache
Represents a view state cache.
Declaration Syntax
C#
public class ViewStateCache : CustomCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ViewStateCache(SiteInfo, Int64) | Initializes a new instance of the ViewStateCache class.
 | Clear()()() | Clears this instance. (Overrides CustomCache.Clear()()().)
 | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from CustomCache.)
 | GetObject(Object) | Gets the object. (Inherited from CustomCache.)
 | GetString(String) | Gets the string. (Inherited from CustomCache.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewState(String) | Gets the state of the view.
 | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomCache.)
 | Remove(Object) | Removes the specified key. (Inherited from CustomCache.)
 | RemoveKeysContaining(String) | Removes the keys containing. (Inherited from CustomCache.)
 | RemovePrefix(String) | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
 | SetID(String, ID) | Sets the ID. (Inherited from CustomCache.)
 | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Sets the object. (Inherited from CustomCache.)
 | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
 | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
 | SetViewState(String, String) | Sets the state of the view.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomCache
 |  | ViewStateCache


ViewStateCache Constructor (site, maxSize)

ViewStateCache Constructor (site, maxSize)
Namespaces ► Sitecore.Caching ► ViewStateCache ► ViewStateCache(SiteInfo, Int64)
Initializes a new instance of the ViewStateCache class.
Declaration Syntax
C#
public ViewStateCache(
    SiteInfo site,
    long maxSize
)
Parameters
site (SiteInfo)
The site.
maxSize (Int64)
Size of the max.


Clear Method

Clear Method
Namespaces ► Sitecore.Caching ► ViewStateCache ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public override void Clear()


GetViewState Method (key)

GetViewState Method (key)
Namespaces ► Sitecore.Caching ► ViewStateCache ► GetViewState(String)
Gets the state of the view.
Declaration Syntax
C#
public string GetViewState(
    string key
)
Parameters
key (String)
The key.
Return Value
The String.


SetViewState Method (key, value)

SetViewState Method (key, value)
Namespaces ► Sitecore.Caching ► ViewStateCache ► SetViewState(String, String)
Sets the state of the view.
Declaration Syntax
C#
public void SetViewState(
    string key,
    string value
)
Parameters
key (String)
The key.
value (String)
The value.


XslCache Class

XslCache Class
Namespaces ► Sitecore.Caching ► XslCache
Represents a Xsl cache.
Declaration Syntax
C#
public class XslCache : CustomCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XslCache(SiteInfo, Int64) | Initializes a new instance of the XslCache class.
 | Clear()()() | Clears this instance. (Overrides CustomCache.Clear()()().)
 | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from CustomCache.)
 | GetObject(Object) | Gets the object. (Inherited from CustomCache.)
 | GetString(String) | Gets the string. (Inherited from CustomCache.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXsl(String) | Obsolete. Gets the XSL.
 | GetXslTransform(String) | Gets the XSL transform.
 | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomCache.)
 | Remove(Object) | Removes the specified key. (Inherited from CustomCache.)
 | RemoveKeysContaining(String) | Removes the keys containing. (Inherited from CustomCache.)
 | RemovePrefix(String) | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
 | SetID(String, ID) | Sets the ID. (Inherited from CustomCache.)
 | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Sets the object. (Inherited from CustomCache.)
 | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
 | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
 | SetXsl(String, XslTransform) | Obsolete. Sets the XSL.
 | SetXslTransform(String, MvpXslTransform) | Sets the XSL transform.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomCache
 |  | XslCache


XslCache Constructor (site, maxSize)

XslCache Constructor (site, maxSize)
Namespaces ► Sitecore.Caching ► XslCache ► XslCache(SiteInfo, Int64)
Initializes a new instance of the XslCache class.
Declaration Syntax
C#
public XslCache(
    SiteInfo site,
    long maxSize
)
Parameters
site (SiteInfo)
The site.
maxSize (Int64)
Size of the max.


Clear Method

Clear Method
Namespaces ► Sitecore.Caching ► XslCache ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public override void Clear()


GetXsl Method (filePath)

GetXsl Method (filePath)
Namespaces ► Sitecore.Caching ► XslCache ► GetXsl(String)
Gets the XSL.
Declaration Syntax
C#
[ObsoleteAttribute("Use GetXslTransform instead.", false)]
public XslTransform GetXsl(
    string filePath
)
Parameters
filePath (String)
The file path.
Return Value
The XSL.


GetXslTransform Method (filePath)

GetXslTransform Method (filePath)
Namespaces ► Sitecore.Caching ► XslCache ► GetXslTransform(String)
Gets the XSL transform.
Declaration Syntax
C#
public MvpXslTransform GetXslTransform(
    string filePath
)
Parameters
filePath (String)
The file path.
Return Value
The XSL transform.


SetXsl Method (filePath, xsl)

SetXsl Method (filePath, xsl)
Namespaces ► Sitecore.Caching ► XslCache ► SetXsl(String, XslTransform)
Sets the XSL.
Declaration Syntax
C#
[ObsoleteAttribute("Use SetXslTransform instead.", false)]
public void SetXsl(
    string filePath,
    XslTransform xsl
)
Parameters
filePath (String)
The file path.
xsl (XslTransform)
The XSL.


SetXslTransform Method (filePath, xsl)

SetXslTransform Method (filePath, xsl)
Namespaces ► Sitecore.Caching ► XslCache ► SetXslTransform(String, MvpXslTransform)
Sets the XSL transform.
Declaration Syntax
C#
public void SetXslTransform(
    string filePath,
    MvpXslTransform xsl
)
Parameters
filePath (String)
The file path.
xsl (MvpXslTransform)
The XSL.


Sitecore.Caching.Generics Namespace

Sitecore.Caching.Generics Namespace
Namespaces ► Sitecore.Caching.Generics
Declaration Syntax
C#
namespace Sitecore.Caching.Generics
Types
All Types Classes
Icon | Type | Description
 | Cache<(Of <(TKey, TData>)>) | Class representing a cache.
 | CacheableRecordBase<(Of <(T>)>) | Base class for typical cacheable record
 | Cache<(Of <(TKey, TData>)>)..::.CacheEntry | Class representing a cache entry.
 | EntryRemovedEventArgs<(Of <(TKey, TData>)>) | Argument for the EntryRemoved event.


Cache(TKey, TData) Class

Cache<(Of <(TKey, TData>)>) Class
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>)
Class representing a cache.
Declaration Syntax
C#
public class Cache<TKey, TData>
where TData : ICacheable
Generic Template Parameters
TKey
TData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Cache<(Of <(TKey, TData>)>)(Int64) | Initializes a new instance of the Cache class.
 | Cache<(Of <(TKey, TData>)>)(String, String) | Initializes a new instance of the Cache class.
 | Cache<(Of <(TKey, TData>)>)(String, Int64) | Initializes a new instance of the Cache class.
 | Add(TKey, TData) | Adds the specified key.
 | Clear()()() | Clears this instance.
 | Count | Gets the count.
 | DefaultPriority | Gets or sets the default priority.
 | Enabled | Gets or sets a value indicating whether this Cache is enabled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCacheKeys()()() | Gets the cache keys.
 | GetCacheKeys(String) | Gets the cache keys.
 | GetEntry(TKey, Boolean) | Gets the entry represented by key.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(TKey) | Gets the value.
 | Id | Gets the id.
 | Item[([(TKey])]) | Gets the data with the specified key.
 | MaxSize | Gets or sets the max size.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | ParseSizeString(String) | Parses the size string.
 | RemainingSpace | Gets the remaining space (in bytes).
 | Remove(TKey) | Removes the specified key.
 | RemoveKeysContaining(String) | Removes the keys containing the value.
 | RemovePrefix(String) | Removes the prefix.
 | Scavengable | Gets or sets a value indicating whether this Cache is scavengable.
 | Scavenge()()() | Scavenges this cache.
 | Size | Gets the size.
 | SyncRoot | Gets the sync root.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Cache<(Of <(TKey, TData>)>)


Cache(TKey, TData) Constructor

Cache<(Of <(TKey, TData>)>) Constructor
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Cache<(Of <(TKey, TData>)>)()()()
Members
Icon | Member | Description
 | Cache<(Of <(TKey, TData>)>)(Int64) | Initializes a new instance of the Cache class.
 | Cache<(Of <(TKey, TData>)>)(String, String) | Initializes a new instance of the Cache class.
 | Cache<(Of <(TKey, TData>)>)(String, Int64) | Initializes a new instance of the Cache class.


Cache(TKey, TData) Constructor (maxSize)

Cache<(Of <(TKey, TData>)>) Constructor (maxSize)
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Cache<(Of <(TKey, TData>)>)(Int64)
Initializes a new instance of the Cache class.
Declaration Syntax
C#
public Cache(
    long maxSize
)
Parameters
maxSize (Int64)
Size of the max.


Cache(TKey, TData) Constructor (name, maxSize)

Cache<(Of <(TKey, TData>)>) Constructor (name, maxSize)
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Cache<(Of <(TKey, TData>)>)(String, Int64)
Initializes a new instance of the Cache class.
Declaration Syntax
C#
public Cache(
    string name,
    long maxSize
)
Parameters
name (String)
The name.
maxSize (Int64)
Size of the max.


Cache(TKey, TData) Constructor (name, maxSize)

Cache<(Of <(TKey, TData>)>) Constructor (name, maxSize)
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Cache<(Of <(TKey, TData>)>)(String, String)
Initializes a new instance of the Cache class.
Declaration Syntax
C#
public Cache(
    string name,
    string maxSize
)
Parameters
name (String)
The name.
maxSize (String)
Size of the max.


Add Method (key, data)

Add Method (key, data)
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Add(TKey, TData)
Adds the specified key.
Declaration Syntax
C#
public void Add(
    TKey key,
    TData data
)
Parameters
key (TKey)
The key.
data (TData)
The data.


Clear Method

Clear Method
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public void Clear()


Count Property

Count Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


DefaultPriority Property

DefaultPriority Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► DefaultPriority
Gets or sets the default priority.
Declaration Syntax
C#
public CachePriority DefaultPriority { get; set; }
Value
The default priority.


Enabled Property

Enabled Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Enabled
Gets or sets a value indicating whether this Cache is enabled.
Declaration Syntax
C#
public bool Enabled { get; set; }
Value
true if enabled; otherwise, false.


GetCacheKeys Method

GetCacheKeys Method
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► GetCacheKeys()()()
Members
Icon | Member | Description
 | GetCacheKeys()()() | Gets the cache keys.
 | GetCacheKeys(String) | Gets the cache keys.


GetCacheKeys Method

GetCacheKeys Method
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► GetCacheKeys()()()
Gets the cache keys.
Declaration Syntax
C#
public Collection<TKey> GetCacheKeys()
Return Value


GetCacheKeys Method (keyPrefix)

GetCacheKeys Method (keyPrefix)
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► GetCacheKeys(String)
Gets the cache keys.
Declaration Syntax
C#
public Collection<TKey> GetCacheKeys(
    string keyPrefix
)
Parameters
keyPrefix (String)
The key prefix.
Return Value


GetEntry Method (key, updateAccessed)

GetEntry Method (key, updateAccessed)
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► GetEntry(TKey, Boolean)
Gets the entry represented by key.
Declaration Syntax
C#
public Cache<(Of <(TKey, TData>)>)..::.CacheEntry GetEntry(
    TKey key,
    bool updateAccessed
)
Parameters
key (TKey)
The key.
updateAccessed (Boolean)
if set to true the accessed counter is updated.
Return Value
The entry (or null).


GetValue Method (key)

GetValue Method (key)
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► GetValue(TKey)
Gets the value.
Declaration Syntax
C#
public TData GetValue(
    TKey key
)
Parameters
key (TKey)
The key.
Return Value


Id Property

Id Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Id
Gets the id.
Declaration Syntax
C#
public ID Id { get; }
Value
The id.


Item Property (key)

Item Property (key)
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Item[([(TKey])])
Gets the data with the specified key.
Declaration Syntax
C#
public TData this[
    TKey key
] { get; }
Parameters
key (TKey)
Value


MaxSize Property

MaxSize Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► MaxSize
Gets or sets the max size.
Declaration Syntax
C#
public long MaxSize { get; set; }
Value
The max size.


Name Property

Name Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


ParseSizeString Method (value)

ParseSizeString Method (value)
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► ParseSizeString(String)
Parses the size string.
Declaration Syntax
C#
public static long ParseSizeString(
    string value
)
Parameters
value (String)
The value.
Return Value


RemainingSpace Property

RemainingSpace Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► RemainingSpace
Gets the remaining space (in bytes).
Declaration Syntax
C#
public long RemainingSpace { get; }
Value
The remaining space.


Remove Method (key)

Remove Method (key)
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Remove(TKey)
Removes the specified key.
Declaration Syntax
C#
public void Remove(
    TKey key
)
Parameters
key (TKey)
The key.


RemoveKeysContaining Method (value)

RemoveKeysContaining Method (value)
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► RemoveKeysContaining(String)
Removes the keys containing the value.
Declaration Syntax
C#
public void RemoveKeysContaining(
    string value
)
Parameters
value (String)
The value.


RemovePrefix Method (keyPrefix)

RemovePrefix Method (keyPrefix)
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► RemovePrefix(String)
Removes the prefix.
Declaration Syntax
C#
public void RemovePrefix(
    string keyPrefix
)
Parameters
keyPrefix (String)
The key prefix.


Scavengable Property

Scavengable Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Scavengable
Gets or sets a value indicating whether this Cache is scavengable.
Declaration Syntax
C#
public bool Scavengable { get; set; }
Value
true if scavengable; otherwise, false.


Scavenge Method

Scavenge Method
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Scavenge()()()
Scavenges this cache.
Declaration Syntax
C#
public void Scavenge()


Size Property

Size Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Size
Gets the size.
Declaration Syntax
C#
public long Size { get; }
Value
The size.


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► SyncRoot
Gets the sync root.
Declaration Syntax
C#
public Object SyncRoot { get; }
Value
The sync root.


Cache(TKey, TData).CacheEntry Class

Cache<(Of <(TKey, TData>)>)..::.CacheEntry Class
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>) ► Cache<(Of <(TKey, TData>)>)..::.CacheEntry
Class representing a cache entry.
Declaration Syntax
C#
public class CacheEntry
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Cache<(Of <(TKey, TData>)>)..::.CacheEntry(TKey, TData, CachePriority, Cache<(Of <(TKey, TData>)>)) | Initializes a new instance of the Cache<(Of <(TKey, TData>)>)..::.CacheEntry class.
 | AbsoluteExpiration | Gets or sets the sliding expiration.
 | Accessed | Gets the date/time where the entry was last accessed.
 | Data | Gets the data.
 | DataLength | Gets the length of the data.
 | EntryRemoved |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Expired | Gets a value indicating whether this Cache<(Of <(TKey, TData>)>)..::.CacheEntry is expired.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Priority | Gets the priority.
 | RaiseEntryRemoved()()() | Raises the EntryRemoved event.
 | SlidingExpiration | Gets or sets the sliding expiration.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateAccessed()()() | Updates the accessed time.
Inheritance Hierarchy
Object
Cache<(Of <(TKey, TData>)>)..::.CacheEntry


Cache(TKey, TData).CacheEntry Constructor (key, data, priority, cache)

Cache<(Of <(TKey, TData>)>)..::.CacheEntry Constructor (key, data, priority, cache)
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>)..::.CacheEntry ► Cache<(Of <(TKey, TData>)>)..::.CacheEntry(TKey, TData, CachePriority, Cache<(Of <(TKey, TData>)>))
Initializes a new instance of the Cache<(Of <(TKey, TData>)>)..::.CacheEntry class.
Declaration Syntax
C#
public CacheEntry(
    TKey key,
    TData data,
    CachePriority priority,
    Cache<TKey, TData> cache
)
Parameters
key (TKey)
The key.
data (TData)
The data.
priority (CachePriority)
The priority.
cache (Cache <(Of <( TKey, TData >)>))
The cache.


AbsoluteExpiration Property

AbsoluteExpiration Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>)..::.CacheEntry ► AbsoluteExpiration
Gets or sets the sliding expiration.
Declaration Syntax
C#
public DateTime AbsoluteExpiration { get; set; }
Value
The sliding expiration.


Accessed Property

Accessed Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>)..::.CacheEntry ► Accessed
Gets the date/time where the entry was last accessed.
Declaration Syntax
C#
public DateTime Accessed { get; set; }
Value
The date/time of access.


Data Property

Data Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>)..::.CacheEntry ► Data
Gets the data.
Declaration Syntax
C#
public TData Data { get; }
Value
The data.


DataLength Property

DataLength Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>)..::.CacheEntry ► DataLength
Gets the length of the data.
Declaration Syntax
C#
public long DataLength { get; }
Value
The length of the data.


EntryRemoved Event

EntryRemoved Event
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>)..::.CacheEntry ► EntryRemoved
Declaration Syntax
C#
public event EventHandler<EntryRemovedEventArgs<TKey, TData>> EntryRemoved


Expired Property

Expired Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>)..::.CacheEntry ► Expired
Gets a value indicating whether this Cache<(Of <(TKey, TData>)>)..::.CacheEntry is expired.
Declaration Syntax
C#
public bool Expired { get; }
Value
true if expired; otherwise, false.


Key Property

Key Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>)..::.CacheEntry ► Key
Gets the key.
Declaration Syntax
C#
public TKey Key { get; }
Value
The key.


Priority Property

Priority Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>)..::.CacheEntry ► Priority
Gets the priority.
Declaration Syntax
C#
public CachePriority Priority { get; }
Value
The priority.


RaiseEntryRemoved Method

RaiseEntryRemoved Method
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>)..::.CacheEntry ► RaiseEntryRemoved()()()
Raises the EntryRemoved event.
Declaration Syntax
C#
public void RaiseEntryRemoved()


SlidingExpiration Property

SlidingExpiration Property
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>)..::.CacheEntry ► SlidingExpiration
Gets or sets the sliding expiration.
Declaration Syntax
C#
public TimeSpan SlidingExpiration { get; set; }
Value
The sliding expiration.


UpdateAccessed Method

UpdateAccessed Method
Namespaces ► Sitecore.Caching.Generics ► Cache<(Of <(TKey, TData>)>)..::.CacheEntry ► UpdateAccessed()()()
Updates the accessed time.
Declaration Syntax
C#
public void UpdateAccessed()


CacheableRecordBase(T) Class

CacheableRecordBase<(Of <(T>)>) Class
Namespaces ► Sitecore.Caching.Generics ► CacheableRecordBase<(Of <(T>)>)
Base class for typical cacheable record
Declaration Syntax
C#
public abstract class CacheableRecordBase<T> : ICacheable
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CacheableRecordBase<(Of <(T>)>)()()() | Initializes a new instance of the CacheableRecordBase<(Of <(T>)>) class
 | Cacheable | Gets or sets a value indicating whether this ICacheable is cacheable.
 | DataLengthChanged | Length of the data changed
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataLength()()() | Gets the size of the data to use when caching.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Immutable | Gets a value indicating whether this ICacheable is immutable.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDataLengthChanged()()() | Length of the data changed
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Cached value
Inheritance Hierarchy
Object
 | CacheableRecordBase<(Of <(T>)>)
 |  | IsUserInRoleCacheRecord
 |  | UserProfileCacheRecord
 |  | AccessResultCacheRecord


CacheableRecordBase(T) Constructor

CacheableRecordBase<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Caching.Generics ► CacheableRecordBase<(Of <(T>)>) ► CacheableRecordBase<(Of <(T>)>)()()()
Initializes a new instance of the CacheableRecordBase<(Of <(T>)>) class
Declaration Syntax
C#
protected CacheableRecordBase()


Cacheable Property

Cacheable Property
Namespaces ► Sitecore.Caching.Generics ► CacheableRecordBase<(Of <(T>)>) ► Cacheable
Gets or sets a value indicating whether this ICacheable is cacheable.
Declaration Syntax
C#
public virtual bool Cacheable { get; set; }
Value
true if cacheable; otherwise, false.


DataLengthChanged Event

DataLengthChanged Event
Namespaces ► Sitecore.Caching.Generics ► CacheableRecordBase<(Of <(T>)>) ► DataLengthChanged
Length of the data changed
Declaration Syntax
C#
public event DataLengthChangedDelegate DataLengthChanged


GetDataLength Method

GetDataLength Method
Namespaces ► Sitecore.Caching.Generics ► CacheableRecordBase<(Of <(T>)>) ► GetDataLength()()()
Gets the size of the data to use when caching.
Declaration Syntax
C#
public abstract long GetDataLength()
Return Value


Immutable Property

Immutable Property
Namespaces ► Sitecore.Caching.Generics ► CacheableRecordBase<(Of <(T>)>) ► Immutable
Gets a value indicating whether this ICacheable is immutable.
Declaration Syntax
C#
public virtual bool Immutable { get; }
Value
true if immutable; otherwise, false.


OnDataLengthChanged Method

OnDataLengthChanged Method
Namespaces ► Sitecore.Caching.Generics ► CacheableRecordBase<(Of <(T>)>) ► OnDataLengthChanged()()()
Length of the data changed
Declaration Syntax
C#
protected void OnDataLengthChanged()


Value Property

Value Property
Namespaces ► Sitecore.Caching.Generics ► CacheableRecordBase<(Of <(T>)>) ► Value
Cached value
Declaration Syntax
C#
public T Value { get; set; }


EntryRemovedEventArgs(TKey, TData) Class

EntryRemovedEventArgs<(Of <(TKey, TData>)>) Class
Namespaces ► Sitecore.Caching.Generics ► EntryRemovedEventArgs<(Of <(TKey, TData>)>)
Argument for the EntryRemoved event.
Declaration Syntax
C#
public class EntryRemovedEventArgs<TKey, TData> : EventArgs
where TData : ICacheable
Generic Template Parameters
TKey
TData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EntryRemovedEventArgs<(Of <(TKey, TData>)>)(Cache<(Of <(TKey, TData>)>)..::.CacheEntry) | Initializes a new instance of the EntryRemovedEventArgs class.
 | Entry | Gets the entry that triggered the evtn.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | EntryRemovedEventArgs<(Of <(TKey, TData>)>)


EntryRemovedEventArgs(TKey, TData) Constructor (entry)

EntryRemovedEventArgs<(Of <(TKey, TData>)>) Constructor (entry)
Namespaces ► Sitecore.Caching.Generics ► EntryRemovedEventArgs<(Of <(TKey, TData>)>) ► EntryRemovedEventArgs<(Of <(TKey, TData>)>)(Cache<(Of <(TKey, TData>)>)..::.CacheEntry)
Initializes a new instance of the EntryRemovedEventArgs class.
Declaration Syntax
C#
public EntryRemovedEventArgs(
    Cache<(Of <(TKey, TData>)>)..::.CacheEntry entry
)
Parameters
entry (Cache<(Of <(TKey, TData>)>)..::.CacheEntry)


Entry Property

Entry Property
Namespaces ► Sitecore.Caching.Generics ► EntryRemovedEventArgs<(Of <(TKey, TData>)>) ► Entry
Gets the entry that triggered the evtn.
Declaration Syntax
C#
public Cache<(Of <(TKey, TData>)>)..::.CacheEntry Entry { get; }
Value
The entry.


Sitecore.Caching.IsUserInRole Namespace

Sitecore.Caching.IsUserInRole Namespace
Namespaces ► Sitecore.Caching.IsUserInRole
Declaration Syntax
C#
namespace Sitecore.Caching.IsUserInRole
Types
All Types Classes
Icon | Type | Description
 | IsUserInRoleCache | Represents IsUserInRoleCache
 | IsUserInRoleCacheRecord | Is user is role value


IsUserInRoleCache Class

IsUserInRoleCache Class
Namespaces ► Sitecore.Caching.IsUserInRole ► IsUserInRoleCache
Represents IsUserInRoleCache
Declaration Syntax
C#
public class IsUserInRoleCache : CustomCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IsUserInRoleCache(Int64) | Initializes a new instance of the IsInRolerCache class.
 | AddRecord(String, String, Boolean) | Add combination to cache.
 | Clear()()() | Clears this instance. (Inherited from CustomCache.)
 | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from CustomCache.)
 | GetObject(Object) | Gets the object. (Inherited from CustomCache.)
 | GetRecord(String, String) | Gets the is in role.
 | GetString(String) | Gets the string. (Inherited from CustomCache.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomCache.)
 | Remove(Object) | Removes the specified key. (Inherited from CustomCache.)
 | RemoveKeysContaining(String) | Removes the keys containing. (Inherited from CustomCache.)
 | RemovePrefix(String) | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
 | RemoveUser(String) | Clears the cache for specified user name.
 | SetID(String, ID) | Sets the ID. (Inherited from CustomCache.)
 | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Sets the object. (Inherited from CustomCache.)
 | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
 | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomCache
 |  | IsUserInRoleCache


IsUserInRoleCache Constructor (maxSize)

IsUserInRoleCache Constructor (maxSize)
Namespaces ► Sitecore.Caching.IsUserInRole ► IsUserInRoleCache ► IsUserInRoleCache(Int64)
Initializes a new instance of the IsInRolerCache class.
Declaration Syntax
C#
public IsUserInRoleCache(
    long maxSize
)
Parameters
maxSize (Int64)
Size of the max.


AddRecord Method (roleName, accountName, isInRole)

AddRecord Method (roleName, accountName, isInRole)
Namespaces ► Sitecore.Caching.IsUserInRole ► IsUserInRoleCache ► AddRecord(String, String, Boolean)
Add combination to cache.
Declaration Syntax
C#
public void AddRecord(
    string roleName,
    string accountName,
    bool isInRole
)
Parameters
roleName (String)
Name of the role.
accountName (String)
Name of the account.
isInRole (Boolean)
if set to true this instance is is in role.


GetRecord Method (roleName, accountName)

GetRecord Method (roleName, accountName)
Namespaces ► Sitecore.Caching.IsUserInRole ► IsUserInRoleCache ► GetRecord(String, String)
Gets the is in role.
Declaration Syntax
C#
public IsUserInRoleCacheRecord GetRecord(
    string roleName,
    string accountName
)
Parameters
roleName (String)
Name of the role.
accountName (String)
Name of the account. Could be Role or User
Return Value
The is in role.


RemoveUser Method (userName)

RemoveUser Method (userName)
Namespaces ► Sitecore.Caching.IsUserInRole ► IsUserInRoleCache ► RemoveUser(String)
Clears the cache for specified user name.
Declaration Syntax
C#
public void RemoveUser(
    string userName
)
Parameters
userName (String)
Name of the user.


IsUserInRoleCacheRecord Class

IsUserInRoleCacheRecord Class
Namespaces ► Sitecore.Caching.IsUserInRole ► IsUserInRoleCacheRecord
Is user is role value
Declaration Syntax
C#
public class IsUserInRoleCacheRecord : CacheableRecordBase<bool>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IsUserInRoleCacheRecord()()() | Initializes a new instance of the IsUserInRoleCacheRecord class
 | Cacheable | Gets or sets a value indicating whether this ICacheable is cacheable. (Inherited from CacheableRecordBase<(Of <(T>)>).)
 | DataLengthChanged | Length of the data changed (Inherited from CacheableRecordBase<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataLength()()() | Gets the size of the data to use when caching. (Overrides CacheableRecordBase <(Of <(Boolean>)>).GetDataLength()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Immutable | Gets a value indicating whether this ICacheable is immutable. (Inherited from CacheableRecordBase<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDataLengthChanged()()() | Length of the data changed (Inherited from CacheableRecordBase<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Cached value (Inherited from CacheableRecordBase<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | CacheableRecordBase <(Of <(Boolean>)>)
 |  | IsUserInRoleCacheRecord


IsUserInRoleCacheRecord Constructor

IsUserInRoleCacheRecord Constructor
Namespaces ► Sitecore.Caching.IsUserInRole ► IsUserInRoleCacheRecord ► IsUserInRoleCacheRecord()()()
Initializes a new instance of the IsUserInRoleCacheRecord class
Declaration Syntax
C#
public IsUserInRoleCacheRecord()


GetDataLength Method

GetDataLength Method
Namespaces ► Sitecore.Caching.IsUserInRole ► IsUserInRoleCacheRecord ► GetDataLength()()()
Gets the size of the data to use when caching.
Declaration Syntax
C#
public override long GetDataLength()
Return Value


Sitecore.Caching.UserProfile Namespace

Sitecore.Caching.UserProfile Namespace
Namespaces ► Sitecore.Caching.UserProfile
Declaration Syntax
C#
namespace Sitecore.Caching.UserProfile
Types
All Types Classes
Icon | Type | Description
 | UserProfileCache | Represents UserProfileCache
 | UserProfileCacheRecord | User profile cache record


UserProfileCache Class

UserProfileCache Class
Namespaces ► Sitecore.Caching.UserProfile ► UserProfileCache
Represents UserProfileCache
Declaration Syntax
C#
public class UserProfileCache : CustomCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserProfileCache(Int64) | Initializes a new instance of the UserProfileCache class.
 | AddRecord(String, String, Object) | Adds the specified user profile to cache.
 | Clear()()() | Clears this instance. (Inherited from CustomCache.)
 | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from CustomCache.)
 | GetObject(Object) | Gets the object. (Inherited from CustomCache.)
 | GetRecord(String, String) | Gets the property value.
 | GetString(String) | Gets the string. (Inherited from CustomCache.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomCache.)
 | Remove(Object) | Removes the specified key. (Inherited from CustomCache.)
 | RemoveKeysContaining(String) | Removes the keys containing. (Inherited from CustomCache.)
 | RemovePrefix(String) | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
 | RemoveUser(String) | Removes the user from cache.
 | SetID(String, ID) | Sets the ID. (Inherited from CustomCache.)
 | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
 | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
 | SetObject(String, Object, Int64, EventHandler<(Of <(EntryRemovedEventArgs>)>)) | Sets the object. (Inherited from CustomCache.)
 | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
 | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomCache
 |  | UserProfileCache


UserProfileCache Constructor (maxSize)

UserProfileCache Constructor (maxSize)
Namespaces ► Sitecore.Caching.UserProfile ► UserProfileCache ► UserProfileCache(Int64)
Initializes a new instance of the UserProfileCache class.
Declaration Syntax
C#
public UserProfileCache(
    long maxSize
)
Parameters
maxSize (Int64)
Size of the max.


AddRecord Method (userName, propertyName, propertyValue)

AddRecord Method (userName, propertyName, propertyValue)
Namespaces ► Sitecore.Caching.UserProfile ► UserProfileCache ► AddRecord(String, String, Object)
Adds the specified user profile to cache.
Declaration Syntax
C#
public void AddRecord(
    string userName,
    string propertyName,
    Object propertyValue
)
Parameters
userName (String)
Name of the user.
propertyName (String)
Name of the property.
propertyValue (Object)
The property value.


GetRecord Method (userName, propertyName)

GetRecord Method (userName, propertyName)
Namespaces ► Sitecore.Caching.UserProfile ► UserProfileCache ► GetRecord(String, String)
Gets the property value.
Declaration Syntax
C#
public UserProfileCacheRecord GetRecord(
    string userName,
    string propertyName
)
Parameters
userName (String)
Name of the user.
propertyName (String)
Name of the property.
Return Value
The property value.


RemoveUser Method (userName)

RemoveUser Method (userName)
Namespaces ► Sitecore.Caching.UserProfile ► UserProfileCache ► RemoveUser(String)
Removes the user from cache.
Declaration Syntax
C#
public void RemoveUser(
    string userName
)
Parameters
userName (String)
Name of the user.


UserProfileCacheRecord Class

UserProfileCacheRecord Class
Namespaces ► Sitecore.Caching.UserProfile ► UserProfileCacheRecord
User profile cache record
Declaration Syntax
C#
public class UserProfileCacheRecord : CacheableRecordBase<Object>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserProfileCacheRecord()()() | Initializes a new instance of the UserProfileCacheRecord class
 | Cacheable | Gets or sets a value indicating whether this ICacheable is cacheable. (Inherited from CacheableRecordBase<(Of <(T>)>).)
 | DataLengthChanged | Length of the data changed (Inherited from CacheableRecordBase<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataLength()()() | Gets the size of the data to use when caching. (Overrides CacheableRecordBase <(Of <(Object>)>).GetDataLength()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Immutable | Gets a value indicating whether this ICacheable is immutable. (Inherited from CacheableRecordBase<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDataLengthChanged()()() | Length of the data changed (Inherited from CacheableRecordBase<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Cached value (Inherited from CacheableRecordBase<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | CacheableRecordBase <(Of <(Object>)>)
 |  | UserProfileCacheRecord


UserProfileCacheRecord Constructor

UserProfileCacheRecord Constructor
Namespaces ► Sitecore.Caching.UserProfile ► UserProfileCacheRecord ► UserProfileCacheRecord()()()
Initializes a new instance of the UserProfileCacheRecord class
Declaration Syntax
C#
public UserProfileCacheRecord()


GetDataLength Method

GetDataLength Method
Namespaces ► Sitecore.Caching.UserProfile ► UserProfileCacheRecord ► GetDataLength()()()
Gets the size of the data to use when caching.
Declaration Syntax
C#
public override long GetDataLength()
Return Value


Sitecore.CodeDom Namespace

Sitecore.CodeDom Namespace
Namespaces ► Sitecore.CodeDom
Declaration Syntax
C#
namespace Sitecore.CodeDom
Types
All Types Classes
Icon | Type | Description
 | CodeBuilder | Represents a CodeBuilder.
 | CodeParser | Represents a CodeParser.


CodeBuilder Class

CodeBuilder Class
Namespaces ► Sitecore.CodeDom ► CodeBuilder
Represents a CodeBuilder.
Declaration Syntax
C#
public class CodeBuilder
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CodeBuilder()()() | Initializes a new instance of the CodeBuilder class.
 | AddBlank()()() | Adds the blank.
 | AddComment(String) | Adds the comment.
 | AddComment(String, Boolean) | Adds the comment.
 | AddRaw(String) | Adds the raw.
 | AddString(String, Boolean) | Adds the string.
 | AddString(String, Boolean, Boolean) | Adds the string.
 | AddUsing(String) | Adds the using.
 | AddVariable(String, Type) | Adds the variable.
 | AddVariable(String, String) | Adds the variable.
 | AddVarRef(String) | Adds the var ref.
 | AssertContext(String) | Asserts the context.
 | EndAssign()()() | Ends the assign.
 | EndClass()()() | Ends the class.
 | EndEqual()()() | Ends the equal.
 | EndGet()()() | Ends the get.
 | EndIf()()() | Ends if.
 | EndIfTrue()()() | Ends if true.
 | EndMethod()()() | Ends the method.
 | EndMethodCall()()() | Ends the method call.
 | EndNamespace()()() | Ends the namespace.
 | EndProperty()()() | Ends the property.
 | EndReturn()()() | Ends the return.
 | EndSet()()() | Ends the set.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCodeXml()()() | Gets the code XML.
 | GetCSharpCode()()() | Gets the C sharp code.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StartAssign()()() | Starts the assign.
 | StartClass(String, Type) | Starts the class.
 | StartClass(String, String) | Starts the class.
 | StartClass(String, Type, String, String) | Starts the class.
 | StartClass(String, String, String, String) | Starts the class.
 | StartEqual()()() | Starts the equal.
 | StartGet()()() | Starts the get.
 | StartIf()()() | Starts if.
 | StartIfTrue()()() | Starts if true.
 | StartMethod(String, Type) | Starts the method.
 | StartMethod(String, Type, String) | Starts the method.
 | StartMethod(String, String) | Starts the method.
 | StartMethod(String, String, String) | Starts the method.
 | StartMethodCall(String) | Starts the method call.
 | StartMethodCall(String, String) | Starts the method call.
 | StartNamespace(String) | Starts the namespace.
 | StartProperty(String, Type, String) | Starts the property.
 | StartProperty(String, String, String) | Starts the property.
 | StartReturn()()() | Starts the return.
 | StartSet()()() | Starts the set.
 | Test()()() | Tests this instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CodeBuilder


CodeBuilder Constructor

CodeBuilder Constructor
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► CodeBuilder()()()
Initializes a new instance of the CodeBuilder class.
Declaration Syntax
C#
public CodeBuilder()


AddBlank Method

AddBlank Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► AddBlank()()()
Adds the blank.
Declaration Syntax
C#
public void AddBlank()


AddComment Method

AddComment Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► AddComment()()()
Members
Icon | Member | Description
 | AddComment(String) | Adds the comment.
 | AddComment(String, Boolean) | Adds the comment.


AddComment Method (text)

AddComment Method (text)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► AddComment(String)
Adds the comment.
Declaration Syntax
C#
public void AddComment(
    string text
)
Parameters
text (String)
The text.


AddComment Method (text, emptyLineBefore)

AddComment Method (text, emptyLineBefore)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► AddComment(String, Boolean)
Adds the comment.
Declaration Syntax
C#
public void AddComment(
    string text,
    bool emptyLineBefore
)
Parameters
text (String)
The text.
emptyLineBefore (Boolean)
if set to true this instance is empty line before.


AddRaw Method (code)

AddRaw Method (code)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► AddRaw(String)
Adds the raw.
Declaration Syntax
C#
public void AddRaw(
    string code
)
Parameters
code (String)
The code.


AddString Method

AddString Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► AddString()()()
Members
Icon | Member | Description
 | AddString(String, Boolean) | Adds the string.
 | AddString(String, Boolean, Boolean) | Adds the string.


AddString Method (value, escape)

AddString Method (value, escape)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► AddString(String, Boolean)
Adds the string.
Declaration Syntax
C#
public void AddString(
    string value,
    bool escape
)
Parameters
value (String)
The value.
escape (Boolean)
if set to true this instance is escape.


AddString Method (value, escape, quotes)

AddString Method (value, escape, quotes)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► AddString(String, Boolean, Boolean)
Adds the string.
Declaration Syntax
C#
public void AddString(
    string value,
    bool escape,
    bool quotes
)
Parameters
value (String)
The _value.
escape (Boolean)
if set to true this instance is escape.
quotes (Boolean)
if set to true this instance is quotes.


AddUsing Method (namespace)

AddUsing Method (namespace)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► AddUsing(String)
Adds the using.
Declaration Syntax
C#
public void AddUsing(
    string namespace
)
Parameters
namespace (String)
The _namespace.


AddVariable Method

AddVariable Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► AddVariable()()()
Members
Icon | Member | Description
 | AddVariable(String, Type) | Adds the variable.
 | AddVariable(String, String) | Adds the variable.


AddVariable Method (name, type)

AddVariable Method (name, type)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► AddVariable(String, String)
Adds the variable.
Declaration Syntax
C#
public void AddVariable(
    string name,
    string type
)
Parameters
name (String)
The name.
type (String)
The type.


AddVariable Method (name, type)

AddVariable Method (name, type)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► AddVariable(String, Type)
Adds the variable.
Declaration Syntax
C#
public void AddVariable(
    string name,
    Type type
)
Parameters
name (String)
The name.
type (Type)
The type.


AddVarRef Method (name)

AddVarRef Method (name)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► AddVarRef(String)
Adds the var ref.
Declaration Syntax
C#
public void AddVarRef(
    string name
)
Parameters
name (String)
The name.


AssertContext Method (context)

AssertContext Method (context)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► AssertContext(String)
Asserts the context.
Declaration Syntax
C#
public void AssertContext(
    string context
)
Parameters
context (String)
The context.


EndAssign Method

EndAssign Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► EndAssign()()()
Ends the assign.
Declaration Syntax
C#
public void EndAssign()


EndClass Method

EndClass Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► EndClass()()()
Ends the class.
Declaration Syntax
C#
public void EndClass()


EndEqual Method

EndEqual Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► EndEqual()()()
Ends the equal.
Declaration Syntax
C#
public void EndEqual()


EndGet Method

EndGet Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► EndGet()()()
Ends the get.
Declaration Syntax
C#
public void EndGet()


EndIf Method

EndIf Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► EndIf()()()
Ends if.
Declaration Syntax
C#
public void EndIf()


EndIfTrue Method

EndIfTrue Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► EndIfTrue()()()
Ends if true.
Declaration Syntax
C#
public void EndIfTrue()


EndMethod Method

EndMethod Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► EndMethod()()()
Ends the method.
Declaration Syntax
C#
public void EndMethod()


EndMethodCall Method

EndMethodCall Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► EndMethodCall()()()
Ends the method call.
Declaration Syntax
C#
public void EndMethodCall()


EndNamespace Method

EndNamespace Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► EndNamespace()()()
Ends the namespace.
Declaration Syntax
C#
public void EndNamespace()


EndProperty Method

EndProperty Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► EndProperty()()()
Ends the property.
Declaration Syntax
C#
public void EndProperty()


EndReturn Method

EndReturn Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► EndReturn()()()
Ends the return.
Declaration Syntax
C#
public void EndReturn()


EndSet Method

EndSet Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► EndSet()()()
Ends the set.
Declaration Syntax
C#
public void EndSet()


GetCodeXml Method

GetCodeXml Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► GetCodeXml()()()
Gets the code XML.
Declaration Syntax
C#
public string GetCodeXml()
Return Value


GetCSharpCode Method

GetCSharpCode Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► GetCSharpCode()()()
Gets the C sharp code.
Declaration Syntax
C#
public string GetCSharpCode()
Return Value


StartAssign Method

StartAssign Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartAssign()()()
Starts the assign.
Declaration Syntax
C#
public void StartAssign()


StartClass Method

StartClass Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartClass()()()
Members
Icon | Member | Description
 | StartClass(String, Type) | Starts the class.
 | StartClass(String, String) | Starts the class.
 | StartClass(String, Type, String, String) | Starts the class.
 | StartClass(String, String, String, String) | Starts the class.


StartClass Method (name, inherits)

StartClass Method (name, inherits)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartClass(String, String)
Starts the class.
Declaration Syntax
C#
public void StartClass(
    string name,
    string inherits
)
Parameters
name (String)
The name.
inherits (String)
The inherits.


StartClass Method (name, inherits, scope, renderAs)

StartClass Method (name, inherits, scope, renderAs)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartClass(String, String, String, String)
Starts the class.
Declaration Syntax
C#
public void StartClass(
    string name,
    string inherits,
    string scope,
    string renderAs
)
Parameters
name (String)
The name.
inherits (String)
The inherits.
scope (String)
The scope.
renderAs (String)
The render as.


StartClass Method (name, inherits)

StartClass Method (name, inherits)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartClass(String, Type)
Starts the class.
Declaration Syntax
C#
public void StartClass(
    string name,
    Type inherits
)
Parameters
name (String)
The name.
inherits (Type)
The inherits.


StartClass Method (name, inherits, scope, renderAs)

StartClass Method (name, inherits, scope, renderAs)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartClass(String, Type, String, String)
Starts the class.
Declaration Syntax
C#
public void StartClass(
    string name,
    Type inherits,
    string scope,
    string renderAs
)
Parameters
name (String)
The name.
inherits (Type)
The inherits.
scope (String)
The scope.
renderAs (String)
The render as.


StartEqual Method

StartEqual Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartEqual()()()
Starts the equal.
Declaration Syntax
C#
public void StartEqual()


StartGet Method

StartGet Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartGet()()()
Starts the get.
Declaration Syntax
C#
public void StartGet()


StartIf Method

StartIf Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartIf()()()
Starts if.
Declaration Syntax
C#
public void StartIf()


StartIfTrue Method

StartIfTrue Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartIfTrue()()()
Starts if true.
Declaration Syntax
C#
public void StartIfTrue()


StartMethod Method

StartMethod Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartMethod()()()
Members
Icon | Member | Description
 | StartMethod(String, Type) | Starts the method.
 | StartMethod(String, Type, String) | Starts the method.
 | StartMethod(String, String) | Starts the method.
 | StartMethod(String, String, String) | Starts the method.


StartMethod Method (name, returnType)

StartMethod Method (name, returnType)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartMethod(String, String)
Starts the method.
Declaration Syntax
C#
public void StartMethod(
    string name,
    string returnType
)
Parameters
name (String)
The name.
returnType (String)
Type of the return.


StartMethod Method (name, returnType, modifiers)

StartMethod Method (name, returnType, modifiers)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartMethod(String, String, String)
Starts the method.
Declaration Syntax
C#
public void StartMethod(
    string name,
    string returnType,
    string modifiers
)
Parameters
name (String)
The name.
returnType (String)
Type of the return.
modifiers (String)
The modifiers.


StartMethod Method (name, returnType)

StartMethod Method (name, returnType)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartMethod(String, Type)
Starts the method.
Declaration Syntax
C#
public void StartMethod(
    string name,
    Type returnType
)
Parameters
name (String)
The name.
returnType (Type)
Type of the return.


StartMethod Method (name, returnType, modifiers)

StartMethod Method (name, returnType, modifiers)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartMethod(String, Type, String)
Starts the method.
Declaration Syntax
C#
public void StartMethod(
    string name,
    Type returnType,
    string modifiers
)
Parameters
name (String)
The name.
returnType (Type)
Type of the return.
modifiers (String)
The modifiers.


StartMethodCall Method

StartMethodCall Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartMethodCall()()()
Members
Icon | Member | Description
 | StartMethodCall(String) | Starts the method call.
 | StartMethodCall(String, String) | Starts the method call.


StartMethodCall Method (name)

StartMethodCall Method (name)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartMethodCall(String)
Starts the method call.
Declaration Syntax
C#
public void StartMethodCall(
    string name
)
Parameters
name (String)
The name.


StartMethodCall Method (name, cast)

StartMethodCall Method (name, cast)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartMethodCall(String, String)
Starts the method call.
Declaration Syntax
C#
public void StartMethodCall(
    string name,
    string cast
)
Parameters
name (String)
The name.
cast (String)
The cast.


StartNamespace Method (name)

StartNamespace Method (name)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartNamespace(String)
Starts the namespace.
Declaration Syntax
C#
public void StartNamespace(
    string name
)
Parameters
name (String)
The name.


StartProperty Method

StartProperty Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartProperty()()()
Members
Icon | Member | Description
 | StartProperty(String, Type, String) | Starts the property.
 | StartProperty(String, String, String) | Starts the property.


StartProperty Method (name, type, modifier)

StartProperty Method (name, type, modifier)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartProperty(String, String, String)
Starts the property.
Declaration Syntax
C#
public void StartProperty(
    string name,
    string type,
    string modifier
)
Parameters
name (String)
The name.
type (String)
The type.
modifier (String)
The modifier.


StartProperty Method (name, type, modifier)

StartProperty Method (name, type, modifier)
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartProperty(String, Type, String)
Starts the property.
Declaration Syntax
C#
public void StartProperty(
    string name,
    Type type,
    string modifier
)
Parameters
name (String)
The name.
type (Type)
The type.
modifier (String)
The modifier.


StartReturn Method

StartReturn Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartReturn()()()
Starts the return.
Declaration Syntax
C#
public void StartReturn()


StartSet Method

StartSet Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► StartSet()()()
Starts the set.
Declaration Syntax
C#
public void StartSet()


Test Method

Test Method
Namespaces ► Sitecore.CodeDom ► CodeBuilder ► Test()()()
Tests this instance.
Declaration Syntax
C#
public void Test()


CodeParser Class

CodeParser Class
Namespaces ► Sitecore.CodeDom ► CodeParser
Represents a CodeParser.
Declaration Syntax
C#
public class CodeParser
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CodeParser()()() | Initializes a new instance of the CodeParser class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(XmlDocument) | Parses the specified code.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CodeParser


CodeParser Constructor

CodeParser Constructor
Namespaces ► Sitecore.CodeDom ► CodeParser ► CodeParser()()()
Initializes a new instance of the CodeParser class.
Declaration Syntax
C#
public CodeParser()


Parse Method (code)

Parse Method (code)
Namespaces ► Sitecore.CodeDom ► CodeParser ► Parse(XmlDocument)
Parses the specified code.
Declaration Syntax
C#
public string Parse(
    XmlDocument code
)
Parameters
code (XmlDocument)
The code.
Return Value


Sitecore.CodeDom.Compiler Namespace

Sitecore.CodeDom.Compiler Namespace
Namespaces ► Sitecore.CodeDom.Compiler
Declaration Syntax
C#
namespace Sitecore.CodeDom.Compiler
Types
All Types Classes
Icon | Type | Description
 | CompilerException | Represents a compiler exception.
 | CSharpCompiler | C# compiler.


CompilerException Class

CompilerException Class
Namespaces ► Sitecore.CodeDom.Compiler ► CompilerException
Represents a compiler exception.
Declaration Syntax
C#
[SerializableAttribute]
public sealed class CompilerException : ApplicationException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompilerException(CompilerErrorCollection) | Constructor.
 | CompilerException(CompilerErrorCollection, String) | Constructor.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | CompilerException


CompilerException Constructor

CompilerException Constructor
Namespaces ► Sitecore.CodeDom.Compiler ► CompilerException ► CompilerException()()()
Members
Icon | Member | Description
 | CompilerException(CompilerErrorCollection) | Constructor.
 | CompilerException(CompilerErrorCollection, String) | Constructor.


CompilerException Constructor (errors)

CompilerException Constructor (errors)
Namespaces ► Sitecore.CodeDom.Compiler ► CompilerException ► CompilerException(CompilerErrorCollection)
Constructor.
Declaration Syntax
C#
public CompilerException(
    CompilerErrorCollection errors
)
Parameters
errors (CompilerErrorCollection)
The errors.


CompilerException Constructor (errors, sourceFile)

CompilerException Constructor (errors, sourceFile)
Namespaces ► Sitecore.CodeDom.Compiler ► CompilerException ► CompilerException(CompilerErrorCollection, String)
Constructor.
Declaration Syntax
C#
public CompilerException(
    CompilerErrorCollection errors,
    string sourceFile
)
Parameters
errors (CompilerErrorCollection)
The errors.
sourceFile (String)
The source file.


CSharpCompiler Class

CSharpCompiler Class
Namespaces ► Sitecore.CodeDom.Compiler ► CSharpCompiler
C# compiler.
Declaration Syntax
C#
public class CSharpCompiler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CSharpCompiler()()() | Initializes a new instance of the CSharpCompiler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileToFile(String, String, StringCollection) | Compile C# code to assembly.
 | FileToMemory(String, StringCollection) | Compile C# code to assembly.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SourceToFile(String, String, String, StringCollection) | Compile C# code to assembly.
 | SourceToMemory(String, StringCollection) | Compile C# code to assembly.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CSharpCompiler


CSharpCompiler Constructor

CSharpCompiler Constructor
Namespaces ► Sitecore.CodeDom.Compiler ► CSharpCompiler ► CSharpCompiler()()()
Initializes a new instance of the CSharpCompiler class
Declaration Syntax
C#
public CSharpCompiler()


FileToFile Method (sourceFile, assemblyFile, referencedAssemblies)

FileToFile Method (sourceFile, assemblyFile, referencedAssemblies)
Namespaces ► Sitecore.CodeDom.Compiler ► CSharpCompiler ► FileToFile(String, String, StringCollection)
Compile C# code to assembly.
Declaration Syntax
C#
public void FileToFile(
    string sourceFile,
    string assemblyFile,
    StringCollection referencedAssemblies
)
Parameters
sourceFile (String)
The source file.
assemblyFile (String)
The assembly file.
referencedAssemblies (StringCollection)
The referenced assemblies.


FileToMemory Method (sourceFile, referencedAssemblies)

FileToMemory Method (sourceFile, referencedAssemblies)
Namespaces ► Sitecore.CodeDom.Compiler ► CSharpCompiler ► FileToMemory(String, StringCollection)
Compile C# code to assembly.
Declaration Syntax
C#
public Assembly FileToMemory(
    string sourceFile,
    StringCollection referencedAssemblies
)
Parameters
sourceFile (String)
The source file.
referencedAssemblies (StringCollection)
The referenced assemblies.
Return Value


SourceToFile Method (sourceFile, code, assemblyFile, referencedAssemblies)

SourceToFile Method (sourceFile, code, assemblyFile, referencedAssemblies)
Namespaces ► Sitecore.CodeDom.Compiler ► CSharpCompiler ► SourceToFile(String, String, String, StringCollection)
Compile C# code to assembly.
Declaration Syntax
C#
public void SourceToFile(
    string sourceFile,
    string code,
    string assemblyFile,
    StringCollection referencedAssemblies
)
Parameters
sourceFile (String)
The source file.
code (String)
The code.
assemblyFile (String)
The assembly file.
referencedAssemblies (StringCollection)
The referenced assemblies.


SourceToMemory Method (code, referencedAssemblies)

SourceToMemory Method (code, referencedAssemblies)
Namespaces ► Sitecore.CodeDom.Compiler ► CSharpCompiler ► SourceToMemory(String, StringCollection)
Compile C# code to assembly.
Declaration Syntax
C#
public Assembly SourceToMemory(
    string code,
    StringCollection referencedAssemblies
)
Parameters
code (String)
The code.
referencedAssemblies (StringCollection)
The referenced assemblies.
Return Value


Sitecore.CodeDom.Scripts Namespace

Sitecore.CodeDom.Scripts Namespace
Namespaces ► Sitecore.CodeDom.Scripts
Declaration Syntax
C#
namespace Sitecore.CodeDom.Scripts
Types
All Types Classes
Icon | Type | Description
 | ItemScripts | Extensions methods for string.
 | Script | Defines the script class.
 | ScriptFactory | Defines the script factory class.


ItemScripts Class

ItemScripts Class
Namespaces ► Sitecore.CodeDom.Scripts ► ItemScripts
Extensions methods for string.
Declaration Syntax
C#
public static class ItemScripts
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Compile(Item) | Gets the attribute value.
 | CreateObject(Item) | Creates the object.
 | GetGenericType<(Of <(T>)>)(Item) | Gets the generic type.
 | InvokeDefaultMethod<(Of <(T>)>)(Item, array<Object>[]()[]) | Invokes this instance.
Inheritance Hierarchy
Object
ItemScripts


Compile Method (item)

Compile Method (item)
Namespaces ► Sitecore.CodeDom.Scripts ► ItemScripts ► Compile(Item)
Gets the attribute value.
Declaration Syntax
C#
public static Script Compile(
    Item item
)
Parameters
item (Item)
The source item.
Return Value
The script.


CreateObject Method (item)

CreateObject Method (item)
Namespaces ► Sitecore.CodeDom.Scripts ► ItemScripts ► CreateObject(Item)
Creates the object.
Declaration Syntax
C#
public static Object CreateObject(
    Item item
)
Parameters
item (Item)
The script item.
Return Value
Returns the created object.


GetGenericType Method (item)

GetGenericType<(Of <(T>)>) Method (item)
Namespaces ► Sitecore.CodeDom.Scripts ► ItemScripts ► GetGenericType<(Of <(T>)>)(Item)
Gets the generic type.
Declaration Syntax
C#
public static Type GetGenericType<T>(
    Item item
)
Generic Template Parameters
T
The generic type.
Parameters
item (Item)
The script item.
Return Value
Returns the type.


InvokeDefaultMethod Method (item, parameters)

InvokeDefaultMethod<(Of <(T>)>) Method (item, parameters)
Namespaces ► Sitecore.CodeDom.Scripts ► ItemScripts ► InvokeDefaultMethod<(Of <(T>)>)(Item, array<Object>[]()[])
Invokes this instance.
Declaration Syntax
C#
public static T InvokeDefaultMethod<T>(
    Item item,
    params Object[] parameters
)
Generic Template Parameters
T
The return type
Parameters
item (Item)
The source item.
parameters (array< Object >[]()[])
The parameters.
Return Value
Returns the invoked value.


Script Class

Script Class
Namespaces ► Sitecore.CodeDom.Scripts ► Script
Defines the script class.
Declaration Syntax
C#
public class Script : ICacheable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Script()()() | Initializes a new instance of the Script class
 | Assembly | Gets or sets the assembly.
 | Empty | Gets the empty.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets or sets the errors.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultType()()() | Gets the type of the default.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasDefaultMethod()()() | Determines whether the script has a default method.
 | InvokeDefaultMethod<(Of <(T>)>)(array<Object>[]()[]) | Invokes the default.
 | IsValid | Gets a value indicating whether this instance is valid.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Script


Script Constructor

Script Constructor
Namespaces ► Sitecore.CodeDom.Scripts ► Script ► Script()()()
Initializes a new instance of the Script class
Declaration Syntax
C#
public Script()


Assembly Property

Assembly Property
Namespaces ► Sitecore.CodeDom.Scripts ► Script ► Assembly
Gets or sets the assembly.
Declaration Syntax
C#
public Assembly Assembly { get; set; }
Value
The assembly.


Empty Property

Empty Property
Namespaces ► Sitecore.CodeDom.Scripts ► Script ► Empty
Gets the empty.
Declaration Syntax
C#
public static Script Empty { get; }
Value
The empty.


Errors Property

Errors Property
Namespaces ► Sitecore.CodeDom.Scripts ► Script ► Errors
Gets or sets the errors.
Declaration Syntax
C#
public CompilerErrorCollection Errors { get; set; }
Value
The errors.


GetDefaultType Method

GetDefaultType Method
Namespaces ► Sitecore.CodeDom.Scripts ► Script ► GetDefaultType()()()
Gets the type of the default.
Declaration Syntax
C#
public Type GetDefaultType()
Return Value
Returns the type.


HasDefaultMethod Method

HasDefaultMethod Method
Namespaces ► Sitecore.CodeDom.Scripts ► Script ► HasDefaultMethod()()()
Determines whether the script has a default method.
Declaration Syntax
C#
public bool HasDefaultMethod()
Return Value
true if the script has a default method; otherwise, false.


InvokeDefaultMethod Method (parameters)

InvokeDefaultMethod<(Of <(T>)>) Method (parameters)
Namespaces ► Sitecore.CodeDom.Scripts ► Script ► InvokeDefaultMethod<(Of <(T>)>)(array<Object>[]()[])
Invokes the default.
Declaration Syntax
C#
public T InvokeDefaultMethod<T>(
    params Object[] parameters
)
Generic Template Parameters
T
The return type.
Parameters
parameters (array< Object >[]()[])
The parameters.
Return Value
Returns the object.


IsValid Property

IsValid Property
Namespaces ► Sitecore.CodeDom.Scripts ► Script ► IsValid
Gets a value indicating whether this instance is valid.
Declaration Syntax
C#
public bool IsValid { get; }
Value
true if this instance is valid; otherwise, false.


ScriptFactory Class

ScriptFactory Class
Namespaces ► Sitecore.CodeDom.Scripts ► ScriptFactory
Defines the script factory class.
Declaration Syntax
C#
public static class ScriptFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Compile(String, IEnumerable<(Of <(String>)>), String, String) | Gets the script.
 | InvalidateCache()()() | Invalidates the cache.
 | SyntaxCheck(IEnumerable<(Of <(String>)>), String, String) | Syntaxes the check.
Inheritance Hierarchy
Object
ScriptFactory


Compile Method (cacheKey, references, code, language)

Compile Method (cacheKey, references, code, language)
Namespaces ► Sitecore.CodeDom.Scripts ► ScriptFactory ► Compile(String, IEnumerable<(Of <(String>)>), String, String)
Gets the script.
Declaration Syntax
C#
public static Script Compile(
    string cacheKey,
    IEnumerable<string> references,
    string code,
    string language
)
Parameters
cacheKey (String)
The key for the cache.
references (IEnumerable<(Of <(String>)>))
The references.
code (String)
The script code.
language (String)
The language.
Return Value
Returns the script.


InvalidateCache Method

InvalidateCache Method
Namespaces ► Sitecore.CodeDom.Scripts ► ScriptFactory ► InvalidateCache()()()
Invalidates the cache.
Declaration Syntax
C#
public static void InvalidateCache()


SyntaxCheck Method (references, code, language)

SyntaxCheck Method (references, code, language)
Namespaces ► Sitecore.CodeDom.Scripts ► ScriptFactory ► SyntaxCheck(IEnumerable<(Of <(String>)>), String, String)
Syntaxes the check.
Declaration Syntax
C#
public static CompilerErrorCollection SyntaxCheck(
    IEnumerable<string> references,
    string code,
    string language
)
Parameters
references (IEnumerable<(Of <(String>)>))
The references.
code (String)
The source code.
language (String)
The language.
Return Value
The list of errors.


Sitecore.Collections Namespace

Sitecore.Collections Namespace
Namespaces ► Sitecore.Collections
Declaration Syntax
C#
namespace Sitecore.Collections
Types
All Types Classes Enumerations
Icon | Type | Description
 | Attribute | Attribute class
 | AttributeList | AttributeList class
 | ChildList | Represents a list of children.
 | ChildListOptions | Specifies security options for the ChildList class
 | DataProviderCollection | Represents a data provider collection.
 | FieldCollection | Represents a collection of fields.
 | FieldValueDictionary | Dictionary holding a list of templates indexed by template id.
 | HashDictionary<(Of <(TKey, TValue>)>) | HashDictionary class
 | HashList<(Of <(TKey, TValue>)>) | Maintains a hash table of objects with the ability to retrieve the objects in the same order as they were put in.
 | HistoryEntryCollection | Represents a HistoryEntryCollection.
 | IdCollection | Collection holding a list of id's.
 | IdList | Holds a list of Ids.
 | IDList | Represents a list of Ids.
 | IndexedDictionary | Maintains a dictionary of objects with the ability to retrieve the objects in the same order as they were put in.
 | ItemCollection | Represents a collection of Item objects.
 | ItemList | Represents a list of Item objects.
 | JobCollection | Collection class for holding jobs.
 | LanguageCollection | Holds a collection of languages.
 | LanguageDictionary | Dictionary of Languages
 | LanguageList | Represents a list of languages.
 | LockSet | LockSet class
 | MinMax<(Of <(T>)>) | MinMax class
 | Pair<(Of <(T1, T2>)>) | Represents a pair.
 | PerformanceCounterCollection | Represents a performance counter collection.
 | ReadOnlyList<(Of <(TElement>)>) | ReadOnlyList class
 | ReadOnlyStringList | ReadOnlyStringList
 | SafeDictionary<(Of <(TKey, TValue>)>) | Dictionary allowing dictionary[key] without exceptions.
 | SafeDictionary<(Of <(TKeyAndValue>)>) | Dictionary using the same type for keys and values (and allowing dictionary[key] without exceptions).
 | Set<(Of <(T>)>) | Set
 | StringDictionary | StringDictionary class
 | StringHashtable | Maintains a Hashtable of strings.
 | StringList | StringList class
 | TemplateDictionary | Dictionary holding a list of templates indexed by template id.
 | VersionCollection | Collection class for holding Version.
 | VersionList | Represents a list of versions.
 | VersionUriList | VersionList


Attribute Class

Attribute Class
Namespaces ► Sitecore.Collections ► Attribute
Attribute class
Declaration Syntax
C#
public class Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Attribute(String, String) | Initializes a new instance of the Attribute class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets the value.
Inheritance Hierarchy
Object
Attribute


Attribute Constructor (name, value)

Attribute Constructor (name, value)
Namespaces ► Sitecore.Collections ► Attribute ► Attribute(String, String)
Initializes a new instance of the Attribute class.
Declaration Syntax
C#
public Attribute(
    string name,
    string value
)
Parameters
name (String)
The name.
value (String)
The value.


Name Property

Name Property
Namespaces ► Sitecore.Collections ► Attribute ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Value Property

Value Property
Namespaces ► Sitecore.Collections ► Attribute ► Value
Gets the value.
Declaration Syntax
C#
public string Value { get; }
Value
The value.


AttributeList Class

AttributeList Class
Namespaces ► Sitecore.Collections ► AttributeList
AttributeList class
Declaration Syntax
C#
public class AttributeList : ReadOnlyList<Attribute>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AttributeList(IEnumerable<(Of <(Attribute>)>)) | Initializes a new instance of the AttributeList class.
 | AttributeList(array<Attribute>[]()[]) | Initializes a new instance of the AttributeList class.
 | AttributeList(array<String>[]()[]) | Initializes a new instance of the AttributeList class.
 | AttributeList()()() | Initializes a new instance of the AttributeList class.
 | Contains(TElement) | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets the String with the specified attribute name.
 | Item[([(Int32])]) | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToArray()()() | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ReadOnlyList <(Of <( Attribute >)>)
 |  | AttributeList


AttributeList Constructor

AttributeList Constructor
Namespaces ► Sitecore.Collections ► AttributeList ► AttributeList()()()
Members
Icon | Member | Description
 | AttributeList(IEnumerable<(Of <(Attribute>)>)) | Initializes a new instance of the AttributeList class.
 | AttributeList(array<Attribute>[]()[]) | Initializes a new instance of the AttributeList class.
 | AttributeList(array<String>[]()[]) | Initializes a new instance of the AttributeList class.
 | AttributeList()()() | Initializes a new instance of the AttributeList class.


AttributeList Constructor

AttributeList Constructor
Namespaces ► Sitecore.Collections ► AttributeList ► AttributeList()()()
Initializes a new instance of the AttributeList class.
Declaration Syntax
C#
public AttributeList()


AttributeList Constructor (entries)

AttributeList Constructor (entries)
Namespaces ► Sitecore.Collections ► AttributeList ► AttributeList(array<Attribute>[]()[])
Initializes a new instance of the AttributeList class.
Declaration Syntax
C#
public AttributeList(
    params Attribute[] entries
)
Parameters
entries (array< Attribute >[]()[])
The entries.


AttributeList Constructor (entries)

AttributeList Constructor (entries)
Namespaces ► Sitecore.Collections ► AttributeList ► AttributeList(IEnumerable<(Of <(Attribute>)>))
Initializes a new instance of the AttributeList class.
Declaration Syntax
C#
public AttributeList(
    IEnumerable<Attribute> entries
)
Parameters
entries (IEnumerable<(Of <( Attribute >)>))
The entries.


AttributeList Constructor (entries)

AttributeList Constructor (entries)
Namespaces ► Sitecore.Collections ► AttributeList ► AttributeList(array<String>[]()[])
Initializes a new instance of the AttributeList class.
Declaration Syntax
C#
public AttributeList(
    params string[] entries
)
Parameters
entries (array< String >[]()[])
The entries.


Item Property (attributeName)

Item Property (attributeName)
Namespaces ► Sitecore.Collections ► AttributeList ► Item[([(String])])
Gets the String with the specified attribute name.
Declaration Syntax
C#
public virtual string this[
    string attributeName
] { get; }
Parameters
attributeName (String)
Value


ChildList Class

ChildList Class
Namespaces ► Sitecore.Collections ► ChildList
Represents a list of children.
Declaration Syntax
C#
public class ChildList : ICollection, IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChildList(Item) | Initializes a new instance of the ChildList class.
 | ChildList(Item, ChildListOptions) | Initializes a new instance of the ChildList class.
 | ChildList(Item, ICollection) | Initializes a new instance of the ChildList class.
 | ChildList(Item, ItemList) | Initializes a new instance of the ChildList class.
 | CopyTo(Array, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index.
 | Count | Gets the number of elements contained in the ICollection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(Item) | Searches for the item and returns the zero-based index of the first occurrence within the entire ChildList.
 | IndexOf(ID) | Searches for the item and returns the zero-based index of the first occurrence within the entire ChildList.
 | InnerChildren | Gets the inner children.
 | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
 | Item[([(ID])]) | Gets the Item with the specified child ID.
 | Item[([(String])]) | Gets the Item with the specified child name.
 | Item[([(Int32])]) | Gets the Item at the specified index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OwnerItem | Gets the owner item.
 | Populate(ChildListOptions) | Populates the childlist.
 | Reset()()() | Resets the child collection.
 | Reset(ChildListOptions) | Resets the child collection.
 | Sort()()() | Sorts the child list.
 | Sort(IComparer<(Of <(Item>)>)) | Sorts the child list using the specified comparer.
 | Sort(IComparer) | Obsolete. Sorts the child list using the specified comparer.
 | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.
 | ToArray()()() | Converts the child list to an array of items.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ChildList


ChildList Constructor

ChildList Constructor
Namespaces ► Sitecore.Collections ► ChildList ► ChildList()()()
Members
Icon | Member | Description
 | ChildList(Item) | Initializes a new instance of the ChildList class.
 | ChildList(Item, ChildListOptions) | Initializes a new instance of the ChildList class.
 | ChildList(Item, ICollection) | Initializes a new instance of the ChildList class.
 | ChildList(Item, ItemList) | Initializes a new instance of the ChildList class.


ChildList Constructor (ownerItem)

ChildList Constructor (ownerItem)
Namespaces ► Sitecore.Collections ► ChildList ► ChildList(Item)
Initializes a new instance of the ChildList class.
Declaration Syntax
C#
public ChildList(
    Item ownerItem
)
Parameters
ownerItem (Item)
The owner item.


ChildList Constructor (ownerItem, options)

ChildList Constructor (ownerItem, options)
Namespaces ► Sitecore.Collections ► ChildList ► ChildList(Item, ChildListOptions)
Initializes a new instance of the ChildList class.
Declaration Syntax
C#
public ChildList(
    Item ownerItem,
    ChildListOptions options
)
Parameters
ownerItem (Item)
The owner item.
options (ChildListOptions)
The options.


ChildList Constructor (ownerItem, children)

ChildList Constructor (ownerItem, children)
Namespaces ► Sitecore.Collections ► ChildList ► ChildList(Item, ItemList)
Initializes a new instance of the ChildList class.
Declaration Syntax
C#
public ChildList(
    Item ownerItem,
    ItemList children
)
Parameters
ownerItem (Item)
The owner item.
children (ItemList)
The children.


ChildList Constructor (ownerItem, children)

ChildList Constructor (ownerItem, children)
Namespaces ► Sitecore.Collections ► ChildList ► ChildList(Item, ICollection)
Initializes a new instance of the ChildList class.
Declaration Syntax
C#
public ChildList(
    Item ownerItem,
    ICollection children
)
Parameters
ownerItem (Item)
The owner item.
children (ICollection)
The children.


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces ► Sitecore.Collections ► ChildList ► CopyTo(Array, Int32)
Copies the elements of the ICollection to an Array, starting at a particular Array index.
Declaration Syntax
C#
public void CopyTo(
    Array array,
    int index
)
Parameters
array (Array)
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index (Int32)
The zero-based index in array at which copying begins.
Exceptions
Exception | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional.-or- index is equal to or greater than the length of array.-or- The number of elements in the source ICollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ICollection cannot be cast automatically to the type of the destination array.


Count Property

Count Property
Namespaces ► Sitecore.Collections ► ChildList ► Count
Gets the number of elements contained in the ICollection.
Declaration Syntax
C#
public int Count { get; }
Value
Return Value
The number of elements contained in the ICollection.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Collections ► ChildList ► GetEnumerator()()()
Returns an enumerator that iterates through a collection.
Declaration Syntax
C#
public IEnumerator GetEnumerator()
Return Value
An IEnumerator object that can be used to iterate through the collection.


IndexOf Method

IndexOf Method
Namespaces ► Sitecore.Collections ► ChildList ► IndexOf()()()
Members
Icon | Member | Description
 | IndexOf(Item) | Searches for the item and returns the zero-based index of the first occurrence within the entire ChildList.
 | IndexOf(ID) | Searches for the item and returns the zero-based index of the first occurrence within the entire ChildList.


IndexOf Method (itemID)

IndexOf Method (itemID)
Namespaces ► Sitecore.Collections ► ChildList ► IndexOf(ID)
Searches for the item and returns the zero-based index of the first occurrence within the entire ChildList.
Declaration Syntax
C#
public int IndexOf(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► Sitecore.Collections ► ChildList ► IndexOf(Item)
Searches for the item and returns the zero-based index of the first occurrence within the entire ChildList.
Declaration Syntax
C#
public int IndexOf(
    Item item
)
Parameters
item (Item)
The item.
Return Value


InnerChildren Property

InnerChildren Property
Namespaces ► Sitecore.Collections ► ChildList ► InnerChildren
Gets the inner children.
Declaration Syntax
C#
public ItemList InnerChildren { get; }
Value
The inner children.


IsSynchronized Property

IsSynchronized Property
Namespaces ► Sitecore.Collections ► ChildList ► IsSynchronized
Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Declaration Syntax
C#
public bool IsSynchronized { get; }
Value
Return Value
true if access to the ICollection is synchronized (thread safe); otherwise, false.


Item Property

Item Property
Namespaces ► Sitecore.Collections ► ChildList ► Item
Members
Icon | Member | Description
 | Item[([(ID])]) | Gets the Item with the specified child ID.
 | Item[([(String])]) | Gets the Item with the specified child name.
 | Item[([(Int32])]) | Gets the Item at the specified index.


Item Property (childID)

Item Property (childID)
Namespaces ► Sitecore.Collections ► ChildList ► Item[([(ID])])
Gets the Item with the specified child ID.
Declaration Syntax
C#
public Item this[
    ID childID
] { get; }
Parameters
childID (ID)
Value


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Collections ► ChildList ► Item[([(Int32])])
Gets the Item at the specified index.
Declaration Syntax
C#
public Item this[
    int index
] { get; }
Parameters
index (Int32)
Value


Item Property (childName)

Item Property (childName)
Namespaces ► Sitecore.Collections ► ChildList ► Item[([(String])])
Gets the Item with the specified child name.
Declaration Syntax
C#
public Item this[
    string childName
] { get; }
Parameters
childName (String)
Value


OwnerItem Property

OwnerItem Property
Namespaces ► Sitecore.Collections ► ChildList ► OwnerItem
Gets the owner item.
Declaration Syntax
C#
public Item OwnerItem { get; }
Value
The owner item.


Populate Method (options)

Populate Method (options)
Namespaces ► Sitecore.Collections ► ChildList ► Populate(ChildListOptions)
Populates the childlist.
Declaration Syntax
C#
protected virtual ItemList Populate(
    ChildListOptions options
)
Parameters
options (ChildListOptions)
Return Value


Reset Method

Reset Method
Namespaces ► Sitecore.Collections ► ChildList ► Reset()()()
Members
Icon | Member | Description
 | Reset()()() | Resets the child collection.
 | Reset(ChildListOptions) | Resets the child collection.


Reset Method

Reset Method
Namespaces ► Sitecore.Collections ► ChildList ► Reset()()()
Resets the child collection.
Declaration Syntax
C#
public void Reset()


Reset Method (options)

Reset Method (options)
Namespaces ► Sitecore.Collections ► ChildList ► Reset(ChildListOptions)
Resets the child collection.
Declaration Syntax
C#
public void Reset(
    ChildListOptions options
)
Parameters
options (ChildListOptions)


Sort Method

Sort Method
Namespaces ► Sitecore.Collections ► ChildList ► Sort()()()
Members
Icon | Member | Description
 | Sort()()() | Sorts the child list.
 | Sort(IComparer<(Of <(Item>)>)) | Sorts the child list using the specified comparer.
 | Sort(IComparer) | Obsolete. Sorts the child list using the specified comparer.


Sort Method

Sort Method
Namespaces ► Sitecore.Collections ► ChildList ► Sort()()()
Sorts the child list.
Declaration Syntax
C#
public void Sort()


Sort Method (comparer)

Sort Method (comparer)
Namespaces ► Sitecore.Collections ► ChildList ► Sort(IComparer<(Of <(Item>)>))
Sorts the child list using the specified comparer.
Declaration Syntax
C#
public void Sort(
    IComparer<Item> comparer
)
Parameters
comparer (IComparer<(Of <( Item >)>))
The comparer.


Sort Method (comparer)

Sort Method (comparer)
Namespaces ► Sitecore.Collections ► ChildList ► Sort(IComparer)
Sorts the child list using the specified comparer.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated. Use Sort(IComparer<Item> comparer) instead.")]
public void Sort(
    IComparer comparer
)
Parameters
comparer (IComparer)
The comparer.


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Collections ► ChildList ► SyncRoot
Gets an object that can be used to synchronize access to the ICollection.
Declaration Syntax
C#
public Object SyncRoot { get; }
Value
Return Value
An object that can be used to synchronize access to the ICollection.


ToArray Method

ToArray Method
Namespaces ► Sitecore.Collections ► ChildList ► ToArray()()()
Converts the child list to an array of items.
Declaration Syntax
C#
public Item[] ToArray()
Return Value


ChildListOptions Enumeration

ChildListOptions Enumeration
Namespaces ► Sitecore.Collections ► ChildListOptions
Specifies security options for the ChildList class
Declaration Syntax
C#
[FlagsAttribute]
public enum ChildListOptions
Members
Member | Description
None |
IgnoreSecurity |
AllowReuse |


DataProviderCollection Class

DataProviderCollection Class
Namespaces ► Sitecore.Collections ► DataProviderCollection
Represents a data provider collection.
Declaration Syntax
C#
public class DataProviderCollection : Collection<DataProvider>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataProviderCollection()()() | Initializes a new instance of the DataProviderCollection class
 | Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DataProvider >)>).)
 | Clear()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DataProvider >)>).)
 | ClearItems()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DataProvider >)>).)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DataProvider >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( DataProvider >)>).)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DataProvider >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DataProvider >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DataProvider >)>).)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( DataProvider >)>).)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( DataProvider >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( DataProvider >)>).)
 | Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DataProvider >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DataProvider >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DataProvider >)>).)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DataProvider >)>).)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection<(Of <( DataProvider >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection<(Of <( DataProvider >)>)
 |  | DataProviderCollection


DataProviderCollection Constructor

DataProviderCollection Constructor
Namespaces ► Sitecore.Collections ► DataProviderCollection ► DataProviderCollection()()()
Initializes a new instance of the DataProviderCollection class
Declaration Syntax
C#
public DataProviderCollection()


FieldCollection Class

FieldCollection Class
Namespaces ► Sitecore.Collections ► FieldCollection
Represents a collection of fields.
Declaration Syntax
C#
public class FieldCollection : ICollection,
    IEnumerable<Field>, IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldCollection(Item) | Initializes a new instance of the FieldCollection class.
 | Contains(ID) | Determines whether the collection contains a field with the specified id.
 | CopyTo(Array, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index.
 | Count | Gets the number of elements contained in the ICollection.
 | EnsureField(Field) | Ensures that the field is included in the internal field collection.
 | EnsureField(ID) | Ensures that the field is included in the internal field collection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
 | Item[([(ID])]) | Gets the Field with the specified field ID.
 | Item[([(String])]) | Gets the Field with the specified field name.
 | Item[([(Int32])]) | Gets the Field at the specified index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadAll()()() | Reads all.
 | Reset()()() | Resets this instance.
 | Sort()()() | Sorts the list of fields.
 | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FieldCollection


FieldCollection Constructor (ownerItem)

FieldCollection Constructor (ownerItem)
Namespaces ► Sitecore.Collections ► FieldCollection ► FieldCollection(Item)
Initializes a new instance of the FieldCollection class.
Declaration Syntax
C#
public FieldCollection(
    Item ownerItem
)
Parameters
ownerItem (Item)
The owner item.


Contains Method (fieldId)

Contains Method (fieldId)
Namespaces ► Sitecore.Collections ► FieldCollection ► Contains(ID)
Determines whether the collection contains a field with the specified id.
Declaration Syntax
C#
public bool Contains(
    ID fieldId
)
Parameters
fieldId (ID)
The field id.
Return Value
true if the specified field id has field; otherwise, false.


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces ► Sitecore.Collections ► FieldCollection ► CopyTo(Array, Int32)
Copies the elements of the ICollection to an Array, starting at a particular Array index.
Declaration Syntax
C#
public void CopyTo(
    Array array,
    int index
)
Parameters
array (Array)
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index (Int32)
The zero-based index in array at which copying begins.
Exceptions
Exception | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional.-or- index is equal to or greater than the length of array.-or- The number of elements in the source ICollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ICollection cannot be cast automatically to the type of the destination array.


Count Property

Count Property
Namespaces ► Sitecore.Collections ► FieldCollection ► Count
Gets the number of elements contained in the ICollection.
Declaration Syntax
C#
public int Count { get; }
Value
Return Value
The number of elements contained in the ICollection.


EnsureField Method

EnsureField Method
Namespaces ► Sitecore.Collections ► FieldCollection ► EnsureField()()()
Members
Icon | Member | Description
 | EnsureField(Field) | Ensures that the field is included in the internal field collection.
 | EnsureField(ID) | Ensures that the field is included in the internal field collection.


EnsureField Method (field)

EnsureField Method (field)
Namespaces ► Sitecore.Collections ► FieldCollection ► EnsureField(Field)
Ensures that the field is included in the internal field collection.
Declaration Syntax
C#
public void EnsureField(
    Field field
)
Parameters
field (Field)
The field.


EnsureField Method (fieldId)

EnsureField Method (fieldId)
Namespaces ► Sitecore.Collections ► FieldCollection ► EnsureField(ID)
Ensures that the field is included in the internal field collection.
Declaration Syntax
C#
public void EnsureField(
    ID fieldId
)
Parameters
fieldId (ID)
The field id.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Collections ► FieldCollection ► GetEnumerator()()()
Returns an enumerator that iterates through a collection.
Declaration Syntax
C#
public IEnumerator GetEnumerator()
Return Value
An IEnumerator object that can be used to iterate through the collection.


IsSynchronized Property

IsSynchronized Property
Namespaces ► Sitecore.Collections ► FieldCollection ► IsSynchronized
Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Declaration Syntax
C#
public bool IsSynchronized { get; }
Value


Item Property

Item Property
Namespaces ► Sitecore.Collections ► FieldCollection ► Item
Members
Icon | Member | Description
 | Item[([(ID])]) | Gets the Field with the specified field ID.
 | Item[([(String])]) | Gets the Field with the specified field name.
 | Item[([(Int32])]) | Gets the Field at the specified index.


Item Property (fieldID)

Item Property (fieldID)
Namespaces ► Sitecore.Collections ► FieldCollection ► Item[([(ID])])
Gets the Field with the specified field ID.
Declaration Syntax
C#
public Field this[
    ID fieldID
] { get; }
Parameters
fieldID (ID)
Value
The Field.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Collections ► FieldCollection ► Item[([(Int32])])
Gets the Field at the specified index.
Declaration Syntax
C#
public Field this[
    int index
] { get; }
Parameters
index (Int32)
Value
The Field.


Item Property (fieldName)

Item Property (fieldName)
Namespaces ► Sitecore.Collections ► FieldCollection ► Item[([(String])])
Gets the Field with the specified field name.
Declaration Syntax
C#
public Field this[
    string fieldName
] { get; }
Parameters
fieldName (String)
Value
The Field.


ReadAll Method

ReadAll Method
Namespaces ► Sitecore.Collections ► FieldCollection ► ReadAll()()()
Reads all.
Declaration Syntax
C#
public void ReadAll()


Reset Method

Reset Method
Namespaces ► Sitecore.Collections ► FieldCollection ► Reset()()()
Resets this instance.
Declaration Syntax
C#
public void Reset()


Sort Method

Sort Method
Namespaces ► Sitecore.Collections ► FieldCollection ► Sort()()()
Sorts the list of fields.
Declaration Syntax
C#
public void Sort()


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Collections ► FieldCollection ► SyncRoot
Gets an object that can be used to synchronize access to the ICollection.
Declaration Syntax
C#
public Object SyncRoot { get; }
Value


FieldValueDictionary Class

FieldValueDictionary Class
Namespaces ► Sitecore.Collections ► FieldValueDictionary
Dictionary holding a list of templates indexed by template id.
Declaration Syntax
C#
[SerializableAttribute]
public class FieldValueDictionary : SafeDictionary<ID, string>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldValueDictionary(SerializationInfo, StreamingContext) | Initializes a new instance of the FieldValueDictionary class.
 | Add(TKey, TValue) | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | AddRange(SafeDictionary<(Of <(TKey, TValue>)>)) | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Clear()()() | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Clone()()() | Clones this instance. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | ContainsKey(TKey) | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Count | Gets the number of entries in the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hashtable | Gets the internal hashtable. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Item[([(TKey])]) | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Keys | Gets the keys of the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Remove(TKey) | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | SyncRoot | Gets the object to use for locking in multi-thread scenarios. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | ToKeyArray()()() | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToValueArray()()() | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | TryGetValue(TKey, TValue%) | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Values | Gets the values of the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
Inheritance Hierarchy
Object
 | SafeDictionary <(Of <( ID, String>)>)
 |  | FieldValueDictionary


FieldValueDictionary Constructor (info, context)

FieldValueDictionary Constructor (info, context)
Namespaces ► Sitecore.Collections ► FieldValueDictionary ► FieldValueDictionary(SerializationInfo, StreamingContext)
Initializes a new instance of the FieldValueDictionary class.
Declaration Syntax
C#
protected FieldValueDictionary(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


HashDictionary(TKey, TValue) Class

HashDictionary<(Of <(TKey, TValue>)>) Class
Namespaces ► Sitecore.Collections ► HashDictionary<(Of <(TKey, TValue>)>)
HashDictionary class
Declaration Syntax
C#
public class HashDictionary<TKey, TValue> : Dictionary<TKey, TValue>
where TValue : class
Generic Template Parameters
TKey
TValue
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HashDictionary<(Of <(TKey, TValue>)>)()()() | Initializes a new instance of the HashDictionary<(Of <(TKey, TValue>)>) class.
 | HashDictionary<(Of <(TKey, TValue>)>)(IEqualityComparer<(Of <(TKey>)>)) | Initializes a new instance of the HashDictionary<(Of <(TKey, TValue>)>) class.
 | Add(TKey, TValue) | Adds the specified key and value to the dictionary. (Inherited from Dictionary<(Of <(TKey, TValue>)>).)
 | Clear()()() | Removes all keys and values from the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary<(Of <(TKey, TValue>)>).)
 | Comparer | Gets the IEqualityComparer<(Of <(T>)>) that is used to determine equality of keys for the dictionary. (Inherited from Dictionary<(Of <(TKey, TValue>)>).)
 | ContainsKey(TKey) | Determines whether the Dictionary<(Of <(TKey, TValue>)>) contains the specified key. (Inherited from Dictionary<(Of <(TKey, TValue>)>).)
 | ContainsValue(TValue) | Determines whether the Dictionary<(Of <(TKey, TValue>)>) contains a specific value. (Inherited from Dictionary<(Of <(TKey, TValue>)>).)
 | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary<(Of <(TKey, TValue>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary<(Of <(TKey, TValue>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(TKey, TValue>)>) instance. (Inherited from Dictionary<(Of <(TKey, TValue>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(TKey])]) | Gets or sets the entry with the specified key.
 | Keys | Gets a collection containing the keys in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary<(Of <(TKey, TValue>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserialization(Object) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary<(Of <(TKey, TValue>)>).)
 | Remove(TKey) | Removes the value with the specified key from the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary<(Of <(TKey, TValue>)>).)
 | RemoveNullValues | Gets or sets a value indicating whether [remove null values].
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetValue(TKey, TValue%) | Gets the value associated with the specified key. (Inherited from Dictionary<(Of <(TKey, TValue>)>).)
 | Values | Gets a collection containing the values in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary<(Of <(TKey, TValue>)>).)
Inheritance Hierarchy
Object
 | Dictionary<(Of <(TKey, TValue>)>)
 |  | HashDictionary<(Of <(TKey, TValue>)>)


HashDictionary(TKey, TValue) Constructor

HashDictionary<(Of <(TKey, TValue>)>) Constructor
Namespaces ► Sitecore.Collections ► HashDictionary<(Of <(TKey, TValue>)>) ► HashDictionary<(Of <(TKey, TValue>)>)()()()
Members
Icon | Member | Description
 | HashDictionary<(Of <(TKey, TValue>)>)()()() | Initializes a new instance of the HashDictionary<(Of <(TKey, TValue>)>) class.
 | HashDictionary<(Of <(TKey, TValue>)>)(IEqualityComparer<(Of <(TKey>)>)) | Initializes a new instance of the HashDictionary<(Of <(TKey, TValue>)>) class.


HashDictionary(TKey, TValue) Constructor

HashDictionary<(Of <(TKey, TValue>)>) Constructor
Namespaces ► Sitecore.Collections ► HashDictionary<(Of <(TKey, TValue>)>) ► HashDictionary<(Of <(TKey, TValue>)>)()()()
Initializes a new instance of the HashDictionary<(Of <(TKey, TValue>)>) class.
Declaration Syntax
C#
public HashDictionary()


HashDictionary(TKey, TValue) Constructor (comparer)

HashDictionary<(Of <(TKey, TValue>)>) Constructor (comparer)
Namespaces ► Sitecore.Collections ► HashDictionary<(Of <(TKey, TValue>)>) ► HashDictionary<(Of <(TKey, TValue>)>)(IEqualityComparer<(Of <(TKey>)>))
Initializes a new instance of the HashDictionary<(Of <(TKey, TValue>)>) class.
Declaration Syntax
C#
public HashDictionary(
    IEqualityComparer<TKey> comparer
)
Parameters
comparer (IEqualityComparer<(Of <( TKey >)>))
The comparer.


Item Property (key)

Item Property (key)
Namespaces ► Sitecore.Collections ► HashDictionary<(Of <(TKey, TValue>)>) ► Item[([(TKey])])
Gets or sets the entry with the specified key.
Declaration Syntax
C#
public virtual TValue this[
    TKey key
] { get; set; }
Parameters
key (TKey)
Value


RemoveNullValues Property

RemoveNullValues Property
Namespaces ► Sitecore.Collections ► HashDictionary<(Of <(TKey, TValue>)>) ► RemoveNullValues
Gets or sets a value indicating whether [remove null values].
Declaration Syntax
C#
public virtual bool RemoveNullValues { get; set; }
Value
true if [remove null values]; otherwise, false.


HashList(TKey, TValue) Class

HashList<(Of <(TKey, TValue>)>) Class
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>)
Maintains a hash table of objects with the ability to retrieve the objects in the same order as they were put in.
Declaration Syntax
C#
[SerializableAttribute]
public class HashList<TKey, TValue> : ISerializable
where TKey : class
where TValue : class
Generic Template Parameters
TKey
TValue
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HashList<(Of <(TKey, TValue>)>)()()() | Initializes a new instance of the HashList<(Of <(TKey, TValue>)>) class.
 | HashList<(Of <(TKey, TValue>)>)(SerializationInfo, StreamingContext) | Initializes a new instance of the HashList<(Of <(TKey, TValue>)>) class.
 | Add(TKey, TValue) | Adds an object to the hash table.
 | AddAt(Int32, TKey, TValue) | Adds or replaces an object at a specific index.
 | Clear()()() | Clears the list.
 | Contains(TKey) | Checks if the hash table contains a key.
 | Count | Gets the number of objects in the hash table.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKey(Int32) | Gets a key by an index.
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(TKey) | Gets the index of a key.
 | Item[([(Int32])]) | Gets an object by its index.
 | Item[([(TKey])]) | Gets or sets an object by its key.
 | Keys | Gets a collection of keys.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(TKey) | Removes an object from the hash table.
 | RemoveRange(Int32, Int32) | Removes a range of objects from the hash table.
 | SyncRoot | Gets the sync root.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HashList<(Of <(TKey, TValue>)>)


HashList(TKey, TValue) Constructor

HashList<(Of <(TKey, TValue>)>) Constructor
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► HashList<(Of <(TKey, TValue>)>)()()()
Members
Icon | Member | Description
 | HashList<(Of <(TKey, TValue>)>)()()() | Initializes a new instance of the HashList<(Of <(TKey, TValue>)>) class.
 | HashList<(Of <(TKey, TValue>)>)(SerializationInfo, StreamingContext) | Initializes a new instance of the HashList<(Of <(TKey, TValue>)>) class.


HashList(TKey, TValue) Constructor

HashList<(Of <(TKey, TValue>)>) Constructor
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► HashList<(Of <(TKey, TValue>)>)()()()
Initializes a new instance of the HashList<(Of <(TKey, TValue>)>) class.
Declaration Syntax
C#
public HashList()


HashList(TKey, TValue) Constructor (info, context)

HashList<(Of <(TKey, TValue>)>) Constructor (info, context)
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► HashList<(Of <(TKey, TValue>)>)(SerializationInfo, StreamingContext)
Initializes a new instance of the HashList<(Of <(TKey, TValue>)>) class.
Declaration Syntax
C#
protected HashList(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Add Method (key, value)

Add Method (key, value)
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► Add(TKey, TValue)
Adds an object to the hash table.
Declaration Syntax
C#
public void Add(
    TKey key,
    TValue value
)
Parameters
key (TKey)
A key uniquely describing the object.
value (TValue)
An object.
Examples
CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");
hashTable.Add("2", "pears");


AddAt Method (index, key, value)

AddAt Method (index, key, value)
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► AddAt(Int32, TKey, TValue)
Adds or replaces an object at a specific index.
Declaration Syntax
C#
public void AddAt(
    int index,
    TKey key,
    TValue value
)
Parameters
index (Int32)
An index into the hash table.
key (TKey)
A key uniquely describing the object.
value (TValue)
The value.
Remarks
If the key does not exist in the hash table, the key and object is added.
Examples
CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");
hashTable.Add(0, "2", "pears");


Clear Method

Clear Method
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► Clear()()()
Clears the list.
Declaration Syntax
C#
public void Clear()
Examples
CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("1", "bananas");
hashTable.Add(0, "2", "pears");
hashTable.Clear();


Contains Method (key)

Contains Method (key)
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► Contains(TKey)
Checks if the hash table contains a key.
Declaration Syntax
C#
public bool Contains(
    TKey key
)
Parameters
key (TKey)
A key.
Return Value
True, if the key exists in the hash table, otherwise false.
Examples
CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");
hashTable.Add("2", "pears");
if (hashTable.Contains("1")) {
hashTable.Add("3", "pineapple");
}


Count Property

Count Property
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► Count
Gets the number of objects in the hash table.
Declaration Syntax
C#
public int Count { get; }
Value
Gets the number of objects.
Examples
CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");


GetKey Method (index)

GetKey Method (index)
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► GetKey(Int32)
Gets a key by an index.
Declaration Syntax
C#
public TKey GetKey(
    int index
)
Parameters
index (Int32)
An index into the hash table.
Return Value
Returns the key at the index'ed position. If the index is less than zero or greater than the length of the table, blank is returned.
Examples
CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");
hashTable.Add("2", "pears");
string bananaKey = hashTable.GetKey(1);


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


IndexOf Method (key)

IndexOf Method (key)
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► IndexOf(TKey)
Gets the index of a key.
Declaration Syntax
C#
public int IndexOf(
    TKey key
)
Parameters
key (TKey)
A key.
Return Value
The index of the key. If the key is not found, -1 is returned.
Examples
CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");
hashTable.Add("2", "pears");
int bananaKey = hashTable.IndexOf("1");


Item Property

Item Property
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets an object by its index.
 | Item[([(TKey])]) | Gets or sets an object by its key.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► Item[([(Int32])])
Gets an object by its index.
Declaration Syntax
C#
public TValue this[
    int index
] { get; }
Parameters
index (Int32)
An index into the hash table.
Value
Gets the object at index position.
Remarks
If index if less than zero or greater than the number of objects in the list, null is returned.
Examples
CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");
hashTable.Add("2", "pears");

string bananas = hashTable[1]; // returns "bananas"
string apples = hashTable["0"]; // returns "apples"


Item Property (key)

Item Property (key)
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► Item[([(TKey])])
Gets or sets an object by its key.
Declaration Syntax
C#
public TValue this[
    TKey key
] { get; set; }
Parameters
key (TKey)
A key.
Value
Gets the object which is associated with a key.
Remarks
If the key does not exist, null is returned.
Examples
CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");
hashTable.Add("2", "pears");

string bananas = hashTable[1]; // returns "bananas"
string apples = hashTable["0"]; // returns "apples"


Keys Property

Keys Property
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► Keys
Gets a collection of keys.
Declaration Syntax
C#
public ICollection Keys { get; }
Value
A collection of keys.


Remove Method (key)

Remove Method (key)
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► Remove(TKey)
Removes an object from the hash table.
Declaration Syntax
C#
public void Remove(
    TKey key
)
Parameters
key (TKey)
A key.
Remarks
No exception is thrown if the key does not exist.
Examples
CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");
hashTable.Add("2", "pears");
hashTable.Remove("1");


RemoveRange Method (index, count)

RemoveRange Method (index, count)
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► RemoveRange(Int32, Int32)
Removes a range of objects from the hash table.
Declaration Syntax
C#
public void RemoveRange(
    int index,
    int count
)
Parameters
index (Int32)
The index.
count (Int32)
The count.


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Collections ► HashList<(Of <(TKey, TValue>)>) ► SyncRoot
Gets the sync root.
Declaration Syntax
C#
public Object SyncRoot { get; }
Value
The sync root.


HistoryEntryCollection Class

HistoryEntryCollection Class
Namespaces ► Sitecore.Collections ► HistoryEntryCollection
Represents a HistoryEntryCollection.
Declaration Syntax
C#
public class HistoryEntryCollection : Collection<HistoryEntry>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HistoryEntryCollection()()() | Initializes a new instance of the HistoryEntryCollection class
 | Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | Clear()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | ClearItems()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection<(Of <( HistoryEntry >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection<(Of <( HistoryEntry >)>)
 |  | HistoryEntryCollection


HistoryEntryCollection Constructor

HistoryEntryCollection Constructor
Namespaces ► Sitecore.Collections ► HistoryEntryCollection ► HistoryEntryCollection()()()
Initializes a new instance of the HistoryEntryCollection class
Declaration Syntax
C#
public HistoryEntryCollection()


IdCollection Class

IdCollection Class
Namespaces ► Sitecore.Collections ► IdCollection
Collection holding a list of id's.
Declaration Syntax
C#
public class IdCollection : Collection<ID>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IdCollection()()() | Initializes a new instance of the IdCollection class
 | Add(array<ID>[]()[]) | Adds the specified values.
 | Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ID >)>).)
 | Clear()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ID >)>).)
 | ClearItems()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ID >)>).)
 | Combine(IdCollection, IdCollection) | Gets a collection containing the combined items of two other collections.
 | Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ID >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( ID >)>).)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ID >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ID >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ID >)>).)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ID >)>).)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ID >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( ID >)>).)
 | Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ID >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ID >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ID >)>).)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ID >)>).)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection<(Of <( ID >)>).)
 | ToArray()()() | Copies the collection to an array.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
 | Collection<(Of <( ID >)>)
 |  | IdCollection


IdCollection Constructor

IdCollection Constructor
Namespaces ► Sitecore.Collections ► IdCollection ► IdCollection()()()
Initializes a new instance of the IdCollection class
Declaration Syntax
C#
public IdCollection()


Add Method (values)

Add Method (values)
Namespaces ► Sitecore.Collections ► IdCollection ► Add(array<ID>[]()[])
Adds the specified values.
Declaration Syntax
C#
public void Add(
    ID[] values
)
Parameters
values (array< ID >[]()[])
The values.


Combine Method (collection1, collection2)

Combine Method (collection1, collection2)
Namespaces ► Sitecore.Collections ► IdCollection ► Combine(IdCollection, IdCollection)
Gets a collection containing the combined items of two other collections.
Declaration Syntax
C#
public static IdCollection Combine(
    IdCollection collection1,
    IdCollection collection2
)
Parameters
collection1 (IdCollection)
The collection1.
collection2 (IdCollection)
The collection2.
Return Value


ToArray Method

ToArray Method
Namespaces ► Sitecore.Collections ► IdCollection ► ToArray()()()
Copies the collection to an array.
Declaration Syntax
C#
public ID[] ToArray()
Return Value


ToString Method

ToString Method
Namespaces ► Sitecore.Collections ► IdCollection ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


IdList Class

IdList Class
Namespaces ► Sitecore.Collections ► IdList
Holds a list of Ids.
Declaration Syntax
C#
public class IdList : List<ID>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IdList()()() | Initializes a new instance of the IdList class
 | Add(T) | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | AddRange(IEnumerable<(Of <(T>)>)) | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | AsReadOnly()()() | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List<(Of <( ID >)>).)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( ID >)>).)
 | BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List<(Of <( ID >)>).)
 | BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( ID >)>).)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <( ID >)>).)
 | Clear()()() | Removes all elements from the List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | Contains(T) | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | ConvertAll<(Of <(TOutput>)>)(Converter<(Of <(T, TOutput>)>)) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List<(Of <( ID >)>).)
 | CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List<(Of <( ID >)>).)
 | CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( ID >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( ID >)>).)
 | Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <(T>)>)) | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( ID >)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | FindAll(Predicate<(Of <(T>)>)) | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( ID >)>).)
 | FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( ID >)>).)
 | FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( ID >)>).)
 | FindLast(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( ID >)>).)
 | FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( ID >)>).)
 | ForEach(Action<(Of <(T>)>)) | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( ID >)>).)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( ID >)>).)
 | Insert(Int32, T) | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( ID >)>).)
 | InsertRange(Int32, IEnumerable<(Of <(T>)>)) | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( ID >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from List<(Of <( ID >)>).)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( ID >)>).)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( ID >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | RemoveAll(Predicate<(Of <(T>)>)) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( ID >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List<(Of <( ID >)>).)
 | Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List<(Of <( ID >)>).)
 | Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( ID >)>).)
 | Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( ID >)>).)
 | Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List<(Of <( ID >)>).)
 | ToArray()()() | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List<(Of <( ID >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()()() | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List<(Of <( ID >)>).)
 | TrueForAll(Predicate<(Of <(T>)>)) | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List<(Of <( ID >)>).)
Inheritance Hierarchy
Object
 | List<(Of <( ID >)>)
 |  | IdList


IdList Constructor

IdList Constructor
Namespaces ► Sitecore.Collections ► IdList ► IdList()()()
Initializes a new instance of the IdList class
Declaration Syntax
C#
public IdList()


IDList Class

IDList Class
Namespaces ► Sitecore.Collections ► IDList
Represents a list of Ids.
Declaration Syntax
C#
public class IDList : IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IDList()()() | Initializes a new instance of the IDList class
 | Add(ID) | Adds the specified id.
 | Add(IDList, IDList) | Adds the specified list1.
 | Build(array<ID>[]()[]) | Builds the specified ids.
 | Clone()()() | Clones this instance (shallowly).
 | Count | Gets the count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataLength()()() | Gets the size of the data to use when caching.
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the ID at the specified index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(ID) | Removes the specified id.
 | ToArray()()() | Converts the IDList to an array.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
IDList


IDList Constructor

IDList Constructor
Namespaces ► Sitecore.Collections ► IDList ► IDList()()()
Initializes a new instance of the IDList class
Declaration Syntax
C#
public IDList()


Add Method

Add Method
Namespaces ► Sitecore.Collections ► IDList ► Add()()()
Members
Icon | Member | Description
 | Add(ID) | Adds the specified id.
 | Add(IDList, IDList) | Adds the specified list1.


Add Method (list1, list2)

Add Method (list1, list2)
Namespaces ► Sitecore.Collections ► IDList ► Add(IDList, IDList)
Adds the specified list1.
Declaration Syntax
C#
public static IDList Add(
    IDList list1,
    IDList list2
)
Parameters
list1 (IDList)
The list1.
list2 (IDList)
The list2.
Return Value
The add.


Add Method (id)

Add Method (id)
Namespaces ► Sitecore.Collections ► IDList ► Add(ID)
Adds the specified id.
Declaration Syntax
C#
public void Add(
    ID id
)
Parameters
id (ID)
The id.


Build Method (ids)

Build Method (ids)
Namespaces ► Sitecore.Collections ► IDList ► Build(array<ID>[]()[])
Builds the specified ids.
Declaration Syntax
C#
public static IDList Build(
    params ID[] ids
)
Parameters
ids (array< ID >[]()[])
The ids.
Return Value
The build.


Clone Method

Clone Method
Namespaces ► Sitecore.Collections ► IDList ► Clone()()()
Clones this instance (shallowly).
Declaration Syntax
C#
public IDList Clone()
Return Value


Count Property

Count Property
Namespaces ► Sitecore.Collections ► IDList ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


GetDataLength Method

GetDataLength Method
Namespaces ► Sitecore.Collections ► IDList ► GetDataLength()()()
Gets the size of the data to use when caching.
Declaration Syntax
C#
public long GetDataLength()
Return Value


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Collections ► IDList ► GetEnumerator()()()
Returns an enumerator that iterates through a collection.
Declaration Syntax
C#
public IEnumerator GetEnumerator()
Return Value
An IEnumerator object that can be used to iterate through the collection.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Collections ► IDList ► Item[([(Int32])])
Gets the ID at the specified index.
Declaration Syntax
C#
public ID this[
    int index
] { get; }
Parameters
index (Int32)
Value
The ID.


Remove Method (id)

Remove Method (id)
Namespaces ► Sitecore.Collections ► IDList ► Remove(ID)
Removes the specified id.
Declaration Syntax
C#
public void Remove(
    ID id
)
Parameters
id (ID)
The id.


ToArray Method

ToArray Method
Namespaces ► Sitecore.Collections ► IDList ► ToArray()()()
Converts the IDList to an array.
Declaration Syntax
C#
public Array ToArray()
Return Value
The IDList as an array.


IndexedDictionary Class

IndexedDictionary Class
Namespaces ► Sitecore.Collections ► IndexedDictionary
Maintains a dictionary of objects with the ability to retrieve the objects in the same order as they were put in.
Declaration Syntax
C#
public class IndexedDictionary : ICollection,
    IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexedDictionary()()() | Initializes a new instance of the IndexedDictionary class
 | CopyTo(Array, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index.
 | Count | Gets the number of elements contained in the ICollection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKey(Int32) | Gets the key.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
 | Item[([(Int32])]) | Gets the Object at the specified index.
 | Item[([(Object])]) | Gets or sets the Object with the specified key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(Int32) | Removes the specified index.
 | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
IndexedDictionary


IndexedDictionary Constructor

IndexedDictionary Constructor
Namespaces ► Sitecore.Collections ► IndexedDictionary ► IndexedDictionary()()()
Initializes a new instance of the IndexedDictionary class
Declaration Syntax
C#
public IndexedDictionary()


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces ► Sitecore.Collections ► IndexedDictionary ► CopyTo(Array, Int32)
Copies the elements of the ICollection to an Array, starting at a particular Array index.
Declaration Syntax
C#
public void CopyTo(
    Array array,
    int index
)
Parameters
array (Array)
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index (Int32)
The zero-based index in array at which copying begins.
Exceptions
Exception | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional.-or- index is equal to or greater than the length of array.-or- The number of elements in the source ICollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ICollection cannot be cast automatically to the type of the destination array.


Count Property

Count Property
Namespaces ► Sitecore.Collections ► IndexedDictionary ► Count
Gets the number of elements contained in the ICollection.
Declaration Syntax
C#
public int Count { get; }
Value
Return Value
The number of elements contained in the ICollection.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Collections ► IndexedDictionary ► GetEnumerator()()()
Returns an enumerator that iterates through a collection.
Declaration Syntax
C#
public IEnumerator GetEnumerator()
Return Value
An IEnumerator object that can be used to iterate through the collection.


GetKey Method (index)

GetKey Method (index)
Namespaces ► Sitecore.Collections ► IndexedDictionary ► GetKey(Int32)
Gets the key.
Declaration Syntax
C#
public Object GetKey(
    int index
)
Parameters
index (Int32)
The index.
Return Value


IsSynchronized Property

IsSynchronized Property
Namespaces ► Sitecore.Collections ► IndexedDictionary ► IsSynchronized
Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Declaration Syntax
C#
public bool IsSynchronized { get; }
Value
Return Value
true if access to the ICollection is synchronized (thread safe); otherwise, false.


Item Property

Item Property
Namespaces ► Sitecore.Collections ► IndexedDictionary ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets the Object at the specified index.
 | Item[([(Object])]) | Gets or sets the Object with the specified key.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Collections ► IndexedDictionary ► Item[([(Int32])])
Gets the Object at the specified index.
Declaration Syntax
C#
public Object this[
    int index
] { get; }
Parameters
index (Int32)
Value


Item Property (key)

Item Property (key)
Namespaces ► Sitecore.Collections ► IndexedDictionary ► Item[([(Object])])
Gets or sets the Object with the specified key.
Declaration Syntax
C#
public Object this[
    Object key
] { get; set; }
Parameters
key (Object)
Value


Remove Method (index)

Remove Method (index)
Namespaces ► Sitecore.Collections ► IndexedDictionary ► Remove(Int32)
Removes the specified index.
Declaration Syntax
C#
public void Remove(
    int index
)
Parameters
index (Int32)
The index.


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Collections ► IndexedDictionary ► SyncRoot
Gets an object that can be used to synchronize access to the ICollection.
Declaration Syntax
C#
public Object SyncRoot { get; }
Value
Return Value
An object that can be used to synchronize access to the ICollection.


ItemCollection Class

ItemCollection Class
Namespaces ► Sitecore.Collections ► ItemCollection
Represents a collection of Item objects.
Declaration Syntax
C#
public class ItemCollection : CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemCollection()()() | Initializes a new instance of the ItemCollection class
 | Add(Item) | Adds the specified item.
 | AddRange(ItemCollection) | Adds the range.
 | AddRange(array<Item>[]()[]) | Adds the range.
 | Build(array<Item>[]()[]) | Builds the collection from the specified items.
 | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
 | Clear()()() | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
 | Contains(Item) | Determines whether the collection contains the specified item.
 | ContainsID(ID) | Determines whether the collection contains an item with the specified ID.
 | CopyTo(Array, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index.
 | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(Item) | Searches for the item and returns the zero-based index of the first occurrence within the entire ItemCollection.
 | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
 | Insert(Int32, Item) | Inserts the item at the specified index.
 | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
 | Item[([(Int32])]) | Gets the Item at the specified index.
 | Item[([(String])]) | Gets the Item with the specified name.
 | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnClear()()() | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
 | OnClearComplete()()() | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
 | OnValidate(Object) | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
 | Remove(Item) | Removes the specified item.
 | Remove(Int32) | Removes the item at the specified index.
 | RemoveAt(Int32) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
 | Sort(IComparer) | Sorts the collection.
 | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.
 | ToArray()()() | Converts the list to an array.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ItemCollection


ItemCollection Constructor

ItemCollection Constructor
Namespaces ► Sitecore.Collections ► ItemCollection ► ItemCollection()()()
Initializes a new instance of the ItemCollection class
Declaration Syntax
C#
public ItemCollection()


Add Method (item)

Add Method (item)
Namespaces ► Sitecore.Collections ► ItemCollection ► Add(Item)
Adds the specified item.
Declaration Syntax
C#
public int Add(
    Item item
)
Parameters
item (Item)
The item.
Return Value


AddRange Method

AddRange Method
Namespaces ► Sitecore.Collections ► ItemCollection ► AddRange()()()
Members
Icon | Member | Description
 | AddRange(ItemCollection) | Adds the range.
 | AddRange(array<Item>[]()[]) | Adds the range.


AddRange Method (collection)

AddRange Method (collection)
Namespaces ► Sitecore.Collections ► ItemCollection ► AddRange(ItemCollection)
Adds the range.
Declaration Syntax
C#
public void AddRange(
    ItemCollection collection
)
Parameters
collection (ItemCollection)
The collection.


AddRange Method (items)

AddRange Method (items)
Namespaces ► Sitecore.Collections ► ItemCollection ► AddRange(array<Item>[]()[])
Adds the range.
Declaration Syntax
C#
public void AddRange(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.


Build Method (items)

Build Method (items)
Namespaces ► Sitecore.Collections ► ItemCollection ► Build(array<Item>[]()[])
Builds the collection from the specified items.
Declaration Syntax
C#
public static ItemCollection Build(
    params Item[] items
)
Parameters
items (array< Item >[]()[])
The items.
Return Value


Contains Method (item)

Contains Method (item)
Namespaces ► Sitecore.Collections ► ItemCollection ► Contains(Item)
Determines whether the collection contains the specified item.
Declaration Syntax
C#
public bool Contains(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the collection contains the specified item; otherwise, false.


ContainsID Method (itemID)

ContainsID Method (itemID)
Namespaces ► Sitecore.Collections ► ItemCollection ► ContainsID(ID)
Determines whether the collection contains an item with the specified ID.
Declaration Syntax
C#
public bool ContainsID(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value
true if the collection contains an item with the specified ID; otherwise, false.


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces ► Sitecore.Collections ► ItemCollection ► CopyTo(Array, Int32)
Copies the elements of the ICollection to an Array, starting at a particular Array index.
Declaration Syntax
C#
public void CopyTo(
    Array array,
    int index
)
Parameters
array (Array)
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index (Int32)
The zero-based index in array at which copying begins.
Exceptions
Exception | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional.-or- index is equal to or greater than the length of array.-or- The number of elements in the source ICollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ICollection cannot be cast automatically to the type of the destination array.


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► Sitecore.Collections ► ItemCollection ► IndexOf(Item)
Searches for the item and returns the zero-based index of the first occurrence within the entire ItemCollection.
Declaration Syntax
C#
public int IndexOf(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The index position of the item if that Item is found, or -1 if it is not.


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► Sitecore.Collections ► ItemCollection ► Insert(Int32, Item)
Inserts the item at the specified index.
Declaration Syntax
C#
public void Insert(
    int index,
    Item item
)
Parameters
index (Int32)
The index.
item (Item)
The item.


IsSynchronized Property

IsSynchronized Property
Namespaces ► Sitecore.Collections ► ItemCollection ► IsSynchronized
Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Declaration Syntax
C#
public bool IsSynchronized { get; }
Value
Return Value
true if access to the ICollection is synchronized (thread safe); otherwise, false.


Item Property

Item Property
Namespaces ► Sitecore.Collections ► ItemCollection ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets the Item at the specified index.
 | Item[([(String])]) | Gets the Item with the specified name.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Collections ► ItemCollection ► Item[([(Int32])])
Gets the Item at the specified index.
Declaration Syntax
C#
public Item this[
    int index
] { get; }
Parameters
index (Int32)
Value


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Collections ► ItemCollection ► Item[([(String])])
Gets the Item with the specified name.
Declaration Syntax
C#
public Item this[
    string name
] { get; }
Parameters
name (String)
Value


Remove Method

Remove Method
Namespaces ► Sitecore.Collections ► ItemCollection ► Remove()()()
Members
Icon | Member | Description
 | Remove(Item) | Removes the specified item.
 | Remove(Int32) | Removes the item at the specified index.


Remove Method (item)

Remove Method (item)
Namespaces ► Sitecore.Collections ► ItemCollection ► Remove(Item)
Removes the specified item.
Declaration Syntax
C#
public void Remove(
    Item item
)
Parameters
item (Item)
The item.


Remove Method (index)

Remove Method (index)
Namespaces ► Sitecore.Collections ► ItemCollection ► Remove(Int32)
Removes the item at the specified index.
Declaration Syntax
C#
public void Remove(
    int index
)
Parameters
index (Int32)
The index.


Sort Method (comparer)

Sort Method (comparer)
Namespaces ► Sitecore.Collections ► ItemCollection ► Sort(IComparer)
Sorts the collection.
Declaration Syntax
C#
public void Sort(
    IComparer comparer
)
Parameters
comparer (IComparer)
The comparer.


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Collections ► ItemCollection ► SyncRoot
Gets an object that can be used to synchronize access to the ICollection.
Declaration Syntax
C#
public Object SyncRoot { get; }
Value
Return Value
An object that can be used to synchronize access to the ICollection.


ToArray Method

ToArray Method
Namespaces ► Sitecore.Collections ► ItemCollection ► ToArray()()()
Converts the list to an array.
Declaration Syntax
C#
public Item[] ToArray()
Return Value


ItemList Class

ItemList Class
Namespaces ► Sitecore.Collections ► ItemList
Represents a list of Item objects.
Declaration Syntax
C#
public class ItemList : List<Item>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemList()()() | Initializes a new instance of the ItemList class
 | Add(T) | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | AddRange(IEnumerable<(Of <(T>)>)) | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | AsReadOnly()()() | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List<(Of <( Item >)>).)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( Item >)>).)
 | BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List<(Of <( Item >)>).)
 | BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( Item >)>).)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <( Item >)>).)
 | Clear()()() | Removes all elements from the List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | Contains(T) | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | ConvertAll<(Of <(TOutput>)>)(Converter<(Of <(T, TOutput>)>)) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List<(Of <( Item >)>).)
 | CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List<(Of <( Item >)>).)
 | CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( Item >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( Item >)>).)
 | Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <(T>)>)) | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( Item >)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | FindAll(Predicate<(Of <(T>)>)) | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( Item >)>).)
 | FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( Item >)>).)
 | FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( Item >)>).)
 | FindLast(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( Item >)>).)
 | FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( Item >)>).)
 | ForEach(Action<(Of <(T>)>)) | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( Item >)>).)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( Item >)>).)
 | Insert(Int32, T) | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( Item >)>).)
 | InsertRange(Int32, IEnumerable<(Of <(T>)>)) | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( Item >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from List<(Of <( Item >)>).)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( Item >)>).)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( Item >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | RemoveAll(Predicate<(Of <(T>)>)) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( Item >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List<(Of <( Item >)>).)
 | Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List<(Of <( Item >)>).)
 | Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( Item >)>).)
 | Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( Item >)>).)
 | Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List<(Of <( Item >)>).)
 | ToArray()()() | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List<(Of <( Item >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()()() | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List<(Of <( Item >)>).)
 | TrueForAll(Predicate<(Of <(T>)>)) | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List<(Of <( Item >)>).)
Inheritance Hierarchy
Object
 | List<(Of <( Item >)>)
 |  | ItemList


ItemList Constructor

ItemList Constructor
Namespaces ► Sitecore.Collections ► ItemList ► ItemList()()()
Initializes a new instance of the ItemList class
Declaration Syntax
C#
public ItemList()


JobCollection Class

JobCollection Class
Namespaces ► Sitecore.Collections ► JobCollection
Collection class for holding jobs.
Declaration Syntax
C#
public class JobCollection : Collection<Job>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JobCollection()()() | Initializes a new instance of the JobCollection class
 | Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Job >)>).)
 | Clear()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Job >)>).)
 | ClearItems()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Job >)>).)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Job >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Job >)>).)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Job >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Job >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Job >)>).)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Job >)>).)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Job >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Job >)>).)
 | Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Job >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Job >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Job >)>).)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Job >)>).)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection<(Of <( Job >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection<(Of <( Job >)>)
 |  | JobCollection


JobCollection Constructor

JobCollection Constructor
Namespaces ► Sitecore.Collections ► JobCollection ► JobCollection()()()
Initializes a new instance of the JobCollection class
Declaration Syntax
C#
public JobCollection()


LanguageCollection Class

LanguageCollection Class
Namespaces ► Sitecore.Collections ► LanguageCollection
Holds a collection of languages.
Declaration Syntax
C#
public class LanguageCollection : Collection<Language>,
    ICacheable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LanguageCollection()()() | Initializes a new instance of the LanguageCollection class.
 | LanguageCollection(IEnumerable<(Of <(Language>)>)) | Initializes a new instance of the LanguageCollection class.
 | Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Language >)>).)
 | Cacheable | Gets a value indicating if the object is cacheable.
 | Clear()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Language >)>).)
 | ClearItems()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Language >)>).)
 | Contains(String) | Checks if the collection contains a language with a specific name.
 | Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Language >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Language >)>).)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Language >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataLength()()() | Gets the current (estimated) size of the object (in bytes).
 | GetEnumerator()()() | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Language >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Immutable | Gets a value indicating whether this ICacheable is immutable.
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Language >)>).)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Language >)>).)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Language >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Language >)>).)
 | Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Language >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Language >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Language >)>).)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Language >)>).)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection<(Of <( Language >)>).)
 | ToArray()()() | Converts the collection to an array.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection<(Of <( Language >)>)
 |  | LanguageCollection


LanguageCollection Constructor

LanguageCollection Constructor
Namespaces ► Sitecore.Collections ► LanguageCollection ► LanguageCollection()()()
Members
Icon | Member | Description
 | LanguageCollection()()() | Initializes a new instance of the LanguageCollection class.
 | LanguageCollection(IEnumerable<(Of <(Language>)>)) | Initializes a new instance of the LanguageCollection class.


LanguageCollection Constructor

LanguageCollection Constructor
Namespaces ► Sitecore.Collections ► LanguageCollection ► LanguageCollection()()()
Initializes a new instance of the LanguageCollection class.
Declaration Syntax
C#
public LanguageCollection()


LanguageCollection Constructor (initialData)

LanguageCollection Constructor (initialData)
Namespaces ► Sitecore.Collections ► LanguageCollection ► LanguageCollection(IEnumerable<(Of <(Language>)>))
Initializes a new instance of the LanguageCollection class.
Declaration Syntax
C#
public LanguageCollection(
    IEnumerable<Language> initialData
)
Parameters
initialData (IEnumerable<(Of <( Language >)>))
The initial data.


Cacheable Property

Cacheable Property
Namespaces ► Sitecore.Collections ► LanguageCollection ► Cacheable
Gets a value indicating if the object is cacheable.
Declaration Syntax
C#
public bool Cacheable { get; set; }
Value


Contains Method (languageName)

Contains Method (languageName)
Namespaces ► Sitecore.Collections ► LanguageCollection ► Contains(String)
Checks if the collection contains a language with a specific name.
Declaration Syntax
C#
public bool Contains(
    string languageName
)
Parameters
languageName (String)
Return Value


GetDataLength Method

GetDataLength Method
Namespaces ► Sitecore.Collections ► LanguageCollection ► GetDataLength()()()
Gets the current (estimated) size of the object (in bytes).
Declaration Syntax
C#
public long GetDataLength()
Return Value


Immutable Property

Immutable Property
Namespaces ► Sitecore.Collections ► LanguageCollection ► Immutable
Gets a value indicating whether this ICacheable is immutable.
Declaration Syntax
C#
public bool Immutable { get; }
Value
true if immutable; otherwise, false.


ToArray Method

ToArray Method
Namespaces ► Sitecore.Collections ► LanguageCollection ► ToArray()()()
Converts the collection to an array.
Declaration Syntax
C#
public Language[] ToArray()
Return Value


LanguageDictionary Class

LanguageDictionary Class
Namespaces ► Sitecore.Collections ► LanguageDictionary
Dictionary of Languages
Declaration Syntax
C#
[SerializableAttribute]
public class LanguageDictionary : SafeDictionary<string, Language>,
    ICacheable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LanguageDictionary(SerializationInfo, StreamingContext) | Initializes a new instance of the LanguageDictionary class.
 | Add(TKey, TValue) | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | AddRange(SafeDictionary<(Of <(TKey, TValue>)>)) | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Cacheable | Gets a value indicating if the object is cacheable.
 | Clear()()() | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Clone()()() | Clones this instance. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | ContainsKey(TKey) | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Count | Gets the number of entries in the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataLength()()() | Gets the current (estimated) size of the object (in bytes).
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides SafeDictionary <(Of <(String, Language >)>).GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hashtable | Gets the internal hashtable. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Immutable | Gets a value indicating whether this ICacheable is immutable.
 | Item[([(TKey])]) | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Keys | Gets the keys of the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Remove(TKey) | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | SyncRoot | Gets the object to use for locking in multi-thread scenarios. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | ToKeyArray()()() | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToValueArray()()() | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | TryGetValue(TKey, TValue%) | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Values | Gets the values of the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
Inheritance Hierarchy
Object
 | SafeDictionary <(Of <(String, Language >)>)
 |  | LanguageDictionary


LanguageDictionary Constructor (info, context)

LanguageDictionary Constructor (info, context)
Namespaces ► Sitecore.Collections ► LanguageDictionary ► LanguageDictionary(SerializationInfo, StreamingContext)
Initializes a new instance of the LanguageDictionary class.
Declaration Syntax
C#
protected LanguageDictionary(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Cacheable Property

Cacheable Property
Namespaces ► Sitecore.Collections ► LanguageDictionary ► Cacheable
Gets a value indicating if the object is cacheable.
Declaration Syntax
C#
public bool Cacheable { get; set; }
Value


GetDataLength Method

GetDataLength Method
Namespaces ► Sitecore.Collections ► LanguageDictionary ► GetDataLength()()()
Gets the current (estimated) size of the object (in bytes).
Declaration Syntax
C#
public long GetDataLength()
Return Value


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Collections ► LanguageDictionary ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Immutable Property

Immutable Property
Namespaces ► Sitecore.Collections ► LanguageDictionary ► Immutable
Gets a value indicating whether this ICacheable is immutable.
Declaration Syntax
C#
public bool Immutable { get; }
Value
true if immutable; otherwise, false.


LanguageList Class

LanguageList Class
Namespaces ► Sitecore.Collections ► LanguageList
Represents a list of languages.
Declaration Syntax
C#
public class LanguageList : IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LanguageList()()() | Initializes a new instance of the LanguageList class
 | Add(Language) | Adds the specified language.
 | Add(LanguageList, LanguageList) | Adds the specified list.
 | Build(array<Language>[]()[]) | Builds the specified languages.
 | Contains(Language) | Determines whether the list contains the specified language.
 | Count | Gets the count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the Language at the specified index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToArray()()() | Converts the LanguageList to an array.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LanguageList


LanguageList Constructor

LanguageList Constructor
Namespaces ► Sitecore.Collections ► LanguageList ► LanguageList()()()
Initializes a new instance of the LanguageList class
Declaration Syntax
C#
public LanguageList()


Add Method

Add Method
Namespaces ► Sitecore.Collections ► LanguageList ► Add()()()
Members
Icon | Member | Description
 | Add(Language) | Adds the specified language.
 | Add(LanguageList, LanguageList) | Adds the specified list.


Add Method (list1, list2)

Add Method (list1, list2)
Namespaces ► Sitecore.Collections ► LanguageList ► Add(LanguageList, LanguageList)
Adds the specified list.
Declaration Syntax
C#
public static LanguageList Add(
    LanguageList list1,
    LanguageList list2
)
Parameters
list1 (LanguageList)
The list1.
list2 (LanguageList)
The list2.
Return Value


Add Method (language)

Add Method (language)
Namespaces ► Sitecore.Collections ► LanguageList ► Add(Language)
Adds the specified language.
Declaration Syntax
C#
public void Add(
    Language language
)
Parameters
language (Language)
The language.


Build Method (languages)

Build Method (languages)
Namespaces ► Sitecore.Collections ► LanguageList ► Build(array<Language>[]()[])
Builds the specified languages.
Declaration Syntax
C#
public static LanguageList Build(
    params Language[] languages
)
Parameters
languages (array< Language >[]()[])
The languages.
Return Value


Contains Method (language)

Contains Method (language)
Namespaces ► Sitecore.Collections ► LanguageList ► Contains(Language)
Determines whether the list contains the specified language.
Declaration Syntax
C#
public bool Contains(
    Language language
)
Parameters
language (Language)
The language.
Return Value
true if the list contains the specified language; otherwise, false.


Count Property

Count Property
Namespaces ► Sitecore.Collections ► LanguageList ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Collections ► LanguageList ► GetEnumerator()()()
Returns an enumerator that iterates through a collection.
Declaration Syntax
C#
public IEnumerator GetEnumerator()
Return Value
An IEnumerator object that can be used to iterate through the collection.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Collections ► LanguageList ► Item[([(Int32])])
Gets the Language at the specified index.
Declaration Syntax
C#
public Language this[
    int index
] { get; }
Parameters
index (Int32)
Value


ToArray Method

ToArray Method
Namespaces ► Sitecore.Collections ► LanguageList ► ToArray()()()
Converts the LanguageList to an array.
Declaration Syntax
C#
public Array ToArray()
Return Value
The LanguageList as an array.


LockSet Class

LockSet Class
Namespaces ► Sitecore.Collections ► LockSet
LockSet class
Declaration Syntax
C#
public class LockSet
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LockSet()()() | Initializes a new instance of the LockSet class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLock(Object) | Gets a lock object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LockSet


LockSet Constructor

LockSet Constructor
Namespaces ► Sitecore.Collections ► LockSet ► LockSet()()()
Initializes a new instance of the LockSet class.
Declaration Syntax
C#
public LockSet()


GetLock Method (value)

GetLock Method (value)
Namespaces ► Sitecore.Collections ► LockSet ► GetLock(Object)
Gets a lock object.
Declaration Syntax
C#
public Object GetLock(
    Object value
)
Parameters
value (Object)
The value.
Return Value
The lock object.


MinMax(T) Class

MinMax<(Of <(T>)>) Class
Namespaces ► Sitecore.Collections ► MinMax<(Of <(T>)>)
MinMax class
Declaration Syntax
C#
public class MinMax<T>
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MinMax<(Of <(T>)>)(T, T) | Initializes a new instance of the Pair<(Of <(T1, T2>)>) class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Max | Gets the max.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Min | Gets the min.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MinMax<(Of <(T>)>)


MinMax(T) Constructor (min, max)

MinMax<(Of <(T>)>) Constructor (min, max)
Namespaces ► Sitecore.Collections ► MinMax<(Of <(T>)>) ► MinMax<(Of <(T>)>)(T, T)
Initializes a new instance of the Pair<(Of <(T1, T2>)>) class.
Declaration Syntax
C#
public MinMax(
    T min,
    T max
)
Parameters
min (T)
The min.
max (T)
The max.


Max Property

Max Property
Namespaces ► Sitecore.Collections ► MinMax<(Of <(T>)>) ► Max
Gets the max.
Declaration Syntax
C#
public T Max { get; }
Value
The max.


Min Property

Min Property
Namespaces ► Sitecore.Collections ► MinMax<(Of <(T>)>) ► Min
Gets the min.
Declaration Syntax
C#
public T Min { get; }
Value
The min.


Pair(T1, T2) Class

Pair<(Of <(T1, T2>)>) Class
Namespaces ► Sitecore.Collections ► Pair<(Of <(T1, T2>)>)
Represents a pair.
Declaration Syntax
C#
public class Pair<T1, T2>
Generic Template Parameters
T1
T2
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Pair<(Of <(T1, T2>)>)(T1, T2) | Initializes a new instance of the Pair<(Of <(T1, T2>)>) class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Part1 | Gets part1.
 | Part2 | Gets part2.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Pair<(Of <(T1, T2>)>)


Pair(T1, T2) Constructor (part1, part2)

Pair<(Of <(T1, T2>)>) Constructor (part1, part2)
Namespaces ► Sitecore.Collections ► Pair<(Of <(T1, T2>)>) ► Pair<(Of <(T1, T2>)>)(T1, T2)
Initializes a new instance of the Pair<(Of <(T1, T2>)>) class.
Declaration Syntax
C#
public Pair(
    T1 part1,
    T2 part2
)
Parameters
part1 (T1)
The part1.
part2 (T2)
The part2.


Part1 Property

Part1 Property
Namespaces ► Sitecore.Collections ► Pair<(Of <(T1, T2>)>) ► Part1
Gets part1.
Declaration Syntax
C#
public T1 Part1 { get; }
Value
The part1.


Part2 Property

Part2 Property
Namespaces ► Sitecore.Collections ► Pair<(Of <(T1, T2>)>) ► Part2
Gets part2.
Declaration Syntax
C#
public T2 Part2 { get; }
Value
The part1.


PerformanceCounterCollection Class

PerformanceCounterCollection Class
Namespaces ► Sitecore.Collections ► PerformanceCounterCollection
Represents a performance counter collection.
Declaration Syntax
C#
public class PerformanceCounterCollection : Collection<PerformanceCounter>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PerformanceCounterCollection()()() | Initializes a new instance of the PerformanceCounterCollection class
 | Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | Clear()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | ClearItems()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection<(Of <( PerformanceCounter >)>).)
 | ToArray()()() | Converts the collection to an array.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection<(Of <( PerformanceCounter >)>)
 |  | PerformanceCounterCollection


PerformanceCounterCollection Constructor

PerformanceCounterCollection Constructor
Namespaces ► Sitecore.Collections ► PerformanceCounterCollection ► PerformanceCounterCollection()()()
Initializes a new instance of the PerformanceCounterCollection class
Declaration Syntax
C#
public PerformanceCounterCollection()


ToArray Method

ToArray Method
Namespaces ► Sitecore.Collections ► PerformanceCounterCollection ► ToArray()()()
Converts the collection to an array.
Declaration Syntax
C#
public PerformanceCounter[] ToArray()
Return Value
The PerformanceCounterCollection as an array.


ReadOnlyList(TElement) Class

ReadOnlyList<(Of <(TElement>)>) Class
Namespaces ► Sitecore.Collections ► ReadOnlyList<(Of <(TElement>)>)
ReadOnlyList class
Declaration Syntax
C#
public class ReadOnlyList<TElement> : IEnumerable<T>,
    IEnumerable
Generic Template Parameters
TElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReadOnlyList<(Of <(TElement>)>)()()() | Initializes a new instance of the ReadOnlyList<(Of <(TElement>)>) class.
 | ReadOnlyList<(Of <(TElement>)>)(IEnumerable<(Of <(TElement>)>)) | Initializes a new instance of the ReadOnlyList<(Of <(TElement>)>) class.
 | Combine(IEnumerable<(Of <(TElement>)>), IEnumerable<(Of <(TElement>)>)) | Combines two lists
 | Contains(TElement) | Determines whether the list contains the specified element.
 | Count | Gets the number of entries in the list.
 | Empty | Gets the empty collection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the element at the specified index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToArray()()() | Converts the list to an array.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ReadOnlyList<(Of <(TElement>)>)
 |  | AttributeList
 |  | ReadOnlyStringList
 |  | ArchiveEntryList
 |  | ReadOnlyItemList
 |  | TemplateList
 |  | RenderingReferenceList
 |  | AccountList
 |  | RoleList
 |  | UserList
 |  | DomainList
 |  | PlaceholderList


ReadOnlyList(TElement) Constructor

ReadOnlyList<(Of <(TElement>)>) Constructor
Namespaces ► Sitecore.Collections ► ReadOnlyList<(Of <(TElement>)>) ► ReadOnlyList<(Of <(TElement>)>)()()()
Members
Icon | Member | Description
 | ReadOnlyList<(Of <(TElement>)>)()()() | Initializes a new instance of the ReadOnlyList<(Of <(TElement>)>) class.
 | ReadOnlyList<(Of <(TElement>)>)(IEnumerable<(Of <(TElement>)>)) | Initializes a new instance of the ReadOnlyList<(Of <(TElement>)>) class.


ReadOnlyList(TElement) Constructor

ReadOnlyList<(Of <(TElement>)>) Constructor
Namespaces ► Sitecore.Collections ► ReadOnlyList<(Of <(TElement>)>) ► ReadOnlyList<(Of <(TElement>)>)()()()
Initializes a new instance of the ReadOnlyList<(Of <(TElement>)>) class.
Declaration Syntax
C#
public ReadOnlyList()


ReadOnlyList(TElement) Constructor (entries)

ReadOnlyList<(Of <(TElement>)>) Constructor (entries)
Namespaces ► Sitecore.Collections ► ReadOnlyList<(Of <(TElement>)>) ► ReadOnlyList<(Of <(TElement>)>)(IEnumerable<(Of <(TElement>)>))
Initializes a new instance of the ReadOnlyList<(Of <(TElement>)>) class.
Declaration Syntax
C#
public ReadOnlyList(
    IEnumerable<TElement> entries
)
Parameters
entries (IEnumerable<(Of <( TElement >)>))
The entries.


Combine Method (list1, list2)

Combine Method (list1, list2)
Namespaces ► Sitecore.Collections ► ReadOnlyList<(Of <(TElement>)>) ► Combine(IEnumerable<(Of <(TElement>)>), IEnumerable<(Of <(TElement>)>))
Combines two lists
Declaration Syntax
C#
public static IEnumerable<TElement> Combine(
    IEnumerable<TElement> list1,
    IEnumerable<TElement> list2
)
Parameters
list1 (IEnumerable<(Of <( TElement >)>))
list2 (IEnumerable<(Of <( TElement >)>))
Value


Contains Method (element)

Contains Method (element)
Namespaces ► Sitecore.Collections ► ReadOnlyList<(Of <(TElement>)>) ► Contains(TElement)
Determines whether the list contains the specified element.
Declaration Syntax
C#
public virtual bool Contains(
    TElement element
)
Parameters
element (TElement)
The element.
Return Value
true if the list contains the specified element; otherwise, false.


Count Property

Count Property
Namespaces ► Sitecore.Collections ► ReadOnlyList<(Of <(TElement>)>) ► Count
Gets the number of entries in the list.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


Empty Property

Empty Property
Namespaces ► Sitecore.Collections ► ReadOnlyList<(Of <(TElement>)>) ► Empty
Gets the empty collection.
Declaration Syntax
C#
public static IEnumerable<TElement> Empty { get; }
Value
The empty.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Collections ► ReadOnlyList<(Of <(TElement>)>) ► GetEnumerator()()()
Returns an enumerator that iterates through a collection.
Declaration Syntax
C#
public IEnumerator GetEnumerator()
Return Value
An IEnumerator object that can be used to iterate through the collection.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Collections ► ReadOnlyList<(Of <(TElement>)>) ► Item[([(Int32])])
Gets the element at the specified index.
Declaration Syntax
C#
public TElement this[
    int index
] { get; }
Parameters
index (Int32)
Value


ToArray Method

ToArray Method
Namespaces ► Sitecore.Collections ► ReadOnlyList<(Of <(TElement>)>) ► ToArray()()()
Converts the list to an array.
Declaration Syntax
C#
public TElement[] ToArray()
Return Value


ReadOnlyStringList Class

ReadOnlyStringList Class
Namespaces ► Sitecore.Collections ► ReadOnlyStringList
ReadOnlyStringList
Declaration Syntax
C#
public class ReadOnlyStringList : ReadOnlyList<string>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReadOnlyStringList(IEnumerable<(Of <(String>)>)) | Initializes a new instance of the ReadOnlyStringList class.
 | ReadOnlyStringList()()() | Initializes a new instance of the ReadOnlyStringList class.
 | Contains(TElement) | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToArray()()() | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ReadOnlyList <(Of <(String>)>)
 |  | ReadOnlyStringList


ReadOnlyStringList Constructor

ReadOnlyStringList Constructor
Namespaces ► Sitecore.Collections ► ReadOnlyStringList ► ReadOnlyStringList()()()
Members
Icon | Member | Description
 | ReadOnlyStringList(IEnumerable<(Of <(String>)>)) | Initializes a new instance of the ReadOnlyStringList class.
 | ReadOnlyStringList()()() | Initializes a new instance of the ReadOnlyStringList class.


ReadOnlyStringList Constructor

ReadOnlyStringList Constructor
Namespaces ► Sitecore.Collections ► ReadOnlyStringList ► ReadOnlyStringList()()()
Initializes a new instance of the ReadOnlyStringList class.
Declaration Syntax
C#
public ReadOnlyStringList()


ReadOnlyStringList Constructor (entries)

ReadOnlyStringList Constructor (entries)
Namespaces ► Sitecore.Collections ► ReadOnlyStringList ► ReadOnlyStringList(IEnumerable<(Of <(String>)>))
Initializes a new instance of the ReadOnlyStringList class.
Declaration Syntax
C#
public ReadOnlyStringList(
    IEnumerable<string> entries
)
Parameters
entries (IEnumerable<(Of <(String>)>))
The entries.


SafeDictionary(TKeyAndValue) Class

SafeDictionary<(Of <(TKeyAndValue>)>) Class
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKeyAndValue>)>)
Dictionary using the same type for keys and values (and allowing dictionary[key] without exceptions).
Declaration Syntax
C#
[SerializableAttribute]
public class SafeDictionary<TKeyAndValue> : SafeDictionary<TKeyAndValue, TKeyAndValue>
Generic Template Parameters
TKeyAndValue
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SafeDictionary<(Of <(TKeyAndValue>)>)()()() | Initializes a new instance of the SafeDictionary<(Of <(TKeyAndValue>)>) class.
 | SafeDictionary<(Of <(TKeyAndValue>)>)(IEqualityComparer) | Initializes a new instance of the SafeDictionary<(Of <(TKeyAndValue>)>) class.
 | SafeDictionary<(Of <(TKeyAndValue>)>)(SerializationInfo, StreamingContext) | Initializes a new instance of the SafeDictionary<(Of <(TKeyAndValue>)>) class.
 | Add(TKey, TValue) | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | AddArray(array<TKeyAndValue>[]()[]) | Adds an array of values.
 | AddRange(SafeDictionary<(Of <(TKey, TValue>)>)) | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Clear()()() | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Clone()()() | Clones this instance.
 | ContainsKey(TKey) | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Count | Gets the number of entries in the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hashtable | Gets the internal hashtable. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Item[([(TKey])]) | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Keys | Gets the keys of the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Remove(TKey) | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | SyncRoot | Gets the object to use for locking in multi-thread scenarios. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | ToArray()()() | Converts the collection to an array.
 | ToKeyArray()()() | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToValueArray()()() | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | TryGetValue(TKey, TValue%) | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Values | Gets the values of the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
Inheritance Hierarchy
Object
 | SafeDictionary <(Of <(TKeyAndValue, TKeyAndValue>)>)
 |  | SafeDictionary<(Of <(TKeyAndValue>)>)


SafeDictionary(TKeyAndValue) Constructor

SafeDictionary<(Of <(TKeyAndValue>)>) Constructor
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKeyAndValue>)>) ► SafeDictionary<(Of <(TKeyAndValue>)>)()()()
Members
Icon | Member | Description
 | SafeDictionary<(Of <(TKeyAndValue>)>)()()() | Initializes a new instance of the SafeDictionary<(Of <(TKeyAndValue>)>) class.
 | SafeDictionary<(Of <(TKeyAndValue>)>)(IEqualityComparer) | Initializes a new instance of the SafeDictionary<(Of <(TKeyAndValue>)>) class.
 | SafeDictionary<(Of <(TKeyAndValue>)>)(SerializationInfo, StreamingContext) | Initializes a new instance of the SafeDictionary<(Of <(TKeyAndValue>)>) class.


SafeDictionary(TKeyAndValue) Constructor

SafeDictionary<(Of <(TKeyAndValue>)>) Constructor
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKeyAndValue>)>) ► SafeDictionary<(Of <(TKeyAndValue>)>)()()()
Initializes a new instance of the SafeDictionary<(Of <(TKeyAndValue>)>) class.
Declaration Syntax
C#
public SafeDictionary()


SafeDictionary(TKeyAndValue) Constructor (comparer)

SafeDictionary<(Of <(TKeyAndValue>)>) Constructor (comparer)
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKeyAndValue>)>) ► SafeDictionary<(Of <(TKeyAndValue>)>)(IEqualityComparer)
Initializes a new instance of the SafeDictionary<(Of <(TKeyAndValue>)>) class.
Declaration Syntax
C#
public SafeDictionary(
    IEqualityComparer comparer
)
Parameters
comparer (IEqualityComparer)
The comparer.


SafeDictionary(TKeyAndValue) Constructor (info, context)

SafeDictionary<(Of <(TKeyAndValue>)>) Constructor (info, context)
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKeyAndValue>)>) ► SafeDictionary<(Of <(TKeyAndValue>)>)(SerializationInfo, StreamingContext)
Initializes a new instance of the SafeDictionary<(Of <(TKeyAndValue>)>) class.
Declaration Syntax
C#
protected SafeDictionary(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


AddArray Method (values)

AddArray Method (values)
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKeyAndValue>)>) ► AddArray(array<TKeyAndValue>[]()[])
Adds an array of values.
Declaration Syntax
C#
public void AddArray(
    TKeyAndValue[] values
)
Parameters
values (array< TKeyAndValue >[]()[])
The values.


Clone Method

Clone Method
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKeyAndValue>)>) ► Clone()()()
Clones this instance.
Declaration Syntax
C#
public SafeDictionary<TKeyAndValue> Clone()
Return Value


ToArray Method

ToArray Method
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKeyAndValue>)>) ► ToArray()()()
Converts the collection to an array.
Declaration Syntax
C#
public TKeyAndValue[] ToArray()
Return Value


SafeDictionary(TKey, TValue) Class

SafeDictionary<(Of <(TKey, TValue>)>) Class
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>)
Dictionary allowing dictionary[key] without exceptions.
Declaration Syntax
C#
[SerializableAttribute]
public class SafeDictionary<TKey, TValue> : ISerializable,
    IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable
Generic Template Parameters
TKey
TValue
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SafeDictionary<(Of <(TKey, TValue>)>)()()() | Initializes a new instance of the SafeDictionary<(Of <(TKey, TValue>)>) class.
 | SafeDictionary<(Of <(TKey, TValue>)>)(IEqualityComparer) | Initializes a new instance of the SafeDictionary<(Of <(TKey, TValue>)>) class.
 | SafeDictionary<(Of <(TKey, TValue>)>)(SerializationInfo, StreamingContext) | Initializes a new instance of the SafeDictionary<(Of <(TKey, TValue>)>) class.
 | Add(TKey, TValue) | Adds the specified key/value pair to the dictionary.
 | AddRange(SafeDictionary<(Of <(TKey, TValue>)>)) | Adds a range of key/values.
 | Clear()()() | Removes all entries from the dictionary.
 | Clone()()() | Clones this instance.
 | ContainsKey(TKey) | Determines whether the dictionary contains the specified key.
 | Count | Gets the number of entries in the dictionary.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hashtable | Gets the internal hashtable.
 | Item[([(TKey])]) | Gets or sets the value with the specified key.
 | Keys | Gets the keys of the dictionary.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadOnly | Gets or sets a value indicating whether [read only].
 | Remove(TKey) | Removes the entry with the specified key from the dictionary.
 | SyncRoot | Gets the object to use for locking in multi-thread scenarios.
 | ToKeyArray()()() | Returns an array containing all keys.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToValueArray()()() | Returns an array containing all values.
 | TryGetValue(TKey, TValue%) | Attempts to get a specific value.
 | Values | Gets the values of the dictionary.
Inheritance Hierarchy
Object
 | SafeDictionary<(Of <(TKey, TValue>)>)
 |  | FieldValueDictionary
 |  | LanguageDictionary
 |  | SafeDictionary<(Of <(TKeyAndValue>)>)
 |  | StringDictionary
 |  | TemplateDictionary


SafeDictionary(TKey, TValue) Constructor

SafeDictionary<(Of <(TKey, TValue>)>) Constructor
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► SafeDictionary<(Of <(TKey, TValue>)>)()()()
Members
Icon | Member | Description
 | SafeDictionary<(Of <(TKey, TValue>)>)()()() | Initializes a new instance of the SafeDictionary<(Of <(TKey, TValue>)>) class.
 | SafeDictionary<(Of <(TKey, TValue>)>)(IEqualityComparer) | Initializes a new instance of the SafeDictionary<(Of <(TKey, TValue>)>) class.
 | SafeDictionary<(Of <(TKey, TValue>)>)(SerializationInfo, StreamingContext) | Initializes a new instance of the SafeDictionary<(Of <(TKey, TValue>)>) class.


SafeDictionary(TKey, TValue) Constructor

SafeDictionary<(Of <(TKey, TValue>)>) Constructor
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► SafeDictionary<(Of <(TKey, TValue>)>)()()()
Initializes a new instance of the SafeDictionary<(Of <(TKey, TValue>)>) class.
Declaration Syntax
C#
public SafeDictionary()


SafeDictionary(TKey, TValue) Constructor (comparer)

SafeDictionary<(Of <(TKey, TValue>)>) Constructor (comparer)
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► SafeDictionary<(Of <(TKey, TValue>)>)(IEqualityComparer)
Initializes a new instance of the SafeDictionary<(Of <(TKey, TValue>)>) class.
Declaration Syntax
C#
public SafeDictionary(
    IEqualityComparer comparer
)
Parameters
comparer (IEqualityComparer)
The comparer.


SafeDictionary(TKey, TValue) Constructor (info, context)

SafeDictionary<(Of <(TKey, TValue>)>) Constructor (info, context)
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► SafeDictionary<(Of <(TKey, TValue>)>)(SerializationInfo, StreamingContext)
Initializes a new instance of the SafeDictionary<(Of <(TKey, TValue>)>) class.
Declaration Syntax
C#
protected SafeDictionary(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Add Method (key, value)

Add Method (key, value)
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► Add(TKey, TValue)
Adds the specified key/value pair to the dictionary.
Declaration Syntax
C#
public void Add(
    TKey key,
    TValue value
)
Parameters
key (TKey)
The key.
value (TValue)
The value.


AddRange Method (dictionary)

AddRange Method (dictionary)
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► AddRange(SafeDictionary<(Of <(TKey, TValue>)>))
Adds a range of key/values.
Declaration Syntax
C#
public void AddRange(
    SafeDictionary<TKey, TValue> dictionary
)
Parameters
dictionary (SafeDictionary <(Of <( TKey, TValue >)>))
The dictionary.


Clear Method

Clear Method
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► Clear()()()
Removes all entries from the dictionary.
Declaration Syntax
C#
public void Clear()


Clone Method

Clone Method
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► Clone()()()
Clones this instance.
Declaration Syntax
C#
public virtual SafeDictionary<TKey, TValue> Clone()
Return Value


ContainsKey Method (key)

ContainsKey Method (key)
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► ContainsKey(TKey)
Determines whether the dictionary contains the specified key.
Declaration Syntax
C#
public bool ContainsKey(
    TKey key
)
Parameters
key (TKey)
The key.
Return Value
true if the dictionary contains the specified key; otherwise, false.


Count Property

Count Property
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► Count
Gets the number of entries in the dictionary.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► GetEnumerator()()()
Returns an enumerator that iterates through the collection.
Declaration Syntax
C#
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
Return Value
A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Hashtable Property

Hashtable Property
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► Hashtable
Gets the internal hashtable.
Declaration Syntax
C#
protected Hashtable Hashtable { get; }
Value
The hashtable.


Item Property (key)

Item Property (key)
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► Item[([(TKey])])
Gets or sets the value with the specified key.
Declaration Syntax
C#
public virtual TValue this[
    TKey key
] { get; set; }
Parameters
key (TKey)
Value


Keys Property

Keys Property
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► Keys
Gets the keys of the dictionary.
Declaration Syntax
C#
public IEnumerable<TKey> Keys { get; }
Value
The keys.


ReadOnly Property

ReadOnly Property
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► ReadOnly
Gets or sets a value indicating whether [read only].
Declaration Syntax
C#
public virtual bool ReadOnly { get; set; }
Value
true if [read only]; otherwise, false.


Remove Method (key)

Remove Method (key)
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► Remove(TKey)
Removes the entry with the specified key from the dictionary.
Declaration Syntax
C#
public void Remove(
    TKey key
)
Parameters
key (TKey)
The key.


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► SyncRoot
Gets the object to use for locking in multi-thread scenarios.
Declaration Syntax
C#
public Object SyncRoot { get; }
Value
The sync root.


ToKeyArray Method

ToKeyArray Method
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► ToKeyArray()()()
Returns an array containing all keys.
Declaration Syntax
C#
public TKey[] ToKeyArray()
Return Value


ToValueArray Method

ToValueArray Method
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► ToValueArray()()()
Returns an array containing all values.
Declaration Syntax
C#
public TValue[] ToValueArray()
Return Value


TryGetValue Method (key, result)

TryGetValue Method (key, result)
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► TryGetValue(TKey, TValue%)
Attempts to get a specific value.
Declaration Syntax
C#
public bool TryGetValue(
    TKey key,
    out TValue result
)
Parameters
key (TKey)
The key.
result ( TValue %)
The result.
Return Value
true if the value was found; false otherwise.


Values Property

Values Property
Namespaces ► Sitecore.Collections ► SafeDictionary<(Of <(TKey, TValue>)>) ► Values
Gets the values of the dictionary.
Declaration Syntax
C#
public IEnumerable<TValue> Values { get; }
Value
The values.


Set(T) Class

Set<(Of <(T>)>) Class
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>)
Set
Declaration Syntax
C#
public class Set<T> : IEnumerable<T>, IEnumerable
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Set<(Of <(T>)>)()()() | Initializes a new instance of the Set<(Of <(T>)>) class.
 | Set<(Of <(T>)>)(IEqualityComparer) | Initializes a new instance of the Set<(Of <(T>)>) class.
 | Set<(Of <(T>)>)(IEnumerable<(Of <(T>)>)) | Initializes a new instance of the Set<(Of <(T>)>) class.
 | Add(T) | Adds the specified value to the set.
 | AddRange(IEnumerable<(Of <(T>)>)) | Adds a range of values to the set.
 | AddRange(array<T>[]()[]) | Initializes a new instance of the Set<(Of <(T>)>) class.
 | AddRange(IEnumerable<(Of <(T>)>), Func<(Of <(T, T>)>)) | Adds a range of values, converting each value before adding it.
 | Clear()()() | Removes all members of the set.
 | Contains(T) | Checks if the specified value is contained in the set.
 | Count | Gets the count.
 | Create(array<T>[]()[]) | Creates a set containing the specified values.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Gets the enumerator.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the specified value.
 | SyncRoot | Gets the sync root.
 | ToArray()()() | Converts the members to an array.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Set<(Of <(T>)>)


Set(T) Constructor

Set<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► Set<(Of <(T>)>)()()()
Members
Icon | Member | Description
 | Set<(Of <(T>)>)()()() | Initializes a new instance of the Set<(Of <(T>)>) class.
 | Set<(Of <(T>)>)(IEqualityComparer) | Initializes a new instance of the Set<(Of <(T>)>) class.
 | Set<(Of <(T>)>)(IEnumerable<(Of <(T>)>)) | Initializes a new instance of the Set<(Of <(T>)>) class.


Set(T) Constructor

Set<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► Set<(Of <(T>)>)()()()
Initializes a new instance of the Set<(Of <(T>)>) class.
Declaration Syntax
C#
public Set()


Set(T) Constructor (enumerable)

Set<(Of <(T>)>) Constructor (enumerable)
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► Set<(Of <(T>)>)(IEnumerable<(Of <(T>)>))
Initializes a new instance of the Set<(Of <(T>)>) class.
Declaration Syntax
C#
public Set(
    IEnumerable<T> enumerable
)
Parameters
enumerable (IEnumerable<(Of <( T >)>))


Set(T) Constructor (comparer)

Set<(Of <(T>)>) Constructor (comparer)
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► Set<(Of <(T>)>)(IEqualityComparer)
Initializes a new instance of the Set<(Of <(T>)>) class.
Declaration Syntax
C#
public Set(
    IEqualityComparer comparer
)
Parameters
comparer (IEqualityComparer)


Add Method (value)

Add Method (value)
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► Add(T)
Adds the specified value to the set.
Declaration Syntax
C#
public void Add(
    T value
)
Parameters
value (T)
The value.


AddRange Method

AddRange Method
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► AddRange()()()
Members
Icon | Member | Description
 | AddRange(IEnumerable<(Of <(T>)>)) | Adds a range of values to the set.
 | AddRange(array<T>[]()[]) | Initializes a new instance of the Set<(Of <(T>)>) class.
 | AddRange(IEnumerable<(Of <(T>)>), Func<(Of <(T, T>)>)) | Adds a range of values, converting each value before adding it.


AddRange Method (values)

AddRange Method (values)
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► AddRange(IEnumerable<(Of <(T>)>))
Adds a range of values to the set.
Declaration Syntax
C#
public void AddRange(
    IEnumerable<T> values
)
Parameters
values (IEnumerable<(Of <( T >)>))
The values.


AddRange Method (values, convert)

AddRange Method (values, convert)
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► AddRange(IEnumerable<(Of <(T>)>), Func<(Of <(T, T>)>))
Adds a range of values, converting each value before adding it.
Declaration Syntax
C#
public void AddRange(
    IEnumerable<T> values,
    Func<T, T> convert
)
Parameters
values (IEnumerable<(Of <( T >)>))
The values.
convert (Func<(Of <( T, T >)>))
The converter method.


AddRange Method (members)

AddRange Method (members)
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► AddRange(array<T>[]()[])
Initializes a new instance of the Set<(Of <(T>)>) class.
Declaration Syntax
C#
public void AddRange(
    params T[] members
)
Parameters
members (array< T >[]()[])


Clear Method

Clear Method
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► Clear()()()
Removes all members of the set.
Declaration Syntax
C#
public void Clear()


Contains Method (value)

Contains Method (value)
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► Contains(T)
Checks if the specified value is contained in the set.
Declaration Syntax
C#
public bool Contains(
    T value
)
Parameters
value (T)
The value.


Count Property

Count Property
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


Create Method (values)

Create Method (values)
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► Create(array<T>[]()[])
Creates a set containing the specified values.
Declaration Syntax
C#
public static Set<T> Create(
    params T[] values
)
Parameters
values (array< T >[]()[])
The values.
Return Value


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► GetEnumerator()()()
Gets the enumerator.
Declaration Syntax
C#
public IEnumerator<T> GetEnumerator()
Return Value
The enumerator.


Remove Method (value)

Remove Method (value)
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► Remove(T)
Removes the specified value.
Declaration Syntax
C#
public void Remove(
    T value
)
Parameters
value (T)
The value.


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► SyncRoot
Gets the sync root.
Declaration Syntax
C#
public Object SyncRoot { get; }
Value
The sync root.


ToArray Method

ToArray Method
Namespaces ► Sitecore.Collections ► Set<(Of <(T>)>) ► ToArray()()()
Converts the members to an array.
Declaration Syntax
C#
public T[] ToArray()
Return Value


StringDictionary Class

StringDictionary Class
Namespaces ► Sitecore.Collections ► StringDictionary
StringDictionary class
Declaration Syntax
C#
[SerializableAttribute]
public class StringDictionary : SafeDictionary<string, string>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringDictionary()()() | Initializes a new instance of the StringDictionary class.
 | StringDictionary(IEnumerable<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)) | Initializes a new instance of the StringDictionary class.
 | StringDictionary(IEqualityComparer) | Initializes a new instance of the StringDictionary class.
 | StringDictionary(SerializationInfo, StreamingContext) | Initializes a new instance of the SafeDictionary class.
 | Add(TKey, TValue) | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | AddRange(SafeDictionary<(Of <(TKey, TValue>)>)) | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Clear()()() | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Clone()()() | Clones this instance. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | ContainsKey(TKey) | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Count | Gets the number of entries in the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hashtable | Gets the internal hashtable. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Item[([(TKey])]) | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Keys | Gets the keys of the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Remove(TKey) | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | SyncRoot | Gets the object to use for locking in multi-thread scenarios. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | ToKeyArray()()() | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | ToNameValueCollection()()() | Converts the dictionary to a NameValueCollection.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToValueArray()()() | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | TryGetValue(TKey, TValue%) | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Values | Gets the values of the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
Inheritance Hierarchy
Object
 | SafeDictionary <(Of <(String, String>)>)
 |  | StringDictionary
 |  |  | AjaxScriptManager..::.StateBag
 |  |  | ChildCreator..::.SymbolStackFrame


StringDictionary Constructor

StringDictionary Constructor
Namespaces ► Sitecore.Collections ► StringDictionary ► StringDictionary()()()
Members
Icon | Member | Description
 | StringDictionary()()() | Initializes a new instance of the StringDictionary class.
 | StringDictionary(IEnumerable<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)) | Initializes a new instance of the StringDictionary class.
 | StringDictionary(IEqualityComparer) | Initializes a new instance of the StringDictionary class.
 | StringDictionary(SerializationInfo, StreamingContext) | Initializes a new instance of the SafeDictionary class.


StringDictionary Constructor

StringDictionary Constructor
Namespaces ► Sitecore.Collections ► StringDictionary ► StringDictionary()()()
Initializes a new instance of the StringDictionary class.
Declaration Syntax
C#
public StringDictionary()


StringDictionary Constructor (values)

StringDictionary Constructor (values)
Namespaces ► Sitecore.Collections ► StringDictionary ► StringDictionary(IEnumerable<(Of <(KeyValuePair<(Of <(String, String>)>)>)>))
Initializes a new instance of the StringDictionary class.
Declaration Syntax
C#
public StringDictionary(
    IEnumerable<KeyValuePair<string, string>> values
)
Parameters
values (IEnumerable<(Of <(KeyValuePair<(Of <(String, String>)>)>)>))


StringDictionary Constructor (comparer)

StringDictionary Constructor (comparer)
Namespaces ► Sitecore.Collections ► StringDictionary ► StringDictionary(IEqualityComparer)
Initializes a new instance of the StringDictionary class.
Declaration Syntax
C#
public StringDictionary(
    IEqualityComparer comparer
)
Parameters
comparer (IEqualityComparer)


StringDictionary Constructor (info, context)

StringDictionary Constructor (info, context)
Namespaces ► Sitecore.Collections ► StringDictionary ► StringDictionary(SerializationInfo, StreamingContext)
Initializes a new instance of the SafeDictionary class.
Declaration Syntax
C#
protected StringDictionary(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo object containing the information required to serialize the Dictionary<(Of <(TKey, TValue>)>).
context (StreamingContext)
A StreamingContext structure containing the source and destination of the serialized stream associated with the Dictionary<(Of <(TKey, TValue>)>).


ToNameValueCollection Method

ToNameValueCollection Method
Namespaces ► Sitecore.Collections ► StringDictionary ► ToNameValueCollection()()()
Converts the dictionary to a NameValueCollection.
Declaration Syntax
C#
public NameValueCollection ToNameValueCollection()
Return Value


StringHashtable Class

StringHashtable Class
Namespaces ► Sitecore.Collections ► StringHashtable
Maintains a Hashtable of strings.
Declaration Syntax
C#
public class StringHashtable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringHashtable()()() | Initializes a new instance of the StringHashtable class
 | Add(String, String) | Adds a string to the table.
 | Add(StringHashtable) | Adds a StringHashtable to the table.
 | Count | Gets the number of strings in the table.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets or sets a string by its key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Examples
CopyC#
StringHashtable table = new StringHashtable();
table["myKey"] = "Hello world";
int count = table.Count; // 1
string myValue = table["myKey"]; // "Hello world"
Inheritance Hierarchy
Object
StringHashtable


StringHashtable Constructor

StringHashtable Constructor
Namespaces ► Sitecore.Collections ► StringHashtable ► StringHashtable()()()
Initializes a new instance of the StringHashtable class
Declaration Syntax
C#
public StringHashtable()


Add Method

Add Method
Namespaces ► Sitecore.Collections ► StringHashtable ► Add()()()
Members
Icon | Member | Description
 | Add(String, String) | Adds a string to the table.
 | Add(StringHashtable) | Adds a StringHashtable to the table.


Add Method (hash)

Add Method (hash)
Namespaces ► Sitecore.Collections ► StringHashtable ► Add(StringHashtable)
Adds a StringHashtable to the table.
Declaration Syntax
C#
public void Add(
    StringHashtable hash
)
Parameters
hash (StringHashtable)
A StringHashtable.
Remarks
Each key/value pair is added to the table. If the tables contain values with the same key, an exception is thrown.
Examples
CopyC#
StringHashtable table1 = new StringHashtable();
table1.Add("myKey", "Hello world");
StringHashtable table2 = new StringHashtable();
table2.Add(table1);


Add Method (sKey, sValue)

Add Method (sKey, sValue)
Namespaces ► Sitecore.Collections ► StringHashtable ► Add(String, String)
Adds a string to the table.
Declaration Syntax
C#
public void Add(
    string sKey,
    string sValue
)
Parameters
sKey (String)
The key of the string.
sValue (String)
A string.
Examples
CopyC#
StringHashtable table = new StringHashtable();
table.Add("myKey", "Hello world");


Count Property

Count Property
Namespaces ► Sitecore.Collections ► StringHashtable ► Count
Gets the number of strings in the table.
Declaration Syntax
C#
public int Count { get; }
Value
The number of strings in the table.
Examples
CopyC#
StringHashtable table = new StringHashtable();
table["myKey"] = "Hello world";
int count = table.Count; // 1


Item Property (sKey)

Item Property (sKey)
Namespaces ► Sitecore.Collections ► StringHashtable ► Item[([(String])])
Gets or sets a string by its key.
Declaration Syntax
C#
public string this[
    string sKey
] { get; set; }
Parameters
sKey (String)
Value
The string identified by the key.
Remarks
Any null values are converted to blanks.
Examples
CopyC#
StringHashtable table = new StringHashtable();
table["myKey"] = "Hello world";


StringList Class

StringList Class
Namespaces ► Sitecore.Collections ► StringList
StringList class
Declaration Syntax
C#
public class StringList : List<string>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringList()()() | Initializes a new instance of the StringList class.
 | StringList(String) | Initializes a new instance of the StringList class.
 | StringList(IEnumerable<(Of <(String>)>)) | Initializes a new instance of the StringList class.
 | Add(T) | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | AddRange(IEnumerable<(Of <(T>)>)) | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | AppendToFile(String) | Appends the list to a file.
 | AsReadOnly()()() | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List<(Of <(String>)>).)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <(String>)>).)
 | BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List<(Of <(String>)>).)
 | BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <(String>)>).)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <(String>)>).)
 | Clear()()() | Removes all elements from the List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | Contains(T) | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | ConvertAll<(Of <(TOutput>)>)(Converter<(Of <(T, TOutput>)>)) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List<(Of <(String>)>).)
 | CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List<(Of <(String>)>).)
 | CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <(String>)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <(String>)>).)
 | Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | Empty | Gets the empty.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <(T>)>)) | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(String>)>).)
 | ExtractDictionary(String, String) | Extracts a dictionary.
 | ExtractRecord(String) | Extracts a single record.
 | ExtractSection(String) | Extracts a section from a record.
 | ExtractSingleValue(String) | Extracts a single value from a record.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | FindAll(Predicate<(Of <(T>)>)) | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(String>)>).)
 | FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <(String>)>).)
 | FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <(String>)>).)
 | FindLast(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <(String>)>).)
 | FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <(String>)>).)
 | ForEach(Action<(Of <(T>)>)) | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | FromFile(String) | Instantiate a list from a file.
 | GetEnumerator()()() | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(String, StringComparison) | Get the index of a specific value.
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <(String>)>).)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <(String>)>).)
 | Insert(Int32, T) | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <(String>)>).)
 | InsertRange(Int32, IEnumerable<(Of <(T>)>)) | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <(String>)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from List<(Of <(String>)>).)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <(String>)>).)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <(String>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadFromFile(String) | Reads the list from a file.
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | RemoveAll(Predicate<(Of <(T>)>)) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(String>)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List<(Of <(String>)>).)
 | Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List<(Of <(String>)>).)
 | Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <(String>)>).)
 | Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <(String>)>).)
 | Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List<(Of <(String>)>).)
 | ToArray()()() | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List<(Of <(String>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | TrimExcess()()() | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List<(Of <(String>)>).)
 | TrueForAll(Predicate<(Of <(T>)>)) | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List<(Of <(String>)>).)
 | WriteToFile(String) | Writes the list to a file.
Inheritance Hierarchy
Object
 | List<(Of <(String>)>)
 |  | StringList


StringList Constructor

StringList Constructor
Namespaces ► Sitecore.Collections ► StringList ► StringList()()()
Members
Icon | Member | Description
 | StringList()()() | Initializes a new instance of the StringList class.
 | StringList(String) | Initializes a new instance of the StringList class.
 | StringList(IEnumerable<(Of <(String>)>)) | Initializes a new instance of the StringList class.


StringList Constructor

StringList Constructor
Namespaces ► Sitecore.Collections ► StringList ► StringList()()()
Initializes a new instance of the StringList class.
Declaration Syntax
C#
public StringList()


StringList Constructor (values)

StringList Constructor (values)
Namespaces ► Sitecore.Collections ► StringList ► StringList(IEnumerable<(Of <(String>)>))
Initializes a new instance of the StringList class.
Declaration Syntax
C#
public StringList(
    IEnumerable<string> values
)
Parameters
values (IEnumerable<(Of <(String>)>))
The values.


StringList Constructor (value)

StringList Constructor (value)
Namespaces ► Sitecore.Collections ► StringList ► StringList(String)
Initializes a new instance of the StringList class.
Declaration Syntax
C#
public StringList(
    string value
)
Parameters
value (String)
A value to add.


AppendToFile Method (filePath)

AppendToFile Method (filePath)
Namespaces ► Sitecore.Collections ► StringList ► AppendToFile(String)
Appends the list to a file.
Declaration Syntax
C#
public void AppendToFile(
    string filePath
)
Parameters
filePath (String)
The file path.


Empty Property

Empty Property
Namespaces ► Sitecore.Collections ► StringList ► Empty
Gets the empty.
Declaration Syntax
C#
public static StringList Empty { get; }
Value
The empty.


ExtractDictionary Method (sectionName, separator)

ExtractDictionary Method (sectionName, separator)
Namespaces ► Sitecore.Collections ► StringList ► ExtractDictionary(String, String)
Extracts a dictionary.
Declaration Syntax
C#
public StringDictionary ExtractDictionary(
    string sectionName,
    string separator
)
Parameters
sectionName (String)
Name of the section.
separator (String)
The key/value separator.
Return Value


ExtractRecord Method (key)

ExtractRecord Method (key)
Namespaces ► Sitecore.Collections ► StringList ► ExtractRecord(String)
Extracts a single record.
Declaration Syntax
C#
public StringList ExtractRecord(
    string key
)
Parameters
key (String)
The key.
Return Value


ExtractSection Method (name)

ExtractSection Method (name)
Namespaces ► Sitecore.Collections ► StringList ► ExtractSection(String)
Extracts a section from a record.
Declaration Syntax
C#
public StringList ExtractSection(
    string name
)
Parameters
name (String)
The name.
Return Value


ExtractSingleValue Method (sectionName)

ExtractSingleValue Method (sectionName)
Namespaces ► Sitecore.Collections ► StringList ► ExtractSingleValue(String)
Extracts a single value from a record.
Declaration Syntax
C#
public string ExtractSingleValue(
    string sectionName
)
Parameters
sectionName (String)
Name of the section.
Return Value


FromFile Method (fileName)

FromFile Method (fileName)
Namespaces ► Sitecore.Collections ► StringList ► FromFile(String)
Instantiate a list from a file.
Declaration Syntax
C#
public static StringList FromFile(
    string fileName
)
Parameters
fileName (String)
Name of the file.
Return Value


IndexOf Method (value, comparison)

IndexOf Method (value, comparison)
Namespaces ► Sitecore.Collections ► StringList ► IndexOf(String, StringComparison)
Get the index of a specific value.
Declaration Syntax
C#
public int IndexOf(
    string value,
    StringComparison comparison
)
Parameters
value (String)
The value.
comparison (StringComparison)
The comparison.
Return Value


ReadFromFile Method (filePath)

ReadFromFile Method (filePath)
Namespaces ► Sitecore.Collections ► StringList ► ReadFromFile(String)
Reads the list from a file.
Declaration Syntax
C#
public void ReadFromFile(
    string filePath
)
Parameters
filePath (String)
The file path.


ToString Method

ToString Method
Namespaces ► Sitecore.Collections ► StringList ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


WriteToFile Method (filePath)

WriteToFile Method (filePath)
Namespaces ► Sitecore.Collections ► StringList ► WriteToFile(String)
Writes the list to a file.
Declaration Syntax
C#
public void WriteToFile(
    string filePath
)
Parameters
filePath (String)
The file path.


TemplateDictionary Class

TemplateDictionary Class
Namespaces ► Sitecore.Collections ► TemplateDictionary
Dictionary holding a list of templates indexed by template id.
Declaration Syntax
C#
[SerializableAttribute]
public class TemplateDictionary : SafeDictionary<ID, Template>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateDictionary(IEqualityComparer) | Initializes a new instance of the TemplateDictionary class.
 | TemplateDictionary()()() | Initializes a new instance of the TemplateDictionary class.
 | TemplateDictionary(SerializationInfo, StreamingContext) | Initializes a new instance of the TemplateDictionary class.
 | Add(TKey, TValue) | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | AddRange(SafeDictionary<(Of <(TKey, TValue>)>)) | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Clear()()() | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Clone()()() | Creates a shallow copy of the collection.
 | ContainsKey(TKey) | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | CopyTo(array<Template>[]()[], Int32) | Copies the templates to an array.
 | Count | Gets the number of entries in the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hashtable | Gets the internal hashtable. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Item[([(String])]) | Gets the Template with the specified full name.
 | Item[([(TKey])]) | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Keys | Gets the keys of the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Remove(TKey) | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | SyncRoot | Gets the object to use for locking in multi-thread scenarios. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | ToKeyArray()()() | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToValueArray()()() | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | TryGetValue(TKey, TValue%) | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
 | Values | Gets the values of the dictionary. (Inherited from SafeDictionary<(Of <(TKey, TValue>)>).)
Inheritance Hierarchy
Object
 | SafeDictionary <(Of <( ID, Template >)>)
 |  | TemplateDictionary


TemplateDictionary Constructor

TemplateDictionary Constructor
Namespaces ► Sitecore.Collections ► TemplateDictionary ► TemplateDictionary()()()
Members
Icon | Member | Description
 | TemplateDictionary(IEqualityComparer) | Initializes a new instance of the TemplateDictionary class.
 | TemplateDictionary()()() | Initializes a new instance of the TemplateDictionary class.
 | TemplateDictionary(SerializationInfo, StreamingContext) | Initializes a new instance of the TemplateDictionary class.


TemplateDictionary Constructor

TemplateDictionary Constructor
Namespaces ► Sitecore.Collections ► TemplateDictionary ► TemplateDictionary()()()
Initializes a new instance of the TemplateDictionary class.
Declaration Syntax
C#
public TemplateDictionary()


TemplateDictionary Constructor (comparer)

TemplateDictionary Constructor (comparer)
Namespaces ► Sitecore.Collections ► TemplateDictionary ► TemplateDictionary(IEqualityComparer)
Initializes a new instance of the TemplateDictionary class.
Declaration Syntax
C#
public TemplateDictionary(
    IEqualityComparer comparer
)
Parameters
comparer (IEqualityComparer)
The comparer.


TemplateDictionary Constructor (info, context)

TemplateDictionary Constructor (info, context)
Namespaces ► Sitecore.Collections ► TemplateDictionary ► TemplateDictionary(SerializationInfo, StreamingContext)
Initializes a new instance of the TemplateDictionary class.
Declaration Syntax
C#
protected TemplateDictionary(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Clone Method

Clone Method
Namespaces ► Sitecore.Collections ► TemplateDictionary ► Clone()()()
Creates a shallow copy of the collection.
Declaration Syntax
C#
public TemplateDictionary Clone()
Return Value


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces ► Sitecore.Collections ► TemplateDictionary ► CopyTo(array<Template>[]()[], Int32)
Copies the templates to an array.
Declaration Syntax
C#
public void CopyTo(
    Template[] array,
    int index
)
Parameters
array (array< Template >[]()[])
The array.
index (Int32)
The target index.


Item Property (fullName)

Item Property (fullName)
Namespaces ► Sitecore.Collections ► TemplateDictionary ► Item[([(String])])
Gets the Template with the specified full name.
Declaration Syntax
C#
public virtual Template this[
    string fullName
] { get; }
Parameters
fullName (String)
Value


VersionCollection Class

VersionCollection Class
Namespaces ► Sitecore.Collections ► VersionCollection
Collection class for holding Version.
Declaration Syntax
C#
public class VersionCollection : List<Version>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VersionCollection()()() | Initializes a new instance of the VersionCollection class
 | Add(T) | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | AddRange(IEnumerable<(Of <(T>)>)) | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | AsReadOnly()()() | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List<(Of <( Version >)>).)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( Version >)>).)
 | BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List<(Of <( Version >)>).)
 | BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( Version >)>).)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <( Version >)>).)
 | Clear()()() | Removes all elements from the List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | Contains(T) | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | ConvertAll<(Of <(TOutput>)>)(Converter<(Of <(T, TOutput>)>)) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List<(Of <( Version >)>).)
 | CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List<(Of <( Version >)>).)
 | CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( Version >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( Version >)>).)
 | Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <(T>)>)) | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( Version >)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | FindAll(Predicate<(Of <(T>)>)) | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( Version >)>).)
 | FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( Version >)>).)
 | FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( Version >)>).)
 | FindLast(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( Version >)>).)
 | FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( Version >)>).)
 | ForEach(Action<(Of <(T>)>)) | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( Version >)>).)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( Version >)>).)
 | Insert(Int32, T) | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( Version >)>).)
 | InsertRange(Int32, IEnumerable<(Of <(T>)>)) | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( Version >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from List<(Of <( Version >)>).)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( Version >)>).)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( Version >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | RemoveAll(Predicate<(Of <(T>)>)) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( Version >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List<(Of <( Version >)>).)
 | Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List<(Of <( Version >)>).)
 | Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( Version >)>).)
 | Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( Version >)>).)
 | Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List<(Of <( Version >)>).)
 | ToArray()()() | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List<(Of <( Version >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()()() | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List<(Of <( Version >)>).)
 | TrueForAll(Predicate<(Of <(T>)>)) | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List<(Of <( Version >)>).)
Inheritance Hierarchy
Object
 | List<(Of <( Version >)>)
 |  | VersionCollection


VersionCollection Constructor

VersionCollection Constructor
Namespaces ► Sitecore.Collections ► VersionCollection ► VersionCollection()()()
Initializes a new instance of the VersionCollection class
Declaration Syntax
C#
public VersionCollection()


VersionList Class

VersionList Class
Namespaces ► Sitecore.Collections ► VersionList
Represents a list of versions.
Declaration Syntax
C#
public class VersionList : IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VersionList()()() | Initializes a new instance of the VersionList class
 | Add(Version) | Adds the specified version.
 | Add(VersionList, VersionList) | Adds the specified list1.
 | Build(array<Version>[]()[]) | Builds the specified versions.
 | Contains(Version) | Determines whether [contains] [the specified version].
 | Count | Gets the count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the Version at the specified index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(Version) | Removes the specified version.
 | Sort()()() | Sorts this instance.
 | SyncRoot | Gets the sync root.
 | ToArray()()() | Converts the VersionList to an array.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
VersionList


VersionList Constructor

VersionList Constructor
Namespaces ► Sitecore.Collections ► VersionList ► VersionList()()()
Initializes a new instance of the VersionList class
Declaration Syntax
C#
public VersionList()


Add Method

Add Method
Namespaces ► Sitecore.Collections ► VersionList ► Add()()()
Members
Icon | Member | Description
 | Add(Version) | Adds the specified version.
 | Add(VersionList, VersionList) | Adds the specified list1.


Add Method (list1, list2)

Add Method (list1, list2)
Namespaces ► Sitecore.Collections ► VersionList ► Add(VersionList, VersionList)
Adds the specified list1.
Declaration Syntax
C#
public static VersionList Add(
    VersionList list1,
    VersionList list2
)
Parameters
list1 (VersionList)
The list1.
list2 (VersionList)
The list2.
Return Value
The VersionList.


Add Method (version)

Add Method (version)
Namespaces ► Sitecore.Collections ► VersionList ► Add(Version)
Adds the specified version.
Declaration Syntax
C#
public void Add(
    Version version
)
Parameters
version (Version)
The version.


Build Method (versions)

Build Method (versions)
Namespaces ► Sitecore.Collections ► VersionList ► Build(array<Version>[]()[])
Builds the specified versions.
Declaration Syntax
C#
public static VersionList Build(
    params Version[] versions
)
Parameters
versions (array< Version >[]()[])
The versions.
Return Value
The VersionList.


Contains Method (version)

Contains Method (version)
Namespaces ► Sitecore.Collections ► VersionList ► Contains(Version)
Determines whether [contains] [the specified version].
Declaration Syntax
C#
public bool Contains(
    Version version
)
Parameters
version (Version)
The version.
Return Value
true if [contains] [the specified version]; otherwise, false.


Count Property

Count Property
Namespaces ► Sitecore.Collections ► VersionList ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Collections ► VersionList ► GetEnumerator()()()
Returns an enumerator that iterates through a collection.
Declaration Syntax
C#
public IEnumerator GetEnumerator()
Return Value
An IEnumerator object that can be used to iterate through the collection.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Collections ► VersionList ► Item[([(Int32])])
Gets the Version at the specified index.
Declaration Syntax
C#
public Version this[
    int index
] { get; }
Parameters
index (Int32)
Value
The Version.


Remove Method (version)

Remove Method (version)
Namespaces ► Sitecore.Collections ► VersionList ► Remove(Version)
Removes the specified version.
Declaration Syntax
C#
public void Remove(
    Version version
)
Parameters
version (Version)
The version.


Sort Method

Sort Method
Namespaces ► Sitecore.Collections ► VersionList ► Sort()()()
Sorts this instance.
Declaration Syntax
C#
public void Sort()


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Collections ► VersionList ► SyncRoot
Gets the sync root.
Declaration Syntax
C#
public Object SyncRoot { get; }
Value
The sync root object.


ToArray Method

ToArray Method
Namespaces ► Sitecore.Collections ► VersionList ► ToArray()()()
Converts the VersionList to an array.
Declaration Syntax
C#
public Array ToArray()
Return Value
The VersionList as an array.


VersionUriList Class

VersionUriList Class
Namespaces ► Sitecore.Collections ► VersionUriList
VersionList
Declaration Syntax
C#
public class VersionUriList : IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VersionUriList()()() | Initializes a new instance of the VersionUriList class
 | Add(VersionUri) | Adds the specified URI.
 | Add(Language, Version) | Adds the specified language.
 | Add(Language, VersionList) | Adds the specified language.
 | Add(VersionUriList, VersionUriList) | Adds the specified list1.
 | Count | Gets the count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataLength()()() | Gets the size of the data to use when caching.
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the VersionUri at the specified index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
VersionUriList


VersionUriList Constructor

VersionUriList Constructor
Namespaces ► Sitecore.Collections ► VersionUriList ► VersionUriList()()()
Initializes a new instance of the VersionUriList class
Declaration Syntax
C#
public VersionUriList()


Add Method

Add Method
Namespaces ► Sitecore.Collections ► VersionUriList ► Add()()()
Members
Icon | Member | Description
 | Add(VersionUri) | Adds the specified URI.
 | Add(Language, Version) | Adds the specified language.
 | Add(Language, VersionList) | Adds the specified language.
 | Add(VersionUriList, VersionUriList) | Adds the specified list1.


Add Method (list1, list2)

Add Method (list1, list2)
Namespaces ► Sitecore.Collections ► VersionUriList ► Add(VersionUriList, VersionUriList)
Adds the specified list1.
Declaration Syntax
C#
public static VersionUriList Add(
    VersionUriList list1,
    VersionUriList list2
)
Parameters
list1 (VersionUriList)
The list1.
list2 (VersionUriList)
The list2.
Return Value
The VersionUriList.


Add Method (uri)

Add Method (uri)
Namespaces ► Sitecore.Collections ► VersionUriList ► Add(VersionUri)
Adds the specified URI.
Declaration Syntax
C#
public void Add(
    VersionUri uri
)
Parameters
uri (VersionUri)
The URI.


Add Method (language, versions)

Add Method (language, versions)
Namespaces ► Sitecore.Collections ► VersionUriList ► Add(Language, VersionList)
Adds the specified language.
Declaration Syntax
C#
public void Add(
    Language language,
    VersionList versions
)
Parameters
language (Language)
The language.
versions (VersionList)
The versions.


Add Method (language, version)

Add Method (language, version)
Namespaces ► Sitecore.Collections ► VersionUriList ► Add(Language, Version)
Adds the specified language.
Declaration Syntax
C#
public void Add(
    Language language,
    Version version
)
Parameters
language (Language)
The language.
version (Version)
The version.


Count Property

Count Property
Namespaces ► Sitecore.Collections ► VersionUriList ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


GetDataLength Method

GetDataLength Method
Namespaces ► Sitecore.Collections ► VersionUriList ► GetDataLength()()()
Gets the size of the data to use when caching.
Declaration Syntax
C#
public long GetDataLength()
Return Value


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Collections ► VersionUriList ► GetEnumerator()()()
Returns an enumerator that iterates through a collection.
Declaration Syntax
C#
public IEnumerator GetEnumerator()
Return Value
An IEnumerator object that can be used to iterate through the collection.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Collections ► VersionUriList ► Item[([(Int32])])
Gets the VersionUri at the specified index.
Declaration Syntax
C#
public VersionUri this[
    int index
] { get; }
Parameters
index (Int32)
Value
The VersionUri.


Sitecore.Common Namespace

Sitecore.Common Namespace
Namespaces ► Sitecore.Common
Declaration Syntax
C#
namespace Sitecore.Common
Types
All Types Classes Interfaces Delegates
Icon | Type | Description
 | CallContext | AuthorizationCallContext class
 | CallContextSwitcher | AuthorizationCallContextSwitcher class
 | DateTimeExtensions | Extension methods for the DateTime class.
 | DateTimeRange | Class representing a range between to dates and times.
 | ElementCounter | ElementCounter
 | Enumerable<(Of <(TElement>)>) | UserEnumerable
 | Enumerator<(Of <(TElement>)>) | Enumerator class
 | Filterable<(Of <(TElement>)>) | Filterable class
 | PagingHelper<(Of <(TInput, TOutput>)>)..::.GetElements | GetElements delegate
 | PagingIterator<(Of <(T>)>)..::.GetPage |
 | ICommand<(Of <(TReturnType>)>) | Interface for a command object.
 | IFilterable<(Of <(TElement>)>) | IFilterable interface
 | IPageable<(Of <(TElement>)>) | IPageableData interface
 | IPrototype<(Of <(TObjectType>)>) | Interface for a prototype object.
 | Pageable<(Of <(TElement>)>) | Pageable class
 | PageableList<(Of <(TElement>)>) | ListPageableData class
 | PagingHelper<(Of <(TInput, TOutput>)>) | PagingHelper class
 | PagingIterator<(Of <(T>)>) |
 | SettingsPropertyCollectionExtensions | Extension methods for the SettingsPropertyCollection class.
 | Switcher<(Of <(TValue, TSwitchType>)>) | Switcher class
 | Switcher<(Of <(T>)>) | Swither class
 | Timeline | Timeline class


CallContext Class

CallContext Class
Namespaces ► Sitecore.Common ► CallContext
AuthorizationCallContext class
Declaration Syntax
C#
public class CallContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CallContext()()() | Initializes a new instance of the CallContext class
 | Aborted | Gets or sets a value indicating whether the call chain has been aborted.
 | Current | Gets the current call context.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotSupported | Gets or sets a value indicating whether the operation is supported by the called method.
 | Reset()()() | Resets this instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CallContext


CallContext Constructor

CallContext Constructor
Namespaces ► Sitecore.Common ► CallContext ► CallContext()()()
Initializes a new instance of the CallContext class
Declaration Syntax
C#
public CallContext()


Aborted Property

Aborted Property
Namespaces ► Sitecore.Common ► CallContext ► Aborted
Gets or sets a value indicating whether the call chain has been aborted.
Declaration Syntax
C#
public bool Aborted { get; set; }
Value
true if aborted; otherwise, false.


Current Property

Current Property
Namespaces ► Sitecore.Common ► CallContext ► Current
Gets the current call context.
Declaration Syntax
C#
public static CallContext Current { get; }
Value
The current.


NotSupported Property

NotSupported Property
Namespaces ► Sitecore.Common ► CallContext ► NotSupported
Gets or sets a value indicating whether the operation is supported by the called method.
Declaration Syntax
C#
public bool NotSupported { get; set; }
Value
true if the called method is not supported by the implementation; otherwise, false.


Reset Method

Reset Method
Namespaces ► Sitecore.Common ► CallContext ► Reset()()()
Resets this instance.
Declaration Syntax
C#
public void Reset()


CallContextSwitcher Class

CallContextSwitcher Class
Namespaces ► Sitecore.Common ► CallContextSwitcher
AuthorizationCallContextSwitcher class
Declaration Syntax
C#
public class CallContextSwitcher : Switcher<CallContext, CallContextSwitcher>
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CallContextSwitcher()()() | Initializes a new instance of the CallContextSwitcher class.
 | CallContextSwitcher(CallContext) | Initializes a new instance of the CallContextSwitcher class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <( CallContext, CallContextSwitcher>)>)
 |  | CallContextSwitcher


CallContextSwitcher Constructor

CallContextSwitcher Constructor
Namespaces ► Sitecore.Common ► CallContextSwitcher ► CallContextSwitcher()()()
Members
Icon | Member | Description
 | CallContextSwitcher()()() | Initializes a new instance of the CallContextSwitcher class.
 | CallContextSwitcher(CallContext) | Initializes a new instance of the CallContextSwitcher class.


CallContextSwitcher Constructor

CallContextSwitcher Constructor
Namespaces ► Sitecore.Common ► CallContextSwitcher ► CallContextSwitcher()()()
Initializes a new instance of the CallContextSwitcher class.
Declaration Syntax
C#
public CallContextSwitcher()


CallContextSwitcher Constructor (context)

CallContextSwitcher Constructor (context)
Namespaces ► Sitecore.Common ► CallContextSwitcher ► CallContextSwitcher(CallContext)
Initializes a new instance of the CallContextSwitcher class.
Declaration Syntax
C#
public CallContextSwitcher(
    CallContext context
)
Parameters
context (CallContext)


DateTimeExtensions Class

DateTimeExtensions Class
Namespaces ► Sitecore.Common ► DateTimeExtensions
Extension methods for the DateTime class.
Declaration Syntax
C#
public static class DateTimeExtensions
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InRange(DateTime, DateTime, DateTime) | Determines if a DateTime is within the specified range (inclusive).
 | InRange(DateTime, Pair<(Of <(DateTime, DateTime>)>)) | Determines if a DateTime is within the specified range (inclusive).
Inheritance Hierarchy
Object
DateTimeExtensions


InRange Method

InRange Method
Namespaces ► Sitecore.Common ► DateTimeExtensions ► InRange()()()
Members
Icon | Member | Description
 | InRange(DateTime, DateTime, DateTime) | Determines if a DateTime is within the specified range (inclusive).
 | InRange(DateTime, Pair<(Of <(DateTime, DateTime>)>)) | Determines if a DateTime is within the specified range (inclusive).


InRange Method (date, range)

InRange Method (date, range)
Namespaces ► Sitecore.Common ► DateTimeExtensions ► InRange(DateTime, Pair<(Of <(DateTime, DateTime>)>))
Determines if a DateTime is within the specified range (inclusive).
Declaration Syntax
C#
public static bool InRange(
    DateTime date,
    Pair<DateTime, DateTime> range
)
Parameters
date (DateTime)
range (Pair <(Of <(DateTime, DateTime>)>))
Return Value


InRange Method (date, from, to)

InRange Method (date, from, to)
Namespaces ► Sitecore.Common ► DateTimeExtensions ► InRange(DateTime, DateTime, DateTime)
Determines if a DateTime is within the specified range (inclusive).
Declaration Syntax
C#
public static bool InRange(
    DateTime date,
    DateTime from,
    DateTime to
)
Parameters
date (DateTime)
from (DateTime)
to (DateTime)
Return Value


DateTimeRange Class

DateTimeRange Class
Namespaces ► Sitecore.Common ► DateTimeRange
Class representing a range between to dates and times.
Declaration Syntax
C#
public class DateTimeRange
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DateTimeRange(DateTime, DateTime) | Initializes a new instance of the DateTimeRange class.
 | Contains(DateTime) | Determines whether the range contains the specified date time.
 | Empty | Gets the empty range.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | From | Gets the 'from' date.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | To | Gets the 'to' date.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DateTimeRange


DateTimeRange Constructor (from, to)

DateTimeRange Constructor (from, to)
Namespaces ► Sitecore.Common ► DateTimeRange ► DateTimeRange(DateTime, DateTime)
Initializes a new instance of the DateTimeRange class.
Declaration Syntax
C#
public DateTimeRange(
    DateTime from,
    DateTime to
)
Parameters
from (DateTime)
From.
to (DateTime)
To.


Contains Method (dateTime)

Contains Method (dateTime)
Namespaces ► Sitecore.Common ► DateTimeRange ► Contains(DateTime)
Determines whether the range contains the specified date time.
Declaration Syntax
C#
public bool Contains(
    DateTime dateTime
)
Parameters
dateTime (DateTime)
The date time.
Return Value
true if it contains the specified date time; otherwise, false.


Empty Property

Empty Property
Namespaces ► Sitecore.Common ► DateTimeRange ► Empty
Gets the empty range.
Declaration Syntax
C#
public static DateTimeRange Empty { get; }
Value
The empty range.


From Property

From Property
Namespaces ► Sitecore.Common ► DateTimeRange ► From
Gets the 'from' date.
Declaration Syntax
C#
public DateTime From { get; }
Value
From.


To Property

To Property
Namespaces ► Sitecore.Common ► DateTimeRange ► To
Gets the 'to' date.
Declaration Syntax
C#
public DateTime To { get; }
Value
To.


ElementCounter Class

ElementCounter Class
Namespaces ► Sitecore.Common ► ElementCounter
ElementCounter
Declaration Syntax
C#
public class ElementCounter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementCounter()()() | Initializes a new instance of the ElementCounter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the value.
Inheritance Hierarchy
Object
ElementCounter


ElementCounter Constructor

ElementCounter Constructor
Namespaces ► Sitecore.Common ► ElementCounter ► ElementCounter()()()
Initializes a new instance of the ElementCounter class
Declaration Syntax
C#
public ElementCounter()


Value Property

Value Property
Namespaces ► Sitecore.Common ► ElementCounter ► Value
Gets or sets the value.
Declaration Syntax
C#
public int Value { get; set; }
Value
The value.


Enumerable(TElement) Class

Enumerable<(Of <(TElement>)>) Class
Namespaces ► Sitecore.Common ► Enumerable<(Of <(TElement>)>)
UserEnumerable
Declaration Syntax
C#
public class Enumerable<TElement> : IEnumerable<T>,
    IEnumerable
Generic Template Parameters
TElement
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Enumerable<(Of <(TElement>)>)(Func<(Of <(IEnumerable>)>), Func<(Of <(Object, TElement>)>)) | Initializes a new instance of the Enumerable<(Of <(TElement>)>) class.
 | Enumerable<(Of <(TElement>)>)(Func<(Of <(IEnumerator>)>), Func<(Of <(Object, TElement>)>)) | Initializes a new instance of the Enumerable<(Of <(TElement>)>) class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Enumerable<(Of <(TElement>)>)


Enumerable(TElement) Constructor

Enumerable<(Of <(TElement>)>) Constructor
Namespaces ► Sitecore.Common ► Enumerable<(Of <(TElement>)>) ► Enumerable<(Of <(TElement>)>)()()()
Members
Icon | Member | Description
 | Enumerable<(Of <(TElement>)>)(Func<(Of <(IEnumerable>)>), Func<(Of <(Object, TElement>)>)) | Initializes a new instance of the Enumerable<(Of <(TElement>)>) class.
 | Enumerable<(Of <(TElement>)>)(Func<(Of <(IEnumerator>)>), Func<(Of <(Object, TElement>)>)) | Initializes a new instance of the Enumerable<(Of <(TElement>)>) class.


Enumerable(TElement) Constructor (getEnumerable, mapElement)

Enumerable<(Of <(TElement>)>) Constructor (getEnumerable, mapElement)
Namespaces ► Sitecore.Common ► Enumerable<(Of <(TElement>)>) ► Enumerable<(Of <(TElement>)>)(Func<(Of <(IEnumerable>)>), Func<(Of <(Object, TElement>)>))
Initializes a new instance of the Enumerable<(Of <(TElement>)>) class.
Declaration Syntax
C#
public Enumerable(
    Func<IEnumerable> getEnumerable,
    Func<Object, TElement> mapElement
)
Parameters
getEnumerable (Func<(Of <(IEnumerable>)>))
The get enumerable function.
mapElement (Func<(Of <(Object, TElement >)>))
The map element function.


Enumerable(TElement) Constructor (getEnumerator, mapElement)

Enumerable<(Of <(TElement>)>) Constructor (getEnumerator, mapElement)
Namespaces ► Sitecore.Common ► Enumerable<(Of <(TElement>)>) ► Enumerable<(Of <(TElement>)>)(Func<(Of <(IEnumerator>)>), Func<(Of <(Object, TElement>)>))
Initializes a new instance of the Enumerable<(Of <(TElement>)>) class.
Declaration Syntax
C#
public Enumerable(
    Func<IEnumerator> getEnumerator,
    Func<Object, TElement> mapElement
)
Parameters
getEnumerator (Func<(Of <(IEnumerator>)>))
The get enumerator.
mapElement (Func<(Of <(Object, TElement >)>))
The map element.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Common ► Enumerable<(Of <(TElement>)>) ► GetEnumerator()()()
Returns an enumerator that iterates through the collection.
Declaration Syntax
C#
public IEnumerator<TElement> GetEnumerator()
Return Value
A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.


Enumerator(TElement) Class

Enumerator<(Of <(TElement>)>) Class
Namespaces ► Sitecore.Common ► Enumerator<(Of <(TElement>)>)
Enumerator class
Declaration Syntax
C#
public class Enumerator<TElement> : IEnumerator<TElement>,
    IDisposable, IEnumerator
Generic Template Parameters
TElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Enumerator<(Of <(TElement>)>)(Func<(Of <(IEnumerator>)>), Func<(Of <(Object, TElement>)>)) | Initializes a new instance of the Enumerator<(Of <(TElement>)>) class.
 | Current | Gets the element in the collection at the current position of the enumerator.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerEnumerator | Gets the enumerator.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveNext()()() | Advances the enumerator to the next element of the collection.
 | Reset()()() | Sets the enumerator to its initial position, which is before the first element in the collection.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Enumerator<(Of <(TElement>)>)


Enumerator(TElement) Constructor (getEnumerator, mapElement)

Enumerator<(Of <(TElement>)>) Constructor (getEnumerator, mapElement)
Namespaces ► Sitecore.Common ► Enumerator<(Of <(TElement>)>) ► Enumerator<(Of <(TElement>)>)(Func<(Of <(IEnumerator>)>), Func<(Of <(Object, TElement>)>))
Initializes a new instance of the Enumerator<(Of <(TElement>)>) class.
Declaration Syntax
C#
public Enumerator(
    Func<IEnumerator> getEnumerator,
    Func<Object, TElement> mapElement
)
Parameters
getEnumerator (Func<(Of <(IEnumerator>)>))
The get enumerator function.
mapElement (Func<(Of <(Object, TElement >)>))
The map element function.


Current Property

Current Property
Namespaces ► Sitecore.Common ► Enumerator<(Of <(TElement>)>) ► Current
Gets the element in the collection at the current position of the enumerator.
Declaration Syntax
C#
public TElement Current { get; }
Return Value
The element in the collection at the current position of the enumerator.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Common ► Enumerator<(Of <(TElement>)>) ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


InnerEnumerator Property

InnerEnumerator Property
Namespaces ► Sitecore.Common ► Enumerator<(Of <(TElement>)>) ► InnerEnumerator
Gets the enumerator.
Declaration Syntax
C#
protected IEnumerator InnerEnumerator { get; }
Value
The enumerator.


MoveNext Method

MoveNext Method
Namespaces ► Sitecore.Common ► Enumerator<(Of <(TElement>)>) ► MoveNext()()()
Advances the enumerator to the next element of the collection.
Declaration Syntax
C#
public bool MoveNext()
Return Value
true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.
Exceptions
Exception | Condition
InvalidOperationException | The collection was modified after the enumerator was created.


Reset Method

Reset Method
Namespaces ► Sitecore.Common ► Enumerator<(Of <(TElement>)>) ► Reset()()()
Sets the enumerator to its initial position, which is before the first element in the collection.
Declaration Syntax
C#
public void Reset()
Exceptions
Exception | Condition
InvalidOperationException | The collection was modified after the enumerator was created.


Filterable(TElement) Class

Filterable<(Of <(TElement>)>) Class
Namespaces ► Sitecore.Common ► Filterable<(Of <(TElement>)>)
Filterable class
Declaration Syntax
C#
public class Filterable<TElement> : Pageable<TElement>,
    IFilterable<TElement>, IPageable<TElement>, IEnumerable<T>, IEnumerable
Generic Template Parameters
TElement
The type of the element.
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Filterable<(Of <(TElement>)>)(Func<(Of <(Int32, Int32, IEnumerable<(Of <(TElement>)>)>)>), Func<(Of <(IEnumerable<(Of <(TElement>)>)>)>), Func<(Of <(Int32>)>), Func<(Of <(Int32, Int32, String, IEnumerable<(Of <(TElement>)>)>)>), Func<(Of <(String, Int32>)>)) | Initializes a new instance of the Filterable<(Of <(TElement>)>) class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAll()()() | Gets all elements. (Inherited from Pageable<(Of <(TElement>)>).)
 | GetCount(String) | Gets the number of elements matching the specified filter.
 | GetCount()()() | Gets the number of elements. (Inherited from Pageable<(Of <(TElement>)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from Pageable<(Of <(TElement>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPage(Int32, Int32, String) | Gets a page of filtered elements.
 | GetPage(Int32, Int32) | Gets a page of elements. (Inherited from Pageable<(Of <(TElement>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Pageable <(Of <(TElement>)>)
 |  | Filterable<(Of <(TElement>)>)


Filterable(TElement) Constructor (getPage, getAll, getCount, getFiltered, getFilteredCount)

Filterable<(Of <(TElement>)>) Constructor (getPage, getAll, getCount, getFiltered, getFilteredCount)
Namespaces ► Sitecore.Common ► Filterable<(Of <(TElement>)>) ► Filterable<(Of <(TElement>)>)(Func<(Of <(Int32, Int32, IEnumerable<(Of <(TElement>)>)>)>), Func<(Of <(IEnumerable<(Of <(TElement>)>)>)>), Func<(Of <(Int32>)>), Func<(Of <(Int32, Int32, String, IEnumerable<(Of <(TElement>)>)>)>), Func<(Of <(String, Int32>)>))
Initializes a new instance of the Filterable<(Of <(TElement>)>) class.
Declaration Syntax
C#
public Filterable(
    Func<int, int, IEnumerable<TElement>> getPage,
    Func<IEnumerable<TElement>> getAll,
    Func<int> getCount,
    Func<int, int, string, IEnumerable<TElement>> getFiltered,
    Func<string, int> getFilteredCount
)
Parameters
getPage (Func<(Of <(Int32, Int32, IEnumerable<(Of <( TElement >)>)>)>))
The 'get single page of elements' delegate.
getAll (Func<(Of <(IEnumerable<(Of <( TElement >)>)>)>))
The 'get all elements' delegate.
getCount (Func<(Of <(Int32>)>))
The 'get number of elements' delegate.
getFiltered (Func<(Of <(Int32, Int32, String, IEnumerable<(Of <( TElement >)>)>)>))
The 'get filtered elements' delegate.
getFilteredCount (Func<(Of <(String, Int32>)>))
The get filtered count.


GetCount Method (filter)

GetCount Method (filter)
Namespaces ► Sitecore.Common ► Filterable<(Of <(TElement>)>) ► GetCount(String)
Gets the number of elements matching the specified filter.
Declaration Syntax
C#
public int GetCount(
    string filter
)
Parameters
filter (String)
Value
The number of elements.
Return Value


GetPage Method (pageIndex, pageSize, filter)

GetPage Method (pageIndex, pageSize, filter)
Namespaces ► Sitecore.Common ► Filterable<(Of <(TElement>)>) ► GetPage(Int32, Int32, String)
Gets a page of filtered elements.
Declaration Syntax
C#
public IEnumerable<TElement> GetPage(
    int pageIndex,
    int pageSize,
    string filter
)
Parameters
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
filter (String)
The filter. This will be a simple string to match. It is up to the implementation to decide how to use this (search single/multiple column(s), use LIKE or exact matches, etc.).
Return Value


ICommand(TReturnType) Interface

ICommand<(Of <(TReturnType>)>) Interface
Namespaces ► Sitecore.Common ► ICommand<(Of <(TReturnType>)>)
Interface for a command object.
Declaration Syntax
C#
public interface ICommand<TReturnType>
Generic Template Parameters
TReturnType
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Execute()()() | Executes the command.


Execute Method

Execute Method
Namespaces ► Sitecore.Common ► ICommand<(Of <(TReturnType>)>) ► Execute()()()
Executes the command.
Declaration Syntax
C#
TReturnType Execute()
Return Value


IFilterable(TElement) Interface

IFilterable<(Of <(TElement>)>) Interface
Namespaces ► Sitecore.Common ► IFilterable<(Of <(TElement>)>)
IFilterable interface
Declaration Syntax
C#
public interface IFilterable<TElement> : IPageable<TElement>,
    IEnumerable<T>, IEnumerable
Generic Template Parameters
TElement
The type of the element.
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetAll()()() | Gets all elements. (Inherited from IPageable<(Of <(TElement>)>).)
 | GetCount(String) | Gets the number of elements matching the specified filter.
 | GetCount()()() | Gets the number of elements. (Inherited from IPageable<(Of <(TElement>)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( T >)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
 | GetPage(Int32, Int32, String) | Gets a page of filtered elements.
 | GetPage(Int32, Int32) | Gets a page of elements. (Inherited from IPageable<(Of <(TElement>)>).)


GetCount Method (filter)

GetCount Method (filter)
Namespaces ► Sitecore.Common ► IFilterable<(Of <(TElement>)>) ► GetCount(String)
Gets the number of elements matching the specified filter.
Declaration Syntax
C#
int GetCount(
    string filter
)
Parameters
filter (String)
Value
The number of elements.


GetPage Method (pageIndex, pageSize, filter)

GetPage Method (pageIndex, pageSize, filter)
Namespaces ► Sitecore.Common ► IFilterable<(Of <(TElement>)>) ► GetPage(Int32, Int32, String)
Gets a page of filtered elements.
Declaration Syntax
C#
IEnumerable<TElement> GetPage(
    int pageIndex,
    int pageSize,
    string filter
)
Parameters
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
filter (String)
The filter. This will be a simple string to match. It is up to the implementation to decide how to use this (search single/multiple column(s), use LIKE or exact matches, etc.).
Return Value


IPageable(TElement) Interface

IPageable<(Of <(TElement>)>) Interface
Namespaces ► Sitecore.Common ► IPageable<(Of <(TElement>)>)
IPageableData interface
Declaration Syntax
C#
public interface IPageable<TElement> : IEnumerable<T>,
    IEnumerable
Generic Template Parameters
TElement
The type of the element.
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetAll()()() | Gets all elements.
 | GetCount()()() | Gets the number of elements.
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <( T >)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
 | GetPage(Int32, Int32) | Gets a page of elements.


GetAll Method

GetAll Method
Namespaces ► Sitecore.Common ► IPageable<(Of <(TElement>)>) ► GetAll()()()
Gets all elements.
Declaration Syntax
C#
IEnumerable<TElement> GetAll()
Return Value


GetCount Method

GetCount Method
Namespaces ► Sitecore.Common ► IPageable<(Of <(TElement>)>) ► GetCount()()()
Gets the number of elements.
Declaration Syntax
C#
int GetCount()
Value
The number of elements.


GetPage Method (pageIndex, pageSize)

GetPage Method (pageIndex, pageSize)
Namespaces ► Sitecore.Common ► IPageable<(Of <(TElement>)>) ► GetPage(Int32, Int32)
Gets a page of elements.
Declaration Syntax
C#
IEnumerable<TElement> GetPage(
    int pageIndex,
    int pageSize
)
Parameters
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
Return Value


IPrototype(TObjectType) Interface

IPrototype<(Of <(TObjectType>)>) Interface
Namespaces ► Sitecore.Common ► IPrototype<(Of <(TObjectType>)>)
Interface for a prototype object.
Declaration Syntax
C#
public interface IPrototype<TObjectType>
Generic Template Parameters
TObjectType
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the type.


Clone Method

Clone Method
Namespaces ► Sitecore.Common ► IPrototype<(Of <(TObjectType>)>) ► Clone()()()
Clones the source object. Has the same effect as creating a new instance of the type.
Declaration Syntax
C#
TObjectType Clone()
Return Value


Pageable(TElement) Class

Pageable<(Of <(TElement>)>) Class
Namespaces ► Sitecore.Common ► Pageable<(Of <(TElement>)>)
Pageable class
Declaration Syntax
C#
public class Pageable<TElement> : IPageable<TElement>,
    IEnumerable<T>, IEnumerable
Generic Template Parameters
TElement
The type of the element.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Pageable<(Of <(TElement>)>)(Func<(Of <(Int32, Int32, IEnumerable<(Of <(TElement>)>)>)>), Func<(Of <(IEnumerable<(Of <(TElement>)>)>)>), Func<(Of <(Int32>)>)) | Initializes a new instance of the Pageable<(Of <(TElement>)>) class.
 | Empty | Gets the 'empty' Pageable.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAll()()() | Gets all elements.
 | GetCount()()() | Gets the number of elements.
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPage(Int32, Int32) | Gets a page of elements.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Pageable<(Of <(TElement>)>)
 |  | Filterable<(Of <(TElement>)>)


Pageable(TElement) Constructor (getPage, getAll, getCount)

Pageable<(Of <(TElement>)>) Constructor (getPage, getAll, getCount)
Namespaces ► Sitecore.Common ► Pageable<(Of <(TElement>)>) ► Pageable<(Of <(TElement>)>)(Func<(Of <(Int32, Int32, IEnumerable<(Of <(TElement>)>)>)>), Func<(Of <(IEnumerable<(Of <(TElement>)>)>)>), Func<(Of <(Int32>)>))
Initializes a new instance of the Pageable<(Of <(TElement>)>) class.
Declaration Syntax
C#
public Pageable(
    Func<int, int, IEnumerable<TElement>> getPage,
    Func<IEnumerable<TElement>> getAll,
    Func<int> getCount
)
Parameters
getPage (Func<(Of <(Int32, Int32, IEnumerable<(Of <( TElement >)>)>)>))
The 'get single page of elements' delegate.
getAll (Func<(Of <(IEnumerable<(Of <( TElement >)>)>)>))
The 'get all elements' delegate.
getCount (Func<(Of <(Int32>)>))
The 'get number of elements' delegate.


Empty Property

Empty Property
Namespaces ► Sitecore.Common ► Pageable<(Of <(TElement>)>) ► Empty
Gets the 'empty' Pageable.
Declaration Syntax
C#
public static Pageable<TElement> Empty { get; }
Value
The empty.


GetAll Method

GetAll Method
Namespaces ► Sitecore.Common ► Pageable<(Of <(TElement>)>) ► GetAll()()()
Gets all elements.
Declaration Syntax
C#
public IEnumerable<TElement> GetAll()
Return Value


GetCount Method

GetCount Method
Namespaces ► Sitecore.Common ► Pageable<(Of <(TElement>)>) ► GetCount()()()
Gets the number of elements.
Declaration Syntax
C#
public int GetCount()
Value
The number of elements.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Common ► Pageable<(Of <(TElement>)>) ► GetEnumerator()()()
Returns an enumerator that iterates through the collection.
Declaration Syntax
C#
public IEnumerator<TElement> GetEnumerator()
Return Value
A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.


GetPage Method (pageIndex, pageSize)

GetPage Method (pageIndex, pageSize)
Namespaces ► Sitecore.Common ► Pageable<(Of <(TElement>)>) ► GetPage(Int32, Int32)
Gets a page of elements.
Declaration Syntax
C#
public IEnumerable<TElement> GetPage(
    int pageIndex,
    int pageSize
)
Parameters
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
Return Value


PageableList(TElement) Class

PageableList<(Of <(TElement>)>) Class
Namespaces ► Sitecore.Common ► PageableList<(Of <(TElement>)>)
ListPageableData class
Declaration Syntax
C#
public class PageableList<TElement> : IPageable<TElement>,
    IEnumerable<T>, IEnumerable
Generic Template Parameters
TElement
The type of the element.
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PageableList<(Of <(TElement>)>)(List<(Of <(TElement>)>)) | Initializes a new instance of the PageableList<(Of <(TElement>)>) class.
 | PageableList<(Of <(TElement>)>)(IEnumerable<(Of <(TElement>)>)) | Initializes a new instance of the PageableList<(Of <(TElement>)>) class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAll()()() | Gets all elements.
 | GetCount()()() | Gets the number of elements.
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPage(Int32, Int32) | Gets a page of elements.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PageableList<(Of <(TElement>)>)


PageableList(TElement) Constructor

PageableList<(Of <(TElement>)>) Constructor
Namespaces ► Sitecore.Common ► PageableList<(Of <(TElement>)>) ► PageableList<(Of <(TElement>)>)()()()
Members
Icon | Member | Description
 | PageableList<(Of <(TElement>)>)(List<(Of <(TElement>)>)) | Initializes a new instance of the PageableList<(Of <(TElement>)>) class.
 | PageableList<(Of <(TElement>)>)(IEnumerable<(Of <(TElement>)>)) | Initializes a new instance of the PageableList<(Of <(TElement>)>) class.


PageableList(TElement) Constructor (elements)

PageableList<(Of <(TElement>)>) Constructor (elements)
Namespaces ► Sitecore.Common ► PageableList<(Of <(TElement>)>) ► PageableList<(Of <(TElement>)>)(IEnumerable<(Of <(TElement>)>))
Initializes a new instance of the PageableList<(Of <(TElement>)>) class.
Declaration Syntax
C#
public PageableList(
    IEnumerable<TElement> elements
)
Parameters
elements (IEnumerable<(Of <( TElement >)>))
The elements.


PageableList(TElement) Constructor (elements)

PageableList<(Of <(TElement>)>) Constructor (elements)
Namespaces ► Sitecore.Common ► PageableList<(Of <(TElement>)>) ► PageableList<(Of <(TElement>)>)(List<(Of <(TElement>)>))
Initializes a new instance of the PageableList<(Of <(TElement>)>) class.
Declaration Syntax
C#
public PageableList(
    List<TElement> elements
)
Parameters
elements (List<(Of <( TElement >)>))
The elements.


GetAll Method

GetAll Method
Namespaces ► Sitecore.Common ► PageableList<(Of <(TElement>)>) ► GetAll()()()
Gets all elements.
Declaration Syntax
C#
public IEnumerable<TElement> GetAll()
Return Value


GetCount Method

GetCount Method
Namespaces ► Sitecore.Common ► PageableList<(Of <(TElement>)>) ► GetCount()()()
Gets the number of elements.
Declaration Syntax
C#
public int GetCount()
Value
The number of elements.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Common ► PageableList<(Of <(TElement>)>) ► GetEnumerator()()()
Returns an enumerator that iterates through the collection.
Declaration Syntax
C#
public IEnumerator<TElement> GetEnumerator()
Return Value
A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.


GetPage Method (pageIndex, pageSize)

GetPage Method (pageIndex, pageSize)
Namespaces ► Sitecore.Common ► PageableList<(Of <(TElement>)>) ► GetPage(Int32, Int32)
Gets a page of elements.
Declaration Syntax
C#
public IEnumerable<TElement> GetPage(
    int pageIndex,
    int pageSize
)
Parameters
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
Return Value


PagingHelper(TInput, TOutput) Class

PagingHelper<(Of <(TInput, TOutput>)>) Class
Namespaces ► Sitecore.Common ► PagingHelper<(Of <(TInput, TOutput>)>)
PagingHelper class
Declaration Syntax
C#
public class PagingHelper<TInput, TOutput>
where TOutput : class
Generic Template Parameters
TInput
TOutput
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PagingHelper<(Of <(TInput, TOutput>)>)()()() | Initializes a new instance of the PagingHelper<(Of <(TInput, TOutput>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRecords(Int32, Int32, IEnumerable<(Of <(TInput>)>), PagingHelper<(Of <(TInput, TOutput>)>)..::.GetElements, Int32%) | Gets the records.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PagingHelper<(Of <(TInput, TOutput>)>)


PagingHelper(TInput, TOutput) Constructor

PagingHelper<(Of <(TInput, TOutput>)>) Constructor
Namespaces ► Sitecore.Common ► PagingHelper<(Of <(TInput, TOutput>)>) ► PagingHelper<(Of <(TInput, TOutput>)>)()()()
Initializes a new instance of the PagingHelper<(Of <(TInput, TOutput>)>) class
Declaration Syntax
C#
public PagingHelper()


GetRecords Method (pageIndex, pageSize, inputList, getElements, totalRecords)

GetRecords Method (pageIndex, pageSize, inputList, getElements, totalRecords)
Namespaces ► Sitecore.Common ► PagingHelper<(Of <(TInput, TOutput>)>) ► GetRecords(Int32, Int32, IEnumerable<(Of <(TInput>)>), PagingHelper<(Of <(TInput, TOutput>)>)..::.GetElements, Int32%)
Gets the records.
Declaration Syntax
C#
public List<TOutput> GetRecords(
    int pageIndex,
    int pageSize,
    IEnumerable<TInput> inputList,
    PagingHelper<(Of <(TInput, TOutput>)>)..::.GetElements getElements,
    out int totalRecords
)
Parameters
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
inputList (IEnumerable<(Of <( TInput >)>))
The list of elements to process.
getElements (PagingHelper<(Of <(TInput, TOutput>)>)..::.GetElements)
The function to call for each input element.
totalRecords ( Int32 %)
The total number of records in all elements combined.
Return Value


PagingHelper(TInput, TOutput).GetElements Delegate

PagingHelper<(Of <(TInput, TOutput>)>)..::.GetElements Delegate
Namespaces ► Sitecore.Common ► PagingHelper<(Of <(TInput, TOutput>)>) ► PagingHelper<(Of <(TInput, TOutput>)>)..::.GetElements
GetElements delegate
Declaration Syntax
C#
public delegate Object GetElements(
    TInput source,
    int pageIndex,
    int pageSize,
    out int totalRecords
)
Parameters
source (TInput)
The source to retrieve records from.
pageIndex (Int32)
The index of the page of results to return.
pageSize (Int32)
The size of each page.
totalRecords ( Int32 %)
When this method returns, contains the total number of elements in the source.
Return Value
An object that is either IEnumerable or has a GetEnumerator method.


PagingIterator(T) Class

PagingIterator<(Of <(T>)>) Class
Namespaces ► Sitecore.Common ► PagingIterator<(Of <(T>)>)
Declaration Syntax
C#
public class PagingIterator<T> : IEnumerable<T>,
    IEnumerable
Generic Template Parameters
T
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PagingIterator<(Of <(T>)>)(PagingIterator<(Of <(T>)>)..::.GetPage) | Initializes a new instance of the PagingIterator<(Of <(T>)>) class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PagingIterator<(Of <(T>)>)


PagingIterator(T) Constructor (getPage)

PagingIterator<(Of <(T>)>) Constructor (getPage)
Namespaces ► Sitecore.Common ► PagingIterator<(Of <(T>)>) ► PagingIterator<(Of <(T>)>)(PagingIterator<(Of <(T>)>)..::.GetPage)
Initializes a new instance of the PagingIterator<(Of <(T>)>) class.
Declaration Syntax
C#
public PagingIterator(
    PagingIterator<(Of <(T>)>)..::.GetPage getPage
)
Parameters
getPage (PagingIterator<(Of <(T>)>)..::.GetPage)
The get page delegate.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Common ► PagingIterator<(Of <(T>)>) ► GetEnumerator()()()
Returns an enumerator that iterates through the collection.
Declaration Syntax
C#
public IEnumerator<T> GetEnumerator()
Return Value
A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.


PagingIterator(T).GetPage Delegate

PagingIterator<(Of <(T>)>)..::.GetPage Delegate
Namespaces ► Sitecore.Common ► PagingIterator<(Of <(T>)>) ► PagingIterator<(Of <(T>)>)..::.GetPage
Declaration Syntax
C#
public delegate IEnumerable GetPage(
    int pageIndex
)
Parameters
pageIndex (Int32)


SettingsPropertyCollectionExtensions Class

SettingsPropertyCollectionExtensions Class
Namespaces ► Sitecore.Common ► SettingsPropertyCollectionExtensions
Extension methods for the SettingsPropertyCollection class.
Declaration Syntax
C#
public static class SettingsPropertyCollectionExtensions
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Contains(SettingsPropertyCollection, String) | Determines whether SettingsPropertyCollection contains the specified property.
Inheritance Hierarchy
Object
SettingsPropertyCollectionExtensions


Contains Method (propertyCollection, propertyName)

Contains Method (propertyCollection, propertyName)
Namespaces ► Sitecore.Common ► SettingsPropertyCollectionExtensions ► Contains(SettingsPropertyCollection, String)
Determines whether SettingsPropertyCollection contains the specified property.
Declaration Syntax
C#
public static bool Contains(
    SettingsPropertyCollection propertyCollection,
    string propertyName
)
Parameters
propertyCollection (SettingsPropertyCollection)
The property collection.
propertyName (String)
Name of the property.
Return Value
true if contains; otherwise, false.


Switcher(T) Class

Switcher<(Of <(T>)>) Class
Namespaces ► Sitecore.Common ► Switcher<(Of <(T>)>)
Swither class
Declaration Syntax
C#
public class Switcher<T> : Switcher<T, T>
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Switcher<(Of <(T>)>)()()() | Initializes a new instance of the Switcher<(Of <(T>)>) class.
 | Switcher<(Of <(T>)>)(T) | Initializes a new instance of the Switcher<(Of <(T>)>) class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <(T, T>)>)
 |  | Switcher<(Of <(T>)>)
 |  |  | DomainSwitcher
 |  |  | AuthorizationSwitcher
 |  |  | UserSwitcher
 |  |  | AuthenticationSwitcher
 |  |  | ProfileSwitcher
 |  |  | SecurityStateSwitcher


Switcher(T) Constructor

Switcher<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Common ► Switcher<(Of <(T>)>) ► Switcher<(Of <(T>)>)()()()
Members
Icon | Member | Description
 | Switcher<(Of <(T>)>)()()() | Initializes a new instance of the Switcher<(Of <(T>)>) class.
 | Switcher<(Of <(T>)>)(T) | Initializes a new instance of the Switcher<(Of <(T>)>) class.


Switcher(T) Constructor

Switcher<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Common ► Switcher<(Of <(T>)>) ► Switcher<(Of <(T>)>)()()()
Initializes a new instance of the Switcher<(Of <(T>)>) class.
Declaration Syntax
C#
protected Switcher()


Switcher(T) Constructor (objectToSwitchTo)

Switcher<(Of <(T>)>) Constructor (objectToSwitchTo)
Namespaces ► Sitecore.Common ► Switcher<(Of <(T>)>) ► Switcher<(Of <(T>)>)(T)
Initializes a new instance of the Switcher<(Of <(T>)>) class.
Declaration Syntax
C#
public Switcher(
    T objectToSwitchTo
)
Parameters
objectToSwitchTo (T)
The object to switch to.


Switcher(TValue, TSwitchType) Class

Switcher<(Of <(TValue, TSwitchType>)>) Class
Namespaces ► Sitecore.Common ► Switcher<(Of <(TValue, TSwitchType>)>)
Switcher class
Declaration Syntax
C#
public class Switcher<TValue, TSwitchType> : IDisposable
Generic Template Parameters
TValue
TSwitchType
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Switcher<(Of <(TValue, TSwitchType>)>)(TValue) | Initializes a new instance of the Switcher<(Of <(TValue, TSwitchType>)>) class.
 | Switcher<(Of <(TValue, TSwitchType>)>)()()() | Initializes a new instance of the Switcher<(Of <(TValue, TSwitchType>)>) class.
 | CurrentValue | Gets the current object instance (or default(T) if no switch is active).
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Disposed | Occurs when the object has been disposed.
 | Enter(TValue) | Enters an object instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exit()()() | Exits the current object.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStack(Boolean) | Gets the stack.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemsKey | Key used for storing state in Items
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher<(Of <(TValue, TSwitchType>)>)
 |  | CallContextSwitcher
 |  | Switcher<(Of <(T>)>)
 |  | DatabaseCacheDisabler
 |  | SyncOperationContext
 |  | EventDisabler
 |  | ContextItemSwitcher
 |  | LinkDisabler
 |  | SiteContextSwitcher
 |  | ViewStateDisabler
 |  | PlaceholderSwitcher


Switcher(TValue, TSwitchType) Constructor

Switcher<(Of <(TValue, TSwitchType>)>) Constructor
Namespaces ► Sitecore.Common ► Switcher<(Of <(TValue, TSwitchType>)>) ► Switcher<(Of <(TValue, TSwitchType>)>)()()()
Members
Icon | Member | Description
 | Switcher<(Of <(TValue, TSwitchType>)>)(TValue) | Initializes a new instance of the Switcher<(Of <(TValue, TSwitchType>)>) class.
 | Switcher<(Of <(TValue, TSwitchType>)>)()()() | Initializes a new instance of the Switcher<(Of <(TValue, TSwitchType>)>) class.


Switcher(TValue, TSwitchType) Constructor

Switcher<(Of <(TValue, TSwitchType>)>) Constructor
Namespaces ► Sitecore.Common ► Switcher<(Of <(TValue, TSwitchType>)>) ► Switcher<(Of <(TValue, TSwitchType>)>)()()()
Initializes a new instance of the Switcher<(Of <(TValue, TSwitchType>)>) class.
Declaration Syntax
C#
protected Switcher()


Switcher(TValue, TSwitchType) Constructor (objectToSwitchTo)

Switcher<(Of <(TValue, TSwitchType>)>) Constructor (objectToSwitchTo)
Namespaces ► Sitecore.Common ► Switcher<(Of <(TValue, TSwitchType>)>) ► Switcher<(Of <(TValue, TSwitchType>)>)(TValue)
Initializes a new instance of the Switcher<(Of <(TValue, TSwitchType>)>) class.
Declaration Syntax
C#
public Switcher(
    TValue objectToSwitchTo
)
Parameters
objectToSwitchTo (TValue)
The object to switch to.


CurrentValue Property

CurrentValue Property
Namespaces ► Sitecore.Common ► Switcher<(Of <(TValue, TSwitchType>)>) ► CurrentValue
Gets the current object instance (or default(T) if no switch is active).
Declaration Syntax
C#
public static TValue CurrentValue { get; }
Value
The current group.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Common ► Switcher<(Of <(TValue, TSwitchType>)>) ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public virtual void Dispose()


Disposed Event

Disposed Event
Namespaces ► Sitecore.Common ► Switcher<(Of <(TValue, TSwitchType>)>) ► Disposed
Occurs when the object has been disposed.
Declaration Syntax
C#
protected event EventHandler<EventArgs> Disposed


Enter Method (objectToSwitchTo)

Enter Method (objectToSwitchTo)
Namespaces ► Sitecore.Common ► Switcher<(Of <(TValue, TSwitchType>)>) ► Enter(TValue)
Enters an object instance.
Declaration Syntax
C#
public static void Enter(
    TValue objectToSwitchTo
)
Parameters
objectToSwitchTo (TValue)
The object to switch to.


Exit Method

Exit Method
Namespaces ► Sitecore.Common ► Switcher<(Of <(TValue, TSwitchType>)>) ► Exit()()()
Exits the current object.
Declaration Syntax
C#
public static void Exit()


GetStack Method (createIfEmpty)

GetStack Method (createIfEmpty)
Namespaces ► Sitecore.Common ► Switcher<(Of <(TValue, TSwitchType>)>) ► GetStack(Boolean)
Gets the stack.
Declaration Syntax
C#
public static Stack<TValue> GetStack(
    bool createIfEmpty
)
Parameters
createIfEmpty (Boolean)
if set to true null value will never be returned.
Return Value


ItemsKey Property

ItemsKey Property
Namespaces ► Sitecore.Common ► Switcher<(Of <(TValue, TSwitchType>)>) ► ItemsKey
Key used for storing state in Items
Declaration Syntax
C#
public static string ItemsKey { get; }


Timeline Class

Timeline Class
Namespaces ► Sitecore.Common ► Timeline
Timeline class
Declaration Syntax
C#
public class Timeline
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Timeline(DateTimeRange) | Initializes a new instance of the Timeline class.
 | Contains(DateTime) | Determines whether the timeline contains the specified date time.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRangeContaining(DateTime) | Gets the range containing the specified date time.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveAfter(DateTime) | Removes everything after the specified date time from the timeline.
 | RemoveBefore(DateTime) | Removes everything before the specified date time from the timeline.
 | Subtract(DateTimeRange) | Subtracts the specified range.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Timeline


Timeline Constructor (range)

Timeline Constructor (range)
Namespaces ► Sitecore.Common ► Timeline ► Timeline(DateTimeRange)
Initializes a new instance of the Timeline class.
Declaration Syntax
C#
public Timeline(
    DateTimeRange range
)
Parameters
range (DateTimeRange)
The initial range.


Contains Method (dateTime)

Contains Method (dateTime)
Namespaces ► Sitecore.Common ► Timeline ► Contains(DateTime)
Determines whether the timeline contains the specified date time.
Declaration Syntax
C#
public bool Contains(
    DateTime dateTime
)
Parameters
dateTime (DateTime)
The date time.
Return Value
true if the specified date time is contained; otherwise, false.


GetRangeContaining Method (dateTime)

GetRangeContaining Method (dateTime)
Namespaces ► Sitecore.Common ► Timeline ► GetRangeContaining(DateTime)
Gets the range containing the specified date time.
Declaration Syntax
C#
public DateTimeRange GetRangeContaining(
    DateTime dateTime
)
Parameters
dateTime (DateTime)
The date time.
Return Value
The range. If no range is found, Empty is returned.


RemoveAfter Method (dateTime)

RemoveAfter Method (dateTime)
Namespaces ► Sitecore.Common ► Timeline ► RemoveAfter(DateTime)
Removes everything after the specified date time from the timeline.
Declaration Syntax
C#
public void RemoveAfter(
    DateTime dateTime
)
Parameters
dateTime (DateTime)
The date time.


RemoveBefore Method (dateTime)

RemoveBefore Method (dateTime)
Namespaces ► Sitecore.Common ► Timeline ► RemoveBefore(DateTime)
Removes everything before the specified date time from the timeline.
Declaration Syntax
C#
public void RemoveBefore(
    DateTime dateTime
)
Parameters
dateTime (DateTime)
The date time.


Subtract Method (range)

Subtract Method (range)
Namespaces ► Sitecore.Common ► Timeline ► Subtract(DateTimeRange)
Subtracts the specified range.
Declaration Syntax
C#
public void Subtract(
    DateTimeRange range
)
Parameters
range (DateTimeRange)
The range.


Sitecore.Configuration Namespace

Sitecore.Configuration Namespace
Namespaces ► Sitecore.Configuration
Declaration Syntax
C#
namespace Sitecore.Configuration
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | About | About Sitecore.
 | Settings..::.Authentication |
 | Settings..::.Authorization |
 | Settings..::.Caching |
 | State..::.Client |
 | ClientContext | Represents the current client context.
 | ClientDataStore | Represents a Client Data Store.
 | ConfigChangedEventArgs | ConfigChangedEventArgs class
 | ConfigReader | Class to read custom configuration sections.
 | ConfigRecord | ConfigRecord class
 | ConfigStore | ConfigStore class
 | ConfigurationAction | ConfigurationAction class
 | ConfigWatcher | Monitors the /App_Config folder for changes.
 | Settings..::.ContentEditor | Defines Content Editor options.
 | Settings..::.Counters |
 | Factory | The Factory.
 | FileDataStore | Represents a FileDataStore.
 | Factory..::.HashKeyType | Represents a HashKeyType.
 | Factory..::.HashValueFormat | Represents a HashValueFormat.
 | Factory..::.HashValueType | Represents a HashValueType.
 | Settings..::.HtmlEditor |
 | State..::.HttpRuntime |
 | IFactoryHelper | IFactoryHelper class
 | Settings..::.Indexing |
 | Settings..::.Install | Settings for Install namespace
 | Settings..::.Jobs |
 | Settings..::.Languages |
 | Settings..::.Links |
 | Settings..::.Login |
 | Settings..::.Media |
 | Settings..::.MediaResponse |
 | ObjectList | Represents an object list.
 | State..::.PageDesigner | PageDesigner state
 | Settings..::.Performance |
 | Settings..::.Preview |
 | Settings..::.Profiling | Defines profile options.
 | ProviderHelper<(Of <(TProvider, TCollection>)>) | ManagerData class
 | Settings..::.Publishing |
 | Settings..::.Query |
 | Settings..::.Rendering |
 | State..::.Request |
 | Settings..::.RequestErrors | Settings controlling behaviour when a request error condition occurs.
 | Settings..::.Roles |
 | Settings..::.Rules | Defines the rule sets class.
 | Settings..::.Runtime |
 | Settings..::.Scripts | Defines the scripts class.
 | Settings | The Settings class encapsulates the web.config file and provides easy access to the values therein.
 | State..::.Sites |
 | Settings..::.Caching..::.StandardValues | StandardValues class
 | State | Sitecore maintains a state about the current webpage (in the Items collection) and about the current session (in the Session collection). Typical information include the current user, the current web item, the current master item, the current layout etc. The State class encapsulates both the Items and Session collections.
 | StateContext | Represents the state context.
 | Settings..::.Statistics |
 | Settings..::.Tasks |
 | Settings..::.Templates |
 | Settings..::.Trace |
 | Settings..::.UI |
 | Settings..::.UnitTests |
 | Settings..::.Upload |
 | Settings..::.Validators |
 | Settings..::.WebConfig | WebConfig class
 | Settings..::.WebEdit |
 | Settings..::.WorldLingo |
 | XmlConfigFile | XmlConfigFile
 | XmlConfigRecord | XmlConfigRecord class
 | XmlConfigStore | XmlConfigStore class
 | Settings..::.XmlControls |


About Class

About Class
Namespaces ► Sitecore.Configuration ► About
About Sitecore.
Declaration Syntax
C#
public sealed class About
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | About()()() | Initializes a new instance of the About class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersionNumber(Boolean) | Gets the version number (on the form Major.Minor.Build[.Revision]).
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToHtml()()() | Gets about information of the current installation as html.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | Gets version information of the current installation.
 | VersionInformation()()() | Gets version information of the current installation.
Inheritance Hierarchy
Object
About


About Constructor

About Constructor
Namespaces ► Sitecore.Configuration ► About ► About()()()
Initializes a new instance of the About class
Declaration Syntax
C#
public About()


GetVersionNumber Method (includeRevision)

GetVersionNumber Method (includeRevision)
Namespaces ► Sitecore.Configuration ► About ► GetVersionNumber(Boolean)
Gets the version number (on the form Major.Minor.Build[.Revision]).
Declaration Syntax
C#
public static string GetVersionNumber(
    bool includeRevision
)
Parameters
includeRevision (Boolean)
if set to true revision number is included in the value.
Return Value


ToHtml Method

ToHtml Method
Namespaces ► Sitecore.Configuration ► About ► ToHtml()()()
Gets about information of the current installation as html.
Declaration Syntax
C#
public static string ToHtml()
Return Value
Remarks
The returned html is a fragment made up of more div tags having class='sc_about_font'.
Examples
CopyC#
string aboutInfo = "<td>" + About.ToHtml() + "</td>"; // returns ready-to-use html.


Version Property

Version Property
Namespaces ► Sitecore.Configuration ► About ► Version
Gets version information of the current installation.
Declaration Syntax
C#
public static string Version { get; }
Value
The version.
Remarks
The information is on the format Major.Minor.Revision.Build.
Examples
CopyC#
string versionInfo = About.Version(); // "5.3.0"


VersionInformation Method

VersionInformation Method
Namespaces ► Sitecore.Configuration ► About ► VersionInformation()()()
Gets version information of the current installation.
Declaration Syntax
C#
public static string VersionInformation()
Return Value
Remarks
The information is on the format Sitecore Major.Minor.Revision.Build.
Examples
CopyC#
string versionInfo = About.VersionInformation(); // "Sitecore 4.3.2"


ClientContext Class

ClientContext Class
Namespaces ► Sitecore.Configuration ► ClientContext
Represents the current client context.
Declaration Syntax
C#
public static class ClientContext
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DataStore | Gets the data store.
 | GetValue(String) | Gets the value.
 | GetValueNames()()() | Gets the value names.
 | RemoveValue(String) | Removes the value.
 | SetValue(String, String) | Sets the value.
 | SetValue(String, Object, String) | Sets the value.
Inheritance Hierarchy
Object
ClientContext


DataStore Property

DataStore Property
Namespaces ► Sitecore.Configuration ► ClientContext ► DataStore
Gets the data store.
Declaration Syntax
C#
public static ClientDataStore DataStore { get; }
Value
The data store.


GetValue Method (name)

GetValue Method (name)
Namespaces ► Sitecore.Configuration ► ClientContext ► GetValue(String)
Gets the value.
Declaration Syntax
C#
public static Object GetValue(
    string name
)
Parameters
name (String)
The name.
Return Value
The value.


GetValueNames Method

GetValueNames Method
Namespaces ► Sitecore.Configuration ► ClientContext ► GetValueNames()()()
Gets the value names.
Declaration Syntax
C#
public static string[] GetValueNames()
Return Value
The value names.


RemoveValue Method (name)

RemoveValue Method (name)
Namespaces ► Sitecore.Configuration ► ClientContext ► RemoveValue(String)
Removes the value.
Declaration Syntax
C#
public static void RemoveValue(
    string name
)
Parameters
name (String)
The name.


SetValue Method

SetValue Method
Namespaces ► Sitecore.Configuration ► ClientContext ► SetValue()()()
Members
Icon | Member | Description
 | SetValue(String, String) | Sets the value.
 | SetValue(String, Object, String) | Sets the value.


SetValue Method (name, value, persistableValue)

SetValue Method (name, value, persistableValue)
Namespaces ► Sitecore.Configuration ► ClientContext ► SetValue(String, Object, String)
Sets the value.
Declaration Syntax
C#
public static void SetValue(
    string name,
    Object value,
    string persistableValue
)
Parameters
name (String)
The name.
value (Object)
The value.
persistableValue (String)
The persistable value.


SetValue Method (name, value)

SetValue Method (name, value)
Namespaces ► Sitecore.Configuration ► ClientContext ► SetValue(String, String)
Sets the value.
Declaration Syntax
C#
public static void SetValue(
    string name,
    string value
)
Parameters
name (String)
The name.
value (String)
The value.


ClientDataStore Class

ClientDataStore Class
Namespaces ► Sitecore.Configuration ► ClientDataStore
Represents a Client Data Store.
Declaration Syntax
C#
public abstract class ClientDataStore
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientDataStore(TimeSpan) | Initializes a new instance of the ClientDataStore class.
 | ClientDataStore(TimeSpan, Boolean) | Initializes a new instance of the ClientDataStore class.
 | AddDataToCache(String, Hashtable, Int64) | Adds data to the cache.
 | Compact()()() | Compacts this instance.
 | CompactData()()() | Compacts the data.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataFromCache(String) | Gets data from the cache.
 | GetDataKey()()() | Gets the data key.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSize(Hashtable) | Gets the size of newly returned data.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(String) | Gets the value.
 | GetValueNames()()() | Gets the value names.
 | LoadData()()() | Loads the data.
 | LoadData(String) | Loads the data.
 | LoadViewstate(String) | Loads the viewstate.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ObjectLifetime | Gets the object lifetime.
 | RemoveAll()()() | Removes the values.
 | RemoveAllData()()() | Removes all data.
 | RemoveData()()() | Removes the data.
 | RemoveData(String) | Removes the data.
 | RemoveDataFromCache(String) | Removes data from the cache.
 | RemoveValue(String) | Removes the value.
 | RemoveValues()()() | Removes the values.
 | RemoveViewstate(String) | Removes the viewstate.
 | SaveData(Hashtable) | Saves the data.
 | SaveData(String, String) | Saves the data.
 | SaveViewstate(String, String) | Saves the viewstate.
 | SetValue(String, String) | Sets the value.
 | SetValue(String, Object, String) | Sets the value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TouchActiveData()()() | Touches all active data.
 | TouchData(String) | Touches the data represented by key.
Inheritance Hierarchy
Object
 | ClientDataStore
 |  | FileDataStore
 |  | SqlServerClientDataStore


ClientDataStore Constructor

ClientDataStore Constructor
Namespaces ► Sitecore.Configuration ► ClientDataStore ► ClientDataStore()()()
Members
Icon | Member | Description
 | ClientDataStore(TimeSpan) | Initializes a new instance of the ClientDataStore class.
 | ClientDataStore(TimeSpan, Boolean) | Initializes a new instance of the ClientDataStore class.


ClientDataStore Constructor (objectLifetime)

ClientDataStore Constructor (objectLifetime)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► ClientDataStore(TimeSpan)
Initializes a new instance of the ClientDataStore class.
Declaration Syntax
C#
protected ClientDataStore(
    TimeSpan objectLifetime
)
Parameters
objectLifetime (TimeSpan)
The object lifetime.


ClientDataStore Constructor (objectLifetime, enableCaching)

ClientDataStore Constructor (objectLifetime, enableCaching)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► ClientDataStore(TimeSpan, Boolean)
Initializes a new instance of the ClientDataStore class.
Declaration Syntax
C#
protected ClientDataStore(
    TimeSpan objectLifetime,
    bool enableCaching
)
Parameters
objectLifetime (TimeSpan)
The object lifetime.
enableCaching (Boolean)
If set to true this instance enables caching.


AddDataToCache Method (key, data, size)

AddDataToCache Method (key, data, size)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► AddDataToCache(String, Hashtable, Int64)
Adds data to the cache.
Declaration Syntax
C#
protected virtual void AddDataToCache(
    string key,
    Hashtable data,
    long size
)
Parameters
key (String)
The key.
data (Hashtable)
The data.
size (Int64)
The size.


Compact Method

Compact Method
Namespaces ► Sitecore.Configuration ► ClientDataStore ► Compact()()()
Compacts this instance.
Declaration Syntax
C#
public virtual void Compact()


CompactData Method

CompactData Method
Namespaces ► Sitecore.Configuration ► ClientDataStore ► CompactData()()()
Compacts the data.
Declaration Syntax
C#
protected abstract void CompactData()


GetDataFromCache Method (key)

GetDataFromCache Method (key)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► GetDataFromCache(String)
Gets data from the cache.
Declaration Syntax
C#
protected virtual Hashtable GetDataFromCache(
    string key
)
Parameters
key (String)
The key.
Return Value
The data (or null).


GetDataKey Method

GetDataKey Method
Namespaces ► Sitecore.Configuration ► ClientDataStore ► GetDataKey()()()
Gets the data key.
Declaration Syntax
C#
protected virtual string GetDataKey()
Return Value
The data key.


GetSize Method (data)

GetSize Method (data)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► GetSize(Hashtable)
Gets the size of newly returned data.
Declaration Syntax
C#
protected virtual long GetSize(
    Hashtable data
)
Parameters
data (Hashtable)
The data.
Return Value
The size.


GetValue Method (name)

GetValue Method (name)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► GetValue(String)
Gets the value.
Declaration Syntax
C#
public virtual Object GetValue(
    string name
)
Parameters
name (String)
The name.
Return Value
The value.


GetValueNames Method

GetValueNames Method
Namespaces ► Sitecore.Configuration ► ClientDataStore ► GetValueNames()()()
Gets the value names.
Declaration Syntax
C#
public virtual string[] GetValueNames()
Return Value
The value names.


LoadData Method

LoadData Method
Namespaces ► Sitecore.Configuration ► ClientDataStore ► LoadData()()()
Members
Icon | Member | Description
 | LoadData()()() | Loads the data.
 | LoadData(String) | Loads the data.


LoadData Method

LoadData Method
Namespaces ► Sitecore.Configuration ► ClientDataStore ► LoadData()()()
Loads the data.
Declaration Syntax
C#
protected virtual Hashtable LoadData()
Return Value
The data.


LoadData Method (key)

LoadData Method (key)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► LoadData(String)
Loads the data.
Declaration Syntax
C#
protected abstract string LoadData(
    string key
)
Parameters
key (String)
The key.
Return Value


LoadViewstate Method (key)

LoadViewstate Method (key)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► LoadViewstate(String)
Loads the viewstate.
Declaration Syntax
C#
public virtual string LoadViewstate(
    string key
)
Parameters
key (String)
The key.
Return Value


ObjectLifetime Property

ObjectLifetime Property
Namespaces ► Sitecore.Configuration ► ClientDataStore ► ObjectLifetime
Gets the object lifetime.
Declaration Syntax
C#
public TimeSpan ObjectLifetime { get; }
Value
The object lifetime.


RemoveAll Method

RemoveAll Method
Namespaces ► Sitecore.Configuration ► ClientDataStore ► RemoveAll()()()
Removes the values.
Declaration Syntax
C#
public virtual void RemoveAll()


RemoveAllData Method

RemoveAllData Method
Namespaces ► Sitecore.Configuration ► ClientDataStore ► RemoveAllData()()()
Removes all data.
Declaration Syntax
C#
protected virtual void RemoveAllData()


RemoveData Method

RemoveData Method
Namespaces ► Sitecore.Configuration ► ClientDataStore ► RemoveData()()()
Members
Icon | Member | Description
 | RemoveData()()() | Removes the data.
 | RemoveData(String) | Removes the data.


RemoveData Method

RemoveData Method
Namespaces ► Sitecore.Configuration ► ClientDataStore ► RemoveData()()()
Removes the data.
Declaration Syntax
C#
protected virtual void RemoveData()


RemoveData Method (key)

RemoveData Method (key)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► RemoveData(String)
Removes the data.
Declaration Syntax
C#
protected abstract void RemoveData(
    string key
)
Parameters
key (String)
The key.


RemoveDataFromCache Method (key)

RemoveDataFromCache Method (key)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► RemoveDataFromCache(String)
Removes data from the cache.
Declaration Syntax
C#
protected virtual void RemoveDataFromCache(
    string key
)
Parameters
key (String)
The key.


RemoveValue Method (name)

RemoveValue Method (name)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► RemoveValue(String)
Removes the value.
Declaration Syntax
C#
public virtual void RemoveValue(
    string name
)
Parameters
name (String)
The name.


RemoveValues Method

RemoveValues Method
Namespaces ► Sitecore.Configuration ► ClientDataStore ► RemoveValues()()()
Removes the values.
Declaration Syntax
C#
public virtual void RemoveValues()


RemoveViewstate Method (key)

RemoveViewstate Method (key)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► RemoveViewstate(String)
Removes the viewstate.
Declaration Syntax
C#
public virtual void RemoveViewstate(
    string key
)
Parameters
key (String)
The key.


SaveData Method

SaveData Method
Namespaces ► Sitecore.Configuration ► ClientDataStore ► SaveData()()()
Members
Icon | Member | Description
 | SaveData(Hashtable) | Saves the data.
 | SaveData(String, String) | Saves the data.


SaveData Method (data)

SaveData Method (data)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► SaveData(Hashtable)
Saves the data.
Declaration Syntax
C#
protected virtual void SaveData(
    Hashtable data
)
Parameters
data (Hashtable)
The data.


SaveData Method (key, data)

SaveData Method (key, data)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► SaveData(String, String)
Saves the data.
Declaration Syntax
C#
protected abstract void SaveData(
    string key,
    string data
)
Parameters
key (String)
The key.
data (String)
The data.


SaveViewstate Method (key, value)

SaveViewstate Method (key, value)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► SaveViewstate(String, String)
Saves the viewstate.
Declaration Syntax
C#
public virtual void SaveViewstate(
    string key,
    string value
)
Parameters
key (String)
The key.
value (String)
The value.


SetValue Method

SetValue Method
Namespaces ► Sitecore.Configuration ► ClientDataStore ► SetValue()()()
Members
Icon | Member | Description
 | SetValue(String, String) | Sets the value.
 | SetValue(String, Object, String) | Sets the value.


SetValue Method (name, value, persistableValue)

SetValue Method (name, value, persistableValue)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► SetValue(String, Object, String)
Sets the value.
Declaration Syntax
C#
public virtual void SetValue(
    string name,
    Object value,
    string persistableValue
)
Parameters
name (String)
The name.
value (Object)
The value.
persistableValue (String)
The persistable value.


SetValue Method (name, value)

SetValue Method (name, value)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► SetValue(String, String)
Sets the value.
Declaration Syntax
C#
public virtual void SetValue(
    string name,
    string value
)
Parameters
name (String)
The name.
value (String)
The value.


TouchActiveData Method

TouchActiveData Method
Namespaces ► Sitecore.Configuration ► ClientDataStore ► TouchActiveData()()()
Touches all active data.
Declaration Syntax
C#
protected virtual void TouchActiveData()


TouchData Method (key)

TouchData Method (key)
Namespaces ► Sitecore.Configuration ► ClientDataStore ► TouchData(String)
Touches the data represented by key.
Declaration Syntax
C#
protected virtual void TouchData(
    string key
)
Parameters
key (String)
The key.


ConfigChangedEventArgs Class

ConfigChangedEventArgs Class
Namespaces ► Sitecore.Configuration ► ConfigChangedEventArgs
ConfigChangedEventArgs class
Declaration Syntax
C#
public class ConfigChangedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigChangedEventArgs(String) | Initializes a new instance of the ConfigChangedEventArgs class.
 | ConfigFilePath | Gets the config file path.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ConfigChangedEventArgs


ConfigChangedEventArgs Constructor (configFilePath)

ConfigChangedEventArgs Constructor (configFilePath)
Namespaces ► Sitecore.Configuration ► ConfigChangedEventArgs ► ConfigChangedEventArgs(String)
Initializes a new instance of the ConfigChangedEventArgs class.
Declaration Syntax
C#
public ConfigChangedEventArgs(
    string configFilePath
)
Parameters
configFilePath (String)


ConfigFilePath Property

ConfigFilePath Property
Namespaces ► Sitecore.Configuration ► ConfigChangedEventArgs ► ConfigFilePath
Gets the config file path.
Declaration Syntax
C#
public string ConfigFilePath { get; }
Value
The config file path.


ConfigReader Class

ConfigReader Class
Namespaces ► Sitecore.Configuration ► ConfigReader
Class to read custom configuration sections.
Declaration Syntax
C#
public class ConfigReader : IConfigurationSectionHandler
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigReader()()() | Initializes a new instance of the ConfigReader class
 | ConfigutationIsSet | Gets a value indicating whether configutation is set.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute(String, String) | Obsolete. Gets the attribute.
 | GetConfigNode()()() | Gets the root config node (ie. sitecore)
 | GetConfigNode(String) | Gets a specific config node.
 | GetConfigNodes(String) | Gets a list of config nodes matching an xpath.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetImplementationNode(String, String) | Gets a specific implementation node.
 | GetNode(String) | Get an xml node.
 | GetNodes(String) | Get a list of xml nodes.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConfigReader


ConfigReader Constructor

ConfigReader Constructor
Namespaces ► Sitecore.Configuration ► ConfigReader ► ConfigReader()()()
Initializes a new instance of the ConfigReader class
Declaration Syntax
C#
public ConfigReader()


ConfigutationIsSet Property

ConfigutationIsSet Property
Namespaces ► Sitecore.Configuration ► ConfigReader ► ConfigutationIsSet
Gets a value indicating whether configutation is set.
Declaration Syntax
C#
public static bool ConfigutationIsSet { get; }
Value
true if configutation is set; otherwise, false.


GetAttribute Method (nodePath, attributeName)

GetAttribute Method (nodePath, attributeName)
Namespaces ► Sitecore.Configuration ► ConfigReader ► GetAttribute(String, String)
Gets the attribute.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static string GetAttribute(
    string nodePath,
    string attributeName
)
Parameters
nodePath (String)
The node path.
attributeName (String)
Name of the attribute.
Return Value


GetConfigNode Method

GetConfigNode Method
Namespaces ► Sitecore.Configuration ► ConfigReader ► GetConfigNode()()()
Members
Icon | Member | Description
 | GetConfigNode()()() | Gets the root config node (ie. sitecore)
 | GetConfigNode(String) | Gets a specific config node.


GetConfigNode Method

GetConfigNode Method
Namespaces ► Sitecore.Configuration ► ConfigReader ► GetConfigNode()()()
Gets the root config node (ie. sitecore)
Declaration Syntax
C#
public static XmlNode GetConfigNode()
Return Value
Root configuration node. If no node is found, null is returned.
Examples
Get the number of nodes below the <sitecore> node in web.config:
CopyC#
XmlNode node = ConfigReader.GetConfigNode();
Mainutil.Out("Config nodes: " + node.ChildNodes.Count);
 Outputs: Config nodes: 43


GetConfigNode Method (xpath)

GetConfigNode Method (xpath)
Namespaces ► Sitecore.Configuration ► ConfigReader ► GetConfigNode(String)
Gets a specific config node.
Declaration Syntax
C#
public static XmlNode GetConfigNode(
    string xpath
)
Parameters
xpath (String)
XPath of node to find (relative to the sitecore node).
Return Value
Requested configuration node. If no node is found, null is returned.
Remarks
The xpath must be relative to the sitecore node. It must never start with /
Examples
Get the config node for the database requirement setting:
CopyC#
XmlNode node = ConfigReader.GetConfigNode("requirements/database");
MainUtil.Out("Required version: " + Xmlutil.getAttribute("version", node));
 Outputs: Required version: 4.3.1


GetConfigNodes Method (xpath)

GetConfigNodes Method (xpath)
Namespaces ► Sitecore.Configuration ► ConfigReader ► GetConfigNodes(String)
Gets a list of config nodes matching an xpath.
Declaration Syntax
C#
public static XmlNodeList GetConfigNodes(
    string xpath
)
Parameters
xpath (String)
XPath of node to find (relative to the sitecore node).
Return Value
Requested configuration nodes. If no nodes are found, null is returned.
Remarks
The xpath must be relative to the sitecore node. It must never start with /
Examples
Get the list of item event handlers:
CopyC#
XmlNodeList nodes = ConfigReader.GetConfigNodes("eventHandlers/items");
foreach(XmlNode node in nodes) {
MainUtil.Out("Type: " + XmlUtil.GetAttribute("type", node));
}
 Outputs:
CopyC#
Type: Sitecore.Logging
Type: Sitecore.WebEdit.ItemEventHandler
Type: Sitecore.Preview.ItemEventHandler


GetImplementationNode Method (interface, configName)

GetImplementationNode Method (interface, configName)
Namespaces ► Sitecore.Configuration ► ConfigReader ► GetImplementationNode(String, String)
Gets a specific implementation node.
Declaration Syntax
C#
public static XmlNode GetImplementationNode(
    string interface,
    string configName
)
Parameters
interface (String)
Name of interface to find an implementation for.
configName (String)
Configuration name of implementation (specified in the configName attribute in web.config).
Return Value
Requested configuration node. If no node is found, null is returned.
Remarks
Implementation nodes are nodes describing 'pluggable' types. These are typically data providers or other types that may vary significantly between installations.
Examples
Get the configuration node for the master database index and display the name of the class implementing it:
CopyC#
XmlNode node = GetImplementationNode(typeof(IIndex), "master");
MainUtil.Out("Master index implemented by: " + XmlUtil.GetAttribute("class", node));
 Outputs: Master index implemented by: Sitecore.Index.


GetNode Method (xpath)

GetNode Method (xpath)
Namespaces ► Sitecore.Configuration ► ConfigReader ► GetNode(String)
Get an xml node.
Declaration Syntax
C#
protected XmlNode GetNode(
    string xpath
)
Parameters
xpath (String)
The xpath.
Return Value
The node.


GetNodes Method (xpath)

GetNodes Method (xpath)
Namespaces ► Sitecore.Configuration ► ConfigReader ► GetNodes(String)
Get a list of xml nodes.
Declaration Syntax
C#
protected XmlNodeList GetNodes(
    string xpath
)
Parameters
xpath (String)
The xpath.
Return Value
The nodes.


ConfigRecord Class

ConfigRecord Class
Namespaces ► Sitecore.Configuration ► ConfigRecord
ConfigRecord class
Declaration Syntax
C#
public abstract class ConfigRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigRecord(String, ConfigStore) | Initializes a new instance of the ConfigRecord class.
 | AddRecord(String) | Adds the record.
 | AddRecord(String, String, array<String>[]()[]) | Adds a new child record to the record.
 | Attributes | Gets the attributes.
 | ConfigStore | Gets the store.
 | CreateObject<(Of <(T>)>)()()() | Creates the object represented by the record.
 | CreateObjects<(Of <(T>)>)(String) | Creates objects from all child record with the name specified in recordName.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildRecord(String) | Gets a child record with the specified name.
 | GetChildRecords()()() | Gets all child records.
 | GetChildRecords(String) | Gets all child records with the specified name.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNamedChildRecord(String, String) | Gets a named child record.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the textual value of the record.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Remove()()() | Removes the record from the config store.
 | SetAttribute(String, String) | Sets the attribute.
 | SetValue(String) | Sets the textual value of the record.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ConfigRecord
 |  | XmlConfigRecord


ConfigRecord Constructor (name, store)

ConfigRecord Constructor (name, store)
Namespaces ► Sitecore.Configuration ► ConfigRecord ► ConfigRecord(String, ConfigStore)
Initializes a new instance of the ConfigRecord class.
Declaration Syntax
C#
protected ConfigRecord(
    string name,
    ConfigStore store
)
Parameters
name (String)
The name.
store (ConfigStore)
The store.


AddRecord Method

AddRecord Method
Namespaces ► Sitecore.Configuration ► ConfigRecord ► AddRecord()()()
Members
Icon | Member | Description
 | AddRecord(String) | Adds the record.
 | AddRecord(String, String, array<String>[]()[]) | Adds a new child record to the record.


AddRecord Method (recordName)

AddRecord Method (recordName)
Namespaces ► Sitecore.Configuration ► ConfigRecord ► AddRecord(String)
Adds the record.
Declaration Syntax
C#
public abstract ConfigRecord AddRecord(
    string recordName
)
Parameters
recordName (String)
Name of the record.
Return Value


AddRecord Method (recordName, value, attributes)

AddRecord Method (recordName, value, attributes)
Namespaces ► Sitecore.Configuration ► ConfigRecord ► AddRecord(String, String, array<String>[]()[])
Adds a new child record to the record.
Declaration Syntax
C#
public virtual ConfigRecord AddRecord(
    string recordName,
    string value,
    params string[] attributes
)
Parameters
recordName (String)
Name of the record.
value (String)
The textual value of the record (pass the empty string if the record holds no value).
attributes (array< String >[]()[])
The attributes (must be alternating between attribute name and value).
Return Value


Attributes Property

Attributes Property
Namespaces ► Sitecore.Configuration ► ConfigRecord ► Attributes
Gets the attributes.
Declaration Syntax
C#
public abstract AttributeList Attributes { get; }
Value
The attributes.


ConfigStore Property

ConfigStore Property
Namespaces ► Sitecore.Configuration ► ConfigRecord ► ConfigStore
Gets the store.
Declaration Syntax
C#
public ConfigStore ConfigStore { get; }
Value
The store.


CreateObject Method

CreateObject<(Of <(T>)>) Method
Namespaces ► Sitecore.Configuration ► ConfigRecord ► CreateObject<(Of <(T>)>)()()()
Creates the object represented by the record.
Declaration Syntax
C#
public abstract T CreateObject<T>()
where T : class
Generic Template Parameters
T
Return Value


CreateObjects Method (recordName)

CreateObjects<(Of <(T>)>) Method (recordName)
Namespaces ► Sitecore.Configuration ► ConfigRecord ► CreateObjects<(Of <(T>)>)(String)
Creates objects from all child record with the name specified in recordName.
Declaration Syntax
C#
public List<T> CreateObjects<T>(
    string recordName
)
where T : class
Generic Template Parameters
T
Parameters
recordName (String)
Name of the child records.
Return Value


GetChildRecord Method (recordName)

GetChildRecord Method (recordName)
Namespaces ► Sitecore.Configuration ► ConfigRecord ► GetChildRecord(String)
Gets a child record with the specified name.
Declaration Syntax
C#
public abstract ConfigRecord GetChildRecord(
    string recordName
)
Parameters
recordName (String)
Name of the record.
Return Value


GetChildRecords Method

GetChildRecords Method
Namespaces ► Sitecore.Configuration ► ConfigRecord ► GetChildRecords()()()
Members
Icon | Member | Description
 | GetChildRecords()()() | Gets all child records.
 | GetChildRecords(String) | Gets all child records with the specified name.


GetChildRecords Method

GetChildRecords Method
Namespaces ► Sitecore.Configuration ► ConfigRecord ► GetChildRecords()()()
Gets all child records.
Declaration Syntax
C#
public abstract List<ConfigRecord> GetChildRecords()
Return Value


GetChildRecords Method (recordName)

GetChildRecords Method (recordName)
Namespaces ► Sitecore.Configuration ► ConfigRecord ► GetChildRecords(String)
Gets all child records with the specified name.
Declaration Syntax
C#
public abstract List<ConfigRecord> GetChildRecords(
    string recordName
)
Parameters
recordName (String)
Name of the record.
Return Value


GetNamedChildRecord Method (recordName, name)

GetNamedChildRecord Method (recordName, name)
Namespaces ► Sitecore.Configuration ► ConfigRecord ► GetNamedChildRecord(String, String)
Gets a named child record.
Declaration Syntax
C#
public abstract ConfigRecord GetNamedChildRecord(
    string recordName,
    string name
)
Parameters
recordName (String)
Name of the record.
name (String)
The name.


GetValue Method

GetValue Method
Namespaces ► Sitecore.Configuration ► ConfigRecord ► GetValue()()()
Gets the textual value of the record.
Declaration Syntax
C#
public abstract string GetValue()


Name Property

Name Property
Namespaces ► Sitecore.Configuration ► ConfigRecord ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Remove Method

Remove Method
Namespaces ► Sitecore.Configuration ► ConfigRecord ► Remove()()()
Removes the record from the config store.
Declaration Syntax
C#
public abstract void Remove()


SetAttribute Method (attributeName, value)

SetAttribute Method (attributeName, value)
Namespaces ► Sitecore.Configuration ► ConfigRecord ► SetAttribute(String, String)
Sets the attribute.
Declaration Syntax
C#
public abstract void SetAttribute(
    string attributeName,
    string value
)
Parameters
attributeName (String)
Name of the attribute.
value (String)
The value.


SetValue Method (value)

SetValue Method (value)
Namespaces ► Sitecore.Configuration ► ConfigRecord ► SetValue(String)
Sets the textual value of the record.
Declaration Syntax
C#
public abstract void SetValue(
    string value
)
Parameters
value (String)
The value.


ConfigStore Class

ConfigStore Class
Namespaces ► Sitecore.Configuration ► ConfigStore
ConfigStore class
Declaration Syntax
C#
public abstract class ConfigStore
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigStore()()() | Initializes a new instance of the ConfigStore class
 | CommitChanges()()() | Commits the changes.
 | ConfigChanged | Occurs when configuration has been changed (externally).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTemplateRecord(String, String) | Gets the template record.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Load(String) | Loads the specified config store name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotifyConfigChanged()()() | Notify subscribers that the configuration has changed.
 | RootRecord | Gets the root record.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ConfigStore
 |  | XmlConfigStore


ConfigStore Constructor

ConfigStore Constructor
Namespaces ► Sitecore.Configuration ► ConfigStore ► ConfigStore()()()
Initializes a new instance of the ConfigStore class
Declaration Syntax
C#
protected ConfigStore()


CommitChanges Method

CommitChanges Method
Namespaces ► Sitecore.Configuration ► ConfigStore ► CommitChanges()()()
Commits the changes.
Declaration Syntax
C#
public abstract void CommitChanges()


ConfigChanged Event

ConfigChanged Event
Namespaces ► Sitecore.Configuration ► ConfigStore ► ConfigChanged
Occurs when configuration has been changed (externally).
Declaration Syntax
C#
public event EventHandler ConfigChanged


GetTemplateRecord Method (recordName, templateName)

GetTemplateRecord Method (recordName, templateName)
Namespaces ► Sitecore.Configuration ► ConfigStore ► GetTemplateRecord(String, String)
Gets the template record.
Declaration Syntax
C#
public virtual ConfigRecord GetTemplateRecord(
    string recordName,
    string templateName
)
Parameters
recordName (String)
Name of the record.
templateName (String)
Name of the template.
Return Value


Load Method (configStoreName)

Load Method (configStoreName)
Namespaces ► Sitecore.Configuration ► ConfigStore ► Load(String)
Loads the specified config store name.
Declaration Syntax
C#
public static ConfigStore Load(
    string configStoreName
)
Parameters
configStoreName (String)
Name of the config store.
Return Value


NotifyConfigChanged Method

NotifyConfigChanged Method
Namespaces ► Sitecore.Configuration ► ConfigStore ► NotifyConfigChanged()()()
Notify subscribers that the configuration has changed.
Declaration Syntax
C#
protected virtual void NotifyConfigChanged()


RootRecord Property

RootRecord Property
Namespaces ► Sitecore.Configuration ► ConfigStore ► RootRecord
Gets the root record.
Declaration Syntax
C#
public abstract ConfigRecord RootRecord { get; }
Value
The root record.


ConfigurationAction Enumeration

ConfigurationAction Enumeration
Namespaces ► Sitecore.Configuration ► ConfigurationAction
ConfigurationAction class
Declaration Syntax
C#
public enum ConfigurationAction
Members
Member | Description
AddRecord | Add a new record to the configuration store.
RemoveRecord | Remove an existing record.
UpdateRecord | Update an existing record.


ConfigWatcher Class

ConfigWatcher Class
Namespaces ► Sitecore.Configuration ► ConfigWatcher
Monitors the /App_Config folder for changes.
Declaration Syntax
C#
public class ConfigWatcher : FileWatcher
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigWatcher()()() | Initializes a new instance of the ConfigWatcher class.
 | ConfigChanged |
 | Created(String) | Called when a file has been created. (Overrides FileWatcher.Created(String).)
 | Deleted(String) | Called when a file has been deleted. (Overrides FileWatcher.Deleted(String).)
 | Dispose()()() | Application shutdown handler (Inherited from FileWatcher.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(HttpApplication) | Application startup handler (Inherited from FileWatcher.)
 | InitializeWatcher(String, String) | Initializes a file watcher. (Inherited from FileWatcher.)
 | InitializeWorker()()() | Initializes the worker. (Inherited from FileWatcher.)
 | MapPathToSiteCore(String, String, String) | Maps the path to a Sitecore path. (Inherited from FileWatcher.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnFileCreated(Object, FileSystemEventArgs) | File has been created. (Inherited from FileWatcher.)
 | OnFileDeleted(Object, FileSystemEventArgs) | File has been deleted. (Inherited from FileWatcher.)
 | OnFileRenamed(Object, RenamedEventArgs) | File has been renamed. (Inherited from FileWatcher.)
 | PathShouldBeIngnored(String) | Checks whether the pathes the should be ingnored. (Inherited from FileWatcher.)
 | PostponeEvents()()() | Postpones the execution.
 | Renamed(String, String) | Called when a file has been renamed. (Overrides FileWatcher.Renamed(String, String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FileWatcher
 |  | ConfigWatcher


ConfigWatcher Constructor

ConfigWatcher Constructor
Namespaces ► Sitecore.Configuration ► ConfigWatcher ► ConfigWatcher()()()
Initializes a new instance of the ConfigWatcher class.
Declaration Syntax
C#
public ConfigWatcher()


ConfigChanged Event

ConfigChanged Event
Namespaces ► Sitecore.Configuration ► ConfigWatcher ► ConfigChanged
Declaration Syntax
C#
public static event EventHandler<ConfigChangedEventArgs> ConfigChanged


Created Method (filePath)

Created Method (filePath)
Namespaces ► Sitecore.Configuration ► ConfigWatcher ► Created(String)
Called when a file has been created.
Declaration Syntax
C#
protected override void Created(
    string filePath
)
Parameters
filePath (String)
The file path.


Deleted Method (filePath)

Deleted Method (filePath)
Namespaces ► Sitecore.Configuration ► ConfigWatcher ► Deleted(String)
Called when a file has been deleted.
Declaration Syntax
C#
protected override void Deleted(
    string filePath
)
Parameters
filePath (String)
The full path.


PostponeEvents Method

PostponeEvents Method
Namespaces ► Sitecore.Configuration ► ConfigWatcher ► PostponeEvents()()()
Postpones the execution.
Declaration Syntax
C#
public static IDisposable PostponeEvents()
Return Value


Renamed Method (filePath, oldFilePath)

Renamed Method (filePath, oldFilePath)
Namespaces ► Sitecore.Configuration ► ConfigWatcher ► Renamed(String, String)
Called when a file has been renamed.
Declaration Syntax
C#
protected override void Renamed(
    string filePath,
    string oldFilePath
)
Parameters
filePath (String)
The full path.
oldFilePath (String)
The old full path.


Factory Class

Factory Class
Namespaces ► Sitecore.Configuration ► Factory
The Factory.
Declaration Syntax
C#
public static class Factory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreateErrorControl(String, String) | Creates an error control.
 | CreateItemNavigator(Item) | Creates an item navigator.
 | CreateObject<(Of <(T>)>)(XmlNode) | Creates an object from a configuration node.
 | CreateObject(String, Boolean) | Creates the object.
 | CreateObject(String, array<String>[]()[], Boolean) | Creates the object.
 | CreateObject(XmlNode, Boolean) | Creates the object.
 | CreateObject(XmlNode, array<String>[]()[], Boolean) | Creates the object.
 | CreateObject(XmlNode, array<String>[]()[], Boolean, IFactoryHelper) | Creates the object.
 | CreateType(XmlNode, Boolean) | Creates the type.
 | CreateType(XmlNode, array<String>[]()[], Boolean) | Creates the type.
 | FindType(String, Assembly) | Finds the type.
 | GetAttribute(String, XmlNode, array<String>[]()[]) | Gets the attribute.
 | GetConfigNode(String) | Gets a config node.
 | GetConfigNode(String, Boolean) | Gets a config node.
 | GetConfigNodes(String) | Gets a set of config nodes.
 | GetConfigStore(String) | Gets the config store.
 | GetConfiguration()()() | Gets the configuration.
 | GetCustomHandlers()()() | Gets the request handlers.
 | GetDatabase(String) | Gets the database.
 | GetDatabase(String, Boolean) | Gets the database.
 | GetDatabaseNames()()() | Gets the database names.
 | GetDatabases()()() | Gets all databases.
 | GetDomain(String) | Gets the domain.
 | GetDomainMap(String) | Gets the domain map.
 | GetDomainNames()()() | Gets the domain names.
 | GetHashtable(String, Factory..::.HashKeyType, Factory..::.HashValueType, Factory..::.HashValueFormat, Type) | Gets the hash table.
 | GetIDTable()()() | Gets the ID table.
 | GetIndex(String) | Gets the index.
 | GetItemComparer(Item) | Gets an item comparer.
 | GetLinkDatabase()()() | Gets the link database.
 | GetMasterVariablesReplacer()()() | Gets the object used for replacing variables when creating a master.
 | GetPerformanceCounters()()() | Gets the performance counters.
 | GetProviders<(Of <(TProvider, TCollection>)>)(String, TProvider%) | Gets a list of providers.
 | GetReplacer(String) | Gets the replacer.
 | GetSite(String) | Gets the site.
 | GetSiteInfo(String) | Gets the site info.
 | GetSiteInfoList()()() | Gets a list of all site info instances.
 | GetSiteNames()()() | Gets the site names.
 | GetSites()()() | Obsolete. Gets all sites.
 | GetSitesInfo()()() | Obsolete. Gets a list of all site info instances.
 | GetString(String, Boolean) | Gets the string.
 | GetStringSet(String) | Gets a string set from config.
 | GetTaskDatabase()()() | Gets the task database.
 | Reset()()() | Resets all cached information.
Inheritance Hierarchy
Object
Factory


CreateErrorControl Method (message, details)

CreateErrorControl Method (message, details)
Namespaces ► Sitecore.Configuration ► Factory ► CreateErrorControl(String, String)
Creates an error control.
Declaration Syntax
C#
public static ErrorControl CreateErrorControl(
    string message,
    string details
)
Parameters
message (String)
The message.
details (String)
The details.
Return Value


CreateItemNavigator Method (item)

CreateItemNavigator Method (item)
Namespaces ► Sitecore.Configuration ► Factory ► CreateItemNavigator(Item)
Creates an item navigator.
Declaration Syntax
C#
public static ItemNavigator CreateItemNavigator(
    Item item
)
Parameters
item (Item)
The item.
Return Value


CreateObject Method

CreateObject Method
Namespaces ► Sitecore.Configuration ► Factory ► CreateObject()()()
Members
Icon | Member | Description
 | CreateObject<(Of <(T>)>)(XmlNode) | Creates an object from a configuration node.
 | CreateObject(String, Boolean) | Creates the object.
 | CreateObject(String, array<String>[]()[], Boolean) | Creates the object.
 | CreateObject(XmlNode, Boolean) | Creates the object.
 | CreateObject(XmlNode, array<String>[]()[], Boolean) | Creates the object.
 | CreateObject(XmlNode, array<String>[]()[], Boolean, IFactoryHelper) | Creates the object.


CreateObject Method (configPath, assert)

CreateObject Method (configPath, assert)
Namespaces ► Sitecore.Configuration ► Factory ► CreateObject(String, Boolean)
Creates the object.
Declaration Syntax
C#
public static Object CreateObject(
    string configPath,
    bool assert
)
Parameters
configPath (String)
The config path.
assert (Boolean)
if set to true this instance is assert.
Return Value


CreateObject Method (configPath, parameters, assert)

CreateObject Method (configPath, parameters, assert)
Namespaces ► Sitecore.Configuration ► Factory ► CreateObject(String, array<String>[]()[], Boolean)
Creates the object.
Declaration Syntax
C#
public static Object CreateObject(
    string configPath,
    string[] parameters,
    bool assert
)
Parameters
configPath (String)
The config path.
parameters (array< String >[]()[])
The parameters.
assert (Boolean)
if set to true this instance is assert.
Return Value


CreateObject Method (configNode)

CreateObject<(Of <(T>)>) Method (configNode)
Namespaces ► Sitecore.Configuration ► Factory ► CreateObject<(Of <(T>)>)(XmlNode)
Creates an object from a configuration node.
Declaration Syntax
C#
public static T CreateObject<T>(
    XmlNode configNode
)
where T : class
Generic Template Parameters
T
The type of object to create.
Parameters
configNode (XmlNode)
The config node.
Return Value


CreateObject Method (configNode, assert)

CreateObject Method (configNode, assert)
Namespaces ► Sitecore.Configuration ► Factory ► CreateObject(XmlNode, Boolean)
Creates the object.
Declaration Syntax
C#
public static Object CreateObject(
    XmlNode configNode,
    bool assert
)
Parameters
configNode (XmlNode)
The config node.
assert (Boolean)
if set to true this instance is assert.
Return Value


CreateObject Method (configNode, parameters, assert)

CreateObject Method (configNode, parameters, assert)
Namespaces ► Sitecore.Configuration ► Factory ► CreateObject(XmlNode, array<String>[]()[], Boolean)
Creates the object.
Declaration Syntax
C#
public static Object CreateObject(
    XmlNode configNode,
    string[] parameters,
    bool assert
)
Parameters
configNode (XmlNode)
The config node.
parameters (array< String >[]()[])
The parameters.
assert (Boolean)
if set to true this instance is assert.
Return Value


CreateObject Method (configNode, parameters, assert, helper)

CreateObject Method (configNode, parameters, assert, helper)
Namespaces ► Sitecore.Configuration ► Factory ► CreateObject(XmlNode, array<String>[]()[], Boolean, IFactoryHelper)
Creates the object.
Declaration Syntax
C#
public static Object CreateObject(
    XmlNode configNode,
    string[] parameters,
    bool assert,
    IFactoryHelper helper
)
Parameters
configNode (XmlNode)
The config node.
parameters (array< String >[]()[])
The parameters.
assert (Boolean)
If set to true throw an exception if the object could not be created.
helper (IFactoryHelper)
The helper.
Return Value
The object.


CreateType Method

CreateType Method
Namespaces ► Sitecore.Configuration ► Factory ► CreateType()()()
Members
Icon | Member | Description
 | CreateType(XmlNode, Boolean) | Creates the type.
 | CreateType(XmlNode, array<String>[]()[], Boolean) | Creates the type.


CreateType Method (configNode, assert)

CreateType Method (configNode, assert)
Namespaces ► Sitecore.Configuration ► Factory ► CreateType(XmlNode, Boolean)
Creates the type.
Declaration Syntax
C#
public static Type CreateType(
    XmlNode configNode,
    bool assert
)
Parameters
configNode (XmlNode)
The config node.
assert (Boolean)
if set to true this instance is assert.
Return Value


CreateType Method (configNode, parameters, assert)

CreateType Method (configNode, parameters, assert)
Namespaces ► Sitecore.Configuration ► Factory ► CreateType(XmlNode, array<String>[]()[], Boolean)
Creates the type.
Declaration Syntax
C#
public static Type CreateType(
    XmlNode configNode,
    string[] parameters,
    bool assert
)
Parameters
configNode (XmlNode)
The config node.
parameters (array< String >[]()[])
The parameters.
assert (Boolean)
if set to true this instance is assert.
Return Value


FindType Method (className, assembly)

FindType Method (className, assembly)
Namespaces ► Sitecore.Configuration ► Factory ► FindType(String, Assembly)
Finds the type.
Declaration Syntax
C#
public static Type FindType(
    string className,
    Assembly assembly
)
Parameters
className (String)
Name of the class.
assembly (Assembly)
The assembly.
Return Value


GetAttribute Method (name, node, parameters)

GetAttribute Method (name, node, parameters)
Namespaces ► Sitecore.Configuration ► Factory ► GetAttribute(String, XmlNode, array<String>[]()[])
Gets the attribute.
Declaration Syntax
C#
public static string GetAttribute(
    string name,
    XmlNode node,
    string[] parameters
)
Parameters
name (String)
The name.
node (XmlNode)
The node.
parameters (array< String >[]()[])
The parameters.
Return Value
The attribute.


GetConfigNode Method

GetConfigNode Method
Namespaces ► Sitecore.Configuration ► Factory ► GetConfigNode()()()
Members
Icon | Member | Description
 | GetConfigNode(String) | Gets a config node.
 | GetConfigNode(String, Boolean) | Gets a config node.


GetConfigNode Method (xpath)

GetConfigNode Method (xpath)
Namespaces ► Sitecore.Configuration ► Factory ► GetConfigNode(String)
Gets a config node.
Declaration Syntax
C#
public static XmlNode GetConfigNode(
    string xpath
)
Parameters
xpath (String)
The Xpath.
Return Value
The config node.


GetConfigNode Method (xpath, assert)

GetConfigNode Method (xpath, assert)
Namespaces ► Sitecore.Configuration ► Factory ► GetConfigNode(String, Boolean)
Gets a config node.
Declaration Syntax
C#
public static XmlNode GetConfigNode(
    string xpath,
    bool assert
)
Parameters
xpath (String)
The Xpath.
assert (Boolean)
if set to true assert that the node is not null.
Return Value
The config node.


GetConfigNodes Method (xpath)

GetConfigNodes Method (xpath)
Namespaces ► Sitecore.Configuration ► Factory ► GetConfigNodes(String)
Gets a set of config nodes.
Declaration Syntax
C#
public static XmlNodeList GetConfigNodes(
    string xpath
)
Parameters
xpath (String)
The Xpath.
Return Value


GetConfigStore Method (configStoreName)

GetConfigStore Method (configStoreName)
Namespaces ► Sitecore.Configuration ► Factory ► GetConfigStore(String)
Gets the config store.
Declaration Syntax
C#
public static ConfigStore GetConfigStore(
    string configStoreName
)
Parameters
configStoreName (String)
Name of the config store.
Return Value


GetConfiguration Method

GetConfiguration Method
Namespaces ► Sitecore.Configuration ► Factory ► GetConfiguration()()()
Gets the configuration.
Declaration Syntax
C#
public static XmlDocument GetConfiguration()
Return Value
Xml document containing the entire Sitecore configuration.


GetCustomHandlers Method

GetCustomHandlers Method
Namespaces ► Sitecore.Configuration ► Factory ► GetCustomHandlers()()()
Gets the request handlers.
Declaration Syntax
C#
public static List<CustomHandler> GetCustomHandlers()
Return Value
The request handlers.
Exceptions
Exception | Condition
InvalidOperationException | InvalidOperationException.


GetDatabase Method

GetDatabase Method
Namespaces ► Sitecore.Configuration ► Factory ► GetDatabase()()()
Members
Icon | Member | Description
 | GetDatabase(String) | Gets the database.
 | GetDatabase(String, Boolean) | Gets the database.


GetDatabase Method (name)

GetDatabase Method (name)
Namespaces ► Sitecore.Configuration ► Factory ► GetDatabase(String)
Gets the database.
Declaration Syntax
C#
public static Database GetDatabase(
    string name
)
Parameters
name (String)
The name.
Return Value


GetDatabase Method (name, assert)

GetDatabase Method (name, assert)
Namespaces ► Sitecore.Configuration ► Factory ► GetDatabase(String, Boolean)
Gets the database.
Declaration Syntax
C#
public static Database GetDatabase(
    string name,
    bool assert
)
Parameters
name (String)
The name.
assert (Boolean)
if set to true this instance is assert.
Return Value


GetDatabaseNames Method

GetDatabaseNames Method
Namespaces ► Sitecore.Configuration ► Factory ► GetDatabaseNames()()()
Gets the database names.
Declaration Syntax
C#
public static string[] GetDatabaseNames()
Return Value


GetDatabases Method

GetDatabases Method
Namespaces ► Sitecore.Configuration ► Factory ► GetDatabases()()()
Gets all databases.
Declaration Syntax
C#
public static List<Database> GetDatabases()
Return Value


GetDomain Method (name)

GetDomain Method (name)
Namespaces ► Sitecore.Configuration ► Factory ► GetDomain(String)
Gets the domain.
Declaration Syntax
C#
public static Domain GetDomain(
    string name
)
Parameters
name (String)
The name.
Return Value


GetDomainMap Method (path)

GetDomainMap Method (path)
Namespaces ► Sitecore.Configuration ► Factory ► GetDomainMap(String)
Gets the domain map.
Declaration Syntax
C#
public static StringDictionary GetDomainMap(
    string path
)
Parameters
path (String)
The path.
Return Value


GetDomainNames Method

GetDomainNames Method
Namespaces ► Sitecore.Configuration ► Factory ► GetDomainNames()()()
Gets the domain names.
Declaration Syntax
C#
public static string[] GetDomainNames()
Return Value


GetHashtable Method (path, keyType, valueType, format, dataType)

GetHashtable Method (path, keyType, valueType, format, dataType)
Namespaces ► Sitecore.Configuration ► Factory ► GetHashtable(String, Factory..::.HashKeyType, Factory..::.HashValueType, Factory..::.HashValueFormat, Type)
Gets the hash table.
Declaration Syntax
C#
public static Hashtable GetHashtable(
    string path,
    Factory..::.HashKeyType keyType,
    Factory..::.HashValueType valueType,
    Factory..::.HashValueFormat format,
    Type dataType
)
Parameters
path (String)
The path.
keyType (Factory..::.HashKeyType)
Type of the key.
valueType (Factory..::.HashValueType)
Type of the value.
format (Factory..::.HashValueFormat)
The format.
dataType (Type)
Type of the data.
Return Value


GetIDTable Method

GetIDTable Method
Namespaces ► Sitecore.Configuration ► Factory ► GetIDTable()()()
Gets the ID table.
Declaration Syntax
C#
public static IDTableProvider GetIDTable()
Return Value


GetIndex Method (name)

GetIndex Method (name)
Namespaces ► Sitecore.Configuration ► Factory ► GetIndex(String)
Gets the index.
Declaration Syntax
C#
public static Index GetIndex(
    string name
)
Parameters
name (String)
The name.
Return Value


GetItemComparer Method (item)

GetItemComparer Method (item)
Namespaces ► Sitecore.Configuration ► Factory ► GetItemComparer(Item)
Gets an item comparer.
Declaration Syntax
C#
public static IComparer<Item> GetItemComparer(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetLinkDatabase Method

GetLinkDatabase Method
Namespaces ► Sitecore.Configuration ► Factory ► GetLinkDatabase()()()
Gets the link database.
Declaration Syntax
C#
public static LinkDatabase GetLinkDatabase()
Return Value
Exceptions
Exception | Condition
InvalidTypeException | LinkDatabase object is of wrong type


GetMasterVariablesReplacer Method

GetMasterVariablesReplacer Method
Namespaces ► Sitecore.Configuration ► Factory ► GetMasterVariablesReplacer()()()
Gets the object used for replacing variables when creating a master.
Declaration Syntax
C#
public static MasterVariablesReplacer GetMasterVariablesReplacer()
Return Value


GetPerformanceCounters Method

GetPerformanceCounters Method
Namespaces ► Sitecore.Configuration ► Factory ► GetPerformanceCounters()()()
Gets the performance counters.
Declaration Syntax
C#
public static PerformanceCounterCollection GetPerformanceCounters()
Return Value
The performance counters.


GetProviders Method (rootPath, defaultProvider)

GetProviders<(Of <(TProvider, TCollection>)>) Method (rootPath, defaultProvider)
Namespaces ► Sitecore.Configuration ► Factory ► GetProviders<(Of <(TProvider, TCollection>)>)(String, TProvider%)
Gets a list of providers.
Declaration Syntax
C#
public static TCollection GetProviders<TProvider, TCollection>(
    string rootPath,
    out TProvider defaultProvider
)
where TProvider : ProviderBase
where TCollection : new(), ProviderCollection
Generic Template Parameters
TProvider
TCollection
Parameters
rootPath (String)
defaultProvider ( TProvider %)
Return Value
The providers.


GetReplacer Method (name)

GetReplacer Method (name)
Namespaces ► Sitecore.Configuration ► Factory ► GetReplacer(String)
Gets the replacer.
Declaration Syntax
C#
public static Replacer GetReplacer(
    string name
)
Parameters
name (String)
The name.
Return Value
The replacer.


GetSite Method (siteName)

GetSite Method (siteName)
Namespaces ► Sitecore.Configuration ► Factory ► GetSite(String)
Gets the site.
Declaration Syntax
C#
public static SiteContext GetSite(
    string siteName
)
Parameters
siteName (String)
Name of the site.
Return Value
The site.


GetSiteInfo Method (siteName)

GetSiteInfo Method (siteName)
Namespaces ► Sitecore.Configuration ► Factory ► GetSiteInfo(String)
Gets the site info.
Declaration Syntax
C#
public static SiteInfo GetSiteInfo(
    string siteName
)
Parameters
siteName (String)
Name of the site.
Return Value
The site info.


GetSiteInfoList Method

GetSiteInfoList Method
Namespaces ► Sitecore.Configuration ► Factory ► GetSiteInfoList()()()
Gets a list of all site info instances.
Declaration Syntax
C#
public static List<SiteInfo> GetSiteInfoList()
Return Value
Gets all sites.


GetSiteNames Method

GetSiteNames Method
Namespaces ► Sitecore.Configuration ► Factory ► GetSiteNames()()()
Gets the site names.
Declaration Syntax
C#
public static string[] GetSiteNames()
Return Value
The site names.


GetSites Method

GetSites Method
Namespaces ► Sitecore.Configuration ► Factory ► GetSites()()()
Gets all sites.
Declaration Syntax
C#
[ObsoleteAttribute("Use GetSitesInfo() method instead")]
public static List<SiteContext> GetSites()
Return Value
The sites.


GetSitesInfo Method

GetSitesInfo Method
Namespaces ► Sitecore.Configuration ► Factory ► GetSitesInfo()()()
Gets a list of all site info instances.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use GetSiteInfoList instead.")]
public static List<SiteInfo> GetSitesInfo()
Return Value
Gets all sites.


GetString Method (configPath, assert)

GetString Method (configPath, assert)
Namespaces ► Sitecore.Configuration ► Factory ► GetString(String, Boolean)
Gets the string.
Declaration Syntax
C#
public static string GetString(
    string configPath,
    bool assert
)
Parameters
configPath (String)
The config path.
assert (Boolean)
if set to true this instance is assert.
Return Value
The string.


GetStringSet Method (configPath)

GetStringSet Method (configPath)
Namespaces ► Sitecore.Configuration ► Factory ► GetStringSet(String)
Gets a string set from config.
Declaration Syntax
C#
public static Set<string> GetStringSet(
    string configPath
)
Parameters
configPath (String)
The config path.
Return Value


GetTaskDatabase Method

GetTaskDatabase Method
Namespaces ► Sitecore.Configuration ► Factory ► GetTaskDatabase()()()
Gets the task database.
Declaration Syntax
C#
public static TaskDatabase GetTaskDatabase()
Return Value
The task database.
Exceptions
Exception | Condition
InvalidTypeException | TaskDatabase object is of wrong type


Reset Method

Reset Method
Namespaces ► Sitecore.Configuration ► Factory ► Reset()()()
Resets all cached information.
Declaration Syntax
C#
public static void Reset()
Remarks
This will cause all configuration data to be reloaded.


Factory.HashKeyType Enumeration

Factory..::.HashKeyType Enumeration
Namespaces ► Sitecore.Configuration ► Factory ► Factory..::.HashKeyType
Represents a HashKeyType.
Declaration Syntax
C#
public enum HashKeyType
Members
Member | Description
NodeName | Node name.


Factory.HashValueFormat Enumeration

Factory..::.HashValueFormat Enumeration
Namespaces ► Sitecore.Configuration ► Factory ► Factory..::.HashValueFormat
Represents a HashValueFormat.
Declaration Syntax
C#
public enum HashValueFormat
Members
Member | Description
SingleObject | Single object.
Array | Array.


Factory.HashValueType Enumeration

Factory..::.HashValueType Enumeration
Namespaces ► Sitecore.Configuration ► Factory ► Factory..::.HashValueType
Represents a HashValueType.
Declaration Syntax
C#
public enum HashValueType
Members
Member | Description
NodeName | Node name.
Object | Object.


FileDataStore Class

FileDataStore Class
Namespaces ► Sitecore.Configuration ► FileDataStore
Represents a FileDataStore.
Declaration Syntax
C#
public class FileDataStore : ClientDataStore
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileDataStore(String, String) | Initializes a new instance of the FileDataStore class.
 | AddDataToCache(String, Hashtable, Int64) | Adds data to the cache. (Inherited from ClientDataStore.)
 | Compact()()() | Compacts this instance. (Inherited from ClientDataStore.)
 | CompactData()()() | Compacts the data. (Overrides ClientDataStore.CompactData()()().)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataFromCache(String) | Gets data from the cache. (Inherited from ClientDataStore.)
 | GetDataKey()()() | Gets the data key. (Inherited from ClientDataStore.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSize(Hashtable) | Gets the size of newly returned data. (Inherited from ClientDataStore.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(String) | Gets the value. (Inherited from ClientDataStore.)
 | GetValueNames()()() | Gets the value names. (Inherited from ClientDataStore.)
 | LoadData(String) | Loads the data. (Overrides ClientDataStore.LoadData(String).)
 | LoadData()()() | Loads the data. (Inherited from ClientDataStore.)
 | LoadViewstate(String) | Loads the viewstate. (Inherited from ClientDataStore.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ObjectLifetime | Gets the object lifetime. (Inherited from ClientDataStore.)
 | RemoveAll()()() | Removes the values. (Inherited from ClientDataStore.)
 | RemoveAllData()()() | Removes all data. (Inherited from ClientDataStore.)
 | RemoveData(String) | Removes the data. (Overrides ClientDataStore.RemoveData(String).)
 | RemoveData()()() | Removes the data. (Inherited from ClientDataStore.)
 | RemoveDataFromCache(String) | Removes data from the cache. (Inherited from ClientDataStore.)
 | RemoveValue(String) | Removes the value. (Inherited from ClientDataStore.)
 | RemoveValues()()() | Removes the values. (Inherited from ClientDataStore.)
 | RemoveViewstate(String) | Removes the viewstate. (Inherited from ClientDataStore.)
 | SaveData(Hashtable) | Saves the data. (Overrides ClientDataStore.SaveData(Hashtable).)
 | SaveData(String, String) | Saves the data. (Overrides ClientDataStore.SaveData(String, String).)
 | SaveViewstate(String, String) | Saves the viewstate. (Inherited from ClientDataStore.)
 | SetValue(String, String) | Sets the value. (Inherited from ClientDataStore.)
 | SetValue(String, Object, String) | Sets the value. (Inherited from ClientDataStore.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TouchActiveData()()() | Touches all active data. (Inherited from ClientDataStore.)
 | TouchData(String) | Touches the data represented by key. (Inherited from ClientDataStore.)
Inheritance Hierarchy
Object
 | ClientDataStore
 |  | FileDataStore


FileDataStore Constructor (baseFolder, objectLifetime)

FileDataStore Constructor (baseFolder, objectLifetime)
Namespaces ► Sitecore.Configuration ► FileDataStore ► FileDataStore(String, String)
Initializes a new instance of the FileDataStore class.
Declaration Syntax
C#
public FileDataStore(
    string baseFolder,
    string objectLifetime
)
Parameters
baseFolder (String)
The base folder.
objectLifetime (String)
The object lifetime.


CompactData Method

CompactData Method
Namespaces ► Sitecore.Configuration ► FileDataStore ► CompactData()()()
Compacts the data.
Declaration Syntax
C#
protected override void CompactData()


LoadData Method (key)

LoadData Method (key)
Namespaces ► Sitecore.Configuration ► FileDataStore ► LoadData(String)
Loads the data.
Declaration Syntax
C#
protected override string LoadData(
    string key
)
Parameters
key (String)
Return Value
The data.


RemoveData Method (key)

RemoveData Method (key)
Namespaces ► Sitecore.Configuration ► FileDataStore ► RemoveData(String)
Removes the data.
Declaration Syntax
C#
protected override void RemoveData(
    string key
)
Parameters
key (String)


SaveData Method

SaveData Method
Namespaces ► Sitecore.Configuration ► FileDataStore ► SaveData()()()
Members
Icon | Member | Description
 | SaveData(Hashtable) | Saves the data. (Overrides ClientDataStore.SaveData(Hashtable).)
 | SaveData(String, String) | Saves the data. (Overrides ClientDataStore.SaveData(String, String).)


SaveData Method (data)

SaveData Method (data)
Namespaces ► Sitecore.Configuration ► FileDataStore ► SaveData(Hashtable)
Saves the data.
Declaration Syntax
C#
protected override void SaveData(
    Hashtable data
)
Parameters
data (Hashtable)
The data.


SaveData Method (key, data)

SaveData Method (key, data)
Namespaces ► Sitecore.Configuration ► FileDataStore ► SaveData(String, String)
Saves the data.
Declaration Syntax
C#
protected override void SaveData(
    string key,
    string data
)
Parameters
key (String)
The key.
data (String)
The data.


IFactoryHelper Interface

IFactoryHelper Interface
Namespaces ► Sitecore.Configuration ► IFactoryHelper
IFactoryHelper class
Declaration Syntax
C#
public interface IFactoryHelper
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SetProperty(XmlNode, Object) | Sets a property on the object being created.


SetProperty Method (propertyNode, objectBeingCreated)

SetProperty Method (propertyNode, objectBeingCreated)
Namespaces ► Sitecore.Configuration ► IFactoryHelper ► SetProperty(XmlNode, Object)
Sets a property on the object being created.
Declaration Syntax
C#
bool SetProperty(
    XmlNode propertyNode,
    Object objectBeingCreated
)
Parameters
propertyNode (XmlNode)
The property node.
objectBeingCreated (Object)
The object being created.
Return Value
true if the helper set the property, false if the factory should set the property itself.


ObjectList Class

ObjectList Class
Namespaces ► Sitecore.Configuration ► ObjectList
Represents an object list.
Declaration Syntax
C#
public class ObjectList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ObjectList(String) | Initializes a new instance of the ObjectList class.
 | Add(String, Object) | Adds the specified key.
 | AddMethod | Gets the add method.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | List | Gets the list.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ObjectList


ObjectList Constructor (addMethod)

ObjectList Constructor (addMethod)
Namespaces ► Sitecore.Configuration ► ObjectList ► ObjectList(String)
Initializes a new instance of the ObjectList class.
Declaration Syntax
C#
public ObjectList(
    string addMethod
)
Parameters
addMethod (String)
The add method.


Add Method (key, value)

Add Method (key, value)
Namespaces ► Sitecore.Configuration ► ObjectList ► Add(String, Object)
Adds the specified key.
Declaration Syntax
C#
public void Add(
    string key,
    Object value
)
Parameters
key (String)
The key.
value (Object)
The value.


AddMethod Property

AddMethod Property
Namespaces ► Sitecore.Configuration ► ObjectList ► AddMethod
Gets the add method.
Declaration Syntax
C#
public string AddMethod { get; }
Value
The add method.


List Property

List Property
Namespaces ► Sitecore.Configuration ► ObjectList ► List
Gets the list.
Declaration Syntax
C#
public ArrayList List { get; }
Value
The list.


ProviderHelper(TProvider, TCollection) Class

ProviderHelper<(Of <(TProvider, TCollection>)>) Class
Namespaces ► Sitecore.Configuration ► ProviderHelper<(Of <(TProvider, TCollection>)>)
ManagerData class
Declaration Syntax
C#
public class ProviderHelper<TProvider, TCollection>
where TProvider : ProviderBase
where TCollection : new(), ProviderCollection
Generic Template Parameters
TProvider
TCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProviderHelper<(Of <(TProvider, TCollection>)>)(String) | Initializes a new instance of the ProviderHelper<(Of <(TProvider, TCollection>)>) class.
 | DefaultProvider | Sets the default provider.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRootAttribute(String) | Gets the root attribute.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Provider | Gets the provider.
 | Providers | Gets all provider.
 | ReadProviders()()() | Reads the providers from configuration.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProviderHelper<(Of <(TProvider, TCollection>)>)


ProviderHelper(TProvider, TCollection) Constructor (configPath)

ProviderHelper<(Of <(TProvider, TCollection>)>) Constructor (configPath)
Namespaces ► Sitecore.Configuration ► ProviderHelper<(Of <(TProvider, TCollection>)>) ► ProviderHelper<(Of <(TProvider, TCollection>)>)(String)
Initializes a new instance of the ProviderHelper<(Of <(TProvider, TCollection>)>) class.
Declaration Syntax
C#
public ProviderHelper(
    string configPath
)
Parameters
configPath (String)
The config path.


DefaultProvider Property

DefaultProvider Property
Namespaces ► Sitecore.Configuration ► ProviderHelper<(Of <(TProvider, TCollection>)>) ► DefaultProvider
Sets the default provider.
Declaration Syntax
C#
public static TProvider DefaultProvider { set; }
Value
The default provider.


GetRootAttribute Method (attributeName)

GetRootAttribute Method (attributeName)
Namespaces ► Sitecore.Configuration ► ProviderHelper<(Of <(TProvider, TCollection>)>) ► GetRootAttribute(String)
Gets the root attribute.
Declaration Syntax
C#
public string GetRootAttribute(
    string attributeName
)
Parameters
attributeName (String)
Name of the attribute.
Return Value


Provider Property

Provider Property
Namespaces ► Sitecore.Configuration ► ProviderHelper<(Of <(TProvider, TCollection>)>) ► Provider
Gets the provider.
Declaration Syntax
C#
public TProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Configuration ► ProviderHelper<(Of <(TProvider, TCollection>)>) ► Providers
Gets all provider.
Declaration Syntax
C#
public TCollection Providers { get; }
Value
The providers.


ReadProviders Method

ReadProviders Method
Namespaces ► Sitecore.Configuration ► ProviderHelper<(Of <(TProvider, TCollection>)>) ► ReadProviders()()()
Reads the providers from configuration.
Declaration Syntax
C#
protected void ReadProviders()


Settings Class

Settings Class
Namespaces ► Sitecore.Configuration ► Settings
The Settings class encapsulates the web.config file and provides easy access to the values therein.
Declaration Syntax
C#
public sealed class Settings
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Settings()()() | Initializes a new instance of the Settings class
 | AccountNameValidation | Gets the default account name validation.
 | AliasesActive | Indicates if aliases are active.
 | AllowLogoutOfAllUsers | Indicates if the logout screen presents all users or just users with the same name.
 | AppendQSToUrlRendering | Indicates if main query strings are appended to URL renderings?
 | AutoMaintainProxyDefinitions | Gets a value indicating whether proxy definitions (items with template Proxy) are maintained by the system automatically. This affects copy, duplicate, archive, recycle and delete operations.
 | AutomaticDataBind | Indicates if the DataBind function is called by the web engine.
 | AutomaticLockOnSave | Gets a value indicating whether the item is automatically locked on save.
 | AutomaticUnlockOnSaved | Gets a value indicating whether the item is automatically unlocked on saved.
 | CheckSecurityOnLanguages | Indicates if security on languages should be checked.
 | ClientLanguage | Gets the default client language.
 | ConfigurationIsSet | Gets a value indicating whether configuration is set.
 | ConnectionStringExists(String) | Determines if the specified connection string exists.
 | DataFolder | Gets the path to the data folder.
 | DataProviderTimeout | Gets the default timeout for data provider commands.
 | DebugBorderColor | Gets the color of debug borders.
 | DebugBorderTag | Gets the html tag to use for debug borders (usually span or div).
 | DebugEnabled | Gets a value indicating whether ASP.NET debuggin is enabled.
 | DebugFolder | Gets the path to the debug folder.
 | DefaultBaseTemplate | The guid of the default base templates.
 | DefaultDesktop | Gets the default desktop.
 | DefaultIcon | Gets the path to the default icon for items in the Sitecore client.
 | DefaultItem | Gets the default item for the Sitecore client.
 | DefaultLanguage | Gets the default language for the web site.
 | DefaultLayoutFile | Gets the path to the layout file to use for items that do not specify a layout file themselves.
 | DefaultPageName | Gets the name of the default ASPX page.
 | DefaultPublishingTargets | Gets a pipe separated list of publishing group names.
 | DefaultRegionalIsoCode | Gets the default regional ISO code.
 | DefaultShellControl | Gets the default shell control.
 | DefaultSortOrder | Gets the default value of the sort order attribute.
 | DefaultSQLTimeout | Gets the default timeout for SQL commands.
 | DefaultTheme | Gets the default Sitecore client theme.
 | DisableBrowserCaching | Indicates if browser caching of pages should be disabled.
 | EnableXslDocumentFunction | Gets a value indicating whether XSLT document() support should be enabled.
 | EnableXslScripts | Gets a value indicating whether XSLT script support should be enabled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorPage | Gets the page to redirect to, if a generic error occurs.
 | FastPublishing | Use fast publishing?
 | FastQueryDescendantsDisabled | Setting this to 'true' will improve performance of item creation/moving/deletion, but will make fast query return incorrect results when selecting items using the Ancestors/Descendants axes.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateThumbnails | Indicates if thumbnails of uploaded image files should be generated.
 | GetAppSetting(String) | Get named application setting.
 | GetAppSetting(String, String) | Get named application setting.
 | GetBoolSetting(String, Boolean) | Get boolean setting.
 | GetConnectionString(String) | Gets a named connection string.
 | GetDoubleSetting(String, Double) | Get double setting.
 | GetFileSetting(String) | Get named setting containg a file path.
 | GetFileSetting(String, String) | Get named setting containg a file path.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIntSetting(String, Int32) | Get int setting.
 | GetLongSetting(String, Int64) | Get long setting.
 | GetNumberOfSettings()()() | Get number of settings.
 | GetProviderObject(String, Type) | Gets the provider object.
 | GetProviderObject(String, String, Type) | Gets the provider object.
 | GetProviderObjects(String, String, Type) | Gets the provider objects.
 | GetSetting(String) | Get named setting.
 | GetSetting(String, String) | Get named setting with default.
 | GetSystemSection<(Of <(T>)>)(String) | Gets a system section from web.config (i.e. a section located beneath system.web).
 | GetTimeSpanSetting(String, String) | Get setting containg a time span (hh:mm:ss)
 | GetTimeSpanSetting(String, TimeSpan) | Get setting containg a time span (hh:mm:ss)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GridPageSize | Gets the number of rows in a UI grid.
 | HashEncryptionProvider | Gets the hash encryption provider.
 | HealthMonitorInterval | Gets the health monitor interval.
 | HeartbeatInterval | Gets the interval between heartbeats.
 | IgnoreUrlPrefixes | Gets a pipe separated list of url prefixes to ignore when mapping friendly urls.
 | ImageTypes | Gets a pipe separated list of image file types (extensions).
 | IncludeProxiesInLinkDatabase | Gets a value indicating whether to include proxy definitions in the link database.
 | IndexFolder | Gets the index folder.
 | InvalidItemNameChars | Gets the invalid item name chars.
 | ItemNameValidation | Gets the item name validation.
 | ItemNotFoundUrl | Gets the url to redirect to, if an item being linked to is not found.
 | KeepLockAfterSaveForAdminUsers | Gets a value indicating whether the item is keeped locked after save in Page Editor for Administator users.
 | LayoutFolder | Gets the path to the layout file root folder.
 | LayoutNotFoundUrl | Gets the url to redirect to, if an items layout is not found.
 | LayoutPageEvent | Gets the name of page event where the layout pipeline will be run.
 | LicenseFile | Gets the path to the license file.
 | LinkItemNotFoundUrl | Gets the url to redirect to, if an item is not found.
 | LogFolder | Gets the path to the log folder.
 | LoginLayout | Gets the name of the layout to use for logging in (to extranet)
 | LoginPage | Gets the path to the page to use for logging in (to extranet)
 | MailServer | Gets the mail server.
 | MailServerPassword | Gets the mail server password.
 | MailServerPort | Gets the mail server port.
 | MailServerUserName | Gets the name of the mail server user.
 | MasterVariablesReplacer | Gets the type of a class used for replacing variables when creating a master.
 | MaxCallLevel | Specifies the maximum allowed depth of a recursive method call.
 | MaxItemNameLength | Specifies the maximum length of an item name.
 | MaxSqlBatchStatements | Gets the maximum number of statements to put in a SqlBatch.
 | MaxTreeDepth | Specifies the maximum allowed depth of an item tree.
 | MaxWorkerThreads | Gets the maximum number of worker threads to use.
 | MediaFolder | Gets the path to the media library root folder.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NoAccessUrl | Gets the url to redirect to, if access to an item is denied.
 | NoLicenseUrl | Gets the url to redirect to, if a license is missing.
 | PackagePath | Specifies the path where package files are located.
 | PortalPrincipalResolver | Gets the portal principal resolver.
 | PortalStorage | Gets the portal storage.
 | ProcessHistoryCount | Gets the number of process histories to show at startup.
 | ProtectedSite | Indicates if the entire site is protected (require login).
 | RecycleBinActive | Indicates if recycle bin is active.
 | RequireLockBeforeEditing | Gets a value indicating whether a lock is required before editing.
 | Reset()()() | Resets this instance.
 | SerializationFolder | Gets the serialization folder.
 | SerializationPassword | Gets the password used for deserializing users.
 | Sites | Gets the list of sites.
 | SystemBlockedUrl | Gets the url to redirect to, if the system has been blocked.
 | TempFolderPath | Gets the temp folder path.
 | ThumbnailHeight | Gets the max height of auto-generated image thumbnails.
 | ThumbnailsBackgroundColor | Gets the color of the thumbnails background.
 | ThumbnailWidth | Gets the maximum width of auto-generated image thumbnails.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnlockAfterCopy | Gets a value indicating whether to unlock items after copying.
 | VersionFilePath | Gets the path to the version file.
 | ViewStateStore | Indicates if ViewState is cached in the GlobalCache in SheerUI.
 | Wallpaper | Gets the wallpaper.
 | WallpapersPath | Gets the wallpapers path.
 | WebStylesheet | Gets the path to the default web site stylesheet.
 | WelcomeTitle | Gets the welcome title to show on the login page.
 | WriteSetting(String, String, Boolean) | Write a setting to web.config.
 | WriteSetting(String, String, String, Boolean) | Write a setting to web.config.
 | XHtmlSchemaFile | Gets the XHTML schema file.
 | XmlControlAspxFile | Gets the extension used for xml control files.
 | XmlControlExtension | Gets the extension used for xml control files.
Inheritance Hierarchy
Object
Settings


Settings Constructor

Settings Constructor
Namespaces ► Sitecore.Configuration ► Settings ► Settings()()()
Initializes a new instance of the Settings class
Declaration Syntax
C#
public Settings()


AccountNameValidation Property

AccountNameValidation Property
Namespaces ► Sitecore.Configuration ► Settings ► AccountNameValidation
Gets the default account name validation.
Declaration Syntax
C#
public static string AccountNameValidation { get; }
Value
The default account name validation.


AliasesActive Property

AliasesActive Property
Namespaces ► Sitecore.Configuration ► Settings ► AliasesActive
Indicates if aliases are active.
Declaration Syntax
C#
public static bool AliasesActive { get; }
Value
True, if aliases are active, otherwise false. Default value: true.
Remarks

When Sitecore renders a page, it first tries to determine the current item from the path on the query string. If the path does not match an item, it search the alias list for matching pages. An alias is a simple pointer to an item in Sitecore. If a match is found, that page is rendered.

Aliases are configured in /sitecore/system/aliases.

Aliases cause a small performance loss as the alias list has to be searched, if the page was not found.

This setting controls if the alias lias search or not.

The name of the web.config setting is "AliasesActive".


AllowLogoutOfAllUsers Property

AllowLogoutOfAllUsers Property
Namespaces ► Sitecore.Configuration ► Settings ► AllowLogoutOfAllUsers
Indicates if the logout screen presents all users or just users with the same name.
Declaration Syntax
C#
public static bool AllowLogoutOfAllUsers { get; }
Value
True, if all users are shown, otherwise false. Default value: false.
Remarks

>When a user logs in, Sitecore checks if the maximum number of users has been reached (as specified in the license). If so, the logout user web page is shown allowing the user to logout a existing session.

This flags is the user is allowed to logout only sessions with the same name as the user, or all other sessions. For instance if the flag is false, the user "Andy" may only logout other sessions created by the user "Andy". If the flag is true, "Andy" can also logout sessions created by "Bob".

The name of the web.config setting is "AllowLogoutOfAllUsers".


AppendQSToUrlRendering Property

AppendQSToUrlRendering Property
Namespaces ► Sitecore.Configuration ► Settings ► AppendQSToUrlRendering
Indicates if main query strings are appended to URL renderings?
Declaration Syntax
C#
public static bool AppendQSToUrlRendering { get; }
Value
Default value: true.
Remarks
If true, query strings of the main page will be passed on the all URL renderings on the page.
Examples
If a layout contains a URL rendering with the url http://www.google.com/search., and the layout is triggered by the url http://localhost/home.aspx?q=sitecore., the url rendering will request the url http://www.google.com/search?q=sitecore.


AutoMaintainProxyDefinitions Property

AutoMaintainProxyDefinitions Property
Namespaces ► Sitecore.Configuration ► Settings ► AutoMaintainProxyDefinitions
Gets a value indicating whether proxy definitions (items with template Proxy) are maintained by the system automatically. This affects copy, duplicate, archive, recycle and delete operations.
Declaration Syntax
C#
public static bool AutoMaintainProxyDefinitions { get; }
Value
true if the Sitecore shall copy/delete proxy definitions automatically; otherwise, false.


AutomaticDataBind Property

AutomaticDataBind Property
Namespaces ► Sitecore.Configuration ► Settings ► AutomaticDataBind
Indicates if the DataBind function is called by the web engine.
Declaration Syntax
C#
public static bool AutomaticDataBind { get; }
Value
True, if DataBind()()() is called, otherwise false. Default value: false.
Remarks
This settings holds the default value for the DataBind State variable.


AutomaticLockOnSave Property

AutomaticLockOnSave Property
Namespaces ► Sitecore.Configuration ► Settings ► AutomaticLockOnSave
Gets a value indicating whether the item is automatically locked on save.
Declaration Syntax
C#
public static bool AutomaticLockOnSave { get; }
Value
true if the item is automatically locked on save; otherwise, false.


AutomaticUnlockOnSaved Property

AutomaticUnlockOnSaved Property
Namespaces ► Sitecore.Configuration ► Settings ► AutomaticUnlockOnSaved
Gets a value indicating whether the item is automatically unlocked on saved.
Declaration Syntax
C#
public static bool AutomaticUnlockOnSaved { get; }
Value
true if the item is automatically unlocked on saved; otherwise, false.


CheckSecurityOnLanguages Property

CheckSecurityOnLanguages Property
Namespaces ► Sitecore.Configuration ► Settings ► CheckSecurityOnLanguages
Indicates if security on languages should be checked.
Declaration Syntax
C#
public static bool CheckSecurityOnLanguages { get; }
Value
Default value: false.
Remarks

If true, the security settings on individual languages will be checked.

This allows the administrator to hide languages from individual users. For instance, security may be set that allows a user to read English and write German.


ClientLanguage Property

ClientLanguage Property
Namespaces ► Sitecore.Configuration ► Settings ► ClientLanguage
Gets the default client language.
Declaration Syntax
C#
public static string ClientLanguage { get; }
Value
Default value: "en"
Remarks

Determines the language of the user interface in the Sitecore client.

This setting will be ignored if a specific client language has been specified for the user (in the user settings).


ConfigurationIsSet Property

ConfigurationIsSet Property
Namespaces ► Sitecore.Configuration ► Settings ► ConfigurationIsSet
Gets a value indicating whether configuration is set.
Declaration Syntax
C#
public static bool ConfigurationIsSet { get; }
Value
true if configuration is set; otherwise, false.


ConnectionStringExists Method (connectionStringName)

ConnectionStringExists Method (connectionStringName)
Namespaces ► Sitecore.Configuration ► Settings ► ConnectionStringExists(String)
Determines if the specified connection string exists.
Declaration Syntax
C#
public static bool ConnectionStringExists(
    string connectionStringName
)
Parameters
connectionStringName (String)
Name of the connection string.
Return Value


DataFolder Property

DataFolder Property
Namespaces ► Sitecore.Configuration ► Settings ► DataFolder
Gets the path to the data folder.
Declaration Syntax
C#
public static string DataFolder { get; }
Value
Default value: "/data"
Remarks

The data folder is the place where data, index, audit and log files are stored.

The value can be a virtual or physical path.


DataProviderTimeout Property

DataProviderTimeout Property
Namespaces ► Sitecore.Configuration ► Settings ► DataProviderTimeout
Gets the default timeout for data provider commands.
Declaration Syntax
C#
public static TimeSpan DataProviderTimeout { get; }
Value
Default value: 3 minutes


DebugBorderColor Property

DebugBorderColor Property
Namespaces ► Sitecore.Configuration ► Settings ► DebugBorderColor
Gets the color of debug borders.
Declaration Syntax
C#
public static string DebugBorderColor { get; }
Value
Default value: "red"
Remarks
This is the CSS color value to use when drawing borders around elements on the Sitecore debug page (/sitecore/debug).


DebugBorderTag Property

DebugBorderTag Property
Namespaces ► Sitecore.Configuration ► Settings ► DebugBorderTag
Gets the html tag to use for debug borders (usually span or div).
Declaration Syntax
C#
public static string DebugBorderTag { get; }
Value
Default value: "span"
Remarks
This is the html tag to use when drawing borders around elements on the Sitecore debug page (/sitecore/debug).


DebugEnabled Property

DebugEnabled Property
Namespaces ► Sitecore.Configuration ► Settings ► DebugEnabled
Gets a value indicating whether ASP.NET debuggin is enabled.
Declaration Syntax
C#
public static bool DebugEnabled { get; }
Value
true if debug is enabled; otherwise, false.


DebugFolder Property

DebugFolder Property
Namespaces ► Sitecore.Configuration ► Settings ► DebugFolder
Gets the path to the debug folder.
Declaration Syntax
C#
public static string DebugFolder { get; }
Value
Default value: DataFolder
Remarks

The debug folder is the place where debug files are stored.

The value can be a virtual or physical path.


DefaultBaseTemplate Property

DefaultBaseTemplate Property
Namespaces ► Sitecore.Configuration ► Settings ► DefaultBaseTemplate
The guid of the default base templates.
Declaration Syntax
C#
public static string DefaultBaseTemplate { get; }
Value
The default base template.


DefaultDesktop Property

DefaultDesktop Property
Namespaces ► Sitecore.Configuration ► Settings ► DefaultDesktop
Gets the default desktop.
Declaration Syntax
C#
public static string DefaultDesktop { get; }
Value
Default value: "/sitecore/client/desktops/standard/default.aspx"
Remarks
Gets the path of the aspx page that defines the default layout (frameset) of the Sitecore client.


DefaultIcon Property

DefaultIcon Property
Namespaces ► Sitecore.Configuration ► Settings ► DefaultIcon
Gets the path to the default icon for items in the Sitecore client.
Declaration Syntax
C#
public static string DefaultIcon { get; }
Value
Default value: "/sitecore/client/images/document.gif"
Remarks

Gets the path of the default image file to show next to items in the tree view of the Sitecore client.

The image shown can be overriden by filling out the Icon field on an item or its template.


DefaultItem Property

DefaultItem Property
Namespaces ► Sitecore.Configuration ► Settings ► DefaultItem
Gets the default item for the Sitecore client.
Declaration Syntax
C#
public static string DefaultItem { get; }
Value
Default value: "/home"
Remarks
This is the path to the item that will be the selected when starting the Sitecore client (unless overriden by user settings).


DefaultLanguage Property

DefaultLanguage Property
Namespaces ► Sitecore.Configuration ► Settings ► DefaultLanguage
Gets the default language for the web site.
Declaration Syntax
C#
public static string DefaultLanguage { get; }
Value
Default value: "en"
Remarks

This is the default language of all content on the web site.

If multiple sites are specified using the <sites> section of web.config, the current url will be matched against the sites specified in that section.

If a match is found, the language of that site definition is used. Otherwise, the value of the 'DefaultLanguage' setting is used.


DefaultLayoutFile Property

DefaultLayoutFile Property
Namespaces ► Sitecore.Configuration ► Settings ► DefaultLayoutFile
Gets the path to the layout file to use for items that do not specify a layout file themselves.
Declaration Syntax
C#
public static string DefaultLayoutFile { get; }
Value
Default value: "/default.aspx"


DefaultPageName Property

DefaultPageName Property
Namespaces ► Sitecore.Configuration ► Settings ► DefaultPageName
Gets the name of the default ASPX page.
Declaration Syntax
C#
public static string DefaultPageName { get; }
Value
The name of the default page.
Remarks
Default value: default.aspx


DefaultPublishingTargets Property

DefaultPublishingTargets Property
Namespaces ► Sitecore.Configuration ► Settings ► DefaultPublishingTargets
Gets a pipe separated list of publishing group names.
Declaration Syntax
C#
public static string DefaultPublishingTargets { get; }
Value
Default value: "||"
Remarks
Groups in this list will be preselected in the Publish and Preview dialogs.


DefaultRegionalIsoCode Property

DefaultRegionalIsoCode Property
Namespaces ► Sitecore.Configuration ► Settings ► DefaultRegionalIsoCode
Gets the default regional ISO code.
Declaration Syntax
C#
public static string DefaultRegionalIsoCode { get; }
Value
The default regional ISO code.


DefaultShellControl Property

DefaultShellControl Property
Namespaces ► Sitecore.Configuration ► Settings ► DefaultShellControl
Gets the default shell control.
Declaration Syntax
C#
public static string DefaultShellControl { get; }
Value
Default value: "Cyclops"
Remarks
This specifies the default XML control to use in /sitecore/shell/default.aspx, if none is specified.


DefaultSortOrder Property

DefaultSortOrder Property
Namespaces ► Sitecore.Configuration ► Settings ► DefaultSortOrder
Gets the default value of the sort order attribute.
Declaration Syntax
C#
public static int DefaultSortOrder { get; }
Value
Default value: 0
Remarks
Sort order is used for displaying items in the Sitecore client and for API functions that returns sorted sets.


DefaultSQLTimeout Property

DefaultSQLTimeout Property
Namespaces ► Sitecore.Configuration ► Settings ► DefaultSQLTimeout
Gets the default timeout for SQL commands.
Declaration Syntax
C#
public static TimeSpan DefaultSQLTimeout { get; }
Value
Default value: 3 minutes


DefaultTheme Property

DefaultTheme Property
Namespaces ► Sitecore.Configuration ► Settings ► DefaultTheme
Gets the default Sitecore client theme.
Declaration Syntax
C#
public static string DefaultTheme { get; }
Value
Default value: "standard"
Remarks
A theme is a set of colors and fonts used in the Sitecore client (ie. a 'skin').


DisableBrowserCaching Property

DisableBrowserCaching Property
Namespaces ► Sitecore.Configuration ► Settings ► DisableBrowserCaching
Indicates if browser caching of pages should be disabled.
Declaration Syntax
C#
public static bool DisableBrowserCaching { get; }
Value
Default value: true.
Remarks
If true, a HTTP header value disabling browser caching will be written to all outgoing pages.


EnableXslDocumentFunction Property

EnableXslDocumentFunction Property
Namespaces ► Sitecore.Configuration ► Settings ► EnableXslDocumentFunction
Gets a value indicating whether XSLT document() support should be enabled.
Declaration Syntax
C#
public static bool EnableXslDocumentFunction { get; }
Value
true if document() support is enabled; otherwise, false.
Remarks

If this is not enabled, it will be an error if the XSLT file contains 'document()' references.

Document support can be set for individual XSLT files by using the EnableDocument property.

Default value: true.


EnableXslScripts Property

EnableXslScripts Property
Namespaces ► Sitecore.Configuration ► Settings ► EnableXslScripts
Gets a value indicating whether XSLT script support should be enabled.
Declaration Syntax
C#
public static bool EnableXslScripts { get; }
Value
true if script support is enabled; otherwise, false.
Remarks

If script support is not enabled, it will be an error if the XSLT file contains script blocks.

Script support can be set for individual XSLT files by using the EnableScript property.

Default value: false.


ErrorPage Property

ErrorPage Property
Namespaces ► Sitecore.Configuration ► Settings ► ErrorPage
Gets the page to redirect to, if a generic error occurs.
Declaration Syntax
C#
public static string ErrorPage { get; }
Value
Default value: "/sitecore/service/error.aspx"
Remarks
If an error occurs during processing of an incoming request, an error message wil be shown using the page pointed to


FastPublishing Property

FastPublishing Property
Namespaces ► Sitecore.Configuration ► Settings ► FastPublishing
Use fast publishing?
Declaration Syntax
C#
public static bool FastPublishing { get; }
Value
true if the fast publishing is used; otherwise, false.


FastQueryDescendantsDisabled Property

FastQueryDescendantsDisabled Property
Namespaces ► Sitecore.Configuration ► Settings ► FastQueryDescendantsDisabled
Setting this to 'true' will improve performance of item creation/moving/deletion, but will make fast query return incorrect results when selecting items using the Ancestors/Descendants axes.
Declaration Syntax
C#
public static bool FastQueryDescendantsDisabled { get; }
Value
true if axes info are refreshed; otherwise, false.


GenerateThumbnails Property

GenerateThumbnails Property
Namespaces ► Sitecore.Configuration ► Settings ► GenerateThumbnails
Indicates if thumbnails of uploaded image files should be generated.
Declaration Syntax
C#
public static bool GenerateThumbnails { get; }
Value
Default value: true.
Remarks

If true, a thumbnail will be generated each time an image file is uploaded.

The thumbnail will be stored in the MediaFolder.

See Also
ThumbnailWidth
ThumbnailHeight


GetAppSetting Method

GetAppSetting Method
Namespaces ► Sitecore.Configuration ► Settings ► GetAppSetting()()()
Members
Icon | Member | Description
 | GetAppSetting(String) | Get named application setting.
 | GetAppSetting(String, String) | Get named application setting.


GetAppSetting Method (name)

GetAppSetting Method (name)
Namespaces ► Sitecore.Configuration ► Settings ► GetAppSetting(String)
Get named application setting.
Declaration Syntax
C#
public static string GetAppSetting(
    string name
)
Parameters
name (String)
The name.
Return Value
The app setting.


GetAppSetting Method (name, defaultValue)

GetAppSetting Method (name, defaultValue)
Namespaces ► Sitecore.Configuration ► Settings ► GetAppSetting(String, String)
Get named application setting.
Declaration Syntax
C#
public static string GetAppSetting(
    string name,
    string defaultValue
)
Parameters
name (String)
The name.
defaultValue (String)
The _default.
Return Value
The app setting.


GetBoolSetting Method (name, defaultValue)

GetBoolSetting Method (name, defaultValue)
Namespaces ► Sitecore.Configuration ► Settings ► GetBoolSetting(String, Boolean)
Get boolean setting.
Declaration Syntax
C#
public static bool GetBoolSetting(
    string name,
    bool defaultValue
)
Parameters
name (String)
Name of the s.
defaultValue (Boolean)
if set to true this instance is default value.
Return Value
The bool setting.


GetConnectionString Method (connectionStringName)

GetConnectionString Method (connectionStringName)
Namespaces ► Sitecore.Configuration ► Settings ► GetConnectionString(String)
Gets a named connection string.
Declaration Syntax
C#
public static string GetConnectionString(
    string connectionStringName
)
Parameters
connectionStringName (String)
Name of the connection string.
Return Value
The connection string.


GetDoubleSetting Method (name, defaultValue)

GetDoubleSetting Method (name, defaultValue)
Namespaces ► Sitecore.Configuration ► Settings ► GetDoubleSetting(String, Double)
Get double setting.
Declaration Syntax
C#
public static double GetDoubleSetting(
    string name,
    double defaultValue
)
Parameters
name (String)
The name.
defaultValue (Double)
The default value.
Return Value
The long setting.


GetFileSetting Method

GetFileSetting Method
Namespaces ► Sitecore.Configuration ► Settings ► GetFileSetting()()()
Members
Icon | Member | Description
 | GetFileSetting(String) | Get named setting containg a file path.
 | GetFileSetting(String, String) | Get named setting containg a file path.


GetFileSetting Method (sName)

GetFileSetting Method (sName)
Namespaces ► Sitecore.Configuration ► Settings ► GetFileSetting(String)
Get named setting containg a file path.
Declaration Syntax
C#
public static string GetFileSetting(
    string sName
)
Parameters
sName (String)
Name of the s.
Return Value
The file setting.


GetFileSetting Method (name, defaultValue)

GetFileSetting Method (name, defaultValue)
Namespaces ► Sitecore.Configuration ► Settings ► GetFileSetting(String, String)
Get named setting containg a file path.
Declaration Syntax
C#
public static string GetFileSetting(
    string name,
    string defaultValue
)
Parameters
name (String)
The name.
defaultValue (String)
The _default.
Return Value
The file setting.


GetIntSetting Method (name, defaultValue)

GetIntSetting Method (name, defaultValue)
Namespaces ► Sitecore.Configuration ► Settings ► GetIntSetting(String, Int32)
Get int setting.
Declaration Syntax
C#
public static int GetIntSetting(
    string name,
    int defaultValue
)
Parameters
name (String)
The name.
defaultValue (Int32)
The default value.
Return Value
The int setting.


GetLongSetting Method (name, defaultValue)

GetLongSetting Method (name, defaultValue)
Namespaces ► Sitecore.Configuration ► Settings ► GetLongSetting(String, Int64)
Get long setting.
Declaration Syntax
C#
public static long GetLongSetting(
    string name,
    long defaultValue
)
Parameters
name (String)
The name.
defaultValue (Int64)
The default value.
Return Value
The long setting.


GetNumberOfSettings Method

GetNumberOfSettings Method
Namespaces ► Sitecore.Configuration ► Settings ► GetNumberOfSettings()()()
Get number of settings.
Declaration Syntax
C#
public static int GetNumberOfSettings()
Return Value
The number of settings.


GetProviderObject Method

GetProviderObject Method
Namespaces ► Sitecore.Configuration ► Settings ► GetProviderObject()()()
Members
Icon | Member | Description
 | GetProviderObject(String, Type) | Gets the provider object.
 | GetProviderObject(String, String, Type) | Gets the provider object.


GetProviderObject Method (referencePath, implementationPath, expectedType)

GetProviderObject Method (referencePath, implementationPath, expectedType)
Namespaces ► Sitecore.Configuration ► Settings ► GetProviderObject(String, String, Type)
Gets the provider object.
Declaration Syntax
C#
public static Object GetProviderObject(
    string referencePath,
    string implementationPath,
    Type expectedType
)
Parameters
referencePath (String)
The reference path.
implementationPath (String)
The implementation path.
expectedType (Type)
The expected type.
Return Value
The provider object.


GetProviderObject Method (implementationPath, expectedType)

GetProviderObject Method (implementationPath, expectedType)
Namespaces ► Sitecore.Configuration ► Settings ► GetProviderObject(String, Type)
Gets the provider object.
Declaration Syntax
C#
public static Object GetProviderObject(
    string implementationPath,
    Type expectedType
)
Parameters
implementationPath (String)
The implementation path.
expectedType (Type)
The expected type.
Return Value
The provider object.


GetProviderObjects Method (referencePath, implementationPath, expectedType)

GetProviderObjects Method (referencePath, implementationPath, expectedType)
Namespaces ► Sitecore.Configuration ► Settings ► GetProviderObjects(String, String, Type)
Gets the provider objects.
Declaration Syntax
C#
public static Object[] GetProviderObjects(
    string referencePath,
    string implementationPath,
    Type expectedType
)
Parameters
referencePath (String)
The reference path.
implementationPath (String)
The implementation path.
expectedType (Type)
The expected type.
Return Value
The provider objects.


GetSetting Method

GetSetting Method
Namespaces ► Sitecore.Configuration ► Settings ► GetSetting()()()
Members
Icon | Member | Description
 | GetSetting(String) | Get named setting.
 | GetSetting(String, String) | Get named setting with default.


GetSetting Method (name)

GetSetting Method (name)
Namespaces ► Sitecore.Configuration ► Settings ► GetSetting(String)
Get named setting.
Declaration Syntax
C#
public static string GetSetting(
    string name
)
Parameters
name (String)
The name.
Return Value
The setting.


GetSetting Method (name, defaultValue)

GetSetting Method (name, defaultValue)
Namespaces ► Sitecore.Configuration ► Settings ► GetSetting(String, String)
Get named setting with default.
Declaration Syntax
C#
public static string GetSetting(
    string name,
    string defaultValue
)
Parameters
name (String)
The name.
defaultValue (String)
The _default.
Return Value
The setting.


GetSystemSection Method (sectionName)

GetSystemSection<(Of <(T>)>) Method (sectionName)
Namespaces ► Sitecore.Configuration ► Settings ► GetSystemSection<(Of <(T>)>)(String)
Gets a system section from web.config (i.e. a section located beneath system.web).
Declaration Syntax
C#
public static T GetSystemSection<T>(
    string sectionName
)
where T : class
Generic Template Parameters
T
Parameters
sectionName (String)
Name of the section.
Return Value


GetTimeSpanSetting Method

GetTimeSpanSetting Method
Namespaces ► Sitecore.Configuration ► Settings ► GetTimeSpanSetting()()()
Members
Icon | Member | Description
 | GetTimeSpanSetting(String, String) | Get setting containg a time span (hh:mm:ss)
 | GetTimeSpanSetting(String, TimeSpan) | Get setting containg a time span (hh:mm:ss)


GetTimeSpanSetting Method (name, defaultValue)

GetTimeSpanSetting Method (name, defaultValue)
Namespaces ► Sitecore.Configuration ► Settings ► GetTimeSpanSetting(String, String)
Get setting containg a time span (hh:mm:ss)
Declaration Syntax
C#
public static TimeSpan GetTimeSpanSetting(
    string name,
    string defaultValue
)
Parameters
name (String)
The name.
defaultValue (String)
The _default.
Return Value
The time span setting.


GetTimeSpanSetting Method (name, defaultValue)

GetTimeSpanSetting Method (name, defaultValue)
Namespaces ► Sitecore.Configuration ► Settings ► GetTimeSpanSetting(String, TimeSpan)
Get setting containg a time span (hh:mm:ss)
Declaration Syntax
C#
public static TimeSpan GetTimeSpanSetting(
    string name,
    TimeSpan defaultValue
)
Parameters
name (String)
The name.
defaultValue (TimeSpan)
The _default.
Return Value
The time span setting.


GridPageSize Property

GridPageSize Property
Namespaces ► Sitecore.Configuration ► Settings ► GridPageSize
Gets the number of rows in a UI grid.
Declaration Syntax
C#
public static int GridPageSize { get; }
Value
The number of rows in a UI grid.


HashEncryptionProvider Property

HashEncryptionProvider Property
Namespaces ► Sitecore.Configuration ► Settings ► HashEncryptionProvider
Gets the hash encryption provider.
Declaration Syntax
C#
public static HashEncryption..::.EncryptionProvider HashEncryptionProvider { get; }
Value
The hash encryption provider.


HealthMonitorInterval Property

HealthMonitorInterval Property
Namespaces ► Sitecore.Configuration ► Settings ► HealthMonitorInterval
Gets the health monitor interval.
Declaration Syntax
C#
public static TimeSpan HealthMonitorInterval { get; }
Value
The health monitor interval (default: 10 minutes).


HeartbeatInterval Property

HeartbeatInterval Property
Namespaces ► Sitecore.Configuration ► Settings ► HeartbeatInterval
Gets the interval between heartbeats.
Declaration Syntax
C#
public static TimeSpan HeartbeatInterval { get; }
Value
Default value: 00:00:05 (5 seconds)


IgnoreUrlPrefixes Property

IgnoreUrlPrefixes Property
Namespaces ► Sitecore.Configuration ► Settings ► IgnoreUrlPrefixes
Gets a pipe separated list of url prefixes to ignore when mapping friendly urls.
Declaration Syntax
C#
public static string[] IgnoreUrlPrefixes { get; }
Value
Default value: "/sitecore|/layouts/|/images/|/trace.axd"
Remarks

Normally, url requests coming in are mapped to an item and the request is redirected to the items layout page.

For example, if the item /home/news. has the layout /layouts/newslist.aspx., the url http://localhost/home/news.aspx. will be redirected to http://localhost/layouts/newslist.aspx?path=[id of the News item].

To prevent this redirection to take place for physical aspx pages, their prefixes can be added to IgnoreUrlPrefixes.

For example, if an aspx page called /forms/registration.aspx. existed, the prefix /forms/ could be added to web.config to prevent requests for this page to be redirected.

Elements must be lowercase and non-empty.


ImageTypes Property

ImageTypes Property
Namespaces ► Sitecore.Configuration ► Settings ► ImageTypes
Gets a pipe separated list of image file types (extensions).
Declaration Syntax
C#
public static string ImageTypes { get; }
Value
Default value: "|gif|jpg|png|"
Remarks

List of file extension that are to be considered images by the Sitecore system.

Used for determining if thumbnails should be generated when uploading files.


IncludeProxiesInLinkDatabase Property

IncludeProxiesInLinkDatabase Property
Namespaces ► Sitecore.Configuration ► Settings ► IncludeProxiesInLinkDatabase
Gets a value indicating whether to include proxy definitions in the link database.
Declaration Syntax
C#
public static bool IncludeProxiesInLinkDatabase { get; }
Value
true if proxy definitions should be included in the link database; otherwise, false.


IndexFolder Property

IndexFolder Property
Namespaces ► Sitecore.Configuration ► Settings ► IndexFolder
Gets the index folder.
Declaration Syntax
C#
public static string IndexFolder { get; }
Value
The index folder.


InvalidItemNameChars Property

InvalidItemNameChars Property
Namespaces ► Sitecore.Configuration ► Settings ► InvalidItemNameChars
Gets the invalid item name chars.
Declaration Syntax
C#
public static char[] InvalidItemNameChars { get; }
Value
The invalid item name chars.


ItemNameValidation Property

ItemNameValidation Property
Namespaces ► Sitecore.Configuration ► Settings ► ItemNameValidation
Gets the item name validation.
Declaration Syntax
C#
public static string ItemNameValidation { get; }
Value
The item name validation.


ItemNotFoundUrl Property

ItemNotFoundUrl Property
Namespaces ► Sitecore.Configuration ► Settings ► ItemNotFoundUrl
Gets the url to redirect to, if an item being linked to is not found.
Declaration Syntax
C#
public static string ItemNotFoundUrl { get; }
Value
Default value: "/sitecore/service/notfound.aspx"
Remarks
If a dynamic link is made for a non-existing item on the web site, the request is redirected to the url pointed to by this setting.


KeepLockAfterSaveForAdminUsers Property

KeepLockAfterSaveForAdminUsers Property
Namespaces ► Sitecore.Configuration ► Settings ► KeepLockAfterSaveForAdminUsers
Gets a value indicating whether the item is keeped locked after save in Page Editor for Administator users.
Declaration Syntax
C#
public static bool KeepLockAfterSaveForAdminUsers { get; }
Value
true if the item is keeped locked on saved; otherwise, false.


LayoutFolder Property

LayoutFolder Property
Namespaces ► Sitecore.Configuration ► Settings ► LayoutFolder
Gets the path to the layout file root folder.
Declaration Syntax
C#
public static string LayoutFolder { get; }
Value
Default value: "/layouts"
Remarks

The layout folder is the place where layout files are stored.

The value can be a virtual or physical path.


LayoutNotFoundUrl Property

LayoutNotFoundUrl Property
Namespaces ► Sitecore.Configuration ► Settings ► LayoutNotFoundUrl
Gets the url to redirect to, if an items layout is not found.
Declaration Syntax
C#
public static string LayoutNotFoundUrl { get; }
Value
Default value: "/sitecore/service/nolayout.aspx"
Remarks
If a request for an item with an empty or a non-existing layout comes in, the request is redirected to the url pointed to by this setting.


LayoutPageEvent Property

LayoutPageEvent Property
Namespaces ► Sitecore.Configuration ► Settings ► LayoutPageEvent
Gets the name of page event where the layout pipeline will be run.
Declaration Syntax
C#
public static string LayoutPageEvent { get; }
Value
The layout page event.
Remarks

Presently, there are three valid values: 'preInit', 'init' or 'load'.

Default value is: 'preInit'.


LicenseFile Property

LicenseFile Property
Namespaces ► Sitecore.Configuration ► Settings ► LicenseFile
Gets the path to the license file.
Declaration Syntax
C#
public static string LicenseFile { get; }
Value
Default value: MakePath(String, String)(DataFolder, "license.xml")


LinkItemNotFoundUrl Property

LinkItemNotFoundUrl Property
Namespaces ► Sitecore.Configuration ► Settings ► LinkItemNotFoundUrl
Gets the url to redirect to, if an item is not found.
Declaration Syntax
C#
public static string LinkItemNotFoundUrl { get; }
Value
Default value: "/sitecore/service/notfound.aspx"
Remarks
If a request for a non-existing item comes in on the web site, the request is redirected to the url pointed to by this setting.


LogFolder Property

LogFolder Property
Namespaces ► Sitecore.Configuration ► Settings ► LogFolder
Gets the path to the log folder.
Declaration Syntax
C#
public static string LogFolder { get; }
Value
Default value: DataFolder
Remarks

The log folder is the place where log files are stored.

The value can be a virtual or physical path.


LoginLayout Property

LoginLayout Property
Namespaces ► Sitecore.Configuration ► Settings ► LoginLayout
Gets the name of the layout to use for logging in (to extranet)
Declaration Syntax
C#
public static string LoginLayout { get; }
Value
Default value: [an empty string]
Remarks

If the web site is protected (see ProtectedSite), the layout specified by this setting will be shown, when an unauthorised person tries to view the site.

If no LoginLayout is specified, the ProtectedSite setting will have no effect.


LoginPage Property

LoginPage Property
Namespaces ► Sitecore.Configuration ► Settings ► LoginPage
Gets the path to the page to use for logging in (to extranet)
Declaration Syntax
C#
public static string LoginPage { get; }
Value
Default value: [an empty string]
Remarks

If the web site is protected (see ProtectedSite), the layout specified by this setting will be shown, when an unauthorised person tries to view the site.

If no LoginPage is specified, the user will be redirected to an error page.


MailServer Property

MailServer Property
Namespaces ► Sitecore.Configuration ► Settings ► MailServer
Gets the mail server.
Declaration Syntax
C#
public static string MailServer { get; }
Value
The mail server.


MailServerPassword Property

MailServerPassword Property
Namespaces ► Sitecore.Configuration ► Settings ► MailServerPassword
Gets the mail server password.
Declaration Syntax
C#
public static string MailServerPassword { get; }
Value
The mail server password.


MailServerPort Property

MailServerPort Property
Namespaces ► Sitecore.Configuration ► Settings ► MailServerPort
Gets the mail server port.
Declaration Syntax
C#
public static int MailServerPort { get; }
Value
The mail server port.


MailServerUserName Property

MailServerUserName Property
Namespaces ► Sitecore.Configuration ► Settings ► MailServerUserName
Gets the name of the mail server user.
Declaration Syntax
C#
public static string MailServerUserName { get; }
Value
The name of the mail server user.


MasterVariablesReplacer Property

MasterVariablesReplacer Property
Namespaces ► Sitecore.Configuration ► Settings ► MasterVariablesReplacer
Gets the type of a class used for replacing variables when creating a master.
Declaration Syntax
C#
public static string MasterVariablesReplacer { get; }
Value
The master variables replacer.


MaxCallLevel Property

MaxCallLevel Property
Namespaces ► Sitecore.Configuration ► Settings ► MaxCallLevel
Specifies the maximum allowed depth of a recursive method call.
Declaration Syntax
C#
public static int MaxCallLevel { get; }
Value
Default value: The current value of MaxTreeDepth


MaxItemNameLength Property

MaxItemNameLength Property
Namespaces ► Sitecore.Configuration ► Settings ► MaxItemNameLength
Specifies the maximum length of an item name.
Declaration Syntax
C#
public static int MaxItemNameLength { get; }
Value
Default value: 100


MaxSqlBatchStatements Property

MaxSqlBatchStatements Property
Namespaces ► Sitecore.Configuration ► Settings ► MaxSqlBatchStatements
Gets the maximum number of statements to put in a SqlBatch.
Declaration Syntax
C#
public static int MaxSqlBatchStatements { get; }
Value
The maximum number. Default value: 150


MaxTreeDepth Property

MaxTreeDepth Property
Namespaces ► Sitecore.Configuration ► Settings ► MaxTreeDepth
Specifies the maximum allowed depth of an item tree.
Declaration Syntax
C#
public static int MaxTreeDepth { get; }
Value
Default value: 20


MaxWorkerThreads Property

MaxWorkerThreads Property
Namespaces ► Sitecore.Configuration ► Settings ► MaxWorkerThreads
Gets the maximum number of worker threads to use.
Declaration Syntax
C#
public static int MaxWorkerThreads { get; }
Value
Default value: 20
Remarks
Used by the ManagedThreadPool.


MediaFolder Property

MediaFolder Property
Namespaces ► Sitecore.Configuration ► Settings ► MediaFolder
Gets the path to the media library root folder.
Declaration Syntax
C#
public static string MediaFolder { get; }
Value
Default value: "/upload"
Remarks

The media folder is the place where images, pdf's, and other media files are stored.

The value can be a virtual or physical path.


NoAccessUrl Property

NoAccessUrl Property
Namespaces ► Sitecore.Configuration ► Settings ► NoAccessUrl
Gets the url to redirect to, if access to an item is denied.
Declaration Syntax
C#
public static string NoAccessUrl { get; }
Value
Default value: "/sitecore/service/noaccess.aspx"
Remarks
If a request for an item for which the current user does not have read rights is detected, the request is redirected to the url pointed to by this setting.


NoLicenseUrl Property

NoLicenseUrl Property
Namespaces ► Sitecore.Configuration ► Settings ► NoLicenseUrl
Gets the url to redirect to, if a license is missing.
Declaration Syntax
C#
public static string NoLicenseUrl { get; }
Value
Default value: "/sitecore/service/nolicense.aspx"
Remarks
If a required license is missing, page requests will be redirected to the url pointed to by this setting.


PackagePath Property

PackagePath Property
Namespaces ► Sitecore.Configuration ► Settings ► PackagePath
Specifies the path where package files are located.
Declaration Syntax
C#
public static string PackagePath { get; }
Value
Default value: MakePath(String, String)(DataFolder, "packages")
Remarks

When installing packages, the package files must be located in this folder.

Also, when generating new packages, the files will be saved in this folder.


PortalPrincipalResolver Property

PortalPrincipalResolver Property
Namespaces ► Sitecore.Configuration ► Settings ► PortalPrincipalResolver
Gets the portal principal resolver.
Declaration Syntax
C#
public static string PortalPrincipalResolver { get; }
Value
The portal principal resolver.


PortalStorage Property

PortalStorage Property
Namespaces ► Sitecore.Configuration ► Settings ► PortalStorage
Gets the portal storage.
Declaration Syntax
C#
public static string PortalStorage { get; }
Value
The portal storage.


ProcessHistoryCount Property

ProcessHistoryCount Property
Namespaces ► Sitecore.Configuration ► Settings ► ProcessHistoryCount
Gets the number of process histories to show at startup.
Declaration Syntax
C#
public static int ProcessHistoryCount { get; }
Value
Default value: 2
Remarks

For diagnostic purposes, the shutdown reason for previous ASP.NET worker processes are shown in the Sitecore log file.

This setting determinies how many proceses to look back (max. 100).


ProtectedSite Property

ProtectedSite Property
Namespaces ► Sitecore.Configuration ► Settings ► ProtectedSite
Indicates if the entire site is protected (require login).
Declaration Syntax
C#
public static bool ProtectedSite { get; }
Value
Default value: false.
Remarks

If true, no page on the site can be accessed without logging in to the extranet security subsystem.

For this to work, the setting LoginLayout must. also be set.


RecycleBinActive Property

RecycleBinActive Property
Namespaces ► Sitecore.Configuration ► Settings ► RecycleBinActive
Indicates if recycle bin is active.
Declaration Syntax
C#
public static bool RecycleBinActive { get; }
Value
Default value: true.
Remarks

If true, deleted items are moved to the recycle bin rather than being physically deleted.

If false, items are always physically deleted.


RequireLockBeforeEditing Property

RequireLockBeforeEditing Property
Namespaces ► Sitecore.Configuration ► Settings ► RequireLockBeforeEditing
Gets a value indicating whether a lock is required before editing.
Declaration Syntax
C#
public static bool RequireLockBeforeEditing { get; }
Value
true if a lock is required before editing; otherwise, false.


Reset Method

Reset Method
Namespaces ► Sitecore.Configuration ► Settings ► Reset()()()
Resets this instance.
Declaration Syntax
C#
public static void Reset()
Remarks
This will cause all configuration data to be reloaded.


SerializationFolder Property

SerializationFolder Property
Namespaces ► Sitecore.Configuration ► Settings ► SerializationFolder
Gets the serialization folder.
Declaration Syntax
C#
public static string SerializationFolder { get; }
Value
The serialization folder.


SerializationPassword Property

SerializationPassword Property
Namespaces ► Sitecore.Configuration ► Settings ► SerializationPassword
Gets the password used for deserializing users.
Declaration Syntax
C#
public static string SerializationPassword { get; }
Value
The serialization password.


Sites Property

Sites Property
Namespaces ► Sitecore.Configuration ► Settings ► Sites
Gets the list of sites.
Declaration Syntax
C#
public static List<SiteInfo> Sites { get; }
Value
Default value: [empty list]
Remarks

A single Sitecore database can contain multiple sites with different root paths and languages.

This setting returns a list of SiteInfo objects describing the individual sites in a multi-site installation.

The site data is collected from the <sites> section in web.config.


SystemBlockedUrl Property

SystemBlockedUrl Property
Namespaces ► Sitecore.Configuration ► Settings ► SystemBlockedUrl
Gets the url to redirect to, if the system has been blocked.
Declaration Syntax
C#
public static string SystemBlockedUrl { get; }
Value
Default value: "/sitecore/blocked.aspx"
Remarks
If the system has been blocked, page requests will be redirected to the url pointed to by this setting.


TempFolderPath Property

TempFolderPath Property
Namespaces ► Sitecore.Configuration ► Settings ► TempFolderPath
Gets the temp folder path.
Declaration Syntax
C#
public static string TempFolderPath { get; }
Value
The temp folder path.


ThumbnailHeight Property

ThumbnailHeight Property
Namespaces ► Sitecore.Configuration ► Settings ► ThumbnailHeight
Gets the max height of auto-generated image thumbnails.
Declaration Syntax
C#
public static int ThumbnailHeight { get; }
Value
Default value: 50
Remarks

When images are uploaded to the media library, a thumbnail is generated (see GenerateThumbnails).

If zero, the ThumbnailWidth property decides the size (scaling is done proportionally).


ThumbnailsBackgroundColor Property

ThumbnailsBackgroundColor Property
Namespaces ► Sitecore.Configuration ► Settings ► ThumbnailsBackgroundColor
Gets the color of the thumbnails background.
Declaration Syntax
C#
public static string ThumbnailsBackgroundColor { get; }
Value
The color of the thumbnails background.


ThumbnailWidth Property

ThumbnailWidth Property
Namespaces ► Sitecore.Configuration ► Settings ► ThumbnailWidth
Gets the maximum width of auto-generated image thumbnails.
Declaration Syntax
C#
public static int ThumbnailWidth { get; }
Value
Default value: 0
Remarks

When images are uploaded to the media library, a thumbnail is generated (see GenerateThumbnails).

If zero, the ThumbnailHeight property decides the size (scaling is done proportionally).


UnlockAfterCopy Property

UnlockAfterCopy Property
Namespaces ► Sitecore.Configuration ► Settings ► UnlockAfterCopy
Gets a value indicating whether to unlock items after copying.
Declaration Syntax
C#
public static bool UnlockAfterCopy { get; }
Value
true if items should be unlocked after copying; otherwise, false.
Remarks
Only the copies are unlocked. The original items stay locked.


VersionFilePath Property

VersionFilePath Property
Namespaces ► Sitecore.Configuration ► Settings ► VersionFilePath
Gets the path to the version file.
Declaration Syntax
C#
public static string VersionFilePath { get; }
Value
The version file path.


ViewStateStore Property

ViewStateStore Property
Namespaces ► Sitecore.Configuration ► Settings ► ViewStateStore
Indicates if ViewState is cached in the GlobalCache in SheerUI.
Declaration Syntax
C#
public static string ViewStateStore { get; }
Value
The view state store.


Wallpaper Property

Wallpaper Property
Namespaces ► Sitecore.Configuration ► Settings ► Wallpaper
Gets the wallpaper.
Declaration Syntax
C#
public static string Wallpaper { get; }
Value
The wallpaper.


WallpapersPath Property

WallpapersPath Property
Namespaces ► Sitecore.Configuration ► Settings ► WallpapersPath
Gets the wallpapers path.
Declaration Syntax
C#
public static string WallpapersPath { get; }
Value
The wallpapers path.


WebStylesheet Property

WebStylesheet Property
Namespaces ► Sitecore.Configuration ► Settings ► WebStylesheet
Gets the path to the default web site stylesheet.
Declaration Syntax
C#
public static string WebStylesheet { get; }
Value
Default value: /default.css.
Remarks
The stylesheet pointed to by this setting is automatically added to all pages descending from Sitecore.BasePage".


WelcomeTitle Property

WelcomeTitle Property
Namespaces ► Sitecore.Configuration ► Settings ► WelcomeTitle
Gets the welcome title to show on the login page.
Declaration Syntax
C#
public static string WelcomeTitle { get; }
Value
Default value: "" (empty string)
Remarks
The title to show on the Sitecore client login page.


WriteSetting Method

WriteSetting Method
Namespaces ► Sitecore.Configuration ► Settings ► WriteSetting()()()
Members
Icon | Member | Description
 | WriteSetting(String, String, Boolean) | Write a setting to web.config.
 | WriteSetting(String, String, String, Boolean) | Write a setting to web.config.


WriteSetting Method (key, value, overwrite)

WriteSetting Method (key, value, overwrite)
Namespaces ► Sitecore.Configuration ► Settings ► WriteSetting(String, String, Boolean)
Write a setting to web.config.
Declaration Syntax
C#
public static bool WriteSetting(
    string key,
    string value,
    bool overwrite
)
Parameters
key (String)
The key.
value (String)
The value.
overwrite (Boolean)
if set to true this instance is overwrite.
Return Value
The setting.


WriteSetting Method (path, match, content, overwrite)

WriteSetting Method (path, match, content, overwrite)
Namespaces ► Sitecore.Configuration ► Settings ► WriteSetting(String, String, String, Boolean)
Write a setting to web.config.
Declaration Syntax
C#
public static bool WriteSetting(
    string path,
    string match,
    string content,
    bool overwrite
)
Parameters
path (String)
The path.
match (String)
The match.
content (String)
The content.
overwrite (Boolean)
if set to true this instance is overwrite.
Return Value
The setting.


XHtmlSchemaFile Property

XHtmlSchemaFile Property
Namespaces ► Sitecore.Configuration ► Settings ► XHtmlSchemaFile
Gets the XHTML schema file.
Declaration Syntax
C#
public static string XHtmlSchemaFile { get; }
Value
The XHTML schema file.


XmlControlAspxFile Property

XmlControlAspxFile Property
Namespaces ► Sitecore.Configuration ► Settings ► XmlControlAspxFile
Gets the extension used for xml control files.
Declaration Syntax
C#
public static string XmlControlAspxFile { get; }
Value
Default value: "xml"


XmlControlExtension Property

XmlControlExtension Property
Namespaces ► Sitecore.Configuration ► Settings ► XmlControlExtension
Gets the extension used for xml control files.
Declaration Syntax
C#
public static string XmlControlExtension { get; }
Value
Default value: "xml"


Settings.Authentication Class

Settings..::.Authentication Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Authentication
Declaration Syntax
C#
public static class Authentication
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClientPersistentLoginDuration | Specifies the timeout in days for the client "remember me" feature.
 | DefaultDomainName | Gets the name of the default domain.
 | DefaultMembershipProviderWildcard | Gets the default membership wildcard used by the providers.
 | SaveRawUrl | Specifies whether the original request URL is passed to the login page (saved in 'url' query string parameter).
 | TicketTimeout | Obsolete. Specifies the timeout in minutes of an authentication ticket.
 | VirtualMembershipWildcard | Gets the membership wildcard to use in high level code.
Inheritance Hierarchy
Object
Settings..::.Authentication


ClientPersistentLoginDuration Property

ClientPersistentLoginDuration Property
Namespaces ► Sitecore.Configuration ► Settings..::.Authentication ► ClientPersistentLoginDuration
Specifies the timeout in days for the client "remember me" feature.
Declaration Syntax
C#
public static TimeSpan ClientPersistentLoginDuration { get; }


DefaultDomainName Property

DefaultDomainName Property
Namespaces ► Sitecore.Configuration ► Settings..::.Authentication ► DefaultDomainName
Gets the name of the default domain.
Declaration Syntax
C#
public static string DefaultDomainName { get; }
Value
The name of the default domain.
Remarks
Default value: default


DefaultMembershipProviderWildcard Property

DefaultMembershipProviderWildcard Property
Namespaces ► Sitecore.Configuration ► Settings..::.Authentication ► DefaultMembershipProviderWildcard
Gets the default membership wildcard used by the providers.
Declaration Syntax
C#
public static string DefaultMembershipProviderWildcard { get; }
Value
The membership wildcard. Default value: %


SaveRawUrl Property

SaveRawUrl Property
Namespaces ► Sitecore.Configuration ► Settings..::.Authentication ► SaveRawUrl
Specifies whether the original request URL is passed to the login page (saved in 'url' query string parameter).
Declaration Syntax
C#
public static bool SaveRawUrl { get; }
Value
true if raw URL of original request should be passed to the login page otherwise, false.


TicketTimeout Property

TicketTimeout Property
Namespaces ► Sitecore.Configuration ► Settings..::.Authentication ► TicketTimeout
Specifies the timeout in minutes of an authentication ticket.
Declaration Syntax
C#
[ObsoleteAttribute("Authentication.ClientPersistentLoginDuration is used for remember me duration, ticket timeouts are obsolete")]
public static TimeSpan TicketTimeout { get; }


VirtualMembershipWildcard Property

VirtualMembershipWildcard Property
Namespaces ► Sitecore.Configuration ► Settings..::.Authentication ► VirtualMembershipWildcard
Gets the membership wildcard to use in high level code.
Declaration Syntax
C#
public static string VirtualMembershipWildcard { get; }
Value
The membership wildcard. Default value: *


Settings.Authorization Class

Settings..::.Authorization Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Authorization
Declaration Syntax
C#
public static class Authorization
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InheritSecurityByDefault | Gets a value indicating whether to inherit security by default.
Inheritance Hierarchy
Object
Settings..::.Authorization


InheritSecurityByDefault Property

InheritSecurityByDefault Property
Namespaces ► Sitecore.Configuration ► Settings..::.Authorization ► InheritSecurityByDefault
Gets a value indicating whether to inherit security by default.
Declaration Syntax
C#
public static bool InheritSecurityByDefault { get; }
Value
true if security is inherited by default; otherwise, false.


Settings.Caching Class

Settings..::.Caching Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Caching
Declaration Syntax
C#
public static class Caching
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AccessResultCacheSize | Gets the size of the access result cache.
 | AverageItemSize | Gets the average size of an item.
 | CacheViewState | Indicates if ViewState is cached in the GlobalCache in SheerUI.
 | DefaultClientDataCacheSize | Gets the size of the default client data cache.
 | DefaultDataCacheSize | Gets the size of the default data cache.
 | DefaultFilteredItemsCacheSize | Gets the default size of the filtered items cache.
 | DefaultHtmlCacheSize | Gets the size of the default HTML cache.
 | DefaultItemCacheSize | Gets the size of the default item cache.
 | DefaultPathCacheSize | Gets the size of the default path cache.
 | DefaultPriority | Gets the default priority.
 | DefaultPropertyCacheSize | Gets the size of the default property cache.
 | DefaultProxyCacheSize | Gets the size of the default proxy cache.
 | DefaultRegistryCacheSize | Gets the size of the default registry cache.
 | DefaultTemplateCacheSize | Gets the size of the default template cache.
 | DefaultViewStateCacheSize | Gets the size of the default view state cache.
 | DefaultXslCacheSize | Gets the size of the default XSL cache.
 | Enabled | Gets a value indicating whether caching is enabled.
 | FastMediaCacheMapSize | Obsolete. Gets the size of the fast media cache map cache.
 | HtmlLifetime | Gets the HTML timeout.
 | HugeCacheSize | Gets the size of a huge cache.
 | IsUserInRoleCacheSize | Gets the size of the is in role cache.
 | ItemCachingEnabled | Gets a value indicating whether item caching is enabled.
 | LargeCacheSize | Gets the size of a large cache.
 | LoadFactor | Gets a value indicating the default load factor to use for cached values.
 | MaxLoadFactor | Gets a value indicating the maximum load factor to use for cached values.
 | MediumCacheSize | Gets the size of a medium cache.
 | ScavengeInterval | Gets the scavenge interval.
 | SmallCacheSize | Gets the size of a small cache.
 | TinyCacheSize | Gets the size of a tiny cache.
 | UserProfileCacheSize | Gets the size of the user profile cache.
Inheritance Hierarchy
Object
Settings..::.Caching


AccessResultCacheSize Property

AccessResultCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► AccessResultCacheSize
Gets the size of the access result cache.
Declaration Syntax
C#
public static long AccessResultCacheSize { get; }
Value
The size of the access result cache. Default size: 2MB


AverageItemSize Property

AverageItemSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► AverageItemSize
Gets the average size of an item.
Declaration Syntax
C#
public static int AverageItemSize { get; }
Value
The average size of the item.


CacheViewState Property

CacheViewState Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► CacheViewState
Indicates if ViewState is cached in the GlobalCache in SheerUI.
Declaration Syntax
C#
public static bool CacheViewState { get; }
Value
true if ViewState is cached in the GlobalCache in SheerUI; otherwise, false.


DefaultClientDataCacheSize Property

DefaultClientDataCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► DefaultClientDataCacheSize
Gets the size of the default client data cache.
Declaration Syntax
C#
public static long DefaultClientDataCacheSize { get; }
Value
The size of the default client data cache.


DefaultDataCacheSize Property

DefaultDataCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► DefaultDataCacheSize
Gets the size of the default data cache.
Declaration Syntax
C#
public static long DefaultDataCacheSize { get; }
Value
The size of the default data cache.


DefaultFilteredItemsCacheSize Property

DefaultFilteredItemsCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► DefaultFilteredItemsCacheSize
Gets the default size of the filtered items cache.
Declaration Syntax
C#
public static long DefaultFilteredItemsCacheSize { get; }
Value
The size of the filtered items cache. Default value: 0 (cache disabled)


DefaultHtmlCacheSize Property

DefaultHtmlCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► DefaultHtmlCacheSize
Gets the size of the default HTML cache.
Declaration Syntax
C#
public static long DefaultHtmlCacheSize { get; }
Value
The size of the default HTML cache.


DefaultItemCacheSize Property

DefaultItemCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► DefaultItemCacheSize
Gets the size of the default item cache.
Declaration Syntax
C#
public static long DefaultItemCacheSize { get; }
Value
The size of the default item cache.


DefaultPathCacheSize Property

DefaultPathCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► DefaultPathCacheSize
Gets the size of the default path cache.
Declaration Syntax
C#
public static long DefaultPathCacheSize { get; }
Value
The size of the default path cache.


DefaultPriority Property

DefaultPriority Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► DefaultPriority
Gets the default priority.
Declaration Syntax
C#
public static CachePriority DefaultPriority { get; }
Value
The default priority.


DefaultPropertyCacheSize Property

DefaultPropertyCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► DefaultPropertyCacheSize
Gets the size of the default property cache.
Declaration Syntax
C#
public static long DefaultPropertyCacheSize { get; }
Value
The size of the default property cache.


DefaultProxyCacheSize Property

DefaultProxyCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► DefaultProxyCacheSize
Gets the size of the default proxy cache.
Declaration Syntax
C#
public static long DefaultProxyCacheSize { get; }
Value
The size of the default proxy cache.


DefaultRegistryCacheSize Property

DefaultRegistryCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► DefaultRegistryCacheSize
Gets the size of the default registry cache.
Declaration Syntax
C#
public static long DefaultRegistryCacheSize { get; }
Value
The size of the default registry cache.


DefaultTemplateCacheSize Property

DefaultTemplateCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► DefaultTemplateCacheSize
Gets the size of the default template cache.
Declaration Syntax
C#
public static long DefaultTemplateCacheSize { get; }
Value
The size of the default template cache.


DefaultViewStateCacheSize Property

DefaultViewStateCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► DefaultViewStateCacheSize
Gets the size of the default view state cache.
Declaration Syntax
C#
public static long DefaultViewStateCacheSize { get; }
Value
The size of the default view state cache.


DefaultXslCacheSize Property

DefaultXslCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► DefaultXslCacheSize
Gets the size of the default XSL cache.
Declaration Syntax
C#
public static long DefaultXslCacheSize { get; }
Value
The size of the default XSL cache.


Enabled Property

Enabled Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► Enabled
Gets a value indicating whether caching is enabled.
Declaration Syntax
C#
public static bool Enabled { get; }
Value
true if enabled; otherwise, false.


FastMediaCacheMapSize Property

FastMediaCacheMapSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► FastMediaCacheMapSize
Gets the size of the fast media cache map cache.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static long FastMediaCacheMapSize { get; }
Value
The size of the fast media cache map cache.


HtmlLifetime Property

HtmlLifetime Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► HtmlLifetime
Gets the HTML timeout.
Declaration Syntax
C#
public static TimeSpan HtmlLifetime { get; }
Value
The HTML timeout.


HugeCacheSize Property

HugeCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► HugeCacheSize
Gets the size of a huge cache.
Declaration Syntax
C#
public static long HugeCacheSize { get; }
Value
The size of a huge cache.


IsUserInRoleCacheSize Property

IsUserInRoleCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► IsUserInRoleCacheSize
Gets the size of the is in role cache.
Declaration Syntax
C#
public static long IsUserInRoleCacheSize { get; }
Value
The size of the is in role cache.


ItemCachingEnabled Property

ItemCachingEnabled Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► ItemCachingEnabled
Gets a value indicating whether item caching is enabled.
Declaration Syntax
C#
public static bool ItemCachingEnabled { get; }
Value
true if enabled; otherwise, false.


LargeCacheSize Property

LargeCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► LargeCacheSize
Gets the size of a large cache.
Declaration Syntax
C#
public static long LargeCacheSize { get; }
Value
The size of a large cache.


LoadFactor Property

LoadFactor Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► LoadFactor
Gets a value indicating the default load factor to use for cached values.
Declaration Syntax
C#
public static double LoadFactor { get; }
Value
The meximum load factor.
Remarks

The size of all cached values are multiplied with this value before being added to the cache.

Default value: 1.0.


MaxLoadFactor Property

MaxLoadFactor Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► MaxLoadFactor
Gets a value indicating the maximum load factor to use for cached values.
Declaration Syntax
C#
public static double MaxLoadFactor { get; }
Value
The meximum load factor.
Remarks

The load factor might be increased up to this value during heavy memory load.

Default value: 3.0.


MediumCacheSize Property

MediumCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► MediumCacheSize
Gets the size of a medium cache.
Declaration Syntax
C#
public static long MediumCacheSize { get; }
Value
The size of a medium cache.


ScavengeInterval Property

ScavengeInterval Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► ScavengeInterval
Gets the scavenge interval.
Declaration Syntax
C#
public static TimeSpan ScavengeInterval { get; }
Value
The scavenge interval (default: 2 minutes).


SmallCacheSize Property

SmallCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► SmallCacheSize
Gets the size of a small cache.
Declaration Syntax
C#
public static long SmallCacheSize { get; }
Value
The size of a small cache.


TinyCacheSize Property

TinyCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► TinyCacheSize
Gets the size of a tiny cache.
Declaration Syntax
C#
public static long TinyCacheSize { get; }
Value
The size of a tiny cache.


UserProfileCacheSize Property

UserProfileCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► UserProfileCacheSize
Gets the size of the user profile cache.
Declaration Syntax
C#
public static long UserProfileCacheSize { get; }
Value
The size of the user profile cache.


Settings.Caching.StandardValues Class

Settings..::.Caching..::.StandardValues Class
Namespaces ► Sitecore.Configuration ► Settings..::.Caching ► Settings..::.Caching..::.StandardValues
StandardValues class
Declaration Syntax
C#
public class StandardValues
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Settings..::.Caching..::.StandardValues()()() | Initializes a new instance of the Settings..::.Caching..::.StandardValues class
 | AverageValueSize | Gets the average size of a standard values.
 | DefaultCacheSize | Gets the default size of the standard value cache.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Settings..::.Caching..::.StandardValues


Settings.Caching.StandardValues Constructor

Settings..::.Caching..::.StandardValues Constructor
Namespaces ► Sitecore.Configuration ► Settings..::.Caching..::.StandardValues ► Settings..::.Caching..::.StandardValues()()()
Initializes a new instance of the Settings..::.Caching..::.StandardValues class
Declaration Syntax
C#
public StandardValues()


AverageValueSize Property

AverageValueSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching..::.StandardValues ► AverageValueSize
Gets the average size of a standard values.
Declaration Syntax
C#
public static long AverageValueSize { get; }
Value
The average size of standard values entries.
Remarks
Default value: 100


DefaultCacheSize Property

DefaultCacheSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Caching..::.StandardValues ► DefaultCacheSize
Gets the default size of the standard value cache.
Declaration Syntax
C#
public static long DefaultCacheSize { get; }
Value
The default size of the standard value cache.
Remarks
Default value: 1MB


Settings.ContentEditor Class

Settings..::.ContentEditor Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.ContentEditor
Defines Content Editor options.
Declaration Syntax
C#
public static class ContentEditor
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckHasChildrenOnTreeNodes | Gets a value indicating whether the Settings..::.ContentEditor uses HasChildren when drawing tree nodes.
 | CheckSecurityOnTreeNodes | Gets a value indicating whether the Settings..::.ContentEditor checks the security on tree nodes.
 | ClassicFrameEventPropagation | Gets a value indicating whether the Content Editor uses classic frame event propagation.
 | DefaultSkin | Gets the default skin.
 | RenderCollapsedSections | Gets a value indicating whether the content editor renders collapsed sections.
 | ShowGutter | Gets a value indicating whether the Settings..::.ContentEditor shows the gutter.
 | ShowSearchPanel | Gets a value indicating whether the Settings..::.ContentEditor shows the search panel.
 | ShowValidatorBar | Gets a value indicating whether the Settings..::.ContentEditor shows the validator bar.
 | UseSmartTags | Gets a value indicating whether the Settings..::.ContentEditor uses the smart tags.
Inheritance Hierarchy
Object
Settings..::.ContentEditor


CheckHasChildrenOnTreeNodes Property

CheckHasChildrenOnTreeNodes Property
Namespaces ► Sitecore.Configuration ► Settings..::.ContentEditor ► CheckHasChildrenOnTreeNodes
Gets a value indicating whether the Settings..::.ContentEditor uses HasChildren when drawing tree nodes.
Declaration Syntax
C#
public static bool CheckHasChildrenOnTreeNodes { get; }
Value
true if the Settings..::.ContentEditor uses HasChildren when drawing tree nodes; otherwise, false.


CheckSecurityOnTreeNodes Property

CheckSecurityOnTreeNodes Property
Namespaces ► Sitecore.Configuration ► Settings..::.ContentEditor ► CheckSecurityOnTreeNodes
Gets a value indicating whether the Settings..::.ContentEditor checks the security on tree nodes.
Declaration Syntax
C#
public static bool CheckSecurityOnTreeNodes { get; }
Value
true if the Settings..::.ContentEditor checks the security on tree nodes; otherwise, false.


ClassicFrameEventPropagation Property

ClassicFrameEventPropagation Property
Namespaces ► Sitecore.Configuration ► Settings..::.ContentEditor ► ClassicFrameEventPropagation
Gets a value indicating whether the Content Editor uses classic frame event propagation.
Declaration Syntax
C#
public static bool ClassicFrameEventPropagation { get; }
Value
true if the Content Editor uses classic frame event propagation; otherwise, false.
Remarks
In classic propagation all item events are sent to all frames in the content editor. This may hurt server and client performance. If classic mode is not used, only events relating to items that are either selected in the content editor or subitms thereof, are propagated.


DefaultSkin Property

DefaultSkin Property
Namespaces ► Sitecore.Configuration ► Settings..::.ContentEditor ► DefaultSkin
Gets the default skin.
Declaration Syntax
C#
public static string DefaultSkin { get; }
Value
The default skin.


RenderCollapsedSections Property

RenderCollapsedSections Property
Namespaces ► Sitecore.Configuration ► Settings..::.ContentEditor ► RenderCollapsedSections
Gets a value indicating whether the content editor renders collapsed sections.
Declaration Syntax
C#
public static bool RenderCollapsedSections { get; }
Value
true if the content editor renders collapsed sections; otherwise, false.


ShowGutter Property

ShowGutter Property
Namespaces ► Sitecore.Configuration ► Settings..::.ContentEditor ► ShowGutter
Gets a value indicating whether the Settings..::.ContentEditor shows the gutter.
Declaration Syntax
C#
public static bool ShowGutter { get; }
Value
true if the Settings..::.ContentEditor shows the gutter; otherwise, false.


ShowSearchPanel Property

ShowSearchPanel Property
Namespaces ► Sitecore.Configuration ► Settings..::.ContentEditor ► ShowSearchPanel
Gets a value indicating whether the Settings..::.ContentEditor shows the search panel.
Declaration Syntax
C#
public static bool ShowSearchPanel { get; }
Value
true if the Settings..::.ContentEditor shows the search panel; otherwise, false.


ShowValidatorBar Property

ShowValidatorBar Property
Namespaces ► Sitecore.Configuration ► Settings..::.ContentEditor ► ShowValidatorBar
Gets a value indicating whether the Settings..::.ContentEditor shows the validator bar.
Declaration Syntax
C#
public static bool ShowValidatorBar { get; }
Value
true if the Settings..::.ContentEditor shows the validator bar; otherwise, false.


UseSmartTags Property

UseSmartTags Property
Namespaces ► Sitecore.Configuration ► Settings..::.ContentEditor ► UseSmartTags
Gets a value indicating whether the Settings..::.ContentEditor uses the smart tags.
Declaration Syntax
C#
public static bool UseSmartTags { get; }
Value
true if the Settings..::.ContentEditor uses the smart tags; otherwise, false.


Settings.Counters Class

Settings..::.Counters Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Counters
Declaration Syntax
C#
public static class Counters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Enabled | Indicates if performance counters are enabled.
 | InstanceName | Indicates if performance counters are enabled.
 | ResetOnStartup | Indicates if performance counters will be reset on Sitecore startup.
Inheritance Hierarchy
Object
Settings..::.Counters


Enabled Property

Enabled Property
Namespaces ► Sitecore.Configuration ► Settings..::.Counters ► Enabled
Indicates if performance counters are enabled.
Declaration Syntax
C#
public static bool Enabled { get; }
Value
true if enabled; otherwise, false.


InstanceName Property

InstanceName Property
Namespaces ► Sitecore.Configuration ► Settings..::.Counters ► InstanceName
Indicates if performance counters are enabled.
Declaration Syntax
C#
public static string InstanceName { get; }
Value
The name of the instance.


ResetOnStartup Property

ResetOnStartup Property
Namespaces ► Sitecore.Configuration ► Settings..::.Counters ► ResetOnStartup
Indicates if performance counters will be reset on Sitecore startup.
Declaration Syntax
C#
public static bool ResetOnStartup { get; }
Value
true if performance counters will be reset on Sitecore startup; otherwise, false.


Settings.HtmlEditor Class

Settings..::.HtmlEditor Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.HtmlEditor
Declaration Syntax
C#
public static class HtmlEditor
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LineBreak | Gets the line break.
 | SupportWebControls | Gets a value indicating whether the Settings..::.HtmlEditor supports the web controls.
 | ValidatorServiceUrl | Gets the validator service URL.
Inheritance Hierarchy
Object
Settings..::.HtmlEditor


LineBreak Property

LineBreak Property
Namespaces ► Sitecore.Configuration ► Settings..::.HtmlEditor ► LineBreak
Gets the line break.
Declaration Syntax
C#
public static string LineBreak { get; }
Value
The line break.


SupportWebControls Property

SupportWebControls Property
Namespaces ► Sitecore.Configuration ► Settings..::.HtmlEditor ► SupportWebControls
Gets a value indicating whether the Settings..::.HtmlEditor supports the web controls.
Declaration Syntax
C#
public static bool SupportWebControls { get; }
Value
true if the Settings..::.HtmlEditor supports the web controls; otherwise, false.


ValidatorServiceUrl Property

ValidatorServiceUrl Property
Namespaces ► Sitecore.Configuration ► Settings..::.HtmlEditor ► ValidatorServiceUrl
Gets the validator service URL.
Declaration Syntax
C#
public static string ValidatorServiceUrl { get; }
Value
The validator service URL.


Settings.Indexing Class

Settings..::.Indexing Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Indexing
Declaration Syntax
C#
public static class Indexing
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Enabled | This property can be used to disable/enable indexing during the run time.
 | ServerSpecificProperties | Gets a value indicating whether to store properties specific to each server name.
 | UpdateInterval | Gets the interval between the IndexingManager checking its queue for pending actions.
 | UpdateJobThrottle | Gets the minimum time to wait between individual index update jobs.
Inheritance Hierarchy
Object
Settings..::.Indexing


Enabled Property

Enabled Property
Namespaces ► Sitecore.Configuration ► Settings..::.Indexing ► Enabled
This property can be used to disable/enable indexing during the run time.
Declaration Syntax
C#
public static bool Enabled { get; set; }
Value
true if enabled; otherwise, false.


ServerSpecificProperties Property

ServerSpecificProperties Property
Namespaces ► Sitecore.Configuration ► Settings..::.Indexing ► ServerSpecificProperties
Gets a value indicating whether to store properties specific to each server name.
Declaration Syntax
C#
public static bool ServerSpecificProperties { get; }
Value
true if server specific properties; otherwise, false.


UpdateInterval Property

UpdateInterval Property
Namespaces ► Sitecore.Configuration ► Settings..::.Indexing ► UpdateInterval
Gets the interval between the IndexingManager checking its queue for pending actions.
Declaration Syntax
C#
public static TimeSpan UpdateInterval { get; }
Value
Default value: "00:05:00" (5 minutes)


UpdateJobThrottle Property

UpdateJobThrottle Property
Namespaces ► Sitecore.Configuration ► Settings..::.Indexing ► UpdateJobThrottle
Gets the minimum time to wait between individual index update jobs.
Declaration Syntax
C#
public static TimeSpan UpdateJobThrottle { get; }
Value
Default value: "00:00:01" (1 second)


Settings.Install Class

Settings..::.Install Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Install
Settings for Install namespace
Declaration Syntax
C#
public static class Install
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HistoryFolder | Gets the history folder.
 | RemoveTransactionFolder | Gets a value indicating whether the Settings..::.Install removes the transaction folder.
 | TransactionsRoot | Gets the transactions root.
Inheritance Hierarchy
Object
Settings..::.Install


HistoryFolder Property

HistoryFolder Property
Namespaces ► Sitecore.Configuration ► Settings..::.Install ► HistoryFolder
Gets the history folder.
Declaration Syntax
C#
public static string HistoryFolder { get; }
Value
The history folder.


RemoveTransactionFolder Property

RemoveTransactionFolder Property
Namespaces ► Sitecore.Configuration ► Settings..::.Install ► RemoveTransactionFolder
Gets a value indicating whether the Settings..::.Install removes the transaction folder.
Declaration Syntax
C#
public static bool RemoveTransactionFolder { get; }
Value
true if the Settings..::.Install removes the transaction folder; otherwise, false.


TransactionsRoot Property

TransactionsRoot Property
Namespaces ► Sitecore.Configuration ► Settings..::.Install ► TransactionsRoot
Gets the transactions root.
Declaration Syntax
C#
public static string TransactionsRoot { get; }
Value
The transactions root.


Settings.Jobs Class

Settings..::.Jobs Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Jobs
Declaration Syntax
C#
public static class Jobs
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | QueueProcessingInterval | Gets the interval between the JobManager checking its queue for pending actions.
Inheritance Hierarchy
Object
Settings..::.Jobs


QueueProcessingInterval Property

QueueProcessingInterval Property
Namespaces ► Sitecore.Configuration ► Settings..::.Jobs ► QueueProcessingInterval
Gets the interval between the JobManager checking its queue for pending actions.
Declaration Syntax
C#
public static TimeSpan QueueProcessingInterval { get; }
Value
Default value: "00:00:02" (2 seconds)


Settings.Languages Class

Settings..::.Languages Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Languages
Declaration Syntax
C#
public static class Languages
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoRemoveItemData | Indicates if item data is automatically removed from a database when a language item is deleted.
 | AutoRenameItemData | Indicates if the language of item data is automatically renamed when a language item is renamed.
Inheritance Hierarchy
Object
Settings..::.Languages


AutoRemoveItemData Property

AutoRemoveItemData Property
Namespaces ► Sitecore.Configuration ► Settings..::.Languages ► AutoRemoveItemData
Indicates if item data is automatically removed from a database when a language item is deleted.
Declaration Syntax
C#
public static bool AutoRemoveItemData { get; }
Value
true if data should be removed; otherwise, false.


AutoRenameItemData Property

AutoRenameItemData Property
Namespaces ► Sitecore.Configuration ► Settings..::.Languages ► AutoRenameItemData
Indicates if the language of item data is automatically renamed when a language item is renamed.
Declaration Syntax
C#
public static bool AutoRenameItemData { get; }
Value
true if data language should be renamed; otherwise, false.


Settings.Links Class

Settings..::.Links Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Links
Declaration Syntax
C#
public static class Links
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | QueryStringSeparator | Gets the string used to separate entries in generated query strings.
Inheritance Hierarchy
Object
Settings..::.Links


QueryStringSeparator Property

QueryStringSeparator Property
Namespaces ► Sitecore.Configuration ► Settings..::.Links ► QueryStringSeparator
Gets the string used to separate entries in generated query strings.
Declaration Syntax
C#
public static string QueryStringSeparator { get; }
Value
The separator.
Remarks
Default value: &


Settings.Login Class

Settings..::.Login Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Login
Declaration Syntax
C#
public static class Login
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SitecoreUrl | Gets the max items.
Inheritance Hierarchy
Object
Settings..::.Login


SitecoreUrl Property

SitecoreUrl Property
Namespaces ► Sitecore.Configuration ► Settings..::.Login ► SitecoreUrl
Gets the max items.
Declaration Syntax
C#
public static string SitecoreUrl { get; }
Value
The max items.


Settings.Media Class

Settings..::.Media Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Media
Declaration Syntax
C#
public static class Media
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoSetAlt | Indicates if the Alt field on the Image template is set autmatically to the file path when the image is uploaded. If false, the Alt field is blank.
 | BaseFolder | Obsolete. Gets the base folder used when storing media files.
 | CacheFolder | Gets the folder under which media files are cached by the system.
 | CachingEnabled | Indicates if caching of media files is enabled.
 | DefaultImageFormat | Gets the default ImageFormat to use when it's not possible to deduce this from an extension.
 | FileFolder | Gets the folder under which media files are stored by the system.
 | IncludeExtensionsInItemNames | Gets a value indicating whether to include a file extension when generating an item name from a file name.
 | InterpolationMode | Gets the interpolation mode to use when resizing images.
 | MaxImageWidth | Gets the max width of the image in a Rich Text field.
 | MaxSizeInDatabase | Gets the maximum allowed size of media intended to be stored in a database (binary blob).
 | MaxSizeInMemory | Gets the maximum size of media to load into memory for processing (rezising etc.).
 | OpenContentEditorAfterUpload | Gets a value indicating whether the content editor must be opened after a file has been uploaded.
 | RequestExtension | Gets the extension to use in media request URLs.
 | StreamBufferSize | Gets the size of the buffer to use when streaming media to files or other targets.
 | StreamPartiallyCachedFiles | Gets a value indicating whether to start streaming files before they have been fully written to the cache.
 | UploadAsFiles | Determines if media should be uploaded as files or as database blobs.
 | UploadAsVersionableByDefault | Gets a value indicating whether media items is uploaded as versionable by default.
 | UseItemPaths | Gets a value indicating whether to use item paths for media URLs.
 | UseLegacyResizing | Gets a value indicating whether to use legacy resizing (ie. bypass the Sitecore.ImageLib library).
 | WhitespaceReplacement | Gets the character to use when replacing whitespace in the names of uploaded media.
Inheritance Hierarchy
Object
Settings..::.Media


AutoSetAlt Property

AutoSetAlt Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► AutoSetAlt
Indicates if the Alt field on the Image template is set autmatically to the file path when the image is uploaded. If false, the Alt field is blank.
Declaration Syntax
C#
public static bool AutoSetAlt { get; }


BaseFolder Property

BaseFolder Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► BaseFolder
Gets the base folder used when storing media files.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static string BaseFolder { get; }
Value
The base folder.
Remarks
Default value: /App_Data/MediaFiles


CacheFolder Property

CacheFolder Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► CacheFolder
Gets the folder under which media files are cached by the system.
Declaration Syntax
C#
public static string CacheFolder { get; }
Value
The cache folder.
Remarks
Default value: /App_Data/MediaCache


CachingEnabled Property

CachingEnabled Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► CachingEnabled
Indicates if caching of media files is enabled.
Declaration Syntax
C#
public static bool CachingEnabled { get; }
Remarks
Default value: true


DefaultImageFormat Property

DefaultImageFormat Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► DefaultImageFormat
Gets the default ImageFormat to use when it's not possible to deduce this from an extension.
Declaration Syntax
C#
public static string DefaultImageFormat { get; }
Value
The image format. Default value: "" (empty string).
Remarks

The value must be parsable to a valid ImageFormat value.

If the value is not set, the GetImageFormat(String) may return null causing image functions to fail.


FileFolder Property

FileFolder Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► FileFolder
Gets the folder under which media files are stored by the system.
Declaration Syntax
C#
public static string FileFolder { get; }
Value
The folder.
Remarks
Default value: /App_Data/MediaFiles


IncludeExtensionsInItemNames Property

IncludeExtensionsInItemNames Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► IncludeExtensionsInItemNames
Gets a value indicating whether to include a file extension when generating an item name from a file name.
Declaration Syntax
C#
public static bool IncludeExtensionsInItemNames { get; }
Value
true if extansion should be included; otherwise, false.


InterpolationMode Property

InterpolationMode Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► InterpolationMode
Gets the interpolation mode to use when resizing images.
Declaration Syntax
C#
public static InterpolationMode InterpolationMode { get; }
Value
The interpolation mode.
Remarks
Default value: High


MaxImageWidth Property

MaxImageWidth Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► MaxImageWidth
Gets the max width of the image in a Rich Text field.
Declaration Syntax
C#
public static int MaxImageWidth { get; }
Value
The max width of an image in a Rich Text field.


MaxSizeInDatabase Property

MaxSizeInDatabase Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► MaxSizeInDatabase
Gets the maximum allowed size of media intended to be stored in a database (binary blob).
Declaration Syntax
C#
public static long MaxSizeInDatabase { get; }
Value
The maximum size.
Remarks
Default value: 500MB


MaxSizeInMemory Property

MaxSizeInMemory Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► MaxSizeInMemory
Gets the maximum size of media to load into memory for processing (rezising etc.).
Declaration Syntax
C#
public static long MaxSizeInMemory { get; }
Value
The maximum size.
Remarks
Default value: 40MB


OpenContentEditorAfterUpload Property

OpenContentEditorAfterUpload Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► OpenContentEditorAfterUpload
Gets a value indicating whether the content editor must be opened after a file has been uploaded.
Declaration Syntax
C#
public static bool OpenContentEditorAfterUpload { get; }
Value
true if the content editor must be opened after a file has been uploaded; otherwise, false.


RequestExtension Property

RequestExtension Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► RequestExtension
Gets the extension to use in media request URLs.
Declaration Syntax
C#
public static string RequestExtension { get; }
Value
The request extension. Default value: "" (an empty string)
Remarks
If the value is not set, the Extension field of the individual media items will be used (ie. JPG, GIF, etc.)


StreamBufferSize Property

StreamBufferSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► StreamBufferSize
Gets the size of the buffer to use when streaming media to files or other targets.
Declaration Syntax
C#
public static int StreamBufferSize { get; }
Value
The size of the stream buffer.
Remarks
Default value: 100000


StreamPartiallyCachedFiles Property

StreamPartiallyCachedFiles Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► StreamPartiallyCachedFiles
Gets a value indicating whether to start streaming files before they have been fully written to the cache.
Declaration Syntax
C#
public static bool StreamPartiallyCachedFiles { get; }
Value
true if the feature should be enabled; otherwise, false.
Remarks
Default value: true


UploadAsFiles Property

UploadAsFiles Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► UploadAsFiles
Determines if media should be uploaded as files or as database blobs.
Declaration Syntax
C#
public static bool UploadAsFiles { get; }
Value
true if upload as files; otherwise, false.


UploadAsVersionableByDefault Property

UploadAsVersionableByDefault Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► UploadAsVersionableByDefault
Gets a value indicating whether media items is uploaded as versionable by default.
Declaration Syntax
C#
public static bool UploadAsVersionableByDefault { get; }
Value
true if media items is uploaded as versionable by default; otherwise, false.


UseItemPaths Property

UseItemPaths Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► UseItemPaths
Gets a value indicating whether to use item paths for media URLs.
Declaration Syntax
C#
public static bool UseItemPaths { get; }
Value
true if item paths should be used; otherwise, false.
Remarks
Default value: false


UseLegacyResizing Property

UseLegacyResizing Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► UseLegacyResizing
Gets a value indicating whether to use legacy resizing (ie. bypass the Sitecore.ImageLib library).
Declaration Syntax
C#
public static bool UseLegacyResizing { get; }
Value
true if legacy resizing should be used; otherwise, false.
Remarks
Default value: false.


WhitespaceReplacement Property

WhitespaceReplacement Property
Namespaces ► Sitecore.Configuration ► Settings..::.Media ► WhitespaceReplacement
Gets the character to use when replacing whitespace in the names of uploaded media.
Declaration Syntax
C#
public static string WhitespaceReplacement { get; }
Value
The extension divider.
Remarks
Default: A single space character.


Settings.MediaResponse Class

Settings..::.MediaResponse Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.MediaResponse
Declaration Syntax
C#
public static class MediaResponse
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cacheability | Gets the cacheability to use in media response headers.
 | CacheExtensions | Gets the cache extension to use in media response headers.
 | MaxAge | Gets the max age to use in media response headers.
 | SlidingExpiration | Gets the sliding expiration to use in media response headers.
Inheritance Hierarchy
Object
Settings..::.MediaResponse


Cacheability Property

Cacheability Property
Namespaces ► Sitecore.Configuration ► Settings..::.MediaResponse ► Cacheability
Gets the cacheability to use in media response headers.
Declaration Syntax
C#
public static HttpCacheability Cacheability { get; }
Value
The cacheability.


CacheExtensions Property

CacheExtensions Property
Namespaces ► Sitecore.Configuration ► Settings..::.MediaResponse ► CacheExtensions
Gets the cache extension to use in media response headers.
Declaration Syntax
C#
public static string CacheExtensions { get; }
Value
The cache extension.
Remarks
Default value: "".


MaxAge Property

MaxAge Property
Namespaces ► Sitecore.Configuration ► Settings..::.MediaResponse ► MaxAge
Gets the max age to use in media response headers.
Declaration Syntax
C#
public static TimeSpan MaxAge { get; }
Value
The max age. Set it to "00:00:00" to omit this header.
Remarks
Default value: "00:00:00" (Zero).


SlidingExpiration Property

SlidingExpiration Property
Namespaces ► Sitecore.Configuration ► Settings..::.MediaResponse ► SlidingExpiration
Gets the sliding expiration to use in media response headers.
Declaration Syntax
C#
public static Tristate SlidingExpiration { get; }
Value
The sliding expiration ("true"/"false"). Set it to "" to omit this header.
Remarks
Default value: "".


Settings.Performance Class

Settings..::.Performance Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Performance
Declaration Syntax
C#
public static class Performance
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PagingIteratorPageSize | Gets the default page size to use with the PagingIterator<(Of <(T>)>).
Inheritance Hierarchy
Object
Settings..::.Performance


PagingIteratorPageSize Property

PagingIteratorPageSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Performance ► PagingIteratorPageSize
Gets the default page size to use with the PagingIterator<(Of <(T>)>).
Declaration Syntax
C#
public static int PagingIteratorPageSize { get; }
Value
The size of the paging iterator page.
Remarks
Default value: 100


Settings.Preview Class

Settings..::.Preview Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Preview
Declaration Syntax
C#
public static class Preview
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DefaultSite | Gets the default site.
Inheritance Hierarchy
Object
Settings..::.Preview


DefaultSite Property

DefaultSite Property
Namespaces ► Sitecore.Configuration ► Settings..::.Preview ► DefaultSite
Gets the default site.
Declaration Syntax
C#
public static string DefaultSite { get; }
Value
The default site.


Settings.Profiling Class

Settings..::.Profiling Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Profiling
Defines profile options.
Declaration Syntax
C#
public static class Profiling
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FormattingXslFile | Gets the formatting XSL file.
 | RenderFieldThreshold | Defines the threshold value for logging long field render operations.
 | SheerUI | Determines if SheerUI is profiled.
 | SheerUIWarningThreshold | Defines the threshold value for logging long requests.
Inheritance Hierarchy
Object
Settings..::.Profiling


FormattingXslFile Property

FormattingXslFile Property
Namespaces ► Sitecore.Configuration ► Settings..::.Profiling ► FormattingXslFile
Gets the formatting XSL file.
Declaration Syntax
C#
public static string FormattingXslFile { get; }
Value
The formatting XSL file.


RenderFieldThreshold Property

RenderFieldThreshold Property
Namespaces ► Sitecore.Configuration ► Settings..::.Profiling ► RenderFieldThreshold
Defines the threshold value for logging long field render operations.
Declaration Syntax
C#
public static int RenderFieldThreshold { get; }
Value
The threshold value for logging long field render operations.


SheerUI Property

SheerUI Property
Namespaces ► Sitecore.Configuration ► Settings..::.Profiling ► SheerUI
Determines if SheerUI is profiled.
Declaration Syntax
C#
public static bool SheerUI { get; }
Value
true if SheerUI is profiled; otherwise, false.


SheerUIWarningThreshold Property

SheerUIWarningThreshold Property
Namespaces ► Sitecore.Configuration ► Settings..::.Profiling ► SheerUIWarningThreshold
Defines the threshold value for logging long requests.
Declaration Syntax
C#
public static int SheerUIWarningThreshold { get; }
Value
The sheer UI warning threshold.


Settings.Publishing Class

Settings..::.Publishing Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Publishing
Declaration Syntax
C#
public static class Publishing
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoScheduleSmartPublish | Gets a value indicating whether to automatically schedule a smart publish when proxy definitions etc. change?
 | CheckSecurity | Determines whether to check security rights when publishing.
 | CompareRevisions | Gets a value indicating whether publishing compares the revisions.
 | LogInterval | Gets the log interval.
 | PublishDialogPollingInterval | Gets the publish dialog polling interval.
 | PublishEmptyItems | Determines if empty items (i.e. items without publishable versions) shold be published.
 | RequireTargetDeleteRightWhenCheckingSecurity | Determines whether to check for delete rights on target items when publishing.
 | ThreadPriority | Gets the thread priority of publishing jobs.
Inheritance Hierarchy
Object
Settings..::.Publishing


AutoScheduleSmartPublish Property

AutoScheduleSmartPublish Property
Namespaces ► Sitecore.Configuration ► Settings..::.Publishing ► AutoScheduleSmartPublish
Gets a value indicating whether to automatically schedule a smart publish when proxy definitions etc. change?
Declaration Syntax
C#
public static bool AutoScheduleSmartPublish { get; }
Value
true if enabled; otherwise, false.


CheckSecurity Property

CheckSecurity Property
Namespaces ► Sitecore.Configuration ► Settings..::.Publishing ► CheckSecurity
Determines whether to check security rights when publishing.
Declaration Syntax
C#
public static bool CheckSecurity { get; }
Value
true if security should be checked; otherwise, false.
Remarks

Only read and write rights are used.

Default value: false.


CompareRevisions Property

CompareRevisions Property
Namespaces ► Sitecore.Configuration ► Settings..::.Publishing ► CompareRevisions
Gets a value indicating whether publishing compares the revisions.
Declaration Syntax
C#
public static bool CompareRevisions { get; }
Value
true if publishing compares the revisions; otherwise, false.


LogInterval Property

LogInterval Property
Namespaces ► Sitecore.Configuration ► Settings..::.Publishing ► LogInterval
Gets the log interval.
Declaration Syntax
C#
public static int LogInterval { get; }
Value
The log interval.


PublishDialogPollingInterval Property

PublishDialogPollingInterval Property
Namespaces ► Sitecore.Configuration ► Settings..::.Publishing ► PublishDialogPollingInterval
Gets the publish dialog polling interval.
Declaration Syntax
C#
public static int PublishDialogPollingInterval { get; }
Value
The publish dialog polling interval.


PublishEmptyItems Property

PublishEmptyItems Property
Namespaces ► Sitecore.Configuration ► Settings..::.Publishing ► PublishEmptyItems
Determines if empty items (i.e. items without publishable versions) shold be published.
Declaration Syntax
C#
public static bool PublishEmptyItems { get; }
Value
true if empty items should be published; otherwise, false.


RequireTargetDeleteRightWhenCheckingSecurity Property

RequireTargetDeleteRightWhenCheckingSecurity Property
Namespaces ► Sitecore.Configuration ► Settings..::.Publishing ► RequireTargetDeleteRightWhenCheckingSecurity
Determines whether to check for delete rights on target items when publishing.
Declaration Syntax
C#
public static bool RequireTargetDeleteRightWhenCheckingSecurity { get; }
Value
true if delete right should be checked; otherwise, false.
Remarks

Only used when CheckSecurity is true.

If set to false all publishing users will be able to publish deletions.

Default value: true.


ThreadPriority Property

ThreadPriority Property
Namespaces ► Sitecore.Configuration ► Settings..::.Publishing ► ThreadPriority
Gets the thread priority of publishing jobs.
Declaration Syntax
C#
public static ThreadPriority ThreadPriority { get; }
Value
The priority. Default value is ThreadPriority.BelowNormal/>


Settings.Query Class

Settings..::.Query Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Query
Declaration Syntax
C#
public static class Query
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MaxItems | Gets the max items.
Inheritance Hierarchy
Object
Settings..::.Query


MaxItems Property

MaxItems Property
Namespaces ► Sitecore.Configuration ► Settings..::.Query ► MaxItems
Gets the max items.
Declaration Syntax
C#
public static int MaxItems { get; }
Value
The max items.


Settings.Rendering Class

Settings..::.Rendering Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Rendering
Declaration Syntax
C#
public static class Rendering
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ImagesAsXhtml | Gets a value indicating whether to render images as XHTML.
 | ProcessDuplicatePlaceholders | Gets a value indicating whether to process duplicate placeholders.
 | SiteResolving | Setting it to true, will cause resolving site information while rendering item links.
 | TypesThatShouldNotBeExpanded | Gets a Set<(Of <(T>)>) of the types that should not be expanded during page building.
Inheritance Hierarchy
Object
Settings..::.Rendering


ImagesAsXhtml Property

ImagesAsXhtml Property
Namespaces ► Sitecore.Configuration ► Settings..::.Rendering ► ImagesAsXhtml
Gets a value indicating whether to render images as XHTML.
Declaration Syntax
C#
public static bool ImagesAsXhtml { get; }
Value
true if images should be rendered as XHTML; otherwise, false.
Remarks
Default value: true


ProcessDuplicatePlaceholders Property

ProcessDuplicatePlaceholders Property
Namespaces ► Sitecore.Configuration ► Settings..::.Rendering ► ProcessDuplicatePlaceholders
Gets a value indicating whether to process duplicate placeholders.
Declaration Syntax
C#
public static bool ProcessDuplicatePlaceholders { get; }
Value
true if [process duplicate placeholders]; otherwise, false.


SiteResolving Property

SiteResolving Property
Namespaces ► Sitecore.Configuration ► Settings..::.Rendering ► SiteResolving
Setting it to true, will cause resolving site information while rendering item links.
Declaration Syntax
C#
public static bool SiteResolving { get; }
Value
true if site resolving is enabled; otherwise, false.


TypesThatShouldNotBeExpanded Property

TypesThatShouldNotBeExpanded Property
Namespaces ► Sitecore.Configuration ► Settings..::.Rendering ► TypesThatShouldNotBeExpanded
Gets a Set<(Of <(T>)>) of the types that should not be expanded during page building.
Declaration Syntax
C#
public static Set<string> TypesThatShouldNotBeExpanded { get; }
Value
The types that should not be expanded.


Settings.RequestErrors Class

Settings..::.RequestErrors Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.RequestErrors
Settings controlling behaviour when a request error condition occurs.
Declaration Syntax
C#
public static class RequestErrors
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UseServerSideRedirect | Gets a value indicating whether the Sitecore uses Server.Transfer instead of Response.Redirect to move to a service page.
Inheritance Hierarchy
Object
Settings..::.RequestErrors


UseServerSideRedirect Property

UseServerSideRedirect Property
Namespaces ► Sitecore.Configuration ► Settings..::.RequestErrors ► UseServerSideRedirect
Gets a value indicating whether the Sitecore uses Server.Transfer instead of Response.Redirect to move to a service page.
Declaration Syntax
C#
public static bool UseServerSideRedirect { get; }
Value
true if Sitecore should use Server.Transfer; otherwise, false.


Settings.Roles Class

Settings..::.Roles Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Roles
Declaration Syntax
C#
public static class Roles
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MaxNameLength | Gets the length of the max name.
Inheritance Hierarchy
Object
Settings..::.Roles


MaxNameLength Property

MaxNameLength Property
Namespaces ► Sitecore.Configuration ► Settings..::.Roles ► MaxNameLength
Gets the length of the max name.
Declaration Syntax
C#
public static int MaxNameLength { get; }
Value
The length of the max name.


Settings.Rules Class

Settings..::.Rules Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Rules
Defines the rule sets class.
Declaration Syntax
C#
public static class Rules
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MaxCachedRules | Gets the number of maxed cached rule sets.
Inheritance Hierarchy
Object
Settings..::.Rules


MaxCachedRules Property

MaxCachedRules Property
Namespaces ► Sitecore.Configuration ► Settings..::.Rules ► MaxCachedRules
Gets the number of maxed cached rule sets.
Declaration Syntax
C#
public static int MaxCachedRules { get; }
Value
The number of maxed cached rule sets.


Settings.Runtime Class

Settings..::.Runtime Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Runtime
Declaration Syntax
C#
public static class Runtime
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EffectiveMaxRequestLengthBytes | Gets the maximum request length in bytes, adjusted to account for system data being transmitted. Defined as maxRequestLength attribute of httpRuntime.
 | MaxRequestLength | Gets the maximum request length. Defined as maxRequestLength attribute of httpRuntime.
Inheritance Hierarchy
Object
Settings..::.Runtime


EffectiveMaxRequestLengthBytes Property

EffectiveMaxRequestLengthBytes Property
Namespaces ► Sitecore.Configuration ► Settings..::.Runtime ► EffectiveMaxRequestLengthBytes
Gets the maximum request length in bytes, adjusted to account for system data being transmitted. Defined as maxRequestLength attribute of httpRuntime.
Declaration Syntax
C#
public static long EffectiveMaxRequestLengthBytes { get; }
Value
The max request length bytes.


MaxRequestLength Property

MaxRequestLength Property
Namespaces ► Sitecore.Configuration ► Settings..::.Runtime ► MaxRequestLength
Gets the maximum request length. Defined as maxRequestLength attribute of httpRuntime.
Declaration Syntax
C#
public static int MaxRequestLength { get; }
Value
The length of the max request.


Settings.Scripts Class

Settings..::.Scripts Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Scripts
Defines the scripts class.
Declaration Syntax
C#
public static class Scripts
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MaxCachedScripts | Gets the max cached scripts.
Inheritance Hierarchy
Object
Settings..::.Scripts


MaxCachedScripts Property

MaxCachedScripts Property
Namespaces ► Sitecore.Configuration ► Settings..::.Scripts ► MaxCachedScripts
Gets the max cached scripts.
Declaration Syntax
C#
public static int MaxCachedScripts { get; }
Value
The max cached scripts.


Settings.Statistics Class

Settings..::.Statistics Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Statistics
Declaration Syntax
C#
public static class Statistics
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CollectRenderingData | Indicates if renderings statistics should be collected.
Inheritance Hierarchy
Object
Settings..::.Statistics


CollectRenderingData Property

CollectRenderingData Property
Namespaces ► Sitecore.Configuration ► Settings..::.Statistics ► CollectRenderingData
Indicates if renderings statistics should be collected.
Declaration Syntax
C#
public static bool CollectRenderingData { get; }
Value
true if renderings statistics should be collected; false otherwise.


Settings.Tasks Class

Settings..::.Tasks Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Tasks
Declaration Syntax
C#
public static class Tasks
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EmailReminderSubject | Gets the subject to use for email reminders.
 | EmailReminderText | Gets the leading text to use for email reminders. Custom text will be appended.
Inheritance Hierarchy
Object
Settings..::.Tasks


EmailReminderSubject Property

EmailReminderSubject Property
Namespaces ► Sitecore.Configuration ► Settings..::.Tasks ► EmailReminderSubject
Gets the subject to use for email reminders.
Declaration Syntax
C#
public static string EmailReminderSubject { get; }
Value
The subject text.


EmailReminderText Property

EmailReminderText Property
Namespaces ► Sitecore.Configuration ► Settings..::.Tasks ► EmailReminderText
Gets the leading text to use for email reminders. Custom text will be appended.
Declaration Syntax
C#
public static string EmailReminderText { get; }
Value
The reminder text.


Settings.Templates Class

Settings..::.Templates Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Templates
Declaration Syntax
C#
public static class Templates
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MaxInheritanceDepth | Gets the max inheritance depth.
Inheritance Hierarchy
Object
Settings..::.Templates


MaxInheritanceDepth Property

MaxInheritanceDepth Property
Namespaces ► Sitecore.Configuration ► Settings..::.Templates ► MaxInheritanceDepth
Gets the max inheritance depth.
Declaration Syntax
C#
public static int MaxInheritanceDepth { get; }
Value
The max inheritance depth.


Settings.Trace Class

Settings..::.Trace Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Trace
Declaration Syntax
C#
public static class Trace
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FormattingXslFile | Gets the formatting XSL file.
Inheritance Hierarchy
Object
Settings..::.Trace


FormattingXslFile Property

FormattingXslFile Property
Namespaces ► Sitecore.Configuration ► Settings..::.Trace ► FormattingXslFile
Gets the formatting XSL file.
Declaration Syntax
C#
public static string FormattingXslFile { get; }
Value
The formatting XSL file.


Settings.UI Class

Settings..::.UI Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.UI
Declaration Syntax
C#
public static class UI
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CalendarTimeOfDay | Defines the default time of day.
Inheritance Hierarchy
Object
Settings..::.UI


CalendarTimeOfDay Property

CalendarTimeOfDay Property
Namespaces ► Sitecore.Configuration ► Settings..::.UI ► CalendarTimeOfDay
Defines the default time of day.
Declaration Syntax
C#
public static TimeSpan CalendarTimeOfDay { get; }
Value
The default time of day.
Remarks
Defines the default time of day when the user user the calendar drop down to select a day. The drop down does not allow the user to set the time of day.


Settings.UnitTests Class

Settings..::.UnitTests Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.UnitTests
Declaration Syntax
C#
public static class UnitTests
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Host | Gets the host.
 | Password | Gets the password.
 | UserName | Gets the name of the user.
Inheritance Hierarchy
Object
Settings..::.UnitTests


Host Property

Host Property
Namespaces ► Sitecore.Configuration ► Settings..::.UnitTests ► Host
Gets the host.
Declaration Syntax
C#
public static string Host { get; }
Value
The host.


Password Property

Password Property
Namespaces ► Sitecore.Configuration ► Settings..::.UnitTests ► Password
Gets the password.
Declaration Syntax
C#
public static string Password { get; }
Value
The password.


UserName Property

UserName Property
Namespaces ► Sitecore.Configuration ► Settings..::.UnitTests ► UserName
Gets the name of the user.
Declaration Syntax
C#
public static string UserName { get; }
Value
The name of the user.


Settings.Upload Class

Settings..::.Upload Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Upload
Declaration Syntax
C#
public static class Upload
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Classic | Indicates if uploading runs in classic (no flash) mode
 | MaximumDatabaseUploadSize | Gets the maximum file size that can be uploaded to database.
 | SimpleUploadOverwriting | Gets a value indicating whether the simple Upload dialog has overwriting on.
 | UserSelectableDestination | Defines if the user can select the destination database or file.
Inheritance Hierarchy
Object
Settings..::.Upload


Classic Property

Classic Property
Namespaces ► Sitecore.Configuration ► Settings..::.Upload ► Classic
Indicates if uploading runs in classic (no flash) mode
Declaration Syntax
C#
public static bool Classic { get; }
Value
true Indicates if uploading runs in classic (no flash) mode; otherwise, false.


MaximumDatabaseUploadSize Property

MaximumDatabaseUploadSize Property
Namespaces ► Sitecore.Configuration ► Settings..::.Upload ► MaximumDatabaseUploadSize
Gets the maximum file size that can be uploaded to database.
Declaration Syntax
C#
public static long MaximumDatabaseUploadSize { get; }
Value
The size of the max file.


SimpleUploadOverwriting Property

SimpleUploadOverwriting Property
Namespaces ► Sitecore.Configuration ► Settings..::.Upload ► SimpleUploadOverwriting
Gets a value indicating whether the simple Upload dialog has overwriting on.
Declaration Syntax
C#
public static bool SimpleUploadOverwriting { get; }
Value
true if the simple Upload dialog has overwriting on; otherwise, false.


UserSelectableDestination Property

UserSelectableDestination Property
Namespaces ► Sitecore.Configuration ► Settings..::.Upload ► UserSelectableDestination
Defines if the user can select the destination database or file.
Declaration Syntax
C#
public static bool UserSelectableDestination { get; }
Value
true if the user can select the destination; otherwise, false.


Settings.Validators Class

Settings..::.Validators Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.Validators
Declaration Syntax
C#
public static class Validators
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutomaticUpdate | Gets a value indicating whether validators are automatically run in the content editor.
 | BlockingExpiry | Gets the blocking expiry.
 | BlockingSleep | Gets the blocking sleep.
 | Expiry | Gets the expiry.
 | UpdateDelay | Gets the update delay.
 | UpdateFrequency | Gets the update frequency.
Inheritance Hierarchy
Object
Settings..::.Validators


AutomaticUpdate Property

AutomaticUpdate Property
Namespaces ► Sitecore.Configuration ► Settings..::.Validators ► AutomaticUpdate
Gets a value indicating whether validators are automatically run in the content editor.
Declaration Syntax
C#
public static bool AutomaticUpdate { get; }
Value
true if validators are automatically run in the content editor; otherwise, false.
Remarks
Setting this to 0 disables automatic updates.


BlockingExpiry Property

BlockingExpiry Property
Namespaces ► Sitecore.Configuration ► Settings..::.Validators ► BlockingExpiry
Gets the blocking expiry.
Declaration Syntax
C#
public static TimeSpan BlockingExpiry { get; }
Value
The blocking expiry.


BlockingSleep Property

BlockingSleep Property
Namespaces ► Sitecore.Configuration ► Settings..::.Validators ► BlockingSleep
Gets the blocking sleep.
Declaration Syntax
C#
public static TimeSpan BlockingSleep { get; }
Value
The blocking sleep.


Expiry Property

Expiry Property
Namespaces ► Sitecore.Configuration ► Settings..::.Validators ► Expiry
Gets the expiry.
Declaration Syntax
C#
public static TimeSpan Expiry { get; }
Value
The expiry.


UpdateDelay Property

UpdateDelay Property
Namespaces ► Sitecore.Configuration ► Settings..::.Validators ► UpdateDelay
Gets the update delay.
Declaration Syntax
C#
public static int UpdateDelay { get; }
Value
The update delay.


UpdateFrequency Property

UpdateFrequency Property
Namespaces ► Sitecore.Configuration ► Settings..::.Validators ► UpdateFrequency
Gets the update frequency.
Declaration Syntax
C#
public static int UpdateFrequency { get; }
Value
The update frequency.


Settings.WebConfig Class

Settings..::.WebConfig Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.WebConfig
WebConfig class
Declaration Syntax
C#
public static class WebConfig
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetNodeAttribute(String, String) | Gets the value of an attribute of the node specified by xpath.
 | GetNodeValue(String) | Gets the value of the node specified by xpath.
 | GetWebConfig()()() | Gets web.config as an XmlDocument.
 | NodeExists(String) | Determines if a node satisfying the specified xpath exists in web.config.
Inheritance Hierarchy
Object
Settings..::.WebConfig


GetNodeAttribute Method (xpath, attributeName)

GetNodeAttribute Method (xpath, attributeName)
Namespaces ► Sitecore.Configuration ► Settings..::.WebConfig ► GetNodeAttribute(String, String)
Gets the value of an attribute of the node specified by xpath.
Declaration Syntax
C#
public static string GetNodeAttribute(
    string xpath,
    string attributeName
)
Parameters
xpath (String)
The xpath.
attributeName (String)
Name of the attribute.
Return Value


GetNodeValue Method (xpath)

GetNodeValue Method (xpath)
Namespaces ► Sitecore.Configuration ► Settings..::.WebConfig ► GetNodeValue(String)
Gets the value of the node specified by xpath.
Declaration Syntax
C#
public static string GetNodeValue(
    string xpath
)
Parameters
xpath (String)
The xpath.
Return Value


GetWebConfig Method

GetWebConfig Method
Namespaces ► Sitecore.Configuration ► Settings..::.WebConfig ► GetWebConfig()()()
Gets web.config as an XmlDocument.
Declaration Syntax
C#
public static XmlDocument GetWebConfig()
Return Value


NodeExists Method (xpath)

NodeExists Method (xpath)
Namespaces ► Sitecore.Configuration ► Settings..::.WebConfig ► NodeExists(String)
Determines if a node satisfying the specified xpath exists in web.config.
Declaration Syntax
C#
public static bool NodeExists(
    string xpath
)
Parameters
xpath (String)
The xpath.
Return Value


Settings.WebEdit Class

Settings..::.WebEdit Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.WebEdit
Declaration Syntax
C#
public static class WebEdit
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Classic | Gets a value indicating whether this Settings..::.WebEdit is classic.
 | ContentEditorStyle | Gets the content editor Iframe CSS style.
 | ContentEditorStylesheet | Gets the content editor stylesheet.
 | CssClass | Gets the CSS class.
 | DefaultButtonPath | Gets the default button path.
 | DisabledCssClass | Gets the disabled CSS class.
 | DisabledDot | Gets the disabled dot.
 | DrawContentDotsByDefault | Gets a value indicating whether WebEdit draws the content dots by default.
 | EnabledDot | Gets the enabled dot.
 | HSpace | Gets the horizontal space.
 | ShowNumberOfLockedItemsOnButton | Gets a value indicating whether [show number of locked items on button].
 | SpaceCssClass | Gets the spacer CSS class.
 | UsePopupContentEditor | Gets a value indicating whether WebEdit uses the popup content editor.
 | VSpace | Gets the vertical space.
Inheritance Hierarchy
Object
Settings..::.WebEdit


Classic Property

Classic Property
Namespaces ► Sitecore.Configuration ► Settings..::.WebEdit ► Classic
Gets a value indicating whether this Settings..::.WebEdit is classic.
Declaration Syntax
C#
public static bool Classic { get; }
Value
true if classic; otherwise, false.


ContentEditorStyle Property

ContentEditorStyle Property
Namespaces ► Sitecore.Configuration ► Settings..::.WebEdit ► ContentEditorStyle
Gets the content editor Iframe CSS style.
Declaration Syntax
C#
public static string ContentEditorStyle { get; }
Value
The content editor Iframe CSS style.


ContentEditorStylesheet Property

ContentEditorStylesheet Property
Namespaces ► Sitecore.Configuration ► Settings..::.WebEdit ► ContentEditorStylesheet
Gets the content editor stylesheet.
Declaration Syntax
C#
public static string ContentEditorStylesheet { get; }
Value
The content editor stylesheet.


CssClass Property

CssClass Property
Namespaces ► Sitecore.Configuration ► Settings..::.WebEdit ► CssClass
Gets the CSS class.
Declaration Syntax
C#
public static string CssClass { get; }
Value
The CSS class.


DefaultButtonPath Property

DefaultButtonPath Property
Namespaces ► Sitecore.Configuration ► Settings..::.WebEdit ► DefaultButtonPath
Gets the default button path.
Declaration Syntax
C#
public static string DefaultButtonPath { get; }
Value
The default button path.


DisabledCssClass Property

DisabledCssClass Property
Namespaces ► Sitecore.Configuration ► Settings..::.WebEdit ► DisabledCssClass
Gets the disabled CSS class.
Declaration Syntax
C#
public static string DisabledCssClass { get; }
Value
The disabled CSS class.


DisabledDot Property

DisabledDot Property
Namespaces ► Sitecore.Configuration ► Settings..::.WebEdit ► DisabledDot
Gets the disabled dot.
Declaration Syntax
C#
public static string DisabledDot { get; }
Value
The disabled dot.


DrawContentDotsByDefault Property

DrawContentDotsByDefault Property
Namespaces ► Sitecore.Configuration ► Settings..::.WebEdit ► DrawContentDotsByDefault
Gets a value indicating whether WebEdit draws the content dots by default.
Declaration Syntax
C#
public static bool DrawContentDotsByDefault { get; }
Value
true if the WebEdit draws the content dots by default; otherwise, false.


EnabledDot Property

EnabledDot Property
Namespaces ► Sitecore.Configuration ► Settings..::.WebEdit ► EnabledDot
Gets the enabled dot.
Declaration Syntax
C#
public static string EnabledDot { get; }
Value
The enabled dot.


HSpace Property

HSpace Property
Namespaces ► Sitecore.Configuration ► Settings..::.WebEdit ► HSpace
Gets the horizontal space.
Declaration Syntax
C#
public static int HSpace { get; }
Value
The horizontal space.


ShowNumberOfLockedItemsOnButton Property

ShowNumberOfLockedItemsOnButton Property
Namespaces ► Sitecore.Configuration ► Settings..::.WebEdit ► ShowNumberOfLockedItemsOnButton
Gets a value indicating whether [show number of locked items on button].
Declaration Syntax
C#
public static bool ShowNumberOfLockedItemsOnButton { get; }
Value
true if [show number of locked items on button]; otherwise, false.


SpaceCssClass Property

SpaceCssClass Property
Namespaces ► Sitecore.Configuration ► Settings..::.WebEdit ► SpaceCssClass
Gets the spacer CSS class.
Declaration Syntax
C#
public static string SpaceCssClass { get; }
Value
The spacer CSS class.


UsePopupContentEditor Property

UsePopupContentEditor Property
Namespaces ► Sitecore.Configuration ► Settings..::.WebEdit ► UsePopupContentEditor
Gets a value indicating whether WebEdit uses the popup content editor.
Declaration Syntax
C#
public static bool UsePopupContentEditor { get; }
Value
true if the WebEdit uses the popup content editor; otherwise, false.


VSpace Property

VSpace Property
Namespaces ► Sitecore.Configuration ► Settings..::.WebEdit ► VSpace
Gets the vertical space.
Declaration Syntax
C#
public static int VSpace { get; }
Value
The vertical space.


Settings.WorldLingo Class

Settings..::.WorldLingo Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.WorldLingo
Declaration Syntax
C#
public static class WorldLingo
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Enabled | Gets a value indicating whether WorldLingo is enabled.
 | Password | Gets the password.
 | Url | Gets the URL.
Inheritance Hierarchy
Object
Settings..::.WorldLingo


Enabled Property

Enabled Property
Namespaces ► Sitecore.Configuration ► Settings..::.WorldLingo ► Enabled
Gets a value indicating whether WorldLingo is enabled.
Declaration Syntax
C#
public static bool Enabled { get; }
Value
true if enabled; otherwise, false.


Password Property

Password Property
Namespaces ► Sitecore.Configuration ► Settings..::.WorldLingo ► Password
Gets the password.
Declaration Syntax
C#
public static string Password { get; }
Value
The password.


Url Property

Url Property
Namespaces ► Sitecore.Configuration ► Settings..::.WorldLingo ► Url
Gets the URL.
Declaration Syntax
C#
public static string Url { get; }
Value
The URL.


Settings.XmlControls Class

Settings..::.XmlControls Class
Namespaces ► Sitecore.Configuration ► Settings ► Settings..::.XmlControls
Declaration Syntax
C#
public static class XmlControls
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ThrowException | Gets a value indicating whether parsing XmlControls can throw an exception.
Inheritance Hierarchy
Object
Settings..::.XmlControls


ThrowException Property

ThrowException Property
Namespaces ► Sitecore.Configuration ► Settings..::.XmlControls ► ThrowException
Gets a value indicating whether parsing XmlControls can throw an exception.
Declaration Syntax
C#
public static bool ThrowException { get; }
Value
true if parsing XmlControls can throw an exception; otherwise, false.


State Class

State Class
Namespaces ► Sitecore.Configuration ► State

Sitecore maintains a state about the current webpage (in the Items collection) and about the current session (in the Session collection).

Typical information include the current user, the current web item, the current master item, the current layout etc.

The State class encapsulates both the Items and Session collections.

Declaration Syntax
C#
public sealed class State
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | State()()() | Initializes a new instance of the State class
 | ActivePublishDate | Gets the active publish date.
 | ActivePublishGroups | Gets the active publish groups.
 | AddRenderings | Gets an array list of renderings to add to the default list of renderings.
 | ClientLanguage | Gets or sets the ISO language code the the current client language.
 | ClientUsesOSWindows | Obsolete. Gets or sets a value indicating whether the client uses OS windows.
 | CommitDisabled | Option to disable commits on items.
 | ContentDatabase | Gets or sets the content database.
 | CurrentLayout | Obsolete. Gets or sets the ID or name of the current layout.
 | CurrentLayoutChanged | Obsolete. Gets or sets a boolean that indicates if current layout was changed.
 | CustomLayout | Gets or sets the ID or name of a custom layout to use for the current page request.
 | DebugMode | Gets or sets a boolean that indicates if Sitecore is in debug mode.
 | Desktop | Gets or sets the path of the client desktop webpage.
 | DisableDefaultRenderings | Gets or sets a boolean that indicates if the default renderings are disabled or not.
 | DisableItemChangeRegistering | Gets or sets a boolean that indicates of item changes are registered.
 | DispatchEvents | Gets or sets a boolean that indicates if events are dispatched.
 | DrawRenderingBorders | Get or sets a boolean that indicates if borders are drawn around renderings.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtensionObjects | Gets the hash list of XSL extention objects.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Form | Gets or sets the current form collection from web page.
 | GetCustom(String) | Gets a custom State variable.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Language | Get or sets the current language code.
 | LastError | Gets a hash list of sections containing the last errors.
 | LayoutGroup | Obsolete. Gets or sets the current layout group.
 | MasterItem | Gets or sets the current master item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreviewDate | Gets or sets the current date/time of a preview.
 | PreviewGroups | Gets or sets the current publishing groups of a preview.
 | Previewing | Gets a value indicating whether the system is previewing.
 | Profiling | Gets or sets a boolean that indicates if profiling data are generated.
 | RemoveCustom(String) | Removes a custom State variable.
 | RemoveRenderings | Gets a has array list of renderings that should be removed from the list of default renderings.
 | ResetAfterWebView | Gets or sets a boolean that indicates if the web editing state should be reset after web view.
 | SetActivePublish(DateTime, String) | Set active publishing info.
 | SetCustom(String, Object) | Sets a custom State variable.
 | ShowEditDots | Gets or sets a boolean that indicates if dots (and panel) are shown in preview and web edit mode.
 | ShowRenderingInfo | Gets or sets a boolean that indicates if rendering info is available.
 | Theme | Gets or sets the current theme.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Tracing | Gets or sets a boolean that indicates if tracing data is collected.
 | Translating | Gets or sets a value indicating whether this State is translating.
 | WebEditing | Gets a value indicating whether the system is web editing.
Inheritance Hierarchy
Object
State


State Constructor

State Constructor
Namespaces ► Sitecore.Configuration ► State ► State()()()
Initializes a new instance of the State class
Declaration Syntax
C#
public State()


ActivePublishDate Property

ActivePublishDate Property
Namespaces ► Sitecore.Configuration ► State ► ActivePublishDate
Gets the active publish date.
Declaration Syntax
C#
public static DateTime ActivePublishDate { get; }
Value
The active publish date.


ActivePublishGroups Property

ActivePublishGroups Property
Namespaces ► Sitecore.Configuration ► State ► ActivePublishGroups
Gets the active publish groups.
Declaration Syntax
C#
public static string ActivePublishGroups { get; }
Value
The active publish groups.


AddRenderings Property

AddRenderings Property
Namespaces ► Sitecore.Configuration ► State ► AddRenderings
Gets an array list of renderings to add to the default list of renderings.
Declaration Syntax
C#
public static ArrayList AddRenderings { get; }
Value
An array list of renderingings.
Remarks

As the web engine renders a page, it builds a list of renderings to add to the page. Normally the renderings are fetched from the current item, but the AddRenderings State variable allows additional renderings to be rendered on the page.

Usually this is used in global.aspx to programatically add new renderings to a page based on certain conditions.

The list consists of either IDs or names of renderings.

The scope of the value is page and it is stored in the Items variable "SC_ADD_RENDERINGS".

Examples
The following code add the SpotBox rendering to the page, and removes the Document rendering, id the user is logged into the extranet.
CopyC#
public PersonalizePage() {
if (ExtranetSecurity.IsLoggedIn) {
State.AddRenderings.Add("SpotBox");
State.RemoveRenderings.Add("Document");
}
}
See Also
RemoveRenderings
DisableDefaultRenderings


ClientLanguage Property

ClientLanguage Property
Namespaces ► Sitecore.Configuration ► State ► ClientLanguage
Gets or sets the ISO language code the the current client language.
Declaration Syntax
C#
public static string ClientLanguage { get; set; }
Value
The current client language ISO code.
Remarks

The client language is the language that the Sitecore client is presented in. For instance if the client language is "da" the client will present all menus, toolbars etc. in the Danish language.

The client language code is usually set when the user logs in. The language code for a user is specified in the Client Language field on the __User template.

If the language code is changed, the Sitecore client must be reloaded in order to retrieve the new language from the server.

The scope of the value is session and it is stored in the Session variable "SC_CLIENT_LANGUAGE".

Examples
The following example checks the client language to provide the correct text.
CopyC#
public string GetWelcomeText() {
if (State.ClientLanguage == "da") {
return "Velkommen";
}
return "Welcome";
}
See Also
Language


ClientUsesOSWindows Property

ClientUsesOSWindows Property
Namespaces ► Sitecore.Configuration ► State ► ClientUsesOSWindows
Gets or sets a value indicating whether the client uses OS windows.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - use State.Client.UsesBrowserWindows")]
public static bool ClientUsesOSWindows { get; set; }
Value
true if the client uses OS windows; otherwise, false.


CommitDisabled Property

CommitDisabled Property
Namespaces ► Sitecore.Configuration ► State ► CommitDisabled
Option to disable commits on items.
Declaration Syntax
C#
public static bool CommitDisabled { get; set; }
Value
true if commits are disabled; otherwise, false.
Remarks
The scope of the value is thread and it is stored in the thread variable "SC_COMMIT_DISABLED".


ContentDatabase Property

ContentDatabase Property
Namespaces ► Sitecore.Configuration ► State ► ContentDatabase
Gets or sets the content database.
Declaration Syntax
C#
public static string ContentDatabase { get; set; }
Value
The content database.


CurrentLayout Property

CurrentLayout Property
Namespaces ► Sitecore.Configuration ► State ► CurrentLayout
Gets or sets the ID or name of the current layout.
Declaration Syntax
C#
[ObsoleteAttribute("Use State.CustomLayout instead")]
public static string CurrentLayout { get; set; }
Value
The ID or name of the current layout.
Remarks

The current layout is the layout that will be rendered by the web engine. This is by default the layout of the current item.

The default layout can be overridden by setting the current layout before the web engine starts. This can be used to build the layout programatically in conjunction with AddRenderings and RemoveRenderings. Normally programatic layouts are built in global.aspx which executes before the web engine.

When programatically setting the current layout, the State property CurrentLayoutChanged is set to true.

By default the current layout is set from then request query string argument "layout". This is argument is set to the layout of the current item by the Sitecore Http Request handler (HttpModule).

The scope of the value is page and it is stored in the Items variable "SC_CURRENT_LAYOUT".

Examples
The following example builds a special layout if the user is a special user.
CopyC#
public void BuildVIPLayout(string user) {
if (user == "VIP") {
State.CurrentLayout = "VIP layout";
State.AddRenderings.Add("VIPRendering");
}
}
See Also
CurrentLayoutChanged


CurrentLayoutChanged Property

CurrentLayoutChanged Property
Namespaces ► Sitecore.Configuration ► State ► CurrentLayoutChanged
Gets or sets a boolean that indicates if current layout was changed.
Declaration Syntax
C#
[ObsoleteAttribute("Use State.CustomLayout instead")]
public static bool CurrentLayoutChanged { get; set; }
Value
True, if the layout has been changed, otherwise false.
Remarks

This boolean is used with with the State variable CurrentLayout. When CurrentLayout is programatically set, CurrentLayoutChanged is set to true.

The scope of the value is page and it is stored in the Items variable "SC_CURRENT_LAYOUT_CHANGED".

Examples
The following example builds a special layout if the user is a special user.
CopyC#
public void BuildVIPLayout(string user) {
if (user == "VIP") {
State.CurrentLayout = "VIP layout";
State.AddRenderings.Add("VIPRendering");
}
}
public void Build() {
bool changed = State.CurrentLayoutChanged; // false
BuildVIPLayout("Employee");
changed = State.CurrentLayoutChanged; // false
BuildVIPLayout("VIP");
changed = State.CurrentLayoutChanged; // true
}
See Also
CurrentLayout


CustomLayout Property

CustomLayout Property
Namespaces ► Sitecore.Configuration ► State ► CustomLayout
Gets or sets the ID or name of a custom layout to use for the current page request.
Declaration Syntax
C#
public static string CustomLayout { get; set; }
Value
The ID or name of the custom layout.
Remarks

The default layout can be overridden by setting the custom layout before the web engine starts (typically in Page_Init or a page handler). This can be used to build the layout programatically in conjunction with AddRenderings and RemoveRenderings.

The scope of the value is page and it is stored in the Items variable "SC_CUSTOM_LAYOUT".

Examples
The following example builds a special layout if the user is a special user.
CopyC#
public void BuildVIPLayout(string user) {
if (user == "VIP") {
State.CustomLayout = "VIP layout";
State.AddRenderings.Add("VIPRendering");
}
void Page_Init() {
BuildVIPLayout(myUser);
}
}


DebugMode Property

DebugMode Property
Namespaces ► Sitecore.Configuration ► State ► DebugMode
Gets or sets a boolean that indicates if Sitecore is in debug mode.
Declaration Syntax
C#
public static bool DebugMode { get; set; }
Value
True, if Sitecore is in debug mode, otherwise false.
Remarks

DebugMode is the global controller of all debug activities. It controls such tools as Profiling, Trace, Rendering Borders and Rendering Info. Only if DebugMode is true will these tools be available.

The DebugMode flag also adds further information on the Debug tab in the content area.

The DebugMode flag can be enabled by specifying the "sc_debug=1" argument on the query string. To disable it, specify "sc_debug=0".

The scope of the value is sesion and it is stored in the Session variable "SC_DEBUGMODE".

See Also
DrawRenderingBorders
Profiling
ShowRenderingInfo
Tracing


Desktop Property

Desktop Property
Namespaces ► Sitecore.Configuration ► State ► Desktop
Gets or sets the path of the client desktop webpage.
Declaration Syntax
C#
public static string Desktop { get; set; }
Value
The path to the webpage that specifies the Sitecore client.
Remarks

A desktop is the basic webpage that contains a Sitecore client. Sitecore only provides one desktop, but customers or partners may implement other desktops.

The desktop is initialized during user login. When the login procedure has completed, the browser is redirected to the desktop webpage.

The desktop for a specific user is specified in the Desktop field on the __User template. This is a lookup field pointing to "/sitecore/system/Desktops and Themes/Desktops".

If the user item does not specify a desktop, the value from DefaultDesktop is used.

The scope of the value is session and it is stored in the Session variable "SC_DESKTOP".

See Also
Theme


DisableDefaultRenderings Property

DisableDefaultRenderings Property
Namespaces ► Sitecore.Configuration ► State ► DisableDefaultRenderings
Gets or sets a boolean that indicates if the default renderings are disabled or not.
Declaration Syntax
C#
public static bool DisableDefaultRenderings { get; set; }
Value
True, if default renderings are disabled, otherwise false.
Remarks

Default renderings are the renderings, specified as part of the current layout. For instance the Home layout may have a Document rendering.

When builing a programatic layout using AddRenderings and RemoveRenderings, it is possible to disable any renderings that the layout specifies.

The scope of the value is page and it stored in the Items variable "SC_DISABLE_DEFAULT_RENDERINGS".

Examples
The following example builds a special layout if the user is a VIP.
CopyC#
public void BuildVIPLayout(string user) {
if (user == "VIP") {
State.DisableDefaultRenderings = true;
State.AddRenderings.Add("VIPRendering");
}
}
See Also
AddRenderings
RemoveRenderings


DisableItemChangeRegistering Property

DisableItemChangeRegistering Property
Namespaces ► Sitecore.Configuration ► State ► DisableItemChangeRegistering
Gets or sets a boolean that indicates of item changes are registered.
Declaration Syntax
C#
public static bool DisableItemChangeRegistering { get; set; }
Value
true if the State disables the item change registering; otherwise, false.
Remarks
The scope of the value is thread and it is stored in the thread variable "SC_COMMIT_DISABLED".


DispatchEvents Property

DispatchEvents Property
Namespaces ► Sitecore.Configuration ► State ► DispatchEvents
Gets or sets a boolean that indicates if events are dispatched.
Declaration Syntax
C#
public static bool DispatchEvents { get; set; }
Value
True, if events are dispatched, otherwise false.
Remarks

The event dispatcher is the event handling mechanism in Sitecore. Certain actions raise events, for instance saving an item, publishing, tracing and exception handling.

This flag can be used to disable event handling on the current web page.

The scope of the value is page and it is stored in the Items variable "SC_DISPATCH_EVENTS".


DrawRenderingBorders Property

DrawRenderingBorders Property
Namespaces ► Sitecore.Configuration ► State ► DrawRenderingBorders
Get or sets a boolean that indicates if borders are drawn around renderings.
Declaration Syntax
C#
public static bool DrawRenderingBorders { get; set; }
Value
True, if DebugMode is true and borders are drawn, otherwise false.
Remarks

When the web engine is running in debug mode, it can drawn borders around each rendering. This makes it easy for the developer to identify individual renderings.

This flag requires that DebugMode is true.

The scope of the value is session and it stored in the Session variable "SC_DRAW_RENDERING_BORDERS".


ExtensionObjects Property

ExtensionObjects Property
Namespaces ► Sitecore.Configuration ► State ► ExtensionObjects
Gets the hash list of XSL extention objects.
Declaration Syntax
C#
public static Hashtable ExtensionObjects { get; }
Value
A hash list of extention objects.
Remarks

An XSL extention is an object that is accessible from within XSL transformations. For instance the XslHelper object, which implements the "sc:fld" function.

The developer may make more extention objects available on a per page basis. It such case the new extention object can be added to this list.

The scope of this list is page only. To add extention objects globally, use the xslExtentions section ion the web.config.

The ExtensionObjects is usually used in global.aspx.

The scope of the value is page and it is stored in the Items variable "SC_EXPAND_LINKED_DATABASES".


Form Property

Form Property
Namespaces ► Sitecore.Configuration ► State ► Form
Gets or sets the current form collection from web page.
Declaration Syntax
C#
public static NameValueCollection Form { get; set; }
Value
The form collection from the current web page.
Remarks

The Sitecore request handler (HttpModule) overrides the current form collection in order to find the correct layout for the page. The normal form collection (Form) is therefore not valid. However Sitecore stores the original form collection in this variable before overwriting it.


GetCustom Method (name)

GetCustom Method (name)
Namespaces ► Sitecore.Configuration ► State ► GetCustom(String)
Gets a custom State variable.
Declaration Syntax
C#
public static Object GetCustom(
    string name
)
Parameters
name (String)
The name of the State variable.
Return Value
The value of the State variable.
Remarks
A custom state variable is stored in the Session object under the name "SC_CUSTOM_" + name.
See Also
SetCustom(String, Object)


Language Property

Language Property
Namespaces ► Sitecore.Configuration ► State ► Language
Get or sets the current language code.
Declaration Syntax
C#
public static string Language { get; set; }
Value
The current language code.
Remarks

The current language specifies which pieces of content, Sitecore fetches by default. For instance if the language code is "da" (Danish), Sitecore will by default fetch contents that have the code "da".

The code is just an identifier, but usually it is an ISO language code, e.g. "en", "en-us", "da", "ge" etc.

This State variable does not change the language of the Sitecore client.

Examples
The following example changes the language to german.
CopyC#
string english = version.GetFieldValue("Text"); // english text
State.Language = "ge";
string german = version.GetFieldValue("Text"); // german text
See Also
ClientLanguage


LastError Property

LastError Property
Namespaces ► Sitecore.Configuration ► State ► LastError
Gets a hash list of sections containing the last errors.
Declaration Syntax
C#
public static Hashtable LastError { get; }
Value
A hash list of of errors.
Remarks
It is possible to log errors using this State variable. The key of the error identifies the type of error, e.g. "Extranet".
Examples
The following example adds an error and retrieves it again.
CopyC#
State.LastError.Add("Extranet", "Unknown user or password");
string error = State.LastError["Extranet"];


LayoutGroup Property

LayoutGroup Property
Namespaces ► Sitecore.Configuration ► State ► LayoutGroup
Gets or sets the current layout group.
Declaration Syntax
C#
[ObsoleteAttribute]
public static string LayoutGroup { get; set; }
Value
The name of the current layout group.
Remarks

A layout groups holds a number of different layouts. When the web engine renders a web page at looks at the current layout. If the current layout is a layout group it selects the layout that matches the current value of this State variable.

For instance the State layout group variable may be set to "Print". If the web engine encounters a layout group, it will select the layout matches "Print".

Layout groups can be specified the request query string by specifying "lg=<value>". In this case the scope of the layout group is page only. The "lg" key name can be specified in the Settings.LayoutGroupQSName web.config setting.

When setting the Layout group variable, the request has usually already started and it is too late to change the Layout group as the layout has already be identified. The solution is the redirect to a web page that sets the layout group and then redirect to the original web page. That way the layout group will be set when the request starts.

The scope of the value is session and it is stored in a cookied named "SC_LAYOUTGROUP".

Examples
The following example sets the layout group to "Netscape".
CopyC#
State.LayoutGroup = "Netscape";


MasterItem Property

MasterItem Property
Namespaces ► Sitecore.Configuration ► State ► MasterItem
Gets or sets the current master item.
Declaration Syntax
C#
public static Item MasterItem { get; set; }
Value
The current Item object.
Remarks

The current master item is used in the Sitecore client. It points to the current loaded item in the content area and is set when the content area page loads.

The scope of the value is page and it is stored the Items variable "SC_CURRENT_MASTER_ITEM".

Examples
The following example processes the children of the current master item.
CopyC#
public void IterateChildren() {
if (State.MasterItem != null) {
SortedList list = State.MasterItem.GetChildrenSorted();
for(int n = 0; n < list.count; n++) {
IMasterItem2 child = list.GetByIndex(n) as IMasterItem2;
ProcessChild(child);
}
}
}


PreviewDate Property

PreviewDate Property
Namespaces ► Sitecore.Configuration ► State ► PreviewDate
Gets or sets the current date/time of a preview.
Declaration Syntax
C#
public static DateTime PreviewDate { get; }
Value
The date/time of the preview.
Remarks

When a preview is generated, it reflects the web site at a certain date and time. This date and time is specified in this State variable.

See Also
PreviewGroups


PreviewGroups Property

PreviewGroups Property
Namespaces ► Sitecore.Configuration ► State ► PreviewGroups
Gets or sets the current publishing groups of a preview.
Declaration Syntax
C#
public static string PreviewGroups { get; }
Value
The publishing groups of the preview.
Remarks
When a preview is generated, it publishes certain publishing groups. These groups are specified in this State variable.


Previewing Property

Previewing Property
Namespaces ► Sitecore.Configuration ► State ► Previewing
Gets a value indicating whether the system is previewing.
Declaration Syntax
C#
public static bool Previewing { get; }
Value
true if the system is previewing; otherwise, false.


Profiling Property

Profiling Property
Namespaces ► Sitecore.Configuration ► State ► Profiling
Gets or sets a boolean that indicates if profiling data are generated.
Declaration Syntax
C#
public static bool Profiling { get; set; }
Value
True, if DebugMode is true and profiling is enabled, otherwise false.
Remarks

When profiling the web engine times each rendering. This information is available on the Sitecore debug pages "http://www.mysite.net/sitecore/debug".

Profiling can only be enabled if DebugMode is true.

The scope of the value is session and it is stored in the Session variable "SC_PROFILING".

See Also
Tracing


RemoveCustom Method (name)

RemoveCustom Method (name)
Namespaces ► Sitecore.Configuration ► State ► RemoveCustom(String)
Removes a custom State variable.
Declaration Syntax
C#
public static void RemoveCustom(
    string name
)
Parameters
name (String)
The name.


RemoveRenderings Property

RemoveRenderings Property
Namespaces ► Sitecore.Configuration ► State ► RemoveRenderings
Gets a has array list of renderings that should be removed from the list of default renderings.
Declaration Syntax
C#
public static ArrayList RemoveRenderings { get; }
Value
An array list of rendering names or IDs.
Remarks

Default renderings are the renderings specified as part of the current layout. For instance the Home layout may have a Document rendering.

When builing a programatic layout using AddRenderings and DisableDefaultRenderings, it is possible to remove default renderings.

Examples
The following code adds the SpotBox rendering to the page, and removes the Document rendering, if the user is logged into the extranet.
CopyC#
public PersonalizePage() {
if (ExtranetSecurity.IsLoggedIn) {
State.AddRenderings.Add("SpotBox");
State.RemoveRenderings.Add("Document");
}
}


ResetAfterWebView Property

ResetAfterWebView Property
Namespaces ► Sitecore.Configuration ► State ► ResetAfterWebView
Gets or sets a boolean that indicates if the web editing state should be reset after web view.
Declaration Syntax
C#
public static bool ResetAfterWebView { get; set; }
Value
True, if it should be reset, otherwise false.
Remarks
This is for internal use only.


SetActivePublish Method (publishDate, groups)

SetActivePublish Method (publishDate, groups)
Namespaces ► Sitecore.Configuration ► State ► SetActivePublish(DateTime, String)
Set active publishing info.
Declaration Syntax
C#
public static void SetActivePublish(
    DateTime publishDate,
    string groups
)
Parameters
publishDate (DateTime)
The publish date.
groups (String)
The groups.


SetCustom Method (name, value)

SetCustom Method (name, value)
Namespaces ► Sitecore.Configuration ► State ► SetCustom(String, Object)
Sets a custom State variable.
Declaration Syntax
C#
public static void SetCustom(
    string name,
    Object value
)
Parameters
name (String)
The name of the State variable.
value (Object)
The value of the State variable.
Remarks
A custom state variable is stored in the Session object under the name "SC_CUSTOM_" + name.
See Also
GetCustom(String)


ShowEditDots Property

ShowEditDots Property
Namespaces ► Sitecore.Configuration ► State ► ShowEditDots
Gets or sets a boolean that indicates if dots (and panel) are shown in preview and web edit mode.
Declaration Syntax
C#
public static bool ShowEditDots { get; }
Value
True, if dots are shown, otherwise false.
Remarks

Dots are the small markers that an editor clicks on in preview or web edit mode to edit the content.

The dots can be turned off. For example this is done in the Web view pane in the Sitecore client.


ShowRenderingInfo Property

ShowRenderingInfo Property
Namespaces ► Sitecore.Configuration ► State ► ShowRenderingInfo
Gets or sets a boolean that indicates if rendering info is available.
Declaration Syntax
C#
public static bool ShowRenderingInfo { get; set; }
Value
True, if DebugMode is true and rendering info should be available, otherwise false.
Remarks

The web engine can render information about each rendering on the web page. That makes it easy for a developer to identify the individual renderings and their parameters.

Rendering information can only be enabled if DebugMode is true.

The scope of the value is session and it is stored in the Session variable "SC_SHOW_RENDERING_INFO".


Theme Property

Theme Property
Namespaces ► Sitecore.Configuration ► State ► Theme
Gets or sets the current theme.
Declaration Syntax
C#
public static string Theme { get; set; }
Value
The name of the current theme.
Remarks

A theme is the appearance of the Sitecore client. Themes control the stylesheet and images used in the client.

The theme is initialized during user login.

The desktop for a specific user is specified in the Theme field on the __User template. This is a lookup field pointing to "/sitecore/system/Desktops and Themes/Themes".

If the user item does not specify a theme, the value from DefaultTheme is used.

The scope of the value is session and it is stored in the Session variable "SC_THEME".

See Also
Desktop


Tracing Property

Tracing Property
Namespaces ► Sitecore.Configuration ► State ► Tracing
Gets or sets a boolean that indicates if tracing data is collected.
Declaration Syntax
C#
public static bool Tracing { get; set; }
Value
True, if DebugMode is true and tracing is enabled, otherwise false.
Remarks

When tracing the web engine collects information about the rendering process. This information is available on the Sitecore debug pages "http://www.mysite.net/sitecore/debug".

Tracing can only be enabled if DebugMode is true.

The scope of the value is session and it is stored in the Session variable "SC_TRACING".

See Also
Profiling


Translating Property

Translating Property
Namespaces ► Sitecore.Configuration ► State ► Translating
Gets or sets a value indicating whether this State is translating.
Declaration Syntax
C#
public static bool Translating { get; set; }
Value
true if translating; otherwise, false.


WebEditing Property

WebEditing Property
Namespaces ► Sitecore.Configuration ► State ► WebEditing
Gets a value indicating whether the system is web editing.
Declaration Syntax
C#
public static bool WebEditing { get; }
Value
true if the system is web editing; otherwise, false.


State.Client Class

State..::.Client Class
Namespaces ► Sitecore.Configuration ► State ► State..::.Client
Declaration Syntax
C#
public static class Client
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsFullscreen | Gets or sets a value indicating whether this session is fullscreen.
 | NoDesktop | Gets or sets a value indicating whether the browser shows the the desktop.
 | UsesBrowserWindows | Gets or sets a value indicating whether the session uses browser windows.
Inheritance Hierarchy
Object
State..::.Client


IsFullscreen Property

IsFullscreen Property
Namespaces ► Sitecore.Configuration ► State..::.Client ► IsFullscreen
Gets or sets a value indicating whether this session is fullscreen.
Declaration Syntax
C#
public static bool IsFullscreen { get; set; }
Value
true if this session is fullscreen; otherwise, false.


NoDesktop Property

NoDesktop Property
Namespaces ► Sitecore.Configuration ► State..::.Client ► NoDesktop
Gets or sets a value indicating whether the browser shows the the desktop.
Declaration Syntax
C#
public static bool NoDesktop { get; set; }
Value
true if the browser shows the the desktop; otherwise, false.


UsesBrowserWindows Property

UsesBrowserWindows Property
Namespaces ► Sitecore.Configuration ► State..::.Client ► UsesBrowserWindows
Gets or sets a value indicating whether the session uses browser windows.
Declaration Syntax
C#
public static bool UsesBrowserWindows { get; set; }
Value
true if the session uses browser windows; otherwise, false.


State.HttpRuntime Class

State..::.HttpRuntime Class
Namespaces ► Sitecore.Configuration ► State ► State..::.HttpRuntime
Declaration Syntax
C#
public static class HttpRuntime
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AppDomainAppPath | Gets or sets the application domain application path.
Inheritance Hierarchy
Object
State..::.HttpRuntime


AppDomainAppPath Property

AppDomainAppPath Property
Namespaces ► Sitecore.Configuration ► State..::.HttpRuntime ► AppDomainAppPath
Gets or sets the application domain application path.
Declaration Syntax
C#
public static string AppDomainAppPath { get; set; }
Value
The application domain application path.


State.PageDesigner Class

State..::.PageDesigner Class
Namespaces ► Sitecore.Configuration ► State ► State..::.PageDesigner
PageDesigner state
Declaration Syntax
C#
public static class PageDesigner
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CurrentDevice | Gets or sets the current device.
Inheritance Hierarchy
Object
State..::.PageDesigner


CurrentDevice Property

CurrentDevice Property
Namespaces ► Sitecore.Configuration ► State..::.PageDesigner ► CurrentDevice
Gets or sets the current device.
Declaration Syntax
C#
public static string CurrentDevice { get; set; }
Value
The current device.


State.Request Class

State..::.Request Class
Namespaces ► Sitecore.Configuration ► State ► State..::.Request
Declaration Syntax
C#
public static class Request
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ContentType | Gets or sets a value indicating whether this session is fullscreen.
Inheritance Hierarchy
Object
State..::.Request


ContentType Property

ContentType Property
Namespaces ► Sitecore.Configuration ► State..::.Request ► ContentType
Gets or sets a value indicating whether this session is fullscreen.
Declaration Syntax
C#
public static string ContentType { get; set; }
Value
true if this session is fullscreen; otherwise, false.


State.Sites Class

State..::.Sites Class
Namespaces ► Sitecore.Configuration ► State ► State..::.Sites
Declaration Syntax
C#
public static class Sites
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsSiteResolved | Gets or sets a value indicating whether the current site has been resolved.
Inheritance Hierarchy
Object
State..::.Sites


IsSiteResolved Property

IsSiteResolved Property
Namespaces ► Sitecore.Configuration ► State..::.Sites ► IsSiteResolved
Gets or sets a value indicating whether the current site has been resolved.
Declaration Syntax
C#
public static bool IsSiteResolved { get; set; }
Value
true if the current site has been resolved; otherwise, false.


StateContext Class

StateContext Class
Namespaces ► Sitecore.Configuration ► StateContext
Represents the state context.
Declaration Syntax
C#
public class StateContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StateContext()()() | Initializes a new instance of the StateContext class
 | DataBind | Gets or sets a boolean that indicates if the DataBind()()() method should be called for current page.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
StateContext


StateContext Constructor

StateContext Constructor
Namespaces ► Sitecore.Configuration ► StateContext ► StateContext()()()
Initializes a new instance of the StateContext class
Declaration Syntax
C#
public StateContext()


DataBind Property

DataBind Property
Namespaces ► Sitecore.Configuration ► StateContext ► DataBind
Gets or sets a boolean that indicates if the DataBind()()() method should be called for current page.
Declaration Syntax
C#
public bool DataBind { get; set; }
Value
True, if DataBind()()() should be called, otherwise false.
Remarks

This flag indicates if the DataBind()()() method should be called by the web engine.

The default value is controlled by AutomaticDataBind.

The scope of the value is page and it is stored in the Items variable "SC_DATA_BIND".


XmlConfigFile Class

XmlConfigFile Class
Namespaces ► Sitecore.Configuration ► XmlConfigFile
XmlConfigFile
Declaration Syntax
C#
public class XmlConfigFile
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | XmlConfigFile()()() | Initializes a new instance of the XmlConfigFile class
 | CreateObjects(String) | Creates all objects matching xpath.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoadFromFile(String) | Loads a configuration file from a file.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
XmlConfigFile


XmlConfigFile Constructor

XmlConfigFile Constructor
Namespaces ► Sitecore.Configuration ► XmlConfigFile ► XmlConfigFile()()()
Initializes a new instance of the XmlConfigFile class
Declaration Syntax
C#
public XmlConfigFile()


CreateObjects Method (xpath)

CreateObjects Method (xpath)
Namespaces ► Sitecore.Configuration ► XmlConfigFile ► CreateObjects(String)
Creates all objects matching xpath.
Declaration Syntax
C#
public List<Domain> CreateObjects(
    string xpath
)
Parameters
xpath (String)
The xpath.
Return Value
Exceptions
Exception | Condition
NotImplementedException | NotImplementedException.


LoadFromFile Method (filePath)

LoadFromFile Method (filePath)
Namespaces ► Sitecore.Configuration ► XmlConfigFile ► LoadFromFile(String)
Loads a configuration file from a file.
Declaration Syntax
C#
public static XmlConfigFile LoadFromFile(
    string filePath
)
Parameters
filePath (String)
The file path.
Return Value
Exceptions
Exception | Condition
NotImplementedException | NotImplementedException.


XmlConfigRecord Class

XmlConfigRecord Class
Namespaces ► Sitecore.Configuration ► XmlConfigRecord
XmlConfigRecord class
Declaration Syntax
C#
public class XmlConfigRecord : ConfigRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlConfigRecord(XmlNode, ConfigStore) | Initializes a new instance of the XmlConfigRecord class.
 | AddRecord(String) | Adds the record. (Overrides ConfigRecord.AddRecord(String).)
 | AddRecord(String, String, array<String>[]()[]) | Adds a new child record to the record. (Inherited from ConfigRecord.)
 | Attributes | Gets the attributes. (Overrides ConfigRecord.Attributes.)
 | ConfigStore | Gets the store. (Inherited from ConfigRecord.)
 | CreateObject<(Of <(T>)>)()()() | Creates the object represented by the record. (Overrides ConfigRecord.CreateObject<(Of <(T>)>)()()().)
 | CreateObjects<(Of <(T>)>)(String) | Creates objects from all child record with the name specified in recordName. (Inherited from ConfigRecord.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildRecord(String) | Gets a child record with the specified name. (Overrides ConfigRecord.GetChildRecord(String).)
 | GetChildRecords()()() | Gets all child records. (Overrides ConfigRecord.GetChildRecords()()().)
 | GetChildRecords(String) | Gets all child records with the specified name. (Overrides ConfigRecord.GetChildRecords(String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNamedChildRecord(String, String) | Gets a named child record. (Overrides ConfigRecord.GetNamedChildRecord(String, String).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the textual value of the record. (Overrides ConfigRecord.GetValue()()().)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from ConfigRecord.)
 | Remove()()() | Removes the record from the config store. (Overrides ConfigRecord.Remove()()().)
 | SetAttribute(String, String) | Sets the attribute. (Overrides ConfigRecord.SetAttribute(String, String).)
 | SetValue(String) | Sets the value. (Overrides ConfigRecord.SetValue(String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ConfigRecord
 |  | XmlConfigRecord


XmlConfigRecord Constructor (node, store)

XmlConfigRecord Constructor (node, store)
Namespaces ► Sitecore.Configuration ► XmlConfigRecord ► XmlConfigRecord(XmlNode, ConfigStore)
Initializes a new instance of the XmlConfigRecord class.
Declaration Syntax
C#
public XmlConfigRecord(
    XmlNode node,
    ConfigStore store
)
Parameters
node (XmlNode)
The node.
store (ConfigStore)
The store.


AddRecord Method (recordName)

AddRecord Method (recordName)
Namespaces ► Sitecore.Configuration ► XmlConfigRecord ► AddRecord(String)
Adds the record.
Declaration Syntax
C#
public override ConfigRecord AddRecord(
    string recordName
)
Parameters
recordName (String)
Name of the record.
Return Value


Attributes Property

Attributes Property
Namespaces ► Sitecore.Configuration ► XmlConfigRecord ► Attributes
Gets the attributes.
Declaration Syntax
C#
public override AttributeList Attributes { get; }
Value
The attributes.


CreateObject Method

CreateObject<(Of <(T>)>) Method
Namespaces ► Sitecore.Configuration ► XmlConfigRecord ► CreateObject<(Of <(T>)>)()()()
Creates the object represented by the record.
Declaration Syntax
C#
public override T CreateObject<T>()
where T : class
Generic Template Parameters
T
Return Value
Exceptions
Exception | Condition
ConfigurationException |


GetChildRecord Method (recordName)

GetChildRecord Method (recordName)
Namespaces ► Sitecore.Configuration ► XmlConfigRecord ► GetChildRecord(String)
Gets a child record with the specified name.
Declaration Syntax
C#
public override ConfigRecord GetChildRecord(
    string recordName
)
Parameters
recordName (String)
Name of the record.
Return Value


GetChildRecords Method

GetChildRecords Method
Namespaces ► Sitecore.Configuration ► XmlConfigRecord ► GetChildRecords()()()
Members
Icon | Member | Description
 | GetChildRecords()()() | Gets all child records. (Overrides ConfigRecord.GetChildRecords()()().)
 | GetChildRecords(String) | Gets all child records with the specified name. (Overrides ConfigRecord.GetChildRecords(String).)


GetChildRecords Method

GetChildRecords Method
Namespaces ► Sitecore.Configuration ► XmlConfigRecord ► GetChildRecords()()()
Gets all child records.
Declaration Syntax
C#
public override List<ConfigRecord> GetChildRecords()
Return Value


GetChildRecords Method (recordName)

GetChildRecords Method (recordName)
Namespaces ► Sitecore.Configuration ► XmlConfigRecord ► GetChildRecords(String)
Gets all child records with the specified name.
Declaration Syntax
C#
public override List<ConfigRecord> GetChildRecords(
    string recordName
)
Parameters
recordName (String)
Name of the record.
Return Value


GetNamedChildRecord Method (recordName, name)

GetNamedChildRecord Method (recordName, name)
Namespaces ► Sitecore.Configuration ► XmlConfigRecord ► GetNamedChildRecord(String, String)
Gets a named child record.
Declaration Syntax
C#
public override ConfigRecord GetNamedChildRecord(
    string recordName,
    string name
)
Parameters
recordName (String)
Name of the record.
name (String)
The name.


GetValue Method

GetValue Method
Namespaces ► Sitecore.Configuration ► XmlConfigRecord ► GetValue()()()
Gets the textual value of the record.
Declaration Syntax
C#
public override string GetValue()


Remove Method

Remove Method
Namespaces ► Sitecore.Configuration ► XmlConfigRecord ► Remove()()()
Removes the record from the config store.
Declaration Syntax
C#
public override void Remove()


SetAttribute Method (attributeName, value)

SetAttribute Method (attributeName, value)
Namespaces ► Sitecore.Configuration ► XmlConfigRecord ► SetAttribute(String, String)
Sets the attribute.
Declaration Syntax
C#
public override void SetAttribute(
    string attributeName,
    string value
)
Parameters
attributeName (String)
Name of the attribute.
value (String)
The value.


SetValue Method (value)

SetValue Method (value)
Namespaces ► Sitecore.Configuration ► XmlConfigRecord ► SetValue(String)
Sets the value.
Declaration Syntax
C#
public override void SetValue(
    string value
)
Parameters
value (String)
The value.


XmlConfigStore Class

XmlConfigStore Class
Namespaces ► Sitecore.Configuration ► XmlConfigStore
XmlConfigStore class
Declaration Syntax
C#
public class XmlConfigStore : ConfigStore
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlConfigStore(String) | Initializes a new instance of the XmlConfigStore class.
 | CommitChanges()()() | Commits the changes. (Overrides ConfigStore.CommitChanges()()().)
 | ConfigChanged | Occurs when configuration has been changed (externally). (Inherited from ConfigStore.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath | Gets the file path.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTemplateRecord(String, String) | Gets the template record. (Inherited from ConfigStore.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoadFromFile(String) | Loads from file.
 | LoadFromXml(XmlDocument) | Loads the config store from an XML document.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotifyConfigChanged()()() | Notifies that the configuration file has been changed. (Overrides ConfigStore.NotifyConfigChanged()()().)
 | Reload()()() | Reloads this instance.
 | RootRecord | Gets the root record. (Overrides ConfigStore.RootRecord.)
 | SaveToFile(String) | Saves to file.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ConfigStore
 |  | XmlConfigStore


XmlConfigStore Constructor (rootElementName)

XmlConfigStore Constructor (rootElementName)
Namespaces ► Sitecore.Configuration ► XmlConfigStore ► XmlConfigStore(String)
Initializes a new instance of the XmlConfigStore class.
Declaration Syntax
C#
public XmlConfigStore(
    string rootElementName
)
Parameters
rootElementName (String)


CommitChanges Method

CommitChanges Method
Namespaces ► Sitecore.Configuration ► XmlConfigStore ► CommitChanges()()()
Commits the changes.
Declaration Syntax
C#
public override void CommitChanges()


FilePath Property

FilePath Property
Namespaces ► Sitecore.Configuration ► XmlConfigStore ► FilePath
Gets the file path.
Declaration Syntax
C#
public virtual string FilePath { get; }
Value
The file path.


LoadFromFile Method (filePath)

LoadFromFile Method (filePath)
Namespaces ► Sitecore.Configuration ► XmlConfigStore ► LoadFromFile(String)
Loads from file.
Declaration Syntax
C#
public static XmlConfigStore LoadFromFile(
    string filePath
)
Parameters
filePath (String)
The file path.
Return Value


LoadFromXml Method (document)

LoadFromXml Method (document)
Namespaces ► Sitecore.Configuration ► XmlConfigStore ► LoadFromXml(XmlDocument)
Loads the config store from an XML document.
Declaration Syntax
C#
public static XmlConfigStore LoadFromXml(
    XmlDocument document
)
Parameters
document (XmlDocument)
The document.
Return Value


NotifyConfigChanged Method

NotifyConfigChanged Method
Namespaces ► Sitecore.Configuration ► XmlConfigStore ► NotifyConfigChanged()()()
Notifies that the configuration file has been changed.
Declaration Syntax
C#
protected override void NotifyConfigChanged()


Reload Method

Reload Method
Namespaces ► Sitecore.Configuration ► XmlConfigStore ► Reload()()()
Reloads this instance.
Declaration Syntax
C#
protected virtual void Reload()


RootRecord Property

RootRecord Property
Namespaces ► Sitecore.Configuration ► XmlConfigStore ► RootRecord
Gets the root record.
Declaration Syntax
C#
public override ConfigRecord RootRecord { get; }
Value
The root record.


SaveToFile Method (filePath)

SaveToFile Method (filePath)
Namespaces ► Sitecore.Configuration ► XmlConfigStore ► SaveToFile(String)
Saves to file.
Declaration Syntax
C#
public virtual void SaveToFile(
    string filePath
)
Parameters
filePath (String)
The file path.


Sitecore.Controls Namespace

Sitecore.Controls Namespace
Namespaces ► Sitecore.Controls
Declaration Syntax
C#
namespace Sitecore.Controls
Types
All Types Classes
Icon | Type | Description
 | DialogPage | Represents the Device Editor form.
 | ModalDialogPage | Represents the Device Editor form.
 | Wizard | Provides a class that handles wizard dialog forms.
 | WizardPage | WizardPage class


DialogPage Class

DialogPage Class
Namespaces ► Sitecore.Controls ► DialogPage
Represents the Device Editor form.
Declaration Syntax
C#
public class DialogPage : XamlMainControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DialogPage()()() | Initializes a new instance of the DialogPage class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets or sets the application. (Inherited from XamlMainControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cancel_Click()()() | Handles a click on the OK button.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OK_Click()()() | Handles a click on the OK button.
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from XamlMainControl.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text.
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | XamlMainControl
 |  |  |  |  | DialogPage
 |  |  |  |  |  | CampaignFieldPage
 |  |  |  |  |  | FilterDetailsPage
 |  |  |  |  |  | FilterEditorPage
 |  |  |  |  |  | SelectDatabaseRowPage
 |  |  |  |  |  | TrackingFieldDetailsPage
 |  |  |  |  |  | TrackingFieldPageBase
 |  |  |  |  |  | VisitorIdentificationPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DialogPage Constructor

DialogPage Constructor
Namespaces ► Sitecore.Controls ► DialogPage ► DialogPage()()()
Initializes a new instance of the DialogPage class
Declaration Syntax
C#
public DialogPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Cancel_Click Method

Cancel_Click Method
Namespaces ► Sitecore.Controls ► DialogPage ► Cancel_Click()()()
Handles a click on the OK button.
Declaration Syntax
C#
protected virtual void Cancel_Click()
Remarks
When the user clicks OK, the dialog is closed by calling the CloseWindow method.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Header Property

Header Property
Namespaces ► Sitecore.Controls ► DialogPage ► Header
Gets or sets the header.
Declaration Syntax
C#
protected string Header { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OK_Click Method

OK_Click Method
Namespaces ► Sitecore.Controls ► DialogPage ► OK_Click()()()
Handles a click on the OK button.
Declaration Syntax
C#
protected virtual void OK_Click()
Remarks
When the user clicks OK, the dialog is closed by calling the CloseWindow method.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Text Property

Text Property
Namespaces ► Sitecore.Controls ► DialogPage ► Text
Gets or sets the text.
Declaration Syntax
C#
protected string Text { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ModalDialogPage Class

ModalDialogPage Class
Namespaces ► Sitecore.Controls ► ModalDialogPage
Represents the Device Editor form.
Declaration Syntax
C#
public class ModalDialogPage : XamlMainControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ModalDialogPage()()() | Initializes a new instance of the ModalDialogPage class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets or sets the application. (Inherited from XamlMainControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Close_Click()()() | Handles a click on the OK button.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from XamlMainControl.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | XamlMainControl
 |  |  |  |  | ModalDialogPage
 |  |  |  |  |  | SubscriptionPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ModalDialogPage Constructor

ModalDialogPage Constructor
Namespaces ► Sitecore.Controls ► ModalDialogPage ► ModalDialogPage()()()
Initializes a new instance of the ModalDialogPage class
Declaration Syntax
C#
public ModalDialogPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Close_Click Method

Close_Click Method
Namespaces ► Sitecore.Controls ► ModalDialogPage ► Close_Click()()()
Handles a click on the OK button.
Declaration Syntax
C#
protected virtual void Close_Click()
Remarks
When the user clicks OK, the dialog is closed by calling the CloseWindow method.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Wizard Class

Wizard Class
Namespaces ► Sitecore.Controls ► Wizard
Provides a class that handles wizard dialog forms.
Declaration Syntax
C#
public class Wizard : XamlControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Wizard()()() | Initializes a new instance of the Wizard class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Active | Gets or sets the active page name.
 | ActivePageChanged(String, String) | Called when the active page has been changed.
 | ActivePageChanging(String, String%) | Called when the active page is changing.
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | Back()()() | Back.
 | BackButton |
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cancel()()() | Cancel.
 | CancelButton |
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CloseWizard(ClientPipelineArgs) | Shows a confirmation window.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EndWizard()()() | Ends the wizard.
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | Next()()() | Moves the wizard to the next page.
 | NextButton |
 | OnBack(Object, EventArgs) | Called when the user clicks the Back button.
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCancel(Object, EventArgs) | Called when the user clicks the Cancel button.
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides XamlControl.OnLoad(EventArgs).)
 | OnNext(Object, EventArgs) | Called when the user clicks the Next button.
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Pages | Gets the pages.
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Remarks

The class has methods to handles Next, Back and Cancel button clicks. These methods can be overridden to provide other functionality.

Further more the path through the wizard pages can be controlled by overridding the ActivePageChanging and ActivePageChanged methods.

Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | Wizard

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Wizard Constructor

Wizard Constructor
Namespaces ► Sitecore.Controls ► Wizard ► Wizard()()()
Initializes a new instance of the Wizard class
Declaration Syntax
C#
public Wizard()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Active Property

Active Property
Namespaces ► Sitecore.Controls ► Wizard ► Active
Gets or sets the active page name.
Declaration Syntax
C#
public string Active { get; set; }
Value
The active name.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ActivePageChanged Method (page, oldPage)

ActivePageChanged Method (page, oldPage)
Namespaces ► Sitecore.Controls ► Wizard ► ActivePageChanged(String, String)
Called when the active page has been changed.
Declaration Syntax
C#
protected virtual void ActivePageChanged(
    string page,
    string oldPage
)
Parameters
page (String)
The page that has been entered.
oldPage (String)
The page that was left.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ActivePageChanging Method (page, newpage)

ActivePageChanging Method (page, newpage)
Namespaces ► Sitecore.Controls ► Wizard ► ActivePageChanging(String, String%)
Called when the active page is changing.
Declaration Syntax
C#
protected virtual bool ActivePageChanging(
    string page,
    ref string newpage
)
Parameters
page (String)
The page that is being left.
newpage ( String %)
The new page that is being entered.
Return Value
True, if the change is allowed, otherwise false.
Remarks
Set the newpage parameter to another page ID to control the path through the wizard pages.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Back Method

Back Method
Namespaces ► Sitecore.Controls ► Wizard ► Back()()()
Back.
Declaration Syntax
C#
public void Back()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


BackButton Property

BackButton Property
Namespaces ► Sitecore.Controls ► Wizard ► BackButton
Declaration Syntax
C#
protected Button BackButton { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Cancel Method

Cancel Method
Namespaces ► Sitecore.Controls ► Wizard ► Cancel()()()
Cancel.
Declaration Syntax
C#
public void Cancel()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CancelButton Property

CancelButton Property
Namespaces ► Sitecore.Controls ► Wizard ► CancelButton
Declaration Syntax
C#
protected Button CancelButton { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CloseWizard Method (args)

CloseWizard Method (args)
Namespaces ► Sitecore.Controls ► Wizard ► CloseWizard(ClientPipelineArgs)
Shows a confirmation window.
Declaration Syntax
C#
protected void CloseWizard(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


EndWizard Method

EndWizard Method
Namespaces ► Sitecore.Controls ► Wizard ► EndWizard()()()
Ends the wizard.
Declaration Syntax
C#
protected virtual void EndWizard()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Next Method

Next Method
Namespaces ► Sitecore.Controls ► Wizard ► Next()()()
Moves the wizard to the next page.
Declaration Syntax
C#
public void Next()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


NextButton Property

NextButton Property
Namespaces ► Sitecore.Controls ► Wizard ► NextButton
Declaration Syntax
C#
protected Button NextButton { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnBack Method (sender, formEventArgs)

OnBack Method (sender, formEventArgs)
Namespaces ► Sitecore.Controls ► Wizard ► OnBack(Object, EventArgs)
Called when the user clicks the Back button.
Declaration Syntax
C#
protected virtual void OnBack(
    Object sender,
    EventArgs formEventArgs
)
Parameters
sender (Object)
The sender.
formEventArgs (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnCancel Method (sender, formEventArgs)

OnCancel Method (sender, formEventArgs)
Namespaces ► Sitecore.Controls ► Wizard ► OnCancel(Object, EventArgs)
Called when the user clicks the Cancel button.
Declaration Syntax
C#
protected virtual void OnCancel(
    Object sender,
    EventArgs formEventArgs
)
Parameters
sender (Object)
The sender.
formEventArgs (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Controls ► Wizard ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnNext Method (sender, formEventArgs)

OnNext Method (sender, formEventArgs)
Namespaces ► Sitecore.Controls ► Wizard ► OnNext(Object, EventArgs)
Called when the user clicks the Next button.
Declaration Syntax
C#
protected virtual void OnNext(
    Object sender,
    EventArgs formEventArgs
)
Parameters
sender (Object)
The sender.
formEventArgs (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Pages Property

Pages Property
Namespaces ► Sitecore.Controls ► Wizard ► Pages
Gets the pages.
Declaration Syntax
C#
public StringCollection Pages { get; set; }
Value
The pages.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


WizardPage Class

WizardPage Class
Namespaces ► Sitecore.Controls ► WizardPage
WizardPage class
Declaration Syntax
C#
public class WizardPage : XamlControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WizardPage()()() | Initializes a new instance of the WizardPage class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from XamlControl.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | WizardPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


WizardPage Constructor

WizardPage Constructor
Namespaces ► Sitecore.Controls ► WizardPage ► WizardPage()()()
Initializes a new instance of the WizardPage class
Declaration Syntax
C#
public WizardPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Data Namespace

Sitecore.Data Namespace
Namespaces ► Sitecore.Data
Declaration Syntax
C#
namespace Sitecore.Data
Types
All Types Classes Structures Enumerations
Icon | Type | Description
 | AliasResolver | Resolves an alias.
 | Appearance | Defines the appearance properties.
 | BranchId | Represents a master ID.
 | BranchRecords | Represents the masters that are defined in a specified database.
 | BulkUpdateContext | BatchUpdateContext class
 | Database | Represents a database. Represents a database.
 | DatabaseCacheDisabler | Disables database caches for given thread.
 | DatabaseCaches | Stores caches for a database.
 | DatabaseEngines | DatabaseEngines
 | DatabaseProperties | Stores custom properties for a database.
 | DatabaseSwitcher | Switches to another database temporarily.
 | DataManager | Represents the data manager.
 | Database..::.DataRecords | Items records
 | DataSource | Represents a data source.
 | DataUri | Represents a moniker to an item in a specified database.
 | DeviceRecords | Represents the layout devices that are defined in a specified database.
 | FieldDescriptor | Defines the field URI class.
 | FieldList | Represents a list of fields.
 | ID | An ID represents a unique identifier.
 | ItemData | Represents item data.
 | ItemDefinition | Represents an item definition.
 | ItemInformation | ItemInformation
 | ItemPath | Contains utility properties and function that describe the path of an item.
 | ItemPointer | Points to an item.
 | ItemRecords | Provides access to the items in a database.
 | ItemUri | Provides a moniker to an item in a database.
 | ItemUriBuilder | Builds an ItemUri.
 | ItemUriFormat | Defines how the string representation of an ItemURI is formatted.
 | LayoutRecords | Represents the layout that are defined in a specified database.
 | LongID | A LongID is a fully qualified ID path.
 | MasterVariablesReplacer | Represents a master variables replacer.
 | PropertiesBase | Defines a meta data store for a database.
 | RenderingRecords | Represents the renderings that are defined in a specified database.
 | ShortID | Represents an ID in a compressed form.
 | SortCriteria | GridSort
 | StandardValuesManager | StandardValueManager class
 | StandardValuesProvider | StandardValuesProvider
 | StandardValuesProviderCollection | StandardValuesProviderCollection class
 | TreeNavigator..::.State | Represents the state of a tree navigator.
 | SublayoutRecords | Represents the sublayouts in a database.
 | TemplateID | Represents a template ID.
 | TemplateRecords | Represents the templates that are defined in a specified database.
 | TreeNavigator | Obsolete. Represents a tree navigator.
 | Version | Represents a version number of an item.
 | VersionComparer | Represents a version comparer.
 | VersioningType | Defines the type of versioning for a field.
 | VersionUri | Represents an Uri to a Version.


AliasResolver Class

AliasResolver Class
Namespaces ► Sitecore.Data ► AliasResolver
Resolves an alias.
Declaration Syntax
C#
public class AliasResolver
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AliasResolver(Database) | Creates a new AliasResolver instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(String) | Determines if an alias point to a valid item.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTargetID(String) | Gets the target ID.
 | GetTargetUrl(String) | Gets the target URL.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets a LinkField form a specified alias.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

An alias is a URL that points to another location in the content tree. For instance the URL "/campaign" can be setup to point to "/sitecore/content/Home/Campaigns/2005/Super Offers".

Aliases are configures in /sitecore/system/Aliases

An alias resolver is attach to a database and is access through the Sitecore.Data.Database.Aliases property.

Inheritance Hierarchy
Object
AliasResolver


AliasResolver Constructor (database)

AliasResolver Constructor (database)
Namespaces ► Sitecore.Data ► AliasResolver ► AliasResolver(Database)
Creates a new AliasResolver instance.
Declaration Syntax
C#
public AliasResolver(
    Database database
)
Parameters
database (Database)
Database.


Exists Method (alias)

Exists Method (alias)
Namespaces ► Sitecore.Data ► AliasResolver ► Exists(String)
Determines if an alias point to a valid item.
Declaration Syntax
C#
public bool Exists(
    string alias
)
Parameters
alias (String)
Alias.
Return Value
The exists.


GetTargetID Method (alias)

GetTargetID Method (alias)
Namespaces ► Sitecore.Data ► AliasResolver ► GetTargetID(String)
Gets the target ID.
Declaration Syntax
C#
public ID GetTargetID(
    string alias
)
Parameters
alias (String)
Alias.
Return Value
The target ID.


GetTargetUrl Method (alias)

GetTargetUrl Method (alias)
Namespaces ► Sitecore.Data ► AliasResolver ► GetTargetUrl(String)
Gets the target URL.
Declaration Syntax
C#
public string GetTargetUrl(
    string alias
)
Parameters
alias (String)
Alias.
Return Value
The target URL.


Item Property (alias)

Item Property (alias)
Namespaces ► Sitecore.Data ► AliasResolver ► Item[([(String])])
Gets a LinkField form a specified alias.
Declaration Syntax
C#
public LinkField this[
    string alias
] { get; }
Parameters
alias (String)


Appearance Class

Appearance Class
Namespaces ► Sitecore.Data ► Appearance
Defines the appearance properties.
Declaration Syntax
C#
public class Appearance
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Appearance()()() | Creates a new Appearance instance.
 | Appearance(String) | Creates a new Appearance instance.
 | DisplayName | Gets or sets the display name.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HelpLink | Gets or sets the help link.
 | Icon | Gets or sets the icon.
 | LongDescription | Gets or sets the long description.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ShortDescription | Gets or sets the short description.
 | Style | Gets or sets the CSS style.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Appearance
 |  | ItemAppearance


Appearance Constructor

Appearance Constructor
Namespaces ► Sitecore.Data ► Appearance ► Appearance()()()
Members
Icon | Member | Description
 | Appearance()()() | Creates a new Appearance instance.
 | Appearance(String) | Creates a new Appearance instance.


Appearance Constructor

Appearance Constructor
Namespaces ► Sitecore.Data ► Appearance ► Appearance()()()
Creates a new Appearance instance.
Declaration Syntax
C#
public Appearance()


Appearance Constructor (displayName)

Appearance Constructor (displayName)
Namespaces ► Sitecore.Data ► Appearance ► Appearance(String)
Creates a new Appearance instance.
Declaration Syntax
C#
public Appearance(
    string displayName
)
Parameters
displayName (String)
The display name.


DisplayName Property

DisplayName Property
Namespaces ► Sitecore.Data ► Appearance ► DisplayName
Gets or sets the display name.
Declaration Syntax
C#
public virtual string DisplayName { get; set; }
Value
The name of the display.
Remarks
If the display name field is blank, the item name is used.


HelpLink Property

HelpLink Property
Namespaces ► Sitecore.Data ► Appearance ► HelpLink
Gets or sets the help link.
Declaration Syntax
C#
public virtual string HelpLink { get; set; }
Value
The help link.


Icon Property

Icon Property
Namespaces ► Sitecore.Data ► Appearance ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public virtual string Icon { get; set; }
Value
The icon.


LongDescription Property

LongDescription Property
Namespaces ► Sitecore.Data ► Appearance ► LongDescription
Gets or sets the long description.
Declaration Syntax
C#
public virtual string LongDescription { get; set; }
Value
The long description.


ShortDescription Property

ShortDescription Property
Namespaces ► Sitecore.Data ► Appearance ► ShortDescription
Gets or sets the short description.
Declaration Syntax
C#
public virtual string ShortDescription { get; set; }
Value
The short description.


Style Property

Style Property
Namespaces ► Sitecore.Data ► Appearance ► Style
Gets or sets the CSS style.
Declaration Syntax
C#
public virtual string Style { get; set; }
Value
The CSS style.
Remarks

The CSS style is primarly used in the Content Tree where the style is applied to tree node. For instance all top sections (content, media library, templates etc.) have the style "color:green" which makes the nodes appear green.


BranchId Structure

BranchId Structure
Namespaces ► Sitecore.Data ► BranchId
Represents a master ID.
Declaration Syntax
C#
public struct BranchId
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BranchId(ID) | Initializes a new instance of the BranchId class.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns the ID as a string. (Overrides ValueType.ToString()()().)


BranchId Constructor (id)

BranchId Constructor (id)
Namespaces ► Sitecore.Data ► BranchId ► BranchId(ID)
Initializes a new instance of the BranchId class.
Declaration Syntax
C#
public BranchId(
    ID id
)
Parameters
id (ID)
The id.


ID Property

ID Property
Namespaces ► Sitecore.Data ► BranchId ► ID
Gets the ID.
Declaration Syntax
C#
public ID ID { get; }
Value
The ID.


ToString Method

ToString Method
Namespaces ► Sitecore.Data ► BranchId ► ToString()()()
Returns the ID as a string.
Declaration Syntax
C#
public override string ToString()
Return Value
A String containing the ID.


BranchRecords Class

BranchRecords Class
Namespaces ► Sitecore.Data ► BranchRecords
Represents the masters that are defined in a specified database.
Declaration Syntax
C#
public class BranchRecords : Database..::.DataRecords
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BranchRecords(Database) | Creates a new BranchRecords instance.
 | BasePath | Gets the base path. (Inherited from Database..::.DataRecords.)
 | CreateMaster(String, TemplateItem) | Creates a new master.
 | Database | Gets the database. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::.DataRecords.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::.DataRecords.)
 | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::.DataRecords.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMaster(ID) | Gets a master.
 | GetMaster(ID, Language) | Gets a master.
 | GetMaster(ID, Language, Version) | Gets a master.
 | GetMaster(String) | Gets a master.
 | GetMaster(String, Language) | Gets a master.
 | GetMaster(String, Language, Version) | Gets a master.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniquePath(String) | Gets a unique path of an item in the database. (Inherited from Database..::.DataRecords.)
 | Item[([(ID])]) | Gets the BranchItem with the specified id.
 | Item[([(ID, Language])]) | Gets the BranchItem with the specified id.
 | Item[([(ID, Language, Version])]) | Gets the BranchItem with the specified id.
 | Item[([(String])]) | Gets the BranchItem with the specified name.
 | Item[([(String, Language])]) | Gets the BranchItem with the specified name.
 | Item[([(String, Language, Version])]) | Gets the BranchItem with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

Masters are configured in /sitecore/masters.

The masters are normally access through the Branches property.

Inheritance Hierarchy
Object
 | Database..::.DataRecords
 |  | BranchRecords


BranchRecords Constructor (database)

BranchRecords Constructor (database)
Namespaces ► Sitecore.Data ► BranchRecords ► BranchRecords(Database)
Creates a new BranchRecords instance.
Declaration Syntax
C#
public BranchRecords(
    Database database
)
Parameters
database (Database)
Database.


CreateMaster Method (name, template)

CreateMaster Method (name, template)
Namespaces ► Sitecore.Data ► BranchRecords ► CreateMaster(String, TemplateItem)
Creates a new master.
Declaration Syntax
C#
public BranchItem CreateMaster(
    string name,
    TemplateItem template
)
Parameters
name (String)
Name.
template (TemplateItem)
Template.
Return Value
The master.


GetMaster Method

GetMaster Method
Namespaces ► Sitecore.Data ► BranchRecords ► GetMaster()()()
Members
Icon | Member | Description
 | GetMaster(ID) | Gets a master.
 | GetMaster(ID, Language) | Gets a master.
 | GetMaster(ID, Language, Version) | Gets a master.
 | GetMaster(String) | Gets a master.
 | GetMaster(String, Language) | Gets a master.
 | GetMaster(String, Language, Version) | Gets a master.


GetMaster Method (itemID)

GetMaster Method (itemID)
Namespaces ► Sitecore.Data ► BranchRecords ► GetMaster(ID)
Gets a master.
Declaration Syntax
C#
public BranchItem GetMaster(
    ID itemID
)
Parameters
itemID (ID)
Item ID.
Return Value
The master.


GetMaster Method (itemID, language)

GetMaster Method (itemID, language)
Namespaces ► Sitecore.Data ► BranchRecords ► GetMaster(ID, Language)
Gets a master.
Declaration Syntax
C#
public BranchItem GetMaster(
    ID itemID,
    Language language
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
Return Value
The master.


GetMaster Method (itemID, language, version)

GetMaster Method (itemID, language, version)
Namespaces ► Sitecore.Data ► BranchRecords ► GetMaster(ID, Language, Version)
Gets a master.
Declaration Syntax
C#
public BranchItem GetMaster(
    ID itemID,
    Language language,
    Version version
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
version (Version)
Version.
Return Value
The master.


GetMaster Method (itemPath)

GetMaster Method (itemPath)
Namespaces ► Sitecore.Data ► BranchRecords ► GetMaster(String)
Gets a master.
Declaration Syntax
C#
public BranchItem GetMaster(
    string itemPath
)
Parameters
itemPath (String)
Item path.
Return Value
The master.


GetMaster Method (itemPath, language)

GetMaster Method (itemPath, language)
Namespaces ► Sitecore.Data ► BranchRecords ► GetMaster(String, Language)
Gets a master.
Declaration Syntax
C#
public BranchItem GetMaster(
    string itemPath,
    Language language
)
Parameters
itemPath (String)
Item path.
language (Language)
Language.
Return Value
The master.


GetMaster Method (masterName, language, version)

GetMaster Method (masterName, language, version)
Namespaces ► Sitecore.Data ► BranchRecords ► GetMaster(String, Language, Version)
Gets a master.
Declaration Syntax
C#
public BranchItem GetMaster(
    string masterName,
    Language language,
    Version version
)
Parameters
masterName (String)
Item path.
language (Language)
Language.
version (Version)
Version.
Return Value
The master.


Item Property

Item Property
Namespaces ► Sitecore.Data ► BranchRecords ► Item
Members
Icon | Member | Description
 | Item[([(ID])]) | Gets the BranchItem with the specified id.
 | Item[([(ID, Language])]) | Gets the BranchItem with the specified id.
 | Item[([(ID, Language, Version])]) | Gets the BranchItem with the specified id.
 | Item[([(String])]) | Gets the BranchItem with the specified name.
 | Item[([(String, Language])]) | Gets the BranchItem with the specified name.
 | Item[([(String, Language, Version])]) | Gets the BranchItem with the specified name.


Item Property (itemID)

Item Property (itemID)
Namespaces ► Sitecore.Data ► BranchRecords ► Item[([(ID])])
Gets the BranchItem with the specified id.
Declaration Syntax
C#
public BranchItem this[
    ID itemID
] { get; }
Parameters
itemID (ID)


Item Property (itemID, language)

Item Property (itemID, language)
Namespaces ► Sitecore.Data ► BranchRecords ► Item[([(ID, Language])])
Gets the BranchItem with the specified id.
Declaration Syntax
C#
public BranchItem this[
    ID itemID,
    Language language
] { get; }
Parameters
itemID (ID)
language (Language)


Item Property (itemID, language, version)

Item Property (itemID, language, version)
Namespaces ► Sitecore.Data ► BranchRecords ► Item[([(ID, Language, Version])])
Gets the BranchItem with the specified id.
Declaration Syntax
C#
public BranchItem this[
    ID itemID,
    Language language,
    Version version
] { get; }
Parameters
itemID (ID)
language (Language)
version (Version)


Item Property (masterName)

Item Property (masterName)
Namespaces ► Sitecore.Data ► BranchRecords ► Item[([(String])])
Gets the BranchItem with the specified name.
Declaration Syntax
C#
public BranchItem this[
    string masterName
] { get; }
Parameters
masterName (String)


Item Property (masterName, language)

Item Property (masterName, language)
Namespaces ► Sitecore.Data ► BranchRecords ► Item[([(String, Language])])
Gets the BranchItem with the specified name.
Declaration Syntax
C#
public BranchItem this[
    string masterName,
    Language language
] { get; }
Parameters
masterName (String)
language (Language)
Value


Item Property (masterName, language, version)

Item Property (masterName, language, version)
Namespaces ► Sitecore.Data ► BranchRecords ► Item[([(String, Language, Version])])
Gets the BranchItem with the specified name.
Declaration Syntax
C#
public BranchItem this[
    string masterName,
    Language language,
    Version version
] { get; }
Parameters
masterName (String)
language (Language)
version (Version)


BulkUpdateContext Class

BulkUpdateContext Class
Namespaces ► Sitecore.Data ► BulkUpdateContext
BatchUpdateContext class
Declaration Syntax
C#
public class BulkUpdateContext : IDisposable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BulkUpdateContext()()() | Initializes a new instance of the BulkUpdateContext class
 | _onLeave | Actions to be done while leaving context
 | Dispose()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsActive | Gets a value indicating whether a batch update is in progress.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnLeave | Occurs when leaving context.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BulkUpdateContext


BulkUpdateContext Constructor

BulkUpdateContext Constructor
Namespaces ► Sitecore.Data ► BulkUpdateContext ► BulkUpdateContext()()()
Initializes a new instance of the BulkUpdateContext class
Declaration Syntax
C#
public BulkUpdateContext()


_onLeave Field

_onLeave Field
Namespaces ► Sitecore.Data ► BulkUpdateContext ► _onLeave
Actions to be done while leaving context
Declaration Syntax
C#
protected static List<ThreadStart> _onLeave


Dispose Method

Dispose Method
Namespaces ► Sitecore.Data ► BulkUpdateContext ► Dispose()()()
Declaration Syntax
C#
public void Dispose()


IsActive Property

IsActive Property
Namespaces ► Sitecore.Data ► BulkUpdateContext ► IsActive
Gets a value indicating whether a batch update is in progress.
Declaration Syntax
C#
public static bool IsActive { get; }
Value
true if this instance is active; otherwise, false.


OnLeave Event

OnLeave Event
Namespaces ► Sitecore.Data ► BulkUpdateContext ► OnLeave
Occurs when leaving context.
Declaration Syntax
C#
public static event ThreadStart OnLeave


Database Class

Database Class
Namespaces ► Sitecore.Data ► Database
Represents a database.
Represents a database.
Declaration Syntax
C#
public class Database
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Database(String) | Initializes a new database.
 | Aliases | Gets the alias resolver object.
 | ArchiveNames | Provides access to the names of the Archives associated with the database.
 | Archives | Provides access to the Archives associated with the database.
 | Branches | Provides access to the branches in the database.
 | Caches | Gets the caches.
 | CleanupDatabase()()() | Cleans up the database. Note: Make sure that the database has been backed up before calling this method. It may delete a lot of data.
 | ConnectionStringName | Gets or sets the name of the connection string used by archives etc..
 | Constructed |
 | CreateItemPath(String) | Creates a path of items.
 | CreateItemPath(String, TemplateItem) | Creates a path of items.
 | CreateItemPath(String, TemplateItem, TemplateItem) | Creates a path of items.
 | DataManager | Gets the database manager object that provides low-level access to a DataSource.
 | DataProviders | Gets the data providers.
 | Engines | Gets the engines.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDatabase(String) | Connects to the specified database.
 | GetDataProviders()()() | Gets the data providers.
 | GetDataSize(Int32, Int32) | Gets the size of the data contained in the database.
 | GetDataSizes(Int32, Int32) | Gets the data sizes of all databases.
 | GetDictionaryEntryCount()()() | Gets the number of dictionary entries stored in the database.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(ID) | Gets an item from a path.
 | GetItem(ID, Language) | Gets an item from a path.
 | GetItem(ID, Language, Version) | Gets an item from a path.
 | GetItem(String) | Gets an item from a path.
 | GetItem(String, Language) | Gets an item from a path.
 | GetItem(String, Language, Version) | Gets an item from a path.
 | GetItem(DataUri) | Gets the item.
 | GetItem(ItemUri) | Gets an item from an Item URI.
 | GetLanguages()()() | Gets the languages defined in the database.
 | GetRootItem()()() | Gets the root item of the database.
 | GetRootItem(Language) | Gets the root item of a database.
 | GetSearcher(String) | Gets an Index searcher for the database.
 | GetTemplate(ID) | Gets the template.
 | GetTemplate(String) | Gets the template.
 | GetTotalDataSize(Int32, Int32) | Gets the total size of the data.
 | GetTotalDictionaryEntryCount()()() | Gets the total number of dictionary entries in all databases.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasContentItem | Gets a value that indicates is the /sitecore/content item is present.
 | Icon | Gets or sets the icon.
 | Indexes | Provides access to the Indexes associated with the database.
 | InstanceCreated |
 | Items | Provides access to the items in the database.
 | Languages | Provides access to the languages in the database.
 | Masters | Obsolete. Provides access to the masters in the database.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the database.
 | Properties | Provides access to the database properties.
 | Protected | Gets or sets a value indicating whether this database should be protected.
 | ProxiesEnabled | Gets or sets a value that indicates if proxy items are enabled.
 | ProxyDataProvider | Gets or sets the proxy data provider.
 | PublishVirtualItems | Gets or sets a value that indicates whether virtual items will be published.
 | ReadOnly | Gets or sets a value that indicates if the database is read-only.
 | Resources | Gets the resources.
 | SecurityEnabled | Gets a value that indicates if security is enforced when accessing items.
 | SelectItems(String) | Performs a Sitecore Xpath query in the database.
 | SelectItemsUsingXPath(String) | Selects the items using Xpath.
 | SelectSingleItem(String) | Performs a Sitecore Xpath query in the database.
 | SelectSingleItemUsingXPath(String) | Selects the single item using Xpath.
 | SitecoreItem | Gets the sitecore item.
 | Templates | Provides access to the Templates in the database.
 | ToString()()() | Gets the name of the database. (Overrides Object.ToString()()().)
 | WorkflowProvider | Gets the workflow associated with the database.
Remarks

To create a database object use the Factory.GetDatabase method.

The database object provides access to items, aliases, templates etc.

Databases are configured in the web.config.

Remarks

To create a database object use the Factory.GetDatabase method.

The database object provides access to items, aliases, templates etc.

Databases are configured in the web.config.

Inheritance Hierarchy
Object
Database


Database Constructor (name)

Database Constructor (name)
Namespaces ► Sitecore.Data ► Database ► Database(String)
Initializes a new database.
Declaration Syntax
C#
public Database(
    string name
)
Parameters
name (String)
The name.
Remarks
Normally database objects are created using Factory.GetDatabase.


Aliases Property

Aliases Property
Namespaces ► Sitecore.Data ► Database ► Aliases
Gets the alias resolver object.
Declaration Syntax
C#
public AliasResolver Aliases { get; }
Value
The aliases.


ArchiveNames Property

ArchiveNames Property
Namespaces ► Sitecore.Data ► Database ► ArchiveNames
Provides access to the names of the Archives associated with the database.
Declaration Syntax
C#
public List<string> ArchiveNames { get; }
Value
The archives.


Archives Property

Archives Property
Namespaces ► Sitecore.Data ► Database ► Archives
Provides access to the Archives associated with the database.
Declaration Syntax
C#
public DataArchives Archives { get; }
Value
The archives.


Branches Property

Branches Property
Namespaces ► Sitecore.Data ► Database ► Branches
Provides access to the branches in the database.
Declaration Syntax
C#
public BranchRecords Branches { get; }
Value
The branches.


Caches Property

Caches Property
Namespaces ► Sitecore.Data ► Database ► Caches
Gets the caches.
Declaration Syntax
C#
public DatabaseCaches Caches { get; }
Value
The caches.


CleanupDatabase Method

CleanupDatabase Method
Namespaces ► Sitecore.Data ► Database ► CleanupDatabase()()()
Cleans up the database. Note: Make sure that the database has been backed up before calling this method. It may delete a lot of data.
Declaration Syntax
C#
public bool CleanupDatabase()
Return Value
true if cleanup was performed; false otherwise.
Remarks

Typically, a cleanup operation will remove data in invalid languages and items in orphaned trees.

Specific operations depends on the actual data provider implementation.


ConnectionStringName Property

ConnectionStringName Property
Namespaces ► Sitecore.Data ► Database ► ConnectionStringName
Gets or sets the name of the connection string used by archives etc..
Declaration Syntax
C#
public string ConnectionStringName { get; set; }
Value
The name of the connection string.


Constructed Event

Constructed Event
Namespaces ► Sitecore.Data ► Database ► Constructed
Declaration Syntax
C#
public event EventHandler<ConstructedEventArgs> Constructed


CreateItemPath Method

CreateItemPath Method
Namespaces ► Sitecore.Data ► Database ► CreateItemPath()()()
Members
Icon | Member | Description
 | CreateItemPath(String) | Creates a path of items.
 | CreateItemPath(String, TemplateItem) | Creates a path of items.
 | CreateItemPath(String, TemplateItem, TemplateItem) | Creates a path of items.


CreateItemPath Method (path)

CreateItemPath Method (path)
Namespaces ► Sitecore.Data ► Database ► CreateItemPath(String)
Creates a path of items.
Declaration Syntax
C#
public Item CreateItemPath(
    string path
)
Parameters
path (String)
Path that must exist in the database.
Return Value
The item corresponding to the last element in the path, e.g. the "deepest" item.
Remarks

Use this method to ensure that a specific path of items exist in the database.

For each element in the path it is checked if an item matching the element exists. If it does not, a new item is created with the proper name.

The new items are created from the __Node template.


CreateItemPath Method (path, template)

CreateItemPath Method (path, template)
Namespaces ► Sitecore.Data ► Database ► CreateItemPath(String, TemplateItem)
Creates a path of items.
Declaration Syntax
C#
public Item CreateItemPath(
    string path,
    TemplateItem template
)
Parameters
path (String)
Path that must exist in the database.
template (TemplateItem)
Name or ID of template to use when creating new items.
Return Value
The item corresponding to the last element in the path. E.g. the "deepest" item.
Remarks

Use this method to ensure that a specific path of items exist in the database.

For each element in the path it is checked if an item matching the element exists. If it does not, a new item is created with the proper name.

The new items are created from the template specified in template


CreateItemPath Method (path, folderTemplate, itemTemplate)

CreateItemPath Method (path, folderTemplate, itemTemplate)
Namespaces ► Sitecore.Data ► Database ► CreateItemPath(String, TemplateItem, TemplateItem)
Creates a path of items.
Declaration Syntax
C#
public Item CreateItemPath(
    string path,
    TemplateItem folderTemplate,
    TemplateItem itemTemplate
)
Parameters
path (String)
Path that must exist in the database
folderTemplate (TemplateItem)
Name or ID of template to use when creating folder items (all items except last).
itemTemplate (TemplateItem)
Name or ID of template to use when creating final item in path.
Return Value
The item corresponding to the last element in the path. I.e. the "deepest" item.
Remarks

Use this method to ensure that a specific path of items exist in the database.

For each element in the path it is checked if an item matching the element exists. If it does not, a new item is created with the proper name.

The new items are created from the template specified in itemTemplate


DataManager Property

DataManager Property
Namespaces ► Sitecore.Data ► Database ► DataManager
Gets the database manager object that provides low-level access to a DataSource.
Declaration Syntax
C#
public DataManager DataManager { get; }
Value
The data manager.
Remarks
The DataManager object provides a low-level access to a DataSource.


DataProviders Property

DataProviders Property
Namespaces ► Sitecore.Data ► Database ► DataProviders
Gets the data providers.
Declaration Syntax
C#
protected internal DataProviderCollection DataProviders { get; }
Value
The data providers.


Engines Property

Engines Property
Namespaces ► Sitecore.Data ► Database ► Engines
Gets the engines.
Declaration Syntax
C#
public DatabaseEngines Engines { get; }
Value
The engines.


GetDatabase Method (databaseName)

GetDatabase Method (databaseName)
Namespaces ► Sitecore.Data ► Database ► GetDatabase(String)
Connects to the specified database.
Declaration Syntax
C#
public static Database GetDatabase(
    string databaseName
)
Parameters
databaseName (String)
Name of the database.
Return Value


GetDataProviders Method

GetDataProviders Method
Namespaces ► Sitecore.Data ► Database ► GetDataProviders()()()
Gets the data providers.
Declaration Syntax
C#
public DataProvider[] GetDataProviders()
Return Value


GetDataSize Method (minEntitySize, maxEntitySize)

GetDataSize Method (minEntitySize, maxEntitySize)
Namespaces ► Sitecore.Data ► Database ► GetDataSize(Int32, Int32)
Gets the size of the data contained in the database.
Declaration Syntax
C#
public long GetDataSize(
    int minEntitySize,
    int maxEntitySize
)
Parameters
minEntitySize (Int32)
Minimum size of an entity.
maxEntitySize (Int32)
Maximum size of an entity.
Return Value


GetDataSizes Method (minEntitySize, maxEntitySize)

GetDataSizes Method (minEntitySize, maxEntitySize)
Namespaces ► Sitecore.Data ► Database ► GetDataSizes(Int32, Int32)
Gets the data sizes of all databases.
Declaration Syntax
C#
public static SafeDictionary<Database, long> GetDataSizes(
    int minEntitySize,
    int maxEntitySize
)
Parameters
minEntitySize (Int32)
Minimum size of an entity.
maxEntitySize (Int32)
Maximum size of an entity.
Return Value


GetDictionaryEntryCount Method

GetDictionaryEntryCount Method
Namespaces ► Sitecore.Data ► Database ► GetDictionaryEntryCount()()()
Gets the number of dictionary entries stored in the database.
Declaration Syntax
C#
public long GetDictionaryEntryCount()
Return Value
The number of dictionary entries stored in the database.


GetItem Method

GetItem Method
Namespaces ► Sitecore.Data ► Database ► GetItem()()()
Members
Icon | Member | Description
 | GetItem(ID) | Gets an item from a path.
 | GetItem(ID, Language) | Gets an item from a path.
 | GetItem(ID, Language, Version) | Gets an item from a path.
 | GetItem(String) | Gets an item from a path.
 | GetItem(String, Language) | Gets an item from a path.
 | GetItem(String, Language, Version) | Gets an item from a path.
 | GetItem(DataUri) | Gets the item.
 | GetItem(ItemUri) | Gets an item from an Item URI.


GetItem Method (uri)

GetItem Method (uri)
Namespaces ► Sitecore.Data ► Database ► GetItem(DataUri)
Gets the item.
Declaration Syntax
C#
public Item GetItem(
    DataUri uri
)
Parameters
uri (DataUri)
The URI.
Return Value


GetItem Method (itemId)

GetItem Method (itemId)
Namespaces ► Sitecore.Data ► Database ► GetItem(ID)
Gets an item from a path.
Declaration Syntax
C#
public Item GetItem(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value


GetItem Method (itemId, language)

GetItem Method (itemId, language)
Namespaces ► Sitecore.Data ► Database ► GetItem(ID, Language)
Gets an item from a path.
Declaration Syntax
C#
public Item GetItem(
    ID itemId,
    Language language
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
Return Value


GetItem Method (itemId, language, version)

GetItem Method (itemId, language, version)
Namespaces ► Sitecore.Data ► Database ► GetItem(ID, Language, Version)
Gets an item from a path.
Declaration Syntax
C#
public Item GetItem(
    ID itemId,
    Language language,
    Version version
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
version (Version)
The version.
Return Value


GetItem Method (uri)

GetItem Method (uri)
Namespaces ► Sitecore.Data ► Database ► GetItem(ItemUri)
Gets an item from an Item URI.
Declaration Syntax
C#
public static Item GetItem(
    ItemUri uri
)
Parameters
uri (ItemUri)
The URI.
Return Value


GetItem Method (path)

GetItem Method (path)
Namespaces ► Sitecore.Data ► Database ► GetItem(String)
Gets an item from a path.
Declaration Syntax
C#
public Item GetItem(
    string path
)
Parameters
path (String)
The path.
Return Value


GetItem Method (path, language)

GetItem Method (path, language)
Namespaces ► Sitecore.Data ► Database ► GetItem(String, Language)
Gets an item from a path.
Declaration Syntax
C#
public Item GetItem(
    string path,
    Language language
)
Parameters
path (String)
The path.
language (Language)
The language.
Return Value
The item.


GetItem Method (path, language, version)

GetItem Method (path, language, version)
Namespaces ► Sitecore.Data ► Database ► GetItem(String, Language, Version)
Gets an item from a path.
Declaration Syntax
C#
public Item GetItem(
    string path,
    Language language,
    Version version
)
Parameters
path (String)
The path.
language (Language)
The language.
version (Version)
The version.
Return Value
The item.


GetLanguages Method

GetLanguages Method
Namespaces ► Sitecore.Data ► Database ► GetLanguages()()()
Gets the languages defined in the database.
Declaration Syntax
C#
public LanguageCollection GetLanguages()
Return Value


GetRootItem Method

GetRootItem Method
Namespaces ► Sitecore.Data ► Database ► GetRootItem()()()
Members
Icon | Member | Description
 | GetRootItem()()() | Gets the root item of the database.
 | GetRootItem(Language) | Gets the root item of a database.


GetRootItem Method

GetRootItem Method
Namespaces ► Sitecore.Data ► Database ► GetRootItem()()()
Gets the root item of the database.
Declaration Syntax
C#
public Item GetRootItem()
Return Value


GetRootItem Method (language)

GetRootItem Method (language)
Namespaces ► Sitecore.Data ► Database ► GetRootItem(Language)
Gets the root item of a database.
Declaration Syntax
C#
public Item GetRootItem(
    Language language
)
Parameters
language (Language)
The language.
Return Value


GetSearcher Method (name)

GetSearcher Method (name)
Namespaces ► Sitecore.Data ► Database ► GetSearcher(String)
Gets an Index searcher for the database.
Declaration Syntax
C#
public IndexSearcher GetSearcher(
    string name
)
Parameters
name (String)
The name.
Return Value


GetTemplate Method

GetTemplate Method
Namespaces ► Sitecore.Data ► Database ► GetTemplate()()()
Members
Icon | Member | Description
 | GetTemplate(ID) | Gets the template.
 | GetTemplate(String) | Gets the template.


GetTemplate Method (templateId)

GetTemplate Method (templateId)
Namespaces ► Sitecore.Data ► Database ► GetTemplate(ID)
Gets the template.
Declaration Syntax
C#
public TemplateItem GetTemplate(
    ID templateId
)
Parameters
templateId (ID)
The template id.
Return Value
The template.


GetTemplate Method (fullName)

GetTemplate Method (fullName)
Namespaces ► Sitecore.Data ► Database ► GetTemplate(String)
Gets the template.
Declaration Syntax
C#
public TemplateItem GetTemplate(
    string fullName
)
Parameters
fullName (String)
The full name.
Return Value
The template.


GetTotalDataSize Method (minEntitySize, maxEntitySize)

GetTotalDataSize Method (minEntitySize, maxEntitySize)
Namespaces ► Sitecore.Data ► Database ► GetTotalDataSize(Int32, Int32)
Gets the total size of the data.
Declaration Syntax
C#
public static long GetTotalDataSize(
    int minEntitySize,
    int maxEntitySize
)
Parameters
minEntitySize (Int32)
Minimum size of an entity.
maxEntitySize (Int32)
Maximum size of an entity.
Return Value
The total data size.


GetTotalDictionaryEntryCount Method

GetTotalDictionaryEntryCount Method
Namespaces ► Sitecore.Data ► Database ► GetTotalDictionaryEntryCount()()()
Gets the total number of dictionary entries in all databases.
Declaration Syntax
C#
public static long GetTotalDictionaryEntryCount()
Return Value


HasContentItem Property

HasContentItem Property
Namespaces ► Sitecore.Data ► Database ► HasContentItem
Gets a value that indicates is the /sitecore/content item is present.
Declaration Syntax
C#
public bool HasContentItem { get; }
Value
true if this instance has content item; otherwise, false.
Remarks
Some database does not contain the /sitecore/content item which indicates that this is a special database. The Security and Extranet databases are examples of this.


Icon Property

Icon Property
Namespaces ► Sitecore.Data ► Database ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


Indexes Property

Indexes Property
Namespaces ► Sitecore.Data ► Database ► Indexes
Provides access to the Indexes associated with the database.
Declaration Syntax
C#
public DataIndexes Indexes { get; }
Value
The indexes.


InstanceCreated Event

InstanceCreated Event
Namespaces ► Sitecore.Data ► Database ► InstanceCreated
Declaration Syntax
C#
public static event EventHandler<InstanceCreatedEventArgs> InstanceCreated


Items Property

Items Property
Namespaces ► Sitecore.Data ► Database ► Items
Provides access to the items in the database.
Declaration Syntax
C#
public ItemRecords Items { get; }
Value
The items.


Languages Property

Languages Property
Namespaces ► Sitecore.Data ► Database ► Languages
Provides access to the languages in the database.
Declaration Syntax
C#
public Language[] Languages { get; }
Value
The languages.


Masters Property

Masters Property
Namespaces ► Sitecore.Data ► Database ► Masters
Provides access to the masters in the database.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Branches instead.")]
public BranchRecords Masters { get; }
Value
The masters.


Name Property

Name Property
Namespaces ► Sitecore.Data ► Database ► Name
Gets the name of the database.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Properties Property

Properties Property
Namespaces ► Sitecore.Data ► Database ► Properties
Provides access to the database properties.
Declaration Syntax
C#
public DatabaseProperties Properties { get; }
Value
The properties.
Remarks

Database properties are meta data that describe the database, e.g. the version number of the database.

Properties can freely be added to the database.


Protected Property

Protected Property
Namespaces ► Sitecore.Data ► Database ► Protected
Gets or sets a value indicating whether this database should be protected.
Declaration Syntax
C#
public bool Protected { get; set; }
Value
true if this database should be protected; otherwise, false.
Remarks

This property might be used by client applications to limit access to certain databases.

For instance, a protected database can not be used as a content database unless the current user is an administrator.


ProxiesEnabled Property

ProxiesEnabled Property
Namespaces ► Sitecore.Data ► Database ► ProxiesEnabled
Gets or sets a value that indicates if proxy items are enabled.
Declaration Syntax
C#
public bool ProxiesEnabled { get; set; }
Value
true if the Database has proxies enabled; otherwise, false.


ProxyDataProvider Property

ProxyDataProvider Property
Namespaces ► Sitecore.Data ► Database ► ProxyDataProvider
Gets or sets the proxy data provider.
Declaration Syntax
C#
public ProxyDataProvider ProxyDataProvider { get; set; }
Value
The proxy data provider.


PublishVirtualItems Property

PublishVirtualItems Property
Namespaces ► Sitecore.Data ► Database ► PublishVirtualItems
Gets or sets a value that indicates whether virtual items will be published.
Declaration Syntax
C#
public bool PublishVirtualItems { get; set; }
Remarks

When this setting is false, only the proxy definitions will be published. Therefore proxy support must be enabled on the web database.

When true, virtual items will be published as if they were real items. Therefore, proxy support should not be enabled on the web site.

The default value is false, meaning that only proxy definitions are published.


ReadOnly Property

ReadOnly Property
Namespaces ► Sitecore.Data ► Database ► ReadOnly
Gets or sets a value that indicates if the database is read-only.
Declaration Syntax
C#
public bool ReadOnly { get; set; }
Value
true if the Database is read-only; otherwise, false.


Resources Property

Resources Property
Namespaces ► Sitecore.Data ► Database ► Resources
Gets the resources.
Declaration Syntax
C#
public ResourceItems Resources { get; }
Value
The resources.


SecurityEnabled Property

SecurityEnabled Property
Namespaces ► Sitecore.Data ► Database ► SecurityEnabled
Gets a value that indicates if security is enforced when accessing items.
Declaration Syntax
C#
public bool SecurityEnabled { get; set; }
Value
true if the Database has security enabled; otherwise, false.


SelectItems Method (query)

SelectItems Method (query)
Namespaces ► Sitecore.Data ► Database ► SelectItems(String)
Performs a Sitecore Xpath query in the database.
Declaration Syntax
C#
public Item[] SelectItems(
    string query
)
Parameters
query (String)
The query.
Return Value


SelectItemsUsingXPath Method (query)

SelectItemsUsingXPath Method (query)
Namespaces ► Sitecore.Data ► Database ► SelectItemsUsingXPath(String)
Selects the items using Xpath.
Declaration Syntax
C#
public ItemList SelectItemsUsingXPath(
    string query
)
Parameters
query (String)
The query.
Return Value


SelectSingleItem Method (query)

SelectSingleItem Method (query)
Namespaces ► Sitecore.Data ► Database ► SelectSingleItem(String)
Performs a Sitecore Xpath query in the database.
Declaration Syntax
C#
public Item SelectSingleItem(
    string query
)
Parameters
query (String)
The query.
Return Value


SelectSingleItemUsingXPath Method (query)

SelectSingleItemUsingXPath Method (query)
Namespaces ► Sitecore.Data ► Database ► SelectSingleItemUsingXPath(String)
Selects the single item using Xpath.
Declaration Syntax
C#
public Item SelectSingleItemUsingXPath(
    string query
)
Parameters
query (String)
The query.
Return Value


SitecoreItem Property

SitecoreItem Property
Namespaces ► Sitecore.Data ► Database ► SitecoreItem
Gets the sitecore item.
Declaration Syntax
C#
public Item SitecoreItem { get; }
Value
The sitecore item.


Templates Property

Templates Property
Namespaces ► Sitecore.Data ► Database ► Templates
Provides access to the Templates in the database.
Declaration Syntax
C#
public TemplateRecords Templates { get; }
Value
The templates.


ToString Method

ToString Method
Namespaces ► Sitecore.Data ► Database ► ToString()()()
Gets the name of the database.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


WorkflowProvider Property

WorkflowProvider Property
Namespaces ► Sitecore.Data ► Database ► WorkflowProvider
Gets the workflow associated with the database.
Declaration Syntax
C#
public IWorkflowProvider WorkflowProvider { get; set; }
Value
The workflow provider.


Database.DataRecords Class

Database..::.DataRecords Class
Namespaces ► Sitecore.Data ► Database ► Database..::.DataRecords
Items records
Declaration Syntax
C#
public class DataRecords
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Database..::.DataRecords(Database) | Initializes a new instance of the Database..::.DataRecords class.
 | Database..::.DataRecords(Database, String) | Initializes a new instance of the Database..::.DataRecords class.
 | BasePath | Gets the base path.
 | Database | Gets the database.
 | DoGetItem(ID) | Gets the item.
 | DoGetItem(ID, Language) | Gets the item.
 | DoGetItem(ID, Language, Version) | Gets the item.
 | DoGetItem(String) | Gets the item.
 | DoGetItem(String, Language) | Gets the item.
 | DoGetItem(String, Language, Version) | Gets the item.
 | DoGetItem(DataUri) | Gets the item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(ID) | Gets a value that indicates if the item ID exists in the database.
 | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniquePath(String) | Gets a unique path of an item in the database.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Database..::.DataRecords
 |  | BranchRecords
 |  | DeviceRecords
 |  | ItemRecords
 |  | LayoutRecords
 |  | RenderingRecords
 |  | SublayoutRecords


Database.DataRecords Constructor

Database..::.DataRecords Constructor
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► Database..::.DataRecords()()()
Members
Icon | Member | Description
 | Database..::.DataRecords(Database) | Initializes a new instance of the Database..::.DataRecords class.
 | Database..::.DataRecords(Database, String) | Initializes a new instance of the Database..::.DataRecords class.


Database.DataRecords Constructor (database)

Database..::.DataRecords Constructor (database)
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► Database..::.DataRecords(Database)
Initializes a new instance of the Database..::.DataRecords class.
Declaration Syntax
C#
public DataRecords(
    Database database
)
Parameters
database (Database)
The database.


Database.DataRecords Constructor (database, basePath)

Database..::.DataRecords Constructor (database, basePath)
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► Database..::.DataRecords(Database, String)
Initializes a new instance of the Database..::.DataRecords class.
Declaration Syntax
C#
public DataRecords(
    Database database,
    string basePath
)
Parameters
database (Database)
The database.
basePath (String)
The base path.


BasePath Property

BasePath Property
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► BasePath
Gets the base path.
Declaration Syntax
C#
public string BasePath { get; }
Value
The base path.


Database Property

Database Property
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


DoGetItem Method

DoGetItem Method
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► DoGetItem()()()
Members
Icon | Member | Description
 | DoGetItem(ID) | Gets the item.
 | DoGetItem(ID, Language) | Gets the item.
 | DoGetItem(ID, Language, Version) | Gets the item.
 | DoGetItem(String) | Gets the item.
 | DoGetItem(String, Language) | Gets the item.
 | DoGetItem(String, Language, Version) | Gets the item.
 | DoGetItem(DataUri) | Gets the item.


DoGetItem Method (uri)

DoGetItem Method (uri)
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► DoGetItem(DataUri)
Gets the item.
Declaration Syntax
C#
protected virtual Item DoGetItem(
    DataUri uri
)
Parameters
uri (DataUri)
The URI.
Return Value


DoGetItem Method (itemID)

DoGetItem Method (itemID)
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► DoGetItem(ID)
Gets the item.
Declaration Syntax
C#
protected virtual Item DoGetItem(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value


DoGetItem Method (itemID, language)

DoGetItem Method (itemID, language)
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► DoGetItem(ID, Language)
Gets the item.
Declaration Syntax
C#
protected virtual Item DoGetItem(
    ID itemID,
    Language language
)
Parameters
itemID (ID)
The item ID.
language (Language)
The language.
Return Value


DoGetItem Method (itemID, language, version)

DoGetItem Method (itemID, language, version)
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► DoGetItem(ID, Language, Version)
Gets the item.
Declaration Syntax
C#
protected virtual Item DoGetItem(
    ID itemID,
    Language language,
    Version version
)
Parameters
itemID (ID)
The item ID.
language (Language)
The language.
version (Version)
The version.
Return Value


DoGetItem Method (itemPath)

DoGetItem Method (itemPath)
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► DoGetItem(String)
Gets the item.
Declaration Syntax
C#
protected virtual Item DoGetItem(
    string itemPath
)
Parameters
itemPath (String)
The item path.
Return Value


DoGetItem Method (itemPath, language)

DoGetItem Method (itemPath, language)
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► DoGetItem(String, Language)
Gets the item.
Declaration Syntax
C#
protected virtual Item DoGetItem(
    string itemPath,
    Language language
)
Parameters
itemPath (String)
The item path.
language (Language)
The language.
Return Value


DoGetItem Method (itemPath, language, version)

DoGetItem Method (itemPath, language, version)
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► DoGetItem(String, Language, Version)
Gets the item.
Declaration Syntax
C#
protected virtual Item DoGetItem(
    string itemPath,
    Language language,
    Version version
)
Parameters
itemPath (String)
The item path.
language (Language)
The language.
version (Version)
The version.
Return Value


Exists Method

Exists Method
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► Exists()()()
Members
Icon | Member | Description
 | Exists(ID) | Gets a value that indicates if the item ID exists in the database.
 | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database.


Exists Method (itemUri)

Exists Method (itemUri)
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► Exists(DataUri)
Gets a value that indicates if the data URI exists in the database.
Declaration Syntax
C#
public bool Exists(
    DataUri itemUri
)
Parameters
itemUri (DataUri)
The item URI.
Return Value


Exists Method (itemID)

Exists Method (itemID)
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► Exists(ID)
Gets a value that indicates if the item ID exists in the database.
Declaration Syntax
C#
public bool Exists(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value


GetUniquePath Method (id)

GetUniquePath Method (id)
Namespaces ► Sitecore.Data ► Database..::.DataRecords ► GetUniquePath(String)
Gets a unique path of an item in the database.
Declaration Syntax
C#
public string GetUniquePath(
    string id
)
Parameters
id (String)
The id.
Return Value
Remarks
A unique path is a path consisting of item IDs.


DatabaseCacheDisabler Class

DatabaseCacheDisabler Class
Namespaces ► Sitecore.Data ► DatabaseCacheDisabler
Disables database caches for given thread.
Declaration Syntax
C#
public class DatabaseCacheDisabler : Switcher<bool, DatabaseCacheDisabler>
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatabaseCacheDisabler()()() | Initializes a new instance of the DatabaseCacheDisabler class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <(Boolean, DatabaseCacheDisabler>)>)
 |  | DatabaseCacheDisabler


DatabaseCacheDisabler Constructor

DatabaseCacheDisabler Constructor
Namespaces ► Sitecore.Data ► DatabaseCacheDisabler ► DatabaseCacheDisabler()()()
Initializes a new instance of the DatabaseCacheDisabler class.
Declaration Syntax
C#
public DatabaseCacheDisabler()


DatabaseCaches Class

DatabaseCaches Class
Namespaces ► Sitecore.Data ► DatabaseCaches
Stores caches for a database.
Declaration Syntax
C#
public class DatabaseCaches
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatabaseCaches(Database) | Creates a new DatabaseProperties instance.
 | DataCache | Gets the data cache.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemCache | Gets the item cache.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PathCache | Gets the path cache.
 | StandardValuesCache | Gets the standard values cache.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DatabaseCaches


DatabaseCaches Constructor (database)

DatabaseCaches Constructor (database)
Namespaces ► Sitecore.Data ► DatabaseCaches ► DatabaseCaches(Database)
Creates a new DatabaseProperties instance.
Declaration Syntax
C#
public DatabaseCaches(
    Database database
)
Parameters
database (Database)
Database.


DataCache Property

DataCache Property
Namespaces ► Sitecore.Data ► DatabaseCaches ► DataCache
Gets the data cache.
Declaration Syntax
C#
public virtual DataCache DataCache { get; }
Value
The data cache.


ItemCache Property

ItemCache Property
Namespaces ► Sitecore.Data ► DatabaseCaches ► ItemCache
Gets the item cache.
Declaration Syntax
C#
public virtual ItemCache ItemCache { get; }
Value
The item cache.


PathCache Property

PathCache Property
Namespaces ► Sitecore.Data ► DatabaseCaches ► PathCache
Gets the path cache.
Declaration Syntax
C#
public virtual PathCache PathCache { get; }
Value
The path cache.


StandardValuesCache Property

StandardValuesCache Property
Namespaces ► Sitecore.Data ► DatabaseCaches ► StandardValuesCache
Gets the standard values cache.
Declaration Syntax
C#
public StandardValuesCache StandardValuesCache { get; }
Value
The standard values cache.


DatabaseEngines Class

DatabaseEngines Class
Namespaces ► Sitecore.Data ► DatabaseEngines
DatabaseEngines
Declaration Syntax
C#
public class DatabaseEngines
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatabaseEngines(Database) | Initializes a new instance of the DatabaseEngines class.
 | DataEngine | Gets the data engine.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HistoryEngine | Gets the history engine.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TemplateEngine | Gets the template engine.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WorkflowEngine | Gets the workflow engine.
Inheritance Hierarchy
Object
DatabaseEngines


DatabaseEngines Constructor (database)

DatabaseEngines Constructor (database)
Namespaces ► Sitecore.Data ► DatabaseEngines ► DatabaseEngines(Database)
Initializes a new instance of the DatabaseEngines class.
Declaration Syntax
C#
public DatabaseEngines(
    Database database
)
Parameters
database (Database)
The database.


DataEngine Property

DataEngine Property
Namespaces ► Sitecore.Data ► DatabaseEngines ► DataEngine
Gets the data engine.
Declaration Syntax
C#
public DataEngine DataEngine { get; }
Value
The data engine.


HistoryEngine Property

HistoryEngine Property
Namespaces ► Sitecore.Data ► DatabaseEngines ► HistoryEngine
Gets the history engine.
Declaration Syntax
C#
public HistoryEngine HistoryEngine { get; }
Value
The history engine.


TemplateEngine Property

TemplateEngine Property
Namespaces ► Sitecore.Data ► DatabaseEngines ► TemplateEngine
Gets the template engine.
Declaration Syntax
C#
public TemplateEngine TemplateEngine { get; }
Value
The template engine.


WorkflowEngine Property

WorkflowEngine Property
Namespaces ► Sitecore.Data ► DatabaseEngines ► WorkflowEngine
Gets the workflow engine.
Declaration Syntax
C#
public WorkflowEngine WorkflowEngine { get; }
Value
The workflow engine.


DatabaseProperties Class

DatabaseProperties Class
Namespaces ► Sitecore.Data ► DatabaseProperties
Stores custom properties for a database.
Declaration Syntax
C#
public class DatabaseProperties : PropertiesBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatabaseProperties(Database) | Creates a new DatabaseProperties instance.
 | Database | Gets the database. (Inherited from PropertiesBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBoolValue(String, Boolean) | Gets a bool value. (Inherited from PropertiesBase.)
 | GetDateValue(String, DateTime) | Gets a date value. (Inherited from PropertiesBase.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIntValue(String, Int32) | Gets an integer value. (Inherited from PropertiesBase.)
 | GetLastPublishDate(Database, Language) | Gets the last publish date.
 | GetSmartPublishRequired(String, Language) | Gets a value indicating if smart publish is required.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets or sets the value with the specified name. (Inherited from PropertiesBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a value with the specified name. (Inherited from PropertiesBase.)
 | RemovePrefix(String) | Removes all values which names have the specified prefix. (Inherited from PropertiesBase.)
 | SetBoolValue(String, Boolean) | Sets a bool value. (Inherited from PropertiesBase.)
 | SetDateValue(String, DateTime) | Sets a date value. (Inherited from PropertiesBase.)
 | SetIntValue(String, Int32) | Sets an integer value. (Inherited from PropertiesBase.)
 | SetLastPublishDate(Database, Language, DateTime) | Sets the last publish date.
 | SetSmartPublishRequired(String, Language, Boolean) | Sets a value indicating if smart publish is required.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | Gets the version of the database.
Remarks
The database properties allows the developer to attach meta data to a database. For instance the database version is a database property.
Inheritance Hierarchy
Object
 | PropertiesBase
 |  | DatabaseProperties


DatabaseProperties Constructor (database)

DatabaseProperties Constructor (database)
Namespaces ► Sitecore.Data ► DatabaseProperties ► DatabaseProperties(Database)
Creates a new DatabaseProperties instance.
Declaration Syntax
C#
public DatabaseProperties(
    Database database
)
Parameters
database (Database)
Database.


GetLastPublishDate Method (target, language)

GetLastPublishDate Method (target, language)
Namespaces ► Sitecore.Data ► DatabaseProperties ► GetLastPublishDate(Database, Language)
Gets the last publish date.
Declaration Syntax
C#
public DateTime GetLastPublishDate(
    Database target,
    Language language
)
Parameters
target (Database)
Target.
language (Language)
Language.
Return Value
The last publish date.


GetSmartPublishRequired Method (targetName, language)

GetSmartPublishRequired Method (targetName, language)
Namespaces ► Sitecore.Data ► DatabaseProperties ► GetSmartPublishRequired(String, Language)
Gets a value indicating if smart publish is required.
Declaration Syntax
C#
public bool GetSmartPublishRequired(
    string targetName,
    Language language
)
Parameters
targetName (String)
Name of the target database.
language (Language)
Language.
Return Value


SetLastPublishDate Method (target, language, date)

SetLastPublishDate Method (target, language, date)
Namespaces ► Sitecore.Data ► DatabaseProperties ► SetLastPublishDate(Database, Language, DateTime)
Sets the last publish date.
Declaration Syntax
C#
public void SetLastPublishDate(
    Database target,
    Language language,
    DateTime date
)
Parameters
target (Database)
Target.
language (Language)
Language.
date (DateTime)
Date.
Remarks
This property is automatically updated for each publish.


SetSmartPublishRequired Method (targetName, language, required)

SetSmartPublishRequired Method (targetName, language, required)
Namespaces ► Sitecore.Data ► DatabaseProperties ► SetSmartPublishRequired(String, Language, Boolean)
Sets a value indicating if smart publish is required.
Declaration Syntax
C#
public void SetSmartPublishRequired(
    string targetName,
    Language language,
    bool required
)
Parameters
targetName (String)
Name of the target database.
language (Language)
Language.
required (Boolean)
if set to true smart publish is required.


Version Property

Version Property
Namespaces ► Sitecore.Data ► DatabaseProperties ► Version
Gets the version of the database.
Declaration Syntax
C#
public int Version { get; }
Value
The version.


DatabaseSwitcher Class

DatabaseSwitcher Class
Namespaces ► Sitecore.Data ► DatabaseSwitcher
Switches to another database temporarily.
Declaration Syntax
C#
public class DatabaseSwitcher : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DatabaseSwitcher(Database) | Initializes a new instance of the DatabaseSwitcher class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DatabaseSwitcher


DatabaseSwitcher Constructor (database)

DatabaseSwitcher Constructor (database)
Namespaces ► Sitecore.Data ► DatabaseSwitcher ► DatabaseSwitcher(Database)
Initializes a new instance of the DatabaseSwitcher class.
Declaration Syntax
C#
public DatabaseSwitcher(
    Database database
)
Parameters
database (Database)
The database to switch to.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Data ► DatabaseSwitcher ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


DataManager Class

DataManager Class
Namespaces ► Sitecore.Data ► DataManager
Represents the data manager.
Declaration Syntax
C#
public class DataManager : IQueryable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataManager(Database) | Initializes a new instance of the DataManager class.
 | CleanupPublishQueue(DateTime) | Cleanups the publish queue.
 | Database | Gets the database.
 | DataEngine | Gets the data engine.
 | DataSource | Gets the DataSource associated with this DataManager instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemsInWorkflowState(WorkflowInfo) | Gets the state of the items in workflow.
 | GetProperty(String) | Gets the property.
 | GetPropertyKeys(String) | Gets the property.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWorkflowInfo(Item) | Gets the workflow info.
 | HasShadows(Item) | Determines whether the specified item has shadows.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveProperty(String, Boolean) | Removes the property.
 | SelectItems(String) | Selects the items.
 | SelectItems(String, Boolean%) | Selects the items.
 | SelectSingleItem(String, Boolean%) | Selects the single item.
 | SetProperty(String, String) | Sets the property.
 | SetWorkflowInfo(Item, WorkflowInfo) | Sets the workflow info.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DataManager


DataManager Constructor (database)

DataManager Constructor (database)
Namespaces ► Sitecore.Data ► DataManager ► DataManager(Database)
Initializes a new instance of the DataManager class.
Declaration Syntax
C#
public DataManager(
    Database database
)
Parameters
database (Database)
The database.


CleanupPublishQueue Method (to)

CleanupPublishQueue Method (to)
Namespaces ► Sitecore.Data ► DataManager ► CleanupPublishQueue(DateTime)
Cleanups the publish queue.
Declaration Syntax
C#
public bool CleanupPublishQueue(
    DateTime to
)
Parameters
to (DateTime)
To.
Return Value
The publish queue.


Database Property

Database Property
Namespaces ► Sitecore.Data ► DataManager ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


DataEngine Property

DataEngine Property
Namespaces ► Sitecore.Data ► DataManager ► DataEngine
Gets the data engine.
Declaration Syntax
C#
public DataEngine DataEngine { get; }
Value
The data engine.


DataSource Property

DataSource Property
Namespaces ► Sitecore.Data ► DataManager ► DataSource
Gets the DataSource associated with this DataManager instance.
Declaration Syntax
C#
public DataSource DataSource { get; }
Value
The data source.


GetItemsInWorkflowState Method (info)

GetItemsInWorkflowState Method (info)
Namespaces ► Sitecore.Data ► DataManager ► GetItemsInWorkflowState(WorkflowInfo)
Gets the state of the items in workflow.
Declaration Syntax
C#
public DataUri[] GetItemsInWorkflowState(
    WorkflowInfo info
)
Parameters
info (WorkflowInfo)
The info.
Return Value
The DataUri.


GetProperty Method (name)

GetProperty Method (name)
Namespaces ► Sitecore.Data ► DataManager ► GetProperty(String)
Gets the property.
Declaration Syntax
C#
public string GetProperty(
    string name
)
Parameters
name (String)
The name.
Return Value
The property.


GetPropertyKeys Method (prefix)

GetPropertyKeys Method (prefix)
Namespaces ► Sitecore.Data ► DataManager ► GetPropertyKeys(String)
Gets the property.
Declaration Syntax
C#
public List<string> GetPropertyKeys(
    string prefix
)
Parameters
prefix (String)
The prefix.
Return Value
The property.


GetWorkflowInfo Method (item)

GetWorkflowInfo Method (item)
Namespaces ► Sitecore.Data ► DataManager ► GetWorkflowInfo(Item)
Gets the workflow info.
Declaration Syntax
C#
public WorkflowInfo GetWorkflowInfo(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The workflow info.


HasShadows Method (item)

HasShadows Method (item)
Namespaces ► Sitecore.Data ► DataManager ► HasShadows(Item)
Determines whether the specified item has shadows.
Declaration Syntax
C#
public bool HasShadows(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item has shadows; otherwise, false.


RemoveProperty Method (name, isPrefix)

RemoveProperty Method (name, isPrefix)
Namespaces ► Sitecore.Data ► DataManager ► RemoveProperty(String, Boolean)
Removes the property.
Declaration Syntax
C#
public bool RemoveProperty(
    string name,
    bool isPrefix
)
Parameters
name (String)
The name.
isPrefix (Boolean)
if set to true this instance is is prefix.
Return Value
The property.


SelectItems Method

SelectItems Method
Namespaces ► Sitecore.Data ► DataManager ► SelectItems()()()
Members
Icon | Member | Description
 | SelectItems(String) | Selects the items.
 | SelectItems(String, Boolean%) | Selects the items.


SelectItems Method (query)

SelectItems Method (query)
Namespaces ► Sitecore.Data ► DataManager ► SelectItems(String)
Selects the items.
Declaration Syntax
C#
public Item[] SelectItems(
    string query
)
Parameters
query (String)
The query.
Return Value
The items.


SelectItems Method (query, processed)

SelectItems Method (query, processed)
Namespaces ► Sitecore.Data ► DataManager ► SelectItems(String, Boolean%)
Selects the items.
Declaration Syntax
C#
public Item[] SelectItems(
    string query,
    out bool processed
)
Parameters
query (String)
The query.
processed ( Boolean %)
If set to true the query was processed.
Return Value
The items.


SelectSingleItem Method (query, processed)

SelectSingleItem Method (query, processed)
Namespaces ► Sitecore.Data ► DataManager ► SelectSingleItem(String, Boolean%)
Selects the single item.
Declaration Syntax
C#
public Item SelectSingleItem(
    string query,
    out bool processed
)
Parameters
query (String)
The query.
processed ( Boolean %)
If set to true the query was processed.
Return Value
The single item.


SetProperty Method (name, value)

SetProperty Method (name, value)
Namespaces ► Sitecore.Data ► DataManager ► SetProperty(String, String)
Sets the property.
Declaration Syntax
C#
public bool SetProperty(
    string name,
    string value
)
Parameters
name (String)
The name.
value (String)
The value.
Return Value
The property.


SetWorkflowInfo Method (item, info)

SetWorkflowInfo Method (item, info)
Namespaces ► Sitecore.Data ► DataManager ► SetWorkflowInfo(Item, WorkflowInfo)
Sets the workflow info.
Declaration Syntax
C#
public bool SetWorkflowInfo(
    Item item,
    WorkflowInfo info
)
Parameters
item (Item)
The item.
info (WorkflowInfo)
The info.
Return Value
The workflow info.


DataSource Class

DataSource Class
Namespaces ► Sitecore.Data ► DataSource
Represents a data source.
Declaration Syntax
C#
public class DataSource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataSource(DataManager) | Initializes a new instance of the DataSource class.
 | AddToPublishQueue(ID, String, DateTime) | Adds to publish queue.
 | AddVersion(ID, VersionUri) | Adds the version.
 | BlobStreamExists(Guid) | Determines whether the specified field contains a BLOB value.
 | ChangeFieldSharing(TemplateField, TemplateFieldSharing) | Changes the type of field sharing for a single field.
 | ChangeTemplate(ID, TemplateChangeList) | Changes the template.
 | CleanupDatabase()()() | Cleans up the database.
 | CleanupPublishQueue(DateTime) | Cleanups the publish queue.
 | CopyItem(ID, ID, String, ID) | Copies the item.
 | CreateItem(ID, String, ID, ID) | Creates the item.
 | DataManager | Gets the data manager.
 | DeleteItem(ID) | Deletes the item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBlobStream(Guid) | Gets the BLOB stream associated with a field.
 | GetChildIDs(ID) | Gets the child I ds.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemData(ID, Language, Version) | Gets the item data.
 | GetItemDefinition(ID) | Gets the item definition.
 | GetItemDefinition(String) | Gets the item definition.
 | GetItemInformation(ID) | Gets the item information.
 | GetItemsInWorkflowState(WorkflowInfo) | Gets the state of the items in workflow.
 | GetLanguages()()() | Removes all data using a specific language from the database.
 | GetLanguages(ID) | Gets the languages containing data for a specific item.
 | GetLatestVersion(ID, Language) | Gets the latest version.
 | GetParentID(ID) | Gets the parent ID.
 | GetProperty(String) | Gets the property.
 | GetPropertyKeys(String) | Gets a list of property keys matching a specific prefix.
 | GetPublishQueue(DateTime, DateTime) | Gets the publish queue.
 | GetRootID()()() | Gets the root ID.
 | GetTemplate(ID) | Gets the template.
 | GetTemplate(String) | Gets the template.
 | GetTemplateIds()()() | Get a list of all template ids stored in the data providers.
 | GetTemplates()()() | Gets the templates.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersions(ID, Language) | Gets the versions.
 | GetVersions(ItemInformation, Language) | Gets the versions.
 | GetVersionUris(ID) | Gets all version URIs for an item.
 | GetWorkflowInfo(ID, Language, Version) | Gets the workflow info.
 | HasChildren(ID) | Determines whether the specified item has children.
 | ItemExists(ID) | Items the exists.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveItem(ID, ID) | Moves the item.
 | RemoveLanguageData(Language) | Removes the language data specified by language.
 | RemoveProperty(String, Boolean) | Removes the property.
 | RemoveVersion(ID, VersionUri) | Removes the version.
 | RemoveVersions(ID, Language, Boolean) | Removes the versions.
 | RenameLanguageData(String, String) | Renames a language binding.
 | ResolvePath(String) | Resolves the path.
 | SaveItem(ID, ItemChanges) | Saves the item.
 | SelectIDs(String) | Selects the I ds.
 | SelectSingleID(String) | Selects the single ID.
 | SetBlobStream(Stream, Guid) | Sets the BLOB stream associated with a field.
 | SetProperty(String, String) | Sets the property.
 | SetWorkflowInfo(ID, Language, Version, WorkflowInfo) | Sets the workflow info.
 | SetWorkflowInfo(ItemDefinition, VersionUri, WorkflowInfo) | Sets the workflow info.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DataSource


DataSource Constructor (dataManager)

DataSource Constructor (dataManager)
Namespaces ► Sitecore.Data ► DataSource ► DataSource(DataManager)
Initializes a new instance of the DataSource class.
Declaration Syntax
C#
public DataSource(
    DataManager dataManager
)
Parameters
dataManager (DataManager)
The data manager.


AddToPublishQueue Method (itemID, action, date)

AddToPublishQueue Method (itemID, action, date)
Namespaces ► Sitecore.Data ► DataSource ► AddToPublishQueue(ID, String, DateTime)
Adds to publish queue.
Declaration Syntax
C#
public bool AddToPublishQueue(
    ID itemID,
    string action,
    DateTime date
)
Parameters
itemID (ID)
The item ID.
action (String)
The action.
date (DateTime)
The date.
Return Value
The to publish queue.


AddVersion Method (itemID, baseVersion)

AddVersion Method (itemID, baseVersion)
Namespaces ► Sitecore.Data ► DataSource ► AddVersion(ID, VersionUri)
Adds the version.
Declaration Syntax
C#
public int AddVersion(
    ID itemID,
    VersionUri baseVersion
)
Parameters
itemID (ID)
The item ID.
baseVersion (VersionUri)
The base version.
Return Value
The version.


BlobStreamExists Method (blobId)

BlobStreamExists Method (blobId)
Namespaces ► Sitecore.Data ► DataSource ► BlobStreamExists(Guid)
Determines whether the specified field contains a BLOB value.
Declaration Syntax
C#
public bool BlobStreamExists(
    Guid blobId
)
Parameters
blobId (Guid)
The BLOB id.
Return Value
true if [has BLOB value] [the specified BLOB id]; otherwise, false.


ChangeFieldSharing Method (fieldDefinition, sharing)

ChangeFieldSharing Method (fieldDefinition, sharing)
Namespaces ► Sitecore.Data ► DataSource ► ChangeFieldSharing(TemplateField, TemplateFieldSharing)
Changes the type of field sharing for a single field.
Declaration Syntax
C#
public bool ChangeFieldSharing(
    TemplateField fieldDefinition,
    TemplateFieldSharing sharing
)
Parameters
fieldDefinition (TemplateField)
The field definition.
sharing (TemplateFieldSharing)
The new sharing type.
Return Value


ChangeTemplate Method (itemID, changes)

ChangeTemplate Method (itemID, changes)
Namespaces ► Sitecore.Data ► DataSource ► ChangeTemplate(ID, TemplateChangeList)
Changes the template.
Declaration Syntax
C#
public bool ChangeTemplate(
    ID itemID,
    TemplateChangeList changes
)
Parameters
itemID (ID)
The item ID.
changes (TemplateChangeList)
The changes.
Return Value
The template.


CleanupDatabase Method

CleanupDatabase Method
Namespaces ► Sitecore.Data ► DataSource ► CleanupDatabase()()()
Cleans up the database.
Declaration Syntax
C#
public bool CleanupDatabase()
Return Value
true if cleanup was performed; false otherwise.
Remarks

Typically, a cleanup operation will remove data in invalid languages and items in orphaned trees.

Specific operations depends on the actual data provider implementation.


CleanupPublishQueue Method (to)

CleanupPublishQueue Method (to)
Namespaces ► Sitecore.Data ► DataSource ► CleanupPublishQueue(DateTime)
Cleanups the publish queue.
Declaration Syntax
C#
public bool CleanupPublishQueue(
    DateTime to
)
Parameters
to (DateTime)
To.
Return Value
The publish queue.


CopyItem Method (sourceID, destinationID, copyName, copyID)

CopyItem Method (sourceID, destinationID, copyName, copyID)
Namespaces ► Sitecore.Data ► DataSource ► CopyItem(ID, ID, String, ID)
Copies the item.
Declaration Syntax
C#
public bool CopyItem(
    ID sourceID,
    ID destinationID,
    string copyName,
    ID copyID
)
Parameters
sourceID (ID)
The source ID.
destinationID (ID)
The destination ID.
copyName (String)
Name of the copy.
copyID (ID)
The copy ID.
Return Value
The item.


CreateItem Method (itemID, itemName, templateID, parentID)

CreateItem Method (itemID, itemName, templateID, parentID)
Namespaces ► Sitecore.Data ► DataSource ► CreateItem(ID, String, ID, ID)
Creates the item.
Declaration Syntax
C#
public bool CreateItem(
    ID itemID,
    string itemName,
    ID templateID,
    ID parentID
)
Parameters
itemID (ID)
The item ID.
itemName (String)
Name of the item.
templateID (ID)
The template ID.
parentID (ID)
The parent ID.
Return Value
The item.


DataManager Property

DataManager Property
Namespaces ► Sitecore.Data ► DataSource ► DataManager
Gets the data manager.
Declaration Syntax
C#
public DataManager DataManager { get; }
Value
The data manager.


DeleteItem Method (itemID)

DeleteItem Method (itemID)
Namespaces ► Sitecore.Data ► DataSource ► DeleteItem(ID)
Deletes the item.
Declaration Syntax
C#
public bool DeleteItem(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value
The item.


GetBlobStream Method (blobId)

GetBlobStream Method (blobId)
Namespaces ► Sitecore.Data ► DataSource ► GetBlobStream(Guid)
Gets the BLOB stream associated with a field.
Declaration Syntax
C#
public Stream GetBlobStream(
    Guid blobId
)
Parameters
blobId (Guid)
The BLOB id.
Return Value
The stream.


GetChildIDs Method (itemID)

GetChildIDs Method (itemID)
Namespaces ► Sitecore.Data ► DataSource ► GetChildIDs(ID)
Gets the child I ds.
Declaration Syntax
C#
public virtual IDList GetChildIDs(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value
The child I ds.


GetItemData Method (itemID, language, version)

GetItemData Method (itemID, language, version)
Namespaces ► Sitecore.Data ► DataSource ► GetItemData(ID, Language, Version)
Gets the item data.
Declaration Syntax
C#
public virtual ItemData GetItemData(
    ID itemID,
    Language language,
    Version version
)
Parameters
itemID (ID)
The item ID.
language (Language)
The language.
version (Version)
The version.
Return Value
The item data.


GetItemDefinition Method

GetItemDefinition Method
Namespaces ► Sitecore.Data ► DataSource ► GetItemDefinition()()()
Members
Icon | Member | Description
 | GetItemDefinition(ID) | Gets the item definition.
 | GetItemDefinition(String) | Gets the item definition.


GetItemDefinition Method (itemID)

GetItemDefinition Method (itemID)
Namespaces ► Sitecore.Data ► DataSource ► GetItemDefinition(ID)
Gets the item definition.
Declaration Syntax
C#
public virtual ItemDefinition GetItemDefinition(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value
The item definition.


GetItemDefinition Method (path)

GetItemDefinition Method (path)
Namespaces ► Sitecore.Data ► DataSource ► GetItemDefinition(String)
Gets the item definition.
Declaration Syntax
C#
public virtual ItemDefinition GetItemDefinition(
    string path
)
Parameters
path (String)
The path.
Return Value
The item definition.


GetItemInformation Method (itemID)

GetItemInformation Method (itemID)
Namespaces ► Sitecore.Data ► DataSource ► GetItemInformation(ID)
Gets the item information.
Declaration Syntax
C#
public virtual ItemInformation GetItemInformation(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value
The item information.


GetItemsInWorkflowState Method (info)

GetItemsInWorkflowState Method (info)
Namespaces ► Sitecore.Data ► DataSource ► GetItemsInWorkflowState(WorkflowInfo)
Gets the state of the items in workflow.
Declaration Syntax
C#
public DataUri[] GetItemsInWorkflowState(
    WorkflowInfo info
)
Parameters
info (WorkflowInfo)
The info.
Return Value
The DataUri array.


GetLanguages Method

GetLanguages Method
Namespaces ► Sitecore.Data ► DataSource ► GetLanguages()()()
Members
Icon | Member | Description
 | GetLanguages()()() | Removes all data using a specific language from the database.
 | GetLanguages(ID) | Gets the languages containing data for a specific item.


GetLanguages Method

GetLanguages Method
Namespaces ► Sitecore.Data ► DataSource ► GetLanguages()()()
Removes all data using a specific language from the database.
Declaration Syntax
C#
public LanguageCollection GetLanguages()
Return Value
The languages.


GetLanguages Method (itemId)

GetLanguages Method (itemId)
Namespaces ► Sitecore.Data ► DataSource ► GetLanguages(ID)
Gets the languages containing data for a specific item.
Declaration Syntax
C#
public LanguageCollection GetLanguages(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value
The languages.


GetLatestVersion Method (itemID, language)

GetLatestVersion Method (itemID, language)
Namespaces ► Sitecore.Data ► DataSource ► GetLatestVersion(ID, Language)
Gets the latest version.
Declaration Syntax
C#
public Version GetLatestVersion(
    ID itemID,
    Language language
)
Parameters
itemID (ID)
The item ID.
language (Language)
The language.
Return Value


GetParentID Method (itemID)

GetParentID Method (itemID)
Namespaces ► Sitecore.Data ► DataSource ► GetParentID(ID)
Gets the parent ID.
Declaration Syntax
C#
public virtual ID GetParentID(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value


GetProperty Method (name)

GetProperty Method (name)
Namespaces ► Sitecore.Data ► DataSource ► GetProperty(String)
Gets the property.
Declaration Syntax
C#
public string GetProperty(
    string name
)
Parameters
name (String)
The name.
Return Value
The property.


GetPropertyKeys Method (prefix)

GetPropertyKeys Method (prefix)
Namespaces ► Sitecore.Data ► DataSource ► GetPropertyKeys(String)
Gets a list of property keys matching a specific prefix.
Declaration Syntax
C#
public List<string> GetPropertyKeys(
    string prefix
)
Parameters
prefix (String)
The prefix.
Return Value
The property.


GetPublishQueue Method (from, to)

GetPublishQueue Method (from, to)
Namespaces ► Sitecore.Data ► DataSource ► GetPublishQueue(DateTime, DateTime)
Gets the publish queue.
Declaration Syntax
C#
public IDList GetPublishQueue(
    DateTime from,
    DateTime to
)
Parameters
from (DateTime)
From.
to (DateTime)
To.
Return Value
The publish queue.


GetRootID Method

GetRootID Method
Namespaces ► Sitecore.Data ► DataSource ► GetRootID()()()
Gets the root ID.
Declaration Syntax
C#
public ID GetRootID()
Return Value
The root ID.


GetTemplate Method

GetTemplate Method
Namespaces ► Sitecore.Data ► DataSource ► GetTemplate()()()
Members
Icon | Member | Description
 | GetTemplate(ID) | Gets the template.
 | GetTemplate(String) | Gets the template.


GetTemplate Method (templateId)

GetTemplate Method (templateId)
Namespaces ► Sitecore.Data ► DataSource ► GetTemplate(ID)
Gets the template.
Declaration Syntax
C#
public Template GetTemplate(
    ID templateId
)
Parameters
templateId (ID)
The template id.
Return Value
The template.


GetTemplate Method (fullName)

GetTemplate Method (fullName)
Namespaces ► Sitecore.Data ► DataSource ► GetTemplate(String)
Gets the template.
Declaration Syntax
C#
public Template GetTemplate(
    string fullName
)
Parameters
fullName (String)
The full name.
Return Value
The template.


GetTemplateIds Method

GetTemplateIds Method
Namespaces ► Sitecore.Data ► DataSource ► GetTemplateIds()()()
Get a list of all template ids stored in the data providers.
Declaration Syntax
C#
public IdCollection GetTemplateIds()
Return Value
The template ids.


GetTemplates Method

GetTemplates Method
Namespaces ► Sitecore.Data ► DataSource ► GetTemplates()()()
Gets the templates.
Declaration Syntax
C#
public TemplateCollection GetTemplates()
Return Value
The templates.


GetVersions Method

GetVersions Method
Namespaces ► Sitecore.Data ► DataSource ► GetVersions()()()
Members
Icon | Member | Description
 | GetVersions(ID, Language) | Gets the versions.
 | GetVersions(ItemInformation, Language) | Gets the versions.


GetVersions Method (itemID, language)

GetVersions Method (itemID, language)
Namespaces ► Sitecore.Data ► DataSource ► GetVersions(ID, Language)
Gets the versions.
Declaration Syntax
C#
public VersionList GetVersions(
    ID itemID,
    Language language
)
Parameters
itemID (ID)
The item ID.
language (Language)
The language.
Return Value


GetVersions Method (itemInformation, language)

GetVersions Method (itemInformation, language)
Namespaces ► Sitecore.Data ► DataSource ► GetVersions(ItemInformation, Language)
Gets the versions.
Declaration Syntax
C#
public VersionCollection GetVersions(
    ItemInformation itemInformation,
    Language language
)
Parameters
itemInformation (ItemInformation)
The item information.
language (Language)
The language.
Return Value


GetVersionUris Method (itemID)

GetVersionUris Method (itemID)
Namespaces ► Sitecore.Data ► DataSource ► GetVersionUris(ID)
Gets all version URIs for an item.
Declaration Syntax
C#
public VersionUriList GetVersionUris(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value


GetWorkflowInfo Method (itemID, language, version)

GetWorkflowInfo Method (itemID, language, version)
Namespaces ► Sitecore.Data ► DataSource ► GetWorkflowInfo(ID, Language, Version)
Gets the workflow info.
Declaration Syntax
C#
public WorkflowInfo GetWorkflowInfo(
    ID itemID,
    Language language,
    Version version
)
Parameters
itemID (ID)
The item ID.
language (Language)
The language.
version (Version)
The version.
Return Value
The workflow info.


HasChildren Method (itemId)

HasChildren Method (itemId)
Namespaces ► Sitecore.Data ► DataSource ► HasChildren(ID)
Determines whether the specified item has children.
Declaration Syntax
C#
public bool HasChildren(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value


ItemExists Method (itemID)

ItemExists Method (itemID)
Namespaces ► Sitecore.Data ► DataSource ► ItemExists(ID)
Items the exists.
Declaration Syntax
C#
public bool ItemExists(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value
The exists.


MoveItem Method (itemID, destinationID)

MoveItem Method (itemID, destinationID)
Namespaces ► Sitecore.Data ► DataSource ► MoveItem(ID, ID)
Moves the item.
Declaration Syntax
C#
public bool MoveItem(
    ID itemID,
    ID destinationID
)
Parameters
itemID (ID)
The item ID.
destinationID (ID)
The destination ID.
Return Value
The item.


RemoveLanguageData Method (language)

RemoveLanguageData Method (language)
Namespaces ► Sitecore.Data ► DataSource ► RemoveLanguageData(Language)
Removes the language data specified by language.
Declaration Syntax
C#
public void RemoveLanguageData(
    Language language
)
Parameters
language (Language)
The language.


RemoveProperty Method (name, isPrefix)

RemoveProperty Method (name, isPrefix)
Namespaces ► Sitecore.Data ► DataSource ► RemoveProperty(String, Boolean)
Removes the property.
Declaration Syntax
C#
public bool RemoveProperty(
    string name,
    bool isPrefix
)
Parameters
name (String)
The name.
isPrefix (Boolean)
if set to true this instance is is prefix.
Return Value
The property.


RemoveVersion Method (itemID, uri)

RemoveVersion Method (itemID, uri)
Namespaces ► Sitecore.Data ► DataSource ► RemoveVersion(ID, VersionUri)
Removes the version.
Declaration Syntax
C#
public bool RemoveVersion(
    ID itemID,
    VersionUri uri
)
Parameters
itemID (ID)
The item ID.
uri (VersionUri)
The URI.
Return Value
The version.


RemoveVersions Method (itemID, language, removeSharedData)

RemoveVersions Method (itemID, language, removeSharedData)
Namespaces ► Sitecore.Data ► DataSource ► RemoveVersions(ID, Language, Boolean)
Removes the versions.
Declaration Syntax
C#
public bool RemoveVersions(
    ID itemID,
    Language language,
    bool removeSharedData
)
Parameters
itemID (ID)
The item ID.
language (Language)
The language.
removeSharedData (Boolean)
If set to true shared data is removed.
Return Value
The versions.


RenameLanguageData Method (fromLanguage, toLanguage)

RenameLanguageData Method (fromLanguage, toLanguage)
Namespaces ► Sitecore.Data ► DataSource ► RenameLanguageData(String, String)
Renames a language binding.
Declaration Syntax
C#
public void RenameLanguageData(
    string fromLanguage,
    string toLanguage
)
Parameters
fromLanguage (String)
Rename from this language name.
toLanguage (String)
Rename to this language name.


ResolvePath Method (path)

ResolvePath Method (path)
Namespaces ► Sitecore.Data ► DataSource ► ResolvePath(String)
Resolves the path.
Declaration Syntax
C#
public ID ResolvePath(
    string path
)
Parameters
path (String)
The path.
Return Value
The path.


SaveItem Method (itemID, changes)

SaveItem Method (itemID, changes)
Namespaces ► Sitecore.Data ► DataSource ► SaveItem(ID, ItemChanges)
Saves the item.
Declaration Syntax
C#
public bool SaveItem(
    ID itemID,
    ItemChanges changes
)
Parameters
itemID (ID)
The item ID.
changes (ItemChanges)
The changes.
Return Value
The item.


SelectIDs Method (query)

SelectIDs Method (query)
Namespaces ► Sitecore.Data ► DataSource ► SelectIDs(String)
Selects the I ds.
Declaration Syntax
C#
public IDList SelectIDs(
    string query
)
Parameters
query (String)
The query.
Return Value
The I ds.


SelectSingleID Method (query)

SelectSingleID Method (query)
Namespaces ► Sitecore.Data ► DataSource ► SelectSingleID(String)
Selects the single ID.
Declaration Syntax
C#
public ID SelectSingleID(
    string query
)
Parameters
query (String)
The query.
Return Value
The single ID.


SetBlobStream Method (stream, blobId)

SetBlobStream Method (stream, blobId)
Namespaces ► Sitecore.Data ► DataSource ► SetBlobStream(Stream, Guid)
Sets the BLOB stream associated with a field.
Declaration Syntax
C#
public bool SetBlobStream(
    Stream stream,
    Guid blobId
)
Parameters
stream (Stream)
The stream.
blobId (Guid)
The BLOB id.
Return Value


SetProperty Method (name, value)

SetProperty Method (name, value)
Namespaces ► Sitecore.Data ► DataSource ► SetProperty(String, String)
Sets the property.
Declaration Syntax
C#
public bool SetProperty(
    string name,
    string value
)
Parameters
name (String)
The name.
value (String)
The value.
Return Value
The property.


SetWorkflowInfo Method

SetWorkflowInfo Method
Namespaces ► Sitecore.Data ► DataSource ► SetWorkflowInfo()()()
Members
Icon | Member | Description
 | SetWorkflowInfo(ID, Language, Version, WorkflowInfo) | Sets the workflow info.
 | SetWorkflowInfo(ItemDefinition, VersionUri, WorkflowInfo) | Sets the workflow info.


SetWorkflowInfo Method (itemID, language, version, info)

SetWorkflowInfo Method (itemID, language, version, info)
Namespaces ► Sitecore.Data ► DataSource ► SetWorkflowInfo(ID, Language, Version, WorkflowInfo)
Sets the workflow info.
Declaration Syntax
C#
public bool SetWorkflowInfo(
    ID itemID,
    Language language,
    Version version,
    WorkflowInfo info
)
Parameters
itemID (ID)
The item ID.
language (Language)
The language.
version (Version)
The version.
info (WorkflowInfo)
The info.
Return Value
The workflow info.


SetWorkflowInfo Method (item, versionUri, info)

SetWorkflowInfo Method (item, versionUri, info)
Namespaces ► Sitecore.Data ► DataSource ► SetWorkflowInfo(ItemDefinition, VersionUri, WorkflowInfo)
Sets the workflow info.
Declaration Syntax
C#
public bool SetWorkflowInfo(
    ItemDefinition item,
    VersionUri versionUri,
    WorkflowInfo info
)
Parameters
item (ItemDefinition)
The item.
versionUri (VersionUri)
The version URI.
info (WorkflowInfo)
The info.
Return Value
The workflow info.


DataUri Class

DataUri Class
Namespaces ► Sitecore.Data ► DataUri
Represents a moniker to an item in a specified database.
Declaration Syntax
C#
[SerializableAttribute]
public class DataUri : ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataUri(DataUri) | Creates a new DataUri instance.
 | DataUri(ItemUri) | Creates a new DataUri instance.
 | DataUri(String) | Creates a new DataUri instance.
 | DataUri(ID) | Creates a new DataUri instance.
 | DataUri(ID, Language) | Creates a new DataUri instance.
 | DataUri(ID, Language, Version) | Creates a new DataUri instance.
 | DataUri(String, Language) | Creates a new DataUri instance.
 | DataUri(String, Language, Version) | Creates a new DataUri instance.
 | DataUri(SerializationInfo, StreamingContext) | Creates a new DataUri instance.
 | Clone()()() | Clones this instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemID | Gets the item ID.
 | Language | Gets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Converts a string into a DataUri.
 | Path | Gets or sets the path.
 | ToString()()() | Returns the string presentation of a DataUri. (Overrides Object.ToString()()().)
 | ToString(Boolean) | Returns the string presentation of a DataUri.
 | Version | Gets the version.
Remarks

A data URI point to an item in a database. Compared to a ItemUri the DataUri is database independant, meaning that a DataUri does no contain any information about database.

Format: sitecore://home/news?lang=da#ver=2

Inheritance Hierarchy
Object
DataUri


DataUri Constructor

DataUri Constructor
Namespaces ► Sitecore.Data ► DataUri ► DataUri()()()
Members
Icon | Member | Description
 | DataUri(DataUri) | Creates a new DataUri instance.
 | DataUri(ItemUri) | Creates a new DataUri instance.
 | DataUri(String) | Creates a new DataUri instance.
 | DataUri(ID) | Creates a new DataUri instance.
 | DataUri(ID, Language) | Creates a new DataUri instance.
 | DataUri(ID, Language, Version) | Creates a new DataUri instance.
 | DataUri(String, Language) | Creates a new DataUri instance.
 | DataUri(String, Language, Version) | Creates a new DataUri instance.
 | DataUri(SerializationInfo, StreamingContext) | Creates a new DataUri instance.


DataUri Constructor (uri)

DataUri Constructor (uri)
Namespaces ► Sitecore.Data ► DataUri ► DataUri(DataUri)
Creates a new DataUri instance.
Declaration Syntax
C#
public DataUri(
    DataUri uri
)
Parameters
uri (DataUri)
URI.


DataUri Constructor (itemID)

DataUri Constructor (itemID)
Namespaces ► Sitecore.Data ► DataUri ► DataUri(ID)
Creates a new DataUri instance.
Declaration Syntax
C#
public DataUri(
    ID itemID
)
Parameters
itemID (ID)
Item ID.


DataUri Constructor (itemID, language)

DataUri Constructor (itemID, language)
Namespaces ► Sitecore.Data ► DataUri ► DataUri(ID, Language)
Creates a new DataUri instance.
Declaration Syntax
C#
public DataUri(
    ID itemID,
    Language language
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.


DataUri Constructor (itemID, language, version)

DataUri Constructor (itemID, language, version)
Namespaces ► Sitecore.Data ► DataUri ► DataUri(ID, Language, Version)
Creates a new DataUri instance.
Declaration Syntax
C#
public DataUri(
    ID itemID,
    Language language,
    Version version
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
version (Version)
Version.


DataUri Constructor (uri)

DataUri Constructor (uri)
Namespaces ► Sitecore.Data ► DataUri ► DataUri(ItemUri)
Creates a new DataUri instance.
Declaration Syntax
C#
public DataUri(
    ItemUri uri
)
Parameters
uri (ItemUri)
URI.


DataUri Constructor (info, context)

DataUri Constructor (info, context)
Namespaces ► Sitecore.Data ► DataUri ► DataUri(SerializationInfo, StreamingContext)
Creates a new DataUri instance.
Declaration Syntax
C#
protected DataUri(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
Info.
context (StreamingContext)
Context.


DataUri Constructor (dataUri)

DataUri Constructor (dataUri)
Namespaces ► Sitecore.Data ► DataUri ► DataUri(String)
Creates a new DataUri instance.
Declaration Syntax
C#
public DataUri(
    string dataUri
)
Parameters
dataUri (String)
Data URI.


DataUri Constructor (path, language)

DataUri Constructor (path, language)
Namespaces ► Sitecore.Data ► DataUri ► DataUri(String, Language)
Creates a new DataUri instance.
Declaration Syntax
C#
public DataUri(
    string path,
    Language language
)
Parameters
path (String)
Path.
language (Language)
Language.


DataUri Constructor (path, language, version)

DataUri Constructor (path, language, version)
Namespaces ► Sitecore.Data ► DataUri ► DataUri(String, Language, Version)
Creates a new DataUri instance.
Declaration Syntax
C#
public DataUri(
    string path,
    Language language,
    Version version
)
Parameters
path (String)
Path.
language (Language)
Language.
version (Version)
Version.


Clone Method

Clone Method
Namespaces ► Sitecore.Data ► DataUri ► Clone()()()
Clones this instance.
Declaration Syntax
C#
public Object Clone()
Return Value
A new object that is a copy of this instance.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Data ► DataUri ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


ItemID Property

ItemID Property
Namespaces ► Sitecore.Data ► DataUri ► ItemID
Gets the item ID.
Declaration Syntax
C#
public ID ItemID { get; }
Value
The item ID.


Language Property

Language Property
Namespaces ► Sitecore.Data ► DataUri ► Language
Gets the language.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


Parse Method (dataUri)

Parse Method (dataUri)
Namespaces ► Sitecore.Data ► DataUri ► Parse(String)
Converts a string into a DataUri.
Declaration Syntax
C#
public static DataUri Parse(
    string dataUri
)
Parameters
dataUri (String)
Data URI.
Return Value
The parse.


Path Property

Path Property
Namespaces ► Sitecore.Data ► DataUri ► Path
Gets or sets the path.
Declaration Syntax
C#
public string Path { get; set; }
Value
The path.


ToString Method

ToString Method
Namespaces ► Sitecore.Data ► DataUri ► ToString()()()
Members
Icon | Member | Description
 | ToString()()() | Returns the string presentation of a DataUri. (Overrides Object.ToString()()().)
 | ToString(Boolean) | Returns the string presentation of a DataUri.


ToString Method

ToString Method
Namespaces ► Sitecore.Data ► DataUri ► ToString()()()
Returns the string presentation of a DataUri.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


ToString Method (shortFormat)

ToString Method (shortFormat)
Namespaces ► Sitecore.Data ► DataUri ► ToString(Boolean)
Returns the string presentation of a DataUri.
Declaration Syntax
C#
public string ToString(
    bool shortFormat
)
Parameters
shortFormat (Boolean)
if set to true this instance is short format.
Return Value
The string.


Version Property

Version Property
Namespaces ► Sitecore.Data ► DataUri ► Version
Gets the version.
Declaration Syntax
C#
public Version Version { get; }
Value
The version.


DeviceRecords Class

DeviceRecords Class
Namespaces ► Sitecore.Data ► DeviceRecords
Represents the layout devices that are defined in a specified database.
Declaration Syntax
C#
public class DeviceRecords : Database..::.DataRecords
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeviceRecords(Database) | Creates a new DeviceRecords instance.
 | BasePath | Gets the base path. (Inherited from Database..::.DataRecords.)
 | Database | Gets the database. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::.DataRecords.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::.DataRecords.)
 | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::.DataRecords.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAll()()() | Gets all the devices defined by the database.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniquePath(String) | Gets a unique path of an item in the database. (Inherited from Database..::.DataRecords.)
 | Item[([(ID])]) | Gets the DeviceItem with the specified item ID.
 | Item[([(String])]) | Gets the DeviceItem with the specified item path.
 | Item[([(DataUri])]) | Gets the DeviceItem with the specified URI.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

Devices are configured in /sitecore/layouts/Layout/Devices.

The devices are normally access through the Devices property.

Inheritance Hierarchy
Object
 | Database..::.DataRecords
 |  | DeviceRecords


DeviceRecords Constructor (database)

DeviceRecords Constructor (database)
Namespaces ► Sitecore.Data ► DeviceRecords ► DeviceRecords(Database)
Creates a new DeviceRecords instance.
Declaration Syntax
C#
public DeviceRecords(
    Database database
)
Parameters
database (Database)
Database.


GetAll Method

GetAll Method
Namespaces ► Sitecore.Data ► DeviceRecords ► GetAll()()()
Gets all the devices defined by the database.
Declaration Syntax
C#
public DeviceItem[] GetAll()
Return Value
The all.


Item Property

Item Property
Namespaces ► Sitecore.Data ► DeviceRecords ► Item
Members
Icon | Member | Description
 | Item[([(ID])]) | Gets the DeviceItem with the specified item ID.
 | Item[([(String])]) | Gets the DeviceItem with the specified item path.
 | Item[([(DataUri])]) | Gets the DeviceItem with the specified URI.


Item Property (uri)

Item Property (uri)
Namespaces ► Sitecore.Data ► DeviceRecords ► Item[([(DataUri])])
Gets the DeviceItem with the specified URI.
Declaration Syntax
C#
public DeviceItem this[
    DataUri uri
] { get; }
Parameters
uri (DataUri)


Item Property (itemID)

Item Property (itemID)
Namespaces ► Sitecore.Data ► DeviceRecords ► Item[([(ID])])
Gets the DeviceItem with the specified item ID.
Declaration Syntax
C#
public DeviceItem this[
    ID itemID
] { get; }
Parameters
itemID (ID)


Item Property (itemPath)

Item Property (itemPath)
Namespaces ► Sitecore.Data ► DeviceRecords ► Item[([(String])])
Gets the DeviceItem with the specified item path.
Declaration Syntax
C#
public DeviceItem this[
    string itemPath
] { get; }
Parameters
itemPath (String)


FieldDescriptor Class

FieldDescriptor Class
Namespaces ► Sitecore.Data ► FieldDescriptor
Defines the field URI class.
Declaration Syntax
C#
public class FieldDescriptor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldDescriptor(Item, String) | Initializes a new instance of the FieldDescriptor class.
 | FieldDescriptor(ItemUri, ID, String) | Initializes a new instance of the FieldDescriptor class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)
 | FieldID | Gets the field ID.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemUri | Gets the item URI.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Parses the specified field URI.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | Value | Gets or sets the value.
Inheritance Hierarchy
Object
FieldDescriptor


FieldDescriptor Constructor

FieldDescriptor Constructor
Namespaces ► Sitecore.Data ► FieldDescriptor ► FieldDescriptor()()()
Members
Icon | Member | Description
 | FieldDescriptor(Item, String) | Initializes a new instance of the FieldDescriptor class.
 | FieldDescriptor(ItemUri, ID, String) | Initializes a new instance of the FieldDescriptor class.


FieldDescriptor Constructor (item, fieldName)

FieldDescriptor Constructor (item, fieldName)
Namespaces ► Sitecore.Data ► FieldDescriptor ► FieldDescriptor(Item, String)
Initializes a new instance of the FieldDescriptor class.
Declaration Syntax
C#
public FieldDescriptor(
    Item item,
    string fieldName
)
Parameters
item (Item)
The item.
fieldName (String)
The field name


FieldDescriptor Constructor (itemUri, fieldID, value)

FieldDescriptor Constructor (itemUri, fieldID, value)
Namespaces ► Sitecore.Data ► FieldDescriptor ► FieldDescriptor(ItemUri, ID, String)
Initializes a new instance of the FieldDescriptor class.
Declaration Syntax
C#
public FieldDescriptor(
    ItemUri itemUri,
    ID fieldID,
    string value
)
Parameters
itemUri (ItemUri)
The item URI.
fieldID (ID)
The field ID.
value (String)
The value.


Equals Method (obj)

Equals Method (obj)
Namespaces ► Sitecore.Data ► FieldDescriptor ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C#
public override bool Equals(
    Object obj
)
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.


FieldID Property

FieldID Property
Namespaces ► Sitecore.Data ► FieldDescriptor ► FieldID
Gets the field ID.
Declaration Syntax
C#
public ID FieldID { get; }
Value
The field ID.


GetHashCode Method

GetHashCode Method
Namespaces ► Sitecore.Data ► FieldDescriptor ► GetHashCode()()()
Serves as a hash function for a particular type.
Declaration Syntax
C#
public override int GetHashCode()
Return Value
A hash code for the current Object.


ItemUri Property

ItemUri Property
Namespaces ► Sitecore.Data ► FieldDescriptor ► ItemUri
Gets the item URI.
Declaration Syntax
C#
public ItemUri ItemUri { get; }
Value
The item URI.


Parse Method (fieldUri)

Parse Method (fieldUri)
Namespaces ► Sitecore.Data ► FieldDescriptor ► Parse(String)
Parses the specified field URI.
Declaration Syntax
C#
public static FieldDescriptor Parse(
    string fieldUri
)
Parameters
fieldUri (String)
The field URI.
Return Value
The field URI.


ToString Method

ToString Method
Namespaces ► Sitecore.Data ► FieldDescriptor ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Value Property

Value Property
Namespaces ► Sitecore.Data ► FieldDescriptor ► Value
Gets or sets the value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.


FieldList Class

FieldList Class
Namespaces ► Sitecore.Data ► FieldList
Represents a list of fields.
Declaration Syntax
C#
public class FieldList : IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldList()()() | Initializes a new instance of the FieldList class
 | Add(ID, String) | Adds the specified field ID.
 | Add(FieldList, FieldList) | Joins the specified lists of fields.
 | Clear()()() | Clears this instance.
 | Count | Gets the count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldValues | Gets the fields.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataLength()()() | Gets the size of the data to use when caching.
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection (yielding KeyValuePair{ID, string}).
 | GetFieldIDs()()() | Gets the field Ids.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(ID])]) | Gets the String with the specified field ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SyncRoot | Gets the sync root.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FieldList


FieldList Constructor

FieldList Constructor
Namespaces ► Sitecore.Data ► FieldList ► FieldList()()()
Initializes a new instance of the FieldList class
Declaration Syntax
C#
public FieldList()


Add Method

Add Method
Namespaces ► Sitecore.Data ► FieldList ► Add()()()
Members
Icon | Member | Description
 | Add(ID, String) | Adds the specified field ID.
 | Add(FieldList, FieldList) | Joins the specified lists of fields.


Add Method (list1, list2)

Add Method (list1, list2)
Namespaces ► Sitecore.Data ► FieldList ► Add(FieldList, FieldList)
Joins the specified lists of fields.
Declaration Syntax
C#
public static FieldList Add(
    FieldList list1,
    FieldList list2
)
Parameters
list1 (FieldList)
The first list.
list2 (FieldList)
The second list.
Return Value
The joined lists.


Add Method (fieldId, value)

Add Method (fieldId, value)
Namespaces ► Sitecore.Data ► FieldList ► Add(ID, String)
Adds the specified field ID.
Declaration Syntax
C#
public void Add(
    ID fieldId,
    string value
)
Parameters
fieldId (ID)
The field ID.
value (String)
The value.


Clear Method

Clear Method
Namespaces ► Sitecore.Data ► FieldList ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public void Clear()


Count Property

Count Property
Namespaces ► Sitecore.Data ► FieldList ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


FieldValues Property

FieldValues Property
Namespaces ► Sitecore.Data ► FieldList ► FieldValues
Gets the fields.
Declaration Syntax
C#
public HashList<ID, string> FieldValues { get; }
Value
The fields.


GetDataLength Method

GetDataLength Method
Namespaces ► Sitecore.Data ► FieldList ► GetDataLength()()()
Gets the size of the data to use when caching.
Declaration Syntax
C#
public long GetDataLength()
Return Value


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Data ► FieldList ► GetEnumerator()()()
Returns an enumerator that iterates through a collection (yielding KeyValuePair{ID, string}).
Declaration Syntax
C#
public IEnumerator GetEnumerator()
Return Value
An IEnumerator object that can be used to iterate through the collection.


GetFieldIDs Method

GetFieldIDs Method
Namespaces ► Sitecore.Data ► FieldList ► GetFieldIDs()()()
Gets the field Ids.
Declaration Syntax
C#
public ID[] GetFieldIDs()
Return Value
The field Ids.


Item Property (fieldID)

Item Property (fieldID)
Namespaces ► Sitecore.Data ► FieldList ► Item[([(ID])])
Gets the String with the specified field ID.
Declaration Syntax
C#
public string this[
    ID fieldID
] { get; }
Parameters
fieldID (ID)
Value
The String.


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Data ► FieldList ► SyncRoot
Gets the sync root.
Declaration Syntax
C#
public Object SyncRoot { get; }
Value
The sync root.


ID Class

ID Class
Namespaces ► Sitecore.Data ► ID
An ID represents a unique identifier.
Declaration Syntax
C#
[SerializableAttribute]
public class ID : ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ID(String) | Initializes an ID from a string.
 | ID(Guid) | Initializes an ID from a GUID.
 | ID(SerializationInfo, StreamingContext) | Initializes a new instance of the ID class.
 | ArrayToString(array<ID>[]()[]) | Arrays to string.
 | ArrayToString(array<ID>[]()[], Char) | Arrays to string.
 | Decode(String) | Converts a ShortID into a an ID.
 | Encode(ID) | Converts an ID to a ShortID.
 | Equality(ID, ID) | Operator ==s the specified id1.
 | Equality(ShortID, ID) | Operator ==s the specified id1.
 | Equality(ID, ShortID) | Operator ==s the specified id1.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataLength()()() | Gets the length of the data.
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object.GetHashCode()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Guid | Gets the GUID represented by the ID.
 | Implicit(BranchId) | Implicit operators the specified master ID.
 | Implicit(TemplateID) | Implicit operators the specified template ID.
 | Inequality(ID, ID) | Operator !=s the specified id1.
 | Inequality(ShortID, ID) | Operator !=s the specified id1.
 | Inequality(ID, ShortID) | Operator !=s the specified id1.
 | IsGlobalNullId | Gets or sets a value indicating whether this instance is the global null id.
 | IsID(String) | Tests if the string is a valid ID.
 | IsNull | Gets or sets a value indicating whether this instance is null.
 | IsNullOrEmpty(ID) | Determines whether the specified id is null or empty.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewID | Gets a new unique ID.
 | Null | Gets the Null ID.
 | Parse(Object) | Converts an object to an ID.
 | Parse(Guid) | Converts a GUID to an ID.
 | Parse(String) | Converts a string to an ID.
 | Parse(String, ID) | Converts a string to an ID.
 | ParseArray(String) | Converts a string of pipe separated IDs to an array of IDs.
 | ParseArray(String, Boolean) | Converts a string of pipe separated IDs to an array of IDs.
 | ToGuid()()() | Gets the GUID represented by the ID.
 | ToShortID()()() | Converts the ID to a ShortID.
 | ToString()()() | Converts the ID to a string. (Overrides Object.ToString()()().)
 | TryParse(Object, ID%) | Tries to parse a value.
 | TryParse(String, ID%) | Tries to parse a string value.
 | Undefined | Gets the Undefined ID.
Remarks

In Sitecore an ID is a GUID.

The ID can be converted to a ShortID or a LongID.

Inheritance Hierarchy
Object
ID


ID Constructor

ID Constructor
Namespaces ► Sitecore.Data ► ID ► ID()()()
Members
Icon | Member | Description
 | ID(String) | Initializes an ID from a string.
 | ID(Guid) | Initializes an ID from a GUID.
 | ID(SerializationInfo, StreamingContext) | Initializes a new instance of the ID class.


ID Constructor (id)

ID Constructor (id)
Namespaces ► Sitecore.Data ► ID ► ID(Guid)
Initializes an ID from a GUID.
Declaration Syntax
C#
public ID(
    Guid id
)
Parameters
id (Guid)
The id.


ID Constructor (info, context)

ID Constructor (info, context)
Namespaces ► Sitecore.Data ► ID ► ID(SerializationInfo, StreamingContext)
Initializes a new instance of the ID class.
Declaration Syntax
C#
protected ID(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


ID Constructor (id)

ID Constructor (id)
Namespaces ► Sitecore.Data ► ID ► ID(String)
Initializes an ID from a string.
Declaration Syntax
C#
public ID(
    string id
)
Parameters
id (String)
The id.
Remarks
The string must be 38 characters long, start with a curly brace "{" and end with a curly brace "}".


ArrayToString Method

ArrayToString Method
Namespaces ► Sitecore.Data ► ID ► ArrayToString()()()
Members
Icon | Member | Description
 | ArrayToString(array<ID>[]()[]) | Arrays to string.
 | ArrayToString(array<ID>[]()[], Char) | Arrays to string.


ArrayToString Method (ids)

ArrayToString Method (ids)
Namespaces ► Sitecore.Data ► ID ► ArrayToString(array<ID>[]()[])
Arrays to string.
Declaration Syntax
C#
public static string ArrayToString(
    ID[] ids
)
Parameters
ids (array< ID >[]()[])
The ids.
Return Value
The to string.


ArrayToString Method (ids, separator)

ArrayToString Method (ids, separator)
Namespaces ► Sitecore.Data ► ID ► ArrayToString(array<ID>[]()[], Char)
Arrays to string.
Declaration Syntax
C#
public static string ArrayToString(
    ID[] ids,
    char separator
)
Parameters
ids (array< ID >[]()[])
The ids.
separator (Char)
The separator.
Return Value
The to string.


Decode Method (id)

Decode Method (id)
Namespaces ► Sitecore.Data ► ID ► Decode(String)
Converts a ShortID into a an ID.
Declaration Syntax
C#
public static ID Decode(
    string id
)
Parameters
id (String)
The id.
Return Value
The decode.


Encode Method (id)

Encode Method (id)
Namespaces ► Sitecore.Data ► ID ► Encode(ID)
Converts an ID to a ShortID.
Declaration Syntax
C#
public static string Encode(
    ID id
)
Parameters
id (ID)
The id.
Return Value
The encode.


Equality Method

Equality Method
Namespaces ► Sitecore.Data ► ID ► Equality()()()
Members
Icon | Member | Description
 | Equality(ID, ID) | Operator ==s the specified id1.
 | Equality(ShortID, ID) | Operator ==s the specified id1.
 | Equality(ID, ShortID) | Operator ==s the specified id1.


Equality Operator

Equality Operator
Namespaces ► Sitecore.Data ► ID ► Equality(ID, ID)
Operator ==s the specified id1.
Declaration Syntax
C#
public static bool operator ==(
    ID id1,
    ID id2
)
Parameters
id1 (ID)
The id1.
id2 (ID)
The id2.
Return Value
The operator ==.


Equality Operator

Equality Operator
Namespaces ► Sitecore.Data ► ID ► Equality(ID, ShortID)
Operator ==s the specified id1.
Declaration Syntax
C#
public static bool operator ==(
    ID id1,
    ShortID id2
)
Parameters
id1 (ID)
The id1.
id2 (ShortID)
The id2.
Return Value
The operator ==.


Equality Operator

Equality Operator
Namespaces ► Sitecore.Data ► ID ► Equality(ShortID, ID)
Operator ==s the specified id1.
Declaration Syntax
C#
public static bool operator ==(
    ShortID id1,
    ID id2
)
Parameters
id1 (ShortID)
The id1.
id2 (ID)
The id2.
Return Value
The operator ==.


Equals Method (obj)

Equals Method (obj)
Namespaces ► Sitecore.Data ► ID ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C#
public override bool Equals(
    Object obj
)
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.


GetDataLength Method

GetDataLength Method
Namespaces ► Sitecore.Data ► ID ► GetDataLength()()()
Gets the length of the data.
Declaration Syntax
C#
public long GetDataLength()
Return Value
The data length.


GetHashCode Method

GetHashCode Method
Namespaces ► Sitecore.Data ► ID ► GetHashCode()()()
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
Declaration Syntax
C#
public override int GetHashCode()
Return Value
A hash code for the current Object.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Data ► ID ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Guid Property

Guid Property
Namespaces ► Sitecore.Data ► ID ► Guid
Gets the GUID represented by the ID.
Declaration Syntax
C#
public Guid Guid { get; }
Value
The GUID.


Implicit Method

Implicit Method
Namespaces ► Sitecore.Data ► ID ► Implicit()()()
Members
Icon | Member | Description
 | Implicit(BranchId) | Implicit operators the specified master ID.
 | Implicit(TemplateID) | Implicit operators the specified template ID.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data ► ID ► Implicit(BranchId)
Implicit operators the specified master ID.
Declaration Syntax
C#
public static implicit operator ID (
    BranchId branchId
)
Parameters
branchId (BranchId)
The master ID.
Return Value
The implicit operator.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data ► ID ► Implicit(TemplateID)
Implicit operators the specified template ID.
Declaration Syntax
C#
public static implicit operator ID (
    TemplateID templateID
)
Parameters
templateID (TemplateID)
The template ID.
Return Value
The implicit operator.


Inequality Method

Inequality Method
Namespaces ► Sitecore.Data ► ID ► Inequality()()()
Members
Icon | Member | Description
 | Inequality(ID, ID) | Operator !=s the specified id1.
 | Inequality(ShortID, ID) | Operator !=s the specified id1.
 | Inequality(ID, ShortID) | Operator !=s the specified id1.


Inequality Operator

Inequality Operator
Namespaces ► Sitecore.Data ► ID ► Inequality(ID, ID)
Operator !=s the specified id1.
Declaration Syntax
C#
public static bool operator !=(
    ID id1,
    ID id2
)
Parameters
id1 (ID)
The id1.
id2 (ID)
The id2.
Return Value
The operator !=.


Inequality Operator

Inequality Operator
Namespaces ► Sitecore.Data ► ID ► Inequality(ID, ShortID)
Operator !=s the specified id1.
Declaration Syntax
C#
public static bool operator !=(
    ID id1,
    ShortID id2
)
Parameters
id1 (ID)
The id1.
id2 (ShortID)
The id2.
Return Value
The operator !=.


Inequality Operator

Inequality Operator
Namespaces ► Sitecore.Data ► ID ► Inequality(ShortID, ID)
Operator !=s the specified id1.
Declaration Syntax
C#
public static bool operator !=(
    ShortID id1,
    ID id2
)
Parameters
id1 (ShortID)
The id1.
id2 (ID)
The id2.
Return Value
The operator !=.


IsGlobalNullId Property

IsGlobalNullId Property
Namespaces ► Sitecore.Data ► ID ► IsGlobalNullId
Gets or sets a value indicating whether this instance is the global null id.
Declaration Syntax
C#
public bool IsGlobalNullId { get; internal set; }
Value
true if this instance is the global null id; otherwise, false.


IsID Method (id)

IsID Method (id)
Namespaces ► Sitecore.Data ► ID ► IsID(String)
Tests if the string is a valid ID.
Declaration Syntax
C#
public static bool IsID(
    string id
)
Parameters
id (String)
The id.
Return Value
true if the specified id is ID; otherwise, false.
Remarks
The string must be 38 characters long, start with a curly brace "{" and end with a curly brace "}".


IsNull Property

IsNull Property
Namespaces ► Sitecore.Data ► ID ► IsNull
Gets or sets a value indicating whether this instance is null.
Declaration Syntax
C#
public bool IsNull { get; }
Value
true if this instance is null; otherwise, false.


IsNullOrEmpty Method (id)

IsNullOrEmpty Method (id)
Namespaces ► Sitecore.Data ► ID ► IsNullOrEmpty(ID)
Determines whether the specified id is null or empty.
Declaration Syntax
C#
public static bool IsNullOrEmpty(
    ID id
)
Parameters
id (ID)
The id.
Return Value
true if the specified id is null or empty; otherwise, false.


NewID Property

NewID Property
Namespaces ► Sitecore.Data ► ID ► NewID
Gets a new unique ID.
Declaration Syntax
C#
public static ID NewID { get; }
Value
The new ID.


Null Property

Null Property
Namespaces ► Sitecore.Data ► ID ► Null
Gets the Null ID.
Declaration Syntax
C#
public static ID Null { get; }
Value
The null.
Remarks
The Null ID is a special wellknown ID.


Parse Method

Parse Method
Namespaces ► Sitecore.Data ► ID ► Parse()()()
Members
Icon | Member | Description
 | Parse(Object) | Converts an object to an ID.
 | Parse(Guid) | Converts a GUID to an ID.
 | Parse(String) | Converts a string to an ID.
 | Parse(String, ID) | Converts a string to an ID.


Parse Method (value)

Parse Method (value)
Namespaces ► Sitecore.Data ► ID ► Parse(Guid)
Converts a GUID to an ID.
Declaration Syntax
C#
public static ID Parse(
    Guid value
)
Parameters
value (Guid)
The value.
Return Value
The parse.


Parse Method (value)

Parse Method (value)
Namespaces ► Sitecore.Data ► ID ► Parse(Object)
Converts an object to an ID.
Declaration Syntax
C#
public static ID Parse(
    Object value
)
Parameters
value (Object)
The value.
Return Value
The parse.


Parse Method (value)

Parse Method (value)
Namespaces ► Sitecore.Data ► ID ► Parse(String)
Converts a string to an ID.
Declaration Syntax
C#
public static ID Parse(
    string value
)
Parameters
value (String)
The value.
Return Value
The parse.


Parse Method (value, defaultValue)

Parse Method (value, defaultValue)
Namespaces ► Sitecore.Data ► ID ► Parse(String, ID)
Converts a string to an ID.
Declaration Syntax
C#
public static ID Parse(
    string value,
    ID defaultValue
)
Parameters
value (String)
The value.
defaultValue (ID)
The default value.
Return Value
The parse.


ParseArray Method

ParseArray Method
Namespaces ► Sitecore.Data ► ID ► ParseArray()()()
Members
Icon | Member | Description
 | ParseArray(String) | Converts a string of pipe separated IDs to an array of IDs.
 | ParseArray(String, Boolean) | Converts a string of pipe separated IDs to an array of IDs.


ParseArray Method (values)

ParseArray Method (values)
Namespaces ► Sitecore.Data ► ID ► ParseArray(String)
Converts a string of pipe separated IDs to an array of IDs.
Declaration Syntax
C#
public static ID[] ParseArray(
    string values
)
Parameters
values (String)
The values.
Return Value
The array.
Remarks
The list of IDs is separated by a pipe "|".


ParseArray Method (values, allowNull)

ParseArray Method (values, allowNull)
Namespaces ► Sitecore.Data ► ID ► ParseArray(String, Boolean)
Converts a string of pipe separated IDs to an array of IDs.
Declaration Syntax
C#
public static ID[] ParseArray(
    string values,
    bool allowNull
)
Parameters
values (String)
The values.
allowNull (Boolean)
if set to true this instance is allow null.
Return Value
The array.
Remarks
The list of IDs is separated by a pipe "|".


ToGuid Method

ToGuid Method
Namespaces ► Sitecore.Data ► ID ► ToGuid()()()
Gets the GUID represented by the ID.
Declaration Syntax
C#
public Guid ToGuid()
Return Value
The GUID.


ToShortID Method

ToShortID Method
Namespaces ► Sitecore.Data ► ID ► ToShortID()()()
Converts the ID to a ShortID.
Declaration Syntax
C#
public ShortID ToShortID()
Return Value
The short ID.


ToString Method

ToString Method
Namespaces ► Sitecore.Data ► ID ► ToString()()()
Converts the ID to a string.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


TryParse Method

TryParse Method
Namespaces ► Sitecore.Data ► ID ► TryParse()()()
Members
Icon | Member | Description
 | TryParse(Object, ID%) | Tries to parse a value.
 | TryParse(String, ID%) | Tries to parse a string value.


TryParse Method (value, result)

TryParse Method (value, result)
Namespaces ► Sitecore.Data ► ID ► TryParse(Object, ID%)
Tries to parse a value.
Declaration Syntax
C#
public static bool TryParse(
    Object value,
    out ID result
)
Parameters
value (Object)
The value.
result ( ID %)
The result.
Return Value
true, if the pasing was successful, otherwise false.


TryParse Method (value, result)

TryParse Method (value, result)
Namespaces ► Sitecore.Data ► ID ► TryParse(String, ID%)
Tries to parse a string value.
Declaration Syntax
C#
public static bool TryParse(
    string value,
    out ID result
)
Parameters
value (String)
The value.
result ( ID %)
The result.
Return Value
true, if the parsing was successful, otherwise false.


Undefined Property

Undefined Property
Namespaces ► Sitecore.Data ► ID ► Undefined
Gets the Undefined ID.
Declaration Syntax
C#
public static ID Undefined { get; }
Value
The undefined.
Remarks
The Undefined ID is a special wellknown ID.


ItemData Class

ItemData Class
Namespaces ► Sitecore.Data ► ItemData
Represents item data.
Declaration Syntax
C#
public class ItemData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemData(ItemDefinition, Language, Version, FieldList) | Initializes a new instance of the ItemData class.
 | DataID | Obsolete. Gets the data ID.
 | Definition | Gets the definition.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fields | Gets the fields.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Language | Gets the language of the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | Gets the version of the item.
Inheritance Hierarchy
Object
ItemData


ItemData Constructor (definition, language, version, fields)

ItemData Constructor (definition, language, version, fields)
Namespaces ► Sitecore.Data ► ItemData ► ItemData(ItemDefinition, Language, Version, FieldList)
Initializes a new instance of the ItemData class.
Declaration Syntax
C#
public ItemData(
    ItemDefinition definition,
    Language language,
    Version version,
    FieldList fields
)
Parameters
definition (ItemDefinition)
The definition.
language (Language)
The language.
version (Version)
The version.
fields (FieldList)
The fields.


DataID Property

DataID Property
Namespaces ► Sitecore.Data ► ItemData ► DataID
Gets the data ID.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Defintion instead.")]
public ID DataID { get; }
Value
The data ID.


Definition Property

Definition Property
Namespaces ► Sitecore.Data ► ItemData ► Definition
Gets the definition.
Declaration Syntax
C#
public ItemDefinition Definition { get; }
Value
The definition.


Fields Property

Fields Property
Namespaces ► Sitecore.Data ► ItemData ► Fields
Gets the fields.
Declaration Syntax
C#
public FieldList Fields { get; }
Value
The fields.


Language Property

Language Property
Namespaces ► Sitecore.Data ► ItemData ► Language
Gets the language of the item.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


Version Property

Version Property
Namespaces ► Sitecore.Data ► ItemData ► Version
Gets the version of the item.
Declaration Syntax
C#
public Version Version { get; }
Value
The version.


ItemDefinition Class

ItemDefinition Class
Namespaces ► Sitecore.Data ► ItemDefinition
Represents an item definition.
Declaration Syntax
C#
public class ItemDefinition : ICacheable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemDefinition(ID, String, ID, ID) | Creates a new ItemDefinition instance.
 | BranchId | Gets the ID of master used for creating the item.
 | Empty | Gets the empty ItemInformation.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataLength()()() | Gets the size of the data to use when caching.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the ID of the item.
 | IsEmpty | Gets a value indicating whether this instance is empty (ie. the null instance).
 | Key | Gets the key of the item.
 | MasterID | Obsolete. Gets the ID of master used for creating the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the item.
 | TemplateID | Gets the ID of the template.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemDefinition


ItemDefinition Constructor (itemID, itemName, templateID, branchId)

ItemDefinition Constructor (itemID, itemName, templateID, branchId)
Namespaces ► Sitecore.Data ► ItemDefinition ► ItemDefinition(ID, String, ID, ID)
Creates a new ItemDefinition instance.
Declaration Syntax
C#
public ItemDefinition(
    ID itemID,
    string itemName,
    ID templateID,
    ID branchId
)
Parameters
itemID (ID)
Item ID.
itemName (String)
Name.
templateID (ID)
Template ID.
branchId (ID)
Branch id.


BranchId Property

BranchId Property
Namespaces ► Sitecore.Data ► ItemDefinition ► BranchId
Gets the ID of master used for creating the item.
Declaration Syntax
C#
public ID BranchId { get; }
Value
The master ID.


Empty Property

Empty Property
Namespaces ► Sitecore.Data ► ItemDefinition ► Empty
Gets the empty ItemInformation.
Declaration Syntax
C#
public static ItemDefinition Empty { get; }
Value
The empty ItemInformation.


GetDataLength Method

GetDataLength Method
Namespaces ► Sitecore.Data ► ItemDefinition ► GetDataLength()()()
Gets the size of the data to use when caching.
Declaration Syntax
C#
public long GetDataLength()
Return Value


ID Property

ID Property
Namespaces ► Sitecore.Data ► ItemDefinition ► ID
Gets the ID of the item.
Declaration Syntax
C#
public ID ID { get; }
Value
The ID.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Data ► ItemDefinition ► IsEmpty
Gets a value indicating whether this instance is empty (ie. the null instance).
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


Key Property

Key Property
Namespaces ► Sitecore.Data ► ItemDefinition ► Key
Gets the key of the item.
Declaration Syntax
C#
public string Key { get; }
Remarks
Same as Name in lowercase.


MasterID Property

MasterID Property
Namespaces ► Sitecore.Data ► ItemDefinition ► MasterID
Gets the ID of master used for creating the item.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use BranchId instead.")]
public ID MasterID { get; }
Value
The master ID.


Name Property

Name Property
Namespaces ► Sitecore.Data ► ItemDefinition ► Name
Gets the name of the item.
Declaration Syntax
C#
public string Name { get; }
Value


TemplateID Property

TemplateID Property
Namespaces ► Sitecore.Data ► ItemDefinition ► TemplateID
Gets the ID of the template.
Declaration Syntax
C#
public ID TemplateID { get; }
Value
The template ID.


ItemInformation Class

ItemInformation Class
Namespaces ► Sitecore.Data ► ItemInformation
ItemInformation
Declaration Syntax
C#
public class ItemInformation : ICacheable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemInformation(ItemDefinition) | Initializes a new instance of the ItemInformation class.
 | AddItemData(ItemData) | Adds the item data.
 | AddLanguages(LanguageCollection) | Adds the languages.
 | AddVersions(VersionUriList) | Adds the versions.
 | AddVersions(VersionCollection, Language) | Adds the versions.
 | ChildIDs | Gets or sets the child I ds.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemData(Language, Version) | Gets the item data.
 | GetLanguages()()() | Gets the languages.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersions()()() | Gets the versions.
 | GetVersions(Language) | Gets the versions.
 | ItemDefinition | Gets the item definition.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotifyChildAdded(ID) | Notifies the child added.
 | NotifyChildRemoved(ID) | Notifies the child removed.
 | NotifySaved(ItemInformation, ItemChanges) | Notifies the saved.
 | NotifyVersionAdded(Language, Version) | Notifies the version added.
 | NotifyVersionRemoved(Language, Version) | Notifies the version removed.
 | NotifyVersionsRemoved(Language) | Notifies the versions removed.
 | ParentID | Gets or sets the parent ID.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemInformation


ItemInformation Constructor (itemDefinition)

ItemInformation Constructor (itemDefinition)
Namespaces ► Sitecore.Data ► ItemInformation ► ItemInformation(ItemDefinition)
Initializes a new instance of the ItemInformation class.
Declaration Syntax
C#
public ItemInformation(
    ItemDefinition itemDefinition
)
Parameters
itemDefinition (ItemDefinition)
The item definition.


AddItemData Method (data)

AddItemData Method (data)
Namespaces ► Sitecore.Data ► ItemInformation ► AddItemData(ItemData)
Adds the item data.
Declaration Syntax
C#
public void AddItemData(
    ItemData data
)
Parameters
data (ItemData)
The data.


AddLanguages Method (languages)

AddLanguages Method (languages)
Namespaces ► Sitecore.Data ► ItemInformation ► AddLanguages(LanguageCollection)
Adds the languages.
Declaration Syntax
C#
public void AddLanguages(
    LanguageCollection languages
)
Parameters
languages (LanguageCollection)
The languages.


AddVersions Method

AddVersions Method
Namespaces ► Sitecore.Data ► ItemInformation ► AddVersions()()()
Members
Icon | Member | Description
 | AddVersions(VersionUriList) | Adds the versions.
 | AddVersions(VersionCollection, Language) | Adds the versions.


AddVersions Method (versions, language)

AddVersions Method (versions, language)
Namespaces ► Sitecore.Data ► ItemInformation ► AddVersions(VersionCollection, Language)
Adds the versions.
Declaration Syntax
C#
public void AddVersions(
    VersionCollection versions,
    Language language
)
Parameters
versions (VersionCollection)
The versions.
language (Language)
The language.


AddVersions Method (versionUris)

AddVersions Method (versionUris)
Namespaces ► Sitecore.Data ► ItemInformation ► AddVersions(VersionUriList)
Adds the versions.
Declaration Syntax
C#
public void AddVersions(
    VersionUriList versionUris
)
Parameters
versionUris (VersionUriList)
The version uris.


ChildIDs Property

ChildIDs Property
Namespaces ► Sitecore.Data ► ItemInformation ► ChildIDs
Gets or sets the child I ds.
Declaration Syntax
C#
public IDList ChildIDs { get; set; }
Value
The child I ds.


GetItemData Method (language, version)

GetItemData Method (language, version)
Namespaces ► Sitecore.Data ► ItemInformation ► GetItemData(Language, Version)
Gets the item data.
Declaration Syntax
C#
public ItemData GetItemData(
    Language language,
    Version version
)
Parameters
language (Language)
The language.
version (Version)
The version.
Return Value
The item data.


GetLanguages Method

GetLanguages Method
Namespaces ► Sitecore.Data ► ItemInformation ► GetLanguages()()()
Gets the languages.
Declaration Syntax
C#
public LanguageCollection GetLanguages()
Return Value
The languages.


GetVersions Method

GetVersions Method
Namespaces ► Sitecore.Data ► ItemInformation ► GetVersions()()()
Members
Icon | Member | Description
 | GetVersions()()() | Gets the versions.
 | GetVersions(Language) | Gets the versions.


GetVersions Method

GetVersions Method
Namespaces ► Sitecore.Data ► ItemInformation ► GetVersions()()()
Gets the versions.
Declaration Syntax
C#
public VersionUriList GetVersions()
Return Value
The versions.


GetVersions Method (language)

GetVersions Method (language)
Namespaces ► Sitecore.Data ► ItemInformation ► GetVersions(Language)
Gets the versions.
Declaration Syntax
C#
public VersionCollection GetVersions(
    Language language
)
Parameters
language (Language)
The language.
Return Value
The versions.


ItemDefinition Property

ItemDefinition Property
Namespaces ► Sitecore.Data ► ItemInformation ► ItemDefinition
Gets the item definition.
Declaration Syntax
C#
public ItemDefinition ItemDefinition { get; }
Value
The item definition.


NotifyChildAdded Method (childID)

NotifyChildAdded Method (childID)
Namespaces ► Sitecore.Data ► ItemInformation ► NotifyChildAdded(ID)
Notifies the child added.
Declaration Syntax
C#
public void NotifyChildAdded(
    ID childID
)
Parameters
childID (ID)
The child ID.


NotifyChildRemoved Method (childID)

NotifyChildRemoved Method (childID)
Namespaces ► Sitecore.Data ► ItemInformation ► NotifyChildRemoved(ID)
Notifies the child removed.
Declaration Syntax
C#
public void NotifyChildRemoved(
    ID childID
)
Parameters
childID (ID)
The child ID.


NotifySaved Method (item, changes)

NotifySaved Method (item, changes)
Namespaces ► Sitecore.Data ► ItemInformation ► NotifySaved(ItemInformation, ItemChanges)
Notifies the saved.
Declaration Syntax
C#
public void NotifySaved(
    ItemInformation item,
    ItemChanges changes
)
Parameters
item (ItemInformation)
The item.
changes (ItemChanges)
The changes.


NotifyVersionAdded Method (language, version)

NotifyVersionAdded Method (language, version)
Namespaces ► Sitecore.Data ► ItemInformation ► NotifyVersionAdded(Language, Version)
Notifies the version added.
Declaration Syntax
C#
public void NotifyVersionAdded(
    Language language,
    Version version
)
Parameters
language (Language)
The language.
version (Version)
The version.


NotifyVersionRemoved Method (language, version)

NotifyVersionRemoved Method (language, version)
Namespaces ► Sitecore.Data ► ItemInformation ► NotifyVersionRemoved(Language, Version)
Notifies the version removed.
Declaration Syntax
C#
public void NotifyVersionRemoved(
    Language language,
    Version version
)
Parameters
language (Language)
The language.
version (Version)
The version.


NotifyVersionsRemoved Method (language)

NotifyVersionsRemoved Method (language)
Namespaces ► Sitecore.Data ► ItemInformation ► NotifyVersionsRemoved(Language)
Notifies the versions removed.
Declaration Syntax
C#
public void NotifyVersionsRemoved(
    Language language
)
Parameters
language (Language)
The language.


ParentID Property

ParentID Property
Namespaces ► Sitecore.Data ► ItemInformation ► ParentID
Gets or sets the parent ID.
Declaration Syntax
C#
public ID ParentID { get; set; }
Value
The parent ID.


ItemPath Class

ItemPath Class
Namespaces ► Sitecore.Data ► ItemPath
Contains utility properties and function that describe the path of an item.
Declaration Syntax
C#
public class ItemPath
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemPath(Item) | Creates a new ItemPath instance.
 | ContentPath | Gets the content path.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullPath | Gets the full path of the item.
 | GetFriendlyUrl()()() | Obsolete. Gets the friendly URL.
 | GetFriendlyUrl(String) | Obsolete. Gets the friendly URL.
 | GetFriendlyUrl(SiteContext) | Obsolete. Gets the friendly URL.
 | GetFriendlyUrl(SiteContext, Boolean) | Obsolete. Gets the friendly URL.
 | GetFriendlyUrl(String, String) | Obsolete. Gets the friendly URL.
 | GetFriendlyUrl(String, String, Boolean) | Obsolete. Gets the friendly URL.
 | GetFriendlyUrl(Boolean) | Obsolete. Gets the friendly URL.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the current item.
 | GetItem(Database) | Gets the current item.
 | GetPath(ItemPathType) | Gets the path of the item.
 | GetPath(String, String, ItemPathType) | Get item path
 | GetSubItem(String) | Gets the sub item with a specified path.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAncestorOf(Item) | Determines whether an item is an ancestor of the current item.
 | IsContentItem | Gets a value indicating whether this item is a descendant of the /sitecore/content item.
 | IsDescendantOf(Item) | Determines whether the current item is a descendant of another item.
 | IsFullyQualified | Gets a value indicating whether this item has a root that is either "/{11111111-1111-1111-1111-111111111111}" or "/sitecore".
 | IsMasterPart | Gets a value indicating whether this instance is a master.
 | IsMediaItem | Gets a value indicating whether this item is a descendant of the /sitecore/media library item.
 | Item | Gets the item.
 | LongID | Gets the long ID.
 | Map(String, String) | Maps a path to another path.
 | MediaPath | Gets the media path.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentPath | Gets the path of the parent item.
 | Path | Gets the path.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemPath


ItemPath Constructor (item)

ItemPath Constructor (item)
Namespaces ► Sitecore.Data ► ItemPath ► ItemPath(Item)
Creates a new ItemPath instance.
Declaration Syntax
C#
public ItemPath(
    Item item
)
Parameters
item (Item)
Item.


ContentPath Property

ContentPath Property
Namespaces ► Sitecore.Data ► ItemPath ► ContentPath
Gets the content path.
Declaration Syntax
C#
public string ContentPath { get; }
Value
The content path.
Remarks
If the item is a descendant of /sitecore/content the path relative to /sitecore/content is returned with a slash '/' prepended. If not, the absolute path is returned.
Examples
Item item = Sitecore.Context.Database.Items["/sitecore/content/Home/News"]; string s = item.Paths.Path; // /Home/News


FullPath Property

FullPath Property
Namespaces ► Sitecore.Data ► ItemPath ► FullPath
Gets the full path of the item.
Declaration Syntax
C#
public string FullPath { get; }
Value
The full path.


GetFriendlyUrl Method

GetFriendlyUrl Method
Namespaces ► Sitecore.Data ► ItemPath ► GetFriendlyUrl()()()
Members
Icon | Member | Description
 | GetFriendlyUrl()()() | Obsolete. Gets the friendly URL.
 | GetFriendlyUrl(String) | Obsolete. Gets the friendly URL.
 | GetFriendlyUrl(SiteContext) | Obsolete. Gets the friendly URL.
 | GetFriendlyUrl(SiteContext, Boolean) | Obsolete. Gets the friendly URL.
 | GetFriendlyUrl(String, String) | Obsolete. Gets the friendly URL.
 | GetFriendlyUrl(String, String, Boolean) | Obsolete. Gets the friendly URL.
 | GetFriendlyUrl(Boolean) | Obsolete. Gets the friendly URL.


GetFriendlyUrl Method

GetFriendlyUrl Method
Namespaces ► Sitecore.Data ► ItemPath ► GetFriendlyUrl()()()
Gets the friendly URL.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public string GetFriendlyUrl()
Return Value
The friendly URL.


GetFriendlyUrl Method (site)

GetFriendlyUrl Method (site)
Namespaces ► Sitecore.Data ► ItemPath ► GetFriendlyUrl(SiteContext)
Gets the friendly URL.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public string GetFriendlyUrl(
    SiteContext site
)
Parameters
site (SiteContext)
The site.
Return Value
The friendly URL.


GetFriendlyUrl Method (site, useDisplayName)

GetFriendlyUrl Method (site, useDisplayName)
Namespaces ► Sitecore.Data ► ItemPath ► GetFriendlyUrl(SiteContext, Boolean)
Gets the friendly URL.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public string GetFriendlyUrl(
    SiteContext site,
    bool useDisplayName
)
Parameters
site (SiteContext)
The site.
useDisplayName (Boolean)
if set to true [use display name].
Return Value
The friendly URL.


GetFriendlyUrl Method (shorten)

GetFriendlyUrl Method (shorten)
Namespaces ► Sitecore.Data ► ItemPath ► GetFriendlyUrl(Boolean)
Gets the friendly URL.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public string GetFriendlyUrl(
    bool shorten
)
Parameters
shorten (Boolean)
Shorten path.
Return Value
The friendly URL.


GetFriendlyUrl Method (siteName)

GetFriendlyUrl Method (siteName)
Namespaces ► Sitecore.Data ► ItemPath ► GetFriendlyUrl(String)
Gets the friendly URL.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public string GetFriendlyUrl(
    string siteName
)
Parameters
siteName (String)
Name of the site.
Return Value
The friendly URL.


GetFriendlyUrl Method (startPath, virtualFolder)

GetFriendlyUrl Method (startPath, virtualFolder)
Namespaces ► Sitecore.Data ► ItemPath ► GetFriendlyUrl(String, String)
Gets the friendly URL.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public string GetFriendlyUrl(
    string startPath,
    string virtualFolder
)
Parameters
startPath (String)
The start path.
virtualFolder (String)
The virtual folder.
Return Value
The friendly URL.


GetFriendlyUrl Method (startPath, virtualFolder, useDisplayName)

GetFriendlyUrl Method (startPath, virtualFolder, useDisplayName)
Namespaces ► Sitecore.Data ► ItemPath ► GetFriendlyUrl(String, String, Boolean)
Gets the friendly URL.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public string GetFriendlyUrl(
    string startPath,
    string virtualFolder,
    bool useDisplayName
)
Parameters
startPath (String)
The start path.
virtualFolder (String)
The virtual folder.
useDisplayName (Boolean)
if set to true [use display name].
Return Value
The friendly URL.


GetItem Method

GetItem Method
Namespaces ► Sitecore.Data ► ItemPath ► GetItem()()()
Members
Icon | Member | Description
 | GetItem()()() | Gets the current item.
 | GetItem(Database) | Gets the current item.


GetItem Method

GetItem Method
Namespaces ► Sitecore.Data ► ItemPath ► GetItem()()()
Gets the current item.
Declaration Syntax
C#
public Item GetItem()
Return Value
The item.


GetItem Method (database)

GetItem Method (database)
Namespaces ► Sitecore.Data ► ItemPath ► GetItem(Database)
Gets the current item.
Declaration Syntax
C#
public Item GetItem(
    Database database
)
Parameters
database (Database)
Database.
Return Value
The item.


GetPath Method

GetPath Method
Namespaces ► Sitecore.Data ► ItemPath ► GetPath()()()
Members
Icon | Member | Description
 | GetPath(ItemPathType) | Gets the path of the item.
 | GetPath(String, String, ItemPathType) | Get item path


GetPath Method (type)

GetPath Method (type)
Namespaces ► Sitecore.Data ► ItemPath ► GetPath(ItemPathType)
Gets the path of the item.
Declaration Syntax
C#
public string GetPath(
    ItemPathType type
)
Parameters
type (ItemPathType)
The type of path to return.
Return Value


GetPath Method (from, separator, type)

GetPath Method (from, separator, type)
Namespaces ► Sitecore.Data ► ItemPath ► GetPath(String, String, ItemPathType)
Get item path
Declaration Syntax
C#
public string GetPath(
    string from,
    string separator,
    ItemPathType type
)
Parameters
from (String)
Base path that will not be included in the result
separator (String)
Path separator
type (ItemPathType)
Type of the elements in the path. Can be: id, key or name
Return Value
Sitecore path of item (excluding from)


GetSubItem Method (path)

GetSubItem Method (path)
Namespaces ► Sitecore.Data ► ItemPath ► GetSubItem(String)
Gets the sub item with a specified path.
Declaration Syntax
C#
public Item GetSubItem(
    string path
)
Parameters
path (String)
Path.
Return Value
The sub item.


IsAncestorOf Method (item)

IsAncestorOf Method (item)
Namespaces ► Sitecore.Data ► ItemPath ► IsAncestorOf(Item)
Determines whether an item is an ancestor of the current item.
Declaration Syntax
C#
public bool IsAncestorOf(
    Item item
)
Parameters
item (Item)
Item.
Return Value
true if an item is an ancestor of the current item; otherwise, false.


IsContentItem Property

IsContentItem Property
Namespaces ► Sitecore.Data ► ItemPath ► IsContentItem
Gets a value indicating whether this item is a descendant of the /sitecore/content item.
Declaration Syntax
C#
public bool IsContentItem { get; }
Value
true if this item is a descendant of the /sitecore/content item; otherwise, false.


IsDescendantOf Method (item)

IsDescendantOf Method (item)
Namespaces ► Sitecore.Data ► ItemPath ► IsDescendantOf(Item)
Determines whether the current item is a descendant of another item.
Declaration Syntax
C#
public bool IsDescendantOf(
    Item item
)
Parameters
item (Item)
Item.
Return Value
true if the current item is a descendant of the other item; otherwise, false.


IsFullyQualified Property

IsFullyQualified Property
Namespaces ► Sitecore.Data ► ItemPath ► IsFullyQualified
Gets a value indicating whether this item has a root that is either "/{11111111-1111-1111-1111-111111111111}" or "/sitecore".
Declaration Syntax
C#
public bool IsFullyQualified { get; }
Value
true if this item has a root that is either "/{11111111-1111-1111-1111-111111111111}" or "/sitecore"; otherwise, false.


IsMasterPart Property

IsMasterPart Property
Namespaces ► Sitecore.Data ► ItemPath ► IsMasterPart
Gets a value indicating whether this instance is a master.
Declaration Syntax
C#
public bool IsMasterPart { get; }
Value
true if this instance is a master; otherwise, false.


IsMediaItem Property

IsMediaItem Property
Namespaces ► Sitecore.Data ► ItemPath ► IsMediaItem
Gets a value indicating whether this item is a descendant of the /sitecore/media library item.
Declaration Syntax
C#
public bool IsMediaItem { get; }
Value
true if this item is a descendant of the /sitecore/media library; otherwise, false.


Item Property

Item Property
Namespaces ► Sitecore.Data ► ItemPath ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


LongID Property

LongID Property
Namespaces ► Sitecore.Data ► ItemPath ► LongID
Gets the long ID.
Declaration Syntax
C#
public string LongID { get; }
Value
The long ID.


Map Method (from, to)

Map Method (from, to)
Namespaces ► Sitecore.Data ► ItemPath ► Map(String, String)
Maps a path to another path.
Declaration Syntax
C#
public string Map(
    string from,
    string to
)
Parameters
from (String)
From.
to (String)
To.
Return Value
The map.


MediaPath Property

MediaPath Property
Namespaces ► Sitecore.Data ► ItemPath ► MediaPath
Gets the media path.
Declaration Syntax
C#
public string MediaPath { get; }
Value
The media path.
Remarks
If the item is a descendant of /sitecore/media library the path relative to /sitecore/media library is returned with a slash '/' prepended. If not, the absolute path is returned.
Examples
Item item = Sitecore.Context.Database.Items["/sitecore/media library/Buildings/House"]; string s = item.Paths.Path; // /Buildings/House


ParentPath Property

ParentPath Property
Namespaces ► Sitecore.Data ► ItemPath ► ParentPath
Gets the path of the parent item.
Declaration Syntax
C#
public string ParentPath { get; }
Value
The parent path.


Path Property

Path Property
Namespaces ► Sitecore.Data ► ItemPath ► Path
Gets the path.
Declaration Syntax
C#
public string Path { get; }
Value
The path.


ItemPointer Class

ItemPointer Class
Namespaces ► Sitecore.Data ► ItemPointer
Points to an item.
Declaration Syntax
C#
public class ItemPointer
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemPointer(ID, Language, Version) | Creates a new ItemPointer instance.
 | ItemPointer(Item) | Creates a new ItemPointer instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemID | Gets the item ID.
 | Language | Gets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Parses the specified value.
 | ToString()()() | Converts the point to a string representation. (Overrides Object.ToString()()().)
 | Version | Gets the version.
Remarks
Points to an item without the ambiguities of ItemUri.
Inheritance Hierarchy
Object
ItemPointer


ItemPointer Constructor

ItemPointer Constructor
Namespaces ► Sitecore.Data ► ItemPointer ► ItemPointer()()()
Members
Icon | Member | Description
 | ItemPointer(ID, Language, Version) | Creates a new ItemPointer instance.
 | ItemPointer(Item) | Creates a new ItemPointer instance.


ItemPointer Constructor (itemID, language, version)

ItemPointer Constructor (itemID, language, version)
Namespaces ► Sitecore.Data ► ItemPointer ► ItemPointer(ID, Language, Version)
Creates a new ItemPointer instance.
Declaration Syntax
C#
public ItemPointer(
    ID itemID,
    Language language,
    Version version
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
version (Version)
Version.


ItemPointer Constructor (item)

ItemPointer Constructor (item)
Namespaces ► Sitecore.Data ► ItemPointer ► ItemPointer(Item)
Creates a new ItemPointer instance.
Declaration Syntax
C#
public ItemPointer(
    Item item
)
Parameters
item (Item)
Item.


ItemID Property

ItemID Property
Namespaces ► Sitecore.Data ► ItemPointer ► ItemID
Gets the item ID.
Declaration Syntax
C#
public ID ItemID { get; }
Value
The item ID.


Language Property

Language Property
Namespaces ► Sitecore.Data ► ItemPointer ► Language
Gets the language.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


Parse Method (value)

Parse Method (value)
Namespaces ► Sitecore.Data ► ItemPointer ► Parse(String)
Parses the specified value.
Declaration Syntax
C#
public static ItemPointer Parse(
    string value
)
Parameters
value (String)
Value.
Return Value
The parse.


ToString Method

ToString Method
Namespaces ► Sitecore.Data ► ItemPointer ► ToString()()()
Converts the point to a string representation.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Version Property

Version Property
Namespaces ► Sitecore.Data ► ItemPointer ► Version
Gets the version.
Declaration Syntax
C#
public Version Version { get; }
Value
The version.


ItemRecords Class

ItemRecords Class
Namespaces ► Sitecore.Data ► ItemRecords
Provides access to the items in a database.
Declaration Syntax
C#
public class ItemRecords : Database..::.DataRecords
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemRecords(Database) | Creates a new ItemRecords instance.
 | BasePath | Gets the base path. (Inherited from Database..::.DataRecords.)
 | Database | Gets the database. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::.DataRecords.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::.DataRecords.)
 | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::.DataRecords.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(ID) | Gets an item.
 | GetItem(ID, Language) | Gets an item.
 | GetItem(ID, Language, Version) | Gets an item.
 | GetItem(String) | Gets an item.
 | GetItem(String, Language) | Gets an item.
 | GetItem(String, Language, Version) | Gets an item.
 | GetItem(DataUri) | Gets an item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniquePath(String) | Gets a unique path of an item in the database. (Inherited from Database..::.DataRecords.)
 | Item[([(ID])]) | Gets the Item with the specified item ID.
 | Item[([(ID, Language])]) | Gets the Item with the specified item ID.
 | Item[([(ID, Language, Version])]) | Gets the Item with the specified item ID.
 | Item[([(String])]) | Gets the Item with the specified item path.
 | Item[([(String, Language])]) | Gets the Item with the specified item path.
 | Item[([(String, Language, Version])]) | Gets the Item with the specified item path.
 | Item[([(ItemPointer])]) | Gets the Item with the specified pointer.
 | Item[([(DataUri])]) | Gets the Item with the specified URI.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Normally items are accessed through the GetItem(ID) property.
Inheritance Hierarchy
Object
 | Database..::.DataRecords
 |  | ItemRecords


ItemRecords Constructor (database)

ItemRecords Constructor (database)
Namespaces ► Sitecore.Data ► ItemRecords ► ItemRecords(Database)
Creates a new ItemRecords instance.
Declaration Syntax
C#
public ItemRecords(
    Database database
)
Parameters
database (Database)
Database.


GetItem Method

GetItem Method
Namespaces ► Sitecore.Data ► ItemRecords ► GetItem()()()
Members
Icon | Member | Description
 | GetItem(ID) | Gets an item.
 | GetItem(ID, Language) | Gets an item.
 | GetItem(ID, Language, Version) | Gets an item.
 | GetItem(String) | Gets an item.
 | GetItem(String, Language) | Gets an item.
 | GetItem(String, Language, Version) | Gets an item.
 | GetItem(DataUri) | Gets an item.


GetItem Method (uri)

GetItem Method (uri)
Namespaces ► Sitecore.Data ► ItemRecords ► GetItem(DataUri)
Gets an item.
Declaration Syntax
C#
public Item GetItem(
    DataUri uri
)
Parameters
uri (DataUri)
URI.
Return Value
The item.


GetItem Method (itemID)

GetItem Method (itemID)
Namespaces ► Sitecore.Data ► ItemRecords ► GetItem(ID)
Gets an item.
Declaration Syntax
C#
public Item GetItem(
    ID itemID
)
Parameters
itemID (ID)
Item ID.
Return Value
The item.


GetItem Method (itemID, language)

GetItem Method (itemID, language)
Namespaces ► Sitecore.Data ► ItemRecords ► GetItem(ID, Language)
Gets an item.
Declaration Syntax
C#
public Item GetItem(
    ID itemID,
    Language language
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
Return Value
The item.


GetItem Method (itemID, language, version)

GetItem Method (itemID, language, version)
Namespaces ► Sitecore.Data ► ItemRecords ► GetItem(ID, Language, Version)
Gets an item.
Declaration Syntax
C#
public Item GetItem(
    ID itemID,
    Language language,
    Version version
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
version (Version)
Version.
Return Value
The item.


GetItem Method (itemPath)

GetItem Method (itemPath)
Namespaces ► Sitecore.Data ► ItemRecords ► GetItem(String)
Gets an item.
Declaration Syntax
C#
public Item GetItem(
    string itemPath
)
Parameters
itemPath (String)
Item path.
Return Value
The item.


GetItem Method (itemPath, language)

GetItem Method (itemPath, language)
Namespaces ► Sitecore.Data ► ItemRecords ► GetItem(String, Language)
Gets an item.
Declaration Syntax
C#
public Item GetItem(
    string itemPath,
    Language language
)
Parameters
itemPath (String)
Item path.
language (Language)
Language.
Return Value
The item.


GetItem Method (itemPath, language, version)

GetItem Method (itemPath, language, version)
Namespaces ► Sitecore.Data ► ItemRecords ► GetItem(String, Language, Version)
Gets an item.
Declaration Syntax
C#
public Item GetItem(
    string itemPath,
    Language language,
    Version version
)
Parameters
itemPath (String)
Item path.
language (Language)
Language.
version (Version)
Version.
Return Value
The item.


Item Property

Item Property
Namespaces ► Sitecore.Data ► ItemRecords ► Item
Members
Icon | Member | Description
 | Item[([(ID])]) | Gets the Item with the specified item ID.
 | Item[([(ID, Language])]) | Gets the Item with the specified item ID.
 | Item[([(ID, Language, Version])]) | Gets the Item with the specified item ID.
 | Item[([(String])]) | Gets the Item with the specified item path.
 | Item[([(String, Language])]) | Gets the Item with the specified item path.
 | Item[([(String, Language, Version])]) | Gets the Item with the specified item path.
 | Item[([(ItemPointer])]) | Gets the Item with the specified pointer.
 | Item[([(DataUri])]) | Gets the Item with the specified URI.


Item Property (uri)

Item Property (uri)
Namespaces ► Sitecore.Data ► ItemRecords ► Item[([(DataUri])])
Gets the Item with the specified URI.
Declaration Syntax
C#
public Item this[
    DataUri uri
] { get; }
Parameters
uri (DataUri)


Item Property (itemID)

Item Property (itemID)
Namespaces ► Sitecore.Data ► ItemRecords ► Item[([(ID])])
Gets the Item with the specified item ID.
Declaration Syntax
C#
public Item this[
    ID itemID
] { get; }
Parameters
itemID (ID)


Item Property (itemID, language)

Item Property (itemID, language)
Namespaces ► Sitecore.Data ► ItemRecords ► Item[([(ID, Language])])
Gets the Item with the specified item ID.
Declaration Syntax
C#
public Item this[
    ID itemID,
    Language language
] { get; }
Parameters
itemID (ID)
language (Language)


Item Property (itemID, language, version)

Item Property (itemID, language, version)
Namespaces ► Sitecore.Data ► ItemRecords ► Item[([(ID, Language, Version])])
Gets the Item with the specified item ID.
Declaration Syntax
C#
public Item this[
    ID itemID,
    Language language,
    Version version
] { get; }
Parameters
itemID (ID)
language (Language)
version (Version)


Item Property (pointer)

Item Property (pointer)
Namespaces ► Sitecore.Data ► ItemRecords ► Item[([(ItemPointer])])
Gets the Item with the specified pointer.
Declaration Syntax
C#
public Item this[
    ItemPointer pointer
] { get; }
Parameters
pointer (ItemPointer)


Item Property (itemPath)

Item Property (itemPath)
Namespaces ► Sitecore.Data ► ItemRecords ► Item[([(String])])
Gets the Item with the specified item path.
Declaration Syntax
C#
public Item this[
    string itemPath
] { get; }
Parameters
itemPath (String)


Item Property (itemPath, language)

Item Property (itemPath, language)
Namespaces ► Sitecore.Data ► ItemRecords ► Item[([(String, Language])])
Gets the Item with the specified item path.
Declaration Syntax
C#
public Item this[
    string itemPath,
    Language language
] { get; }
Parameters
itemPath (String)
language (Language)


Item Property (itemPath, language, version)

Item Property (itemPath, language, version)
Namespaces ► Sitecore.Data ► ItemRecords ► Item[([(String, Language, Version])])
Gets the Item with the specified item path.
Declaration Syntax
C#
public Item this[
    string itemPath,
    Language language,
    Version version
] { get; }
Parameters
itemPath (String)
language (Language)
version (Version)


ItemUri Class

ItemUri Class
Namespaces ► Sitecore.Data ► ItemUri
Provides a moniker to an item in a database.
Declaration Syntax
C#
[SerializableAttribute]
public class ItemUri : ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemUri(ItemUri) | Creates a new ItemUri instance.
 | ItemUri(DataUri, Database) | Creates a new ItemUri instance.
 | ItemUri(String) | Creates a new ItemUri instance.
 | ItemUri(ID, Database) | Creates a new ItemUri instance.
 | ItemUri(ID, Language, Database) | Creates a new ItemUri instance.
 | ItemUri(ID, Language, Version, Database) | Creates a new ItemUri instance.
 | ItemUri(ID, Language, Version, String) | Creates a new ItemUri instance.
 | ItemUri(String, Database) | Creates a new ItemUri instance.
 | ItemUri(String, Language, Database) | Creates a new ItemUri instance.
 | ItemUri(String, Language, Version, Database) | Creates a new ItemUri instance.
 | ItemUri(String, Language, Version, String) | Creates a new ItemUri instance.
 | ItemUri(ID, String, Language, Version, String) | Creates a new ItemUri instance.
 | ItemUri(Item) | Creates a new ItemUri instance.
 | ItemUri(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemUri class.
 | AddToUrlString(UrlString) | Adds the Uri to the specified Url string.
 | Clone()()() | Clones this instance.
 | DatabaseName | Gets the name of the database.
 | Equality(ItemUri, ItemUri) | Determines if two Uris are equal.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object.GetHashCode()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetPathOrId()()() | Gets the item path.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Inequality(ItemUri, ItemUri) | Determines if two Uris are unequal.
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | IsItemUri(String) | Checks if a path is an item URI.
 | ItemID | Gets the item ID.
 | Language | Gets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Converts the string into an ItemUri.
 | ParseQueryString()()() | Parses the query string.
 | ParseQueryString(Database) | Parses the query string.
 | Path | Gets the path.
 | ToDataUri()()() | Converts the ItemUri to a DataUri.
 | ToString()()() | Returns a string representing the URI. (Overrides Object.ToString()()().)
 | ToString(ItemUriFormat) | Returns a string representing the URI.
 | ToUrlString(String) | Converts the Uri to an Url.
 | Version | Gets the version.
Remarks
An ItemUri is immutable and cannot be changed once created. To build an ItemUri dynamically use ItemUriBuilder.
Inheritance Hierarchy
Object
ItemUri


ItemUri Constructor

ItemUri Constructor
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri()()()
Members
Icon | Member | Description
 | ItemUri(ItemUri) | Creates a new ItemUri instance.
 | ItemUri(DataUri, Database) | Creates a new ItemUri instance.
 | ItemUri(String) | Creates a new ItemUri instance.
 | ItemUri(ID, Database) | Creates a new ItemUri instance.
 | ItemUri(ID, Language, Database) | Creates a new ItemUri instance.
 | ItemUri(ID, Language, Version, Database) | Creates a new ItemUri instance.
 | ItemUri(ID, Language, Version, String) | Creates a new ItemUri instance.
 | ItemUri(String, Database) | Creates a new ItemUri instance.
 | ItemUri(String, Language, Database) | Creates a new ItemUri instance.
 | ItemUri(String, Language, Version, Database) | Creates a new ItemUri instance.
 | ItemUri(String, Language, Version, String) | Creates a new ItemUri instance.
 | ItemUri(ID, String, Language, Version, String) | Creates a new ItemUri instance.
 | ItemUri(Item) | Creates a new ItemUri instance.
 | ItemUri(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemUri class.


ItemUri Constructor (dataUri, database)

ItemUri Constructor (dataUri, database)
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri(DataUri, Database)
Creates a new ItemUri instance.
Declaration Syntax
C#
public ItemUri(
    DataUri dataUri,
    Database database
)
Parameters
dataUri (DataUri)
Data URI.
database (Database)
Database.


ItemUri Constructor (itemID, database)

ItemUri Constructor (itemID, database)
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri(ID, Database)
Creates a new ItemUri instance.
Declaration Syntax
C#
public ItemUri(
    ID itemID,
    Database database
)
Parameters
itemID (ID)
Item ID.
database (Database)
Database.


ItemUri Constructor (itemID, language, database)

ItemUri Constructor (itemID, language, database)
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri(ID, Language, Database)
Creates a new ItemUri instance.
Declaration Syntax
C#
public ItemUri(
    ID itemID,
    Language language,
    Database database
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
database (Database)
Database.


ItemUri Constructor (itemID, language, version, database)

ItemUri Constructor (itemID, language, version, database)
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri(ID, Language, Version, Database)
Creates a new ItemUri instance.
Declaration Syntax
C#
public ItemUri(
    ID itemID,
    Language language,
    Version version,
    Database database
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
version (Version)
Version.
database (Database)
Database.


ItemUri Constructor (itemID, language, version, databaseName)

ItemUri Constructor (itemID, language, version, databaseName)
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri(ID, Language, Version, String)
Creates a new ItemUri instance.
Declaration Syntax
C#
public ItemUri(
    ID itemID,
    Language language,
    Version version,
    string databaseName
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
version (Version)
Version.
databaseName (String)
Name of the database.


ItemUri Constructor (itemID, path, language, version, databaseName)

ItemUri Constructor (itemID, path, language, version, databaseName)
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri(ID, String, Language, Version, String)
Creates a new ItemUri instance.
Declaration Syntax
C#
public ItemUri(
    ID itemID,
    string path,
    Language language,
    Version version,
    string databaseName
)
Parameters
itemID (ID)
Item ID.
path (String)
Path.
language (Language)
Language.
version (Version)
Version.
databaseName (String)
Name of the database.


ItemUri Constructor (item)

ItemUri Constructor (item)
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri(Item)
Creates a new ItemUri instance.
Declaration Syntax
C#
public ItemUri(
    Item item
)
Parameters
item (Item)
The item.


ItemUri Constructor (uri)

ItemUri Constructor (uri)
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri(ItemUri)
Creates a new ItemUri instance.
Declaration Syntax
C#
public ItemUri(
    ItemUri uri
)
Parameters
uri (ItemUri)
URI.


ItemUri Constructor (info, context)

ItemUri Constructor (info, context)
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri(SerializationInfo, StreamingContext)
Initializes a new instance of the ItemUri class.
Declaration Syntax
C#
protected ItemUri(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


ItemUri Constructor (itemUri)

ItemUri Constructor (itemUri)
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri(String)
Creates a new ItemUri instance.
Declaration Syntax
C#
public ItemUri(
    string itemUri
)
Parameters
itemUri (String)
Item URI.


ItemUri Constructor (path, database)

ItemUri Constructor (path, database)
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri(String, Database)
Creates a new ItemUri instance.
Declaration Syntax
C#
public ItemUri(
    string path,
    Database database
)
Parameters
path (String)
Path.
database (Database)
Database.


ItemUri Constructor (path, language, database)

ItemUri Constructor (path, language, database)
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri(String, Language, Database)
Creates a new ItemUri instance.
Declaration Syntax
C#
public ItemUri(
    string path,
    Language language,
    Database database
)
Parameters
path (String)
Path.
language (Language)
Language.
database (Database)
Database.


ItemUri Constructor (path, language, version, database)

ItemUri Constructor (path, language, version, database)
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri(String, Language, Version, Database)
Creates a new ItemUri instance.
Declaration Syntax
C#
public ItemUri(
    string path,
    Language language,
    Version version,
    Database database
)
Parameters
path (String)
Path.
language (Language)
Language.
version (Version)
Version.
database (Database)
Database.


ItemUri Constructor (path, language, version, databaseName)

ItemUri Constructor (path, language, version, databaseName)
Namespaces ► Sitecore.Data ► ItemUri ► ItemUri(String, Language, Version, String)
Creates a new ItemUri instance.
Declaration Syntax
C#
public ItemUri(
    string path,
    Language language,
    Version version,
    string databaseName
)
Parameters
path (String)
Path.
language (Language)
Language.
version (Version)
Version.
databaseName (String)
Name of the database.


AddToUrlString Method (urlString)

AddToUrlString Method (urlString)
Namespaces ► Sitecore.Data ► ItemUri ► AddToUrlString(UrlString)
Adds the Uri to the specified Url string.
Declaration Syntax
C#
public void AddToUrlString(
    UrlString urlString
)
Parameters
urlString (UrlString)
The Url string.


Clone Method

Clone Method
Namespaces ► Sitecore.Data ► ItemUri ► Clone()()()
Clones this instance.
Declaration Syntax
C#
public Object Clone()
Return Value
A new object that is a copy of this instance.


DatabaseName Property

DatabaseName Property
Namespaces ► Sitecore.Data ► ItemUri ► DatabaseName
Gets the name of the database.
Declaration Syntax
C#
public string DatabaseName { get; }
Value
The name of the database.


Equality Operator

Equality Operator
Namespaces ► Sitecore.Data ► ItemUri ► Equality(ItemUri, ItemUri)
Determines if two Uris are equal.
Declaration Syntax
C#
public static bool operator ==(
    ItemUri uri1,
    ItemUri uri2
)
Parameters
uri1 (ItemUri)
The uri1.
uri2 (ItemUri)
The uri2.
Return Value
The operator ==.


Equals Method (obj)

Equals Method (obj)
Namespaces ► Sitecore.Data ► ItemUri ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C#
public override bool Equals(
    Object obj
)
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.


GetHashCode Method

GetHashCode Method
Namespaces ► Sitecore.Data ► ItemUri ► GetHashCode()()()
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
Declaration Syntax
C#
public override int GetHashCode()
Return Value
A hash code for the current Object.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Data ► ItemUri ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


GetPathOrId Method

GetPathOrId Method
Namespaces ► Sitecore.Data ► ItemUri ► GetPathOrId()()()
Gets the item path.
Declaration Syntax
C#
public string GetPathOrId()
Return Value
The item path.


Inequality Operator

Inequality Operator
Namespaces ► Sitecore.Data ► ItemUri ► Inequality(ItemUri, ItemUri)
Determines if two Uris are unequal.
Declaration Syntax
C#
public static bool operator !=(
    ItemUri uri1,
    ItemUri uri2
)
Parameters
uri1 (ItemUri)
The uri1.
uri2 (ItemUri)
The uri2.
Return Value
The operator !=.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Data ► ItemUri ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


IsItemUri Method (path)

IsItemUri Method (path)
Namespaces ► Sitecore.Data ► ItemUri ► IsItemUri(String)
Checks if a path is an item URI.
Declaration Syntax
C#
public static bool IsItemUri(
    string path
)
Parameters
path (String)
The path.
Return Value
true if the path is an item URI; false otherwise.


ItemID Property

ItemID Property
Namespaces ► Sitecore.Data ► ItemUri ► ItemID
Gets the item ID.
Declaration Syntax
C#
public ID ItemID { get; }
Value
The item ID.


Language Property

Language Property
Namespaces ► Sitecore.Data ► ItemUri ► Language
Gets the language.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


Parse Method (itemUri)

Parse Method (itemUri)
Namespaces ► Sitecore.Data ► ItemUri ► Parse(String)
Converts the string into an ItemUri.
Declaration Syntax
C#
public static ItemUri Parse(
    string itemUri
)
Parameters
itemUri (String)
Item URI.
Return Value
The parse.


ParseQueryString Method

ParseQueryString Method
Namespaces ► Sitecore.Data ► ItemUri ► ParseQueryString()()()
Members
Icon | Member | Description
 | ParseQueryString()()() | Parses the query string.
 | ParseQueryString(Database) | Parses the query string.


ParseQueryString Method

ParseQueryString Method
Namespaces ► Sitecore.Data ► ItemUri ► ParseQueryString()()()
Parses the query string.
Declaration Syntax
C#
public static ItemUri ParseQueryString()
Return Value
The query string.


ParseQueryString Method (database)

ParseQueryString Method (database)
Namespaces ► Sitecore.Data ► ItemUri ► ParseQueryString(Database)
Parses the query string.
Declaration Syntax
C#
public static ItemUri ParseQueryString(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The query string.


Path Property

Path Property
Namespaces ► Sitecore.Data ► ItemUri ► Path
Gets the path.
Declaration Syntax
C#
public string Path { get; }
Value
The path.


ToDataUri Method

ToDataUri Method
Namespaces ► Sitecore.Data ► ItemUri ► ToDataUri()()()
Converts the ItemUri to a DataUri.
Declaration Syntax
C#
public DataUri ToDataUri()
Return Value
The data URI.


ToString Method

ToString Method
Namespaces ► Sitecore.Data ► ItemUri ► ToString()()()
Members
Icon | Member | Description
 | ToString()()() | Returns a string representing the URI. (Overrides Object.ToString()()().)
 | ToString(ItemUriFormat) | Returns a string representing the URI.


ToString Method

ToString Method
Namespaces ► Sitecore.Data ► ItemUri ► ToString()()()
Returns a string representing the URI.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


ToString Method (format)

ToString Method (format)
Namespaces ► Sitecore.Data ► ItemUri ► ToString(ItemUriFormat)
Returns a string representing the URI.
Declaration Syntax
C#
public string ToString(
    ItemUriFormat format
)
Parameters
format (ItemUriFormat)
The format.
Return Value
A String that represents the current Object.


ToUrlString Method (path)

ToUrlString Method (path)
Namespaces ► Sitecore.Data ► ItemUri ► ToUrlString(String)
Converts the Uri to an Url.
Declaration Syntax
C#
public UrlString ToUrlString(
    string path
)
Parameters
path (String)
Return Value
The URL.


Version Property

Version Property
Namespaces ► Sitecore.Data ► ItemUri ► Version
Gets the version.
Declaration Syntax
C#
public Version Version { get; }
Value
The version.


ItemUriBuilder Class

ItemUriBuilder Class
Namespaces ► Sitecore.Data ► ItemUriBuilder
Builds an ItemUri.
Declaration Syntax
C#
public class ItemUriBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemUriBuilder(ItemUri) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(ID) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(ID, Language) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(ID, Language, Version) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(ID, Language, Version, Database) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(ID, Language, Version, String) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(String) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(String, Language) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(String, Language, Version) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(String, Database) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(String, Language, Version, String) | Creates a new ItemUriBuilder instance.
 | DatabaseName | Gets or sets the name of the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemID | Gets or sets the item ID.
 | ItemUri | Gets the item URI.
 | Language | Gets or sets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets or sets the path.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | Gets or sets the version.
Remarks
A ItemUri is immutable and cannot be changed once created. The ItemUriBuilder allows the URI to be built dynamically and then converted into a ItemUri.
Inheritance Hierarchy
Object
ItemUriBuilder


ItemUriBuilder Constructor

ItemUriBuilder Constructor
Namespaces ► Sitecore.Data ► ItemUriBuilder ► ItemUriBuilder()()()
Members
Icon | Member | Description
 | ItemUriBuilder(ItemUri) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(ID) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(ID, Language) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(ID, Language, Version) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(ID, Language, Version, Database) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(ID, Language, Version, String) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(String) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(String, Language) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(String, Language, Version) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(String, Database) | Creates a new ItemUriBuilder instance.
 | ItemUriBuilder(String, Language, Version, String) | Creates a new ItemUriBuilder instance.


ItemUriBuilder Constructor (itemID)

ItemUriBuilder Constructor (itemID)
Namespaces ► Sitecore.Data ► ItemUriBuilder ► ItemUriBuilder(ID)
Creates a new ItemUriBuilder instance.
Declaration Syntax
C#
public ItemUriBuilder(
    ID itemID
)
Parameters
itemID (ID)
Item ID.


ItemUriBuilder Constructor (itemID, language)

ItemUriBuilder Constructor (itemID, language)
Namespaces ► Sitecore.Data ► ItemUriBuilder ► ItemUriBuilder(ID, Language)
Creates a new ItemUriBuilder instance.
Declaration Syntax
C#
public ItemUriBuilder(
    ID itemID,
    Language language
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.


ItemUriBuilder Constructor (itemID, language, version)

ItemUriBuilder Constructor (itemID, language, version)
Namespaces ► Sitecore.Data ► ItemUriBuilder ► ItemUriBuilder(ID, Language, Version)
Creates a new ItemUriBuilder instance.
Declaration Syntax
C#
public ItemUriBuilder(
    ID itemID,
    Language language,
    Version version
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
version (Version)
Version.


ItemUriBuilder Constructor (itemID, language, version, database)

ItemUriBuilder Constructor (itemID, language, version, database)
Namespaces ► Sitecore.Data ► ItemUriBuilder ► ItemUriBuilder(ID, Language, Version, Database)
Creates a new ItemUriBuilder instance.
Declaration Syntax
C#
public ItemUriBuilder(
    ID itemID,
    Language language,
    Version version,
    Database database
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
version (Version)
Version.
database (Database)
Database.


ItemUriBuilder Constructor (itemID, language, version, databaseName)

ItemUriBuilder Constructor (itemID, language, version, databaseName)
Namespaces ► Sitecore.Data ► ItemUriBuilder ► ItemUriBuilder(ID, Language, Version, String)
Creates a new ItemUriBuilder instance.
Declaration Syntax
C#
public ItemUriBuilder(
    ID itemID,
    Language language,
    Version version,
    string databaseName
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
version (Version)
Version.
databaseName (String)
Name of the database.


ItemUriBuilder Constructor (uri)

ItemUriBuilder Constructor (uri)
Namespaces ► Sitecore.Data ► ItemUriBuilder ► ItemUriBuilder(ItemUri)
Creates a new ItemUriBuilder instance.
Declaration Syntax
C#
public ItemUriBuilder(
    ItemUri uri
)
Parameters
uri (ItemUri)
URI.


ItemUriBuilder Constructor (path)

ItemUriBuilder Constructor (path)
Namespaces ► Sitecore.Data ► ItemUriBuilder ► ItemUriBuilder(String)
Creates a new ItemUriBuilder instance.
Declaration Syntax
C#
public ItemUriBuilder(
    string path
)
Parameters
path (String)
Path.


ItemUriBuilder Constructor (path, database)

ItemUriBuilder Constructor (path, database)
Namespaces ► Sitecore.Data ► ItemUriBuilder ► ItemUriBuilder(String, Database)
Creates a new ItemUriBuilder instance.
Declaration Syntax
C#
public ItemUriBuilder(
    string path,
    Database database
)
Parameters
path (String)
Path.
database (Database)
Database.


ItemUriBuilder Constructor (path, language)

ItemUriBuilder Constructor (path, language)
Namespaces ► Sitecore.Data ► ItemUriBuilder ► ItemUriBuilder(String, Language)
Creates a new ItemUriBuilder instance.
Declaration Syntax
C#
public ItemUriBuilder(
    string path,
    Language language
)
Parameters
path (String)
Path.
language (Language)
Language.


ItemUriBuilder Constructor (path, language, version)

ItemUriBuilder Constructor (path, language, version)
Namespaces ► Sitecore.Data ► ItemUriBuilder ► ItemUriBuilder(String, Language, Version)
Creates a new ItemUriBuilder instance.
Declaration Syntax
C#
public ItemUriBuilder(
    string path,
    Language language,
    Version version
)
Parameters
path (String)
Path.
language (Language)
Language.
version (Version)
Version.


ItemUriBuilder Constructor (path, language, version, databaseName)

ItemUriBuilder Constructor (path, language, version, databaseName)
Namespaces ► Sitecore.Data ► ItemUriBuilder ► ItemUriBuilder(String, Language, Version, String)
Creates a new ItemUriBuilder instance.
Declaration Syntax
C#
public ItemUriBuilder(
    string path,
    Language language,
    Version version,
    string databaseName
)
Parameters
path (String)
Path.
language (Language)
Language.
version (Version)
Version.
databaseName (String)
Name of the database.


DatabaseName Property

DatabaseName Property
Namespaces ► Sitecore.Data ► ItemUriBuilder ► DatabaseName
Gets or sets the name of the database.
Declaration Syntax
C#
public string DatabaseName { get; set; }
Value
The name of the database.


ItemID Property

ItemID Property
Namespaces ► Sitecore.Data ► ItemUriBuilder ► ItemID
Gets or sets the item ID.
Declaration Syntax
C#
public ID ItemID { get; set; }
Value
The item ID.


ItemUri Property

ItemUri Property
Namespaces ► Sitecore.Data ► ItemUriBuilder ► ItemUri
Gets the item URI.
Declaration Syntax
C#
public ItemUri ItemUri { get; }
Value
The item URI.


Language Property

Language Property
Namespaces ► Sitecore.Data ► ItemUriBuilder ► Language
Gets or sets the language.
Declaration Syntax
C#
public Language Language { get; set; }
Value
The language.


Path Property

Path Property
Namespaces ► Sitecore.Data ► ItemUriBuilder ► Path
Gets or sets the path.
Declaration Syntax
C#
public string Path { get; set; }
Value
The path.


Version Property

Version Property
Namespaces ► Sitecore.Data ► ItemUriBuilder ► Version
Gets or sets the version.
Declaration Syntax
C#
public Version Version { get; set; }
Value
The version.


ItemUriFormat Enumeration

ItemUriFormat Enumeration
Namespaces ► Sitecore.Data ► ItemUriFormat
Defines how the string representation of an ItemURI is formatted.
Declaration Syntax
C#
public enum ItemUriFormat
Members
Member | Description
Uri | Uri.
QueryString | QueryString.
Message | Message.


LayoutRecords Class

LayoutRecords Class
Namespaces ► Sitecore.Data ► LayoutRecords
Represents the layout that are defined in a specified database.
Declaration Syntax
C#
public class LayoutRecords : Database..::.DataRecords
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayoutRecords(Database) | Creates a new LayoutRecords instance.
 | BasePath | Gets the base path. (Inherited from Database..::.DataRecords.)
 | Database | Gets the database. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::.DataRecords.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::.DataRecords.)
 | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::.DataRecords.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniquePath(String) | Gets a unique path of an item in the database. (Inherited from Database..::.DataRecords.)
 | Item[([(ID])]) | Gets the LayoutItem with the specified item ID.
 | Item[([(ID, Language])]) | Gets the LayoutItem with the specified item ID.
 | Item[([(ID, Language, Version])]) | Gets the LayoutItem with the specified item ID.
 | Item[([(String])]) | Gets the LayoutItem with the specified item path.
 | Item[([(String, Language])]) | Gets the LayoutItem with the specified item path.
 | Item[([(String, Language, Version])]) | Gets the LayoutItem with the specified item path.
 | Item[([(DataUri])]) | Gets the LayoutItem with the specified URI.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

Layouts are configured in /sitecore/layouts/Layout/Layouts.

The devices are normally access through the Layouts property.

Inheritance Hierarchy
Object
 | Database..::.DataRecords
 |  | LayoutRecords


LayoutRecords Constructor (database)

LayoutRecords Constructor (database)
Namespaces ► Sitecore.Data ► LayoutRecords ► LayoutRecords(Database)
Creates a new LayoutRecords instance.
Declaration Syntax
C#
public LayoutRecords(
    Database database
)
Parameters
database (Database)
Database.


Item Property

Item Property
Namespaces ► Sitecore.Data ► LayoutRecords ► Item
Members
Icon | Member | Description
 | Item[([(ID])]) | Gets the LayoutItem with the specified item ID.
 | Item[([(ID, Language])]) | Gets the LayoutItem with the specified item ID.
 | Item[([(ID, Language, Version])]) | Gets the LayoutItem with the specified item ID.
 | Item[([(String])]) | Gets the LayoutItem with the specified item path.
 | Item[([(String, Language])]) | Gets the LayoutItem with the specified item path.
 | Item[([(String, Language, Version])]) | Gets the LayoutItem with the specified item path.
 | Item[([(DataUri])]) | Gets the LayoutItem with the specified URI.


Item Property (uri)

Item Property (uri)
Namespaces ► Sitecore.Data ► LayoutRecords ► Item[([(DataUri])])
Gets the LayoutItem with the specified URI.
Declaration Syntax
C#
public LayoutItem this[
    DataUri uri
] { get; }
Parameters
uri (DataUri)


Item Property (itemID)

Item Property (itemID)
Namespaces ► Sitecore.Data ► LayoutRecords ► Item[([(ID])])
Gets the LayoutItem with the specified item ID.
Declaration Syntax
C#
public LayoutItem this[
    ID itemID
] { get; }
Parameters
itemID (ID)


Item Property (itemID, language)

Item Property (itemID, language)
Namespaces ► Sitecore.Data ► LayoutRecords ► Item[([(ID, Language])])
Gets the LayoutItem with the specified item ID.
Declaration Syntax
C#
public LayoutItem this[
    ID itemID,
    Language language
] { get; }
Parameters
itemID (ID)
language (Language)


Item Property (itemID, language, version)

Item Property (itemID, language, version)
Namespaces ► Sitecore.Data ► LayoutRecords ► Item[([(ID, Language, Version])])
Gets the LayoutItem with the specified item ID.
Declaration Syntax
C#
public LayoutItem this[
    ID itemID,
    Language language,
    Version version
] { get; }
Parameters
itemID (ID)
language (Language)
version (Version)


Item Property (itemPath)

Item Property (itemPath)
Namespaces ► Sitecore.Data ► LayoutRecords ► Item[([(String])])
Gets the LayoutItem with the specified item path.
Declaration Syntax
C#
public LayoutItem this[
    string itemPath
] { get; }
Parameters
itemPath (String)


Item Property (itemPath, language)

Item Property (itemPath, language)
Namespaces ► Sitecore.Data ► LayoutRecords ► Item[([(String, Language])])
Gets the LayoutItem with the specified item path.
Declaration Syntax
C#
public LayoutItem this[
    string itemPath,
    Language language
] { get; }
Parameters
itemPath (String)
language (Language)


Item Property (itemPath, language, version)

Item Property (itemPath, language, version)
Namespaces ► Sitecore.Data ► LayoutRecords ► Item[([(String, Language, Version])])
Gets the LayoutItem with the specified item path.
Declaration Syntax
C#
public LayoutItem this[
    string itemPath,
    Language language,
    Version version
] { get; }
Parameters
itemPath (String)
language (Language)
version (Version)


LongID Structure

LongID Structure
Namespaces ► Sitecore.Data ► LongID
A LongID is a fully qualified ID path.
Declaration Syntax
C#
public struct LongID
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsLongID(String) | Tests if a string is a valid LongID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToID(String) | Converts a LongID to an ID.
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Remarks

A LongID contains a path of IDs, e.g. "/{678E49BA-7D1F-48E2-BE86-35824C641556}/{61624451-6216-4C5D-AF67-46FF91442DF7}".

This will uniquely identify an item within a database that supports virtual links.


IsLongID Method (id)

IsLongID Method (id)
Namespaces ► Sitecore.Data ► LongID ► IsLongID(String)
Tests if a string is a valid LongID.
Declaration Syntax
C#
public static bool IsLongID(
    string id
)
Parameters
id (String)
The id.
Return Value
true if [is long ID] [the specified id]; otherwise, false.


ToID Method (longID)

ToID Method (longID)
Namespaces ► Sitecore.Data ► LongID ► ToID(String)
Converts a LongID to an ID.
Declaration Syntax
C#
public static string ToID(
    string longID
)
Parameters
longID (String)
The long ID.
Return Value
The ID.


MasterVariablesReplacer Class

MasterVariablesReplacer Class
Namespaces ► Sitecore.Data ► MasterVariablesReplacer
Represents a master variables replacer.
Declaration Syntax
C#
public class MasterVariablesReplacer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MasterVariablesReplacer()()() | Initializes a new instance of the MasterVariablesReplacer class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExpandBranchItemName(Item, String) | Expands the name of the branch item.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetContext()()() | Gets the current context.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Replace(String, Item) | Replaces the specified text.
 | ReplaceField(Item, Field) | Replaces the field.
 | ReplaceItem(Item) | Replaces the item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MasterVariablesReplacer


MasterVariablesReplacer Constructor

MasterVariablesReplacer Constructor
Namespaces ► Sitecore.Data ► MasterVariablesReplacer ► MasterVariablesReplacer()()()
Initializes a new instance of the MasterVariablesReplacer class
Declaration Syntax
C#
public MasterVariablesReplacer()


ExpandBranchItemName Method (branchTemplateItem, rootItemName)

ExpandBranchItemName Method (branchTemplateItem, rootItemName)
Namespaces ► Sitecore.Data ► MasterVariablesReplacer ► ExpandBranchItemName(Item, String)
Expands the name of the branch item.
Declaration Syntax
C#
public string ExpandBranchItemName(
    Item branchTemplateItem,
    string rootItemName
)
Parameters
branchTemplateItem (Item)
The branch template item.
rootItemName (String)
Name of the root item.
Return Value


GetContext Method

GetContext Method
Namespaces ► Sitecore.Data ► MasterVariablesReplacer ► GetContext()()()
Gets the current context.
Declaration Syntax
C#
protected virtual ReplacerContext GetContext()
Return Value


Replace Method (text, targetItem)

Replace Method (text, targetItem)
Namespaces ► Sitecore.Data ► MasterVariablesReplacer ► Replace(String, Item)
Replaces the specified text.
Declaration Syntax
C#
public virtual string Replace(
    string text,
    Item targetItem
)
Parameters
text (String)
The text.
targetItem (Item)
The target item for the field data.


ReplaceField Method (item, field)

ReplaceField Method (item, field)
Namespaces ► Sitecore.Data ► MasterVariablesReplacer ► ReplaceField(Item, Field)
Replaces the field.
Declaration Syntax
C#
public virtual void ReplaceField(
    Item item,
    Field field
)
Parameters
item (Item)
The item.
field (Field)
The field.


ReplaceItem Method (item)

ReplaceItem Method (item)
Namespaces ► Sitecore.Data ► MasterVariablesReplacer ► ReplaceItem(Item)
Replaces the item.
Declaration Syntax
C#
public virtual void ReplaceItem(
    Item item
)
Parameters
item (Item)
The item.


PropertiesBase Class

PropertiesBase Class
Namespaces ► Sitecore.Data ► PropertiesBase
Defines a meta data store for a database.
Declaration Syntax
C#
public class PropertiesBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PropertiesBase(Database) | Creates a new PropertiesBase instance.
 | Database | Gets the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBoolValue(String, Boolean) | Gets a bool value.
 | GetDateValue(String, DateTime) | Gets a date value.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIntValue(String, Int32) | Gets an integer value.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets or sets the value with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a value with the specified name.
 | RemovePrefix(String) | Removes all values which names have the specified prefix.
 | SetBoolValue(String, Boolean) | Sets a bool value.
 | SetDateValue(String, DateTime) | Sets a date value.
 | SetIntValue(String, Int32) | Sets an integer value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
 | PropertiesBase
 |  | DatabaseProperties
See Also
DatabaseProperties


PropertiesBase Constructor (database)

PropertiesBase Constructor (database)
Namespaces ► Sitecore.Data ► PropertiesBase ► PropertiesBase(Database)
Creates a new PropertiesBase instance.
Declaration Syntax
C#
public PropertiesBase(
    Database database
)
Parameters
database (Database)
Database.


Database Property

Database Property
Namespaces ► Sitecore.Data ► PropertiesBase ► Database
Gets the database.
Declaration Syntax
C#
public virtual Database Database { get; }
Value
The database.


GetBoolValue Method (name, defaultValue)

GetBoolValue Method (name, defaultValue)
Namespaces ► Sitecore.Data ► PropertiesBase ► GetBoolValue(String, Boolean)
Gets a bool value.
Declaration Syntax
C#
public bool GetBoolValue(
    string name,
    bool defaultValue
)
Parameters
name (String)
Name.
defaultValue (Boolean)
Default value.
Return Value
The value.


GetDateValue Method (name, defaultValue)

GetDateValue Method (name, defaultValue)
Namespaces ► Sitecore.Data ► PropertiesBase ► GetDateValue(String, DateTime)
Gets a date value.
Declaration Syntax
C#
public DateTime GetDateValue(
    string name,
    DateTime defaultValue
)
Parameters
name (String)
Name.
defaultValue (DateTime)
Default value.
Return Value
The date value.


GetIntValue Method (name, defaultValue)

GetIntValue Method (name, defaultValue)
Namespaces ► Sitecore.Data ► PropertiesBase ► GetIntValue(String, Int32)
Gets an integer value.
Declaration Syntax
C#
public int GetIntValue(
    string name,
    int defaultValue
)
Parameters
name (String)
Name.
defaultValue (Int32)
Default value.
Return Value
The int value.


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Data ► PropertiesBase ► Item[([(String])])
Gets or sets the value with the specified name.
Declaration Syntax
C#
public virtual string this[
    string name
] { get; set; }
Parameters
name (String)


Remove Method (name)

Remove Method (name)
Namespaces ► Sitecore.Data ► PropertiesBase ► Remove(String)
Removes a value with the specified name.
Declaration Syntax
C#
public virtual void Remove(
    string name
)
Parameters
name (String)
Name.


RemovePrefix Method (prefix)

RemovePrefix Method (prefix)
Namespaces ► Sitecore.Data ► PropertiesBase ► RemovePrefix(String)
Removes all values which names have the specified prefix.
Declaration Syntax
C#
public virtual void RemovePrefix(
    string prefix
)
Parameters
prefix (String)
Prefix.


SetBoolValue Method (name, value)

SetBoolValue Method (name, value)
Namespaces ► Sitecore.Data ► PropertiesBase ► SetBoolValue(String, Boolean)
Sets a bool value.
Declaration Syntax
C#
public void SetBoolValue(
    string name,
    bool value
)
Parameters
name (String)
Name.
value (Boolean)
Value.


SetDateValue Method (name, date)

SetDateValue Method (name, date)
Namespaces ► Sitecore.Data ► PropertiesBase ► SetDateValue(String, DateTime)
Sets a date value.
Declaration Syntax
C#
public void SetDateValue(
    string name,
    DateTime date
)
Parameters
name (String)
Name.
date (DateTime)
Date.


SetIntValue Method (name, value)

SetIntValue Method (name, value)
Namespaces ► Sitecore.Data ► PropertiesBase ► SetIntValue(String, Int32)
Sets an integer value.
Declaration Syntax
C#
public void SetIntValue(
    string name,
    int value
)
Parameters
name (String)
Name.
value (Int32)
Value.


RenderingRecords Class

RenderingRecords Class
Namespaces ► Sitecore.Data ► RenderingRecords
Represents the renderings that are defined in a specified database.
Declaration Syntax
C#
public class RenderingRecords : Database..::.DataRecords
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderingRecords(Database) | Creates a new RenderingRecords instance.
 | BasePath | Gets the base path. (Inherited from Database..::.DataRecords.)
 | Database | Gets the database. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::.DataRecords.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::.DataRecords.)
 | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::.DataRecords.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAll()()() | Gets all the renderings defined by the database.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniquePath(String) | Gets a unique path of an item in the database. (Inherited from Database..::.DataRecords.)
 | Item[([(ID])]) | Gets the RenderingItem with the specified item ID.
 | Item[([(ID, Language])]) | Gets the RenderingItem with the specified item ID.
 | Item[([(ID, Language, Version])]) | Gets the RenderingItem with the specified item ID.
 | Item[([(String])]) | Gets the RenderingItem with the specified item path.
 | Item[([(String, Language])]) | Gets the RenderingItem with the specified item path.
 | Item[([(String, Language, Version])]) | Gets the RenderingItem with the specified item path.
 | Item[([(DataUri])]) | Gets the RenderingItem with the specified URI.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

Renderings are configured in /sitecore/layouts/Layout/Renderings.

The renderings are normally access through the Renderings property.

Inheritance Hierarchy
Object
 | Database..::.DataRecords
 |  | RenderingRecords


RenderingRecords Constructor (database)

RenderingRecords Constructor (database)
Namespaces ► Sitecore.Data ► RenderingRecords ► RenderingRecords(Database)
Creates a new RenderingRecords instance.
Declaration Syntax
C#
public RenderingRecords(
    Database database
)
Parameters
database (Database)
Database.


GetAll Method

GetAll Method
Namespaces ► Sitecore.Data ► RenderingRecords ► GetAll()()()
Gets all the renderings defined by the database.
Declaration Syntax
C#
public RenderingItem[] GetAll()
Return Value
The all.


Item Property

Item Property
Namespaces ► Sitecore.Data ► RenderingRecords ► Item
Members
Icon | Member | Description
 | Item[([(ID])]) | Gets the RenderingItem with the specified item ID.
 | Item[([(ID, Language])]) | Gets the RenderingItem with the specified item ID.
 | Item[([(ID, Language, Version])]) | Gets the RenderingItem with the specified item ID.
 | Item[([(String])]) | Gets the RenderingItem with the specified item path.
 | Item[([(String, Language])]) | Gets the RenderingItem with the specified item path.
 | Item[([(String, Language, Version])]) | Gets the RenderingItem with the specified item path.
 | Item[([(DataUri])]) | Gets the RenderingItem with the specified URI.


Item Property (uri)

Item Property (uri)
Namespaces ► Sitecore.Data ► RenderingRecords ► Item[([(DataUri])])
Gets the RenderingItem with the specified URI.
Declaration Syntax
C#
public RenderingItem this[
    DataUri uri
] { get; }
Parameters
uri (DataUri)


Item Property (itemID)

Item Property (itemID)
Namespaces ► Sitecore.Data ► RenderingRecords ► Item[([(ID])])
Gets the RenderingItem with the specified item ID.
Declaration Syntax
C#
public RenderingItem this[
    ID itemID
] { get; }
Parameters
itemID (ID)


Item Property (itemID, language)

Item Property (itemID, language)
Namespaces ► Sitecore.Data ► RenderingRecords ► Item[([(ID, Language])])
Gets the RenderingItem with the specified item ID.
Declaration Syntax
C#
public RenderingItem this[
    ID itemID,
    Language language
] { get; }
Parameters
itemID (ID)
language (Language)


Item Property (itemID, language, version)

Item Property (itemID, language, version)
Namespaces ► Sitecore.Data ► RenderingRecords ► Item[([(ID, Language, Version])])
Gets the RenderingItem with the specified item ID.
Declaration Syntax
C#
public RenderingItem this[
    ID itemID,
    Language language,
    Version version
] { get; }
Parameters
itemID (ID)
language (Language)
version (Version)


Item Property (itemPath)

Item Property (itemPath)
Namespaces ► Sitecore.Data ► RenderingRecords ► Item[([(String])])
Gets the RenderingItem with the specified item path.
Declaration Syntax
C#
public RenderingItem this[
    string itemPath
] { get; }
Parameters
itemPath (String)


Item Property (itemPath, language)

Item Property (itemPath, language)
Namespaces ► Sitecore.Data ► RenderingRecords ► Item[([(String, Language])])
Gets the RenderingItem with the specified item path.
Declaration Syntax
C#
public RenderingItem this[
    string itemPath,
    Language language
] { get; }
Parameters
itemPath (String)
language (Language)


Item Property (itemPath, language, version)

Item Property (itemPath, language, version)
Namespaces ► Sitecore.Data ► RenderingRecords ► Item[([(String, Language, Version])])
Gets the RenderingItem with the specified item path.
Declaration Syntax
C#
public RenderingItem this[
    string itemPath,
    Language language,
    Version version
] { get; }
Parameters
itemPath (String)
language (Language)
version (Version)


ShortID Class

ShortID Class
Namespaces ► Sitecore.Data ► ShortID
Represents an ID in a compressed form.
Declaration Syntax
C#
[SerializableAttribute]
public class ShortID : ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShortID(String) | Initializes a ShortID from a string.
 | ShortID(ID) | Initializes a ShortID from an ID.
 | ShortID(Guid) | Initializes a ShortID from a GUID.
 | ShortID(SerializationInfo, StreamingContext) | Initializes a new instance of the ShortID class.
 | ShortID()()() | Initializes a new instance of the ShortID class.
 | Decode(String) | Converts a string containing a ShortID to a string
 | DecodeID(String) | Converts a string containing a ShortID to a ID.
 | DecodeItem(String) | Gets an ID path that represents an item from an encoded string.
 | Encode(String) | Converts a string to a ShortID.
 | Encode(ID) | Converts an ID to a ShortID.
 | Encode(Guid) | Converts a GUID to a ShortID.
 | EncodeItem(Item) | Gets a an encoded path of ShortIDs that represents an item.
 | Equality(ShortID, ShortID) | Determines whether two short IDs instances are equal.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object.GetHashCode()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Guid | Gets the GUID represented by the ShortID.
 | Inequality(ShortID, ShortID) | Determines whether two short IDs instances are unequal.
 | IsShortID(String) | Tests if a string is a ShortID.
 | Length | Gets the constant length of 32 character.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewId()()() | Gets a new id.
 | Parse(String) | Parses the specified value.
 | ToID()()() | Converts the ShortID to an ID.
 | ToString()()() | Converts the ShortID to a string. (Overrides Object.ToString()()().)
 | TryParse(String, ShortID%) | Tries to parse a value.
Remarks

A string representation of an ID is usually 38 characters long. Some of these characters are omittable and can be excluded to save space.

The ShortID equivalent of the ID "{678E49BA-7D1F-48E2-BE86-35824C641556}" is "678E49BA7D1F48E2BE8635824C641556".

A ShortID is 32 characters long.

Inheritance Hierarchy
Object
ShortID


ShortID Constructor

ShortID Constructor
Namespaces ► Sitecore.Data ► ShortID ► ShortID()()()
Members
Icon | Member | Description
 | ShortID(String) | Initializes a ShortID from a string.
 | ShortID(ID) | Initializes a ShortID from an ID.
 | ShortID(Guid) | Initializes a ShortID from a GUID.
 | ShortID(SerializationInfo, StreamingContext) | Initializes a new instance of the ShortID class.
 | ShortID()()() | Initializes a new instance of the ShortID class.


ShortID Constructor

ShortID Constructor
Namespaces ► Sitecore.Data ► ShortID ► ShortID()()()
Initializes a new instance of the ShortID class.
Declaration Syntax
C#
public ShortID()


ShortID Constructor (id)

ShortID Constructor (id)
Namespaces ► Sitecore.Data ► ShortID ► ShortID(ID)
Initializes a ShortID from an ID.
Declaration Syntax
C#
public ShortID(
    ID id
)
Parameters
id (ID)
The id.


ShortID Constructor (id)

ShortID Constructor (id)
Namespaces ► Sitecore.Data ► ShortID ► ShortID(Guid)
Initializes a ShortID from a GUID.
Declaration Syntax
C#
public ShortID(
    Guid id
)
Parameters
id (Guid)
The id.


ShortID Constructor (info, context)

ShortID Constructor (info, context)
Namespaces ► Sitecore.Data ► ShortID ► ShortID(SerializationInfo, StreamingContext)
Initializes a new instance of the ShortID class.
Declaration Syntax
C#
protected ShortID(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


ShortID Constructor (id)

ShortID Constructor (id)
Namespaces ► Sitecore.Data ► ShortID ► ShortID(String)
Initializes a ShortID from a string.
Declaration Syntax
C#
public ShortID(
    string id
)
Parameters
id (String)
The id.


Decode Method (id)

Decode Method (id)
Namespaces ► Sitecore.Data ► ShortID ► Decode(String)
Converts a string containing a ShortID to a string
Declaration Syntax
C#
public static string Decode(
    string id
)
Parameters
id (String)
The id.
Return Value
The decode.


DecodeID Method (id)

DecodeID Method (id)
Namespaces ► Sitecore.Data ► ShortID ► DecodeID(String)
Converts a string containing a ShortID to a ID.
Declaration Syntax
C#
public static ID DecodeID(
    string id
)
Parameters
id (String)
The id.
Return Value
The ID.


DecodeItem Method (id)

DecodeItem Method (id)
Namespaces ► Sitecore.Data ► ShortID ► DecodeItem(String)
Gets an ID path that represents an item from an encoded string.
Declaration Syntax
C#
public static string DecodeItem(
    string id
)
Parameters
id (String)
The id.
Return Value
The item.


Encode Method

Encode Method
Namespaces ► Sitecore.Data ► ShortID ► Encode()()()
Members
Icon | Member | Description
 | Encode(String) | Converts a string to a ShortID.
 | Encode(ID) | Converts an ID to a ShortID.
 | Encode(Guid) | Converts a GUID to a ShortID.


Encode Method (id)

Encode Method (id)
Namespaces ► Sitecore.Data ► ShortID ► Encode(ID)
Converts an ID to a ShortID.
Declaration Syntax
C#
public static string Encode(
    ID id
)
Parameters
id (ID)
The id.
Return Value
The encode.


Encode Method (id)

Encode Method (id)
Namespaces ► Sitecore.Data ► ShortID ► Encode(Guid)
Converts a GUID to a ShortID.
Declaration Syntax
C#
public static string Encode(
    Guid id
)
Parameters
id (Guid)
The id.
Return Value
The encode.


Encode Method (guid)

Encode Method (guid)
Namespaces ► Sitecore.Data ► ShortID ► Encode(String)
Converts a string to a ShortID.
Declaration Syntax
C#
public static string Encode(
    string guid
)
Parameters
guid (String)
The GUID.
Return Value
The encode.


EncodeItem Method (item)

EncodeItem Method (item)
Namespaces ► Sitecore.Data ► ShortID ► EncodeItem(Item)
Gets a an encoded path of ShortIDs that represents an item.
Declaration Syntax
C#
public static string EncodeItem(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The item.


Equality Operator

Equality Operator
Namespaces ► Sitecore.Data ► ShortID ► Equality(ShortID, ShortID)
Determines whether two short IDs instances are equal.
Declaration Syntax
C#
public static bool operator ==(
    ShortID id1,
    ShortID id2
)
Parameters
id1 (ShortID)
The first ShortID to compare.
id2 (ShortID)
The second ShortID to compare.
Return Value
true if id1 is the same instance as id2 or if both are null references or if id1.Equals(id2) returns true; otherwise, false.


Equals Method (obj)

Equals Method (obj)
Namespaces ► Sitecore.Data ► ShortID ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C#
public override bool Equals(
    Object obj
)
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.


GetHashCode Method

GetHashCode Method
Namespaces ► Sitecore.Data ► ShortID ► GetHashCode()()()
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
Declaration Syntax
C#
public override int GetHashCode()
Return Value
A hash code for the current Object.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Data ► ShortID ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Guid Property

Guid Property
Namespaces ► Sitecore.Data ► ShortID ► Guid
Gets the GUID represented by the ShortID.
Declaration Syntax
C#
public Guid Guid { get; set; }
Value
The GUID.


Inequality Operator

Inequality Operator
Namespaces ► Sitecore.Data ► ShortID ► Inequality(ShortID, ShortID)
Determines whether two short IDs instances are unequal.
Declaration Syntax
C#
public static bool operator !=(
    ShortID id1,
    ShortID id2
)
Parameters
id1 (ShortID)
The first ShortID to compare.
id2 (ShortID)
The second ShortID to compare.
Return Value
true if id1 is not the same instance as id2 or if id1.Equals(id2) returns false; otherwise, false.


IsShortID Method (id)

IsShortID Method (id)
Namespaces ► Sitecore.Data ► ShortID ► IsShortID(String)
Tests if a string is a ShortID.
Declaration Syntax
C#
public static bool IsShortID(
    string id
)
Parameters
id (String)
The id.
Return Value
true if [is short ID] [the specified id]; otherwise, false.


Length Field

Length Field
Namespaces ► Sitecore.Data ► ShortID ► Length
Gets the constant length of 32 character.
Declaration Syntax
C#
public const int Length


NewId Method

NewId Method
Namespaces ► Sitecore.Data ► ShortID ► NewId()()()
Gets a new id.
Declaration Syntax
C#
public static ShortID NewId()
Return Value
The id


Parse Method (value)

Parse Method (value)
Namespaces ► Sitecore.Data ► ShortID ► Parse(String)
Parses the specified value.
Declaration Syntax
C#
public static ShortID Parse(
    string value
)
Parameters
value (String)
The value.
Return Value


ToID Method

ToID Method
Namespaces ► Sitecore.Data ► ShortID ► ToID()()()
Converts the ShortID to an ID.
Declaration Syntax
C#
public ID ToID()
Return Value
The ID.


ToString Method

ToString Method
Namespaces ► Sitecore.Data ► ShortID ► ToString()()()
Converts the ShortID to a string.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


TryParse Method (value, result)

TryParse Method (value, result)
Namespaces ► Sitecore.Data ► ShortID ► TryParse(String, ShortID%)
Tries to parse a value.
Declaration Syntax
C#
public static bool TryParse(
    string value,
    out ShortID result
)
Parameters
value (String)
The value.
result ( ShortID %)
The result.
Return Value


SortCriteria Class

SortCriteria Class
Namespaces ► Sitecore.Data ► SortCriteria
GridSort
Declaration Syntax
C#
public class SortCriteria
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SortCriteria(String, SortDirection) | Initializes a new instance of the SortCriteria class.
 | Direction | Gets the direction.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldName | Gets the name of the field.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SortCriteria


SortCriteria Constructor (fieldName, direction)

SortCriteria Constructor (fieldName, direction)
Namespaces ► Sitecore.Data ► SortCriteria ► SortCriteria(String, SortDirection)
Initializes a new instance of the SortCriteria class.
Declaration Syntax
C#
public SortCriteria(
    string fieldName,
    SortDirection direction
)
Parameters
fieldName (String)
Name of the field.
direction (SortDirection)
The direction.


Direction Property

Direction Property
Namespaces ► Sitecore.Data ► SortCriteria ► Direction
Gets the direction.
Declaration Syntax
C#
public SortDirection Direction { get; }
Value
The direction.


FieldName Property

FieldName Property
Namespaces ► Sitecore.Data ► SortCriteria ► FieldName
Gets the name of the field.
Declaration Syntax
C#
public string FieldName { get; }
Value
The name of the field.


StandardValuesManager Class

StandardValuesManager Class
Namespaces ► Sitecore.Data ► StandardValuesManager
StandardValueManager class
Declaration Syntax
C#
public static class StandardValuesManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetStandardValue(Field) | Gets the standard value of a field.
 | IsStandardValuesHolder(Item) | Determines whether the specified item is a is standard values holder.
 | Provider | Gets the provider.
 | Providers | Gets the providers.
Inheritance Hierarchy
Object
StandardValuesManager


GetStandardValue Method (field)

GetStandardValue Method (field)
Namespaces ► Sitecore.Data ► StandardValuesManager ► GetStandardValue(Field)
Gets the standard value of a field.
Declaration Syntax
C#
public static string GetStandardValue(
    Field field
)
Parameters
field (Field)
The field.
Return Value


IsStandardValuesHolder Method (item)

IsStandardValuesHolder Method (item)
Namespaces ► Sitecore.Data ► StandardValuesManager ► IsStandardValuesHolder(Item)
Determines whether the specified item is a is standard values holder.
Declaration Syntax
C#
public static bool IsStandardValuesHolder(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item is a standard values holder; otherwise, false.


Provider Property

Provider Property
Namespaces ► Sitecore.Data ► StandardValuesManager ► Provider
Gets the provider.
Declaration Syntax
C#
public static StandardValuesProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Data ► StandardValuesManager ► Providers
Gets the providers.
Declaration Syntax
C#
public static StandardValuesProviderCollection Providers { get; }
Value
The provider.


StandardValuesProvider Class

StandardValuesProvider Class
Namespaces ► Sitecore.Data ► StandardValuesProvider
StandardValuesProvider
Declaration Syntax
C#
public class StandardValuesProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StandardValuesProvider()()() | Initializes a new instance of the StandardValuesProvider class
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStandardValue(Field) | Gets the standard value of a field.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | IsStandardValuesHolder(Item) | Determines whether the specified item is a is standard values holder.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | StandardValuesProvider


StandardValuesProvider Constructor

StandardValuesProvider Constructor
Namespaces ► Sitecore.Data ► StandardValuesProvider ► StandardValuesProvider()()()
Initializes a new instance of the StandardValuesProvider class
Declaration Syntax
C#
public StandardValuesProvider()


GetStandardValue Method (field)

GetStandardValue Method (field)
Namespaces ► Sitecore.Data ► StandardValuesProvider ► GetStandardValue(Field)
Gets the standard value of a field.
Declaration Syntax
C#
public virtual string GetStandardValue(
    Field field
)
Parameters
field (Field)
The field.
Return Value


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Data ► StandardValuesProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
ArgumentException | The name of the provider has a length of zero.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.


IsStandardValuesHolder Method (item)

IsStandardValuesHolder Method (item)
Namespaces ► Sitecore.Data ► StandardValuesProvider ► IsStandardValuesHolder(Item)
Determines whether the specified item is a is standard values holder.
Declaration Syntax
C#
public virtual bool IsStandardValuesHolder(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item is a standard values holder; otherwise, false.


StandardValuesProviderCollection Class

StandardValuesProviderCollection Class
Namespaces ► Sitecore.Data ► StandardValuesProviderCollection
StandardValuesProviderCollection class
Declaration Syntax
C#
public class StandardValuesProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StandardValuesProviderCollection()()() | Initializes a new instance of the StandardValuesProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the StandardValuesProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | StandardValuesProviderCollection


StandardValuesProviderCollection Constructor

StandardValuesProviderCollection Constructor
Namespaces ► Sitecore.Data ► StandardValuesProviderCollection ► StandardValuesProviderCollection()()()
Initializes a new instance of the StandardValuesProviderCollection class
Declaration Syntax
C#
public StandardValuesProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Data ► StandardValuesProviderCollection ► Item[([(String])])
Gets the StandardValuesProvider with the specified name.
Declaration Syntax
C#
public StandardValuesProvider this[
    string name
] { get; }
Parameters
name (String)
Value


SublayoutRecords Class

SublayoutRecords Class
Namespaces ► Sitecore.Data ► SublayoutRecords
Represents the sublayouts in a database.
Declaration Syntax
C#
public class SublayoutRecords : Database..::.DataRecords
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SublayoutRecords(Database) | Represents the sublayouts that are defined in a specified database.
 | BasePath | Gets the base path. (Inherited from Database..::.DataRecords.)
 | Database | Gets the database. (Inherited from Database..::.DataRecords.)
 | DoGetItem(DataUri) | Gets a sublayout. (Overrides Database..::.DataRecords.DoGetItem(DataUri).)
 | DoGetItem(ID) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::.DataRecords.)
 | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::.DataRecords.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::.DataRecords.)
 | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::.DataRecords.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSublayout(ID) | Gets a sublayout.
 | GetSublayout(ID, Language) | Gets a sublayout.
 | GetSublayout(ID, Language, Version) | Gets a sublayout.
 | GetSublayout(String) | Gets a sublayout.
 | GetSublayout(String, Language) | Gets a sublayout.
 | GetSublayout(String, Language, Version) | Gets a sublayout.
 | GetSublayout(DataUri) | Gets a sublayout.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniquePath(String) | Gets a unique path of an item in the database. (Inherited from Database..::.DataRecords.)
 | Item[([(ID])]) | Gets the SublayoutItem with the specified item ID.
 | Item[([(ID, Language])]) | Gets the SublayoutItem with the specified item ID.
 | Item[([(ID, Language, Version])]) | Gets the SublayoutItem with the specified item ID.
 | Item[([(String])]) | Gets the SublayoutItem with the specified item path.
 | Item[([(String, Language])]) | Gets the SublayoutItem with the specified item path.
 | Item[([(String, Language, Version])]) | Gets the SublayoutItem with the specified item path.
 | Item[([(DataUri])]) | Gets the SublayoutItem with the specified URI.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Database..::.DataRecords
 |  | SublayoutRecords


SublayoutRecords Constructor (database)

SublayoutRecords Constructor (database)
Namespaces ► Sitecore.Data ► SublayoutRecords ► SublayoutRecords(Database)
Represents the sublayouts that are defined in a specified database.
Declaration Syntax
C#
public SublayoutRecords(
    Database database
)
Parameters
database (Database)
Remarks

Sublayouts are configured in /sitecore/layouts/Layout/Sublayouts.

The renderingsare normally access through the Sublayouts property.


DoGetItem Method (uri)

DoGetItem Method (uri)
Namespaces ► Sitecore.Data ► SublayoutRecords ► DoGetItem(DataUri)
Gets a sublayout.
Declaration Syntax
C#
protected override Item DoGetItem(
    DataUri uri
)
Parameters
uri (DataUri)
URI.


GetSublayout Method

GetSublayout Method
Namespaces ► Sitecore.Data ► SublayoutRecords ► GetSublayout()()()
Members
Icon | Member | Description
 | GetSublayout(ID) | Gets a sublayout.
 | GetSublayout(ID, Language) | Gets a sublayout.
 | GetSublayout(ID, Language, Version) | Gets a sublayout.
 | GetSublayout(String) | Gets a sublayout.
 | GetSublayout(String, Language) | Gets a sublayout.
 | GetSublayout(String, Language, Version) | Gets a sublayout.
 | GetSublayout(DataUri) | Gets a sublayout.


GetSublayout Method (uri)

GetSublayout Method (uri)
Namespaces ► Sitecore.Data ► SublayoutRecords ► GetSublayout(DataUri)
Gets a sublayout.
Declaration Syntax
C#
public SublayoutItem GetSublayout(
    DataUri uri
)
Parameters
uri (DataUri)
URI.
Return Value
The sublayout.


GetSublayout Method (itemID)

GetSublayout Method (itemID)
Namespaces ► Sitecore.Data ► SublayoutRecords ► GetSublayout(ID)
Gets a sublayout.
Declaration Syntax
C#
public SublayoutItem GetSublayout(
    ID itemID
)
Parameters
itemID (ID)
Item ID.
Return Value
The sublayout.


GetSublayout Method (itemID, language)

GetSublayout Method (itemID, language)
Namespaces ► Sitecore.Data ► SublayoutRecords ► GetSublayout(ID, Language)
Gets a sublayout.
Declaration Syntax
C#
public SublayoutItem GetSublayout(
    ID itemID,
    Language language
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
Return Value
The sublayout.


GetSublayout Method (itemID, language, version)

GetSublayout Method (itemID, language, version)
Namespaces ► Sitecore.Data ► SublayoutRecords ► GetSublayout(ID, Language, Version)
Gets a sublayout.
Declaration Syntax
C#
public SublayoutItem GetSublayout(
    ID itemID,
    Language language,
    Version version
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
version (Version)
Version.
Return Value
The sublayout.


GetSublayout Method (itemPath)

GetSublayout Method (itemPath)
Namespaces ► Sitecore.Data ► SublayoutRecords ► GetSublayout(String)
Gets a sublayout.
Declaration Syntax
C#
public SublayoutItem GetSublayout(
    string itemPath
)
Parameters
itemPath (String)
Item path.
Return Value
The sublayout.


GetSublayout Method (itemPath, language)

GetSublayout Method (itemPath, language)
Namespaces ► Sitecore.Data ► SublayoutRecords ► GetSublayout(String, Language)
Gets a sublayout.
Declaration Syntax
C#
public SublayoutItem GetSublayout(
    string itemPath,
    Language language
)
Parameters
itemPath (String)
Item path.
language (Language)
Language.
Return Value
The sublayout.


GetSublayout Method (itemPath, language, version)

GetSublayout Method (itemPath, language, version)
Namespaces ► Sitecore.Data ► SublayoutRecords ► GetSublayout(String, Language, Version)
Gets a sublayout.
Declaration Syntax
C#
public SublayoutItem GetSublayout(
    string itemPath,
    Language language,
    Version version
)
Parameters
itemPath (String)
Item path.
language (Language)
Language.
version (Version)
Version.
Return Value
The sublayout.


Item Property

Item Property
Namespaces ► Sitecore.Data ► SublayoutRecords ► Item
Members
Icon | Member | Description
 | Item[([(ID])]) | Gets the SublayoutItem with the specified item ID.
 | Item[([(ID, Language])]) | Gets the SublayoutItem with the specified item ID.
 | Item[([(ID, Language, Version])]) | Gets the SublayoutItem with the specified item ID.
 | Item[([(String])]) | Gets the SublayoutItem with the specified item path.
 | Item[([(String, Language])]) | Gets the SublayoutItem with the specified item path.
 | Item[([(String, Language, Version])]) | Gets the SublayoutItem with the specified item path.
 | Item[([(DataUri])]) | Gets the SublayoutItem with the specified URI.


Item Property (uri)

Item Property (uri)
Namespaces ► Sitecore.Data ► SublayoutRecords ► Item[([(DataUri])])
Gets the SublayoutItem with the specified URI.
Declaration Syntax
C#
public SublayoutItem this[
    DataUri uri
] { get; }
Parameters
uri (DataUri)


Item Property (itemID)

Item Property (itemID)
Namespaces ► Sitecore.Data ► SublayoutRecords ► Item[([(ID])])
Gets the SublayoutItem with the specified item ID.
Declaration Syntax
C#
public SublayoutItem this[
    ID itemID
] { get; }
Parameters
itemID (ID)


Item Property (itemID, language)

Item Property (itemID, language)
Namespaces ► Sitecore.Data ► SublayoutRecords ► Item[([(ID, Language])])
Gets the SublayoutItem with the specified item ID.
Declaration Syntax
C#
public SublayoutItem this[
    ID itemID,
    Language language
] { get; }
Parameters
itemID (ID)
language (Language)


Item Property (itemID, language, version)

Item Property (itemID, language, version)
Namespaces ► Sitecore.Data ► SublayoutRecords ► Item[([(ID, Language, Version])])
Gets the SublayoutItem with the specified item ID.
Declaration Syntax
C#
public SublayoutItem this[
    ID itemID,
    Language language,
    Version version
] { get; }
Parameters
itemID (ID)
language (Language)
version (Version)


Item Property (itemPath)

Item Property (itemPath)
Namespaces ► Sitecore.Data ► SublayoutRecords ► Item[([(String])])
Gets the SublayoutItem with the specified item path.
Declaration Syntax
C#
public SublayoutItem this[
    string itemPath
] { get; }
Parameters
itemPath (String)


Item Property (itemPath, language)

Item Property (itemPath, language)
Namespaces ► Sitecore.Data ► SublayoutRecords ► Item[([(String, Language])])
Gets the SublayoutItem with the specified item path.
Declaration Syntax
C#
public SublayoutItem this[
    string itemPath,
    Language language
] { get; }
Parameters
itemPath (String)
language (Language)


Item Property (itemPath, language, version)

Item Property (itemPath, language, version)
Namespaces ► Sitecore.Data ► SublayoutRecords ► Item[([(String, Language, Version])])
Gets the SublayoutItem with the specified item path.
Declaration Syntax
C#
public SublayoutItem this[
    string itemPath,
    Language language,
    Version version
] { get; }
Parameters
itemPath (String)
language (Language)
version (Version)


TemplateID Structure

TemplateID Structure
Namespaces ► Sitecore.Data ► TemplateID
Represents a template ID.
Declaration Syntax
C#
public struct TemplateID
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateID(ID) | Initializes a new instance of the TemplateID class.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns the fully qualified type name of this instance. (Overrides ValueType.ToString()()().)


TemplateID Constructor (id)

TemplateID Constructor (id)
Namespaces ► Sitecore.Data ► TemplateID ► TemplateID(ID)
Initializes a new instance of the TemplateID class.
Declaration Syntax
C#
public TemplateID(
    ID id
)
Parameters
id (ID)
The id.


ID Property

ID Property
Namespaces ► Sitecore.Data ► TemplateID ► ID
Gets the ID.
Declaration Syntax
C#
public ID ID { get; }
Value
The ID.


ToString Method

ToString Method
Namespaces ► Sitecore.Data ► TemplateID ► ToString()()()
Returns the fully qualified type name of this instance.
Declaration Syntax
C#
public override string ToString()
Return Value
A String containing a fully qualified type name.


TemplateRecords Class

TemplateRecords Class
Namespaces ► Sitecore.Data ► TemplateRecords
Represents the templates that are defined in a specified database.
Declaration Syntax
C#
public class TemplateRecords
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateRecords(Database) | Creates a new TemplateRecords instance.
 | CreateTemplate(String, Item) | Creates a new template.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTemplates(Language) | Gets all the templates in a specified language.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets the TemplateItem with the specified full name.
 | Item[([(String, Language])]) | Gets the TemplateItem with the specified full name.
 | Item[([(ID])]) | Gets the TemplateItem with the specified template ID.
 | Item[([(ID, Language])]) | Gets the TemplateItem with the specified template ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

Templates are configured in /sitecore/templates.

The templates are normally access through the Templates property.

Inheritance Hierarchy
Object
TemplateRecords


TemplateRecords Constructor (database)

TemplateRecords Constructor (database)
Namespaces ► Sitecore.Data ► TemplateRecords ► TemplateRecords(Database)
Creates a new TemplateRecords instance.
Declaration Syntax
C#
public TemplateRecords(
    Database database
)
Parameters
database (Database)
Database.


CreateTemplate Method (fullName, parent)

CreateTemplate Method (fullName, parent)
Namespaces ► Sitecore.Data ► TemplateRecords ► CreateTemplate(String, Item)
Creates a new template.
Declaration Syntax
C#
public TemplateItem CreateTemplate(
    string fullName,
    Item parent
)
Parameters
fullName (String)
Full name.
parent (Item)
Parent.
Return Value
The template.


GetTemplates Method (language)

GetTemplates Method (language)
Namespaces ► Sitecore.Data ► TemplateRecords ► GetTemplates(Language)
Gets all the templates in a specified language.
Declaration Syntax
C#
public TemplateItem[] GetTemplates(
    Language language
)
Parameters
language (Language)
Language.
Return Value
The templates.


Item Property

Item Property
Namespaces ► Sitecore.Data ► TemplateRecords ► Item
Members
Icon | Member | Description
 | Item[([(String])]) | Gets the TemplateItem with the specified full name.
 | Item[([(String, Language])]) | Gets the TemplateItem with the specified full name.
 | Item[([(ID])]) | Gets the TemplateItem with the specified template ID.
 | Item[([(ID, Language])]) | Gets the TemplateItem with the specified template ID.


Item Property (templateID)

Item Property (templateID)
Namespaces ► Sitecore.Data ► TemplateRecords ► Item[([(ID])])
Gets the TemplateItem with the specified template ID.
Declaration Syntax
C#
public TemplateItem this[
    ID templateID
] { get; }
Parameters
templateID (ID)


Item Property (templateID, language)

Item Property (templateID, language)
Namespaces ► Sitecore.Data ► TemplateRecords ► Item[([(ID, Language])])
Gets the TemplateItem with the specified template ID.
Declaration Syntax
C#
public TemplateItem this[
    ID templateID,
    Language language
] { get; }
Parameters
templateID (ID)
language (Language)


Item Property (fullName)

Item Property (fullName)
Namespaces ► Sitecore.Data ► TemplateRecords ► Item[([(String])])
Gets the TemplateItem with the specified full name.
Declaration Syntax
C#
public TemplateItem this[
    string fullName
] { get; }
Parameters
fullName (String)


Item Property (fullName, language)

Item Property (fullName, language)
Namespaces ► Sitecore.Data ► TemplateRecords ► Item[([(String, Language])])
Gets the TemplateItem with the specified full name.
Declaration Syntax
C#
public TemplateItem this[
    string fullName,
    Language language
] { get; }
Parameters
fullName (String)
language (Language)


TreeNavigator Class

TreeNavigator Class
Namespaces ► Sitecore.Data ► TreeNavigator
Represents a tree navigator.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public class TreeNavigator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TreeNavigator(Item) | Initializes a new instance of the TreeNavigator class.
 | Current | Gets the current.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveToNext()()() | Moves to next.
 | MoveToRoot()()() | Moves to root.
 | Root | Gets the root.
 | SkipBranch()()() | Skips the branch.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TreeNavigator


TreeNavigator Constructor (rootItem)

TreeNavigator Constructor (rootItem)
Namespaces ► Sitecore.Data ► TreeNavigator ► TreeNavigator(Item)
Initializes a new instance of the TreeNavigator class.
Declaration Syntax
C#
public TreeNavigator(
    Item rootItem
)
Parameters
rootItem (Item)
The root item.


Current Property

Current Property
Namespaces ► Sitecore.Data ► TreeNavigator ► Current
Gets the current.
Declaration Syntax
C#
public Item Current { get; }
Value
The current.


MoveToNext Method

MoveToNext Method
Namespaces ► Sitecore.Data ► TreeNavigator ► MoveToNext()()()
Moves to next.
Declaration Syntax
C#
public bool MoveToNext()
Return Value
The next.


MoveToRoot Method

MoveToRoot Method
Namespaces ► Sitecore.Data ► TreeNavigator ► MoveToRoot()()()
Moves to root.
Declaration Syntax
C#
public bool MoveToRoot()
Return Value
The root.


Root Property

Root Property
Namespaces ► Sitecore.Data ► TreeNavigator ► Root
Gets the root.
Declaration Syntax
C#
public Item Root { get; }
Value
The root.


SkipBranch Method

SkipBranch Method
Namespaces ► Sitecore.Data ► TreeNavigator ► SkipBranch()()()
Skips the branch.
Declaration Syntax
C#
public void SkipBranch()


TreeNavigator.State Class

TreeNavigator..::.State Class
Namespaces ► Sitecore.Data ► TreeNavigator ► TreeNavigator..::.State
Represents the state of a tree navigator.
Declaration Syntax
C#
public class State
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TreeNavigator..::.State(ArrayList) | Initializes a new instance of the TreeNavigator..::.State class.
 | Current | Gets the current.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Index | Gets the index.
 | Items | Gets the items.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveNext()()() | Moves the next.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TreeNavigator..::.State


TreeNavigator.State Constructor (items)

TreeNavigator..::.State Constructor (items)
Namespaces ► Sitecore.Data ► TreeNavigator..::.State ► TreeNavigator..::.State(ArrayList)
Initializes a new instance of the TreeNavigator..::.State class.
Declaration Syntax
C#
public State(
    ArrayList items
)
Parameters
items (ArrayList)
The items.


Current Property

Current Property
Namespaces ► Sitecore.Data ► TreeNavigator..::.State ► Current
Gets the current.
Declaration Syntax
C#
public Item Current { get; }
Value
The current.


Index Property

Index Property
Namespaces ► Sitecore.Data ► TreeNavigator..::.State ► Index
Gets the index.
Declaration Syntax
C#
public int Index { get; }
Value
The index.


Items Property

Items Property
Namespaces ► Sitecore.Data ► TreeNavigator..::.State ► Items
Gets the items.
Declaration Syntax
C#
public ArrayList Items { get; }
Value
The items.


MoveNext Method

MoveNext Method
Namespaces ► Sitecore.Data ► TreeNavigator..::.State ► MoveNext()()()
Moves the next.
Declaration Syntax
C#
public bool MoveNext()
Return Value
The next.


Version Class

Version Class
Namespaces ► Sitecore.Data ► Version
Represents a version number of an item.
Declaration Syntax
C#
[SerializableAttribute]
public class Version : ISerializable, ICacheable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Version(String) | Creates a new Version instance.
 | Version(String, Int32) | Creates a new Version instance.
 | Version(Int32) | Creates a new Version instance.
 | Version(Int32, Int32) | Creates a new Version instance.
 | Version(SerializationInfo, StreamingContext) | Creates a new Version instance.
 | Equality(Version, Version) | Determines whether two version instances are equal.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | First | Gets the first version number.
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object.GetHashCode()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Inequality(Version, Version) | Determines whether two version instances are unequal.
 | Invalid | Gets the invalid version number.
 | Latest | Gets the latest number.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Number | Gets or sets the number.
 | Parse(Object) | Converts a string into a version number.
 | Parse(Int32) | Converts a string into a version number.
 | Parse(String) | Converts a string into a version number.
 | ToInt32()()() | Converts the version number into an integer.
 | ToString()()() | Converts the version number to a string. (Overrides Object.ToString()()().)
 | TryParse(String, Version%) | Tries to parse a string.
Inheritance Hierarchy
Object
Version


Version Constructor

Version Constructor
Namespaces ► Sitecore.Data ► Version ► Version()()()
Members
Icon | Member | Description
 | Version(String) | Creates a new Version instance.
 | Version(String, Int32) | Creates a new Version instance.
 | Version(Int32) | Creates a new Version instance.
 | Version(Int32, Int32) | Creates a new Version instance.
 | Version(SerializationInfo, StreamingContext) | Creates a new Version instance.


Version Constructor (version)

Version Constructor (version)
Namespaces ► Sitecore.Data ► Version ► Version(Int32)
Creates a new Version instance.
Declaration Syntax
C#
public Version(
    int version
)
Parameters
version (Int32)
Version.


Version Constructor (version, defaultValue)

Version Constructor (version, defaultValue)
Namespaces ► Sitecore.Data ► Version ► Version(Int32, Int32)
Creates a new Version instance.
Declaration Syntax
C#
public Version(
    int version,
    int defaultValue
)
Parameters
version (Int32)
Version.
defaultValue (Int32)
Default value.


Version Constructor (info, context)

Version Constructor (info, context)
Namespaces ► Sitecore.Data ► Version ► Version(SerializationInfo, StreamingContext)
Creates a new Version instance.
Declaration Syntax
C#
protected Version(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
Info.
context (StreamingContext)
Context.


Version Constructor (version)

Version Constructor (version)
Namespaces ► Sitecore.Data ► Version ► Version(String)
Creates a new Version instance.
Declaration Syntax
C#
public Version(
    string version
)
Parameters
version (String)
Version.


Version Constructor (version, defaultValue)

Version Constructor (version, defaultValue)
Namespaces ► Sitecore.Data ► Version ► Version(String, Int32)
Creates a new Version instance.
Declaration Syntax
C#
public Version(
    string version,
    int defaultValue
)
Parameters
version (String)
Version.
defaultValue (Int32)
Default value.


Equality Operator

Equality Operator
Namespaces ► Sitecore.Data ► Version ► Equality(Version, Version)
Determines whether two version instances are equal.
Declaration Syntax
C#
public static bool operator ==(
    Version version1,
    Version version2
)
Parameters
version1 (Version)
The first version to compare.
version2 (Version)
The second version to compare.
Return Value
true if version1 is the same instance as version2 or if both are null references or if version1.Equals(version2) returns true; otherwise, false.


Equals Method (obj)

Equals Method (obj)
Namespaces ► Sitecore.Data ► Version ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C#
public override bool Equals(
    Object obj
)
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.


First Property

First Property
Namespaces ► Sitecore.Data ► Version ► First
Gets the first version number.
Declaration Syntax
C#
public static Version First { get; }
Value
The first.
Remarks
The version number of the first version is 1.


GetHashCode Method

GetHashCode Method
Namespaces ► Sitecore.Data ► Version ► GetHashCode()()()
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
Declaration Syntax
C#
public override int GetHashCode()
Return Value
A hash code for the current Object.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Data ► Version ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Inequality Operator

Inequality Operator
Namespaces ► Sitecore.Data ► Version ► Inequality(Version, Version)
Determines whether two version instances are unequal.
Declaration Syntax
C#
public static bool operator !=(
    Version version1,
    Version version2
)
Parameters
version1 (Version)
The first version to compare.
version2 (Version)
The second version to compare.
Return Value
true if version1 is not the same instance as version2 or if version1.Equals(version2) returns false; otherwise, false.


Invalid Property

Invalid Property
Namespaces ► Sitecore.Data ► Version ► Invalid
Gets the invalid version number.
Declaration Syntax
C#
public static Version Invalid { get; }
Value
The invalid.
Remarks
The version number of the first version is -1.


Latest Property

Latest Property
Namespaces ► Sitecore.Data ► Version ► Latest
Gets the latest number.
Declaration Syntax
C#
public static Version Latest { get; }
Value
The latest.
Remarks
The version number of the first version is 0.


Number Property

Number Property
Namespaces ► Sitecore.Data ► Version ► Number
Gets or sets the number.
Declaration Syntax
C#
public int Number { get; }
Value
The number.


Parse Method

Parse Method
Namespaces ► Sitecore.Data ► Version ► Parse()()()
Members
Icon | Member | Description
 | Parse(Object) | Converts a string into a version number.
 | Parse(Int32) | Converts a string into a version number.
 | Parse(String) | Converts a string into a version number.


Parse Method (value)

Parse Method (value)
Namespaces ► Sitecore.Data ► Version ► Parse(Int32)
Converts a string into a version number.
Declaration Syntax
C#
public static Version Parse(
    int value
)
Parameters
value (Int32)
Value.
Return Value
The parse.


Parse Method (value)

Parse Method (value)
Namespaces ► Sitecore.Data ► Version ► Parse(Object)
Converts a string into a version number.
Declaration Syntax
C#
public static Version Parse(
    Object value
)
Parameters
value (Object)
Value.
Return Value
The parse.


Parse Method (value)

Parse Method (value)
Namespaces ► Sitecore.Data ► Version ► Parse(String)
Converts a string into a version number.
Declaration Syntax
C#
public static Version Parse(
    string value
)
Parameters
value (String)
Value.
Return Value
The parse.


ToInt32 Method

ToInt32 Method
Namespaces ► Sitecore.Data ► Version ► ToInt32()()()
Converts the version number into an integer.
Declaration Syntax
C#
public int ToInt32()
Return Value
The int32.


ToString Method

ToString Method
Namespaces ► Sitecore.Data ► Version ► ToString()()()
Converts the version number to a string.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


TryParse Method (value, result)

TryParse Method (value, result)
Namespaces ► Sitecore.Data ► Version ► TryParse(String, Version%)
Tries to parse a string.
Declaration Syntax
C#
public static bool TryParse(
    string value,
    out Version result
)
Parameters
value (String)
The value.
result ( Version %)
The result.
Return Value


VersionComparer Class

VersionComparer Class
Namespaces ► Sitecore.Data ► VersionComparer
Represents a version comparer.
Declaration Syntax
C#
public class VersionComparer : IComparer,
    IComparer<Version>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | VersionComparer()()() | Initializes a new instance of the VersionComparer class
 | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
 | Compare(Version, Version) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
VersionComparer


VersionComparer Constructor

VersionComparer Constructor
Namespaces ► Sitecore.Data ► VersionComparer ► VersionComparer()()()
Initializes a new instance of the VersionComparer class
Declaration Syntax
C#
public VersionComparer()


Compare Method

Compare Method
Namespaces ► Sitecore.Data ► VersionComparer ► Compare()()()
Members
Icon | Member | Description
 | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
 | Compare(Version, Version) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.


Compare Method (version1, version2)

Compare Method (version1, version2)
Namespaces ► Sitecore.Data ► VersionComparer ► Compare(Version, Version)
Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Declaration Syntax
C#
public int Compare(
    Version version1,
    Version version2
)
Parameters
version1 (Version)
The version1.
version2 (Version)
The version2.
Return Value
Value Condition Less than zerox is less than y.Zerox equals y.Greater than zerox is greater than y.


Compare Method (x, y)

Compare Method (x, y)
Namespaces ► Sitecore.Data ► VersionComparer ► Compare(Object, Object)
Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Declaration Syntax
C#
public int Compare(
    Object x,
    Object y
)
Parameters
x (Object)
The first object to compare.
y (Object)
The second object to compare.
Return Value
Value Condition Less than zero x is less than y. Zero x equals y. Greater than zero x is greater than y.
Exceptions
Exception | Condition
ArgumentException | Neither x nor y implements the IComparable interface.-or- x and y are of different types and neither one can handle comparisons with the other.


VersioningType Enumeration

VersioningType Enumeration
Namespaces ► Sitecore.Data ► VersioningType
Defines the type of versioning for a field.
Declaration Syntax
C#
public enum VersioningType
Members
Member | Description
None | Field is shared by all languages and versions.
Language | Field is shared by languages.
Full | Field is not shared.


VersionUri Class

VersionUri Class
Namespaces ► Sitecore.Data ► VersionUri
Represents an Uri to a Version.
Declaration Syntax
C#
public class VersionUri
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VersionUri(Language, Version) | Initializes a new instance of the VersionUri class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Language | Gets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | Version | Gets the version.
Inheritance Hierarchy
Object
VersionUri


VersionUri Constructor (language, version)

VersionUri Constructor (language, version)
Namespaces ► Sitecore.Data ► VersionUri ► VersionUri(Language, Version)
Initializes a new instance of the VersionUri class.
Declaration Syntax
C#
public VersionUri(
    Language language,
    Version version
)
Parameters
language (Language)
The language.
version (Version)
The version.


Language Property

Language Property
Namespaces ► Sitecore.Data ► VersionUri ► Language
Gets the language.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


ToString Method

ToString Method
Namespaces ► Sitecore.Data ► VersionUri ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Version Property

Version Property
Namespaces ► Sitecore.Data ► VersionUri ► Version
Gets the version.
Declaration Syntax
C#
public Version Version { get; }
Value
The version.


Sitecore.Data.Archiving Namespace

Sitecore.Data.Archiving Namespace
Namespaces ► Sitecore.Data.Archiving
Declaration Syntax
C#
namespace Sitecore.Data.Archiving
Types
All Types Classes Enumerations
Icon | Type | Description
 | Archive | Provides functionality to archive an item.
 | ArchiveEntry | ArchiveEntry
 | ArchiveEntryList | ArchiveEntry list.
 | ArchiveQuery..::.ArchiveField | ArchiveField
 | ArchiveManager | ArchiveManager
 | ArchiveProvider | ArchiveProvider
 | ArchiveProviderCollection | ArchiveProviderCollection
 | ArchiveQuery | ArchiveQuery
 | DataArchives | Represents the archives that are attached to a database.
 | ArchiveQuery..::.OrderDirection | OrderDirection
 | ArchiveQuery..::.Ordering | Ordering
 | SqlArchive | SqlArchive
 | SqlArchiveProvider | SqlArchiveProvider
 | SwitchingArchiveProvider | SwitchingArchiveProvider class


Archive Class

Archive Class
Namespaces ► Sitecore.Data.Archiving ► Archive
Provides functionality to archive an item.
Declaration Syntax
C#
public abstract class Archive
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Archive(String) | Creates a new Archive instance.
 | ArchiveItem(Item) | Archives an item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetArchivalId(ID) | Gets the archival id associated with an item.
 | GetEntries(Int32, Int32) | Gets a list of entries.
 | GetEntries(ArchiveQuery, Int32, Int32) | Gets a list of entries.
 | GetEntriesForUser(User, Int32, Int32) | Gets a list of entries owned by the specified user.
 | GetEntryCount()()() | Gets the number of entries currently in the archive.
 | GetEntryCount(ArchiveQuery) | Gets the number of entries currently in the archive.
 | GetEntryCountForUser(User) | Gets the entry count for current user.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the archive.
 | NotifyItemDeleted(Item, ID) | Notifies the item deleted.
 | NotifyItemDeleting(Item, Boolean%) | Notifies the item deleting.
 | RemoveEntries()()() | Removes all entries from the archive.
 | RemoveEntries(ArchiveQuery) | Removes all entries from the archive.
 | RestoreItem(Guid) | Restores an item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
When archiving an item, the item is moved to the Archive database.
Inheritance Hierarchy
Object
 | Archive
 |  | SqlArchive


Archive Constructor (name)

Archive Constructor (name)
Namespaces ► Sitecore.Data.Archiving ► Archive ► Archive(String)
Creates a new Archive instance.
Declaration Syntax
C#
protected Archive(
    string name
)
Parameters
name (String)
Name.


ArchiveItem Method (item)

ArchiveItem Method (item)
Namespaces ► Sitecore.Data.Archiving ► Archive ► ArchiveItem(Item)
Archives an item.
Declaration Syntax
C#
public abstract Guid ArchiveItem(
    Item item
)
Parameters
item (Item)
Item.
Return Value
The archival id.


GetArchivalId Method (itemId)

GetArchivalId Method (itemId)
Namespaces ► Sitecore.Data.Archiving ► Archive ► GetArchivalId(ID)
Gets the archival id associated with an item.
Declaration Syntax
C#
public abstract Guid GetArchivalId(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value


GetEntries Method

GetEntries Method
Namespaces ► Sitecore.Data.Archiving ► Archive ► GetEntries()()()
Members
Icon | Member | Description
 | GetEntries(Int32, Int32) | Gets a list of entries.
 | GetEntries(ArchiveQuery, Int32, Int32) | Gets a list of entries.


GetEntries Method (query, pageIndex, pageSize)

GetEntries Method (query, pageIndex, pageSize)
Namespaces ► Sitecore.Data.Archiving ► Archive ► GetEntries(ArchiveQuery, Int32, Int32)
Gets a list of entries.
Declaration Syntax
C#
public abstract IEnumerable<ArchiveEntry> GetEntries(
    ArchiveQuery query,
    int pageIndex,
    int pageSize
)
Parameters
query (ArchiveQuery)
The query.
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
Return Value


GetEntries Method (pageIndex, pageSize)

GetEntries Method (pageIndex, pageSize)
Namespaces ► Sitecore.Data.Archiving ► Archive ► GetEntries(Int32, Int32)
Gets a list of entries.
Declaration Syntax
C#
public virtual IEnumerable<ArchiveEntry> GetEntries(
    int pageIndex,
    int pageSize
)
Parameters
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
Return Value


GetEntriesForUser Method (user, pageIndex, pageSize)

GetEntriesForUser Method (user, pageIndex, pageSize)
Namespaces ► Sitecore.Data.Archiving ► Archive ► GetEntriesForUser(User, Int32, Int32)
Gets a list of entries owned by the specified user.
Declaration Syntax
C#
public virtual IEnumerable<ArchiveEntry> GetEntriesForUser(
    User user,
    int pageIndex,
    int pageSize
)
Parameters
user (User)
The user.
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
Return Value
Remarks
If the current user is an administrator, all entries are returned.


GetEntryCount Method

GetEntryCount Method
Namespaces ► Sitecore.Data.Archiving ► Archive ► GetEntryCount()()()
Members
Icon | Member | Description
 | GetEntryCount()()() | Gets the number of entries currently in the archive.
 | GetEntryCount(ArchiveQuery) | Gets the number of entries currently in the archive.


GetEntryCount Method

GetEntryCount Method
Namespaces ► Sitecore.Data.Archiving ► Archive ► GetEntryCount()()()
Gets the number of entries currently in the archive.
Declaration Syntax
C#
public virtual int GetEntryCount()
Return Value


GetEntryCount Method (query)

GetEntryCount Method (query)
Namespaces ► Sitecore.Data.Archiving ► Archive ► GetEntryCount(ArchiveQuery)
Gets the number of entries currently in the archive.
Declaration Syntax
C#
public abstract int GetEntryCount(
    ArchiveQuery query
)
Parameters
query (ArchiveQuery)
Return Value


GetEntryCountForUser Method (user)

GetEntryCountForUser Method (user)
Namespaces ► Sitecore.Data.Archiving ► Archive ► GetEntryCountForUser(User)
Gets the entry count for current user.
Declaration Syntax
C#
public int GetEntryCountForUser(
    User user
)
Parameters
user (User)
Return Value


Name Property

Name Property
Namespaces ► Sitecore.Data.Archiving ► Archive ► Name
Gets the name of the archive.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


NotifyItemDeleted Method (item, parentId)

NotifyItemDeleted Method (item, parentId)
Namespaces ► Sitecore.Data.Archiving ► Archive ► NotifyItemDeleted(Item, ID)
Notifies the item deleted.
Declaration Syntax
C#
protected virtual void NotifyItemDeleted(
    Item item,
    ID parentId
)
Parameters
item (Item)
The item.
parentId (ID)
The parent id.


NotifyItemDeleting Method (item, canceled)

NotifyItemDeleting Method (item, canceled)
Namespaces ► Sitecore.Data.Archiving ► Archive ► NotifyItemDeleting(Item, Boolean%)
Notifies the item deleting.
Declaration Syntax
C#
protected virtual void NotifyItemDeleting(
    Item item,
    out bool canceled
)
Parameters
item (Item)
The item.
canceled ( Boolean %)
if set to true this event is canceled.


RemoveEntries Method

RemoveEntries Method
Namespaces ► Sitecore.Data.Archiving ► Archive ► RemoveEntries()()()
Members
Icon | Member | Description
 | RemoveEntries()()() | Removes all entries from the archive.
 | RemoveEntries(ArchiveQuery) | Removes all entries from the archive.


RemoveEntries Method

RemoveEntries Method
Namespaces ► Sitecore.Data.Archiving ► Archive ► RemoveEntries()()()
Removes all entries from the archive.
Declaration Syntax
C#
public virtual void RemoveEntries()


RemoveEntries Method (query)

RemoveEntries Method (query)
Namespaces ► Sitecore.Data.Archiving ► Archive ► RemoveEntries(ArchiveQuery)
Removes all entries from the archive.
Declaration Syntax
C#
public abstract void RemoveEntries(
    ArchiveQuery query
)
Parameters
query (ArchiveQuery)


RestoreItem Method (archivalId)

RestoreItem Method (archivalId)
Namespaces ► Sitecore.Data.Archiving ► Archive ► RestoreItem(Guid)
Restores an item.
Declaration Syntax
C#
public abstract bool RestoreItem(
    Guid archivalId
)
Parameters
archivalId (Guid)
The archival id.
Return Value


ArchiveEntry Class

ArchiveEntry Class
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntry
ArchiveEntry
Declaration Syntax
C#
public class ArchiveEntry
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveEntry(Guid, ID, ID, String, String, DateTime, String, String, Database) | Initializes a new instance of the ArchiveEntry class.
 | ArchivalId | Gets the archival id.
 | ArchiveDate | Gets the archive date in UTC time.
 | ArchivedBy | Gets the archived by.
 | ArchiveLocalDate | Gets the archive local date in local time.
 | ArchiveName | Gets the name of the archive.
 | Database | Gets the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemId | Gets the item id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | OriginalLocation | Gets the original location.
 | ParentId | Gets the parent id.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ArchiveEntry


ArchiveEntry Constructor (archivalId, itemId, parentId, name, originalLocation, archiveDate, archivedBy, archiveName, database)

ArchiveEntry Constructor (archivalId, itemId, parentId, name, originalLocation, archiveDate, archivedBy, archiveName, database)
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntry ► ArchiveEntry(Guid, ID, ID, String, String, DateTime, String, String, Database)
Initializes a new instance of the ArchiveEntry class.
Declaration Syntax
C#
public ArchiveEntry(
    Guid archivalId,
    ID itemId,
    ID parentId,
    string name,
    string originalLocation,
    DateTime archiveDate,
    string archivedBy,
    string archiveName,
    Database database
)
Parameters
archivalId (Guid)
The archival id.
itemId (ID)
The item id.
parentId (ID)
The parent id.
name (String)
The name.
originalLocation (String)
The original location.
archiveDate (DateTime)
The archive date.
archivedBy (String)
The archived by.
archiveName (String)
Name of the archive.
database (Database)
The database.


ArchivalId Property

ArchivalId Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntry ► ArchivalId
Gets the archival id.
Declaration Syntax
C#
public Guid ArchivalId { get; }
Value
The archival id.


ArchiveDate Property

ArchiveDate Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntry ► ArchiveDate
Gets the archive date in UTC time.
Declaration Syntax
C#
public DateTime ArchiveDate { get; }
Value
The archive date.


ArchivedBy Property

ArchivedBy Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntry ► ArchivedBy
Gets the archived by.
Declaration Syntax
C#
public string ArchivedBy { get; }
Value
The archived by.


ArchiveLocalDate Property

ArchiveLocalDate Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntry ► ArchiveLocalDate
Gets the archive local date in local time.
Declaration Syntax
C#
public DateTime ArchiveLocalDate { get; }
Value
The archive local date.


ArchiveName Property

ArchiveName Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntry ► ArchiveName
Gets the name of the archive.
Declaration Syntax
C#
public string ArchiveName { get; }
Value
The name of the archive.


Database Property

Database Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntry ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


ItemId Property

ItemId Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntry ► ItemId
Gets the item id.
Declaration Syntax
C#
public ID ItemId { get; }
Value
The item id.


Name Property

Name Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntry ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


OriginalLocation Property

OriginalLocation Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntry ► OriginalLocation
Gets the original location.
Declaration Syntax
C#
public string OriginalLocation { get; }
Value
The original location.


ParentId Property

ParentId Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntry ► ParentId
Gets the parent id.
Declaration Syntax
C#
public ID ParentId { get; }
Value
The parent id.


ArchiveEntryList Class

ArchiveEntryList Class
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntryList
ArchiveEntry list.
Declaration Syntax
C#
public class ArchiveEntryList : ReadOnlyList<ArchiveEntry>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveEntryList(IEnumerable<(Of <(ArchiveEntry>)>)) | Initializes a new instance of the ArchiveEntryList class.
 | ArchiveEntryList()()() | Initializes a new instance of the ArchiveEntryList class.
 | Contains(TElement) | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToArray()()() | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ReadOnlyList <(Of <( ArchiveEntry >)>)
 |  | ArchiveEntryList


ArchiveEntryList Constructor

ArchiveEntryList Constructor
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntryList ► ArchiveEntryList()()()
Members
Icon | Member | Description
 | ArchiveEntryList(IEnumerable<(Of <(ArchiveEntry>)>)) | Initializes a new instance of the ArchiveEntryList class.
 | ArchiveEntryList()()() | Initializes a new instance of the ArchiveEntryList class.


ArchiveEntryList Constructor

ArchiveEntryList Constructor
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntryList ► ArchiveEntryList()()()
Initializes a new instance of the ArchiveEntryList class.
Declaration Syntax
C#
public ArchiveEntryList()


ArchiveEntryList Constructor (entries)

ArchiveEntryList Constructor (entries)
Namespaces ► Sitecore.Data.Archiving ► ArchiveEntryList ► ArchiveEntryList(IEnumerable<(Of <(ArchiveEntry>)>))
Initializes a new instance of the ArchiveEntryList class.
Declaration Syntax
C#
public ArchiveEntryList(
    IEnumerable<ArchiveEntry> entries
)
Parameters
entries (IEnumerable<(Of <( ArchiveEntry >)>))
The entries.


ArchiveManager Class

ArchiveManager Class
Namespaces ► Sitecore.Data.Archiving ► ArchiveManager
ArchiveManager
Declaration Syntax
C#
public static class ArchiveManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetArchive(String, Database) | Gets an archive by name from the specifoed database.
 | GetArchiveCount(Database) | Gets the archive count for the specified database.
 | GetArchives(Database) | Gets all the archives of the specified database.
 | Provider | Gets the provider.
 | Providers | Gets all providers.
Inheritance Hierarchy
Object
ArchiveManager


GetArchive Method (archiveName, database)

GetArchive Method (archiveName, database)
Namespaces ► Sitecore.Data.Archiving ► ArchiveManager ► GetArchive(String, Database)
Gets an archive by name from the specifoed database.
Declaration Syntax
C#
public static Archive GetArchive(
    string archiveName,
    Database database
)
Parameters
archiveName (String)
Name of the archive.
database (Database)
The database.
Return Value


GetArchiveCount Method (database)

GetArchiveCount Method (database)
Namespaces ► Sitecore.Data.Archiving ► ArchiveManager ► GetArchiveCount(Database)
Gets the archive count for the specified database.
Declaration Syntax
C#
public static int GetArchiveCount(
    Database database
)
Parameters
database (Database)
The database.
Return Value


GetArchives Method (database)

GetArchives Method (database)
Namespaces ► Sitecore.Data.Archiving ► ArchiveManager ► GetArchives(Database)
Gets all the archives of the specified database.
Declaration Syntax
C#
public static List<Archive> GetArchives(
    Database database
)
Parameters
database (Database)
The database.
Return Value


Provider Property

Provider Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveManager ► Provider
Gets the provider.
Declaration Syntax
C#
public static ArchiveProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveManager ► Providers
Gets all providers.
Declaration Syntax
C#
public static ArchiveProviderCollection Providers { get; }
Value
The providers.


ArchiveProvider Class

ArchiveProvider Class
Namespaces ► Sitecore.Data.Archiving ► ArchiveProvider
ArchiveProvider
Declaration Syntax
C#
public abstract class ArchiveProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveProvider()()() | Initializes a new instance of the ArchiveProvider class
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetArchive(String, Database) | Gets an archive by name from the specifoed database.
 | GetArchiveCount(Database) | Gets the archive count for the specified database.
 | GetArchives(Database) | Gets all the archives of the specified database.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | MatchDatabaseNames | Gets the match databases.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | ArchiveProvider
 |  |  | SqlArchiveProvider
 |  |  | SwitchingArchiveProvider


ArchiveProvider Constructor

ArchiveProvider Constructor
Namespaces ► Sitecore.Data.Archiving ► ArchiveProvider ► ArchiveProvider()()()
Initializes a new instance of the ArchiveProvider class
Declaration Syntax
C#
protected ArchiveProvider()


GetArchive Method (archiveName, database)

GetArchive Method (archiveName, database)
Namespaces ► Sitecore.Data.Archiving ► ArchiveProvider ► GetArchive(String, Database)
Gets an archive by name from the specifoed database.
Declaration Syntax
C#
public abstract Archive GetArchive(
    string archiveName,
    Database database
)
Parameters
archiveName (String)
Name of the archive.
database (Database)
The database.
Return Value


GetArchiveCount Method (database)

GetArchiveCount Method (database)
Namespaces ► Sitecore.Data.Archiving ► ArchiveProvider ► GetArchiveCount(Database)
Gets the archive count for the specified database.
Declaration Syntax
C#
public abstract int GetArchiveCount(
    Database database
)
Parameters
database (Database)
The database.
Return Value


GetArchives Method (database)

GetArchives Method (database)
Namespaces ► Sitecore.Data.Archiving ► ArchiveProvider ► GetArchives(Database)
Gets all the archives of the specified database.
Declaration Syntax
C#
public abstract List<Archive> GetArchives(
    Database database
)
Parameters
database (Database)
The database.
Return Value


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Data.Archiving ► ArchiveProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
ArgumentException | The name of the provider has a length of zero.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.


MatchDatabaseNames Property

MatchDatabaseNames Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveProvider ► MatchDatabaseNames
Gets the match databases.
Declaration Syntax
C#
public virtual List<string> MatchDatabaseNames { get; }
Value
The match databases.


ArchiveProviderCollection Class

ArchiveProviderCollection Class
Namespaces ► Sitecore.Data.Archiving ► ArchiveProviderCollection
ArchiveProviderCollection
Declaration Syntax
C#
public class ArchiveProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveProviderCollection()()() | Initializes a new instance of the ArchiveProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the ArchiveProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | ArchiveProviderCollection


ArchiveProviderCollection Constructor

ArchiveProviderCollection Constructor
Namespaces ► Sitecore.Data.Archiving ► ArchiveProviderCollection ► ArchiveProviderCollection()()()
Initializes a new instance of the ArchiveProviderCollection class
Declaration Syntax
C#
public ArchiveProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Data.Archiving ► ArchiveProviderCollection ► Item[([(String])])
Gets the ArchiveProvider with the specified name.
Declaration Syntax
C#
public ArchiveProvider this[
    string name
] { get; }
Parameters
name (String)
Value


ArchiveQuery Class

ArchiveQuery Class
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery
ArchiveQuery
Declaration Syntax
C#
public class ArchiveQuery
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveQuery()()() | Initializes a new instance of the ArchiveQuery class
 | AddOrdering(ArchiveQuery..::.ArchiveField, ArchiveQuery..::.OrderDirection) | Adds an ordering.
 | ArchivalId | Gets or sets the archival id.
 | ArchiveDateBegin | Gets or sets the archive date begin.
 | ArchiveDateEnd | Gets or sets the archive date end.
 | ArchivedBy | Gets or sets the archived by start.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | ItemId | Gets or sets the item id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name.
 | Orderings | Gets the orderings.
 | OriginalLocation | Gets or sets the original location.
 | ParentId | Gets or sets the parent id.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ArchiveQuery


ArchiveQuery Constructor

ArchiveQuery Constructor
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► ArchiveQuery()()()
Initializes a new instance of the ArchiveQuery class
Declaration Syntax
C#
public ArchiveQuery()


AddOrdering Method (field, orderDirection)

AddOrdering Method (field, orderDirection)
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► AddOrdering(ArchiveQuery..::.ArchiveField, ArchiveQuery..::.OrderDirection)
Adds an ordering.
Declaration Syntax
C#
public void AddOrdering(
    ArchiveQuery..::.ArchiveField field,
    ArchiveQuery..::.OrderDirection orderDirection
)
Parameters
field (ArchiveQuery..::.ArchiveField)
The field.
orderDirection (ArchiveQuery..::.OrderDirection)
The order direction.


ArchivalId Property

ArchivalId Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► ArchivalId
Gets or sets the archival id.
Declaration Syntax
C#
public Guid ArchivalId { get; set; }
Value
The archival id.


ArchiveDateBegin Property

ArchiveDateBegin Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► ArchiveDateBegin
Gets or sets the archive date begin.
Declaration Syntax
C#
public DateTime ArchiveDateBegin { get; set; }
Value
The archive date begin.


ArchiveDateEnd Property

ArchiveDateEnd Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► ArchiveDateEnd
Gets or sets the archive date end.
Declaration Syntax
C#
public DateTime ArchiveDateEnd { get; set; }
Value
The archive date end.


ArchivedBy Property

ArchivedBy Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► ArchivedBy
Gets or sets the archived by start.
Declaration Syntax
C#
public string ArchivedBy { get; set; }
Value
The archived by start.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


ItemId Property

ItemId Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► ItemId
Gets or sets the item id.
Declaration Syntax
C#
public ID ItemId { get; set; }
Value
The item id.


Name Property

Name Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► Name
Gets or sets the name.
Declaration Syntax
C#
public string Name { get; set; }
Value
The name.


Orderings Property

Orderings Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► Orderings
Gets the orderings.
Declaration Syntax
C#
public List<ArchiveQuery..::.Ordering> Orderings { get; }
Value
The orderings.


OriginalLocation Property

OriginalLocation Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► OriginalLocation
Gets or sets the original location.
Declaration Syntax
C#
public string OriginalLocation { get; set; }
Value
The original location.


ParentId Property

ParentId Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► ParentId
Gets or sets the parent id.
Declaration Syntax
C#
public ID ParentId { get; set; }
Value
The parent id.


ArchiveQuery.ArchiveField Enumeration

ArchiveQuery..::.ArchiveField Enumeration
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► ArchiveQuery..::.ArchiveField
ArchiveField
Declaration Syntax
C#
public enum ArchiveField
Members
Member | Description
ArchivalId |
ArchiveDate |
ArchivedBy |
ItemId |
Name |
OriginalLocation |
ParentId |


ArchiveQuery.OrderDirection Enumeration

ArchiveQuery..::.OrderDirection Enumeration
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► ArchiveQuery..::.OrderDirection
OrderDirection
Declaration Syntax
C#
public enum OrderDirection
Members
Member | Description
Ascending |
Descending |


ArchiveQuery.Ordering Class

ArchiveQuery..::.Ordering Class
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery ► ArchiveQuery..::.Ordering
Ordering
Declaration Syntax
C#
public class Ordering
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveQuery..::.Ordering(ArchiveQuery..::.ArchiveField, ArchiveQuery..::.OrderDirection) | Initializes a new instance of the ArchiveQuery..::.Ordering class.
 | Direction | Gets the direction.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Field | Gets the field.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ArchiveQuery..::.Ordering


ArchiveQuery.Ordering Constructor (field, direction)

ArchiveQuery..::.Ordering Constructor (field, direction)
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery..::.Ordering ► ArchiveQuery..::.Ordering(ArchiveQuery..::.ArchiveField, ArchiveQuery..::.OrderDirection)
Initializes a new instance of the ArchiveQuery..::.Ordering class.
Declaration Syntax
C#
public Ordering(
    ArchiveQuery..::.ArchiveField field,
    ArchiveQuery..::.OrderDirection direction
)
Parameters
field (ArchiveQuery..::.ArchiveField)
The field.
direction (ArchiveQuery..::.OrderDirection)
The direction.


Direction Property

Direction Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery..::.Ordering ► Direction
Gets the direction.
Declaration Syntax
C#
public ArchiveQuery..::.OrderDirection Direction { get; }
Value
The direction.


Field Property

Field Property
Namespaces ► Sitecore.Data.Archiving ► ArchiveQuery..::.Ordering ► Field
Gets the field.
Declaration Syntax
C#
public ArchiveQuery..::.ArchiveField Field { get; }
Value
The field.


DataArchives Class

DataArchives Class
Namespaces ► Sitecore.Data.Archiving ► DataArchives
Represents the archives that are attached to a database.
Declaration Syntax
C#
public class DataArchives
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataArchives(Database) | Initializes a new instance of the DataArchives class.
 | Count | Gets the number of archives.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets the Archive with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
The archives are normally access through the Archives property.
Inheritance Hierarchy
Object
DataArchives


DataArchives Constructor (database)

DataArchives Constructor (database)
Namespaces ► Sitecore.Data.Archiving ► DataArchives ► DataArchives(Database)
Initializes a new instance of the DataArchives class.
Declaration Syntax
C#
public DataArchives(
    Database database
)
Parameters
database (Database)


Count Property

Count Property
Namespaces ► Sitecore.Data.Archiving ► DataArchives ► Count
Gets the number of archives.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Data.Archiving ► DataArchives ► Item[([(String])])
Gets the Archive with the specified name.
Declaration Syntax
C#
public Archive this[
    string name
] { get; }
Parameters
name (String)


SqlArchive Class

SqlArchive Class
Namespaces ► Sitecore.Data.Archiving ► SqlArchive
SqlArchive
Declaration Syntax
C#
public class SqlArchive : Archive
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlArchive(String, Database) | Initializes a new instance of the SqlArchive class.
 | _dataApi | data API
 | _database | Database
 | AddDate(DateTime, String, String, StringBuilder, SqlStatement) | Adds the lower date.
 | AddGuid(Guid, String, StringBuilder, SqlStatement) | Adds an id.
 | AddId(ID, String, StringBuilder, SqlStatement) | Adds an id.
 | AddOrderByClause(ArchiveQuery, SqlStatement) | Adds an 'order by' clause.
 | AddString(String, String, StringBuilder, SqlStatement) | Adds the string.
 | AddWhereClause(ArchiveQuery, SqlStatement) | Adds the where clause.
 | ArchiveItem(Item) | Archives an item. (Overrides Archive.ArchiveItem(Item).)
 | CreateDataApi()()() | Initializes the data API.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetArchivalId(ID) | Gets the archival id associated with an item. (Overrides Archive.GetArchivalId(ID).)
 | GetEntries(ArchiveQuery, Int32, Int32) | Gets a list of entries. (Overrides Archive.GetEntries(ArchiveQuery, Int32, Int32).)
 | GetEntries(SqlStatement) | Gets the entries.
 | GetEntries(Int32, Int32) | Gets a list of entries. (Inherited from Archive.)
 | GetEntriesForUser(User, Int32, Int32) | Gets a list of entries owned by the specified user. (Inherited from Archive.)
 | GetEntryCount(ArchiveQuery) | Gets the number of entries currently in the archive. (Overrides Archive.GetEntryCount(ArchiveQuery).)
 | GetEntryCount()()() | Gets the number of entries currently in the archive. (Inherited from Archive.)
 | GetEntryCountForUser(User) | Gets the entry count for current user. (Inherited from Archive.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetParameterName(String) | Gets the name of the parameter.
 | GetSelectStatement(ArchiveQuery, String) | Gets a select statement.
 | GetSelectStatement(ArchiveQuery, String, Int32, Int32) | Gets a paged select statement.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the archive. (Inherited from Archive.)
 | NotifyItemDeleted(Item, ID) | Notifies the item deleted. (Inherited from Archive.)
 | NotifyItemDeleting(Item, Boolean%) | Notifies the item deleting. (Inherited from Archive.)
 | RemoveEntries(ArchiveQuery) | Removes all entries from the archive. (Overrides Archive.RemoveEntries(ArchiveQuery).)
 | RemoveEntries()()() | Removes all entries from the archive. (Inherited from Archive.)
 | RestoreItem(Guid) | Restores an item. (Overrides Archive.RestoreItem(Guid).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Archive
 |  | SqlArchive


SqlArchive Constructor (name, database)

SqlArchive Constructor (name, database)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► SqlArchive(String, Database)
Initializes a new instance of the SqlArchive class.
Declaration Syntax
C#
public SqlArchive(
    string name,
    Database database
)
Parameters
name (String)
Name.
database (Database)
The database.


_dataApi Field

_dataApi Field
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► _dataApi
data API
Declaration Syntax
C#
protected readonly SqlDataApi _dataApi


_database Field

_database Field
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► _database
Database
Declaration Syntax
C#
protected readonly Database _database


AddDate Method (value, columnName, comparisonOperator, whereClause, statement)

AddDate Method (value, columnName, comparisonOperator, whereClause, statement)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► AddDate(DateTime, String, String, StringBuilder, SqlStatement)
Adds the lower date.
Declaration Syntax
C#
protected virtual void AddDate(
    DateTime value,
    string columnName,
    string comparisonOperator,
    StringBuilder whereClause,
    SqlStatement statement
)
Parameters
value (DateTime)
The value.
columnName (String)
Name of the column.
comparisonOperator (String)
The comparison operator.
whereClause (StringBuilder)
The where clause.
statement (SqlStatement)
The statement.


AddGuid Method (id, columnName, whereClause, statement)

AddGuid Method (id, columnName, whereClause, statement)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► AddGuid(Guid, String, StringBuilder, SqlStatement)
Adds an id.
Declaration Syntax
C#
protected virtual void AddGuid(
    Guid id,
    string columnName,
    StringBuilder whereClause,
    SqlStatement statement
)
Parameters
id (Guid)
The id.
columnName (String)
Name of the column.
whereClause (StringBuilder)
The where clause.
statement (SqlStatement)
The statement.


AddId Method (id, columnName, whereClause, statement)

AddId Method (id, columnName, whereClause, statement)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► AddId(ID, String, StringBuilder, SqlStatement)
Adds an id.
Declaration Syntax
C#
protected virtual void AddId(
    ID id,
    string columnName,
    StringBuilder whereClause,
    SqlStatement statement
)
Parameters
id (ID)
The id.
columnName (String)
Name of the column.
whereClause (StringBuilder)
The where clause.
statement (SqlStatement)
The statement.


AddOrderByClause Method (query, statement)

AddOrderByClause Method (query, statement)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► AddOrderByClause(ArchiveQuery, SqlStatement)
Adds an 'order by' clause.
Declaration Syntax
C#
protected virtual void AddOrderByClause(
    ArchiveQuery query,
    SqlStatement statement
)
Parameters
query (ArchiveQuery)
The query.
statement (SqlStatement)
The statement.


AddString Method (value, columnName, whereClause, statement)

AddString Method (value, columnName, whereClause, statement)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► AddString(String, String, StringBuilder, SqlStatement)
Adds the string.
Declaration Syntax
C#
protected virtual void AddString(
    string value,
    string columnName,
    StringBuilder whereClause,
    SqlStatement statement
)
Parameters
value (String)
The value.
columnName (String)
Name of the column.
whereClause (StringBuilder)
The where clause.
statement (SqlStatement)
The statement.


AddWhereClause Method (query, statement)

AddWhereClause Method (query, statement)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► AddWhereClause(ArchiveQuery, SqlStatement)
Adds the where clause.
Declaration Syntax
C#
protected virtual void AddWhereClause(
    ArchiveQuery query,
    SqlStatement statement
)
Parameters
query (ArchiveQuery)
The query.
statement (SqlStatement)
The statement.


ArchiveItem Method (item)

ArchiveItem Method (item)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► ArchiveItem(Item)
Archives an item.
Declaration Syntax
C#
public override Guid ArchiveItem(
    Item item
)
Parameters
item (Item)
Item.
Return Value
The archival id.


CreateDataApi Method

CreateDataApi Method
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► CreateDataApi()()()
Initializes the data API.
Declaration Syntax
C#
protected virtual SqlDataApi CreateDataApi()
Exceptions
Exception | Condition
InvalidOperationException | SqlArchive can only be used for databases with a valid ConnectionStringName


GetArchivalId Method (itemId)

GetArchivalId Method (itemId)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► GetArchivalId(ID)
Gets the archival id associated with an item.
Declaration Syntax
C#
public override Guid GetArchivalId(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value


GetEntries Method

GetEntries Method
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► GetEntries()()()
Members
Icon | Member | Description
 | GetEntries(ArchiveQuery, Int32, Int32) | Gets a list of entries. (Overrides Archive.GetEntries(ArchiveQuery, Int32, Int32).)
 | GetEntries(SqlStatement) | Gets the entries.
 | GetEntries(Int32, Int32) | Gets a list of entries.


GetEntries Method (query, pageIndex, pageSize)

GetEntries Method (query, pageIndex, pageSize)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► GetEntries(ArchiveQuery, Int32, Int32)
Gets a list of entries.
Declaration Syntax
C#
public override IEnumerable<ArchiveEntry> GetEntries(
    ArchiveQuery query,
    int pageIndex,
    int pageSize
)
Parameters
query (ArchiveQuery)
The query.
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
Return Value


GetEntries Method (statement)

GetEntries Method (statement)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► GetEntries(SqlStatement)
Gets the entries.
Declaration Syntax
C#
protected virtual IEnumerable<ArchiveEntry> GetEntries(
    SqlStatement statement
)
Parameters
statement (SqlStatement)
The statement.
Return Value


GetEntryCount Method (query)

GetEntryCount Method (query)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► GetEntryCount(ArchiveQuery)
Gets the number of entries currently in the archive.
Declaration Syntax
C#
public override int GetEntryCount(
    ArchiveQuery query
)
Parameters
query (ArchiveQuery)
Return Value


GetParameterName Method (columnName)

GetParameterName Method (columnName)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► GetParameterName(String)
Gets the name of the parameter.
Declaration Syntax
C#
protected virtual string GetParameterName(
    string columnName
)
Parameters
columnName (String)
Name of the column.
Return Value


GetSelectStatement Method

GetSelectStatement Method
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► GetSelectStatement()()()
Members
Icon | Member | Description
 | GetSelectStatement(ArchiveQuery, String) | Gets a select statement.
 | GetSelectStatement(ArchiveQuery, String, Int32, Int32) | Gets a paged select statement.


GetSelectStatement Method (query, columns)

GetSelectStatement Method (query, columns)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► GetSelectStatement(ArchiveQuery, String)
Gets a select statement.
Declaration Syntax
C#
protected virtual SqlStatement GetSelectStatement(
    ArchiveQuery query,
    string columns
)
Parameters
query (ArchiveQuery)
The query.
columns (String)
The columns.
Return Value


GetSelectStatement Method (query, columns, pageIndex, pageSize)

GetSelectStatement Method (query, columns, pageIndex, pageSize)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► GetSelectStatement(ArchiveQuery, String, Int32, Int32)
Gets a paged select statement.
Declaration Syntax
C#
protected virtual SqlStatement GetSelectStatement(
    ArchiveQuery query,
    string columns,
    int pageIndex,
    int pageSize
)
Parameters
query (ArchiveQuery)
The query.
columns (String)
The columns.
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
Return Value


RemoveEntries Method (query)

RemoveEntries Method (query)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► RemoveEntries(ArchiveQuery)
Removes all entries from the archive.
Declaration Syntax
C#
public override void RemoveEntries(
    ArchiveQuery query
)
Parameters
query (ArchiveQuery)


RestoreItem Method (archivalId)

RestoreItem Method (archivalId)
Namespaces ► Sitecore.Data.Archiving ► SqlArchive ► RestoreItem(Guid)
Restores an item.
Declaration Syntax
C#
public override bool RestoreItem(
    Guid archivalId
)
Parameters
archivalId (Guid)
The archival id.
Return Value


SqlArchiveProvider Class

SqlArchiveProvider Class
Namespaces ► Sitecore.Data.Archiving ► SqlArchiveProvider
SqlArchiveProvider
Declaration Syntax
C#
public class SqlArchiveProvider : ArchiveProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlArchiveProvider()()() | Initializes a new instance of the SqlArchiveProvider class
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetArchive(String, Database) | Gets an archive by name from the specified database. (Overrides ArchiveProvider.GetArchive(String, Database).)
 | GetArchive(XmlNode, Database) | Gets the archive.
 | GetArchiveCount(Database) | Gets the archive count for the specified database. (Overrides ArchiveProvider.GetArchiveCount(Database).)
 | GetArchives(Database) | Gets all the archives of the specified database. (Overrides ArchiveProvider.GetArchives(Database).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ArchiveProvider.)
 | MatchDatabaseNames | Gets the match databases. (Inherited from ArchiveProvider.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | ArchiveProvider
 |  |  | SqlArchiveProvider


SqlArchiveProvider Constructor

SqlArchiveProvider Constructor
Namespaces ► Sitecore.Data.Archiving ► SqlArchiveProvider ► SqlArchiveProvider()()()
Initializes a new instance of the SqlArchiveProvider class
Declaration Syntax
C#
public SqlArchiveProvider()


GetArchive Method

GetArchive Method
Namespaces ► Sitecore.Data.Archiving ► SqlArchiveProvider ► GetArchive()()()
Members
Icon | Member | Description
 | GetArchive(String, Database) | Gets an archive by name from the specified database. (Overrides ArchiveProvider.GetArchive(String, Database).)
 | GetArchive(XmlNode, Database) | Gets the archive.


GetArchive Method (archiveName, database)

GetArchive Method (archiveName, database)
Namespaces ► Sitecore.Data.Archiving ► SqlArchiveProvider ► GetArchive(String, Database)
Gets an archive by name from the specified database.
Declaration Syntax
C#
public override Archive GetArchive(
    string archiveName,
    Database database
)
Parameters
archiveName (String)
Name of the archive.
database (Database)
The database.
Return Value


GetArchive Method (configNode, database)

GetArchive Method (configNode, database)
Namespaces ► Sitecore.Data.Archiving ► SqlArchiveProvider ► GetArchive(XmlNode, Database)
Gets the archive.
Declaration Syntax
C#
protected virtual Archive GetArchive(
    XmlNode configNode,
    Database database
)
Parameters
configNode (XmlNode)
The config node.
database (Database)
The database.
Return Value


GetArchiveCount Method (database)

GetArchiveCount Method (database)
Namespaces ► Sitecore.Data.Archiving ► SqlArchiveProvider ► GetArchiveCount(Database)
Gets the archive count for the specified database.
Declaration Syntax
C#
public override int GetArchiveCount(
    Database database
)
Parameters
database (Database)
The database.
Return Value


GetArchives Method (database)

GetArchives Method (database)
Namespaces ► Sitecore.Data.Archiving ► SqlArchiveProvider ► GetArchives(Database)
Gets all the archives of the specified database.
Declaration Syntax
C#
public override List<Archive> GetArchives(
    Database database
)
Parameters
database (Database)
The database.
Return Value


SwitchingArchiveProvider Class

SwitchingArchiveProvider Class
Namespaces ► Sitecore.Data.Archiving ► SwitchingArchiveProvider
SwitchingArchiveProvider class
Declaration Syntax
C#
public class SwitchingArchiveProvider : ArchiveProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SwitchingArchiveProvider()()() | Initializes a new instance of the SwitchingArchiveProvider class
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetArchive(String, Database) | Gets an archive by name from the specified database. (Overrides ArchiveProvider.GetArchive(String, Database).)
 | GetArchiveCount(Database) | Gets the archive count for the specified database. (Overrides ArchiveProvider.GetArchiveCount(Database).)
 | GetArchives(Database) | Gets all the archives of the specified database. (Overrides ArchiveProvider.GetArchives(Database).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProvider(Database) | Gets appropriate provider for database.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ArchiveProvider.)
 | InitializeMapping()()() | Initializes the mapping.
 | MatchDatabaseNames | Gets the match databases. (Inherited from ArchiveProvider.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | ArchiveProvider
 |  |  | SwitchingArchiveProvider


SwitchingArchiveProvider Constructor

SwitchingArchiveProvider Constructor
Namespaces ► Sitecore.Data.Archiving ► SwitchingArchiveProvider ► SwitchingArchiveProvider()()()
Initializes a new instance of the SwitchingArchiveProvider class
Declaration Syntax
C#
public SwitchingArchiveProvider()


GetArchive Method (archiveName, database)

GetArchive Method (archiveName, database)
Namespaces ► Sitecore.Data.Archiving ► SwitchingArchiveProvider ► GetArchive(String, Database)
Gets an archive by name from the specified database.
Declaration Syntax
C#
public override Archive GetArchive(
    string archiveName,
    Database database
)
Parameters
archiveName (String)
Name of the archive.
database (Database)
The database.
Return Value


GetArchiveCount Method (database)

GetArchiveCount Method (database)
Namespaces ► Sitecore.Data.Archiving ► SwitchingArchiveProvider ► GetArchiveCount(Database)
Gets the archive count for the specified database.
Declaration Syntax
C#
public override int GetArchiveCount(
    Database database
)
Parameters
database (Database)
The database.
Return Value


GetArchives Method (database)

GetArchives Method (database)
Namespaces ► Sitecore.Data.Archiving ► SwitchingArchiveProvider ► GetArchives(Database)
Gets all the archives of the specified database.
Declaration Syntax
C#
public override List<Archive> GetArchives(
    Database database
)
Parameters
database (Database)
The database.
Return Value


GetProvider Method (database)

GetProvider Method (database)
Namespaces ► Sitecore.Data.Archiving ► SwitchingArchiveProvider ► GetProvider(Database)
Gets appropriate provider for database.
Declaration Syntax
C#
protected virtual ArchiveProvider GetProvider(
    Database database
)
Parameters
database (Database)
The database.
Return Value


InitializeMapping Method

InitializeMapping Method
Namespaces ► Sitecore.Data.Archiving ► SwitchingArchiveProvider ► InitializeMapping()()()
Initializes the mapping.
Declaration Syntax
C#
protected virtual void InitializeMapping()
Exceptions
Exception | Condition
ProviderConfigurationException | ProviderConfigurationException.


Sitecore.Data.Comparers Namespace

Sitecore.Data.Comparers Namespace
Namespaces ► Sitecore.Data.Comparers
Declaration Syntax
C#
namespace Sitecore.Data.Comparers
Types
All Types Classes
Icon | Type | Description
 | Comparer | Compares two items.
 | ComparerFactory | Creates Comparer objects.
 | CreatedComparer | Compares two items using the created fields.
 | DefaultComparer | Default comparing between items.
 | DisplayNameComparer | Compares the displaynames between two items.
 | IDComparer | Compares two items.
 | ItemComparer | Compares two items.
 | LogicalComparer | Compares two items using the StrCmpLogicalW Windows API method.
 | ReverseComparer | Compares two items and reverses the result.
 | UpdatedComparer | Compares two items using the updated fields.


Comparer Class

Comparer Class
Namespaces ► Sitecore.Data.Comparers ► Comparer
Compares two items.
Declaration Syntax
C#
public abstract class Comparer : IComparer<Item>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Comparer()()() | Initializes a new instance of the Comparer class
 | Compare(Item, Item) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
 | DoCompare(Item, Item) | Compares two items.
 | DoCompareSortorder(Item, Item, Int32%) | Compares the sortorder of two items.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Comparer
 |  | CreatedComparer
 |  | DefaultComparer
 |  | DisplayNameComparer
 |  | LogicalComparer
 |  | ReverseComparer
 |  | UpdatedComparer


Comparer Constructor

Comparer Constructor
Namespaces ► Sitecore.Data.Comparers ► Comparer ► Comparer()()()
Initializes a new instance of the Comparer class
Declaration Syntax
C#
protected Comparer()


Compare Method (item1, item2)

Compare Method (item1, item2)
Namespaces ► Sitecore.Data.Comparers ► Comparer ► Compare(Item, Item)
Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Declaration Syntax
C#
public int Compare(
    Item item1,
    Item item2
)
Parameters
item1 (Item)
The first object to compare.
item2 (Item)
The second object to compare.
Return Value
Value Condition Less than zero if x is less than y. Zero if x equals y. Greater than zero if x is greater than y.


DoCompare Method (item1, item2)

DoCompare Method (item1, item2)
Namespaces ► Sitecore.Data.Comparers ► Comparer ► DoCompare(Item, Item)
Compares two items.
Declaration Syntax
C#
protected abstract int DoCompare(
    Item item1,
    Item item2
)
Parameters
item1 (Item)
The item1.
item2 (Item)
The item2.
Return Value


DoCompareSortorder Method (item1, item2, result)

DoCompareSortorder Method (item1, item2, result)
Namespaces ► Sitecore.Data.Comparers ► Comparer ► DoCompareSortorder(Item, Item, Int32%)
Compares the sortorder of two items.
Declaration Syntax
C#
protected virtual bool DoCompareSortorder(
    Item item1,
    Item item2,
    out int result
)
Parameters
item1 (Item)
The item1.
item2 (Item)
The item2.
result ( Int32 %)
The result.
Return Value


ComparerFactory Class

ComparerFactory Class
Namespaces ► Sitecore.Data.Comparers ► ComparerFactory
Creates Comparer objects.
Declaration Syntax
C#
public static class ComparerFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetComparer(String) | Obsolete. Gets the comparer.
 | GetComparer(String, Database) | Gets the comparer.
 | GetComparer(Item) | Gets the comparer.
Inheritance Hierarchy
Object
ComparerFactory


GetComparer Method

GetComparer Method
Namespaces ► Sitecore.Data.Comparers ► ComparerFactory ► GetComparer()()()
Members
Icon | Member | Description
 | GetComparer(String) | Obsolete. Gets the comparer.
 | GetComparer(String, Database) | Gets the comparer.
 | GetComparer(Item) | Gets the comparer.


GetComparer Method (item)

GetComparer Method (item)
Namespaces ► Sitecore.Data.Comparers ► ComparerFactory ► GetComparer(Item)
Gets the comparer.
Declaration Syntax
C#
public static IComparer<Item> GetComparer(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetComparer Method (sortingID)

GetComparer Method (sortingID)
Namespaces ► Sitecore.Data.Comparers ► ComparerFactory ► GetComparer(String)
Gets the comparer.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use GetComparer(sortingId, database) instead.")]
public static IComparer<Item> GetComparer(
    string sortingID
)
Parameters
sortingID (String)
The sorting ID.
Return Value


GetComparer Method (sortingId, database)

GetComparer Method (sortingId, database)
Namespaces ► Sitecore.Data.Comparers ► ComparerFactory ► GetComparer(String, Database)
Gets the comparer.
Declaration Syntax
C#
public static IComparer<Item> GetComparer(
    string sortingId,
    Database database
)
Parameters
sortingId (String)
The sorting ID.
database (Database)
The database.
Return Value


CreatedComparer Class

CreatedComparer Class
Namespaces ► Sitecore.Data.Comparers ► CreatedComparer
Compares two items using the created fields.
Declaration Syntax
C#
public class CreatedComparer : Comparer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreatedComparer()()() | Initializes a new instance of the CreatedComparer class
 | Compare(Item, Item) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
 | DoCompare(Item, Item) | Compares two items. (Overrides Comparer.DoCompare(Item, Item).)
 | DoCompareSortorder(Item, Item, Int32%) | Compares the sortorder of two items. (Inherited from Comparer.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Comparer
 |  | CreatedComparer


CreatedComparer Constructor

CreatedComparer Constructor
Namespaces ► Sitecore.Data.Comparers ► CreatedComparer ► CreatedComparer()()()
Initializes a new instance of the CreatedComparer class
Declaration Syntax
C#
public CreatedComparer()


DoCompare Method (item1, item2)

DoCompare Method (item1, item2)
Namespaces ► Sitecore.Data.Comparers ► CreatedComparer ► DoCompare(Item, Item)
Compares two items.
Declaration Syntax
C#
protected override int DoCompare(
    Item item1,
    Item item2
)
Parameters
item1 (Item)
The item1.
item2 (Item)
The item2.
Return Value


DefaultComparer Class

DefaultComparer Class
Namespaces ► Sitecore.Data.Comparers ► DefaultComparer
Default comparing between items.
Declaration Syntax
C#
public class DefaultComparer : Comparer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DefaultComparer()()() | Initializes a new instance of the DefaultComparer class
 | Compare(Item, Item) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
 | DoCompare(Item, Item) | Compares two items. (Overrides Comparer.DoCompare(Item, Item).)
 | DoCompareSortorder(Item, Item, Int32%) | Compares the sortorder of two items. (Inherited from Comparer.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Comparer
 |  | DefaultComparer


DefaultComparer Constructor

DefaultComparer Constructor
Namespaces ► Sitecore.Data.Comparers ► DefaultComparer ► DefaultComparer()()()
Initializes a new instance of the DefaultComparer class
Declaration Syntax
C#
public DefaultComparer()


DoCompare Method (item1, item2)

DoCompare Method (item1, item2)
Namespaces ► Sitecore.Data.Comparers ► DefaultComparer ► DoCompare(Item, Item)
Compares two items.
Declaration Syntax
C#
protected override int DoCompare(
    Item item1,
    Item item2
)
Parameters
item1 (Item)
The item1.
item2 (Item)
The item2.
Return Value


DisplayNameComparer Class

DisplayNameComparer Class
Namespaces ► Sitecore.Data.Comparers ► DisplayNameComparer
Compares the displaynames between two items.
Declaration Syntax
C#
public class DisplayNameComparer : Comparer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DisplayNameComparer()()() | Initializes a new instance of the DisplayNameComparer class
 | Compare(Item, Item) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
 | DoCompare(Item, Item) | Compares two items. (Overrides Comparer.DoCompare(Item, Item).)
 | DoCompareSortorder(Item, Item, Int32%) | Compares the sortorder of two items. (Inherited from Comparer.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Comparer
 |  | DisplayNameComparer


DisplayNameComparer Constructor

DisplayNameComparer Constructor
Namespaces ► Sitecore.Data.Comparers ► DisplayNameComparer ► DisplayNameComparer()()()
Initializes a new instance of the DisplayNameComparer class
Declaration Syntax
C#
public DisplayNameComparer()


DoCompare Method (item1, item2)

DoCompare Method (item1, item2)
Namespaces ► Sitecore.Data.Comparers ► DisplayNameComparer ► DoCompare(Item, Item)
Compares two items.
Declaration Syntax
C#
protected override int DoCompare(
    Item item1,
    Item item2
)
Parameters
item1 (Item)
The item1.
item2 (Item)
The item2.
Return Value


IDComparer Class

IDComparer Class
Namespaces ► Sitecore.Data.Comparers ► IDComparer
Compares two items.
Declaration Syntax
C#
public class IDComparer : IComparer<ID>,
    IComparer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IDComparer()()() | Initializes a new instance of the IDComparer class
 | Compare(ID, ID) | Compares the specified items.
 | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
IDComparer


IDComparer Constructor

IDComparer Constructor
Namespaces ► Sitecore.Data.Comparers ► IDComparer ► IDComparer()()()
Initializes a new instance of the IDComparer class
Declaration Syntax
C#
public IDComparer()


Compare Method

Compare Method
Namespaces ► Sitecore.Data.Comparers ► IDComparer ► Compare()()()
Members
Icon | Member | Description
 | Compare(ID, ID) | Compares the specified items.
 | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.


Compare Method (id1, id2)

Compare Method (id1, id2)
Namespaces ► Sitecore.Data.Comparers ► IDComparer ► Compare(ID, ID)
Compares the specified items.
Declaration Syntax
C#
public int Compare(
    ID id1,
    ID id2
)
Parameters
id1 (ID)
Item1.
id2 (ID)
Item2.
Return Value


Compare Method (x, y)

Compare Method (x, y)
Namespaces ► Sitecore.Data.Comparers ► IDComparer ► Compare(Object, Object)
Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Declaration Syntax
C#
public int Compare(
    Object x,
    Object y
)
Parameters
x (Object)
The first object to compare.
y (Object)
The second object to compare.
Return Value
Value Condition Less than zero x is less than y. Zero x equals y. Greater than zero x is greater than y.
Exceptions
Exception | Condition
ArgumentException | Neither x nor y implements the IComparable interface.-or- x and y are of different types and neither one can handle comparisons with the other.


ItemComparer Class

ItemComparer Class
Namespaces ► Sitecore.Data.Comparers ► ItemComparer
Compares two items.
Declaration Syntax
C#
public class ItemComparer : IComparer<Item>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemComparer()()() | Initializes a new instance of the ItemComparer class
 | Compare(Item, Item) | Compares the specified items.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemComparer


ItemComparer Constructor

ItemComparer Constructor
Namespaces ► Sitecore.Data.Comparers ► ItemComparer ► ItemComparer()()()
Initializes a new instance of the ItemComparer class
Declaration Syntax
C#
public ItemComparer()


Compare Method (item1, item2)

Compare Method (item1, item2)
Namespaces ► Sitecore.Data.Comparers ► ItemComparer ► Compare(Item, Item)
Compares the specified items.
Declaration Syntax
C#
public int Compare(
    Item item1,
    Item item2
)
Parameters
item1 (Item)
Item1.
item2 (Item)
Item2.
Return Value


LogicalComparer Class

LogicalComparer Class
Namespaces ► Sitecore.Data.Comparers ► LogicalComparer
Compares two items using the StrCmpLogicalW Windows API method.
Declaration Syntax
C#
public class LogicalComparer : Comparer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LogicalComparer()()() | Initializes a new instance of the LogicalComparer class
 | Compare(Item, Item) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
 | DoCompare(Item, Item) | Compares two items. (Overrides Comparer.DoCompare(Item, Item).)
 | DoCompareSortorder(Item, Item, Int32%) | Compares the sortorder of two items. (Inherited from Comparer.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Comparer
 |  | LogicalComparer


LogicalComparer Constructor

LogicalComparer Constructor
Namespaces ► Sitecore.Data.Comparers ► LogicalComparer ► LogicalComparer()()()
Initializes a new instance of the LogicalComparer class
Declaration Syntax
C#
public LogicalComparer()


DoCompare Method (item1, item2)

DoCompare Method (item1, item2)
Namespaces ► Sitecore.Data.Comparers ► LogicalComparer ► DoCompare(Item, Item)
Compares two items.
Declaration Syntax
C#
protected override int DoCompare(
    Item item1,
    Item item2
)
Parameters
item1 (Item)
The item1.
item2 (Item)
The item2.
Return Value


ReverseComparer Class

ReverseComparer Class
Namespaces ► Sitecore.Data.Comparers ► ReverseComparer
Compares two items and reverses the result.
Declaration Syntax
C#
public class ReverseComparer : Comparer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ReverseComparer()()() | Initializes a new instance of the ReverseComparer class
 | Compare(Item, Item) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
 | DoCompare(Item, Item) | Compares two items. (Overrides Comparer.DoCompare(Item, Item).)
 | DoCompareSortorder(Item, Item, Int32%) | Compares the sortorder of two items. (Overrides Comparer.DoCompareSortorder(Item, Item, Int32%).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Comparer
 |  | ReverseComparer


ReverseComparer Constructor

ReverseComparer Constructor
Namespaces ► Sitecore.Data.Comparers ► ReverseComparer ► ReverseComparer()()()
Initializes a new instance of the ReverseComparer class
Declaration Syntax
C#
public ReverseComparer()


DoCompare Method (item1, item2)

DoCompare Method (item1, item2)
Namespaces ► Sitecore.Data.Comparers ► ReverseComparer ► DoCompare(Item, Item)
Compares two items.
Declaration Syntax
C#
protected override int DoCompare(
    Item item1,
    Item item2
)
Parameters
item1 (Item)
The item1.
item2 (Item)
The item2.
Return Value


DoCompareSortorder Method (item1, item2, result)

DoCompareSortorder Method (item1, item2, result)
Namespaces ► Sitecore.Data.Comparers ► ReverseComparer ► DoCompareSortorder(Item, Item, Int32%)
Compares the sortorder of two items.
Declaration Syntax
C#
protected override bool DoCompareSortorder(
    Item item1,
    Item item2,
    out int result
)
Parameters
item1 (Item)
The item1.
item2 (Item)
The item2.
result ( Int32 %)
The result.
Return Value


UpdatedComparer Class

UpdatedComparer Class
Namespaces ► Sitecore.Data.Comparers ► UpdatedComparer
Compares two items using the updated fields.
Declaration Syntax
C#
public class UpdatedComparer : Comparer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UpdatedComparer()()() | Initializes a new instance of the UpdatedComparer class
 | Compare(Item, Item) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
 | DoCompare(Item, Item) | Compares two items. (Overrides Comparer.DoCompare(Item, Item).)
 | DoCompareSortorder(Item, Item, Int32%) | Compares the sortorder of two items. (Inherited from Comparer.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Comparer
 |  | UpdatedComparer


UpdatedComparer Constructor

UpdatedComparer Constructor
Namespaces ► Sitecore.Data.Comparers ► UpdatedComparer ► UpdatedComparer()()()
Initializes a new instance of the UpdatedComparer class
Declaration Syntax
C#
public UpdatedComparer()


DoCompare Method (item1, item2)

DoCompare Method (item1, item2)
Namespaces ► Sitecore.Data.Comparers ► UpdatedComparer ► DoCompare(Item, Item)
Compares two items.
Declaration Syntax
C#
protected override int DoCompare(
    Item item1,
    Item item2
)
Parameters
item1 (Item)
The item1.
item2 (Item)
The item2.
Return Value


Sitecore.Data.Databases Namespace

Sitecore.Data.Databases Namespace
Namespaces ► Sitecore.Data.Databases
Declaration Syntax
C#
namespace Sitecore.Data.Databases
Types
All Types Classes
Icon | Type | Description
 | CustomDatabase | Defines the basic functionality of a custom database.
 | DomainDatabase | Encapsulates a security base database.


CustomDatabase Class

CustomDatabase Class
Namespaces ► Sitecore.Data.Databases ► CustomDatabase
Defines the basic functionality of a custom database.
Declaration Syntax
C#
public abstract class CustomDatabase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomDatabase(Database) | Creates a new CustomDatabase instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerDatabase | Gets the inner database.
 | Items | Gets the items.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | SelectItems(String) | Performs an Sitecore XPath query against the database.
 | SelectSingleItem(String) | Performs an Sitecore XPath query against the database.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomDatabase
 |  | DomainDatabase


CustomDatabase Constructor (innerDatabase)

CustomDatabase Constructor (innerDatabase)
Namespaces ► Sitecore.Data.Databases ► CustomDatabase ► CustomDatabase(Database)
Creates a new CustomDatabase instance.
Declaration Syntax
C#
protected CustomDatabase(
    Database innerDatabase
)
Parameters
innerDatabase (Database)
Inner database.


InnerDatabase Property

InnerDatabase Property
Namespaces ► Sitecore.Data.Databases ► CustomDatabase ► InnerDatabase
Gets the inner database.
Declaration Syntax
C#
public Database InnerDatabase { get; }
Value
The inner database.


Items Property

Items Property
Namespaces ► Sitecore.Data.Databases ► CustomDatabase ► Items
Gets the items.
Declaration Syntax
C#
public ItemRecords Items { get; }
Value
The items.


Name Property

Name Property
Namespaces ► Sitecore.Data.Databases ► CustomDatabase ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


SelectItems Method (query)

SelectItems Method (query)
Namespaces ► Sitecore.Data.Databases ► CustomDatabase ► SelectItems(String)
Performs an Sitecore XPath query against the database.
Declaration Syntax
C#
public Item[] SelectItems(
    string query
)
Parameters
query (String)
The query.
Return Value
The items.


SelectSingleItem Method (query)

SelectSingleItem Method (query)
Namespaces ► Sitecore.Data.Databases ► CustomDatabase ► SelectSingleItem(String)
Performs an Sitecore XPath query against the database.
Declaration Syntax
C#
public Item SelectSingleItem(
    string query
)
Parameters
query (String)
The query.
Return Value
The single item.


DomainDatabase Class

DomainDatabase Class
Namespaces ► Sitecore.Data.Databases ► DomainDatabase
Encapsulates a security base database.
Declaration Syntax
C#
public class DomainDatabase : CustomDatabase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainDatabase(Database) | Creates a new DomainDatabase instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRoleNames()()() | Gets the role names defined in the database.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Implicit(Database) | Implicit operators the specified database.
 | InnerDatabase | Gets the inner database. (Inherited from CustomDatabase.)
 | Items | Gets the items. (Inherited from CustomDatabase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomDatabase.)
 | SelectItems(String) | Performs an Sitecore XPath query against the database. (Inherited from CustomDatabase.)
 | SelectSingleItem(String) | Performs an Sitecore XPath query against the database. (Inherited from CustomDatabase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomDatabase
 |  | DomainDatabase


DomainDatabase Constructor (innerDatabase)

DomainDatabase Constructor (innerDatabase)
Namespaces ► Sitecore.Data.Databases ► DomainDatabase ► DomainDatabase(Database)
Creates a new DomainDatabase instance.
Declaration Syntax
C#
public DomainDatabase(
    Database innerDatabase
)
Parameters
innerDatabase (Database)
Inner database.


GetRoleNames Method

GetRoleNames Method
Namespaces ► Sitecore.Data.Databases ► DomainDatabase ► GetRoleNames()()()
Gets the role names defined in the database.
Declaration Syntax
C#
public string[] GetRoleNames()
Return Value
The role names.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Databases ► DomainDatabase ► Implicit(Database)
Implicit operators the specified database.
Declaration Syntax
C#
public static implicit operator DomainDatabase (
    Database database
)
Parameters
database (Database)
The database.
Return Value
The implicit operator.


Sitecore.Data.DataProviders Namespace

Sitecore.Data.DataProviders Namespace
Namespaces ► Sitecore.Data.DataProviders
Declaration Syntax
C#
namespace Sitecore.Data.DataProviders
Types
All Types Classes
Icon | Type | Description
 | CacheOptions | Represents a set of cache options.
 | CallContext | Represents a call context.
 | DatabaseViewStateStore | Serializes ViewState using the ClientContext.DataStore object.
 | DataProvider | DataProvider
 | FileSystemDataProvider | Represents a file system data provider.
 | HelloWorldProvider | Test class
 | PrefetchData | Prefetch data container
 | PropertyStore | Defines the basic methods of a property store.
 | TemplateFileResolver | Represents a template file resolver.


CacheOptions Class

CacheOptions Class
Namespaces ► Sitecore.Data.DataProviders ► CacheOptions
Represents a set of cache options.
Declaration Syntax
C#
public class CacheOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CacheOptions()()() | Initializes a new instance of the CacheOptions class
 | DisableAll | Gets or sets a value indicating whether the CacheOptions disables all.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CacheOptions


CacheOptions Constructor

CacheOptions Constructor
Namespaces ► Sitecore.Data.DataProviders ► CacheOptions ► CacheOptions()()()
Initializes a new instance of the CacheOptions class
Declaration Syntax
C#
public CacheOptions()


DisableAll Property

DisableAll Property
Namespaces ► Sitecore.Data.DataProviders ► CacheOptions ► DisableAll
Gets or sets a value indicating whether the CacheOptions disables all.
Declaration Syntax
C#
public bool DisableAll { get; set; }
Value
true if the CacheOptions disables all; otherwise, false.


CallContext Class

CallContext Class
Namespaces ► Sitecore.Data.DataProviders ► CallContext
Represents a call context.
Declaration Syntax
C#
public class CallContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CallContext(DataManager, Int32) | Initializes a new instance of the CallContext class.
 | Abort()()() | Aborts this instance.
 | Aborted | Gets a value indicating whether this CallContext is aborted.
 | CurrentResult | Gets or sets the current result.
 | DataManager | Gets the data manager.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Index | Gets the index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProviderCount | Gets the provider count.
 | SetNextIndex(Int32) | Sets the index of the next.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CallContext


CallContext Constructor (manager, providerCount)

CallContext Constructor (manager, providerCount)
Namespaces ► Sitecore.Data.DataProviders ► CallContext ► CallContext(DataManager, Int32)
Initializes a new instance of the CallContext class.
Declaration Syntax
C#
public CallContext(
    DataManager manager,
    int providerCount
)
Parameters
manager (DataManager)
The manager.
providerCount (Int32)
The provider count.


Abort Method

Abort Method
Namespaces ► Sitecore.Data.DataProviders ► CallContext ► Abort()()()
Aborts this instance.
Declaration Syntax
C#
public void Abort()


Aborted Property

Aborted Property
Namespaces ► Sitecore.Data.DataProviders ► CallContext ► Aborted
Gets a value indicating whether this CallContext is aborted.
Declaration Syntax
C#
public bool Aborted { get; }
Value
true if aborted; otherwise, false.


CurrentResult Property

CurrentResult Property
Namespaces ► Sitecore.Data.DataProviders ► CallContext ► CurrentResult
Gets or sets the current result.
Declaration Syntax
C#
public Object CurrentResult { get; set; }
Value
The current result.


DataManager Property

DataManager Property
Namespaces ► Sitecore.Data.DataProviders ► CallContext ► DataManager
Gets the data manager.
Declaration Syntax
C#
public DataManager DataManager { get; }
Value
The data manager.


Index Property

Index Property
Namespaces ► Sitecore.Data.DataProviders ► CallContext ► Index
Gets the index.
Declaration Syntax
C#
public int Index { get; }
Value
The index.


ProviderCount Property

ProviderCount Property
Namespaces ► Sitecore.Data.DataProviders ► CallContext ► ProviderCount
Gets the provider count.
Declaration Syntax
C#
public int ProviderCount { get; }
Value
The provider count.


SetNextIndex Method (value)

SetNextIndex Method (value)
Namespaces ► Sitecore.Data.DataProviders ► CallContext ► SetNextIndex(Int32)
Sets the index of the next.
Declaration Syntax
C#
public void SetNextIndex(
    int value
)
Parameters
value (Int32)
The value.


DatabaseViewStateStore Class

DatabaseViewStateStore Class
Namespaces ► Sitecore.Data.DataProviders ► DatabaseViewStateStore
Serializes ViewState using the ClientContext.DataStore object.
Declaration Syntax
C#
public class DatabaseViewStateStore : IViewStateStore
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DatabaseViewStateStore()()() | Initializes a new instance of the DatabaseViewStateStore class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Load(String) | Loads viewstate data by the the specified key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes data that has the specified key.
 | Save(String, String) | Saves the viewstate data.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DatabaseViewStateStore


DatabaseViewStateStore Constructor

DatabaseViewStateStore Constructor
Namespaces ► Sitecore.Data.DataProviders ► DatabaseViewStateStore ► DatabaseViewStateStore()()()
Initializes a new instance of the DatabaseViewStateStore class
Declaration Syntax
C#
public DatabaseViewStateStore()


Load Method (key)

Load Method (key)
Namespaces ► Sitecore.Data.DataProviders ► DatabaseViewStateStore ► Load(String)
Loads viewstate data by the the specified key.
Declaration Syntax
C#
public string Load(
    string key
)
Parameters
key (String)
The key.
Return Value
The loaded data.


Remove Method (key)

Remove Method (key)
Namespaces ► Sitecore.Data.DataProviders ► DatabaseViewStateStore ► Remove(String)
Removes data that has the specified key.
Declaration Syntax
C#
public void Remove(
    string key
)
Parameters
key (String)
The key.


Save Method (key, viewstate)

Save Method (key, viewstate)
Namespaces ► Sitecore.Data.DataProviders ► DatabaseViewStateStore ► Save(String, String)
Saves the viewstate data.
Declaration Syntax
C#
public void Save(
    string key,
    string viewstate
)
Parameters
key (String)
The key.
viewstate (String)
The viewstate.


DataProvider Class

DataProvider Class
Namespaces ► Sitecore.Data.DataProviders ► DataProvider
DataProvider
Declaration Syntax
C#
public abstract class DataProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataProvider()()() | Initializes a new instance of the DataProvider class
 | AddToPublishQueue(ID, String, DateTime, CallContext) | Adds an item to the publish queue.
 | AddVersion(ItemDefinition, VersionUri, CallContext) | Adds a version to an item.
 | BlobStreamExists(Guid, CallContext) | Determines whether the specified field contains a BLOB value.
 | CacheOptions | Gets the cache options.
 | ChangeFieldSharing(TemplateField, TemplateFieldSharing, CallContext) | Changes the type of field sharing for a single field.
 | ChangeTemplate(ItemDefinition, TemplateChangeList, CallContext) | Changes the template of an item.
 | CleanupDatabase(CallContext) | Cleans up the database.
 | CleanupPublishQueue(DateTime, CallContext) | Cleans up the publish queue.
 | CopyItem(ItemDefinition, ItemDefinition, String, ID, CallContext) | Copies an item.
 | CreateItem(ID, String, ID, ItemDefinition, CallContext) | Creates a item.
 | DeleteItem(ItemDefinition, CallContext) | Deletes an item.
 | Disable | Disables a method.
 | DisableGroup | Disables a group.
 | Enable | Enables a method.
 | EnableGroup | Enables a group.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBlobStream(Guid, CallContext) | Gets the BLOB stream associated with a field.
 | GetChildIDs(ItemDefinition, CallContext) | Gets the child ids of an item.
 | GetDataSize(Int32, Int32) | Gets the size of the data managed by the provider.
 | GetDictionaryEntryCount()()() | Gets the number of dictionary entries.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemDefinition(ID, CallContext) | Gets the definition of an item.
 | GetItemFields(ItemDefinition, VersionUri, CallContext) | Gets the fields of a specific item version.
 | GetItemsInWorkflowState(WorkflowInfo, CallContext) | Gets all items that are in a specific workflow state.
 | GetItemVersions(ItemDefinition, CallContext) | Gets a list of the available versions of an item.
 | GetLanguages(CallContext) | Gets a list of all the language that have been defined in the database.
 | GetParentID(ItemDefinition, CallContext) | Gets the parent ID of an item.
 | GetProperty(String, CallContext) | Gets a property.
 | GetPropertyKeys(String, CallContext) | Gets a list of property keys matching a specific prefix.
 | GetPublishQueue(DateTime, DateTime, CallContext) | Gets the publish queue.
 | GetRootID(CallContext) | Gets the root ID.
 | GetTemplateItemIds(CallContext) | Gets the template item ids.
 | GetTemplates(CallContext) | Gets the templates.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWorkflowInfo(ItemDefinition, VersionUri, CallContext) | Gets the workflow info form an item.
 | HasChildren(ItemDefinition, CallContext) | Determines whether the specified item definition has children.
 | IsEnabled(String) | Determines whether the specified method is enabled.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveItem(ItemDefinition, ItemDefinition, CallContext) | Moves an item (ie. changes its parent).
 | RemoveLanguageData(Language, CallContext) | Removes a language and all the data using the language from the database.
 | RemoveProperty(String, Boolean, CallContext) | Removes a property.
 | RemoveVersion(ItemDefinition, VersionUri, CallContext) | Removes a version from an item.
 | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item.
 | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item.
 | RenameLanguageData(String, String, CallContext) | Renames a language binding.
 | ResolvePath(String, CallContext) | Resolves the path.
 | SaveItem(ItemDefinition, ItemChanges, CallContext) | Saves an item.
 | SelectIDs(String, CallContext) | Selects a set of ids.
 | SelectSingleID(String, CallContext) | Selects a single ID.
 | SetBlobStream(Stream, Guid, CallContext) | Sets the BLOB stream associated with a field.
 | SetProperty(String, String, CallContext) | Sets a property.
 | SetWorkflowInfo(ItemDefinition, VersionUri, WorkflowInfo, CallContext) | Sets the workflow info for an item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataProvider
 |  | FileSystemDataProvider
 |  | HelloWorldProvider
 |  | SqlDataProvider
 |  | TemplateFileResolver
 |  | SerializationTemplateProvider


DataProvider Constructor

DataProvider Constructor
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► DataProvider()()()
Initializes a new instance of the DataProvider class
Declaration Syntax
C#
protected DataProvider()


AddToPublishQueue Method (itemID, action, date, context)

AddToPublishQueue Method (itemID, action, date, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► AddToPublishQueue(ID, String, DateTime, CallContext)
Adds an item to the publish queue.
Declaration Syntax
C#
public virtual bool AddToPublishQueue(
    ID itemID,
    string action,
    DateTime date,
    CallContext context
)
Parameters
itemID (ID)
The item ID.
action (String)
The action.
date (DateTime)
The date.
context (CallContext)
The context.
Return Value


AddVersion Method (itemDefinition, baseVersion, context)

AddVersion Method (itemDefinition, baseVersion, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► AddVersion(ItemDefinition, VersionUri, CallContext)
Adds a version to an item.
Declaration Syntax
C#
public virtual int AddVersion(
    ItemDefinition itemDefinition,
    VersionUri baseVersion,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
baseVersion (VersionUri)
The base version.
context (CallContext)
The context.
Return Value


BlobStreamExists Method (blobId, context)

BlobStreamExists Method (blobId, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► BlobStreamExists(Guid, CallContext)
Determines whether the specified field contains a BLOB value.
Declaration Syntax
C#
public virtual bool BlobStreamExists(
    Guid blobId,
    CallContext context
)
Parameters
blobId (Guid)
The BLOB id.
context (CallContext)
The context.
Return Value
true if the specified item definition has children; otherwise, false.


CacheOptions Property

CacheOptions Property
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► CacheOptions
Gets the cache options.
Declaration Syntax
C#
public virtual CacheOptions CacheOptions { get; }
Value
The cache options.


ChangeFieldSharing Method (fieldDefinition, sharing, context)

ChangeFieldSharing Method (fieldDefinition, sharing, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► ChangeFieldSharing(TemplateField, TemplateFieldSharing, CallContext)
Changes the type of field sharing for a single field.
Declaration Syntax
C#
public virtual bool ChangeFieldSharing(
    TemplateField fieldDefinition,
    TemplateFieldSharing sharing,
    CallContext context
)
Parameters
fieldDefinition (TemplateField)
The field definition.
sharing (TemplateFieldSharing)
The new sharing type.
context (CallContext)
The context.
Return Value


ChangeTemplate Method (itemDefinition, changes, context)

ChangeTemplate Method (itemDefinition, changes, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► ChangeTemplate(ItemDefinition, TemplateChangeList, CallContext)
Changes the template of an item.
Declaration Syntax
C#
public virtual bool ChangeTemplate(
    ItemDefinition itemDefinition,
    TemplateChangeList changes,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
changes (TemplateChangeList)
The changes.
context (CallContext)
The context.
Return Value


CleanupDatabase Method (context)

CleanupDatabase Method (context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► CleanupDatabase(CallContext)
Cleans up the database.
Declaration Syntax
C#
public virtual bool CleanupDatabase(
    CallContext context
)
Parameters
context (CallContext)
Return Value
true if cleanup was performed; false otherwise.
Remarks

Typically, a cleanup operation will remove data in invalid languages and items in orphaned trees.

Specific operations depends on the actual data provider implementation.


CleanupPublishQueue Method (to, context)

CleanupPublishQueue Method (to, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► CleanupPublishQueue(DateTime, CallContext)
Cleans up the publish queue.
Declaration Syntax
C#
public virtual bool CleanupPublishQueue(
    DateTime to,
    CallContext context
)
Parameters
to (DateTime)
To.
context (CallContext)
The context.
Return Value


CopyItem Method (source, destination, copyName, copyID, context)

CopyItem Method (source, destination, copyName, copyID, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► CopyItem(ItemDefinition, ItemDefinition, String, ID, CallContext)
Copies an item.
Declaration Syntax
C#
public virtual bool CopyItem(
    ItemDefinition source,
    ItemDefinition destination,
    string copyName,
    ID copyID,
    CallContext context
)
Parameters
source (ItemDefinition)
The source.
destination (ItemDefinition)
The destination.
copyName (String)
Name of the copy.
copyID (ID)
The copy ID.
context (CallContext)
The context.
Return Value


CreateItem Method (itemID, itemName, templateID, parent, context)

CreateItem Method (itemID, itemName, templateID, parent, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► CreateItem(ID, String, ID, ItemDefinition, CallContext)
Creates a item.
Declaration Syntax
C#
public virtual bool CreateItem(
    ID itemID,
    string itemName,
    ID templateID,
    ItemDefinition parent,
    CallContext context
)
Parameters
itemID (ID)
The item ID.
itemName (String)
Name of the item.
templateID (ID)
The template ID.
parent (ItemDefinition)
The parent.
context (CallContext)
The context.
Return Value


DeleteItem Method (itemDefinition, context)

DeleteItem Method (itemDefinition, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► DeleteItem(ItemDefinition, CallContext)
Deletes an item.
Declaration Syntax
C#
public virtual bool DeleteItem(
    ItemDefinition itemDefinition,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
context (CallContext)
The context.
Return Value


Disable Property

Disable Property
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► Disable
Disables a method.
Declaration Syntax
C#
protected virtual string Disable { set; }
Value
The disable.


DisableGroup Property

DisableGroup Property
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► DisableGroup
Disables a group.
Declaration Syntax
C#
protected virtual string DisableGroup { set; }
Value
The disable group.


Enable Property

Enable Property
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► Enable
Enables a method.
Declaration Syntax
C#
protected virtual string Enable { set; }
Value
The enable.


EnableGroup Property

EnableGroup Property
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► EnableGroup
Enables a group.
Declaration Syntax
C#
protected virtual string EnableGroup { set; }
Value
The enable group.


GetBlobStream Method (blobId, context)

GetBlobStream Method (blobId, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetBlobStream(Guid, CallContext)
Gets the BLOB stream associated with a field.
Declaration Syntax
C#
public virtual Stream GetBlobStream(
    Guid blobId,
    CallContext context
)
Parameters
blobId (Guid)
The BLOB id.
context (CallContext)
The call context.
Return Value
The stream.


GetChildIDs Method (itemDefinition, context)

GetChildIDs Method (itemDefinition, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetChildIDs(ItemDefinition, CallContext)
Gets the child ids of an item.
Declaration Syntax
C#
public virtual IDList GetChildIDs(
    ItemDefinition itemDefinition,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
context (CallContext)
The context.
Return Value


GetDataSize Method (minEntitySize, maxEntitySize)

GetDataSize Method (minEntitySize, maxEntitySize)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetDataSize(Int32, Int32)
Gets the size of the data managed by the provider.
Declaration Syntax
C#
public virtual long GetDataSize(
    int minEntitySize,
    int maxEntitySize
)
Parameters
minEntitySize (Int32)
maxEntitySize (Int32)
Return Value


GetDictionaryEntryCount Method

GetDictionaryEntryCount Method
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetDictionaryEntryCount()()()
Gets the number of dictionary entries.
Declaration Syntax
C#
public virtual long GetDictionaryEntryCount()
Return Value
The number of dictionary entries.


GetItemDefinition Method (itemId, context)

GetItemDefinition Method (itemId, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetItemDefinition(ID, CallContext)
Gets the definition of an item.
Declaration Syntax
C#
public virtual ItemDefinition GetItemDefinition(
    ID itemId,
    CallContext context
)
Parameters
itemId (ID)
The item ID.
context (CallContext)
The context.
Return Value


GetItemFields Method (itemDefinition, versionUri, context)

GetItemFields Method (itemDefinition, versionUri, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetItemFields(ItemDefinition, VersionUri, CallContext)
Gets the fields of a specific item version.
Declaration Syntax
C#
public virtual FieldList GetItemFields(
    ItemDefinition itemDefinition,
    VersionUri versionUri,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item.
versionUri (VersionUri)
The version URI.
context (CallContext)
The context.
Return Value


GetItemsInWorkflowState Method (info, context)

GetItemsInWorkflowState Method (info, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetItemsInWorkflowState(WorkflowInfo, CallContext)
Gets all items that are in a specific workflow state.
Declaration Syntax
C#
public virtual DataUri[] GetItemsInWorkflowState(
    WorkflowInfo info,
    CallContext context
)
Parameters
info (WorkflowInfo)
The info.
context (CallContext)
The context.
Return Value


GetItemVersions Method (itemDefinition, context)

GetItemVersions Method (itemDefinition, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetItemVersions(ItemDefinition, CallContext)
Gets a list of the available versions of an item.
Declaration Syntax
C#
public virtual VersionUriList GetItemVersions(
    ItemDefinition itemDefinition,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item.
context (CallContext)
The context.
Return Value


GetLanguages Method (context)

GetLanguages Method (context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetLanguages(CallContext)
Gets a list of all the language that have been defined in the database.
Declaration Syntax
C#
public virtual LanguageCollection GetLanguages(
    CallContext context
)
Parameters
context (CallContext)
The context.
Return Value


GetParentID Method (itemDefinition, context)

GetParentID Method (itemDefinition, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetParentID(ItemDefinition, CallContext)
Gets the parent ID of an item.
Declaration Syntax
C#
public virtual ID GetParentID(
    ItemDefinition itemDefinition,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
context (CallContext)
The context.
Return Value


GetProperty Method (name, context)

GetProperty Method (name, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetProperty(String, CallContext)
Gets a property.
Declaration Syntax
C#
public virtual string GetProperty(
    string name,
    CallContext context
)
Parameters
name (String)
The name.
context (CallContext)
The context.
Return Value


GetPropertyKeys Method (prefix, context)

GetPropertyKeys Method (prefix, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetPropertyKeys(String, CallContext)
Gets a list of property keys matching a specific prefix.
Declaration Syntax
C#
public virtual List<string> GetPropertyKeys(
    string prefix,
    CallContext context
)
Parameters
prefix (String)
The prefix.
context (CallContext)
The context.
Return Value


GetPublishQueue Method (from, to, context)

GetPublishQueue Method (from, to, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetPublishQueue(DateTime, DateTime, CallContext)
Gets the publish queue.
Declaration Syntax
C#
public virtual IDList GetPublishQueue(
    DateTime from,
    DateTime to,
    CallContext context
)
Parameters
from (DateTime)
From.
to (DateTime)
To.
context (CallContext)
The context.
Return Value


GetRootID Method (context)

GetRootID Method (context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetRootID(CallContext)
Gets the root ID.
Declaration Syntax
C#
public virtual ID GetRootID(
    CallContext context
)
Parameters
context (CallContext)
The context.
Return Value


GetTemplateItemIds Method (context)

GetTemplateItemIds Method (context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetTemplateItemIds(CallContext)
Gets the template item ids.
Declaration Syntax
C#
public virtual IdCollection GetTemplateItemIds(
    CallContext context
)
Parameters
context (CallContext)
The context.
Return Value


GetTemplates Method (context)

GetTemplates Method (context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetTemplates(CallContext)
Gets the templates.
Declaration Syntax
C#
public virtual TemplateCollection GetTemplates(
    CallContext context
)
Parameters
context (CallContext)
The context.
Return Value


GetWorkflowInfo Method (item, version, context)

GetWorkflowInfo Method (item, version, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► GetWorkflowInfo(ItemDefinition, VersionUri, CallContext)
Gets the workflow info form an item.
Declaration Syntax
C#
public virtual WorkflowInfo GetWorkflowInfo(
    ItemDefinition item,
    VersionUri version,
    CallContext context
)
Parameters
item (ItemDefinition)
The item.
version (VersionUri)
The version.
context (CallContext)
The context.
Return Value


HasChildren Method (itemDefinition, context)

HasChildren Method (itemDefinition, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► HasChildren(ItemDefinition, CallContext)
Determines whether the specified item definition has children.
Declaration Syntax
C#
public virtual bool HasChildren(
    ItemDefinition itemDefinition,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
context (CallContext)
The context.
Return Value
true if the specified item definition has children; otherwise, false.


IsEnabled Method (methodName)

IsEnabled Method (methodName)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► IsEnabled(String)
Determines whether the specified method is enabled.
Declaration Syntax
C#
public bool IsEnabled(
    string methodName
)
Parameters
methodName (String)
Name of the method.
Return Value
true if the specified method name is enabled; otherwise, false.


MoveItem Method (itemDefinition, destination, context)

MoveItem Method (itemDefinition, destination, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► MoveItem(ItemDefinition, ItemDefinition, CallContext)
Moves an item (ie. changes its parent).
Declaration Syntax
C#
public virtual bool MoveItem(
    ItemDefinition itemDefinition,
    ItemDefinition destination,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
destination (ItemDefinition)
The destination.
context (CallContext)
The call context.
Return Value
True if the item was moved by the provider, false otherwise.


RemoveLanguageData Method (language, context)

RemoveLanguageData Method (language, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► RemoveLanguageData(Language, CallContext)
Removes a language and all the data using the language from the database.
Declaration Syntax
C#
public virtual void RemoveLanguageData(
    Language language,
    CallContext context
)
Parameters
language (Language)
The language.
context (CallContext)
The context.
Remarks
Proceeed with caution.


RemoveProperty Method (name, isPrefix, context)

RemoveProperty Method (name, isPrefix, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► RemoveProperty(String, Boolean, CallContext)
Removes a property.
Declaration Syntax
C#
public virtual bool RemoveProperty(
    string name,
    bool isPrefix,
    CallContext context
)
Parameters
name (String)
The name.
isPrefix (Boolean)
if set to true this instance is is prefix.
context (CallContext)
The context.
Return Value


RemoveVersion Method (itemDefinition, version, context)

RemoveVersion Method (itemDefinition, version, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► RemoveVersion(ItemDefinition, VersionUri, CallContext)
Removes a version from an item.
Declaration Syntax
C#
public virtual bool RemoveVersion(
    ItemDefinition itemDefinition,
    VersionUri version,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
version (VersionUri)
The version.
context (CallContext)
The context.
Return Value


RemoveVersions Method

RemoveVersions Method
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► RemoveVersions()()()
Members
Icon | Member | Description
 | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item.
 | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item.


RemoveVersions Method (itemDefinition, language, context)

RemoveVersions Method (itemDefinition, language, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► RemoveVersions(ItemDefinition, Language, CallContext)
Removes versions from an item.
Declaration Syntax
C#
public virtual bool RemoveVersions(
    ItemDefinition itemDefinition,
    Language language,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
language (Language)
The language.
context (CallContext)
The context.
Return Value


RemoveVersions Method (itemDefinition, language, removeSharedData, context)

RemoveVersions Method (itemDefinition, language, removeSharedData, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► RemoveVersions(ItemDefinition, Language, Boolean, CallContext)
Removes versions from an item.
Declaration Syntax
C#
public virtual bool RemoveVersions(
    ItemDefinition itemDefinition,
    Language language,
    bool removeSharedData,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
language (Language)
The language.
removeSharedData (Boolean)
If set to true shared data is removed.
context (CallContext)
The context.
Return Value


RenameLanguageData Method (fromLanguage, toLanguage, context)

RenameLanguageData Method (fromLanguage, toLanguage, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► RenameLanguageData(String, String, CallContext)
Renames a language binding.
Declaration Syntax
C#
public virtual void RenameLanguageData(
    string fromLanguage,
    string toLanguage,
    CallContext context
)
Parameters
fromLanguage (String)
Rename from this language name.
toLanguage (String)
Rename to this language name.
context (CallContext)
The context.


ResolvePath Method (itemPath, context)

ResolvePath Method (itemPath, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► ResolvePath(String, CallContext)
Resolves the path.
Declaration Syntax
C#
public virtual ID ResolvePath(
    string itemPath,
    CallContext context
)
Parameters
itemPath (String)
The item path.
context (CallContext)
The context.
Return Value


SaveItem Method (itemDefinition, changes, context)

SaveItem Method (itemDefinition, changes, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► SaveItem(ItemDefinition, ItemChanges, CallContext)
Saves an item.
Declaration Syntax
C#
public virtual bool SaveItem(
    ItemDefinition itemDefinition,
    ItemChanges changes,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
changes (ItemChanges)
The changes.
context (CallContext)
The context.
Return Value


SelectIDs Method (query, context)

SelectIDs Method (query, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► SelectIDs(String, CallContext)
Selects a set of ids.
Declaration Syntax
C#
public virtual IDList SelectIDs(
    string query,
    CallContext context
)
Parameters
query (String)
The query.
context (CallContext)
The context.
Return Value


SelectSingleID Method (query, context)

SelectSingleID Method (query, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► SelectSingleID(String, CallContext)
Selects a single ID.
Declaration Syntax
C#
public virtual ID SelectSingleID(
    string query,
    CallContext context
)
Parameters
query (String)
The query.
context (CallContext)
The context.
Return Value


SetBlobStream Method (stream, blobId, context)

SetBlobStream Method (stream, blobId, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► SetBlobStream(Stream, Guid, CallContext)
Sets the BLOB stream associated with a field.
Declaration Syntax
C#
public virtual bool SetBlobStream(
    Stream stream,
    Guid blobId,
    CallContext context
)
Parameters
stream (Stream)
The stream.
blobId (Guid)
The BLOB id.
context (CallContext)
The call context.
Return Value


SetProperty Method (name, value, context)

SetProperty Method (name, value, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► SetProperty(String, String, CallContext)
Sets a property.
Declaration Syntax
C#
public virtual bool SetProperty(
    string name,
    string value,
    CallContext context
)
Parameters
name (String)
The name.
value (String)
The value.
context (CallContext)
The context.
Return Value


SetWorkflowInfo Method (item, version, info, context)

SetWorkflowInfo Method (item, version, info, context)
Namespaces ► Sitecore.Data.DataProviders ► DataProvider ► SetWorkflowInfo(ItemDefinition, VersionUri, WorkflowInfo, CallContext)
Sets the workflow info for an item.
Declaration Syntax
C#
public virtual bool SetWorkflowInfo(
    ItemDefinition item,
    VersionUri version,
    WorkflowInfo info,
    CallContext context
)
Parameters
item (ItemDefinition)
The item.
version (VersionUri)
The version.
info (WorkflowInfo)
The info.
context (CallContext)
The context.
Return Value


FileSystemDataProvider Class

FileSystemDataProvider Class
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider
Represents a file system data provider.
Declaration Syntax
C#
public class FileSystemDataProvider : DataProvider
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileSystemDataProvider()()() | Initializes a new instance of the FileSystemDataProvider class.
 | AddToPublishQueue(ID, String, DateTime, CallContext) | Adds an item to the publish queue. (Inherited from DataProvider.)
 | AddVersion(ItemDefinition, VersionUri, CallContext) | Adds a version to an item. (Inherited from DataProvider.)
 | BlobStreamExists(Guid, CallContext) | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
 | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
 | ChangeFieldSharing(TemplateField, TemplateFieldSharing, CallContext) | Changes the type of field sharing for a single field. (Inherited from DataProvider.)
 | ChangeTemplate(ItemDefinition, TemplateChangeList, CallContext) | Changes the template of an item. (Inherited from DataProvider.)
 | CleanupDatabase(CallContext) | Cleans up the database. (Inherited from DataProvider.)
 | CleanupPublishQueue(DateTime, CallContext) | Cleans up the publish queue. (Inherited from DataProvider.)
 | CopyItem(ItemDefinition, ItemDefinition, String, ID, CallContext) | Copies an item. (Inherited from DataProvider.)
 | CreateItem(ID, String, ID, ItemDefinition, CallContext) | Creates a item. (Inherited from DataProvider.)
 | DataFolderName | Data folder
 | DeleteItem(ItemDefinition, CallContext) | Deletes an item. (Inherited from DataProvider.)
 | Disable | Disables a method. (Inherited from DataProvider.)
 | DisableGroup | Disables a group. (Inherited from DataProvider.)
 | Enable | Enables a method. (Inherited from DataProvider.)
 | EnableGroup | Enables a group. (Inherited from DataProvider.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileID |
 | FileModifiedID |
 | FilePathID |
 | FileSizeID |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FolderID |
 | FolderPathID |
 | GetBlobStream(Guid, CallContext) | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
 | GetChildIDs(ItemDefinition, CallContext) | Gets the child ids of an item. (Overrides DataProvider.GetChildIDs(ItemDefinition, CallContext).)
 | GetChildIDs(ID, Boolean) | Gets the child I ds.
 | GetDataSize(Int32, Int32) | Gets the size of the data managed by the provider. (Inherited from DataProvider.)
 | GetDictionaryEntryCount()()() | Gets the number of dictionary entries. (Inherited from DataProvider.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemDefinition(ID, CallContext) | Gets the definition of an item. (Overrides DataProvider.GetItemDefinition(ID, CallContext).)
 | GetItemFields(ItemDefinition, VersionUri, CallContext) | Gets the item fields. (Overrides DataProvider.GetItemFields(ItemDefinition, VersionUri, CallContext).)
 | GetItemsInWorkflowState(WorkflowInfo, CallContext) | Gets all items that are in a specific workflow state. (Inherited from DataProvider.)
 | GetItemVersions(ItemDefinition, CallContext) | Gets a list of the available versions of an item. (Inherited from DataProvider.)
 | GetLanguages(CallContext) | Gets a list of all the language that have been defined in the database. (Inherited from DataProvider.)
 | GetParentID(ItemDefinition, CallContext) | Gets the parent ID of an item. (Overrides DataProvider.GetParentID(ItemDefinition, CallContext).)
 | GetProperty(String, CallContext) | Gets a property. (Inherited from DataProvider.)
 | GetPropertyKeys(String, CallContext) | Gets a list of property keys matching a specific prefix. (Inherited from DataProvider.)
 | GetPublishQueue(DateTime, DateTime, CallContext) | Gets the publish queue. (Inherited from DataProvider.)
 | GetRootID()()() | Gets the root ID.
 | GetRootID(CallContext) | Gets the root ID. (Overrides DataProvider.GetRootID(CallContext).)
 | GetTemplateItemIds(CallContext) | Gets the template item ids. (Inherited from DataProvider.)
 | GetTemplates(CallContext) | Gets the templates. (Overrides DataProvider.GetTemplates(CallContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWorkflowInfo(ItemDefinition, VersionUri, CallContext) | Gets the workflow info form an item. (Inherited from DataProvider.)
 | HasChildren(ItemDefinition, CallContext) | Determines whether the specified item definition has children. (Inherited from DataProvider.)
 | IncludeRelocatedFolders | Gets or sets a value indicating whether relocated folders will be included.
 | IsEnabled(String) | Determines whether the specified method is enabled. (Inherited from DataProvider.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveItem(ItemDefinition, ItemDefinition, CallContext) | Moves an item (ie. changes its parent). (Inherited from DataProvider.)
 | RemoveLanguageData(Language, CallContext) | Removes a language and all the data using the language from the database. (Inherited from DataProvider.)
 | RemoveProperty(String, Boolean, CallContext) | Removes a property. (Inherited from DataProvider.)
 | RemoveVersion(ItemDefinition, VersionUri, CallContext) | Removes a version from an item. (Inherited from DataProvider.)
 | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
 | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
 | RenameLanguageData(String, String, CallContext) | Renames a language binding. (Inherited from DataProvider.)
 | ResolvePath(String, CallContext) | Resolves the path. (Overrides DataProvider.ResolvePath(String, CallContext).)
 | ResolvePath(String) | Resolves the path.
 | SaveItem(ItemDefinition, ItemChanges, CallContext) | Saves an item. (Inherited from DataProvider.)
 | SelectIDs(String, CallContext) | Selects a set of ids. (Inherited from DataProvider.)
 | SelectSingleID(String, CallContext) | Selects a single ID. (Inherited from DataProvider.)
 | SetBlobStream(Stream, Guid, CallContext) | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
 | SetProperty(String, String, CallContext) | Sets a property. (Inherited from DataProvider.)
 | SetWorkflowInfo(ItemDefinition, VersionUri, WorkflowInfo, CallContext) | Sets the workflow info for an item. (Inherited from DataProvider.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataProvider
 |  | FileSystemDataProvider


FileSystemDataProvider Constructor

FileSystemDataProvider Constructor
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► FileSystemDataProvider()()()
Initializes a new instance of the FileSystemDataProvider class.
Declaration Syntax
C#
public FileSystemDataProvider()


DataFolderName Field

DataFolderName Field
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► DataFolderName
Data folder
Declaration Syntax
C#
public static readonly string DataFolderName


FileID Field

FileID Field
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► FileID
Declaration Syntax
C#
public static readonly ID FileID


FileModifiedID Field

FileModifiedID Field
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► FileModifiedID
Declaration Syntax
C#
public static readonly ID FileModifiedID


FilePathID Field

FilePathID Field
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► FilePathID
Declaration Syntax
C#
public static readonly ID FilePathID


FileSizeID Field

FileSizeID Field
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► FileSizeID
Declaration Syntax
C#
public static readonly ID FileSizeID


FolderID Field

FolderID Field
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► FolderID
Declaration Syntax
C#
public static readonly ID FolderID


FolderPathID Field

FolderPathID Field
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► FolderPathID
Declaration Syntax
C#
public static readonly ID FolderPathID


GetChildIDs Method

GetChildIDs Method
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► GetChildIDs()()()
Members
Icon | Member | Description
 | GetChildIDs(ItemDefinition, CallContext) | Gets the child ids of an item. (Overrides DataProvider.GetChildIDs(ItemDefinition, CallContext).)
 | GetChildIDs(ID, Boolean) | Gets the child I ds.


GetChildIDs Method (itemID, forseIncludeRelocated)

GetChildIDs Method (itemID, forseIncludeRelocated)
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► GetChildIDs(ID, Boolean)
Gets the child I ds.
Declaration Syntax
C#
public IDList GetChildIDs(
    ID itemID,
    bool forseIncludeRelocated
)
Parameters
itemID (ID)
The item ID.
forseIncludeRelocated (Boolean)
if set to true [forse include relocated].
Return Value
The child I ds.


GetChildIDs Method (itemDefinition, context)

GetChildIDs Method (itemDefinition, context)
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► GetChildIDs(ItemDefinition, CallContext)
Gets the child ids of an item.
Declaration Syntax
C#
public override IDList GetChildIDs(
    ItemDefinition itemDefinition,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
context (CallContext)
The context.
Return Value


GetItemDefinition Method (itemId, context)

GetItemDefinition Method (itemId, context)
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► GetItemDefinition(ID, CallContext)
Gets the definition of an item.
Declaration Syntax
C#
public override ItemDefinition GetItemDefinition(
    ID itemId,
    CallContext context
)
Parameters
itemId (ID)
The item ID.
context (CallContext)
The context.
Return Value


GetItemFields Method (itemDefinition, version, context)

GetItemFields Method (itemDefinition, version, context)
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► GetItemFields(ItemDefinition, VersionUri, CallContext)
Gets the item fields.
Declaration Syntax
C#
public override FieldList GetItemFields(
    ItemDefinition itemDefinition,
    VersionUri version,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
version (VersionUri)
The version.
context (CallContext)
The context.
Return Value
The item fields.


GetParentID Method (itemDefinition, context)

GetParentID Method (itemDefinition, context)
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► GetParentID(ItemDefinition, CallContext)
Gets the parent ID of an item.
Declaration Syntax
C#
public override ID GetParentID(
    ItemDefinition itemDefinition,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
context (CallContext)
The context.
Return Value


GetRootID Method

GetRootID Method
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► GetRootID()()()
Members
Icon | Member | Description
 | GetRootID()()() | Gets the root ID.
 | GetRootID(CallContext) | Gets the root ID. (Overrides DataProvider.GetRootID(CallContext).)


GetRootID Method

GetRootID Method
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► GetRootID()()()
Gets the root ID.
Declaration Syntax
C#
public ID GetRootID()
Return Value


GetRootID Method (context)

GetRootID Method (context)
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► GetRootID(CallContext)
Gets the root ID.
Declaration Syntax
C#
public override ID GetRootID(
    CallContext context
)
Parameters
context (CallContext)
The context.
Return Value


GetTemplates Method (context)

GetTemplates Method (context)
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► GetTemplates(CallContext)
Gets the templates.
Declaration Syntax
C#
public override TemplateCollection GetTemplates(
    CallContext context
)
Parameters
context (CallContext)
The context.
Return Value


IncludeRelocatedFolders Property

IncludeRelocatedFolders Property
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► IncludeRelocatedFolders
Gets or sets a value indicating whether relocated folders will be included.
Declaration Syntax
C#
public bool IncludeRelocatedFolders { get; set; }
Value
true if include relocated folders are included; otherwise, false.


ResolvePath Method

ResolvePath Method
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► ResolvePath()()()
Members
Icon | Member | Description
 | ResolvePath(String, CallContext) | Resolves the path. (Overrides DataProvider.ResolvePath(String, CallContext).)
 | ResolvePath(String) | Resolves the path.


ResolvePath Method (path)

ResolvePath Method (path)
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► ResolvePath(String)
Resolves the path.
Declaration Syntax
C#
public ID ResolvePath(
    string path
)
Parameters
path (String)
The path.
Return Value
The path.


ResolvePath Method (itemPath, context)

ResolvePath Method (itemPath, context)
Namespaces ► Sitecore.Data.DataProviders ► FileSystemDataProvider ► ResolvePath(String, CallContext)
Resolves the path.
Declaration Syntax
C#
public override ID ResolvePath(
    string itemPath,
    CallContext context
)
Parameters
itemPath (String)
The item path.
context (CallContext)
The context.
Return Value


HelloWorldProvider Class

HelloWorldProvider Class
Namespaces ► Sitecore.Data.DataProviders ► HelloWorldProvider
Test class
Declaration Syntax
C#
public class HelloWorldProvider : DataProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HelloWorldProvider()()() | Initializes a new instance of the HelloWorldProvider class
 | AddToPublishQueue(ID, String, DateTime, CallContext) | Adds an item to the publish queue. (Inherited from DataProvider.)
 | AddVersion(ItemDefinition, VersionUri, CallContext) | Adds a version to an item. (Inherited from DataProvider.)
 | BlobStreamExists(Guid, CallContext) | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
 | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
 | ChangeFieldSharing(TemplateField, TemplateFieldSharing, CallContext) | Changes the type of field sharing for a single field. (Inherited from DataProvider.)
 | ChangeTemplate(ItemDefinition, TemplateChangeList, CallContext) | Changes the template of an item. (Inherited from DataProvider.)
 | CleanupDatabase(CallContext) | Cleans up the database. (Inherited from DataProvider.)
 | CleanupPublishQueue(DateTime, CallContext) | Cleans up the publish queue. (Inherited from DataProvider.)
 | CopyItem(ItemDefinition, ItemDefinition, String, ID, CallContext) | Copies an item. (Inherited from DataProvider.)
 | CreateItem(ID, String, ID, ItemDefinition, CallContext) | Creates a item. (Inherited from DataProvider.)
 | DeleteItem(ItemDefinition, CallContext) | Deletes an item. (Inherited from DataProvider.)
 | Disable | Disables a method. (Inherited from DataProvider.)
 | DisableGroup | Disables a group. (Inherited from DataProvider.)
 | Enable | Enables a method. (Inherited from DataProvider.)
 | EnableGroup | Enables a group. (Inherited from DataProvider.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBlobStream(Guid, CallContext) | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
 | GetChildIDs(ItemDefinition, CallContext) | Gets the child ids of an item. (Inherited from DataProvider.)
 | GetDataSize(Int32, Int32) | Gets the size of the data managed by the provider. (Inherited from DataProvider.)
 | GetDictionaryEntryCount()()() | Gets the number of dictionary entries. (Inherited from DataProvider.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemDefinition(ID, CallContext) | Gets the item definition. (Overrides DataProvider.GetItemDefinition(ID, CallContext).)
 | GetItemFields(ItemDefinition, VersionUri, CallContext) | Gets the item fields. (Overrides DataProvider.GetItemFields(ItemDefinition, VersionUri, CallContext).)
 | GetItemsInWorkflowState(WorkflowInfo, CallContext) | Gets all items that are in a specific workflow state. (Inherited from DataProvider.)
 | GetItemVersions(ItemDefinition, CallContext) | Gets a list of the available versions of an item. (Inherited from DataProvider.)
 | GetLanguages(CallContext) | Gets a list of all the language that have been defined in the database. (Inherited from DataProvider.)
 | GetParentID(ItemDefinition, CallContext) | Gets the parent ID of an item. (Inherited from DataProvider.)
 | GetProperty(String, CallContext) | Gets a property. (Inherited from DataProvider.)
 | GetPropertyKeys(String, CallContext) | Gets a list of property keys matching a specific prefix. (Inherited from DataProvider.)
 | GetPublishQueue(DateTime, DateTime, CallContext) | Gets the publish queue. (Inherited from DataProvider.)
 | GetRootID(CallContext) | Gets the root ID. (Inherited from DataProvider.)
 | GetTemplateItemIds(CallContext) | Gets the template item ids. (Inherited from DataProvider.)
 | GetTemplates(CallContext) | Gets the templates. (Overrides DataProvider.GetTemplates(CallContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWorkflowInfo(ItemDefinition, VersionUri, CallContext) | Gets the workflow info form an item. (Inherited from DataProvider.)
 | HasChildren(ItemDefinition, CallContext) | Determines whether the specified item definition has children. (Inherited from DataProvider.)
 | IsEnabled(String) | Determines whether the specified method is enabled. (Inherited from DataProvider.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveItem(ItemDefinition, ItemDefinition, CallContext) | Moves an item (ie. changes its parent). (Inherited from DataProvider.)
 | RemoveLanguageData(Language, CallContext) | Removes a language and all the data using the language from the database. (Inherited from DataProvider.)
 | RemoveProperty(String, Boolean, CallContext) | Removes a property. (Inherited from DataProvider.)
 | RemoveVersion(ItemDefinition, VersionUri, CallContext) | Removes a version from an item. (Inherited from DataProvider.)
 | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
 | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
 | RenameLanguageData(String, String, CallContext) | Renames a language binding. (Inherited from DataProvider.)
 | ResolvePath(String, CallContext) | Resolves the path. (Inherited from DataProvider.)
 | SaveItem(ItemDefinition, ItemChanges, CallContext) | Saves an item. (Inherited from DataProvider.)
 | SelectIDs(String, CallContext) | Selects a set of ids. (Inherited from DataProvider.)
 | SelectSingleID(String, CallContext) | Selects a single ID. (Inherited from DataProvider.)
 | SetBlobStream(Stream, Guid, CallContext) | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
 | SetProperty(String, String, CallContext) | Sets a property. (Inherited from DataProvider.)
 | SetWorkflowInfo(ItemDefinition, VersionUri, WorkflowInfo, CallContext) | Sets the workflow info for an item. (Inherited from DataProvider.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataProvider
 |  | HelloWorldProvider


HelloWorldProvider Constructor

HelloWorldProvider Constructor
Namespaces ► Sitecore.Data.DataProviders ► HelloWorldProvider ► HelloWorldProvider()()()
Initializes a new instance of the HelloWorldProvider class
Declaration Syntax
C#
public HelloWorldProvider()


GetItemDefinition Method (itemId, context)

GetItemDefinition Method (itemId, context)
Namespaces ► Sitecore.Data.DataProviders ► HelloWorldProvider ► GetItemDefinition(ID, CallContext)
Gets the item definition.
Declaration Syntax
C#
public override ItemDefinition GetItemDefinition(
    ID itemId,
    CallContext context
)
Parameters
itemId (ID)
The item ID.
context (CallContext)
The context.
Return Value


GetItemFields Method (item, version, context)

GetItemFields Method (item, version, context)
Namespaces ► Sitecore.Data.DataProviders ► HelloWorldProvider ► GetItemFields(ItemDefinition, VersionUri, CallContext)
Gets the item fields.
Declaration Syntax
C#
public override FieldList GetItemFields(
    ItemDefinition item,
    VersionUri version,
    CallContext context
)
Parameters
item (ItemDefinition)
The item.
version (VersionUri)
The version.
context (CallContext)
The context.
Return Value


GetTemplates Method (context)

GetTemplates Method (context)
Namespaces ► Sitecore.Data.DataProviders ► HelloWorldProvider ► GetTemplates(CallContext)
Gets the templates.
Declaration Syntax
C#
public override TemplateCollection GetTemplates(
    CallContext context
)
Parameters
context (CallContext)
The context.
Return Value


PrefetchData Class

PrefetchData Class
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData
Prefetch data container
Declaration Syntax
C#
public class PrefetchData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PrefetchData(ItemDefinition, ID) | Initializes a new instance of the PrefetchData class.
 | AddChildId(ID) | Adds the child id.
 | AddField(String, Int32, ID, String) | Adds a field.
 | AddSharedField(ID, String) | Adds a shared field.
 | AddUnversionedField(String, ID, String) | Adds an unversioned field.
 | AddVersionedField(String, Int32, ID, String) | Adds a versioned field.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildIds()()() | Gets the child ids.
 | GetDataLength()()() | Gets the size of the data to use when caching.
 | GetFieldList(String, Int32) | Gets a field list.
 | GetFieldList(String, Int32, Boolean) | Gets a field list.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSharedFields()()() | Gets the shared fields.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersionUris()()() | Gets the version uris.
 | InitializeFieldLists(LanguageCollection) | Initializes the field lists.
 | ItemDefinition | Gets or sets the item definition.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentId | Gets or sets the parent id.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PrefetchData


PrefetchData Constructor (itemDefinition, parentId)

PrefetchData Constructor (itemDefinition, parentId)
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► PrefetchData(ItemDefinition, ID)
Initializes a new instance of the PrefetchData class.
Declaration Syntax
C#
public PrefetchData(
    ItemDefinition itemDefinition,
    ID parentId
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
parentId (ID)
The parent id.


AddChildId Method (childId)

AddChildId Method (childId)
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► AddChildId(ID)
Adds the child id.
Declaration Syntax
C#
public void AddChildId(
    ID childId
)
Parameters
childId (ID)
The child id.


AddField Method (language, version, fieldId, value)

AddField Method (language, version, fieldId, value)
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► AddField(String, Int32, ID, String)
Adds a field.
Declaration Syntax
C#
public void AddField(
    string language,
    int version,
    ID fieldId,
    string value
)
Parameters
language (String)
The language.
version (Int32)
The version.
fieldId (ID)
The field id.
value (String)
The value.


AddSharedField Method (fieldId, value)

AddSharedField Method (fieldId, value)
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► AddSharedField(ID, String)
Adds a shared field.
Declaration Syntax
C#
public void AddSharedField(
    ID fieldId,
    string value
)
Parameters
fieldId (ID)
The field id.
value (String)
The value.


AddUnversionedField Method (language, fieldId, value)

AddUnversionedField Method (language, fieldId, value)
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► AddUnversionedField(String, ID, String)
Adds an unversioned field.
Declaration Syntax
C#
public void AddUnversionedField(
    string language,
    ID fieldId,
    string value
)
Parameters
language (String)
The language.
fieldId (ID)
The field id.
value (String)
The value.


AddVersionedField Method (language, version, fieldId, value)

AddVersionedField Method (language, version, fieldId, value)
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► AddVersionedField(String, Int32, ID, String)
Adds a versioned field.
Declaration Syntax
C#
public void AddVersionedField(
    string language,
    int version,
    ID fieldId,
    string value
)
Parameters
language (String)
The language.
version (Int32)
The version.
fieldId (ID)
The field id.
value (String)
The value.


GetChildIds Method

GetChildIds Method
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► GetChildIds()()()
Gets the child ids.
Declaration Syntax
C#
public IDList GetChildIds()
Value
The child ids.


GetDataLength Method

GetDataLength Method
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► GetDataLength()()()
Gets the size of the data to use when caching.
Declaration Syntax
C#
public long GetDataLength()
Return Value


GetFieldList Method

GetFieldList Method
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► GetFieldList()()()
Members
Icon | Member | Description
 | GetFieldList(String, Int32) | Gets a field list.
 | GetFieldList(String, Int32, Boolean) | Gets a field list.


GetFieldList Method (language, version)

GetFieldList Method (language, version)
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► GetFieldList(String, Int32)
Gets a field list.
Declaration Syntax
C#
public FieldList GetFieldList(
    string language,
    int version
)
Parameters
language (String)
The language.
version (Int32)
The version.
Return Value


GetFieldList Method (language, version, force)

GetFieldList Method (language, version, force)
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► GetFieldList(String, Int32, Boolean)
Gets a field list.
Declaration Syntax
C#
public FieldList GetFieldList(
    string language,
    int version,
    bool force
)
Parameters
language (String)
The language.
version (Int32)
The version.
force (Boolean)
If set to true create the list if it does not exist.
Return Value


GetSharedFields Method

GetSharedFields Method
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► GetSharedFields()()()
Gets the shared fields.
Declaration Syntax
C#
public FieldList GetSharedFields()
Return Value


GetVersionUris Method

GetVersionUris Method
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► GetVersionUris()()()
Gets the version uris.
Declaration Syntax
C#
public VersionUriList GetVersionUris()
Value
The version uris.


InitializeFieldLists Method (languages)

InitializeFieldLists Method (languages)
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► InitializeFieldLists(LanguageCollection)
Initializes the field lists.
Declaration Syntax
C#
public void InitializeFieldLists(
    LanguageCollection languages
)
Parameters
languages (LanguageCollection)
The languages.


ItemDefinition Property

ItemDefinition Property
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► ItemDefinition
Gets or sets the item definition.
Declaration Syntax
C#
public ItemDefinition ItemDefinition { get; }
Value
The item definition.


ParentId Property

ParentId Property
Namespaces ► Sitecore.Data.DataProviders ► PrefetchData ► ParentId
Gets or sets the parent id.
Declaration Syntax
C#
public ID ParentId { get; }
Value
The parent id.


PropertyStore Class

PropertyStore Class
Namespaces ► Sitecore.Data.DataProviders ► PropertyStore
Defines the basic methods of a property store.
Declaration Syntax
C#
public abstract class PropertyStore
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PropertyStore()()() | Initializes a new instance of the PropertyStore class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(String, String, String) | Gets the string.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PropertyStore


PropertyStore Constructor

PropertyStore Constructor
Namespaces ► Sitecore.Data.DataProviders ► PropertyStore ► PropertyStore()()()
Initializes a new instance of the PropertyStore class
Declaration Syntax
C#
protected PropertyStore()


GetString Method (key, keyField, valueField)

GetString Method (key, keyField, valueField)
Namespaces ► Sitecore.Data.DataProviders ► PropertyStore ► GetString(String, String, String)
Gets the string.
Declaration Syntax
C#
public abstract string GetString(
    string key,
    string keyField,
    string valueField
)
Parameters
key (String)
The key.
keyField (String)
The key field.
valueField (String)
The value field.
Return Value
The string.


TemplateFileResolver Class

TemplateFileResolver Class
Namespaces ► Sitecore.Data.DataProviders ► TemplateFileResolver
Represents a template file resolver.
Declaration Syntax
C#
public class TemplateFileResolver : DataProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateFileResolver(String) | Creates a new TemplateFileResolver instance.
 | AbortChain | Gets or sets a value indicating whether the TemplateFileResolver aborts the chain.
 | AddToPublishQueue(ID, String, DateTime, CallContext) | Adds an item to the publish queue. (Inherited from DataProvider.)
 | AddVersion(ItemDefinition, VersionUri, CallContext) | Adds a version to an item. (Inherited from DataProvider.)
 | BlobStreamExists(Guid, CallContext) | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
 | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
 | ChangeFieldSharing(TemplateField, TemplateFieldSharing, CallContext) | Changes the type of field sharing for a single field. (Inherited from DataProvider.)
 | ChangeTemplate(ItemDefinition, TemplateChangeList, CallContext) | Changes the template of an item. (Inherited from DataProvider.)
 | CleanupDatabase(CallContext) | Cleans up the database. (Inherited from DataProvider.)
 | CleanupPublishQueue(DateTime, CallContext) | Cleans up the publish queue. (Inherited from DataProvider.)
 | CopyItem(ItemDefinition, ItemDefinition, String, ID, CallContext) | Copies an item. (Inherited from DataProvider.)
 | CreateItem(ID, String, ID, ItemDefinition, CallContext) | Creates a item. (Inherited from DataProvider.)
 | DeleteItem(ItemDefinition, CallContext) | Deletes an item. (Inherited from DataProvider.)
 | Disable | Disables a method. (Inherited from DataProvider.)
 | DisableGroup | Disables a group. (Inherited from DataProvider.)
 | Enable | Enables a method. (Inherited from DataProvider.)
 | EnableGroup | Enables a group. (Inherited from DataProvider.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBlobStream(Guid, CallContext) | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
 | GetChildIDs(ItemDefinition, CallContext) | Gets the child ids of an item. (Inherited from DataProvider.)
 | GetDataSize(Int32, Int32) | Gets the size of the data managed by the provider. (Inherited from DataProvider.)
 | GetDictionaryEntryCount()()() | Gets the number of dictionary entries. (Inherited from DataProvider.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemDefinition(ID, CallContext) | Gets the definition of an item. (Inherited from DataProvider.)
 | GetItemFields(ItemDefinition, VersionUri, CallContext) | Gets the fields of a specific item version. (Inherited from DataProvider.)
 | GetItemsInWorkflowState(WorkflowInfo, CallContext) | Gets all items that are in a specific workflow state. (Inherited from DataProvider.)
 | GetItemVersions(ItemDefinition, CallContext) | Gets a list of the available versions of an item. (Inherited from DataProvider.)
 | GetLanguages(CallContext) | Gets a list of all the language that have been defined in the database. (Inherited from DataProvider.)
 | GetParentID(ItemDefinition, CallContext) | Gets the parent ID of an item. (Inherited from DataProvider.)
 | GetProperty(String, CallContext) | Gets a property. (Inherited from DataProvider.)
 | GetPropertyKeys(String, CallContext) | Gets a list of property keys matching a specific prefix. (Inherited from DataProvider.)
 | GetPublishQueue(DateTime, DateTime, CallContext) | Gets the publish queue. (Inherited from DataProvider.)
 | GetRootID(CallContext) | Gets the root ID. (Inherited from DataProvider.)
 | GetTemplateItemIds(CallContext) | Gets the template item ids. (Inherited from DataProvider.)
 | GetTemplates(CallContext) | Gets the templates. (Overrides DataProvider.GetTemplates(CallContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWorkflowInfo(ItemDefinition, VersionUri, CallContext) | Gets the workflow info form an item. (Inherited from DataProvider.)
 | HasChildren(ItemDefinition, CallContext) | Determines whether the specified item definition has children. (Inherited from DataProvider.)
 | IsEnabled(String) | Determines whether the specified method is enabled. (Inherited from DataProvider.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveItem(ItemDefinition, ItemDefinition, CallContext) | Moves an item (ie. changes its parent). (Inherited from DataProvider.)
 | RemoveLanguageData(Language, CallContext) | Removes a language and all the data using the language from the database. (Inherited from DataProvider.)
 | RemoveProperty(String, Boolean, CallContext) | Removes a property. (Inherited from DataProvider.)
 | RemoveVersion(ItemDefinition, VersionUri, CallContext) | Removes a version from an item. (Inherited from DataProvider.)
 | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
 | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
 | RenameLanguageData(String, String, CallContext) | Renames a language binding. (Inherited from DataProvider.)
 | ResolvePath(String, CallContext) | Resolves the path. (Inherited from DataProvider.)
 | SaveItem(ItemDefinition, ItemChanges, CallContext) | Saves an item. (Inherited from DataProvider.)
 | SelectIDs(String, CallContext) | Selects a set of ids. (Inherited from DataProvider.)
 | SelectSingleID(String, CallContext) | Selects a single ID. (Inherited from DataProvider.)
 | SetBlobStream(Stream, Guid, CallContext) | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
 | SetProperty(String, String, CallContext) | Sets a property. (Inherited from DataProvider.)
 | SetWorkflowInfo(ItemDefinition, VersionUri, WorkflowInfo, CallContext) | Sets the workflow info for an item. (Inherited from DataProvider.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataProvider
 |  | TemplateFileResolver


TemplateFileResolver Constructor (templateFile)

TemplateFileResolver Constructor (templateFile)
Namespaces ► Sitecore.Data.DataProviders ► TemplateFileResolver ► TemplateFileResolver(String)
Creates a new TemplateFileResolver instance.
Declaration Syntax
C#
public TemplateFileResolver(
    string templateFile
)
Parameters
templateFile (String)
Template file.


AbortChain Property

AbortChain Property
Namespaces ► Sitecore.Data.DataProviders ► TemplateFileResolver ► AbortChain
Gets or sets a value indicating whether the TemplateFileResolver aborts the chain.
Declaration Syntax
C#
public bool AbortChain { get; set; }
Value
true if the TemplateFileResolver aborts the chain; otherwise, false.


GetTemplates Method (context)

GetTemplates Method (context)
Namespaces ► Sitecore.Data.DataProviders ► TemplateFileResolver ► GetTemplates(CallContext)
Gets the templates.
Declaration Syntax
C#
public override TemplateCollection GetTemplates(
    CallContext context
)
Parameters
context (CallContext)
The context.
Return Value


Sitecore.Data.DataProviders.Sql Namespace

Sitecore.Data.DataProviders.Sql Namespace
Namespaces ► Sitecore.Data.DataProviders.Sql
Declaration Syntax
C#
namespace Sitecore.Data.DataProviders.Sql
Types
All Types Classes Delegates
Icon | Type | Description
 | ConnectionInfo<(Of <(TConnection, TTransaction>)>) | Represents a connection info.
 | DataProviderCommand | Base command class for SQL based data providers.
 | DataProviderReader | Base reader class for SQL based data providers.
 | DataProviderTransaction | Base transaction class for SQL based data providers.
 | SqlDataProvider..::.FieldSharingConverter | FieldSharingConverter
 | SqlDataApi | Base class for SQL based data APIs.
 | SqlDataProvider | Base class for SQL based data providers.
 | SqlStatement | SqlStatement
 | SqlDataProvider..::.UpdateFieldValueDelegate | Delegate to update field values


ConnectionInfo(TConnection, TTransaction) Class

ConnectionInfo<(Of <(TConnection, TTransaction>)>) Class
Namespaces ► Sitecore.Data.DataProviders.Sql ► ConnectionInfo<(Of <(TConnection, TTransaction>)>)
Represents a connection info.
Declaration Syntax
C#
public class ConnectionInfo<TConnection, TTransaction>
where TConnection : IDbConnection
where TTransaction : IDbTransaction
Generic Template Parameters
TConnection
TTransaction
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConnectionInfo<(Of <(TConnection, TTransaction>)>)(TConnection) | Initializes a new instance of the ConnectionInfo class.
 | ConnectionInfo<(Of <(TConnection, TTransaction>)>)(TTransaction) | Initializes a new instance of the ConnectionInfo class.
 | Connection | Gets the connection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transaction | Gets the transaction.
Inheritance Hierarchy
Object
ConnectionInfo<(Of <(TConnection, TTransaction>)>)


ConnectionInfo(TConnection, TTransaction) Constructor

ConnectionInfo<(Of <(TConnection, TTransaction>)>) Constructor
Namespaces ► Sitecore.Data.DataProviders.Sql ► ConnectionInfo<(Of <(TConnection, TTransaction>)>) ► ConnectionInfo<(Of <(TConnection, TTransaction>)>)()()()
Members
Icon | Member | Description
 | ConnectionInfo<(Of <(TConnection, TTransaction>)>)(TConnection) | Initializes a new instance of the ConnectionInfo class.
 | ConnectionInfo<(Of <(TConnection, TTransaction>)>)(TTransaction) | Initializes a new instance of the ConnectionInfo class.


ConnectionInfo(TConnection, TTransaction) Constructor (connection)

ConnectionInfo<(Of <(TConnection, TTransaction>)>) Constructor (connection)
Namespaces ► Sitecore.Data.DataProviders.Sql ► ConnectionInfo<(Of <(TConnection, TTransaction>)>) ► ConnectionInfo<(Of <(TConnection, TTransaction>)>)(TConnection)
Initializes a new instance of the ConnectionInfo class.
Declaration Syntax
C#
public ConnectionInfo(
    TConnection connection
)
Parameters
connection (TConnection)
The connection.


ConnectionInfo(TConnection, TTransaction) Constructor (transaction)

ConnectionInfo<(Of <(TConnection, TTransaction>)>) Constructor (transaction)
Namespaces ► Sitecore.Data.DataProviders.Sql ► ConnectionInfo<(Of <(TConnection, TTransaction>)>) ► ConnectionInfo<(Of <(TConnection, TTransaction>)>)(TTransaction)
Initializes a new instance of the ConnectionInfo class.
Declaration Syntax
C#
public ConnectionInfo(
    TTransaction transaction
)
Parameters
transaction (TTransaction)
The transaction.


Connection Property

Connection Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► ConnectionInfo<(Of <(TConnection, TTransaction>)>) ► Connection
Gets the connection.
Declaration Syntax
C#
public TConnection Connection { get; }
Value
The connection.


Transaction Property

Transaction Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► ConnectionInfo<(Of <(TConnection, TTransaction>)>) ► Transaction
Gets the transaction.
Declaration Syntax
C#
public TTransaction Transaction { get; }
Value
The transaction.


DataProviderCommand Class

DataProviderCommand Class
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderCommand
Base command class for SQL based data providers.
Declaration Syntax
C#
public class DataProviderCommand : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DataProviderCommand(IDbCommand, Boolean) | Constructs an instance of DataProviderCommand
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteNonQuery()()() | Executes the non query.
 | ExecuteReader()()() | Executes the reader.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataProviderCommand
 |  | SqlServerCommand


DataProviderCommand Constructor (command, openConnection)

DataProviderCommand Constructor (command, openConnection)
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderCommand ► DataProviderCommand(IDbCommand, Boolean)
Constructs an instance of DataProviderCommand
Declaration Syntax
C#
public DataProviderCommand(
    IDbCommand command,
    bool openConnection
)
Parameters
command (IDbCommand)
The command.
openConnection (Boolean)
if set to true this instance is open connection.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderCommand ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public virtual void Dispose()


ExecuteNonQuery Method

ExecuteNonQuery Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderCommand ► ExecuteNonQuery()()()
Executes the non query.
Declaration Syntax
C#
public virtual int ExecuteNonQuery()


ExecuteReader Method

ExecuteReader Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderCommand ► ExecuteReader()()()
Executes the reader.
Declaration Syntax
C#
public virtual IDataReader ExecuteReader()
Return Value
The reader.


DataProviderReader Class

DataProviderReader Class
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderReader
Base reader class for SQL based data providers.
Declaration Syntax
C#
public class DataProviderReader : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataProviderReader(DataProviderCommand) | Initializes a new instance of the DataProviderReader class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerReader | Gets a reference to the embedded reader.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Read()()() | Reads this instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DataProviderReader


DataProviderReader Constructor (command)

DataProviderReader Constructor (command)
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderReader ► DataProviderReader(DataProviderCommand)
Initializes a new instance of the DataProviderReader class.
Declaration Syntax
C#
public DataProviderReader(
    DataProviderCommand command
)
Parameters
command (DataProviderCommand)
The command.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderReader ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public virtual void Dispose()


InnerReader Property

InnerReader Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderReader ► InnerReader
Gets a reference to the embedded reader.
Declaration Syntax
C#
public IDataReader InnerReader { get; }
Value
The inner reader.


Read Method

Read Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderReader ► Read()()()
Reads this instance.
Declaration Syntax
C#
public virtual bool Read()
Return Value
The read.


DataProviderTransaction Class

DataProviderTransaction Class
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderTransaction
Base transaction class for SQL based data providers.
Declaration Syntax
C#
public class DataProviderTransaction : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DataProviderTransaction(IDbConnection, String) | Constructs an instance of DataProviderTransactionScope
 | Complete()()() | Completes this instance.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCurrentTransaction(String) | Gets the current transaction context.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PopTransaction()()() | Pops the transaction.
 | PushTransaction()()() | Pushes the transaction.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DataProviderTransaction


DataProviderTransaction Constructor (connection, key)

DataProviderTransaction Constructor (connection, key)
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderTransaction ► DataProviderTransaction(IDbConnection, String)
Constructs an instance of DataProviderTransactionScope
Declaration Syntax
C#
public DataProviderTransaction(
    IDbConnection connection,
    string key
)
Parameters
connection (IDbConnection)
The connection.
key (String)
The key.


Complete Method

Complete Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderTransaction ► Complete()()()
Completes this instance.
Declaration Syntax
C#
public virtual void Complete()


Dispose Method

Dispose Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderTransaction ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public virtual void Dispose()


GetCurrentTransaction Method (key)

GetCurrentTransaction Method (key)
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderTransaction ► GetCurrentTransaction(String)
Gets the current transaction context.
Declaration Syntax
C#
public static IDbTransaction GetCurrentTransaction(
    string key
)
Parameters
key (String)
The connection string.
Return Value
The current transaction.


PopTransaction Method

PopTransaction Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderTransaction ► PopTransaction()()()
Pops the transaction.
Declaration Syntax
C#
protected virtual void PopTransaction()


PushTransaction Method

PushTransaction Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► DataProviderTransaction ► PushTransaction()()()
Pushes the transaction.
Declaration Syntax
C#
protected virtual void PushTransaction()


SqlDataApi Class

SqlDataApi Class
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi
Base class for SQL based data APIs.
Declaration Syntax
C#
public abstract class SqlDataApi
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlDataApi()()() | Initializes a new instance of the SqlDataApi class
 | ConnectionString | Gets the connection string for this connection.
 | CreateCommand(String, array<Object>[]()[]) | Factory method for creating a new command object.
 | CreateConnection()()() | Creates a physical database connection.
 | CreateParameter(String, Object) | Creates a parameter for use in a command.
 | CreateReader(String, array<Object>[]()[]) | Factory method for creating an instance of a DataProviderReader
 | CreateTransaction()()() | Factory method for creating an instance of a DataProviderTransaction
 | EmptyStringLiteral | Gets the empty literal.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(String, array<Object>[]()[]) | Executes the specified SQL.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Format(String) | Formats the specified SQL.
 | FormatRawID(ID) | Formats ID to be used in raw SQL queries (e.g. itemID in 'select * from items where id = :itemID')
 | GetDateTime(Int32, DataProviderReader) | Gets a date/time value from a specified column.
 | GetGuid(Int32, DataProviderReader) | Gets an id value from a specified column.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetId(Int32, DataProviderReader) | Gets an id value from a specified column.
 | GetInt(Int32, DataProviderReader) | Gets an int32 value from a specified column.
 | GetInt32(String, Int32, array<Object>[]()[]) | Gets an integer result from an SQL query.
 | GetLanguage(Int32, DataProviderReader) | Gets a language value from a specified column.
 | GetLong(Int32, DataProviderReader) | Gets an int64 value from a specified column.
 | GetString(Int32, DataProviderReader) | Gets a string value from a specified column.
 | GetStringList(String, array<Object>[]()[]) | Gets a list of string values from a database.
 | GetStringSet(String, array<Object>[]()[]) | Gets a list of string values from a database.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersion(Int32, DataProviderReader) | Gets a version value from a specified column.
 | Identifier | Gets an identifier for the data API.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamePostfix | Gets the postfix used for encapsulating table and column names in SQL statements.
 | NamePrefix | Gets the prefix used for encapsulating table and column names in SQL statements.
 | ParameterPostfix | Gets the postfix used for encapsulating parameter names in SQL statements.
 | ParameterPrefix | Gets the prefix used for encapsulating parameter names in SQL statements.
 | Quote | Gets the character used for encapsulating a string value in SQL statements.
 | Safe(String) | Escapes a string for use in SQL statements.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Wildcard | Gets the character used for wildcard queries in SQL statements.
Inheritance Hierarchy
Object
 | SqlDataApi
 |  | SqlServerDataApi


SqlDataApi Constructor

SqlDataApi Constructor
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► SqlDataApi()()()
Initializes a new instance of the SqlDataApi class
Declaration Syntax
C#
protected SqlDataApi()


ConnectionString Property

ConnectionString Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► ConnectionString
Gets the connection string for this connection.
Declaration Syntax
C#
public abstract string ConnectionString { get; set; }
Value
The connection string.


CreateCommand Method (sql, parameters)

CreateCommand Method (sql, parameters)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► CreateCommand(String, array<Object>[]()[])
Factory method for creating a new command object.
Declaration Syntax
C#
public virtual DataProviderCommand CreateCommand(
    string sql,
    params Object[] parameters
)
Parameters
sql (String)
The SQL to execute.
parameters (array< Object >[]()[])
The values of any parameters embedded in the SQL. These should be on the form {"name1", value1, "name2", value2}.
Return Value


CreateConnection Method

CreateConnection Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► CreateConnection()()()
Creates a physical database connection.
Declaration Syntax
C#
protected abstract IDbConnection CreateConnection()
Return Value
A connection to the database. Note that the connection will not be open.


CreateParameter Method (name, value)

CreateParameter Method (name, value)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► CreateParameter(String, Object)
Creates a parameter for use in a command.
Declaration Syntax
C#
protected abstract IDbDataParameter CreateParameter(
    string name,
    Object value
)
Parameters
name (String)
The name of the parameter.
value (Object)
The value of the parameter.
Return Value

A parameter object in which the DbType of the value has been set and where the parameter value has been mapped to the native value expected by the database.

For instance, if value is an ID, the parameter value might be a Guid representing the same value.


CreateReader Method (sql, parameters)

CreateReader Method (sql, parameters)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► CreateReader(String, array<Object>[]()[])
Factory method for creating an instance of a DataProviderReader
Declaration Syntax
C#
public virtual DataProviderReader CreateReader(
    string sql,
    params Object[] parameters
)
Parameters
sql (String)
The SQL that will be executed to obtain the reader.
parameters (array< Object >[]()[])
The parameters for the SQl command.
Return Value
A reader that can be used to traverse the result set.


CreateTransaction Method

CreateTransaction Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► CreateTransaction()()()
Factory method for creating an instance of a DataProviderTransaction
Declaration Syntax
C#
public virtual DataProviderTransaction CreateTransaction()
Return Value
A transaction object.


EmptyStringLiteral Property

EmptyStringLiteral Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► EmptyStringLiteral
Gets the empty literal.
Declaration Syntax
C#
public virtual string EmptyStringLiteral { get; }
Value
The empty literal.


Execute Method (sql, parameters)

Execute Method (sql, parameters)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► Execute(String, array<Object>[]()[])
Executes the specified SQL.
Declaration Syntax
C#
public virtual int Execute(
    string sql,
    params Object[] parameters
)
Parameters
sql (String)
The SQL.
parameters (array< Object >[]()[])
The parameters.


Format Method (sql)

Format Method (sql)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► Format(String)
Formats the specified SQL.
Declaration Syntax
C#
public virtual string Format(
    string sql
)
Parameters
sql (String)
The SQL.
Return Value


FormatRawID Method (id)

FormatRawID Method (id)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► FormatRawID(ID)
Formats ID to be used in raw SQL queries (e.g. itemID in 'select * from items where id = :itemID')
Declaration Syntax
C#
public virtual string FormatRawID(
    ID id
)
Parameters
id (ID)
The id.
Return Value
The raw ID.


GetDateTime Method (columnIndex, reader)

GetDateTime Method (columnIndex, reader)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► GetDateTime(Int32, DataProviderReader)
Gets a date/time value from a specified column.
Declaration Syntax
C#
public abstract DateTime GetDateTime(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to a DateTime


GetGuid Method (columnIndex, reader)

GetGuid Method (columnIndex, reader)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► GetGuid(Int32, DataProviderReader)
Gets an id value from a specified column.
Declaration Syntax
C#
public abstract Guid GetGuid(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to a Guid


GetId Method (columnIndex, reader)

GetId Method (columnIndex, reader)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► GetId(Int32, DataProviderReader)
Gets an id value from a specified column.
Declaration Syntax
C#
public abstract ID GetId(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to an ID


GetInt Method (columnIndex, reader)

GetInt Method (columnIndex, reader)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► GetInt(Int32, DataProviderReader)
Gets an int32 value from a specified column.
Declaration Syntax
C#
public abstract int GetInt(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to an Int32


GetInt32 Method (sql, defaultValue, parameters)

GetInt32 Method (sql, defaultValue, parameters)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► GetInt32(String, Int32, array<Object>[]()[])
Gets an integer result from an SQL query.
Declaration Syntax
C#
public virtual int GetInt32(
    string sql,
    int defaultValue,
    params Object[] parameters
)
Parameters
sql (String)
A string containing an SQL statement.
defaultValue (Int32)
The default value.
parameters (array< Object >[]()[])
The parameters.
Return Value
The result of the query as an integer.


GetLanguage Method (columnIndex, reader)

GetLanguage Method (columnIndex, reader)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► GetLanguage(Int32, DataProviderReader)
Gets a language value from a specified column.
Declaration Syntax
C#
public abstract Language GetLanguage(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to a Language


GetLong Method (columnIndex, reader)

GetLong Method (columnIndex, reader)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► GetLong(Int32, DataProviderReader)
Gets an int64 value from a specified column.
Declaration Syntax
C#
public abstract long GetLong(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to an Int32


GetString Method (columnIndex, reader)

GetString Method (columnIndex, reader)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► GetString(Int32, DataProviderReader)
Gets a string value from a specified column.
Declaration Syntax
C#
public abstract string GetString(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to a String


GetStringList Method (sql, parameters)

GetStringList Method (sql, parameters)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► GetStringList(String, array<Object>[]()[])
Gets a list of string values from a database.
Declaration Syntax
C#
public virtual List<string> GetStringList(
    string sql,
    Object[] parameters
)
Parameters
sql (String)
The SQL.
parameters (array< Object >[]()[])
The parameters.
Return Value


GetStringSet Method (sql, parameters)

GetStringSet Method (sql, parameters)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► GetStringSet(String, array<Object>[]()[])
Gets a list of string values from a database.
Declaration Syntax
C#
public virtual Set<string> GetStringSet(
    string sql,
    params Object[] parameters
)
Parameters
sql (String)
The SQL.
parameters (array< Object >[]()[])
The parameters.
Return Value


GetVersion Method (columnIndex, reader)

GetVersion Method (columnIndex, reader)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► GetVersion(Int32, DataProviderReader)
Gets a version value from a specified column.
Declaration Syntax
C#
public abstract Version GetVersion(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to a Version


Identifier Property

Identifier Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► Identifier
Gets an identifier for the data API.
Declaration Syntax
C#
public virtual string Identifier { get; }
Value
For SQL Server: The connection string.


NamePostfix Property

NamePostfix Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► NamePostfix
Gets the postfix used for encapsulating table and column names in SQL statements.
Declaration Syntax
C#
public abstract string NamePostfix { get; }
Remarks
For example, SQL Server will use: ].


NamePrefix Property

NamePrefix Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► NamePrefix
Gets the prefix used for encapsulating table and column names in SQL statements.
Declaration Syntax
C#
public abstract string NamePrefix { get; }
Remarks
For example, SQL Server will use: [.


ParameterPostfix Property

ParameterPostfix Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► ParameterPostfix
Gets the postfix used for encapsulating parameter names in SQL statements.
Declaration Syntax
C#
public abstract string ParameterPostfix { get; }
Remarks
For example, SQL Server will use: Empty()()().


ParameterPrefix Property

ParameterPrefix Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► ParameterPrefix
Gets the prefix used for encapsulating parameter names in SQL statements.
Declaration Syntax
C#
public abstract string ParameterPrefix { get; }
Remarks
For example, SQL Server will use: @.


Quote Property

Quote Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► Quote
Gets the character used for encapsulating a string value in SQL statements.
Declaration Syntax
C#
public abstract string Quote { get; }
Remarks
For example, SQL Server will use: '.


Safe Method (text)

Safe Method (text)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► Safe(String)
Escapes a string for use in SQL statements.
Declaration Syntax
C#
public virtual string Safe(
    string text
)
Parameters
text (String)
A string.
Return Value
The escaped string.
Remarks
The base version of the method simply replaces a single quote with two single quotes, but individual implementations may override this behaviour.
Examples
CopyC#
string parameter = Safe("Andy's"); // "Andy''s"


Wildcard Property

Wildcard Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataApi ► Wildcard
Gets the character used for wildcard queries in SQL statements.
Declaration Syntax
C#
public abstract string Wildcard { get; }
Remarks
For example, SQL Server will use: %.


SqlDataProvider Class

SqlDataProvider Class
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider
Base class for SQL based data providers.
Declaration Syntax
C#
public class SqlDataProvider : DataProvider
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlDataProvider(SqlDataApi) | Initializes a new instance of the SqlDataProvider class.
 | _descendantsLock | Used for syncronization of access to [Descendants] table
 | _descendantsShouldBeUpdated | Determines whether [Descendants] table should be updated
 | _languages | Languages
 | _prefetchCacheLock |
 | _rebuildThread | rebuilding thread
 | AddPrefetch(XmlNode) | Adds a prefetch option.
 | AddToPublishQueue(ID, String, DateTime, CallContext) | Adds an item to the publish queue. (Overrides DataProvider.AddToPublishQueue(ID, String, DateTime, CallContext).)
 | AddVersion(ItemDefinition, VersionUri, CallContext) | Adds a version to an item. (Overrides DataProvider.AddVersion(ItemDefinition, VersionUri, CallContext).)
 | Api | Gets the data API to the physical database.
 | BlobStreamExists(Guid, CallContext) | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
 | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
 | ChangeFieldSharing(TemplateField, TemplateFieldSharing, CallContext) | Changes the type of field sharing for a single field. (Overrides DataProvider.ChangeFieldSharing(TemplateField, TemplateFieldSharing, CallContext).)
 | ChangeTemplate(ItemDefinition, TemplateChangeList, CallContext) | Changes the template. (Overrides DataProvider.ChangeTemplate(ItemDefinition, TemplateChangeList, CallContext).)
 | CleanupBlobs(CallContext) | Removes unused blob fields
 | CleanupDatabase(CallContext) | Cleanups the database. (Overrides DataProvider.CleanupDatabase(CallContext).)
 | CleanupFields(CallContext) | Removes all field data for non-existing items.
 | CleanupInvalidLanguageData()()() | Removes all invalid language data (ie. data for which the language does not exist).
 | CleanupOrphans()()() | Removes orphaned items from the database.
 | CleanupPublishQueue(DateTime, CallContext) | Cleans up the publish queue. (Overrides DataProvider.CleanupPublishQueue(DateTime, CallContext).)
 | CleanupTemplateFields(array<String>[]()[], CallContext) | Cleanups the template fields.
 | CopyItem(ItemDefinition, ItemDefinition, String, ID, CallContext) | Copies an item. (Overrides DataProvider.CopyItem(ItemDefinition, ItemDefinition, String, ID, CallContext).)
 | CreateItem(ID, String, ID, ItemDefinition, CallContext) | Creates a item. (Overrides DataProvider.CreateItem(ID, String, ID, ItemDefinition, CallContext).)
 | CreateSqlTranslator()()() | Creates the SQL translator.
 | DeleteItem(ItemDefinition, CallContext) | Deletes an item. (Overrides DataProvider.DeleteItem(ItemDefinition, CallContext).)
 | Descendants_ItemCreated(ID, ID) | Performs changes to 'Descandants' table after item creation.
 | Descendants_ItemDeleted(ID) | Performs changes to 'Descandants' table after item deleting.
 | Disable | Disables a method. (Inherited from DataProvider.)
 | DisableGroup | Disables a group. (Inherited from DataProvider.)
 | Enable | Enables a method. (Inherited from DataProvider.)
 | EnableGroup | Enables a group. (Inherited from DataProvider.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(String, array<Object>[]()[]) | Check if data satisfying the specified SQL exists.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBlobStream(Guid, CallContext) | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
 | GetChildIDs(ItemDefinition, CallContext) | Gets the child ids of an item. (Overrides DataProvider.GetChildIDs(ItemDefinition, CallContext).)
 | GetDataSize(Int32, Int32) | Gets the size of the data managed by the provider. (Overrides DataProvider.GetDataSize(Int32, Int32).)
 | GetDictionaryEntryCount()()() | Gets the number of dictionary entries. (Overrides DataProvider.GetDictionaryEntryCount()()().)
 | GetFieldSharingConverter()()() | Gets a SqlDataProvider..::.FieldSharingConverter.
 | GetFieldValue(String, Guid) | Gets the field value.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIdEnumerator(String, String, String) | Gets all id values.
 | GetItemDefinition(ID, CallContext) | Gets the definition of an item. (Overrides DataProvider.GetItemDefinition(ID, CallContext).)
 | GetItemFields(ItemDefinition, VersionUri, CallContext) | Gets the fields of a specific item version. (Overrides DataProvider.GetItemFields(ItemDefinition, VersionUri, CallContext).)
 | GetItemKeyColumnName()()() | Gets the name of the 'item name' column.
 | GetItemsInWorkflowState(WorkflowInfo, CallContext) | Gets all items that are in a specific workflow state. (Overrides DataProvider.GetItemsInWorkflowState(WorkflowInfo, CallContext).)
 | GetItemVersions(ItemDefinition, CallContext) | Gets a list of the available versions of an item. (Overrides DataProvider.GetItemVersions(ItemDefinition, CallContext).)
 | GetLanguages()()() | Gets a list of all the language that have been defined in the database.
 | GetLanguages(CallContext) | Gets a list of all the language that have been defined in the database. (Overrides DataProvider.GetLanguages(CallContext).)
 | GetLock(Object) | Gets a lock.
 | GetParentID(ItemDefinition, CallContext) | Gets the parent ID of an item. (Overrides DataProvider.GetParentID(ItemDefinition, CallContext).)
 | GetPrefetchDataFromCache(ID) | Gets the prefetch data from cache.
 | GetProperty(String, CallContext) | Gets a property. (Overrides DataProvider.GetProperty(String, CallContext).)
 | GetPropertyCore(String, CallContext) | Gets the property core.
 | GetPropertyKeys(String, CallContext) | Gets a list of property keys matching a specific prefix. (Overrides DataProvider.GetPropertyKeys(String, CallContext).)
 | GetPublishQueue(DateTime, DateTime, CallContext) | Gets the publish queue. (Overrides DataProvider.GetPublishQueue(DateTime, DateTime, CallContext).)
 | GetResolverSql(String) | Gets the resolver SQL.
 | GetRootID(CallContext) | Gets the root ID. (Overrides DataProvider.GetRootID(CallContext).)
 | GetSharingType(TemplateField) | Gets the type of the sharing.
 | GetTemplateItemIds(CallContext) | Gets the template item ids. (Overrides DataProvider.GetTemplateItemIds(CallContext).)
 | GetTemplates(CallContext) | Gets the templates. (Inherited from DataProvider.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersions()()() | Gets a list of all versions that have been defined in the entire database.
 | GetWorkflowInfo(ItemDefinition, VersionUri, CallContext) | Gets the workflow info form an item. (Inherited from DataProvider.)
 | HasChildren(ItemDefinition, CallContext) | Determines whether the specified item definition has children. (Overrides DataProvider.HasChildren(ItemDefinition, CallContext).)
 | IsEnabled(String) | Determines whether the specified method is enabled. (Inherited from DataProvider.)
 | LoadChildIds(String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>)) | Loads the child ids.
 | LoadItemDefinitions(String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>)) | Loads the item definitions.
 | LoadItemFields(String, String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>)) | Loads the item fields.
 | LoadLanguages()()() | Loads the list of languages from the database.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveItem(ItemDefinition, ItemDefinition, CallContext) | Moves an item (ie. changes its parent). (Overrides DataProvider.MoveItem(ItemDefinition, ItemDefinition, CallContext).)
 | Name | Gets or sets the name.
 | PrefetchCache | Gets the prefetch cache.
 | PropertyCache | Gets the property cache.
 | QueryFast(String, CallContext) | Executes fast query.
 | RebuildDescendants()()() | Rebuilds the descendants table.
 | RemoveFields(ID, Language, Version) | Removes the fields.
 | RemoveLanguageData(Language, CallContext) | Removes a language and all the data using the language from the database. (Overrides DataProvider.RemoveLanguageData(Language, CallContext).)
 | RemovePrefetchDataFromCache(ID) | Removes prefetch data from the cache.
 | RemoveProperty(String, Boolean, CallContext) | Removes a property. (Overrides DataProvider.RemoveProperty(String, Boolean, CallContext).)
 | RemovePropertyCore(String, Boolean, CallContext) | Removes the property core.
 | RemoveVersion(ItemDefinition, VersionUri, CallContext) | Removes a version from an item. (Overrides DataProvider.RemoveVersion(ItemDefinition, VersionUri, CallContext).)
 | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Overrides DataProvider.RemoveVersions(ItemDefinition, Language, Boolean, CallContext).)
 | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
 | RenameLanguageData(String, String, CallContext) | Renames a language binding. (Overrides DataProvider.RenameLanguageData(String, String, CallContext).)
 | ResolveNames(String) | Resolves the names.
 | ResolvePath(String, CallContext) | Resolves the path. (Inherited from DataProvider.)
 | SaveItem(ItemDefinition, ItemChanges, CallContext) | Saves an item. (Overrides DataProvider.SaveItem(ItemDefinition, ItemChanges, CallContext).)
 | SelectIDs(String, CallContext) | Selects a set of ids. (Overrides DataProvider.SelectIDs(String, CallContext).)
 | SelectSingleID(String, CallContext) | Selects a single ID. (Overrides DataProvider.SelectSingleID(String, CallContext).)
 | SetBlobStream(Stream, Guid, CallContext) | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
 | SetFieldValue(String, Guid, String) | Sets the field value.
 | SetProperty(String, String, CallContext) | Sets a property. (Overrides DataProvider.SetProperty(String, String, CallContext).)
 | SetPropertyCore(String, String, CallContext) | Sets the property core.
 | SetWorkflowInfo(ItemDefinition, VersionUri, WorkflowInfo, CallContext) | Sets the workflow info for an item. (Inherited from DataProvider.)
 | SkipDescendantsUpdate | Determines whether [Descendants] table should be updated.
 | StartRebuildDescendants()()() | Starts the rebuild descendants.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Translator | Gets the Sitecore Query to SQL translator.
 | UpdateFieldValues(ID, SqlDataProvider..::.UpdateFieldValueDelegate, Boolean) | Updates field values.
 | WriteSharedField(ID, FieldChange, DateTime, Boolean) | Writes the shared field.
 | WriteUnversionedField(ID, FieldChange, DateTime, Boolean) | Writes the unversioned field.
 | WriteVersionedField(ID, FieldChange, DateTime, Boolean) | Writes the versioned field.
Inheritance Hierarchy
Object
 | DataProvider
 |  | SqlDataProvider
 |  |  | SqlServerDataProvider


SqlDataProvider Constructor (api)

SqlDataProvider Constructor (api)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► SqlDataProvider(SqlDataApi)
Initializes a new instance of the SqlDataProvider class.
Declaration Syntax
C#
public SqlDataProvider(
    SqlDataApi api
)
Parameters
api (SqlDataApi)
The API.


_descendantsLock Field

_descendantsLock Field
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► _descendantsLock
Used for syncronization of access to [Descendants] table
Declaration Syntax
C#
protected readonly ReaderWriterLock _descendantsLock


_descendantsShouldBeUpdated Field

_descendantsShouldBeUpdated Field
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► _descendantsShouldBeUpdated
Determines whether [Descendants] table should be updated
Declaration Syntax
C#
protected bool _descendantsShouldBeUpdated


_languages Field

_languages Field
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► _languages
Languages
Declaration Syntax
C#
protected LanguageCollection _languages


_prefetchCacheLock Field

_prefetchCacheLock Field
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► _prefetchCacheLock
Declaration Syntax
C#
protected readonly Object _prefetchCacheLock


_rebuildThread Field

_rebuildThread Field
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► _rebuildThread
rebuilding thread
Declaration Syntax
C#
protected Thread _rebuildThread


AddPrefetch Method (configNode)

AddPrefetch Method (configNode)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► AddPrefetch(XmlNode)
Adds a prefetch option.
Declaration Syntax
C#
protected virtual void AddPrefetch(
    XmlNode configNode
)
Parameters
configNode (XmlNode)
The config node.


AddToPublishQueue Method (itemID, action, date, context)

AddToPublishQueue Method (itemID, action, date, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► AddToPublishQueue(ID, String, DateTime, CallContext)
Adds an item to the publish queue.
Declaration Syntax
C#
public override bool AddToPublishQueue(
    ID itemID,
    string action,
    DateTime date,
    CallContext context
)
Parameters
itemID (ID)
The item ID.
action (String)
The action.
date (DateTime)
The date.
context (CallContext)
The context.
Return Value


AddVersion Method (itemDefinition, baseVersion, context)

AddVersion Method (itemDefinition, baseVersion, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► AddVersion(ItemDefinition, VersionUri, CallContext)
Adds a version to an item.
Declaration Syntax
C#
public override int AddVersion(
    ItemDefinition itemDefinition,
    VersionUri baseVersion,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
baseVersion (VersionUri)
The base version.
context (CallContext)
The context.
Return Value


Api Property

Api Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► Api
Gets the data API to the physical database.
Declaration Syntax
C#
protected SqlDataApi Api { get; }
Value
The data API.


ChangeFieldSharing Method (fieldDefinition, sharing, context)

ChangeFieldSharing Method (fieldDefinition, sharing, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► ChangeFieldSharing(TemplateField, TemplateFieldSharing, CallContext)
Changes the type of field sharing for a single field.
Declaration Syntax
C#
public override bool ChangeFieldSharing(
    TemplateField fieldDefinition,
    TemplateFieldSharing sharing,
    CallContext context
)
Parameters
fieldDefinition (TemplateField)
The field definition.
sharing (TemplateFieldSharing)
The new sharing type.
context (CallContext)
The context.
Return Value


ChangeTemplate Method (itemDefinition, changeList, context)

ChangeTemplate Method (itemDefinition, changeList, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► ChangeTemplate(ItemDefinition, TemplateChangeList, CallContext)
Changes the template.
Declaration Syntax
C#
public override bool ChangeTemplate(
    ItemDefinition itemDefinition,
    TemplateChangeList changeList,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
changeList (TemplateChangeList)
The change list.
context (CallContext)
The context.
Return Value


CleanupBlobs Method (context)

CleanupBlobs Method (context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► CleanupBlobs(CallContext)
Removes unused blob fields
Declaration Syntax
C#
protected virtual void CleanupBlobs(
    CallContext context
)
Parameters
context (CallContext)


CleanupDatabase Method (context)

CleanupDatabase Method (context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► CleanupDatabase(CallContext)
Cleanups the database.
Declaration Syntax
C#
public override bool CleanupDatabase(
    CallContext context
)
Parameters
context (CallContext)
Return Value
true if cleanup was performed; false otherwise.
Remarks

Typically, a cleanup operation will remove data in invalid languages and items in orphaned trees.

Specific operations depends on the actual data provider implementation.


CleanupFields Method (context)

CleanupFields Method (context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► CleanupFields(CallContext)
Removes all field data for non-existing items.
Declaration Syntax
C#
protected virtual void CleanupFields(
    CallContext context
)
Parameters
context (CallContext)


CleanupInvalidLanguageData Method

CleanupInvalidLanguageData Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► CleanupInvalidLanguageData()()()
Removes all invalid language data (ie. data for which the language does not exist).
Declaration Syntax
C#
protected virtual void CleanupInvalidLanguageData()


CleanupOrphans Method

CleanupOrphans Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► CleanupOrphans()()()
Removes orphaned items from the database.
Declaration Syntax
C#
protected virtual void CleanupOrphans()


CleanupPublishQueue Method (to, context)

CleanupPublishQueue Method (to, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► CleanupPublishQueue(DateTime, CallContext)
Cleans up the publish queue.
Declaration Syntax
C#
public override bool CleanupPublishQueue(
    DateTime to,
    CallContext context
)
Parameters
to (DateTime)
To.
context (CallContext)
The context.
Return Value


CleanupTemplateFields Method (tables, context)

CleanupTemplateFields Method (tables, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► CleanupTemplateFields(array<String>[]()[], CallContext)
Cleanups the template fields.
Declaration Syntax
C#
protected virtual void CleanupTemplateFields(
    string[] tables,
    CallContext context
)
Parameters
tables (array< String >[]()[])
The tables.
context (CallContext)
The context.


CopyItem Method (source, destination, copyName, copyID, context)

CopyItem Method (source, destination, copyName, copyID, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► CopyItem(ItemDefinition, ItemDefinition, String, ID, CallContext)
Copies an item.
Declaration Syntax
C#
public override bool CopyItem(
    ItemDefinition source,
    ItemDefinition destination,
    string copyName,
    ID copyID,
    CallContext context
)
Parameters
source (ItemDefinition)
The source.
destination (ItemDefinition)
The destination.
copyName (String)
Name of the copy.
copyID (ID)
The copy ID.
context (CallContext)
The context.
Return Value


CreateItem Method (itemID, itemName, templateID, parent, context)

CreateItem Method (itemID, itemName, templateID, parent, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► CreateItem(ID, String, ID, ItemDefinition, CallContext)
Creates a item.
Declaration Syntax
C#
public override bool CreateItem(
    ID itemID,
    string itemName,
    ID templateID,
    ItemDefinition parent,
    CallContext context
)
Parameters
itemID (ID)
The item ID.
itemName (String)
Name of the item.
templateID (ID)
The template ID.
parent (ItemDefinition)
The parent.
context (CallContext)
The context.
Return Value


CreateSqlTranslator Method

CreateSqlTranslator Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► CreateSqlTranslator()()()
Creates the SQL translator.
Declaration Syntax
C#
protected virtual QueryToSqlTranslator CreateSqlTranslator()
Return Value
The SQL translator.


DeleteItem Method (itemDefinition, context)

DeleteItem Method (itemDefinition, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► DeleteItem(ItemDefinition, CallContext)
Deletes an item.
Declaration Syntax
C#
public override bool DeleteItem(
    ItemDefinition itemDefinition,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
context (CallContext)
The context.
Return Value


Descendants_ItemCreated Method (parentId, itemId)

Descendants_ItemCreated Method (parentId, itemId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► Descendants_ItemCreated(ID, ID)
Performs changes to 'Descandants' table after item creation.
Declaration Syntax
C#
protected virtual void Descendants_ItemCreated(
    ID parentId,
    ID itemId
)
Parameters
parentId (ID)
The parent item id.
itemId (ID)
The item id.


Descendants_ItemDeleted Method (itemId)

Descendants_ItemDeleted Method (itemId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► Descendants_ItemDeleted(ID)
Performs changes to 'Descandants' table after item deleting.
Declaration Syntax
C#
protected virtual void Descendants_ItemDeleted(
    ID itemId
)
Parameters
itemId (ID)
The item id.


Exists Method (sql, parameters)

Exists Method (sql, parameters)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► Exists(String, array<Object>[]()[])
Check if data satisfying the specified SQL exists.
Declaration Syntax
C#
protected bool Exists(
    string sql,
    params Object[] parameters
)
Parameters
sql (String)
The SQL.
parameters (array< Object >[]()[])
The parameters.
Return Value
True, if data is found, false otherwise.


GetChildIDs Method (itemDefinition, context)

GetChildIDs Method (itemDefinition, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetChildIDs(ItemDefinition, CallContext)
Gets the child ids of an item.
Declaration Syntax
C#
public override IDList GetChildIDs(
    ItemDefinition itemDefinition,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
context (CallContext)
The context.
Return Value


GetDataSize Method (minEntitySize, maxEntitySize)

GetDataSize Method (minEntitySize, maxEntitySize)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetDataSize(Int32, Int32)
Gets the size of the data managed by the provider.
Declaration Syntax
C#
public override long GetDataSize(
    int minEntitySize,
    int maxEntitySize
)
Parameters
minEntitySize (Int32)
maxEntitySize (Int32)
Return Value


GetDictionaryEntryCount Method

GetDictionaryEntryCount Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetDictionaryEntryCount()()()
Gets the number of dictionary entries.
Declaration Syntax
C#
public override long GetDictionaryEntryCount()
Return Value
The number of dictionary entries.


GetFieldSharingConverter Method

GetFieldSharingConverter Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetFieldSharingConverter()()()
Gets a SqlDataProvider..::.FieldSharingConverter.
Declaration Syntax
C#
protected virtual SqlDataProvider..::.FieldSharingConverter GetFieldSharingConverter()
Return Value


GetFieldValue Method (tableName, entryId)

GetFieldValue Method (tableName, entryId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetFieldValue(String, Guid)
Gets the field value.
Declaration Syntax
C#
protected virtual string GetFieldValue(
    string tableName,
    Guid entryId
)
Parameters
tableName (String)
Name of the table.
entryId (Guid)
The entry id.


GetIdEnumerator Method (tableName, idFieldName, condition)

GetIdEnumerator Method (tableName, idFieldName, condition)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetIdEnumerator(String, String, String)
Gets all id values.
Declaration Syntax
C#
protected virtual IEnumerable<Guid> GetIdEnumerator(
    string tableName,
    string idFieldName,
    string condition
)
Parameters
tableName (String)
Name of the table.
idFieldName (String)
Name of the id field.
condition (String)
The condition to be put to the 'where' section.
Return Value


GetItemDefinition Method (itemId, context)

GetItemDefinition Method (itemId, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetItemDefinition(ID, CallContext)
Gets the definition of an item.
Declaration Syntax
C#
public override ItemDefinition GetItemDefinition(
    ID itemId,
    CallContext context
)
Parameters
itemId (ID)
The item ID.
context (CallContext)
The context.
Return Value


GetItemFields Method (itemDefinition, versionUri, context)

GetItemFields Method (itemDefinition, versionUri, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetItemFields(ItemDefinition, VersionUri, CallContext)
Gets the fields of a specific item version.
Declaration Syntax
C#
public override FieldList GetItemFields(
    ItemDefinition itemDefinition,
    VersionUri versionUri,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item.
versionUri (VersionUri)
The version URI.
context (CallContext)
The context.
Return Value


GetItemKeyColumnName Method

GetItemKeyColumnName Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetItemKeyColumnName()()()
Gets the name of the 'item name' column.
Declaration Syntax
C#
protected virtual string GetItemKeyColumnName()
Return Value


GetItemsInWorkflowState Method (info, context)

GetItemsInWorkflowState Method (info, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetItemsInWorkflowState(WorkflowInfo, CallContext)
Gets all items that are in a specific workflow state.
Declaration Syntax
C#
public override DataUri[] GetItemsInWorkflowState(
    WorkflowInfo info,
    CallContext context
)
Parameters
info (WorkflowInfo)
The info.
context (CallContext)
The context.
Return Value


GetItemVersions Method (itemDefinition, context)

GetItemVersions Method (itemDefinition, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetItemVersions(ItemDefinition, CallContext)
Gets a list of the available versions of an item.
Declaration Syntax
C#
public override VersionUriList GetItemVersions(
    ItemDefinition itemDefinition,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item.
context (CallContext)
The context.
Return Value


GetLanguages Method

GetLanguages Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetLanguages()()()
Members
Icon | Member | Description
 | GetLanguages()()() | Gets a list of all the language that have been defined in the database.
 | GetLanguages(CallContext) | Gets a list of all the language that have been defined in the database. (Overrides DataProvider.GetLanguages(CallContext).)


GetLanguages Method

GetLanguages Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetLanguages()()()
Gets a list of all the language that have been defined in the database.
Declaration Syntax
C#
public virtual LanguageCollection GetLanguages()
Return Value


GetLanguages Method (context)

GetLanguages Method (context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetLanguages(CallContext)
Gets a list of all the language that have been defined in the database.
Declaration Syntax
C#
public override LanguageCollection GetLanguages(
    CallContext context
)
Parameters
context (CallContext)
Return Value


GetLock Method (value)

GetLock Method (value)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetLock(Object)
Gets a lock.
Declaration Syntax
C#
protected Object GetLock(
    Object value
)
Parameters
value (Object)
The value to get a lock for.
Return Value


GetParentID Method (itemDefinition, context)

GetParentID Method (itemDefinition, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetParentID(ItemDefinition, CallContext)
Gets the parent ID of an item.
Declaration Syntax
C#
public override ID GetParentID(
    ItemDefinition itemDefinition,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
context (CallContext)
The context.
Return Value


GetPrefetchDataFromCache Method (itemId)

GetPrefetchDataFromCache Method (itemId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetPrefetchDataFromCache(ID)
Gets the prefetch data from cache.
Declaration Syntax
C#
protected PrefetchData GetPrefetchDataFromCache(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value


GetProperty Method (name, context)

GetProperty Method (name, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetProperty(String, CallContext)
Gets a property.
Declaration Syntax
C#
public override string GetProperty(
    string name,
    CallContext context
)
Parameters
name (String)
The name.
context (CallContext)
The context.
Return Value


GetPropertyCore Method (name, context)

GetPropertyCore Method (name, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetPropertyCore(String, CallContext)
Gets the property core.
Declaration Syntax
C#
protected virtual string GetPropertyCore(
    string name,
    CallContext context
)
Parameters
name (String)
The name.
context (CallContext)
The context.
Return Value


GetPropertyKeys Method (prefix, context)

GetPropertyKeys Method (prefix, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetPropertyKeys(String, CallContext)
Gets a list of property keys matching a specific prefix.
Declaration Syntax
C#
public override List<string> GetPropertyKeys(
    string prefix,
    CallContext context
)
Parameters
prefix (String)
The prefix.
context (CallContext)
The context.
Return Value


GetPublishQueue Method (from, to, context)

GetPublishQueue Method (from, to, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetPublishQueue(DateTime, DateTime, CallContext)
Gets the publish queue.
Declaration Syntax
C#
public override IDList GetPublishQueue(
    DateTime from,
    DateTime to,
    CallContext context
)
Parameters
from (DateTime)
From.
to (DateTime)
To.
context (CallContext)
The context.
Return Value


GetResolverSql Method (path)

GetResolverSql Method (path)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetResolverSql(String)
Gets the resolver SQL.
Declaration Syntax
C#
protected virtual string GetResolverSql(
    string path
)
Parameters
path (String)
The path.
Return Value


GetRootID Method (context)

GetRootID Method (context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetRootID(CallContext)
Gets the root ID.
Declaration Syntax
C#
public override ID GetRootID(
    CallContext context
)
Parameters
context (CallContext)
The context.
Return Value


GetSharingType Method (templateField)

GetSharingType Method (templateField)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetSharingType(TemplateField)
Gets the type of the sharing.
Declaration Syntax
C#
public DefaultFieldSharing..::.SharingType GetSharingType(
    TemplateField templateField
)
Parameters
templateField (TemplateField)
The template of the field.
Return Value


GetTemplateItemIds Method (context)

GetTemplateItemIds Method (context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetTemplateItemIds(CallContext)
Gets the template item ids.
Declaration Syntax
C#
public override IdCollection GetTemplateItemIds(
    CallContext context
)
Parameters
context (CallContext)
The context.
Return Value


GetVersions Method

GetVersions Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► GetVersions()()()
Gets a list of all versions that have been defined in the entire database.
Declaration Syntax
C#
protected virtual List<Version> GetVersions()
Return Value


HasChildren Method (itemDefinition, context)

HasChildren Method (itemDefinition, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► HasChildren(ItemDefinition, CallContext)
Determines whether the specified item definition has children.
Declaration Syntax
C#
public override bool HasChildren(
    ItemDefinition itemDefinition,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
context (CallContext)
The context.
Return Value
true if the specified item definition has children; otherwise, false.


LoadChildIds Method (condition, parameters, prefetchData)

LoadChildIds Method (condition, parameters, prefetchData)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► LoadChildIds(String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>))
Loads the child ids.
Declaration Syntax
C#
protected virtual void LoadChildIds(
    string condition,
    Object[] parameters,
    SafeDictionary<ID, PrefetchData> prefetchData
)
Parameters
condition (String)
The condition.
parameters (array< Object >[]()[])
The parameters.
prefetchData (SafeDictionary <(Of <( ID, PrefetchData >)>))
The working set.


LoadItemDefinitions Method (condition, parameters, prefetchData)

LoadItemDefinitions Method (condition, parameters, prefetchData)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► LoadItemDefinitions(String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>))
Loads the item definitions.
Declaration Syntax
C#
protected virtual void LoadItemDefinitions(
    string condition,
    Object[] parameters,
    SafeDictionary<ID, PrefetchData> prefetchData
)
Parameters
condition (String)
The condition.
parameters (array< Object >[]()[])
The parameters.
prefetchData (SafeDictionary <(Of <( ID, PrefetchData >)>))
The working set.


LoadItemFields Method (itemCondition, fieldCondition, parameters, prefetchData)

LoadItemFields Method (itemCondition, fieldCondition, parameters, prefetchData)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► LoadItemFields(String, String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>))
Loads the item fields.
Declaration Syntax
C#
protected virtual void LoadItemFields(
    string itemCondition,
    string fieldCondition,
    Object[] parameters,
    SafeDictionary<ID, PrefetchData> prefetchData
)
Parameters
itemCondition (String)
The item condition.
fieldCondition (String)
The field condition.
parameters (array< Object >[]()[])
The parameters.
prefetchData (SafeDictionary <(Of <( ID, PrefetchData >)>))
The working set.


LoadLanguages Method

LoadLanguages Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► LoadLanguages()()()
Loads the list of languages from the database.
Declaration Syntax
C#
protected virtual LanguageCollection LoadLanguages()
Return Value


MoveItem Method (itemDefinition, destination, context)

MoveItem Method (itemDefinition, destination, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► MoveItem(ItemDefinition, ItemDefinition, CallContext)
Moves an item (ie. changes its parent).
Declaration Syntax
C#
public override bool MoveItem(
    ItemDefinition itemDefinition,
    ItemDefinition destination,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
destination (ItemDefinition)
The destination.
context (CallContext)
The call context.
Return Value
True if the item was moved by the provider, false otherwise.


Name Property

Name Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► Name
Gets or sets the name.
Declaration Syntax
C#
public virtual string Name { get; set; }
Value
The name.


PrefetchCache Property

PrefetchCache Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► PrefetchCache
Gets the prefetch cache.
Declaration Syntax
C#
protected Cache PrefetchCache { get; }
Value
The prefetch cache.


PropertyCache Property

PropertyCache Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► PropertyCache
Gets the property cache.
Declaration Syntax
C#
protected Cache PropertyCache { get; }
Value
The property cache.


QueryFast Method (query, context)

QueryFast Method (query, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► QueryFast(String, CallContext)
Executes fast query.
Declaration Syntax
C#
protected virtual IDList QueryFast(
    string query,
    CallContext context
)
Parameters
query (String)
The query.
context (CallContext)
The context.
Return Value
List of IDs.


RebuildDescendants Method

RebuildDescendants Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► RebuildDescendants()()()
Rebuilds the descendants table.
Declaration Syntax
C#
protected virtual void RebuildDescendants()


RemoveFields Method (itemId, language, version)

RemoveFields Method (itemId, language, version)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► RemoveFields(ID, Language, Version)
Removes the fields.
Declaration Syntax
C#
protected virtual void RemoveFields(
    ID itemId,
    Language language,
    Version version
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
version (Version)
The version.


RemoveLanguageData Method (language, context)

RemoveLanguageData Method (language, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► RemoveLanguageData(Language, CallContext)
Removes a language and all the data using the language from the database.
Declaration Syntax
C#
public override void RemoveLanguageData(
    Language language,
    CallContext context
)
Parameters
language (Language)
The language.
context (CallContext)
The context.
Remarks
Proceeed with caution.


RemovePrefetchDataFromCache Method (itemId)

RemovePrefetchDataFromCache Method (itemId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► RemovePrefetchDataFromCache(ID)
Removes prefetch data from the cache.
Declaration Syntax
C#
protected void RemovePrefetchDataFromCache(
    ID itemId
)
Parameters
itemId (ID)
The item id.


RemoveProperty Method (name, isPrefix, context)

RemoveProperty Method (name, isPrefix, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► RemoveProperty(String, Boolean, CallContext)
Removes a property.
Declaration Syntax
C#
public override bool RemoveProperty(
    string name,
    bool isPrefix,
    CallContext context
)
Parameters
name (String)
The name.
isPrefix (Boolean)
if set to true this instance is is prefix.
context (CallContext)
The context.
Return Value


RemovePropertyCore Method (name, isPrefix, context)

RemovePropertyCore Method (name, isPrefix, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► RemovePropertyCore(String, Boolean, CallContext)
Removes the property core.
Declaration Syntax
C#
protected virtual bool RemovePropertyCore(
    string name,
    bool isPrefix,
    CallContext context
)
Parameters
name (String)
The name.
isPrefix (Boolean)
if set to true this instance is is prefix.
context (CallContext)
The context.
Return Value


RemoveVersion Method (itemDefinition, version, context)

RemoveVersion Method (itemDefinition, version, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► RemoveVersion(ItemDefinition, VersionUri, CallContext)
Removes a version from an item.
Declaration Syntax
C#
public override bool RemoveVersion(
    ItemDefinition itemDefinition,
    VersionUri version,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
version (VersionUri)
The version.
context (CallContext)
The context.
Return Value


RemoveVersions Method (itemDefinition, language, removeSharedData, context)

RemoveVersions Method (itemDefinition, language, removeSharedData, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► RemoveVersions(ItemDefinition, Language, Boolean, CallContext)
Removes versions from an item.
Declaration Syntax
C#
public override bool RemoveVersions(
    ItemDefinition itemDefinition,
    Language language,
    bool removeSharedData,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
language (Language)
The language.
removeSharedData (Boolean)
If set to true shared data is removed.
context (CallContext)
The context.
Return Value


RenameLanguageData Method (fromLanguage, toLanguage, context)

RenameLanguageData Method (fromLanguage, toLanguage, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► RenameLanguageData(String, String, CallContext)
Renames a language binding.
Declaration Syntax
C#
public override void RenameLanguageData(
    string fromLanguage,
    string toLanguage,
    CallContext context
)
Parameters
fromLanguage (String)
Rename from this language name.
toLanguage (String)
Rename to this language name.
context (CallContext)
The call context.


ResolveNames Method (itemName)

ResolveNames Method (itemName)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► ResolveNames(String)
Resolves the names.
Declaration Syntax
C#
protected virtual IDList ResolveNames(
    string itemName
)
Parameters
itemName (String)
Name of the item.
Return Value


SaveItem Method (itemDefinition, changes, context)

SaveItem Method (itemDefinition, changes, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► SaveItem(ItemDefinition, ItemChanges, CallContext)
Saves an item.
Declaration Syntax
C#
public override bool SaveItem(
    ItemDefinition itemDefinition,
    ItemChanges changes,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
changes (ItemChanges)
The changes.
context (CallContext)
The context.
Return Value


SelectIDs Method (query, context)

SelectIDs Method (query, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► SelectIDs(String, CallContext)
Selects a set of ids.
Declaration Syntax
C#
public override IDList SelectIDs(
    string query,
    CallContext context
)
Parameters
query (String)
The query.
context (CallContext)
The context.
Return Value


SelectSingleID Method (query, context)

SelectSingleID Method (query, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► SelectSingleID(String, CallContext)
Selects a single ID.
Declaration Syntax
C#
public override ID SelectSingleID(
    string query,
    CallContext context
)
Parameters
query (String)
The query.
context (CallContext)
The context.
Return Value


SetFieldValue Method (tableName, entryId, value)

SetFieldValue Method (tableName, entryId, value)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► SetFieldValue(String, Guid, String)
Sets the field value.
Declaration Syntax
C#
protected virtual void SetFieldValue(
    string tableName,
    Guid entryId,
    string value
)
Parameters
tableName (String)
Name of the table.
entryId (Guid)
The entry id.
value (String)
The value.


SetProperty Method (name, value, context)

SetProperty Method (name, value, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► SetProperty(String, String, CallContext)
Sets a property.
Declaration Syntax
C#
public override bool SetProperty(
    string name,
    string value,
    CallContext context
)
Parameters
name (String)
The name.
value (String)
The value.
context (CallContext)
The context.
Return Value


SetPropertyCore Method (name, value, context)

SetPropertyCore Method (name, value, context)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► SetPropertyCore(String, String, CallContext)
Sets the property core.
Declaration Syntax
C#
protected virtual bool SetPropertyCore(
    string name,
    string value,
    CallContext context
)
Parameters
name (String)
The name.
value (String)
The value.
context (CallContext)
The context.
Return Value


SkipDescendantsUpdate Property

SkipDescendantsUpdate Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► SkipDescendantsUpdate
Determines whether [Descendants] table should be updated.
Declaration Syntax
C#
protected virtual bool SkipDescendantsUpdate { get; }
Return Value


StartRebuildDescendants Method

StartRebuildDescendants Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► StartRebuildDescendants()()()
Starts the rebuild descendants.
Declaration Syntax
C#
protected virtual void StartRebuildDescendants()


Translator Property

Translator Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► Translator
Gets the Sitecore Query to SQL translator.
Declaration Syntax
C#
protected QueryToSqlTranslator Translator { get; }
Value
An intstance of QueryToSqlTranslator class.


UpdateFieldValues Method (fieldId, updateFunction, skipEmpty)

UpdateFieldValues Method (fieldId, updateFunction, skipEmpty)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► UpdateFieldValues(ID, SqlDataProvider..::.UpdateFieldValueDelegate, Boolean)
Updates field values.
Declaration Syntax
C#
public virtual int UpdateFieldValues(
    ID fieldId,
    SqlDataProvider..::.UpdateFieldValueDelegate updateFunction,
    bool skipEmpty
)
Parameters
fieldId (ID)
The field id.
updateFunction (SqlDataProvider..::.UpdateFieldValueDelegate)
The update function.
skipEmpty (Boolean)
if set to true empty fields will be skipped.


WriteSharedField Method (itemId, change, now, fieldsAreEmpty)

WriteSharedField Method (itemId, change, now, fieldsAreEmpty)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► WriteSharedField(ID, FieldChange, DateTime, Boolean)
Writes the shared field.
Declaration Syntax
C#
protected virtual void WriteSharedField(
    ID itemId,
    FieldChange change,
    DateTime now,
    bool fieldsAreEmpty
)
Parameters
itemId (ID)
The item id.
change (FieldChange)
The change.
now (DateTime)
The now.
fieldsAreEmpty (Boolean)
if set to true fields are empty.


WriteUnversionedField Method (itemId, change, now, fieldsAreEmpty)

WriteUnversionedField Method (itemId, change, now, fieldsAreEmpty)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► WriteUnversionedField(ID, FieldChange, DateTime, Boolean)
Writes the unversioned field.
Declaration Syntax
C#
protected virtual void WriteUnversionedField(
    ID itemId,
    FieldChange change,
    DateTime now,
    bool fieldsAreEmpty
)
Parameters
itemId (ID)
The item id.
change (FieldChange)
The change.
now (DateTime)
The now.
fieldsAreEmpty (Boolean)
if set to true fields are empty.


WriteVersionedField Method (itemId, change, now, fieldsAreEmpty)

WriteVersionedField Method (itemId, change, now, fieldsAreEmpty)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► WriteVersionedField(ID, FieldChange, DateTime, Boolean)
Writes the versioned field.
Declaration Syntax
C#
protected virtual void WriteVersionedField(
    ID itemId,
    FieldChange change,
    DateTime now,
    bool fieldsAreEmpty
)
Parameters
itemId (ID)
The item id.
change (FieldChange)
The change.
now (DateTime)
The now.
fieldsAreEmpty (Boolean)
if set to true fields are empty.


SqlDataProvider.FieldSharingConverter Class

SqlDataProvider..::.FieldSharingConverter Class
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► SqlDataProvider..::.FieldSharingConverter
FieldSharingConverter
Declaration Syntax
C#
public class FieldSharingConverter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SqlDataProvider..::.FieldSharingConverter(SqlDataProvider) | Initializes a new instance of the SqlDataProvider..::.FieldSharingConverter class.
 | ChangeShareType(ID, DefaultFieldSharing..::.SharingType, DefaultFieldSharing..::.SharingType) | Changes type of the field sharing.
 | DeleteSharedFields(ID, ID) | Deletes the shared field values by id.
 | DeleteUnversionedFields(ID, ID) | Deletes the unversioned field values by id.
 | DeleteVersionedFields(ID, ID) | Deletes the versioned field values by id.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MakeShared(TemplateField) | Makes field shared.
 | MakeShared(ID, DefaultFieldSharing..::.SharingType) | Makes the field shared.
 | MakeSharedFromUnversioned(ID) | Converts the field from unversioned to shared.
 | MakeSharedFromVersioned(ID) | Converts the field from versioned to shared.
 | MakeUnversioned(TemplateField) | Makes the field unversioned.
 | MakeUnversioned(ID, DefaultFieldSharing..::.SharingType) | Makes the field unversioned.
 | MakeUnversionedFromShared(ID) | Converts the field from shared to unversioned.
 | MakeUnversionedFromVersioned(ID) | Converts the field from versioned to unversioned.
 | MakeVersioned(TemplateField) | Makes the field versioned.
 | MakeVersioned(ID, DefaultFieldSharing..::.SharingType) | Makes the field versioned.
 | MakeVersionedFromShared(ID) | Converts the field from shared to versioned.
 | MakeVersionedFromUnversioned(ID) | Converts the field from unversioned to versioned.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveDataToSharedFromUnversioned(ID, ID) | Moves the data to shared from unversioned.
 | MoveDataToSharedFromVersioned(ID, ID) | Moves the data to shared from versioned.
 | MoveDataToUnversionedFromShared(ID, ID) | Converts the field from shared to unversioned.
 | MoveDataToUnversionedFromVersioned(ID, ID) | Converts the field from versioned to unversioned.
 | MoveDataToVersionedFromShared(ID, ID) | Converts the field from shared to versioned.
 | MoveDataToVersionedFromUnversioned(ID, ID) | Moves the data to versioned from unversioned.
 | MoveFieldData(TemplateField, TemplateField, ID) | Changes field sharing.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SqlDataProvider..::.FieldSharingConverter


SqlDataProvider.FieldSharingConverter Constructor (owner)

SqlDataProvider..::.FieldSharingConverter Constructor (owner)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► SqlDataProvider..::.FieldSharingConverter(SqlDataProvider)
Initializes a new instance of the SqlDataProvider..::.FieldSharingConverter class.
Declaration Syntax
C#
public FieldSharingConverter(
    SqlDataProvider owner
)
Parameters
owner (SqlDataProvider)
The owner.


ChangeShareType Method (fieldId, sourceType, targetType)

ChangeShareType Method (fieldId, sourceType, targetType)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► ChangeShareType(ID, DefaultFieldSharing..::.SharingType, DefaultFieldSharing..::.SharingType)
Changes type of the field sharing.
Declaration Syntax
C#
public virtual bool ChangeShareType(
    ID fieldId,
    DefaultFieldSharing..::.SharingType sourceType,
    DefaultFieldSharing..::.SharingType targetType
)
Parameters
fieldId (ID)
The field id.
sourceType (DefaultFieldSharing..::.SharingType)
Source type
targetType (DefaultFieldSharing..::.SharingType)
Target type
Return Value


DeleteSharedFields Method (fieldId, itemId)

DeleteSharedFields Method (fieldId, itemId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► DeleteSharedFields(ID, ID)
Deletes the shared field values by id.
Declaration Syntax
C#
protected virtual void DeleteSharedFields(
    ID fieldId,
    ID itemId
)
Parameters
fieldId (ID)
The field id.
itemId (ID)
The item id.


DeleteUnversionedFields Method (fieldId, itemId)

DeleteUnversionedFields Method (fieldId, itemId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► DeleteUnversionedFields(ID, ID)
Deletes the unversioned field values by id.
Declaration Syntax
C#
protected virtual void DeleteUnversionedFields(
    ID fieldId,
    ID itemId
)
Parameters
fieldId (ID)
The field id.
itemId (ID)
The item id.


DeleteVersionedFields Method (fieldId, itemId)

DeleteVersionedFields Method (fieldId, itemId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► DeleteVersionedFields(ID, ID)
Deletes the versioned field values by id.
Declaration Syntax
C#
protected virtual void DeleteVersionedFields(
    ID fieldId,
    ID itemId
)
Parameters
fieldId (ID)
The field id.
itemId (ID)
The item ID.


MakeShared Method

MakeShared Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeShared()()()
Members
Icon | Member | Description
 | MakeShared(TemplateField) | Makes field shared.
 | MakeShared(ID, DefaultFieldSharing..::.SharingType) | Makes the field shared.


MakeShared Method (fieldId, sharingType)

MakeShared Method (fieldId, sharingType)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeShared(ID, DefaultFieldSharing..::.SharingType)
Makes the field shared.
Declaration Syntax
C#
public virtual bool MakeShared(
    ID fieldId,
    DefaultFieldSharing..::.SharingType sharingType
)
Parameters
fieldId (ID)
The field id.
sharingType (DefaultFieldSharing..::.SharingType)
The sharing type
Return Value


MakeShared Method (fieldDefinition)

MakeShared Method (fieldDefinition)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeShared(TemplateField)
Makes field shared.
Declaration Syntax
C#
public virtual bool MakeShared(
    TemplateField fieldDefinition
)
Parameters
fieldDefinition (TemplateField)
The field definition.
Return Value


MakeSharedFromUnversioned Method (fieldId)

MakeSharedFromUnversioned Method (fieldId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeSharedFromUnversioned(ID)
Converts the field from unversioned to shared.
Declaration Syntax
C#
protected virtual bool MakeSharedFromUnversioned(
    ID fieldId
)
Parameters
fieldId (ID)
The field id.
Return Value


MakeSharedFromVersioned Method (fieldId)

MakeSharedFromVersioned Method (fieldId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeSharedFromVersioned(ID)
Converts the field from versioned to shared.
Declaration Syntax
C#
protected virtual bool MakeSharedFromVersioned(
    ID fieldId
)
Parameters
fieldId (ID)
The field id.
Return Value


MakeUnversioned Method

MakeUnversioned Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeUnversioned()()()
Members
Icon | Member | Description
 | MakeUnversioned(TemplateField) | Makes the field unversioned.
 | MakeUnversioned(ID, DefaultFieldSharing..::.SharingType) | Makes the field unversioned.


MakeUnversioned Method (fieldId, sharingType)

MakeUnversioned Method (fieldId, sharingType)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeUnversioned(ID, DefaultFieldSharing..::.SharingType)
Makes the field unversioned.
Declaration Syntax
C#
public virtual bool MakeUnversioned(
    ID fieldId,
    DefaultFieldSharing..::.SharingType sharingType
)
Parameters
fieldId (ID)
The field id
sharingType (DefaultFieldSharing..::.SharingType)
The sharing type
Return Value


MakeUnversioned Method (fieldDefinition)

MakeUnversioned Method (fieldDefinition)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeUnversioned(TemplateField)
Makes the field unversioned.
Declaration Syntax
C#
public virtual bool MakeUnversioned(
    TemplateField fieldDefinition
)
Parameters
fieldDefinition (TemplateField)
The field definition.
Return Value


MakeUnversionedFromShared Method (fieldId)

MakeUnversionedFromShared Method (fieldId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeUnversionedFromShared(ID)
Converts the field from shared to unversioned.
Declaration Syntax
C#
protected virtual bool MakeUnversionedFromShared(
    ID fieldId
)
Parameters
fieldId (ID)
The field id.
Return Value


MakeUnversionedFromVersioned Method (fieldId)

MakeUnversionedFromVersioned Method (fieldId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeUnversionedFromVersioned(ID)
Converts the field from versioned to unversioned.
Declaration Syntax
C#
protected virtual bool MakeUnversionedFromVersioned(
    ID fieldId
)
Parameters
fieldId (ID)
The field id.
Return Value


MakeVersioned Method

MakeVersioned Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeVersioned()()()
Members
Icon | Member | Description
 | MakeVersioned(TemplateField) | Makes the field versioned.
 | MakeVersioned(ID, DefaultFieldSharing..::.SharingType) | Makes the field versioned.


MakeVersioned Method (fieldId, sharingType)

MakeVersioned Method (fieldId, sharingType)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeVersioned(ID, DefaultFieldSharing..::.SharingType)
Makes the field versioned.
Declaration Syntax
C#
public virtual bool MakeVersioned(
    ID fieldId,
    DefaultFieldSharing..::.SharingType sharingType
)
Parameters
fieldId (ID)
The field id
sharingType (DefaultFieldSharing..::.SharingType)
The sharing type
Return Value


MakeVersioned Method (fieldDefinition)

MakeVersioned Method (fieldDefinition)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeVersioned(TemplateField)
Makes the field versioned.
Declaration Syntax
C#
public virtual bool MakeVersioned(
    TemplateField fieldDefinition
)
Parameters
fieldDefinition (TemplateField)
The field definition.
Return Value


MakeVersionedFromShared Method (fieldId)

MakeVersionedFromShared Method (fieldId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeVersionedFromShared(ID)
Converts the field from shared to versioned.
Declaration Syntax
C#
protected virtual bool MakeVersionedFromShared(
    ID fieldId
)
Parameters
fieldId (ID)
The field id.
Return Value


MakeVersionedFromUnversioned Method (fieldId)

MakeVersionedFromUnversioned Method (fieldId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MakeVersionedFromUnversioned(ID)
Converts the field from unversioned to versioned.
Declaration Syntax
C#
protected virtual bool MakeVersionedFromUnversioned(
    ID fieldId
)
Parameters
fieldId (ID)
The field id.
Return Value


MoveDataToSharedFromUnversioned Method (fieldId, itemId)

MoveDataToSharedFromUnversioned Method (fieldId, itemId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MoveDataToSharedFromUnversioned(ID, ID)
Moves the data to shared from unversioned.
Declaration Syntax
C#
protected virtual bool MoveDataToSharedFromUnversioned(
    ID fieldId,
    ID itemId
)
Parameters
fieldId (ID)
The field id.
itemId (ID)
The item id.
Return Value


MoveDataToSharedFromVersioned Method (fieldId, itemId)

MoveDataToSharedFromVersioned Method (fieldId, itemId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MoveDataToSharedFromVersioned(ID, ID)
Moves the data to shared from versioned.
Declaration Syntax
C#
protected virtual bool MoveDataToSharedFromVersioned(
    ID fieldId,
    ID itemId
)
Parameters
fieldId (ID)
The field id.
itemId (ID)
The item id.
Return Value
The data to shared from versioned.


MoveDataToUnversionedFromShared Method (fieldId, itemId)

MoveDataToUnversionedFromShared Method (fieldId, itemId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MoveDataToUnversionedFromShared(ID, ID)
Converts the field from shared to unversioned.
Declaration Syntax
C#
protected virtual bool MoveDataToUnversionedFromShared(
    ID fieldId,
    ID itemId
)
Parameters
fieldId (ID)
The field id.
itemId (ID)
The item id.
Return Value


MoveDataToUnversionedFromVersioned Method (fieldId, itemId)

MoveDataToUnversionedFromVersioned Method (fieldId, itemId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MoveDataToUnversionedFromVersioned(ID, ID)
Converts the field from versioned to unversioned.
Declaration Syntax
C#
protected virtual bool MoveDataToUnversionedFromVersioned(
    ID fieldId,
    ID itemId
)
Parameters
fieldId (ID)
The field id.
itemId (ID)
The item id.
Return Value


MoveDataToVersionedFromShared Method (fieldId, itemId)

MoveDataToVersionedFromShared Method (fieldId, itemId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MoveDataToVersionedFromShared(ID, ID)
Converts the field from shared to versioned.
Declaration Syntax
C#
protected virtual bool MoveDataToVersionedFromShared(
    ID fieldId,
    ID itemId
)
Parameters
fieldId (ID)
The field id.
itemId (ID)
The item id.
Return Value


MoveDataToVersionedFromUnversioned Method (fieldId, itemId)

MoveDataToVersionedFromUnversioned Method (fieldId, itemId)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MoveDataToVersionedFromUnversioned(ID, ID)
Moves the data to versioned from unversioned.
Declaration Syntax
C#
protected virtual bool MoveDataToVersionedFromUnversioned(
    ID fieldId,
    ID itemId
)
Parameters
fieldId (ID)
The field id.
itemId (ID)
The item id.
Return Value
The data to versioned from unversioned.


MoveFieldData Method (sourceField, targetField, itemID)

MoveFieldData Method (sourceField, targetField, itemID)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider..::.FieldSharingConverter ► MoveFieldData(TemplateField, TemplateField, ID)
Changes field sharing.
Declaration Syntax
C#
public virtual bool MoveFieldData(
    TemplateField sourceField,
    TemplateField targetField,
    ID itemID
)
Parameters
sourceField (TemplateField)
The source field.
targetField (TemplateField)
The field.
itemID (ID)
The item ID.
Return Value
true is data has been modified, false otherwise.


SqlDataProvider.UpdateFieldValueDelegate Delegate

SqlDataProvider..::.UpdateFieldValueDelegate Delegate
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlDataProvider ► SqlDataProvider..::.UpdateFieldValueDelegate
Delegate to update field values
Declaration Syntax
C#
public delegate string UpdateFieldValueDelegate(
    string value
)
Parameters
value (String)
value of a field
Return Value
New value for the field


SqlStatement Class

SqlStatement Class
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlStatement
SqlStatement
Declaration Syntax
C#
public class SqlStatement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlStatement()()() | Initializes a new instance of the SqlStatement class
 | AddParameter(String, Object) | Adds a parameter.
 | AddParameters(IEnumerable) | Adds the parameters.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | From | Gets or sets the FROM part.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetParameters()()() | Gets the parameters.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OrderBy | Gets the order by.
 | Select | Gets or sets the SELECT part.
 | Sql | Gets the SQL.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Where | Gets or sets the where.
Inheritance Hierarchy
Object
SqlStatement


SqlStatement Constructor

SqlStatement Constructor
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlStatement ► SqlStatement()()()
Initializes a new instance of the SqlStatement class
Declaration Syntax
C#
public SqlStatement()


AddParameter Method (name, value)

AddParameter Method (name, value)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlStatement ► AddParameter(String, Object)
Adds a parameter.
Declaration Syntax
C#
public void AddParameter(
    string name,
    Object value
)
Parameters
name (String)
The name.
value (Object)
The value.


AddParameters Method (parameters)

AddParameters Method (parameters)
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlStatement ► AddParameters(IEnumerable)
Adds the parameters.
Declaration Syntax
C#
public void AddParameters(
    IEnumerable parameters
)
Parameters
parameters (IEnumerable)
The parameters.


From Property

From Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlStatement ► From
Gets or sets the FROM part.
Declaration Syntax
C#
public string From { get; set; }
Value
From.


GetParameters Method

GetParameters Method
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlStatement ► GetParameters()()()
Gets the parameters.
Declaration Syntax
C#
public Object[] GetParameters()
Return Value


OrderBy Property

OrderBy Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlStatement ► OrderBy
Gets the order by.
Declaration Syntax
C#
public string OrderBy { get; set; }
Value
The order by.


Select Property

Select Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlStatement ► Select
Gets or sets the SELECT part.
Declaration Syntax
C#
public string Select { get; set; }
Value
The select.


Sql Property

Sql Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlStatement ► Sql
Gets the SQL.
Declaration Syntax
C#
public string Sql { get; }
Value
The SQL.


Where Property

Where Property
Namespaces ► Sitecore.Data.DataProviders.Sql ► SqlStatement ► Where
Gets or sets the where.
Declaration Syntax
C#
public string Where { get; set; }
Value
The where.


Sitecore.Data.DataProviders.Sql.FastQuery Namespace

Sitecore.Data.DataProviders.Sql.FastQuery Namespace
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery
Declaration Syntax
C#
namespace Sitecore.Data.DataProviders.Sql.FastQuery
Types
All Types Classes Interfaces
Icon | Type | Description
 | BasicTranslationContext | Defines context for Query opcode to SQL translation operation.
 | BasicTranslatorFactory | Simple factory of objects translating Query opcodes to SQL
 | BooleanValueTranslator | Translator for Boolean values
 | ComparisonOperatorTranslator | Translates comparison operators (=, !=, >=, <=) into SQL predicates
 | EqualsOperatorTraits | Traits description for '==' and '!=' operators
 | FieldTranslator | Translates item field reference in query to SQL.
 | IDFieldInfo | IFieldInfo implementation for field references by ID
 | IFieldInfo | Carries additional info for a field in the translation context
 | IOpcodeTranslator | Interface for Query opcode translators.
 | IOpcodeTranslatorFactory | Interface for a factory of objects performing translation of Query staements into SQL statements.
 | IOperatorTraits | Describes features of eachs operator
 | ITranslationContext | Defines context for Query to SQL translation operation.
 | LiteralOpcodeTranslator | Translates string literal to SQL.
 | LocalTranslationContext | ITranlationContext implementation with isolated LocalData property.
 | LogicalOperatorTranslator | Translates logical operator (OR | AND) to SQL.
 | NameFieldInfo | IFieldInfo for field references by name
 | NumberValueTranslator | Converts number to SQL
 | ParametersList | Passes SQL parameters from translator to the caller.
 | QueryToSqlTranslator | Summary description for QueryToSqlTranslator.
 | RelationOperatorTraits | Description for comparison operators other that '==' and '!=';


BasicTranslationContext Class

BasicTranslationContext Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslationContext
Defines context for Query opcode to SQL translation operation.
Declaration Syntax
C#
public class BasicTranslationContext : ITranslationContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BasicTranslationContext(IOpcodeTranslatorFactory, SqlDataApi, Database, ParametersList) | Initializes a new instance of the BasicTranslationContext class.
 | AddSubquery(String, String) | Adds the subquery.
 | AddTable(String) | Adds the table.
 | Data | Gets the data.
 | Database | Gets the database for which translation is performed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the factory.
 | Fields | Gets the fields.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNextAlias(String) | Gets the next alias.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LocalData | Gets the local data.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets the parameters manager for the SQL query.
 | ParentContext | Gets the parent context.
 | SqlApi | Gets the SQL API.
 | Tables | Gets the tables.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BasicTranslationContext


BasicTranslationContext Constructor (factory, api, database, parameters)

BasicTranslationContext Constructor (factory, api, database, parameters)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslationContext ► BasicTranslationContext(IOpcodeTranslatorFactory, SqlDataApi, Database, ParametersList)
Initializes a new instance of the BasicTranslationContext class.
Declaration Syntax
C#
public BasicTranslationContext(
    IOpcodeTranslatorFactory factory,
    SqlDataApi api,
    Database database,
    ParametersList parameters
)
Parameters
factory (IOpcodeTranslatorFactory)
The factory.
api (SqlDataApi)
The API.
database (Database)
The database.
parameters (ParametersList)
The parameters.


AddSubquery Method (query, tableName)

AddSubquery Method (query, tableName)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslationContext ► AddSubquery(String, String)
Adds the subquery.
Declaration Syntax
C#
public string AddSubquery(
    string query,
    string tableName
)
Parameters
query (String)
The query.
tableName (String)
Name of the table.
Return Value
The subquery.


AddTable Method (tableName)

AddTable Method (tableName)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslationContext ► AddTable(String)
Adds the table.
Declaration Syntax
C#
public string AddTable(
    string tableName
)
Parameters
tableName (String)
Name of the table.
Return Value
The table.


Data Property

Data Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslationContext ► Data
Gets the data.
Declaration Syntax
C#
public IDictionary Data { get; }
Value
The data.


Database Property

Database Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslationContext ► Database
Gets the database for which translation is performed.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


Factory Property

Factory Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslationContext ► Factory
Gets the factory.
Declaration Syntax
C#
public IOpcodeTranslatorFactory Factory { get; }
Value
The factory.


Fields Property

Fields Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslationContext ► Fields
Gets the fields.
Declaration Syntax
C#
public IDictionary Fields { get; }
Value
The fields.


GetNextAlias Method (prefix)

GetNextAlias Method (prefix)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslationContext ► GetNextAlias(String)
Gets the next alias.
Declaration Syntax
C#
public string GetNextAlias(
    string prefix
)
Parameters
prefix (String)
The prefix.
Return Value
The next alias.


LocalData Property

LocalData Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslationContext ► LocalData
Gets the local data.
Declaration Syntax
C#
public IDictionary LocalData { get; }
Value
The local data.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslationContext ► Parameters
Gets the parameters manager for the SQL query.
Declaration Syntax
C#
public ParametersList Parameters { get; }
Value
The parameters.


ParentContext Property

ParentContext Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslationContext ► ParentContext
Gets the parent context.
Declaration Syntax
C#
public ITranslationContext ParentContext { get; }
Value
The parent context.


SqlApi Property

SqlApi Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslationContext ► SqlApi
Gets the SQL API.
Declaration Syntax
C#
public SqlDataApi SqlApi { get; }
Value
The SQL API.


Tables Property

Tables Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslationContext ► Tables
Gets the tables.
Declaration Syntax
C#
public IDictionary Tables { get; }
Value
The tables.


BasicTranslatorFactory Class

BasicTranslatorFactory Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslatorFactory
Simple factory of objects translating Query opcodes to SQL
Declaration Syntax
C#
public class BasicTranslatorFactory : IOpcodeTranslatorFactory
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BasicTranslatorFactory()()() | Initializes a new instance of the BasicTranslatorFactory class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTranslator(Opcode) | Gets the translator for the opcode
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Register(Type, IOpcodeTranslator) | Registers the specified type.
 | Remove(Type) | Removes the specified type.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BasicTranslatorFactory


BasicTranslatorFactory Constructor

BasicTranslatorFactory Constructor
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslatorFactory ► BasicTranslatorFactory()()()
Initializes a new instance of the BasicTranslatorFactory class
Declaration Syntax
C#
public BasicTranslatorFactory()


GetTranslator Method (opcode)

GetTranslator Method (opcode)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslatorFactory ► GetTranslator(Opcode)
Gets the translator for the opcode
Declaration Syntax
C#
public IOpcodeTranslator GetTranslator(
    Opcode opcode
)
Parameters
opcode (Opcode)
The opcode.
Return Value
The translator.


Register Method (type, translator)

Register Method (type, translator)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslatorFactory ► Register(Type, IOpcodeTranslator)
Registers the specified type.
Declaration Syntax
C#
public void Register(
    Type type,
    IOpcodeTranslator translator
)
Parameters
type (Type)
The type.
translator (IOpcodeTranslator)
The translator.


Remove Method (type)

Remove Method (type)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BasicTranslatorFactory ► Remove(Type)
Removes the specified type.
Declaration Syntax
C#
public void Remove(
    Type type
)
Parameters
type (Type)
The type.


BooleanValueTranslator Class

BooleanValueTranslator Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BooleanValueTranslator
Translator for Boolean values
Declaration Syntax
C#
public class BooleanValueTranslator : IOpcodeTranslator
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BooleanValueTranslator()()() | Initializes a new instance of the BooleanValueTranslator class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFalseExpression()()() | Gets the false expression.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTrueExpression()()() | Gets the true expression.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Translate(Opcode, ITranslationContext) | Translates the specified opcode.
Inheritance Hierarchy
Object
BooleanValueTranslator


BooleanValueTranslator Constructor

BooleanValueTranslator Constructor
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BooleanValueTranslator ► BooleanValueTranslator()()()
Initializes a new instance of the BooleanValueTranslator class
Declaration Syntax
C#
public BooleanValueTranslator()


GetFalseExpression Method

GetFalseExpression Method
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BooleanValueTranslator ► GetFalseExpression()()()
Gets the false expression.
Declaration Syntax
C#
protected virtual string GetFalseExpression()
Return Value
The false expression.


GetTrueExpression Method

GetTrueExpression Method
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BooleanValueTranslator ► GetTrueExpression()()()
Gets the true expression.
Declaration Syntax
C#
protected virtual string GetTrueExpression()
Return Value
The true expression.


Translate Method (opcode, context)

Translate Method (opcode, context)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► BooleanValueTranslator ► Translate(Opcode, ITranslationContext)
Translates the specified opcode.
Declaration Syntax
C#
public string Translate(
    Opcode opcode,
    ITranslationContext context
)
Parameters
opcode (Opcode)
The opcode.
context (ITranslationContext)
The context.
Return Value
The translate.


ComparisonOperatorTranslator Class

ComparisonOperatorTranslator Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ComparisonOperatorTranslator
Translates comparison operators (=, !=, >=, <=) into SQL predicates
Declaration Syntax
C#
public class ComparisonOperatorTranslator : IOpcodeTranslator
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ComparisonOperatorTranslator(IOperatorTraits) | Initializes a new instance of the ComparisonOperatorTranslator class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareLeft(String) | Prepares the left side of the relation.
 | PrepareRight(String) | Prepares the right side of the relation.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Translate(Opcode, ITranslationContext) | Translates the specified opcode.
Inheritance Hierarchy
Object
ComparisonOperatorTranslator


ComparisonOperatorTranslator Constructor (traits)

ComparisonOperatorTranslator Constructor (traits)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ComparisonOperatorTranslator ► ComparisonOperatorTranslator(IOperatorTraits)
Initializes a new instance of the ComparisonOperatorTranslator class.
Declaration Syntax
C#
public ComparisonOperatorTranslator(
    IOperatorTraits traits
)
Parameters
traits (IOperatorTraits)
The traits.


PrepareLeft Method (left)

PrepareLeft Method (left)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ComparisonOperatorTranslator ► PrepareLeft(String)
Prepares the left side of the relation.
Declaration Syntax
C#
protected virtual string PrepareLeft(
    string left
)
Parameters
left (String)
The left.
Return Value
The left.


PrepareRight Method (right)

PrepareRight Method (right)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ComparisonOperatorTranslator ► PrepareRight(String)
Prepares the right side of the relation.
Declaration Syntax
C#
protected virtual string PrepareRight(
    string right
)
Parameters
right (String)
The right.
Return Value
The right.


Translate Method (opcode, context)

Translate Method (opcode, context)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ComparisonOperatorTranslator ► Translate(Opcode, ITranslationContext)
Translates the specified opcode.
Declaration Syntax
C#
public string Translate(
    Opcode opcode,
    ITranslationContext context
)
Parameters
opcode (Opcode)
The opcode.
context (ITranslationContext)
The context.
Return Value
The translate.


EqualsOperatorTraits Class

EqualsOperatorTraits Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► EqualsOperatorTraits
Traits description for '==' and '!=' operators
Declaration Syntax
C#
public class EqualsOperatorTraits : IOperatorTraits
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EqualsOperatorTraits(Boolean) | Initializes a new instance of the EqualsOperatorTraits class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperatorString(ITranslationContext, ITranslationContext) | Gets the operator string.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NeedsSimpleValues | Gets a value indicating whether the IOperatorTraits needss the simple values.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
EqualsOperatorTraits


EqualsOperatorTraits Constructor (equals)

EqualsOperatorTraits Constructor (equals)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► EqualsOperatorTraits ► EqualsOperatorTraits(Boolean)
Initializes a new instance of the EqualsOperatorTraits class.
Declaration Syntax
C#
public EqualsOperatorTraits(
    bool equals
)
Parameters
equals (Boolean)
if set to true this instance is equals.


GetOperatorString Method (left, right)

GetOperatorString Method (left, right)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► EqualsOperatorTraits ► GetOperatorString(ITranslationContext, ITranslationContext)
Gets the operator string.
Declaration Syntax
C#
public string GetOperatorString(
    ITranslationContext left,
    ITranslationContext right
)
Parameters
left (ITranslationContext)
The left.
right (ITranslationContext)
The right.
Return Value
The operator string.


NeedsSimpleValues Property

NeedsSimpleValues Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► EqualsOperatorTraits ► NeedsSimpleValues
Gets a value indicating whether the IOperatorTraits needss the simple values.
Declaration Syntax
C#
public bool NeedsSimpleValues { get; }
Value
true if the IOperatorTraits needss the simple values; otherwise, false.


FieldTranslator Class

FieldTranslator Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► FieldTranslator
Translates item field reference in query to SQL.
Declaration Syntax
C#
public class FieldTranslator : IOpcodeTranslator
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FieldTranslator()()() | Initializes a new instance of the FieldTranslator class
 | EnsureNotNull(String) | Transforms expression to ensure it does not return NULL
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MakeSimpleString(String) | Changes the expression so it returns a simple string value to allow comparison operators other than LIKE or equality.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RenderAttribute(String, ITranslationContext) | Renders the attribute.
 | RenderField(IFieldInfo, ITranslationContext) | Renders the field from field info.
 | RenderFieldByGuid(ID, ITranslationContext) | Renders the field by GUID.
 | RenderFieldByName(String, ITranslationContext) | Renders field by name.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Translate(Opcode, ITranslationContext) | Translates the specified opcode.
Inheritance Hierarchy
Object
FieldTranslator


FieldTranslator Constructor

FieldTranslator Constructor
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► FieldTranslator ► FieldTranslator()()()
Initializes a new instance of the FieldTranslator class
Declaration Syntax
C#
public FieldTranslator()


EnsureNotNull Method (expression)

EnsureNotNull Method (expression)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► FieldTranslator ► EnsureNotNull(String)
Transforms expression to ensure it does not return NULL
Declaration Syntax
C#
protected virtual string EnsureNotNull(
    string expression
)
Parameters
expression (String)
The expression.
Return Value
The not null.


MakeSimpleString Method (expression)

MakeSimpleString Method (expression)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► FieldTranslator ► MakeSimpleString(String)
Changes the expression so it returns a simple string value to allow comparison operators other than LIKE or equality.
Declaration Syntax
C#
protected virtual string MakeSimpleString(
    string expression
)
Parameters
expression (String)
The expression.
Return Value
Transformed expression.


RenderAttribute Method (attribute, context)

RenderAttribute Method (attribute, context)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► FieldTranslator ► RenderAttribute(String, ITranslationContext)
Renders the attribute.
Declaration Syntax
C#
protected virtual string RenderAttribute(
    string attribute,
    ITranslationContext context
)
Parameters
attribute (String)
The attribute.
context (ITranslationContext)
The context.
Return Value
The attribute.


RenderField Method (info, context)

RenderField Method (info, context)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► FieldTranslator ► RenderField(IFieldInfo, ITranslationContext)
Renders the field from field info.
Declaration Syntax
C#
protected virtual string RenderField(
    IFieldInfo info,
    ITranslationContext context
)
Parameters
info (IFieldInfo)
The info.
context (ITranslationContext)
The context.
Return Value
The field.


RenderFieldByGuid Method (fieldID, context)

RenderFieldByGuid Method (fieldID, context)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► FieldTranslator ► RenderFieldByGuid(ID, ITranslationContext)
Renders the field by GUID.
Declaration Syntax
C#
protected virtual string RenderFieldByGuid(
    ID fieldID,
    ITranslationContext context
)
Parameters
fieldID (ID)
The field ID.
context (ITranslationContext)
The context.
Return Value
The field by GUID.


RenderFieldByName Method (fieldName, context)

RenderFieldByName Method (fieldName, context)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► FieldTranslator ► RenderFieldByName(String, ITranslationContext)
Renders field by name.
Declaration Syntax
C#
protected virtual string RenderFieldByName(
    string fieldName,
    ITranslationContext context
)
Parameters
fieldName (String)
Name of the field.
context (ITranslationContext)
The context.
Return Value
The field by name.


Translate Method (opcode, context)

Translate Method (opcode, context)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► FieldTranslator ► Translate(Opcode, ITranslationContext)
Translates the specified opcode.
Declaration Syntax
C#
public string Translate(
    Opcode opcode,
    ITranslationContext context
)
Parameters
opcode (Opcode)
The opcode.
context (ITranslationContext)
The context.
Return Value
The translate.


IDFieldInfo Class

IDFieldInfo Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► IDFieldInfo
IFieldInfo implementation for field references by ID
Declaration Syntax
C#
public class IDFieldInfo : IFieldInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IDFieldInfo(ID, ITranslationContext) | Initializes a new instance of the IDFieldInfo class.
 | Alias | Gets the alias/name of the table/view holding the field value. The view will have VALUE column.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
IDFieldInfo


IDFieldInfo Constructor (fieldId, context)

IDFieldInfo Constructor (fieldId, context)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► IDFieldInfo ► IDFieldInfo(ID, ITranslationContext)
Initializes a new instance of the IDFieldInfo class.
Declaration Syntax
C#
public IDFieldInfo(
    ID fieldId,
    ITranslationContext context
)
Parameters
fieldId (ID)
The field id.
context (ITranslationContext)
The context.


Alias Property

Alias Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► IDFieldInfo ► Alias
Gets the alias/name of the table/view holding the field value. The view will have VALUE column.
Declaration Syntax
C#
public string Alias { get; }
Value
The alias.


IFieldInfo Interface

IFieldInfo Interface
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► IFieldInfo
Carries additional info for a field in the translation context
Declaration Syntax
C#
public interface IFieldInfo
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Alias | Gets the alias/name of the table/view holding the field value. The view will have VALUE column.


Alias Property

Alias Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► IFieldInfo ► Alias
Gets the alias/name of the table/view holding the field value. The view will have VALUE column.
Declaration Syntax
C#
string Alias { get; }
Value
The alias.


IOpcodeTranslator Interface

IOpcodeTranslator Interface
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► IOpcodeTranslator
Interface for Query opcode translators.
Declaration Syntax
C#
public interface IOpcodeTranslator
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Translate(Opcode, ITranslationContext) | Translates the specified opcode.


Translate Method (opcode, context)

Translate Method (opcode, context)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► IOpcodeTranslator ► Translate(Opcode, ITranslationContext)
Translates the specified opcode.
Declaration Syntax
C#
string Translate(
    Opcode opcode,
    ITranslationContext context
)
Parameters
opcode (Opcode)
The opcode.
context (ITranslationContext)
The context.
Return Value
The translate.


IOpcodeTranslatorFactory Interface

IOpcodeTranslatorFactory Interface
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► IOpcodeTranslatorFactory
Interface for a factory of objects performing translation of Query staements into SQL statements.
Declaration Syntax
C#
public interface IOpcodeTranslatorFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetTranslator(Opcode) | Gets the translator for specific opcode.


GetTranslator Method (opcode)

GetTranslator Method (opcode)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► IOpcodeTranslatorFactory ► GetTranslator(Opcode)
Gets the translator for specific opcode.
Declaration Syntax
C#
IOpcodeTranslator GetTranslator(
    Opcode opcode
)
Parameters
opcode (Opcode)
The opcode.
Return Value
The translator.


IOperatorTraits Interface

IOperatorTraits Interface
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► IOperatorTraits
Describes features of eachs operator
Declaration Syntax
C#
public interface IOperatorTraits
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetOperatorString(ITranslationContext, ITranslationContext) | Gets the operator string.
 | NeedsSimpleValues | Gets a value indicating whether the IOperatorTraits needss the simple values.


GetOperatorString Method (left, right)

GetOperatorString Method (left, right)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► IOperatorTraits ► GetOperatorString(ITranslationContext, ITranslationContext)
Gets the operator string.
Declaration Syntax
C#
string GetOperatorString(
    ITranslationContext left,
    ITranslationContext right
)
Parameters
left (ITranslationContext)
The left.
right (ITranslationContext)
The right.
Return Value
The operator string.


NeedsSimpleValues Property

NeedsSimpleValues Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► IOperatorTraits ► NeedsSimpleValues
Gets a value indicating whether the IOperatorTraits needss the simple values.
Declaration Syntax
C#
bool NeedsSimpleValues { get; }
Value
true if the IOperatorTraits needss the simple values; otherwise, false.


ITranslationContext Interface

ITranslationContext Interface
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ITranslationContext
Defines context for Query to SQL translation operation.
Declaration Syntax
C#
public interface ITranslationContext
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddSubquery(String, String) | Adds the subquery.
 | AddTable(String) | Adds the table.
 | Data | Custom data dictionary (global).
 | Database | Gets the database for which translation is performed.
 | Factory | Gets the factory.
 | Fields | Gets the fields and their extra information.
 | GetNextAlias(String) | Gets the next alias.
 | LocalData | Local data dictionary.
 | Parameters | Gets the parameters manager for the SQL query.
 | ParentContext | Gets the parent context.
 | SqlApi | Gets the SQL API.
 | Tables | Gets the tables and their aliases.


AddSubquery Method (query, tableName)

AddSubquery Method (query, tableName)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ITranslationContext ► AddSubquery(String, String)
Adds the subquery.
Declaration Syntax
C#
string AddSubquery(
    string query,
    string tableName
)
Parameters
query (String)
The query.
tableName (String)
Name of the table.
Return Value
The subquery.


AddTable Method (tableName)

AddTable Method (tableName)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ITranslationContext ► AddTable(String)
Adds the table.
Declaration Syntax
C#
string AddTable(
    string tableName
)
Parameters
tableName (String)
Name of the table.
Return Value
The table.


Data Property

Data Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ITranslationContext ► Data
Custom data dictionary (global).
Declaration Syntax
C#
IDictionary Data { get; }
Value
The data.


Database Property

Database Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ITranslationContext ► Database
Gets the database for which translation is performed.
Declaration Syntax
C#
Database Database { get; }
Value
The database.


Factory Property

Factory Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ITranslationContext ► Factory
Gets the factory.
Declaration Syntax
C#
IOpcodeTranslatorFactory Factory { get; }
Value
The factory.


Fields Property

Fields Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ITranslationContext ► Fields
Gets the fields and their extra information.
Declaration Syntax
C#
IDictionary Fields { get; }
Value
The fields.


GetNextAlias Method (prefix)

GetNextAlias Method (prefix)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ITranslationContext ► GetNextAlias(String)
Gets the next alias.
Declaration Syntax
C#
string GetNextAlias(
    string prefix
)
Parameters
prefix (String)
The prefix.
Return Value
The next alias.


LocalData Property

LocalData Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ITranslationContext ► LocalData
Local data dictionary.
Declaration Syntax
C#
IDictionary LocalData { get; }
Value
The local data.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ITranslationContext ► Parameters
Gets the parameters manager for the SQL query.
Declaration Syntax
C#
ParametersList Parameters { get; }
Value
The parameters.


ParentContext Property

ParentContext Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ITranslationContext ► ParentContext
Gets the parent context.
Declaration Syntax
C#
ITranslationContext ParentContext { get; }
Value
The parent context.


SqlApi Property

SqlApi Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ITranslationContext ► SqlApi
Gets the SQL API.
Declaration Syntax
C#
SqlDataApi SqlApi { get; }
Value
The SQL API.


Tables Property

Tables Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ITranslationContext ► Tables
Gets the tables and their aliases.
Declaration Syntax
C#
IDictionary Tables { get; }
Value
The tables.


LiteralOpcodeTranslator Class

LiteralOpcodeTranslator Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LiteralOpcodeTranslator
Translates string literal to SQL.
Declaration Syntax
C#
public class LiteralOpcodeTranslator : IOpcodeTranslator
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LiteralOpcodeTranslator()()() | Initializes a new instance of the LiteralOpcodeTranslator class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTemplates(ITranslationContext) | Gets the templates.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RenderTemplateReference(ITranslationContext, Literal) | Renders the template reference.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Translate(Opcode, ITranslationContext) | Translates the specified opcode.
Inheritance Hierarchy
Object
LiteralOpcodeTranslator


LiteralOpcodeTranslator Constructor

LiteralOpcodeTranslator Constructor
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LiteralOpcodeTranslator ► LiteralOpcodeTranslator()()()
Initializes a new instance of the LiteralOpcodeTranslator class
Declaration Syntax
C#
public LiteralOpcodeTranslator()


GetTemplates Method (context)

GetTemplates Method (context)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LiteralOpcodeTranslator ► GetTemplates(ITranslationContext)
Gets the templates.
Declaration Syntax
C#
protected Dictionary<string, string> GetTemplates(
    ITranslationContext context
)
Parameters
context (ITranslationContext)
The context.
Return Value
The templates.


RenderTemplateReference Method (context, literal)

RenderTemplateReference Method (context, literal)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LiteralOpcodeTranslator ► RenderTemplateReference(ITranslationContext, Literal)
Renders the template reference.
Declaration Syntax
C#
protected virtual string RenderTemplateReference(
    ITranslationContext context,
    Literal literal
)
Parameters
context (ITranslationContext)
The context.
literal (Literal)
The literal.
Return Value
The template reference.


Translate Method (opcode, context)

Translate Method (opcode, context)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LiteralOpcodeTranslator ► Translate(Opcode, ITranslationContext)
Translates the specified opcode.
Declaration Syntax
C#
public string Translate(
    Opcode opcode,
    ITranslationContext context
)
Parameters
opcode (Opcode)
The opcode.
context (ITranslationContext)
The context.
Return Value
The translate.


LocalTranslationContext Class

LocalTranslationContext Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LocalTranslationContext
ITranlationContext implementation with isolated LocalData property.
Declaration Syntax
C#
public class LocalTranslationContext : ITranslationContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalTranslationContext(ITranslationContext) | Initializes a new instance of the LocalTranslationContext class.
 | AddSubquery(String, String) | Adds the subquery.
 | AddTable(String) | Adds the table.
 | Data | Gets the data.
 | Database | Gets the database for which translation is performed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Factory | Gets the factory.
 | Fields | Gets the fields.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNextAlias(String) | Gets the next alias.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LocalData | Gets the local data.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets the parameters manager for the SQL query.
 | ParentContext | Gets the parent context.
 | SqlApi | Gets the SQL API.
 | Tables | Gets the tables.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LocalTranslationContext


LocalTranslationContext Constructor (baseContext)

LocalTranslationContext Constructor (baseContext)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LocalTranslationContext ► LocalTranslationContext(ITranslationContext)
Initializes a new instance of the LocalTranslationContext class.
Declaration Syntax
C#
public LocalTranslationContext(
    ITranslationContext baseContext
)
Parameters
baseContext (ITranslationContext)
The base context.


AddSubquery Method (query, tableName)

AddSubquery Method (query, tableName)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LocalTranslationContext ► AddSubquery(String, String)
Adds the subquery.
Declaration Syntax
C#
public string AddSubquery(
    string query,
    string tableName
)
Parameters
query (String)
The query.
tableName (String)
Name of the table.
Return Value
The subquery.


AddTable Method (tableName)

AddTable Method (tableName)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LocalTranslationContext ► AddTable(String)
Adds the table.
Declaration Syntax
C#
public string AddTable(
    string tableName
)
Parameters
tableName (String)
Name of the table.
Return Value
The table.


Data Property

Data Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LocalTranslationContext ► Data
Gets the data.
Declaration Syntax
C#
public IDictionary Data { get; }
Value
The data.


Database Property

Database Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LocalTranslationContext ► Database
Gets the database for which translation is performed.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


Factory Property

Factory Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LocalTranslationContext ► Factory
Gets the factory.
Declaration Syntax
C#
public IOpcodeTranslatorFactory Factory { get; }
Value
The factory.


Fields Property

Fields Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LocalTranslationContext ► Fields
Gets the fields.
Declaration Syntax
C#
public IDictionary Fields { get; }
Value
The fields.


GetNextAlias Method (prefix)

GetNextAlias Method (prefix)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LocalTranslationContext ► GetNextAlias(String)
Gets the next alias.
Declaration Syntax
C#
public string GetNextAlias(
    string prefix
)
Parameters
prefix (String)
The prefix.
Return Value
The next alias.


LocalData Property

LocalData Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LocalTranslationContext ► LocalData
Gets the local data.
Declaration Syntax
C#
public IDictionary LocalData { get; }
Value
The local data.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LocalTranslationContext ► Parameters
Gets the parameters manager for the SQL query.
Declaration Syntax
C#
public ParametersList Parameters { get; }
Value
The parameters.


ParentContext Property

ParentContext Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LocalTranslationContext ► ParentContext
Gets the parent context.
Declaration Syntax
C#
public ITranslationContext ParentContext { get; }
Value
The parent context.


SqlApi Property

SqlApi Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LocalTranslationContext ► SqlApi
Gets the SQL API.
Declaration Syntax
C#
public SqlDataApi SqlApi { get; }
Value
The SQL API.


Tables Property

Tables Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LocalTranslationContext ► Tables
Gets the tables.
Declaration Syntax
C#
public IDictionary Tables { get; }
Value
The tables.


LogicalOperatorTranslator Class

LogicalOperatorTranslator Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LogicalOperatorTranslator
Translates logical operator (OR | AND) to SQL.
Declaration Syntax
C#
public class LogicalOperatorTranslator : IOpcodeTranslator
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LogicalOperatorTranslator()()() | Initializes a new instance of the LogicalOperatorTranslator class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Translate(Opcode, ITranslationContext) | Translates the specified opcode.
Inheritance Hierarchy
Object
LogicalOperatorTranslator


LogicalOperatorTranslator Constructor

LogicalOperatorTranslator Constructor
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LogicalOperatorTranslator ► LogicalOperatorTranslator()()()
Initializes a new instance of the LogicalOperatorTranslator class
Declaration Syntax
C#
public LogicalOperatorTranslator()


Translate Method (opcode, context)

Translate Method (opcode, context)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► LogicalOperatorTranslator ► Translate(Opcode, ITranslationContext)
Translates the specified opcode.
Declaration Syntax
C#
public string Translate(
    Opcode opcode,
    ITranslationContext context
)
Parameters
opcode (Opcode)
The opcode.
context (ITranslationContext)
The context.
Return Value
The translate.


NameFieldInfo Class

NameFieldInfo Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► NameFieldInfo
IFieldInfo for field references by name
Declaration Syntax
C#
public class NameFieldInfo : IFieldInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NameFieldInfo(String, ITranslationContext) | Initializes a new instance of the NameFieldInfo class.
 | Alias | Gets the alias/name of the table/view holding the field value. The view will have VALUE column.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NameFieldInfo


NameFieldInfo Constructor (fieldName, context)

NameFieldInfo Constructor (fieldName, context)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► NameFieldInfo ► NameFieldInfo(String, ITranslationContext)
Initializes a new instance of the NameFieldInfo class.
Declaration Syntax
C#
public NameFieldInfo(
    string fieldName,
    ITranslationContext context
)
Parameters
fieldName (String)
Name of the field.
context (ITranslationContext)
The context.


Alias Property

Alias Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► NameFieldInfo ► Alias
Gets the alias/name of the table/view holding the field value. The view will have VALUE column.
Declaration Syntax
C#
public string Alias { get; }
Value
The alias.


NumberValueTranslator Class

NumberValueTranslator Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► NumberValueTranslator
Converts number to SQL
Declaration Syntax
C#
public class NumberValueTranslator : IOpcodeTranslator
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NumberValueTranslator()()() | Initializes a new instance of the NumberValueTranslator class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Translate(Opcode, ITranslationContext) | Translates the specified opcode.
Inheritance Hierarchy
Object
NumberValueTranslator


NumberValueTranslator Constructor

NumberValueTranslator Constructor
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► NumberValueTranslator ► NumberValueTranslator()()()
Initializes a new instance of the NumberValueTranslator class
Declaration Syntax
C#
public NumberValueTranslator()


Translate Method (opcode, context)

Translate Method (opcode, context)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► NumberValueTranslator ► Translate(Opcode, ITranslationContext)
Translates the specified opcode.
Declaration Syntax
C#
public string Translate(
    Opcode opcode,
    ITranslationContext context
)
Parameters
opcode (Opcode)
The opcode.
context (ITranslationContext)
The context.
Return Value
The translate.


ParametersList Class

ParametersList Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ParametersList
Passes SQL parameters from translator to the caller.
Declaration Syntax
C#
public class ParametersList
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ParametersList()()() | Initializes a new instance of the ParametersList class
 | AddParameter(Object) | Adds the parameter.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToArray()()() | Converts the ParametersList to an array of objects.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ParametersList


ParametersList Constructor

ParametersList Constructor
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ParametersList ► ParametersList()()()
Initializes a new instance of the ParametersList class
Declaration Syntax
C#
public ParametersList()


AddParameter Method (value)

AddParameter Method (value)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ParametersList ► AddParameter(Object)
Adds the parameter.
Declaration Syntax
C#
public string AddParameter(
    Object value
)
Parameters
value (Object)
The value.
Return Value
The parameter.


ToArray Method

ToArray Method
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► ParametersList ► ToArray()()()
Converts the ParametersList to an array of objects.
Declaration Syntax
C#
public Object[] ToArray()
Return Value
The array of parameters suitable for SqlDataApi.


QueryToSqlTranslator Class

QueryToSqlTranslator Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator
Summary description for QueryToSqlTranslator.
Declaration Syntax
C#
public class QueryToSqlTranslator
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QueryToSqlTranslator(SqlDataApi) | Initializes a new instance of the QueryToSqlTranslator class.
 | _api | Database-specific SQL Api
 | _factory | Factory of translator objects
 | AddConditionJoint(Boolean, StringBuilder) | Adds the condition joint.
 | AddExtraJoins(ITranslationContext, StringBuilder) | Adds the extra joins.
 | AddFieldJoins(ITranslationContext, StringBuilder) | Adds the field joins.
 | AddInitialStatement(StringBuilder) | Adds the initial statement.
 | AddName(StringBuilder, Object) | Adds the name to the query.
 | AddNameFilter(String, StringBuilder) | Adds the name filter.
 | AddNestedQuery(Step, String, StringBuilder) | Adds the nested query.
 | AddRootItemFilter(ParametersList, StringBuilder) | Adds the root item filter.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetName(Step) | Gets the name.
 | GetPredicate(Step) | Gets the predicate.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TranslateQuery(String, CallContext, ParametersList) | Translates the query.
Inheritance Hierarchy
Object
QueryToSqlTranslator


QueryToSqlTranslator Constructor (api)

QueryToSqlTranslator Constructor (api)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator ► QueryToSqlTranslator(SqlDataApi)
Initializes a new instance of the QueryToSqlTranslator class.
Declaration Syntax
C#
public QueryToSqlTranslator(
    SqlDataApi api
)
Parameters
api (SqlDataApi)
The API.


_api Field

_api Field
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator ► _api
Database-specific SQL Api
Declaration Syntax
C#
protected SqlDataApi _api


_factory Field

_factory Field
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator ► _factory
Factory of translator objects
Declaration Syntax
C#
protected IOpcodeTranslatorFactory _factory


AddConditionJoint Method (whereAppended, builder)

AddConditionJoint Method (whereAppended, builder)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator ► AddConditionJoint(Boolean, StringBuilder)
Adds the condition joint.
Declaration Syntax
C#
protected virtual bool AddConditionJoint(
    bool whereAppended,
    StringBuilder builder
)
Parameters
whereAppended (Boolean)
if set to true this instance is where appended.
builder (StringBuilder)
The builder.
Return Value
The condition joint.


AddExtraJoins Method (context, builder)

AddExtraJoins Method (context, builder)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator ► AddExtraJoins(ITranslationContext, StringBuilder)
Adds the extra joins.
Declaration Syntax
C#
protected virtual void AddExtraJoins(
    ITranslationContext context,
    StringBuilder builder
)
Parameters
context (ITranslationContext)
The context.
builder (StringBuilder)
The builder.


AddFieldJoins Method (context, builder)

AddFieldJoins Method (context, builder)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator ► AddFieldJoins(ITranslationContext, StringBuilder)
Adds the field joins.
Declaration Syntax
C#
protected virtual void AddFieldJoins(
    ITranslationContext context,
    StringBuilder builder
)
Parameters
context (ITranslationContext)
The context.
builder (StringBuilder)
The builder.


AddInitialStatement Method (builder)

AddInitialStatement Method (builder)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator ► AddInitialStatement(StringBuilder)
Adds the initial statement.
Declaration Syntax
C#
protected virtual void AddInitialStatement(
    StringBuilder builder
)
Parameters
builder (StringBuilder)
The builder.


AddName Method (builder, name)

AddName Method (builder, name)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator ► AddName(StringBuilder, Object)
Adds the name to the query.
Declaration Syntax
C#
protected void AddName(
    StringBuilder builder,
    Object name
)
Parameters
builder (StringBuilder)
The builder.
name (Object)
The name.


AddNameFilter Method (name, builder)

AddNameFilter Method (name, builder)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator ► AddNameFilter(String, StringBuilder)
Adds the name filter.
Declaration Syntax
C#
protected virtual void AddNameFilter(
    string name,
    StringBuilder builder
)
Parameters
name (String)
The name.
builder (StringBuilder)
The builder.


AddNestedQuery Method (step, sql, builder)

AddNestedQuery Method (step, sql, builder)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator ► AddNestedQuery(Step, String, StringBuilder)
Adds the nested query.
Declaration Syntax
C#
protected virtual void AddNestedQuery(
    Step step,
    string sql,
    StringBuilder builder
)
Parameters
step (Step)
The step.
sql (String)
The SQL.
builder (StringBuilder)
The builder.


AddRootItemFilter Method (parameters, builder)

AddRootItemFilter Method (parameters, builder)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator ► AddRootItemFilter(ParametersList, StringBuilder)
Adds the root item filter.
Declaration Syntax
C#
protected virtual void AddRootItemFilter(
    ParametersList parameters,
    StringBuilder builder
)
Parameters
parameters (ParametersList)
The parameters.
builder (StringBuilder)
The builder.


GetName Method (step)

GetName Method (step)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator ► GetName(Step)
Gets the name.
Declaration Syntax
C#
protected string GetName(
    Step step
)
Parameters
step (Step)
The step.
Return Value
The name.


GetPredicate Method (step)

GetPredicate Method (step)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator ► GetPredicate(Step)
Gets the predicate.
Declaration Syntax
C#
protected Predicate GetPredicate(
    Step step
)
Parameters
step (Step)
The step.
Return Value
The predicate.


TranslateQuery Method (query, callContext, parameters)

TranslateQuery Method (query, callContext, parameters)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► QueryToSqlTranslator ► TranslateQuery(String, CallContext, ParametersList)
Translates the query.
Declaration Syntax
C#
public virtual string TranslateQuery(
    string query,
    CallContext callContext,
    ParametersList parameters
)
Parameters
query (String)
The query.
callContext (CallContext)
The call context.
parameters (ParametersList)
The parameters.
Return Value
The query.


RelationOperatorTraits Class

RelationOperatorTraits Class
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► RelationOperatorTraits
Description for comparison operators other that '==' and '!=';
Declaration Syntax
C#
public class RelationOperatorTraits : IOperatorTraits
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RelationOperatorTraits(String) | Initializes a new instance of the RelationOperatorTraits class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperatorString(ITranslationContext, ITranslationContext) | Gets the operator string.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NeedsSimpleValues | Gets a value indicating whether the IOperatorTraits needss the simple values.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RelationOperatorTraits


RelationOperatorTraits Constructor (operatorString)

RelationOperatorTraits Constructor (operatorString)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► RelationOperatorTraits ► RelationOperatorTraits(String)
Initializes a new instance of the RelationOperatorTraits class.
Declaration Syntax
C#
public RelationOperatorTraits(
    string operatorString
)
Parameters
operatorString (String)
The operator string.


GetOperatorString Method (left, right)

GetOperatorString Method (left, right)
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► RelationOperatorTraits ► GetOperatorString(ITranslationContext, ITranslationContext)
Gets the operator string.
Declaration Syntax
C#
public string GetOperatorString(
    ITranslationContext left,
    ITranslationContext right
)
Parameters
left (ITranslationContext)
The left.
right (ITranslationContext)
The right.
Return Value
The operator string.


NeedsSimpleValues Property

NeedsSimpleValues Property
Namespaces ► Sitecore.Data.DataProviders.Sql.FastQuery ► RelationOperatorTraits ► NeedsSimpleValues
Gets a value indicating whether the IOperatorTraits needss the simple values.
Declaration Syntax
C#
public bool NeedsSimpleValues { get; }
Value
true if the IOperatorTraits needss the simple values; otherwise, false.


Sitecore.Data.DataProviders.SqlServer Namespace

Sitecore.Data.DataProviders.SqlServer Namespace
Namespaces ► Sitecore.Data.DataProviders.SqlServer
Declaration Syntax
C#
namespace Sitecore.Data.DataProviders.SqlServer
Types
All Types Classes
Icon | Type | Description
 | SqlServerHelper | SqlServerHelper class
 | SqlServerStream | SqlServerStream class


SqlServerHelper Class

SqlServerHelper Class
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerHelper
SqlServerHelper class
Declaration Syntax
C#
public static class SqlServerHelper
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetInt(SqlDataReader, Int32) | Gets an Int32 value from a reader.
 | GetLong(SqlDataReader, Int32) | Gets a Int64 value from a reader.
Inheritance Hierarchy
Object
SqlServerHelper


GetInt Method (reader, columnIndex)

GetInt Method (reader, columnIndex)
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerHelper ► GetInt(SqlDataReader, Int32)
Gets an Int32 value from a reader.
Declaration Syntax
C#
public static int GetInt(
    SqlDataReader reader,
    int columnIndex
)
Parameters
reader (SqlDataReader)
The reader.
columnIndex (Int32)
Index of the column.
Return Value


GetLong Method (reader, columnIndex)

GetLong Method (reader, columnIndex)
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerHelper ► GetLong(SqlDataReader, Int32)
Gets a Int64 value from a reader.
Declaration Syntax
C#
public static long GetLong(
    SqlDataReader reader,
    int columnIndex
)
Parameters
reader (SqlDataReader)
The reader.
columnIndex (Int32)
Index of the column.


SqlServerStream Class

SqlServerStream Class
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerStream
SqlServerStream class
Declaration Syntax
C#
public class SqlServerStream : Stream
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerStream(SqlDataReader, Int64) | Initializes a new instance of the SqlServerStream class.
 | BeginRead(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead | When overridden in a derived class, gets a value indicating whether the current stream supports reading. (Overrides Stream.CanRead.)
 | CanSeek | When overridden in a derived class, gets a value indicating whether the current stream supports seeking. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | When overridden in a derived class, gets a value indicating whether the current stream supports writing. (Overrides Stream.CanWrite.)
 | Close()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Overrides Stream.Close()()().)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()() | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Overrides Stream.Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length | When overridden in a derived class, gets the length in bytes of the stream. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | When overridden in a derived class, gets or sets the position within the current stream. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[], Int32, Int32) | When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Overrides Stream.Read(array<Byte>[]()[], Int32, Int32).)
 | ReadByte()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | When overridden in a derived class, sets the position within the current stream. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | When overridden in a derived class, sets the length of the current stream. (Overrides Stream.SetLength(Int64).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Write(array<Byte>[]()[], Int32, Int32) | When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Overrides Stream.Write(array<Byte>[]()[], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | SqlServerStream


SqlServerStream Constructor (reader, length)

SqlServerStream Constructor (reader, length)
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerStream ► SqlServerStream(SqlDataReader, Int64)
Initializes a new instance of the SqlServerStream class.
Declaration Syntax
C#
public SqlServerStream(
    SqlDataReader reader,
    long length
)
Parameters
reader (SqlDataReader)
The reader.
length (Int64)
The length of the data in the stream.


CanRead Property

CanRead Property
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerStream ► CanRead
When overridden in a derived class, gets a value indicating whether the current stream supports reading.
Declaration Syntax
C#
public override bool CanRead { get; }
Return Value
true if the stream supports reading; otherwise, false.


CanSeek Property

CanSeek Property
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerStream ► CanSeek
When overridden in a derived class, gets a value indicating whether the current stream supports seeking.
Declaration Syntax
C#
public override bool CanSeek { get; }
Return Value
true if the stream supports seeking; otherwise, false.


CanWrite Property

CanWrite Property
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerStream ► CanWrite
When overridden in a derived class, gets a value indicating whether the current stream supports writing.
Declaration Syntax
C#
public override bool CanWrite { get; }
Return Value
true if the stream supports writing; otherwise, false.


Close Method

Close Method
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerStream ► Close()()()
Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.
Declaration Syntax
C#
public override void Close()


Flush Method

Flush Method
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerStream ► Flush()()()
When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device.
Declaration Syntax
C#
public override void Flush()
Exceptions
Exception | Condition
IOException | An I/O error occurs.


Length Property

Length Property
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerStream ► Length
When overridden in a derived class, gets the length in bytes of the stream.
Declaration Syntax
C#
public override long Length { get; }
Return Value
A long value representing the length of the stream in bytes.
Exceptions
Exception | Condition
NotSupportedException | A class derived from Stream does not support seeking.
ObjectDisposedException | Methods were called after the stream was closed.


Position Property

Position Property
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerStream ► Position
When overridden in a derived class, gets or sets the position within the current stream.
Declaration Syntax
C#
public override long Position { get; set; }
Return Value
The current position within the stream.
Exceptions
Exception | Condition
IOException | An I/O error occurs.
NotSupportedException | The stream does not support seeking.
ObjectDisposedException | Methods were called after the stream was closed.


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerStream ► Read(array<Byte>[]()[], Int32, Int32)
When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.
Declaration Syntax
C#
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Parameters
buffer (array< Byte >[]()[])
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset (Int32)
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count (Int32)
The maximum number of bytes to be read from the current stream.
Return Value
The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.
Exceptions
Exception | Condition
ArgumentException | The sum of offset and count is larger than the buffer length.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | offset or count is negative.
IOException | An I/O error occurs.
NotSupportedException | The stream does not support reading.
ObjectDisposedException | Methods were called after the stream was closed.


Seek Method (offset, origin)

Seek Method (offset, origin)
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerStream ► Seek(Int64, SeekOrigin)
When overridden in a derived class, sets the position within the current stream.
Declaration Syntax
C#
public override long Seek(
    long offset,
    SeekOrigin origin
)
Parameters
offset (Int64)
A byte offset relative to the origin parameter.
origin (SeekOrigin)
A value of type SeekOrigin indicating the reference point used to obtain the new position.
Return Value
The new position within the current stream.
Exceptions
Exception | Condition
IOException | An I/O error occurs.
NotSupportedException | The stream does not support seeking, such as if the stream is constructed from a pipe or console output.
ObjectDisposedException | Methods were called after the stream was closed.


SetLength Method (value)

SetLength Method (value)
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerStream ► SetLength(Int64)
When overridden in a derived class, sets the length of the current stream.
Declaration Syntax
C#
public override void SetLength(
    long value
)
Parameters
value (Int64)
The desired length of the current stream in bytes.
Exceptions
Exception | Condition
IOException | An I/O error occurs.
NotSupportedException | The stream does not support both writing and seeking, such as if the stream is constructed from a pipe or console output.
ObjectDisposedException | Methods were called after the stream was closed.


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
Namespaces ► Sitecore.Data.DataProviders.SqlServer ► SqlServerStream ► Write(array<Byte>[]()[], Int32, Int32)
When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.
Declaration Syntax
C#
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Parameters
buffer (array< Byte >[]()[])
An array of bytes. This method copies count bytes from buffer to the current stream.
offset (Int32)
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count (Int32)
The number of bytes to be written to the current stream.
Exceptions
Exception | Condition
ArgumentException | The sum of offset and count is greater than the buffer length.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | offset or count is negative.
IOException | An I/O error occurs.
NotSupportedException | The stream does not support writing.
ObjectDisposedException | Methods were called after the stream was closed.


Sitecore.Data.Engines Namespace

Sitecore.Data.Engines Namespace
Namespaces ► Sitecore.Data.Engines
Declaration Syntax
C#
namespace Sitecore.Data.Engines
Types
All Types Classes Enumerations
Icon | Type | Description
 | HistoryEntry..::.Builder | Builder used for generating HistoryEntrys.
 | DataEngine | The engine dealing with data retrieval and update.
 | DataEngineCommand<(Of <(TReturnType, TCommandType>)>) | Base class for engine commands
 | EngineCommand<(Of <(TReturnType, TCommandType>)>) | Base class for engine commands
 | DataEngineCommand<(Of <(TReturnType, TCommandType>)>)..::.EngineLockingType | EngineLockingType class
 | HistoryAction |
 | HistoryAddedEventArgs | HistoryAddedEventArgs
 | HistoryCategory |
 | HistoryEngine | The engine dealing with data history.
 | HistoryEntry | Defines an entry in the history.
 | HistoryStorage | The abstract base class for data history storage providers.
 | SyncOperationContext | Notifies database engines to make all operations synchronously.
 | TemplateEngine | The template engine.
 | WorkflowEngine | The engine dealing with workflows


DataEngine Class

DataEngine Class
Namespaces ► Sitecore.Data.Engines ► DataEngine
The engine dealing with data retrieval and update.
Declaration Syntax
C#
public class DataEngine
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataEngine(Database) | Initializes a new instance of the DataEngine class.
 | AddedFromTemplate |
 | AddedVersion |
 | AddFromTemplate(String, ID, Item, ID) | Adds a new item from a template.
 | AddingFromTemplate |
 | AddingVersion |
 | AddVersion(Item) | Adds a new version to an item by copying the data from an existing version.
 | BlobStreamExists(Guid) | Determines whether the specified field contains a BLOB value.
 | Commands | Gets the command collection.
 | CopiedItem |
 | CopyingItem |
 | CopyItem(Item, Item, Boolean, String, ID) | Copies a specified item.
 | CopyProcessedSingleItem | Occurs for each item that 'copy item' operation processes.
 | CreatedItem |
 | CreateItem(String, Item, ID, ID) | Creates an empty item.
 | CreatingItem |
 | Database | Gets the database associated with the engine.
 | DeletedItem |
 | DeleteItem(Item) | Deletes an item.
 | DeleteProcessedSingleItem | Occurs for each item that 'delete item' operation processes.
 | DeletingItem |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBlobStream(Guid) | Gets the BLOB stream associated with a field.
 | GetChildren(Item) | Gets the children of an item.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(ID, Language, Version) | Gets an item.
 | GetParent(Item) | Gets the parent of an item.
 | GetRootItem(Language, Version) | Gets the root item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersions(Item, Language) | Gets the version numbers of an item.
 | HasChildren(Item) | Determines whether the specified item has children.
 | ItemAccessLock |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MovedItem |
 | MoveItem(Item, Item) | Moves an item.
 | MovingItem |
 | RaiseAddedFromTemplate(String, ID, Item, ID, Item) | Raises the 'added from template' event.
 | RaiseAddedVersion(Item, Item) | Raises the 'added version' event.
 | RaiseCopiedItem(Item, Item, String, ID, Boolean, Item) | Raises the 'copied item' event.
 | RaiseCopyProcessedSingleItem(ID, ID, ID) | Raises the copy processed single item.
 | RaiseCreatedItem(ID, String, ID, Item, Item) | Raises the created item event.
 | RaiseDeletedItem(Item, ID, Boolean) | Raises the deleted event.
 | RaiseDeleteProcessedSingleItem(ID) | Raises the 'delete processed single item' event.
 | RaiseDeletingItem(Item, Boolean%) | Raises the deleting event.
 | RaiseMovedItem(Item, Item, Boolean) | Raises the 'moved item' event.
 | RaiseRemovedVersion(Item, Boolean) | Raises the 'removed version' event.
 | RaiseSavedItem(Item, Boolean) | Raises the 'saved item' event.
 | RemoveData(ID, Language, Boolean) | Removes all data in a specific language from an item.
 | RemovedData |
 | RemovedVersion |
 | RemoveVersion(Item) | Removes a version from an item.
 | RemovingData |
 | RemovingVersion |
 | ResolvePath(String) | Resolves an item path to an id.
 | SavedItem |
 | SaveItem(Item) | Saves changes to an item.
 | SavingItem |
 | SetBlobStream(Stream, Guid) | Sets the BLOB stream associated with a field.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DataEngine


DataEngine Constructor (database)

DataEngine Constructor (database)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► DataEngine(Database)
Initializes a new instance of the DataEngine class.
Declaration Syntax
C#
public DataEngine(
    Database database
)
Parameters
database (Database)
The database.


AddedFromTemplate Event

AddedFromTemplate Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► AddedFromTemplate
Declaration Syntax
C#
public event EventHandler<ExecutedEventArgs<AddFromTemplateCommand>> AddedFromTemplate


AddedVersion Event

AddedVersion Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► AddedVersion
Declaration Syntax
C#
public event EventHandler<ExecutedEventArgs<AddVersionCommand>> AddedVersion


AddFromTemplate Method (itemName, templateId, destination, newId)

AddFromTemplate Method (itemName, templateId, destination, newId)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► AddFromTemplate(String, ID, Item, ID)
Adds a new item from a template.
Declaration Syntax
C#
public Item AddFromTemplate(
    string itemName,
    ID templateId,
    Item destination,
    ID newId
)
Parameters
itemName (String)
Name of the item.
templateId (ID)
The template id.
destination (Item)
The target item. This will be the parent of the new item.
newId (ID)
The id of the new item.
Return Value

The newly created item. If the item could not be created, null is returned.

Note that the item is returned in the same language as the destination item.


AddingFromTemplate Event

AddingFromTemplate Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► AddingFromTemplate
Declaration Syntax
C#
public event EventHandler<ExecutingEventArgs<AddFromTemplateCommand>> AddingFromTemplate


AddingVersion Event

AddingVersion Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► AddingVersion
Declaration Syntax
C#
public event EventHandler<ExecutingEventArgs<AddVersionCommand>> AddingVersion


AddVersion Method (item)

AddVersion Method (item)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► AddVersion(Item)
Adds a new version to an item by copying the data from an existing version.
Declaration Syntax
C#
public Item AddVersion(
    Item item
)
Parameters
item (Item)
The item that will have a version added.
Return Value
The added version of the item. If a version could not be added to the item, null is returned.


BlobStreamExists Method (blobId)

BlobStreamExists Method (blobId)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► BlobStreamExists(Guid)
Determines whether the specified field contains a BLOB value.
Declaration Syntax
C#
public bool BlobStreamExists(
    Guid blobId
)
Parameters
blobId (Guid)
The BLOB id.
Return Value
The value.


Commands Property

Commands Property
Namespaces ► Sitecore.Data.Engines ► DataEngine ► Commands
Gets the command collection.
Declaration Syntax
C#
public CommandCollection Commands { get; }
Value
The commands.


CopiedItem Event

CopiedItem Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► CopiedItem
Declaration Syntax
C#
public event EventHandler<ExecutedEventArgs<CopyItemCommand>> CopiedItem


CopyingItem Event

CopyingItem Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► CopyingItem
Declaration Syntax
C#
public event EventHandler<ExecutingEventArgs<CopyItemCommand>> CopyingItem


CopyItem Method (source, destination, deep, copyName, copyId)

CopyItem Method (source, destination, deep, copyName, copyId)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► CopyItem(Item, Item, Boolean, String, ID)
Copies a specified item.
Declaration Syntax
C#
public Item CopyItem(
    Item source,
    Item destination,
    bool deep,
    string copyName,
    ID copyId
)
Parameters
source (Item)
The item to copy.
destination (Item)
The destination.
deep (Boolean)
If set to true, child items will be copied recursively.
copyName (String)
Name of the copy.
copyId (ID)
Id of the copy.
Return Value


CopyProcessedSingleItem Event

CopyProcessedSingleItem Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► CopyProcessedSingleItem
Occurs for each item that 'copy item' operation processes.
Declaration Syntax
C#
public event EventHandler<CopyProcessedSingleItemEventArgs> CopyProcessedSingleItem


CreatedItem Event

CreatedItem Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► CreatedItem
Declaration Syntax
C#
public event EventHandler<ExecutedEventArgs<CreateItemCommand>> CreatedItem


CreateItem Method (itemName, destination, templateId, newId)

CreateItem Method (itemName, destination, templateId, newId)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► CreateItem(String, Item, ID, ID)
Creates an empty item.
Declaration Syntax
C#
public Item CreateItem(
    string itemName,
    Item destination,
    ID templateId,
    ID newId
)
Parameters
itemName (String)
Name of the item.
destination (Item)
The destination.
templateId (ID)
The template ID.
newId (ID)
The item id.
Return Value
The created item. If the item could not be created, null is returned.


CreatingItem Event

CreatingItem Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► CreatingItem
Declaration Syntax
C#
public event EventHandler<ExecutingEventArgs<CreateItemCommand>> CreatingItem


Database Property

Database Property
Namespaces ► Sitecore.Data.Engines ► DataEngine ► Database
Gets the database associated with the engine.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


DeletedItem Event

DeletedItem Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► DeletedItem
Declaration Syntax
C#
public event EventHandler<ExecutedEventArgs<DeleteItemCommand>> DeletedItem


DeleteItem Method (item)

DeleteItem Method (item)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► DeleteItem(Item)
Deletes an item.
Declaration Syntax
C#
public bool DeleteItem(
    Item item
)
Parameters
item (Item)
The item to delete.
Return Value
True if the item was deleted, false otherwise.


DeleteProcessedSingleItem Event

DeleteProcessedSingleItem Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► DeleteProcessedSingleItem
Occurs for each item that 'delete item' operation processes.
Declaration Syntax
C#
public event EventHandler<DeleteProcessedSingleItemEventArgs> DeleteProcessedSingleItem


DeletingItem Event

DeletingItem Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► DeletingItem
Declaration Syntax
C#
public event EventHandler<ExecutingEventArgs<DeleteItemCommand>> DeletingItem


GetBlobStream Method (blobId)

GetBlobStream Method (blobId)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► GetBlobStream(Guid)
Gets the BLOB stream associated with a field.
Declaration Syntax
C#
public Stream GetBlobStream(
    Guid blobId
)
Parameters
blobId (Guid)
The BLOB id.
Return Value
The stream.


GetChildren Method (item)

GetChildren Method (item)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► GetChildren(Item)
Gets the children of an item.
Declaration Syntax
C#
public ItemList GetChildren(
    Item item
)
Parameters
item (Item)
The parent item.
Return Value
The child items.


GetItem Method (itemId, language, version)

GetItem Method (itemId, language, version)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► GetItem(ID, Language, Version)
Gets an item.
Declaration Syntax
C#
public Item GetItem(
    ID itemId,
    Language language,
    Version version
)
Parameters
itemId (ID)
The id of the item to get.
language (Language)
The language of the item to get.
version (Version)
The version of the item to get.
Return Value
The item. If no item is found, null is returned.


GetParent Method (item)

GetParent Method (item)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► GetParent(Item)
Gets the parent of an item.
Declaration Syntax
C#
public Item GetParent(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The parent item.


GetRootItem Method (language, version)

GetRootItem Method (language, version)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► GetRootItem(Language, Version)
Gets the root item.
Declaration Syntax
C#
public Item GetRootItem(
    Language language,
    Version version
)
Parameters
language (Language)
The language to return.
version (Version)
The version to return.
Return Value
The root item. If no item is found, null is returned.


GetVersions Method (item, language)

GetVersions Method (item, language)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► GetVersions(Item, Language)
Gets the version numbers of an item.
Declaration Syntax
C#
public VersionCollection GetVersions(
    Item item,
    Language language
)
Parameters
item (Item)
The item.
language (Language)
The language.
Return Value
The list of versions.


HasChildren Method (item)

HasChildren Method (item)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► HasChildren(Item)
Determines whether the specified item has children.
Declaration Syntax
C#
public bool HasChildren(
    Item item
)
Parameters
item (Item)
The parent item.
Return Value
The child items.


ItemAccessLock Field

ItemAccessLock Field
Namespaces ► Sitecore.Data.Engines ► DataEngine ► ItemAccessLock
Declaration Syntax
C#
public readonly ReaderWriterLock ItemAccessLock


MovedItem Event

MovedItem Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► MovedItem
Declaration Syntax
C#
public event EventHandler<ExecutedEventArgs<MoveItemCommand>> MovedItem


MoveItem Method (item, destination)

MoveItem Method (item, destination)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► MoveItem(Item, Item)
Moves an item.
Declaration Syntax
C#
public bool MoveItem(
    Item item,
    Item destination
)
Parameters
item (Item)
The item to move.
destination (Item)
The destination. This will become the new parent of item.
Return Value
true if the item was moved; false otherwise.


MovingItem Event

MovingItem Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► MovingItem
Declaration Syntax
C#
public event EventHandler<ExecutingEventArgs<MoveItemCommand>> MovingItem


RaiseAddedFromTemplate Method (itemName, templateId, destination, newId, result)

RaiseAddedFromTemplate Method (itemName, templateId, destination, newId, result)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RaiseAddedFromTemplate(String, ID, Item, ID, Item)
Raises the 'added from template' event.
Declaration Syntax
C#
public void RaiseAddedFromTemplate(
    string itemName,
    ID templateId,
    Item destination,
    ID newId,
    Item result
)
Parameters
itemName (String)
Name of the item.
templateId (ID)
The template id.
destination (Item)
The destination.
newId (ID)
The new id.
result (Item)
The result.


RaiseAddedVersion Method (item, result)

RaiseAddedVersion Method (item, result)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RaiseAddedVersion(Item, Item)
Raises the 'added version' event.
Declaration Syntax
C#
public void RaiseAddedVersion(
    Item item,
    Item result
)
Parameters
item (Item)
The item.
result (Item)
The result.


RaiseCopiedItem Method (source, destination, copyName, copyId, deep, result)

RaiseCopiedItem Method (source, destination, copyName, copyId, deep, result)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RaiseCopiedItem(Item, Item, String, ID, Boolean, Item)
Raises the 'copied item' event.
Declaration Syntax
C#
public void RaiseCopiedItem(
    Item source,
    Item destination,
    string copyName,
    ID copyId,
    bool deep,
    Item result
)
Parameters
source (Item)
The source.
destination (Item)
The destination.
copyName (String)
Name of the copy.
copyId (ID)
The copy id.
deep (Boolean)
if set to true [deep].
result (Item)
The result.


RaiseCopyProcessedSingleItem Method (sourceID, destinationID, copyID)

RaiseCopyProcessedSingleItem Method (sourceID, destinationID, copyID)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RaiseCopyProcessedSingleItem(ID, ID, ID)
Raises the copy processed single item.
Declaration Syntax
C#
public void RaiseCopyProcessedSingleItem(
    ID sourceID,
    ID destinationID,
    ID copyID
)
Parameters
sourceID (ID)
The source ID.
destinationID (ID)
The destination ID.
copyID (ID)
The copy ID.


RaiseCreatedItem Method (itemId, itemName, templateId, destination, result)

RaiseCreatedItem Method (itemId, itemName, templateId, destination, result)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RaiseCreatedItem(ID, String, ID, Item, Item)
Raises the created item event.
Declaration Syntax
C#
public void RaiseCreatedItem(
    ID itemId,
    string itemName,
    ID templateId,
    Item destination,
    Item result
)
Parameters
itemId (ID)
The item id.
itemName (String)
Name of the item.
templateId (ID)
The template id.
destination (Item)
The destination.
result (Item)
The result.


RaiseDeletedItem Method (item, parentId, result)

RaiseDeletedItem Method (item, parentId, result)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RaiseDeletedItem(Item, ID, Boolean)
Raises the deleted event.
Declaration Syntax
C#
public void RaiseDeletedItem(
    Item item,
    ID parentId,
    bool result
)
Parameters
item (Item)
The item.
parentId (ID)
The parent id.
result (Boolean)
The result.


RaiseDeleteProcessedSingleItem Method (itemID)

RaiseDeleteProcessedSingleItem Method (itemID)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RaiseDeleteProcessedSingleItem(ID)
Raises the 'delete processed single item' event.
Declaration Syntax
C#
public void RaiseDeleteProcessedSingleItem(
    ID itemID
)
Parameters
itemID (ID)
The item ID.


RaiseDeletingItem Method (item, cancelled)

RaiseDeletingItem Method (item, cancelled)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RaiseDeletingItem(Item, Boolean%)
Raises the deleting event.
Declaration Syntax
C#
public void RaiseDeletingItem(
    Item item,
    out bool cancelled
)
Parameters
item (Item)
The item.
cancelled ( Boolean %)
if set to true this instance is cancelled.


RaiseMovedItem Method (item, destination, result)

RaiseMovedItem Method (item, destination, result)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RaiseMovedItem(Item, Item, Boolean)
Raises the 'moved item' event.
Declaration Syntax
C#
public void RaiseMovedItem(
    Item item,
    Item destination,
    bool result
)
Parameters
item (Item)
The item.
destination (Item)
The destination.
result (Boolean)
The result.


RaiseRemovedVersion Method (item, result)

RaiseRemovedVersion Method (item, result)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RaiseRemovedVersion(Item, Boolean)
Raises the 'removed version' event.
Declaration Syntax
C#
public void RaiseRemovedVersion(
    Item item,
    bool result
)
Parameters
item (Item)
The item.
result (Boolean)
The result.


RaiseSavedItem Method (item, result)

RaiseSavedItem Method (item, result)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RaiseSavedItem(Item, Boolean)
Raises the 'saved item' event.
Declaration Syntax
C#
public void RaiseSavedItem(
    Item item,
    bool result
)
Parameters
item (Item)
The item.
result (Boolean)
if set to true [result].


RemoveData Method (itemId, language, removeSharedData)

RemoveData Method (itemId, language, removeSharedData)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RemoveData(ID, Language, Boolean)
Removes all data in a specific language from an item.
Declaration Syntax
C#
public bool RemoveData(
    ID itemId,
    Language language,
    bool removeSharedData
)
Parameters
itemId (ID)
The item id.
language (Language)
The language of the data to remove. Specify Invariant to remove data in all languages.
removeSharedData (Boolean)
If set to true shared data is removed.
Return Value
true if the data was removed, otherwise false.


RemovedData Event

RemovedData Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RemovedData
Declaration Syntax
C#
public event EventHandler<ExecutedEventArgs<RemoveDataCommand>> RemovedData


RemovedVersion Event

RemovedVersion Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RemovedVersion
Declaration Syntax
C#
public event EventHandler<ExecutedEventArgs<RemoveVersionCommand>> RemovedVersion


RemoveVersion Method (item)

RemoveVersion Method (item)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RemoveVersion(Item)
Removes a version from an item.
Declaration Syntax
C#
public bool RemoveVersion(
    Item item
)
Parameters
item (Item)
The item representing the version to remove.
Return Value
true if the version was removed, otherwise false.


RemovingData Event

RemovingData Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RemovingData
Declaration Syntax
C#
public event EventHandler<ExecutingEventArgs<RemoveDataCommand>> RemovingData


RemovingVersion Event

RemovingVersion Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► RemovingVersion
Declaration Syntax
C#
public event EventHandler<ExecutingEventArgs<RemoveVersionCommand>> RemovingVersion


ResolvePath Method (itemPath)

ResolvePath Method (itemPath)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► ResolvePath(String)
Resolves an item path to an id.
Declaration Syntax
C#
public ID ResolvePath(
    string itemPath
)
Parameters
itemPath (String)
The item path.
Return Value
The id of the item with the path specified by itemPath.


SavedItem Event

SavedItem Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► SavedItem
Declaration Syntax
C#
public event EventHandler<ExecutedEventArgs<SaveItemCommand>> SavedItem


SaveItem Method (item)

SaveItem Method (item)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► SaveItem(Item)
Saves changes to an item.
Declaration Syntax
C#
public bool SaveItem(
    Item item
)
Parameters
item (Item)
The item.
Return Value
True if the item was saved, false otherwise.


SavingItem Event

SavingItem Event
Namespaces ► Sitecore.Data.Engines ► DataEngine ► SavingItem
Declaration Syntax
C#
public event EventHandler<ExecutingEventArgs<SaveItemCommand>> SavingItem


SetBlobStream Method (stream, blobId)

SetBlobStream Method (stream, blobId)
Namespaces ► Sitecore.Data.Engines ► DataEngine ► SetBlobStream(Stream, Guid)
Sets the BLOB stream associated with a field.
Declaration Syntax
C#
public bool SetBlobStream(
    Stream stream,
    Guid blobId
)
Parameters
stream (Stream)
The stream.
blobId (Guid)
The BLOB id.
Return Value


DataEngineCommand(TReturnType, TCommandType) Class

DataEngineCommand<(Of <(TReturnType, TCommandType>)>) Class
Namespaces ► Sitecore.Data.Engines ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>)
Base class for engine commands
Declaration Syntax
C#
public abstract class DataEngineCommand<TReturnType, TCommandType> : EngineCommand<TReturnType, TCommandType>
where TCommandType : new(), DataEngineCommand<TReturnType, TCommandType>
Generic Template Parameters
TReturnType
TCommandType
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataEngineCommand<(Of <(TReturnType, TCommandType>)>)()()() | Initializes a new instance of the DataEngineCommand<(Of <(TReturnType, TCommandType>)>) class
 | _lockType |
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).Clone()()().)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events.
 | Construct(DataEngine) | Constructs an instance of a command.
 | CreateInstance()()() | Creates an instance of the command class.
 | Database | Gets the database owning the engine.
 | DataSource | Gets the data source.
 | DoExecute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Engine | Gets the data engine associated with this command.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).FinalizeExecution()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).PrepareExecution()()().)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand<(Of <(TReturnType, TCommandType>)>)
 |  |  | AddFromTemplateCommand
 |  |  | AddVersionCommand
 |  |  | BlobStreamExistsCommand
 |  |  | CopyItemCommand
 |  |  | CreateItemCommand
 |  |  | DeleteItemCommand
 |  |  | GetBlobStreamCommand
 |  |  | GetChildrenCommand
 |  |  | GetItemCommand
 |  |  | GetParentCommand
 |  |  | GetRootItemCommand
 |  |  | GetVersionsCommand
 |  |  | HasChildrenCommand
 |  |  | MoveItemCommand
 |  |  | RemoveDataCommand
 |  |  | RemoveVersionCommand
 |  |  | ResolvePathCommand
 |  |  | SaveItemCommand
 |  |  | SetBlobStreamCommand


DataEngineCommand(TReturnType, TCommandType) Constructor

DataEngineCommand<(Of <(TReturnType, TCommandType>)>) Constructor
Namespaces ► Sitecore.Data.Engines ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>) ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>)()()()
Initializes a new instance of the DataEngineCommand<(Of <(TReturnType, TCommandType>)>) class
Declaration Syntax
C#
protected DataEngineCommand()


_lockType Field

_lockType Field
Namespaces ► Sitecore.Data.Engines ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>) ► _lockType
Declaration Syntax
C#
protected DataEngineCommand<(Of <(TReturnType, TCommandType>)>)..::.EngineLockingType _lockType


Clone Method

Clone Method
Namespaces ► Sitecore.Data.Engines ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>) ► Clone()()()
Members
Icon | Member | Description
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).Clone()()().)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events.


Clone Method

Clone Method
Namespaces ► Sitecore.Data.Engines ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>) ► Clone()()()
Clones the source object. Has the same effect as creating a new instance of the prototype.
Declaration Syntax
C#
public override TCommandType Clone()
Return Value


Clone Method (executingEvent, executedEvent)

Clone Method (executingEvent, executedEvent)
Namespaces ► Sitecore.Data.Engines ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>) ► Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>))
Clones the object and sets the events.
Declaration Syntax
C#
public virtual TCommandType Clone(
    EventHandler<ExecutingEventArgs<TCommandType>> executingEvent,
    EventHandler<ExecutedEventArgs<TCommandType>> executedEvent
)
Parameters
executingEvent (EventHandler<(Of <( ExecutingEventArgs <(Of <( TCommandType >)>)>)>))
The executing event.
executedEvent (EventHandler<(Of <( ExecutedEventArgs <(Of <( TCommandType >)>)>)>))
The executed event.
Return Value


Construct Method (engine)

Construct Method (engine)
Namespaces ► Sitecore.Data.Engines ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>) ► Construct(DataEngine)
Constructs an instance of a command.
Declaration Syntax
C#
public static TCommandType Construct(
    DataEngine engine
)
Parameters
engine (DataEngine)
The data engine.
Return Value


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>) ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected abstract TCommandType CreateInstance()
Return Value


Database Property

Database Property
Namespaces ► Sitecore.Data.Engines ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>) ► Database
Gets the database owning the engine.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


DataSource Property

DataSource Property
Namespaces ► Sitecore.Data.Engines ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>) ► DataSource
Gets the data source.
Declaration Syntax
C#
public DataSource DataSource { get; }
Value
The data source.


Engine Property

Engine Property
Namespaces ► Sitecore.Data.Engines ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>) ► Engine
Gets the data engine associated with this command.
Declaration Syntax
C#
public DataEngine Engine { get; set; }
Value
The data engine.


FinalizeExecution Method

FinalizeExecution Method
Namespaces ► Sitecore.Data.Engines ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>) ► FinalizeExecution()()()
Finalizes the execution.
Declaration Syntax
C#
protected override void FinalizeExecution()


PrepareExecution Method

PrepareExecution Method
Namespaces ► Sitecore.Data.Engines ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>) ► PrepareExecution()()()
Prepares the execution.
Declaration Syntax
C#
protected override void PrepareExecution()


DataEngineCommand(TReturnType, TCommandType).EngineLockingType Enumeration

DataEngineCommand<(Of <(TReturnType, TCommandType>)>)..::.EngineLockingType Enumeration
Namespaces ► Sitecore.Data.Engines ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>) ► DataEngineCommand<(Of <(TReturnType, TCommandType>)>)..::.EngineLockingType
EngineLockingType class
Declaration Syntax
C#
public enum EngineLockingType
Members
Member | Description
None |
Shared |
Exclusive |


EngineCommand(TReturnType, TCommandType) Class

EngineCommand<(Of <(TReturnType, TCommandType>)>) Class
Namespaces ► Sitecore.Data.Engines ► EngineCommand<(Of <(TReturnType, TCommandType>)>)
Base class for engine commands
Declaration Syntax
C#
public abstract class EngineCommand<TReturnType, TCommandType> : ICommand<TReturnType>,
    IPrototype<TCommandType>
where TCommandType : EngineCommand<TReturnType, TCommandType>
Generic Template Parameters
TReturnType
TCommandType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EngineCommand<(Of <(TReturnType, TCommandType>)>)()()() | Initializes a new instance of the EngineCommand<(Of <(TReturnType, TCommandType>)>) class
 | CanExecute()()() | Determines whether the command can be executed.
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the type.
 | DoExecute()()() | Executes the command.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command.
 | Executed()()() | Post processing handler.
 | ExecutedEvent | Gets the executed event.
 | ExecutingEvent | Gets the executing event.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution.
 | RaiseExecuted()()() | Raises the executed event.
 | RaiseExecuting(Boolean%) | Raises the executing event.
 | Result | Gets the result of the execution.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand<(Of <(TReturnType, TCommandType>)>)
 |  | DataEngineCommand<(Of <(TReturnType, TCommandType>)>)


EngineCommand(TReturnType, TCommandType) Constructor

EngineCommand<(Of <(TReturnType, TCommandType>)>) Constructor
Namespaces ► Sitecore.Data.Engines ► EngineCommand<(Of <(TReturnType, TCommandType>)>) ► EngineCommand<(Of <(TReturnType, TCommandType>)>)()()()
Initializes a new instance of the EngineCommand<(Of <(TReturnType, TCommandType>)>) class
Declaration Syntax
C#
protected EngineCommand()


CanExecute Method

CanExecute Method
Namespaces ► Sitecore.Data.Engines ► EngineCommand<(Of <(TReturnType, TCommandType>)>) ► CanExecute()()()
Determines whether the command can be executed.
Declaration Syntax
C#
protected virtual bool CanExecute()
Return Value
true if this instance can execute; otherwise, false.


Clone Method

Clone Method
Namespaces ► Sitecore.Data.Engines ► EngineCommand<(Of <(TReturnType, TCommandType>)>) ► Clone()()()
Clones the source object. Has the same effect as creating a new instance of the type.
Declaration Syntax
C#
public abstract TCommandType Clone()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines ► EngineCommand<(Of <(TReturnType, TCommandType>)>) ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected abstract TReturnType DoExecute()
Return Value
The result of execution.


Execute Method

Execute Method
Namespaces ► Sitecore.Data.Engines ► EngineCommand<(Of <(TReturnType, TCommandType>)>) ► Execute()()()
Executes the command.
Declaration Syntax
C#
public virtual TReturnType Execute()
Return Value
The result of execution.


Executed Method

Executed Method
Namespaces ► Sitecore.Data.Engines ► EngineCommand<(Of <(TReturnType, TCommandType>)>) ► Executed()()()
Post processing handler.
Declaration Syntax
C#
protected virtual void Executed()
Remarks

This method is called right after the command has been executed.

The result of the execution can be accessed through the Result property.


ExecutedEvent Property

ExecutedEvent Property
Namespaces ► Sitecore.Data.Engines ► EngineCommand<(Of <(TReturnType, TCommandType>)>) ► ExecutedEvent
Gets the executed event.
Declaration Syntax
C#
protected EventHandler<ExecutedEventArgs<TCommandType>> ExecutedEvent { get; set; }
Value
The executed event.


ExecutingEvent Property

ExecutingEvent Property
Namespaces ► Sitecore.Data.Engines ► EngineCommand<(Of <(TReturnType, TCommandType>)>) ► ExecutingEvent
Gets the executing event.
Declaration Syntax
C#
protected EventHandler<ExecutingEventArgs<TCommandType>> ExecutingEvent { get; set; }
Value
The executing event.


FinalizeExecution Method

FinalizeExecution Method
Namespaces ► Sitecore.Data.Engines ► EngineCommand<(Of <(TReturnType, TCommandType>)>) ► FinalizeExecution()()()
Finalizes the execution.
Declaration Syntax
C#
protected virtual void FinalizeExecution()


PrepareExecution Method

PrepareExecution Method
Namespaces ► Sitecore.Data.Engines ► EngineCommand<(Of <(TReturnType, TCommandType>)>) ► PrepareExecution()()()
Prepares the execution.
Declaration Syntax
C#
protected virtual void PrepareExecution()


RaiseExecuted Method

RaiseExecuted Method
Namespaces ► Sitecore.Data.Engines ► EngineCommand<(Of <(TReturnType, TCommandType>)>) ► RaiseExecuted()()()
Raises the executed event.
Declaration Syntax
C#
public virtual void RaiseExecuted()


RaiseExecuting Method (cancelled)

RaiseExecuting Method (cancelled)
Namespaces ► Sitecore.Data.Engines ► EngineCommand<(Of <(TReturnType, TCommandType>)>) ► RaiseExecuting(Boolean%)
Raises the executing event.
Declaration Syntax
C#
public virtual void RaiseExecuting(
    out bool cancelled
)
Parameters
cancelled ( Boolean %)
if set to true this event is cancelled.


Result Property

Result Property
Namespaces ► Sitecore.Data.Engines ► EngineCommand<(Of <(TReturnType, TCommandType>)>) ► Result
Gets the result of the execution.
Declaration Syntax
C#
public TReturnType Result { get; internal set; }
Value
The result of execution. If the command has not been executed yet, the value will be default(TReturnType).


HistoryAction Enumeration

HistoryAction Enumeration
Namespaces ► Sitecore.Data.Engines ► HistoryAction
Declaration Syntax
C#
public enum HistoryAction
Members
Member | Description
Unknown | Unknown.
AddedVersion | A new version was added to an existing item.
Copied | An item was copied.
Created | An new item was created.
Deleted | An item was deleted.
Moved | An item was moved.
Saved | An item was saved.
RemovedVersion | A version was removed from an existing item.


HistoryAddedEventArgs Class

HistoryAddedEventArgs Class
Namespaces ► Sitecore.Data.Engines ► HistoryAddedEventArgs
HistoryAddedEventArgs
Declaration Syntax
C#
public class HistoryAddedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HistoryAddedEventArgs(HistoryEntry, Database) | Initializes a new instance of the HistoryAddedEventArgs class.
 | Database | Gets the database.
 | Entry | Gets the entry that was added.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | HistoryAddedEventArgs


HistoryAddedEventArgs Constructor (entry, database)

HistoryAddedEventArgs Constructor (entry, database)
Namespaces ► Sitecore.Data.Engines ► HistoryAddedEventArgs ► HistoryAddedEventArgs(HistoryEntry, Database)
Initializes a new instance of the HistoryAddedEventArgs class.
Declaration Syntax
C#
public HistoryAddedEventArgs(
    HistoryEntry entry,
    Database database
)
Parameters
entry (HistoryEntry)
database (Database)


Database Property

Database Property
Namespaces ► Sitecore.Data.Engines ► HistoryAddedEventArgs ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


Entry Property

Entry Property
Namespaces ► Sitecore.Data.Engines ► HistoryAddedEventArgs ► Entry
Gets the entry that was added.
Declaration Syntax
C#
public HistoryEntry Entry { get; }
Value
The entry.


HistoryCategory Enumeration

HistoryCategory Enumeration
Namespaces ► Sitecore.Data.Engines ► HistoryCategory
Declaration Syntax
C#
public enum HistoryCategory
Members
Member | Description
Unknown | Unknown.
Item | Item.


HistoryEngine Class

HistoryEngine Class
Namespaces ► Sitecore.Data.Engines ► HistoryEngine
The engine dealing with data history.
Declaration Syntax
C#
public class HistoryEngine
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HistoryEngine(Database) | Constructs an instance of AuditEngine
 | AddedEntry |
 | Cleanup()()() | Removes outdated entries from storage.
 | Database | Gets the database associated with the engine.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHistory(DateTime, DateTime) | Gets the history for the database in a specified interval.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterItemCopied(Item, Item) | Registers an 'item created' event in the history storage.
 | RegisterItemCreated(Item) | Registers an 'item created' event in the history storage.
 | RegisterItemDeleted(Item, ID) | Registers an 'item deleted' event in the history storage.
 | RegisterItemMoved(Item, ID) | Registers an 'item moved' event in the history storage.
 | RegisterItemSaved(Item, ItemChanges) | Registers an 'item saved' event in the history storage.
 | RegisterVersionAdded(Item) | Registers an 'version added' event in the history storage.
 | RegisterVersionRemoved(Item) | Registers an 'version removed' event in the history storage.
 | SaveDotNetCallStack | Gets or sets a value indicating whether the HistoryEngine saves the dot net call stack.
 | Storage | Gets the storage provider.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HistoryEngine


HistoryEngine Constructor (database)

HistoryEngine Constructor (database)
Namespaces ► Sitecore.Data.Engines ► HistoryEngine ► HistoryEngine(Database)
Constructs an instance of AuditEngine
Declaration Syntax
C#
public HistoryEngine(
    Database database
)
Parameters
database (Database)
The database.


AddedEntry Event

AddedEntry Event
Namespaces ► Sitecore.Data.Engines ► HistoryEngine ► AddedEntry
Declaration Syntax
C#
public event EventHandler<HistoryAddedEventArgs> AddedEntry


Cleanup Method

Cleanup Method
Namespaces ► Sitecore.Data.Engines ► HistoryEngine ► Cleanup()()()
Removes outdated entries from storage.
Declaration Syntax
C#
public void Cleanup()


Database Property

Database Property
Namespaces ► Sitecore.Data.Engines ► HistoryEngine ► Database
Gets the database associated with the engine.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


GetHistory Method (from, to)

GetHistory Method (from, to)
Namespaces ► Sitecore.Data.Engines ► HistoryEngine ► GetHistory(DateTime, DateTime)
Gets the history for the database in a specified interval.
Declaration Syntax
C#
public HistoryEntryCollection GetHistory(
    DateTime from,
    DateTime to
)
Parameters
from (DateTime)
From date (UTC).
to (DateTime)
To date (UTC).
Return Value
The history entries for the period.


RegisterItemCopied Method (copiedItem, sourceItem)

RegisterItemCopied Method (copiedItem, sourceItem)
Namespaces ► Sitecore.Data.Engines ► HistoryEngine ► RegisterItemCopied(Item, Item)
Registers an 'item created' event in the history storage.
Declaration Syntax
C#
public void RegisterItemCopied(
    Item copiedItem,
    Item sourceItem
)
Parameters
copiedItem (Item)
The copied item.
sourceItem (Item)
The source item.


RegisterItemCreated Method (item)

RegisterItemCreated Method (item)
Namespaces ► Sitecore.Data.Engines ► HistoryEngine ► RegisterItemCreated(Item)
Registers an 'item created' event in the history storage.
Declaration Syntax
C#
public void RegisterItemCreated(
    Item item
)
Parameters
item (Item)
The item.


RegisterItemDeleted Method (item, oldParentId)

RegisterItemDeleted Method (item, oldParentId)
Namespaces ► Sitecore.Data.Engines ► HistoryEngine ► RegisterItemDeleted(Item, ID)
Registers an 'item deleted' event in the history storage.
Declaration Syntax
C#
public void RegisterItemDeleted(
    Item item,
    ID oldParentId
)
Parameters
item (Item)
The item.
oldParentId (ID)
The old parent id.


RegisterItemMoved Method (item, oldParentId)

RegisterItemMoved Method (item, oldParentId)
Namespaces ► Sitecore.Data.Engines ► HistoryEngine ► RegisterItemMoved(Item, ID)
Registers an 'item moved' event in the history storage.
Declaration Syntax
C#
public virtual void RegisterItemMoved(
    Item item,
    ID oldParentId
)
Parameters
item (Item)
The item.
oldParentId (ID)
The old parent id.


RegisterItemSaved Method (item, changes)

RegisterItemSaved Method (item, changes)
Namespaces ► Sitecore.Data.Engines ► HistoryEngine ► RegisterItemSaved(Item, ItemChanges)
Registers an 'item saved' event in the history storage.
Declaration Syntax
C#
public void RegisterItemSaved(
    Item item,
    ItemChanges changes
)
Parameters
item (Item)
The item.
changes (ItemChanges)
The changes.


RegisterVersionAdded Method (item)

RegisterVersionAdded Method (item)
Namespaces ► Sitecore.Data.Engines ► HistoryEngine ► RegisterVersionAdded(Item)
Registers an 'version added' event in the history storage.
Declaration Syntax
C#
public void RegisterVersionAdded(
    Item item
)
Parameters
item (Item)
The version that was added.


RegisterVersionRemoved Method (item)

RegisterVersionRemoved Method (item)
Namespaces ► Sitecore.Data.Engines ► HistoryEngine ► RegisterVersionRemoved(Item)
Registers an 'version removed' event in the history storage.
Declaration Syntax
C#
public virtual void RegisterVersionRemoved(
    Item item
)
Parameters
item (Item)
The version that was removed.


SaveDotNetCallStack Property

SaveDotNetCallStack Property
Namespaces ► Sitecore.Data.Engines ► HistoryEngine ► SaveDotNetCallStack
Gets or sets a value indicating whether the HistoryEngine saves the dot net call stack.
Declaration Syntax
C#
public bool SaveDotNetCallStack { get; set; }
Value
true if the HistoryEngine saves the dot net call stack; otherwise, false.


Storage Property

Storage Property
Namespaces ► Sitecore.Data.Engines ► HistoryEngine ► Storage
Gets the storage provider.
Declaration Syntax
C#
public HistoryStorage Storage { get; set; }
Value
The storage.


HistoryEntry Class

HistoryEntry Class
Namespaces ► Sitecore.Data.Engines ► HistoryEntry
Defines an entry in the history.
Declaration Syntax
C#
public class HistoryEntry
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HistoryEntry(HistoryCategory, HistoryAction, Item, ID, String) | Constructs an instance of HistoryEntry.
 | Action | Gets the action associated with the entry.
 | AdditionalInfo | Gets the additional info.
 | Category | Gets the category associated with the entry.
 | Created | Gets the creation date of the entry (UTC).
 | EntryId | Gets the unique id of the entry.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemId | Gets the item id associated with the entry.
 | ItemLanguage | Gets the item language associated with the entry.
 | ItemPath | Gets the item path.
 | ItemVersion | Gets the item version associated with the entry.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TaskStack | Gets the task stack.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserName | Gets the name of the user that caused the entry to be created.
Inheritance Hierarchy
Object
HistoryEntry


HistoryEntry Constructor (category, action, item, parentId, additionalInfo)

HistoryEntry Constructor (category, action, item, parentId, additionalInfo)
Namespaces ► Sitecore.Data.Engines ► HistoryEntry ► HistoryEntry(HistoryCategory, HistoryAction, Item, ID, String)
Constructs an instance of HistoryEntry.
Declaration Syntax
C#
public HistoryEntry(
    HistoryCategory category,
    HistoryAction action,
    Item item,
    ID parentId,
    string additionalInfo
)
Parameters
category (HistoryCategory)
The category.
action (HistoryAction)
The action.
item (Item)
The item.
parentId (ID)
The parent id.
additionalInfo (String)
The additional info.


Action Property

Action Property
Namespaces ► Sitecore.Data.Engines ► HistoryEntry ► Action
Gets the action associated with the entry.
Declaration Syntax
C#
public HistoryAction Action { get; }
Value
The action.


AdditionalInfo Property

AdditionalInfo Property
Namespaces ► Sitecore.Data.Engines ► HistoryEntry ► AdditionalInfo
Gets the additional info.
Declaration Syntax
C#
public string AdditionalInfo { get; }
Value
The additional info.


Category Property

Category Property
Namespaces ► Sitecore.Data.Engines ► HistoryEntry ► Category
Gets the category associated with the entry.
Declaration Syntax
C#
public HistoryCategory Category { get; }
Value
The category.


Created Property

Created Property
Namespaces ► Sitecore.Data.Engines ► HistoryEntry ► Created
Gets the creation date of the entry (UTC).
Declaration Syntax
C#
public DateTime Created { get; }
Value
The creation date (UTC).


EntryId Property

EntryId Property
Namespaces ► Sitecore.Data.Engines ► HistoryEntry ► EntryId
Gets the unique id of the entry.
Declaration Syntax
C#
public ID EntryId { get; }
Value
The entry id.


ItemId Property

ItemId Property
Namespaces ► Sitecore.Data.Engines ► HistoryEntry ► ItemId
Gets the item id associated with the entry.
Declaration Syntax
C#
public ID ItemId { get; }
Value
The item id.


ItemLanguage Property

ItemLanguage Property
Namespaces ► Sitecore.Data.Engines ► HistoryEntry ► ItemLanguage
Gets the item language associated with the entry.
Declaration Syntax
C#
public Language ItemLanguage { get; }
Value
The item language.


ItemPath Property

ItemPath Property
Namespaces ► Sitecore.Data.Engines ► HistoryEntry ► ItemPath
Gets the item path.
Declaration Syntax
C#
public string ItemPath { get; }
Value
The item path.


ItemVersion Property

ItemVersion Property
Namespaces ► Sitecore.Data.Engines ► HistoryEntry ► ItemVersion
Gets the item version associated with the entry.
Declaration Syntax
C#
public Version ItemVersion { get; }
Value
The item version.


TaskStack Property

TaskStack Property
Namespaces ► Sitecore.Data.Engines ► HistoryEntry ► TaskStack
Gets the task stack.
Declaration Syntax
C#
public string TaskStack { get; set; }
Value
The task stack.


UserName Property

UserName Property
Namespaces ► Sitecore.Data.Engines ► HistoryEntry ► UserName
Gets the name of the user that caused the entry to be created.
Declaration Syntax
C#
public string UserName { get; }
Value
The name of the user.


HistoryEntry.Builder Class

HistoryEntry..::.Builder Class
Namespaces ► Sitecore.Data.Engines ► HistoryEntry ► HistoryEntry..::.Builder
Builder used for generating HistoryEntrys.
Declaration Syntax
C#
public class Builder
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HistoryEntry..::.Builder()()() | Initializes a new instance of the HistoryEntry..::.Builder class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEntry()()() | Creates an entry based in the current data.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetAction(String) | Sets the action associated with the entry.
 | SetAdditionalInfo(String) | Sets the additional information associated with the entry.
 | SetCategory(String) | Sets the category associated with the entry.
 | SetCreated(DateTime) | Sets the creation date associated with the entry.
 | SetId(ID) | Sets the entry id associated with the entry.
 | SetItemId(ID) | Sets the item id associated with the entry.
 | SetItemLanguage(Language) | Sets the item language associated with the entry.
 | SetItemPath(String) | Sets the item path associated with the entry.
 | SetItemVersion(Version) | Sets the item version associated with the entry.
 | SetTaskStack(String) | Sets the task stack associated with the entry.
 | SetUserName(String) | Sets the user name associated with the entry.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HistoryEntry..::.Builder


HistoryEntry.Builder Constructor

HistoryEntry..::.Builder Constructor
Namespaces ► Sitecore.Data.Engines ► HistoryEntry..::.Builder ► HistoryEntry..::.Builder()()()
Initializes a new instance of the HistoryEntry..::.Builder class
Declaration Syntax
C#
public Builder()


GetEntry Method

GetEntry Method
Namespaces ► Sitecore.Data.Engines ► HistoryEntry..::.Builder ► GetEntry()()()
Creates an entry based in the current data.
Declaration Syntax
C#
public HistoryEntry GetEntry()
Return Value
The entry.


SetAction Method (actionName)

SetAction Method (actionName)
Namespaces ► Sitecore.Data.Engines ► HistoryEntry..::.Builder ► SetAction(String)
Sets the action associated with the entry.
Declaration Syntax
C#
public void SetAction(
    string actionName
)
Parameters
actionName (String)
Name of the action.


SetAdditionalInfo Method (additionalInfo)

SetAdditionalInfo Method (additionalInfo)
Namespaces ► Sitecore.Data.Engines ► HistoryEntry..::.Builder ► SetAdditionalInfo(String)
Sets the additional information associated with the entry.
Declaration Syntax
C#
public void SetAdditionalInfo(
    string additionalInfo
)
Parameters
additionalInfo (String)
The additional info.


SetCategory Method (categoryName)

SetCategory Method (categoryName)
Namespaces ► Sitecore.Data.Engines ► HistoryEntry..::.Builder ► SetCategory(String)
Sets the category associated with the entry.
Declaration Syntax
C#
public void SetCategory(
    string categoryName
)
Parameters
categoryName (String)
Name of the category.


SetCreated Method (created)

SetCreated Method (created)
Namespaces ► Sitecore.Data.Engines ► HistoryEntry..::.Builder ► SetCreated(DateTime)
Sets the creation date associated with the entry.
Declaration Syntax
C#
public void SetCreated(
    DateTime created
)
Parameters
created (DateTime)
The creation date (UTC).


SetId Method (id)

SetId Method (id)
Namespaces ► Sitecore.Data.Engines ► HistoryEntry..::.Builder ► SetId(ID)
Sets the entry id associated with the entry.
Declaration Syntax
C#
public void SetId(
    ID id
)
Parameters
id (ID)
The id.


SetItemId Method (itemId)

SetItemId Method (itemId)
Namespaces ► Sitecore.Data.Engines ► HistoryEntry..::.Builder ► SetItemId(ID)
Sets the item id associated with the entry.
Declaration Syntax
C#
public void SetItemId(
    ID itemId
)
Parameters
itemId (ID)
The item id.


SetItemLanguage Method (itemLanguage)

SetItemLanguage Method (itemLanguage)
Namespaces ► Sitecore.Data.Engines ► HistoryEntry..::.Builder ► SetItemLanguage(Language)
Sets the item language associated with the entry.
Declaration Syntax
C#
public void SetItemLanguage(
    Language itemLanguage
)
Parameters
itemLanguage (Language)
The item language.


SetItemPath Method (itemPath)

SetItemPath Method (itemPath)
Namespaces ► Sitecore.Data.Engines ► HistoryEntry..::.Builder ► SetItemPath(String)
Sets the item path associated with the entry.
Declaration Syntax
C#
public void SetItemPath(
    string itemPath
)
Parameters
itemPath (String)
The item path.


SetItemVersion Method (itemVersion)

SetItemVersion Method (itemVersion)
Namespaces ► Sitecore.Data.Engines ► HistoryEntry..::.Builder ► SetItemVersion(Version)
Sets the item version associated with the entry.
Declaration Syntax
C#
public void SetItemVersion(
    Version itemVersion
)
Parameters
itemVersion (Version)
The item version.


SetTaskStack Method (taskStack)

SetTaskStack Method (taskStack)
Namespaces ► Sitecore.Data.Engines ► HistoryEntry..::.Builder ► SetTaskStack(String)
Sets the task stack associated with the entry.
Declaration Syntax
C#
public void SetTaskStack(
    string taskStack
)
Parameters
taskStack (String)
The task stack.


SetUserName Method (userName)

SetUserName Method (userName)
Namespaces ► Sitecore.Data.Engines ► HistoryEntry..::.Builder ► SetUserName(String)
Sets the user name associated with the entry.
Declaration Syntax
C#
public void SetUserName(
    string userName
)
Parameters
userName (String)
Name of the user.


HistoryStorage Class

HistoryStorage Class
Namespaces ► Sitecore.Data.Engines ► HistoryStorage
The abstract base class for data history storage providers.
Declaration Syntax
C#
public abstract class HistoryStorage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HistoryStorage()()() | Initializes a new instance of the HistoryStorage class
 | AddEntry(HistoryEntry) | Adds an entry to the history storage.
 | Cleanup()()() | Removes outdated entries from storage.
 | EntryLifeTime | Gets or sets the entry life time.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHistory(DateTime, DateTime) | Gets the history for the database in a specified interval.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HistoryStorage
 |  | SqlServerHistoryStorage


HistoryStorage Constructor

HistoryStorage Constructor
Namespaces ► Sitecore.Data.Engines ► HistoryStorage ► HistoryStorage()()()
Initializes a new instance of the HistoryStorage class
Declaration Syntax
C#
protected HistoryStorage()


AddEntry Method (entry)

AddEntry Method (entry)
Namespaces ► Sitecore.Data.Engines ► HistoryStorage ► AddEntry(HistoryEntry)
Adds an entry to the history storage.
Declaration Syntax
C#
public abstract void AddEntry(
    HistoryEntry entry
)
Parameters
entry (HistoryEntry)
The entry.


Cleanup Method

Cleanup Method
Namespaces ► Sitecore.Data.Engines ► HistoryStorage ► Cleanup()()()
Removes outdated entries from storage.
Declaration Syntax
C#
public virtual void Cleanup()


EntryLifeTime Property

EntryLifeTime Property
Namespaces ► Sitecore.Data.Engines ► HistoryStorage ► EntryLifeTime
Gets or sets the entry life time.
Declaration Syntax
C#
public virtual TimeSpan EntryLifeTime { get; set; }
Value
The entry life time.


GetHistory Method (from, to)

GetHistory Method (from, to)
Namespaces ► Sitecore.Data.Engines ► HistoryStorage ► GetHistory(DateTime, DateTime)
Gets the history for the database in a specified interval.
Declaration Syntax
C#
public abstract HistoryEntryCollection GetHistory(
    DateTime from,
    DateTime to
)
Parameters
from (DateTime)
From date (UTC).
to (DateTime)
To date (UTC).
Return Value
The history entries for the period.


SyncOperationContext Class

SyncOperationContext Class
Namespaces ► Sitecore.Data.Engines ► SyncOperationContext
Notifies database engines to make all operations synchronously.
Declaration Syntax
C#
public class SyncOperationContext : Switcher<bool, SyncOperationContext>
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SyncOperationContext()()() | Initializes a new instance of the SyncOperationContext class.
 | SyncOperationContext(Boolean) | Initializes a new instance of the SyncOperationContext class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <(Boolean, SyncOperationContext>)>)
 |  | SyncOperationContext


SyncOperationContext Constructor

SyncOperationContext Constructor
Namespaces ► Sitecore.Data.Engines ► SyncOperationContext ► SyncOperationContext()()()
Members
Icon | Member | Description
 | SyncOperationContext()()() | Initializes a new instance of the SyncOperationContext class.
 | SyncOperationContext(Boolean) | Initializes a new instance of the SyncOperationContext class.


SyncOperationContext Constructor

SyncOperationContext Constructor
Namespaces ► Sitecore.Data.Engines ► SyncOperationContext ► SyncOperationContext()()()
Initializes a new instance of the SyncOperationContext class.
Declaration Syntax
C#
public SyncOperationContext()


SyncOperationContext Constructor (enable)

SyncOperationContext Constructor (enable)
Namespaces ► Sitecore.Data.Engines ► SyncOperationContext ► SyncOperationContext(Boolean)
Initializes a new instance of the SyncOperationContext class.
Declaration Syntax
C#
public SyncOperationContext(
    bool enable
)
Parameters
enable (Boolean)
if set to true this switch should be enabled.


TemplateEngine Class

TemplateEngine Class
Namespaces ► Sitecore.Data.Engines ► TemplateEngine
The template engine.
Declaration Syntax
C#
public class TemplateEngine
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateEngine(Database) | Constructs an instance of TemplateEngine
 | ChangeFieldSharing(TemplateField, TemplateFieldSharing) | Changes the type of field sharing for a single field.
 | DataEngine | Gets the data engine of the owner database.
 | DataManager | Gets the data manager.
 | DataSource | Gets the data source.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTemplate(ID) | Gets a template with a specific id.
 | GetTemplate(String) | Gets a template with a specific full name.
 | GetTemplates()()() | Gets the templates.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsTemplate(Item) | Determines whether an item is a templatepart.
 | IsTemplatePart(Item) | Determines whether an item is a template part.
 | IsTemplateSection(Item) | Determines whether item is template section.
 | IsTemplateSection(ItemDefinition) | Determines whether item is template section.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Reset()()() | Resets the engine.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TemplateEngine


TemplateEngine Constructor (database)

TemplateEngine Constructor (database)
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► TemplateEngine(Database)
Constructs an instance of TemplateEngine
Declaration Syntax
C#
public TemplateEngine(
    Database database
)
Parameters
database (Database)
The database.


ChangeFieldSharing Method (fieldDefinition, sharing)

ChangeFieldSharing Method (fieldDefinition, sharing)
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► ChangeFieldSharing(TemplateField, TemplateFieldSharing)
Changes the type of field sharing for a single field.
Declaration Syntax
C#
public bool ChangeFieldSharing(
    TemplateField fieldDefinition,
    TemplateFieldSharing sharing
)
Parameters
fieldDefinition (TemplateField)
The field definition.
sharing (TemplateFieldSharing)
The new sharing type.
Return Value


DataEngine Property

DataEngine Property
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► DataEngine
Gets the data engine of the owner database.
Declaration Syntax
C#
public DataEngine DataEngine { get; }
Value
The data engine.


DataManager Property

DataManager Property
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► DataManager
Gets the data manager.
Declaration Syntax
C#
public DataManager DataManager { get; }
Value
The data manager.


DataSource Property

DataSource Property
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► DataSource
Gets the data source.
Declaration Syntax
C#
public DataSource DataSource { get; }
Value
The data source.


GetTemplate Method

GetTemplate Method
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► GetTemplate()()()
Members
Icon | Member | Description
 | GetTemplate(ID) | Gets a template with a specific id.
 | GetTemplate(String) | Gets a template with a specific full name.


GetTemplate Method (templateId)

GetTemplate Method (templateId)
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► GetTemplate(ID)
Gets a template with a specific id.
Declaration Syntax
C#
public Template GetTemplate(
    ID templateId
)
Parameters
templateId (ID)
The template id.
Return Value


GetTemplate Method (fullName)

GetTemplate Method (fullName)
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► GetTemplate(String)
Gets a template with a specific full name.
Declaration Syntax
C#
public Template GetTemplate(
    string fullName
)
Parameters
fullName (String)
The full name.
Return Value


GetTemplates Method

GetTemplates Method
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► GetTemplates()()()
Gets the templates.
Declaration Syntax
C#
public TemplateDictionary GetTemplates()
Return Value


IsTemplate Method (item)

IsTemplate Method (item)
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► IsTemplate(Item)
Determines whether an item is a templatepart.
Declaration Syntax
C#
public bool IsTemplate(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the item is a template; otherwise, false.


IsTemplatePart Method (item)

IsTemplatePart Method (item)
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► IsTemplatePart(Item)
Determines whether an item is a template part.
Declaration Syntax
C#
public bool IsTemplatePart(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the item is a template part; otherwise, false.


IsTemplateSection Method

IsTemplateSection Method
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► IsTemplateSection()()()
Members
Icon | Member | Description
 | IsTemplateSection(Item) | Determines whether item is template section.
 | IsTemplateSection(ItemDefinition) | Determines whether item is template section.


IsTemplateSection Method (item)

IsTemplateSection Method (item)
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► IsTemplateSection(ItemDefinition)
Determines whether item is template section.
Declaration Syntax
C#
public bool IsTemplateSection(
    ItemDefinition item
)
Parameters
item (ItemDefinition)
The item.
Return Value
true if [is template section] [the specified item]; otherwise, false.


IsTemplateSection Method (item)

IsTemplateSection Method (item)
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► IsTemplateSection(Item)
Determines whether item is template section.
Declaration Syntax
C#
public bool IsTemplateSection(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if [is template section] [the specified item]; otherwise, false.


Reset Method

Reset Method
Namespaces ► Sitecore.Data.Engines ► TemplateEngine ► Reset()()()
Resets the engine.
Declaration Syntax
C#
public void Reset()


WorkflowEngine Class

WorkflowEngine Class
Namespaces ► Sitecore.Data.Engines ► WorkflowEngine
The engine dealing with workflows
Declaration Syntax
C#
public class WorkflowEngine
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WorkflowEngine(Database) | Initializes a new instance of the DataEngine class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WorkflowEngine


WorkflowEngine Constructor (database)

WorkflowEngine Constructor (database)
Namespaces ► Sitecore.Data.Engines ► WorkflowEngine ► WorkflowEngine(Database)
Initializes a new instance of the DataEngine class.
Declaration Syntax
C#
public WorkflowEngine(
    Database database
)
Parameters
database (Database)
The database.


Sitecore.Data.Engines.Data Namespace

Sitecore.Data.Engines.Data Namespace
Namespaces ► Sitecore.Data.Engines.Data
Declaration Syntax
C#
namespace Sitecore.Data.Engines.Data
Types
All Types Classes
Icon | Type | Description
 | CommandCollection | Command collection for DataEngine


CommandCollection Class

CommandCollection Class
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection
Command collection for DataEngine
Declaration Syntax
C#
public class CommandCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandCollection(DataEngine) | Initializes a new instance of the CommandCollection class.
 | AddFromTemplatePrototype | Gets the prototype for creating instances of AddFromTemplateCommand objects.
 | AddVersionPrototype | Gets the prototype for creating instances of AddVersionCommand objects.
 | BlobStreamExistsPrototype | Gets the prototype for creating instances of BlobStreamExistsCommand objects.
 | CopyItemPrototype | Gets the prototype for creating instances of CopyItemCommand objects.
 | CreateItemPrototype | Gets the prototype for creating instances of CreateItemCommand objects.
 | DeletePrototype | Gets the prototype for creating instances of DeleteItemCommand objects.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBlobStreamPrototype | Gets the prototype for creating instances of GetBlobStreamCommand objects.
 | GetChildrenPrototype | Gets the prototype for creating instances of GetChildrenCommand objects.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemPrototype | Gets the prototype for creating instances of GetItemCommand objects.
 | GetParentPrototype | Gets the prototype for creating instances of GetParentCommand objects.
 | GetRootItemPrototype | Gets the prototype for creating instances of GetRootItemCommand objects.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersionsPrototype | Gets the prototype for creating instances of GetVersionsCommand objects.
 | HasChildrenPrototype | Gets the prototype for creating instances of HasChildrenCommand objects.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveItemPrototype | Gets the prototype for creating instances of MoveItemCommand objects.
 | RemoveDataPrototype | Gets the prototype for creating instances of RemoveDataCommand objects.
 | RemoveVersionPrototype | Gets the prototype for creating instances of RemoveVersionCommand objects.
 | ResolvePathPrototype | Gets the prototype for creating instances of ResolvePathCommand objects.
 | SaveItemPrototype | Gets the prototype for creating instances of SaveItemCommand objects.
 | SetBlobStreamPrototype | Gets the prototype for creating instances of SetBlobStreamCommand objects.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CommandCollection


CommandCollection Constructor (engine)

CommandCollection Constructor (engine)
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► CommandCollection(DataEngine)
Initializes a new instance of the CommandCollection class.
Declaration Syntax
C#
public CommandCollection(
    DataEngine engine
)
Parameters
engine (DataEngine)
The engine.


AddFromTemplatePrototype Property

AddFromTemplatePrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► AddFromTemplatePrototype
Gets the prototype for creating instances of AddFromTemplateCommand objects.
Declaration Syntax
C#
public AddFromTemplateCommand AddFromTemplatePrototype { get; set; }
Value
The prototype.


AddVersionPrototype Property

AddVersionPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► AddVersionPrototype
Gets the prototype for creating instances of AddVersionCommand objects.
Declaration Syntax
C#
public AddVersionCommand AddVersionPrototype { get; set; }
Value
The prototype.


BlobStreamExistsPrototype Property

BlobStreamExistsPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► BlobStreamExistsPrototype
Gets the prototype for creating instances of BlobStreamExistsCommand objects.
Declaration Syntax
C#
public BlobStreamExistsCommand BlobStreamExistsPrototype { get; set; }
Value
The prototype.


CopyItemPrototype Property

CopyItemPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► CopyItemPrototype
Gets the prototype for creating instances of CopyItemCommand objects.
Declaration Syntax
C#
public CopyItemCommand CopyItemPrototype { get; set; }
Value
The prototype.


CreateItemPrototype Property

CreateItemPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► CreateItemPrototype
Gets the prototype for creating instances of CreateItemCommand objects.
Declaration Syntax
C#
public CreateItemCommand CreateItemPrototype { get; set; }
Value
The prototype.


DeletePrototype Property

DeletePrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► DeletePrototype
Gets the prototype for creating instances of DeleteItemCommand objects.
Declaration Syntax
C#
public DeleteItemCommand DeletePrototype { get; set; }
Value
The prototype.


GetBlobStreamPrototype Property

GetBlobStreamPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► GetBlobStreamPrototype
Gets the prototype for creating instances of GetBlobStreamCommand objects.
Declaration Syntax
C#
public GetBlobStreamCommand GetBlobStreamPrototype { get; set; }
Value
The prototype.


GetChildrenPrototype Property

GetChildrenPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► GetChildrenPrototype
Gets the prototype for creating instances of GetChildrenCommand objects.
Declaration Syntax
C#
public GetChildrenCommand GetChildrenPrototype { get; set; }
Value
The prototype.


GetItemPrototype Property

GetItemPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► GetItemPrototype
Gets the prototype for creating instances of GetItemCommand objects.
Declaration Syntax
C#
public GetItemCommand GetItemPrototype { get; set; }
Value
The prototype.


GetParentPrototype Property

GetParentPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► GetParentPrototype
Gets the prototype for creating instances of GetParentCommand objects.
Declaration Syntax
C#
public GetParentCommand GetParentPrototype { get; set; }
Value
The prototype.


GetRootItemPrototype Property

GetRootItemPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► GetRootItemPrototype
Gets the prototype for creating instances of GetRootItemCommand objects.
Declaration Syntax
C#
public GetRootItemCommand GetRootItemPrototype { get; set; }
Value
The prototype.


GetVersionsPrototype Property

GetVersionsPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► GetVersionsPrototype
Gets the prototype for creating instances of GetVersionsCommand objects.
Declaration Syntax
C#
public GetVersionsCommand GetVersionsPrototype { get; set; }
Value
The prototype.


HasChildrenPrototype Property

HasChildrenPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► HasChildrenPrototype
Gets the prototype for creating instances of HasChildrenCommand objects.
Declaration Syntax
C#
public HasChildrenCommand HasChildrenPrototype { get; set; }
Value
The prototype.


MoveItemPrototype Property

MoveItemPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► MoveItemPrototype
Gets the prototype for creating instances of MoveItemCommand objects.
Declaration Syntax
C#
public MoveItemCommand MoveItemPrototype { get; set; }
Value
The prototype.


RemoveDataPrototype Property

RemoveDataPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► RemoveDataPrototype
Gets the prototype for creating instances of RemoveDataCommand objects.
Declaration Syntax
C#
public RemoveDataCommand RemoveDataPrototype { get; set; }
Value
The prototype.


RemoveVersionPrototype Property

RemoveVersionPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► RemoveVersionPrototype
Gets the prototype for creating instances of RemoveVersionCommand objects.
Declaration Syntax
C#
public RemoveVersionCommand RemoveVersionPrototype { get; set; }
Value
The prototype.


ResolvePathPrototype Property

ResolvePathPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► ResolvePathPrototype
Gets the prototype for creating instances of ResolvePathCommand objects.
Declaration Syntax
C#
public ResolvePathCommand ResolvePathPrototype { get; set; }
Value
The prototype.


SaveItemPrototype Property

SaveItemPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► SaveItemPrototype
Gets the prototype for creating instances of SaveItemCommand objects.
Declaration Syntax
C#
public SaveItemCommand SaveItemPrototype { get; set; }
Value
The prototype.


SetBlobStreamPrototype Property

SetBlobStreamPrototype Property
Namespaces ► Sitecore.Data.Engines.Data ► CommandCollection ► SetBlobStreamPrototype
Gets the prototype for creating instances of SetBlobStreamCommand objects.
Declaration Syntax
C#
public SetBlobStreamCommand SetBlobStreamPrototype { get; set; }
Value
The prototype.


Sitecore.Data.Engines.DataCommands Namespace

Sitecore.Data.Engines.DataCommands Namespace
Namespaces ► Sitecore.Data.Engines.DataCommands
Declaration Syntax
C#
namespace Sitecore.Data.Engines.DataCommands
Types
All Types Classes
Icon | Type | Description
 | AddFromTemplateCommand | The command used by the engine when deleting items.
 | AddVersionCommand | The command used by the engine when adding a version to an item.
 | BlobStreamExistsCommand | The command used by the engine when deleting items.
 | CopyItemCommand | The command used by the engine when copying items.
 | CreateItemCommand | The command used by the engine when deleting items.
 | DeleteItemCommand | The command used by the engine when deleting items.
 | GetBlobStreamCommand | The command used by the engine when deleting items.
 | GetChildrenCommand | The command used by the engine when getting child items.
 | GetItemCommand | The command used by the engine when getting items.
 | GetParentCommand | The command used by the engine when getting parent items.
 | GetRootItemCommand | The command used by the engine when getting the root item.
 | GetVersionsCommand | The command used by the engine when getting versions of an item.
 | HasChildrenCommand | The command used by the engine when getting child items.
 | MoveItemCommand | The command used by the engine when moving items.
 | RemoveDataCommand | The command used by the engine when removing data from an item.
 | RemoveVersionCommand | The command used by the engine when removing a version of an item.
 | ResolvePathCommand | The command used by the engine when getting items.
 | SaveItemCommand | The command used by the engine when saving items.
 | SetBlobStreamCommand | The command used by the engine when deleting items.


AddFromTemplateCommand Class

AddFromTemplateCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddFromTemplateCommand
The command used by the engine when deleting items.
Declaration Syntax
C#
public class AddFromTemplateCommand : DataEngineCommand<Item, AddFromTemplateCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddFromTemplateCommand()()() | Adds from tempalte command.
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <( Item, AddFromTemplateCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Destination | Gets the destination. The newly created item will be a child of the destination item.
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).Executed()()().)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, ID, Item, ID) | Initializes the command.
 | ItemName | Gets the name of the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewId | Gets the id of the new item.
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | TemplateId | Gets the id of the template to use.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <( Item, AddFromTemplateCommand>)>)
 |  |  | AddFromTemplateCommand


AddFromTemplateCommand Constructor

AddFromTemplateCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddFromTemplateCommand ► AddFromTemplateCommand()()()
Adds from tempalte command.
Declaration Syntax
C#
public AddFromTemplateCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddFromTemplateCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override AddFromTemplateCommand CreateInstance()
Return Value


Destination Property

Destination Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddFromTemplateCommand ► Destination
Gets the destination. The newly created item will be a child of the destination item.
Declaration Syntax
C#
public virtual Item Destination { get; }
Value
The destination item.


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddFromTemplateCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override Item DoExecute()
Return Value
The id of the newly created item. If the item could not be created, null is returned.


Executed Method

Executed Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddFromTemplateCommand ► Executed()()()
Post processing handler.
Declaration Syntax
C#
protected override void Executed()
Remarks

This method is called right after the command has been executed.

The result of the execution can be accessed through the Result property.


Initialize Method (itemName, templateId, destination, newId)

Initialize Method (itemName, templateId, destination, newId)
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddFromTemplateCommand ► Initialize(String, ID, Item, ID)
Initializes the command.
Declaration Syntax
C#
public virtual void Initialize(
    string itemName,
    ID templateId,
    Item destination,
    ID newId
)
Parameters
itemName (String)
Name of the item.
templateId (ID)
The template id.
destination (Item)
The destination.
newId (ID)
The id of the new item.


ItemName Property

ItemName Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddFromTemplateCommand ► ItemName
Gets the name of the item.
Declaration Syntax
C#
public string ItemName { get; }
Value
The name of the item.


NewId Property

NewId Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddFromTemplateCommand ► NewId
Gets the id of the new item.
Declaration Syntax
C#
public ID NewId { get; }
Value
The new id.


TemplateId Property

TemplateId Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddFromTemplateCommand ► TemplateId
Gets the id of the template to use.
Declaration Syntax
C#
public virtual ID TemplateId { get; }
Value
The template id.


AddVersionCommand Class

AddVersionCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddVersionCommand
The command used by the engine when adding a version to an item.
Declaration Syntax
C#
public class AddVersionCommand : DataEngineCommand<Item, AddVersionCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddVersionCommand()()() | Initializes a new instance of the AddVersionCommand class.
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <( Item, AddVersionCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).Executed()()().)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Item) | Initializes the command.
 | Item | Gets the item that will have a version added.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <( Item, AddVersionCommand>)>)
 |  |  | AddVersionCommand


AddVersionCommand Constructor

AddVersionCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddVersionCommand ► AddVersionCommand()()()
Initializes a new instance of the AddVersionCommand class.
Declaration Syntax
C#
public AddVersionCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddVersionCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override AddVersionCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddVersionCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override Item DoExecute()
Return Value
The added version of the item. If a version could not be added to the item, null is returned.


Executed Method

Executed Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddVersionCommand ► Executed()()()
Post processing handler.
Declaration Syntax
C#
protected override void Executed()
Remarks

This method is called right after the command has been executed.

The result of the execution can be accessed through the Result property.


Initialize Method (item)

Initialize Method (item)
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddVersionCommand ► Initialize(Item)
Initializes the command.
Declaration Syntax
C#
public virtual void Initialize(
    Item item
)
Parameters
item (Item)
The item that will have a version added.


Item Property

Item Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► AddVersionCommand ► Item
Gets the item that will have a version added.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


BlobStreamExistsCommand Class

BlobStreamExistsCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► BlobStreamExistsCommand
The command used by the engine when deleting items.
Declaration Syntax
C#
public class BlobStreamExistsCommand : DataEngineCommand<bool, BlobStreamExistsCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BlobStreamExistsCommand()()() | Initializes a new instance of the BlobStreamExistsCommand class
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <(Boolean, BlobStreamExistsCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Guid) | Initializes the instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <(Boolean, BlobStreamExistsCommand>)>)
 |  |  | BlobStreamExistsCommand


BlobStreamExistsCommand Constructor

BlobStreamExistsCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► BlobStreamExistsCommand ► BlobStreamExistsCommand()()()
Initializes a new instance of the BlobStreamExistsCommand class
Declaration Syntax
C#
public BlobStreamExistsCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► BlobStreamExistsCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override BlobStreamExistsCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► BlobStreamExistsCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override bool DoExecute()
Return Value
The blob value (or null if no value was found).


Initialize Method (blobId)

Initialize Method (blobId)
Namespaces ► Sitecore.Data.Engines.DataCommands ► BlobStreamExistsCommand ► Initialize(Guid)
Initializes the instance.
Declaration Syntax
C#
public virtual void Initialize(
    Guid blobId
)
Parameters
blobId (Guid)
The BLOB id.


CopyItemCommand Class

CopyItemCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► CopyItemCommand
The command used by the engine when copying items.
Declaration Syntax
C#
public class CopyItemCommand : DataEngineCommand<Item, CopyItemCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CopyItemCommand()()() | Initializes a new instance of the CopyItemCommand class.
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CopyId | Gets the id of the copy.
 | CopyName | Gets the name of the copy.
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <( Item, CopyItemCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Deep | Gets a value indicating whether child items should be copied.
 | Destination | Gets the destination for the copy. This will be the parent of the copied item.
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).Executed()()().)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Item, Item, String, ID, Boolean) | Initializes the command.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Source | Gets the item to copy.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <( Item, CopyItemCommand>)>)
 |  |  | CopyItemCommand


CopyItemCommand Constructor

CopyItemCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► CopyItemCommand ► CopyItemCommand()()()
Initializes a new instance of the CopyItemCommand class.
Declaration Syntax
C#
public CopyItemCommand()


CopyId Property

CopyId Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► CopyItemCommand ► CopyId
Gets the id of the copy.
Declaration Syntax
C#
public ID CopyId { get; }
Value
The copy id.


CopyName Property

CopyName Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► CopyItemCommand ► CopyName
Gets the name of the copy.
Declaration Syntax
C#
public string CopyName { get; }
Value
The name of the copy.


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► CopyItemCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override CopyItemCommand CreateInstance()
Return Value


Deep Property

Deep Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► CopyItemCommand ► Deep
Gets a value indicating whether child items should be copied.
Declaration Syntax
C#
public bool Deep { get; }
Value
true if child items should be copied; otherwise, false.


Destination Property

Destination Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► CopyItemCommand ► Destination
Gets the destination for the copy. This will be the parent of the copied item.
Declaration Syntax
C#
public Item Destination { get; }
Value
The destination.


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► CopyItemCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override Item DoExecute()
Return Value
The copy of Source. If the item was ot copied, null is returned.


Executed Method

Executed Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► CopyItemCommand ► Executed()()()
Post processing handler.
Declaration Syntax
C#
protected override void Executed()
Remarks

This method is called right after the command has been executed.

The result of the execution can be accessed through the Result property.


Initialize Method (source, destination, copyName, copyId, deep)

Initialize Method (source, destination, copyName, copyId, deep)
Namespaces ► Sitecore.Data.Engines.DataCommands ► CopyItemCommand ► Initialize(Item, Item, String, ID, Boolean)
Initializes the command.
Declaration Syntax
C#
public virtual void Initialize(
    Item source,
    Item destination,
    string copyName,
    ID copyId,
    bool deep
)
Parameters
source (Item)
The item to copy.
destination (Item)
The destination.
copyName (String)
Name of the copy.
copyId (ID)
Id of the copy.
deep (Boolean)
If set to true, child items will be copied recursively.


Source Property

Source Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► CopyItemCommand ► Source
Gets the item to copy.
Declaration Syntax
C#
public virtual Item Source { get; }
Value
The item.


CreateItemCommand Class

CreateItemCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► CreateItemCommand
The command used by the engine when deleting items.
Declaration Syntax
C#
public class CreateItemCommand : DataEngineCommand<Item, CreateItemCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateItemCommand()()() | Initializes a new instance of the CreateItemCommand class.
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <( Item, CreateItemCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Destination | Gets the destination. The newly created item will be a child of the destination item.
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).Executed()()().)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(ID, String, ID, Item) | Initializes the command.
 | ItemId | Gets the item id.
 | ItemName | Gets the name of the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | TemplateId | Gets the id of the template to use.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <( Item, CreateItemCommand>)>)
 |  |  | CreateItemCommand


CreateItemCommand Constructor

CreateItemCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► CreateItemCommand ► CreateItemCommand()()()
Initializes a new instance of the CreateItemCommand class.
Declaration Syntax
C#
public CreateItemCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► CreateItemCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override CreateItemCommand CreateInstance()
Return Value


Destination Property

Destination Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► CreateItemCommand ► Destination
Gets the destination. The newly created item will be a child of the destination item.
Declaration Syntax
C#
public Item Destination { get; }
Value
The destination.


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► CreateItemCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override Item DoExecute()
Return Value
true if the item was created; false otherwise.


Executed Method

Executed Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► CreateItemCommand ► Executed()()()
Post processing handler.
Declaration Syntax
C#
protected override void Executed()
Remarks

This method is called right after the command has been executed.

The result of the execution can be accessed through the Result property.


Initialize Method (itemId, itemName, templateId, destination)

Initialize Method (itemId, itemName, templateId, destination)
Namespaces ► Sitecore.Data.Engines.DataCommands ► CreateItemCommand ► Initialize(ID, String, ID, Item)
Initializes the command.
Declaration Syntax
C#
public virtual void Initialize(
    ID itemId,
    string itemName,
    ID templateId,
    Item destination
)
Parameters
itemId (ID)
The item id.
itemName (String)
Name of the item.
templateId (ID)
The template ID.
destination (Item)
The destination.


ItemId Property

ItemId Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► CreateItemCommand ► ItemId
Gets the item id.
Declaration Syntax
C#
public ID ItemId { get; }
Value
The item id.


ItemName Property

ItemName Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► CreateItemCommand ► ItemName
Gets the name of the item.
Declaration Syntax
C#
public string ItemName { get; }
Value
The name of the item.


TemplateId Property

TemplateId Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► CreateItemCommand ► TemplateId
Gets the id of the template to use.
Declaration Syntax
C#
public virtual ID TemplateId { get; }
Value
The template id.


DeleteItemCommand Class

DeleteItemCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► DeleteItemCommand
The command used by the engine when deleting items.
Declaration Syntax
C#
public class DeleteItemCommand : DataEngineCommand<bool, DeleteItemCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteItemCommand()()() | Initializes a new instance of the DeleteItemCommand class.
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <(Boolean, DeleteItemCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Executes the delete command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Item, ID) | Initializes the instance.
 | Item | Gets the Item being saved.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentId | Gets the parent id of the item being deleted.
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <(Boolean, DeleteItemCommand>)>)
 |  |  | DeleteItemCommand


DeleteItemCommand Constructor

DeleteItemCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► DeleteItemCommand ► DeleteItemCommand()()()
Initializes a new instance of the DeleteItemCommand class.
Declaration Syntax
C#
public DeleteItemCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► DeleteItemCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override DeleteItemCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► DeleteItemCommand ► DoExecute()()()
Executes the delete command.
Declaration Syntax
C#
protected override bool DoExecute()
Return Value
True if the item was deleted, false otherwise.


Initialize Method (item, parentId)

Initialize Method (item, parentId)
Namespaces ► Sitecore.Data.Engines.DataCommands ► DeleteItemCommand ► Initialize(Item, ID)
Initializes the instance.
Declaration Syntax
C#
public virtual void Initialize(
    Item item,
    ID parentId
)
Parameters
item (Item)
The item to delete.
parentId (ID)
The parent id.


Item Property

Item Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► DeleteItemCommand ► Item
Gets the Item being saved.
Declaration Syntax
C#
public virtual Item Item { get; }
Value
The item.


ParentId Property

ParentId Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► DeleteItemCommand ► ParentId
Gets the parent id of the item being deleted.
Declaration Syntax
C#
public virtual ID ParentId { get; }
Value
The parent id.


GetBlobStreamCommand Class

GetBlobStreamCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetBlobStreamCommand
The command used by the engine when deleting items.
Declaration Syntax
C#
public class GetBlobStreamCommand : DataEngineCommand<Stream, GetBlobStreamCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetBlobStreamCommand()()() | Initializes a new instance of the GetBlobStreamCommand class
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | BlobId | Gets the BLOB id.
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <(Stream, GetBlobStreamCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Guid) | Initializes the instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <(Stream, GetBlobStreamCommand>)>)
 |  |  | GetBlobStreamCommand


GetBlobStreamCommand Constructor

GetBlobStreamCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetBlobStreamCommand ► GetBlobStreamCommand()()()
Initializes a new instance of the GetBlobStreamCommand class
Declaration Syntax
C#
public GetBlobStreamCommand()


BlobId Property

BlobId Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetBlobStreamCommand ► BlobId
Gets the BLOB id.
Declaration Syntax
C#
public Guid BlobId { get; }
Value
The BLOB id.


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetBlobStreamCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override GetBlobStreamCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetBlobStreamCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override Stream DoExecute()
Return Value
The blob stream (or null if no stream was found).


Initialize Method (blobId)

Initialize Method (blobId)
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetBlobStreamCommand ► Initialize(Guid)
Initializes the instance.
Declaration Syntax
C#
public virtual void Initialize(
    Guid blobId
)
Parameters
blobId (Guid)
The BLOB id.


GetChildrenCommand Class

GetChildrenCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetChildrenCommand
The command used by the engine when getting child items.
Declaration Syntax
C#
public class GetChildrenCommand : DataEngineCommand<ItemList, GetChildrenCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetChildrenCommand()()() | Initializes a new instance of the GetChildrenCommand class
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <( ItemList, GetChildrenCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Performs the actual save operation. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Item) | Initializes the specified item.
 | Item | Gets the id of the item to get.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <( ItemList, GetChildrenCommand>)>)
 |  |  | GetChildrenCommand


GetChildrenCommand Constructor

GetChildrenCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetChildrenCommand ► GetChildrenCommand()()()
Initializes a new instance of the GetChildrenCommand class
Declaration Syntax
C#
public GetChildrenCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetChildrenCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override GetChildrenCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetChildrenCommand ► DoExecute()()()
Performs the actual save operation.
Declaration Syntax
C#
protected override ItemList DoExecute()
Return Value
The result of execution.


Initialize Method (item)

Initialize Method (item)
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetChildrenCommand ► Initialize(Item)
Initializes the specified item.
Declaration Syntax
C#
public virtual void Initialize(
    Item item
)
Parameters
item (Item)
The item.


Item Property

Item Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetChildrenCommand ► Item
Gets the id of the item to get.
Declaration Syntax
C#
public virtual Item Item { get; }
Value
The item.


GetItemCommand Class

GetItemCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetItemCommand
The command used by the engine when getting items.
Declaration Syntax
C#
public class GetItemCommand : DataEngineCommand<Item, GetItemCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetItemCommand()()() | Initializes a new instance of the GetItemCommand class.
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <( Item, GetItemCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(ID, Language, Version) | Initializes the specified item id.
 | ItemId | Gets the id of the item to get.
 | Language | Gets the language of the item to get.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | Gets the version of the item to get.
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <( Item, GetItemCommand>)>)
 |  |  | GetItemCommand


GetItemCommand Constructor

GetItemCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetItemCommand ► GetItemCommand()()()
Initializes a new instance of the GetItemCommand class.
Declaration Syntax
C#
public GetItemCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetItemCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override GetItemCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetItemCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override Item DoExecute()
Return Value
The item that was found. If no item was found, null is returned.


Initialize Method (itemId, language, version)

Initialize Method (itemId, language, version)
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetItemCommand ► Initialize(ID, Language, Version)
Initializes the specified item id.
Declaration Syntax
C#
public virtual void Initialize(
    ID itemId,
    Language language,
    Version version
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
version (Version)
The version.


ItemId Property

ItemId Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetItemCommand ► ItemId
Gets the id of the item to get.
Declaration Syntax
C#
public virtual ID ItemId { get; }
Value
The item id.


Language Property

Language Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetItemCommand ► Language
Gets the language of the item to get.
Declaration Syntax
C#
public virtual Language Language { get; }
Value
The language of the item to get.


Version Property

Version Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetItemCommand ► Version
Gets the version of the item to get.
Declaration Syntax
C#
public virtual Version Version { get; }
Value
The version of the item to get.


GetParentCommand Class

GetParentCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetParentCommand
The command used by the engine when getting parent items.
Declaration Syntax
C#
public class GetParentCommand : DataEngineCommand<Item, GetParentCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetParentCommand()()() | Initializes a new instance of the GetParentCommand class
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <( Item, GetParentCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Item) | Initializes the command.
 | Item | Gets the item to get the parent for.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <( Item, GetParentCommand>)>)
 |  |  | GetParentCommand


GetParentCommand Constructor

GetParentCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetParentCommand ► GetParentCommand()()()
Initializes a new instance of the GetParentCommand class
Declaration Syntax
C#
public GetParentCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetParentCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override GetParentCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetParentCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override Item DoExecute()
Return Value
The parent of Item. If the parent can not be found, null is returned.


Initialize Method (item)

Initialize Method (item)
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetParentCommand ► Initialize(Item)
Initializes the command.
Declaration Syntax
C#
public virtual void Initialize(
    Item item
)
Parameters
item (Item)
The item to get the parent for.


Item Property

Item Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetParentCommand ► Item
Gets the item to get the parent for.
Declaration Syntax
C#
public virtual Item Item { get; }
Value
The item.


GetRootItemCommand Class

GetRootItemCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetRootItemCommand
The command used by the engine when getting the root item.
Declaration Syntax
C#
public class GetRootItemCommand : DataEngineCommand<Item, GetRootItemCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetRootItemCommand()()() | Initializes a new instance of the GetRootItemCommand class
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <( Item, GetRootItemCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Language, Version) | Initializes the instance.
 | Language | Gets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | Gets the version.
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <( Item, GetRootItemCommand>)>)
 |  |  | GetRootItemCommand


GetRootItemCommand Constructor

GetRootItemCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetRootItemCommand ► GetRootItemCommand()()()
Initializes a new instance of the GetRootItemCommand class
Declaration Syntax
C#
public GetRootItemCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetRootItemCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override GetRootItemCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetRootItemCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override Item DoExecute()
Return Value
The the root item, null if no root item was found.


Initialize Method (language, version)

Initialize Method (language, version)
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetRootItemCommand ► Initialize(Language, Version)
Initializes the instance.
Declaration Syntax
C#
public virtual void Initialize(
    Language language,
    Version version
)
Parameters
language (Language)
version (Version)


Language Property

Language Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetRootItemCommand ► Language
Gets the language.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


Version Property

Version Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetRootItemCommand ► Version
Gets the version.
Declaration Syntax
C#
public Version Version { get; }
Value
The version.


GetVersionsCommand Class

GetVersionsCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetVersionsCommand
The command used by the engine when getting versions of an item.
Declaration Syntax
C#
public class GetVersionsCommand : DataEngineCommand<VersionCollection, GetVersionsCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetVersionsCommand()()() | Initializes a new instance of the GetVersionsCommand class
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <( VersionCollection, GetVersionsCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Item, Language) | Initializes the command.
 | Item | Gets the id of the item to get the versions for.
 | Language | Gets the language to get the versions for.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <( VersionCollection, GetVersionsCommand>)>)
 |  |  | GetVersionsCommand


GetVersionsCommand Constructor

GetVersionsCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetVersionsCommand ► GetVersionsCommand()()()
Initializes a new instance of the GetVersionsCommand class
Declaration Syntax
C#
public GetVersionsCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetVersionsCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override GetVersionsCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetVersionsCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override VersionCollection DoExecute()
Return Value
The parent of Item. If the parent can not be found, null is returned.


Initialize Method (item, language)

Initialize Method (item, language)
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetVersionsCommand ► Initialize(Item, Language)
Initializes the command.
Declaration Syntax
C#
public virtual void Initialize(
    Item item,
    Language language
)
Parameters
item (Item)
The item.
language (Language)
The language.


Item Property

Item Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetVersionsCommand ► Item
Gets the id of the item to get the versions for.
Declaration Syntax
C#
public virtual Item Item { get; }
Value
The item id.


Language Property

Language Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► GetVersionsCommand ► Language
Gets the language to get the versions for.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


HasChildrenCommand Class

HasChildrenCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► HasChildrenCommand
The command used by the engine when getting child items.
Declaration Syntax
C#
public class HasChildrenCommand : DataEngineCommand<bool, HasChildrenCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HasChildrenCommand()()() | Initializes a new instance of the HasChildrenCommand class
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <(Boolean, HasChildrenCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Performs the actual save operation. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Item) | Initializes the specified item.
 | Item | Gets the id of the item to get.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <(Boolean, HasChildrenCommand>)>)
 |  |  | HasChildrenCommand


HasChildrenCommand Constructor

HasChildrenCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► HasChildrenCommand ► HasChildrenCommand()()()
Initializes a new instance of the HasChildrenCommand class
Declaration Syntax
C#
public HasChildrenCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► HasChildrenCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override HasChildrenCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► HasChildrenCommand ► DoExecute()()()
Performs the actual save operation.
Declaration Syntax
C#
protected override bool DoExecute()
Return Value
The result of execution.


Initialize Method (item)

Initialize Method (item)
Namespaces ► Sitecore.Data.Engines.DataCommands ► HasChildrenCommand ► Initialize(Item)
Initializes the specified item.
Declaration Syntax
C#
public virtual void Initialize(
    Item item
)
Parameters
item (Item)
The item.


Item Property

Item Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► HasChildrenCommand ► Item
Gets the id of the item to get.
Declaration Syntax
C#
public virtual Item Item { get; }
Value
The item.


MoveItemCommand Class

MoveItemCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► MoveItemCommand
The command used by the engine when moving items.
Declaration Syntax
C#
public class MoveItemCommand : DataEngineCommand<bool, MoveItemCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MoveItemCommand()()() | Initializes a new instance of the MoveItemCommand class
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <(Boolean, MoveItemCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Destination | Gets the destination. This will be the parent of the moved item.
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Item, Item) | Initializes the command.
 | Item | Gets the item to move.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OldParentId | Gets the old parent id.
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <(Boolean, MoveItemCommand>)>)
 |  |  | MoveItemCommand


MoveItemCommand Constructor

MoveItemCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► MoveItemCommand ► MoveItemCommand()()()
Initializes a new instance of the MoveItemCommand class
Declaration Syntax
C#
public MoveItemCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► MoveItemCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override MoveItemCommand CreateInstance()
Return Value


Destination Property

Destination Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► MoveItemCommand ► Destination
Gets the destination. This will be the parent of the moved item.
Declaration Syntax
C#
public Item Destination { get; }
Value
The destination.


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► MoveItemCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override bool DoExecute()
Return Value
If the item was moved, true is returned. Otherwise, false is returned.


Initialize Method (item, destination)

Initialize Method (item, destination)
Namespaces ► Sitecore.Data.Engines.DataCommands ► MoveItemCommand ► Initialize(Item, Item)
Initializes the command.
Declaration Syntax
C#
public virtual void Initialize(
    Item item,
    Item destination
)
Parameters
item (Item)
The item to move.
destination (Item)
The destination.


Item Property

Item Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► MoveItemCommand ► Item
Gets the item to move.
Declaration Syntax
C#
public virtual Item Item { get; }
Value
The item.


OldParentId Property

OldParentId Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► MoveItemCommand ► OldParentId
Gets the old parent id.
Declaration Syntax
C#
public ID OldParentId { get; }
Value
The old parent id.


RemoveDataCommand Class

RemoveDataCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveDataCommand
The command used by the engine when removing data from an item.
Declaration Syntax
C#
public class RemoveDataCommand : DataEngineCommand<bool, RemoveDataCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RemoveDataCommand()()() | Initializes a new instance of the RemoveDataCommand class.
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <(Boolean, RemoveDataCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(ID, Language, Boolean) | Initializes the command.
 | ItemId | Gets the id of the item.
 | Language | Gets the language of the data to remove.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RemoveAllLanguages | Gets a value indicating whether to remove data in all languages.
 | RemoveSharedData | Gets a value indicating whether to remove shared data.
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <(Boolean, RemoveDataCommand>)>)
 |  |  | RemoveDataCommand


RemoveDataCommand Constructor

RemoveDataCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveDataCommand ► RemoveDataCommand()()()
Initializes a new instance of the RemoveDataCommand class.
Declaration Syntax
C#
public RemoveDataCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveDataCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override RemoveDataCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveDataCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override bool DoExecute()
Return Value
true if the data was removed; otherwise false.


Initialize Method (itemId, language, removeSharedData)

Initialize Method (itemId, language, removeSharedData)
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveDataCommand ► Initialize(ID, Language, Boolean)
Initializes the command.
Declaration Syntax
C#
public virtual void Initialize(
    ID itemId,
    Language language,
    bool removeSharedData
)
Parameters
itemId (ID)
The id of the item.
language (Language)
The language of the data to remove.
removeSharedData (Boolean)
If set to true shared data is removed.


ItemId Property

ItemId Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveDataCommand ► ItemId
Gets the id of the item.
Declaration Syntax
C#
public virtual ID ItemId { get; }
Value
The item id.


Language Property

Language Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveDataCommand ► Language
Gets the language of the data to remove.
Declaration Syntax
C#
public virtual Language Language { get; }
Value
The language.
Remarks
If all data is to be removed, Invariant is returned.


RemoveAllLanguages Property

RemoveAllLanguages Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveDataCommand ► RemoveAllLanguages
Gets a value indicating whether to remove data in all languages.
Declaration Syntax
C#
public virtual bool RemoveAllLanguages { get; }
Value
true if data in all languages will be removed; otherwise, false.


RemoveSharedData Property

RemoveSharedData Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveDataCommand ► RemoveSharedData
Gets a value indicating whether to remove shared data.
Declaration Syntax
C#
public bool RemoveSharedData { get; }
Value
true if shared data should be removed; otherwise, false.


RemoveVersionCommand Class

RemoveVersionCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveVersionCommand
The command used by the engine when removing a version of an item.
Declaration Syntax
C#
public class RemoveVersionCommand : DataEngineCommand<bool, RemoveVersionCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RemoveVersionCommand()()() | Initializes a new instance of the RemoveVersionCommand class.
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <(Boolean, RemoveVersionCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Item) | Initializes the command.
 | Item | Gets the item representing the version to remove.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <(Boolean, RemoveVersionCommand>)>)
 |  |  | RemoveVersionCommand


RemoveVersionCommand Constructor

RemoveVersionCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveVersionCommand ► RemoveVersionCommand()()()
Initializes a new instance of the RemoveVersionCommand class.
Declaration Syntax
C#
public RemoveVersionCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveVersionCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override RemoveVersionCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveVersionCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override bool DoExecute()
Return Value
true if the version was removed; otherwise false.


Initialize Method (item)

Initialize Method (item)
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveVersionCommand ► Initialize(Item)
Initializes the command.
Declaration Syntax
C#
public virtual void Initialize(
    Item item
)
Parameters
item (Item)
The item representing the version to remove.


Item Property

Item Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► RemoveVersionCommand ► Item
Gets the item representing the version to remove.
Declaration Syntax
C#
public virtual Item Item { get; }
Value
The item.


ResolvePathCommand Class

ResolvePathCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► ResolvePathCommand
The command used by the engine when getting items.
Declaration Syntax
C#
public class ResolvePathCommand : DataEngineCommand<ID, ResolvePathCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResolvePathCommand()()() | Initializes a new instance of the ResolvePathCommand class
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <( ID, ResolvePathCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String) | Initializes the specified item path.
 | ItemPath | Gets the id of the item to get.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <( ID, ResolvePathCommand>)>)
 |  |  | ResolvePathCommand


ResolvePathCommand Constructor

ResolvePathCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► ResolvePathCommand ► ResolvePathCommand()()()
Initializes a new instance of the ResolvePathCommand class
Declaration Syntax
C#
public ResolvePathCommand()


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► ResolvePathCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override ResolvePathCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► ResolvePathCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override ID DoExecute()
Return Value
The id of the resolved item. If no item is found, null is returned.


Initialize Method (itemPath)

Initialize Method (itemPath)
Namespaces ► Sitecore.Data.Engines.DataCommands ► ResolvePathCommand ► Initialize(String)
Initializes the specified item path.
Declaration Syntax
C#
public virtual void Initialize(
    string itemPath
)
Parameters
itemPath (String)
The item path.


ItemPath Property

ItemPath Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► ResolvePathCommand ► ItemPath
Gets the id of the item to get.
Declaration Syntax
C#
public virtual string ItemPath { get; }
Value
The item path.


SaveItemCommand Class

SaveItemCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► SaveItemCommand
The command used by the engine when saving items.
Declaration Syntax
C#
public class SaveItemCommand : DataEngineCommand<bool, SaveItemCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SaveItemCommand()()() | Initializes a new instance of the SaveItemCommand class.
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Changes | Gets the changes being saved.
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <(Boolean, SaveItemCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Executes the save command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Item) | Initializes the command.
 | Item | Gets the Item being saved.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <(Boolean, SaveItemCommand>)>)
 |  |  | SaveItemCommand


SaveItemCommand Constructor

SaveItemCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► SaveItemCommand ► SaveItemCommand()()()
Initializes a new instance of the SaveItemCommand class.
Declaration Syntax
C#
public SaveItemCommand()


Changes Property

Changes Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► SaveItemCommand ► Changes
Gets the changes being saved.
Declaration Syntax
C#
public virtual ItemChanges Changes { get; }
Value
The changes.


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► SaveItemCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override SaveItemCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► SaveItemCommand ► DoExecute()()()
Executes the save command.
Declaration Syntax
C#
protected override bool DoExecute()
Return Value
True if the item was saved, false otherwise.


Initialize Method (item)

Initialize Method (item)
Namespaces ► Sitecore.Data.Engines.DataCommands ► SaveItemCommand ► Initialize(Item)
Initializes the command.
Declaration Syntax
C#
public virtual void Initialize(
    Item item
)
Parameters
item (Item)
The item to save.


Item Property

Item Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► SaveItemCommand ► Item
Gets the Item being saved.
Declaration Syntax
C#
public virtual Item Item { get; }
Value
The item.


SetBlobStreamCommand Class

SetBlobStreamCommand Class
Namespaces ► Sitecore.Data.Engines.DataCommands ► SetBlobStreamCommand
The command used by the engine when deleting items.
Declaration Syntax
C#
public class SetBlobStreamCommand : DataEngineCommand<bool, SetBlobStreamCommand>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetBlobStreamCommand()()() | Initializes a new instance of the SetBlobStreamCommand class
 | _lockType | (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | BlobId | Gets the BLOB id.
 | CanExecute()()() | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Clone(EventHandler<(Of <(ExecutingEventArgs<(Of <(TCommandType>)>)>)>), EventHandler<(Of <(ExecutedEventArgs<(Of <(TCommandType>)>)>)>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | CreateInstance()()() | Creates an instance of the command class. (Overrides DataEngineCommand <(Of <(Boolean, SetBlobStreamCommand>)>).CreateInstance()()().)
 | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | DoExecute()()() | Executes the command. (Overrides EngineCommand <(Of <( TReturnType, TCommandType >)>).DoExecute()()().)
 | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the command. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Executed()()() | Post processing handler. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeExecution()()() | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Stream, Guid) | Initializes the instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrepareExecution()()() | Prepares the execution. (Inherited from DataEngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuted()()() | Raises the executed event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | RaiseExecuting(Boolean%) | Raises the executing event. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(TReturnType, TCommandType>)>).)
 | Stream | Gets the stream.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EngineCommand <(Of <( TReturnType, TCommandType >)>)
 |  | DataEngineCommand <(Of <(Boolean, SetBlobStreamCommand>)>)
 |  |  | SetBlobStreamCommand


SetBlobStreamCommand Constructor

SetBlobStreamCommand Constructor
Namespaces ► Sitecore.Data.Engines.DataCommands ► SetBlobStreamCommand ► SetBlobStreamCommand()()()
Initializes a new instance of the SetBlobStreamCommand class
Declaration Syntax
C#
public SetBlobStreamCommand()


BlobId Property

BlobId Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► SetBlobStreamCommand ► BlobId
Gets the BLOB id.
Declaration Syntax
C#
public Guid BlobId { get; }
Value
The BLOB id.


CreateInstance Method

CreateInstance Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► SetBlobStreamCommand ► CreateInstance()()()
Creates an instance of the command class.
Declaration Syntax
C#
protected override SetBlobStreamCommand CreateInstance()
Return Value


DoExecute Method

DoExecute Method
Namespaces ► Sitecore.Data.Engines.DataCommands ► SetBlobStreamCommand ► DoExecute()()()
Executes the command.
Declaration Syntax
C#
protected override bool DoExecute()
Return Value
The blob stream (or null if no stream was found).


Initialize Method (stream, blobId)

Initialize Method (stream, blobId)
Namespaces ► Sitecore.Data.Engines.DataCommands ► SetBlobStreamCommand ► Initialize(Stream, Guid)
Initializes the instance.
Declaration Syntax
C#
public virtual void Initialize(
    Stream stream,
    Guid blobId
)
Parameters
stream (Stream)
The stream.
blobId (Guid)
The BLOB id.


Stream Property

Stream Property
Namespaces ► Sitecore.Data.Engines.DataCommands ► SetBlobStreamCommand ► Stream
Gets the stream.
Declaration Syntax
C#
public Stream Stream { get; }
Value
The stream.


Sitecore.Data.Events Namespace

Sitecore.Data.Events Namespace
Namespaces ► Sitecore.Data.Events
Declaration Syntax
C#
namespace Sitecore.Data.Events
Types
All Types Classes Enumerations Delegates
Icon | Type | Description
 | ConstructedEventArgs | Represents the arguments of a constructed event.
 | CopyProcessedSingleItemEventArgs |
 | DeleteProcessedSingleItemEventArgs |
 | EventDisabler | EventDisabler class
 | EventDisablerState |
 | ExecutedEventArgs<(Of <(TCommand>)>) | Defines the arguments passed in a AddingFromMaster event.
 | ExecutingEventArgs<(Of <(TCommand>)>) | Defines the arguments passed in a AddingFromMaster event.
 | FieldSavedDelegate | Represents the method that will handle the FieldSaved event.
 | FieldSavedEventArgs | Defines the arguments passed in a FieldSaved event.
 | GetChildrenEventArgs | Defines the arguments passed in a BeforeItemMove event.
 | GetItemEventArgs | Defines the arguments passed in a GetItem event.
 | GetParentIDEventArgs | Defines the arguments passed in a GetParentID event.
 | GetVersionNumbersEventArgs | Defines the arguments passed in a GetVersionNumbers event.
 | InstanceCreatedEventArgs | Represents the arguments of a instance created event.
 | ItemAddedDelegate | Obsolete. Represents the method that will handle the ItemAdded event.
 | ItemAddedEventArgs | Defines the arguments passed in a ItemAdded event.
 | ItemChildrenChangedDelegate | Represents the method that will handle the ItemChildrenChanged event.
 | ItemChildrenChangedEventArgs | Defines the arguments passed in a ItemChildrenChanged event.
 | ItemCopiedDelegate | Represents the method that will handle the ItemCopied event.
 | ItemCopiedEventArgs | Defines the arguments passed in a ItemCopied event.
 | ItemCreatedDelegate | Represents the method that will handle the ItemCreated event.
 | ItemCreatedEventArgs | Defines the arguments passed in a ItemCreated event.
 | ItemCreatingEventArgs | Defines the arguments passed in a ItemAdded event.
 | ItemDeletedDelegate | Represents the method that will handle the ItemDeleted event.
 | ItemDeletedEventArgs | Defines the arguments passed in a ItemDeleted event.
 | ItemDeletingEventArgs | Defines the arguments passed in a ItemDeleting event.
 | ItemMovedDelegate | Represents the method that will handle the ItemMoved event.
 | ItemMovedEventArgs | Defines the arguments passed in a ItemMoved event.
 | ItemRemovedEventArgs | Defines the arguments passed in a ItemRemoved event.
 | ItemRenamedDelegate | Represents the method that will handle the ItemRenamed event.
 | ItemRenamedEventArgs | Defines the arguments passed in a ItemRenamed event.
 | ItemSavedDelegate | Represents the method that will handle the ItemSaved event.
 | ItemSavedEventArgs | Defines the arguments passed in a ItemSaved event.
 | ItemSavingEventArgs | Defines the arguments passed in a ItemSaving event.
 | ItemSortorderChangedDelegate | Represents the method that will handle the ItemSortorderChanged event.
 | ItemSortorderChangedEventArgs | Defines the arguments passed in a ItemSortorderChanged event.
 | ResolvePathEventArgs | Defines the arguments passed in a ResolvePath event.
 | VersionAddedDelegate | Represents the method that will handle the VersionAdded event.
 | VersionAddedEventArgs | Defines the arguments passed in a VersionAdded event.
 | VersionRemovedDelegate | Represents the method that will handle the VersionRemoved event.
 | VersionsRemovedEventArgs | Defines the arguments passed in a VersionsRemoved event.


ConstructedEventArgs Class

ConstructedEventArgs Class
Namespaces ► Sitecore.Data.Events ► ConstructedEventArgs
Represents the arguments of a constructed event.
Declaration Syntax
C#
public class ConstructedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConstructedEventArgs(Database) | Constructs an instance of DatabaseLoadedEventArgs
 | Database | Gets the database that was loaded.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ConstructedEventArgs


ConstructedEventArgs Constructor (database)

ConstructedEventArgs Constructor (database)
Namespaces ► Sitecore.Data.Events ► ConstructedEventArgs ► ConstructedEventArgs(Database)
Constructs an instance of DatabaseLoadedEventArgs
Declaration Syntax
C#
public ConstructedEventArgs(
    Database database
)
Parameters
database (Database)
The database.


Database Property

Database Property
Namespaces ► Sitecore.Data.Events ► ConstructedEventArgs ► Database
Gets the database that was loaded.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


CopyProcessedSingleItemEventArgs Class

CopyProcessedSingleItemEventArgs Class
Namespaces ► Sitecore.Data.Events ► CopyProcessedSingleItemEventArgs
Declaration Syntax
C#
public class CopyProcessedSingleItemEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CopyProcessedSingleItemEventArgs(Database, ID, ID, ID) | Creates a new CopyProcessedSingleItemEventArgs instance.
 | CopyID | Gets the copy ID.
 | Database | Gets the database.
 | DestinationID | Gets the destination ID.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SourceID | Gets the source ID.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CopyProcessedSingleItemEventArgs


CopyProcessedSingleItemEventArgs Constructor (database, sourceID, destinationID, copyID)

CopyProcessedSingleItemEventArgs Constructor (database, sourceID, destinationID, copyID)
Namespaces ► Sitecore.Data.Events ► CopyProcessedSingleItemEventArgs ► CopyProcessedSingleItemEventArgs(Database, ID, ID, ID)
Creates a new CopyProcessedSingleItemEventArgs instance.
Declaration Syntax
C#
public CopyProcessedSingleItemEventArgs(
    Database database,
    ID sourceID,
    ID destinationID,
    ID copyID
)
Parameters
database (Database)
The database.
sourceID (ID)
The source ID.
destinationID (ID)
The destination ID.
copyID (ID)
The copy ID.


CopyID Property

CopyID Property
Namespaces ► Sitecore.Data.Events ► CopyProcessedSingleItemEventArgs ► CopyID
Gets the copy ID.
Declaration Syntax
C#
public ID CopyID { get; }
Value
The copy ID.


Database Property

Database Property
Namespaces ► Sitecore.Data.Events ► CopyProcessedSingleItemEventArgs ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


DestinationID Property

DestinationID Property
Namespaces ► Sitecore.Data.Events ► CopyProcessedSingleItemEventArgs ► DestinationID
Gets the destination ID.
Declaration Syntax
C#
public ID DestinationID { get; }
Value
The destination ID.


SourceID Property

SourceID Property
Namespaces ► Sitecore.Data.Events ► CopyProcessedSingleItemEventArgs ► SourceID
Gets the source ID.
Declaration Syntax
C#
public ID SourceID { get; }
Value
The source ID.


DeleteProcessedSingleItemEventArgs Class

DeleteProcessedSingleItemEventArgs Class
Namespaces ► Sitecore.Data.Events ► DeleteProcessedSingleItemEventArgs
Declaration Syntax
C#
public class DeleteProcessedSingleItemEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteProcessedSingleItemEventArgs(ID, Database) | Initializes a new instance of the DeleteProcessedSingleItemEventArgs class.
 | Database | Gets the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemID | Gets the item ID. Item itself is not available already.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DeleteProcessedSingleItemEventArgs


DeleteProcessedSingleItemEventArgs Constructor (itemID, database)

DeleteProcessedSingleItemEventArgs Constructor (itemID, database)
Namespaces ► Sitecore.Data.Events ► DeleteProcessedSingleItemEventArgs ► DeleteProcessedSingleItemEventArgs(ID, Database)
Initializes a new instance of the DeleteProcessedSingleItemEventArgs class.
Declaration Syntax
C#
public DeleteProcessedSingleItemEventArgs(
    ID itemID,
    Database database
)
Parameters
itemID (ID)
The item ID.
database (Database)
The database.


Database Property

Database Property
Namespaces ► Sitecore.Data.Events ► DeleteProcessedSingleItemEventArgs ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


ItemID Property

ItemID Property
Namespaces ► Sitecore.Data.Events ► DeleteProcessedSingleItemEventArgs ► ItemID
Gets the item ID. Item itself is not available already.
Declaration Syntax
C#
public ID ItemID { get; }
Value
The item ID.


EventDisabler Class

EventDisabler Class
Namespaces ► Sitecore.Data.Events ► EventDisabler
EventDisabler class
Declaration Syntax
C#
public sealed class EventDisabler : Switcher<EventDisablerState, EventDisabler>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EventDisabler()()() | Initializes a new instance of the EventDisabler class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsActive | Gets a value indicating whether this instance is active.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <( EventDisablerState, EventDisabler>)>)
 |  | EventDisabler


EventDisabler Constructor

EventDisabler Constructor
Namespaces ► Sitecore.Data.Events ► EventDisabler ► EventDisabler()()()
Initializes a new instance of the EventDisabler class.
Declaration Syntax
C#
public EventDisabler()


IsActive Property

IsActive Property
Namespaces ► Sitecore.Data.Events ► EventDisabler ► IsActive
Gets a value indicating whether this instance is active.
Declaration Syntax
C#
public static bool IsActive { get; }
Value
true if this instance is active; otherwise, false.


EventDisablerState Enumeration

EventDisablerState Enumeration
Namespaces ► Sitecore.Data.Events ► EventDisablerState
Declaration Syntax
C#
public enum EventDisablerState
Members
Member | Description
Disabled |
Enabled |


ExecutedEventArgs(TCommand) Class

ExecutedEventArgs<(Of <(TCommand>)>) Class
Namespaces ► Sitecore.Data.Events ► ExecutedEventArgs<(Of <(TCommand>)>)
Defines the arguments passed in a AddingFromMaster event.
Declaration Syntax
C#
public class ExecutedEventArgs<TCommand> : EventArgs
Generic Template Parameters
TCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExecutedEventArgs<(Of <(TCommand>)>)(TCommand) | Creates a new ExecutingEventArgs instance.
 | Command | Gets the item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ExecutedEventArgs<(Of <(TCommand>)>)


ExecutedEventArgs(TCommand) Constructor (command)

ExecutedEventArgs<(Of <(TCommand>)>) Constructor (command)
Namespaces ► Sitecore.Data.Events ► ExecutedEventArgs<(Of <(TCommand>)>) ► ExecutedEventArgs<(Of <(TCommand>)>)(TCommand)
Creates a new ExecutingEventArgs instance.
Declaration Syntax
C#
public ExecutedEventArgs(
    TCommand command
)
Parameters
command (TCommand)
The command.


Command Property

Command Property
Namespaces ► Sitecore.Data.Events ► ExecutedEventArgs<(Of <(TCommand>)>) ► Command
Gets the item.
Declaration Syntax
C#
public TCommand Command { get; }
Value
The command.


ExecutingEventArgs(TCommand) Class

ExecutingEventArgs<(Of <(TCommand>)>) Class
Namespaces ► Sitecore.Data.Events ► ExecutingEventArgs<(Of <(TCommand>)>)
Defines the arguments passed in a AddingFromMaster event.
Declaration Syntax
C#
public class ExecutingEventArgs<TCommand> : CancelEventArgs
Generic Template Parameters
TCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExecutingEventArgs<(Of <(TCommand>)>)(TCommand) | Creates a new instance.
 | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
 | Command | Gets the item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CancelEventArgs
 |  |  | ExecutingEventArgs<(Of <(TCommand>)>)


ExecutingEventArgs(TCommand) Constructor (command)

ExecutingEventArgs<(Of <(TCommand>)>) Constructor (command)
Namespaces ► Sitecore.Data.Events ► ExecutingEventArgs<(Of <(TCommand>)>) ► ExecutingEventArgs<(Of <(TCommand>)>)(TCommand)
Creates a new instance.
Declaration Syntax
C#
public ExecutingEventArgs(
    TCommand command
)
Parameters
command (TCommand)
The command.


Command Property

Command Property
Namespaces ► Sitecore.Data.Events ► ExecutingEventArgs<(Of <(TCommand>)>) ► Command
Gets the item.
Declaration Syntax
C#
public TCommand Command { get; }
Value
The command.


FieldSavedDelegate Delegate

FieldSavedDelegate Delegate
Namespaces ► Sitecore.Data.Events ► FieldSavedDelegate
Represents the method that will handle the FieldSaved event.
Declaration Syntax
C#
public delegate void FieldSavedDelegate(
    Object sender,
    FieldSavedEventArgs args
)
Parameters
sender (Object)
args (FieldSavedEventArgs)
Remarks
When you create a FieldSavedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.


FieldSavedEventArgs Class

FieldSavedEventArgs Class
Namespaces ► Sitecore.Data.Events ► FieldSavedEventArgs
Defines the arguments passed in a FieldSaved event.
Declaration Syntax
C#
public class FieldSavedEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldSavedEventArgs(Field) | Creates a new FieldSavedEventArgs instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Field | Gets the field.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FieldSavedEventArgs


FieldSavedEventArgs Constructor (field)

FieldSavedEventArgs Constructor (field)
Namespaces ► Sitecore.Data.Events ► FieldSavedEventArgs ► FieldSavedEventArgs(Field)
Creates a new FieldSavedEventArgs instance.
Declaration Syntax
C#
public FieldSavedEventArgs(
    Field field
)
Parameters
field (Field)
Field.


Field Property

Field Property
Namespaces ► Sitecore.Data.Events ► FieldSavedEventArgs ► Field
Gets the field.
Declaration Syntax
C#
public Field Field { get; }
Value
The field.


GetChildrenEventArgs Class

GetChildrenEventArgs Class
Namespaces ► Sitecore.Data.Events ► GetChildrenEventArgs
Defines the arguments passed in a BeforeItemMove event.
Declaration Syntax
C#
public class GetChildrenEventArgs : CancelEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetChildrenEventArgs(ID) | Creates a new GetChildrenEventArgs instance.
 | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
 | CustomResult | Gets or sets the custom result.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemID | Gets the item ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CancelEventArgs
 |  |  | GetChildrenEventArgs


GetChildrenEventArgs Constructor (itemID)

GetChildrenEventArgs Constructor (itemID)
Namespaces ► Sitecore.Data.Events ► GetChildrenEventArgs ► GetChildrenEventArgs(ID)
Creates a new GetChildrenEventArgs instance.
Declaration Syntax
C#
public GetChildrenEventArgs(
    ID itemID
)
Parameters
itemID (ID)
Item ID.


CustomResult Property

CustomResult Property
Namespaces ► Sitecore.Data.Events ► GetChildrenEventArgs ► CustomResult
Gets or sets the custom result.
Declaration Syntax
C#
public ID[] CustomResult { get; set; }
Value
The custom result.


ItemID Property

ItemID Property
Namespaces ► Sitecore.Data.Events ► GetChildrenEventArgs ► ItemID
Gets the item ID.
Declaration Syntax
C#
public ID ItemID { get; }
Value
The item ID.


GetItemEventArgs Class

GetItemEventArgs Class
Namespaces ► Sitecore.Data.Events ► GetItemEventArgs
Defines the arguments passed in a GetItem event.
Declaration Syntax
C#
public class GetItemEventArgs : CancelEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetItemEventArgs(ID, Language, Version) | Creates a new GetItemEventArgs instance.
 | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
 | CustomResult | Gets or sets the custom result.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemId | Gets the item id.
 | Language | Gets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | Gets the version.
Inheritance Hierarchy
Object
 | EventArgs
 |  | CancelEventArgs
 |  |  | GetItemEventArgs


GetItemEventArgs Constructor (itemID, language, version)

GetItemEventArgs Constructor (itemID, language, version)
Namespaces ► Sitecore.Data.Events ► GetItemEventArgs ► GetItemEventArgs(ID, Language, Version)
Creates a new GetItemEventArgs instance.
Declaration Syntax
C#
public GetItemEventArgs(
    ID itemID,
    Language language,
    Version version
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.
version (Version)
Version.


CustomResult Property

CustomResult Property
Namespaces ► Sitecore.Data.Events ► GetItemEventArgs ► CustomResult
Gets or sets the custom result.
Declaration Syntax
C#
public Item CustomResult { get; set; }
Value
The custom result.


ItemId Property

ItemId Property
Namespaces ► Sitecore.Data.Events ► GetItemEventArgs ► ItemId
Gets the item id.
Declaration Syntax
C#
public ID ItemId { get; }
Value
The item id.


Language Property

Language Property
Namespaces ► Sitecore.Data.Events ► GetItemEventArgs ► Language
Gets the language.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


Version Property

Version Property
Namespaces ► Sitecore.Data.Events ► GetItemEventArgs ► Version
Gets the version.
Declaration Syntax
C#
public Version Version { get; }
Value
The version.


GetParentIDEventArgs Class

GetParentIDEventArgs Class
Namespaces ► Sitecore.Data.Events ► GetParentIDEventArgs
Defines the arguments passed in a GetParentID event.
Declaration Syntax
C#
public class GetParentIDEventArgs : CancelEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetParentIDEventArgs(ID) | Creates a new GetParentIDEventArgs instance.
 | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
 | CustomResult | Gets or sets the custom result.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemID | Gets the item ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CancelEventArgs
 |  |  | GetParentIDEventArgs


GetParentIDEventArgs Constructor (itemID)

GetParentIDEventArgs Constructor (itemID)
Namespaces ► Sitecore.Data.Events ► GetParentIDEventArgs ► GetParentIDEventArgs(ID)
Creates a new GetParentIDEventArgs instance.
Declaration Syntax
C#
public GetParentIDEventArgs(
    ID itemID
)
Parameters
itemID (ID)
Item ID.


CustomResult Property

CustomResult Property
Namespaces ► Sitecore.Data.Events ► GetParentIDEventArgs ► CustomResult
Gets or sets the custom result.
Declaration Syntax
C#
public ID CustomResult { get; set; }
Value
The custom result.


ItemID Property

ItemID Property
Namespaces ► Sitecore.Data.Events ► GetParentIDEventArgs ► ItemID
Gets the item ID.
Declaration Syntax
C#
public ID ItemID { get; }
Value
The item ID.


GetVersionNumbersEventArgs Class

GetVersionNumbersEventArgs Class
Namespaces ► Sitecore.Data.Events ► GetVersionNumbersEventArgs
Defines the arguments passed in a GetVersionNumbers event.
Declaration Syntax
C#
public class GetVersionNumbersEventArgs : CancelEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetVersionNumbersEventArgs(ID, Language) | Creates a new GetVersionNumbersEventArgs instance.
 | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
 | CustomResult | Gets or sets the custom result.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemID | Gets the item ID.
 | Language | Gets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CancelEventArgs
 |  |  | GetVersionNumbersEventArgs


GetVersionNumbersEventArgs Constructor (itemID, language)

GetVersionNumbersEventArgs Constructor (itemID, language)
Namespaces ► Sitecore.Data.Events ► GetVersionNumbersEventArgs ► GetVersionNumbersEventArgs(ID, Language)
Creates a new GetVersionNumbersEventArgs instance.
Declaration Syntax
C#
public GetVersionNumbersEventArgs(
    ID itemID,
    Language language
)
Parameters
itemID (ID)
Item ID.
language (Language)
Language.


CustomResult Property

CustomResult Property
Namespaces ► Sitecore.Data.Events ► GetVersionNumbersEventArgs ► CustomResult
Gets or sets the custom result.
Declaration Syntax
C#
public Version[] CustomResult { get; set; }
Value
The custom result.


ItemID Property

ItemID Property
Namespaces ► Sitecore.Data.Events ► GetVersionNumbersEventArgs ► ItemID
Gets the item ID.
Declaration Syntax
C#
public ID ItemID { get; }
Value
The item ID.


Language Property

Language Property
Namespaces ► Sitecore.Data.Events ► GetVersionNumbersEventArgs ► Language
Gets the language.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


InstanceCreatedEventArgs Class

InstanceCreatedEventArgs Class
Namespaces ► Sitecore.Data.Events ► InstanceCreatedEventArgs
Represents the arguments of a instance created event.
Declaration Syntax
C#
public class InstanceCreatedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstanceCreatedEventArgs(Database) | Constructs an instance of DatabaseLoadedEventArgs
 | Database | Gets the database that was loaded.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | InstanceCreatedEventArgs


InstanceCreatedEventArgs Constructor (database)

InstanceCreatedEventArgs Constructor (database)
Namespaces ► Sitecore.Data.Events ► InstanceCreatedEventArgs ► InstanceCreatedEventArgs(Database)
Constructs an instance of DatabaseLoadedEventArgs
Declaration Syntax
C#
public InstanceCreatedEventArgs(
    Database database
)
Parameters
database (Database)
The database.


Database Property

Database Property
Namespaces ► Sitecore.Data.Events ► InstanceCreatedEventArgs ► Database
Gets the database that was loaded.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


ItemAddedDelegate Delegate

ItemAddedDelegate Delegate
Namespaces ► Sitecore.Data.Events ► ItemAddedDelegate
Represents the method that will handle the ItemAdded event.
Declaration Syntax
C#
[ObsoleteAttribute("Use the ItemCreatedDelegate event instead.")]
public delegate void ItemAddedDelegate(
    Object sender,
    ItemAddedEventArgs args
)
Parameters
sender (Object)
args (ItemAddedEventArgs)
Remarks
When you create a ItemAddedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.


ItemAddedEventArgs Class

ItemAddedEventArgs Class
Namespaces ► Sitecore.Data.Events ► ItemAddedEventArgs
Defines the arguments passed in a ItemAdded event.
Declaration Syntax
C#
public class ItemAddedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemAddedEventArgs(Item) | Creates a new ItemAddedEventArgs instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ItemAddedEventArgs


ItemAddedEventArgs Constructor (item)

ItemAddedEventArgs Constructor (item)
Namespaces ► Sitecore.Data.Events ► ItemAddedEventArgs ► ItemAddedEventArgs(Item)
Creates a new ItemAddedEventArgs instance.
Declaration Syntax
C#
public ItemAddedEventArgs(
    Item item
)
Parameters
item (Item)
Item.


Item Property

Item Property
Namespaces ► Sitecore.Data.Events ► ItemAddedEventArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


ItemChildrenChangedDelegate Delegate

ItemChildrenChangedDelegate Delegate
Namespaces ► Sitecore.Data.Events ► ItemChildrenChangedDelegate
Represents the method that will handle the ItemChildrenChanged event.
Declaration Syntax
C#
public delegate void ItemChildrenChangedDelegate(
    Object sender,
    ItemChildrenChangedEventArgs args
)
Parameters
sender (Object)
args (ItemChildrenChangedEventArgs)
Remarks
When you create a ItemChildrenChangedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.


ItemChildrenChangedEventArgs Class

ItemChildrenChangedEventArgs Class
Namespaces ► Sitecore.Data.Events ► ItemChildrenChangedEventArgs
Defines the arguments passed in a ItemChildrenChanged event.
Declaration Syntax
C#
public class ItemChildrenChangedEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemChildrenChangedEventArgs(Item) | Creates a new ItemCopiedEventArgs instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemChildrenChangedEventArgs


ItemChildrenChangedEventArgs Constructor (item)

ItemChildrenChangedEventArgs Constructor (item)
Namespaces ► Sitecore.Data.Events ► ItemChildrenChangedEventArgs ► ItemChildrenChangedEventArgs(Item)
Creates a new ItemCopiedEventArgs instance.
Declaration Syntax
C#
public ItemChildrenChangedEventArgs(
    Item item
)
Parameters
item (Item)
Item.


Item Property

Item Property
Namespaces ► Sitecore.Data.Events ► ItemChildrenChangedEventArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


ItemCopiedDelegate Delegate

ItemCopiedDelegate Delegate
Namespaces ► Sitecore.Data.Events ► ItemCopiedDelegate
Represents the method that will handle the ItemCopied event.
Declaration Syntax
C#
public delegate void ItemCopiedDelegate(
    Object sender,
    ItemCopiedEventArgs args
)
Parameters
sender (Object)
args (ItemCopiedEventArgs)
Remarks
When you create a ItemCopiedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.


ItemCopiedEventArgs Class

ItemCopiedEventArgs Class
Namespaces ► Sitecore.Data.Events ► ItemCopiedEventArgs
Defines the arguments passed in a ItemCopied event.
Declaration Syntax
C#
public class ItemCopiedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemCopiedEventArgs(Item, Item) | Creates a new ItemCopiedEventArgs instance.
 | Copy | Gets the copy.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Source | Gets the source.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ItemCopiedEventArgs


ItemCopiedEventArgs Constructor (source, copy)

ItemCopiedEventArgs Constructor (source, copy)
Namespaces ► Sitecore.Data.Events ► ItemCopiedEventArgs ► ItemCopiedEventArgs(Item, Item)
Creates a new ItemCopiedEventArgs instance.
Declaration Syntax
C#
public ItemCopiedEventArgs(
    Item source,
    Item copy
)
Parameters
source (Item)
Source.
copy (Item)
Copy.


Copy Property

Copy Property
Namespaces ► Sitecore.Data.Events ► ItemCopiedEventArgs ► Copy
Gets the copy.
Declaration Syntax
C#
public Item Copy { get; }
Value
The copy.


Source Property

Source Property
Namespaces ► Sitecore.Data.Events ► ItemCopiedEventArgs ► Source
Gets the source.
Declaration Syntax
C#
public Item Source { get; }
Value
The source.


ItemCreatedDelegate Delegate

ItemCreatedDelegate Delegate
Namespaces ► Sitecore.Data.Events ► ItemCreatedDelegate
Represents the method that will handle the ItemCreated event.
Declaration Syntax
C#
public delegate void ItemCreatedDelegate(
    Object sender,
    ItemCreatedEventArgs args
)
Parameters
sender (Object)
args (ItemCreatedEventArgs)
Remarks
When you create a ItemCreatedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.


ItemCreatedEventArgs Class

ItemCreatedEventArgs Class
Namespaces ► Sitecore.Data.Events ► ItemCreatedEventArgs
Defines the arguments passed in a ItemCreated event.
Declaration Syntax
C#
public class ItemCreatedEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemCreatedEventArgs(Item) | Creates a new ItemCreatedEventArgs instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemCreatedEventArgs


ItemCreatedEventArgs Constructor (item)

ItemCreatedEventArgs Constructor (item)
Namespaces ► Sitecore.Data.Events ► ItemCreatedEventArgs ► ItemCreatedEventArgs(Item)
Creates a new ItemCreatedEventArgs instance.
Declaration Syntax
C#
public ItemCreatedEventArgs(
    Item item
)
Parameters
item (Item)
Item.


Item Property

Item Property
Namespaces ► Sitecore.Data.Events ► ItemCreatedEventArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


ItemCreatingEventArgs Class

ItemCreatingEventArgs Class
Namespaces ► Sitecore.Data.Events ► ItemCreatingEventArgs
Defines the arguments passed in a ItemAdded event.
Declaration Syntax
C#
public class ItemCreatingEventArgs : CancelEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemCreatingEventArgs(String, ID, ID, Item) | Creates a new ItemCreatingEventArgs instance.
 | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemId | Gets the item id.
 | ItemName | Gets the name of the item being created.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets the parent.
 | TemplateId | Gets the template id of the item being created.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CancelEventArgs
 |  |  | ItemCreatingEventArgs


ItemCreatingEventArgs Constructor (itemName, itemId, templateId, parent)

ItemCreatingEventArgs Constructor (itemName, itemId, templateId, parent)
Namespaces ► Sitecore.Data.Events ► ItemCreatingEventArgs ► ItemCreatingEventArgs(String, ID, ID, Item)
Creates a new ItemCreatingEventArgs instance.
Declaration Syntax
C#
public ItemCreatingEventArgs(
    string itemName,
    ID itemId,
    ID templateId,
    Item parent
)
Parameters
itemName (String)
Name of the item.
itemId (ID)
The item id.
templateId (ID)
The template id.
parent (Item)
The parent.


ItemId Property

ItemId Property
Namespaces ► Sitecore.Data.Events ► ItemCreatingEventArgs ► ItemId
Gets the item id.
Declaration Syntax
C#
public ID ItemId { get; }
Value
The item id.


ItemName Property

ItemName Property
Namespaces ► Sitecore.Data.Events ► ItemCreatingEventArgs ► ItemName
Gets the name of the item being created.
Declaration Syntax
C#
public string ItemName { get; }
Value
The name of the item.


Parent Property

Parent Property
Namespaces ► Sitecore.Data.Events ► ItemCreatingEventArgs ► Parent
Gets the parent.
Declaration Syntax
C#
public Item Parent { get; }
Value
The parent.


TemplateId Property

TemplateId Property
Namespaces ► Sitecore.Data.Events ► ItemCreatingEventArgs ► TemplateId
Gets the template id of the item being created.
Declaration Syntax
C#
public ID TemplateId { get; }
Value
The template id.


ItemDeletedDelegate Delegate

ItemDeletedDelegate Delegate
Namespaces ► Sitecore.Data.Events ► ItemDeletedDelegate
Represents the method that will handle the ItemDeleted event.
Declaration Syntax
C#
public delegate void ItemDeletedDelegate(
    Object sender,
    ItemDeletedEventArgs args
)
Parameters
sender (Object)
args (ItemDeletedEventArgs)
Remarks
When you create a ItemDeletedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.


ItemDeletedEventArgs Class

ItemDeletedEventArgs Class
Namespaces ► Sitecore.Data.Events ► ItemDeletedEventArgs
Defines the arguments passed in a ItemDeleted event.
Declaration Syntax
C#
public class ItemDeletedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemDeletedEventArgs(Item, ID) | Creates a new ItemDeletedEventArgs instance.
 | ItemDeletedEventArgs(Item, ID, Int32) | Creates a new ItemDeletedEventArgs instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Index | Gets the ID of the item that should be focused in the client after this item is deleted.
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentID | Gets the parent ID.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ItemDeletedEventArgs


ItemDeletedEventArgs Constructor

ItemDeletedEventArgs Constructor
Namespaces ► Sitecore.Data.Events ► ItemDeletedEventArgs ► ItemDeletedEventArgs()()()
Members
Icon | Member | Description
 | ItemDeletedEventArgs(Item, ID) | Creates a new ItemDeletedEventArgs instance.
 | ItemDeletedEventArgs(Item, ID, Int32) | Creates a new ItemDeletedEventArgs instance.


ItemDeletedEventArgs Constructor (item, parentID)

ItemDeletedEventArgs Constructor (item, parentID)
Namespaces ► Sitecore.Data.Events ► ItemDeletedEventArgs ► ItemDeletedEventArgs(Item, ID)
Creates a new ItemDeletedEventArgs instance.
Declaration Syntax
C#
public ItemDeletedEventArgs(
    Item item,
    ID parentID
)
Parameters
item (Item)
Item.
parentID (ID)
Parent ID.


ItemDeletedEventArgs Constructor (item, parentID, index)

ItemDeletedEventArgs Constructor (item, parentID, index)
Namespaces ► Sitecore.Data.Events ► ItemDeletedEventArgs ► ItemDeletedEventArgs(Item, ID, Int32)
Creates a new ItemDeletedEventArgs instance.
Declaration Syntax
C#
public ItemDeletedEventArgs(
    Item item,
    ID parentID,
    int index
)
Parameters
item (Item)
Item.
parentID (ID)
Parent ID.
index (Int32)
Index of the item (among its siblings) before it was deleted.


Index Property

Index Property
Namespaces ► Sitecore.Data.Events ► ItemDeletedEventArgs ► Index
Gets the ID of the item that should be focused in the client after this item is deleted.
Declaration Syntax
C#
public int Index { get; }
Value
The index.


Item Property

Item Property
Namespaces ► Sitecore.Data.Events ► ItemDeletedEventArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


ParentID Property

ParentID Property
Namespaces ► Sitecore.Data.Events ► ItemDeletedEventArgs ► ParentID
Gets the parent ID.
Declaration Syntax
C#
public ID ParentID { get; }
Value
The parent ID.


ItemDeletingEventArgs Class

ItemDeletingEventArgs Class
Namespaces ► Sitecore.Data.Events ► ItemDeletingEventArgs
Defines the arguments passed in a ItemDeleting event.
Declaration Syntax
C#
public class ItemDeletingEventArgs : CancelEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemDeletingEventArgs(Item) | Creates a new ItemDeletingEventArgs instance.
 | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CancelEventArgs
 |  |  | ItemDeletingEventArgs


ItemDeletingEventArgs Constructor (item)

ItemDeletingEventArgs Constructor (item)
Namespaces ► Sitecore.Data.Events ► ItemDeletingEventArgs ► ItemDeletingEventArgs(Item)
Creates a new ItemDeletingEventArgs instance.
Declaration Syntax
C#
public ItemDeletingEventArgs(
    Item item
)
Parameters
item (Item)
Item.


Item Property

Item Property
Namespaces ► Sitecore.Data.Events ► ItemDeletingEventArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


ItemMovedDelegate Delegate

ItemMovedDelegate Delegate
Namespaces ► Sitecore.Data.Events ► ItemMovedDelegate
Represents the method that will handle the ItemMoved event.
Declaration Syntax
C#
public delegate void ItemMovedDelegate(
    Object sender,
    ItemMovedEventArgs args
)
Parameters
sender (Object)
args (ItemMovedEventArgs)
Remarks
When you create a ItemMovedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.


ItemMovedEventArgs Class

ItemMovedEventArgs Class
Namespaces ► Sitecore.Data.Events ► ItemMovedEventArgs
Defines the arguments passed in a ItemMoved event.
Declaration Syntax
C#
public class ItemMovedEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemMovedEventArgs(Item, ID) | Creates a new ItemMovedEventArgs instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OldParentID | Gets the old parent ID.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemMovedEventArgs


ItemMovedEventArgs Constructor (item, oldParentID)

ItemMovedEventArgs Constructor (item, oldParentID)
Namespaces ► Sitecore.Data.Events ► ItemMovedEventArgs ► ItemMovedEventArgs(Item, ID)
Creates a new ItemMovedEventArgs instance.
Declaration Syntax
C#
public ItemMovedEventArgs(
    Item item,
    ID oldParentID
)
Parameters
item (Item)
Item.
oldParentID (ID)
Old parent ID.


Item Property

Item Property
Namespaces ► Sitecore.Data.Events ► ItemMovedEventArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


OldParentID Property

OldParentID Property
Namespaces ► Sitecore.Data.Events ► ItemMovedEventArgs ► OldParentID
Gets the old parent ID.
Declaration Syntax
C#
public ID OldParentID { get; }
Value
The old parent ID.


ItemRemovedEventArgs Class

ItemRemovedEventArgs Class
Namespaces ► Sitecore.Data.Events ► ItemRemovedEventArgs
Defines the arguments passed in a ItemRemoved event.
Declaration Syntax
C#
public class ItemRemovedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemRemovedEventArgs(ID) | Creates a new ItemRemovedEventArgs instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemId | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ItemRemovedEventArgs


ItemRemovedEventArgs Constructor (itemId)

ItemRemovedEventArgs Constructor (itemId)
Namespaces ► Sitecore.Data.Events ► ItemRemovedEventArgs ► ItemRemovedEventArgs(ID)
Creates a new ItemRemovedEventArgs instance.
Declaration Syntax
C#
public ItemRemovedEventArgs(
    ID itemId
)
Parameters
itemId (ID)
The item id.


ItemId Property

ItemId Property
Namespaces ► Sitecore.Data.Events ► ItemRemovedEventArgs ► ItemId
Gets the item.
Declaration Syntax
C#
public ID ItemId { get; }
Value
The item id.


ItemRenamedDelegate Delegate

ItemRenamedDelegate Delegate
Namespaces ► Sitecore.Data.Events ► ItemRenamedDelegate
Represents the method that will handle the ItemRenamed event.
Declaration Syntax
C#
public delegate void ItemRenamedDelegate(
    Object sender,
    ItemRenamedEventArgs args
)
Parameters
sender (Object)
args (ItemRenamedEventArgs)
Remarks
When you create a ItemRenamedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.


ItemRenamedEventArgs Class

ItemRenamedEventArgs Class
Namespaces ► Sitecore.Data.Events ► ItemRenamedEventArgs
Defines the arguments passed in a ItemRenamed event.
Declaration Syntax
C#
public class ItemRenamedEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemRenamedEventArgs(Item, String) | Creates a new ItemRenamedEventArgs instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OldName | Gets the old name of the item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemRenamedEventArgs


ItemRenamedEventArgs Constructor (item, oldName)

ItemRenamedEventArgs Constructor (item, oldName)
Namespaces ► Sitecore.Data.Events ► ItemRenamedEventArgs ► ItemRenamedEventArgs(Item, String)
Creates a new ItemRenamedEventArgs instance.
Declaration Syntax
C#
public ItemRenamedEventArgs(
    Item item,
    string oldName
)
Parameters
item (Item)
Item.
oldName (String)
Old Name of the item.


Item Property

Item Property
Namespaces ► Sitecore.Data.Events ► ItemRenamedEventArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


OldName Property

OldName Property
Namespaces ► Sitecore.Data.Events ► ItemRenamedEventArgs ► OldName
Gets the old name of the item.
Declaration Syntax
C#
public Object OldName { get; }
Value
The old name.


ItemSavedDelegate Delegate

ItemSavedDelegate Delegate
Namespaces ► Sitecore.Data.Events ► ItemSavedDelegate
Represents the method that will handle the ItemSaved event.
Declaration Syntax
C#
public delegate void ItemSavedDelegate(
    Object sender,
    ItemSavedEventArgs args
)
Parameters
sender (Object)
args (ItemSavedEventArgs)
Remarks
When you create a ItemSavedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.


ItemSavedEventArgs Class

ItemSavedEventArgs Class
Namespaces ► Sitecore.Data.Events ► ItemSavedEventArgs
Defines the arguments passed in a ItemSaved event.
Declaration Syntax
C#
public class ItemSavedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemSavedEventArgs(Item) | Creates a new ItemSavedEventArgs instance.
 | ItemSavedEventArgs(Item, ItemChanges) | Creates a new ItemSavedEventArgs instance.
 | Changes | Gets the changes that were saved.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ItemSavedEventArgs


ItemSavedEventArgs Constructor

ItemSavedEventArgs Constructor
Namespaces ► Sitecore.Data.Events ► ItemSavedEventArgs ► ItemSavedEventArgs()()()
Members
Icon | Member | Description
 | ItemSavedEventArgs(Item) | Creates a new ItemSavedEventArgs instance.
 | ItemSavedEventArgs(Item, ItemChanges) | Creates a new ItemSavedEventArgs instance.


ItemSavedEventArgs Constructor (item)

ItemSavedEventArgs Constructor (item)
Namespaces ► Sitecore.Data.Events ► ItemSavedEventArgs ► ItemSavedEventArgs(Item)
Creates a new ItemSavedEventArgs instance.
Declaration Syntax
C#
public ItemSavedEventArgs(
    Item item
)
Parameters
item (Item)
Item.


ItemSavedEventArgs Constructor (item, changes)

ItemSavedEventArgs Constructor (item, changes)
Namespaces ► Sitecore.Data.Events ► ItemSavedEventArgs ► ItemSavedEventArgs(Item, ItemChanges)
Creates a new ItemSavedEventArgs instance.
Declaration Syntax
C#
public ItemSavedEventArgs(
    Item item,
    ItemChanges changes
)
Parameters
item (Item)
Item.
changes (ItemChanges)
The changes that were saved.


Changes Property

Changes Property
Namespaces ► Sitecore.Data.Events ► ItemSavedEventArgs ► Changes
Gets the changes that were saved.
Declaration Syntax
C#
public ItemChanges Changes { get; }
Value
The changes.


Item Property

Item Property
Namespaces ► Sitecore.Data.Events ► ItemSavedEventArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


ItemSavingEventArgs Class

ItemSavingEventArgs Class
Namespaces ► Sitecore.Data.Events ► ItemSavingEventArgs
Defines the arguments passed in a ItemSaving event.
Declaration Syntax
C#
public class ItemSavingEventArgs : CancelEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemSavingEventArgs(Item, ItemChanges) | Creates a new ItemSavedEventArgs instance.
 | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
 | Changes | Gets the changes that were saved.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CancelEventArgs
 |  |  | ItemSavingEventArgs


ItemSavingEventArgs Constructor (item, changes)

ItemSavingEventArgs Constructor (item, changes)
Namespaces ► Sitecore.Data.Events ► ItemSavingEventArgs ► ItemSavingEventArgs(Item, ItemChanges)
Creates a new ItemSavedEventArgs instance.
Declaration Syntax
C#
public ItemSavingEventArgs(
    Item item,
    ItemChanges changes
)
Parameters
item (Item)
Item.
changes (ItemChanges)
The changes that were saved.


Changes Property

Changes Property
Namespaces ► Sitecore.Data.Events ► ItemSavingEventArgs ► Changes
Gets the changes that were saved.
Declaration Syntax
C#
public ItemChanges Changes { get; }
Value
The changes.


Item Property

Item Property
Namespaces ► Sitecore.Data.Events ► ItemSavingEventArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


ItemSortorderChangedDelegate Delegate

ItemSortorderChangedDelegate Delegate
Namespaces ► Sitecore.Data.Events ► ItemSortorderChangedDelegate
Represents the method that will handle the ItemSortorderChanged event.
Declaration Syntax
C#
public delegate void ItemSortorderChangedDelegate(
    Object sender,
    ItemSortorderChangedEventArgs args
)
Parameters
sender (Object)
args (ItemSortorderChangedEventArgs)
Remarks
When you create a ItemSortorderChangedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.


ItemSortorderChangedEventArgs Class

ItemSortorderChangedEventArgs Class
Namespaces ► Sitecore.Data.Events ► ItemSortorderChangedEventArgs
Defines the arguments passed in a ItemSortorderChanged event.
Declaration Syntax
C#
public class ItemSortorderChangedEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemSortorderChangedEventArgs(Item, String) | Creates a new ItemSortorderChangedEventArgs instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OldSortorder | Gets the old sortorder.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemSortorderChangedEventArgs


ItemSortorderChangedEventArgs Constructor (item, oldSortorder)

ItemSortorderChangedEventArgs Constructor (item, oldSortorder)
Namespaces ► Sitecore.Data.Events ► ItemSortorderChangedEventArgs ► ItemSortorderChangedEventArgs(Item, String)
Creates a new ItemSortorderChangedEventArgs instance.
Declaration Syntax
C#
public ItemSortorderChangedEventArgs(
    Item item,
    string oldSortorder
)
Parameters
item (Item)
Item.
oldSortorder (String)
Old sortorder.


Item Property

Item Property
Namespaces ► Sitecore.Data.Events ► ItemSortorderChangedEventArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


OldSortorder Property

OldSortorder Property
Namespaces ► Sitecore.Data.Events ► ItemSortorderChangedEventArgs ► OldSortorder
Gets the old sortorder.
Declaration Syntax
C#
public Object OldSortorder { get; }
Value
The old sortorder.


ResolvePathEventArgs Class

ResolvePathEventArgs Class
Namespaces ► Sitecore.Data.Events ► ResolvePathEventArgs
Defines the arguments passed in a ResolvePath event.
Declaration Syntax
C#
public class ResolvePathEventArgs : CancelEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResolvePathEventArgs(String) | Creates a new ResolvePathEventArgs instance.
 | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
 | CustomResult | Gets or sets the custom result.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets the path.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CancelEventArgs
 |  |  | ResolvePathEventArgs


ResolvePathEventArgs Constructor (path)

ResolvePathEventArgs Constructor (path)
Namespaces ► Sitecore.Data.Events ► ResolvePathEventArgs ► ResolvePathEventArgs(String)
Creates a new ResolvePathEventArgs instance.
Declaration Syntax
C#
public ResolvePathEventArgs(
    string path
)
Parameters
path (String)
Path.


CustomResult Property

CustomResult Property
Namespaces ► Sitecore.Data.Events ► ResolvePathEventArgs ► CustomResult
Gets or sets the custom result.
Declaration Syntax
C#
public ID CustomResult { get; set; }
Value
The custom result.


Path Property

Path Property
Namespaces ► Sitecore.Data.Events ► ResolvePathEventArgs ► Path
Gets the path.
Declaration Syntax
C#
public string Path { get; }
Value
The path.


VersionAddedDelegate Delegate

VersionAddedDelegate Delegate
Namespaces ► Sitecore.Data.Events ► VersionAddedDelegate
Represents the method that will handle the VersionAdded event.
Declaration Syntax
C#
public delegate void VersionAddedDelegate(
    Object sender,
    VersionAddedEventArgs args
)
Parameters
sender (Object)
args (VersionAddedEventArgs)
Remarks
When you create a VersionAddedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.


VersionAddedEventArgs Class

VersionAddedEventArgs Class
Namespaces ► Sitecore.Data.Events ► VersionAddedEventArgs
Defines the arguments passed in a VersionAdded event.
Declaration Syntax
C#
public class VersionAddedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VersionAddedEventArgs(Item) | Creates a new VersionAddedEventArgs instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | VersionAddedEventArgs


VersionAddedEventArgs Constructor (item)

VersionAddedEventArgs Constructor (item)
Namespaces ► Sitecore.Data.Events ► VersionAddedEventArgs ► VersionAddedEventArgs(Item)
Creates a new VersionAddedEventArgs instance.
Declaration Syntax
C#
public VersionAddedEventArgs(
    Item item
)
Parameters
item (Item)
Item.


Item Property

Item Property
Namespaces ► Sitecore.Data.Events ► VersionAddedEventArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


VersionRemovedDelegate Delegate

VersionRemovedDelegate Delegate
Namespaces ► Sitecore.Data.Events ► VersionRemovedDelegate
Represents the method that will handle the VersionRemoved event.
Declaration Syntax
C#
public delegate void VersionRemovedDelegate(
    Object sender,
    VersionRemovedEventArgs args
)
Parameters
sender (Object)
args (VersionRemovedEventArgs)
Remarks
When you create a ItemRemovedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.


VersionsRemovedEventArgs Class

VersionsRemovedEventArgs Class
Namespaces ► Sitecore.Data.Events ► VersionsRemovedEventArgs
Defines the arguments passed in a VersionsRemoved event.
Declaration Syntax
C#
public class VersionsRemovedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VersionsRemovedEventArgs(ID, Language) | Creates a new VersionsRemovedEventArgs instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemId | Gets the item id.
 | Language | Gets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | VersionsRemovedEventArgs


VersionsRemovedEventArgs Constructor (itemId, language)

VersionsRemovedEventArgs Constructor (itemId, language)
Namespaces ► Sitecore.Data.Events ► VersionsRemovedEventArgs ► VersionsRemovedEventArgs(ID, Language)
Creates a new VersionsRemovedEventArgs instance.
Declaration Syntax
C#
public VersionsRemovedEventArgs(
    ID itemId,
    Language language
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.


ItemId Property

ItemId Property
Namespaces ► Sitecore.Data.Events ► VersionsRemovedEventArgs ► ItemId
Gets the item id.
Declaration Syntax
C#
public ID ItemId { get; }
Value
The item id.


Language Property

Language Property
Namespaces ► Sitecore.Data.Events ► VersionsRemovedEventArgs ► Language
Gets the language.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


Sitecore.Data.Fields Namespace

Sitecore.Data.Fields Namespace
Namespaces ► Sitecore.Data.Fields
Declaration Syntax
C#
namespace Sitecore.Data.Fields
Types
All Types Classes
Icon | Type | Description
 | CheckboxField | Represents a Checkbox field.
 | CustomCustomField | Defines the custom custom field class.
 | CustomField | Defines the basic functionality of a custom field.
 | DateField | Represents a Date field.
 | DelimitedField | Defines the basic functionality of a field type where the value is a delimited string.
 | Field | Represents a field in an Item.
 | FieldComparer | Field comparer
 | FieldType | Represents a FieldType.
 | FieldTypeManager | Represents the Field Type Manager.
 | FileField | Represents an Image field.
 | GroupedDroplinkField | Represents a Group Droplink field.
 | GroupedDroplistField | Represents a Lookup field.
 | HtmlField | Represents an Html field.
 | ImageField | Represents an Image field.
 | InternalLinkField | Represents a Link field.
 | ItemEventHandler | Represents an item event handler.
 | LayoutField | Represents a Layout field.
 | LinkField | Represents a Link field.
 | LockField | Represents the Lock field.
 | LookupField | Represents a Lookup field.
 | MediaPath | Represents a Media Path field.
 | MultilistField | Represents a MultiList field.
 | PropertyField | Represents a Property field.
 | ReferenceField | Represents a Link field.
 | RendererField | Represents the Renderer field.
 | TemplateFieldSourceField | Represents a Link field.
 | TextField | Represents a Date field.
 | ValueLookupField | Represents a Lookup field.
 | WebEditButton | Represents a WebEditButton.
 | XmlField | Defines the basic functionality of a field where the value is an XML document.


CheckboxField Class

CheckboxField Class
Namespaces ► Sitecore.Data.Fields ► CheckboxField
Represents a Checkbox field.
Declaration Syntax
C#
public class CheckboxField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckboxField(Field) | Creates a new CheckboxField instance.
 | Checked | Gets or sets a value indicating whether this CheckboxField is checked.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a CheckboxField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from CustomField.)
 | RemoveLink(ItemLink) | Removes the link. (Inherited from CustomField.)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from CustomField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Inherited from CustomField.)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | CheckboxField


CheckboxField Constructor (innerField)

CheckboxField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► CheckboxField ► CheckboxField(Field)
Creates a new CheckboxField instance.
Declaration Syntax
C#
public CheckboxField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


Checked Property

Checked Property
Namespaces ► Sitecore.Data.Fields ► CheckboxField ► Checked
Gets or sets a value indicating whether this CheckboxField is checked.
Declaration Syntax
C#
public bool Checked { get; set; }
Value
true if checked; otherwise, false.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► CheckboxField ► Implicit(Field)
Converts a Field to a CheckboxField.
Declaration Syntax
C#
public static implicit operator CheckboxField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


CustomCustomField Class

CustomCustomField Class
Namespaces ► Sitecore.Data.Fields ► CustomCustomField
Defines the custom custom field class.
Declaration Syntax
C#
public class CustomCustomField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomCustomField(Field) | Initializes a new instance of the CustomCustomField class. Creates a new LinkField instance.
 | CustomCustomField(Field, String) | Initializes a new instance of the CustomCustomField class.
 | Database | Gets the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a LinkField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField.Relink(ItemLink, Item).)
 | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField.RemoveLink(ItemLink).)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Overrides CustomField.UpdateLink(ItemLink).)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Overrides CustomField.ValidateLinks(LinksValidationResult).)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | CustomCustomField


CustomCustomField Constructor

CustomCustomField Constructor
Namespaces ► Sitecore.Data.Fields ► CustomCustomField ► CustomCustomField()()()
Members
Icon | Member | Description
 | CustomCustomField(Field) | Initializes a new instance of the CustomCustomField class. Creates a new LinkField instance.
 | CustomCustomField(Field, String) | Initializes a new instance of the CustomCustomField class.


CustomCustomField Constructor (innerField)

CustomCustomField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► CustomCustomField ► CustomCustomField(Field)
Initializes a new instance of the CustomCustomField class. Creates a new LinkField instance.
Declaration Syntax
C#
public CustomCustomField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


CustomCustomField Constructor (innerField, runtimeValue)

CustomCustomField Constructor (innerField, runtimeValue)
Namespaces ► Sitecore.Data.Fields ► CustomCustomField ► CustomCustomField(Field, String)
Initializes a new instance of the CustomCustomField class.
Declaration Syntax
C#
public CustomCustomField(
    Field innerField,
    string runtimeValue
)
Parameters
innerField (Field)
The inner field.
runtimeValue (String)
The runtime value.


Database Property

Database Property
Namespaces ► Sitecore.Data.Fields ► CustomCustomField ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► CustomCustomField ► Implicit(Field)
Converts a Field to a LinkField.
Declaration Syntax
C#
public static implicit operator CustomCustomField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


Relink Method (itemLink, newLink)

Relink Method (itemLink, newLink)
Namespaces ► Sitecore.Data.Fields ► CustomCustomField ► Relink(ItemLink, Item)
Relinks the specified item.
Declaration Syntax
C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Parameters
itemLink (ItemLink)
The item link.
newLink (Item)
The new link.


RemoveLink Method (itemLink)

RemoveLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► CustomCustomField ► RemoveLink(ItemLink)
Removes the link.
Declaration Syntax
C#
public override void RemoveLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The item link.


UpdateLink Method (itemLink)

UpdateLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► CustomCustomField ► UpdateLink(ItemLink)
Updates the link.
Declaration Syntax
C#
public override void UpdateLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The link.


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► CustomCustomField ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public override void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


CustomField Class

CustomField Class
Namespaces ► Sitecore.Data.Fields ► CustomField
Defines the basic functionality of a custom field.
Declaration Syntax
C#
public abstract class CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomField(Field) | Creates a new CustomField instance.
 | CustomField(Field, String) | Creates a new CustomField instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value.
 | GetWebEditButtons()()() | Gets the web edit buttons.
 | GetWebEditButtons(Field) | Gets the web edit buttons. This static overload used for Fields which type is not listed in FieldTypes.config.
 | InnerField | Gets the inner field.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item.
 | RemoveLink(ItemLink) | Removes the link.
 | SetValue(String) | Sets the value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link.
 | ValidateLinks(LinksValidationResult) | Validates the links.
 | Value | Gets or sets the field value.
Inheritance Hierarchy
Object
 | CustomField
 |  | CheckboxField
 |  | CustomCustomField
 |  | DateField
 |  | DelimitedField
 |  | HtmlField
 |  | InternalLinkField
 |  | LayoutField
 |  | LockField
 |  | LookupField
 |  | MediaPath
 |  | PropertyField
 |  | ReferenceField
 |  | RendererField
 |  | TextField
 |  | ValueLookupField
 |  | XmlField
 |  | ScheduleField


CustomField Constructor

CustomField Constructor
Namespaces ► Sitecore.Data.Fields ► CustomField ► CustomField()()()
Members
Icon | Member | Description
 | CustomField(Field) | Creates a new CustomField instance.
 | CustomField(Field, String) | Creates a new CustomField instance.


CustomField Constructor (innerField)

CustomField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► CustomField ► CustomField(Field)
Creates a new CustomField instance.
Declaration Syntax
C#
protected CustomField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


CustomField Constructor (innerField, runtimeValue)

CustomField Constructor (innerField, runtimeValue)
Namespaces ► Sitecore.Data.Fields ► CustomField ► CustomField(Field, String)
Creates a new CustomField instance.
Declaration Syntax
C#
protected CustomField(
    Field innerField,
    string runtimeValue
)
Parameters
innerField (Field)
Inner field.
runtimeValue (String)


GetValue Method

GetValue Method
Namespaces ► Sitecore.Data.Fields ► CustomField ► GetValue()()()
Gets the value.
Declaration Syntax
C#
protected virtual string GetValue()
Return Value
The value.


GetWebEditButtons Method

GetWebEditButtons Method
Namespaces ► Sitecore.Data.Fields ► CustomField ► GetWebEditButtons()()()
Members
Icon | Member | Description
 | GetWebEditButtons()()() | Gets the web edit buttons.
 | GetWebEditButtons(Field) | Gets the web edit buttons. This static overload used for Fields which type is not listed in FieldTypes.config.


GetWebEditButtons Method

GetWebEditButtons Method
Namespaces ► Sitecore.Data.Fields ► CustomField ► GetWebEditButtons()()()
Gets the web edit buttons.
Declaration Syntax
C#
public virtual List<WebEditButton> GetWebEditButtons()
Return Value
The web edit buttons.


GetWebEditButtons Method (field)

GetWebEditButtons Method (field)
Namespaces ► Sitecore.Data.Fields ► CustomField ► GetWebEditButtons(Field)
Gets the web edit buttons. This static overload used for Fields which type is not listed in FieldTypes.config.
Declaration Syntax
C#
public static List<WebEditButton> GetWebEditButtons(
    Field field
)
Parameters
field (Field)
The field.
Return Value
The web edit buttons.


InnerField Property

InnerField Property
Namespaces ► Sitecore.Data.Fields ► CustomField ► InnerField
Gets the inner field.
Declaration Syntax
C#
public Field InnerField { get; }
Value
The inner field.
Remarks
The Inner Field propertu points to the original Field that is being wrapped by this class.


Relink Method (item, newLink)

Relink Method (item, newLink)
Namespaces ► Sitecore.Data.Fields ► CustomField ► Relink(ItemLink, Item)
Relinks the specified item.
Declaration Syntax
C#
public virtual void Relink(
    ItemLink item,
    Item newLink
)
Parameters
item (ItemLink)
The item.
newLink (Item)
The new link.


RemoveLink Method (itemLink)

RemoveLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► CustomField ► RemoveLink(ItemLink)
Removes the link.
Declaration Syntax
C#
public virtual void RemoveLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The item link.


SetValue Method (value)

SetValue Method (value)
Namespaces ► Sitecore.Data.Fields ► CustomField ► SetValue(String)
Sets the value.
Declaration Syntax
C#
protected virtual void SetValue(
    string value
)
Parameters
value (String)
The value.


UpdateLink Method (itemLink)

UpdateLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► CustomField ► UpdateLink(ItemLink)
Updates the link.
Declaration Syntax
C#
public virtual void UpdateLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The link.


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► CustomField ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public virtual void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


Value Property

Value Property
Namespaces ► Sitecore.Data.Fields ► CustomField ► Value
Gets or sets the field value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.


DateField Class

DateField Class
Namespaces ► Sitecore.Data.Fields ► DateField
Represents a Date field.
Declaration Syntax
C#
public class DateField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DateField(Field) | Creates a new DateField instance.
 | DateTime | Gets the value as a DateTime.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a DateField
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from CustomField.)
 | RemoveLink(ItemLink) | Removes the link. (Inherited from CustomField.)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | ToString()()() | Formats the value as a string. (Overrides Object.ToString()()().)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from CustomField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Inherited from CustomField.)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | DateField


DateField Constructor (innerField)

DateField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► DateField ► DateField(Field)
Creates a new DateField instance.
Declaration Syntax
C#
public DateField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


DateTime Property

DateTime Property
Namespaces ► Sitecore.Data.Fields ► DateField ► DateTime
Gets the value as a DateTime.
Declaration Syntax
C#
public DateTime DateTime { get; }
Value
The date time.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► DateField ► Implicit(Field)
Converts a Field to a DateField
Declaration Syntax
C#
public static implicit operator DateField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


ToString Method

ToString Method
Namespaces ► Sitecore.Data.Fields ► DateField ► ToString()()()
Formats the value as a string.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


DelimitedField Class

DelimitedField Class
Namespaces ► Sitecore.Data.Fields ► DelimitedField
Defines the basic functionality of a field type where the value is a delimited string.
Declaration Syntax
C#
public class DelimitedField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DelimitedField(Field, Char) | Creates a new DelimitedField instance.
 | Add(String) | Adds the specified item.
 | Add(String, Boolean) | Adds the specified item.
 | CharIndexOf(String) | Gets the index of an item in the value.
 | Contains(String) | Determines if the specified item is present in the value.
 | Count | Gets the count of items in this field.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Gets an enumerator.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a DelimitedField.
 | IndexOf(String) | Get the index of an item.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | Item[([(Int32])]) | Gets the value at the specified index.
 | Items | Gets an array of values..
 | List | Gets the value a as ListString.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(Item, Item) | Obsolete. Relinks the specified item.
 | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField.Relink(ItemLink, Item).)
 | Remove(String) | Removes the specified item.
 | RemoveLink(Item) | Obsolete. Removes the link.
 | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField.RemoveLink(ItemLink).)
 | Replace(String, String) | Replaces the specified item.
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | ToString()()() | Gets the value. (Overrides Object.ToString()()().)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from CustomField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Overrides CustomField.ValidateLinks(LinksValidationResult).)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | DelimitedField
 |  |  | MultilistField


DelimitedField Constructor (innerField, separator)

DelimitedField Constructor (innerField, separator)
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► DelimitedField(Field, Char)
Creates a new DelimitedField instance.
Declaration Syntax
C#
public DelimitedField(
    Field innerField,
    char separator
)
Parameters
innerField (Field)
Inner field.
separator (Char)
Separator.


Add Method

Add Method
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► Add()()()
Members
Icon | Member | Description
 | Add(String) | Adds the specified item.
 | Add(String, Boolean) | Adds the specified item.


Add Method (item)

Add Method (item)
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► Add(String)
Adds the specified item.
Declaration Syntax
C#
public string Add(
    string item
)
Parameters
item (String)
Item.
Return Value
The add.


Add Method (item, includeBlank)

Add Method (item, includeBlank)
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► Add(String, Boolean)
Adds the specified item.
Declaration Syntax
C#
public string Add(
    string item,
    bool includeBlank
)
Parameters
item (String)
Item.
includeBlank (Boolean)
Include blank.
Return Value
The add.


CharIndexOf Method (item)

CharIndexOf Method (item)
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► CharIndexOf(String)
Gets the index of an item in the value.
Declaration Syntax
C#
public int CharIndexOf(
    string item
)
Parameters
item (String)
Item.
Return Value
The index of.


Contains Method (item)

Contains Method (item)
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► Contains(String)
Determines if the specified item is present in the value.
Declaration Syntax
C#
public bool Contains(
    string item
)
Parameters
item (String)
Item.
Return Value
true if [contains] [the specified item]; otherwise, false.


Count Property

Count Property
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► Count
Gets the count of items in this field.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► GetEnumerator()()()
Gets an enumerator.
Declaration Syntax
C#
public IEnumerator GetEnumerator()
Return Value
The enumerator.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► Implicit(Field)
Converts a Field to a DelimitedField.
Declaration Syntax
C#
public static implicit operator DelimitedField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► IndexOf(String)
Get the index of an item.
Declaration Syntax
C#
public int IndexOf(
    string item
)
Parameters
item (String)
Item.
Return Value
The index position of the item if the item is found, or -1 if it is not.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► Item[([(Int32])])
Gets the value at the specified index.
Declaration Syntax
C#
public string this[
    int index
] { get; }
Parameters
index (Int32)


Items Property

Items Property
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► Items
Gets an array of values..
Declaration Syntax
C#
public string[] Items { get; }
Value
The items.


List Property

List Property
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► List
Gets the value a as ListString.
Declaration Syntax
C#
public ListString List { get; }
Value
The list.


Relink Method

Relink Method
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► Relink()()()
Members
Icon | Member | Description
 | Relink(Item, Item) | Obsolete. Relinks the specified item.
 | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField.Relink(ItemLink, Item).)


Relink Method (item, newLink)

Relink Method (item, newLink)
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► Relink(Item, Item)
Relinks the specified item.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Relink(ItemLink, Item) instead.")]
public void Relink(
    Item item,
    Item newLink
)
Parameters
item (Item)
The item.
newLink (Item)
The new link.


Relink Method (itemLink, newLink)

Relink Method (itemLink, newLink)
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► Relink(ItemLink, Item)
Relinks the specified item.
Declaration Syntax
C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Parameters
itemLink (ItemLink)
The item link.
newLink (Item)
The new link.


Remove Method (item)

Remove Method (item)
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► Remove(String)
Removes the specified item.
Declaration Syntax
C#
public string Remove(
    string item
)
Parameters
item (String)
Item.
Return Value
The remove.


RemoveLink Method

RemoveLink Method
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► RemoveLink()()()
Members
Icon | Member | Description
 | RemoveLink(Item) | Obsolete. Removes the link.
 | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField.RemoveLink(ItemLink).)


RemoveLink Method (item)

RemoveLink Method (item)
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► RemoveLink(Item)
Removes the link.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use RemoveLink(ItemLink) instead.")]
public void RemoveLink(
    Item item
)
Parameters
item (Item)
The item.


RemoveLink Method (itemLink)

RemoveLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► RemoveLink(ItemLink)
Removes the link.
Declaration Syntax
C#
public override void RemoveLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The item link.


Replace Method (item, with)

Replace Method (item, with)
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► Replace(String, String)
Replaces the specified item.
Declaration Syntax
C#
public string Replace(
    string item,
    string with
)
Parameters
item (String)
Item.
with (String)
With.
Return Value
The replace.


ToString Method

ToString Method
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► ToString()()()
Gets the value.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► DelimitedField ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public override void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


Field Class

Field Class
Namespaces ► Sitecore.Data.Fields ► Field
Represents a field in an Item.
Declaration Syntax
C#
public class Field : ISecurable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Field(ID, Item) | Creates a new Field instance.
 | CanRead | Gets a value indicating whether this field can be read by the current user.
 | CanWrite | Gets a value indicating whether this field can be written to.
 | Compare(Field, Field) | Compares the specified fields.
 | ContainsStandardValue | Returns a flag indicating if the current Value is a standard value (ie. it has been retrieved from the item holding the standard values rather than from the field itself).
 | Database | Gets the database.
 | Definition | Gets the definition.
 | Description | Gets the description.
 | DisplayName | Gets the display name.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBlobStream()()() | Gets the BLOB stream associated with the field.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStandardValue()()() | Gets the standard value for the field.
 | GetTemplateField()()() | Gets the template field.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniqueId()()() | Gets a unique id.
 | GetValue(Boolean) | Gets the current value of the field.
 | GetValue(Boolean, Boolean) | Gets the current value of the field.
 | HasBlobStream | Gets a value indicating whether this field instance has a value.
 | HasValue | Gets a value indicating whether this field instance has a value.
 | HelpLink | Gets the help link.
 | ID | Gets the ID.
 | InheritedValue | Gets the inherited value.
 | IsBlobField | Gets a value indicating whether this instance is a BLOB field.
 | IsModified | Gets a value indicating whether this field is modified.
 | Item | Gets the Item.
 | Key | Gets the key.
 | Language | Gets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Reset()()() | Resets the field.
 | ResetBlank | Gets a value indicating whether this Field should be reset if its value is blank.
 | Section | Gets the section name.
 | SectionSortorder | Gets the section sortorder.
 | SetBlobStream(Stream) | Sets the BLOB stream associated with the field.
 | SetValue(String, Boolean) | Sets the value of the field.
 | Shared | Gets a value indicating whether this Field is shared.
 | ShouldBeTranslated | Indicates if a field is eligable for translation.
 | Sortorder | Gets the field sortorder.
 | Source | Gets the source.
 | Style | Gets the CSS style.
 | Title | Gets the title.
 | ToolTip | Gets the tool tip.
 | ToString()()() | Gets the value of the field. (Overrides Object.ToString()()().)
 | Translatable | Indicates if a field can be translated.
 | Type | Gets the type.
 | TypeKey | Gets the type key.
 | Unversioned | Gets a value indicating whether this Field is unversioned.
 | Validation | Gets the validation regular expression.
 | ValidationText | Gets the validation text that is displayed if the Validation regular expression fails.
 | Value | Gets or sets the value.
Inheritance Hierarchy
Object
Field


Field Constructor (fieldID, ownerItem)

Field Constructor (fieldID, ownerItem)
Namespaces ► Sitecore.Data.Fields ► Field ► Field(ID, Item)
Creates a new Field instance.
Declaration Syntax
C#
public Field(
    ID fieldID,
    Item ownerItem
)
Parameters
fieldID (ID)
Field ID.
ownerItem (Item)
Owner item.
Exceptions
Exception | Condition
ArgumentNullException | fieldID or ownerItem was null.


CanRead Property

CanRead Property
Namespaces ► Sitecore.Data.Fields ► Field ► CanRead
Gets a value indicating whether this field can be read by the current user.
Declaration Syntax
C#
public bool CanRead { get; }
Value
true if this field can be read; otherwise, false.


CanWrite Property

CanWrite Property
Namespaces ► Sitecore.Data.Fields ► Field ► CanWrite
Gets a value indicating whether this field can be written to.
Declaration Syntax
C#
public bool CanWrite { get; }
Value
true if this field can be written to; otherwise, false.


Compare Method (field1, field2)

Compare Method (field1, field2)
Namespaces ► Sitecore.Data.Fields ► Field ► Compare(Field, Field)
Compares the specified fields.
Declaration Syntax
C#
public static int Compare(
    Field field1,
    Field field2
)
Parameters
field1 (Field)
Field1.
field2 (Field)
Field2.
Return Value
The compare.


ContainsStandardValue Property

ContainsStandardValue Property
Namespaces ► Sitecore.Data.Fields ► Field ► ContainsStandardValue
Returns a flag indicating if the current Value is a standard value (ie. it has been retrieved from the item holding the standard values rather than from the field itself).
Declaration Syntax
C#
public bool ContainsStandardValue { get; }
Value
true if the Field contains the standard value; otherwise, false.


Database Property

Database Property
Namespaces ► Sitecore.Data.Fields ► Field ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


Definition Property

Definition Property
Namespaces ► Sitecore.Data.Fields ► Field ► Definition
Gets the definition.
Declaration Syntax
C#
public TemplateField Definition { get; }
Value
The definition.


Description Property

Description Property
Namespaces ► Sitecore.Data.Fields ► Field ► Description
Gets the description.
Declaration Syntax
C#
public string Description { get; }
Value
The description.


DisplayName Property

DisplayName Property
Namespaces ► Sitecore.Data.Fields ► Field ► DisplayName
Gets the display name.
Declaration Syntax
C#
public string DisplayName { get; }
Value
The name of the display.


GetBlobStream Method

GetBlobStream Method
Namespaces ► Sitecore.Data.Fields ► Field ► GetBlobStream()()()
Gets the BLOB stream associated with the field.
Declaration Syntax
C#
public Stream GetBlobStream()
Return Value


GetStandardValue Method

GetStandardValue Method
Namespaces ► Sitecore.Data.Fields ► Field ► GetStandardValue()()()
Gets the standard value for the field.
Declaration Syntax
C#
public string GetStandardValue()
Return Value
The standard value for the field if it has one. Otherwise, null is returned.


GetTemplateField Method

GetTemplateField Method
Namespaces ► Sitecore.Data.Fields ► Field ► GetTemplateField()()()
Gets the template field.
Declaration Syntax
C#
public TemplateField GetTemplateField()
Return Value
The template field.


GetUniqueId Method

GetUniqueId Method
Namespaces ► Sitecore.Data.Fields ► Field ► GetUniqueId()()()
Gets a unique id.
Declaration Syntax
C#
public string GetUniqueId()
Return Value
Remarks

The id must be unique enough to be used in a global cache.

For example, an Item might implement this as Database.Name + ID.

The resulting key used by Item might therefore be typeof(Item).FullName + divider + Database.Name + ID.


GetValue Method

GetValue Method
Namespaces ► Sitecore.Data.Fields ► Field ► GetValue()()()
Members
Icon | Member | Description
 | GetValue(Boolean) | Gets the current value of the field.
 | GetValue(Boolean, Boolean) | Gets the current value of the field.


GetValue Method (allowStandardValue)

GetValue Method (allowStandardValue)
Namespaces ► Sitecore.Data.Fields ► Field ► GetValue(Boolean)
Gets the current value of the field.
Declaration Syntax
C#
public string GetValue(
    bool allowStandardValue
)
Parameters
allowStandardValue (Boolean)
Indicates if an standard value should be returned if the field itself does not contain any data.
Remarks

This is similar to calling Value with the important difference that this method supports null values.

If the field contains no data, null will be returned. Calling Value in the same case will yield Empty()()()


GetValue Method (allowStandardValue, allowDefaultValue)

GetValue Method (allowStandardValue, allowDefaultValue)
Namespaces ► Sitecore.Data.Fields ► Field ► GetValue(Boolean, Boolean)
Gets the current value of the field.
Declaration Syntax
C#
public string GetValue(
    bool allowStandardValue,
    bool allowDefaultValue
)
Parameters
allowStandardValue (Boolean)
Indicates if an standard value should be returned if the field itself does not contain any data.
allowDefaultValue (Boolean)
if set to true this instance is allow default value.
Return Value
Remarks

This is similar to calling Value with the important difference that this method supports null values.

If the field contains no data, null will be returned. Calling Value in the same case will yield Empty()()()


HasBlobStream Property

HasBlobStream Property
Namespaces ► Sitecore.Data.Fields ► Field ► HasBlobStream
Gets a value indicating whether this field instance has a value.
Declaration Syntax
C#
public bool HasBlobStream { get; }
Value
true if this instance has value; otherwise, false.


HasValue Property

HasValue Property
Namespaces ► Sitecore.Data.Fields ► Field ► HasValue
Gets a value indicating whether this field instance has a value.
Declaration Syntax
C#
public bool HasValue { get; }
Value
true if this instance has value; otherwise, false.


HelpLink Property

HelpLink Property
Namespaces ► Sitecore.Data.Fields ► Field ► HelpLink
Gets the help link.
Declaration Syntax
C#
public string HelpLink { get; }
Value
The help link.


ID Property

ID Property
Namespaces ► Sitecore.Data.Fields ► Field ► ID
Gets the ID.
Declaration Syntax
C#
public ID ID { get; }
Value
The ID.


InheritedValue Property

InheritedValue Property
Namespaces ► Sitecore.Data.Fields ► Field ► InheritedValue
Gets the inherited value.
Declaration Syntax
C#
public string InheritedValue { get; }
Value
The inherited value.
Remarks
If the field does not have a value, the value is fetched from the owning items template.


IsBlobField Property

IsBlobField Property
Namespaces ► Sitecore.Data.Fields ► Field ► IsBlobField
Gets a value indicating whether this instance is a BLOB field.
Declaration Syntax
C#
public bool IsBlobField { get; }
Value
true if this instance is a BLOB field; otherwise, false.


IsModified Property

IsModified Property
Namespaces ► Sitecore.Data.Fields ► Field ► IsModified
Gets a value indicating whether this field is modified.
Declaration Syntax
C#
public bool IsModified { get; }
Value
true if this field is modified; otherwise, false.


Item Property

Item Property
Namespaces ► Sitecore.Data.Fields ► Field ► Item
Gets the Item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


Key Property

Key Property
Namespaces ► Sitecore.Data.Fields ► Field ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


Language Property

Language Property
Namespaces ► Sitecore.Data.Fields ► Field ► Language
Gets the language.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


Name Property

Name Property
Namespaces ► Sitecore.Data.Fields ► Field ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Reset Method

Reset Method
Namespaces ► Sitecore.Data.Fields ► Field ► Reset()()()
Resets the field.
Declaration Syntax
C#
public void Reset()
Remarks
Equivalent to setting the field value to null.


ResetBlank Property

ResetBlank Property
Namespaces ► Sitecore.Data.Fields ► Field ► ResetBlank
Gets a value indicating whether this Field should be reset if its value is blank.
Declaration Syntax
C#
public bool ResetBlank { get; }
Value
true if 'reset blank' has been set on the field definition in the template; otherwise, false.
Remarks
When a field is reset, it will again reflect the default value from the template.


Section Property

Section Property
Namespaces ► Sitecore.Data.Fields ► Field ► Section
Gets the section name.
Declaration Syntax
C#
public string Section { get; }
Value
The section.


SectionSortorder Property

SectionSortorder Property
Namespaces ► Sitecore.Data.Fields ► Field ► SectionSortorder
Gets the section sortorder.
Declaration Syntax
C#
public int SectionSortorder { get; }
Value
The section sortorder.


SetBlobStream Method (stream)

SetBlobStream Method (stream)
Namespaces ► Sitecore.Data.Fields ► Field ► SetBlobStream(Stream)
Sets the BLOB stream associated with the field.
Declaration Syntax
C#
public void SetBlobStream(
    Stream stream
)
Parameters
stream (Stream)
The stream.


SetValue Method (value, force)

SetValue Method (value, force)
Namespaces ► Sitecore.Data.Fields ► Field ► SetValue(String, Boolean)
Sets the value of the field.
Declaration Syntax
C#
public void SetValue(
    string value,
    bool force
)
Parameters
value (String)
The new value of the field.
force (Boolean)
Normally, the field value will not be updated if the new value equals the old one. If force is true, then the field value will always be updated (and therefore written to the database).
Remarks

This is similar to calling Value with the important difference that this method accepts null values.

Passing null in the value parameter will indicate that the field will be physically removed from the database (rather than just being set equal to Empty()()())


Shared Property

Shared Property
Namespaces ► Sitecore.Data.Fields ► Field ► Shared
Gets a value indicating whether this Field is shared.
Declaration Syntax
C#
public bool Shared { get; }
Value
true if shared; otherwise, false.
Remarks
A shared field has the same value regardless of language and item version.


ShouldBeTranslated Property

ShouldBeTranslated Property
Namespaces ► Sitecore.Data.Fields ► Field ► ShouldBeTranslated
Indicates if a field is eligable for translation.
Declaration Syntax
C#
public bool ShouldBeTranslated { get; }
Value
true if the Field should be translated; otherwise, false.
Remarks
Most fields that are not shared should be translated. However the followed shared system fields should not be translated: Created, CreateBy, Updated, UpdatedBy, ValiedFrom, ValidTo, Lock, Revision, WorkflowState, ReminderDate, ReminderRecipents, ReminderText and HideVersion.


Sortorder Property

Sortorder Property
Namespaces ► Sitecore.Data.Fields ► Field ► Sortorder
Gets the field sortorder.
Declaration Syntax
C#
public int Sortorder { get; }
Value
The sortorder.


Source Property

Source Property
Namespaces ► Sitecore.Data.Fields ► Field ► Source
Gets the source.
Declaration Syntax
C#
public string Source { get; }
Value
The source.


Style Property

Style Property
Namespaces ► Sitecore.Data.Fields ► Field ► Style
Gets the CSS style.
Declaration Syntax
C#
public string Style { get; }
Value
The style.
Remarks
The CSS style is used in the client.


Title Property

Title Property
Namespaces ► Sitecore.Data.Fields ► Field ► Title
Gets the title.
Declaration Syntax
C#
public string Title { get; }
Value
The title.


ToolTip Property

ToolTip Property
Namespaces ► Sitecore.Data.Fields ► Field ► ToolTip
Gets the tool tip.
Declaration Syntax
C#
public string ToolTip { get; }
Value
The tool tip.


ToString Method

ToString Method
Namespaces ► Sitecore.Data.Fields ► Field ► ToString()()()
Gets the value of the field.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Translatable Property

Translatable Property
Namespaces ► Sitecore.Data.Fields ► Field ► Translatable
Indicates if a field can be translated.
Declaration Syntax
C#
public bool Translatable { get; }
Value
true if translatable; otherwise, false.
Remarks
The Field types Text, Memo, Html, Rich Text are translatable.


Type Property

Type Property
Namespaces ► Sitecore.Data.Fields ► Field ► Type
Gets the type.
Declaration Syntax
C#
public string Type { get; }
Value
The type.
Remarks
The field types are located in /sitecore/system/Field types.


TypeKey Property

TypeKey Property
Namespaces ► Sitecore.Data.Fields ► Field ► TypeKey
Gets the type key.
Declaration Syntax
C#
public string TypeKey { get; }
Value
The type key.


Unversioned Property

Unversioned Property
Namespaces ► Sitecore.Data.Fields ► Field ► Unversioned
Gets a value indicating whether this Field is unversioned.
Declaration Syntax
C#
public bool Unversioned { get; }
Value
true if unversioned; otherwise, false.


Validation Property

Validation Property
Namespaces ► Sitecore.Data.Fields ► Field ► Validation
Gets the validation regular expression.
Declaration Syntax
C#
public string Validation { get; }
Value
The validation.


ValidationText Property

ValidationText Property
Namespaces ► Sitecore.Data.Fields ► Field ► ValidationText
Gets the validation text that is displayed if the Validation regular expression fails.
Declaration Syntax
C#
public string ValidationText { get; }
Value
The validation text.


Value Property

Value Property
Namespaces ► Sitecore.Data.Fields ► Field ► Value
Gets or sets the value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.


FieldComparer Class

FieldComparer Class
Namespaces ► Sitecore.Data.Fields ► FieldComparer
Field comparer
Declaration Syntax
C#
public class FieldComparer : IComparer<Field>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FieldComparer()()() | Initializes a new instance of the FieldComparer class
 | Compare(Field, Field) | Compares the specified field1.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FieldComparer


FieldComparer Constructor

FieldComparer Constructor
Namespaces ► Sitecore.Data.Fields ► FieldComparer ► FieldComparer()()()
Initializes a new instance of the FieldComparer class
Declaration Syntax
C#
public FieldComparer()


Compare Method (field1, field2)

Compare Method (field1, field2)
Namespaces ► Sitecore.Data.Fields ► FieldComparer ► Compare(Field, Field)
Compares the specified field1.
Declaration Syntax
C#
public int Compare(
    Field field1,
    Field field2
)
Parameters
field1 (Field)
Field1.
field2 (Field)
Field2.
Return Value


FieldType Class

FieldType Class
Namespaces ► Sitecore.Data.Fields ► FieldType
Represents a FieldType.
Declaration Syntax
C#
public class FieldType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldType(XmlNode) | Initializes a new instance of the FieldType class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetField(Field) | Gets the field.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the type.
Inheritance Hierarchy
Object
FieldType


FieldType Constructor (node)

FieldType Constructor (node)
Namespaces ► Sitecore.Data.Fields ► FieldType ► FieldType(XmlNode)
Initializes a new instance of the FieldType class.
Declaration Syntax
C#
public FieldType(
    XmlNode node
)
Parameters
node (XmlNode)
The node.


GetField Method (field)

GetField Method (field)
Namespaces ► Sitecore.Data.Fields ► FieldType ► GetField(Field)
Gets the field.
Declaration Syntax
C#
public CustomField GetField(
    Field field
)
Parameters
field (Field)
Return Value
The field.


Name Property

Name Property
Namespaces ► Sitecore.Data.Fields ► FieldType ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Type Property

Type Property
Namespaces ► Sitecore.Data.Fields ► FieldType ► Type
Gets the type.
Declaration Syntax
C#
public Type Type { get; }
Value
The type.


FieldTypeManager Class

FieldTypeManager Class
Namespaces ► Sitecore.Data.Fields ► FieldTypeManager
Represents the Field Type Manager.
Declaration Syntax
C#
public static class FieldTypeManager
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Clear()()() | Clears this instance.
 | GetDefaultFieldTypeItem()()() | Gets the type of the default field.
 | GetField(Field) | Gets the field.
 | GetFieldType(String) | Gets the type of the field.
 | GetFieldTypeItem(Field) | Gets the field type item.
 | GetFieldTypeItem(String) | Gets the field type item.
 | GetTemplateFieldItem(Field) | Gets the template field item.
Inheritance Hierarchy
Object
FieldTypeManager


Clear Method

Clear Method
Namespaces ► Sitecore.Data.Fields ► FieldTypeManager ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public static void Clear()


GetDefaultFieldTypeItem Method

GetDefaultFieldTypeItem Method
Namespaces ► Sitecore.Data.Fields ► FieldTypeManager ► GetDefaultFieldTypeItem()()()
Gets the type of the default field.
Declaration Syntax
C#
public static Item GetDefaultFieldTypeItem()
Return Value
The default field type.


GetField Method (field)

GetField Method (field)
Namespaces ► Sitecore.Data.Fields ► FieldTypeManager ► GetField(Field)
Gets the field.
Declaration Syntax
C#
public static CustomField GetField(
    Field field
)
Parameters
field (Field)
The field.
Return Value
The field.


GetFieldType Method (name)

GetFieldType Method (name)
Namespaces ► Sitecore.Data.Fields ► FieldTypeManager ► GetFieldType(String)
Gets the type of the field.
Declaration Syntax
C#
public static FieldType GetFieldType(
    string name
)
Parameters
name (String)
The name.
Return Value
The FieldType.


GetFieldTypeItem Method

GetFieldTypeItem Method
Namespaces ► Sitecore.Data.Fields ► FieldTypeManager ► GetFieldTypeItem()()()
Members
Icon | Member | Description
 | GetFieldTypeItem(Field) | Gets the field type item.
 | GetFieldTypeItem(String) | Gets the field type item.


GetFieldTypeItem Method (field)

GetFieldTypeItem Method (field)
Namespaces ► Sitecore.Data.Fields ► FieldTypeManager ► GetFieldTypeItem(Field)
Gets the field type item.
Declaration Syntax
C#
public static Item GetFieldTypeItem(
    Field field
)
Parameters
field (Field)
The field.
Return Value
The field type item.


GetFieldTypeItem Method (fieldType)

GetFieldTypeItem Method (fieldType)
Namespaces ► Sitecore.Data.Fields ► FieldTypeManager ► GetFieldTypeItem(String)
Gets the field type item.
Declaration Syntax
C#
public static Item GetFieldTypeItem(
    string fieldType
)
Parameters
fieldType (String)
Type of the field.
Return Value
The field type item.


GetTemplateFieldItem Method (field)

GetTemplateFieldItem Method (field)
Namespaces ► Sitecore.Data.Fields ► FieldTypeManager ► GetTemplateFieldItem(Field)
Gets the template field item.
Declaration Syntax
C#
public static TemplateFieldItem GetTemplateFieldItem(
    Field field
)
Parameters
field (Field)
The field.
Return Value
The template field item.


FileField Class

FileField Class
Namespaces ► Sitecore.Data.Fields ► FileField
Represents an Image field.
Declaration Syntax
C#
public class FileField : XmlField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileField(Field) | Creates a new FileField instance.
 | FileField(Field, String) | Initializes a new instance of the FileField class.
 | Clear()()() | Clears this instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute(String) | Gets the attribute. (Inherited from XmlField.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a FileField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MediaDatabase | Gets or sets the database containing the the media.
 | MediaID | Gets or sets the ID of the media item.
 | MediaItem | Gets the media item.
 | MediaLanguage | Gets or sets the language of the media item to use.
 | MediaVersion | Gets or sets the version of the media item to use.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField.Relink(ItemLink, Item).)
 | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField.RemoveLink(ItemLink).)
 | Root | Gets or sets the root tag. (Inherited from XmlField.)
 | SetAttribute(String, String) | Sets the attribute. (Inherited from XmlField.)
 | SetValue(String) | Sets the value. (Inherited from XmlField.)
 | Src | Gets or sets the source path.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Overrides CustomField.UpdateLink(ItemLink).)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Overrides CustomField.ValidateLinks(LinksValidationResult).)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
 | Xml | Gets the XML document contained in this field value. (Inherited from XmlField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | XmlField
 |  |  | FileField


FileField Constructor

FileField Constructor
Namespaces ► Sitecore.Data.Fields ► FileField ► FileField()()()
Members
Icon | Member | Description
 | FileField(Field) | Creates a new FileField instance.
 | FileField(Field, String) | Initializes a new instance of the FileField class.


FileField Constructor (innerField)

FileField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► FileField ► FileField(Field)
Creates a new FileField instance.
Declaration Syntax
C#
public FileField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


FileField Constructor (innerField, runtimeValue)

FileField Constructor (innerField, runtimeValue)
Namespaces ► Sitecore.Data.Fields ► FileField ► FileField(Field, String)
Initializes a new instance of the FileField class.
Declaration Syntax
C#
public FileField(
    Field innerField,
    string runtimeValue
)
Parameters
innerField (Field)
The inner field.
runtimeValue (String)
The runtime value.


Clear Method

Clear Method
Namespaces ► Sitecore.Data.Fields ► FileField ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public void Clear()


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► FileField ► Implicit(Field)
Converts a Field to a FileField.
Declaration Syntax
C#
public static implicit operator FileField (
    Field field
)
Parameters
field (Field)
Field.
Return Value


MediaDatabase Property

MediaDatabase Property
Namespaces ► Sitecore.Data.Fields ► FileField ► MediaDatabase
Gets or sets the database containing the the media.
Declaration Syntax
C#
public Database MediaDatabase { get; set; }
Value
The media database.


MediaID Property

MediaID Property
Namespaces ► Sitecore.Data.Fields ► FileField ► MediaID
Gets or sets the ID of the media item.
Declaration Syntax
C#
public ID MediaID { get; set; }
Value
The media ID.


MediaItem Property

MediaItem Property
Namespaces ► Sitecore.Data.Fields ► FileField ► MediaItem
Gets the media item.
Declaration Syntax
C#
public Item MediaItem { get; }
Value
The media item.


MediaLanguage Property

MediaLanguage Property
Namespaces ► Sitecore.Data.Fields ► FileField ► MediaLanguage
Gets or sets the language of the media item to use.
Declaration Syntax
C#
public Language MediaLanguage { get; set; }
Value
The media language.


MediaVersion Property

MediaVersion Property
Namespaces ► Sitecore.Data.Fields ► FileField ► MediaVersion
Gets or sets the version of the media item to use.
Declaration Syntax
C#
public Version MediaVersion { get; set; }
Value
The media version.


Relink Method (itemLink, newLink)

Relink Method (itemLink, newLink)
Namespaces ► Sitecore.Data.Fields ► FileField ► Relink(ItemLink, Item)
Relinks the specified item.
Declaration Syntax
C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Parameters
itemLink (ItemLink)
The item link.
newLink (Item)
The new link.


RemoveLink Method (itemLink)

RemoveLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► FileField ► RemoveLink(ItemLink)
Removes the link.
Declaration Syntax
C#
public override void RemoveLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The item link.


Src Property

Src Property
Namespaces ► Sitecore.Data.Fields ► FileField ► Src
Gets or sets the source path.
Declaration Syntax
C#
public string Src { get; set; }
Value
The source.


UpdateLink Method (itemLink)

UpdateLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► FileField ► UpdateLink(ItemLink)
Updates the link.
Declaration Syntax
C#
public override void UpdateLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The link.


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► FileField ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public override void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


GroupedDroplinkField Class

GroupedDroplinkField Class
Namespaces ► Sitecore.Data.Fields ► GroupedDroplinkField
Represents a Group Droplink field.
Declaration Syntax
C#
public sealed class GroupedDroplinkField : LookupField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GroupedDroplinkField(Field) | Creates a new GroupedDroplinkField instance.
 | Clear()()() | Clears this instance. (Inherited from LookupField.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a GroupedDroplinkField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from LookupField.)
 | RemoveLink(ItemLink) | Removes the link. (Inherited from LookupField.)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | TargetID | Gets the target ID. (Inherited from LookupField.)
 | TargetItem | Gets the target item. (Inherited from LookupField.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from CustomField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Inherited from LookupField.)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | LookupField
 |  |  | GroupedDroplinkField


GroupedDroplinkField Constructor (innerField)

GroupedDroplinkField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► GroupedDroplinkField ► GroupedDroplinkField(Field)
Creates a new GroupedDroplinkField instance.
Declaration Syntax
C#
public GroupedDroplinkField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► GroupedDroplinkField ► Implicit(Field)
Converts a Field to a GroupedDroplinkField.
Declaration Syntax
C#
public static implicit operator GroupedDroplinkField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


GroupedDroplistField Class

GroupedDroplistField Class
Namespaces ► Sitecore.Data.Fields ► GroupedDroplistField
Represents a Lookup field.
Declaration Syntax
C#
public class GroupedDroplistField : ValueLookupField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GroupedDroplistField(Field) | Creates a new LookupField instance.
 | Clear()()() | Clears this instance. (Inherited from ValueLookupField.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a LookupField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from ValueLookupField.)
 | RemoveLink(ItemLink) | Removes the link. (Inherited from ValueLookupField.)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from ValueLookupField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Overrides ValueLookupField.ValidateLinks(LinksValidationResult).)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | ValueLookupField
 |  |  | GroupedDroplistField


GroupedDroplistField Constructor (innerField)

GroupedDroplistField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► GroupedDroplistField ► GroupedDroplistField(Field)
Creates a new LookupField instance.
Declaration Syntax
C#
public GroupedDroplistField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► GroupedDroplistField ► Implicit(Field)
Converts a Field to a LookupField.
Declaration Syntax
C#
public static implicit operator GroupedDroplistField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► GroupedDroplistField ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public override void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


HtmlField Class

HtmlField Class
Namespaces ► Sitecore.Data.Fields ► HtmlField
Represents an Html field.
Declaration Syntax
C#
public class HtmlField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlField(Field) | Creates a new HtmlField instance.
 | ConvertToXHtml(String) | Obsolete. Converts to HTML fragment to XHTML.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Overrides CustomField.GetWebEditButtons()()().)
 | Implicit(Field) | Converts a Field to a HtmlField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField.Relink(ItemLink, Item).)
 | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField.RemoveLink(ItemLink).)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | TightenRelativeImageLinks(String) | Tightens the relative image links.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from CustomField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Overrides CustomField.ValidateLinks(LinksValidationResult).)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | HtmlField


HtmlField Constructor (innerField)

HtmlField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► HtmlField ► HtmlField(Field)
Creates a new HtmlField instance.
Declaration Syntax
C#
public HtmlField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


ConvertToXHtml Method (html)

ConvertToXHtml Method (html)
Namespaces ► Sitecore.Data.Fields ► HtmlField ► ConvertToXHtml(String)
Converts to HTML fragment to XHTML.
Declaration Syntax
C#
[ObsoleteAttribute("Use XHtml.Convert() instead.")]
public static string ConvertToXHtml(
    string html
)
Parameters
html (String)
HTML.
Return Value
The to X HTML.


GetWebEditButtons Method

GetWebEditButtons Method
Namespaces ► Sitecore.Data.Fields ► HtmlField ► GetWebEditButtons()()()
Gets the web edit buttons.
Declaration Syntax
C#
public override List<WebEditButton> GetWebEditButtons()
Return Value
The web edit buttons.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► HtmlField ► Implicit(Field)
Converts a Field to a HtmlField.
Declaration Syntax
C#
public static implicit operator HtmlField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


Relink Method (itemLink, newLink)

Relink Method (itemLink, newLink)
Namespaces ► Sitecore.Data.Fields ► HtmlField ► Relink(ItemLink, Item)
Relinks the specified item.
Declaration Syntax
C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Parameters
itemLink (ItemLink)
The item link.
newLink (Item)
The new link.


RemoveLink Method (itemLink)

RemoveLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► HtmlField ► RemoveLink(ItemLink)
Removes the link.
Declaration Syntax
C#
public override void RemoveLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The item link.


TightenRelativeImageLinks Method (html)

TightenRelativeImageLinks Method (html)
Namespaces ► Sitecore.Data.Fields ► HtmlField ► TightenRelativeImageLinks(String)
Tightens the relative image links.
Declaration Syntax
C#
public static string TightenRelativeImageLinks(
    string html
)
Parameters
html (String)
The HTML.
Return Value


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► HtmlField ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public override void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


ImageField Class

ImageField Class
Namespaces ► Sitecore.Data.Fields ► ImageField
Represents an Image field.
Declaration Syntax
C#
public class ImageField : XmlField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImageField(Field) | Creates a new ImageField instance.
 | ImageField(Field, String) | Initializes a new instance of the ImageField class.
 | Alt | Gets or sets the Alt text.
 | Border | Gets or sets the Border value.
 | Class | Gets or sets the HTML class.
 | Clear()()() | Clears this instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute(String) | Gets the attribute. (Inherited from XmlField.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Height | Gets or sets the height.
 | HSpace | Gets or sets the HSpace value.
 | Implicit(Field) | Converts a Field to a ImageField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | InternalPath | Gets the internal path, if any.
 | IsInternal | Gets a value indicating whether the image is internal.
 | LinkType | Gets or sets the link type.
 | MediaDatabase | Gets or sets the database containing the the media.
 | MediaID | Gets or sets the ID of the media item.
 | MediaItem | Gets the media item.
 | MediaLanguage | Gets or sets the language of the media item to use.
 | MediaPath | Gets or sets the media path.
 | MediaVersion | Gets or sets the version of the media item to use.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField.Relink(ItemLink, Item).)
 | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField.RemoveLink(ItemLink).)
 | Root | Gets or sets the root tag. (Inherited from XmlField.)
 | SetAttribute(String, String) | Sets the attribute. (Inherited from XmlField.)
 | SetValue(String) | Sets the value. (Inherited from XmlField.)
 | Src | Gets or sets the source path.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Overrides CustomField.UpdateLink(ItemLink).)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Overrides CustomField.ValidateLinks(LinksValidationResult).)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
 | VSpace | Gets or sets the VSpace value.
 | Width | Gets or sets the width.
 | Xml | Gets the XML document contained in this field value. (Inherited from XmlField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | XmlField
 |  |  | ImageField


ImageField Constructor

ImageField Constructor
Namespaces ► Sitecore.Data.Fields ► ImageField ► ImageField()()()
Members
Icon | Member | Description
 | ImageField(Field) | Creates a new ImageField instance.
 | ImageField(Field, String) | Initializes a new instance of the ImageField class.


ImageField Constructor (innerField)

ImageField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► ImageField ► ImageField(Field)
Creates a new ImageField instance.
Declaration Syntax
C#
public ImageField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


ImageField Constructor (innerField, runtimeValue)

ImageField Constructor (innerField, runtimeValue)
Namespaces ► Sitecore.Data.Fields ► ImageField ► ImageField(Field, String)
Initializes a new instance of the ImageField class.
Declaration Syntax
C#
public ImageField(
    Field innerField,
    string runtimeValue
)
Parameters
innerField (Field)
The inner field.
runtimeValue (String)
The runtime value.


Alt Property

Alt Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► Alt
Gets or sets the Alt text.
Declaration Syntax
C#
public string Alt { get; set; }
Value
The alt.


Border Property

Border Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► Border
Gets or sets the Border value.
Declaration Syntax
C#
public string Border { get; set; }
Value
The Border value.


Class Property

Class Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► Class
Gets or sets the HTML class.
Declaration Syntax
C#
public string Class { get; set; }
Value
The class.


Clear Method

Clear Method
Namespaces ► Sitecore.Data.Fields ► ImageField ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public void Clear()


Height Property

Height Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► Height
Gets or sets the height.
Declaration Syntax
C#
public string Height { get; set; }
Value
The height.


HSpace Property

HSpace Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► HSpace
Gets or sets the HSpace value.
Declaration Syntax
C#
public string HSpace { get; set; }
Value
The HSpace value.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► ImageField ► Implicit(Field)
Converts a Field to a ImageField.
Declaration Syntax
C#
public static implicit operator ImageField (
    Field field
)
Parameters
field (Field)
Field.
Return Value


InternalPath Property

InternalPath Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► InternalPath
Gets the internal path, if any.
Declaration Syntax
C#
public string InternalPath { get; }
Value
The internal path.


IsInternal Property

IsInternal Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► IsInternal
Gets a value indicating whether the image is internal.
Declaration Syntax
C#
public bool IsInternal { get; }
Value
true if the image is internal; otherwise, false.


LinkType Property

LinkType Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► LinkType
Gets or sets the link type.
Declaration Syntax
C#
public string LinkType { get; set; }
Value
The type of the link.


MediaDatabase Property

MediaDatabase Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► MediaDatabase
Gets or sets the database containing the the media.
Declaration Syntax
C#
public Database MediaDatabase { get; set; }
Value
The media database.


MediaID Property

MediaID Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► MediaID
Gets or sets the ID of the media item.
Declaration Syntax
C#
public ID MediaID { get; set; }
Value
The media ID.


MediaItem Property

MediaItem Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► MediaItem
Gets the media item.
Declaration Syntax
C#
public Item MediaItem { get; }
Value
The media item.


MediaLanguage Property

MediaLanguage Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► MediaLanguage
Gets or sets the language of the media item to use.
Declaration Syntax
C#
public Language MediaLanguage { get; set; }
Value
The media language.


MediaPath Property

MediaPath Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► MediaPath
Gets or sets the media path.
Declaration Syntax
C#
public string MediaPath { get; set; }
Value
The media path.


MediaVersion Property

MediaVersion Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► MediaVersion
Gets or sets the version of the media item to use.
Declaration Syntax
C#
public Version MediaVersion { get; set; }
Value
The media version.


Relink Method (itemLink, newLink)

Relink Method (itemLink, newLink)
Namespaces ► Sitecore.Data.Fields ► ImageField ► Relink(ItemLink, Item)
Relinks the specified item.
Declaration Syntax
C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Parameters
itemLink (ItemLink)
The item link.
newLink (Item)
The new link.


RemoveLink Method (itemLink)

RemoveLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► ImageField ► RemoveLink(ItemLink)
Removes the link.
Declaration Syntax
C#
public override void RemoveLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The item link.


Src Property

Src Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► Src
Gets or sets the source path.
Declaration Syntax
C#
public string Src { get; set; }
Value
The source.


UpdateLink Method (itemLink)

UpdateLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► ImageField ► UpdateLink(ItemLink)
Updates the link.
Declaration Syntax
C#
public override void UpdateLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The link.


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► ImageField ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public override void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


VSpace Property

VSpace Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► VSpace
Gets or sets the VSpace value.
Declaration Syntax
C#
public string VSpace { get; set; }
Value
The VSpace value.


Width Property

Width Property
Namespaces ► Sitecore.Data.Fields ► ImageField ► Width
Gets or sets the width.
Declaration Syntax
C#
public string Width { get; set; }
Value
The width.


InternalLinkField Class

InternalLinkField Class
Namespaces ► Sitecore.Data.Fields ► InternalLinkField
Represents a Link field.
Declaration Syntax
C#
public class InternalLinkField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InternalLinkField(Field) | Creates a new LinkField instance.
 | InternalLinkField(Field, String) | Initializes a new instance of the InternalLinkField class.
 | Clear()()() | Clears this instance.
 | Database | Gets the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a LinkField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets or sets the HTML class.
 | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField.Relink(ItemLink, Item).)
 | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField.RemoveLink(ItemLink).)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | TargetID | Gets or sets the target ID.
 | TargetItem | Gets the target item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Overrides CustomField.UpdateLink(ItemLink).)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Overrides CustomField.ValidateLinks(LinksValidationResult).)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | InternalLinkField
 |  |  | TemplateFieldSourceField


InternalLinkField Constructor

InternalLinkField Constructor
Namespaces ► Sitecore.Data.Fields ► InternalLinkField ► InternalLinkField()()()
Members
Icon | Member | Description
 | InternalLinkField(Field) | Creates a new LinkField instance.
 | InternalLinkField(Field, String) | Initializes a new instance of the InternalLinkField class.


InternalLinkField Constructor (innerField)

InternalLinkField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► InternalLinkField ► InternalLinkField(Field)
Creates a new LinkField instance.
Declaration Syntax
C#
public InternalLinkField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


InternalLinkField Constructor (innerField, runtimeValue)

InternalLinkField Constructor (innerField, runtimeValue)
Namespaces ► Sitecore.Data.Fields ► InternalLinkField ► InternalLinkField(Field, String)
Initializes a new instance of the InternalLinkField class.
Declaration Syntax
C#
public InternalLinkField(
    Field innerField,
    string runtimeValue
)
Parameters
innerField (Field)
The inner field.
runtimeValue (String)
The runtime value.


Clear Method

Clear Method
Namespaces ► Sitecore.Data.Fields ► InternalLinkField ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public void Clear()


Database Property

Database Property
Namespaces ► Sitecore.Data.Fields ► InternalLinkField ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► InternalLinkField ► Implicit(Field)
Converts a Field to a LinkField.
Declaration Syntax
C#
public static implicit operator InternalLinkField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


Path Property

Path Property
Namespaces ► Sitecore.Data.Fields ► InternalLinkField ► Path
Gets or sets the HTML class.
Declaration Syntax
C#
public string Path { get; set; }
Value
The path.


Relink Method (itemLink, newLink)

Relink Method (itemLink, newLink)
Namespaces ► Sitecore.Data.Fields ► InternalLinkField ► Relink(ItemLink, Item)
Relinks the specified item.
Declaration Syntax
C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Parameters
itemLink (ItemLink)
The item link.
newLink (Item)
The new link.


RemoveLink Method (itemLink)

RemoveLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► InternalLinkField ► RemoveLink(ItemLink)
Removes the link.
Declaration Syntax
C#
public override void RemoveLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The item link.


TargetID Property

TargetID Property
Namespaces ► Sitecore.Data.Fields ► InternalLinkField ► TargetID
Gets or sets the target ID.
Declaration Syntax
C#
public ID TargetID { get; }
Value
The target ID.


TargetItem Property

TargetItem Property
Namespaces ► Sitecore.Data.Fields ► InternalLinkField ► TargetItem
Gets the target item.
Declaration Syntax
C#
public Item TargetItem { get; }
Value
The target item.


UpdateLink Method (itemLink)

UpdateLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► InternalLinkField ► UpdateLink(ItemLink)
Updates the link.
Declaration Syntax
C#
public override void UpdateLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The link.


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► InternalLinkField ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public override void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


ItemEventHandler Class

ItemEventHandler Class
Namespaces ► Sitecore.Data.Fields ► ItemEventHandler
Represents an item event handler.
Declaration Syntax
C#
public class ItemEventHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemEventHandler()()() | Initializes a new instance of the ItemEventHandler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnItemAdded(Object, EventArgs) | Called when the item has added.
 | OnItemDeleted(Object, EventArgs) | Called when the item has been deleted.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemEventHandler


ItemEventHandler Constructor

ItemEventHandler Constructor
Namespaces ► Sitecore.Data.Fields ► ItemEventHandler ► ItemEventHandler()()()
Initializes a new instance of the ItemEventHandler class
Declaration Syntax
C#
public ItemEventHandler()


OnItemAdded Method (sender, args)

OnItemAdded Method (sender, args)
Namespaces ► Sitecore.Data.Fields ► ItemEventHandler ► OnItemAdded(Object, EventArgs)
Called when the item has added.
Declaration Syntax
C#
protected void OnItemAdded(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


OnItemDeleted Method (sender, args)

OnItemDeleted Method (sender, args)
Namespaces ► Sitecore.Data.Fields ► ItemEventHandler ► OnItemDeleted(Object, EventArgs)
Called when the item has been deleted.
Declaration Syntax
C#
protected void OnItemDeleted(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


LayoutField Class

LayoutField Class
Namespaces ► Sitecore.Data.Fields ► LayoutField
Represents a Layout field.
Declaration Syntax
C#
public class LayoutField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayoutField(Field) | Creates a new LayoutField instance.
 | Data | Gets the XML data document.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtractLayoutID(XmlNode) | Extracts the layout ID.
 | ExtractReferences(XmlNode, Language, Database) | Extracts the Rendering references.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDeviceNode(DeviceItem) | Gets the device node.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLayoutID(DeviceItem) | Gets the layout ID.
 | GetReferences(DeviceItem) | Gets the Rendering references for a device.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a LayoutField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField.Relink(ItemLink, Item).)
 | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField.RemoveLink(ItemLink).)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from CustomField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Overrides CustomField.ValidateLinks(LinksValidationResult).)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | LayoutField


LayoutField Constructor (innerField)

LayoutField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► LayoutField ► LayoutField(Field)
Creates a new LayoutField instance.
Declaration Syntax
C#
public LayoutField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


Data Property

Data Property
Namespaces ► Sitecore.Data.Fields ► LayoutField ► Data
Gets the XML data document.
Declaration Syntax
C#
public XmlDocument Data { get; }
Value
The data.


ExtractLayoutID Method (deviceNode)

ExtractLayoutID Method (deviceNode)
Namespaces ► Sitecore.Data.Fields ► LayoutField ► ExtractLayoutID(XmlNode)
Extracts the layout ID.
Declaration Syntax
C#
public static ID ExtractLayoutID(
    XmlNode deviceNode
)
Parameters
deviceNode (XmlNode)
Device node.
Return Value
The layout ID.


ExtractReferences Method (deviceNode, language, database)

ExtractReferences Method (deviceNode, language, database)
Namespaces ► Sitecore.Data.Fields ► LayoutField ► ExtractReferences(XmlNode, Language, Database)
Extracts the Rendering references.
Declaration Syntax
C#
public static RenderingReference[] ExtractReferences(
    XmlNode deviceNode,
    Language language,
    Database database
)
Parameters
deviceNode (XmlNode)
Device node.
language (Language)
Language.
database (Database)
Database.
Return Value
The references.


GetDeviceNode Method (device)

GetDeviceNode Method (device)
Namespaces ► Sitecore.Data.Fields ► LayoutField ► GetDeviceNode(DeviceItem)
Gets the device node.
Declaration Syntax
C#
public XmlNode GetDeviceNode(
    DeviceItem device
)
Parameters
device (DeviceItem)
Device.
Return Value
The device node.


GetLayoutID Method (device)

GetLayoutID Method (device)
Namespaces ► Sitecore.Data.Fields ► LayoutField ► GetLayoutID(DeviceItem)
Gets the layout ID.
Declaration Syntax
C#
public ID GetLayoutID(
    DeviceItem device
)
Parameters
device (DeviceItem)
Device.
Return Value
The layout ID.


GetReferences Method (device)

GetReferences Method (device)
Namespaces ► Sitecore.Data.Fields ► LayoutField ► GetReferences(DeviceItem)
Gets the Rendering references for a device.
Declaration Syntax
C#
public RenderingReference[] GetReferences(
    DeviceItem device
)
Parameters
device (DeviceItem)
Device.
Return Value
The references.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► LayoutField ► Implicit(Field)
Converts a Field to a LayoutField.
Declaration Syntax
C#
public static implicit operator LayoutField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


Relink Method (itemLink, newLink)

Relink Method (itemLink, newLink)
Namespaces ► Sitecore.Data.Fields ► LayoutField ► Relink(ItemLink, Item)
Relinks the specified item.
Declaration Syntax
C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Parameters
itemLink (ItemLink)
The item link.
newLink (Item)
The new link.


RemoveLink Method (itemLink)

RemoveLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► LayoutField ► RemoveLink(ItemLink)
Removes the link.
Declaration Syntax
C#
public override void RemoveLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The item link.


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► LayoutField ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public override void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


LinkField Class

LinkField Class
Namespaces ► Sitecore.Data.Fields ► LinkField
Represents a Link field.
Declaration Syntax
C#
public class LinkField : XmlField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LinkField(Field) | Creates a new LinkField instance.
 | LinkField(Field, String) | Creates a new LinkField instance.
 | Anchor | Gets or sets the anchor.
 | Class | Gets or sets the HTML class.
 | Clear()()() | Clears this instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute(String) | Gets the attribute. (Inherited from XmlField.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a LinkField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | InternalPath | Gets the internal path.
 | IsInternal | Gets a value indicating whether this link is internal.
 | IsMediaLink | Gets a value indicating whether this instance is media link.
 | LinkType | Gets or sets the link type.
 | MediaPath |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | QueryString | Gets or sets the query string in internal links.
 | Relink(Item, Item) | Obsolete. Relinks the specified item.
 | Relink(ItemLink, Item) | Relinks the specified item link. (Overrides CustomField.Relink(ItemLink, Item).)
 | RemoveLink(Item) | Obsolete. Removes the link.
 | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField.RemoveLink(ItemLink).)
 | Root | Gets or sets the root tag. (Inherited from XmlField.)
 | SetAttribute(String, String) | Sets the attribute. (Inherited from XmlField.)
 | SetValue(String) | Sets the value. (Inherited from XmlField.)
 | Target | Gets or sets the HTML target.
 | TargetID | Gets or sets the target ID.
 | TargetItem | Gets the target item.
 | Text | Gets or sets the text.
 | Title | Gets or sets the title.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(Item, String, String) | Obsolete. Updates the link.
 | UpdateLink(ItemLink) | Updates the link. (Overrides CustomField.UpdateLink(ItemLink).)
 | Url | Gets or sets the URL.
 | ValidateLinks(LinksValidationResult) | Validates the links. (Overrides CustomField.ValidateLinks(LinksValidationResult).)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
 | Xml | Gets the XML document contained in this field value. (Inherited from XmlField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | XmlField
 |  |  | LinkField


LinkField Constructor

LinkField Constructor
Namespaces ► Sitecore.Data.Fields ► LinkField ► LinkField()()()
Members
Icon | Member | Description
 | LinkField(Field) | Creates a new LinkField instance.
 | LinkField(Field, String) | Creates a new LinkField instance.


LinkField Constructor (innerField)

LinkField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► LinkField ► LinkField(Field)
Creates a new LinkField instance.
Declaration Syntax
C#
public LinkField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


LinkField Constructor (innerField, runtimeValue)

LinkField Constructor (innerField, runtimeValue)
Namespaces ► Sitecore.Data.Fields ► LinkField ► LinkField(Field, String)
Creates a new LinkField instance.
Declaration Syntax
C#
public LinkField(
    Field innerField,
    string runtimeValue
)
Parameters
innerField (Field)
The inner field.
runtimeValue (String)
The runtime value.


Anchor Property

Anchor Property
Namespaces ► Sitecore.Data.Fields ► LinkField ► Anchor
Gets or sets the anchor.
Declaration Syntax
C#
public string Anchor { get; set; }
Value
The anchor.


Class Property

Class Property
Namespaces ► Sitecore.Data.Fields ► LinkField ► Class
Gets or sets the HTML class.
Declaration Syntax
C#
public string Class { get; set; }
Value
The class.


Clear Method

Clear Method
Namespaces ► Sitecore.Data.Fields ► LinkField ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public void Clear()


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► LinkField ► Implicit(Field)
Converts a Field to a LinkField.
Declaration Syntax
C#
public static implicit operator LinkField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


InternalPath Property

InternalPath Property
Namespaces ► Sitecore.Data.Fields ► LinkField ► InternalPath
Gets the internal path.
Declaration Syntax
C#
public string InternalPath { get; }
Value
The internal path.


IsInternal Property

IsInternal Property
Namespaces ► Sitecore.Data.Fields ► LinkField ► IsInternal
Gets a value indicating whether this link is internal.
Declaration Syntax
C#
public bool IsInternal { get; }
Value
true if this link is internal; otherwise, false.


IsMediaLink Property

IsMediaLink Property
Namespaces ► Sitecore.Data.Fields ► LinkField ► IsMediaLink
Gets a value indicating whether this instance is media link.
Declaration Syntax
C#
public bool IsMediaLink { get; }
Value
true if this instance is media link; otherwise, false.


LinkType Property

LinkType Property
Namespaces ► Sitecore.Data.Fields ► LinkField ► LinkType
Gets or sets the link type.
Declaration Syntax
C#
public string LinkType { get; set; }
Value
The type of the link.


MediaPath Property

MediaPath Property
Namespaces ► Sitecore.Data.Fields ► LinkField ► MediaPath
Declaration Syntax
C#
public string MediaPath { get; }
Value
The internal path.


QueryString Property

QueryString Property
Namespaces ► Sitecore.Data.Fields ► LinkField ► QueryString
Gets or sets the query string in internal links.
Declaration Syntax
C#
public string QueryString { get; set; }
Value
The query string.


Relink Method

Relink Method
Namespaces ► Sitecore.Data.Fields ► LinkField ► Relink()()()
Members
Icon | Member | Description
 | Relink(Item, Item) | Obsolete. Relinks the specified item.
 | Relink(ItemLink, Item) | Relinks the specified item link. (Overrides CustomField.Relink(ItemLink, Item).)


Relink Method (item, newLink)

Relink Method (item, newLink)
Namespaces ► Sitecore.Data.Fields ► LinkField ► Relink(Item, Item)
Relinks the specified item.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Relink(ItemLink, Item) instead.")]
public void Relink(
    Item item,
    Item newLink
)
Parameters
item (Item)
The item.
newLink (Item)
The new link.


Relink Method (itemLink, newLink)

Relink Method (itemLink, newLink)
Namespaces ► Sitecore.Data.Fields ► LinkField ► Relink(ItemLink, Item)
Relinks the specified item link.
Declaration Syntax
C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Parameters
itemLink (ItemLink)
The item link.
newLink (Item)
The new link.


RemoveLink Method

RemoveLink Method
Namespaces ► Sitecore.Data.Fields ► LinkField ► RemoveLink()()()
Members
Icon | Member | Description
 | RemoveLink(Item) | Obsolete. Removes the link.
 | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField.RemoveLink(ItemLink).)


RemoveLink Method (item)

RemoveLink Method (item)
Namespaces ► Sitecore.Data.Fields ► LinkField ► RemoveLink(Item)
Removes the link.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use RemoveLink(ItemLink) instead.")]
public void RemoveLink(
    Item item
)
Parameters
item (Item)
The item.


RemoveLink Method (itemLink)

RemoveLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► LinkField ► RemoveLink(ItemLink)
Removes the link.
Declaration Syntax
C#
public override void RemoveLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The item link.


Target Property

Target Property
Namespaces ► Sitecore.Data.Fields ► LinkField ► Target
Gets or sets the HTML target.
Declaration Syntax
C#
public string Target { get; set; }
Value
The target.


TargetID Property

TargetID Property
Namespaces ► Sitecore.Data.Fields ► LinkField ► TargetID
Gets or sets the target ID.
Declaration Syntax
C#
public ID TargetID { get; set; }
Value
The target ID.


TargetItem Property

TargetItem Property
Namespaces ► Sitecore.Data.Fields ► LinkField ► TargetItem
Gets the target item.
Declaration Syntax
C#
public Item TargetItem { get; }
Value
The target item.


Text Property

Text Property
Namespaces ► Sitecore.Data.Fields ► LinkField ► Text
Gets or sets the text.
Declaration Syntax
C#
public string Text { get; set; }
Value
The text.


Title Property

Title Property
Namespaces ► Sitecore.Data.Fields ► LinkField ► Title
Gets or sets the title.
Declaration Syntax
C#
public string Title { get; set; }
Value
The title.


UpdateLink Method

UpdateLink Method
Namespaces ► Sitecore.Data.Fields ► LinkField ► UpdateLink()()()
Members
Icon | Member | Description
 | UpdateLink(Item, String, String) | Obsolete. Updates the link.
 | UpdateLink(ItemLink) | Updates the link. (Overrides CustomField.UpdateLink(ItemLink).)


UpdateLink Method (item, oldShortPath, oldLongPath)

UpdateLink Method (item, oldShortPath, oldLongPath)
Namespaces ► Sitecore.Data.Fields ► LinkField ► UpdateLink(Item, String, String)
Updates the link.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use UpdateLink(ItemLink) instead.")]
public void UpdateLink(
    Item item,
    string oldShortPath,
    string oldLongPath
)
Parameters
item (Item)
The item.
oldShortPath (String)
The old short path.
oldLongPath (String)
The old long path.


UpdateLink Method (itemLink)

UpdateLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► LinkField ► UpdateLink(ItemLink)
Updates the link.
Declaration Syntax
C#
public override void UpdateLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The link.


Url Property

Url Property
Namespaces ► Sitecore.Data.Fields ► LinkField ► Url
Gets or sets the URL.
Declaration Syntax
C#
public string Url { get; set; }
Value
The URL.


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► LinkField ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public override void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


LockField Class

LockField Class
Namespaces ► Sitecore.Data.Fields ► LockField
Represents the Lock field.
Declaration Syntax
C#
public class LockField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LockField(Field) | Creates a new LockField instance.
 | AcquireLock()()() | Acquires the lock.
 | Date | Gets the lock date.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a LockField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Owner | Gets the owner of the lock.
 | ReleaseLock()()() | Releases the lock.
 | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from CustomField.)
 | RemoveLink(ItemLink) | Removes the link. (Inherited from CustomField.)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from CustomField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Inherited from CustomField.)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | LockField


LockField Constructor (innerField)

LockField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► LockField ► LockField(Field)
Creates a new LockField instance.
Declaration Syntax
C#
public LockField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


AcquireLock Method

AcquireLock Method
Namespaces ► Sitecore.Data.Fields ► LockField ► AcquireLock()()()
Acquires the lock.
Declaration Syntax
C#
public bool AcquireLock()
Return Value
The lock.


Date Property

Date Property
Namespaces ► Sitecore.Data.Fields ► LockField ► Date
Gets the lock date.
Declaration Syntax
C#
public DateTime Date { get; }
Value
The date.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► LockField ► Implicit(Field)
Converts a Field to a LockField.
Declaration Syntax
C#
public static implicit operator LockField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


Owner Property

Owner Property
Namespaces ► Sitecore.Data.Fields ► LockField ► Owner
Gets the owner of the lock.
Declaration Syntax
C#
public string Owner { get; }
Value
The owner.


ReleaseLock Method

ReleaseLock Method
Namespaces ► Sitecore.Data.Fields ► LockField ► ReleaseLock()()()
Releases the lock.
Declaration Syntax
C#
public bool ReleaseLock()
Return Value
The lock.


LookupField Class

LookupField Class
Namespaces ► Sitecore.Data.Fields ► LookupField
Represents a Lookup field.
Declaration Syntax
C#
public class LookupField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LookupField(Field) | Creates a new LookupField instance.
 | Clear()()() | Clears this instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a LookupField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField.Relink(ItemLink, Item).)
 | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField.RemoveLink(ItemLink).)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | TargetID | Gets the target ID.
 | TargetItem | Gets the target item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from CustomField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Overrides CustomField.ValidateLinks(LinksValidationResult).)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | LookupField
 |  |  | GroupedDroplinkField


LookupField Constructor (innerField)

LookupField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► LookupField ► LookupField(Field)
Creates a new LookupField instance.
Declaration Syntax
C#
public LookupField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


Clear Method

Clear Method
Namespaces ► Sitecore.Data.Fields ► LookupField ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public void Clear()


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► LookupField ► Implicit(Field)
Converts a Field to a LookupField.
Declaration Syntax
C#
public static implicit operator LookupField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


Relink Method (itemLink, newLink)

Relink Method (itemLink, newLink)
Namespaces ► Sitecore.Data.Fields ► LookupField ► Relink(ItemLink, Item)
Relinks the specified item.
Declaration Syntax
C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Parameters
itemLink (ItemLink)
The item link.
newLink (Item)
The new link.


RemoveLink Method (itemLink)

RemoveLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► LookupField ► RemoveLink(ItemLink)
Removes the link.
Declaration Syntax
C#
public override void RemoveLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The item link.


TargetID Property

TargetID Property
Namespaces ► Sitecore.Data.Fields ► LookupField ► TargetID
Gets the target ID.
Declaration Syntax
C#
public ID TargetID { get; }
Value
The target ID.


TargetItem Property

TargetItem Property
Namespaces ► Sitecore.Data.Fields ► LookupField ► TargetItem
Gets the target item.
Declaration Syntax
C#
public Item TargetItem { get; }
Value
The target item.


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► LookupField ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public override void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


MediaPath Class

MediaPath Class
Namespaces ► Sitecore.Data.Fields ► MediaPath
Represents a Media Path field.
Declaration Syntax
C#
public class MediaPath : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaPath(Field) | Creates a new LinkField instance.
 | Clear()()() | Clears this instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a LinkField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets or sets the HTML class.
 | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField.Relink(ItemLink, Item).)
 | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField.RemoveLink(ItemLink).)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Overrides CustomField.UpdateLink(ItemLink).)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Overrides CustomField.ValidateLinks(LinksValidationResult).)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | MediaPath


MediaPath Constructor (innerField)

MediaPath Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► MediaPath ► MediaPath(Field)
Creates a new LinkField instance.
Declaration Syntax
C#
public MediaPath(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


Clear Method

Clear Method
Namespaces ► Sitecore.Data.Fields ► MediaPath ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public void Clear()


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► MediaPath ► Implicit(Field)
Converts a Field to a LinkField.
Declaration Syntax
C#
public static implicit operator MediaPath (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


Path Property

Path Property
Namespaces ► Sitecore.Data.Fields ► MediaPath ► Path
Gets or sets the HTML class.
Declaration Syntax
C#
public string Path { get; set; }
Value
The path.


Relink Method (itemLink, newLink)

Relink Method (itemLink, newLink)
Namespaces ► Sitecore.Data.Fields ► MediaPath ► Relink(ItemLink, Item)
Relinks the specified item.
Declaration Syntax
C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Parameters
itemLink (ItemLink)
The item link.
newLink (Item)
The new link.


RemoveLink Method (itemLink)

RemoveLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► MediaPath ► RemoveLink(ItemLink)
Removes the link.
Declaration Syntax
C#
public override void RemoveLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The item link.


UpdateLink Method (itemLink)

UpdateLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► MediaPath ► UpdateLink(ItemLink)
Updates the link.
Declaration Syntax
C#
public override void UpdateLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The link.


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► MediaPath ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public override void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


MultilistField Class

MultilistField Class
Namespaces ► Sitecore.Data.Fields ► MultilistField
Represents a MultiList field.
Declaration Syntax
C#
public class MultilistField : DelimitedField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultilistField(Field) | Creates a new MultilistField instance.
 | Add(String) | Adds the specified item. (Inherited from DelimitedField.)
 | Add(String, Boolean) | Adds the specified item. (Inherited from DelimitedField.)
 | CharIndexOf(String) | Gets the index of an item in the value. (Inherited from DelimitedField.)
 | Contains(String) | Determines if the specified item is present in the value. (Inherited from DelimitedField.)
 | Count | Gets the count of items in this field. (Inherited from DelimitedField.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Gets an enumerator. (Inherited from DelimitedField.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItems()()() | Gets the items.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a MultilistField.
 | IndexOf(String) | Get the index of an item. (Inherited from DelimitedField.)
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | Item[([(Int32])]) | Gets the value at the specified index. (Inherited from DelimitedField.)
 | Items | Gets an array of values.. (Inherited from DelimitedField.)
 | List | Gets the value a as ListString. (Inherited from DelimitedField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(Item, Item) | Obsolete. Relinks the specified item. (Inherited from DelimitedField.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from DelimitedField.)
 | Remove(String) | Removes the specified item. (Inherited from DelimitedField.)
 | RemoveLink(Item) | Obsolete. Removes the link. (Inherited from DelimitedField.)
 | RemoveLink(ItemLink) | Removes the link. (Inherited from DelimitedField.)
 | Replace(String, String) | Replaces the specified item. (Inherited from DelimitedField.)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | TargetIDs | Gets the list of target IDs.
 | ToString()()() | Gets the value. (Inherited from DelimitedField.)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from CustomField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Inherited from DelimitedField.)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | DelimitedField
 |  |  | MultilistField


MultilistField Constructor (innerField)

MultilistField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► MultilistField ► MultilistField(Field)
Creates a new MultilistField instance.
Declaration Syntax
C#
public MultilistField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


GetItems Method

GetItems Method
Namespaces ► Sitecore.Data.Fields ► MultilistField ► GetItems()()()
Gets the items.
Declaration Syntax
C#
public Item[] GetItems()
Return Value
The items.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► MultilistField ► Implicit(Field)
Converts a Field to a MultilistField.
Declaration Syntax
C#
public static implicit operator MultilistField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


TargetIDs Property

TargetIDs Property
Namespaces ► Sitecore.Data.Fields ► MultilistField ► TargetIDs
Gets the list of target IDs.
Declaration Syntax
C#
public ID[] TargetIDs { get; }
Value
The target I ds.


PropertyField Class

PropertyField Class
Namespaces ► Sitecore.Data.Fields ► PropertyField
Represents a Property field.
Declaration Syntax
C#
public class PropertyField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PropertyField(Field) | Creates a new PropertyField instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a PropertyField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | Item[([(String])]) | Gets or sets the value with the specified key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from CustomField.)
 | RemoveLink(ItemLink) | Removes the link. (Inherited from CustomField.)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from CustomField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Inherited from CustomField.)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | PropertyField


PropertyField Constructor (innerField)

PropertyField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► PropertyField ► PropertyField(Field)
Creates a new PropertyField instance.
Declaration Syntax
C#
public PropertyField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► PropertyField ► Implicit(Field)
Converts a Field to a PropertyField.
Declaration Syntax
C#
public static implicit operator PropertyField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


Item Property (key)

Item Property (key)
Namespaces ► Sitecore.Data.Fields ► PropertyField ► Item[([(String])])
Gets or sets the value with the specified key.
Declaration Syntax
C#
public string this[
    string key
] { get; set; }
Parameters
key (String)
Value


ReferenceField Class

ReferenceField Class
Namespaces ► Sitecore.Data.Fields ► ReferenceField
Represents a Link field.
Declaration Syntax
C#
public class ReferenceField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReferenceField(Field) | Creates a new LinkField instance.
 | Clear()()() | Clears this instance.
 | Database | Gets the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a LinkField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets or sets the path to the target.
 | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField.Relink(ItemLink, Item).)
 | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField.RemoveLink(ItemLink).)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | TargetID | Gets or sets the target ID.
 | TargetItem | Gets the target item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Overrides CustomField.UpdateLink(ItemLink).)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Overrides CustomField.ValidateLinks(LinksValidationResult).)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | ReferenceField


ReferenceField Constructor (innerField)

ReferenceField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► ReferenceField ► ReferenceField(Field)
Creates a new LinkField instance.
Declaration Syntax
C#
public ReferenceField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


Clear Method

Clear Method
Namespaces ► Sitecore.Data.Fields ► ReferenceField ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public void Clear()


Database Property

Database Property
Namespaces ► Sitecore.Data.Fields ► ReferenceField ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► ReferenceField ► Implicit(Field)
Converts a Field to a LinkField.
Declaration Syntax
C#
public static implicit operator ReferenceField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


Path Property

Path Property
Namespaces ► Sitecore.Data.Fields ► ReferenceField ► Path
Gets or sets the path to the target.
Declaration Syntax
C#
public string Path { get; set; }
Value
The path.


Relink Method (itemLink, newLink)

Relink Method (itemLink, newLink)
Namespaces ► Sitecore.Data.Fields ► ReferenceField ► Relink(ItemLink, Item)
Relinks the specified item.
Declaration Syntax
C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Parameters
itemLink (ItemLink)
The item link.
newLink (Item)
The new link.


RemoveLink Method (itemLink)

RemoveLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► ReferenceField ► RemoveLink(ItemLink)
Removes the link.
Declaration Syntax
C#
public override void RemoveLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The item link.


TargetID Property

TargetID Property
Namespaces ► Sitecore.Data.Fields ► ReferenceField ► TargetID
Gets or sets the target ID.
Declaration Syntax
C#
public ID TargetID { get; }
Value
The target ID.


TargetItem Property

TargetItem Property
Namespaces ► Sitecore.Data.Fields ► ReferenceField ► TargetItem
Gets the target item.
Declaration Syntax
C#
public Item TargetItem { get; }
Value
The target item.


UpdateLink Method (itemLink)

UpdateLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► ReferenceField ► UpdateLink(ItemLink)
Updates the link.
Declaration Syntax
C#
public override void UpdateLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The link.


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► ReferenceField ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public override void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


RendererField Class

RendererField Class
Namespaces ► Sitecore.Data.Fields ► RendererField
Represents the Renderer field.
Declaration Syntax
C#
public class RendererField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RendererField(Field) | Creates a new RendererField instance.
 | Data | Gets the value as an XML document.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControl(String, Boolean, Item) | Gets the control.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a RendererField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from CustomField.)
 | RemoveLink(ItemLink) | Removes the link. (Inherited from CustomField.)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from CustomField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Inherited from CustomField.)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | RendererField


RendererField Constructor (innerField)

RendererField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► RendererField ► RendererField(Field)
Creates a new RendererField instance.
Declaration Syntax
C#
public RendererField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


Data Property

Data Property
Namespaces ► Sitecore.Data.Fields ► RendererField ► Data
Gets the value as an XML document.
Declaration Syntax
C#
public XmlDocument Data { get; }
Value
The data.


GetControl Method (mode, allowDefault, dataItem)

GetControl Method (mode, allowDefault, dataItem)
Namespaces ► Sitecore.Data.Fields ► RendererField ► GetControl(String, Boolean, Item)
Gets the control.
Declaration Syntax
C#
public Control GetControl(
    string mode,
    bool allowDefault,
    Item dataItem
)
Parameters
mode (String)
Mode.
allowDefault (Boolean)
Allow default.
dataItem (Item)
Data item.
Return Value
The control.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► RendererField ► Implicit(Field)
Converts a Field to a RendererField.
Declaration Syntax
C#
public static implicit operator RendererField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


TemplateFieldSourceField Class

TemplateFieldSourceField Class
Namespaces ► Sitecore.Data.Fields ► TemplateFieldSourceField
Represents a Link field.
Declaration Syntax
C#
public class TemplateFieldSourceField : InternalLinkField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateFieldSourceField(Field) | Creates a new LinkField instance.
 | Clear()()() | Clears this instance. (Inherited from InternalLinkField.)
 | Database | Gets the database. (Inherited from InternalLinkField.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a LinkField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets or sets the HTML class. (Inherited from InternalLinkField.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from InternalLinkField.)
 | RemoveLink(ItemLink) | Removes the link. (Inherited from InternalLinkField.)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | TargetID | Gets or sets the target ID. (Inherited from InternalLinkField.)
 | TargetItem | Gets the target item. (Inherited from InternalLinkField.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from InternalLinkField.)
 | ValidateImage(LinksValidationResult) | Validates the links.
 | ValidateLinks(LinksValidationResult) | Validates the links. (Overrides InternalLinkField.ValidateLinks(LinksValidationResult).)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | InternalLinkField
 |  |  | TemplateFieldSourceField


TemplateFieldSourceField Constructor (innerField)

TemplateFieldSourceField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► TemplateFieldSourceField ► TemplateFieldSourceField(Field)
Creates a new LinkField instance.
Declaration Syntax
C#
public TemplateFieldSourceField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► TemplateFieldSourceField ► Implicit(Field)
Converts a Field to a LinkField.
Declaration Syntax
C#
public static implicit operator TemplateFieldSourceField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


ValidateImage Method (result)

ValidateImage Method (result)
Namespaces ► Sitecore.Data.Fields ► TemplateFieldSourceField ► ValidateImage(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public void ValidateImage(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► TemplateFieldSourceField ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public override void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


TextField Class

TextField Class
Namespaces ► Sitecore.Data.Fields ► TextField
Represents a Date field.
Declaration Syntax
C#
public sealed class TextField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextField(Field) | Creates a new DateField instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a DateField
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from CustomField.)
 | RemoveLink(ItemLink) | Removes the link. (Inherited from CustomField.)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from CustomField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Inherited from CustomField.)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | TextField


TextField Constructor (innerField)

TextField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► TextField ► TextField(Field)
Creates a new DateField instance.
Declaration Syntax
C#
public TextField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► TextField ► Implicit(Field)
Converts a Field to a DateField
Declaration Syntax
C#
public static implicit operator TextField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


ValueLookupField Class

ValueLookupField Class
Namespaces ► Sitecore.Data.Fields ► ValueLookupField
Represents a Lookup field.
Declaration Syntax
C#
public class ValueLookupField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValueLookupField(Field) | Creates a new LookupField instance.
 | Clear()()() | Clears this instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a LookupField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField.Relink(ItemLink, Item).)
 | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField.RemoveLink(ItemLink).)
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Overrides CustomField.UpdateLink(ItemLink).)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Overrides CustomField.ValidateLinks(LinksValidationResult).)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | ValueLookupField
 |  |  | GroupedDroplistField


ValueLookupField Constructor (innerField)

ValueLookupField Constructor (innerField)
Namespaces ► Sitecore.Data.Fields ► ValueLookupField ► ValueLookupField(Field)
Creates a new LookupField instance.
Declaration Syntax
C#
public ValueLookupField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


Clear Method

Clear Method
Namespaces ► Sitecore.Data.Fields ► ValueLookupField ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public void Clear()


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► ValueLookupField ► Implicit(Field)
Converts a Field to a LookupField.
Declaration Syntax
C#
public static implicit operator ValueLookupField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


Relink Method (itemLink, newLink)

Relink Method (itemLink, newLink)
Namespaces ► Sitecore.Data.Fields ► ValueLookupField ► Relink(ItemLink, Item)
Relinks the specified item.
Declaration Syntax
C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Parameters
itemLink (ItemLink)
The item link.
newLink (Item)
The new link.


RemoveLink Method (itemLink)

RemoveLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► ValueLookupField ► RemoveLink(ItemLink)
Removes the link.
Declaration Syntax
C#
public override void RemoveLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The item link.


UpdateLink Method (itemLink)

UpdateLink Method (itemLink)
Namespaces ► Sitecore.Data.Fields ► ValueLookupField ► UpdateLink(ItemLink)
Updates the link.
Declaration Syntax
C#
public override void UpdateLink(
    ItemLink itemLink
)
Parameters
itemLink (ItemLink)
The link.


ValidateLinks Method (result)

ValidateLinks Method (result)
Namespaces ► Sitecore.Data.Fields ► ValueLookupField ► ValidateLinks(LinksValidationResult)
Validates the links.
Declaration Syntax
C#
public override void ValidateLinks(
    LinksValidationResult result
)
Parameters
result (LinksValidationResult)
The result.


WebEditButton Class

WebEditButton Class
Namespaces ► Sitecore.Data.Fields ► WebEditButton
Represents a WebEditButton.
Declaration Syntax
C#
public class WebEditButton
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WebEditButton()()() | Initializes a new instance of the WebEditButton class
 | Click | Gets or sets the click.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Header | Gets or sets the header.
 | Icon | Gets or sets the icon.
 | IsDivider | Gets or sets a value indicating whether this WebEditButton is a divider.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Tooltip | Gets or sets the tooltip.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets or sets the type.
Inheritance Hierarchy
Object
WebEditButton


WebEditButton Constructor

WebEditButton Constructor
Namespaces ► Sitecore.Data.Fields ► WebEditButton ► WebEditButton()()()
Initializes a new instance of the WebEditButton class
Declaration Syntax
C#
public WebEditButton()


Click Property

Click Property
Namespaces ► Sitecore.Data.Fields ► WebEditButton ► Click
Gets or sets the click.
Declaration Syntax
C#
public string Click { get; set; }
Value
The click.


Header Property

Header Property
Namespaces ► Sitecore.Data.Fields ► WebEditButton ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Icon Property

Icon Property
Namespaces ► Sitecore.Data.Fields ► WebEditButton ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


IsDivider Property

IsDivider Property
Namespaces ► Sitecore.Data.Fields ► WebEditButton ► IsDivider
Gets or sets a value indicating whether this WebEditButton is a divider.
Declaration Syntax
C#
public bool IsDivider { get; set; }
Value
true if divider; otherwise, false.


Tooltip Property

Tooltip Property
Namespaces ► Sitecore.Data.Fields ► WebEditButton ► Tooltip
Gets or sets the tooltip.
Declaration Syntax
C#
public string Tooltip { get; set; }
Value
The tooltip.


Type Property

Type Property
Namespaces ► Sitecore.Data.Fields ► WebEditButton ► Type
Gets or sets the type.
Declaration Syntax
C#
public string Type { get; set; }
Value
The type.


XmlField Class

XmlField Class
Namespaces ► Sitecore.Data.Fields ► XmlField
Defines the basic functionality of a field where the value is an XML document.
Declaration Syntax
C#
public class XmlField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlField(Field, String) | Creates a new XmlField instance.
 | XmlField(Field, String, String) | Initializes a new instance of the XmlField class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute(String) | Gets the attribute.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Converts a Field to a XmlField.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from CustomField.)
 | RemoveLink(ItemLink) | Removes the link. (Inherited from CustomField.)
 | Root | Gets or sets the root tag.
 | SetAttribute(String, String) | Sets the attribute.
 | SetValue(String) | Sets the value. (Overrides CustomField.SetValue(String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from CustomField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Inherited from CustomField.)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
 | Xml | Gets the XML document contained in this field value.
Inheritance Hierarchy
Object
 | CustomField
 |  | XmlField
 |  |  | FileField
 |  |  | ImageField
 |  |  | LinkField


XmlField Constructor

XmlField Constructor
Namespaces ► Sitecore.Data.Fields ► XmlField ► XmlField()()()
Members
Icon | Member | Description
 | XmlField(Field, String) | Creates a new XmlField instance.
 | XmlField(Field, String, String) | Initializes a new instance of the XmlField class.


XmlField Constructor (innerField, root)

XmlField Constructor (innerField, root)
Namespaces ► Sitecore.Data.Fields ► XmlField ► XmlField(Field, String)
Creates a new XmlField instance.
Declaration Syntax
C#
public XmlField(
    Field innerField,
    string root
)
Parameters
innerField (Field)
Inner field.
root (String)
Root tag.


XmlField Constructor (innerField, root, runtimeValue)

XmlField Constructor (innerField, root, runtimeValue)
Namespaces ► Sitecore.Data.Fields ► XmlField ► XmlField(Field, String, String)
Initializes a new instance of the XmlField class.
Declaration Syntax
C#
public XmlField(
    Field innerField,
    string root,
    string runtimeValue
)
Parameters
innerField (Field)
The inner field.
root (String)
The root.
runtimeValue (String)
The runtime value.


GetAttribute Method (name)

GetAttribute Method (name)
Namespaces ► Sitecore.Data.Fields ► XmlField ► GetAttribute(String)
Gets the attribute.
Declaration Syntax
C#
public string GetAttribute(
    string name
)
Parameters
name (String)
Name.
Return Value
The attribute.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Fields ► XmlField ► Implicit(Field)
Converts a Field to a XmlField.
Declaration Syntax
C#
public static implicit operator XmlField (
    Field field
)
Parameters
field (Field)
The field.
Return Value
The implicit operator.


Root Property

Root Property
Namespaces ► Sitecore.Data.Fields ► XmlField ► Root
Gets or sets the root tag.
Declaration Syntax
C#
public string Root { get; set; }
Value
The root.


SetAttribute Method (name, value)

SetAttribute Method (name, value)
Namespaces ► Sitecore.Data.Fields ► XmlField ► SetAttribute(String, String)
Sets the attribute.
Declaration Syntax
C#
public void SetAttribute(
    string name,
    string value
)
Parameters
name (String)
Name.
value (String)
Value.


SetValue Method (value)

SetValue Method (value)
Namespaces ► Sitecore.Data.Fields ► XmlField ► SetValue(String)
Sets the value.
Declaration Syntax
C#
protected override void SetValue(
    string value
)
Parameters
value (String)
The value.


Xml Property

Xml Property
Namespaces ► Sitecore.Data.Fields ► XmlField ► Xml
Gets the XML document contained in this field value.
Declaration Syntax
C#
public XmlDocument Xml { get; }
Value
The XML.


Sitecore.Data.IDTables Namespace

Sitecore.Data.IDTables Namespace
Namespaces ► Sitecore.Data.IDTables
Declaration Syntax
C#
namespace Sitecore.Data.IDTables
Types
All Types Classes
Icon | Type | Description
 | IDTable | Represents a table of IDs.
 | IDTableEntry | Represents an entrey in the ID table.
 | IDTableProvider | Defines the basic properties and methods of an ID table provider.


IDTable Class

IDTable Class
Namespaces ► Sitecore.Data.IDTables ► IDTable
Represents a table of IDs.
Declaration Syntax
C#
public sealed class IDTable
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(String, String, ID) | Adds the specified ID.
 | Add(String, String, ID, ID) | Adds the specified ID.
 | Add(String, String, ID, ID, String) | Adds the specified ID.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String, String) | Gets the ID.
 | GetKeys(String, ID) | Gets the keys.
 | GetNewID(String, String) | Gets the new ID.
 | GetNewID(String, String, ID) | Gets the new ID.
 | GetNewID(String, String, ID, String) | Gets the new ID.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveID(String, ID) | Removes the ID.
 | RemoveKey(String, String) | Removes the key.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
IDTable


Add Method

Add Method
Namespaces ► Sitecore.Data.IDTables ► IDTable ► Add()()()
Members
Icon | Member | Description
 | Add(String, String, ID) | Adds the specified ID.
 | Add(String, String, ID, ID) | Adds the specified ID.
 | Add(String, String, ID, ID, String) | Adds the specified ID.


Add Method (prefix, key, id)

Add Method (prefix, key, id)
Namespaces ► Sitecore.Data.IDTables ► IDTable ► Add(String, String, ID)
Adds the specified ID.
Declaration Syntax
C#
public static IDTableEntry Add(
    string prefix,
    string key,
    ID id
)
Parameters
prefix (String)
The prefix.
key (String)
The key.
id (ID)
The id.
Return Value
The add.


Add Method (prefix, key, id, parentID)

Add Method (prefix, key, id, parentID)
Namespaces ► Sitecore.Data.IDTables ► IDTable ► Add(String, String, ID, ID)
Adds the specified ID.
Declaration Syntax
C#
public static IDTableEntry Add(
    string prefix,
    string key,
    ID id,
    ID parentID
)
Parameters
prefix (String)
The prefix.
key (String)
The key.
id (ID)
The id.
parentID (ID)
The parent ID.
Return Value
The add.


Add Method (prefix, key, id, parentID, customData)

Add Method (prefix, key, id, parentID, customData)
Namespaces ► Sitecore.Data.IDTables ► IDTable ► Add(String, String, ID, ID, String)
Adds the specified ID.
Declaration Syntax
C#
public static IDTableEntry Add(
    string prefix,
    string key,
    ID id,
    ID parentID,
    string customData
)
Parameters
prefix (String)
The prefix.
key (String)
The key.
id (ID)
The id.
parentID (ID)
The parent ID.
customData (String)
The custom data.
Return Value
The add.


GetID Method (prefix, key)

GetID Method (prefix, key)
Namespaces ► Sitecore.Data.IDTables ► IDTable ► GetID(String, String)
Gets the ID.
Declaration Syntax
C#
public static IDTableEntry GetID(
    string prefix,
    string key
)
Parameters
prefix (String)
The prefix.
key (String)
The key.
Return Value
The ID.


GetKeys Method (prefix, id)

GetKeys Method (prefix, id)
Namespaces ► Sitecore.Data.IDTables ► IDTable ► GetKeys(String, ID)
Gets the keys.
Declaration Syntax
C#
public static IDTableEntry[] GetKeys(
    string prefix,
    ID id
)
Parameters
prefix (String)
The prefix.
id (ID)
The id.
Return Value
The keys.


GetNewID Method

GetNewID Method
Namespaces ► Sitecore.Data.IDTables ► IDTable ► GetNewID()()()
Members
Icon | Member | Description
 | GetNewID(String, String) | Gets the new ID.
 | GetNewID(String, String, ID) | Gets the new ID.
 | GetNewID(String, String, ID, String) | Gets the new ID.


GetNewID Method (prefix, key)

GetNewID Method (prefix, key)
Namespaces ► Sitecore.Data.IDTables ► IDTable ► GetNewID(String, String)
Gets the new ID.
Declaration Syntax
C#
public static IDTableEntry GetNewID(
    string prefix,
    string key
)
Parameters
prefix (String)
The prefix.
key (String)
The key.
Return Value
The new ID.


GetNewID Method (prefix, key, parentID)

GetNewID Method (prefix, key, parentID)
Namespaces ► Sitecore.Data.IDTables ► IDTable ► GetNewID(String, String, ID)
Gets the new ID.
Declaration Syntax
C#
public static IDTableEntry GetNewID(
    string prefix,
    string key,
    ID parentID
)
Parameters
prefix (String)
The prefix.
key (String)
The key.
parentID (ID)
The parent ID.
Return Value
The new ID.


GetNewID Method (prefix, key, parentID, customData)

GetNewID Method (prefix, key, parentID, customData)
Namespaces ► Sitecore.Data.IDTables ► IDTable ► GetNewID(String, String, ID, String)
Gets the new ID.
Declaration Syntax
C#
public static IDTableEntry GetNewID(
    string prefix,
    string key,
    ID parentID,
    string customData
)
Parameters
prefix (String)
The prefix.
key (String)
The key.
parentID (ID)
The parent ID.
customData (String)
The custom data.
Return Value
The new ID.


RemoveID Method (prefix, id)

RemoveID Method (prefix, id)
Namespaces ► Sitecore.Data.IDTables ► IDTable ► RemoveID(String, ID)
Removes the ID.
Declaration Syntax
C#
public static void RemoveID(
    string prefix,
    ID id
)
Parameters
prefix (String)
The prefix.
id (ID)
The id.


RemoveKey Method (prefix, key)

RemoveKey Method (prefix, key)
Namespaces ► Sitecore.Data.IDTables ► IDTable ► RemoveKey(String, String)
Removes the key.
Declaration Syntax
C#
public static void RemoveKey(
    string prefix,
    string key
)
Parameters
prefix (String)
The prefix.
key (String)
The key.


IDTableEntry Class

IDTableEntry Class
Namespaces ► Sitecore.Data.IDTables ► IDTableEntry
Represents an entrey in the ID table.
Declaration Syntax
C#
public class IDTableEntry : ICacheable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IDTableEntry(String, String, ID, ID, String) | Initializes a new instance of the IDTableEntry class.
 | CustomData | Gets the custom data.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the ID.
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentID | Gets the parent ID.
 | Prefix | Gets the prefix.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
IDTableEntry


IDTableEntry Constructor (prefix, key, id, parentID, customData)

IDTableEntry Constructor (prefix, key, id, parentID, customData)
Namespaces ► Sitecore.Data.IDTables ► IDTableEntry ► IDTableEntry(String, String, ID, ID, String)
Initializes a new instance of the IDTableEntry class.
Declaration Syntax
C#
public IDTableEntry(
    string prefix,
    string key,
    ID id,
    ID parentID,
    string customData
)
Parameters
prefix (String)
The prefix.
key (String)
The key.
id (ID)
The id.
parentID (ID)
The parent ID.
customData (String)
The custom data.


CustomData Property

CustomData Property
Namespaces ► Sitecore.Data.IDTables ► IDTableEntry ► CustomData
Gets the custom data.
Declaration Syntax
C#
public string CustomData { get; }
Value
The custom data.


ID Property

ID Property
Namespaces ► Sitecore.Data.IDTables ► IDTableEntry ► ID
Gets the ID.
Declaration Syntax
C#
public ID ID { get; }
Value
The ID.


Key Property

Key Property
Namespaces ► Sitecore.Data.IDTables ► IDTableEntry ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


ParentID Property

ParentID Property
Namespaces ► Sitecore.Data.IDTables ► IDTableEntry ► ParentID
Gets the parent ID.
Declaration Syntax
C#
public ID ParentID { get; }
Value
The parent ID.


Prefix Property

Prefix Property
Namespaces ► Sitecore.Data.IDTables ► IDTableEntry ► Prefix
Gets the prefix.
Declaration Syntax
C#
public string Prefix { get; }
Value
The prefix.


IDTableProvider Class

IDTableProvider Class
Namespaces ► Sitecore.Data.IDTables ► IDTableProvider
Defines the basic properties and methods of an ID table provider.
Declaration Syntax
C#
public abstract class IDTableProvider
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IDTableProvider()()() | Initializes a new instance of the IDTableProvider class
 | Add(IDTableEntry) | Adds the specified entry.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String, String) | Gets the ID.
 | GetKeys(String, ID) | Gets the keys.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String, String) | Removes the specified prefix.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | IDTableProvider
 |  | SqlServerIDTable


IDTableProvider Constructor

IDTableProvider Constructor
Namespaces ► Sitecore.Data.IDTables ► IDTableProvider ► IDTableProvider()()()
Initializes a new instance of the IDTableProvider class
Declaration Syntax
C#
protected IDTableProvider()


Add Method (entry)

Add Method (entry)
Namespaces ► Sitecore.Data.IDTables ► IDTableProvider ► Add(IDTableEntry)
Adds the specified entry.
Declaration Syntax
C#
public abstract void Add(
    IDTableEntry entry
)
Parameters
entry (IDTableEntry)
The entry.


GetID Method (prefix, key)

GetID Method (prefix, key)
Namespaces ► Sitecore.Data.IDTables ► IDTableProvider ► GetID(String, String)
Gets the ID.
Declaration Syntax
C#
public abstract IDTableEntry GetID(
    string prefix,
    string key
)
Parameters
prefix (String)
The prefix.
key (String)
The key.
Return Value
The ID.


GetKeys Method (prefix, id)

GetKeys Method (prefix, id)
Namespaces ► Sitecore.Data.IDTables ► IDTableProvider ► GetKeys(String, ID)
Gets the keys.
Declaration Syntax
C#
public abstract IDTableEntry[] GetKeys(
    string prefix,
    ID id
)
Parameters
prefix (String)
The prefix.
id (ID)
The id.
Return Value
The keys.


Remove Method (prefix, key)

Remove Method (prefix, key)
Namespaces ► Sitecore.Data.IDTables ► IDTableProvider ► Remove(String, String)
Removes the specified prefix.
Declaration Syntax
C#
public abstract void Remove(
    string prefix,
    string key
)
Parameters
prefix (String)
The prefix.
key (String)
The key.


Sitecore.Data.Indexing Namespace

Sitecore.Data.Indexing Namespace
Namespaces ► Sitecore.Data.Indexing
Declaration Syntax
C#
namespace Sitecore.Data.Indexing
Types
All Types Classes Enumerations
Icon | Type | Description
 | Index..::.Criterion |
 | DataIndexes | Represents the indexes defined on a database
 | DebugFSDirectory | FSDirectory derivative with diagnostics capabilities
 | FSDirectory | A reimplementation of Lucene's FSDirectory fixing several bugs and increasing performance.
 | FSLock | Implements proper locking using files. The class itself is not thread-safe.
 | Index | Represents an index in a database.
 | Index..::.IndexData |
 | IndexLocker | IDisposable holder for Lucene.NET Lock objects
 | ItemEventHandler | Implements an event handler for updating indexes.
 | LockScope | Implements nesting scopes for lucene (write) locks.
 | StorageType | Defines the Lucene storage types for a field.


DataIndexes Class

DataIndexes Class
Namespaces ► Sitecore.Data.Indexing ► DataIndexes
Represents the indexes defined on a database
Declaration Syntax
C#
public class DataIndexes
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataIndexes()()() | Initializes a new instance of the DataIndexes class
 | AddIndex(Index) | Adds an index.
 | Count | Gets the number of indexes.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the Index at the specified index.
 | Item[([(String])]) | Gets the Index with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveItem(Item, Boolean) | Removes an item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateItem(Item) | Updates an item.
Inheritance Hierarchy
Object
DataIndexes


DataIndexes Constructor

DataIndexes Constructor
Namespaces ► Sitecore.Data.Indexing ► DataIndexes ► DataIndexes()()()
Initializes a new instance of the DataIndexes class
Declaration Syntax
C#
public DataIndexes()


AddIndex Method (index)

AddIndex Method (index)
Namespaces ► Sitecore.Data.Indexing ► DataIndexes ► AddIndex(Index)
Adds an index.
Declaration Syntax
C#
public void AddIndex(
    Index index
)
Parameters
index (Index)
Index.


Count Property

Count Property
Namespaces ► Sitecore.Data.Indexing ► DataIndexes ► Count
Gets the number of indexes.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


Item Property

Item Property
Namespaces ► Sitecore.Data.Indexing ► DataIndexes ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets the Index at the specified index.
 | Item[([(String])]) | Gets the Index with the specified name.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Data.Indexing ► DataIndexes ► Item[([(Int32])])
Gets the Index at the specified index.
Declaration Syntax
C#
public Index this[
    int index
] { get; }
Parameters
index (Int32)


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Data.Indexing ► DataIndexes ► Item[([(String])])
Gets the Index with the specified name.
Declaration Syntax
C#
public Index this[
    string name
] { get; }
Parameters
name (String)


RemoveItem Method (item, removeAllVersions)

RemoveItem Method (item, removeAllVersions)
Namespaces ► Sitecore.Data.Indexing ► DataIndexes ► RemoveItem(Item, Boolean)
Removes an item.
Declaration Syntax
C#
public void RemoveItem(
    Item item,
    bool removeAllVersions
)
Parameters
item (Item)
Item.
removeAllVersions (Boolean)
Remove all versions.


UpdateItem Method (item)

UpdateItem Method (item)
Namespaces ► Sitecore.Data.Indexing ► DataIndexes ► UpdateItem(Item)
Updates an item.
Declaration Syntax
C#
public void UpdateItem(
    Item item
)
Parameters
item (Item)
Item.


DebugFSDirectory Class

DebugFSDirectory Class
Namespaces ► Sitecore.Data.Indexing ► DebugFSDirectory
FSDirectory derivative with diagnostics capabilities
Declaration Syntax
C#
public class DebugFSDirectory : FSDirectory
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DebugFSDirectory()()() | Initializes a new instance of the DebugFSDirectory class
 | ClearLock(String) | (Inherited from Directory.)
 | Close()()() | (Inherited from FSDirectory.)
 | CreateOutput(String) | Creates output stream for the specified file. (Overrides FSDirectory.CreateOutput(String).)
 | Debug(String, array<Object>[]()[]) | Outputs debugging information. (Overrides FSDirectory.Debug(String, array<Object>[]()[]).)
 | DeleteFile(String) | (Inherited from FSDirectory.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileExists(String) | (Inherited from FSDirectory.)
 | FileLength(String) | (Inherited from FSDirectory.)
 | FileModified(String) | (Inherited from FSDirectory.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFile()()() | (Inherited from FSDirectory.)
 | GetFullLockName(String) | Gets the full name of the lock. (Inherited from FSDirectory.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLockFactory()()() | (Inherited from Directory.)
 | GetLockID()()() | (Inherited from FSDirectory.)
 | GetLockPrefix()()() | Gets the lock prefix. (Inherited from FSDirectory.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | KeepsLock(String) | Checks whether current thread keeps the given lock for this directory. (Inherited from FSDirectory.)
 | List()()() | (Inherited from FSDirectory.)
 | lockFactory()()() | (Inherited from Directory.)
 | MakeLock(String) | Makes a lock of a given name. (Inherited from FSDirectory.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnRetryFailed()()() | Called when the retry has failed. (Overrides FSDirectory.OnRetryFailed()()().)
 | OpenInput(String) | Opens the input. (Overrides FSDirectory.OpenInput(String).)
 | OpenInput(String, Int32) | (Inherited from FSDirectory.)
 | ReleasePendingLocks(String) | Releases locks of the given name that were obtained in the current thread. (Inherited from FSDirectory.)
 | RenameFile(String, String) | (Inherited from FSDirectory.)
 | Retry(ThreadStart) | Retries the specified callback. (Inherited from FSDirectory.)
 | SetLockFactory(LockFactory) | (Inherited from Directory.)
 | ToString()()() | (Inherited from FSDirectory.)
 | TouchFile(String) | (Inherited from FSDirectory.)
Inheritance Hierarchy
Object
 | Directory
 |  | FSDirectory
 |  |  | FSDirectory
 |  |  |  | DebugFSDirectory


DebugFSDirectory Constructor

DebugFSDirectory Constructor
Namespaces ► Sitecore.Data.Indexing ► DebugFSDirectory ► DebugFSDirectory()()()
Initializes a new instance of the DebugFSDirectory class
Declaration Syntax
C#
public DebugFSDirectory()


CreateOutput Method (name)

CreateOutput Method (name)
Namespaces ► Sitecore.Data.Indexing ► DebugFSDirectory ► CreateOutput(String)
Creates output stream for the specified file.
Declaration Syntax
C#
public override IndexOutput CreateOutput(
    string name
)
Parameters
name (String)
The name of the file.
Return Value
The output stream.


Debug Method (format, args)

Debug Method (format, args)
Namespaces ► Sitecore.Data.Indexing ► DebugFSDirectory ► Debug(String, array<Object>[]()[])
Outputs debugging information.
Declaration Syntax
C#
protected override void Debug(
    string format,
    params Object[] args
)
Parameters
format (String)
The format.
args (array< Object >[]()[])
The arguments.


OnRetryFailed Method

OnRetryFailed Method
Namespaces ► Sitecore.Data.Indexing ► DebugFSDirectory ► OnRetryFailed()()()
Called when the retry has failed.
Declaration Syntax
C#
protected override void OnRetryFailed()


OpenInput Method (name)

OpenInput Method (name)
Namespaces ► Sitecore.Data.Indexing ► DebugFSDirectory ► OpenInput(String)
Opens the input.
Declaration Syntax
C#
public override IndexInput OpenInput(
    string name
)
Parameters
name (String)
The name.
Return Value
The input.


FSDirectory Class

FSDirectory Class
Namespaces ► Sitecore.Data.Indexing ► FSDirectory
A reimplementation of Lucene's FSDirectory fixing several bugs and increasing performance.
Declaration Syntax
C#
public class FSDirectory : FSDirectory
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FSDirectory()()() | Initializes a new instance of the FSDirectory class
 | ClearLock(String) | (Inherited from Directory.)
 | Close()()() | (Inherited from FSDirectory.)
 | CreateOutput(String) | Creates output stream for the specified file. (Overrides FSDirectory.CreateOutput(String).)
 | Debug(String, array<Object>[]()[]) | Outputs debugging information.
 | DeleteFile(String) | (Inherited from FSDirectory.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileExists(String) | (Inherited from FSDirectory.)
 | FileLength(String) | (Inherited from FSDirectory.)
 | FileModified(String) | (Inherited from FSDirectory.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFile()()() | (Inherited from FSDirectory.)
 | GetFullLockName(String) | Gets the full name of the lock.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLockFactory()()() | (Inherited from Directory.)
 | GetLockID()()() | (Inherited from FSDirectory.)
 | GetLockPrefix()()() | Gets the lock prefix.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | KeepsLock(String) | Checks whether current thread keeps the given lock for this directory.
 | List()()() | (Inherited from FSDirectory.)
 | lockFactory()()() | (Inherited from Directory.)
 | MakeLock(String) | Makes a lock of a given name. (Overrides Directory.MakeLock(String).)
 | MaxRetries | Maximum number of times Sitecore will retry a file operation before reporting a failure.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnRetryFailed()()() | Called when the retry has failed.
 | OpenInput(String) | Opens the input. (Overrides FSDirectory.OpenInput(String).)
 | OpenInput(String, Int32) | (Inherited from FSDirectory.)
 | ReleasePendingLocks(String) | Releases locks of the given name that were obtained in the current thread.
 | RenameFile(String, String) | (Inherited from FSDirectory.)
 | Retry(ThreadStart) | Retries the specified callback.
 | RetryInterval | Sitecore will wait this number of milliseconds between tries.
 | SetLockFactory(LockFactory) | (Inherited from Directory.)
 | ToString()()() | (Inherited from FSDirectory.)
 | TouchFile(String) | (Inherited from FSDirectory.)
Inheritance Hierarchy
Object
 | Directory
 |  | FSDirectory
 |  |  | FSDirectory
 |  |  |  | DebugFSDirectory


FSDirectory Constructor

FSDirectory Constructor
Namespaces ► Sitecore.Data.Indexing ► FSDirectory ► FSDirectory()()()
Initializes a new instance of the FSDirectory class
Declaration Syntax
C#
public FSDirectory()


CreateOutput Method (name)

CreateOutput Method (name)
Namespaces ► Sitecore.Data.Indexing ► FSDirectory ► CreateOutput(String)
Creates output stream for the specified file.
Declaration Syntax
C#
public override IndexOutput CreateOutput(
    string name
)
Parameters
name (String)
The name of the file.
Return Value
The output stream.


Debug Method (format, args)

Debug Method (format, args)
Namespaces ► Sitecore.Data.Indexing ► FSDirectory ► Debug(String, array<Object>[]()[])
Outputs debugging information.
Declaration Syntax
C#
protected virtual void Debug(
    string format,
    params Object[] args
)
Parameters
format (String)
The format.
args (array< Object >[]()[])
The arguments.


GetFullLockName Method (name)

GetFullLockName Method (name)
Namespaces ► Sitecore.Data.Indexing ► FSDirectory ► GetFullLockName(String)
Gets the full name of the lock.
Declaration Syntax
C#
protected string GetFullLockName(
    string name
)
Parameters
name (String)
The name.
Return Value
The full lock name.


GetLockPrefix Method

GetLockPrefix Method
Namespaces ► Sitecore.Data.Indexing ► FSDirectory ► GetLockPrefix()()()
Gets the lock prefix.
Declaration Syntax
C#
protected virtual StringBuilder GetLockPrefix()
Return Value
The lock prefix.


KeepsLock Method (lockName)

KeepsLock Method (lockName)
Namespaces ► Sitecore.Data.Indexing ► FSDirectory ► KeepsLock(String)
Checks whether current thread keeps the given lock for this directory.
Declaration Syntax
C#
public bool KeepsLock(
    string lockName
)
Parameters
lockName (String)
Name of the lock.
Return Value
The lock.


MakeLock Method (name)

MakeLock Method (name)
Namespaces ► Sitecore.Data.Indexing ► FSDirectory ► MakeLock(String)
Makes a lock of a given name.
Declaration Syntax
C#
public override Lock MakeLock(
    string name
)
Parameters
name (String)
The name.
Return Value
The lock.


MaxRetries Field

MaxRetries Field
Namespaces ► Sitecore.Data.Indexing ► FSDirectory ► MaxRetries
Maximum number of times Sitecore will retry a file operation before reporting a failure.
Declaration Syntax
C#
public static int MaxRetries


OnRetryFailed Method

OnRetryFailed Method
Namespaces ► Sitecore.Data.Indexing ► FSDirectory ► OnRetryFailed()()()
Called when the retry has failed.
Declaration Syntax
C#
protected virtual void OnRetryFailed()


OpenInput Method (name)

OpenInput Method (name)
Namespaces ► Sitecore.Data.Indexing ► FSDirectory ► OpenInput(String)
Opens the input.
Declaration Syntax
C#
public override IndexInput OpenInput(
    string name
)
Parameters
name (String)
The name.
Return Value
The input.


ReleasePendingLocks Method (lockName)

ReleasePendingLocks Method (lockName)
Namespaces ► Sitecore.Data.Indexing ► FSDirectory ► ReleasePendingLocks(String)
Releases locks of the given name that were obtained in the current thread.
Declaration Syntax
C#
public void ReleasePendingLocks(
    string lockName
)
Parameters
lockName (String)
Name of the lock.


Retry Method (callback)

Retry Method (callback)
Namespaces ► Sitecore.Data.Indexing ► FSDirectory ► Retry(ThreadStart)
Retries the specified callback.
Declaration Syntax
C#
protected void Retry(
    ThreadStart callback
)
Parameters
callback (ThreadStart)
The callback.
Exceptions
Exception | Condition
IOException | IOException.


RetryInterval Field

RetryInterval Field
Namespaces ► Sitecore.Data.Indexing ► FSDirectory ► RetryInterval
Sitecore will wait this number of milliseconds between tries.
Declaration Syntax
C#
public static int RetryInterval


FSLock Class

FSLock Class
Namespaces ► Sitecore.Data.Indexing ► FSLock
Implements proper locking using files. The class itself is not thread-safe.
Declaration Syntax
C#
public class FSLock : Lock, IDisposable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FSLock(String) | Initializes a new instance of the FSLock class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | failureReason()()() | (Inherited from Lock.)
 | Finalize()()() | Releases unmanaged resources and performs other cleanup operations before the FSLock is reclaimed by garbage collection. (Overrides Object.Finalize()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsLocked()()() | Determines whether this instance is locked. (Overrides Lock.IsLocked()()().)
 | KeepsLock(String) | Checks whether the current thread holds a particular lock.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the lock.
 | Obtain()()() | Obtains the lock for this instance. (Overrides Lock.Obtain()()().)
 | Obtain(Int64) | (Inherited from Lock.)
 | Obtained | Occurs right after the lock is obtained.
 | Release()()() | Releases this instance. (Overrides Lock.Release()()().)
 | Released | Occurs right after the lock has been released.
 | ReleasePendingLocks(String) | Releases the pending locks.
 | Releasing | Occurs right before the lock gets released.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
 | Lock
 |  | FSLock


FSLock Constructor (filename)

FSLock Constructor (filename)
Namespaces ► Sitecore.Data.Indexing ► FSLock ► FSLock(String)
Initializes a new instance of the FSLock class.
Declaration Syntax
C#
public FSLock(
    string filename
)
Parameters
filename (String)
The filename to lock.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Data.Indexing ► FSLock ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


Finalize Method

Finalize Method
Namespaces ► Sitecore.Data.Indexing ► FSLock ► Finalize()()()
Releases unmanaged resources and performs other cleanup operations before the FSLock is reclaimed by garbage collection.
Declaration Syntax
C#
protected override void Finalize()


IsLocked Method

IsLocked Method
Namespaces ► Sitecore.Data.Indexing ► FSLock ► IsLocked()()()
Determines whether this instance is locked.
Declaration Syntax
C#
public override bool IsLocked()
Return Value
true if this instance is locked; otherwise, false.


KeepsLock Method (filename)

KeepsLock Method (filename)
Namespaces ► Sitecore.Data.Indexing ► FSLock ► KeepsLock(String)
Checks whether the current thread holds a particular lock.
Declaration Syntax
C#
public static bool KeepsLock(
    string filename
)
Parameters
filename (String)
Name of the lock.
Return Value
The lock.


Name Property

Name Property
Namespaces ► Sitecore.Data.Indexing ► FSLock ► Name
Gets the name of the lock.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Obtain Method

Obtain Method
Namespaces ► Sitecore.Data.Indexing ► FSLock ► Obtain()()()
Obtains the lock for this instance.
Declaration Syntax
C#
public override bool Obtain()
Return Value
The obtain.


Obtained Event

Obtained Event
Namespaces ► Sitecore.Data.Indexing ► FSLock ► Obtained
Occurs right after the lock is obtained.
Declaration Syntax
C#
public event EventHandler Obtained


Release Method

Release Method
Namespaces ► Sitecore.Data.Indexing ► FSLock ► Release()()()
Releases this instance.
Declaration Syntax
C#
public override void Release()


Released Event

Released Event
Namespaces ► Sitecore.Data.Indexing ► FSLock ► Released
Occurs right after the lock has been released.
Declaration Syntax
C#
public event EventHandler Released


ReleasePendingLocks Method (filename)

ReleasePendingLocks Method (filename)
Namespaces ► Sitecore.Data.Indexing ► FSLock ► ReleasePendingLocks(String)
Releases the pending locks.
Declaration Syntax
C#
public static void ReleasePendingLocks(
    string filename
)
Parameters
filename (String)
The filename.


Releasing Event

Releasing Event
Namespaces ► Sitecore.Data.Indexing ► FSLock ► Releasing
Occurs right before the lock gets released.
Declaration Syntax
C#
public event EventHandler Releasing


ToString Method

ToString Method
Namespaces ► Sitecore.Data.Indexing ► FSLock ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Index Class

Index Class
Namespaces ► Sitecore.Data.Indexing ► Index
Represents an index in a database.
Declaration Syntax
C#
public class Index
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Index(String) | Creates a new Index instance.
 | AddField(XmlNode) | Adds a field.
 | AddFields(Item, Document) | Adds the fields.
 | AddIndexData(ArrayList, Document) | Adds the index data.
 | AddTemplate(String) | Adds a template.
 | ContentFieldName |
 | CreateWriter(Directory, Boolean) | Creates the writer.
 | DocIDFieldName |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldIDFieldName |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDocID(ID) | Gets a doc ID.
 | GetDocID(ID, Language, Version) | Gets a doc ID.
 | GetDocID(Item, Boolean) | Gets the doc ID.
 | GetDocumentCount(Database) | Gets the document count.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIndexDirectory(Database) | Gets the file directory where the index is located.
 | GetItem(Document, Database) | Gets an item.
 | GetSearcher(Database) | Gets a IndexSearcher object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersionsToIndex(Item, Boolean) | Gets the versions to index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the index.
 | OpenReader(Database) | Opens a IndexReader.
 | OpenWriter(Database) | Opens a IndexWriter.
 | Rebuild(Database) | Rebuilds the index.
 | RebuildAsync(Database) | Rebuilds the index using a Job.
 | Reindex(Item, Boolean, Boolean) | Reindexes an item.
 | RemoveItem(ID, Database) | Removes an item.
 | RemoveItem(ID, Language, Version, Database) | Removes a specific version of an item.
 | RemoveItem(Item, Boolean) | Removes an item.
 | Reset(Database) | Resets the index.
 | Search(String, Database) | Searches the index.
 | SyncRoot | Gets an object that can be used to synchronize access to the Index.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateItem(Item) | Updates an item.
 | UpdateItem(Item, Boolean, Boolean, IndexWriter) | Updates the item.
 | UpdateVersion(Item, IndexWriter) | Updates a single version.
Remarks

Indexes are implemented using DotLucene.

Indexes are accessed through the Indexes property.

Inheritance Hierarchy
Object
Index


Index Constructor (name)

Index Constructor (name)
Namespaces ► Sitecore.Data.Indexing ► Index ► Index(String)
Creates a new Index instance.
Declaration Syntax
C#
public Index(
    string name
)
Parameters
name (String)
Name.


AddField Method (configNode)

AddField Method (configNode)
Namespaces ► Sitecore.Data.Indexing ► Index ► AddField(XmlNode)
Adds a field.
Declaration Syntax
C#
public virtual void AddField(
    XmlNode configNode
)
Parameters
configNode (XmlNode)
Config node.


AddFields Method (item, document)

AddFields Method (item, document)
Namespaces ► Sitecore.Data.Indexing ► Index ► AddFields(Item, Document)
Adds the fields.
Declaration Syntax
C#
protected virtual void AddFields(
    Item item,
    Document document
)
Parameters
item (Item)
The item.
document (Document)
The document.


AddIndexData Method (indexData, document)

AddIndexData Method (indexData, document)
Namespaces ► Sitecore.Data.Indexing ► Index ► AddIndexData(ArrayList, Document)
Adds the index data.
Declaration Syntax
C#
protected virtual void AddIndexData(
    ArrayList indexData,
    Document document
)
Parameters
indexData (ArrayList)
The index data.
document (Document)
The document.


AddTemplate Method (template)

AddTemplate Method (template)
Namespaces ► Sitecore.Data.Indexing ► Index ► AddTemplate(String)
Adds a template.
Declaration Syntax
C#
public virtual void AddTemplate(
    string template
)
Parameters
template (String)
Template.


ContentFieldName Field

ContentFieldName Field
Namespaces ► Sitecore.Data.Indexing ► Index ► ContentFieldName
Declaration Syntax
C#
public const string ContentFieldName


CreateWriter Method (folder, forceCreate)

CreateWriter Method (folder, forceCreate)
Namespaces ► Sitecore.Data.Indexing ► Index ► CreateWriter(Directory, Boolean)
Creates the writer.
Declaration Syntax
C#
protected virtual IndexWriter CreateWriter(
    Directory folder,
    bool forceCreate
)
Parameters
folder (Directory)
The folder.
forceCreate (Boolean)
if set to true this instance is force create.
Return Value
The writer.


DocIDFieldName Field

DocIDFieldName Field
Namespaces ► Sitecore.Data.Indexing ► Index ► DocIDFieldName
Declaration Syntax
C#
public const string DocIDFieldName


FieldIDFieldName Field

FieldIDFieldName Field
Namespaces ► Sitecore.Data.Indexing ► Index ► FieldIDFieldName
Declaration Syntax
C#
public const string FieldIDFieldName


GetDocID Method

GetDocID Method
Namespaces ► Sitecore.Data.Indexing ► Index ► GetDocID()()()
Members
Icon | Member | Description
 | GetDocID(ID) | Gets a doc ID.
 | GetDocID(ID, Language, Version) | Gets a doc ID.
 | GetDocID(Item, Boolean) | Gets the doc ID.


GetDocID Method (itemId)

GetDocID Method (itemId)
Namespaces ► Sitecore.Data.Indexing ► Index ► GetDocID(ID)
Gets a doc ID.
Declaration Syntax
C#
public virtual string GetDocID(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value
The doc ID.


GetDocID Method (itemId, language, version)

GetDocID Method (itemId, language, version)
Namespaces ► Sitecore.Data.Indexing ► Index ► GetDocID(ID, Language, Version)
Gets a doc ID.
Declaration Syntax
C#
public virtual string GetDocID(
    ID itemId,
    Language language,
    Version version
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
version (Version)
The version.
Return Value
The doc ID.


GetDocID Method (item, versionSpecific)

GetDocID Method (item, versionSpecific)
Namespaces ► Sitecore.Data.Indexing ► Index ► GetDocID(Item, Boolean)
Gets the doc ID.
Declaration Syntax
C#
public virtual string GetDocID(
    Item item,
    bool versionSpecific
)
Parameters
item (Item)
Item.
versionSpecific (Boolean)
Version specific.
Return Value
The doc ID.


GetDocumentCount Method (database)

GetDocumentCount Method (database)
Namespaces ► Sitecore.Data.Indexing ► Index ► GetDocumentCount(Database)
Gets the document count.
Declaration Syntax
C#
public virtual int GetDocumentCount(
    Database database
)
Parameters
database (Database)
Database.
Return Value
The document count.


GetIndexDirectory Method (database)

GetIndexDirectory Method (database)
Namespaces ► Sitecore.Data.Indexing ► Index ► GetIndexDirectory(Database)
Gets the file directory where the index is located.
Declaration Syntax
C#
public virtual Directory GetIndexDirectory(
    Database database
)
Parameters
database (Database)
Database.
Return Value
The index directory.


GetItem Method (document, database)

GetItem Method (document, database)
Namespaces ► Sitecore.Data.Indexing ► Index ► GetItem(Document, Database)
Gets an item.
Declaration Syntax
C#
public static Item GetItem(
    Document document,
    Database database
)
Parameters
document (Document)
Document.
database (Database)
Database.
Return Value
The item.


GetSearcher Method (database)

GetSearcher Method (database)
Namespaces ► Sitecore.Data.Indexing ► Index ► GetSearcher(Database)
Gets a IndexSearcher object.
Declaration Syntax
C#
public virtual IndexSearcher GetSearcher(
    Database database
)
Parameters
database (Database)
Database.
Return Value
The searcher.


GetVersionsToIndex Method (item, updateAllVersions)

GetVersionsToIndex Method (item, updateAllVersions)
Namespaces ► Sitecore.Data.Indexing ► Index ► GetVersionsToIndex(Item, Boolean)
Gets the versions to index.
Declaration Syntax
C#
protected virtual Item[] GetVersionsToIndex(
    Item item,
    bool updateAllVersions
)
Parameters
item (Item)
The item.
updateAllVersions (Boolean)
if set to true [update all versions].
Return Value


Name Property

Name Property
Namespaces ► Sitecore.Data.Indexing ► Index ► Name
Gets the name of the index.
Declaration Syntax
C#
public virtual string Name { get; }
Value
The name.


OpenReader Method (database)

OpenReader Method (database)
Namespaces ► Sitecore.Data.Indexing ► Index ► OpenReader(Database)
Opens a IndexReader.
Declaration Syntax
C#
public virtual IndexReader OpenReader(
    Database database
)
Parameters
database (Database)
Database.
Return Value
The reader.


OpenWriter Method (database)

OpenWriter Method (database)
Namespaces ► Sitecore.Data.Indexing ► Index ► OpenWriter(Database)
Opens a IndexWriter.
Declaration Syntax
C#
public virtual IndexWriter OpenWriter(
    Database database
)
Parameters
database (Database)
Database.
Return Value
The writer.


Rebuild Method (database)

Rebuild Method (database)
Namespaces ► Sitecore.Data.Indexing ► Index ► Rebuild(Database)
Rebuilds the index.
Declaration Syntax
C#
public virtual void Rebuild(
    Database database
)
Parameters
database (Database)
Database.


RebuildAsync Method (database)

RebuildAsync Method (database)
Namespaces ► Sitecore.Data.Indexing ► Index ► RebuildAsync(Database)
Rebuilds the index using a Job.
Declaration Syntax
C#
public virtual Job RebuildAsync(
    Database database
)
Parameters
database (Database)
Database.
Return Value
The async.


Reindex Method (item, deep, removeOld)

Reindex Method (item, deep, removeOld)
Namespaces ► Sitecore.Data.Indexing ► Index ► Reindex(Item, Boolean, Boolean)
Reindexes an item.
Declaration Syntax
C#
public virtual void Reindex(
    Item item,
    bool deep,
    bool removeOld
)
Parameters
item (Item)
The item to reindex.
deep (Boolean)
Include children?
removeOld (Boolean)
Remove old entries for the item before reindexing?
Remarks
All versions of the item will be reindexed.


RemoveItem Method

RemoveItem Method
Namespaces ► Sitecore.Data.Indexing ► Index ► RemoveItem()()()
Members
Icon | Member | Description
 | RemoveItem(ID, Database) | Removes an item.
 | RemoveItem(ID, Language, Version, Database) | Removes a specific version of an item.
 | RemoveItem(Item, Boolean) | Removes an item.


RemoveItem Method (itemId, database)

RemoveItem Method (itemId, database)
Namespaces ► Sitecore.Data.Indexing ► Index ► RemoveItem(ID, Database)
Removes an item.
Declaration Syntax
C#
public virtual void RemoveItem(
    ID itemId,
    Database database
)
Parameters
itemId (ID)
The item id.
database (Database)
The database.


RemoveItem Method (itemId, language, version, database)

RemoveItem Method (itemId, language, version, database)
Namespaces ► Sitecore.Data.Indexing ► Index ► RemoveItem(ID, Language, Version, Database)
Removes a specific version of an item.
Declaration Syntax
C#
public virtual void RemoveItem(
    ID itemId,
    Language language,
    Version version,
    Database database
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
version (Version)
The version.
database (Database)
The database.


RemoveItem Method (item, removeAllVersions)

RemoveItem Method (item, removeAllVersions)
Namespaces ► Sitecore.Data.Indexing ► Index ► RemoveItem(Item, Boolean)
Removes an item.
Declaration Syntax
C#
public virtual void RemoveItem(
    Item item,
    bool removeAllVersions
)
Parameters
item (Item)
Item.
removeAllVersions (Boolean)
Remove all versions.


Reset Method (database)

Reset Method (database)
Namespaces ► Sitecore.Data.Indexing ► Index ► Reset(Database)
Resets the index.
Declaration Syntax
C#
public virtual void Reset(
    Database database
)
Parameters
database (Database)
Database.


Search Method (query, database)

Search Method (query, database)
Namespaces ► Sitecore.Data.Indexing ► Index ► Search(String, Database)
Searches the index.
Declaration Syntax
C#
public virtual Hits Search(
    string query,
    Database database
)
Parameters
query (String)
Query.
database (Database)
Database.
Return Value
The search.


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Data.Indexing ► Index ► SyncRoot
Gets an object that can be used to synchronize access to the Index.
Declaration Syntax
C#
public virtual Object SyncRoot { get; }
Value
The sync root.


UpdateItem Method

UpdateItem Method
Namespaces ► Sitecore.Data.Indexing ► Index ► UpdateItem()()()
Members
Icon | Member | Description
 | UpdateItem(Item) | Updates an item.
 | UpdateItem(Item, Boolean, Boolean, IndexWriter) | Updates the item.


UpdateItem Method (item)

UpdateItem Method (item)
Namespaces ► Sitecore.Data.Indexing ► Index ► UpdateItem(Item)
Updates an item.
Declaration Syntax
C#
public virtual void UpdateItem(
    Item item
)
Parameters
item (Item)
Item.


UpdateItem Method (item, removeOld, updateAllVersions, writer)

UpdateItem Method (item, removeOld, updateAllVersions, writer)
Namespaces ► Sitecore.Data.Indexing ► Index ► UpdateItem(Item, Boolean, Boolean, IndexWriter)
Updates the item.
Declaration Syntax
C#
protected virtual void UpdateItem(
    Item item,
    bool removeOld,
    bool updateAllVersions,
    IndexWriter writer
)
Parameters
item (Item)
The item.
removeOld (Boolean)
if set to true this instance is remove old.
updateAllVersions (Boolean)
if set to true this instance is update all versions.
writer (IndexWriter)
The writer.


UpdateVersion Method (version, writer)

UpdateVersion Method (version, writer)
Namespaces ► Sitecore.Data.Indexing ► Index ► UpdateVersion(Item, IndexWriter)
Updates a single version.
Declaration Syntax
C#
protected virtual void UpdateVersion(
    Item version,
    IndexWriter writer
)
Parameters
version (Item)
The version.
writer (IndexWriter)
The writer.


Index.Criterion Class

Index..::.Criterion Class
Namespaces ► Sitecore.Data.Indexing ► Index ► Index..::.Criterion
Declaration Syntax
C#
public class Criterion
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Index..::.Criterion()()() | Initializes a new instance of the Index..::.Criterion class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exclude | Gets or sets a value indicating whether this Index..::.Criterion is exclude.
 | FieldID | Gets the field ID.
 | FieldName | Gets the name of the field.
 | FieldType | Gets the type of the field.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIndexData(Item) | Gets the index data.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseConfigNode(XmlNode) | Parses the config node.
 | StorageType | Gets or sets the type of the storage.
 | StripTags | Gets or sets a value indicating whether the Index..::.Criterion strips the tags.
 | Target | Gets or sets the target.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Index..::.Criterion


Index.Criterion Constructor

Index..::.Criterion Constructor
Namespaces ► Sitecore.Data.Indexing ► Index..::.Criterion ► Index..::.Criterion()()()
Initializes a new instance of the Index..::.Criterion class
Declaration Syntax
C#
public Criterion()


Exclude Property

Exclude Property
Namespaces ► Sitecore.Data.Indexing ► Index..::.Criterion ► Exclude
Gets or sets a value indicating whether this Index..::.Criterion is exclude.
Declaration Syntax
C#
public bool Exclude { get; set; }
Value
true if exclude; otherwise, false.


FieldID Property

FieldID Property
Namespaces ► Sitecore.Data.Indexing ► Index..::.Criterion ► FieldID
Gets the field ID.
Declaration Syntax
C#
public ID FieldID { get; }
Value
The field ID.


FieldName Property

FieldName Property
Namespaces ► Sitecore.Data.Indexing ► Index..::.Criterion ► FieldName
Gets the name of the field.
Declaration Syntax
C#
public string FieldName { get; }
Value
The name of the field.


FieldType Property

FieldType Property
Namespaces ► Sitecore.Data.Indexing ► Index..::.Criterion ► FieldType
Gets the type of the field.
Declaration Syntax
C#
public string FieldType { get; }
Value
The type of the field.


GetIndexData Method (item)

GetIndexData Method (item)
Namespaces ► Sitecore.Data.Indexing ► Index..::.Criterion ► GetIndexData(Item)
Gets the index data.
Declaration Syntax
C#
public Index..::.IndexData[] GetIndexData(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The index data.


ParseConfigNode Method (configNode)

ParseConfigNode Method (configNode)
Namespaces ► Sitecore.Data.Indexing ► Index..::.Criterion ► ParseConfigNode(XmlNode)
Parses the config node.
Declaration Syntax
C#
public static Index..::.Criterion ParseConfigNode(
    XmlNode configNode
)
Parameters
configNode (XmlNode)
The config node.
Return Value
The config node.


StorageType Property

StorageType Property
Namespaces ► Sitecore.Data.Indexing ► Index..::.Criterion ► StorageType
Gets or sets the type of the storage.
Declaration Syntax
C#
public StorageType StorageType { get; set; }
Value
The type of the storage.


StripTags Property

StripTags Property
Namespaces ► Sitecore.Data.Indexing ► Index..::.Criterion ► StripTags
Gets or sets a value indicating whether the Index..::.Criterion strips the tags.
Declaration Syntax
C#
public bool StripTags { get; set; }
Value
true if the Index..::.Criterion strips the tags; otherwise, false.


Target Property

Target Property
Namespaces ► Sitecore.Data.Indexing ► Index..::.Criterion ► Target
Gets or sets the target.
Declaration Syntax
C#
public string Target { get; set; }
Value
The target.


Index.IndexData Class

Index..::.IndexData Class
Namespaces ► Sitecore.Data.Indexing ► Index ► Index..::.IndexData
Declaration Syntax
C#
public class IndexData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Index..::.IndexData(Index..::.Criterion) | Initializes a new instance of the Index..::.IndexData class.
 | Index..::.IndexData(Index..::.Criterion, Field) | Initializes a new instance of the Index..::.IndexData class.
 | Criterion | Gets the criterion.
 | DocumentField | Gets the document field.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exclude | Gets a value indicating whether this Index..::.IndexData is exclude.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDate()()() | Gets the date.
 | GetFieldID()()() | Gets the field ID.
 | GetFieldID(Boolean) | Gets the field ID.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValueField()()() | Gets the value field.
 | GetValueField(Boolean) | Gets the value field.
 | IndexFieldType | Gets the type of the index field.
 | IsDate | Gets a value indicating whether this instance is date.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Target | Gets or sets the target.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the value.
Inheritance Hierarchy
Object
Index..::.IndexData


Index.IndexData Constructor

Index..::.IndexData Constructor
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► Index..::.IndexData()()()
Members
Icon | Member | Description
 | Index..::.IndexData(Index..::.Criterion) | Initializes a new instance of the Index..::.IndexData class.
 | Index..::.IndexData(Index..::.Criterion, Field) | Initializes a new instance of the Index..::.IndexData class.


Index.IndexData Constructor (criterion)

Index..::.IndexData Constructor (criterion)
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► Index..::.IndexData(Index..::.Criterion)
Initializes a new instance of the Index..::.IndexData class.
Declaration Syntax
C#
public IndexData(
    Index..::.Criterion criterion
)
Parameters
criterion (Index..::.Criterion)
The criterion.


Index.IndexData Constructor (criterion, field)

Index..::.IndexData Constructor (criterion, field)
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► Index..::.IndexData(Index..::.Criterion, Field)
Initializes a new instance of the Index..::.IndexData class.
Declaration Syntax
C#
public IndexData(
    Index..::.Criterion criterion,
    Field field
)
Parameters
criterion (Index..::.Criterion)
The criterion.
field (Field)
The field.


Criterion Property

Criterion Property
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► Criterion
Gets the criterion.
Declaration Syntax
C#
public Index..::.Criterion Criterion { get; }
Value
The criterion.


DocumentField Property

DocumentField Property
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► DocumentField
Gets the document field.
Declaration Syntax
C#
public string DocumentField { get; }
Value
The document field.


Exclude Property

Exclude Property
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► Exclude
Gets a value indicating whether this Index..::.IndexData is exclude.
Declaration Syntax
C#
public bool Exclude { get; }
Value
true if exclude; otherwise, false.


GetDate Method

GetDate Method
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► GetDate()()()
Gets the date.
Declaration Syntax
C#
public DateTime GetDate()
Return Value
The date.


GetFieldID Method

GetFieldID Method
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► GetFieldID()()()
Members
Icon | Member | Description
 | GetFieldID()()() | Gets the field ID.
 | GetFieldID(Boolean) | Gets the field ID.


GetFieldID Method

GetFieldID Method
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► GetFieldID()()()
Gets the field ID.
Declaration Syntax
C#
public ID GetFieldID()
Return Value
The field ID.


GetFieldID Method (ignoreTarget)

GetFieldID Method (ignoreTarget)
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► GetFieldID(Boolean)
Gets the field ID.
Declaration Syntax
C#
public ID GetFieldID(
    bool ignoreTarget
)
Parameters
ignoreTarget (Boolean)
Return Value
The field ID.


GetValueField Method

GetValueField Method
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► GetValueField()()()
Members
Icon | Member | Description
 | GetValueField()()() | Gets the value field.
 | GetValueField(Boolean) | Gets the value field.


GetValueField Method

GetValueField Method
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► GetValueField()()()
Gets the value field.
Declaration Syntax
C#
public Field GetValueField()
Return Value
The value field.


GetValueField Method (ignoreTarget)

GetValueField Method (ignoreTarget)
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► GetValueField(Boolean)
Gets the value field.
Declaration Syntax
C#
public Field GetValueField(
    bool ignoreTarget
)
Parameters
ignoreTarget (Boolean)
Return Value
The value field.


IndexFieldType Property

IndexFieldType Property
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► IndexFieldType
Gets the type of the index field.
Declaration Syntax
C#
public StorageType IndexFieldType { get; }
Value
The type of the index field.


IsDate Property

IsDate Property
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► IsDate
Gets a value indicating whether this instance is date.
Declaration Syntax
C#
public bool IsDate { get; }
Value
true if this instance is date; otherwise, false.


Target Property

Target Property
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► Target
Gets or sets the target.
Declaration Syntax
C#
public string Target { get; set; }
Value
The target.


Value Property

Value Property
Namespaces ► Sitecore.Data.Indexing ► Index..::.IndexData ► Value
Gets or sets the value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.


IndexLocker Class

IndexLocker Class
Namespaces ► Sitecore.Data.Indexing ► IndexLocker
IDisposable holder for Lucene.NET Lock objects
Declaration Syntax
C#
public class IndexLocker : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IndexLocker(Lock) | Initializes a new instance of the IndexLocker class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
IndexLocker


IndexLocker Constructor (instance)

IndexLocker Constructor (instance)
Namespaces ► Sitecore.Data.Indexing ► IndexLocker ► IndexLocker(Lock)
Initializes a new instance of the IndexLocker class.
Declaration Syntax
C#
public IndexLocker(
    Lock instance
)
Parameters
instance (Lock)
The lock instance.
Exceptions
Exception | Condition
Exception | Could not obtain lock


Dispose Method

Dispose Method
Namespaces ► Sitecore.Data.Indexing ► IndexLocker ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


ItemEventHandler Class

ItemEventHandler Class
Namespaces ► Sitecore.Data.Indexing ► ItemEventHandler
Implements an event handler for updating indexes.
Declaration Syntax
C#
public class ItemEventHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemEventHandler()()() | Initializes a new instance of the ItemEventHandler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnItemDeleted(Object, EventArgs) | Handles an ItemDeleted event.
 | OnItemSaved(Object, EventArgs) | Handles an ItemSaved event.
 | Test(Object, EventArgs) | Tests the specified sender.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemEventHandler


ItemEventHandler Constructor

ItemEventHandler Constructor
Namespaces ► Sitecore.Data.Indexing ► ItemEventHandler ► ItemEventHandler()()()
Initializes a new instance of the ItemEventHandler class
Declaration Syntax
C#
public ItemEventHandler()


OnItemDeleted Method (sender, args)

OnItemDeleted Method (sender, args)
Namespaces ► Sitecore.Data.Indexing ► ItemEventHandler ► OnItemDeleted(Object, EventArgs)
Handles an ItemDeleted event.
Declaration Syntax
C#
protected void OnItemDeleted(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
Sender.
args (EventArgs)
Args.


OnItemSaved Method (sender, args)

OnItemSaved Method (sender, args)
Namespaces ► Sitecore.Data.Indexing ► ItemEventHandler ► OnItemSaved(Object, EventArgs)
Handles an ItemSaved event.
Declaration Syntax
C#
protected void OnItemSaved(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
Sender.
args (EventArgs)
Args.


Test Method (sender, args)

Test Method (sender, args)
Namespaces ► Sitecore.Data.Indexing ► ItemEventHandler ► Test(Object, EventArgs)
Tests the specified sender.
Declaration Syntax
C#
public void Test(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


LockScope Class

LockScope Class
Namespaces ► Sitecore.Data.Indexing ► LockScope
Implements nesting scopes for lucene (write) locks.
Declaration Syntax
C#
public class LockScope : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LockScope(Directory) | Initializes a new instance of the LockScope class for write.lock.
 | LockScope(Directory, String) | Initializes a new instance of the LockScope class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LockScope


LockScope Constructor

LockScope Constructor
Namespaces ► Sitecore.Data.Indexing ► LockScope ► LockScope()()()
Members
Icon | Member | Description
 | LockScope(Directory) | Initializes a new instance of the LockScope class for write.lock.
 | LockScope(Directory, String) | Initializes a new instance of the LockScope class.


LockScope Constructor (directory)

LockScope Constructor (directory)
Namespaces ► Sitecore.Data.Indexing ► LockScope ► LockScope(Directory)
Initializes a new instance of the LockScope class for write.lock.
Declaration Syntax
C#
public LockScope(
    Directory directory
)
Parameters
directory (Directory)
The directory.


LockScope Constructor (directory, lockName)

LockScope Constructor (directory, lockName)
Namespaces ► Sitecore.Data.Indexing ► LockScope ► LockScope(Directory, String)
Initializes a new instance of the LockScope class.
Declaration Syntax
C#
public LockScope(
    Directory directory,
    string lockName
)
Parameters
directory (Directory)
The directory.
lockName (String)
Name of the lock.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Data.Indexing ► LockScope ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


StorageType Enumeration

StorageType Enumeration
Namespaces ► Sitecore.Data.Indexing ► StorageType
Defines the Lucene storage types for a field.
Declaration Syntax
C#
public enum StorageType
Members
Member | Description
Text | Text.
Keyword | Keyword.
Unstored | Unstored.
Unindexed | Unindexed.


Sitecore.Data.Items Namespace

Sitecore.Data.Items Namespace
Namespaces ► Sitecore.Data.Items
Declaration Syntax
C#
namespace Sitecore.Data.Items
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | BaseItem | Defines the basic functionality of an item.
 | BranchItem | Represents a master.
 | CoreItem..::.Builder | Builds an item.
 | ContextItemSwitcher | Switches the context item
 | CoreItem | Represents a basic item.
 | CustomItem | Implements the basic functionality of a custom item.
 | CustomItemBase | Implements the basic functionality of a custom item.
 | DeviceItem | Represents a Device item.
 | EditContext | Provides a mean to put an item in editing mode.
 | FieldChange | Represents a field change.
 | FieldChangeList | Represents a list of field changes.
 | Item | Represents an item.
 | ItemAppearance | Defines the appearance of the item.
 | ItemAxes | Provides access to other items relative to a source item.
 | ItemChanges | ItemChanges
 | Item..::.ItemDebuggerTypeProxy | ItemDebuggerTypeProxy class
 | ItemEditing | Retrieves information about the editing of a source item.
 | ItemHelp | Contains help information for a source item.
 | ItemPathType | Specifies how the path is constructed.
 | ItemPublishing | Retrieves information about the publishing of a source item.
 | ItemRuntimeSettings | Provides miscellaneous information about a source item.
 | ItemSerializer | Represents an item serializer.
 | ItemState | Provides information about the workflow state of a source item.
 | ItemStatistics | Provides information about changes to a source item.
 | ItemUpdateType | Defines the type of update to an item.
 | ItemUtil | Provides miscellaneous functions that operates on an item.
 | ItemVersions | Provides methods for working with versions of an item.
 | ItemVisualization | Defines how an item is visible to a user.
 | ITrackingItem | Defines the basic functionality for an item that tracks modifications.
 | LayoutItem | Represents a Layout item.
 | MediaItem | Represents a media item.
 | PasteMode |
 | ProcessorItem | Represents a Processor item.
 | ReadOnlyItemList |
 | RenderingItem | Represents a Rendering item.
 | SectionTimer | SectionTimer
 | SublayoutItem | Represents a Sublayout item.
 | TemplateFieldItem | Represents a TemplateField item.
 | TemplateItem | Represents a Template item.
 | TemplateSectionItem | Represents a Template Section item.


BaseItem Class

BaseItem Class
Namespaces ► Sitecore.Data.Items ► BaseItem
Defines the basic functionality of an item.
Declaration Syntax
C#
public abstract class BaseItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseItem()()() | Initializes a new instance of the BaseItem class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fields | Gets the fields of the item.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets or sets the value of the field with the specified name.
 | Item[([(Int32])]) | Gets or sets the value of a specified field.
 | Item[([(ID])]) | Gets or sets the value of a specified field.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This is a work-around to provides an Item collection on a class named Item.
Inheritance Hierarchy
Object
 | BaseItem
 |  | Item


BaseItem Constructor

BaseItem Constructor
Namespaces ► Sitecore.Data.Items ► BaseItem ► BaseItem()()()
Initializes a new instance of the BaseItem class
Declaration Syntax
C#
protected BaseItem()


Fields Property

Fields Property
Namespaces ► Sitecore.Data.Items ► BaseItem ► Fields
Gets the fields of the item.
Declaration Syntax
C#
public abstract FieldCollection Fields { get; }
Value
The fields.


Item Property

Item Property
Namespaces ► Sitecore.Data.Items ► BaseItem ► Item
Members
Icon | Member | Description
 | Item[([(String])]) | Gets or sets the value of the field with the specified name.
 | Item[([(Int32])]) | Gets or sets the value of a specified field.
 | Item[([(ID])]) | Gets or sets the value of a specified field.


Item Property (fieldID)

Item Property (fieldID)
Namespaces ► Sitecore.Data.Items ► BaseItem ► Item[([(ID])])
Gets or sets the value of a specified field.
Declaration Syntax
C#
public string this[
    ID fieldID
] { get; set; }
Parameters
fieldID (ID)
Value


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Data.Items ► BaseItem ► Item[([(Int32])])
Gets or sets the value of a specified field.
Declaration Syntax
C#
public string this[
    int index
] { get; set; }
Parameters
index (Int32)
Value


Item Property (fieldName)

Item Property (fieldName)
Namespaces ► Sitecore.Data.Items ► BaseItem ► Item[([(String])])
Gets or sets the value of the field with the specified name.
Declaration Syntax
C#
public string this[
    string fieldName
] { get; set; }
Parameters
fieldName (String)
Value


BranchItem Class

BranchItem Class
Namespaces ► Sitecore.Data.Items ► BranchItem
Represents a master.
Declaration Syntax
C#
public class BranchItem : CustomItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BranchItem(Item) | Creates a new BranchItem instance.
 | AddTo(Item, String) | Adds an item based on this master to another item.
 | BeginEdit()()() | Begins editing the item. (Inherited from CustomItemBase.)
 | Database | Gets the database. (Inherited from CustomItemBase.)
 | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
 | EndEdit()()() | Ends editing the item. (Inherited from CustomItemBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets the icon. (Inherited from CustomItemBase.)
 | ID | Gets the ID. (Inherited from CustomItemBase.)
 | Implicit(Item) | Converts an item to BranchItem.
 | Implicit(BranchItem) | Converts a BranchItem to a Item.
 | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
 | Item[([(ID])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
 | Item[([(Int32])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
 | Item[([(String])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomItemBase.)
 | StandardValues | Gets the standard values.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomItemBase
 |  | CustomItem
 |  |  | BranchItem


BranchItem Constructor (innerItem)

BranchItem Constructor (innerItem)
Namespaces ► Sitecore.Data.Items ► BranchItem ► BranchItem(Item)
Creates a new BranchItem instance.
Declaration Syntax
C#
public BranchItem(
    Item innerItem
)
Parameters
innerItem (Item)
Inner item.


AddTo Method (parentItem, name)

AddTo Method (parentItem, name)
Namespaces ► Sitecore.Data.Items ► BranchItem ► AddTo(Item, String)
Adds an item based on this master to another item.
Declaration Syntax
C#
public Item AddTo(
    Item parentItem,
    string name
)
Parameters
parentItem (Item)
Parent item.
name (String)
Name.
Return Value
The to.


Implicit Method

Implicit Method
Namespaces ► Sitecore.Data.Items ► BranchItem ► Implicit()()()
Members
Icon | Member | Description
 | Implicit(Item) | Converts an item to BranchItem.
 | Implicit(BranchItem) | Converts a BranchItem to a Item.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Items ► BranchItem ► Implicit(BranchItem)
Converts a BranchItem to a Item.
Declaration Syntax
C#
public static implicit operator Item (
    BranchItem branchItem
)
Parameters
branchItem (BranchItem)
The item.
Return Value
The implicit operator.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Items ► BranchItem ► Implicit(Item)
Converts an item to BranchItem.
Declaration Syntax
C#
public static implicit operator BranchItem (
    Item item
)
Parameters
item (Item)
The item.
Return Value
The implicit operator.


Key Property

Key Property
Namespaces ► Sitecore.Data.Items ► BranchItem ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.
Remarks
See Also
Key


StandardValues Property

StandardValues Property
Namespaces ► Sitecore.Data.Items ► BranchItem ► StandardValues
Gets the standard values.
Declaration Syntax
C#
public Item StandardValues { get; }
Value
The standard values.


ContextItemSwitcher Class

ContextItemSwitcher Class
Namespaces ► Sitecore.Data.Items ► ContextItemSwitcher
Switches the context item
Declaration Syntax
C#
public class ContextItemSwitcher : Switcher<Item, ContextItemSwitcher>
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContextItemSwitcher(Item) | Switches the context item
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <( Item, ContextItemSwitcher>)>)
 |  | ContextItemSwitcher


ContextItemSwitcher Constructor (item)

ContextItemSwitcher Constructor (item)
Namespaces ► Sitecore.Data.Items ► ContextItemSwitcher ► ContextItemSwitcher(Item)
Switches the context item
Declaration Syntax
C#
public ContextItemSwitcher(
    Item item
)
Parameters
item (Item)
The item to be used as a new context item


CoreItem Class

CoreItem Class
Namespaces ► Sitecore.Data.Items ► CoreItem
Represents a basic item.
Declaration Syntax
C#
public class CoreItem
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BranchId | Id of branch used for creating the item
 | Data | Gets the data.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataLength()()() | Gets the length of the data.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the ID of item
 | Item[([(ID])]) | Gets or sets the field value with the specified field ID.
 | Language | Gets the language.
 | MasterID | Obsolete. ID of master used for creating the item
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name.
 | TemplateID | Gets the ID of the items template
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | Gets the version.
Inheritance Hierarchy
Object
CoreItem


BranchId Property

BranchId Property
Namespaces ► Sitecore.Data.Items ► CoreItem ► BranchId
Id of branch used for creating the item
Declaration Syntax
C#
public ID BranchId { get; set; }
Value
The branch id.


Data Property

Data Property
Namespaces ► Sitecore.Data.Items ► CoreItem ► Data
Gets the data.
Declaration Syntax
C#
public Hashtable Data { get; }
Value
The data.


GetDataLength Method

GetDataLength Method
Namespaces ► Sitecore.Data.Items ► CoreItem ► GetDataLength()()()
Gets the length of the data.
Declaration Syntax
C#
public virtual long GetDataLength()
Return Value


ID Property

ID Property
Namespaces ► Sitecore.Data.Items ► CoreItem ► ID
Gets the ID of item
Declaration Syntax
C#
public ID ID { get; }
Value
The ID.


Item Property (fieldID)

Item Property (fieldID)
Namespaces ► Sitecore.Data.Items ► CoreItem ► Item[([(ID])])
Gets or sets the field value with the specified field ID.
Declaration Syntax
C#
public string this[
    ID fieldID
] { get; set; }
Parameters
fieldID (ID)
Value


Language Property

Language Property
Namespaces ► Sitecore.Data.Items ► CoreItem ► Language
Gets the language.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


MasterID Property

MasterID Property
Namespaces ► Sitecore.Data.Items ► CoreItem ► MasterID
ID of master used for creating the item
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use BranchId instead.")]
public ID MasterID { get; set; }
Value
The master ID.


Name Property

Name Property
Namespaces ► Sitecore.Data.Items ► CoreItem ► Name
Gets or sets the name.
Declaration Syntax
C#
public string Name { get; set; }
Value
The name.


TemplateID Property

TemplateID Property
Namespaces ► Sitecore.Data.Items ► CoreItem ► TemplateID
Gets the ID of the items template
Declaration Syntax
C#
public ID TemplateID { get; set; }
Value
The template ID.


Version Property

Version Property
Namespaces ► Sitecore.Data.Items ► CoreItem ► Version
Gets the version.
Declaration Syntax
C#
public Version Version { get; }
Value
The version.


CoreItem.Builder Class

CoreItem..::.Builder Class
Namespaces ► Sitecore.Data.Items ► CoreItem ► CoreItem..::.Builder
Builds an item.
Declaration Syntax
C#
public class Builder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CoreItem..::.Builder(ID, String, ID, DataManager) | Initializes a new instance of the CoreItem..::.Builder class.
 | AddField(ID, String) | Adds the field.
 | AddField(String, String) | Adds the field.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemData | Gets the item data.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetBranchId(ID) | Sets the branch id.
 | SetLanguage(Language) | Sets the language.
 | SetMasterID(ID) | Obsolete. Sets the master ID.
 | SetVersion(Version) | Sets the version.
 | Template | Gets the template.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CoreItem..::.Builder


CoreItem.Builder Constructor (itemID, itemName, templateID, manager)

CoreItem..::.Builder Constructor (itemID, itemName, templateID, manager)
Namespaces ► Sitecore.Data.Items ► CoreItem..::.Builder ► CoreItem..::.Builder(ID, String, ID, DataManager)
Initializes a new instance of the CoreItem..::.Builder class.
Declaration Syntax
C#
public Builder(
    ID itemID,
    string itemName,
    ID templateID,
    DataManager manager
)
Parameters
itemID (ID)
The item ID.
itemName (String)
Name of the item.
templateID (ID)
The template ID.
manager (DataManager)
The manager.


AddField Method

AddField Method
Namespaces ► Sitecore.Data.Items ► CoreItem..::.Builder ► AddField()()()
Members
Icon | Member | Description
 | AddField(ID, String) | Adds the field.
 | AddField(String, String) | Adds the field.


AddField Method (fieldID, fieldValue)

AddField Method (fieldID, fieldValue)
Namespaces ► Sitecore.Data.Items ► CoreItem..::.Builder ► AddField(ID, String)
Adds the field.
Declaration Syntax
C#
public void AddField(
    ID fieldID,
    string fieldValue
)
Parameters
fieldID (ID)
The field ID.
fieldValue (String)
The field value.


AddField Method (fieldName, fieldValue)

AddField Method (fieldName, fieldValue)
Namespaces ► Sitecore.Data.Items ► CoreItem..::.Builder ► AddField(String, String)
Adds the field.
Declaration Syntax
C#
public void AddField(
    string fieldName,
    string fieldValue
)
Parameters
fieldName (String)
Name of the field.
fieldValue (String)
The field value.


ItemData Property

ItemData Property
Namespaces ► Sitecore.Data.Items ► CoreItem..::.Builder ► ItemData
Gets the item data.
Declaration Syntax
C#
public ItemData ItemData { get; }
Value
The item data.


SetBranchId Method (branchId)

SetBranchId Method (branchId)
Namespaces ► Sitecore.Data.Items ► CoreItem..::.Builder ► SetBranchId(ID)
Sets the branch id.
Declaration Syntax
C#
public void SetBranchId(
    ID branchId
)
Parameters
branchId (ID)
The branch id.


SetLanguage Method (language)

SetLanguage Method (language)
Namespaces ► Sitecore.Data.Items ► CoreItem..::.Builder ► SetLanguage(Language)
Sets the language.
Declaration Syntax
C#
public void SetLanguage(
    Language language
)
Parameters
language (Language)
The language.


SetMasterID Method (masterID)

SetMasterID Method (masterID)
Namespaces ► Sitecore.Data.Items ► CoreItem..::.Builder ► SetMasterID(ID)
Sets the master ID.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use SetBranchId instead.")]
public void SetMasterID(
    ID masterID
)
Parameters
masterID (ID)
The master ID.


SetVersion Method (version)

SetVersion Method (version)
Namespaces ► Sitecore.Data.Items ► CoreItem..::.Builder ► SetVersion(Version)
Sets the version.
Declaration Syntax
C#
public void SetVersion(
    Version version
)
Parameters
version (Version)
The version.


Template Property

Template Property
Namespaces ► Sitecore.Data.Items ► CoreItem..::.Builder ► Template
Gets the template.
Declaration Syntax
C#
public Template Template { get; }
Value
The template.


CustomItem Class

CustomItem Class
Namespaces ► Sitecore.Data.Items ► CustomItem
Implements the basic functionality of a custom item.
Declaration Syntax
C#
public abstract class CustomItem : CustomItemBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomItem(Item) | Creates a new CustomItem instance.
 | BeginEdit()()() | Begins editing the item. (Inherited from CustomItemBase.)
 | Database | Gets the database. (Inherited from CustomItemBase.)
 | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
 | EndEdit()()() | Ends editing the item. (Inherited from CustomItemBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets the icon. (Inherited from CustomItemBase.)
 | ID | Gets the ID. (Inherited from CustomItemBase.)
 | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
 | Item[([(ID])]) | Gets or sets the value of a specified field.
 | Item[([(Int32])]) | Gets or sets the value of a specified field.
 | Item[([(String])]) | Gets or sets the value of a specified field.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomItemBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomItemBase
 |  | CustomItem
 |  |  | BranchItem
 |  |  | CommandItem
 |  |  | ScheduleItem


CustomItem Constructor (innerItem)

CustomItem Constructor (innerItem)
Namespaces ► Sitecore.Data.Items ► CustomItem ► CustomItem(Item)
Creates a new CustomItem instance.
Declaration Syntax
C#
protected CustomItem(
    Item innerItem
)
Parameters
innerItem (Item)
Inner item.


Item Property

Item Property
Namespaces ► Sitecore.Data.Items ► CustomItem ► Item
Members
Icon | Member | Description
 | Item[([(ID])]) | Gets or sets the value of a specified field.
 | Item[([(Int32])]) | Gets or sets the value of a specified field.
 | Item[([(String])]) | Gets or sets the value of a specified field.


Item Property (fieldID)

Item Property (fieldID)
Namespaces ► Sitecore.Data.Items ► CustomItem ► Item[([(ID])])
Gets or sets the value of a specified field.
Declaration Syntax
C#
public string this[
    ID fieldID
] { get; set; }
Parameters
fieldID (ID)


Item Property (fieldIndex)

Item Property (fieldIndex)
Namespaces ► Sitecore.Data.Items ► CustomItem ► Item[([(Int32])])
Gets or sets the value of a specified field.
Declaration Syntax
C#
public string this[
    int fieldIndex
] { get; }
Parameters
fieldIndex (Int32)


Item Property (fieldName)

Item Property (fieldName)
Namespaces ► Sitecore.Data.Items ► CustomItem ► Item[([(String])])
Gets or sets the value of a specified field.
Declaration Syntax
C#
public string this[
    string fieldName
] { get; set; }
Parameters
fieldName (String)


CustomItemBase Class

CustomItemBase Class
Namespaces ► Sitecore.Data.Items ► CustomItemBase
Implements the basic functionality of a custom item.
Declaration Syntax
C#
public abstract class CustomItemBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomItemBase(Item) | Creates a new CustomItemBase instance.
 | BeginEdit()()() | Begins editing the item.
 | Database | Gets the database.
 | DisplayName | Gets the display name.
 | EndEdit()()() | Ends editing the item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets the icon.
 | ID | Gets the ID.
 | InnerItem | Gets the inner item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomItemBase
 |  | CustomItem
 |  | DeviceItem
 |  | LayoutItem
 |  | MediaItem
 |  | ProcessorItem
 |  | RenderingItem
 |  | SublayoutItem
 |  | TemplateFieldItem
 |  | TemplateItem
 |  | TemplateSectionItem
 |  | PortletItem


CustomItemBase Constructor (innerItem)

CustomItemBase Constructor (innerItem)
Namespaces ► Sitecore.Data.Items ► CustomItemBase ► CustomItemBase(Item)
Creates a new CustomItemBase instance.
Declaration Syntax
C#
protected CustomItemBase(
    Item innerItem
)
Parameters
innerItem (Item)
Inner item.


BeginEdit Method

BeginEdit Method
Namespaces ► Sitecore.Data.Items ► CustomItemBase ► BeginEdit()()()
Begins editing the item.
Declaration Syntax
C#
public void BeginEdit()
Remarks
See Also
BeginEdit()()()


Database Property

Database Property
Namespaces ► Sitecore.Data.Items ► CustomItemBase ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.
Remarks
See Also
Database


DisplayName Property

DisplayName Property
Namespaces ► Sitecore.Data.Items ► CustomItemBase ► DisplayName
Gets the display name.
Declaration Syntax
C#
public virtual string DisplayName { get; }
Value
The name of the display.
Remarks
See Also
DisplayName


EndEdit Method

EndEdit Method
Namespaces ► Sitecore.Data.Items ► CustomItemBase ► EndEdit()()()
Ends editing the item.
Declaration Syntax
C#
public void EndEdit()
Remarks
See Also
EndEdit()()()


Icon Property

Icon Property
Namespaces ► Sitecore.Data.Items ► CustomItemBase ► Icon
Gets the icon.
Declaration Syntax
C#
public virtual string Icon { get; }
Value
The icon.
Remarks
See Also
Icon


ID Property

ID Property
Namespaces ► Sitecore.Data.Items ► CustomItemBase ► ID
Gets the ID.
Declaration Syntax
C#
public ID ID { get; }
Value
The ID.


InnerItem Property

InnerItem Property
Namespaces ► Sitecore.Data.Items ► CustomItemBase ► InnerItem
Gets the inner item.
Declaration Syntax
C#
public Item InnerItem { get; }
Value
The inner item.


Name Property

Name Property
Namespaces ► Sitecore.Data.Items ► CustomItemBase ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.
Remarks
See Also
Name


DeviceItem Class

DeviceItem Class
Namespaces ► Sitecore.Data.Items ► DeviceItem
Represents a Device item.
Declaration Syntax
C#
public class DeviceItem : CustomItemBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeviceItem(Item) | Creates a new DeviceItem instance.
 | Agent | Gets the agent identification string.
 | BeginEdit()()() | Begins editing the item. (Inherited from CustomItemBase.)
 | Capabilities | Gets the capabilities of the device.
 | Database | Gets the database. (Inherited from CustomItemBase.)
 | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
 | EndEdit()()() | Ends editing the item. (Inherited from CustomItemBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FallbackDevice | Gets the fallback device.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets the icon. (Inherited from CustomItemBase.)
 | ID | Gets the ID. (Inherited from CustomItemBase.)
 | Implicit(Item) | Converts an item to a DeviceItem.
 | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
 | IsDefault | Gets a value indicating whether this device is default.
 | IsValid | Gets a value indicating whether this device is valid.
 | MatchesAgent()()() | Determines if the current Http query string matches the Agent.
 | MatchesQueryString()()() | Determines if the current Http query string matches the QueryString.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomItemBase.)
 | QueryString | Gets the Http query string that must be matched for this device to be valid.
 | ResolveDevice(Database) | Gets the current device.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomItemBase
 |  | DeviceItem


DeviceItem Constructor (innerItem)

DeviceItem Constructor (innerItem)
Namespaces ► Sitecore.Data.Items ► DeviceItem ► DeviceItem(Item)
Creates a new DeviceItem instance.
Declaration Syntax
C#
public DeviceItem(
    Item innerItem
)
Parameters
innerItem (Item)
Inner item.


Agent Property

Agent Property
Namespaces ► Sitecore.Data.Items ► DeviceItem ► Agent
Gets the agent identification string.
Declaration Syntax
C#
public string Agent { get; }
Value


Capabilities Property

Capabilities Property
Namespaces ► Sitecore.Data.Items ► DeviceItem ► Capabilities
Gets the capabilities of the device.
Declaration Syntax
C#
public DeviceCapabilities Capabilities { get; }
Value
The capabilities of the device.


FallbackDevice Property

FallbackDevice Property
Namespaces ► Sitecore.Data.Items ► DeviceItem ► FallbackDevice
Gets the fallback device.
Declaration Syntax
C#
public DeviceItem FallbackDevice { get; }
Value


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Items ► DeviceItem ► Implicit(Item)
Converts an item to a DeviceItem.
Declaration Syntax
C#
public static implicit operator DeviceItem (
    Item item
)
Parameters
item (Item)


IsDefault Property

IsDefault Property
Namespaces ► Sitecore.Data.Items ► DeviceItem ► IsDefault
Gets a value indicating whether this device is default.
Declaration Syntax
C#
public bool IsDefault { get; }
Value
true if this device is default; otherwise, false.


IsValid Property

IsValid Property
Namespaces ► Sitecore.Data.Items ► DeviceItem ► IsValid
Gets a value indicating whether this device is valid.
Declaration Syntax
C#
public bool IsValid { get; }
Value
true if this device is valid; otherwise, false.


MatchesAgent Method

MatchesAgent Method
Namespaces ► Sitecore.Data.Items ► DeviceItem ► MatchesAgent()()()
Determines if the current Http query string matches the Agent.
Declaration Syntax
C#
public bool MatchesAgent()
Return Value


MatchesQueryString Method

MatchesQueryString Method
Namespaces ► Sitecore.Data.Items ► DeviceItem ► MatchesQueryString()()()
Determines if the current Http query string matches the QueryString.
Declaration Syntax
C#
public bool MatchesQueryString()
Return Value


QueryString Property

QueryString Property
Namespaces ► Sitecore.Data.Items ► DeviceItem ► QueryString
Gets the Http query string that must be matched for this device to be valid.
Declaration Syntax
C#
public string QueryString { get; }
Value


ResolveDevice Method (database)

ResolveDevice Method (database)
Namespaces ► Sitecore.Data.Items ► DeviceItem ► ResolveDevice(Database)
Gets the current device.
Declaration Syntax
C#
public static DeviceItem ResolveDevice(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The current device.


EditContext Class

EditContext Class
Namespaces ► Sitecore.Data.Items ► EditContext
Provides a mean to put an item in editing mode.
Declaration Syntax
C#
public class EditContext : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EditContext(Item) | Creates a new EditContext instance.
 | EditContext(Item, SecurityCheck) | Creates a new EditContext instance.
 | EditContext(Item, Boolean, Boolean) | Creates a new EditContext instance.
 | Dispose()()() | Disposes this instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

The item is enters editing mode when this object is created and leaves editing mode when the object is disposed.

This provides an easy to use mechanism for editing items.

Examples
The following code updates the Title field of the Home item.
CopyC#
Item item = Sitecore.Context.Item["/sitecore/context/Home"];
  using (new EditContext(item)) {
    item["Title"] = "My title";
  }
Inheritance Hierarchy
Object
EditContext


EditContext Constructor

EditContext Constructor
Namespaces ► Sitecore.Data.Items ► EditContext ► EditContext()()()
Members
Icon | Member | Description
 | EditContext(Item) | Creates a new EditContext instance.
 | EditContext(Item, SecurityCheck) | Creates a new EditContext instance.
 | EditContext(Item, Boolean, Boolean) | Creates a new EditContext instance.


EditContext Constructor (item)

EditContext Constructor (item)
Namespaces ► Sitecore.Data.Items ► EditContext ► EditContext(Item)
Creates a new EditContext instance.
Declaration Syntax
C#
public EditContext(
    Item item
)
Parameters
item (Item)
Item.
Remarks
The item enters editing mode.


EditContext Constructor (item, securityCheck)

EditContext Constructor (item, securityCheck)
Namespaces ► Sitecore.Data.Items ► EditContext ► EditContext(Item, SecurityCheck)
Creates a new EditContext instance.
Declaration Syntax
C#
public EditContext(
    Item item,
    SecurityCheck securityCheck
)
Parameters
item (Item)
Item.
securityCheck (SecurityCheck)
The security check.
Remarks
The item enters editing mode.


EditContext Constructor (item, updateStatistics, silent)

EditContext Constructor (item, updateStatistics, silent)
Namespaces ► Sitecore.Data.Items ► EditContext ► EditContext(Item, Boolean, Boolean)
Creates a new EditContext instance.
Declaration Syntax
C#
public EditContext(
    Item item,
    bool updateStatistics,
    bool silent
)
Parameters
item (Item)
The item.
updateStatistics (Boolean)
if set to true this instance is update statistics.
silent (Boolean)
if set to true this instance is silent.
Remarks
The item enters editing mode.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Data.Items ► EditContext ► Dispose()()()
Disposes this instance.
Declaration Syntax
C#
public void Dispose()
Remarks
The item leaves editing mode.


FieldChange Class

FieldChange Class
Namespaces ► Sitecore.Data.Items ► FieldChange
Represents a field change.
Declaration Syntax
C#
public class FieldChange
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldChange(Field, String) | Initializes a new instance of the FieldChange class.
 | Definition | Gets the definition.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldID | Gets the field ID.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Language | Gets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveField | Gets a value indicating whether the FieldChange removes the field.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets the value.
 | Version | Gets the version.
Inheritance Hierarchy
Object
FieldChange


FieldChange Constructor (field, value)

FieldChange Constructor (field, value)
Namespaces ► Sitecore.Data.Items ► FieldChange ► FieldChange(Field, String)
Initializes a new instance of the FieldChange class.
Declaration Syntax
C#
public FieldChange(
    Field field,
    string value
)
Parameters
field (Field)
The field.
value (String)
The value.


Definition Property

Definition Property
Namespaces ► Sitecore.Data.Items ► FieldChange ► Definition
Gets the definition.
Declaration Syntax
C#
public TemplateField Definition { get; }
Value
The definition.


FieldID Property

FieldID Property
Namespaces ► Sitecore.Data.Items ► FieldChange ► FieldID
Gets the field ID.
Declaration Syntax
C#
public ID FieldID { get; }
Value
The field ID.


Language Property

Language Property
Namespaces ► Sitecore.Data.Items ► FieldChange ► Language
Gets the language.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


RemoveField Property

RemoveField Property
Namespaces ► Sitecore.Data.Items ► FieldChange ► RemoveField
Gets a value indicating whether the FieldChange removes the field.
Declaration Syntax
C#
public bool RemoveField { get; }
Value
true if the FieldChange removes the field; otherwise, false.


Value Property

Value Property
Namespaces ► Sitecore.Data.Items ► FieldChange ► Value
Gets the value.
Declaration Syntax
C#
public string Value { get; }
Value
The value.


Version Property

Version Property
Namespaces ► Sitecore.Data.Items ► FieldChange ► Version
Gets the version.
Declaration Syntax
C#
public Version Version { get; }
Value
The version.


FieldChangeList Class

FieldChangeList Class
Namespaces ► Sitecore.Data.Items ► FieldChangeList
Represents a list of field changes.
Declaration Syntax
C#
public class FieldChangeList : IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldChangeList()()() | Initializes a new instance of the FieldChangeList class
 | Contains(ID) | Determines whether the list of changed fields contains the specified field id.
 | ContainsAnyOf(array<ID>[]()[]) | Determines whether the list of changed fields contains any of the specified field ids.
 | Count | Gets the count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(ID])]) | Gets or sets the FieldChange with the specified field ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SyncRoot | Gets the sync root.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FieldChangeList


FieldChangeList Constructor

FieldChangeList Constructor
Namespaces ► Sitecore.Data.Items ► FieldChangeList ► FieldChangeList()()()
Initializes a new instance of the FieldChangeList class
Declaration Syntax
C#
public FieldChangeList()


Contains Method (fieldId)

Contains Method (fieldId)
Namespaces ► Sitecore.Data.Items ► FieldChangeList ► Contains(ID)
Determines whether the list of changed fields contains the specified field id.
Declaration Syntax
C#
public bool Contains(
    ID fieldId
)
Parameters
fieldId (ID)
The field ID.
Return Value
true if the field id is contained; otherwise, false.


ContainsAnyOf Method (fieldIds)

ContainsAnyOf Method (fieldIds)
Namespaces ► Sitecore.Data.Items ► FieldChangeList ► ContainsAnyOf(array<ID>[]()[])
Determines whether the list of changed fields contains any of the specified field ids.
Declaration Syntax
C#
public bool ContainsAnyOf(
    params ID[] fieldIds
)
Parameters
fieldIds (array< ID >[]()[])
The field ids.
Return Value
true if any of the field ids are contained; otherwise, false.


Count Property

Count Property
Namespaces ► Sitecore.Data.Items ► FieldChangeList ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Data.Items ► FieldChangeList ► GetEnumerator()()()
Returns an enumerator that iterates through a collection.
Declaration Syntax
C#
public IEnumerator GetEnumerator()
Return Value
An IEnumerator object that can be used to iterate through the collection.


Item Property (fieldID)

Item Property (fieldID)
Namespaces ► Sitecore.Data.Items ► FieldChangeList ► Item[([(ID])])
Gets or sets the FieldChange with the specified field ID.
Declaration Syntax
C#
public FieldChange this[
    ID fieldID
] { get; set; }
Parameters
fieldID (ID)
Value
The FieldChange.


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Data.Items ► FieldChangeList ► SyncRoot
Gets the sync root.
Declaration Syntax
C#
public Object SyncRoot { get; }
Value
The sync root.


Item Class

Item Class
Namespaces ► Sitecore.Data.Items ► Item
Represents an item.
Declaration Syntax
C#
public class Item : BaseItem, ISecurable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Item(ID, ItemData, Database) | Initializes a new instance of the Item class.
 | Access | Provides access to the Access framework.
 | Add(String, BranchItem) | Creates an item under this item from a master.
 | Add(String, BranchId) | Creates an item under this item from a master ID.
 | Add(String, TemplateItem) | Creates an item under this item from a template.
 | Add(String, TemplateID) | Creates an item under this item from a template ID.
 | Appearance | Provides access to appearance information.
 | Axes | Provides access to functions that retrieve other item relative to this item.
 | BeginEdit()()() | Obsolete. Marks the beginning of an editing operation.
 | Branch | Gets the branch from which the item was created.
 | Branches | Gets a list of branches that are allowed to be created under this item.
 | BranchId | Gets the id of the branch that was used to create this item.
 | ChangeTemplate(TemplateItem) | Changes the template of the item.
 | Children | Gets a list of child items.
 | Clone(Item) | Clones the specified item.
 | Clone(ID, Database) | Clones the specified item.
 | CopyTo(Item, String) | Copies an item to another location.
 | CopyTo(Item, String, ID, Boolean) | Copies an item to another location.
 | Database | Gets the database.
 | Delete()()() | Deletes the item.
 | DeleteChildren()()() | Deletes all child items to which the current user has delete access.
 | DisplayName | Gets the language-specific display name.
 | Duplicate()()() | Duplicates the item.
 | Duplicate(String) | Duplicates the item.
 | Editing | Provides access to the publishing framework.
 | Empty | Gets a value indicating whether this Item is empty (i.e. has no versions in any language).
 | EndEdit()()() | Obsolete. Ends an edit operation.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fields | Gets the list of fields. (Overrides BaseItem.Fields.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildren()()() | Gets the children.
 | GetChildren(ChildListOptions) | Gets the children.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOuterXml(Boolean) | Gets the outer XML of the item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniqueId()()() | Gets a unique id.
 | HasChildren | Gets a value that indicates if the item has child items.
 | Help | Provides access to help information.
 | ID | Gets the ID of the item.
 | InnerData | Gets the inner data.
 | IsEditing | Obsolete. Gets a value that indicates if the item is being edited.
 | IsEmpty(ID, Database) | Gets a value that indicates if the item is empty (i.e. has no versions).
 | Item[([(String])]) | Gets or sets the value of the field with the specified name. (Inherited from BaseItem.)
 | Item[([(Int32])]) | Gets or sets the value of a specified field. (Inherited from BaseItem.)
 | Item[([(ID])]) | Gets or sets the value of a specified field. (Inherited from BaseItem.)
 | Key | Gets the key of item.
 | Language | Get the language of the item.
 | Languages | Gets a list of languages that the item has content in.
 | Links | Provides access to the Links framework.
 | Locking | Provides to the Locking framework.
 | Master | Obsolete. Gets the master from which the item was created.
 | MasterID | Obsolete. Gets the ID of the master that was used to create this item.
 | Masters | Obsolete. Gets a list of masters that are allowed to be created under this item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Modified | Gets a value that indicates if the item has been modified.
 | MoveTo(Item) | Moves the item to another location.
 | Name | Gets or sets the name.
 | OriginatorId | Gets the originator id.
 | Parent | Gets the parent item.
 | ParentID | Gets the ID of the parent item.
 | Paste(String, Boolean, PasteMode) | Inserts new items from an XML string.
 | PasteItem(String, Boolean, PasteMode) | Inserts new items from an XML string.
 | Paths | Provides access to Path information.
 | Publishing | Provides access to the publishing framework.
 | Recycle()()() | Puts the item in the Recycle Bin database.
 | RecycleChildren()()() | Deletes all child items to which the current user has delete access.
 | Reload()()() | Reloads the item from storage.
 | RuntimeSettings | Provides access to miscellaneous runtime information.
 | Security | Gets the access rules defined for the item.
 | State | Gets the state.
 | Statistics | Provides access to statistical information.
 | SyncRoot | Gets the sync root.
 | Template | Gets the template of the item.
 | TemplateID | Gets the ID of the template.
 | TemplateName | Gets the name of the template.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Uri | Gets an URI for the item.
 | Version | Gets the version represented by this item.
 | Versions | Provides access to different versions of the item.
 | Visualization | Provides access to the visible representations of the item.
Remarks

The item is language-specific and represents a single version.

The Item class is a top-level class that provide access to many operations within the system.

An item is usually obtained directly from a database.

Examples

Item item = Sitecore.Context.Database["/sitecore/content/Home"];

Inheritance Hierarchy
Object
 | BaseItem
 |  | Item


Item Constructor (itemID, data, database)

Item Constructor (itemID, data, database)
Namespaces ► Sitecore.Data.Items ► Item ► Item(ID, ItemData, Database)
Initializes a new instance of the Item class.
Declaration Syntax
C#
public Item(
    ID itemID,
    ItemData data,
    Database database
)
Parameters
itemID (ID)
The item ID.
data (ItemData)
The data.
database (Database)
The database.


Access Property

Access Property
Namespaces ► Sitecore.Data.Items ► Item ► Access
Provides access to the Access framework.
Declaration Syntax
C#
public ItemAccess Access { get; }
Value
The access.
Remarks
The Access framework determine user rights from security and workflow settings.


Add Method

Add Method
Namespaces ► Sitecore.Data.Items ► Item ► Add()()()
Members
Icon | Member | Description
 | Add(String, BranchItem) | Creates an item under this item from a master.
 | Add(String, BranchId) | Creates an item under this item from a master ID.
 | Add(String, TemplateItem) | Creates an item under this item from a template.
 | Add(String, TemplateID) | Creates an item under this item from a template ID.


Add Method (name, branchId)

Add Method (name, branchId)
Namespaces ► Sitecore.Data.Items ► Item ► Add(String, BranchId)
Creates an item under this item from a master ID.
Declaration Syntax
C#
public Item Add(
    string name,
    BranchId branchId
)
Parameters
name (String)
The name.
branchId (BranchId)
The master ID.
Return Value
The add.


Add Method (name, branch)

Add Method (name, branch)
Namespaces ► Sitecore.Data.Items ► Item ► Add(String, BranchItem)
Creates an item under this item from a master.
Declaration Syntax
C#
public Item Add(
    string name,
    BranchItem branch
)
Parameters
name (String)
The name.
branch (BranchItem)
The master.
Return Value
The add.


Add Method (name, template)

Add Method (name, template)
Namespaces ► Sitecore.Data.Items ► Item ► Add(String, TemplateItem)
Creates an item under this item from a template.
Declaration Syntax
C#
public Item Add(
    string name,
    TemplateItem template
)
Parameters
name (String)
The name.
template (TemplateItem)
The template.
Return Value
The add.


Add Method (name, templateID)

Add Method (name, templateID)
Namespaces ► Sitecore.Data.Items ► Item ► Add(String, TemplateID)
Creates an item under this item from a template ID.
Declaration Syntax
C#
public Item Add(
    string name,
    TemplateID templateID
)
Parameters
name (String)
The name.
templateID (TemplateID)
The template ID.
Return Value
The add.


Appearance Property

Appearance Property
Namespaces ► Sitecore.Data.Items ► Item ► Appearance
Provides access to appearance information.
Declaration Syntax
C#
public ItemAppearance Appearance { get; }
Value
The appearance.
Remarks
Appearance information includes CSS style and an icon.


Axes Property

Axes Property
Namespaces ► Sitecore.Data.Items ► Item ► Axes
Provides access to functions that retrieve other item relative to this item.
Declaration Syntax
C#
public ItemAxes Axes { get; }
Value
The axes.


BeginEdit Method

BeginEdit Method
Namespaces ► Sitecore.Data.Items ► Item ► BeginEdit()()()
Marks the beginning of an editing operation.
Declaration Syntax
C#
[ObsoleteAttribute("Use Item.Editing.BeginEdit instead.")]
public void BeginEdit()
Remarks
This method is deprecated from version 5.1.


Branch Property

Branch Property
Namespaces ► Sitecore.Data.Items ► Item ► Branch
Gets the branch from which the item was created.
Declaration Syntax
C#
public BranchItem Branch { get; }
Value
The branch.


Branches Property

Branches Property
Namespaces ► Sitecore.Data.Items ► Item ► Branches
Gets a list of branches that are allowed to be created under this item.
Declaration Syntax
C#
public BranchItem[] Branches { get; }
Value
The branches.


BranchId Property

BranchId Property
Namespaces ► Sitecore.Data.Items ► Item ► BranchId
Gets the id of the branch that was used to create this item.
Declaration Syntax
C#
public ID BranchId { get; set; }
Value
The branch ID.


ChangeTemplate Method (template)

ChangeTemplate Method (template)
Namespaces ► Sitecore.Data.Items ► Item ► ChangeTemplate(TemplateItem)
Changes the template of the item.
Declaration Syntax
C#
public void ChangeTemplate(
    TemplateItem template
)
Parameters
template (TemplateItem)
The template.
Remarks
Field values are transfered by name.


Children Property

Children Property
Namespaces ► Sitecore.Data.Items ► Item ► Children
Gets a list of child items.
Declaration Syntax
C#
public ChildList Children { get; }
Value
The children.


Clone Method

Clone Method
Namespaces ► Sitecore.Data.Items ► Item ► Clone()()()
Members
Icon | Member | Description
 | Clone(Item) | Clones the specified item.
 | Clone(ID, Database) | Clones the specified item.


Clone Method (cloneID, ownerDatabase)

Clone Method (cloneID, ownerDatabase)
Namespaces ► Sitecore.Data.Items ► Item ► Clone(ID, Database)
Clones the specified item.
Declaration Syntax
C#
public Item Clone(
    ID cloneID,
    Database ownerDatabase
)
Parameters
cloneID (ID)
The clone ID.
ownerDatabase (Database)
The database that is to own the clone.
Return Value


Clone Method (item)

Clone Method (item)
Namespaces ► Sitecore.Data.Items ► Item ► Clone(Item)
Clones the specified item.
Declaration Syntax
C#
public Item Clone(
    Item item
)
Parameters
item (Item)
The item.
Return Value


CopyTo Method

CopyTo Method
Namespaces ► Sitecore.Data.Items ► Item ► CopyTo()()()
Members
Icon | Member | Description
 | CopyTo(Item, String) | Copies an item to another location.
 | CopyTo(Item, String, ID, Boolean) | Copies an item to another location.


CopyTo Method (destination, copyName)

CopyTo Method (destination, copyName)
Namespaces ► Sitecore.Data.Items ► Item ► CopyTo(Item, String)
Copies an item to another location.
Declaration Syntax
C#
public Item CopyTo(
    Item destination,
    string copyName
)
Parameters
destination (Item)
The destination item (i.e. the item that will serve as the parent of the copy).
copyName (String)
Name of the copy.
Return Value
The copied item (i.e. the root of the copied subtree).
Remarks

Copies an item and all of its descendants to another location in the content tree.

All item IDs are changed before the copy is merged into the content tree.


CopyTo Method (destination, copyName, copyID, deep)

CopyTo Method (destination, copyName, copyID, deep)
Namespaces ► Sitecore.Data.Items ► Item ► CopyTo(Item, String, ID, Boolean)
Copies an item to another location.
Declaration Syntax
C#
public Item CopyTo(
    Item destination,
    string copyName,
    ID copyID,
    bool deep
)
Parameters
destination (Item)
The destination item (i.e. the item that will serve as the parent of the copy).
copyName (String)
Name of the copy.
copyID (ID)
The copy ID.
deep (Boolean)
Indicates if child items are copied.
Return Value
The copied item (i.e. the root of the copied subtree).
Remarks

Copies an item to another location in the content tree.

All item IDs are changed before the copy is merged into the content tree.


Database Property

Database Property
Namespaces ► Sitecore.Data.Items ► Item ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.
Remarks

Gets the database that item resides in.

The Database class is a top-level class that provides access many other functions within the system.


Delete Method

Delete Method
Namespaces ► Sitecore.Data.Items ► Item ► Delete()()()
Deletes the item.
Declaration Syntax
C#
public void Delete()


DeleteChildren Method

DeleteChildren Method
Namespaces ► Sitecore.Data.Items ► Item ► DeleteChildren()()()
Deletes all child items to which the current user has delete access.
Declaration Syntax
C#
public int DeleteChildren()
Return Value
The number of child items deleted.


DisplayName Property

DisplayName Property
Namespaces ► Sitecore.Data.Items ► Item ► DisplayName
Gets the language-specific display name.
Declaration Syntax
C#
public string DisplayName { get; }
Value
The name of the display.


Duplicate Method

Duplicate Method
Namespaces ► Sitecore.Data.Items ► Item ► Duplicate()()()
Members
Icon | Member | Description
 | Duplicate()()() | Duplicates the item.
 | Duplicate(String) | Duplicates the item.


Duplicate Method

Duplicate Method
Namespaces ► Sitecore.Data.Items ► Item ► Duplicate()()()
Duplicates the item.
Declaration Syntax
C#
public Item Duplicate()
Return Value
The new item.
Remarks
Creates a copy of the item and all of its child items under the same parent item. All new items will have new IDs assigned.


Duplicate Method (copyName)

Duplicate Method (copyName)
Namespaces ► Sitecore.Data.Items ► Item ► Duplicate(String)
Duplicates the item.
Declaration Syntax
C#
public Item Duplicate(
    string copyName
)
Parameters
copyName (String)
Name of the copy.
Return Value
The new item.
Remarks
Creates a copy of the item and all of its subitems under the same parent item. All new items will have new IDs assigned


Editing Property

Editing Property
Namespaces ► Sitecore.Data.Items ► Item ► Editing
Provides access to the publishing framework.
Declaration Syntax
C#
public ItemEditing Editing { get; }
Value
The editing.


Empty Property

Empty Property
Namespaces ► Sitecore.Data.Items ► Item ► Empty
Gets a value indicating whether this Item is empty (i.e. has no versions in any language).
Declaration Syntax
C#
public bool Empty { get; }
Value
true if empty; otherwise, false.


EndEdit Method

EndEdit Method
Namespaces ► Sitecore.Data.Items ► Item ► EndEdit()()()
Ends an edit operation.
Declaration Syntax
C#
[ObsoleteAttribute("Use Item.Editing.EndEdit instead.")]
public bool EndEdit()
Return Value
The edit.
Remarks
This method is deprecated from version 5.1.


Fields Property

Fields Property
Namespaces ► Sitecore.Data.Items ► Item ► Fields
Gets the list of fields.
Declaration Syntax
C#
public override FieldCollection Fields { get; }
Value
The fields.
Remarks

The list only contains the fields that have content.

To get all fields defined by the template, use the ReadAll method on the returned list.


GetChildren Method

GetChildren Method
Namespaces ► Sitecore.Data.Items ► Item ► GetChildren()()()
Members
Icon | Member | Description
 | GetChildren()()() | Gets the children.
 | GetChildren(ChildListOptions) | Gets the children.


GetChildren Method

GetChildren Method
Namespaces ► Sitecore.Data.Items ► Item ► GetChildren()()()
Gets the children.
Declaration Syntax
C#
public ChildList GetChildren()
Return Value


GetChildren Method (options)

GetChildren Method (options)
Namespaces ► Sitecore.Data.Items ► Item ► GetChildren(ChildListOptions)
Gets the children.
Declaration Syntax
C#
public ChildList GetChildren(
    ChildListOptions options
)
Parameters
options (ChildListOptions)
The options.
Return Value


GetOuterXml Method (includeSubitems)

GetOuterXml Method (includeSubitems)
Namespaces ► Sitecore.Data.Items ► Item ► GetOuterXml(Boolean)
Gets the outer XML of the item.
Declaration Syntax
C#
public string GetOuterXml(
    bool includeSubitems
)
Parameters
includeSubitems (Boolean)
if set to true the XML includes subitems.
Return Value


GetUniqueId Method

GetUniqueId Method
Namespaces ► Sitecore.Data.Items ► Item ► GetUniqueId()()()
Gets a unique id.
Declaration Syntax
C#
public string GetUniqueId()
Return Value
Remarks

The id must be unique enough to be used in a global cache.

For example, an Item might implement this as Database.Name + ID.

The resulting key used by the AuthorizationManager might therefore be typeof(Item).FullName + divider + Database.Name + ID.


HasChildren Property

HasChildren Property
Namespaces ► Sitecore.Data.Items ► Item ► HasChildren
Gets a value that indicates if the item has child items.
Declaration Syntax
C#
public bool HasChildren { get; }
Value
true if this instance has children; otherwise, false.
Remarks

This is an efficient method for determine if the item has child items.

Do not use Children.Count as this retrieves all child items.


Help Property

Help Property
Namespaces ► Sitecore.Data.Items ► Item ► Help
Provides access to help information.
Declaration Syntax
C#
public ItemHelp Help { get; }
Value
The help.
Remarks
Help information include Short Description (ToolTip) Long Help (Description) and Help link.


ID Property

ID Property
Namespaces ► Sitecore.Data.Items ► Item ► ID
Gets the ID of the item.
Declaration Syntax
C#
public ID ID { get; }
Value
The ID.


InnerData Property

InnerData Property
Namespaces ► Sitecore.Data.Items ► Item ► InnerData
Gets the inner data.
Declaration Syntax
C#
public ItemData InnerData { get; }
Value
The inner data.


IsEditing Property

IsEditing Property
Namespaces ► Sitecore.Data.Items ► Item ► IsEditing
Gets a value that indicates if the item is being edited.
Declaration Syntax
C#
[ObsoleteAttribute("Use Item.Editing.IsEditing instead.")]
public bool IsEditing { get; }
Value
true if this instance is editing; otherwise, false.
Remarks
This property is deprecated from version 5.1.


IsEmpty Method (itemID, database)

IsEmpty Method (itemID, database)
Namespaces ► Sitecore.Data.Items ► Item ► IsEmpty(ID, Database)
Gets a value that indicates if the item is empty (i.e. has no versions).
Declaration Syntax
C#
public static bool IsEmpty(
    ID itemID,
    Database database
)
Parameters
itemID (ID)
The item ID.
database (Database)
The database.
Return Value
true if the specified item ID is empty; otherwise, false.


Key Property

Key Property
Namespaces ► Sitecore.Data.Items ► Item ► Key
Gets the key of item.
Declaration Syntax
C#
public string Key { get; }
Value
The key.
Remarks
The key is always %Name% in lowercase.


Language Property

Language Property
Namespaces ► Sitecore.Data.Items ► Item ► Language
Get the language of the item.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


Languages Property

Languages Property
Namespaces ► Sitecore.Data.Items ► Item ► Languages
Gets a list of languages that the item has content in.
Declaration Syntax
C#
public Language[] Languages { get; }
Value
The languages.


Links Property

Links Property
Namespaces ► Sitecore.Data.Items ► Item ► Links
Provides access to the Links framework.
Declaration Syntax
C#
public ItemLinks Links { get; }
Value
The links.
Remarks
The Links framework contains information about which items links to this item and which items are references from this item.


Locking Property

Locking Property
Namespaces ► Sitecore.Data.Items ► Item ► Locking
Provides to the Locking framework.
Declaration Syntax
C#
public ItemLocking Locking { get; }
Value
The locking.
Remarks
The Locking framework ensures, if enabled, that only one user can edit an item at a time.


Master Property

Master Property
Namespaces ► Sitecore.Data.Items ► Item ► Master
Gets the master from which the item was created.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use BranchItem instead.")]
public BranchItem Master { get; }
Value
The master.


MasterID Property

MasterID Property
Namespaces ► Sitecore.Data.Items ► Item ► MasterID
Gets the ID of the master that was used to create this item.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use BranchId instead.")]
public ID MasterID { get; set; }
Value
The master ID.


Masters Property

Masters Property
Namespaces ► Sitecore.Data.Items ► Item ► Masters
Gets a list of masters that are allowed to be created under this item.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Branches instead.")]
public BranchItem[] Masters { get; }
Value
The masters.


Modified Property

Modified Property
Namespaces ► Sitecore.Data.Items ► Item ► Modified
Gets a value that indicates if the item has been modified.
Declaration Syntax
C#
public bool Modified { get; }
Value
true if modified; otherwise, false.


MoveTo Method (destination)

MoveTo Method (destination)
Namespaces ► Sitecore.Data.Items ► Item ► MoveTo(Item)
Moves the item to another location.
Declaration Syntax
C#
public void MoveTo(
    Item destination
)
Parameters
destination (Item)
Destination item (i.e. the item that will serve as the new parent of the item).
Remarks
Moves an item and all of its descendants to another location in the content tree.


Name Property

Name Property
Namespaces ► Sitecore.Data.Items ► Item ► Name
Gets or sets the name.
Declaration Syntax
C#
public string Name { get; set; }
Value
The name.
Remarks

The name is a short textual description of the item, like a filename in Windows.

It can not be language versioned.


OriginatorId Property

OriginatorId Property
Namespaces ► Sitecore.Data.Items ► Item ► OriginatorId
Gets the originator id.
Declaration Syntax
C#
public ID OriginatorId { get; }
Value
The originator id.


Parent Property

Parent Property
Namespaces ► Sitecore.Data.Items ► Item ► Parent
Gets the parent item.
Declaration Syntax
C#
public Item Parent { get; }
Value
The parent.
Remarks
For the root element, null is returned.
Examples
Get the parent of the Home item:
CopyC#
Item home = Sitecore.Context.Database["/sitecore/content/Home"];
Item parent = home.Parent;
MainUtil.Out("Parent is: " + parent.Parent.Path);
// Parent is: /sitecore/content
CopyC#

Send comments on this topic to
        dv@sitecore.net


ParentID Property

ParentID Property
Namespaces ► Sitecore.Data.Items ► Item ► ParentID
Gets the ID of the parent item.
Declaration Syntax
C#
public ID ParentID { get; }
Value
The parent ID.


Paste Method (xml, changeIDs, mode)

Paste Method (xml, changeIDs, mode)
Namespaces ► Sitecore.Data.Items ► Item ► Paste(String, Boolean, PasteMode)
Inserts new items from an XML string.
Declaration Syntax
C#
public void Paste(
    string xml,
    bool changeIDs,
    PasteMode mode
)
Parameters
xml (String)
The XML.
changeIDs (Boolean)
if set to true ids should be changed.
mode (PasteMode)
The mode.


PasteItem Method (xml, changeIDs, mode)

PasteItem Method (xml, changeIDs, mode)
Namespaces ► Sitecore.Data.Items ► Item ► PasteItem(String, Boolean, PasteMode)
Inserts new items from an XML string.
Declaration Syntax
C#
public Item PasteItem(
    string xml,
    bool changeIDs,
    PasteMode mode
)
Parameters
xml (String)
The XML.
changeIDs (Boolean)
if set to true ids should be changed.
mode (PasteMode)
The mode.
Return Value
The item.


Paths Property

Paths Property
Namespaces ► Sitecore.Data.Items ► Item ► Paths
Provides access to Path information.
Declaration Syntax
C#
public ItemPath Paths { get; }
Value
The paths.
Remarks
Path information describes the items position in relation to other items.


Publishing Property

Publishing Property
Namespaces ► Sitecore.Data.Items ► Item ► Publishing
Provides access to the publishing framework.
Declaration Syntax
C#
public ItemPublishing Publishing { get; }
Value
The publishing.


Recycle Method

Recycle Method
Namespaces ► Sitecore.Data.Items ► Item ► Recycle()()()
Puts the item in the Recycle Bin database.
Declaration Syntax
C#
public Guid Recycle()
Return Value
The id of archive entry. If an archive entry hasn't been created, the return value will be Guid.Empty.


RecycleChildren Method

RecycleChildren Method
Namespaces ► Sitecore.Data.Items ► Item ► RecycleChildren()()()
Deletes all child items to which the current user has delete access.
Declaration Syntax
C#
public int RecycleChildren()
Return Value
The number of child items deleted.


Reload Method

Reload Method
Namespaces ► Sitecore.Data.Items ► Item ► Reload()()()
Reloads the item from storage.
Declaration Syntax
C#
public void Reload()


RuntimeSettings Property

RuntimeSettings Property
Namespaces ► Sitecore.Data.Items ► Item ► RuntimeSettings
Provides access to miscellaneous runtime information.
Declaration Syntax
C#
public ItemRuntimeSettings RuntimeSettings { get; }
Value
The runtime settings.


Security Property

Security Property
Namespaces ► Sitecore.Data.Items ► Item ► Security
Gets the access rules defined for the item.
Declaration Syntax
C#
public ItemSecurity Security { get; set; }
Value
The access rules.


State Property

State Property
Namespaces ► Sitecore.Data.Items ► Item ► State
Gets the state.
Declaration Syntax
C#
public ItemState State { get; }
Value
The state.


Statistics Property

Statistics Property
Namespaces ► Sitecore.Data.Items ► Item ► Statistics
Provides access to statistical information.
Declaration Syntax
C#
public ItemStatistics Statistics { get; }
Value
The statistics.
Remarks
Statistical information is creation time, author, last updated time and more.


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Data.Items ► Item ► SyncRoot
Gets the sync root.
Declaration Syntax
C#
public Object SyncRoot { get; }
Value
The sync root.


Template Property

Template Property
Namespaces ► Sitecore.Data.Items ► Item ► Template
Gets the template of the item.
Declaration Syntax
C#
public TemplateItem Template { get; }
Value
The template.


TemplateID Property

TemplateID Property
Namespaces ► Sitecore.Data.Items ► Item ► TemplateID
Gets the ID of the template.
Declaration Syntax
C#
public ID TemplateID { get; set; }
Value
The template ID.


TemplateName Property

TemplateName Property
Namespaces ► Sitecore.Data.Items ► Item ► TemplateName
Gets the name of the template.
Declaration Syntax
C#
public string TemplateName { get; }
Value
The name of the template.


Uri Property

Uri Property
Namespaces ► Sitecore.Data.Items ► Item ► Uri
Gets an URI for the item.
Declaration Syntax
C#
public ItemUri Uri { get; }
Value
The URI.


Version Property

Version Property
Namespaces ► Sitecore.Data.Items ► Item ► Version
Gets the version represented by this item.
Declaration Syntax
C#
public Version Version { get; }
Value
The version.


Versions Property

Versions Property
Namespaces ► Sitecore.Data.Items ► Item ► Versions
Provides access to different versions of the item.
Declaration Syntax
C#
public ItemVersions Versions { get; }
Value
The versions.


Visualization Property

Visualization Property
Namespaces ► Sitecore.Data.Items ► Item ► Visualization
Provides access to the visible representations of the item.
Declaration Syntax
C#
public ItemVisualization Visualization { get; }
Value
The visualization.
Remarks
Visible representation is usually the layout of the item.


Item.ItemDebuggerTypeProxy Class

Item..::.ItemDebuggerTypeProxy Class
Namespaces ► Sitecore.Data.Items ► Item ► Item..::.ItemDebuggerTypeProxy
ItemDebuggerTypeProxy class
Declaration Syntax
C#
public class ItemDebuggerTypeProxy
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Item..::.ItemDebuggerTypeProxy(Item) | Initializes a new instance of the Item..::.ItemDebuggerTypeProxy class.
 | Database | Gets the database name.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the item id.
 | Language | Gets the item language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the item name.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | Gets the item version.
Inheritance Hierarchy
Object
Item..::.ItemDebuggerTypeProxy


Item.ItemDebuggerTypeProxy Constructor (item)

Item..::.ItemDebuggerTypeProxy Constructor (item)
Namespaces ► Sitecore.Data.Items ► Item..::.ItemDebuggerTypeProxy ► Item..::.ItemDebuggerTypeProxy(Item)
Initializes a new instance of the Item..::.ItemDebuggerTypeProxy class.
Declaration Syntax
C#
public ItemDebuggerTypeProxy(
    Item item
)
Parameters
item (Item)
The item.


Database Property

Database Property
Namespaces ► Sitecore.Data.Items ► Item..::.ItemDebuggerTypeProxy ► Database
Gets the database name.
Declaration Syntax
C#
public string Database { get; }
Value
The database.


Id Property

Id Property
Namespaces ► Sitecore.Data.Items ► Item..::.ItemDebuggerTypeProxy ► Id
Gets the item id.
Declaration Syntax
C#
public string Id { get; }
Value
The id.


Language Property

Language Property
Namespaces ► Sitecore.Data.Items ► Item..::.ItemDebuggerTypeProxy ► Language
Gets the item language.
Declaration Syntax
C#
public string Language { get; }
Value
The language.


Name Property

Name Property
Namespaces ► Sitecore.Data.Items ► Item..::.ItemDebuggerTypeProxy ► Name
Gets the item name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Version Property

Version Property
Namespaces ► Sitecore.Data.Items ► Item..::.ItemDebuggerTypeProxy ► Version
Gets the item version.
Declaration Syntax
C#
public string Version { get; }
Value
The version.


ItemAppearance Class

ItemAppearance Class
Namespaces ► Sitecore.Data.Items ► ItemAppearance
Defines the appearance of the item.
Declaration Syntax
C#
public class ItemAppearance : Appearance
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemAppearance(Item) | Initializes a ItemAppearance class for an item.
 | ContextMenu | Gets or sets the context menu.
 | CustomEditor | Obsolete. Gets or sets the custom editor.
 | DisplayName | Gets or sets the display name. (Overrides Appearance.DisplayName.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HelpLink | Gets or sets the help link. (Inherited from Appearance.)
 | Hidden | Gets or sets a value indicating whether this Item is hidden.
 | Icon | Gets the path to the icon file. (Overrides Appearance.Icon.)
 | LongDescription | Gets or sets the long description. (Inherited from Appearance.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadOnly | Gets or sets a value indicating whether this Item is read-only.
 | Ribbon | Gets or sets the ribbon.
 | ShortDescription | Gets or sets the short description. (Inherited from Appearance.)
 | Skin | Gets the skin.
 | Sortorder | Gets or sets the sortorder.
 | Style | Gets the CSS style for the item. (Overrides Appearance.Style.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

Appearance defines how the item appears in the Sitecore client.

The %Icon% property provides the item with a graphical representation.

The Style property defines the CSS style that is applied to item when displayed in the content tree.

Inheritance Hierarchy
Object
 | Appearance
 |  | ItemAppearance


ItemAppearance Constructor (item)

ItemAppearance Constructor (item)
Namespaces ► Sitecore.Data.Items ► ItemAppearance ► ItemAppearance(Item)
Initializes a ItemAppearance class for an item.
Declaration Syntax
C#
public ItemAppearance(
    Item item
)
Parameters
item (Item)


ContextMenu Property

ContextMenu Property
Namespaces ► Sitecore.Data.Items ► ItemAppearance ► ContextMenu
Gets or sets the context menu.
Declaration Syntax
C#
public string ContextMenu { get; set; }
Value
The context menu.


CustomEditor Property

CustomEditor Property
Namespaces ► Sitecore.Data.Items ► ItemAppearance ► CustomEditor
Gets or sets the custom editor.
Declaration Syntax
C#
[ObsoleteAttribute("Use Editors instead.")]
public string CustomEditor { get; set; }
Value
The custom editor.


DisplayName Property

DisplayName Property
Namespaces ► Sitecore.Data.Items ► ItemAppearance ► DisplayName
Gets or sets the display name.
Declaration Syntax
C#
public override string DisplayName { get; set; }
Value


Hidden Property

Hidden Property
Namespaces ► Sitecore.Data.Items ► ItemAppearance ► Hidden
Gets or sets a value indicating whether this Item is hidden.
Declaration Syntax
C#
public bool Hidden { get; set; }
Value
true if hidden; otherwise, false.


Icon Property

Icon Property
Namespaces ► Sitecore.Data.Items ► ItemAppearance ► Icon
Gets the path to the icon file.
Declaration Syntax
C#
public override string Icon { get; set; }
Remarks
This can be a themed path, e.g. "Applications/16x16/About.png", or an absolute path, e.g. "/sitecore/shell/Themes/Standard/Applications/16x16/About.png". The value is get from item's field, but information about database of an item is being added automatically


ReadOnly Property

ReadOnly Property
Namespaces ► Sitecore.Data.Items ► ItemAppearance ► ReadOnly
Gets or sets a value indicating whether this Item is read-only.
Declaration Syntax
C#
public bool ReadOnly { get; set; }
Value
true if read-only; otherwise, false.


Ribbon Property

Ribbon Property
Namespaces ► Sitecore.Data.Items ► ItemAppearance ► Ribbon
Gets or sets the ribbon.
Declaration Syntax
C#
public string Ribbon { get; set; }
Value
The ribbon.


Skin Property

Skin Property
Namespaces ► Sitecore.Data.Items ► ItemAppearance ► Skin
Gets the skin.
Declaration Syntax
C#
public string Skin { get; }
Value
The skin.


Sortorder Property

Sortorder Property
Namespaces ► Sitecore.Data.Items ► ItemAppearance ► Sortorder
Gets or sets the sortorder.
Declaration Syntax
C#
public virtual int Sortorder { get; set; }
Value
The sortorder.


Style Property

Style Property
Namespaces ► Sitecore.Data.Items ► ItemAppearance ► Style
Gets the CSS style for the item.
Declaration Syntax
C#
public override string Style { get; set; }
Value
Remarks
This must be a valid CSS style string, e.g. "color:red; font-weight:bold".


ItemAxes Class

ItemAxes Class
Namespaces ► Sitecore.Data.Items ► ItemAxes
Provides access to other items relative to a source item.
Declaration Syntax
C#
public class ItemAxes
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemAxes(Item) | Initializes a new ItemAxes object.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAncestor(ID, Boolean) | Gets an ancestor item.
 | GetAncestors()()() | Gets all ancestors.
 | GetChild(String) | Gets a child item.
 | GetChild(ID) | Gets a child item.
 | GetDescendant(String) | Gets an item that is in the descendants axis of the source item.
 | GetDescendants()()() | Gets a list of items that is in descendant axis of the source item.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(String) | Gets an item relative to the source item.
 | GetNextSibling()()() | Gets the next item in the sibling axis.
 | GetPreviousSibling()()() | Gets the previous item in the sibling axis.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAncestorOf(Item) | Tests if the source item is an ancestor of an item (or the item itself).
 | IsDecendantOf(Item) | Obsolete. Tests if the source item is a descendant of an item.
 | IsDescendantOf(Item) | Determines whether if the item is a descendant of the specified item.
 | Level | Gets the number of parents of the source item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Root | Gets the root item of the items database.
 | SelectItems(String) | Performs a Sitecore XPath query using the source item as context item.
 | SelectSingleItem(String) | Performs a Sitecore XPath query using the source item as context item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

Implements the Axes property.

You should never instantiate this class.

Inheritance Hierarchy
Object
ItemAxes


ItemAxes Constructor (item)

ItemAxes Constructor (item)
Namespaces ► Sitecore.Data.Items ► ItemAxes ► ItemAxes(Item)
Initializes a new ItemAxes object.
Declaration Syntax
C#
public ItemAxes(
    Item item
)
Parameters
item (Item)
The item.


GetAncestor Method (itemID, includeSelf)

GetAncestor Method (itemID, includeSelf)
Namespaces ► Sitecore.Data.Items ► ItemAxes ► GetAncestor(ID, Boolean)
Gets an ancestor item.
Declaration Syntax
C#
public Item GetAncestor(
    ID itemID,
    bool includeSelf
)
Parameters
itemID (ID)
The item ID.
includeSelf (Boolean)
if set to true this instance is include self.
Return Value
The ancestor.


GetAncestors Method

GetAncestors Method
Namespaces ► Sitecore.Data.Items ► ItemAxes ► GetAncestors()()()
Gets all ancestors.
Declaration Syntax
C#
public Item[] GetAncestors()
Return Value
The ancestors.


GetChild Method

GetChild Method
Namespaces ► Sitecore.Data.Items ► ItemAxes ► GetChild()()()
Members
Icon | Member | Description
 | GetChild(String) | Gets a child item.
 | GetChild(ID) | Gets a child item.


GetChild Method (childID)

GetChild Method (childID)
Namespaces ► Sitecore.Data.Items ► ItemAxes ► GetChild(ID)
Gets a child item.
Declaration Syntax
C#
public Item GetChild(
    ID childID
)
Parameters
childID (ID)
The child ID.
Return Value
The child.


GetChild Method (itemName)

GetChild Method (itemName)
Namespaces ► Sitecore.Data.Items ► ItemAxes ► GetChild(String)
Gets a child item.
Declaration Syntax
C#
public Item GetChild(
    string itemName
)
Parameters
itemName (String)
Name of the item.
Return Value
The child.


GetDescendant Method (name)

GetDescendant Method (name)
Namespaces ► Sitecore.Data.Items ► ItemAxes ► GetDescendant(String)
Gets an item that is in the descendants axis of the source item.
Declaration Syntax
C#
public Item GetDescendant(
    string name
)
Parameters
name (String)
The name.
Return Value
The descendant.


GetDescendants Method

GetDescendants Method
Namespaces ► Sitecore.Data.Items ► ItemAxes ► GetDescendants()()()
Gets a list of items that is in descendant axis of the source item.
Declaration Syntax
C#
public Item[] GetDescendants()
Return Value
The descendants.


GetItem Method (path)

GetItem Method (path)
Namespaces ► Sitecore.Data.Items ► ItemAxes ► GetItem(String)
Gets an item relative to the source item.
Declaration Syntax
C#
public Item GetItem(
    string path
)
Parameters
path (String)
The path.
Return Value
The item.
Remarks
The path can be a relative path. In that case the path of the source item is prepend to the path before the item is retrieved.


GetNextSibling Method

GetNextSibling Method
Namespaces ► Sitecore.Data.Items ► ItemAxes ► GetNextSibling()()()
Gets the next item in the sibling axis.
Declaration Syntax
C#
public Item GetNextSibling()
Return Value
The next sibling.


GetPreviousSibling Method

GetPreviousSibling Method
Namespaces ► Sitecore.Data.Items ► ItemAxes ► GetPreviousSibling()()()
Gets the previous item in the sibling axis.
Declaration Syntax
C#
public Item GetPreviousSibling()
Return Value
The previous sibling.


IsAncestorOf Method (item)

IsAncestorOf Method (item)
Namespaces ► Sitecore.Data.Items ► ItemAxes ► IsAncestorOf(Item)
Tests if the source item is an ancestor of an item (or the item itself).
Declaration Syntax
C#
public bool IsAncestorOf(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if [is ancestor of] [the specified item]; otherwise, false.


IsDecendantOf Method (item)

IsDecendantOf Method (item)
Namespaces ► Sitecore.Data.Items ► ItemAxes ► IsDecendantOf(Item)
Tests if the source item is a descendant of an item.
Declaration Syntax
C#
[ObsoleteAttribute("Use IsDescendantOf method instead.")]
public bool IsDecendantOf(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if [is decendant of] [the specified item]; otherwise, false.


IsDescendantOf Method (item)

IsDescendantOf Method (item)
Namespaces ► Sitecore.Data.Items ► ItemAxes ► IsDescendantOf(Item)
Determines whether if the item is a descendant of the specified item.
Declaration Syntax
C#
public bool IsDescendantOf(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the item is a descendant of the specified item; otherwise, false.


Level Property

Level Property
Namespaces ► Sitecore.Data.Items ► ItemAxes ► Level
Gets the number of parents of the source item.
Declaration Syntax
C#
public int Level { get; }
Value
The level.


Root Property

Root Property
Namespaces ► Sitecore.Data.Items ► ItemAxes ► Root
Gets the root item of the items database.
Declaration Syntax
C#
public Item Root { get; }
Value
The root.


SelectItems Method (query)

SelectItems Method (query)
Namespaces ► Sitecore.Data.Items ► ItemAxes ► SelectItems(String)
Performs a Sitecore XPath query using the source item as context item.
Declaration Syntax
C#
public Item[] SelectItems(
    string query
)
Parameters
query (String)
The query.
Return Value
The items.


SelectSingleItem Method (query)

SelectSingleItem Method (query)
Namespaces ► Sitecore.Data.Items ► ItemAxes ► SelectSingleItem(String)
Performs a Sitecore XPath query using the source item as context item.
Declaration Syntax
C#
public Item SelectSingleItem(
    string query
)
Parameters
query (String)
The query.
Return Value
The single item.


ItemChanges Class

ItemChanges Class
Namespaces ► Sitecore.Data.Items ► ItemChanges
ItemChanges
Declaration Syntax
C#
public class ItemChanges
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemChanges(Item) | Initializes a new instance of the ItemChanges class.
 | Clone(Item) | Clones the specified owner.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldChanges | Gets the field changes.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldValue(Field) | Gets the field value.
 | GetFieldValue(ID) | Gets the field value.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPropertyValue(String) | Gets the property value.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasFieldsChanged | Gets a value indicating whether this instance has fields changed.
 | HasPropertiesChanged | Gets a value indicating whether this instance has properties changed.
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | IsFieldModified(Field) | Determines whether [is field modified] [the specified field].
 | IsFieldModified(ID) | Determines whether [is field modified] [the specified field ID].
 | IsPropertyModified(String) | Determines whether [is property modified] [the specified property name].
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PropertyChanges | Gets the property changes.
 | Renamed | Gets a value indicating if the item was renamed (ie. the Name was changed).
 | SetFieldValue(Field, String) | Sets the field value.
 | SetPropertyValue(String, ID) | Sets the property value.
 | SetPropertyValue(String, String) | Sets the property value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemChanges


ItemChanges Constructor (item)

ItemChanges Constructor (item)
Namespaces ► Sitecore.Data.Items ► ItemChanges ► ItemChanges(Item)
Initializes a new instance of the ItemChanges class.
Declaration Syntax
C#
public ItemChanges(
    Item item
)
Parameters
item (Item)


Clone Method (owner)

Clone Method (owner)
Namespaces ► Sitecore.Data.Items ► ItemChanges ► Clone(Item)
Clones the specified owner.
Declaration Syntax
C#
public ItemChanges Clone(
    Item owner
)
Parameters
owner (Item)
The owner.
Return Value
The clone.


FieldChanges Property

FieldChanges Property
Namespaces ► Sitecore.Data.Items ► ItemChanges ► FieldChanges
Gets the field changes.
Declaration Syntax
C#
public FieldChangeList FieldChanges { get; }
Value
The field changes.


GetFieldValue Method

GetFieldValue Method
Namespaces ► Sitecore.Data.Items ► ItemChanges ► GetFieldValue()()()
Members
Icon | Member | Description
 | GetFieldValue(Field) | Gets the field value.
 | GetFieldValue(ID) | Gets the field value.


GetFieldValue Method (field)

GetFieldValue Method (field)
Namespaces ► Sitecore.Data.Items ► ItemChanges ► GetFieldValue(Field)
Gets the field value.
Declaration Syntax
C#
public string GetFieldValue(
    Field field
)
Parameters
field (Field)
The field.
Return Value
The field value.


GetFieldValue Method (fieldId)

GetFieldValue Method (fieldId)
Namespaces ► Sitecore.Data.Items ► ItemChanges ► GetFieldValue(ID)
Gets the field value.
Declaration Syntax
C#
public string GetFieldValue(
    ID fieldId
)
Parameters
fieldId (ID)
The field id.
Return Value
The field value.


GetPropertyValue Method (propertyName)

GetPropertyValue Method (propertyName)
Namespaces ► Sitecore.Data.Items ► ItemChanges ► GetPropertyValue(String)
Gets the property value.
Declaration Syntax
C#
public Object GetPropertyValue(
    string propertyName
)
Parameters
propertyName (String)
Name of the property.
Return Value
The property value.


HasFieldsChanged Property

HasFieldsChanged Property
Namespaces ► Sitecore.Data.Items ► ItemChanges ► HasFieldsChanged
Gets a value indicating whether this instance has fields changed.
Declaration Syntax
C#
public bool HasFieldsChanged { get; }
Value
true if this instance has fields changed; otherwise, false.


HasPropertiesChanged Property

HasPropertiesChanged Property
Namespaces ► Sitecore.Data.Items ► ItemChanges ► HasPropertiesChanged
Gets a value indicating whether this instance has properties changed.
Declaration Syntax
C#
public bool HasPropertiesChanged { get; }
Value
true if this instance has properties changed; otherwise, false.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Data.Items ► ItemChanges ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


IsFieldModified Method

IsFieldModified Method
Namespaces ► Sitecore.Data.Items ► ItemChanges ► IsFieldModified()()()
Members
Icon | Member | Description
 | IsFieldModified(Field) | Determines whether [is field modified] [the specified field].
 | IsFieldModified(ID) | Determines whether [is field modified] [the specified field ID].


IsFieldModified Method (field)

IsFieldModified Method (field)
Namespaces ► Sitecore.Data.Items ► ItemChanges ► IsFieldModified(Field)
Determines whether [is field modified] [the specified field].
Declaration Syntax
C#
public bool IsFieldModified(
    Field field
)
Parameters
field (Field)
The field.
Return Value
true if [is field modified] [the specified field]; otherwise, false.


IsFieldModified Method (fieldID)

IsFieldModified Method (fieldID)
Namespaces ► Sitecore.Data.Items ► ItemChanges ► IsFieldModified(ID)
Determines whether [is field modified] [the specified field ID].
Declaration Syntax
C#
public bool IsFieldModified(
    ID fieldID
)
Parameters
fieldID (ID)
The field ID.
Return Value
true if [is field modified] [the specified field ID]; otherwise, false.


IsPropertyModified Method (propertyName)

IsPropertyModified Method (propertyName)
Namespaces ► Sitecore.Data.Items ► ItemChanges ► IsPropertyModified(String)
Determines whether [is property modified] [the specified property name].
Declaration Syntax
C#
public bool IsPropertyModified(
    string propertyName
)
Parameters
propertyName (String)
Name of the property.
Return Value
true if [is property modified] [the specified property name]; otherwise, false.


Item Property

Item Property
Namespaces ► Sitecore.Data.Items ► ItemChanges ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


PropertyChanges Property

PropertyChanges Property
Namespaces ► Sitecore.Data.Items ► ItemChanges ► PropertyChanges
Gets the property changes.
Declaration Syntax
C#
public Hashtable PropertyChanges { get; }
Value
The property changes.


Renamed Property

Renamed Property
Namespaces ► Sitecore.Data.Items ► ItemChanges ► Renamed
Gets a value indicating if the item was renamed (ie. the Name was changed).
Declaration Syntax
C#
public bool Renamed { get; }
Value
true if renamed; otherwise, false.


SetFieldValue Method (field, value)

SetFieldValue Method (field, value)
Namespaces ► Sitecore.Data.Items ► ItemChanges ► SetFieldValue(Field, String)
Sets the field value.
Declaration Syntax
C#
public void SetFieldValue(
    Field field,
    string value
)
Parameters
field (Field)
The field.
value (String)
The value.


SetPropertyValue Method

SetPropertyValue Method
Namespaces ► Sitecore.Data.Items ► ItemChanges ► SetPropertyValue()()()
Members
Icon | Member | Description
 | SetPropertyValue(String, ID) | Sets the property value.
 | SetPropertyValue(String, String) | Sets the property value.


SetPropertyValue Method (propertyName, value)

SetPropertyValue Method (propertyName, value)
Namespaces ► Sitecore.Data.Items ► ItemChanges ► SetPropertyValue(String, ID)
Sets the property value.
Declaration Syntax
C#
public void SetPropertyValue(
    string propertyName,
    ID value
)
Parameters
propertyName (String)
Name of the property.
value (ID)
The value.


SetPropertyValue Method (propertyName, value)

SetPropertyValue Method (propertyName, value)
Namespaces ► Sitecore.Data.Items ► ItemChanges ► SetPropertyValue(String, String)
Sets the property value.
Declaration Syntax
C#
public void SetPropertyValue(
    string propertyName,
    string value
)
Parameters
propertyName (String)
Name of the property.
value (String)
The value.


ItemEditing Class

ItemEditing Class
Namespaces ► Sitecore.Data.Items ► ItemEditing
Retrieves information about the editing of a source item.
Declaration Syntax
C#
public class ItemEditing
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemEditing(Item) | Creates a new ItemPublishing instance.
 | AcceptChanges()()() | Accepts the changes.
 | AcceptChanges(Boolean, Boolean) | Ends an edit operation.
 | AssertEditing()()() | Asserts the editing.
 | BeginEdit()()() | Marks the beginning of an editing operation.
 | CancelEdit()()() | Cancels the edit.
 | Clone(Item) | Clones this instance.
 | EndEdit()()() | Ends an edit operation.
 | EndEdit(Boolean) | Ends the edit.
 | EndEdit(Boolean, Boolean) | Ends an edit operation.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEditing | Gets a value that indicates if the item is being edited.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RejectChanges()()() | Rejects the changes.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemEditing


ItemEditing Constructor (item)

ItemEditing Constructor (item)
Namespaces ► Sitecore.Data.Items ► ItemEditing ► ItemEditing(Item)
Creates a new ItemPublishing instance.
Declaration Syntax
C#
public ItemEditing(
    Item item
)
Parameters
item (Item)
The item.


AcceptChanges Method

AcceptChanges Method
Namespaces ► Sitecore.Data.Items ► ItemEditing ► AcceptChanges()()()
Members
Icon | Member | Description
 | AcceptChanges()()() | Accepts the changes.
 | AcceptChanges(Boolean, Boolean) | Ends an edit operation.


AcceptChanges Method

AcceptChanges Method
Namespaces ► Sitecore.Data.Items ► ItemEditing ► AcceptChanges()()()
Accepts the changes.
Declaration Syntax
C#
public bool AcceptChanges()
Return Value
The changes.


AcceptChanges Method (updateStatistics, silent)

AcceptChanges Method (updateStatistics, silent)
Namespaces ► Sitecore.Data.Items ► ItemEditing ► AcceptChanges(Boolean, Boolean)
Ends an edit operation.
Declaration Syntax
C#
public bool AcceptChanges(
    bool updateStatistics,
    bool silent
)
Parameters
updateStatistics (Boolean)
if set to true this instance is update statistics.
silent (Boolean)
if set to true this instance is silent.
Return Value
The changes.
Remarks

Editing an item without calling BeginEdit throws an exception.

It is usually easier and more readable to using the EditContext class instead of a BeginEdit and EndEdit pair.


AssertEditing Method

AssertEditing Method
Namespaces ► Sitecore.Data.Items ► ItemEditing ► AssertEditing()()()
Asserts the editing.
Declaration Syntax
C#
public void AssertEditing()


BeginEdit Method

BeginEdit Method
Namespaces ► Sitecore.Data.Items ► ItemEditing ► BeginEdit()()()
Marks the beginning of an editing operation.
Declaration Syntax
C#
public void BeginEdit()


CancelEdit Method

CancelEdit Method
Namespaces ► Sitecore.Data.Items ► ItemEditing ► CancelEdit()()()
Cancels the edit.
Declaration Syntax
C#
public void CancelEdit()


Clone Method (owner)

Clone Method (owner)
Namespaces ► Sitecore.Data.Items ► ItemEditing ► Clone(Item)
Clones this instance.
Declaration Syntax
C#
public ItemEditing Clone(
    Item owner
)
Parameters
owner (Item)
The owner item.
Return Value


EndEdit Method

EndEdit Method
Namespaces ► Sitecore.Data.Items ► ItemEditing ► EndEdit()()()
Members
Icon | Member | Description
 | EndEdit()()() | Ends an edit operation.
 | EndEdit(Boolean) | Ends the edit.
 | EndEdit(Boolean, Boolean) | Ends an edit operation.


EndEdit Method

EndEdit Method
Namespaces ► Sitecore.Data.Items ► ItemEditing ► EndEdit()()()
Ends an edit operation.
Declaration Syntax
C#
public bool EndEdit()
Return Value
The edit.
Remarks

Editing an item without calling BeginEdit throws an exception.

It is usually easier and more readable to using the EditContext class instead of a BeginEdit and EndEdit pair.


EndEdit Method (silent)

EndEdit Method (silent)
Namespaces ► Sitecore.Data.Items ► ItemEditing ► EndEdit(Boolean)
Ends the edit.
Declaration Syntax
C#
public bool EndEdit(
    bool silent
)
Parameters
silent (Boolean)
If set to true, no events will be raised due to saving.
Return Value


EndEdit Method (updateStatistics, silent)

EndEdit Method (updateStatistics, silent)
Namespaces ► Sitecore.Data.Items ► ItemEditing ► EndEdit(Boolean, Boolean)
Ends an edit operation.
Declaration Syntax
C#
public bool EndEdit(
    bool updateStatistics,
    bool silent
)
Parameters
updateStatistics (Boolean)
if set to true this instance is update statistics.
silent (Boolean)
if set to true this instance is silent.
Return Value
The edit.
Remarks

Editing an item without calling BeginEdit throws an exception.

It is usually easier and more readable to using the EditContext class instead of a BeginEdit and EndEdit pair.


IsEditing Property

IsEditing Property
Namespaces ► Sitecore.Data.Items ► ItemEditing ► IsEditing
Gets a value that indicates if the item is being edited.
Declaration Syntax
C#
public bool IsEditing { get; }
Value
true if this instance is editing; otherwise, false.


RejectChanges Method

RejectChanges Method
Namespaces ► Sitecore.Data.Items ► ItemEditing ► RejectChanges()()()
Rejects the changes.
Declaration Syntax
C#
public void RejectChanges()


ItemHelp Class

ItemHelp Class
Namespaces ► Sitecore.Data.Items ► ItemHelp
Contains help information for a source item.
Declaration Syntax
C#
public class ItemHelp
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemHelp(Item) | Creates a new ItemHelp instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Link | Gets or sets the help link.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text | Gets or sets the text (long description).
 | ToolTip | Gets or sets the tool tip.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

The help information includes:

  • Short description (ToolTip)
  • Long description (Description)
  • Link
Inheritance Hierarchy
Object
ItemHelp


ItemHelp Constructor (item)

ItemHelp Constructor (item)
Namespaces ► Sitecore.Data.Items ► ItemHelp ► ItemHelp(Item)
Creates a new ItemHelp instance.
Declaration Syntax
C#
public ItemHelp(
    Item item
)
Parameters
item (Item)
Source item.


Link Property

Link Property
Namespaces ► Sitecore.Data.Items ► ItemHelp ► Link
Gets or sets the help link.
Declaration Syntax
C#
public string Link { get; set; }
Value
The link.


Text Property

Text Property
Namespaces ► Sitecore.Data.Items ► ItemHelp ► Text
Gets or sets the text (long description).
Declaration Syntax
C#
public string Text { get; set; }
Value
The text.


ToolTip Property

ToolTip Property
Namespaces ► Sitecore.Data.Items ► ItemHelp ► ToolTip
Gets or sets the tool tip.
Declaration Syntax
C#
public string ToolTip { get; set; }
Value
The tool tip.


ItemPathType Enumeration

ItemPathType Enumeration
Namespaces ► Sitecore.Data.Items ► ItemPathType
Specifies how the path is constructed.
Declaration Syntax
C#
public enum ItemPathType
Members
Member | Description
ItemID | Path of IDs.
Key | Path of keys (lowercase name).
Name | Path of names.
DisplayName | Path of display names.


ItemPublishing Class

ItemPublishing Class
Namespaces ► Sitecore.Data.Items ► ItemPublishing
Retrieves information about the publishing of a source item.
Declaration Syntax
C#
public class ItemPublishing
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemPublishing(Item) | Creates a new ItemPublishing instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValidVersion(DateTime, Boolean) | Gets the valid version on a specific date.
 | GetValidVersion(DateTime, Boolean, Boolean) | Gets the valid version on a specific date.
 | GetVisibleInterval(DateTime, Boolean) | Gets the interval around date for which the current item version is potentially visible (i.e. published).
 | HideVersion | Gets or sets a value indicating whether the version can be published.
 | IsPublishable(DateTime, Boolean) | Determines whether the item is publishable on a specified date.
 | IsValid(DateTime, Boolean) | Determines whether the version is valid on a specified date.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NeverPublish | Gets or sets a value indicating whether the entire item can be published.
 | PublishDate | Gets or sets the publish date of the entire item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnpublishDate | Gets or sets the unpublish date of the entire item.
 | ValidFrom | Gets or sets the valid from date of the version.
 | ValidTo | Gets or sets the valid to date of the version.
Inheritance Hierarchy
Object
ItemPublishing


ItemPublishing Constructor (item)

ItemPublishing Constructor (item)
Namespaces ► Sitecore.Data.Items ► ItemPublishing ► ItemPublishing(Item)
Creates a new ItemPublishing instance.
Declaration Syntax
C#
public ItemPublishing(
    Item item
)
Parameters
item (Item)
The item.


GetValidVersion Method

GetValidVersion Method
Namespaces ► Sitecore.Data.Items ► ItemPublishing ► GetValidVersion()()()
Members
Icon | Member | Description
 | GetValidVersion(DateTime, Boolean) | Gets the valid version on a specific date.
 | GetValidVersion(DateTime, Boolean, Boolean) | Gets the valid version on a specific date.


GetValidVersion Method (date, requireApproved)

GetValidVersion Method (date, requireApproved)
Namespaces ► Sitecore.Data.Items ► ItemPublishing ► GetValidVersion(DateTime, Boolean)
Gets the valid version on a specific date.
Declaration Syntax
C#
public Item GetValidVersion(
    DateTime date,
    bool requireApproved
)
Parameters
date (DateTime)
Date.
requireApproved (Boolean)
Require that the version is approved.
Return Value
The valid version.


GetValidVersion Method (date, requireApproved, allowEmpty)

GetValidVersion Method (date, requireApproved, allowEmpty)
Namespaces ► Sitecore.Data.Items ► ItemPublishing ► GetValidVersion(DateTime, Boolean, Boolean)
Gets the valid version on a specific date.
Declaration Syntax
C#
public Item GetValidVersion(
    DateTime date,
    bool requireApproved,
    bool allowEmpty
)
Parameters
date (DateTime)
Date.
requireApproved (Boolean)
Require that the version is approved.
allowEmpty (Boolean)
If set to true allow an empty item to be returned.
Return Value
The valid version.


GetVisibleInterval Method (date, checkAncestors)

GetVisibleInterval Method (date, checkAncestors)
Namespaces ► Sitecore.Data.Items ► ItemPublishing ► GetVisibleInterval(DateTime, Boolean)
Gets the interval around date for which the current item version is potentially visible (i.e. published).
Declaration Syntax
C#
public DateTimeRange GetVisibleInterval(
    DateTime date,
    bool checkAncestors
)
Parameters
date (DateTime)
checkAncestors (Boolean)
Return Value


HideVersion Property

HideVersion Property
Namespaces ► Sitecore.Data.Items ► ItemPublishing ► HideVersion
Gets or sets a value indicating whether the version can be published.
Declaration Syntax
C#
public bool HideVersion { get; set; }
Value
true if the version can be published; otherwise, false.


IsPublishable Method (date, checkAncestors)

IsPublishable Method (date, checkAncestors)
Namespaces ► Sitecore.Data.Items ► ItemPublishing ► IsPublishable(DateTime, Boolean)
Determines whether the item is publishable on a specified date.
Declaration Syntax
C#
public bool IsPublishable(
    DateTime date,
    bool checkAncestors
)
Parameters
date (DateTime)
Date.
checkAncestors (Boolean)
Check if ancestors are publishable.
Return Value
true if the item is publishable on a specified date; otherwise, false.


IsValid Method (date, requireApproved)

IsValid Method (date, requireApproved)
Namespaces ► Sitecore.Data.Items ► ItemPublishing ► IsValid(DateTime, Boolean)
Determines whether the version is valid on a specified date.
Declaration Syntax
C#
public bool IsValid(
    DateTime date,
    bool requireApproved
)
Parameters
date (DateTime)
Date.
requireApproved (Boolean)
Require that the version is approved.
Return Value
true if the version is valid on the specified date; otherwise, false.


NeverPublish Property

NeverPublish Property
Namespaces ► Sitecore.Data.Items ► ItemPublishing ► NeverPublish
Gets or sets a value indicating whether the entire item can be published.
Declaration Syntax
C#
public bool NeverPublish { get; set; }
Value
true if the item cannot be published; otherwise, false.


PublishDate Property

PublishDate Property
Namespaces ► Sitecore.Data.Items ► ItemPublishing ► PublishDate
Gets or sets the publish date of the entire item.
Declaration Syntax
C#
public DateTime PublishDate { get; set; }
Value
The publish date.


UnpublishDate Property

UnpublishDate Property
Namespaces ► Sitecore.Data.Items ► ItemPublishing ► UnpublishDate
Gets or sets the unpublish date of the entire item.
Declaration Syntax
C#
public DateTime UnpublishDate { get; set; }
Value
The unpublish date.


ValidFrom Property

ValidFrom Property
Namespaces ► Sitecore.Data.Items ► ItemPublishing ► ValidFrom
Gets or sets the valid from date of the version.
Declaration Syntax
C#
public DateTime ValidFrom { get; set; }
Value
The valid from.


ValidTo Property

ValidTo Property
Namespaces ► Sitecore.Data.Items ► ItemPublishing ► ValidTo
Gets or sets the valid to date of the version.
Declaration Syntax
C#
public DateTime ValidTo { get; set; }
Value
The valid to.


ItemRuntimeSettings Class

ItemRuntimeSettings Class
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings
Provides miscellaneous information about a source item.
Declaration Syntax
C#
public class ItemRuntimeSettings
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemRuntimeSettings(Item) | Creates a new ItemRuntimeSettings instance.
 | BrowseOnly | Gets a value indicating whether the item is in browse only mode.
 | Clone(Item) | Clones the specified owner.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | ForceModified | Gets or sets a value indicating whether to force Modified to return true.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Invalid | Gets a value indicating whether the owning Item is invalid.
 | IsExternal | Gets a value indicating whether this instance is external.
 | IsVirtual | Gets a value indicating whether this instance is virtual.
 | MakeBrowseOnly()()() | Marks the item as browse only.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OwnerDatabase | Gets or sets the owner database.
 | ProxyId | Gets or sets the proxy id.
 | ReadOnlyStatistics | Gets or sets a value indicating whether the item statistics are read-only.
 | SaveAll | Gets or sets a value indicating whether to save all data.
 | SetupVirtual(Boolean, Boolean) | Make nesessary, after changing IsVirtual property, changes.
 | SortOrder | Gets or sets the sort order.
 | TemplateDatabase | Gets the database to use when resolving the template for the item.
 | Temporary | Gets or sets a value indicating whether the item is temporary.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidFrom | Gets or sets the (UTC) date for which the item is valid from.
 | ValidTo | Gets or sets the (UTC) date for which the item is valid until.
Inheritance Hierarchy
Object
ItemRuntimeSettings


ItemRuntimeSettings Constructor (item)

ItemRuntimeSettings Constructor (item)
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► ItemRuntimeSettings(Item)
Creates a new ItemRuntimeSettings instance.
Declaration Syntax
C#
public ItemRuntimeSettings(
    Item item
)
Parameters
item (Item)
Source item.


BrowseOnly Property

BrowseOnly Property
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► BrowseOnly
Gets a value indicating whether the item is in browse only mode.
Declaration Syntax
C#
public bool BrowseOnly { get; }
Value
true if the item is in browse only mode; otherwise, false.


Clone Method (owner)

Clone Method (owner)
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► Clone(Item)
Clones the specified owner.
Declaration Syntax
C#
public ItemRuntimeSettings Clone(
    Item owner
)
Parameters
owner (Item)
The owner.
Return Value
The clone.


ForceModified Property

ForceModified Property
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► ForceModified
Gets or sets a value indicating whether to force Modified to return true.
Declaration Syntax
C#
public bool ForceModified { get; set; }
Remarks
If false, the property will be ignored.


Invalid Property

Invalid Property
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► Invalid
Gets a value indicating whether the owning Item is invalid.
Declaration Syntax
C#
public bool Invalid { get; set; }
Value
true if invalid; otherwise, false.


IsExternal Property

IsExternal Property
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► IsExternal
Gets a value indicating whether this instance is external.
Declaration Syntax
C#
public bool IsExternal { get; }
Value
true if this instance is external; otherwise, false.


IsVirtual Property

IsVirtual Property
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► IsVirtual
Gets a value indicating whether this instance is virtual.
Declaration Syntax
C#
public bool IsVirtual { get; set; }
Value
true if this instance is virtual; otherwise, false.


MakeBrowseOnly Method

MakeBrowseOnly Method
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► MakeBrowseOnly()()()
Marks the item as browse only.
Declaration Syntax
C#
public void MakeBrowseOnly()


OwnerDatabase Property

OwnerDatabase Property
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► OwnerDatabase
Gets or sets the owner database.
Declaration Syntax
C#
public Database OwnerDatabase { get; set; }
Value
The owner database.


ProxyId Property

ProxyId Property
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► ProxyId
Gets or sets the proxy id.
Declaration Syntax
C#
public ID ProxyId { get; set; }
Value
The proxy id.


ReadOnlyStatistics Property

ReadOnlyStatistics Property
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► ReadOnlyStatistics
Gets or sets a value indicating whether the item statistics are read-only.
Declaration Syntax
C#
public bool ReadOnlyStatistics { get; set; }
Value
true if the item statistics are read-only; otherwise, false.


SaveAll Property

SaveAll Property
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► SaveAll
Gets or sets a value indicating whether to save all data.
Declaration Syntax
C#
public bool SaveAll { get; set; }
Remarks
If false, only changed data will be saved.


SetupVirtual Method (isVitrualOld, isVirtualNew)

SetupVirtual Method (isVitrualOld, isVirtualNew)
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► SetupVirtual(Boolean, Boolean)
Make nesessary, after changing IsVirtual property, changes.
Declaration Syntax
C#
protected virtual void SetupVirtual(
    bool isVitrualOld,
    bool isVirtualNew
)
Parameters
isVitrualOld (Boolean)
old value of IsVirtual property.
isVirtualNew (Boolean)
new value of IsVirtual property.


SortOrder Property

SortOrder Property
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► SortOrder
Gets or sets the sort order.
Declaration Syntax
C#
public string SortOrder { get; set; }
Value
The sort order.


TemplateDatabase Property

TemplateDatabase Property
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► TemplateDatabase
Gets the database to use when resolving the template for the item.
Declaration Syntax
C#
public Database TemplateDatabase { get; set; }
Value
The template database.


Temporary Property

Temporary Property
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► Temporary
Gets or sets a value indicating whether the item is temporary.
Declaration Syntax
C#
public bool Temporary { get; set; }
Value
true if temporary; otherwise, false.


ValidFrom Property

ValidFrom Property
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► ValidFrom
Gets or sets the (UTC) date for which the item is valid from.
Declaration Syntax
C#
public DateTime ValidFrom { get; set; }
Value
The valid until.


ValidTo Property

ValidTo Property
Namespaces ► Sitecore.Data.Items ► ItemRuntimeSettings ► ValidTo
Gets or sets the (UTC) date for which the item is valid until.
Declaration Syntax
C#
public DateTime ValidTo { get; set; }
Value
The valid until.


ItemSerializer Class

ItemSerializer Class
Namespaces ► Sitecore.Data.Items ► ItemSerializer
Represents an item serializer.
Declaration Syntax
C#
public sealed class ItemSerializer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemSerializer()()() | Initializes a new instance of the ItemSerializer class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemXml(Item, Boolean) | Gets the item XML.
 | GetItemXml(Item, Boolean, Boolean) | Gets the item XML.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersionXml(Item) | Gets the version XML.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseItemXml(String, Database, Boolean) | Parses the item XML.
 | PasteItemXml(String, Item, Boolean, PasteMode) | Pastes the item XML.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemSerializer


ItemSerializer Constructor

ItemSerializer Constructor
Namespaces ► Sitecore.Data.Items ► ItemSerializer ► ItemSerializer()()()
Initializes a new instance of the ItemSerializer class
Declaration Syntax
C#
public ItemSerializer()


GetItemXml Method

GetItemXml Method
Namespaces ► Sitecore.Data.Items ► ItemSerializer ► GetItemXml()()()
Members
Icon | Member | Description
 | GetItemXml(Item, Boolean) | Gets the item XML.
 | GetItemXml(Item, Boolean, Boolean) | Gets the item XML.


GetItemXml Method (item, deep)

GetItemXml Method (item, deep)
Namespaces ► Sitecore.Data.Items ► ItemSerializer ► GetItemXml(Item, Boolean)
Gets the item XML.
Declaration Syntax
C#
public static string GetItemXml(
    Item item,
    bool deep
)
Parameters
item (Item)
The item.
deep (Boolean)
if set to true this instance is deep.
Return Value
The item XML.


GetItemXml Method (item, deep, includeBlobs)

GetItemXml Method (item, deep, includeBlobs)
Namespaces ► Sitecore.Data.Items ► ItemSerializer ► GetItemXml(Item, Boolean, Boolean)
Gets the item XML.
Declaration Syntax
C#
public static string GetItemXml(
    Item item,
    bool deep,
    bool includeBlobs
)
Parameters
item (Item)
The item.
deep (Boolean)
if set to true [deep].
includeBlobs (Boolean)
if set to true include blob fields in the result.
Return Value


GetVersionXml Method (item)

GetVersionXml Method (item)
Namespaces ► Sitecore.Data.Items ► ItemSerializer ► GetVersionXml(Item)
Gets the version XML.
Declaration Syntax
C#
public static string GetVersionXml(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The version XML.


ParseItemXml Method (xml, database, changeID)

ParseItemXml Method (xml, database, changeID)
Namespaces ► Sitecore.Data.Items ► ItemSerializer ► ParseItemXml(String, Database, Boolean)
Parses the item XML.
Declaration Syntax
C#
public static Item[] ParseItemXml(
    string xml,
    Database database,
    bool changeID
)
Parameters
xml (String)
The XML.
database (Database)
The database.
changeID (Boolean)
if set to true this instance is change ID.
Return Value
The item XML.


PasteItemXml Method (xml, target, changeIDs, mode)

PasteItemXml Method (xml, target, changeIDs, mode)
Namespaces ► Sitecore.Data.Items ► ItemSerializer ► PasteItemXml(String, Item, Boolean, PasteMode)
Pastes the item XML.
Declaration Syntax
C#
public static Item PasteItemXml(
    string xml,
    Item target,
    bool changeIDs,
    PasteMode mode
)
Parameters
xml (String)
The XML.
target (Item)
The target.
changeIDs (Boolean)
if set to true this instance is change I ds.
mode (PasteMode)
The mode.
Return Value
The item XML.


ItemState Class

ItemState Class
Namespaces ► Sitecore.Data.Items ► ItemState
Provides information about the workflow state of a source item.
Declaration Syntax
C#
public class ItemState
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemState(Item) | Creates a new ItemState instance.
 | CanEdit()()() | Determines whether the source item can be edited.
 | CanSave()()() | Determines whether the source item can be saved.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWorkflow()()() | Gets the workflow.
 | GetWorkflowState()()() | Gets the workflow state of the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemState


ItemState Constructor (item)

ItemState Constructor (item)
Namespaces ► Sitecore.Data.Items ► ItemState ► ItemState(Item)
Creates a new ItemState instance.
Declaration Syntax
C#
public ItemState(
    Item item
)
Parameters
item (Item)
Source item.


CanEdit Method

CanEdit Method
Namespaces ► Sitecore.Data.Items ► ItemState ► CanEdit()()()
Determines whether the source item can be edited.
Declaration Syntax
C#
public bool CanEdit()
Return Value
true if the source item can be edited; otherwise, false.


CanSave Method

CanSave Method
Namespaces ► Sitecore.Data.Items ► ItemState ► CanSave()()()
Determines whether the source item can be saved.
Declaration Syntax
C#
public bool CanSave()
Return Value
true if the source item can be saved; otherwise, false.


GetWorkflow Method

GetWorkflow Method
Namespaces ► Sitecore.Data.Items ► ItemState ► GetWorkflow()()()
Gets the workflow.
Declaration Syntax
C#
public IWorkflow GetWorkflow()
Return Value


GetWorkflowState Method

GetWorkflowState Method
Namespaces ► Sitecore.Data.Items ► ItemState ► GetWorkflowState()()()
Gets the workflow state of the item.
Declaration Syntax
C#
public WorkflowState GetWorkflowState()
Return Value


ItemStatistics Class

ItemStatistics Class
Namespaces ► Sitecore.Data.Items ► ItemStatistics
Provides information about changes to a source item.
Declaration Syntax
C#
public class ItemStatistics
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemStatistics(Item) | Creates a new ItemStatistics instance.
 | Created | Gets the creation date of the source item.
 | CreatedBy | Gets the original author of the source item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Revision | Gets the current revision of the source item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Updated | Gets the date of the latest update to the item.
 | UpdatedBy | Gets the author of the latest update.
 | UpdateRevision()()() | Updates the revision.
Inheritance Hierarchy
Object
ItemStatistics


ItemStatistics Constructor (item)

ItemStatistics Constructor (item)
Namespaces ► Sitecore.Data.Items ► ItemStatistics ► ItemStatistics(Item)
Creates a new ItemStatistics instance.
Declaration Syntax
C#
public ItemStatistics(
    Item item
)
Parameters
item (Item)
Item.


Created Property

Created Property
Namespaces ► Sitecore.Data.Items ► ItemStatistics ► Created
Gets the creation date of the source item.
Declaration Syntax
C#
public DateTime Created { get; }
Value
The created.


CreatedBy Property

CreatedBy Property
Namespaces ► Sitecore.Data.Items ► ItemStatistics ► CreatedBy
Gets the original author of the source item.
Declaration Syntax
C#
public string CreatedBy { get; }
Value
The created by.


Revision Property

Revision Property
Namespaces ► Sitecore.Data.Items ► ItemStatistics ► Revision
Gets the current revision of the source item.
Declaration Syntax
C#
public string Revision { get; }
Value
The revision.
Remarks
The revision is updated each time the source item is updated.


Updated Property

Updated Property
Namespaces ► Sitecore.Data.Items ► ItemStatistics ► Updated
Gets the date of the latest update to the item.
Declaration Syntax
C#
public DateTime Updated { get; }
Value
The updated.


UpdatedBy Property

UpdatedBy Property
Namespaces ► Sitecore.Data.Items ► ItemStatistics ► UpdatedBy
Gets the author of the latest update.
Declaration Syntax
C#
public string UpdatedBy { get; }
Value
The updated by.


UpdateRevision Method

UpdateRevision Method
Namespaces ► Sitecore.Data.Items ► ItemStatistics ► UpdateRevision()()()
Updates the revision.
Declaration Syntax
C#
public void UpdateRevision()


ItemUpdateType Enumeration

ItemUpdateType Enumeration
Namespaces ► Sitecore.Data.Items ► ItemUpdateType
Defines the type of update to an item.
Declaration Syntax
C#
public enum ItemUpdateType
Members
Member | Description
Added | Item was added.
Copied | Item was copied.
Created | Item was copied.
Deleted | Item was deleted.
Moved | Item was moved.
Saved | Item was saved.
VersionAdded | A version was added to the item.
VersionRemoved | A version was removed from the item.


ItemUtil Class

ItemUtil Class
Namespaces ► Sitecore.Data.Items ► ItemUtil
Provides miscellaneous functions that operates on an item.
Declaration Syntax
C#
public sealed class ItemUtil
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemUtil()()() | Initializes a new instance of the ItemUtil class
 | AddFromTemplate(String, String, Item) | Adds from template.
 | AssertItemName(String) | Asserts that the name of the item is valid.
 | CopyItem(Item, Item, Boolean, Boolean) | Copies the item.
 | DeleteItem(ID, Database) | Deletes an item.
 | DeleteItem(String, Database) | Deletes an item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildrenAt(String) | Gets the children at.
 | GetCopyOfName(Item, String) | Gets an item name that includes a "Copy of" text.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemFromPartialPath(String, Database) | Gets an item from a partial path.
 | GetItemID(String, Database) | Gets the item ID.
 | GetItemNameError(String) | Gets an error text for an item name.
 | GetLevel(Item) | Gets the level of an item.
 | GetParentID(Item) | Gets the parent ID of an item.
 | GetParentName(Item) | Gets the name of the parent of an item.
 | GetParentName(Item, Boolean) | Gets the name of the parent.
 | GetTemplateKey(Item) | Gets the template key.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsItemNameValid(String) | Determines whether an item name is valid.
 | IsNull(ID) | Determines whether the specified id is null.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProposeValidItemName(String) | Given a invalid itemname, proposes a new itemname where all invalid characters have been replased with an empty character.
 | ProposeValidItemName(String, String) | Given a invalid itemname, proposes a new itemname where all invalid characters have been replased with an empty character.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemUtil


ItemUtil Constructor

ItemUtil Constructor
Namespaces ► Sitecore.Data.Items ► ItemUtil ► ItemUtil()()()
Initializes a new instance of the ItemUtil class
Declaration Syntax
C#
public ItemUtil()


AddFromTemplate Method (itemName, templateName, parent)

AddFromTemplate Method (itemName, templateName, parent)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► AddFromTemplate(String, String, Item)
Adds from template.
Declaration Syntax
C#
public static Item AddFromTemplate(
    string itemName,
    string templateName,
    Item parent
)
Parameters
itemName (String)
Name of the item.
templateName (String)
Name of the template.
parent (Item)
The parent.
Return Value
The from template.


AssertItemName Method (name)

AssertItemName Method (name)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► AssertItemName(String)
Asserts that the name of the item is valid.
Declaration Syntax
C#
public static void AssertItemName(
    string name
)
Parameters
name (String)
Item name.


CopyItem Method (source, destination, saveIds, deep)

CopyItem Method (source, destination, saveIds, deep)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► CopyItem(Item, Item, Boolean, Boolean)
Copies the item.
Declaration Syntax
C#
public static Item CopyItem(
    Item source,
    Item destination,
    bool saveIds,
    bool deep
)
Parameters
source (Item)
The source.
destination (Item)
The destination.
saveIds (Boolean)
if set to true values of ids will be saved.
deep (Boolean)
if set to true childer will be copied.


DeleteItem Method

DeleteItem Method
Namespaces ► Sitecore.Data.Items ► ItemUtil ► DeleteItem()()()
Members
Icon | Member | Description
 | DeleteItem(ID, Database) | Deletes an item.
 | DeleteItem(String, Database) | Deletes an item.


DeleteItem Method (itemID, database)

DeleteItem Method (itemID, database)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► DeleteItem(ID, Database)
Deletes an item.
Declaration Syntax
C#
public static void DeleteItem(
    ID itemID,
    Database database
)
Parameters
itemID (ID)
ID of the item.
database (Database)
Database.


DeleteItem Method (path, database)

DeleteItem Method (path, database)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► DeleteItem(String, Database)
Deletes an item.
Declaration Syntax
C#
public static void DeleteItem(
    string path,
    Database database
)
Parameters
path (String)
Path of the item.
database (Database)
Database.


GetChildrenAt Method (path)

GetChildrenAt Method (path)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► GetChildrenAt(String)
Gets the children at.
Declaration Syntax
C#
public static List<Item> GetChildrenAt(
    string path
)
Parameters
path (String)
The path.
Return Value
The children at.


GetCopyOfName Method (destination, name)

GetCopyOfName Method (destination, name)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► GetCopyOfName(Item, String)
Gets an item name that includes a "Copy of" text.
Declaration Syntax
C#
public static string GetCopyOfName(
    Item destination,
    string name
)
Parameters
destination (Item)
Parent item of the item.
name (String)
Name.
Return Value
The name.


GetItemFromPartialPath Method (partialPath, database)

GetItemFromPartialPath Method (partialPath, database)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► GetItemFromPartialPath(String, Database)
Gets an item from a partial path.
Declaration Syntax
C#
public static Item GetItemFromPartialPath(
    string partialPath,
    Database database
)
Parameters
partialPath (String)
Partial path.
database (Database)
Database.
Return Value
The item from partial path.


GetItemID Method (itemPath, database)

GetItemID Method (itemPath, database)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► GetItemID(String, Database)
Gets the item ID.
Declaration Syntax
C#
public static ID GetItemID(
    string itemPath,
    Database database
)
Parameters
itemPath (String)
The item path.
database (Database)
The database.
Return Value
The item ID.


GetItemNameError Method (name)

GetItemNameError Method (name)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► GetItemNameError(String)
Gets an error text for an item name.
Declaration Syntax
C#
public static string GetItemNameError(
    string name
)
Parameters
name (String)
Item name.
Return Value
The item name error.


GetLevel Method (itm)

GetLevel Method (itm)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► GetLevel(Item)
Gets the level of an item.
Declaration Syntax
C#
public static int GetLevel(
    Item itm
)
Parameters
itm (Item)
The itm.
Return Value
The level.
Remarks
"/sitecore" is level 0 (zero), "/sitecore/content" is level 1 (one) and so forth.


GetParentID Method (item)

GetParentID Method (item)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► GetParentID(Item)
Gets the parent ID of an item.
Declaration Syntax
C#
public static ID GetParentID(
    Item item
)
Parameters
item (Item)
Item.
Return Value
The parent ID.


GetParentName Method

GetParentName Method
Namespaces ► Sitecore.Data.Items ► ItemUtil ► GetParentName()()()
Members
Icon | Member | Description
 | GetParentName(Item) | Gets the name of the parent of an item.
 | GetParentName(Item, Boolean) | Gets the name of the parent.


GetParentName Method (item)

GetParentName Method (item)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► GetParentName(Item)
Gets the name of the parent of an item.
Declaration Syntax
C#
public static string GetParentName(
    Item item
)
Parameters
item (Item)
Item.
Return Value
The name.


GetParentName Method (item, useDisplayName)

GetParentName Method (item, useDisplayName)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► GetParentName(Item, Boolean)
Gets the name of the parent.
Declaration Syntax
C#
public static string GetParentName(
    Item item,
    bool useDisplayName
)
Parameters
item (Item)
Item.
useDisplayName (Boolean)
Use the display name of the parent item.
Return Value
The parent name.


GetTemplateKey Method (item)

GetTemplateKey Method (item)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► GetTemplateKey(Item)
Gets the template key.
Declaration Syntax
C#
public static string GetTemplateKey(
    Item item
)
Parameters
item (Item)
The item.
Return Value


IsItemNameValid Method (name)

IsItemNameValid Method (name)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► IsItemNameValid(String)
Determines whether an item name is valid.
Declaration Syntax
C#
public static bool IsItemNameValid(
    string name
)
Parameters
name (String)
Name.
Return Value
true if the item name is valid; otherwise, false.


IsNull Method (id)

IsNull Method (id)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► IsNull(ID)
Determines whether the specified id is null.
Declaration Syntax
C#
public static bool IsNull(
    ID id
)
Parameters
id (ID)
The id.
Return Value
true if the specified id is null; otherwise, false.


ProposeValidItemName Method

ProposeValidItemName Method
Namespaces ► Sitecore.Data.Items ► ItemUtil ► ProposeValidItemName()()()
Members
Icon | Member | Description
 | ProposeValidItemName(String) | Given a invalid itemname, proposes a new itemname where all invalid characters have been replased with an empty character.
 | ProposeValidItemName(String, String) | Given a invalid itemname, proposes a new itemname where all invalid characters have been replased with an empty character.


ProposeValidItemName Method (name)

ProposeValidItemName Method (name)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► ProposeValidItemName(String)
Given a invalid itemname, proposes a new itemname where all invalid characters have been replased with an empty character.
Declaration Syntax
C#
public static string ProposeValidItemName(
    string name
)
Parameters
name (String)
Item name.
Return Value
The name.


ProposeValidItemName Method (name, defaultValue)

ProposeValidItemName Method (name, defaultValue)
Namespaces ► Sitecore.Data.Items ► ItemUtil ► ProposeValidItemName(String, String)
Given a invalid itemname, proposes a new itemname where all invalid characters have been replased with an empty character.
Declaration Syntax
C#
public static string ProposeValidItemName(
    string name,
    string defaultValue
)
Parameters
name (String)
Item name.
defaultValue (String)
The default value.
Return Value
The name.


ItemVersions Class

ItemVersions Class
Namespaces ► Sitecore.Data.Items ► ItemVersions
Provides methods for working with versions of an item.
Declaration Syntax
C#
public class ItemVersions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemVersions(Item) | Creates a new ItemVersions instance.
 | AddVersion()()() | Adds a new version to the source item.
 | Count | Gets the count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLaterVersions()()() | Gets the versions that have come after the current version.
 | GetLatestVersion()()() | Gets the latest version of current item language.
 | GetLatestVersion(Language) | Gets the latest version of item in defined language.
 | GetOlderVersions()()() | Gets the versions that have come before the current version.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersionNumbers()()() | Gets a list of version numbers for the source item.
 | GetVersionNumbers(Boolean) | Gets a list of version numbers for the source item.
 | GetVersions()()() | Gets the versions of the source item.
 | GetVersions(Boolean) | Gets the versions of the source item.
 | IsLatestVersion()()() | Determines whether item is the latest version in item language.
 | Item[([(Version])]) | Gets the Item with the specified version.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveAll(Boolean) | Removes all the versions of an item.
 | RemoveVersion()()() | Removes a version.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemVersions


ItemVersions Constructor (item)

ItemVersions Constructor (item)
Namespaces ► Sitecore.Data.Items ► ItemVersions ► ItemVersions(Item)
Creates a new ItemVersions instance.
Declaration Syntax
C#
public ItemVersions(
    Item item
)
Parameters
item (Item)
Source item.


AddVersion Method

AddVersion Method
Namespaces ► Sitecore.Data.Items ► ItemVersions ► AddVersion()()()
Adds a new version to the source item.
Declaration Syntax
C#
public Item AddVersion()
Return Value
The version.


Count Property

Count Property
Namespaces ► Sitecore.Data.Items ► ItemVersions ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


GetLaterVersions Method

GetLaterVersions Method
Namespaces ► Sitecore.Data.Items ► ItemVersions ► GetLaterVersions()()()
Gets the versions that have come after the current version.
Declaration Syntax
C#
public Item[] GetLaterVersions()
Return Value


GetLatestVersion Method

GetLatestVersion Method
Namespaces ► Sitecore.Data.Items ► ItemVersions ► GetLatestVersion()()()
Members
Icon | Member | Description
 | GetLatestVersion()()() | Gets the latest version of current item language.
 | GetLatestVersion(Language) | Gets the latest version of item in defined language.


GetLatestVersion Method

GetLatestVersion Method
Namespaces ► Sitecore.Data.Items ► ItemVersions ► GetLatestVersion()()()
Gets the latest version of current item language.
Declaration Syntax
C#
public Item GetLatestVersion()
Return Value


GetLatestVersion Method (language)

GetLatestVersion Method (language)
Namespaces ► Sitecore.Data.Items ► ItemVersions ► GetLatestVersion(Language)
Gets the latest version of item in defined language.
Declaration Syntax
C#
public Item GetLatestVersion(
    Language language
)
Parameters
language (Language)
The language.
Return Value


GetOlderVersions Method

GetOlderVersions Method
Namespaces ► Sitecore.Data.Items ► ItemVersions ► GetOlderVersions()()()
Gets the versions that have come before the current version.
Declaration Syntax
C#
public Item[] GetOlderVersions()
Return Value


GetVersionNumbers Method

GetVersionNumbers Method
Namespaces ► Sitecore.Data.Items ► ItemVersions ► GetVersionNumbers()()()
Members
Icon | Member | Description
 | GetVersionNumbers()()() | Gets a list of version numbers for the source item.
 | GetVersionNumbers(Boolean) | Gets a list of version numbers for the source item.


GetVersionNumbers Method

GetVersionNumbers Method
Namespaces ► Sitecore.Data.Items ► ItemVersions ► GetVersionNumbers()()()
Gets a list of version numbers for the source item.
Declaration Syntax
C#
public Version[] GetVersionNumbers()
Return Value
The version numbers.


GetVersionNumbers Method (atLeastOne)

GetVersionNumbers Method (atLeastOne)
Namespaces ► Sitecore.Data.Items ► ItemVersions ► GetVersionNumbers(Boolean)
Gets a list of version numbers for the source item.
Declaration Syntax
C#
public Version[] GetVersionNumbers(
    bool atLeastOne
)
Parameters
atLeastOne (Boolean)
if set to true this instance is at least one.
Return Value
The version numbers.


GetVersions Method

GetVersions Method
Namespaces ► Sitecore.Data.Items ► ItemVersions ► GetVersions()()()
Members
Icon | Member | Description
 | GetVersions()()() | Gets the versions of the source item.
 | GetVersions(Boolean) | Gets the versions of the source item.


GetVersions Method

GetVersions Method
Namespaces ► Sitecore.Data.Items ► ItemVersions ► GetVersions()()()
Gets the versions of the source item.
Declaration Syntax
C#
public Item[] GetVersions()
Return Value
The versions.


GetVersions Method (includeAllLanguages)

GetVersions Method (includeAllLanguages)
Namespaces ► Sitecore.Data.Items ► ItemVersions ► GetVersions(Boolean)
Gets the versions of the source item.
Declaration Syntax
C#
public Item[] GetVersions(
    bool includeAllLanguages
)
Parameters
includeAllLanguages (Boolean)
Include all languages.
Return Value
The versions.


IsLatestVersion Method

IsLatestVersion Method
Namespaces ► Sitecore.Data.Items ► ItemVersions ► IsLatestVersion()()()
Determines whether item is the latest version in item language.
Declaration Syntax
C#
public bool IsLatestVersion()
Return Value
true if item is the latest version in item language otherwise, false.


Item Property (version)

Item Property (version)
Namespaces ► Sitecore.Data.Items ► ItemVersions ► Item[([(Version])])
Gets the Item with the specified version.
Declaration Syntax
C#
public Item this[
    Version version
] { get; }
Parameters
version (Version)
Value


RemoveAll Method (includeAllLanguages)

RemoveAll Method (includeAllLanguages)
Namespaces ► Sitecore.Data.Items ► ItemVersions ► RemoveAll(Boolean)
Removes all the versions of an item.
Declaration Syntax
C#
public void RemoveAll(
    bool includeAllLanguages
)
Parameters
includeAllLanguages (Boolean)
if set to true this instance is include all languages.


RemoveVersion Method

RemoveVersion Method
Namespaces ► Sitecore.Data.Items ► ItemVersions ► RemoveVersion()()()
Removes a version.
Declaration Syntax
C#
public void RemoveVersion()


ItemVisualization Class

ItemVisualization Class
Namespaces ► Sitecore.Data.Items ► ItemVisualization
Defines how an item is visible to a user.
Declaration Syntax
C#
public class ItemVisualization
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemVisualization(Item) | Creates a new ItemVisualization instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLayout(DeviceItem) | Gets the layout item for the source item in a specific device.
 | GetLayoutID(DeviceItem) | Gets the ID of the layout item.
 | GetRenderer(String, Boolean) | Gets the renderer control for the item.
 | GetRenderings(DeviceItem, Boolean) | Gets the renderings for a device.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Layout | Gets the layout item for the source item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemVisualization


ItemVisualization Constructor (item)

ItemVisualization Constructor (item)
Namespaces ► Sitecore.Data.Items ► ItemVisualization ► ItemVisualization(Item)
Creates a new ItemVisualization instance.
Declaration Syntax
C#
public ItemVisualization(
    Item item
)
Parameters
item (Item)
Item.


GetLayout Method (device)

GetLayout Method (device)
Namespaces ► Sitecore.Data.Items ► ItemVisualization ► GetLayout(DeviceItem)
Gets the layout item for the source item in a specific device.
Declaration Syntax
C#
public LayoutItem GetLayout(
    DeviceItem device
)
Parameters
device (DeviceItem)
Device.
Return Value
The layout.


GetLayoutID Method (device)

GetLayoutID Method (device)
Namespaces ► Sitecore.Data.Items ► ItemVisualization ► GetLayoutID(DeviceItem)
Gets the ID of the layout item.
Declaration Syntax
C#
public ID GetLayoutID(
    DeviceItem device
)
Parameters
device (DeviceItem)
Device.
Return Value
The layout ID.


GetRenderer Method (mode, allowDefault)

GetRenderer Method (mode, allowDefault)
Namespaces ► Sitecore.Data.Items ► ItemVisualization ► GetRenderer(String, Boolean)
Gets the renderer control for the item.
Declaration Syntax
C#
public Control GetRenderer(
    string mode,
    bool allowDefault
)
Parameters
mode (String)
Mode.
allowDefault (Boolean)
Allow default.
Return Value
The renderer.


GetRenderings Method (device, checkLogin)

GetRenderings Method (device, checkLogin)
Namespaces ► Sitecore.Data.Items ► ItemVisualization ► GetRenderings(DeviceItem, Boolean)
Gets the renderings for a device.
Declaration Syntax
C#
public RenderingReference[] GetRenderings(
    DeviceItem device,
    bool checkLogin
)
Parameters
device (DeviceItem)
Device.
checkLogin (Boolean)
Check if a user is logged in. If not, use login renderings (if assigned)
Return Value
The renderings.


Layout Property

Layout Property
Namespaces ► Sitecore.Data.Items ► ItemVisualization ► Layout
Gets the layout item for the source item.
Declaration Syntax
C#
public LayoutItem Layout { get; }
Value
The layout.


ITrackingItem Interface

ITrackingItem Interface
Namespaces ► Sitecore.Data.Items ► ITrackingItem
Defines the basic functionality for an item that tracks modifications.
Declaration Syntax
C#
public interface ITrackingItem
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsDefinitionModified | Gets a value indicating whether the definition has been modified.


IsDefinitionModified Property

IsDefinitionModified Property
Namespaces ► Sitecore.Data.Items ► ITrackingItem ► IsDefinitionModified
Gets a value indicating whether the definition has been modified.
Declaration Syntax
C#
bool IsDefinitionModified { get; }
Value
true if the definition has been modified; otherwise, false.


LayoutItem Class

LayoutItem Class
Namespaces ► Sitecore.Data.Items ► LayoutItem
Represents a Layout item.
Declaration Syntax
C#
public class LayoutItem : CustomItemBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayoutItem(Item) | Creates a new LayoutItem instance.
 | BeginEdit()()() | Begins editing the item. (Inherited from CustomItemBase.)
 | Control | Gets the control of the layout.
 | Database | Gets the database. (Inherited from CustomItemBase.)
 | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
 | EndEdit()()() | Ends editing the item. (Inherited from CustomItemBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath | Gets the file path of the layout.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets the icon. (Inherited from CustomItemBase.)
 | ID | Gets the ID. (Inherited from CustomItemBase.)
 | Implicit(Item) | Converts an item to a LayoutItem.
 | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomItemBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomItemBase
 |  | LayoutItem


LayoutItem Constructor (innerItem)

LayoutItem Constructor (innerItem)
Namespaces ► Sitecore.Data.Items ► LayoutItem ► LayoutItem(Item)
Creates a new LayoutItem instance.
Declaration Syntax
C#
public LayoutItem(
    Item innerItem
)
Parameters
innerItem (Item)
Inner item.


Control Property

Control Property
Namespaces ► Sitecore.Data.Items ► LayoutItem ► Control
Gets the control of the layout.
Declaration Syntax
C#
public string Control { get; }
Value
The control.


FilePath Property

FilePath Property
Namespaces ► Sitecore.Data.Items ► LayoutItem ► FilePath
Gets the file path of the layout.
Declaration Syntax
C#
public string FilePath { get; }
Value
The file path.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Items ► LayoutItem ► Implicit(Item)
Converts an item to a LayoutItem.
Declaration Syntax
C#
public static implicit operator LayoutItem (
    Item item
)
Parameters
item (Item)
The item.
Return Value
The implicit operator.


MediaItem Class

MediaItem Class
Namespaces ► Sitecore.Data.Items ► MediaItem
Represents a media item.
Declaration Syntax
C#
public class MediaItem : CustomItemBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaItem(Item) | Creates a new MediaItem instance.
 | Alt | Gets the Alt text.
 | BeginEdit()()() | Begins editing the item. (Inherited from CustomItemBase.)
 | Database | Gets the database. (Inherited from CustomItemBase.)
 | Description | Gets the description.
 | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
 | EndEdit()()() | Ends editing the item. (Inherited from CustomItemBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extension | Gets the extension.
 | FileBased | Gets a value indicating whether the media is file based.
 | FilePath | Gets or sets the path for file based media.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMediaInfo()()() | Obsolete. Gets media information.
 | GetMediaStream()()() | Returns a Stream from the database
 | GetMetaData()()() | Gets the meta data.
 | GetThumbnail()()() | Obsolete. Gets the thumbnail.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasMediaStream(String) | Determines whether this instance has a mediastream.
 | Icon | Gets the icon. (Inherited from CustomItemBase.)
 | ID | Gets the ID. (Inherited from CustomItemBase.)
 | Implicit(Item) | Converts an item to a MediaItem.
 | Implicit(MediaItem) | Converts an item to a MediaItem.
 | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
 | MediaPath | Gets the path in the media library.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MimeType | Gets the MIME type of the item.
 | Name | Gets the name. (Inherited from CustomItemBase.)
 | Path | Gets the path.
 | Size | Gets or sets the size of the current media data.
 | Title | Gets the title.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateMedia()()() | Validates the media.
Inheritance Hierarchy
Object
 | CustomItemBase
 |  | MediaItem


MediaItem Constructor (innerItem)

MediaItem Constructor (innerItem)
Namespaces ► Sitecore.Data.Items ► MediaItem ► MediaItem(Item)
Creates a new MediaItem instance.
Declaration Syntax
C#
public MediaItem(
    Item innerItem
)
Parameters
innerItem (Item)
Inner item.


Alt Property

Alt Property
Namespaces ► Sitecore.Data.Items ► MediaItem ► Alt
Gets the Alt text.
Declaration Syntax
C#
public string Alt { get; set; }
Value
The alt.


Description Property

Description Property
Namespaces ► Sitecore.Data.Items ► MediaItem ► Description
Gets the description.
Declaration Syntax
C#
public string Description { get; }
Value
The description.


Extension Property

Extension Property
Namespaces ► Sitecore.Data.Items ► MediaItem ► Extension
Gets the extension.
Declaration Syntax
C#
public string Extension { get; set; }
Value
The extension.


FileBased Property

FileBased Property
Namespaces ► Sitecore.Data.Items ► MediaItem ► FileBased
Gets a value indicating whether the media is file based.
Declaration Syntax
C#
public bool FileBased { get; }
Value
true if the media is file based; otherwise, false.


FilePath Property

FilePath Property
Namespaces ► Sitecore.Data.Items ► MediaItem ► FilePath
Gets or sets the path for file based media.
Declaration Syntax
C#
public string FilePath { get; set; }
Value
The file path.


GetMediaInfo Method

GetMediaInfo Method
Namespaces ► Sitecore.Data.Items ► MediaItem ► GetMediaInfo()()()
Gets media information.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public MediaInfo GetMediaInfo()
Return Value
The media info.


GetMediaStream Method

GetMediaStream Method
Namespaces ► Sitecore.Data.Items ► MediaItem ► GetMediaStream()()()
Returns a Stream from the database
Declaration Syntax
C#
public Stream GetMediaStream()
Return Value
A stream representation of the blob field of this Item
Remarks
It is absolutely essential that the caller closes the returned stream after use. Otherwise,the system may leak resources.


GetMetaData Method

GetMetaData Method
Namespaces ► Sitecore.Data.Items ► MediaItem ► GetMetaData()()()
Gets the meta data.
Declaration Syntax
C#
public MediaMetaDataCollection GetMetaData()
Return Value
The meta data.


GetThumbnail Method

GetThumbnail Method
Namespaces ► Sitecore.Data.Items ► MediaItem ► GetThumbnail()()()
Gets the thumbnail.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Media.GetThumbnailStream instead.")]
public string GetThumbnail()
Return Value
The thumbnail.


HasMediaStream Method (fieldname)

HasMediaStream Method (fieldname)
Namespaces ► Sitecore.Data.Items ► MediaItem ► HasMediaStream(String)
Determines whether this instance has a mediastream.
Declaration Syntax
C#
public bool HasMediaStream(
    string fieldname
)
Parameters
fieldname (String)
Return Value
true if this instance has a mediastream otherwise, false.


Implicit Method

Implicit Method
Namespaces ► Sitecore.Data.Items ► MediaItem ► Implicit()()()
Members
Icon | Member | Description
 | Implicit(Item) | Converts an item to a MediaItem.
 | Implicit(MediaItem) | Converts an item to a MediaItem.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Items ► MediaItem ► Implicit(Item)
Converts an item to a MediaItem.
Declaration Syntax
C#
public static implicit operator MediaItem (
    Item item
)
Parameters
item (Item)
The item.
Return Value
The implicit operator.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Items ► MediaItem ► Implicit(MediaItem)
Converts an item to a MediaItem.
Declaration Syntax
C#
public static implicit operator Item (
    MediaItem mediaItem
)
Parameters
mediaItem (MediaItem)
The item.
Return Value
The implicit operator.


MediaPath Property

MediaPath Property
Namespaces ► Sitecore.Data.Items ► MediaItem ► MediaPath
Gets the path in the media library.
Declaration Syntax
C#
public string MediaPath { get; }
Value
The media path.


MimeType Property

MimeType Property
Namespaces ► Sitecore.Data.Items ► MediaItem ► MimeType
Gets the MIME type of the item.
Declaration Syntax
C#
public string MimeType { get; }
Value
The type of the MIME.


Path Property

Path Property
Namespaces ► Sitecore.Data.Items ► MediaItem ► Path
Gets the path.
Declaration Syntax
C#
public string Path { get; }
Value
The path.


Size Property

Size Property
Namespaces ► Sitecore.Data.Items ► MediaItem ► Size
Gets or sets the size of the current media data.
Declaration Syntax
C#
public long Size { get; set; }
Value
The size.


Title Property

Title Property
Namespaces ► Sitecore.Data.Items ► MediaItem ► Title
Gets the title.
Declaration Syntax
C#
public string Title { get; }
Value
The title.


ValidateMedia Method

ValidateMedia Method
Namespaces ► Sitecore.Data.Items ► MediaItem ► ValidateMedia()()()
Validates the media.
Declaration Syntax
C#
public MediaValidatorResult ValidateMedia()
Return Value
The media.


PasteMode Enumeration

PasteMode Enumeration
Namespaces ► Sitecore.Data.Items ► PasteMode
Declaration Syntax
C#
public enum PasteMode
Members
Member | Description
Undefined | Undefined.
Overwrite | Overwrite.
Merge | Merge.


ProcessorItem Class

ProcessorItem Class
Namespaces ► Sitecore.Data.Items ► ProcessorItem
Represents a Processor item.
Declaration Syntax
C#
public class ProcessorItem : CustomItemBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProcessorItem(Item) | Creates a new ProcessorItem instance.
 | Active | Obsolete. Gets a value indicating whether this ProcessorItem is active.
 | BeginEdit()()() | Begins editing the item. (Inherited from CustomItemBase.)
 | Database | Gets the database. (Inherited from CustomItemBase.)
 | Disabled | Gets a value indicating whether this ProcessorItem is disabled.
 | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
 | EndEdit()()() | Ends editing the item. (Inherited from CustomItemBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets the icon. (Inherited from CustomItemBase.)
 | ID | Gets the ID. (Inherited from CustomItemBase.)
 | Implicit(Item) | Converts an item to a ProcessorItem
 | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Method | Gets the method to invoke.
 | Name | Gets the name. (Inherited from CustomItemBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the type/assembly identifier string.
Inheritance Hierarchy
Object
 | CustomItemBase
 |  | ProcessorItem


ProcessorItem Constructor (innerItem)

ProcessorItem Constructor (innerItem)
Namespaces ► Sitecore.Data.Items ► ProcessorItem ► ProcessorItem(Item)
Creates a new ProcessorItem instance.
Declaration Syntax
C#
public ProcessorItem(
    Item innerItem
)
Parameters
innerItem (Item)
Inner item.


Active Property

Active Property
Namespaces ► Sitecore.Data.Items ► ProcessorItem ► Active
Gets a value indicating whether this ProcessorItem is active.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Disabled instead.")]
public bool Active { get; }
Value
true if active; otherwise, false.


Disabled Property

Disabled Property
Namespaces ► Sitecore.Data.Items ► ProcessorItem ► Disabled
Gets a value indicating whether this ProcessorItem is disabled.
Declaration Syntax
C#
public bool Disabled { get; }
Value
true if disabled; otherwise, false.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Items ► ProcessorItem ► Implicit(Item)
Converts an item to a ProcessorItem
Declaration Syntax
C#
public static implicit operator ProcessorItem (
    Item item
)
Parameters
item (Item)
The item.
Return Value
The implicit operator.


Method Property

Method Property
Namespaces ► Sitecore.Data.Items ► ProcessorItem ► Method
Gets the method to invoke.
Declaration Syntax
C#
public string Method { get; }
Value
The method.


Type Property

Type Property
Namespaces ► Sitecore.Data.Items ► ProcessorItem ► Type
Gets the type/assembly identifier string.
Declaration Syntax
C#
public string Type { get; }
Value
The type.


ReadOnlyItemList Class

ReadOnlyItemList Class
Namespaces ► Sitecore.Data.Items ► ReadOnlyItemList
Declaration Syntax
C#
public class ReadOnlyItemList : ReadOnlyList<Item>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReadOnlyItemList(IEnumerable<(Of <(Item>)>)) | Initializes a new instance of the ItemList class.
 | ReadOnlyItemList()()() | Initializes a new instance of the ItemList class.
 | Contains(TElement) | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToArray()()() | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ReadOnlyList <(Of <( Item >)>)
 |  | ReadOnlyItemList


ReadOnlyItemList Constructor

ReadOnlyItemList Constructor
Namespaces ► Sitecore.Data.Items ► ReadOnlyItemList ► ReadOnlyItemList()()()
Members
Icon | Member | Description
 | ReadOnlyItemList(IEnumerable<(Of <(Item>)>)) | Initializes a new instance of the ItemList class.
 | ReadOnlyItemList()()() | Initializes a new instance of the ItemList class.


ReadOnlyItemList Constructor

ReadOnlyItemList Constructor
Namespaces ► Sitecore.Data.Items ► ReadOnlyItemList ► ReadOnlyItemList()()()
Initializes a new instance of the ItemList class.
Declaration Syntax
C#
public ReadOnlyItemList()


ReadOnlyItemList Constructor (entries)

ReadOnlyItemList Constructor (entries)
Namespaces ► Sitecore.Data.Items ► ReadOnlyItemList ► ReadOnlyItemList(IEnumerable<(Of <(Item>)>))
Initializes a new instance of the ItemList class.
Declaration Syntax
C#
public ReadOnlyItemList(
    IEnumerable<Item> entries
)
Parameters
entries (IEnumerable<(Of <( Item >)>))
The entries.


RenderingItem Class

RenderingItem Class
Namespaces ► Sitecore.Data.Items ► RenderingItem
Represents a Rendering item.
Declaration Syntax
C#
public class RenderingItem : CustomItemBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderingItem(Item) | Creates a new RenderingItem instance.
 | BeginEdit()()() | Begins editing the item. (Inherited from CustomItemBase.)
 | Caching | Gets caching information.
 | Conditions | Gets the conditions.
 | Database | Gets the database. (Inherited from CustomItemBase.)
 | DataSource | Gets the data source.
 | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
 | EndEdit()()() | Ends editing the item. (Inherited from CustomItemBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttributes(NameValueCollection) | Gets the attributes.
 | GetControl(RenderingSettings) | Gets the control.
 | GetDesignTimeHtml(NameValueCollection, String%) | Gets the design time HTML.
 | GetDesignTimeHtml(String, String, String, String, String, String, NameValueCollection, String%) | Gets the design time HTML.
 | GetDesignTimeLiveControl(RenderingSettings) | Gets the control.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(ID, Database, Boolean) | Gets the Rendering item.
 | GetItem(String, Database, Boolean) | Gets the Rendering item.
 | GetParameters()()() | Gets the rendering parameters.
 | GetTagPrefix(String, String, String%, String%) | Gets the tag prefix.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets the icon. (Inherited from CustomItemBase.)
 | ID | Gets the ID. (Inherited from CustomItemBase.)
 | Implicit(Item) | Convert an item to a RenderingItem.
 | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
 | MakeTagPrefix(String%) | Gets the tag prefix.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultiVariateTest | Gets the multi variate test.
 | Name | Gets the name. (Inherited from CustomItemBase.)
 | Parameters | Gets the parameters.
 | Placeholder | Gets the placeholder.
 | TagName | Gets the name of the tag.
 | TagPrefix | Gets the tag prefix.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomItemBase
 |  | RenderingItem


RenderingItem Constructor (innerItem)

RenderingItem Constructor (innerItem)
Namespaces ► Sitecore.Data.Items ► RenderingItem ► RenderingItem(Item)
Creates a new RenderingItem instance.
Declaration Syntax
C#
public RenderingItem(
    Item innerItem
)
Parameters
innerItem (Item)
Inner item.


Caching Property

Caching Property
Namespaces ► Sitecore.Data.Items ► RenderingItem ► Caching
Gets caching information.
Declaration Syntax
C#
public RenderingCaching Caching { get; }
Value
The caching.


Conditions Property

Conditions Property
Namespaces ► Sitecore.Data.Items ► RenderingItem ► Conditions
Gets the conditions.
Declaration Syntax
C#
public string Conditions { get; }
Value
The conditions.


DataSource Property

DataSource Property
Namespaces ► Sitecore.Data.Items ► RenderingItem ► DataSource
Gets the data source.
Declaration Syntax
C#
public string DataSource { get; }
Value
The data source.


GetAttributes Method (attributes)

GetAttributes Method (attributes)
Namespaces ► Sitecore.Data.Items ► RenderingItem ► GetAttributes(NameValueCollection)
Gets the attributes.
Declaration Syntax
C#
public void GetAttributes(
    NameValueCollection attributes
)
Parameters
attributes (NameValueCollection)
The attributes.


GetControl Method (settings)

GetControl Method (settings)
Namespaces ► Sitecore.Data.Items ► RenderingItem ► GetControl(RenderingSettings)
Gets the control.
Declaration Syntax
C#
public Control GetControl(
    RenderingSettings settings
)
Parameters
settings (RenderingSettings)
Settings.
Return Value


GetDesignTimeHtml Method

GetDesignTimeHtml Method
Namespaces ► Sitecore.Data.Items ► RenderingItem ► GetDesignTimeHtml()()()
Members
Icon | Member | Description
 | GetDesignTimeHtml(NameValueCollection, String%) | Gets the design time HTML.
 | GetDesignTimeHtml(String, String, String, String, String, String, NameValueCollection, String%) | Gets the design time HTML.


GetDesignTimeHtml Method (querystring, html)

GetDesignTimeHtml Method (querystring, html)
Namespaces ► Sitecore.Data.Items ► RenderingItem ► GetDesignTimeHtml(NameValueCollection, String%)
Gets the design time HTML.
Declaration Syntax
C#
public string GetDesignTimeHtml(
    NameValueCollection querystring,
    ref string html
)
Parameters
querystring (NameValueCollection)
The querystring.
html ( String %)
The HTML.
Return Value


GetDesignTimeHtml Method (ns, assembly, renderingID, tagPrefix, tagName, parameters, querystring, html)

GetDesignTimeHtml Method (ns, assembly, renderingID, tagPrefix, tagName, parameters, querystring, html)
Namespaces ► Sitecore.Data.Items ► RenderingItem ► GetDesignTimeHtml(String, String, String, String, String, String, NameValueCollection, String%)
Gets the design time HTML.
Declaration Syntax
C#
public static string GetDesignTimeHtml(
    string ns,
    string assembly,
    string renderingID,
    string tagPrefix,
    string tagName,
    string parameters,
    NameValueCollection querystring,
    ref string html
)
Parameters
ns (String)
The namespace.
assembly (String)
The assembly.
renderingID (String)
The rendering ID.
tagPrefix (String)
The tag prefix.
tagName (String)
Name of the tag.
parameters (String)
The parameters.
querystring (NameValueCollection)
The querystring.
html ( String %)
The HTML.
Return Value


GetDesignTimeLiveControl Method (settings)

GetDesignTimeLiveControl Method (settings)
Namespaces ► Sitecore.Data.Items ► RenderingItem ► GetDesignTimeLiveControl(RenderingSettings)
Gets the control.
Declaration Syntax
C#
public Control GetDesignTimeLiveControl(
    RenderingSettings settings
)
Parameters
settings (RenderingSettings)
Settings.
Return Value


GetItem Method

GetItem Method
Namespaces ► Sitecore.Data.Items ► RenderingItem ► GetItem()()()
Members
Icon | Member | Description
 | GetItem(ID, Database, Boolean) | Gets the Rendering item.
 | GetItem(String, Database, Boolean) | Gets the Rendering item.


GetItem Method (renderingID, database, assert)

GetItem Method (renderingID, database, assert)
Namespaces ► Sitecore.Data.Items ► RenderingItem ► GetItem(ID, Database, Boolean)
Gets the Rendering item.
Declaration Syntax
C#
public static RenderingItem GetItem(
    ID renderingID,
    Database database,
    bool assert
)
Parameters
renderingID (ID)
Rendering ID.
database (Database)
Database.
assert (Boolean)
Assert that the item is found.
Return Value


GetItem Method (path, database, assert)

GetItem Method (path, database, assert)
Namespaces ► Sitecore.Data.Items ► RenderingItem ► GetItem(String, Database, Boolean)
Gets the Rendering item.
Declaration Syntax
C#
public static RenderingItem GetItem(
    string path,
    Database database,
    bool assert
)
Parameters
path (String)
Path.
database (Database)
Database.
assert (Boolean)
Assert that the item is found.
Return Value


GetParameters Method

GetParameters Method
Namespaces ► Sitecore.Data.Items ► RenderingItem ► GetParameters()()()
Gets the rendering parameters.
Declaration Syntax
C#
public UrlString GetParameters()
Return Value
The rendering parameters.


GetTagPrefix Method (ns, assembly, tagPrefix, html)

GetTagPrefix Method (ns, assembly, tagPrefix, html)
Namespaces ► Sitecore.Data.Items ► RenderingItem ► GetTagPrefix(String, String, String%, String%)
Gets the tag prefix.
Declaration Syntax
C#
public static void GetTagPrefix(
    string ns,
    string assembly,
    ref string tagPrefix,
    ref string html
)
Parameters
ns (String)
The namespace.
assembly (String)
The assembly.
tagPrefix ( String %)
The tag prefix.
html ( String %)
The HTML.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Items ► RenderingItem ► Implicit(Item)
Convert an item to a RenderingItem.
Declaration Syntax
C#
public static implicit operator RenderingItem (
    Item item
)
Parameters
item (Item)
The item.
Return Value


MakeTagPrefix Method (htmlHeader)

MakeTagPrefix Method (htmlHeader)
Namespaces ► Sitecore.Data.Items ► RenderingItem ► MakeTagPrefix(String%)
Gets the tag prefix.
Declaration Syntax
C#
public string MakeTagPrefix(
    ref string htmlHeader
)
Parameters
htmlHeader ( String %)
The HTML header. The method will add addional page declaration as needed for control to operate properly.
Return Value
The tag prefix.


MultiVariateTest Property

MultiVariateTest Property
Namespaces ► Sitecore.Data.Items ► RenderingItem ► MultiVariateTest
Gets the multi variate test.
Declaration Syntax
C#
public string MultiVariateTest { get; }
Value
The multi variate test.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Data.Items ► RenderingItem ► Parameters
Gets the parameters.
Declaration Syntax
C#
public string Parameters { get; }
Value
The parameters.


Placeholder Property

Placeholder Property
Namespaces ► Sitecore.Data.Items ► RenderingItem ► Placeholder
Gets the placeholder.
Declaration Syntax
C#
public string Placeholder { get; }
Value
The placeholder.


TagName Property

TagName Property
Namespaces ► Sitecore.Data.Items ► RenderingItem ► TagName
Gets the name of the tag.
Declaration Syntax
C#
public string TagName { get; }
Value
The name of the tag.


TagPrefix Property

TagPrefix Property
Namespaces ► Sitecore.Data.Items ► RenderingItem ► TagPrefix
Gets the tag prefix.
Declaration Syntax
C#
public string TagPrefix { get; }
Value
The tag prefix.


SectionTimer Class

SectionTimer Class
Namespaces ► Sitecore.Data.Items ► SectionTimer
SectionTimer
Declaration Syntax
C#
public class SectionTimer : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SectionTimer(String, Boolean) | Initializes a new instance of the SectionTimer class.
 | SectionTimer(String, Boolean, Int32) | Initializes a new instance of the SectionTimer class.
 | SectionTimer(String, String) | Initializes a new instance of the SectionTimer class that writes to a file.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Elapsed | Gets the current number of elapsed milliseconds
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SectionTimer


SectionTimer Constructor

SectionTimer Constructor
Namespaces ► Sitecore.Data.Items ► SectionTimer ► SectionTimer()()()
Members
Icon | Member | Description
 | SectionTimer(String, Boolean) | Initializes a new instance of the SectionTimer class.
 | SectionTimer(String, Boolean, Int32) | Initializes a new instance of the SectionTimer class.
 | SectionTimer(String, String) | Initializes a new instance of the SectionTimer class that writes to a file.


SectionTimer Constructor (sectionName, displayResult)

SectionTimer Constructor (sectionName, displayResult)
Namespaces ► Sitecore.Data.Items ► SectionTimer ► SectionTimer(String, Boolean)
Initializes a new instance of the SectionTimer class.
Declaration Syntax
C#
public SectionTimer(
    string sectionName,
    bool displayResult
)
Parameters
sectionName (String)
Name of the section.
displayResult (Boolean)
if set to true this instance is displaying results on the screen.


SectionTimer Constructor (sectionName, displayResult, divideBy)

SectionTimer Constructor (sectionName, displayResult, divideBy)
Namespaces ► Sitecore.Data.Items ► SectionTimer ► SectionTimer(String, Boolean, Int32)
Initializes a new instance of the SectionTimer class.
Declaration Syntax
C#
public SectionTimer(
    string sectionName,
    bool displayResult,
    int divideBy
)
Parameters
sectionName (String)
Name of the section.
displayResult (Boolean)
if set to true this instance is displaying results on the screen.
divideBy (Int32)
The divide by factor.


SectionTimer Constructor (filename, sectionName)

SectionTimer Constructor (filename, sectionName)
Namespaces ► Sitecore.Data.Items ► SectionTimer ► SectionTimer(String, String)
Initializes a new instance of the SectionTimer class that writes to a file.
Declaration Syntax
C#
public SectionTimer(
    string filename,
    string sectionName
)
Parameters
filename (String)
The filename.
sectionName (String)
Name of the section.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Data.Items ► SectionTimer ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


Elapsed Property

Elapsed Property
Namespaces ► Sitecore.Data.Items ► SectionTimer ► Elapsed
Gets the current number of elapsed milliseconds
Declaration Syntax
C#
public double Elapsed { get; }
Value
The elapsed.


SublayoutItem Class

SublayoutItem Class
Namespaces ► Sitecore.Data.Items ► SublayoutItem
Represents a Sublayout item.
Declaration Syntax
C#
public class SublayoutItem : CustomItemBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SublayoutItem(Item) | Creates a new SublayoutItem instance.
 | BeginEdit()()() | Begins editing the item. (Inherited from CustomItemBase.)
 | Database | Gets the database. (Inherited from CustomItemBase.)
 | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
 | EndEdit()()() | Ends editing the item. (Inherited from CustomItemBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath | Gets the file path of the sublayout.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets the icon. (Inherited from CustomItemBase.)
 | ID | Gets the ID. (Inherited from CustomItemBase.)
 | Implicit(Item) | Converts an item to a SublayoutItem.
 | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomItemBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomItemBase
 |  | SublayoutItem


SublayoutItem Constructor (innerItem)

SublayoutItem Constructor (innerItem)
Namespaces ► Sitecore.Data.Items ► SublayoutItem ► SublayoutItem(Item)
Creates a new SublayoutItem instance.
Declaration Syntax
C#
public SublayoutItem(
    Item innerItem
)
Parameters
innerItem (Item)
Inner item.


FilePath Property

FilePath Property
Namespaces ► Sitecore.Data.Items ► SublayoutItem ► FilePath
Gets the file path of the sublayout.
Declaration Syntax
C#
public string FilePath { get; }
Value
The file path.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Items ► SublayoutItem ► Implicit(Item)
Converts an item to a SublayoutItem.
Declaration Syntax
C#
public static implicit operator SublayoutItem (
    Item item
)
Parameters
item (Item)
The item.
Return Value
The implicit operator.


TemplateFieldItem Class

TemplateFieldItem Class
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem
Represents a TemplateField item.
Declaration Syntax
C#
public class TemplateFieldItem : CustomItemBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateFieldItem(Item, TemplateSectionItem) | Creates a new TemplateFieldItem instance.
 | BeginEdit()()() | Begins editing the item. (Inherited from CustomItemBase.)
 | Database | Gets the database. (Inherited from CustomItemBase.)
 | Description | Gets the description.
 | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
 | EndEdit()()() | Ends editing the item. (Inherited from CustomItemBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HelpLink | Gets the help link.
 | Icon | Gets the icon. (Inherited from CustomItemBase.)
 | ID | Gets the ID. (Inherited from CustomItemBase.)
 | Implicit(Item) | Converts an item to a TemplateFieldItem.
 | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
 | IsShared | Gets a value indicating whether this instance is shared.
 | IsUnversioned | Gets a value indicating whether this instance is unversioned.
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomItemBase.)
 | ResetBlank | Gets a value indicating whether the TemplateFieldItem resets the blank flag.
 | Section | Gets the section.
 | Shared | Gets a value indicating whether this TemplateFieldItem is shared.
 | Sortorder | Gets or sets the sortorder.
 | Source | Gets or sets the source.
 | Style | Gets or sets the CSS style.
 | Template | Gets the template.
 | Title | Gets or sets the title.
 | ToolTip | Gets the tool tip.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets or sets the type.
 | Unversioned | Gets a value indicating whether this TemplateFieldItem is unversioned.
 | Validation | Gets or sets the validation regular expression.
 | ValidationText | Gets or sets the validation text that is shown if the Validation regular expression fails.
Inheritance Hierarchy
Object
 | CustomItemBase
 |  | TemplateFieldItem


TemplateFieldItem Constructor (innerItem, owner)

TemplateFieldItem Constructor (innerItem, owner)
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► TemplateFieldItem(Item, TemplateSectionItem)
Creates a new TemplateFieldItem instance.
Declaration Syntax
C#
public TemplateFieldItem(
    Item innerItem,
    TemplateSectionItem owner
)
Parameters
innerItem (Item)
Inner item.
owner (TemplateSectionItem)
Owner.


Description Property

Description Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► Description
Gets the description.
Declaration Syntax
C#
public string Description { get; }
Value
The description.


HelpLink Property

HelpLink Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► HelpLink
Gets the help link.
Declaration Syntax
C#
public LinkField HelpLink { get; }
Value
The help link.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► Implicit(Item)
Converts an item to a TemplateFieldItem.
Declaration Syntax
C#
public static implicit operator TemplateFieldItem (
    Item item
)
Parameters
item (Item)
The item.
Return Value
The implicit operator.


IsShared Property

IsShared Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► IsShared
Gets a value indicating whether this instance is shared.
Declaration Syntax
C#
public bool IsShared { get; }
Value
true if this instance is shared; otherwise, false.


IsUnversioned Property

IsUnversioned Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► IsUnversioned
Gets a value indicating whether this instance is unversioned.
Declaration Syntax
C#
public bool IsUnversioned { get; }
Value
true if this instance is unversioned; otherwise, false.


Key Property

Key Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


ResetBlank Property

ResetBlank Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► ResetBlank
Gets a value indicating whether the TemplateFieldItem resets the blank flag.
Declaration Syntax
C#
public bool ResetBlank { get; }
Value
true if the TemplateFieldItem resets the blank flag; otherwise, false.


Section Property

Section Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► Section
Gets the section.
Declaration Syntax
C#
public TemplateSectionItem Section { get; }
Value
The section.


Shared Property

Shared Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► Shared
Gets a value indicating whether this TemplateFieldItem is shared.
Declaration Syntax
C#
public bool Shared { get; }
Value
true if shared; otherwise, false.


Sortorder Property

Sortorder Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► Sortorder
Gets or sets the sortorder.
Declaration Syntax
C#
public int Sortorder { get; set; }
Value
The sortorder.


Source Property

Source Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► Source
Gets or sets the source.
Declaration Syntax
C#
public string Source { get; set; }
Value
The source.


Style Property

Style Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► Style
Gets or sets the CSS style.
Declaration Syntax
C#
public string Style { get; set; }
Value
The style.


Template Property

Template Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► Template
Gets the template.
Declaration Syntax
C#
public TemplateItem Template { get; }
Value
The template.


Title Property

Title Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► Title
Gets or sets the title.
Declaration Syntax
C#
public string Title { get; set; }
Value
The title.


ToolTip Property

ToolTip Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► ToolTip
Gets the tool tip.
Declaration Syntax
C#
public string ToolTip { get; }
Value
The tool tip.


Type Property

Type Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► Type
Gets or sets the type.
Declaration Syntax
C#
public string Type { get; set; }
Value
The type.


Unversioned Property

Unversioned Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► Unversioned
Gets a value indicating whether this TemplateFieldItem is unversioned.
Declaration Syntax
C#
public bool Unversioned { get; }
Value
true if unversioned; otherwise, false.


Validation Property

Validation Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► Validation
Gets or sets the validation regular expression.
Declaration Syntax
C#
public string Validation { get; set; }
Value
The validation.


ValidationText Property

ValidationText Property
Namespaces ► Sitecore.Data.Items ► TemplateFieldItem ► ValidationText
Gets or sets the validation text that is shown if the Validation regular expression fails.
Declaration Syntax
C#
public string ValidationText { get; set; }
Value
The validation text.


TemplateItem Class

TemplateItem Class
Namespaces ► Sitecore.Data.Items ► TemplateItem
Represents a Template item.
Declaration Syntax
C#
public class TemplateItem : CustomItemBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateItem(Item) | Creates a new TemplateItem instance.
 | AddField(String, String) | Adds a field.
 | AddSection(String) | Adds the section.
 | AddSection(String, Boolean) | Adds the section.
 | AddTo(Item, String) | Adds an item based on this template to another template.
 | BaseTemplates | Gets a list of base templates.
 | BeginEdit()()() | Begins editing the item. (Inherited from CustomItemBase.)
 | CreateItemFrom(String, Item) | Creates the item from another item.
 | CreateStandardValues()()() | Creates the standard values.
 | Database | Gets the database. (Inherited from CustomItemBase.)
 | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
 | EndEdit()()() | Ends editing the item. (Inherited from CustomItemBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fields | Gets the fields.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullName | Gets the full name.
 | GetField(ID) | Gets a field.
 | GetField(String) | Gets a field.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSection(ID) | Gets a section.
 | GetSection(ID, Boolean) | Gets a section.
 | GetSection(String) | Gets a section.
 | GetSections()()() | Gets a list of sections.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUsages()()() | Gets the usages of this template from Lucene.
 | Icon | Gets the icon. (Inherited from CustomItemBase.)
 | ID | Gets the ID. (Inherited from CustomItemBase.)
 | Implicit(Item) | Converts an Item to a TemplateItem.
 | Implicit(TemplateItem) | Converts a TemplateItem to an Item.
 | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomItemBase.)
 | OwnFields | Gets the fields that are defined by this template.
 | RemoveField(ID) | Removes a field.
 | RemoveField(String) | Removes a field.
 | RemoveSection(ID) | Removes a section.
 | RemoveSection(String) | Removes a section.
 | StandardValues | Gets the standard values.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomItemBase
 |  | TemplateItem


TemplateItem Constructor (innerItem)

TemplateItem Constructor (innerItem)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► TemplateItem(Item)
Creates a new TemplateItem instance.
Declaration Syntax
C#
public TemplateItem(
    Item innerItem
)
Parameters
innerItem (Item)
Inner item.


AddField Method (fieldName, sectionName)

AddField Method (fieldName, sectionName)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► AddField(String, String)
Adds a field.
Declaration Syntax
C#
public TemplateFieldItem AddField(
    string fieldName,
    string sectionName
)
Parameters
fieldName (String)
Name of the field.
sectionName (String)
Name of the section.
Return Value
A TemplateFieldItem


AddSection Method

AddSection Method
Namespaces ► Sitecore.Data.Items ► TemplateItem ► AddSection()()()
Members
Icon | Member | Description
 | AddSection(String) | Adds the section.
 | AddSection(String, Boolean) | Adds the section.


AddSection Method (sectionName)

AddSection Method (sectionName)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► AddSection(String)
Adds the section.
Declaration Syntax
C#
public TemplateSectionItem AddSection(
    string sectionName
)
Parameters
sectionName (String)
Name of the section.
Return Value
The section.


AddSection Method (sectionName, allowInheritedSection)

AddSection Method (sectionName, allowInheritedSection)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► AddSection(String, Boolean)
Adds the section.
Declaration Syntax
C#
public TemplateSectionItem AddSection(
    string sectionName,
    bool allowInheritedSection
)
Parameters
sectionName (String)
Name of the section.
allowInheritedSection (Boolean)
if set to true this instance allows inherited section.
Return Value
The section.


AddTo Method (item, name)

AddTo Method (item, name)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► AddTo(Item, String)
Adds an item based on this template to another template.
Declaration Syntax
C#
public Item AddTo(
    Item item,
    string name
)
Parameters
item (Item)
Item.
name (String)
Name.
Return Value
The to.


BaseTemplates Property

BaseTemplates Property
Namespaces ► Sitecore.Data.Items ► TemplateItem ► BaseTemplates
Gets a list of base templates.
Declaration Syntax
C#
public TemplateItem[] BaseTemplates { get; }
Value
The base templates.


CreateItemFrom Method (name, parent)

CreateItemFrom Method (name, parent)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► CreateItemFrom(String, Item)
Creates the item from another item.
Declaration Syntax
C#
public Item CreateItemFrom(
    string name,
    Item parent
)
Parameters
name (String)
Name.
parent (Item)
Parent.
Return Value
The item from.


CreateStandardValues Method

CreateStandardValues Method
Namespaces ► Sitecore.Data.Items ► TemplateItem ► CreateStandardValues()()()
Creates the standard values.
Declaration Syntax
C#
public Item CreateStandardValues()
Return Value
The standard values.


Fields Property

Fields Property
Namespaces ► Sitecore.Data.Items ► TemplateItem ► Fields
Gets the fields.
Declaration Syntax
C#
public TemplateFieldItem[] Fields { get; }
Value
The fields.


FullName Property

FullName Property
Namespaces ► Sitecore.Data.Items ► TemplateItem ► FullName
Gets the full name.
Declaration Syntax
C#
public string FullName { get; }
Value
The full name.


GetField Method

GetField Method
Namespaces ► Sitecore.Data.Items ► TemplateItem ► GetField()()()
Members
Icon | Member | Description
 | GetField(ID) | Gets a field.
 | GetField(String) | Gets a field.


GetField Method (fieldID)

GetField Method (fieldID)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► GetField(ID)
Gets a field.
Declaration Syntax
C#
public TemplateFieldItem GetField(
    ID fieldID
)
Parameters
fieldID (ID)
Field ID.
Return Value
The field.


GetField Method (fieldName)

GetField Method (fieldName)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► GetField(String)
Gets a field.
Declaration Syntax
C#
public TemplateFieldItem GetField(
    string fieldName
)
Parameters
fieldName (String)
Name of the field.
Return Value
The field.


GetSection Method

GetSection Method
Namespaces ► Sitecore.Data.Items ► TemplateItem ► GetSection()()()
Members
Icon | Member | Description
 | GetSection(ID) | Gets a section.
 | GetSection(ID, Boolean) | Gets a section.
 | GetSection(String) | Gets a section.


GetSection Method (sectionID)

GetSection Method (sectionID)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► GetSection(ID)
Gets a section.
Declaration Syntax
C#
public TemplateSectionItem GetSection(
    ID sectionID
)
Parameters
sectionID (ID)
Section ID.
Return Value
The section.


GetSection Method (sectionID, allowInheritedSection)

GetSection Method (sectionID, allowInheritedSection)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► GetSection(ID, Boolean)
Gets a section.
Declaration Syntax
C#
public TemplateSectionItem GetSection(
    ID sectionID,
    bool allowInheritedSection
)
Parameters
sectionID (ID)
Section ID.
allowInheritedSection (Boolean)
if set to true if inherited sections are allowed.
Return Value
The section.


GetSection Method (sectionName)

GetSection Method (sectionName)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► GetSection(String)
Gets a section.
Declaration Syntax
C#
public TemplateSectionItem GetSection(
    string sectionName
)
Parameters
sectionName (String)
Name of the section.
Return Value
The section.


GetSections Method

GetSections Method
Namespaces ► Sitecore.Data.Items ► TemplateItem ► GetSections()()()
Gets a list of sections.
Declaration Syntax
C#
public TemplateSectionItem[] GetSections()
Return Value
The sections.


GetUsages Method

GetUsages Method
Namespaces ► Sitecore.Data.Items ► TemplateItem ► GetUsages()()()
Gets the usages of this template from Lucene.
Declaration Syntax
C#
public Hits GetUsages()
Return Value
The usages.


Implicit Method

Implicit Method
Namespaces ► Sitecore.Data.Items ► TemplateItem ► Implicit()()()
Members
Icon | Member | Description
 | Implicit(Item) | Converts an Item to a TemplateItem.
 | Implicit(TemplateItem) | Converts a TemplateItem to an Item.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Items ► TemplateItem ► Implicit(Item)
Converts an Item to a TemplateItem.
Declaration Syntax
C#
public static implicit operator TemplateItem (
    Item item
)
Parameters
item (Item)
The item.
Return Value
The implicit operator.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Items ► TemplateItem ► Implicit(TemplateItem)
Converts a TemplateItem to an Item.
Declaration Syntax
C#
public static implicit operator Item (
    TemplateItem templateItem
)
Parameters
templateItem (TemplateItem)
The item.
Return Value
The implicit operator.


Key Property

Key Property
Namespaces ► Sitecore.Data.Items ► TemplateItem ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


OwnFields Property

OwnFields Property
Namespaces ► Sitecore.Data.Items ► TemplateItem ► OwnFields
Gets the fields that are defined by this template.
Declaration Syntax
C#
public TemplateFieldItem[] OwnFields { get; }
Value
The own fields.
Remarks
Fields are that are inherited from other templates are omitted.


RemoveField Method

RemoveField Method
Namespaces ► Sitecore.Data.Items ► TemplateItem ► RemoveField()()()
Members
Icon | Member | Description
 | RemoveField(ID) | Removes a field.
 | RemoveField(String) | Removes a field.


RemoveField Method (fieldID)

RemoveField Method (fieldID)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► RemoveField(ID)
Removes a field.
Declaration Syntax
C#
public void RemoveField(
    ID fieldID
)
Parameters
fieldID (ID)
Field ID.


RemoveField Method (fieldName)

RemoveField Method (fieldName)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► RemoveField(String)
Removes a field.
Declaration Syntax
C#
public void RemoveField(
    string fieldName
)
Parameters
fieldName (String)
Name of the field.


RemoveSection Method

RemoveSection Method
Namespaces ► Sitecore.Data.Items ► TemplateItem ► RemoveSection()()()
Members
Icon | Member | Description
 | RemoveSection(ID) | Removes a section.
 | RemoveSection(String) | Removes a section.


RemoveSection Method (sectionID)

RemoveSection Method (sectionID)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► RemoveSection(ID)
Removes a section.
Declaration Syntax
C#
public void RemoveSection(
    ID sectionID
)
Parameters
sectionID (ID)
Section ID.


RemoveSection Method (sectionName)

RemoveSection Method (sectionName)
Namespaces ► Sitecore.Data.Items ► TemplateItem ► RemoveSection(String)
Removes a section.
Declaration Syntax
C#
public void RemoveSection(
    string sectionName
)
Parameters
sectionName (String)
Name of the section.


StandardValues Property

StandardValues Property
Namespaces ► Sitecore.Data.Items ► TemplateItem ► StandardValues
Gets the standard values.
Declaration Syntax
C#
public Item StandardValues { get; }
Value
The standard values.


TemplateSectionItem Class

TemplateSectionItem Class
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem
Represents a Template Section item.
Declaration Syntax
C#
public class TemplateSectionItem : CustomItemBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateSectionItem(Item, TemplateItem) | Creates a new TemplateSectionItem instance.
 | AddField(String) | Adds a field.
 | BeginEdit()()() | Begins editing the item. (Inherited from CustomItemBase.)
 | Control | Gets the control that is used to display section toolbars in the client.
 | Database | Gets the database. (Inherited from CustomItemBase.)
 | DisplayName | Gets the display name. (Overrides CustomItemBase.DisplayName.)
 | EndEdit()()() | Ends editing the item. (Inherited from CustomItemBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetField(ID) | Gets a field.
 | GetField(String) | Gets a field.
 | GetFields()()() | Gets the fields.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HiddenByDefault | Gets a value indicating whether the section is hidden by default.
 | HideFields | Gets a value indicating whether fields are hidden for this section in the client.
 | Icon | Gets the icon.
 | ID | Gets the ID. (Inherited from CustomItemBase.)
 | Implicit(Item) | Converts an Item to a TemplateSectionItem.
 | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomItemBase.)
 | RemoveField(ID) | Removes the field.
 | RemoveField(String) | Removes the field.
 | Sortorder | Gets the sortorder.
 | Template | Gets the template.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomItemBase
 |  | TemplateSectionItem


TemplateSectionItem Constructor (innerItem, owner)

TemplateSectionItem Constructor (innerItem, owner)
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► TemplateSectionItem(Item, TemplateItem)
Creates a new TemplateSectionItem instance.
Declaration Syntax
C#
public TemplateSectionItem(
    Item innerItem,
    TemplateItem owner
)
Parameters
innerItem (Item)
Inner item.
owner (TemplateItem)
Owner.


AddField Method (fieldName)

AddField Method (fieldName)
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► AddField(String)
Adds a field.
Declaration Syntax
C#
public TemplateFieldItem AddField(
    string fieldName
)
Parameters
fieldName (String)
Name of the field.
Return Value
The field.


Control Property

Control Property
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► Control
Gets the control that is used to display section toolbars in the client.
Declaration Syntax
C#
public string Control { get; }
Value
The control.


DisplayName Property

DisplayName Property
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► DisplayName
Gets the display name.
Declaration Syntax
C#
public override string DisplayName { get; }
Value
The name of the display.
Remarks
See Also
DisplayName


GetField Method

GetField Method
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► GetField()()()
Members
Icon | Member | Description
 | GetField(ID) | Gets a field.
 | GetField(String) | Gets a field.


GetField Method (fieldID)

GetField Method (fieldID)
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► GetField(ID)
Gets a field.
Declaration Syntax
C#
public TemplateFieldItem GetField(
    ID fieldID
)
Parameters
fieldID (ID)
Field ID.
Return Value
The field.


GetField Method (fieldName)

GetField Method (fieldName)
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► GetField(String)
Gets a field.
Declaration Syntax
C#
public TemplateFieldItem GetField(
    string fieldName
)
Parameters
fieldName (String)
Name of the field.
Return Value
The field.


GetFields Method

GetFields Method
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► GetFields()()()
Gets the fields.
Declaration Syntax
C#
public TemplateFieldItem[] GetFields()
Return Value
The fields.


HiddenByDefault Property

HiddenByDefault Property
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► HiddenByDefault
Gets a value indicating whether the section is hidden by default.
Declaration Syntax
C#
public bool HiddenByDefault { get; }
Value
true if the section is hidden by default; otherwise, false.


HideFields Property

HideFields Property
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► HideFields
Gets a value indicating whether fields are hidden for this section in the client.
Declaration Syntax
C#
public bool HideFields { get; }
Value
true if fields are hidden; otherwise, false.


Icon Property

Icon Property
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► Icon
Gets the icon.
Declaration Syntax
C#
public string Icon { get; }
Value
The icon.
Remarks
See Also
Icon


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► Implicit(Item)
Converts an Item to a TemplateSectionItem.
Declaration Syntax
C#
public static implicit operator TemplateSectionItem (
    Item item
)
Parameters
item (Item)
The item.
Return Value
The implicit operator.


Key Property

Key Property
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


RemoveField Method

RemoveField Method
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► RemoveField()()()
Members
Icon | Member | Description
 | RemoveField(ID) | Removes the field.
 | RemoveField(String) | Removes the field.


RemoveField Method (fieldID)

RemoveField Method (fieldID)
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► RemoveField(ID)
Removes the field.
Declaration Syntax
C#
public void RemoveField(
    ID fieldID
)
Parameters
fieldID (ID)
Field ID.


RemoveField Method (fieldName)

RemoveField Method (fieldName)
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► RemoveField(String)
Removes the field.
Declaration Syntax
C#
public void RemoveField(
    string fieldName
)
Parameters
fieldName (String)
Name of the field.


Sortorder Property

Sortorder Property
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► Sortorder
Gets the sortorder.
Declaration Syntax
C#
public int Sortorder { get; }
Value
The sortorder.


Template Property

Template Property
Namespaces ► Sitecore.Data.Items ► TemplateSectionItem ► Template
Gets the template.
Declaration Syntax
C#
public TemplateItem Template { get; }
Value
The template.


Sitecore.Data.Locking Namespace

Sitecore.Data.Locking Namespace
Namespaces ► Sitecore.Data.Locking
Declaration Syntax
C#
namespace Sitecore.Data.Locking
Types
All Types Classes
Icon | Type | Description
 | ItemLocking | Represents the locking state of an item.


ItemLocking Class

ItemLocking Class
Namespaces ► Sitecore.Data.Locking ► ItemLocking
Represents the locking state of an item.
Declaration Syntax
C#
public class ItemLocking
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemLocking(Item) | Creates a new ItemLocking instance.
 | CanLock()()() | Determines whether this item can be locked by the current user.
 | CanUnlock()()() | Determines whether the current user can unlock this item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDatabaseName()()() | Gets the name of the database.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOwner()()() | Gets the user that owns the current lock.
 | GetOwnerWithoutDomain()()() | Gets the user that owns the current lock.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasLock()()() | Determines whether the current user has a lock on the item.
 | IsLocked()()() | Determines whether the item is locked by a user.
 | Lock()()() | Locks the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unlock()()() | Unlocks the item.
Remarks

Locking ensures that only one user can edit an item at a time.

Locking is tightly integrated with workflows.

Locking information is stored on the item in the field "__Lock".

Inheritance Hierarchy
Object
ItemLocking


ItemLocking Constructor (item)

ItemLocking Constructor (item)
Namespaces ► Sitecore.Data.Locking ► ItemLocking ► ItemLocking(Item)
Creates a new ItemLocking instance.
Declaration Syntax
C#
public ItemLocking(
    Item item
)
Parameters
item (Item)
Item.


CanLock Method

CanLock Method
Namespaces ► Sitecore.Data.Locking ► ItemLocking ► CanLock()()()
Determines whether this item can be locked by the current user.
Declaration Syntax
C#
public bool CanLock()
Return Value
true if this item can be locked by the current user; otherwise, false.


CanUnlock Method

CanUnlock Method
Namespaces ► Sitecore.Data.Locking ► ItemLocking ► CanUnlock()()()
Determines whether the current user can unlock this item.
Declaration Syntax
C#
public bool CanUnlock()
Return Value
true if the current user can unlock this item; otherwise, false.


GetDatabaseName Method

GetDatabaseName Method
Namespaces ► Sitecore.Data.Locking ► ItemLocking ► GetDatabaseName()()()
Gets the name of the database.
Declaration Syntax
C#
public void GetDatabaseName()


GetOwner Method

GetOwner Method
Namespaces ► Sitecore.Data.Locking ► ItemLocking ► GetOwner()()()
Gets the user that owns the current lock.
Declaration Syntax
C#
public string GetOwner()
Return Value
The owner.


GetOwnerWithoutDomain Method

GetOwnerWithoutDomain Method
Namespaces ► Sitecore.Data.Locking ► ItemLocking ► GetOwnerWithoutDomain()()()
Gets the user that owns the current lock.
Declaration Syntax
C#
public string GetOwnerWithoutDomain()
Return Value
The owner.


HasLock Method

HasLock Method
Namespaces ► Sitecore.Data.Locking ► ItemLocking ► HasLock()()()
Determines whether the current user has a lock on the item.
Declaration Syntax
C#
public bool HasLock()
Return Value
true if the current user has a lock on the item; otherwise, false.


IsLocked Method

IsLocked Method
Namespaces ► Sitecore.Data.Locking ► ItemLocking ► IsLocked()()()
Determines whether the item is locked by a user.
Declaration Syntax
C#
public bool IsLocked()
Return Value
true if the item is locked by a user; otherwise, false.


Lock Method

Lock Method
Namespaces ► Sitecore.Data.Locking ► ItemLocking ► Lock()()()
Locks the item.
Declaration Syntax
C#
public bool Lock()
Return Value
The lock.


Unlock Method

Unlock Method
Namespaces ► Sitecore.Data.Locking ► ItemLocking ► Unlock()()()
Unlocks the item.
Declaration Syntax
C#
public bool Unlock()
Return Value
The unlock.


Sitecore.Data.Managers Namespace

Sitecore.Data.Managers Namespace
Namespaces ► Sitecore.Data.Managers
Declaration Syntax
C#
namespace Sitecore.Data.Managers
Types
All Types Classes
Icon | Type | Description
 | HistoryManager | Manager class for history.
 | HistoryProvider | Default provider used for audting operations.
 | IndexingProvider | Provider class for indexing.
 | ItemManager | Static interface for performing basic CRUD operations against the item database.
 | ItemProvider | Provider for performing basic CRUD operations against the item database.
 | ItemProviderCollection | ItemProviderCollection class
 | LanguageManager | Manager for language related operations.
 | LanguageProvider | Provider for language related operations.
 | TemplateManager | Static API for interacting with templates.
 | ThemeManager | Static interface for performing theme operations.
 | ThemeProvider | Provider for performing theme operations.


HistoryManager Class

HistoryManager Class
Namespaces ► Sitecore.Data.Managers ► HistoryManager
Manager class for history.
Declaration Syntax
C#
public sealed class HistoryManager
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HistoryManager()()() | Initializes a new instance of the HistoryManager class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHistory(Database, DateTime, DateTime) | Gets the history for a database.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes event handlers.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Provider | Gets the active provider.
 | RegisterItemCopied(Item, Item) | Registers an 'item copied' event in the audit log.
 | RegisterItemCreated(Item) | Registers an 'item created' event in the audit log.
 | RegisterItemDeleted(Item, ID) | Registers an 'item deleted' event in the audit log.
 | RegisterItemMoved(Item, ID) | Registers an 'item moved' event in the audit log.
 | RegisterItemSaved(Item, ItemChanges) | Registers an 'item saved' event in the audit log.
 | RegisterVersionAdded(Item) | Registers an 'version added' event in the audit log.
 | RegisterVersionRemoved(Item) | Registers an 'version removed' event in the audit log.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HistoryManager


HistoryManager Constructor

HistoryManager Constructor
Namespaces ► Sitecore.Data.Managers ► HistoryManager ► HistoryManager()()()
Initializes a new instance of the HistoryManager class
Declaration Syntax
C#
public HistoryManager()


GetHistory Method (database, from, to)

GetHistory Method (database, from, to)
Namespaces ► Sitecore.Data.Managers ► HistoryManager ► GetHistory(Database, DateTime, DateTime)
Gets the history for a database.
Declaration Syntax
C#
public static HistoryEntryCollection GetHistory(
    Database database,
    DateTime from,
    DateTime to
)
Parameters
database (Database)
The database.
from (DateTime)
From date (UTC).
to (DateTime)
To date (UTC).
Return Value
The history.


Initialize Method

Initialize Method
Namespaces ► Sitecore.Data.Managers ► HistoryManager ► Initialize()()()
Initializes event handlers.
Declaration Syntax
C#
public static void Initialize()


Provider Property

Provider Property
Namespaces ► Sitecore.Data.Managers ► HistoryManager ► Provider
Gets the active provider.
Declaration Syntax
C#
public static HistoryProvider Provider { get; }
Value
The provider.


RegisterItemCopied Method (copiedItem, sourceItem)

RegisterItemCopied Method (copiedItem, sourceItem)
Namespaces ► Sitecore.Data.Managers ► HistoryManager ► RegisterItemCopied(Item, Item)
Registers an 'item copied' event in the audit log.
Declaration Syntax
C#
public static void RegisterItemCopied(
    Item copiedItem,
    Item sourceItem
)
Parameters
copiedItem (Item)
The copied item.
sourceItem (Item)
The source item.


RegisterItemCreated Method (item)

RegisterItemCreated Method (item)
Namespaces ► Sitecore.Data.Managers ► HistoryManager ► RegisterItemCreated(Item)
Registers an 'item created' event in the audit log.
Declaration Syntax
C#
public static void RegisterItemCreated(
    Item item
)
Parameters
item (Item)
The item.


RegisterItemDeleted Method (item, oldParentId)

RegisterItemDeleted Method (item, oldParentId)
Namespaces ► Sitecore.Data.Managers ► HistoryManager ► RegisterItemDeleted(Item, ID)
Registers an 'item deleted' event in the audit log.
Declaration Syntax
C#
public static void RegisterItemDeleted(
    Item item,
    ID oldParentId
)
Parameters
item (Item)
The item.
oldParentId (ID)
The old parent id.


RegisterItemMoved Method (item, oldParentId)

RegisterItemMoved Method (item, oldParentId)
Namespaces ► Sitecore.Data.Managers ► HistoryManager ► RegisterItemMoved(Item, ID)
Registers an 'item moved' event in the audit log.
Declaration Syntax
C#
public static void RegisterItemMoved(
    Item item,
    ID oldParentId
)
Parameters
item (Item)
The item.
oldParentId (ID)
The old parent id.


RegisterItemSaved Method (item, changes)

RegisterItemSaved Method (item, changes)
Namespaces ► Sitecore.Data.Managers ► HistoryManager ► RegisterItemSaved(Item, ItemChanges)
Registers an 'item saved' event in the audit log.
Declaration Syntax
C#
public static void RegisterItemSaved(
    Item item,
    ItemChanges changes
)
Parameters
item (Item)
The item.
changes (ItemChanges)
The changes.


RegisterVersionAdded Method (item)

RegisterVersionAdded Method (item)
Namespaces ► Sitecore.Data.Managers ► HistoryManager ► RegisterVersionAdded(Item)
Registers an 'version added' event in the audit log.
Declaration Syntax
C#
public static void RegisterVersionAdded(
    Item item
)
Parameters
item (Item)
The added version.


RegisterVersionRemoved Method (item)

RegisterVersionRemoved Method (item)
Namespaces ► Sitecore.Data.Managers ► HistoryManager ► RegisterVersionRemoved(Item)
Registers an 'version removed' event in the audit log.
Declaration Syntax
C#
public static void RegisterVersionRemoved(
    Item item
)
Parameters
item (Item)
The version that was removed.


HistoryProvider Class

HistoryProvider Class
Namespaces ► Sitecore.Data.Managers ► HistoryProvider
Default provider used for audting operations.
Declaration Syntax
C#
public class HistoryProvider
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HistoryProvider()()() | Initializes a new instance of the HistoryProvider class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHistory(Database, DateTime, DateTime) | Gets the history for a database.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterItemCopied(Item, Item) | Registers an 'item copied' event in the audit log.
 | RegisterItemCreated(Item) | Registers an 'item deleted' event in the audit log.
 | RegisterItemDeleted(Item, ID) | Registers an 'item deleted' event in the audit log.
 | RegisterItemMoved(Item, ID) | Registers an 'item moved' event in the audit log.
 | RegisterItemSaved(Item, ItemChanges) | Registers an 'item saved' event in the audit log.
 | RegisterVersionAdded(Item) | Registers an 'version added' event in the audit log.
 | RegisterVersionRemoved(Item) | Registers an 'version removed' event in the audit log.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HistoryProvider


HistoryProvider Constructor

HistoryProvider Constructor
Namespaces ► Sitecore.Data.Managers ► HistoryProvider ► HistoryProvider()()()
Initializes a new instance of the HistoryProvider class
Declaration Syntax
C#
public HistoryProvider()


GetHistory Method (database, from, to)

GetHistory Method (database, from, to)
Namespaces ► Sitecore.Data.Managers ► HistoryProvider ► GetHistory(Database, DateTime, DateTime)
Gets the history for a database.
Declaration Syntax
C#
public virtual HistoryEntryCollection GetHistory(
    Database database,
    DateTime from,
    DateTime to
)
Parameters
database (Database)
The database.
from (DateTime)
From date (UTC).
to (DateTime)
To date (UTC).
Return Value
The history.


RegisterItemCopied Method (copiedItem, sourceItem)

RegisterItemCopied Method (copiedItem, sourceItem)
Namespaces ► Sitecore.Data.Managers ► HistoryProvider ► RegisterItemCopied(Item, Item)
Registers an 'item copied' event in the audit log.
Declaration Syntax
C#
public virtual void RegisterItemCopied(
    Item copiedItem,
    Item sourceItem
)
Parameters
copiedItem (Item)
The copied item.
sourceItem (Item)
The source item.


RegisterItemCreated Method (item)

RegisterItemCreated Method (item)
Namespaces ► Sitecore.Data.Managers ► HistoryProvider ► RegisterItemCreated(Item)
Registers an 'item deleted' event in the audit log.
Declaration Syntax
C#
public virtual void RegisterItemCreated(
    Item item
)
Parameters
item (Item)
The item.


RegisterItemDeleted Method (item, oldParentId)

RegisterItemDeleted Method (item, oldParentId)
Namespaces ► Sitecore.Data.Managers ► HistoryProvider ► RegisterItemDeleted(Item, ID)
Registers an 'item deleted' event in the audit log.
Declaration Syntax
C#
public virtual void RegisterItemDeleted(
    Item item,
    ID oldParentId
)
Parameters
item (Item)
The item.
oldParentId (ID)
The old parent id.


RegisterItemMoved Method (item, oldParentId)

RegisterItemMoved Method (item, oldParentId)
Namespaces ► Sitecore.Data.Managers ► HistoryProvider ► RegisterItemMoved(Item, ID)
Registers an 'item moved' event in the audit log.
Declaration Syntax
C#
public virtual void RegisterItemMoved(
    Item item,
    ID oldParentId
)
Parameters
item (Item)
The item.
oldParentId (ID)
The old parent id.


RegisterItemSaved Method (item, changes)

RegisterItemSaved Method (item, changes)
Namespaces ► Sitecore.Data.Managers ► HistoryProvider ► RegisterItemSaved(Item, ItemChanges)
Registers an 'item saved' event in the audit log.
Declaration Syntax
C#
public virtual void RegisterItemSaved(
    Item item,
    ItemChanges changes
)
Parameters
item (Item)
The item.
changes (ItemChanges)
The changes.


RegisterVersionAdded Method (item)

RegisterVersionAdded Method (item)
Namespaces ► Sitecore.Data.Managers ► HistoryProvider ► RegisterVersionAdded(Item)
Registers an 'version added' event in the audit log.
Declaration Syntax
C#
public virtual void RegisterVersionAdded(
    Item item
)
Parameters
item (Item)
The added version.


RegisterVersionRemoved Method (item)

RegisterVersionRemoved Method (item)
Namespaces ► Sitecore.Data.Managers ► HistoryProvider ► RegisterVersionRemoved(Item)
Registers an 'version removed' event in the audit log.
Declaration Syntax
C#
public virtual void RegisterVersionRemoved(
    Item item
)
Parameters
item (Item)
The version that was removed.


IndexingProvider Class

IndexingProvider Class
Namespaces ► Sitecore.Data.Managers ► IndexingProvider
Provider class for indexing.
Declaration Syntax
C#
public class IndexingProvider
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexingProvider()()() | Initializes a new instance of the IndexingProvider class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnRemoveItem | Occurs when the provider removes an item from the index.
 | OnRemoveVersion | Occurs when the provider removes a version from the index.
 | OnUpdateItem | Occurs when the provider updates an item in the index.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateIndex(Database) | Updates the index(es) for a specific database.
 | UpdateIndex(Database, DateTime) | Updates the index(es) for a specific database.
Inheritance Hierarchy
Object
IndexingProvider


IndexingProvider Constructor

IndexingProvider Constructor
Namespaces ► Sitecore.Data.Managers ► IndexingProvider ► IndexingProvider()()()
Initializes a new instance of the IndexingProvider class
Declaration Syntax
C#
public IndexingProvider()


OnRemoveItem Event

OnRemoveItem Event
Namespaces ► Sitecore.Data.Managers ► IndexingProvider ► OnRemoveItem
Occurs when the provider removes an item from the index.
Declaration Syntax
C#
public event EventHandler OnRemoveItem


OnRemoveVersion Event

OnRemoveVersion Event
Namespaces ► Sitecore.Data.Managers ► IndexingProvider ► OnRemoveVersion
Occurs when the provider removes a version from the index.
Declaration Syntax
C#
public event EventHandler OnRemoveVersion


OnUpdateItem Event

OnUpdateItem Event
Namespaces ► Sitecore.Data.Managers ► IndexingProvider ► OnUpdateItem
Occurs when the provider updates an item in the index.
Declaration Syntax
C#
public event EventHandler OnUpdateItem


UpdateIndex Method

UpdateIndex Method
Namespaces ► Sitecore.Data.Managers ► IndexingProvider ► UpdateIndex()()()
Members
Icon | Member | Description
 | UpdateIndex(Database) | Updates the index(es) for a specific database.
 | UpdateIndex(Database, DateTime) | Updates the index(es) for a specific database.


UpdateIndex Method (database)

UpdateIndex Method (database)
Namespaces ► Sitecore.Data.Managers ► IndexingProvider ► UpdateIndex(Database)
Updates the index(es) for a specific database.
Declaration Syntax
C#
public virtual void UpdateIndex(
    Database database
)
Parameters
database (Database)
The database.


UpdateIndex Method (database, from)

UpdateIndex Method (database, from)
Namespaces ► Sitecore.Data.Managers ► IndexingProvider ► UpdateIndex(Database, DateTime)
Updates the index(es) for a specific database.
Declaration Syntax
C#
public virtual void UpdateIndex(
    Database database,
    DateTime from
)
Parameters
database (Database)
The database.
from (DateTime)
From date (UTC).


ItemManager Class

ItemManager Class
Namespaces ► Sitecore.Data.Managers ► ItemManager
Static interface for performing basic CRUD operations against the item database.
Declaration Syntax
C#
public static class ItemManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddFromTemplate(String, ID, Item) | Adds a new item from a template.
 | AddFromTemplate(String, ID, Item, ID) | Adds a new item from a template.
 | AddVersion(Item) | Adds a new version to an item by copying the data from an existing version.
 | AddVersion(Item, SecurityCheck) | Adds a new version to an item by copying the data from an existing version.
 | BlobStreamExists(Guid, Database) | Determines whether the specified field contains a BLOB value.
 | CopyItem(Item, Item, Boolean) | Copies a specified item. Destination item should be in the same database with target item.
 | CopyItem(Item, Item, Boolean, String) | Copies a specified item. Destination item should be in the same database with target item.
 | CopyItem(Item, Item, Boolean, String, ID) | Copies a specified item. Destination item should be in the same database with target item.
 | CreateItem(String, Item, ID) | Creates an empty item.
 | CreateItem(String, Item, ID, ID) | Creates an empty item.
 | CreateItem(String, Item, ID, ID, SecurityCheck) | Creates an empty item.
 | DeleteItem(Item) | Deletes an item.
 | DeleteItem(Item, SecurityCheck) | Deletes an item.
 | GetBlobStream(Field) | Gets the BLOB stream associated with a field.
 | GetBlobStream(Guid, Database) | Gets a BLOB stream from its id.
 | GetChildren(Item) | Gets the children of an item.
 | GetChildren(Item, SecurityCheck) | Gets the children of an item.
 | GetContentLanguages(Item) | Gets the content languages (ie. the languages for which the item has content).
 | GetItem(ID, Language, Version, Database) | Gets an item from a database.
 | GetItem(ID, Language, Version, Database, SecurityCheck) | Gets an item from a database.
 | GetItem(String, Language, Version, Database) | Gets an item from a database.
 | GetItem(String, Language, Version, Database, SecurityCheck) | Gets an item from a database.
 | GetParent(Item) | Gets the parent of an item.
 | GetParent(Item, SecurityCheck) | Gets the parent of an item.
 | GetRootItem(Language, Version, Database) | Gets the root item.
 | GetRootItem(Language, Version, Database, SecurityCheck) | Gets the root item.
 | GetVersions(Item) | Gets the version numbers of an item.
 | GetVersions(Item, Language) | Gets the version numbers of an item.
 | HasChildren(Item) | Determines whether the specified item has children.
 | HasChildren(Item, SecurityCheck) | Determines whether the specified item has children.
 | Initialize()()() | Initializes class.
 | MoveItem(Item, Item) | Moves an item.
 | MoveItem(Item, Item, SecurityCheck) | Moves an item.
 | Provider | The provider instance handling requests to the maanager.
 | Providers | Gets the providers.
 | RemoveData(ID, Database) | Removes all data from an item.
 | RemoveData(ID, Language, Boolean, Database) | Removes all data in a specific language from an item.
 | RemoveVersion(Item) | Removes a version from an item.
 | RemoveVersion(Item, SecurityCheck) | Removes a version from an item.
 | RemoveVersions(Item, Language, SecurityCheck) | Deletes all versions in the specified language.
 | ResolvePath(String, Database) | Resolves an item path to an id.
 | SaveItem(Item) | Saves changes to an item.
 | SetBlobStream(Stream, Guid, Database) | Sets the BLOB stream associated with a field.
Inheritance Hierarchy
Object
ItemManager


AddFromTemplate Method

AddFromTemplate Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► AddFromTemplate()()()
Members
Icon | Member | Description
 | AddFromTemplate(String, ID, Item) | Adds a new item from a template.
 | AddFromTemplate(String, ID, Item, ID) | Adds a new item from a template.


AddFromTemplate Method (itemName, templateId, destination)

AddFromTemplate Method (itemName, templateId, destination)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► AddFromTemplate(String, ID, Item)
Adds a new item from a template.
Declaration Syntax
C#
public static Item AddFromTemplate(
    string itemName,
    ID templateId,
    Item destination
)
Parameters
itemName (String)
Name of the new item.
templateId (ID)
The template id.
destination (Item)
The destination item. This will be the parent of the new item.
Return Value


AddFromTemplate Method (itemName, templateId, destination, newItemId)

AddFromTemplate Method (itemName, templateId, destination, newItemId)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► AddFromTemplate(String, ID, Item, ID)
Adds a new item from a template.
Declaration Syntax
C#
public static Item AddFromTemplate(
    string itemName,
    ID templateId,
    Item destination,
    ID newItemId
)
Parameters
itemName (String)
Name of the new item.
templateId (ID)
The template id.
destination (Item)
The destination item. This will be the parent of the new item.
newItemId (ID)
The id of the new item.
Return Value


AddVersion Method

AddVersion Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► AddVersion()()()
Members
Icon | Member | Description
 | AddVersion(Item) | Adds a new version to an item by copying the data from an existing version.
 | AddVersion(Item, SecurityCheck) | Adds a new version to an item by copying the data from an existing version.


AddVersion Method (item)

AddVersion Method (item)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► AddVersion(Item)
Adds a new version to an item by copying the data from an existing version.
Declaration Syntax
C#
public static Item AddVersion(
    Item item
)
Parameters
item (Item)
The item that will have a version added.
Return Value
The added version of the item. If a version could not be added to the item, null is returned.


AddVersion Method (item, securityCheck)

AddVersion Method (item, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► AddVersion(Item, SecurityCheck)
Adds a new version to an item by copying the data from an existing version.
Declaration Syntax
C#
public static Item AddVersion(
    Item item,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item that will have a version added.
securityCheck (SecurityCheck)
The security check.
Return Value
The added version of the item. If a version could not be added to the item, null is returned.


BlobStreamExists Method (blobId, database)

BlobStreamExists Method (blobId, database)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► BlobStreamExists(Guid, Database)
Determines whether the specified field contains a BLOB value.
Declaration Syntax
C#
public static bool BlobStreamExists(
    Guid blobId,
    Database database
)
Parameters
blobId (Guid)
The BLOB id.
database (Database)
The database.
Return Value
true if the specified field contains a BLOB value; otherwise, false.


CopyItem Method

CopyItem Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► CopyItem()()()
Members
Icon | Member | Description
 | CopyItem(Item, Item, Boolean) | Copies a specified item. Destination item should be in the same database with target item.
 | CopyItem(Item, Item, Boolean, String) | Copies a specified item. Destination item should be in the same database with target item.
 | CopyItem(Item, Item, Boolean, String, ID) | Copies a specified item. Destination item should be in the same database with target item.


CopyItem Method (source, destination, deep)

CopyItem Method (source, destination, deep)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► CopyItem(Item, Item, Boolean)
Copies a specified item. Destination item should be in the same database with target item.
Declaration Syntax
C#
public static Item CopyItem(
    Item source,
    Item destination,
    bool deep
)
Parameters
source (Item)
The item to copy.
destination (Item)
The destination.
deep (Boolean)
if set to true this instance is deep.
Return Value


CopyItem Method (source, destination, deep, copyName)

CopyItem Method (source, destination, deep, copyName)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► CopyItem(Item, Item, Boolean, String)
Copies a specified item. Destination item should be in the same database with target item.
Declaration Syntax
C#
public static Item CopyItem(
    Item source,
    Item destination,
    bool deep,
    string copyName
)
Parameters
source (Item)
The item to copy.
destination (Item)
The destination.
deep (Boolean)
if set to true [deep].
copyName (String)
Name of the copied item.
Return Value


CopyItem Method (source, destination, deep, copyName, copyId)

CopyItem Method (source, destination, deep, copyName, copyId)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► CopyItem(Item, Item, Boolean, String, ID)
Copies a specified item. Destination item should be in the same database with target item.
Declaration Syntax
C#
public static Item CopyItem(
    Item source,
    Item destination,
    bool deep,
    string copyName,
    ID copyId
)
Parameters
source (Item)
The item to copy.
destination (Item)
The destination.
deep (Boolean)
If set to true, child items will be copied recursively.
copyName (String)
Name of the copied item.
copyId (ID)
Id of the copied item.
Return Value


CreateItem Method

CreateItem Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► CreateItem()()()
Members
Icon | Member | Description
 | CreateItem(String, Item, ID) | Creates an empty item.
 | CreateItem(String, Item, ID, ID) | Creates an empty item.
 | CreateItem(String, Item, ID, ID, SecurityCheck) | Creates an empty item.


CreateItem Method (itemName, destination, templateId)

CreateItem Method (itemName, destination, templateId)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► CreateItem(String, Item, ID)
Creates an empty item.
Declaration Syntax
C#
public static Item CreateItem(
    string itemName,
    Item destination,
    ID templateId
)
Parameters
itemName (String)
Name of the item.
destination (Item)
The destination.
templateId (ID)
The template ID.
Return Value
The created item. If the item could not be created, null is returned.


CreateItem Method (itemName, destination, templateId, newId)

CreateItem Method (itemName, destination, templateId, newId)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► CreateItem(String, Item, ID, ID)
Creates an empty item.
Declaration Syntax
C#
public static Item CreateItem(
    string itemName,
    Item destination,
    ID templateId,
    ID newId
)
Parameters
itemName (String)
Name of the item.
destination (Item)
The destination.
templateId (ID)
The template ID.
newId (ID)
The item id.
Return Value
The created item. If the item could not be created, null is returned.


CreateItem Method (itemName, destination, templateId, newId, securityCheck)

CreateItem Method (itemName, destination, templateId, newId, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► CreateItem(String, Item, ID, ID, SecurityCheck)
Creates an empty item.
Declaration Syntax
C#
public static Item CreateItem(
    string itemName,
    Item destination,
    ID templateId,
    ID newId,
    SecurityCheck securityCheck
)
Parameters
itemName (String)
Name of the item.
destination (Item)
The destination.
templateId (ID)
The template ID.
newId (ID)
The item id.
securityCheck (SecurityCheck)
The security check.
Return Value
The created item. If the item was created, but could not be read, null is returned.


DeleteItem Method

DeleteItem Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► DeleteItem()()()
Members
Icon | Member | Description
 | DeleteItem(Item) | Deletes an item.
 | DeleteItem(Item, SecurityCheck) | Deletes an item.


DeleteItem Method (item)

DeleteItem Method (item)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► DeleteItem(Item)
Deletes an item.
Declaration Syntax
C#
public static bool DeleteItem(
    Item item
)
Parameters
item (Item)
The item to delete.
Return Value
True if the item was deleted, false otherwise.


DeleteItem Method (item, securityCheck)

DeleteItem Method (item, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► DeleteItem(Item, SecurityCheck)
Deletes an item.
Declaration Syntax
C#
public static bool DeleteItem(
    Item item,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item to delete.
securityCheck (SecurityCheck)
The security check.
Return Value
True if the item was deleted, false otherwise.


GetBlobStream Method

GetBlobStream Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetBlobStream()()()
Members
Icon | Member | Description
 | GetBlobStream(Field) | Gets the BLOB stream associated with a field.
 | GetBlobStream(Guid, Database) | Gets a BLOB stream from its id.


GetBlobStream Method (field)

GetBlobStream Method (field)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetBlobStream(Field)
Gets the BLOB stream associated with a field.
Declaration Syntax
C#
public static Stream GetBlobStream(
    Field field
)
Parameters
field (Field)
The field.
Return Value
The stream.


GetBlobStream Method (blobId, database)

GetBlobStream Method (blobId, database)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetBlobStream(Guid, Database)
Gets a BLOB stream from its id.
Declaration Syntax
C#
public static Stream GetBlobStream(
    Guid blobId,
    Database database
)
Parameters
blobId (Guid)
The BLOB id.
database (Database)
The database.
Return Value
The stream.


GetChildren Method

GetChildren Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetChildren()()()
Members
Icon | Member | Description
 | GetChildren(Item) | Gets the children of an item.
 | GetChildren(Item, SecurityCheck) | Gets the children of an item.


GetChildren Method (item)

GetChildren Method (item)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetChildren(Item)
Gets the children of an item.
Declaration Syntax
C#
public static ChildList GetChildren(
    Item item
)
Parameters
item (Item)
The parent item.
Return Value
The child items.


GetChildren Method (item, securityCheck)

GetChildren Method (item, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetChildren(Item, SecurityCheck)
Gets the children of an item.
Declaration Syntax
C#
public static ChildList GetChildren(
    Item item,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The parent item.
securityCheck (SecurityCheck)
The security check.
Return Value
The child items.


GetContentLanguages Method (item)

GetContentLanguages Method (item)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetContentLanguages(Item)
Gets the content languages (ie. the languages for which the item has content).
Declaration Syntax
C#
public static LanguageCollection GetContentLanguages(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetItem Method

GetItem Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetItem()()()
Members
Icon | Member | Description
 | GetItem(ID, Language, Version, Database) | Gets an item from a database.
 | GetItem(ID, Language, Version, Database, SecurityCheck) | Gets an item from a database.
 | GetItem(String, Language, Version, Database) | Gets an item from a database.
 | GetItem(String, Language, Version, Database, SecurityCheck) | Gets an item from a database.


GetItem Method (itemId, language, version, database)

GetItem Method (itemId, language, version, database)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetItem(ID, Language, Version, Database)
Gets an item from a database.
Declaration Syntax
C#
public static Item GetItem(
    ID itemId,
    Language language,
    Version version,
    Database database
)
Parameters
itemId (ID)
The item id.
language (Language)
The language of the item to get.
version (Version)
The version of the item to get.
database (Database)
The database.
Return Value
The item. If no item is found, null is returned.


GetItem Method (itemId, language, version, database, securityCheck)

GetItem Method (itemId, language, version, database, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetItem(ID, Language, Version, Database, SecurityCheck)
Gets an item from a database.
Declaration Syntax
C#
public static Item GetItem(
    ID itemId,
    Language language,
    Version version,
    Database database,
    SecurityCheck securityCheck
)
Parameters
itemId (ID)
The item id.
language (Language)
The language of the item to get.
version (Version)
The version of the item to get.
database (Database)
The database.
securityCheck (SecurityCheck)
The security check.
Return Value
The item. If no item is found, null is returned.


GetItem Method (itemPath, language, version, database)

GetItem Method (itemPath, language, version, database)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetItem(String, Language, Version, Database)
Gets an item from a database.
Declaration Syntax
C#
public static Item GetItem(
    string itemPath,
    Language language,
    Version version,
    Database database
)
Parameters
itemPath (String)
The item path.
language (Language)
The language of the item to get.
version (Version)
The version of the item to get.
database (Database)
The database.
Return Value
The item. If no item is found, null is returned.


GetItem Method (itemPath, language, version, database, securityCheck)

GetItem Method (itemPath, language, version, database, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetItem(String, Language, Version, Database, SecurityCheck)
Gets an item from a database.
Declaration Syntax
C#
public static Item GetItem(
    string itemPath,
    Language language,
    Version version,
    Database database,
    SecurityCheck securityCheck
)
Parameters
itemPath (String)
The item path.
language (Language)
The language of the item to get.
version (Version)
The version of the item to get.
database (Database)
The database.
securityCheck (SecurityCheck)
The security check.
Return Value
The item. If no item is found, null is returned.


GetParent Method

GetParent Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetParent()()()
Members
Icon | Member | Description
 | GetParent(Item) | Gets the parent of an item.
 | GetParent(Item, SecurityCheck) | Gets the parent of an item.


GetParent Method (item)

GetParent Method (item)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetParent(Item)
Gets the parent of an item.
Declaration Syntax
C#
public static Item GetParent(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The parent item.


GetParent Method (item, securityCheck)

GetParent Method (item, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetParent(Item, SecurityCheck)
Gets the parent of an item.
Declaration Syntax
C#
public static Item GetParent(
    Item item,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item.
securityCheck (SecurityCheck)
The security check.
Return Value
The parent item.


GetRootItem Method

GetRootItem Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetRootItem()()()
Members
Icon | Member | Description
 | GetRootItem(Language, Version, Database) | Gets the root item.
 | GetRootItem(Language, Version, Database, SecurityCheck) | Gets the root item.


GetRootItem Method (language, version, database)

GetRootItem Method (language, version, database)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetRootItem(Language, Version, Database)
Gets the root item.
Declaration Syntax
C#
public static Item GetRootItem(
    Language language,
    Version version,
    Database database
)
Parameters
language (Language)
The language to return.
version (Version)
The version to return.
database (Database)
The database.
Return Value
The root item. If no item is found, null is returned.


GetRootItem Method (language, version, database, securityCheck)

GetRootItem Method (language, version, database, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetRootItem(Language, Version, Database, SecurityCheck)
Gets the root item.
Declaration Syntax
C#
public static Item GetRootItem(
    Language language,
    Version version,
    Database database,
    SecurityCheck securityCheck
)
Parameters
language (Language)
The language to return.
version (Version)
The version to return.
database (Database)
The database.
securityCheck (SecurityCheck)
The security check.
Return Value
The root item. If no item is found, null is returned.


GetVersions Method

GetVersions Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetVersions()()()
Members
Icon | Member | Description
 | GetVersions(Item) | Gets the version numbers of an item.
 | GetVersions(Item, Language) | Gets the version numbers of an item.


GetVersions Method (item)

GetVersions Method (item)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetVersions(Item)
Gets the version numbers of an item.
Declaration Syntax
C#
public static VersionCollection GetVersions(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The list of versions.


GetVersions Method (item, language)

GetVersions Method (item, language)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► GetVersions(Item, Language)
Gets the version numbers of an item.
Declaration Syntax
C#
public static VersionCollection GetVersions(
    Item item,
    Language language
)
Parameters
item (Item)
The item.
language (Language)
The language.
Return Value
The list of versions.


HasChildren Method

HasChildren Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► HasChildren()()()
Members
Icon | Member | Description
 | HasChildren(Item) | Determines whether the specified item has children.
 | HasChildren(Item, SecurityCheck) | Determines whether the specified item has children.


HasChildren Method (item)

HasChildren Method (item)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► HasChildren(Item)
Determines whether the specified item has children.
Declaration Syntax
C#
public static bool HasChildren(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item has children; otherwise, false.


HasChildren Method (item, securityCheck)

HasChildren Method (item, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► HasChildren(Item, SecurityCheck)
Determines whether the specified item has children.
Declaration Syntax
C#
public static bool HasChildren(
    Item item,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item.
securityCheck (SecurityCheck)
The security check.
Return Value
true if the specified item has children; otherwise, false.


Initialize Method

Initialize Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► Initialize()()()
Initializes class.
Declaration Syntax
C#
public static void Initialize()


MoveItem Method

MoveItem Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► MoveItem()()()
Members
Icon | Member | Description
 | MoveItem(Item, Item) | Moves an item.
 | MoveItem(Item, Item, SecurityCheck) | Moves an item.


MoveItem Method (item, destination)

MoveItem Method (item, destination)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► MoveItem(Item, Item)
Moves an item.
Declaration Syntax
C#
public static bool MoveItem(
    Item item,
    Item destination
)
Parameters
item (Item)
The item to move.
destination (Item)
The destination. This will become the new parent of item.
Return Value
true if the item was moved; false otherwise.


MoveItem Method (item, destination, securityCheck)

MoveItem Method (item, destination, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► MoveItem(Item, Item, SecurityCheck)
Moves an item.
Declaration Syntax
C#
public static bool MoveItem(
    Item item,
    Item destination,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item.
destination (Item)
The destination.
securityCheck (SecurityCheck)
The security check.
Return Value


Provider Property

Provider Property
Namespaces ► Sitecore.Data.Managers ► ItemManager ► Provider
The provider instance handling requests to the maanager.
Declaration Syntax
C#
public static ItemProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Data.Managers ► ItemManager ► Providers
Gets the providers.
Declaration Syntax
C#
public static ItemProviderCollection Providers { get; }
Value
The providers.


RemoveData Method

RemoveData Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► RemoveData()()()
Members
Icon | Member | Description
 | RemoveData(ID, Database) | Removes all data from an item.
 | RemoveData(ID, Language, Boolean, Database) | Removes all data in a specific language from an item.


RemoveData Method (itemId, database)

RemoveData Method (itemId, database)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► RemoveData(ID, Database)
Removes all data from an item.
Declaration Syntax
C#
public static bool RemoveData(
    ID itemId,
    Database database
)
Parameters
itemId (ID)
The item id.
database (Database)
The database.
Return Value
true if the data was removed, otherwise false.


RemoveData Method (itemId, language, removeSharedData, database)

RemoveData Method (itemId, language, removeSharedData, database)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► RemoveData(ID, Language, Boolean, Database)
Removes all data in a specific language from an item.
Declaration Syntax
C#
public static bool RemoveData(
    ID itemId,
    Language language,
    bool removeSharedData,
    Database database
)
Parameters
itemId (ID)
The item id.
language (Language)
The language of the data to remove. Specify Invariant to remove data in all languages.
removeSharedData (Boolean)
If set to true shared data is removed.
database (Database)
The database.
Return Value
true if the data was removed, otherwise false.


RemoveVersion Method

RemoveVersion Method
Namespaces ► Sitecore.Data.Managers ► ItemManager ► RemoveVersion()()()
Members
Icon | Member | Description
 | RemoveVersion(Item) | Removes a version from an item.
 | RemoveVersion(Item, SecurityCheck) | Removes a version from an item.


RemoveVersion Method (item)

RemoveVersion Method (item)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► RemoveVersion(Item)
Removes a version from an item.
Declaration Syntax
C#
public static bool RemoveVersion(
    Item item
)
Parameters
item (Item)
The item representing the version to remove.
Return Value
true if the version was removed, otherwise false.


RemoveVersion Method (item, securityCheck)

RemoveVersion Method (item, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► RemoveVersion(Item, SecurityCheck)
Removes a version from an item.
Declaration Syntax
C#
public static bool RemoveVersion(
    Item item,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item representing the version to remove.
securityCheck (SecurityCheck)
The security check.
Return Value
true if the version was removed, otherwise false.


RemoveVersions Method (item, language, securityCheck)

RemoveVersions Method (item, language, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► RemoveVersions(Item, Language, SecurityCheck)
Deletes all versions in the specified language.
Declaration Syntax
C#
public static void RemoveVersions(
    Item item,
    Language language,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item.
language (Language)
The language.
securityCheck (SecurityCheck)
The security check.


ResolvePath Method (itemPath, database)

ResolvePath Method (itemPath, database)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► ResolvePath(String, Database)
Resolves an item path to an id.
Declaration Syntax
C#
public static ID ResolvePath(
    string itemPath,
    Database database
)
Parameters
itemPath (String)
The item path.
database (Database)
The database.
Return Value
The id of the item with the path specified by itemPath.


SaveItem Method (item)

SaveItem Method (item)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► SaveItem(Item)
Saves changes to an item.
Declaration Syntax
C#
public static bool SaveItem(
    Item item
)
Parameters
item (Item)
The item.
Return Value
True if the item was saved, false otherwise.


SetBlobStream Method (stream, blobId, database)

SetBlobStream Method (stream, blobId, database)
Namespaces ► Sitecore.Data.Managers ► ItemManager ► SetBlobStream(Stream, Guid, Database)
Sets the BLOB stream associated with a field.
Declaration Syntax
C#
public static bool SetBlobStream(
    Stream stream,
    Guid blobId,
    Database database
)
Parameters
stream (Stream)
The stream.
blobId (Guid)
The BLOB id.
database (Database)
The database.
Return Value
The guid identifying the new blob.


ItemProvider Class

ItemProvider Class
Namespaces ► Sitecore.Data.Managers ► ItemProvider
Provider for performing basic CRUD operations against the item database.
Declaration Syntax
C#
public class ItemProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemProvider()()() | Initializes a new instance of the ItemProvider class.
 | AddFromTemplate(String, ID, Item, ID) | Adds a new item from a template.
 | AddVersion(Item, SecurityCheck) | Adds a new version to an item by copying the data from an existing version.
 | ApplySecurity(Item, SecurityCheck) | Applies security to an items.
 | ApplySecurity(ItemList, SecurityCheck) | Applies security to a collection of items.
 | BlobStreamExists(Guid, Database) | Determines whether the specified field contains a BLOB value.
 | CopyItem(Item, Item, Boolean, String, ID) | Copies a specified item.
 | CreateItem(String, Item, ID, ID, SecurityCheck) | Creates an empty item.
 | DeleteItem(Item, SecurityCheck) | Deletes an item.
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | DoCreateItem(String, Item, ID, ID) | Creates a new item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBlobStream(Guid, Database) | Gets a BLOB stream from its id.
 | GetChildren(Item, SecurityCheck) | Gets the children of an item.
 | GetChildren(Item) | Gets the children of an item.
 | GetContentLanguages(Item) | Gets the content languages (ie. the languages for which the item has content).
 | GetDataEngine(Database) | Gets the data engine associated with a database.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(ID, Language, Version, Database, SecurityCheck) | Gets an item from a database.
 | GetItem(String, Language, Version, Database, SecurityCheck) | Gets an item from a database.
 | GetItem(ID, Language, Version, Database) | Gets an item from a database.
 | GetParent(Item, SecurityCheck) | Gets the parent of an item.
 | GetParent(Item) | Gets the parent of an item.
 | GetRootItem(Language, Version, Database, SecurityCheck) | Gets the root item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersions(Item, Language) | Gets the version numbers of an item.
 | HasChildren(Item) | Obsolete. Determines whether the specified item has children.
 | HasChildren(Item, SecurityCheck) | Determines whether the specified item has children.
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | InsertVirtualChildren(ItemList, Item) | Inserts shadows (if any) into a native list of children.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveItem(Item, Item, SecurityCheck) | Moves an item.
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | RemoveData(ID, Language, Boolean, Database) | Removes all data in a specific language from an item.
 | RemoveVersion(Item, SecurityCheck) | Removes a version from an item.
 | RemoveVersions(Item, Language, SecurityCheck) | Deletes all versions in the specified language.
 | ResolvePath(String, Database) | Resolves an item path to an id.
 | SaveItem(Item) | Saves changes to an item.
 | SetBlobStream(Stream, Guid, Database) | Sets the BLOB stream associated with a field.
 | Sort(ItemList, Item) | Sorts the specified items.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | ItemProvider


ItemProvider Constructor

ItemProvider Constructor
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► ItemProvider()()()
Initializes a new instance of the ItemProvider class.
Declaration Syntax
C#
public ItemProvider()


AddFromTemplate Method (itemName, templateId, destination, newId)

AddFromTemplate Method (itemName, templateId, destination, newId)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► AddFromTemplate(String, ID, Item, ID)
Adds a new item from a template.
Declaration Syntax
C#
public virtual Item AddFromTemplate(
    string itemName,
    ID templateId,
    Item destination,
    ID newId
)
Parameters
itemName (String)
Name of the new item.
templateId (ID)
The template id.
destination (Item)
The destination item. This will be the parent of the new item.
newId (ID)
The id of the new item.
Return Value


AddVersion Method (item, securityCheck)

AddVersion Method (item, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► AddVersion(Item, SecurityCheck)
Adds a new version to an item by copying the data from an existing version.
Declaration Syntax
C#
public virtual Item AddVersion(
    Item item,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item that will have a version added.
securityCheck (SecurityCheck)
The security check.
Return Value
The added version of the item. If a version could not be added to the item, null is returned.


ApplySecurity Method

ApplySecurity Method
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► ApplySecurity()()()
Members
Icon | Member | Description
 | ApplySecurity(Item, SecurityCheck) | Applies security to an items.
 | ApplySecurity(ItemList, SecurityCheck) | Applies security to a collection of items.


ApplySecurity Method (children, securityCheck)

ApplySecurity Method (children, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► ApplySecurity(ItemList, SecurityCheck)
Applies security to a collection of items.
Declaration Syntax
C#
protected virtual ItemList ApplySecurity(
    ItemList children,
    SecurityCheck securityCheck
)
Parameters
children (ItemList)
The items.
securityCheck (SecurityCheck)
The security check to perform.
Return Value
A collection with the items that the current user has 'read' access to.
Remarks
All items that can not be read by the current user will be removed from the collection.


ApplySecurity Method (item, securityCheck)

ApplySecurity Method (item, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► ApplySecurity(Item, SecurityCheck)
Applies security to an items.
Declaration Syntax
C#
protected virtual Item ApplySecurity(
    Item item,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item.
securityCheck (SecurityCheck)
The security check to perform.
Return Value
Remarks
If the item can not be read by the current user, null will be returned.


BlobStreamExists Method (blobId, database)

BlobStreamExists Method (blobId, database)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► BlobStreamExists(Guid, Database)
Determines whether the specified field contains a BLOB value.
Declaration Syntax
C#
public virtual bool BlobStreamExists(
    Guid blobId,
    Database database
)
Parameters
blobId (Guid)
The BLOB id.
database (Database)
The database.
Return Value
true if the specified field contains a BLOB value; otherwise, false.


CopyItem Method (source, destination, deep, copyName, copyId)

CopyItem Method (source, destination, deep, copyName, copyId)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► CopyItem(Item, Item, Boolean, String, ID)
Copies a specified item.
Declaration Syntax
C#
public virtual Item CopyItem(
    Item source,
    Item destination,
    bool deep,
    string copyName,
    ID copyId
)
Parameters
source (Item)
The item to copy.
destination (Item)
The destination.
deep (Boolean)
If set to true, child items will be copied recursively.
copyName (String)
Name of the copied item.
copyId (ID)
Id of the copied item.
Return Value


CreateItem Method (itemName, destination, templateId, newId, securityCheck)

CreateItem Method (itemName, destination, templateId, newId, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► CreateItem(String, Item, ID, ID, SecurityCheck)
Creates an empty item.
Declaration Syntax
C#
public virtual Item CreateItem(
    string itemName,
    Item destination,
    ID templateId,
    ID newId,
    SecurityCheck securityCheck
)
Parameters
itemName (String)
Name of the item.
destination (Item)
The destination.
templateId (ID)
The template ID.
newId (ID)
The item id.
securityCheck (SecurityCheck)
The security check.
Return Value
The created item. If the item was created, but could not be read, null is returned.


DeleteItem Method (item, securityCheck)

DeleteItem Method (item, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► DeleteItem(Item, SecurityCheck)
Deletes an item.
Declaration Syntax
C#
public virtual bool DeleteItem(
    Item item,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item to delete.
securityCheck (SecurityCheck)
The security check.
Return Value
True if the item was deleted, false otherwise.


DoCreateItem Method (itemName, destination, templateId, newId)

DoCreateItem Method (itemName, destination, templateId, newId)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► DoCreateItem(String, Item, ID, ID)
Creates a new item.
Declaration Syntax
C#
protected virtual void DoCreateItem(
    string itemName,
    Item destination,
    ID templateId,
    ID newId
)
Parameters
itemName (String)
Name of the item.
destination (Item)
The destination.
templateId (ID)
The template id.
newId (ID)
The new id.


GetBlobStream Method (blobId, database)

GetBlobStream Method (blobId, database)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetBlobStream(Guid, Database)
Gets a BLOB stream from its id.
Declaration Syntax
C#
public virtual Stream GetBlobStream(
    Guid blobId,
    Database database
)
Parameters
blobId (Guid)
The BLOB id.
database (Database)
The database.
Return Value
The stream.


GetChildren Method

GetChildren Method
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetChildren()()()
Members
Icon | Member | Description
 | GetChildren(Item, SecurityCheck) | Gets the children of an item.
 | GetChildren(Item) | Gets the children of an item.


GetChildren Method (item)

GetChildren Method (item)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetChildren(Item)
Gets the children of an item.
Declaration Syntax
C#
protected virtual ItemList GetChildren(
    Item item
)
Parameters
item (Item)
The parent item.
Return Value
The child items.


GetChildren Method (item, securityCheck)

GetChildren Method (item, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetChildren(Item, SecurityCheck)
Gets the children of an item.
Declaration Syntax
C#
public virtual ChildList GetChildren(
    Item item,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The parent item.
securityCheck (SecurityCheck)
The security check.
Return Value
The child items.


GetContentLanguages Method (item)

GetContentLanguages Method (item)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetContentLanguages(Item)
Gets the content languages (ie. the languages for which the item has content).
Declaration Syntax
C#
public virtual LanguageCollection GetContentLanguages(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetDataEngine Method (database)

GetDataEngine Method (database)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetDataEngine(Database)
Gets the data engine associated with a database.
Declaration Syntax
C#
protected virtual DataEngine GetDataEngine(
    Database database
)
Parameters
database (Database)
The database.
Return Value


GetItem Method

GetItem Method
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetItem()()()
Members
Icon | Member | Description
 | GetItem(ID, Language, Version, Database, SecurityCheck) | Gets an item from a database.
 | GetItem(String, Language, Version, Database, SecurityCheck) | Gets an item from a database.
 | GetItem(ID, Language, Version, Database) | Gets an item from a database.


GetItem Method (itemId, language, version, database)

GetItem Method (itemId, language, version, database)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetItem(ID, Language, Version, Database)
Gets an item from a database.
Declaration Syntax
C#
protected virtual Item GetItem(
    ID itemId,
    Language language,
    Version version,
    Database database
)
Parameters
itemId (ID)
The item id.
language (Language)
The language of the item to get.
version (Version)
The version of the item to get.
database (Database)
The database.
Return Value
The item. If no item is found, null is returned.


GetItem Method (itemId, language, version, database, securityCheck)

GetItem Method (itemId, language, version, database, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetItem(ID, Language, Version, Database, SecurityCheck)
Gets an item from a database.
Declaration Syntax
C#
public virtual Item GetItem(
    ID itemId,
    Language language,
    Version version,
    Database database,
    SecurityCheck securityCheck
)
Parameters
itemId (ID)
The item id.
language (Language)
The language of the item to get.
version (Version)
The version of the item to get.
database (Database)
The database.
securityCheck (SecurityCheck)
The security check.
Return Value
The item. If no item is found, null is returned.


GetItem Method (itemPath, language, version, database, securityCheck)

GetItem Method (itemPath, language, version, database, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetItem(String, Language, Version, Database, SecurityCheck)
Gets an item from a database.
Declaration Syntax
C#
public virtual Item GetItem(
    string itemPath,
    Language language,
    Version version,
    Database database,
    SecurityCheck securityCheck
)
Parameters
itemPath (String)
The item path.
language (Language)
The language of the item to get.
version (Version)
The version of the item to get.
database (Database)
The database.
securityCheck (SecurityCheck)
The security check.
Return Value
The item. If no item is found, null is returned.


GetParent Method

GetParent Method
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetParent()()()
Members
Icon | Member | Description
 | GetParent(Item, SecurityCheck) | Gets the parent of an item.
 | GetParent(Item) | Gets the parent of an item.


GetParent Method (item)

GetParent Method (item)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetParent(Item)
Gets the parent of an item.
Declaration Syntax
C#
protected virtual Item GetParent(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The parent item.


GetParent Method (item, securityCheck)

GetParent Method (item, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetParent(Item, SecurityCheck)
Gets the parent of an item.
Declaration Syntax
C#
public virtual Item GetParent(
    Item item,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item.
securityCheck (SecurityCheck)
The security check.
Return Value
The parent item.


GetRootItem Method (language, version, database, securityCheck)

GetRootItem Method (language, version, database, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetRootItem(Language, Version, Database, SecurityCheck)
Gets the root item.
Declaration Syntax
C#
public virtual Item GetRootItem(
    Language language,
    Version version,
    Database database,
    SecurityCheck securityCheck
)
Parameters
language (Language)
The language to return.
version (Version)
The version to return.
database (Database)
The database.
securityCheck (SecurityCheck)
The security check.
Return Value
The root item. If no item is found, null is returned.


GetVersions Method (item, language)

GetVersions Method (item, language)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► GetVersions(Item, Language)
Gets the version numbers of an item.
Declaration Syntax
C#
public virtual VersionCollection GetVersions(
    Item item,
    Language language
)
Parameters
item (Item)
The item.
language (Language)
The language.
Return Value
The list of versions.


HasChildren Method

HasChildren Method
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► HasChildren()()()
Members
Icon | Member | Description
 | HasChildren(Item) | Obsolete. Determines whether the specified item has children.
 | HasChildren(Item, SecurityCheck) | Determines whether the specified item has children.


HasChildren Method (item)

HasChildren Method (item)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► HasChildren(Item)
Determines whether the specified item has children.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use HasChildren(Item, SecurityCheck) instead.")]
public virtual bool HasChildren(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item has children; otherwise, false.


HasChildren Method (item, securityCheck)

HasChildren Method (item, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► HasChildren(Item, SecurityCheck)
Determines whether the specified item has children.
Declaration Syntax
C#
public virtual bool HasChildren(
    Item item,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item.
securityCheck (SecurityCheck)
The security check.
Return Value
true if the specified item has children; otherwise, false.


InsertVirtualChildren Method (children, parent)

InsertVirtualChildren Method (children, parent)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► InsertVirtualChildren(ItemList, Item)
Inserts shadows (if any) into a native list of children.
Declaration Syntax
C#
protected virtual void InsertVirtualChildren(
    ItemList children,
    Item parent
)
Parameters
children (ItemList)
The children.
parent (Item)
The parent of the children.


MoveItem Method (item, destination, securityCheck)

MoveItem Method (item, destination, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► MoveItem(Item, Item, SecurityCheck)
Moves an item.
Declaration Syntax
C#
public virtual bool MoveItem(
    Item item,
    Item destination,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item to move.
destination (Item)
The destination. This will become the new parent of item.
securityCheck (SecurityCheck)
The security check.
Return Value
true if the item was moved; false otherwise.


RemoveData Method (itemId, language, removeSharedData, database)

RemoveData Method (itemId, language, removeSharedData, database)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► RemoveData(ID, Language, Boolean, Database)
Removes all data in a specific language from an item.
Declaration Syntax
C#
public virtual bool RemoveData(
    ID itemId,
    Language language,
    bool removeSharedData,
    Database database
)
Parameters
itemId (ID)
The item id.
language (Language)
The language of the data to remove. Specify Invariant to remove data in all languages.
removeSharedData (Boolean)
If set to true shared data is removed.
database (Database)
The database.
Return Value
true if the data was removed, otherwise false.


RemoveVersion Method (item, securityCheck)

RemoveVersion Method (item, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► RemoveVersion(Item, SecurityCheck)
Removes a version from an item.
Declaration Syntax
C#
public virtual bool RemoveVersion(
    Item item,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item representing the version to remove.
securityCheck (SecurityCheck)
The security check.
Return Value
true if the version was removed, otherwise false.


RemoveVersions Method (item, language, securityCheck)

RemoveVersions Method (item, language, securityCheck)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► RemoveVersions(Item, Language, SecurityCheck)
Deletes all versions in the specified language.
Declaration Syntax
C#
public virtual void RemoveVersions(
    Item item,
    Language language,
    SecurityCheck securityCheck
)
Parameters
item (Item)
The item.
language (Language)
The language.
securityCheck (SecurityCheck)
The security check.


ResolvePath Method (itemPath, database)

ResolvePath Method (itemPath, database)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► ResolvePath(String, Database)
Resolves an item path to an id.
Declaration Syntax
C#
public virtual ID ResolvePath(
    string itemPath,
    Database database
)
Parameters
itemPath (String)
The item path.
database (Database)
The database.
Return Value
The id of the item with the path specified by itemPath.


SaveItem Method (item)

SaveItem Method (item)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► SaveItem(Item)
Saves changes to an item.
Declaration Syntax
C#
public virtual bool SaveItem(
    Item item
)
Parameters
item (Item)
The item.
Return Value
True if the item was saved, false otherwise.


SetBlobStream Method (stream, blobId, database)

SetBlobStream Method (stream, blobId, database)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► SetBlobStream(Stream, Guid, Database)
Sets the BLOB stream associated with a field.
Declaration Syntax
C#
public virtual bool SetBlobStream(
    Stream stream,
    Guid blobId,
    Database database
)
Parameters
stream (Stream)
The stream.
blobId (Guid)
The BLOB id.
database (Database)
The database.
Return Value
The guid identifying the new blob.


Sort Method (items, owner)

Sort Method (items, owner)
Namespaces ► Sitecore.Data.Managers ► ItemProvider ► Sort(ItemList, Item)
Sorts the specified items.
Declaration Syntax
C#
protected virtual void Sort(
    ItemList items,
    Item owner
)
Parameters
items (ItemList)
The items.
owner (Item)
The owner.


ItemProviderCollection Class

ItemProviderCollection Class
Namespaces ► Sitecore.Data.Managers ► ItemProviderCollection
ItemProviderCollection class
Declaration Syntax
C#
public class ItemProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemProviderCollection()()() | Initializes a new instance of the ItemProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the ItemProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | ItemProviderCollection


ItemProviderCollection Constructor

ItemProviderCollection Constructor
Namespaces ► Sitecore.Data.Managers ► ItemProviderCollection ► ItemProviderCollection()()()
Initializes a new instance of the ItemProviderCollection class
Declaration Syntax
C#
public ItemProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Data.Managers ► ItemProviderCollection ► Item[([(String])])
Gets the ItemProvider with the specified name.
Declaration Syntax
C#
public ItemProvider this[
    string name
] { get; }
Parameters
name (String)
Value


LanguageManager Class

LanguageManager Class
Namespaces ► Sitecore.Data.Managers ► LanguageManager
Manager for language related operations.
Declaration Syntax
C#
public sealed class LanguageManager
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LanguageManager()()() | Initializes a new instance of the LanguageManager class
 | AddLanguage(Language, Database) | Obsolete. Adds a Language to a specific database.
 | DefaultLanguage | Gets the default language.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLanguage(String) | Gets a language by name.
 | GetLanguage(String, Database) | Gets a language (only if it is defined in the specified database).
 | GetLanguageItemId(Language, Database) | Gets the id of the item representing the language in a specific database.
 | GetLanguages(Database) | Gets all the languages defined in a specific database.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initialize type.
 | IsLanguageNameDefined(Database, String) | Determines if the language name is defined in the specified database.
 | IsValidLanguageName(String) | Determines whether the specified name is a valid language name.
 | LanguageRegistered(String) | Gets a value indicating if a specific language is registered with the ASP.NET globalization engine.
 | LanguageRegistered(String, Database) | Gets a value indicating if a specific language is registered in a specific database.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Provider | Gets the current provider.
 | RegisterLanguage(String) | Registers a specific language in the ASP.NET globalization engine.
 | RemoveLanguageData(Language, Database) | Removes all data using a specific language from the database.
 | RenameLanguageData(String, String, Database) | Rename all data language bindings for a specific language.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LanguageManager


LanguageManager Constructor

LanguageManager Constructor
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► LanguageManager()()()
Initializes a new instance of the LanguageManager class
Declaration Syntax
C#
public LanguageManager()


AddLanguage Method (language, database)

AddLanguage Method (language, database)
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► AddLanguage(Language, Database)
Adds a Language to a specific database.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static void AddLanguage(
    Language language,
    Database database
)
Parameters
language (Language)
The language.
database (Database)
The database.
Remarks
If the language already exists in the target database, no action will be taken.


DefaultLanguage Property

DefaultLanguage Property
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► DefaultLanguage
Gets the default language.
Declaration Syntax
C#
public static Language DefaultLanguage { get; }
Value
The default language.


GetLanguage Method

GetLanguage Method
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► GetLanguage()()()
Members
Icon | Member | Description
 | GetLanguage(String) | Gets a language by name.
 | GetLanguage(String, Database) | Gets a language (only if it is defined in the specified database).


GetLanguage Method (name)

GetLanguage Method (name)
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► GetLanguage(String)
Gets a language by name.
Declaration Syntax
C#
public static Language GetLanguage(
    string name
)
Parameters
name (String)
The name.
Return Value
The language.


GetLanguage Method (name, database)

GetLanguage Method (name, database)
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► GetLanguage(String, Database)
Gets a language (only if it is defined in the specified database).
Declaration Syntax
C#
public static Language GetLanguage(
    string name,
    Database database
)
Parameters
name (String)
The name.
database (Database)
The database.
Return Value


GetLanguageItemId Method (language, database)

GetLanguageItemId Method (language, database)
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► GetLanguageItemId(Language, Database)
Gets the id of the item representing the language in a specific database.
Declaration Syntax
C#
public static ID GetLanguageItemId(
    Language language,
    Database database
)
Parameters
language (Language)
The language.
database (Database)
The database.
Return Value
The language item id.


GetLanguages Method (database)

GetLanguages Method (database)
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► GetLanguages(Database)
Gets all the languages defined in a specific database.
Declaration Syntax
C#
public static LanguageCollection GetLanguages(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The languages.


Initialize Method

Initialize Method
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► Initialize()()()
Initialize type.
Declaration Syntax
C#
public static void Initialize()


IsLanguageNameDefined Method (database, languageName)

IsLanguageNameDefined Method (database, languageName)
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► IsLanguageNameDefined(Database, String)
Determines if the language name is defined in the specified database.
Declaration Syntax
C#
public static bool IsLanguageNameDefined(
    Database database,
    string languageName
)
Parameters
database (Database)
The database.
languageName (String)
The name.
Return Value
true if the language name is defined in the specified database; otherwise, false.


IsValidLanguageName Method (name)

IsValidLanguageName Method (name)
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► IsValidLanguageName(String)
Determines whether the specified name is a valid language name.
Declaration Syntax
C#
public static bool IsValidLanguageName(
    string name
)
Parameters
name (String)
The name.
Return Value
true if the specified name is a valid language name; otherwise, false.


LanguageRegistered Method

LanguageRegistered Method
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► LanguageRegistered()()()
Members
Icon | Member | Description
 | LanguageRegistered(String) | Gets a value indicating if a specific language is registered with the ASP.NET globalization engine.
 | LanguageRegistered(String, Database) | Gets a value indicating if a specific language is registered in a specific database.


LanguageRegistered Method (name)

LanguageRegistered Method (name)
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► LanguageRegistered(String)
Gets a value indicating if a specific language is registered with the ASP.NET globalization engine.
Declaration Syntax
C#
public static bool LanguageRegistered(
    string name
)
Parameters
name (String)
The name.
Return Value


LanguageRegistered Method (name, database)

LanguageRegistered Method (name, database)
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► LanguageRegistered(String, Database)
Gets a value indicating if a specific language is registered in a specific database.
Declaration Syntax
C#
public static bool LanguageRegistered(
    string name,
    Database database
)
Parameters
name (String)
The name.
database (Database)
The database.
Return Value


Provider Property

Provider Property
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► Provider
Gets the current provider.
Declaration Syntax
C#
public static LanguageProvider Provider { get; }
Value
The provider.


RegisterLanguage Method (name)

RegisterLanguage Method (name)
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► RegisterLanguage(String)
Registers a specific language in the ASP.NET globalization engine.
Declaration Syntax
C#
public static bool RegisterLanguage(
    string name
)
Parameters
name (String)
The name.
Return Value


RemoveLanguageData Method (language, database)

RemoveLanguageData Method (language, database)
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► RemoveLanguageData(Language, Database)
Removes all data using a specific language from the database.
Declaration Syntax
C#
public static void RemoveLanguageData(
    Language language,
    Database database
)
Parameters
language (Language)
The language.
database (Database)
The database.
Remarks
If the language does not exist in the target database, no action will be taken.


RenameLanguageData Method (fromLanguage, toLanguage, database)

RenameLanguageData Method (fromLanguage, toLanguage, database)
Namespaces ► Sitecore.Data.Managers ► LanguageManager ► RenameLanguageData(String, String, Database)
Rename all data language bindings for a specific language.
Declaration Syntax
C#
public static void RenameLanguageData(
    string fromLanguage,
    string toLanguage,
    Database database
)
Parameters
fromLanguage (String)
Rename from this language name.
toLanguage (String)
Rename to this language name.
database (Database)
The database.


LanguageProvider Class

LanguageProvider Class
Namespaces ► Sitecore.Data.Managers ► LanguageProvider
Provider for language related operations.
Declaration Syntax
C#
public class LanguageProvider
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LanguageProvider()()() | Constructs an instance of LanguageProvider
 | AddLanguage(Language, Database) | Obsolete. Adds a Language to a specific database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLanguage(String) | Gets a language by name.
 | GetLanguage(String, Database) | Gets a language (only if it is defined in the specified database).
 | GetLanguageItemId(Language, Database) | Gets the id of the item representing the language in a specific database.
 | GetLanguages(Database) | Gets all the languages defined in a specific database.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InvalidateCaches(Database) | Invalidates the caches for a specific database.
 | IsLanguageNameDefined(Database, String) | Determines if the language name is defined in the specified database.
 | IsValidLanguageName(String) | Determines whether the specified name is a valid language name.
 | LanguageRegistered(String) | Gets a value indicating if a specific language is registered with the ASP.NET globalization engine.
 | LanguageRegistered(String, Database) | Gets a value indicating if a specific language is registered in a specific database.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterLanguage(String) | Registers a specific language in the ASP.NET globalization engine.
 | RemoveLanguageData(Language, Database) | Removes all data using a specific language from the database.
 | RenameLanguageData(String, String, Database) | Rename all data language bindings for a specific language.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LanguageProvider


LanguageProvider Constructor

LanguageProvider Constructor
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► LanguageProvider()()()
Constructs an instance of LanguageProvider
Declaration Syntax
C#
public LanguageProvider()


AddLanguage Method (language, database)

AddLanguage Method (language, database)
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► AddLanguage(Language, Database)
Adds a Language to a specific database.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public virtual void AddLanguage(
    Language language,
    Database database
)
Parameters
language (Language)
The language.
database (Database)
The database.
Remarks
If the language already exists in the target database, no action will be taken.


GetLanguage Method

GetLanguage Method
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► GetLanguage()()()
Members
Icon | Member | Description
 | GetLanguage(String) | Gets a language by name.
 | GetLanguage(String, Database) | Gets a language (only if it is defined in the specified database).


GetLanguage Method (name)

GetLanguage Method (name)
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► GetLanguage(String)
Gets a language by name.
Declaration Syntax
C#
public virtual Language GetLanguage(
    string name
)
Parameters
name (String)
The name.
Return Value


GetLanguage Method (name, database)

GetLanguage Method (name, database)
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► GetLanguage(String, Database)
Gets a language (only if it is defined in the specified database).
Declaration Syntax
C#
public Language GetLanguage(
    string name,
    Database database
)
Parameters
name (String)
The name.
database (Database)
The database.
Return Value


GetLanguageItemId Method (language, database)

GetLanguageItemId Method (language, database)
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► GetLanguageItemId(Language, Database)
Gets the id of the item representing the language in a specific database.
Declaration Syntax
C#
public virtual ID GetLanguageItemId(
    Language language,
    Database database
)
Parameters
language (Language)
The language.
database (Database)
The database.
Return Value


GetLanguages Method (database)

GetLanguages Method (database)
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► GetLanguages(Database)
Gets all the languages defined in a specific database.
Declaration Syntax
C#
public virtual LanguageCollection GetLanguages(
    Database database
)
Parameters
database (Database)
The database.
Return Value


InvalidateCaches Method (database)

InvalidateCaches Method (database)
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► InvalidateCaches(Database)
Invalidates the caches for a specific database.
Declaration Syntax
C#
public virtual void InvalidateCaches(
    Database database
)
Parameters
database (Database)
The database.


IsLanguageNameDefined Method (database, languageName)

IsLanguageNameDefined Method (database, languageName)
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► IsLanguageNameDefined(Database, String)
Determines if the language name is defined in the specified database.
Declaration Syntax
C#
public virtual bool IsLanguageNameDefined(
    Database database,
    string languageName
)
Parameters
database (Database)
The database.
languageName (String)
The name.
Return Value
true if the language name is defined in the specified database; otherwise, false.


IsValidLanguageName Method (name)

IsValidLanguageName Method (name)
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► IsValidLanguageName(String)
Determines whether the specified name is a valid language name.
Declaration Syntax
C#
public virtual bool IsValidLanguageName(
    string name
)
Parameters
name (String)
The name.
Return Value
true if the specified name is a valid language name; otherwise, false.


LanguageRegistered Method

LanguageRegistered Method
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► LanguageRegistered()()()
Members
Icon | Member | Description
 | LanguageRegistered(String) | Gets a value indicating if a specific language is registered with the ASP.NET globalization engine.
 | LanguageRegistered(String, Database) | Gets a value indicating if a specific language is registered in a specific database.


LanguageRegistered Method (name)

LanguageRegistered Method (name)
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► LanguageRegistered(String)
Gets a value indicating if a specific language is registered with the ASP.NET globalization engine.
Declaration Syntax
C#
public virtual bool LanguageRegistered(
    string name
)
Parameters
name (String)
The name.
Return Value


LanguageRegistered Method (name, database)

LanguageRegistered Method (name, database)
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► LanguageRegistered(String, Database)
Gets a value indicating if a specific language is registered in a specific database.
Declaration Syntax
C#
public virtual bool LanguageRegistered(
    string name,
    Database database
)
Parameters
name (String)
The name.
database (Database)
The database.
Return Value


RegisterLanguage Method (name)

RegisterLanguage Method (name)
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► RegisterLanguage(String)
Registers a specific language in the ASP.NET globalization engine.
Declaration Syntax
C#
public virtual bool RegisterLanguage(
    string name
)
Parameters
name (String)
The name.
Return Value


RemoveLanguageData Method (language, database)

RemoveLanguageData Method (language, database)
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► RemoveLanguageData(Language, Database)
Removes all data using a specific language from the database.
Declaration Syntax
C#
public virtual void RemoveLanguageData(
    Language language,
    Database database
)
Parameters
language (Language)
The language.
database (Database)
The database.
Remarks
If the language does not exist in the target database, no action will be taken.


RenameLanguageData Method (fromLanguage, toLanguage, database)

RenameLanguageData Method (fromLanguage, toLanguage, database)
Namespaces ► Sitecore.Data.Managers ► LanguageProvider ► RenameLanguageData(String, String, Database)
Rename all data language bindings for a specific language.
Declaration Syntax
C#
public virtual void RenameLanguageData(
    string fromLanguage,
    string toLanguage,
    Database database
)
Parameters
fromLanguage (String)
Rename from this language name.
toLanguage (String)
Rename to this language name.
database (Database)
The database.


TemplateManager Class

TemplateManager Class
Namespaces ► Sitecore.Data.Managers ► TemplateManager
Static API for interacting with templates.
Declaration Syntax
C#
public static class TemplateManager
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ChangeFieldSharing(TemplateField, TemplateFieldSharing, Database) | Changes the field sharing type of a single field.
 | ChangeTemplate(Item, TemplateChangeList) | Changes the template of an item.
 | GetFieldId(String, ID, Database) | Gets the id of a field.
 | GetTemplate(Item) | Gets the template associated with an item.
 | GetTemplate(ID, Database) | Gets the template associated with a template id.
 | GetTemplate(String, Database) | Gets the template with a specific name.
 | GetTemplateField(ID, Item) | Gets the template field.
 | GetTemplateField(ID, ID, Database) | Gets a template field.
 | GetTemplates(Database) | Gets all templates defined in a specific database.
 | IsFieldPartOfTemplate(ID, Item) | Determines whether a template contains a specific field.
 | IsFieldPartOfTemplate(ID, ID, Database) | Determines whether a template contains a specific field.
 | IsStandardValuesHolder(Item) | Determines whether the specified item is a is standard values holder for a template.
 | IsTemplate(Item) | Determines whether an item is a template.
 | IsTemplatePart(Item) | Determines whether an item is a template part.
Inheritance Hierarchy
Object
TemplateManager


ChangeFieldSharing Method (definition, sharing, database)

ChangeFieldSharing Method (definition, sharing, database)
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► ChangeFieldSharing(TemplateField, TemplateFieldSharing, Database)
Changes the field sharing type of a single field.
Declaration Syntax
C#
public static bool ChangeFieldSharing(
    TemplateField definition,
    TemplateFieldSharing sharing,
    Database database
)
Parameters
definition (TemplateField)
The field definition.
sharing (TemplateFieldSharing)
The new sharing type.
database (Database)
The database.
Return Value


ChangeTemplate Method (item, changes)

ChangeTemplate Method (item, changes)
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► ChangeTemplate(Item, TemplateChangeList)
Changes the template of an item.
Declaration Syntax
C#
public static bool ChangeTemplate(
    Item item,
    TemplateChangeList changes
)
Parameters
item (Item)
The item.
changes (TemplateChangeList)
The changes.


GetFieldId Method (fieldName, templateId, database)

GetFieldId Method (fieldName, templateId, database)
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► GetFieldId(String, ID, Database)
Gets the id of a field.
Declaration Syntax
C#
public static ID GetFieldId(
    string fieldName,
    ID templateId,
    Database database
)
Parameters
fieldName (String)
Name of the field.
templateId (ID)
The template id.
database (Database)
The database.
Return Value


GetTemplate Method

GetTemplate Method
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► GetTemplate()()()
Members
Icon | Member | Description
 | GetTemplate(Item) | Gets the template associated with an item.
 | GetTemplate(ID, Database) | Gets the template associated with a template id.
 | GetTemplate(String, Database) | Gets the template with a specific name.


GetTemplate Method (templateId, database)

GetTemplate Method (templateId, database)
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► GetTemplate(ID, Database)
Gets the template associated with a template id.
Declaration Syntax
C#
public static Template GetTemplate(
    ID templateId,
    Database database
)
Parameters
templateId (ID)
The id of the desired template.
database (Database)
The database containing the template.
Return Value
The template.


GetTemplate Method (item)

GetTemplate Method (item)
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► GetTemplate(Item)
Gets the template associated with an item.
Declaration Syntax
C#
public static Template GetTemplate(
    Item item
)
Parameters
item (Item)
The item to get the template for.
Return Value
The template.


GetTemplate Method (fullName, database)

GetTemplate Method (fullName, database)
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► GetTemplate(String, Database)
Gets the template with a specific name.
Declaration Syntax
C#
public static Template GetTemplate(
    string fullName,
    Database database
)
Parameters
fullName (String)
The full name of the desired template. A full name is either a full Sitecore path (ie. /sitecore/templates/documents/Document) or a path relative to /sitecore/templates (ie. documents/Document). The name is case-insensitive.
database (Database)
The database containing the template.
Return Value
The template.


GetTemplateField Method

GetTemplateField Method
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► GetTemplateField()()()
Members
Icon | Member | Description
 | GetTemplateField(ID, Item) | Gets the template field.
 | GetTemplateField(ID, ID, Database) | Gets a template field.


GetTemplateField Method (fieldId, templateID, database)

GetTemplateField Method (fieldId, templateID, database)
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► GetTemplateField(ID, ID, Database)
Gets a template field.
Declaration Syntax
C#
public static TemplateField GetTemplateField(
    ID fieldId,
    ID templateID,
    Database database
)
Parameters
fieldId (ID)
The field id.
templateID (ID)
The template ID.
database (Database)
The database.


GetTemplateField Method (fieldId, item)

GetTemplateField Method (fieldId, item)
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► GetTemplateField(ID, Item)
Gets the template field.
Declaration Syntax
C#
public static TemplateField GetTemplateField(
    ID fieldId,
    Item item
)
Parameters
fieldId (ID)
The field id.
item (Item)
The item.
Return Value
The template field.


GetTemplates Method (database)

GetTemplates Method (database)
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► GetTemplates(Database)
Gets all templates defined in a specific database.
Declaration Syntax
C#
public static TemplateDictionary GetTemplates(
    Database database
)
Parameters
database (Database)
The database containing the templates.


IsFieldPartOfTemplate Method

IsFieldPartOfTemplate Method
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► IsFieldPartOfTemplate()()()
Members
Icon | Member | Description
 | IsFieldPartOfTemplate(ID, Item) | Determines whether a template contains a specific field.
 | IsFieldPartOfTemplate(ID, ID, Database) | Determines whether a template contains a specific field.


IsFieldPartOfTemplate Method (fieldId, templateId, database)

IsFieldPartOfTemplate Method (fieldId, templateId, database)
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► IsFieldPartOfTemplate(ID, ID, Database)
Determines whether a template contains a specific field.
Declaration Syntax
C#
public static bool IsFieldPartOfTemplate(
    ID fieldId,
    ID templateId,
    Database database
)
Parameters
fieldId (ID)
The field id.
templateId (ID)
The template id.
database (Database)
The database.
Return Value
The field part of template.


IsFieldPartOfTemplate Method (fieldId, item)

IsFieldPartOfTemplate Method (fieldId, item)
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► IsFieldPartOfTemplate(ID, Item)
Determines whether a template contains a specific field.
Declaration Syntax
C#
public static bool IsFieldPartOfTemplate(
    ID fieldId,
    Item item
)
Parameters
fieldId (ID)
The field id.
item (Item)
The item.
Return Value
The field part of template.


IsStandardValuesHolder Method (item)

IsStandardValuesHolder Method (item)
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► IsStandardValuesHolder(Item)
Determines whether the specified item is a is standard values holder for a template.
Declaration Syntax
C#
public static bool IsStandardValuesHolder(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item is a standard values holder; otherwise, false.


IsTemplate Method (item)

IsTemplate Method (item)
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► IsTemplate(Item)
Determines whether an item is a template.
Declaration Syntax
C#
public static bool IsTemplate(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the item is a template; otherwise, false.


IsTemplatePart Method (item)

IsTemplatePart Method (item)
Namespaces ► Sitecore.Data.Managers ► TemplateManager ► IsTemplatePart(Item)
Determines whether an item is a template part.
Declaration Syntax
C#
public static bool IsTemplatePart(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the item is a template part; otherwise, false.


ThemeManager Class

ThemeManager Class
Namespaces ► Sitecore.Data.Managers ► ThemeManager
Static interface for performing theme operations.
Declaration Syntax
C#
public sealed class ThemeManager
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ThemeManager()()() | Initializes a new instance of the ThemeManager class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIconImage(Item, Int32, Int32, String, String) | Gets an image for an items icon.
 | GetIconImage(Item, Int32, Int32, String, String, String, String, Boolean) | Gets an image for an items icon.
 | GetImage(String, Int32, Int32) | Gets an image from a path.
 | GetImage(String, Int32, Int32, String, String, String, String, Boolean) | Gets an image from a path.
 | GetLanguageImage(Language, Database, Int32, Int32) | Gets the image symbolizing a language.
 | GetLanguageImage(Language, Database, Int32, Int32, String, String, String, String, Boolean) | Gets the image symbolizing a language.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ThemeManager


ThemeManager Constructor

ThemeManager Constructor
Namespaces ► Sitecore.Data.Managers ► ThemeManager ► ThemeManager()()()
Initializes a new instance of the ThemeManager class
Declaration Syntax
C#
public ThemeManager()


GetIconImage Method

GetIconImage Method
Namespaces ► Sitecore.Data.Managers ► ThemeManager ► GetIconImage()()()
Members
Icon | Member | Description
 | GetIconImage(Item, Int32, Int32, String, String) | Gets an image for an items icon.
 | GetIconImage(Item, Int32, Int32, String, String, String, String, Boolean) | Gets an image for an items icon.


GetIconImage Method (item, width, height, align, margin)

GetIconImage Method (item, width, height, align, margin)
Namespaces ► Sitecore.Data.Managers ► ThemeManager ► GetIconImage(Item, Int32, Int32, String, String)
Gets an image for an items icon.
Declaration Syntax
C#
public static string GetIconImage(
    Item item,
    int width,
    int height,
    string align,
    string margin
)
Parameters
item (Item)
The item.
width (Int32)
The width.
height (Int32)
The height.
align (String)
The align.
margin (String)
The margin.
Return Value
The icon image.


GetIconImage Method (item, width, height, align, margin, alt, id, resize)

GetIconImage Method (item, width, height, align, margin, alt, id, resize)
Namespaces ► Sitecore.Data.Managers ► ThemeManager ► GetIconImage(Item, Int32, Int32, String, String, String, String, Boolean)
Gets an image for an items icon.
Declaration Syntax
C#
public static string GetIconImage(
    Item item,
    int width,
    int height,
    string align,
    string margin,
    string alt,
    string id,
    bool resize
)
Parameters
item (Item)
The item.
width (Int32)
The width.
height (Int32)
The height.
align (String)
The align.
margin (String)
The margin.
alt (String)
The alt.
id (String)
The id.
resize (Boolean)
if set to true [resize].
Return Value
The icon image.


GetImage Method

GetImage Method
Namespaces ► Sitecore.Data.Managers ► ThemeManager ► GetImage()()()
Members
Icon | Member | Description
 | GetImage(String, Int32, Int32) | Gets an image from a path.
 | GetImage(String, Int32, Int32, String, String, String, String, Boolean) | Gets an image from a path.


GetImage Method (path, width, height)

GetImage Method (path, width, height)
Namespaces ► Sitecore.Data.Managers ► ThemeManager ► GetImage(String, Int32, Int32)
Gets an image from a path.
Declaration Syntax
C#
public static string GetImage(
    string path,
    int width,
    int height
)
Parameters
path (String)
The path.
width (Int32)
The width.
height (Int32)
The height.
Return Value
The image.


GetImage Method (path, width, height, align, margin, alt, id, resize)

GetImage Method (path, width, height, align, margin, alt, id, resize)
Namespaces ► Sitecore.Data.Managers ► ThemeManager ► GetImage(String, Int32, Int32, String, String, String, String, Boolean)
Gets an image from a path.
Declaration Syntax
C#
public static string GetImage(
    string path,
    int width,
    int height,
    string align,
    string margin,
    string alt,
    string id,
    bool resize
)
Parameters
path (String)
The path.
width (Int32)
The width.
height (Int32)
The height.
align (String)
The align.
margin (String)
The margin.
alt (String)
The alt.
id (String)
The id.
resize (Boolean)
if set to true [resize].
Return Value
The image.


GetLanguageImage Method

GetLanguageImage Method
Namespaces ► Sitecore.Data.Managers ► ThemeManager ► GetLanguageImage()()()
Members
Icon | Member | Description
 | GetLanguageImage(Language, Database, Int32, Int32) | Gets the image symbolizing a language.
 | GetLanguageImage(Language, Database, Int32, Int32, String, String, String, String, Boolean) | Gets the image symbolizing a language.


GetLanguageImage Method (language, database, width, height)

GetLanguageImage Method (language, database, width, height)
Namespaces ► Sitecore.Data.Managers ► ThemeManager ► GetLanguageImage(Language, Database, Int32, Int32)
Gets the image symbolizing a language.
Declaration Syntax
C#
public static string GetLanguageImage(
    Language language,
    Database database,
    int width,
    int height
)
Parameters
language (Language)
The language.
database (Database)
The database.
width (Int32)
The width.
height (Int32)
The height.
Return Value
The language image.


GetLanguageImage Method (language, database, width, height, align, margin, alt, id, resize)

GetLanguageImage Method (language, database, width, height, align, margin, alt, id, resize)
Namespaces ► Sitecore.Data.Managers ► ThemeManager ► GetLanguageImage(Language, Database, Int32, Int32, String, String, String, String, Boolean)
Gets the image symbolizing a language.
Declaration Syntax
C#
public static string GetLanguageImage(
    Language language,
    Database database,
    int width,
    int height,
    string align,
    string margin,
    string alt,
    string id,
    bool resize
)
Parameters
language (Language)
The language.
database (Database)
The database.
width (Int32)
The width.
height (Int32)
The height.
align (String)
The align.
margin (String)
The margin.
alt (String)
The alt.
id (String)
The id.
resize (Boolean)
if set to true this instance is resize.
Return Value
The language image.


ThemeProvider Class

ThemeProvider Class
Namespaces ► Sitecore.Data.Managers ► ThemeProvider
Provider for performing theme operations.
Declaration Syntax
C#
public class ThemeProvider
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ThemeProvider()()() | Initializes a new instance of the ThemeProvider class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCurrentTheme()()() | Gets the current theme.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIconImage(Item, Int32, Int32, String, String, String, String, Boolean) | Gets an image for an items icon.
 | GetImage(String, Int32, Int32, String, String, String, String, Boolean) | Gets an image for an items icon.
 | GetLanguageImage(Language, Database, Int32, Int32, String, String, String, String, Boolean) | Gets the image symbolizing a language.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ThemeProvider


ThemeProvider Constructor

ThemeProvider Constructor
Namespaces ► Sitecore.Data.Managers ► ThemeProvider ► ThemeProvider()()()
Initializes a new instance of the ThemeProvider class
Declaration Syntax
C#
public ThemeProvider()


GetCurrentTheme Method

GetCurrentTheme Method
Namespaces ► Sitecore.Data.Managers ► ThemeProvider ► GetCurrentTheme()()()
Gets the current theme.
Declaration Syntax
C#
public virtual string GetCurrentTheme()
Return Value


GetIconImage Method (item, width, height, align, margin, alt, id, resize)

GetIconImage Method (item, width, height, align, margin, alt, id, resize)
Namespaces ► Sitecore.Data.Managers ► ThemeProvider ► GetIconImage(Item, Int32, Int32, String, String, String, String, Boolean)
Gets an image for an items icon.
Declaration Syntax
C#
public virtual string GetIconImage(
    Item item,
    int width,
    int height,
    string align,
    string margin,
    string alt,
    string id,
    bool resize
)
Parameters
item (Item)
The item.
width (Int32)
The width.
height (Int32)
The height.
align (String)
The align.
margin (String)
The margin.
alt (String)
The alt.
id (String)
The id.
resize (Boolean)
if set to true [resize].
Return Value


GetImage Method (path, width, height, align, margin, alt, id, resize)

GetImage Method (path, width, height, align, margin, alt, id, resize)
Namespaces ► Sitecore.Data.Managers ► ThemeProvider ► GetImage(String, Int32, Int32, String, String, String, String, Boolean)
Gets an image for an items icon.
Declaration Syntax
C#
public virtual string GetImage(
    string path,
    int width,
    int height,
    string align,
    string margin,
    string alt,
    string id,
    bool resize
)
Parameters
path (String)
The path.
width (Int32)
The width.
height (Int32)
The height.
align (String)
The align.
margin (String)
The margin.
alt (String)
The alt.
id (String)
The id.
resize (Boolean)
if set to true [resize].
Return Value


GetLanguageImage Method (language, database, width, height, align, margin, alt, id, resize)

GetLanguageImage Method (language, database, width, height, align, margin, alt, id, resize)
Namespaces ► Sitecore.Data.Managers ► ThemeProvider ► GetLanguageImage(Language, Database, Int32, Int32, String, String, String, String, Boolean)
Gets the image symbolizing a language.
Declaration Syntax
C#
public virtual string GetLanguageImage(
    Language language,
    Database database,
    int width,
    int height,
    string align,
    string margin,
    string alt,
    string id,
    bool resize
)
Parameters
language (Language)
The language.
database (Database)
The database.
width (Int32)
The width.
height (Int32)
The height.
align (String)
The align.
margin (String)
The margin.
alt (String)
The alt.
id (String)
The id.
resize (Boolean)
if set to true this instance is resize.
Return Value


Sitecore.Data.Masters Namespace

Sitecore.Data.Masters Namespace
Namespaces ► Sitecore.Data.Masters
Declaration Syntax
C#
namespace Sitecore.Data.Masters
Types
All Types Classes
Icon | Type | Description
 | InsertRule | Represents a DynamicMaster.
 | Masters | Represents a Masters.


InsertRule Class

InsertRule Class
Namespaces ► Sitecore.Data.Masters ► InsertRule
Represents a DynamicMaster.
Declaration Syntax
C#
public abstract class InsertRule
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InsertRule()()() | Initializes a new instance of the InsertRule class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Expand(List<(Of <(Item>)>), Item) | Expands the specified masters.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InsertRule


InsertRule Constructor

InsertRule Constructor
Namespaces ► Sitecore.Data.Masters ► InsertRule ► InsertRule()()()
Initializes a new instance of the InsertRule class
Declaration Syntax
C#
protected InsertRule()


Expand Method (masters, item)

Expand Method (masters, item)
Namespaces ► Sitecore.Data.Masters ► InsertRule ► Expand(List<(Of <(Item>)>), Item)
Expands the specified masters.
Declaration Syntax
C#
public abstract void Expand(
    List<Item> masters,
    Item item
)
Parameters
masters (List<(Of <( Item >)>))
The masters.
item (Item)
The item.


Masters Class

Masters Class
Namespaces ► Sitecore.Data.Masters ► Masters
Represents a Masters.
Declaration Syntax
C#
public static class Masters
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreateMaster(Item, ID) | Creates the master.
 | GetClick(Item) | Gets the click.
 | GetClick(Item, Item) | Gets the click.
 | GetMasters(Item) | Gets the masters.
Inheritance Hierarchy
Object
Masters


CreateMaster Method (parent, templateId)

CreateMaster Method (parent, templateId)
Namespaces ► Sitecore.Data.Masters ► Masters ► CreateMaster(Item, ID)
Creates the master.
Declaration Syntax
C#
public static Item CreateMaster(
    Item parent,
    ID templateId
)
Parameters
parent (Item)
The parent.
templateId (ID)
The template id.


GetClick Method

GetClick Method
Namespaces ► Sitecore.Data.Masters ► Masters ► GetClick()()()
Members
Icon | Member | Description
 | GetClick(Item) | Gets the click.
 | GetClick(Item, Item) | Gets the click.


GetClick Method (master)

GetClick Method (master)
Namespaces ► Sitecore.Data.Masters ► Masters ► GetClick(Item)
Gets the click.
Declaration Syntax
C#
public static string GetClick(
    Item master
)
Parameters
master (Item)
The master.
Return Value
The click.


GetClick Method (master, parent)

GetClick Method (master, parent)
Namespaces ► Sitecore.Data.Masters ► Masters ► GetClick(Item, Item)
Gets the click.
Declaration Syntax
C#
public static string GetClick(
    Item master,
    Item parent
)
Parameters
master (Item)
The master.
parent (Item)
The parent item.
Return Value
The click.


GetMasters Method (item)

GetMasters Method (item)
Namespaces ► Sitecore.Data.Masters ► Masters ► GetMasters(Item)
Gets the masters.
Declaration Syntax
C#
public static List<Item> GetMasters(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The masters.


Sitecore.Data.Proxies Namespace

Sitecore.Data.Proxies Namespace
Namespaces ► Sitecore.Data.Proxies
Declaration Syntax
C#
namespace Sitecore.Data.Proxies
Types
All Types Classes Enumerations
Icon | Type | Description
 | DomainSwitcher | Disables proxy resolving temporarily.
 | Proxy | Proxy class
 | ProxyCache | ProxyCache class
 | ProxyDataProvider | ProxyDataProvider class
 | ProxyDataRecord | ProxyDataRecord class
 | ProxyDisabler | Disables proxy resolving temporarily.
 | ProxyManager | ProxyManager class
 | ProxyMapper | ProxyMapper class
 | ProxyProvider | ProxyProvider class
 | ProxyReference | ProxyReference class
 | ProxyResolver | ProxyResolver class
 | ProxyState | ProxyState enum
 | ProxyStateMonitor | StateMonitor class
 | ProxyTarget | Represents a proxy target.
 | ProxyType | Insertion type for a proxy
 | SqlProxyDataProvider | Base class for SQL based data providers.


DomainSwitcher Class

DomainSwitcher Class
Namespaces ► Sitecore.Data.Proxies ► DomainSwitcher
Disables proxy resolving temporarily.
Declaration Syntax
C#
public class DomainSwitcher : Switcher<Domain>
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainSwitcher(Domain) | Initializes a new instance of the DomainSwitcher class.
 | DomainSwitcher(String) | Initializes a new instance of the DomainSwitcher class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <( Domain, Domain >)>)
 |  | Switcher <(Of <( Domain >)>)
 |  |  | DomainSwitcher


DomainSwitcher Constructor

DomainSwitcher Constructor
Namespaces ► Sitecore.Data.Proxies ► DomainSwitcher ► DomainSwitcher()()()
Members
Icon | Member | Description
 | DomainSwitcher(Domain) | Initializes a new instance of the DomainSwitcher class.
 | DomainSwitcher(String) | Initializes a new instance of the DomainSwitcher class.


DomainSwitcher Constructor (domain)

DomainSwitcher Constructor (domain)
Namespaces ► Sitecore.Data.Proxies ► DomainSwitcher ► DomainSwitcher(Domain)
Initializes a new instance of the DomainSwitcher class.
Declaration Syntax
C#
public DomainSwitcher(
    Domain domain
)
Parameters
domain (Domain)
The domain.


DomainSwitcher Constructor (domainName)

DomainSwitcher Constructor (domainName)
Namespaces ► Sitecore.Data.Proxies ► DomainSwitcher ► DomainSwitcher(String)
Initializes a new instance of the DomainSwitcher class.
Declaration Syntax
C#
public DomainSwitcher(
    string domainName
)
Parameters
domainName (String)
Name of the domain.


Proxy Class

Proxy Class
Namespaces ► Sitecore.Data.Proxies ► Proxy
Proxy class
Declaration Syntax
C#
public class Proxy
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Proxy(ID) | Initializes a new instance of the Proxy class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSourceItem(Language, Version) | Gets the source item.
 | GetTargetItem(Language, Version) | Gets the target item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsNullOrEmpty(Proxy) | Determines whether a proxy class is null or does not contain any data.
 | IsRootItem(Item) | Determines whether the specified item is the root of the proxy tree.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Null | Gets the null Proxy.
 | ProxyId | Gets the proxy id.
 | ProxyType | Gets or sets the type of the proxy.
 | SourceDatabase | Gets or sets the source database. Source database is where real item is located.
 | SourceId | Gets or sets the source id. Source item is real item that gets 'virtualized' under another item.
 | TargetDatabase | Gets or sets the target database. Target database is where virtual items get inserted.
 | TargetId | Gets or sets the target id. Target is the item under which virtual items get inserted.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Proxy


Proxy Constructor (proxyId)

Proxy Constructor (proxyId)
Namespaces ► Sitecore.Data.Proxies ► Proxy ► Proxy(ID)
Initializes a new instance of the Proxy class.
Declaration Syntax
C#
public Proxy(
    ID proxyId
)
Parameters
proxyId (ID)
The proxy id.


GetSourceItem Method (language, version)

GetSourceItem Method (language, version)
Namespaces ► Sitecore.Data.Proxies ► Proxy ► GetSourceItem(Language, Version)
Gets the source item.
Declaration Syntax
C#
public Item GetSourceItem(
    Language language,
    Version version
)
Parameters
language (Language)
version (Version)
Return Value


GetTargetItem Method (language, version)

GetTargetItem Method (language, version)
Namespaces ► Sitecore.Data.Proxies ► Proxy ► GetTargetItem(Language, Version)
Gets the target item.
Declaration Syntax
C#
public Item GetTargetItem(
    Language language,
    Version version
)
Parameters
language (Language)
The language.
version (Version)
The version.
Return Value


IsNullOrEmpty Method (proxy)

IsNullOrEmpty Method (proxy)
Namespaces ► Sitecore.Data.Proxies ► Proxy ► IsNullOrEmpty(Proxy)
Determines whether a proxy class is null or does not contain any data.
Declaration Syntax
C#
public static bool IsNullOrEmpty(
    Proxy proxy
)
Parameters
proxy (Proxy)
Return Value
true if the instance is null or empty; otherwise, false.


IsRootItem Method (item)

IsRootItem Method (item)
Namespaces ► Sitecore.Data.Proxies ► Proxy ► IsRootItem(Item)
Determines whether the specified item is the root of the proxy tree.
Declaration Syntax
C#
public virtual bool IsRootItem(
    Item item
)
Parameters
item (Item)
The item.


Null Property

Null Property
Namespaces ► Sitecore.Data.Proxies ► Proxy ► Null
Gets the null Proxy.
Declaration Syntax
C#
public static Proxy Null { get; }
Value
The null.


ProxyId Property

ProxyId Property
Namespaces ► Sitecore.Data.Proxies ► Proxy ► ProxyId
Gets the proxy id.
Declaration Syntax
C#
public ID ProxyId { get; }
Value
The proxy id.


ProxyType Property

ProxyType Property
Namespaces ► Sitecore.Data.Proxies ► Proxy ► ProxyType
Gets or sets the type of the proxy.
Declaration Syntax
C#
public ProxyType ProxyType { get; set; }
Value
The type of the proxy.


SourceDatabase Property

SourceDatabase Property
Namespaces ► Sitecore.Data.Proxies ► Proxy ► SourceDatabase
Gets or sets the source database. Source database is where real item is located.
Declaration Syntax
C#
public Database SourceDatabase { get; set; }
Value
The source database.


SourceId Property

SourceId Property
Namespaces ► Sitecore.Data.Proxies ► Proxy ► SourceId
Gets or sets the source id. Source item is real item that gets 'virtualized' under another item.
Declaration Syntax
C#
public ID SourceId { get; set; }
Value
The source id.


TargetDatabase Property

TargetDatabase Property
Namespaces ► Sitecore.Data.Proxies ► Proxy ► TargetDatabase
Gets or sets the target database. Target database is where virtual items get inserted.
Declaration Syntax
C#
public Database TargetDatabase { get; set; }
Value
The target database.


TargetId Property

TargetId Property
Namespaces ► Sitecore.Data.Proxies ► Proxy ► TargetId
Gets or sets the target id. Target is the item under which virtual items get inserted.
Declaration Syntax
C#
public ID TargetId { get; set; }
Value
The target id.


ProxyCache Class

ProxyCache Class
Namespaces ► Sitecore.Data.Proxies ► ProxyCache
ProxyCache class
Declaration Syntax
C#
public class ProxyCache
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProxyCache(ProxyProvider) | Initializes a new instance of the ProxyCache class.
 | AddProxy(ID, Database, Proxy) | Adds a proxy.
 | AddProxyTable(Database, SafeDictionary<(Of <(Object, IList<(Of <(Proxy>)>)>)>)) | Adds the proxy list for the database to the cache.
 | AddReferences(Item, List<(Of <(ProxyReference>)>)) | Adds a list of references to the cache.
 | AddTarget(ID, Database, ProxyTarget) | Adds an item id to cache.
 | AddVirtualId(ID, ID, Database, ID) | Adds a virtual id to cache.
 | Clear()()() | Clears the cache.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProxy(ID, Database) | Gets a proxy.
 | GetProxyListKey(Database) | Gets the proxy list key.
 | GetProxyTable(Database) | Gets the cached proxy list for the database.
 | GetReferences(Item) | Gets a list of references from the cache.
 | GetReferencesKey(Item) | Gets a cache key for storing a list of references.
 | GetTarget(ID, Database) | Gets the item id from the cache.
 | GetTargetCacheKey(ID, Database) | Gets a cache key for storing an item id.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVirtualId(ID, ID, Database) | Gets a virtual id from cache.
 | GetVirtualIdCacheKey(ID, ID, Database) | Gets a cache key for storing a virtual id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveProxyTable(Database) | Removes the proxy list for the database from the cache.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProxyCache


ProxyCache Constructor (owner)

ProxyCache Constructor (owner)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► ProxyCache(ProxyProvider)
Initializes a new instance of the ProxyCache class.
Declaration Syntax
C#
public ProxyCache(
    ProxyProvider owner
)
Parameters
owner (ProxyProvider)


AddProxy Method (proxyId, database, proxy)

AddProxy Method (proxyId, database, proxy)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► AddProxy(ID, Database, Proxy)
Adds a proxy.
Declaration Syntax
C#
public void AddProxy(
    ID proxyId,
    Database database,
    Proxy proxy
)
Parameters
proxyId (ID)
The proxy id.
database (Database)
The database.
proxy (Proxy)
The proxy.


AddProxyTable Method (database, list)

AddProxyTable Method (database, list)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► AddProxyTable(Database, SafeDictionary<(Of <(Object, IList<(Of <(Proxy>)>)>)>))
Adds the proxy list for the database to the cache.
Declaration Syntax
C#
public virtual void AddProxyTable(
    Database database,
    SafeDictionary<Object, IList<Proxy>> list
)
Parameters
database (Database)
The database.
list (SafeDictionary <(Of <(Object, IList<(Of <( Proxy >)>)>)>))
The list.


AddReferences Method (item, references)

AddReferences Method (item, references)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► AddReferences(Item, List<(Of <(ProxyReference>)>))
Adds a list of references to the cache.
Declaration Syntax
C#
public virtual void AddReferences(
    Item item,
    List<ProxyReference> references
)
Parameters
item (Item)
The item.
references (List<(Of <( ProxyReference >)>))
The references.


AddTarget Method (virtualId, database, target)

AddTarget Method (virtualId, database, target)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► AddTarget(ID, Database, ProxyTarget)
Adds an item id to cache.
Declaration Syntax
C#
public virtual void AddTarget(
    ID virtualId,
    Database database,
    ProxyTarget target
)
Parameters
virtualId (ID)
The virtual id.
database (Database)
The database.
target (ProxyTarget)
The item id.


AddVirtualId Method (itemId, proxyId, proxyDatabase, virtualId)

AddVirtualId Method (itemId, proxyId, proxyDatabase, virtualId)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► AddVirtualId(ID, ID, Database, ID)
Adds a virtual id to cache.
Declaration Syntax
C#
public virtual void AddVirtualId(
    ID itemId,
    ID proxyId,
    Database proxyDatabase,
    ID virtualId
)
Parameters
itemId (ID)
The item id.
proxyId (ID)
The proxy id.
proxyDatabase (Database)
The proxy database.
virtualId (ID)
The virtual id.


Clear Method

Clear Method
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► Clear()()()
Clears the cache.
Declaration Syntax
C#
public virtual void Clear()


GetProxy Method (proxyId, database)

GetProxy Method (proxyId, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► GetProxy(ID, Database)
Gets a proxy.
Declaration Syntax
C#
public Proxy GetProxy(
    ID proxyId,
    Database database
)
Parameters
proxyId (ID)
The proxy id.
database (Database)
The database.
Return Value


GetProxyListKey Method (database)

GetProxyListKey Method (database)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► GetProxyListKey(Database)
Gets the proxy list key.
Declaration Syntax
C#
protected virtual string GetProxyListKey(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The proxy list key.


GetProxyTable Method (database)

GetProxyTable Method (database)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► GetProxyTable(Database)
Gets the cached proxy list for the database.
Declaration Syntax
C#
public virtual SafeDictionary<Object, IList<Proxy>> GetProxyTable(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The proxy list.


GetReferences Method (item)

GetReferences Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► GetReferences(Item)
Gets a list of references from the cache.
Declaration Syntax
C#
public virtual List<ProxyReference> GetReferences(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetReferencesKey Method (item)

GetReferencesKey Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► GetReferencesKey(Item)
Gets a cache key for storing a list of references.
Declaration Syntax
C#
protected virtual string GetReferencesKey(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetTarget Method (virtualId, database)

GetTarget Method (virtualId, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► GetTarget(ID, Database)
Gets the item id from the cache.
Declaration Syntax
C#
public virtual ProxyTarget GetTarget(
    ID virtualId,
    Database database
)
Parameters
virtualId (ID)
The virtual id.
database (Database)
The database.
Return Value


GetTargetCacheKey Method (virtualId, database)

GetTargetCacheKey Method (virtualId, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► GetTargetCacheKey(ID, Database)
Gets a cache key for storing an item id.
Declaration Syntax
C#
protected virtual string GetTargetCacheKey(
    ID virtualId,
    Database database
)
Parameters
virtualId (ID)
The virtual id.
database (Database)
The database.
Return Value


GetVirtualId Method (itemId, proxyId, proxyDatabase)

GetVirtualId Method (itemId, proxyId, proxyDatabase)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► GetVirtualId(ID, ID, Database)
Gets a virtual id from cache.
Declaration Syntax
C#
public virtual ID GetVirtualId(
    ID itemId,
    ID proxyId,
    Database proxyDatabase
)
Parameters
itemId (ID)
The item id.
proxyId (ID)
The proxy id.
proxyDatabase (Database)
The proxy database.
Return Value


GetVirtualIdCacheKey Method (itemId, proxyId, proxyDatabase)

GetVirtualIdCacheKey Method (itemId, proxyId, proxyDatabase)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► GetVirtualIdCacheKey(ID, ID, Database)
Gets a cache key for storing a virtual id.
Declaration Syntax
C#
protected virtual string GetVirtualIdCacheKey(
    ID itemId,
    ID proxyId,
    Database proxyDatabase
)
Parameters
itemId (ID)
The item id.
proxyId (ID)
The proxy id.
proxyDatabase (Database)
The proxy database.
Return Value


RemoveProxyTable Method (database)

RemoveProxyTable Method (database)
Namespaces ► Sitecore.Data.Proxies ► ProxyCache ► RemoveProxyTable(Database)
Removes the proxy list for the database from the cache.
Declaration Syntax
C#
public virtual void RemoveProxyTable(
    Database database
)
Parameters
database (Database)
The database.


ProxyDataProvider Class

ProxyDataProvider Class
Namespaces ► Sitecore.Data.Proxies ► ProxyDataProvider
ProxyDataProvider class
Declaration Syntax
C#
public abstract class ProxyDataProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProxyDataProvider()()() | Initializes a new instance of the ProxyDataProvider class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReferences(ID) | Gets all references to a specific item.
 | GetTarget(ID) | Gets the id of the item pointed to by a virtual id.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVirtualId(ID, ID, Boolean) | Gets the id of a shadow pointing to a specific item id within a specific proxy.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name.
 | RemoveData(ID) | Removes all data associated with a specific proxy.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProxyDataProvider
 |  | SqlProxyDataProvider


ProxyDataProvider Constructor

ProxyDataProvider Constructor
Namespaces ► Sitecore.Data.Proxies ► ProxyDataProvider ► ProxyDataProvider()()()
Initializes a new instance of the ProxyDataProvider class
Declaration Syntax
C#
protected ProxyDataProvider()


GetReferences Method (itemId)

GetReferences Method (itemId)
Namespaces ► Sitecore.Data.Proxies ► ProxyDataProvider ► GetReferences(ID)
Gets all references to a specific item.
Declaration Syntax
C#
public abstract List<ProxyDataRecord> GetReferences(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value


GetTarget Method (virtualId)

GetTarget Method (virtualId)
Namespaces ► Sitecore.Data.Proxies ► ProxyDataProvider ► GetTarget(ID)
Gets the id of the item pointed to by a virtual id.
Declaration Syntax
C#
public abstract ProxyTarget GetTarget(
    ID virtualId
)
Parameters
virtualId (ID)
The virtual id.
Return Value


GetVirtualId Method (itemId, proxyId, generateIfNotFound)

GetVirtualId Method (itemId, proxyId, generateIfNotFound)
Namespaces ► Sitecore.Data.Proxies ► ProxyDataProvider ► GetVirtualId(ID, ID, Boolean)
Gets the id of a shadow pointing to a specific item id within a specific proxy.
Declaration Syntax
C#
public abstract ID GetVirtualId(
    ID itemId,
    ID proxyId,
    bool generateIfNotFound
)
Parameters
itemId (ID)
The item id.
proxyId (ID)
The proxy id.
generateIfNotFound (Boolean)
If set to true a virtual id will be generated if it does not already exist.
Return Value


Name Property

Name Property
Namespaces ► Sitecore.Data.Proxies ► ProxyDataProvider ► Name
Gets or sets the name.
Declaration Syntax
C#
public virtual string Name { get; set; }
Value
The name.


RemoveData Method (proxyId)

RemoveData Method (proxyId)
Namespaces ► Sitecore.Data.Proxies ► ProxyDataProvider ► RemoveData(ID)
Removes all data associated with a specific proxy.
Declaration Syntax
C#
public abstract void RemoveData(
    ID proxyId
)
Parameters
proxyId (ID)
The proxy id.


ProxyDataRecord Class

ProxyDataRecord Class
Namespaces ► Sitecore.Data.Proxies ► ProxyDataRecord
ProxyDataRecord class
Declaration Syntax
C#
public class ProxyDataRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProxyDataRecord(ID, ID, ID) | Initializes a new instance of the ProxyDataRecord class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemId | Gets the item id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProxyId | Gets the proxy id.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VirtualId | Gets the virtual id.
Inheritance Hierarchy
Object
ProxyDataRecord


ProxyDataRecord Constructor (itemId, virtualId, proxyId)

ProxyDataRecord Constructor (itemId, virtualId, proxyId)
Namespaces ► Sitecore.Data.Proxies ► ProxyDataRecord ► ProxyDataRecord(ID, ID, ID)
Initializes a new instance of the ProxyDataRecord class.
Declaration Syntax
C#
public ProxyDataRecord(
    ID itemId,
    ID virtualId,
    ID proxyId
)
Parameters
itemId (ID)
virtualId (ID)
proxyId (ID)


ItemId Property

ItemId Property
Namespaces ► Sitecore.Data.Proxies ► ProxyDataRecord ► ItemId
Gets the item id.
Declaration Syntax
C#
public ID ItemId { get; }
Value
The item id.


ProxyId Property

ProxyId Property
Namespaces ► Sitecore.Data.Proxies ► ProxyDataRecord ► ProxyId
Gets the proxy id.
Declaration Syntax
C#
public ID ProxyId { get; }
Value
The proxy id.


VirtualId Property

VirtualId Property
Namespaces ► Sitecore.Data.Proxies ► ProxyDataRecord ► VirtualId
Gets the virtual id.
Declaration Syntax
C#
public ID VirtualId { get; }
Value
The virtual id.


ProxyDisabler Class

ProxyDisabler Class
Namespaces ► Sitecore.Data.Proxies ► ProxyDisabler
Disables proxy resolving temporarily.
Declaration Syntax
C#
public class ProxyDisabler : IDisposable
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProxyDisabler()()() | Initializes a new instance of the ProxyDisabler class.
 | ProxyDisabler(Boolean) | Initializes a new instance of the ProxyDisabler class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsActive()()() | Determines whether this instance is active (ie. proxies are disabled).
 | ItemsKey | Key used for storing state in Items
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProxyDisabler


ProxyDisabler Constructor

ProxyDisabler Constructor
Namespaces ► Sitecore.Data.Proxies ► ProxyDisabler ► ProxyDisabler()()()
Members
Icon | Member | Description
 | ProxyDisabler()()() | Initializes a new instance of the ProxyDisabler class.
 | ProxyDisabler(Boolean) | Initializes a new instance of the ProxyDisabler class.


ProxyDisabler Constructor

ProxyDisabler Constructor
Namespaces ► Sitecore.Data.Proxies ► ProxyDisabler ► ProxyDisabler()()()
Initializes a new instance of the ProxyDisabler class.
Declaration Syntax
C#
public ProxyDisabler()


ProxyDisabler Constructor (disable)

ProxyDisabler Constructor (disable)
Namespaces ► Sitecore.Data.Proxies ► ProxyDisabler ► ProxyDisabler(Boolean)
Initializes a new instance of the ProxyDisabler class.
Declaration Syntax
C#
public ProxyDisabler(
    bool disable
)
Parameters
disable (Boolean)
if set to true this instance disables proxies (default behavior). If set to false, this instance enables proxies down the scope.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Data.Proxies ► ProxyDisabler ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


IsActive Method

IsActive Method
Namespaces ► Sitecore.Data.Proxies ► ProxyDisabler ► IsActive()()()
Determines whether this instance is active (ie. proxies are disabled).
Declaration Syntax
C#
public static bool IsActive()
Return Value
true if this instance is active; otherwise, false.


ItemsKey Field

ItemsKey Field
Namespaces ► Sitecore.Data.Proxies ► ProxyDisabler ► ItemsKey
Key used for storing state in Items
Declaration Syntax
C#
public const string ItemsKey


ProxyManager Class

ProxyManager Class
Namespaces ► Sitecore.Data.Proxies ► ProxyManager
ProxyManager class
Declaration Syntax
C#
public sealed class ProxyManager
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProxyManager()()() | Initializes a new instance of the ProxyManager class
 | AreProxiesEnabled(Database) | Checks if proxies are enabled for a specific database.
 | CopyVirtualTreeRoot(Item, Item) | Copies the virtual item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(ID, Language, Version, Database) | Gets an item.
 | GetParent(Item) | Gets the parent of an item.
 | GetRealDatabase(Item) | Gets the real database of an item.
 | GetRealId(Item) | Gets the real item id of a virtual item.
 | GetRealItem(Item, Boolean) | Gets the real item behind a virtual item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVirtualId(ID, ID, Database, Boolean) | Gets the virtual id of an item within a specific proxy context.
 | GetVirtualInstances(Item, Boolean) | Gets all virtual instances of an item.
 | GetVirtualItem(Item, ID, Database, Boolean) | Gets the virtual version of an item within a specific proxy context.
 | HasVirtualItems(Item) | Determines whether the specified item has any shadows.
 | Initialize()()() | Initialize type.
 | InsertVirtualChildren(ItemList, Item) | Inserts virtual children (if any) into a native list of children.
 | IsProxy(Item) | Determines whether the specified item is a proxy definition.
 | IsVirtual(Item) | Determines whether the specified item is virtual.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProxyManager


ProxyManager Constructor

ProxyManager Constructor
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► ProxyManager()()()
Initializes a new instance of the ProxyManager class
Declaration Syntax
C#
public ProxyManager()


AreProxiesEnabled Method (database)

AreProxiesEnabled Method (database)
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► AreProxiesEnabled(Database)
Checks if proxies are enabled for a specific database.
Declaration Syntax
C#
public static bool AreProxiesEnabled(
    Database database
)
Parameters
database (Database)
The database.
Return Value


CopyVirtualTreeRoot Method (item, target)

CopyVirtualTreeRoot Method (item, target)
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► CopyVirtualTreeRoot(Item, Item)
Copies the virtual item.
Declaration Syntax
C#
public static Item CopyVirtualTreeRoot(
    Item item,
    Item target
)
Parameters
item (Item)
The item.
target (Item)
The target.
Return Value


GetItem Method (itemId, language, version, database)

GetItem Method (itemId, language, version, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► GetItem(ID, Language, Version, Database)
Gets an item.
Declaration Syntax
C#
public static Item GetItem(
    ID itemId,
    Language language,
    Version version,
    Database database
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
version (Version)
The version.
database (Database)
The database.
Return Value


GetParent Method (item)

GetParent Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► GetParent(Item)
Gets the parent of an item.
Declaration Syntax
C#
public static Item GetParent(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The parent item.


GetRealDatabase Method (item)

GetRealDatabase Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► GetRealDatabase(Item)
Gets the real database of an item.
Declaration Syntax
C#
public static Database GetRealDatabase(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetRealId Method (item)

GetRealId Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► GetRealId(Item)
Gets the real item id of a virtual item.
Declaration Syntax
C#
public static ID GetRealId(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetRealItem Method (item, preserveState)

GetRealItem Method (item, preserveState)
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► GetRealItem(Item, Boolean)
Gets the real item behind a virtual item.
Declaration Syntax
C#
public static Item GetRealItem(
    Item item,
    bool preserveState
)
Parameters
item (Item)
The item.
preserveState (Boolean)
If set to true state is preserved.
Return Value


GetVirtualId Method (itemId, proxyId, proxyDatabase, generateIfNotFound)

GetVirtualId Method (itemId, proxyId, proxyDatabase, generateIfNotFound)
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► GetVirtualId(ID, ID, Database, Boolean)
Gets the virtual id of an item within a specific proxy context.
Declaration Syntax
C#
public static ID GetVirtualId(
    ID itemId,
    ID proxyId,
    Database proxyDatabase,
    bool generateIfNotFound
)
Parameters
itemId (ID)
The real item id.
proxyId (ID)
The proxy id.
proxyDatabase (Database)
The proxy database.
generateIfNotFound (Boolean)
If set to true a virtual id will be generated if it does not already exist.
Return Value


GetVirtualInstances Method (item, preserveState)

GetVirtualInstances Method (item, preserveState)
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► GetVirtualInstances(Item, Boolean)
Gets all virtual instances of an item.
Declaration Syntax
C#
public static ItemList GetVirtualInstances(
    Item item,
    bool preserveState
)
Parameters
item (Item)
The item.
preserveState (Boolean)
If set to true, state is preserved.
Return Value


GetVirtualItem Method (item, proxyId, database, preserveState)

GetVirtualItem Method (item, proxyId, database, preserveState)
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► GetVirtualItem(Item, ID, Database, Boolean)
Gets the virtual version of an item within a specific proxy context.
Declaration Syntax
C#
public static Item GetVirtualItem(
    Item item,
    ID proxyId,
    Database database,
    bool preserveState
)
Parameters
item (Item)
The item.
proxyId (ID)
The proxy id.
database (Database)
The database.
preserveState (Boolean)
If set to true, state is preserved.
Return Value


HasVirtualItems Method (item)

HasVirtualItems Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► HasVirtualItems(Item)
Determines whether the specified item has any shadows.
Declaration Syntax
C#
public static bool HasVirtualItems(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item has shadows; otherwise, false.


Initialize Method

Initialize Method
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► Initialize()()()
Initialize type.
Declaration Syntax
C#
public static void Initialize()


InsertVirtualChildren Method (children, parent)

InsertVirtualChildren Method (children, parent)
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► InsertVirtualChildren(ItemList, Item)
Inserts virtual children (if any) into a native list of children.
Declaration Syntax
C#
public static void InsertVirtualChildren(
    ItemList children,
    Item parent
)
Parameters
children (ItemList)
The children.
parent (Item)
The parent of the children.


IsProxy Method (item)

IsProxy Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► IsProxy(Item)
Determines whether the specified item is a proxy definition.
Declaration Syntax
C#
public static bool IsProxy(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item is proxy; otherwise, false.


IsVirtual Method (item)

IsVirtual Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyManager ► IsVirtual(Item)
Determines whether the specified item is virtual.
Declaration Syntax
C#
public static bool IsVirtual(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item is proxy; otherwise, false.


ProxyMapper Class

ProxyMapper Class
Namespaces ► Sitecore.Data.Proxies ► ProxyMapper
ProxyMapper class
Declaration Syntax
C#
public class ProxyMapper
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProxyMapper(ProxyProvider) | Initializes a new instance of the ProxyMapper class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRealDatabase(Item) | Gets the real database of a virtual item.
 | GetRealId(Item) | Gets the real id of a virtual item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVirtual(Item) | Determines whether the specified item is virtual.
 | MakeReal(Item, Boolean) | Converts a virtual item to the real one.
 | MakeVirtual(Item, Proxy) | Makes an item virtual.
 | MakeVirtual(Item, ID, Database) | Makes an item virtual.
 | MakeVirtual(Item, ID, Database, Boolean) | Makes an item virtual.
 | MakeVirtual(Item, ID, ID, Database, Boolean) | Makes an item virtual.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProxyMapper


ProxyMapper Constructor (owner)

ProxyMapper Constructor (owner)
Namespaces ► Sitecore.Data.Proxies ► ProxyMapper ► ProxyMapper(ProxyProvider)
Initializes a new instance of the ProxyMapper class.
Declaration Syntax
C#
public ProxyMapper(
    ProxyProvider owner
)
Parameters
owner (ProxyProvider)


GetRealDatabase Method (item)

GetRealDatabase Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyMapper ► GetRealDatabase(Item)
Gets the real database of a virtual item.
Declaration Syntax
C#
public Database GetRealDatabase(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetRealId Method (item)

GetRealId Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyMapper ► GetRealId(Item)
Gets the real id of a virtual item.
Declaration Syntax
C#
public virtual ID GetRealId(
    Item item
)
Parameters
item (Item)
The item.
Return Value


IsVirtual Method (item)

IsVirtual Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyMapper ► IsVirtual(Item)
Determines whether the specified item is virtual.
Declaration Syntax
C#
public virtual bool IsVirtual(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item is proxy; otherwise, false.


MakeReal Method (item, preserveState)

MakeReal Method (item, preserveState)
Namespaces ► Sitecore.Data.Proxies ► ProxyMapper ► MakeReal(Item, Boolean)
Converts a virtual item to the real one.
Declaration Syntax
C#
public Item MakeReal(
    Item item,
    bool preserveState
)
Parameters
item (Item)
The item.
preserveState (Boolean)
if set to true [preserve state].
Return Value


MakeVirtual Method

MakeVirtual Method
Namespaces ► Sitecore.Data.Proxies ► ProxyMapper ► MakeVirtual()()()
Members
Icon | Member | Description
 | MakeVirtual(Item, Proxy) | Makes an item virtual.
 | MakeVirtual(Item, ID, Database) | Makes an item virtual.
 | MakeVirtual(Item, ID, Database, Boolean) | Makes an item virtual.
 | MakeVirtual(Item, ID, ID, Database, Boolean) | Makes an item virtual.


MakeVirtual Method (item, proxyId, database)

MakeVirtual Method (item, proxyId, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyMapper ► MakeVirtual(Item, ID, Database)
Makes an item virtual.
Declaration Syntax
C#
public virtual Item MakeVirtual(
    Item item,
    ID proxyId,
    Database database
)
Parameters
item (Item)
The item.
proxyId (ID)
The proxy id.
database (Database)
The database.
Return Value


MakeVirtual Method (item, proxyId, database, preserveState)

MakeVirtual Method (item, proxyId, database, preserveState)
Namespaces ► Sitecore.Data.Proxies ► ProxyMapper ► MakeVirtual(Item, ID, Database, Boolean)
Makes an item virtual.
Declaration Syntax
C#
public virtual Item MakeVirtual(
    Item item,
    ID proxyId,
    Database database,
    bool preserveState
)
Parameters
item (Item)
The item.
proxyId (ID)
The proxy id.
database (Database)
The database.
preserveState (Boolean)
If set to true, state is preserved.
Return Value


MakeVirtual Method (item, virtualId, proxyId, database, preserveState)

MakeVirtual Method (item, virtualId, proxyId, database, preserveState)
Namespaces ► Sitecore.Data.Proxies ► ProxyMapper ► MakeVirtual(Item, ID, ID, Database, Boolean)
Makes an item virtual.
Declaration Syntax
C#
public virtual Item MakeVirtual(
    Item item,
    ID virtualId,
    ID proxyId,
    Database database,
    bool preserveState
)
Parameters
item (Item)
The item.
virtualId (ID)
The virtual id.
proxyId (ID)
The proxy id.
database (Database)
The database.
preserveState (Boolean)
If set to true, state is preserved.
Return Value


MakeVirtual Method (item, proxy)

MakeVirtual Method (item, proxy)
Namespaces ► Sitecore.Data.Proxies ► ProxyMapper ► MakeVirtual(Item, Proxy)
Makes an item virtual.
Declaration Syntax
C#
public virtual Item MakeVirtual(
    Item item,
    Proxy proxy
)
Parameters
item (Item)
The item.
proxy (Proxy)
The proxy.
Return Value


ProxyProvider Class

ProxyProvider Class
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider
ProxyProvider class
Declaration Syntax
C#
public class ProxyProvider
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProxyProvider()()() | Initializes a new instance of the ProxyProvider class.
 | _cache | The cache.
 | _mapper | The mapper.
 | _resolver | The resolver.
 | _state | The state.
 | AreProxiesEnabled(Database) | Checks if proxies are enabled for a specific database.
 | Cache | Gets the cache.
 | ClearCaches()()() | Clears all provider caches.
 | CopyVirtualTreeRoot(Item, Item) | Copies the virtual tree root.
 | DataEngine_AddedFromTemplate(Object, ExecutedEventArgs<(Of <(AddFromTemplateCommand>)>)) | Handles the AddedFromTemplate event of the DataEngine control.
 | DataEngine_AddedVersion(Object, ExecutedEventArgs<(Of <(AddVersionCommand>)>)) | Handles the AddedVersion event of the DataEngine control.
 | DataEngine_CopiedItem(Object, ExecutedEventArgs<(Of <(CopyItemCommand>)>)) | Handles the CopiedItem event of the DataEngine control.
 | DataEngine_CopyProcessedSingleItem(Object, CopyProcessedSingleItemEventArgs) | Handles the CopyProcessedSingleItem event of a DataEngine.
 | DataEngine_CreatedItem(Object, ExecutedEventArgs<(Of <(CreateItemCommand>)>)) | Handles the CreatedItem event of the DataEngine control.
 | DataEngine_DeletedItem(Object, ExecutedEventArgs<(Of <(DeleteItemCommand>)>)) | Handles the DeletedItem event of the DataEngine control.
 | DataEngine_MovedItem(Object, ExecutedEventArgs<(Of <(MoveItemCommand>)>)) | Handles the MovedItem event of the DataEngine control.
 | DataEngine_RemovedData(Object, ExecutedEventArgs<(Of <(RemoveDataCommand>)>)) | Handles the RemovedData event of the DataEngine control.
 | DataEngine_RemovedVersion(Object, ExecutedEventArgs<(Of <(RemoveVersionCommand>)>)) | Handles the RemovedVersion event of the DataEngine control.
 | DataEngine_SavedItem(Object, ExecutedEventArgs<(Of <(SaveItemCommand>)>)) | Handles the SavedItem event of the DataEngine control.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(ID, Language, Version, Database) | Gets an item.
 | GetParent(Item) | Gets the parent of an item.
 | GetProxyTargetId(Item) | Gets the proxy source id of the proxy having item as its root.
 | GetRealDatabase(Item) | Gets the real database of an item.
 | GetRealId(Item) | Gets the real id of a virtual.
 | GetRealItem(Item, Boolean) | Gets the real item behind a virtual item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVirtualId(ID, ID, Database, Boolean) | Gets the virtual id of an item within a specific proxy.
 | GetVirtualInstances(Item, Boolean) | Gets all virtual instances of an item.
 | GetVirtualItem(Item, ID, Database, Boolean) | Gets the virtual version of an item within a specific proxy context.
 | HasVirtualItems(Item) | Determines whether the specified item has any virtual items associated with it.
 | InitializeEventHandlers()()() | Initializes the event handlers.
 | InsertVirtualChildren(ItemList, Item) | Inserts virtual children (if any) into a list of native children.
 | IsProxy(Item) | Determines whether the specified item is a proxy definition.
 | IsVirtual(Item) | Determines whether the specified item is virtual.
 | Mapper | Gets the mapper.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PropagateAddedFromTemplate(AddFromTemplateCommand) | Propagates the 'added from template' event.
 | PropagateAddedVersion(AddVersionCommand) | Propagates the 'added version' event.
 | PropagateCopiedItem(CopyItemCommand) | Propagates the 'copied item' event.
 | PropagateCreatedItem(CreateItemCommand) | Propagates the 'created item' event.
 | PropagateDeletedItem(DeleteItemCommand) | Propagates the 'deleted item' event.
 | PropagateDeletedProxy(DeleteItemCommand) | Propagates the deleted proxy.
 | PropagateMovedItem(MoveItemCommand) | Propagates the 'moved item' event.
 | PropagateRemovedVersion(RemoveVersionCommand) | Propagates the 'removed version' event.
 | PropagateSavedItem(SaveItemCommand) | Propagates the 'saved item' event.
 | ProxyChanged(Item) | Proxies the target changed.
 | RemoveProxyData(ID, Database) | Removes all data releated to a proxy.
 | Resolver | Gets the resolver.
 | State | Gets the state.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProxyProvider


ProxyProvider Constructor

ProxyProvider Constructor
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► ProxyProvider()()()
Initializes a new instance of the ProxyProvider class.
Declaration Syntax
C#
public ProxyProvider()


_cache Field

_cache Field
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► _cache
The cache.
Declaration Syntax
C#
protected ProxyCache _cache


_mapper Field

_mapper Field
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► _mapper
The mapper.
Declaration Syntax
C#
protected ProxyMapper _mapper


_resolver Field

_resolver Field
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► _resolver
The resolver.
Declaration Syntax
C#
protected ProxyResolver _resolver


_state Field

_state Field
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► _state
The state.
Declaration Syntax
C#
protected ProxyStateMonitor _state


AreProxiesEnabled Method (database)

AreProxiesEnabled Method (database)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► AreProxiesEnabled(Database)
Checks if proxies are enabled for a specific database.
Declaration Syntax
C#
public virtual bool AreProxiesEnabled(
    Database database
)
Parameters
database (Database)
The database.
Return Value


Cache Property

Cache Property
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► Cache
Gets the cache.
Declaration Syntax
C#
public virtual ProxyCache Cache { get; }
Value
The cache.


ClearCaches Method

ClearCaches Method
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► ClearCaches()()()
Clears all provider caches.
Declaration Syntax
C#
public virtual void ClearCaches()


CopyVirtualTreeRoot Method (item, target)

CopyVirtualTreeRoot Method (item, target)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► CopyVirtualTreeRoot(Item, Item)
Copies the virtual tree root.
Declaration Syntax
C#
public virtual Item CopyVirtualTreeRoot(
    Item item,
    Item target
)
Parameters
item (Item)
The item.
target (Item)
The target.
Return Value


DataEngine_AddedFromTemplate Method (sender, e)

DataEngine_AddedFromTemplate Method (sender, e)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► DataEngine_AddedFromTemplate(Object, ExecutedEventArgs<(Of <(AddFromTemplateCommand>)>))
Handles the AddedFromTemplate event of the DataEngine control.
Declaration Syntax
C#
protected virtual void DataEngine_AddedFromTemplate(
    Object sender,
    ExecutedEventArgs<AddFromTemplateCommand> e
)
Parameters
sender (Object)
The source of the event.
e (ExecutedEventArgs <(Of <( AddFromTemplateCommand >)>))
The ExecutedEventArgs<(Of <(TCommand>)>) instance containing the event data.


DataEngine_AddedVersion Method (sender, e)

DataEngine_AddedVersion Method (sender, e)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► DataEngine_AddedVersion(Object, ExecutedEventArgs<(Of <(AddVersionCommand>)>))
Handles the AddedVersion event of the DataEngine control.
Declaration Syntax
C#
protected virtual void DataEngine_AddedVersion(
    Object sender,
    ExecutedEventArgs<AddVersionCommand> e
)
Parameters
sender (Object)
The source of the event.
e (ExecutedEventArgs <(Of <( AddVersionCommand >)>))
The ExecutedEventArgs<(Of <(TCommand>)>) instance containing the event data.


DataEngine_CopiedItem Method (sender, e)

DataEngine_CopiedItem Method (sender, e)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► DataEngine_CopiedItem(Object, ExecutedEventArgs<(Of <(CopyItemCommand>)>))
Handles the CopiedItem event of the DataEngine control.
Declaration Syntax
C#
protected virtual void DataEngine_CopiedItem(
    Object sender,
    ExecutedEventArgs<CopyItemCommand> e
)
Parameters
sender (Object)
The source of the event.
e (ExecutedEventArgs <(Of <( CopyItemCommand >)>))
The ExecutedEventArgs<(Of <(TCommand>)>) instance containing the event data.


DataEngine_CopyProcessedSingleItem Method (sender, e)

DataEngine_CopyProcessedSingleItem Method (sender, e)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► DataEngine_CopyProcessedSingleItem(Object, CopyProcessedSingleItemEventArgs)
Handles the CopyProcessedSingleItem event of a DataEngine.
Declaration Syntax
C#
protected virtual void DataEngine_CopyProcessedSingleItem(
    Object sender,
    CopyProcessedSingleItemEventArgs e
)
Parameters
sender (Object)
The source of the event.
e (CopyProcessedSingleItemEventArgs)
The CopyProcessedSingleItemEventArgs instance containing the event data.


DataEngine_CreatedItem Method (sender, e)

DataEngine_CreatedItem Method (sender, e)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► DataEngine_CreatedItem(Object, ExecutedEventArgs<(Of <(CreateItemCommand>)>))
Handles the CreatedItem event of the DataEngine control.
Declaration Syntax
C#
protected virtual void DataEngine_CreatedItem(
    Object sender,
    ExecutedEventArgs<CreateItemCommand> e
)
Parameters
sender (Object)
The source of the event.
e (ExecutedEventArgs <(Of <( CreateItemCommand >)>))
The ExecutedEventArgs<(Of <(TCommand>)>) instance containing the event data.


DataEngine_DeletedItem Method (sender, e)

DataEngine_DeletedItem Method (sender, e)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► DataEngine_DeletedItem(Object, ExecutedEventArgs<(Of <(DeleteItemCommand>)>))
Handles the DeletedItem event of the DataEngine control.
Declaration Syntax
C#
protected virtual void DataEngine_DeletedItem(
    Object sender,
    ExecutedEventArgs<DeleteItemCommand> e
)
Parameters
sender (Object)
The source of the event.
e (ExecutedEventArgs <(Of <( DeleteItemCommand >)>))
The ExecutedEventArgs<(Of <(TCommand>)>) instance containing the event data.


DataEngine_MovedItem Method (sender, e)

DataEngine_MovedItem Method (sender, e)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► DataEngine_MovedItem(Object, ExecutedEventArgs<(Of <(MoveItemCommand>)>))
Handles the MovedItem event of the DataEngine control.
Declaration Syntax
C#
protected virtual void DataEngine_MovedItem(
    Object sender,
    ExecutedEventArgs<MoveItemCommand> e
)
Parameters
sender (Object)
The source of the event.
e (ExecutedEventArgs <(Of <( MoveItemCommand >)>))
The ExecutedEventArgs<(Of <(TCommand>)>) instance containing the event data.


DataEngine_RemovedData Method (sender, e)

DataEngine_RemovedData Method (sender, e)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► DataEngine_RemovedData(Object, ExecutedEventArgs<(Of <(RemoveDataCommand>)>))
Handles the RemovedData event of the DataEngine control.
Declaration Syntax
C#
protected virtual void DataEngine_RemovedData(
    Object sender,
    ExecutedEventArgs<RemoveDataCommand> e
)
Parameters
sender (Object)
The source of the event.
e (ExecutedEventArgs <(Of <( RemoveDataCommand >)>))
The ExecutedEventArgs<(Of <(TCommand>)>) instance containing the event data.


DataEngine_RemovedVersion Method (sender, e)

DataEngine_RemovedVersion Method (sender, e)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► DataEngine_RemovedVersion(Object, ExecutedEventArgs<(Of <(RemoveVersionCommand>)>))
Handles the RemovedVersion event of the DataEngine control.
Declaration Syntax
C#
protected virtual void DataEngine_RemovedVersion(
    Object sender,
    ExecutedEventArgs<RemoveVersionCommand> e
)
Parameters
sender (Object)
The source of the event.
e (ExecutedEventArgs <(Of <( RemoveVersionCommand >)>))
The ExecutedEventArgs<(Of <(TCommand>)>) instance containing the event data.


DataEngine_SavedItem Method (sender, e)

DataEngine_SavedItem Method (sender, e)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► DataEngine_SavedItem(Object, ExecutedEventArgs<(Of <(SaveItemCommand>)>))
Handles the SavedItem event of the DataEngine control.
Declaration Syntax
C#
protected virtual void DataEngine_SavedItem(
    Object sender,
    ExecutedEventArgs<SaveItemCommand> e
)
Parameters
sender (Object)
The source of the event.
e (ExecutedEventArgs <(Of <( SaveItemCommand >)>))
The instance containing the event data.


GetItem Method (virtualId, language, version, database)

GetItem Method (virtualId, language, version, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► GetItem(ID, Language, Version, Database)
Gets an item.
Declaration Syntax
C#
public virtual Item GetItem(
    ID virtualId,
    Language language,
    Version version,
    Database database
)
Parameters
virtualId (ID)
The virtual item id.
language (Language)
The language.
version (Version)
The version.
database (Database)
The database.
Return Value


GetParent Method (item)

GetParent Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► GetParent(Item)
Gets the parent of an item.
Declaration Syntax
C#
public virtual Item GetParent(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The parent item.


GetProxyTargetId Method (item)

GetProxyTargetId Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► GetProxyTargetId(Item)
Gets the proxy source id of the proxy having item as its root.
Declaration Syntax
C#
protected virtual ID GetProxyTargetId(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetRealDatabase Method (item)

GetRealDatabase Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► GetRealDatabase(Item)
Gets the real database of an item.
Declaration Syntax
C#
public virtual Database GetRealDatabase(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetRealId Method (item)

GetRealId Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► GetRealId(Item)
Gets the real id of a virtual.
Declaration Syntax
C#
public virtual ID GetRealId(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetRealItem Method (item, preserveState)

GetRealItem Method (item, preserveState)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► GetRealItem(Item, Boolean)
Gets the real item behind a virtual item.
Declaration Syntax
C#
public virtual Item GetRealItem(
    Item item,
    bool preserveState
)
Parameters
item (Item)
The item.
preserveState (Boolean)
If set to true state is preserved.
Return Value


GetVirtualId Method (itemId, proxyId, database, generateIfNotFound)

GetVirtualId Method (itemId, proxyId, database, generateIfNotFound)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► GetVirtualId(ID, ID, Database, Boolean)
Gets the virtual id of an item within a specific proxy.
Declaration Syntax
C#
public virtual ID GetVirtualId(
    ID itemId,
    ID proxyId,
    Database database,
    bool generateIfNotFound
)
Parameters
itemId (ID)
The real item id.
proxyId (ID)
The proxy id.
database (Database)
The database.
generateIfNotFound (Boolean)
If set to true a virtual id will be generated if it does not already exist.
Return Value


GetVirtualInstances Method (item, preserveState)

GetVirtualInstances Method (item, preserveState)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► GetVirtualInstances(Item, Boolean)
Gets all virtual instances of an item.
Declaration Syntax
C#
public virtual ItemList GetVirtualInstances(
    Item item,
    bool preserveState
)
Parameters
item (Item)
The item.
preserveState (Boolean)
If set to true, state is preserved.
Return Value


GetVirtualItem Method (item, proxyId, database, preserveState)

GetVirtualItem Method (item, proxyId, database, preserveState)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► GetVirtualItem(Item, ID, Database, Boolean)
Gets the virtual version of an item within a specific proxy context.
Declaration Syntax
C#
public virtual Item GetVirtualItem(
    Item item,
    ID proxyId,
    Database database,
    bool preserveState
)
Parameters
item (Item)
The item.
proxyId (ID)
The proxy id.
database (Database)
The database.
preserveState (Boolean)
If set to true, state is preserved.
Return Value


HasVirtualItems Method (item)

HasVirtualItems Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► HasVirtualItems(Item)
Determines whether the specified item has any virtual items associated with it.
Declaration Syntax
C#
public virtual bool HasVirtualItems(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item has virtual items; otherwise, false.


InitializeEventHandlers Method

InitializeEventHandlers Method
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► InitializeEventHandlers()()()
Initializes the event handlers.
Declaration Syntax
C#
protected void InitializeEventHandlers()


InsertVirtualChildren Method (children, parent)

InsertVirtualChildren Method (children, parent)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► InsertVirtualChildren(ItemList, Item)
Inserts virtual children (if any) into a list of native children.
Declaration Syntax
C#
public virtual void InsertVirtualChildren(
    ItemList children,
    Item parent
)
Parameters
children (ItemList)
The children.
parent (Item)
The parent of the children.


IsProxy Method (item)

IsProxy Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► IsProxy(Item)
Determines whether the specified item is a proxy definition.
Declaration Syntax
C#
public virtual bool IsProxy(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item is proxy; otherwise, false.


IsVirtual Method (item)

IsVirtual Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► IsVirtual(Item)
Determines whether the specified item is virtual.
Declaration Syntax
C#
public virtual bool IsVirtual(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item is proxy; otherwise, false.


Mapper Property

Mapper Property
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► Mapper
Gets the mapper.
Declaration Syntax
C#
public virtual ProxyMapper Mapper { get; }
Value
The mapper.


PropagateAddedFromTemplate Method (command)

PropagateAddedFromTemplate Method (command)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► PropagateAddedFromTemplate(AddFromTemplateCommand)
Propagates the 'added from template' event.
Declaration Syntax
C#
protected virtual void PropagateAddedFromTemplate(
    AddFromTemplateCommand command
)
Parameters
command (AddFromTemplateCommand)
The command.


PropagateAddedVersion Method (command)

PropagateAddedVersion Method (command)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► PropagateAddedVersion(AddVersionCommand)
Propagates the 'added version' event.
Declaration Syntax
C#
protected virtual void PropagateAddedVersion(
    AddVersionCommand command
)
Parameters
command (AddVersionCommand)
The command.


PropagateCopiedItem Method (command)

PropagateCopiedItem Method (command)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► PropagateCopiedItem(CopyItemCommand)
Propagates the 'copied item' event.
Declaration Syntax
C#
protected virtual void PropagateCopiedItem(
    CopyItemCommand command
)
Parameters
command (CopyItemCommand)
The command.


PropagateCreatedItem Method (command)

PropagateCreatedItem Method (command)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► PropagateCreatedItem(CreateItemCommand)
Propagates the 'created item' event.
Declaration Syntax
C#
protected virtual void PropagateCreatedItem(
    CreateItemCommand command
)
Parameters
command (CreateItemCommand)
The command.


PropagateDeletedItem Method (command)

PropagateDeletedItem Method (command)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► PropagateDeletedItem(DeleteItemCommand)
Propagates the 'deleted item' event.
Declaration Syntax
C#
protected virtual void PropagateDeletedItem(
    DeleteItemCommand command
)
Parameters
command (DeleteItemCommand)
The command.


PropagateDeletedProxy Method (command)

PropagateDeletedProxy Method (command)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► PropagateDeletedProxy(DeleteItemCommand)
Propagates the deleted proxy.
Declaration Syntax
C#
protected virtual void PropagateDeletedProxy(
    DeleteItemCommand command
)
Parameters
command (DeleteItemCommand)
The command.


PropagateMovedItem Method (command)

PropagateMovedItem Method (command)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► PropagateMovedItem(MoveItemCommand)
Propagates the 'moved item' event.
Declaration Syntax
C#
protected virtual void PropagateMovedItem(
    MoveItemCommand command
)
Parameters
command (MoveItemCommand)
The command.


PropagateRemovedVersion Method (command)

PropagateRemovedVersion Method (command)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► PropagateRemovedVersion(RemoveVersionCommand)
Propagates the 'removed version' event.
Declaration Syntax
C#
protected virtual void PropagateRemovedVersion(
    RemoveVersionCommand command
)
Parameters
command (RemoveVersionCommand)
The command.


PropagateSavedItem Method (command)

PropagateSavedItem Method (command)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► PropagateSavedItem(SaveItemCommand)
Propagates the 'saved item' event.
Declaration Syntax
C#
protected virtual void PropagateSavedItem(
    SaveItemCommand command
)
Parameters
command (SaveItemCommand)
The command.


ProxyChanged Method (item)

ProxyChanged Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► ProxyChanged(Item)
Proxies the target changed.
Declaration Syntax
C#
protected virtual bool ProxyChanged(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The target changed.


RemoveProxyData Method (proxyId, database)

RemoveProxyData Method (proxyId, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► RemoveProxyData(ID, Database)
Removes all data releated to a proxy.
Declaration Syntax
C#
public virtual void RemoveProxyData(
    ID proxyId,
    Database database
)
Parameters
proxyId (ID)
The proxy id.
database (Database)
The database.


Resolver Property

Resolver Property
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► Resolver
Gets the resolver.
Declaration Syntax
C#
public virtual ProxyResolver Resolver { get; }
Value
The resolver.


State Property

State Property
Namespaces ► Sitecore.Data.Proxies ► ProxyProvider ► State
Gets the state.
Declaration Syntax
C#
public virtual ProxyStateMonitor State { get; }
Value
The state.


ProxyReference Class

ProxyReference Class
Namespaces ► Sitecore.Data.Proxies ► ProxyReference
ProxyReference class
Declaration Syntax
C#
public class ProxyReference
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProxyReference(ID, ID, Database) | Initializes a new instance of the ProxyReference class.
 | Database | Gets the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProxyId | Gets the proxy id.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VirtualId | Gets the virtual item id.
Inheritance Hierarchy
Object
ProxyReference


ProxyReference Constructor (virtualId, proxyId, database)

ProxyReference Constructor (virtualId, proxyId, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyReference ► ProxyReference(ID, ID, Database)
Initializes a new instance of the ProxyReference class.
Declaration Syntax
C#
public ProxyReference(
    ID virtualId,
    ID proxyId,
    Database database
)
Parameters
virtualId (ID)
The virtual id.
proxyId (ID)
The proxy id.
database (Database)
The database.


Database Property

Database Property
Namespaces ► Sitecore.Data.Proxies ► ProxyReference ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


ProxyId Property

ProxyId Property
Namespaces ► Sitecore.Data.Proxies ► ProxyReference ► ProxyId
Gets the proxy id.
Declaration Syntax
C#
public ID ProxyId { get; }
Value
The proxy id.


VirtualId Property

VirtualId Property
Namespaces ► Sitecore.Data.Proxies ► ProxyReference ► VirtualId
Gets the virtual item id.
Declaration Syntax
C#
public ID VirtualId { get; }
Value
The virtual item id.


ProxyResolver Class

ProxyResolver Class
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver
ProxyResolver class
Declaration Syntax
C#
public class ProxyResolver
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProxyResolver(ProxyProvider) | Initializes a new instance of the ProxyResolver class.
 | AddProxyDefinition(SafeDictionary<(Of <(Object, IList<(Of <(Proxy>)>)>)>), Proxy) | Adds the proxy definition.
 | Cache | Gets the cache.
 | CopyVirtualTreeRoot(Item, Item) | Copies the virtual item.
 | DuplicateProxyDefinitions(Item, Item) | Duplicates the proxy definitions.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataProvider(Database) | Gets the data provider for a specific database.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetParent(Item) | Gets the parent of a virtual item.
 | GetProxies(Database) | Gets all proxies in a database.
 | GetProxiesUnder(Item) | Gets all proxies linked to a specific item.
 | GetProxy(ID, Database) | Gets the proxy with a specific id.
 | GetProxy(Item) | Gets the proxy for a virtual item.
 | GetProxyChildren(Item) | Gets all proxy targets for a specific item.
 | GetProxyCore(ID, Database) | Gets the proxy core.
 | GetProxyDefinitionName(Item, Item, Item) | Gets the name of the proxy definition.
 | GetProxyId(Item) | Gets the proxy id for a virtual item.
 | GetProxyItem(ID, Database) | Gets a proxy item.
 | GetReferenceInstances(Item, List<(Of <(ProxyReference>)>), Boolean) | Gets the instances pointed to by a list of references.
 | GetReferences(Item) | Gets the references to an item.
 | GetReferencesFromDataProvider(Item) | Gets the references to an item from the data providers.
 | GetTarget(ID, Database) | Gets the target description for a virtual item.
 | GetTargetCore(ID, Database) | Gets the target.
 | GetTargetFromDataProvider(ID, Database) | Gets the item id from the data provider.
 | GetTargetItem(ID, Language, Version, Database) | Gets the target item of a virtual id.
 | GetTrueVirtualChildren(Item) | Inserts children for a virtual item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVirtualChildren(Item) | Gets the virtual children of an item.
 | GetVirtualId(ID, ID, Database, Boolean) | Gets the virtual id of an item within a specific proxy.
 | GetVirtualIdCore(ID, ID, Database, Boolean) | Gets the virtual id core.
 | GetVirtualIdFromDataProvider(ID, ID, Database, Boolean) | Gets a virtual id from data provider.
 | GetVirtualInstances(Item, Boolean) | Gets all virtual instances of an item.
 | IsProxy(Item) | Determines whether the specified item is a proxy definition.
 | LoadProxyDefinitions(Database, Item, SafeDictionary<(Of <(Object, IList<(Of <(Proxy>)>)>)>)) | Loads the proxy definitions.
 | Mapper | Gets the mapper.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseProxyItem(Item) | Parses a proxy item.
 | RemoveProxyData(ID, Database) | Removes all data associated with a specific proxy.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProxyResolver


ProxyResolver Constructor (owner)

ProxyResolver Constructor (owner)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► ProxyResolver(ProxyProvider)
Initializes a new instance of the ProxyResolver class.
Declaration Syntax
C#
public ProxyResolver(
    ProxyProvider owner
)
Parameters
owner (ProxyProvider)


AddProxyDefinition Method (result, proxy)

AddProxyDefinition Method (result, proxy)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► AddProxyDefinition(SafeDictionary<(Of <(Object, IList<(Of <(Proxy>)>)>)>), Proxy)
Adds the proxy definition.
Declaration Syntax
C#
protected void AddProxyDefinition(
    SafeDictionary<Object, IList<Proxy>> result,
    Proxy proxy
)
Parameters
result (SafeDictionary <(Of <(Object, IList<(Of <( Proxy >)>)>)>))
The result.
proxy (Proxy)
The proxy.


Cache Property

Cache Property
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► Cache
Gets the cache.
Declaration Syntax
C#
public ProxyCache Cache { get; }
Value
The cache.


CopyVirtualTreeRoot Method (item, target)

CopyVirtualTreeRoot Method (item, target)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► CopyVirtualTreeRoot(Item, Item)
Copies the virtual item.
Declaration Syntax
C#
public virtual Item CopyVirtualTreeRoot(
    Item item,
    Item target
)
Parameters
item (Item)
The item.
target (Item)
The target.
Return Value


DuplicateProxyDefinitions Method (original, copy)

DuplicateProxyDefinitions Method (original, copy)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► DuplicateProxyDefinitions(Item, Item)
Duplicates the proxy definitions.
Declaration Syntax
C#
public virtual void DuplicateProxyDefinitions(
    Item original,
    Item copy
)
Parameters
original (Item)
The source.
copy (Item)
The copy.


GetDataProvider Method (database)

GetDataProvider Method (database)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetDataProvider(Database)
Gets the data provider for a specific database.
Declaration Syntax
C#
protected virtual ProxyDataProvider GetDataProvider(
    Database database
)
Parameters
database (Database)
The database.
Return Value


GetParent Method (item)

GetParent Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetParent(Item)
Gets the parent of a virtual item.
Declaration Syntax
C#
public virtual Item GetParent(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetProxies Method (database)

GetProxies Method (database)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetProxies(Database)
Gets all proxies in a database.
Declaration Syntax
C#
protected virtual SafeDictionary<Object, IList<Proxy>> GetProxies(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The proxies.


GetProxiesUnder Method (item)

GetProxiesUnder Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetProxiesUnder(Item)
Gets all proxies linked to a specific item.
Declaration Syntax
C#
protected virtual IList<Proxy> GetProxiesUnder(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetProxy Method

GetProxy Method
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetProxy()()()
Members
Icon | Member | Description
 | GetProxy(ID, Database) | Gets the proxy with a specific id.
 | GetProxy(Item) | Gets the proxy for a virtual item.


GetProxy Method (proxyId, database)

GetProxy Method (proxyId, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetProxy(ID, Database)
Gets the proxy with a specific id.
Declaration Syntax
C#
public virtual Proxy GetProxy(
    ID proxyId,
    Database database
)
Parameters
proxyId (ID)
The proxy id.
database (Database)
The database.
Return Value


GetProxy Method (item)

GetProxy Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetProxy(Item)
Gets the proxy for a virtual item.
Declaration Syntax
C#
public virtual Proxy GetProxy(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetProxyChildren Method (item)

GetProxyChildren Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetProxyChildren(Item)
Gets all proxy targets for a specific item.
Declaration Syntax
C#
protected virtual ItemList GetProxyChildren(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetProxyCore Method (proxyId, database)

GetProxyCore Method (proxyId, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetProxyCore(ID, Database)
Gets the proxy core.
Declaration Syntax
C#
protected virtual Proxy GetProxyCore(
    ID proxyId,
    Database database
)
Parameters
proxyId (ID)
The proxy id.
database (Database)
The database.
Return Value


GetProxyDefinitionName Method (item, originalProxy, destination)

GetProxyDefinitionName Method (item, originalProxy, destination)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetProxyDefinitionName(Item, Item, Item)
Gets the name of the proxy definition.
Declaration Syntax
C#
protected virtual string GetProxyDefinitionName(
    Item item,
    Item originalProxy,
    Item destination
)
Parameters
item (Item)
The item.
originalProxy (Item)
The original proxy.
destination (Item)
The destination.
Return Value
The proxy definition name.


GetProxyId Method (item)

GetProxyId Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetProxyId(Item)
Gets the proxy id for a virtual item.
Declaration Syntax
C#
public virtual ID GetProxyId(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetProxyItem Method (proxyId, database)

GetProxyItem Method (proxyId, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetProxyItem(ID, Database)
Gets a proxy item.
Declaration Syntax
C#
public virtual Item GetProxyItem(
    ID proxyId,
    Database database
)
Parameters
proxyId (ID)
The proxy id.
database (Database)
The database.
Return Value


GetReferenceInstances Method (realItem, references, preserveState)

GetReferenceInstances Method (realItem, references, preserveState)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetReferenceInstances(Item, List<(Of <(ProxyReference>)>), Boolean)
Gets the instances pointed to by a list of references.
Declaration Syntax
C#
protected virtual ItemList GetReferenceInstances(
    Item realItem,
    List<ProxyReference> references,
    bool preserveState
)
Parameters
realItem (Item)
The real item.
references (List<(Of <( ProxyReference >)>))
The references.
preserveState (Boolean)
If set to true, state is preserved.
Return Value


GetReferences Method (item)

GetReferences Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetReferences(Item)
Gets the references to an item.
Declaration Syntax
C#
public virtual List<ProxyReference> GetReferences(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetReferencesFromDataProvider Method (item)

GetReferencesFromDataProvider Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetReferencesFromDataProvider(Item)
Gets the references to an item from the data providers.
Declaration Syntax
C#
protected virtual List<ProxyReference> GetReferencesFromDataProvider(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetTarget Method (virtualId, database)

GetTarget Method (virtualId, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetTarget(ID, Database)
Gets the target description for a virtual item.
Declaration Syntax
C#
public virtual ProxyTarget GetTarget(
    ID virtualId,
    Database database
)
Parameters
virtualId (ID)
The virtual id.
database (Database)
The database.
Return Value


GetTargetCore Method (virtualId, database)

GetTargetCore Method (virtualId, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetTargetCore(ID, Database)
Gets the target.
Declaration Syntax
C#
protected virtual ProxyTarget GetTargetCore(
    ID virtualId,
    Database database
)
Parameters
virtualId (ID)
The virtual id.
database (Database)
The database.
Return Value


GetTargetFromDataProvider Method (virtualId, database)

GetTargetFromDataProvider Method (virtualId, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetTargetFromDataProvider(ID, Database)
Gets the item id from the data provider.
Declaration Syntax
C#
protected virtual ProxyTarget GetTargetFromDataProvider(
    ID virtualId,
    Database database
)
Parameters
virtualId (ID)
The virtual id.
database (Database)
The database.
Return Value


GetTargetItem Method (virtualId, language, version, database)

GetTargetItem Method (virtualId, language, version, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetTargetItem(ID, Language, Version, Database)
Gets the target item of a virtual id.
Declaration Syntax
C#
public Item GetTargetItem(
    ID virtualId,
    Language language,
    Version version,
    Database database
)
Parameters
virtualId (ID)
The virtual id.
language (Language)
The language.
version (Version)
The version.
database (Database)
The database.
Return Value


GetTrueVirtualChildren Method (item)

GetTrueVirtualChildren Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetTrueVirtualChildren(Item)
Inserts children for a virtual item.
Declaration Syntax
C#
protected virtual ItemList GetTrueVirtualChildren(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetVirtualChildren Method (item)

GetVirtualChildren Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetVirtualChildren(Item)
Gets the virtual children of an item.
Declaration Syntax
C#
public ItemList GetVirtualChildren(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetVirtualId Method (itemId, proxyId, database, generateIfNotFound)

GetVirtualId Method (itemId, proxyId, database, generateIfNotFound)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetVirtualId(ID, ID, Database, Boolean)
Gets the virtual id of an item within a specific proxy.
Declaration Syntax
C#
public virtual ID GetVirtualId(
    ID itemId,
    ID proxyId,
    Database database,
    bool generateIfNotFound
)
Parameters
itemId (ID)
The real item id.
proxyId (ID)
The proxy id.
database (Database)
The database.
generateIfNotFound (Boolean)
If set to true a virtual id will be generated if it does not already exist.
Return Value


GetVirtualIdCore Method (itemId, proxyId, database, generateIfNotFound)

GetVirtualIdCore Method (itemId, proxyId, database, generateIfNotFound)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetVirtualIdCore(ID, ID, Database, Boolean)
Gets the virtual id core.
Declaration Syntax
C#
protected virtual ID GetVirtualIdCore(
    ID itemId,
    ID proxyId,
    Database database,
    bool generateIfNotFound
)
Parameters
itemId (ID)
The item id.
proxyId (ID)
The proxy id.
database (Database)
The database.
generateIfNotFound (Boolean)
if set to true [generate if not found].
Return Value


GetVirtualIdFromDataProvider Method (itemId, proxyId, database, generateIfNotFound)

GetVirtualIdFromDataProvider Method (itemId, proxyId, database, generateIfNotFound)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetVirtualIdFromDataProvider(ID, ID, Database, Boolean)
Gets a virtual id from data provider.
Declaration Syntax
C#
protected virtual ID GetVirtualIdFromDataProvider(
    ID itemId,
    ID proxyId,
    Database database,
    bool generateIfNotFound
)
Parameters
itemId (ID)
The item id.
proxyId (ID)
The proxy id.
database (Database)
The proxy database.
generateIfNotFound (Boolean)
If set to true a virtual id will be generated if it does not already exist.
Return Value


GetVirtualInstances Method (item, preserveState)

GetVirtualInstances Method (item, preserveState)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► GetVirtualInstances(Item, Boolean)
Gets all virtual instances of an item.
Declaration Syntax
C#
public virtual ItemList GetVirtualInstances(
    Item item,
    bool preserveState
)
Parameters
item (Item)
The item.
preserveState (Boolean)
If set to true, state is preserved.
Return Value


IsProxy Method (item)

IsProxy Method (item)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► IsProxy(Item)
Determines whether the specified item is a proxy definition.
Declaration Syntax
C#
public virtual bool IsProxy(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item is proxy; otherwise, false.


LoadProxyDefinitions Method (database, root, result)

LoadProxyDefinitions Method (database, root, result)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► LoadProxyDefinitions(Database, Item, SafeDictionary<(Of <(Object, IList<(Of <(Proxy>)>)>)>))
Loads the proxy definitions.
Declaration Syntax
C#
protected virtual void LoadProxyDefinitions(
    Database database,
    Item root,
    SafeDictionary<Object, IList<Proxy>> result
)
Parameters
database (Database)
The database.
root (Item)
The root.
result (SafeDictionary <(Of <(Object, IList<(Of <( Proxy >)>)>)>))
The result.


Mapper Property

Mapper Property
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► Mapper
Gets the mapper.
Declaration Syntax
C#
public ProxyMapper Mapper { get; }
Value
The mapper.


ParseProxyItem Method (proxyItem)

ParseProxyItem Method (proxyItem)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► ParseProxyItem(Item)
Parses a proxy item.
Declaration Syntax
C#
protected virtual Proxy ParseProxyItem(
    Item proxyItem
)
Parameters
proxyItem (Item)
The proxy item.
Return Value


RemoveProxyData Method (proxyId, database)

RemoveProxyData Method (proxyId, database)
Namespaces ► Sitecore.Data.Proxies ► ProxyResolver ► RemoveProxyData(ID, Database)
Removes all data associated with a specific proxy.
Declaration Syntax
C#
public virtual void RemoveProxyData(
    ID proxyId,
    Database database
)
Parameters
proxyId (ID)
The proxy id.
database (Database)
The database.


ProxyState Enumeration

ProxyState Enumeration
Namespaces ► Sitecore.Data.Proxies ► ProxyState
ProxyState enum
Declaration Syntax
C#
public enum ProxyState
Members
Member | Description
Disabled |
Enabled |


ProxyStateMonitor Class

ProxyStateMonitor Class
Namespaces ► Sitecore.Data.Proxies ► ProxyStateMonitor
StateMonitor class
Declaration Syntax
C#
public class ProxyStateMonitor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProxyStateMonitor()()() | Initializes a new instance of the ProxyStateMonitor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetState()()() | Gets the general system state (basically the same as ProxiesActive).
 | GetState(Database) | Gets the state for a specific database.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsActive(Database) | Determines whether proxies are active for the specified database.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProxiesActive | Gets a value indicating whether proxies are active.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProxyStateMonitor


ProxyStateMonitor Constructor

ProxyStateMonitor Constructor
Namespaces ► Sitecore.Data.Proxies ► ProxyStateMonitor ► ProxyStateMonitor()()()
Initializes a new instance of the ProxyStateMonitor class
Declaration Syntax
C#
public ProxyStateMonitor()


GetState Method

GetState Method
Namespaces ► Sitecore.Data.Proxies ► ProxyStateMonitor ► GetState()()()
Members
Icon | Member | Description
 | GetState()()() | Gets the general system state (basically the same as ProxiesActive).
 | GetState(Database) | Gets the state for a specific database.


GetState Method

GetState Method
Namespaces ► Sitecore.Data.Proxies ► ProxyStateMonitor ► GetState()()()
Gets the general system state (basically the same as ProxiesActive).
Declaration Syntax
C#
public ProxyState GetState()
Return Value


GetState Method (database)

GetState Method (database)
Namespaces ► Sitecore.Data.Proxies ► ProxyStateMonitor ► GetState(Database)
Gets the state for a specific database.
Declaration Syntax
C#
public ProxyState GetState(
    Database database
)
Parameters
database (Database)
The database.
Return Value
Remarks
If proxy support has been disabled generally, this method will result Disabled for all databases regardless of their individual settings.


IsActive Method (database)

IsActive Method (database)
Namespaces ► Sitecore.Data.Proxies ► ProxyStateMonitor ► IsActive(Database)
Determines whether proxies are active for the specified database.
Declaration Syntax
C#
public virtual bool IsActive(
    Database database
)
Parameters
database (Database)
The database.
Return Value
true if proxies are active for the specified database; otherwise, false.


ProxiesActive Property

ProxiesActive Property
Namespaces ► Sitecore.Data.Proxies ► ProxyStateMonitor ► ProxiesActive
Gets a value indicating whether proxies are active.
Declaration Syntax
C#
public bool ProxiesActive { get; }
Value
true if proxies are active; otherwise, false.


ProxyTarget Class

ProxyTarget Class
Namespaces ► Sitecore.Data.Proxies ► ProxyTarget
Represents a proxy target.
Declaration Syntax
C#
public class ProxyTarget
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProxyTarget(ID, ID) | Initializes a new instance of the ProxyTarget class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTargetItem(Language, Version) | Gets the target item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsNullOrEmpty(ProxyTarget) | Determines whether the specified target is null or empty.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Null | Gets the null instance.
 | ProxyID | Gets the proxy ID.
 | TargetDatabase | Gets or sets the target database.
 | TargetID | Gets the target ID.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProxyTarget


ProxyTarget Constructor (targetId, proxyId)

ProxyTarget Constructor (targetId, proxyId)
Namespaces ► Sitecore.Data.Proxies ► ProxyTarget ► ProxyTarget(ID, ID)
Initializes a new instance of the ProxyTarget class.
Declaration Syntax
C#
public ProxyTarget(
    ID targetId,
    ID proxyId
)
Parameters
targetId (ID)
The target ID.
proxyId (ID)
The proxy ID.


GetTargetItem Method (language, version)

GetTargetItem Method (language, version)
Namespaces ► Sitecore.Data.Proxies ► ProxyTarget ► GetTargetItem(Language, Version)
Gets the target item.
Declaration Syntax
C#
public Item GetTargetItem(
    Language language,
    Version version
)
Parameters
language (Language)
The language.
version (Version)
The version.
Return Value


IsNullOrEmpty Method (target)

IsNullOrEmpty Method (target)
Namespaces ► Sitecore.Data.Proxies ► ProxyTarget ► IsNullOrEmpty(ProxyTarget)
Determines whether the specified target is null or empty.
Declaration Syntax
C#
public static bool IsNullOrEmpty(
    ProxyTarget target
)
Parameters
target (ProxyTarget)
The target.


Null Property

Null Property
Namespaces ► Sitecore.Data.Proxies ► ProxyTarget ► Null
Gets the null instance.
Declaration Syntax
C#
public static ProxyTarget Null { get; }
Value
The null.


ProxyID Property

ProxyID Property
Namespaces ► Sitecore.Data.Proxies ► ProxyTarget ► ProxyID
Gets the proxy ID.
Declaration Syntax
C#
public ID ProxyID { get; }
Value
The proxy ID.


TargetDatabase Property

TargetDatabase Property
Namespaces ► Sitecore.Data.Proxies ► ProxyTarget ► TargetDatabase
Gets or sets the target database.
Declaration Syntax
C#
public Database TargetDatabase { get; set; }
Value
The target database.


TargetID Property

TargetID Property
Namespaces ► Sitecore.Data.Proxies ► ProxyTarget ► TargetID
Gets the target ID.
Declaration Syntax
C#
public ID TargetID { get; }
Value
The target ID.


ProxyType Enumeration

ProxyType Enumeration
Namespaces ► Sitecore.Data.Proxies ► ProxyType
Insertion type for a proxy
Declaration Syntax
C#
public enum ProxyType
Members
Member | Description
EntireSubtree | All items will be included
RootOnly | Only source item will be included
DescendantsOnly | Only children of a source item will be included


SqlProxyDataProvider Class

SqlProxyDataProvider Class
Namespaces ► Sitecore.Data.Proxies ► SqlProxyDataProvider
Base class for SQL based data providers.
Declaration Syntax
C#
public class SqlProxyDataProvider : ProxyDataProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlProxyDataProvider(SqlDataApi) | Initializes a new instance of the SqlProxyDataProvider class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReferences(ID) | Gets all references to a specific item. (Overrides ProxyDataProvider.GetReferences(ID).)
 | GetTarget(ID) | Gets the id of the item pointed to by a virtual id. (Overrides ProxyDataProvider.GetTarget(ID).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVirtualId(ID, ID, Boolean) | Gets the id of a shadow pointing to a specific item id within a specific proxy. (Overrides ProxyDataProvider.GetVirtualId(ID, ID, Boolean).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from ProxyDataProvider.)
 | RemoveData(ID) | Removes all data associated with a specific proxy. (Overrides ProxyDataProvider.RemoveData(ID).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProxyDataProvider
 |  | SqlProxyDataProvider
 |  |  | SqlServerProxyDataProvider


SqlProxyDataProvider Constructor (api)

SqlProxyDataProvider Constructor (api)
Namespaces ► Sitecore.Data.Proxies ► SqlProxyDataProvider ► SqlProxyDataProvider(SqlDataApi)
Initializes a new instance of the SqlProxyDataProvider class.
Declaration Syntax
C#
public SqlProxyDataProvider(
    SqlDataApi api
)
Parameters
api (SqlDataApi)
The API.


GetReferences Method (itemId)

GetReferences Method (itemId)
Namespaces ► Sitecore.Data.Proxies ► SqlProxyDataProvider ► GetReferences(ID)
Gets all references to a specific item.
Declaration Syntax
C#
public override List<ProxyDataRecord> GetReferences(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value


GetTarget Method (virtualId)

GetTarget Method (virtualId)
Namespaces ► Sitecore.Data.Proxies ► SqlProxyDataProvider ► GetTarget(ID)
Gets the id of the item pointed to by a virtual id.
Declaration Syntax
C#
public override ProxyTarget GetTarget(
    ID virtualId
)
Parameters
virtualId (ID)
The virtual id.
Return Value


GetVirtualId Method (itemId, proxyId, generateIfNotFound)

GetVirtualId Method (itemId, proxyId, generateIfNotFound)
Namespaces ► Sitecore.Data.Proxies ► SqlProxyDataProvider ► GetVirtualId(ID, ID, Boolean)
Gets the id of a shadow pointing to a specific item id within a specific proxy.
Declaration Syntax
C#
public override ID GetVirtualId(
    ID itemId,
    ID proxyId,
    bool generateIfNotFound
)
Parameters
itemId (ID)
The item id.
proxyId (ID)
The proxy id.
generateIfNotFound (Boolean)
If set to true a virtual id will be generated if it does not already exist.
Return Value


RemoveData Method (proxyId)

RemoveData Method (proxyId)
Namespaces ► Sitecore.Data.Proxies ► SqlProxyDataProvider ► RemoveData(ID)
Removes all data associated with a specific proxy.
Declaration Syntax
C#
public override void RemoveData(
    ID proxyId
)
Parameters
proxyId (ID)
The proxy id.


Sitecore.Data.Query Namespace

Sitecore.Data.Query Namespace
Namespaces ► Sitecore.Data.Query
Declaration Syntax
C#
namespace Sitecore.Data.Query
Types
All Types Classes Structures Interfaces Delegates
Icon | Type | Description
 | AddOperator | Represents an Add operator in an Sitecore XPath query.
 | Ancestor | Represents the ancestor axis in an Sitecore XPath expression.
 | AncestorOrSelf | Represents the ancestor-or-self axis in an Sitecore XPath expression.
 | AndOperator | Represents an And operator in an Sitecore XPath query.
 | BinaryOperator | Defines the basic functionality of binary operators in an Sitecore XPath query.
 | BooleanValue | Represents a boolean value in an Sitecore XPath expression.
 | Children | Represents a children list in an Sitecore XPath expression.
 | Descendant | Represents a descendant axis in an Sitecore XPath expression.
 | DescendantOrSelf | Represents a descendant-or-self axis in an Sitecore XPath expression.
 | DivideOperator | Represents an Divide operator in an Sitecore XPath query.
 | ElementBase | Defines the basic functonlity for an Element in an Sitecore XPath query.
 | EqualsOperator | Represents an Equals operator in an Sitecore XPath query.
 | FieldElement | Represents a field element in an Sitecore XPath expression.
 | Following | Represents a following axis in an Sitecore XPath expression.
 | Function | Represents a custom function in an Sitecore XPath expression.
 | FunctionArgs | Represents the arguments passed to a custom function in an Sitecore XPath expression.
 | FunctionEventHandler | Represents the method that will be called when a function is invoked in an Sitecore XPath query.
 | Functions | Contains custom functions for use in an Sitecore XPath expression.
 | GreaterOperator | Represents an Greater operator in an Sitecore XPath query.
 | GreaterOrEqualsOperator | Represents an Greater or Equals operator in an Sitecore XPath query.
 | IQueryable | Defines the basic functionality of an object that can be queried using Sitecore XPath.
 | ISupportPaths | Marks a class that it supports long item paths.
 | ItemElement | Represents an Item element in an Sitecore XPath query.
 | Literal | Represents a literal text in an Sitecore XPath query.
 | MatchArgs | Represents the arguments that are passed when a Match event is raised.
 | MatchEventHandler | Represents the method that will be called when a node is tested in a predicate in an Sitecore XPath query.
 | MinusOperator | Represents an Minus operator in an Sitecore XPath query.
 | ModulusOperator | Represents an Modulus operator in an Sitecore XPath query.
 | MultiplyOperator | Represents an Multiply operator in an Sitecore XPath query.
 | Number | Represents a number value in an Sitecore XPath query.
 | Opcode | Defines the basic functionality of a statement in an Sitecore XPath query.
 | OrOperator | Represents an Or operator in an Sitecore XPath query.
 | Parameter | Represents a Parameter element in an Sitecore XPath query.
 | Parent | Represents the Parent axis in an Sitecore XPath query.
 | ParseException | Represents the exception that is thrown when a an Sitecore XPath expression could not be parse.
 | Preceding | Represents the Preceding axis in an Sitecore XPath query.
 | Predicate | Represents a predicate in an Sitecore XPath query.
 | Query | Represents a Sitecore XPath query.
 | QueryBuilder | Creates opcode objects for an Sitecore XPath query.
 | QueryContext | Represent the current context node of a Sitecore XPath query.
 | QueryParser | Parses a string into an Sitecore XPath query.
 | QueryTokenBuilder | Builds tokens for a Sitecore XPath query.
 | QueryTokenType | Defines IDs for query keywords.
 | QueryUtil | Implements support functions for an Sitecore XPath query.
 | Root | Represents a Root element in an Sitecore XPath query.
 | Self | Represents a Self element in an Sitecore XPath query.
 | SmallerOperator | Represents an Smaller Than operator in an Sitecore XPath query.
 | SmallerOrEqualsOperator | Represents an Smaller Than or Equals operator in an Sitecore XPath query.
 | Step | Defines the basic functionality of a Step in an Sitecore XPath query.
 | Token | Represents a token when parsing an Sitecore XPath query.
 | TokenBuilder | Builds tokens.
 | Tokenizer | Tokenizes a string for use in a Sitecore XPath query.
 | TokenType | Defines IDs for keywords in a Sitecore XPath query.
 | UnequalsOperator | Represents an Unequals operator in an Sitecore XPath query.
 | XorOperator | Represents an XOR operator in an Sitecore XPath query.


AddOperator Class

AddOperator Class
Namespaces ► Sitecore.Data.Query ► AddOperator
Represents an Add operator in an Sitecore XPath query.
Declaration Syntax
C#
public class AddOperator : BinaryOperator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddOperator(Opcode, Opcode) | Creates a new AddOperator instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Object, Object, Boolean%) | Evaluates the expression.
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
 | EvaluateOperands(Object, Object) | Evaluates the expression. (Overrides BinaryOperator.EvaluateOperands(Object, Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression. (Inherited from BinaryOperator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from BinaryOperator.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression. (Inherited from BinaryOperator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | AddOperator


AddOperator Constructor (left, right)

AddOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► AddOperator ► AddOperator(Opcode, Opcode)
Creates a new AddOperator instance.
Declaration Syntax
C#
public AddOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.


Evaluate Method (left, right, handled)

Evaluate Method (left, right, handled)
Namespaces ► Sitecore.Data.Query ► AddOperator ► Evaluate(Object, Object, Boolean%)
Evaluates the expression.
Declaration Syntax
C#
public Object Evaluate(
    Object left,
    Object right,
    out bool handled
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
handled ( Boolean %)
Handled.
Return Value
The result of the evaluation.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► AddOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value


Ancestor Class

Ancestor Class
Namespaces ► Sitecore.Data.Query ► Ancestor
Represents the ancestor axis in an Sitecore XPath expression.
Declaration Syntax
C#
public class Ancestor : Step
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Ancestor(ElementBase) | Creates a new Ancestor instance.
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetContextNode(QueryContext) | Gets the context node.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Predicate | Gets the predicate.
 | Print(HtmlTextWriter) | Prints the expression. (Overrides Step.Print(HtmlTextWriter).)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | Ancestor
 |  |  |  | AncestorOrSelf


Ancestor Constructor (element)

Ancestor Constructor (element)
Namespaces ► Sitecore.Data.Query ► Ancestor ► Ancestor(ElementBase)
Creates a new Ancestor instance.
Declaration Syntax
C#
public Ancestor(
    ElementBase element
)
Parameters
element (ElementBase)
Element.


Evaluate Method (query, contextNode)

Evaluate Method (query, contextNode)
Namespaces ► Sitecore.Data.Query ► Ancestor ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext contextNode
)
Parameters
query (Query)
Query.
contextNode (QueryContext)
Context node.
Return Value
The result of the evaluation.


GetContextNode Method (node)

GetContextNode Method (node)
Namespaces ► Sitecore.Data.Query ► Ancestor ► GetContextNode(QueryContext)
Gets the context node.
Declaration Syntax
C#
protected virtual QueryContext GetContextNode(
    QueryContext node
)
Parameters
node (QueryContext)
Node.
Return Value
The context node.


Name Property

Name Property
Namespaces ► Sitecore.Data.Query ► Ancestor ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Predicate Property

Predicate Property
Namespaces ► Sitecore.Data.Query ► Ancestor ► Predicate
Gets the predicate.
Declaration Syntax
C#
public Predicate Predicate { get; }
Value
The predicate.


Print Method (output)

Print Method (output)
Namespaces ► Sitecore.Data.Query ► Ancestor ► Print(HtmlTextWriter)
Prints the expression.
Declaration Syntax
C#
public override void Print(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
Output.


AncestorOrSelf Class

AncestorOrSelf Class
Namespaces ► Sitecore.Data.Query ► AncestorOrSelf
Represents the ancestor-or-self axis in an Sitecore XPath expression.
Declaration Syntax
C#
public class AncestorOrSelf : Ancestor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AncestorOrSelf(ElementBase) | Creates a new AncestorOrSelf instance.
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from Ancestor.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetContextNode(QueryContext) | Gets the context node. (Overrides Ancestor.GetContextNode(QueryContext).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Ancestor.)
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Predicate | Gets the predicate. (Inherited from Ancestor.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from Ancestor.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | Ancestor
 |  |  |  | AncestorOrSelf


AncestorOrSelf Constructor (element)

AncestorOrSelf Constructor (element)
Namespaces ► Sitecore.Data.Query ► AncestorOrSelf ► AncestorOrSelf(ElementBase)
Creates a new AncestorOrSelf instance.
Declaration Syntax
C#
public AncestorOrSelf(
    ElementBase element
)
Parameters
element (ElementBase)
Element.


GetContextNode Method (node)

GetContextNode Method (node)
Namespaces ► Sitecore.Data.Query ► AncestorOrSelf ► GetContextNode(QueryContext)
Gets the context node.
Declaration Syntax
C#
protected override QueryContext GetContextNode(
    QueryContext node
)
Parameters
node (QueryContext)
Node.
Return Value
The context node.


AndOperator Class

AndOperator Class
Namespaces ► Sitecore.Data.Query ► AndOperator
Represents an And operator in an Sitecore XPath query.
Declaration Syntax
C#
public class AndOperator : BinaryOperator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AndOperator(Opcode, Opcode) | Creates a new AndOperator instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
 | EvaluateOperands(Object, Object) | Evaluates the expression. (Overrides BinaryOperator.EvaluateOperands(Object, Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression. (Inherited from BinaryOperator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from BinaryOperator.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression. (Inherited from BinaryOperator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | AndOperator


AndOperator Constructor (left, right)

AndOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► AndOperator ► AndOperator(Opcode, Opcode)
Creates a new AndOperator instance.
Declaration Syntax
C#
public AndOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► AndOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value
The result of the evaluation.


BinaryOperator Class

BinaryOperator Class
Namespaces ► Sitecore.Data.Query ► BinaryOperator
Defines the basic functionality of binary operators in an Sitecore XPath query.
Declaration Syntax
C#
public abstract class BinaryOperator : Opcode
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BinaryOperator(Opcode, Opcode) | Creates a new BinaryOperator instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | EvaluateOperands(Object, Object) | Evaluates the expression.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Overrides Opcode.Print(HtmlTextWriter).)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | AddOperator
 |  |  | AndOperator
 |  |  | DivideOperator
 |  |  | EqualsOperator
 |  |  | GreaterOperator
 |  |  | GreaterOrEqualsOperator
 |  |  | MinusOperator
 |  |  | ModulusOperator
 |  |  | MultiplyOperator
 |  |  | OrOperator
 |  |  | SmallerOperator
 |  |  | SmallerOrEqualsOperator
 |  |  | UnequalsOperator
 |  |  | XorOperator


BinaryOperator Constructor (left, right)

BinaryOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► BinaryOperator ► BinaryOperator(Opcode, Opcode)
Creates a new BinaryOperator instance.
Declaration Syntax
C#
protected BinaryOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► BinaryOperator ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluation.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► BinaryOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public abstract Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value
The result of the evaluation.


Left Property

Left Property
Namespaces ► Sitecore.Data.Query ► BinaryOperator ► Left
Gets the left expression.
Declaration Syntax
C#
public Opcode Left { get; }
Value
The left.


Print Method (output)

Print Method (output)
Namespaces ► Sitecore.Data.Query ► BinaryOperator ► Print(HtmlTextWriter)
Prints the expression.
Declaration Syntax
C#
public override void Print(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
Output.


Right Property

Right Property
Namespaces ► Sitecore.Data.Query ► BinaryOperator ► Right
Gets the right expression.
Declaration Syntax
C#
public Opcode Right { get; }
Value
The right.


BooleanValue Class

BooleanValue Class
Namespaces ► Sitecore.Data.Query ► BooleanValue
Represents a boolean value in an Sitecore XPath expression.
Declaration Syntax
C#
public class BooleanValue : Opcode
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BooleanValue(Boolean) | Creates a new BooleanValue instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from Opcode.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets a value indicating whether this BooleanValue is value.
Inheritance Hierarchy
Object
 | Opcode
 |  | BooleanValue


BooleanValue Constructor (value)

BooleanValue Constructor (value)
Namespaces ► Sitecore.Data.Query ► BooleanValue ► BooleanValue(Boolean)
Creates a new BooleanValue instance.
Declaration Syntax
C#
public BooleanValue(
    bool value
)
Parameters
value (Boolean)
Value.


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► BooleanValue ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluatation.


Value Property

Value Property
Namespaces ► Sitecore.Data.Query ► BooleanValue ► Value
Gets a value indicating whether this BooleanValue is value.
Declaration Syntax
C#
public bool Value { get; }
Value
true if value; otherwise, false.


Children Class

Children Class
Namespaces ► Sitecore.Data.Query ► Children
Represents a children list in an Sitecore XPath expression.
Declaration Syntax
C#
public class Children : Step
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Children(ElementBase) | Creates a new Children instance.
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Predicate | Gets the predicate.
 | Print(HtmlTextWriter) | Prints the expression. (Overrides Step.Print(HtmlTextWriter).)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | Children


Children Constructor (element)

Children Constructor (element)
Namespaces ► Sitecore.Data.Query ► Children ► Children(ElementBase)
Creates a new Children instance.
Declaration Syntax
C#
public Children(
    ElementBase element
)
Parameters
element (ElementBase)
Element.


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► Children ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluation.


Name Property

Name Property
Namespaces ► Sitecore.Data.Query ► Children ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Predicate Property

Predicate Property
Namespaces ► Sitecore.Data.Query ► Children ► Predicate
Gets the predicate.
Declaration Syntax
C#
public Predicate Predicate { get; }
Value
The predicate.


Print Method (output)

Print Method (output)
Namespaces ► Sitecore.Data.Query ► Children ► Print(HtmlTextWriter)
Prints the expression.
Declaration Syntax
C#
public override void Print(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
Output.


Descendant Class

Descendant Class
Namespaces ► Sitecore.Data.Query ► Descendant
Represents a descendant axis in an Sitecore XPath expression.
Declaration Syntax
C#
public class Descendant : Step
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Descendant(ElementBase) | Creates a new Descendant instance.
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Iterate(Query, QueryContext, Object%) | Iterates the specified query.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Predicate | Gets the predicate.
 | Print(HtmlTextWriter) | Prints the expression. (Overrides Step.Print(HtmlTextWriter).)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | TestNode(Query, QueryContext, Object%) | Tests the node againt the predicate.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | Descendant
 |  |  |  | DescendantOrSelf


Descendant Constructor (element)

Descendant Constructor (element)
Namespaces ► Sitecore.Data.Query ► Descendant ► Descendant(ElementBase)
Creates a new Descendant instance.
Declaration Syntax
C#
public Descendant(
    ElementBase element
)
Parameters
element (ElementBase)
Element.


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► Descendant ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluation.


Iterate Method (query, node, result)

Iterate Method (query, node, result)
Namespaces ► Sitecore.Data.Query ► Descendant ► Iterate(Query, QueryContext, Object%)
Iterates the specified query.
Declaration Syntax
C#
protected void Iterate(
    Query query,
    QueryContext node,
    ref Object result
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
result ( Object %)
Result.


Name Property

Name Property
Namespaces ► Sitecore.Data.Query ► Descendant ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Predicate Property

Predicate Property
Namespaces ► Sitecore.Data.Query ► Descendant ► Predicate
Gets the predicate.
Declaration Syntax
C#
public Predicate Predicate { get; }
Value
The predicate.


Print Method (output)

Print Method (output)
Namespaces ► Sitecore.Data.Query ► Descendant ► Print(HtmlTextWriter)
Prints the expression.
Declaration Syntax
C#
public override void Print(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
Output.


TestNode Method (query, node, result)

TestNode Method (query, node, result)
Namespaces ► Sitecore.Data.Query ► Descendant ► TestNode(Query, QueryContext, Object%)
Tests the node againt the predicate.
Declaration Syntax
C#
protected void TestNode(
    Query query,
    QueryContext node,
    ref Object result
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
result ( Object %)
Result.


DescendantOrSelf Class

DescendantOrSelf Class
Namespaces ► Sitecore.Data.Query ► DescendantOrSelf
Represents a descendant-or-self axis in an Sitecore XPath expression.
Declaration Syntax
C#
public class DescendantOrSelf : Descendant
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DescendantOrSelf(ElementBase) | Creates a new DescendantOrSelf instance.
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Descendant.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Iterate(Query, QueryContext, Object%) | Iterates the specified query. (Inherited from Descendant.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Descendant.)
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Predicate | Gets the predicate. (Inherited from Descendant.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from Descendant.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | TestNode(Query, QueryContext, Object%) | Tests the node againt the predicate. (Inherited from Descendant.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | Descendant
 |  |  |  | DescendantOrSelf


DescendantOrSelf Constructor (element)

DescendantOrSelf Constructor (element)
Namespaces ► Sitecore.Data.Query ► DescendantOrSelf ► DescendantOrSelf(ElementBase)
Creates a new DescendantOrSelf instance.
Declaration Syntax
C#
public DescendantOrSelf(
    ElementBase element
)
Parameters
element (ElementBase)
Element.


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► DescendantOrSelf ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluation.


DivideOperator Class

DivideOperator Class
Namespaces ► Sitecore.Data.Query ► DivideOperator
Represents an Divide operator in an Sitecore XPath query.
Declaration Syntax
C#
public class DivideOperator : BinaryOperator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DivideOperator(Opcode, Opcode) | Creates a new DivideOperator instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
 | EvaluateOperands(Object, Object) | Evaluates the expression. (Overrides BinaryOperator.EvaluateOperands(Object, Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression. (Inherited from BinaryOperator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from BinaryOperator.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression. (Inherited from BinaryOperator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | DivideOperator


DivideOperator Constructor (left, right)

DivideOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► DivideOperator ► DivideOperator(Opcode, Opcode)
Creates a new DivideOperator instance.
Declaration Syntax
C#
public DivideOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► DivideOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value
The result of the evaluation.


ElementBase Class

ElementBase Class
Namespaces ► Sitecore.Data.Query ► ElementBase
Defines the basic functonlity for an Element in an Sitecore XPath query.
Declaration Syntax
C#
public abstract class ElementBase : Step
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementBase(String) | Creates a new ElementBase instance.
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from Opcode.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Print(HtmlTextWriter) | Prints the expression. (Overrides Step.Print(HtmlTextWriter).)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | ElementBase
 |  |  |  | FieldElement
 |  |  |  | ItemElement
 |  |  |  | Parameter


ElementBase Constructor (name)

ElementBase Constructor (name)
Namespaces ► Sitecore.Data.Query ► ElementBase ► ElementBase(String)
Creates a new ElementBase instance.
Declaration Syntax
C#
protected ElementBase(
    string name
)
Parameters
name (String)
Name.


Name Property

Name Property
Namespaces ► Sitecore.Data.Query ► ElementBase ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Print Method (output)

Print Method (output)
Namespaces ► Sitecore.Data.Query ► ElementBase ► Print(HtmlTextWriter)
Prints the expression.
Declaration Syntax
C#
public override void Print(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
Output.


EqualsOperator Class

EqualsOperator Class
Namespaces ► Sitecore.Data.Query ► EqualsOperator
Represents an Equals operator in an Sitecore XPath query.
Declaration Syntax
C#
public class EqualsOperator : BinaryOperator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EqualsOperator(Opcode, Opcode) | Creates a new EqualsOperator instance.
 | Compare(Object, Object, Boolean%) | Compares the specified expressions.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
 | EvaluateOperands(Object, Object) | Evaluates the expression. (Overrides BinaryOperator.EvaluateOperands(Object, Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression. (Inherited from BinaryOperator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from BinaryOperator.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression. (Inherited from BinaryOperator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | EqualsOperator


EqualsOperator Constructor (left, right)

EqualsOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► EqualsOperator ► EqualsOperator(Opcode, Opcode)
Creates a new EqualsOperator instance.
Declaration Syntax
C#
public EqualsOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.


Compare Method (left, right, handled)

Compare Method (left, right, handled)
Namespaces ► Sitecore.Data.Query ► EqualsOperator ► Compare(Object, Object, Boolean%)
Compares the specified expressions.
Declaration Syntax
C#
public static bool Compare(
    Object left,
    Object right,
    out bool handled
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
handled ( Boolean %)
Handled.
Return Value
The compare.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► EqualsOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value
The result of the evaluation.


FieldElement Class

FieldElement Class
Namespaces ► Sitecore.Data.Query ► FieldElement
Represents a field element in an Sitecore XPath expression.
Declaration Syntax
C#
public class FieldElement : ElementBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldElement(String) | Creates a new FieldElement instance.
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from ElementBase.)
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from ElementBase.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | ElementBase
 |  |  |  | FieldElement


FieldElement Constructor (name)

FieldElement Constructor (name)
Namespaces ► Sitecore.Data.Query ► FieldElement ► FieldElement(String)
Creates a new FieldElement instance.
Declaration Syntax
C#
public FieldElement(
    string name
)
Parameters
name (String)
Name.


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► FieldElement ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluation.


Following Class

Following Class
Namespaces ► Sitecore.Data.Query ► Following
Represents a following axis in an Sitecore XPath expression.
Declaration Syntax
C#
public class Following : Step
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Following(ElementBase) | Creates a new Following instance.
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Print(HtmlTextWriter) | Prints the expression. (Overrides Step.Print(HtmlTextWriter).)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | Following


Following Constructor (element)

Following Constructor (element)
Namespaces ► Sitecore.Data.Query ► Following ► Following(ElementBase)
Creates a new Following instance.
Declaration Syntax
C#
public Following(
    ElementBase element
)
Parameters
element (ElementBase)
Element.


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► Following ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluation.


Print Method (output)

Print Method (output)
Namespaces ► Sitecore.Data.Query ► Following ► Print(HtmlTextWriter)
Prints the expression.
Declaration Syntax
C#
public override void Print(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
Output.


Function Class

Function Class
Namespaces ► Sitecore.Data.Query ► Function
Represents a custom function in an Sitecore XPath expression.
Declaration Syntax
C#
public class Function : Opcode
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Function(String) | Creates a new Function instance.
 | Add(Opcode) | Adds an argument.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the function.
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from Opcode.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Function


Function Constructor (name)

Function Constructor (name)
Namespaces ► Sitecore.Data.Query ► Function ► Function(String)
Creates a new Function instance.
Declaration Syntax
C#
public Function(
    string name
)
Parameters
name (String)
Name.


Add Method (argument)

Add Method (argument)
Namespaces ► Sitecore.Data.Query ► Function ► Add(Opcode)
Adds an argument.
Declaration Syntax
C#
public void Add(
    Opcode argument
)
Parameters
argument (Opcode)
Argument.


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► Function ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluation.


Name Property

Name Property
Namespaces ► Sitecore.Data.Query ► Function ► Name
Gets the name of the function.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


FunctionArgs Class

FunctionArgs Class
Namespaces ► Sitecore.Data.Query ► FunctionArgs
Represents the arguments passed to a custom function in an Sitecore XPath expression.
Declaration Syntax
C#
public class FunctionArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FunctionArgs(Query, Function, array<Opcode>[]()[], QueryContext) | Creates a new FunctionArgs instance.
 | Arguments | Arguments.
 | ContextNode | Context node.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Function | The function to be called.
 | FunctionName | The name of the function to be called.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Query | Query.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | FunctionArgs


FunctionArgs Constructor (query, function, arguments, contextNode)

FunctionArgs Constructor (query, function, arguments, contextNode)
Namespaces ► Sitecore.Data.Query ► FunctionArgs ► FunctionArgs(Query, Function, array<Opcode>[]()[], QueryContext)
Creates a new FunctionArgs instance.
Declaration Syntax
C#
public FunctionArgs(
    Query query,
    Function function,
    Opcode[] arguments,
    QueryContext contextNode
)
Parameters
query (Query)
Query.
function (Function)
Function.
arguments (array< Opcode >[]()[])
Arguments.
contextNode (QueryContext)
Context node.


Arguments Property

Arguments Property
Namespaces ► Sitecore.Data.Query ► FunctionArgs ► Arguments
Arguments.
Declaration Syntax
C#
public Opcode[] Arguments { get; set; }
Value
The arguments.


ContextNode Property

ContextNode Property
Namespaces ► Sitecore.Data.Query ► FunctionArgs ► ContextNode
Context node.
Declaration Syntax
C#
public QueryContext ContextNode { get; set; }
Value
The context node.


Function Property

Function Property
Namespaces ► Sitecore.Data.Query ► FunctionArgs ► Function
The function to be called.
Declaration Syntax
C#
public Function Function { get; set; }
Value
The function.


FunctionName Property

FunctionName Property
Namespaces ► Sitecore.Data.Query ► FunctionArgs ► FunctionName
The name of the function to be called.
Declaration Syntax
C#
public string FunctionName { get; set; }
Value
The name of the function.


Query Property

Query Property
Namespaces ► Sitecore.Data.Query ► FunctionArgs ► Query
Query.
Declaration Syntax
C#
public Query Query { get; set; }
Value
The query.


FunctionEventHandler Delegate

FunctionEventHandler Delegate
Namespaces ► Sitecore.Data.Query ► FunctionEventHandler
Represents the method that will be called when a function is invoked in an Sitecore XPath query.
Declaration Syntax
C#
public delegate Object FunctionEventHandler(
    FunctionArgs args
)
Parameters
args (FunctionArgs)
Remarks
When you create a FieldSavedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.


Functions Class

Functions Class
Namespaces ► Sitecore.Data.Query ► Functions
Contains custom functions for use in an Sitecore XPath expression.
Declaration Syntax
C#
public class Functions
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Functions()()() | Initializes a new instance of the Functions class
 | CompareCaseInsensitive(FunctionArgs) | Compares the strings case insensitive.
 | Contains(FunctionArgs) | Determines if a string is contained in another string.
 | Current(FunctionArgs) | Gets the current context node.
 | EndsWith(FunctionArgs) | Determines if a string ends with another string.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FunctionCall(FunctionArgs) | Calls a custom function.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Last(FunctionArgs) | Gets the last child.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Not(FunctionArgs) | Inverts the expression.
 | Number(FunctionArgs) | Converts the specified args to a number.
 | Position(FunctionArgs) | Gets the position index of a node in an expression.
 | StartsWith(FunctionArgs) | Determines if a string begins with another string.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Functions


Functions Constructor

Functions Constructor
Namespaces ► Sitecore.Data.Query ► Functions ► Functions()()()
Initializes a new instance of the Functions class
Declaration Syntax
C#
public Functions()


CompareCaseInsensitive Method (args)

CompareCaseInsensitive Method (args)
Namespaces ► Sitecore.Data.Query ► Functions ► CompareCaseInsensitive(FunctionArgs)
Compares the strings case insensitive.
Declaration Syntax
C#
public static bool CompareCaseInsensitive(
    FunctionArgs args
)
Parameters
args (FunctionArgs)
The arguments.
Return Value
true, if the strings are equal.


Contains Method (args)

Contains Method (args)
Namespaces ► Sitecore.Data.Query ► Functions ► Contains(FunctionArgs)
Determines if a string is contained in another string.
Declaration Syntax
C#
public static bool Contains(
    FunctionArgs args
)
Parameters
args (FunctionArgs)
Arguments.
Return Value
true if [contains] [the specified args]; otherwise, false.


Current Method (args)

Current Method (args)
Namespaces ► Sitecore.Data.Query ► Functions ► Current(FunctionArgs)
Gets the current context node.
Declaration Syntax
C#
public static QueryContext Current(
    FunctionArgs args
)
Parameters
args (FunctionArgs)
Arguments.
Return Value
The current.


EndsWith Method (args)

EndsWith Method (args)
Namespaces ► Sitecore.Data.Query ► Functions ► EndsWith(FunctionArgs)
Determines if a string ends with another string.
Declaration Syntax
C#
public static bool EndsWith(
    FunctionArgs args
)
Parameters
args (FunctionArgs)
Arguments.
Return Value
The with.


FunctionCall Method (args)

FunctionCall Method (args)
Namespaces ► Sitecore.Data.Query ► Functions ► FunctionCall(FunctionArgs)
Calls a custom function.
Declaration Syntax
C#
public static Object FunctionCall(
    FunctionArgs args
)
Parameters
args (FunctionArgs)
Arguments.
Return Value
The call.


Last Method (args)

Last Method (args)
Namespaces ► Sitecore.Data.Query ► Functions ► Last(FunctionArgs)
Gets the last child.
Declaration Syntax
C#
public static int Last(
    FunctionArgs args
)
Parameters
args (FunctionArgs)
Arguments.
Return Value
The last.


Not Method (args)

Not Method (args)
Namespaces ► Sitecore.Data.Query ► Functions ► Not(FunctionArgs)
Inverts the expression.
Declaration Syntax
C#
public static bool Not(
    FunctionArgs args
)
Parameters
args (FunctionArgs)
Arguments.
Return Value
The not.


Number Method (args)

Number Method (args)
Namespaces ► Sitecore.Data.Query ► Functions ► Number(FunctionArgs)
Converts the specified args to a number.
Declaration Syntax
C#
public static int Number(
    FunctionArgs args
)
Parameters
args (FunctionArgs)
The arguments.
Return Value
The number
Exceptions
Exception | Condition
QueryException | QueryException.


Position Method (args)

Position Method (args)
Namespaces ► Sitecore.Data.Query ► Functions ► Position(FunctionArgs)
Gets the position index of a node in an expression.
Declaration Syntax
C#
public static int Position(
    FunctionArgs args
)
Parameters
args (FunctionArgs)
Arguments.
Return Value
The position.


StartsWith Method (args)

StartsWith Method (args)
Namespaces ► Sitecore.Data.Query ► Functions ► StartsWith(FunctionArgs)
Determines if a string begins with another string.
Declaration Syntax
C#
public static bool StartsWith(
    FunctionArgs args
)
Parameters
args (FunctionArgs)
Arguments.
Return Value
The with.


GreaterOperator Class

GreaterOperator Class
Namespaces ► Sitecore.Data.Query ► GreaterOperator
Represents an Greater operator in an Sitecore XPath query.
Declaration Syntax
C#
public class GreaterOperator : BinaryOperator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GreaterOperator(Opcode, Opcode) | Creates a new GreaterOperator instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
 | EvaluateOperands(Object, Object) | Evaluates the expression. (Overrides BinaryOperator.EvaluateOperands(Object, Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression. (Inherited from BinaryOperator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from BinaryOperator.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression. (Inherited from BinaryOperator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | GreaterOperator


GreaterOperator Constructor (left, right)

GreaterOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► GreaterOperator ► GreaterOperator(Opcode, Opcode)
Creates a new GreaterOperator instance.
Declaration Syntax
C#
public GreaterOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► GreaterOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value


GreaterOrEqualsOperator Class

GreaterOrEqualsOperator Class
Namespaces ► Sitecore.Data.Query ► GreaterOrEqualsOperator
Represents an Greater or Equals operator in an Sitecore XPath query.
Declaration Syntax
C#
public class GreaterOrEqualsOperator : BinaryOperator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GreaterOrEqualsOperator(Opcode, Opcode) | Creates a new GreaterOrEqualsOperator instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
 | EvaluateOperands(Object, Object) | Evaluates the expression. (Overrides BinaryOperator.EvaluateOperands(Object, Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression. (Inherited from BinaryOperator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from BinaryOperator.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression. (Inherited from BinaryOperator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | GreaterOrEqualsOperator


GreaterOrEqualsOperator Constructor (left, right)

GreaterOrEqualsOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► GreaterOrEqualsOperator ► GreaterOrEqualsOperator(Opcode, Opcode)
Creates a new GreaterOrEqualsOperator instance.
Declaration Syntax
C#
public GreaterOrEqualsOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left.
right (Opcode)
Right.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► GreaterOrEqualsOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value


IQueryable Interface

IQueryable Interface
Namespaces ► Sitecore.Data.Query ► IQueryable
Defines the basic functionality of an object that can be queried using Sitecore XPath.
Declaration Syntax
C#
public interface IQueryable
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetChildIDs(ID) | Gets the IDs of child nodes.
 | GetFieldValue(ID, String) | Gets a field value.
 | GetName(ID) | Gets the name of a node.
 | GetParentID(ID) | Gets the parent ID of a node.
 | GetQueryContextItem(ID) | Gets the current query context item.


GetChildIDs Method (itemID)

GetChildIDs Method (itemID)
Namespaces ► Sitecore.Data.Query ► IQueryable ► GetChildIDs(ID)
Gets the IDs of child nodes.
Declaration Syntax
C#
ID[] GetChildIDs(
    ID itemID
)
Parameters
itemID (ID)
Item ID.
Return Value
The child I ds.


GetFieldValue Method (itemID, fieldName)

GetFieldValue Method (itemID, fieldName)
Namespaces ► Sitecore.Data.Query ► IQueryable ► GetFieldValue(ID, String)
Gets a field value.
Declaration Syntax
C#
string GetFieldValue(
    ID itemID,
    string fieldName
)
Parameters
itemID (ID)
Item ID.
fieldName (String)
Name of the field.
Return Value
The field value.


GetName Method (itemID)

GetName Method (itemID)
Namespaces ► Sitecore.Data.Query ► IQueryable ► GetName(ID)
Gets the name of a node.
Declaration Syntax
C#
string GetName(
    ID itemID
)
Parameters
itemID (ID)
Item ID.
Return Value
The name.


GetParentID Method (itemID)

GetParentID Method (itemID)
Namespaces ► Sitecore.Data.Query ► IQueryable ► GetParentID(ID)
Gets the parent ID of a node.
Declaration Syntax
C#
ID GetParentID(
    ID itemID
)
Parameters
itemID (ID)
Item ID.
Return Value
The parent ID.


GetQueryContextItem Method (itemID)

GetQueryContextItem Method (itemID)
Namespaces ► Sitecore.Data.Query ► IQueryable ► GetQueryContextItem(ID)
Gets the current query context item.
Declaration Syntax
C#
Item GetQueryContextItem(
    ID itemID
)
Parameters
itemID (ID)
Item ID.
Return Value
The query context item.


ISupportPaths Interface

ISupportPaths Interface
Namespaces ► Sitecore.Data.Query ► ISupportPaths
Marks a class that it supports long item paths.
Declaration Syntax
C#
public interface ISupportPaths


ItemElement Class

ItemElement Class
Namespaces ► Sitecore.Data.Query ► ItemElement
Represents an Item element in an Sitecore XPath query.
Declaration Syntax
C#
public class ItemElement : ElementBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemElement(String, Predicate) | Creates a new ItemElement instance.
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from Opcode.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from ElementBase.)
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Predicate | Gets or sets the predicate.
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from ElementBase.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | ElementBase
 |  |  |  | ItemElement


ItemElement Constructor (name, predicate)

ItemElement Constructor (name, predicate)
Namespaces ► Sitecore.Data.Query ► ItemElement ► ItemElement(String, Predicate)
Creates a new ItemElement instance.
Declaration Syntax
C#
public ItemElement(
    string name,
    Predicate predicate
)
Parameters
name (String)
Name.
predicate (Predicate)
Predicate.


Predicate Property

Predicate Property
Namespaces ► Sitecore.Data.Query ► ItemElement ► Predicate
Gets or sets the predicate.
Declaration Syntax
C#
public Predicate Predicate { get; set; }
Value
The predicate.


Literal Class

Literal Class
Namespaces ► Sitecore.Data.Query ► Literal
Represents a literal text in an Sitecore XPath query.
Declaration Syntax
C#
public class Literal : Opcode
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Literal(String) | Creates a new Literal instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Overrides Opcode.Print(HtmlTextWriter).)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Text | Gets the text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Literal


Literal Constructor (text)

Literal Constructor (text)
Namespaces ► Sitecore.Data.Query ► Literal ► Literal(String)
Creates a new Literal instance.
Declaration Syntax
C#
public Literal(
    string text
)
Parameters
text (String)
Text.


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► Literal ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluation.


Print Method (output)

Print Method (output)
Namespaces ► Sitecore.Data.Query ► Literal ► Print(HtmlTextWriter)
Prints the expression.
Declaration Syntax
C#
public override void Print(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
Output.


Text Property

Text Property
Namespaces ► Sitecore.Data.Query ► Literal ► Text
Gets the text.
Declaration Syntax
C#
public string Text { get; }
Value
The text.


MatchArgs Class

MatchArgs Class
Namespaces ► Sitecore.Data.Query ► MatchArgs
Represents the arguments that are passed when a Match event is raised.
Declaration Syntax
C#
public class MatchArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MatchArgs(QueryContext) | Creates a new MatchArgs instance.
 | Abort | Aborts the current query.
 | ContextNode | Context node.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsMatch | Indicates that a match has been found.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | MatchArgs


MatchArgs Constructor (contextNode)

MatchArgs Constructor (contextNode)
Namespaces ► Sitecore.Data.Query ► MatchArgs ► MatchArgs(QueryContext)
Creates a new MatchArgs instance.
Declaration Syntax
C#
public MatchArgs(
    QueryContext contextNode
)
Parameters
contextNode (QueryContext)
Context node.


Abort Property

Abort Property
Namespaces ► Sitecore.Data.Query ► MatchArgs ► Abort
Aborts the current query.
Declaration Syntax
C#
public bool Abort { get; set; }
Value
true if abort; otherwise, false.


ContextNode Property

ContextNode Property
Namespaces ► Sitecore.Data.Query ► MatchArgs ► ContextNode
Context node.
Declaration Syntax
C#
public QueryContext ContextNode { get; set; }
Value
The context node.


IsMatch Property

IsMatch Property
Namespaces ► Sitecore.Data.Query ► MatchArgs ► IsMatch
Indicates that a match has been found.
Declaration Syntax
C#
public bool IsMatch { get; set; }
Value
true if this instance is match; otherwise, false.


MatchEventHandler Delegate

MatchEventHandler Delegate
Namespaces ► Sitecore.Data.Query ► MatchEventHandler
Represents the method that will be called when a node is tested in a predicate in an Sitecore XPath query.
Declaration Syntax
C#
public delegate void MatchEventHandler(
    MatchArgs args
)
Parameters
args (MatchArgs)
Remarks
When you create a FieldSavedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.


MinusOperator Class

MinusOperator Class
Namespaces ► Sitecore.Data.Query ► MinusOperator
Represents an Minus operator in an Sitecore XPath query.
Declaration Syntax
C#
public class MinusOperator : BinaryOperator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MinusOperator(Opcode, Opcode) | Creates a new MinusOperator instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
 | EvaluateOperands(Object, Object) | Evaluates the expression. (Overrides BinaryOperator.EvaluateOperands(Object, Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression. (Inherited from BinaryOperator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from BinaryOperator.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression. (Inherited from BinaryOperator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | MinusOperator


MinusOperator Constructor (left, right)

MinusOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► MinusOperator ► MinusOperator(Opcode, Opcode)
Creates a new MinusOperator instance.
Declaration Syntax
C#
public MinusOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► MinusOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value


ModulusOperator Class

ModulusOperator Class
Namespaces ► Sitecore.Data.Query ► ModulusOperator
Represents an Modulus operator in an Sitecore XPath query.
Declaration Syntax
C#
public class ModulusOperator : BinaryOperator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ModulusOperator(Opcode, Opcode) | Creates a new ModulusOperator instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
 | EvaluateOperands(Object, Object) | Evaluates the expression. (Overrides BinaryOperator.EvaluateOperands(Object, Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression. (Inherited from BinaryOperator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from BinaryOperator.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression. (Inherited from BinaryOperator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | ModulusOperator


ModulusOperator Constructor (left, right)

ModulusOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► ModulusOperator ► ModulusOperator(Opcode, Opcode)
Creates a new ModulusOperator instance.
Declaration Syntax
C#
public ModulusOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► ModulusOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value


MultiplyOperator Class

MultiplyOperator Class
Namespaces ► Sitecore.Data.Query ► MultiplyOperator
Represents an Multiply operator in an Sitecore XPath query.
Declaration Syntax
C#
public class MultiplyOperator : BinaryOperator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiplyOperator(Opcode, Opcode) | Creates a new MultiplyOperator instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
 | EvaluateOperands(Object, Object) | Evaluates the expression. (Overrides BinaryOperator.EvaluateOperands(Object, Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression. (Inherited from BinaryOperator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from BinaryOperator.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression. (Inherited from BinaryOperator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | MultiplyOperator


MultiplyOperator Constructor (left, right)

MultiplyOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► MultiplyOperator ► MultiplyOperator(Opcode, Opcode)
Creates a new MultiplyOperator instance.
Declaration Syntax
C#
public MultiplyOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► MultiplyOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value


Number Class

Number Class
Namespaces ► Sitecore.Data.Query ► Number
Represents a number value in an Sitecore XPath query.
Declaration Syntax
C#
public class Number : Opcode
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Number(Int32) | Creates a new Number instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Overrides Opcode.Print(HtmlTextWriter).)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets the value.
Inheritance Hierarchy
Object
 | Opcode
 |  | Number


Number Constructor (number)

Number Constructor (number)
Namespaces ► Sitecore.Data.Query ► Number ► Number(Int32)
Creates a new Number instance.
Declaration Syntax
C#
public Number(
    int number
)
Parameters
number (Int32)
Number.


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► Number ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluation.


Print Method (output)

Print Method (output)
Namespaces ► Sitecore.Data.Query ► Number ► Print(HtmlTextWriter)
Prints the expression.
Declaration Syntax
C#
public override void Print(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
Output.


Value Property

Value Property
Namespaces ► Sitecore.Data.Query ► Number ► Value
Gets the value.
Declaration Syntax
C#
public int Value { get; }
Value
The value.


Opcode Class

Opcode Class
Namespaces ► Sitecore.Data.Query ► Opcode
Defines the basic functionality of a statement in an Sitecore XPath query.
Declaration Syntax
C#
public abstract class Opcode
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Opcode()()() | Initializes a new instance of the Opcode class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression.
 | PrintIndent(HtmlTextWriter) | Prints the indentation.
 | PrintLine(HtmlTextWriter, String) | Prints a line of text.
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  | BooleanValue
 |  | Function
 |  | Literal
 |  | Number
 |  | Step


Opcode Constructor

Opcode Constructor
Namespaces ► Sitecore.Data.Query ► Opcode ► Opcode()()()
Initializes a new instance of the Opcode class
Declaration Syntax
C#
protected Opcode()


Evaluate Method (query, contextNode)

Evaluate Method (query, contextNode)
Namespaces ► Sitecore.Data.Query ► Opcode ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public virtual Object Evaluate(
    Query query,
    QueryContext contextNode
)
Parameters
query (Query)
Query.
contextNode (QueryContext)
Context node.
Return Value
The result of the evaluation.


Print Method (output)

Print Method (output)
Namespaces ► Sitecore.Data.Query ► Opcode ► Print(HtmlTextWriter)
Prints the expression.
Declaration Syntax
C#
public virtual void Print(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


PrintIndent Method (output)

PrintIndent Method (output)
Namespaces ► Sitecore.Data.Query ► Opcode ► PrintIndent(HtmlTextWriter)
Prints the indentation.
Declaration Syntax
C#
public void PrintIndent(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
Output.


PrintLine Method (output, text)

PrintLine Method (output, text)
Namespaces ► Sitecore.Data.Query ► Opcode ► PrintLine(HtmlTextWriter, String)
Prints a line of text.
Declaration Syntax
C#
public void PrintLine(
    HtmlTextWriter output,
    string text
)
Parameters
output (HtmlTextWriter)
Output.
text (String)
Text.


Process Method (query, contextNode, predicate, nextStep, result)

Process Method (query, contextNode, predicate, nextStep, result)
Namespaces ► Sitecore.Data.Query ► Opcode ► Process(Query, QueryContext, Predicate, Opcode, Object%)
Processes the specified query.
Declaration Syntax
C#
protected void Process(
    Query query,
    QueryContext contextNode,
    Predicate predicate,
    Opcode nextStep,
    ref Object result
)
Parameters
query (Query)
Query.
contextNode (QueryContext)
Context node.
predicate (Predicate)
Predicate.
nextStep (Opcode)
Next step.
result ( Object %)
Result.


OrOperator Class

OrOperator Class
Namespaces ► Sitecore.Data.Query ► OrOperator
Represents an Or operator in an Sitecore XPath query.
Declaration Syntax
C#
public class OrOperator : BinaryOperator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OrOperator(Opcode, Opcode) | Creates a new OrOperator instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
 | EvaluateOperands(Object, Object) | Evaluates the expression. (Overrides BinaryOperator.EvaluateOperands(Object, Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression. (Inherited from BinaryOperator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from BinaryOperator.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression. (Inherited from BinaryOperator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | OrOperator


OrOperator Constructor (left, right)

OrOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► OrOperator ► OrOperator(Opcode, Opcode)
Creates a new OrOperator instance.
Declaration Syntax
C#
public OrOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► OrOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value


Parameter Class

Parameter Class
Namespaces ► Sitecore.Data.Query ► Parameter
Represents a Parameter element in an Sitecore XPath query.
Declaration Syntax
C#
public class Parameter : ElementBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Parameter(String) | Creates a new Parameter instance.
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from ElementBase.)
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from ElementBase.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | ElementBase
 |  |  |  | Parameter


Parameter Constructor (name)

Parameter Constructor (name)
Namespaces ► Sitecore.Data.Query ► Parameter ► Parameter(String)
Creates a new Parameter instance.
Declaration Syntax
C#
public Parameter(
    string name
)
Parameters
name (String)
Name.


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► Parameter ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluation.


Parent Class

Parent Class
Namespaces ► Sitecore.Data.Query ► Parent
Represents the Parent axis in an Sitecore XPath query.
Declaration Syntax
C#
public class Parent : Step
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Parent()()() | Initializes a new instance of the Parent class
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from Step.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | Parent


Parent Constructor

Parent Constructor
Namespaces ► Sitecore.Data.Query ► Parent ► Parent()()()
Initializes a new instance of the Parent class
Declaration Syntax
C#
public Parent()


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► Parent ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluation.


ParseException Class

ParseException Class
Namespaces ► Sitecore.Data.Query ► ParseException
Represents the exception that is thrown when a an Sitecore XPath expression could not be parse.
Declaration Syntax
C#
[SerializableAttribute]
public class ParseException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ParseException(String) | Creates a new ParseException instance.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | ParseException


ParseException Constructor (message)

ParseException Constructor (message)
Namespaces ► Sitecore.Data.Query ► ParseException ► ParseException(String)
Creates a new ParseException instance.
Declaration Syntax
C#
public ParseException(
    string message
)
Parameters
message (String)
Message.


Preceding Class

Preceding Class
Namespaces ► Sitecore.Data.Query ► Preceding
Represents the Preceding axis in an Sitecore XPath query.
Declaration Syntax
C#
public class Preceding : Step
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Preceding(ElementBase) | Creates a new Preceding instance.
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Print(HtmlTextWriter) | Prints the expression. (Overrides Step.Print(HtmlTextWriter).)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | Preceding


Preceding Constructor (element)

Preceding Constructor (element)
Namespaces ► Sitecore.Data.Query ► Preceding ► Preceding(ElementBase)
Creates a new Preceding instance.
Declaration Syntax
C#
public Preceding(
    ElementBase element
)
Parameters
element (ElementBase)
Element.


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► Preceding ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluation.


Print Method (output)

Print Method (output)
Namespaces ► Sitecore.Data.Query ► Preceding ► Print(HtmlTextWriter)
Prints the expression.
Declaration Syntax
C#
public override void Print(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
Output.


Predicate Class

Predicate Class
Namespaces ► Sitecore.Data.Query ► Predicate
Represents a predicate in an Sitecore XPath query.
Declaration Syntax
C#
public class Predicate : Step
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Predicate(String) | Creates a new Predicate instance.
 | Predicate(Opcode) | Creates a new Predicate instance.
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Current | Gets the current context node.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the predicate. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Expression | Gets the expression.
 | Filter(array<Item>[]()[]) | Filters a list of items and returns the items that fulfill the predicate.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Print(HtmlTextWriter) | Prints the expression. (Overrides Step.Print(HtmlTextWriter).)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Test(Item) | Tests if the specified context node fulfill the predicate.
 | Test(QueryContext) | Tests if the specified context node fulfill the predicate.
 | Test(Query, QueryContext) | Tests if the specified query fulfill the predicate.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | Predicate


Predicate Constructor

Predicate Constructor
Namespaces ► Sitecore.Data.Query ► Predicate ► Predicate()()()
Members
Icon | Member | Description
 | Predicate(String) | Creates a new Predicate instance.
 | Predicate(Opcode) | Creates a new Predicate instance.


Predicate Constructor (expression)

Predicate Constructor (expression)
Namespaces ► Sitecore.Data.Query ► Predicate ► Predicate(Opcode)
Creates a new Predicate instance.
Declaration Syntax
C#
public Predicate(
    Opcode expression
)
Parameters
expression (Opcode)
Expression.


Predicate Constructor (expression)

Predicate Constructor (expression)
Namespaces ► Sitecore.Data.Query ► Predicate ► Predicate(String)
Creates a new Predicate instance.
Declaration Syntax
C#
public Predicate(
    string expression
)
Parameters
expression (String)
Expression.


Current Property

Current Property
Namespaces ► Sitecore.Data.Query ► Predicate ► Current
Gets the current context node.
Declaration Syntax
C#
public QueryContext Current { get; }
Value
The current.


Evaluate Method (query, contextNode)

Evaluate Method (query, contextNode)
Namespaces ► Sitecore.Data.Query ► Predicate ► Evaluate(Query, QueryContext)
Evaluates the predicate.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext contextNode
)
Parameters
query (Query)
Query.
contextNode (QueryContext)
Context node.
Return Value
The result of the evaluation.


Expression Property

Expression Property
Namespaces ► Sitecore.Data.Query ► Predicate ► Expression
Gets the expression.
Declaration Syntax
C#
public Opcode Expression { get; }
Value
The expression.


Filter Method (items)

Filter Method (items)
Namespaces ► Sitecore.Data.Query ► Predicate ► Filter(array<Item>[]()[])
Filters a list of items and returns the items that fulfill the predicate.
Declaration Syntax
C#
public Item[] Filter(
    Item[] items
)
Parameters
items (array< Item >[]()[])
Items.
Return Value
The filter.


Print Method (output)

Print Method (output)
Namespaces ► Sitecore.Data.Query ► Predicate ► Print(HtmlTextWriter)
Prints the expression.
Declaration Syntax
C#
public override void Print(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
Output.


Test Method

Test Method
Namespaces ► Sitecore.Data.Query ► Predicate ► Test()()()
Members
Icon | Member | Description
 | Test(Item) | Tests if the specified context node fulfill the predicate.
 | Test(QueryContext) | Tests if the specified context node fulfill the predicate.
 | Test(Query, QueryContext) | Tests if the specified query fulfill the predicate.


Test Method (contextNode)

Test Method (contextNode)
Namespaces ► Sitecore.Data.Query ► Predicate ► Test(Item)
Tests if the specified context node fulfill the predicate.
Declaration Syntax
C#
public bool Test(
    Item contextNode
)
Parameters
contextNode (Item)
Context node.
Return Value
The test.


Test Method (query, contextNode)

Test Method (query, contextNode)
Namespaces ► Sitecore.Data.Query ► Predicate ► Test(Query, QueryContext)
Tests if the specified query fulfill the predicate.
Declaration Syntax
C#
public bool Test(
    Query query,
    QueryContext contextNode
)
Parameters
query (Query)
Query.
contextNode (QueryContext)
Context node.
Return Value
The test.


Test Method (contextNode)

Test Method (contextNode)
Namespaces ► Sitecore.Data.Query ► Predicate ► Test(QueryContext)
Tests if the specified context node fulfill the predicate.
Declaration Syntax
C#
public bool Test(
    QueryContext contextNode
)
Parameters
contextNode (QueryContext)
Context node.
Return Value
The test.


Query Class

Query Class
Namespaces ► Sitecore.Data.Query ► Query
Represents a Sitecore XPath query.
Declaration Syntax
C#
public class Query
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Query()()() | Creates a new Query instance.
 | Query(String) | Creates a new Query instance.
 | Query(Opcode) | Creates a new Query instance.
 | Abort | Gets or sets a value indicating whether this Query is aborted.
 | Any | Gets or sets a value indicating whether this Query returns when any match is found..
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the query.
 | Execute(Item) | Executes the query with a specified context node.
 | Execute(QueryContext) | Executes the query with a specified context node.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Function |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Match |
 | Max | Gets the max number of items to find.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets or sets the parameters.
 | Print(HtmlTextWriter) | Prints the query execution plan.
 | SelectItems(String) | Selects the items from a database using an Sitecore XPath query.
 | SelectItems(String, Item) | Selects the items from a database using an Sitecore XPath query.
 | SelectItems(String, Database) | Selects the items from a database using an Sitecore XPath query.
 | SelectItems(String, QueryContext, Database) | Selects the items from a database using an Sitecore XPath query.
 | SelectSingleID(String, QueryContext) | Selects a single item ID from a database using an Sitecore XPath query.
 | SelectSingleItem(String) | Selects a single item from a database using an Sitecore XPath query.
 | SelectSingleItem(String, Item) | Selects a single item from a database using an Sitecore XPath query.
 | SelectSingleItem(String, Database) | Selects a single item from a database using an Sitecore XPath query.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Query


Query Constructor

Query Constructor
Namespaces ► Sitecore.Data.Query ► Query ► Query()()()
Members
Icon | Member | Description
 | Query()()() | Creates a new Query instance.
 | Query(String) | Creates a new Query instance.
 | Query(Opcode) | Creates a new Query instance.


Query Constructor

Query Constructor
Namespaces ► Sitecore.Data.Query ► Query ► Query()()()
Creates a new Query instance.
Declaration Syntax
C#
protected Query()


Query Constructor (query)

Query Constructor (query)
Namespaces ► Sitecore.Data.Query ► Query ► Query(Opcode)
Creates a new Query instance.
Declaration Syntax
C#
public Query(
    Opcode query
)
Parameters
query (Opcode)
Query.


Query Constructor (query)

Query Constructor (query)
Namespaces ► Sitecore.Data.Query ► Query ► Query(String)
Creates a new Query instance.
Declaration Syntax
C#
public Query(
    string query
)
Parameters
query (String)
Query.


Abort Property

Abort Property
Namespaces ► Sitecore.Data.Query ► Query ► Abort
Gets or sets a value indicating whether this Query is aborted.
Declaration Syntax
C#
public bool Abort { get; set; }
Value
true if aborted; otherwise, false.


Any Property

Any Property
Namespaces ► Sitecore.Data.Query ► Query ► Any
Gets or sets a value indicating whether this Query returns when any match is found..
Declaration Syntax
C#
public bool Any { get; set; }
Value
true if this Query returns when any match is found.; otherwise, false.


Execute Method

Execute Method
Namespaces ► Sitecore.Data.Query ► Query ► Execute()()()
Members
Icon | Member | Description
 | Execute()()() | Executes the query.
 | Execute(Item) | Executes the query with a specified context node.
 | Execute(QueryContext) | Executes the query with a specified context node.


Execute Method

Execute Method
Namespaces ► Sitecore.Data.Query ► Query ► Execute()()()
Executes the query.
Declaration Syntax
C#
public Object Execute()
Return Value
The execute.


Execute Method (contextNode)

Execute Method (contextNode)
Namespaces ► Sitecore.Data.Query ► Query ► Execute(Item)
Executes the query with a specified context node.
Declaration Syntax
C#
public Object Execute(
    Item contextNode
)
Parameters
contextNode (Item)
Context node.
Return Value
The execute.


Execute Method (contextNode)

Execute Method (contextNode)
Namespaces ► Sitecore.Data.Query ► Query ► Execute(QueryContext)
Executes the query with a specified context node.
Declaration Syntax
C#
public Object Execute(
    QueryContext contextNode
)
Parameters
contextNode (QueryContext)
Context node.
Return Value
The execute.


Function Event

Function Event
Namespaces ► Sitecore.Data.Query ► Query ► Function
Declaration Syntax
C#
public event FunctionEventHandler Function


Match Event

Match Event
Namespaces ► Sitecore.Data.Query ► Query ► Match
Declaration Syntax
C#
public event MatchEventHandler Match


Max Property

Max Property
Namespaces ► Sitecore.Data.Query ► Query ► Max
Gets the max number of items to find.
Declaration Syntax
C#
public int Max { get; set; }
Value
The max.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Data.Query ► Query ► Parameters
Gets or sets the parameters.
Declaration Syntax
C#
public Hashtable Parameters { get; set; }
Value
The parameters.


Print Method (output)

Print Method (output)
Namespaces ► Sitecore.Data.Query ► Query ► Print(HtmlTextWriter)
Prints the query execution plan.
Declaration Syntax
C#
public void Print(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
Output.


SelectItems Method

SelectItems Method
Namespaces ► Sitecore.Data.Query ► Query ► SelectItems()()()
Members
Icon | Member | Description
 | SelectItems(String) | Selects the items from a database using an Sitecore XPath query.
 | SelectItems(String, Item) | Selects the items from a database using an Sitecore XPath query.
 | SelectItems(String, Database) | Selects the items from a database using an Sitecore XPath query.
 | SelectItems(String, QueryContext, Database) | Selects the items from a database using an Sitecore XPath query.


SelectItems Method (query)

SelectItems Method (query)
Namespaces ► Sitecore.Data.Query ► Query ► SelectItems(String)
Selects the items from a database using an Sitecore XPath query.
Declaration Syntax
C#
public static Item[] SelectItems(
    string query
)
Parameters
query (String)
Query.
Return Value
The items.


SelectItems Method (query, database)

SelectItems Method (query, database)
Namespaces ► Sitecore.Data.Query ► Query ► SelectItems(String, Database)
Selects the items from a database using an Sitecore XPath query.
Declaration Syntax
C#
public static Item[] SelectItems(
    string query,
    Database database
)
Parameters
query (String)
Query.
database (Database)
Database.
Return Value
The items.


SelectItems Method (query, contextNode)

SelectItems Method (query, contextNode)
Namespaces ► Sitecore.Data.Query ► Query ► SelectItems(String, Item)
Selects the items from a database using an Sitecore XPath query.
Declaration Syntax
C#
public static Item[] SelectItems(
    string query,
    Item contextNode
)
Parameters
query (String)
Query.
contextNode (Item)
Context node.
Return Value
The items.


SelectItems Method (query, contextNode, database)

SelectItems Method (query, contextNode, database)
Namespaces ► Sitecore.Data.Query ► Query ► SelectItems(String, QueryContext, Database)
Selects the items from a database using an Sitecore XPath query.
Declaration Syntax
C#
public static Item[] SelectItems(
    string query,
    QueryContext contextNode,
    Database database
)
Parameters
query (String)
Query.
contextNode (QueryContext)
Context node.
database (Database)
Database.
Return Value
The items.


SelectSingleID Method (path, queryContext)

SelectSingleID Method (path, queryContext)
Namespaces ► Sitecore.Data.Query ► Query ► SelectSingleID(String, QueryContext)
Selects a single item ID from a database using an Sitecore XPath query.
Declaration Syntax
C#
public static ID SelectSingleID(
    string path,
    QueryContext queryContext
)
Parameters
path (String)
Path.
queryContext (QueryContext)
Query context.
Return Value
The single ID.


SelectSingleItem Method

SelectSingleItem Method
Namespaces ► Sitecore.Data.Query ► Query ► SelectSingleItem()()()
Members
Icon | Member | Description
 | SelectSingleItem(String) | Selects a single item from a database using an Sitecore XPath query.
 | SelectSingleItem(String, Item) | Selects a single item from a database using an Sitecore XPath query.
 | SelectSingleItem(String, Database) | Selects a single item from a database using an Sitecore XPath query.


SelectSingleItem Method (query)

SelectSingleItem Method (query)
Namespaces ► Sitecore.Data.Query ► Query ► SelectSingleItem(String)
Selects a single item from a database using an Sitecore XPath query.
Declaration Syntax
C#
public static Item SelectSingleItem(
    string query
)
Parameters
query (String)
Query.
Return Value
The single item.


SelectSingleItem Method (query, database)

SelectSingleItem Method (query, database)
Namespaces ► Sitecore.Data.Query ► Query ► SelectSingleItem(String, Database)
Selects a single item from a database using an Sitecore XPath query.
Declaration Syntax
C#
public static Item SelectSingleItem(
    string query,
    Database database
)
Parameters
query (String)
Query.
database (Database)
Database.
Return Value
The single item.


SelectSingleItem Method (query, contextNode)

SelectSingleItem Method (query, contextNode)
Namespaces ► Sitecore.Data.Query ► Query ► SelectSingleItem(String, Item)
Selects a single item from a database using an Sitecore XPath query.
Declaration Syntax
C#
public static Item SelectSingleItem(
    string query,
    Item contextNode
)
Parameters
query (String)
Query.
contextNode (Item)
Context node.
Return Value
The single item.


QueryBuilder Class

QueryBuilder Class
Namespaces ► Sitecore.Data.Query ► QueryBuilder
Creates opcode objects for an Sitecore XPath query.
Declaration Syntax
C#
public class QueryBuilder
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | QueryBuilder()()() | Initializes a new instance of the QueryBuilder class
 | Add(Opcode, Opcode) | Gets an Add operator.
 | Ancestor(ElementBase) | Gets an Ancestor axis.
 | AncestorOrSelf(ElementBase) | Gets an Ancestor-or-self axis.
 | And(Opcode, Opcode) | Gets an And operator.
 | BooleanValue(Boolean) | Gets a boolean element.
 | Children(ElementBase) | Gets a Children operator.
 | Descendants(ElementBase) | Gets an Descendants axis.
 | DescendantsOrSelf(ElementBase) | Gets an descendants-or-self axis.
 | Divide(Opcode, Opcode) | Gets a Divide operator.
 | Equals(Opcode, Opcode) | Gets an Equals operator.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldElement(String) | Gets a Field value.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Following(ElementBase) | Gets a Following axis.
 | Function(String) | Gets a Function statement.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Greater(Opcode, Opcode) | Gets a Greater Than operator.
 | GreaterOrEquals(Opcode, Opcode) | Gets a Greater Than or Equals operator.
 | ItemElement(String, Predicate) | Gets an Item element.
 | Literal(String) | Gets a Literal element.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Minus(Opcode, Opcode) | Gets a Minus operator.
 | Modulus(Opcode, Opcode) | Gets a Modulus operator.
 | Multiply(Opcode, Opcode) | Gets a Multiply operator.
 | Number(Int32) | Gets a Number element.
 | Or(Opcode, Opcode) | Gets an Or operator.
 | Parent()()() | Gets a Parent axis.
 | Preceding(ElementBase) | Gets a Preceeding axis.
 | Predicate(Opcode) | Gets a predicate.
 | QueryParameter(String) | Gets a Query parameter object.
 | Root()()() | Gets a Root element.
 | Self(Predicate) | Gets a Self element axis.
 | Smaller(Opcode, Opcode) | Gets a Smaller Than operator.
 | SmallerOrEquals(Opcode, Opcode) | Gets a Smaller Than or Equals operator.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unequals(Opcode, Opcode) | Gets a Unequals operator.
 | Xor(Opcode, Opcode) | Gets a Xor operator.
Inheritance Hierarchy
Object
QueryBuilder


QueryBuilder Constructor

QueryBuilder Constructor
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► QueryBuilder()()()
Initializes a new instance of the QueryBuilder class
Declaration Syntax
C#
public QueryBuilder()


Add Method (left, right)

Add Method (left, right)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Add(Opcode, Opcode)
Gets an Add operator.
Declaration Syntax
C#
public Opcode Add(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.
Return Value
The add.


Ancestor Method (element)

Ancestor Method (element)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Ancestor(ElementBase)
Gets an Ancestor axis.
Declaration Syntax
C#
public Step Ancestor(
    ElementBase element
)
Parameters
element (ElementBase)
Element.
Return Value
The ancestor.


AncestorOrSelf Method (element)

AncestorOrSelf Method (element)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► AncestorOrSelf(ElementBase)
Gets an Ancestor-or-self axis.
Declaration Syntax
C#
public Step AncestorOrSelf(
    ElementBase element
)
Parameters
element (ElementBase)
Element.
Return Value
The or self.


And Method (left, right)

And Method (left, right)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► And(Opcode, Opcode)
Gets an And operator.
Declaration Syntax
C#
public Opcode And(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.
Return Value
The and.


BooleanValue Method (value)

BooleanValue Method (value)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► BooleanValue(Boolean)
Gets a boolean element.
Declaration Syntax
C#
public Opcode BooleanValue(
    bool value
)
Parameters
value (Boolean)
Value.
Return Value
The value.


Children Method (element)

Children Method (element)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Children(ElementBase)
Gets a Children operator.
Declaration Syntax
C#
public Step Children(
    ElementBase element
)
Parameters
element (ElementBase)
Element.
Return Value
The children.


Descendants Method (element)

Descendants Method (element)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Descendants(ElementBase)
Gets an Descendants axis.
Declaration Syntax
C#
public Step Descendants(
    ElementBase element
)
Parameters
element (ElementBase)
Element.
Return Value
The descendants.


DescendantsOrSelf Method (element)

DescendantsOrSelf Method (element)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► DescendantsOrSelf(ElementBase)
Gets an descendants-or-self axis.
Declaration Syntax
C#
public Step DescendantsOrSelf(
    ElementBase element
)
Parameters
element (ElementBase)
Element.
Return Value
The or self.


Divide Method (left, right)

Divide Method (left, right)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Divide(Opcode, Opcode)
Gets a Divide operator.
Declaration Syntax
C#
public Opcode Divide(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.
Return Value
The divide.


Equals Method (left, right)

Equals Method (left, right)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Equals(Opcode, Opcode)
Gets an Equals operator.
Declaration Syntax
C#
public Opcode Equals(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.
Return Value
The equals.


FieldElement Method (name)

FieldElement Method (name)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► FieldElement(String)
Gets a Field value.
Declaration Syntax
C#
public FieldElement FieldElement(
    string name
)
Parameters
name (String)
Name.
Return Value
The element.


Following Method (element)

Following Method (element)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Following(ElementBase)
Gets a Following axis.
Declaration Syntax
C#
public Step Following(
    ElementBase element
)
Parameters
element (ElementBase)
Element.
Return Value
The following.


Function Method (name)

Function Method (name)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Function(String)
Gets a Function statement.
Declaration Syntax
C#
public Function Function(
    string name
)
Parameters
name (String)
Name.
Return Value
The function.


Greater Method (left, right)

Greater Method (left, right)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Greater(Opcode, Opcode)
Gets a Greater Than operator.
Declaration Syntax
C#
public Opcode Greater(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.
Return Value
The greater.


GreaterOrEquals Method (left, right)

GreaterOrEquals Method (left, right)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► GreaterOrEquals(Opcode, Opcode)
Gets a Greater Than or Equals operator.
Declaration Syntax
C#
public Opcode GreaterOrEquals(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.
Return Value
The or equals.


ItemElement Method (name, predicate)

ItemElement Method (name, predicate)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► ItemElement(String, Predicate)
Gets an Item element.
Declaration Syntax
C#
public ItemElement ItemElement(
    string name,
    Predicate predicate
)
Parameters
name (String)
Name.
predicate (Predicate)
Predicate.
Return Value
The element.


Literal Method (text)

Literal Method (text)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Literal(String)
Gets a Literal element.
Declaration Syntax
C#
public Opcode Literal(
    string text
)
Parameters
text (String)
Text.
Return Value
The literal.


Minus Method (left, right)

Minus Method (left, right)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Minus(Opcode, Opcode)
Gets a Minus operator.
Declaration Syntax
C#
public Opcode Minus(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.
Return Value
The minus.


Modulus Method (left, right)

Modulus Method (left, right)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Modulus(Opcode, Opcode)
Gets a Modulus operator.
Declaration Syntax
C#
public Opcode Modulus(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.
Return Value
The modulus.


Multiply Method (left, right)

Multiply Method (left, right)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Multiply(Opcode, Opcode)
Gets a Multiply operator.
Declaration Syntax
C#
public Opcode Multiply(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.
Return Value
The multiply.


Number Method (value)

Number Method (value)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Number(Int32)
Gets a Number element.
Declaration Syntax
C#
public Opcode Number(
    int value
)
Parameters
value (Int32)
Value.
Return Value
The number.


Or Method (left, right)

Or Method (left, right)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Or(Opcode, Opcode)
Gets an Or operator.
Declaration Syntax
C#
public Opcode Or(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.
Return Value
The or.


Parent Method

Parent Method
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Parent()()()
Gets a Parent axis.
Declaration Syntax
C#
public Step Parent()
Return Value
The parent.


Preceding Method (element)

Preceding Method (element)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Preceding(ElementBase)
Gets a Preceeding axis.
Declaration Syntax
C#
public Step Preceding(
    ElementBase element
)
Parameters
element (ElementBase)
Element.
Return Value
The preceding.


Predicate Method (expression)

Predicate Method (expression)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Predicate(Opcode)
Gets a predicate.
Declaration Syntax
C#
public Predicate Predicate(
    Opcode expression
)
Parameters
expression (Opcode)
Expression.
Return Value
The predicate.


QueryParameter Method (name)

QueryParameter Method (name)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► QueryParameter(String)
Gets a Query parameter object.
Declaration Syntax
C#
public Parameter QueryParameter(
    string name
)
Parameters
name (String)
Name.
Return Value
The parameter.


Root Method

Root Method
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Root()()()
Gets a Root element.
Declaration Syntax
C#
public Step Root()
Return Value
The root.


Self Method (predicate)

Self Method (predicate)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Self(Predicate)
Gets a Self element axis.
Declaration Syntax
C#
public Step Self(
    Predicate predicate
)
Parameters
predicate (Predicate)
Predicate.
Return Value
The self.


Smaller Method (left, right)

Smaller Method (left, right)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Smaller(Opcode, Opcode)
Gets a Smaller Than operator.
Declaration Syntax
C#
public Opcode Smaller(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.
Return Value
The smaller.


SmallerOrEquals Method (left, right)

SmallerOrEquals Method (left, right)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► SmallerOrEquals(Opcode, Opcode)
Gets a Smaller Than or Equals operator.
Declaration Syntax
C#
public Opcode SmallerOrEquals(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.
Return Value
The or equals.


Unequals Method (left, right)

Unequals Method (left, right)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Unequals(Opcode, Opcode)
Gets a Unequals operator.
Declaration Syntax
C#
public Opcode Unequals(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.
Return Value
The unequals.


Xor Method (left, right)

Xor Method (left, right)
Namespaces ► Sitecore.Data.Query ► QueryBuilder ► Xor(Opcode, Opcode)
Gets a Xor operator.
Declaration Syntax
C#
public Opcode Xor(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.
Return Value
The xor.


QueryContext Class

QueryContext Class
Namespaces ► Sitecore.Data.Query ► QueryContext
Represent the current context node of a Sitecore XPath query.
Declaration Syntax
C#
public class QueryContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QueryContext(IQueryable) | Creates a new QueryContext instance.
 | QueryContext(IQueryable, ID) | Creates a new QueryContext instance.
 | Children | Gets the children.
 | DocumentElement | Gets a value indicating whether this node is the document element.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetQueryContextItem()()() | Gets the query context item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the ID.
 | Item[([(String])]) | Gets the field value with the specified name.
 | Matches(String) | Tests if the name of the item matches a specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Parent | Gets the parent.
 | Queryable | Gets the source object that this node represents.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
QueryContext


QueryContext Constructor

QueryContext Constructor
Namespaces ► Sitecore.Data.Query ► QueryContext ► QueryContext()()()
Members
Icon | Member | Description
 | QueryContext(IQueryable) | Creates a new QueryContext instance.
 | QueryContext(IQueryable, ID) | Creates a new QueryContext instance.


QueryContext Constructor (queryable)

QueryContext Constructor (queryable)
Namespaces ► Sitecore.Data.Query ► QueryContext ► QueryContext(IQueryable)
Creates a new QueryContext instance.
Declaration Syntax
C#
public QueryContext(
    IQueryable queryable
)
Parameters
queryable (IQueryable)
Queryable.


QueryContext Constructor (queryable, id)

QueryContext Constructor (queryable, id)
Namespaces ► Sitecore.Data.Query ► QueryContext ► QueryContext(IQueryable, ID)
Creates a new QueryContext instance.
Declaration Syntax
C#
public QueryContext(
    IQueryable queryable,
    ID id
)
Parameters
queryable (IQueryable)
Queryable.
id (ID)
Id.


Children Property

Children Property
Namespaces ► Sitecore.Data.Query ► QueryContext ► Children
Gets the children.
Declaration Syntax
C#
public QueryContext[] Children { get; }
Value
The children.


DocumentElement Property

DocumentElement Property
Namespaces ► Sitecore.Data.Query ► QueryContext ► DocumentElement
Gets a value indicating whether this node is the document element.
Declaration Syntax
C#
public bool DocumentElement { get; }
Value
true if this node is the document element; otherwise, false.


GetQueryContextItem Method

GetQueryContextItem Method
Namespaces ► Sitecore.Data.Query ► QueryContext ► GetQueryContextItem()()()
Gets the query context item.
Declaration Syntax
C#
public Item GetQueryContextItem()
Return Value
The query context item.


ID Property

ID Property
Namespaces ► Sitecore.Data.Query ► QueryContext ► ID
Gets the ID.
Declaration Syntax
C#
public ID ID { get; }
Value
The ID.


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Data.Query ► QueryContext ► Item[([(String])])
Gets the field value with the specified name.
Declaration Syntax
C#
public string this[
    string name
] { get; }
Parameters
name (String)


Matches Method (name)

Matches Method (name)
Namespaces ► Sitecore.Data.Query ► QueryContext ► Matches(String)
Tests if the name of the item matches a specified name.
Declaration Syntax
C#
public bool Matches(
    string name
)
Parameters
name (String)
Name.
Return Value
The matches.


Name Property

Name Property
Namespaces ► Sitecore.Data.Query ► QueryContext ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Parent Property

Parent Property
Namespaces ► Sitecore.Data.Query ► QueryContext ► Parent
Gets the parent.
Declaration Syntax
C#
public QueryContext Parent { get; }
Value
The parent.


Queryable Property

Queryable Property
Namespaces ► Sitecore.Data.Query ► QueryContext ► Queryable
Gets the source object that this node represents.
Declaration Syntax
C#
public IQueryable Queryable { get; }
Value
The queryable.
Remarks
This is usually an Item.


QueryParser Class

QueryParser Class
Namespaces ► Sitecore.Data.Query ► QueryParser
Parses a string into an Sitecore XPath query.
Declaration Syntax
C#
public class QueryParser
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | QueryParser()()() | Initializes a new instance of the QueryParser class
 | DoParse(String) | Performs the parsing.
 | DoParsePredicate(String) | Performs the parsing.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAncestorAxis()()() | Gets the ancestor axis.
 | GetAttribute()()() | Gets the attribute.
 | GetChildAxis()()() | Gets the child axis.
 | GetChildren()()() | Gets the children.
 | GetDescendants()()() | Gets the descendants.
 | GetDescendantsAxis()()() | Gets the descendants axis.
 | GetDotDot()()() | Gets the dot dot.
 | GetElement()()() | Gets the element.
 | GetExpression()()() | Gets the expression.
 | GetFactor()()() | Gets the factor.
 | GetFollowingAxis()()() | Gets the following axis.
 | GetFunction()()() | Gets the function.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNode()()() | Gets the node.
 | GetParameter()()() | Gets the parameter.
 | GetParentAxis()()() | Gets the parent axis.
 | GetPathStep()()() | Gets the path step.
 | GetPrecedingAxis()()() | Gets the preceding axis.
 | GetPredicate()()() | Gets the predicate.
 | GetQueries()()() | Gets the queries.
 | GetQuery()()() | Gets the query.
 | GetSelf()()() | Gets the self.
 | GetSelfAxis()()() | Gets the self axis.
 | GetTerm0()()() | Gets the term0.
 | GetTerm1()()() | Gets the term1.
 | GetTerm2()()() | Gets the term2.
 | GetTerm3()()() | Gets the term3.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Match()()() | Matches this instance.
 | Match(Int32, String) | Matches the specified type.
 | MatchCheck(Int32, String) | Matches the check.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Parses the specified query.
 | ParsePredicate(String) | Parses a predicate.
 | Peek()()() | Peeks this instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Queries = Query | ( Queries "|" Query )
Query = PathStep ( PathStep )*
PathStep = Node | Children | Descendants
Children = "/" Node
Descendants = "//" Node
Node = Attribute | Element
Attribute = "@" Name
Element = [ Axis ] ( "*" | "." | ".." | Name ) [ Predicate ]
Name = Identifier | Name Identifier
Axis = ( "ancestor" | "ancestor-or-self" | "descendants" | "descendants-or-self" |
       "child" | "parent" | "following" | "preceding" | "self" ) "::"
Predicate = "[" Expression "]"
Expression = Term3 [ ( "or" | "xor" ) Term3 ]
Term3 = Term2 [ "and" Term2 ]
Term2 = Term1 [ ( "=" | ">" | ">=" | "<" | "<=" | "!=" ) Term1 ]
Term1 = Term0 [ ( "+" | "-" ) Term0 ]
Term0 = Factor [ ( "*" | "div" | "mod" ) Factor ]
Factor = Queries | Literal | Number | True | False | "(" Expression ")" |
         Attribute | Function | Parameter
Parameter = "$" Identifier
Function = Identifier "(" ExpressionList ")"
ExpressionList = Expression | ( ExpressionList "," Expression )
Inheritance Hierarchy
Object
QueryParser


QueryParser Constructor

QueryParser Constructor
Namespaces ► Sitecore.Data.Query ► QueryParser ► QueryParser()()()
Initializes a new instance of the QueryParser class
Declaration Syntax
C#
public QueryParser()


DoParse Method (query)

DoParse Method (query)
Namespaces ► Sitecore.Data.Query ► QueryParser ► DoParse(String)
Performs the parsing.
Declaration Syntax
C#
protected virtual Opcode DoParse(
    string query
)
Parameters
query (String)
Query.
Return Value
The Opcode.


DoParsePredicate Method (query)

DoParsePredicate Method (query)
Namespaces ► Sitecore.Data.Query ► QueryParser ► DoParsePredicate(String)
Performs the parsing.
Declaration Syntax
C#
protected virtual Opcode DoParsePredicate(
    string query
)
Parameters
query (String)
Query.
Return Value
The Opcode.


GetAncestorAxis Method

GetAncestorAxis Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetAncestorAxis()()()
Gets the ancestor axis.
Declaration Syntax
C#
protected Step GetAncestorAxis()
Return Value
The ancestor axis.


GetAttribute Method

GetAttribute Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetAttribute()()()
Gets the attribute.
Declaration Syntax
C#
protected ElementBase GetAttribute()
Return Value
The attribute.


GetChildAxis Method

GetChildAxis Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetChildAxis()()()
Gets the child axis.
Declaration Syntax
C#
protected Step GetChildAxis()
Return Value
The child axis.


GetChildren Method

GetChildren Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetChildren()()()
Gets the children.
Declaration Syntax
C#
protected Step GetChildren()
Return Value
The children.


GetDescendants Method

GetDescendants Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetDescendants()()()
Gets the descendants.
Declaration Syntax
C#
protected Step GetDescendants()
Return Value
The descendants.


GetDescendantsAxis Method

GetDescendantsAxis Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetDescendantsAxis()()()
Gets the descendants axis.
Declaration Syntax
C#
protected Step GetDescendantsAxis()
Return Value
The descendants axis.


GetDotDot Method

GetDotDot Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetDotDot()()()
Gets the dot dot.
Declaration Syntax
C#
protected Step GetDotDot()
Return Value
The dot dot.


GetElement Method

GetElement Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetElement()()()
Gets the element.
Declaration Syntax
C#
protected ElementBase GetElement()
Return Value
The element.


GetExpression Method

GetExpression Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetExpression()()()
Gets the expression.
Declaration Syntax
C#
protected Opcode GetExpression()
Return Value
The expression.


GetFactor Method

GetFactor Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetFactor()()()
Gets the factor.
Declaration Syntax
C#
protected Opcode GetFactor()
Return Value
The factor.


GetFollowingAxis Method

GetFollowingAxis Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetFollowingAxis()()()
Gets the following axis.
Declaration Syntax
C#
protected Step GetFollowingAxis()
Return Value
The following axis.


GetFunction Method

GetFunction Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetFunction()()()
Gets the function.
Declaration Syntax
C#
protected Opcode GetFunction()
Return Value
The function.


GetNode Method

GetNode Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetNode()()()
Gets the node.
Declaration Syntax
C#
protected Object GetNode()
Return Value
The node.


GetParameter Method

GetParameter Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetParameter()()()
Gets the parameter.
Declaration Syntax
C#
protected ElementBase GetParameter()
Return Value
The parameter.


GetParentAxis Method

GetParentAxis Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetParentAxis()()()
Gets the parent axis.
Declaration Syntax
C#
protected Step GetParentAxis()
Return Value
The parent axis.


GetPathStep Method

GetPathStep Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetPathStep()()()
Gets the path step.
Declaration Syntax
C#
protected Step GetPathStep()
Return Value
The path step.


GetPrecedingAxis Method

GetPrecedingAxis Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetPrecedingAxis()()()
Gets the preceding axis.
Declaration Syntax
C#
protected Step GetPrecedingAxis()
Return Value
The preceding axis.


GetPredicate Method

GetPredicate Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetPredicate()()()
Gets the predicate.
Declaration Syntax
C#
protected Predicate GetPredicate()
Return Value
The predicate.


GetQueries Method

GetQueries Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetQueries()()()
Gets the queries.
Declaration Syntax
C#
protected Opcode GetQueries()
Return Value
The queries.


GetQuery Method

GetQuery Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetQuery()()()
Gets the query.
Declaration Syntax
C#
protected Opcode GetQuery()
Return Value
The query.


GetSelf Method

GetSelf Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetSelf()()()
Gets the self.
Declaration Syntax
C#
protected Step GetSelf()
Return Value
The self.


GetSelfAxis Method

GetSelfAxis Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetSelfAxis()()()
Gets the self axis.
Declaration Syntax
C#
protected Step GetSelfAxis()
Return Value
The self axis.


GetTerm0 Method

GetTerm0 Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetTerm0()()()
Gets the term0.
Declaration Syntax
C#
protected Opcode GetTerm0()
Return Value
The term0.


GetTerm1 Method

GetTerm1 Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetTerm1()()()
Gets the term1.
Declaration Syntax
C#
protected Opcode GetTerm1()
Return Value
The term1.


GetTerm2 Method

GetTerm2 Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetTerm2()()()
Gets the term2.
Declaration Syntax
C#
protected Opcode GetTerm2()
Return Value
The term2.


GetTerm3 Method

GetTerm3 Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► GetTerm3()()()
Gets the term3.
Declaration Syntax
C#
protected Opcode GetTerm3()
Return Value
The term3.


Match Method

Match Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► Match()()()
Members
Icon | Member | Description
 | Match()()() | Matches this instance.
 | Match(Int32, String) | Matches the specified type.


Match Method

Match Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► Match()()()
Matches this instance.
Declaration Syntax
C#
protected void Match()


Match Method (type, error)

Match Method (type, error)
Namespaces ► Sitecore.Data.Query ► QueryParser ► Match(Int32, String)
Matches the specified type.
Declaration Syntax
C#
protected void Match(
    int type,
    string error
)
Parameters
type (Int32)
The type.
error (String)
The error.


MatchCheck Method (type, error)

MatchCheck Method (type, error)
Namespaces ► Sitecore.Data.Query ► QueryParser ► MatchCheck(Int32, String)
Matches the check.
Declaration Syntax
C#
protected void MatchCheck(
    int type,
    string error
)
Parameters
type (Int32)
The type.
error (String)
The error.


Parse Method (query)

Parse Method (query)
Namespaces ► Sitecore.Data.Query ► QueryParser ► Parse(String)
Parses the specified query.
Declaration Syntax
C#
public static Opcode Parse(
    string query
)
Parameters
query (String)
Query.
Return Value
The parse.


ParsePredicate Method (query)

ParsePredicate Method (query)
Namespaces ► Sitecore.Data.Query ► QueryParser ► ParsePredicate(String)
Parses a predicate.
Declaration Syntax
C#
public static Opcode ParsePredicate(
    string query
)
Parameters
query (String)
Query.
Return Value
The predicate.


Peek Method

Peek Method
Namespaces ► Sitecore.Data.Query ► QueryParser ► Peek()()()
Peeks this instance.
Declaration Syntax
C#
protected int Peek()
Return Value
The peek.


QueryTokenBuilder Class

QueryTokenBuilder Class
Namespaces ► Sitecore.Data.Query ► QueryTokenBuilder
Builds tokens for a Sitecore XPath query.
Declaration Syntax
C#
public class QueryTokenBuilder : TokenBuilder
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QueryTokenBuilder()()() | Initializes a new instance of the QueryTokenBuilder class
 | At()()() | At. (Inherited from TokenBuilder.)
 | Axis()()() | Axis. (Inherited from TokenBuilder.)
 | Comma()()() | Comma. (Inherited from TokenBuilder.)
 | Dollar()()() | Dollar. (Inherited from TokenBuilder.)
 | Dot()()() | Dot. (Inherited from TokenBuilder.)
 | DotDot()()() | Dot dot. (Inherited from TokenBuilder.)
 | DoubleSlash()()() | Double slash. (Inherited from TokenBuilder.)
 | End()()() | End. (Inherited from TokenBuilder.)
 | EndParentes()()() | End parentes. (Inherited from TokenBuilder.)
 | EndSquareBracket()()() | End square bracket. (Inherited from TokenBuilder.)
 | Equals()()() | Equal. (Inherited from TokenBuilder.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Greater()()() | Greater. (Inherited from TokenBuilder.)
 | GreaterOrEquals()()() | Greater or equals. (Inherited from TokenBuilder.)
 | Guid(String) | GUID. (Inherited from TokenBuilder.)
 | Identifier(String) | Maps an identifier to a keyword. (Overrides TokenBuilder.Identifier(String).)
 | Literal(String) | Literal. (Inherited from TokenBuilder.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Minus()()() | Minus. (Inherited from TokenBuilder.)
 | Namespace()()() | Namespace. (Inherited from TokenBuilder.)
 | Number(Int32) | Number. (Inherited from TokenBuilder.)
 | Pipe()()() | Pipe. (Inherited from TokenBuilder.)
 | Plus()()() | Plus. (Inherited from TokenBuilder.)
 | Slash()()() | Slash. (Inherited from TokenBuilder.)
 | Smaller()()() | Smaller. (Inherited from TokenBuilder.)
 | SmallerOrEquals()()() | Smaller or equal. (Inherited from TokenBuilder.)
 | Star()()() | Star. (Inherited from TokenBuilder.)
 | StartParentes()()() | Start parentes. (Inherited from TokenBuilder.)
 | StartSquareBracket()()() | Start square bracket. (Inherited from TokenBuilder.)
 | Token | The current token. (Inherited from TokenBuilder.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unequals()()() | Unequal. (Inherited from TokenBuilder.)
Inheritance Hierarchy
Object
 | TokenBuilder
 |  | QueryTokenBuilder


QueryTokenBuilder Constructor

QueryTokenBuilder Constructor
Namespaces ► Sitecore.Data.Query ► QueryTokenBuilder ► QueryTokenBuilder()()()
Initializes a new instance of the QueryTokenBuilder class
Declaration Syntax
C#
public QueryTokenBuilder()


Identifier Method (value)

Identifier Method (value)
Namespaces ► Sitecore.Data.Query ► QueryTokenBuilder ► Identifier(String)
Maps an identifier to a keyword.
Declaration Syntax
C#
public override void Identifier(
    string value
)
Parameters
value (String)
Identifier.


QueryTokenType Class

QueryTokenType Class
Namespaces ► Sitecore.Data.Query ► QueryTokenType
Defines IDs for query keywords.
Declaration Syntax
C#
public class QueryTokenType : TokenType
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QueryTokenType()()() | Initializes a new instance of the QueryTokenType class
 | Ancestor | Ancestor
 | And | And
 | Child | Child
 | Descendant | Descandant
 | Div | Div
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | False | False
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Following | Following
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Mod | Modulus
 | Or | Or
 | Parent | Parent
 | Preceding | Preceding
 | Self | Self
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | True | True
 | Xor | Xor
Inheritance Hierarchy
Object
 | TokenType
 |  | QueryTokenType


QueryTokenType Constructor

QueryTokenType Constructor
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► QueryTokenType()()()
Initializes a new instance of the QueryTokenType class
Declaration Syntax
C#
public QueryTokenType()


Ancestor Field

Ancestor Field
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► Ancestor
Ancestor
Declaration Syntax
C#
public const int Ancestor


And Field

And Field
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► And
And
Declaration Syntax
C#
public const int And


Child Field

Child Field
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► Child
Child
Declaration Syntax
C#
public const int Child


Descendant Field

Descendant Field
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► Descendant
Descandant
Declaration Syntax
C#
public const int Descendant


Div Field

Div Field
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► Div
Div
Declaration Syntax
C#
public const int Div


False Field

False Field
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► False
False
Declaration Syntax
C#
public const int False


Following Field

Following Field
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► Following
Following
Declaration Syntax
C#
public const int Following


Mod Field

Mod Field
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► Mod
Modulus
Declaration Syntax
C#
public const int Mod


Or Field

Or Field
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► Or
Or
Declaration Syntax
C#
public const int Or


Parent Field

Parent Field
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► Parent
Parent
Declaration Syntax
C#
public const int Parent


Preceding Field

Preceding Field
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► Preceding
Preceding
Declaration Syntax
C#
public const int Preceding


Self Field

Self Field
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► Self
Self
Declaration Syntax
C#
public const int Self


True Field

True Field
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► True
True
Declaration Syntax
C#
public const int True


Xor Field

Xor Field
Namespaces ► Sitecore.Data.Query ► QueryTokenType ► Xor
Xor
Declaration Syntax
C#
public const int Xor


QueryUtil Class

QueryUtil Class
Namespaces ► Sitecore.Data.Query ► QueryUtil
Implements support functions for an Sitecore XPath query.
Declaration Syntax
C#
public static class QueryUtil
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CanResolve(Object, DataUri) | Determines whether an object can be resolved.
 | IsQueryPath(String) | Determines whether if a string is a query path.
Inheritance Hierarchy
Object
QueryUtil


CanResolve Method (obj, uri)

CanResolve Method (obj, uri)
Namespaces ► Sitecore.Data.Query ► QueryUtil ► CanResolve(Object, DataUri)
Determines whether an object can be resolved.
Declaration Syntax
C#
public static bool CanResolve(
    Object obj,
    DataUri uri
)
Parameters
obj (Object)
Obj.
uri (DataUri)
URI.
Return Value
true if an object can be resolved; otherwise, false.


IsQueryPath Method (path)

IsQueryPath Method (path)
Namespaces ► Sitecore.Data.Query ► QueryUtil ► IsQueryPath(String)
Determines whether if a string is a query path.
Declaration Syntax
C#
public static bool IsQueryPath(
    string path
)
Parameters
path (String)
Path.
Return Value
true if a string is a query path; otherwise, false.
Remarks
A query path is defined by containing either a "[" or a "::" string.


Root Class

Root Class
Namespaces ► Sitecore.Data.Query ► Root
Represents a Root element in an Sitecore XPath query.
Declaration Syntax
C#
public class Root : Step
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Root()()() | Initializes a new instance of the Root class
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from Step.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | Root


Root Constructor

Root Constructor
Namespaces ► Sitecore.Data.Query ► Root ► Root()()()
Initializes a new instance of the Root class
Declaration Syntax
C#
public Root()


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► Root ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluation.


Self Class

Self Class
Namespaces ► Sitecore.Data.Query ► Self
Represents a Self element in an Sitecore XPath query.
Declaration Syntax
C#
public class Self : Step
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Self(Predicate) | Creates a new Self instance.
 | Break(Query, Object) | Breaks the query. (Inherited from Step.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Overrides Opcode.Evaluate(Query, QueryContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextStep | Gets or sets the next step. (Inherited from Step.)
 | Print(HtmlTextWriter) | Prints the expression. (Overrides Step.Print(HtmlTextWriter).)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | Self


Self Constructor (predicate)

Self Constructor (predicate)
Namespaces ► Sitecore.Data.Query ► Self ► Self(Predicate)
Creates a new Self instance.
Declaration Syntax
C#
public Self(
    Predicate predicate
)
Parameters
predicate (Predicate)
Predicate.


Evaluate Method (query, node)

Evaluate Method (query, node)
Namespaces ► Sitecore.Data.Query ► Self ► Evaluate(Query, QueryContext)
Evaluates the specified query.
Declaration Syntax
C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Parameters
query (Query)
Query.
node (QueryContext)
Node.
Return Value
The result of the evaluation.


Print Method (output)

Print Method (output)
Namespaces ► Sitecore.Data.Query ► Self ► Print(HtmlTextWriter)
Prints the expression.
Declaration Syntax
C#
public override void Print(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
Output.


SmallerOperator Class

SmallerOperator Class
Namespaces ► Sitecore.Data.Query ► SmallerOperator
Represents an Smaller Than operator in an Sitecore XPath query.
Declaration Syntax
C#
public class SmallerOperator : BinaryOperator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SmallerOperator(Opcode, Opcode) | Creates a new SmallerOperator instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
 | EvaluateOperands(Object, Object) | Evaluates the expression. (Overrides BinaryOperator.EvaluateOperands(Object, Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression. (Inherited from BinaryOperator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from BinaryOperator.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression. (Inherited from BinaryOperator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | SmallerOperator


SmallerOperator Constructor (left, right)

SmallerOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► SmallerOperator ► SmallerOperator(Opcode, Opcode)
Creates a new SmallerOperator instance.
Declaration Syntax
C#
public SmallerOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► SmallerOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value


SmallerOrEqualsOperator Class

SmallerOrEqualsOperator Class
Namespaces ► Sitecore.Data.Query ► SmallerOrEqualsOperator
Represents an Smaller Than or Equals operator in an Sitecore XPath query.
Declaration Syntax
C#
public class SmallerOrEqualsOperator : BinaryOperator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SmallerOrEqualsOperator(Opcode, Opcode) | Creates a new SmallerOrEqualsOperator instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
 | EvaluateOperands(Object, Object) | Evaluates the expression. (Overrides BinaryOperator.EvaluateOperands(Object, Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression. (Inherited from BinaryOperator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from BinaryOperator.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression. (Inherited from BinaryOperator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | SmallerOrEqualsOperator


SmallerOrEqualsOperator Constructor (left, right)

SmallerOrEqualsOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► SmallerOrEqualsOperator ► SmallerOrEqualsOperator(Opcode, Opcode)
Creates a new SmallerOrEqualsOperator instance.
Declaration Syntax
C#
public SmallerOrEqualsOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► SmallerOrEqualsOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value


Step Class

Step Class
Namespaces ► Sitecore.Data.Query ► Step
Defines the basic functionality of a Step in an Sitecore XPath query.
Declaration Syntax
C#
public abstract class Step : Opcode
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Step()()() | Initializes a new instance of the Step class
 | Break(Query, Object) | Breaks the query.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from Opcode.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextStep | Gets or sets the next step.
 | Print(HtmlTextWriter) | Prints the expression. (Overrides Opcode.Print(HtmlTextWriter).)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | Step
 |  |  | Ancestor
 |  |  | Children
 |  |  | Descendant
 |  |  | ElementBase
 |  |  | Following
 |  |  | Parent
 |  |  | Preceding
 |  |  | Predicate
 |  |  | Root
 |  |  | Self


Step Constructor

Step Constructor
Namespaces ► Sitecore.Data.Query ► Step ► Step()()()
Initializes a new instance of the Step class
Declaration Syntax
C#
protected Step()


Break Method (query, result)

Break Method (query, result)
Namespaces ► Sitecore.Data.Query ► Step ► Break(Query, Object)
Breaks the query.
Declaration Syntax
C#
protected bool Break(
    Query query,
    Object result
)
Parameters
query (Query)
Query.
result (Object)
Result.
Return Value
The break.


NextStep Property

NextStep Property
Namespaces ► Sitecore.Data.Query ► Step ► NextStep
Gets or sets the next step.
Declaration Syntax
C#
public Step NextStep { get; set; }
Value
The next step.


Print Method (output)

Print Method (output)
Namespaces ► Sitecore.Data.Query ► Step ► Print(HtmlTextWriter)
Prints the expression.
Declaration Syntax
C#
public override void Print(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
Output.


Token Structure

Token Structure
Namespaces ► Sitecore.Data.Query ► Token
Represents a token when parsing an Sitecore XPath query.
Declaration Syntax
C#
public struct Token
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Index | Index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NumberValue | NumberValue.
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | Type | Type.
 | Value | Value.
 | Whitespace | Whitespace.


Index Field

Index Field
Namespaces ► Sitecore.Data.Query ► Token ► Index
Index.
Declaration Syntax
C#
public int Index


NumberValue Field

NumberValue Field
Namespaces ► Sitecore.Data.Query ► Token ► NumberValue
NumberValue.
Declaration Syntax
C#
public int NumberValue


Type Field

Type Field
Namespaces ► Sitecore.Data.Query ► Token ► Type
Type.
Declaration Syntax
C#
public int Type


Value Field

Value Field
Namespaces ► Sitecore.Data.Query ► Token ► Value
Value.
Declaration Syntax
C#
public string Value


Whitespace Field

Whitespace Field
Namespaces ► Sitecore.Data.Query ► Token ► Whitespace
Whitespace.
Declaration Syntax
C#
public string Whitespace


TokenBuilder Class

TokenBuilder Class
Namespaces ► Sitecore.Data.Query ► TokenBuilder
Builds tokens.
Declaration Syntax
C#
public class TokenBuilder
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TokenBuilder()()() | Initializes a new instance of the TokenBuilder class
 | At()()() | At.
 | Axis()()() | Axis.
 | Comma()()() | Comma.
 | Dollar()()() | Dollar.
 | Dot()()() | Dot.
 | DotDot()()() | Dot dot.
 | DoubleSlash()()() | Double slash.
 | End()()() | End.
 | EndParentes()()() | End parentes.
 | EndSquareBracket()()() | End square bracket.
 | Equals()()() | Equal.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Greater()()() | Greater.
 | GreaterOrEquals()()() | Greater or equals.
 | Guid(String) | GUID.
 | Identifier(String) | Identifier.
 | Literal(String) | Literal.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Minus()()() | Minus.
 | Namespace()()() | Namespace.
 | Number(Int32) | Number.
 | Pipe()()() | Pipe.
 | Plus()()() | Plus.
 | Slash()()() | Slash.
 | Smaller()()() | Smaller.
 | SmallerOrEquals()()() | Smaller or equal.
 | Star()()() | Star.
 | StartParentes()()() | Start parentes.
 | StartSquareBracket()()() | Start square bracket.
 | Token | The current token.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unequals()()() | Unequal.
Inheritance Hierarchy
Object
 | TokenBuilder
 |  | QueryTokenBuilder


TokenBuilder Constructor

TokenBuilder Constructor
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► TokenBuilder()()()
Initializes a new instance of the TokenBuilder class
Declaration Syntax
C#
public TokenBuilder()


At Method

At Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► At()()()
At.
Declaration Syntax
C#
public void At()


Axis Method

Axis Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Axis()()()
Axis.
Declaration Syntax
C#
public void Axis()


Comma Method

Comma Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Comma()()()
Comma.
Declaration Syntax
C#
public void Comma()


Dollar Method

Dollar Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Dollar()()()
Dollar.
Declaration Syntax
C#
public void Dollar()


Dot Method

Dot Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Dot()()()
Dot.
Declaration Syntax
C#
public void Dot()


DotDot Method

DotDot Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► DotDot()()()
Dot dot.
Declaration Syntax
C#
public void DotDot()


DoubleSlash Method

DoubleSlash Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► DoubleSlash()()()
Double slash.
Declaration Syntax
C#
public void DoubleSlash()


End Method

End Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► End()()()
End.
Declaration Syntax
C#
public void End()


EndParentes Method

EndParentes Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► EndParentes()()()
End parentes.
Declaration Syntax
C#
public void EndParentes()


EndSquareBracket Method

EndSquareBracket Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► EndSquareBracket()()()
End square bracket.
Declaration Syntax
C#
public void EndSquareBracket()


Equals Method

Equals Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Equals()()()
Equal.
Declaration Syntax
C#
public void Equals()


Greater Method

Greater Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Greater()()()
Greater.
Declaration Syntax
C#
public void Greater()


GreaterOrEquals Method

GreaterOrEquals Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► GreaterOrEquals()()()
Greater or equals.
Declaration Syntax
C#
public void GreaterOrEquals()


Guid Method (value)

Guid Method (value)
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Guid(String)
GUID.
Declaration Syntax
C#
public void Guid(
    string value
)
Parameters
value (String)
The GUID.


Identifier Method (value)

Identifier Method (value)
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Identifier(String)
Identifier.
Declaration Syntax
C#
public virtual void Identifier(
    string value
)
Parameters
value (String)
The identifier.


Literal Method (name)

Literal Method (name)
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Literal(String)
Literal.
Declaration Syntax
C#
public void Literal(
    string name
)
Parameters
name (String)
The name.


Minus Method

Minus Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Minus()()()
Minus.
Declaration Syntax
C#
public void Minus()


Namespace Method

Namespace Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Namespace()()()
Namespace.
Declaration Syntax
C#
public void Namespace()


Number Method (value)

Number Method (value)
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Number(Int32)
Number.
Declaration Syntax
C#
public void Number(
    int value
)
Parameters
value (Int32)
The number.


Pipe Method

Pipe Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Pipe()()()
Pipe.
Declaration Syntax
C#
public void Pipe()


Plus Method

Plus Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Plus()()()
Plus.
Declaration Syntax
C#
public void Plus()


Slash Method

Slash Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Slash()()()
Slash.
Declaration Syntax
C#
public void Slash()


Smaller Method

Smaller Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Smaller()()()
Smaller.
Declaration Syntax
C#
public void Smaller()


SmallerOrEquals Method

SmallerOrEquals Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► SmallerOrEquals()()()
Smaller or equal.
Declaration Syntax
C#
public void SmallerOrEquals()


Star Method

Star Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Star()()()
Star.
Declaration Syntax
C#
public void Star()


StartParentes Method

StartParentes Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► StartParentes()()()
Start parentes.
Declaration Syntax
C#
public void StartParentes()


StartSquareBracket Method

StartSquareBracket Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► StartSquareBracket()()()
Start square bracket.
Declaration Syntax
C#
public void StartSquareBracket()


Token Field

Token Field
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Token
The current token.
Declaration Syntax
C#
public Token Token


Unequals Method

Unequals Method
Namespaces ► Sitecore.Data.Query ► TokenBuilder ► Unequals()()()
Unequal.
Declaration Syntax
C#
public void Unequals()


Tokenizer Class

Tokenizer Class
Namespaces ► Sitecore.Data.Query ► Tokenizer
Tokenizes a string for use in a Sitecore XPath query.
Declaration Syntax
C#
public class Tokenizer
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Tokenizer(TokenBuilder, String) | Creates a new Tokenizer instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IdentifierCharacters | Identifier characters.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextToken()()() | Gets the next token.
 | PeekToken()()() | Gets the next token without forwarding the current parsing location.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UngetToken(Token) | Ungets the token.
Inheritance Hierarchy
Object
Tokenizer


Tokenizer Constructor (builder, text)

Tokenizer Constructor (builder, text)
Namespaces ► Sitecore.Data.Query ► Tokenizer ► Tokenizer(TokenBuilder, String)
Creates a new Tokenizer instance.
Declaration Syntax
C#
public Tokenizer(
    TokenBuilder builder,
    string text
)
Parameters
builder (TokenBuilder)
Builder.
text (String)
Text.


IdentifierCharacters Field

IdentifierCharacters Field
Namespaces ► Sitecore.Data.Query ► Tokenizer ► IdentifierCharacters
Identifier characters.
Declaration Syntax
C#
public const string IdentifierCharacters


NextToken Method

NextToken Method
Namespaces ► Sitecore.Data.Query ► Tokenizer ► NextToken()()()
Gets the next token.
Declaration Syntax
C#
public virtual Token NextToken()
Return Value
The token.


PeekToken Method

PeekToken Method
Namespaces ► Sitecore.Data.Query ► Tokenizer ► PeekToken()()()
Gets the next token without forwarding the current parsing location.
Declaration Syntax
C#
public Token PeekToken()
Return Value
The token.


UngetToken Method (token)

UngetToken Method (token)
Namespaces ► Sitecore.Data.Query ► Tokenizer ► UngetToken(Token)
Ungets the token.
Declaration Syntax
C#
public void UngetToken(
    Token token
)
Parameters
token (Token)
The token.


TokenType Class

TokenType Class
Namespaces ► Sitecore.Data.Query ► TokenType
Defines IDs for keywords in a Sitecore XPath query.
Declaration Syntax
C#
public class TokenType
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TokenType()()() | Initializes a new instance of the TokenType class
 | At | At.
 | Axis | Axis.
 | Comma | Comma.
 | Dollar | Dollar.
 | Dot | Dot.
 | DotDot | DotDot.
 | DoubleSlash | DoubleSlash.
 | End | End.
 | EndParentes | EndParentes.
 | EndSquareBracket | EndSquareBracket.
 | Equal | Equal.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Greater | Greater.
 | GreaterOrEquals | GreaterOrEquals.
 | Guid | Guid.
 | Identifier | Identifier.
 | Literal | Literal.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Minus | Minus.
 | Namespace | Namespace.
 | Number | Number.
 | Pipe | Pipe.
 | Plus | Plus.
 | Slash | Slash.
 | Smaller | Smaller.
 | SmallerOrEquals | SmallerOrEquals.
 | Star | Star.
 | StartParentes | StartParentes.
 | StartSquareBracket | StartSquareBracket.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unequals | Unequals.
Inheritance Hierarchy
Object
 | TokenType
 |  | QueryTokenType


TokenType Constructor

TokenType Constructor
Namespaces ► Sitecore.Data.Query ► TokenType ► TokenType()()()
Initializes a new instance of the TokenType class
Declaration Syntax
C#
public TokenType()


At Field

At Field
Namespaces ► Sitecore.Data.Query ► TokenType ► At
At.
Declaration Syntax
C#
public const int At


Axis Field

Axis Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Axis
Axis.
Declaration Syntax
C#
public const int Axis


Comma Field

Comma Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Comma
Comma.
Declaration Syntax
C#
public const int Comma


Dollar Field

Dollar Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Dollar
Dollar.
Declaration Syntax
C#
public const int Dollar


Dot Field

Dot Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Dot
Dot.
Declaration Syntax
C#
public const int Dot


DotDot Field

DotDot Field
Namespaces ► Sitecore.Data.Query ► TokenType ► DotDot
DotDot.
Declaration Syntax
C#
public const int DotDot


DoubleSlash Field

DoubleSlash Field
Namespaces ► Sitecore.Data.Query ► TokenType ► DoubleSlash
DoubleSlash.
Declaration Syntax
C#
public const int DoubleSlash


End Field

End Field
Namespaces ► Sitecore.Data.Query ► TokenType ► End
End.
Declaration Syntax
C#
public const int End


EndParentes Field

EndParentes Field
Namespaces ► Sitecore.Data.Query ► TokenType ► EndParentes
EndParentes.
Declaration Syntax
C#
public const int EndParentes


EndSquareBracket Field

EndSquareBracket Field
Namespaces ► Sitecore.Data.Query ► TokenType ► EndSquareBracket
EndSquareBracket.
Declaration Syntax
C#
public const int EndSquareBracket


Equal Field

Equal Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Equal
Equal.
Declaration Syntax
C#
public const int Equal


Greater Field

Greater Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Greater
Greater.
Declaration Syntax
C#
public const int Greater


GreaterOrEquals Field

GreaterOrEquals Field
Namespaces ► Sitecore.Data.Query ► TokenType ► GreaterOrEquals
GreaterOrEquals.
Declaration Syntax
C#
public const int GreaterOrEquals


Guid Field

Guid Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Guid
Guid.
Declaration Syntax
C#
public const int Guid


Identifier Field

Identifier Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Identifier
Identifier.
Declaration Syntax
C#
public const int Identifier


Literal Field

Literal Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Literal
Literal.
Declaration Syntax
C#
public const int Literal


Minus Field

Minus Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Minus
Minus.
Declaration Syntax
C#
public const int Minus


Namespace Field

Namespace Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Namespace
Namespace.
Declaration Syntax
C#
public const int Namespace


Number Field

Number Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Number
Number.
Declaration Syntax
C#
public const int Number


Pipe Field

Pipe Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Pipe
Pipe.
Declaration Syntax
C#
public const int Pipe


Plus Field

Plus Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Plus
Plus.
Declaration Syntax
C#
public const int Plus


Slash Field

Slash Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Slash
Slash.
Declaration Syntax
C#
public const int Slash


Smaller Field

Smaller Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Smaller
Smaller.
Declaration Syntax
C#
public const int Smaller


SmallerOrEquals Field

SmallerOrEquals Field
Namespaces ► Sitecore.Data.Query ► TokenType ► SmallerOrEquals
SmallerOrEquals.
Declaration Syntax
C#
public const int SmallerOrEquals


Star Field

Star Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Star
Star.
Declaration Syntax
C#
public const int Star


StartParentes Field

StartParentes Field
Namespaces ► Sitecore.Data.Query ► TokenType ► StartParentes
StartParentes.
Declaration Syntax
C#
public const int StartParentes


StartSquareBracket Field

StartSquareBracket Field
Namespaces ► Sitecore.Data.Query ► TokenType ► StartSquareBracket
StartSquareBracket.
Declaration Syntax
C#
public const int StartSquareBracket


Unequals Field

Unequals Field
Namespaces ► Sitecore.Data.Query ► TokenType ► Unequals
Unequals.
Declaration Syntax
C#
public const int Unequals


UnequalsOperator Class

UnequalsOperator Class
Namespaces ► Sitecore.Data.Query ► UnequalsOperator
Represents an Unequals operator in an Sitecore XPath query.
Declaration Syntax
C#
public class UnequalsOperator : BinaryOperator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnequalsOperator(Opcode, Opcode) | Creates a new UnequalsOperator instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
 | EvaluateOperands(Object, Object) | Evaluates the expression. (Overrides BinaryOperator.EvaluateOperands(Object, Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression. (Inherited from BinaryOperator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from BinaryOperator.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression. (Inherited from BinaryOperator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | UnequalsOperator


UnequalsOperator Constructor (left, right)

UnequalsOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► UnequalsOperator ► UnequalsOperator(Opcode, Opcode)
Creates a new UnequalsOperator instance.
Declaration Syntax
C#
public UnequalsOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► UnequalsOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value


XorOperator Class

XorOperator Class
Namespaces ► Sitecore.Data.Query ► XorOperator
Represents an XOR operator in an Sitecore XPath query.
Declaration Syntax
C#
public class XorOperator : BinaryOperator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XorOperator(Opcode, Opcode) | Creates a new XorOperator instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
 | EvaluateOperands(Object, Object) | Evaluates the expression. (Overrides BinaryOperator.EvaluateOperands(Object, Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets the left expression. (Inherited from BinaryOperator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Print(HtmlTextWriter) | Prints the expression. (Inherited from BinaryOperator.)
 | PrintIndent(HtmlTextWriter) | Prints the indentation. (Inherited from Opcode.)
 | PrintLine(HtmlTextWriter, String) | Prints a line of text. (Inherited from Opcode.)
 | Process(Query, QueryContext, Predicate, Opcode, Object%) | Processes the specified query. (Inherited from Opcode.)
 | Right | Gets the right expression. (Inherited from BinaryOperator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Opcode
 |  | BinaryOperator
 |  |  | XorOperator


XorOperator Constructor (left, right)

XorOperator Constructor (left, right)
Namespaces ► Sitecore.Data.Query ► XorOperator ► XorOperator(Opcode, Opcode)
Creates a new XorOperator instance.
Declaration Syntax
C#
public XorOperator(
    Opcode left,
    Opcode right
)
Parameters
left (Opcode)
Left expression.
right (Opcode)
Right expression.


EvaluateOperands Method (left, right)

EvaluateOperands Method (left, right)
Namespaces ► Sitecore.Data.Query ► XorOperator ► EvaluateOperands(Object, Object)
Evaluates the expression.
Declaration Syntax
C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Parameters
left (Object)
Left expression.
right (Object)
Right expression.
Return Value


Sitecore.Data.Serialization Namespace

Sitecore.Data.Serialization Namespace
Namespaces ► Sitecore.Data.Serialization
Declaration Syntax
C#
namespace Sitecore.Data.Serialization
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | CommonUtils | Common utilities used by Serialization
 | DatabaseLoader | Description of DatabaseLoader.
 | ItemOperation..::.DataComparer | Compares ItemOperation objects by data.
 | ItemOperation..::.DataStampComparer | Compares ItemOperation objects by data then stamp.
 | FileOperationType | Type of the occured event
 | FileSystemEventArgs | Arguments for FileOperationDelegate delegate
 | IDataConnectionFactory | Provides ways for DatabaseLoader to construct database-specific objects
 | IDbAdminConnection | Description of IDbAdminConnection.
 | ItemHandler |
 | ItemOperation | Encapsulates an operation on an Item
 | ItemReference | Path-based item reference with uniqueness support.
 | ItemSynchronization | Implements Item <-> File synchronization
 | LoadOptions | Specifies operation options when loading data from dumped database.
 | Manager | Facade to all Serialization operations
 | Operation | List of supported operations.
 | PathUtils | Utility functions for managing paths inside dump root
 | ShadowWriter | Encapsulates background process of synchronizing filesystem with the database.
 | SqlConnectionFactory | Description of SqlConnectionFactory.
 | SqlServerAdminConnection | Description of DbAdminConnection.
 | ItemOperation..::.StampComparer | Compares ItemOperation objets by timestamp.


CommonUtils Class

CommonUtils Class
Namespaces ► Sitecore.Data.Serialization ► CommonUtils
Common utilities used by Serialization
Declaration Syntax
C#
public static class CommonUtils
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreateCIHashtable()()() | Creates the case-insensitive hashtable.
 | IsDirectoryHidden(String) | Determines whether directory is hidden.
 | IsHidden(FileSystemInfo) | Determines whether the specified file/directory is hidden.
 | Uniq<(Of <(T>)>)(List<(Of <(T>)>), IComparer<(Of <(T>)>)) | Scans sorted workset for duplicate entries.
Inheritance Hierarchy
Object
CommonUtils


CreateCIHashtable Method

CreateCIHashtable Method
Namespaces ► Sitecore.Data.Serialization ► CommonUtils ► CreateCIHashtable()()()
Creates the case-insensitive hashtable.
Declaration Syntax
C#
public static Hashtable CreateCIHashtable()
Return Value
The hashtable.


IsDirectoryHidden Method (path)

IsDirectoryHidden Method (path)
Namespaces ► Sitecore.Data.Serialization ► CommonUtils ► IsDirectoryHidden(String)
Determines whether directory is hidden.
Declaration Syntax
C#
public static bool IsDirectoryHidden(
    string path
)
Parameters
path (String)
The path pointing to a directory.
Return Value
true if directory is hidden; otherwise, false.


IsHidden Method (info)

IsHidden Method (info)
Namespaces ► Sitecore.Data.Serialization ► CommonUtils ► IsHidden(FileSystemInfo)
Determines whether the specified file/directory is hidden.
Declaration Syntax
C#
public static bool IsHidden(
    FileSystemInfo info
)
Parameters
info (FileSystemInfo)
The file system entry info.
Return Value
true if the specified file/info is hidden; otherwise, false.


Uniq Method (workset, comparer)

Uniq<(Of <(T>)>) Method (workset, comparer)
Namespaces ► Sitecore.Data.Serialization ► CommonUtils ► Uniq<(Of <(T>)>)(List<(Of <(T>)>), IComparer<(Of <(T>)>))
Scans sorted workset for duplicate entries.
Declaration Syntax
C#
public static List<T> Uniq<T>(
    List<T> workset,
    IComparer<T> comparer
)
Generic Template Parameters
T
Parameters
workset (List<(Of <(T>)>))
The workset.
comparer (IComparer<(Of <(T>)>))
The comparer.
Return Value
The workset without duplicate entries.


DatabaseLoader Class

DatabaseLoader Class
Namespaces ► Sitecore.Data.Serialization ► DatabaseLoader
Description of DatabaseLoader.
Declaration Syntax
C#
public class DatabaseLoader
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DatabaseLoader(String) | Initializes a new instance of database loader.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoadDatabase(IDataConnectionFactory) | Loads database
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DatabaseLoader


DatabaseLoader Constructor (path)

DatabaseLoader Constructor (path)
Namespaces ► Sitecore.Data.Serialization ► DatabaseLoader ► DatabaseLoader(String)
Initializes a new instance of database loader.
Declaration Syntax
C#
public DatabaseLoader(
    string path
)
Parameters
path (String)
Path to the database dump and schema


LoadDatabase Method (factory)

LoadDatabase Method (factory)
Namespaces ► Sitecore.Data.Serialization ► DatabaseLoader ► LoadDatabase(IDataConnectionFactory)
Loads database
Declaration Syntax
C#
public Database LoadDatabase(
    IDataConnectionFactory factory
)
Parameters
factory (IDataConnectionFactory)


FileOperationType Enumeration

FileOperationType Enumeration
Namespaces ► Sitecore.Data.Serialization ► FileOperationType
Type of the occured event
Declaration Syntax
C#
public enum FileOperationType
Members
Member | Description
Created | Created file or directory
Deleted | Deleted file or directory


FileSystemEventArgs Class

FileSystemEventArgs Class
Namespaces ► Sitecore.Data.Serialization ► FileSystemEventArgs
Arguments for FileOperationDelegate delegate
Declaration Syntax
C#
public class FileSystemEventArgs : EventArgs,
    IPassNativeEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileSystemEventArgs(FileOperationType, String) | Initializes a new instance of the FileSystemEventArgs class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileName | Gets the name of the file.
 | FileOperationType | Gets the type of the file operation.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | FileSystemEventArgs


FileSystemEventArgs Constructor (fileType, fileName)

FileSystemEventArgs Constructor (fileType, fileName)
Namespaces ► Sitecore.Data.Serialization ► FileSystemEventArgs ► FileSystemEventArgs(FileOperationType, String)
Initializes a new instance of the FileSystemEventArgs class.
Declaration Syntax
C#
public FileSystemEventArgs(
    FileOperationType fileType,
    string fileName
)
Parameters
fileType (FileOperationType)
Type of the file.
fileName (String)
Name of the file.


FileName Property

FileName Property
Namespaces ► Sitecore.Data.Serialization ► FileSystemEventArgs ► FileName
Gets the name of the file.
Declaration Syntax
C#
public string FileName { get; }
Value
The name of the file.


FileOperationType Property

FileOperationType Property
Namespaces ► Sitecore.Data.Serialization ► FileSystemEventArgs ► FileOperationType
Gets the type of the file operation.
Declaration Syntax
C#
public FileOperationType FileOperationType { get; }
Value
The type of the file operation.


IDataConnectionFactory Interface

IDataConnectionFactory Interface
Namespaces ► Sitecore.Data.Serialization ► IDataConnectionFactory
Provides ways for DatabaseLoader to construct database-specific objects
Declaration Syntax
C#
public interface IDataConnectionFactory
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConnectionString | Gets the connection string for this database connection.
 | CreateApi()()() | Creates a new instance of SqlDataApi tied to the factory.
 | CreateProvider()()() | Creates DataProvider instance tied to the factory.


ConnectionString Property

ConnectionString Property
Namespaces ► Sitecore.Data.Serialization ► IDataConnectionFactory ► ConnectionString
Gets the connection string for this database connection.
Declaration Syntax
C#
string ConnectionString { get; }


CreateApi Method

CreateApi Method
Namespaces ► Sitecore.Data.Serialization ► IDataConnectionFactory ► CreateApi()()()
Creates a new instance of SqlDataApi tied to the factory.
Declaration Syntax
C#
SqlDataApi CreateApi()
Return Value
Database-specific SqlDataApi implementation.


CreateProvider Method

CreateProvider Method
Namespaces ► Sitecore.Data.Serialization ► IDataConnectionFactory ► CreateProvider()()()
Creates DataProvider instance tied to the factory.
Declaration Syntax
C#
DataProvider CreateProvider()
Return Value
Database-specific DataProvider implementation


IDbAdminConnection Interface

IDbAdminConnection Interface
Namespaces ► Sitecore.Data.Serialization ► IDbAdminConnection
Description of IDbAdminConnection.
Declaration Syntax
C#
public interface IDbAdminConnection
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreateDatabase(String) | Creates a new database with the specified names
 | CreateDatabase(String, String) | Creates a new database with the specified names
 | Detach(String) | Detach database to unlock file;
 | GetConnectionFactory(String) | Returns connection factory pointing to specific database


CreateDatabase Method

CreateDatabase Method
Namespaces ► Sitecore.Data.Serialization ► IDbAdminConnection ► CreateDatabase()()()
Members
Icon | Member | Description
 | CreateDatabase(String) | Creates a new database with the specified names
 | CreateDatabase(String, String) | Creates a new database with the specified names


CreateDatabase Method (databaseName)

CreateDatabase Method (databaseName)
Namespaces ► Sitecore.Data.Serialization ► IDbAdminConnection ► CreateDatabase(String)
Creates a new database with the specified names
Declaration Syntax
C#
void CreateDatabase(
    string databaseName
)
Parameters
databaseName (String)
Name of the database


CreateDatabase Method (databaseName, fileName)

CreateDatabase Method (databaseName, fileName)
Namespaces ► Sitecore.Data.Serialization ► IDbAdminConnection ► CreateDatabase(String, String)
Creates a new database with the specified names
Declaration Syntax
C#
void CreateDatabase(
    string databaseName,
    string fileName
)
Parameters
databaseName (String)
Name of the database
fileName (String)
File to store created database


Detach Method (databaseName)

Detach Method (databaseName)
Namespaces ► Sitecore.Data.Serialization ► IDbAdminConnection ► Detach(String)
Detach database to unlock file;
Declaration Syntax
C#
void Detach(
    string databaseName
)
Parameters
databaseName (String)
Name of the database


GetConnectionFactory Method (databaseName)

GetConnectionFactory Method (databaseName)
Namespaces ► Sitecore.Data.Serialization ► IDbAdminConnection ► GetConnectionFactory(String)
Returns connection factory pointing to specific database
Declaration Syntax
C#
IDataConnectionFactory GetConnectionFactory(
    string databaseName
)
Parameters
databaseName (String)
Name of the database
Return Value
Implementation of IDataConnectionFactory


ItemHandler Class

ItemHandler Class
Namespaces ► Sitecore.Data.Serialization ► ItemHandler
Declaration Syntax
C#
public class ItemHandler
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemHandler()()() | Initializes a new instance of the ItemHandler class
 | Disabled | Gets or sets a value indicating whether this ItemHandler is disabled.
 | DisabledLocally | Gets or sets a value indicating whether the ItemHandler is disabled in the calling thread.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnItemDeleted(Object, EventArgs) | Called when the item has been deleted.
 | OnItemMoved(Object, EventArgs) | Called when the item has been moved.
 | OnItemSaved(Object, EventArgs) | Called when the item has been saved.
 | OnItemVersionRemoved(Object, EventArgs) | Called when the item version has been removed.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemHandler


ItemHandler Constructor

ItemHandler Constructor
Namespaces ► Sitecore.Data.Serialization ► ItemHandler ► ItemHandler()()()
Initializes a new instance of the ItemHandler class
Declaration Syntax
C#
public ItemHandler()


Disabled Property

Disabled Property
Namespaces ► Sitecore.Data.Serialization ► ItemHandler ► Disabled
Gets or sets a value indicating whether this ItemHandler is disabled.
Declaration Syntax
C#
public static bool Disabled { get; set; }
Value
true if disabled; otherwise, false.


DisabledLocally Property

DisabledLocally Property
Namespaces ► Sitecore.Data.Serialization ► ItemHandler ► DisabledLocally
Gets or sets a value indicating whether the ItemHandler is disabled in the calling thread.
Declaration Syntax
C#
public static bool DisabledLocally { get; set; }
Value
true if the ItemHandler is disabled in the current thread; otherwise, false.


OnItemDeleted Method (sender, args)

OnItemDeleted Method (sender, args)
Namespaces ► Sitecore.Data.Serialization ► ItemHandler ► OnItemDeleted(Object, EventArgs)
Called when the item has been deleted.
Declaration Syntax
C#
public void OnItemDeleted(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


OnItemMoved Method (sender, args)

OnItemMoved Method (sender, args)
Namespaces ► Sitecore.Data.Serialization ► ItemHandler ► OnItemMoved(Object, EventArgs)
Called when the item has been moved.
Declaration Syntax
C#
public void OnItemMoved(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


OnItemSaved Method (sender, args)

OnItemSaved Method (sender, args)
Namespaces ► Sitecore.Data.Serialization ► ItemHandler ► OnItemSaved(Object, EventArgs)
Called when the item has been saved.
Declaration Syntax
C#
public void OnItemSaved(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


OnItemVersionRemoved Method (sender, args)

OnItemVersionRemoved Method (sender, args)
Namespaces ► Sitecore.Data.Serialization ► ItemHandler ► OnItemVersionRemoved(Object, EventArgs)
Called when the item version has been removed.
Declaration Syntax
C#
public void OnItemVersionRemoved(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


ItemOperation Class

ItemOperation Class
Namespaces ► Sitecore.Data.Serialization ► ItemOperation
Encapsulates an operation on an Item
Declaration Syntax
C#
public class ItemOperation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemOperation(Operation, Item, Item) | Initializes a new instance of the ItemOperation class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item | Gets or sets the data.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Operation | Gets or sets the operation.
 | Parent | Gets or sets the parent.
 | Stamp | Gets or sets the timestamp.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemOperation


ItemOperation Constructor (operation, item, parent)

ItemOperation Constructor (operation, item, parent)
Namespaces ► Sitecore.Data.Serialization ► ItemOperation ► ItemOperation(Operation, Item, Item)
Initializes a new instance of the ItemOperation class.
Declaration Syntax
C#
public ItemOperation(
    Operation operation,
    Item item,
    Item parent
)
Parameters
operation (Operation)
The op.
item (Item)
The item.
parent (Item)
The parent.


Item Property

Item Property
Namespaces ► Sitecore.Data.Serialization ► ItemOperation ► Item
Gets or sets the data.
Declaration Syntax
C#
public Item Item { get; set; }
Value
The data.


Operation Property

Operation Property
Namespaces ► Sitecore.Data.Serialization ► ItemOperation ► Operation
Gets or sets the operation.
Declaration Syntax
C#
public Operation Operation { get; set; }
Value
The operation.


Parent Property

Parent Property
Namespaces ► Sitecore.Data.Serialization ► ItemOperation ► Parent
Gets or sets the parent.
Declaration Syntax
C#
public Item Parent { get; set; }
Value
The parent.


Stamp Property

Stamp Property
Namespaces ► Sitecore.Data.Serialization ► ItemOperation ► Stamp
Gets or sets the timestamp.
Declaration Syntax
C#
public long Stamp { get; set; }
Value
The stamp.


ItemOperation.DataComparer Class

ItemOperation..::.DataComparer Class
Namespaces ► Sitecore.Data.Serialization ► ItemOperation ► ItemOperation..::.DataComparer
Compares ItemOperation objects by data.
Declaration Syntax
C#
public class DataComparer : IComparer<ItemOperation>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemOperation..::.DataComparer()()() | Initializes a new instance of the ItemOperation..::.DataComparer class
 | Compare(ItemOperation, ItemOperation) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ItemOperation..::.DataComparer
 |  | ItemOperation..::.DataStampComparer


ItemOperation.DataComparer Constructor

ItemOperation..::.DataComparer Constructor
Namespaces ► Sitecore.Data.Serialization ► ItemOperation..::.DataComparer ► ItemOperation..::.DataComparer()()()
Initializes a new instance of the ItemOperation..::.DataComparer class
Declaration Syntax
C#
public DataComparer()


Compare Method (x, y)

Compare Method (x, y)
Namespaces ► Sitecore.Data.Serialization ► ItemOperation..::.DataComparer ► Compare(ItemOperation, ItemOperation)
Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Declaration Syntax
C#
public int Compare(
    ItemOperation x,
    ItemOperation y
)
Parameters
x (ItemOperation)
The first object to compare.
y (ItemOperation)
The second object to compare.
Return Value
Value Condition Less than zerox is less than y.Zerox equals y.Greater than zerox is greater than y.


ItemOperation.DataStampComparer Class

ItemOperation..::.DataStampComparer Class
Namespaces ► Sitecore.Data.Serialization ► ItemOperation ► ItemOperation..::.DataStampComparer
Compares ItemOperation objects by data then stamp.
Declaration Syntax
C#
public class DataStampComparer : ItemOperation..::.DataComparer,
    IComparer<ItemOperation>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemOperation..::.DataStampComparer()()() | Initializes a new instance of the ItemOperation..::.DataStampComparer class
 | Compare(ItemOperation, ItemOperation) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ItemOperation..::.DataComparer
 |  | ItemOperation..::.DataStampComparer


ItemOperation.DataStampComparer Constructor

ItemOperation..::.DataStampComparer Constructor
Namespaces ► Sitecore.Data.Serialization ► ItemOperation..::.DataStampComparer ► ItemOperation..::.DataStampComparer()()()
Initializes a new instance of the ItemOperation..::.DataStampComparer class
Declaration Syntax
C#
public DataStampComparer()


Compare Method (x, y)

Compare Method (x, y)
Namespaces ► Sitecore.Data.Serialization ► ItemOperation..::.DataStampComparer ► Compare(ItemOperation, ItemOperation)
Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Declaration Syntax
C#
public int Compare(
    ItemOperation x,
    ItemOperation y
)
Parameters
x (ItemOperation)
The first object to compare.
y (ItemOperation)
The second object to compare.
Return Value
Value Condition Less than zerox is less than y.Zerox equals y.Greater than zerox is greater than y.


ItemOperation.StampComparer Class

ItemOperation..::.StampComparer Class
Namespaces ► Sitecore.Data.Serialization ► ItemOperation ► ItemOperation..::.StampComparer
Compares ItemOperation objets by timestamp.
Declaration Syntax
C#
public class StampComparer : IComparer<ItemOperation>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemOperation..::.StampComparer()()() | Initializes a new instance of the ItemOperation..::.StampComparer class
 | Compare(ItemOperation, ItemOperation) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemOperation..::.StampComparer


ItemOperation.StampComparer Constructor

ItemOperation..::.StampComparer Constructor
Namespaces ► Sitecore.Data.Serialization ► ItemOperation..::.StampComparer ► ItemOperation..::.StampComparer()()()
Initializes a new instance of the ItemOperation..::.StampComparer class
Declaration Syntax
C#
public StampComparer()


Compare Method (x, y)

Compare Method (x, y)
Namespaces ► Sitecore.Data.Serialization ► ItemOperation..::.StampComparer ► Compare(ItemOperation, ItemOperation)
Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Declaration Syntax
C#
public int Compare(
    ItemOperation x,
    ItemOperation y
)
Parameters
x (ItemOperation)
The first object to compare.
y (ItemOperation)
The second object to compare.
Return Value
Value Condition Less than zerox is less than y.Zerox equals y.Greater than zerox is greater than y.


ItemReference Class

ItemReference Class
Namespaces ► Sitecore.Data.Serialization ► ItemReference
Path-based item reference with uniqueness support.
Declaration Syntax
C#
public class ItemReference
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemReference(Item) | Initializes a new instance of the ItemReference class.
 | ItemReference(String, String) | Initializes a new instance of the ItemReference class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item.
 | GetItemInDatabase(Database) | Gets the item in database.
 | GetItemStrict()()() | Gets the item strict way. Ensures that reference for returned item is the same as 'this' one.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Parses the specified path.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
ItemReference


ItemReference Constructor

ItemReference Constructor
Namespaces ► Sitecore.Data.Serialization ► ItemReference ► ItemReference()()()
Members
Icon | Member | Description
 | ItemReference(Item) | Initializes a new instance of the ItemReference class.
 | ItemReference(String, String) | Initializes a new instance of the ItemReference class.


ItemReference Constructor (item)

ItemReference Constructor (item)
Namespaces ► Sitecore.Data.Serialization ► ItemReference ► ItemReference(Item)
Initializes a new instance of the ItemReference class.
Declaration Syntax
C#
public ItemReference(
    Item item
)
Parameters
item (Item)
The item.


ItemReference Constructor (database, path)

ItemReference Constructor (database, path)
Namespaces ► Sitecore.Data.Serialization ► ItemReference ► ItemReference(String, String)
Initializes a new instance of the ItemReference class.
Declaration Syntax
C#
public ItemReference(
    string database,
    string path
)
Parameters
database (String)
The database.
path (String)
The path.


GetItem Method

GetItem Method
Namespaces ► Sitecore.Data.Serialization ► ItemReference ► GetItem()()()
Gets the item.
Declaration Syntax
C#
public Item GetItem()
Return Value
The item.


GetItemInDatabase Method (database)

GetItemInDatabase Method (database)
Namespaces ► Sitecore.Data.Serialization ► ItemReference ► GetItemInDatabase(Database)
Gets the item in database.
Declaration Syntax
C#
public Item GetItemInDatabase(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The item in database.


GetItemStrict Method

GetItemStrict Method
Namespaces ► Sitecore.Data.Serialization ► ItemReference ► GetItemStrict()()()
Gets the item strict way. Ensures that reference for returned item is the same as 'this' one.
Declaration Syntax
C#
public Item GetItemStrict()
Return Value
The item.


Parse Method (path)

Parse Method (path)
Namespaces ► Sitecore.Data.Serialization ► ItemReference ► Parse(String)
Parses the specified path.
Declaration Syntax
C#
public static ItemReference Parse(
    string path
)
Parameters
path (String)
The path.
Return Value
The parse.


ToString Method

ToString Method
Namespaces ► Sitecore.Data.Serialization ► ItemReference ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


ItemSynchronization Class

ItemSynchronization Class
Namespaces ► Sitecore.Data.Serialization ► ItemSynchronization
Implements Item <-> File synchronization
Declaration Syntax
C#
public static class ItemSynchronization
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BuildSyncItem(Item) | Builds the dump item object from item.
 | PasteSyncItem(SyncItem, LoadOptions) | Pastes SyncItem into the database.
 | ReadItem(TextReader) | Reads the item from TextReader.
 | ReadItem(TextReader, LoadOptions) | Reads the item from TextReader.
 | WriteItem(Item, TextWriter) | Writes the item to TextWriter.
Inheritance Hierarchy
Object
ItemSynchronization


BuildSyncItem Method (item)

BuildSyncItem Method (item)
Namespaces ► Sitecore.Data.Serialization ► ItemSynchronization ► BuildSyncItem(Item)
Builds the dump item object from item.
Declaration Syntax
C#
public static SyncItem BuildSyncItem(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The dump item.


PasteSyncItem Method (syncItem, options)

PasteSyncItem Method (syncItem, options)
Namespaces ► Sitecore.Data.Serialization ► ItemSynchronization ► PasteSyncItem(SyncItem, LoadOptions)
Pastes SyncItem into the database.
Declaration Syntax
C#
public static Item PasteSyncItem(
    SyncItem syncItem,
    LoadOptions options
)
Parameters
syncItem (SyncItem)
The sync item.
options (LoadOptions)
The options.
Return Value
The sync item.


ReadItem Method

ReadItem Method
Namespaces ► Sitecore.Data.Serialization ► ItemSynchronization ► ReadItem()()()
Members
Icon | Member | Description
 | ReadItem(TextReader) | Reads the item from TextReader.
 | ReadItem(TextReader, LoadOptions) | Reads the item from TextReader.


ReadItem Method (reader)

ReadItem Method (reader)
Namespaces ► Sitecore.Data.Serialization ► ItemSynchronization ► ReadItem(TextReader)
Reads the item from TextReader.
Declaration Syntax
C#
public static Item ReadItem(
    TextReader reader
)
Parameters
reader (TextReader)
The reader.
Return Value
The item.


ReadItem Method (reader, options)

ReadItem Method (reader, options)
Namespaces ► Sitecore.Data.Serialization ► ItemSynchronization ► ReadItem(TextReader, LoadOptions)
Reads the item from TextReader.
Declaration Syntax
C#
public static Item ReadItem(
    TextReader reader,
    LoadOptions options
)
Parameters
reader (TextReader)
The reader.
options (LoadOptions)
The options.
Return Value
The item.


WriteItem Method (item, writer)

WriteItem Method (item, writer)
Namespaces ► Sitecore.Data.Serialization ► ItemSynchronization ► WriteItem(Item, TextWriter)
Writes the item to TextWriter.
Declaration Syntax
C#
public static void WriteItem(
    Item item,
    TextWriter writer
)
Parameters
item (Item)
The item.
writer (TextWriter)
The writer.


LoadOptions Class

LoadOptions Class
Namespaces ► Sitecore.Data.Serialization ► LoadOptions
Specifies operation options when loading data from dumped database.
Declaration Syntax
C#
public class LoadOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoadOptions()()() | Initializes a new instance of the LoadOptions class.
 | LoadOptions(Database) | Creates LoadOptions instance tied to a database.
 | LoadOptions(LoadOptions) | Initializes a new instance of the LoadOptions class.
 | LoadOptions(Database, String) | Initializes a new instance of the LoadOptions class tied to a specific database and a custom serialization root.
 | Database | Database to use when loading data
 | DisableEvents | Specifies whether database events should be suppressed when loading (which makes it much faster and is the default).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | ForceUpdate | Gets or sets a value indicating whether to clean all local modifications on the update.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Root | Custom serialization root for load operation.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseNewID | Gets or sets a value indicating whether the to use new IDs always when inserting new items.
Inheritance Hierarchy
Object
LoadOptions


LoadOptions Constructor

LoadOptions Constructor
Namespaces ► Sitecore.Data.Serialization ► LoadOptions ► LoadOptions()()()
Members
Icon | Member | Description
 | LoadOptions()()() | Initializes a new instance of the LoadOptions class.
 | LoadOptions(Database) | Creates LoadOptions instance tied to a database.
 | LoadOptions(LoadOptions) | Initializes a new instance of the LoadOptions class.
 | LoadOptions(Database, String) | Initializes a new instance of the LoadOptions class tied to a specific database and a custom serialization root.


LoadOptions Constructor

LoadOptions Constructor
Namespaces ► Sitecore.Data.Serialization ► LoadOptions ► LoadOptions()()()
Initializes a new instance of the LoadOptions class.
Declaration Syntax
C#
public LoadOptions()


LoadOptions Constructor (database)

LoadOptions Constructor (database)
Namespaces ► Sitecore.Data.Serialization ► LoadOptions ► LoadOptions(Database)
Creates LoadOptions instance tied to a database.
Declaration Syntax
C#
public LoadOptions(
    Database database
)
Parameters
database (Database)


LoadOptions Constructor (database, root)

LoadOptions Constructor (database, root)
Namespaces ► Sitecore.Data.Serialization ► LoadOptions ► LoadOptions(Database, String)
Initializes a new instance of the LoadOptions class tied to a specific database and a custom serialization root.
Declaration Syntax
C#
public LoadOptions(
    Database database,
    string root
)
Parameters
database (Database)
The database
root (String)


LoadOptions Constructor (options)

LoadOptions Constructor (options)
Namespaces ► Sitecore.Data.Serialization ► LoadOptions ► LoadOptions(LoadOptions)
Initializes a new instance of the LoadOptions class.
Declaration Syntax
C#
public LoadOptions(
    LoadOptions options
)
Parameters
options (LoadOptions)
The options.


Database Property

Database Property
Namespaces ► Sitecore.Data.Serialization ► LoadOptions ► Database
Database to use when loading data
Declaration Syntax
C#
public Database Database { get; set; }


DisableEvents Property

DisableEvents Property
Namespaces ► Sitecore.Data.Serialization ► LoadOptions ► DisableEvents
Specifies whether database events should be suppressed when loading (which makes it much faster and is the default).
Declaration Syntax
C#
public bool DisableEvents { get; set; }


ForceUpdate Property

ForceUpdate Property
Namespaces ► Sitecore.Data.Serialization ► LoadOptions ► ForceUpdate
Gets or sets a value indicating whether to clean all local modifications on the update.
Declaration Syntax
C#
public bool ForceUpdate { get; set; }
Value
true if the LoadOptions forces the update; otherwise, false.


Root Property

Root Property
Namespaces ► Sitecore.Data.Serialization ► LoadOptions ► Root
Custom serialization root for load operation.
Declaration Syntax
C#
public string Root { get; set; }


UseNewID Property

UseNewID Property
Namespaces ► Sitecore.Data.Serialization ► LoadOptions ► UseNewID
Gets or sets a value indicating whether the to use new IDs always when inserting new items.
Declaration Syntax
C#
public bool UseNewID { get; set; }
Value
true if new IDs should be used; otherwise, false.


Manager Class

Manager Class
Namespaces ► Sitecore.Data.Serialization ► Manager
Facade to all Serialization operations
Declaration Syntax
C#
public static class Manager
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CleanupPath(String) | Cleans up the path removing all obsolete files and folders (which are not in database).
 | CleanupPath(String, Boolean) | Cleans up the path removing all obsolete files and folders (which are not in database).
 | DoLoadTree(String, LoadOptions) | Does the job of loading subtree from specified path.
 | DropItem(String) | Drops the item identified by dump path.
 | DumpItem(Item) | Dumps the item to a corresponding file under dump root.
 | DumpItem(String, Item) | Dumps the item to the specified path.
 | DumpRole(String) | Dumps the role to a corresponding file under dump root.
 | DumpRole(String, Role) | Dumps the role to the specified path.
 | DumpSet(IList<(Of <(IncludeEntry>)>)) | Dumps the specified item set.
 | DumpTemplates(Database) | Dumps templates to disk
 | DumpTree(Item) | Dumps the tree under the dump root.
 | DumpUser(String) | Dumps the user to a corresponding file under dump root.
 | DumpUser(String, MembershipUser) | Dumps the user to the specified path.
 | LoadAllRoles()()() | Loads all roles from serialization.
 | LoadAllUsers()()() | Loads all users from seriazation.
 | LoadItem(String, LoadOptions) | Loads the item from the specified file.
 | LoadRole(String) | Loads the role from the specified file.
 | LoadTree(String, LoadOptions) | Loads the subtree from specified path.
 | LoadUser(String) | Loads the user from the specified file.
Inheritance Hierarchy
Object
Manager


CleanupPath Method

CleanupPath Method
Namespaces ► Sitecore.Data.Serialization ► Manager ► CleanupPath()()()
Members
Icon | Member | Description
 | CleanupPath(String) | Cleans up the path removing all obsolete files and folders (which are not in database).
 | CleanupPath(String, Boolean) | Cleans up the path removing all obsolete files and folders (which are not in database).


CleanupPath Method (path)

CleanupPath Method (path)
Namespaces ► Sitecore.Data.Serialization ► Manager ► CleanupPath(String)
Cleans up the path removing all obsolete files and folders (which are not in database).
Declaration Syntax
C#
public static void CleanupPath(
    string path
)
Parameters
path (String)
The path.


CleanupPath Method (path, recursive)

CleanupPath Method (path, recursive)
Namespaces ► Sitecore.Data.Serialization ► Manager ► CleanupPath(String, Boolean)
Cleans up the path removing all obsolete files and folders (which are not in database).
Declaration Syntax
C#
public static void CleanupPath(
    string path,
    bool recursive
)
Parameters
path (String)
The path.
recursive (Boolean)
if set to true this instance is recursive.


DoLoadTree Method (path, options)

DoLoadTree Method (path, options)
Namespaces ► Sitecore.Data.Serialization ► Manager ► DoLoadTree(String, LoadOptions)
Does the job of loading subtree from specified path.
Declaration Syntax
C#
public static void DoLoadTree(
    string path,
    LoadOptions options
)
Parameters
path (String)
options (LoadOptions)
Exceptions
Exception | Condition
Exception | Exception.


DropItem Method (path)

DropItem Method (path)
Namespaces ► Sitecore.Data.Serialization ► Manager ► DropItem(String)
Drops the item identified by dump path.
Declaration Syntax
C#
public static void DropItem(
    string path
)
Parameters
path (String)
The path.


DumpItem Method

DumpItem Method
Namespaces ► Sitecore.Data.Serialization ► Manager ► DumpItem()()()
Members
Icon | Member | Description
 | DumpItem(Item) | Dumps the item to a corresponding file under dump root.
 | DumpItem(String, Item) | Dumps the item to the specified path.


DumpItem Method (item)

DumpItem Method (item)
Namespaces ► Sitecore.Data.Serialization ► Manager ► DumpItem(Item)
Dumps the item to a corresponding file under dump root.
Declaration Syntax
C#
public static void DumpItem(
    Item item
)
Parameters
item (Item)
The item.


DumpItem Method (path, item)

DumpItem Method (path, item)
Namespaces ► Sitecore.Data.Serialization ► Manager ► DumpItem(String, Item)
Dumps the item to the specified path.
Declaration Syntax
C#
public static void DumpItem(
    string path,
    Item item
)
Parameters
path (String)
The path.
item (Item)
The item.


DumpRole Method

DumpRole Method
Namespaces ► Sitecore.Data.Serialization ► Manager ► DumpRole()()()
Members
Icon | Member | Description
 | DumpRole(String) | Dumps the role to a corresponding file under dump root.
 | DumpRole(String, Role) | Dumps the role to the specified path.


DumpRole Method (rolename)

DumpRole Method (rolename)
Namespaces ► Sitecore.Data.Serialization ► Manager ► DumpRole(String)
Dumps the role to a corresponding file under dump root.
Declaration Syntax
C#
public static void DumpRole(
    string rolename
)
Parameters
rolename (String)
The role name.


DumpRole Method (path, role)

DumpRole Method (path, role)
Namespaces ► Sitecore.Data.Serialization ► Manager ► DumpRole(String, Role)
Dumps the role to the specified path.
Declaration Syntax
C#
public static void DumpRole(
    string path,
    Role role
)
Parameters
path (String)
The path.
role (Role)
The role.


DumpSet Method (entries)

DumpSet Method (entries)
Namespaces ► Sitecore.Data.Serialization ► Manager ► DumpSet(IList<(Of <(IncludeEntry>)>))
Dumps the specified item set.
Declaration Syntax
C#
public static void DumpSet(
    IList<IncludeEntry> entries
)
Parameters
entries (IList<(Of <( IncludeEntry >)>))
A list of IncludeEntry objects describing the set of items to process.


DumpTemplates Method (database)

DumpTemplates Method (database)
Namespaces ► Sitecore.Data.Serialization ► Manager ► DumpTemplates(Database)
Dumps templates to disk
Declaration Syntax
C#
public static void DumpTemplates(
    Database database
)
Parameters
database (Database)
Database to dump templates for


DumpTree Method (item)

DumpTree Method (item)
Namespaces ► Sitecore.Data.Serialization ► Manager ► DumpTree(Item)
Dumps the tree under the dump root.
Declaration Syntax
C#
public static void DumpTree(
    Item item
)
Parameters
item (Item)
The item.


DumpUser Method

DumpUser Method
Namespaces ► Sitecore.Data.Serialization ► Manager ► DumpUser()()()
Members
Icon | Member | Description
 | DumpUser(String) | Dumps the user to a corresponding file under dump root.
 | DumpUser(String, MembershipUser) | Dumps the user to the specified path.


DumpUser Method (username)

DumpUser Method (username)
Namespaces ► Sitecore.Data.Serialization ► Manager ► DumpUser(String)
Dumps the user to a corresponding file under dump root.
Declaration Syntax
C#
public static void DumpUser(
    string username
)
Parameters
username (String)
The user name.


DumpUser Method (path, user)

DumpUser Method (path, user)
Namespaces ► Sitecore.Data.Serialization ► Manager ► DumpUser(String, MembershipUser)
Dumps the user to the specified path.
Declaration Syntax
C#
public static void DumpUser(
    string path,
    MembershipUser user
)
Parameters
path (String)
The path.
user (MembershipUser)
The user.


LoadAllRoles Method

LoadAllRoles Method
Namespaces ► Sitecore.Data.Serialization ► Manager ► LoadAllRoles()()()
Loads all roles from serialization.
Declaration Syntax
C#
public static void LoadAllRoles()


LoadAllUsers Method

LoadAllUsers Method
Namespaces ► Sitecore.Data.Serialization ► Manager ► LoadAllUsers()()()
Loads all users from seriazation.
Declaration Syntax
C#
public static void LoadAllUsers()


LoadItem Method (path, options)

LoadItem Method (path, options)
Namespaces ► Sitecore.Data.Serialization ► Manager ► LoadItem(String, LoadOptions)
Loads the item from the specified file.
Declaration Syntax
C#
public static Item LoadItem(
    string path,
    LoadOptions options
)
Parameters
path (String)
The path.
options (LoadOptions)
Load options.
Return Value
The item.


LoadRole Method (path)

LoadRole Method (path)
Namespaces ► Sitecore.Data.Serialization ► Manager ► LoadRole(String)
Loads the role from the specified file.
Declaration Syntax
C#
public static Role LoadRole(
    string path
)
Parameters
path (String)
The path.
Return Value
The role.


LoadTree Method (path, options)

LoadTree Method (path, options)
Namespaces ► Sitecore.Data.Serialization ► Manager ► LoadTree(String, LoadOptions)
Loads the subtree from specified path.
Declaration Syntax
C#
public static void LoadTree(
    string path,
    LoadOptions options
)
Parameters
path (String)
The path.
options (LoadOptions)
The options.


LoadUser Method (path)

LoadUser Method (path)
Namespaces ► Sitecore.Data.Serialization ► Manager ► LoadUser(String)
Loads the user from the specified file.
Declaration Syntax
C#
public static User LoadUser(
    string path
)
Parameters
path (String)
The path.
Return Value
The user.


Operation Enumeration

Operation Enumeration
Namespaces ► Sitecore.Data.Serialization ► Operation
List of supported operations.
Declaration Syntax
C#
public enum Operation
Members
Member | Description
Updated | Data object has been updated.
Deleted | Data object has been deleted.


PathUtils Class

PathUtils Class
Namespaces ► Sitecore.Data.Serialization ► PathUtils
Utility functions for managing paths inside dump root
Declaration Syntax
C#
public static class PathUtils
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreateWatcher()()() | Creates the FileSystemWatcher for dump root.
 | Extension | Extension for item files.
 | GetDatabaseRoot(String) | Gets the database dump root folder.
 | GetDirectories(String) | Gets the directories.
 | GetDirectoryPath(String) | Gets the directory path from item reference string representation.
 | GetDirectoryPath(String, String) | Gets the directory path from item reference string representation.
 | GetFilePath(String) | Gets the file path from item reference string representation.
 | GetFilePath(UserReference) | Gets the file path from user reference.
 | GetFilePath(RoleReference) | Gets the file path from role reference.
 | GetShortPath(String) | Gets the short variant of specified path.
 | MakeItemPath(String) | Makes the item path from full file path. Uses Root as serialization root.
 | MakeItemPath(String, String) | Makes the item path from full file path.
 | RoleExtension | Extension for role files.
 | Root | Dump root folder.
 | StripPath(String) | Removes item file extension from the filePath.
 | UnmapItemPath(String, String) | Unmaps the item path, expanding any junction points.
 | UserExtension | Extension for user files.
Inheritance Hierarchy
Object
PathUtils


CreateWatcher Method

CreateWatcher Method
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► CreateWatcher()()()
Creates the FileSystemWatcher for dump root.
Declaration Syntax
C#
public static FileSystemWatcher CreateWatcher()
Return Value
The watcher.


Extension Field

Extension Field
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► Extension
Extension for item files.
Declaration Syntax
C#
public static readonly string Extension


GetDatabaseRoot Method (databaseName)

GetDatabaseRoot Method (databaseName)
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► GetDatabaseRoot(String)
Gets the database dump root folder.
Declaration Syntax
C#
public static string GetDatabaseRoot(
    string databaseName
)
Parameters
databaseName (String)
Name of the database.
Return Value
Root path of the database dump.


GetDirectories Method (path)

GetDirectories Method (path)
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► GetDirectories(String)
Gets the directories.
Declaration Syntax
C#
public static string[] GetDirectories(
    string path
)
Parameters
path (String)
The path.
Return Value
The directories.


GetDirectoryPath Method

GetDirectoryPath Method
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► GetDirectoryPath()()()
Members
Icon | Member | Description
 | GetDirectoryPath(String) | Gets the directory path from item reference string representation.
 | GetDirectoryPath(String, String) | Gets the directory path from item reference string representation.


GetDirectoryPath Method (itempath)

GetDirectoryPath Method (itempath)
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► GetDirectoryPath(String)
Gets the directory path from item reference string representation.
Declaration Syntax
C#
public static string GetDirectoryPath(
    string itempath
)
Parameters
itempath (String)
The itempath.
Return Value
The directory path.


GetDirectoryPath Method (itempath, root)

GetDirectoryPath Method (itempath, root)
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► GetDirectoryPath(String, String)
Gets the directory path from item reference string representation.
Declaration Syntax
C#
public static string GetDirectoryPath(
    string itempath,
    string root
)
Parameters
itempath (String)
The itempath.
root (String)
Overridden serialization root.
Return Value
The directory path.


GetFilePath Method

GetFilePath Method
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► GetFilePath()()()
Members
Icon | Member | Description
 | GetFilePath(String) | Gets the file path from item reference string representation.
 | GetFilePath(UserReference) | Gets the file path from user reference.
 | GetFilePath(RoleReference) | Gets the file path from role reference.


GetFilePath Method (roleReference)

GetFilePath Method (roleReference)
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► GetFilePath(RoleReference)
Gets the file path from role reference.
Declaration Syntax
C#
public static string GetFilePath(
    RoleReference roleReference
)
Parameters
roleReference (RoleReference)
The role reference.
Return Value
The file path.


GetFilePath Method (userReference)

GetFilePath Method (userReference)
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► GetFilePath(UserReference)
Gets the file path from user reference.
Declaration Syntax
C#
public static string GetFilePath(
    UserReference userReference
)
Parameters
userReference (UserReference)
The user reference.
Return Value
The file path.


GetFilePath Method (itempath)

GetFilePath Method (itempath)
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► GetFilePath(String)
Gets the file path from item reference string representation.
Declaration Syntax
C#
public static string GetFilePath(
    string itempath
)
Parameters
itempath (String)
The itempath.
Return Value
The file path.


GetShortPath Method (path)

GetShortPath Method (path)
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► GetShortPath(String)
Gets the short variant of specified path.
Declaration Syntax
C#
public static string GetShortPath(
    string path
)
Parameters
path (String)
The path.
Return Value
The short path.
Exceptions
Exception | Condition
Exception | path is not under the root


MakeItemPath Method

MakeItemPath Method
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► MakeItemPath()()()
Members
Icon | Member | Description
 | MakeItemPath(String) | Makes the item path from full file path. Uses Root as serialization root.
 | MakeItemPath(String, String) | Makes the item path from full file path.


MakeItemPath Method (path)

MakeItemPath Method (path)
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► MakeItemPath(String)
Makes the item path from full file path. Uses Root as serialization root.
Declaration Syntax
C#
public static string MakeItemPath(
    string path
)
Parameters
path (String)
The path.
Return Value
The item path.


MakeItemPath Method (path, root)

MakeItemPath Method (path, root)
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► MakeItemPath(String, String)
Makes the item path from full file path.
Declaration Syntax
C#
public static string MakeItemPath(
    string path,
    string root
)
Parameters
path (String)
The path.
root (String)
Overridden serialization root.
Return Value
The item path.


RoleExtension Field

RoleExtension Field
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► RoleExtension
Extension for role files.
Declaration Syntax
C#
public static readonly string RoleExtension


Root Field

Root Field
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► Root
Dump root folder.
Declaration Syntax
C#
public static readonly string Root


StripPath Method (filePath)

StripPath Method (filePath)
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► StripPath(String)
Removes item file extension from the filePath.
Declaration Syntax
C#
public static string StripPath(
    string filePath
)
Parameters
filePath (String)
The path.
Return Value
The filePath.


UnmapItemPath Method (filePath, root)

UnmapItemPath Method (filePath, root)
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► UnmapItemPath(String, String)
Unmaps the item path, expanding any junction points.
Declaration Syntax
C#
public static string UnmapItemPath(
    string filePath,
    string root
)
Parameters
filePath (String)
The file path.
root (String)
root
Return Value
The item path.
Exceptions
Exception | Condition
Exception | File path is not under dump root


UserExtension Field

UserExtension Field
Namespaces ► Sitecore.Data.Serialization ► PathUtils ► UserExtension
Extension for user files.
Declaration Syntax
C#
public static readonly string UserExtension


ShadowWriter Class

ShadowWriter Class
Namespaces ► Sitecore.Data.Serialization ► ShadowWriter
Encapsulates background process of synchronizing filesystem with the database.
Declaration Syntax
C#
public static class ShadowWriter
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PutItem(Operation, Item, Item) | Puts the item to the operation queue
 | Terminate()()() | Terminates this instance.
Inheritance Hierarchy
Object
ShadowWriter


PutItem Method (operation, item, parent)

PutItem Method (operation, item, parent)
Namespaces ► Sitecore.Data.Serialization ► ShadowWriter ► PutItem(Operation, Item, Item)
Puts the item to the operation queue
Declaration Syntax
C#
public static void PutItem(
    Operation operation,
    Item item,
    Item parent
)
Parameters
operation (Operation)
The operation.
item (Item)
The item.
parent (Item)
The parent.


Terminate Method

Terminate Method
Namespaces ► Sitecore.Data.Serialization ► ShadowWriter ► Terminate()()()
Terminates this instance.
Declaration Syntax
C#
public static void Terminate()


SqlConnectionFactory Class

SqlConnectionFactory Class
Namespaces ► Sitecore.Data.Serialization ► SqlConnectionFactory
Description of SqlConnectionFactory.
Declaration Syntax
C#
public class SqlConnectionFactory : IDataConnectionFactory
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlConnectionFactory(String) | Initializes a new instance of SqlConnectionFactory.
 | ConnectionString | Gets the connection string for this database connection.
 | CreateApi()()() | See DataConnectionFactory.CreateApi.
 | CreateProvider()()() | See DataConnectionFactory.CreateProvider.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SqlConnectionFactory


SqlConnectionFactory Constructor (connectionString)

SqlConnectionFactory Constructor (connectionString)
Namespaces ► Sitecore.Data.Serialization ► SqlConnectionFactory ► SqlConnectionFactory(String)
Initializes a new instance of SqlConnectionFactory.
Declaration Syntax
C#
public SqlConnectionFactory(
    string connectionString
)
Parameters
connectionString (String)
Connection string to use


ConnectionString Property

ConnectionString Property
Namespaces ► Sitecore.Data.Serialization ► SqlConnectionFactory ► ConnectionString
Gets the connection string for this database connection.
Declaration Syntax
C#
public string ConnectionString { get; }
Value
The connection string for this connection


CreateApi Method

CreateApi Method
Namespaces ► Sitecore.Data.Serialization ► SqlConnectionFactory ► CreateApi()()()
See DataConnectionFactory.CreateApi.
Declaration Syntax
C#
public SqlDataApi CreateApi()
Return Value


CreateProvider Method

CreateProvider Method
Namespaces ► Sitecore.Data.Serialization ► SqlConnectionFactory ► CreateProvider()()()
See DataConnectionFactory.CreateProvider.
Declaration Syntax
C#
public DataProvider CreateProvider()
Return Value


SqlServerAdminConnection Class

SqlServerAdminConnection Class
Namespaces ► Sitecore.Data.Serialization ► SqlServerAdminConnection
Description of DbAdminConnection.
Declaration Syntax
C#
public class SqlServerAdminConnection : IDbAdminConnection
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SqlServerAdminConnection(String) | Initializes new instance of administrative connection
 | CreateDatabase(String) | Creates a new database with the specified names
 | CreateDatabase(String, String) | Creates database with a specific name
 | Detach(String) | Detach database to unlock file;
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConnectionFactory(String) | Returns connection object factory for specific database
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SqlServerAdminConnection


SqlServerAdminConnection Constructor (connectionString)

SqlServerAdminConnection Constructor (connectionString)
Namespaces ► Sitecore.Data.Serialization ► SqlServerAdminConnection ► SqlServerAdminConnection(String)
Initializes new instance of administrative connection
Declaration Syntax
C#
public SqlServerAdminConnection(
    string connectionString
)
Parameters
connectionString (String)
Connection string to the master database


CreateDatabase Method

CreateDatabase Method
Namespaces ► Sitecore.Data.Serialization ► SqlServerAdminConnection ► CreateDatabase()()()
Members
Icon | Member | Description
 | CreateDatabase(String) | Creates a new database with the specified names
 | CreateDatabase(String, String) | Creates database with a specific name


CreateDatabase Method (databaseName)

CreateDatabase Method (databaseName)
Namespaces ► Sitecore.Data.Serialization ► SqlServerAdminConnection ► CreateDatabase(String)
Creates a new database with the specified names
Declaration Syntax
C#
public void CreateDatabase(
    string databaseName
)
Parameters
databaseName (String)
Name of the database


CreateDatabase Method (databaseName, primaryFileName)

CreateDatabase Method (databaseName, primaryFileName)
Namespaces ► Sitecore.Data.Serialization ► SqlServerAdminConnection ► CreateDatabase(String, String)
Creates database with a specific name
Declaration Syntax
C#
public void CreateDatabase(
    string databaseName,
    string primaryFileName
)
Parameters
databaseName (String)
Name of the database
primaryFileName (String)
File to strore the database


Detach Method (databaseName)

Detach Method (databaseName)
Namespaces ► Sitecore.Data.Serialization ► SqlServerAdminConnection ► Detach(String)
Detach database to unlock file;
Declaration Syntax
C#
public void Detach(
    string databaseName
)
Parameters
databaseName (String)
Name of the database


GetConnectionFactory Method (databaseName)

GetConnectionFactory Method (databaseName)
Namespaces ► Sitecore.Data.Serialization ► SqlServerAdminConnection ► GetConnectionFactory(String)
Returns connection object factory for specific database
Declaration Syntax
C#
public IDataConnectionFactory GetConnectionFactory(
    string databaseName
)
Parameters
databaseName (String)
Name of the database
Return Value
IDataConnectionFactory implementation pointing to the database


Sitecore.Data.Serialization.ObjectModel Namespace

Sitecore.Data.Serialization.ObjectModel Namespace
Namespaces ► Sitecore.Data.Serialization.ObjectModel
Declaration Syntax
C#
namespace Sitecore.Data.Serialization.ObjectModel
Types
All Types Classes
Icon | Type | Description
 | SerializationUtils | Low-level formatting routines used when dumping items to text files and parsing back
 | SyncField | Represents item field in ItemDom
 | SyncItem | Represents Sitecore item in ItemDom.
 | SyncVersion | Represents item version in ItemDom
 | Tokenizer | Adapter for TextReader, convenient for line-based parsing.
 | ValuesDictionary | Encapsulates dictionary of field values


SerializationUtils Class

SerializationUtils Class
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SerializationUtils
Low-level formatting routines used when dumping items to text files and parsing back
Declaration Syntax
C#
public static class SerializationUtils
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsItemSerialization(String) | Checks whether file is itemsync file.
Inheritance Hierarchy
Object
SerializationUtils


IsItemSerialization Method (filePath)

IsItemSerialization Method (filePath)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SerializationUtils ► IsItemSerialization(String)
Checks whether file is itemsync file.
Declaration Syntax
C#
public static bool IsItemSerialization(
    string filePath
)
Parameters
filePath (String)
Path to the file
Return Value
true if file was generated by itemsync, false otherwise.


SyncField Class

SyncField Class
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncField
Represents item field in ItemDom
Declaration Syntax
C#
public class SyncField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SyncField()()() | Initializes a new instance of the SyncField class
 | BuildField(String, String, String, String, Boolean) | Builds the field.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldID | Gets or sets the field ID.
 | FieldKey | Gets or sets the field key.
 | FieldName | Gets or sets the name of the field.
 | FieldValue | Gets or sets the field value.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadField(Tokenizer) | Reads the field.
 | Serialize(TextWriter) | Serializes field to the specified writer.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SyncField


SyncField Constructor

SyncField Constructor
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncField ► SyncField()()()
Initializes a new instance of the SyncField class
Declaration Syntax
C#
public SyncField()


BuildField Method (fieldID, fieldName, fieldKey, fieldValue, hasValue)

BuildField Method (fieldID, fieldName, fieldKey, fieldValue, hasValue)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncField ► BuildField(String, String, String, String, Boolean)
Builds the field.
Declaration Syntax
C#
public static SyncField BuildField(
    string fieldID,
    string fieldName,
    string fieldKey,
    string fieldValue,
    bool hasValue
)
Parameters
fieldID (String)
The field ID.
fieldName (String)
Name of the field.
fieldKey (String)
The field key.
fieldValue (String)
The field value.
hasValue (Boolean)
if set to true this instance is has value.
Return Value
The field.


FieldID Property

FieldID Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncField ► FieldID
Gets or sets the field ID.
Declaration Syntax
C#
public string FieldID { get; set; }
Value
The field ID.


FieldKey Property

FieldKey Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncField ► FieldKey
Gets or sets the field key.
Declaration Syntax
C#
public string FieldKey { get; set; }
Value
The field key.


FieldName Property

FieldName Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncField ► FieldName
Gets or sets the name of the field.
Declaration Syntax
C#
public string FieldName { get; set; }
Value
The name of the field.


FieldValue Property

FieldValue Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncField ► FieldValue
Gets or sets the field value.
Declaration Syntax
C#
public string FieldValue { get; set; }
Value
The field value.


ReadField Method (reader)

ReadField Method (reader)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncField ► ReadField(Tokenizer)
Reads the field.
Declaration Syntax
C#
public static SyncField ReadField(
    Tokenizer reader
)
Parameters
reader (Tokenizer)
The reader.
Return Value
The field.
Exceptions
Exception | Condition
Exception | Exception.


Serialize Method (writer)

Serialize Method (writer)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncField ► Serialize(TextWriter)
Serializes field to the specified writer.
Declaration Syntax
C#
public void Serialize(
    TextWriter writer
)
Parameters
writer (TextWriter)
The writer.


SyncItem Class

SyncItem Class
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem
Represents Sitecore item in ItemDom.
Declaration Syntax
C#
public class SyncItem
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SyncItem()()() | Initializes a new instance of the SyncItem class
 | AddSharedField(String, String, String, String, Boolean) | Adds the shared field.
 | AddVersion(String, String, String) | Adds the version.
 | BranchId | Gets or sets the branch id.
 | DatabaseName | Gets or sets the name of the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatVersion | Version of item dump file format.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLatestVersions()()() | Gets the latest versions.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the item ID.
 | ItemPath | Gets or sets the item path.
 | MasterID | Gets or sets the master ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name.
 | ParentID | Gets or sets the parent ID.
 | ReadItem(Tokenizer) | Reads the item.
 | ReadItem(Tokenizer, Boolean) | Reads the item from a Tokenizer.
 | RemoveField(String) | Remove either shared field from item or versioned field from all versions.
 | RemoveSharedField(String) | Remove shared field information from the version
 | RemoveVersion(String, String) | Remove version by language and versionNumber
 | RemoveVersions(String) | Remove all versions for specified language
 | Serialize(TextWriter) | Serializes item to the specified writer.
 | SharedFields | Gets the shared fields.
 | SharedValues | Gets the values.
 | TemplateID | Gets or sets the template ID.
 | TemplateName | Gets or sets the name of the template.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Versions | Gets the versions.
Inheritance Hierarchy
Object
SyncItem


SyncItem Constructor

SyncItem Constructor
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► SyncItem()()()
Initializes a new instance of the SyncItem class
Declaration Syntax
C#
public SyncItem()


AddSharedField Method (fieldID, fieldName, fieldKey, fieldValue, hasValue)

AddSharedField Method (fieldID, fieldName, fieldKey, fieldValue, hasValue)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► AddSharedField(String, String, String, String, Boolean)
Adds the shared field.
Declaration Syntax
C#
public SyncField AddSharedField(
    string fieldID,
    string fieldName,
    string fieldKey,
    string fieldValue,
    bool hasValue
)
Parameters
fieldID (String)
The field ID.
fieldName (String)
Name of the field.
fieldKey (String)
The field key.
fieldValue (String)
The field value.
hasValue (Boolean)
if set to true this instance is has value.
Return Value
The shared field.


AddVersion Method (language, version, revision)

AddVersion Method (language, version, revision)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► AddVersion(String, String, String)
Adds the version.
Declaration Syntax
C#
public SyncVersion AddVersion(
    string language,
    string version,
    string revision
)
Parameters
language (String)
The language.
version (String)
The version.
revision (String)
The revision.
Return Value
The version.


BranchId Property

BranchId Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► BranchId
Gets or sets the branch id.
Declaration Syntax
C#
public string BranchId { get; set; }
Value
The branch id.


DatabaseName Property

DatabaseName Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► DatabaseName
Gets or sets the name of the database.
Declaration Syntax
C#
public string DatabaseName { get; set; }
Value
The name of the database.


FormatVersion Field

FormatVersion Field
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► FormatVersion
Version of item dump file format.
Declaration Syntax
C#
public static readonly int FormatVersion


GetLatestVersions Method

GetLatestVersions Method
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► GetLatestVersions()()()
Gets the latest versions.
Declaration Syntax
C#
public IEnumerable<SyncVersion> GetLatestVersions()
Return Value
The latest versions.


ID Property

ID Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► ID
Gets or sets the item ID.
Declaration Syntax
C#
public string ID { get; set; }
Value
The ID.


ItemPath Property

ItemPath Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► ItemPath
Gets or sets the item path.
Declaration Syntax
C#
public string ItemPath { get; set; }
Value
The item path.


MasterID Property

MasterID Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► MasterID
Gets or sets the master ID.
Declaration Syntax
C#
public string MasterID { get; set; }
Value
The master ID.


Name Property

Name Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► Name
Gets or sets the name.
Declaration Syntax
C#
public string Name { get; set; }
Value
The name.


ParentID Property

ParentID Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► ParentID
Gets or sets the parent ID.
Declaration Syntax
C#
public string ParentID { get; set; }
Value
The parent ID.


ReadItem Method

ReadItem Method
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► ReadItem()()()
Members
Icon | Member | Description
 | ReadItem(Tokenizer) | Reads the item.
 | ReadItem(Tokenizer, Boolean) | Reads the item from a Tokenizer.


ReadItem Method (reader)

ReadItem Method (reader)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► ReadItem(Tokenizer)
Reads the item.
Declaration Syntax
C#
public static SyncItem ReadItem(
    Tokenizer reader
)
Parameters
reader (Tokenizer)
The reader.
Return Value
The item.


ReadItem Method (reader, assertVersion)

ReadItem Method (reader, assertVersion)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► ReadItem(Tokenizer, Boolean)
Reads the item from a Tokenizer.
Declaration Syntax
C#
public static SyncItem ReadItem(
    Tokenizer reader,
    bool assertVersion
)
Parameters
reader (Tokenizer)
The reader.
assertVersion (Boolean)
Assert file format version flag.
Return Value
The item.
Exceptions
Exception | Condition
Exception | The file was generated using a newer version of Serialization


RemoveField Method (fieldName)

RemoveField Method (fieldName)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► RemoveField(String)
Remove either shared field from item or versioned field from all versions.
Declaration Syntax
C#
public bool RemoveField(
    string fieldName
)
Parameters
fieldName (String)
field name or ID
Return Value
true if field found and deleted


RemoveSharedField Method (fieldName)

RemoveSharedField Method (fieldName)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► RemoveSharedField(String)
Remove shared field information from the version
Declaration Syntax
C#
public bool RemoveSharedField(
    string fieldName
)
Parameters
fieldName (String)
field name or ID
Return Value
true if field found and deleted


RemoveVersion Method (language, versionNumber)

RemoveVersion Method (language, versionNumber)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► RemoveVersion(String, String)
Remove version by language and versionNumber
Declaration Syntax
C#
public bool RemoveVersion(
    string language,
    string versionNumber
)
Parameters
language (String)
version language
versionNumber (String)
version number
Return Value
true if version found and deleted


RemoveVersions Method (language)

RemoveVersions Method (language)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► RemoveVersions(String)
Remove all versions for specified language
Declaration Syntax
C#
public bool RemoveVersions(
    string language
)
Parameters
language (String)
version language
Return Value
true if versions found and deleted


Serialize Method (writer)

Serialize Method (writer)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► Serialize(TextWriter)
Serializes item to the specified writer.
Declaration Syntax
C#
public void Serialize(
    TextWriter writer
)
Parameters
writer (TextWriter)
The writer.


SharedFields Property

SharedFields Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► SharedFields
Gets the shared fields.
Declaration Syntax
C#
public IList<SyncField> SharedFields { get; }
Value
The shared fields.


SharedValues Property

SharedValues Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► SharedValues
Gets the values.
Declaration Syntax
C#
public ValuesDictionary SharedValues { get; }
Value
The values.


TemplateID Property

TemplateID Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► TemplateID
Gets or sets the template ID.
Declaration Syntax
C#
public string TemplateID { get; set; }
Value
The template ID.


TemplateName Property

TemplateName Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► TemplateName
Gets or sets the name of the template.
Declaration Syntax
C#
public string TemplateName { get; set; }
Value
The name of the template.


Versions Property

Versions Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncItem ► Versions
Gets the versions.
Declaration Syntax
C#
public IList<SyncVersion> Versions { get; }
Value
The versions.


SyncVersion Class

SyncVersion Class
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncVersion
Represents item version in ItemDom
Declaration Syntax
C#
public class SyncVersion
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SyncVersion()()() | Initializes a new instance of the SyncVersion class
 | AddField(String, String, String, String, Boolean) | Adds the field.
 | BuildVersion(String, String, String) | Builds the version.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fields | Gets the fields.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Language | Gets or sets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadVersion(Tokenizer) | Reads the version.
 | RemoveField(String) | Remove field information from the version
 | Revision | Gets or sets the revision.
 | Serialize(TextWriter) | Serializes vesion to the specified writer.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Values | Gets the values.
 | Version | Gets or sets the version.
Inheritance Hierarchy
Object
SyncVersion


SyncVersion Constructor

SyncVersion Constructor
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncVersion ► SyncVersion()()()
Initializes a new instance of the SyncVersion class
Declaration Syntax
C#
public SyncVersion()


AddField Method (fieldID, fieldName, fieldKey, fieldValue, hasValue)

AddField Method (fieldID, fieldName, fieldKey, fieldValue, hasValue)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncVersion ► AddField(String, String, String, String, Boolean)
Adds the field.
Declaration Syntax
C#
public SyncField AddField(
    string fieldID,
    string fieldName,
    string fieldKey,
    string fieldValue,
    bool hasValue
)
Parameters
fieldID (String)
The field ID.
fieldName (String)
Name of the field.
fieldKey (String)
The field key.
fieldValue (String)
The field value.
hasValue (Boolean)
if set to true this instance is has value.
Return Value
The field.


BuildVersion Method (language, version, revision)

BuildVersion Method (language, version, revision)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncVersion ► BuildVersion(String, String, String)
Builds the version.
Declaration Syntax
C#
public static SyncVersion BuildVersion(
    string language,
    string version,
    string revision
)
Parameters
language (String)
The language.
version (String)
The version.
revision (String)
The revision.
Return Value
The version.


Fields Property

Fields Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncVersion ► Fields
Gets the fields.
Declaration Syntax
C#
public IList<SyncField> Fields { get; }
Value
The fields.


Language Property

Language Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncVersion ► Language
Gets or sets the language.
Declaration Syntax
C#
public string Language { get; set; }
Value
The language.


ReadVersion Method (reader)

ReadVersion Method (reader)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncVersion ► ReadVersion(Tokenizer)
Reads the version.
Declaration Syntax
C#
public static SyncVersion ReadVersion(
    Tokenizer reader
)
Parameters
reader (Tokenizer)
The reader.
Return Value
The version.
Exceptions
Exception | Condition
Exception | Exception.


RemoveField Method (fieldName)

RemoveField Method (fieldName)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncVersion ► RemoveField(String)
Remove field information from the version
Declaration Syntax
C#
public bool RemoveField(
    string fieldName
)
Parameters
fieldName (String)
field name or ID
Return Value
true if field found and deleted


Revision Property

Revision Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncVersion ► Revision
Gets or sets the revision.
Declaration Syntax
C#
public string Revision { get; set; }
Value
The revision.


Serialize Method (writer)

Serialize Method (writer)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncVersion ► Serialize(TextWriter)
Serializes vesion to the specified writer.
Declaration Syntax
C#
public void Serialize(
    TextWriter writer
)
Parameters
writer (TextWriter)
The writer.


Values Property

Values Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncVersion ► Values
Gets the values.
Declaration Syntax
C#
public ValuesDictionary Values { get; }
Value
The values.


Version Property

Version Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► SyncVersion ► Version
Gets or sets the version.
Declaration Syntax
C#
public string Version { get; set; }
Value
The version.


Tokenizer Class

Tokenizer Class
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► Tokenizer
Adapter for TextReader, convenient for line-based parsing.
Declaration Syntax
C#
public class Tokenizer
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Tokenizer(TextReader) | Initializes a new instance of the Tokenizer class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Line | Gets the line.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextLine()()() | Moves to the next line.
 | Reader | Gets the reader.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Tokenizer


Tokenizer Constructor (reader)

Tokenizer Constructor (reader)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► Tokenizer ► Tokenizer(TextReader)
Initializes a new instance of the Tokenizer class.
Declaration Syntax
C#
public Tokenizer(
    TextReader reader
)
Parameters
reader (TextReader)
The reader.


Line Property

Line Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► Tokenizer ► Line
Gets the line.
Declaration Syntax
C#
public string Line { get; }
Value
The line.


NextLine Method

NextLine Method
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► Tokenizer ► NextLine()()()
Moves to the next line.
Declaration Syntax
C#
public string NextLine()
Return Value
The line.


Reader Property

Reader Property
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► Tokenizer ► Reader
Gets the reader.
Declaration Syntax
C#
public TextReader Reader { get; }
Value
The reader.


ValuesDictionary Class

ValuesDictionary Class
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► ValuesDictionary
Encapsulates dictionary of field values
Declaration Syntax
C#
public class ValuesDictionary
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValuesDictionary(SyncVersion) | Initializes a new instance of the ValuesDictionary class.
 | ValuesDictionary(IEnumerable<(Of <(SyncField>)>)) | Initializes a new instance of the ValuesDictionary class.
 | Add(SyncField) | Adds the specified field.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets the String with the specified id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ValuesDictionary


ValuesDictionary Constructor

ValuesDictionary Constructor
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► ValuesDictionary ► ValuesDictionary()()()
Members
Icon | Member | Description
 | ValuesDictionary(SyncVersion) | Initializes a new instance of the ValuesDictionary class.
 | ValuesDictionary(IEnumerable<(Of <(SyncField>)>)) | Initializes a new instance of the ValuesDictionary class.


ValuesDictionary Constructor (version)

ValuesDictionary Constructor (version)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► ValuesDictionary ► ValuesDictionary(SyncVersion)
Initializes a new instance of the ValuesDictionary class.
Declaration Syntax
C#
public ValuesDictionary(
    SyncVersion version
)
Parameters
version (SyncVersion)
The version.


ValuesDictionary Constructor (fields)

ValuesDictionary Constructor (fields)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► ValuesDictionary ► ValuesDictionary(IEnumerable<(Of <(SyncField>)>))
Initializes a new instance of the ValuesDictionary class.
Declaration Syntax
C#
public ValuesDictionary(
    IEnumerable<SyncField> fields
)
Parameters
fields (IEnumerable<(Of <( SyncField >)>))
List of fields to create ValuesDictionary from


Add Method (field)

Add Method (field)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► ValuesDictionary ► Add(SyncField)
Adds the specified field.
Declaration Syntax
C#
public void Add(
    SyncField field
)
Parameters
field (SyncField)
The field.


Item Property (id)

Item Property (id)
Namespaces ► Sitecore.Data.Serialization.ObjectModel ► ValuesDictionary ► Item[([(String])])
Gets the String with the specified id.
Declaration Syntax
C#
public string this[
    string id
] { get; }
Parameters
id (String)
Value
The String.


Sitecore.Data.Serialization.Presets Namespace

Sitecore.Data.Serialization.Presets Namespace
Namespaces ► Sitecore.Data.Serialization.Presets
Declaration Syntax
C#
namespace Sitecore.Data.Serialization.Presets
Types
All Types Classes Delegates
Icon | Type | Description
 | ExcludeEntry | Description of ExcludeEntry.
 | IncludeEntry | Description of IncludeEntry.
 | ItemCallback | Item handling callback.
 | PresetFactory | Creates Interation entries from XML confguration;


ExcludeEntry Class

ExcludeEntry Class
Namespaces ► Sitecore.Data.Serialization.Presets ► ExcludeEntry
Description of ExcludeEntry.
Declaration Syntax
C#
public class ExcludeEntry
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExcludeEntry()()() | Creates a new instance of ExcludeEntry.
 | ExcludeEntry(String, String) | Creates a new instance of ExcludeEntry
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Include | List of overriding includes
 | Matches(Item) | Checks whether exclude criterium matches the specified item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Sets or gets the type of this exclude entry.
 | Value | Value to match against
Inheritance Hierarchy
Object
ExcludeEntry


ExcludeEntry Constructor

ExcludeEntry Constructor
Namespaces ► Sitecore.Data.Serialization.Presets ► ExcludeEntry ► ExcludeEntry()()()
Members
Icon | Member | Description
 | ExcludeEntry()()() | Creates a new instance of ExcludeEntry.
 | ExcludeEntry(String, String) | Creates a new instance of ExcludeEntry


ExcludeEntry Constructor

ExcludeEntry Constructor
Namespaces ► Sitecore.Data.Serialization.Presets ► ExcludeEntry ► ExcludeEntry()()()
Creates a new instance of ExcludeEntry.
Declaration Syntax
C#
public ExcludeEntry()


ExcludeEntry Constructor (type, value)

ExcludeEntry Constructor (type, value)
Namespaces ► Sitecore.Data.Serialization.Presets ► ExcludeEntry ► ExcludeEntry(String, String)
Creates a new instance of ExcludeEntry
Declaration Syntax
C#
public ExcludeEntry(
    string type,
    string value
)
Parameters
type (String)
value (String)


Include Property

Include Property
Namespaces ► Sitecore.Data.Serialization.Presets ► ExcludeEntry ► Include
List of overriding includes
Declaration Syntax
C#
public List<IncludeEntry> Include { get; }


Matches Method (item)

Matches Method (item)
Namespaces ► Sitecore.Data.Serialization.Presets ► ExcludeEntry ► Matches(Item)
Checks whether exclude criterium matches the specified item.
Declaration Syntax
C#
public bool Matches(
    Item item
)
Parameters
item (Item)
Return Value


Type Property

Type Property
Namespaces ► Sitecore.Data.Serialization.Presets ► ExcludeEntry ► Type
Sets or gets the type of this exclude entry.
Declaration Syntax
C#
public string Type { get; set; }


Value Property

Value Property
Namespaces ► Sitecore.Data.Serialization.Presets ► ExcludeEntry ► Value
Value to match against
Declaration Syntax
C#
public string Value { get; set; }


IncludeEntry Class

IncludeEntry Class
Namespaces ► Sitecore.Data.Serialization.Presets ► IncludeEntry
Description of IncludeEntry.
Declaration Syntax
C#
public class IncludeEntry
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IncludeEntry()()() | Creates a new instance of IncludeEntry.
 | IncludeEntry(String) | Creates a new instance of IncludeEntry.
 | IncludeEntry(String, String) | Creates a new instance of IncludeEntry.
 | Database | Name of the database to get items in.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exclude | List of exclusion criteria. Recursion stops at excluded items.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Path to the root item.
 | Process(ItemCallback) | Invokes specified callback on all items
 | Process(ItemCallback, IncludeEntry) |
 | Skip | List of skip criteria. Descendants are iterated bu the item itself i
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
IncludeEntry


IncludeEntry Constructor

IncludeEntry Constructor
Namespaces ► Sitecore.Data.Serialization.Presets ► IncludeEntry ► IncludeEntry()()()
Members
Icon | Member | Description
 | IncludeEntry()()() | Creates a new instance of IncludeEntry.
 | IncludeEntry(String) | Creates a new instance of IncludeEntry.
 | IncludeEntry(String, String) | Creates a new instance of IncludeEntry.


IncludeEntry Constructor

IncludeEntry Constructor
Namespaces ► Sitecore.Data.Serialization.Presets ► IncludeEntry ► IncludeEntry()()()
Creates a new instance of IncludeEntry.
Declaration Syntax
C#
public IncludeEntry()


IncludeEntry Constructor (path)

IncludeEntry Constructor (path)
Namespaces ► Sitecore.Data.Serialization.Presets ► IncludeEntry ► IncludeEntry(String)
Creates a new instance of IncludeEntry.
Declaration Syntax
C#
public IncludeEntry(
    string path
)
Parameters
path (String)
Path to the root item to iterate.


IncludeEntry Constructor (database, path)

IncludeEntry Constructor (database, path)
Namespaces ► Sitecore.Data.Serialization.Presets ► IncludeEntry ► IncludeEntry(String, String)
Creates a new instance of IncludeEntry.
Declaration Syntax
C#
public IncludeEntry(
    string database,
    string path
)
Parameters
database (String)
Name of the database.
path (String)
Path to the root item to iterate.


Database Property

Database Property
Namespaces ► Sitecore.Data.Serialization.Presets ► IncludeEntry ► Database
Name of the database to get items in.
Declaration Syntax
C#
public string Database { get; set; }


Exclude Property

Exclude Property
Namespaces ► Sitecore.Data.Serialization.Presets ► IncludeEntry ► Exclude
List of exclusion criteria. Recursion stops at excluded items.
Declaration Syntax
C#
public List<ExcludeEntry> Exclude { get; }


Path Property

Path Property
Namespaces ► Sitecore.Data.Serialization.Presets ► IncludeEntry ► Path
Path to the root item.
Declaration Syntax
C#
public string Path { get; set; }


Process Method

Process Method
Namespaces ► Sitecore.Data.Serialization.Presets ► IncludeEntry ► Process()()()
Members
Icon | Member | Description
 | Process(ItemCallback) | Invokes specified callback on all items
 | Process(ItemCallback, IncludeEntry) |


Process Method (callback)

Process Method (callback)
Namespaces ► Sitecore.Data.Serialization.Presets ► IncludeEntry ► Process(ItemCallback)
Invokes specified callback on all items
Declaration Syntax
C#
public void Process(
    ItemCallback callback
)
Parameters
callback (ItemCallback)


Process Method (callback, parent)

Process Method (callback, parent)
Namespaces ► Sitecore.Data.Serialization.Presets ► IncludeEntry ► Process(ItemCallback, IncludeEntry)
Declaration Syntax
C#
public void Process(
    ItemCallback callback,
    IncludeEntry parent
)
Parameters
callback (ItemCallback)
parent (IncludeEntry)


Skip Property

Skip Property
Namespaces ► Sitecore.Data.Serialization.Presets ► IncludeEntry ► Skip
List of skip criteria. Descendants are iterated bu the item itself i
Declaration Syntax
C#
public List<ExcludeEntry> Skip { get; }


ItemCallback Delegate

ItemCallback Delegate
Namespaces ► Sitecore.Data.Serialization.Presets ► ItemCallback
Item handling callback.
Declaration Syntax
C#
public delegate void ItemCallback(
    Item item
)
Parameters
item (Item)


PresetFactory Class

PresetFactory Class
Namespaces ► Sitecore.Data.Serialization.Presets ► PresetFactory
Creates Interation entries from XML confguration;
Declaration Syntax
C#
public static class PresetFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Create(XmlNode) | Creates a list of IncludeEntries from XML configuration
Inheritance Hierarchy
Object
PresetFactory


Create Method (configuration)

Create Method (configuration)
Namespaces ► Sitecore.Data.Serialization.Presets ► PresetFactory ► Create(XmlNode)
Creates a list of IncludeEntries from XML configuration
Declaration Syntax
C#
public static IList<IncludeEntry> Create(
    XmlNode configuration
)
Parameters
configuration (XmlNode)
Return Value


Sitecore.Data.Serialization.Templates Namespace

Sitecore.Data.Serialization.Templates Namespace
Namespaces ► Sitecore.Data.Serialization.Templates
Declaration Syntax
C#
namespace Sitecore.Data.Serialization.Templates
Types
All Types Classes
Icon | Type | Description
 | SerializationTemplateProvider | Class to load templates directly from ISync dump and to be used as a template provider


SerializationTemplateProvider Class

SerializationTemplateProvider Class
Namespaces ► Sitecore.Data.Serialization.Templates ► SerializationTemplateProvider
Class to load templates directly from ISync dump and to be used as a template provider
Declaration Syntax
C#
public class SerializationTemplateProvider : DataProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SerializationTemplateProvider(String) | Create SyncTemplateManager
 | AddField(TemplateSection..::.Builder, SyncItem) | Add field to the template section
 | AddSection(Template..::.Builder, SyncItem, LoadOptions) | Add section to template
 | AddToPublishQueue(ID, String, DateTime, CallContext) | Adds an item to the publish queue. (Inherited from DataProvider.)
 | AddVersion(ItemDefinition, VersionUri, CallContext) | Adds a version to an item. (Inherited from DataProvider.)
 | BlobStreamExists(Guid, CallContext) | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
 | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
 | ChangeFieldSharing(TemplateField, TemplateFieldSharing, CallContext) | Changes the type of field sharing for a single field. (Inherited from DataProvider.)
 | ChangeTemplate(ItemDefinition, TemplateChangeList, CallContext) | Changes the template of an item. (Inherited from DataProvider.)
 | CleanupDatabase(CallContext) | Cleans up the database. (Inherited from DataProvider.)
 | CleanupPublishQueue(DateTime, CallContext) | Cleans up the publish queue. (Inherited from DataProvider.)
 | CopyItem(ItemDefinition, ItemDefinition, String, ID, CallContext) | Copies an item. (Inherited from DataProvider.)
 | CreateItem(ID, String, ID, ItemDefinition, CallContext) | Creates a item. (Inherited from DataProvider.)
 | DeleteItem(ItemDefinition, CallContext) | Deletes an item. (Inherited from DataProvider.)
 | Disable | Disables a method. (Inherited from DataProvider.)
 | DisableGroup | Disables a group. (Inherited from DataProvider.)
 | DoLoadTemplates(String, LoadOptions, TemplateCollection) | Recursively load templates from ISync dump tree
 | Enable | Enables a method. (Inherited from DataProvider.)
 | EnableGroup | Enables a group. (Inherited from DataProvider.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBlobStream(Guid, CallContext) | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
 | GetChildIDs(ItemDefinition, CallContext) | Gets the child ids of an item. (Inherited from DataProvider.)
 | GetDataSize(Int32, Int32) | Gets the size of the data managed by the provider. (Inherited from DataProvider.)
 | GetDictionaryEntryCount()()() | Gets the number of dictionary entries. (Inherited from DataProvider.)
 | GetDirectoryPath(SyncItem, LoadOptions) | Helper method to retrieve correct directory path for item
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemDefinition(ID, CallContext) | Gets the definition of an item. (Inherited from DataProvider.)
 | GetItemFields(ItemDefinition, VersionUri, CallContext) | Gets the fields of a specific item version. (Inherited from DataProvider.)
 | GetItemsInWorkflowState(WorkflowInfo, CallContext) | Gets all items that are in a specific workflow state. (Inherited from DataProvider.)
 | GetItemVersions(ItemDefinition, CallContext) | Gets a list of the available versions of an item. (Inherited from DataProvider.)
 | GetLanguages(CallContext) | Gets a list of all the language that have been defined in the database. (Inherited from DataProvider.)
 | GetParentID(ItemDefinition, CallContext) | Gets the parent ID of an item. (Inherited from DataProvider.)
 | GetProperty(String, CallContext) | Gets a property. (Inherited from DataProvider.)
 | GetPropertyKeys(String, CallContext) | Gets a list of property keys matching a specific prefix. (Inherited from DataProvider.)
 | GetPublishQueue(DateTime, DateTime, CallContext) | Gets the publish queue. (Inherited from DataProvider.)
 | GetRootID(CallContext) | Gets the root ID. (Inherited from DataProvider.)
 | GetTemplateItemIds(CallContext) | Gets the template item ids. (Inherited from DataProvider.)
 | GetTemplates(CallContext) | Get templates from ISync tree (Overrides DataProvider.GetTemplates(CallContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWorkflowInfo(ItemDefinition, VersionUri, CallContext) | Gets the workflow info form an item. (Inherited from DataProvider.)
 | HasChildren(ItemDefinition, CallContext) | Determines whether the specified item definition has children. (Inherited from DataProvider.)
 | IsEnabled(String) | Determines whether the specified method is enabled. (Inherited from DataProvider.)
 | LoadOneLevel(String) | Load SyncItems from 1 level of ISync tree
 | LoadTemplatesFromTree(String, TemplateCollection) | Load templates from ISync dump tree
 | LoadTemplatesFromXmlFile(String, TemplateCollection) | Load templates from templates.xml file
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveItem(ItemDefinition, ItemDefinition, CallContext) | Moves an item (ie. changes its parent). (Inherited from DataProvider.)
 | RemoveLanguageData(Language, CallContext) | Removes a language and all the data using the language from the database. (Inherited from DataProvider.)
 | RemoveProperty(String, Boolean, CallContext) | Removes a property. (Inherited from DataProvider.)
 | RemoveVersion(ItemDefinition, VersionUri, CallContext) | Removes a version from an item. (Inherited from DataProvider.)
 | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
 | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
 | RenameLanguageData(String, String, CallContext) | Renames a language binding. (Inherited from DataProvider.)
 | ResolvePath(String, CallContext) | Resolves the path. (Inherited from DataProvider.)
 | SaveItem(ItemDefinition, ItemChanges, CallContext) | Saves an item. (Inherited from DataProvider.)
 | SelectIDs(String, CallContext) | Selects a set of ids. (Inherited from DataProvider.)
 | SelectSingleID(String, CallContext) | Selects a single ID. (Inherited from DataProvider.)
 | SetBlobStream(Stream, Guid, CallContext) | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
 | SetProperty(String, String, CallContext) | Sets a property. (Inherited from DataProvider.)
 | SetWorkflowInfo(ItemDefinition, VersionUri, WorkflowInfo, CallContext) | Sets the workflow info for an item. (Inherited from DataProvider.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataProvider
 |  | SerializationTemplateProvider


SerializationTemplateProvider Constructor (syncRoot)

SerializationTemplateProvider Constructor (syncRoot)
Namespaces ► Sitecore.Data.Serialization.Templates ► SerializationTemplateProvider ► SerializationTemplateProvider(String)
Create SyncTemplateManager
Declaration Syntax
C#
public SerializationTemplateProvider(
    string syncRoot
)
Parameters
syncRoot (String)
Root of the database dump


AddField Method (sectionBuilder, item)

AddField Method (sectionBuilder, item)
Namespaces ► Sitecore.Data.Serialization.Templates ► SerializationTemplateProvider ► AddField(TemplateSection..::.Builder, SyncItem)
Add field to the template section
Declaration Syntax
C#
protected static void AddField(
    TemplateSection..::.Builder sectionBuilder,
    SyncItem item
)
Parameters
sectionBuilder (TemplateSection..::.Builder)
Section to add field to
item (SyncItem)
SyncItem represent TemplateField


AddSection Method (template, item, options)

AddSection Method (template, item, options)
Namespaces ► Sitecore.Data.Serialization.Templates ► SerializationTemplateProvider ► AddSection(Template..::.Builder, SyncItem, LoadOptions)
Add section to template
Declaration Syntax
C#
protected static void AddSection(
    Template..::.Builder template,
    SyncItem item,
    LoadOptions options
)
Parameters
template (Template..::.Builder)
Template to add section to
item (SyncItem)
SyncItem represent Section
options (LoadOptions)
Used to pass root


DoLoadTemplates Method (path, options, templates)

DoLoadTemplates Method (path, options, templates)
Namespaces ► Sitecore.Data.Serialization.Templates ► SerializationTemplateProvider ► DoLoadTemplates(String, LoadOptions, TemplateCollection)
Recursively load templates from ISync dump tree
Declaration Syntax
C#
protected static void DoLoadTemplates(
    string path,
    LoadOptions options,
    TemplateCollection templates
)
Parameters
path (String)
Path to the folder to load templates from
options (LoadOptions)
Option to pass database root path
templates (TemplateCollection)
TemplateCollection to be filled


GetDirectoryPath Method (item, options)

GetDirectoryPath Method (item, options)
Namespaces ► Sitecore.Data.Serialization.Templates ► SerializationTemplateProvider ► GetDirectoryPath(SyncItem, LoadOptions)
Helper method to retrieve correct directory path for item
Declaration Syntax
C#
protected static string GetDirectoryPath(
    SyncItem item,
    LoadOptions options
)
Parameters
item (SyncItem)
item to retrieve path from
options (LoadOptions)
used to pass root
Return Value
Directory path


GetTemplates Method (context)

GetTemplates Method (context)
Namespaces ► Sitecore.Data.Serialization.Templates ► SerializationTemplateProvider ► GetTemplates(CallContext)
Get templates from ISync tree
Declaration Syntax
C#
public override TemplateCollection GetTemplates(
    CallContext context
)
Parameters
context (CallContext)
not used
Return Value
Loaded templates


LoadOneLevel Method (path)

LoadOneLevel Method (path)
Namespaces ► Sitecore.Data.Serialization.Templates ► SerializationTemplateProvider ► LoadOneLevel(String)
Load SyncItems from 1 level of ISync tree
Declaration Syntax
C#
protected static IList<SyncItem> LoadOneLevel(
    string path
)
Parameters
path (String)
Path to load SyncItems from
Return Value
List of SyncItems


LoadTemplatesFromTree Method (path, templates)

LoadTemplatesFromTree Method (path, templates)
Namespaces ► Sitecore.Data.Serialization.Templates ► SerializationTemplateProvider ► LoadTemplatesFromTree(String, TemplateCollection)
Load templates from ISync dump tree
Declaration Syntax
C#
public static void LoadTemplatesFromTree(
    string path,
    TemplateCollection templates
)
Parameters
path (String)
Root of the database dump
templates (TemplateCollection)
TemplateCollection to be filled


LoadTemplatesFromXmlFile Method (path, templates)

LoadTemplatesFromXmlFile Method (path, templates)
Namespaces ► Sitecore.Data.Serialization.Templates ► SerializationTemplateProvider ► LoadTemplatesFromXmlFile(String, TemplateCollection)
Load templates from templates.xml file
Declaration Syntax
C#
public static bool LoadTemplatesFromXmlFile(
    string path,
    TemplateCollection templates
)
Parameters
path (String)
Database root
templates (TemplateCollection)
Collection to be filled
Return Value
true - in case of success


Sitecore.Data.Sql Namespace

Sitecore.Data.Sql Namespace
Namespaces ► Sitecore.Data.Sql
Declaration Syntax
C#
namespace Sitecore.Data.Sql
Types
All Types Classes Enumerations
Icon | Type | Description
 | SqlBatch | Contructs and executes a series of SQL statements.
 | SqlBuilder | Implements a utility class for handling and executing SQL statements.
 | SqlStatementType | Defines SQL statement types.
 | SqlUtil | Implements a utility class for handling and executing SQL statements.


SqlBatch Class

SqlBatch Class
Namespaces ► Sitecore.Data.Sql ► SqlBatch
Contructs and executes a series of SQL statements.
Declaration Syntax
C#
public class SqlBatch
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlBatch(Boolean) | Creates a new SqlBatch instance.
 | AddArgument(String, Object, Boolean) | Adds an argument.
 | AddBreak()()() | Adds a line break to the text.
 | AddParameter(String, Object) | Adds a parameter.
 | AddParameter(String, Object, Boolean) | Adds a parameter.
 | AddSql(String) | Adds an SQL string.
 | AddVariable(String, String) | Adds a variable.
 | AddVariableParameter(String) | Adds a variable parameter.
 | EndFunctionCall()()() | Ends a function call.
 | EndIf()()() | Ends an if statement.
 | EndProcedureCall()()() | Ends a procedure call.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(String) | Executes the SQL batch.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets the parameters.
 | StartFunctionCall(String, String) | Starts a function call.
 | StartIf(String) | Starts an if statment.
 | StartProcedureCall(String) | Starts a procedure call.
 | Text | Gets the SQL text.
 | Timeout | Gets or sets the timeout.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseTransaction | Gets a value indicating whether to use transactions.
Inheritance Hierarchy
Object
SqlBatch


SqlBatch Constructor (useTransaction)

SqlBatch Constructor (useTransaction)
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► SqlBatch(Boolean)
Creates a new SqlBatch instance.
Declaration Syntax
C#
public SqlBatch(
    bool useTransaction
)
Parameters
useTransaction (Boolean)
Use transaction.


AddArgument Method (name, value, sharedName)

AddArgument Method (name, value, sharedName)
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► AddArgument(String, Object, Boolean)
Adds an argument.
Declaration Syntax
C#
public string AddArgument(
    string name,
    Object value,
    bool sharedName
)
Parameters
name (String)
Name.
value (Object)
Value.
sharedName (Boolean)
Name of the shared.


AddBreak Method

AddBreak Method
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► AddBreak()()()
Adds a line break to the text.
Declaration Syntax
C#
public void AddBreak()


AddParameter Method

AddParameter Method
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► AddParameter()()()
Members
Icon | Member | Description
 | AddParameter(String, Object) | Adds a parameter.
 | AddParameter(String, Object, Boolean) | Adds a parameter.


AddParameter Method (name, value)

AddParameter Method (name, value)
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► AddParameter(String, Object)
Adds a parameter.
Declaration Syntax
C#
public void AddParameter(
    string name,
    Object value
)
Parameters
name (String)
Name.
value (Object)
Value.


AddParameter Method (name, value, sharedName)

AddParameter Method (name, value, sharedName)
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► AddParameter(String, Object, Boolean)
Adds a parameter.
Declaration Syntax
C#
public string AddParameter(
    string name,
    Object value,
    bool sharedName
)
Parameters
name (String)
Name.
value (Object)
Value.
sharedName (Boolean)
Name of the shared.
Return Value


AddSql Method (sql)

AddSql Method (sql)
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► AddSql(String)
Adds an SQL string.
Declaration Syntax
C#
public void AddSql(
    string sql
)
Parameters
sql (String)
SQL.


AddVariable Method (variable, type)

AddVariable Method (variable, type)
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► AddVariable(String, String)
Adds a variable.
Declaration Syntax
C#
public void AddVariable(
    string variable,
    string type
)
Parameters
variable (String)
Variable.
type (String)
Type.


AddVariableParameter Method (variable)

AddVariableParameter Method (variable)
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► AddVariableParameter(String)
Adds a variable parameter.
Declaration Syntax
C#
public void AddVariableParameter(
    string variable
)
Parameters
variable (String)
Variable.


EndFunctionCall Method

EndFunctionCall Method
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► EndFunctionCall()()()
Ends a function call.
Declaration Syntax
C#
public void EndFunctionCall()
Remarks
See Also
EndFunctionCall()()()


EndIf Method

EndIf Method
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► EndIf()()()
Ends an if statement.
Declaration Syntax
C#
public void EndIf()
Remarks
See Also
StartIf(String)


EndProcedureCall Method

EndProcedureCall Method
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► EndProcedureCall()()()
Ends a procedure call.
Declaration Syntax
C#
public void EndProcedureCall()
Remarks
See Also
StartProcedureCall(String)


Execute Method (connectionString)

Execute Method (connectionString)
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► Execute(String)
Executes the SQL batch.
Declaration Syntax
C#
public void Execute(
    string connectionString
)
Parameters
connectionString (String)
Connection string.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► Parameters
Gets the parameters.
Declaration Syntax
C#
public Hashtable Parameters { get; }


StartFunctionCall Method (functionName, targetVariable)

StartFunctionCall Method (functionName, targetVariable)
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► StartFunctionCall(String, String)
Starts a function call.
Declaration Syntax
C#
public void StartFunctionCall(
    string functionName,
    string targetVariable
)
Parameters
functionName (String)
Name of the function.
targetVariable (String)
Target variable.
Remarks
See Also
EndFunctionCall()()()


StartIf Method (condition)

StartIf Method (condition)
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► StartIf(String)
Starts an if statment.
Declaration Syntax
C#
public void StartIf(
    string condition
)
Parameters
condition (String)
Condition.
Remarks
See Also
EndIf()()()


StartProcedureCall Method (procedureName)

StartProcedureCall Method (procedureName)
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► StartProcedureCall(String)
Starts a procedure call.
Declaration Syntax
C#
public void StartProcedureCall(
    string procedureName
)
Parameters
procedureName (String)
Name of the procedure.
Remarks
See Also
EndProcedureCall()()()


Text Property

Text Property
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► Text
Gets the SQL text.
Declaration Syntax
C#
public string Text { get; }


Timeout Property

Timeout Property
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► Timeout
Gets or sets the timeout.
Declaration Syntax
C#
public TimeSpan Timeout { get; set; }


UseTransaction Property

UseTransaction Property
Namespaces ► Sitecore.Data.Sql ► SqlBatch ► UseTransaction
Gets a value indicating whether to use transactions.
Declaration Syntax
C#
public bool UseTransaction { get; }
Value
true if to use transactions; otherwise, false.


SqlBuilder Class

SqlBuilder Class
Namespaces ► Sitecore.Data.Sql ► SqlBuilder
Implements a utility class for handling and executing SQL statements.
Declaration Syntax
C#
public class SqlBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlBuilder(String, SqlStatementType) | Constructs new instance of the SqlBuilder class from a table name and a statement type.
 | SqlBuilder(String, SqlStatementType, TimeSpan) | Constructs new instance of the SqlBuilder class from a table name and a statement type.
 | AddParameter(String, DateTime) | Adds a parameter.
 | AddParameter(String, ID) | Adds a parameter.
 | AddParameter(String, Language) | Adds a parameter.
 | AddParameter(String, Version) | Adds a parameter.
 | AddParameter(String, Object) | Adds a parameter to the parameters list.
 | AddVarRef(String) | Adds the variable reference.
 | AddWhereClause(String) | Adds a "where" clause as a string.
 | CreateCommand(String) | Creates an SQL command object from a connection object.
 | CreateCommand(SqlConnection) | Creates an SQL command object from a connection object.
 | CreateDeleteCommand(SqlCommand) | Creates an SQL Delete command object.
 | CreateInsertCommand(SqlCommand) | Creates an SQL Insert command object.
 | CreateStoredProcedureCommand(SqlCommand) | Creates a Stored Procedure command object.
 | CreateUDFCommand(SqlCommand) | Creates a User Defined Function command object.
 | CreateUpdateCommand(SqlCommand) | Creates an Update command object.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(String) | Executes current SQL command.
 | ExecuteReader(String) | Executes current SQL command and returns a reader.
 | ExecuteScalar(String) | Executes current SQL command.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCommandText()()() | Gets the command text.
 | GetDeleteCommandText()()() | Gets the delete command text.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInsertCommandText()()() | Gets the insert command text.
 | GetStoredProcedureCommandText()()() | Gets the stored procedure command text.
 | GetStringArray(String) | Get a string array of results.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUDFCommandText()()() | Gets the UDF command text.
 | GetUpdateCommandText()()() | Gets the update command text.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StatementType | Gets the statement type.
 | Timeout | Gets or sets the timeout.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

The class is aimed at SQL Servers and uses the native .NET driver for optimal performance. This class will not work with other databases.

Normally only the AddParameter, AddWhereClause and Execute methods are called. The other methods function as utility methods for these methods.

Examples
The following code deletes the company "Alfreds Futterkiste" from the Customers table.
CopyC#
SqlBuilder builder = new SqlBuilder("Customers", SqlStatementType.Delete);
builder.AddWhereClause("CompanyName='Alfreds Futterkiste'");
builder.Execute(myConnectionString);
Remarks
Inheritance Hierarchy
Object
SqlBuilder
See Also
DateUtil
FileUtil
HtmlUtil
SqlUtil
StringUtil
WebUtil
XmlUtil


SqlBuilder Constructor

SqlBuilder Constructor
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► SqlBuilder()()()
Members
Icon | Member | Description
 | SqlBuilder(String, SqlStatementType) | Constructs new instance of the SqlBuilder class from a table name and a statement type.
 | SqlBuilder(String, SqlStatementType, TimeSpan) | Constructs new instance of the SqlBuilder class from a table name and a statement type.


SqlBuilder Constructor (objectName, type)

SqlBuilder Constructor (objectName, type)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► SqlBuilder(String, SqlStatementType)
Constructs new instance of the SqlBuilder class from a table name and a statement type.
Declaration Syntax
C#
public SqlBuilder(
    string objectName,
    SqlStatementType type
)
Parameters
objectName (String)
Name of table.
type (SqlStatementType)
Statement type.
Examples
The following code deletes the company "Alfreds Futterkiste" from the Customers table.
CopyC#
SqlBuilder builder = new SqlBuilder("Customers", SqlStatementType.Delete);
builder.AddWhereClause("CompanyName='Alfreds Futterkiste'");
builder.Execute(myConnectionString);
See Also
SqlStatementType


SqlBuilder Constructor (objectName, type, timeout)

SqlBuilder Constructor (objectName, type, timeout)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► SqlBuilder(String, SqlStatementType, TimeSpan)
Constructs new instance of the SqlBuilder class from a table name and a statement type.
Declaration Syntax
C#
public SqlBuilder(
    string objectName,
    SqlStatementType type,
    TimeSpan timeout
)
Parameters
objectName (String)
Name of table.
type (SqlStatementType)
Statement type.
timeout (TimeSpan)
Command timeout of the SQL call.
Examples
The following code deletes the company "Alfreds Futterkiste" from the Customers table.
CopyC#
SqlBuilder builder = new SqlBuilder("Customers", SqlStatementType.Delete);
builder.AddWhereClause("CompanyName='Alfreds Futterkiste'");
builder.Execute(myConnectionString);
See Also
SqlStatementType


AddParameter Method

AddParameter Method
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► AddParameter()()()
Members
Icon | Member | Description
 | AddParameter(String, DateTime) | Adds a parameter.
 | AddParameter(String, ID) | Adds a parameter.
 | AddParameter(String, Language) | Adds a parameter.
 | AddParameter(String, Version) | Adds a parameter.
 | AddParameter(String, Object) | Adds a parameter to the parameters list.


AddParameter Method (parameterName, parameterValue)

AddParameter Method (parameterName, parameterValue)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► AddParameter(String, ID)
Adds a parameter.
Declaration Syntax
C#
public void AddParameter(
    string parameterName,
    ID parameterValue
)
Parameters
parameterName (String)
Name of the parameter.
parameterValue (ID)
Parameter value.


AddParameter Method (parameterName, parameterValue)

AddParameter Method (parameterName, parameterValue)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► AddParameter(String, Version)
Adds a parameter.
Declaration Syntax
C#
public void AddParameter(
    string parameterName,
    Version parameterValue
)
Parameters
parameterName (String)
Name of the parameter.
parameterValue (Version)
Parameter value.


AddParameter Method (parameterName, parameterValue)

AddParameter Method (parameterName, parameterValue)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► AddParameter(String, Language)
Adds a parameter.
Declaration Syntax
C#
public void AddParameter(
    string parameterName,
    Language parameterValue
)
Parameters
parameterName (String)
Name of the parameter.
parameterValue (Language)
Parameter value.


AddParameter Method (parameterName, parameterValue)

AddParameter Method (parameterName, parameterValue)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► AddParameter(String, DateTime)
Adds a parameter.
Declaration Syntax
C#
public void AddParameter(
    string parameterName,
    DateTime parameterValue
)
Parameters
parameterName (String)
Name of the parameter.
parameterValue (DateTime)
Parameter value.


AddParameter Method (parameterName, parameterValue)

AddParameter Method (parameterName, parameterValue)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► AddParameter(String, Object)
Adds a parameter to the parameters list.
Declaration Syntax
C#
public void AddParameter(
    string parameterName,
    Object parameterValue
)
Parameters
parameterName (String)
A string containing the parameter name.
parameterValue (Object)
An object.
Remarks
The parameter is added to the internal parameters list.
Examples
CopyC#
SqlBuilder builder = new SqlBuilder("Customers", SqlStatementType.StoredProcedure);
builder.AddParameter("name", "Alfreds Futterkiste");


AddVarRef Method (variableName)

AddVarRef Method (variableName)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► AddVarRef(String)
Adds the variable reference.
Declaration Syntax
C#
public void AddVarRef(
    string variableName
)
Parameters
variableName (String)
Name of the variable.


AddWhereClause Method (whereClause)

AddWhereClause Method (whereClause)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► AddWhereClause(String)
Adds a "where" clause as a string.
Declaration Syntax
C#
public void AddWhereClause(
    string whereClause
)
Parameters
whereClause (String)
The SQL where clase excluding the "where" keyword.
Remarks
The "where" keyword is automatically added if the where clause is not blank.
Examples
CopyC#
SqlBuilder builder = new SqlBuilder("Customers", SqlStatementType.Delete);
builder.AddWhereClause("name='Alfreds Futterkiste' and address='Elmstreet');


CreateCommand Method

CreateCommand Method
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► CreateCommand()()()
Members
Icon | Member | Description
 | CreateCommand(String) | Creates an SQL command object from a connection object.
 | CreateCommand(SqlConnection) | Creates an SQL command object from a connection object.


CreateCommand Method (connection)

CreateCommand Method (connection)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► CreateCommand(SqlConnection)
Creates an SQL command object from a connection object.
Declaration Syntax
C#
public SqlCommand CreateCommand(
    SqlConnection connection
)
Parameters
connection (SqlConnection)
An SQL connection object.
Return Value
The created SQL command object.
Remarks

This method is called by the Execute method. It is rarely used seperately.


CreateCommand Method (connection)

CreateCommand Method (connection)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► CreateCommand(String)
Creates an SQL command object from a connection object.
Declaration Syntax
C#
public SqlCommand CreateCommand(
    string connection
)
Parameters
connection (String)
An SQL connection string.
Return Value
The created SQL command object.
Remarks

This method is called by the Execute method. It is rarely used seperately.

Important: Remember to close the connection after using the returned command object (cmd). Use cmd.Connection.Close().


CreateDeleteCommand Method (cmd)

CreateDeleteCommand Method (cmd)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► CreateDeleteCommand(SqlCommand)
Creates an SQL Delete command object.
Declaration Syntax
C#
public SqlCommand CreateDeleteCommand(
    SqlCommand cmd
)
Parameters
cmd (SqlCommand)
An SQL command object.
Return Value
The created SQL command object.
Remarks

This method is called by the Execute method. It is rarely used seperately.


CreateInsertCommand Method (cmd)

CreateInsertCommand Method (cmd)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► CreateInsertCommand(SqlCommand)
Creates an SQL Insert command object.
Declaration Syntax
C#
public SqlCommand CreateInsertCommand(
    SqlCommand cmd
)
Parameters
cmd (SqlCommand)
An SQL command object.
Return Value
The created SQL command object.
Remarks

This method is called by the Execute method. It is rarely used seperately.


CreateStoredProcedureCommand Method (cmd)

CreateStoredProcedureCommand Method (cmd)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► CreateStoredProcedureCommand(SqlCommand)
Creates a Stored Procedure command object.
Declaration Syntax
C#
public SqlCommand CreateStoredProcedureCommand(
    SqlCommand cmd
)
Parameters
cmd (SqlCommand)
An SQL command object.
Return Value
The created SQL command object.
Remarks

This method is called by the Execute method. It is rarely used seperately.


CreateUDFCommand Method (cmd)

CreateUDFCommand Method (cmd)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► CreateUDFCommand(SqlCommand)
Creates a User Defined Function command object.
Declaration Syntax
C#
public SqlCommand CreateUDFCommand(
    SqlCommand cmd
)
Parameters
cmd (SqlCommand)
An SQL command object.
Return Value
The created SQL command object.
Remarks

This method is called by the Execute method. It is rarely used seperately.


CreateUpdateCommand Method (cmd)

CreateUpdateCommand Method (cmd)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► CreateUpdateCommand(SqlCommand)
Creates an Update command object.
Declaration Syntax
C#
public SqlCommand CreateUpdateCommand(
    SqlCommand cmd
)
Parameters
cmd (SqlCommand)
An SQL command object.
Return Value
The created SQL command object.
Remarks

This method is called by the Execute method. It is rarely used seperately.


Execute Method (connection)

Execute Method (connection)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► Execute(String)
Executes current SQL command.
Declaration Syntax
C#
public void Execute(
    string connection
)
Parameters
connection (String)
A connection string.
Remarks
The result of the command is discarded.
Examples
The following code deletes the company "Alfreds Futterkiste" from the Customers table.
CopyC#
SqlBuilder builder = new SqlBuilder("Customers", SqlStatementType.Delete);
builder.AddWhereClause("CompanyName='Alfreds Futterkiste'");
builder.Execute(myConnectionString);


ExecuteReader Method (connection)

ExecuteReader Method (connection)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► ExecuteReader(String)
Executes current SQL command and returns a reader.
Declaration Syntax
C#
public SqlDataReader ExecuteReader(
    string connection
)
Parameters
connection (String)
A connection string.


ExecuteScalar Method (connection)

ExecuteScalar Method (connection)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► ExecuteScalar(String)
Executes current SQL command.
Declaration Syntax
C#
public Object ExecuteScalar(
    string connection
)
Parameters
connection (String)
Connection.


GetCommandText Method

GetCommandText Method
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► GetCommandText()()()
Gets the command text.
Declaration Syntax
C#
public string GetCommandText()


GetDeleteCommandText Method

GetDeleteCommandText Method
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► GetDeleteCommandText()()()
Gets the delete command text.
Declaration Syntax
C#
public string GetDeleteCommandText()


GetInsertCommandText Method

GetInsertCommandText Method
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► GetInsertCommandText()()()
Gets the insert command text.
Declaration Syntax
C#
public string GetInsertCommandText()
Return Value


GetStoredProcedureCommandText Method

GetStoredProcedureCommandText Method
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► GetStoredProcedureCommandText()()()
Gets the stored procedure command text.
Declaration Syntax
C#
public string GetStoredProcedureCommandText()


GetStringArray Method (connection)

GetStringArray Method (connection)
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► GetStringArray(String)
Get a string array of results.
Declaration Syntax
C#
public string[] GetStringArray(
    string connection
)
Parameters
connection (String)
A connection string.


GetUDFCommandText Method

GetUDFCommandText Method
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► GetUDFCommandText()()()
Gets the UDF command text.
Declaration Syntax
C#
public string GetUDFCommandText()


GetUpdateCommandText Method

GetUpdateCommandText Method
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► GetUpdateCommandText()()()
Gets the update command text.
Declaration Syntax
C#
public string GetUpdateCommandText()


StatementType Property

StatementType Property
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► StatementType
Gets the statement type.
Declaration Syntax
C#
public SqlStatementType StatementType { get; }


Timeout Property

Timeout Property
Namespaces ► Sitecore.Data.Sql ► SqlBuilder ► Timeout
Gets or sets the timeout.
Declaration Syntax
C#
public TimeSpan Timeout { get; set; }


SqlStatementType Enumeration

SqlStatementType Enumeration
Namespaces ► Sitecore.Data.Sql ► SqlStatementType
Defines SQL statement types.
Declaration Syntax
C#
public enum SqlStatementType
Members
Member | Description
Delete | Defines a Delete statement.
Insert | Defines an Insert statement.
StoredProcedure | Defines a Stored Procedure.
UDF | Defines a User Defined Function.
Update | Defines an Update statement.
See Also
SqlBuilder


SqlUtil Class

SqlUtil Class
Namespaces ► Sitecore.Data.Sql ► SqlUtil
Implements a utility class for handling and executing SQL statements.
Declaration Syntax
C#
public static class SqlUtil
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddParameters(SqlCommand, array<Object>[]()[]) | Adds the parameters.
 | CreateCommand(String, String) | Gets a SQL command object from a SQL statement string and a connection string.
 | CreateCommand(String, String, TimeSpan) | Gets a SQL command object from a SQL statement string and a connection string.
 | Delete(String, String) | Deletes all data form a table.
 | ExecCommand(String, String) | Executes an SQL command statement.
 | ExecCommand(String, String, TimeSpan) | Executes an SQL command statement.
 | ExecCommand(String, array<Object>[]()[], String) | Executes an SQL command statement.
 | ExecCommand(String, array<Object>[]()[], String, TimeSpan) | Executes an SQL command statement.
 | ExecReader(SqlBuilder, String, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.
 | ExecReader(String, array<Object>[]()[], String, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.
 | ExecReader(SqlCommand, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.
 | Execute(String, array<Object>[]()[], String) | Executes an SQL command statement.
 | ExecuteNonQuery(SqlCommand) |
 | ExecuteReader(String, array<Object>[]()[], String) | Opens a reader using the specified SQL.
 | ExecuteReader(SqlCommand) | Executes a reader on a command.
 | ExecuteScalar(SqlCommand) |
 | ExtractConnnectionValue(String, String) | Extracts a value from a connection string.
 | GetArray(SqlBuilder, String) | Gets an array of results from an SQL statement.
 | GetArray(String, array<Object>[]()[], String) | Gets an array of results from an SQL statement.
 | GetArray(SqlCommand, Int32, Int32) | Gets an array of results from an SQL statement.
 | GetCount(SqlBuilder, String) | Gets a row count.
 | GetCount(String, String) | Gets a row count for a table.
 | GetCount(String, String, array<Object>[]()[], String) | Gets a row count for a table.
 | GetDataSet(String, String, Int32, Int32) | Gets a Dataset object from an SQL statement.
 | GetFullTextSearchSql(String, String, String, String) | Gets an SQL statement for use with a full-text query.
 | GetHashtable(String, String) | Gets results from an SQL statement as a hashtable.
 | GetHashtable(SqlBuilder, String) | Gets results from an SQL statement as a hashtable.
 | GetHashtable(SqlCommand) | Gets results from an SQL statement as a hashtable.
 | GetHashtable(SqlDataReader) | Gets results from an SQL statement as a hashtable.
 | GetID(SqlBuilder, String) | Gets a result string from an SQL builder.
 | GetIDArray(SqlBuilder, String) | Gets an array of results from an SQL statement.
 | GetIDArray(String, String) | Gets an array of results from an SQL statement.
 | GetInt32(String, array<Object>[]()[], String, Int32) | Gets an integer result from an SQL query.
 | GetItemID(String, String) | Gets an item ID.
 | GetItemID(SqlBuilder, String) | Gets an item ID.
 | GetItemID(SqlCommand) | Gets the item ID.
 | GetString(String, String) | Gets a result string from an SQL query.
 | GetString(String, String, array<Object>[]()[]) | Gets a string.
 | GetString(SqlBuilder, String) | Gets a result string from an SQL builder.
 | GetString(SqlCommand) | Gets a result string from an SQL command.
 | GetStringArray(String, String) | Gets an array of results from an SQL statement.
 | GetStringArray(String, String, Int32, Int32) | Gets an array of results from an SQL statement.
 | GetStringArray(SqlBuilder, String) | Gets an array of results from an SQL statement.
 | GetStringArray(SqlBuilder, String, Int32, Int32) | Gets an array of results from an SQL statement.
 | GetStringArray(SqlCommand) | Gets an array of results from an SQL statement.
 | GetStringArray(SqlCommand, Int32, Int32) | Gets an array of results from an SQL statement.
 | GetStringList(String, array<Object>[]()[], String) | Gets a list of string values from a database.
 | GetStringSet(String, array<Object>[]()[], String) | Gets a list of string values from a database.
 | MapType(Object) | Maps the type.
 | MapValue(Object) | Maps the value.
 | ObfuscatePassword(String) | Obfuscates the password part of a connection string.
 | Safe(DateTime) | Gets a date.
 | Safe(String) | Escapes a string for use in SQL statements.
 | StripPasswords(String) | Removes the passwords from connection string.
Remarks
Inheritance Hierarchy
Object
SqlUtil
See Also
DateUtil
SqlUtil
StringUtil


AddParameters Method (cmd, parameters)

AddParameters Method (cmd, parameters)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► AddParameters(SqlCommand, array<Object>[]()[])
Adds the parameters.
Declaration Syntax
C#
public static void AddParameters(
    SqlCommand cmd,
    Object[] parameters
)
Parameters
cmd (SqlCommand)
CMD.
parameters (array< Object >[]()[])
Parameters.


CreateCommand Method

CreateCommand Method
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► CreateCommand()()()
Members
Icon | Member | Description
 | CreateCommand(String, String) | Gets a SQL command object from a SQL statement string and a connection string.
 | CreateCommand(String, String, TimeSpan) | Gets a SQL command object from a SQL statement string and a connection string.


CreateCommand Method (sql, connection)

CreateCommand Method (sql, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► CreateCommand(String, String)
Gets a SQL command object from a SQL statement string and a connection string.
Declaration Syntax
C#
public static SqlCommand CreateCommand(
    string sql,
    string connection
)
Parameters
sql (String)
A string containing an SQL statement.
connection (String)
A SQL Server connection string.
Return Value
The created SQL command object.
Examples
CopyC#
SqlCommand cmd = SqlUtil.CreateCommand("select * from Customers", myConnection);


CreateCommand Method (sql, connection, timeout)

CreateCommand Method (sql, connection, timeout)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► CreateCommand(String, String, TimeSpan)
Gets a SQL command object from a SQL statement string and a connection string.
Declaration Syntax
C#
public static SqlCommand CreateCommand(
    string sql,
    string connection,
    TimeSpan timeout
)
Parameters
sql (String)
A string containing an SQL statement.
connection (String)
A SQL Server connection string.
timeout (TimeSpan)
Time before the command times out.
Return Value
The created SQL command object.
Examples
CopyC#
SqlCommand cmd = SqlUtil.CreateCommand("select * from Customers", myConnection);


Delete Method (table, connection)

Delete Method (table, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► Delete(String, String)
Deletes all data form a table.
Declaration Syntax
C#
public static void Delete(
    string table,
    string connection
)
Parameters
table (String)
Name of table.
connection (String)
A SQL Server connection string.
Examples
CopyC#
SqlUtil.Delete("customers", myConnection);


ExecCommand Method

ExecCommand Method
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExecCommand()()()
Members
Icon | Member | Description
 | ExecCommand(String, String) | Executes an SQL command statement.
 | ExecCommand(String, String, TimeSpan) | Executes an SQL command statement.
 | ExecCommand(String, array<Object>[]()[], String) | Executes an SQL command statement.
 | ExecCommand(String, array<Object>[]()[], String, TimeSpan) | Executes an SQL command statement.


ExecCommand Method (sql, parameters, connection)

ExecCommand Method (sql, parameters, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExecCommand(String, array<Object>[]()[], String)
Executes an SQL command statement.
Declaration Syntax
C#
public static void ExecCommand(
    string sql,
    Object[] parameters,
    string connection
)
Parameters
sql (String)
A string containing an SQL statement.
parameters (array< Object >[]()[])
connection (String)
A SQL Server connection string.
Remarks
The SQL command statement can be an Insert, Delete or Update statement. The result from the command is discarded.


ExecCommand Method (sql, parameters, connection, timeout)

ExecCommand Method (sql, parameters, connection, timeout)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExecCommand(String, array<Object>[]()[], String, TimeSpan)
Executes an SQL command statement.
Declaration Syntax
C#
public static void ExecCommand(
    string sql,
    Object[] parameters,
    string connection,
    TimeSpan timeout
)
Parameters
sql (String)
A string containing an SQL statement.
parameters (array< Object >[]()[])
connection (String)
A SQL Server connection string.
timeout (TimeSpan)
Time before the command times out.
Remarks
The SQL command statement can be an Insert, Delete or Update statement. The result from the command is discarded.
Examples
CopyC#
SqlUtil.ExecCommand("delete * from customers", myConnection);


ExecCommand Method (sql, connection)

ExecCommand Method (sql, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExecCommand(String, String)
Executes an SQL command statement.
Declaration Syntax
C#
public static void ExecCommand(
    string sql,
    string connection
)
Parameters
sql (String)
A string containing an SQL statement.
connection (String)
A SQL Server connection string.
Remarks
The SQL command statement can be an Insert, Delete or Update statement. The result from the command is discarded.
Examples
CopyC#
SqlUtil.ExecCommand("delete * from customers", myConnection);


ExecCommand Method (sql, connection, timeout)

ExecCommand Method (sql, connection, timeout)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExecCommand(String, String, TimeSpan)
Executes an SQL command statement.
Declaration Syntax
C#
public static void ExecCommand(
    string sql,
    string connection,
    TimeSpan timeout
)
Parameters
sql (String)
A string containing an SQL statement.
connection (String)
A SQL Server connection string.
timeout (TimeSpan)
Command timeout
Remarks
The SQL command statement can be an Insert, Delete or Update statement. The result from the command is discarded.
Examples
CopyC#
SqlUtil.ExecCommand("delete * from customers", myConnection);


ExecReader Method

ExecReader Method
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExecReader()()()
Members
Icon | Member | Description
 | ExecReader(SqlBuilder, String, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.
 | ExecReader(String, array<Object>[]()[], String, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.
 | ExecReader(SqlCommand, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.


ExecReader Method (builder, connection, conn)

ExecReader Method (builder, connection, conn)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExecReader(SqlBuilder, String, SqlConnection%)
Executes an SQL statement that yields a result.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static SqlDataReader ExecReader(
    SqlBuilder builder,
    string connection,
    out SqlConnection conn
)
Parameters
builder (SqlBuilder)
A builder.
connection (String)
A SQL Server connection string.
conn ( SqlConnection %)
The resulting SQL connection object.
Return Value
The result dataset from the SQL Server.
Remarks
The connection that is created from the connection string is returned in the conn parameter.
Examples
CopyC#
SqlConnection conn = null;
SqlDataReader reader = SqlUtil.ExecReader("select * from customers", myConnection, out conn);
while (reader.Read()) {
  ...
}


ExecReader Method (cmd, conn)

ExecReader Method (cmd, conn)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExecReader(SqlCommand, SqlConnection%)
Executes an SQL statement that yields a result.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static SqlDataReader ExecReader(
    SqlCommand cmd,
    out SqlConnection conn
)
Parameters
cmd (SqlCommand)
A SQL command.
conn ( SqlConnection %)
The resulting SQL connection object.
Return Value
The result dataset from the SQL Server.
Remarks
The connection that is created from the connection string is returned in the conn parameter.
Examples
CopyC#
SqlConnection conn = null;
SqlDataReader reader = SqlUtil.ExecReader("select * from customers", myConnection, out conn);
while (reader.Read()) {
  ...
}


ExecReader Method (sql, parameters, connection, conn)

ExecReader Method (sql, parameters, connection, conn)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExecReader(String, array<Object>[]()[], String, SqlConnection%)
Executes an SQL statement that yields a result.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static SqlDataReader ExecReader(
    string sql,
    Object[] parameters,
    string connection,
    out SqlConnection conn
)
Parameters
sql (String)
A string containing an SQL statement.
parameters (array< Object >[]()[])
connection (String)
A SQL Server connection string.
conn ( SqlConnection %)
The resulting SQL connection object.
Return Value
The result dataset from the SQL Server.
Remarks
The connection that is created from the connection string is returned in the conn parameter.
Examples
CopyC#
SqlConnection conn = null;
SqlDataReader reader = SqlUtil.ExecReader("select * from customers", myConnection, out conn);
while (reader.Read()) {
  ...
}


Execute Method (sql, parameters, connectionString)

Execute Method (sql, parameters, connectionString)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► Execute(String, array<Object>[]()[], String)
Executes an SQL command statement.
Declaration Syntax
C#
public static void Execute(
    string sql,
    Object[] parameters,
    string connectionString
)
Parameters
sql (String)
A string containing an SQL statement.
parameters (array< Object >[]()[])
connectionString (String)
A SQL Server connection string.
Remarks
The SQL command statement can be an Insert, Delete or Update statement. The result from the command is discarded.
Examples
CopyC#
SqlUtil.ExecCommand("delete * from customers", myConnection);


ExecuteNonQuery Method (cmd)

ExecuteNonQuery Method (cmd)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExecuteNonQuery(SqlCommand)
Declaration Syntax
C#
public static void ExecuteNonQuery(
    SqlCommand cmd
)
Parameters
cmd (SqlCommand)


ExecuteReader Method

ExecuteReader Method
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExecuteReader()()()
Members
Icon | Member | Description
 | ExecuteReader(String, array<Object>[]()[], String) | Opens a reader using the specified SQL.
 | ExecuteReader(SqlCommand) | Executes a reader on a command.


ExecuteReader Method (cmd)

ExecuteReader Method (cmd)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExecuteReader(SqlCommand)
Executes a reader on a command.
Declaration Syntax
C#
public static SqlDataReader ExecuteReader(
    SqlCommand cmd
)
Parameters
cmd (SqlCommand)
The CMD.
Return Value
Remarks
The reader is opened with the CloseConnection option, making it simple to use in using(...) scenarios.


ExecuteReader Method (sql, parameters, connectionString)

ExecuteReader Method (sql, parameters, connectionString)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExecuteReader(String, array<Object>[]()[], String)
Opens a reader using the specified SQL.
Declaration Syntax
C#
public static SqlDataReader ExecuteReader(
    string sql,
    Object[] parameters,
    string connectionString
)
Parameters
sql (String)
The SQL.
parameters (array< Object >[]()[])
The parameters.
connectionString (String)
A valid SQL Server connection string.
Return Value
Remarks
The reader is opened with the CloseConnection option, making it simple to use in using(...) scenarios.


ExecuteScalar Method (cmd)

ExecuteScalar Method (cmd)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExecuteScalar(SqlCommand)
Declaration Syntax
C#
public static Object ExecuteScalar(
    SqlCommand cmd
)
Parameters
cmd (SqlCommand)


ExtractConnnectionValue Method (name, connection)

ExtractConnnectionValue Method (name, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ExtractConnnectionValue(String, String)
Extracts a value from a connection string.
Declaration Syntax
C#
public static string ExtractConnnectionValue(
    string name,
    string connection
)
Parameters
name (String)
Name of the value to extract.
connection (String)
A connection string.
Return Value
The value of the named parameter. If not found, blank is returned.
Examples
CopyC#
string connectionString = "data source=myserver;user id=guest;password=;initial catalog=northwind;Connect Timeout=30";
string userID = SqlUtil.ExtractConnnectionValue("user id"); // guest


GetArray Method

GetArray Method
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetArray()()()
Members
Icon | Member | Description
 | GetArray(SqlBuilder, String) | Gets an array of results from an SQL statement.
 | GetArray(String, array<Object>[]()[], String) | Gets an array of results from an SQL statement.
 | GetArray(SqlCommand, Int32, Int32) | Gets an array of results from an SQL statement.


GetArray Method (builder, connection)

GetArray Method (builder, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetArray(SqlBuilder, String)
Gets an array of results from an SQL statement.
Declaration Syntax
C#
public static Object[] GetArray(
    SqlBuilder builder,
    string connection
)
Parameters
builder (SqlBuilder)
connection (String)


GetArray Method (cmd, fromRow, maxCount)

GetArray Method (cmd, fromRow, maxCount)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetArray(SqlCommand, Int32, Int32)
Gets an array of results from an SQL statement.
Declaration Syntax
C#
public static Object[] GetArray(
    SqlCommand cmd,
    int fromRow,
    int maxCount
)
Parameters
cmd (SqlCommand)
fromRow (Int32)
maxCount (Int32)


GetArray Method (sql, parameters, connection)

GetArray Method (sql, parameters, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetArray(String, array<Object>[]()[], String)
Gets an array of results from an SQL statement.
Declaration Syntax
C#
public static Object[] GetArray(
    string sql,
    Object[] parameters,
    string connection
)
Parameters
sql (String)
A string containing an SQL statement.
parameters (array< Object >[]()[])
connection (String)
A SQL Server connection string.
Return Value
An array of results from the query.
Examples
CopyC#
ArrayList result = SqlUtil.GetArray("select CompanyName from Customers",
  "data source=myserver;user id=guest;password=;initial catalog=northwind;Connect Timeout=30");


GetCount Method

GetCount Method
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetCount()()()
Members
Icon | Member | Description
 | GetCount(SqlBuilder, String) | Gets a row count.
 | GetCount(String, String) | Gets a row count for a table.
 | GetCount(String, String, array<Object>[]()[], String) | Gets a row count for a table.


GetCount Method (builder, connection)

GetCount Method (builder, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetCount(SqlBuilder, String)
Gets a row count.
Declaration Syntax
C#
public static int GetCount(
    SqlBuilder builder,
    string connection
)
Parameters
builder (SqlBuilder)
Builder
connection (String)
A connection string.
Return Value
The number of rows in the table.


GetCount Method (tableName, connection)

GetCount Method (tableName, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetCount(String, String)
Gets a row count for a table.
Declaration Syntax
C#
public static int GetCount(
    string tableName,
    string connection
)
Parameters
tableName (String)
Name of the table.
connection (String)
A connection string.
Return Value
The number of rows in the table.
Examples
CopyC#
int count = SqlUtil.GetCount("customers", "data source=myserver;user id=guest;password=;initial catalog=northwind;Connect Timeout=30");


GetCount Method (tableName, condition, parameters, connection)

GetCount Method (tableName, condition, parameters, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetCount(String, String, array<Object>[]()[], String)
Gets a row count for a table.
Declaration Syntax
C#
public static int GetCount(
    string tableName,
    string condition,
    Object[] parameters,
    string connection
)
Parameters
tableName (String)
Name of the table.
condition (String)
An SQL where clause.
parameters (array< Object >[]()[])
connection (String)
A connection string.
Return Value
The number of rows in the table.
Remarks
The condition is specified without the "where" keyword.
Examples
CopyC#
int count = SqlUtil.GetCount("customers", "Country='Germany'", "data source=myserver;user id=guest;password=;initial catalog=northwind;Connect Timeout=30");


GetDataSet Method (sql, connection, startIndex, maxCount)

GetDataSet Method (sql, connection, startIndex, maxCount)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetDataSet(String, String, Int32, Int32)
Gets a Dataset object from an SQL statement.
Declaration Syntax
C#
public static DataSet GetDataSet(
    string sql,
    string connection,
    int startIndex,
    int maxCount
)
Parameters
sql (String)
A string containing an SQL statement.
connection (String)
A connection string.
startIndex (Int32)
Starting position for the Dataset object.
maxCount (Int32)
Max number of rows.
Return Value
The created Dataset object.
Examples
The following example gets the first 100 customers from the Customers table.
CopyC#
Dataset dataset = SqlUtil.GetDataset("select * from customers",
  "data source=myserver;user id=guest;password=;initial catalog=northwind;Connect Timeout=30",
  0, 100);


GetFullTextSearchSql Method (search, table, displayFields, searchFields)

GetFullTextSearchSql Method (search, table, displayFields, searchFields)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetFullTextSearchSql(String, String, String, String)
Gets an SQL statement for use with a full-text query.
Declaration Syntax
C#
public static string GetFullTextSearchSql(
    string search,
    string table,
    string displayFields,
    string searchFields
)
Parameters
search (String)
A List of words to search for (separated by spaces).
table (String)
Name of a table to search.
displayFields (String)
A comma separated list of fields to return.
searchFields (String)
A comma separated list of fields to search in.
Return Value
An SQL statement that can be executed.
Remarks
Searches are performed in Google style, ie. all words in search term must be present in result. The search is performed against all fields in the full-text index.
Examples
CopyC#
string sql = SqlUtil.GetFullTextSearchSql("helmet", "products", "description", "description");


GetHashtable Method

GetHashtable Method
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetHashtable()()()
Members
Icon | Member | Description
 | GetHashtable(String, String) | Gets results from an SQL statement as a hashtable.
 | GetHashtable(SqlBuilder, String) | Gets results from an SQL statement as a hashtable.
 | GetHashtable(SqlCommand) | Gets results from an SQL statement as a hashtable.
 | GetHashtable(SqlDataReader) | Gets results from an SQL statement as a hashtable.


GetHashtable Method (builder, connection)

GetHashtable Method (builder, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetHashtable(SqlBuilder, String)
Gets results from an SQL statement as a hashtable.
Declaration Syntax
C#
public static Hashtable GetHashtable(
    SqlBuilder builder,
    string connection
)
Parameters
builder (SqlBuilder)
A SQL builder.
connection (String)
A SQL Server connection string.


GetHashtable Method (cmd)

GetHashtable Method (cmd)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetHashtable(SqlCommand)
Gets results from an SQL statement as a hashtable.
Declaration Syntax
C#
public static Hashtable GetHashtable(
    SqlCommand cmd
)
Parameters
cmd (SqlCommand)
A SQL command.


GetHashtable Method (reader)

GetHashtable Method (reader)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetHashtable(SqlDataReader)
Gets results from an SQL statement as a hashtable.
Declaration Syntax
C#
public static Hashtable GetHashtable(
    SqlDataReader reader
)
Parameters
reader (SqlDataReader)
A reader.


GetHashtable Method (sql, connection)

GetHashtable Method (sql, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetHashtable(String, String)
Gets results from an SQL statement as a hashtable.
Declaration Syntax
C#
public static Hashtable GetHashtable(
    string sql,
    string connection
)
Parameters
sql (String)
A string containing an SQL statement.
connection (String)
A SQL Server connection string.


GetID Method (builder, connection)

GetID Method (builder, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetID(SqlBuilder, String)
Gets a result string from an SQL builder.
Declaration Syntax
C#
public static ID GetID(
    SqlBuilder builder,
    string connection
)
Parameters
builder (SqlBuilder)
connection (String)


GetIDArray Method

GetIDArray Method
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetIDArray()()()
Members
Icon | Member | Description
 | GetIDArray(SqlBuilder, String) | Gets an array of results from an SQL statement.
 | GetIDArray(String, String) | Gets an array of results from an SQL statement.


GetIDArray Method (builder, connection)

GetIDArray Method (builder, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetIDArray(SqlBuilder, String)
Gets an array of results from an SQL statement.
Declaration Syntax
C#
public static ID[] GetIDArray(
    SqlBuilder builder,
    string connection
)
Parameters
builder (SqlBuilder)
connection (String)


GetIDArray Method (sql, connection)

GetIDArray Method (sql, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetIDArray(String, String)
Gets an array of results from an SQL statement.
Declaration Syntax
C#
public static ID[] GetIDArray(
    string sql,
    string connection
)
Parameters
sql (String)
connection (String)


GetInt32 Method (sql, parameters, connectionString, defaultValue)

GetInt32 Method (sql, parameters, connectionString, defaultValue)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetInt32(String, array<Object>[]()[], String, Int32)
Gets an integer result from an SQL query.
Declaration Syntax
C#
public static int GetInt32(
    string sql,
    Object[] parameters,
    string connectionString,
    int defaultValue
)
Parameters
sql (String)
A string containing an SQL statement.
parameters (array< Object >[]()[])
The parameters.
connectionString (String)
A SQL Server connection string.
defaultValue (Int32)
The default value.
Return Value
The result of the query as an integer.


GetItemID Method

GetItemID Method
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetItemID()()()
Members
Icon | Member | Description
 | GetItemID(String, String) | Gets an item ID.
 | GetItemID(SqlBuilder, String) | Gets an item ID.
 | GetItemID(SqlCommand) | Gets the item ID.


GetItemID Method (builder, connection)

GetItemID Method (builder, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetItemID(SqlBuilder, String)
Gets an item ID.
Declaration Syntax
C#
public static ID GetItemID(
    SqlBuilder builder,
    string connection
)
Parameters
builder (SqlBuilder)
Builder.
connection (String)
Connection.


GetItemID Method (cmd)

GetItemID Method (cmd)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetItemID(SqlCommand)
Gets the item ID.
Declaration Syntax
C#
public static ID GetItemID(
    SqlCommand cmd
)
Parameters
cmd (SqlCommand)
CMD.


GetItemID Method (sql, connection)

GetItemID Method (sql, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetItemID(String, String)
Gets an item ID.
Declaration Syntax
C#
public static ID GetItemID(
    string sql,
    string connection
)
Parameters
sql (String)
SQL.
connection (String)
Connection.


GetString Method

GetString Method
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetString()()()
Members
Icon | Member | Description
 | GetString(String, String) | Gets a result string from an SQL query.
 | GetString(String, String, array<Object>[]()[]) | Gets a string.
 | GetString(SqlBuilder, String) | Gets a result string from an SQL builder.
 | GetString(SqlCommand) | Gets a result string from an SQL command.


GetString Method (builder, connection)

GetString Method (builder, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetString(SqlBuilder, String)
Gets a result string from an SQL builder.
Declaration Syntax
C#
public static string GetString(
    SqlBuilder builder,
    string connection
)
Parameters
builder (SqlBuilder)
connection (String)


GetString Method (cmd)

GetString Method (cmd)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetString(SqlCommand)
Gets a result string from an SQL command.
Declaration Syntax
C#
public static string GetString(
    SqlCommand cmd
)
Parameters
cmd (SqlCommand)


GetString Method (sql, connection)

GetString Method (sql, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetString(String, String)
Gets a result string from an SQL query.
Declaration Syntax
C#
public static string GetString(
    string sql,
    string connection
)
Parameters
sql (String)
A string containing an SQL statement.
connection (String)
A SQL Server connection string.
Return Value
The result of the query as a string.
Examples
CopyC#
string result = SqlUtil.GetString("select CompanyName from Customers where CustomerName='Alfreds Futterkiste'",
  "data source=myserver;user id=guest;password=;initial catalog=northwind;Connect Timeout=30");


GetString Method (sql, connection, parameters)

GetString Method (sql, connection, parameters)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetString(String, String, array<Object>[]()[])
Gets a string.
Declaration Syntax
C#
public static string GetString(
    string sql,
    string connection,
    Object[] parameters
)
Parameters
sql (String)
SQL.
connection (String)
Connection.
parameters (array< Object >[]()[])
Parameters.


GetStringArray Method

GetStringArray Method
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetStringArray()()()
Members
Icon | Member | Description
 | GetStringArray(String, String) | Gets an array of results from an SQL statement.
 | GetStringArray(String, String, Int32, Int32) | Gets an array of results from an SQL statement.
 | GetStringArray(SqlBuilder, String) | Gets an array of results from an SQL statement.
 | GetStringArray(SqlBuilder, String, Int32, Int32) | Gets an array of results from an SQL statement.
 | GetStringArray(SqlCommand) | Gets an array of results from an SQL statement.
 | GetStringArray(SqlCommand, Int32, Int32) | Gets an array of results from an SQL statement.


GetStringArray Method (builder, connection)

GetStringArray Method (builder, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetStringArray(SqlBuilder, String)
Gets an array of results from an SQL statement.
Declaration Syntax
C#
public static string[] GetStringArray(
    SqlBuilder builder,
    string connection
)
Parameters
builder (SqlBuilder)
connection (String)


GetStringArray Method (builder, connection, fromRow, count)

GetStringArray Method (builder, connection, fromRow, count)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetStringArray(SqlBuilder, String, Int32, Int32)
Gets an array of results from an SQL statement.
Declaration Syntax
C#
public static string[] GetStringArray(
    SqlBuilder builder,
    string connection,
    int fromRow,
    int count
)
Parameters
builder (SqlBuilder)
connection (String)
fromRow (Int32)
count (Int32)


GetStringArray Method (cmd)

GetStringArray Method (cmd)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetStringArray(SqlCommand)
Gets an array of results from an SQL statement.
Declaration Syntax
C#
public static string[] GetStringArray(
    SqlCommand cmd
)
Parameters
cmd (SqlCommand)


GetStringArray Method (cmd, fromRow, count)

GetStringArray Method (cmd, fromRow, count)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetStringArray(SqlCommand, Int32, Int32)
Gets an array of results from an SQL statement.
Declaration Syntax
C#
public static string[] GetStringArray(
    SqlCommand cmd,
    int fromRow,
    int count
)
Parameters
cmd (SqlCommand)
fromRow (Int32)
count (Int32)


GetStringArray Method (sql, connection)

GetStringArray Method (sql, connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetStringArray(String, String)
Gets an array of results from an SQL statement.
Declaration Syntax
C#
public static string[] GetStringArray(
    string sql,
    string connection
)
Parameters
sql (String)
A string containing an SQL statement.
connection (String)
A SQL Server connection string.
Return Value
An array of results from the query.
Examples
CopyC#
ArrayList result = SqlUtil.GetStringArray("select CompanyName from Customers",
  "data source=myserver;user id=guest;password=;initial catalog=northwind;Connect Timeout=30");


GetStringArray Method (sql, connection, fromRow, count)

GetStringArray Method (sql, connection, fromRow, count)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetStringArray(String, String, Int32, Int32)
Gets an array of results from an SQL statement.
Declaration Syntax
C#
public static string[] GetStringArray(
    string sql,
    string connection,
    int fromRow,
    int count
)
Parameters
sql (String)
connection (String)
fromRow (Int32)
count (Int32)


GetStringList Method (sql, parameters, connectionString)

GetStringList Method (sql, parameters, connectionString)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetStringList(String, array<Object>[]()[], String)
Gets a list of string values from a database.
Declaration Syntax
C#
public static List<string> GetStringList(
    string sql,
    Object[] parameters,
    string connectionString
)
Parameters
sql (String)
The SQL.
parameters (array< Object >[]()[])
The parameters.
connectionString (String)
The connection string.
Return Value


GetStringSet Method (sql, parameters, connectionString)

GetStringSet Method (sql, parameters, connectionString)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► GetStringSet(String, array<Object>[]()[], String)
Gets a list of string values from a database.
Declaration Syntax
C#
public static Set<string> GetStringSet(
    string sql,
    Object[] parameters,
    string connectionString
)
Parameters
sql (String)
The SQL.
parameters (array< Object >[]()[])
The parameters.
connectionString (String)
The connection string.
Return Value


MapType Method (value)

MapType Method (value)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► MapType(Object)
Maps the type.
Declaration Syntax
C#
public static SqlDbType MapType(
    Object value
)
Parameters
value (Object)
Value.


MapValue Method (value)

MapValue Method (value)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► MapValue(Object)
Maps the value.
Declaration Syntax
C#
public static Object MapValue(
    Object value
)
Parameters
value (Object)
Value.


ObfuscatePassword Method (connection)

ObfuscatePassword Method (connection)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► ObfuscatePassword(String)
Obfuscates the password part of a connection string.
Declaration Syntax
C#
public static string ObfuscatePassword(
    string connection
)
Parameters
connection (String)


Safe Method

Safe Method
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► Safe()()()
Members
Icon | Member | Description
 | Safe(DateTime) | Gets a date.
 | Safe(String) | Escapes a string for use in SQL statements.


Safe Method (date)

Safe Method (date)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► Safe(DateTime)
Gets a date.
Declaration Syntax
C#
public static DateTime Safe(
    DateTime date
)
Parameters
date (DateTime)
Date.


Safe Method (text)

Safe Method (text)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► Safe(String)
Escapes a string for use in SQL statements.
Declaration Syntax
C#
public static string Safe(
    string text
)
Parameters
text (String)
A string.
Return Value
The escaped string.
Remarks
This function replaces a single quote with two single quotes.
Examples
CopyC#
string parameter = SqlUtil.Safe("Andy's"); // "Andy''s"


StripPasswords Method (connectionString)

StripPasswords Method (connectionString)
Namespaces ► Sitecore.Data.Sql ► SqlUtil ► StripPasswords(String)
Removes the passwords from connection string.
Declaration Syntax
C#
public static string StripPasswords(
    string connectionString
)
Parameters
connectionString (String)
The connection string.
Return Value
The connection string with password removed.


Sitecore.Data.SqlServer Namespace

Sitecore.Data.SqlServer Namespace
Namespaces ► Sitecore.Data.SqlServer
Declaration Syntax
C#
namespace Sitecore.Data.SqlServer
Types
All Types Classes
Icon | Type | Description
 | SqlServerApi |
 | SqlServerClientDataStore | SqlServerClientDataStore
 | SqlServerCommand |
 | SqlServerConnectionInfo |
 | SqlServerDataApi | Class implementing the SQL Server data API.
 | SqlServerDataProvider | SQL Server based data provider.
 | SqlServerHistoryStorage | SqlServerHistoryStorage
 | SqlServerHistoryStore | SqlServerHistoryStore
 | SqlServerIDTable |
 | SqlServerLinkDatabase | Represents a SQL Server link database.
 | SqlServerProxyDataProvider | SQL Server based proxy data provider.
 | SqlServerTaskDatabase | SqlTaskDatabase


SqlServerApi Class

SqlServerApi Class
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi
Declaration Syntax
C#
public class SqlServerApi
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerApi(String) | Initializes a new instance of the SqlServerApi class
 | CommandTimeout | Gets the timeout used when issuing SQL Server commands.
 | CreateReader(String, array<Object>[]()[]) |
 | CreateTransactionScope()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(String, array<Object>[]()[]) |
 | Exists(String, array<Object>[]()[]) |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCount(String, array<Object>[]()[]) |
 | GetDateTime(Object) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(Object) |
 | GetInt32(Object) |
 | GetString(Object) |
 | GetTopValues(String, Int32, array<Object>[]()[]) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValues(String, array<Object>[]()[]) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Safe(String) | Escapes a string for use in SQL statements.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SqlServerApi


SqlServerApi Constructor (connection)

SqlServerApi Constructor (connection)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi ► SqlServerApi(String)
Initializes a new instance of the SqlServerApi class
Declaration Syntax
C#
public SqlServerApi(
    string connection
)
Parameters
connection (String)


CommandTimeout Property

CommandTimeout Property
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi ► CommandTimeout
Gets the timeout used when issuing SQL Server commands.
Declaration Syntax
C#
public TimeSpan CommandTimeout { get; set; }


CreateReader Method (sql, parameters)

CreateReader Method (sql, parameters)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi ► CreateReader(String, array<Object>[]()[])
Declaration Syntax
C#
public DataProviderReader CreateReader(
    string sql,
    params Object[] parameters
)
Parameters
sql (String)
parameters (array< Object >[]()[])


CreateTransactionScope Method

CreateTransactionScope Method
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi ► CreateTransactionScope()()()
Declaration Syntax
C#
public DataProviderTransaction CreateTransactionScope()


Execute Method (sql, parameters)

Execute Method (sql, parameters)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi ► Execute(String, array<Object>[]()[])
Declaration Syntax
C#
public void Execute(
    string sql,
    params Object[] parameters
)
Parameters
sql (String)
parameters (array< Object >[]()[])


Exists Method (sql, parameters)

Exists Method (sql, parameters)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi ► Exists(String, array<Object>[]()[])
Declaration Syntax
C#
public bool Exists(
    string sql,
    params Object[] parameters
)
Parameters
sql (String)
parameters (array< Object >[]()[])


GetCount Method (sql, parameters)

GetCount Method (sql, parameters)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi ► GetCount(String, array<Object>[]()[])
Declaration Syntax
C#
public int GetCount(
    string sql,
    params Object[] parameters
)
Parameters
sql (String)
parameters (array< Object >[]()[])


GetDateTime Method (value)

GetDateTime Method (value)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi ► GetDateTime(Object)
Declaration Syntax
C#
public DateTime GetDateTime(
    Object value
)
Parameters
value (Object)


GetID Method (value)

GetID Method (value)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi ► GetID(Object)
Declaration Syntax
C#
public ID GetID(
    Object value
)
Parameters
value (Object)


GetInt32 Method (value)

GetInt32 Method (value)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi ► GetInt32(Object)
Declaration Syntax
C#
public int GetInt32(
    Object value
)
Parameters
value (Object)


GetString Method (value)

GetString Method (value)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi ► GetString(Object)
Declaration Syntax
C#
public string GetString(
    Object value
)
Parameters
value (Object)


GetTopValues Method (sql, maxRecords, parameters)

GetTopValues Method (sql, maxRecords, parameters)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi ► GetTopValues(String, Int32, array<Object>[]()[])
Declaration Syntax
C#
public ArrayList GetTopValues(
    string sql,
    int maxRecords,
    params Object[] parameters
)
Parameters
sql (String)
maxRecords (Int32)
parameters (array< Object >[]()[])


GetValues Method (sql, parameters)

GetValues Method (sql, parameters)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi ► GetValues(String, array<Object>[]()[])
Declaration Syntax
C#
public ArrayList GetValues(
    string sql,
    params Object[] parameters
)
Parameters
sql (String)
parameters (array< Object >[]()[])


Safe Method (text)

Safe Method (text)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerApi ► Safe(String)
Escapes a string for use in SQL statements.
Declaration Syntax
C#
public string Safe(
    string text
)
Parameters
text (String)
A string.
Return Value
The escaped string.
Remarks
This function replaces a single quote with two single quotes.
Examples
CopyC#
string parameter = SqlUtil.Safe("Andy's"); // "Andy''s"


SqlServerClientDataStore Class

SqlServerClientDataStore Class
Namespaces ► Sitecore.Data.SqlServer ► SqlServerClientDataStore
SqlServerClientDataStore
Declaration Syntax
C#
public class SqlServerClientDataStore : ClientDataStore
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerClientDataStore(String, String) | Initializes a new instance of the SqlServerClientDataStore class.
 | SqlServerClientDataStore(SqlDataApi, String) | Initializes a new instance of the SqlServerClientDataStore class.
 | _api | The Server API
 | AddDataToCache(String, Hashtable, Int64) | Adds data to the cache. (Inherited from ClientDataStore.)
 | Compact()()() | Compacts this instance. (Inherited from ClientDataStore.)
 | CompactData()()() | Compacts the data. (Overrides ClientDataStore.CompactData()()().)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(String) | Check if data satisfying the specified SQL exists.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataFromCache(String) | Gets data from the cache. (Inherited from ClientDataStore.)
 | GetDataKey()()() | Gets the data key. (Inherited from ClientDataStore.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSize(Hashtable) | Gets the size of newly returned data. (Overrides ClientDataStore.GetSize(Hashtable).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(String) | Gets the value. (Inherited from ClientDataStore.)
 | GetValueNames()()() | Gets the value names. (Inherited from ClientDataStore.)
 | LoadData(String) | Loads the data. (Overrides ClientDataStore.LoadData(String).)
 | LoadData()()() | Loads the data. (Inherited from ClientDataStore.)
 | LoadViewstate(String) | Loads the viewstate. (Inherited from ClientDataStore.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ObjectLifetime | Gets the object lifetime. (Inherited from ClientDataStore.)
 | RemoveAll()()() | Removes the values. (Inherited from ClientDataStore.)
 | RemoveAllData()()() | Removes all Client data. (Overrides ClientDataStore.RemoveAllData()()().)
 | RemoveData(String) | Removes the data. (Overrides ClientDataStore.RemoveData(String).)
 | RemoveData()()() | Removes the data. (Inherited from ClientDataStore.)
 | RemoveDataFromCache(String) | Removes data from the cache. (Inherited from ClientDataStore.)
 | RemoveValue(String) | Removes the value. (Inherited from ClientDataStore.)
 | RemoveValues()()() | Removes the values. (Inherited from ClientDataStore.)
 | RemoveViewstate(String) | Removes the viewstate. (Inherited from ClientDataStore.)
 | SaveData(String, String) | Saves the data. (Overrides ClientDataStore.SaveData(String, String).)
 | SaveData(Hashtable) | Saves the data. (Inherited from ClientDataStore.)
 | SaveViewstate(String, String) | Saves the viewstate. (Inherited from ClientDataStore.)
 | SetValue(String, String) | Sets the value. (Inherited from ClientDataStore.)
 | SetValue(String, Object, String) | Sets the value. (Inherited from ClientDataStore.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TouchActiveData()()() | Touches all active data. (Inherited from ClientDataStore.)
 | TouchData(String) | Touches the data represented by key. (Overrides ClientDataStore.TouchData(String).)
Inheritance Hierarchy
Object
 | ClientDataStore
 |  | SqlServerClientDataStore


SqlServerClientDataStore Constructor

SqlServerClientDataStore Constructor
Namespaces ► Sitecore.Data.SqlServer ► SqlServerClientDataStore ► SqlServerClientDataStore()()()
Members
Icon | Member | Description
 | SqlServerClientDataStore(String, String) | Initializes a new instance of the SqlServerClientDataStore class.
 | SqlServerClientDataStore(SqlDataApi, String) | Initializes a new instance of the SqlServerClientDataStore class.


SqlServerClientDataStore Constructor (api, objectLifetime)

SqlServerClientDataStore Constructor (api, objectLifetime)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerClientDataStore ► SqlServerClientDataStore(SqlDataApi, String)
Initializes a new instance of the SqlServerClientDataStore class.
Declaration Syntax
C#
public SqlServerClientDataStore(
    SqlDataApi api,
    string objectLifetime
)
Parameters
api (SqlDataApi)
The API.
objectLifetime (String)
The object lifetime.


SqlServerClientDataStore Constructor (connectionString, objectLifetime)

SqlServerClientDataStore Constructor (connectionString, objectLifetime)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerClientDataStore ► SqlServerClientDataStore(String, String)
Initializes a new instance of the SqlServerClientDataStore class.
Declaration Syntax
C#
public SqlServerClientDataStore(
    string connectionString,
    string objectLifetime
)
Parameters
connectionString (String)
The connection string.
objectLifetime (String)
The object lifetime.


_api Field

_api Field
Namespaces ► Sitecore.Data.SqlServer ► SqlServerClientDataStore ► _api
The Server API
Declaration Syntax
C#
protected SqlDataApi _api


CompactData Method

CompactData Method
Namespaces ► Sitecore.Data.SqlServer ► SqlServerClientDataStore ► CompactData()()()
Compacts the data.
Declaration Syntax
C#
protected override void CompactData()


Exists Method (key)

Exists Method (key)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerClientDataStore ► Exists(String)
Check if data satisfying the specified SQL exists.
Declaration Syntax
C#
protected bool Exists(
    string key
)
Parameters
key (String)
Return Value
True, if data is found, false otherwise.


GetSize Method (data)

GetSize Method (data)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerClientDataStore ► GetSize(Hashtable)
Gets the size of newly returned data.
Declaration Syntax
C#
protected override long GetSize(
    Hashtable data
)
Parameters
data (Hashtable)
The data.
Return Value


LoadData Method (key)

LoadData Method (key)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerClientDataStore ► LoadData(String)
Loads the data.
Declaration Syntax
C#
protected override string LoadData(
    string key
)
Parameters
key (String)
The key.
Return Value


RemoveAllData Method

RemoveAllData Method
Namespaces ► Sitecore.Data.SqlServer ► SqlServerClientDataStore ► RemoveAllData()()()
Removes all Client data.
Declaration Syntax
C#
protected override void RemoveAllData()


RemoveData Method (key)

RemoveData Method (key)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerClientDataStore ► RemoveData(String)
Removes the data.
Declaration Syntax
C#
protected override void RemoveData(
    string key
)
Parameters
key (String)
The key.


SaveData Method (key, data)

SaveData Method (key, data)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerClientDataStore ► SaveData(String, String)
Saves the data.
Declaration Syntax
C#
protected override void SaveData(
    string key,
    string data
)
Parameters
key (String)
The key.
data (String)
The data.


TouchData Method (key)

TouchData Method (key)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerClientDataStore ► TouchData(String)
Touches the data represented by key.
Declaration Syntax
C#
protected override void TouchData(
    string key
)
Parameters
key (String)
The key.


SqlServerCommand Class

SqlServerCommand Class
Namespaces ► Sitecore.Data.SqlServer ► SqlServerCommand
Declaration Syntax
C#
public class SqlServerCommand : DataProviderCommand
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SqlServerCommand(SqlCommand, Boolean) | Constructs an instance of SqlServerCommand
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from DataProviderCommand.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteNonQuery()()() | Executes the non query. (Inherited from DataProviderCommand.)
 | ExecuteReader()()() | Executes the reader. (Inherited from DataProviderCommand.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataProviderCommand
 |  | SqlServerCommand


SqlServerCommand Constructor (command, openConnection)

SqlServerCommand Constructor (command, openConnection)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerCommand ► SqlServerCommand(SqlCommand, Boolean)
Constructs an instance of SqlServerCommand
Declaration Syntax
C#
public SqlServerCommand(
    SqlCommand command,
    bool openConnection
)
Parameters
command (SqlCommand)
openConnection (Boolean)


SqlServerConnectionInfo Class

SqlServerConnectionInfo Class
Namespaces ► Sitecore.Data.SqlServer ► SqlServerConnectionInfo
Declaration Syntax
C#
public class SqlServerConnectionInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerConnectionInfo(SqlConnection) | Initializes a new instance of the SqlServerConnectionInfo class
 | SqlServerConnectionInfo(SqlTransaction) | Initializes a new instance of the SqlServerConnectionInfo class
 | Connection |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transaction |
Inheritance Hierarchy
Object
SqlServerConnectionInfo


SqlServerConnectionInfo Constructor

SqlServerConnectionInfo Constructor
Namespaces ► Sitecore.Data.SqlServer ► SqlServerConnectionInfo ► SqlServerConnectionInfo()()()
Members
Icon | Member | Description
 | SqlServerConnectionInfo(SqlConnection) | Initializes a new instance of the SqlServerConnectionInfo class
 | SqlServerConnectionInfo(SqlTransaction) | Initializes a new instance of the SqlServerConnectionInfo class


SqlServerConnectionInfo Constructor (connection)

SqlServerConnectionInfo Constructor (connection)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerConnectionInfo ► SqlServerConnectionInfo(SqlConnection)
Initializes a new instance of the SqlServerConnectionInfo class
Declaration Syntax
C#
public SqlServerConnectionInfo(
    SqlConnection connection
)
Parameters
connection (SqlConnection)


SqlServerConnectionInfo Constructor (transaction)

SqlServerConnectionInfo Constructor (transaction)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerConnectionInfo ► SqlServerConnectionInfo(SqlTransaction)
Initializes a new instance of the SqlServerConnectionInfo class
Declaration Syntax
C#
public SqlServerConnectionInfo(
    SqlTransaction transaction
)
Parameters
transaction (SqlTransaction)


Connection Property

Connection Property
Namespaces ► Sitecore.Data.SqlServer ► SqlServerConnectionInfo ► Connection
Declaration Syntax
C#
public SqlConnection Connection { get; }


Transaction Property

Transaction Property
Namespaces ► Sitecore.Data.SqlServer ► SqlServerConnectionInfo ► Transaction
Declaration Syntax
C#
public SqlTransaction Transaction { get; }


SqlServerDataApi Class

SqlServerDataApi Class
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi
Class implementing the SQL Server data API.
Declaration Syntax
C#
public class SqlServerDataApi : SqlDataApi
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerDataApi()()() | Initializes a new instance of the SqlServerDataApi class.
 | SqlServerDataApi(String) | Initializes a new instance of the SqlServerDataApi class.
 | ConnectionString | Gets the connection string. (Overrides SqlDataApi.ConnectionString.)
 | CreateCommand(String, array<Object>[]()[]) | Factory method for creating a new command object. (Inherited from SqlDataApi.)
 | CreateConnection()()() | Creates a physical database connection. (Overrides SqlDataApi.CreateConnection()()().)
 | CreateParameter(String, Object) | Creates a parameter for use in a command. (Overrides SqlDataApi.CreateParameter(String, Object).)
 | CreateReader(String, array<Object>[]()[]) | Factory method for creating an instance of a DataProviderReader (Inherited from SqlDataApi.)
 | CreateTransaction()()() | Factory method for creating an instance of a DataProviderTransaction (Inherited from SqlDataApi.)
 | EmptyStringLiteral | Gets the empty literal. (Inherited from SqlDataApi.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(String, array<Object>[]()[]) | Executes the specified SQL. (Inherited from SqlDataApi.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Format(String) | Formats the specified SQL. (Inherited from SqlDataApi.)
 | FormatRawID(ID) | Formats ID to be used in raw SQL queries (e.g. itemID in 'select * from items where id = :itemID') (Inherited from SqlDataApi.)
 | GetDateTime(Int32, DataProviderReader) | Gets a date/time value from a specified column. (Overrides SqlDataApi.GetDateTime(Int32, DataProviderReader).)
 | GetGuid(Int32, DataProviderReader) | Gets an id value from a specified column. (Overrides SqlDataApi.GetGuid(Int32, DataProviderReader).)
 | GetGuid(String, array<Object>[]()[], Guid) | Gets a guid value from the database.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetId(Int32, DataProviderReader) | Gets an id value from a specified column. (Overrides SqlDataApi.GetId(Int32, DataProviderReader).)
 | GetInt(Int32, DataProviderReader) | Gets an int32 value from a specified column. (Overrides SqlDataApi.GetInt(Int32, DataProviderReader).)
 | GetInt(String, array<Object>[]()[], Int32) | Gets an integer value from the database.
 | GetInt32(String, Int32, array<Object>[]()[]) | Gets an integer result from an SQL query. (Inherited from SqlDataApi.)
 | GetLanguage(Int32, DataProviderReader) | Gets a language value from a specified column. (Overrides SqlDataApi.GetLanguage(Int32, DataProviderReader).)
 | GetLong(Int32, DataProviderReader) | Gets an int64 value from a specified column. (Overrides SqlDataApi.GetLong(Int32, DataProviderReader).)
 | GetString(Int32, DataProviderReader) | Gets a string value from a specified column. (Overrides SqlDataApi.GetString(Int32, DataProviderReader).)
 | GetStringList(String, array<Object>[]()[]) | Gets a list of string values from a database. (Inherited from SqlDataApi.)
 | GetStringSet(String, array<Object>[]()[]) | Gets a list of string values from a database. (Inherited from SqlDataApi.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersion(Int32, DataProviderReader) | Gets a version value from a specified column. (Overrides SqlDataApi.GetVersion(Int32, DataProviderReader).)
 | Identifier | Gets an identifier for the data API. (Overrides SqlDataApi.Identifier.)
 | MapFileNames(String) | Maps the file names embedded in a connection string.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamePostfix | Gets the postfix used for encapsulating table and column names in SQL statements. (Overrides SqlDataApi.NamePostfix.)
 | NamePrefix | Gets the prefix used for encapsulating table and column names in SQL statements. (Overrides SqlDataApi.NamePrefix.)
 | ParameterPostfix | Gets the postfix used for encapsulating parameter names in SQL statements. (Overrides SqlDataApi.ParameterPostfix.)
 | ParameterPrefix | Gets the prefix used for encapsulating parameter names in SQL statements. (Overrides SqlDataApi.ParameterPrefix.)
 | Quote | Gets the character used for encapsulating a string value in SQL statements. (Overrides SqlDataApi.Quote.)
 | Safe(String) | Escapes a string for use in SQL statements. (Inherited from SqlDataApi.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Wildcard | Gets the character used for wildcard queries in SQL statements. (Overrides SqlDataApi.Wildcard.)
Inheritance Hierarchy
Object
 | SqlDataApi
 |  | SqlServerDataApi


SqlServerDataApi Constructor

SqlServerDataApi Constructor
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► SqlServerDataApi()()()
Members
Icon | Member | Description
 | SqlServerDataApi()()() | Initializes a new instance of the SqlServerDataApi class.
 | SqlServerDataApi(String) | Initializes a new instance of the SqlServerDataApi class.


SqlServerDataApi Constructor

SqlServerDataApi Constructor
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► SqlServerDataApi()()()
Initializes a new instance of the SqlServerDataApi class.
Declaration Syntax
C#
public SqlServerDataApi()


SqlServerDataApi Constructor (connectionString)

SqlServerDataApi Constructor (connectionString)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► SqlServerDataApi(String)
Initializes a new instance of the SqlServerDataApi class.
Declaration Syntax
C#
public SqlServerDataApi(
    string connectionString
)
Parameters
connectionString (String)
The connection string.


ConnectionString Property

ConnectionString Property
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► ConnectionString
Gets the connection string.
Declaration Syntax
C#
public override string ConnectionString { get; set; }
Value
The connection string.


CreateConnection Method

CreateConnection Method
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► CreateConnection()()()
Creates a physical database connection.
Declaration Syntax
C#
protected override IDbConnection CreateConnection()
Return Value
A connection object. Note that the connection is only created, not opened.


CreateParameter Method (name, value)

CreateParameter Method (name, value)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► CreateParameter(String, Object)
Creates a parameter for use in a command.
Declaration Syntax
C#
protected override IDbDataParameter CreateParameter(
    string name,
    Object value
)
Parameters
name (String)
The name of the parameter.
value (Object)
The value of the parameter.
Return Value

A parameter object in which the DbType of the value has been set and where the parameter value has been mapped to the native value expected by the database.

For instance, if value is an ID, the parameter value might be a Guid representing the same value.


GetDateTime Method (columnIndex, reader)

GetDateTime Method (columnIndex, reader)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► GetDateTime(Int32, DataProviderReader)
Gets a date/time value from a specified column.
Declaration Syntax
C#
public override DateTime GetDateTime(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to a DateTime


GetGuid Method

GetGuid Method
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► GetGuid()()()
Members
Icon | Member | Description
 | GetGuid(Int32, DataProviderReader) | Gets an id value from a specified column. (Overrides SqlDataApi.GetGuid(Int32, DataProviderReader).)
 | GetGuid(String, array<Object>[]()[], Guid) | Gets a guid value from the database.


GetGuid Method (columnIndex, reader)

GetGuid Method (columnIndex, reader)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► GetGuid(Int32, DataProviderReader)
Gets an id value from a specified column.
Declaration Syntax
C#
public override Guid GetGuid(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to a Guid


GetGuid Method (sql, parameters, defaultValue)

GetGuid Method (sql, parameters, defaultValue)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► GetGuid(String, array<Object>[]()[], Guid)
Gets a guid value from the database.
Declaration Syntax
C#
public Guid GetGuid(
    string sql,
    Object[] parameters,
    Guid defaultValue
)
Parameters
sql (String)
The SQL.
parameters (array< Object >[]()[])
The parameters.
defaultValue (Guid)
The default value.
Return Value


GetId Method (columnIndex, reader)

GetId Method (columnIndex, reader)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► GetId(Int32, DataProviderReader)
Gets an id value from a specified column.
Declaration Syntax
C#
public override ID GetId(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to an ID


GetInt Method

GetInt Method
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► GetInt()()()
Members
Icon | Member | Description
 | GetInt(Int32, DataProviderReader) | Gets an int32 value from a specified column. (Overrides SqlDataApi.GetInt(Int32, DataProviderReader).)
 | GetInt(String, array<Object>[]()[], Int32) | Gets an integer value from the database.


GetInt Method (columnIndex, reader)

GetInt Method (columnIndex, reader)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► GetInt(Int32, DataProviderReader)
Gets an int32 value from a specified column.
Declaration Syntax
C#
public override int GetInt(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to an Int32


GetInt Method (sql, parameters, defaultValue)

GetInt Method (sql, parameters, defaultValue)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► GetInt(String, array<Object>[]()[], Int32)
Gets an integer value from the database.
Declaration Syntax
C#
public int GetInt(
    string sql,
    Object[] parameters,
    int defaultValue
)
Parameters
sql (String)
The SQL.
parameters (array< Object >[]()[])
The parameters.
defaultValue (Int32)
The default value.
Return Value


GetLanguage Method (columnIndex, reader)

GetLanguage Method (columnIndex, reader)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► GetLanguage(Int32, DataProviderReader)
Gets a language value from a specified column.
Declaration Syntax
C#
public override Language GetLanguage(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to a Language


GetLong Method (columnIndex, reader)

GetLong Method (columnIndex, reader)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► GetLong(Int32, DataProviderReader)
Gets an int64 value from a specified column.
Declaration Syntax
C#
public override long GetLong(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to an Int32


GetString Method (columnIndex, reader)

GetString Method (columnIndex, reader)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► GetString(Int32, DataProviderReader)
Gets a string value from a specified column.
Declaration Syntax
C#
public override string GetString(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to a String


GetVersion Method (columnIndex, reader)

GetVersion Method (columnIndex, reader)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► GetVersion(Int32, DataProviderReader)
Gets a version value from a specified column.
Declaration Syntax
C#
public override Version GetVersion(
    int columnIndex,
    DataProviderReader reader
)
Parameters
columnIndex (Int32)
Index of the column.
reader (DataProviderReader)
The reader.
Return Value
The column value cast to a Version


Identifier Property

Identifier Property
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► Identifier
Gets an identifier for the data API.
Declaration Syntax
C#
public override string Identifier { get; }
Value
For SQL Server: The connection string.


MapFileNames Method (connectionString)

MapFileNames Method (connectionString)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► MapFileNames(String)
Maps the file names embedded in a connection string.
Declaration Syntax
C#
public static string MapFileNames(
    string connectionString
)
Parameters
connectionString (String)
The connection string.
Return Value


NamePostfix Property

NamePostfix Property
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► NamePostfix
Gets the postfix used for encapsulating table and column names in SQL statements.
Declaration Syntax
C#
public override string NamePostfix { get; }
Value
For SQL Server: ].


NamePrefix Property

NamePrefix Property
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► NamePrefix
Gets the prefix used for encapsulating table and column names in SQL statements.
Declaration Syntax
C#
public override string NamePrefix { get; }
Value
For SQL Server: [.


ParameterPostfix Property

ParameterPostfix Property
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► ParameterPostfix
Gets the postfix used for encapsulating parameter names in SQL statements.
Declaration Syntax
C#
public override string ParameterPostfix { get; }
Value
For SQL Server: Empty()()().


ParameterPrefix Property

ParameterPrefix Property
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► ParameterPrefix
Gets the prefix used for encapsulating parameter names in SQL statements.
Declaration Syntax
C#
public override string ParameterPrefix { get; }
Value
For SQL Server: @.


Quote Property

Quote Property
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► Quote
Gets the character used for encapsulating a string value in SQL statements.
Declaration Syntax
C#
public override string Quote { get; }
Value
Remarks
For example, SQL Server will use: ', and so will Firebird.


Wildcard Property

Wildcard Property
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataApi ► Wildcard
Gets the character used for wildcard queries in SQL statements.
Declaration Syntax
C#
public override string Wildcard { get; }
Remarks
For example, SQL Server will use: %.


SqlServerDataProvider Class

SqlServerDataProvider Class
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataProvider
SQL Server based data provider.
Declaration Syntax
C#
public class SqlServerDataProvider : SqlDataProvider
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerDataProvider(String) | Initializes a new instance of the SqlServerDataProvider class.
 | _descendantsLock | Used for syncronization of access to [Descendants] table (Inherited from SqlDataProvider.)
 | _descendantsShouldBeUpdated | Determines whether [Descendants] table should be updated (Inherited from SqlDataProvider.)
 | _languages | Languages (Inherited from SqlDataProvider.)
 | _prefetchCacheLock | (Inherited from SqlDataProvider.)
 | _rebuildThread | rebuilding thread (Inherited from SqlDataProvider.)
 | AddPrefetch(XmlNode) | Adds a prefetch option. (Inherited from SqlDataProvider.)
 | AddToPublishQueue(ID, String, DateTime, CallContext) | Adds an item to the publish queue. (Inherited from SqlDataProvider.)
 | AddVersion(ItemDefinition, VersionUri, CallContext) | Adds a version to an item. (Inherited from SqlDataProvider.)
 | Api | Gets the data API to the physical database. (Inherited from SqlDataProvider.)
 | BlobChunkSize | Gets the size of the individual chunks making up a BLOB.
 | BlobStreamExists(Guid, CallContext) | Determines whether the specified field contains a BLOB value. (Overrides DataProvider.BlobStreamExists(Guid, CallContext).)
 | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
 | ChangeFieldSharing(TemplateField, TemplateFieldSharing, CallContext) | Changes the type of field sharing for a single field. (Inherited from SqlDataProvider.)
 | ChangeTemplate(ItemDefinition, TemplateChangeList, CallContext) | Changes the template. (Inherited from SqlDataProvider.)
 | CleanupBlobs(CallContext) | Removes unused blob fields (Inherited from SqlDataProvider.)
 | CleanupDatabase(CallContext) | Cleanups the database. (Inherited from SqlDataProvider.)
 | CleanupFields(CallContext) | Removes all field data for non-existing items. (Inherited from SqlDataProvider.)
 | CleanupInvalidLanguageData()()() | Removes all invalid language data (ie. data for which the language does not exist). (Inherited from SqlDataProvider.)
 | CleanupOrphans()()() | Removes orphaned items from the database. (Inherited from SqlDataProvider.)
 | CleanupPublishQueue(DateTime, CallContext) | Cleans up the publish queue. (Inherited from SqlDataProvider.)
 | CleanupTemplateFields(array<String>[]()[], CallContext) | Cleanups the template fields. (Inherited from SqlDataProvider.)
 | CopyItem(ItemDefinition, ItemDefinition, String, ID, CallContext) | Copies an item. (Inherited from SqlDataProvider.)
 | CreateItem(ID, String, ID, ItemDefinition, CallContext) | Creates a item. (Inherited from SqlDataProvider.)
 | CreateSqlTranslator()()() | Creates the SQL translator. (Inherited from SqlDataProvider.)
 | DeleteItem(ItemDefinition, CallContext) | Deletes an item. (Overrides SqlDataProvider.DeleteItem(ItemDefinition, CallContext).)
 | Descendants_ItemCreated(ID, ID) | Performs changes to 'Descandants' table after item creation. (Inherited from SqlDataProvider.)
 | Descendants_ItemDeleted(ID) | Performs changes to 'Descandants' table after item deleting. (Inherited from SqlDataProvider.)
 | Disable | Disables a method. (Inherited from DataProvider.)
 | DisableGroup | Disables a group. (Inherited from DataProvider.)
 | Enable | Enables a method. (Inherited from DataProvider.)
 | EnableGroup | Enables a group. (Inherited from DataProvider.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(String, array<Object>[]()[]) | Check if data satisfying the specified SQL exists. (Inherited from SqlDataProvider.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBlobStream(Guid, CallContext) | Gets the BLOB stream associated with a field. (Overrides DataProvider.GetBlobStream(Guid, CallContext).)
 | GetChildIDs(ItemDefinition, CallContext) | Gets the child ids of an item. (Inherited from SqlDataProvider.)
 | GetDataSize(Int32, Int32) | Gets the size of the data managed by the provider. (Inherited from SqlDataProvider.)
 | GetDictionaryEntryCount()()() | Gets the number of dictionary entries. (Inherited from SqlDataProvider.)
 | GetFieldSharingConverter()()() | Gets a SqlDataProvider..::.FieldSharingConverter. (Inherited from SqlDataProvider.)
 | GetFieldValue(String, Guid) | Gets the field value. (Inherited from SqlDataProvider.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIdEnumerator(String, String, String) | Gets all id values. (Inherited from SqlDataProvider.)
 | GetItemDefinition(ID, CallContext) | Gets the definition of an item. (Inherited from SqlDataProvider.)
 | GetItemFields(ItemDefinition, VersionUri, CallContext) | Gets the fields of a specific item version. (Inherited from SqlDataProvider.)
 | GetItemKeyColumnName()()() | Gets the name of the 'item name' column. (Inherited from SqlDataProvider.)
 | GetItemsInWorkflowState(WorkflowInfo, CallContext) | Gets all items that are in a specific workflow state. (Inherited from SqlDataProvider.)
 | GetItemVersions(ItemDefinition, CallContext) | Gets a list of the available versions of an item. (Inherited from SqlDataProvider.)
 | GetLanguages()()() | Gets a list of all the language that have been defined in the database. (Inherited from SqlDataProvider.)
 | GetLanguages(CallContext) | Gets a list of all the language that have been defined in the database. (Inherited from SqlDataProvider.)
 | GetLock(Object) | Gets a lock. (Inherited from SqlDataProvider.)
 | GetParentID(ItemDefinition, CallContext) | Gets the parent ID of an item. (Inherited from SqlDataProvider.)
 | GetPrefetchDataFromCache(ID) | Gets the prefetch data from cache. (Inherited from SqlDataProvider.)
 | GetProperty(String, CallContext) | Gets a property. (Inherited from SqlDataProvider.)
 | GetPropertyCore(String, CallContext) | Gets the property core. (Inherited from SqlDataProvider.)
 | GetPropertyKeys(String, CallContext) | Gets a list of property keys matching a specific prefix. (Inherited from SqlDataProvider.)
 | GetPublishQueue(DateTime, DateTime, CallContext) | Gets the publish queue. (Inherited from SqlDataProvider.)
 | GetResolverSql(String) | Gets the resolver SQL. (Inherited from SqlDataProvider.)
 | GetRootID(CallContext) | Gets the root ID. (Inherited from SqlDataProvider.)
 | GetSharingType(TemplateField) | Gets the type of the sharing. (Inherited from SqlDataProvider.)
 | GetTemplateItemIds(CallContext) | Gets the template item ids. (Inherited from SqlDataProvider.)
 | GetTemplates(CallContext) | Gets the templates. (Inherited from DataProvider.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersions()()() | Gets a list of all versions that have been defined in the entire database. (Inherited from SqlDataProvider.)
 | GetWorkflowInfo(ItemDefinition, VersionUri, CallContext) | Gets the workflow info form an item. (Inherited from DataProvider.)
 | HasChildren(ItemDefinition, CallContext) | Determines whether the specified item definition has children. (Inherited from SqlDataProvider.)
 | IsEnabled(String) | Determines whether the specified method is enabled. (Inherited from DataProvider.)
 | LoadChildIds(String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>)) | Loads the child ids. (Overrides SqlDataProvider.LoadChildIds(String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>)).)
 | LoadItemDefinitions(String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>)) | Loads the item definitions. (Overrides SqlDataProvider.LoadItemDefinitions(String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>)).)
 | LoadItemFields(String, String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>)) | Loads the item fields. (Overrides SqlDataProvider.LoadItemFields(String, String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>)).)
 | LoadLanguages()()() | Loads the list of languages from the database. (Inherited from SqlDataProvider.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveItem(ItemDefinition, ItemDefinition, CallContext) | Moves an item (ie. changes its parent). (Inherited from SqlDataProvider.)
 | Name | Gets or sets the name. (Inherited from SqlDataProvider.)
 | PrefetchCache | Gets the prefetch cache. (Inherited from SqlDataProvider.)
 | PropertyCache | Gets the property cache. (Inherited from SqlDataProvider.)
 | QueryFast(String, CallContext) | Executes fast query. (Inherited from SqlDataProvider.)
 | RebuildDescendants()()() | Rebuilds the descendants table. (Inherited from SqlDataProvider.)
 | RemoveFields(ID, Language, Version) | Removes the fields. (Overrides SqlDataProvider.RemoveFields(ID, Language, Version).)
 | RemoveLanguageData(Language, CallContext) | Removes a language and all the data using the language from the database. (Inherited from SqlDataProvider.)
 | RemovePrefetchDataFromCache(ID) | Removes prefetch data from the cache. (Inherited from SqlDataProvider.)
 | RemoveProperty(String, Boolean, CallContext) | Removes a property. (Inherited from SqlDataProvider.)
 | RemovePropertyCore(String, Boolean, CallContext) | Removes the property core. (Inherited from SqlDataProvider.)
 | RemoveVersion(ItemDefinition, VersionUri, CallContext) | Removes a version from an item. (Inherited from SqlDataProvider.)
 | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from SqlDataProvider.)
 | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
 | RenameLanguageData(String, String, CallContext) | Renames a language binding. (Inherited from SqlDataProvider.)
 | ResolveNames(String) | Resolves the names. (Inherited from SqlDataProvider.)
 | ResolvePath(String, CallContext) | Resolves the path. (Inherited from DataProvider.)
 | SaveItem(ItemDefinition, ItemChanges, CallContext) | Saves an item. (Inherited from SqlDataProvider.)
 | SelectIDs(String, CallContext) | Selects a set of ids. (Inherited from SqlDataProvider.)
 | SelectSingleID(String, CallContext) | Selects a single ID. (Inherited from SqlDataProvider.)
 | SetBlobStream(Stream, Guid, CallContext) | Sets the BLOB stream associated with a field. (Overrides DataProvider.SetBlobStream(Stream, Guid, CallContext).)
 | SetFieldValue(String, Guid, String) | Sets the field value. (Inherited from SqlDataProvider.)
 | SetProperty(String, String, CallContext) | Sets a property. (Inherited from SqlDataProvider.)
 | SetPropertyCore(String, String, CallContext) | Sets the property core. (Inherited from SqlDataProvider.)
 | SetWorkflowInfo(ItemDefinition, VersionUri, WorkflowInfo, CallContext) | Sets the workflow info for an item. (Inherited from DataProvider.)
 | SkipDescendantsUpdate | Determines whether [Descendants] table should be updated. (Inherited from SqlDataProvider.)
 | StartRebuildDescendants()()() | Starts the rebuild descendants. (Inherited from SqlDataProvider.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Translator | Gets the Sitecore Query to SQL translator. (Inherited from SqlDataProvider.)
 | UpdateFieldValues(ID, SqlDataProvider..::.UpdateFieldValueDelegate, Boolean) | Updates field values. (Inherited from SqlDataProvider.)
 | WriteSharedField(ID, FieldChange, DateTime, Boolean) | Writes the shared field. (Inherited from SqlDataProvider.)
 | WriteUnversionedField(ID, FieldChange, DateTime, Boolean) | Writes the unversioned field. (Inherited from SqlDataProvider.)
 | WriteVersionedField(ID, FieldChange, DateTime, Boolean) | Writes the versioned field. (Inherited from SqlDataProvider.)
Inheritance Hierarchy
Object
 | DataProvider
 |  | SqlDataProvider
 |  |  | SqlServerDataProvider


SqlServerDataProvider Constructor (connectionString)

SqlServerDataProvider Constructor (connectionString)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataProvider ► SqlServerDataProvider(String)
Initializes a new instance of the SqlServerDataProvider class.
Declaration Syntax
C#
public SqlServerDataProvider(
    string connectionString
)
Parameters
connectionString (String)
The connection string.


BlobChunkSize Property

BlobChunkSize Property
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataProvider ► BlobChunkSize
Gets the size of the individual chunks making up a BLOB.
Declaration Syntax
C#
public virtual int BlobChunkSize { get; }
Value
The size of the BLOB chunk.


BlobStreamExists Method (blobId, context)

BlobStreamExists Method (blobId, context)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataProvider ► BlobStreamExists(Guid, CallContext)
Determines whether the specified field contains a BLOB value.
Declaration Syntax
C#
public override bool BlobStreamExists(
    Guid blobId,
    CallContext context
)
Parameters
blobId (Guid)
The BLOB id.
context (CallContext)
The context.
Return Value
true if the specified item definition has children; otherwise, false.


DeleteItem Method (itemDefinition, context)

DeleteItem Method (itemDefinition, context)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataProvider ► DeleteItem(ItemDefinition, CallContext)
Deletes an item.
Declaration Syntax
C#
public override bool DeleteItem(
    ItemDefinition itemDefinition,
    CallContext context
)
Parameters
itemDefinition (ItemDefinition)
The item definition.
context (CallContext)
The context.
Return Value


GetBlobStream Method (blobId, context)

GetBlobStream Method (blobId, context)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataProvider ► GetBlobStream(Guid, CallContext)
Gets the BLOB stream associated with a field.
Declaration Syntax
C#
public override Stream GetBlobStream(
    Guid blobId,
    CallContext context
)
Parameters
blobId (Guid)
The BLOB id.
context (CallContext)
The call context.
Return Value
The stream.


LoadChildIds Method (condition, parameters, prefetchData)

LoadChildIds Method (condition, parameters, prefetchData)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataProvider ► LoadChildIds(String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>))
Loads the child ids.
Declaration Syntax
C#
protected override void LoadChildIds(
    string condition,
    Object[] parameters,
    SafeDictionary<ID, PrefetchData> prefetchData
)
Parameters
condition (String)
The condition.
parameters (array< Object >[]()[])
The parameters.
prefetchData (SafeDictionary <(Of <( ID, PrefetchData >)>))
The working set.


LoadItemDefinitions Method (condition, parameters, prefetchData)

LoadItemDefinitions Method (condition, parameters, prefetchData)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataProvider ► LoadItemDefinitions(String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>))
Loads the item definitions.
Declaration Syntax
C#
protected override void LoadItemDefinitions(
    string condition,
    Object[] parameters,
    SafeDictionary<ID, PrefetchData> prefetchData
)
Parameters
condition (String)
The condition.
parameters (array< Object >[]()[])
The parameters.
prefetchData (SafeDictionary <(Of <( ID, PrefetchData >)>))
The working set.


LoadItemFields Method (itemCondition, fieldCondition, parameters, prefetchData)

LoadItemFields Method (itemCondition, fieldCondition, parameters, prefetchData)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataProvider ► LoadItemFields(String, String, array<Object>[]()[], SafeDictionary<(Of <(ID, PrefetchData>)>))
Loads the item fields.
Declaration Syntax
C#
protected override void LoadItemFields(
    string itemCondition,
    string fieldCondition,
    Object[] parameters,
    SafeDictionary<ID, PrefetchData> prefetchData
)
Parameters
itemCondition (String)
The item condition.
fieldCondition (String)
The field condition.
parameters (array< Object >[]()[])
The parameters.
prefetchData (SafeDictionary <(Of <( ID, PrefetchData >)>))
The working set.


RemoveFields Method (itemId, language, version)

RemoveFields Method (itemId, language, version)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataProvider ► RemoveFields(ID, Language, Version)
Removes the fields.
Declaration Syntax
C#
protected override void RemoveFields(
    ID itemId,
    Language language,
    Version version
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
version (Version)
The version.


SetBlobStream Method (stream, blobId, context)

SetBlobStream Method (stream, blobId, context)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerDataProvider ► SetBlobStream(Stream, Guid, CallContext)
Sets the BLOB stream associated with a field.
Declaration Syntax
C#
public override bool SetBlobStream(
    Stream stream,
    Guid blobId,
    CallContext context
)
Parameters
stream (Stream)
The stream.
blobId (Guid)
The BLOB id.
context (CallContext)
The call context.
Return Value


SqlServerHistoryStorage Class

SqlServerHistoryStorage Class
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStorage
SqlServerHistoryStorage
Declaration Syntax
C#
public class SqlServerHistoryStorage : HistoryStorage
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerHistoryStorage(String) | Initializes a new instance of the SqlServerHistoryStorage class.
 | SqlServerHistoryStorage(SqlDataApi) | Initializes a new instance of the SqlServerHistoryStorage class.
 | _api | Data API
 | AddEntry(HistoryEntry) | Adds an entry to the database. (Overrides HistoryStorage.AddEntry(HistoryEntry).)
 | Cleanup()()() | Removes outdated entries from storage. (Overrides HistoryStorage.Cleanup()()().)
 | EntryLifeTime | Gets or sets the entry life time. (Inherited from HistoryStorage.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHistory(DateTime, DateTime) | Gets the history for the database in a specified interval. (Overrides HistoryStorage.GetHistory(DateTime, DateTime).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HistoryStorage
 |  | SqlServerHistoryStorage


SqlServerHistoryStorage Constructor

SqlServerHistoryStorage Constructor
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStorage ► SqlServerHistoryStorage()()()
Members
Icon | Member | Description
 | SqlServerHistoryStorage(String) | Initializes a new instance of the SqlServerHistoryStorage class.
 | SqlServerHistoryStorage(SqlDataApi) | Initializes a new instance of the SqlServerHistoryStorage class.


SqlServerHistoryStorage Constructor (api)

SqlServerHistoryStorage Constructor (api)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStorage ► SqlServerHistoryStorage(SqlDataApi)
Initializes a new instance of the SqlServerHistoryStorage class.
Declaration Syntax
C#
public SqlServerHistoryStorage(
    SqlDataApi api
)
Parameters
api (SqlDataApi)
The API.


SqlServerHistoryStorage Constructor (connectionString)

SqlServerHistoryStorage Constructor (connectionString)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStorage ► SqlServerHistoryStorage(String)
Initializes a new instance of the SqlServerHistoryStorage class.
Declaration Syntax
C#
public SqlServerHistoryStorage(
    string connectionString
)
Parameters
connectionString (String)
The connection string.


_api Field

_api Field
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStorage ► _api
Data API
Declaration Syntax
C#
protected SqlDataApi _api


AddEntry Method (entry)

AddEntry Method (entry)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStorage ► AddEntry(HistoryEntry)
Adds an entry to the database.
Declaration Syntax
C#
public override void AddEntry(
    HistoryEntry entry
)
Parameters
entry (HistoryEntry)
The entry.


Cleanup Method

Cleanup Method
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStorage ► Cleanup()()()
Removes outdated entries from storage.
Declaration Syntax
C#
public override void Cleanup()


GetHistory Method (from, to)

GetHistory Method (from, to)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStorage ► GetHistory(DateTime, DateTime)
Gets the history for the database in a specified interval.
Declaration Syntax
C#
public override HistoryEntryCollection GetHistory(
    DateTime from,
    DateTime to
)
Parameters
from (DateTime)
From date (UTC).
to (DateTime)
To date (UTC).
Return Value
The history entries for the period.


SqlServerHistoryStore Class

SqlServerHistoryStore Class
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStore
SqlServerHistoryStore
Declaration Syntax
C#
public class SqlServerHistoryStore : HistoryStore
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerHistoryStore(String) | Initializes a new instance of the SqlServerHistoryStore class.
 | SqlServerHistoryStore(SqlDataApi) | Initializes a new instance of the SqlServerHistoryStore class.
 | _api | Data API
 | AddHistory(Item, String, String, String) | Adds the history. (Overrides HistoryStore.AddHistory(Item, String, String, String).)
 | ClearHistory(Item) | Clears the history. (Overrides HistoryStore.ClearHistory(Item).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHistory(Item) | Gets the history of the specified item. (Overrides HistoryStore.GetHistory(Item).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HistoryStore
 |  | SqlServerHistoryStore


SqlServerHistoryStore Constructor

SqlServerHistoryStore Constructor
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStore ► SqlServerHistoryStore()()()
Members
Icon | Member | Description
 | SqlServerHistoryStore(String) | Initializes a new instance of the SqlServerHistoryStore class.
 | SqlServerHistoryStore(SqlDataApi) | Initializes a new instance of the SqlServerHistoryStore class.


SqlServerHistoryStore Constructor (api)

SqlServerHistoryStore Constructor (api)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStore ► SqlServerHistoryStore(SqlDataApi)
Initializes a new instance of the SqlServerHistoryStore class.
Declaration Syntax
C#
public SqlServerHistoryStore(
    SqlDataApi api
)
Parameters
api (SqlDataApi)
The API.


SqlServerHistoryStore Constructor (connectionString)

SqlServerHistoryStore Constructor (connectionString)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStore ► SqlServerHistoryStore(String)
Initializes a new instance of the SqlServerHistoryStore class.
Declaration Syntax
C#
public SqlServerHistoryStore(
    string connectionString
)
Parameters
connectionString (String)
The connection string.


_api Field

_api Field
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStore ► _api
Data API
Declaration Syntax
C#
protected SqlDataApi _api


AddHistory Method (item, oldState, newState, text)

AddHistory Method (item, oldState, newState, text)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStore ► AddHistory(Item, String, String, String)
Adds the history.
Declaration Syntax
C#
public override void AddHistory(
    Item item,
    string oldState,
    string newState,
    string text
)
Parameters
item (Item)
The item.
oldState (String)
The old state.
newState (String)
The new state.
text (String)
The text.


ClearHistory Method (item)

ClearHistory Method (item)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStore ► ClearHistory(Item)
Clears the history.
Declaration Syntax
C#
public override void ClearHistory(
    Item item
)
Parameters
item (Item)
The item.


GetHistory Method (item)

GetHistory Method (item)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerHistoryStore ► GetHistory(Item)
Gets the history of the specified item.
Declaration Syntax
C#
public override WorkflowEvent[] GetHistory(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The history.


SqlServerIDTable Class

SqlServerIDTable Class
Namespaces ► Sitecore.Data.SqlServer ► SqlServerIDTable
Declaration Syntax
C#
public class SqlServerIDTable : IDTableProvider
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SqlServerIDTable(String, String) | Initializes a new instance of the SqlServerIDTable class
 | Add(IDTableEntry) | (Overrides IDTableProvider.Add(IDTableEntry).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String, String) | (Overrides IDTableProvider.GetID(String, String).)
 | GetKeys(String, ID) | (Overrides IDTableProvider.GetKeys(String, ID).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String, String) | (Overrides IDTableProvider.Remove(String, String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | IDTableProvider
 |  | SqlServerIDTable


SqlServerIDTable Constructor (connectionString, cacheSize)

SqlServerIDTable Constructor (connectionString, cacheSize)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerIDTable ► SqlServerIDTable(String, String)
Initializes a new instance of the SqlServerIDTable class
Declaration Syntax
C#
public SqlServerIDTable(
    string connectionString,
    string cacheSize
)
Parameters
connectionString (String)
cacheSize (String)


Add Method (entry)

Add Method (entry)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerIDTable ► Add(IDTableEntry)
Declaration Syntax
C#
public override void Add(
    IDTableEntry entry
)
Parameters
entry (IDTableEntry)


GetID Method (prefix, key)

GetID Method (prefix, key)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerIDTable ► GetID(String, String)
Declaration Syntax
C#
public override IDTableEntry GetID(
    string prefix,
    string key
)
Parameters
prefix (String)
key (String)


GetKeys Method (prefix, id)

GetKeys Method (prefix, id)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerIDTable ► GetKeys(String, ID)
Declaration Syntax
C#
public override IDTableEntry[] GetKeys(
    string prefix,
    ID id
)
Parameters
prefix (String)
id (ID)


Remove Method (prefix, key)

Remove Method (prefix, key)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerIDTable ► Remove(String, String)
Declaration Syntax
C#
public override void Remove(
    string prefix,
    string key
)
Parameters
prefix (String)
key (String)


SqlServerLinkDatabase Class

SqlServerLinkDatabase Class
Namespaces ► Sitecore.Data.SqlServer ► SqlServerLinkDatabase
Represents a SQL Server link database.
Declaration Syntax
C#
public class SqlServerLinkDatabase : SqlLinkDatabase
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerLinkDatabase(String) | Initializes a new instance of the SqlServerLinkDatabase class.
 | _dataApi | data API (Inherited from SqlLinkDatabase.)
 | AddLink(Item, ItemLink) | Adds the link. (Inherited from SqlLinkDatabase.)
 | Compact(Database) | Compacts the specified database. (Inherited from SqlLinkDatabase.)
 | ConnectionString | Gets the connection string.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBrokenLinks(Database) | Gets the broken links. (Inherited from SqlLinkDatabase.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReferenceCount(Item) | Gets the reference count. (Inherited from SqlLinkDatabase.)
 | GetReferences(Item) | Gets the references. (Inherited from SqlLinkDatabase.)
 | GetRefererCount(Item) | Obsolete. Gets the referrer count. (Inherited from LinkDatabase.)
 | GetReferers(Item) | Obsolete. Gets the referrers. (Inherited from LinkDatabase.)
 | GetReferrerCount(Item) | Gets the referrer count. (Inherited from SqlLinkDatabase.)
 | GetReferrers(Item) | Gets the referrers. (Inherited from SqlLinkDatabase.)
 | GetReferrers(Item, Boolean) | Obsolete. Gets the referrers. (Inherited from SqlLinkDatabase.)
 | GetString(String, Int32) | Gets a string. (Inherited from SqlLinkDatabase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasExternalReferers(Item, Boolean) | Obsolete. Determines whether the specified item has external referrers. (Inherited from LinkDatabase.)
 | HasExternalReferrers(Item, Boolean) | Determines whether the specified item has external referrers. (Inherited from LinkDatabase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rebuild(Database) | Rebuilds the specified database. (Inherited from LinkDatabase.)
 | RemoveLinks(Item) | Removes the links. (Inherited from SqlLinkDatabase.)
 | RemoveReferences(Item) | Removes the references. (Inherited from SqlLinkDatabase.)
 | TargetExists(ID, String, Database) | Determines if the target exists. (Inherited from LinkDatabase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLinks(Item, array<ItemLink>[]()[]) | Updates the links. (Inherited from SqlLinkDatabase.)
 | UpdateReferences(Item) | Updates the references. (Inherited from LinkDatabase.)
Inheritance Hierarchy
Object
 | LinkDatabase
 |  | SqlLinkDatabase
 |  |  | SqlServerLinkDatabase


SqlServerLinkDatabase Constructor (connectionString)

SqlServerLinkDatabase Constructor (connectionString)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerLinkDatabase ► SqlServerLinkDatabase(String)
Initializes a new instance of the SqlServerLinkDatabase class.
Declaration Syntax
C#
public SqlServerLinkDatabase(
    string connectionString
)
Parameters
connectionString (String)
The connection string.


ConnectionString Property

ConnectionString Property
Namespaces ► Sitecore.Data.SqlServer ► SqlServerLinkDatabase ► ConnectionString
Gets the connection string.
Declaration Syntax
C#
public virtual string ConnectionString { get; }
Value
The connection string.


SqlServerProxyDataProvider Class

SqlServerProxyDataProvider Class
Namespaces ► Sitecore.Data.SqlServer ► SqlServerProxyDataProvider
SQL Server based proxy data provider.
Declaration Syntax
C#
public class SqlServerProxyDataProvider : SqlProxyDataProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerProxyDataProvider(String) | Initializes a new instance of the SqlServerDataProvider class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReferences(ID) | Gets all references to a specific item. (Inherited from SqlProxyDataProvider.)
 | GetTarget(ID) | Gets the id of the item pointed to by a virtual id. (Inherited from SqlProxyDataProvider.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVirtualId(ID, ID, Boolean) | Gets the id of a shadow pointing to a specific item id within a specific proxy. (Inherited from SqlProxyDataProvider.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from ProxyDataProvider.)
 | RemoveData(ID) | Removes all data associated with a specific proxy. (Inherited from SqlProxyDataProvider.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProxyDataProvider
 |  | SqlProxyDataProvider
 |  |  | SqlServerProxyDataProvider


SqlServerProxyDataProvider Constructor (connectionString)

SqlServerProxyDataProvider Constructor (connectionString)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerProxyDataProvider ► SqlServerProxyDataProvider(String)
Initializes a new instance of the SqlServerDataProvider class.
Declaration Syntax
C#
public SqlServerProxyDataProvider(
    string connectionString
)
Parameters
connectionString (String)
The connection string.


SqlServerTaskDatabase Class

SqlServerTaskDatabase Class
Namespaces ► Sitecore.Data.SqlServer ► SqlServerTaskDatabase
SqlTaskDatabase
Declaration Syntax
C#
public class SqlServerTaskDatabase : TaskDatabase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerTaskDatabase(String) | Initializes a new instance of the SqlServerTaskDatabase class
 | ConnectionString |
 | Disable(Task) | (Overrides TaskDatabase.Disable(Task).)
 | Enable(Task) | (Overrides TaskDatabase.Enable(Task).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPendingTasks()()() | (Overrides TaskDatabase.GetPendingTasks()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MarkDone(Task) | (Overrides TaskDatabase.MarkDone(Task).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(Task) | (Overrides TaskDatabase.Remove(Task).)
 | RemoveItemTasks(Item) | (Overrides TaskDatabase.RemoveItemTasks(Item).)
 | RemoveItemTasks(Item, Type) | (Overrides TaskDatabase.RemoveItemTasks(Item, Type).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(Task, Boolean) | (Overrides TaskDatabase.Update(Task, Boolean).)
 | UpdateItemTask(Task, Boolean) | (Overrides TaskDatabase.UpdateItemTask(Task, Boolean).)
Inheritance Hierarchy
Object
 | TaskDatabase
 |  | SqlServerTaskDatabase


SqlServerTaskDatabase Constructor (connectionString)

SqlServerTaskDatabase Constructor (connectionString)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerTaskDatabase ► SqlServerTaskDatabase(String)
Initializes a new instance of the SqlServerTaskDatabase class
Declaration Syntax
C#
public SqlServerTaskDatabase(
    string connectionString
)
Parameters
connectionString (String)


ConnectionString Property

ConnectionString Property
Namespaces ► Sitecore.Data.SqlServer ► SqlServerTaskDatabase ► ConnectionString
Declaration Syntax
C#
public string ConnectionString { get; }


Disable Method (task)

Disable Method (task)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerTaskDatabase ► Disable(Task)
Declaration Syntax
C#
public override void Disable(
    Task task
)
Parameters
task (Task)


Enable Method (task)

Enable Method (task)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerTaskDatabase ► Enable(Task)
Declaration Syntax
C#
public override void Enable(
    Task task
)
Parameters
task (Task)


GetPendingTasks Method

GetPendingTasks Method
Namespaces ► Sitecore.Data.SqlServer ► SqlServerTaskDatabase ► GetPendingTasks()()()
Declaration Syntax
C#
public override Task[] GetPendingTasks()


MarkDone Method (task)

MarkDone Method (task)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerTaskDatabase ► MarkDone(Task)
Declaration Syntax
C#
public override void MarkDone(
    Task task
)
Parameters
task (Task)


Remove Method (task)

Remove Method (task)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerTaskDatabase ► Remove(Task)
Declaration Syntax
C#
public override void Remove(
    Task task
)
Parameters
task (Task)


RemoveItemTasks Method

RemoveItemTasks Method
Namespaces ► Sitecore.Data.SqlServer ► SqlServerTaskDatabase ► RemoveItemTasks()()()
Members
Icon | Member | Description
 | RemoveItemTasks(Item) | (Overrides TaskDatabase.RemoveItemTasks(Item).)
 | RemoveItemTasks(Item, Type) | (Overrides TaskDatabase.RemoveItemTasks(Item, Type).)


RemoveItemTasks Method (item)

RemoveItemTasks Method (item)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerTaskDatabase ► RemoveItemTasks(Item)
Declaration Syntax
C#
public override void RemoveItemTasks(
    Item item
)
Parameters
item (Item)


RemoveItemTasks Method (item, taskType)

RemoveItemTasks Method (item, taskType)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerTaskDatabase ► RemoveItemTasks(Item, Type)
Declaration Syntax
C#
public override void RemoveItemTasks(
    Item item,
    Type taskType
)
Parameters
item (Item)
taskType (Type)


Update Method (task, insertIfNotFound)

Update Method (task, insertIfNotFound)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerTaskDatabase ► Update(Task, Boolean)
Declaration Syntax
C#
public override void Update(
    Task task,
    bool insertIfNotFound
)
Parameters
task (Task)
insertIfNotFound (Boolean)


UpdateItemTask Method (task, insertIfNotFound)

UpdateItemTask Method (task, insertIfNotFound)
Namespaces ► Sitecore.Data.SqlServer ► SqlServerTaskDatabase ► UpdateItemTask(Task, Boolean)
Declaration Syntax
C#
public override void UpdateItemTask(
    Task task,
    bool insertIfNotFound
)
Parameters
task (Task)
insertIfNotFound (Boolean)


Sitecore.Data.Templates Namespace

Sitecore.Data.Templates Namespace
Namespaces ► Sitecore.Data.Templates
Declaration Syntax
C#
namespace Sitecore.Data.Templates
Types
All Types Classes Enumerations
Icon | Type | Description
 | Template..::.Builder | Represents a builder.
 | TemplateField..::.Builder | Implements a builder class for TemplateField.
 | TemplateSection..::.Builder | Implements a builder class for TemplateSection.
 | DefaultFieldSharing | DefaultFieldSharing
 | DefaultFieldSharing..::.SharingType | SharingType
 | Template | Template class Represents a template.
 | TemplateChangeList..::.TemplateChange | Represents a single change when changing the template of an item.
 | TemplateChangeAction | Defines the possible actions to make to a field when changing the template of an item.
 | TemplateChangeList | Holds a list of changes to be made when the template of an item is changed.
 | TemplateCollection | Represents a collection of templates.
 | TemplateField | Represents a template field.
 | TemplateFieldSharing | TemplateFieldSharing class
 | TemplateList | AccountList class
 | TemplateParser | Builds templates from an XML specification.
 | TemplateSection | Represents a template section.
 | TemplateUpdateContext | Obsolete. Represents a template update context.


DefaultFieldSharing Class

DefaultFieldSharing Class
Namespaces ► Sitecore.Data.Templates ► DefaultFieldSharing
DefaultFieldSharing
Declaration Syntax
C#
public static class DefaultFieldSharing
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Sharing | Gets the sharing.
Inheritance Hierarchy
Object
DefaultFieldSharing


Sharing Property

Sharing Property
Namespaces ► Sitecore.Data.Templates ► DefaultFieldSharing ► Sharing
Gets the sharing.
Declaration Syntax
C#
public static SafeDictionary<ID, DefaultFieldSharing..::.SharingType> Sharing { get; }
Value
The sharing.


DefaultFieldSharing.SharingType Enumeration

DefaultFieldSharing..::.SharingType Enumeration
Namespaces ► Sitecore.Data.Templates ► DefaultFieldSharing ► DefaultFieldSharing..::.SharingType
SharingType
Declaration Syntax
C#
public enum SharingType
Members
Member | Description
Unknown | Unknown
Shared | Shared
Unversioned | Unversioned
Versioned | Versioned


Template Class

Template Class
Namespaces ► Sitecore.Data.Templates ► Template
Template class
Represents a template.
Declaration Syntax
C#
public class Template
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddDefault(ID, String) | Adds a default to a field.
 | BaseIDs | Gets the IDs of the base templates.
 | ContainsField(ID) | Check if the template includes a specific field
 | CustomValues | Gets the custom values.
 | DescendsFrom(ID) | Determines whether the template descends directly or indirectly from another template.
 | DescendsFrom(Template) | Descendses from.
 | DescendsFromOrEquals(ID) | A convenience method to determine whether the template equals or descends directly or indirectly from another template.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullName | Gets the full name.
 | GetBaseTemplates()()() | Gets the base templates.
 | GetDefaults()()() | Gets the default values for all fields.
 | GetDescendants()()() | Gets the templates that inherit from this template.
 | GetField(ID) | Gets a field.
 | GetField(String) | Gets a field.
 | GetFields()()() | Gets the fields.
 | GetFields(Boolean) | Gets the fields.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSection(ID) | Gets a section.
 | GetSection(String) | Gets a section.
 | GetSections()()() | Gets the sections.
 | GetTemplateChangeList(Template) | Gets the template change list.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets the icon.
 | ID | Gets the ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Parse(XmlNode, TemplateCollection) | Constructs a template from an XmlNode..
 | StandardValueHolderId | Gets the id of the item holding standard values for the template.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Remarks
Inheritance Hierarchy
Object
Template
See Also
TemplateField
TemplateSection


AddDefault Method (fieldID, value)

AddDefault Method (fieldID, value)
Namespaces ► Sitecore.Data.Templates ► Template ► AddDefault(ID, String)
Adds a default to a field.
Declaration Syntax
C#
public void AddDefault(
    ID fieldID,
    string value
)
Parameters
fieldID (ID)
Field ID.
value (String)
Value.


BaseIDs Property

BaseIDs Property
Namespaces ► Sitecore.Data.Templates ► Template ► BaseIDs
Gets the IDs of the base templates.
Declaration Syntax
C#
public ID[] BaseIDs { get; }
Value
The base Ids.


ContainsField Method (fieldID)

ContainsField Method (fieldID)
Namespaces ► Sitecore.Data.Templates ► Template ► ContainsField(ID)
Check if the template includes a specific field
Declaration Syntax
C#
public bool ContainsField(
    ID fieldID
)
Parameters
fieldID (ID)
The field ID.
Return Value
true if the specified field ID contains field; otherwise, false.


CustomValues Property

CustomValues Property
Namespaces ► Sitecore.Data.Templates ► Template ► CustomValues
Gets the custom values.
Declaration Syntax
C#
public NameValueCollection CustomValues { get; }
Value
The custom values.


DescendsFrom Method

DescendsFrom Method
Namespaces ► Sitecore.Data.Templates ► Template ► DescendsFrom()()()
Members
Icon | Member | Description
 | DescendsFrom(ID) | Determines whether the template descends directly or indirectly from another template.
 | DescendsFrom(Template) | Descendses from.


DescendsFrom Method (templateId)

DescendsFrom Method (templateId)
Namespaces ► Sitecore.Data.Templates ► Template ► DescendsFrom(ID)
Determines whether the template descends directly or indirectly from another template.
Declaration Syntax
C#
public bool DescendsFrom(
    ID templateId
)
Parameters
templateId (ID)
The template id.
Return Value


DescendsFrom Method (template)

DescendsFrom Method (template)
Namespaces ► Sitecore.Data.Templates ► Template ► DescendsFrom(Template)
Descendses from.
Declaration Syntax
C#
public bool DescendsFrom(
    Template template
)
Parameters
template (Template)
The template.
Return Value


DescendsFromOrEquals Method (templateId)

DescendsFromOrEquals Method (templateId)
Namespaces ► Sitecore.Data.Templates ► Template ► DescendsFromOrEquals(ID)
A convenience method to determine whether the template equals or descends directly or indirectly from another template.
Declaration Syntax
C#
public bool DescendsFromOrEquals(
    ID templateId
)
Parameters
templateId (ID)
The template id.
Return Value


FullName Property

FullName Property
Namespaces ► Sitecore.Data.Templates ► Template ► FullName
Gets the full name.
Declaration Syntax
C#
public string FullName { get; }
Value
The full name.


GetBaseTemplates Method

GetBaseTemplates Method
Namespaces ► Sitecore.Data.Templates ► Template ► GetBaseTemplates()()()
Gets the base templates.
Declaration Syntax
C#
public TemplateList GetBaseTemplates()
Return Value


GetDefaults Method

GetDefaults Method
Namespaces ► Sitecore.Data.Templates ► Template ► GetDefaults()()()
Gets the default values for all fields.
Declaration Syntax
C#
public Hashtable GetDefaults()
Return Value
The defaults.


GetDescendants Method

GetDescendants Method
Namespaces ► Sitecore.Data.Templates ► Template ► GetDescendants()()()
Gets the templates that inherit from this template.
Declaration Syntax
C#
public Template[] GetDescendants()
Return Value
The descendants.


GetField Method

GetField Method
Namespaces ► Sitecore.Data.Templates ► Template ► GetField()()()
Members
Icon | Member | Description
 | GetField(ID) | Gets a field.
 | GetField(String) | Gets a field.


GetField Method (fieldID)

GetField Method (fieldID)
Namespaces ► Sitecore.Data.Templates ► Template ► GetField(ID)
Gets a field.
Declaration Syntax
C#
public TemplateField GetField(
    ID fieldID
)
Parameters
fieldID (ID)
Field ID.
Return Value
The field.


GetField Method (fieldName)

GetField Method (fieldName)
Namespaces ► Sitecore.Data.Templates ► Template ► GetField(String)
Gets a field.
Declaration Syntax
C#
public TemplateField GetField(
    string fieldName
)
Parameters
fieldName (String)
Name of the field.
Return Value
The field.


GetFields Method

GetFields Method
Namespaces ► Sitecore.Data.Templates ► Template ► GetFields()()()
Members
Icon | Member | Description
 | GetFields()()() | Gets the fields.
 | GetFields(Boolean) | Gets the fields.


GetFields Method

GetFields Method
Namespaces ► Sitecore.Data.Templates ► Template ► GetFields()()()
Gets the fields.
Declaration Syntax
C#
public TemplateField[] GetFields()
Return Value
The fields.


GetFields Method (includeBaseFields)

GetFields Method (includeBaseFields)
Namespaces ► Sitecore.Data.Templates ► Template ► GetFields(Boolean)
Gets the fields.
Declaration Syntax
C#
public TemplateField[] GetFields(
    bool includeBaseFields
)
Parameters
includeBaseFields (Boolean)
Include base fields.
Return Value
The fields.


GetSection Method

GetSection Method
Namespaces ► Sitecore.Data.Templates ► Template ► GetSection()()()
Members
Icon | Member | Description
 | GetSection(ID) | Gets a section.
 | GetSection(String) | Gets a section.


GetSection Method (sectionID)

GetSection Method (sectionID)
Namespaces ► Sitecore.Data.Templates ► Template ► GetSection(ID)
Gets a section.
Declaration Syntax
C#
public TemplateSection GetSection(
    ID sectionID
)
Parameters
sectionID (ID)
Section ID.
Return Value
The section.


GetSection Method (sectionName)

GetSection Method (sectionName)
Namespaces ► Sitecore.Data.Templates ► Template ► GetSection(String)
Gets a section.
Declaration Syntax
C#
public TemplateSection GetSection(
    string sectionName
)
Parameters
sectionName (String)
Name of the section.
Return Value
The section.


GetSections Method

GetSections Method
Namespaces ► Sitecore.Data.Templates ► Template ► GetSections()()()
Gets the sections.
Declaration Syntax
C#
public TemplateSection[] GetSections()
Return Value
The sections.


GetTemplateChangeList Method (target)

GetTemplateChangeList Method (target)
Namespaces ► Sitecore.Data.Templates ► Template ► GetTemplateChangeList(Template)
Gets the template change list.
Declaration Syntax
C#
public TemplateChangeList GetTemplateChangeList(
    Template target
)
Parameters
target (Template)
The target.
Return Value
The template change list.


Icon Property

Icon Property
Namespaces ► Sitecore.Data.Templates ► Template ► Icon
Gets the icon.
Declaration Syntax
C#
public string Icon { get; }
Value
The icon.


ID Property

ID Property
Namespaces ► Sitecore.Data.Templates ► Template ► ID
Gets the ID.
Declaration Syntax
C#
public ID ID { get; }
Value
The ID.


Name Property

Name Property
Namespaces ► Sitecore.Data.Templates ► Template ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Parse Method (node, owner)

Parse Method (node, owner)
Namespaces ► Sitecore.Data.Templates ► Template ► Parse(XmlNode, TemplateCollection)
Constructs a template from an XmlNode..
Declaration Syntax
C#
public static Template Parse(
    XmlNode node,
    TemplateCollection owner
)
Parameters
node (XmlNode)
Node.
owner (TemplateCollection)
Owner collection.
Return Value
The parse.


StandardValueHolderId Property

StandardValueHolderId Property
Namespaces ► Sitecore.Data.Templates ► Template ► StandardValueHolderId
Gets the id of the item holding standard values for the template.
Declaration Syntax
C#
public ID StandardValueHolderId { get; }
Value
The standard value holder id.


Template.Builder Class

Template..::.Builder Class
Namespaces ► Sitecore.Data.Templates ► Template ► Template..::.Builder
Represents a builder.
Declaration Syntax
C#
public class Builder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Template..::.Builder(String, ID, TemplateEngine) | Initializes a new instance of the Template..::.Builder class.
 | Template..::.Builder(String, ID, TemplateCollection) | Initializes a new instance of the Template..::.Builder class.
 | AddData(XmlNode) | Adds the data.
 | AddSection(String, ID) | Adds the section.
 | AddSection(XmlNode) | Adds the section.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(XmlNode, TemplateCollection) | Parses the specified node.
 | SetBaseIDs(String) | Sets the base Ids.
 | SetFullName(String) | Sets the full name.
 | SetIcon(String) | Sets the icon.
 | SetID(ID) | Sets the ID.
 | SetName(String) | Sets the name.
 | SetStandardValueHolderId(String) | Sets the standard value holder id.
 | Template | Gets the template.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Template..::.Builder


Template.Builder Constructor

Template..::.Builder Constructor
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► Template..::.Builder()()()
Members
Icon | Member | Description
 | Template..::.Builder(String, ID, TemplateEngine) | Initializes a new instance of the Template..::.Builder class.
 | Template..::.Builder(String, ID, TemplateCollection) | Initializes a new instance of the Template..::.Builder class.


Template.Builder Constructor (templateName, templateID, engine)

Template..::.Builder Constructor (templateName, templateID, engine)
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► Template..::.Builder(String, ID, TemplateEngine)
Initializes a new instance of the Template..::.Builder class.
Declaration Syntax
C#
public Builder(
    string templateName,
    ID templateID,
    TemplateEngine engine
)
Parameters
templateName (String)
Name of the template.
templateID (ID)
The template ID.
engine (TemplateEngine)
The engine.


Template.Builder Constructor (templateName, templateID, owner)

Template..::.Builder Constructor (templateName, templateID, owner)
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► Template..::.Builder(String, ID, TemplateCollection)
Initializes a new instance of the Template..::.Builder class.
Declaration Syntax
C#
public Builder(
    string templateName,
    ID templateID,
    TemplateCollection owner
)
Parameters
templateName (String)
Name of the template.
templateID (ID)
The template ID.
owner (TemplateCollection)
The owner.


AddData Method (node)

AddData Method (node)
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► AddData(XmlNode)
Adds the data.
Declaration Syntax
C#
public void AddData(
    XmlNode node
)
Parameters
node (XmlNode)
The node.


AddSection Method

AddSection Method
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► AddSection()()()
Members
Icon | Member | Description
 | AddSection(String, ID) | Adds the section.
 | AddSection(XmlNode) | Adds the section.


AddSection Method (sectionName, sectionID)

AddSection Method (sectionName, sectionID)
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► AddSection(String, ID)
Adds the section.
Declaration Syntax
C#
public TemplateSection..::.Builder AddSection(
    string sectionName,
    ID sectionID
)
Parameters
sectionName (String)
Name of the section.
sectionID (ID)
The section ID.
Return Value
The section.


AddSection Method (node)

AddSection Method (node)
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► AddSection(XmlNode)
Adds the section.
Declaration Syntax
C#
public TemplateSection..::.Builder AddSection(
    XmlNode node
)
Parameters
node (XmlNode)
The node.
Return Value
The section.


Parse Method (node, owner)

Parse Method (node, owner)
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► Parse(XmlNode, TemplateCollection)
Parses the specified node.
Declaration Syntax
C#
public static Template..::.Builder Parse(
    XmlNode node,
    TemplateCollection owner
)
Parameters
node (XmlNode)
The node.
owner (TemplateCollection)
The owner.
Return Value
The parse.


SetBaseIDs Method (baseIDs)

SetBaseIDs Method (baseIDs)
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► SetBaseIDs(String)
Sets the base Ids.
Declaration Syntax
C#
public void SetBaseIDs(
    string baseIDs
)
Parameters
baseIDs (String)
The base Ids.


SetFullName Method (fullName)

SetFullName Method (fullName)
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► SetFullName(String)
Sets the full name.
Declaration Syntax
C#
public void SetFullName(
    string fullName
)
Parameters
fullName (String)
The full name.


SetIcon Method (icon)

SetIcon Method (icon)
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► SetIcon(String)
Sets the icon.
Declaration Syntax
C#
public void SetIcon(
    string icon
)
Parameters
icon (String)
The icon.


SetID Method (templateID)

SetID Method (templateID)
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► SetID(ID)
Sets the ID.
Declaration Syntax
C#
public void SetID(
    ID templateID
)
Parameters
templateID (ID)
The template ID.


SetName Method (name)

SetName Method (name)
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► SetName(String)
Sets the name.
Declaration Syntax
C#
public void SetName(
    string name
)
Parameters
name (String)
The name.


SetStandardValueHolderId Method (value)

SetStandardValueHolderId Method (value)
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► SetStandardValueHolderId(String)
Sets the standard value holder id.
Declaration Syntax
C#
public void SetStandardValueHolderId(
    string value
)
Parameters
value (String)
The value.


Template Property

Template Property
Namespaces ► Sitecore.Data.Templates ► Template..::.Builder ► Template
Gets the template.
Declaration Syntax
C#
public Template Template { get; }
Value
The template.


TemplateChangeAction Enumeration

TemplateChangeAction Enumeration
Namespaces ► Sitecore.Data.Templates ► TemplateChangeAction
Defines the possible actions to make to a field when changing the template of an item.
Declaration Syntax
C#
public enum TemplateChangeAction
Members
Member | Description
None | None
ChangeFieldID | Changes the ID of the field.
DeleteField | Deletes the field.


TemplateChangeList Class

TemplateChangeList Class
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList
Holds a list of changes to be made when the template of an item is changed.
Declaration Syntax
C#
public class TemplateChangeList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateChangeList(TemplateItem, TemplateItem) | Obsolete. Creates a new TemplateChangeList instance.
 | TemplateChangeList(Template, Template) | Creates a new TemplateChangeList instance.
 | Add(TemplateChangeAction, TemplateField, TemplateField) | Adds an action.
 | Changes | Gets the changes.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldChanged(TemplateField, TemplateField) | A field has changed.
 | FieldChanged(TemplateFieldItem, TemplateFieldItem) | Obsolete. A field has changed.
 | FieldRemoved(TemplateField) | A field has been removed.
 | FieldRemoved(TemplateFieldItem) | Obsolete. A field has been removed.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreferredLanguage | Gets or sets the preferred language.
 | PreferredVersion | Gets or sets the preferred version.
 | Source | Gets the source.
 | Target | Gets the target.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TemplateChangeList


TemplateChangeList Constructor

TemplateChangeList Constructor
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► TemplateChangeList()()()
Members
Icon | Member | Description
 | TemplateChangeList(TemplateItem, TemplateItem) | Obsolete. Creates a new TemplateChangeList instance.
 | TemplateChangeList(Template, Template) | Creates a new TemplateChangeList instance.


TemplateChangeList Constructor (source, target)

TemplateChangeList Constructor (source, target)
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► TemplateChangeList(TemplateItem, TemplateItem)
Creates a new TemplateChangeList instance.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public TemplateChangeList(
    TemplateItem source,
    TemplateItem target
)
Parameters
source (TemplateItem)
Source.
target (TemplateItem)
Target.


TemplateChangeList Constructor (source, target)

TemplateChangeList Constructor (source, target)
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► TemplateChangeList(Template, Template)
Creates a new TemplateChangeList instance.
Declaration Syntax
C#
public TemplateChangeList(
    Template source,
    Template target
)
Parameters
source (Template)
Source.
target (Template)
Target.


Add Method (action, source, target)

Add Method (action, source, target)
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► Add(TemplateChangeAction, TemplateField, TemplateField)
Adds an action.
Declaration Syntax
C#
public void Add(
    TemplateChangeAction action,
    TemplateField source,
    TemplateField target
)
Parameters
action (TemplateChangeAction)
Action.
source (TemplateField)
Source.
target (TemplateField)
Target.


Changes Property

Changes Property
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► Changes
Gets the changes.
Declaration Syntax
C#
public TemplateChangeList..::.TemplateChange[] Changes { get; }
Value
The changes.


FieldChanged Method

FieldChanged Method
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► FieldChanged()()()
Members
Icon | Member | Description
 | FieldChanged(TemplateField, TemplateField) | A field has changed.
 | FieldChanged(TemplateFieldItem, TemplateFieldItem) | Obsolete. A field has changed.


FieldChanged Method (source, target)

FieldChanged Method (source, target)
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► FieldChanged(TemplateFieldItem, TemplateFieldItem)
A field has changed.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public void FieldChanged(
    TemplateFieldItem source,
    TemplateFieldItem target
)
Parameters
source (TemplateFieldItem)
Source.
target (TemplateFieldItem)
Target.


FieldChanged Method (source, target)

FieldChanged Method (source, target)
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► FieldChanged(TemplateField, TemplateField)
A field has changed.
Declaration Syntax
C#
public void FieldChanged(
    TemplateField source,
    TemplateField target
)
Parameters
source (TemplateField)
Source.
target (TemplateField)
Target.


FieldRemoved Method

FieldRemoved Method
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► FieldRemoved()()()
Members
Icon | Member | Description
 | FieldRemoved(TemplateField) | A field has been removed.
 | FieldRemoved(TemplateFieldItem) | Obsolete. A field has been removed.


FieldRemoved Method (field)

FieldRemoved Method (field)
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► FieldRemoved(TemplateFieldItem)
A field has been removed.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public void FieldRemoved(
    TemplateFieldItem field
)
Parameters
field (TemplateFieldItem)
Field.


FieldRemoved Method (field)

FieldRemoved Method (field)
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► FieldRemoved(TemplateField)
A field has been removed.
Declaration Syntax
C#
public void FieldRemoved(
    TemplateField field
)
Parameters
field (TemplateField)
Field.


PreferredLanguage Property

PreferredLanguage Property
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► PreferredLanguage
Gets or sets the preferred language.
Declaration Syntax
C#
public Language PreferredLanguage { get; set; }
Value
The preferred language.


PreferredVersion Property

PreferredVersion Property
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► PreferredVersion
Gets or sets the preferred version.
Declaration Syntax
C#
public Version PreferredVersion { get; set; }
Value
The preferred version.


Source Property

Source Property
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► Source
Gets the source.
Declaration Syntax
C#
public Template Source { get; }
Value
The source.


Target Property

Target Property
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► Target
Gets the target.
Declaration Syntax
C#
public Template Target { get; }
Value
The target.


TemplateChangeList.TemplateChange Class

TemplateChangeList..::.TemplateChange Class
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList ► TemplateChangeList..::.TemplateChange
Represents a single change when changing the template of an item.
Declaration Syntax
C#
public class TemplateChange
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateChangeList..::.TemplateChange(TemplateChangeAction, TemplateField, TemplateChangeList) | Creates a new TemplateChangeList..::.TemplateChange instance.
 | TemplateChangeList..::.TemplateChange(TemplateChangeAction, TemplateField, TemplateField, TemplateChangeList) | Creates a new TemplateChangeList..::.TemplateChange instance.
 | Action | Gets the action.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Owner | Gets the owner.
 | SourceField | Gets the source field.
 | TargetField | Gets the target field.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TemplateChangeList..::.TemplateChange


TemplateChangeList.TemplateChange Constructor

TemplateChangeList..::.TemplateChange Constructor
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList..::.TemplateChange ► TemplateChangeList..::.TemplateChange()()()
Members
Icon | Member | Description
 | TemplateChangeList..::.TemplateChange(TemplateChangeAction, TemplateField, TemplateChangeList) | Creates a new TemplateChangeList..::.TemplateChange instance.
 | TemplateChangeList..::.TemplateChange(TemplateChangeAction, TemplateField, TemplateField, TemplateChangeList) | Creates a new TemplateChangeList..::.TemplateChange instance.


TemplateChangeList.TemplateChange Constructor (action, sourceField, owner)

TemplateChangeList..::.TemplateChange Constructor (action, sourceField, owner)
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList..::.TemplateChange ► TemplateChangeList..::.TemplateChange(TemplateChangeAction, TemplateField, TemplateChangeList)
Creates a new TemplateChangeList..::.TemplateChange instance.
Declaration Syntax
C#
public TemplateChange(
    TemplateChangeAction action,
    TemplateField sourceField,
    TemplateChangeList owner
)
Parameters
action (TemplateChangeAction)
Action.
sourceField (TemplateField)
Source field.
owner (TemplateChangeList)
Owner.


TemplateChangeList.TemplateChange Constructor (action, sourceField, targetField, owner)

TemplateChangeList..::.TemplateChange Constructor (action, sourceField, targetField, owner)
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList..::.TemplateChange ► TemplateChangeList..::.TemplateChange(TemplateChangeAction, TemplateField, TemplateField, TemplateChangeList)
Creates a new TemplateChangeList..::.TemplateChange instance.
Declaration Syntax
C#
public TemplateChange(
    TemplateChangeAction action,
    TemplateField sourceField,
    TemplateField targetField,
    TemplateChangeList owner
)
Parameters
action (TemplateChangeAction)
Action.
sourceField (TemplateField)
Source field.
targetField (TemplateField)
Target field.
owner (TemplateChangeList)
Owner.


Action Property

Action Property
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList..::.TemplateChange ► Action
Gets the action.
Declaration Syntax
C#
public TemplateChangeAction Action { get; }
Value
The action.


Owner Property

Owner Property
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList..::.TemplateChange ► Owner
Gets the owner.
Declaration Syntax
C#
public TemplateChangeList Owner { get; }
Value
The owner.


SourceField Property

SourceField Property
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList..::.TemplateChange ► SourceField
Gets the source field.
Declaration Syntax
C#
public TemplateField SourceField { get; }
Value
The source field.


TargetField Property

TargetField Property
Namespaces ► Sitecore.Data.Templates ► TemplateChangeList..::.TemplateChange ► TargetField
Gets the target field.
Declaration Syntax
C#
public TemplateField TargetField { get; }
Value
The target field.


TemplateCollection Class

TemplateCollection Class
Namespaces ► Sitecore.Data.Templates ► TemplateCollection
Represents a collection of templates.
Declaration Syntax
C#
public class TemplateCollection : Collection<Template>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateCollection()()() | Initializes a new instance of the TemplateCollection class.
 | TemplateCollection(array<Template>[]()[]) | Obsolete. Initializes a new instance of the TemplateCollection class.
 | Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Template >)>).)
 | Clear()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Template >)>).)
 | ClearItems()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Template >)>).)
 | Clone()()() | Creates a shallow copy of the collection.
 | Contains(ID) | Creates a shallow copy of the collection.
 | Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Template >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Template >)>).)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Template >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAll()()() | Gets all templates in the collection.
 | GetEnumerator()()() | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Template >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTemplate(String) | Gets the template.
 | GetTemplate(ID) | Gets the template.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Template >)>).)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Template >)>).)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Template >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Template >)>).)
 | Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Template >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Template >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Template >)>).)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Template >)>).)
 | Reset(array<Template>[]()[]) | Resets the specified templates.
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection<(Of <( Template >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection<(Of <( Template >)>)
 |  | TemplateCollection


TemplateCollection Constructor

TemplateCollection Constructor
Namespaces ► Sitecore.Data.Templates ► TemplateCollection ► TemplateCollection()()()
Members
Icon | Member | Description
 | TemplateCollection()()() | Initializes a new instance of the TemplateCollection class.
 | TemplateCollection(array<Template>[]()[]) | Obsolete. Initializes a new instance of the TemplateCollection class.


TemplateCollection Constructor

TemplateCollection Constructor
Namespaces ► Sitecore.Data.Templates ► TemplateCollection ► TemplateCollection()()()
Initializes a new instance of the TemplateCollection class.
Declaration Syntax
C#
public TemplateCollection()


TemplateCollection Constructor (templates)

TemplateCollection Constructor (templates)
Namespaces ► Sitecore.Data.Templates ► TemplateCollection ► TemplateCollection(array<Template>[]()[])
Initializes a new instance of the TemplateCollection class.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated", false)]
public TemplateCollection(
    Template[] templates
)
Parameters
templates (array< Template >[]()[])
The templates.


Clone Method

Clone Method
Namespaces ► Sitecore.Data.Templates ► TemplateCollection ► Clone()()()
Creates a shallow copy of the collection.
Declaration Syntax
C#
public TemplateCollection Clone()
Return Value


Contains Method (templateId)

Contains Method (templateId)
Namespaces ► Sitecore.Data.Templates ► TemplateCollection ► Contains(ID)
Creates a shallow copy of the collection.
Declaration Syntax
C#
public bool Contains(
    ID templateId
)
Parameters
templateId (ID)
The template id.
Return Value
true if [contains] [the specified template id]; otherwise, false.


GetAll Method

GetAll Method
Namespaces ► Sitecore.Data.Templates ► TemplateCollection ► GetAll()()()
Gets all templates in the collection.
Declaration Syntax
C#
public virtual Template[] GetAll()
Return Value


GetTemplate Method

GetTemplate Method
Namespaces ► Sitecore.Data.Templates ► TemplateCollection ► GetTemplate()()()
Members
Icon | Member | Description
 | GetTemplate(String) | Gets the template.
 | GetTemplate(ID) | Gets the template.


GetTemplate Method (templateID)

GetTemplate Method (templateID)
Namespaces ► Sitecore.Data.Templates ► TemplateCollection ► GetTemplate(ID)
Gets the template.
Declaration Syntax
C#
public virtual Template GetTemplate(
    ID templateID
)
Parameters
templateID (ID)
The template ID.
Return Value


GetTemplate Method (fullName)

GetTemplate Method (fullName)
Namespaces ► Sitecore.Data.Templates ► TemplateCollection ► GetTemplate(String)
Gets the template.
Declaration Syntax
C#
public virtual Template GetTemplate(
    string fullName
)
Parameters
fullName (String)
The full name.
Return Value


Reset Method (templates)

Reset Method (templates)
Namespaces ► Sitecore.Data.Templates ► TemplateCollection ► Reset(array<Template>[]()[])
Resets the specified templates.
Declaration Syntax
C#
public virtual void Reset(
    Template[] templates
)
Parameters
templates (array< Template >[]()[])
The templates.


TemplateField Class

TemplateField Class
Namespaces ► Sitecore.Data.Templates ► TemplateField
Represents a template field.
Declaration Syntax
C#
public class TemplateField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateField(String, ID, TemplateSection) | Creates a new TemplateField instance.
 | DefaultValue | Gets the default value.
 | Empty | Gets the empty (ie. null) instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExcludeFromTextSearch | Marks field to be skipped by index crawler when looking for fields using field type. Does not affect direct references to fields by name or ID. In default installation excludes a text field from Lucene FTS index ('system').
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDescription(Language) | Gets the description.
 | GetDescriptionIndex(Language) | Gets the description index.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTitle(Language) | Gets the title.
 | GetTitleIndex(Language) | Obsolete. Gets the index of the title.
 | GetToolTip(Language) | Gets the tool tip.
 | GetToolTipIndex(Language) | Obsolete. Gets the index of the tool tip.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HelpLink | Gets the help link.
 | Icon | Gets the icon.
 | ID | Gets the ID.
 | IsBlob | Gets a value indicating whether the field should be loaded on demand.
 | IsEmpty | Gets a value indicating whether this instance is empty (ie. the null instance).
 | IsShared | Gets a value indicating whether this TemplateField is shared.
 | IsUnversioned | Gets a value indicating whether this TemplateField is unversioned.
 | IsVersioned | Gets a value indicating whether this TemplateField is versioned.
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | ResetBlank | Gets a value indicating whether blank fields should be set to their default value.
 | Section | Gets the section.
 | Sortorder | Gets the sortorder.
 | Source | Gets the source.
 | Style | Gets the CSS style to use in the client.
 | Template | Gets the template.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the type.
 | TypeKey | Gets the type key.
 | Validation | Gets the validation.
 | ValidationText | Gets the validation text.
Remarks
Remarks
Inheritance Hierarchy
Object
TemplateField
See Also
TemplateSection
Template


TemplateField Constructor (name, id, section)

TemplateField Constructor (name, id, section)
Namespaces ► Sitecore.Data.Templates ► TemplateField ► TemplateField(String, ID, TemplateSection)
Creates a new TemplateField instance.
Declaration Syntax
C#
public TemplateField(
    string name,
    ID id,
    TemplateSection section
)
Parameters
name (String)
Name.
id (ID)
Id.
section (TemplateSection)
Section.


DefaultValue Property

DefaultValue Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► DefaultValue
Gets the default value.
Declaration Syntax
C#
public string DefaultValue { get; }
Value
The default value.


Empty Property

Empty Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► Empty
Gets the empty (ie. null) instance.
Declaration Syntax
C#
public static TemplateField Empty { get; }
Value
The empty.


ExcludeFromTextSearch Property

ExcludeFromTextSearch Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► ExcludeFromTextSearch
Marks field to be skipped by index crawler when looking for fields using field type. Does not affect direct references to fields by name or ID. In default installation excludes a text field from Lucene FTS index ('system').
Declaration Syntax
C#
public bool ExcludeFromTextSearch { get; }


GetDescription Method (language)

GetDescription Method (language)
Namespaces ► Sitecore.Data.Templates ► TemplateField ► GetDescription(Language)
Gets the description.
Declaration Syntax
C#
public string GetDescription(
    Language language
)
Parameters
language (Language)
Language.
Return Value
The description.


GetDescriptionIndex Method (language)

GetDescriptionIndex Method (language)
Namespaces ► Sitecore.Data.Templates ► TemplateField ► GetDescriptionIndex(Language)
Gets the description index.
Declaration Syntax
C#
public int GetDescriptionIndex(
    Language language
)
Parameters
language (Language)
Language.
Return Value
The description index.


GetTitle Method (language)

GetTitle Method (language)
Namespaces ► Sitecore.Data.Templates ► TemplateField ► GetTitle(Language)
Gets the title.
Declaration Syntax
C#
public string GetTitle(
    Language language
)
Parameters
language (Language)
Language.
Return Value
The title.


GetTitleIndex Method (language)

GetTitleIndex Method (language)
Namespaces ► Sitecore.Data.Templates ► TemplateField ► GetTitleIndex(Language)
Gets the index of the title.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated")]
public int GetTitleIndex(
    Language language
)
Parameters
language (Language)
The language.
Return Value
The index of the title.


GetToolTip Method (language)

GetToolTip Method (language)
Namespaces ► Sitecore.Data.Templates ► TemplateField ► GetToolTip(Language)
Gets the tool tip.
Declaration Syntax
C#
public string GetToolTip(
    Language language
)
Parameters
language (Language)
Language.
Return Value
The tool tip.


GetToolTipIndex Method (language)

GetToolTipIndex Method (language)
Namespaces ► Sitecore.Data.Templates ► TemplateField ► GetToolTipIndex(Language)
Gets the index of the tool tip.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated")]
public int GetToolTipIndex(
    Language language
)
Parameters
language (Language)
The language.
Return Value
The Int32.


HelpLink Property

HelpLink Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► HelpLink
Gets the help link.
Declaration Syntax
C#
public string HelpLink { get; }
Value
The help link.


Icon Property

Icon Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► Icon
Gets the icon.
Declaration Syntax
C#
public string Icon { get; }
Value
The icon.


ID Property

ID Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► ID
Gets the ID.
Declaration Syntax
C#
public ID ID { get; }
Value
The ID.


IsBlob Property

IsBlob Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► IsBlob
Gets a value indicating whether the field should be loaded on demand.
Declaration Syntax
C#
public bool IsBlob { get; }
Value
true if shared; otherwise, false.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► IsEmpty
Gets a value indicating whether this instance is empty (ie. the null instance).
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


IsShared Property

IsShared Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► IsShared
Gets a value indicating whether this TemplateField is shared.
Declaration Syntax
C#
public bool IsShared { get; }
Value
true if shared; otherwise, false.


IsUnversioned Property

IsUnversioned Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► IsUnversioned
Gets a value indicating whether this TemplateField is unversioned.
Declaration Syntax
C#
public bool IsUnversioned { get; }
Value
true if unversioned; otherwise, false.


IsVersioned Property

IsVersioned Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► IsVersioned
Gets a value indicating whether this TemplateField is versioned.
Declaration Syntax
C#
public bool IsVersioned { get; }
Value
true if versioned; otherwise, false.


Key Property

Key Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


Name Property

Name Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


ResetBlank Property

ResetBlank Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► ResetBlank
Gets a value indicating whether blank fields should be set to their default value.
Declaration Syntax
C#
public bool ResetBlank { get; }
Value
true if blank fields should be set to their default value; otherwise, false.


Section Property

Section Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► Section
Gets the section.
Declaration Syntax
C#
public TemplateSection Section { get; }
Value
The section.


Sortorder Property

Sortorder Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► Sortorder
Gets the sortorder.
Declaration Syntax
C#
public int Sortorder { get; }
Value
The sortorder.


Source Property

Source Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► Source
Gets the source.
Declaration Syntax
C#
public string Source { get; }
Value
The source.


Style Property

Style Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► Style
Gets the CSS style to use in the client.
Declaration Syntax
C#
public string Style { get; }
Value
The style.


Template Property

Template Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► Template
Gets the template.
Declaration Syntax
C#
public Template Template { get; }
Value
The template.


Type Property

Type Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► Type
Gets the type.
Declaration Syntax
C#
public string Type { get; }
Value
The type.


TypeKey Property

TypeKey Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► TypeKey
Gets the type key.
Declaration Syntax
C#
public string TypeKey { get; }
Value
The type key.


Validation Property

Validation Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► Validation
Gets the validation.
Declaration Syntax
C#
public string Validation { get; }
Value
The validation.


ValidationText Property

ValidationText Property
Namespaces ► Sitecore.Data.Templates ► TemplateField ► ValidationText
Gets the validation text.
Declaration Syntax
C#
public string ValidationText { get; }
Value
The validation text.


TemplateField.Builder Class

TemplateField..::.Builder Class
Namespaces ► Sitecore.Data.Templates ► TemplateField ► TemplateField..::.Builder
Implements a builder class for TemplateField.
Declaration Syntax
C#
public class Builder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateField..::.Builder(String, ID, TemplateSection) | Creates a new TemplateField..::.Builder instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Field | Gets the field.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetDefaultValue(String) | Sets the default value.
 | SetDescription(String, Language) | Sets the description.
 | SetExcludeFromTextSearch(Boolean) | Sets the 'exclude from index' flag.
 | SetHelpLink(String) | Sets the help link.
 | SetIcon(String) | Sets the icon.
 | SetIsBlob(Boolean) | Sets the load on demand flag.
 | SetResetBlank(Boolean) | Sets the reset blank flag.
 | SetShared(Boolean) | Sets the shared flag.
 | SetSortorder(Int32) | Sets the sortorder.
 | SetSource(String) | Sets the source.
 | SetStyle(String) | Sets the CSS style.
 | SetTitle(String, Language) | Sets the title.
 | SetToolTip(String, Language) | Sets the tool tip.
 | SetType(String) | Sets the type.
 | SetUnversioned(Boolean) | Sets the unversioned flag.
 | SetValidation(String) | Sets the validation.
 | SetValidationText(String) | Sets the validation text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TemplateField..::.Builder


TemplateField.Builder Constructor (fieldName, fieldID, section)

TemplateField..::.Builder Constructor (fieldName, fieldID, section)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► TemplateField..::.Builder(String, ID, TemplateSection)
Creates a new TemplateField..::.Builder instance.
Declaration Syntax
C#
public Builder(
    string fieldName,
    ID fieldID,
    TemplateSection section
)
Parameters
fieldName (String)
Name of the field.
fieldID (ID)
Field ID.
section (TemplateSection)
Section.


Field Property

Field Property
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► Field
Gets the field.
Declaration Syntax
C#
public TemplateField Field { get; }
Value
The field.


SetDefaultValue Method (value)

SetDefaultValue Method (value)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetDefaultValue(String)
Sets the default value.
Declaration Syntax
C#
public void SetDefaultValue(
    string value
)
Parameters
value (String)
Value.


SetDescription Method (description, language)

SetDescription Method (description, language)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetDescription(String, Language)
Sets the description.
Declaration Syntax
C#
public void SetDescription(
    string description,
    Language language
)
Parameters
description (String)
Description.
language (Language)
Language.


SetExcludeFromTextSearch Method (value)

SetExcludeFromTextSearch Method (value)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetExcludeFromTextSearch(Boolean)
Sets the 'exclude from index' flag.
Declaration Syntax
C#
public void SetExcludeFromTextSearch(
    bool value
)
Parameters
value (Boolean)
Flag state


SetHelpLink Method (value)

SetHelpLink Method (value)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetHelpLink(String)
Sets the help link.
Declaration Syntax
C#
public void SetHelpLink(
    string value
)
Parameters
value (String)
Value.


SetIcon Method (icon)

SetIcon Method (icon)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetIcon(String)
Sets the icon.
Declaration Syntax
C#
public void SetIcon(
    string icon
)
Parameters
icon (String)
Icon.


SetIsBlob Method (value)

SetIsBlob Method (value)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetIsBlob(Boolean)
Sets the load on demand flag.
Declaration Syntax
C#
public void SetIsBlob(
    bool value
)
Parameters
value (Boolean)
The flag value.


SetResetBlank Method (value)

SetResetBlank Method (value)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetResetBlank(Boolean)
Sets the reset blank flag.
Declaration Syntax
C#
public void SetResetBlank(
    bool value
)
Parameters
value (Boolean)
Value.


SetShared Method (value)

SetShared Method (value)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetShared(Boolean)
Sets the shared flag.
Declaration Syntax
C#
public void SetShared(
    bool value
)
Parameters
value (Boolean)
Value.


SetSortorder Method (value)

SetSortorder Method (value)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetSortorder(Int32)
Sets the sortorder.
Declaration Syntax
C#
public void SetSortorder(
    int value
)
Parameters
value (Int32)
Value.


SetSource Method (value)

SetSource Method (value)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetSource(String)
Sets the source.
Declaration Syntax
C#
public void SetSource(
    string value
)
Parameters
value (String)
Value.


SetStyle Method (value)

SetStyle Method (value)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetStyle(String)
Sets the CSS style.
Declaration Syntax
C#
public void SetStyle(
    string value
)
Parameters
value (String)
Value.


SetTitle Method (title, language)

SetTitle Method (title, language)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetTitle(String, Language)
Sets the title.
Declaration Syntax
C#
public void SetTitle(
    string title,
    Language language
)
Parameters
title (String)
Title.
language (Language)
Language.


SetToolTip Method (tooltip, language)

SetToolTip Method (tooltip, language)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetToolTip(String, Language)
Sets the tool tip.
Declaration Syntax
C#
public void SetToolTip(
    string tooltip,
    Language language
)
Parameters
tooltip (String)
Tooltip.
language (Language)
Language.


SetType Method (type)

SetType Method (type)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetType(String)
Sets the type.
Declaration Syntax
C#
public void SetType(
    string type
)
Parameters
type (String)
Type.


SetUnversioned Method (value)

SetUnversioned Method (value)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetUnversioned(Boolean)
Sets the unversioned flag.
Declaration Syntax
C#
public void SetUnversioned(
    bool value
)
Parameters
value (Boolean)
Value.


SetValidation Method (validation)

SetValidation Method (validation)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetValidation(String)
Sets the validation.
Declaration Syntax
C#
public void SetValidation(
    string validation
)
Parameters
validation (String)
The validation.


SetValidationText Method (validationText)

SetValidationText Method (validationText)
Namespaces ► Sitecore.Data.Templates ► TemplateField..::.Builder ► SetValidationText(String)
Sets the validation text.
Declaration Syntax
C#
public void SetValidationText(
    string validationText
)
Parameters
validationText (String)
The validation text.


TemplateFieldSharing Enumeration

TemplateFieldSharing Enumeration
Namespaces ► Sitecore.Data.Templates ► TemplateFieldSharing
TemplateFieldSharing class
Declaration Syntax
C#
public enum TemplateFieldSharing
Members
Member | Description
None |
Unversioned |
Shared |


TemplateList Class

TemplateList Class
Namespaces ► Sitecore.Data.Templates ► TemplateList
AccountList class
Declaration Syntax
C#
public class TemplateList : ReadOnlyList<Template>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateList(IEnumerable<(Of <(Template>)>)) | Initializes a new instance of the TemplateList class.
 | TemplateList()()() | Initializes a new instance of the TemplateList class.
 | Contains(TElement) | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToArray()()() | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ReadOnlyList <(Of <( Template >)>)
 |  | TemplateList


TemplateList Constructor

TemplateList Constructor
Namespaces ► Sitecore.Data.Templates ► TemplateList ► TemplateList()()()
Members
Icon | Member | Description
 | TemplateList(IEnumerable<(Of <(Template>)>)) | Initializes a new instance of the TemplateList class.
 | TemplateList()()() | Initializes a new instance of the TemplateList class.


TemplateList Constructor

TemplateList Constructor
Namespaces ► Sitecore.Data.Templates ► TemplateList ► TemplateList()()()
Initializes a new instance of the TemplateList class.
Declaration Syntax
C#
public TemplateList()


TemplateList Constructor (entries)

TemplateList Constructor (entries)
Namespaces ► Sitecore.Data.Templates ► TemplateList ► TemplateList(IEnumerable<(Of <(Template>)>))
Initializes a new instance of the TemplateList class.
Declaration Syntax
C#
public TemplateList(
    IEnumerable<Template> entries
)
Parameters
entries (IEnumerable<(Of <( Template >)>))
The entries.


TemplateParser Class

TemplateParser Class
Namespaces ► Sitecore.Data.Templates ► TemplateParser
Builds templates from an XML specification.
Declaration Syntax
C#
public static class TemplateParser
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Parse(String) | Builds template from XML string.
 | Parse(XmlDocument) | Builds templates from an XML document.
 | ParseFile(String) | Builds templates from an XML file.
Inheritance Hierarchy
Object
TemplateParser


Parse Method

Parse Method
Namespaces ► Sitecore.Data.Templates ► TemplateParser ► Parse()()()
Members
Icon | Member | Description
 | Parse(String) | Builds template from XML string.
 | Parse(XmlDocument) | Builds templates from an XML document.


Parse Method (xml)

Parse Method (xml)
Namespaces ► Sitecore.Data.Templates ► TemplateParser ► Parse(String)
Builds template from XML string.
Declaration Syntax
C#
public static TemplateCollection Parse(
    string xml
)
Parameters
xml (String)
XML.
Return Value
The parse.


Parse Method (xmlDocument)

Parse Method (xmlDocument)
Namespaces ► Sitecore.Data.Templates ► TemplateParser ► Parse(XmlDocument)
Builds templates from an XML document.
Declaration Syntax
C#
public static TemplateCollection Parse(
    XmlDocument xmlDocument
)
Parameters
xmlDocument (XmlDocument)
XML document.
Return Value
The parse.


ParseFile Method (filename)

ParseFile Method (filename)
Namespaces ► Sitecore.Data.Templates ► TemplateParser ► ParseFile(String)
Builds templates from an XML file.
Declaration Syntax
C#
public static TemplateCollection ParseFile(
    string filename
)
Parameters
filename (String)
Filename.
Return Value
The file.


TemplateSection Class

TemplateSection Class
Namespaces ► Sitecore.Data.Templates ► TemplateSection
Represents a template section.
Declaration Syntax
C#
public class TemplateSection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateSection(String, ID, Template) | Creates a new TemplateSection instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fields | Gets the fields.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetField(ID) | Gets a field.
 | GetField(String) | Gets a field.
 | GetFields()()() | Gets all the fields.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets the icon.
 | ID | Gets the ID.
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Sortorder | Gets the sortorder.
 | Template | Gets the template.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TemplateSection
See Also
Template
TemplateField


TemplateSection Constructor (name, id, template)

TemplateSection Constructor (name, id, template)
Namespaces ► Sitecore.Data.Templates ► TemplateSection ► TemplateSection(String, ID, Template)
Creates a new TemplateSection instance.
Declaration Syntax
C#
public TemplateSection(
    string name,
    ID id,
    Template template
)
Parameters
name (String)
Name.
id (ID)
Id.
template (Template)
Template.


Fields Property

Fields Property
Namespaces ► Sitecore.Data.Templates ► TemplateSection ► Fields
Gets the fields.
Declaration Syntax
C#
public ListDictionary Fields { get; }
Value
The fields.


GetField Method

GetField Method
Namespaces ► Sitecore.Data.Templates ► TemplateSection ► GetField()()()
Members
Icon | Member | Description
 | GetField(ID) | Gets a field.
 | GetField(String) | Gets a field.


GetField Method (fieldID)

GetField Method (fieldID)
Namespaces ► Sitecore.Data.Templates ► TemplateSection ► GetField(ID)
Gets a field.
Declaration Syntax
C#
public TemplateField GetField(
    ID fieldID
)
Parameters
fieldID (ID)
Field ID.
Return Value


GetField Method (fieldName)

GetField Method (fieldName)
Namespaces ► Sitecore.Data.Templates ► TemplateSection ► GetField(String)
Gets a field.
Declaration Syntax
C#
public TemplateField GetField(
    string fieldName
)
Parameters
fieldName (String)
Name of the field.
Return Value


GetFields Method

GetFields Method
Namespaces ► Sitecore.Data.Templates ► TemplateSection ► GetFields()()()
Gets all the fields.
Declaration Syntax
C#
public TemplateField[] GetFields()
Return Value


Icon Property

Icon Property
Namespaces ► Sitecore.Data.Templates ► TemplateSection ► Icon
Gets the icon.
Declaration Syntax
C#
public string Icon { get; }
Value
The icon.


ID Property

ID Property
Namespaces ► Sitecore.Data.Templates ► TemplateSection ► ID
Gets the ID.
Declaration Syntax
C#
public ID ID { get; }
Value
The ID.


Key Property

Key Property
Namespaces ► Sitecore.Data.Templates ► TemplateSection ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


Name Property

Name Property
Namespaces ► Sitecore.Data.Templates ► TemplateSection ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Sortorder Property

Sortorder Property
Namespaces ► Sitecore.Data.Templates ► TemplateSection ► Sortorder
Gets the sortorder.
Declaration Syntax
C#
public int Sortorder { get; }
Value
The sortorder.


Template Property

Template Property
Namespaces ► Sitecore.Data.Templates ► TemplateSection ► Template
Gets the template.
Declaration Syntax
C#
public Template Template { get; }
Value
The template.


TemplateSection.Builder Class

TemplateSection..::.Builder Class
Namespaces ► Sitecore.Data.Templates ► TemplateSection ► TemplateSection..::.Builder
Implements a builder class for TemplateSection.
Declaration Syntax
C#
public class Builder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateSection..::.Builder(String, ID, Template) | Creates a new TemplateSection..::.Builder instance.
 | AddField(String, ID) | Adds a field.
 | AddField(XmlNode) | Adds a field.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Section | Gets the section.
 | SetIcon(String) | Sets the icon.
 | SetSortorder(Int32) | Sets the sortorder.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TemplateSection..::.Builder


TemplateSection.Builder Constructor (sectionName, sectionID, template)

TemplateSection..::.Builder Constructor (sectionName, sectionID, template)
Namespaces ► Sitecore.Data.Templates ► TemplateSection..::.Builder ► TemplateSection..::.Builder(String, ID, Template)
Creates a new TemplateSection..::.Builder instance.
Declaration Syntax
C#
public Builder(
    string sectionName,
    ID sectionID,
    Template template
)
Parameters
sectionName (String)
Name of the section.
sectionID (ID)
Section ID.
template (Template)
Template.


AddField Method

AddField Method
Namespaces ► Sitecore.Data.Templates ► TemplateSection..::.Builder ► AddField()()()
Members
Icon | Member | Description
 | AddField(String, ID) | Adds a field.
 | AddField(XmlNode) | Adds a field.


AddField Method (fieldName, fieldID)

AddField Method (fieldName, fieldID)
Namespaces ► Sitecore.Data.Templates ► TemplateSection..::.Builder ► AddField(String, ID)
Adds a field.
Declaration Syntax
C#
public TemplateField..::.Builder AddField(
    string fieldName,
    ID fieldID
)
Parameters
fieldName (String)
Name of the field.
fieldID (ID)
Field ID.
Return Value
The field.


AddField Method (node)

AddField Method (node)
Namespaces ► Sitecore.Data.Templates ► TemplateSection..::.Builder ► AddField(XmlNode)
Adds a field.
Declaration Syntax
C#
public TemplateField..::.Builder AddField(
    XmlNode node
)
Parameters
node (XmlNode)
Node.
Return Value
The field.


Section Property

Section Property
Namespaces ► Sitecore.Data.Templates ► TemplateSection..::.Builder ► Section
Gets the section.
Declaration Syntax
C#
public TemplateSection Section { get; }
Value
The section.


SetIcon Method (icon)

SetIcon Method (icon)
Namespaces ► Sitecore.Data.Templates ► TemplateSection..::.Builder ► SetIcon(String)
Sets the icon.
Declaration Syntax
C#
public void SetIcon(
    string icon
)
Parameters
icon (String)
Icon.


SetSortorder Method (value)

SetSortorder Method (value)
Namespaces ► Sitecore.Data.Templates ► TemplateSection..::.Builder ► SetSortorder(Int32)
Sets the sortorder.
Declaration Syntax
C#
public void SetSortorder(
    int value
)
Parameters
value (Int32)
Value.


TemplateUpdateContext Class

TemplateUpdateContext Class
Namespaces ► Sitecore.Data.Templates ► TemplateUpdateContext
Represents a template update context.
Declaration Syntax
C#
[ObsoleteAttribute("No longer needed", false)]
public class TemplateUpdateContext : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TemplateUpdateContext(DataManager) | Initializes a new instance of the TemplateUpdateContext class.
 | Dispose()()() | Disposes this instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TemplateUpdateContext


TemplateUpdateContext Constructor (manager)

TemplateUpdateContext Constructor (manager)
Namespaces ► Sitecore.Data.Templates ► TemplateUpdateContext ► TemplateUpdateContext(DataManager)
Initializes a new instance of the TemplateUpdateContext class.
Declaration Syntax
C#
public TemplateUpdateContext(
    DataManager manager
)
Parameters
manager (DataManager)
The manager.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Data.Templates ► TemplateUpdateContext ► Dispose()()()
Disposes this instance.
Declaration Syntax
C#
public void Dispose()
Remarks
The item leaves editing mode.


Sitecore.Data.Treeviews Namespace

Sitecore.Data.Treeviews Namespace
Namespaces ► Sitecore.Data.Treeviews
Declaration Syntax
C#
namespace Sitecore.Data.Treeviews
Types
All Types Classes
Icon | Type | Description
 | RenderingTreeviewSource | Represents a TreeviewSource.
 | TreeviewSource | Represents a TreeviewSource.


RenderingTreeviewSource Class

RenderingTreeviewSource Class
Namespaces ► Sitecore.Data.Treeviews ► RenderingTreeviewSource
Represents a TreeviewSource.
Declaration Syntax
C#
public class RenderingTreeviewSource : TreeviewSource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderingTreeviewSource()()() | Initializes a new instance of the RenderingTreeviewSource class
 | BuildNode(TreeViewNode, Item) | Builds the node. (Inherited from TreeviewSource.)
 | CanDisplay(Item) | Determines whether this instance can display the specified item. (Overrides TreeviewSource.CanDisplay(Item).)
 | CanSelect(Item) | Determines whether this instance can select the specified item. (Overrides TreeviewSource.CanSelect(Item).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExcludeTemplatesForDisplay | Gets or sets the exclude templates for display. (Inherited from TreeviewSource.)
 | ExcludeTemplatesForSelection | Gets or sets the exclude templates for selection. (Inherited from TreeviewSource.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildren(Item) | Gets the children. (Inherited from TreeviewSource.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNodeUrl(Item) | Gets the node URL. (Inherited from TreeviewSource.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IncludeTemplatesForDisplay | Gets or sets the include templates for display. (Inherited from TreeviewSource.)
 | IncludeTemplatesForSelection | Gets or sets the include templates for selection. (Inherited from TreeviewSource.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(TreeView, Item) | Renders the specified treeview. (Inherited from TreeviewSource.)
 | Render(TreeView, Item, Boolean) | Builds the specified treeview. (Inherited from TreeviewSource.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TreeviewSource
 |  | RenderingTreeviewSource


RenderingTreeviewSource Constructor

RenderingTreeviewSource Constructor
Namespaces ► Sitecore.Data.Treeviews ► RenderingTreeviewSource ► RenderingTreeviewSource()()()
Initializes a new instance of the RenderingTreeviewSource class
Declaration Syntax
C#
public RenderingTreeviewSource()


CanDisplay Method (item)

CanDisplay Method (item)
Namespaces ► Sitecore.Data.Treeviews ► RenderingTreeviewSource ► CanDisplay(Item)
Determines whether this instance can display the specified item.
Declaration Syntax
C#
protected override bool CanDisplay(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if this instance can display the specified item; otherwise, false.


CanSelect Method (item)

CanSelect Method (item)
Namespaces ► Sitecore.Data.Treeviews ► RenderingTreeviewSource ► CanSelect(Item)
Determines whether this instance can select the specified item.
Declaration Syntax
C#
protected override bool CanSelect(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if this instance can select the specified item; otherwise, false.


TreeviewSource Class

TreeviewSource Class
Namespaces ► Sitecore.Data.Treeviews ► TreeviewSource
Represents a TreeviewSource.
Declaration Syntax
C#
public class TreeviewSource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TreeviewSource()()() | Initializes a new instance of the TreeviewSource class
 | BuildNode(TreeViewNode, Item) | Builds the node.
 | CanDisplay(Item) | Determines whether this instance can display the specified item.
 | CanSelect(Item) | Determines whether this instance can select the specified item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExcludeTemplatesForDisplay | Gets or sets the exclude templates for display.
 | ExcludeTemplatesForSelection | Gets or sets the exclude templates for selection.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildren(Item) | Gets the children.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNodeUrl(Item) | Gets the node URL.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IncludeTemplatesForDisplay | Gets or sets the include templates for display.
 | IncludeTemplatesForSelection | Gets or sets the include templates for selection.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(TreeView, Item) | Renders the specified treeview.
 | Render(TreeView, Item, Boolean) | Builds the specified treeview.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TreeviewSource
 |  | RenderingTreeviewSource


TreeviewSource Constructor

TreeviewSource Constructor
Namespaces ► Sitecore.Data.Treeviews ► TreeviewSource ► TreeviewSource()()()
Initializes a new instance of the TreeviewSource class
Declaration Syntax
C#
public TreeviewSource()


BuildNode Method (node, item)

BuildNode Method (node, item)
Namespaces ► Sitecore.Data.Treeviews ► TreeviewSource ► BuildNode(TreeViewNode, Item)
Builds the node.
Declaration Syntax
C#
protected virtual void BuildNode(
    TreeViewNode node,
    Item item
)
Parameters
node (TreeViewNode)
The node.
item (Item)
The item.


CanDisplay Method (item)

CanDisplay Method (item)
Namespaces ► Sitecore.Data.Treeviews ► TreeviewSource ► CanDisplay(Item)
Determines whether this instance can display the specified item.
Declaration Syntax
C#
protected virtual bool CanDisplay(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if this instance can display the specified item; otherwise, false.


CanSelect Method (item)

CanSelect Method (item)
Namespaces ► Sitecore.Data.Treeviews ► TreeviewSource ► CanSelect(Item)
Determines whether this instance can select the specified item.
Declaration Syntax
C#
protected virtual bool CanSelect(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if this instance can select the specified item; otherwise, false.


ExcludeTemplatesForDisplay Property

ExcludeTemplatesForDisplay Property
Namespaces ► Sitecore.Data.Treeviews ► TreeviewSource ► ExcludeTemplatesForDisplay
Gets or sets the exclude templates for display.
Declaration Syntax
C#
public string ExcludeTemplatesForDisplay { get; set; }
Value
The exclude templates for display.


ExcludeTemplatesForSelection Property

ExcludeTemplatesForSelection Property
Namespaces ► Sitecore.Data.Treeviews ► TreeviewSource ► ExcludeTemplatesForSelection
Gets or sets the exclude templates for selection.
Declaration Syntax
C#
public string ExcludeTemplatesForSelection { get; set; }
Value
The exclude templates for selection.


GetChildren Method (item)

GetChildren Method (item)
Namespaces ► Sitecore.Data.Treeviews ► TreeviewSource ► GetChildren(Item)
Gets the children.
Declaration Syntax
C#
protected virtual ChildList GetChildren(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The children.


GetNodeUrl Method (item)

GetNodeUrl Method (item)
Namespaces ► Sitecore.Data.Treeviews ► TreeviewSource ► GetNodeUrl(Item)
Gets the node URL.
Declaration Syntax
C#
protected virtual UrlString GetNodeUrl(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The node URL.


IncludeTemplatesForDisplay Property

IncludeTemplatesForDisplay Property
Namespaces ► Sitecore.Data.Treeviews ► TreeviewSource ► IncludeTemplatesForDisplay
Gets or sets the include templates for display.
Declaration Syntax
C#
public string IncludeTemplatesForDisplay { get; set; }
Value
The include templates for display.


IncludeTemplatesForSelection Property

IncludeTemplatesForSelection Property
Namespaces ► Sitecore.Data.Treeviews ► TreeviewSource ► IncludeTemplatesForSelection
Gets or sets the include templates for selection.
Declaration Syntax
C#
public string IncludeTemplatesForSelection { get; set; }
Value
The include templates for selection.


Render Method

Render Method
Namespaces ► Sitecore.Data.Treeviews ► TreeviewSource ► Render()()()
Members
Icon | Member | Description
 | Render(TreeView, Item) | Renders the specified treeview.
 | Render(TreeView, Item, Boolean) | Builds the specified treeview.


Render Method (treeview, parent)

Render Method (treeview, parent)
Namespaces ► Sitecore.Data.Treeviews ► TreeviewSource ► Render(TreeView, Item)
Renders the specified treeview.
Declaration Syntax
C#
public virtual void Render(
    TreeView treeview,
    Item parent
)
Parameters
treeview (TreeView)
The treeview.
parent (Item)
The parent.


Render Method (treeview, parent, expandFirstLevel)

Render Method (treeview, parent, expandFirstLevel)
Namespaces ► Sitecore.Data.Treeviews ► TreeviewSource ► Render(TreeView, Item, Boolean)
Builds the specified treeview.
Declaration Syntax
C#
public virtual void Render(
    TreeView treeview,
    Item parent,
    bool expandFirstLevel
)
Parameters
treeview (TreeView)
The treeview.
parent (Item)
The parent.
expandFirstLevel (Boolean)
if set to true this instance expands the first level.


Sitecore.Data.Validators Namespace

Sitecore.Data.Validators Namespace
Namespaces ► Sitecore.Data.Validators
Declaration Syntax
C#
namespace Sitecore.Data.Validators
Types
All Types Classes Enumerations
Icon | Type | Description
 | BaseValidator | Represents a BaseValidator.
 | StandardValidator | Represents a Standard Validator.
 | ValidatorBarFormatter | Represents a ValidatorsFormatter.
 | ValidatorCollection | Represents a ValidatorCollection.
 | ValidatorEvaluationMode | Determines how the validator is evaluated.
 | ValidatorManager | Represents a ValidationManager.
 | ValidatorOptions |
 | ValidatorPanelFormatter | Represents a ValidatorsFormatter.
 | ValidatorResult | Represents the state of a Validator.
 | ValidatorsMode | Specifies
 | ValidatorsQueue | Represents a ValidatorsQueue.
 | ValidatorWorker | Represents a ValidatorsWorker.


BaseValidator Class

BaseValidator Class
Namespaces ► Sitecore.Data.Validators ► BaseValidator
Represents a BaseValidator.
Declaration Syntax
C#
[SerializableAttribute]
public abstract class BaseValidator : ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseValidator()()() | Initializes a new instance of the BaseValidator class.
 | BaseValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the BaseValidator class.
 | ControlToValidate | Gets or sets the input control to validate.
 | ControlValidationValue | Gets the control validation value.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors.
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
 | EvaluationMode | Gets or sets the evaluation.
 | Expire()()() | Expires this instance.
 | Expiry | Gets or sets the expiry.
 | FieldID | Gets or sets the field ID.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value.
 | GetField()()() | Gets the field.
 | GetFieldDisplayName()()() | Gets the display name of the field.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon.
 | GetIcon(ValidatorResult) | Gets the icon.
 | GetItem()()() | Gets the item.
 | GetMaxValidatorResult()()() | Gets the max validator result.
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate.
 | HasMenu | Gets or sets a value indicating whether this instance has menu.
 | Icon | Gets or sets the icon.
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid.
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating.
 | IsEvaluationRequired()()() | Determines if evaluation should be performed.
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation.
 | ItemUri | Gets or sets the item URI.
 | MarkerID | Gets the marker ID.
 | MaxValidatorResult | Gets the max validator result that the validator can return.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Options | Gets the options.
 | Parameters | Gets the parameters.
 | Result | Gets or sets the state.
 | Text | Gets or sets the text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance.
 | Validate(ValidatorOptions) | Validates this instance.
 | ValidatorID | Gets or sets the validator ID.
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator


BaseValidator Constructor

BaseValidator Constructor
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► BaseValidator()()()
Members
Icon | Member | Description
 | BaseValidator()()() | Initializes a new instance of the BaseValidator class.
 | BaseValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the BaseValidator class.


BaseValidator Constructor

BaseValidator Constructor
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► BaseValidator()()()
Initializes a new instance of the BaseValidator class.
Declaration Syntax
C#
public BaseValidator()


BaseValidator Constructor (info, context)

BaseValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► BaseValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the BaseValidator class.
Declaration Syntax
C#
protected BaseValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


ControlToValidate Property

ControlToValidate Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► ControlToValidate
Gets or sets the input control to validate.
Declaration Syntax
C#
public string ControlToValidate { get; set; }
Value
The input control to validate. The default value is String.Empty, which indicates that this property is not set.


ControlValidationValue Property

ControlValidationValue Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► ControlValidationValue
Gets the control validation value.
Declaration Syntax
C#
public string ControlValidationValue { get; }
Value
The control validation value.


Errors Property

Errors Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► Errors
Gets the errors.
Declaration Syntax
C#
public List<string> Errors { get; }
Value
The errors.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected abstract ValidatorResult Evaluate()
Return Value
The result of the evaluation.


EvaluationMode Property

EvaluationMode Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► EvaluationMode
Gets or sets the evaluation.
Declaration Syntax
C#
public ValidatorEvaluationMode EvaluationMode { get; set; }
Value
The evaluation.


Expire Method

Expire Method
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► Expire()()()
Expires this instance.
Declaration Syntax
C#
public void Expire()


Expiry Property

Expiry Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► Expiry
Gets or sets the expiry.
Declaration Syntax
C#
public DateTime Expiry { get; set; }
Value
The expiry.


FieldID Property

FieldID Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► FieldID
Gets or sets the field ID.
Declaration Syntax
C#
public ID FieldID { get; set; }
Value
The field ID.


GetControlValidationValue Method

GetControlValidationValue Method
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► GetControlValidationValue()()()
Gets the control validation value.
Declaration Syntax
C#
protected virtual string GetControlValidationValue()
Return Value
The control validation value.


GetField Method

GetField Method
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► GetField()()()
Gets the field.
Declaration Syntax
C#
protected Field GetField()
Return Value
The field.


GetFieldDisplayName Method

GetFieldDisplayName Method
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► GetFieldDisplayName()()()
Gets the display name of the field.
Declaration Syntax
C#
public string GetFieldDisplayName()
Return Value
The display name of the field.


GetIcon Method

GetIcon Method
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► GetIcon()()()
Members
Icon | Member | Description
 | GetIcon()()() | Gets the icon.
 | GetIcon(ValidatorResult) | Gets the icon.


GetIcon Method

GetIcon Method
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► GetIcon()()()
Gets the icon.
Declaration Syntax
C#
public string GetIcon()
Return Value
The icon.


GetIcon Method (result)

GetIcon Method (result)
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► GetIcon(ValidatorResult)
Gets the icon.
Declaration Syntax
C#
public static string GetIcon(
    ValidatorResult result
)
Parameters
result (ValidatorResult)
The result.
Return Value
The icon.


GetItem Method

GetItem Method
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► GetItem()()()
Gets the item.
Declaration Syntax
C#
protected Item GetItem()
Return Value
The item.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected abstract ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


HasControlToValidate Method

HasControlToValidate Method
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► HasControlToValidate()()()
Determines whether this instance has a control to validate.
Declaration Syntax
C#
protected virtual bool HasControlToValidate()
Return Value
true if this instance has a control to validate; otherwise, false.


HasMenu Property

HasMenu Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► HasMenu
Gets or sets a value indicating whether this instance has menu.
Declaration Syntax
C#
public bool HasMenu { get; set; }
Value
true if this instance has menu; otherwise, false.


Icon Property

Icon Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


IsControlValidationValueValid Method

IsControlValidationValueValid Method
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► IsControlValidationValueValid()()()
Determines whether the control validation value is valid.
Declaration Syntax
C#
protected virtual bool IsControlValidationValueValid()
Return Value
true if the control validation value is valid; otherwise, false.


IsEvaluating Property

IsEvaluating Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► IsEvaluating
Gets or sets a value indicating whether this instance is evaluating.
Declaration Syntax
C#
public bool IsEvaluating { get; set; }
Value
true if this instance is evaluating; otherwise, false.


IsEvaluationRequired Method

IsEvaluationRequired Method
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► IsEvaluationRequired()()()
Determines if evaluation should be performed.
Declaration Syntax
C#
protected virtual bool IsEvaluationRequired()
Return Value
The evaluation.


IsValid Property

IsValid Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► IsValid
Gets or sets a value that indicates whether the associated input control passes validation.
Declaration Syntax
C#
public bool IsValid { get; }
Value
true if the associated input control passes validation; otherwise, false. The default value is true.


ItemUri Property

ItemUri Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► ItemUri
Gets or sets the item URI.
Declaration Syntax
C#
public ItemUri ItemUri { get; set; }
Value
The item URI.


MarkerID Property

MarkerID Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► MarkerID
Gets the marker ID.
Declaration Syntax
C#
public string MarkerID { get; }
Value
The marker ID.


MaxValidatorResult Property

MaxValidatorResult Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► MaxValidatorResult
Gets the max validator result that the validator can return.
Declaration Syntax
C#
public ValidatorResult MaxValidatorResult { get; }
Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► Name
Gets the name.
Declaration Syntax
C#
public abstract string Name { get; }
Value
The name.


Options Property

Options Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► Options
Gets the options.
Declaration Syntax
C#
public ValidatorOptions Options { get; }
Value
The options.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► Parameters
Gets the parameters.
Declaration Syntax
C#
public SafeDictionary<string> Parameters { get; set; }
Value
The parameters.


Result Property

Result Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► Result
Gets or sets the state.
Declaration Syntax
C#
public ValidatorResult Result { get; set; }
Value
The state.


Text Property

Text Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► Text
Gets or sets the text.
Declaration Syntax
C#
public string Text { get; set; }
Value
The text.


Update Method

Update Method
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► Update()()()
Updates this instance.
Declaration Syntax
C#
public void Update()


Validate Method (options)

Validate Method (options)
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► Validate(ValidatorOptions)
Validates this instance.
Declaration Syntax
C#
public void Validate(
    ValidatorOptions options
)
Parameters
options (ValidatorOptions)
The options.


ValidatorID Property

ValidatorID Property
Namespaces ► Sitecore.Data.Validators ► BaseValidator ► ValidatorID
Gets or sets the validator ID.
Declaration Syntax
C#
public ID ValidatorID { get; set; }
Value
The validator ID.


StandardValidator Class

StandardValidator Class
Namespaces ► Sitecore.Data.Validators ► StandardValidator
Represents a Standard Validator.
Declaration Syntax
C#
public abstract class StandardValidator : BaseValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StandardValidator()()() | Initializes a new instance of the StandardValidator class.
 | StandardValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the StandardValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Inherited from BaseValidator.)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result.
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Inherited from BaseValidator.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from BaseValidator.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | BrokenLinksValidator
 |  |  | ContainsCharactersValidator
 |  |  | DateTimeRangeValidator
 |  |  | ExternLinkTargetValidator
 |  |  | ImageAltFieldValidator
 |  |  | ImageAltFromMediaLibraryFieldValidator
 |  |  | ImageSizeValidator
 |  |  | IntegerFieldValidator
 |  |  | IntegerRangeValidator
 |  |  | MaxLengthFieldValidator
 |  |  | RegexValidator
 |  |  | RequiredFieldValidator
 |  |  | RichTextImageSizeValidator
 |  |  | ScriptCodeValidator
 |  |  | SpellcheckValidator
 |  |  | StringEnumValidator
 |  |  | TypeAndAssemblyValidator
 |  |  | W3CXhtmlValidator
 |  |  | XhtmlValidator
 |  |  | BrokenLinkValidator
 |  |  | DuplicateNameValidator
 |  |  | FullPageXHtmlValidator
 |  |  | MediaSizeValidator
 |  |  | UrlCharacterValidator


StandardValidator Constructor

StandardValidator Constructor
Namespaces ► Sitecore.Data.Validators ► StandardValidator ► StandardValidator()()()
Members
Icon | Member | Description
 | StandardValidator()()() | Initializes a new instance of the StandardValidator class.
 | StandardValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the StandardValidator class.


StandardValidator Constructor

StandardValidator Constructor
Namespaces ► Sitecore.Data.Validators ► StandardValidator ► StandardValidator()()()
Initializes a new instance of the StandardValidator class.
Declaration Syntax
C#
protected StandardValidator()


StandardValidator Constructor (info, context)

StandardValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators ► StandardValidator ► StandardValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the StandardValidator class.
Declaration Syntax
C#
protected StandardValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


GetFailedResult Method (defaultResult)

GetFailedResult Method (defaultResult)
Namespaces ► Sitecore.Data.Validators ► StandardValidator ► GetFailedResult(ValidatorResult)
Gets the result.
Declaration Syntax
C#
protected ValidatorResult GetFailedResult(
    ValidatorResult defaultResult
)
Parameters
defaultResult (ValidatorResult)
The default result.
Return Value
The result.
Exceptions
Exception | Condition
ArgumentNullException |
ArgumentException |


GetText Method (text, arguments)

GetText Method (text, arguments)
Namespaces ► Sitecore.Data.Validators ► StandardValidator ► GetText(String, array<String>[]()[])
Gets the text.
Declaration Syntax
C#
protected string GetText(
    string text,
    params string[] arguments
)
Parameters
text (String)
The text.
arguments (array< String >[]()[])
The arguments.
Return Value
The text.
Exceptions
Exception | Condition
ArgumentNullException |
FormatException |


ValidatorBarFormatter Class

ValidatorBarFormatter Class
Namespaces ► Sitecore.Data.Validators ► ValidatorBarFormatter
Represents a ValidatorsFormatter.
Declaration Syntax
C#
public static class ValidatorBarFormatter
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenderValidationResult(ValidatorCollection) | Renders the validation result.
Inheritance Hierarchy
Object
ValidatorBarFormatter


RenderValidationResult Method (validators)

RenderValidationResult Method (validators)
Namespaces ► Sitecore.Data.Validators ► ValidatorBarFormatter ► RenderValidationResult(ValidatorCollection)
Renders the validation result.
Declaration Syntax
C#
public static string RenderValidationResult(
    ValidatorCollection validators
)
Parameters
validators (ValidatorCollection)
The validators.
Return Value
The validation result.


ValidatorCollection Class

ValidatorCollection Class
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection
Represents a ValidatorCollection.
Declaration Syntax
C#
[SerializableAttribute]
public class ValidatorCollection : ISerializable,
    IList<BaseValidator>, ICollection<BaseValidator>, IEnumerable<BaseValidator>,
    IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidatorCollection()()() | Initializes a new instance of the ValidatorCollection class.
 | ValidatorCollection(SerializationInfo, StreamingContext) | Initializes a new instance of the ValidatorCollection class.
 | Add(BaseValidator) | Adds the specified validator.
 | Clear()()() | Removes all items from the ICollection<(Of <(T>)>).
 | Contains(BaseValidator) | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
 | CopyTo(array<BaseValidator>[]()[], Int32) | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
 | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetByMarkerID(String) | Gets the validator by marker ID.
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(BaseValidator) | Determines the index of a specific item in the IList<(Of <(T>)>).
 | Insert(Int32, BaseValidator) | Inserts an item to the IList<(Of <(T>)>) at the specified index.
 | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
 | Item[([(Int32])]) | Gets the BaseValidator at the specified index.
 | Key | Gets or sets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(BaseValidator) | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
 | RemoveAt(Int32) | Removes the IList<(Of <(T>)>) item at the specified index.
 | Sort()()() | Sorts this instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ValidatorCollection


ValidatorCollection Constructor

ValidatorCollection Constructor
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► ValidatorCollection()()()
Members
Icon | Member | Description
 | ValidatorCollection()()() | Initializes a new instance of the ValidatorCollection class.
 | ValidatorCollection(SerializationInfo, StreamingContext) | Initializes a new instance of the ValidatorCollection class.


ValidatorCollection Constructor

ValidatorCollection Constructor
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► ValidatorCollection()()()
Initializes a new instance of the ValidatorCollection class.
Declaration Syntax
C#
public ValidatorCollection()


ValidatorCollection Constructor (info, context)

ValidatorCollection Constructor (info, context)
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► ValidatorCollection(SerializationInfo, StreamingContext)
Initializes a new instance of the ValidatorCollection class.
Declaration Syntax
C#
protected ValidatorCollection(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Add Method (validator)

Add Method (validator)
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► Add(BaseValidator)
Adds the specified validator.
Declaration Syntax
C#
public void Add(
    BaseValidator validator
)
Parameters
validator (BaseValidator)
The validator.


Clear Method

Clear Method
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► Clear()()()
Removes all items from the ICollection<(Of <(T>)>).
Declaration Syntax
C#
public void Clear()
Exceptions
Exception | Condition
NotSupportedException | The ICollection<(Of <(T>)>) is read-only.


Contains Method (item)

Contains Method (item)
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► Contains(BaseValidator)
Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Declaration Syntax
C#
public bool Contains(
    BaseValidator item
)
Parameters
item (BaseValidator)
The object to locate in the ICollection<(Of <(T>)>).
Return Value
true if item is found in the ICollection<(Of <(T>)>); otherwise, false.


CopyTo Method (array, arrayIndex)

CopyTo Method (array, arrayIndex)
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► CopyTo(array<BaseValidator>[]()[], Int32)
Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Declaration Syntax
C#
public void CopyTo(
    BaseValidator[] array,
    int arrayIndex
)
Parameters
array (array< BaseValidator >[]()[])
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(T>)>). The Array must have zero-based indexing.
arrayIndex (Int32)
The zero-based index in array at which copying begins.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentNullException | array is null.
ArgumentException | array is multidimensional.-or-arrayIndex is equal to or greater than the length of array.-or-The number of elements in the source ICollection<(Of <(T>)>) is greater than the available space from arrayIndex to the end of the destination array.-or-Type T cannot be cast automatically to the type of the destination array.


Count Property

Count Property
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► Count
Gets the number of elements contained in the ICollection<(Of <(T>)>).
Declaration Syntax
C#
public int Count { get; }
Return Value
The number of elements contained in the ICollection<(Of <(T>)>).


GetByMarkerID Method (markerID)

GetByMarkerID Method (markerID)
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► GetByMarkerID(String)
Gets the validator by marker ID.
Declaration Syntax
C#
public BaseValidator GetByMarkerID(
    string markerID
)
Parameters
markerID (String)
The marker ID.
Return Value
The validator.


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► GetEnumerator()()()
Returns an enumerator that iterates through a collection.
Declaration Syntax
C#
public IEnumerator GetEnumerator()
Return Value
An IEnumerator object that can be used to iterate through the collection.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► IndexOf(BaseValidator)
Determines the index of a specific item in the IList<(Of <(T>)>).
Declaration Syntax
C#
public int IndexOf(
    BaseValidator item
)
Parameters
item (BaseValidator)
The object to locate in the IList<(Of <(T>)>).
Return Value
The index of item if found in the list; otherwise, -1.


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► Insert(Int32, BaseValidator)
Inserts an item to the IList<(Of <(T>)>) at the specified index.
Declaration Syntax
C#
public void Insert(
    int index,
    BaseValidator item
)
Parameters
index (Int32)
The zero-based index at which item should be inserted.
item (BaseValidator)
The object to insert into the IList<(Of <(T>)>).
Exceptions
Exception | Condition
NotSupportedException | The IList<(Of <(T>)>) is read-only.
ArgumentOutOfRangeException | index is not a valid index in the IList<(Of <(T>)>).


IsReadOnly Property

IsReadOnly Property
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► IsReadOnly
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Declaration Syntax
C#
public bool IsReadOnly { get; }
Return Value
true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► Item[([(Int32])])
Gets the BaseValidator at the specified index.
Declaration Syntax
C#
public BaseValidator this[
    int index
] { get; }
Parameters
index (Int32)
Value
The BaseValidator.


Key Property

Key Property
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► Key
Gets or sets the key.
Declaration Syntax
C#
public string Key { get; set; }
Value
The key.


Remove Method (item)

Remove Method (item)
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► Remove(BaseValidator)
Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
Declaration Syntax
C#
public bool Remove(
    BaseValidator item
)
Parameters
item (BaseValidator)
The object to remove from the ICollection<(Of <(T>)>).
Return Value
true if item was successfully removed from the ICollection<(Of <(T>)>); otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(T>)>).
Exceptions
Exception | Condition
NotSupportedException | The ICollection<(Of <(T>)>) is read-only.


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► RemoveAt(Int32)
Removes the IList<(Of <(T>)>) item at the specified index.
Declaration Syntax
C#
public void RemoveAt(
    int index
)
Parameters
index (Int32)
The zero-based index of the item to remove.
Exceptions
Exception | Condition
NotSupportedException | The IList<(Of <(T>)>) is read-only.
ArgumentOutOfRangeException | index is not a valid index in the IList<(Of <(T>)>).


Sort Method

Sort Method
Namespaces ► Sitecore.Data.Validators ► ValidatorCollection ► Sort()()()
Sorts this instance.
Declaration Syntax
C#
public void Sort()


ValidatorEvaluationMode Enumeration

ValidatorEvaluationMode Enumeration
Namespaces ► Sitecore.Data.Validators ► ValidatorEvaluationMode
Determines how the validator is evaluated.
Declaration Syntax
C#
public enum ValidatorEvaluationMode
Members
Member | Description
Instant | The evaluation is instant.
UseThread | The evaluation is executed in a background thread.


ValidatorManager Class

ValidatorManager Class
Namespaces ► Sitecore.Data.Validators ► ValidatorManager
Represents a ValidationManager.
Declaration Syntax
C#
public static class ValidatorManager
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BuildValidator(Item, Item) | Gets the validator.
 | BuildValidators(ValidatorsMode, String, Item, SafeDictionary<(Of <(String, String>)>)) | Builds the validation set.
 | BuildValidators(ValidatorsMode, String, ICollection<(Of <(FieldDescriptor>)>), Database, SafeDictionary<(Of <(String, String>)>)) | Builds the validators.
 | BuildValidators(ValidatorsMode, Item) | Builds the validation set.
 | GetValidators(ValidatorsMode, String) | Gets the validators.
 | UpdateValidators(ValidatorCollection) | Updates the validators.
 | Validate(ValidatorCollection, ValidatorOptions) | Validates the specified result.
Inheritance Hierarchy
Object
ValidatorManager


BuildValidator Method (validator, item)

BuildValidator Method (validator, item)
Namespaces ► Sitecore.Data.Validators ► ValidatorManager ► BuildValidator(Item, Item)
Gets the validator.
Declaration Syntax
C#
public static BaseValidator BuildValidator(
    Item validator,
    Item item
)
Parameters
validator (Item)
The validator.
item (Item)
The item.
Return Value
The validator.


BuildValidators Method

BuildValidators Method
Namespaces ► Sitecore.Data.Validators ► ValidatorManager ► BuildValidators()()()
Members
Icon | Member | Description
 | BuildValidators(ValidatorsMode, String, Item, SafeDictionary<(Of <(String, String>)>)) | Builds the validation set.
 | BuildValidators(ValidatorsMode, String, ICollection<(Of <(FieldDescriptor>)>), Database, SafeDictionary<(Of <(String, String>)>)) | Builds the validators.
 | BuildValidators(ValidatorsMode, Item) | Builds the validation set.


BuildValidators Method (mode, item)

BuildValidators Method (mode, item)
Namespaces ► Sitecore.Data.Validators ► ValidatorManager ► BuildValidators(ValidatorsMode, Item)
Builds the validation set.
Declaration Syntax
C#
public static ValidatorCollection BuildValidators(
    ValidatorsMode mode,
    Item item
)
Parameters
mode (ValidatorsMode)
The mode.
item (Item)
The item.
Return Value
The validators.


BuildValidators Method (mode, key, item, controls)

BuildValidators Method (mode, key, item, controls)
Namespaces ► Sitecore.Data.Validators ► ValidatorManager ► BuildValidators(ValidatorsMode, String, Item, SafeDictionary<(Of <(String, String>)>))
Builds the validation set.
Declaration Syntax
C#
public static ValidatorCollection BuildValidators(
    ValidatorsMode mode,
    string key,
    Item item,
    SafeDictionary<string, string> controls
)
Parameters
mode (ValidatorsMode)
The mode.
key (String)
The key.
item (Item)
The item.
controls (SafeDictionary <(Of <(String, String>)>))
The controls.
Return Value
The validators.


BuildValidators Method (mode, key, fields, database, controls)

BuildValidators Method (mode, key, fields, database, controls)
Namespaces ► Sitecore.Data.Validators ► ValidatorManager ► BuildValidators(ValidatorsMode, String, ICollection<(Of <(FieldDescriptor>)>), Database, SafeDictionary<(Of <(String, String>)>))
Builds the validators.
Declaration Syntax
C#
public static ValidatorCollection BuildValidators(
    ValidatorsMode mode,
    string key,
    ICollection<FieldDescriptor> fields,
    Database database,
    SafeDictionary<string, string> controls
)
Parameters
mode (ValidatorsMode)
The mode.
key (String)
The key.
fields (ICollection<(Of <( FieldDescriptor >)>))
The fields.
database (Database)
The database.
controls (SafeDictionary <(Of <(String, String>)>))
The controls.
Return Value
The validators.


GetValidators Method (mode, key)

GetValidators Method (mode, key)
Namespaces ► Sitecore.Data.Validators ► ValidatorManager ► GetValidators(ValidatorsMode, String)
Gets the validators.
Declaration Syntax
C#
public static ValidatorCollection GetValidators(
    ValidatorsMode mode,
    string key
)
Parameters
mode (ValidatorsMode)
The mode.
key (String)
The key.
Return Value
The validators.


UpdateValidators Method (validators)

UpdateValidators Method (validators)
Namespaces ► Sitecore.Data.Validators ► ValidatorManager ► UpdateValidators(ValidatorCollection)
Updates the validators.
Declaration Syntax
C#
public static void UpdateValidators(
    ValidatorCollection validators
)
Parameters
validators (ValidatorCollection)
The validators.


Validate Method (validators, options)

Validate Method (validators, options)
Namespaces ► Sitecore.Data.Validators ► ValidatorManager ► Validate(ValidatorCollection, ValidatorOptions)
Validates the specified result.
Declaration Syntax
C#
public static void Validate(
    ValidatorCollection validators,
    ValidatorOptions options
)
Parameters
validators (ValidatorCollection)
The validators.
options (ValidatorOptions)
The options.


ValidatorOptions Class

ValidatorOptions Class
Namespaces ► Sitecore.Data.Validators ► ValidatorOptions
Declaration Syntax
C#
[SerializableAttribute]
public class ValidatorOptions : ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidatorOptions(Boolean) | Initializes a new instance of the ValidatorOptions class.
 | ValidatorOptions(SerializationInfo, StreamingContext) | Bases the validator.
 | Blocking | Gets a value indicating whether this ValidatorOptions is blocked.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ValidatorOptions


ValidatorOptions Constructor

ValidatorOptions Constructor
Namespaces ► Sitecore.Data.Validators ► ValidatorOptions ► ValidatorOptions()()()
Members
Icon | Member | Description
 | ValidatorOptions(Boolean) | Initializes a new instance of the ValidatorOptions class.
 | ValidatorOptions(SerializationInfo, StreamingContext) | Bases the validator.


ValidatorOptions Constructor (blocking)

ValidatorOptions Constructor (blocking)
Namespaces ► Sitecore.Data.Validators ► ValidatorOptions ► ValidatorOptions(Boolean)
Initializes a new instance of the ValidatorOptions class.
Declaration Syntax
C#
public ValidatorOptions(
    bool blocking
)
Parameters
blocking (Boolean)
if set to true this instance is blocked.


ValidatorOptions Constructor (info, context)

ValidatorOptions Constructor (info, context)
Namespaces ► Sitecore.Data.Validators ► ValidatorOptions ► ValidatorOptions(SerializationInfo, StreamingContext)
Bases the validator.
Declaration Syntax
C#
protected ValidatorOptions(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Blocking Property

Blocking Property
Namespaces ► Sitecore.Data.Validators ► ValidatorOptions ► Blocking
Gets a value indicating whether this ValidatorOptions is blocked.
Declaration Syntax
C#
public bool Blocking { get; }
Value
true if blocked; otherwise, false.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Data.Validators ► ValidatorOptions ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


ValidatorPanelFormatter Class

ValidatorPanelFormatter Class
Namespaces ► Sitecore.Data.Validators ► ValidatorPanelFormatter
Represents a ValidatorsFormatter.
Declaration Syntax
C#
public static class ValidatorPanelFormatter
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenderValidationResult(ValidatorCollection) | Renders the validation result.
Inheritance Hierarchy
Object
ValidatorPanelFormatter


RenderValidationResult Method (validators)

RenderValidationResult Method (validators)
Namespaces ► Sitecore.Data.Validators ► ValidatorPanelFormatter ► RenderValidationResult(ValidatorCollection)
Renders the validation result.
Declaration Syntax
C#
public static string RenderValidationResult(
    ValidatorCollection validators
)
Parameters
validators (ValidatorCollection)
The validators.
Return Value
The validation result.


ValidatorResult Enumeration

ValidatorResult Enumeration
Namespaces ► Sitecore.Data.Validators ► ValidatorResult
Represents the state of a Validator.
Declaration Syntax
C#
public enum ValidatorResult
Members
Member | Description
Unknown | The validator has not yet evaluated.
Valid | The validator has evaluated and is valid.
Suggestion | The validator resulted in a suggestion.
Warning | The validator resulted in a warning.
Error | The validator resulted in an error.
CriticalError | The validator resulted in a critical error. The user will be warned before saving.
FatalError | The validator resulted in a fatal error. The user cannot save before the error has been resolved.


ValidatorsMode Enumeration

ValidatorsMode Enumeration
Namespaces ► Sitecore.Data.Validators ► ValidatorsMode
Specifies
Declaration Syntax
C#
public enum ValidatorsMode
Members
Member | Description
ValidatorBar | Validator Bar
ValidateButton | Validate Button
Gutter | Gutter
Workflow | Workflow


ValidatorsQueue Class

ValidatorsQueue Class
Namespaces ► Sitecore.Data.Validators ► ValidatorsQueue
Represents a ValidatorsQueue.
Declaration Syntax
C#
public static class ValidatorsQueue
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Enqueue(BaseValidator) | Queues the specified validator.
 | Evaluated | Gets or sets the evaluated.
 | GetEvaluatedValidator(ID) | Gets the done validator.
 | GetQueuedValidator(ID) | Gets the queued validator.
 | Queue | Gets or sets the queue.
 | Remove(BaseValidator) | Removes the specified validator.
Inheritance Hierarchy
Object
ValidatorsQueue


Enqueue Method (validator)

Enqueue Method (validator)
Namespaces ► Sitecore.Data.Validators ► ValidatorsQueue ► Enqueue(BaseValidator)
Queues the specified validator.
Declaration Syntax
C#
public static void Enqueue(
    BaseValidator validator
)
Parameters
validator (BaseValidator)
The validator.


Evaluated Property

Evaluated Property
Namespaces ► Sitecore.Data.Validators ► ValidatorsQueue ► Evaluated
Gets or sets the evaluated.
Declaration Syntax
C#
public static List<BaseValidator> Evaluated { get; }
Value
The evaluated.


GetEvaluatedValidator Method (id)

GetEvaluatedValidator Method (id)
Namespaces ► Sitecore.Data.Validators ► ValidatorsQueue ► GetEvaluatedValidator(ID)
Gets the done validator.
Declaration Syntax
C#
public static BaseValidator GetEvaluatedValidator(
    ID id
)
Parameters
id (ID)
The id.
Return Value
The done validator.


GetQueuedValidator Method (id)

GetQueuedValidator Method (id)
Namespaces ► Sitecore.Data.Validators ► ValidatorsQueue ► GetQueuedValidator(ID)
Gets the queued validator.
Declaration Syntax
C#
public static BaseValidator GetQueuedValidator(
    ID id
)
Parameters
id (ID)
The id.
Return Value
The queued validator.


Queue Property

Queue Property
Namespaces ► Sitecore.Data.Validators ► ValidatorsQueue ► Queue
Gets or sets the queue.
Declaration Syntax
C#
public static List<BaseValidator> Queue { get; }
Value
The queue.


Remove Method (validator)

Remove Method (validator)
Namespaces ► Sitecore.Data.Validators ► ValidatorsQueue ► Remove(BaseValidator)
Removes the specified validator.
Declaration Syntax
C#
public static void Remove(
    BaseValidator validator
)
Parameters
validator (BaseValidator)
The validator.


ValidatorWorker Class

ValidatorWorker Class
Namespaces ► Sitecore.Data.Validators ► ValidatorWorker
Represents a ValidatorsWorker.
Declaration Syntax
C#
public class ValidatorWorker
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ValidatorWorker(BaseValidator) | Initializes a new instance of the ValidatorWorker class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Start()()() | Starts this instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ValidatorWorker


ValidatorWorker Constructor (validator)

ValidatorWorker Constructor (validator)
Namespaces ► Sitecore.Data.Validators ► ValidatorWorker ► ValidatorWorker(BaseValidator)
Initializes a new instance of the ValidatorWorker class.
Declaration Syntax
C#
public ValidatorWorker(
    BaseValidator validator
)
Parameters
validator (BaseValidator)
The validator.


Start Method

Start Method
Namespaces ► Sitecore.Data.Validators ► ValidatorWorker ► Start()()()
Starts this instance.
Declaration Syntax
C#
public void Start()


Sitecore.Data.Validators.FieldValidators Namespace

Sitecore.Data.Validators.FieldValidators Namespace
Namespaces ► Sitecore.Data.Validators.FieldValidators
Declaration Syntax
C#
namespace Sitecore.Data.Validators.FieldValidators
Types
All Types Classes
Icon | Type | Description
 | BrokenLinksValidator | Validates that a field doesn't have broken links.
 | ContainsCharactersValidator | Represents a MaxLengthFieldValidator.
 | DateTimeRangeValidator | Represents a DateTimeRangeValidator.
 | ExternLinkTargetValidator | Represents a Image Alt Field Validator.
 | ImageAltFieldValidator | Represents a Image Alt Field Validator.
 | ImageAltFromMediaLibraryFieldValidator | Represents a Image Alt Field Validator.
 | ImageSizeValidator | Represents a DateTimeRangeValidator.
 | IntegerFieldValidator | Represents a IntegerFieldValidator.
 | IntegerRangeValidator | Represents a DateTimeRangeValidator.
 | MaxLengthFieldValidator | Represents a MaxLengthFieldValidator.
 | RegexValidator | Represents a DateTimeRangeValidator.
 | RequiredFieldValidator | Represents a RequiredFieldValidationRule.
 | RichTextImageSizeValidator | Represents a Image Alt Field Validator.
 | ScriptCodeValidator | Validates that a field doesn't have broken links.
 | SpellcheckValidator | Represents a DateTimeRangeValidator.
 | StringEnumValidator | Represents a StringEnumValidator.
 | TypeAndAssemblyValidator | Defines the type and assembly validator class.
 | W3CXhtmlValidator | Represents a DateTimeRangeValidator.
 | XhtmlValidator | Represents a DateTimeRangeValidator.


BrokenLinksValidator Class

BrokenLinksValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► BrokenLinksValidator
Validates that a field doesn't have broken links.
Declaration Syntax
C#
[SerializableAttribute]
public class BrokenLinksValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BrokenLinksValidator()()() | Initializes a new instance of the BrokenLinksValidator class.
 | BrokenLinksValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the BrokenLinksValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | BrokenLinksValidator


BrokenLinksValidator Constructor

BrokenLinksValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► BrokenLinksValidator ► BrokenLinksValidator()()()
Members
Icon | Member | Description
 | BrokenLinksValidator()()() | Initializes a new instance of the BrokenLinksValidator class.
 | BrokenLinksValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the BrokenLinksValidator class.


BrokenLinksValidator Constructor

BrokenLinksValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► BrokenLinksValidator ► BrokenLinksValidator()()()
Initializes a new instance of the BrokenLinksValidator class.
Declaration Syntax
C#
public BrokenLinksValidator()


BrokenLinksValidator Constructor (info, context)

BrokenLinksValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► BrokenLinksValidator ► BrokenLinksValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the BrokenLinksValidator class.
Declaration Syntax
C#
public BrokenLinksValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► BrokenLinksValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► BrokenLinksValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► BrokenLinksValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


ContainsCharactersValidator Class

ContainsCharactersValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ContainsCharactersValidator
Represents a MaxLengthFieldValidator.
Declaration Syntax
C#
[SerializableAttribute]
public class ContainsCharactersValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContainsCharactersValidator()()() | Initializes a new instance of the ContainsCharactersValidator class.
 | ContainsCharactersValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ContainsCharactersValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | ContainsCharactersValidator


ContainsCharactersValidator Constructor

ContainsCharactersValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ContainsCharactersValidator ► ContainsCharactersValidator()()()
Members
Icon | Member | Description
 | ContainsCharactersValidator()()() | Initializes a new instance of the ContainsCharactersValidator class.
 | ContainsCharactersValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ContainsCharactersValidator class.


ContainsCharactersValidator Constructor

ContainsCharactersValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ContainsCharactersValidator ► ContainsCharactersValidator()()()
Initializes a new instance of the ContainsCharactersValidator class.
Declaration Syntax
C#
public ContainsCharactersValidator()


ContainsCharactersValidator Constructor (info, context)

ContainsCharactersValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ContainsCharactersValidator ► ContainsCharactersValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the ContainsCharactersValidator class.
Declaration Syntax
C#
public ContainsCharactersValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ContainsCharactersValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ContainsCharactersValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ContainsCharactersValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


DateTimeRangeValidator Class

DateTimeRangeValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► DateTimeRangeValidator
Represents a DateTimeRangeValidator.
Declaration Syntax
C#
[SerializableAttribute]
public class DateTimeRangeValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DateTimeRangeValidator()()() | Initializes a new instance of the DateTimeRangeValidator class.
 | DateTimeRangeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | DateTimeRangeValidator


DateTimeRangeValidator Constructor

DateTimeRangeValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► DateTimeRangeValidator ► DateTimeRangeValidator()()()
Members
Icon | Member | Description
 | DateTimeRangeValidator()()() | Initializes a new instance of the DateTimeRangeValidator class.
 | DateTimeRangeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.


DateTimeRangeValidator Constructor

DateTimeRangeValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► DateTimeRangeValidator ► DateTimeRangeValidator()()()
Initializes a new instance of the DateTimeRangeValidator class.
Declaration Syntax
C#
public DateTimeRangeValidator()


DateTimeRangeValidator Constructor (info, context)

DateTimeRangeValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► DateTimeRangeValidator ► DateTimeRangeValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the DateTimeRangeValidator class.
Declaration Syntax
C#
public DateTimeRangeValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► DateTimeRangeValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► DateTimeRangeValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► DateTimeRangeValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


ExternLinkTargetValidator Class

ExternLinkTargetValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ExternLinkTargetValidator
Represents a Image Alt Field Validator.
Declaration Syntax
C#
[SerializableAttribute]
public class ExternLinkTargetValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExternLinkTargetValidator()()() | Initializes a new instance of the ExternLinkTargetValidator class.
 | ExternLinkTargetValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ExternLinkTargetValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | ExternLinkTargetValidator


ExternLinkTargetValidator Constructor

ExternLinkTargetValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ExternLinkTargetValidator ► ExternLinkTargetValidator()()()
Members
Icon | Member | Description
 | ExternLinkTargetValidator()()() | Initializes a new instance of the ExternLinkTargetValidator class.
 | ExternLinkTargetValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ExternLinkTargetValidator class.


ExternLinkTargetValidator Constructor

ExternLinkTargetValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ExternLinkTargetValidator ► ExternLinkTargetValidator()()()
Initializes a new instance of the ExternLinkTargetValidator class.
Declaration Syntax
C#
public ExternLinkTargetValidator()


ExternLinkTargetValidator Constructor (info, context)

ExternLinkTargetValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ExternLinkTargetValidator ► ExternLinkTargetValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the ExternLinkTargetValidator class.
Declaration Syntax
C#
public ExternLinkTargetValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ExternLinkTargetValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ExternLinkTargetValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ExternLinkTargetValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


ImageAltFieldValidator Class

ImageAltFieldValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageAltFieldValidator
Represents a Image Alt Field Validator.
Declaration Syntax
C#
[SerializableAttribute]
public class ImageAltFieldValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImageAltFieldValidator()()() | Initializes a new instance of the ImageAltFieldValidator class.
 | ImageAltFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageAltFieldValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | ImageAltFieldValidator


ImageAltFieldValidator Constructor

ImageAltFieldValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageAltFieldValidator ► ImageAltFieldValidator()()()
Members
Icon | Member | Description
 | ImageAltFieldValidator()()() | Initializes a new instance of the ImageAltFieldValidator class.
 | ImageAltFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageAltFieldValidator class.


ImageAltFieldValidator Constructor

ImageAltFieldValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageAltFieldValidator ► ImageAltFieldValidator()()()
Initializes a new instance of the ImageAltFieldValidator class.
Declaration Syntax
C#
public ImageAltFieldValidator()


ImageAltFieldValidator Constructor (info, context)

ImageAltFieldValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageAltFieldValidator ► ImageAltFieldValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the ImageAltFieldValidator class.
Declaration Syntax
C#
public ImageAltFieldValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageAltFieldValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageAltFieldValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageAltFieldValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


ImageAltFromMediaLibraryFieldValidator Class

ImageAltFromMediaLibraryFieldValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageAltFromMediaLibraryFieldValidator
Represents a Image Alt Field Validator.
Declaration Syntax
C#
[SerializableAttribute]
public class ImageAltFromMediaLibraryFieldValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImageAltFromMediaLibraryFieldValidator()()() | Initializes a new instance of the ImageAltFromMediaLibraryFieldValidator class.
 | ImageAltFromMediaLibraryFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageAltFromMediaLibraryFieldValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | ImageAltFromMediaLibraryFieldValidator


ImageAltFromMediaLibraryFieldValidator Constructor

ImageAltFromMediaLibraryFieldValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageAltFromMediaLibraryFieldValidator ► ImageAltFromMediaLibraryFieldValidator()()()
Members
Icon | Member | Description
 | ImageAltFromMediaLibraryFieldValidator()()() | Initializes a new instance of the ImageAltFromMediaLibraryFieldValidator class.
 | ImageAltFromMediaLibraryFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageAltFromMediaLibraryFieldValidator class.


ImageAltFromMediaLibraryFieldValidator Constructor

ImageAltFromMediaLibraryFieldValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageAltFromMediaLibraryFieldValidator ► ImageAltFromMediaLibraryFieldValidator()()()
Initializes a new instance of the ImageAltFromMediaLibraryFieldValidator class.
Declaration Syntax
C#
public ImageAltFromMediaLibraryFieldValidator()


ImageAltFromMediaLibraryFieldValidator Constructor (info, context)

ImageAltFromMediaLibraryFieldValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageAltFromMediaLibraryFieldValidator ► ImageAltFromMediaLibraryFieldValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the ImageAltFromMediaLibraryFieldValidator class.
Declaration Syntax
C#
public ImageAltFromMediaLibraryFieldValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageAltFromMediaLibraryFieldValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageAltFromMediaLibraryFieldValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageAltFromMediaLibraryFieldValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


ImageSizeValidator Class

ImageSizeValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageSizeValidator
Represents a DateTimeRangeValidator.
Declaration Syntax
C#
[SerializableAttribute]
public class ImageSizeValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImageSizeValidator()()() | Initializes a new instance of the ImageSizeValidator class.
 | ImageSizeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageSizeValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | ImageSizeValidator


ImageSizeValidator Constructor

ImageSizeValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageSizeValidator ► ImageSizeValidator()()()
Members
Icon | Member | Description
 | ImageSizeValidator()()() | Initializes a new instance of the ImageSizeValidator class.
 | ImageSizeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageSizeValidator class.


ImageSizeValidator Constructor

ImageSizeValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageSizeValidator ► ImageSizeValidator()()()
Initializes a new instance of the ImageSizeValidator class.
Declaration Syntax
C#
public ImageSizeValidator()


ImageSizeValidator Constructor (info, context)

ImageSizeValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageSizeValidator ► ImageSizeValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the ImageSizeValidator class.
Declaration Syntax
C#
public ImageSizeValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageSizeValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageSizeValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ImageSizeValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


IntegerFieldValidator Class

IntegerFieldValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerFieldValidator
Represents a IntegerFieldValidator.
Declaration Syntax
C#
[SerializableAttribute]
public class IntegerFieldValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntegerFieldValidator()()() | Initializes a new instance of the DateTimeRangeValidator class.
 | IntegerFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.
 | AllowNegative | Gets a value indicating whether the IntegerFieldValidator allows the negative.
 | AllowZero | Gets a value indicating whether the IntegerFieldValidator allows the zero.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | IntegerFieldValidator


IntegerFieldValidator Constructor

IntegerFieldValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerFieldValidator ► IntegerFieldValidator()()()
Members
Icon | Member | Description
 | IntegerFieldValidator()()() | Initializes a new instance of the DateTimeRangeValidator class.
 | IntegerFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.


IntegerFieldValidator Constructor

IntegerFieldValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerFieldValidator ► IntegerFieldValidator()()()
Initializes a new instance of the DateTimeRangeValidator class.
Declaration Syntax
C#
public IntegerFieldValidator()


IntegerFieldValidator Constructor (info, context)

IntegerFieldValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerFieldValidator ► IntegerFieldValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the DateTimeRangeValidator class.
Declaration Syntax
C#
public IntegerFieldValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


AllowNegative Property

AllowNegative Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerFieldValidator ► AllowNegative
Gets a value indicating whether the IntegerFieldValidator allows the negative.
Declaration Syntax
C#
public bool AllowNegative { get; }
Value
true if the IntegerFieldValidator allows the negative; otherwise, false.


AllowZero Property

AllowZero Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerFieldValidator ► AllowZero
Gets a value indicating whether the IntegerFieldValidator allows the zero.
Declaration Syntax
C#
public bool AllowZero { get; }
Value
true if the IntegerFieldValidator allows the zero; otherwise, false.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerFieldValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerFieldValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerFieldValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


IntegerRangeValidator Class

IntegerRangeValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerRangeValidator
Represents a DateTimeRangeValidator.
Declaration Syntax
C#
[SerializableAttribute]
public class IntegerRangeValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntegerRangeValidator()()() | Initializes a new instance of the DateTimeRangeValidator class.
 | IntegerRangeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | IntegerRangeValidator


IntegerRangeValidator Constructor

IntegerRangeValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerRangeValidator ► IntegerRangeValidator()()()
Members
Icon | Member | Description
 | IntegerRangeValidator()()() | Initializes a new instance of the DateTimeRangeValidator class.
 | IntegerRangeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.


IntegerRangeValidator Constructor

IntegerRangeValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerRangeValidator ► IntegerRangeValidator()()()
Initializes a new instance of the DateTimeRangeValidator class.
Declaration Syntax
C#
public IntegerRangeValidator()


IntegerRangeValidator Constructor (info, context)

IntegerRangeValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerRangeValidator ► IntegerRangeValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the DateTimeRangeValidator class.
Declaration Syntax
C#
public IntegerRangeValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerRangeValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerRangeValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► IntegerRangeValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


MaxLengthFieldValidator Class

MaxLengthFieldValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► MaxLengthFieldValidator
Represents a MaxLengthFieldValidator.
Declaration Syntax
C#
[SerializableAttribute]
public class MaxLengthFieldValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaxLengthFieldValidator()()() | Initializes a new instance of the DateTimeRangeValidator class.
 | MaxLengthFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | MaxLengthFieldValidator


MaxLengthFieldValidator Constructor

MaxLengthFieldValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► MaxLengthFieldValidator ► MaxLengthFieldValidator()()()
Members
Icon | Member | Description
 | MaxLengthFieldValidator()()() | Initializes a new instance of the DateTimeRangeValidator class.
 | MaxLengthFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.


MaxLengthFieldValidator Constructor

MaxLengthFieldValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► MaxLengthFieldValidator ► MaxLengthFieldValidator()()()
Initializes a new instance of the DateTimeRangeValidator class.
Declaration Syntax
C#
public MaxLengthFieldValidator()


MaxLengthFieldValidator Constructor (info, context)

MaxLengthFieldValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► MaxLengthFieldValidator ► MaxLengthFieldValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the DateTimeRangeValidator class.
Declaration Syntax
C#
public MaxLengthFieldValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► MaxLengthFieldValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► MaxLengthFieldValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► MaxLengthFieldValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


RegexValidator Class

RegexValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RegexValidator
Represents a DateTimeRangeValidator.
Declaration Syntax
C#
[SerializableAttribute]
public class RegexValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegexValidator()()() | Initializes a new instance of the DateTimeRangeValidator class.
 | RegexValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | RegexValidator


RegexValidator Constructor

RegexValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RegexValidator ► RegexValidator()()()
Members
Icon | Member | Description
 | RegexValidator()()() | Initializes a new instance of the DateTimeRangeValidator class.
 | RegexValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.


RegexValidator Constructor

RegexValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RegexValidator ► RegexValidator()()()
Initializes a new instance of the DateTimeRangeValidator class.
Declaration Syntax
C#
public RegexValidator()


RegexValidator Constructor (info, context)

RegexValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RegexValidator ► RegexValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the DateTimeRangeValidator class.
Declaration Syntax
C#
public RegexValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RegexValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RegexValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RegexValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


RequiredFieldValidator Class

RequiredFieldValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RequiredFieldValidator
Represents a RequiredFieldValidationRule.
Declaration Syntax
C#
[SerializableAttribute]
public class RequiredFieldValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RequiredFieldValidator()()() | Initializes a new instance of the DateTimeRangeValidator class.
 | RequiredFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | RequiredFieldValidator


RequiredFieldValidator Constructor

RequiredFieldValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RequiredFieldValidator ► RequiredFieldValidator()()()
Members
Icon | Member | Description
 | RequiredFieldValidator()()() | Initializes a new instance of the DateTimeRangeValidator class.
 | RequiredFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.


RequiredFieldValidator Constructor

RequiredFieldValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RequiredFieldValidator ► RequiredFieldValidator()()()
Initializes a new instance of the DateTimeRangeValidator class.
Declaration Syntax
C#
public RequiredFieldValidator()


RequiredFieldValidator Constructor (info, context)

RequiredFieldValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RequiredFieldValidator ► RequiredFieldValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the DateTimeRangeValidator class.
Declaration Syntax
C#
public RequiredFieldValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RequiredFieldValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RequiredFieldValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RequiredFieldValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


RichTextImageSizeValidator Class

RichTextImageSizeValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RichTextImageSizeValidator
Represents a Image Alt Field Validator.
Declaration Syntax
C#
[SerializableAttribute]
public class RichTextImageSizeValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RichTextImageSizeValidator()()() | Initializes a new instance of the RichTextImageSizeValidator class.
 | RichTextImageSizeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the RichTextImageSizeValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | RichTextImageSizeValidator


RichTextImageSizeValidator Constructor

RichTextImageSizeValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RichTextImageSizeValidator ► RichTextImageSizeValidator()()()
Members
Icon | Member | Description
 | RichTextImageSizeValidator()()() | Initializes a new instance of the RichTextImageSizeValidator class.
 | RichTextImageSizeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the RichTextImageSizeValidator class.


RichTextImageSizeValidator Constructor

RichTextImageSizeValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RichTextImageSizeValidator ► RichTextImageSizeValidator()()()
Initializes a new instance of the RichTextImageSizeValidator class.
Declaration Syntax
C#
public RichTextImageSizeValidator()


RichTextImageSizeValidator Constructor (info, context)

RichTextImageSizeValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RichTextImageSizeValidator ► RichTextImageSizeValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the RichTextImageSizeValidator class.
Declaration Syntax
C#
public RichTextImageSizeValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RichTextImageSizeValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RichTextImageSizeValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► RichTextImageSizeValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


ScriptCodeValidator Class

ScriptCodeValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ScriptCodeValidator
Validates that a field doesn't have broken links.
Declaration Syntax
C#
[SerializableAttribute]
public class ScriptCodeValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ScriptCodeValidator()()() | Initializes a new instance of the ScriptCodeValidator class.
 | ScriptCodeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ScriptCodeValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | ScriptCodeValidator


ScriptCodeValidator Constructor

ScriptCodeValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ScriptCodeValidator ► ScriptCodeValidator()()()
Members
Icon | Member | Description
 | ScriptCodeValidator()()() | Initializes a new instance of the ScriptCodeValidator class.
 | ScriptCodeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ScriptCodeValidator class.


ScriptCodeValidator Constructor

ScriptCodeValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ScriptCodeValidator ► ScriptCodeValidator()()()
Initializes a new instance of the ScriptCodeValidator class.
Declaration Syntax
C#
public ScriptCodeValidator()


ScriptCodeValidator Constructor (info, context)

ScriptCodeValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ScriptCodeValidator ► ScriptCodeValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the ScriptCodeValidator class.
Declaration Syntax
C#
public ScriptCodeValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialization info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ScriptCodeValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ScriptCodeValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► ScriptCodeValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The validator name.


SpellcheckValidator Class

SpellcheckValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► SpellcheckValidator
Represents a DateTimeRangeValidator.
Declaration Syntax
C#
[SerializableAttribute]
public class SpellcheckValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SpellcheckValidator()()() | Initializes a new instance of the SpellcheckValidator class.
 | SpellcheckValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the SpellcheckValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | SpellcheckValidator


SpellcheckValidator Constructor

SpellcheckValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► SpellcheckValidator ► SpellcheckValidator()()()
Members
Icon | Member | Description
 | SpellcheckValidator()()() | Initializes a new instance of the SpellcheckValidator class.
 | SpellcheckValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the SpellcheckValidator class.


SpellcheckValidator Constructor

SpellcheckValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► SpellcheckValidator ► SpellcheckValidator()()()
Initializes a new instance of the SpellcheckValidator class.
Declaration Syntax
C#
public SpellcheckValidator()


SpellcheckValidator Constructor (info, context)

SpellcheckValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► SpellcheckValidator ► SpellcheckValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the SpellcheckValidator class.
Declaration Syntax
C#
public SpellcheckValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► SpellcheckValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► SpellcheckValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► SpellcheckValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


StringEnumValidator Class

StringEnumValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► StringEnumValidator
Represents a StringEnumValidator.
Declaration Syntax
C#
[SerializableAttribute]
public class StringEnumValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringEnumValidator()()() | Initializes a new instance of the DateTimeRangeValidator class.
 | StringEnumValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | StringEnumValidator


StringEnumValidator Constructor

StringEnumValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► StringEnumValidator ► StringEnumValidator()()()
Members
Icon | Member | Description
 | StringEnumValidator()()() | Initializes a new instance of the DateTimeRangeValidator class.
 | StringEnumValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.


StringEnumValidator Constructor

StringEnumValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► StringEnumValidator ► StringEnumValidator()()()
Initializes a new instance of the DateTimeRangeValidator class.
Declaration Syntax
C#
public StringEnumValidator()


StringEnumValidator Constructor (info, context)

StringEnumValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► StringEnumValidator ► StringEnumValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the DateTimeRangeValidator class.
Declaration Syntax
C#
public StringEnumValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► StringEnumValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► StringEnumValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► StringEnumValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


TypeAndAssemblyValidator Class

TypeAndAssemblyValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► TypeAndAssemblyValidator
Defines the type and assembly validator class.
Declaration Syntax
C#
[SerializableAttribute]
public class TypeAndAssemblyValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TypeAndAssemblyValidator()()() | Initializes a new instance of the TypeAndAssemblyValidator class.
 | TypeAndAssemblyValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the TypeAndAssemblyValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | TypeAndAssemblyValidator


TypeAndAssemblyValidator Constructor

TypeAndAssemblyValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► TypeAndAssemblyValidator ► TypeAndAssemblyValidator()()()
Members
Icon | Member | Description
 | TypeAndAssemblyValidator()()() | Initializes a new instance of the TypeAndAssemblyValidator class.
 | TypeAndAssemblyValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the TypeAndAssemblyValidator class.


TypeAndAssemblyValidator Constructor

TypeAndAssemblyValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► TypeAndAssemblyValidator ► TypeAndAssemblyValidator()()()
Initializes a new instance of the TypeAndAssemblyValidator class.
Declaration Syntax
C#
public TypeAndAssemblyValidator()


TypeAndAssemblyValidator Constructor (info, context)

TypeAndAssemblyValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► TypeAndAssemblyValidator ► TypeAndAssemblyValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the TypeAndAssemblyValidator class.
Declaration Syntax
C#
public TypeAndAssemblyValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialization info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► TypeAndAssemblyValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► TypeAndAssemblyValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► TypeAndAssemblyValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The validator name.


W3CXhtmlValidator Class

W3CXhtmlValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► W3CXhtmlValidator
Represents a DateTimeRangeValidator.
Declaration Syntax
C#
[SerializableAttribute]
public class W3CXhtmlValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W3CXhtmlValidator()()() | Initializes a new instance of the BaseValidator class.
 | W3CXhtmlValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the W3CXhtmlValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides BaseValidator.GetObjectData(SerializationInfo, StreamingContext).)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Report | Gets or sets the report.
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | W3CXhtmlValidator


W3CXhtmlValidator Constructor

W3CXhtmlValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► W3CXhtmlValidator ► W3CXhtmlValidator()()()
Members
Icon | Member | Description
 | W3CXhtmlValidator()()() | Initializes a new instance of the BaseValidator class.
 | W3CXhtmlValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the W3CXhtmlValidator class.


W3CXhtmlValidator Constructor

W3CXhtmlValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► W3CXhtmlValidator ► W3CXhtmlValidator()()()
Initializes a new instance of the BaseValidator class.
Declaration Syntax
C#
public W3CXhtmlValidator()


W3CXhtmlValidator Constructor (info, context)

W3CXhtmlValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► W3CXhtmlValidator ► W3CXhtmlValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the W3CXhtmlValidator class.
Declaration Syntax
C#
protected W3CXhtmlValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► W3CXhtmlValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► W3CXhtmlValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► W3CXhtmlValidator ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► W3CXhtmlValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


Report Property

Report Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► W3CXhtmlValidator ► Report
Gets or sets the report.
Declaration Syntax
C#
public string Report { get; set; }
Value
The report.


XhtmlValidator Class

XhtmlValidator Class
Namespaces ► Sitecore.Data.Validators.FieldValidators ► XhtmlValidator
Represents a DateTimeRangeValidator.
Declaration Syntax
C#
[SerializableAttribute]
public class XhtmlValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XhtmlValidator()()() | Initializes a new instance of the XhtmlValidator class.
 | XhtmlValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the XhtmlValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | XhtmlValidator


XhtmlValidator Constructor

XhtmlValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► XhtmlValidator ► XhtmlValidator()()()
Members
Icon | Member | Description
 | XhtmlValidator()()() | Initializes a new instance of the XhtmlValidator class.
 | XhtmlValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the XhtmlValidator class.


XhtmlValidator Constructor

XhtmlValidator Constructor
Namespaces ► Sitecore.Data.Validators.FieldValidators ► XhtmlValidator ► XhtmlValidator()()()
Initializes a new instance of the XhtmlValidator class.
Declaration Syntax
C#
public XhtmlValidator()


XhtmlValidator Constructor (info, context)

XhtmlValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.FieldValidators ► XhtmlValidator ► XhtmlValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the XhtmlValidator class.
Declaration Syntax
C#
public XhtmlValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► XhtmlValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.FieldValidators ► XhtmlValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.FieldValidators ► XhtmlValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


Sitecore.Data.Validators.ItemValidators Namespace

Sitecore.Data.Validators.ItemValidators Namespace
Namespaces ► Sitecore.Data.Validators.ItemValidators
Declaration Syntax
C#
namespace Sitecore.Data.Validators.ItemValidators
Types
All Types Classes
Icon | Type | Description
 | BrokenLinkValidator | Implements an item validator that checks that no duplicate names appears on the same level.
 | DuplicateNameValidator | Implements an item validator that checks that no duplicate names appears on the same level.
 | FullPageXHtmlValidator | Implements an item validator that checks that no duplicate names appears on the same level.
 | MediaSizeValidator | Implements an item validator that checks that no duplicate names appears on the same level.
 | UrlCharacterValidator | Implements an item validator that checks that no duplicate names appears on the same level.


BrokenLinkValidator Class

BrokenLinkValidator Class
Namespaces ► Sitecore.Data.Validators.ItemValidators ► BrokenLinkValidator
Implements an item validator that checks that no duplicate names appears on the same level.
Declaration Syntax
C#
[SerializableAttribute]
public class BrokenLinkValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BrokenLinkValidator()()() | Initializes a new instance of the BrokenLinkValidator class.
 | BrokenLinkValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the BrokenLinkValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | BrokenLinkValidator


BrokenLinkValidator Constructor

BrokenLinkValidator Constructor
Namespaces ► Sitecore.Data.Validators.ItemValidators ► BrokenLinkValidator ► BrokenLinkValidator()()()
Members
Icon | Member | Description
 | BrokenLinkValidator()()() | Initializes a new instance of the BrokenLinkValidator class.
 | BrokenLinkValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the BrokenLinkValidator class.


BrokenLinkValidator Constructor

BrokenLinkValidator Constructor
Namespaces ► Sitecore.Data.Validators.ItemValidators ► BrokenLinkValidator ► BrokenLinkValidator()()()
Initializes a new instance of the BrokenLinkValidator class.
Declaration Syntax
C#
public BrokenLinkValidator()


BrokenLinkValidator Constructor (info, context)

BrokenLinkValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.ItemValidators ► BrokenLinkValidator ► BrokenLinkValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the BrokenLinkValidator class.
Declaration Syntax
C#
public BrokenLinkValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.ItemValidators ► BrokenLinkValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.ItemValidators ► BrokenLinkValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.ItemValidators ► BrokenLinkValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


DuplicateNameValidator Class

DuplicateNameValidator Class
Namespaces ► Sitecore.Data.Validators.ItemValidators ► DuplicateNameValidator
Implements an item validator that checks that no duplicate names appears on the same level.
Declaration Syntax
C#
[SerializableAttribute]
public class DuplicateNameValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DuplicateNameValidator()()() | Initializes a new instance of the DuplicateNameValidator class.
 | DuplicateNameValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateNameValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | DuplicateNameValidator


DuplicateNameValidator Constructor

DuplicateNameValidator Constructor
Namespaces ► Sitecore.Data.Validators.ItemValidators ► DuplicateNameValidator ► DuplicateNameValidator()()()
Members
Icon | Member | Description
 | DuplicateNameValidator()()() | Initializes a new instance of the DuplicateNameValidator class.
 | DuplicateNameValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateNameValidator class.


DuplicateNameValidator Constructor

DuplicateNameValidator Constructor
Namespaces ► Sitecore.Data.Validators.ItemValidators ► DuplicateNameValidator ► DuplicateNameValidator()()()
Initializes a new instance of the DuplicateNameValidator class.
Declaration Syntax
C#
public DuplicateNameValidator()


DuplicateNameValidator Constructor (info, context)

DuplicateNameValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.ItemValidators ► DuplicateNameValidator ► DuplicateNameValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the DuplicateNameValidator class.
Declaration Syntax
C#
public DuplicateNameValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.ItemValidators ► DuplicateNameValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.ItemValidators ► DuplicateNameValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.ItemValidators ► DuplicateNameValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


FullPageXHtmlValidator Class

FullPageXHtmlValidator Class
Namespaces ► Sitecore.Data.Validators.ItemValidators ► FullPageXHtmlValidator
Implements an item validator that checks that no duplicate names appears on the same level.
Declaration Syntax
C#
[SerializableAttribute]
public class FullPageXHtmlValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FullPageXHtmlValidator()()() | Initializes a new instance of the BrokenLinkValidator class.
 | FullPageXHtmlValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the BrokenLinkValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | FullPageXHtmlValidator


FullPageXHtmlValidator Constructor

FullPageXHtmlValidator Constructor
Namespaces ► Sitecore.Data.Validators.ItemValidators ► FullPageXHtmlValidator ► FullPageXHtmlValidator()()()
Members
Icon | Member | Description
 | FullPageXHtmlValidator()()() | Initializes a new instance of the BrokenLinkValidator class.
 | FullPageXHtmlValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the BrokenLinkValidator class.


FullPageXHtmlValidator Constructor

FullPageXHtmlValidator Constructor
Namespaces ► Sitecore.Data.Validators.ItemValidators ► FullPageXHtmlValidator ► FullPageXHtmlValidator()()()
Initializes a new instance of the BrokenLinkValidator class.
Declaration Syntax
C#
public FullPageXHtmlValidator()


FullPageXHtmlValidator Constructor (info, context)

FullPageXHtmlValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.ItemValidators ► FullPageXHtmlValidator ► FullPageXHtmlValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the BrokenLinkValidator class.
Declaration Syntax
C#
public FullPageXHtmlValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.ItemValidators ► FullPageXHtmlValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.ItemValidators ► FullPageXHtmlValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is ValidatorResult.CriticalError or ValidatorResult.FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.ItemValidators ► FullPageXHtmlValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


MediaSizeValidator Class

MediaSizeValidator Class
Namespaces ► Sitecore.Data.Validators.ItemValidators ► MediaSizeValidator
Implements an item validator that checks that no duplicate names appears on the same level.
Declaration Syntax
C#
[SerializableAttribute]
public class MediaSizeValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaSizeValidator()()() | Initializes a new instance of the MediaSizeValidator class.
 | MediaSizeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the MediaSizeValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | MediaSizeValidator


MediaSizeValidator Constructor

MediaSizeValidator Constructor
Namespaces ► Sitecore.Data.Validators.ItemValidators ► MediaSizeValidator ► MediaSizeValidator()()()
Members
Icon | Member | Description
 | MediaSizeValidator()()() | Initializes a new instance of the MediaSizeValidator class.
 | MediaSizeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the MediaSizeValidator class.


MediaSizeValidator Constructor

MediaSizeValidator Constructor
Namespaces ► Sitecore.Data.Validators.ItemValidators ► MediaSizeValidator ► MediaSizeValidator()()()
Initializes a new instance of the MediaSizeValidator class.
Declaration Syntax
C#
public MediaSizeValidator()


MediaSizeValidator Constructor (info, context)

MediaSizeValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.ItemValidators ► MediaSizeValidator ► MediaSizeValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the MediaSizeValidator class.
Declaration Syntax
C#
public MediaSizeValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.ItemValidators ► MediaSizeValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.ItemValidators ► MediaSizeValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.ItemValidators ► MediaSizeValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


UrlCharacterValidator Class

UrlCharacterValidator Class
Namespaces ► Sitecore.Data.Validators.ItemValidators ► UrlCharacterValidator
Implements an item validator that checks that no duplicate names appears on the same level.
Declaration Syntax
C#
[SerializableAttribute]
public class UrlCharacterValidator : StandardValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UrlCharacterValidator()()() | Initializes a new instance of the DuplicateNameValidator class.
 | UrlCharacterValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateNameValidator class.
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the errors. (Inherited from BaseValidator.)
 | Evaluate()()() | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator.Evaluate()()().)
 | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
 | Expire()()() | Expires this instance. (Inherited from BaseValidator.)
 | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
 | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControlValidationValue()()() | Gets the control validation value. (Inherited from BaseValidator.)
 | GetFailedResult(ValidatorResult) | Gets the result. (Inherited from StandardValidator.)
 | GetField()()() | Gets the field. (Inherited from BaseValidator.)
 | GetFieldDisplayName()()() | Gets the display name of the field. (Inherited from BaseValidator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIcon()()() | Gets the icon. (Inherited from BaseValidator.)
 | GetItem()()() | Gets the item. (Inherited from BaseValidator.)
 | GetMaxValidatorResult()()() | Gets the max validator result. (Overrides BaseValidator.GetMaxValidatorResult()()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
 | GetText(String, array<String>[]()[]) | Gets the text. (Inherited from StandardValidator.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasControlToValidate()()() | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
 | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
 | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
 | IsControlValidationValueValid()()() | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
 | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
 | IsEvaluationRequired()()() | Determines if evaluation should be performed. (Inherited from BaseValidator.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
 | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
 | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Overrides BaseValidator.Name.)
 | Options | Gets the options. (Inherited from BaseValidator.)
 | Parameters | Gets the parameters. (Inherited from BaseValidator.)
 | Result | Gets or sets the state. (Inherited from BaseValidator.)
 | Text | Gets or sets the text. (Inherited from BaseValidator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance. (Inherited from BaseValidator.)
 | Validate(ValidatorOptions) | Validates this instance. (Inherited from BaseValidator.)
 | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)
Inheritance Hierarchy
Object
 | BaseValidator
 |  | StandardValidator
 |  |  | UrlCharacterValidator


UrlCharacterValidator Constructor

UrlCharacterValidator Constructor
Namespaces ► Sitecore.Data.Validators.ItemValidators ► UrlCharacterValidator ► UrlCharacterValidator()()()
Members
Icon | Member | Description
 | UrlCharacterValidator()()() | Initializes a new instance of the DuplicateNameValidator class.
 | UrlCharacterValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateNameValidator class.


UrlCharacterValidator Constructor

UrlCharacterValidator Constructor
Namespaces ► Sitecore.Data.Validators.ItemValidators ► UrlCharacterValidator ► UrlCharacterValidator()()()
Initializes a new instance of the DuplicateNameValidator class.
Declaration Syntax
C#
public UrlCharacterValidator()


UrlCharacterValidator Constructor (info, context)

UrlCharacterValidator Constructor (info, context)
Namespaces ► Sitecore.Data.Validators.ItemValidators ► UrlCharacterValidator ► UrlCharacterValidator(SerializationInfo, StreamingContext)
Initializes a new instance of the DuplicateNameValidator class.
Declaration Syntax
C#
public UrlCharacterValidator(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Evaluate Method

Evaluate Method
Namespaces ► Sitecore.Data.Validators.ItemValidators ► UrlCharacterValidator ► Evaluate()()()
When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Declaration Syntax
C#
protected override ValidatorResult Evaluate()
Return Value
The result of the evaluation.


GetMaxValidatorResult Method

GetMaxValidatorResult Method
Namespaces ► Sitecore.Data.Validators.ItemValidators ► UrlCharacterValidator ► GetMaxValidatorResult()()()
Gets the max validator result.
Declaration Syntax
C#
protected override ValidatorResult GetMaxValidatorResult()
Return Value
The max validator result.
Remarks
This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.


Name Property

Name Property
Namespaces ► Sitecore.Data.Validators.ItemValidators ► UrlCharacterValidator ► Name
Gets the name.
Declaration Syntax
C#
public override string Name { get; }
Value
The name.


Sitecore.Diagnostics Namespace

Sitecore.Diagnostics Namespace
Namespaces ► Sitecore.Diagnostics
Declaration Syntax
C#
namespace Sitecore.Diagnostics
Types
All Types Classes Enumerations Delegates
Icon | Type | Description
 | AnalyticsLogger |
 | Assert | Assertions.
 | Audit | Writes Audit information to a file.
 | AuditFormatter |
 | AuditStorageProvider | The abstract base class for audit storage providers.
 | CallStack | Represents the current call stack.
 | Counter | Obsolete. Represents a Counter.
 | CounterData | Obsolete. Container for counters.
 | CounterLock | Obsolete. Lock that can be held by many threads simultaneously.
 | Counters | Obsolete. Container for counters.
 | CycleAsserter | RecursionLimit class
 | CycleDetector | RecursionLimit class
 | Debug | Debug class
 | DiagnosticContext | Represents the current diagnostics context.
 | DiagnosticWorker | Represents a DiagnosticWorker.
 | DisposeHelper | DisposeHelper
 | Error | Defines methods for error handling.
 | EventDispatcher | Class for dispatching events.
 | FailureReason | FailureReason
 | HealthMonitorHook | Implements a hook for the health monitor
 | HighResTimer | Implements a class that encapsulates the operating system high resolution timer using native API functions.
 | Log | Represents the Log.
 | AnalyticsLogger..::.LogEntry |
 | LoggerFactory | Creates the Log object.
 | LogNotification | Defines the log notification class.
 | LogNotification..::.LogNotificationDelegate | Delegate.
 | LogNotificationLevel | The level of log information.
 | LongRunningOperationWatcher | ProfileSection class
 | MemoryMonitorHook | Implements a hook for the memory monitor
 | Statistics..::.PipelineTiming | PipelineTiming class
 | ProfileEntry | ProfileData
 | Profiler | Represents the Profiler.
 | ProfileSection | ProfileSection class
 | RecursionLimit | RecursionLimit class
 | Statistics..::.RenderingData | RenderingData
 | TextLog..::.Severity | Severity
 | Statistics | Statistics Statistics Statistics
 | TextLog | TextLog class
 | TextLogEntry | TextLogEntry class
 | ThreadError | Thread error container class.
 | Tracer | Represents the Tracer.
 | UnitTester | Test related utility functions
 | Counter..::.Worker | Represents a Worker.
 | Profiler..::.Worker | Represents a Worker.
 | Tracer..::.Worker | Represents a Worker.


AnalyticsLogger Class

AnalyticsLogger Class
Namespaces ► Sitecore.Diagnostics ► AnalyticsLogger
Declaration Syntax
C#
public class AnalyticsLogger : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalyticsLogger()()() | Initializes a new instance of the AnalyticsLogger class
 | Current |
 | Dispose()()() |
 | Entries |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | (Overrides Object.Finalize()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Start()()() |
 | Stop()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AnalyticsLogger

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsLogger Constructor

AnalyticsLogger Constructor
Namespaces ► Sitecore.Diagnostics ► AnalyticsLogger ► AnalyticsLogger()()()
Initializes a new instance of the AnalyticsLogger class
Declaration Syntax
C#
public AnalyticsLogger()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Current Property

Current Property
Namespaces ► Sitecore.Diagnostics ► AnalyticsLogger ► Current
Declaration Syntax
C#
public static AnalyticsLogger Current { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Dispose Method

Dispose Method
Namespaces ► Sitecore.Diagnostics ► AnalyticsLogger ► Dispose()()()
Declaration Syntax
C#
public void Dispose()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Entries Property

Entries Property
Namespaces ► Sitecore.Diagnostics ► AnalyticsLogger ► Entries
Declaration Syntax
C#
public List<AnalyticsLogger..::.LogEntry> Entries { get; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Finalize Method

Finalize Method
Namespaces ► Sitecore.Diagnostics ► AnalyticsLogger ► Finalize()()()
Declaration Syntax
C#
protected override void Finalize()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Start Method

Start Method
Namespaces ► Sitecore.Diagnostics ► AnalyticsLogger ► Start()()()
Declaration Syntax
C#
public static void Start()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Stop Method

Stop Method
Namespaces ► Sitecore.Diagnostics ► AnalyticsLogger ► Stop()()()
Declaration Syntax
C#
public void Stop()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsLogger.LogEntry Class

AnalyticsLogger..::.LogEntry Class
Namespaces ► Sitecore.Diagnostics ► AnalyticsLogger ► AnalyticsLogger..::.LogEntry
Declaration Syntax
C#
public class LogEntry
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnalyticsLogger..::.LogEntry()()() | Initializes a new instance of the AnalyticsLogger..::.LogEntry class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exception |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Level |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AnalyticsLogger..::.LogEntry

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


AnalyticsLogger.LogEntry Constructor

AnalyticsLogger..::.LogEntry Constructor
Namespaces ► Sitecore.Diagnostics ► AnalyticsLogger..::.LogEntry ► AnalyticsLogger..::.LogEntry()()()
Initializes a new instance of the AnalyticsLogger..::.LogEntry class
Declaration Syntax
C#
public LogEntry()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Exception Property

Exception Property
Namespaces ► Sitecore.Diagnostics ► AnalyticsLogger..::.LogEntry ► Exception
Declaration Syntax
C#
public Exception Exception { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Level Property

Level Property
Namespaces ► Sitecore.Diagnostics ► AnalyticsLogger..::.LogEntry ► Level
Declaration Syntax
C#
public LogNotificationLevel Level { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Message Property

Message Property
Namespaces ► Sitecore.Diagnostics ► AnalyticsLogger..::.LogEntry ► Message
Declaration Syntax
C#
public string Message { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Analytics (Module: Sitecore.Analytics) Version: 1.0.0.0 (1.0.0.0)


Assert Class

Assert Class
Namespaces ► Sitecore.Diagnostics ► Assert
Assertions.
Declaration Syntax
C#
public static class Assert
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AreEqual(Int32, Int32, String) | Asserts that the arguments are equal.
 | AreEqual(Int32, Int32, String, array<Object>[]()[]) | Asserts that the arguments are equal.
 | AreEqual(String, String, String) | Asserts that the arguments are equal.
 | AreEqual(String, String, String, array<Object>[]()[]) | Asserts that the arguments are equal.
 | ArgumentCondition(Boolean, String, String) | Asserts a condition on an argument.
 | ArgumentNotNull(Object, String) | Asserts that the arguments are not null.
 | ArgumentNotNull(Object, Func<(Of <(String>)>)) | Asserts that the arguments are not null.
 | ArgumentNotNullOrEmpty(ID, String) | Asserts that the arguments are not null or empty.
 | ArgumentNotNullOrEmpty(String, String) | Asserts that the arguments are not null or empty.
 | ArgumentNotNullOrEmpty(String, Func<(Of <(String>)>)) | Asserts that the arguments are not null or empty.
 | CanRunApplication(String) | Determines whether this instance [can run application] the specified application.
 | HasAccess(Boolean, String) | Determines whether the specified access is allowed.
 | HasAccess(Boolean, String, array<Object>[]()[]) | Determines whether the specified access is allowed.
 | IsEditing(Item) | Determines whether the specified item is in editing mode.
 | IsFalse(Boolean, String) | Asserts that the specified condition is false.
 | IsFalse(Boolean, Func<(Of <(String>)>)) | Asserts that the specified condition is false.
 | IsFalse(Boolean, String, array<Object>[]()[]) | Asserts that the specified condition is false.
 | IsNotNull(Object, String) | Asserts that the specified value is not null.
 | IsNotNull(Object, String, array<Object>[]()[]) | Asserts that the specified value is not null.
 | IsNotNull(Object, Type) | Asserts that the specified value is not null.
 | IsNotNull(Object, Type, String, array<Object>[]()[]) | Asserts that the specified value is not null.
 | IsNotNullOrEmpty(String, String) | Asserts that the specified value is not null.
 | IsNotNullOrEmpty(String, String, array<Object>[]()[]) | Asserts that the specified string is not null or empty.
 | IsNull(Object, String) | Asserts that the specified value is null.
 | IsNull(Object, String, array<Object>[]()[]) | Asserts that the specified value is null.
 | IsTrue(Boolean, String) | Determines whether the specified condition is true.
 | IsTrue(Boolean, Func<(Of <(String>)>)) | Determines whether the specified condition is true.
 | IsTrue(Boolean, String, array<Object>[]()[]) | Determines whether the specified condition is true.
 | ReflectionObjectCreated(Object, String) | Asserts that the object is created.
 | Required(Object, String) | Throws a RequiredObjectIsNullException if a specific condition is not met.
 | Required(Object, String, array<Object>[]()[]) | Throws a RequiredObjectIsNullException if a specific condition is not met.
 | ResultNotNull<(Of <(T>)>)(T, String) | Results the not null.
 | ResultNotNull<(Of <(T>)>)(T) | Results the not null.
Inheritance Hierarchy
Object
Assert


AreEqual Method

AreEqual Method
Namespaces ► Sitecore.Diagnostics ► Assert ► AreEqual()()()
Members
Icon | Member | Description
 | AreEqual(Int32, Int32, String) | Asserts that the arguments are equal.
 | AreEqual(Int32, Int32, String, array<Object>[]()[]) | Asserts that the arguments are equal.
 | AreEqual(String, String, String) | Asserts that the arguments are equal.
 | AreEqual(String, String, String, array<Object>[]()[]) | Asserts that the arguments are equal.


AreEqual Method (value1, value2, message)

AreEqual Method (value1, value2, message)
Namespaces ► Sitecore.Diagnostics ► Assert ► AreEqual(Int32, Int32, String)
Asserts that the arguments are equal.
Declaration Syntax
C#
public static void AreEqual(
    int value1,
    int value2,
    string message
)
Parameters
value1 (Int32)
The value1.
value2 (Int32)
The value2.
message (String)
The message.
Exceptions
Exception | Condition
InvalidValueException | InvalidValueException.


AreEqual Method (value1, value2, format, args)

AreEqual Method (value1, value2, format, args)
Namespaces ► Sitecore.Diagnostics ► Assert ► AreEqual(Int32, Int32, String, array<Object>[]()[])
Asserts that the arguments are equal.
Declaration Syntax
C#
public static void AreEqual(
    int value1,
    int value2,
    string format,
    params Object[] args
)
Parameters
value1 (Int32)
The value1.
value2 (Int32)
The value2.
format (String)
The format.
args (array< Object >[]()[])
The arguments.


AreEqual Method (value1, value2, message)

AreEqual Method (value1, value2, message)
Namespaces ► Sitecore.Diagnostics ► Assert ► AreEqual(String, String, String)
Asserts that the arguments are equal.
Declaration Syntax
C#
public static void AreEqual(
    string value1,
    string value2,
    string message
)
Parameters
value1 (String)
The value1.
value2 (String)
The value2.
message (String)
The message.
Exceptions
Exception | Condition
InvalidValueException | InvalidValueException.


AreEqual Method (value1, value2, format, args)

AreEqual Method (value1, value2, format, args)
Namespaces ► Sitecore.Diagnostics ► Assert ► AreEqual(String, String, String, array<Object>[]()[])
Asserts that the arguments are equal.
Declaration Syntax
C#
public static void AreEqual(
    string value1,
    string value2,
    string format,
    params Object[] args
)
Parameters
value1 (String)
The value1.
value2 (String)
The value2.
format (String)
The format.
args (array< Object >[]()[])
The arguments.


ArgumentCondition Method (condition, argumentName, message)

ArgumentCondition Method (condition, argumentName, message)
Namespaces ► Sitecore.Diagnostics ► Assert ► ArgumentCondition(Boolean, String, String)
Asserts a condition on an argument.
Declaration Syntax
C#
public static void ArgumentCondition(
    bool condition,
    string argumentName,
    string message
)
Parameters
condition (Boolean)
if set to true [condition].
argumentName (String)
Name of the argument.
message (String)
The message.
Exceptions
Exception | Condition
ArgumentException | ArgumentException.


ArgumentNotNull Method

ArgumentNotNull Method
Namespaces ► Sitecore.Diagnostics ► Assert ► ArgumentNotNull()()()
Members
Icon | Member | Description
 | ArgumentNotNull(Object, String) | Asserts that the arguments are not null.
 | ArgumentNotNull(Object, Func<(Of <(String>)>)) | Asserts that the arguments are not null.


ArgumentNotNull Method (argument, getArgumentName)

ArgumentNotNull Method (argument, getArgumentName)
Namespaces ► Sitecore.Diagnostics ► Assert ► ArgumentNotNull(Object, Func<(Of <(String>)>))
Asserts that the arguments are not null.
Declaration Syntax
C#
public static void ArgumentNotNull(
    Object argument,
    Func<string> getArgumentName
)
Parameters
argument (Object)
The argument value.
getArgumentName (Func<(Of <(String>)>))
The delegate used to get the parameter name.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the argument is null.


ArgumentNotNull Method (argument, argumentName)

ArgumentNotNull Method (argument, argumentName)
Namespaces ► Sitecore.Diagnostics ► Assert ► ArgumentNotNull(Object, String)
Asserts that the arguments are not null.
Declaration Syntax
C#
public static void ArgumentNotNull(
    Object argument,
    string argumentName
)
Parameters
argument (Object)
The argument.
argumentName (String)
Name of the argument.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the argument is null.


ArgumentNotNullOrEmpty Method

ArgumentNotNullOrEmpty Method
Namespaces ► Sitecore.Diagnostics ► Assert ► ArgumentNotNullOrEmpty()()()
Members
Icon | Member | Description
 | ArgumentNotNullOrEmpty(ID, String) | Asserts that the arguments are not null or empty.
 | ArgumentNotNullOrEmpty(String, String) | Asserts that the arguments are not null or empty.
 | ArgumentNotNullOrEmpty(String, Func<(Of <(String>)>)) | Asserts that the arguments are not null or empty.


ArgumentNotNullOrEmpty Method (argument, argumentName)

ArgumentNotNullOrEmpty Method (argument, argumentName)
Namespaces ► Sitecore.Diagnostics ► Assert ► ArgumentNotNullOrEmpty(ID, String)
Asserts that the arguments are not null or empty.
Declaration Syntax
C#
public static void ArgumentNotNullOrEmpty(
    ID argument,
    string argumentName
)
Parameters
argument (ID)
The argument.
argumentName (String)
Name of the argument.
Exceptions
Exception | Condition
ArgumentException | ArgumentException.


ArgumentNotNullOrEmpty Method (argument, getArgumentName)

ArgumentNotNullOrEmpty Method (argument, getArgumentName)
Namespaces ► Sitecore.Diagnostics ► Assert ► ArgumentNotNullOrEmpty(String, Func<(Of <(String>)>))
Asserts that the arguments are not null or empty.
Declaration Syntax
C#
public static void ArgumentNotNullOrEmpty(
    string argument,
    Func<string> getArgumentName
)
Parameters
argument (String)
The argument.
getArgumentName (Func<(Of <(String>)>))
Delegate for getting the argument name.
Exceptions
Exception | Condition
ArgumentNullException | Null ids are not allowed.
ArgumentException | Empty strings are not allowed.


ArgumentNotNullOrEmpty Method (argument, argumentName)

ArgumentNotNullOrEmpty Method (argument, argumentName)
Namespaces ► Sitecore.Diagnostics ► Assert ► ArgumentNotNullOrEmpty(String, String)
Asserts that the arguments are not null or empty.
Declaration Syntax
C#
public static void ArgumentNotNullOrEmpty(
    string argument,
    string argumentName
)
Parameters
argument (String)
The argument.
argumentName (String)
Name of the argument.
Exceptions
Exception | Condition
ArgumentNullException | Null ids are not allowed.
ArgumentException | Empty strings are not allowed.


CanRunApplication Method (application)

CanRunApplication Method (application)
Namespaces ► Sitecore.Diagnostics ► Assert ► CanRunApplication(String)
Determines whether this instance [can run application] the specified application.
Declaration Syntax
C#
public static void CanRunApplication(
    string application
)
Parameters
application (String)
The application.


HasAccess Method

HasAccess Method
Namespaces ► Sitecore.Diagnostics ► Assert ► HasAccess()()()
Members
Icon | Member | Description
 | HasAccess(Boolean, String) | Determines whether the specified access is allowed.
 | HasAccess(Boolean, String, array<Object>[]()[]) | Determines whether the specified access is allowed.


HasAccess Method (accessAllowed, message)

HasAccess Method (accessAllowed, message)
Namespaces ► Sitecore.Diagnostics ► Assert ► HasAccess(Boolean, String)
Determines whether the specified access is allowed.
Declaration Syntax
C#
public static void HasAccess(
    bool accessAllowed,
    string message
)
Parameters
accessAllowed (Boolean)
if set to true this access is allowed.
message (String)
The message.
Exceptions
Exception | Condition
AccessDeniedException | AccessDeniedException.


HasAccess Method (accessAllowed, format, args)

HasAccess Method (accessAllowed, format, args)
Namespaces ► Sitecore.Diagnostics ► Assert ► HasAccess(Boolean, String, array<Object>[]()[])
Determines whether the specified access is allowed.
Declaration Syntax
C#
public static void HasAccess(
    bool accessAllowed,
    string format,
    params Object[] args
)
Parameters
accessAllowed (Boolean)
if set to true this access is allowed.
format (String)
The format.
args (array< Object >[]()[])
The arguments.


IsEditing Method (item)

IsEditing Method (item)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsEditing(Item)
Determines whether the specified item is in editing mode.
Declaration Syntax
C#
public static void IsEditing(
    Item item
)
Parameters
item (Item)
The item.
Exceptions
Exception | Condition
EditingNotAllowedException | EditingNotAllowedException.


IsFalse Method

IsFalse Method
Namespaces ► Sitecore.Diagnostics ► Assert ► IsFalse()()()
Members
Icon | Member | Description
 | IsFalse(Boolean, String) | Asserts that the specified condition is false.
 | IsFalse(Boolean, Func<(Of <(String>)>)) | Asserts that the specified condition is false.
 | IsFalse(Boolean, String, array<Object>[]()[]) | Asserts that the specified condition is false.


IsFalse Method (condition, getMessage)

IsFalse Method (condition, getMessage)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsFalse(Boolean, Func<(Of <(String>)>))
Asserts that the specified condition is false.
Declaration Syntax
C#
public static void IsFalse(
    bool condition,
    Func<string> getMessage
)
Parameters
condition (Boolean)
getMessage (Func<(Of <(String>)>))
Exceptions
Exception | Condition
InvalidOperationException | InvalidOperationException.


IsFalse Method (condition, message)

IsFalse Method (condition, message)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsFalse(Boolean, String)
Asserts that the specified condition is false.
Declaration Syntax
C#
public static void IsFalse(
    bool condition,
    string message
)
Parameters
condition (Boolean)
message (String)
Exceptions
Exception | Condition
InvalidOperationException | InvalidOperationException.


IsFalse Method (condition, format, args)

IsFalse Method (condition, format, args)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsFalse(Boolean, String, array<Object>[]()[])
Asserts that the specified condition is false.
Declaration Syntax
C#
public static void IsFalse(
    bool condition,
    string format,
    params Object[] args
)
Parameters
condition (Boolean)
The condition.
format (String)
The format.
args (array< Object >[]()[])
The arguments.


IsNotNull Method

IsNotNull Method
Namespaces ► Sitecore.Diagnostics ► Assert ► IsNotNull()()()
Members
Icon | Member | Description
 | IsNotNull(Object, String) | Asserts that the specified value is not null.
 | IsNotNull(Object, String, array<Object>[]()[]) | Asserts that the specified value is not null.
 | IsNotNull(Object, Type) | Asserts that the specified value is not null.
 | IsNotNull(Object, Type, String, array<Object>[]()[]) | Asserts that the specified value is not null.


IsNotNull Method (value, message)

IsNotNull Method (value, message)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsNotNull(Object, String)
Asserts that the specified value is not null.
Declaration Syntax
C#
public static void IsNotNull(
    Object value,
    string message
)
Parameters
value (Object)
The value.
message (String)
The message.
Exceptions
Exception | Condition
InvalidOperationException | InvalidOperationException.


IsNotNull Method (value, format, args)

IsNotNull Method (value, format, args)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsNotNull(Object, String, array<Object>[]()[])
Asserts that the specified value is not null.
Declaration Syntax
C#
public static void IsNotNull(
    Object value,
    string format,
    params Object[] args
)
Parameters
value (Object)
The value.
format (String)
The format.
args (array< Object >[]()[])
The arguments.


IsNotNull Method (value, type)

IsNotNull Method (value, type)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsNotNull(Object, Type)
Asserts that the specified value is not null.
Declaration Syntax
C#
public static void IsNotNull(
    Object value,
    Type type
)
Parameters
value (Object)
The value.
type (Type)
The object type.


IsNotNull Method (value, type, format, args)

IsNotNull Method (value, type, format, args)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsNotNull(Object, Type, String, array<Object>[]()[])
Asserts that the specified value is not null.
Declaration Syntax
C#
public static void IsNotNull(
    Object value,
    Type type,
    string format,
    params Object[] args
)
Parameters
value (Object)
The value.
type (Type)
The type.
format (String)
The format.
args (array< Object >[]()[])
The arguments.


IsNotNullOrEmpty Method

IsNotNullOrEmpty Method
Namespaces ► Sitecore.Diagnostics ► Assert ► IsNotNullOrEmpty()()()
Members
Icon | Member | Description
 | IsNotNullOrEmpty(String, String) | Asserts that the specified value is not null.
 | IsNotNullOrEmpty(String, String, array<Object>[]()[]) | Asserts that the specified string is not null or empty.


IsNotNullOrEmpty Method (value, message)

IsNotNullOrEmpty Method (value, message)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsNotNullOrEmpty(String, String)
Asserts that the specified value is not null.
Declaration Syntax
C#
public static void IsNotNullOrEmpty(
    string value,
    string message
)
Parameters
value (String)
The value.
message (String)
The message.
Exceptions
Exception | Condition
InvalidOperationException | InvalidOperationException.


IsNotNullOrEmpty Method (value, format, args)

IsNotNullOrEmpty Method (value, format, args)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsNotNullOrEmpty(String, String, array<Object>[]()[])
Asserts that the specified string is not null or empty.
Declaration Syntax
C#
public static void IsNotNullOrEmpty(
    string value,
    string format,
    params Object[] args
)
Parameters
value (String)
The value.
format (String)
The format.
args (array< Object >[]()[])
The args.


IsNull Method

IsNull Method
Namespaces ► Sitecore.Diagnostics ► Assert ► IsNull()()()
Members
Icon | Member | Description
 | IsNull(Object, String) | Asserts that the specified value is null.
 | IsNull(Object, String, array<Object>[]()[]) | Asserts that the specified value is null.


IsNull Method (value, message)

IsNull Method (value, message)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsNull(Object, String)
Asserts that the specified value is null.
Declaration Syntax
C#
public static void IsNull(
    Object value,
    string message
)
Parameters
value (Object)
The value.
message (String)
The message.
Exceptions
Exception | Condition
InvalidOperationException | InvalidOperationException.


IsNull Method (value, format, args)

IsNull Method (value, format, args)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsNull(Object, String, array<Object>[]()[])
Asserts that the specified value is null.
Declaration Syntax
C#
public static void IsNull(
    Object value,
    string format,
    params Object[] args
)
Parameters
value (Object)
The value.
format (String)
The format.
args (array< Object >[]()[])
The arguments.


IsTrue Method

IsTrue Method
Namespaces ► Sitecore.Diagnostics ► Assert ► IsTrue()()()
Members
Icon | Member | Description
 | IsTrue(Boolean, String) | Determines whether the specified condition is true.
 | IsTrue(Boolean, Func<(Of <(String>)>)) | Determines whether the specified condition is true.
 | IsTrue(Boolean, String, array<Object>[]()[]) | Determines whether the specified condition is true.


IsTrue Method (condition, getMessage)

IsTrue Method (condition, getMessage)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsTrue(Boolean, Func<(Of <(String>)>))
Determines whether the specified condition is true.
Declaration Syntax
C#
public static void IsTrue(
    bool condition,
    Func<string> getMessage
)
Parameters
condition (Boolean)
if set to true th condition is true.
getMessage (Func<(Of <(String>)>))
The get message delegate.
Exceptions
Exception | Condition
InvalidOperationException | InvalidOperationException.


IsTrue Method (condition, message)

IsTrue Method (condition, message)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsTrue(Boolean, String)
Determines whether the specified condition is true.
Declaration Syntax
C#
public static void IsTrue(
    bool condition,
    string message
)
Parameters
condition (Boolean)
if set to true th condition is true.
message (String)
The message.
Exceptions
Exception | Condition
InvalidOperationException | InvalidOperationException.


IsTrue Method (condition, format, args)

IsTrue Method (condition, format, args)
Namespaces ► Sitecore.Diagnostics ► Assert ► IsTrue(Boolean, String, array<Object>[]()[])
Determines whether the specified condition is true.
Declaration Syntax
C#
public static void IsTrue(
    bool condition,
    string format,
    params Object[] args
)
Parameters
condition (Boolean)
if set to true the condition is true.
format (String)
The format.
args (array< Object >[]()[])
The arguments.


ReflectionObjectCreated Method (obj, typeName)

ReflectionObjectCreated Method (obj, typeName)
Namespaces ► Sitecore.Diagnostics ► Assert ► ReflectionObjectCreated(Object, String)
Asserts that the object is created.
Declaration Syntax
C#
public static void ReflectionObjectCreated(
    Object obj,
    string typeName
)
Parameters
obj (Object)
The object.
typeName (String)
Name of the type.
Exceptions
Exception | Condition
UnknownTypeException | The type could not be created.


Required Method

Required Method
Namespaces ► Sitecore.Diagnostics ► Assert ► Required()()()
Members
Icon | Member | Description
 | Required(Object, String) | Throws a RequiredObjectIsNullException if a specific condition is not met.
 | Required(Object, String, array<Object>[]()[]) | Throws a RequiredObjectIsNullException if a specific condition is not met.


Required Method (obj, message)

Required Method (obj, message)
Namespaces ► Sitecore.Diagnostics ► Assert ► Required(Object, String)
Throws a RequiredObjectIsNullException if a specific condition is not met.
Declaration Syntax
C#
public static void Required(
    Object obj,
    string message
)
Parameters
obj (Object)
The object.
message (String)
The message.
Exceptions
Exception | Condition
RequiredObjectIsNullException | RequiredObjectIsNullException.


Required Method (obj, format, args)

Required Method (obj, format, args)
Namespaces ► Sitecore.Diagnostics ► Assert ► Required(Object, String, array<Object>[]()[])
Throws a RequiredObjectIsNullException if a specific condition is not met.
Declaration Syntax
C#
public static void Required(
    Object obj,
    string format,
    params Object[] args
)
Parameters
obj (Object)
The object.
format (String)
The format.
args (array< Object >[]()[])
The arguments.


ResultNotNull Method

ResultNotNull Method
Namespaces ► Sitecore.Diagnostics ► Assert ► ResultNotNull()()()
Members
Icon | Member | Description
 | ResultNotNull<(Of <(T>)>)(T, String) | Results the not null.
 | ResultNotNull<(Of <(T>)>)(T) | Results the not null.


ResultNotNull Method (result)

ResultNotNull<(Of <(T>)>) Method (result)
Namespaces ► Sitecore.Diagnostics ► Assert ► ResultNotNull<(Of <(T>)>)(T)
Results the not null.
Declaration Syntax
C#
public static T ResultNotNull<T>(
    T result
)
where T : class
Generic Template Parameters
T
Parameters
result (T)
The result.
Return Value


ResultNotNull Method (result, message)

ResultNotNull<(Of <(T>)>) Method (result, message)
Namespaces ► Sitecore.Diagnostics ► Assert ► ResultNotNull<(Of <(T>)>)(T, String)
Results the not null.
Declaration Syntax
C#
public static T ResultNotNull<T>(
    T result,
    string message
)
where T : class
Generic Template Parameters
T
Parameters
result (T)
The result.
message (String)
Return Value


Audit Class

Audit Class
Namespaces ► Sitecore.Diagnostics ► Audit
Writes Audit information to a file.
Declaration Syntax
C#
public static class Audit
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Write(String, String) | Obsolete. Writes the specified action.
 | Write(String) | Obsolete. Writes an action to the audit log.
 | Write(String, Item) | Obsolete. Writes an action to the audit log.
 | Write(String, String, Item) | Obsolete. Write an action to the audit log.
Inheritance Hierarchy
Object
Audit


Write Method

Write Method
Namespaces ► Sitecore.Diagnostics ► Audit ► Write()()()
Members
Icon | Member | Description
 | Write(String, String) | Obsolete. Writes the specified action.
 | Write(String) | Obsolete. Writes an action to the audit log.
 | Write(String, Item) | Obsolete. Writes an action to the audit log.
 | Write(String, String, Item) | Obsolete. Write an action to the audit log.


Write Method (action)

Write Method (action)
Namespaces ► Sitecore.Diagnostics ► Audit ► Write(String)
Writes an action to the audit log.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Log.Audit instead.")]
public static void Write(
    string action
)
Parameters
action (String)
The action.


Write Method (action, item)

Write Method (action, item)
Namespaces ► Sitecore.Diagnostics ► Audit ► Write(String, Item)
Writes an action to the audit log.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Log.Audit instead.")]
public static void Write(
    string action,
    Item item
)
Parameters
action (String)
The action.
item (Item)
The item.


Write Method (action, data)

Write Method (action, data)
Namespaces ► Sitecore.Diagnostics ► Audit ► Write(String, String)
Writes the specified action.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Log.Audit instead.")]
public static void Write(
    string action,
    string data
)
Parameters
action (String)
The action.
data (String)
The data.


Write Method (action, data, item)

Write Method (action, data, item)
Namespaces ► Sitecore.Diagnostics ► Audit ► Write(String, String, Item)
Write an action to the audit log.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Log.Audit instead.")]
public static void Write(
    string action,
    string data,
    Item item
)
Parameters
action (String)
The action.
data (String)
The data.
item (Item)
The item.


AuditFormatter Class

AuditFormatter Class
Namespaces ► Sitecore.Diagnostics ► AuditFormatter
Declaration Syntax
C#
public static class AuditFormatter
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FormatField(Field) | Formats the field.
 | FormatItem(Item) | Formats the item.
Inheritance Hierarchy
Object
AuditFormatter


FormatField Method (field)

FormatField Method (field)
Namespaces ► Sitecore.Diagnostics ► AuditFormatter ► FormatField(Field)
Formats the field.
Declaration Syntax
C#
public static string FormatField(
    Field field
)
Parameters
field (Field)
The field.
Return Value
The field.


FormatItem Method (item)

FormatItem Method (item)
Namespaces ► Sitecore.Diagnostics ► AuditFormatter ► FormatItem(Item)
Formats the item.
Declaration Syntax
C#
public static string FormatItem(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The item.


AuditStorageProvider Class

AuditStorageProvider Class
Namespaces ► Sitecore.Diagnostics ► AuditStorageProvider
The abstract base class for audit storage providers.
Declaration Syntax
C#
public abstract class AuditStorageProvider
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AuditStorageProvider()()() | Initializes a new instance of the AuditStorageProvider class
 | AddAudit(String, String, String, String) | Adds auditing information to the audit log.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AuditStorageProvider


AuditStorageProvider Constructor

AuditStorageProvider Constructor
Namespaces ► Sitecore.Diagnostics ► AuditStorageProvider ► AuditStorageProvider()()()
Initializes a new instance of the AuditStorageProvider class
Declaration Syntax
C#
protected AuditStorageProvider()


AddAudit Method (category, action, entityId, domainId)

AddAudit Method (category, action, entityId, domainId)
Namespaces ► Sitecore.Diagnostics ► AuditStorageProvider ► AddAudit(String, String, String, String)
Adds auditing information to the audit log.
Declaration Syntax
C#
public abstract void AddAudit(
    string category,
    string action,
    string entityId,
    string domainId
)
Parameters
category (String)
The category.
action (String)
The action.
entityId (String)
The entity id.
domainId (String)
The domain id.


CallStack Class

CallStack Class
Namespaces ► Sitecore.Diagnostics ► CallStack
Represents the current call stack.
Declaration Syntax
C#
public class CallStack
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CallStack()()() | Initializes a new instance of the CallStack class
 | Count | Gets the count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the ID.
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Peek()()() | Peeks this instance.
 | Pop()()() | Pops this instance.
 | Push(ProfileEntry) | Pushes the specified entry.
 | Sequence | Gets the sequence.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CallStack


CallStack Constructor

CallStack Constructor
Namespaces ► Sitecore.Diagnostics ► CallStack ► CallStack()()()
Initializes a new instance of the CallStack class
Declaration Syntax
C#
public CallStack()


Count Property

Count Property
Namespaces ► Sitecore.Diagnostics ► CallStack ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


ID Property

ID Property
Namespaces ► Sitecore.Diagnostics ► CallStack ► ID
Gets the ID.
Declaration Syntax
C#
public string ID { get; }
Value
The ID.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Diagnostics ► CallStack ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


Peek Method

Peek Method
Namespaces ► Sitecore.Diagnostics ► CallStack ► Peek()()()
Peeks this instance.
Declaration Syntax
C#
public ProfileEntry Peek()
Return Value


Pop Method

Pop Method
Namespaces ► Sitecore.Diagnostics ► CallStack ► Pop()()()
Pops this instance.
Declaration Syntax
C#
public ProfileEntry Pop()
Return Value


Push Method (entry)

Push Method (entry)
Namespaces ► Sitecore.Diagnostics ► CallStack ► Push(ProfileEntry)
Pushes the specified entry.
Declaration Syntax
C#
public void Push(
    ProfileEntry entry
)
Parameters
entry (ProfileEntry)
The entry.


Sequence Property

Sequence Property
Namespaces ► Sitecore.Diagnostics ► CallStack ► Sequence
Gets the sequence.
Declaration Syntax
C#
public int Sequence { get; }
Value
The sequence.


Counter Class

Counter Class
Namespaces ► Sitecore.Diagnostics ► Counter
Represents a Counter.
Declaration Syntax
C#
[ObsoleteAttribute("Use the Sitecore.Diagnostics.PerformanceCounter class instead.",
    false)]
public static class Counter
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EndSession()()() | Ends the session.
 | GetReportFileName()()() | Gets the name of the report file.
 | GetValue(String) | Gets the value.
 | Increment(String) | Increments the specified counter name.
 | IsActive | Gets a value indicating whether this instance is active.
 | SaveReport()()() | Saves the report.
 | SaveReport(String) | Saves the report.
 | StartSession()()() | Starts the session.
Inheritance Hierarchy
Object
Counter


EndSession Method

EndSession Method
Namespaces ► Sitecore.Diagnostics ► Counter ► EndSession()()()
Ends the session.
Declaration Syntax
C#
public static void EndSession()


GetReportFileName Method

GetReportFileName Method
Namespaces ► Sitecore.Diagnostics ► Counter ► GetReportFileName()()()
Gets the name of the report file.
Declaration Syntax
C#
public static string GetReportFileName()
Return Value


GetValue Method (counterName)

GetValue Method (counterName)
Namespaces ► Sitecore.Diagnostics ► Counter ► GetValue(String)
Gets the value.
Declaration Syntax
C#
public static int GetValue(
    string counterName
)
Parameters
counterName (String)
Name of the counter.
Return Value


Increment Method (counterName)

Increment Method (counterName)
Namespaces ► Sitecore.Diagnostics ► Counter ► Increment(String)
Increments the specified counter name.
Declaration Syntax
C#
public static void Increment(
    string counterName
)
Parameters
counterName (String)
Name of the counter.


IsActive Property

IsActive Property
Namespaces ► Sitecore.Diagnostics ► Counter ► IsActive
Gets a value indicating whether this instance is active.
Declaration Syntax
C#
public static bool IsActive { get; }
Value
true if this instance is active; otherwise, false.


SaveReport Method

SaveReport Method
Namespaces ► Sitecore.Diagnostics ► Counter ► SaveReport()()()
Members
Icon | Member | Description
 | SaveReport()()() | Saves the report.
 | SaveReport(String) | Saves the report.


SaveReport Method

SaveReport Method
Namespaces ► Sitecore.Diagnostics ► Counter ► SaveReport()()()
Saves the report.
Declaration Syntax
C#
public static void SaveReport()


SaveReport Method (fileName)

SaveReport Method (fileName)
Namespaces ► Sitecore.Diagnostics ► Counter ► SaveReport(String)
Saves the report.
Declaration Syntax
C#
public static void SaveReport(
    string fileName
)
Parameters
fileName (String)
Name of the file.


StartSession Method

StartSession Method
Namespaces ► Sitecore.Diagnostics ► Counter ► StartSession()()()
Starts the session.
Declaration Syntax
C#
public static void StartSession()


Counter.Worker Class

Counter..::.Worker Class
Namespaces ► Sitecore.Diagnostics ► Counter ► Counter..::.Worker
Represents a Worker.
Declaration Syntax
C#
public class Worker : DiagnosticWorker
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Counter..::.Worker()()() | Initializes a new instance of the Counter..::.Worker class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportFileName()()() | Gets the name of the report file.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(String) | Gets the value.
 | Increment(String) | Increments the specified counter name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from DiagnosticWorker.)
 | Packet | Gets the packet. (Inherited from DiagnosticWorker.)
 | SaveReport(String) | Saves the report. (Overrides DiagnosticWorker.SaveReport(String).)
 | StartReport(String) | Starts the report. (Inherited from DiagnosticWorker.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DiagnosticWorker
 |  | Counter..::.Worker


Counter.Worker Constructor

Counter..::.Worker Constructor
Namespaces ► Sitecore.Diagnostics ► Counter..::.Worker ► Counter..::.Worker()()()
Initializes a new instance of the Counter..::.Worker class.
Declaration Syntax
C#
public Worker()


GetReportFileName Method

GetReportFileName Method
Namespaces ► Sitecore.Diagnostics ► Counter..::.Worker ► GetReportFileName()()()
Gets the name of the report file.
Declaration Syntax
C#
public static string GetReportFileName()
Return Value


GetValue Method (counterName)

GetValue Method (counterName)
Namespaces ► Sitecore.Diagnostics ► Counter..::.Worker ► GetValue(String)
Gets the value.
Declaration Syntax
C#
public int GetValue(
    string counterName
)
Parameters
counterName (String)
Name of the counter.
Return Value


Increment Method (counterName)

Increment Method (counterName)
Namespaces ► Sitecore.Diagnostics ► Counter..::.Worker ► Increment(String)
Increments the specified counter name.
Declaration Syntax
C#
public void Increment(
    string counterName
)
Parameters
counterName (String)
Name of the counter.


SaveReport Method (fileName)

SaveReport Method (fileName)
Namespaces ► Sitecore.Diagnostics ► Counter..::.Worker ► SaveReport(String)
Saves the report.
Declaration Syntax
C#
public override void SaveReport(
    string fileName
)
Parameters
fileName (String)
Name of the file.


CounterData Class

CounterData Class
Namespaces ► Sitecore.Diagnostics ► CounterData
Container for counters.
Declaration Syntax
C#
[ObsoleteAttribute("Use the Sitecore.Diagnostics.PerformanceCounters class framework instead.",
    false)]
public class CounterData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CounterData(String) | Constructor
 | Decrement()()() | Decrement counter
 | Decrement(Int32) | Decrement counter
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Increment()()() | Increment counter
 | Increment(Int32) | Increment counter
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Get name
 | Reset()()() | Reset counter
 | Set(Int32) | Set counter to a specific value
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Get value
Inheritance Hierarchy
Object
CounterData


CounterData Constructor (name)

CounterData Constructor (name)
Namespaces ► Sitecore.Diagnostics ► CounterData ► CounterData(String)
Constructor
Declaration Syntax
C#
public CounterData(
    string name
)
Parameters
name (String)
The name.


Decrement Method

Decrement Method
Namespaces ► Sitecore.Diagnostics ► CounterData ► Decrement()()()
Members
Icon | Member | Description
 | Decrement()()() | Decrement counter
 | Decrement(Int32) | Decrement counter


Decrement Method

Decrement Method
Namespaces ► Sitecore.Diagnostics ► CounterData ► Decrement()()()
Decrement counter
Declaration Syntax
C#
public int Decrement()
Return Value


Decrement Method (amount)

Decrement Method (amount)
Namespaces ► Sitecore.Diagnostics ► CounterData ► Decrement(Int32)
Decrement counter
Declaration Syntax
C#
public int Decrement(
    int amount
)
Parameters
amount (Int32)
The amount.
Return Value


Increment Method

Increment Method
Namespaces ► Sitecore.Diagnostics ► CounterData ► Increment()()()
Members
Icon | Member | Description
 | Increment()()() | Increment counter
 | Increment(Int32) | Increment counter


Increment Method

Increment Method
Namespaces ► Sitecore.Diagnostics ► CounterData ► Increment()()()
Increment counter
Declaration Syntax
C#
public int Increment()
Return Value


Increment Method (amount)

Increment Method (amount)
Namespaces ► Sitecore.Diagnostics ► CounterData ► Increment(Int32)
Increment counter
Declaration Syntax
C#
public int Increment(
    int amount
)
Parameters
amount (Int32)
The amount.
Return Value


Name Property

Name Property
Namespaces ► Sitecore.Diagnostics ► CounterData ► Name
Get name
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Reset Method

Reset Method
Namespaces ► Sitecore.Diagnostics ► CounterData ► Reset()()()
Reset counter
Declaration Syntax
C#
public int Reset()
Return Value


Set Method (value)

Set Method (value)
Namespaces ► Sitecore.Diagnostics ► CounterData ► Set(Int32)
Set counter to a specific value
Declaration Syntax
C#
public int Set(
    int value
)
Parameters
value (Int32)
The _value.
Return Value


Value Property

Value Property
Namespaces ► Sitecore.Diagnostics ► CounterData ► Value
Get value
Declaration Syntax
C#
public int Value { get; }
Value
The value.


CounterLock Class

CounterLock Class
Namespaces ► Sitecore.Diagnostics ► CounterLock
Lock that can be held by many threads simultaneously.
Declaration Syntax
C#
[ObsoleteAttribute("Use the Sitecore.Diagnostics.PerformanceCounters class framework instead.",
    false)]
public class CounterLock
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CounterLock()()() | Initializes a new instance of the CounterLock class
 | Count | Number of threads currently holding this lock info.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Lock | Lock object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CounterLock


CounterLock Constructor

CounterLock Constructor
Namespaces ► Sitecore.Diagnostics ► CounterLock ► CounterLock()()()
Initializes a new instance of the CounterLock class
Declaration Syntax
C#
public CounterLock()


Count Field

Count Field
Namespaces ► Sitecore.Diagnostics ► CounterLock ► Count
Number of threads currently holding this lock info.
Declaration Syntax
C#
public int Count


Lock Field

Lock Field
Namespaces ► Sitecore.Diagnostics ► CounterLock ► Lock
Lock object.
Declaration Syntax
C#
public Object Lock


Counters Class

Counters Class
Namespaces ► Sitecore.Diagnostics ► Counters
Container for counters.
Declaration Syntax
C#
[ObsoleteAttribute("Use the Sitecore.Diagnostics.PerformanceCounters class instead.",
    false)]
public static class Counters
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Count | Get number of counters
 | Decrement(String) | Decrement named counter
 | Decrement(String, Int32) | Decrement named counter
 | GetCounter(Int32) | Get counter from its name
 | GetCounter(String) | Get counter from its name
 | GetValue(String) | Get value of named counter
 | Increment(String) | Increment named counter
 | Increment(String, Int32) | Increment named counter
 | Reset(String) | Reset named counter
 | ResetAll()()() | Reset all counters
Inheritance Hierarchy
Object
Counters


Count Property

Count Property
Namespaces ► Sitecore.Diagnostics ► Counters ► Count
Get number of counters
Declaration Syntax
C#
public static int Count { get; }
Value
The count.


Decrement Method

Decrement Method
Namespaces ► Sitecore.Diagnostics ► Counters ► Decrement()()()
Members
Icon | Member | Description
 | Decrement(String) | Decrement named counter
 | Decrement(String, Int32) | Decrement named counter


Decrement Method (name)

Decrement Method (name)
Namespaces ► Sitecore.Diagnostics ► Counters ► Decrement(String)
Decrement named counter
Declaration Syntax
C#
public static int Decrement(
    string name
)
Parameters
name (String)
The name.
Return Value


Decrement Method (name, amount)

Decrement Method (name, amount)
Namespaces ► Sitecore.Diagnostics ► Counters ► Decrement(String, Int32)
Decrement named counter
Declaration Syntax
C#
public static int Decrement(
    string name,
    int amount
)
Parameters
name (String)
The name.
amount (Int32)
The decrement.
Return Value


GetCounter Method

GetCounter Method
Namespaces ► Sitecore.Diagnostics ► Counters ► GetCounter()()()
Members
Icon | Member | Description
 | GetCounter(Int32) | Get counter from its name
 | GetCounter(String) | Get counter from its name


GetCounter Method (index)

GetCounter Method (index)
Namespaces ► Sitecore.Diagnostics ► Counters ► GetCounter(Int32)
Get counter from its name
Declaration Syntax
C#
public static CounterData GetCounter(
    int index
)
Parameters
index (Int32)
The index.
Return Value


GetCounter Method (name)

GetCounter Method (name)
Namespaces ► Sitecore.Diagnostics ► Counters ► GetCounter(String)
Get counter from its name
Declaration Syntax
C#
public static CounterData GetCounter(
    string name
)
Parameters
name (String)
The name.
Return Value


GetValue Method (name)

GetValue Method (name)
Namespaces ► Sitecore.Diagnostics ► Counters ► GetValue(String)
Get value of named counter
Declaration Syntax
C#
public static int GetValue(
    string name
)
Parameters
name (String)
The name.
Return Value


Increment Method

Increment Method
Namespaces ► Sitecore.Diagnostics ► Counters ► Increment()()()
Members
Icon | Member | Description
 | Increment(String) | Increment named counter
 | Increment(String, Int32) | Increment named counter


Increment Method (name)

Increment Method (name)
Namespaces ► Sitecore.Diagnostics ► Counters ► Increment(String)
Increment named counter
Declaration Syntax
C#
public static int Increment(
    string name
)
Parameters
name (String)
The name.
Return Value


Increment Method (name, amount)

Increment Method (name, amount)
Namespaces ► Sitecore.Diagnostics ► Counters ► Increment(String, Int32)
Increment named counter
Declaration Syntax
C#
public static int Increment(
    string name,
    int amount
)
Parameters
name (String)
The name.
amount (Int32)
The increment.
Return Value


Reset Method (name)

Reset Method (name)
Namespaces ► Sitecore.Diagnostics ► Counters ► Reset(String)
Reset named counter
Declaration Syntax
C#
public static int Reset(
    string name
)
Parameters
name (String)
The name.
Return Value


ResetAll Method

ResetAll Method
Namespaces ► Sitecore.Diagnostics ► Counters ► ResetAll()()()
Reset all counters
Declaration Syntax
C#
public static void ResetAll()


CycleAsserter Class

CycleAsserter Class
Namespaces ► Sitecore.Diagnostics ► CycleAsserter
RecursionLimit class
Declaration Syntax
C#
public class CycleAsserter : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CycleAsserter(String, String) | Initializes a new instance of the RecursionLimit class.
 | Caller | Gets the caller.
 | Detail | Gets the detail (if any).
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CycleAsserter


CycleAsserter Constructor (caller, detail)

CycleAsserter Constructor (caller, detail)
Namespaces ► Sitecore.Diagnostics ► CycleAsserter ► CycleAsserter(String, String)
Initializes a new instance of the RecursionLimit class.
Declaration Syntax
C#
public CycleAsserter(
    string caller,
    string detail
)
Parameters
caller (String)
detail (String)


Caller Property

Caller Property
Namespaces ► Sitecore.Diagnostics ► CycleAsserter ► Caller
Gets the caller.
Declaration Syntax
C#
public string Caller { get; }
Value
The caller.


Detail Property

Detail Property
Namespaces ► Sitecore.Diagnostics ► CycleAsserter ► Detail
Gets the detail (if any).
Declaration Syntax
C#
public string Detail { get; }
Value
The detail.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Diagnostics ► CycleAsserter ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


CycleDetector Class

CycleDetector Class
Namespaces ► Sitecore.Diagnostics ► CycleDetector
RecursionLimit class
Declaration Syntax
C#
public class CycleDetector : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CycleDetector(String, String) | Initializes a new instance of the RecursionLimit class.
 | Caller | Gets the caller.
 | Detail | Gets the detail (if any).
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CycleDetector


CycleDetector Constructor (caller, detail)

CycleDetector Constructor (caller, detail)
Namespaces ► Sitecore.Diagnostics ► CycleDetector ► CycleDetector(String, String)
Initializes a new instance of the RecursionLimit class.
Declaration Syntax
C#
public CycleDetector(
    string caller,
    string detail
)
Parameters
caller (String)
detail (String)


Caller Property

Caller Property
Namespaces ► Sitecore.Diagnostics ► CycleDetector ► Caller
Gets the caller.
Declaration Syntax
C#
public string Caller { get; }
Value
The caller.


Detail Property

Detail Property
Namespaces ► Sitecore.Diagnostics ► CycleDetector ► Detail
Gets the detail (if any).
Declaration Syntax
C#
public string Detail { get; }
Value
The detail.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Diagnostics ► CycleDetector ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


Debug Class

Debug Class
Namespaces ► Sitecore.Diagnostics ► Debug
Debug class
Declaration Syntax
C#
public static class Debug
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ArgumentNotNull(Object, String) | Asserts that the arguments are not null.
 | ArgumentNotNullOrEmpty(String, String) | Asserts that the arguments are not null or empty.
 | Assert(Boolean, String) | Asserts a condition.
Inheritance Hierarchy
Object
Debug


ArgumentNotNull Method (argument, argumentName)

ArgumentNotNull Method (argument, argumentName)
Namespaces ► Sitecore.Diagnostics ► Debug ► ArgumentNotNull(Object, String)
Asserts that the arguments are not null.
Declaration Syntax
C#
public static void ArgumentNotNull(
    Object argument,
    string argumentName
)
Parameters
argument (Object)
The argument.
argumentName (String)
Name of the argument.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the argument is null.


ArgumentNotNullOrEmpty Method (argument, argumentName)

ArgumentNotNullOrEmpty Method (argument, argumentName)
Namespaces ► Sitecore.Diagnostics ► Debug ► ArgumentNotNullOrEmpty(String, String)
Asserts that the arguments are not null or empty.
Declaration Syntax
C#
public static void ArgumentNotNullOrEmpty(
    string argument,
    string argumentName
)
Parameters
argument (String)
The argument.
argumentName (String)
Name of the argument.


Assert Method (condition, errorMessage)

Assert Method (condition, errorMessage)
Namespaces ► Sitecore.Diagnostics ► Debug ► Assert(Boolean, String)
Asserts a condition.
Declaration Syntax
C#
public static void Assert(
    bool condition,
    string errorMessage
)
Parameters
condition (Boolean)
if set to true this instance is condition.
errorMessage (String)
The error message.
Remarks
Requires the preprocessor constant DEBUG
Exceptions
Exception | Condition
Exception | Exception.


DiagnosticContext Class

DiagnosticContext Class
Namespaces ► Sitecore.Diagnostics ► DiagnosticContext
Represents the current diagnostics context.
Declaration Syntax
C#
public class DiagnosticContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DiagnosticContext(Context..::.ContextData) | Initializes a new instance of the DiagnosticContext class.
 | CounterWorker | Obsolete. Gets or sets the counter worker.
 | Counting | Obsolete. Gets or sets a value indicating whether this DiagnosticContext is counting.
 | Debugging | Gets or sets a value indicating whether this DiagnosticContext is debugging.
 | DrawRenderingBorders | Gets or sets a value indicating whether the DiagnosticContext draws the rendering borders.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProfileWorker | Gets or sets the profile worker.
 | Profiling | Gets or sets a value indicating whether this DiagnosticContext is profiling.
 | ShowRenderingInfo | Gets or sets a value indicating whether the DiagnosticContext shows the rendering info.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TraceWorker | Gets or sets the trace worker.
 | Tracing | Gets or sets a value indicating whether this DiagnosticContext is tracing.
Inheritance Hierarchy
Object
DiagnosticContext


DiagnosticContext Constructor (context)

DiagnosticContext Constructor (context)
Namespaces ► Sitecore.Diagnostics ► DiagnosticContext ► DiagnosticContext(Context..::.ContextData)
Initializes a new instance of the DiagnosticContext class.
Declaration Syntax
C#
public DiagnosticContext(
    Context..::.ContextData context
)
Parameters
context (Context..::.ContextData)
The context.


CounterWorker Property

CounterWorker Property
Namespaces ► Sitecore.Diagnostics ► DiagnosticContext ► CounterWorker
Gets or sets the counter worker.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public Counter..::.Worker CounterWorker { get; set; }
Value
The counter worker.


Counting Property

Counting Property
Namespaces ► Sitecore.Diagnostics ► DiagnosticContext ► Counting
Gets or sets a value indicating whether this DiagnosticContext is counting.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public bool Counting { get; set; }
Value
true if counting; otherwise, false.


Debugging Property

Debugging Property
Namespaces ► Sitecore.Diagnostics ► DiagnosticContext ► Debugging
Gets or sets a value indicating whether this DiagnosticContext is debugging.
Declaration Syntax
C#
public bool Debugging { get; set; }
Value
true if debugging; otherwise, false.


DrawRenderingBorders Property

DrawRenderingBorders Property
Namespaces ► Sitecore.Diagnostics ► DiagnosticContext ► DrawRenderingBorders
Gets or sets a value indicating whether the DiagnosticContext draws the rendering borders.
Declaration Syntax
C#
public bool DrawRenderingBorders { get; set; }
Value
true if the DiagnosticContext draws the rendering borders; otherwise, false.


ProfileWorker Property

ProfileWorker Property
Namespaces ► Sitecore.Diagnostics ► DiagnosticContext ► ProfileWorker
Gets or sets the profile worker.
Declaration Syntax
C#
public Profiler..::.Worker ProfileWorker { get; set; }
Value
The profile worker.


Profiling Property

Profiling Property
Namespaces ► Sitecore.Diagnostics ► DiagnosticContext ► Profiling
Gets or sets a value indicating whether this DiagnosticContext is profiling.
Declaration Syntax
C#
public bool Profiling { get; set; }
Value
true if profiling; otherwise, false.


ShowRenderingInfo Property

ShowRenderingInfo Property
Namespaces ► Sitecore.Diagnostics ► DiagnosticContext ► ShowRenderingInfo
Gets or sets a value indicating whether the DiagnosticContext shows the rendering info.
Declaration Syntax
C#
public bool ShowRenderingInfo { get; set; }
Value
true if the DiagnosticContext shows the rendering info; otherwise, false.


TraceWorker Property

TraceWorker Property
Namespaces ► Sitecore.Diagnostics ► DiagnosticContext ► TraceWorker
Gets or sets the trace worker.
Declaration Syntax
C#
public Tracer..::.Worker TraceWorker { get; set; }
Value
The trace worker.


Tracing Property

Tracing Property
Namespaces ► Sitecore.Diagnostics ► DiagnosticContext ► Tracing
Gets or sets a value indicating whether this DiagnosticContext is tracing.
Declaration Syntax
C#
public bool Tracing { get; set; }
Value
true if tracing; otherwise, false.


DiagnosticWorker Class

DiagnosticWorker Class
Namespaces ► Sitecore.Diagnostics ► DiagnosticWorker
Represents a DiagnosticWorker.
Declaration Syntax
C#
public class DiagnosticWorker
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DiagnosticWorker(String) | Initializes a new instance of the DiagnosticWorker class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportFileName(String) | Gets the name of the report file.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Packet | Gets the packet.
 | SaveReport(String) | Saves the report.
 | StartReport(String) | Starts the report.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DiagnosticWorker
 |  | Counter..::.Worker
 |  | Profiler..::.Worker
 |  | Tracer..::.Worker


DiagnosticWorker Constructor (rootElementName)

DiagnosticWorker Constructor (rootElementName)
Namespaces ► Sitecore.Diagnostics ► DiagnosticWorker ► DiagnosticWorker(String)
Initializes a new instance of the DiagnosticWorker class.
Declaration Syntax
C#
public DiagnosticWorker(
    string rootElementName
)
Parameters
rootElementName (String)
Name of the root element.


GetReportFileName Method (name)

GetReportFileName Method (name)
Namespaces ► Sitecore.Diagnostics ► DiagnosticWorker ► GetReportFileName(String)
Gets the name of the report file.
Declaration Syntax
C#
public static string GetReportFileName(
    string name
)
Parameters
name (String)
The name.
Return Value


Name Property

Name Property
Namespaces ► Sitecore.Diagnostics ► DiagnosticWorker ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Packet Property

Packet Property
Namespaces ► Sitecore.Diagnostics ► DiagnosticWorker ► Packet
Gets the packet.
Declaration Syntax
C#
public Packet Packet { get; }
Value
The packet.


SaveReport Method (fileName)

SaveReport Method (fileName)
Namespaces ► Sitecore.Diagnostics ► DiagnosticWorker ► SaveReport(String)
Saves the report.
Declaration Syntax
C#
public virtual void SaveReport(
    string fileName
)
Parameters
fileName (String)
Name of the file.


StartReport Method (rootElementName)

StartReport Method (rootElementName)
Namespaces ► Sitecore.Diagnostics ► DiagnosticWorker ► StartReport(String)
Starts the report.
Declaration Syntax
C#
protected void StartReport(
    string rootElementName
)
Parameters
rootElementName (String)
Name of the root element.


DisposeHelper Class

DisposeHelper Class
Namespaces ► Sitecore.Diagnostics ► DisposeHelper
DisposeHelper
Declaration Syntax
C#
public class DisposeHelper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DisposeHelper(Boolean) | Initializes a new instance of the DisposeHelper class.
 | Disposed | Gets the disposed status.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DisposeHelper


DisposeHelper Constructor (threadSafe)

DisposeHelper Constructor (threadSafe)
Namespaces ► Sitecore.Diagnostics ► DisposeHelper ► DisposeHelper(Boolean)
Initializes a new instance of the DisposeHelper class.
Declaration Syntax
C#
public DisposeHelper(
    bool threadSafe
)
Parameters
threadSafe (Boolean)


Disposed Property

Disposed Property
Namespaces ► Sitecore.Diagnostics ► DisposeHelper ► Disposed
Gets the disposed status.
Declaration Syntax
C#
public bool Disposed { get; }
Value
The disposed.
Remarks
Beware that accessing this property will set it to true. It will only be false on the very first access.


Error Class

Error Class
Namespaces ► Sitecore.Diagnostics ► Error
Defines methods for error handling.
Declaration Syntax
C#
public sealed class Error
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Error()()() | Initializes a new instance of the Error class
 | Assert(Boolean, String) | Asserts the condition.
 | Assert(Boolean, String, String) | Asserts the condition.
 | AssertAccess(Boolean, String) | Asserts access.
 | AssertControl(Control, String) | Asserts the control.
 | AssertFile(String) | Asserts that the specified file exists.
 | AssertGuid(Guid, String, Boolean) | Assert that a guid is valid
 | AssertID(ID, String, Boolean) | Assert that an id is valid
 | AssertInt(Int32, String, Boolean, Boolean) | Assert that an integer is valid
 | AssertItem(Item, String) | Assert that a item is not null
 | AssertItemFound(Item) | Asserts the item found.
 | AssertItemFound(Item, String) | Asserts the item found.
 | AssertItemID(ID, String, Boolean) | Assert that a guid is valid
 | AssertLanguage(Language, String, Boolean) | Asserts the language.
 | AssertLicense(String, String) | Asserts that a certain license is valid.
 | AssertNotEqual(Object, Object, String) | Asserts the objects are not equal.
 | AssertNotNull(Object, String) | Asserts that the object is not null.
 | AssertNull(Object, String) | Asserts that the object is null.
 | AssertObject(Object, String) | Assert that an object reference is not null
 | AssertString(String, String, Boolean) | Assert that a string is valid
 | AssertTemplate(TemplateItem, String) | Asserts that a certain license is valid.
 | AssertVersion(Version, String, Boolean) | Asserts the version.
 | AssertXmlControl(XmlControl, String) | Asserts the XML control.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCaller(Int32) | Gets the caller.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LogError(String) | Logs an error message to all logs.
 | LogToEventLog(String) | Logs an error message to the Application. event log
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotSupported(String) | Raises an unsupported error.
 | Raise(String) | Raises the error.
 | Raise(String, String) | Raises the error
 | Raise(Exception, String) | Raises the error
 | RaiseNotImplemented()()() | Raises the "Not implemented" error.
 | RaiseNotSupported()()() | Raises the "Not supported" error.
 | RaiseThreadError(String) | Raises an error from action occurring in a worker thread.
 | ThreadAssert(Boolean, String) | Asserts from worker thread.
 | ThreadErrors | Get list of thread errors
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Warn(Boolean, String) | Dispatches a warning if some condition is true.
Inheritance Hierarchy
Object
Error


Error Constructor

Error Constructor
Namespaces ► Sitecore.Diagnostics ► Error ► Error()()()
Initializes a new instance of the Error class
Declaration Syntax
C#
public Error()


Assert Method

Assert Method
Namespaces ► Sitecore.Diagnostics ► Error ► Assert()()()
Members
Icon | Member | Description
 | Assert(Boolean, String) | Asserts the condition.
 | Assert(Boolean, String, String) | Asserts the condition.


Assert Method (condition, error)

Assert Method (condition, error)
Namespaces ► Sitecore.Diagnostics ► Error ► Assert(Boolean, String)
Asserts the condition.
Declaration Syntax
C#
public static void Assert(
    bool condition,
    string error
)
Parameters
condition (Boolean)
if set to true this condition is true.
error (String)
The error.


Assert Method (condition, error, method)

Assert Method (condition, error, method)
Namespaces ► Sitecore.Diagnostics ► Error ► Assert(Boolean, String, String)
Asserts the condition.
Declaration Syntax
C#
public static void Assert(
    bool condition,
    string error,
    string method
)
Parameters
condition (Boolean)
if set to true this condition is true.
error (String)
The error.
method (String)
The method.


AssertAccess Method (condition, operation)

AssertAccess Method (condition, operation)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertAccess(Boolean, String)
Asserts access.
Declaration Syntax
C#
public static void AssertAccess(
    bool condition,
    string operation
)
Parameters
condition (Boolean)
if set to true this condition is true.
operation (String)
The operation.


AssertControl Method (control, controlName)

AssertControl Method (control, controlName)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertControl(Control, String)
Asserts the control.
Declaration Syntax
C#
public static void AssertControl(
    Control control,
    string controlName
)
Parameters
control (Control)
The control.
controlName (String)
Name of the control.


AssertFile Method (fileName)

AssertFile Method (fileName)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertFile(String)
Asserts that the specified file exists.
Declaration Syntax
C#
public static void AssertFile(
    string fileName
)
Parameters
fileName (String)
Name of the file.


AssertGuid Method (argument, name, allowNullGuid)

AssertGuid Method (argument, name, allowNullGuid)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertGuid(Guid, String, Boolean)
Assert that a guid is valid
Declaration Syntax
C#
public static void AssertGuid(
    Guid argument,
    string name,
    bool allowNullGuid
)
Parameters
argument (Guid)
The argument.
name (String)
The name.
allowNullGuid (Boolean)
if set to true this instance is allow null GUID.


AssertID Method (argument, name, allowNullID)

AssertID Method (argument, name, allowNullID)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertID(ID, String, Boolean)
Assert that an id is valid
Declaration Syntax
C#
public static void AssertID(
    ID argument,
    string name,
    bool allowNullID
)
Parameters
argument (ID)
The argument.
name (String)
The name.
allowNullID (Boolean)
if set to true this instance is allow null ID.


AssertInt Method (argument, name, allowZero, allowNegative)

AssertInt Method (argument, name, allowZero, allowNegative)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertInt(Int32, String, Boolean, Boolean)
Assert that an integer is valid
Declaration Syntax
C#
public static void AssertInt(
    int argument,
    string name,
    bool allowZero,
    bool allowNegative
)
Parameters
argument (Int32)
The argument.
name (String)
The name.
allowZero (Boolean)
if set to true this instance is allow zero.
allowNegative (Boolean)
if set to true this instance is allow negative.


AssertItem Method (item, path)

AssertItem Method (item, path)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertItem(Item, String)
Assert that a item is not null
Declaration Syntax
C#
public static void AssertItem(
    Item item,
    string path
)
Parameters
item (Item)
The item.
path (String)
The path.


AssertItemFound Method

AssertItemFound Method
Namespaces ► Sitecore.Diagnostics ► Error ► AssertItemFound()()()
Members
Icon | Member | Description
 | AssertItemFound(Item) | Asserts the item found.
 | AssertItemFound(Item, String) | Asserts the item found.


AssertItemFound Method (item)

AssertItemFound Method (item)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertItemFound(Item)
Asserts the item found.
Declaration Syntax
C#
public static void AssertItemFound(
    Item item
)
Parameters
item (Item)
The item.
Exceptions
Exception | Condition
ItemNotFoundException | Item not found.


AssertItemFound Method (item, path)

AssertItemFound Method (item, path)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertItemFound(Item, String)
Asserts the item found.
Declaration Syntax
C#
public static void AssertItemFound(
    Item item,
    string path
)
Parameters
item (Item)
The item.
path (String)
The path.
Exceptions
Exception | Condition
ItemNotFoundException | Item not found.


AssertItemID Method (argument, name, allowNullGuid)

AssertItemID Method (argument, name, allowNullGuid)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertItemID(ID, String, Boolean)
Assert that a guid is valid
Declaration Syntax
C#
public static void AssertItemID(
    ID argument,
    string name,
    bool allowNullGuid
)
Parameters
argument (ID)
The argument.
name (String)
The name.
allowNullGuid (Boolean)
if set to true this instance is allow null GUID.


AssertLanguage Method (argument, name, allowAny)

AssertLanguage Method (argument, name, allowAny)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertLanguage(Language, String, Boolean)
Asserts the language.
Declaration Syntax
C#
public static void AssertLanguage(
    Language argument,
    string name,
    bool allowAny
)
Parameters
argument (Language)
The argument.
name (String)
The name.
allowAny (Boolean)
if set to true this instance is allow any.


AssertLicense Method (module, description)

AssertLicense Method (module, description)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertLicense(String, String)
Asserts that a certain license is valid.
Declaration Syntax
C#
public static void AssertLicense(
    string module,
    string description
)
Parameters
module (String)
The module.
description (String)
The description.


AssertNotEqual Method (obj1, obj2, message)

AssertNotEqual Method (obj1, obj2, message)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertNotEqual(Object, Object, String)
Asserts the objects are not equal.
Declaration Syntax
C#
public static void AssertNotEqual(
    Object obj1,
    Object obj2,
    string message
)
Parameters
obj1 (Object)
The obj1.
obj2 (Object)
The obj2.
message (String)
The message.


AssertNotNull Method (obj, message)

AssertNotNull Method (obj, message)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertNotNull(Object, String)
Asserts that the object is not null.
Declaration Syntax
C#
public static void AssertNotNull(
    Object obj,
    string message
)
Parameters
obj (Object)
The object.
message (String)
The message.


AssertNull Method (obj, message)

AssertNull Method (obj, message)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertNull(Object, String)
Asserts that the object is null.
Declaration Syntax
C#
public static void AssertNull(
    Object obj,
    string message
)
Parameters
obj (Object)
The object.
message (String)
The message.


AssertObject Method (argument, name)

AssertObject Method (argument, name)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertObject(Object, String)
Assert that an object reference is not null
Declaration Syntax
C#
public static void AssertObject(
    Object argument,
    string name
)
Parameters
argument (Object)
The argument.
name (String)
The name.


AssertString Method (argument, name, allowEmpty)

AssertString Method (argument, name, allowEmpty)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertString(String, String, Boolean)
Assert that a string is valid
Declaration Syntax
C#
public static void AssertString(
    string argument,
    string name,
    bool allowEmpty
)
Parameters
argument (String)
The argument.
name (String)
The name.
allowEmpty (Boolean)
if set to true this instance is allow empty.


AssertTemplate Method (template, name)

AssertTemplate Method (template, name)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertTemplate(TemplateItem, String)
Asserts that a certain license is valid.
Declaration Syntax
C#
public static void AssertTemplate(
    TemplateItem template,
    string name
)
Parameters
template (TemplateItem)
The template.
name (String)
The name.


AssertVersion Method (argument, name, allowUndefined)

AssertVersion Method (argument, name, allowUndefined)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertVersion(Version, String, Boolean)
Asserts the version.
Declaration Syntax
C#
public static void AssertVersion(
    Version argument,
    string name,
    bool allowUndefined
)
Parameters
argument (Version)
The argument.
name (String)
The name.
allowUndefined (Boolean)
if set to true this instance is allow undefined.


AssertXmlControl Method (control, controlName)

AssertXmlControl Method (control, controlName)
Namespaces ► Sitecore.Diagnostics ► Error ► AssertXmlControl(XmlControl, String)
Asserts the XML control.
Declaration Syntax
C#
public static void AssertXmlControl(
    XmlControl control,
    string controlName
)
Parameters
control (XmlControl)
The control.
controlName (String)
Name of the control.


GetCaller Method (indexInStack)

GetCaller Method (indexInStack)
Namespaces ► Sitecore.Diagnostics ► Error ► GetCaller(Int32)
Gets the caller.
Declaration Syntax
C#
public static string GetCaller(
    int indexInStack
)
Parameters
indexInStack (Int32)
The index in stack.
Return Value


LogError Method (error)

LogError Method (error)
Namespaces ► Sitecore.Diagnostics ► Error ► LogError(String)
Logs an error message to all logs.
Declaration Syntax
C#
public static void LogError(
    string error
)
Parameters
error (String)
The error.


LogToEventLog Method (sError)

LogToEventLog Method (sError)
Namespaces ► Sitecore.Diagnostics ► Error ► LogToEventLog(String)
Logs an error message to the Application. event log
Declaration Syntax
C#
public static void LogToEventLog(
    string sError
)
Parameters
sError (String)
The s error.


NotSupported Method (error)

NotSupported Method (error)
Namespaces ► Sitecore.Diagnostics ► Error ► NotSupported(String)
Raises an unsupported error.
Declaration Syntax
C#
public static void NotSupported(
    string error
)
Parameters
error (String)
The error.


Raise Method

Raise Method
Namespaces ► Sitecore.Diagnostics ► Error ► Raise()()()
Members
Icon | Member | Description
 | Raise(String) | Raises the error.
 | Raise(String, String) | Raises the error
 | Raise(Exception, String) | Raises the error


Raise Method (exception, method)

Raise Method (exception, method)
Namespaces ► Sitecore.Diagnostics ► Error ► Raise(Exception, String)
Raises the error
Declaration Syntax
C#
public static void Raise(
    Exception exception,
    string method
)
Parameters
exception (Exception)
The exception.
method (String)
The method.


Raise Method (error)

Raise Method (error)
Namespaces ► Sitecore.Diagnostics ► Error ► Raise(String)
Raises the error.
Declaration Syntax
C#
public static void Raise(
    string error
)
Parameters
error (String)
The error.


Raise Method (error, method)

Raise Method (error, method)
Namespaces ► Sitecore.Diagnostics ► Error ► Raise(String, String)
Raises the error
Declaration Syntax
C#
public static void Raise(
    string error,
    string method
)
Parameters
error (String)
The error.
method (String)
The method.


RaiseNotImplemented Method

RaiseNotImplemented Method
Namespaces ► Sitecore.Diagnostics ► Error ► RaiseNotImplemented()()()
Raises the "Not implemented" error.
Declaration Syntax
C#
public static void RaiseNotImplemented()


RaiseNotSupported Method

RaiseNotSupported Method
Namespaces ► Sitecore.Diagnostics ► Error ► RaiseNotSupported()()()
Raises the "Not supported" error.
Declaration Syntax
C#
public static void RaiseNotSupported()


RaiseThreadError Method (error)

RaiseThreadError Method (error)
Namespaces ► Sitecore.Diagnostics ► Error ► RaiseThreadError(String)
Raises an error from action occurring in a worker thread.
Declaration Syntax
C#
public static void RaiseThreadError(
    string error
)
Parameters
error (String)
The error.


ThreadAssert Method (condition, error)

ThreadAssert Method (condition, error)
Namespaces ► Sitecore.Diagnostics ► Error ► ThreadAssert(Boolean, String)
Asserts from worker thread.
Declaration Syntax
C#
public static void ThreadAssert(
    bool condition,
    string error
)
Parameters
condition (Boolean)
if set to true this instance is condition.
error (String)
The error.


ThreadErrors Property

ThreadErrors Property
Namespaces ► Sitecore.Diagnostics ► Error ► ThreadErrors
Get list of thread errors
Declaration Syntax
C#
public static ArrayList ThreadErrors { get; }
Value
The thread errors.


Warn Method (condition, warning)

Warn Method (condition, warning)
Namespaces ► Sitecore.Diagnostics ► Error ► Warn(Boolean, String)
Dispatches a warning if some condition is true.
Declaration Syntax
C#
public static void Warn(
    bool condition,
    string warning
)
Parameters
condition (Boolean)
if set to true this instance is condition.
warning (String)
The warning.


EventDispatcher Class

EventDispatcher Class
Namespaces ► Sitecore.Diagnostics ► EventDispatcher
Class for dispatching events.
Declaration Syntax
C#
public static class EventDispatcher
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Debug(String, array<Object>[]()[]) | Dispatch a debug event
 | DispatchBeforeClientSave(XmlNode) | Dispatch a 'before client save' event
 | DispatchError(String, array<Object>[]()[]) | Dispatch an error event
 | DispatchEvent(String, array<Object>[]()[]) | Dispatch a generic event
 | DispatchException(Exception) | Dispatch an exception event
 | DispatchItemCopied(Item, Item) | Dispatch a 'item copied' event
 | DispatchItemCreated(Item) | Dispatch a 'item created' event
 | DispatchItemDeleted(Item, Item) | Dispatch a 'item deleted' event
 | DispatchItemMoved(Item, Item) | Dispatch a 'item moved' event
 | DispatchItemRenamed(Item, String) | Dispatch a 'item renamed' event
 | DispatchItemSaved(Item) | Dispatch a 'item saved' event
 | DispatchMediaUploaded(Item) | Dispatch a 'media uploaded' event
 | DispatchPublishDone(IPublishingRequest) | Dispatch a 'published file' event
 | DispatchTrace(String, array<Object>[]()[]) | Dispatch a trace event
 | DispatchWarning(String, array<Object>[]()[]) | Dispatch a warning event
 | Error(String, array<Object>[]()[]) | Dispatch an error event
 | Trace(String, array<Object>[]()[]) | Dispatch a trace event
 | Warn(String, array<Object>[]()[]) | Dispatch a warning event
Inheritance Hierarchy
Object
EventDispatcher


Debug Method (message, additionalInfo)

Debug Method (message, additionalInfo)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► Debug(String, array<Object>[]()[])
Dispatch a debug event
Declaration Syntax
C#
public static void Debug(
    string message,
    params Object[] additionalInfo
)
Parameters
message (String)
The message.
additionalInfo (array< Object >[]()[])
The additional info.


DispatchBeforeClientSave Method (dataNode)

DispatchBeforeClientSave Method (dataNode)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► DispatchBeforeClientSave(XmlNode)
Dispatch a 'before client save' event
Declaration Syntax
C#
public static void DispatchBeforeClientSave(
    XmlNode dataNode
)
Parameters
dataNode (XmlNode)
The data node.


DispatchError Method (message, additionalInfo)

DispatchError Method (message, additionalInfo)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► DispatchError(String, array<Object>[]()[])
Dispatch an error event
Declaration Syntax
C#
public static void DispatchError(
    string message,
    params Object[] additionalInfo
)
Parameters
message (String)
The message.
additionalInfo (array< Object >[]()[])
The additional info.


DispatchEvent Method (name, additionalInfo)

DispatchEvent Method (name, additionalInfo)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► DispatchEvent(String, array<Object>[]()[])
Dispatch a generic event
Declaration Syntax
C#
public static void DispatchEvent(
    string name,
    params Object[] additionalInfo
)
Parameters
name (String)
The name.
additionalInfo (array< Object >[]()[])
The additional info.


DispatchException Method (ex)

DispatchException Method (ex)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► DispatchException(Exception)
Dispatch an exception event
Declaration Syntax
C#
public static void DispatchException(
    Exception ex
)
Parameters
ex (Exception)
The ex.


DispatchItemCopied Method (itm, source)

DispatchItemCopied Method (itm, source)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► DispatchItemCopied(Item, Item)
Dispatch a 'item copied' event
Declaration Syntax
C#
public static void DispatchItemCopied(
    Item itm,
    Item source
)
Parameters
itm (Item)
The itm.
source (Item)
The source.


DispatchItemCreated Method (itm)

DispatchItemCreated Method (itm)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► DispatchItemCreated(Item)
Dispatch a 'item created' event
Declaration Syntax
C#
public static void DispatchItemCreated(
    Item itm
)
Parameters
itm (Item)
The itm.


DispatchItemDeleted Method (itm, oldParent)

DispatchItemDeleted Method (itm, oldParent)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► DispatchItemDeleted(Item, Item)
Dispatch a 'item deleted' event
Declaration Syntax
C#
public static void DispatchItemDeleted(
    Item itm,
    Item oldParent
)
Parameters
itm (Item)
The itm.
oldParent (Item)
The old parent.


DispatchItemMoved Method (itm, oldParent)

DispatchItemMoved Method (itm, oldParent)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► DispatchItemMoved(Item, Item)
Dispatch a 'item moved' event
Declaration Syntax
C#
public static void DispatchItemMoved(
    Item itm,
    Item oldParent
)
Parameters
itm (Item)
The itm.
oldParent (Item)
The old parent.


DispatchItemRenamed Method (itm, oldName)

DispatchItemRenamed Method (itm, oldName)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► DispatchItemRenamed(Item, String)
Dispatch a 'item renamed' event
Declaration Syntax
C#
public static void DispatchItemRenamed(
    Item itm,
    string oldName
)
Parameters
itm (Item)
The itm.
oldName (String)
The old name.


DispatchItemSaved Method (itm)

DispatchItemSaved Method (itm)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► DispatchItemSaved(Item)
Dispatch a 'item saved' event
Declaration Syntax
C#
public static void DispatchItemSaved(
    Item itm
)
Parameters
itm (Item)
The itm.


DispatchMediaUploaded Method (itm)

DispatchMediaUploaded Method (itm)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► DispatchMediaUploaded(Item)
Dispatch a 'media uploaded' event
Declaration Syntax
C#
public static void DispatchMediaUploaded(
    Item itm
)
Parameters
itm (Item)
The itm.


DispatchPublishDone Method (request)

DispatchPublishDone Method (request)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► DispatchPublishDone(IPublishingRequest)
Dispatch a 'published file' event
Declaration Syntax
C#
public static void DispatchPublishDone(
    IPublishingRequest request
)
Parameters
request (IPublishingRequest)
The request.


DispatchTrace Method (message, additionalInfo)

DispatchTrace Method (message, additionalInfo)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► DispatchTrace(String, array<Object>[]()[])
Dispatch a trace event
Declaration Syntax
C#
public static void DispatchTrace(
    string message,
    params Object[] additionalInfo
)
Parameters
message (String)
The message.
additionalInfo (array< Object >[]()[])
The additional info.


DispatchWarning Method (message, additionalInfo)

DispatchWarning Method (message, additionalInfo)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► DispatchWarning(String, array<Object>[]()[])
Dispatch a warning event
Declaration Syntax
C#
public static void DispatchWarning(
    string message,
    params Object[] additionalInfo
)
Parameters
message (String)
The message.
additionalInfo (array< Object >[]()[])
The additional info.


Error Method (message, additionalInfo)

Error Method (message, additionalInfo)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► Error(String, array<Object>[]()[])
Dispatch an error event
Declaration Syntax
C#
public static void Error(
    string message,
    params Object[] additionalInfo
)
Parameters
message (String)
The message.
additionalInfo (array< Object >[]()[])
The additional info.


Trace Method (message, additionalInfo)

Trace Method (message, additionalInfo)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► Trace(String, array<Object>[]()[])
Dispatch a trace event
Declaration Syntax
C#
public static void Trace(
    string message,
    params Object[] additionalInfo
)
Parameters
message (String)
The message.
additionalInfo (array< Object >[]()[])
The additional info.


Warn Method (message, additionalInfo)

Warn Method (message, additionalInfo)
Namespaces ► Sitecore.Diagnostics ► EventDispatcher ► Warn(String, array<Object>[]()[])
Dispatch a warning event
Declaration Syntax
C#
public static void Warn(
    string message,
    params Object[] additionalInfo
)
Parameters
message (String)
The message.
additionalInfo (array< Object >[]()[])
The additional info.


FailureReason Enumeration

FailureReason Enumeration
Namespaces ► Sitecore.Diagnostics ► FailureReason
FailureReason
Declaration Syntax
C#
public enum FailureReason
Members
Member | Description
None | No failure has occurred.
AccessDenied | Access to a ressource was denied.
ItemNotFound | An item was not found.


HealthMonitorHook Class

HealthMonitorHook Class
Namespaces ► Sitecore.Diagnostics ► HealthMonitorHook
Implements a hook for the health monitor
Declaration Syntax
C#
public class HealthMonitorHook : IHook
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HealthMonitorHook()()() | Initializes a new instance of the HealthMonitorHook class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HealthMonitorHook


HealthMonitorHook Constructor

HealthMonitorHook Constructor
Namespaces ► Sitecore.Diagnostics ► HealthMonitorHook ► HealthMonitorHook()()()
Initializes a new instance of the HealthMonitorHook class
Declaration Syntax
C#
public HealthMonitorHook()


Initialize Method

Initialize Method
Namespaces ► Sitecore.Diagnostics ► HealthMonitorHook ► Initialize()()()
Initializes this instance.
Declaration Syntax
C#
public void Initialize()


HighResTimer Class

HighResTimer Class
Namespaces ► Sitecore.Diagnostics ► HighResTimer
Implements a class that encapsulates the operating system high resolution timer using native API functions.
Declaration Syntax
C#
public class HighResTimer
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HighResTimer()()() | Initializes a new instance of the HighResTimer class.
 | HighResTimer(Boolean) | Initializes a new instance of the HighResTimer class.
 | Elapsed()()() | Gets the number of milliseconds that has elapsed since the timer was started.
 | ElapsedTimeSpan | Gets the elapsed time as a TimeSpan.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Frequency | Gets the frequency.
 | GetElapsed()()() | Gets the number of milliseconds that has elapsed since the timer was started.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMillisecondsBetween(Int64, Int64) | Gets the milliseconds between.
 | GetMillisecondsSince(Int64) | Gets the milliseconds since.
 | GetTick()()() | Gets the tick.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Pause()()() | Pauses this instance.
 | QueryTimer()()() | Queries the timer.
 | Resume()()() | Resumes a stopped timer.
 | SecondsElapsed()()() | Gets the number of seconds that has elapsed since the timer was started.
 | Start()()() | Starts the timer.
 | Stop()()() | Stops the timer.
 | Supported()()() | Checks if timers is supported by the operating system.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

This class is usually used for profiling.

The class uses the API functions QueryPerformanceCounter and QueryPerformanceFrequency.

Inheritance Hierarchy
Object
HighResTimer


HighResTimer Constructor

HighResTimer Constructor
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► HighResTimer()()()
Members
Icon | Member | Description
 | HighResTimer()()() | Initializes a new instance of the HighResTimer class.
 | HighResTimer(Boolean) | Initializes a new instance of the HighResTimer class.


HighResTimer Constructor

HighResTimer Constructor
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► HighResTimer()()()
Initializes a new instance of the HighResTimer class.
Declaration Syntax
C#
public HighResTimer()
Remarks
The timer is not started automatically.
Examples
CopyC#
HighResTimer timer = new HighResTimer();
timer.Start();
timer.Stop();
double ms = timer.Elapsed();


HighResTimer Constructor (bAutoStart)

HighResTimer Constructor (bAutoStart)
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► HighResTimer(Boolean)
Initializes a new instance of the HighResTimer class.
Declaration Syntax
C#
public HighResTimer(
    bool bAutoStart
)
Parameters
bAutoStart (Boolean)
A boolean indicating if the timer should be started.
Examples
CopyC#
HighResTimer timer = new HighResTimer(true);
timer.Stop();
double ms = timer.Elapsed();


Elapsed Method

Elapsed Method
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► Elapsed()()()
Gets the number of milliseconds that has elapsed since the timer was started.
Declaration Syntax
C#
public double Elapsed()
Return Value
Number of milliseconds since the timer was started.
Remarks
Stops the timer.
Examples
CopyC#
HighResTimer timer = new HighResTimer(true);
timer.Stop();
double ms = timer.Elapsed();
See Also
Start()()()


ElapsedTimeSpan Property

ElapsedTimeSpan Property
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► ElapsedTimeSpan
Gets the elapsed time as a TimeSpan.
Declaration Syntax
C#
public TimeSpan ElapsedTimeSpan { get; }
Value
The elapsed time span.


Frequency Property

Frequency Property
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► Frequency
Gets the frequency.
Declaration Syntax
C#
public static long Frequency { get; }
Value
The frequency.


GetElapsed Method

GetElapsed Method
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► GetElapsed()()()
Gets the number of milliseconds that has elapsed since the timer was started.
Declaration Syntax
C#
public double GetElapsed()
Return Value
Number of milliseconds since the timer was started.
Remarks
Does not stop the timer.
Examples
CopyC#
HighResTimer timer = new HighResTimer(true);
double ms = timer.GetElapsed();
See Also
Start()()()


GetMillisecondsBetween Method (startTick, endTick)

GetMillisecondsBetween Method (startTick, endTick)
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► GetMillisecondsBetween(Int64, Int64)
Gets the milliseconds between.
Declaration Syntax
C#
public static double GetMillisecondsBetween(
    long startTick,
    long endTick
)
Parameters
startTick (Int64)
The start tick.
endTick (Int64)
The end tick.
Return Value


GetMillisecondsSince Method (tick)

GetMillisecondsSince Method (tick)
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► GetMillisecondsSince(Int64)
Gets the milliseconds since.
Declaration Syntax
C#
public static double GetMillisecondsSince(
    long tick
)
Parameters
tick (Int64)
The tick.
Return Value


GetTick Method

GetTick Method
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► GetTick()()()
Gets the tick.
Declaration Syntax
C#
public static long GetTick()
Return Value


Pause Method

Pause Method
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► Pause()()()
Pauses this instance.
Declaration Syntax
C#
public void Pause()


QueryTimer Method

QueryTimer Method
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► QueryTimer()()()
Queries the timer.
Declaration Syntax
C#
public double QueryTimer()
Return Value
Returns 1.0 divided by the timer frequency.


Resume Method

Resume Method
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► Resume()()()
Resumes a stopped timer.
Declaration Syntax
C#
public void Resume()
Examples
CopyC#
HighResTimer timer = new HighResTimer(true);
timer.Stop();
timer.Resume();
timer.Stop();
double ms = timer.Elapsed();
See Also
Start()()()


SecondsElapsed Method

SecondsElapsed Method
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► SecondsElapsed()()()
Gets the number of seconds that has elapsed since the timer was started.
Declaration Syntax
C#
public double SecondsElapsed()
Return Value
Number of seconds since the timer was started.
Examples
CopyC#
HighResTimer timer = new HighResTimer(true);
timer.Stop();
double seconds = timer.SecondsElapsed();
See Also
Start()()()


Start Method

Start Method
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► Start()()()
Starts the timer.
Declaration Syntax
C#
public void Start()
Examples
CopyC#
HighResTimer timer = new HighResTimer();
timer.Start();
timer.Stop();
double ms = timer.Elapsed();
See Also
Stop()()()


Stop Method

Stop Method
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► Stop()()()
Stops the timer.
Declaration Syntax
C#
public void Stop()
Examples
CopyC#
HighResTimer timer = new HighResTimer();
timer.Start();
timer.Stop();
double ms = timer.Elapsed();
See Also
Start()()()


Supported Method

Supported Method
Namespaces ► Sitecore.Diagnostics ► HighResTimer ► Supported()()()
Checks if timers is supported by the operating system.
Declaration Syntax
C#
public bool Supported()
Return Value
True, if the operating system supports timers, otherwise false.
Examples
CopyC#
HighResTimer timer = new HighResTimer(false);
if (timer.Supported()) {
timerStart();
timer.Stop();
double seconds = timer.Elapsed();
}
See Also
Start()()()


Log Class

Log Class
Namespaces ► Sitecore.Diagnostics ► Log
Represents the Log.
Declaration Syntax
C#
public static class Log
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Audit(String, Object) | Infoes the specified message.
 | Audit(String, Type) | Audits the specified message.
 | Audit(Type, String, array<String>[]()[]) | Audits the specified owner type.
 | Audit(Object, String, array<String>[]()[]) | Audits the specified owner type.
 | Debug(String, Object) | Debugs the specified message.
 | Debug(String) | Debugs the specified message.
 | Enabled | Gets a value indicating whether this Log is enabled.
 | Error(String, Object) | Errors the specified message.
 | Error(String, Exception, Object) | Errors the specified message.
 | Error(String, Type) | Errors the specified message.
 | Error(String, Exception, Type) | Errors the specified message.
 | Fatal(String, Object) | Fatals the specified message.
 | Fatal(String, Type) | Fatals the specified message.
 | Fatal(String, Exception, Object) | Fatals the specified message.
 | Fatal(String, Exception, Type) | Fatals the specified message.
 | Info(String, Object) | Infoes the specified message.
 | SingleError(String, Object) | Logs a single error.
 | SingleFatal(String, Exception, Object) | Logs a single fatal message.
 | SingleFatal(String, Exception, Type) | Logs a single fatal message.
 | Warn(String, Object) | Warns the specified message.
 | Warn(String, Exception, Object) | Warns the specified message.
Inheritance Hierarchy
Object
Log


Audit Method

Audit Method
Namespaces ► Sitecore.Diagnostics ► Log ► Audit()()()
Members
Icon | Member | Description
 | Audit(String, Object) | Infoes the specified message.
 | Audit(String, Type) | Audits the specified message.
 | Audit(Type, String, array<String>[]()[]) | Audits the specified owner type.
 | Audit(Object, String, array<String>[]()[]) | Audits the specified owner type.


Audit Method (owner, format, parameters)

Audit Method (owner, format, parameters)
Namespaces ► Sitecore.Diagnostics ► Log ► Audit(Object, String, array<String>[]()[])
Audits the specified owner type.
Declaration Syntax
C#
public static void Audit(
    Object owner,
    string format,
    params string[] parameters
)
Parameters
owner (Object)
The owner.
format (String)
The format.
parameters (array< String >[]()[])
The parameters.


Audit Method (message, owner)

Audit Method (message, owner)
Namespaces ► Sitecore.Diagnostics ► Log ► Audit(String, Object)
Infoes the specified message.
Declaration Syntax
C#
public static void Audit(
    string message,
    Object owner
)
Parameters
message (String)
The message.
owner (Object)
The owner.


Audit Method (message, ownerType)

Audit Method (message, ownerType)
Namespaces ► Sitecore.Diagnostics ► Log ► Audit(String, Type)
Audits the specified message.
Declaration Syntax
C#
public static void Audit(
    string message,
    Type ownerType
)
Parameters
message (String)
The message.
ownerType (Type)
Type of the owner.


Audit Method (ownerType, format, parameters)

Audit Method (ownerType, format, parameters)
Namespaces ► Sitecore.Diagnostics ► Log ► Audit(Type, String, array<String>[]()[])
Audits the specified owner type.
Declaration Syntax
C#
public static void Audit(
    Type ownerType,
    string format,
    params string[] parameters
)
Parameters
ownerType (Type)
Type of the owner.
format (String)
The format.
parameters (array< String >[]()[])
The parameters.


Debug Method

Debug Method
Namespaces ► Sitecore.Diagnostics ► Log ► Debug()()()
Members
Icon | Member | Description
 | Debug(String, Object) | Debugs the specified message.
 | Debug(String) | Debugs the specified message.


Debug Method (message)

Debug Method (message)
Namespaces ► Sitecore.Diagnostics ► Log ► Debug(String)
Debugs the specified message.
Declaration Syntax
C#
public static void Debug(
    string message
)
Parameters
message (String)
The message.


Debug Method (message, owner)

Debug Method (message, owner)
Namespaces ► Sitecore.Diagnostics ► Log ► Debug(String, Object)
Debugs the specified message.
Declaration Syntax
C#
public static void Debug(
    string message,
    Object owner
)
Parameters
message (String)
The message.
owner (Object)
The owner.


Enabled Property

Enabled Property
Namespaces ► Sitecore.Diagnostics ► Log ► Enabled
Gets a value indicating whether this Log is enabled.
Declaration Syntax
C#
public static bool Enabled { get; }
Value
true if enabled; otherwise, false.


Error Method

Error Method
Namespaces ► Sitecore.Diagnostics ► Log ► Error()()()
Members
Icon | Member | Description
 | Error(String, Object) | Errors the specified message.
 | Error(String, Exception, Object) | Errors the specified message.
 | Error(String, Type) | Errors the specified message.
 | Error(String, Exception, Type) | Errors the specified message.


Error Method (message, e, owner)

Error Method (message, e, owner)
Namespaces ► Sitecore.Diagnostics ► Log ► Error(String, Exception, Object)
Errors the specified message.
Declaration Syntax
C#
public static void Error(
    string message,
    Exception e,
    Object owner
)
Parameters
message (String)
The message.
e (Exception)
The e.
owner (Object)
The owner.


Error Method (message, e, ownerType)

Error Method (message, e, ownerType)
Namespaces ► Sitecore.Diagnostics ► Log ► Error(String, Exception, Type)
Errors the specified message.
Declaration Syntax
C#
public static void Error(
    string message,
    Exception e,
    Type ownerType
)
Parameters
message (String)
The message.
e (Exception)
The e.
ownerType (Type)
Type of the owner.


Error Method (message, owner)

Error Method (message, owner)
Namespaces ► Sitecore.Diagnostics ► Log ► Error(String, Object)
Errors the specified message.
Declaration Syntax
C#
public static void Error(
    string message,
    Object owner
)
Parameters
message (String)
The message.
owner (Object)
The owner.


Error Method (message, ownerType)

Error Method (message, ownerType)
Namespaces ► Sitecore.Diagnostics ► Log ► Error(String, Type)
Errors the specified message.
Declaration Syntax
C#
public static void Error(
    string message,
    Type ownerType
)
Parameters
message (String)
The message.
ownerType (Type)
Type of the owner.


Fatal Method

Fatal Method
Namespaces ► Sitecore.Diagnostics ► Log ► Fatal()()()
Members
Icon | Member | Description
 | Fatal(String, Object) | Fatals the specified message.
 | Fatal(String, Type) | Fatals the specified message.
 | Fatal(String, Exception, Object) | Fatals the specified message.
 | Fatal(String, Exception, Type) | Fatals the specified message.


Fatal Method (message, e, owner)

Fatal Method (message, e, owner)
Namespaces ► Sitecore.Diagnostics ► Log ► Fatal(String, Exception, Object)
Fatals the specified message.
Declaration Syntax
C#
public static void Fatal(
    string message,
    Exception e,
    Object owner
)
Parameters
message (String)
The message.
e (Exception)
The e.
owner (Object)
The owner.


Fatal Method (message, e, ownerType)

Fatal Method (message, e, ownerType)
Namespaces ► Sitecore.Diagnostics ► Log ► Fatal(String, Exception, Type)
Fatals the specified message.
Declaration Syntax
C#
public static void Fatal(
    string message,
    Exception e,
    Type ownerType
)
Parameters
message (String)
The message.
e (Exception)
The e.
ownerType (Type)
Type of the owner.


Fatal Method (message, owner)

Fatal Method (message, owner)
Namespaces ► Sitecore.Diagnostics ► Log ► Fatal(String, Object)
Fatals the specified message.
Declaration Syntax
C#
public static void Fatal(
    string message,
    Object owner
)
Parameters
message (String)
The message.
owner (Object)
The owner.


Fatal Method (message, ownerType)

Fatal Method (message, ownerType)
Namespaces ► Sitecore.Diagnostics ► Log ► Fatal(String, Type)
Fatals the specified message.
Declaration Syntax
C#
public static void Fatal(
    string message,
    Type ownerType
)
Parameters
message (String)
The message.
ownerType (Type)
Type of the owner.


Info Method (message, owner)

Info Method (message, owner)
Namespaces ► Sitecore.Diagnostics ► Log ► Info(String, Object)
Infoes the specified message.
Declaration Syntax
C#
public static void Info(
    string message,
    Object owner
)
Parameters
message (String)
The message.
owner (Object)
The owner.


SingleError Method (message, owner)

SingleError Method (message, owner)
Namespaces ► Sitecore.Diagnostics ► Log ► SingleError(String, Object)
Logs a single error.
Declaration Syntax
C#
public static void SingleError(
    string message,
    Object owner
)
Parameters
message (String)
The message.
owner (Object)
The owner.


SingleFatal Method

SingleFatal Method
Namespaces ► Sitecore.Diagnostics ► Log ► SingleFatal()()()
Members
Icon | Member | Description
 | SingleFatal(String, Exception, Object) | Logs a single fatal message.
 | SingleFatal(String, Exception, Type) | Logs a single fatal message.


SingleFatal Method (message, e, owner)

SingleFatal Method (message, e, owner)
Namespaces ► Sitecore.Diagnostics ► Log ► SingleFatal(String, Exception, Object)
Logs a single fatal message.
Declaration Syntax
C#
public static void SingleFatal(
    string message,
    Exception e,
    Object owner
)
Parameters
message (String)
The message.
e (Exception)
The exception.
owner (Object)
The owner.


SingleFatal Method (message, e, ownerType)

SingleFatal Method (message, e, ownerType)
Namespaces ► Sitecore.Diagnostics ► Log ► SingleFatal(String, Exception, Type)
Logs a single fatal message.
Declaration Syntax
C#
public static void SingleFatal(
    string message,
    Exception e,
    Type ownerType
)
Parameters
message (String)
The message.
e (Exception)
The exception.
ownerType (Type)
Type of the owner.


Warn Method

Warn Method
Namespaces ► Sitecore.Diagnostics ► Log ► Warn()()()
Members
Icon | Member | Description
 | Warn(String, Object) | Warns the specified message.
 | Warn(String, Exception, Object) | Warns the specified message.


Warn Method (message, e, owner)

Warn Method (message, e, owner)
Namespaces ► Sitecore.Diagnostics ► Log ► Warn(String, Exception, Object)
Warns the specified message.
Declaration Syntax
C#
public static void Warn(
    string message,
    Exception e,
    Object owner
)
Parameters
message (String)
The message.
e (Exception)
The e.
owner (Object)
The owner.


Warn Method (message, owner)

Warn Method (message, owner)
Namespaces ► Sitecore.Diagnostics ► Log ► Warn(String, Object)
Warns the specified message.
Declaration Syntax
C#
public static void Warn(
    string message,
    Object owner
)
Parameters
message (String)
The message.
owner (Object)
The owner.


LoggerFactory Class

LoggerFactory Class
Namespaces ► Sitecore.Diagnostics ► LoggerFactory
Creates the Log object.
Declaration Syntax
C#
public static class LoggerFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetLogger(String) | Gets the logger.
 | GetLogger(Object) | Gets the logger.
 | GetLogger(Type) | Gets the logger.
Inheritance Hierarchy
Object
LoggerFactory


GetLogger Method

GetLogger Method
Namespaces ► Sitecore.Diagnostics ► LoggerFactory ► GetLogger()()()
Members
Icon | Member | Description
 | GetLogger(String) | Gets the logger.
 | GetLogger(Object) | Gets the logger.
 | GetLogger(Type) | Gets the logger.


GetLogger Method (owner)

GetLogger Method (owner)
Namespaces ► Sitecore.Diagnostics ► LoggerFactory ► GetLogger(Object)
Gets the logger.
Declaration Syntax
C#
public static ILog GetLogger(
    Object owner
)
Parameters
owner (Object)
The owner.
Return Value


GetLogger Method (name)

GetLogger Method (name)
Namespaces ► Sitecore.Diagnostics ► LoggerFactory ► GetLogger(String)
Gets the logger.
Declaration Syntax
C#
public static ILog GetLogger(
    string name
)
Parameters
name (String)
The name.
Return Value


GetLogger Method (type)

GetLogger Method (type)
Namespaces ► Sitecore.Diagnostics ► LoggerFactory ► GetLogger(Type)
Gets the logger.
Declaration Syntax
C#
public static ILog GetLogger(
    Type type
)
Parameters
type (Type)
The type.
Return Value


LogNotification Class

LogNotification Class
Namespaces ► Sitecore.Diagnostics ► LogNotification
Defines the log notification class.
Declaration Syntax
C#
public static class LogNotification
Members
All Members | Methods | Events
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Notification | field saved.
 | RaiseNotification(LogNotificationLevel, String) | Raises the field saved event.
 | RaiseNotification(LogNotificationLevel, String, Exception) | Raises the field saved event.
Inheritance Hierarchy
Object
LogNotification


Notification Event

Notification Event
Namespaces ► Sitecore.Diagnostics ► LogNotification ► Notification
field saved.
Declaration Syntax
C#
public static event LogNotification..::.LogNotificationDelegate Notification


RaiseNotification Method

RaiseNotification Method
Namespaces ► Sitecore.Diagnostics ► LogNotification ► RaiseNotification()()()
Members
Icon | Member | Description
 | RaiseNotification(LogNotificationLevel, String) | Raises the field saved event.
 | RaiseNotification(LogNotificationLevel, String, Exception) | Raises the field saved event.


RaiseNotification Method (level, message)

RaiseNotification Method (level, message)
Namespaces ► Sitecore.Diagnostics ► LogNotification ► RaiseNotification(LogNotificationLevel, String)
Raises the field saved event.
Declaration Syntax
C#
public static void RaiseNotification(
    LogNotificationLevel level,
    string message
)
Parameters
level (LogNotificationLevel)
The level.
message (String)
The message.


RaiseNotification Method (level, message, ex)

RaiseNotification Method (level, message, ex)
Namespaces ► Sitecore.Diagnostics ► LogNotification ► RaiseNotification(LogNotificationLevel, String, Exception)
Raises the field saved event.
Declaration Syntax
C#
public static void RaiseNotification(
    LogNotificationLevel level,
    string message,
    Exception ex
)
Parameters
level (LogNotificationLevel)
The level.
message (String)
The message.
ex (Exception)
The ex.


LogNotification.LogNotificationDelegate Delegate

LogNotification..::.LogNotificationDelegate Delegate
Namespaces ► Sitecore.Diagnostics ► LogNotification ► LogNotification..::.LogNotificationDelegate
Delegate.
Declaration Syntax
C#
public delegate void LogNotificationDelegate(
    LogNotificationLevel level,
    string message,
    Exception exception
)
Parameters
level (LogNotificationLevel)
The notification level
message (String)
The message
exception (Exception)
The thrown exception if any.


LogNotificationLevel Enumeration

LogNotificationLevel Enumeration
Namespaces ► Sitecore.Diagnostics ► LogNotificationLevel
The level of log information.
Declaration Syntax
C#
public enum LogNotificationLevel
Members
Member | Description
None | No logging.
Debug | Debug level.
Info | Information level.
Warning | Warning level.
Error | Error level.
Fatal | Fatal error level.


LongRunningOperationWatcher Class

LongRunningOperationWatcher Class
Namespaces ► Sitecore.Diagnostics ► LongRunningOperationWatcher
ProfileSection class
Declaration Syntax
C#
public class LongRunningOperationWatcher : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LongRunningOperationWatcher(Int32, String, array<String>[]()[]) | Initializes a new instance of the LongRunningOperationWatcher class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LongRunningOperationWatcher


LongRunningOperationWatcher Constructor (threshold, message, parameters)

LongRunningOperationWatcher Constructor (threshold, message, parameters)
Namespaces ► Sitecore.Diagnostics ► LongRunningOperationWatcher ► LongRunningOperationWatcher(Int32, String, array<String>[]()[])
Initializes a new instance of the LongRunningOperationWatcher class.
Declaration Syntax
C#
public LongRunningOperationWatcher(
    int threshold,
    string message,
    params string[] parameters
)
Parameters
threshold (Int32)
The threshold.
message (String)
The message.
parameters (array< String >[]()[])
The parameters.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Diagnostics ► LongRunningOperationWatcher ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


MemoryMonitorHook Class

MemoryMonitorHook Class
Namespaces ► Sitecore.Diagnostics ► MemoryMonitorHook
Implements a hook for the memory monitor
Declaration Syntax
C#
public class MemoryMonitorHook : IHook
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MemoryMonitorHook(String, String, String) | Initializes a new instance of the MemoryMonitorHook class.
 | AdjustLoadFactor | Gets or sets a value indicating whether to adjust the global cache load factor when the memory limit is exceeded.
 | ClearCaches | Gets or sets a value indicating whether to clear all caches when the memory limit is exceeded.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GarbageCollect | Gets or sets a value indicating whether to garbage collect when the memory limit is exceeded.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MemoryMonitorHook


MemoryMonitorHook Constructor (threshold, checkInterval, minimumLogInterval)

MemoryMonitorHook Constructor (threshold, checkInterval, minimumLogInterval)
Namespaces ► Sitecore.Diagnostics ► MemoryMonitorHook ► MemoryMonitorHook(String, String, String)
Initializes a new instance of the MemoryMonitorHook class.
Declaration Syntax
C#
public MemoryMonitorHook(
    string threshold,
    string checkInterval,
    string minimumLogInterval
)
Parameters
threshold (String)
The threshold.
checkInterval (String)
The check interval.
minimumLogInterval (String)
The minimum log interval.


AdjustLoadFactor Property

AdjustLoadFactor Property
Namespaces ► Sitecore.Diagnostics ► MemoryMonitorHook ► AdjustLoadFactor
Gets or sets a value indicating whether to adjust the global cache load factor when the memory limit is exceeded.
Declaration Syntax
C#
public bool AdjustLoadFactor { get; set; }
Value
true if the load factor should be adjusted; otherwise, false.


ClearCaches Property

ClearCaches Property
Namespaces ► Sitecore.Diagnostics ► MemoryMonitorHook ► ClearCaches
Gets or sets a value indicating whether to clear all caches when the memory limit is exceeded.
Declaration Syntax
C#
public bool ClearCaches { get; set; }
Value
true if the caches should be cleared; otherwise, false.


GarbageCollect Property

GarbageCollect Property
Namespaces ► Sitecore.Diagnostics ► MemoryMonitorHook ► GarbageCollect
Gets or sets a value indicating whether to garbage collect when the memory limit is exceeded.
Declaration Syntax
C#
public bool GarbageCollect { get; set; }
Value
true if garbage collection should be performed; otherwise, false.


Initialize Method

Initialize Method
Namespaces ► Sitecore.Diagnostics ► MemoryMonitorHook ► Initialize()()()
Initializes this instance.
Declaration Syntax
C#
public void Initialize()


ProfileEntry Class

ProfileEntry Class
Namespaces ► Sitecore.Diagnostics ► ProfileEntry
ProfileData
Declaration Syntax
C#
public class ProfileEntry
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProfileEntry(String, array<String>[]()[]) | Initializes a new instance of the ProfileEntry class.
 | AddAdminTime(Double) | Adds the admin time.
 | AddChildTime(Double) | Adds the child time.
 | AdminTime | Gets the admin time.
 | CallStackID | Gets or sets the call stack ID.
 | ChildTime | Gets the child time.
 | EndTick | Gets or sets the end tick.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Level | Gets or sets the level.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MethodName | Gets the name of the method.
 | OwnTime | Gets the own time.
 | Parameters | Gets the parameters.
 | RequestID | Gets the request ID.
 | Sequence | Gets or sets the sequence.
 | StartTick | Gets or sets the start tick.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalTime | Gets the total time.
Inheritance Hierarchy
Object
ProfileEntry


ProfileEntry Constructor (methodName, parameters)

ProfileEntry Constructor (methodName, parameters)
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► ProfileEntry(String, array<String>[]()[])
Initializes a new instance of the ProfileEntry class.
Declaration Syntax
C#
public ProfileEntry(
    string methodName,
    string[] parameters
)
Parameters
methodName (String)
Name of the method.
parameters (array< String >[]()[])
The parameters.


AddAdminTime Method (time)

AddAdminTime Method (time)
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► AddAdminTime(Double)
Adds the admin time.
Declaration Syntax
C#
public void AddAdminTime(
    double time
)
Parameters
time (Double)
The time.


AddChildTime Method (time)

AddChildTime Method (time)
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► AddChildTime(Double)
Adds the child time.
Declaration Syntax
C#
public void AddChildTime(
    double time
)
Parameters
time (Double)
The time.


AdminTime Property

AdminTime Property
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► AdminTime
Gets the admin time.
Declaration Syntax
C#
public double AdminTime { get; }
Value
The admin time.


CallStackID Property

CallStackID Property
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► CallStackID
Gets or sets the call stack ID.
Declaration Syntax
C#
public string CallStackID { get; set; }
Value
The call stack ID.


ChildTime Property

ChildTime Property
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► ChildTime
Gets the child time.
Declaration Syntax
C#
public double ChildTime { get; }
Value
The child time.


EndTick Property

EndTick Property
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► EndTick
Gets or sets the end tick.
Declaration Syntax
C#
public long EndTick { get; set; }
Value
The end tick.


Level Property

Level Property
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► Level
Gets or sets the level.
Declaration Syntax
C#
public int Level { get; set; }
Value
The level.


MethodName Property

MethodName Property
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► MethodName
Gets the name of the method.
Declaration Syntax
C#
public string MethodName { get; }
Value
The name of the method.


OwnTime Property

OwnTime Property
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► OwnTime
Gets the own time.
Declaration Syntax
C#
public double OwnTime { get; }
Value
The own time.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► Parameters
Gets the parameters.
Declaration Syntax
C#
public string[] Parameters { get; }
Value
The parameters.


RequestID Property

RequestID Property
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► RequestID
Gets the request ID.
Declaration Syntax
C#
public string RequestID { get; }
Value
The request ID.


Sequence Property

Sequence Property
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► Sequence
Gets or sets the sequence.
Declaration Syntax
C#
public int Sequence { get; set; }
Value
The sequence.


StartTick Property

StartTick Property
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► StartTick
Gets or sets the start tick.
Declaration Syntax
C#
public long StartTick { get; set; }
Value
The start tick.


TotalTime Property

TotalTime Property
Namespaces ► Sitecore.Diagnostics ► ProfileEntry ► TotalTime
Gets the total time.
Declaration Syntax
C#
public double TotalTime { get; }
Value
The total time.


Profiler Class

Profiler Class
Namespaces ► Sitecore.Diagnostics ► Profiler
Represents the Profiler.
Declaration Syntax
C#
public static class Profiler
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EndOperation()()() | Ends the operation.
 | EndOperation(String) | Ends the operation.
 | EndSession()()() | Ends the session.
 | GetFormattedProfile()()() | Gets the formatted profile.
 | GetFormattedProfile(String) | Gets the formatted profile.
 | GetReportFileName()()() | Gets the name of the report file.
 | IsActive | Gets a value indicating whether this instance is active.
 | Render()()() | Renders this instance.
 | RenderOnEndSession | Gets or sets a value indicating whether the Profiler renders the on end session.
 | SaveReport()()() | Saves the report.
 | SaveReport(String) | Saves the report.
 | StartOperation(String) | Starts the operation.
 | StartSession()()() | Starts the session.
Inheritance Hierarchy
Object
Profiler


EndOperation Method

EndOperation Method
Namespaces ► Sitecore.Diagnostics ► Profiler ► EndOperation()()()
Members
Icon | Member | Description
 | EndOperation()()() | Ends the operation.
 | EndOperation(String) | Ends the operation.


EndOperation Method

EndOperation Method
Namespaces ► Sitecore.Diagnostics ► Profiler ► EndOperation()()()
Ends the operation.
Declaration Syntax
C#
public static void EndOperation()


EndOperation Method (status)

EndOperation Method (status)
Namespaces ► Sitecore.Diagnostics ► Profiler ► EndOperation(String)
Ends the operation.
Declaration Syntax
C#
public static void EndOperation(
    string status
)
Parameters
status (String)
The status.


EndSession Method

EndSession Method
Namespaces ► Sitecore.Diagnostics ► Profiler ► EndSession()()()
Ends the session.
Declaration Syntax
C#
public static void EndSession()


GetFormattedProfile Method

GetFormattedProfile Method
Namespaces ► Sitecore.Diagnostics ► Profiler ► GetFormattedProfile()()()
Members
Icon | Member | Description
 | GetFormattedProfile()()() | Gets the formatted profile.
 | GetFormattedProfile(String) | Gets the formatted profile.


GetFormattedProfile Method

GetFormattedProfile Method
Namespaces ► Sitecore.Diagnostics ► Profiler ► GetFormattedProfile()()()
Gets the formatted profile.
Declaration Syntax
C#
public static string GetFormattedProfile()
Return Value


GetFormattedProfile Method (xslFile)

GetFormattedProfile Method (xslFile)
Namespaces ► Sitecore.Diagnostics ► Profiler ► GetFormattedProfile(String)
Gets the formatted profile.
Declaration Syntax
C#
public static string GetFormattedProfile(
    string xslFile
)
Parameters
xslFile (String)
The XSL file.
Return Value


GetReportFileName Method

GetReportFileName Method
Namespaces ► Sitecore.Diagnostics ► Profiler ► GetReportFileName()()()
Gets the name of the report file.
Declaration Syntax
C#
public static string GetReportFileName()
Return Value


IsActive Property

IsActive Property
Namespaces ► Sitecore.Diagnostics ► Profiler ► IsActive
Gets a value indicating whether this instance is active.
Declaration Syntax
C#
public static bool IsActive { get; }
Value
true if this instance is active; otherwise, false.


Render Method

Render Method
Namespaces ► Sitecore.Diagnostics ► Profiler ► Render()()()
Renders this instance.
Declaration Syntax
C#
public static void Render()


RenderOnEndSession Property

RenderOnEndSession Property
Namespaces ► Sitecore.Diagnostics ► Profiler ► RenderOnEndSession
Gets or sets a value indicating whether the Profiler renders the on end session.
Declaration Syntax
C#
public static bool RenderOnEndSession { get; set; }
Value
true if the Profiler renders the on end session; otherwise, false.


SaveReport Method

SaveReport Method
Namespaces ► Sitecore.Diagnostics ► Profiler ► SaveReport()()()
Members
Icon | Member | Description
 | SaveReport()()() | Saves the report.
 | SaveReport(String) | Saves the report.


SaveReport Method

SaveReport Method
Namespaces ► Sitecore.Diagnostics ► Profiler ► SaveReport()()()
Saves the report.
Declaration Syntax
C#
public static void SaveReport()


SaveReport Method (fileName)

SaveReport Method (fileName)
Namespaces ► Sitecore.Diagnostics ► Profiler ► SaveReport(String)
Saves the report.
Declaration Syntax
C#
public static void SaveReport(
    string fileName
)
Parameters
fileName (String)
Name of the file.


StartOperation Method (name)

StartOperation Method (name)
Namespaces ► Sitecore.Diagnostics ► Profiler ► StartOperation(String)
Starts the operation.
Declaration Syntax
C#
public static void StartOperation(
    string name
)
Parameters
name (String)
The name.


StartSession Method

StartSession Method
Namespaces ► Sitecore.Diagnostics ► Profiler ► StartSession()()()
Starts the session.
Declaration Syntax
C#
public static void StartSession()


Profiler.Worker Class

Profiler..::.Worker Class
Namespaces ► Sitecore.Diagnostics ► Profiler ► Profiler..::.Worker
Represents a Worker.
Declaration Syntax
C#
public class Worker : DiagnosticWorker
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Profiler..::.Worker()()() | Initializes a new instance of the Profiler..::.Worker class.
 | EndOperation(String) | Ends the operation.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportFileName()()() | Gets the name of the report file.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from DiagnosticWorker.)
 | Packet | Gets the packet. (Inherited from DiagnosticWorker.)
 | RenderOnEndSession | Gets or sets a value indicating whether the Profiler..::.Worker renders the on end session.
 | SaveReport(String) | Saves the report. (Inherited from DiagnosticWorker.)
 | StartOperation(String) | Starts the operation.
 | StartReport(String) | Starts the report. (Inherited from DiagnosticWorker.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DiagnosticWorker
 |  | Profiler..::.Worker


Profiler.Worker Constructor

Profiler..::.Worker Constructor
Namespaces ► Sitecore.Diagnostics ► Profiler..::.Worker ► Profiler..::.Worker()()()
Initializes a new instance of the Profiler..::.Worker class.
Declaration Syntax
C#
public Worker()


EndOperation Method (status)

EndOperation Method (status)
Namespaces ► Sitecore.Diagnostics ► Profiler..::.Worker ► EndOperation(String)
Ends the operation.
Declaration Syntax
C#
public void EndOperation(
    string status
)
Parameters
status (String)
The status.


GetReportFileName Method

GetReportFileName Method
Namespaces ► Sitecore.Diagnostics ► Profiler..::.Worker ► GetReportFileName()()()
Gets the name of the report file.
Declaration Syntax
C#
public static string GetReportFileName()
Return Value


RenderOnEndSession Property

RenderOnEndSession Property
Namespaces ► Sitecore.Diagnostics ► Profiler..::.Worker ► RenderOnEndSession
Gets or sets a value indicating whether the Profiler..::.Worker renders the on end session.
Declaration Syntax
C#
public bool RenderOnEndSession { get; set; }
Value
true if the Profiler..::.Worker renders the on end session; otherwise, false.


StartOperation Method (name)

StartOperation Method (name)
Namespaces ► Sitecore.Diagnostics ► Profiler..::.Worker ► StartOperation(String)
Starts the operation.
Declaration Syntax
C#
public void StartOperation(
    string name
)
Parameters
name (String)
The name.


ProfileSection Class

ProfileSection Class
Namespaces ► Sitecore.Diagnostics ► ProfileSection
ProfileSection class
Declaration Syntax
C#
public class ProfileSection : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProfileSection(String) | Initializes a new instance of the ProfileSection class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProfileSection


ProfileSection Constructor (message)

ProfileSection Constructor (message)
Namespaces ► Sitecore.Diagnostics ► ProfileSection ► ProfileSection(String)
Initializes a new instance of the ProfileSection class.
Declaration Syntax
C#
public ProfileSection(
    string message
)
Parameters
message (String)


Dispose Method

Dispose Method
Namespaces ► Sitecore.Diagnostics ► ProfileSection ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


RecursionLimit Class

RecursionLimit Class
Namespaces ► Sitecore.Diagnostics ► RecursionLimit
RecursionLimit class
Declaration Syntax
C#
public class RecursionLimit : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RecursionLimit(String, Int32) | Initializes a new instance of the RecursionLimit class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exceeded | Gets a value indicating whether this RecursionLimit is exceeded.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Level | Gets the current level.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RecursionLimit


RecursionLimit Constructor (name, maxLevel)

RecursionLimit Constructor (name, maxLevel)
Namespaces ► Sitecore.Diagnostics ► RecursionLimit ► RecursionLimit(String, Int32)
Initializes a new instance of the RecursionLimit class.
Declaration Syntax
C#
public RecursionLimit(
    string name,
    int maxLevel
)
Parameters
name (String)
maxLevel (Int32)


Dispose Method

Dispose Method
Namespaces ► Sitecore.Diagnostics ► RecursionLimit ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


Exceeded Property

Exceeded Property
Namespaces ► Sitecore.Diagnostics ► RecursionLimit ► Exceeded
Gets a value indicating whether this RecursionLimit is exceeded.
Declaration Syntax
C#
public bool Exceeded { get; }
Value
true if exceeded; otherwise, false.


Level Property

Level Property
Namespaces ► Sitecore.Diagnostics ► RecursionLimit ► Level
Gets the current level.
Declaration Syntax
C#
public int Level { get; set; }
Return Value


Statistics Class

Statistics Class
Namespaces ► Sitecore.Diagnostics ► Statistics
Statistics
Statistics
Statistics
Declaration Syntax
C#
public sealed class Statistics
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Statistics()()() | Initializes a new instance of the Statistics class
 | AddPipelineTiming(String, TimeSpan) | Adds a pipeline timing.
 | AddRenderingData(String, Double, Int64, Boolean) | Adds rendering data.
 | AddRequestTiming(TimeSpan) | Adds the request timing.
 | Clear()()() | Clears the current data
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPipelineTiming(String) | Gets a pipeline timing.
 | GetRenderingData(String) | Gets rendering data.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RenderingStatistics | Gets the rendering data.
 | RequestCount | Gets the request count.
 | RequestTime | Gets the request time.
 | ResetPipelineTiming()()() | Resets the pipeline timing.
 | ResetRequestTiming()()() | Resets the request timing.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Statistics


Statistics Constructor

Statistics Constructor
Namespaces ► Sitecore.Diagnostics ► Statistics ► Statistics()()()
Initializes a new instance of the Statistics class
Declaration Syntax
C#
public Statistics()


AddPipelineTiming Method (pipelineName, elapsed)

AddPipelineTiming Method (pipelineName, elapsed)
Namespaces ► Sitecore.Diagnostics ► Statistics ► AddPipelineTiming(String, TimeSpan)
Adds a pipeline timing.
Declaration Syntax
C#
public static void AddPipelineTiming(
    string pipelineName,
    TimeSpan elapsed
)
Parameters
pipelineName (String)
elapsed (TimeSpan)


AddRenderingData Method (traceName, elapsed, itemsAccessed, usedCache)

AddRenderingData Method (traceName, elapsed, itemsAccessed, usedCache)
Namespaces ► Sitecore.Diagnostics ► Statistics ► AddRenderingData(String, Double, Int64, Boolean)
Adds rendering data.
Declaration Syntax
C#
public static void AddRenderingData(
    string traceName,
    double elapsed,
    long itemsAccessed,
    bool usedCache
)
Parameters
traceName (String)
Name of the trace.
elapsed (Double)
The elapsed time (in ms.).
itemsAccessed (Int64)
The items accessed.
usedCache (Boolean)
if set to true this instance is used cache.


AddRequestTiming Method (requestTime)

AddRequestTiming Method (requestTime)
Namespaces ► Sitecore.Diagnostics ► Statistics ► AddRequestTiming(TimeSpan)
Adds the request timing.
Declaration Syntax
C#
public static void AddRequestTiming(
    TimeSpan requestTime
)
Parameters
requestTime (TimeSpan)
The request time.


Clear Method

Clear Method
Namespaces ► Sitecore.Diagnostics ► Statistics ► Clear()()()
Clears the current data
Declaration Syntax
C#
public static void Clear()


GetPipelineTiming Method (pipelineName)

GetPipelineTiming Method (pipelineName)
Namespaces ► Sitecore.Diagnostics ► Statistics ► GetPipelineTiming(String)
Gets a pipeline timing.
Declaration Syntax
C#
public static Statistics..::.PipelineTiming GetPipelineTiming(
    string pipelineName
)
Parameters
pipelineName (String)


GetRenderingData Method (traceName)

GetRenderingData Method (traceName)
Namespaces ► Sitecore.Diagnostics ► Statistics ► GetRenderingData(String)
Gets rendering data.
Declaration Syntax
C#
public static Statistics..::.RenderingData GetRenderingData(
    string traceName
)
Parameters
traceName (String)
Name of the trace.
Return Value
The rendering data.


RenderingStatistics Property

RenderingStatistics Property
Namespaces ► Sitecore.Diagnostics ► Statistics ► RenderingStatistics
Gets the rendering data.
Declaration Syntax
C#
public static IEnumerable<Statistics..::.RenderingData> RenderingStatistics { get; }
Value
The rendering data.


RequestCount Property

RequestCount Property
Namespaces ► Sitecore.Diagnostics ► Statistics ► RequestCount
Gets the request count.
Declaration Syntax
C#
public static int RequestCount { get; }
Value
The request count.


RequestTime Property

RequestTime Property
Namespaces ► Sitecore.Diagnostics ► Statistics ► RequestTime
Gets the request time.
Declaration Syntax
C#
public static TimeSpan RequestTime { get; }
Value
The request time.


ResetPipelineTiming Method

ResetPipelineTiming Method
Namespaces ► Sitecore.Diagnostics ► Statistics ► ResetPipelineTiming()()()
Resets the pipeline timing.
Declaration Syntax
C#
public static void ResetPipelineTiming()


ResetRequestTiming Method

ResetRequestTiming Method
Namespaces ► Sitecore.Diagnostics ► Statistics ► ResetRequestTiming()()()
Resets the request timing.
Declaration Syntax
C#
public static void ResetRequestTiming()


Statistics.PipelineTiming Class

Statistics..::.PipelineTiming Class
Namespaces ► Sitecore.Diagnostics ► Statistics ► Statistics..::.PipelineTiming
PipelineTiming class
Declaration Syntax
C#
public class PipelineTiming
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Statistics..::.PipelineTiming()()() | Initializes a new instance of the Statistics..::.PipelineTiming class
 | Add(TimeSpan) | Adds the specified timing.
 | CallCount | Gets the call count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalTime | Gets the total time.
Inheritance Hierarchy
Object
Statistics..::.PipelineTiming


Statistics.PipelineTiming Constructor

Statistics..::.PipelineTiming Constructor
Namespaces ► Sitecore.Diagnostics ► Statistics..::.PipelineTiming ► Statistics..::.PipelineTiming()()()
Initializes a new instance of the Statistics..::.PipelineTiming class
Declaration Syntax
C#
public PipelineTiming()


Add Method (elapsed)

Add Method (elapsed)
Namespaces ► Sitecore.Diagnostics ► Statistics..::.PipelineTiming ► Add(TimeSpan)
Adds the specified timing.
Declaration Syntax
C#
public Statistics..::.PipelineTiming Add(
    TimeSpan elapsed
)
Parameters
elapsed (TimeSpan)
The elapsed time.
Return Value


CallCount Property

CallCount Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.PipelineTiming ► CallCount
Gets the call count.
Declaration Syntax
C#
public int CallCount { get; }
Value
The call count.


TotalTime Property

TotalTime Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.PipelineTiming ► TotalTime
Gets the total time.
Declaration Syntax
C#
public TimeSpan TotalTime { get; }
Value
The total time.


Statistics.RenderingData Class

Statistics..::.RenderingData Class
Namespaces ► Sitecore.Diagnostics ► Statistics ► Statistics..::.RenderingData
RenderingData
Declaration Syntax
C#
public class RenderingData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Statistics..::.RenderingData(String, String) | Initializes a new instance of the Statistics..::.RenderingData class.
 | AddData(Double, Int64, Boolean) | Adds the data.
 | AverageItemsAccessed | Gets the total number of items accessed by the rendering.
 | AverageTime | Gets the average time spent by the rendering.
 | CacheHitRatio | Gets the cache hit ratio.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LastRendered | Gets the time of the latest rendering.
 | MaxItemsAccessed | Gets the maximum number of items accessed during rendering.
 | MaxTime | Gets the slowest time of rendering (in ms.).
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinItemsAccessed | Gets the minimum number of items accessed during rendering.
 | MinTime | Gets the fastest time of rendering (in ms.).
 | RenderCount | Gets the total number of times the rendering has been rendered.
 | SiteName | Gets the name of the site where the rendering was rendered.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalItemsAccessed | Gets the total number of items accessed by the rendering.
 | TotalTime | Gets the total time spent by the rendering.
 | TraceName | Gets the trace name of the rendering.
 | UsedCache | Gets the number of times the rendering was rendered from cache.
Inheritance Hierarchy
Object
Statistics..::.RenderingData


Statistics.RenderingData Constructor (traceName, site)

Statistics..::.RenderingData Constructor (traceName, site)
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► Statistics..::.RenderingData(String, String)
Initializes a new instance of the Statistics..::.RenderingData class.
Declaration Syntax
C#
public RenderingData(
    string traceName,
    string site
)
Parameters
traceName (String)
The trace name of the rendering.
site (String)
The site.


AddData Method (elapsed, itemsAccessed, usedCache)

AddData Method (elapsed, itemsAccessed, usedCache)
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► AddData(Double, Int64, Boolean)
Adds the data.
Declaration Syntax
C#
public void AddData(
    double elapsed,
    long itemsAccessed,
    bool usedCache
)
Parameters
elapsed (Double)
The elapsed time (in ms.).
itemsAccessed (Int64)
The items accessed.
usedCache (Boolean)
if set to true this instance is used cache.


AverageItemsAccessed Property

AverageItemsAccessed Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► AverageItemsAccessed
Gets the total number of items accessed by the rendering.
Declaration Syntax
C#
public long AverageItemsAccessed { get; }
Value
The total number of items accessed by the rendering.


AverageTime Property

AverageTime Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► AverageTime
Gets the average time spent by the rendering.
Declaration Syntax
C#
public TimeSpan AverageTime { get; }
Value
The average time spent by the rendering.


CacheHitRatio Property

CacheHitRatio Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► CacheHitRatio
Gets the cache hit ratio.
Declaration Syntax
C#
public double CacheHitRatio { get; }
Value
The cache hit ratio.


LastRendered Property

LastRendered Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► LastRendered
Gets the time of the latest rendering.
Declaration Syntax
C#
public DateTime LastRendered { get; }
Value
The time of the latest rendering.


MaxItemsAccessed Property

MaxItemsAccessed Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► MaxItemsAccessed
Gets the maximum number of items accessed during rendering.
Declaration Syntax
C#
public long MaxItemsAccessed { get; }
Value
The maximum number of items accessed during rendering.


MaxTime Property

MaxTime Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► MaxTime
Gets the slowest time of rendering (in ms.).
Declaration Syntax
C#
public TimeSpan MaxTime { get; }
Value
The slowest time of rendering (in ms.).


MinItemsAccessed Property

MinItemsAccessed Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► MinItemsAccessed
Gets the minimum number of items accessed during rendering.
Declaration Syntax
C#
public long MinItemsAccessed { get; }
Value
The minimum number of items accessed during rendering.


MinTime Property

MinTime Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► MinTime
Gets the fastest time of rendering (in ms.).
Declaration Syntax
C#
public TimeSpan MinTime { get; }
Value
The fastest time of rendering (in ms.).


RenderCount Property

RenderCount Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► RenderCount
Gets the total number of times the rendering has been rendered.
Declaration Syntax
C#
public int RenderCount { get; }
Value
The total number of times the rendering has been rendered.


SiteName Property

SiteName Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► SiteName
Gets the name of the site where the rendering was rendered.
Declaration Syntax
C#
public string SiteName { get; }
Value
The name of the site where the rendering was rendered.


TotalItemsAccessed Property

TotalItemsAccessed Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► TotalItemsAccessed
Gets the total number of items accessed by the rendering.
Declaration Syntax
C#
public long TotalItemsAccessed { get; }
Value
The total number of items accessed by the rendering.


TotalTime Property

TotalTime Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► TotalTime
Gets the total time spent by the rendering.
Declaration Syntax
C#
public TimeSpan TotalTime { get; }
Value
The total number of items accessed by the rendering.


TraceName Property

TraceName Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► TraceName
Gets the trace name of the rendering.
Declaration Syntax
C#
public string TraceName { get; }
Value
The trace name of the rendering.


UsedCache Property

UsedCache Property
Namespaces ► Sitecore.Diagnostics ► Statistics..::.RenderingData ► UsedCache
Gets the number of times the rendering was rendered from cache.
Declaration Syntax
C#
public int UsedCache { get; }
Value
The number of times the rendering was rendered from cache.


TextLog Class

TextLog Class
Namespaces ► Sitecore.Diagnostics ► TextLog
TextLog class
Declaration Syntax
C#
public class TextLog
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextLog()()() | Initializes a new instance of the TextLog class
 | AppendError(String) | Appends an error to the log.
 | Entries | Gets the entries.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Errors | Gets the error entries.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Informations | Gets the informtational entries.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Warnings | Gets the warning entries.
Inheritance Hierarchy
Object
TextLog


TextLog Constructor

TextLog Constructor
Namespaces ► Sitecore.Diagnostics ► TextLog ► TextLog()()()
Initializes a new instance of the TextLog class
Declaration Syntax
C#
public TextLog()


AppendError Method (message)

AppendError Method (message)
Namespaces ► Sitecore.Diagnostics ► TextLog ► AppendError(String)
Appends an error to the log.
Declaration Syntax
C#
public void AppendError(
    string message
)
Parameters
message (String)
The message.


Entries Property

Entries Property
Namespaces ► Sitecore.Diagnostics ► TextLog ► Entries
Gets the entries.
Declaration Syntax
C#
public IEnumerable<TextLogEntry> Entries { get; }
Value
The entries.


Errors Property

Errors Property
Namespaces ► Sitecore.Diagnostics ► TextLog ► Errors
Gets the error entries.
Declaration Syntax
C#
public IEnumerable<TextLogEntry> Errors { get; }
Value
The error entries.


Informations Property

Informations Property
Namespaces ► Sitecore.Diagnostics ► TextLog ► Informations
Gets the informtational entries.
Declaration Syntax
C#
public IEnumerable<TextLogEntry> Informations { get; }
Value
The error entries.


Warnings Property

Warnings Property
Namespaces ► Sitecore.Diagnostics ► TextLog ► Warnings
Gets the warning entries.
Declaration Syntax
C#
public IEnumerable<TextLogEntry> Warnings { get; }
Value
The error entries.


TextLog.Severity Enumeration

TextLog..::.Severity Enumeration
Namespaces ► Sitecore.Diagnostics ► TextLog ► TextLog..::.Severity
Severity
Declaration Syntax
C#
public enum Severity
Members
Member | Description
Information | Informational entry.
Warning | Warning entry.
Error | Error entry.


TextLogEntry Class

TextLogEntry Class
Namespaces ► Sitecore.Diagnostics ► TextLogEntry
TextLogEntry class
Declaration Syntax
C#
public class TextLogEntry
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextLogEntry(String, TextLog..::.Severity) | Initializes a new instance of the TextLogEntry class.
 | TextLogEntry(String, TextLog..::.Severity, Exception) | Initializes a new instance of the TextLogEntry class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exception | Gets the exception.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message.
 | Severity | Gets the severity.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TextLogEntry


TextLogEntry Constructor

TextLogEntry Constructor
Namespaces ► Sitecore.Diagnostics ► TextLogEntry ► TextLogEntry()()()
Members
Icon | Member | Description
 | TextLogEntry(String, TextLog..::.Severity) | Initializes a new instance of the TextLogEntry class.
 | TextLogEntry(String, TextLog..::.Severity, Exception) | Initializes a new instance of the TextLogEntry class.


TextLogEntry Constructor (message, severity)

TextLogEntry Constructor (message, severity)
Namespaces ► Sitecore.Diagnostics ► TextLogEntry ► TextLogEntry(String, TextLog..::.Severity)
Initializes a new instance of the TextLogEntry class.
Declaration Syntax
C#
public TextLogEntry(
    string message,
    TextLog..::.Severity severity
)
Parameters
message (String)
The message.
severity (TextLog..::.Severity)
The severity.


TextLogEntry Constructor (message, severity, exception)

TextLogEntry Constructor (message, severity, exception)
Namespaces ► Sitecore.Diagnostics ► TextLogEntry ► TextLogEntry(String, TextLog..::.Severity, Exception)
Initializes a new instance of the TextLogEntry class.
Declaration Syntax
C#
public TextLogEntry(
    string message,
    TextLog..::.Severity severity,
    Exception exception
)
Parameters
message (String)
The message.
severity (TextLog..::.Severity)
The severity.
exception (Exception)
The exception.


Exception Property

Exception Property
Namespaces ► Sitecore.Diagnostics ► TextLogEntry ► Exception
Gets the exception.
Declaration Syntax
C#
public Exception Exception { get; }
Value
The exception.


Message Property

Message Property
Namespaces ► Sitecore.Diagnostics ► TextLogEntry ► Message
Gets the message.
Declaration Syntax
C#
public string Message { get; }
Value
The message.


Severity Property

Severity Property
Namespaces ► Sitecore.Diagnostics ► TextLogEntry ► Severity
Gets the severity.
Declaration Syntax
C#
public TextLog..::.Severity Severity { get; }
Value
The severity.


ThreadError Class

ThreadError Class
Namespaces ► Sitecore.Diagnostics ► ThreadError
Thread error container class.
Declaration Syntax
C#
public class ThreadError
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ThreadError(String) | Initializes a new instance of the ThreadError class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorText | Gets the error text.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Time | Gets the time of the error.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ThreadError


ThreadError Constructor (errorText)

ThreadError Constructor (errorText)
Namespaces ► Sitecore.Diagnostics ► ThreadError ► ThreadError(String)
Initializes a new instance of the ThreadError class.
Declaration Syntax
C#
public ThreadError(
    string errorText
)
Parameters
errorText (String)
The error text.


ErrorText Property

ErrorText Property
Namespaces ► Sitecore.Diagnostics ► ThreadError ► ErrorText
Gets the error text.
Declaration Syntax
C#
public string ErrorText { get; }
Value
The error text.


Time Property

Time Property
Namespaces ► Sitecore.Diagnostics ► ThreadError ► Time
Gets the time of the error.
Declaration Syntax
C#
public DateTime Time { get; }
Value
The time.


Tracer Class

Tracer Class
Namespaces ► Sitecore.Diagnostics ► Tracer
Represents the Tracer.
Declaration Syntax
C#
public static class Tracer
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Debug(Object) | Outputs the specified debug message.
 | DebugInfo(String, Packet) | Outputs the specified debug information.
 | EndSession()()() | Ends the session.
 | Error(Object) | Outputs the specified error message.
 | Error(Object, Object) | Outputs the specified error message.
 | Fatal(Object) | Outputs the specified fatal message.
 | GetFormattedTrace()()() | Gets the formatted trace.
 | GetFormattedTrace(String) | Gets the formatted trace.
 | GetReportFileName()()() | Gets the name of the report file.
 | Indent | Gets or sets the indent.
 | Info(Object) | Outputs the specified information message.
 | Info(Object, Object) | Outputs the specified information message.
 | IsActive | Gets a value indicating whether this instance is active.
 | Render()()() | Renders this instance.
 | RenderOnEndSession | Gets or sets a value indicating whether the Tracer renders on end session.
 | SaveCurrentReport()()() | Saves the current report.
 | SaveReport(String) | Saves the report.
 | StartSession()()() | Starts the session.
 | TotalTime | Gets the total time.
 | Warning(Object) | Outputs the specified warning message.
 | Warning(Object, Object) | Outputs the specified warning message.
Inheritance Hierarchy
Object
Tracer


Debug Method (message)

Debug Method (message)
Namespaces ► Sitecore.Diagnostics ► Tracer ► Debug(Object)
Outputs the specified debug message.
Declaration Syntax
C#
public static void Debug(
    Object message
)
Parameters
message (Object)
The message.


DebugInfo Method (debugInfoID, packet)

DebugInfo Method (debugInfoID, packet)
Namespaces ► Sitecore.Diagnostics ► Tracer ► DebugInfo(String, Packet)
Outputs the specified debug information.
Declaration Syntax
C#
public static void DebugInfo(
    string debugInfoID,
    Packet packet
)
Parameters
debugInfoID (String)
The debug info ID.
packet (Packet)
The debug info.


EndSession Method

EndSession Method
Namespaces ► Sitecore.Diagnostics ► Tracer ► EndSession()()()
Ends the session.
Declaration Syntax
C#
public static void EndSession()


Error Method

Error Method
Namespaces ► Sitecore.Diagnostics ► Tracer ► Error()()()
Members
Icon | Member | Description
 | Error(Object) | Outputs the specified error message.
 | Error(Object, Object) | Outputs the specified error message.


Error Method (message)

Error Method (message)
Namespaces ► Sitecore.Diagnostics ► Tracer ► Error(Object)
Outputs the specified error message.
Declaration Syntax
C#
public static void Error(
    Object message
)
Parameters
message (Object)
The message.


Error Method (message, details)

Error Method (message, details)
Namespaces ► Sitecore.Diagnostics ► Tracer ► Error(Object, Object)
Outputs the specified error message.
Declaration Syntax
C#
public static void Error(
    Object message,
    Object details
)
Parameters
message (Object)
The message.
details (Object)
The details.


Fatal Method (message)

Fatal Method (message)
Namespaces ► Sitecore.Diagnostics ► Tracer ► Fatal(Object)
Outputs the specified fatal message.
Declaration Syntax
C#
public static void Fatal(
    Object message
)
Parameters
message (Object)
The message.


GetFormattedTrace Method

GetFormattedTrace Method
Namespaces ► Sitecore.Diagnostics ► Tracer ► GetFormattedTrace()()()
Members
Icon | Member | Description
 | GetFormattedTrace()()() | Gets the formatted trace.
 | GetFormattedTrace(String) | Gets the formatted trace.


GetFormattedTrace Method

GetFormattedTrace Method
Namespaces ► Sitecore.Diagnostics ► Tracer ► GetFormattedTrace()()()
Gets the formatted trace.
Declaration Syntax
C#
public static string GetFormattedTrace()
Return Value


GetFormattedTrace Method (xslFile)

GetFormattedTrace Method (xslFile)
Namespaces ► Sitecore.Diagnostics ► Tracer ► GetFormattedTrace(String)
Gets the formatted trace.
Declaration Syntax
C#
public static string GetFormattedTrace(
    string xslFile
)
Parameters
xslFile (String)
The XSL file.
Return Value


GetReportFileName Method

GetReportFileName Method
Namespaces ► Sitecore.Diagnostics ► Tracer ► GetReportFileName()()()
Gets the name of the report file.
Declaration Syntax
C#
public static string GetReportFileName()
Return Value


Indent Property

Indent Property
Namespaces ► Sitecore.Diagnostics ► Tracer ► Indent
Gets or sets the indent.
Declaration Syntax
C#
public static int Indent { get; set; }
Value
The indent.


Info Method

Info Method
Namespaces ► Sitecore.Diagnostics ► Tracer ► Info()()()
Members
Icon | Member | Description
 | Info(Object) | Outputs the specified information message.
 | Info(Object, Object) | Outputs the specified information message.


Info Method (message)

Info Method (message)
Namespaces ► Sitecore.Diagnostics ► Tracer ► Info(Object)
Outputs the specified information message.
Declaration Syntax
C#
public static void Info(
    Object message
)
Parameters
message (Object)
The message.


Info Method (message, details)

Info Method (message, details)
Namespaces ► Sitecore.Diagnostics ► Tracer ► Info(Object, Object)
Outputs the specified information message.
Declaration Syntax
C#
public static void Info(
    Object message,
    Object details
)
Parameters
message (Object)
The message.
details (Object)
The details.


IsActive Property

IsActive Property
Namespaces ► Sitecore.Diagnostics ► Tracer ► IsActive
Gets a value indicating whether this instance is active.
Declaration Syntax
C#
public static bool IsActive { get; }
Value
true if this instance is active; otherwise, false.


Render Method

Render Method
Namespaces ► Sitecore.Diagnostics ► Tracer ► Render()()()
Renders this instance.
Declaration Syntax
C#
public static void Render()


RenderOnEndSession Property

RenderOnEndSession Property
Namespaces ► Sitecore.Diagnostics ► Tracer ► RenderOnEndSession
Gets or sets a value indicating whether the Tracer renders on end session.
Declaration Syntax
C#
public static bool RenderOnEndSession { get; set; }
Value
true if the Tracer renders on end session; otherwise, false.


SaveCurrentReport Method

SaveCurrentReport Method
Namespaces ► Sitecore.Diagnostics ► Tracer ► SaveCurrentReport()()()
Saves the current report.
Declaration Syntax
C#
public static void SaveCurrentReport()


SaveReport Method (fileName)

SaveReport Method (fileName)
Namespaces ► Sitecore.Diagnostics ► Tracer ► SaveReport(String)
Saves the report.
Declaration Syntax
C#
public static void SaveReport(
    string fileName
)
Parameters
fileName (String)
Name of the file.


StartSession Method

StartSession Method
Namespaces ► Sitecore.Diagnostics ► Tracer ► StartSession()()()
Starts the session.
Declaration Syntax
C#
public static void StartSession()


TotalTime Property

TotalTime Property
Namespaces ► Sitecore.Diagnostics ► Tracer ► TotalTime
Gets the total time.
Declaration Syntax
C#
public static TimeSpan TotalTime { get; }
Value
The total time.


Warning Method

Warning Method
Namespaces ► Sitecore.Diagnostics ► Tracer ► Warning()()()
Members
Icon | Member | Description
 | Warning(Object) | Outputs the specified warning message.
 | Warning(Object, Object) | Outputs the specified warning message.


Warning Method (message)

Warning Method (message)
Namespaces ► Sitecore.Diagnostics ► Tracer ► Warning(Object)
Outputs the specified warning message.
Declaration Syntax
C#
public static void Warning(
    Object message
)
Parameters
message (Object)
The message.


Warning Method (message, details)

Warning Method (message, details)
Namespaces ► Sitecore.Diagnostics ► Tracer ► Warning(Object, Object)
Outputs the specified warning message.
Declaration Syntax
C#
public static void Warning(
    Object message,
    Object details
)
Parameters
message (Object)
The message.
details (Object)
The details.


Tracer.Worker Class

Tracer..::.Worker Class
Namespaces ► Sitecore.Diagnostics ► Tracer ► Tracer..::.Worker
Represents a Worker.
Declaration Syntax
C#
public class Worker : DiagnosticWorker
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Tracer..::.Worker()()() | Initializes a new instance of the Tracer..::.Worker class.
 | Add(Object, String) | Adds the specified message.
 | Add(Object, Object, String) | Adds the specified message.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportFileName()()() | Gets the name of the report file.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Indent | Gets or sets the indent.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from DiagnosticWorker.)
 | Packet | Gets the packet. (Inherited from DiagnosticWorker.)
 | RenderOnEndSession | Gets or sets a value indicating whether the Tracer..::.Worker renders the on end session.
 | SaveReport(String) | Saves the report. (Inherited from DiagnosticWorker.)
 | StartReport(String) | Starts the report. (Inherited from DiagnosticWorker.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalTime | Gets the total time.
Inheritance Hierarchy
Object
 | DiagnosticWorker
 |  | Tracer..::.Worker


Tracer.Worker Constructor

Tracer..::.Worker Constructor
Namespaces ► Sitecore.Diagnostics ► Tracer..::.Worker ► Tracer..::.Worker()()()
Initializes a new instance of the Tracer..::.Worker class.
Declaration Syntax
C#
public Worker()


Add Method

Add Method
Namespaces ► Sitecore.Diagnostics ► Tracer..::.Worker ► Add()()()
Members
Icon | Member | Description
 | Add(Object, String) | Adds the specified message.
 | Add(Object, Object, String) | Adds the specified message.


Add Method (message, details, elementName)

Add Method (message, details, elementName)
Namespaces ► Sitecore.Diagnostics ► Tracer..::.Worker ► Add(Object, Object, String)
Adds the specified message.
Declaration Syntax
C#
public XmlNode Add(
    Object message,
    Object details,
    string elementName
)
Parameters
message (Object)
The message.
details (Object)
The details.
elementName (String)
Name of the element.
Return Value


Add Method (message, elementName)

Add Method (message, elementName)
Namespaces ► Sitecore.Diagnostics ► Tracer..::.Worker ► Add(Object, String)
Adds the specified message.
Declaration Syntax
C#
public XmlNode Add(
    Object message,
    string elementName
)
Parameters
message (Object)
The message.
elementName (String)
Name of the element.
Return Value


GetReportFileName Method

GetReportFileName Method
Namespaces ► Sitecore.Diagnostics ► Tracer..::.Worker ► GetReportFileName()()()
Gets the name of the report file.
Declaration Syntax
C#
public static string GetReportFileName()
Return Value


Indent Property

Indent Property
Namespaces ► Sitecore.Diagnostics ► Tracer..::.Worker ► Indent
Gets or sets the indent.
Declaration Syntax
C#
public int Indent { get; set; }
Value
The indent.


RenderOnEndSession Property

RenderOnEndSession Property
Namespaces ► Sitecore.Diagnostics ► Tracer..::.Worker ► RenderOnEndSession
Gets or sets a value indicating whether the Tracer..::.Worker renders the on end session.
Declaration Syntax
C#
public bool RenderOnEndSession { get; set; }
Value
true if the Tracer..::.Worker renders the on end session; otherwise, false.


TotalTime Property

TotalTime Property
Namespaces ► Sitecore.Diagnostics ► Tracer..::.Worker ► TotalTime
Gets the total time.
Declaration Syntax
C#
public TimeSpan TotalTime { get; }
Value
The total time.


UnitTester Class

UnitTester Class
Namespaces ► Sitecore.Diagnostics ► UnitTester
Test related utility functions
Declaration Syntax
C#
public class UnitTester
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnitTester(Page) | Initializes a new instance of the UnitTester class.
 | UnitTester(Page, Boolean) | Initializes a new instance of the UnitTester class.
 | EndSection(Page) | Ends the section.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() | Initializes this instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Out(String) | Write message to output
 | ShowStatistics()()() | Show statistics
 | Silent | Gets or sets a value indicating whether this UnitTester is silent.
 | StartSection(String) | Starts the section.
 | StartSection(String, Boolean) | Starts the section.
 | StartTest(String) | Starts a named test.
 | Test(Boolean, String) | Tests the specified condition.
 | Test(Boolean, String, Boolean) | Tests the specified condition.
 | Test(Boolean, String, String) | Tests the specified condition.
 | Test(Boolean, String, String, Boolean) | Tests the specified condition.
 | TestAssigned(Object, Boolean, String, Boolean) | Tests the assigned.
 | TestBool(Boolean, Boolean, String) | Tests the bool.
 | TestCount(Int32, Int32, String) | Tests the count.
 | TestCount(Int32, Int32, String, String) | Tests the count.
 | TestEnum(Object, Object, String) | Tests the enum.
 | TestHead(String) | Tests the head.
 | TestIndex(Int32, Int32, String) | Tests the index.
 | TestIterCount(String, Int32, XPathNavigator) | Tests the iter count.
 | TestIterCount(String, Int32, XPathNavigator, Int32) | Tests the iter count.
 | TestString(String, String, String) | Tests the string.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UnitTester


UnitTester Constructor

UnitTester Constructor
Namespaces ► Sitecore.Diagnostics ► UnitTester ► UnitTester()()()
Members
Icon | Member | Description
 | UnitTester(Page) | Initializes a new instance of the UnitTester class.
 | UnitTester(Page, Boolean) | Initializes a new instance of the UnitTester class.


UnitTester Constructor (page)

UnitTester Constructor (page)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► UnitTester(Page)
Initializes a new instance of the UnitTester class.
Declaration Syntax
C#
public UnitTester(
    Page page
)
Parameters
page (Page)
The m_page.


UnitTester Constructor (page, detailedTiming)

UnitTester Constructor (page, detailedTiming)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► UnitTester(Page, Boolean)
Initializes a new instance of the UnitTester class.
Declaration Syntax
C#
public UnitTester(
    Page page,
    bool detailedTiming
)
Parameters
page (Page)
The page.
detailedTiming (Boolean)
if set to true this instance is detailed timing.


EndSection Method (page)

EndSection Method (page)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► EndSection(Page)
Ends the section.
Declaration Syntax
C#
public void EndSection(
    Page page
)
Parameters
page (Page)
The m_page.


Init Method

Init Method
Namespaces ► Sitecore.Diagnostics ► UnitTester ► Init()()()
Initializes this instance.
Declaration Syntax
C#
public void Init()


Out Method (message)

Out Method (message)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► Out(String)
Write message to output
Declaration Syntax
C#
public void Out(
    string message
)
Parameters
message (String)
The message.


ShowStatistics Method

ShowStatistics Method
Namespaces ► Sitecore.Diagnostics ► UnitTester ► ShowStatistics()()()
Show statistics
Declaration Syntax
C#
public void ShowStatistics()


Silent Property

Silent Property
Namespaces ► Sitecore.Diagnostics ► UnitTester ► Silent
Gets or sets a value indicating whether this UnitTester is silent.
Declaration Syntax
C#
public bool Silent { get; set; }
Value
true if silent; otherwise, false.


StartSection Method

StartSection Method
Namespaces ► Sitecore.Diagnostics ► UnitTester ► StartSection()()()
Members
Icon | Member | Description
 | StartSection(String) | Starts the section.
 | StartSection(String, Boolean) | Starts the section.


StartSection Method (description)

StartSection Method (description)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► StartSection(String)
Starts the section.
Declaration Syntax
C#
public void StartSection(
    string description
)
Parameters
description (String)
The description.


StartSection Method (description, timing)

StartSection Method (description, timing)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► StartSection(String, Boolean)
Starts the section.
Declaration Syntax
C#
public void StartSection(
    string description,
    bool timing
)
Parameters
description (String)
The description.
timing (Boolean)
if set to true this instance is timing.


StartTest Method (description)

StartTest Method (description)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► StartTest(String)
Starts a named test.
Declaration Syntax
C#
public void StartTest(
    string description
)
Parameters
description (String)
The description.


Test Method

Test Method
Namespaces ► Sitecore.Diagnostics ► UnitTester ► Test()()()
Members
Icon | Member | Description
 | Test(Boolean, String) | Tests the specified condition.
 | Test(Boolean, String, Boolean) | Tests the specified condition.
 | Test(Boolean, String, String) | Tests the specified condition.
 | Test(Boolean, String, String, Boolean) | Tests the specified condition.


Test Method (condition, description)

Test Method (condition, description)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► Test(Boolean, String)
Tests the specified condition.
Declaration Syntax
C#
public void Test(
    bool condition,
    string description
)
Parameters
condition (Boolean)
if set to true this instance is condition.
description (String)
The description.


Test Method (condition, description, fatal)

Test Method (condition, description, fatal)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► Test(Boolean, String, Boolean)
Tests the specified condition.
Declaration Syntax
C#
public void Test(
    bool condition,
    string description,
    bool fatal
)
Parameters
condition (Boolean)
if set to true this instance is condition.
description (String)
The description.
fatal (Boolean)
if set to true this instance is fatal.


Test Method (condition, description, timing)

Test Method (condition, description, timing)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► Test(Boolean, String, String)
Tests the specified condition.
Declaration Syntax
C#
public void Test(
    bool condition,
    string description,
    string timing
)
Parameters
condition (Boolean)
if set to true this instance is condition.
description (String)
The description.
timing (String)
The timing.


Test Method (condition, description, timing, fatal)

Test Method (condition, description, timing, fatal)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► Test(Boolean, String, String, Boolean)
Tests the specified condition.
Declaration Syntax
C#
public void Test(
    bool condition,
    string description,
    string timing,
    bool fatal
)
Parameters
condition (Boolean)
if set to true this instance is condition.
description (String)
The description.
timing (String)
The timing.
fatal (Boolean)
if set to true this instance is fatal.


TestAssigned Method (obj, expected, description, fatal)

TestAssigned Method (obj, expected, description, fatal)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► TestAssigned(Object, Boolean, String, Boolean)
Tests the assigned.
Declaration Syntax
C#
public void TestAssigned(
    Object obj,
    bool expected,
    string description,
    bool fatal
)
Parameters
obj (Object)
The object.
expected (Boolean)
if set to true this instance is expected.
description (String)
The description.
fatal (Boolean)
if set to true this instance is fatal.


TestBool Method (value, expected, description)

TestBool Method (value, expected, description)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► TestBool(Boolean, Boolean, String)
Tests the bool.
Declaration Syntax
C#
public void TestBool(
    bool value,
    bool expected,
    string description
)
Parameters
value (Boolean)
if set to true this instance is _value.
expected (Boolean)
if set to true this instance is expected.
description (String)
The description.


TestCount Method

TestCount Method
Namespaces ► Sitecore.Diagnostics ► UnitTester ► TestCount()()()
Members
Icon | Member | Description
 | TestCount(Int32, Int32, String) | Tests the count.
 | TestCount(Int32, Int32, String, String) | Tests the count.


TestCount Method (count, expected, description)

TestCount Method (count, expected, description)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► TestCount(Int32, Int32, String)
Tests the count.
Declaration Syntax
C#
public void TestCount(
    int count,
    int expected,
    string description
)
Parameters
count (Int32)
The count.
expected (Int32)
The expected.
description (String)
The description.


TestCount Method (count, expected, description, timing)

TestCount Method (count, expected, description, timing)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► TestCount(Int32, Int32, String, String)
Tests the count.
Declaration Syntax
C#
public void TestCount(
    int count,
    int expected,
    string description,
    string timing
)
Parameters
count (Int32)
The count.
expected (Int32)
The expected.
description (String)
The description.
timing (String)
The timing.


TestEnum Method (value, expected, description)

TestEnum Method (value, expected, description)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► TestEnum(Object, Object, String)
Tests the enum.
Declaration Syntax
C#
public void TestEnum(
    Object value,
    Object expected,
    string description
)
Parameters
value (Object)
The _value.
expected (Object)
The expected.
description (String)
The description.


TestHead Method (description)

TestHead Method (description)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► TestHead(String)
Tests the head.
Declaration Syntax
C#
public void TestHead(
    string description
)
Parameters
description (String)
The description.


TestIndex Method (index, expected, description)

TestIndex Method (index, expected, description)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► TestIndex(Int32, Int32, String)
Tests the index.
Declaration Syntax
C#
public void TestIndex(
    int index,
    int expected,
    string description
)
Parameters
index (Int32)
The index.
expected (Int32)
The expected.
description (String)
The description.


TestIterCount Method

TestIterCount Method
Namespaces ► Sitecore.Diagnostics ► UnitTester ► TestIterCount()()()
Members
Icon | Member | Description
 | TestIterCount(String, Int32, XPathNavigator) | Tests the iter count.
 | TestIterCount(String, Int32, XPathNavigator, Int32) | Tests the iter count.


TestIterCount Method (xpath, expected, nav)

TestIterCount Method (xpath, expected, nav)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► TestIterCount(String, Int32, XPathNavigator)
Tests the iter count.
Declaration Syntax
C#
public void TestIterCount(
    string xpath,
    int expected,
    XPathNavigator nav
)
Parameters
xpath (String)
The xpath.
expected (Int32)
The expected.
nav (XPathNavigator)
The nav.


TestIterCount Method (xpath, expected, nav, iterations)

TestIterCount Method (xpath, expected, nav, iterations)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► TestIterCount(String, Int32, XPathNavigator, Int32)
Tests the iter count.
Declaration Syntax
C#
public void TestIterCount(
    string xpath,
    int expected,
    XPathNavigator nav,
    int iterations
)
Parameters
xpath (String)
The xpath.
expected (Int32)
The expected.
nav (XPathNavigator)
The nav.
iterations (Int32)
The iterations.


TestString Method (value, expected, description)

TestString Method (value, expected, description)
Namespaces ► Sitecore.Diagnostics ► UnitTester ► TestString(String, String, String)
Tests the string.
Declaration Syntax
C#
public void TestString(
    string value,
    string expected,
    string description
)
Parameters
value (String)
The _value.
expected (String)
The expected.
description (String)
The description.


Sitecore.Diagnostics.Events Namespace

Sitecore.Diagnostics.Events Namespace
Namespaces ► Sitecore.Diagnostics.Events
Declaration Syntax
C#
namespace Sitecore.Diagnostics.Events
Types
All Types Interfaces
Icon | Type | Description
 | IEventHandler | Interface for general event handlers.
 | IExceptionEventHandler | Interface for exception event handlers.
 | IItemEventHandler | Interface for item event handlers.
 | IMediaEventHandler | Interface for media event handlers.
 | IPublishingEventHandler | Interface for publishing event handler.
 | ITraceEventHandler | Interface for trace event handlers.


IEventHandler Interface

IEventHandler Interface
Namespaces ► Sitecore.Diagnostics.Events ► IEventHandler
Interface for general event handlers.
Declaration Syntax
C#
public interface IEventHandler
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HandleEvent(String, Hashtable, NameValueCollection) | Handle an event


HandleEvent Method (name, additionalInfo, configSettings)

HandleEvent Method (name, additionalInfo, configSettings)
Namespaces ► Sitecore.Diagnostics.Events ► IEventHandler ► HandleEvent(String, Hashtable, NameValueCollection)
Handle an event
Declaration Syntax
C#
void HandleEvent(
    string name,
    Hashtable additionalInfo,
    NameValueCollection configSettings
)
Parameters
name (String)
The name.
additionalInfo (Hashtable)
The additional info.
configSettings (NameValueCollection)
The config settings.


IExceptionEventHandler Interface

IExceptionEventHandler Interface
Namespaces ► Sitecore.Diagnostics.Events ► IExceptionEventHandler
Interface for exception event handlers.
Declaration Syntax
C#
public interface IExceptionEventHandler
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HandleException(Exception, Hashtable, NameValueCollection) | Handles an exception.


HandleException Method (ex, additionalInfo, configSettings)

HandleException Method (ex, additionalInfo, configSettings)
Namespaces ► Sitecore.Diagnostics.Events ► IExceptionEventHandler ► HandleException(Exception, Hashtable, NameValueCollection)
Handles an exception.
Declaration Syntax
C#
void HandleException(
    Exception ex,
    Hashtable additionalInfo,
    NameValueCollection configSettings
)
Parameters
ex (Exception)
The ex.
additionalInfo (Hashtable)
The additional info.
configSettings (NameValueCollection)
The config settings.


IItemEventHandler Interface

IItemEventHandler Interface
Namespaces ► Sitecore.Diagnostics.Events ► IItemEventHandler
Interface for item event handlers.
Declaration Syntax
C#
public interface IItemEventHandler
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HandleBeforeClientSave(XmlNode, NameValueCollection) | An item is being saved by the client (ie. via a xml fragment)
 | HandleCopied(Item, Item, NameValueCollection) | An item has been copied
 | HandleCreated(Item, NameValueCollection) | An item has been created
 | HandleDeleted(Item, Item, NameValueCollection) | An item has been deleted
 | HandleMoved(Item, Item, NameValueCollection) | An item has been moved
 | HandleRenamed(Item, String, NameValueCollection) | An item has been renamed
 | HandleSaved(Item, NameValueCollection) | An item has been saved


HandleBeforeClientSave Method (dataNode, configSettings)

HandleBeforeClientSave Method (dataNode, configSettings)
Namespaces ► Sitecore.Diagnostics.Events ► IItemEventHandler ► HandleBeforeClientSave(XmlNode, NameValueCollection)
An item is being saved by the client (ie. via a xml fragment)
Declaration Syntax
C#
void HandleBeforeClientSave(
    XmlNode dataNode,
    NameValueCollection configSettings
)
Parameters
dataNode (XmlNode)
The data node.
configSettings (NameValueCollection)
The config settings.


HandleCopied Method (itm, source, configSettings)

HandleCopied Method (itm, source, configSettings)
Namespaces ► Sitecore.Diagnostics.Events ► IItemEventHandler ► HandleCopied(Item, Item, NameValueCollection)
An item has been copied
Declaration Syntax
C#
void HandleCopied(
    Item itm,
    Item source,
    NameValueCollection configSettings
)
Parameters
itm (Item)
The itm.
source (Item)
The source.
configSettings (NameValueCollection)
The config settings.


HandleCreated Method (itm, configSettings)

HandleCreated Method (itm, configSettings)
Namespaces ► Sitecore.Diagnostics.Events ► IItemEventHandler ► HandleCreated(Item, NameValueCollection)
An item has been created
Declaration Syntax
C#
void HandleCreated(
    Item itm,
    NameValueCollection configSettings
)
Parameters
itm (Item)
The itm.
configSettings (NameValueCollection)
The config settings.


HandleDeleted Method (itm, oldParent, configSettings)

HandleDeleted Method (itm, oldParent, configSettings)
Namespaces ► Sitecore.Diagnostics.Events ► IItemEventHandler ► HandleDeleted(Item, Item, NameValueCollection)
An item has been deleted
Declaration Syntax
C#
void HandleDeleted(
    Item itm,
    Item oldParent,
    NameValueCollection configSettings
)
Parameters
itm (Item)
The itm.
oldParent (Item)
The old parent.
configSettings (NameValueCollection)
The config settings.


HandleMoved Method (itm, oldParent, configSettings)

HandleMoved Method (itm, oldParent, configSettings)
Namespaces ► Sitecore.Diagnostics.Events ► IItemEventHandler ► HandleMoved(Item, Item, NameValueCollection)
An item has been moved
Declaration Syntax
C#
void HandleMoved(
    Item itm,
    Item oldParent,
    NameValueCollection configSettings
)
Parameters
itm (Item)
The itm.
oldParent (Item)
The old parent.
configSettings (NameValueCollection)
The config settings.


HandleRenamed Method (itm, oldName, configSettings)

HandleRenamed Method (itm, oldName, configSettings)
Namespaces ► Sitecore.Diagnostics.Events ► IItemEventHandler ► HandleRenamed(Item, String, NameValueCollection)
An item has been renamed
Declaration Syntax
C#
void HandleRenamed(
    Item itm,
    string oldName,
    NameValueCollection configSettings
)
Parameters
itm (Item)
The itm.
oldName (String)
The old name.
configSettings (NameValueCollection)
The config settings.


HandleSaved Method (itm, configSettings)

HandleSaved Method (itm, configSettings)
Namespaces ► Sitecore.Diagnostics.Events ► IItemEventHandler ► HandleSaved(Item, NameValueCollection)
An item has been saved
Declaration Syntax
C#
void HandleSaved(
    Item itm,
    NameValueCollection configSettings
)
Parameters
itm (Item)
The itm.
configSettings (NameValueCollection)
The config settings.


IMediaEventHandler Interface

IMediaEventHandler Interface
Namespaces ► Sitecore.Diagnostics.Events ► IMediaEventHandler
Interface for media event handlers.
Declaration Syntax
C#
public interface IMediaEventHandler
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HandleUploaded(Item, NameValueCollection) | A media item has been uploaded


HandleUploaded Method (itm, configSettings)

HandleUploaded Method (itm, configSettings)
Namespaces ► Sitecore.Diagnostics.Events ► IMediaEventHandler ► HandleUploaded(Item, NameValueCollection)
A media item has been uploaded
Declaration Syntax
C#
void HandleUploaded(
    Item itm,
    NameValueCollection configSettings
)
Parameters
itm (Item)
The itm.
configSettings (NameValueCollection)
The config settings.


IPublishingEventHandler Interface

IPublishingEventHandler Interface
Namespaces ► Sitecore.Diagnostics.Events ► IPublishingEventHandler
Interface for publishing event handler.
Declaration Syntax
C#
public interface IPublishingEventHandler
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HandlePublishDone(IPublishingRequest, NameValueCollection) | A publishing operation has finished


HandlePublishDone Method (request, configSettings)

HandlePublishDone Method (request, configSettings)
Namespaces ► Sitecore.Diagnostics.Events ► IPublishingEventHandler ► HandlePublishDone(IPublishingRequest, NameValueCollection)
A publishing operation has finished
Declaration Syntax
C#
void HandlePublishDone(
    IPublishingRequest request,
    NameValueCollection configSettings
)
Parameters
request (IPublishingRequest)
The request.
configSettings (NameValueCollection)
The config settings.


ITraceEventHandler Interface

ITraceEventHandler Interface
Namespaces ► Sitecore.Diagnostics.Events ► ITraceEventHandler
Interface for trace event handlers.
Declaration Syntax
C#
public interface ITraceEventHandler
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HandleError(String, Hashtable, NameValueCollection) | An error message has been traced.
 | HandleTrace(String, Hashtable, NameValueCollection) | A trace message has been traced.
 | HandleWarning(String, Hashtable, NameValueCollection) | A warning message has been traced.


HandleError Method (message, additionalInfo, configSettings)

HandleError Method (message, additionalInfo, configSettings)
Namespaces ► Sitecore.Diagnostics.Events ► ITraceEventHandler ► HandleError(String, Hashtable, NameValueCollection)
An error message has been traced.
Declaration Syntax
C#
void HandleError(
    string message,
    Hashtable additionalInfo,
    NameValueCollection configSettings
)
Parameters
message (String)
The message.
additionalInfo (Hashtable)
The additional info.
configSettings (NameValueCollection)
The config settings.


HandleTrace Method (message, additionalInfo, configSettings)

HandleTrace Method (message, additionalInfo, configSettings)
Namespaces ► Sitecore.Diagnostics.Events ► ITraceEventHandler ► HandleTrace(String, Hashtable, NameValueCollection)
A trace message has been traced.
Declaration Syntax
C#
void HandleTrace(
    string message,
    Hashtable additionalInfo,
    NameValueCollection configSettings
)
Parameters
message (String)
The message.
additionalInfo (Hashtable)
The additional info.
configSettings (NameValueCollection)
The config settings.


HandleWarning Method (message, additionalInfo, configSettings)

HandleWarning Method (message, additionalInfo, configSettings)
Namespaces ► Sitecore.Diagnostics.Events ► ITraceEventHandler ► HandleWarning(String, Hashtable, NameValueCollection)
A warning message has been traced.
Declaration Syntax
C#
void HandleWarning(
    string message,
    Hashtable additionalInfo,
    NameValueCollection configSettings
)
Parameters
message (String)
The message.
additionalInfo (Hashtable)
The additional info.
configSettings (NameValueCollection)
The config settings.


Sitecore.Diagnostics.PerformanceCounters Namespace

Sitecore.Diagnostics.PerformanceCounters Namespace
Namespaces ► Sitecore.Diagnostics.PerformanceCounters
Declaration Syntax
C#
namespace Sitecore.Diagnostics.PerformanceCounters
Types
All Types Classes
Icon | Type | Description
 | CacheCounters | Represents the cache counters.
 | Categories |
 | ContextCounters | Represents the context counters.
 | DataCounters | Represents the data counters.
 | EventCounters | Represents the event counters.
 | ExceptionCounters | Represents the exception counters.
 | GlobalizationCounters | Represents a GlobalizationCounters.
 | IOCounters | Represents the IO counters.
 | JobCounters | Represents the job counters.
 | LinkCounters | Represents the link counters.
 | LoggingCounters | Represents the logging counters.
 | MediaCounters | Represents the pipeline counters.
 | PerformanceCounter | Represents a performance counter.
 | PipelineCounters | Represents the pipeline counters.
 | PublishingCounters | Represents the publishing counters.
 | ReflectionCounters | Represents the reflection counters.
 | RenderingCounters | Represents the rendering counters.
 | SecurityCounters | Represents the security counters.
 | ShadowCounters | Represents the shadow counters.
 | TaskCounters | Represents the task counters.
 | ThreadingCounters | Represents the threading counters.
 | WorkflowCounters | Represents a workflow counters.
 | XmlCounters | Represents the xml counters.


CacheCounters Class

CacheCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters
Represents the cache counters.
Declaration Syntax
C#
public static class CacheCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CacheClearings | Gets the total number of times that a Cache has been cleared.
 | CacheHits | Gets the total number of cache hits for all caches.
 | CacheMisses | Gets the total number of cache misses for all caches.
 | DataCacheClearings | Gets the number of times that instances of a DataCache has been cleared.
 | DataCacheHits | Gets the number of cache hits in a DataCache.
 | DataCacheMisses | Gets the number of cache misses in a DataCache.
 | HtmlCacheClearings | Gets the number of times that instances of a HtmlCache has been cleared.
 | HtmlCacheHits | Gets the number of cache hits in a HtmlCache.
 | HtmlCacheMisses | Gets the number of cache misses in a HtmlCache.
 | PathCacheClearings | Gets the number of times that instances of a PathCache has been cleared.
 | PathCacheHits | Gets the number of cache hits in a PathCache.
 | PathCacheMisses | Gets the number of cache misses in a PathCache.
 | RegistryCacheClearings | Gets the number of times that instances of a RegistryCache has been cleared.
 | RegistryCacheHits | Gets the number of cache hits in a RegistryCache.
 | RegistryCacheMisses | Gets the number of cache misses in a RegistryCache.
 | ViewStateCacheClearings | Gets the number of times that instances of a ViewStateCache has been cleared.
 | ViewStateCacheHits | Gets the number of cache hits in a ViewStateCache.
 | ViewStateCacheMisses | Gets the number of cache misses in a ViewStateCache.
 | XslCacheClearings | Gets the number of times that instances of a XslCache has been cleared.
 | XslCacheHits | Gets the number of cache hits in a XslCache.
 | XslCacheMisses | Gets the number of cache misses in a XslCache.
Inheritance Hierarchy
Object
CacheCounters


CacheClearings Property

CacheClearings Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► CacheClearings
Gets the total number of times that a Cache has been cleared.
Declaration Syntax
C#
public static PerformanceCounter CacheClearings { get; }
Value
The cache clearings.


CacheHits Property

CacheHits Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► CacheHits
Gets the total number of cache hits for all caches.
Declaration Syntax
C#
public static PerformanceCounter CacheHits { get; }
Value
The cache hits.


CacheMisses Property

CacheMisses Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► CacheMisses
Gets the total number of cache misses for all caches.
Declaration Syntax
C#
public static PerformanceCounter CacheMisses { get; }
Value
The cache misses.


DataCacheClearings Property

DataCacheClearings Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► DataCacheClearings
Gets the number of times that instances of a DataCache has been cleared.
Declaration Syntax
C#
public static PerformanceCounter DataCacheClearings { get; }
Value
The data cache clearings.


DataCacheHits Property

DataCacheHits Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► DataCacheHits
Gets the number of cache hits in a DataCache.
Declaration Syntax
C#
public static PerformanceCounter DataCacheHits { get; }
Value
The data cache hits.


DataCacheMisses Property

DataCacheMisses Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► DataCacheMisses
Gets the number of cache misses in a DataCache.
Declaration Syntax
C#
public static PerformanceCounter DataCacheMisses { get; }
Value
The data cache misses.


HtmlCacheClearings Property

HtmlCacheClearings Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► HtmlCacheClearings
Gets the number of times that instances of a HtmlCache has been cleared.
Declaration Syntax
C#
public static PerformanceCounter HtmlCacheClearings { get; }
Value
The HTML cache clearings.


HtmlCacheHits Property

HtmlCacheHits Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► HtmlCacheHits
Gets the number of cache hits in a HtmlCache.
Declaration Syntax
C#
public static PerformanceCounter HtmlCacheHits { get; }
Value
The HTML cache hits.


HtmlCacheMisses Property

HtmlCacheMisses Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► HtmlCacheMisses
Gets the number of cache misses in a HtmlCache.
Declaration Syntax
C#
public static PerformanceCounter HtmlCacheMisses { get; }
Value
The HTML cache misses.


PathCacheClearings Property

PathCacheClearings Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► PathCacheClearings
Gets the number of times that instances of a PathCache has been cleared.
Declaration Syntax
C#
public static PerformanceCounter PathCacheClearings { get; }
Value
The path cache clearings.


PathCacheHits Property

PathCacheHits Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► PathCacheHits
Gets the number of cache hits in a PathCache.
Declaration Syntax
C#
public static PerformanceCounter PathCacheHits { get; }
Value
The path cache hits.


PathCacheMisses Property

PathCacheMisses Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► PathCacheMisses
Gets the number of cache misses in a PathCache.
Declaration Syntax
C#
public static PerformanceCounter PathCacheMisses { get; }
Value
The path cache misses.


RegistryCacheClearings Property

RegistryCacheClearings Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► RegistryCacheClearings
Gets the number of times that instances of a RegistryCache has been cleared.
Declaration Syntax
C#
public static PerformanceCounter RegistryCacheClearings { get; }
Value
The registry cache clearings.


RegistryCacheHits Property

RegistryCacheHits Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► RegistryCacheHits
Gets the number of cache hits in a RegistryCache.
Declaration Syntax
C#
public static PerformanceCounter RegistryCacheHits { get; }
Value
The registry cache hits.


RegistryCacheMisses Property

RegistryCacheMisses Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► RegistryCacheMisses
Gets the number of cache misses in a RegistryCache.
Declaration Syntax
C#
public static PerformanceCounter RegistryCacheMisses { get; }
Value
The registry cache misses.


ViewStateCacheClearings Property

ViewStateCacheClearings Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► ViewStateCacheClearings
Gets the number of times that instances of a ViewStateCache has been cleared.
Declaration Syntax
C#
public static PerformanceCounter ViewStateCacheClearings { get; }
Value
The view state cache clearings.


ViewStateCacheHits Property

ViewStateCacheHits Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► ViewStateCacheHits
Gets the number of cache hits in a ViewStateCache.
Declaration Syntax
C#
public static PerformanceCounter ViewStateCacheHits { get; }
Value
The view state cache hits.


ViewStateCacheMisses Property

ViewStateCacheMisses Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► ViewStateCacheMisses
Gets the number of cache misses in a ViewStateCache.
Declaration Syntax
C#
public static PerformanceCounter ViewStateCacheMisses { get; }
Value
The view state cache misses.


XslCacheClearings Property

XslCacheClearings Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► XslCacheClearings
Gets the number of times that instances of a XslCache has been cleared.
Declaration Syntax
C#
public static PerformanceCounter XslCacheClearings { get; }
Value
The XSL cache clearings.


XslCacheHits Property

XslCacheHits Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► XslCacheHits
Gets the number of cache hits in a XslCache.
Declaration Syntax
C#
public static PerformanceCounter XslCacheHits { get; }
Value
The XSL cache hits.


XslCacheMisses Property

XslCacheMisses Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► CacheCounters ► XslCacheMisses
Gets the number of cache misses in a XslCache.
Declaration Syntax
C#
public static PerformanceCounter XslCacheMisses { get; }
Value
The XSL cache misses.


Categories Class

Categories Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► Categories
Declaration Syntax
C#
public class Categories
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Categories()()() | Initializes a new instance of the Categories class
 | Caching | "Sitecore.Caching"
 | Data | "Sitecore.Data"
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Jobs | "Sitecore.Jobs"
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Presentation | "Sitecore.Presentation"
 | Security | "Sitecore.Security"
 | System | "Sitecore.System"
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Categories


Categories Constructor

Categories Constructor
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► Categories ► Categories()()()
Initializes a new instance of the Categories class
Declaration Syntax
C#
public Categories()


Caching Field

Caching Field
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► Categories ► Caching
"Sitecore.Caching"
Declaration Syntax
C#
public const string Caching


Data Field

Data Field
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► Categories ► Data
"Sitecore.Data"
Declaration Syntax
C#
public const string Data


Jobs Field

Jobs Field
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► Categories ► Jobs
"Sitecore.Jobs"
Declaration Syntax
C#
public const string Jobs


Presentation Field

Presentation Field
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► Categories ► Presentation
"Sitecore.Presentation"
Declaration Syntax
C#
public const string Presentation


Security Field

Security Field
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► Categories ► Security
"Sitecore.Security"
Declaration Syntax
C#
public const string Security


System Field

System Field
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► Categories ► System
"Sitecore.System"
Declaration Syntax
C#
public const string System


ContextCounters Class

ContextCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ContextCounters
Represents the context counters.
Declaration Syntax
C#
public static class ContextCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SiteChanged | Gets the total number of times the active site has been changed by the API.
 | ThreadDataAccessed | Gets the total number of times the local thread data has been accessed.
Inheritance Hierarchy
Object
ContextCounters


SiteChanged Property

SiteChanged Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ContextCounters ► SiteChanged
Gets the total number of times the active site has been changed by the API.
Declaration Syntax
C#
public static PerformanceCounter SiteChanged { get; }
Value
The site changed.


ThreadDataAccessed Property

ThreadDataAccessed Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ContextCounters ► ThreadDataAccessed
Gets the total number of times the local thread data has been accessed.
Declaration Syntax
C#
public static PerformanceCounter ThreadDataAccessed { get; }
Value
The thread data accessed.


DataCounters Class

DataCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► DataCounters
Represents the data counters.
Declaration Syntax
C#
public static class DataCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClientDataReads | Gets the 'client data reads' counter.
 | ClientDataWrites | Gets the 'client data writes' counter.
 | ItemsAccessed | Gets the number of items that have been accessed.
 | PhysicalReads | Gets the number of read operations that have been performed against the physical storage medium (typically a RDBMS).
 | PhysicalWrites | Gets the number of write operations that have been performed against the physical storage medium (typically a RDBMS).
Inheritance Hierarchy
Object
DataCounters


ClientDataReads Property

ClientDataReads Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► DataCounters ► ClientDataReads
Gets the 'client data reads' counter.
Declaration Syntax
C#
public static PerformanceCounter ClientDataReads { get; }
Value
The counter.


ClientDataWrites Property

ClientDataWrites Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► DataCounters ► ClientDataWrites
Gets the 'client data writes' counter.
Declaration Syntax
C#
public static PerformanceCounter ClientDataWrites { get; }
Value
The counter.


ItemsAccessed Property

ItemsAccessed Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► DataCounters ► ItemsAccessed
Gets the number of items that have been accessed.
Declaration Syntax
C#
public static PerformanceCounter ItemsAccessed { get; }
Value
The items accessed.


PhysicalReads Property

PhysicalReads Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► DataCounters ► PhysicalReads
Gets the number of read operations that have been performed against the physical storage medium (typically a RDBMS).
Declaration Syntax
C#
public static PerformanceCounter PhysicalReads { get; }
Value
The physical reads.


PhysicalWrites Property

PhysicalWrites Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► DataCounters ► PhysicalWrites
Gets the number of write operations that have been performed against the physical storage medium (typically a RDBMS).
Declaration Syntax
C#
public static PerformanceCounter PhysicalWrites { get; }
Value
The physical writes.


EventCounters Class

EventCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► EventCounters
Represents the event counters.
Declaration Syntax
C#
public static class EventCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EventsRaised | Gets the total number of events that have been raised by the API.
Inheritance Hierarchy
Object
EventCounters


EventsRaised Property

EventsRaised Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► EventCounters ► EventsRaised
Gets the total number of events that have been raised by the API.
Declaration Syntax
C#
public static PerformanceCounter EventsRaised { get; }
Value
The events raised.


ExceptionCounters Class

ExceptionCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ExceptionCounters
Represents the exception counters.
Declaration Syntax
C#
public static class ExceptionCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExceptionsThrown | Gets the total number of exceptions thrown by the API.
Inheritance Hierarchy
Object
ExceptionCounters


ExceptionsThrown Property

ExceptionsThrown Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ExceptionCounters ► ExceptionsThrown
Gets the total number of exceptions thrown by the API.
Declaration Syntax
C#
public static PerformanceCounter ExceptionsThrown { get; }
Value
The exceptions thrown.


GlobalizationCounters Class

GlobalizationCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► GlobalizationCounters
Represents a GlobalizationCounters.
Declaration Syntax
C#
public static class GlobalizationCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TextsTranslated | Gets the total number of texts that have been translated.
 | TranslateFailed | Gets the total number of times a translate operation has failed (ie. the text was not in the dictionary).
Inheritance Hierarchy
Object
GlobalizationCounters


TextsTranslated Property

TextsTranslated Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► GlobalizationCounters ► TextsTranslated
Gets the total number of texts that have been translated.
Declaration Syntax
C#
public static PerformanceCounter TextsTranslated { get; }
Value
The texts translated.


TranslateFailed Property

TranslateFailed Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► GlobalizationCounters ► TranslateFailed
Gets the total number of times a translate operation has failed (ie. the text was not in the dictionary).
Declaration Syntax
C#
public static PerformanceCounter TranslateFailed { get; }
Value
The translate failed.


IOCounters Class

IOCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► IOCounters
Represents the IO counters.
Declaration Syntax
C#
public static class IOCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FileWatcherEvents | Gets the total number of file watcher events that have been handled by the API.
Inheritance Hierarchy
Object
IOCounters


FileWatcherEvents Property

FileWatcherEvents Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► IOCounters ► FileWatcherEvents
Gets the total number of file watcher events that have been handled by the API.
Declaration Syntax
C#
public static PerformanceCounter FileWatcherEvents { get; }
Value
The file watcher events.


JobCounters Class

JobCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► JobCounters
Represents the job counters.
Declaration Syntax
C#
public static class JobCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | JobsExecuted | Gets the total number of jobs that have been executed.
Inheritance Hierarchy
Object
JobCounters


JobsExecuted Property

JobsExecuted Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► JobCounters ► JobsExecuted
Gets the total number of jobs that have been executed.
Declaration Syntax
C#
public static PerformanceCounter JobsExecuted { get; }
Value
The jobs executed.


LinkCounters Class

LinkCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► LinkCounters
Represents the link counters.
Declaration Syntax
C#
public static class LinkCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DataRead | Gets the total number of read operations that have been performed against the link database.
 | DataUpdated | Gets the total number of update operations that have been performed against the link database.
 | FieldsExamined | Gets the total number of fields that have been scanned for links.
Inheritance Hierarchy
Object
LinkCounters


DataRead Property

DataRead Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► LinkCounters ► DataRead
Gets the total number of read operations that have been performed against the link database.
Declaration Syntax
C#
public static PerformanceCounter DataRead { get; }
Value
The data read.


DataUpdated Property

DataUpdated Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► LinkCounters ► DataUpdated
Gets the total number of update operations that have been performed against the link database.
Declaration Syntax
C#
public static PerformanceCounter DataUpdated { get; }
Value
The data updated.


FieldsExamined Property

FieldsExamined Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► LinkCounters ► FieldsExamined
Gets the total number of fields that have been scanned for links.
Declaration Syntax
C#
public static PerformanceCounter FieldsExamined { get; }
Value
The fields examined.


LoggingCounters Class

LoggingCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► LoggingCounters
Represents the logging counters.
Declaration Syntax
C#
public static class LoggingCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AuditsLogged | Gets the number of audit messages that have been sent to the log.
 | ErrorsLogged | Gets the number of error messages that have been sent to the log.
 | FatalsLogged | Gets the number of fatal messages that have been sent to the log.
 | InformationsLogged | Gets the number of information messages that have been sent to the log.
 | WarningsLogged | Gets the number of warning messages that have been sent to the log.
Inheritance Hierarchy
Object
LoggingCounters


AuditsLogged Property

AuditsLogged Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► LoggingCounters ► AuditsLogged
Gets the number of audit messages that have been sent to the log.
Declaration Syntax
C#
public static PerformanceCounter AuditsLogged { get; }
Value
The audits logged.


ErrorsLogged Property

ErrorsLogged Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► LoggingCounters ► ErrorsLogged
Gets the number of error messages that have been sent to the log.
Declaration Syntax
C#
public static PerformanceCounter ErrorsLogged { get; }
Value
The errors logged.


FatalsLogged Property

FatalsLogged Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► LoggingCounters ► FatalsLogged
Gets the number of fatal messages that have been sent to the log.
Declaration Syntax
C#
public static PerformanceCounter FatalsLogged { get; }
Value
The fatals logged.


InformationsLogged Property

InformationsLogged Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► LoggingCounters ► InformationsLogged
Gets the number of information messages that have been sent to the log.
Declaration Syntax
C#
public static PerformanceCounter InformationsLogged { get; }
Value
The informations logged.


WarningsLogged Property

WarningsLogged Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► LoggingCounters ► WarningsLogged
Gets the number of warning messages that have been sent to the log.
Declaration Syntax
C#
public static PerformanceCounter WarningsLogged { get; }
Value
The warnings logged.


MediaCounters Class

MediaCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► MediaCounters
Represents the pipeline counters.
Declaration Syntax
C#
public static class MediaCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FastMediaCacheHits | Obsolete. Gets the number of cache hits in the fast media cache.
 | FastMediaCacheMisses | Obsolete. Gets the number of cache misses in the fast media cache.
 | MediaCacheHits | Gets the number of cache hits in the media cache.
 | MediaCacheMisses | Gets the number of cache misses in the media cache.
 | StandardMediaCacheHits | Obsolete. Gets the number of cache hits in the standard media cache.
 | StandardMediaCacheMisses | Obsolete. Gets the number of cache misses in the standard media cache.
Inheritance Hierarchy
Object
MediaCounters


FastMediaCacheHits Property

FastMediaCacheHits Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► MediaCounters ► FastMediaCacheHits
Gets the number of cache hits in the fast media cache.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static PerformanceCounter FastMediaCacheHits { get; }
Value
The number of cache hits.


FastMediaCacheMisses Property

FastMediaCacheMisses Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► MediaCounters ► FastMediaCacheMisses
Gets the number of cache misses in the fast media cache.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static PerformanceCounter FastMediaCacheMisses { get; }
Value
The number of cache misses.


MediaCacheHits Property

MediaCacheHits Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► MediaCounters ► MediaCacheHits
Gets the number of cache hits in the media cache.
Declaration Syntax
C#
public static PerformanceCounter MediaCacheHits { get; }
Value
The number of cache hits.


MediaCacheMisses Property

MediaCacheMisses Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► MediaCounters ► MediaCacheMisses
Gets the number of cache misses in the media cache.
Declaration Syntax
C#
public static PerformanceCounter MediaCacheMisses { get; }
Value
The number of cache misses.


StandardMediaCacheHits Property

StandardMediaCacheHits Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► MediaCounters ► StandardMediaCacheHits
Gets the number of cache hits in the standard media cache.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static PerformanceCounter StandardMediaCacheHits { get; }
Value
The number of cache hits.


StandardMediaCacheMisses Property

StandardMediaCacheMisses Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► MediaCounters ► StandardMediaCacheMisses
Gets the number of cache misses in the standard media cache.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static PerformanceCounter StandardMediaCacheMisses { get; }
Value
The number of cache misses.


PerformanceCounter Class

PerformanceCounter Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter
Represents a performance counter.
Declaration Syntax
C#
public class PerformanceCounter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PerformanceCounter(String, String) | Constructs an instance of PerformanceCounter
 | PerformanceCounter(String, String, Boolean) | Constructs an instance of PerformanceCounter
 | Category | Gets the category.
 | Decrement()()() | Decrements the counter.
 | Enabled | Gets a value indicating whether this PerformanceCounter is enabled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstanceName()()() | Gets the name of the instance.
 | GetRawValue(String, String) | Gets the raw value of the specified counter.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Increment()()() | Increments this instance.
 | IncrementBy(Int32) | Increments this instance by the specified amount.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Reset()()() | Resets this instance.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | Value | Gets the value.
Inheritance Hierarchy
Object
PerformanceCounter


PerformanceCounter Constructor

PerformanceCounter Constructor
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter ► PerformanceCounter()()()
Members
Icon | Member | Description
 | PerformanceCounter(String, String) | Constructs an instance of PerformanceCounter
 | PerformanceCounter(String, String, Boolean) | Constructs an instance of PerformanceCounter


PerformanceCounter Constructor (counterName, category)

PerformanceCounter Constructor (counterName, category)
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter ► PerformanceCounter(String, String)
Constructs an instance of PerformanceCounter
Declaration Syntax
C#
public PerformanceCounter(
    string counterName,
    string category
)
Parameters
counterName (String)
Name of the counter.
category (String)
The category.


PerformanceCounter Constructor (counterName, category, reset)

PerformanceCounter Constructor (counterName, category, reset)
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter ► PerformanceCounter(String, String, Boolean)
Constructs an instance of PerformanceCounter
Declaration Syntax
C#
public PerformanceCounter(
    string counterName,
    string category,
    bool reset
)
Parameters
counterName (String)
Name of the counter.
category (String)
The category.
reset (Boolean)
if set to true, the counter will be reset before the first usage.


Category Property

Category Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter ► Category
Gets the category.
Declaration Syntax
C#
public string Category { get; }
Value
The category.


Decrement Method

Decrement Method
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter ► Decrement()()()
Decrements the counter.
Declaration Syntax
C#
public long Decrement()


Enabled Property

Enabled Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter ► Enabled
Gets a value indicating whether this PerformanceCounter is enabled.
Declaration Syntax
C#
public bool Enabled { get; }
Value
true if enabled; otherwise, false.


GetInstanceName Method

GetInstanceName Method
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter ► GetInstanceName()()()
Gets the name of the instance.
Declaration Syntax
C#
public static string GetInstanceName()
Return Value
The instance name.


GetRawValue Method (category, counterName)

GetRawValue Method (category, counterName)
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter ► GetRawValue(String, String)
Gets the raw value of the specified counter.
Declaration Syntax
C#
public static long GetRawValue(
    string category,
    string counterName
)
Parameters
category (String)
The category.
counterName (String)
Name of the counter.
Return Value


Increment Method

Increment Method
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter ► Increment()()()
Increments this instance.
Declaration Syntax
C#
public long Increment()
Return Value


IncrementBy Method (amount)

IncrementBy Method (amount)
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter ► IncrementBy(Int32)
Increments this instance by the specified amount.
Declaration Syntax
C#
public long IncrementBy(
    int amount
)
Parameters
amount (Int32)
The amount.
Return Value


Name Property

Name Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Reset Method

Reset Method
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter ► Reset()()()
Resets this instance.
Declaration Syntax
C#
public void Reset()


ToString Method

ToString Method
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Value Property

Value Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PerformanceCounter ► Value
Gets the value.
Declaration Syntax
C#
public long Value { get; }
Value
The value.


PipelineCounters Class

PipelineCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PipelineCounters
Represents the pipeline counters.
Declaration Syntax
C#
public static class PipelineCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PipelinesAborted | Gets the total number of times a pipeline was aborted.
 | PipelinesExecuted | Gets the total number of times a pipeline was executed.
 | ProcessorsExecuted | Gets the total number of processors that have been executed.
Inheritance Hierarchy
Object
PipelineCounters


PipelinesAborted Property

PipelinesAborted Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PipelineCounters ► PipelinesAborted
Gets the total number of times a pipeline was aborted.
Declaration Syntax
C#
public static PerformanceCounter PipelinesAborted { get; }
Value
The pipelines aborted.


PipelinesExecuted Property

PipelinesExecuted Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PipelineCounters ► PipelinesExecuted
Gets the total number of times a pipeline was executed.
Declaration Syntax
C#
public static PerformanceCounter PipelinesExecuted { get; }
Value
The pipelines executed.


ProcessorsExecuted Property

ProcessorsExecuted Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PipelineCounters ► ProcessorsExecuted
Gets the total number of processors that have been executed.
Declaration Syntax
C#
public static PerformanceCounter ProcessorsExecuted { get; }
Value
The processors executed.


PublishingCounters Class

PublishingCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PublishingCounters
Represents the publishing counters.
Declaration Syntax
C#
public static class PublishingCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FullPublishings | Gets the total number of times a full publishing operation has been performed.
 | IncrementalPublishings | Gets the total number of times an incremental publishing operation has been performed.
 | ItemPublishings | Gets the total number of times an item publishing operation has been performed.
 | ItemsExamined | Gets the total number of items that have been examined as candidates for publishing.
 | ItemsPublished | Gets the total number of items that have been published to the web site.
 | ItemsQueued | Gets the total number of items that have been queued for publishing.
 | PublishReplacements | Gets the total number of publishing replacement operations that have been performed.
 | SmartPublishings | Gets the total number of times a smart publishing operation has been performed.
 | TotalPublishings | Gets the total number of publishings that have been performed.
Inheritance Hierarchy
Object
PublishingCounters


FullPublishings Property

FullPublishings Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PublishingCounters ► FullPublishings
Gets the total number of times a full publishing operation has been performed.
Declaration Syntax
C#
public static PerformanceCounter FullPublishings { get; }
Value
The full publishings.


IncrementalPublishings Property

IncrementalPublishings Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PublishingCounters ► IncrementalPublishings
Gets the total number of times an incremental publishing operation has been performed.
Declaration Syntax
C#
public static PerformanceCounter IncrementalPublishings { get; }
Value
The incremental publishings.


ItemPublishings Property

ItemPublishings Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PublishingCounters ► ItemPublishings
Gets the total number of times an item publishing operation has been performed.
Declaration Syntax
C#
public static PerformanceCounter ItemPublishings { get; }
Value
The item publishings.


ItemsExamined Property

ItemsExamined Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PublishingCounters ► ItemsExamined
Gets the total number of items that have been examined as candidates for publishing.
Declaration Syntax
C#
public static PerformanceCounter ItemsExamined { get; }
Value
The items examined.


ItemsPublished Property

ItemsPublished Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PublishingCounters ► ItemsPublished
Gets the total number of items that have been published to the web site.
Declaration Syntax
C#
public static PerformanceCounter ItemsPublished { get; }
Value
The items published.


ItemsQueued Property

ItemsQueued Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PublishingCounters ► ItemsQueued
Gets the total number of items that have been queued for publishing.
Declaration Syntax
C#
public static PerformanceCounter ItemsQueued { get; }
Value
The items queued.


PublishReplacements Property

PublishReplacements Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PublishingCounters ► PublishReplacements
Gets the total number of publishing replacement operations that have been performed.
Declaration Syntax
C#
public static PerformanceCounter PublishReplacements { get; }
Value
The publish replacements.


SmartPublishings Property

SmartPublishings Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PublishingCounters ► SmartPublishings
Gets the total number of times a smart publishing operation has been performed.
Declaration Syntax
C#
public static PerformanceCounter SmartPublishings { get; }
Value
The smart publishings.


TotalPublishings Property

TotalPublishings Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► PublishingCounters ► TotalPublishings
Gets the total number of publishings that have been performed.
Declaration Syntax
C#
public static PerformanceCounter TotalPublishings { get; }
Value
The total publishings.


ReflectionCounters Class

ReflectionCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ReflectionCounters
Represents the reflection counters.
Declaration Syntax
C#
public static class ReflectionCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MethodsInvoked | Gets the total number of methods that have been invoked through reflection.
 | ObjectsCreated | Gets the total number of objects that have been created using reflection.
 | ObjectsNotCreated | Gets the total number of objects where the creation through reflection failed (due to unknown types or constructors).
 | TypesNotResolved | Gets the total number of types where the resolving through reflection failed (due to unknown types or other causes).
 | TypesResolved | Gets the total number of types that have been resolved using reflection.
Inheritance Hierarchy
Object
ReflectionCounters


MethodsInvoked Property

MethodsInvoked Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ReflectionCounters ► MethodsInvoked
Gets the total number of methods that have been invoked through reflection.
Declaration Syntax
C#
public static PerformanceCounter MethodsInvoked { get; }
Value
The methods invoked.


ObjectsCreated Property

ObjectsCreated Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ReflectionCounters ► ObjectsCreated
Gets the total number of objects that have been created using reflection.
Declaration Syntax
C#
public static PerformanceCounter ObjectsCreated { get; }
Value
The objects created.


ObjectsNotCreated Property

ObjectsNotCreated Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ReflectionCounters ► ObjectsNotCreated
Gets the total number of objects where the creation through reflection failed (due to unknown types or constructors).
Declaration Syntax
C#
public static PerformanceCounter ObjectsNotCreated { get; }
Value
The objects not created.


TypesNotResolved Property

TypesNotResolved Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ReflectionCounters ► TypesNotResolved
Gets the total number of types where the resolving through reflection failed (due to unknown types or other causes).
Declaration Syntax
C#
public static PerformanceCounter TypesNotResolved { get; }
Value
The types not resolved.


TypesResolved Property

TypesResolved Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ReflectionCounters ► TypesResolved
Gets the total number of types that have been resolved using reflection.
Declaration Syntax
C#
public static PerformanceCounter TypesResolved { get; }
Value
The types resolved.


RenderingCounters Class

RenderingCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► RenderingCounters
Represents the rendering counters.
Declaration Syntax
C#
public static class RenderingCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ControlsRendered | Gets the total number of Sitecore controls rendered.
 | ControlsRenderedFromCache | Gets the total number of Sitecore controls rendered from a cache.
 | PagesGenerated | Gets the total number of web pages generated by Sitecore.
 | RenderingsRendered | Gets the total number of Renderings rendered.
 | SublayoutsRendered | Gets the total number of Sublayouts rendered.
 | XamlControlsCompiled | Gets the total number of XamlControls compiled.
 | XmlControlsCompiled | Gets the total number of XmlControls compiled.
 | XslTransformsRendered | Gets the total number of XslTransforms rendered.
Inheritance Hierarchy
Object
RenderingCounters


ControlsRendered Property

ControlsRendered Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► RenderingCounters ► ControlsRendered
Gets the total number of Sitecore controls rendered.
Declaration Syntax
C#
public static PerformanceCounter ControlsRendered { get; }
Value
The controls rendered.
Remarks
Sitecore controls include Renderings, Sublayouts, XmlControls and XslTransforms.


ControlsRenderedFromCache Property

ControlsRenderedFromCache Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► RenderingCounters ► ControlsRenderedFromCache
Gets the total number of Sitecore controls rendered from a cache.
Declaration Syntax
C#
public static PerformanceCounter ControlsRenderedFromCache { get; }
Value
The controls rendered from cache.
Remarks
Sitecore controls include Renderings, Sublayouts, XmlControls and XslTransforms.


PagesGenerated Property

PagesGenerated Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► RenderingCounters ► PagesGenerated
Gets the total number of web pages generated by Sitecore.
Declaration Syntax
C#
public static PerformanceCounter PagesGenerated { get; }
Value
The pages generated.


RenderingsRendered Property

RenderingsRendered Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► RenderingCounters ► RenderingsRendered
Gets the total number of Renderings rendered.
Declaration Syntax
C#
public static PerformanceCounter RenderingsRendered { get; }
Value
The renderings rendered.


SublayoutsRendered Property

SublayoutsRendered Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► RenderingCounters ► SublayoutsRendered
Gets the total number of Sublayouts rendered.
Declaration Syntax
C#
public static PerformanceCounter SublayoutsRendered { get; }
Value
The sublayouts rendered.


XamlControlsCompiled Property

XamlControlsCompiled Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► RenderingCounters ► XamlControlsCompiled
Gets the total number of XamlControls compiled.
Declaration Syntax
C#
public static PerformanceCounter XamlControlsCompiled { get; }
Value
The Xaml controls compiled.


XmlControlsCompiled Property

XmlControlsCompiled Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► RenderingCounters ► XmlControlsCompiled
Gets the total number of XmlControls compiled.
Declaration Syntax
C#
public static PerformanceCounter XmlControlsCompiled { get; }
Value
The XML controls compiled.


XslTransformsRendered Property

XslTransformsRendered Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► RenderingCounters ► XslTransformsRendered
Gets the total number of XslTransforms rendered.
Declaration Syntax
C#
public static PerformanceCounter XslTransformsRendered { get; }
Value
The XSL transforms rendered.


SecurityCounters Class

SecurityCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► SecurityCounters
Represents the security counters.
Declaration Syntax
C#
public static class SecurityCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AccessDenied | Gets the total number of access requests that have been denied.
 | AccessGranted | Gets the total number of access requests that have been granted.
 | AccessResolved | Gets the total number of access requests that have been resolved.
 | ModifyRequests | Gets the total number of access requests where the desired access would allow the caller to modify data (ie. update or delete an item).
 | ProgrammaticDisabling | Gets the total number of times that security has been programmatically disabled (using SecurityDisabler).
 | ProgrammaticEnabling | Gets the total number of times that security has been programmatically enabled (using SecurityEnabler).
 | ProgrammaticUserSwitch | Gets the total number of times that the current user has been switched programmatically (using UserSwitcher).
 | ReadRequests | Gets the total number of access requests where the desired access would allow the caller to read data (ie. reading an item).
 | ResolvedRoles | Gets the total number of roles that have been resolved.
 | ResolvedUsers | Gets the total number of users that have been resolved.
 | VirtualUsersBuilt | Gets the total number of virutal users that have been built.
Inheritance Hierarchy
Object
SecurityCounters


AccessDenied Property

AccessDenied Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► SecurityCounters ► AccessDenied
Gets the total number of access requests that have been denied.
Declaration Syntax
C#
public static PerformanceCounter AccessDenied { get; }
Value
The access denied.


AccessGranted Property

AccessGranted Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► SecurityCounters ► AccessGranted
Gets the total number of access requests that have been granted.
Declaration Syntax
C#
public static PerformanceCounter AccessGranted { get; }
Value
The access granted.


AccessResolved Property

AccessResolved Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► SecurityCounters ► AccessResolved
Gets the total number of access requests that have been resolved.
Declaration Syntax
C#
public static PerformanceCounter AccessResolved { get; }
Value
The access resolved.


ModifyRequests Property

ModifyRequests Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► SecurityCounters ► ModifyRequests
Gets the total number of access requests where the desired access would allow the caller to modify data (ie. update or delete an item).
Declaration Syntax
C#
public static PerformanceCounter ModifyRequests { get; }
Value
The modify requests.


ProgrammaticDisabling Property

ProgrammaticDisabling Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► SecurityCounters ► ProgrammaticDisabling
Gets the total number of times that security has been programmatically disabled (using SecurityDisabler).
Declaration Syntax
C#
public static PerformanceCounter ProgrammaticDisabling { get; }
Value
The programmatic disabling.


ProgrammaticEnabling Property

ProgrammaticEnabling Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► SecurityCounters ► ProgrammaticEnabling
Gets the total number of times that security has been programmatically enabled (using SecurityEnabler).
Declaration Syntax
C#
public static PerformanceCounter ProgrammaticEnabling { get; }
Value
The programmatic enabling.


ProgrammaticUserSwitch Property

ProgrammaticUserSwitch Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► SecurityCounters ► ProgrammaticUserSwitch
Gets the total number of times that the current user has been switched programmatically (using UserSwitcher).
Declaration Syntax
C#
public static PerformanceCounter ProgrammaticUserSwitch { get; }
Value
The programmatic user switch.


ReadRequests Property

ReadRequests Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► SecurityCounters ► ReadRequests
Gets the total number of access requests where the desired access would allow the caller to read data (ie. reading an item).
Declaration Syntax
C#
public static PerformanceCounter ReadRequests { get; }
Value
The read requests.


ResolvedRoles Property

ResolvedRoles Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► SecurityCounters ► ResolvedRoles
Gets the total number of roles that have been resolved.
Declaration Syntax
C#
public static PerformanceCounter ResolvedRoles { get; }
Value
The resolved roles.


ResolvedUsers Property

ResolvedUsers Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► SecurityCounters ► ResolvedUsers
Gets the total number of users that have been resolved.
Declaration Syntax
C#
public static PerformanceCounter ResolvedUsers { get; }
Value
The resolved users.


VirtualUsersBuilt Property

VirtualUsersBuilt Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► SecurityCounters ► VirtualUsersBuilt
Gets the total number of virutal users that have been built.
Declaration Syntax
C#
public static PerformanceCounter VirtualUsersBuilt { get; }
Value
The virtual users built.


ShadowCounters Class

ShadowCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ShadowCounters
Represents the shadow counters.
Declaration Syntax
C#
public static class ShadowCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DataRead | Gets the total number of read operations that have been performed against the shadows database.
 | DataUpdated | Gets the total number of update operations that have been performed against the shadows database.
Inheritance Hierarchy
Object
ShadowCounters


DataRead Property

DataRead Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ShadowCounters ► DataRead
Gets the total number of read operations that have been performed against the shadows database.
Declaration Syntax
C#
public static PerformanceCounter DataRead { get; }
Value
The data read.


DataUpdated Property

DataUpdated Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ShadowCounters ► DataUpdated
Gets the total number of update operations that have been performed against the shadows database.
Declaration Syntax
C#
public static PerformanceCounter DataUpdated { get; }
Value
The data updated.


TaskCounters Class

TaskCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► TaskCounters
Represents the task counters.
Declaration Syntax
C#
public static class TaskCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FileCleanups | Gets the total number of times the CleanupAgent task has been run.
 | HtmlCacheClearings | Gets the total number of times the HtmlCacheClearAgent task has been run.
 | ItemsArchived | Gets the total number of items that have been archived.
 | Publishings | Gets the total number of times the PublishAgent task has been run.
 | RemindersSent | Gets the total number of reminders that have been sent.
 | TasksExecuted | Gets the total number of tasks that has been run.
Inheritance Hierarchy
Object
TaskCounters


FileCleanups Property

FileCleanups Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► TaskCounters ► FileCleanups
Gets the total number of times the CleanupAgent task has been run.
Declaration Syntax
C#
public static PerformanceCounter FileCleanups { get; }
Value
The file cleanups.


HtmlCacheClearings Property

HtmlCacheClearings Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► TaskCounters ► HtmlCacheClearings
Gets the total number of times the HtmlCacheClearAgent task has been run.
Declaration Syntax
C#
public static PerformanceCounter HtmlCacheClearings { get; }
Value
The HTML cache clearings.


ItemsArchived Property

ItemsArchived Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► TaskCounters ► ItemsArchived
Gets the total number of items that have been archived.
Declaration Syntax
C#
public static PerformanceCounter ItemsArchived { get; }
Value
The items archived.


Publishings Property

Publishings Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► TaskCounters ► Publishings
Gets the total number of times the PublishAgent task has been run.
Declaration Syntax
C#
public static PerformanceCounter Publishings { get; }
Value
The publishings.


RemindersSent Property

RemindersSent Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► TaskCounters ► RemindersSent
Gets the total number of reminders that have been sent.
Declaration Syntax
C#
public static PerformanceCounter RemindersSent { get; }
Value
The reminders sent.


TasksExecuted Property

TasksExecuted Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► TaskCounters ► TasksExecuted
Gets the total number of tasks that has been run.
Declaration Syntax
C#
public static PerformanceCounter TasksExecuted { get; }
Value
The tasks executed.


ThreadingCounters Class

ThreadingCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ThreadingCounters
Represents the threading counters.
Declaration Syntax
C#
public static class ThreadingCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BackgroundThreadsStarted | Gets the total number of background threads that have been started by the API.
 | ThreadDataModified | Gets the total number of times data in a thread local storage (TLS) slot have been modified.
 | ThreadDataRead | Gets the total number of times data in a thread local storage (TLS) slot have been read.
Inheritance Hierarchy
Object
ThreadingCounters


BackgroundThreadsStarted Property

BackgroundThreadsStarted Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ThreadingCounters ► BackgroundThreadsStarted
Gets the total number of background threads that have been started by the API.
Declaration Syntax
C#
public static PerformanceCounter BackgroundThreadsStarted { get; }
Value
The background threads started.


ThreadDataModified Property

ThreadDataModified Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ThreadingCounters ► ThreadDataModified
Gets the total number of times data in a thread local storage (TLS) slot have been modified.
Declaration Syntax
C#
public static PerformanceCounter ThreadDataModified { get; }
Value
The thread data modified.


ThreadDataRead Property

ThreadDataRead Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► ThreadingCounters ► ThreadDataRead
Gets the total number of times data in a thread local storage (TLS) slot have been read.
Declaration Syntax
C#
public static PerformanceCounter ThreadDataRead { get; }
Value
The thread data read.


WorkflowCounters Class

WorkflowCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► WorkflowCounters
Represents a workflow counters.
Declaration Syntax
C#
public static class WorkflowCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ActionsExecuted | Gets the total number of workflow actions that have been executed.
 | SecurityResolved | Gets the total number of times the workflow engine has resolved an access request.
 | StateChanges | Gets the total number of times that a workflow has changed state.
Inheritance Hierarchy
Object
WorkflowCounters


ActionsExecuted Property

ActionsExecuted Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► WorkflowCounters ► ActionsExecuted
Gets the total number of workflow actions that have been executed.
Declaration Syntax
C#
public static PerformanceCounter ActionsExecuted { get; }
Value
The actions executed.


SecurityResolved Property

SecurityResolved Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► WorkflowCounters ► SecurityResolved
Gets the total number of times the workflow engine has resolved an access request.
Declaration Syntax
C#
public static PerformanceCounter SecurityResolved { get; }
Value
The security resolved.


StateChanges Property

StateChanges Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► WorkflowCounters ► StateChanges
Gets the total number of times that a workflow has changed state.
Declaration Syntax
C#
public static PerformanceCounter StateChanges { get; }
Value
The state changes.


XmlCounters Class

XmlCounters Class
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► XmlCounters
Represents the xml counters.
Declaration Syntax
C#
public static class XmlCounters
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemNavigatorsCreated | Gets the total number of ItemNavigator instances that have been created.
 | PacketsCreated | Gets the total number of Packet instances that have been created.
Inheritance Hierarchy
Object
XmlCounters


ItemNavigatorsCreated Property

ItemNavigatorsCreated Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► XmlCounters ► ItemNavigatorsCreated
Gets the total number of ItemNavigator instances that have been created.
Declaration Syntax
C#
public static PerformanceCounter ItemNavigatorsCreated { get; }
Value
The item navigators created.


PacketsCreated Property

PacketsCreated Property
Namespaces ► Sitecore.Diagnostics.PerformanceCounters ► XmlCounters ► PacketsCreated
Gets the total number of Packet instances that have been created.
Declaration Syntax
C#
public static PerformanceCounter PacketsCreated { get; }
Value
The packets created.


Sitecore.Drawing.Exif Namespace

Sitecore.Drawing.Exif Namespace
Namespaces ► Sitecore.Drawing.Exif
Declaration Syntax
C#
namespace Sitecore.Drawing.Exif
Types
All Types Classes
Icon | Type | Description
 | Reader |


Reader Class

Reader Class
Namespaces ► Sitecore.Drawing.Exif ► Reader
Declaration Syntax
C#
public class Reader
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Reader(Image) | Initializes a new instance of the Reader class.
 | Reader(String) | Initializes a new instance of the Reader class.
 | Count | Gets the count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMakeProperty()()() | The manufacturer of the recording equipment. This is the manufacturer of the DSC, scanner, video digitizer or other equipment that generated the image. When the field is left blank it is treated as unknown.
 | GetProperty(Int32) | Gets the property.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasProperty(Int32) | Determines whether the specified tag id has property.
 | Item[([(Int32])]) | Gets the Property at the specified index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(Image) | Parses the specified image.
 | Properties | Gets the properties.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Reader


Reader Constructor

Reader Constructor
Namespaces ► Sitecore.Drawing.Exif ► Reader ► Reader()()()
Members
Icon | Member | Description
 | Reader(Image) | Initializes a new instance of the Reader class.
 | Reader(String) | Initializes a new instance of the Reader class.


Reader Constructor (image)

Reader Constructor (image)
Namespaces ► Sitecore.Drawing.Exif ► Reader ► Reader(Image)
Initializes a new instance of the Reader class.
Declaration Syntax
C#
public Reader(
    Image image
)
Parameters
image (Image)
The image.


Reader Constructor (filename)

Reader Constructor (filename)
Namespaces ► Sitecore.Drawing.Exif ► Reader ► Reader(String)
Initializes a new instance of the Reader class.
Declaration Syntax
C#
public Reader(
    string filename
)
Parameters
filename (String)
The filename.


Count Property

Count Property
Namespaces ► Sitecore.Drawing.Exif ► Reader ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


GetMakeProperty Method

GetMakeProperty Method
Namespaces ► Sitecore.Drawing.Exif ► Reader ► GetMakeProperty()()()
The manufacturer of the recording equipment. This is the manufacturer of the DSC, scanner, video digitizer or other equipment that generated the image. When the field is left blank it is treated as unknown.
Declaration Syntax
C#
public Property GetMakeProperty()
Return Value


GetProperty Method (TagId)

GetProperty Method (TagId)
Namespaces ► Sitecore.Drawing.Exif ► Reader ► GetProperty(Int32)
Gets the property.
Declaration Syntax
C#
public Property GetProperty(
    int TagId
)
Parameters
TagId (Int32)
The tag id.
Return Value


HasProperty Method (TagId)

HasProperty Method (TagId)
Namespaces ► Sitecore.Drawing.Exif ► Reader ► HasProperty(Int32)
Determines whether the specified tag id has property.
Declaration Syntax
C#
public bool HasProperty(
    int TagId
)
Parameters
TagId (Int32)
The tag id.
Return Value
true if the specified tag id has property; otherwise, false.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Drawing.Exif ► Reader ► Item[([(Int32])])
Gets the Property at the specified index.
Declaration Syntax
C#
public Property this[
    int index
] { get; }
Parameters
index (Int32)
Value


Parse Method (image)

Parse Method (image)
Namespaces ► Sitecore.Drawing.Exif ► Reader ► Parse(Image)
Parses the specified image.
Declaration Syntax
C#
public static Reader Parse(
    Image image
)
Parameters
image (Image)
The image.
Return Value


Properties Property

Properties Property
Namespaces ► Sitecore.Drawing.Exif ► Reader ► Properties
Gets the properties.
Declaration Syntax
C#
public List<Property> Properties { get; }
Value
The properties.


Sitecore.Drawing.Exif.Attributes Namespace

Sitecore.Drawing.Exif.Attributes Namespace
Namespaces ► Sitecore.Drawing.Exif.Attributes
Declaration Syntax
C#
namespace Sitecore.Drawing.Exif.Attributes
Types
All Types Classes
Icon | Type | Description
 | TagBitmaskValueNameAttribute |
 | TagCategoryAttribute |
 | TagCommentAttribute |
 | TagDefaultValueAttribute |
 | TagUnknownValueNameAttribute |
 | TagValueNameAttribute |


TagBitmaskValueNameAttribute Class

TagBitmaskValueNameAttribute Class
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagBitmaskValueNameAttribute
Declaration Syntax
C#
public sealed class TagBitmaskValueNameAttribute : TagValueNameAttribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TagBitmaskValueNameAttribute(Int64, Int64, String) | Initializes a new instance of the TagBitmaskValueNameAttribute class.
 | TagBitmaskValueNameAttribute(Int64, Int64, String, String) | Initializes a new instance of the TagBitmaskValueNameAttribute class.
 | Bitmask | Gets the bitmask.
 | Comment | Gets the comment. (Inherited from TagValueNameAttribute.)
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | IsMatch(Int64) | Determines whether the specified tag value is match. (Overrides TagValueNameAttribute.IsMatch(Int64).)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from TagValueNameAttribute.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
 | Value | Gets the value. (Inherited from TagValueNameAttribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | TagValueNameAttribute
 |  |  | TagBitmaskValueNameAttribute


TagBitmaskValueNameAttribute Constructor

TagBitmaskValueNameAttribute Constructor
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagBitmaskValueNameAttribute ► TagBitmaskValueNameAttribute()()()
Members
Icon | Member | Description
 | TagBitmaskValueNameAttribute(Int64, Int64, String) | Initializes a new instance of the TagBitmaskValueNameAttribute class.
 | TagBitmaskValueNameAttribute(Int64, Int64, String, String) | Initializes a new instance of the TagBitmaskValueNameAttribute class.


TagBitmaskValueNameAttribute Constructor (bitmask, value, name)

TagBitmaskValueNameAttribute Constructor (bitmask, value, name)
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagBitmaskValueNameAttribute ► TagBitmaskValueNameAttribute(Int64, Int64, String)
Initializes a new instance of the TagBitmaskValueNameAttribute class.
Declaration Syntax
C#
public TagBitmaskValueNameAttribute(
    long bitmask,
    long value,
    string name
)
Parameters
bitmask (Int64)
The bitmask.
value (Int64)
The value.
name (String)
The name.


TagBitmaskValueNameAttribute Constructor (bitmask, value, name, comment)

TagBitmaskValueNameAttribute Constructor (bitmask, value, name, comment)
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagBitmaskValueNameAttribute ► TagBitmaskValueNameAttribute(Int64, Int64, String, String)
Initializes a new instance of the TagBitmaskValueNameAttribute class.
Declaration Syntax
C#
public TagBitmaskValueNameAttribute(
    long bitmask,
    long value,
    string name,
    string comment
)
Parameters
bitmask (Int64)
The bitmask.
value (Int64)
The value.
name (String)
The name.
comment (String)
The comment.


Bitmask Property

Bitmask Property
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagBitmaskValueNameAttribute ► Bitmask
Gets the bitmask.
Declaration Syntax
C#
public long Bitmask { get; }
Value
The bitmask.


IsMatch Method (tagValue)

IsMatch Method (tagValue)
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagBitmaskValueNameAttribute ► IsMatch(Int64)
Determines whether the specified tag value is match.
Declaration Syntax
C#
public override bool IsMatch(
    long tagValue
)
Parameters
tagValue (Int64)
The tag value.
Return Value
true if the specified tag value is match; otherwise, false.


TagCategoryAttribute Class

TagCategoryAttribute Class
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagCategoryAttribute
Declaration Syntax
C#
public sealed class TagCategoryAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TagCategoryAttribute(String) | Initializes a new instance of the TagCategoryAttribute class
 | Category | Gets the category.
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | TagCategoryAttribute


TagCategoryAttribute Constructor (category)

TagCategoryAttribute Constructor (category)
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagCategoryAttribute ► TagCategoryAttribute(String)
Initializes a new instance of the TagCategoryAttribute class
Declaration Syntax
C#
public TagCategoryAttribute(
    string category
)
Parameters
category (String)


Category Property

Category Property
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagCategoryAttribute ► Category
Gets the category.
Declaration Syntax
C#
public string Category { get; }
Value
The category.


TagCommentAttribute Class

TagCommentAttribute Class
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagCommentAttribute
Declaration Syntax
C#
public sealed class TagCommentAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TagCommentAttribute(String) | Initializes a new instance of the TagCommentAttribute class.
 | Comment | Gets the comment.
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | TagCommentAttribute


TagCommentAttribute Constructor (comment)

TagCommentAttribute Constructor (comment)
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagCommentAttribute ► TagCommentAttribute(String)
Initializes a new instance of the TagCommentAttribute class.
Declaration Syntax
C#
public TagCommentAttribute(
    string comment
)
Parameters
comment (String)
The comment.


Comment Property

Comment Property
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagCommentAttribute ► Comment
Gets the comment.
Declaration Syntax
C#
public string Comment { get; }
Value
The comment.


TagDefaultValueAttribute Class

TagDefaultValueAttribute Class
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagDefaultValueAttribute
Declaration Syntax
C#
public sealed class TagDefaultValueAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TagDefaultValueAttribute(Object) | Initializes a new instance of the TagDefaultValueAttribute class.
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
 | Value | Gets the value.
Inheritance Hierarchy
Object
 | Attribute
 |  | TagDefaultValueAttribute


TagDefaultValueAttribute Constructor (value)

TagDefaultValueAttribute Constructor (value)
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagDefaultValueAttribute ► TagDefaultValueAttribute(Object)
Initializes a new instance of the TagDefaultValueAttribute class.
Declaration Syntax
C#
public TagDefaultValueAttribute(
    Object value
)
Parameters
value (Object)
The value.


Value Property

Value Property
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagDefaultValueAttribute ► Value
Gets the value.
Declaration Syntax
C#
public Object Value { get; }
Value
The value.


TagUnknownValueNameAttribute Class

TagUnknownValueNameAttribute Class
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagUnknownValueNameAttribute
Declaration Syntax
C#
public sealed class TagUnknownValueNameAttribute : TagValueNameAttribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TagUnknownValueNameAttribute(String) | Initializes a new instance of the TagUnknownValueNameAttribute class.
 | TagUnknownValueNameAttribute(String, String) | Initializes a new instance of the TagUnknownValueNameAttribute class.
 | Comment | Gets the comment. (Inherited from TagValueNameAttribute.)
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | IsMatch(Int64) | Determines whether the specified tag value is match. (Overrides TagValueNameAttribute.IsMatch(Int64).)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from TagValueNameAttribute.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
 | Value | Gets the value. (Inherited from TagValueNameAttribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | TagValueNameAttribute
 |  |  | TagUnknownValueNameAttribute


TagUnknownValueNameAttribute Constructor

TagUnknownValueNameAttribute Constructor
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagUnknownValueNameAttribute ► TagUnknownValueNameAttribute()()()
Members
Icon | Member | Description
 | TagUnknownValueNameAttribute(String) | Initializes a new instance of the TagUnknownValueNameAttribute class.
 | TagUnknownValueNameAttribute(String, String) | Initializes a new instance of the TagUnknownValueNameAttribute class.


TagUnknownValueNameAttribute Constructor (name)

TagUnknownValueNameAttribute Constructor (name)
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagUnknownValueNameAttribute ► TagUnknownValueNameAttribute(String)
Initializes a new instance of the TagUnknownValueNameAttribute class.
Declaration Syntax
C#
public TagUnknownValueNameAttribute(
    string name
)
Parameters
name (String)
The name.


TagUnknownValueNameAttribute Constructor (name, comment)

TagUnknownValueNameAttribute Constructor (name, comment)
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagUnknownValueNameAttribute ► TagUnknownValueNameAttribute(String, String)
Initializes a new instance of the TagUnknownValueNameAttribute class.
Declaration Syntax
C#
public TagUnknownValueNameAttribute(
    string name,
    string comment
)
Parameters
name (String)
The name.
comment (String)
The comment.


IsMatch Method (tagValue)

IsMatch Method (tagValue)
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagUnknownValueNameAttribute ► IsMatch(Int64)
Determines whether the specified tag value is match.
Declaration Syntax
C#
public override bool IsMatch(
    long tagValue
)
Parameters
tagValue (Int64)
The tag value.
Return Value
true if the specified tag value is match; otherwise, false.


TagValueNameAttribute Class

TagValueNameAttribute Class
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagValueNameAttribute
Declaration Syntax
C#
public class TagValueNameAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TagValueNameAttribute(Int64, String) | Initializes a new instance of the TagValueNameAttribute class.
 | TagValueNameAttribute(Int64, String, String) | Initializes a new instance of the TagValueNameAttribute class.
 | Comment | Gets the comment.
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | IsMatch(Int64) | Determines whether the specified tag value is match.
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
 | Value | Gets the value.
Inheritance Hierarchy
Object
 | Attribute
 |  | TagValueNameAttribute
 |  |  | TagBitmaskValueNameAttribute
 |  |  | TagUnknownValueNameAttribute


TagValueNameAttribute Constructor

TagValueNameAttribute Constructor
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagValueNameAttribute ► TagValueNameAttribute()()()
Members
Icon | Member | Description
 | TagValueNameAttribute(Int64, String) | Initializes a new instance of the TagValueNameAttribute class.
 | TagValueNameAttribute(Int64, String, String) | Initializes a new instance of the TagValueNameAttribute class.


TagValueNameAttribute Constructor (value, name)

TagValueNameAttribute Constructor (value, name)
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagValueNameAttribute ► TagValueNameAttribute(Int64, String)
Initializes a new instance of the TagValueNameAttribute class.
Declaration Syntax
C#
public TagValueNameAttribute(
    long value,
    string name
)
Parameters
value (Int64)
The value.
name (String)
The name.


TagValueNameAttribute Constructor (value, name, comment)

TagValueNameAttribute Constructor (value, name, comment)
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagValueNameAttribute ► TagValueNameAttribute(Int64, String, String)
Initializes a new instance of the TagValueNameAttribute class.
Declaration Syntax
C#
public TagValueNameAttribute(
    long value,
    string name,
    string comment
)
Parameters
value (Int64)
The value.
name (String)
The name.
comment (String)
The comment.


Comment Property

Comment Property
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagValueNameAttribute ► Comment
Gets the comment.
Declaration Syntax
C#
public string Comment { get; }
Value
The comment.


IsMatch Method (tagValue)

IsMatch Method (tagValue)
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagValueNameAttribute ► IsMatch(Int64)
Determines whether the specified tag value is match.
Declaration Syntax
C#
public virtual bool IsMatch(
    long tagValue
)
Parameters
tagValue (Int64)
The tag value.
Return Value
true if the specified tag value is match; otherwise, false.


Name Property

Name Property
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagValueNameAttribute ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Value Property

Value Property
Namespaces ► Sitecore.Drawing.Exif.Attributes ► TagValueNameAttribute ► Value
Gets the value.
Declaration Syntax
C#
public long Value { get; }
Value
The value.


Sitecore.Drawing.Exif.Properties Namespace

Sitecore.Drawing.Exif.Properties Namespace
Namespaces ► Sitecore.Drawing.Exif.Properties
Declaration Syntax
C#
namespace Sitecore.Drawing.Exif.Properties
Types
All Types Classes Enumerations
Icon | Type | Description
 | ByteProperty |
 | CopyrightProperty |
 | Property..::.DataType |
 | DateTimeProperty |
 | Int32Property |
 | IntegerProperty |
 | JpegThumbnailProperty |
 | Property |
 | Rational |
 | RationalProperty |
 | SignedRationalProperty |
 | StringProperty |
 | Tag |
 | ThumbnailProperty |
 | UInt16Property |
 | UInt32Property |
 | UndefinedProperty |
 | UnsignedRationalProperty |


ByteProperty Class

ByteProperty Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► ByteProperty
Declaration Syntax
C#
public class ByteProperty : IntegerProperty
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ByteProperty(Int32, array<Byte>[]()[]) | Initializes a new instance of the ByteProperty class.
 | Category | Gets the category. (Inherited from Property.)
 | Comment | Gets the comment. (Inherited from Property.)
 | Count | Gets the count. (Inherited from IntegerProperty.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValueComment(Int64) | Gets the value comment. (Inherited from IntegerProperty.)
 | GetValueName(Int64) | Gets the name of the value. (Inherited from IntegerProperty.)
 | Id | Gets the id. (Inherited from Property.)
 | Item[([(Int32])]) | Gets the Int64 at the specified index. (Inherited from IntegerProperty.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Property.)
 | PropertyType | Gets the type of the property. (Inherited from Property.)
 | RawBytes | Gets the raw bytes. (Inherited from Property.)
 | SetValues(array<Int64>[]()[]) | Sets the values. (Inherited from IntegerProperty.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Property.)
 | ValueComments | Gets the value comments. (Inherited from IntegerProperty.)
 | ValueNames | Gets the value names. (Inherited from IntegerProperty.)
 | Values | Gets the values. (Inherited from IntegerProperty.)
Inheritance Hierarchy
Object
 | Property
 |  | IntegerProperty
 |  |  | ByteProperty


ByteProperty Constructor (id, raw)

ByteProperty Constructor (id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► ByteProperty ► ByteProperty(Int32, array<Byte>[]()[])
Initializes a new instance of the ByteProperty class.
Declaration Syntax
C#
public ByteProperty(
    int id,
    byte[] raw
)
Parameters
id (Int32)
The id.
raw (array< Byte >[]()[])
The raw.


CopyrightProperty Class

CopyrightProperty Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► CopyrightProperty
Declaration Syntax
C#
public class CopyrightProperty : StringProperty
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CopyrightProperty(Int32, array<Byte>[]()[]) | Initializes a new instance of the CopyrightProperty class.
 | Category | Gets the category. (Inherited from Property.)
 | Comment | Gets the comment. (Inherited from Property.)
 | Editor | Gets the editor.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the id. (Inherited from Property.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Property.)
 | Photographer | Gets the photographer.
 | PropertyType | Gets the type of the property. (Inherited from Property.)
 | RawBytes | Gets the raw bytes. (Inherited from Property.)
 | ToString()()() | Returns a String that represents the current Object. (Overrides StringProperty.ToString()()().)
 | Value | Gets the value. (Inherited from StringProperty.)
Inheritance Hierarchy
Object
 | Property
 |  | StringProperty
 |  |  | CopyrightProperty


CopyrightProperty Constructor (id, raw)

CopyrightProperty Constructor (id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► CopyrightProperty ► CopyrightProperty(Int32, array<Byte>[]()[])
Initializes a new instance of the CopyrightProperty class.
Declaration Syntax
C#
public CopyrightProperty(
    int id,
    byte[] raw
)
Parameters
id (Int32)
The id.
raw (array< Byte >[]()[])
The raw.
Exceptions
Exception | Condition
ArgumentNullException | Copyright does not contain a valid copyright message


Editor Property

Editor Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► CopyrightProperty ► Editor
Gets the editor.
Declaration Syntax
C#
public string Editor { get; }
Value
The editor.


Photographer Property

Photographer Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► CopyrightProperty ► Photographer
Gets the photographer.
Declaration Syntax
C#
public string Photographer { get; }
Value
The photographer.


ToString Method

ToString Method
Namespaces ► Sitecore.Drawing.Exif.Properties ► CopyrightProperty ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


DateTimeProperty Class

DateTimeProperty Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► DateTimeProperty
Declaration Syntax
C#
public class DateTimeProperty : StringProperty
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DateTimeProperty(Int32, array<Byte>[]()[]) | Initializes a new instance of the DateTimeProperty class.
 | Category | Gets the category. (Inherited from Property.)
 | Comment | Gets the comment. (Inherited from Property.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the id. (Inherited from Property.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Property.)
 | PropertyType | Gets the type of the property. (Inherited from Property.)
 | RawBytes | Gets the raw bytes. (Inherited from Property.)
 | ToString()()() | Returns a String that represents the current Object. (Overrides StringProperty.ToString()()().)
 | Value | Gets the value.
Inheritance Hierarchy
Object
 | Property
 |  | StringProperty
 |  |  | DateTimeProperty


DateTimeProperty Constructor (id, raw)

DateTimeProperty Constructor (id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► DateTimeProperty ► DateTimeProperty(Int32, array<Byte>[]()[])
Initializes a new instance of the DateTimeProperty class.
Declaration Syntax
C#
public DateTimeProperty(
    int id,
    byte[] raw
)
Parameters
id (Int32)
The id.
raw (array< Byte >[]()[])
The raw.


ToString Method

ToString Method
Namespaces ► Sitecore.Drawing.Exif.Properties ► DateTimeProperty ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Value Property

Value Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► DateTimeProperty ► Value
Gets the value.
Declaration Syntax
C#
public DateTime Value { get; }
Value
The value.


Int32Property Class

Int32Property Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► Int32Property
Declaration Syntax
C#
public class Int32Property : IntegerProperty
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Int32Property(Int32, array<Byte>[]()[]) | Initializes a new instance of the Int32Property class
 | Category | Gets the category. (Inherited from Property.)
 | Comment | Gets the comment. (Inherited from Property.)
 | Count | Gets the count. (Inherited from IntegerProperty.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValueComment(Int64) | Gets the value comment. (Inherited from IntegerProperty.)
 | GetValueName(Int64) | Gets the name of the value. (Inherited from IntegerProperty.)
 | Id | Gets the id. (Inherited from Property.)
 | Item[([(Int32])]) | Gets the Int64 at the specified index. (Inherited from IntegerProperty.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Property.)
 | PropertyType | Gets the type of the property. (Inherited from Property.)
 | RawBytes | Gets the raw bytes. (Inherited from Property.)
 | SetValues(array<Int64>[]()[]) | Sets the values. (Inherited from IntegerProperty.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Property.)
 | ValueComments | Gets the value comments. (Inherited from IntegerProperty.)
 | ValueNames | Gets the value names. (Inherited from IntegerProperty.)
 | Values | Gets the values. (Inherited from IntegerProperty.)
Inheritance Hierarchy
Object
 | Property
 |  | IntegerProperty
 |  |  | Int32Property


Int32Property Constructor (id, raw)

Int32Property Constructor (id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► Int32Property ► Int32Property(Int32, array<Byte>[]()[])
Initializes a new instance of the Int32Property class
Declaration Syntax
C#
public Int32Property(
    int id,
    byte[] raw
)
Parameters
id (Int32)
raw (array< Byte >[]()[])


IntegerProperty Class

IntegerProperty Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► IntegerProperty
Declaration Syntax
C#
public class IntegerProperty : Property
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntegerProperty(Property..::.DataType, Int32, array<Byte>[]()[]) | Initializes a new instance of the IntegerProperty class.
 | Category | Gets the category. (Inherited from Property.)
 | Comment | Gets the comment. (Inherited from Property.)
 | Count | Gets the count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValueComment(Int64) | Gets the value comment.
 | GetValueName(Int64) | Gets the name of the value.
 | Id | Gets the id. (Inherited from Property.)
 | Item[([(Int32])]) | Gets the Int64 at the specified index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Property.)
 | PropertyType | Gets the type of the property. (Inherited from Property.)
 | RawBytes | Gets the raw bytes. (Inherited from Property.)
 | SetValues(array<Int64>[]()[]) | Sets the values.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Property.)
 | ValueComments | Gets the value comments.
 | ValueNames | Gets the value names.
 | Values | Gets the values.
Inheritance Hierarchy
Object
 | Property
 |  | IntegerProperty
 |  |  | ByteProperty
 |  |  | Int32Property
 |  |  | UInt16Property
 |  |  | UInt32Property


IntegerProperty Constructor (dataType, id, raw)

IntegerProperty Constructor (dataType, id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► IntegerProperty ► IntegerProperty(Property..::.DataType, Int32, array<Byte>[]()[])
Initializes a new instance of the IntegerProperty class.
Declaration Syntax
C#
protected IntegerProperty(
    Property..::.DataType dataType,
    int id,
    byte[] raw
)
Parameters
dataType (Property..::.DataType)
Type of the data.
id (Int32)
The id.
raw (array< Byte >[]()[])
The raw.


Count Property

Count Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► IntegerProperty ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


GetValueComment Method (value)

GetValueComment Method (value)
Namespaces ► Sitecore.Drawing.Exif.Properties ► IntegerProperty ► GetValueComment(Int64)
Gets the value comment.
Declaration Syntax
C#
public string GetValueComment(
    long value
)
Parameters
value (Int64)
The value.
Return Value


GetValueName Method (value)

GetValueName Method (value)
Namespaces ► Sitecore.Drawing.Exif.Properties ► IntegerProperty ► GetValueName(Int64)
Gets the name of the value.
Declaration Syntax
C#
public string GetValueName(
    long value
)
Parameters
value (Int64)
The value.
Return Value


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Drawing.Exif.Properties ► IntegerProperty ► Item[([(Int32])])
Gets the Int64 at the specified index.
Declaration Syntax
C#
public long this[
    int index
] { get; }
Parameters
index (Int32)
Value


SetValues Method (values)

SetValues Method (values)
Namespaces ► Sitecore.Drawing.Exif.Properties ► IntegerProperty ► SetValues(array<Int64>[]()[])
Sets the values.
Declaration Syntax
C#
protected void SetValues(
    long[] values
)
Parameters
values (array< Int64 >[]()[])
The values.


ValueComments Property

ValueComments Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► IntegerProperty ► ValueComments
Gets the value comments.
Declaration Syntax
C#
public string[] ValueComments { get; }
Value
The value comments.


ValueNames Property

ValueNames Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► IntegerProperty ► ValueNames
Gets the value names.
Declaration Syntax
C#
public string[] ValueNames { get; }
Value
The value names.


Values Property

Values Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► IntegerProperty ► Values
Gets the values.
Declaration Syntax
C#
public long[] Values { get; }
Value
The values.


JpegThumbnailProperty Class

JpegThumbnailProperty Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► JpegThumbnailProperty
Declaration Syntax
C#
public class JpegThumbnailProperty : ThumbnailProperty
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JpegThumbnailProperty(Int32, array<Byte>[]()[]) | Initializes a new instance of the JpegThumbnailProperty class
 | Category | Gets the category. (Inherited from Property.)
 | Comment | Gets the comment. (Inherited from Property.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the id. (Inherited from Property.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Property.)
 | PropertyType | Gets the type of the property. (Inherited from Property.)
 | RawBytes | Gets the raw bytes. (Inherited from Property.)
 | SetThumbnail(Image) | Sets the thumbnail. (Inherited from ThumbnailProperty.)
 | Thumbnail | Gets the thumbnail. (Inherited from ThumbnailProperty.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from ThumbnailProperty.)
Inheritance Hierarchy
Object
 | Property
 |  | ThumbnailProperty
 |  |  | JpegThumbnailProperty


JpegThumbnailProperty Constructor (id, raw)

JpegThumbnailProperty Constructor (id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► JpegThumbnailProperty ► JpegThumbnailProperty(Int32, array<Byte>[]()[])
Initializes a new instance of the JpegThumbnailProperty class
Declaration Syntax
C#
public JpegThumbnailProperty(
    int id,
    byte[] raw
)
Parameters
id (Int32)
raw (array< Byte >[]()[])


Property Class

Property Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► Property
Declaration Syntax
C#
public class Property
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Property(Property..::.DataType, Int32, array<Byte>[]()[]) | Initializes a new instance of the Property class.
 | Category | Gets the category.
 | Comment | Gets the comment.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | PropertyType | Gets the type of the property.
 | RawBytes | Gets the raw bytes.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
 | Property
 |  | IntegerProperty
 |  | RationalProperty
 |  | StringProperty
 |  | ThumbnailProperty
 |  | UndefinedProperty


Property Constructor (dataType, id, raw)

Property Constructor (dataType, id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► Property ► Property(Property..::.DataType, Int32, array<Byte>[]()[])
Initializes a new instance of the Property class.
Declaration Syntax
C#
protected Property(
    Property..::.DataType dataType,
    int id,
    byte[] raw
)
Parameters
dataType (Property..::.DataType)
Type of the data.
id (Int32)
The id.
raw (array< Byte >[]()[])
The raw.


Category Property

Category Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► Property ► Category
Gets the category.
Declaration Syntax
C#
public string Category { get; }
Value
The category.


Comment Property

Comment Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► Property ► Comment
Gets the comment.
Declaration Syntax
C#
public string Comment { get; }
Value
The comment.


Id Property

Id Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► Property ► Id
Gets the id.
Declaration Syntax
C#
public int Id { get; }
Value
The id.


Name Property

Name Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► Property ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


PropertyType Property

PropertyType Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► Property ► PropertyType
Gets the type of the property.
Declaration Syntax
C#
public Property..::.DataType PropertyType { get; }
Value
The type of the property.


RawBytes Property

RawBytes Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► Property ► RawBytes
Gets the raw bytes.
Declaration Syntax
C#
public byte[] RawBytes { get; }
Value
The raw bytes.


ToString Method

ToString Method
Namespaces ► Sitecore.Drawing.Exif.Properties ► Property ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Property.DataType Enumeration

Property..::.DataType Enumeration
Namespaces ► Sitecore.Drawing.Exif.Properties ► Property ► Property..::.DataType
Declaration Syntax
C#
public enum DataType
Members
Member | Description
Byte |
String |
UInt16 |
UInt32 |
Rational |
Undefined |
Int32 |
SRational |


Rational Class

Rational Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► Rational
Declaration Syntax
C#
public class Rational
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Rational(Int64, Int64) | Initializes a new instance of the Rational class.
 | Denominator | Gets the denominator.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Numerator | Gets the numerator.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | Value | Gets the value.
Inheritance Hierarchy
Object
Rational


Rational Constructor (numerator, denominator)

Rational Constructor (numerator, denominator)
Namespaces ► Sitecore.Drawing.Exif.Properties ► Rational ► Rational(Int64, Int64)
Initializes a new instance of the Rational class.
Declaration Syntax
C#
public Rational(
    long numerator,
    long denominator
)
Parameters
numerator (Int64)
The numerator.
denominator (Int64)
The denominator.


Denominator Property

Denominator Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► Rational ► Denominator
Gets the denominator.
Declaration Syntax
C#
public long Denominator { get; }
Value
The denominator.


Numerator Property

Numerator Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► Rational ► Numerator
Gets the numerator.
Declaration Syntax
C#
public long Numerator { get; }
Value
The numerator.


ToString Method

ToString Method
Namespaces ► Sitecore.Drawing.Exif.Properties ► Rational ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Value Property

Value Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► Rational ► Value
Gets the value.
Declaration Syntax
C#
public double Value { get; }
Value
The value.


RationalProperty Class

RationalProperty Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► RationalProperty
Declaration Syntax
C#
public class RationalProperty : Property
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RationalProperty(Property..::.DataType, Int32, array<Byte>[]()[]) | Initializes a new instance of the RationalProperty class.
 | Category | Gets the category. (Inherited from Property.)
 | Comment | Gets the comment. (Inherited from Property.)
 | Count | Gets the count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the id. (Inherited from Property.)
 | Item[([(Int32])]) | Gets the Rational at the specified index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Property.)
 | PropertyType | Gets the type of the property. (Inherited from Property.)
 | RawBytes | Gets the raw bytes. (Inherited from Property.)
 | SetValues(array<Rational>[]()[]) | Sets the values.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Property.ToString()()().)
 | Values | Gets the values.
Inheritance Hierarchy
Object
 | Property
 |  | RationalProperty
 |  |  | SignedRationalProperty
 |  |  | UnsignedRationalProperty


RationalProperty Constructor (dataType, id, raw)

RationalProperty Constructor (dataType, id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► RationalProperty ► RationalProperty(Property..::.DataType, Int32, array<Byte>[]()[])
Initializes a new instance of the RationalProperty class.
Declaration Syntax
C#
public RationalProperty(
    Property..::.DataType dataType,
    int id,
    byte[] raw
)
Parameters
dataType (Property..::.DataType)
Type of the data.
id (Int32)
The id.
raw (array< Byte >[]()[])
The raw.


Count Property

Count Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► RationalProperty ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Drawing.Exif.Properties ► RationalProperty ► Item[([(Int32])])
Gets the Rational at the specified index.
Declaration Syntax
C#
public Rational this[
    int index
] { get; }
Parameters
index (Int32)
Value


SetValues Method (values)

SetValues Method (values)
Namespaces ► Sitecore.Drawing.Exif.Properties ► RationalProperty ► SetValues(array<Rational>[]()[])
Sets the values.
Declaration Syntax
C#
protected void SetValues(
    Rational[] values
)
Parameters
values (array< Rational >[]()[])
The values.


ToString Method

ToString Method
Namespaces ► Sitecore.Drawing.Exif.Properties ► RationalProperty ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Values Property

Values Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► RationalProperty ► Values
Gets the values.
Declaration Syntax
C#
public Rational[] Values { get; }
Value
The values.


SignedRationalProperty Class

SignedRationalProperty Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► SignedRationalProperty
Declaration Syntax
C#
public class SignedRationalProperty : RationalProperty
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SignedRationalProperty(Int32, array<Byte>[]()[]) | Initializes a new instance of the SignedRationalProperty class.
 | Category | Gets the category. (Inherited from Property.)
 | Comment | Gets the comment. (Inherited from Property.)
 | Count | Gets the count. (Inherited from RationalProperty.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the id. (Inherited from Property.)
 | Item[([(Int32])]) | Gets the Rational at the specified index. (Inherited from RationalProperty.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Property.)
 | PropertyType | Gets the type of the property. (Inherited from Property.)
 | RawBytes | Gets the raw bytes. (Inherited from Property.)
 | SetValues(array<Rational>[]()[]) | Sets the values. (Inherited from RationalProperty.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from RationalProperty.)
 | Values | Gets the values. (Inherited from RationalProperty.)
Inheritance Hierarchy
Object
 | Property
 |  | RationalProperty
 |  |  | SignedRationalProperty


SignedRationalProperty Constructor (id, raw)

SignedRationalProperty Constructor (id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► SignedRationalProperty ► SignedRationalProperty(Int32, array<Byte>[]()[])
Initializes a new instance of the SignedRationalProperty class.
Declaration Syntax
C#
public SignedRationalProperty(
    int id,
    byte[] raw
)
Parameters
id (Int32)
The id.
raw (array< Byte >[]()[])
The raw.


StringProperty Class

StringProperty Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► StringProperty
Declaration Syntax
C#
public class StringProperty : Property
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringProperty(Int32, array<Byte>[]()[]) | Initializes a new instance of the StringProperty class.
 | Category | Gets the category. (Inherited from Property.)
 | Comment | Gets the comment. (Inherited from Property.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the id. (Inherited from Property.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Property.)
 | PropertyType | Gets the type of the property. (Inherited from Property.)
 | RawBytes | Gets the raw bytes. (Inherited from Property.)
 | ToString()()() | Returns a String that represents the current Object. (Overrides Property.ToString()()().)
 | Value | Gets the value.
Inheritance Hierarchy
Object
 | Property
 |  | StringProperty
 |  |  | CopyrightProperty
 |  |  | DateTimeProperty


StringProperty Constructor (id, raw)

StringProperty Constructor (id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► StringProperty ► StringProperty(Int32, array<Byte>[]()[])
Initializes a new instance of the StringProperty class.
Declaration Syntax
C#
public StringProperty(
    int id,
    byte[] raw
)
Parameters
id (Int32)
The id.
raw (array< Byte >[]()[])
The raw.


ToString Method

ToString Method
Namespaces ► Sitecore.Drawing.Exif.Properties ► StringProperty ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Value Property

Value Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► StringProperty ► Value
Gets the value.
Declaration Syntax
C#
public string Value { get; }
Value
The value.


Tag Enumeration

Tag Enumeration
Namespaces ► Sitecore.Drawing.Exif.Properties ► Tag
Declaration Syntax
C#
public enum Tag
Members
Member | Description
ImageWidth |
ImageLength |
ImageHeight |
BitsPerSample |
CompressionScheme |
PhotometricInterpretation |
Orientation |
SamplesPerPixel |
PlanarConfiguration |
YCbCrSubSampling |
YCbCrPositioning |
XResolution |
YResolution |
ResolutionUnit |
StripOffsets |
RowsPerStrip |
StripByteCounts |
JPEGInterchangeFormat |
JPEGInterchangeFormatLength |
TransferFunction |
WhitePoint |
PrimaryChromaticities |
YCbCrCoefficients |
ReferenceBlackWhite |
DateTime |
ImageDescription |
Make |
Model |
Software |
Artist |
Copyright |
ExifVersion |
FlashpixVersion |
ColorSpace |
ComponentsConfiguration |
CompressedBitsPerPixel |
PixelXDimension |
PixelYDimension |
MakerNote |
UserComment |
RelatedSoundFile |
DateTimeOriginal |
DateTimeDigitized |
SubSecTime |
SubSecTimeOriginal |
SubSecTimeDigitized |
ExposureTime |
FNumber |
ExposureProgram |
SpectralSensitivity |
ISOSpeedRatings |
OECF |
ShutterSpeedValue |
ApertureValue |
BrightnessValue |
ExposureBiasValue |
MaxApertureValue |
SubjectDistance |
MeteringMode |
LightSource |
Flash |
FocalLength |
SubjectArea |
FlashEnergy |
SpatialFrequencyResponse |
FocalPlaneXResolution |
FocalPlaneYResolution |
FocalPlaneResolutionUnit |
SubjectLocation |
ExposureIndex |
SensingMethod |
FileSource |
SceneType |
CFAPattern |
CustomRendered |
ExposureMode |
WhiteBalance |
DigitalZoomRatio |
FocalLengthIn35mmFilm |
SceneCaptureType |
GainControl |
Contrast |
Saturation |
Sharpness |
DeviceSettingDescription |
SubjectDistanceRange |
ImageUniqueID |
JpegThumbnail |


ThumbnailProperty Class

ThumbnailProperty Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► ThumbnailProperty
Declaration Syntax
C#
public class ThumbnailProperty : Property
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ThumbnailProperty(Property..::.DataType, Int32, array<Byte>[]()[]) | Initializes a new instance of the ThumbnailProperty class.
 | Category | Gets the category. (Inherited from Property.)
 | Comment | Gets the comment. (Inherited from Property.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the id. (Inherited from Property.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Property.)
 | PropertyType | Gets the type of the property. (Inherited from Property.)
 | RawBytes | Gets the raw bytes. (Inherited from Property.)
 | SetThumbnail(Image) | Sets the thumbnail.
 | Thumbnail | Gets the thumbnail.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Property.ToString()()().)
Inheritance Hierarchy
Object
 | Property
 |  | ThumbnailProperty
 |  |  | JpegThumbnailProperty


ThumbnailProperty Constructor (dataType, id, raw)

ThumbnailProperty Constructor (dataType, id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► ThumbnailProperty ► ThumbnailProperty(Property..::.DataType, Int32, array<Byte>[]()[])
Initializes a new instance of the ThumbnailProperty class.
Declaration Syntax
C#
protected ThumbnailProperty(
    Property..::.DataType dataType,
    int id,
    byte[] raw
)
Parameters
dataType (Property..::.DataType)
Type of the data.
id (Int32)
The id.
raw (array< Byte >[]()[])
The raw.


SetThumbnail Method (thumbnail)

SetThumbnail Method (thumbnail)
Namespaces ► Sitecore.Drawing.Exif.Properties ► ThumbnailProperty ► SetThumbnail(Image)
Sets the thumbnail.
Declaration Syntax
C#
protected void SetThumbnail(
    Image thumbnail
)
Parameters
thumbnail (Image)
The thumbnail.


Thumbnail Property

Thumbnail Property
Namespaces ► Sitecore.Drawing.Exif.Properties ► ThumbnailProperty ► Thumbnail
Gets the thumbnail.
Declaration Syntax
C#
public Image Thumbnail { get; }
Value
The thumbnail.


ToString Method

ToString Method
Namespaces ► Sitecore.Drawing.Exif.Properties ► ThumbnailProperty ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


UInt16Property Class

UInt16Property Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► UInt16Property
Declaration Syntax
C#
public class UInt16Property : IntegerProperty
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UInt16Property(Int32, array<Byte>[]()[]) | Initializes a new instance of the UInt16Property class.
 | Category | Gets the category. (Inherited from Property.)
 | Comment | Gets the comment. (Inherited from Property.)
 | Count | Gets the count. (Inherited from IntegerProperty.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValueComment(Int64) | Gets the value comment. (Inherited from IntegerProperty.)
 | GetValueName(Int64) | Gets the name of the value. (Inherited from IntegerProperty.)
 | Id | Gets the id. (Inherited from Property.)
 | Item[([(Int32])]) | Gets the Int64 at the specified index. (Inherited from IntegerProperty.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Property.)
 | PropertyType | Gets the type of the property. (Inherited from Property.)
 | RawBytes | Gets the raw bytes. (Inherited from Property.)
 | SetValues(array<Int64>[]()[]) | Sets the values. (Inherited from IntegerProperty.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Property.)
 | ValueComments | Gets the value comments. (Inherited from IntegerProperty.)
 | ValueNames | Gets the value names. (Inherited from IntegerProperty.)
 | Values | Gets the values. (Inherited from IntegerProperty.)
Inheritance Hierarchy
Object
 | Property
 |  | IntegerProperty
 |  |  | UInt16Property


UInt16Property Constructor (id, raw)

UInt16Property Constructor (id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► UInt16Property ► UInt16Property(Int32, array<Byte>[]()[])
Initializes a new instance of the UInt16Property class.
Declaration Syntax
C#
public UInt16Property(
    int id,
    byte[] raw
)
Parameters
id (Int32)
The id.
raw (array< Byte >[]()[])
The raw.


UInt32Property Class

UInt32Property Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► UInt32Property
Declaration Syntax
C#
public class UInt32Property : IntegerProperty
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UInt32Property(Int32, array<Byte>[]()[]) | Initializes a new instance of the UInt32Property class.
 | Category | Gets the category. (Inherited from Property.)
 | Comment | Gets the comment. (Inherited from Property.)
 | Count | Gets the count. (Inherited from IntegerProperty.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValueComment(Int64) | Gets the value comment. (Inherited from IntegerProperty.)
 | GetValueName(Int64) | Gets the name of the value. (Inherited from IntegerProperty.)
 | Id | Gets the id. (Inherited from Property.)
 | Item[([(Int32])]) | Gets the Int64 at the specified index. (Inherited from IntegerProperty.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Property.)
 | PropertyType | Gets the type of the property. (Inherited from Property.)
 | RawBytes | Gets the raw bytes. (Inherited from Property.)
 | SetValues(array<Int64>[]()[]) | Sets the values. (Inherited from IntegerProperty.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Property.)
 | ValueComments | Gets the value comments. (Inherited from IntegerProperty.)
 | ValueNames | Gets the value names. (Inherited from IntegerProperty.)
 | Values | Gets the values. (Inherited from IntegerProperty.)
Inheritance Hierarchy
Object
 | Property
 |  | IntegerProperty
 |  |  | UInt32Property


UInt32Property Constructor (id, raw)

UInt32Property Constructor (id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► UInt32Property ► UInt32Property(Int32, array<Byte>[]()[])
Initializes a new instance of the UInt32Property class.
Declaration Syntax
C#
public UInt32Property(
    int id,
    byte[] raw
)
Parameters
id (Int32)
The id.
raw (array< Byte >[]()[])
The raw.


UndefinedProperty Class

UndefinedProperty Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► UndefinedProperty
Declaration Syntax
C#
public class UndefinedProperty : Property
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UndefinedProperty(Int32, array<Byte>[]()[]) | Initializes a new instance of the UndefinedProperty class.
 | Category | Gets the category. (Inherited from Property.)
 | Comment | Gets the comment. (Inherited from Property.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the id. (Inherited from Property.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Property.)
 | PropertyType | Gets the type of the property. (Inherited from Property.)
 | RawBytes | Gets the raw bytes. (Inherited from Property.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Property.)
Inheritance Hierarchy
Object
 | Property
 |  | UndefinedProperty


UndefinedProperty Constructor (id, raw)

UndefinedProperty Constructor (id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► UndefinedProperty ► UndefinedProperty(Int32, array<Byte>[]()[])
Initializes a new instance of the UndefinedProperty class.
Declaration Syntax
C#
public UndefinedProperty(
    int id,
    byte[] raw
)
Parameters
id (Int32)
The id.
raw (array< Byte >[]()[])
The raw.


UnsignedRationalProperty Class

UnsignedRationalProperty Class
Namespaces ► Sitecore.Drawing.Exif.Properties ► UnsignedRationalProperty
Declaration Syntax
C#
public class UnsignedRationalProperty : RationalProperty
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnsignedRationalProperty(Int32, array<Byte>[]()[]) | Initializes a new instance of the UnsignedRationalProperty class.
 | Category | Gets the category. (Inherited from Property.)
 | Comment | Gets the comment. (Inherited from Property.)
 | Count | Gets the count. (Inherited from RationalProperty.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the id. (Inherited from Property.)
 | Item[([(Int32])]) | Gets the Rational at the specified index. (Inherited from RationalProperty.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from Property.)
 | PropertyType | Gets the type of the property. (Inherited from Property.)
 | RawBytes | Gets the raw bytes. (Inherited from Property.)
 | SetValues(array<Rational>[]()[]) | Sets the values. (Inherited from RationalProperty.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from RationalProperty.)
 | Values | Gets the values. (Inherited from RationalProperty.)
Inheritance Hierarchy
Object
 | Property
 |  | RationalProperty
 |  |  | UnsignedRationalProperty


UnsignedRationalProperty Constructor (id, raw)

UnsignedRationalProperty Constructor (id, raw)
Namespaces ► Sitecore.Drawing.Exif.Properties ► UnsignedRationalProperty ► UnsignedRationalProperty(Int32, array<Byte>[]()[])
Initializes a new instance of the UnsignedRationalProperty class.
Declaration Syntax
C#
public UnsignedRationalProperty(
    int id,
    byte[] raw
)
Parameters
id (Int32)
The id.
raw (array< Byte >[]()[])
The raw.


Sitecore.DynamicSerialization Namespace

Sitecore.DynamicSerialization Namespace
Namespaces ► Sitecore.DynamicSerialization
Declaration Syntax
C#
namespace Sitecore.DynamicSerialization
Types
All Types Classes Interfaces
Icon | Type | Description
 | Deserializer | Represents a deserializer
 | ILogger | Defines basic methods for a logger
 | IObjectFactory | Defines basic methods of an object factory
 | ISerializationContext | Defines basic properties of a serialization context
 | ISerializationEvents | Defines events which can be handled during a deserialization process
 | Serializer | Represents a serializer
 | SilentEvents | Represents a stab object which implements ISerializationEvents interface
 | SimpleObjectContext | Represents a simple serialization context
 | SmartObjectFactory | Represents an object factory


Deserializer Class

Deserializer Class
Namespaces ► Sitecore.DynamicSerialization ► Deserializer
Represents a deserializer
Declaration Syntax
C#
public static class Deserializer
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Deserialize(TextReader, ISerializationContext) | Deserializes an object from the specified text reader.
 | ItemElementName | Item element name
 | NullElementName | Null element name
 | PairElementName | Pair element name
Inheritance Hierarchy
Object
Deserializer


Deserialize Method (reader, context)

Deserialize Method (reader, context)
Namespaces ► Sitecore.DynamicSerialization ► Deserializer ► Deserialize(TextReader, ISerializationContext)
Deserializes an object from the specified text reader.
Declaration Syntax
C#
public static Object Deserialize(
    TextReader reader,
    ISerializationContext context
)
Parameters
reader (TextReader)
The reader.
context (ISerializationContext)
The serialization context.
Return Value
The serialized object.


ItemElementName Field

ItemElementName Field
Namespaces ► Sitecore.DynamicSerialization ► Deserializer ► ItemElementName
Item element name
Declaration Syntax
C#
public static readonly string ItemElementName


NullElementName Field

NullElementName Field
Namespaces ► Sitecore.DynamicSerialization ► Deserializer ► NullElementName
Null element name
Declaration Syntax
C#
public static readonly string NullElementName


PairElementName Field

PairElementName Field
Namespaces ► Sitecore.DynamicSerialization ► Deserializer ► PairElementName
Pair element name
Declaration Syntax
C#
public static readonly string PairElementName


ILogger Interface

ILogger Interface
Namespaces ► Sitecore.DynamicSerialization ► ILogger
Defines basic methods for a logger
Declaration Syntax
C#
public interface ILogger
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Error(String, array<Object>[]()[]) | Audits an error
 | Info(String, array<Object>[]()[]) | Audits some information


Error Method (format, args)

Error Method (format, args)
Namespaces ► Sitecore.DynamicSerialization ► ILogger ► Error(String, array<Object>[]()[])
Audits an error
Declaration Syntax
C#
void Error(
    string format,
    params Object[] args
)
Parameters
format (String)
The format string.
args (array< Object >[]()[])
The arguments.


Info Method (format, args)

Info Method (format, args)
Namespaces ► Sitecore.DynamicSerialization ► ILogger ► Info(String, array<Object>[]()[])
Audits some information
Declaration Syntax
C#
void Info(
    string format,
    params Object[] args
)
Parameters
format (String)
The format string.
args (array< Object >[]()[])
The arguments.


IObjectFactory Interface

IObjectFactory Interface
Namespaces ► Sitecore.DynamicSerialization ► IObjectFactory
Defines basic methods of an object factory
Declaration Syntax
C#
public interface IObjectFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetElementName(Object) | Gets the name of the element by instance
 | GetType(String) | Gets the type by element.
 | Register(String, Type) | Registers the specified element.


GetElementName Method (object)

GetElementName Method (object)
Namespaces ► Sitecore.DynamicSerialization ► IObjectFactory ► GetElementName(Object)
Gets the name of the element by instance
Declaration Syntax
C#
string GetElementName(
    Object object
)
Parameters
object (Object)
Instance of type
Return Value


GetType Method (element)

GetType Method (element)
Namespaces ► Sitecore.DynamicSerialization ► IObjectFactory ► GetType(String)
Gets the type by element.
Declaration Syntax
C#
Type GetType(
    string element
)
Parameters
element (String)
The element name
Return Value
The type


Register Method (element, type)

Register Method (element, type)
Namespaces ► Sitecore.DynamicSerialization ► IObjectFactory ► Register(String, Type)
Registers the specified element.
Declaration Syntax
C#
void Register(
    string element,
    Type type
)
Parameters
element (String)
The element.
type (Type)
The type.


ISerializationContext Interface

ISerializationContext Interface
Namespaces ► Sitecore.DynamicSerialization ► ISerializationContext
Defines basic properties of a serialization context
Declaration Syntax
C#
public interface ISerializationContext
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Events | Gets the events.
 | Factory | Gets the factory.
 | Log | Gets the logger.


Events Property

Events Property
Namespaces ► Sitecore.DynamicSerialization ► ISerializationContext ► Events
Gets the events.
Declaration Syntax
C#
ISerializationEvents Events { get; }
Value
The events.


Factory Property

Factory Property
Namespaces ► Sitecore.DynamicSerialization ► ISerializationContext ► Factory
Gets the factory.
Declaration Syntax
C#
IObjectFactory Factory { get; }
Value
The factory.


Log Property

Log Property
Namespaces ► Sitecore.DynamicSerialization ► ISerializationContext ► Log
Gets the logger.
Declaration Syntax
C#
ILogger Log { get; }
Value
The logger.


ISerializationEvents Interface

ISerializationEvents Interface
Namespaces ► Sitecore.DynamicSerialization ► ISerializationEvents
Defines events which can be handled during a deserialization process
Declaration Syntax
C#
public interface ISerializationEvents
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SuppressedException(Exception, ISerializationContext) | Action on suppressing an exception
 | UnknownElement(String, ISerializationContext) | Action on deserializing an unknown element.
 | UnsupportedNodeType(XmlReader, ISerializationContext) | Action on parsing an unsupported type of the node.


SuppressedException Method (exception, context)

SuppressedException Method (exception, context)
Namespaces ► Sitecore.DynamicSerialization ► ISerializationEvents ► SuppressedException(Exception, ISerializationContext)
Action on suppressing an exception
Declaration Syntax
C#
void SuppressedException(
    Exception exception,
    ISerializationContext context
)
Parameters
exception (Exception)
The exception.
context (ISerializationContext)
The context.


UnknownElement Method (element, context)

UnknownElement Method (element, context)
Namespaces ► Sitecore.DynamicSerialization ► ISerializationEvents ► UnknownElement(String, ISerializationContext)
Action on deserializing an unknown element.
Declaration Syntax
C#
void UnknownElement(
    string element,
    ISerializationContext context
)
Parameters
element (String)
The element.
context (ISerializationContext)
The context.


UnsupportedNodeType Method (reader, context)

UnsupportedNodeType Method (reader, context)
Namespaces ► Sitecore.DynamicSerialization ► ISerializationEvents ► UnsupportedNodeType(XmlReader, ISerializationContext)
Action on parsing an unsupported type of the node.
Declaration Syntax
C#
void UnsupportedNodeType(
    XmlReader reader,
    ISerializationContext context
)
Parameters
reader (XmlReader)
The reader.
context (ISerializationContext)
The context.


Serializer Class

Serializer Class
Namespaces ► Sitecore.DynamicSerialization ► Serializer
Represents a serializer
Declaration Syntax
C#
public static class Serializer
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Deserialize(TextReader, ISerializationContext) | Deserializes the object from the specified reader.
 | ItemElementName | Item element name
 | NullElementName | Null element name
 | PairElementName | Pair element name
 | Serialize(TextWriter, Object, ISerializationContext) | Serializes the object to the specified writer.
 | Serialize(TextWriter, Formatting, Object, ISerializationContext) | Serializes the object to the specified writer.
Inheritance Hierarchy
Object
Serializer


Deserialize Method (reader, context)

Deserialize Method (reader, context)
Namespaces ► Sitecore.DynamicSerialization ► Serializer ► Deserialize(TextReader, ISerializationContext)
Deserializes the object from the specified reader.
Declaration Syntax
C#
public static Object Deserialize(
    TextReader reader,
    ISerializationContext context
)
Parameters
reader (TextReader)
The reader.
context (ISerializationContext)
The serialization context.
Return Value
The serialized object.


ItemElementName Field

ItemElementName Field
Namespaces ► Sitecore.DynamicSerialization ► Serializer ► ItemElementName
Item element name
Declaration Syntax
C#
public static readonly string ItemElementName


NullElementName Field

NullElementName Field
Namespaces ► Sitecore.DynamicSerialization ► Serializer ► NullElementName
Null element name
Declaration Syntax
C#
public static readonly string NullElementName


PairElementName Field

PairElementName Field
Namespaces ► Sitecore.DynamicSerialization ► Serializer ► PairElementName
Pair element name
Declaration Syntax
C#
public static readonly string PairElementName


Serialize Method

Serialize Method
Namespaces ► Sitecore.DynamicSerialization ► Serializer ► Serialize()()()
Members
Icon | Member | Description
 | Serialize(TextWriter, Object, ISerializationContext) | Serializes the object to the specified writer.
 | Serialize(TextWriter, Formatting, Object, ISerializationContext) | Serializes the object to the specified writer.


Serialize Method (writer, object, context)

Serialize Method (writer, object, context)
Namespaces ► Sitecore.DynamicSerialization ► Serializer ► Serialize(TextWriter, Object, ISerializationContext)
Serializes the object to the specified writer.
Declaration Syntax
C#
public static void Serialize(
    TextWriter writer,
    Object object,
    ISerializationContext context
)
Parameters
writer (TextWriter)
The text writer.
object (Object)
The object to be serialized.
context (ISerializationContext)
The serialization context.


Serialize Method (writer, formatting, object, context)

Serialize Method (writer, formatting, object, context)
Namespaces ► Sitecore.DynamicSerialization ► Serializer ► Serialize(TextWriter, Formatting, Object, ISerializationContext)
Serializes the object to the specified writer.
Declaration Syntax
C#
public static void Serialize(
    TextWriter writer,
    Formatting formatting,
    Object object,
    ISerializationContext context
)
Parameters
writer (TextWriter)
The text writer.
formatting (Formatting)
The xml formatting.
object (Object)
The object to be serialized.
context (ISerializationContext)
The serialization context.


SilentEvents Class

SilentEvents Class
Namespaces ► Sitecore.DynamicSerialization ► SilentEvents
Represents a stab object which implements ISerializationEvents interface
Declaration Syntax
C#
public class SilentEvents : ISerializationEvents
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SilentEvents()()() | Initializes a new instance of the SilentEvents class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SuppressedException(Exception, ISerializationContext) | Action on suppressing an exception
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnknownElement(String, ISerializationContext) | Action on deserializing an unknown element.
 | UnsupportedNodeType(XmlReader, ISerializationContext) | Action on parsing an unsupported type of the node.
Inheritance Hierarchy
Object
SilentEvents


SilentEvents Constructor

SilentEvents Constructor
Namespaces ► Sitecore.DynamicSerialization ► SilentEvents ► SilentEvents()()()
Initializes a new instance of the SilentEvents class
Declaration Syntax
C#
public SilentEvents()


SuppressedException Method (exception, context)

SuppressedException Method (exception, context)
Namespaces ► Sitecore.DynamicSerialization ► SilentEvents ► SuppressedException(Exception, ISerializationContext)
Action on suppressing an exception
Declaration Syntax
C#
public void SuppressedException(
    Exception exception,
    ISerializationContext context
)
Parameters
exception (Exception)
The exception.
context (ISerializationContext)
The context.


UnknownElement Method (element, context)

UnknownElement Method (element, context)
Namespaces ► Sitecore.DynamicSerialization ► SilentEvents ► UnknownElement(String, ISerializationContext)
Action on deserializing an unknown element.
Declaration Syntax
C#
public void UnknownElement(
    string element,
    ISerializationContext context
)
Parameters
element (String)
The element.
context (ISerializationContext)
The context.


UnsupportedNodeType Method (reader, context)

UnsupportedNodeType Method (reader, context)
Namespaces ► Sitecore.DynamicSerialization ► SilentEvents ► UnsupportedNodeType(XmlReader, ISerializationContext)
Action on parsing an unsupported type of the node.
Declaration Syntax
C#
public void UnsupportedNodeType(
    XmlReader reader,
    ISerializationContext context
)
Parameters
reader (XmlReader)
The reader.
context (ISerializationContext)
The context.


SimpleObjectContext Class

SimpleObjectContext Class
Namespaces ► Sitecore.DynamicSerialization ► SimpleObjectContext
Represents a simple serialization context
Declaration Syntax
C#
public class SimpleObjectContext : ISerializationContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SimpleObjectContext(IObjectFactory, ISerializationEvents, ILogger) | Initializes a new instance of the SimpleObjectContext class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets or sets the events.
 | Factory | Gets or sets the factory.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Log | Gets or sets the logger.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SimpleObjectContext


SimpleObjectContext Constructor (factory, events, logger)

SimpleObjectContext Constructor (factory, events, logger)
Namespaces ► Sitecore.DynamicSerialization ► SimpleObjectContext ► SimpleObjectContext(IObjectFactory, ISerializationEvents, ILogger)
Initializes a new instance of the SimpleObjectContext class.
Declaration Syntax
C#
public SimpleObjectContext(
    IObjectFactory factory,
    ISerializationEvents events,
    ILogger logger
)
Parameters
factory (IObjectFactory)
The factory.
events (ISerializationEvents)
The events.
logger (ILogger)
The logger.


Events Property

Events Property
Namespaces ► Sitecore.DynamicSerialization ► SimpleObjectContext ► Events
Gets or sets the events.
Declaration Syntax
C#
public ISerializationEvents Events { get; set; }
Value
The events.


Factory Property

Factory Property
Namespaces ► Sitecore.DynamicSerialization ► SimpleObjectContext ► Factory
Gets or sets the factory.
Declaration Syntax
C#
public IObjectFactory Factory { get; set; }
Value
The factory.


Log Property

Log Property
Namespaces ► Sitecore.DynamicSerialization ► SimpleObjectContext ► Log
Gets or sets the logger.
Declaration Syntax
C#
public ILogger Log { get; set; }
Value
The logger.


SmartObjectFactory Class

SmartObjectFactory Class
Namespaces ► Sitecore.DynamicSerialization ► SmartObjectFactory
Represents an object factory
Declaration Syntax
C#
public class SmartObjectFactory : IObjectFactory
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SmartObjectFactory()()() | Initializes a new instance of the SmartObjectFactory class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementName(Object) | Gets the name of the element by instance
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType(String) | Gets the type by element.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Register(String, Type) | Registers the specified element.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SmartObjectFactory


SmartObjectFactory Constructor

SmartObjectFactory Constructor
Namespaces ► Sitecore.DynamicSerialization ► SmartObjectFactory ► SmartObjectFactory()()()
Initializes a new instance of the SmartObjectFactory class
Declaration Syntax
C#
public SmartObjectFactory()


GetElementName Method (object)

GetElementName Method (object)
Namespaces ► Sitecore.DynamicSerialization ► SmartObjectFactory ► GetElementName(Object)
Gets the name of the element by instance
Declaration Syntax
C#
public string GetElementName(
    Object object
)
Parameters
object (Object)
Instance of type
Return Value


GetType Method (element)

GetType Method (element)
Namespaces ► Sitecore.DynamicSerialization ► SmartObjectFactory ► GetType(String)
Gets the type by element.
Declaration Syntax
C#
public Type GetType(
    string element
)
Parameters
element (String)
The element name
Return Value
The type


Register Method (element, type)

Register Method (element, type)
Namespaces ► Sitecore.DynamicSerialization ► SmartObjectFactory ► Register(String, Type)
Registers the specified element.
Declaration Syntax
C#
public void Register(
    string element,
    Type type
)
Parameters
element (String)
The element.
type (Type)
The type.


Sitecore.Events Namespace

Sitecore.Events Namespace
Namespaces ► Sitecore.Events
Declaration Syntax
C#
namespace Sitecore.Events
Types
All Types Classes Interfaces
Icon | Type | Description
 | Event | Represents an event.
 | EventResult | Represents an event result.
 | EventSubscriber | Represents an event subscriber.
 | IPassNativeEventArgs | Marker interface for EventArgs that should be passed directly to the event handlers of Event
 | NotificationContext | NotificationContext
 | SitecoreEventArgs | Represents a Sitecore event argument class.
 | TemplateUpdatedEventArgs | Represents a template updated event argument class.
 | VersionRemovedEventArgs | Defines the arguments passed in a VersionRemoved event.
 | WellknownEvents | WellknownEvents


Event Class

Event Class
Namespaces ► Sitecore.Events ► Event
Represents an event.
Declaration Syntax
C#
public static class Event
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddFilter(String, EventHandler) | Adds the filter.
 | ExtractParameter<(Of <(T>)>)(EventArgs, Int32) | Extracts the parameter.
 | ExtractParameter(EventArgs, Int32) | Extracts the parameter.
 | ExtractParameters(EventArgs) | Extracts the parameters.
 | Initialize()()() | Initializes this instance.
 | RaiseEvent(String, IPassNativeEventArgs) | Raises the event.
 | RaiseEvent(String, array<Object>[]()[]) | Raises the event.
 | RaiseItemCopied(Object, ItemCopiedEventArgs) | Raises the item copied event.
 | RaiseItemCreated(Object, ItemCreatedEventArgs) | Raises the item created.
 | RaiseItemCreating(Object, ItemCreatingEventArgs) | Raises the item creating.
 | RaiseItemDeleted(Object, ItemDeletedEventArgs) | Raises the item deleted event.
 | RaiseItemDeleting(Object, ItemDeletingEventArgs) | Raises the item deleting event.
 | RaiseItemMoved(Object, ItemMovedEventArgs) | Raises the item moved event.
 | RaiseItemSaved(Object, ItemSavedEventArgs) | Raises the item saved event.
 | RaiseItemSaving(Object, ItemSavingEventArgs) | Raises the item saving event.
 | RemoveFilter(String, EventHandler) | Removes the filter.
 | Reset()()() | Resets this instance.
 | Subscribe(String, EventHandler) | Subscribes the specified event name.
 | Unsubscribe(String, EventHandler) | Unsubscribes the specified event name.
Inheritance Hierarchy
Object
Event


AddFilter Method (eventName, handler)

AddFilter Method (eventName, handler)
Namespaces ► Sitecore.Events ► Event ► AddFilter(String, EventHandler)
Adds the filter.
Declaration Syntax
C#
public static void AddFilter(
    string eventName,
    EventHandler handler
)
Parameters
eventName (String)
Name of the event.
handler (EventHandler)
The handler.


ExtractParameter Method

ExtractParameter Method
Namespaces ► Sitecore.Events ► Event ► ExtractParameter()()()
Members
Icon | Member | Description
 | ExtractParameter<(Of <(T>)>)(EventArgs, Int32) | Extracts the parameter.
 | ExtractParameter(EventArgs, Int32) | Extracts the parameter.


ExtractParameter Method (args, index)

ExtractParameter<(Of <(T>)>) Method (args, index)
Namespaces ► Sitecore.Events ► Event ► ExtractParameter<(Of <(T>)>)(EventArgs, Int32)
Extracts the parameter.
Declaration Syntax
C#
public static T ExtractParameter<T>(
    EventArgs args,
    int index
)
where T : class
Generic Template Parameters
T
Parameters
args (EventArgs)
The arguments.
index (Int32)
The index.
Return Value
The Object.


ExtractParameter Method (args, index)

ExtractParameter Method (args, index)
Namespaces ► Sitecore.Events ► Event ► ExtractParameter(EventArgs, Int32)
Extracts the parameter.
Declaration Syntax
C#
public static Object ExtractParameter(
    EventArgs args,
    int index
)
Parameters
args (EventArgs)
The arguments.
index (Int32)
The index.
Return Value
The Object.


ExtractParameters Method (args)

ExtractParameters Method (args)
Namespaces ► Sitecore.Events ► Event ► ExtractParameters(EventArgs)
Extracts the parameters.
Declaration Syntax
C#
public static Object[] ExtractParameters(
    EventArgs args
)
Parameters
args (EventArgs)
The arguments.
Return Value
The Object.


Initialize Method

Initialize Method
Namespaces ► Sitecore.Events ► Event ► Initialize()()()
Initializes this instance.
Declaration Syntax
C#
public static void Initialize()


RaiseEvent Method

RaiseEvent Method
Namespaces ► Sitecore.Events ► Event ► RaiseEvent()()()
Members
Icon | Member | Description
 | RaiseEvent(String, IPassNativeEventArgs) | Raises the event.
 | RaiseEvent(String, array<Object>[]()[]) | Raises the event.


RaiseEvent Method (eventName, args)

RaiseEvent Method (eventName, args)
Namespaces ► Sitecore.Events ► Event ► RaiseEvent(String, IPassNativeEventArgs)
Raises the event.
Declaration Syntax
C#
public static void RaiseEvent(
    string eventName,
    IPassNativeEventArgs args
)
Parameters
eventName (String)
Name of the event.
args (IPassNativeEventArgs)
The instance containing the event data.


RaiseEvent Method (eventName, parameters)

RaiseEvent Method (eventName, parameters)
Namespaces ► Sitecore.Events ► Event ► RaiseEvent(String, array<Object>[]()[])
Raises the event.
Declaration Syntax
C#
public static EventResult RaiseEvent(
    string eventName,
    params Object[] parameters
)
Parameters
eventName (String)
Name of the event.
parameters (array< Object >[]()[])
The parameters.
Return Value
The EventResult.


RaiseItemCopied Method (sender, args)

RaiseItemCopied Method (sender, args)
Namespaces ► Sitecore.Events ► Event ► RaiseItemCopied(Object, ItemCopiedEventArgs)
Raises the item copied event.
Declaration Syntax
C#
public static void RaiseItemCopied(
    Object sender,
    ItemCopiedEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemCopiedEventArgs)
The ItemCopiedEventArgs instance containing the event data.


RaiseItemCreated Method (sender, args)

RaiseItemCreated Method (sender, args)
Namespaces ► Sitecore.Events ► Event ► RaiseItemCreated(Object, ItemCreatedEventArgs)
Raises the item created.
Declaration Syntax
C#
public static void RaiseItemCreated(
    Object sender,
    ItemCreatedEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemCreatedEventArgs)
The arguments.


RaiseItemCreating Method (sender, args)

RaiseItemCreating Method (sender, args)
Namespaces ► Sitecore.Events ► Event ► RaiseItemCreating(Object, ItemCreatingEventArgs)
Raises the item creating.
Declaration Syntax
C#
public static void RaiseItemCreating(
    Object sender,
    ItemCreatingEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemCreatingEventArgs)
The arguments.


RaiseItemDeleted Method (sender, args)

RaiseItemDeleted Method (sender, args)
Namespaces ► Sitecore.Events ► Event ► RaiseItemDeleted(Object, ItemDeletedEventArgs)
Raises the item deleted event.
Declaration Syntax
C#
public static void RaiseItemDeleted(
    Object sender,
    ItemDeletedEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemDeletedEventArgs)
The ItemDeletedEventArgs instance containing the event data.


RaiseItemDeleting Method (sender, args)

RaiseItemDeleting Method (sender, args)
Namespaces ► Sitecore.Events ► Event ► RaiseItemDeleting(Object, ItemDeletingEventArgs)
Raises the item deleting event.
Declaration Syntax
C#
public static void RaiseItemDeleting(
    Object sender,
    ItemDeletingEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemDeletingEventArgs)
The ItemDeletingEventArgs instance containing the event data.


RaiseItemMoved Method (sender, args)

RaiseItemMoved Method (sender, args)
Namespaces ► Sitecore.Events ► Event ► RaiseItemMoved(Object, ItemMovedEventArgs)
Raises the item moved event.
Declaration Syntax
C#
public static void RaiseItemMoved(
    Object sender,
    ItemMovedEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemMovedEventArgs)
The ItemMovedEventArgs instance containing the event data.


RaiseItemSaved Method (sender, args)

RaiseItemSaved Method (sender, args)
Namespaces ► Sitecore.Events ► Event ► RaiseItemSaved(Object, ItemSavedEventArgs)
Raises the item saved event.
Declaration Syntax
C#
public static void RaiseItemSaved(
    Object sender,
    ItemSavedEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemSavedEventArgs)
The ItemSavedEventArgs instance containing the event data.


RaiseItemSaving Method (sender, args)

RaiseItemSaving Method (sender, args)
Namespaces ► Sitecore.Events ► Event ► RaiseItemSaving(Object, ItemSavingEventArgs)
Raises the item saving event.
Declaration Syntax
C#
public static void RaiseItemSaving(
    Object sender,
    ItemSavingEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemSavingEventArgs)
The arguments.
Return Value


RemoveFilter Method (eventName, handler)

RemoveFilter Method (eventName, handler)
Namespaces ► Sitecore.Events ► Event ► RemoveFilter(String, EventHandler)
Removes the filter.
Declaration Syntax
C#
public static void RemoveFilter(
    string eventName,
    EventHandler handler
)
Parameters
eventName (String)
Name of the event.
handler (EventHandler)
The handler.


Reset Method

Reset Method
Namespaces ► Sitecore.Events ► Event ► Reset()()()
Resets this instance.
Declaration Syntax
C#
public static void Reset()


Subscribe Method (eventName, handler)

Subscribe Method (eventName, handler)
Namespaces ► Sitecore.Events ► Event ► Subscribe(String, EventHandler)
Subscribes the specified event name.
Declaration Syntax
C#
public static void Subscribe(
    string eventName,
    EventHandler handler
)
Parameters
eventName (String)
Name of the event.
handler (EventHandler)
The handler.


Unsubscribe Method (eventName, handler)

Unsubscribe Method (eventName, handler)
Namespaces ► Sitecore.Events ► Event ► Unsubscribe(String, EventHandler)
Unsubscribes the specified event name.
Declaration Syntax
C#
public static void Unsubscribe(
    string eventName,
    EventHandler handler
)
Parameters
eventName (String)
Name of the event.
handler (EventHandler)
The handler.


EventResult Class

EventResult Class
Namespaces ► Sitecore.Events ► EventResult
Represents an event result.
Declaration Syntax
C#
public class EventResult
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EventResult()()() | Initializes a new instance of the EventResult class
 | Cancel | Gets or sets a value indicating whether this EventResult is cancelled.
 | CreateCancelResult()()() | Creates the cancel result.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Messages | Gets the messages.
 | ReturnValues | Gets the return values.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
EventResult


EventResult Constructor

EventResult Constructor
Namespaces ► Sitecore.Events ► EventResult ► EventResult()()()
Initializes a new instance of the EventResult class
Declaration Syntax
C#
public EventResult()


Cancel Property

Cancel Property
Namespaces ► Sitecore.Events ► EventResult ► Cancel
Gets or sets a value indicating whether this EventResult is cancelled.
Declaration Syntax
C#
public bool Cancel { get; set; }
Value
true if cancelled; otherwise, false.


CreateCancelResult Method

CreateCancelResult Method
Namespaces ► Sitecore.Events ► EventResult ► CreateCancelResult()()()
Creates the cancel result.
Declaration Syntax
C#
public static EventResult CreateCancelResult()
Return Value
The EventResult.


Messages Property

Messages Property
Namespaces ► Sitecore.Events ► EventResult ► Messages
Gets the messages.
Declaration Syntax
C#
public StringCollection Messages { get; }
Value
The messages.


ReturnValues Property

ReturnValues Property
Namespaces ► Sitecore.Events ► EventResult ► ReturnValues
Gets the return values.
Declaration Syntax
C#
public ArrayList ReturnValues { get; }
Value
The return values.


ToString Method

ToString Method
Namespaces ► Sitecore.Events ► EventResult ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


EventSubscriber Class

EventSubscriber Class
Namespaces ► Sitecore.Events ► EventSubscriber
Represents an event subscriber.
Declaration Syntax
C#
public class EventSubscriber
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EventSubscriber(Object, MethodInfo) | Initializes a new instance of the EventSubscriber class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Invoke(array<Object>[]()[]) | Invokes the specified parameters.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
EventSubscriber


EventSubscriber Constructor (obj, methodInfo)

EventSubscriber Constructor (obj, methodInfo)
Namespaces ► Sitecore.Events ► EventSubscriber ► EventSubscriber(Object, MethodInfo)
Initializes a new instance of the EventSubscriber class.
Declaration Syntax
C#
public EventSubscriber(
    Object obj,
    MethodInfo methodInfo
)
Parameters
obj (Object)
The object.
methodInfo (MethodInfo)
The method info.


Invoke Method (parameters)

Invoke Method (parameters)
Namespaces ► Sitecore.Events ► EventSubscriber ► Invoke(array<Object>[]()[])
Invokes the specified parameters.
Declaration Syntax
C#
public void Invoke(
    Object[] parameters
)
Parameters
parameters (array< Object >[]()[])
The parameters.


IPassNativeEventArgs Interface

IPassNativeEventArgs Interface
Namespaces ► Sitecore.Events ► IPassNativeEventArgs
Marker interface for EventArgs that should be passed directly to the event handlers of Event
Declaration Syntax
C#
public interface IPassNativeEventArgs


NotificationContext Class

NotificationContext Class
Namespaces ► Sitecore.Events ► NotificationContext
NotificationContext
Declaration Syntax
C#
public class NotificationContext
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotificationContext()()() | Initializes a new instance of the NotificationContext class
 | Disabled | Gets or sets a value indicating whether this NotificationContext is disabled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldSaved |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemAdded | Obsolete.
 | ItemChildrenChanged |
 | ItemCopied |
 | ItemCreated |
 | ItemDeleted |
 | ItemMoved |
 | ItemRenamed |
 | ItemSaved |
 | ItemSortorderChanged |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseFieldSaved(Object, FieldSavedEventArgs) | Raises the field saved event.
 | RaiseItemAdded(Object, ItemAddedEventArgs) | Obsolete. Raises the item added event.
 | RaiseItemChildrenChanged(Object, ItemChildrenChangedEventArgs) | Raises the item children changed event.
 | RaiseItemCopied(Object, ItemCopiedEventArgs) | Raises the item copied event.
 | RaiseItemCreated(Object, ItemCreatedEventArgs) | Raises the item created event.
 | RaiseItemDeleted(Object, ItemDeletedEventArgs) | Raises the item deleted event.
 | RaiseItemMoved(Object, ItemMovedEventArgs) | Raises the item moved event.
 | RaiseItemRenamed(Object, ItemRenamedEventArgs) | Raises the item renamed event.
 | RaiseItemSaved(Object, ItemSavedEventArgs) | Raises the item saved event.
 | RaiseItemSortorderChanged(Object, ItemSortorderChangedEventArgs) | Raises the item sortorder changed event.
 | RaiseVersionAdded(Object, VersionAddedEventArgs) | Raises the version added event.
 | RaiseVersionRemoved(Object, VersionRemovedEventArgs) | Raises the version removed event.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VersionAdded |
 | VersionRemoved |
Inheritance Hierarchy
Object
NotificationContext


NotificationContext Constructor

NotificationContext Constructor
Namespaces ► Sitecore.Events ► NotificationContext ► NotificationContext()()()
Initializes a new instance of the NotificationContext class
Declaration Syntax
C#
public NotificationContext()


Disabled Property

Disabled Property
Namespaces ► Sitecore.Events ► NotificationContext ► Disabled
Gets or sets a value indicating whether this NotificationContext is disabled.
Declaration Syntax
C#
public bool Disabled { get; set; }
Value
true if disabled; otherwise, false.


FieldSaved Event

FieldSaved Event
Namespaces ► Sitecore.Events ► NotificationContext ► FieldSaved
Declaration Syntax
C#
public event FieldSavedDelegate FieldSaved


ItemAdded Event

ItemAdded Event
Namespaces ► Sitecore.Events ► NotificationContext ► ItemAdded
Declaration Syntax
C#
[ObsoleteAttribute("Use the ItemCreatedDelegate event instead.")]
public event ItemAddedDelegate ItemAdded


ItemChildrenChanged Event

ItemChildrenChanged Event
Namespaces ► Sitecore.Events ► NotificationContext ► ItemChildrenChanged
Declaration Syntax
C#
public event ItemChildrenChangedDelegate ItemChildrenChanged


ItemCopied Event

ItemCopied Event
Namespaces ► Sitecore.Events ► NotificationContext ► ItemCopied
Declaration Syntax
C#
public event ItemCopiedDelegate ItemCopied


ItemCreated Event

ItemCreated Event
Namespaces ► Sitecore.Events ► NotificationContext ► ItemCreated
Declaration Syntax
C#
public event ItemCreatedDelegate ItemCreated


ItemDeleted Event

ItemDeleted Event
Namespaces ► Sitecore.Events ► NotificationContext ► ItemDeleted
Declaration Syntax
C#
public event ItemDeletedDelegate ItemDeleted


ItemMoved Event

ItemMoved Event
Namespaces ► Sitecore.Events ► NotificationContext ► ItemMoved
Declaration Syntax
C#
public event ItemMovedDelegate ItemMoved


ItemRenamed Event

ItemRenamed Event
Namespaces ► Sitecore.Events ► NotificationContext ► ItemRenamed
Declaration Syntax
C#
public event ItemRenamedDelegate ItemRenamed


ItemSaved Event

ItemSaved Event
Namespaces ► Sitecore.Events ► NotificationContext ► ItemSaved
Declaration Syntax
C#
public event ItemSavedDelegate ItemSaved


ItemSortorderChanged Event

ItemSortorderChanged Event
Namespaces ► Sitecore.Events ► NotificationContext ► ItemSortorderChanged
Declaration Syntax
C#
public event ItemSortorderChangedDelegate ItemSortorderChanged


RaiseFieldSaved Method (sender, args)

RaiseFieldSaved Method (sender, args)
Namespaces ► Sitecore.Events ► NotificationContext ► RaiseFieldSaved(Object, FieldSavedEventArgs)
Raises the field saved event.
Declaration Syntax
C#
public void RaiseFieldSaved(
    Object sender,
    FieldSavedEventArgs args
)
Parameters
sender (Object)
The sender.
args (FieldSavedEventArgs)
The arguments.


RaiseItemAdded Method (sender, args)

RaiseItemAdded Method (sender, args)
Namespaces ► Sitecore.Events ► NotificationContext ► RaiseItemAdded(Object, ItemAddedEventArgs)
Raises the item added event.
Declaration Syntax
C#
[ObsoleteAttribute("Use the RaiseItemCreated method instead.", false)]
public void RaiseItemAdded(
    Object sender,
    ItemAddedEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemAddedEventArgs)
The arguments.


RaiseItemChildrenChanged Method (sender, args)

RaiseItemChildrenChanged Method (sender, args)
Namespaces ► Sitecore.Events ► NotificationContext ► RaiseItemChildrenChanged(Object, ItemChildrenChangedEventArgs)
Raises the item children changed event.
Declaration Syntax
C#
public void RaiseItemChildrenChanged(
    Object sender,
    ItemChildrenChangedEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemChildrenChangedEventArgs)
The arguments.


RaiseItemCopied Method (sender, args)

RaiseItemCopied Method (sender, args)
Namespaces ► Sitecore.Events ► NotificationContext ► RaiseItemCopied(Object, ItemCopiedEventArgs)
Raises the item copied event.
Declaration Syntax
C#
public void RaiseItemCopied(
    Object sender,
    ItemCopiedEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemCopiedEventArgs)
The arguments.


RaiseItemCreated Method (sender, args)

RaiseItemCreated Method (sender, args)
Namespaces ► Sitecore.Events ► NotificationContext ► RaiseItemCreated(Object, ItemCreatedEventArgs)
Raises the item created event.
Declaration Syntax
C#
public void RaiseItemCreated(
    Object sender,
    ItemCreatedEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemCreatedEventArgs)
The arguments.


RaiseItemDeleted Method (sender, args)

RaiseItemDeleted Method (sender, args)
Namespaces ► Sitecore.Events ► NotificationContext ► RaiseItemDeleted(Object, ItemDeletedEventArgs)
Raises the item deleted event.
Declaration Syntax
C#
public void RaiseItemDeleted(
    Object sender,
    ItemDeletedEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemDeletedEventArgs)
The arguments.


RaiseItemMoved Method (sender, args)

RaiseItemMoved Method (sender, args)
Namespaces ► Sitecore.Events ► NotificationContext ► RaiseItemMoved(Object, ItemMovedEventArgs)
Raises the item moved event.
Declaration Syntax
C#
public void RaiseItemMoved(
    Object sender,
    ItemMovedEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemMovedEventArgs)
The arguments.


RaiseItemRenamed Method (sender, args)

RaiseItemRenamed Method (sender, args)
Namespaces ► Sitecore.Events ► NotificationContext ► RaiseItemRenamed(Object, ItemRenamedEventArgs)
Raises the item renamed event.
Declaration Syntax
C#
public void RaiseItemRenamed(
    Object sender,
    ItemRenamedEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemRenamedEventArgs)
The arguments.


RaiseItemSaved Method (sender, args)

RaiseItemSaved Method (sender, args)
Namespaces ► Sitecore.Events ► NotificationContext ► RaiseItemSaved(Object, ItemSavedEventArgs)
Raises the item saved event.
Declaration Syntax
C#
public void RaiseItemSaved(
    Object sender,
    ItemSavedEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemSavedEventArgs)
The arguments.


RaiseItemSortorderChanged Method (sender, args)

RaiseItemSortorderChanged Method (sender, args)
Namespaces ► Sitecore.Events ► NotificationContext ► RaiseItemSortorderChanged(Object, ItemSortorderChangedEventArgs)
Raises the item sortorder changed event.
Declaration Syntax
C#
public void RaiseItemSortorderChanged(
    Object sender,
    ItemSortorderChangedEventArgs args
)
Parameters
sender (Object)
The sender.
args (ItemSortorderChangedEventArgs)
The arguments.


RaiseVersionAdded Method (sender, args)

RaiseVersionAdded Method (sender, args)
Namespaces ► Sitecore.Events ► NotificationContext ► RaiseVersionAdded(Object, VersionAddedEventArgs)
Raises the version added event.
Declaration Syntax
C#
public void RaiseVersionAdded(
    Object sender,
    VersionAddedEventArgs args
)
Parameters
sender (Object)
The sender.
args (VersionAddedEventArgs)
The arguments.


RaiseVersionRemoved Method (sender, args)

RaiseVersionRemoved Method (sender, args)
Namespaces ► Sitecore.Events ► NotificationContext ► RaiseVersionRemoved(Object, VersionRemovedEventArgs)
Raises the version removed event.
Declaration Syntax
C#
public void RaiseVersionRemoved(
    Object sender,
    VersionRemovedEventArgs args
)
Parameters
sender (Object)
The sender.
args (VersionRemovedEventArgs)
The arguments.


VersionAdded Event

VersionAdded Event
Namespaces ► Sitecore.Events ► NotificationContext ► VersionAdded
Declaration Syntax
C#
public event VersionAddedDelegate VersionAdded


VersionRemoved Event

VersionRemoved Event
Namespaces ► Sitecore.Events ► NotificationContext ► VersionRemoved
Declaration Syntax
C#
public event VersionRemovedDelegate VersionRemoved


SitecoreEventArgs Class

SitecoreEventArgs Class
Namespaces ► Sitecore.Events ► SitecoreEventArgs
Represents a Sitecore event argument class.
Declaration Syntax
C#
public class SitecoreEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SitecoreEventArgs(String, array<Object>[]()[], EventResult) | Initializes a new instance of the SitecoreEventArgs class.
 | Cancel(EventArgs) | Cancels this event.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventName | Gets the name of the event.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataManager(EventArgs, Int32) | Gets the data manager.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(EventArgs, Int32) | Gets the ID.
 | GetItem(EventArgs, Int32) | Gets the item.
 | GetObject(EventArgs, Int32) | Gets the object.
 | GetString(EventArgs, Int32) | Gets the string.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets the parameters.
 | Result | Gets the result.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | SitecoreEventArgs


SitecoreEventArgs Constructor (eventName, parameters, result)

SitecoreEventArgs Constructor (eventName, parameters, result)
Namespaces ► Sitecore.Events ► SitecoreEventArgs ► SitecoreEventArgs(String, array<Object>[]()[], EventResult)
Initializes a new instance of the SitecoreEventArgs class.
Declaration Syntax
C#
public SitecoreEventArgs(
    string eventName,
    Object[] parameters,
    EventResult result
)
Parameters
eventName (String)
Name of the event.
parameters (array< Object >[]()[])
The parameters.
result (EventResult)
The result.


Cancel Method (args)

Cancel Method (args)
Namespaces ► Sitecore.Events ► SitecoreEventArgs ► Cancel(EventArgs)
Cancels this event.
Declaration Syntax
C#
public static void Cancel(
    EventArgs args
)
Parameters
args (EventArgs)
The arguments.


EventName Property

EventName Property
Namespaces ► Sitecore.Events ► SitecoreEventArgs ► EventName
Gets the name of the event.
Declaration Syntax
C#
public string EventName { get; }
Value
The name of the event.


GetDataManager Method (args, index)

GetDataManager Method (args, index)
Namespaces ► Sitecore.Events ► SitecoreEventArgs ► GetDataManager(EventArgs, Int32)
Gets the data manager.
Declaration Syntax
C#
public static DataManager GetDataManager(
    EventArgs args,
    int index
)
Parameters
args (EventArgs)
The arguments.
index (Int32)
The index.
Return Value
The DataManager.


GetID Method (args, index)

GetID Method (args, index)
Namespaces ► Sitecore.Events ► SitecoreEventArgs ► GetID(EventArgs, Int32)
Gets the ID.
Declaration Syntax
C#
public static ID GetID(
    EventArgs args,
    int index
)
Parameters
args (EventArgs)
The arguments.
index (Int32)
The index.
Return Value
The ID.


GetItem Method (args, index)

GetItem Method (args, index)
Namespaces ► Sitecore.Events ► SitecoreEventArgs ► GetItem(EventArgs, Int32)
Gets the item.
Declaration Syntax
C#
public static Item GetItem(
    EventArgs args,
    int index
)
Parameters
args (EventArgs)
The arguments.
index (Int32)
The index.
Return Value
The Item.


GetObject Method (args, index)

GetObject Method (args, index)
Namespaces ► Sitecore.Events ► SitecoreEventArgs ► GetObject(EventArgs, Int32)
Gets the object.
Declaration Syntax
C#
public static Object GetObject(
    EventArgs args,
    int index
)
Parameters
args (EventArgs)
The arguments.
index (Int32)
The index.
Return Value
The Object.


GetString Method (args, index)

GetString Method (args, index)
Namespaces ► Sitecore.Events ► SitecoreEventArgs ► GetString(EventArgs, Int32)
Gets the string.
Declaration Syntax
C#
public static string GetString(
    EventArgs args,
    int index
)
Parameters
args (EventArgs)
The arguments.
index (Int32)
The index.
Return Value
The String.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Events ► SitecoreEventArgs ► Parameters
Gets the parameters.
Declaration Syntax
C#
public Object[] Parameters { get; }
Value
The parameters.


Result Property

Result Property
Namespaces ► Sitecore.Events ► SitecoreEventArgs ► Result
Gets the result.
Declaration Syntax
C#
public EventResult Result { get; }
Value
The result.


TemplateUpdatedEventArgs Class

TemplateUpdatedEventArgs Class
Namespaces ► Sitecore.Events ► TemplateUpdatedEventArgs
Represents a template updated event argument class.
Declaration Syntax
C#
public class TemplateUpdatedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateUpdatedEventArgs(ID) | Initializes a new instance of the TemplateUpdatedEventArgs class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemID | Gets the item ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | TemplateUpdatedEventArgs


TemplateUpdatedEventArgs Constructor (itemID)

TemplateUpdatedEventArgs Constructor (itemID)
Namespaces ► Sitecore.Events ► TemplateUpdatedEventArgs ► TemplateUpdatedEventArgs(ID)
Initializes a new instance of the TemplateUpdatedEventArgs class.
Declaration Syntax
C#
public TemplateUpdatedEventArgs(
    ID itemID
)
Parameters
itemID (ID)
The item ID.


ItemID Property

ItemID Property
Namespaces ► Sitecore.Events ► TemplateUpdatedEventArgs ► ItemID
Gets the item ID.
Declaration Syntax
C#
public ID ItemID { get; }
Value
The item ID.


VersionRemovedEventArgs Class

VersionRemovedEventArgs Class
Namespaces ► Sitecore.Events ► VersionRemovedEventArgs
Defines the arguments passed in a VersionRemoved event.
Declaration Syntax
C#
public class VersionRemovedEventArgs : CancelEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VersionRemovedEventArgs(Item) | Creates a new VersionRemovedEventArgs instance.
 | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CancelEventArgs
 |  |  | VersionRemovedEventArgs


VersionRemovedEventArgs Constructor (item)

VersionRemovedEventArgs Constructor (item)
Namespaces ► Sitecore.Events ► VersionRemovedEventArgs ► VersionRemovedEventArgs(Item)
Creates a new VersionRemovedEventArgs instance.
Declaration Syntax
C#
public VersionRemovedEventArgs(
    Item item
)
Parameters
item (Item)
Item.


Item Property

Item Property
Namespaces ► Sitecore.Events ► VersionRemovedEventArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


WellknownEvents Class

WellknownEvents Class
Namespaces ► Sitecore.Events ► WellknownEvents
WellknownEvents
Declaration Syntax
C#
public class WellknownEvents
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WellknownEvents()()() | Initializes a new instance of the WellknownEvents class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemTemplateChanged |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WellknownEvents


WellknownEvents Constructor

WellknownEvents Constructor
Namespaces ► Sitecore.Events ► WellknownEvents ► WellknownEvents()()()
Initializes a new instance of the WellknownEvents class
Declaration Syntax
C#
public WellknownEvents()


ItemTemplateChanged Field

ItemTemplateChanged Field
Namespaces ► Sitecore.Events ► WellknownEvents ► ItemTemplateChanged
Declaration Syntax
C#
public const string ItemTemplateChanged


Sitecore.Events.Hooks Namespace

Sitecore.Events.Hooks Namespace
Namespaces ► Sitecore.Events.Hooks
Declaration Syntax
C#
namespace Sitecore.Events.Hooks
Types
All Types Classes Interfaces
Icon | Type | Description
 | HookManager | Represents a hook manager.
 | IHook | Defines the basic methods of a hook.


HookManager Class

HookManager Class
Namespaces ► Sitecore.Events.Hooks ► HookManager
Represents a hook manager.
Declaration Syntax
C#
public static class HookManager
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LoadAll()()() | Loads all.
Inheritance Hierarchy
Object
HookManager


LoadAll Method

LoadAll Method
Namespaces ► Sitecore.Events.Hooks ► HookManager ► LoadAll()()()
Loads all.
Declaration Syntax
C#
public static void LoadAll()


IHook Interface

IHook Interface
Namespaces ► Sitecore.Events.Hooks ► IHook
Defines the basic methods of a hook.
Declaration Syntax
C#
public interface IHook
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Initialize()()() | Initializes this instance.


Initialize Method

Initialize Method
Namespaces ► Sitecore.Events.Hooks ► IHook ► Initialize()()()
Initializes this instance.
Declaration Syntax
C#
void Initialize()


Sitecore.Exceptions Namespace

Sitecore.Exceptions Namespace
Namespaces ► Sitecore.Exceptions
Declaration Syntax
C#
namespace Sitecore.Exceptions
Types
All Types Classes
Icon | Type | Description
 | AccessDeniedException | Represents a AccessDenied exception.
 | CircularReferenceException | Represents a circular reference exception.
 | ClientAlertException | Represents a client alert exception. Throwing such an exception in SheerUI code will display an alert to the user.
 | ClientExceptionAttribute | Defines how the exception is displayed in the client.
 | ConfigurationException | ConfigurationException
 | ControlNotFoundException | Represents a control not found exception.
 | CyclicSublayoutException | CyclicSublayoutException
 | DatabaseNullException | Represents a item not found exception.
 | DomainException | DomainException
 | DomainExistsException | DomainExistsException
 | EditingNotAllowedException | Represents a editing not allowed exception.
 | InvalidItemException | Represents a invalid item exception.
 | InvalidItemNameException | Represents a invalid item name exception.
 | InvalidStructureException | Represents a invalid structure exception.
 | InvalidTypeException | InvalidTypeException
 | InvalidValueException | Represents a invalid value exception.
 | ItemNotFoundException | Represents a item not found exception.
 | ItemNullException | Represents a item not found exception.
 | LoadOnlyPropertyException | Represents a load only property exception.
 | LookupSourceException | Represents the lookup source exception
 | PipelineException | PipelineException class
 | ProviderConfigurationException | ProviderConfigurationException
 | ProviderIsReadOnlyException | ProviderIsReadOnlyException
 | QueryException | Represents a query exception.
 | ReflectionException | ReflectionException
 | RequiredObjectIsNullException | Represents a required object is null exception.
 | SitecoreException | Defines the basic properties and functionality of a Sitecore exception.
 | TemplateNotFoundException | Represents a template not found exception.
 | TicketParseException | Represents a ticket parse exception.
 | TodoException | TodoException class
 | UnknownDomainException | UnknownDomainException
 | UnknownTypeException | Represents a unknown type exception.
 | UnsupportedThumbnailImageFormatException | Represents a unsupported thumbnail image format exception.
 | WorkflowException | Represents a workflow exception.
 | WorkflowInitialStateMissingException | Thrown if worfklow misses an initial state.
 | WorkflowStateMissingException | Represents a Workflow State Missing exception.


AccessDeniedException Class

AccessDeniedException Class
Namespaces ► Sitecore.Exceptions ► AccessDeniedException
Represents a AccessDenied exception.
Declaration Syntax
C#
[SerializableAttribute]
public class AccessDeniedException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessDeniedException()()() | Initializes a new instance of the AccessDeniedException class.
 | AccessDeniedException(String) | Initializes a new instance of the AccessDeniedException class.
 | AccessDeniedException(String, Exception) | Initializes a new instance of the AccessDeniedException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | AccessDeniedException


AccessDeniedException Constructor

AccessDeniedException Constructor
Namespaces ► Sitecore.Exceptions ► AccessDeniedException ► AccessDeniedException()()()
Members
Icon | Member | Description
 | AccessDeniedException()()() | Initializes a new instance of the AccessDeniedException class.
 | AccessDeniedException(String) | Initializes a new instance of the AccessDeniedException class.
 | AccessDeniedException(String, Exception) | Initializes a new instance of the AccessDeniedException class.


AccessDeniedException Constructor

AccessDeniedException Constructor
Namespaces ► Sitecore.Exceptions ► AccessDeniedException ► AccessDeniedException()()()
Initializes a new instance of the AccessDeniedException class.
Declaration Syntax
C#
public AccessDeniedException()


AccessDeniedException Constructor (message)

AccessDeniedException Constructor (message)
Namespaces ► Sitecore.Exceptions ► AccessDeniedException ► AccessDeniedException(String)
Initializes a new instance of the AccessDeniedException class.
Declaration Syntax
C#
public AccessDeniedException(
    string message
)
Parameters
message (String)
The message.


AccessDeniedException Constructor (message, innnerException)

AccessDeniedException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► AccessDeniedException ► AccessDeniedException(String, Exception)
Initializes a new instance of the AccessDeniedException class.
Declaration Syntax
C#
public AccessDeniedException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


CircularReferenceException Class

CircularReferenceException Class
Namespaces ► Sitecore.Exceptions ► CircularReferenceException
Represents a circular reference exception.
Declaration Syntax
C#
[SerializableAttribute]
public class CircularReferenceException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CircularReferenceException()()() | Initializes a new instance of the CircularReferenceException class.
 | CircularReferenceException(String) | Initializes a new instance of the CircularReferenceException class.
 | CircularReferenceException(String, Exception) | Initializes a new instance of the CircularReferenceException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | CircularReferenceException


CircularReferenceException Constructor

CircularReferenceException Constructor
Namespaces ► Sitecore.Exceptions ► CircularReferenceException ► CircularReferenceException()()()
Members
Icon | Member | Description
 | CircularReferenceException()()() | Initializes a new instance of the CircularReferenceException class.
 | CircularReferenceException(String) | Initializes a new instance of the CircularReferenceException class.
 | CircularReferenceException(String, Exception) | Initializes a new instance of the CircularReferenceException class.


CircularReferenceException Constructor

CircularReferenceException Constructor
Namespaces ► Sitecore.Exceptions ► CircularReferenceException ► CircularReferenceException()()()
Initializes a new instance of the CircularReferenceException class.
Declaration Syntax
C#
public CircularReferenceException()


CircularReferenceException Constructor (message)

CircularReferenceException Constructor (message)
Namespaces ► Sitecore.Exceptions ► CircularReferenceException ► CircularReferenceException(String)
Initializes a new instance of the CircularReferenceException class.
Declaration Syntax
C#
public CircularReferenceException(
    string message
)
Parameters
message (String)
The message.


CircularReferenceException Constructor (message, innnerException)

CircularReferenceException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► CircularReferenceException ► CircularReferenceException(String, Exception)
Initializes a new instance of the CircularReferenceException class.
Declaration Syntax
C#
public CircularReferenceException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


ClientAlertException Class

ClientAlertException Class
Namespaces ► Sitecore.Exceptions ► ClientAlertException
Represents a client alert exception. Throwing such an exception in SheerUI code will display an alert to the user.
Declaration Syntax
C#
[SerializableAttribute]
public class ClientAlertException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientAlertException(String) | Initializes a new instance of the ClientAlertException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | ClientAlertException


ClientAlertException Constructor (message)

ClientAlertException Constructor (message)
Namespaces ► Sitecore.Exceptions ► ClientAlertException ► ClientAlertException(String)
Initializes a new instance of the ClientAlertException class.
Declaration Syntax
C#
public ClientAlertException(
    string message
)
Parameters
message (String)
The message.


ClientExceptionAttribute Class

ClientExceptionAttribute Class
Namespaces ► Sitecore.Exceptions ► ClientExceptionAttribute
Defines how the exception is displayed in the client.
Declaration Syntax
C#
public sealed class ClientExceptionAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientExceptionAttribute()()() | Initializes a new instance of the ClientExceptionAttribute class.
 | ClientExceptionAttribute(Boolean) | Initializes a new instance of the ClientExceptionAttribute class.
 | Alert | Gets or sets a value indicating whether this ClientExceptionAttribute is an alert.
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Reload | Gets or sets a value indicating whether this ClientExceptionAttribute causes the client to reload.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | ClientExceptionAttribute


ClientExceptionAttribute Constructor

ClientExceptionAttribute Constructor
Namespaces ► Sitecore.Exceptions ► ClientExceptionAttribute ► ClientExceptionAttribute()()()
Members
Icon | Member | Description
 | ClientExceptionAttribute()()() | Initializes a new instance of the ClientExceptionAttribute class.
 | ClientExceptionAttribute(Boolean) | Initializes a new instance of the ClientExceptionAttribute class.


ClientExceptionAttribute Constructor

ClientExceptionAttribute Constructor
Namespaces ► Sitecore.Exceptions ► ClientExceptionAttribute ► ClientExceptionAttribute()()()
Initializes a new instance of the ClientExceptionAttribute class.
Declaration Syntax
C#
public ClientExceptionAttribute()


ClientExceptionAttribute Constructor (alert)

ClientExceptionAttribute Constructor (alert)
Namespaces ► Sitecore.Exceptions ► ClientExceptionAttribute ► ClientExceptionAttribute(Boolean)
Initializes a new instance of the ClientExceptionAttribute class.
Declaration Syntax
C#
public ClientExceptionAttribute(
    bool alert
)
Parameters
alert (Boolean)
if set to true this instance is alert.


Alert Property

Alert Property
Namespaces ► Sitecore.Exceptions ► ClientExceptionAttribute ► Alert
Gets or sets a value indicating whether this ClientExceptionAttribute is an alert.
Declaration Syntax
C#
public bool Alert { get; set; }
Value
true if alert; otherwise, false.


Reload Property

Reload Property
Namespaces ► Sitecore.Exceptions ► ClientExceptionAttribute ► Reload
Gets or sets a value indicating whether this ClientExceptionAttribute causes the client to reload.
Declaration Syntax
C#
public bool Reload { get; set; }
Value
true if reload; otherwise, false.


ConfigurationException Class

ConfigurationException Class
Namespaces ► Sitecore.Exceptions ► ConfigurationException
ConfigurationException
Declaration Syntax
C#
[SerializableAttribute]
public class ConfigurationException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationException(String) | Initializes a new instance of the ConfigurationException class.
 | ConfigurationException(String, Exception) | Initializes a new instance of the ConfigurationException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | ConfigurationException


ConfigurationException Constructor

ConfigurationException Constructor
Namespaces ► Sitecore.Exceptions ► ConfigurationException ► ConfigurationException()()()
Members
Icon | Member | Description
 | ConfigurationException(String) | Initializes a new instance of the ConfigurationException class.
 | ConfigurationException(String, Exception) | Initializes a new instance of the ConfigurationException class.


ConfigurationException Constructor (message)

ConfigurationException Constructor (message)
Namespaces ► Sitecore.Exceptions ► ConfigurationException ► ConfigurationException(String)
Initializes a new instance of the ConfigurationException class.
Declaration Syntax
C#
public ConfigurationException(
    string message
)
Parameters
message (String)
The message.


ConfigurationException Constructor (message, innnerException)

ConfigurationException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► ConfigurationException ► ConfigurationException(String, Exception)
Initializes a new instance of the ConfigurationException class.
Declaration Syntax
C#
public ConfigurationException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


ControlNotFoundException Class

ControlNotFoundException Class
Namespaces ► Sitecore.Exceptions ► ControlNotFoundException
Represents a control not found exception.
Declaration Syntax
C#
[SerializableAttribute]
public class ControlNotFoundException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ControlNotFoundException(String) | Initializes a new instance of the ControlNotFoundException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | ControlNotFoundException


ControlNotFoundException Constructor (message)

ControlNotFoundException Constructor (message)
Namespaces ► Sitecore.Exceptions ► ControlNotFoundException ► ControlNotFoundException(String)
Initializes a new instance of the ControlNotFoundException class.
Declaration Syntax
C#
public ControlNotFoundException(
    string message
)
Parameters
message (String)
The message.


CyclicSublayoutException Class

CyclicSublayoutException Class
Namespaces ► Sitecore.Exceptions ► CyclicSublayoutException
CyclicSublayoutException
Declaration Syntax
C#
[SerializableAttribute]
public class CyclicSublayoutException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CyclicSublayoutException(String) | Initializes a new instance of the CyclicSublayoutException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | CyclicSublayoutException


CyclicSublayoutException Constructor (message)

CyclicSublayoutException Constructor (message)
Namespaces ► Sitecore.Exceptions ► CyclicSublayoutException ► CyclicSublayoutException(String)
Initializes a new instance of the CyclicSublayoutException class.
Declaration Syntax
C#
public CyclicSublayoutException(
    string message
)
Parameters
message (String)
The message.


DatabaseNullException Class

DatabaseNullException Class
Namespaces ► Sitecore.Exceptions ► DatabaseNullException
Represents a item not found exception.
Declaration Syntax
C#
[SerializableAttribute]
public class DatabaseNullException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatabaseNullException()()() | Initializes a new instance of the ItemNotFoundException class.
 | DatabaseNullException(String) | Initializes a new instance of the ItemNotFoundException class.
 | DatabaseNullException(String, Exception) | Initializes a new instance of the ItemNotFoundException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | DatabaseNullException


DatabaseNullException Constructor

DatabaseNullException Constructor
Namespaces ► Sitecore.Exceptions ► DatabaseNullException ► DatabaseNullException()()()
Members
Icon | Member | Description
 | DatabaseNullException()()() | Initializes a new instance of the ItemNotFoundException class.
 | DatabaseNullException(String) | Initializes a new instance of the ItemNotFoundException class.
 | DatabaseNullException(String, Exception) | Initializes a new instance of the ItemNotFoundException class.


DatabaseNullException Constructor

DatabaseNullException Constructor
Namespaces ► Sitecore.Exceptions ► DatabaseNullException ► DatabaseNullException()()()
Initializes a new instance of the ItemNotFoundException class.
Declaration Syntax
C#
public DatabaseNullException()


DatabaseNullException Constructor (message)

DatabaseNullException Constructor (message)
Namespaces ► Sitecore.Exceptions ► DatabaseNullException ► DatabaseNullException(String)
Initializes a new instance of the ItemNotFoundException class.
Declaration Syntax
C#
public DatabaseNullException(
    string message
)
Parameters
message (String)
The message.


DatabaseNullException Constructor (message, innnerException)

DatabaseNullException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► DatabaseNullException ► DatabaseNullException(String, Exception)
Initializes a new instance of the ItemNotFoundException class.
Declaration Syntax
C#
public DatabaseNullException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


DomainException Class

DomainException Class
Namespaces ► Sitecore.Exceptions ► DomainException
DomainException
Declaration Syntax
C#
[SerializableAttribute]
public class DomainException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainException(String) | Initializes a new instance of the DomainException class.
 | DomainException(String, Exception) | Initializes a new instance of the DomainException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | DomainException


DomainException Constructor

DomainException Constructor
Namespaces ► Sitecore.Exceptions ► DomainException ► DomainException()()()
Members
Icon | Member | Description
 | DomainException(String) | Initializes a new instance of the DomainException class.
 | DomainException(String, Exception) | Initializes a new instance of the DomainException class.


DomainException Constructor (message)

DomainException Constructor (message)
Namespaces ► Sitecore.Exceptions ► DomainException ► DomainException(String)
Initializes a new instance of the DomainException class.
Declaration Syntax
C#
public DomainException(
    string message
)
Parameters
message (String)
The message.


DomainException Constructor (message, innnerException)

DomainException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► DomainException ► DomainException(String, Exception)
Initializes a new instance of the DomainException class.
Declaration Syntax
C#
public DomainException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


DomainExistsException Class

DomainExistsException Class
Namespaces ► Sitecore.Exceptions ► DomainExistsException
DomainExistsException
Declaration Syntax
C#
[SerializableAttribute]
public class DomainExistsException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainExistsException(String) | Initializes a new instance of the DomainExistsException class.
 | DomainExistsException(String, Exception) | Initializes a new instance of the DomainExistsException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | DomainExistsException


DomainExistsException Constructor

DomainExistsException Constructor
Namespaces ► Sitecore.Exceptions ► DomainExistsException ► DomainExistsException()()()
Members
Icon | Member | Description
 | DomainExistsException(String) | Initializes a new instance of the DomainExistsException class.
 | DomainExistsException(String, Exception) | Initializes a new instance of the DomainExistsException class.


DomainExistsException Constructor (message)

DomainExistsException Constructor (message)
Namespaces ► Sitecore.Exceptions ► DomainExistsException ► DomainExistsException(String)
Initializes a new instance of the DomainExistsException class.
Declaration Syntax
C#
public DomainExistsException(
    string message
)
Parameters
message (String)
The message.


DomainExistsException Constructor (message, innnerException)

DomainExistsException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► DomainExistsException ► DomainExistsException(String, Exception)
Initializes a new instance of the DomainExistsException class.
Declaration Syntax
C#
public DomainExistsException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


EditingNotAllowedException Class

EditingNotAllowedException Class
Namespaces ► Sitecore.Exceptions ► EditingNotAllowedException
Represents a editing not allowed exception.
Declaration Syntax
C#
[SerializableAttribute]
public class EditingNotAllowedException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditingNotAllowedException(Item) | Initializes a new instance of the EditingNotAllowedException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | EditingNotAllowedException


EditingNotAllowedException Constructor (item)

EditingNotAllowedException Constructor (item)
Namespaces ► Sitecore.Exceptions ► EditingNotAllowedException ► EditingNotAllowedException(Item)
Initializes a new instance of the EditingNotAllowedException class.
Declaration Syntax
C#
public EditingNotAllowedException(
    Item item
)
Parameters
item (Item)
The item.


InvalidItemException Class

InvalidItemException Class
Namespaces ► Sitecore.Exceptions ► InvalidItemException
Represents a invalid item exception.
Declaration Syntax
C#
[SerializableAttribute]
public class InvalidItemException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InvalidItemException(String) | Initializes a new instance of the InvalidItemException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | InvalidItemException


InvalidItemException Constructor (message)

InvalidItemException Constructor (message)
Namespaces ► Sitecore.Exceptions ► InvalidItemException ► InvalidItemException(String)
Initializes a new instance of the InvalidItemException class.
Declaration Syntax
C#
public InvalidItemException(
    string message
)
Parameters
message (String)
The message.


InvalidItemNameException Class

InvalidItemNameException Class
Namespaces ► Sitecore.Exceptions ► InvalidItemNameException
Represents a invalid item name exception.
Declaration Syntax
C#
[SerializableAttribute]
public class InvalidItemNameException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InvalidItemNameException(String) | Initializes a new instance of the InvalidItemNameException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | InvalidItemNameException


InvalidItemNameException Constructor (message)

InvalidItemNameException Constructor (message)
Namespaces ► Sitecore.Exceptions ► InvalidItemNameException ► InvalidItemNameException(String)
Initializes a new instance of the InvalidItemNameException class.
Declaration Syntax
C#
public InvalidItemNameException(
    string message
)
Parameters
message (String)
The message.


InvalidStructureException Class

InvalidStructureException Class
Namespaces ► Sitecore.Exceptions ► InvalidStructureException
Represents a invalid structure exception.
Declaration Syntax
C#
[SerializableAttribute]
public class InvalidStructureException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InvalidStructureException(String) | Initializes a new instance of the InvalidStructureException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | InvalidStructureException


InvalidStructureException Constructor (message)

InvalidStructureException Constructor (message)
Namespaces ► Sitecore.Exceptions ► InvalidStructureException ► InvalidStructureException(String)
Initializes a new instance of the InvalidStructureException class.
Declaration Syntax
C#
public InvalidStructureException(
    string message
)
Parameters
message (String)
The message.


InvalidTypeException Class

InvalidTypeException Class
Namespaces ► Sitecore.Exceptions ► InvalidTypeException
InvalidTypeException
Declaration Syntax
C#
[SerializableAttribute]
public class InvalidTypeException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InvalidTypeException(String) | Initializes a new instance of the InvalidTypeException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | InvalidTypeException


InvalidTypeException Constructor (message)

InvalidTypeException Constructor (message)
Namespaces ► Sitecore.Exceptions ► InvalidTypeException ► InvalidTypeException(String)
Initializes a new instance of the InvalidTypeException class.
Declaration Syntax
C#
public InvalidTypeException(
    string message
)
Parameters
message (String)
The message.


InvalidValueException Class

InvalidValueException Class
Namespaces ► Sitecore.Exceptions ► InvalidValueException
Represents a invalid value exception.
Declaration Syntax
C#
[SerializableAttribute]
public class InvalidValueException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InvalidValueException(String) | Initializes a new instance of the InvalidValueException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | InvalidValueException


InvalidValueException Constructor (message)

InvalidValueException Constructor (message)
Namespaces ► Sitecore.Exceptions ► InvalidValueException ► InvalidValueException(String)
Initializes a new instance of the InvalidValueException class.
Declaration Syntax
C#
public InvalidValueException(
    string message
)
Parameters
message (String)
The message.


ItemNotFoundException Class

ItemNotFoundException Class
Namespaces ► Sitecore.Exceptions ► ItemNotFoundException
Represents a item not found exception.
Declaration Syntax
C#
[SerializableAttribute]
public class ItemNotFoundException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemNotFoundException()()() | Initializes a new instance of the ItemNotFoundException class.
 | ItemNotFoundException(String) | Initializes a new instance of the ItemNotFoundException class.
 | ItemNotFoundException(String, Exception) | Initializes a new instance of the ItemNotFoundException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | ItemNotFoundException


ItemNotFoundException Constructor

ItemNotFoundException Constructor
Namespaces ► Sitecore.Exceptions ► ItemNotFoundException ► ItemNotFoundException()()()
Members
Icon | Member | Description
 | ItemNotFoundException()()() | Initializes a new instance of the ItemNotFoundException class.
 | ItemNotFoundException(String) | Initializes a new instance of the ItemNotFoundException class.
 | ItemNotFoundException(String, Exception) | Initializes a new instance of the ItemNotFoundException class.


ItemNotFoundException Constructor

ItemNotFoundException Constructor
Namespaces ► Sitecore.Exceptions ► ItemNotFoundException ► ItemNotFoundException()()()
Initializes a new instance of the ItemNotFoundException class.
Declaration Syntax
C#
public ItemNotFoundException()


ItemNotFoundException Constructor (message)

ItemNotFoundException Constructor (message)
Namespaces ► Sitecore.Exceptions ► ItemNotFoundException ► ItemNotFoundException(String)
Initializes a new instance of the ItemNotFoundException class.
Declaration Syntax
C#
public ItemNotFoundException(
    string message
)
Parameters
message (String)
The message.


ItemNotFoundException Constructor (message, innnerException)

ItemNotFoundException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► ItemNotFoundException ► ItemNotFoundException(String, Exception)
Initializes a new instance of the ItemNotFoundException class.
Declaration Syntax
C#
public ItemNotFoundException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


ItemNullException Class

ItemNullException Class
Namespaces ► Sitecore.Exceptions ► ItemNullException
Represents a item not found exception.
Declaration Syntax
C#
[SerializableAttribute]
public class ItemNullException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemNullException()()() | Initializes a new instance of the ItemNotFoundException class.
 | ItemNullException(String) | Initializes a new instance of the ItemNotFoundException class.
 | ItemNullException(String, Exception) | Initializes a new instance of the ItemNotFoundException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | ItemNullException


ItemNullException Constructor

ItemNullException Constructor
Namespaces ► Sitecore.Exceptions ► ItemNullException ► ItemNullException()()()
Members
Icon | Member | Description
 | ItemNullException()()() | Initializes a new instance of the ItemNotFoundException class.
 | ItemNullException(String) | Initializes a new instance of the ItemNotFoundException class.
 | ItemNullException(String, Exception) | Initializes a new instance of the ItemNotFoundException class.


ItemNullException Constructor

ItemNullException Constructor
Namespaces ► Sitecore.Exceptions ► ItemNullException ► ItemNullException()()()
Initializes a new instance of the ItemNotFoundException class.
Declaration Syntax
C#
public ItemNullException()


ItemNullException Constructor (itemPath)

ItemNullException Constructor (itemPath)
Namespaces ► Sitecore.Exceptions ► ItemNullException ► ItemNullException(String)
Initializes a new instance of the ItemNotFoundException class.
Declaration Syntax
C#
public ItemNullException(
    string itemPath
)
Parameters
itemPath (String)
The item path.


ItemNullException Constructor (message, innnerException)

ItemNullException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► ItemNullException ► ItemNullException(String, Exception)
Initializes a new instance of the ItemNotFoundException class.
Declaration Syntax
C#
public ItemNullException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


LoadOnlyPropertyException Class

LoadOnlyPropertyException Class
Namespaces ► Sitecore.Exceptions ► LoadOnlyPropertyException
Represents a load only property exception.
Declaration Syntax
C#
[SerializableAttribute]
public class LoadOnlyPropertyException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoadOnlyPropertyException(String) | Initializes a new instance of the LoadOnlyPropertyException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | LoadOnlyPropertyException


LoadOnlyPropertyException Constructor (propertyName)

LoadOnlyPropertyException Constructor (propertyName)
Namespaces ► Sitecore.Exceptions ► LoadOnlyPropertyException ► LoadOnlyPropertyException(String)
Initializes a new instance of the LoadOnlyPropertyException class.
Declaration Syntax
C#
public LoadOnlyPropertyException(
    string propertyName
)
Parameters
propertyName (String)
Name of the property.


LookupSourceException Class

LookupSourceException Class
Namespaces ► Sitecore.Exceptions ► LookupSourceException
Represents the lookup source exception
Declaration Syntax
C#
[SerializableAttribute]
public class LookupSourceException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LookupSourceException(String, Exception) | Initializes a new instance of the LookupSourceException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | InnerMessage | Gets the inner message.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | LookupSourceException


LookupSourceException Constructor (source, innerException)

LookupSourceException Constructor (source, innerException)
Namespaces ► Sitecore.Exceptions ► LookupSourceException ► LookupSourceException(String, Exception)
Initializes a new instance of the LookupSourceException class.
Declaration Syntax
C#
public LookupSourceException(
    string source,
    Exception innerException
)
Parameters
source (String)
The source.
innerException (Exception)
The inner exception.


InnerMessage Property

InnerMessage Property
Namespaces ► Sitecore.Exceptions ► LookupSourceException ► InnerMessage
Gets the inner message.
Declaration Syntax
C#
public Object InnerMessage { get; }
Value
The inner message.


PipelineException Class

PipelineException Class
Namespaces ► Sitecore.Exceptions ► PipelineException
PipelineException class
Declaration Syntax
C#
public class PipelineException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PipelineException(String) | Initializes a new instance of the PipelineException class.
 | PipelineException(String, Exception) | Initializes a new instance of the PipelineException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | PipelineException


PipelineException Constructor

PipelineException Constructor
Namespaces ► Sitecore.Exceptions ► PipelineException ► PipelineException()()()
Members
Icon | Member | Description
 | PipelineException(String) | Initializes a new instance of the PipelineException class.
 | PipelineException(String, Exception) | Initializes a new instance of the PipelineException class.


PipelineException Constructor (message)

PipelineException Constructor (message)
Namespaces ► Sitecore.Exceptions ► PipelineException ► PipelineException(String)
Initializes a new instance of the PipelineException class.
Declaration Syntax
C#
public PipelineException(
    string message
)
Parameters
message (String)
The message.


PipelineException Constructor (message, innnerException)

PipelineException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► PipelineException ► PipelineException(String, Exception)
Initializes a new instance of the PipelineException class.
Declaration Syntax
C#
public PipelineException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


ProviderConfigurationException Class

ProviderConfigurationException Class
Namespaces ► Sitecore.Exceptions ► ProviderConfigurationException
ProviderConfigurationException
Declaration Syntax
C#
[SerializableAttribute]
public class ProviderConfigurationException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProviderConfigurationException(String) | Initializes a new instance of the ProviderConfigurationException class.
 | ProviderConfigurationException(String, Exception) | Initializes a new instance of the ProviderConfigurationException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | ProviderConfigurationException


ProviderConfigurationException Constructor

ProviderConfigurationException Constructor
Namespaces ► Sitecore.Exceptions ► ProviderConfigurationException ► ProviderConfigurationException()()()
Members
Icon | Member | Description
 | ProviderConfigurationException(String) | Initializes a new instance of the ProviderConfigurationException class.
 | ProviderConfigurationException(String, Exception) | Initializes a new instance of the ProviderConfigurationException class.


ProviderConfigurationException Constructor (message)

ProviderConfigurationException Constructor (message)
Namespaces ► Sitecore.Exceptions ► ProviderConfigurationException ► ProviderConfigurationException(String)
Initializes a new instance of the ProviderConfigurationException class.
Declaration Syntax
C#
public ProviderConfigurationException(
    string message
)
Parameters
message (String)
The message.


ProviderConfigurationException Constructor (message, innnerException)

ProviderConfigurationException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► ProviderConfigurationException ► ProviderConfigurationException(String, Exception)
Initializes a new instance of the ProviderConfigurationException class.
Declaration Syntax
C#
public ProviderConfigurationException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


ProviderIsReadOnlyException Class

ProviderIsReadOnlyException Class
Namespaces ► Sitecore.Exceptions ► ProviderIsReadOnlyException
ProviderIsReadOnlyException
Declaration Syntax
C#
[SerializableAttribute]
public class ProviderIsReadOnlyException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProviderIsReadOnlyException(String) | Initializes a new instance of the ProviderIsReadOnlyException class.
 | ProviderIsReadOnlyException(String, Exception) | Initializes a new instance of the ProviderIsReadOnlyException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | ProviderIsReadOnlyException


ProviderIsReadOnlyException Constructor

ProviderIsReadOnlyException Constructor
Namespaces ► Sitecore.Exceptions ► ProviderIsReadOnlyException ► ProviderIsReadOnlyException()()()
Members
Icon | Member | Description
 | ProviderIsReadOnlyException(String) | Initializes a new instance of the ProviderIsReadOnlyException class.
 | ProviderIsReadOnlyException(String, Exception) | Initializes a new instance of the ProviderIsReadOnlyException class.


ProviderIsReadOnlyException Constructor (message)

ProviderIsReadOnlyException Constructor (message)
Namespaces ► Sitecore.Exceptions ► ProviderIsReadOnlyException ► ProviderIsReadOnlyException(String)
Initializes a new instance of the ProviderIsReadOnlyException class.
Declaration Syntax
C#
public ProviderIsReadOnlyException(
    string message
)
Parameters
message (String)
The message.


ProviderIsReadOnlyException Constructor (message, innnerException)

ProviderIsReadOnlyException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► ProviderIsReadOnlyException ► ProviderIsReadOnlyException(String, Exception)
Initializes a new instance of the ProviderIsReadOnlyException class.
Declaration Syntax
C#
public ProviderIsReadOnlyException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


QueryException Class

QueryException Class
Namespaces ► Sitecore.Exceptions ► QueryException
Represents a query exception.
Declaration Syntax
C#
[SerializableAttribute]
public class QueryException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QueryException()()() | Initializes a new instance of the QueryException class.
 | QueryException(String) | Initializes a new instance of the QueryException class.
 | QueryException(String, Exception) | Initializes a new instance of the QueryException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | QueryException


QueryException Constructor

QueryException Constructor
Namespaces ► Sitecore.Exceptions ► QueryException ► QueryException()()()
Members
Icon | Member | Description
 | QueryException()()() | Initializes a new instance of the QueryException class.
 | QueryException(String) | Initializes a new instance of the QueryException class.
 | QueryException(String, Exception) | Initializes a new instance of the QueryException class.


QueryException Constructor

QueryException Constructor
Namespaces ► Sitecore.Exceptions ► QueryException ► QueryException()()()
Initializes a new instance of the QueryException class.
Declaration Syntax
C#
public QueryException()


QueryException Constructor (message)

QueryException Constructor (message)
Namespaces ► Sitecore.Exceptions ► QueryException ► QueryException(String)
Initializes a new instance of the QueryException class.
Declaration Syntax
C#
public QueryException(
    string message
)
Parameters
message (String)
The message.


QueryException Constructor (message, innerException)

QueryException Constructor (message, innerException)
Namespaces ► Sitecore.Exceptions ► QueryException ► QueryException(String, Exception)
Initializes a new instance of the QueryException class.
Declaration Syntax
C#
public QueryException(
    string message,
    Exception innerException
)
Parameters
message (String)
The message.
innerException (Exception)
The inner exception.


ReflectionException Class

ReflectionException Class
Namespaces ► Sitecore.Exceptions ► ReflectionException
ReflectionException
Declaration Syntax
C#
[SerializableAttribute]
public class ReflectionException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReflectionException(String) | Initializes a new instance of the ReflectionException class.
 | ReflectionException(String, Exception) | Initializes a new instance of the ReflectionException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | ReflectionException


ReflectionException Constructor

ReflectionException Constructor
Namespaces ► Sitecore.Exceptions ► ReflectionException ► ReflectionException()()()
Members
Icon | Member | Description
 | ReflectionException(String) | Initializes a new instance of the ReflectionException class.
 | ReflectionException(String, Exception) | Initializes a new instance of the ReflectionException class.


ReflectionException Constructor (message)

ReflectionException Constructor (message)
Namespaces ► Sitecore.Exceptions ► ReflectionException ► ReflectionException(String)
Initializes a new instance of the ReflectionException class.
Declaration Syntax
C#
public ReflectionException(
    string message
)
Parameters
message (String)
The message.


ReflectionException Constructor (message, innnerException)

ReflectionException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► ReflectionException ► ReflectionException(String, Exception)
Initializes a new instance of the ReflectionException class.
Declaration Syntax
C#
public ReflectionException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


RequiredObjectIsNullException Class

RequiredObjectIsNullException Class
Namespaces ► Sitecore.Exceptions ► RequiredObjectIsNullException
Represents a required object is null exception.
Declaration Syntax
C#
[SerializableAttribute]
public class RequiredObjectIsNullException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RequiredObjectIsNullException(String) | Initializes a new instance of the RequiredObjectIsNullException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | RequiredObjectIsNullException


RequiredObjectIsNullException Constructor (message)

RequiredObjectIsNullException Constructor (message)
Namespaces ► Sitecore.Exceptions ► RequiredObjectIsNullException ► RequiredObjectIsNullException(String)
Initializes a new instance of the RequiredObjectIsNullException class.
Declaration Syntax
C#
public RequiredObjectIsNullException(
    string message
)
Parameters
message (String)
The message.


SitecoreException Class

SitecoreException Class
Namespaces ► Sitecore.Exceptions ► SitecoreException
Defines the basic properties and functionality of a Sitecore exception.
Declaration Syntax
C#
[SerializableAttribute]
public abstract class SitecoreException : Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SitecoreException()()() | Initializes a new instance of the SitecoreException class.
 | SitecoreException(String) | Initializes a new instance of the SitecoreException class.
 | SitecoreException(String, Exception) | Initializes a new instance of the SitecoreException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | ParseException
 |  |  | AccessDeniedException
 |  |  | CircularReferenceException
 |  |  | ClientAlertException
 |  |  | ConfigurationException
 |  |  | ControlNotFoundException
 |  |  | CyclicSublayoutException
 |  |  | DatabaseNullException
 |  |  | DomainException
 |  |  | DomainExistsException
 |  |  | EditingNotAllowedException
 |  |  | InvalidItemException
 |  |  | InvalidItemNameException
 |  |  | InvalidStructureException
 |  |  | InvalidTypeException
 |  |  | InvalidValueException
 |  |  | ItemNotFoundException
 |  |  | ItemNullException
 |  |  | LoadOnlyPropertyException
 |  |  | LookupSourceException
 |  |  | PipelineException
 |  |  | ProviderConfigurationException
 |  |  | ProviderIsReadOnlyException
 |  |  | QueryException
 |  |  | ReflectionException
 |  |  | RequiredObjectIsNullException
 |  |  | TemplateNotFoundException
 |  |  | TicketParseException
 |  |  | UnknownDomainException
 |  |  | UnknownTypeException
 |  |  | UnsupportedThumbnailImageFormatException
 |  |  | WorkflowException
 |  |  | LicenseException
 |  |  | ControlException


SitecoreException Constructor

SitecoreException Constructor
Namespaces ► Sitecore.Exceptions ► SitecoreException ► SitecoreException()()()
Members
Icon | Member | Description
 | SitecoreException()()() | Initializes a new instance of the SitecoreException class.
 | SitecoreException(String) | Initializes a new instance of the SitecoreException class.
 | SitecoreException(String, Exception) | Initializes a new instance of the SitecoreException class.


SitecoreException Constructor

SitecoreException Constructor
Namespaces ► Sitecore.Exceptions ► SitecoreException ► SitecoreException()()()
Initializes a new instance of the SitecoreException class.
Declaration Syntax
C#
protected SitecoreException()


SitecoreException Constructor (message)

SitecoreException Constructor (message)
Namespaces ► Sitecore.Exceptions ► SitecoreException ► SitecoreException(String)
Initializes a new instance of the SitecoreException class.
Declaration Syntax
C#
protected SitecoreException(
    string message
)
Parameters
message (String)
The message.


SitecoreException Constructor (message, innerException)

SitecoreException Constructor (message, innerException)
Namespaces ► Sitecore.Exceptions ► SitecoreException ► SitecoreException(String, Exception)
Initializes a new instance of the SitecoreException class.
Declaration Syntax
C#
protected SitecoreException(
    string message,
    Exception innerException
)
Parameters
message (String)
The message.
innerException (Exception)
The inner exception.


TemplateNotFoundException Class

TemplateNotFoundException Class
Namespaces ► Sitecore.Exceptions ► TemplateNotFoundException
Represents a template not found exception.
Declaration Syntax
C#
[SerializableAttribute]
public class TemplateNotFoundException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateNotFoundException()()() | Initializes a new instance of the TemplateNotFoundException class.
 | TemplateNotFoundException(String) | Initializes a new instance of the TemplateNotFoundException class.
 | TemplateNotFoundException(String, Exception) | Initializes a new instance of the TemplateNotFoundException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | TemplateNotFoundException


TemplateNotFoundException Constructor

TemplateNotFoundException Constructor
Namespaces ► Sitecore.Exceptions ► TemplateNotFoundException ► TemplateNotFoundException()()()
Members
Icon | Member | Description
 | TemplateNotFoundException()()() | Initializes a new instance of the TemplateNotFoundException class.
 | TemplateNotFoundException(String) | Initializes a new instance of the TemplateNotFoundException class.
 | TemplateNotFoundException(String, Exception) | Initializes a new instance of the TemplateNotFoundException class.


TemplateNotFoundException Constructor

TemplateNotFoundException Constructor
Namespaces ► Sitecore.Exceptions ► TemplateNotFoundException ► TemplateNotFoundException()()()
Initializes a new instance of the TemplateNotFoundException class.
Declaration Syntax
C#
public TemplateNotFoundException()


TemplateNotFoundException Constructor (message)

TemplateNotFoundException Constructor (message)
Namespaces ► Sitecore.Exceptions ► TemplateNotFoundException ► TemplateNotFoundException(String)
Initializes a new instance of the TemplateNotFoundException class.
Declaration Syntax
C#
public TemplateNotFoundException(
    string message
)
Parameters
message (String)
The message.


TemplateNotFoundException Constructor (message, innnerException)

TemplateNotFoundException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► TemplateNotFoundException ► TemplateNotFoundException(String, Exception)
Initializes a new instance of the TemplateNotFoundException class.
Declaration Syntax
C#
public TemplateNotFoundException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


TicketParseException Class

TicketParseException Class
Namespaces ► Sitecore.Exceptions ► TicketParseException
Represents a ticket parse exception.
Declaration Syntax
C#
[SerializableAttribute]
public class TicketParseException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TicketParseException()()() | Initializes a new instance of the TicketParseException class.
 | TicketParseException(String) | Initializes a new instance of the TicketParseException class.
 | TicketParseException(String, Exception) | Initializes a new instance of the TicketParseException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | TicketParseException


TicketParseException Constructor

TicketParseException Constructor
Namespaces ► Sitecore.Exceptions ► TicketParseException ► TicketParseException()()()
Members
Icon | Member | Description
 | TicketParseException()()() | Initializes a new instance of the TicketParseException class.
 | TicketParseException(String) | Initializes a new instance of the TicketParseException class.
 | TicketParseException(String, Exception) | Initializes a new instance of the TicketParseException class.


TicketParseException Constructor

TicketParseException Constructor
Namespaces ► Sitecore.Exceptions ► TicketParseException ► TicketParseException()()()
Initializes a new instance of the TicketParseException class.
Declaration Syntax
C#
public TicketParseException()


TicketParseException Constructor (message)

TicketParseException Constructor (message)
Namespaces ► Sitecore.Exceptions ► TicketParseException ► TicketParseException(String)
Initializes a new instance of the TicketParseException class.
Declaration Syntax
C#
public TicketParseException(
    string message
)
Parameters
message (String)
The message.


TicketParseException Constructor (message, innerException)

TicketParseException Constructor (message, innerException)
Namespaces ► Sitecore.Exceptions ► TicketParseException ► TicketParseException(String, Exception)
Initializes a new instance of the TicketParseException class.
Declaration Syntax
C#
public TicketParseException(
    string message,
    Exception innerException
)
Parameters
message (String)
The message.
innerException (Exception)
The inner exception.


TodoException Class

TodoException Class
Namespaces ► Sitecore.Exceptions ► TodoException
TodoException class
Declaration Syntax
C#
public class TodoException : NotImplementedException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TodoException(String) | Initializes a new instance of the TodoException class.
 | TodoException(String, Exception) | Initializes a new instance of the TodoException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SystemException
 |  |  | NotImplementedException
 |  |  |  | TodoException


TodoException Constructor

TodoException Constructor
Namespaces ► Sitecore.Exceptions ► TodoException ► TodoException()()()
Members
Icon | Member | Description
 | TodoException(String) | Initializes a new instance of the TodoException class.
 | TodoException(String, Exception) | Initializes a new instance of the TodoException class.


TodoException Constructor (message)

TodoException Constructor (message)
Namespaces ► Sitecore.Exceptions ► TodoException ► TodoException(String)
Initializes a new instance of the TodoException class.
Declaration Syntax
C#
public TodoException(
    string message
)
Parameters
message (String)
The message.


TodoException Constructor (message, innnerException)

TodoException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► TodoException ► TodoException(String, Exception)
Initializes a new instance of the TodoException class.
Declaration Syntax
C#
public TodoException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


UnknownDomainException Class

UnknownDomainException Class
Namespaces ► Sitecore.Exceptions ► UnknownDomainException
UnknownDomainException
Declaration Syntax
C#
[SerializableAttribute]
public class UnknownDomainException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnknownDomainException(String) | Initializes a new instance of the UnknownDomainException class.
 | UnknownDomainException(String, Exception) | Initializes a new instance of the UnknownDomainException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | UnknownDomainException


UnknownDomainException Constructor

UnknownDomainException Constructor
Namespaces ► Sitecore.Exceptions ► UnknownDomainException ► UnknownDomainException()()()
Members
Icon | Member | Description
 | UnknownDomainException(String) | Initializes a new instance of the UnknownDomainException class.
 | UnknownDomainException(String, Exception) | Initializes a new instance of the UnknownDomainException class.


UnknownDomainException Constructor (message)

UnknownDomainException Constructor (message)
Namespaces ► Sitecore.Exceptions ► UnknownDomainException ► UnknownDomainException(String)
Initializes a new instance of the UnknownDomainException class.
Declaration Syntax
C#
public UnknownDomainException(
    string message
)
Parameters
message (String)
The message.


UnknownDomainException Constructor (message, innnerException)

UnknownDomainException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► UnknownDomainException ► UnknownDomainException(String, Exception)
Initializes a new instance of the UnknownDomainException class.
Declaration Syntax
C#
public UnknownDomainException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


UnknownTypeException Class

UnknownTypeException Class
Namespaces ► Sitecore.Exceptions ► UnknownTypeException
Represents a unknown type exception.
Declaration Syntax
C#
[SerializableAttribute]
public class UnknownTypeException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnknownTypeException()()() | Initializes a new instance of the UnknownTypeException class.
 | UnknownTypeException(String) | Initializes a new instance of the UnknownTypeException class.
 | UnknownTypeException(String, Exception) | Initializes a new instance of the UnknownTypeException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | UnknownTypeException


UnknownTypeException Constructor

UnknownTypeException Constructor
Namespaces ► Sitecore.Exceptions ► UnknownTypeException ► UnknownTypeException()()()
Members
Icon | Member | Description
 | UnknownTypeException()()() | Initializes a new instance of the UnknownTypeException class.
 | UnknownTypeException(String) | Initializes a new instance of the UnknownTypeException class.
 | UnknownTypeException(String, Exception) | Initializes a new instance of the UnknownTypeException class.


UnknownTypeException Constructor

UnknownTypeException Constructor
Namespaces ► Sitecore.Exceptions ► UnknownTypeException ► UnknownTypeException()()()
Initializes a new instance of the UnknownTypeException class.
Declaration Syntax
C#
public UnknownTypeException()


UnknownTypeException Constructor (message)

UnknownTypeException Constructor (message)
Namespaces ► Sitecore.Exceptions ► UnknownTypeException ► UnknownTypeException(String)
Initializes a new instance of the UnknownTypeException class.
Declaration Syntax
C#
public UnknownTypeException(
    string message
)
Parameters
message (String)
The message.


UnknownTypeException Constructor (message, innnerException)

UnknownTypeException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► UnknownTypeException ► UnknownTypeException(String, Exception)
Initializes a new instance of the UnknownTypeException class.
Declaration Syntax
C#
public UnknownTypeException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


UnsupportedThumbnailImageFormatException Class

UnsupportedThumbnailImageFormatException Class
Namespaces ► Sitecore.Exceptions ► UnsupportedThumbnailImageFormatException
Represents a unsupported thumbnail image format exception.
Declaration Syntax
C#
[SerializableAttribute]
public class UnsupportedThumbnailImageFormatException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnsupportedThumbnailImageFormatException()()() | Initializes a new instance of the UnsupportedThumbnailImageFormatException class.
 | UnsupportedThumbnailImageFormatException(String) | Initializes a new instance of the UnsupportedThumbnailImageFormatException class.
 | UnsupportedThumbnailImageFormatException(String, Exception) | Initializes a new instance of the UnsupportedThumbnailImageFormatException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | UnsupportedThumbnailImageFormatException


UnsupportedThumbnailImageFormatException Constructor

UnsupportedThumbnailImageFormatException Constructor
Namespaces ► Sitecore.Exceptions ► UnsupportedThumbnailImageFormatException ► UnsupportedThumbnailImageFormatException()()()
Members
Icon | Member | Description
 | UnsupportedThumbnailImageFormatException()()() | Initializes a new instance of the UnsupportedThumbnailImageFormatException class.
 | UnsupportedThumbnailImageFormatException(String) | Initializes a new instance of the UnsupportedThumbnailImageFormatException class.
 | UnsupportedThumbnailImageFormatException(String, Exception) | Initializes a new instance of the UnsupportedThumbnailImageFormatException class.


UnsupportedThumbnailImageFormatException Constructor

UnsupportedThumbnailImageFormatException Constructor
Namespaces ► Sitecore.Exceptions ► UnsupportedThumbnailImageFormatException ► UnsupportedThumbnailImageFormatException()()()
Initializes a new instance of the UnsupportedThumbnailImageFormatException class.
Declaration Syntax
C#
public UnsupportedThumbnailImageFormatException()


UnsupportedThumbnailImageFormatException Constructor (message)

UnsupportedThumbnailImageFormatException Constructor (message)
Namespaces ► Sitecore.Exceptions ► UnsupportedThumbnailImageFormatException ► UnsupportedThumbnailImageFormatException(String)
Initializes a new instance of the UnsupportedThumbnailImageFormatException class.
Declaration Syntax
C#
public UnsupportedThumbnailImageFormatException(
    string message
)
Parameters
message (String)
The message.


UnsupportedThumbnailImageFormatException Constructor (message, innerException)

UnsupportedThumbnailImageFormatException Constructor (message, innerException)
Namespaces ► Sitecore.Exceptions ► UnsupportedThumbnailImageFormatException ► UnsupportedThumbnailImageFormatException(String, Exception)
Initializes a new instance of the UnsupportedThumbnailImageFormatException class.
Declaration Syntax
C#
public UnsupportedThumbnailImageFormatException(
    string message,
    Exception innerException
)
Parameters
message (String)
The message.
innerException (Exception)
The inner exception.


WorkflowException Class

WorkflowException Class
Namespaces ► Sitecore.Exceptions ► WorkflowException
Represents a workflow exception.
Declaration Syntax
C#
[SerializableAttribute]
public class WorkflowException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WorkflowException(String, Exception) | Initializes a new instance of the WorkflowException class.
 | WorkflowException(String, Item) | Initializes a new instance of the WorkflowException class.
 | WorkflowException(String) | Initializes a new instance of the WorkflowException class.
 | WorkflowException()()() | Initializes a new instance of the WorkflowException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | WorkflowException
 |  |  |  | WorkflowInitialStateMissingException
 |  |  |  | WorkflowStateMissingException


WorkflowException Constructor

WorkflowException Constructor
Namespaces ► Sitecore.Exceptions ► WorkflowException ► WorkflowException()()()
Members
Icon | Member | Description
 | WorkflowException(String, Exception) | Initializes a new instance of the WorkflowException class.
 | WorkflowException(String, Item) | Initializes a new instance of the WorkflowException class.
 | WorkflowException(String) | Initializes a new instance of the WorkflowException class.
 | WorkflowException()()() | Initializes a new instance of the WorkflowException class.


WorkflowException Constructor

WorkflowException Constructor
Namespaces ► Sitecore.Exceptions ► WorkflowException ► WorkflowException()()()
Initializes a new instance of the WorkflowException class.
Declaration Syntax
C#
public WorkflowException()


WorkflowException Constructor (message)

WorkflowException Constructor (message)
Namespaces ► Sitecore.Exceptions ► WorkflowException ► WorkflowException(String)
Initializes a new instance of the WorkflowException class.
Declaration Syntax
C#
public WorkflowException(
    string message
)
Parameters
message (String)
The message.


WorkflowException Constructor (message, item)

WorkflowException Constructor (message, item)
Namespaces ► Sitecore.Exceptions ► WorkflowException ► WorkflowException(String, Item)
Initializes a new instance of the WorkflowException class.
Declaration Syntax
C#
public WorkflowException(
    string message,
    Item item
)
Parameters
message (String)
The message.
item (Item)
The item.


WorkflowException Constructor (message, innerException)

WorkflowException Constructor (message, innerException)
Namespaces ► Sitecore.Exceptions ► WorkflowException ► WorkflowException(String, Exception)
Initializes a new instance of the WorkflowException class.
Declaration Syntax
C#
public WorkflowException(
    string message,
    Exception innerException
)
Parameters
message (String)
The message.
innerException (Exception)
The inner exception.


Item Property

Item Property
Namespaces ► Sitecore.Exceptions ► WorkflowException ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


WorkflowInitialStateMissingException Class

WorkflowInitialStateMissingException Class
Namespaces ► Sitecore.Exceptions ► WorkflowInitialStateMissingException
Thrown if worfklow misses an initial state.
Declaration Syntax
C#
[SerializableAttribute]
public class WorkflowInitialStateMissingException : WorkflowException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WorkflowInitialStateMissingException(Item, String) | Initializes a new instance of the WorkflowInitialStateMissingException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | Item | Gets the item. (Inherited from WorkflowException.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | WorkflowException
 |  |  |  | WorkflowInitialStateMissingException


WorkflowInitialStateMissingException Constructor (item, workflow)

WorkflowInitialStateMissingException Constructor (item, workflow)
Namespaces ► Sitecore.Exceptions ► WorkflowInitialStateMissingException ► WorkflowInitialStateMissingException(Item, String)
Initializes a new instance of the WorkflowInitialStateMissingException class.
Declaration Syntax
C#
public WorkflowInitialStateMissingException(
    Item item,
    string workflow
)
Parameters
item (Item)
The item.
workflow (String)
The workflow.


WorkflowStateMissingException Class

WorkflowStateMissingException Class
Namespaces ► Sitecore.Exceptions ► WorkflowStateMissingException
Represents a Workflow State Missing exception.
Declaration Syntax
C#
[SerializableAttribute]
public class WorkflowStateMissingException : WorkflowException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WorkflowStateMissingException()()() | Initializes a new instance of the WorkflowStateMissingException class.
 | WorkflowStateMissingException(String) | Initializes a new instance of the WorkflowStateMissingException class.
 | WorkflowStateMissingException(String, Exception) | Initializes a new instance of the WorkflowStateMissingException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | Item | Gets the item. (Inherited from WorkflowException.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | WorkflowException
 |  |  |  | WorkflowStateMissingException


WorkflowStateMissingException Constructor

WorkflowStateMissingException Constructor
Namespaces ► Sitecore.Exceptions ► WorkflowStateMissingException ► WorkflowStateMissingException()()()
Members
Icon | Member | Description
 | WorkflowStateMissingException()()() | Initializes a new instance of the WorkflowStateMissingException class.
 | WorkflowStateMissingException(String) | Initializes a new instance of the WorkflowStateMissingException class.
 | WorkflowStateMissingException(String, Exception) | Initializes a new instance of the WorkflowStateMissingException class.


WorkflowStateMissingException Constructor

WorkflowStateMissingException Constructor
Namespaces ► Sitecore.Exceptions ► WorkflowStateMissingException ► WorkflowStateMissingException()()()
Initializes a new instance of the WorkflowStateMissingException class.
Declaration Syntax
C#
public WorkflowStateMissingException()


WorkflowStateMissingException Constructor (message)

WorkflowStateMissingException Constructor (message)
Namespaces ► Sitecore.Exceptions ► WorkflowStateMissingException ► WorkflowStateMissingException(String)
Initializes a new instance of the WorkflowStateMissingException class.
Declaration Syntax
C#
public WorkflowStateMissingException(
    string message
)
Parameters
message (String)
The message.


WorkflowStateMissingException Constructor (message, innnerException)

WorkflowStateMissingException Constructor (message, innnerException)
Namespaces ► Sitecore.Exceptions ► WorkflowStateMissingException ► WorkflowStateMissingException(String, Exception)
Initializes a new instance of the WorkflowStateMissingException class.
Declaration Syntax
C#
public WorkflowStateMissingException(
    string message,
    Exception innnerException
)
Parameters
message (String)
The message.
innnerException (Exception)
The innner exception.


Sitecore.Express Namespace

Sitecore.Express Namespace
Namespaces ► Sitecore.Express
Declaration Syntax
C#
namespace Sitecore.Express
Types
All Types Classes
Icon | Type | Description
 | Application | Implements the Application.
 | Application..::.ApplicationSettings | Represents a ApplicationSettings.
 | ExpressItem |
 | Items | Represents a set of Items.


Application Class

Application Class
Namespaces ► Sitecore.Express ► Application
Implements the Application.
Declaration Syntax
C#
public static class Application
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Language | Gets or sets the language.
 | Log(String) | Logs the specified text.
 | Settings | Gets the settings.
 | Version | Gets the version.
Inheritance Hierarchy
Object
Application


Language Property

Language Property
Namespaces ► Sitecore.Express ► Application ► Language
Gets or sets the language.
Declaration Syntax
C#
public static string Language { get; set; }
Value
The language.


Log Method (text)

Log Method (text)
Namespaces ► Sitecore.Express ► Application ► Log(String)
Logs the specified text.
Declaration Syntax
C#
public static void Log(
    string text
)
Parameters
text (String)
The text.


Settings Property

Settings Property
Namespaces ► Sitecore.Express ► Application ► Settings
Gets the settings.
Declaration Syntax
C#
public static Application..::.ApplicationSettings Settings { get; }
Value
The settings.


Version Property

Version Property
Namespaces ► Sitecore.Express ► Application ► Version
Gets the version.
Declaration Syntax
C#
public static string Version { get; }
Value
The version.


Application.ApplicationSettings Class

Application..::.ApplicationSettings Class
Namespaces ► Sitecore.Express ► Application ► Application..::.ApplicationSettings
Represents a ApplicationSettings.
Declaration Syntax
C#
public class ApplicationSettings
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Application..::.ApplicationSettings()()() | Initializes a new instance of the Application..::.ApplicationSettings class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets the String with the specified name.
 | Item[([(String, String])]) | Gets the String with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Application..::.ApplicationSettings


Application.ApplicationSettings Constructor

Application..::.ApplicationSettings Constructor
Namespaces ► Sitecore.Express ► Application..::.ApplicationSettings ► Application..::.ApplicationSettings()()()
Initializes a new instance of the Application..::.ApplicationSettings class
Declaration Syntax
C#
public ApplicationSettings()


Item Property

Item Property
Namespaces ► Sitecore.Express ► Application..::.ApplicationSettings ► Item
Members
Icon | Member | Description
 | Item[([(String])]) | Gets the String with the specified name.
 | Item[([(String, String])]) | Gets the String with the specified name.


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Express ► Application..::.ApplicationSettings ► Item[([(String])])
Gets the String with the specified name.
Declaration Syntax
C#
public string this[
    string name
] { get; }
Parameters
name (String)
Value
The string.


Item Property (name, defaultValue)

Item Property (name, defaultValue)
Namespaces ► Sitecore.Express ► Application..::.ApplicationSettings ► Item[([(String, String])])
Gets the String with the specified name.
Declaration Syntax
C#
public string this[
    string name,
    string defaultValue
] { get; }
Parameters
name (String)
defaultValue (String)
Value
The setting.


ExpressItem Class

ExpressItem Class
Namespaces ► Sitecore.Express ► ExpressItem
Declaration Syntax
C#
public class ExpressItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExpressItem(Item) | Initializes a new instance of the ExpressItem class.
 | Children | Gets the children.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the ID.
 | Implicit(Item) | Implicit operators the specified item.
 | InnerItem | Gets the inner item.
 | Item[([(String])]) | Gets the String with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ExpressItem


ExpressItem Constructor (innerItem)

ExpressItem Constructor (innerItem)
Namespaces ► Sitecore.Express ► ExpressItem ► ExpressItem(Item)
Initializes a new instance of the ExpressItem class.
Declaration Syntax
C#
public ExpressItem(
    Item innerItem
)
Parameters
innerItem (Item)
The inner item.


Children Property

Children Property
Namespaces ► Sitecore.Express ► ExpressItem ► Children
Gets the children.
Declaration Syntax
C#
public ChildList Children { get; }
Value
The children.


ID Property

ID Property
Namespaces ► Sitecore.Express ► ExpressItem ► ID
Gets the ID.
Declaration Syntax
C#
public ID ID { get; }
Value
The ID.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Express ► ExpressItem ► Implicit(Item)
Implicit operators the specified item.
Declaration Syntax
C#
public static implicit operator ExpressItem (
    Item item
)
Parameters
item (Item)
The item.
Return Value


InnerItem Property

InnerItem Property
Namespaces ► Sitecore.Express ► ExpressItem ► InnerItem
Gets the inner item.
Declaration Syntax
C#
public Item InnerItem { get; }
Value
The inner item.


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Express ► ExpressItem ► Item[([(String])])
Gets the String with the specified name.
Declaration Syntax
C#
public string this[
    string name
] { get; }
Parameters
name (String)
Value


Name Property

Name Property
Namespaces ► Sitecore.Express ► ExpressItem ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Items Class

Items Class
Namespaces ► Sitecore.Express ► Items
Represents a set of Items.
Declaration Syntax
C#
public static class Items
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddItem(String, String, String) | Adds the item.
 | CurrentItem | Gets the current item.
 | DeleteItem(String) | Deletes the item.
 | Exists(ID) | Determines if the item exists.
 | GetItem(String) | Gets the item.
 | Item | Gets the item.
 | Publish()()() | Obsolete. Publishes.
 | PublishItem(String) | Obsolete. Publishes the item.
 | SelectItems(String) | Selects the items.
 | SelectSingleItem(String) | Selects the single item.
Inheritance Hierarchy
Object
Items


AddItem Method (parent, name, template)

AddItem Method (parent, name, template)
Namespaces ► Sitecore.Express ► Items ► AddItem(String, String, String)
Adds the item.
Declaration Syntax
C#
public static Item AddItem(
    string parent,
    string name,
    string template
)
Parameters
parent (String)
The parent.
name (String)
The name.
template (String)
The template.
Return Value


CurrentItem Property

CurrentItem Property
Namespaces ► Sitecore.Express ► Items ► CurrentItem
Gets the current item.
Declaration Syntax
C#
public static Item CurrentItem { get; }
Value
The current item.


DeleteItem Method (id)

DeleteItem Method (id)
Namespaces ► Sitecore.Express ► Items ► DeleteItem(String)
Deletes the item.
Declaration Syntax
C#
public static void DeleteItem(
    string id
)
Parameters
id (String)
The id.


Exists Method (itemID)

Exists Method (itemID)
Namespaces ► Sitecore.Express ► Items ► Exists(ID)
Determines if the item exists.
Declaration Syntax
C#
public static bool Exists(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value


GetItem Method (id)

GetItem Method (id)
Namespaces ► Sitecore.Express ► Items ► GetItem(String)
Gets the item.
Declaration Syntax
C#
public static ExpressItem GetItem(
    string id
)
Parameters
id (String)
The id.
Return Value


Item Property

Item Property
Namespaces ► Sitecore.Express ► Items ► Item
Gets the item.
Declaration Syntax
C#
public static Database..::.DataRecords Item { get; }
Value
The item.


Publish Method

Publish Method
Namespaces ► Sitecore.Express ► Items ► Publish()()()
Publishes.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static void Publish()


PublishItem Method (id)

PublishItem Method (id)
Namespaces ► Sitecore.Express ► Items ► PublishItem(String)
Publishes the item.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static void PublishItem(
    string id
)
Parameters
id (String)
The id.


SelectItems Method (query)

SelectItems Method (query)
Namespaces ► Sitecore.Express ► Items ► SelectItems(String)
Selects the items.
Declaration Syntax
C#
public static Item[] SelectItems(
    string query
)
Parameters
query (String)
The query.
Return Value


SelectSingleItem Method (query)

SelectSingleItem Method (query)
Namespaces ► Sitecore.Express ► Items ► SelectSingleItem(String)
Selects the single item.
Declaration Syntax
C#
public static ExpressItem SelectSingleItem(
    string query
)
Parameters
query (String)
The query.
Return Value


Sitecore.Extensions.DatabaseExtensions Namespace

Sitecore.Extensions.DatabaseExtensions Namespace
Namespaces ► Sitecore.Extensions.DatabaseExtensions
Declaration Syntax
C#
namespace Sitecore.Extensions.DatabaseExtensions
Types
All Types Classes
Icon | Type | Description
 | DatabaseExtensions | Extensions methods for Database.


DatabaseExtensions Class

DatabaseExtensions Class
Namespaces ► Sitecore.Extensions.DatabaseExtensions ► DatabaseExtensions
Extensions methods for Database.
Declaration Syntax
C#
public static class DatabaseExtensions
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetKnownItem(Database, String) | Gets the known item.
 | GetKnownItemId(Database, String) | Gets the leftmost part of a string.
Inheritance Hierarchy
Object
DatabaseExtensions


GetKnownItem Method (database, itemPath)

GetKnownItem Method (database, itemPath)
Namespaces ► Sitecore.Extensions.DatabaseExtensions ► DatabaseExtensions ► GetKnownItem(Database, String)
Gets the known item.
Declaration Syntax
C#
public static Item GetKnownItem(
    Database database,
    string itemPath
)
Parameters
database (Database)
The database.
itemPath (String)
The item path.
Return Value
The known item.


GetKnownItemId Method (database, itemPath)

GetKnownItemId Method (database, itemPath)
Namespaces ► Sitecore.Extensions.DatabaseExtensions ► DatabaseExtensions ► GetKnownItemId(Database, String)
Gets the leftmost part of a string.
Declaration Syntax
C#
public static ID GetKnownItemId(
    Database database,
    string itemPath
)
Parameters
database (Database)
The database.
itemPath (String)
The item path.
Return Value
The known item id.


Sitecore.Extensions.StringExtensions Namespace

Sitecore.Extensions.StringExtensions Namespace
Namespaces ► Sitecore.Extensions.StringExtensions
Declaration Syntax
C#
namespace Sitecore.Extensions.StringExtensions
Types
All Types Classes
Icon | Type | Description
 | StringExtensions | Extensions methods for string.


StringExtensions Class

StringExtensions Class
Namespaces ► Sitecore.Extensions.StringExtensions ► StringExtensions
Extensions methods for string.
Declaration Syntax
C#
public static class StringExtensions
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Left(String, Int32) | Gets the leftmost part of a string.
 | Mid(String, Int32) | Gets the middle part of a string.
 | Mid(String, Int32, Int32) | Gets the middle part of a string.
 | Right(String, Int32) | Gets the rightmost part of a string.
Inheritance Hierarchy
Object
StringExtensions


Left Method (text, length)

Left Method (text, length)
Namespaces ► Sitecore.Extensions.StringExtensions ► StringExtensions ► Left(String, Int32)
Gets the leftmost part of a string.
Declaration Syntax
C#
public static string Left(
    string text,
    int length
)
Parameters
text (String)
A string
length (Int32)
The number of character to return.
Return Value
The first length characters of the string.


Mid Method

Mid Method
Namespaces ► Sitecore.Extensions.StringExtensions ► StringExtensions ► Mid()()()
Members
Icon | Member | Description
 | Mid(String, Int32) | Gets the middle part of a string.
 | Mid(String, Int32, Int32) | Gets the middle part of a string.


Mid Method (text, start)

Mid Method (text, start)
Namespaces ► Sitecore.Extensions.StringExtensions ► StringExtensions ► Mid(String, Int32)
Gets the middle part of a string.
Declaration Syntax
C#
public static string Mid(
    string text,
    int start
)
Parameters
text (String)
A string.
start (Int32)
The starting index into the string.
Return Value
The rightmost part of the string starting at the start position.
Remarks
If start is greater than the length of the string, the blank is returned.


Mid Method (text, start, length)

Mid Method (text, start, length)
Namespaces ► Sitecore.Extensions.StringExtensions ► StringExtensions ► Mid(String, Int32, Int32)
Gets the middle part of a string.
Declaration Syntax
C#
public static string Mid(
    string text,
    int start,
    int length
)
Parameters
text (String)
A string.
start (Int32)
The starting index into the string.
length (Int32)
The number of returned characters
Return Value
The rightmost part of the string starting at the start position.


Right Method (text, length)

Right Method (text, length)
Namespaces ► Sitecore.Extensions.StringExtensions ► StringExtensions ► Right(String, Int32)
Gets the rightmost part of a string.
Declaration Syntax
C#
public static string Right(
    string text,
    int length
)
Parameters
text (String)
A string.
length (Int32)
The number of characters to return.
Return Value
The rightmost length characters.


Sitecore.Extensions.XElementExtensions Namespace

Sitecore.Extensions.XElementExtensions Namespace
Namespaces ► Sitecore.Extensions.XElementExtensions
Declaration Syntax
C#
namespace Sitecore.Extensions.XElementExtensions
Types
All Types Classes
Icon | Type | Description
 | XElementExtensions | Extensions methods for string.


XElementExtensions Class

XElementExtensions Class
Namespaces ► Sitecore.Extensions.XElementExtensions ► XElementExtensions
Extensions methods for string.
Declaration Syntax
C#
public static class XElementExtensions
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Element(XElement, Int32) | Elements the specified element.
 | GetAttributeValue(XElement, String) | Gets the attribute value.
Inheritance Hierarchy
Object
XElementExtensions


Element Method (element, index)

Element Method (element, index)
Namespaces ► Sitecore.Extensions.XElementExtensions ► XElementExtensions ► Element(XElement, Int32)
Elements the specified element.
Declaration Syntax
C#
public static XElement Element(
    XElement element,
    int index
)
Parameters
element (XElement)
The element.
index (Int32)
The index.
Return Value
Returns the X element.


GetAttributeValue Method (element, name)

GetAttributeValue Method (element, name)
Namespaces ► Sitecore.Extensions.XElementExtensions ► XElementExtensions ► GetAttributeValue(XElement, String)
Gets the attribute value.
Declaration Syntax
C#
public static string GetAttributeValue(
    XElement element,
    string name
)
Parameters
element (XElement)
The element.
name (String)
The name of the attribute to get.
Return Value
The attribute value.


Sitecore.Globalization Namespace

Sitecore.Globalization Namespace
Namespaces ► Sitecore.Globalization
Declaration Syntax
C#
namespace Sitecore.Globalization
Types
All Types Classes
Icon | Type | Description
 | ItemEventHandler | Monitors for changes to the dictionary and invalidates the translation tables accordingly.
 | Language | Represents a language.
 | LanguageDefinition | Defines meta data on a language.
 | LanguageDefinitions |
 | LanguageOrigin | Identifies the language item that defines a language.
 | LanguageService | Helper function for languages
 | LanguageSwitcher | Switches to another language temporarily.
 | Language..::.Predefined | Obsolete. Provides a class with predefined language structures.
 | Translate | Implements the localization utility class, which controls the client language.


ItemEventHandler Class

ItemEventHandler Class
Namespaces ► Sitecore.Globalization ► ItemEventHandler
Monitors for changes to the dictionary and invalidates the translation tables accordingly.
Declaration Syntax
C#
public sealed class ItemEventHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemEventHandler()()() | Initializes a new instance of the ItemEventHandler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemEventHandler


ItemEventHandler Constructor

ItemEventHandler Constructor
Namespaces ► Sitecore.Globalization ► ItemEventHandler ► ItemEventHandler()()()
Initializes a new instance of the ItemEventHandler class
Declaration Syntax
C#
public ItemEventHandler()


Language Class

Language Class
Namespaces ► Sitecore.Globalization ► Language
Represents a language.
Declaration Syntax
C#
[SerializableAttribute]
public class Language : ISerializable, ICacheable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Language(SerializationInfo, StreamingContext) | Obsolete. Constructor used when deserializing.
 | Any | Obsolete. Represents any language.
 | ClientLanguage | Obsolete. Gets or sets the current Client language.
 | CreateCultureInfo(String) | Creates the culture info. Synchronizes calls to constructor.
 | CreateCultureInfo(String, Boolean) | Creates the culture info. Synchronizes calls to constructor.
 | CreateSpecificCulture(String) | Creates the specific culture. Synchronizes access to constructor
 | CultureInfo | Gets a CultureInfo structure for the current language.
 | Current | Gets or sets the current language.
 | DefaultClientLanguage | Obsolete. Gets or sets the current Client language as defined in the web.config.
 | DefaultLanguage | Obsolete. Gets the default language as defined in the web.config.
 | Equality(Language, Language) | Implements the == operator.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCharset(Database) | Gets the chararacter set for the language.
 | GetCultureInfo(String) | Gets the culture info.
 | GetCultures(CultureTypes) | Gets the cultures.
 | GetDictionary(Database) | Gets the dictionary associated with the language in a specific database.
 | GetDisplayName()()() | Gets the display name.
 | GetDisplayName(CultureInfo) | Gets the display name.
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object.GetHashCode()()().)
 | GetIcon(Database) | Gets the icon associated with the language in a specific database.
 | GetItem(Database) | Obsolete. Gets the item.
 | GetLanguages(Database) | Obsolete. Gets the list of defined languages in a database.
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetSpellCheckerDictionary(Database) | Obsolete. Gets the name of the NetSpell dictionary.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Inequality(Language, Language) | Implements the != operator.
 | Invariant | Represents the invariant language (culture identifier: 0x007F).
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name of the language.
 | Origin | Gets the id of the item representing the language in a specific database.
 | Parse(String) | Initializes a language structure from a string.
 | Parse(String, String) | Obsolete. Initializes a language structure from a string.
 | Parse(Object) | Obsolete. Initializes a language structure from an object.
 | Title | Obsolete. Gets the display name of the language.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | TryParse(String, Language%) | Initializes a language structure from a string.
Remarks

The language class is used both for specifying web site languages and Client languages.

The web site languages are typically defined below /sitecore/system/Languages.

Client languages are defined in /sitecore/system/Settings/Client languages.

Inheritance Hierarchy
Object
Language


Language Constructor (info, context)

Language Constructor (info, context)
Namespaces ► Sitecore.Globalization ► Language ► Language(SerializationInfo, StreamingContext)
Constructor used when deserializing.
Declaration Syntax
C#
[ObsoleteAttribute("Will be made protected in a future version.")]
protected Language(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Any Property

Any Property
Namespaces ► Sitecore.Globalization ► Language ► Any
Represents any language.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - use Invariant instead.")]
public static Language Any { get; }
Value
Any.


ClientLanguage Property

ClientLanguage Property
Namespaces ► Sitecore.Globalization ► Language ► ClientLanguage
Gets or sets the current Client language.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated, use State.ClientLanguage instead.")]
public static Language ClientLanguage { get; set; }
Value
The client language.


CreateCultureInfo Method

CreateCultureInfo Method
Namespaces ► Sitecore.Globalization ► Language ► CreateCultureInfo()()()
Members
Icon | Member | Description
 | CreateCultureInfo(String) | Creates the culture info. Synchronizes calls to constructor.
 | CreateCultureInfo(String, Boolean) | Creates the culture info. Synchronizes calls to constructor.


CreateCultureInfo Method (name)

CreateCultureInfo Method (name)
Namespaces ► Sitecore.Globalization ► Language ► CreateCultureInfo(String)
Creates the culture info. Synchronizes calls to constructor.
Declaration Syntax
C#
public static CultureInfo CreateCultureInfo(
    string name
)
Parameters
name (String)
The name.
Return Value
The culture info.


CreateCultureInfo Method (name, userOverride)

CreateCultureInfo Method (name, userOverride)
Namespaces ► Sitecore.Globalization ► Language ► CreateCultureInfo(String, Boolean)
Creates the culture info. Synchronizes calls to constructor.
Declaration Syntax
C#
public static CultureInfo CreateCultureInfo(
    string name,
    bool userOverride
)
Parameters
name (String)
The name.
userOverride (Boolean)
if set to true this instance is user override.
Return Value
The culture info.


CreateSpecificCulture Method (name)

CreateSpecificCulture Method (name)
Namespaces ► Sitecore.Globalization ► Language ► CreateSpecificCulture(String)
Creates the specific culture. Synchronizes access to constructor
Declaration Syntax
C#
public static CultureInfo CreateSpecificCulture(
    string name
)
Parameters
name (String)
The name.
Return Value
The specific culture.


CultureInfo Property

CultureInfo Property
Namespaces ► Sitecore.Globalization ► Language ► CultureInfo
Gets a CultureInfo structure for the current language.
Declaration Syntax
C#
public virtual CultureInfo CultureInfo { get; }
Value
The culture info.


Current Property

Current Property
Namespaces ► Sitecore.Globalization ► Language ► Current
Gets or sets the current language.
Declaration Syntax
C#
public static Language Current { get; set; }
Value
The current.


DefaultClientLanguage Property

DefaultClientLanguage Property
Namespaces ► Sitecore.Globalization ► Language ► DefaultClientLanguage
Gets or sets the current Client language as defined in the web.config.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated, use Settings.ClientLanguage instead.")]
public static Language DefaultClientLanguage { get; }
Value
The default client language.


DefaultLanguage Property

DefaultLanguage Property
Namespaces ► Sitecore.Globalization ► Language ► DefaultLanguage
Gets the default language as defined in the web.config.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated, use LanguageManager.DefaultLanguage instead.")]
public static Language DefaultLanguage { get; }
Value
The default language.


Equality Operator

Equality Operator
Namespaces ► Sitecore.Globalization ► Language ► Equality(Language, Language)
Implements the == operator.
Declaration Syntax
C#
public static bool operator ==(
    Language language1,
    Language language2
)
Parameters
language1 (Language)
Language1.
language2 (Language)
Language2.
Return Value


Equals Method (obj)

Equals Method (obj)
Namespaces ► Sitecore.Globalization ► Language ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C#
public override bool Equals(
    Object obj
)
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.


GetCharset Method (database)

GetCharset Method (database)
Namespaces ► Sitecore.Globalization ► Language ► GetCharset(Database)
Gets the chararacter set for the language.
Declaration Syntax
C#
public string GetCharset(
    Database database
)
Parameters
database (Database)
The database.
Return Value


GetCultureInfo Method (cultureName)

GetCultureInfo Method (cultureName)
Namespaces ► Sitecore.Globalization ► Language ► GetCultureInfo(String)
Gets the culture info.
Declaration Syntax
C#
public static CultureInfo GetCultureInfo(
    string cultureName
)
Parameters
cultureName (String)
Name of the culture.
Return Value
The culture info.


GetCultures Method (types)

GetCultures Method (types)
Namespaces ► Sitecore.Globalization ► Language ► GetCultures(CultureTypes)
Gets the cultures.
Declaration Syntax
C#
public static CultureInfo[] GetCultures(
    CultureTypes types
)
Parameters
types (CultureTypes)
The types.
Return Value
The cultures.


GetDictionary Method (database)

GetDictionary Method (database)
Namespaces ► Sitecore.Globalization ► Language ► GetDictionary(Database)
Gets the dictionary associated with the language in a specific database.
Declaration Syntax
C#
public string GetDictionary(
    Database database
)
Parameters
database (Database)
The database.
Return Value


GetDisplayName Method

GetDisplayName Method
Namespaces ► Sitecore.Globalization ► Language ► GetDisplayName()()()
Members
Icon | Member | Description
 | GetDisplayName()()() | Gets the display name.
 | GetDisplayName(CultureInfo) | Gets the display name.


GetDisplayName Method

GetDisplayName Method
Namespaces ► Sitecore.Globalization ► Language ► GetDisplayName()()()
Gets the display name.
Declaration Syntax
C#
public string GetDisplayName()
Return Value
The display name.


GetDisplayName Method (cultureInfo)

GetDisplayName Method (cultureInfo)
Namespaces ► Sitecore.Globalization ► Language ► GetDisplayName(CultureInfo)
Gets the display name.
Declaration Syntax
C#
public static string GetDisplayName(
    CultureInfo cultureInfo
)
Parameters
cultureInfo (CultureInfo)
The culture info.
Return Value
The display name.


GetHashCode Method

GetHashCode Method
Namespaces ► Sitecore.Globalization ► Language ► GetHashCode()()()
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
Declaration Syntax
C#
public override int GetHashCode()
Return Value
A hash code for the current Object.


GetIcon Method (database)

GetIcon Method (database)
Namespaces ► Sitecore.Globalization ► Language ► GetIcon(Database)
Gets the icon associated with the language in a specific database.
Declaration Syntax
C#
public string GetIcon(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The icon.


GetItem Method (database)

GetItem Method (database)
Namespaces ► Sitecore.Globalization ► Language ► GetItem(Database)
Gets the item.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated, use ItemManager.GetItem(Language.LanguageId, database) instead.")]
public Item GetItem(
    Database database
)
Parameters
database (Database)
The database.
Return Value


GetLanguages Method (database)

GetLanguages Method (database)
Namespaces ► Sitecore.Globalization ► Language ► GetLanguages(Database)
Gets the list of defined languages in a database.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated, use LanguageManager.GetLanguages instead.")]
public static Language[] GetLanguages(
    Database database
)
Parameters
database (Database)
The database.
Return Value


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Globalization ► Language ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


GetSpellCheckerDictionary Method (database)

GetSpellCheckerDictionary Method (database)
Namespaces ► Sitecore.Globalization ► Language ► GetSpellCheckerDictionary(Database)
Gets the name of the NetSpell dictionary.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated, use GetDictionary(database) instead.")]
public string GetSpellCheckerDictionary(
    Database database
)
Parameters
database (Database)
The database.
Return Value


Inequality Operator

Inequality Operator
Namespaces ► Sitecore.Globalization ► Language ► Inequality(Language, Language)
Implements the != operator.
Declaration Syntax
C#
public static bool operator !=(
    Language language1,
    Language language2
)
Parameters
language1 (Language)
Language1.
language2 (Language)
Language2.
Return Value


Invariant Property

Invariant Property
Namespaces ► Sitecore.Globalization ► Language ► Invariant
Represents the invariant language (culture identifier: 0x007F).
Declaration Syntax
C#
public static Language Invariant { get; }
Value
The invariant language.


Name Property

Name Property
Namespaces ► Sitecore.Globalization ► Language ► Name
Gets or sets the name of the language.
Declaration Syntax
C#
public virtual string Name { get; }
Value
The name.


Origin Property

Origin Property
Namespaces ► Sitecore.Globalization ► Language ► Origin
Gets the id of the item representing the language in a specific database.
Declaration Syntax
C#
public LanguageOrigin Origin { get; }
Value
The origin.


Parse Method

Parse Method
Namespaces ► Sitecore.Globalization ► Language ► Parse()()()
Members
Icon | Member | Description
 | Parse(String) | Initializes a language structure from a string.
 | Parse(String, String) | Obsolete. Initializes a language structure from a string.
 | Parse(Object) | Obsolete. Initializes a language structure from an object.


Parse Method (value)

Parse Method (value)
Namespaces ► Sitecore.Globalization ► Language ► Parse(Object)
Initializes a language structure from an object.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - use Parse(string) instead.")]
public static Language Parse(
    Object value
)
Parameters
value (Object)
The value.
Return Value


Parse Method (name)

Parse Method (name)
Namespaces ► Sitecore.Globalization ► Language ► Parse(String)
Initializes a language structure from a string.
Declaration Syntax
C#
public static Language Parse(
    string name
)
Parameters
name (String)
The name.
Return Value


Parse Method (value, defaultLanguage)

Parse Method (value, defaultLanguage)
Namespaces ► Sitecore.Globalization ► Language ► Parse(String, String)
Initializes a language structure from a string.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated")]
public static Language Parse(
    string value,
    string defaultLanguage
)
Parameters
value (String)
The value.
defaultLanguage (String)
The default language.
Return Value
Remarks
If the value is empty, defaultLanguage is returned.


Title Property

Title Property
Namespaces ► Sitecore.Globalization ► Language ► Title
Gets the display name of the language.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - use CultureInfo.DisplayName instead.")]
public string Title { get; }
Value
The title.


ToString Method

ToString Method
Namespaces ► Sitecore.Globalization ► Language ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


TryParse Method (name, result)

TryParse Method (name, result)
Namespaces ► Sitecore.Globalization ► Language ► TryParse(String, Language%)
Initializes a language structure from a string.
Declaration Syntax
C#
public static bool TryParse(
    string name,
    out Language result
)
Parameters
name (String)
The name.
result ( Language %)
The result.
Return Value


Language.Predefined Class

Language..::.Predefined Class
Namespaces ► Sitecore.Globalization ► Language ► Language..::.Predefined
Provides a class with predefined language structures.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - use the methods of LanguageManager instead.")]
public static class Predefined
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Danish | Represents the Danish language.
 | English | Represents the English language.
 | German | Represents the German language.
 | Norwegian | Represents the Norwegian language.
 | Spanish | Represents the Spanish language.
 | Swedish | Represents the Swedish language.
Inheritance Hierarchy
Object
Language..::.Predefined


Danish Field

Danish Field
Namespaces ► Sitecore.Globalization ► Language..::.Predefined ► Danish
Represents the Danish language.
Declaration Syntax
C#
public static Language Danish


English Field

English Field
Namespaces ► Sitecore.Globalization ► Language..::.Predefined ► English
Represents the English language.
Declaration Syntax
C#
public static Language English


German Field

German Field
Namespaces ► Sitecore.Globalization ► Language..::.Predefined ► German
Represents the German language.
Declaration Syntax
C#
public static Language German


Norwegian Field

Norwegian Field
Namespaces ► Sitecore.Globalization ► Language..::.Predefined ► Norwegian
Represents the Norwegian language.
Declaration Syntax
C#
public static Language Norwegian


Spanish Field

Spanish Field
Namespaces ► Sitecore.Globalization ► Language..::.Predefined ► Spanish
Represents the Spanish language.
Declaration Syntax
C#
public static Language Spanish


Swedish Field

Swedish Field
Namespaces ► Sitecore.Globalization ► Language..::.Predefined ► Swedish
Represents the Swedish language.
Declaration Syntax
C#
public static Language Swedish


LanguageDefinition Class

LanguageDefinition Class
Namespaces ► Sitecore.Globalization ► LanguageDefinition
Defines meta data on a language.
Declaration Syntax
C#
public class LanguageDefinition
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LanguageDefinition(String, String, String, String, String, String) | Initializes a new instance of the LanguageDefinition class.
 | CharSet | Gets the charset.
 | CodePage | Gets the codepage.
 | Encoding | Gets the encoding.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets the icon.
 | Id | Gets the id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Region | Gets the region.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LanguageDefinition


LanguageDefinition Constructor (id, region, codepage, encoding, charset, icon)

LanguageDefinition Constructor (id, region, codepage, encoding, charset, icon)
Namespaces ► Sitecore.Globalization ► LanguageDefinition ► LanguageDefinition(String, String, String, String, String, String)
Initializes a new instance of the LanguageDefinition class.
Declaration Syntax
C#
public LanguageDefinition(
    string id,
    string region,
    string codepage,
    string encoding,
    string charset,
    string icon
)
Parameters
id (String)
The id.
region (String)
The region.
codepage (String)
The codepage.
encoding (String)
The encoding.
charset (String)
The charset.
icon (String)
The icon.


CharSet Property

CharSet Property
Namespaces ► Sitecore.Globalization ► LanguageDefinition ► CharSet
Gets the charset.
Declaration Syntax
C#
public string CharSet { get; }
Value
The charset.


CodePage Property

CodePage Property
Namespaces ► Sitecore.Globalization ► LanguageDefinition ► CodePage
Gets the codepage.
Declaration Syntax
C#
public string CodePage { get; }
Value
The codepage.


Encoding Property

Encoding Property
Namespaces ► Sitecore.Globalization ► LanguageDefinition ► Encoding
Gets the encoding.
Declaration Syntax
C#
public string Encoding { get; }
Value
The encoding.


Icon Property

Icon Property
Namespaces ► Sitecore.Globalization ► LanguageDefinition ► Icon
Gets the icon.
Declaration Syntax
C#
public string Icon { get; }
Value
The icon.


Id Property

Id Property
Namespaces ► Sitecore.Globalization ► LanguageDefinition ► Id
Gets the id.
Declaration Syntax
C#
public string Id { get; }
Value
The id.


Name Property

Name Property
Namespaces ► Sitecore.Globalization ► LanguageDefinition ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Region Property

Region Property
Namespaces ► Sitecore.Globalization ► LanguageDefinition ► Region
Gets the region.
Declaration Syntax
C#
public string Region { get; }
Value
The region.


LanguageDefinitions Class

LanguageDefinitions Class
Namespaces ► Sitecore.Globalization ► LanguageDefinitions
Declaration Syntax
C#
public static class LanguageDefinitions
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Definitions | Gets the language definitions.
 | GetLanguageDefinition(CultureInfo) | Gets the definition.
 | GetLanguageDefinition(Language) | Gets the definition.
Inheritance Hierarchy
Object
LanguageDefinitions


Definitions Property

Definitions Property
Namespaces ► Sitecore.Globalization ► LanguageDefinitions ► Definitions
Gets the language definitions.
Declaration Syntax
C#
public static List<LanguageDefinition> Definitions { get; }
Value
The language definitions.


GetLanguageDefinition Method

GetLanguageDefinition Method
Namespaces ► Sitecore.Globalization ► LanguageDefinitions ► GetLanguageDefinition()()()
Members
Icon | Member | Description
 | GetLanguageDefinition(CultureInfo) | Gets the definition.
 | GetLanguageDefinition(Language) | Gets the definition.


GetLanguageDefinition Method (language)

GetLanguageDefinition Method (language)
Namespaces ► Sitecore.Globalization ► LanguageDefinitions ► GetLanguageDefinition(Language)
Gets the definition.
Declaration Syntax
C#
public static LanguageDefinition GetLanguageDefinition(
    Language language
)
Parameters
language (Language)
The language.
Return Value
The definition.


GetLanguageDefinition Method (cultureInfo)

GetLanguageDefinition Method (cultureInfo)
Namespaces ► Sitecore.Globalization ► LanguageDefinitions ► GetLanguageDefinition(CultureInfo)
Gets the definition.
Declaration Syntax
C#
public static LanguageDefinition GetLanguageDefinition(
    CultureInfo cultureInfo
)
Parameters
cultureInfo (CultureInfo)
The culture info.


LanguageOrigin Class

LanguageOrigin Class
Namespaces ► Sitecore.Globalization ► LanguageOrigin
Identifies the language item that defines a language.
Declaration Syntax
C#
public class LanguageOrigin
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LanguageOrigin()()() | Initializes a new instance of the LanguageOrigin class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemId | Gets or sets the item id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LanguageOrigin


LanguageOrigin Constructor

LanguageOrigin Constructor
Namespaces ► Sitecore.Globalization ► LanguageOrigin ► LanguageOrigin()()()
Initializes a new instance of the LanguageOrigin class
Declaration Syntax
C#
public LanguageOrigin()


ItemId Property

ItemId Property
Namespaces ► Sitecore.Globalization ► LanguageOrigin ► ItemId
Gets or sets the item id.
Declaration Syntax
C#
public ID ItemId { get; set; }
Value
The item id.


LanguageService Class

LanguageService Class
Namespaces ► Sitecore.Globalization ► LanguageService
Helper function for languages
Declaration Syntax
C#
public static class LanguageService
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetIcon(Item) | Gets the icon.
 | GetIcon(Language, Database) | Gets the icon.
Inheritance Hierarchy
Object
LanguageService


GetIcon Method

GetIcon Method
Namespaces ► Sitecore.Globalization ► LanguageService ► GetIcon()()()
Members
Icon | Member | Description
 | GetIcon(Item) | Gets the icon.
 | GetIcon(Language, Database) | Gets the icon.


GetIcon Method (item)

GetIcon Method (item)
Namespaces ► Sitecore.Globalization ► LanguageService ► GetIcon(Item)
Gets the icon.
Declaration Syntax
C#
public static string GetIcon(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The icon.


GetIcon Method (language, database)

GetIcon Method (language, database)
Namespaces ► Sitecore.Globalization ► LanguageService ► GetIcon(Language, Database)
Gets the icon.
Declaration Syntax
C#
public static string GetIcon(
    Language language,
    Database database
)
Parameters
language (Language)
The language.
database (Database)
The database.
Return Value
The icon.


LanguageSwitcher Class

LanguageSwitcher Class
Namespaces ► Sitecore.Globalization ► LanguageSwitcher
Switches to another language temporarily.
Declaration Syntax
C#
public class LanguageSwitcher : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LanguageSwitcher(String) | Initializes a new instance of the LanguageSwitcher class.
 | LanguageSwitcher(Language) | Initializes a new instance of the LanguageSwitcher class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LanguageSwitcher


LanguageSwitcher Constructor

LanguageSwitcher Constructor
Namespaces ► Sitecore.Globalization ► LanguageSwitcher ► LanguageSwitcher()()()
Members
Icon | Member | Description
 | LanguageSwitcher(String) | Initializes a new instance of the LanguageSwitcher class.
 | LanguageSwitcher(Language) | Initializes a new instance of the LanguageSwitcher class.


LanguageSwitcher Constructor (language)

LanguageSwitcher Constructor (language)
Namespaces ► Sitecore.Globalization ► LanguageSwitcher ► LanguageSwitcher(Language)
Initializes a new instance of the LanguageSwitcher class.
Declaration Syntax
C#
public LanguageSwitcher(
    Language language
)
Parameters
language (Language)
The language.


LanguageSwitcher Constructor (languageName)

LanguageSwitcher Constructor (languageName)
Namespaces ► Sitecore.Globalization ► LanguageSwitcher ► LanguageSwitcher(String)
Initializes a new instance of the LanguageSwitcher class.
Declaration Syntax
C#
public LanguageSwitcher(
    string languageName
)
Parameters
languageName (String)
Name of the language.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Globalization ► LanguageSwitcher ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


Translate Class

Translate Class
Namespaces ► Sitecore.Globalization ► Translate
Implements the localization utility class, which controls the client language.
Declaration Syntax
C#
public class Translate
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Translate()()() | Initializes a new instance of the Translate class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text(String) | Gets a localized string.
 | Text(String, array<Object>[]()[]) | Gets the localized string for the key.
 | TextByLanguage(String, Language) | Gets a localized string.
 | TextByLanguage(String, Language, String) | Texts the by language no default.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
The Sitecore.HttpModule class implements a file watcher that responds to new files in the localization folder. When triggered the file watcher clears the language table, thereby forcing a reload of the language files.
Inheritance Hierarchy
Object
Translate


Translate Constructor

Translate Constructor
Namespaces ► Sitecore.Globalization ► Translate ► Translate()()()
Initializes a new instance of the Translate class
Declaration Syntax
C#
public Translate()


Text Method

Text Method
Namespaces ► Sitecore.Globalization ► Translate ► Text()()()
Members
Icon | Member | Description
 | Text(String) | Gets a localized string.
 | Text(String, array<Object>[]()[]) | Gets the localized string for the key.


Text Method (key)

Text Method (key)
Namespaces ► Sitecore.Globalization ► Translate ► Text(String)
Gets a localized string.
Declaration Syntax
C#
public static string Text(
    string key
)
Parameters
key (String)
The key of the string.
Return Value
The localized string.
Remarks
If the key is not found, the key itself is returned.
Examples
CopyC#
string myText = Localization.ls("My Text");


Text Method (key, parameters)

Text Method (key, parameters)
Namespaces ► Sitecore.Globalization ► Translate ► Text(String, array<Object>[]()[])
Gets the localized string for the key.
Declaration Syntax
C#
public static string Text(
    string key,
    params Object[] parameters
)
Parameters
key (String)
The key.
parameters (array< Object >[]()[])
The parameters.
Return Value
Remarks
The localized string is formatted using String.Format.


TextByLanguage Method

TextByLanguage Method
Namespaces ► Sitecore.Globalization ► Translate ► TextByLanguage()()()
Members
Icon | Member | Description
 | TextByLanguage(String, Language) | Gets a localized string.
 | TextByLanguage(String, Language, String) | Texts the by language no default.


TextByLanguage Method (key, language)

TextByLanguage Method (key, language)
Namespaces ► Sitecore.Globalization ► Translate ► TextByLanguage(String, Language)
Gets a localized string.
Declaration Syntax
C#
public static string TextByLanguage(
    string key,
    Language language
)
Parameters
key (String)
The key of the string.
language (Language)
The language identifier.
Return Value
The localized string.
Remarks
If the key is not found, the key itself is returned.
Examples
CopyC#
string myText = Translate.Text("My Text", "da");


TextByLanguage Method (key, language, defaultValue)

TextByLanguage Method (key, language, defaultValue)
Namespaces ► Sitecore.Globalization ► Translate ► TextByLanguage(String, Language, String)
Texts the by language no default.
Declaration Syntax
C#
public static string TextByLanguage(
    string key,
    Language language,
    string defaultValue
)
Parameters
key (String)
The key.
language (Language)
The language.
defaultValue (String)
The default value.
Return Value
The by language.


Sitecore.ImageLib Namespace

Sitecore.ImageLib Namespace
Namespaces ► Sitecore.ImageLib
Declaration Syntax
C#
namespace Sitecore.ImageLib
Types
All Types Classes
Icon | Type | Description
 | ResizeOptions | ResizeOptions class
 | Resizer | Resizer
 | ThumbMaker | ThumbMaker


ResizeOptions Class

ResizeOptions Class
Namespaces ► Sitecore.ImageLib ► ResizeOptions
ResizeOptions class
Declaration Syntax
C#
public class ResizeOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResizeOptions()()() | Initializes a new instance of the ResizeOptions class
 | AllowStretch | Gets a value indicating whether to allow stretching.
 | BackgroundColor | Gets the color of the background.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Format | Gets or sets the image format.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty (ie. Size is empty and Scale is 0).
 | MaxSize | Gets the max size.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreserveResolution | Gets or sets a value indicating whether the ResizeOptions preserves the image resolution. When generating thumbnails, default resolution is used (96dpi), not the original image resolution.
 | Scale | Gets the scale.
 | Size | Gets the size.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ResizeOptions


ResizeOptions Constructor

ResizeOptions Constructor
Namespaces ► Sitecore.ImageLib ► ResizeOptions ► ResizeOptions()()()
Initializes a new instance of the ResizeOptions class
Declaration Syntax
C#
public ResizeOptions()


AllowStretch Property

AllowStretch Property
Namespaces ► Sitecore.ImageLib ► ResizeOptions ► AllowStretch
Gets a value indicating whether to allow stretching.
Declaration Syntax
C#
public bool AllowStretch { get; set; }
Value
true if stretching is allowed; otherwise, false.


BackgroundColor Property

BackgroundColor Property
Namespaces ► Sitecore.ImageLib ► ResizeOptions ► BackgroundColor
Gets the color of the background.
Declaration Syntax
C#
public Color BackgroundColor { get; set; }
Value
The color of the background.


Format Property

Format Property
Namespaces ► Sitecore.ImageLib ► ResizeOptions ► Format
Gets or sets the image format.
Declaration Syntax
C#
public ImageFormat Format { get; set; }
Value
The format.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.ImageLib ► ResizeOptions ► IsEmpty
Gets a value indicating whether this instance is empty (ie. Size is empty and Scale is 0).
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


MaxSize Property

MaxSize Property
Namespaces ► Sitecore.ImageLib ► ResizeOptions ► MaxSize
Gets the max size.
Declaration Syntax
C#
public Size MaxSize { get; set; }
Value
The max size.


PreserveResolution Property

PreserveResolution Property
Namespaces ► Sitecore.ImageLib ► ResizeOptions ► PreserveResolution
Gets or sets a value indicating whether the ResizeOptions preserves the image resolution. When generating thumbnails, default resolution is used (96dpi), not the original image resolution.
Declaration Syntax
C#
public bool PreserveResolution { get; set; }
Value
true if the ResizeOptions preserves the resolution; otherwise, false.


Scale Property

Scale Property
Namespaces ► Sitecore.ImageLib ► ResizeOptions ► Scale
Gets the scale.
Declaration Syntax
C#
public float Scale { get; set; }
Value
The scale.


Size Property

Size Property
Namespaces ► Sitecore.ImageLib ► ResizeOptions ► Size
Gets the size.
Declaration Syntax
C#
public Size Size { get; set; }
Value
The size.


Resizer Class

Resizer Class
Namespaces ► Sitecore.ImageLib ► Resizer
Resizer
Declaration Syntax
C#
public class Resizer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Resizer()()() | Initializes a new instance of the Resizer class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFrameSize(Bitmap, ResizeOptions) | Gets the size of the output bitmap including any whitespace area.
 | GetFrameSize(Bitmap, ResizeOptions, Boolean%) | Gets the size of the output bitmap including any whitespace area.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Resize(Bitmap, ResizeOptions, ImageFormat, InterpolationMode) | Resizes the specified bitmap.
 | Resize(Bitmap, Size, Size, Color, ImageFormat, InterpolationMode) | Resizes the specified bitmap.
 | Resize(Bitmap, Size, Size, Color, Boolean, ImageFormat, InterpolationMode) | Resizes the specified bitmap.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Resizer


Resizer Constructor

Resizer Constructor
Namespaces ► Sitecore.ImageLib ► Resizer ► Resizer()()()
Initializes a new instance of the Resizer class
Declaration Syntax
C#
public Resizer()


GetFrameSize Method

GetFrameSize Method
Namespaces ► Sitecore.ImageLib ► Resizer ► GetFrameSize()()()
Members
Icon | Member | Description
 | GetFrameSize(Bitmap, ResizeOptions) | Gets the size of the output bitmap including any whitespace area.
 | GetFrameSize(Bitmap, ResizeOptions, Boolean%) | Gets the size of the output bitmap including any whitespace area.


GetFrameSize Method (image, options)

GetFrameSize Method (image, options)
Namespaces ► Sitecore.ImageLib ► Resizer ► GetFrameSize(Bitmap, ResizeOptions)
Gets the size of the output bitmap including any whitespace area.
Declaration Syntax
C#
public Size GetFrameSize(
    Bitmap image,
    ResizeOptions options
)
Parameters
image (Bitmap)
The image.
options (ResizeOptions)
The options.
Return Value


GetFrameSize Method (image, options, proportionsAreSaved)

GetFrameSize Method (image, options, proportionsAreSaved)
Namespaces ► Sitecore.ImageLib ► Resizer ► GetFrameSize(Bitmap, ResizeOptions, Boolean%)
Gets the size of the output bitmap including any whitespace area.
Declaration Syntax
C#
public Size GetFrameSize(
    Bitmap image,
    ResizeOptions options,
    out bool proportionsAreSaved
)
Parameters
image (Bitmap)
The image.
options (ResizeOptions)
The options.
proportionsAreSaved ( Boolean %)
if set to true proportions are saved.
Return Value


Resize Method

Resize Method
Namespaces ► Sitecore.ImageLib ► Resizer ► Resize()()()
Members
Icon | Member | Description
 | Resize(Bitmap, ResizeOptions, ImageFormat, InterpolationMode) | Resizes the specified bitmap.
 | Resize(Bitmap, Size, Size, Color, ImageFormat, InterpolationMode) | Resizes the specified bitmap.
 | Resize(Bitmap, Size, Size, Color, Boolean, ImageFormat, InterpolationMode) | Resizes the specified bitmap.


Resize Method (bitmap, options, format, interpolationMode)

Resize Method (bitmap, options, format, interpolationMode)
Namespaces ► Sitecore.ImageLib ► Resizer ► Resize(Bitmap, ResizeOptions, ImageFormat, InterpolationMode)
Resizes the specified bitmap.
Declaration Syntax
C#
public Bitmap Resize(
    Bitmap bitmap,
    ResizeOptions options,
    ImageFormat format,
    InterpolationMode interpolationMode
)
Parameters
bitmap (Bitmap)
The bitmap.
options (ResizeOptions)
The options.
format (ImageFormat)
The format.
interpolationMode (InterpolationMode)
The interpolation mode.
Return Value


Resize Method (bitmap, imageSize, frameSize, frameColor, preserveResolution, format, interpolationMode)

Resize Method (bitmap, imageSize, frameSize, frameColor, preserveResolution, format, interpolationMode)
Namespaces ► Sitecore.ImageLib ► Resizer ► Resize(Bitmap, Size, Size, Color, Boolean, ImageFormat, InterpolationMode)
Resizes the specified bitmap.
Declaration Syntax
C#
public Bitmap Resize(
    Bitmap bitmap,
    Size imageSize,
    Size frameSize,
    Color frameColor,
    bool preserveResolution,
    ImageFormat format,
    InterpolationMode interpolationMode
)
Parameters
bitmap (Bitmap)
The bitmap.
imageSize (Size)
Size of the image.
frameSize (Size)
Size of the frame.
frameColor (Color)
Color of the frame.
preserveResolution (Boolean)
if set to true resolution will not be reduced to 96dpi.
format (ImageFormat)
The format.
interpolationMode (InterpolationMode)
The interpolation mode.
Return Value
The resize.


Resize Method (bitmap, imageSize, frameSize, frameColor, format, interpolationMode)

Resize Method (bitmap, imageSize, frameSize, frameColor, format, interpolationMode)
Namespaces ► Sitecore.ImageLib ► Resizer ► Resize(Bitmap, Size, Size, Color, ImageFormat, InterpolationMode)
Resizes the specified bitmap.
Declaration Syntax
C#
public Bitmap Resize(
    Bitmap bitmap,
    Size imageSize,
    Size frameSize,
    Color frameColor,
    ImageFormat format,
    InterpolationMode interpolationMode
)
Parameters
bitmap (Bitmap)
The bitmap.
imageSize (Size)
Size of the image.
frameSize (Size)
Size of the frame.
frameColor (Color)
Color of the frame.
format (ImageFormat)
The format.
interpolationMode (InterpolationMode)
The interpolation mode.
Return Value
The resize.


ThumbMaker Class

ThumbMaker Class
Namespaces ► Sitecore.ImageLib ► ThumbMaker
ThumbMaker
Declaration Syntax
C#
public class ThumbMaker
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ThumbMaker(Stream) | Initializes a new instance of the ThumbMaker class.
 | ThumbMaker(Bitmap) | Initializes a new instance of the ThumbMaker class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResizeToGif(Int32, Int32, String) | Resizes to GIF.
 | ResizeToGif(Size, Boolean) | Resizes to GIF.
 | ResizeToJpeg(Int32, Int32, String) | Resizes to JPEG.
 | ResizeToJpeg(Int32, Int32, Stream) | Resizes to JPEG.
 | ResizeToJpeg(Int32, Int32, Int64, String) | Resizes to JPEG.
 | ResizeToJpeg(Int32, Int32, Int64, Stream) | Resizes to JPEG.
 | ResizeToPng(Int32, Int32, String) | Resizes to PNG.
 | ResizeToPng(Int32, Int32, Stream) | Resizes to PNG.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ThumbMaker


ThumbMaker Constructor

ThumbMaker Constructor
Namespaces ► Sitecore.ImageLib ► ThumbMaker ► ThumbMaker()()()
Members
Icon | Member | Description
 | ThumbMaker(Stream) | Initializes a new instance of the ThumbMaker class.
 | ThumbMaker(Bitmap) | Initializes a new instance of the ThumbMaker class.


ThumbMaker Constructor (image)

ThumbMaker Constructor (image)
Namespaces ► Sitecore.ImageLib ► ThumbMaker ► ThumbMaker(Bitmap)
Initializes a new instance of the ThumbMaker class.
Declaration Syntax
C#
public ThumbMaker(
    Bitmap image
)
Parameters
image (Bitmap)
The image.


ThumbMaker Constructor (stream)

ThumbMaker Constructor (stream)
Namespaces ► Sitecore.ImageLib ► ThumbMaker ► ThumbMaker(Stream)
Initializes a new instance of the ThumbMaker class.
Declaration Syntax
C#
public ThumbMaker(
    Stream stream
)
Parameters
stream (Stream)
The stream.


ResizeToGif Method

ResizeToGif Method
Namespaces ► Sitecore.ImageLib ► ThumbMaker ► ResizeToGif()()()
Members
Icon | Member | Description
 | ResizeToGif(Int32, Int32, String) | Resizes to GIF.
 | ResizeToGif(Size, Boolean) | Resizes to GIF.


ResizeToGif Method (size, preserveResolution)

ResizeToGif Method (size, preserveResolution)
Namespaces ► Sitecore.ImageLib ► ThumbMaker ► ResizeToGif(Size, Boolean)
Resizes to GIF.
Declaration Syntax
C#
public Bitmap ResizeToGif(
    Size size,
    bool preserveResolution
)
Parameters
size (Size)
The size.
preserveResolution (Boolean)
if set to true output resolution will be the same as input resolution, not reduced to 96dpi.
Return Value
The to GIF.


ResizeToGif Method (xSize, ySize, fileName)

ResizeToGif Method (xSize, ySize, fileName)
Namespaces ► Sitecore.ImageLib ► ThumbMaker ► ResizeToGif(Int32, Int32, String)
Resizes to GIF.
Declaration Syntax
C#
public void ResizeToGif(
    int xSize,
    int ySize,
    string fileName
)
Parameters
xSize (Int32)
Size of the x.
ySize (Int32)
Size of the y.
fileName (String)
Name of the file.


ResizeToJpeg Method

ResizeToJpeg Method
Namespaces ► Sitecore.ImageLib ► ThumbMaker ► ResizeToJpeg()()()
Members
Icon | Member | Description
 | ResizeToJpeg(Int32, Int32, String) | Resizes to JPEG.
 | ResizeToJpeg(Int32, Int32, Stream) | Resizes to JPEG.
 | ResizeToJpeg(Int32, Int32, Int64, String) | Resizes to JPEG.
 | ResizeToJpeg(Int32, Int32, Int64, Stream) | Resizes to JPEG.


ResizeToJpeg Method (xSize, ySize, jQuality, stream)

ResizeToJpeg Method (xSize, ySize, jQuality, stream)
Namespaces ► Sitecore.ImageLib ► ThumbMaker ► ResizeToJpeg(Int32, Int32, Int64, Stream)
Resizes to JPEG.
Declaration Syntax
C#
public void ResizeToJpeg(
    int xSize,
    int ySize,
    long jQuality,
    Stream stream
)
Parameters
xSize (Int32)
Size of the x.
ySize (Int32)
Size of the y.
jQuality (Int64)
The j quality.
stream (Stream)
The stream.


ResizeToJpeg Method (xSize, ySize, jQuality, fileName)

ResizeToJpeg Method (xSize, ySize, jQuality, fileName)
Namespaces ► Sitecore.ImageLib ► ThumbMaker ► ResizeToJpeg(Int32, Int32, Int64, String)
Resizes to JPEG.
Declaration Syntax
C#
public void ResizeToJpeg(
    int xSize,
    int ySize,
    long jQuality,
    string fileName
)
Parameters
xSize (Int32)
Size of the x.
ySize (Int32)
Size of the y.
jQuality (Int64)
The j quality.
fileName (String)
Name of the file.


ResizeToJpeg Method (xSize, ySize, stream)

ResizeToJpeg Method (xSize, ySize, stream)
Namespaces ► Sitecore.ImageLib ► ThumbMaker ► ResizeToJpeg(Int32, Int32, Stream)
Resizes to JPEG.
Declaration Syntax
C#
public void ResizeToJpeg(
    int xSize,
    int ySize,
    Stream stream
)
Parameters
xSize (Int32)
Size of the x.
ySize (Int32)
Size of the y.
stream (Stream)
The stream.


ResizeToJpeg Method (xSize, ySize, fileName)

ResizeToJpeg Method (xSize, ySize, fileName)
Namespaces ► Sitecore.ImageLib ► ThumbMaker ► ResizeToJpeg(Int32, Int32, String)
Resizes to JPEG.
Declaration Syntax
C#
public void ResizeToJpeg(
    int xSize,
    int ySize,
    string fileName
)
Parameters
xSize (Int32)
Size of the x.
ySize (Int32)
Size of the y.
fileName (String)
Name of the file.


ResizeToPng Method

ResizeToPng Method
Namespaces ► Sitecore.ImageLib ► ThumbMaker ► ResizeToPng()()()
Members
Icon | Member | Description
 | ResizeToPng(Int32, Int32, String) | Resizes to PNG.
 | ResizeToPng(Int32, Int32, Stream) | Resizes to PNG.


ResizeToPng Method (xSize, ySize, stream)

ResizeToPng Method (xSize, ySize, stream)
Namespaces ► Sitecore.ImageLib ► ThumbMaker ► ResizeToPng(Int32, Int32, Stream)
Resizes to PNG.
Declaration Syntax
C#
public void ResizeToPng(
    int xSize,
    int ySize,
    Stream stream
)
Parameters
xSize (Int32)
Size of the x.
ySize (Int32)
Size of the y.
stream (Stream)
The stream.


ResizeToPng Method (xSize, ySize, fileName)

ResizeToPng Method (xSize, ySize, fileName)
Namespaces ► Sitecore.ImageLib ► ThumbMaker ► ResizeToPng(Int32, Int32, String)
Resizes to PNG.
Declaration Syntax
C#
public void ResizeToPng(
    int xSize,
    int ySize,
    string fileName
)
Parameters
xSize (Int32)
Size of the x.
ySize (Int32)
Size of the y.
fileName (String)
Name of the file.


Sitecore.Install Namespace

Sitecore.Install Namespace
Namespaces ► Sitecore.Install
Declaration Syntax
C#
namespace Sitecore.Install
Types
All Types Classes
Icon | Type | Description
 | PackageProject..::.Builder | Represents a sink which is used to build a PackageProject object
 | Constants | Constants
 | Installer | Installer class
 | PackageGenerator | Package generator
 | PackageProject | Package project class
 | PackageRegistrationFieldIDs | Constains field ids
 | PackageUtils | Package utils
 | StreamUtil | Stream utility class


Constants Class

Constants Class
Namespaces ► Sitecore.Install ► Constants
Constants
Declaration Syntax
C#
public static class Constants
Members
All Members | Properties | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ApplicationPath |
 | BlobDataPrefix |
 | Database | Gets the database.
 | FilesPrefix |
 | IDCollisionPrefix |
 | InstallerObjectTemplate |
 | InstallerPrefix |
 | InstallMode |
 | ItemsPrefix |
 | KeySeparator |
 | MediaStreamsFolder |
 | MergeMode |
 | MetadataPrefix |
 | PackageExtension |
 | PathCollisionPrefix |
 | ProjectKey |
 | PropertiesPrefix |
 | SolutionExtension |
 | SystemPath |
 | UnnamedPackage |
Inheritance Hierarchy
Object
Constants


ApplicationPath Field

ApplicationPath Field
Namespaces ► Sitecore.Install ► Constants ► ApplicationPath
Declaration Syntax
C#
public static readonly string ApplicationPath


BlobDataPrefix Field

BlobDataPrefix Field
Namespaces ► Sitecore.Install ► Constants ► BlobDataPrefix
Declaration Syntax
C#
public static readonly string BlobDataPrefix


Database Property

Database Property
Namespaces ► Sitecore.Install ► Constants ► Database
Gets the database.
Declaration Syntax
C#
public static Database Database { get; }
Value
The database.


FilesPrefix Field

FilesPrefix Field
Namespaces ► Sitecore.Install ► Constants ► FilesPrefix
Declaration Syntax
C#
public static readonly string FilesPrefix


IDCollisionPrefix Field

IDCollisionPrefix Field
Namespaces ► Sitecore.Install ► Constants ► IDCollisionPrefix
Declaration Syntax
C#
public static readonly string IDCollisionPrefix


InstallerObjectTemplate Field

InstallerObjectTemplate Field
Namespaces ► Sitecore.Install ► Constants ► InstallerObjectTemplate
Declaration Syntax
C#
public static ID InstallerObjectTemplate


InstallerPrefix Field

InstallerPrefix Field
Namespaces ► Sitecore.Install ► Constants ► InstallerPrefix
Declaration Syntax
C#
public static readonly string InstallerPrefix


InstallMode Field

InstallMode Field
Namespaces ► Sitecore.Install ► Constants ► InstallMode
Declaration Syntax
C#
public static readonly string InstallMode


ItemsPrefix Field

ItemsPrefix Field
Namespaces ► Sitecore.Install ► Constants ► ItemsPrefix
Declaration Syntax
C#
public static readonly string ItemsPrefix


KeySeparator Field

KeySeparator Field
Namespaces ► Sitecore.Install ► Constants ► KeySeparator
Declaration Syntax
C#
public static readonly char KeySeparator


MediaStreamsFolder Field

MediaStreamsFolder Field
Namespaces ► Sitecore.Install ► Constants ► MediaStreamsFolder
Declaration Syntax
C#
public static readonly string MediaStreamsFolder


MergeMode Field

MergeMode Field
Namespaces ► Sitecore.Install ► Constants ► MergeMode
Declaration Syntax
C#
public static readonly string MergeMode


MetadataPrefix Field

MetadataPrefix Field
Namespaces ► Sitecore.Install ► Constants ► MetadataPrefix
Declaration Syntax
C#
public static readonly string MetadataPrefix


PackageExtension Field

PackageExtension Field
Namespaces ► Sitecore.Install ► Constants ► PackageExtension
Declaration Syntax
C#
public static readonly string PackageExtension


PathCollisionPrefix Field

PathCollisionPrefix Field
Namespaces ► Sitecore.Install ► Constants ► PathCollisionPrefix
Declaration Syntax
C#
public static readonly string PathCollisionPrefix


ProjectKey Field

ProjectKey Field
Namespaces ► Sitecore.Install ► Constants ► ProjectKey
Declaration Syntax
C#
public static readonly string ProjectKey


PropertiesPrefix Field

PropertiesPrefix Field
Namespaces ► Sitecore.Install ► Constants ► PropertiesPrefix
Declaration Syntax
C#
public static readonly string PropertiesPrefix


SolutionExtension Field

SolutionExtension Field
Namespaces ► Sitecore.Install ► Constants ► SolutionExtension
Declaration Syntax
C#
public static readonly string SolutionExtension


SystemPath Field

SystemPath Field
Namespaces ► Sitecore.Install ► Constants ► SystemPath
Declaration Syntax
C#
public static readonly string SystemPath


UnnamedPackage Field

UnnamedPackage Field
Namespaces ► Sitecore.Install ► Constants ► UnnamedPackage
Declaration Syntax
C#
public static readonly string UnnamedPackage


Installer Class

Installer Class
Namespaces ► Sitecore.Install ► Installer
Installer class
Declaration Syntax
C#
public class Installer : MarshalByRefObject
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Installer()()() | Initializes a new instance of the Installer class
 | CreateInstallationContext()()() | Creates the installation context.
 | CreateInstallerSink(IProcessingContext) | Creates an installer sink.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreatePreviewContext()()() | Creates the preview context.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecutePostStep(String, IProcessingContext) | Executes the post step.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFilename(String) | Gets the filename.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetPostStep(IProcessingContext) | Gets the post step.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InstallPackage(String) | Installs the package.
 | InstallPackage(String, ISource<(Of <(PackageEntry>)>)) | Installs the package.
 | InstallPackage(String, IProcessingContext) | Installs the package.
 | InstallPackage(String, ISource<(Of <(PackageEntry>)>), IProcessingContext) | Installs the package.
 | InstallSecurity(String) | Installs the security accounts from the package.
 | InstallSecurity(String, IProcessingContext) | Installs the security accounts from the package.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterPackage(IProcessingContext) | Creates an item with information about package installation.
 | RestartServer()()() | Restarts the sitecore server.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Installer


Installer Constructor

Installer Constructor
Namespaces ► Sitecore.Install ► Installer ► Installer()()()
Initializes a new instance of the Installer class
Declaration Syntax
C#
public Installer()


CreateInstallationContext Method

CreateInstallationContext Method
Namespaces ► Sitecore.Install ► Installer ► CreateInstallationContext()()()
Creates the installation context.
Declaration Syntax
C#
public static IProcessingContext CreateInstallationContext()
Return Value
The installation context.


CreateInstallerSink Method (context)

CreateInstallerSink Method (context)
Namespaces ► Sitecore.Install ► Installer ► CreateInstallerSink(IProcessingContext)
Creates an installer sink.
Declaration Syntax
C#
public static ISink<PackageEntry> CreateInstallerSink(
    IProcessingContext context
)
Parameters
context (IProcessingContext)
Return Value
An installer sink.


CreatePreviewContext Method

CreatePreviewContext Method
Namespaces ► Sitecore.Install ► Installer ► CreatePreviewContext()()()
Creates the preview context.
Declaration Syntax
C#
public static IProcessingContext CreatePreviewContext()
Return Value
The preview context.


ExecutePostStep Method (action, context)

ExecutePostStep Method (action, context)
Namespaces ► Sitecore.Install ► Installer ► ExecutePostStep(String, IProcessingContext)
Executes the post step.
Declaration Syntax
C#
public void ExecutePostStep(
    string action,
    IProcessingContext context
)
Parameters
action (String)
The action.
context (IProcessingContext)
The context.


GetFilename Method (filename)

GetFilename Method (filename)
Namespaces ► Sitecore.Install ► Installer ► GetFilename(String)
Gets the filename.
Declaration Syntax
C#
public static string GetFilename(
    string filename
)
Parameters
filename (String)
The filename.
Return Value
The filename.


GetPostStep Method (context)

GetPostStep Method (context)
Namespaces ► Sitecore.Install ► Installer ► GetPostStep(IProcessingContext)
Gets the post step.
Declaration Syntax
C#
public static string GetPostStep(
    IProcessingContext context
)
Parameters
context (IProcessingContext)
The context.
Return Value
The post step.


InstallPackage Method

InstallPackage Method
Namespaces ► Sitecore.Install ► Installer ► InstallPackage()()()
Members
Icon | Member | Description
 | InstallPackage(String) | Installs the package.
 | InstallPackage(String, ISource<(Of <(PackageEntry>)>)) | Installs the package.
 | InstallPackage(String, IProcessingContext) | Installs the package.
 | InstallPackage(String, ISource<(Of <(PackageEntry>)>), IProcessingContext) | Installs the package.


InstallPackage Method (path)

InstallPackage Method (path)
Namespaces ► Sitecore.Install ► Installer ► InstallPackage(String)
Installs the package.
Declaration Syntax
C#
public void InstallPackage(
    string path
)
Parameters
path (String)
The path.


InstallPackage Method (path, context)

InstallPackage Method (path, context)
Namespaces ► Sitecore.Install ► Installer ► InstallPackage(String, IProcessingContext)
Installs the package.
Declaration Syntax
C#
public void InstallPackage(
    string path,
    IProcessingContext context
)
Parameters
path (String)
The path.
context (IProcessingContext)
The processing context.


InstallPackage Method (path, source)

InstallPackage Method (path, source)
Namespaces ► Sitecore.Install ► Installer ► InstallPackage(String, ISource<(Of <(PackageEntry>)>))
Installs the package.
Declaration Syntax
C#
public void InstallPackage(
    string path,
    ISource<PackageEntry> source
)
Parameters
path (String)
The path.
source (ISource <(Of <( PackageEntry >)>))
The source.


InstallPackage Method (path, source, context)

InstallPackage Method (path, source, context)
Namespaces ► Sitecore.Install ► Installer ► InstallPackage(String, ISource<(Of <(PackageEntry>)>), IProcessingContext)
Installs the package.
Declaration Syntax
C#
public void InstallPackage(
    string path,
    ISource<PackageEntry> source,
    IProcessingContext context
)
Parameters
path (String)
The path.
source (ISource <(Of <( PackageEntry >)>))
The source.
context (IProcessingContext)
The processing context.


InstallSecurity Method

InstallSecurity Method
Namespaces ► Sitecore.Install ► Installer ► InstallSecurity()()()
Members
Icon | Member | Description
 | InstallSecurity(String) | Installs the security accounts from the package.
 | InstallSecurity(String, IProcessingContext) | Installs the security accounts from the package.


InstallSecurity Method (path)

InstallSecurity Method (path)
Namespaces ► Sitecore.Install ► Installer ► InstallSecurity(String)
Installs the security accounts from the package.
Declaration Syntax
C#
public void InstallSecurity(
    string path
)
Parameters
path (String)
The path to the package file.


InstallSecurity Method (path, context)

InstallSecurity Method (path, context)
Namespaces ► Sitecore.Install ► Installer ► InstallSecurity(String, IProcessingContext)
Installs the security accounts from the package.
Declaration Syntax
C#
public void InstallSecurity(
    string path,
    IProcessingContext context
)
Parameters
path (String)
The path to the package file.
context (IProcessingContext)
The context.


RegisterPackage Method (context)

RegisterPackage Method (context)
Namespaces ► Sitecore.Install ► Installer ► RegisterPackage(IProcessingContext)
Creates an item with information about package installation.
Declaration Syntax
C#
protected virtual void RegisterPackage(
    IProcessingContext context
)
Parameters
context (IProcessingContext)
The context.


RestartServer Method

RestartServer Method
Namespaces ► Sitecore.Install ► Installer ► RestartServer()()()
Restarts the sitecore server.
Declaration Syntax
C#
public static void RestartServer()


PackageGenerator Class

PackageGenerator Class
Namespaces ► Sitecore.Install ► PackageGenerator
Package generator
Declaration Syntax
C#
public static class PackageGenerator
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GeneratePackage(PackageProject, ISink<(Of <(PackageEntry>)>)) | Generates the package.
 | GeneratePackage(String, String, IProcessingContext) | Generates the package.
 | NewProjectFromPackage(String) | Creates a new project from the package.
Inheritance Hierarchy
Object
PackageGenerator


GeneratePackage Method

GeneratePackage Method
Namespaces ► Sitecore.Install ► PackageGenerator ► GeneratePackage()()()
Members
Icon | Member | Description
 | GeneratePackage(PackageProject, ISink<(Of <(PackageEntry>)>)) | Generates the package.
 | GeneratePackage(String, String, IProcessingContext) | Generates the package.


GeneratePackage Method (solution, writer)

GeneratePackage Method (solution, writer)
Namespaces ► Sitecore.Install ► PackageGenerator ► GeneratePackage(PackageProject, ISink<(Of <(PackageEntry>)>))
Generates the package.
Declaration Syntax
C#
public static void GeneratePackage(
    PackageProject solution,
    ISink<PackageEntry> writer
)
Parameters
solution (PackageProject)
The solution.
writer (ISink <(Of <( PackageEntry >)>))
The writer. Should be initialized.


GeneratePackage Method (solutionFile, packageFile, context)

GeneratePackage Method (solutionFile, packageFile, context)
Namespaces ► Sitecore.Install ► PackageGenerator ► GeneratePackage(String, String, IProcessingContext)
Generates the package.
Declaration Syntax
C#
public static void GeneratePackage(
    string solutionFile,
    string packageFile,
    IProcessingContext context
)
Parameters
solutionFile (String)
The solution file.
packageFile (String)
The package file.
context (IProcessingContext)
The context.


NewProjectFromPackage Method (packageFilename)

NewProjectFromPackage Method (packageFilename)
Namespaces ► Sitecore.Install ► PackageGenerator ► NewProjectFromPackage(String)
Creates a new project from the package.
Declaration Syntax
C#
public static PackageProject NewProjectFromPackage(
    string packageFilename
)
Parameters
packageFilename (String)
The package filename.
Return Value
The project from package.


PackageProject Class

PackageProject Class
Namespaces ► Sitecore.Install ► PackageProject
Package project class
Declaration Syntax
C#
public class PackageProject : BaseSource<PackageEntry>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PackageProject()()() | Initializes a new instance of the PackageProject class.
 | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Include | Gets the include filters. (Inherited from BaseSource<(Of <(T>)>).)
 | InternalPopulate(ISink<(Of <(PackageEntry>)>)) | Populates the sink with metadata and sources have been set (Overrides BaseSource <(Of <( PackageEntry >)>).InternalPopulate(ISink<(Of <(T>)>)).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Metadata | Gets or sets the metadata.
 | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(T>)>).)
 | Populate(ISink<(Of <(PackageEntry>)>)) | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(T>)>).)
 | SaveProject | Gets or sets a value indicating whether project should be saved into the package.
 | Sources | Gets the sources.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSource <(Of <( PackageEntry >)>)
 |  | PackageProject


PackageProject Constructor

PackageProject Constructor
Namespaces ► Sitecore.Install ► PackageProject ► PackageProject()()()
Initializes a new instance of the PackageProject class.
Declaration Syntax
C#
public PackageProject()


InternalPopulate Method (sink)

InternalPopulate Method (sink)
Namespaces ► Sitecore.Install ► PackageProject ► InternalPopulate(ISink<(Of <(PackageEntry>)>))
Populates the sink with metadata and sources have been set
Declaration Syntax
C#
protected override void InternalPopulate(
    ISink<PackageEntry> sink
)
Parameters
sink (ISink <(Of <( PackageEntry >)>))
The sink


Metadata Property

Metadata Property
Namespaces ► Sitecore.Install ► PackageProject ► Metadata
Gets or sets the metadata.
Declaration Syntax
C#
public MetadataSource Metadata { get; set; }
Value
The metadata.


SaveProject Property

SaveProject Property
Namespaces ► Sitecore.Install ► PackageProject ► SaveProject
Gets or sets a value indicating whether project should be saved into the package.
Declaration Syntax
C#
public bool SaveProject { get; set; }
Value
true if project should be included into the package; otherwise, false. Default is true


Sources Property

Sources Property
Namespaces ► Sitecore.Install ► PackageProject ► Sources
Gets the sources.
Declaration Syntax
C#
public IList<ISource<PackageEntry>> Sources { get; }
Value
The sources.


PackageProject.Builder Class

PackageProject..::.Builder Class
Namespaces ► Sitecore.Install ► PackageProject ► PackageProject..::.Builder
Represents a sink which is used to build a PackageProject object
Declaration Syntax
C#
public class Builder : BaseSink<PackageEntry>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PackageProject..::.Builder()()() | Initializes a new instance of the PackageProject..::.Builder class
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Overrides BaseSink <(Of <( PackageEntry >)>).Finish()()().)
 | Flush()()() | Flushes the sink (Overrides BaseSink <(Of <( PackageEntry >)>).Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Overrides BaseSink <(Of <( PackageEntry >)>).Initialize(IProcessingContext).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | Puts the specified entry. (Overrides BaseSink <(Of <( PackageEntry >)>).Put(T).)
 | Source | Gets the source.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( PackageEntry >)>)
 |  | PackageProject..::.Builder


PackageProject.Builder Constructor

PackageProject..::.Builder Constructor
Namespaces ► Sitecore.Install ► PackageProject..::.Builder ► PackageProject..::.Builder()()()
Initializes a new instance of the PackageProject..::.Builder class
Declaration Syntax
C#
public Builder()


Finish Method

Finish Method
Namespaces ► Sitecore.Install ► PackageProject..::.Builder ► Finish()()()
Finishes the sink.
Declaration Syntax
C#
public override void Finish()


Flush Method

Flush Method
Namespaces ► Sitecore.Install ► PackageProject..::.Builder ► Flush()()()
Flushes the sink
Declaration Syntax
C#
public override void Flush()


Initialize Method (context)

Initialize Method (context)
Namespaces ► Sitecore.Install ► PackageProject..::.Builder ► Initialize(IProcessingContext)
Initializes this instance.
Declaration Syntax
C#
public override void Initialize(
    IProcessingContext context
)
Parameters
context (IProcessingContext)
The context.


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install ► PackageProject..::.Builder ► Put(PackageEntry)
Puts the specified entry.
Declaration Syntax
C#
public override void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


Source Property

Source Property
Namespaces ► Sitecore.Install ► PackageProject..::.Builder ► Source
Gets the source.
Declaration Syntax
C#
public PackageProject Source { get; }
Value
The source.


PackageRegistrationFieldIDs Class

PackageRegistrationFieldIDs Class
Namespaces ► Sitecore.Install ► PackageRegistrationFieldIDs
Constains field ids
Declaration Syntax
C#
public static class PackageRegistrationFieldIDs
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PackageAuthor |
 | PackageID |
 | PackageName |
 | PackagePublisher |
 | PackageReadme |
 | PackageRevision |
 | PackageVersion |
Inheritance Hierarchy
Object
PackageRegistrationFieldIDs


PackageAuthor Field

PackageAuthor Field
Namespaces ► Sitecore.Install ► PackageRegistrationFieldIDs ► PackageAuthor
Declaration Syntax
C#
public static readonly ID PackageAuthor


PackageID Field

PackageID Field
Namespaces ► Sitecore.Install ► PackageRegistrationFieldIDs ► PackageID
Declaration Syntax
C#
public static readonly ID PackageID


PackageName Field

PackageName Field
Namespaces ► Sitecore.Install ► PackageRegistrationFieldIDs ► PackageName
Declaration Syntax
C#
public static readonly ID PackageName


PackagePublisher Field

PackagePublisher Field
Namespaces ► Sitecore.Install ► PackageRegistrationFieldIDs ► PackagePublisher
Declaration Syntax
C#
public static readonly ID PackagePublisher


PackageReadme Field

PackageReadme Field
Namespaces ► Sitecore.Install ► PackageRegistrationFieldIDs ► PackageReadme
Declaration Syntax
C#
public static readonly ID PackageReadme


PackageRevision Field

PackageRevision Field
Namespaces ► Sitecore.Install ► PackageRegistrationFieldIDs ► PackageRevision
Declaration Syntax
C#
public static readonly ID PackageRevision


PackageVersion Field

PackageVersion Field
Namespaces ► Sitecore.Install ► PackageRegistrationFieldIDs ► PackageVersion
Declaration Syntax
C#
public static readonly ID PackageVersion


PackageUtils Class

PackageUtils Class
Namespaces ► Sitecore.Install ► PackageUtils
Package utils
Declaration Syntax
C#
public static class PackageUtils
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CleanupFileName(String) | Generates a valid file name
 | GetEntryKeyPrefix(String) | Gets the entry key prefix.
 | GetItemStream(Item) | Gets the item stream.
 | TryGetValue<(Of <(K, V>)>)(IDictionary<(Of <(K, V>)>), K) | Tries the get value from the dictionary.
Inheritance Hierarchy
Object
PackageUtils


CleanupFileName Method (fileName)

CleanupFileName Method (fileName)
Namespaces ► Sitecore.Install ► PackageUtils ► CleanupFileName(String)
Generates a valid file name
Declaration Syntax
C#
public static string CleanupFileName(
    string fileName
)
Parameters
fileName (String)
A file name
Return Value


GetEntryKeyPrefix Method (key)

GetEntryKeyPrefix Method (key)
Namespaces ► Sitecore.Install ► PackageUtils ► GetEntryKeyPrefix(String)
Gets the entry key prefix.
Declaration Syntax
C#
public static string GetEntryKeyPrefix(
    string key
)
Parameters
key (String)
The key.
Return Value
The entry key prefix.


GetItemStream Method (item)

GetItemStream Method (item)
Namespaces ► Sitecore.Install ► PackageUtils ► GetItemStream(Item)
Gets the item stream.
Declaration Syntax
C#
public static Stream GetItemStream(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The item stream.


TryGetValue Method (dictionary, key)

TryGetValue<(Of <(K, V>)>) Method (dictionary, key)
Namespaces ► Sitecore.Install ► PackageUtils ► TryGetValue<(Of <(K, V>)>)(IDictionary<(Of <(K, V>)>), K)
Tries the get value from the dictionary.
Declaration Syntax
C#
public static V TryGetValue<K, V>(
    IDictionary<K, V> dictionary,
    K key
)
Generic Template Parameters
K
Type of the key
V
Type of the value
Parameters
dictionary (IDictionary<(Of <(K, V>)>))
The dictionary.
key (K)
The key.
Return Value
The value.


StreamUtil Class

StreamUtil Class
Namespaces ► Sitecore.Install ► StreamUtil
Stream utility class
Declaration Syntax
C#
public static class StreamUtil
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Copy(Stream, Stream, Int32) | Copies one stream to another.
 | LoadDictionary(IDictionary<(Of <(String, String>)>), Stream) | Loads the dictionary from the stream.
 | LoadString(Stream) | Loads the string from the stream.
 | SaveDictionary(IDictionary<(Of <(String, String>)>)) | Saves the dictionary to the stream.
 | SaveDictionary(IDictionary<(Of <(String, String>)>), Stream, Boolean) | Saves the dictionary to the stream.
 | SaveString(String) | Saves the string to the stream.
Inheritance Hierarchy
Object
StreamUtil


Copy Method (from, to, bufferSize)

Copy Method (from, to, bufferSize)
Namespaces ► Sitecore.Install ► StreamUtil ► Copy(Stream, Stream, Int32)
Copies one stream to another.
Declaration Syntax
C#
public static void Copy(
    Stream from,
    Stream to,
    int bufferSize
)
Parameters
from (Stream)
From.
to (Stream)
To.
bufferSize (Int32)
Size of the buffer.


LoadDictionary Method (dictionary, stream)

LoadDictionary Method (dictionary, stream)
Namespaces ► Sitecore.Install ► StreamUtil ► LoadDictionary(IDictionary<(Of <(String, String>)>), Stream)
Loads the dictionary from the stream.
Declaration Syntax
C#
public static void LoadDictionary(
    IDictionary<string, string> dictionary,
    Stream stream
)
Parameters
dictionary (IDictionary<(Of <(String, String>)>))
The dictionary.
stream (Stream)
The stream.


LoadString Method (stream)

LoadString Method (stream)
Namespaces ► Sitecore.Install ► StreamUtil ► LoadString(Stream)
Loads the string from the stream.
Declaration Syntax
C#
public static string LoadString(
    Stream stream
)
Parameters
stream (Stream)
The stream.
Return Value
The string.


SaveDictionary Method

SaveDictionary Method
Namespaces ► Sitecore.Install ► StreamUtil ► SaveDictionary()()()
Members
Icon | Member | Description
 | SaveDictionary(IDictionary<(Of <(String, String>)>)) | Saves the dictionary to the stream.
 | SaveDictionary(IDictionary<(Of <(String, String>)>), Stream, Boolean) | Saves the dictionary to the stream.


SaveDictionary Method (dictionary)

SaveDictionary Method (dictionary)
Namespaces ► Sitecore.Install ► StreamUtil ► SaveDictionary(IDictionary<(Of <(String, String>)>))
Saves the dictionary to the stream.
Declaration Syntax
C#
public static MemoryStream SaveDictionary(
    IDictionary<string, string> dictionary
)
Parameters
dictionary (IDictionary<(Of <(String, String>)>))
The dictionary.


SaveDictionary Method (dictionary, stream, closeStream)

SaveDictionary Method (dictionary, stream, closeStream)
Namespaces ► Sitecore.Install ► StreamUtil ► SaveDictionary(IDictionary<(Of <(String, String>)>), Stream, Boolean)
Saves the dictionary to the stream.
Declaration Syntax
C#
public static void SaveDictionary(
    IDictionary<string, string> dictionary,
    Stream stream,
    bool closeStream
)
Parameters
dictionary (IDictionary<(Of <(String, String>)>))
The dictionary.
stream (Stream)
The stream.
closeStream (Boolean)
if set to true closes the stream.


SaveString Method (s)

SaveString Method (s)
Namespaces ► Sitecore.Install ► StreamUtil ► SaveString(String)
Saves the string to the stream.
Declaration Syntax
C#
public static Stream SaveString(
    string s
)
Parameters
s (String)
The string.
Return Value
The string.


Sitecore.Install.BlobData Namespace

Sitecore.Install.BlobData Namespace
Namespaces ► Sitecore.Install.BlobData
Declaration Syntax
C#
namespace Sitecore.Install.BlobData
Types
All Types Classes
Icon | Type | Description
 | BlobEntryData | BlobEntryData class
 | BlobInstaller | Media installer
 | BlobInstallerContext | BlobInstallerContext class
 | BlobLink | Link to a blob
 | FileReference | Represents a reference to a file from media item
 | MediaStreamEntryData | MediaStreamEntryData class
 | MediaStreamLink | MediaStreamLink class


BlobEntryData Class

BlobEntryData Class
Namespaces ► Sitecore.Install.BlobData ► BlobEntryData
BlobEntryData class
Declaration Syntax
C#
public class BlobEntryData : IEntryData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BlobEntryData(BlobLink) | Initializes a new instance of the BlobEntryData class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStream()()() | Gets the stream holder.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BlobEntryData


BlobEntryData Constructor (blobLink)

BlobEntryData Constructor (blobLink)
Namespaces ► Sitecore.Install.BlobData ► BlobEntryData ► BlobEntryData(BlobLink)
Initializes a new instance of the BlobEntryData class.
Declaration Syntax
C#
public BlobEntryData(
    BlobLink blobLink
)
Parameters
blobLink (BlobLink)
The BLOB link.


GetStream Method

GetStream Method
Namespaces ► Sitecore.Install.BlobData ► BlobEntryData ► GetStream()()()
Gets the stream holder.
Declaration Syntax
C#
public IStreamHolder GetStream()
Return Value
The stream holder.


Key Property

Key Property
Namespaces ► Sitecore.Install.BlobData ► BlobEntryData ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


BlobInstaller Class

BlobInstaller Class
Namespaces ► Sitecore.Install.BlobData ► BlobInstaller
Media installer
Declaration Syntax
C#
public class BlobInstaller : AdvancedBaseSink<PackageEntry, BlobInstallerContext>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BlobInstaller(IProcessingContext) | Initializes a new instance of the BlobInstaller class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Context | Gets the context. (Inherited from AdvancedBaseSink<(Of <(T, ContextType>)>).)
 | CreateContext()()() | Creates the context. (Overrides AdvancedBaseSink <(Of <( PackageEntry, BlobInstallerContext >)>).CreateContext()()().)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Inherited from BaseSink<(Of <(T>)>).)
 | Flush()()() | Flushes the sink (Inherited from BaseSink<(Of <(T>)>).)
 | FlushData(IProcessingContext) | Flushes the data.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from AdvancedBaseSink<(Of <(T, ContextType>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | Installs blob from the entry.
 | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(T>)>).)
 | SetupContext(ContextType) | Setups the context. (Inherited from AdvancedBaseSink<(Of <(T, ContextType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateBlobData(Item, IProcessingContext) | In Sitecore 5.3 attachment field contains blob value. In Sitecore 6 this field contains guid which is a referense for blob in related table. This method does a convertion for such values. Also the method registers references to blob values. In order not to install unused blobs.
Inheritance Hierarchy
Object
 | BaseSink <(Of <( T >)>)
 |  | AdvancedBaseSink <(Of <( PackageEntry, BlobInstallerContext >)>)
 |  |  | BlobInstaller


BlobInstaller Constructor (context)

BlobInstaller Constructor (context)
Namespaces ► Sitecore.Install.BlobData ► BlobInstaller ► BlobInstaller(IProcessingContext)
Initializes a new instance of the BlobInstaller class.
Declaration Syntax
C#
public BlobInstaller(
    IProcessingContext context
)
Parameters
context (IProcessingContext)
The context.


CreateContext Method

CreateContext Method
Namespaces ► Sitecore.Install.BlobData ► BlobInstaller ► CreateContext()()()
Creates the context.
Declaration Syntax
C#
protected override BlobInstallerContext CreateContext()
Return Value
The context.


FlushData Method (processingContext)

FlushData Method (processingContext)
Namespaces ► Sitecore.Install.BlobData ► BlobInstaller ► FlushData(IProcessingContext)
Flushes the data.
Declaration Syntax
C#
public static void FlushData(
    IProcessingContext processingContext
)
Parameters
processingContext (IProcessingContext)
The context.


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.BlobData ► BlobInstaller ► Put(PackageEntry)
Installs blob from the entry.
Declaration Syntax
C#
public virtual void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


UpdateBlobData Method (item, context)

UpdateBlobData Method (item, context)
Namespaces ► Sitecore.Install.BlobData ► BlobInstaller ► UpdateBlobData(Item, IProcessingContext)
In Sitecore 5.3 attachment field contains blob value. In Sitecore 6 this field contains guid which is a referense for blob in related table. This method does a convertion for such values. Also the method registers references to blob values. In order not to install unused blobs.
Declaration Syntax
C#
public static void UpdateBlobData(
    Item item,
    IProcessingContext context
)
Parameters
item (Item)
context (IProcessingContext)


BlobInstallerContext Class

BlobInstallerContext Class
Namespaces ► Sitecore.Install.BlobData ► BlobInstallerContext
BlobInstallerContext class
Declaration Syntax
C#
public sealed class BlobInstallerContext
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BlobInstallerContext()()() | Initializes a new instance of the BlobInstallerContext class
 | Clear()()() | Clears this instance.
 | Entries | Entries to be installed
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileReferences | Links to files, from the items that have been installed
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImageCache | Contains list of MD5 stamps for installed images and its guid
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | References | Links to blobs, from the items that have been installed
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BlobInstallerContext


BlobInstallerContext Constructor

BlobInstallerContext Constructor
Namespaces ► Sitecore.Install.BlobData ► BlobInstallerContext ► BlobInstallerContext()()()
Initializes a new instance of the BlobInstallerContext class
Declaration Syntax
C#
public BlobInstallerContext()


Clear Method

Clear Method
Namespaces ► Sitecore.Install.BlobData ► BlobInstallerContext ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public void Clear()


Entries Field

Entries Field
Namespaces ► Sitecore.Install.BlobData ► BlobInstallerContext ► Entries
Entries to be installed
Declaration Syntax
C#
public readonly IList<PackageEntry> Entries


FileReferences Field

FileReferences Field
Namespaces ► Sitecore.Install.BlobData ► BlobInstallerContext ► FileReferences
Links to files, from the items that have been installed
Declaration Syntax
C#
public readonly IList<FileReference> FileReferences


ImageCache Field

ImageCache Field
Namespaces ► Sitecore.Install.BlobData ► BlobInstallerContext ► ImageCache
Contains list of MD5 stamps for installed images and its guid
Declaration Syntax
C#
public readonly IList<Pair<byte[], Guid>> ImageCache


References Field

References Field
Namespaces ► Sitecore.Install.BlobData ► BlobInstallerContext ► References
Links to blobs, from the items that have been installed
Declaration Syntax
C#
public readonly IList<BlobLink> References


BlobLink Class

BlobLink Class
Namespaces ► Sitecore.Install.BlobData ► BlobLink
Link to a blob
Declaration Syntax
C#
public class BlobLink
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BlobLink(Field) | Initializes a new instance of the BlobLink class.
 | BlobLink(String, Guid) | Initializes a new instance of the BlobLink class.
 | DatabaseName | Gets the name of the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Guid | Gets the GUID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BlobLink


BlobLink Constructor

BlobLink Constructor
Namespaces ► Sitecore.Install.BlobData ► BlobLink ► BlobLink()()()
Members
Icon | Member | Description
 | BlobLink(Field) | Initializes a new instance of the BlobLink class.
 | BlobLink(String, Guid) | Initializes a new instance of the BlobLink class.


BlobLink Constructor (field)

BlobLink Constructor (field)
Namespaces ► Sitecore.Install.BlobData ► BlobLink ► BlobLink(Field)
Initializes a new instance of the BlobLink class.
Declaration Syntax
C#
public BlobLink(
    Field field
)
Parameters
field (Field)
The field.


BlobLink Constructor (databaseName, guid)

BlobLink Constructor (databaseName, guid)
Namespaces ► Sitecore.Install.BlobData ► BlobLink ► BlobLink(String, Guid)
Initializes a new instance of the BlobLink class.
Declaration Syntax
C#
public BlobLink(
    string databaseName,
    Guid guid
)
Parameters
databaseName (String)
Name of the database.
guid (Guid)
The GUID.


DatabaseName Property

DatabaseName Property
Namespaces ► Sitecore.Install.BlobData ► BlobLink ► DatabaseName
Gets the name of the database.
Declaration Syntax
C#
public string DatabaseName { get; }
Value
The name of the database.


Guid Property

Guid Property
Namespaces ► Sitecore.Install.BlobData ► BlobLink ► Guid
Gets the GUID.
Declaration Syntax
C#
public Guid Guid { get; }
Value
The GUID.


FileReference Class

FileReference Class
Namespaces ► Sitecore.Install.BlobData ► FileReference
Represents a reference to a file from media item
Declaration Syntax
C#
public class FileReference
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileReference(ItemReference, ID, String) | Initializes a new instance of the FileReference class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldID |
 | FileName |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemReference |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FileReference


FileReference Constructor (itemReference, fieldId, fileName)

FileReference Constructor (itemReference, fieldId, fileName)
Namespaces ► Sitecore.Install.BlobData ► FileReference ► FileReference(ItemReference, ID, String)
Initializes a new instance of the FileReference class.
Declaration Syntax
C#
public FileReference(
    ItemReference itemReference,
    ID fieldId,
    string fileName
)
Parameters
itemReference (ItemReference)
The item reference.
fieldId (ID)
The field id.
fileName (String)
Name of the file.


FieldID Field

FieldID Field
Namespaces ► Sitecore.Install.BlobData ► FileReference ► FieldID
Declaration Syntax
C#
public readonly ID FieldID


FileName Field

FileName Field
Namespaces ► Sitecore.Install.BlobData ► FileReference ► FileName
Declaration Syntax
C#
public readonly string FileName


ItemReference Field

ItemReference Field
Namespaces ► Sitecore.Install.BlobData ► FileReference ► ItemReference
Declaration Syntax
C#
public readonly ItemReference ItemReference


MediaStreamEntryData Class

MediaStreamEntryData Class
Namespaces ► Sitecore.Install.BlobData ► MediaStreamEntryData
MediaStreamEntryData class
Declaration Syntax
C#
public class MediaStreamEntryData : IEntryData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaStreamEntryData(MediaStreamLink) | Initializes a new instance of the MediaStreamEntryData class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStream()()() | Gets the stream holder.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MediaStreamEntryData


MediaStreamEntryData Constructor (link)

MediaStreamEntryData Constructor (link)
Namespaces ► Sitecore.Install.BlobData ► MediaStreamEntryData ► MediaStreamEntryData(MediaStreamLink)
Initializes a new instance of the MediaStreamEntryData class.
Declaration Syntax
C#
public MediaStreamEntryData(
    MediaStreamLink link
)
Parameters
link (MediaStreamLink)
The link.


GetStream Method

GetStream Method
Namespaces ► Sitecore.Install.BlobData ► MediaStreamEntryData ► GetStream()()()
Gets the stream holder.
Declaration Syntax
C#
public IStreamHolder GetStream()
Return Value
The stream holder.


Key Property

Key Property
Namespaces ► Sitecore.Install.BlobData ► MediaStreamEntryData ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


MediaStreamLink Class

MediaStreamLink Class
Namespaces ► Sitecore.Install.BlobData ► MediaStreamLink
MediaStreamLink class
Declaration Syntax
C#
public class MediaStreamLink
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaStreamLink(Media, ID) | Initializes a new instance of the MediaStreamLink class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the id.
 | Media | Gets the media.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MediaStreamLink


MediaStreamLink Constructor (media, id)

MediaStreamLink Constructor (media, id)
Namespaces ► Sitecore.Install.BlobData ► MediaStreamLink ► MediaStreamLink(Media, ID)
Initializes a new instance of the MediaStreamLink class.
Declaration Syntax
C#
public MediaStreamLink(
    Media media,
    ID id
)
Parameters
media (Media)
The media.
id (ID)
The id.


Id Property

Id Property
Namespaces ► Sitecore.Install.BlobData ► MediaStreamLink ► Id
Gets the id.
Declaration Syntax
C#
public ID Id { get; }
Value
The id.


Media Property

Media Property
Namespaces ► Sitecore.Install.BlobData ► MediaStreamLink ► Media
Gets the media.
Declaration Syntax
C#
public Media Media { get; }
Value
The media.


Sitecore.Install.Configuration Namespace

Sitecore.Install.Configuration Namespace
Namespaces ► Sitecore.Install.Configuration
Declaration Syntax
C#
namespace Sitecore.Install.Configuration
Types
All Types Classes
Icon | Type | Description
 | InstallerConfigurationTransform | Processor that adds a behaviour options to a package entry
 | InstallerObjectFactory | Installer object factory


InstallerConfigurationTransform Class

InstallerConfigurationTransform Class
Namespaces ► Sitecore.Install.Configuration ► InstallerConfigurationTransform
Processor that adds a behaviour options to a package entry
Declaration Syntax
C#
public class InstallerConfigurationTransform : IProcessor<PackageEntry>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstallerConfigurationTransform()()() | Initializes a new instance of the InstallerConfigurationTransform class.
 | InstallerConfigurationTransform(BehaviourOptions) | Initializes a new instance of the InstallerConfigurationTransform class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Options | Gets or sets the options.
 | Process(PackageEntry, IProcessingContext) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InstallerConfigurationTransform


InstallerConfigurationTransform Constructor

InstallerConfigurationTransform Constructor
Namespaces ► Sitecore.Install.Configuration ► InstallerConfigurationTransform ► InstallerConfigurationTransform()()()
Members
Icon | Member | Description
 | InstallerConfigurationTransform()()() | Initializes a new instance of the InstallerConfigurationTransform class.
 | InstallerConfigurationTransform(BehaviourOptions) | Initializes a new instance of the InstallerConfigurationTransform class.


InstallerConfigurationTransform Constructor

InstallerConfigurationTransform Constructor
Namespaces ► Sitecore.Install.Configuration ► InstallerConfigurationTransform ► InstallerConfigurationTransform()()()
Initializes a new instance of the InstallerConfigurationTransform class.
Declaration Syntax
C#
public InstallerConfigurationTransform()


InstallerConfigurationTransform Constructor (options)

InstallerConfigurationTransform Constructor (options)
Namespaces ► Sitecore.Install.Configuration ► InstallerConfigurationTransform ► InstallerConfigurationTransform(BehaviourOptions)
Initializes a new instance of the InstallerConfigurationTransform class.
Declaration Syntax
C#
public InstallerConfigurationTransform(
    BehaviourOptions options
)
Parameters
options (BehaviourOptions)
The options.


Options Property

Options Property
Namespaces ► Sitecore.Install.Configuration ► InstallerConfigurationTransform ► Options
Gets or sets the options.
Declaration Syntax
C#
public BehaviourOptions Options { get; set; }
Value
The options.


Process Method (entry, context)

Process Method (entry, context)
Namespaces ► Sitecore.Install.Configuration ► InstallerConfigurationTransform ► Process(PackageEntry, IProcessingContext)
Runs the processor.
Declaration Syntax
C#
public void Process(
    PackageEntry entry,
    IProcessingContext context
)
Parameters
entry (PackageEntry)
The entry.
context (IProcessingContext)
The processing context.


InstallerObjectFactory Class

InstallerObjectFactory Class
Namespaces ► Sitecore.Install.Configuration ► InstallerObjectFactory
Installer object factory
Declaration Syntax
C#
public class InstallerObjectFactory : IObjectFactory
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute(Type, String) | Gets the attribute.
 | GetAttributes(Type) | Gets the attributes.
 | GetElementName(Object) | Gets the name of the element by an instance
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType(String) | Gets the type by an element.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance | Gets the instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InstallerObjectFactory


GetAttribute Method (type, key)

GetAttribute Method (type, key)
Namespaces ► Sitecore.Install.Configuration ► InstallerObjectFactory ► GetAttribute(Type, String)
Gets the attribute.
Declaration Syntax
C#
public string GetAttribute(
    Type type,
    string key
)
Parameters
type (Type)
The type.
key (String)
The key.
Return Value
The attribute.


GetAttributes Method (type)

GetAttributes Method (type)
Namespaces ► Sitecore.Install.Configuration ► InstallerObjectFactory ► GetAttributes(Type)
Gets the attributes.
Declaration Syntax
C#
public IDictionary<string, string> GetAttributes(
    Type type
)
Parameters
type (Type)
The type.
Return Value
The attributes.


GetElementName Method (object)

GetElementName Method (object)
Namespaces ► Sitecore.Install.Configuration ► InstallerObjectFactory ► GetElementName(Object)
Gets the name of the element by an instance
Declaration Syntax
C#
public string GetElementName(
    Object object
)
Parameters
object (Object)
Instance of type
Return Value


GetType Method (element)

GetType Method (element)
Namespaces ► Sitecore.Install.Configuration ► InstallerObjectFactory ► GetType(String)
Gets the type by an element.
Declaration Syntax
C#
public Type GetType(
    string element
)
Parameters
element (String)
The element name
Return Value
The type


Instance Property

Instance Property
Namespaces ► Sitecore.Install.Configuration ► InstallerObjectFactory ► Instance
Gets the instance.
Declaration Syntax
C#
public static InstallerObjectFactory Instance { get; }
Value
The instance.


Sitecore.Install.Files Namespace

Sitecore.Install.Files Namespace
Namespaces ► Sitecore.Install.Files
Declaration Syntax
C#
namespace Sitecore.Install.Files
Types
All Types Classes Interfaces
Icon | Type | Description
 | ExplicitFileSystemSource..::.Builder | Builds the ExplicitFileSystemSource object
 | ExplicitFileSource..::.Builder | Builder for ExplicitFileSource
 | DefaultFileInstallerEvents | Default implementation of IFileInstallerEvents
 | DirectoryEntryData | Directory entry data
 | ExplicitFileSource | FileInfo source that accepts Sitecore virtual paths
 | ExplicitFileSystemSource | FileInfo source that accepts raw filesystem paths
 | FileCopyInfo | Information about a file copying
 | FileEntryData | Entry that represents a file
 | FileInstaller | Installs files from package entries
 | FileInstallerContext | File installer context
 | FileSource | FileInfo dynamic source that accepts virtual paths
 | FileSystemSource | File system source. Get all files from the Root property and populates a sink whis FileSystemInfo
 | FileToEntryConverter | File to entry converter
 | IFileInstallerEvents | Defines basic file installer events
 | MappedFileProvider | Mapped file provider
 | PathUtils | Path utils
 | RawFileSystemWriter | Installs files from package entries
 | RawFileToEntryConverter | Represents a convertor from file to package entry


DefaultFileInstallerEvents Class

DefaultFileInstallerEvents Class
Namespaces ► Sitecore.Install.Files ► DefaultFileInstallerEvents
Default implementation of IFileInstallerEvents
Declaration Syntax
C#
public class DefaultFileInstallerEvents : IFileInstallerEvents
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DefaultFileInstallerEvents(Boolean) | Initializes a new instance of the DefaultFileInstallerEvents class.
 | BeforeCommit()()() | Event fired before starting the process of actually installing files to their locations in the site.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RequestOverwrite(String, IProcessingContext) | Requests calling party for overwrite event
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DefaultFileInstallerEvents


DefaultFileInstallerEvents Constructor (overwrite)

DefaultFileInstallerEvents Constructor (overwrite)
Namespaces ► Sitecore.Install.Files ► DefaultFileInstallerEvents ► DefaultFileInstallerEvents(Boolean)
Initializes a new instance of the DefaultFileInstallerEvents class.
Declaration Syntax
C#
public DefaultFileInstallerEvents(
    bool overwrite
)
Parameters
overwrite (Boolean)
if set to true the all items will be overwritten during the installation.


BeforeCommit Method

BeforeCommit Method
Namespaces ► Sitecore.Install.Files ► DefaultFileInstallerEvents ► BeforeCommit()()()
Event fired before starting the process of actually installing files to their locations in the site.
Declaration Syntax
C#
public void BeforeCommit()


RequestOverwrite Method (virtualPath, context)

RequestOverwrite Method (virtualPath, context)
Namespaces ► Sitecore.Install.Files ► DefaultFileInstallerEvents ► RequestOverwrite(String, IProcessingContext)
Requests calling party for overwrite event
Declaration Syntax
C#
public virtual Pair<bool, bool> RequestOverwrite(
    string virtualPath,
    IProcessingContext context
)
Parameters
virtualPath (String)
File path which is subject of request
context (IProcessingContext)
Processing context
Return Value
A pair of bools:
  • First: Whether overwrite is allowed or not
  • Second: Whether decision should be applied to all subsequent files


DirectoryEntryData Class

DirectoryEntryData Class
Namespaces ► Sitecore.Install.Files ► DirectoryEntryData
Directory entry data
Declaration Syntax
C#
public class DirectoryEntryData : IEntryData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DirectoryEntryData(String) | Initializes a new instance of the DirectoryEntryData class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStream()()() | Gets the stream holder.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DirectoryEntryData


DirectoryEntryData Constructor (path)

DirectoryEntryData Constructor (path)
Namespaces ► Sitecore.Install.Files ► DirectoryEntryData ► DirectoryEntryData(String)
Initializes a new instance of the DirectoryEntryData class.
Declaration Syntax
C#
public DirectoryEntryData(
    string path
)
Parameters
path (String)
The path.


GetStream Method

GetStream Method
Namespaces ► Sitecore.Install.Files ► DirectoryEntryData ► GetStream()()()
Gets the stream holder.
Declaration Syntax
C#
public IStreamHolder GetStream()
Return Value
The stream holder.


Key Property

Key Property
Namespaces ► Sitecore.Install.Files ► DirectoryEntryData ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


ExplicitFileSource Class

ExplicitFileSource Class
Namespaces ► Sitecore.Install.Files ► ExplicitFileSource
FileInfo source that accepts Sitecore virtual paths
Declaration Syntax
C#
public class ExplicitFileSource : ExplicitFileSystemSource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExplicitFileSource()()() | Initializes a new instance of the ExplicitFileSource class.
 | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(T>)>).)
 | Entries | Gets the entries. (Inherited from ExplicitFileSystemSource.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetList()()() | Gets the list of paths. (Inherited from ExplicitFileSystemSource.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Include | Gets the include filters. (Inherited from BaseSource<(Of <(T>)>).)
 | InternalPopulate(ISink<(Of <(FileSystemInfo>)>)) | Converts the list of the pathes to the FileSystemInfo objects and populates the sink with it (Inherited from ExplicitFileSystemSource.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(T>)>).)
 | Populate(ISink<(Of <(PackageEntry>)>)) | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(T>)>).)
 | ResolveKey(String) | Resolves the key. (Inherited from ExplicitFileSystemSource.)
 | ResolvePath(String) | Resolves the path. (Overrides ExplicitFileSystemSource.ResolvePath(String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSource <(Of <(FileSystemInfo>)>)
 |  | ExplicitFileSystemSource
 |  |  | ExplicitFileSource


ExplicitFileSource Constructor

ExplicitFileSource Constructor
Namespaces ► Sitecore.Install.Files ► ExplicitFileSource ► ExplicitFileSource()()()
Initializes a new instance of the ExplicitFileSource class.
Declaration Syntax
C#
public ExplicitFileSource()


ResolvePath Method (path)

ResolvePath Method (path)
Namespaces ► Sitecore.Install.Files ► ExplicitFileSource ► ResolvePath(String)
Resolves the path.
Declaration Syntax
C#
protected override string ResolvePath(
    string path
)
Parameters
path (String)
The path.
Return Value
The path.


ExplicitFileSource.Builder Class

ExplicitFileSource..::.Builder Class
Namespaces ► Sitecore.Install.Files ► ExplicitFileSource ► ExplicitFileSource..::.Builder
Builder for ExplicitFileSource
Declaration Syntax
C#
public class Builder : ExplicitFileSystemSource..::.Builder
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExplicitFileSource..::.Builder()()() | Initializes a new instance of the ExplicitFileSource..::.Builder class.
 | ExplicitFileSource..::.Builder(ExplicitFileSource) | Initializes a new instance of the ExplicitFileSource..::.Builder class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Inherited from BaseSink<(Of <(T>)>).)
 | Flush()()() | Flushes the sink (Inherited from BaseSink<(Of <(T>)>).)
 | GetDefaultRoot()()() | Gets the default root. (Overrides ExplicitFileSystemSource..::.Builder.GetDefaultRoot()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | Puts the specified entry. (Inherited from ExplicitFileSystemSource..::.Builder.)
 | Root | Gets or sets the root. (Inherited from ExplicitFileSystemSource..::.Builder.)
 | Source | Gets the source.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( PackageEntry >)>)
 |  | ExplicitFileSystemSource..::.Builder
 |  |  | ExplicitFileSource..::.Builder


ExplicitFileSource.Builder Constructor

ExplicitFileSource..::.Builder Constructor
Namespaces ► Sitecore.Install.Files ► ExplicitFileSource..::.Builder ► ExplicitFileSource..::.Builder()()()
Members
Icon | Member | Description
 | ExplicitFileSource..::.Builder()()() | Initializes a new instance of the ExplicitFileSource..::.Builder class.
 | ExplicitFileSource..::.Builder(ExplicitFileSource) | Initializes a new instance of the ExplicitFileSource..::.Builder class.


ExplicitFileSource.Builder Constructor

ExplicitFileSource..::.Builder Constructor
Namespaces ► Sitecore.Install.Files ► ExplicitFileSource..::.Builder ► ExplicitFileSource..::.Builder()()()
Initializes a new instance of the ExplicitFileSource..::.Builder class.
Declaration Syntax
C#
public Builder()


ExplicitFileSource.Builder Constructor (source)

ExplicitFileSource..::.Builder Constructor (source)
Namespaces ► Sitecore.Install.Files ► ExplicitFileSource..::.Builder ► ExplicitFileSource..::.Builder(ExplicitFileSource)
Initializes a new instance of the ExplicitFileSource..::.Builder class.
Declaration Syntax
C#
public Builder(
    ExplicitFileSource source
)
Parameters
source (ExplicitFileSource)
The source.


GetDefaultRoot Method

GetDefaultRoot Method
Namespaces ► Sitecore.Install.Files ► ExplicitFileSource..::.Builder ► GetDefaultRoot()()()
Gets the default root.
Declaration Syntax
C#
protected override string GetDefaultRoot()
Return Value
The default root.


Source Property

Source Property
Namespaces ► Sitecore.Install.Files ► ExplicitFileSource..::.Builder ► Source
Gets the source.
Declaration Syntax
C#
public ExplicitFileSource Source { get; }
Value
The source.


ExplicitFileSystemSource Class

ExplicitFileSystemSource Class
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource
FileInfo source that accepts raw filesystem paths
Declaration Syntax
C#
public class ExplicitFileSystemSource : BaseSource<FileSystemInfo>,
    IExplicitSource, IKeyResolver
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExplicitFileSystemSource()()() | Initializes a new instance of the ExplicitFileSystemSource class.
 | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(T>)>).)
 | Entries | Gets the entries.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetList()()() | Gets the list of paths.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Include | Gets the include filters. (Inherited from BaseSource<(Of <(T>)>).)
 | InternalPopulate(ISink<(Of <(FileSystemInfo>)>)) | Converts the list of the pathes to the FileSystemInfo objects and populates the sink with it (Overrides BaseSource <(Of <(FileSystemInfo>)>).InternalPopulate(ISink<(Of <(T>)>)).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(T>)>).)
 | Populate(ISink<(Of <(PackageEntry>)>)) | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(T>)>).)
 | ResolveKey(String) | Resolves the key.
 | ResolvePath(String) | Resolves the path.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSource <(Of <(FileSystemInfo>)>)
 |  | ExplicitFileSystemSource
 |  |  | ExplicitFileSource


ExplicitFileSystemSource Constructor

ExplicitFileSystemSource Constructor
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource ► ExplicitFileSystemSource()()()
Initializes a new instance of the ExplicitFileSystemSource class.
Declaration Syntax
C#
public ExplicitFileSystemSource()


Entries Property

Entries Property
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource ► Entries
Gets the entries.
Declaration Syntax
C#
public IList<string> Entries { get; }
Value
The entries.


GetList Method

GetList Method
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource ► GetList()()()
Gets the list of paths.
Declaration Syntax
C#
public IList<string> GetList()
Return Value
The list.


InternalPopulate Method (sink)

InternalPopulate Method (sink)
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource ► InternalPopulate(ISink<(Of <(FileSystemInfo>)>))
Converts the list of the pathes to the FileSystemInfo objects and populates the sink with it
Declaration Syntax
C#
protected override void InternalPopulate(
    ISink<FileSystemInfo> sink
)
Parameters
sink (ISink <(Of <(FileSystemInfo>)>))
The sink


ResolveKey Method (key)

ResolveKey Method (key)
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource ► ResolveKey(String)
Resolves the key.
Declaration Syntax
C#
public Object ResolveKey(
    string key
)
Parameters
key (String)
The key.
Return Value
The object.


ResolvePath Method (path)

ResolvePath Method (path)
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource ► ResolvePath(String)
Resolves the path.
Declaration Syntax
C#
protected virtual string ResolvePath(
    string path
)
Parameters
path (String)
The path.
Return Value
The path.


ExplicitFileSystemSource.Builder Class

ExplicitFileSystemSource..::.Builder Class
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource ► ExplicitFileSystemSource..::.Builder
Builds the ExplicitFileSystemSource object
Declaration Syntax
C#
public class Builder : BaseSink<PackageEntry>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExplicitFileSystemSource..::.Builder()()() | Initializes a new instance of the ExplicitFileSystemSource..::.Builder class.
 | ExplicitFileSystemSource..::.Builder(ExplicitFileSystemSource) | Initializes a new instance of the ExplicitFileSystemSource..::.Builder class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Inherited from BaseSink<(Of <(T>)>).)
 | Flush()()() | Flushes the sink (Inherited from BaseSink<(Of <(T>)>).)
 | GetDefaultRoot()()() | Gets the default root.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | Puts the specified entry. (Overrides BaseSink <(Of <( PackageEntry >)>).Put(T).)
 | Root | Gets or sets the root.
 | Source | Gets the source.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( PackageEntry >)>)
 |  | ExplicitFileSystemSource..::.Builder
 |  |  | ExplicitFileSource..::.Builder


ExplicitFileSystemSource.Builder Constructor

ExplicitFileSystemSource..::.Builder Constructor
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource..::.Builder ► ExplicitFileSystemSource..::.Builder()()()
Members
Icon | Member | Description
 | ExplicitFileSystemSource..::.Builder()()() | Initializes a new instance of the ExplicitFileSystemSource..::.Builder class.
 | ExplicitFileSystemSource..::.Builder(ExplicitFileSystemSource) | Initializes a new instance of the ExplicitFileSystemSource..::.Builder class.


ExplicitFileSystemSource.Builder Constructor

ExplicitFileSystemSource..::.Builder Constructor
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource..::.Builder ► ExplicitFileSystemSource..::.Builder()()()
Initializes a new instance of the ExplicitFileSystemSource..::.Builder class.
Declaration Syntax
C#
public Builder()


ExplicitFileSystemSource.Builder Constructor (source)

ExplicitFileSystemSource..::.Builder Constructor (source)
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource..::.Builder ► ExplicitFileSystemSource..::.Builder(ExplicitFileSystemSource)
Initializes a new instance of the ExplicitFileSystemSource..::.Builder class.
Declaration Syntax
C#
public Builder(
    ExplicitFileSystemSource source
)
Parameters
source (ExplicitFileSystemSource)
The source.


GetDefaultRoot Method

GetDefaultRoot Method
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource..::.Builder ► GetDefaultRoot()()()
Gets the default root.
Declaration Syntax
C#
protected virtual string GetDefaultRoot()
Return Value
The default root.


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource..::.Builder ► Put(PackageEntry)
Puts the specified entry.
Declaration Syntax
C#
public override void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


Root Property

Root Property
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource..::.Builder ► Root
Gets or sets the root.
Declaration Syntax
C#
public string Root { get; set; }
Value
The root.


Source Property

Source Property
Namespaces ► Sitecore.Install.Files ► ExplicitFileSystemSource..::.Builder ► Source
Gets the source.
Declaration Syntax
C#
public ExplicitFileSystemSource Source { get; }
Value
The source.


FileCopyInfo Class

FileCopyInfo Class
Namespaces ► Sitecore.Install.Files ► FileCopyInfo
Information about a file copying
Declaration Syntax
C#
public class FileCopyInfo
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileCopyInfo(String, String) | Initializes a new instance of the FileCopyInfo class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SourcePath |
 | TargetPath |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FileCopyInfo


FileCopyInfo Constructor (sourcePath, targetPath)

FileCopyInfo Constructor (sourcePath, targetPath)
Namespaces ► Sitecore.Install.Files ► FileCopyInfo ► FileCopyInfo(String, String)
Initializes a new instance of the FileCopyInfo class.
Declaration Syntax
C#
public FileCopyInfo(
    string sourcePath,
    string targetPath
)
Parameters
sourcePath (String)
The source path.
targetPath (String)
The target path.


SourcePath Field

SourcePath Field
Namespaces ► Sitecore.Install.Files ► FileCopyInfo ► SourcePath
Declaration Syntax
C#
public readonly string SourcePath


TargetPath Field

TargetPath Field
Namespaces ► Sitecore.Install.Files ► FileCopyInfo ► TargetPath
Declaration Syntax
C#
public readonly string TargetPath


FileEntryData Class

FileEntryData Class
Namespaces ► Sitecore.Install.Files ► FileEntryData
Entry that represents a file
Declaration Syntax
C#
public class FileEntryData : IEntryData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileEntryData(String, FileInfo) | Initializes a new instance of the FileEntryData class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKey(String) | Gets the key.
 | GetStream()()() | Gets the stream holder.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FileEntryData


FileEntryData Constructor (path, info)

FileEntryData Constructor (path, info)
Namespaces ► Sitecore.Install.Files ► FileEntryData ► FileEntryData(String, FileInfo)
Initializes a new instance of the FileEntryData class.
Declaration Syntax
C#
public FileEntryData(
    string path,
    FileInfo info
)
Parameters
path (String)
The file path.
info (FileInfo)
The file info.


GetKey Method (path)

GetKey Method (path)
Namespaces ► Sitecore.Install.Files ► FileEntryData ► GetKey(String)
Gets the key.
Declaration Syntax
C#
public static string GetKey(
    string path
)
Parameters
path (String)
The file path.
Return Value
The key.


GetStream Method

GetStream Method
Namespaces ► Sitecore.Install.Files ► FileEntryData ► GetStream()()()
Gets the stream holder.
Declaration Syntax
C#
public IStreamHolder GetStream()
Return Value
The stream holder.


Key Property

Key Property
Namespaces ► Sitecore.Install.Files ► FileEntryData ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


FileInstaller Class

FileInstaller Class
Namespaces ► Sitecore.Install.Files ► FileInstaller
Installs files from package entries
Declaration Syntax
C#
public sealed class FileInstaller : AdvancedBaseSink<PackageEntry, FileInstallerContext>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileInstaller(IProcessingContext) | Initializes a new instance of the FileInstaller class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Context | Gets the context. (Inherited from AdvancedBaseSink<(Of <(T, ContextType>)>).)
 | CreateContext()()() | Creates the context. (Inherited from AdvancedBaseSink<(Of <(T, ContextType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Overrides BaseSink <(Of <( T >)>).Finish()()().)
 | Flush()()() | Flushes the sink (Inherited from BaseSink<(Of <(T>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStatusFileName(String) | Gets the name of the status file for file installer and its background worker.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from AdvancedBaseSink<(Of <(T, ContextType>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | If an entry contains file or directory it will be installed.
 | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(T>)>).)
 | SetupContext(ContextType) | Setups the context. (Inherited from AdvancedBaseSink<(Of <(T, ContextType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( T >)>)
 |  | AdvancedBaseSink <(Of <( PackageEntry, FileInstallerContext >)>)
 |  |  | FileInstaller


FileInstaller Constructor (processingContext)

FileInstaller Constructor (processingContext)
Namespaces ► Sitecore.Install.Files ► FileInstaller ► FileInstaller(IProcessingContext)
Initializes a new instance of the FileInstaller class.
Declaration Syntax
C#
public FileInstaller(
    IProcessingContext processingContext
)
Parameters
processingContext (IProcessingContext)
The processing context.


Finish Method

Finish Method
Namespaces ► Sitecore.Install.Files ► FileInstaller ► Finish()()()
Finishes the sink.
Declaration Syntax
C#
public override void Finish()


GetStatusFileName Method (taskID)

GetStatusFileName Method (taskID)
Namespaces ► Sitecore.Install.Files ► FileInstaller ► GetStatusFileName(String)
Gets the name of the status file for file installer and its background worker.
Declaration Syntax
C#
public static string GetStatusFileName(
    string taskID
)
Parameters
taskID (String)
The task ID.
Return Value
The status file name.


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Files ► FileInstaller ► Put(PackageEntry)
If an entry contains file or directory it will be installed.
Declaration Syntax
C#
public virtual void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


FileInstallerContext Class

FileInstallerContext Class
Namespaces ► Sitecore.Install.Files ► FileInstallerContext
File installer context
Declaration Syntax
C#
public class FileInstallerContext
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileInstallerContext(IFileInstallerEvents) | Initializes a new instance of the FileInstallerContext class.
 | ApplyToAll |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events |
 | FileInstallerContextKey |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Overwrite | Defines whether files should be overwritten when collision
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transaction |
Inheritance Hierarchy
Object
FileInstallerContext


FileInstallerContext Constructor (events)

FileInstallerContext Constructor (events)
Namespaces ► Sitecore.Install.Files ► FileInstallerContext ► FileInstallerContext(IFileInstallerEvents)
Initializes a new instance of the FileInstallerContext class.
Declaration Syntax
C#
public FileInstallerContext(
    IFileInstallerEvents events
)
Parameters
events (IFileInstallerEvents)
The events.


ApplyToAll Field

ApplyToAll Field
Namespaces ► Sitecore.Install.Files ► FileInstallerContext ► ApplyToAll
Declaration Syntax
C#
public bool ApplyToAll


Events Field

Events Field
Namespaces ► Sitecore.Install.Files ► FileInstallerContext ► Events
Declaration Syntax
C#
public readonly IFileInstallerEvents Events


FileInstallerContextKey Field

FileInstallerContextKey Field
Namespaces ► Sitecore.Install.Files ► FileInstallerContext ► FileInstallerContextKey
Declaration Syntax
C#
public static readonly string FileInstallerContextKey


Overwrite Field

Overwrite Field
Namespaces ► Sitecore.Install.Files ► FileInstallerContext ► Overwrite
Defines whether files should be overwritten when collision
Declaration Syntax
C#
public bool Overwrite


Transaction Field

Transaction Field
Namespaces ► Sitecore.Install.Files ► FileInstallerContext ► Transaction
Declaration Syntax
C#
public List<FileCopyInfo> Transaction


FileSource Class

FileSource Class
Namespaces ► Sitecore.Install.Files ► FileSource
FileInfo dynamic source that accepts virtual paths
Declaration Syntax
C#
public class FileSource : FileSystemSource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileSource()()() | Initializes a new instance of the FileSource class
 | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Include | Gets the include filters. (Inherited from BaseSource<(Of <(T>)>).)
 | InternalPopulate(ISink<(Of <(FileSystemInfo>)>)) | Puts a file or a directory to the sink. (Inherited from FileSystemSource.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(T>)>).)
 | Populate(ISink<(Of <(PackageEntry>)>)) | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(T>)>).)
 | ResolvePath(String) | Resolves the path. (Overrides FileSystemSource.ResolvePath(String).)
 | Root | Gets or sets the root. (Inherited from FileSystemSource.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSource <(Of <(FileSystemInfo>)>)
 |  | FileSystemSource
 |  |  | FileSource


FileSource Constructor

FileSource Constructor
Namespaces ► Sitecore.Install.Files ► FileSource ► FileSource()()()
Initializes a new instance of the FileSource class
Declaration Syntax
C#
public FileSource()


ResolvePath Method (path)

ResolvePath Method (path)
Namespaces ► Sitecore.Install.Files ► FileSource ► ResolvePath(String)
Resolves the path.
Declaration Syntax
C#
protected override string ResolvePath(
    string path
)
Parameters
path (String)
The path.
Return Value
The path.


FileSystemSource Class

FileSystemSource Class
Namespaces ► Sitecore.Install.Files ► FileSystemSource
File system source. Get all files from the Root property and populates a sink whis FileSystemInfo
Declaration Syntax
C#
public class FileSystemSource : BaseSource<FileSystemInfo>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileSystemSource()()() | Initializes a new instance of the FileSystemSource class.
 | FileSystemSource(String) | Initializes a new instance of the FileSystemSource class.
 | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Include | Gets the include filters. (Inherited from BaseSource<(Of <(T>)>).)
 | InternalPopulate(ISink<(Of <(FileSystemInfo>)>)) | Puts a file or a directory to the sink. (Overrides BaseSource <(Of <(FileSystemInfo>)>).InternalPopulate(ISink<(Of <(T>)>)).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(T>)>).)
 | Populate(ISink<(Of <(PackageEntry>)>)) | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(T>)>).)
 | ResolvePath(String) | Resolves the path.
 | Root | Gets or sets the root.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSource <(Of <(FileSystemInfo>)>)
 |  | FileSystemSource
 |  |  | FileSource


FileSystemSource Constructor

FileSystemSource Constructor
Namespaces ► Sitecore.Install.Files ► FileSystemSource ► FileSystemSource()()()
Members
Icon | Member | Description
 | FileSystemSource()()() | Initializes a new instance of the FileSystemSource class.
 | FileSystemSource(String) | Initializes a new instance of the FileSystemSource class.


FileSystemSource Constructor

FileSystemSource Constructor
Namespaces ► Sitecore.Install.Files ► FileSystemSource ► FileSystemSource()()()
Initializes a new instance of the FileSystemSource class.
Declaration Syntax
C#
public FileSystemSource()


FileSystemSource Constructor (root)

FileSystemSource Constructor (root)
Namespaces ► Sitecore.Install.Files ► FileSystemSource ► FileSystemSource(String)
Initializes a new instance of the FileSystemSource class.
Declaration Syntax
C#
public FileSystemSource(
    string root
)
Parameters
root (String)
The root.


InternalPopulate Method (sink)

InternalPopulate Method (sink)
Namespaces ► Sitecore.Install.Files ► FileSystemSource ► InternalPopulate(ISink<(Of <(FileSystemInfo>)>))
Puts a file or a directory to the sink.
Declaration Syntax
C#
protected override void InternalPopulate(
    ISink<FileSystemInfo> sink
)
Parameters
sink (ISink <(Of <(FileSystemInfo>)>))
The sink


ResolvePath Method (path)

ResolvePath Method (path)
Namespaces ► Sitecore.Install.Files ► FileSystemSource ► ResolvePath(String)
Resolves the path.
Declaration Syntax
C#
protected virtual string ResolvePath(
    string path
)
Parameters
path (String)
The path.
Return Value
The path.


Root Property

Root Property
Namespaces ► Sitecore.Install.Files ► FileSystemSource ► Root
Gets or sets the root.
Declaration Syntax
C#
public string Root { get; set; }
Value
The root.


FileToEntryConverter Class

FileToEntryConverter Class
Namespaces ► Sitecore.Install.Files ► FileToEntryConverter
File to entry converter
Declaration Syntax
C#
public class FileToEntryConverter : RawFileToEntryConverter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApplyTransforms(PackageEntry, IProcessingContext) | (Inherited from .)
 | FileToEntryConverter()()() | Initializes a new instance of the FileToEntryConverter class.
 | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform. Applies the transform. (Inherited from BaseConverter<(Of <(T>)>).)
 | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(T>)>) converter transforms should be applied by BaseConverter, not the derived class. (Inherited from BaseConverter<(Of <(T>)>).)
 | Convert(T, IProcessingContext) | Converts the specified entry. (Inherited from BaseConverter<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute(String) | Gets the value of the attribute. (Inherited from BaseConverter<(Of <(T>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InternalConvert(FileSystemInfo, IProcessingContext) | Converts a file into package entry. (Inherited from RawFileToEntryConverter.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReducePath(String) | Reduces the path. (Inherited from RawFileToEntryConverter.)
 | ResolvePath(String) | Resolves the path. (Overrides RawFileToEntryConverter.ResolvePath(String).)
 | Root | Gets or sets the root. (Inherited from RawFileToEntryConverter.)
 | SetAttribute(String, Object) | Sets the value of the attribute. (Inherited from BaseConverter<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | BaseConverter <(Of <(FileSystemInfo>)>)
 |  | RawFileToEntryConverter
 |  |  | FileToEntryConverter


FileToEntryConverter Constructor

FileToEntryConverter Constructor
Namespaces ► Sitecore.Install.Files ► FileToEntryConverter ► FileToEntryConverter()()()
Initializes a new instance of the FileToEntryConverter class.
Declaration Syntax
C#
public FileToEntryConverter()


ResolvePath Method (path)

ResolvePath Method (path)
Namespaces ► Sitecore.Install.Files ► FileToEntryConverter ► ResolvePath(String)
Resolves the path.
Declaration Syntax
C#
protected override string ResolvePath(
    string path
)
Parameters
path (String)
The path.
Return Value
The resolved path.


IFileInstallerEvents Interface

IFileInstallerEvents Interface
Namespaces ► Sitecore.Install.Files ► IFileInstallerEvents
Defines basic file installer events
Declaration Syntax
C#
public interface IFileInstallerEvents
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BeforeCommit()()() | Event fired before starting the process of actually installing files to their locations in the site.
 | RequestOverwrite(String, IProcessingContext) | Requests calling party for overwrite event


BeforeCommit Method

BeforeCommit Method
Namespaces ► Sitecore.Install.Files ► IFileInstallerEvents ► BeforeCommit()()()
Event fired before starting the process of actually installing files to their locations in the site.
Declaration Syntax
C#
void BeforeCommit()


RequestOverwrite Method (virtualPath, context)

RequestOverwrite Method (virtualPath, context)
Namespaces ► Sitecore.Install.Files ► IFileInstallerEvents ► RequestOverwrite(String, IProcessingContext)
Requests calling party for overwrite event
Declaration Syntax
C#
Pair<bool, bool> RequestOverwrite(
    string virtualPath,
    IProcessingContext context
)
Parameters
virtualPath (String)
File path which is subject of request
context (IProcessingContext)
Processing context
Return Value
A pair of bools:
  • First: Whether overwrite is allowed or not
  • Second: Whether decision should be applied to all subsequent files


MappedFileProvider Class

MappedFileProvider Class
Namespaces ► Sitecore.Install.Files ► MappedFileProvider
Mapped file provider
Declaration Syntax
C#
public class MappedFileProvider : IStreamProvider
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MappedFileProvider()()() | Initializes a new instance of the MappedFileProvider class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStream(String) | Gets the stream from a file by file name.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MappedFileProvider


MappedFileProvider Constructor

MappedFileProvider Constructor
Namespaces ► Sitecore.Install.Files ► MappedFileProvider ► MappedFileProvider()()()
Initializes a new instance of the MappedFileProvider class
Declaration Syntax
C#
public MappedFileProvider()


GetStream Method (name)

GetStream Method (name)
Namespaces ► Sitecore.Install.Files ► MappedFileProvider ► GetStream(String)
Gets the stream from a file by file name.
Declaration Syntax
C#
public Stream GetStream(
    string name
)
Parameters
name (String)
File name.
Return Value
The stream.


PathUtils Class

PathUtils Class
Namespaces ► Sitecore.Install.Files ► PathUtils
Path utils
Declaration Syntax
C#
public static class PathUtils
Members
All Members | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DemangleDirectoryPath(String) | Demangles the directory path.
 | DirectorySuffix | Directory suffix
 | IsDirectoryPath(String) | Determines whether [is directory path] [the specified path].
 | MangleDirectoryPath(String) | Mangles the directory path.
 | MapPath(String) | Maps the path.
 | ReducePath(String, String) | Reduces the path.
 | SiteRoot | Gets the site root.
 | UnifyPath(String) | Unifies the path.
 | UnifyPathSeparators(String) | Unifies the path separators.
 | Unmap(String) | Unmaps the specified path.
Inheritance Hierarchy
Object
PathUtils


DemangleDirectoryPath Method (path)

DemangleDirectoryPath Method (path)
Namespaces ► Sitecore.Install.Files ► PathUtils ► DemangleDirectoryPath(String)
Demangles the directory path.
Declaration Syntax
C#
public static string DemangleDirectoryPath(
    string path
)
Parameters
path (String)
The path.
Return Value
The directory path.


DirectorySuffix Field

DirectorySuffix Field
Namespaces ► Sitecore.Install.Files ► PathUtils ► DirectorySuffix
Directory suffix
Declaration Syntax
C#
public static string DirectorySuffix


IsDirectoryPath Method (path)

IsDirectoryPath Method (path)
Namespaces ► Sitecore.Install.Files ► PathUtils ► IsDirectoryPath(String)
Determines whether [is directory path] [the specified path].
Declaration Syntax
C#
public static bool IsDirectoryPath(
    string path
)
Parameters
path (String)
The path.
Return Value
true if [is directory path] [the specified path]; otherwise, false.


MangleDirectoryPath Method (path)

MangleDirectoryPath Method (path)
Namespaces ► Sitecore.Install.Files ► PathUtils ► MangleDirectoryPath(String)
Mangles the directory path.
Declaration Syntax
C#
public static string MangleDirectoryPath(
    string path
)
Parameters
path (String)
The path.
Return Value
The directory path.


MapPath Method (path)

MapPath Method (path)
Namespaces ► Sitecore.Install.Files ► PathUtils ► MapPath(String)
Maps the path.
Declaration Syntax
C#
public static string MapPath(
    string path
)
Parameters
path (String)
The path.
Return Value
The path.


ReducePath Method (root, fullname)

ReducePath Method (root, fullname)
Namespaces ► Sitecore.Install.Files ► PathUtils ► ReducePath(String, String)
Reduces the path.
Declaration Syntax
C#
public static string ReducePath(
    string root,
    string fullname
)
Parameters
root (String)
The root.
fullname (String)
The fullname.
Return Value
The path.


SiteRoot Property

SiteRoot Property
Namespaces ► Sitecore.Install.Files ► PathUtils ► SiteRoot
Gets the site root.
Declaration Syntax
C#
public static string SiteRoot { get; }
Value
The site root.


UnifyPath Method (path)

UnifyPath Method (path)
Namespaces ► Sitecore.Install.Files ► PathUtils ► UnifyPath(String)
Unifies the path.
Declaration Syntax
C#
public static string UnifyPath(
    string path
)
Parameters
path (String)
The path.
Return Value
The path.


UnifyPathSeparators Method (path)

UnifyPathSeparators Method (path)
Namespaces ► Sitecore.Install.Files ► PathUtils ► UnifyPathSeparators(String)
Unifies the path separators.
Declaration Syntax
C#
public static string UnifyPathSeparators(
    string path
)
Parameters
path (String)
The path.
Return Value
The unified path.


Unmap Method (path)

Unmap Method (path)
Namespaces ► Sitecore.Install.Files ► PathUtils ► Unmap(String)
Unmaps the specified path.
Declaration Syntax
C#
public static string Unmap(
    string path
)
Parameters
path (String)
The path.
Return Value
The unmap.


RawFileSystemWriter Class

RawFileSystemWriter Class
Namespaces ► Sitecore.Install.Files ► RawFileSystemWriter
Installs files from package entries
Declaration Syntax
C#
public class RawFileSystemWriter : BaseSink<PackageEntry>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RawFileSystemWriter()()() | Initializes a new instance of the RawFileSystemWriter class.
 | RawFileSystemWriter(String) | Initializes a new instance of the RawFileSystemWriter class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Inherited from BaseSink<(Of <(T>)>).)
 | Flush()()() | Flushes the sink (Inherited from BaseSink<(Of <(T>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | Install a file from a package entry. (Overrides BaseSink <(Of <( PackageEntry >)>).Put(T).)
 | Root | Gets or sets the root.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( PackageEntry >)>)
 |  | RawFileSystemWriter


RawFileSystemWriter Constructor

RawFileSystemWriter Constructor
Namespaces ► Sitecore.Install.Files ► RawFileSystemWriter ► RawFileSystemWriter()()()
Members
Icon | Member | Description
 | RawFileSystemWriter()()() | Initializes a new instance of the RawFileSystemWriter class.
 | RawFileSystemWriter(String) | Initializes a new instance of the RawFileSystemWriter class.


RawFileSystemWriter Constructor

RawFileSystemWriter Constructor
Namespaces ► Sitecore.Install.Files ► RawFileSystemWriter ► RawFileSystemWriter()()()
Initializes a new instance of the RawFileSystemWriter class.
Declaration Syntax
C#
public RawFileSystemWriter()


RawFileSystemWriter Constructor (root)

RawFileSystemWriter Constructor (root)
Namespaces ► Sitecore.Install.Files ► RawFileSystemWriter ► RawFileSystemWriter(String)
Initializes a new instance of the RawFileSystemWriter class.
Declaration Syntax
C#
public RawFileSystemWriter(
    string root
)
Parameters
root (String)
The root.


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Files ► RawFileSystemWriter ► Put(PackageEntry)
Install a file from a package entry.
Declaration Syntax
C#
public override void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


Root Property

Root Property
Namespaces ► Sitecore.Install.Files ► RawFileSystemWriter ► Root
Gets or sets the root.
Declaration Syntax
C#
public string Root { get; set; }
Value
The root.


RawFileToEntryConverter Class

RawFileToEntryConverter Class
Namespaces ► Sitecore.Install.Files ► RawFileToEntryConverter
Represents a convertor from file to package entry
Declaration Syntax
C#
public class RawFileToEntryConverter : BaseConverter<FileSystemInfo>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApplyTransforms(PackageEntry, IProcessingContext) | (Inherited from .)
 | RawFileToEntryConverter()()() | Initializes a new instance of the RawFileToEntryConverter class.
 | RawFileToEntryConverter(String, String) | Initializes a new instance of the RawFileToEntryConverter class.
 | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform. Applies the transform. (Inherited from BaseConverter<(Of <(T>)>).)
 | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(T>)>) converter transforms should be applied by BaseConverter, not the derived class. (Inherited from BaseConverter<(Of <(T>)>).)
 | Convert(T, IProcessingContext) | Converts the specified entry. (Inherited from BaseConverter<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute(String) | Gets the value of the attribute. (Inherited from BaseConverter<(Of <(T>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InternalConvert(FileSystemInfo, IProcessingContext) | Converts a file into package entry. (Overrides BaseConverter <(Of <(FileSystemInfo>)>).InternalConvert(T, IProcessingContext).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReducePath(String) | Reduces the path.
 | ResolvePath(String) | Resolves the path.
 | Root | Gets or sets the root.
 | SetAttribute(String, Object) | Sets the value of the attribute. (Inherited from BaseConverter<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | BaseConverter <(Of <(FileSystemInfo>)>)
 |  | RawFileToEntryConverter
 |  |  | FileToEntryConverter


RawFileToEntryConverter Constructor

RawFileToEntryConverter Constructor
Namespaces ► Sitecore.Install.Files ► RawFileToEntryConverter ► RawFileToEntryConverter()()()
Members
Icon | Member | Description
 | RawFileToEntryConverter()()() | Initializes a new instance of the RawFileToEntryConverter class.
 | RawFileToEntryConverter(String, String) | Initializes a new instance of the RawFileToEntryConverter class.


RawFileToEntryConverter Constructor

RawFileToEntryConverter Constructor
Namespaces ► Sitecore.Install.Files ► RawFileToEntryConverter ► RawFileToEntryConverter()()()
Initializes a new instance of the RawFileToEntryConverter class.
Declaration Syntax
C#
public RawFileToEntryConverter()


RawFileToEntryConverter Constructor (root, prefix)

RawFileToEntryConverter Constructor (root, prefix)
Namespaces ► Sitecore.Install.Files ► RawFileToEntryConverter ► RawFileToEntryConverter(String, String)
Initializes a new instance of the RawFileToEntryConverter class.
Declaration Syntax
C#
public RawFileToEntryConverter(
    string root,
    string prefix
)
Parameters
root (String)
The root.
prefix (String)
The prefix.


InternalConvert Method (entry, context)

InternalConvert Method (entry, context)
Namespaces ► Sitecore.Install.Files ► RawFileToEntryConverter ► InternalConvert(FileSystemInfo, IProcessingContext)
Converts a file into package entry.
Declaration Syntax
C#
protected override PackageEntry[] InternalConvert(
    FileSystemInfo entry,
    IProcessingContext context
)
Parameters
entry (FileSystemInfo)
The entry.
context (IProcessingContext)
The processing context.
Return Value
The conversion result.


ReducePath Method (path)

ReducePath Method (path)
Namespaces ► Sitecore.Install.Files ► RawFileToEntryConverter ► ReducePath(String)
Reduces the path.
Declaration Syntax
C#
public string ReducePath(
    string path
)
Parameters
path (String)
The path.
Return Value
The reduced path.


ResolvePath Method (path)

ResolvePath Method (path)
Namespaces ► Sitecore.Install.Files ► RawFileToEntryConverter ► ResolvePath(String)
Resolves the path.
Declaration Syntax
C#
protected virtual string ResolvePath(
    string path
)
Parameters
path (String)
The path.
Return Value
The resolved path.


Root Property

Root Property
Namespaces ► Sitecore.Install.Files ► RawFileToEntryConverter ► Root
Gets or sets the root.
Declaration Syntax
C#
public string Root { get; set; }
Value
The root.


Sitecore.Install.Filters Namespace

Sitecore.Install.Filters Namespace
Namespaces ► Sitecore.Install.Filters
Declaration Syntax
C#
namespace Sitecore.Install.Filters
Types
All Types Classes Enumerations
Icon | Type | Description
 | ExplicitKeyFilter | Represents a filter which is qualifying an entry by key
 | FileDateFilter | Filter which is checking the creation date of the file
 | FileDateFilter..::.FileDateFilterType | Enumeration that defines a mode of working for FileDateFilter
 | FileNameFilter | Represents a filter which is qualifing the name of the file with the specifyed regular expression pattern
 | FileSizeFilter | Represents a filter which is checking file size
 | ItemDateFilter | Represents a filter which is qualifying items by date
 | ItemDateFilter..::.ItemDateFilterType | Enumeration of the way in which ItemDateFilter is choosing a date
 | ItemLanguageFilter | Represents a filter which is qualifying the item version by its language
 | ItemMasterFilter | Obsolete. Filters items by its master
 | ItemNameFilter | Represent a filter which is qualifying items by name
 | ItemPublishFilter | Accepts only the version of item which would be published on the specified date (optionally taking or not taking workflow into account)
 | ItemRoleFilter | Represents a filter to filiter item by role of the user who created/modified last that item
 | ItemRoleFilter..::.ItemRoleFilterType | Enumeration of ways in which ItemRoleFilter is choosing a field to qualify by
 | ItemTemplateFilter | Represents a filter wich is filtering items by its template
 | ItemUserFilter | Represents a filter which is qualifying an item by the user which created/modified this item
 | ItemUserFilter..::.ItemUserFilterType | Filting mode
 | PackageEntryKeyFilter | Represents a filter which is checking the key of the package entry with the specified pattern
 | ItemNameFilter..::.SearchType | Search type


ExplicitKeyFilter Class

ExplicitKeyFilter Class
Namespaces ► Sitecore.Install.Filters ► ExplicitKeyFilter
Represents a filter which is qualifying an entry by key
Declaration Syntax
C#
public class ExplicitKeyFilter : IFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExplicitKeyFilter()()() | Initializes a new instance of the ExplicitKeyFilter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | Keys | Gets the keys.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Qualify(Object, IProcessingContext) | Qualifies the specified instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ExplicitKeyFilter


ExplicitKeyFilter Constructor

ExplicitKeyFilter Constructor
Namespaces ► Sitecore.Install.Filters ► ExplicitKeyFilter ► ExplicitKeyFilter()()()
Initializes a new instance of the ExplicitKeyFilter class
Declaration Syntax
C#
public ExplicitKeyFilter()


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Install.Filters ► ExplicitKeyFilter ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


Keys Property

Keys Property
Namespaces ► Sitecore.Install.Filters ► ExplicitKeyFilter ► Keys
Gets the keys.
Declaration Syntax
C#
public IList<string> Keys { get; }
Value
The keys.


Qualify Method (instance, context)

Qualify Method (instance, context)
Namespaces ► Sitecore.Install.Filters ► ExplicitKeyFilter ► Qualify(Object, IProcessingContext)
Qualifies the specified instance.
Declaration Syntax
C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Parameters
instance (Object)
The instance.
context (IProcessingContext)
The processing context.
Return Value
Qualification result.


FileDateFilter Class

FileDateFilter Class
Namespaces ► Sitecore.Install.Filters ► FileDateFilter
Filter which is checking the creation date of the file
Declaration Syntax
C#
public class FileDateFilter : IFilter
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileDateFilter()()() | Initializes a new instance of the FileDateFilter class.
 | FileDateFilter(FileDateFilter..::.FileDateFilterType) | Initializes a new instance of the FileDateFilter class.
 | FileDateFilter(String, String, FileDateFilter..::.FileDateFilterType) | Initializes a new instance of the FileDateFilter class.
 | ActionDateFrom | Gets or sets the action date from.
 | ActionDateTo | Gets or sets the action date to.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterType | Gets or sets the type of the filter.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotOlderThan | Gets or sets the value that indicates time pariod, calculated in days.
 | NoValue |
 | Qualify(Object, IProcessingContext) | Qualifies the specified instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FileDateFilter


FileDateFilter Constructor

FileDateFilter Constructor
Namespaces ► Sitecore.Install.Filters ► FileDateFilter ► FileDateFilter()()()
Members
Icon | Member | Description
 | FileDateFilter()()() | Initializes a new instance of the FileDateFilter class.
 | FileDateFilter(FileDateFilter..::.FileDateFilterType) | Initializes a new instance of the FileDateFilter class.
 | FileDateFilter(String, String, FileDateFilter..::.FileDateFilterType) | Initializes a new instance of the FileDateFilter class.


FileDateFilter Constructor

FileDateFilter Constructor
Namespaces ► Sitecore.Install.Filters ► FileDateFilter ► FileDateFilter()()()
Initializes a new instance of the FileDateFilter class.
Declaration Syntax
C#
public FileDateFilter()


FileDateFilter Constructor (filterType)

FileDateFilter Constructor (filterType)
Namespaces ► Sitecore.Install.Filters ► FileDateFilter ► FileDateFilter(FileDateFilter..::.FileDateFilterType)
Initializes a new instance of the FileDateFilter class.
Declaration Syntax
C#
public FileDateFilter(
    FileDateFilter..::.FileDateFilterType filterType
)
Parameters
filterType (FileDateFilter..::.FileDateFilterType)
Type of the filter.


FileDateFilter Constructor (actionDateFrom, actionDateTo, filterType)

FileDateFilter Constructor (actionDateFrom, actionDateTo, filterType)
Namespaces ► Sitecore.Install.Filters ► FileDateFilter ► FileDateFilter(String, String, FileDateFilter..::.FileDateFilterType)
Initializes a new instance of the FileDateFilter class.
Declaration Syntax
C#
public FileDateFilter(
    string actionDateFrom,
    string actionDateTo,
    FileDateFilter..::.FileDateFilterType filterType
)
Parameters
actionDateFrom (String)
The action date from.
actionDateTo (String)
The action date to.
filterType (FileDateFilter..::.FileDateFilterType)
Type of the filter.


ActionDateFrom Property

ActionDateFrom Property
Namespaces ► Sitecore.Install.Filters ► FileDateFilter ► ActionDateFrom
Gets or sets the action date from.
Declaration Syntax
C#
public string ActionDateFrom { get; set; }
Value
The action date from.


ActionDateTo Property

ActionDateTo Property
Namespaces ► Sitecore.Install.Filters ► FileDateFilter ► ActionDateTo
Gets or sets the action date to.
Declaration Syntax
C#
public string ActionDateTo { get; set; }
Value
The action date to.


FilterType Property

FilterType Property
Namespaces ► Sitecore.Install.Filters ► FileDateFilter ► FilterType
Gets or sets the type of the filter.
Declaration Syntax
C#
public FileDateFilter..::.FileDateFilterType FilterType { get; set; }
Value
The type of the filter.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Install.Filters ► FileDateFilter ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


NotOlderThan Property

NotOlderThan Property
Namespaces ► Sitecore.Install.Filters ► FileDateFilter ► NotOlderThan
Gets or sets the value that indicates time pariod, calculated in days.
Declaration Syntax
C#
public string NotOlderThan { get; set; }
Value
Indicates time pariod, calculated in days.


NoValue Field

NoValue Field
Namespaces ► Sitecore.Install.Filters ► FileDateFilter ► NoValue
Declaration Syntax
C#
public static string NoValue


Qualify Method (instance, context)

Qualify Method (instance, context)
Namespaces ► Sitecore.Install.Filters ► FileDateFilter ► Qualify(Object, IProcessingContext)
Qualifies the specified instance.
Declaration Syntax
C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Parameters
instance (Object)
The instance.
context (IProcessingContext)
The processing context.
Return Value
Qualification result.


FileDateFilter.FileDateFilterType Enumeration

FileDateFilter..::.FileDateFilterType Enumeration
Namespaces ► Sitecore.Install.Filters ► FileDateFilter ► FileDateFilter..::.FileDateFilterType
Enumeration that defines a mode of working for FileDateFilter
Declaration Syntax
C#
public enum FileDateFilterType
Members
Member | Description
CreatedFilter | Filter will be checking the date of the creation
ModifiedFilter | Filter will be checking the date of the modification


FileNameFilter Class

FileNameFilter Class
Namespaces ► Sitecore.Install.Filters ► FileNameFilter
Represents a filter which is qualifing the name of the file with the specifyed regular expression pattern
Declaration Syntax
C#
public class FileNameFilter : IFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileNameFilter()()() | Initializes a new instance of the FileNameFilter class.
 | FileNameFilter(String) | Initializes a new instance of the FileNameFilter class.
 | AcceptDirectories | Always accept directories regardless of name pattern match
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateRegex(String) | Generates the regex.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Pattern | Gets or sets the pattern.
 | Qualify(Object, IProcessingContext) | Qualifies the specified instance.
 | RegexPattern | Gets the regex pattern.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FileNameFilter


FileNameFilter Constructor

FileNameFilter Constructor
Namespaces ► Sitecore.Install.Filters ► FileNameFilter ► FileNameFilter()()()
Members
Icon | Member | Description
 | FileNameFilter()()() | Initializes a new instance of the FileNameFilter class.
 | FileNameFilter(String) | Initializes a new instance of the FileNameFilter class.


FileNameFilter Constructor

FileNameFilter Constructor
Namespaces ► Sitecore.Install.Filters ► FileNameFilter ► FileNameFilter()()()
Initializes a new instance of the FileNameFilter class.
Declaration Syntax
C#
public FileNameFilter()


FileNameFilter Constructor (pattern)

FileNameFilter Constructor (pattern)
Namespaces ► Sitecore.Install.Filters ► FileNameFilter ► FileNameFilter(String)
Initializes a new instance of the FileNameFilter class.
Declaration Syntax
C#
public FileNameFilter(
    string pattern
)
Parameters
pattern (String)
The pattern.


AcceptDirectories Property

AcceptDirectories Property
Namespaces ► Sitecore.Install.Filters ► FileNameFilter ► AcceptDirectories
Always accept directories regardless of name pattern match
Declaration Syntax
C#
public bool AcceptDirectories { get; set; }


GenerateRegex Method (pattern)

GenerateRegex Method (pattern)
Namespaces ► Sitecore.Install.Filters ► FileNameFilter ► GenerateRegex(String)
Generates the regex.
Declaration Syntax
C#
public string GenerateRegex(
    string pattern
)
Parameters
pattern (String)
The pattern.
Return Value
The regex.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Install.Filters ► FileNameFilter ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


Pattern Property

Pattern Property
Namespaces ► Sitecore.Install.Filters ► FileNameFilter ► Pattern
Gets or sets the pattern.
Declaration Syntax
C#
public string Pattern { get; set; }
Value
The pattern.


Qualify Method (instance, context)

Qualify Method (instance, context)
Namespaces ► Sitecore.Install.Filters ► FileNameFilter ► Qualify(Object, IProcessingContext)
Qualifies the specified instance.
Declaration Syntax
C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Parameters
instance (Object)
The instance.
context (IProcessingContext)
The processing context.
Return Value
Qualification result.


RegexPattern Property

RegexPattern Property
Namespaces ► Sitecore.Install.Filters ► FileNameFilter ► RegexPattern
Gets the regex pattern.
Declaration Syntax
C#
public string RegexPattern { get; }
Value
The regex pattern.


FileSizeFilter Class

FileSizeFilter Class
Namespaces ► Sitecore.Install.Filters ► FileSizeFilter
Represents a filter which is checking file size
Declaration Syntax
C#
public class FileSizeFilter : IFilter
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileSizeFilter()()() | Initializes a new instance of the FileSizeFilter class.
 | FileSizeFilter(Int32, Int32) | Initializes a new instance of the FileSizeFilter class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | MaximumSize | Gets or sets the maximum size.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumSize | Gets or sets the minimum size.
 | NoValue |
 | Qualify(Object, IProcessingContext) | Qualifies the specified instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FileSizeFilter


FileSizeFilter Constructor

FileSizeFilter Constructor
Namespaces ► Sitecore.Install.Filters ► FileSizeFilter ► FileSizeFilter()()()
Members
Icon | Member | Description
 | FileSizeFilter()()() | Initializes a new instance of the FileSizeFilter class.
 | FileSizeFilter(Int32, Int32) | Initializes a new instance of the FileSizeFilter class.


FileSizeFilter Constructor

FileSizeFilter Constructor
Namespaces ► Sitecore.Install.Filters ► FileSizeFilter ► FileSizeFilter()()()
Initializes a new instance of the FileSizeFilter class.
Declaration Syntax
C#
public FileSizeFilter()


FileSizeFilter Constructor (minimumSize, maximumSize)

FileSizeFilter Constructor (minimumSize, maximumSize)
Namespaces ► Sitecore.Install.Filters ► FileSizeFilter ► FileSizeFilter(Int32, Int32)
Initializes a new instance of the FileSizeFilter class.
Declaration Syntax
C#
public FileSizeFilter(
    int minimumSize,
    int maximumSize
)
Parameters
minimumSize (Int32)
The minimum size.
maximumSize (Int32)
The maximum size.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Install.Filters ► FileSizeFilter ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


MaximumSize Property

MaximumSize Property
Namespaces ► Sitecore.Install.Filters ► FileSizeFilter ► MaximumSize
Gets or sets the maximum size.
Declaration Syntax
C#
public int MaximumSize { get; set; }
Value
The maximum size.


MinimumSize Property

MinimumSize Property
Namespaces ► Sitecore.Install.Filters ► FileSizeFilter ► MinimumSize
Gets or sets the minimum size.
Declaration Syntax
C#
public int MinimumSize { get; set; }
Value
The minimum size.


NoValue Field

NoValue Field
Namespaces ► Sitecore.Install.Filters ► FileSizeFilter ► NoValue
Declaration Syntax
C#
public static readonly int NoValue


Qualify Method (instance, context)

Qualify Method (instance, context)
Namespaces ► Sitecore.Install.Filters ► FileSizeFilter ► Qualify(Object, IProcessingContext)
Qualifies the specified instance.
Declaration Syntax
C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Parameters
instance (Object)
The instance.
context (IProcessingContext)
The processing context.
Return Value
Qualification result.


ItemDateFilter Class

ItemDateFilter Class
Namespaces ► Sitecore.Install.Filters ► ItemDateFilter
Represents a filter which is qualifying items by date
Declaration Syntax
C#
public class ItemDateFilter : IFilter
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemDateFilter()()() | Initializes a new instance of the ItemDateFilter class.
 | ItemDateFilter(ItemDateFilter..::.ItemDateFilterType) | Initializes a new instance of the ItemDateFilter class.
 | ItemDateFilter(String, String, ItemDateFilter..::.ItemDateFilterType) | Initializes a new instance of the ItemDateFilter class.
 | ItemDateFilter(Int32, ItemDateFilter..::.ItemDateFilterType) | Initializes a new instance of the ItemDateFilter class.
 | ActionDateFrom | Gets or sets the action date from.
 | ActionDateTo | Gets or sets the action date to.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterType | Gets or sets the type of the filter.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotOlderThan | Gets or sets the value that indicates time pariod, calculated in days.
 | NoValue |
 | Qualify(Object, IProcessingContext) | Qualifies the specified instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemDateFilter


ItemDateFilter Constructor

ItemDateFilter Constructor
Namespaces ► Sitecore.Install.Filters ► ItemDateFilter ► ItemDateFilter()()()
Members
Icon | Member | Description
 | ItemDateFilter()()() | Initializes a new instance of the ItemDateFilter class.
 | ItemDateFilter(ItemDateFilter..::.ItemDateFilterType) | Initializes a new instance of the ItemDateFilter class.
 | ItemDateFilter(String, String, ItemDateFilter..::.ItemDateFilterType) | Initializes a new instance of the ItemDateFilter class.
 | ItemDateFilter(Int32, ItemDateFilter..::.ItemDateFilterType) | Initializes a new instance of the ItemDateFilter class.


ItemDateFilter Constructor

ItemDateFilter Constructor
Namespaces ► Sitecore.Install.Filters ► ItemDateFilter ► ItemDateFilter()()()
Initializes a new instance of the ItemDateFilter class.
Declaration Syntax
C#
public ItemDateFilter()


ItemDateFilter Constructor (filterType)

ItemDateFilter Constructor (filterType)
Namespaces ► Sitecore.Install.Filters ► ItemDateFilter ► ItemDateFilter(ItemDateFilter..::.ItemDateFilterType)
Initializes a new instance of the ItemDateFilter class.
Declaration Syntax
C#
public ItemDateFilter(
    ItemDateFilter..::.ItemDateFilterType filterType
)
Parameters
filterType (ItemDateFilter..::.ItemDateFilterType)
Type of the filter.


ItemDateFilter Constructor (days, filterType)

ItemDateFilter Constructor (days, filterType)
Namespaces ► Sitecore.Install.Filters ► ItemDateFilter ► ItemDateFilter(Int32, ItemDateFilter..::.ItemDateFilterType)
Initializes a new instance of the ItemDateFilter class.
Declaration Syntax
C#
public ItemDateFilter(
    int days,
    ItemDateFilter..::.ItemDateFilterType filterType
)
Parameters
days (Int32)
Defines time period, in days.
filterType (ItemDateFilter..::.ItemDateFilterType)
Type of the filter.


ItemDateFilter Constructor (actionDateFrom, actionDateTo, filterType)

ItemDateFilter Constructor (actionDateFrom, actionDateTo, filterType)
Namespaces ► Sitecore.Install.Filters ► ItemDateFilter ► ItemDateFilter(String, String, ItemDateFilter..::.ItemDateFilterType)
Initializes a new instance of the ItemDateFilter class.
Declaration Syntax
C#
public ItemDateFilter(
    string actionDateFrom,
    string actionDateTo,
    ItemDateFilter..::.ItemDateFilterType filterType
)
Parameters
actionDateFrom (String)
The action date from.
actionDateTo (String)
The action date to.
filterType (ItemDateFilter..::.ItemDateFilterType)
Type of the filter.


ActionDateFrom Property

ActionDateFrom Property
Namespaces ► Sitecore.Install.Filters ► ItemDateFilter ► ActionDateFrom
Gets or sets the action date from.
Declaration Syntax
C#
public string ActionDateFrom { get; set; }
Value
The action date from.


ActionDateTo Property

ActionDateTo Property
Namespaces ► Sitecore.Install.Filters ► ItemDateFilter ► ActionDateTo
Gets or sets the action date to.
Declaration Syntax
C#
public string ActionDateTo { get; set; }
Value
The action date to.


FilterType Property

FilterType Property
Namespaces ► Sitecore.Install.Filters ► ItemDateFilter ► FilterType
Gets or sets the type of the filter.
Declaration Syntax
C#
public ItemDateFilter..::.ItemDateFilterType FilterType { get; set; }
Value
The type of the filter.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Install.Filters ► ItemDateFilter ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


NotOlderThan Property

NotOlderThan Property
Namespaces ► Sitecore.Install.Filters ► ItemDateFilter ► NotOlderThan
Gets or sets the value that indicates time pariod, calculated in days.
Declaration Syntax
C#
public string NotOlderThan { get; set; }
Value
Indicates time pariod, calculated in days.


NoValue Field

NoValue Field
Namespaces ► Sitecore.Install.Filters ► ItemDateFilter ► NoValue
Declaration Syntax
C#
public static string NoValue


Qualify Method (instance, context)

Qualify Method (instance, context)
Namespaces ► Sitecore.Install.Filters ► ItemDateFilter ► Qualify(Object, IProcessingContext)
Qualifies the specified instance.
Declaration Syntax
C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Parameters
instance (Object)
The instance.
context (IProcessingContext)
The processing context.
Return Value
Qualification result.


ItemDateFilter.ItemDateFilterType Enumeration

ItemDateFilter..::.ItemDateFilterType Enumeration
Namespaces ► Sitecore.Install.Filters ► ItemDateFilter ► ItemDateFilter..::.ItemDateFilterType
Enumeration of the way in which ItemDateFilter is choosing a date
Declaration Syntax
C#
public enum ItemDateFilterType
Members
Member | Description
CreatedFilter | A creation date will be choosen
ModifiedFilter | A modification date will be choosen
PublishedFilter | A publishing date will be choosen


ItemLanguageFilter Class

ItemLanguageFilter Class
Namespaces ► Sitecore.Install.Filters ► ItemLanguageFilter
Represents a filter which is qualifying the item version by its language
Declaration Syntax
C#
public class ItemLanguageFilter : IFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemLanguageFilter()()() | Initializes a new instance of the ItemLanguageFilter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | Languages | Gets or sets the languages.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Qualify(Object, IProcessingContext) | Qualifies the specified instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemLanguageFilter


ItemLanguageFilter Constructor

ItemLanguageFilter Constructor
Namespaces ► Sitecore.Install.Filters ► ItemLanguageFilter ► ItemLanguageFilter()()()
Initializes a new instance of the ItemLanguageFilter class
Declaration Syntax
C#
public ItemLanguageFilter()


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Install.Filters ► ItemLanguageFilter ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


Languages Property

Languages Property
Namespaces ► Sitecore.Install.Filters ► ItemLanguageFilter ► Languages
Gets or sets the languages.
Declaration Syntax
C#
public string Languages { get; set; }
Value
The languages.


Qualify Method (instance, context)

Qualify Method (instance, context)
Namespaces ► Sitecore.Install.Filters ► ItemLanguageFilter ► Qualify(Object, IProcessingContext)
Qualifies the specified instance.
Declaration Syntax
C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Parameters
instance (Object)
The instance.
context (IProcessingContext)
The processing context.
Return Value
Qualification result.


ItemMasterFilter Class

ItemMasterFilter Class
Namespaces ► Sitecore.Install.Filters ► ItemMasterFilter
Filters items by its master
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated")]
public class ItemMasterFilter : IFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemMasterFilter()()() | Initializes a new instance of the ItemMasterFilter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExcludeWithoutMaster | Gets or sets a value indicating whether the ItemMasterFilter excludes without master(s).
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | Masters | Gets or sets the masters.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Qualify(Object, IProcessingContext) | Qualifies the specified instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemMasterFilter


ItemMasterFilter Constructor

ItemMasterFilter Constructor
Namespaces ► Sitecore.Install.Filters ► ItemMasterFilter ► ItemMasterFilter()()()
Initializes a new instance of the ItemMasterFilter class
Declaration Syntax
C#
public ItemMasterFilter()


ExcludeWithoutMaster Property

ExcludeWithoutMaster Property
Namespaces ► Sitecore.Install.Filters ► ItemMasterFilter ► ExcludeWithoutMaster
Gets or sets a value indicating whether the ItemMasterFilter excludes without master(s).
Declaration Syntax
C#
public bool ExcludeWithoutMaster { get; set; }
Value
true if the ItemMasterFilter excludes without master(s); otherwise, false.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Install.Filters ► ItemMasterFilter ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


Masters Property

Masters Property
Namespaces ► Sitecore.Install.Filters ► ItemMasterFilter ► Masters
Gets or sets the masters.
Declaration Syntax
C#
public string Masters { get; set; }
Value
The masters.


Qualify Method (instance, context)

Qualify Method (instance, context)
Namespaces ► Sitecore.Install.Filters ► ItemMasterFilter ► Qualify(Object, IProcessingContext)
Qualifies the specified instance.
Declaration Syntax
C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Parameters
instance (Object)
The instance.
context (IProcessingContext)
The processing context.
Return Value
Qualification result.


ItemNameFilter Class

ItemNameFilter Class
Namespaces ► Sitecore.Install.Filters ► ItemNameFilter
Represent a filter which is qualifying items by name
Declaration Syntax
C#
public class ItemNameFilter : IFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemNameFilter()()() | Initializes a new instance of the ItemNameFilter class.
 | ItemNameFilter(String) | Initializes a new instance of the ItemNameFilter class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterSearchType | Gets or sets the type of the filter search.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Pattern | Gets or sets the pattern.
 | Qualify(Object, IProcessingContext) | Qualifies the specified instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemNameFilter


ItemNameFilter Constructor

ItemNameFilter Constructor
Namespaces ► Sitecore.Install.Filters ► ItemNameFilter ► ItemNameFilter()()()
Members
Icon | Member | Description
 | ItemNameFilter()()() | Initializes a new instance of the ItemNameFilter class.
 | ItemNameFilter(String) | Initializes a new instance of the ItemNameFilter class.


ItemNameFilter Constructor

ItemNameFilter Constructor
Namespaces ► Sitecore.Install.Filters ► ItemNameFilter ► ItemNameFilter()()()
Initializes a new instance of the ItemNameFilter class.
Declaration Syntax
C#
public ItemNameFilter()


ItemNameFilter Constructor (pattern)

ItemNameFilter Constructor (pattern)
Namespaces ► Sitecore.Install.Filters ► ItemNameFilter ► ItemNameFilter(String)
Initializes a new instance of the ItemNameFilter class.
Declaration Syntax
C#
public ItemNameFilter(
    string pattern
)
Parameters
pattern (String)
The pattern.


FilterSearchType Property

FilterSearchType Property
Namespaces ► Sitecore.Install.Filters ► ItemNameFilter ► FilterSearchType
Gets or sets the type of the filter search.
Declaration Syntax
C#
public ItemNameFilter..::.SearchType FilterSearchType { get; set; }
Value
The type of the filter search.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Install.Filters ► ItemNameFilter ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


Pattern Property

Pattern Property
Namespaces ► Sitecore.Install.Filters ► ItemNameFilter ► Pattern
Gets or sets the pattern.
Declaration Syntax
C#
public string Pattern { get; set; }
Value
The pattern.


Qualify Method (instance, context)

Qualify Method (instance, context)
Namespaces ► Sitecore.Install.Filters ► ItemNameFilter ► Qualify(Object, IProcessingContext)
Qualifies the specified instance.
Declaration Syntax
C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Parameters
instance (Object)
The instance.
context (IProcessingContext)
The processing context.
Return Value
Qualification result.


ItemNameFilter.SearchType Enumeration

ItemNameFilter..::.SearchType Enumeration
Namespaces ► Sitecore.Install.Filters ► ItemNameFilter ► ItemNameFilter..::.SearchType
Search type
Declaration Syntax
C#
public enum SearchType
Members
Member | Description
Simple | Simple search
Regex | Searching by a regual expression
Wildcards | Searching by an expression with some wildcards


ItemPublishFilter Class

ItemPublishFilter Class
Namespaces ► Sitecore.Install.Filters ► ItemPublishFilter
Accepts only the version of item which would be published on the specified date (optionally taking or not taking workflow into account)
Declaration Syntax
C#
public class ItemPublishFilter : IFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemPublishFilter()()() | Initializes a new instance of the ItemPublishFilter class
 | CheckWorkflow | Gets or sets a value indicating whether the ItemPublishFilter checks the workflow.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PublishDate | Gets or sets the publish date.
 | Qualify(Object, IProcessingContext) | Qualifies the specified instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemPublishFilter


ItemPublishFilter Constructor

ItemPublishFilter Constructor
Namespaces ► Sitecore.Install.Filters ► ItemPublishFilter ► ItemPublishFilter()()()
Initializes a new instance of the ItemPublishFilter class
Declaration Syntax
C#
public ItemPublishFilter()


CheckWorkflow Property

CheckWorkflow Property
Namespaces ► Sitecore.Install.Filters ► ItemPublishFilter ► CheckWorkflow
Gets or sets a value indicating whether the ItemPublishFilter checks the workflow.
Declaration Syntax
C#
public bool CheckWorkflow { get; set; }
Value
true if the ItemPublishFilter checks the workflow; otherwise, false.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Install.Filters ► ItemPublishFilter ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


PublishDate Property

PublishDate Property
Namespaces ► Sitecore.Install.Filters ► ItemPublishFilter ► PublishDate
Gets or sets the publish date.
Declaration Syntax
C#
public string PublishDate { get; set; }
Value
The publish date.


Qualify Method (instance, context)

Qualify Method (instance, context)
Namespaces ► Sitecore.Install.Filters ► ItemPublishFilter ► Qualify(Object, IProcessingContext)
Qualifies the specified instance.
Declaration Syntax
C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Parameters
instance (Object)
The instance.
context (IProcessingContext)
The processing context.
Return Value
Qualification result.


ItemRoleFilter Class

ItemRoleFilter Class
Namespaces ► Sitecore.Install.Filters ► ItemRoleFilter
Represents a filter to filiter item by role of the user who created/modified last that item
Declaration Syntax
C#
public class ItemRoleFilter : IFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemRoleFilter()()() | Initializes a new instance of the ItemRoleFilter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterType | Gets or sets the type of the filter.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Qualify(Object, IProcessingContext) | Qualifies the specified instance.
 | Roles | Gets or sets the roles.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemRoleFilter


ItemRoleFilter Constructor

ItemRoleFilter Constructor
Namespaces ► Sitecore.Install.Filters ► ItemRoleFilter ► ItemRoleFilter()()()
Initializes a new instance of the ItemRoleFilter class
Declaration Syntax
C#
public ItemRoleFilter()


FilterType Property

FilterType Property
Namespaces ► Sitecore.Install.Filters ► ItemRoleFilter ► FilterType
Gets or sets the type of the filter.
Declaration Syntax
C#
public ItemRoleFilter..::.ItemRoleFilterType FilterType { get; set; }
Value
The type of the filter.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Install.Filters ► ItemRoleFilter ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


Qualify Method (instance, context)

Qualify Method (instance, context)
Namespaces ► Sitecore.Install.Filters ► ItemRoleFilter ► Qualify(Object, IProcessingContext)
Qualifies the specified instance.
Declaration Syntax
C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Parameters
instance (Object)
The instance.
context (IProcessingContext)
The processing context.
Return Value
Qualification result.


Roles Property

Roles Property
Namespaces ► Sitecore.Install.Filters ► ItemRoleFilter ► Roles
Gets or sets the roles.
Declaration Syntax
C#
public string Roles { get; set; }
Value
The roles.


ItemRoleFilter.ItemRoleFilterType Enumeration

ItemRoleFilter..::.ItemRoleFilterType Enumeration
Namespaces ► Sitecore.Install.Filters ► ItemRoleFilter ► ItemRoleFilter..::.ItemRoleFilterType
Enumeration of ways in which ItemRoleFilter is choosing a field to qualify by
Declaration Syntax
C#
public enum ItemRoleFilterType
Members
Member | Description
Created | "Created by" field will be used
Modified | "Modified by" field will be used


ItemTemplateFilter Class

ItemTemplateFilter Class
Namespaces ► Sitecore.Install.Filters ► ItemTemplateFilter
Represents a filter wich is filtering items by its template
Declaration Syntax
C#
public class ItemTemplateFilter : IFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemTemplateFilter()()() | Initializes a new instance of the ItemTemplateFilter class.
 | ItemTemplateFilter(String) | Initializes a new instance of the ItemTemplateFilter class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Qualify(Object, IProcessingContext) | Qualifies the specified instance.
 | Templates | Gets or sets the templates.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemTemplateFilter


ItemTemplateFilter Constructor

ItemTemplateFilter Constructor
Namespaces ► Sitecore.Install.Filters ► ItemTemplateFilter ► ItemTemplateFilter()()()
Members
Icon | Member | Description
 | ItemTemplateFilter()()() | Initializes a new instance of the ItemTemplateFilter class.
 | ItemTemplateFilter(String) | Initializes a new instance of the ItemTemplateFilter class.


ItemTemplateFilter Constructor

ItemTemplateFilter Constructor
Namespaces ► Sitecore.Install.Filters ► ItemTemplateFilter ► ItemTemplateFilter()()()
Initializes a new instance of the ItemTemplateFilter class.
Declaration Syntax
C#
public ItemTemplateFilter()


ItemTemplateFilter Constructor (templates)

ItemTemplateFilter Constructor (templates)
Namespaces ► Sitecore.Install.Filters ► ItemTemplateFilter ► ItemTemplateFilter(String)
Initializes a new instance of the ItemTemplateFilter class.
Declaration Syntax
C#
public ItemTemplateFilter(
    string templates
)
Parameters
templates (String)
The templates.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Install.Filters ► ItemTemplateFilter ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


Qualify Method (instance, context)

Qualify Method (instance, context)
Namespaces ► Sitecore.Install.Filters ► ItemTemplateFilter ► Qualify(Object, IProcessingContext)
Qualifies the specified instance.
Declaration Syntax
C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Parameters
instance (Object)
The instance.
context (IProcessingContext)
The processing context.
Return Value
Qualification result.


Templates Property

Templates Property
Namespaces ► Sitecore.Install.Filters ► ItemTemplateFilter ► Templates
Gets or sets the templates.
Declaration Syntax
C#
public string Templates { get; set; }
Value
The templates.


ItemUserFilter Class

ItemUserFilter Class
Namespaces ► Sitecore.Install.Filters ► ItemUserFilter
Represents a filter which is qualifying an item by the user which created/modified this item
Declaration Syntax
C#
public class ItemUserFilter : IFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemUserFilter()()() | Initializes a new instance of the ItemUserFilter class
 | Accounts | Gets or sets the accounts.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterType | Gets or sets the type of the filter.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Qualify(Object, IProcessingContext) | Qualifies the specified instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemUserFilter


ItemUserFilter Constructor

ItemUserFilter Constructor
Namespaces ► Sitecore.Install.Filters ► ItemUserFilter ► ItemUserFilter()()()
Initializes a new instance of the ItemUserFilter class
Declaration Syntax
C#
public ItemUserFilter()


Accounts Property

Accounts Property
Namespaces ► Sitecore.Install.Filters ► ItemUserFilter ► Accounts
Gets or sets the accounts.
Declaration Syntax
C#
public string Accounts { get; set; }
Value
The accounts.


FilterType Property

FilterType Property
Namespaces ► Sitecore.Install.Filters ► ItemUserFilter ► FilterType
Gets or sets the type of the filter.
Declaration Syntax
C#
public ItemUserFilter..::.ItemUserFilterType FilterType { get; set; }
Value
The type of the filter.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Install.Filters ► ItemUserFilter ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


Qualify Method (instance, context)

Qualify Method (instance, context)
Namespaces ► Sitecore.Install.Filters ► ItemUserFilter ► Qualify(Object, IProcessingContext)
Qualifies the specified instance.
Declaration Syntax
C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Parameters
instance (Object)
The instance.
context (IProcessingContext)
The processing context.
Return Value
Qualification result.


ItemUserFilter.ItemUserFilterType Enumeration

ItemUserFilter..::.ItemUserFilterType Enumeration
Namespaces ► Sitecore.Install.Filters ► ItemUserFilter ► ItemUserFilter..::.ItemUserFilterType
Filting mode
Declaration Syntax
C#
public enum ItemUserFilterType
Members
Member | Description
Created | "Created by" field will be used
Modified | "Modified by" field will be used


PackageEntryKeyFilter Class

PackageEntryKeyFilter Class
Namespaces ► Sitecore.Install.Filters ► PackageEntryKeyFilter
Represents a filter which is checking the key of the package entry with the specified pattern
Declaration Syntax
C#
public class PackageEntryKeyFilter : IFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PackageEntryKeyFilter()()() | Initializes a new instance of the PackageEntryKeyFilter class.
 | PackageEntryKeyFilter(String) | Initializes a new instance of the PackageEntryKeyFilter class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Pattern | Gets or sets the regular expression pattern.
 | Qualify(Object, IProcessingContext) | Qualifies the specified instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PackageEntryKeyFilter


PackageEntryKeyFilter Constructor

PackageEntryKeyFilter Constructor
Namespaces ► Sitecore.Install.Filters ► PackageEntryKeyFilter ► PackageEntryKeyFilter()()()
Members
Icon | Member | Description
 | PackageEntryKeyFilter()()() | Initializes a new instance of the PackageEntryKeyFilter class.
 | PackageEntryKeyFilter(String) | Initializes a new instance of the PackageEntryKeyFilter class.


PackageEntryKeyFilter Constructor

PackageEntryKeyFilter Constructor
Namespaces ► Sitecore.Install.Filters ► PackageEntryKeyFilter ► PackageEntryKeyFilter()()()
Initializes a new instance of the PackageEntryKeyFilter class.
Declaration Syntax
C#
public PackageEntryKeyFilter()


PackageEntryKeyFilter Constructor (pattern)

PackageEntryKeyFilter Constructor (pattern)
Namespaces ► Sitecore.Install.Filters ► PackageEntryKeyFilter ► PackageEntryKeyFilter(String)
Initializes a new instance of the PackageEntryKeyFilter class.
Declaration Syntax
C#
public PackageEntryKeyFilter(
    string pattern
)
Parameters
pattern (String)
The pattern.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Install.Filters ► PackageEntryKeyFilter ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


Pattern Property

Pattern Property
Namespaces ► Sitecore.Install.Filters ► PackageEntryKeyFilter ► Pattern
Gets or sets the regular expression pattern.
Declaration Syntax
C#
public string Pattern { get; set; }
Value
The pattern.


Qualify Method (instance, context)

Qualify Method (instance, context)
Namespaces ► Sitecore.Install.Filters ► PackageEntryKeyFilter ► Qualify(Object, IProcessingContext)
Qualifies the specified instance.
Declaration Syntax
C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Parameters
instance (Object)
The instance.
context (IProcessingContext)
The processing context.
Return Value
Qualification result.


Sitecore.Install.Framework Namespace

Sitecore.Install.Framework Namespace
Namespaces ► Sitecore.Install.Framework
Declaration Syntax
C#
namespace Sitecore.Install.Framework
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | AdvancedBaseSink<(Of <(T, ContextType>)>) | AdvancedBaseSink
 | AspectBase | Base implementation of IAspectContainer
 | BaseConverter<(Of <(T>)>) | Implements basic functionality of "to Entry" convertor
 | BaseSink<(Of <(T>)>) | BaseSink class
 | BaseSource<(Of <(T>)>) | Implements basic source functionality
 | DefaultOutput | Default output
 | EntryBuilder | Converts an IEntryData object to PackageEntry object and populates the internal sink with that package entry
 | FilteringSink<(Of <(T>)>) | A sink that applies filters and populates the result entries to wrapped sink
 | IAspectContainer | IAspectContainer interface
 | IConverter<(Of <(T, K>)>) | Defines a method to transorm some objects
 | IEntryData | Basic methods and properties for an entry
 | IExplicitSource | Defines basic properties of an explicit source
 | IFilter | Defines basic methods and properties for a filer
 | IKeyResolver | Defines a basic methods of a key resolver
 | INamedObject | Defines a "name" property
 | InstallPolicy | Define what to do with the item collision
 | BaseSource<(Of <(T>)>)..::.InternalSink | Internal sink implementation
 | IPostStep | Mefines a basic method of a post step
 | IProcessingContext | Defines basic methods and properties of a processing context
 | IProcessor<(Of <(T>)>) | Defines basic methods of a processor
 | ISink<(Of <(T>)>) | Defines basic methods for a sink
 | ISortingKeyProvider | Defines basic methods of sorting key provider
 | ISource<(Of <(T>)>) | Defines basic methods for a source
 | IStreamHolder | Defines a property to get a stream
 | IStreamProvider | Defines basic methods of a stream provider
 | ISupportsAttributes | Defines methods to get/set attributes
 | ISupportsFiltering | Defines properties to get filters
 | ISupportsTransforms<(Of <(T>)>) | Defines a property to get transforms
 | ITaskOutput | Defines basic methods to work with UI in another thread
 | NullOutput | A "stab" task output
 | PackageEntry | Represents a package entry
 | PropertySetter | Represents a processor which is setting the properties of entries
 | SimpleKeyProvider | Simple key provider
 | SimpleProcessingContext | Simple processing context
 | SinkDispatcher | Represents a sink that use one of internal sinks to populate depends on the prefix of the name of the entry
 | SortingKey | Sorting key
 | SourceCollection<(Of <(T>)>) | An aggregation of sources
 | SourceInverter<(Of <(T>)>) | Adapts ISource into an IEnumerable (inverts from PUSH to PULL model)
 | TrivialConverter | "Stub" converter. As a result of any conversion we will have the input object.


AdvancedBaseSink(T, ContextType) Class

AdvancedBaseSink<(Of <(T, ContextType>)>) Class
Namespaces ► Sitecore.Install.Framework ► AdvancedBaseSink<(Of <(T, ContextType>)>)
AdvancedBaseSink
Declaration Syntax
C#
public abstract class AdvancedBaseSink<T, ContextType> : BaseSink<T>
where ContextType : class
Generic Template Parameters
T
Entry type
ContextType
Context Type
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdvancedBaseSink<(Of <(T, ContextType>)>)()()() | Initializes a new instance of the AdvancedBaseSink<(Of <(T, ContextType>)>) class
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Context | Gets the context.
 | CreateContext()()() | Creates the context.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Inherited from BaseSink<(Of <(T>)>).)
 | Flush()()() | Flushes the sink (Inherited from BaseSink<(Of <(T>)>).)
 | GetContext(IProcessingContext) | Gets the context.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasContext(IProcessingContext) | Determines whether the specified processing context has context.
 | Initialize(IProcessingContext) | Initializes this instance. (Overrides BaseSink <(Of <( T >)>).Initialize(IProcessingContext).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(T>)>).)
 | SetupContext(ContextType) | Setups the context.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( T >)>)
 |  | AdvancedBaseSink<(Of <(T, ContextType>)>)
 |  |  | BlobInstaller
 |  |  | FileInstaller
 |  |  | ItemInstaller


AdvancedBaseSink(T, ContextType) Constructor

AdvancedBaseSink<(Of <(T, ContextType>)>) Constructor
Namespaces ► Sitecore.Install.Framework ► AdvancedBaseSink<(Of <(T, ContextType>)>) ► AdvancedBaseSink<(Of <(T, ContextType>)>)()()()
Initializes a new instance of the AdvancedBaseSink<(Of <(T, ContextType>)>) class
Declaration Syntax
C#
protected AdvancedBaseSink()


Context Property

Context Property
Namespaces ► Sitecore.Install.Framework ► AdvancedBaseSink<(Of <(T, ContextType>)>) ► Context
Gets the context.
Declaration Syntax
C#
public ContextType Context { get; }
Value
The context.


CreateContext Method

CreateContext Method
Namespaces ► Sitecore.Install.Framework ► AdvancedBaseSink<(Of <(T, ContextType>)>) ► CreateContext()()()
Creates the context.
Declaration Syntax
C#
protected abstract ContextType CreateContext()
Return Value
The context.


GetContext Method (processingContext)

GetContext Method (processingContext)
Namespaces ► Sitecore.Install.Framework ► AdvancedBaseSink<(Of <(T, ContextType>)>) ► GetContext(IProcessingContext)
Gets the context.
Declaration Syntax
C#
protected static ContextType GetContext(
    IProcessingContext processingContext
)
Parameters
processingContext (IProcessingContext)
The processing context.
Return Value
The context.


HasContext Method (processingContext)

HasContext Method (processingContext)
Namespaces ► Sitecore.Install.Framework ► AdvancedBaseSink<(Of <(T, ContextType>)>) ► HasContext(IProcessingContext)
Determines whether the specified processing context has context.
Declaration Syntax
C#
protected static bool HasContext(
    IProcessingContext processingContext
)
Parameters
processingContext (IProcessingContext)
The processing context.
Return Value
true if the specified processing context has context; otherwise, false.


Initialize Method (processingContext)

Initialize Method (processingContext)
Namespaces ► Sitecore.Install.Framework ► AdvancedBaseSink<(Of <(T, ContextType>)>) ► Initialize(IProcessingContext)
Initializes this instance.
Declaration Syntax
C#
public override void Initialize(
    IProcessingContext processingContext
)
Parameters
processingContext (IProcessingContext)
The processing context.


SetupContext Method (context)

SetupContext Method (context)
Namespaces ► Sitecore.Install.Framework ► AdvancedBaseSink<(Of <(T, ContextType>)>) ► SetupContext(ContextType)
Setups the context.
Declaration Syntax
C#
protected void SetupContext(
    ContextType context
)
Parameters
context (ContextType)
The context.


AspectBase Class

AspectBase Class
Namespaces ► Sitecore.Install.Framework ► AspectBase
Base implementation of IAspectContainer
Declaration Syntax
C#
public class AspectBase : IAspectContainer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AspectBase()()() | Initializes a new instance of the AspectBase class
 | AddAspect<(Of <(T>)>)(T) | Adds the aspect.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAspect<(Of <(T>)>)()()() | Gets the aspect.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAspect<(Of <(T>)>)()()() | Determines whether this instance has aspect.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | AspectBase
 |  | SimpleProcessingContext


AspectBase Constructor

AspectBase Constructor
Namespaces ► Sitecore.Install.Framework ► AspectBase ► AspectBase()()()
Initializes a new instance of the AspectBase class
Declaration Syntax
C#
public AspectBase()


AddAspect Method (instance)

AddAspect<(Of <(T>)>) Method (instance)
Namespaces ► Sitecore.Install.Framework ► AspectBase ► AddAspect<(Of <(T>)>)(T)
Adds the aspect.
Declaration Syntax
C#
public void AddAspect<T>(
    T instance
)
where T : class
Generic Template Parameters
T
Parameters
instance (T)
The instance.


GetAspect Method

GetAspect<(Of <(T>)>) Method
Namespaces ► Sitecore.Install.Framework ► AspectBase ► GetAspect<(Of <(T>)>)()()()
Gets the aspect.
Declaration Syntax
C#
public T GetAspect<T>()
where T : class
Generic Template Parameters
T
Return Value
The aspect.


HasAspect Method

HasAspect<(Of <(T>)>) Method
Namespaces ► Sitecore.Install.Framework ► AspectBase ► HasAspect<(Of <(T>)>)()()()
Determines whether this instance has aspect.
Declaration Syntax
C#
public bool HasAspect<T>()
where T : class
Generic Template Parameters
T
Return Value
true if this instance has aspect; otherwise, false.


BaseConverter(T) Class

BaseConverter<(Of <(T>)>) Class
Namespaces ► Sitecore.Install.Framework ► BaseConverter<(Of <(T>)>)
Implements basic functionality of "to Entry" convertor
Declaration Syntax
C#
public abstract class BaseConverter<T> : IConverter<T, PackageEntry>,
    ISupportsTransforms<PackageEntry>, ISupportsAttributes
Generic Template Parameters
T
Source type
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseConverter<(Of <(T>)>)()()() | Initializes a new instance of the BaseConverter<(Of <(T>)>) class
 | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform.
 | ApplyTransforms<(Of <(C>)>)(C, IProcessingContext) | Applies the transform.
 | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(T>)>) converter transforms should be applied by BaseConverter, not the derived class.
 | Convert(T, IProcessingContext) | Converts the specified entry.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute(String) | Gets the value of the attribute.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InternalConvert(T, IProcessingContext) | Conversion method. Should be overriden.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetAttribute(String, Object) | Sets the value of the attribute.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transforms | Gets the transforms.
Inheritance Hierarchy
Object
 | BaseConverter<(Of <(T>)>)
 |  | RawFileToEntryConverter
 |  | TrivialConverter
 |  | ItemToEntryConverter
 |  | AccountToEntryConverter


BaseConverter(T) Constructor

BaseConverter<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Install.Framework ► BaseConverter<(Of <(T>)>) ► BaseConverter<(Of <(T>)>)()()()
Initializes a new instance of the BaseConverter<(Of <(T>)>) class
Declaration Syntax
C#
protected BaseConverter()


ApplyTransforms Method

ApplyTransforms Method
Namespaces ► Sitecore.Install.Framework ► BaseConverter<(Of <(T>)>) ► ApplyTransforms()()()
Members
Icon | Member | Description
 | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform.
 | ApplyTransforms<(Of <(C>)>)(C, IProcessingContext) | Applies the transform.


ApplyTransforms Method (entry, context)

ApplyTransforms Method (entry, context)
Namespaces ► Sitecore.Install.Framework ► BaseConverter<(Of <(T>)>) ► ApplyTransforms(PackageEntry, IProcessingContext)
Applies the transform.
Declaration Syntax
C#
protected PackageEntry ApplyTransforms(
    PackageEntry entry,
    IProcessingContext context
)
Parameters
entry (PackageEntry)
The entry.
context (IProcessingContext)
The context.


ApplyTransforms Method (entries, context)

ApplyTransforms<(Of <(C>)>) Method (entries, context)
Namespaces ► Sitecore.Install.Framework ► BaseConverter<(Of <(T>)>) ► ApplyTransforms<(Of <(C>)>)(C, IProcessingContext)
Applies the transform.
Declaration Syntax
C#
protected C ApplyTransforms<C>(
    C entries,
    IProcessingContext context
)
where C : Object, IEnumerable<PackageEntry>
Generic Template Parameters
C
Parameters
entries (C)
The entries.
context (IProcessingContext)
The context.


AutoApplyTransforms Property

AutoApplyTransforms Property
Namespaces ► Sitecore.Install.Framework ► BaseConverter<(Of <(T>)>) ► AutoApplyTransforms
Gets a value indicating whether the BaseConverter<(Of <(T>)>) converter transforms should be applied by BaseConverter, not the derived class.
Declaration Syntax
C#
protected virtual bool AutoApplyTransforms { get; }
Value
true if the BaseConverter<(Of <(T>)>) transforms should be applied by BaseConverter implicitly; otherwise, false.


Convert Method (entry, context)

Convert Method (entry, context)
Namespaces ► Sitecore.Install.Framework ► BaseConverter<(Of <(T>)>) ► Convert(T, IProcessingContext)
Converts the specified entry.
Declaration Syntax
C#
public PackageEntry[] Convert(
    T entry,
    IProcessingContext context
)
Parameters
entry (T)
The entry.
context (IProcessingContext)
The processing context.
Return Value
The conversion result.


GetAttribute Method (name)

GetAttribute Method (name)
Namespaces ► Sitecore.Install.Framework ► BaseConverter<(Of <(T>)>) ► GetAttribute(String)
Gets the value of the attribute.
Declaration Syntax
C#
public Object GetAttribute(
    string name
)
Parameters
name (String)
The attribute name.
Return Value
The value of the attribute.


InternalConvert Method (entry, context)

InternalConvert Method (entry, context)
Namespaces ► Sitecore.Install.Framework ► BaseConverter<(Of <(T>)>) ► InternalConvert(T, IProcessingContext)
Conversion method. Should be overriden.
Declaration Syntax
C#
protected abstract PackageEntry[] InternalConvert(
    T entry,
    IProcessingContext context
)
Parameters
entry (T)
The entry.
context (IProcessingContext)
The processing context.
Return Value
The conversion result.


SetAttribute Method (name, value)

SetAttribute Method (name, value)
Namespaces ► Sitecore.Install.Framework ► BaseConverter<(Of <(T>)>) ► SetAttribute(String, Object)
Sets the value of the attribute.
Declaration Syntax
C#
public void SetAttribute(
    string name,
    Object value
)
Parameters
name (String)
The attribute name.
value (Object)
The value.


Transforms Property

Transforms Property
Namespaces ► Sitecore.Install.Framework ► BaseConverter<(Of <(T>)>) ► Transforms
Gets the transforms.
Declaration Syntax
C#
public IList<IProcessor<PackageEntry>> Transforms { get; }
Value
The transforms.


BaseSink(T) Class

BaseSink<(Of <(T>)>) Class
Namespaces ► Sitecore.Install.Framework ► BaseSink<(Of <(T>)>)
BaseSink class
Declaration Syntax
C#
public abstract class BaseSink<T> : ISink<T>
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseSink<(Of <(T>)>)()()() | Initializes a new instance of the BaseSink<(Of <(T>)>) class
 | _processingContext |
 | AssertInit()()() | Asserts the init.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink.
 | Flush()()() | Flushes the sink
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance.
 | IsInitialized | Gets a value indicating whether this instance is initialized.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context.
 | Put(T) | Puts the specified entry.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink<(Of <(T>)>)
 |  | ExplicitFileSystemSource..::.Builder
 |  | RawFileSystemWriter
 |  | AdvancedBaseSink<(Of <(T, ContextType>)>)
 |  | BaseSource<(Of <(T>)>)..::.InternalSink
 |  | EntryBuilder
 |  | FilteringSink<(Of <(T>)>)
 |  | SinkDispatcher
 |  | ExplicitItemSource..::.Builder
 |  | ItemUninstaller
 |  | LegacyItemUnpacker
 |  | MetadataSink
 |  | PackageProject..::.Builder
 |  | AccountInstaller
 |  | EntrySorter
 |  | Uniq
 |  | PackageWriter


BaseSink(T) Constructor

BaseSink<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Install.Framework ► BaseSink<(Of <(T>)>) ► BaseSink<(Of <(T>)>)()()()
Initializes a new instance of the BaseSink<(Of <(T>)>) class
Declaration Syntax
C#
protected BaseSink()


_processingContext Field

_processingContext Field
Namespaces ► Sitecore.Install.Framework ► BaseSink<(Of <(T>)>) ► _processingContext
Declaration Syntax
C#
protected IProcessingContext _processingContext


AssertInit Method

AssertInit Method
Namespaces ► Sitecore.Install.Framework ► BaseSink<(Of <(T>)>) ► AssertInit()()()
Asserts the init.
Declaration Syntax
C#
protected void AssertInit()


Finish Method

Finish Method
Namespaces ► Sitecore.Install.Framework ► BaseSink<(Of <(T>)>) ► Finish()()()
Finishes the sink.
Declaration Syntax
C#
public virtual void Finish()


Flush Method

Flush Method
Namespaces ► Sitecore.Install.Framework ► BaseSink<(Of <(T>)>) ► Flush()()()
Flushes the sink
Declaration Syntax
C#
public virtual void Flush()


Initialize Method (context)

Initialize Method (context)
Namespaces ► Sitecore.Install.Framework ► BaseSink<(Of <(T>)>) ► Initialize(IProcessingContext)
Initializes this instance.
Declaration Syntax
C#
public virtual void Initialize(
    IProcessingContext context
)
Parameters
context (IProcessingContext)
The context.


IsInitialized Property

IsInitialized Property
Namespaces ► Sitecore.Install.Framework ► BaseSink<(Of <(T>)>) ► IsInitialized
Gets a value indicating whether this instance is initialized.
Declaration Syntax
C#
public bool IsInitialized { get; }
Value
true if this instance is initialized; otherwise, false.


ProcessingContext Property

ProcessingContext Property
Namespaces ► Sitecore.Install.Framework ► BaseSink<(Of <(T>)>) ► ProcessingContext
Gets the processing context.
Declaration Syntax
C#
public IProcessingContext ProcessingContext { get; }
Value
The processing context.


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Framework ► BaseSink<(Of <(T>)>) ► Put(T)
Puts the specified entry.
Declaration Syntax
C#
public abstract void Put(
    T entry
)
Parameters
entry (T)
The entry.


BaseSource(T) Class

BaseSource<(Of <(T>)>) Class
Namespaces ► Sitecore.Install.Framework ► BaseSource<(Of <(T>)>)
Implements basic source functionality
Declaration Syntax
C#
public abstract class BaseSource<T> : ISource<PackageEntry>,
    INamedObject, ISupportsFiltering, ISupportsTransforms<PackageEntry>
Generic Template Parameters
T
Entry type
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseSource<(Of <(T>)>)()()() | Initializes a new instance of the BaseSource<(Of <(T>)>) class
 | Converter | Gets or sets the converter.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exclude | Gets the exclude filters.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Include | Gets the include filters.
 | InternalPopulate(ISink<(Of <(T>)>)) | To be overridden in descendants
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name.
 | Populate(ISink<(Of <(PackageEntry>)>)) | Populates this sourse from the specified sink.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSource<(Of <(T>)>)
 |  | ExplicitFileSystemSource
 |  | FileSystemSource
 |  | ExplicitItemSource
 |  | ItemSource
 |  | PackageProject
 |  | SecuritySource


BaseSource(T) Constructor

BaseSource<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Install.Framework ► BaseSource<(Of <(T>)>) ► BaseSource<(Of <(T>)>)()()()
Initializes a new instance of the BaseSource<(Of <(T>)>) class
Declaration Syntax
C#
protected BaseSource()


Converter Property

Converter Property
Namespaces ► Sitecore.Install.Framework ► BaseSource<(Of <(T>)>) ► Converter
Gets or sets the converter.
Declaration Syntax
C#
public IConverter<T, PackageEntry> Converter { get; set; }
Value
The converter.


Exclude Property

Exclude Property
Namespaces ► Sitecore.Install.Framework ► BaseSource<(Of <(T>)>) ► Exclude
Gets the exclude filters.
Declaration Syntax
C#
public IList<IFilter> Exclude { get; }
Value
The exclude filters.


Include Property

Include Property
Namespaces ► Sitecore.Install.Framework ► BaseSource<(Of <(T>)>) ► Include
Gets the include filters.
Declaration Syntax
C#
public IList<IFilter> Include { get; }
Value
The include filters.


InternalPopulate Method (sink)

InternalPopulate Method (sink)
Namespaces ► Sitecore.Install.Framework ► BaseSource<(Of <(T>)>) ► InternalPopulate(ISink<(Of <(T>)>))
To be overridden in descendants
Declaration Syntax
C#
protected abstract void InternalPopulate(
    ISink<T> sink
)
Parameters
sink (ISink <(Of <( T >)>))
The sink


Name Property

Name Property
Namespaces ► Sitecore.Install.Framework ► BaseSource<(Of <(T>)>) ► Name
Gets or sets the name.
Declaration Syntax
C#
public string Name { get; set; }
Value
The name.


Populate Method (sink)

Populate Method (sink)
Namespaces ► Sitecore.Install.Framework ► BaseSource<(Of <(T>)>) ► Populate(ISink<(Of <(PackageEntry>)>))
Populates this sourse from the specified sink.
Declaration Syntax
C#
public virtual void Populate(
    ISink<PackageEntry> sink
)
Parameters
sink (ISink <(Of <( PackageEntry >)>))
The sink.


BaseSource(T).InternalSink Class

BaseSource<(Of <(T>)>)..::.InternalSink Class
Namespaces ► Sitecore.Install.Framework ► BaseSource<(Of <(T>)>) ► BaseSource<(Of <(T>)>)..::.InternalSink
Internal sink implementation
Declaration Syntax
C#
protected class InternalSink : BaseSink<T>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseSource<(Of <(T>)>)..::.InternalSink(BaseSource<(Of <(T>)>), ISink<(Of <(PackageEntry>)>)) | Initializes a new instance of the BaseSource<(Of <(T>)>)..::.InternalSink class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Inherited from BaseSink<(Of <(T>)>).)
 | Flush()()() | Flushes the sink (Overrides BaseSink <(Of <( T >)>).Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(T) | Puts the specified entry. (Overrides BaseSink <(Of <( T >)>).Put(T).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( T >)>)
 |  | BaseSource<(Of <(T>)>)..::.InternalSink


BaseSource(T).InternalSink Constructor (owner, sink)

BaseSource<(Of <(T>)>)..::.InternalSink Constructor (owner, sink)
Namespaces ► Sitecore.Install.Framework ► BaseSource<(Of <(T>)>)..::.InternalSink ► BaseSource<(Of <(T>)>)..::.InternalSink(BaseSource<(Of <(T>)>), ISink<(Of <(PackageEntry>)>))
Initializes a new instance of the BaseSource<(Of <(T>)>)..::.InternalSink class.
Declaration Syntax
C#
public InternalSink(
    BaseSource<T> owner,
    ISink<PackageEntry> sink
)
Parameters
owner (BaseSource <(Of <( T >)>))
The owner.
sink (ISink <(Of <( PackageEntry >)>))
The sink.


Flush Method

Flush Method
Namespaces ► Sitecore.Install.Framework ► BaseSource<(Of <(T>)>)..::.InternalSink ► Flush()()()
Flushes the sink
Declaration Syntax
C#
public override void Flush()


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Framework ► BaseSource<(Of <(T>)>)..::.InternalSink ► Put(T)
Puts the specified entry.
Declaration Syntax
C#
public override void Put(
    T entry
)
Parameters
entry (T)
The entry.


DefaultOutput Class

DefaultOutput Class
Namespaces ► Sitecore.Install.Framework ► DefaultOutput
Default output
Declaration Syntax
C#
public class DefaultOutput : ITaskOutput
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DefaultOutput()()() | Initializes a new instance of the DefaultOutput class
 | Alert(String) | Shows an alert form.
 | Confirm(String) | Shows the confirmation dialog.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ThreadStart) | Executes the callback asynchronuosly
 | Execute(Callback) | Executes the specified callback.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RunPipeline(PipelineCallback) | Executes the specified pipeline callback.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DefaultOutput


DefaultOutput Constructor

DefaultOutput Constructor
Namespaces ► Sitecore.Install.Framework ► DefaultOutput ► DefaultOutput()()()
Initializes a new instance of the DefaultOutput class
Declaration Syntax
C#
public DefaultOutput()


Alert Method (message)

Alert Method (message)
Namespaces ► Sitecore.Install.Framework ► DefaultOutput ► Alert(String)
Shows an alert form.
Declaration Syntax
C#
public void Alert(
    string message
)
Parameters
message (String)
The message.


Confirm Method (message)

Confirm Method (message)
Namespaces ► Sitecore.Install.Framework ► DefaultOutput ► Confirm(String)
Shows the confirmation dialog.
Declaration Syntax
C#
public string Confirm(
    string message
)
Parameters
message (String)
The message.
Return Value
The confirmation result.


Execute Method

Execute Method
Namespaces ► Sitecore.Install.Framework ► DefaultOutput ► Execute()()()
Members
Icon | Member | Description
 | Execute(ThreadStart) | Executes the callback asynchronuosly
 | Execute(Callback) | Executes the specified callback.


Execute Method (callback)

Execute Method (callback)
Namespaces ► Sitecore.Install.Framework ► DefaultOutput ► Execute(Callback)
Executes the specified callback.
Declaration Syntax
C#
public Object Execute(
    Callback callback
)
Parameters
callback (Callback)
The callback.
Return Value
The execute.


Execute Method (callback)

Execute Method (callback)
Namespaces ► Sitecore.Install.Framework ► DefaultOutput ► Execute(ThreadStart)
Executes the callback asynchronuosly
Declaration Syntax
C#
public void Execute(
    ThreadStart callback
)
Parameters
callback (ThreadStart)
The callback.


RunPipeline Method (callback)

RunPipeline Method (callback)
Namespaces ► Sitecore.Install.Framework ► DefaultOutput ► RunPipeline(PipelineCallback)
Executes the specified pipeline callback.
Declaration Syntax
C#
public Object RunPipeline(
    PipelineCallback callback
)
Parameters
callback (PipelineCallback)
The callback.
Return Value
The execute.


EntryBuilder Class

EntryBuilder Class
Namespaces ► Sitecore.Install.Framework ► EntryBuilder
Converts an IEntryData object to PackageEntry object and populates the internal sink with that package entry
Declaration Syntax
C#
public class EntryBuilder : BaseSink<IEntryData>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EntryBuilder(ISink<(Of <(PackageEntry>)>)) | Initializes a new instance of the EntryBuilder class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Overrides BaseSink <(Of <( IEntryData >)>).Finish()()().)
 | Flush()()() | Flushes the sink (Overrides BaseSink <(Of <( IEntryData >)>).Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(IEntryData) | Puts the specified entry. (Overrides BaseSink <(Of <( IEntryData >)>).Put(T).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( IEntryData >)>)
 |  | EntryBuilder


EntryBuilder Constructor (sink)

EntryBuilder Constructor (sink)
Namespaces ► Sitecore.Install.Framework ► EntryBuilder ► EntryBuilder(ISink<(Of <(PackageEntry>)>))
Initializes a new instance of the EntryBuilder class.
Declaration Syntax
C#
public EntryBuilder(
    ISink<PackageEntry> sink
)
Parameters
sink (ISink <(Of <( PackageEntry >)>))
The sink.


Finish Method

Finish Method
Namespaces ► Sitecore.Install.Framework ► EntryBuilder ► Finish()()()
Finishes the sink.
Declaration Syntax
C#
public override void Finish()


Flush Method

Flush Method
Namespaces ► Sitecore.Install.Framework ► EntryBuilder ► Flush()()()
Flushes the sink
Declaration Syntax
C#
public override void Flush()


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Framework ► EntryBuilder ► Put(IEntryData)
Puts the specified entry.
Declaration Syntax
C#
public override void Put(
    IEntryData entry
)
Parameters
entry (IEntryData)
The entry.


FilteringSink(T) Class

FilteringSink<(Of <(T>)>) Class
Namespaces ► Sitecore.Install.Framework ► FilteringSink<(Of <(T>)>)
A sink that applies filters and populates the result entries to wrapped sink
Declaration Syntax
C#
public class FilteringSink<T> : BaseSink<T>,
    ISupportsFiltering
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FilteringSink<(Of <(T>)>)(ISink<(Of <(T>)>)) | Initializes a new instance of the FilteringSink<(Of <(T>)>) class.
 | FilteringSink<(Of <(T>)>)(ISink<(Of <(T>)>), IList<(Of <(IFilter>)>), IList<(Of <(IFilter>)>)) | Initializes a new instance of the FilteringSink<(Of <(T>)>) class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exclude | Gets the exclude filters.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Inherited from BaseSink<(Of <(T>)>).)
 | Flush()()() | Flushes the sink (Overrides BaseSink <(Of <( T >)>).Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Include | Gets the include filters.
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(T) | Puts the specified entry to the sink if the entry satisfies the filters.
 | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(T>)>).)
 | Qualify(T) | Qualifies the specified entry.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( T >)>)
 |  | FilteringSink<(Of <(T>)>)


FilteringSink(T) Constructor

FilteringSink<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Install.Framework ► FilteringSink<(Of <(T>)>) ► FilteringSink<(Of <(T>)>)()()()
Members
Icon | Member | Description
 | FilteringSink<(Of <(T>)>)(ISink<(Of <(T>)>)) | Initializes a new instance of the FilteringSink<(Of <(T>)>) class.
 | FilteringSink<(Of <(T>)>)(ISink<(Of <(T>)>), IList<(Of <(IFilter>)>), IList<(Of <(IFilter>)>)) | Initializes a new instance of the FilteringSink<(Of <(T>)>) class.


FilteringSink(T) Constructor (sink)

FilteringSink<(Of <(T>)>) Constructor (sink)
Namespaces ► Sitecore.Install.Framework ► FilteringSink<(Of <(T>)>) ► FilteringSink<(Of <(T>)>)(ISink<(Of <(T>)>))
Initializes a new instance of the FilteringSink<(Of <(T>)>) class.
Declaration Syntax
C#
public FilteringSink(
    ISink<T> sink
)
Parameters
sink (ISink <(Of <( T >)>))
The inner sink.


FilteringSink(T) Constructor (sink, include, exclude)

FilteringSink<(Of <(T>)>) Constructor (sink, include, exclude)
Namespaces ► Sitecore.Install.Framework ► FilteringSink<(Of <(T>)>) ► FilteringSink<(Of <(T>)>)(ISink<(Of <(T>)>), IList<(Of <(IFilter>)>), IList<(Of <(IFilter>)>))
Initializes a new instance of the FilteringSink<(Of <(T>)>) class.
Declaration Syntax
C#
public FilteringSink(
    ISink<T> sink,
    IList<IFilter> include,
    IList<IFilter> exclude
)
Parameters
sink (ISink <(Of <( T >)>))
The inner sink.
include (IList<(Of <( IFilter >)>))
The include filters.
exclude (IList<(Of <( IFilter >)>))
The exclude filters.


Exclude Property

Exclude Property
Namespaces ► Sitecore.Install.Framework ► FilteringSink<(Of <(T>)>) ► Exclude
Gets the exclude filters.
Declaration Syntax
C#
public IList<IFilter> Exclude { get; }
Value
The exclude filters.


Flush Method

Flush Method
Namespaces ► Sitecore.Install.Framework ► FilteringSink<(Of <(T>)>) ► Flush()()()
Flushes the sink
Declaration Syntax
C#
public override void Flush()


Include Property

Include Property
Namespaces ► Sitecore.Install.Framework ► FilteringSink<(Of <(T>)>) ► Include
Gets the include filters.
Declaration Syntax
C#
public IList<IFilter> Include { get; }
Value
The include filters.


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Framework ► FilteringSink<(Of <(T>)>) ► Put(T)
Puts the specified entry to the sink if the entry satisfies the filters.
Declaration Syntax
C#
public virtual void Put(
    T entry
)
Parameters
entry (T)
The entry.


Qualify Method (entry)

Qualify Method (entry)
Namespaces ► Sitecore.Install.Framework ► FilteringSink<(Of <(T>)>) ► Qualify(T)
Qualifies the specified entry.
Declaration Syntax
C#
protected virtual bool Qualify(
    T entry
)
Parameters
entry (T)
The entry.
Return Value
The qualify.


IAspectContainer Interface

IAspectContainer Interface
Namespaces ► Sitecore.Install.Framework ► IAspectContainer
IAspectContainer interface
Declaration Syntax
C#
public interface IAspectContainer
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddAspect<(Of <(T>)>)(T) | Adds the aspect.
 | GetAspect<(Of <(T>)>)()()() | Gets the aspect.
 | HasAspect<(Of <(T>)>)()()() | Determines whether this instance has aspect.


AddAspect Method (instance)

AddAspect<(Of <(T>)>) Method (instance)
Namespaces ► Sitecore.Install.Framework ► IAspectContainer ► AddAspect<(Of <(T>)>)(T)
Adds the aspect.
Declaration Syntax
C#
void AddAspect<T>(
    T instance
)
where T : class
Generic Template Parameters
T
Parameters
instance (T)
The instance.


GetAspect Method

GetAspect<(Of <(T>)>) Method
Namespaces ► Sitecore.Install.Framework ► IAspectContainer ► GetAspect<(Of <(T>)>)()()()
Gets the aspect.
Declaration Syntax
C#
T GetAspect<T>()
where T : class
Generic Template Parameters
T
Return Value
The aspect.


HasAspect Method

HasAspect<(Of <(T>)>) Method
Namespaces ► Sitecore.Install.Framework ► IAspectContainer ► HasAspect<(Of <(T>)>)()()()
Determines whether this instance has aspect.
Declaration Syntax
C#
bool HasAspect<T>()
where T : class
Generic Template Parameters
T
Return Value
true if this instance has aspect; otherwise, false.


IConverter(T, K) Interface

IConverter<(Of <(T, K>)>) Interface
Namespaces ► Sitecore.Install.Framework ► IConverter<(Of <(T, K>)>)
Defines a method to transorm some objects
Declaration Syntax
C#
public interface IConverter<T, K> : ISupportsTransforms<K>,
    ISupportsAttributes
Generic Template Parameters
T
Source type
K
Transformation result type
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Convert(T, IProcessingContext) | Converts the specified entry.
 | GetAttribute(String) | Gets the value of the attribute. (Inherited from ISupportsAttributes.)
 | SetAttribute(String, Object) | Sets the value of the attribute. (Inherited from ISupportsAttributes.)
 | Transforms | Gets the transforms. (Inherited from ISupportsTransforms<(Of <(T>)>).)


Convert Method (entry, context)

Convert Method (entry, context)
Namespaces ► Sitecore.Install.Framework ► IConverter<(Of <(T, K>)>) ► Convert(T, IProcessingContext)
Converts the specified entry.
Declaration Syntax
C#
K[] Convert(
    T entry,
    IProcessingContext context
)
Parameters
entry (T)
The entry.
context (IProcessingContext)
The processing context.
Return Value
The conversion result.


IEntryData Interface

IEntryData Interface
Namespaces ► Sitecore.Install.Framework ► IEntryData
Basic methods and properties for an entry
Declaration Syntax
C#
public interface IEntryData
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetStream()()() | Gets the stream holder.
 | Key | Gets the key.


GetStream Method

GetStream Method
Namespaces ► Sitecore.Install.Framework ► IEntryData ► GetStream()()()
Gets the stream holder.
Declaration Syntax
C#
IStreamHolder GetStream()
Return Value
The stream holder.


Key Property

Key Property
Namespaces ► Sitecore.Install.Framework ► IEntryData ► Key
Gets the key.
Declaration Syntax
C#
string Key { get; }
Value
The key.


IExplicitSource Interface

IExplicitSource Interface
Namespaces ► Sitecore.Install.Framework ► IExplicitSource
Defines basic properties of an explicit source
Declaration Syntax
C#
public interface IExplicitSource : IKeyResolver
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Entries | Gets the entries.
 | ResolveKey(String) | Resolves the key. (Inherited from IKeyResolver.)


Entries Property

Entries Property
Namespaces ► Sitecore.Install.Framework ► IExplicitSource ► Entries
Gets the entries.
Declaration Syntax
C#
IList<string> Entries { get; }
Value
The entries.


IFilter Interface

IFilter Interface
Namespaces ► Sitecore.Install.Framework ► IFilter
Defines basic methods and properties for a filer
Declaration Syntax
C#
public interface IFilter
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | Qualify(Object, IProcessingContext) | Qualifies the specified instance.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Install.Framework ► IFilter ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


Qualify Method (instance, context)

Qualify Method (instance, context)
Namespaces ► Sitecore.Install.Framework ► IFilter ► Qualify(Object, IProcessingContext)
Qualifies the specified instance.
Declaration Syntax
C#
bool Qualify(
    Object instance,
    IProcessingContext context
)
Parameters
instance (Object)
The instance.
context (IProcessingContext)
The processing context.
Return Value
Qualification result.


IKeyResolver Interface

IKeyResolver Interface
Namespaces ► Sitecore.Install.Framework ► IKeyResolver
Defines a basic methods of a key resolver
Declaration Syntax
C#
public interface IKeyResolver
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ResolveKey(String) | Resolves the key.


ResolveKey Method (key)

ResolveKey Method (key)
Namespaces ► Sitecore.Install.Framework ► IKeyResolver ► ResolveKey(String)
Resolves the key.
Declaration Syntax
C#
Object ResolveKey(
    string key
)
Parameters
key (String)
The key.
Return Value
The object.


INamedObject Interface

INamedObject Interface
Namespaces ► Sitecore.Install.Framework ► INamedObject
Defines a "name" property
Declaration Syntax
C#
public interface INamedObject
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Name | Gets or sets the name.


Name Property

Name Property
Namespaces ► Sitecore.Install.Framework ► INamedObject ► Name
Gets or sets the name.
Declaration Syntax
C#
string Name { get; set; }
Value
The name.


InstallPolicy Enumeration

InstallPolicy Enumeration
Namespaces ► Sitecore.Install.Framework ► InstallPolicy
Define what to do with the item collision
Declaration Syntax
C#
[FlagsAttribute]
public enum InstallPolicy
Members
Member | Description
Overwrite | Item should be overwritten
Append | A verstion should be append
Skip | A version should be skipped


IPostStep Interface

IPostStep Interface
Namespaces ► Sitecore.Install.Framework ► IPostStep
Mefines a basic method of a post step
Declaration Syntax
C#
public interface IPostStep
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Run(ITaskOutput, NameValueCollection) | Runs this post step


Run Method (output, metaData)

Run Method (output, metaData)
Namespaces ► Sitecore.Install.Framework ► IPostStep ► Run(ITaskOutput, NameValueCollection)
Runs this post step
Declaration Syntax
C#
void Run(
    ITaskOutput output,
    NameValueCollection metaData
)
Parameters
output (ITaskOutput)
The output.
metaData (NameValueCollection)
The meta data.


IProcessingContext Interface

IProcessingContext Interface
Namespaces ► Sitecore.Install.Framework ► IProcessingContext
Defines basic methods and properties of a processing context
Declaration Syntax
C#
public interface IProcessingContext : IAspectContainer
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddAspect<(Of <(T>)>)(T) | Adds the aspect. (Inherited from IAspectContainer.)
 | Data | Gets the data.
 | GetAspect<(Of <(T>)>)()()() | Gets the aspect. (Inherited from IAspectContainer.)
 | HasAspect<(Of <(T>)>)()()() | Determines whether this instance has aspect. (Inherited from IAspectContainer.)
 | Log | Gets the logger.
 | MapDatabase(String) | Return the mapped database for the specified database.
 | ObjectNotFound(String, String) | Actions to perform when source cannot add an find the object to add to the package.
 | Output | Gets the output.
 | PostActions | Gets the post actions.
 | ShowSourceInfo | Gets or sets a value indicating whether the IProcessingContext shows the source info.
 | SkipCompression | Gets or sets a value indicating whether the IProcessingContext skips the compression.
 | SkipData | Gets or sets a value indicating whether the IProcessingContext skips the data.
 | SkipProperties | Gets or sets a value indicating whether the IProcessingContext skips the properties.
 | TaskID | Gets the unique task ID. Can be used in workers to derive task-specific object names.


Data Property

Data Property
Namespaces ► Sitecore.Install.Framework ► IProcessingContext ► Data
Gets the data.
Declaration Syntax
C#
IDictionary<string, Object> Data { get; }
Value
The data.


Log Property

Log Property
Namespaces ► Sitecore.Install.Framework ► IProcessingContext ► Log
Gets the logger.
Declaration Syntax
C#
ILogger Log { get; }
Value
The logger.


MapDatabase Method (database)

MapDatabase Method (database)
Namespaces ► Sitecore.Install.Framework ► IProcessingContext ► MapDatabase(String)
Return the mapped database for the specified database.
Declaration Syntax
C#
string MapDatabase(
    string database
)
Parameters
database (String)
The database.
Return Value
The mapped database.


ObjectNotFound Method (key, description)

ObjectNotFound Method (key, description)
Namespaces ► Sitecore.Install.Framework ► IProcessingContext ► ObjectNotFound(String, String)
Actions to perform when source cannot add an find the object to add to the package.
Declaration Syntax
C#
void ObjectNotFound(
    string key,
    string description
)
Parameters
key (String)
The key.
description (String)
The description.


Output Property

Output Property
Namespaces ► Sitecore.Install.Framework ► IProcessingContext ► Output
Gets the output.
Declaration Syntax
C#
ITaskOutput Output { get; }
Value
The output.


PostActions Property

PostActions Property
Namespaces ► Sitecore.Install.Framework ► IProcessingContext ► PostActions
Gets the post actions.
Declaration Syntax
C#
IList<IProcessor<IProcessingContext>> PostActions { get; }
Value
The post actions.


ShowSourceInfo Property

ShowSourceInfo Property
Namespaces ► Sitecore.Install.Framework ► IProcessingContext ► ShowSourceInfo
Gets or sets a value indicating whether the IProcessingContext shows the source info.
Declaration Syntax
C#
bool ShowSourceInfo { get; set; }
Value
true if the IProcessingContext shows the source info; otherwise, false.


SkipCompression Property

SkipCompression Property
Namespaces ► Sitecore.Install.Framework ► IProcessingContext ► SkipCompression
Gets or sets a value indicating whether the IProcessingContext skips the compression.
Declaration Syntax
C#
bool SkipCompression { get; set; }
Value
true if the IProcessingContext skips the compression; otherwise, false.


SkipData Property

SkipData Property
Namespaces ► Sitecore.Install.Framework ► IProcessingContext ► SkipData
Gets or sets a value indicating whether the IProcessingContext skips the data.
Declaration Syntax
C#
bool SkipData { get; set; }
Value
true if the IProcessingContext skips the data; otherwise, false.


SkipProperties Property

SkipProperties Property
Namespaces ► Sitecore.Install.Framework ► IProcessingContext ► SkipProperties
Gets or sets a value indicating whether the IProcessingContext skips the properties.
Declaration Syntax
C#
bool SkipProperties { get; set; }
Value
true if the IProcessingContext skips the properties; otherwise, false.


TaskID Property

TaskID Property
Namespaces ► Sitecore.Install.Framework ► IProcessingContext ► TaskID
Gets the unique task ID. Can be used in workers to derive task-specific object names.
Declaration Syntax
C#
string TaskID { get; }
Value
The task ID.


IProcessor(T) Interface

IProcessor<(Of <(T>)>) Interface
Namespaces ► Sitecore.Install.Framework ► IProcessor<(Of <(T>)>)
Defines basic methods of a processor
Declaration Syntax
C#
public interface IProcessor<T>
Generic Template Parameters
T
Entry type
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Process(T, IProcessingContext) | Runs the processor.


Process Method (entry, context)

Process Method (entry, context)
Namespaces ► Sitecore.Install.Framework ► IProcessor<(Of <(T>)>) ► Process(T, IProcessingContext)
Runs the processor.
Declaration Syntax
C#
void Process(
    T entry,
    IProcessingContext context
)
Parameters
entry (T)
The entry.
context (IProcessingContext)
The processing context.


ISink(T) Interface

ISink<(Of <(T>)>) Interface
Namespaces ► Sitecore.Install.Framework ► ISink<(Of <(T>)>)
Defines basic methods for a sink
Declaration Syntax
C#
public interface ISink<T>
Generic Template Parameters
T
Type of entry
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Finish()()() | Finishes the sink.
 | Flush()()() | Flushes the sink
 | Initialize(IProcessingContext) | Initializes the specified context.
 | IsInitialized | Gets a value indicating whether this instance is initialized.
 | ProcessingContext | Gets the processing context.
 | Put(T) | Puts the specified entry.


Finish Method

Finish Method
Namespaces ► Sitecore.Install.Framework ► ISink<(Of <(T>)>) ► Finish()()()
Finishes the sink.
Declaration Syntax
C#
void Finish()


Flush Method

Flush Method
Namespaces ► Sitecore.Install.Framework ► ISink<(Of <(T>)>) ► Flush()()()
Flushes the sink
Declaration Syntax
C#
void Flush()


Initialize Method (context)

Initialize Method (context)
Namespaces ► Sitecore.Install.Framework ► ISink<(Of <(T>)>) ► Initialize(IProcessingContext)
Initializes the specified context.
Declaration Syntax
C#
void Initialize(
    IProcessingContext context
)
Parameters
context (IProcessingContext)
The context.


IsInitialized Property

IsInitialized Property
Namespaces ► Sitecore.Install.Framework ► ISink<(Of <(T>)>) ► IsInitialized
Gets a value indicating whether this instance is initialized.
Declaration Syntax
C#
bool IsInitialized { get; }
Value
true if this instance is initialized; otherwise, false.


ProcessingContext Property

ProcessingContext Property
Namespaces ► Sitecore.Install.Framework ► ISink<(Of <(T>)>) ► ProcessingContext
Gets the processing context.
Declaration Syntax
C#
IProcessingContext ProcessingContext { get; }
Value
The processing context.


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Framework ► ISink<(Of <(T>)>) ► Put(T)
Puts the specified entry.
Declaration Syntax
C#
void Put(
    T entry
)
Parameters
entry (T)
The entry.


ISortingKeyProvider Interface

ISortingKeyProvider Interface
Namespaces ► Sitecore.Install.Framework ► ISortingKeyProvider
Defines basic methods of sorting key provider
Declaration Syntax
C#
public interface ISortingKeyProvider
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetKey(String) | Gets the key.


GetKey Method (key)

GetKey Method (key)
Namespaces ► Sitecore.Install.Framework ► ISortingKeyProvider ► GetKey(String)
Gets the key.
Declaration Syntax
C#
SortingKey GetKey(
    string key
)
Parameters
key (String)
The key.
Return Value
The key.


ISource(T) Interface

ISource<(Of <(T>)>) Interface
Namespaces ► Sitecore.Install.Framework ► ISource<(Of <(T>)>)
Defines basic methods for a source
Declaration Syntax
C#
public interface ISource<T>
Generic Template Parameters
T
Entry type
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Populate(ISink<(Of <(T>)>)) | Populates specified sink from this sourse.


Populate Method (sink)

Populate Method (sink)
Namespaces ► Sitecore.Install.Framework ► ISource<(Of <(T>)>) ► Populate(ISink<(Of <(T>)>))
Populates specified sink from this sourse.
Declaration Syntax
C#
void Populate(
    ISink<T> sink
)
Parameters
sink (ISink <(Of <( T >)>))
The sink.


IStreamHolder Interface

IStreamHolder Interface
Namespaces ► Sitecore.Install.Framework ► IStreamHolder
Defines a property to get a stream
Declaration Syntax
C#
public interface IStreamHolder : IDisposable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | Stream | Gets the stream.


Stream Property

Stream Property
Namespaces ► Sitecore.Install.Framework ► IStreamHolder ► Stream
Gets the stream.
Declaration Syntax
C#
Stream Stream { get; }
Value
The stream.


IStreamProvider Interface

IStreamProvider Interface
Namespaces ► Sitecore.Install.Framework ► IStreamProvider
Defines basic methods of a stream provider
Declaration Syntax
C#
public interface IStreamProvider
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetStream(String) | Gets the stream by its name.


GetStream Method (name)

GetStream Method (name)
Namespaces ► Sitecore.Install.Framework ► IStreamProvider ► GetStream(String)
Gets the stream by its name.
Declaration Syntax
C#
Stream GetStream(
    string name
)
Parameters
name (String)
The name of the stream.
Return Value
The stream.


ISupportsAttributes Interface

ISupportsAttributes Interface
Namespaces ► Sitecore.Install.Framework ► ISupportsAttributes
Defines methods to get/set attributes
Declaration Syntax
C#
public interface ISupportsAttributes
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetAttribute(String) | Gets the value of the attribute.
 | SetAttribute(String, Object) | Sets the value of the attribute.


GetAttribute Method (name)

GetAttribute Method (name)
Namespaces ► Sitecore.Install.Framework ► ISupportsAttributes ► GetAttribute(String)
Gets the value of the attribute.
Declaration Syntax
C#
Object GetAttribute(
    string name
)
Parameters
name (String)
The attribute name.
Return Value
The value of the attribute.


SetAttribute Method (name, value)

SetAttribute Method (name, value)
Namespaces ► Sitecore.Install.Framework ► ISupportsAttributes ► SetAttribute(String, Object)
Sets the value of the attribute.
Declaration Syntax
C#
void SetAttribute(
    string name,
    Object value
)
Parameters
name (String)
The attribute name.
value (Object)
The value.


ISupportsFiltering Interface

ISupportsFiltering Interface
Namespaces ► Sitecore.Install.Framework ► ISupportsFiltering
Defines properties to get filters
Declaration Syntax
C#
public interface ISupportsFiltering
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Exclude | Gets the exclude filters.
 | Include | Gets the include filters.


Exclude Property

Exclude Property
Namespaces ► Sitecore.Install.Framework ► ISupportsFiltering ► Exclude
Gets the exclude filters.
Declaration Syntax
C#
IList<IFilter> Exclude { get; }
Value
The exclude filters.


Include Property

Include Property
Namespaces ► Sitecore.Install.Framework ► ISupportsFiltering ► Include
Gets the include filters.
Declaration Syntax
C#
IList<IFilter> Include { get; }
Value
The include filters.


ISupportsTransforms(T) Interface

ISupportsTransforms<(Of <(T>)>) Interface
Namespaces ► Sitecore.Install.Framework ► ISupportsTransforms<(Of <(T>)>)
Defines a property to get transforms
Declaration Syntax
C#
public interface ISupportsTransforms<T>
Generic Template Parameters
T
Type of object to be processed
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Transforms | Gets the transforms.


Transforms Property

Transforms Property
Namespaces ► Sitecore.Install.Framework ► ISupportsTransforms<(Of <(T>)>) ► Transforms
Gets the transforms.
Declaration Syntax
C#
IList<IProcessor<T>> Transforms { get; }
Value
The transforms.


ITaskOutput Interface

ITaskOutput Interface
Namespaces ► Sitecore.Install.Framework ► ITaskOutput
Defines basic methods to work with UI in another thread
Declaration Syntax
C#
public interface ITaskOutput
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Alert(String) | Shows an alert form.
 | Confirm(String) | Shows the confirmation dialog.
 | Execute(ThreadStart) | Executes the callback asynchronuosly
 | Execute(Callback) | Executes the specified callback.
 | RunPipeline(PipelineCallback) | Executes the specified pipeline callback.


Alert Method (message)

Alert Method (message)
Namespaces ► Sitecore.Install.Framework ► ITaskOutput ► Alert(String)
Shows an alert form.
Declaration Syntax
C#
void Alert(
    string message
)
Parameters
message (String)
The message.


Confirm Method (message)

Confirm Method (message)
Namespaces ► Sitecore.Install.Framework ► ITaskOutput ► Confirm(String)
Shows the confirmation dialog.
Declaration Syntax
C#
string Confirm(
    string message
)
Parameters
message (String)
The message.
Return Value
The confirmation result.


Execute Method

Execute Method
Namespaces ► Sitecore.Install.Framework ► ITaskOutput ► Execute()()()
Members
Icon | Member | Description
 | Execute(ThreadStart) | Executes the callback asynchronuosly
 | Execute(Callback) | Executes the specified callback.


Execute Method (callback)

Execute Method (callback)
Namespaces ► Sitecore.Install.Framework ► ITaskOutput ► Execute(Callback)
Executes the specified callback.
Declaration Syntax
C#
Object Execute(
    Callback callback
)
Parameters
callback (Callback)
The callback.
Return Value
The execute.


Execute Method (callback)

Execute Method (callback)
Namespaces ► Sitecore.Install.Framework ► ITaskOutput ► Execute(ThreadStart)
Executes the callback asynchronuosly
Declaration Syntax
C#
void Execute(
    ThreadStart callback
)
Parameters
callback (ThreadStart)
The callback.


RunPipeline Method (callback)

RunPipeline Method (callback)
Namespaces ► Sitecore.Install.Framework ► ITaskOutput ► RunPipeline(PipelineCallback)
Executes the specified pipeline callback.
Declaration Syntax
C#
Object RunPipeline(
    PipelineCallback callback
)
Parameters
callback (PipelineCallback)
The callback.
Return Value
The execute.


NullOutput Class

NullOutput Class
Namespaces ► Sitecore.Install.Framework ► NullOutput
A "stab" task output
Declaration Syntax
C#
public class NullOutput : ITaskOutput
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NullOutput()()() | Initializes a new instance of the NullOutput class
 | Alert(String) | Shows an alert form.
 | Confirm(String) | Shows the confirmation dialog.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ThreadStart) | Executes the callback asynchronuosly
 | Execute(Callback) | Executes the specified callback.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PutMessage(String, array<Object>[]()[]) | Puts the message.
 | RunPipeline(PipelineCallback) | Executes the specified pipeline callback.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NullOutput


NullOutput Constructor

NullOutput Constructor
Namespaces ► Sitecore.Install.Framework ► NullOutput ► NullOutput()()()
Initializes a new instance of the NullOutput class
Declaration Syntax
C#
public NullOutput()


Alert Method (message)

Alert Method (message)
Namespaces ► Sitecore.Install.Framework ► NullOutput ► Alert(String)
Shows an alert form.
Declaration Syntax
C#
public void Alert(
    string message
)
Parameters
message (String)
The message.


Confirm Method (message)

Confirm Method (message)
Namespaces ► Sitecore.Install.Framework ► NullOutput ► Confirm(String)
Shows the confirmation dialog.
Declaration Syntax
C#
public string Confirm(
    string message
)
Parameters
message (String)
The message.
Return Value
The confirmation result.


Execute Method

Execute Method
Namespaces ► Sitecore.Install.Framework ► NullOutput ► Execute()()()
Members
Icon | Member | Description
 | Execute(ThreadStart) | Executes the callback asynchronuosly
 | Execute(Callback) | Executes the specified callback.


Execute Method (callback)

Execute Method (callback)
Namespaces ► Sitecore.Install.Framework ► NullOutput ► Execute(Callback)
Executes the specified callback.
Declaration Syntax
C#
public Object Execute(
    Callback callback
)
Parameters
callback (Callback)
The callback.
Return Value
The execute.


Execute Method (callback)

Execute Method (callback)
Namespaces ► Sitecore.Install.Framework ► NullOutput ► Execute(ThreadStart)
Executes the callback asynchronuosly
Declaration Syntax
C#
public void Execute(
    ThreadStart callback
)
Parameters
callback (ThreadStart)
The callback.


PutMessage Method (message, args)

PutMessage Method (message, args)
Namespaces ► Sitecore.Install.Framework ► NullOutput ► PutMessage(String, array<Object>[]()[])
Puts the message.
Declaration Syntax
C#
public void PutMessage(
    string message,
    params Object[] args
)
Parameters
message (String)
The message.
args (array< Object >[]()[])
The arguments.


RunPipeline Method (callback)

RunPipeline Method (callback)
Namespaces ► Sitecore.Install.Framework ► NullOutput ► RunPipeline(PipelineCallback)
Executes the specified pipeline callback.
Declaration Syntax
C#
public Object RunPipeline(
    PipelineCallback callback
)
Parameters
callback (PipelineCallback)
The callback.
Return Value
The execute.


PackageEntry Class

PackageEntry Class
Namespaces ► Sitecore.Install.Framework ► PackageEntry
Represents a package entry
Declaration Syntax
C#
public class PackageEntry
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PackageEntry(IEntryData) | Initializes a new instance of the PackageEntry class.
 | PackageEntry(IEntryData, IDictionary<(Of <(String, String>)>), IDictionary<(Of <(String, String>)>)) | Initializes a new instance of the PackageEntry class.
 | Attributes | Volatile values, handled by objects in the current processing session
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStream()()() | Gets the stream holder.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Properties | Persistent values, stored along the entry in package file
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PackageEntry


PackageEntry Constructor

PackageEntry Constructor
Namespaces ► Sitecore.Install.Framework ► PackageEntry ► PackageEntry()()()
Members
Icon | Member | Description
 | PackageEntry(IEntryData) | Initializes a new instance of the PackageEntry class.
 | PackageEntry(IEntryData, IDictionary<(Of <(String, String>)>), IDictionary<(Of <(String, String>)>)) | Initializes a new instance of the PackageEntry class.


PackageEntry Constructor (data)

PackageEntry Constructor (data)
Namespaces ► Sitecore.Install.Framework ► PackageEntry ► PackageEntry(IEntryData)
Initializes a new instance of the PackageEntry class.
Declaration Syntax
C#
public PackageEntry(
    IEntryData data
)
Parameters
data (IEntryData)
The data.


PackageEntry Constructor (data, attributes, properties)

PackageEntry Constructor (data, attributes, properties)
Namespaces ► Sitecore.Install.Framework ► PackageEntry ► PackageEntry(IEntryData, IDictionary<(Of <(String, String>)>), IDictionary<(Of <(String, String>)>))
Initializes a new instance of the PackageEntry class.
Declaration Syntax
C#
public PackageEntry(
    IEntryData data,
    IDictionary<string, string> attributes,
    IDictionary<string, string> properties
)
Parameters
data (IEntryData)
The entry data.
attributes (IDictionary<(Of <(String, String>)>))
The attributes.
properties (IDictionary<(Of <(String, String>)>))
The properties.


Attributes Property

Attributes Property
Namespaces ► Sitecore.Install.Framework ► PackageEntry ► Attributes
Volatile values, handled by objects in the current processing session
Declaration Syntax
C#
public IDictionary<string, string> Attributes { get; }


GetStream Method

GetStream Method
Namespaces ► Sitecore.Install.Framework ► PackageEntry ► GetStream()()()
Gets the stream holder.
Declaration Syntax
C#
public IStreamHolder GetStream()
Return Value
The stream holder.


Key Property

Key Property
Namespaces ► Sitecore.Install.Framework ► PackageEntry ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


Properties Property

Properties Property
Namespaces ► Sitecore.Install.Framework ► PackageEntry ► Properties
Persistent values, stored along the entry in package file
Declaration Syntax
C#
public IDictionary<string, string> Properties { get; }


PropertySetter Class

PropertySetter Class
Namespaces ► Sitecore.Install.Framework ► PropertySetter
Represents a processor which is setting the properties of entries
Declaration Syntax
C#
public class PropertySetter : IProcessor<PackageEntry>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PropertySetter()()() | Initializes a new instance of the PropertySetter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PackageEntry, IProcessingContext) | Runs the processor.
 | Properties | Gets the properties.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PropertySetter


PropertySetter Constructor

PropertySetter Constructor
Namespaces ► Sitecore.Install.Framework ► PropertySetter ► PropertySetter()()()
Initializes a new instance of the PropertySetter class
Declaration Syntax
C#
public PropertySetter()


Process Method (entry, context)

Process Method (entry, context)
Namespaces ► Sitecore.Install.Framework ► PropertySetter ► Process(PackageEntry, IProcessingContext)
Runs the processor.
Declaration Syntax
C#
public void Process(
    PackageEntry entry,
    IProcessingContext context
)
Parameters
entry (PackageEntry)
The entry.
context (IProcessingContext)
The processing context.


Properties Property

Properties Property
Namespaces ► Sitecore.Install.Framework ► PropertySetter ► Properties
Gets the properties.
Declaration Syntax
C#
public IDictionary Properties { get; }
Value
The properties.


SimpleKeyProvider Class

SimpleKeyProvider Class
Namespaces ► Sitecore.Install.Framework ► SimpleKeyProvider
Simple key provider
Declaration Syntax
C#
public class SimpleKeyProvider : ISortingKeyProvider
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SimpleKeyProvider()()() | Initializes a new instance of the SimpleKeyProvider class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKey(String) | Gets the key.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SimpleKeyProvider


SimpleKeyProvider Constructor

SimpleKeyProvider Constructor
Namespaces ► Sitecore.Install.Framework ► SimpleKeyProvider ► SimpleKeyProvider()()()
Initializes a new instance of the SimpleKeyProvider class
Declaration Syntax
C#
public SimpleKeyProvider()


GetKey Method (key)

GetKey Method (key)
Namespaces ► Sitecore.Install.Framework ► SimpleKeyProvider ► GetKey(String)
Gets the key.
Declaration Syntax
C#
public SortingKey GetKey(
    string key
)
Parameters
key (String)
The key.
Return Value
The key.


SimpleProcessingContext Class

SimpleProcessingContext Class
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext
Simple processing context
Declaration Syntax
C#
public class SimpleProcessingContext : AspectBase,
    IProcessingContext, IAspectContainer
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SimpleProcessingContext()()() | Initializes a new instance of the SimpleProcessingContext class.
 | SimpleProcessingContext(ITaskOutput) | Initializes a new instance of the SimpleProcessingContext class.
 | AddAspect<(Of <(T>)>)(T) | Adds the aspect. (Inherited from AspectBase.)
 | Data | Gets the data.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAspect<(Of <(T>)>)()()() | Gets the aspect. (Inherited from AspectBase.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAspect<(Of <(T>)>)()()() | Determines whether this instance has aspect. (Inherited from AspectBase.)
 | Log | Gets the logger.
 | MapDatabase(String) | Returns the mapped database for the specified database.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ObjectNotFound(String, String) | An action on objects the not found.
 | Output | Gets the output.
 | PostActions | Gets the post actions.
 | ShowSourceInfo | Gets or sets a value indicating whether the IProcessingContext shows the source info.
 | SkipCompression | Gets or sets a value indicating whether the IProcessingContext skips the compression.
 | SkipData | Gets or sets a value indicating whether the IProcessingContext skips the data.
 | SkipErrors | Gets or sets a value indicating whether error should be skipped.
 | SkipProperties | Gets or sets a value indicating whether the IProcessingContext skips the properties.
 | TaskID | Gets the unique task ID. Can be used in workers to derive task-specific object names.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | AspectBase
 |  | SimpleProcessingContext


SimpleProcessingContext Constructor

SimpleProcessingContext Constructor
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► SimpleProcessingContext()()()
Members
Icon | Member | Description
 | SimpleProcessingContext()()() | Initializes a new instance of the SimpleProcessingContext class.
 | SimpleProcessingContext(ITaskOutput) | Initializes a new instance of the SimpleProcessingContext class.


SimpleProcessingContext Constructor

SimpleProcessingContext Constructor
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► SimpleProcessingContext()()()
Initializes a new instance of the SimpleProcessingContext class.
Declaration Syntax
C#
public SimpleProcessingContext()


SimpleProcessingContext Constructor (output)

SimpleProcessingContext Constructor (output)
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► SimpleProcessingContext(ITaskOutput)
Initializes a new instance of the SimpleProcessingContext class.
Declaration Syntax
C#
public SimpleProcessingContext(
    ITaskOutput output
)
Parameters
output (ITaskOutput)
The task output.


Data Property

Data Property
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► Data
Gets the data.
Declaration Syntax
C#
public IDictionary<string, Object> Data { get; }
Value
The data.


Log Property

Log Property
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► Log
Gets the logger.
Declaration Syntax
C#
public ILogger Log { get; }
Value
The logger.


MapDatabase Method (database)

MapDatabase Method (database)
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► MapDatabase(String)
Returns the mapped database for the specified database.
Declaration Syntax
C#
public virtual string MapDatabase(
    string database
)
Parameters
database (String)
The database.
Return Value
The mapped database.


ObjectNotFound Method (key, description)

ObjectNotFound Method (key, description)
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► ObjectNotFound(String, String)
An action on objects the not found.
Declaration Syntax
C#
public void ObjectNotFound(
    string key,
    string description
)
Parameters
key (String)
The key.
description (String)
The description.


Output Property

Output Property
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► Output
Gets the output.
Declaration Syntax
C#
public ITaskOutput Output { get; }
Value
The output.


PostActions Property

PostActions Property
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► PostActions
Gets the post actions.
Declaration Syntax
C#
public IList<IProcessor<IProcessingContext>> PostActions { get; }
Value
The post actions.


ShowSourceInfo Property

ShowSourceInfo Property
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► ShowSourceInfo
Gets or sets a value indicating whether the IProcessingContext shows the source info.
Declaration Syntax
C#
public bool ShowSourceInfo { get; set; }
Value
true if the IProcessingContext shows the source info; otherwise, false.


SkipCompression Property

SkipCompression Property
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► SkipCompression
Gets or sets a value indicating whether the IProcessingContext skips the compression.
Declaration Syntax
C#
public bool SkipCompression { get; set; }
Value
true if the IProcessingContext skips the compression; otherwise, false.


SkipData Property

SkipData Property
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► SkipData
Gets or sets a value indicating whether the IProcessingContext skips the data.
Declaration Syntax
C#
public bool SkipData { get; set; }
Value
true if the IProcessingContext skips the data; otherwise, false.


SkipErrors Property

SkipErrors Property
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► SkipErrors
Gets or sets a value indicating whether error should be skipped.
Declaration Syntax
C#
public bool SkipErrors { get; set; }
Value
true if [skip errors]; otherwise, false.


SkipProperties Property

SkipProperties Property
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► SkipProperties
Gets or sets a value indicating whether the IProcessingContext skips the properties.
Declaration Syntax
C#
public bool SkipProperties { get; set; }
Value
true if the IProcessingContext skips the properties; otherwise, false.


TaskID Property

TaskID Property
Namespaces ► Sitecore.Install.Framework ► SimpleProcessingContext ► TaskID
Gets the unique task ID. Can be used in workers to derive task-specific object names.
Declaration Syntax
C#
public string TaskID { get; }
Value
The task ID.


SinkDispatcher Class

SinkDispatcher Class
Namespaces ► Sitecore.Install.Framework ► SinkDispatcher
Represents a sink that use one of internal sinks to populate depends on the prefix of the name of the entry
Declaration Syntax
C#
public class SinkDispatcher : BaseSink<PackageEntry>,
    IDisposable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SinkDispatcher(IProcessingContext) | Initializes a new instance of the SinkDispatcher class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AddSink(String, ISink<(Of <(PackageEntry>)>)) | Adds the sink.
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Overrides BaseSink <(Of <( PackageEntry >)>).Finish()()().)
 | Flush()()() | Flushes the sink (Overrides BaseSink <(Of <( PackageEntry >)>).Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | Puts the specified entry. (Overrides BaseSink <(Of <( PackageEntry >)>).Put(T).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( PackageEntry >)>)
 |  | SinkDispatcher


SinkDispatcher Constructor (context)

SinkDispatcher Constructor (context)
Namespaces ► Sitecore.Install.Framework ► SinkDispatcher ► SinkDispatcher(IProcessingContext)
Initializes a new instance of the SinkDispatcher class.
Declaration Syntax
C#
public SinkDispatcher(
    IProcessingContext context
)
Parameters
context (IProcessingContext)
The context.


AddSink Method (prefix, sink)

AddSink Method (prefix, sink)
Namespaces ► Sitecore.Install.Framework ► SinkDispatcher ► AddSink(String, ISink<(Of <(PackageEntry>)>))
Adds the sink.
Declaration Syntax
C#
public void AddSink(
    string prefix,
    ISink<PackageEntry> sink
)
Parameters
prefix (String)
The prefix.
sink (ISink <(Of <( PackageEntry >)>))
The sink.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Install.Framework ► SinkDispatcher ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


Finish Method

Finish Method
Namespaces ► Sitecore.Install.Framework ► SinkDispatcher ► Finish()()()
Finishes the sink.
Declaration Syntax
C#
public override void Finish()


Flush Method

Flush Method
Namespaces ► Sitecore.Install.Framework ► SinkDispatcher ► Flush()()()
Flushes the sink
Declaration Syntax
C#
public override void Flush()


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Framework ► SinkDispatcher ► Put(PackageEntry)
Puts the specified entry.
Declaration Syntax
C#
public override void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


SortingKey Class

SortingKey Class
Namespaces ► Sitecore.Install.Framework ► SortingKey
Sorting key
Declaration Syntax
C#
public class SortingKey : IComparable<SortingKey>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SortingKey()()() | Initializes a new instance of the SortingKey class.
 | SortingKey(String, String, String, String) | Initializes a new instance of the SortingKey class.
 | SortingKey(String, String) | Initializes a new instance of the SortingKey class.
 | Compare(SortingKey, SortingKey) | Compares two keys.
 | CompareIDs(SortingKey, SortingKey) | Compares the IDs.
 | CompareLanguages(SortingKey, SortingKey) | Compares the languages.
 | ComparePaths(SortingKey, SortingKey) | Compares the paths.
 | ComparePrefixes(SortingKey, SortingKey) | Compares the prefixes.
 | CompareTo(SortingKey) | Compares the current object with another object of the same type.
 | CompareVersions(SortingKey, SortingKey) | Compares the versions.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets or sets the path.
 | Prefix | Gets or sets the prefix.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UniqueID | Gets or sets the unique ID.
 | Version | Gets or sets the version.
Inheritance Hierarchy
Object
SortingKey


SortingKey Constructor

SortingKey Constructor
Namespaces ► Sitecore.Install.Framework ► SortingKey ► SortingKey()()()
Members
Icon | Member | Description
 | SortingKey()()() | Initializes a new instance of the SortingKey class.
 | SortingKey(String, String, String, String) | Initializes a new instance of the SortingKey class.
 | SortingKey(String, String) | Initializes a new instance of the SortingKey class.


SortingKey Constructor

SortingKey Constructor
Namespaces ► Sitecore.Install.Framework ► SortingKey ► SortingKey()()()
Initializes a new instance of the SortingKey class.
Declaration Syntax
C#
public SortingKey()


SortingKey Constructor (prefix, path)

SortingKey Constructor (prefix, path)
Namespaces ► Sitecore.Install.Framework ► SortingKey ► SortingKey(String, String)
Initializes a new instance of the SortingKey class.
Declaration Syntax
C#
public SortingKey(
    string prefix,
    string path
)
Parameters
prefix (String)
The prefix.
path (String)
The path.


SortingKey Constructor (prefix, path, uniqueid, version)

SortingKey Constructor (prefix, path, uniqueid, version)
Namespaces ► Sitecore.Install.Framework ► SortingKey ► SortingKey(String, String, String, String)
Initializes a new instance of the SortingKey class.
Declaration Syntax
C#
public SortingKey(
    string prefix,
    string path,
    string uniqueid,
    string version
)
Parameters
prefix (String)
The prefix.
path (String)
The path.
uniqueid (String)
The unique id.
version (String)
The version.


Compare Method (left, right)

Compare Method (left, right)
Namespaces ► Sitecore.Install.Framework ► SortingKey ► Compare(SortingKey, SortingKey)
Compares two keys.
Declaration Syntax
C#
public static int Compare(
    SortingKey left,
    SortingKey right
)
Parameters
left (SortingKey)
The left key.
right (SortingKey)
The right key.
Return Value
Comparsion result.


CompareIDs Method (left, right)

CompareIDs Method (left, right)
Namespaces ► Sitecore.Install.Framework ► SortingKey ► CompareIDs(SortingKey, SortingKey)
Compares the IDs.
Declaration Syntax
C#
protected virtual int CompareIDs(
    SortingKey left,
    SortingKey right
)
Parameters
left (SortingKey)
The left.
right (SortingKey)
The right.
Return Value


CompareLanguages Method (left, right)

CompareLanguages Method (left, right)
Namespaces ► Sitecore.Install.Framework ► SortingKey ► CompareLanguages(SortingKey, SortingKey)
Compares the languages.
Declaration Syntax
C#
protected virtual int CompareLanguages(
    SortingKey left,
    SortingKey right
)
Parameters
left (SortingKey)
The left.
right (SortingKey)
The right.
Return Value


ComparePaths Method (left, right)

ComparePaths Method (left, right)
Namespaces ► Sitecore.Install.Framework ► SortingKey ► ComparePaths(SortingKey, SortingKey)
Compares the paths.
Declaration Syntax
C#
protected virtual int ComparePaths(
    SortingKey left,
    SortingKey right
)
Parameters
left (SortingKey)
The left.
right (SortingKey)
The right.
Return Value


ComparePrefixes Method (left, right)

ComparePrefixes Method (left, right)
Namespaces ► Sitecore.Install.Framework ► SortingKey ► ComparePrefixes(SortingKey, SortingKey)
Compares the prefixes.
Declaration Syntax
C#
protected virtual int ComparePrefixes(
    SortingKey left,
    SortingKey right
)
Parameters
left (SortingKey)
The left.
right (SortingKey)
The right.
Return Value


CompareTo Method (other)

CompareTo Method (other)
Namespaces ► Sitecore.Install.Framework ► SortingKey ► CompareTo(SortingKey)
Compares the current object with another object of the same type.
Declaration Syntax
C#
public virtual int CompareTo(
    SortingKey other
)
Parameters
other (SortingKey)
An object to compare with this object.
Return Value
A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.


CompareVersions Method (left, right)

CompareVersions Method (left, right)
Namespaces ► Sitecore.Install.Framework ► SortingKey ► CompareVersions(SortingKey, SortingKey)
Compares the versions.
Declaration Syntax
C#
protected virtual int CompareVersions(
    SortingKey left,
    SortingKey right
)
Parameters
left (SortingKey)
The left.
right (SortingKey)
The right.
Return Value


Path Property

Path Property
Namespaces ► Sitecore.Install.Framework ► SortingKey ► Path
Gets or sets the path.
Declaration Syntax
C#
public string Path { get; set; }
Value
The path.


Prefix Property

Prefix Property
Namespaces ► Sitecore.Install.Framework ► SortingKey ► Prefix
Gets or sets the prefix.
Declaration Syntax
C#
public string Prefix { get; set; }
Value
The prefix.


UniqueID Property

UniqueID Property
Namespaces ► Sitecore.Install.Framework ► SortingKey ► UniqueID
Gets or sets the unique ID.
Declaration Syntax
C#
public string UniqueID { get; set; }
Value
The unique ID.


Version Property

Version Property
Namespaces ► Sitecore.Install.Framework ► SortingKey ► Version
Gets or sets the version.
Declaration Syntax
C#
public string Version { get; set; }
Value
The version.


SourceCollection(T) Class

SourceCollection<(Of <(T>)>) Class
Namespaces ► Sitecore.Install.Framework ► SourceCollection<(Of <(T>)>)
An aggregation of sources
Declaration Syntax
C#
public class SourceCollection<T> : ISource<T>
Generic Template Parameters
T
Entry type
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SourceCollection<(Of <(T>)>)()()() | Initializes a new instance of the SourceCollection<(Of <(T>)>) class
 | Add(ISource<(Of <(T>)>)) | Adds the specified source.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Populate(ISink<(Of <(T>)>)) | Populates specified sink with sources.
 | Sources | Gets the sources.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SourceCollection<(Of <(T>)>)


SourceCollection(T) Constructor

SourceCollection<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Install.Framework ► SourceCollection<(Of <(T>)>) ► SourceCollection<(Of <(T>)>)()()()
Initializes a new instance of the SourceCollection<(Of <(T>)>) class
Declaration Syntax
C#
public SourceCollection()


Add Method (source)

Add Method (source)
Namespaces ► Sitecore.Install.Framework ► SourceCollection<(Of <(T>)>) ► Add(ISource<(Of <(T>)>))
Adds the specified source.
Declaration Syntax
C#
public void Add(
    ISource<T> source
)
Parameters
source (ISource <(Of <( T >)>))
The source.


Populate Method (sink)

Populate Method (sink)
Namespaces ► Sitecore.Install.Framework ► SourceCollection<(Of <(T>)>) ► Populate(ISink<(Of <(T>)>))
Populates specified sink with sources.
Declaration Syntax
C#
public void Populate(
    ISink<T> sink
)
Parameters
sink (ISink <(Of <( T >)>))
The sink.


Sources Property

Sources Property
Namespaces ► Sitecore.Install.Framework ► SourceCollection<(Of <(T>)>) ► Sources
Gets the sources.
Declaration Syntax
C#
public ICollection<ISource<T>> Sources { get; }
Value
The sources.


SourceInverter(T) Class

SourceInverter<(Of <(T>)>) Class
Namespaces ► Sitecore.Install.Framework ► SourceInverter<(Of <(T>)>)
Adapts ISource into an IEnumerable (inverts from PUSH to PULL model)
Declaration Syntax
C#
public class SourceInverter<T> : IEnumerable<T>,
    IEnumerable, IEnumerator<TElement>, IDisposable, IEnumerator
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SourceInverter<(Of <(T>)>)(ISource<(Of <(T>)>), IProcessingContext) | Initializes a new instance of the SourceInverter<(Of <(T>)>) class.
 | Current | Gets the element in the collection at the current position of the enumerator.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveNext()()() | Advances the enumerator to the next element of the collection.
 | Reset()()() | Sets the enumerator to its initial position, which is before the first element in the collection.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SourceInverter<(Of <(T>)>)


SourceInverter(T) Constructor (source, context)

SourceInverter<(Of <(T>)>) Constructor (source, context)
Namespaces ► Sitecore.Install.Framework ► SourceInverter<(Of <(T>)>) ► SourceInverter<(Of <(T>)>)(ISource<(Of <(T>)>), IProcessingContext)
Initializes a new instance of the SourceInverter<(Of <(T>)>) class.
Declaration Syntax
C#
public SourceInverter(
    ISource<T> source,
    IProcessingContext context
)
Parameters
source (ISource <(Of <( T >)>))
The source.
context (IProcessingContext)
The processing context.


Current Property

Current Property
Namespaces ► Sitecore.Install.Framework ► SourceInverter<(Of <(T>)>) ► Current
Gets the element in the collection at the current position of the enumerator.
Declaration Syntax
C#
public T Current { get; }
Value
Return Value
The element in the collection at the current position of the enumerator.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Install.Framework ► SourceInverter<(Of <(T>)>) ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Install.Framework ► SourceInverter<(Of <(T>)>) ► GetEnumerator()()()
Returns an enumerator that iterates through the collection.
Declaration Syntax
C#
public IEnumerator<T> GetEnumerator()
Return Value
A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.


MoveNext Method

MoveNext Method
Namespaces ► Sitecore.Install.Framework ► SourceInverter<(Of <(T>)>) ► MoveNext()()()
Advances the enumerator to the next element of the collection.
Declaration Syntax
C#
public bool MoveNext()
Return Value
true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.
Exceptions
Exception | Condition
InvalidOperationException | The collection was modified after the enumerator was created.


Reset Method

Reset Method
Namespaces ► Sitecore.Install.Framework ► SourceInverter<(Of <(T>)>) ► Reset()()()
Sets the enumerator to its initial position, which is before the first element in the collection.
Declaration Syntax
C#
public void Reset()
Exceptions
Exception | Condition
InvalidOperationException | The collection was modified after the enumerator was created.


TrivialConverter Class

TrivialConverter Class
Namespaces ► Sitecore.Install.Framework ► TrivialConverter
"Stub" converter. As a result of any conversion we will have the input object.
Declaration Syntax
C#
public class TrivialConverter : BaseConverter<PackageEntry>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApplyTransforms(PackageEntry, IProcessingContext) | (Inherited from .)
 | TrivialConverter()()() | Initializes a new instance of the TrivialConverter class
 | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform. Applies the transform. (Inherited from BaseConverter<(Of <(T>)>).)
 | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(T>)>) converter transforms should be applied by BaseConverter, not the derived class. (Inherited from BaseConverter<(Of <(T>)>).)
 | Convert(T, IProcessingContext) | Converts the specified entry. (Inherited from BaseConverter<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute(String) | Gets the value of the attribute. (Inherited from BaseConverter<(Of <(T>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InternalConvert(PackageEntry, IProcessingContext) | Returns the entry. (Overrides BaseConverter <(Of <( PackageEntry >)>).InternalConvert(T, IProcessingContext).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetAttribute(String, Object) | Sets the value of the attribute. (Inherited from BaseConverter<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | BaseConverter <(Of <( PackageEntry >)>)
 |  | TrivialConverter


TrivialConverter Constructor

TrivialConverter Constructor
Namespaces ► Sitecore.Install.Framework ► TrivialConverter ► TrivialConverter()()()
Initializes a new instance of the TrivialConverter class
Declaration Syntax
C#
public TrivialConverter()


InternalConvert Method (entry, context)

InternalConvert Method (entry, context)
Namespaces ► Sitecore.Install.Framework ► TrivialConverter ► InternalConvert(PackageEntry, IProcessingContext)
Returns the entry.
Declaration Syntax
C#
protected override PackageEntry[] InternalConvert(
    PackageEntry entry,
    IProcessingContext context
)
Parameters
entry (PackageEntry)
The entry.
context (IProcessingContext)
The processing context.
Return Value
The conversion result.


Sitecore.Install.Items Namespace

Sitecore.Install.Items Namespace
Namespaces ► Sitecore.Install.Items
Declaration Syntax
C#
namespace Sitecore.Install.Items
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | ExplicitItemSource..::.Builder | Builds an ExplicitItemSource object
 | DefaultItemInstallerEvents | Default implementation of IItemInstallerEvents
 | ExplicitItemSource | Explicit item source
 | IItemInstallerEvents | Defines basic event of an item installer
 | ItemEntryData | Item entry data
 | ItemInstaller | Item installer
 | ItemInstallerContext | Item installer context
 | ItemKeyProvider | Item key provider
 | ItemKeyUtils | Item key utils
 | ItemReference | Item reference
 | ItemSource | Item source
 | ItemToEntryConverter | Item to entry converter
 | ItemUninstaller | Item uninstaller
 | LegacyItemUnpacker | Legacy item unpacker
 | ItemInstaller..::.VersionInstaller | Version installer
 | VersionInstallMode | Version install mode


DefaultItemInstallerEvents Class

DefaultItemInstallerEvents Class
Namespaces ► Sitecore.Install.Items ► DefaultItemInstallerEvents
Default implementation of IItemInstallerEvents
Declaration Syntax
C#
public class DefaultItemInstallerEvents : IItemInstallerEvents
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DefaultItemInstallerEvents(BehaviourOptions) | Initializes a new instance of the DefaultItemInstallerEvents class.
 | AskUser(ItemInfo, ItemInfo, IProcessingContext) | Returns the behavour options was specified in the constructor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DefaultItemInstallerEvents


DefaultItemInstallerEvents Constructor (options)

DefaultItemInstallerEvents Constructor (options)
Namespaces ► Sitecore.Install.Items ► DefaultItemInstallerEvents ► DefaultItemInstallerEvents(BehaviourOptions)
Initializes a new instance of the DefaultItemInstallerEvents class.
Declaration Syntax
C#
public DefaultItemInstallerEvents(
    BehaviourOptions options
)
Parameters
options (BehaviourOptions)
The options.


AskUser Method (databaseItem, packageItem, context)

AskUser Method (databaseItem, packageItem, context)
Namespaces ► Sitecore.Install.Items ► DefaultItemInstallerEvents ► AskUser(ItemInfo, ItemInfo, IProcessingContext)
Returns the behavour options was specified in the constructor
Declaration Syntax
C#
public Pair<BehaviourOptions, bool> AskUser(
    ItemInfo databaseItem,
    ItemInfo packageItem,
    IProcessingContext context
)
Parameters
databaseItem (ItemInfo)
The database item.
packageItem (ItemInfo)
The package item.
context (IProcessingContext)
The context.
Return Value
The user.


ExplicitItemSource Class

ExplicitItemSource Class
Namespaces ► Sitecore.Install.Items ► ExplicitItemSource
Explicit item source
Declaration Syntax
C#
public class ExplicitItemSource : BaseSource<Item>,
    IExplicitSource, IKeyResolver
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExplicitItemSource()()() | Initializes a new instance of the ExplicitItemSource class.
 | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(T>)>).)
 | Entries | Gets the entries.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Include | Gets the include filters. (Inherited from BaseSource<(Of <(T>)>).)
 | InternalPopulate(ISink<(Of <(Item>)>)) | To be overridden in descendants (Overrides BaseSource <(Of <( Item >)>).InternalPopulate(ISink<(Of <(T>)>)).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(T>)>).)
 | Populate(ISink<(Of <(PackageEntry>)>)) | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(T>)>).)
 | ResolveKey(String) | Resolves the key.
 | SkipVersions | Gets or sets a value indicating whether the ExplicitItemSource skips the versions.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSource <(Of <( Item >)>)
 |  | ExplicitItemSource


ExplicitItemSource Constructor

ExplicitItemSource Constructor
Namespaces ► Sitecore.Install.Items ► ExplicitItemSource ► ExplicitItemSource()()()
Initializes a new instance of the ExplicitItemSource class.
Declaration Syntax
C#
public ExplicitItemSource()


Entries Property

Entries Property
Namespaces ► Sitecore.Install.Items ► ExplicitItemSource ► Entries
Gets the entries.
Declaration Syntax
C#
public IList<string> Entries { get; }
Value
The entries.


InternalPopulate Method (sink)

InternalPopulate Method (sink)
Namespaces ► Sitecore.Install.Items ► ExplicitItemSource ► InternalPopulate(ISink<(Of <(Item>)>))
To be overridden in descendants
Declaration Syntax
C#
protected override void InternalPopulate(
    ISink<Item> sink
)
Parameters
sink (ISink <(Of <( Item >)>))
The sink


ResolveKey Method (key)

ResolveKey Method (key)
Namespaces ► Sitecore.Install.Items ► ExplicitItemSource ► ResolveKey(String)
Resolves the key.
Declaration Syntax
C#
public Object ResolveKey(
    string key
)
Parameters
key (String)
The key.
Return Value
The object.


SkipVersions Property

SkipVersions Property
Namespaces ► Sitecore.Install.Items ► ExplicitItemSource ► SkipVersions
Gets or sets a value indicating whether the ExplicitItemSource skips the versions.
Declaration Syntax
C#
public bool SkipVersions { get; set; }
Value
true if the ExplicitItemSource skips the versions; otherwise, false.


ExplicitItemSource.Builder Class

ExplicitItemSource..::.Builder Class
Namespaces ► Sitecore.Install.Items ► ExplicitItemSource ► ExplicitItemSource..::.Builder
Builds an ExplicitItemSource object
Declaration Syntax
C#
public class Builder : BaseSink<PackageEntry>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExplicitItemSource..::.Builder()()() | Initializes a new instance of the ExplicitItemSource..::.Builder class.
 | ExplicitItemSource..::.Builder(ExplicitItemSource) | Initializes a new instance of the ExplicitItemSource..::.Builder class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExpectExactReferences | Gets or sets a value indicating whether the ExplicitItemSource..::.Builder expects the exact references.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Overrides BaseSink <(Of <( PackageEntry >)>).Finish()()().)
 | Flush()()() | Flushes the sink (Inherited from BaseSink<(Of <(T>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | Puts the specified entry. (Overrides BaseSink <(Of <( PackageEntry >)>).Put(T).)
 | Source | Gets or sets the source.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( PackageEntry >)>)
 |  | ExplicitItemSource..::.Builder


ExplicitItemSource.Builder Constructor

ExplicitItemSource..::.Builder Constructor
Namespaces ► Sitecore.Install.Items ► ExplicitItemSource..::.Builder ► ExplicitItemSource..::.Builder()()()
Members
Icon | Member | Description
 | ExplicitItemSource..::.Builder()()() | Initializes a new instance of the ExplicitItemSource..::.Builder class.
 | ExplicitItemSource..::.Builder(ExplicitItemSource) | Initializes a new instance of the ExplicitItemSource..::.Builder class.


ExplicitItemSource.Builder Constructor

ExplicitItemSource..::.Builder Constructor
Namespaces ► Sitecore.Install.Items ► ExplicitItemSource..::.Builder ► ExplicitItemSource..::.Builder()()()
Initializes a new instance of the ExplicitItemSource..::.Builder class.
Declaration Syntax
C#
public Builder()


ExplicitItemSource.Builder Constructor (source)

ExplicitItemSource..::.Builder Constructor (source)
Namespaces ► Sitecore.Install.Items ► ExplicitItemSource..::.Builder ► ExplicitItemSource..::.Builder(ExplicitItemSource)
Initializes a new instance of the ExplicitItemSource..::.Builder class.
Declaration Syntax
C#
public Builder(
    ExplicitItemSource source
)
Parameters
source (ExplicitItemSource)
The source.


ExpectExactReferences Property

ExpectExactReferences Property
Namespaces ► Sitecore.Install.Items ► ExplicitItemSource..::.Builder ► ExpectExactReferences
Gets or sets a value indicating whether the ExplicitItemSource..::.Builder expects the exact references.
Declaration Syntax
C#
public bool ExpectExactReferences { get; set; }
Value
true if the ExplicitItemSource..::.Builder expects the exact references; otherwise, false.


Finish Method

Finish Method
Namespaces ► Sitecore.Install.Items ► ExplicitItemSource..::.Builder ► Finish()()()
Finishes the sink.
Declaration Syntax
C#
public override void Finish()


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Items ► ExplicitItemSource..::.Builder ► Put(PackageEntry)
Puts the specified entry.
Declaration Syntax
C#
public override void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


Source Property

Source Property
Namespaces ► Sitecore.Install.Items ► ExplicitItemSource..::.Builder ► Source
Gets or sets the source.
Declaration Syntax
C#
public ExplicitItemSource Source { get; set; }
Value
The source.


IItemInstallerEvents Interface

IItemInstallerEvents Interface
Namespaces ► Sitecore.Install.Items ► IItemInstallerEvents
Defines basic event of an item installer
Declaration Syntax
C#
public interface IItemInstallerEvents
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AskUser(ItemInfo, ItemInfo, IProcessingContext) | Asks the user what to do when we have an item collision.


AskUser Method (databaseItem, packageItem, context)

AskUser Method (databaseItem, packageItem, context)
Namespaces ► Sitecore.Install.Items ► IItemInstallerEvents ► AskUser(ItemInfo, ItemInfo, IProcessingContext)
Asks the user what to do when we have an item collision.
Declaration Syntax
C#
Pair<BehaviourOptions, bool> AskUser(
    ItemInfo databaseItem,
    ItemInfo packageItem,
    IProcessingContext context
)
Parameters
databaseItem (ItemInfo)
The database item.
packageItem (ItemInfo)
The package item.
context (IProcessingContext)
The context.
Return Value
The user.


ItemEntryData Class

ItemEntryData Class
Namespaces ► Sitecore.Install.Items ► ItemEntryData
Item entry data
Declaration Syntax
C#
public class ItemEntryData : IEntryData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemEntryData(Item) | Initializes a new instance of the ItemEntryData class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStream()()() | Gets the stream holder.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemEntryData


ItemEntryData Constructor (item)

ItemEntryData Constructor (item)
Namespaces ► Sitecore.Install.Items ► ItemEntryData ► ItemEntryData(Item)
Initializes a new instance of the ItemEntryData class.
Declaration Syntax
C#
public ItemEntryData(
    Item item
)
Parameters
item (Item)
The item.


GetStream Method

GetStream Method
Namespaces ► Sitecore.Install.Items ► ItemEntryData ► GetStream()()()
Gets the stream holder.
Declaration Syntax
C#
public IStreamHolder GetStream()
Return Value
The stream holder.


Key Property

Key Property
Namespaces ► Sitecore.Install.Items ► ItemEntryData ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


ItemInstaller Class

ItemInstaller Class
Namespaces ► Sitecore.Install.Items ► ItemInstaller
Item installer
Declaration Syntax
C#
public class ItemInstaller : AdvancedBaseSink<PackageEntry, ItemInstallerContext>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemInstaller(IProcessingContext) | Initializes a new instance of the ItemInstaller class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Context | Gets the context. (Inherited from AdvancedBaseSink<(Of <(T, ContextType>)>).)
 | CreateContext()()() | Creates the context. (Overrides AdvancedBaseSink <(Of <( PackageEntry, ItemInstallerContext >)>).CreateContext()()().)
 | CreateLightweightItem(ItemReference, XmlVersionParser) | Creates the lightweight item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Overrides BaseSink <(Of <( T >)>).Finish()()().)
 | Flush()()() | Flushes the sink (Overrides BaseSink <(Of <( T >)>).Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemInstallOptions(PackageEntry, ItemInstallerContext, String) | Gets the item install options.
 | GetPrefix(ItemInfo, ItemInfo) | Gets the prefix.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from AdvancedBaseSink<(Of <(T, ContextType>)>).)
 | InstallItem(BehaviourOptions, Item, ItemReference, XmlVersionParser) | Installs the item.
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PendingDeleteItems | Gets the pended to be deleted items.
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | If an entry contains an item than that item will be added to the installation queue.
 | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(T>)>).)
 | RemoveVersions(Item, Boolean) | Removes the versions.
 | SetupContext(ContextType) | Setups the context. (Inherited from AdvancedBaseSink<(Of <(T, ContextType>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( T >)>)
 |  | AdvancedBaseSink <(Of <( PackageEntry, ItemInstallerContext >)>)
 |  |  | ItemInstaller


ItemInstaller Constructor (context)

ItemInstaller Constructor (context)
Namespaces ► Sitecore.Install.Items ► ItemInstaller ► ItemInstaller(IProcessingContext)
Initializes a new instance of the ItemInstaller class.
Declaration Syntax
C#
public ItemInstaller(
    IProcessingContext context
)
Parameters
context (IProcessingContext)
The context.


CreateContext Method

CreateContext Method
Namespaces ► Sitecore.Install.Items ► ItemInstaller ► CreateContext()()()
Creates the context.
Declaration Syntax
C#
protected override ItemInstallerContext CreateContext()
Return Value
The context.


CreateLightweightItem Method (item, parser)

CreateLightweightItem Method (item, parser)
Namespaces ► Sitecore.Install.Items ► ItemInstaller ► CreateLightweightItem(ItemReference, XmlVersionParser)
Creates the lightweight item.
Declaration Syntax
C#
protected static Item CreateLightweightItem(
    ItemReference item,
    XmlVersionParser parser
)
Parameters
item (ItemReference)
The item.
parser (XmlVersionParser)
The parser.
Return Value
The lightweight item.


Finish Method

Finish Method
Namespaces ► Sitecore.Install.Items ► ItemInstaller ► Finish()()()
Finishes the sink.
Declaration Syntax
C#
public override void Finish()


Flush Method

Flush Method
Namespaces ► Sitecore.Install.Items ► ItemInstaller ► Flush()()()
Flushes the sink
Declaration Syntax
C#
public override void Flush()


GetItemInstallOptions Method (entry, context, prefix)

GetItemInstallOptions Method (entry, context, prefix)
Namespaces ► Sitecore.Install.Items ► ItemInstaller ► GetItemInstallOptions(PackageEntry, ItemInstallerContext, String)
Gets the item install options.
Declaration Syntax
C#
protected virtual BehaviourOptions GetItemInstallOptions(
    PackageEntry entry,
    ItemInstallerContext context,
    string prefix
)
Parameters
entry (PackageEntry)
The entry.
context (ItemInstallerContext)
The context.
prefix (String)
The prefix.
Return Value
The item install options.


GetPrefix Method (installedItem, newItem)

GetPrefix Method (installedItem, newItem)
Namespaces ► Sitecore.Install.Items ► ItemInstaller ► GetPrefix(ItemInfo, ItemInfo)
Gets the prefix.
Declaration Syntax
C#
protected static string GetPrefix(
    ItemInfo installedItem,
    ItemInfo newItem
)
Parameters
installedItem (ItemInfo)
The installed item.
newItem (ItemInfo)
The new item.
Return Value
The prefix.


InstallItem Method (installOptions, targetItem, item, parser)

InstallItem Method (installOptions, targetItem, item, parser)
Namespaces ► Sitecore.Install.Items ► ItemInstaller ► InstallItem(BehaviourOptions, Item, ItemReference, XmlVersionParser)
Installs the item.
Declaration Syntax
C#
protected void InstallItem(
    BehaviourOptions installOptions,
    Item targetItem,
    ItemReference item,
    XmlVersionParser parser
)
Parameters
installOptions (BehaviourOptions)
The install options.
targetItem (Item)
The target item.
item (ItemReference)
The item.
parser (XmlVersionParser)
The parser.


PendingDeleteItems Property

PendingDeleteItems Property
Namespaces ► Sitecore.Install.Items ► ItemInstaller ► PendingDeleteItems
Gets the pended to be deleted items.
Declaration Syntax
C#
public IList<KeyValuePair<string, string>> PendingDeleteItems { get; }
Value
The pending delete items.


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Items ► ItemInstaller ► Put(PackageEntry)
If an entry contains an item than that item will be added to the installation queue.
Declaration Syntax
C#
public virtual void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


RemoveVersions Method (targetItem, removeSharedData)

RemoveVersions Method (targetItem, removeSharedData)
Namespaces ► Sitecore.Install.Items ► ItemInstaller ► RemoveVersions(Item, Boolean)
Removes the versions.
Declaration Syntax
C#
protected static void RemoveVersions(
    Item targetItem,
    bool removeSharedData
)
Parameters
targetItem (Item)
The target item.
removeSharedData (Boolean)
if set to true the shared data will be removed.


ItemInstaller.VersionInstaller Class

ItemInstaller..::.VersionInstaller Class
Namespaces ► Sitecore.Install.Items ► ItemInstaller ► ItemInstaller..::.VersionInstaller
Version installer
Declaration Syntax
C#
public static class VersionInstaller
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ParseItemVersion(XmlNode, Item, VersionInstallMode) | Parses the item version.
 | PasteVersion(XmlNode, Item, VersionInstallMode, IProcessingContext) | Pastes the version.
Inheritance Hierarchy
Object
ItemInstaller..::.VersionInstaller


ParseItemVersion Method (versionNode, target, mode)

ParseItemVersion Method (versionNode, target, mode)
Namespaces ► Sitecore.Install.Items ► ItemInstaller..::.VersionInstaller ► ParseItemVersion(XmlNode, Item, VersionInstallMode)
Parses the item version.
Declaration Syntax
C#
public static Item ParseItemVersion(
    XmlNode versionNode,
    Item target,
    VersionInstallMode mode
)
Parameters
versionNode (XmlNode)
The version node.
target (Item)
The target item.
mode (VersionInstallMode)
The version install mode.
Return Value
The item version.


PasteVersion Method (versionXml, target, mode, context)

PasteVersion Method (versionXml, target, mode, context)
Namespaces ► Sitecore.Install.Items ► ItemInstaller..::.VersionInstaller ► PasteVersion(XmlNode, Item, VersionInstallMode, IProcessingContext)
Pastes the version.
Declaration Syntax
C#
public static void PasteVersion(
    XmlNode versionXml,
    Item target,
    VersionInstallMode mode,
    IProcessingContext context
)
Parameters
versionXml (XmlNode)
The version XML.
target (Item)
The target.
mode (VersionInstallMode)
The mode.
context (IProcessingContext)
The context.


ItemInstallerContext Class

ItemInstallerContext Class
Namespaces ► Sitecore.Install.Items ► ItemInstallerContext
Item installer context
Declaration Syntax
C#
public class ItemInstallerContext
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemInstallerContext(IItemInstallerEvents) | Initializes a new instance of the ItemInstallerContext class.
 | ApplyToAll |
 | CurrentItemID |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstallOptions(String) | Gets the install options.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplyToAll(String) | Determines whether behavior should be applied for all entries whit the specified prefix
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VersionInstallMode |
Inheritance Hierarchy
Object
ItemInstallerContext


ItemInstallerContext Constructor (events)

ItemInstallerContext Constructor (events)
Namespaces ► Sitecore.Install.Items ► ItemInstallerContext ► ItemInstallerContext(IItemInstallerEvents)
Initializes a new instance of the ItemInstallerContext class.
Declaration Syntax
C#
public ItemInstallerContext(
    IItemInstallerEvents events
)
Parameters
events (IItemInstallerEvents)
The events.


ApplyToAll Field

ApplyToAll Field
Namespaces ► Sitecore.Install.Items ► ItemInstallerContext ► ApplyToAll
Declaration Syntax
C#
public Dictionary<string, bool> ApplyToAll


CurrentItemID Field

CurrentItemID Field
Namespaces ► Sitecore.Install.Items ► ItemInstallerContext ► CurrentItemID
Declaration Syntax
C#
public string CurrentItemID


Events Field

Events Field
Namespaces ► Sitecore.Install.Items ► ItemInstallerContext ► Events
Declaration Syntax
C#
public IItemInstallerEvents Events


GetInstallOptions Method (prefix)

GetInstallOptions Method (prefix)
Namespaces ► Sitecore.Install.Items ► ItemInstallerContext ► GetInstallOptions(String)
Gets the install options.
Declaration Syntax
C#
public BehaviourOptions GetInstallOptions(
    string prefix
)
Parameters
prefix (String)
The prefix.
Return Value
The install options.


IsApplyToAll Method (prefix)

IsApplyToAll Method (prefix)
Namespaces ► Sitecore.Install.Items ► ItemInstallerContext ► IsApplyToAll(String)
Determines whether behavior should be applied for all entries whit the specified prefix
Declaration Syntax
C#
public bool IsApplyToAll(
    string prefix
)
Parameters
prefix (String)
The prefix.
Return Value


VersionInstallMode Field

VersionInstallMode Field
Namespaces ► Sitecore.Install.Items ► ItemInstallerContext ► VersionInstallMode
Declaration Syntax
C#
public VersionInstallMode VersionInstallMode


ItemKeyProvider Class

ItemKeyProvider Class
Namespaces ► Sitecore.Install.Items ► ItemKeyProvider
Item key provider
Declaration Syntax
C#
public class ItemKeyProvider : ISortingKeyProvider
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemKeyProvider()()() | Initializes a new instance of the ItemKeyProvider class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKey(String) | Gets the key.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemKeyProvider


ItemKeyProvider Constructor

ItemKeyProvider Constructor
Namespaces ► Sitecore.Install.Items ► ItemKeyProvider ► ItemKeyProvider()()()
Initializes a new instance of the ItemKeyProvider class
Declaration Syntax
C#
public ItemKeyProvider()


GetKey Method (key)

GetKey Method (key)
Namespaces ► Sitecore.Install.Items ► ItemKeyProvider ► GetKey(String)
Gets the key.
Declaration Syntax
C#
public SortingKey GetKey(
    string key
)
Parameters
key (String)
The key.
Return Value
The key.


ItemKeyUtils Class

ItemKeyUtils Class
Namespaces ► Sitecore.Install.Items ► ItemKeyUtils
Item key utils
Declaration Syntax
C#
public static class ItemKeyUtils
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetKey(Item) | Gets the key.
 | GetKey(ItemReference) | Gets the key.
 | GetReference(String) | Gets the reference.
 | Resolve(String) | Gets an item by the reference.
Inheritance Hierarchy
Object
ItemKeyUtils


GetKey Method

GetKey Method
Namespaces ► Sitecore.Install.Items ► ItemKeyUtils ► GetKey()()()
Members
Icon | Member | Description
 | GetKey(Item) | Gets the key.
 | GetKey(ItemReference) | Gets the key.


GetKey Method (item)

GetKey Method (item)
Namespaces ► Sitecore.Install.Items ► ItemKeyUtils ► GetKey(Item)
Gets the key.
Declaration Syntax
C#
public static string GetKey(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The key.


GetKey Method (reference)

GetKey Method (reference)
Namespaces ► Sitecore.Install.Items ► ItemKeyUtils ► GetKey(ItemReference)
Gets the key.
Declaration Syntax
C#
public static string GetKey(
    ItemReference reference
)
Parameters
reference (ItemReference)
The reference.
Return Value
The key.


GetReference Method (key)

GetReference Method (key)
Namespaces ► Sitecore.Install.Items ► ItemKeyUtils ► GetReference(String)
Gets the reference.
Declaration Syntax
C#
public static ItemReference GetReference(
    string key
)
Parameters
key (String)
The key.
Return Value
The reference.


Resolve Method (key)

Resolve Method (key)
Namespaces ► Sitecore.Install.Items ► ItemKeyUtils ► Resolve(String)
Gets an item by the reference.
Declaration Syntax
C#
public static Item Resolve(
    string key
)
Parameters
key (String)
The reference.
Return Value
The resolved item.


ItemReference Class

ItemReference Class
Namespaces ► Sitecore.Install.Items ► ItemReference
Item reference
Declaration Syntax
C#
[SerializableAttribute]
public class ItemReference
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemReference(Item) | Initializes a new instance of the ItemReference class.
 | ItemReference(String, String, ID, Language, Version) | Initializes a new instance of the ItemReference class.
 | ItemReference(ItemUri, Boolean) | Initializes a new instance of the ItemReference class.
 | Database | Gets the database.
 | DatabaseName | Gets or sets the name of the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item.
 | GetItems()()() | Gets the items.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the ID.
 | IsLanguageInvariant | Gets a value indicating whether this instance is language invariant.
 | IsStrong | Gets a value indicating whether this instance is strong.
 | IsVersionInvariant | Gets a value indicating whether this instance is version invariant.
 | Language | Gets or sets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Parses the specified reference.
 | Path | Gets or sets the path.
 | Reduce()()() | Gets the reduced reference
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | Version | Gets or sets the version.
Inheritance Hierarchy
Object
ItemReference


ItemReference Constructor

ItemReference Constructor
Namespaces ► Sitecore.Install.Items ► ItemReference ► ItemReference()()()
Members
Icon | Member | Description
 | ItemReference(Item) | Initializes a new instance of the ItemReference class.
 | ItemReference(String, String, ID, Language, Version) | Initializes a new instance of the ItemReference class.
 | ItemReference(ItemUri, Boolean) | Initializes a new instance of the ItemReference class.


ItemReference Constructor (item)

ItemReference Constructor (item)
Namespaces ► Sitecore.Install.Items ► ItemReference ► ItemReference(Item)
Initializes a new instance of the ItemReference class.
Declaration Syntax
C#
public ItemReference(
    Item item
)
Parameters
item (Item)
The item.


ItemReference Constructor (uri, exact)

ItemReference Constructor (uri, exact)
Namespaces ► Sitecore.Install.Items ► ItemReference ► ItemReference(ItemUri, Boolean)
Initializes a new instance of the ItemReference class.
Declaration Syntax
C#
public ItemReference(
    ItemUri uri,
    bool exact
)
Parameters
uri (ItemUri)
The URI.
exact (Boolean)
if set to true this instance is exact.


ItemReference Constructor (database, path, id, language, version)

ItemReference Constructor (database, path, id, language, version)
Namespaces ► Sitecore.Install.Items ► ItemReference ► ItemReference(String, String, ID, Language, Version)
Initializes a new instance of the ItemReference class.
Declaration Syntax
C#
public ItemReference(
    string database,
    string path,
    ID id,
    Language language,
    Version version
)
Parameters
database (String)
The database.
path (String)
The path.
id (ID)
The id.
language (Language)
The language.
version (Version)
The version.


Database Property

Database Property
Namespaces ► Sitecore.Install.Items ► ItemReference ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


DatabaseName Property

DatabaseName Property
Namespaces ► Sitecore.Install.Items ► ItemReference ► DatabaseName
Gets or sets the name of the database.
Declaration Syntax
C#
public string DatabaseName { get; set; }
Value
The name of the database.


GetItem Method

GetItem Method
Namespaces ► Sitecore.Install.Items ► ItemReference ► GetItem()()()
Gets the item.
Declaration Syntax
C#
public Item GetItem()
Return Value
The item.


GetItems Method

GetItems Method
Namespaces ► Sitecore.Install.Items ► ItemReference ► GetItems()()()
Gets the items.
Declaration Syntax
C#
public IList<Item> GetItems()
Return Value
The items.


ID Property

ID Property
Namespaces ► Sitecore.Install.Items ► ItemReference ► ID
Gets or sets the ID.
Declaration Syntax
C#
public ID ID { get; set; }
Value
The ID.


IsLanguageInvariant Property

IsLanguageInvariant Property
Namespaces ► Sitecore.Install.Items ► ItemReference ► IsLanguageInvariant
Gets a value indicating whether this instance is language invariant.
Declaration Syntax
C#
public bool IsLanguageInvariant { get; }
Value
true if this instance is language invariant; otherwise, false.


IsStrong Property

IsStrong Property
Namespaces ► Sitecore.Install.Items ► ItemReference ► IsStrong
Gets a value indicating whether this instance is strong.
Declaration Syntax
C#
public bool IsStrong { get; }
Value
true if this instance is strong; otherwise, false.


IsVersionInvariant Property

IsVersionInvariant Property
Namespaces ► Sitecore.Install.Items ► ItemReference ► IsVersionInvariant
Gets a value indicating whether this instance is version invariant.
Declaration Syntax
C#
public bool IsVersionInvariant { get; }
Value
true if this instance is version invariant; otherwise, false.


Language Property

Language Property
Namespaces ► Sitecore.Install.Items ► ItemReference ► Language
Gets or sets the language.
Declaration Syntax
C#
public Language Language { get; set; }
Value
The language.


Parse Method (reference)

Parse Method (reference)
Namespaces ► Sitecore.Install.Items ► ItemReference ► Parse(String)
Parses the specified reference.
Declaration Syntax
C#
public static ItemReference Parse(
    string reference
)
Parameters
reference (String)
The reference.
Return Value
The item refecence.
Examples
ItemReference.Parse("/master/sitecore/content/home/{}/en/1");


Path Property

Path Property
Namespaces ► Sitecore.Install.Items ► ItemReference ► Path
Gets or sets the path.
Declaration Syntax
C#
public string Path { get; set; }
Value
The path.


Reduce Method

Reduce Method
Namespaces ► Sitecore.Install.Items ► ItemReference ► Reduce()()()
Gets the reduced reference
Declaration Syntax
C#
public ItemReference Reduce()
Return Value


ToString Method

ToString Method
Namespaces ► Sitecore.Install.Items ► ItemReference ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Version Property

Version Property
Namespaces ► Sitecore.Install.Items ► ItemReference ► Version
Gets or sets the version.
Declaration Syntax
C#
public Version Version { get; set; }
Value
The version.


ItemSource Class

ItemSource Class
Namespaces ► Sitecore.Install.Items ► ItemSource
Item source
Declaration Syntax
C#
public class ItemSource : BaseSource<Item>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemSource()()() | Initializes a new instance of the ItemSource class.
 | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(T>)>).)
 | Database | Gets or sets the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Include | Gets the include filters. (Inherited from BaseSource<(Of <(T>)>).)
 | InternalPopulate(ISink<(Of <(Item>)>)) | Populates the specified sink with the item and its subitems) (Overrides BaseSource <(Of <( Item >)>).InternalPopulate(ISink<(Of <(T>)>)).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(T>)>).)
 | Populate(ISink<(Of <(PackageEntry>)>)) | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(T>)>).)
 | Root | Gets or sets the root.
 | SkipVersions | Gets or sets a value indicating whether the ItemSource skips the versions.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSource <(Of <( Item >)>)
 |  | ItemSource


ItemSource Constructor

ItemSource Constructor
Namespaces ► Sitecore.Install.Items ► ItemSource ► ItemSource()()()
Initializes a new instance of the ItemSource class.
Declaration Syntax
C#
public ItemSource()


Database Property

Database Property
Namespaces ► Sitecore.Install.Items ► ItemSource ► Database
Gets or sets the database.
Declaration Syntax
C#
public string Database { get; set; }
Value
The database.


InternalPopulate Method (sink)

InternalPopulate Method (sink)
Namespaces ► Sitecore.Install.Items ► ItemSource ► InternalPopulate(ISink<(Of <(Item>)>))
Populates the specified sink with the item and its subitems)
Declaration Syntax
C#
protected override void InternalPopulate(
    ISink<Item> sink
)
Parameters
sink (ISink <(Of <( Item >)>))
The sink


Root Property

Root Property
Namespaces ► Sitecore.Install.Items ► ItemSource ► Root
Gets or sets the root.
Declaration Syntax
C#
public string Root { get; set; }
Value
The root.


SkipVersions Property

SkipVersions Property
Namespaces ► Sitecore.Install.Items ► ItemSource ► SkipVersions
Gets or sets a value indicating whether the ItemSource skips the versions.
Declaration Syntax
C#
public bool SkipVersions { get; set; }
Value
true if the ItemSource skips the versions; otherwise, false.


ItemToEntryConverter Class

ItemToEntryConverter Class
Namespaces ► Sitecore.Install.Items ► ItemToEntryConverter
Item to entry converter
Declaration Syntax
C#
public class ItemToEntryConverter : BaseConverter<Item>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApplyTransforms(PackageEntry, IProcessingContext) | (Inherited from .)
 | ItemToEntryConverter()()() | Initializes a new instance of the ItemToEntryConverter class
 | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform. Applies the transform. (Inherited from BaseConverter<(Of <(T>)>).)
 | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(T>)>) converter transforms should be applied by BaseConverter, not the derived class. (Overrides BaseConverter <(Of <( Item >)>).AutoApplyTransforms.)
 | Convert(T, IProcessingContext) | Converts the specified entry. (Inherited from BaseConverter<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute(String) | Gets the value of the attribute. (Inherited from BaseConverter<(Of <(T>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InternalConvert(Item, IProcessingContext) | Convert the item to an entry. (Overrides BaseConverter <(Of <( Item >)>).InternalConvert(T, IProcessingContext).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetAttribute(String, Object) | Sets the value of the attribute. (Inherited from BaseConverter<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | BaseConverter <(Of <( Item >)>)
 |  | ItemToEntryConverter


ItemToEntryConverter Constructor

ItemToEntryConverter Constructor
Namespaces ► Sitecore.Install.Items ► ItemToEntryConverter ► ItemToEntryConverter()()()
Initializes a new instance of the ItemToEntryConverter class
Declaration Syntax
C#
public ItemToEntryConverter()


AutoApplyTransforms Property

AutoApplyTransforms Property
Namespaces ► Sitecore.Install.Items ► ItemToEntryConverter ► AutoApplyTransforms
Gets a value indicating whether the BaseConverter<(Of <(T>)>) converter transforms should be applied by BaseConverter, not the derived class.
Declaration Syntax
C#
protected override bool AutoApplyTransforms { get; }
Value
true if the BaseConverter<(Of <(T>)>) transforms should be applied by BaseConverter implicitly; otherwise, false.


InternalConvert Method (item, context)

InternalConvert Method (item, context)
Namespaces ► Sitecore.Install.Items ► ItemToEntryConverter ► InternalConvert(Item, IProcessingContext)
Convert the item to an entry.
Declaration Syntax
C#
protected override PackageEntry[] InternalConvert(
    Item item,
    IProcessingContext context
)
Parameters
item (Item)
The item.
context (IProcessingContext)
The context.
Return Value
The convert.


ItemUninstaller Class

ItemUninstaller Class
Namespaces ► Sitecore.Install.Items ► ItemUninstaller
Item uninstaller
Declaration Syntax
C#
public class ItemUninstaller : BaseSink<PackageEntry>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemUninstaller()()() | Initializes a new instance of the ItemUninstaller class
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Inherited from BaseSink<(Of <(T>)>).)
 | Flush()()() | Flushes the sink (Inherited from BaseSink<(Of <(T>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | Puts the specified entry. (Overrides BaseSink <(Of <( PackageEntry >)>).Put(T).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( PackageEntry >)>)
 |  | ItemUninstaller


ItemUninstaller Constructor

ItemUninstaller Constructor
Namespaces ► Sitecore.Install.Items ► ItemUninstaller ► ItemUninstaller()()()
Initializes a new instance of the ItemUninstaller class
Declaration Syntax
C#
public ItemUninstaller()


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Items ► ItemUninstaller ► Put(PackageEntry)
Puts the specified entry.
Declaration Syntax
C#
public override void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


LegacyItemUnpacker Class

LegacyItemUnpacker Class
Namespaces ► Sitecore.Install.Items ► LegacyItemUnpacker
Legacy item unpacker
Declaration Syntax
C#
public class LegacyItemUnpacker : BaseSink<PackageEntry>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LegacyItemUnpacker(ISink<(Of <(PackageEntry>)>)) | Initializes a new instance of the LegacyItemUnpacker class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Overrides BaseSink <(Of <( PackageEntry >)>).Finish()()().)
 | Flush()()() | Flushes the sink (Overrides BaseSink <(Of <( PackageEntry >)>).Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | If the entry is in the old format this method "splits" this entry to several entries for each item version (Overrides BaseSink <(Of <( PackageEntry >)>).Put(T).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( PackageEntry >)>)
 |  | LegacyItemUnpacker


LegacyItemUnpacker Constructor (owner)

LegacyItemUnpacker Constructor (owner)
Namespaces ► Sitecore.Install.Items ► LegacyItemUnpacker ► LegacyItemUnpacker(ISink<(Of <(PackageEntry>)>))
Initializes a new instance of the LegacyItemUnpacker class.
Declaration Syntax
C#
public LegacyItemUnpacker(
    ISink<PackageEntry> owner
)
Parameters
owner (ISink <(Of <( PackageEntry >)>))
The owner.


Finish Method

Finish Method
Namespaces ► Sitecore.Install.Items ► LegacyItemUnpacker ► Finish()()()
Finishes the sink.
Declaration Syntax
C#
public override void Finish()


Flush Method

Flush Method
Namespaces ► Sitecore.Install.Items ► LegacyItemUnpacker ► Flush()()()
Flushes the sink
Declaration Syntax
C#
public override void Flush()


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Items ► LegacyItemUnpacker ► Put(PackageEntry)
If the entry is in the old format this method "splits" this entry to several entries for each item version
Declaration Syntax
C#
public override void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


VersionInstallMode Enumeration

VersionInstallMode Enumeration
Namespaces ► Sitecore.Install.Items ► VersionInstallMode
Version install mode
Declaration Syntax
C#
public enum VersionInstallMode
Members
Member | Description
Merge | Merge versions by version number
Append | Append version if version with same revision number is not exists
Skip | Don't install version
Undefined | Undefined


Sitecore.Install.Metadata Namespace

Sitecore.Install.Metadata Namespace
Namespaces ► Sitecore.Install.Metadata
Declaration Syntax
C#
namespace Sitecore.Install.Metadata
Types
All Types Classes
Icon | Type | Description
 | MetadataSink | Reads metadata from a package entry.
 | MetadataSource | Represents metadata as a source for package entries
 | MetadataView | Represents the metadata part of a package


MetadataSink Class

MetadataSink Class
Namespaces ► Sitecore.Install.Metadata ► MetadataSink
Reads metadata from a package entry.
Declaration Syntax
C#
public class MetadataSink : BaseSink<PackageEntry>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MetadataSink(IProcessingContext) | Initializes a new instance of the MetadataSink class.
 | MetadataSink(MetadataView) | Initializes a new instance of the MetadataSink class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Overrides BaseSink <(Of <( PackageEntry >)>).Finish()()().)
 | Flush()()() | Flushes the sink (Overrides BaseSink <(Of <( PackageEntry >)>).Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | Reads metadata from a package entry. If the entry contains it (Overrides BaseSink <(Of <( PackageEntry >)>).Put(T).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( PackageEntry >)>)
 |  | MetadataSink


MetadataSink Constructor

MetadataSink Constructor
Namespaces ► Sitecore.Install.Metadata ► MetadataSink ► MetadataSink()()()
Members
Icon | Member | Description
 | MetadataSink(IProcessingContext) | Initializes a new instance of the MetadataSink class.
 | MetadataSink(MetadataView) | Initializes a new instance of the MetadataSink class.


MetadataSink Constructor (context)

MetadataSink Constructor (context)
Namespaces ► Sitecore.Install.Metadata ► MetadataSink ► MetadataSink(IProcessingContext)
Initializes a new instance of the MetadataSink class.
Declaration Syntax
C#
public MetadataSink(
    IProcessingContext context
)
Parameters
context (IProcessingContext)


MetadataSink Constructor (view)

MetadataSink Constructor (view)
Namespaces ► Sitecore.Install.Metadata ► MetadataSink ► MetadataSink(MetadataView)
Initializes a new instance of the MetadataSink class.
Declaration Syntax
C#
public MetadataSink(
    MetadataView view
)
Parameters
view (MetadataView)
The view.


Finish Method

Finish Method
Namespaces ► Sitecore.Install.Metadata ► MetadataSink ► Finish()()()
Finishes the sink.
Declaration Syntax
C#
public override void Finish()


Flush Method

Flush Method
Namespaces ► Sitecore.Install.Metadata ► MetadataSink ► Flush()()()
Flushes the sink
Declaration Syntax
C#
public override void Flush()


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Metadata ► MetadataSink ► Put(PackageEntry)
Reads metadata from a package entry. If the entry contains it
Declaration Syntax
C#
public override void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


MetadataSource Class

MetadataSource Class
Namespaces ► Sitecore.Install.Metadata ► MetadataSource
Represents metadata as a source for package entries
Declaration Syntax
C#
public class MetadataSource : MetadataView,
    ISource<PackageEntry>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MetadataSource()()() | Initializes a new instance of the MetadataSource class.
 | Attributes | Gets or sets the attributes. (Inherited from MetadataView.)
 | Author | Gets or sets the author. (Inherited from MetadataView.)
 | Comment | Gets or sets the comment. (Inherited from MetadataView.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDictionary()()() | Gets the dictionary. (Inherited from MetadataView.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(String) | Gets the value. (Inherited from MetadataView.)
 | License | Gets or sets the license. (Inherited from MetadataView.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Metadata | Gets the metadata as a NameValueCollection. (Inherited from MetadataView.)
 | PackageID | Gets or sets the package ID. (Inherited from MetadataView.)
 | PackageName | Gets or sets the name of the package. (Inherited from MetadataView.)
 | Populate(ISink<(Of <(PackageEntry>)>)) | Populates specified sink from this sourse.
 | PostStep | Gets or sets the post step. (Inherited from MetadataView.)
 | Publisher | Gets or sets the publisher. (Inherited from MetadataView.)
 | Readme | Gets or sets the readme. (Inherited from MetadataView.)
 | Revision | Gets or sets the revision. (Inherited from MetadataView.)
 | SetValue(String, String) | Sets the value. (Inherited from MetadataView.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | Gets or sets the version. (Inherited from MetadataView.)
Inheritance Hierarchy
Object
 | MetadataView
 |  | MetadataSource


MetadataSource Constructor

MetadataSource Constructor
Namespaces ► Sitecore.Install.Metadata ► MetadataSource ► MetadataSource()()()
Initializes a new instance of the MetadataSource class.
Declaration Syntax
C#
public MetadataSource()


Populate Method (sink)

Populate Method (sink)
Namespaces ► Sitecore.Install.Metadata ► MetadataSource ► Populate(ISink<(Of <(PackageEntry>)>))
Populates specified sink from this sourse.
Declaration Syntax
C#
public void Populate(
    ISink<PackageEntry> sink
)
Parameters
sink (ISink <(Of <( PackageEntry >)>))
The sink.


MetadataView Class

MetadataView Class
Namespaces ► Sitecore.Install.Metadata ► MetadataView
Represents the metadata part of a package
Declaration Syntax
C#
public class MetadataView
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MetadataView(IProcessingContext) | Initializes a new instance of the MetadataView class.
 | MetadataView(IDictionary<(Of <(String, String>)>)) | Initializes a new instance of the MetadataView class.
 | Attributes | Gets or sets the attributes.
 | Author | Gets or sets the author.
 | Comment | Gets or sets the comment.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDictionary()()() | Gets the dictionary.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(String) | Gets the value.
 | License | Gets or sets the license.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Metadata | Gets the metadata as a NameValueCollection.
 | PackageID | Gets or sets the package ID.
 | PackageName | Gets or sets the name of the package.
 | PostStep | Gets or sets the post step.
 | Publisher | Gets or sets the publisher.
 | Readme | Gets or sets the readme.
 | Revision | Gets or sets the revision.
 | SetValue(String, String) | Sets the value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | Gets or sets the version.
Inheritance Hierarchy
Object
 | MetadataView
 |  | MetadataSource


MetadataView Constructor

MetadataView Constructor
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► MetadataView()()()
Members
Icon | Member | Description
 | MetadataView(IProcessingContext) | Initializes a new instance of the MetadataView class.
 | MetadataView(IDictionary<(Of <(String, String>)>)) | Initializes a new instance of the MetadataView class.


MetadataView Constructor (context)

MetadataView Constructor (context)
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► MetadataView(IProcessingContext)
Initializes a new instance of the MetadataView class.
Declaration Syntax
C#
public MetadataView(
    IProcessingContext context
)
Parameters
context (IProcessingContext)
The context.


MetadataView Constructor (data)

MetadataView Constructor (data)
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► MetadataView(IDictionary<(Of <(String, String>)>))
Initializes a new instance of the MetadataView class.
Declaration Syntax
C#
public MetadataView(
    IDictionary<string, string> data
)
Parameters
data (IDictionary<(Of <(String, String>)>))
The data.


Attributes Property

Attributes Property
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► Attributes
Gets or sets the attributes.
Declaration Syntax
C#
public string Attributes { get; set; }
Value
The attributes.


Author Property

Author Property
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► Author
Gets or sets the author.
Declaration Syntax
C#
public string Author { get; set; }
Value
The author.


Comment Property

Comment Property
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► Comment
Gets or sets the comment.
Declaration Syntax
C#
public string Comment { get; set; }
Value
The comment.


GetDictionary Method

GetDictionary Method
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► GetDictionary()()()
Gets the dictionary.
Declaration Syntax
C#
public IDictionary<string, string> GetDictionary()
Return Value
The dictionary.


GetValue Method (key)

GetValue Method (key)
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► GetValue(String)
Gets the value.
Declaration Syntax
C#
protected virtual string GetValue(
    string key
)
Parameters
key (String)
The key.
Return Value
The value.


License Property

License Property
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► License
Gets or sets the license.
Declaration Syntax
C#
public string License { get; set; }
Value
The license.


Metadata Property

Metadata Property
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► Metadata
Gets the metadata as a NameValueCollection.
Declaration Syntax
C#
public virtual NameValueCollection Metadata { get; }
Value
The metadata.


PackageID Property

PackageID Property
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► PackageID
Gets or sets the package ID.
Declaration Syntax
C#
public string PackageID { get; set; }
Value
The package ID.


PackageName Property

PackageName Property
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► PackageName
Gets or sets the name of the package.
Declaration Syntax
C#
public string PackageName { get; set; }
Value
The name of the package.


PostStep Property

PostStep Property
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► PostStep
Gets or sets the post step.
Declaration Syntax
C#
public string PostStep { get; set; }
Value
The post step.


Publisher Property

Publisher Property
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► Publisher
Gets or sets the publisher.
Declaration Syntax
C#
public string Publisher { get; set; }
Value
The publisher.


Readme Property

Readme Property
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► Readme
Gets or sets the readme.
Declaration Syntax
C#
public string Readme { get; set; }
Value
The readme.


Revision Property

Revision Property
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► Revision
Gets or sets the revision.
Declaration Syntax
C#
public string Revision { get; set; }
Value
The revision.


SetValue Method (key, value)

SetValue Method (key, value)
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► SetValue(String, String)
Sets the value.
Declaration Syntax
C#
protected virtual void SetValue(
    string key,
    string value
)
Parameters
key (String)
The key.
value (String)
The value.


Version Property

Version Property
Namespaces ► Sitecore.Install.Metadata ► MetadataView ► Version
Gets or sets the version.
Declaration Syntax
C#
public string Version { get; set; }
Value
The version.


Sitecore.Install.Security Namespace

Sitecore.Install.Security Namespace
Namespaces ► Sitecore.Install.Security
Declaration Syntax
C#
namespace Sitecore.Install.Security
Types
All Types Classes Interfaces
Icon | Type | Description
 | AccountInstaller | Account installer
 | AccountToEntryConverter | UserToEntryConverter class
 | IAccountInstallerEvents | Define an interface for working with UI to be used in AccountInstaller
 | SecuritySource | SecuritySource class


AccountInstaller Class

AccountInstaller Class
Namespaces ► Sitecore.Install.Security ► AccountInstaller
Account installer
Declaration Syntax
C#
public class AccountInstaller : BaseSink<PackageEntry>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccountInstaller()()() | Initializes a new instance of the AccountInstaller class
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Overrides BaseSink <(Of <( PackageEntry >)>).Finish()()().)
 | Flush()()() | Flushes the sink (Inherited from BaseSink<(Of <(T>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | InstallRole(PackageEntry) | Installs the role.
 | InstallUser(PackageEntry) | Installs the user.
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | Installs the entry (Overrides BaseSink <(Of <( PackageEntry >)>).Put(T).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( PackageEntry >)>)
 |  | AccountInstaller


AccountInstaller Constructor

AccountInstaller Constructor
Namespaces ► Sitecore.Install.Security ► AccountInstaller ► AccountInstaller()()()
Initializes a new instance of the AccountInstaller class
Declaration Syntax
C#
public AccountInstaller()


Finish Method

Finish Method
Namespaces ► Sitecore.Install.Security ► AccountInstaller ► Finish()()()
Finishes the sink.
Declaration Syntax
C#
public override void Finish()


InstallRole Method (entry)

InstallRole Method (entry)
Namespaces ► Sitecore.Install.Security ► AccountInstaller ► InstallRole(PackageEntry)
Installs the role.
Declaration Syntax
C#
protected void InstallRole(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


InstallUser Method (entry)

InstallUser Method (entry)
Namespaces ► Sitecore.Install.Security ► AccountInstaller ► InstallUser(PackageEntry)
Installs the user.
Declaration Syntax
C#
protected void InstallUser(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Security ► AccountInstaller ► Put(PackageEntry)
Installs the entry
Declaration Syntax
C#
public override void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
entry


AccountToEntryConverter Class

AccountToEntryConverter Class
Namespaces ► Sitecore.Install.Security ► AccountToEntryConverter
UserToEntryConverter class
Declaration Syntax
C#
public class AccountToEntryConverter : BaseConverter<string>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApplyTransforms(PackageEntry, IProcessingContext) | (Inherited from .)
 | AccountToEntryConverter()()() | Initializes a new instance of the AccountToEntryConverter class
 | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform. Applies the transform. (Inherited from BaseConverter<(Of <(T>)>).)
 | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(T>)>) converter transforms should be applied by BaseConverter, not the derived class. (Inherited from BaseConverter<(Of <(T>)>).)
 | Convert(T, IProcessingContext) | Converts the specified entry. (Inherited from BaseConverter<(Of <(T>)>).)
 | CreateRoleEntry(String) | Creates the role entry.
 | CreateUserEntry(String) | Creates the user entry.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute(String) | Gets the value of the attribute. (Inherited from BaseConverter<(Of <(T>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InternalConvert(String, IProcessingContext) | Creates a package entry by user name. (Overrides BaseConverter <(Of <(String>)>).InternalConvert(T, IProcessingContext).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveUserProfile(User, XmlWriter) | Saves the user profile.
 | SaveUserProperties(User, XmlWriter) | Saves the user properties.
 | SaveUserRoles(User, XmlWriter) | Saves the user roles.
 | SetAttribute(String, Object) | Sets the value of the attribute. (Inherited from BaseConverter<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(T>)>).)
 | WriteProperty(String, Object, XmlWriter) | Writes the property.
Inheritance Hierarchy
Object
 | BaseConverter <(Of <(String>)>)
 |  | AccountToEntryConverter


AccountToEntryConverter Constructor

AccountToEntryConverter Constructor
Namespaces ► Sitecore.Install.Security ► AccountToEntryConverter ► AccountToEntryConverter()()()
Initializes a new instance of the AccountToEntryConverter class
Declaration Syntax
C#
public AccountToEntryConverter()


CreateRoleEntry Method (roleName)

CreateRoleEntry Method (roleName)
Namespaces ► Sitecore.Install.Security ► AccountToEntryConverter ► CreateRoleEntry(String)
Creates the role entry.
Declaration Syntax
C#
protected static PackageEntry[] CreateRoleEntry(
    string roleName
)
Parameters
roleName (String)
Name of the role.
Return Value


CreateUserEntry Method (userName)

CreateUserEntry Method (userName)
Namespaces ► Sitecore.Install.Security ► AccountToEntryConverter ► CreateUserEntry(String)
Creates the user entry.
Declaration Syntax
C#
protected static PackageEntry[] CreateUserEntry(
    string userName
)
Parameters
userName (String)
Name of the user.
Return Value


InternalConvert Method (accountName, context)

InternalConvert Method (accountName, context)
Namespaces ► Sitecore.Install.Security ► AccountToEntryConverter ► InternalConvert(String, IProcessingContext)
Creates a package entry by user name.
Declaration Syntax
C#
protected override PackageEntry[] InternalConvert(
    string accountName,
    IProcessingContext context
)
Parameters
accountName (String)
Name of the account.
context (IProcessingContext)
The context.
Return Value


SaveUserProfile Method (user, writer)

SaveUserProfile Method (user, writer)
Namespaces ► Sitecore.Install.Security ► AccountToEntryConverter ► SaveUserProfile(User, XmlWriter)
Saves the user profile.
Declaration Syntax
C#
protected static void SaveUserProfile(
    User user,
    XmlWriter writer
)
Parameters
user (User)
The user.
writer (XmlWriter)
The writer.


SaveUserProperties Method (user, writer)

SaveUserProperties Method (user, writer)
Namespaces ► Sitecore.Install.Security ► AccountToEntryConverter ► SaveUserProperties(User, XmlWriter)
Saves the user properties.
Declaration Syntax
C#
protected static void SaveUserProperties(
    User user,
    XmlWriter writer
)
Parameters
user (User)
The user.
writer (XmlWriter)
The writer.


SaveUserRoles Method (user, writer)

SaveUserRoles Method (user, writer)
Namespaces ► Sitecore.Install.Security ► AccountToEntryConverter ► SaveUserRoles(User, XmlWriter)
Saves the user roles.
Declaration Syntax
C#
protected static void SaveUserRoles(
    User user,
    XmlWriter writer
)
Parameters
user (User)
The user.
writer (XmlWriter)
The writer.


WriteProperty Method (name, value, writer)

WriteProperty Method (name, value, writer)
Namespaces ► Sitecore.Install.Security ► AccountToEntryConverter ► WriteProperty(String, Object, XmlWriter)
Writes the property.
Declaration Syntax
C#
protected static void WriteProperty(
    string name,
    Object value,
    XmlWriter writer
)
Parameters
name (String)
The name.
value (Object)
The value.
writer (XmlWriter)
The writer.


IAccountInstallerEvents Interface

IAccountInstallerEvents Interface
Namespaces ► Sitecore.Install.Security ► IAccountInstallerEvents
Define an interface for working with UI to be used in AccountInstaller
Declaration Syntax
C#
public interface IAccountInstallerEvents
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ShowWarning(String, String) | Shows the warning.


ShowWarning Method (message, warningType)

ShowWarning Method (message, warningType)
Namespaces ► Sitecore.Install.Security ► IAccountInstallerEvents ► ShowWarning(String, String)
Shows the warning.
Declaration Syntax
C#
void ShowWarning(
    string message,
    string warningType
)
Parameters
message (String)
The message.
warningType (String)
Type of the warning. Meaning is that message of one type can be ignored.


SecuritySource Class

SecuritySource Class
Namespaces ► Sitecore.Install.Security ► SecuritySource
SecuritySource class
Declaration Syntax
C#
public class SecuritySource : BaseSource<string>,
    IExplicitSource, IKeyResolver
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecuritySource()()() | Initializes a new instance of the SecuritySource class.
 | AddAccount(AccountString) | Adds the account.
 | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(T>)>).)
 | Entries | Gets the entries.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Include | Gets the include filters. (Inherited from BaseSource<(Of <(T>)>).)
 | InternalPopulate(ISink<(Of <(String>)>)) | Populates internal sink (Overrides BaseSource <(Of <(String>)>).InternalPopulate(ISink<(Of <(T>)>)).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(T>)>).)
 | Populate(ISink<(Of <(PackageEntry>)>)) | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(T>)>).)
 | ResolveKey(String) | Returns string.Empty if the account exists, otherwice returns null
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSource <(Of <(String>)>)
 |  | SecuritySource


SecuritySource Constructor

SecuritySource Constructor
Namespaces ► Sitecore.Install.Security ► SecuritySource ► SecuritySource()()()
Initializes a new instance of the SecuritySource class.
Declaration Syntax
C#
public SecuritySource()


AddAccount Method (account)

AddAccount Method (account)
Namespaces ► Sitecore.Install.Security ► SecuritySource ► AddAccount(AccountString)
Adds the account.
Declaration Syntax
C#
public void AddAccount(
    AccountString account
)
Parameters
account (AccountString)
The account.


Entries Property

Entries Property
Namespaces ► Sitecore.Install.Security ► SecuritySource ► Entries
Gets the entries.
Declaration Syntax
C#
public IList<string> Entries { get; }
Value
The entries.


InternalPopulate Method (sink)

InternalPopulate Method (sink)
Namespaces ► Sitecore.Install.Security ► SecuritySource ► InternalPopulate(ISink<(Of <(String>)>))
Populates internal sink
Declaration Syntax
C#
protected override void InternalPopulate(
    ISink<string> sink
)
Parameters
sink (ISink <(Of <(String>)>))
The sink


ResolveKey Method (key)

ResolveKey Method (key)
Namespaces ► Sitecore.Install.Security ► SecuritySource ► ResolveKey(String)
Returns string.Empty if the account exists, otherwice returns null
Declaration Syntax
C#
public Object ResolveKey(
    string key
)
Parameters
key (String)
Return Value


Sitecore.Install.Serialization Namespace

Sitecore.Install.Serialization Namespace
Namespaces ► Sitecore.Install.Serialization
Declaration Syntax
C#
namespace Sitecore.Install.Serialization
Types
All Types Classes
Icon | Type | Description
 | IOUtils | IO Utility


IOUtils Class

IOUtils Class
Namespaces ► Sitecore.Install.Serialization ► IOUtils
IO Utility
Declaration Syntax
C#
public static class IOUtils
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LoadObject(String) | Deserializes an object from string.
 | LoadSolution(String) | Deseliaziles a solution from string.
 | SerializationContext | Gets the serialization context.
 | StoreObject(Object) | Serializes the object to a string.
 | StoreObject(Object, Formatting) | Serializes the specifyed object to a string. The string will contain an xml code.
 | StoreSolution(PackageProject) | Serializes the solution to a string.
Inheritance Hierarchy
Object
IOUtils


LoadObject Method (stream)

LoadObject Method (stream)
Namespaces ► Sitecore.Install.Serialization ► IOUtils ► LoadObject(String)
Deserializes an object from string.
Declaration Syntax
C#
public static Object LoadObject(
    string stream
)
Parameters
stream (String)
The stream.
Return Value
The deserialized object.


LoadSolution Method (stream)

LoadSolution Method (stream)
Namespaces ► Sitecore.Install.Serialization ► IOUtils ► LoadSolution(String)
Deseliaziles a solution from string.
Declaration Syntax
C#
public static PackageProject LoadSolution(
    string stream
)
Parameters
stream (String)
The stream with a serialized solution.
Return Value
The solution.


SerializationContext Property

SerializationContext Property
Namespaces ► Sitecore.Install.Serialization ► IOUtils ► SerializationContext
Gets the serialization context.
Declaration Syntax
C#
public static ISerializationContext SerializationContext { get; }
Value
The serialization context.


StoreObject Method

StoreObject Method
Namespaces ► Sitecore.Install.Serialization ► IOUtils ► StoreObject()()()
Members
Icon | Member | Description
 | StoreObject(Object) | Serializes the object to a string.
 | StoreObject(Object, Formatting) | Serializes the specifyed object to a string. The string will contain an xml code.


StoreObject Method (instance)

StoreObject Method (instance)
Namespaces ► Sitecore.Install.Serialization ► IOUtils ► StoreObject(Object)
Serializes the object to a string.
Declaration Syntax
C#
public static string StoreObject(
    Object instance
)
Parameters
instance (Object)
The instance.
Return Value
The object.


StoreObject Method (instance, formatting)

StoreObject Method (instance, formatting)
Namespaces ► Sitecore.Install.Serialization ► IOUtils ► StoreObject(Object, Formatting)
Serializes the specifyed object to a string. The string will contain an xml code.
Declaration Syntax
C#
public static string StoreObject(
    Object instance,
    Formatting formatting
)
Parameters
instance (Object)
The instance.
formatting (Formatting)
The xml formatting to be used.
Return Value
The object serialized into a string.


StoreSolution Method (solution)

StoreSolution Method (solution)
Namespaces ► Sitecore.Install.Serialization ► IOUtils ► StoreSolution(PackageProject)
Serializes the solution to a string.
Declaration Syntax
C#
public static string StoreSolution(
    PackageProject solution
)
Parameters
solution (PackageProject)
The solution.
Return Value
The serialized solution.


Sitecore.Install.Utils Namespace

Sitecore.Install.Utils Namespace
Namespaces ► Sitecore.Install.Utils
Declaration Syntax
C#
namespace Sitecore.Install.Utils
Types
All Types Classes Enumerations
Icon | Type | Description
 | BehaviourOptions | Defines behavior answering what to do with collision
 | EntrySorter | Entry sorter
 | Files | Utility to work with files
 | InstallationException | An installation error.
 | InstallerMarker | Add an entry with a installer version to a sink
 | InstallerVersion | Contains methods to work with versions of the instraller
 | InstallMode | Defines what to do with an item in collision
 | ItemInfo | Item iformation
 | MergeMode | Defines item merge mode
 | PackageUser | Package user type
 | SitecoreLogger | Wrapper for Sitecore.Diagnostics.Log class
 | StatusFile..::.Status | Represents status of the operation.
 | StatusFile | Wrapper around a file-based one-way communication channel.
 | StatusFile..::.StatusInfo | Encapsulates status information passed from packaground worker.
 | StringEntryData | String entry data
 | StrongStreamHolder | Strong stream holder.
 | Uniq | Strips adjacent duplicate entries in the package
 | WeakStreamHolder | Weak stream holder. Contains a reference to one stream
 | XmlVersionParser | Xml version parser


BehaviourOptions Class

BehaviourOptions Class
Namespaces ► Sitecore.Install.Utils ► BehaviourOptions
Defines behavior answering what to do with collision
Declaration Syntax
C#
public class BehaviourOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BehaviourOptions()()() | Initializes a new instance of the BehaviourOptions class.
 | BehaviourOptions(IDictionary<(Of <(String, String>)>), String) | Initializes a new instance of the BehaviourOptions class.
 | BehaviourOptions(InstallMode, MergeMode) | Initializes a new instance of the BehaviourOptions class.
 | Assign(BehaviourOptions) | Assigns the specified options.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersionInstallMode()()() | Gets the version install mode.
 | IsDefined | Gets a value indicating whether merge mode is defined.
 | ItemMergeMode | Gets or sets the item merge mode.
 | ItemMode | Gets or sets the item mode.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BehaviourOptions


BehaviourOptions Constructor

BehaviourOptions Constructor
Namespaces ► Sitecore.Install.Utils ► BehaviourOptions ► BehaviourOptions()()()
Members
Icon | Member | Description
 | BehaviourOptions()()() | Initializes a new instance of the BehaviourOptions class.
 | BehaviourOptions(IDictionary<(Of <(String, String>)>), String) | Initializes a new instance of the BehaviourOptions class.
 | BehaviourOptions(InstallMode, MergeMode) | Initializes a new instance of the BehaviourOptions class.


BehaviourOptions Constructor

BehaviourOptions Constructor
Namespaces ► Sitecore.Install.Utils ► BehaviourOptions ► BehaviourOptions()()()
Initializes a new instance of the BehaviourOptions class.
Declaration Syntax
C#
public BehaviourOptions()


BehaviourOptions Constructor (installMode, mergeMode)

BehaviourOptions Constructor (installMode, mergeMode)
Namespaces ► Sitecore.Install.Utils ► BehaviourOptions ► BehaviourOptions(InstallMode, MergeMode)
Initializes a new instance of the BehaviourOptions class.
Declaration Syntax
C#
public BehaviourOptions(
    InstallMode installMode,
    MergeMode mergeMode
)
Parameters
installMode (InstallMode)
The install mode.
mergeMode (MergeMode)
The merge mode.


BehaviourOptions Constructor (data, prefix)

BehaviourOptions Constructor (data, prefix)
Namespaces ► Sitecore.Install.Utils ► BehaviourOptions ► BehaviourOptions(IDictionary<(Of <(String, String>)>), String)
Initializes a new instance of the BehaviourOptions class.
Declaration Syntax
C#
public BehaviourOptions(
    IDictionary<string, string> data,
    string prefix
)
Parameters
data (IDictionary<(Of <(String, String>)>))
The data.
prefix (String)
The prefix.


Assign Method (options)

Assign Method (options)
Namespaces ► Sitecore.Install.Utils ► BehaviourOptions ► Assign(BehaviourOptions)
Assigns the specified options.
Declaration Syntax
C#
public void Assign(
    BehaviourOptions options
)
Parameters
options (BehaviourOptions)
The options.


GetVersionInstallMode Method

GetVersionInstallMode Method
Namespaces ► Sitecore.Install.Utils ► BehaviourOptions ► GetVersionInstallMode()()()
Gets the version install mode.
Declaration Syntax
C#
public VersionInstallMode GetVersionInstallMode()
Return Value
The version install mode.


IsDefined Property

IsDefined Property
Namespaces ► Sitecore.Install.Utils ► BehaviourOptions ► IsDefined
Gets a value indicating whether merge mode is defined.
Declaration Syntax
C#
public bool IsDefined { get; }
Value
true if this merge mode is defined; otherwise, false.


ItemMergeMode Property

ItemMergeMode Property
Namespaces ► Sitecore.Install.Utils ► BehaviourOptions ► ItemMergeMode
Gets or sets the item merge mode.
Declaration Syntax
C#
public MergeMode ItemMergeMode { get; set; }
Value
The item merge mode.


ItemMode Property

ItemMode Property
Namespaces ► Sitecore.Install.Utils ► BehaviourOptions ► ItemMode
Gets or sets the item mode.
Declaration Syntax
C#
public InstallMode ItemMode { get; set; }
Value
The item mode.


EntrySorter Class

EntrySorter Class
Namespaces ► Sitecore.Install.Utils ► EntrySorter
Entry sorter
Declaration Syntax
C#
public class EntrySorter : BaseSink<PackageEntry>,
    ISource<PackageEntry>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EntrySorter(ISource<(Of <(PackageEntry>)>)) | Initializes a new instance of the EntrySorter class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | ClearCache()()() | Clears the cache.
 | CompareEntries(PackageEntry, PackageEntry) | Compares the entries.
 | CompareKeys(String, String) | Compares the keys.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Overrides BaseSink <(Of <( PackageEntry >)>).Finish()()().)
 | Flush()()() | Flushes the sink (Overrides BaseSink <(Of <( PackageEntry >)>).Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | KeyCache | Gets the key cache.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Populate(ISink<(Of <(PackageEntry>)>)) | Populates specified sink from this sourse.
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | Puts the specified entry. (Overrides BaseSink <(Of <( PackageEntry >)>).Put(T).)
 | SetKeyProvider(String, ISortingKeyProvider) | Sets the key provider.
 | SetSectionOrder(String, String) | Sets the section order.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( PackageEntry >)>)
 |  | EntrySorter


EntrySorter Constructor (baseSource)

EntrySorter Constructor (baseSource)
Namespaces ► Sitecore.Install.Utils ► EntrySorter ► EntrySorter(ISource<(Of <(PackageEntry>)>))
Initializes a new instance of the EntrySorter class.
Declaration Syntax
C#
public EntrySorter(
    ISource<PackageEntry> baseSource
)
Parameters
baseSource (ISource <(Of <( PackageEntry >)>))
The base source.


ClearCache Method

ClearCache Method
Namespaces ► Sitecore.Install.Utils ► EntrySorter ► ClearCache()()()
Clears the cache.
Declaration Syntax
C#
public static void ClearCache()


CompareEntries Method (left, right)

CompareEntries Method (left, right)
Namespaces ► Sitecore.Install.Utils ► EntrySorter ► CompareEntries(PackageEntry, PackageEntry)
Compares the entries.
Declaration Syntax
C#
public static int CompareEntries(
    PackageEntry left,
    PackageEntry right
)
Parameters
left (PackageEntry)
The left.
right (PackageEntry)
The right.
Return Value


CompareKeys Method (left, right)

CompareKeys Method (left, right)
Namespaces ► Sitecore.Install.Utils ► EntrySorter ► CompareKeys(String, String)
Compares the keys.
Declaration Syntax
C#
public static int CompareKeys(
    string left,
    string right
)
Parameters
left (String)
The left.
right (String)
The right.
Return Value


Finish Method

Finish Method
Namespaces ► Sitecore.Install.Utils ► EntrySorter ► Finish()()()
Finishes the sink.
Declaration Syntax
C#
public override void Finish()


Flush Method

Flush Method
Namespaces ► Sitecore.Install.Utils ► EntrySorter ► Flush()()()
Flushes the sink
Declaration Syntax
C#
public override void Flush()


KeyCache Property

KeyCache Property
Namespaces ► Sitecore.Install.Utils ► EntrySorter ► KeyCache
Gets the key cache.
Declaration Syntax
C#
protected static Dictionary<string, SortingKey> KeyCache { get; }
Value
The key cache.


Populate Method (sink)

Populate Method (sink)
Namespaces ► Sitecore.Install.Utils ► EntrySorter ► Populate(ISink<(Of <(PackageEntry>)>))
Populates specified sink from this sourse.
Declaration Syntax
C#
public void Populate(
    ISink<PackageEntry> sink
)
Parameters
sink (ISink <(Of <( PackageEntry >)>))
The sink.


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Utils ► EntrySorter ► Put(PackageEntry)
Puts the specified entry.
Declaration Syntax
C#
public override void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


SetKeyProvider Method (key, provider)

SetKeyProvider Method (key, provider)
Namespaces ► Sitecore.Install.Utils ► EntrySorter ► SetKeyProvider(String, ISortingKeyProvider)
Sets the key provider.
Declaration Syntax
C#
public static void SetKeyProvider(
    string key,
    ISortingKeyProvider provider
)
Parameters
key (String)
The key.
provider (ISortingKeyProvider)
The provider.


SetSectionOrder Method (sectionName, order)

SetSectionOrder Method (sectionName, order)
Namespaces ► Sitecore.Install.Utils ► EntrySorter ► SetSectionOrder(String, String)
Sets the section order.
Declaration Syntax
C#
public static void SetSectionOrder(
    string sectionName,
    string order
)
Parameters
sectionName (String)
Name of the section.
order (String)
The order.


Files Class

Files Class
Namespaces ► Sitecore.Install.Utils ► Files
Utility to work with files
Declaration Syntax
C#
public static class Files
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | OpenFile(String, String, String, String, String, String, String, String) | Opens the file wiht FileBrowser application.
 | UploadToDirectory(String) | Shows "upload to directory" dialog.
Inheritance Hierarchy
Object
Files


OpenFile Method (header, text, icon, button, root, directory, selected, filter)

OpenFile Method (header, text, icon, button, root, directory, selected, filter)
Namespaces ► Sitecore.Install.Utils ► Files ► OpenFile(String, String, String, String, String, String, String, String)
Opens the file wiht FileBrowser application.
Declaration Syntax
C#
public static void OpenFile(
    string header,
    string text,
    string icon,
    string button,
    string root,
    string directory,
    string selected,
    string filter
)
Parameters
header (String)
The header.
text (String)
The text.
icon (String)
The icon.
button (String)
The button.
root (String)
The root.
directory (String)
The directory.
selected (String)
The selected.
filter (String)
The filter.


UploadToDirectory Method (directory)

UploadToDirectory Method (directory)
Namespaces ► Sitecore.Install.Utils ► Files ► UploadToDirectory(String)
Shows "upload to directory" dialog.
Declaration Syntax
C#
public static void UploadToDirectory(
    string directory
)
Parameters
directory (String)
The directory.


InstallationException Class

InstallationException Class
Namespaces ► Sitecore.Install.Utils ► InstallationException
An installation error.
Declaration Syntax
C#
public class InstallationException : Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstallationException(String) | Initializes a new instance of the InstallationException class.
 | InstallationException(String, Exception) | Initializes a new instance of the InstallationException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | InstallationException


InstallationException Constructor

InstallationException Constructor
Namespaces ► Sitecore.Install.Utils ► InstallationException ► InstallationException()()()
Members
Icon | Member | Description
 | InstallationException(String) | Initializes a new instance of the InstallationException class.
 | InstallationException(String, Exception) | Initializes a new instance of the InstallationException class.


InstallationException Constructor (message)

InstallationException Constructor (message)
Namespaces ► Sitecore.Install.Utils ► InstallationException ► InstallationException(String)
Initializes a new instance of the InstallationException class.
Declaration Syntax
C#
public InstallationException(
    string message
)
Parameters
message (String)
The message.


InstallationException Constructor (message, innerException)

InstallationException Constructor (message, innerException)
Namespaces ► Sitecore.Install.Utils ► InstallationException ► InstallationException(String, Exception)
Initializes a new instance of the InstallationException class.
Declaration Syntax
C#
public InstallationException(
    string message,
    Exception innerException
)
Parameters
message (String)
The message.
innerException (Exception)
The inner exception.


InstallerMarker Class

InstallerMarker Class
Namespaces ► Sitecore.Install.Utils ► InstallerMarker
Add an entry with a installer version to a sink
Declaration Syntax
C#
public class InstallerMarker : ISource<PackageEntry>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InstallerMarker()()() | Initializes a new instance of the InstallerMarker class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Populate(ISink<(Of <(PackageEntry>)>)) | Add an entry with a installer version to a sink.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InstallerMarker


InstallerMarker Constructor

InstallerMarker Constructor
Namespaces ► Sitecore.Install.Utils ► InstallerMarker ► InstallerMarker()()()
Initializes a new instance of the InstallerMarker class
Declaration Syntax
C#
public InstallerMarker()


Populate Method (sink)

Populate Method (sink)
Namespaces ► Sitecore.Install.Utils ► InstallerMarker ► Populate(ISink<(Of <(PackageEntry>)>))
Add an entry with a installer version to a sink.
Declaration Syntax
C#
public void Populate(
    ISink<PackageEntry> sink
)
Parameters
sink (ISink <(Of <( PackageEntry >)>))
The sink.


InstallerVersion Class

InstallerVersion Class
Namespaces ► Sitecore.Install.Utils ► InstallerVersion
Contains methods to work with versions of the instraller
Declaration Syntax
C#
public static class InstallerVersion
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CanHandleVersion(String) | Determines whether this version of packager can handle the specified package version.
 | GetInstallerVersion()()() | Gets the installer version.
Inheritance Hierarchy
Object
InstallerVersion


CanHandleVersion Method (packageVersion)

CanHandleVersion Method (packageVersion)
Namespaces ► Sitecore.Install.Utils ► InstallerVersion ► CanHandleVersion(String)
Determines whether this version of packager can handle the specified package version.
Declaration Syntax
C#
public static bool CanHandleVersion(
    string packageVersion
)
Parameters
packageVersion (String)
The package version.
Return Value


GetInstallerVersion Method

GetInstallerVersion Method
Namespaces ► Sitecore.Install.Utils ► InstallerVersion ► GetInstallerVersion()()()
Gets the installer version.
Declaration Syntax
C#
public static string GetInstallerVersion()
Return Value
The installer version.


InstallMode Enumeration

InstallMode Enumeration
Namespaces ► Sitecore.Install.Utils ► InstallMode
Defines what to do with an item in collision
Declaration Syntax
C#
public enum InstallMode
Members
Member | Description
Overwrite | Delete item -> add item from template -> append versions
Merge | See ItemMergeVersionMode acions
Skip | Skips item
SideBySide | Installs new item with same path but different ID (for path collision only)
Undefined |


ItemInfo Class

ItemInfo Class
Namespaces ► Sitecore.Install.Utils ► ItemInfo
Item iformation
Declaration Syntax
C#
public class ItemInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemInfo(Item) | Initializes a new instance of the ItemInfo class.
 | ItemInfo(ItemReference, XmlVersionParser) | Initializes a new instance of the ItemInfo class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets the path.
 | TemplateID | Gets the template ID.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemInfo


ItemInfo Constructor

ItemInfo Constructor
Namespaces ► Sitecore.Install.Utils ► ItemInfo ► ItemInfo()()()
Members
Icon | Member | Description
 | ItemInfo(Item) | Initializes a new instance of the ItemInfo class.
 | ItemInfo(ItemReference, XmlVersionParser) | Initializes a new instance of the ItemInfo class.


ItemInfo Constructor (item)

ItemInfo Constructor (item)
Namespaces ► Sitecore.Install.Utils ► ItemInfo ► ItemInfo(Item)
Initializes a new instance of the ItemInfo class.
Declaration Syntax
C#
public ItemInfo(
    Item item
)
Parameters
item (Item)
The item.


ItemInfo Constructor (reference, parser)

ItemInfo Constructor (reference, parser)
Namespaces ► Sitecore.Install.Utils ► ItemInfo ► ItemInfo(ItemReference, XmlVersionParser)
Initializes a new instance of the ItemInfo class.
Declaration Syntax
C#
public ItemInfo(
    ItemReference reference,
    XmlVersionParser parser
)
Parameters
reference (ItemReference)
The reference.
parser (XmlVersionParser)
The parser.


ID Property

ID Property
Namespaces ► Sitecore.Install.Utils ► ItemInfo ► ID
Gets the ID.
Declaration Syntax
C#
public string ID { get; }
Value
The ID.


Path Property

Path Property
Namespaces ► Sitecore.Install.Utils ► ItemInfo ► Path
Gets the path.
Declaration Syntax
C#
public string Path { get; }
Value
The path.


TemplateID Property

TemplateID Property
Namespaces ► Sitecore.Install.Utils ► ItemInfo ► TemplateID
Gets the template ID.
Declaration Syntax
C#
public string TemplateID { get; }
Value
The template ID.


MergeMode Enumeration

MergeMode Enumeration
Namespaces ► Sitecore.Install.Utils ► MergeMode
Defines item merge mode
Declaration Syntax
C#
public enum MergeMode
Members
Member | Description
Clear | Delete versions -> Append versions
Append | Append versions
Merge | Merge versions by versions number
Undefined |


PackageUser Enumeration

PackageUser Enumeration
Namespaces ► Sitecore.Install.Utils ► PackageUser
Package user type
Declaration Syntax
C#
public enum PackageUser
Members
Member | Description
Developer |
EndUser |


SitecoreLogger Class

SitecoreLogger Class
Namespaces ► Sitecore.Install.Utils ► SitecoreLogger
Wrapper for Sitecore.Diagnostics.Log class
Declaration Syntax
C#
public class SitecoreLogger : ILogger
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SitecoreLogger()()() | Initializes a new instance of the SitecoreLogger class.
 | SitecoreLogger(Object) | Initializes a new instance of the SitecoreLogger class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error(String, array<Object>[]()[]) | Audits an error
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Info(String, array<Object>[]()[]) | Audits some information
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SitecoreLogger


SitecoreLogger Constructor

SitecoreLogger Constructor
Namespaces ► Sitecore.Install.Utils ► SitecoreLogger ► SitecoreLogger()()()
Members
Icon | Member | Description
 | SitecoreLogger()()() | Initializes a new instance of the SitecoreLogger class.
 | SitecoreLogger(Object) | Initializes a new instance of the SitecoreLogger class.


SitecoreLogger Constructor

SitecoreLogger Constructor
Namespaces ► Sitecore.Install.Utils ► SitecoreLogger ► SitecoreLogger()()()
Initializes a new instance of the SitecoreLogger class.
Declaration Syntax
C#
public SitecoreLogger()


SitecoreLogger Constructor (source)

SitecoreLogger Constructor (source)
Namespaces ► Sitecore.Install.Utils ► SitecoreLogger ► SitecoreLogger(Object)
Initializes a new instance of the SitecoreLogger class.
Declaration Syntax
C#
public SitecoreLogger(
    Object source
)
Parameters
source (Object)
The source.


Error Method (format, args)

Error Method (format, args)
Namespaces ► Sitecore.Install.Utils ► SitecoreLogger ► Error(String, array<Object>[]()[])
Audits an error
Declaration Syntax
C#
public void Error(
    string format,
    params Object[] args
)
Parameters
format (String)
The format string.
args (array< Object >[]()[])
The arguments.


Info Method (format, args)

Info Method (format, args)
Namespaces ► Sitecore.Install.Utils ► SitecoreLogger ► Info(String, array<Object>[]()[])
Audits some information
Declaration Syntax
C#
public void Info(
    string format,
    params Object[] args
)
Parameters
format (String)
The format string.
args (array< Object >[]()[])
The arguments.


StatusFile Class

StatusFile Class
Namespaces ► Sitecore.Install.Utils ► StatusFile
Wrapper around a file-based one-way communication channel.
Declaration Syntax
C#
public class StatusFile
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StatusFile(String) | Initializes a new instance of the StatusFile class.
 | CreateStatusInfo(StatusFile..::.Status, String, array<Object>[]()[]) | Creates the status info.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileName | Gets the name of the file.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadStatus()()() | Gets the status.
 | ReportError(Exception, array<Object>[]()[]) | Reports the error.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteFinished(String, array<Object>[]()[]) | Writes the finished.
 | WriteWorking(String, array<Object>[]()[]) | Sets the status.
Inheritance Hierarchy
Object
StatusFile


StatusFile Constructor (filename)

StatusFile Constructor (filename)
Namespaces ► Sitecore.Install.Utils ► StatusFile ► StatusFile(String)
Initializes a new instance of the StatusFile class.
Declaration Syntax
C#
public StatusFile(
    string filename
)
Parameters
filename (String)
The filename.


CreateStatusInfo Method (status, message, args)

CreateStatusInfo Method (status, message, args)
Namespaces ► Sitecore.Install.Utils ► StatusFile ► CreateStatusInfo(StatusFile..::.Status, String, array<Object>[]()[])
Creates the status info.
Declaration Syntax
C#
protected static StatusFile..::.StatusInfo CreateStatusInfo(
    StatusFile..::.Status status,
    string message,
    Object[] args
)
Parameters
status (StatusFile..::.Status)
The status.
message (String)
The message.
args (array< Object >[]()[])
The arguments.
Return Value
The status info.


FileName Property

FileName Property
Namespaces ► Sitecore.Install.Utils ► StatusFile ► FileName
Gets the name of the file.
Declaration Syntax
C#
public string FileName { get; }
Value
The name of the file.


ReadStatus Method

ReadStatus Method
Namespaces ► Sitecore.Install.Utils ► StatusFile ► ReadStatus()()()
Gets the status.
Declaration Syntax
C#
public StatusFile..::.StatusInfo ReadStatus()
Return Value
The status.


ReportError Method (exception, args)

ReportError Method (exception, args)
Namespaces ► Sitecore.Install.Utils ► StatusFile ► ReportError(Exception, array<Object>[]()[])
Reports the error.
Declaration Syntax
C#
public void ReportError(
    Exception exception,
    params Object[] args
)
Parameters
exception (Exception)
The exception.
args (array< Object >[]()[])
1 Optional data parameter.


WriteFinished Method (message, args)

WriteFinished Method (message, args)
Namespaces ► Sitecore.Install.Utils ► StatusFile ► WriteFinished(String, array<Object>[]()[])
Writes the finished.
Declaration Syntax
C#
public void WriteFinished(
    string message,
    params Object[] args
)
Parameters
message (String)
The message.
args (array< Object >[]()[])
1 Optional data parameter.


WriteWorking Method (message, args)

WriteWorking Method (message, args)
Namespaces ► Sitecore.Install.Utils ► StatusFile ► WriteWorking(String, array<Object>[]()[])
Sets the status.
Declaration Syntax
C#
public void WriteWorking(
    string message,
    params Object[] args
)
Parameters
message (String)
The message.
args (array< Object >[]()[])
Optional data parameter.


StatusFile.Status Enumeration

StatusFile..::.Status Enumeration
Namespaces ► Sitecore.Install.Utils ► StatusFile ► StatusFile..::.Status
Represents status of the operation.
Declaration Syntax
C#
[SerializableAttribute]
public enum Status
Members
Member | Description
Working | Background process is still working.
Finished | Background process has finished successfully.
Failed | Background process has failed with exception.


StatusFile.StatusInfo Class

StatusFile..::.StatusInfo Class
Namespaces ► Sitecore.Install.Utils ► StatusFile ► StatusFile..::.StatusInfo
Encapsulates status information passed from packaground worker.
Declaration Syntax
C#
[SerializableAttribute]
public class StatusInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StatusFile..::.StatusInfo(StatusFile..::.Status, String) | Initializes a new instance of the StatusFile..::.StatusInfo class.
 | StatusFile..::.StatusInfo(StatusFile..::.Status, Exception) | Initializes a new instance of the StatusFile..::.StatusInfo class.
 | Data | Gets the data.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exception | Gets the exception.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message.
 | Status | Gets the status.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
StatusFile..::.StatusInfo


StatusFile.StatusInfo Constructor

StatusFile..::.StatusInfo Constructor
Namespaces ► Sitecore.Install.Utils ► StatusFile..::.StatusInfo ► StatusFile..::.StatusInfo()()()
Members
Icon | Member | Description
 | StatusFile..::.StatusInfo(StatusFile..::.Status, String) | Initializes a new instance of the StatusFile..::.StatusInfo class.
 | StatusFile..::.StatusInfo(StatusFile..::.Status, Exception) | Initializes a new instance of the StatusFile..::.StatusInfo class.


StatusFile.StatusInfo Constructor (status, exception)

StatusFile..::.StatusInfo Constructor (status, exception)
Namespaces ► Sitecore.Install.Utils ► StatusFile..::.StatusInfo ► StatusFile..::.StatusInfo(StatusFile..::.Status, Exception)
Initializes a new instance of the StatusFile..::.StatusInfo class.
Declaration Syntax
C#
public StatusInfo(
    StatusFile..::.Status status,
    Exception exception
)
Parameters
status (StatusFile..::.Status)
The status.
exception (Exception)
The exception.


StatusFile.StatusInfo Constructor (status, message)

StatusFile..::.StatusInfo Constructor (status, message)
Namespaces ► Sitecore.Install.Utils ► StatusFile..::.StatusInfo ► StatusFile..::.StatusInfo(StatusFile..::.Status, String)
Initializes a new instance of the StatusFile..::.StatusInfo class.
Declaration Syntax
C#
public StatusInfo(
    StatusFile..::.Status status,
    string message
)
Parameters
status (StatusFile..::.Status)
The status.
message (String)
The message.


Data Property

Data Property
Namespaces ► Sitecore.Install.Utils ► StatusFile..::.StatusInfo ► Data
Gets the data.
Declaration Syntax
C#
public Object Data { get; set; }
Value
The data.


Exception Property

Exception Property
Namespaces ► Sitecore.Install.Utils ► StatusFile..::.StatusInfo ► Exception
Gets the exception.
Declaration Syntax
C#
public Exception Exception { get; set; }
Value
The exception.


Message Property

Message Property
Namespaces ► Sitecore.Install.Utils ► StatusFile..::.StatusInfo ► Message
Gets the message.
Declaration Syntax
C#
public string Message { get; set; }
Value
The message.


Status Property

Status Property
Namespaces ► Sitecore.Install.Utils ► StatusFile..::.StatusInfo ► Status
Gets the status.
Declaration Syntax
C#
public StatusFile..::.Status Status { get; set; }
Value
The status.


StringEntryData Class

StringEntryData Class
Namespaces ► Sitecore.Install.Utils ► StringEntryData
String entry data
Declaration Syntax
C#
public class StringEntryData : IEntryData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringEntryData(String, String) | Initializes a new instance of the StringEntryData class.
 | StringEntryData(String, String, Encoding) | Initializes a new instance of the StringEntryData class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStream()()() | Gets the stream holder.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
StringEntryData


StringEntryData Constructor

StringEntryData Constructor
Namespaces ► Sitecore.Install.Utils ► StringEntryData ► StringEntryData()()()
Members
Icon | Member | Description
 | StringEntryData(String, String) | Initializes a new instance of the StringEntryData class.
 | StringEntryData(String, String, Encoding) | Initializes a new instance of the StringEntryData class.


StringEntryData Constructor (key, content)

StringEntryData Constructor (key, content)
Namespaces ► Sitecore.Install.Utils ► StringEntryData ► StringEntryData(String, String)
Initializes a new instance of the StringEntryData class.
Declaration Syntax
C#
public StringEntryData(
    string key,
    string content
)
Parameters
key (String)
The key.
content (String)
The content.


StringEntryData Constructor (key, content, encoding)

StringEntryData Constructor (key, content, encoding)
Namespaces ► Sitecore.Install.Utils ► StringEntryData ► StringEntryData(String, String, Encoding)
Initializes a new instance of the StringEntryData class.
Declaration Syntax
C#
public StringEntryData(
    string key,
    string content,
    Encoding encoding
)
Parameters
key (String)
The key.
content (String)
The content.
encoding (Encoding)
The encoding.


GetStream Method

GetStream Method
Namespaces ► Sitecore.Install.Utils ► StringEntryData ► GetStream()()()
Gets the stream holder.
Declaration Syntax
C#
public IStreamHolder GetStream()
Return Value
The stream holder.


Key Property

Key Property
Namespaces ► Sitecore.Install.Utils ► StringEntryData ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


StrongStreamHolder Class

StrongStreamHolder Class
Namespaces ► Sitecore.Install.Utils ► StrongStreamHolder
Strong stream holder.
Declaration Syntax
C#
public class StrongStreamHolder : IStreamHolder,
    IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StrongStreamHolder(Stream) | Initializes a new instance of the StrongStreamHolder class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Stream | Gets the stream.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
StrongStreamHolder


StrongStreamHolder Constructor (stream)

StrongStreamHolder Constructor (stream)
Namespaces ► Sitecore.Install.Utils ► StrongStreamHolder ► StrongStreamHolder(Stream)
Initializes a new instance of the StrongStreamHolder class.
Declaration Syntax
C#
public StrongStreamHolder(
    Stream stream
)
Parameters
stream (Stream)
The stream.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Install.Utils ► StrongStreamHolder ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


Stream Property

Stream Property
Namespaces ► Sitecore.Install.Utils ► StrongStreamHolder ► Stream
Gets the stream.
Declaration Syntax
C#
public Stream Stream { get; }
Value
The stream.


Uniq Class

Uniq Class
Namespaces ► Sitecore.Install.Utils ► Uniq
Strips adjacent duplicate entries in the package
Declaration Syntax
C#
public class Uniq : BaseSink<PackageEntry>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Uniq(ISink<(Of <(PackageEntry>)>)) | Initializes a new instance of the Uniq class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Overrides BaseSink <(Of <( PackageEntry >)>).Finish()()().)
 | Flush()()() | Flushes the sink (Overrides BaseSink <(Of <( PackageEntry >)>).Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | Puts the specified entry if its key is different from the last parsed key. (Overrides BaseSink <(Of <( PackageEntry >)>).Put(T).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( PackageEntry >)>)
 |  | Uniq


Uniq Constructor (sink)

Uniq Constructor (sink)
Namespaces ► Sitecore.Install.Utils ► Uniq ► Uniq(ISink<(Of <(PackageEntry>)>))
Initializes a new instance of the Uniq class.
Declaration Syntax
C#
public Uniq(
    ISink<PackageEntry> sink
)
Parameters
sink (ISink <(Of <( PackageEntry >)>))
The sink.


Finish Method

Finish Method
Namespaces ► Sitecore.Install.Utils ► Uniq ► Finish()()()
Finishes the sink.
Declaration Syntax
C#
public override void Finish()


Flush Method

Flush Method
Namespaces ► Sitecore.Install.Utils ► Uniq ► Flush()()()
Flushes the sink
Declaration Syntax
C#
public override void Flush()


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Utils ► Uniq ► Put(PackageEntry)
Puts the specified entry if its key is different from the last parsed key.
Declaration Syntax
C#
public override void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


WeakStreamHolder Class

WeakStreamHolder Class
Namespaces ► Sitecore.Install.Utils ► WeakStreamHolder
Weak stream holder. Contains a reference to one stream
Declaration Syntax
C#
public class WeakStreamHolder : IStreamHolder,
    IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WeakStreamHolder(Stream) | Initializes a new instance of the WeakStreamHolder class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Stream | Gets the stream.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WeakStreamHolder


WeakStreamHolder Constructor (stream)

WeakStreamHolder Constructor (stream)
Namespaces ► Sitecore.Install.Utils ► WeakStreamHolder ► WeakStreamHolder(Stream)
Initializes a new instance of the WeakStreamHolder class.
Declaration Syntax
C#
public WeakStreamHolder(
    Stream stream
)
Parameters
stream (Stream)
The stream.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Install.Utils ► WeakStreamHolder ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


Stream Property

Stream Property
Namespaces ► Sitecore.Install.Utils ► WeakStreamHolder ► Stream
Gets the stream.
Declaration Syntax
C#
public Stream Stream { get; }
Value
The stream.


XmlVersionParser Class

XmlVersionParser Class
Namespaces ► Sitecore.Install.Utils ► XmlVersionParser
Xml version parser
Declaration Syntax
C#
public class XmlVersionParser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlVersionParser(PackageEntry) | Initializes a new instance of the XmlVersionParser class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | ParentID | Gets the parent ID.
 | TemplateID | Gets the template ID.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Xml | Gets the XML.
Inheritance Hierarchy
Object
XmlVersionParser


XmlVersionParser Constructor (entry)

XmlVersionParser Constructor (entry)
Namespaces ► Sitecore.Install.Utils ► XmlVersionParser ► XmlVersionParser(PackageEntry)
Initializes a new instance of the XmlVersionParser class.
Declaration Syntax
C#
public XmlVersionParser(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


Name Property

Name Property
Namespaces ► Sitecore.Install.Utils ► XmlVersionParser ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


ParentID Property

ParentID Property
Namespaces ► Sitecore.Install.Utils ► XmlVersionParser ► ParentID
Gets the parent ID.
Declaration Syntax
C#
public ID ParentID { get; }
Value
The parent ID.


TemplateID Property

TemplateID Property
Namespaces ► Sitecore.Install.Utils ► XmlVersionParser ► TemplateID
Gets the template ID.
Declaration Syntax
C#
public ID TemplateID { get; }
Value
The template ID.


Xml Property

Xml Property
Namespaces ► Sitecore.Install.Utils ► XmlVersionParser ► Xml
Gets the XML.
Declaration Syntax
C#
public XmlDocument Xml { get; }
Value
The XML.


Sitecore.Install.Zip Namespace

Sitecore.Install.Zip Namespace
Namespaces ► Sitecore.Install.Zip
Declaration Syntax
C#
namespace Sitecore.Install.Zip
Types
All Types Classes
Icon | Type | Description
 | PackageReader | Reads zip as a source of package entries
 | PackageWriter | Sink for PackageEntry that creates result zip file
 | ZipEntryData | Zip entry data


PackageReader Class

PackageReader Class
Namespaces ► Sitecore.Install.Zip ► PackageReader
Reads zip as a source of package entries
Declaration Syntax
C#
public class PackageReader : ISource<PackageEntry>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PackageReader()()() | Initializes a new instance of the PackageReader class. Should be used only during deserialization
 | PackageReader(String) | Initializes a new instance of the PackageReader class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileName | Gets or sets the name of the file.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Populate(ISink<(Of <(PackageEntry>)>)) | Populates specified sink with package entiries from the file.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PackageReader


PackageReader Constructor

PackageReader Constructor
Namespaces ► Sitecore.Install.Zip ► PackageReader ► PackageReader()()()
Members
Icon | Member | Description
 | PackageReader()()() | Initializes a new instance of the PackageReader class. Should be used only during deserialization
 | PackageReader(String) | Initializes a new instance of the PackageReader class.


PackageReader Constructor

PackageReader Constructor
Namespaces ► Sitecore.Install.Zip ► PackageReader ► PackageReader()()()
Initializes a new instance of the PackageReader class. Should be used only during deserialization
Declaration Syntax
C#
public PackageReader()


PackageReader Constructor (filename)

PackageReader Constructor (filename)
Namespaces ► Sitecore.Install.Zip ► PackageReader ► PackageReader(String)
Initializes a new instance of the PackageReader class.
Declaration Syntax
C#
public PackageReader(
    string filename
)
Parameters
filename (String)
The filename.


FileName Property

FileName Property
Namespaces ► Sitecore.Install.Zip ► PackageReader ► FileName
Gets or sets the name of the file.
Declaration Syntax
C#
public string FileName { get; set; }
Value
The name of the file.


Populate Method (sink)

Populate Method (sink)
Namespaces ► Sitecore.Install.Zip ► PackageReader ► Populate(ISink<(Of <(PackageEntry>)>))
Populates specified sink with package entiries from the file.
Declaration Syntax
C#
public void Populate(
    ISink<PackageEntry> sink
)
Parameters
sink (ISink <(Of <( PackageEntry >)>))
The sink.


PackageWriter Class

PackageWriter Class
Namespaces ► Sitecore.Install.Zip ► PackageWriter
Sink for PackageEntry that creates result zip file
Declaration Syntax
C#
public class PackageWriter : BaseSink<PackageEntry>,
    IDisposable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PackageWriter()()() | Initializes a new instance of the PackageWriter class.
 | PackageWriter(String) | Initializes a new instance of the PackageWriter class.
 | _processingContext | (Inherited from BaseSink<(Of <(T>)>).)
 | AssertInit()()() | Asserts the init. (Inherited from BaseSink<(Of <(T>)>).)
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finish()()() | Finishes the sink. (Overrides BaseSink <(Of <( PackageEntry >)>).Finish()()().)
 | Flush()()() | Flushes the sink (Overrides BaseSink <(Of <( PackageEntry >)>).Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(T>)>).)
 | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PackagePath | Gets or sets the package path.
 | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(T>)>).)
 | Put(PackageEntry) | Puts the specified entry to file. (Overrides BaseSink <(Of <( PackageEntry >)>).Put(T).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseSink <(Of <( PackageEntry >)>)
 |  | PackageWriter


PackageWriter Constructor

PackageWriter Constructor
Namespaces ► Sitecore.Install.Zip ► PackageWriter ► PackageWriter()()()
Members
Icon | Member | Description
 | PackageWriter()()() | Initializes a new instance of the PackageWriter class.
 | PackageWriter(String) | Initializes a new instance of the PackageWriter class.


PackageWriter Constructor

PackageWriter Constructor
Namespaces ► Sitecore.Install.Zip ► PackageWriter ► PackageWriter()()()
Initializes a new instance of the PackageWriter class.
Declaration Syntax
C#
public PackageWriter()


PackageWriter Constructor (filename)

PackageWriter Constructor (filename)
Namespaces ► Sitecore.Install.Zip ► PackageWriter ► PackageWriter(String)
Initializes a new instance of the PackageWriter class.
Declaration Syntax
C#
public PackageWriter(
    string filename
)
Parameters
filename (String)
The filename.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Install.Zip ► PackageWriter ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


Finish Method

Finish Method
Namespaces ► Sitecore.Install.Zip ► PackageWriter ► Finish()()()
Finishes the sink.
Declaration Syntax
C#
public override void Finish()


Flush Method

Flush Method
Namespaces ► Sitecore.Install.Zip ► PackageWriter ► Flush()()()
Flushes the sink
Declaration Syntax
C#
public override void Flush()


PackagePath Property

PackagePath Property
Namespaces ► Sitecore.Install.Zip ► PackageWriter ► PackagePath
Gets or sets the package path.
Declaration Syntax
C#
public string PackagePath { get; set; }
Value
The package path.


Put Method (entry)

Put Method (entry)
Namespaces ► Sitecore.Install.Zip ► PackageWriter ► Put(PackageEntry)
Puts the specified entry to file.
Declaration Syntax
C#
public override void Put(
    PackageEntry entry
)
Parameters
entry (PackageEntry)
The entry.


ZipEntryData Class

ZipEntryData Class
Namespaces ► Sitecore.Install.Zip ► ZipEntryData
Zip entry data
Declaration Syntax
C#
public class ZipEntryData : IEntryData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZipEntryData(ZipEntry) | Initializes a new instance of the ZipEntryData class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStream()()() | Gets the stream holder.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Key | Gets the key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ZipEntryData


ZipEntryData Constructor (entry)

ZipEntryData Constructor (entry)
Namespaces ► Sitecore.Install.Zip ► ZipEntryData ► ZipEntryData(ZipEntry)
Initializes a new instance of the ZipEntryData class.
Declaration Syntax
C#
public ZipEntryData(
    ZipEntry entry
)
Parameters
entry (ZipEntry)
The entry.


GetStream Method

GetStream Method
Namespaces ► Sitecore.Install.Zip ► ZipEntryData ► GetStream()()()
Gets the stream holder.
Declaration Syntax
C#
public IStreamHolder GetStream()
Return Value
The stream holder.


Key Property

Key Property
Namespaces ► Sitecore.Install.Zip ► ZipEntryData ► Key
Gets the key.
Declaration Syntax
C#
public string Key { get; }
Value
The key.


Sitecore.IO Namespace

Sitecore.IO Namespace
Namespaces ► Sitecore.IO
Declaration Syntax
C#
namespace Sitecore.IO
Types
All Types Classes Enumerations
Icon | Type | Description
 | Compression | Implements compression for Lucene
 | Crc | Calculates Cycling Redundancy Check values.
 | FileUtil | Implements a utility class for manipulating files.
 | FileWatcher | Monitors a folder for changes to files.
 | LayoutWatcher | Implements a file watcher that looks for changes in the /Layout folder.
 | StreamSharer..::.MetaStream | StreamSharer.MetaStream class
 | SpecialFolder | Identifies special folders.
 | StreamSharer | StreamSharer.MetaStream class StreamSharer class
 | TempFolder | Represents the temporary folder.
 | UploadFile | Implements a class for simplifing upload of files from a HTML form.
 | XslWatcher | Implements a file watcher that monitors changes in the /Xsl folder.


Compression Class

Compression Class
Namespaces ► Sitecore.IO ► Compression
Implements compression for Lucene
Declaration Syntax
C#
public class Compression
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Compression()()() | Initializes a new instance of the Compression class
 | Compress(array<Byte>[]()[]) | Compresses the specified input.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Uncompress(array<Byte>[]()[]) | Uncompresses the specified input.
Inheritance Hierarchy
Object
Compression


Compression Constructor

Compression Constructor
Namespaces ► Sitecore.IO ► Compression ► Compression()()()
Initializes a new instance of the Compression class
Declaration Syntax
C#
public Compression()


Compress Method (input)

Compress Method (input)
Namespaces ► Sitecore.IO ► Compression ► Compress(array<Byte>[]()[])
Compresses the specified input.
Declaration Syntax
C#
public byte[] Compress(
    byte[] input
)
Parameters
input (array< Byte >[]()[])
The input.
Return Value


Uncompress Method (input)

Uncompress Method (input)
Namespaces ► Sitecore.IO ► Compression ► Uncompress(array<Byte>[]()[])
Uncompresses the specified input.
Declaration Syntax
C#
public byte[] Uncompress(
    byte[] input
)
Parameters
input (array< Byte >[]()[])
The input.
Return Value


Crc Class

Crc Class
Namespaces ► Sitecore.IO ► Crc
Calculates Cycling Redundancy Check values.
Declaration Syntax
C#
public static class Crc
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CRC(Stream) | Calculates the Crc value of the specified stream.
 | CRC(Stream, Int64, Int64) | Calculates the Crc value of the specified stream.
 | CRC(String) | Calculates the Crc value of the specified string.
 | CRC(array<Byte>[]()[]) | Calculates the Crc value of the specified byte array.
Inheritance Hierarchy
Object
Crc


CRC Method

CRC Method
Namespaces ► Sitecore.IO ► Crc ► CRC()()()
Members
Icon | Member | Description
 | CRC(Stream) | Calculates the Crc value of the specified stream.
 | CRC(Stream, Int64, Int64) | Calculates the Crc value of the specified stream.
 | CRC(String) | Calculates the Crc value of the specified string.
 | CRC(array<Byte>[]()[]) | Calculates the Crc value of the specified byte array.


CRC Method (bytes)

CRC Method (bytes)
Namespaces ► Sitecore.IO ► Crc ► CRC(array<Byte>[]()[])
Calculates the Crc value of the specified byte array.
Declaration Syntax
C#
public static long CRC(
    byte[] bytes
)
Parameters
bytes (array< Byte >[]()[])
The bytes.
Return Value
The Crc value


CRC Method (stream)

CRC Method (stream)
Namespaces ► Sitecore.IO ► Crc ► CRC(Stream)
Calculates the Crc value of the specified stream.
Declaration Syntax
C#
public static long CRC(
    Stream stream
)
Parameters
stream (Stream)
The stream.
Return Value
The Crc value


CRC Method (stream, offset, length)

CRC Method (stream, offset, length)
Namespaces ► Sitecore.IO ► Crc ► CRC(Stream, Int64, Int64)
Calculates the Crc value of the specified stream.
Declaration Syntax
C#
public static long CRC(
    Stream stream,
    long offset,
    long length
)
Parameters
stream (Stream)
The stream.
offset (Int64)
The offset.
length (Int64)
The length.
Return Value
The Crc value


CRC Method (text)

CRC Method (text)
Namespaces ► Sitecore.IO ► Crc ► CRC(String)
Calculates the Crc value of the specified string.
Declaration Syntax
C#
public static long CRC(
    string text
)
Parameters
text (String)
The text.
Return Value
The Crc value


FileUtil Class

FileUtil Class
Namespaces ► Sitecore.IO ► FileUtil
Implements a utility class for manipulating files.
Declaration Syntax
C#
public static class FileUtil
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AppendToFile(String, String) | Appends the text to a file.
 | Backup(XmlDocument, String) | Makes a backup file from an XML document.
 | BackupFile(String) | Copies a file to a file with a ".bak" extension.
 | BackupFilename(String) | Generates a backup filename with an ".bak" extension.
 | CloseFileStream(FileStream) | Closes a file stream.
 | CloseStream(Stream) | Closes a stream.
 | CopyStream(Stream, Stream, Int32) | Copies one stream to another.
 | CopyStream(Stream, Stream) | Copies one stream to another.
 | CopyTextFile(String, String) | Copies the text file.
 | CreateFile(String, Stream, Boolean) | Creates the file.
 | CreateFolder(String) | Create a folder (if it does not exist).
 | Delete(String) | Deletes a file.
 | Delete(String, Boolean) | Deletes a file.
 | DeleteDirectory(String) | Deletes a directory.
 | DeleteDirectory(String, Boolean) | Deletes a directory.
 | EmptyDirectory(String) | Deletes all files in the specified directory and all its subdirectories.
 | EnsureFileFolder(String) | Ensures that the folder part of a file path exists.
 | EnsureFolder(String) | Ensures that the folder part of a path exists.
 | Exists(String) | Checks if a file or folder exists.
 | FileExists(String) | Checks if a file exists.
 | FolderExists(String) | Checks if a folder exists.
 | GetBackupFilename(String) | Gets a filename for a backup file.
 | GetBackupFilename(String, String, String) | Gets a filename for a backup file.
 | GetExtension(String) | Gets the file extension of a path (without a leading dot).
 | GetFileLock(String) | Gets file specific lock object.
 | GetFileName(String) | Gets the name of the file.
 | GetFilePathFromFileUri(String) | Converts the file URI to a file path.
 | GetFiles(String, String, Boolean) | Gets the files matching a pattern.
 | GetFileSize(String) | Gets the size if a file.
 | GetFileTime(String) | Gets the last modified time of a file.
 | GetFileWriteTime(String) | Gets the last modified time of a file.
 | GetParentPath(String) | Gets the parent path.
 | GetPathSeparator(String) | Determines the separator used in a filename path.
 | GetSpecialFolder(SpecialFolder) | Gets the special folder.
 | GetUniqueFilename(String) | Gets a unique filename.
 | GetValidFilePath(String) | Gets a valid filename from a proposed path (ie. strip invalid chars).
 | GetWorkFilename(String, String, String) | Gets a unique filename.
 | IsAspxFile(String) | Check if a path denotes an aspx file.
 | IsFile(String) | Determines whether the specified path is an existing file.
 | IsFolder(String) | Determines whether the specified path is an existing folder.
 | IsFullyQualified(String) | Determines whether the filename is fully qualified.
 | IsReadOnly(String) | Determines whether the specified file is read only.
 | IsWritable(FileInfo) | Determines whether the specified file is writable.
 | LoadHashtable(String) | Loads a hashtable from a file.
 | LoadObject(String) | Loads the object from a file.
 | MakePath(String, String) | Makes a path from two filename parts.
 | MakePath(String, String, Char) | Makes a path from two filename parts.
 | MapDataFilePath(String) | Maps a filename to a physical filename in the data folder.
 | MapPath(String) | Maps a virtual file path to a physical file path.
 | MatchPattern(String, String) | Checks whether the value matches the pattern.
 | NormalizeWebPath(String) | Normalizes the web path by replacing all backslashes (\) with forward slashes (/).
 | OpenCreate(String) | Creates a new file and opens it in read/write mode.
 | OpenFileStream(String, FileMode, FileAccess, FileShare, Boolean, Boolean) | Opens the file stream.
 | OpenRead(String) | Opens a file in read mode.
 | OpenWrite(String) | Opens a file in write mode.
 | ReadBinaryFile(String) | Reads the binary file.
 | ReadFromFile(String) | Reads a text file.
 | ReadUTF8File(String) | Reads the file in UTF8 encoding.
 | ReplaceVariables(String) | Replaces variables in a filename.
 | Save(XmlDocument, String) | Saves an XML document to a file.
 | SaveHashtable(String, Hashtable) | Saves a hashtable to a file.
 | SaveObject(String, Object) | Saves an object to a file.
 | SaveToTemporaryFile(MediaItem) | Saves the Media Item's MediaStream to a temporary file and returns the path to that file.
 | SubtractPath(String, String) | Subtracts one path from another.
 | UnmapPath(String, Boolean) | Maps a physical path to a virtual path.
 | UnmapPath(String) | Maps a physical path to a virtual path.
 | WriteToFile(String, array<Byte>[]()[]%) | Writes a byte array to a file.
 | WriteToFile(String, String) | Writes a string to a file.
 | WriteToFile(String, String, Boolean) | Write or appends a atring to a file.
 | WriteToStream(Stream, Int32, Stream) | Writes one stream to another stream.
 | WriteUTF8File(String, String) | Writes the file in UTF8 encoding.
 | ZipFiles(String, array<String>[]()[]) | Zips a list of files.
Remarks
Inheritance Hierarchy
Object
FileUtil
See Also
DateUtil
HtmlUtil
MainUtil
StringUtil
WebUtil
XmlUtil


AppendToFile Method (filename, text)

AppendToFile Method (filename, text)
Namespaces ► Sitecore.IO ► FileUtil ► AppendToFile(String, String)
Appends the text to a file.
Declaration Syntax
C#
public static void AppendToFile(
    string filename,
    string text
)
Parameters
filename (String)
The filename.
text (String)
The text.


Backup Method (doc, baseFilename)

Backup Method (doc, baseFilename)
Namespaces ► Sitecore.IO ► FileUtil ► Backup(XmlDocument, String)
Makes a backup file from an XML document.
Declaration Syntax
C#
public static void Backup(
    XmlDocument doc,
    string baseFilename
)
Parameters
doc (XmlDocument)
An XML document which will be placed in the backup file.
baseFilename (String)
The base filename of the backup file. This name will be extended to make it unique within the backup folder.
Remarks
An exception is thrown if the XML document is null or the filename is blank.
Examples
The following example takes a backup of an XML document.
CopyC#
XmlDocument doc = new XmlDocument();
doc.LoadXml(myXmlString);
FileUtil.Backup(doc, "MyXml.xml");


BackupFile Method (filename)

BackupFile Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► BackupFile(String)
Copies a file to a file with a ".bak" extension.
Declaration Syntax
C#
public static string BackupFile(
    string filename
)
Parameters
filename (String)
The filename of the file which will be copied.
Return Value
The filename of the backup file.
Remarks
If the file does not exist, no file is copied and blank is returned.
Examples
The following example takes a backup of the robots.txt file in the root folder of the website. Afterwards there will be a robots.bak in the root folder.
CopyC#
string filename = MainUtil.MapPath("robots.txt");
FileUtil.BackupFile(filename);


BackupFilename Method (filename)

BackupFilename Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► BackupFilename(String)
Generates a backup filename with an ".bak" extension.
Declaration Syntax
C#
public static string BackupFilename(
    string filename
)
Parameters
filename (String)
A filename.
Return Value
The filename with the a new extension ".bak".
Examples
The following example generates a backup filename.
CopyC#
string filename = "MyXml.xml";
string backupname = FileUtil.BackupFilename(filename);
 The filename variable is "MyXml.bak" afterwards.


CloseFileStream Method (stream)

CloseFileStream Method (stream)
Namespaces ► Sitecore.IO ► FileUtil ► CloseFileStream(FileStream)
Closes a file stream.
Declaration Syntax
C#
public static void CloseFileStream(
    FileStream stream
)
Parameters
stream (FileStream)
The file.


CloseStream Method (stream)

CloseStream Method (stream)
Namespaces ► Sitecore.IO ► FileUtil ► CloseStream(Stream)
Closes a stream.
Declaration Syntax
C#
public static void CloseStream(
    Stream stream
)
Parameters
stream (Stream)
The stream.


CopyStream Method

CopyStream Method
Namespaces ► Sitecore.IO ► FileUtil ► CopyStream()()()
Members
Icon | Member | Description
 | CopyStream(Stream, Stream, Int32) | Copies one stream to another.
 | CopyStream(Stream, Stream) | Copies one stream to another.


CopyStream Method (from, to)

CopyStream Method (from, to)
Namespaces ► Sitecore.IO ► FileUtil ► CopyStream(Stream, Stream)
Copies one stream to another.
Declaration Syntax
C#
public static void CopyStream(
    Stream from,
    Stream to
)
Parameters
from (Stream)
From.
to (Stream)
To.


CopyStream Method (from, to, bufferSize)

CopyStream Method (from, to, bufferSize)
Namespaces ► Sitecore.IO ► FileUtil ► CopyStream(Stream, Stream, Int32)
Copies one stream to another.
Declaration Syntax
C#
public static void CopyStream(
    Stream from,
    Stream to,
    int bufferSize
)
Parameters
from (Stream)
From.
to (Stream)
To.
bufferSize (Int32)
Size of the buffer.


CopyTextFile Method (destination, source)

CopyTextFile Method (destination, source)
Namespaces ► Sitecore.IO ► FileUtil ► CopyTextFile(String, String)
Copies the text file.
Declaration Syntax
C#
public static void CopyTextFile(
    string destination,
    string source
)
Parameters
destination (String)
The destination.
source (String)
The source.
Remarks
The file is saved in UTF8 encoding.


CreateFile Method (filePath, inputStream, closeStream)

CreateFile Method (filePath, inputStream, closeStream)
Namespaces ► Sitecore.IO ► FileUtil ► CreateFile(String, Stream, Boolean)
Creates the file.
Declaration Syntax
C#
public static void CreateFile(
    string filePath,
    Stream inputStream,
    bool closeStream
)
Parameters
filePath (String)
The file path.
inputStream (Stream)
The input stream.
closeStream (Boolean)
if set to true the input stream will be closed.


CreateFolder Method (folder)

CreateFolder Method (folder)
Namespaces ► Sitecore.IO ► FileUtil ► CreateFolder(String)
Create a folder (if it does not exist).
Declaration Syntax
C#
public static bool CreateFolder(
    string folder
)
Parameters
folder (String)
The path.
Return Value


Delete Method

Delete Method
Namespaces ► Sitecore.IO ► FileUtil ► Delete()()()
Members
Icon | Member | Description
 | Delete(String) | Deletes a file.
 | Delete(String, Boolean) | Deletes a file.


Delete Method (fileName)

Delete Method (fileName)
Namespaces ► Sitecore.IO ► FileUtil ► Delete(String)
Deletes a file.
Declaration Syntax
C#
public static void Delete(
    string fileName
)
Parameters
fileName (String)
The path of the file.


Delete Method (path, includeDirectories)

Delete Method (path, includeDirectories)
Namespaces ► Sitecore.IO ► FileUtil ► Delete(String, Boolean)
Deletes a file.
Declaration Syntax
C#
public static void Delete(
    string path,
    bool includeDirectories
)
Parameters
path (String)
The path of the file.
includeDirectories (Boolean)
if set to true this instance includes directories.


DeleteDirectory Method

DeleteDirectory Method
Namespaces ► Sitecore.IO ► FileUtil ► DeleteDirectory()()()
Members
Icon | Member | Description
 | DeleteDirectory(String) | Deletes a directory.
 | DeleteDirectory(String, Boolean) | Deletes a directory.


DeleteDirectory Method (folder)

DeleteDirectory Method (folder)
Namespaces ► Sitecore.IO ► FileUtil ► DeleteDirectory(String)
Deletes a directory.
Declaration Syntax
C#
public static void DeleteDirectory(
    string folder
)
Parameters
folder (String)
The path of the directory.


DeleteDirectory Method (folder, recursive)

DeleteDirectory Method (folder, recursive)
Namespaces ► Sitecore.IO ► FileUtil ► DeleteDirectory(String, Boolean)
Deletes a directory.
Declaration Syntax
C#
public static void DeleteDirectory(
    string folder,
    bool recursive
)
Parameters
folder (String)
The path of the directory.
recursive (Boolean)
if set to true the action is recursive.


EmptyDirectory Method (folder)

EmptyDirectory Method (folder)
Namespaces ► Sitecore.IO ► FileUtil ► EmptyDirectory(String)
Deletes all files in the specified directory and all its subdirectories.
Declaration Syntax
C#
public static void EmptyDirectory(
    string folder
)
Parameters
folder (String)


EnsureFileFolder Method (filePath)

EnsureFileFolder Method (filePath)
Namespaces ► Sitecore.IO ► FileUtil ► EnsureFileFolder(String)
Ensures that the folder part of a file path exists.
Declaration Syntax
C#
public static void EnsureFileFolder(
    string filePath
)
Parameters
filePath (String)
The file path.
Remarks

For example, given the file path:

/images/new/image.jpg

the method will ensure that the folder '/images/new' is created if it does not exist.


EnsureFolder Method (path)

EnsureFolder Method (path)
Namespaces ► Sitecore.IO ► FileUtil ► EnsureFolder(String)
Ensures that the folder part of a path exists.
Declaration Syntax
C#
public static void EnsureFolder(
    string path
)
Parameters
path (String)
The path.


Exists Method (path)

Exists Method (path)
Namespaces ► Sitecore.IO ► FileUtil ► Exists(String)
Checks if a file or folder exists.
Declaration Syntax
C#
public static bool Exists(
    string path
)
Parameters
path (String)
The path to the file or folder.
Return Value
True, if the file or folder exists, otherwise false.
Examples
The following example checks if the robots.txt file exists and if it does make a backup of it.
CopyC#
string filename = MainUtil.MapPath("robots.txt");
if (FileUtil.Exists(filename)) {
FileUtil.BackupFile(filename);
}


FileExists Method (filename)

FileExists Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► FileExists(String)
Checks if a file exists.
Declaration Syntax
C#
public static bool FileExists(
    string filename
)
Parameters
filename (String)
The name of the file.
Return Value
True, if the file exists, otherwise false.
Examples
The following example checks if the robots.txt file exists and if it does make a backup of it.
CopyC#
string filename = MainUtil.MapPath("robots.txt");
if (FileUtil.FileExists(filename)) {
FileUtil.BackupFile(filename);
}


FolderExists Method (folder)

FolderExists Method (folder)
Namespaces ► Sitecore.IO ► FileUtil ► FolderExists(String)
Checks if a folder exists.
Declaration Syntax
C#
public static bool FolderExists(
    string folder
)
Parameters
folder (String)
The name of the folder.
Return Value
True, if the folder exists, otherwise false.
Examples
The following example checks if the data folder exists.
CopyC#
string folderPath = MainUtil.MapPath("/data");
if (FileUtil.FolderExists(folderPath)) {
MainUtil.Out("Folder exists: " + folderPath);
}


GetBackupFilename Method

GetBackupFilename Method
Namespaces ► Sitecore.IO ► FileUtil ► GetBackupFilename()()()
Members
Icon | Member | Description
 | GetBackupFilename(String) | Gets a filename for a backup file.
 | GetBackupFilename(String, String, String) | Gets a filename for a backup file.


GetBackupFilename Method (baseFilename)

GetBackupFilename Method (baseFilename)
Namespaces ► Sitecore.IO ► FileUtil ► GetBackupFilename(String)
Gets a filename for a backup file.
Declaration Syntax
C#
public static string GetBackupFilename(
    string baseFilename
)
Parameters
baseFilename (String)
The base filename.
Return Value
A unique filename.
Remarks
The filename is made unique by inserting a timestamp in the filename. The timestamp is a ISO formatted date/time string. The date/time string is formatted as "yyyyMMddTHHmmss".
Examples
The following example finds the backup filename for the robots.txt. Afterwards the backupname variable holds a name like "c:\inetpub\wwwroot\default website\robots_20030101T120000.txt".
CopyC#
string filename = MainUtil.MapPath("robots.txt");
string backupname = FileUtil.GetBackupFilename(filename);


GetBackupFilename Method (folder, prefix, extension)

GetBackupFilename Method (folder, prefix, extension)
Namespaces ► Sitecore.IO ► FileUtil ► GetBackupFilename(String, String, String)
Gets a filename for a backup file.
Declaration Syntax
C#
public static string GetBackupFilename(
    string folder,
    string prefix,
    string extension
)
Parameters
folder (String)
The folder of a file.
prefix (String)
The file prefix of a file (usually the filename itself).
extension (String)
The extension of a file.
Return Value
A unique filename.
Remarks
The filename is made unique by inserting a timestamp in the filename. The timestamp is a ISO formatted date/time string. The date/time string is formatted as "yyyyMMddTHHmmss".
Examples
The following example finds the backup filename for the robots.txt. Afterwards the backupname variable holds a name like "c:\inetpub\wwwroot\default website\robots_20030101T120000.txt".
CopyC#
string backupname = FileUtil.GetBackupFilename(@"c:\inetpub\wwwroot\default website", "robots", "txt");


GetExtension Method (path)

GetExtension Method (path)
Namespaces ► Sitecore.IO ► FileUtil ► GetExtension(String)
Gets the file extension of a path (without a leading dot).
Declaration Syntax
C#
public static string GetExtension(
    string path
)
Parameters
path (String)
The path.
Return Value
Examples
CopyC#
string extension = FileUtil.GetExtension("/temp/document.txt");  // returns 'txt'


GetFileLock Method (path)

GetFileLock Method (path)
Namespaces ► Sitecore.IO ► FileUtil ► GetFileLock(String)
Gets file specific lock object.
Declaration Syntax
C#
public static Object GetFileLock(
    string path
)
Parameters
path (String)
A filename path.
Return Value
The lock object.


GetFileName Method (filename)

GetFileName Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► GetFileName(String)
Gets the name of the file.
Declaration Syntax
C#
public static string GetFileName(
    string filename
)
Parameters
filename (String)
The path.
Return Value


GetFilePathFromFileUri Method (fileUri)

GetFilePathFromFileUri Method (fileUri)
Namespaces ► Sitecore.IO ► FileUtil ► GetFilePathFromFileUri(String)
Converts the file URI to a file path.
Declaration Syntax
C#
public static string GetFilePathFromFileUri(
    string fileUri
)
Parameters
fileUri (String)
The file URI.
Return Value
The file path corresponding to the URI.


GetFiles Method (folder, pattern, mapResult)

GetFiles Method (folder, pattern, mapResult)
Namespaces ► Sitecore.IO ► FileUtil ► GetFiles(String, String, Boolean)
Gets the files matching a pattern.
Declaration Syntax
C#
public static StringList GetFiles(
    string folder,
    string pattern,
    bool mapResult
)
Parameters
folder (String)
The folder.
pattern (String)
The pattern.
mapResult (Boolean)
If set to true the resulting file paths will be mapped (using MapPath(String)).
Return Value


GetFileSize Method (filePath)

GetFileSize Method (filePath)
Namespaces ► Sitecore.IO ► FileUtil ► GetFileSize(String)
Gets the size if a file.
Declaration Syntax
C#
public static long GetFileSize(
    string filePath
)
Parameters
filePath (String)
A filename (including path).
Return Value
The size of the file in bytes. If the file does not exist, -1 is returned.


GetFileTime Method (filename)

GetFileTime Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► GetFileTime(String)
Gets the last modified time of a file.
Declaration Syntax
C#
public static string GetFileTime(
    string filename
)
Parameters
filename (String)
A filename path.
Return Value
The last modified time of the file as a string.
Remarks
If the file does not have a last modified time, blank is returned.
Examples
CopyC#
string lastModified = FileUtil.GetFileTime("/robots.txt");


GetFileWriteTime Method (filename)

GetFileWriteTime Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► GetFileWriteTime(String)
Gets the last modified time of a file.
Declaration Syntax
C#
public static DateTime GetFileWriteTime(
    string filename
)
Parameters
filename (String)
A filename path.
Return Value
The last modified time of the file as a date/time.
Remarks
If the file does not have a last modified time, DateTime.MinValue is returned.
Examples
CopyC#
DateTime lastModified = FileUtil.GetFileWriteTime("/robots.txt");


GetParentPath Method (path)

GetParentPath Method (path)
Namespaces ► Sitecore.IO ► FileUtil ► GetParentPath(String)
Gets the parent path.
Declaration Syntax
C#
public static string GetParentPath(
    string path
)
Parameters
path (String)
The path.
Return Value


GetPathSeparator Method (path)

GetPathSeparator Method (path)
Namespaces ► Sitecore.IO ► FileUtil ► GetPathSeparator(String)
Determines the separator used in a filename path.
Declaration Syntax
C#
public static char GetPathSeparator(
    string path
)
Parameters
path (String)
A filename path.
Return Value
The separator character (slash (/) or backslash (\)).
Remarks
In paths with mixed separators, the backslash (\) takes precedens over the slash. If the filename path is blank, slash (/) is returned.
Examples
CopyC#
char s1 = FileUtil.GetPathSeparator("/sitecore/data/masterdata.xml"); // returns /
char s2 = FileUtil.GetPathSeparator(@"c:\inetpub\wwwroot\default site"); // returns \
char s3 = FileUtil.GetPathSeparator(@"c:\inetpub\wwwroot\default site/sitecore/data/masterdata.xml"); // returns \


GetSpecialFolder Method (folder)

GetSpecialFolder Method (folder)
Namespaces ► Sitecore.IO ► FileUtil ► GetSpecialFolder(SpecialFolder)
Gets the special folder.
Declaration Syntax
C#
public static string GetSpecialFolder(
    SpecialFolder folder
)
Parameters
folder (SpecialFolder)
The folder.
Return Value


GetUniqueFilename Method (filePath)

GetUniqueFilename Method (filePath)
Namespaces ► Sitecore.IO ► FileUtil ► GetUniqueFilename(String)
Gets a unique filename.
Declaration Syntax
C#
public static string GetUniqueFilename(
    string filePath
)
Parameters
filePath (String)
The file path.
Return Value


GetValidFilePath Method (proposedPath)

GetValidFilePath Method (proposedPath)
Namespaces ► Sitecore.IO ► FileUtil ► GetValidFilePath(String)
Gets a valid filename from a proposed path (ie. strip invalid chars).
Declaration Syntax
C#
public static string GetValidFilePath(
    string proposedPath
)
Parameters
proposedPath (String)
The proposed path.
Return Value


GetWorkFilename Method (folder, prefix, extension)

GetWorkFilename Method (folder, prefix, extension)
Namespaces ► Sitecore.IO ► FileUtil ► GetWorkFilename(String, String, String)
Gets a unique filename.
Declaration Syntax
C#
public static string GetWorkFilename(
    string folder,
    string prefix,
    string extension
)
Parameters
folder (String)
The folder of a file.
prefix (String)
The file prefix of a file (usually the filename itself).
extension (String)
The extension of a file.
Return Value
The unique filename.
Remarks
The filename is made unique by inserting a running serial number into it.
Examples
The following example gets a unique filename for the robots.txt file. Afterwards the backupname variable holds a name like "c:\inetpub\wwwroot\default website\robots_00001.txt".
CopyC#
string backupname = FileUtil.GetWorkFilename(@"c:\inetpub\wwwroot\default website", "robots", "txt");


IsAspxFile Method (filename)

IsAspxFile Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► IsAspxFile(String)
Check if a path denotes an aspx file.
Declaration Syntax
C#
public static bool IsAspxFile(
    string filename
)
Parameters
filename (String)
The path.
Return Value
true if the file is an aspx file; otherwise, false.


IsFile Method (filename)

IsFile Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► IsFile(String)
Determines whether the specified path is an existing file.
Declaration Syntax
C#
public static bool IsFile(
    string filename
)
Parameters
filename (String)
The path.
Return Value
true if the specified path is an existing file; otherwise, false.


IsFolder Method (folder)

IsFolder Method (folder)
Namespaces ► Sitecore.IO ► FileUtil ► IsFolder(String)
Determines whether the specified path is an existing folder.
Declaration Syntax
C#
public static bool IsFolder(
    string folder
)
Parameters
folder (String)
The path.
Return Value
true if the specified path is an existing folder; otherwise, false.


IsFullyQualified Method (filename)

IsFullyQualified Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► IsFullyQualified(String)
Determines whether the filename is fully qualified.
Declaration Syntax
C#
public static bool IsFullyQualified(
    string filename
)
Parameters
filename (String)
The filename.
Return Value
true if the filename is fully qualified; otherwise, false.


IsReadOnly Method (filename)

IsReadOnly Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► IsReadOnly(String)
Determines whether the specified file is read only.
Declaration Syntax
C#
public static bool IsReadOnly(
    string filename
)
Parameters
filename (String)
The filename.
Return Value
true if the specified file is read only; otherwise, false.


IsWritable Method (file)

IsWritable Method (file)
Namespaces ► Sitecore.IO ► FileUtil ► IsWritable(FileInfo)
Determines whether the specified file is writable.
Declaration Syntax
C#
public static bool IsWritable(
    FileInfo file
)
Parameters
file (FileInfo)
The file.
Return Value
true if the specified file is writable; otherwise, false.


LoadHashtable Method (filename)

LoadHashtable Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► LoadHashtable(String)
Loads a hashtable from a file.
Declaration Syntax
C#
public static Hashtable LoadHashtable(
    string filename
)
Parameters
filename (String)
The filename.
Return Value


LoadObject Method (filename)

LoadObject Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► LoadObject(String)
Loads the object from a file.
Declaration Syntax
C#
public static Object LoadObject(
    string filename
)
Parameters
filename (String)
The filename.
Return Value


MakePath Method

MakePath Method
Namespaces ► Sitecore.IO ► FileUtil ► MakePath()()()
Members
Icon | Member | Description
 | MakePath(String, String) | Makes a path from two filename parts.
 | MakePath(String, String, Char) | Makes a path from two filename parts.


MakePath Method (part1, part2)

MakePath Method (part1, part2)
Namespaces ► Sitecore.IO ► FileUtil ► MakePath(String, String)
Makes a path from two filename parts.
Declaration Syntax
C#
public static string MakePath(
    string part1,
    string part2
)
Parameters
part1 (String)
The first part of the filename.
part2 (String)
The second part of the filename.
Return Value
The two parts concatenated with a separator in between.
Remarks
The parts are seperated by the separator used in the first part.
Examples
The following example joins "c:\inetpub\wwwroot\default website" and "robots.txt" into a single string seperated by a backslash (\).
CopyC#
string filename = FileUtil.MakePath(@"c:\inetpub\wwwroot\default website", "robots");


MakePath Method (part1, part2, separator)

MakePath Method (part1, part2, separator)
Namespaces ► Sitecore.IO ► FileUtil ► MakePath(String, String, Char)
Makes a path from two filename parts.
Declaration Syntax
C#
public static string MakePath(
    string part1,
    string part2,
    char separator
)
Parameters
part1 (String)
The first part of the filename.
part2 (String)
The second part of the filename.
separator (Char)
A separator character.
Return Value
The two parts concatenated with the separator in between.
Examples
The following example joins "c:\inetpub\wwwroot\default website" and "robots.txt" into a single string seperated by a backslash (\).
CopyC#
string filename = FileUtil.MakePath(@"c:\inetpub\wwwroot\default website", "robots", "\\");


MapDataFilePath Method (path)

MapDataFilePath Method (path)
Namespaces ► Sitecore.IO ► FileUtil ► MapDataFilePath(String)
Maps a filename to a physical filename in the data folder.
Declaration Syntax
C#
public static string MapDataFilePath(
    string path
)
Parameters
path (String)
A filename path.
Return Value
A filename in the data folder.
Remarks
If the path does not contain any folder information, the file is assumed to be located in the data folder. The data folder is specified by the Settings.DataFolder setting.
Examples
The following example returns the filename of the mydata.xml file in the data folder. Afterwards the filename variable holds a value like "c:\inetpub\wwwroot\default website\sitecore\data\mydata.xml".
CopyC#
string filename = FileUtil.MapDataFilePath("mydata.xml");


MapPath Method (path)

MapPath Method (path)
Namespaces ► Sitecore.IO ► FileUtil ► MapPath(String)
Maps a virtual file path to a physical file path.
Declaration Syntax
C#
public static string MapPath(
    string path
)
Parameters
path (String)
A virtual file path.
Return Value
The physical file path.
Remarks
If the file path is blank, contains a backslash (\) or contains the string "://" the path itself is returned.
Examples
The following example returns the physical filename of the mydata.xml file in the data folder. Afterwards the filename variable holds a value like "c:\inetpub\wwwroot\default website\sitecore\data\mydata.xml".
CopyC#
string filename = FileUtil.MapPath("/sitecore/data/mydata.xml");


MatchPattern Method (value, pattern)

MatchPattern Method (value, pattern)
Namespaces ► Sitecore.IO ► FileUtil ► MatchPattern(String, String)
Checks whether the value matches the pattern.
Declaration Syntax
C#
public static bool MatchPattern(
    string value,
    string pattern
)
Parameters
value (String)
The value.
pattern (String)
The pattern.
Return Value


NormalizeWebPath Method (path)

NormalizeWebPath Method (path)
Namespaces ► Sitecore.IO ► FileUtil ► NormalizeWebPath(String)
Normalizes the web path by replacing all backslashes (\) with forward slashes (/).
Declaration Syntax
C#
public static string NormalizeWebPath(
    string path
)
Parameters
path (String)
The path.
Return Value


OpenCreate Method (filePath)

OpenCreate Method (filePath)
Namespaces ► Sitecore.IO ► FileUtil ► OpenCreate(String)
Creates a new file and opens it in read/write mode.
Declaration Syntax
C#
public static FileStream OpenCreate(
    string filePath
)
Parameters
filePath (String)
The file path.
Return Value


OpenFileStream Method (filePath, mode, access, share, createFolder, logErrors)

OpenFileStream Method (filePath, mode, access, share, createFolder, logErrors)
Namespaces ► Sitecore.IO ► FileUtil ► OpenFileStream(String, FileMode, FileAccess, FileShare, Boolean, Boolean)
Opens the file stream.
Declaration Syntax
C#
public static FileStream OpenFileStream(
    string filePath,
    FileMode mode,
    FileAccess access,
    FileShare share,
    bool createFolder,
    bool logErrors
)
Parameters
filePath (String)
The filename.
mode (FileMode)
The mode.
access (FileAccess)
The access.
share (FileShare)
The share.
createFolder (Boolean)
if set to true this instance is create folder.
logErrors (Boolean)
if set to true this instance is log errors.
Return Value


OpenRead Method (filePath)

OpenRead Method (filePath)
Namespaces ► Sitecore.IO ► FileUtil ► OpenRead(String)
Opens a file in read mode.
Declaration Syntax
C#
public static FileStream OpenRead(
    string filePath
)
Parameters
filePath (String)
The file path.
Return Value


OpenWrite Method (filePath)

OpenWrite Method (filePath)
Namespaces ► Sitecore.IO ► FileUtil ► OpenWrite(String)
Opens a file in write mode.
Declaration Syntax
C#
public static FileStream OpenWrite(
    string filePath
)
Parameters
filePath (String)
The file path.
Return Value


ReadBinaryFile Method (filename)

ReadBinaryFile Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► ReadBinaryFile(String)
Reads the binary file.
Declaration Syntax
C#
public static byte[] ReadBinaryFile(
    string filename
)
Parameters
filename (String)
Name of the file.
Return Value


ReadFromFile Method (path)

ReadFromFile Method (path)
Namespaces ► Sitecore.IO ► FileUtil ► ReadFromFile(String)
Reads a text file.
Declaration Syntax
C#
public static string ReadFromFile(
    string path
)
Parameters
path (String)
A file name.
Return Value
The content of the file.
Remarks
If the file is not found, an exception is written to the trace file and blank is returned.
Examples
CopyC#
string text = MainUtil.ReadFromFile("/robots.txt");


ReadUTF8File Method (filename)

ReadUTF8File Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► ReadUTF8File(String)
Reads the file in UTF8 encoding.
Declaration Syntax
C#
public static string ReadUTF8File(
    string filename
)
Parameters
filename (String)
The filename.
Return Value


ReplaceVariables Method (filename)

ReplaceVariables Method (filename)
Namespaces ► Sitecore.IO ► FileUtil ► ReplaceVariables(String)
Replaces variables in a filename.
Declaration Syntax
C#
public static string ReplaceVariables(
    string filename
)
Parameters
filename (String)
The filename.
Return Value
Remarks
Currently only {$date} is supported.


Save Method (doc, filename)

Save Method (doc, filename)
Namespaces ► Sitecore.IO ► FileUtil ► Save(XmlDocument, String)
Saves an XML document to a file.
Declaration Syntax
C#
public static void Save(
    XmlDocument doc,
    string filename
)
Parameters
doc (XmlDocument)
An XML document to be saved.
filename (String)
A filename.
Remarks
The XML document is first saved to a temporary file, then the temporary file is renamed to the name of the original file.
Examples
The following example saves the XML document in the xml variable to a file
CopyC#
string filename = FileUtil.MapPath("/sitecore/data/mydata.xml");
FileUtil.Save(xml, filename);


SaveHashtable Method (filename, data)

SaveHashtable Method (filename, data)
Namespaces ► Sitecore.IO ► FileUtil ► SaveHashtable(String, Hashtable)
Saves a hashtable to a file.
Declaration Syntax
C#
public static void SaveHashtable(
    string filename,
    Hashtable data
)
Parameters
filename (String)
The filename.
data (Hashtable)
The data.


SaveObject Method (filename, data)

SaveObject Method (filename, data)
Namespaces ► Sitecore.IO ► FileUtil ► SaveObject(String, Object)
Saves an object to a file.
Declaration Syntax
C#
public static void SaveObject(
    string filename,
    Object data
)
Parameters
filename (String)
The filename.
data (Object)
The data.


SaveToTemporaryFile Method (item)

SaveToTemporaryFile Method (item)
Namespaces ► Sitecore.IO ► FileUtil ► SaveToTemporaryFile(MediaItem)
Saves the Media Item's MediaStream to a temporary file and returns the path to that file.
Declaration Syntax
C#
public static string SaveToTemporaryFile(
    MediaItem item
)
Parameters
item (MediaItem)
The MediaItem
Return Value
The path to the generated temporary file.


SubtractPath Method (fullPath, subtract)

SubtractPath Method (fullPath, subtract)
Namespaces ► Sitecore.IO ► FileUtil ► SubtractPath(String, String)
Subtracts one path from another.
Declaration Syntax
C#
public static string SubtractPath(
    string fullPath,
    string subtract
)
Parameters
fullPath (String)
The full path.
subtract (String)
The path to subtract.
Return Value
Examples
CopyC#
string path = FileUtil.SubtractPath("/layouts/hola.aspx", "/layouts/"); // hola.aspx
string path = FileUtil.SubtractPath("c:\website\layouts\hola.aspx", "/layouts/"); // hola.aspx (assuming the web site )
string path = FileUtil.SubtractPath("/layouts/hola.aspx", "/temp/"); // null


UnmapPath Method

UnmapPath Method
Namespaces ► Sitecore.IO ► FileUtil ► UnmapPath()()()
Members
Icon | Member | Description
 | UnmapPath(String, Boolean) | Maps a physical path to a virtual path.
 | UnmapPath(String) | Maps a physical path to a virtual path.


UnmapPath Method (path)

UnmapPath Method (path)
Namespaces ► Sitecore.IO ► FileUtil ► UnmapPath(String)
Maps a physical path to a virtual path.
Declaration Syntax
C#
public static string UnmapPath(
    string path
)
Parameters
path (String)
A path.
Return Value
A virtual path.
Remarks
If the path cannot be made into a virtual path, the physical path is returned.
Examples
CopyC#
string path = MainUtil.UnmapPath(@"c:\inetpub\wwwroot\default side\sitecore\images\blank.gif");
// "/sitecore/images/blank.gif"
See Also
MapPath(String)


UnmapPath Method (path, toLower)

UnmapPath Method (path, toLower)
Namespaces ► Sitecore.IO ► FileUtil ► UnmapPath(String, Boolean)
Maps a physical path to a virtual path.
Declaration Syntax
C#
public static string UnmapPath(
    string path,
    bool toLower
)
Parameters
path (String)
A path.
toLower (Boolean)
Indicated whether result should be converded to lower case
Return Value
A virtual path.
Remarks
If the path cannot be made into a virtual path, the physical path is returned.
Examples
CopyC#
string path = MainUtil.UnmapPath(@"c:\Inetpub\wwwroot\Default side\Sitecore\Images\blank.gif", false);
// "/Sitecore/Images/blank.gif"
See Also
MapPath(String)


WriteToFile Method

WriteToFile Method
Namespaces ► Sitecore.IO ► FileUtil ► WriteToFile()()()
Members
Icon | Member | Description
 | WriteToFile(String, array<Byte>[]()[]%) | Writes a byte array to a file.
 | WriteToFile(String, String) | Writes a string to a file.
 | WriteToFile(String, String, Boolean) | Write or appends a atring to a file.


WriteToFile Method (path, data)

WriteToFile Method (path, data)
Namespaces ► Sitecore.IO ► FileUtil ► WriteToFile(String, array<Byte>[]()[]%)
Writes a byte array to a file.
Declaration Syntax
C#
public static void WriteToFile(
    string path,
    ref byte[] data
)
Parameters
path (String)
A file name path.
data ( array< Byte >[]()[] %)
A byte array of data.


WriteToFile Method (path, text)

WriteToFile Method (path, text)
Namespaces ► Sitecore.IO ► FileUtil ► WriteToFile(String, String)
Writes a string to a file.
Declaration Syntax
C#
public static void WriteToFile(
    string path,
    string text
)
Parameters
path (String)
A file name path.
text (String)
A string.
Examples
CopyC#
MainUtil.WriteToString("/my.txt", "Hello world");


WriteToFile Method (path, text, append)

WriteToFile Method (path, text, append)
Namespaces ► Sitecore.IO ► FileUtil ► WriteToFile(String, String, Boolean)
Write or appends a atring to a file.
Declaration Syntax
C#
public static void WriteToFile(
    string path,
    string text,
    bool append
)
Parameters
path (String)
A file name path.
text (String)
A string.
append (Boolean)
Indicates if the string is appended to the file.
Examples
CopyC#
MainUtil.WriteToString("/my.txt", "Hello world", true);


WriteToStream Method (inputStream, blockSize, outputStream)

WriteToStream Method (inputStream, blockSize, outputStream)
Namespaces ► Sitecore.IO ► FileUtil ► WriteToStream(Stream, Int32, Stream)
Writes one stream to another stream.
Declaration Syntax
C#
public static void WriteToStream(
    Stream inputStream,
    int blockSize,
    Stream outputStream
)
Parameters
inputStream (Stream)
The stream to read data from.
blockSize (Int32)
Size of each block being read.
outputStream (Stream)
The stream to write data to.


WriteUTF8File Method (filename, data)

WriteUTF8File Method (filename, data)
Namespaces ► Sitecore.IO ► FileUtil ► WriteUTF8File(String, String)
Writes the file in UTF8 encoding.
Declaration Syntax
C#
public static void WriteUTF8File(
    string filename,
    string data
)
Parameters
filename (String)
The filename.
data (String)
The data.


ZipFiles Method (zipfile, files)

ZipFiles Method (zipfile, files)
Namespaces ► Sitecore.IO ► FileUtil ► ZipFiles(String, array<String>[]()[])
Zips a list of files.
Declaration Syntax
C#
public static string ZipFiles(
    string zipfile,
    string[] files
)
Parameters
zipfile (String)
The zipfile.
files (array< String >[]()[])
The files.
Return Value


FileWatcher Class

FileWatcher Class
Namespaces ► Sitecore.IO ► FileWatcher
Monitors a folder for changes to files.
Declaration Syntax
C#
public abstract class FileWatcher : IHttpModule
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FileWatcher(String, String) | Initializes a new instance of the FileWatcher class.
 | FileWatcher(String) | Initializes a new instance of the FileWatcher class.
 | FileWatcher()()() | Initializes a new instance of the FileWatcher class.
 | Created(String) | Called when a file has been created.
 | Deleted(String) | Called when a file has been deleted.
 | Dispose()()() | Application shutdown handler
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(HttpApplication) | Application startup handler
 | InitializeWatcher(String, String) | Initializes a file watcher.
 | InitializeWorker()()() | Initializes the worker.
 | MapPathToSiteCore(String, String, String) | Maps the path to a Sitecore path.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnFileCreated(Object, FileSystemEventArgs) | File has been created.
 | OnFileDeleted(Object, FileSystemEventArgs) | File has been deleted.
 | OnFileRenamed(Object, RenamedEventArgs) | File has been renamed.
 | PathShouldBeIngnored(String) | Checks whether the pathes the should be ingnored.
 | ProcessPending()()() | Processes all pending operations for all file watchers.
 | Renamed(String, String) | Called when a file has been renamed.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FileWatcher
 |  | ConfigWatcher
 |  | LayoutWatcher
 |  | XslWatcher
 |  | UploadWatcher
 |  | LicenseWatcher


FileWatcher Constructor

FileWatcher Constructor
Namespaces ► Sitecore.IO ► FileWatcher ► FileWatcher()()()
Members
Icon | Member | Description
 | FileWatcher(String, String) | Initializes a new instance of the FileWatcher class.
 | FileWatcher(String) | Initializes a new instance of the FileWatcher class.
 | FileWatcher()()() | Initializes a new instance of the FileWatcher class.


FileWatcher Constructor

FileWatcher Constructor
Namespaces ► Sitecore.IO ► FileWatcher ► FileWatcher()()()
Initializes a new instance of the FileWatcher class.
Declaration Syntax
C#
protected FileWatcher()


FileWatcher Constructor (configReference)

FileWatcher Constructor (configReference)
Namespaces ► Sitecore.IO ► FileWatcher ► FileWatcher(String)
Initializes a new instance of the FileWatcher class.
Declaration Syntax
C#
protected FileWatcher(
    string configReference
)
Parameters
configReference (String)
The configuration reference.


FileWatcher Constructor (folder, filter)

FileWatcher Constructor (folder, filter)
Namespaces ► Sitecore.IO ► FileWatcher ► FileWatcher(String, String)
Initializes a new instance of the FileWatcher class.
Declaration Syntax
C#
protected FileWatcher(
    string folder,
    string filter
)
Parameters
folder (String)
The folder.
filter (String)
The filter.


Created Method (fullPath)

Created Method (fullPath)
Namespaces ► Sitecore.IO ► FileWatcher ► Created(String)
Called when a file has been created.
Declaration Syntax
C#
protected abstract void Created(
    string fullPath
)
Parameters
fullPath (String)
The full path.


Deleted Method (filePath)

Deleted Method (filePath)
Namespaces ► Sitecore.IO ► FileWatcher ► Deleted(String)
Called when a file has been deleted.
Declaration Syntax
C#
protected abstract void Deleted(
    string filePath
)
Parameters
filePath (String)
The full path.


Dispose Method

Dispose Method
Namespaces ► Sitecore.IO ► FileWatcher ► Dispose()()()
Application shutdown handler
Declaration Syntax
C#
public void Dispose()


Init Method (context)

Init Method (context)
Namespaces ► Sitecore.IO ► FileWatcher ► Init(HttpApplication)
Application startup handler
Declaration Syntax
C#
public void Init(
    HttpApplication context
)
Parameters
context (HttpApplication)
An HttpApplication that provides access to the methods, properties, and events common to all application objects within an ASP.NET application


InitializeWatcher Method (filter, folder)

InitializeWatcher Method (filter, folder)
Namespaces ► Sitecore.IO ► FileWatcher ► InitializeWatcher(String, String)
Initializes a file watcher.
Declaration Syntax
C#
protected void InitializeWatcher(
    string filter,
    string folder
)
Parameters
filter (String)
The filter.
folder (String)
The folder.


InitializeWorker Method

InitializeWorker Method
Namespaces ► Sitecore.IO ► FileWatcher ► InitializeWorker()()()
Initializes the worker.
Declaration Syntax
C#
protected void InitializeWorker()


MapPathToSiteCore Method (fullPath, directory, id)

MapPathToSiteCore Method (fullPath, directory, id)
Namespaces ► Sitecore.IO ► FileWatcher ► MapPathToSiteCore(String, String, String)
Maps the path to a Sitecore path.
Declaration Syntax
C#
protected string MapPathToSiteCore(
    string fullPath,
    string directory,
    string id
)
Parameters
fullPath (String)
The full path.
directory (String)
The directory.
id (String)
The id.
Return Value


OnFileCreated Method (o, args)

OnFileCreated Method (o, args)
Namespaces ► Sitecore.IO ► FileWatcher ► OnFileCreated(Object, FileSystemEventArgs)
File has been created.
Declaration Syntax
C#
protected void OnFileCreated(
    Object o,
    FileSystemEventArgs args
)
Parameters
o (Object)
The object.
args (FileSystemEventArgs)
The arguments.


OnFileDeleted Method (o, args)

OnFileDeleted Method (o, args)
Namespaces ► Sitecore.IO ► FileWatcher ► OnFileDeleted(Object, FileSystemEventArgs)
File has been deleted.
Declaration Syntax
C#
protected void OnFileDeleted(
    Object o,
    FileSystemEventArgs args
)
Parameters
o (Object)
The object.
args (FileSystemEventArgs)
The arguments.


OnFileRenamed Method (o, args)

OnFileRenamed Method (o, args)
Namespaces ► Sitecore.IO ► FileWatcher ► OnFileRenamed(Object, RenamedEventArgs)
File has been renamed.
Declaration Syntax
C#
protected void OnFileRenamed(
    Object o,
    RenamedEventArgs args
)
Parameters
o (Object)
The object.
args (RenamedEventArgs)
The arguments.


PathShouldBeIngnored Method (path)

PathShouldBeIngnored Method (path)
Namespaces ► Sitecore.IO ► FileWatcher ► PathShouldBeIngnored(String)
Checks whether the pathes the should be ingnored.
Declaration Syntax
C#
protected virtual bool PathShouldBeIngnored(
    string path
)
Parameters
path (String)
The path.
Return Value


ProcessPending Method

ProcessPending Method
Namespaces ► Sitecore.IO ► FileWatcher ► ProcessPending()()()
Processes all pending operations for all file watchers.
Declaration Syntax
C#
public static void ProcessPending()


Renamed Method (filePath, oldFilePath)

Renamed Method (filePath, oldFilePath)
Namespaces ► Sitecore.IO ► FileWatcher ► Renamed(String, String)
Called when a file has been renamed.
Declaration Syntax
C#
protected abstract void Renamed(
    string filePath,
    string oldFilePath
)
Parameters
filePath (String)
The full path.
oldFilePath (String)
The old full path.


LayoutWatcher Class

LayoutWatcher Class
Namespaces ► Sitecore.IO ► LayoutWatcher
Implements a file watcher that looks for changes in the /Layout folder.
Declaration Syntax
C#
public class LayoutWatcher : FileWatcher
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LayoutWatcher()()() | Initializes a new instance of the LayoutWatcher class.
 | Created(String) | Called when a file has been created. (Overrides FileWatcher.Created(String).)
 | Deleted(String) | Called when a file has been deleted. (Overrides FileWatcher.Deleted(String).)
 | Dispose()()() | Application shutdown handler (Inherited from FileWatcher.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(HttpApplication) | Application startup handler (Inherited from FileWatcher.)
 | InitializeWatcher(String, String) | Initializes a file watcher. (Inherited from FileWatcher.)
 | InitializeWorker()()() | Initializes the worker. (Inherited from FileWatcher.)
 | MapPathToSiteCore(String, String, String) | Maps the path to a Sitecore path. (Inherited from FileWatcher.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnFileCreated(Object, FileSystemEventArgs) | File has been created. (Inherited from FileWatcher.)
 | OnFileDeleted(Object, FileSystemEventArgs) | File has been deleted. (Inherited from FileWatcher.)
 | OnFileRenamed(Object, RenamedEventArgs) | File has been renamed. (Inherited from FileWatcher.)
 | PathShouldBeIngnored(String) | Checks whether the pathes the should be ingnored. (Inherited from FileWatcher.)
 | Renamed(String, String) | Called when a file has been renamed. (Overrides FileWatcher.Renamed(String, String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FileWatcher
 |  | LayoutWatcher


LayoutWatcher Constructor

LayoutWatcher Constructor
Namespaces ► Sitecore.IO ► LayoutWatcher ► LayoutWatcher()()()
Initializes a new instance of the LayoutWatcher class.
Declaration Syntax
C#
public LayoutWatcher()


Created Method (fullPath)

Created Method (fullPath)
Namespaces ► Sitecore.IO ► LayoutWatcher ► Created(String)
Called when a file has been created.
Declaration Syntax
C#
protected override void Created(
    string fullPath
)
Parameters
fullPath (String)
The full path.


Deleted Method (filePath)

Deleted Method (filePath)
Namespaces ► Sitecore.IO ► LayoutWatcher ► Deleted(String)
Called when a file has been deleted.
Declaration Syntax
C#
protected override void Deleted(
    string filePath
)
Parameters
filePath (String)
The full path.


Renamed Method (filePath, oldFilePath)

Renamed Method (filePath, oldFilePath)
Namespaces ► Sitecore.IO ► LayoutWatcher ► Renamed(String, String)
Called when a file has been renamed.
Declaration Syntax
C#
protected override void Renamed(
    string filePath,
    string oldFilePath
)
Parameters
filePath (String)
The full path.
oldFilePath (String)
The old full path.


SpecialFolder Enumeration

SpecialFolder Enumeration
Namespaces ► Sitecore.IO ► SpecialFolder
Identifies special folders.
Declaration Syntax
C#
public enum SpecialFolder
Members
Member | Description
IndexRoot | Index root.
TempDiagnostics | Temporary folder for diagnostics.


StreamSharer Class

StreamSharer Class
Namespaces ► Sitecore.IO ► StreamSharer
StreamSharer.MetaStream class
StreamSharer class
Declaration Syntax
C#
public class StreamSharer : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StreamSharer(Stream, String) | Initializes a new instance of the StreamSharer class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OpenStream()()() | Opens a new instance of the stream.
 | PrepareRead(Int64, Int32) | Prepares the master buffer file for a specific read operation.
 | Read(Int64, array<Byte>[]()[], Int32, Int32) | Reads data from the stream.
 | StreamLength | Gets the length of the stream.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
StreamSharer


StreamSharer Constructor (masterStream, bufferFilePath)

StreamSharer Constructor (masterStream, bufferFilePath)
Namespaces ► Sitecore.IO ► StreamSharer ► StreamSharer(Stream, String)
Initializes a new instance of the StreamSharer class.
Declaration Syntax
C#
public StreamSharer(
    Stream masterStream,
    string bufferFilePath
)
Parameters
masterStream (Stream)
The master stream.
bufferFilePath (String)
The buffer file path.


Dispose Method

Dispose Method
Namespaces ► Sitecore.IO ► StreamSharer ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


OpenStream Method

OpenStream Method
Namespaces ► Sitecore.IO ► StreamSharer ► OpenStream()()()
Opens a new instance of the stream.
Declaration Syntax
C#
public Stream OpenStream()
Return Value


PrepareRead Method (position, count)

PrepareRead Method (position, count)
Namespaces ► Sitecore.IO ► StreamSharer ► PrepareRead(Int64, Int32)
Prepares the master buffer file for a specific read operation.
Declaration Syntax
C#
public void PrepareRead(
    long position,
    int count
)
Parameters
position (Int64)
The position that will be read.
count (Int32)
The number of bytes that will be read.


Read Method (position, buffer, offset, count)

Read Method (position, buffer, offset, count)
Namespaces ► Sitecore.IO ► StreamSharer ► Read(Int64, array<Byte>[]()[], Int32, Int32)
Reads data from the stream.
Declaration Syntax
C#
public int Read(
    long position,
    byte[] buffer,
    int offset,
    int count
)
Parameters
position (Int64)
The position that will be read.
buffer (array< Byte >[]()[])
The buffer.
offset (Int32)
The offset.
count (Int32)
The number of bytes that will be read.


StreamLength Property

StreamLength Property
Namespaces ► Sitecore.IO ► StreamSharer ► StreamLength
Gets the length of the stream.
Declaration Syntax
C#
public long StreamLength { get; }
Return Value


StreamSharer.MetaStream Class

StreamSharer..::.MetaStream Class
Namespaces ► Sitecore.IO ► StreamSharer ► StreamSharer..::.MetaStream
StreamSharer.MetaStream class
Declaration Syntax
C#
public class MetaStream : Stream
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StreamSharer..::.MetaStream(StreamSharer) | Initializes a new instance of the StreamSharer..::.MetaStream class.
 | BeginRead(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead | When overridden in a derived class, gets a value indicating whether the current stream supports reading. (Overrides Stream.CanRead.)
 | CanSeek | When overridden in a derived class, gets a value indicating whether the current stream supports seeking. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | When overridden in a derived class, gets a value indicating whether the current stream supports writing. (Overrides Stream.CanWrite.)
 | Close()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()() | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Overrides Stream.Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length | When overridden in a derived class, gets the length in bytes of the stream. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | When overridden in a derived class, gets or sets the position within the current stream. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[], Int32, Int32) | When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Overrides Stream.Read(array<Byte>[]()[], Int32, Int32).)
 | ReadByte()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | When overridden in a derived class, sets the position within the current stream. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | When overridden in a derived class, sets the length of the current stream. (Overrides Stream.SetLength(Int64).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Write(array<Byte>[]()[], Int32, Int32) | When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Overrides Stream.Write(array<Byte>[]()[], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | StreamSharer..::.MetaStream


StreamSharer.MetaStream Constructor (streamSharer)

StreamSharer..::.MetaStream Constructor (streamSharer)
Namespaces ► Sitecore.IO ► StreamSharer..::.MetaStream ► StreamSharer..::.MetaStream(StreamSharer)
Initializes a new instance of the StreamSharer..::.MetaStream class.
Declaration Syntax
C#
public MetaStream(
    StreamSharer streamSharer
)
Parameters
streamSharer (StreamSharer)
The stream sharer.


CanRead Property

CanRead Property
Namespaces ► Sitecore.IO ► StreamSharer..::.MetaStream ► CanRead
When overridden in a derived class, gets a value indicating whether the current stream supports reading.
Declaration Syntax
C#
public override bool CanRead { get; }
Value
Return Value
true if the stream supports reading; otherwise, false.


CanSeek Property

CanSeek Property
Namespaces ► Sitecore.IO ► StreamSharer..::.MetaStream ► CanSeek
When overridden in a derived class, gets a value indicating whether the current stream supports seeking.
Declaration Syntax
C#
public override bool CanSeek { get; }
Value
Return Value
true if the stream supports seeking; otherwise, false.


CanWrite Property

CanWrite Property
Namespaces ► Sitecore.IO ► StreamSharer..::.MetaStream ► CanWrite
When overridden in a derived class, gets a value indicating whether the current stream supports writing.
Declaration Syntax
C#
public override bool CanWrite { get; }
Value
Return Value
true if the stream supports writing; otherwise, false.


Flush Method

Flush Method
Namespaces ► Sitecore.IO ► StreamSharer..::.MetaStream ► Flush()()()
When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device.
Declaration Syntax
C#
public override void Flush()
Exceptions
Exception | Condition
IOException | An I/O error occurs.


Length Property

Length Property
Namespaces ► Sitecore.IO ► StreamSharer..::.MetaStream ► Length
When overridden in a derived class, gets the length in bytes of the stream.
Declaration Syntax
C#
public override long Length { get; }
Value
Return Value
A long value representing the length of the stream in bytes.
Exceptions
Exception | Condition
NotSupportedException | A class derived from Stream does not support seeking.
ObjectDisposedException | Methods were called after the stream was closed.


Position Property

Position Property
Namespaces ► Sitecore.IO ► StreamSharer..::.MetaStream ► Position
When overridden in a derived class, gets or sets the position within the current stream.
Declaration Syntax
C#
public override long Position { get; set; }
Value
Return Value
The current position within the stream.
Exceptions
Exception | Condition
IOException | An I/O error occurs.
NotSupportedException | The stream does not support seeking.
ObjectDisposedException | Methods were called after the stream was closed.


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
Namespaces ► Sitecore.IO ► StreamSharer..::.MetaStream ► Read(array<Byte>[]()[], Int32, Int32)
When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.
Declaration Syntax
C#
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Parameters
buffer (array< Byte >[]()[])
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset (Int32)
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count (Int32)
The maximum number of bytes to be read from the current stream.
Return Value
The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.
Exceptions
Exception | Condition
ArgumentException | The sum of offset and count is larger than the buffer length.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | offset or count is negative.
IOException | An I/O error occurs.
NotSupportedException | The stream does not support reading.
ObjectDisposedException | Methods were called after the stream was closed.


Seek Method (offset, origin)

Seek Method (offset, origin)
Namespaces ► Sitecore.IO ► StreamSharer..::.MetaStream ► Seek(Int64, SeekOrigin)
When overridden in a derived class, sets the position within the current stream.
Declaration Syntax
C#
public override long Seek(
    long offset,
    SeekOrigin origin
)
Parameters
offset (Int64)
A byte offset relative to the origin parameter.
origin (SeekOrigin)
A value of type SeekOrigin indicating the reference point used to obtain the new position.
Return Value
The new position within the current stream.
Exceptions
Exception | Condition
IOException | An I/O error occurs.
NotSupportedException | The stream does not support seeking, such as if the stream is constructed from a pipe or console output.
ObjectDisposedException | Methods were called after the stream was closed.


SetLength Method (value)

SetLength Method (value)
Namespaces ► Sitecore.IO ► StreamSharer..::.MetaStream ► SetLength(Int64)
When overridden in a derived class, sets the length of the current stream.
Declaration Syntax
C#
public override void SetLength(
    long value
)
Parameters
value (Int64)
The desired length of the current stream in bytes.
Exceptions
Exception | Condition
IOException | An I/O error occurs.
NotSupportedException | The stream does not support both writing and seeking, such as if the stream is constructed from a pipe or console output.
ObjectDisposedException | Methods were called after the stream was closed.


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
Namespaces ► Sitecore.IO ► StreamSharer..::.MetaStream ► Write(array<Byte>[]()[], Int32, Int32)
When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.
Declaration Syntax
C#
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Parameters
buffer (array< Byte >[]()[])
An array of bytes. This method copies count bytes from buffer to the current stream.
offset (Int32)
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count (Int32)
The number of bytes to be written to the current stream.
Exceptions
Exception | Condition
ArgumentException | The sum of offset and count is greater than the buffer length.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | offset or count is negative.
IOException | An I/O error occurs.
NotSupportedException | The stream does not support writing.
ObjectDisposedException | Methods were called after the stream was closed.


TempFolder Class

TempFolder Class
Namespaces ► Sitecore.IO ► TempFolder
Represents the temporary folder.
Declaration Syntax
C#
public static class TempFolder
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreateTempFile(String) | Creates the temp file.
 | Ensure()()() | Obsolete. Ensures that the Temp folder exists on the physical disk.
 | EnsureFolder()()() | Ensures that the Temp folder exists on the physical disk.
 | Folder | Gets the folder.
 | GetFilename()()() | Gets the filename.
 | GetFilename(String) | Gets the filename.
Inheritance Hierarchy
Object
TempFolder


CreateTempFile Method (filename)

CreateTempFile Method (filename)
Namespaces ► Sitecore.IO ► TempFolder ► CreateTempFile(String)
Creates the temp file.
Declaration Syntax
C#
public static string CreateTempFile(
    string filename
)
Parameters
filename (String)
The filename.
Return Value


Ensure Method

Ensure Method
Namespaces ► Sitecore.IO ► TempFolder ► Ensure()()()
Ensures that the Temp folder exists on the physical disk.
Declaration Syntax
C#
[ObsoleteAttribute("Use EnsureFolder instead")]
public static void Ensure()


EnsureFolder Method

EnsureFolder Method
Namespaces ► Sitecore.IO ► TempFolder ► EnsureFolder()()()
Ensures that the Temp folder exists on the physical disk.
Declaration Syntax
C#
public static void EnsureFolder()


Folder Property

Folder Property
Namespaces ► Sitecore.IO ► TempFolder ► Folder
Gets the folder.
Declaration Syntax
C#
public static string Folder { get; }
Value
The folder.


GetFilename Method

GetFilename Method
Namespaces ► Sitecore.IO ► TempFolder ► GetFilename()()()
Members
Icon | Member | Description
 | GetFilename()()() | Gets the filename.
 | GetFilename(String) | Gets the filename.


GetFilename Method

GetFilename Method
Namespaces ► Sitecore.IO ► TempFolder ► GetFilename()()()
Gets the filename.
Declaration Syntax
C#
public static string GetFilename()
Return Value


GetFilename Method (filename)

GetFilename Method (filename)
Namespaces ► Sitecore.IO ► TempFolder ► GetFilename(String)
Gets the filename.
Declaration Syntax
C#
public static string GetFilename(
    string filename
)
Parameters
filename (String)
The filename.
Return Value


UploadFile Class

UploadFile Class
Namespaces ► Sitecore.IO ► UploadFile
Implements a class for simplifing upload of files from a HTML form.
Declaration Syntax
C#
public class UploadFile
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UploadFile(HtmlInputFile) | Initializes a new instance of the UploadFile class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid | Checks if the file object is valid.
 | MakeThumbnail(String, Int32, Int32) | Makes a thumbnail of the file.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveToFolder(String, Boolean) | Saves the file to a folder.
 | ThumbnailAborter()()() | Implements a thumbnail aborter delegate.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This is an internal class for uploaing files and should not be used.
Inheritance Hierarchy
Object
UploadFile


UploadFile Constructor (file)

UploadFile Constructor (file)
Namespaces ► Sitecore.IO ► UploadFile ► UploadFile(HtmlInputFile)
Initializes a new instance of the UploadFile class.
Declaration Syntax
C#
public UploadFile(
    HtmlInputFile file
)
Parameters
file (HtmlInputFile)
A file from a HTML form.


IsValid Property

IsValid Property
Namespaces ► Sitecore.IO ► UploadFile ► IsValid
Checks if the file object is valid.
Declaration Syntax
C#
public bool IsValid { get; }
Value
True, if the file object contains a value, otherwise false.
Remarks
A file object is valid if it contains a value.


MakeThumbnail Method (sFile, nWidth, nHeight)

MakeThumbnail Method (sFile, nWidth, nHeight)
Namespaces ► Sitecore.IO ► UploadFile ► MakeThumbnail(String, Int32, Int32)
Makes a thumbnail of the file.
Declaration Syntax
C#
protected bool MakeThumbnail(
    string sFile,
    int nWidth,
    int nHeight
)
Parameters
sFile (String)
A file name.
nWidth (Int32)
Width of thumbnail.
nHeight (Int32)
Height of thumbnail.
Return Value
True, if a thumbnail was generated, otherwise false.
Remarks
The function looks for an extension of .gif or .jpg.


SaveToFolder Method (sFolder, bUniqueName)

SaveToFolder Method (sFolder, bUniqueName)
Namespaces ► Sitecore.IO ► UploadFile ► SaveToFolder(String, Boolean)
Saves the file to a folder.
Declaration Syntax
C#
public string SaveToFolder(
    string sFolder,
    bool bUniqueName
)
Parameters
sFolder (String)
A folder file name.
bUniqueName (Boolean)
A boolean indicating if the name should unique within the folder.
Return Value
The filename of the file.
Remarks
If the file is not valid, blank is returned.


ThumbnailAborter Method

ThumbnailAborter Method
Namespaces ► Sitecore.IO ► UploadFile ► ThumbnailAborter()()()
Implements a thumbnail aborter delegate.
Declaration Syntax
C#
protected bool ThumbnailAborter()
Return Value
Always false.
Remarks
Always returns false.


XslWatcher Class

XslWatcher Class
Namespaces ► Sitecore.IO ► XslWatcher
Implements a file watcher that monitors changes in the /Xsl folder.
Declaration Syntax
C#
public class XslWatcher : FileWatcher
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | XslWatcher()()() | Initializes a new instance of the XslWatcher class.
 | Created(String) | Called when a file has been created. (Overrides FileWatcher.Created(String).)
 | Deleted(String) | Called when a file has been deleted. (Overrides FileWatcher.Deleted(String).)
 | Dispose()()() | Application shutdown handler (Inherited from FileWatcher.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(HttpApplication) | Application startup handler (Inherited from FileWatcher.)
 | InitializeWatcher(String, String) | Initializes a file watcher. (Inherited from FileWatcher.)
 | InitializeWorker()()() | Initializes the worker. (Inherited from FileWatcher.)
 | MapPathToSiteCore(String, String, String) | Maps the path to a Sitecore path. (Inherited from FileWatcher.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnFileCreated(Object, FileSystemEventArgs) | File has been created. (Inherited from FileWatcher.)
 | OnFileDeleted(Object, FileSystemEventArgs) | File has been deleted. (Inherited from FileWatcher.)
 | OnFileRenamed(Object, RenamedEventArgs) | File has been renamed. (Inherited from FileWatcher.)
 | PathShouldBeIngnored(String) | Checks whether the pathes the should be ingnored. (Inherited from FileWatcher.)
 | Renamed(String, String) | Called when a file has been renamed. (Overrides FileWatcher.Renamed(String, String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FileWatcher
 |  | XslWatcher


XslWatcher Constructor

XslWatcher Constructor
Namespaces ► Sitecore.IO ► XslWatcher ► XslWatcher()()()
Initializes a new instance of the XslWatcher class.
Declaration Syntax
C#
public XslWatcher()


Created Method (fullPath)

Created Method (fullPath)
Namespaces ► Sitecore.IO ► XslWatcher ► Created(String)
Called when a file has been created.
Declaration Syntax
C#
protected override void Created(
    string fullPath
)
Parameters
fullPath (String)
The full path.


Deleted Method (filePath)

Deleted Method (filePath)
Namespaces ► Sitecore.IO ► XslWatcher ► Deleted(String)
Called when a file has been deleted.
Declaration Syntax
C#
protected override void Deleted(
    string filePath
)
Parameters
filePath (String)
The full path.


Renamed Method (filePath, oldFilePath)

Renamed Method (filePath, oldFilePath)
Namespaces ► Sitecore.IO ► XslWatcher ► Renamed(String, String)
Called when a file has been renamed.
Declaration Syntax
C#
protected override void Renamed(
    string filePath,
    string oldFilePath
)
Parameters
filePath (String)
The full path.
oldFilePath (String)
The old full path.


Sitecore.Jobs Namespace

Sitecore.Jobs Namespace
Namespaces ► Sitecore.Jobs
Declaration Syntax
C#
namespace Sitecore.Jobs
Types
All Types Classes Enumerations
Icon | Type | Description
 | Job | Represents a job.
 | JobArgs | Represents the arguments for a Job.
 | JobFinishedEventArgs | Represents the arguments for a job finished event.
 | JobManager | Represents the job manager.
 | JobOptions | Represents the options for a Job.
 | JobRunner | Represents a Job runner.
 | JobState | Represents the state of a Job.
 | JobStatus | Represents the status of a Job.


Job Class

Job Class
Namespaces ► Sitecore.Jobs ► Job
Represents a job.
Declaration Syntax
C#
public class Job
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Job(JobOptions) | Initializes a new instance of the Job class.
 | AddMessage(String, array<Object>[]()[]) | Adds the status message to the context job. If there is no job, the message is ignored.
 | Category | Gets the category.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Finished |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle | Gets the handle.
 | IsDone | Gets a value indicating whether this job is done.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessageQueue | Gets the message queue.
 | Name | Gets the name.
 | Options | Gets the options.
 | Processed | Gets or sets the processed counter of the context job. If there is no job, the operation is ignored.
 | QueueTime | Gets or sets the queue time.
 | Start()()() | Starts this job.
 | Status | Gets the status.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Total | Gets or sets the total counter of the context job. If there is no job, the operation is ignored.
 | Wait()()() | Waits.
 | Wait(Int32) | Waits the specified milliseconds.
 | WaitHandle | Gets the wait handle.
Inheritance Hierarchy
Object
Job


Job Constructor (options)

Job Constructor (options)
Namespaces ► Sitecore.Jobs ► Job ► Job(JobOptions)
Initializes a new instance of the Job class.
Declaration Syntax
C#
public Job(
    JobOptions options
)
Parameters
options (JobOptions)
The options.


AddMessage Method (message, args)

AddMessage Method (message, args)
Namespaces ► Sitecore.Jobs ► Job ► AddMessage(String, array<Object>[]()[])
Adds the status message to the context job. If there is no job, the message is ignored.
Declaration Syntax
C#
public static void AddMessage(
    string message,
    params Object[] args
)
Parameters
message (String)
The message.
args (array< Object >[]()[])
The args.


Category Property

Category Property
Namespaces ► Sitecore.Jobs ► Job ► Category
Gets the category.
Declaration Syntax
C#
public string Category { get; }
Value
The category.


Finished Event

Finished Event
Namespaces ► Sitecore.Jobs ► Job ► Finished
Declaration Syntax
C#
public event EventHandler<JobFinishedEventArgs> Finished


Handle Property

Handle Property
Namespaces ► Sitecore.Jobs ► Job ► Handle
Gets the handle.
Declaration Syntax
C#
public Handle Handle { get; }
Value
The handle.


IsDone Property

IsDone Property
Namespaces ► Sitecore.Jobs ► Job ► IsDone
Gets a value indicating whether this job is done.
Declaration Syntax
C#
public bool IsDone { get; }
Value
true if this job is done; otherwise, false.


MessageQueue Property

MessageQueue Property
Namespaces ► Sitecore.Jobs ► Job ► MessageQueue
Gets the message queue.
Declaration Syntax
C#
public MessageQueue MessageQueue { get; }
Value
The message queue.


Name Property

Name Property
Namespaces ► Sitecore.Jobs ► Job ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Options Property

Options Property
Namespaces ► Sitecore.Jobs ► Job ► Options
Gets the options.
Declaration Syntax
C#
public JobOptions Options { get; }
Value
The options.


Processed Property

Processed Property
Namespaces ► Sitecore.Jobs ► Job ► Processed
Gets or sets the processed counter of the context job. If there is no job, the operation is ignored.
Declaration Syntax
C#
public static long Processed { get; set; }
Value
The processed.


QueueTime Property

QueueTime Property
Namespaces ► Sitecore.Jobs ► Job ► QueueTime
Gets or sets the queue time.
Declaration Syntax
C#
public DateTime QueueTime { get; set; }
Value
The queue time.


Start Method

Start Method
Namespaces ► Sitecore.Jobs ► Job ► Start()()()
Starts this job.
Declaration Syntax
C#
public void Start()


Status Property

Status Property
Namespaces ► Sitecore.Jobs ► Job ► Status
Gets the status.
Declaration Syntax
C#
public JobStatus Status { get; }
Value
The status.


Total Property

Total Property
Namespaces ► Sitecore.Jobs ► Job ► Total
Gets or sets the total counter of the context job. If there is no job, the operation is ignored.
Declaration Syntax
C#
public static long Total { get; set; }
Value
The total.


Wait Method

Wait Method
Namespaces ► Sitecore.Jobs ► Job ► Wait()()()
Members
Icon | Member | Description
 | Wait()()() | Waits.
 | Wait(Int32) | Waits the specified milliseconds.


Wait Method

Wait Method
Namespaces ► Sitecore.Jobs ► Job ► Wait()()()
Waits.
Declaration Syntax
C#
public bool Wait()
Return Value


Wait Method (milliseconds)

Wait Method (milliseconds)
Namespaces ► Sitecore.Jobs ► Job ► Wait(Int32)
Waits the specified milliseconds.
Declaration Syntax
C#
public bool Wait(
    int milliseconds
)
Parameters
milliseconds (Int32)
The milliseconds.
Return Value


WaitHandle Property

WaitHandle Property
Namespaces ► Sitecore.Jobs ► Job ► WaitHandle
Gets the wait handle.
Declaration Syntax
C#
public WaitHandle WaitHandle { get; }
Value
The wait handle.


JobArgs Class

JobArgs Class
Namespaces ► Sitecore.Jobs ► JobArgs
Represents the arguments for a Job.
Declaration Syntax
C#
[SerializableAttribute]
public class JobArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JobArgs(Job) | Initializes a new instance of the JobArgs class.
 | JobArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the JobArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | Job | Gets the job.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Result | Gets or sets the result.
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | JobArgs


JobArgs Constructor

JobArgs Constructor
Namespaces ► Sitecore.Jobs ► JobArgs ► JobArgs()()()
Members
Icon | Member | Description
 | JobArgs(Job) | Initializes a new instance of the JobArgs class.
 | JobArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the JobArgs class.


JobArgs Constructor (job)

JobArgs Constructor (job)
Namespaces ► Sitecore.Jobs ► JobArgs ► JobArgs(Job)
Initializes a new instance of the JobArgs class.
Declaration Syntax
C#
public JobArgs(
    Job job
)
Parameters
job (Job)
The job.


JobArgs Constructor (info, context)

JobArgs Constructor (info, context)
Namespaces ► Sitecore.Jobs ► JobArgs ► JobArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the JobArgs class.
Declaration Syntax
C#
protected JobArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Jobs ► JobArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Job Property

Job Property
Namespaces ► Sitecore.Jobs ► JobArgs ► Job
Gets the job.
Declaration Syntax
C#
public Job Job { get; }
Value
The job.


Result Property

Result Property
Namespaces ► Sitecore.Jobs ► JobArgs ► Result
Gets or sets the result.
Declaration Syntax
C#
public Object Result { get; set; }
Value
The result.


JobFinishedEventArgs Class

JobFinishedEventArgs Class
Namespaces ► Sitecore.Jobs ► JobFinishedEventArgs
Represents the arguments for a job finished event.
Declaration Syntax
C#
public class JobFinishedEventArgs : EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JobFinishedEventArgs(Job) | Initializes a new instance of the JobFinishedEventArgs class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Job | Gets the Job associated with the event.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | JobFinishedEventArgs


JobFinishedEventArgs Constructor (job)

JobFinishedEventArgs Constructor (job)
Namespaces ► Sitecore.Jobs ► JobFinishedEventArgs ► JobFinishedEventArgs(Job)
Initializes a new instance of the JobFinishedEventArgs class.
Declaration Syntax
C#
public JobFinishedEventArgs(
    Job job
)
Parameters
job (Job)
The job.


Job Property

Job Property
Namespaces ► Sitecore.Jobs ► JobFinishedEventArgs ► Job
Gets the Job associated with the event.
Declaration Syntax
C#
public Job Job { get; }
Value
The job.


JobManager Class

JobManager Class
Namespaces ► Sitecore.Jobs ► JobManager
Represents the job manager.
Declaration Syntax
C#
public static class JobManager
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetJob(Handle) | Gets the job.
 | GetJob(String) | Gets a job.
 | GetJobs()()() | Gets the jobs.
 | IsJobActive(String) | Obsolete. Determines whether a job is running.
 | IsJobQueued(String) | Determines whether a job is queued.
 | IsJobRunning(String) | Determines whether a job is running.
 | RemoveJob(Handle) | Obsolete. Removes the job.
 | Start(JobOptions) | Starts the specified options.
 | Start(Job) | Starts the specified job.
Inheritance Hierarchy
Object
JobManager


GetJob Method

GetJob Method
Namespaces ► Sitecore.Jobs ► JobManager ► GetJob()()()
Members
Icon | Member | Description
 | GetJob(Handle) | Gets the job.
 | GetJob(String) | Gets a job.


GetJob Method (handle)

GetJob Method (handle)
Namespaces ► Sitecore.Jobs ► JobManager ► GetJob(Handle)
Gets the job.
Declaration Syntax
C#
public static Job GetJob(
    Handle handle
)
Parameters
handle (Handle)
The handle.
Return Value
The Job.


GetJob Method (jobName)

GetJob Method (jobName)
Namespaces ► Sitecore.Jobs ► JobManager ► GetJob(String)
Gets a job.
Declaration Syntax
C#
public static Job GetJob(
    string jobName
)
Parameters
jobName (String)
Return Value
The Job.


GetJobs Method

GetJobs Method
Namespaces ► Sitecore.Jobs ► JobManager ► GetJobs()()()
Gets the jobs.
Declaration Syntax
C#
public static Job[] GetJobs()
Return Value
The Job.


IsJobActive Method (jobName)

IsJobActive Method (jobName)
Namespaces ► Sitecore.Jobs ► JobManager ► IsJobActive(String)
Determines whether a job is running.
Declaration Syntax
C#
[ObsoleteAttribute("Use IsJobRunning instead")]
public static bool IsJobActive(
    string jobName
)
Parameters
jobName (String)
Name of the job.
Return Value
true if a job with the specified job name is running; otherwise, false.


IsJobQueued Method (jobName)

IsJobQueued Method (jobName)
Namespaces ► Sitecore.Jobs ► JobManager ► IsJobQueued(String)
Determines whether a job is queued.
Declaration Syntax
C#
public static bool IsJobQueued(
    string jobName
)
Parameters
jobName (String)
Name of the job.
Return Value
true if a job with the specified job name is queued; otherwise, false.


IsJobRunning Method (jobName)

IsJobRunning Method (jobName)
Namespaces ► Sitecore.Jobs ► JobManager ► IsJobRunning(String)
Determines whether a job is running.
Declaration Syntax
C#
public static bool IsJobRunning(
    string jobName
)
Parameters
jobName (String)
Name of the job.
Return Value
true if a job with the specified job name is running; otherwise, false.


RemoveJob Method (handle)

RemoveJob Method (handle)
Namespaces ► Sitecore.Jobs ► JobManager ► RemoveJob(Handle)
Removes the job.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated")]
public static void RemoveJob(
    Handle handle
)
Parameters
handle (Handle)
The handle.


Start Method

Start Method
Namespaces ► Sitecore.Jobs ► JobManager ► Start()()()
Members
Icon | Member | Description
 | Start(JobOptions) | Starts the specified options.
 | Start(Job) | Starts the specified job.


Start Method (job)

Start Method (job)
Namespaces ► Sitecore.Jobs ► JobManager ► Start(Job)
Starts the specified job.
Declaration Syntax
C#
public static void Start(
    Job job
)
Parameters
job (Job)
The job.


Start Method (options)

Start Method (options)
Namespaces ► Sitecore.Jobs ► JobManager ► Start(JobOptions)
Starts the specified options.
Declaration Syntax
C#
public static Job Start(
    JobOptions options
)
Parameters
options (JobOptions)
The options.
Return Value
The Job.


JobOptions Class

JobOptions Class
Namespaces ► Sitecore.Jobs ► JobOptions
Represents the options for a Job.
Declaration Syntax
C#
public class JobOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JobOptions(String, String, String, Object, String) | Initializes a new instance of the JobOptions class.
 | JobOptions(String, String, String, Object, String, array<Object>[]()[]) | Initializes a new instance of the JobOptions class.
 | AfterLife | Gets or sets the after life.
 | AtomicExecution | Gets or sets a value indicating whether the JobOptions has atomic execution.
 | Category | Gets the category.
 | ContextUser | Gets or sets the context user.
 | CustomData | Gets or sets the custom data.
 | EnableSecurity | Gets or sets a value indicating whether the JobOptions enables security.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitialDelay | Gets or sets the initial delay.
 | Item | Gets or sets the item.
 | JobName | Gets the name of the job.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Method | Gets the method.
 | Parameters | Gets the parameters.
 | PipelineDomain | Gets or sets the pipeline domain.
 | PipelineName | Gets or sets the name of the pipeline.
 | Priority | Gets or sets the priority.
 | SiteName | Gets or sets the name of the site.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteToLog | Gets or sets a value indicating whether the JobOptions writes the to log.
Inheritance Hierarchy
Object
JobOptions


JobOptions Constructor

JobOptions Constructor
Namespaces ► Sitecore.Jobs ► JobOptions ► JobOptions()()()
Members
Icon | Member | Description
 | JobOptions(String, String, String, Object, String) | Initializes a new instance of the JobOptions class.
 | JobOptions(String, String, String, Object, String, array<Object>[]()[]) | Initializes a new instance of the JobOptions class.


JobOptions Constructor (jobName, category, siteName, obj, methodName)

JobOptions Constructor (jobName, category, siteName, obj, methodName)
Namespaces ► Sitecore.Jobs ► JobOptions ► JobOptions(String, String, String, Object, String)
Initializes a new instance of the JobOptions class.
Declaration Syntax
C#
public JobOptions(
    string jobName,
    string category,
    string siteName,
    Object obj,
    string methodName
)
Parameters
jobName (String)
Name of the job.
category (String)
The category.
siteName (String)
Name of the site.
obj (Object)
The object.
methodName (String)
Name of the method.


JobOptions Constructor (jobName, category, siteName, obj, methodName, parameters)

JobOptions Constructor (jobName, category, siteName, obj, methodName, parameters)
Namespaces ► Sitecore.Jobs ► JobOptions ► JobOptions(String, String, String, Object, String, array<Object>[]()[])
Initializes a new instance of the JobOptions class.
Declaration Syntax
C#
public JobOptions(
    string jobName,
    string category,
    string siteName,
    Object obj,
    string methodName,
    Object[] parameters
)
Parameters
jobName (String)
Name of the job.
category (String)
The category.
siteName (String)
Name of the site.
obj (Object)
The object.
methodName (String)
Name of the method.
parameters (array< Object >[]()[])
The parameters.


AfterLife Property

AfterLife Property
Namespaces ► Sitecore.Jobs ► JobOptions ► AfterLife
Gets or sets the after life.
Declaration Syntax
C#
public TimeSpan AfterLife { get; set; }
Value
The after life.


AtomicExecution Property

AtomicExecution Property
Namespaces ► Sitecore.Jobs ► JobOptions ► AtomicExecution
Gets or sets a value indicating whether the JobOptions has atomic execution.
Declaration Syntax
C#
public bool AtomicExecution { get; set; }
Value
true if the JobOptions has atomic execution; otherwise, false.


Category Property

Category Property
Namespaces ► Sitecore.Jobs ► JobOptions ► Category
Gets the category.
Declaration Syntax
C#
public string Category { get; }
Value
The category.


ContextUser Property

ContextUser Property
Namespaces ► Sitecore.Jobs ► JobOptions ► ContextUser
Gets or sets the context user.
Declaration Syntax
C#
public User ContextUser { get; set; }
Value
The context user.


CustomData Property

CustomData Property
Namespaces ► Sitecore.Jobs ► JobOptions ► CustomData
Gets or sets the custom data.
Declaration Syntax
C#
public Object CustomData { get; set; }
Value
The custom data.


EnableSecurity Property

EnableSecurity Property
Namespaces ► Sitecore.Jobs ► JobOptions ► EnableSecurity
Gets or sets a value indicating whether the JobOptions enables security.
Declaration Syntax
C#
public bool EnableSecurity { get; set; }
Value
true if the JobOptions enables security; otherwise, false.


InitialDelay Property

InitialDelay Property
Namespaces ► Sitecore.Jobs ► JobOptions ► InitialDelay
Gets or sets the initial delay.
Declaration Syntax
C#
public TimeSpan InitialDelay { get; set; }
Value
The initial delay.
Remarks
The job will sleep for this period before executing.


Item Property

Item Property
Namespaces ► Sitecore.Jobs ► JobOptions ► Item
Gets or sets the item.
Declaration Syntax
C#
public Item Item { get; set; }
Value
The item.


JobName Property

JobName Property
Namespaces ► Sitecore.Jobs ► JobOptions ► JobName
Gets the name of the job.
Declaration Syntax
C#
public string JobName { get; }
Value
The name of the job.


Method Property

Method Property
Namespaces ► Sitecore.Jobs ► JobOptions ► Method
Gets the method.
Declaration Syntax
C#
public MethodInstance Method { get; }
Value
The method.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Jobs ► JobOptions ► Parameters
Gets the parameters.
Declaration Syntax
C#
public Object[] Parameters { get; }
Value
The parameters.


PipelineDomain Property

PipelineDomain Property
Namespaces ► Sitecore.Jobs ► JobOptions ► PipelineDomain
Gets or sets the pipeline domain.
Declaration Syntax
C#
public string PipelineDomain { get; set; }
Value
The pipeline domain.


PipelineName Property

PipelineName Property
Namespaces ► Sitecore.Jobs ► JobOptions ► PipelineName
Gets or sets the name of the pipeline.
Declaration Syntax
C#
public string PipelineName { get; set; }
Value
The name of the pipeline.


Priority Property

Priority Property
Namespaces ► Sitecore.Jobs ► JobOptions ► Priority
Gets or sets the priority.
Declaration Syntax
C#
public ThreadPriority Priority { get; set; }
Value
The priority.


SiteName Property

SiteName Property
Namespaces ► Sitecore.Jobs ► JobOptions ► SiteName
Gets or sets the name of the site.
Declaration Syntax
C#
public string SiteName { get; set; }
Value
The name of the site.


WriteToLog Property

WriteToLog Property
Namespaces ► Sitecore.Jobs ► JobOptions ► WriteToLog
Gets or sets a value indicating whether the JobOptions writes the to log.
Declaration Syntax
C#
public bool WriteToLog { get; set; }
Value
true if the JobOptions writes the to log; otherwise, false.


JobRunner Class

JobRunner Class
Namespaces ► Sitecore.Jobs ► JobRunner
Represents a Job runner.
Declaration Syntax
C#
public class JobRunner
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | JobRunner()()() | Initializes a new instance of the JobRunner class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeContext(JobArgs) | Initializes the context.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResetSecurity(JobArgs) | Resets the security.
 | RunMethod(JobArgs) | Runs the method.
 | SetContextUser(JobArgs) | Sets the context user.
 | SetPriority(JobArgs) | Sets the priority.
 | SetSecurity(JobArgs) | Sets the security.
 | SignalEnd(JobArgs) | Signals the end.
 | SignalStart(JobArgs) | Signals the start.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
JobRunner


JobRunner Constructor

JobRunner Constructor
Namespaces ► Sitecore.Jobs ► JobRunner ► JobRunner()()()
Initializes a new instance of the JobRunner class
Declaration Syntax
C#
public JobRunner()


InitializeContext Method (args)

InitializeContext Method (args)
Namespaces ► Sitecore.Jobs ► JobRunner ► InitializeContext(JobArgs)
Initializes the context.
Declaration Syntax
C#
public static void InitializeContext(
    JobArgs args
)
Parameters
args (JobArgs)
The arguments.


ResetSecurity Method (args)

ResetSecurity Method (args)
Namespaces ► Sitecore.Jobs ► JobRunner ► ResetSecurity(JobArgs)
Resets the security.
Declaration Syntax
C#
public static void ResetSecurity(
    JobArgs args
)
Parameters
args (JobArgs)
The arguments.


RunMethod Method (args)

RunMethod Method (args)
Namespaces ► Sitecore.Jobs ► JobRunner ► RunMethod(JobArgs)
Runs the method.
Declaration Syntax
C#
public static void RunMethod(
    JobArgs args
)
Parameters
args (JobArgs)
The arguments.


SetContextUser Method (args)

SetContextUser Method (args)
Namespaces ► Sitecore.Jobs ► JobRunner ► SetContextUser(JobArgs)
Sets the context user.
Declaration Syntax
C#
public static void SetContextUser(
    JobArgs args
)
Parameters
args (JobArgs)
The arguments.


SetPriority Method (args)

SetPriority Method (args)
Namespaces ► Sitecore.Jobs ► JobRunner ► SetPriority(JobArgs)
Sets the priority.
Declaration Syntax
C#
public static void SetPriority(
    JobArgs args
)
Parameters
args (JobArgs)
The arguments.


SetSecurity Method (args)

SetSecurity Method (args)
Namespaces ► Sitecore.Jobs ► JobRunner ► SetSecurity(JobArgs)
Sets the security.
Declaration Syntax
C#
public static void SetSecurity(
    JobArgs args
)
Parameters
args (JobArgs)
The arguments.


SignalEnd Method (args)

SignalEnd Method (args)
Namespaces ► Sitecore.Jobs ► JobRunner ► SignalEnd(JobArgs)
Signals the end.
Declaration Syntax
C#
public static void SignalEnd(
    JobArgs args
)
Parameters
args (JobArgs)
The arguments.


SignalStart Method (args)

SignalStart Method (args)
Namespaces ► Sitecore.Jobs ► JobRunner ► SignalStart(JobArgs)
Signals the start.
Declaration Syntax
C#
public static void SignalStart(
    JobArgs args
)
Parameters
args (JobArgs)
The arguments.


JobState Enumeration

JobState Enumeration
Namespaces ► Sitecore.Jobs ► JobState
Represents the state of a Job.
Declaration Syntax
C#
public enum JobState
Members
Member | Description
Initializing | Initializing.
Queued | Queued.
Running | Running.
Finished | Finished.
Unknown | Unknown.


JobStatus Class

JobStatus Class
Namespaces ► Sitecore.Jobs ► JobStatus
Represents the status of a Job.
Declaration Syntax
C#
public class JobStatus
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JobStatus(Job) | Initializes a new instance of the JobStatus class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Expiry | Gets or sets the expiry.
 | Failed | Gets or sets a value indicating whether this JobStatus is failed.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCounter(String) | Obsolete. Gets the counter.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Job | Gets the job.
 | LogError(String) | Logs the error.
 | LogException(Exception) | Logs the exception.
 | LogInfo(String) | Logs the info.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Messages | Gets the messages.
 | Processed | Gets or sets the number of processed units.
 | Result | Gets or sets the result.
 | State | Gets or sets the state.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Total | Gets or sets the total.
Inheritance Hierarchy
Object
JobStatus


JobStatus Constructor (job)

JobStatus Constructor (job)
Namespaces ► Sitecore.Jobs ► JobStatus ► JobStatus(Job)
Initializes a new instance of the JobStatus class.
Declaration Syntax
C#
public JobStatus(
    Job job
)
Parameters
job (Job)
The job.


Expiry Property

Expiry Property
Namespaces ► Sitecore.Jobs ► JobStatus ► Expiry
Gets or sets the expiry.
Declaration Syntax
C#
public DateTime Expiry { get; set; }
Value
The expiry.


Failed Property

Failed Property
Namespaces ► Sitecore.Jobs ► JobStatus ► Failed
Gets or sets a value indicating whether this JobStatus is failed.
Declaration Syntax
C#
public bool Failed { get; set; }
Value
true if failed; otherwise, false.


GetCounter Method (name)

GetCounter Method (name)
Namespaces ► Sitecore.Jobs ► JobStatus ► GetCounter(String)
Gets the counter.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated")]
public CounterData GetCounter(
    string name
)
Parameters
name (String)
The name.
Return Value
The CounterData.


Job Property

Job Property
Namespaces ► Sitecore.Jobs ► JobStatus ► Job
Gets the job.
Declaration Syntax
C#
public Job Job { get; }
Value
The job.


LogError Method (message)

LogError Method (message)
Namespaces ► Sitecore.Jobs ► JobStatus ► LogError(String)
Logs the error.
Declaration Syntax
C#
public void LogError(
    string message
)
Parameters
message (String)
The message.


LogException Method (ex)

LogException Method (ex)
Namespaces ► Sitecore.Jobs ► JobStatus ► LogException(Exception)
Logs the exception.
Declaration Syntax
C#
public void LogException(
    Exception ex
)
Parameters
ex (Exception)
The ex.


LogInfo Method (message)

LogInfo Method (message)
Namespaces ► Sitecore.Jobs ► JobStatus ► LogInfo(String)
Logs the info.
Declaration Syntax
C#
public void LogInfo(
    string message
)
Parameters
message (String)
The message.


Messages Property

Messages Property
Namespaces ► Sitecore.Jobs ► JobStatus ► Messages
Gets the messages.
Declaration Syntax
C#
public StringCollection Messages { get; }
Value
The messages.


Processed Property

Processed Property
Namespaces ► Sitecore.Jobs ► JobStatus ► Processed
Gets or sets the number of processed units.
Declaration Syntax
C#
public long Processed { get; set; }
Value
The number of processed units.


Result Property

Result Property
Namespaces ► Sitecore.Jobs ► JobStatus ► Result
Gets or sets the result.
Declaration Syntax
C#
public Object Result { get; set; }
Value
The result.


State Property

State Property
Namespaces ► Sitecore.Jobs ► JobStatus ► State
Gets or sets the state.
Declaration Syntax
C#
public JobState State { get; set; }
Value
The state.


Total Property

Total Property
Namespaces ► Sitecore.Jobs ► JobStatus ► Total
Gets or sets the total.
Declaration Syntax
C#
public long Total { get; set; }
Value
The total.


Sitecore.Jobs.AsyncUI Namespace

Sitecore.Jobs.AsyncUI Namespace
Namespaces ► Sitecore.Jobs.AsyncUI
Declaration Syntax
C#
namespace Sitecore.Jobs.AsyncUI
Types
All Types Classes Interfaces Delegates
Icon | Type | Description
 | AlertMessage | Message to show an alert
 | BasePipelineMessage | A base class for a pipeline message
 | Callback | Callback
 | ConfirmMessage | Confirmation message
 | ExecuteMessage | Execute message
 | FlushMessage | Flush message
 | IMessage | Defines basic methods for a message
 | InvalidContextException | InvalidContextException class
 | JobContext | Task context
 | JobMonitor | Controls which is checking the TaskInfo and executing scheduled callbacks
 | MessageQueue | Message queue
 | PipelineCallback | Pipeline callback
 | ExecuteMessage..::.PipelineRunner | Pipeline callback
 | SendMessageMessage | SendMessage Message
 | ShowModalDialogMessage | Show modal dialog message
 | SyncBoolean | A wrapper for AutoResetEvent class to use as a boolean
 | JobMonitor..::.TaskRunner | Adaptor from ThreadStart to job API


AlertMessage Class

AlertMessage Class
Namespaces ► Sitecore.Jobs.AsyncUI ► AlertMessage
Message to show an alert
Declaration Syntax
C#
[SerializableAttribute]
public class AlertMessage : IMessage
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AlertMessage(String) | Initializes a new instance of the AlertMessage class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Shows an alert message.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AlertMessage


AlertMessage Constructor (message)

AlertMessage Constructor (message)
Namespaces ► Sitecore.Jobs.AsyncUI ► AlertMessage ► AlertMessage(String)
Initializes a new instance of the AlertMessage class.
Declaration Syntax
C#
public AlertMessage(
    string message
)
Parameters
message (String)
The message.


Execute Method

Execute Method
Namespaces ► Sitecore.Jobs.AsyncUI ► AlertMessage ► Execute()()()
Shows an alert message.
Declaration Syntax
C#
public void Execute()


BasePipelineMessage Class

BasePipelineMessage Class
Namespaces ► Sitecore.Jobs.AsyncUI ► BasePipelineMessage
A base class for a pipeline message
Declaration Syntax
C#
[SerializableAttribute]
public abstract class BasePipelineMessage : IMessage
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BasePipelineMessage()()() | Initializes a new instance of the BasePipelineMessage class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Starts the pipeline.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Pipeline(ClientPipelineArgs) | Entry point for a pipeline.
 | ShowUI()()() | Abstract method to show the UI.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BasePipelineMessage
 |  | ConfirmMessage
 |  | ShowModalDialogMessage


BasePipelineMessage Constructor

BasePipelineMessage Constructor
Namespaces ► Sitecore.Jobs.AsyncUI ► BasePipelineMessage ► BasePipelineMessage()()()
Initializes a new instance of the BasePipelineMessage class.
Declaration Syntax
C#
protected BasePipelineMessage()


Execute Method

Execute Method
Namespaces ► Sitecore.Jobs.AsyncUI ► BasePipelineMessage ► Execute()()()
Starts the pipeline.
Declaration Syntax
C#
public void Execute()


Pipeline Method (args)

Pipeline Method (args)
Namespaces ► Sitecore.Jobs.AsyncUI ► BasePipelineMessage ► Pipeline(ClientPipelineArgs)
Entry point for a pipeline.
Declaration Syntax
C#
public void Pipeline(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


ShowUI Method

ShowUI Method
Namespaces ► Sitecore.Jobs.AsyncUI ► BasePipelineMessage ► ShowUI()()()
Abstract method to show the UI.
Declaration Syntax
C#
protected abstract void ShowUI()


Callback Delegate

Callback Delegate
Namespaces ► Sitecore.Jobs.AsyncUI ► Callback
Callback
Declaration Syntax
C#
public delegate Object Callback()


ConfirmMessage Class

ConfirmMessage Class
Namespaces ► Sitecore.Jobs.AsyncUI ► ConfirmMessage
Confirmation message
Declaration Syntax
C#
[SerializableAttribute]
public class ConfirmMessage : BasePipelineMessage
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConfirmMessage(String) | Initializes a new instance of the ConfirmMessage class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Starts the pipeline. (Inherited from BasePipelineMessage.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Pipeline(ClientPipelineArgs) | Entry point for a pipeline. (Inherited from BasePipelineMessage.)
 | ShowUI()()() | Shows a confirmation dialog. (Overrides BasePipelineMessage.ShowUI()()().)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BasePipelineMessage
 |  | ConfirmMessage


ConfirmMessage Constructor (message)

ConfirmMessage Constructor (message)
Namespaces ► Sitecore.Jobs.AsyncUI ► ConfirmMessage ► ConfirmMessage(String)
Initializes a new instance of the ConfirmMessage class.
Declaration Syntax
C#
public ConfirmMessage(
    string message
)
Parameters
message (String)
The message.


ShowUI Method

ShowUI Method
Namespaces ► Sitecore.Jobs.AsyncUI ► ConfirmMessage ► ShowUI()()()
Shows a confirmation dialog.
Declaration Syntax
C#
protected override void ShowUI()


ExecuteMessage Class

ExecuteMessage Class
Namespaces ► Sitecore.Jobs.AsyncUI ► ExecuteMessage
Execute message
Declaration Syntax
C#
public class ExecuteMessage : IMessage
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExecuteMessage(Delegate) | Initializes a new instance of the ExecuteMessage class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the callback.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ExecuteMessage


ExecuteMessage Constructor (callback)

ExecuteMessage Constructor (callback)
Namespaces ► Sitecore.Jobs.AsyncUI ► ExecuteMessage ► ExecuteMessage(Delegate)
Initializes a new instance of the ExecuteMessage class.
Declaration Syntax
C#
public ExecuteMessage(
    Delegate callback
)
Parameters
callback (Delegate)
The callback.


Execute Method

Execute Method
Namespaces ► Sitecore.Jobs.AsyncUI ► ExecuteMessage ► Execute()()()
Executes the callback.
Declaration Syntax
C#
public void Execute()


ExecuteMessage.PipelineRunner Class

ExecuteMessage..::.PipelineRunner Class
Namespaces ► Sitecore.Jobs.AsyncUI ► ExecuteMessage ► ExecuteMessage..::.PipelineRunner
Pipeline callback
Declaration Syntax
C#
[SerializableAttribute]
public class PipelineRunner
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExecuteMessage..::.PipelineRunner(PipelineCallback, Handle) | Initializes a new instance of the ExecuteMessage..::.PipelineRunner class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Pipeline(ClientPipelineArgs) | Pipeline function.
 | Start()()() | Starts this instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ExecuteMessage..::.PipelineRunner


ExecuteMessage.PipelineRunner Constructor (callback, jobHandle)

ExecuteMessage..::.PipelineRunner Constructor (callback, jobHandle)
Namespaces ► Sitecore.Jobs.AsyncUI ► ExecuteMessage..::.PipelineRunner ► ExecuteMessage..::.PipelineRunner(PipelineCallback, Handle)
Initializes a new instance of the ExecuteMessage..::.PipelineRunner class.
Declaration Syntax
C#
public PipelineRunner(
    PipelineCallback callback,
    Handle jobHandle
)
Parameters
callback (PipelineCallback)
The callback.
jobHandle (Handle)
The taskid.


Pipeline Method (args)

Pipeline Method (args)
Namespaces ► Sitecore.Jobs.AsyncUI ► ExecuteMessage..::.PipelineRunner ► Pipeline(ClientPipelineArgs)
Pipeline function.
Declaration Syntax
C#
public void Pipeline(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Start Method

Start Method
Namespaces ► Sitecore.Jobs.AsyncUI ► ExecuteMessage..::.PipelineRunner ► Start()()()
Starts this instance.
Declaration Syntax
C#
public void Start()


FlushMessage Class

FlushMessage Class
Namespaces ► Sitecore.Jobs.AsyncUI ► FlushMessage
Flush message
Declaration Syntax
C#
public class FlushMessage : IMessage
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FlushMessage()()() | Initializes a new instance of the FlushMessage class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Put bool(true) value to the result
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FlushMessage


FlushMessage Constructor

FlushMessage Constructor
Namespaces ► Sitecore.Jobs.AsyncUI ► FlushMessage ► FlushMessage()()()
Initializes a new instance of the FlushMessage class.
Declaration Syntax
C#
public FlushMessage()


Execute Method

Execute Method
Namespaces ► Sitecore.Jobs.AsyncUI ► FlushMessage ► Execute()()()
Put bool(true) value to the result
Declaration Syntax
C#
public void Execute()


IMessage Interface

IMessage Interface
Namespaces ► Sitecore.Jobs.AsyncUI ► IMessage
Defines basic methods for a message
Declaration Syntax
C#
public interface IMessage
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Execute()()() | Executes message action.


Execute Method

Execute Method
Namespaces ► Sitecore.Jobs.AsyncUI ► IMessage ► Execute()()()
Executes message action.
Declaration Syntax
C#
void Execute()


InvalidContextException Class

InvalidContextException Class
Namespaces ► Sitecore.Jobs.AsyncUI ► InvalidContextException
InvalidContextException class
Declaration Syntax
C#
[SerializableAttribute]
public class InvalidContextException : InvalidOperationException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InvalidContextException()()() | Initializes a new instance of the InvalidContextException class.
 | InvalidContextException(String) | Initializes a new instance of the InvalidContextException class.
 | InvalidContextException(String, Exception) | Initializes a new instance of the InvalidContextException class.
 | InvalidContextException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidContextException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SystemException
 |  |  | InvalidOperationException
 |  |  |  | InvalidContextException


InvalidContextException Constructor

InvalidContextException Constructor
Namespaces ► Sitecore.Jobs.AsyncUI ► InvalidContextException ► InvalidContextException()()()
Members
Icon | Member | Description
 | InvalidContextException()()() | Initializes a new instance of the InvalidContextException class.
 | InvalidContextException(String) | Initializes a new instance of the InvalidContextException class.
 | InvalidContextException(String, Exception) | Initializes a new instance of the InvalidContextException class.
 | InvalidContextException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidContextException class.


InvalidContextException Constructor

InvalidContextException Constructor
Namespaces ► Sitecore.Jobs.AsyncUI ► InvalidContextException ► InvalidContextException()()()
Initializes a new instance of the InvalidContextException class.
Declaration Syntax
C#
public InvalidContextException()


InvalidContextException Constructor (info, context)

InvalidContextException Constructor (info, context)
Namespaces ► Sitecore.Jobs.AsyncUI ► InvalidContextException ► InvalidContextException(SerializationInfo, StreamingContext)
Initializes a new instance of the InvalidContextException class.
Declaration Syntax
C#
public InvalidContextException(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The object that holds the serialized object data.
context (StreamingContext)
The contextual information about the source or destination.


InvalidContextException Constructor (message)

InvalidContextException Constructor (message)
Namespaces ► Sitecore.Jobs.AsyncUI ► InvalidContextException ► InvalidContextException(String)
Initializes a new instance of the InvalidContextException class.
Declaration Syntax
C#
public InvalidContextException(
    string message
)
Parameters
message (String)
The message.


InvalidContextException Constructor (message, inner)

InvalidContextException Constructor (message, inner)
Namespaces ► Sitecore.Jobs.AsyncUI ► InvalidContextException ► InvalidContextException(String, Exception)
Initializes a new instance of the InvalidContextException class.
Declaration Syntax
C#
public InvalidContextException(
    string message,
    Exception inner
)
Parameters
message (String)
The message.
inner (Exception)
The inner.


JobContext Class

JobContext Class
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext
Task context
Declaration Syntax
C#
public static class JobContext
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Alert(String) | Shows an alert dialog.
 | Confirm(String) | Runs a confirm dialog.
 | Execute(Callback) | Executes the specified callback.
 | Execute(PipelineCallback) | Executes the specified pipeline callback.
 | Execute(ThreadStart) | Executes the specified callback asynchroniously.
 | Flush()()() | Makes sure monitor processes all outstanding messages.
 | IsJob | Gets a value indicating whether current thread contains a task.
 | Job | Gets the job.
 | JobHandle | Gets the task ID.
 | MessageQueue | Gets the message queue for the current job.
 | PostMessage(String) | Posts the message to the page without waiting for result.
 | PostMessage(Message) | Posts the message to the page without waiting fo result.
 | SendMessage(String) | Sends the message and waits for result.
 | SendMessage(Message) | Sends the message and waits for result.
 | ShowModalDialog(String) | Shows the modal dialog.
 | ShowModalDialog(String, String, String) | Shows the modal dialog.
 | ShowModalDialog(String, String, String, String) | Shows the modal dialog.
 | ShowModalDialog(Hashtable, String, String, String) | Shows the modal dialog.
Inheritance Hierarchy
Object
JobContext


Alert Method (message)

Alert Method (message)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► Alert(String)
Shows an alert dialog.
Declaration Syntax
C#
public static void Alert(
    string message
)
Parameters
message (String)
The message.


Confirm Method (message)

Confirm Method (message)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► Confirm(String)
Runs a confirm dialog.
Declaration Syntax
C#
public static string Confirm(
    string message
)
Parameters
message (String)
The message.
Return Value
The confirmation result.


Execute Method

Execute Method
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► Execute()()()
Members
Icon | Member | Description
 | Execute(Callback) | Executes the specified callback.
 | Execute(PipelineCallback) | Executes the specified pipeline callback.
 | Execute(ThreadStart) | Executes the specified callback asynchroniously.


Execute Method (callback)

Execute Method (callback)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► Execute(Callback)
Executes the specified callback.
Declaration Syntax
C#
public static Object Execute(
    Callback callback
)
Parameters
callback (Callback)
The callback.
Return Value
Callback result.


Execute Method (callback)

Execute Method (callback)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► Execute(PipelineCallback)
Executes the specified pipeline callback.
Declaration Syntax
C#
public static Object Execute(
    PipelineCallback callback
)
Parameters
callback (PipelineCallback)
The callback.
Return Value
Callback result.


Execute Method (callback)

Execute Method (callback)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► Execute(ThreadStart)
Executes the specified callback asynchroniously.
Declaration Syntax
C#
public static void Execute(
    ThreadStart callback
)
Parameters
callback (ThreadStart)
The callback.
Return Value
Callback result.


Flush Method

Flush Method
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► Flush()()()
Makes sure monitor processes all outstanding messages.
Declaration Syntax
C#
public static void Flush()


IsJob Property

IsJob Property
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► IsJob
Gets a value indicating whether current thread contains a task.
Declaration Syntax
C#
public static bool IsJob { get; }
Value
true if this instance is a task; otherwise, false.


Job Property

Job Property
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► Job
Gets the job.
Declaration Syntax
C#
public static Job Job { get; }
Value
The job.
Exceptions
Exception | Condition
InvalidContextException | InvalidContextException.


JobHandle Property

JobHandle Property
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► JobHandle
Gets the task ID.
Declaration Syntax
C#
public static Handle JobHandle { get; }
Value
The task ID.


MessageQueue Property

MessageQueue Property
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► MessageQueue
Gets the message queue for the current job.
Declaration Syntax
C#
public static MessageQueue MessageQueue { get; }
Value
The message queue.


PostMessage Method

PostMessage Method
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► PostMessage()()()
Members
Icon | Member | Description
 | PostMessage(String) | Posts the message to the page without waiting for result.
 | PostMessage(Message) | Posts the message to the page without waiting fo result.


PostMessage Method (message)

PostMessage Method (message)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► PostMessage(Message)
Posts the message to the page without waiting fo result.
Declaration Syntax
C#
public static void PostMessage(
    Message message
)
Parameters
message (Message)
The message.


PostMessage Method (message)

PostMessage Method (message)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► PostMessage(String)
Posts the message to the page without waiting for result.
Declaration Syntax
C#
public static void PostMessage(
    string message
)
Parameters
message (String)
The message.


SendMessage Method

SendMessage Method
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► SendMessage()()()
Members
Icon | Member | Description
 | SendMessage(String) | Sends the message and waits for result.
 | SendMessage(Message) | Sends the message and waits for result.


SendMessage Method (message)

SendMessage Method (message)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► SendMessage(Message)
Sends the message and waits for result.
Declaration Syntax
C#
public static Object SendMessage(
    Message message
)
Parameters
message (Message)
The message.
Return Value


SendMessage Method (message)

SendMessage Method (message)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► SendMessage(String)
Sends the message and waits for result.
Declaration Syntax
C#
public static Object SendMessage(
    string message
)
Parameters
message (String)
The message.
Return Value


ShowModalDialog Method

ShowModalDialog Method
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► ShowModalDialog()()()
Members
Icon | Member | Description
 | ShowModalDialog(String) | Shows the modal dialog.
 | ShowModalDialog(String, String, String) | Shows the modal dialog.
 | ShowModalDialog(String, String, String, String) | Shows the modal dialog.
 | ShowModalDialog(Hashtable, String, String, String) | Shows the modal dialog.


ShowModalDialog Method (parameters, controlName, width, height)

ShowModalDialog Method (parameters, controlName, width, height)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► ShowModalDialog(Hashtable, String, String, String)
Shows the modal dialog.
Declaration Syntax
C#
public static string ShowModalDialog(
    Hashtable parameters,
    string controlName,
    string width,
    string height
)
Parameters
parameters (Hashtable)
The parameters.
controlName (String)
Name of the control.
width (String)
The width.
height (String)
The height.
Return Value
Dialog result.


ShowModalDialog Method (url)

ShowModalDialog Method (url)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► ShowModalDialog(String)
Shows the modal dialog.
Declaration Syntax
C#
public static string ShowModalDialog(
    string url
)
Parameters
url (String)
The URL.
Return Value
Dialog result.


ShowModalDialog Method (url, width, height)

ShowModalDialog Method (url, width, height)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► ShowModalDialog(String, String, String)
Shows the modal dialog.
Declaration Syntax
C#
public static string ShowModalDialog(
    string url,
    string width,
    string height
)
Parameters
url (String)
The URL.
width (String)
The width.
height (String)
The height.
Return Value
Dialog result.


ShowModalDialog Method (title, controlName, width, height)

ShowModalDialog Method (title, controlName, width, height)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobContext ► ShowModalDialog(String, String, String, String)
Shows the modal dialog.
Declaration Syntax
C#
public static string ShowModalDialog(
    string title,
    string controlName,
    string width,
    string height
)
Parameters
title (String)
The message.
controlName (String)
Name of the control.
width (String)
The width.
height (String)
The height.
Return Value
Dialog result.


JobMonitor Class

JobMonitor Class
Namespaces ► Sitecore.Jobs.AsyncUI ► JobMonitor
Controls which is checking the TaskInfo and executing scheduled callbacks
Declaration Syntax
C#
public class JobMonitor : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JobMonitor()()() | Initializes a new instance of the JobMonitor class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Component.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Overrides Control.HandleMessage(Message).)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | JobDisappeared | Occurs when check message received without current task.
 | JobFinished | Occurs when the task is finished.
 | JobHandle | Gets or sets the task.
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Start(String, String, ThreadStart) | Starts the specified task.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | JobMonitor


JobMonitor Constructor

JobMonitor Constructor
Namespaces ► Sitecore.Jobs.AsyncUI ► JobMonitor ► JobMonitor()()()
Initializes a new instance of the JobMonitor class
Declaration Syntax
C#
public JobMonitor()


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobMonitor ► HandleMessage(Message)
Handles the message.
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)
The message.


JobDisappeared Event

JobDisappeared Event
Namespaces ► Sitecore.Jobs.AsyncUI ► JobMonitor ► JobDisappeared
Occurs when check message received without current task.
Declaration Syntax
C#
public event EventHandler JobDisappeared


JobFinished Event

JobFinished Event
Namespaces ► Sitecore.Jobs.AsyncUI ► JobMonitor ► JobFinished
Occurs when the task is finished.
Declaration Syntax
C#
public event EventHandler JobFinished


JobHandle Property

JobHandle Property
Namespaces ► Sitecore.Jobs.AsyncUI ► JobMonitor ► JobHandle
Gets or sets the task.
Declaration Syntax
C#
public Handle JobHandle { get; set; }
Value
The task.


Start Method (name, category, task)

Start Method (name, category, task)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobMonitor ► Start(String, String, ThreadStart)
Starts the specified task.
Declaration Syntax
C#
public void Start(
    string name,
    string category,
    ThreadStart task
)
Parameters
name (String)
The name.
category (String)
The category.
task (ThreadStart)
The entry.


JobMonitor.TaskRunner Class

JobMonitor..::.TaskRunner Class
Namespaces ► Sitecore.Jobs.AsyncUI ► JobMonitor ► JobMonitor..::.TaskRunner
Adaptor from ThreadStart to job API
Declaration Syntax
C#
public class TaskRunner
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | JobMonitor..::.TaskRunner(ThreadStart) | Initializes a new instance of the JobMonitor..::.TaskRunner class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run()()() | Runs the task inside the job.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
JobMonitor..::.TaskRunner


JobMonitor.TaskRunner Constructor (task)

JobMonitor..::.TaskRunner Constructor (task)
Namespaces ► Sitecore.Jobs.AsyncUI ► JobMonitor..::.TaskRunner ► JobMonitor..::.TaskRunner(ThreadStart)
Initializes a new instance of the JobMonitor..::.TaskRunner class.
Declaration Syntax
C#
public TaskRunner(
    ThreadStart task
)
Parameters
task (ThreadStart)
The task.


Run Method

Run Method
Namespaces ► Sitecore.Jobs.AsyncUI ► JobMonitor..::.TaskRunner ► Run()()()
Runs the task inside the job.
Declaration Syntax
C#
public void Run()


MessageQueue Class

MessageQueue Class
Namespaces ► Sitecore.Jobs.AsyncUI ► MessageQueue
Message queue
Declaration Syntax
C#
public class MessageQueue
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MessageQueue()()() | Initializes a new instance of the MessageQueue class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessage(IMessage%) | Gets the message from the queue.
 | GetResult()()() | Gets the result.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PutMessage(IMessage) | Puts the message to the queue.
 | PutResult(Object) | Puts the result to the queue.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MessageQueue


MessageQueue Constructor

MessageQueue Constructor
Namespaces ► Sitecore.Jobs.AsyncUI ► MessageQueue ► MessageQueue()()()
Initializes a new instance of the MessageQueue class
Declaration Syntax
C#
public MessageQueue()


GetMessage Method (message)

GetMessage Method (message)
Namespaces ► Sitecore.Jobs.AsyncUI ► MessageQueue ► GetMessage(IMessage%)
Gets the message from the queue.
Declaration Syntax
C#
public bool GetMessage(
    out IMessage message
)
Parameters
message ( IMessage %)
The message.
Return Value
False if the queue was empty


GetResult Method

GetResult Method
Namespaces ► Sitecore.Jobs.AsyncUI ► MessageQueue ► GetResult()()()
Gets the result.
Declaration Syntax
C#
public Object GetResult()
Return Value
The result.


PutMessage Method (message)

PutMessage Method (message)
Namespaces ► Sitecore.Jobs.AsyncUI ► MessageQueue ► PutMessage(IMessage)
Puts the message to the queue.
Declaration Syntax
C#
public void PutMessage(
    IMessage message
)
Parameters
message (IMessage)
The message.


PutResult Method (result)

PutResult Method (result)
Namespaces ► Sitecore.Jobs.AsyncUI ► MessageQueue ► PutResult(Object)
Puts the result to the queue.
Declaration Syntax
C#
public void PutResult(
    Object result
)
Parameters
result (Object)
The result.


PipelineCallback Delegate

PipelineCallback Delegate
Namespaces ► Sitecore.Jobs.AsyncUI ► PipelineCallback
Pipeline callback
Declaration Syntax
C#
public delegate Object PipelineCallback(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)


SendMessageMessage Class

SendMessageMessage Class
Namespaces ► Sitecore.Jobs.AsyncUI ► SendMessageMessage
SendMessage Message
Declaration Syntax
C#
public class SendMessageMessage : IMessage
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SendMessageMessage(String, Boolean) | Initializes a new instance of the SendMessageMessage class.
 | SendMessageMessage(Message, Boolean) | Initializes a new instance of the SendMessageMessage class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Sends a message.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SendMessageMessage


SendMessageMessage Constructor

SendMessageMessage Constructor
Namespaces ► Sitecore.Jobs.AsyncUI ► SendMessageMessage ► SendMessageMessage()()()
Members
Icon | Member | Description
 | SendMessageMessage(String, Boolean) | Initializes a new instance of the SendMessageMessage class.
 | SendMessageMessage(Message, Boolean) | Initializes a new instance of the SendMessageMessage class.


SendMessageMessage Constructor (message, postBack)

SendMessageMessage Constructor (message, postBack)
Namespaces ► Sitecore.Jobs.AsyncUI ► SendMessageMessage ► SendMessageMessage(Message, Boolean)
Initializes a new instance of the SendMessageMessage class.
Declaration Syntax
C#
public SendMessageMessage(
    Message message,
    bool postBack
)
Parameters
message (Message)
The message.
postBack (Boolean)
if set to true the result should be put to the queue.


SendMessageMessage Constructor (message, postBack)

SendMessageMessage Constructor (message, postBack)
Namespaces ► Sitecore.Jobs.AsyncUI ► SendMessageMessage ► SendMessageMessage(String, Boolean)
Initializes a new instance of the SendMessageMessage class.
Declaration Syntax
C#
public SendMessageMessage(
    string message,
    bool postBack
)
Parameters
message (String)
The message.
postBack (Boolean)
if set to true the result should be put to the queue.


Execute Method

Execute Method
Namespaces ► Sitecore.Jobs.AsyncUI ► SendMessageMessage ► Execute()()()
Sends a message.
Declaration Syntax
C#
public void Execute()


ShowModalDialogMessage Class

ShowModalDialogMessage Class
Namespaces ► Sitecore.Jobs.AsyncUI ► ShowModalDialogMessage
Show modal dialog message
Declaration Syntax
C#
[SerializableAttribute]
public class ShowModalDialogMessage : BasePipelineMessage
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ShowModalDialogMessage(String) | Initializes a new instance of the ShowModalDialogMessage class.
 | ShowModalDialogMessage(String, String, String) | Initializes a new instance of the ShowModalDialogMessage class.
 | ShowModalDialogMessage(String, String, String, String) | Initializes a new instance of the ShowModalDialogMessage class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Starts the pipeline. (Inherited from BasePipelineMessage.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Pipeline(ClientPipelineArgs) | Entry point for a pipeline. (Inherited from BasePipelineMessage.)
 | ShowUI()()() | Shows the dialog. (Overrides BasePipelineMessage.ShowUI()()().)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BasePipelineMessage
 |  | ShowModalDialogMessage


ShowModalDialogMessage Constructor

ShowModalDialogMessage Constructor
Namespaces ► Sitecore.Jobs.AsyncUI ► ShowModalDialogMessage ► ShowModalDialogMessage()()()
Members
Icon | Member | Description
 | ShowModalDialogMessage(String) | Initializes a new instance of the ShowModalDialogMessage class.
 | ShowModalDialogMessage(String, String, String) | Initializes a new instance of the ShowModalDialogMessage class.
 | ShowModalDialogMessage(String, String, String, String) | Initializes a new instance of the ShowModalDialogMessage class.


ShowModalDialogMessage Constructor (url)

ShowModalDialogMessage Constructor (url)
Namespaces ► Sitecore.Jobs.AsyncUI ► ShowModalDialogMessage ► ShowModalDialogMessage(String)
Initializes a new instance of the ShowModalDialogMessage class.
Declaration Syntax
C#
public ShowModalDialogMessage(
    string url
)
Parameters
url (String)
The URL.


ShowModalDialogMessage Constructor (url, width, height)

ShowModalDialogMessage Constructor (url, width, height)
Namespaces ► Sitecore.Jobs.AsyncUI ► ShowModalDialogMessage ► ShowModalDialogMessage(String, String, String)
Initializes a new instance of the ShowModalDialogMessage class.
Declaration Syntax
C#
public ShowModalDialogMessage(
    string url,
    string width,
    string height
)
Parameters
url (String)
The URL.
width (String)
The width.
height (String)
The height.


ShowModalDialogMessage Constructor (url, width, height, message)

ShowModalDialogMessage Constructor (url, width, height, message)
Namespaces ► Sitecore.Jobs.AsyncUI ► ShowModalDialogMessage ► ShowModalDialogMessage(String, String, String, String)
Initializes a new instance of the ShowModalDialogMessage class.
Declaration Syntax
C#
public ShowModalDialogMessage(
    string url,
    string width,
    string height,
    string message
)
Parameters
url (String)
The URL.
width (String)
The width.
height (String)
The height.
message (String)
The message.


ShowUI Method

ShowUI Method
Namespaces ► Sitecore.Jobs.AsyncUI ► ShowModalDialogMessage ► ShowUI()()()
Shows the dialog.
Declaration Syntax
C#
protected override void ShowUI()


SyncBoolean Class

SyncBoolean Class
Namespaces ► Sitecore.Jobs.AsyncUI ► SyncBoolean
A wrapper for AutoResetEvent class to use as a boolean
Declaration Syntax
C#
public class SyncBoolean
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SyncBoolean()()() | Initializes a new instance of the SyncBoolean class.
 | SyncBoolean(Boolean) | Initializes a new instance of the SyncBoolean class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Timeout | Gets or sets the timeout.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets a value of this instance.
 | WaitFor(Boolean) | Waits for when this instance will have specifyed value
Inheritance Hierarchy
Object
SyncBoolean


SyncBoolean Constructor

SyncBoolean Constructor
Namespaces ► Sitecore.Jobs.AsyncUI ► SyncBoolean ► SyncBoolean()()()
Members
Icon | Member | Description
 | SyncBoolean()()() | Initializes a new instance of the SyncBoolean class.
 | SyncBoolean(Boolean) | Initializes a new instance of the SyncBoolean class.


SyncBoolean Constructor

SyncBoolean Constructor
Namespaces ► Sitecore.Jobs.AsyncUI ► SyncBoolean ► SyncBoolean()()()
Initializes a new instance of the SyncBoolean class.
Declaration Syntax
C#
public SyncBoolean()


SyncBoolean Constructor (initialValue)

SyncBoolean Constructor (initialValue)
Namespaces ► Sitecore.Jobs.AsyncUI ► SyncBoolean ► SyncBoolean(Boolean)
Initializes a new instance of the SyncBoolean class.
Declaration Syntax
C#
public SyncBoolean(
    bool initialValue
)
Parameters
initialValue (Boolean)
if set to true this instance is initial value.


Timeout Property

Timeout Property
Namespaces ► Sitecore.Jobs.AsyncUI ► SyncBoolean ► Timeout
Gets or sets the timeout.
Declaration Syntax
C#
public TimeSpan Timeout { get; set; }
Value
The timeout.


Value Property

Value Property
Namespaces ► Sitecore.Jobs.AsyncUI ► SyncBoolean ► Value
Gets or sets a value of this instance.
Declaration Syntax
C#
public bool Value { get; set; }
Value
Boolean value


WaitFor Method (value)

WaitFor Method (value)
Namespaces ► Sitecore.Jobs.AsyncUI ► SyncBoolean ► WaitFor(Boolean)
Waits for when this instance will have specifyed value
Declaration Syntax
C#
public void WaitFor(
    bool value
)
Parameters
value (Boolean)
if set to true this instance is value.


Sitecore.layouts Namespace

Sitecore.layouts Namespace
Namespaces ► Sitecore.layouts
Declaration Syntax
C#
namespace Sitecore.layouts
Types
All Types Classes
Icon | Type | Description
 | SizeStatus |


SizeStatus Class

SizeStatus Class
Namespaces ► Sitecore.layouts ► SizeStatus
Declaration Syntax
C#
public class SizeStatus : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SizeStatus()()() | Initializes a new instance of the SizeStatus class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | c_base | c_base control.
 | c_baseUsed | c_baseUsed control.
 | c_details | c_details control.
 | c_dictionaryEntries | c_dictionaryEntries control.
 | c_limit | c_limit control.
 | c_limitUser | c_limitUser control.
 | c_maxEntity | c_maxEntity control.
 | c_minDictionaryEntries | c_minDictionaryEntries control.
 | c_minEntity | c_minEntity control.
 | c_remaining | c_remaining control.
 | c_remainingPct | c_remainingPct control.
 | c_remainingUser | c_remainingUser control.
 | c_remainingUserPct | c_remainingUserPct control.
 | c_used | c_used control.
 | c_usedPct | c_usedPct control.
 | c_usedUser | c_usedUser control.
 | c_usedUserPct | c_usedUserPct control.
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 | form1 control.
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) | Handles the Load event of the Page control.
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | SizeStatus

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SizeStatus Constructor

SizeStatus Constructor
Namespaces ► Sitecore.layouts ► SizeStatus ► SizeStatus()()()
Initializes a new instance of the SizeStatus class
Declaration Syntax
C#
public SizeStatus()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_base Field

c_base Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_base
c_base control.
Declaration Syntax
C#
protected Label c_base
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_baseUsed Field

c_baseUsed Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_baseUsed
c_baseUsed control.
Declaration Syntax
C#
protected Label c_baseUsed
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_details Field

c_details Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_details
c_details control.
Declaration Syntax
C#
protected PlaceHolder c_details
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_dictionaryEntries Field

c_dictionaryEntries Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_dictionaryEntries
c_dictionaryEntries control.
Declaration Syntax
C#
protected Label c_dictionaryEntries
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_limit Field

c_limit Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_limit
c_limit control.
Declaration Syntax
C#
protected Label c_limit
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_limitUser Field

c_limitUser Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_limitUser
c_limitUser control.
Declaration Syntax
C#
protected Label c_limitUser
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_maxEntity Field

c_maxEntity Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_maxEntity
c_maxEntity control.
Declaration Syntax
C#
protected Label c_maxEntity
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_minDictionaryEntries Field

c_minDictionaryEntries Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_minDictionaryEntries
c_minDictionaryEntries control.
Declaration Syntax
C#
protected Label c_minDictionaryEntries
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_minEntity Field

c_minEntity Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_minEntity
c_minEntity control.
Declaration Syntax
C#
protected Label c_minEntity
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_remaining Field

c_remaining Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_remaining
c_remaining control.
Declaration Syntax
C#
protected Label c_remaining
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_remainingPct Field

c_remainingPct Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_remainingPct
c_remainingPct control.
Declaration Syntax
C#
protected Label c_remainingPct
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_remainingUser Field

c_remainingUser Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_remainingUser
c_remainingUser control.
Declaration Syntax
C#
protected Label c_remainingUser
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_remainingUserPct Field

c_remainingUserPct Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_remainingUserPct
c_remainingUserPct control.
Declaration Syntax
C#
protected Label c_remainingUserPct
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_used Field

c_used Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_used
c_used control.
Declaration Syntax
C#
protected Label c_used
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_usedPct Field

c_usedPct Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_usedPct
c_usedPct control.
Declaration Syntax
C#
protected Label c_usedPct
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_usedUser Field

c_usedUser Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_usedUser
c_usedUser control.
Declaration Syntax
C#
protected Label c_usedUser
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_usedUserPct Field

c_usedUserPct Field
Namespaces ► Sitecore.layouts ► SizeStatus ► c_usedUserPct
c_usedUserPct control.
Declaration Syntax
C#
protected Label c_usedUserPct
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


form1 Field

form1 Field
Namespaces ► Sitecore.layouts ► SizeStatus ► form1
form1 control.
Declaration Syntax
C#
protected HtmlForm form1
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore.layouts ► SizeStatus ► Page_Load(Object, EventArgs)
Handles the Load event of the Page control.
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Layouts Namespace

Sitecore.Layouts Namespace
Namespaces ► Sitecore.Layouts
Declaration Syntax
C#
namespace Sitecore.Layouts
Types
All Types Classes Interfaces
Icon | Type | Description
 | CachedXmlUrlResolver |
 | ControlFactory | Creates controls for layouts.
 | DesignTimeHtml..::.ControlOptions | Rendering node parameters
 | Converter | Converts HTML from runtime to designtime and back.
 | DesignTimeHtml | Converts HTML from runtime to designtime and back.
 | DeviceDefinition | Represents a device.
 | HtmlParts | Represents html document parsed into header / body / footer.
 | IExpandable |
 | LayoutDefinition | Represents a layout.
 | PageContext | Nested type: Expander Holds the current page context.
 | PlaceholderDefinition | Represents a placeholder.
 | RenderingCaching | Represents caching information for a rendering.
 | RenderingDefinition | Represents a rendering.
 | RenderingReference | Represents a reference to a rendering.
 | RenderingReferenceList | Represents a list of rendering references
 | RenderingSettings | Represents a set of rendering settings.
 | RuntimeHtml | Converts HTML from runtime to designtime and back.
 | XHtml | Represents a XHtml.
 | XHtmlValidator |
 | XHtmlValidatorError |


CachedXmlUrlResolver Class

CachedXmlUrlResolver Class
Namespaces ► Sitecore.Layouts ► CachedXmlUrlResolver
Declaration Syntax
C#
public class CachedXmlUrlResolver : XmlUrlResolver
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CachedXmlUrlResolver()()() | Initializes a new instance of the CachedXmlUrlResolver class
 | Credentials | Sets credentials used to authenticate Web requests. (Inherited from XmlUrlResolver.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEntity(Uri, String, Type) | Maps a URI to an object containing the actual resource. (Overrides XmlUrlResolver.GetEntity(Uri, String, Type).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveUri(Uri, String) | Resolves the absolute URI from the base and relative URIs. (Inherited from XmlUrlResolver.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | XmlResolver
 |  | XmlUrlResolver
 |  |  | CachedXmlUrlResolver


CachedXmlUrlResolver Constructor

CachedXmlUrlResolver Constructor
Namespaces ► Sitecore.Layouts ► CachedXmlUrlResolver ► CachedXmlUrlResolver()()()
Initializes a new instance of the CachedXmlUrlResolver class
Declaration Syntax
C#
public CachedXmlUrlResolver()


GetEntity Method (absoluteUri, role, ofObjectToReturn)

GetEntity Method (absoluteUri, role, ofObjectToReturn)
Namespaces ► Sitecore.Layouts ► CachedXmlUrlResolver ► GetEntity(Uri, String, Type)
Maps a URI to an object containing the actual resource.
Declaration Syntax
C#
public override Object GetEntity(
    Uri absoluteUri,
    string role,
    Type ofObjectToReturn
)
Parameters
absoluteUri (Uri)
The URI returned from ResolveUri(Uri, String)
role (String)
The current implementation does not use this parameter when resolving URIs. This is provided for future extensibility purposes. For example, this can be mapped to the xlink:role and used as an implementation specific argument in other scenarios.
ofObjectToReturn (Type)
The type of object to return. The current implementation only returns System.IO.Stream objects.
Return Value
A System.IO.Stream object or null if a type other than stream is specified.
Exceptions
Exception | Condition
XmlException | ofObjectToReturn is neither null nor a Stream type.
UriFormatException | The specified URI is not an absolute URI.
NullReferenceException | absoluteUri is null.
Exception | There is a runtime error (for example, an interrupted server connection).


ControlFactory Class

ControlFactory Class
Namespaces ► Sitecore.Layouts ► ControlFactory
Creates controls for layouts.
Declaration Syntax
C#
public static class ControlFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetLoginControl(WebControl, Boolean) | Gets the login control.
 | GetRenderingControl(String, Boolean) | Gets the rendering control.
Inheritance Hierarchy
Object
ControlFactory


GetLoginControl Method (control, assert)

GetLoginControl Method (control, assert)
Namespaces ► Sitecore.Layouts ► ControlFactory ► GetLoginControl(WebControl, Boolean)
Gets the login control.
Declaration Syntax
C#
public static Control GetLoginControl(
    WebControl control,
    bool assert
)
Parameters
control (WebControl)
The control.
assert (Boolean)
if set to true this instance is assert.
Return Value


GetRenderingControl Method (renderingPath, assert)

GetRenderingControl Method (renderingPath, assert)
Namespaces ► Sitecore.Layouts ► ControlFactory ► GetRenderingControl(String, Boolean)
Gets the rendering control.
Declaration Syntax
C#
public static Control GetRenderingControl(
    string renderingPath,
    bool assert
)
Parameters
renderingPath (String)
The rendering path.
assert (Boolean)
if set to true this instance is assert.
Return Value


Converter Class

Converter Class
Namespaces ► Sitecore.Layouts ► Converter
Converts HTML from runtime to designtime and back.
Declaration Syntax
C#
public static class Converter
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Convert(String) | Obsolete. Converts to XHtml.
 | ConvertToDesignTime(String, String) | Obsolete. Converts to design time.
 | ConvertToDesignTime(String, String, NameValueCollection) | Obsolete. Converts to design time.
 | ConvertToDesignTime(String, String, NameValueCollection, Boolean) | Obsolete. Converts to design time.
 | ConvertToRuntime(String) | Obsolete. Converts to runtime.
 | ConvertToXml(String) | Obsolete. Converts to XML.
 | FixBullets(HtmlDocument) | Obsolete. Fixes the bullets.
 | GetLayoutObject(HtmlDocument, String, String, String, String, String, String, NameValueCollection) | Obsolete. Gets the layout object.
 | GetLayoutObject(HtmlDocument, String, String, String, String, String, String, NameValueCollection, Boolean) | Obsolete. Gets the layout object.
 | Parse(String, String%, String%, String%) | Obsolete. Parses the specified HTML.
Inheritance Hierarchy
Object
Converter


Convert Method (body)

Convert Method (body)
Namespaces ► Sitecore.Layouts ► Converter ► Convert(String)
Converts to XHtml.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use XHtml.Convert instead.")]
public static string Convert(
    string body
)
Parameters
body (String)
The body.
Return Value


ConvertToDesignTime Method

ConvertToDesignTime Method
Namespaces ► Sitecore.Layouts ► Converter ► ConvertToDesignTime()()()
Members
Icon | Member | Description
 | ConvertToDesignTime(String, String) | Obsolete. Converts to design time.
 | ConvertToDesignTime(String, String, NameValueCollection) | Obsolete. Converts to design time.
 | ConvertToDesignTime(String, String, NameValueCollection, Boolean) | Obsolete. Converts to design time.


ConvertToDesignTime Method (body, controlName)

ConvertToDesignTime Method (body, controlName)
Namespaces ► Sitecore.Layouts ► Converter ► ConvertToDesignTime(String, String)
Converts to design time.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use DesignTimeHtml.Convert instead.")]
public static string ConvertToDesignTime(
    string body,
    string controlName
)
Parameters
body (String)
The body.
controlName (String)
Name of the control.
Return Value


ConvertToDesignTime Method (body, controlName, querystring)

ConvertToDesignTime Method (body, controlName, querystring)
Namespaces ► Sitecore.Layouts ► Converter ► ConvertToDesignTime(String, String, NameValueCollection)
Converts to design time.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use DesignTimeHtml.Convert instead.")]
public static string ConvertToDesignTime(
    string body,
    string controlName,
    NameValueCollection querystring
)
Parameters
body (String)
The body.
controlName (String)
Name of the control.
querystring (NameValueCollection)
The querystring.
Return Value
The to design time Html.


ConvertToDesignTime Method (body, controlName, querystring, inlineControls)

ConvertToDesignTime Method (body, controlName, querystring, inlineControls)
Namespaces ► Sitecore.Layouts ► Converter ► ConvertToDesignTime(String, String, NameValueCollection, Boolean)
Converts to design time.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use DesignTimeHtml.Convert instead.")]
public static string ConvertToDesignTime(
    string body,
    string controlName,
    NameValueCollection querystring,
    bool inlineControls
)
Parameters
body (String)
The body.
controlName (String)
Name of the control.
querystring (NameValueCollection)
The querystring.
inlineControls (Boolean)
if set to true this instance generates inline controls.
Return Value
The to design time Html.


ConvertToRuntime Method (body)

ConvertToRuntime Method (body)
Namespaces ► Sitecore.Layouts ► Converter ► ConvertToRuntime(String)
Converts to runtime.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use RuntimeHtml.Convert instead.")]
public static string ConvertToRuntime(
    string body
)
Parameters
body (String)
The body.
Return Value


ConvertToXml Method (body)

ConvertToXml Method (body)
Namespaces ► Sitecore.Layouts ► Converter ► ConvertToXml(String)
Converts to XML.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use XHtml.ConvertToXml instead.")]
public static string ConvertToXml(
    string body
)
Parameters
body (String)
The body.
Return Value


FixBullets Method (document)

FixBullets Method (document)
Namespaces ► Sitecore.Layouts ► Converter ► FixBullets(HtmlDocument)
Fixes the bullets.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use RuntimeHtml.FixBullets instead.")]
public static void FixBullets(
    HtmlDocument document
)
Parameters
document (HtmlDocument)
The document.


GetLayoutObject Method

GetLayoutObject Method
Namespaces ► Sitecore.Layouts ► Converter ► GetLayoutObject()()()
Members
Icon | Member | Description
 | GetLayoutObject(HtmlDocument, String, String, String, String, String, String, NameValueCollection) | Obsolete. Gets the layout object.
 | GetLayoutObject(HtmlDocument, String, String, String, String, String, String, NameValueCollection, Boolean) | Obsolete. Gets the layout object.


GetLayoutObject Method (document, id, tagPrefix, tagName, parameters, renderingID, controlName, querystring)

GetLayoutObject Method (document, id, tagPrefix, tagName, parameters, renderingID, controlName, querystring)
Namespaces ► Sitecore.Layouts ► Converter ► GetLayoutObject(HtmlDocument, String, String, String, String, String, String, NameValueCollection)
Gets the layout object.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use DesignTimeHtml.GetRenderingNode instead.")]
public static HtmlNode GetLayoutObject(
    HtmlDocument document,
    string id,
    string tagPrefix,
    string tagName,
    string parameters,
    string renderingID,
    string controlName,
    NameValueCollection querystring
)
Parameters
document (HtmlDocument)
The document.
id (String)
The id.
tagPrefix (String)
The tag prefix.
tagName (String)
Name of the tag.
parameters (String)
The parameters.
renderingID (String)
The rendering ID.
controlName (String)
Name of the control.
querystring (NameValueCollection)
The querystring.
Return Value
The layout object.


GetLayoutObject Method (document, id, tagPrefix, tagName, parameters, renderingID, controlName, querystring, inlineControls)

GetLayoutObject Method (document, id, tagPrefix, tagName, parameters, renderingID, controlName, querystring, inlineControls)
Namespaces ► Sitecore.Layouts ► Converter ► GetLayoutObject(HtmlDocument, String, String, String, String, String, String, NameValueCollection, Boolean)
Gets the layout object.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use DesignTimeHtml.GetRenderingNode instead.")]
public static HtmlNode GetLayoutObject(
    HtmlDocument document,
    string id,
    string tagPrefix,
    string tagName,
    string parameters,
    string renderingID,
    string controlName,
    NameValueCollection querystring,
    bool inlineControls
)
Parameters
document (HtmlDocument)
The document.
id (String)
The id.
tagPrefix (String)
The tag prefix.
tagName (String)
Name of the tag.
parameters (String)
The parameters.
renderingID (String)
The rendering ID.
controlName (String)
Name of the control.
querystring (NameValueCollection)
The querystring.
inlineControls (Boolean)
if set to true this instance is inline controls.
Return Value
The layout object.


Parse Method (html, header, body, footer)

Parse Method (html, header, body, footer)
Namespaces ► Sitecore.Layouts ► Converter ► Parse(String, String%, String%, String%)
Parses the specified HTML.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use RuntimeHtml.Parse instead.")]
public static void Parse(
    string html,
    out string header,
    out string body,
    out string footer
)
Parameters
html (String)
The HTML.
header ( String %)
The header.
body ( String %)
The body.
footer ( String %)
The footer.


DesignTimeHtml Class

DesignTimeHtml Class
Namespaces ► Sitecore.Layouts ► DesignTimeHtml
Converts HTML from runtime to designtime and back.
Declaration Syntax
C#
public static class DesignTimeHtml
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Convert(String, String) | Obsolete. Converts to design time.
 | Convert(String, String, NameValueCollection) | Converts to design time.
 | Convert(String, String, NameValueCollection, Boolean) | Converts to design time.
 | FixBullets(HtmlDocument) | Fixes the bullets.
 | FixSelectOptions(HtmlDocument) | Fixes the select options.
 | GetRenderingNode(HtmlDocument, RenderingItem, String, String%) | Gets the rendering node.
 | GetRenderingNode(HtmlDocument, DesignTimeHtml..::.ControlOptions) | Gets the layout object.
Inheritance Hierarchy
Object
DesignTimeHtml


Convert Method

Convert Method
Namespaces ► Sitecore.Layouts ► DesignTimeHtml ► Convert()()()
Members
Icon | Member | Description
 | Convert(String, String) | Obsolete. Converts to design time.
 | Convert(String, String, NameValueCollection) | Converts to design time.
 | Convert(String, String, NameValueCollection, Boolean) | Converts to design time.


Convert Method (body, controlName)

Convert Method (body, controlName)
Namespaces ► Sitecore.Layouts ► DesignTimeHtml ► Convert(String, String)
Converts to design time.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Convert(string, string, NameValueCollection) instead.")]
public static string Convert(
    string body,
    string controlName
)
Parameters
body (String)
The body.
controlName (String)
Name of the control.
Return Value
The design time html.


Convert Method (body, controlName, querystring)

Convert Method (body, controlName, querystring)
Namespaces ► Sitecore.Layouts ► DesignTimeHtml ► Convert(String, String, NameValueCollection)
Converts to design time.
Declaration Syntax
C#
public static string Convert(
    string body,
    string controlName,
    NameValueCollection querystring
)
Parameters
body (String)
The body.
controlName (String)
Name of the control.
querystring (NameValueCollection)
The querystring.
Return Value
The to design time Html.


Convert Method (body, controlName, querystring, inlineControls)

Convert Method (body, controlName, querystring, inlineControls)
Namespaces ► Sitecore.Layouts ► DesignTimeHtml ► Convert(String, String, NameValueCollection, Boolean)
Converts to design time.
Declaration Syntax
C#
public static string Convert(
    string body,
    string controlName,
    NameValueCollection querystring,
    bool inlineControls
)
Parameters
body (String)
The body.
controlName (String)
Name of the control.
querystring (NameValueCollection)
The querystring.
inlineControls (Boolean)
if set to true this instance generates inline controls.
Return Value
The to design time Html.


FixBullets Method (document)

FixBullets Method (document)
Namespaces ► Sitecore.Layouts ► DesignTimeHtml ► FixBullets(HtmlDocument)
Fixes the bullets.
Declaration Syntax
C#
public static void FixBullets(
    HtmlDocument document
)
Parameters
document (HtmlDocument)
The document.


FixSelectOptions Method (document)

FixSelectOptions Method (document)
Namespaces ► Sitecore.Layouts ► DesignTimeHtml ► FixSelectOptions(HtmlDocument)
Fixes the select options.
Declaration Syntax
C#
public static void FixSelectOptions(
    HtmlDocument document
)
Parameters
document (HtmlDocument)
The document.


GetRenderingNode Method

GetRenderingNode Method
Namespaces ► Sitecore.Layouts ► DesignTimeHtml ► GetRenderingNode()()()
Members
Icon | Member | Description
 | GetRenderingNode(HtmlDocument, RenderingItem, String, String%) | Gets the rendering node.
 | GetRenderingNode(HtmlDocument, DesignTimeHtml..::.ControlOptions) | Gets the layout object.


GetRenderingNode Method (document, rendering, controlName, htmlHeader)

GetRenderingNode Method (document, rendering, controlName, htmlHeader)
Namespaces ► Sitecore.Layouts ► DesignTimeHtml ► GetRenderingNode(HtmlDocument, RenderingItem, String, String%)
Gets the rendering node.
Declaration Syntax
C#
public static HtmlNode GetRenderingNode(
    HtmlDocument document,
    RenderingItem rendering,
    string controlName,
    ref string htmlHeader
)
Parameters
document (HtmlDocument)
The document.
rendering (RenderingItem)
The rendering.
controlName (String)
Name of the control.
htmlHeader ( String %)
The HTML header.
Return Value
The rendering node.


GetRenderingNode Method (document, options)

GetRenderingNode Method (document, options)
Namespaces ► Sitecore.Layouts ► DesignTimeHtml ► GetRenderingNode(HtmlDocument, DesignTimeHtml..::.ControlOptions)
Gets the layout object.
Declaration Syntax
C#
public static HtmlNode GetRenderingNode(
    HtmlDocument document,
    DesignTimeHtml..::.ControlOptions options
)
Parameters
document (HtmlDocument)
The document.
options (DesignTimeHtml..::.ControlOptions)
The rendering node params.
Return Value
The layout object.


DesignTimeHtml.ControlOptions Class

DesignTimeHtml..::.ControlOptions Class
Namespaces ► Sitecore.Layouts ► DesignTimeHtml ► DesignTimeHtml..::.ControlOptions
Rendering node parameters
Declaration Syntax
C#
public class ControlOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DesignTimeHtml..::.ControlOptions()()() | Initializes a new instance of the DesignTimeHtml..::.ControlOptions class
 | ControlName | Gets or sets the name of the control.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the ID.
 | InlineControls | Gets or sets a value indicating whether the DesignTimeHtml..::.ControlOptions inlines the controls.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets or sets the parameters.
 | Querystring | Gets the querystring.
 | RenderingID | Gets or sets the rendering ID.
 | TagName | Gets or sets the name of the tag.
 | TagPrefix | Gets or sets the tag prefix.
 | Tooltip | Gets or sets the tooltip.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DesignTimeHtml..::.ControlOptions


DesignTimeHtml.ControlOptions Constructor

DesignTimeHtml..::.ControlOptions Constructor
Namespaces ► Sitecore.Layouts ► DesignTimeHtml..::.ControlOptions ► DesignTimeHtml..::.ControlOptions()()()
Initializes a new instance of the DesignTimeHtml..::.ControlOptions class
Declaration Syntax
C#
public ControlOptions()


ControlName Property

ControlName Property
Namespaces ► Sitecore.Layouts ► DesignTimeHtml..::.ControlOptions ► ControlName
Gets or sets the name of the control.
Declaration Syntax
C#
public string ControlName { get; set; }
Value
The name of the control.


ID Property

ID Property
Namespaces ► Sitecore.Layouts ► DesignTimeHtml..::.ControlOptions ► ID
Gets or sets the ID.
Declaration Syntax
C#
public string ID { get; set; }
Value
The ID.


InlineControls Property

InlineControls Property
Namespaces ► Sitecore.Layouts ► DesignTimeHtml..::.ControlOptions ► InlineControls
Gets or sets a value indicating whether the DesignTimeHtml..::.ControlOptions inlines the controls.
Declaration Syntax
C#
public bool InlineControls { get; set; }
Value
true if the DesignTimeHtml..::.ControlOptions inlines the controls; otherwise, false.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Layouts ► DesignTimeHtml..::.ControlOptions ► Parameters
Gets or sets the parameters.
Declaration Syntax
C#
public string Parameters { get; set; }
Value
The parameters.


Querystring Property

Querystring Property
Namespaces ► Sitecore.Layouts ► DesignTimeHtml..::.ControlOptions ► Querystring
Gets the querystring.
Declaration Syntax
C#
public NameValueCollection Querystring { get; set; }
Value
The querystring.


RenderingID Property

RenderingID Property
Namespaces ► Sitecore.Layouts ► DesignTimeHtml..::.ControlOptions ► RenderingID
Gets or sets the rendering ID.
Declaration Syntax
C#
public string RenderingID { get; set; }
Value
The rendering ID.


TagName Property

TagName Property
Namespaces ► Sitecore.Layouts ► DesignTimeHtml..::.ControlOptions ► TagName
Gets or sets the name of the tag.
Declaration Syntax
C#
public string TagName { get; set; }
Value
The name of the tag.


TagPrefix Property

TagPrefix Property
Namespaces ► Sitecore.Layouts ► DesignTimeHtml..::.ControlOptions ► TagPrefix
Gets or sets the tag prefix.
Declaration Syntax
C#
public string TagPrefix { get; set; }
Value
The tag prefix.


Tooltip Property

Tooltip Property
Namespaces ► Sitecore.Layouts ► DesignTimeHtml..::.ControlOptions ► Tooltip
Gets or sets the tooltip.
Declaration Syntax
C#
public string Tooltip { get; set; }
Value
The tooltip.


DeviceDefinition Class

DeviceDefinition Class
Namespaces ► Sitecore.Layouts ► DeviceDefinition
Represents a device.
Declaration Syntax
C#
public class DeviceDefinition : XmlSerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeviceDefinition()()() | Initializes a new instance of the DeviceDefinition class
 | AddPlaceholder(PlaceholderDefinition) | Adds the placeholder.
 | AddRendering(RenderingDefinition) | Adds the rendering.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIndex(String) | Gets the index.
 | GetPlaceholder(String) | Gets the placeholder.
 | GetRendering(String) | Gets the rendering.
 | GetRenderings(String) | Gets all renderings with a specific id.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the ID.
 | Insert(Int32, RenderingDefinition) | Inserts the specified index.
 | Layout | Gets or sets the layout.
 | LoadXml(String) | Creates an object represenation of the string xml given as parameter. (Inherited from XmlSerializable.)
 | LoadXml(String, String) | Creates a object representation of the xml transformed using the xslt style sheed whos path is given as argument. (Inherited from XmlSerializable.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Placeholders | Gets or sets the placeholders.
 | RemoveRendering(ID, ID) | Obsolete. Removes the rendering.
 | Renderings | Gets or sets the renderings.
 | SaveAsXml(String) | Saves this object representated as xml to a file. (Inherited from XmlSerializable.)
 | SortRenderingNext(ID, ID) | Obsolete. Sorts the rendering next.
 | SortRenderingPrior(ID, ID) | Obsolete. Sorts the rendering prior.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToXml()()() | Creates a string xml representation of this object. Note that cycles are not allowed. (Inherited from XmlSerializable.)
 | ToXml(String) | Creates a xml string representation, and transforms that xml using the xslt file given at the location of the path given as parameter. (Inherited from XmlSerializable.)
Inheritance Hierarchy
Object
 | XmlSerializable
 |  | DeviceDefinition


DeviceDefinition Constructor

DeviceDefinition Constructor
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► DeviceDefinition()()()
Initializes a new instance of the DeviceDefinition class
Declaration Syntax
C#
public DeviceDefinition()


AddPlaceholder Method (placeholderDefinition)

AddPlaceholder Method (placeholderDefinition)
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► AddPlaceholder(PlaceholderDefinition)
Adds the placeholder.
Declaration Syntax
C#
public void AddPlaceholder(
    PlaceholderDefinition placeholderDefinition
)
Parameters
placeholderDefinition (PlaceholderDefinition)
The placeholder definition.


AddRendering Method (renderingDefinition)

AddRendering Method (renderingDefinition)
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► AddRendering(RenderingDefinition)
Adds the rendering.
Declaration Syntax
C#
public void AddRendering(
    RenderingDefinition renderingDefinition
)
Parameters
renderingDefinition (RenderingDefinition)
The rendering definition.


GetIndex Method (uniqueId)

GetIndex Method (uniqueId)
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► GetIndex(String)
Gets the index.
Declaration Syntax
C#
public int GetIndex(
    string uniqueId
)
Parameters
uniqueId (String)
The unique id.
Return Value
The index.


GetPlaceholder Method (uniqueID)

GetPlaceholder Method (uniqueID)
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► GetPlaceholder(String)
Gets the placeholder.
Declaration Syntax
C#
public PlaceholderDefinition GetPlaceholder(
    string uniqueID
)
Parameters
uniqueID (String)
The unique ID.
Return Value
The placeholder.


GetRendering Method (id)

GetRendering Method (id)
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► GetRendering(String)
Gets the rendering.
Declaration Syntax
C#
public RenderingDefinition GetRendering(
    string id
)
Parameters
id (String)
The id.
Return Value


GetRenderings Method (id)

GetRenderings Method (id)
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► GetRenderings(String)
Gets all renderings with a specific id.
Declaration Syntax
C#
public List<RenderingDefinition> GetRenderings(
    string id
)
Parameters
id (String)
The id.
Return Value


ID Property

ID Property
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► ID
Gets or sets the ID.
Declaration Syntax
C#
public string ID { get; set; }
Value
The ID.


Insert Method (index, renderingDefinition)

Insert Method (index, renderingDefinition)
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► Insert(Int32, RenderingDefinition)
Inserts the specified index.
Declaration Syntax
C#
public void Insert(
    int index,
    RenderingDefinition renderingDefinition
)
Parameters
index (Int32)
The index.
renderingDefinition (RenderingDefinition)
The rendering definition.


Layout Property

Layout Property
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► Layout
Gets or sets the layout.
Declaration Syntax
C#
public string Layout { get; set; }
Value
The layout.


Placeholders Property

Placeholders Property
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► Placeholders
Gets or sets the placeholders.
Declaration Syntax
C#
public ArrayList Placeholders { get; set; }
Value
The placeholders.


RemoveRendering Method (device, rendering)

RemoveRendering Method (device, rendering)
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► RemoveRendering(ID, ID)
Removes the rendering.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public void RemoveRendering(
    ID device,
    ID rendering
)
Parameters
device (ID)
The device.
rendering (ID)
The rendering.


Renderings Property

Renderings Property
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► Renderings
Gets or sets the renderings.
Declaration Syntax
C#
public ArrayList Renderings { get; set; }
Value
The renderings.


SortRenderingNext Method (device, rendering)

SortRenderingNext Method (device, rendering)
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► SortRenderingNext(ID, ID)
Sorts the rendering next.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public void SortRenderingNext(
    ID device,
    ID rendering
)
Parameters
device (ID)
The device.
rendering (ID)
The rendering.


SortRenderingPrior Method (device, rendering)

SortRenderingPrior Method (device, rendering)
Namespaces ► Sitecore.Layouts ► DeviceDefinition ► SortRenderingPrior(ID, ID)
Sorts the rendering prior.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public void SortRenderingPrior(
    ID device,
    ID rendering
)
Parameters
device (ID)
The device.
rendering (ID)
The rendering.


HtmlParts Class

HtmlParts Class
Namespaces ► Sitecore.Layouts ► HtmlParts
Represents html document parsed into header / body / footer.
Declaration Syntax
C#
[SerializableAttribute]
public class HtmlParts
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlParts()()() | Initializes a new instance of the HtmlParts class
 | Body | Gets or sets the body.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Footer | Gets or sets the footer.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Header | Gets or sets the header.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HtmlParts


HtmlParts Constructor

HtmlParts Constructor
Namespaces ► Sitecore.Layouts ► HtmlParts ► HtmlParts()()()
Initializes a new instance of the HtmlParts class
Declaration Syntax
C#
public HtmlParts()


Body Property

Body Property
Namespaces ► Sitecore.Layouts ► HtmlParts ► Body
Gets or sets the body.
Declaration Syntax
C#
public string Body { get; set; }
Value
The body.


Footer Property

Footer Property
Namespaces ► Sitecore.Layouts ► HtmlParts ► Footer
Gets or sets the footer.
Declaration Syntax
C#
public string Footer { get; set; }
Value
The footer.


Header Property

Header Property
Namespaces ► Sitecore.Layouts ► HtmlParts ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


IExpandable Interface

IExpandable Interface
Namespaces ► Sitecore.Layouts ► IExpandable
Declaration Syntax
C#
public interface IExpandable
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Expand()()() | Expands this instance.


Expand Method

Expand Method
Namespaces ► Sitecore.Layouts ► IExpandable ► Expand()()()
Expands this instance.
Declaration Syntax
C#
void Expand()


LayoutDefinition Class

LayoutDefinition Class
Namespaces ► Sitecore.Layouts ► LayoutDefinition
Represents a layout.
Declaration Syntax
C#
public class LayoutDefinition : XmlSerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayoutDefinition()()() | Initializes a new instance of the LayoutDefinition class
 | Devices | Gets or sets the devices.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDevice(String) | Gets the device.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoadXml(String) | Creates an object represenation of the string xml given as parameter. (Inherited from XmlSerializable.)
 | LoadXml(String, String) | Creates a object representation of the xml transformed using the xslt style sheed whos path is given as argument. (Inherited from XmlSerializable.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Parses the specified XML.
 | SaveAsXml(String) | Saves this object representated as xml to a file. (Inherited from XmlSerializable.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToXml()()() | Creates a string xml representation of this object. Note that cycles are not allowed. (Inherited from XmlSerializable.)
 | ToXml(String) | Creates a xml string representation, and transforms that xml using the xslt file given at the location of the path given as parameter. (Inherited from XmlSerializable.)
Inheritance Hierarchy
Object
 | XmlSerializable
 |  | LayoutDefinition


LayoutDefinition Constructor

LayoutDefinition Constructor
Namespaces ► Sitecore.Layouts ► LayoutDefinition ► LayoutDefinition()()()
Initializes a new instance of the LayoutDefinition class
Declaration Syntax
C#
public LayoutDefinition()


Devices Property

Devices Property
Namespaces ► Sitecore.Layouts ► LayoutDefinition ► Devices
Gets or sets the devices.
Declaration Syntax
C#
public ArrayList Devices { get; set; }
Value
The devices.


GetDevice Method (id)

GetDevice Method (id)
Namespaces ► Sitecore.Layouts ► LayoutDefinition ► GetDevice(String)
Gets the device.
Declaration Syntax
C#
public DeviceDefinition GetDevice(
    string id
)
Parameters
id (String)
The id.
Return Value


Parse Method (xml)

Parse Method (xml)
Namespaces ► Sitecore.Layouts ► LayoutDefinition ► Parse(String)
Parses the specified XML.
Declaration Syntax
C#
public static LayoutDefinition Parse(
    string xml
)
Parameters
xml (String)
The XML.
Return Value


PageContext Class

PageContext Class
Namespaces ► Sitecore.Layouts ► PageContext
Nested type: Expander
Holds the current page context.
Declaration Syntax
C#
public class PageContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PageContext()()() | Initializes a new instance of the PageContext class
 | AddRendering(RenderingReference) | Adds the rendering.
 | Build()()() | Builds this page.
 | Device | Gets or sets the device.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Expand(Control) | Expands the specified control.
 | FilePath | Gets or sets the file path.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPlaceholder(String) | Gets the placeholder.
 | GetPlaceholderDefinition(String, String) | Gets the placeholder definition.
 | GetPlaceholderItem(String, Database) | Gets the placeholder item.
 | GetPlaceholderItem(String, Database, String) | Gets the placeholder item.
 | GetPlaceholderItem(Placeholder, Database) | Gets the placeholder item.
 | GetRenderingReference(Control) | Gets the rendering reference corresponding to the control.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InsertDebugger()()() | Obsolete. Inserts the debugger.
 | InsertPreviewMenu()()() | Obsolete. Inserts the preview menu.
 | InsertSystemControls()()() | Inserts the system controls.
 | InsertUnusedControls()()() | Traces all unused renderings.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Page | Gets the page.
 | Placeholders | Gets the placeholders.
 | Renderings | Gets the renderings.
 | SetLayout(LayoutItem) | Obsolete. Sets the layout.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PageContext


PageContext Constructor

PageContext Constructor
Namespaces ► Sitecore.Layouts ► PageContext ► PageContext()()()
Initializes a new instance of the PageContext class
Declaration Syntax
C#
public PageContext()


AddRendering Method (reference)

AddRendering Method (reference)
Namespaces ► Sitecore.Layouts ► PageContext ► AddRendering(RenderingReference)
Adds the rendering.
Declaration Syntax
C#
public void AddRendering(
    RenderingReference reference
)
Parameters
reference (RenderingReference)
The reference.


Build Method

Build Method
Namespaces ► Sitecore.Layouts ► PageContext ► Build()()()
Builds this page.
Declaration Syntax
C#
public void Build()


Device Property

Device Property
Namespaces ► Sitecore.Layouts ► PageContext ► Device
Gets or sets the device.
Declaration Syntax
C#
public DeviceItem Device { get; set; }
Value
The device.


Expand Method (control)

Expand Method (control)
Namespaces ► Sitecore.Layouts ► PageContext ► Expand(Control)
Expands the specified control.
Declaration Syntax
C#
public void Expand(
    Control control
)
Parameters
control (Control)
The control.


FilePath Property

FilePath Property
Namespaces ► Sitecore.Layouts ► PageContext ► FilePath
Gets or sets the file path.
Declaration Syntax
C#
public string FilePath { get; set; }
Value
The file path.


GetPlaceholder Method (key)

GetPlaceholder Method (key)
Namespaces ► Sitecore.Layouts ► PageContext ► GetPlaceholder(String)
Gets the placeholder.
Declaration Syntax
C#
public Placeholder GetPlaceholder(
    string key
)
Parameters
key (String)
The key.
Return Value
The placeholder.


GetPlaceholderDefinition Method (layoutDefinition, placeholderKey)

GetPlaceholderDefinition Method (layoutDefinition, placeholderKey)
Namespaces ► Sitecore.Layouts ► PageContext ► GetPlaceholderDefinition(String, String)
Gets the placeholder definition.
Declaration Syntax
C#
public PlaceholderDefinition GetPlaceholderDefinition(
    string layoutDefinition,
    string placeholderKey
)
Parameters
layoutDefinition (String)
The layout definition.
placeholderKey (String)
The placeholder key.
Return Value
The placeholder definition.


GetPlaceholderItem Method

GetPlaceholderItem Method
Namespaces ► Sitecore.Layouts ► PageContext ► GetPlaceholderItem()()()
Members
Icon | Member | Description
 | GetPlaceholderItem(String, Database) | Gets the placeholder item.
 | GetPlaceholderItem(String, Database, String) | Gets the placeholder item.
 | GetPlaceholderItem(Placeholder, Database) | Gets the placeholder item.


GetPlaceholderItem Method (placeholder, database)

GetPlaceholderItem Method (placeholder, database)
Namespaces ► Sitecore.Layouts ► PageContext ► GetPlaceholderItem(Placeholder, Database)
Gets the placeholder item.
Declaration Syntax
C#
public Item GetPlaceholderItem(
    Placeholder placeholder,
    Database database
)
Parameters
placeholder (Placeholder)
The placeholder.
database (Database)
The database.
Return Value
The placeholder item.


GetPlaceholderItem Method (placeholderKey, database)

GetPlaceholderItem Method (placeholderKey, database)
Namespaces ► Sitecore.Layouts ► PageContext ► GetPlaceholderItem(String, Database)
Gets the placeholder item.
Declaration Syntax
C#
public Item GetPlaceholderItem(
    string placeholderKey,
    Database database
)
Parameters
placeholderKey (String)
The placeholder key.
database (Database)
The database.
Return Value
The placeholder item.


GetPlaceholderItem Method (placeholderKey, database, layoutDefinition)

GetPlaceholderItem Method (placeholderKey, database, layoutDefinition)
Namespaces ► Sitecore.Layouts ► PageContext ► GetPlaceholderItem(String, Database, String)
Gets the placeholder item.
Declaration Syntax
C#
public Item GetPlaceholderItem(
    string placeholderKey,
    Database database,
    string layoutDefinition
)
Parameters
placeholderKey (String)
The placeholder key.
database (Database)
The database.
layoutDefinition (String)
The layout definition.
Return Value
The placeholder item.


GetRenderingReference Method (control)

GetRenderingReference Method (control)
Namespaces ► Sitecore.Layouts ► PageContext ► GetRenderingReference(Control)
Gets the rendering reference corresponding to the control.
Declaration Syntax
C#
public RenderingReference GetRenderingReference(
    Control control
)
Parameters
control (Control)
The control.
Return Value
The rendering reference.


InsertDebugger Method

InsertDebugger Method
Namespaces ► Sitecore.Layouts ► PageContext ► InsertDebugger()()()
Inserts the debugger.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public void InsertDebugger()


InsertPreviewMenu Method

InsertPreviewMenu Method
Namespaces ► Sitecore.Layouts ► PageContext ► InsertPreviewMenu()()()
Inserts the preview menu.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public void InsertPreviewMenu()


InsertSystemControls Method

InsertSystemControls Method
Namespaces ► Sitecore.Layouts ► PageContext ► InsertSystemControls()()()
Inserts the system controls.
Declaration Syntax
C#
public void InsertSystemControls()


InsertUnusedControls Method

InsertUnusedControls Method
Namespaces ► Sitecore.Layouts ► PageContext ► InsertUnusedControls()()()
Traces all unused renderings.
Declaration Syntax
C#
public virtual void InsertUnusedControls()


Page Property

Page Property
Namespaces ► Sitecore.Layouts ► PageContext ► Page
Gets the page.
Declaration Syntax
C#
public Page Page { get; }
Value
The page.


Placeholders Property

Placeholders Property
Namespaces ► Sitecore.Layouts ► PageContext ► Placeholders
Gets the placeholders.
Declaration Syntax
C#
public PlaceholderList Placeholders { get; }
Value
The placeholders.


Renderings Property

Renderings Property
Namespaces ► Sitecore.Layouts ► PageContext ► Renderings
Gets the renderings.
Declaration Syntax
C#
public RenderingReferenceList Renderings { get; }
Value
The renderings.


SetLayout Method (layout)

SetLayout Method (layout)
Namespaces ► Sitecore.Layouts ► PageContext ► SetLayout(LayoutItem)
Sets the layout.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated. Use FilePath instead.")]
public void SetLayout(
    LayoutItem layout
)
Parameters
layout (LayoutItem)
The layout.


PlaceholderDefinition Class

PlaceholderDefinition Class
Namespaces ► Sitecore.Layouts ► PlaceholderDefinition
Represents a placeholder.
Declaration Syntax
C#
public class PlaceholderDefinition : XmlSerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlaceholderDefinition()()() | Initializes a new instance of the PlaceholderDefinition class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Key | Gets or sets the name.
 | LoadXml(String) | Creates an object represenation of the string xml given as parameter. (Inherited from XmlSerializable.)
 | LoadXml(String, String) | Creates a object representation of the xml transformed using the xslt style sheed whos path is given as argument. (Inherited from XmlSerializable.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MetaDataItemId | Gets or sets the meta data item id.
 | SaveAsXml(String) | Saves this object representated as xml to a file. (Inherited from XmlSerializable.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToXml()()() | Creates a string xml representation of this object. Note that cycles are not allowed. (Inherited from XmlSerializable.)
 | ToXml(String) | Creates a xml string representation, and transforms that xml using the xslt file given at the location of the path given as parameter. (Inherited from XmlSerializable.)
 | UniqueId | Gets or sets the id.
Inheritance Hierarchy
Object
 | XmlSerializable
 |  | PlaceholderDefinition


PlaceholderDefinition Constructor

PlaceholderDefinition Constructor
Namespaces ► Sitecore.Layouts ► PlaceholderDefinition ► PlaceholderDefinition()()()
Initializes a new instance of the PlaceholderDefinition class
Declaration Syntax
C#
public PlaceholderDefinition()


Key Property

Key Property
Namespaces ► Sitecore.Layouts ► PlaceholderDefinition ► Key
Gets or sets the name.
Declaration Syntax
C#
public string Key { get; set; }
Value
The name.


MetaDataItemId Property

MetaDataItemId Property
Namespaces ► Sitecore.Layouts ► PlaceholderDefinition ► MetaDataItemId
Gets or sets the meta data item id.
Declaration Syntax
C#
public string MetaDataItemId { get; set; }
Value
The meta data item id.


UniqueId Property

UniqueId Property
Namespaces ► Sitecore.Layouts ► PlaceholderDefinition ► UniqueId
Gets or sets the id.
Declaration Syntax
C#
public string UniqueId { get; set; }
Value
The id.


RenderingCaching Class

RenderingCaching Class
Namespaces ► Sitecore.Layouts ► RenderingCaching
Represents caching information for a rendering.
Declaration Syntax
C#
public class RenderingCaching
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderingCaching()()() | Initializes a new instance of the RenderingCaching class
 | Cacheable | Gets or sets a value indicating whether this RenderingCaching is cacheable.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(XmlNode) | Parses the specified config node.
 | Parse(Item) | Parses the specified item.
 | Parse(RenderingDefinition) | Parses the specified item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VaryByData | Gets or sets a value indicating whether the RenderingCaching varies by the data.
 | VaryByDevice | Gets or sets a value indicating whether the RenderingCaching varies by the device.
 | VaryByLogin | Gets or sets a value indicating whether the RenderingCaching varies by the login.
 | VaryByParm | Gets or sets a value indicating whether the RenderingCaching varies by the parameters.
 | VaryByQueryString | Gets or sets a value indicating whether the RenderingCaching varies by the query string.
 | VaryByUser | Gets or sets a value indicating whether the RenderingCaching varies by the user.
Inheritance Hierarchy
Object
RenderingCaching


RenderingCaching Constructor

RenderingCaching Constructor
Namespaces ► Sitecore.Layouts ► RenderingCaching ► RenderingCaching()()()
Initializes a new instance of the RenderingCaching class
Declaration Syntax
C#
public RenderingCaching()


Cacheable Property

Cacheable Property
Namespaces ► Sitecore.Layouts ► RenderingCaching ► Cacheable
Gets or sets a value indicating whether this RenderingCaching is cacheable.
Declaration Syntax
C#
public bool Cacheable { get; set; }
Value
true if cacheable; otherwise, false.


Parse Method

Parse Method
Namespaces ► Sitecore.Layouts ► RenderingCaching ► Parse()()()
Members
Icon | Member | Description
 | Parse(XmlNode) | Parses the specified config node.
 | Parse(Item) | Parses the specified item.
 | Parse(RenderingDefinition) | Parses the specified item.


Parse Method (item)

Parse Method (item)
Namespaces ► Sitecore.Layouts ► RenderingCaching ► Parse(Item)
Parses the specified item.
Declaration Syntax
C#
public static RenderingCaching Parse(
    Item item
)
Parameters
item (Item)
The item.
Return Value


Parse Method (definition)

Parse Method (definition)
Namespaces ► Sitecore.Layouts ► RenderingCaching ► Parse(RenderingDefinition)
Parses the specified item.
Declaration Syntax
C#
public static RenderingCaching Parse(
    RenderingDefinition definition
)
Parameters
definition (RenderingDefinition)
The definition.
Return Value
The parse.


Parse Method (configNode)

Parse Method (configNode)
Namespaces ► Sitecore.Layouts ► RenderingCaching ► Parse(XmlNode)
Parses the specified config node.
Declaration Syntax
C#
public static RenderingCaching Parse(
    XmlNode configNode
)
Parameters
configNode (XmlNode)
The config node.
Return Value


VaryByData Property

VaryByData Property
Namespaces ► Sitecore.Layouts ► RenderingCaching ► VaryByData
Gets or sets a value indicating whether the RenderingCaching varies by the data.
Declaration Syntax
C#
public bool VaryByData { get; set; }
Value
true if the RenderingCaching variess by the data; otherwise, false.


VaryByDevice Property

VaryByDevice Property
Namespaces ► Sitecore.Layouts ► RenderingCaching ► VaryByDevice
Gets or sets a value indicating whether the RenderingCaching varies by the device.
Declaration Syntax
C#
public bool VaryByDevice { get; set; }
Value
true if the RenderingCaching varies by the device; otherwise, false.


VaryByLogin Property

VaryByLogin Property
Namespaces ► Sitecore.Layouts ► RenderingCaching ► VaryByLogin
Gets or sets a value indicating whether the RenderingCaching varies by the login.
Declaration Syntax
C#
public bool VaryByLogin { get; set; }
Value
true if the RenderingCaching varies by the login; otherwise, false.


VaryByParm Property

VaryByParm Property
Namespaces ► Sitecore.Layouts ► RenderingCaching ► VaryByParm
Gets or sets a value indicating whether the RenderingCaching varies by the parameters.
Declaration Syntax
C#
public bool VaryByParm { get; set; }
Value
true if the RenderingCaching varies by the parameters; otherwise, false.


VaryByQueryString Property

VaryByQueryString Property
Namespaces ► Sitecore.Layouts ► RenderingCaching ► VaryByQueryString
Gets or sets a value indicating whether the RenderingCaching varies by the query string.
Declaration Syntax
C#
public bool VaryByQueryString { get; set; }
Value
true if the RenderingCaching varies by the query string; otherwise, false.


VaryByUser Property

VaryByUser Property
Namespaces ► Sitecore.Layouts ► RenderingCaching ► VaryByUser
Gets or sets a value indicating whether the RenderingCaching varies by the user.
Declaration Syntax
C#
public bool VaryByUser { get; set; }
Value
true if the RenderingCaching varies by the user; otherwise, false.


RenderingDefinition Class

RenderingDefinition Class
Namespaces ► Sitecore.Layouts ► RenderingDefinition
Represents a rendering.
Declaration Syntax
C#
public class RenderingDefinition : XmlSerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderingDefinition()()() | Initializes a new instance of the RenderingDefinition class
 | Cachable | Gets or sets the cachable flag.
 | Conditions | Gets or sets the conditions.
 | Datasource | Gets or sets the datasource.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemID | Gets or sets the item ID.
 | LoadXml(String) | Creates an object represenation of the string xml given as parameter. (Inherited from XmlSerializable.)
 | LoadXml(String, String) | Creates a object representation of the xml transformed using the xslt style sheed whos path is given as argument. (Inherited from XmlSerializable.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultiVariateTest | Gets or sets the multi variate test.
 | Parameters | Gets or sets the parameters.
 | Placeholder | Gets or sets the placeholder.
 | SaveAsXml(String) | Saves this object representated as xml to a file. (Inherited from XmlSerializable.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToXml()()() | Creates a string xml representation of this object. Note that cycles are not allowed. (Inherited from XmlSerializable.)
 | ToXml(String) | Creates a xml string representation, and transforms that xml using the xslt file given at the location of the path given as parameter. (Inherited from XmlSerializable.)
 | UniqueId | Gets or sets the unique id.
 | VaryByData | Gets or sets the vary by data.
 | VaryByDevice | Gets or sets the vary by device.
 | VaryByLogin | Gets or sets the vary by login.
 | VaryByParameters | Gets or sets the vary by parameters.
 | VaryByQueryString | Gets or sets the vary by query string.
 | VaryByUser | Gets or sets the vary by user.
Inheritance Hierarchy
Object
 | XmlSerializable
 |  | RenderingDefinition


RenderingDefinition Constructor

RenderingDefinition Constructor
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► RenderingDefinition()()()
Initializes a new instance of the RenderingDefinition class
Declaration Syntax
C#
public RenderingDefinition()


Cachable Property

Cachable Property
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► Cachable
Gets or sets the cachable flag.
Declaration Syntax
C#
public string Cachable { get; set; }
Value
The cachable flag.


Conditions Property

Conditions Property
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► Conditions
Gets or sets the conditions.
Declaration Syntax
C#
public string Conditions { get; set; }
Value
The conditions.


Datasource Property

Datasource Property
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► Datasource
Gets or sets the datasource.
Declaration Syntax
C#
public string Datasource { get; set; }
Value
The datasource.


ItemID Property

ItemID Property
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► ItemID
Gets or sets the item ID.
Declaration Syntax
C#
public string ItemID { get; set; }
Value
The item ID.


MultiVariateTest Property

MultiVariateTest Property
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► MultiVariateTest
Gets or sets the multi variate test.
Declaration Syntax
C#
public string MultiVariateTest { get; set; }
Value
The multi variate test.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► Parameters
Gets or sets the parameters.
Declaration Syntax
C#
public string Parameters { get; set; }
Value
The parameters.


Placeholder Property

Placeholder Property
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► Placeholder
Gets or sets the placeholder.
Declaration Syntax
C#
public string Placeholder { get; set; }
Value
The placeholder.


UniqueId Property

UniqueId Property
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► UniqueId
Gets or sets the unique id.
Declaration Syntax
C#
public string UniqueId { get; set; }
Value
The unique id.


VaryByData Property

VaryByData Property
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► VaryByData
Gets or sets the vary by data.
Declaration Syntax
C#
public string VaryByData { get; set; }
Value
The vary by data.


VaryByDevice Property

VaryByDevice Property
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► VaryByDevice
Gets or sets the vary by device.
Declaration Syntax
C#
public string VaryByDevice { get; set; }
Value
The vary by device.


VaryByLogin Property

VaryByLogin Property
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► VaryByLogin
Gets or sets the vary by login.
Declaration Syntax
C#
public string VaryByLogin { get; set; }
Value
The vary by login.


VaryByParameters Property

VaryByParameters Property
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► VaryByParameters
Gets or sets the vary by parameters.
Declaration Syntax
C#
public string VaryByParameters { get; set; }
Value
The vary by parameters.


VaryByQueryString Property

VaryByQueryString Property
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► VaryByQueryString
Gets or sets the vary by query string.
Declaration Syntax
C#
public string VaryByQueryString { get; set; }
Value
The vary by query string.


VaryByUser Property

VaryByUser Property
Namespaces ► Sitecore.Layouts ► RenderingDefinition ► VaryByUser
Gets or sets the vary by user.
Declaration Syntax
C#
public string VaryByUser { get; set; }
Value
The vary by user.


RenderingReference Class

RenderingReference Class
Namespaces ► Sitecore.Layouts ► RenderingReference
Represents a reference to a rendering.
Declaration Syntax
C#
public class RenderingReference
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderingReference(XmlNode, Language, Database) | Initializes a new instance of the RenderingReference class.
 | RenderingReference(RenderingItem) | Initializes a new instance of the RenderingReference class.
 | RenderingReference(RenderingDefinition, Language, Database) | Initializes a new instance of the RenderingReference class.
 | RenderingReference(Control) | Initializes a new instance of the RenderingReference class.
 | AddedToPage | Gets or sets a value indicating whether the rendering has been added to a page.
 | AddToFormIfUnused | Gets or sets a value indicating whether the RenderingReference adds the to form if unused.
 | Database | Gets the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FailureReason | Gets the failure reason.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControl()()() | Gets the control.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Language | Gets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Placeholder | Gets the placeholder.
 | RenderingID | Gets the rendering ID.
 | RenderingItem | Gets the rendering item.
 | SetControl(Control) | Sets the control.
 | Settings | Gets the settings.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UniqueId | Gets the unique ID.
Inheritance Hierarchy
Object
RenderingReference


RenderingReference Constructor

RenderingReference Constructor
Namespaces ► Sitecore.Layouts ► RenderingReference ► RenderingReference()()()
Members
Icon | Member | Description
 | RenderingReference(XmlNode, Language, Database) | Initializes a new instance of the RenderingReference class.
 | RenderingReference(RenderingItem) | Initializes a new instance of the RenderingReference class.
 | RenderingReference(RenderingDefinition, Language, Database) | Initializes a new instance of the RenderingReference class.
 | RenderingReference(Control) | Initializes a new instance of the RenderingReference class.


RenderingReference Constructor (renderingItem)

RenderingReference Constructor (renderingItem)
Namespaces ► Sitecore.Layouts ► RenderingReference ► RenderingReference(RenderingItem)
Initializes a new instance of the RenderingReference class.
Declaration Syntax
C#
public RenderingReference(
    RenderingItem renderingItem
)
Parameters
renderingItem (RenderingItem)
The rendering item.


RenderingReference Constructor (renderingDefinition, language, database)

RenderingReference Constructor (renderingDefinition, language, database)
Namespaces ► Sitecore.Layouts ► RenderingReference ► RenderingReference(RenderingDefinition, Language, Database)
Initializes a new instance of the RenderingReference class.
Declaration Syntax
C#
public RenderingReference(
    RenderingDefinition renderingDefinition,
    Language language,
    Database database
)
Parameters
renderingDefinition (RenderingDefinition)
The rendering definition.
language (Language)
The language.
database (Database)
The database.


RenderingReference Constructor (control)

RenderingReference Constructor (control)
Namespaces ► Sitecore.Layouts ► RenderingReference ► RenderingReference(Control)
Initializes a new instance of the RenderingReference class.
Declaration Syntax
C#
public RenderingReference(
    Control control
)
Parameters
control (Control)
The control.


RenderingReference Constructor (configNode, language, database)

RenderingReference Constructor (configNode, language, database)
Namespaces ► Sitecore.Layouts ► RenderingReference ► RenderingReference(XmlNode, Language, Database)
Initializes a new instance of the RenderingReference class.
Declaration Syntax
C#
public RenderingReference(
    XmlNode configNode,
    Language language,
    Database database
)
Parameters
configNode (XmlNode)
The config node.
language (Language)
The language.
database (Database)
The database.


AddedToPage Property

AddedToPage Property
Namespaces ► Sitecore.Layouts ► RenderingReference ► AddedToPage
Gets or sets a value indicating whether the rendering has been added to a page.
Declaration Syntax
C#
public bool AddedToPage { get; set; }
Value
true if [the rendering was added to a page; otherwise, false.


AddToFormIfUnused Property

AddToFormIfUnused Property
Namespaces ► Sitecore.Layouts ► RenderingReference ► AddToFormIfUnused
Gets or sets a value indicating whether the RenderingReference adds the to form if unused.
Declaration Syntax
C#
public bool AddToFormIfUnused { get; set; }
Value
true if the RenderingReference adds the to form if unused; otherwise, false.


Database Property

Database Property
Namespaces ► Sitecore.Layouts ► RenderingReference ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


FailureReason Property

FailureReason Property
Namespaces ► Sitecore.Layouts ► RenderingReference ► FailureReason
Gets the failure reason.
Declaration Syntax
C#
public FailureReason FailureReason { get; }
Value
The failure reason.


GetControl Method

GetControl Method
Namespaces ► Sitecore.Layouts ► RenderingReference ► GetControl()()()
Gets the control.
Declaration Syntax
C#
public Control GetControl()
Return Value


Language Property

Language Property
Namespaces ► Sitecore.Layouts ► RenderingReference ► Language
Gets the language.
Declaration Syntax
C#
public Language Language { get; }
Value
The language.


Placeholder Property

Placeholder Property
Namespaces ► Sitecore.Layouts ► RenderingReference ► Placeholder
Gets the placeholder.
Declaration Syntax
C#
public string Placeholder { get; set; }
Value
The placeholder.


RenderingID Property

RenderingID Property
Namespaces ► Sitecore.Layouts ► RenderingReference ► RenderingID
Gets the rendering ID.
Declaration Syntax
C#
public ID RenderingID { get; }
Value
The rendering ID.


RenderingItem Property

RenderingItem Property
Namespaces ► Sitecore.Layouts ► RenderingReference ► RenderingItem
Gets the rendering item.
Declaration Syntax
C#
public RenderingItem RenderingItem { get; }
Value
The rendering item.


SetControl Method (control)

SetControl Method (control)
Namespaces ► Sitecore.Layouts ► RenderingReference ► SetControl(Control)
Sets the control.
Declaration Syntax
C#
public void SetControl(
    Control control
)
Parameters
control (Control)
The control.


Settings Property

Settings Property
Namespaces ► Sitecore.Layouts ► RenderingReference ► Settings
Gets the settings.
Declaration Syntax
C#
public RenderingSettings Settings { get; }
Value
The settings.


UniqueId Property

UniqueId Property
Namespaces ► Sitecore.Layouts ► RenderingReference ► UniqueId
Gets the unique ID.
Declaration Syntax
C#
public string UniqueId { get; set; }
Value
The unique ID.


RenderingReferenceList Class

RenderingReferenceList Class
Namespaces ► Sitecore.Layouts ► RenderingReferenceList
Represents a list of rendering references
Declaration Syntax
C#
public class RenderingReferenceList : ReadOnlyList<RenderingReference>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderingReferenceList(IEnumerable<(Of <(RenderingReference>)>)) | Initializes a new instance of the RenderingReferenceList class.
 | RenderingReferenceList()()() | Initializes a new instance of the RenderingReferenceList class.
 | Contains(TElement) | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToArray()()() | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ReadOnlyList <(Of <( RenderingReference >)>)
 |  | RenderingReferenceList


RenderingReferenceList Constructor

RenderingReferenceList Constructor
Namespaces ► Sitecore.Layouts ► RenderingReferenceList ► RenderingReferenceList()()()
Members
Icon | Member | Description
 | RenderingReferenceList(IEnumerable<(Of <(RenderingReference>)>)) | Initializes a new instance of the RenderingReferenceList class.
 | RenderingReferenceList()()() | Initializes a new instance of the RenderingReferenceList class.


RenderingReferenceList Constructor

RenderingReferenceList Constructor
Namespaces ► Sitecore.Layouts ► RenderingReferenceList ► RenderingReferenceList()()()
Initializes a new instance of the RenderingReferenceList class.
Declaration Syntax
C#
public RenderingReferenceList()


RenderingReferenceList Constructor (entries)

RenderingReferenceList Constructor (entries)
Namespaces ► Sitecore.Layouts ► RenderingReferenceList ► RenderingReferenceList(IEnumerable<(Of <(RenderingReference>)>))
Initializes a new instance of the RenderingReferenceList class.
Declaration Syntax
C#
public RenderingReferenceList(
    IEnumerable<RenderingReference> entries
)
Parameters
entries (IEnumerable<(Of <( RenderingReference >)>))
The entries.


RenderingSettings Class

RenderingSettings Class
Namespaces ► Sitecore.Layouts ► RenderingSettings
Represents a set of rendering settings.
Declaration Syntax
C#
public class RenderingSettings
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderingSettings()()() | Initializes a new instance of the RenderingSettings class
 | Caching | Gets or sets the caching information.
 | Conditions | Gets or sets the m_conditions.
 | DataSource | Gets or sets the data source.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultiVariateTest | Gets or sets the multi variate test.
 | Parameters | Gets or sets the parameters.
 | Placeholder | Gets or sets the placeholder.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RenderingSettings


RenderingSettings Constructor

RenderingSettings Constructor
Namespaces ► Sitecore.Layouts ► RenderingSettings ► RenderingSettings()()()
Initializes a new instance of the RenderingSettings class
Declaration Syntax
C#
public RenderingSettings()


Caching Property

Caching Property
Namespaces ► Sitecore.Layouts ► RenderingSettings ► Caching
Gets or sets the caching information.
Declaration Syntax
C#
public RenderingCaching Caching { get; set; }
Value
The caching information.


Conditions Property

Conditions Property
Namespaces ► Sitecore.Layouts ► RenderingSettings ► Conditions
Gets or sets the m_conditions.
Declaration Syntax
C#
public string Conditions { get; set; }
Value
The m_conditions.


DataSource Property

DataSource Property
Namespaces ► Sitecore.Layouts ► RenderingSettings ► DataSource
Gets or sets the data source.
Declaration Syntax
C#
public string DataSource { get; set; }
Value
The data source.


MultiVariateTest Property

MultiVariateTest Property
Namespaces ► Sitecore.Layouts ► RenderingSettings ► MultiVariateTest
Gets or sets the multi variate test.
Declaration Syntax
C#
public string MultiVariateTest { get; set; }
Value
The multi variate test.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Layouts ► RenderingSettings ► Parameters
Gets or sets the parameters.
Declaration Syntax
C#
public string Parameters { get; set; }
Value
The parameters.


Placeholder Property

Placeholder Property
Namespaces ► Sitecore.Layouts ► RenderingSettings ► Placeholder
Gets or sets the placeholder.
Declaration Syntax
C#
public string Placeholder { get; set; }
Value
The placeholder.


RuntimeHtml Class

RuntimeHtml Class
Namespaces ► Sitecore.Layouts ► RuntimeHtml
Converts HTML from runtime to designtime and back.
Declaration Syntax
C#
public static class RuntimeHtml
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Convert(String) | Converts to runtime.
 | Convert(String, Boolean) | Converts to runtime.
 | FixBullets(HtmlDocument) | Fixes the bullets.
 | FixSelectOptions(HtmlDocument) | Fixes the select options.
 | Parse(String, String%, String%, String%) | Parses the specified HTML.
Inheritance Hierarchy
Object
RuntimeHtml


Convert Method

Convert Method
Namespaces ► Sitecore.Layouts ► RuntimeHtml ► Convert()()()
Members
Icon | Member | Description
 | Convert(String) | Converts to runtime.
 | Convert(String, Boolean) | Converts to runtime.


Convert Method (body)

Convert Method (body)
Namespaces ► Sitecore.Layouts ► RuntimeHtml ► Convert(String)
Converts to runtime.
Declaration Syntax
C#
public static string Convert(
    string body
)
Parameters
body (String)
The body.
Return Value
The runtime html.


Convert Method (body, convertWebControls)

Convert Method (body, convertWebControls)
Namespaces ► Sitecore.Layouts ► RuntimeHtml ► Convert(String, Boolean)
Converts to runtime.
Declaration Syntax
C#
public static string Convert(
    string body,
    bool convertWebControls
)
Parameters
body (String)
The body.
convertWebControls (Boolean)
if set to true this instance is convert web controls.
Return Value
The runtime html.


FixBullets Method (document)

FixBullets Method (document)
Namespaces ► Sitecore.Layouts ► RuntimeHtml ► FixBullets(HtmlDocument)
Fixes the bullets.
Declaration Syntax
C#
public static void FixBullets(
    HtmlDocument document
)
Parameters
document (HtmlDocument)
The document.


FixSelectOptions Method (document)

FixSelectOptions Method (document)
Namespaces ► Sitecore.Layouts ► RuntimeHtml ► FixSelectOptions(HtmlDocument)
Fixes the select options.
Declaration Syntax
C#
public static void FixSelectOptions(
    HtmlDocument document
)
Parameters
document (HtmlDocument)
The document.


Parse Method (html, header, body, footer)

Parse Method (html, header, body, footer)
Namespaces ► Sitecore.Layouts ► RuntimeHtml ► Parse(String, String%, String%, String%)
Parses the specified HTML.
Declaration Syntax
C#
public static void Parse(
    string html,
    out string header,
    out string body,
    out string footer
)
Parameters
html (String)
The HTML.
header ( String %)
The header.
body ( String %)
The body.
footer ( String %)
The footer.


XHtml Class

XHtml Class
Namespaces ► Sitecore.Layouts ► XHtml
Represents a XHtml.
Declaration Syntax
C#
public static class XHtml
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Convert(String) | Converts to XHtml.
 | ConvertToXml(String) | Converts to XML.
 | Format(String) | Formats the specified HTML.
 | Format(HtmlDocument) | Formats the specified HTML document.
 | GetBody(String) | Gets the body.
 | GetHtml(HtmlDocument) | Gets the HTML.
 | LoadHtmlDocument(String) | Loads the HTML document.
 | LoadHtmlDocument(String, Boolean) | Loads the HTML document.
 | MakeDocument(String) | Makes the XHTML document.
 | PrepareHtml(String) | Prepares the HTML.
 | Validate(String) | Validates the specified XHTML.
Inheritance Hierarchy
Object
XHtml


Convert Method (body)

Convert Method (body)
Namespaces ► Sitecore.Layouts ► XHtml ► Convert(String)
Converts to XHtml.
Declaration Syntax
C#
public static string Convert(
    string body
)
Parameters
body (String)
The body.
Return Value
The convert body.


ConvertToXml Method (body)

ConvertToXml Method (body)
Namespaces ► Sitecore.Layouts ► XHtml ► ConvertToXml(String)
Converts to XML.
Declaration Syntax
C#
public static string ConvertToXml(
    string body
)
Parameters
body (String)
The body.
Return Value
the body in Xml format.


Format Method

Format Method
Namespaces ► Sitecore.Layouts ► XHtml ► Format()()()
Members
Icon | Member | Description
 | Format(String) | Formats the specified HTML.
 | Format(HtmlDocument) | Formats the specified HTML document.


Format Method (htmlDocument)

Format Method (htmlDocument)
Namespaces ► Sitecore.Layouts ► XHtml ► Format(HtmlDocument)
Formats the specified HTML document.
Declaration Syntax
C#
public static string Format(
    HtmlDocument htmlDocument
)
Parameters
htmlDocument (HtmlDocument)
The HTML document.
Return Value


Format Method (html)

Format Method (html)
Namespaces ► Sitecore.Layouts ► XHtml ► Format(String)
Formats the specified HTML.
Declaration Syntax
C#
public static string Format(
    string html
)
Parameters
html (String)
The HTML.
Return Value
The formatted HTML.
Exceptions
Exception | Condition
XmlException | The Html is valid valid Xml.
ArgumentNullException |


GetBody Method (html)

GetBody Method (html)
Namespaces ► Sitecore.Layouts ► XHtml ► GetBody(String)
Gets the body.
Declaration Syntax
C#
public static string GetBody(
    string html
)
Parameters
html (String)
The HTML.
Return Value
The body


GetHtml Method (htmlDocument)

GetHtml Method (htmlDocument)
Namespaces ► Sitecore.Layouts ► XHtml ► GetHtml(HtmlDocument)
Gets the HTML.
Declaration Syntax
C#
public static string GetHtml(
    HtmlDocument htmlDocument
)
Parameters
htmlDocument (HtmlDocument)
The HTML document.
Return Value
The HTML.


LoadHtmlDocument Method

LoadHtmlDocument Method
Namespaces ► Sitecore.Layouts ► XHtml ► LoadHtmlDocument()()()
Members
Icon | Member | Description
 | LoadHtmlDocument(String) | Loads the HTML document.
 | LoadHtmlDocument(String, Boolean) | Loads the HTML document.


LoadHtmlDocument Method (html)

LoadHtmlDocument Method (html)
Namespaces ► Sitecore.Layouts ► XHtml ► LoadHtmlDocument(String)
Loads the HTML document.
Declaration Syntax
C#
public static HtmlDocument LoadHtmlDocument(
    string html
)
Parameters
html (String)
The HTML.
Return Value
The HTML document.


LoadHtmlDocument Method (html, isXml)

LoadHtmlDocument Method (html, isXml)
Namespaces ► Sitecore.Layouts ► XHtml ► LoadHtmlDocument(String, Boolean)
Loads the HTML document.
Declaration Syntax
C#
public static HtmlDocument LoadHtmlDocument(
    string html,
    bool isXml
)
Parameters
html (String)
The HTML.
isXml (Boolean)
if set to true [is XML].
Return Value
The HTML document.


MakeDocument Method (body)

MakeDocument Method (body)
Namespaces ► Sitecore.Layouts ► XHtml ► MakeDocument(String)
Makes the XHTML document.
Declaration Syntax
C#
public static string MakeDocument(
    string body
)
Parameters
body (String)
The body.
Return Value
The XHTML document.


PrepareHtml Method (html)

PrepareHtml Method (html)
Namespaces ► Sitecore.Layouts ► XHtml ► PrepareHtml(String)
Prepares the HTML.
Declaration Syntax
C#
public static string PrepareHtml(
    string html
)
Parameters
html (String)
The HTML.
Return Value
The HTML.
Exceptions
Exception | Condition
ArgumentNullException |


Validate Method (xhtml)

Validate Method (xhtml)
Namespaces ► Sitecore.Layouts ► XHtml ► Validate(String)
Validates the specified XHTML.
Declaration Syntax
C#
public static Collection<XHtmlValidatorError> Validate(
    string xhtml
)
Parameters
xhtml (String)
The XHTML.


XHtmlValidator Class

XHtmlValidator Class
Namespaces ► Sitecore.Layouts ► XHtmlValidator
Declaration Syntax
C#
public class XHtmlValidator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XHtmlValidator(String) | XHTMLs the validator.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReportWarnings | Gets or sets a value indicating whether the XHtmlValidator reports the warnings.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Validate()()() | Validates this instance.
Inheritance Hierarchy
Object
XHtmlValidator


XHtmlValidator Constructor (document)

XHtmlValidator Constructor (document)
Namespaces ► Sitecore.Layouts ► XHtmlValidator ► XHtmlValidator(String)
XHTMLs the validator.
Declaration Syntax
C#
public XHtmlValidator(
    string document
)
Parameters
document (String)
The input.


ReportWarnings Property

ReportWarnings Property
Namespaces ► Sitecore.Layouts ► XHtmlValidator ► ReportWarnings
Gets or sets a value indicating whether the XHtmlValidator reports the warnings.
Declaration Syntax
C#
public bool ReportWarnings { get; set; }
Value
true if the XHtmlValidator reports the warnings; otherwise, false.


Validate Method

Validate Method
Namespaces ► Sitecore.Layouts ► XHtmlValidator ► Validate()()()
Validates this instance.
Declaration Syntax
C#
public Collection<XHtmlValidatorError> Validate()
Return Value
The validate.


XHtmlValidatorError Class

XHtmlValidatorError Class
Namespaces ► Sitecore.Layouts ► XHtmlValidatorError
Declaration Syntax
C#
public class XHtmlValidatorError
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XHtmlValidatorError(ValidationEventArgs) | Initializes a new instance of the XHtmlValidatorError class.
 | XHtmlValidatorError(XmlException) | Initializes a new instance of the XHtmlValidatorError class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LineNumber | Gets the line number.
 | LinePosition | Gets the line position.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message.
 | Severity | Gets the severity.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
XHtmlValidatorError


XHtmlValidatorError Constructor

XHtmlValidatorError Constructor
Namespaces ► Sitecore.Layouts ► XHtmlValidatorError ► XHtmlValidatorError()()()
Members
Icon | Member | Description
 | XHtmlValidatorError(ValidationEventArgs) | Initializes a new instance of the XHtmlValidatorError class.
 | XHtmlValidatorError(XmlException) | Initializes a new instance of the XHtmlValidatorError class.


XHtmlValidatorError Constructor (args)

XHtmlValidatorError Constructor (args)
Namespaces ► Sitecore.Layouts ► XHtmlValidatorError ► XHtmlValidatorError(ValidationEventArgs)
Initializes a new instance of the XHtmlValidatorError class.
Declaration Syntax
C#
public XHtmlValidatorError(
    ValidationEventArgs args
)
Parameters
args (ValidationEventArgs)
The arguments.


XHtmlValidatorError Constructor (exception)

XHtmlValidatorError Constructor (exception)
Namespaces ► Sitecore.Layouts ► XHtmlValidatorError ► XHtmlValidatorError(XmlException)
Initializes a new instance of the XHtmlValidatorError class.
Declaration Syntax
C#
public XHtmlValidatorError(
    XmlException exception
)
Parameters
exception (XmlException)
The XML exc.


LineNumber Property

LineNumber Property
Namespaces ► Sitecore.Layouts ► XHtmlValidatorError ► LineNumber
Gets the line number.
Declaration Syntax
C#
public int LineNumber { get; }
Value
The line number.


LinePosition Property

LinePosition Property
Namespaces ► Sitecore.Layouts ► XHtmlValidatorError ► LinePosition
Gets the line position.
Declaration Syntax
C#
public int LinePosition { get; }
Value
The line position.


Message Property

Message Property
Namespaces ► Sitecore.Layouts ► XHtmlValidatorError ► Message
Gets the message.
Declaration Syntax
C#
public string Message { get; }
Value
The message.


Severity Property

Severity Property
Namespaces ► Sitecore.Layouts ► XHtmlValidatorError ► Severity
Gets the severity.
Declaration Syntax
C#
public XmlSeverityType Severity { get; }
Value
The severity.


ToString Method

ToString Method
Namespaces ► Sitecore.Layouts ► XHtmlValidatorError ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Sitecore.Layouts.PageExtenders Namespace

Sitecore.Layouts.PageExtenders Namespace
Namespaces ► Sitecore.Layouts.PageExtenders
Declaration Syntax
C#
namespace Sitecore.Layouts.PageExtenders
Types
All Types Classes
Icon | Type | Description
 | DebuggerPageExtender | The page debugger.
 | PageExtender | Defines the basic properties and functionality of a page extender.
 | PreviewPageExtender | Preview page extender.
 | WebEditPageExtender | WebEdit page extender.


DebuggerPageExtender Class

DebuggerPageExtender Class
Namespaces ► Sitecore.Layouts.PageExtenders ► DebuggerPageExtender
The page debugger.
Declaration Syntax
C#
public class DebuggerPageExtender : PageExtender
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DebuggerPageExtender()()() | Initializes a new instance of the DebuggerPageExtender class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Insert()()() | Inserts the page extender into the page. (Overrides PageExtender.Insert()()().)
 | InsertControl(Control) | Inserts the control. (Inherited from PageExtender.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PageExtender
 |  | DebuggerPageExtender


DebuggerPageExtender Constructor

DebuggerPageExtender Constructor
Namespaces ► Sitecore.Layouts.PageExtenders ► DebuggerPageExtender ► DebuggerPageExtender()()()
Initializes a new instance of the DebuggerPageExtender class
Declaration Syntax
C#
public DebuggerPageExtender()


Insert Method

Insert Method
Namespaces ► Sitecore.Layouts.PageExtenders ► DebuggerPageExtender ► Insert()()()
Inserts the page extender into the page.
Declaration Syntax
C#
public override void Insert()


PageExtender Class

PageExtender Class
Namespaces ► Sitecore.Layouts.PageExtenders ► PageExtender
Defines the basic properties and functionality of a page extender.
Declaration Syntax
C#
public abstract class PageExtender
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PageExtender()()() | Initializes a new instance of the PageExtender class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Insert()()() | Inserts the page extender into the page.
 | InsertControl(Control) | Inserts the control.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PageExtender
 |  | DebuggerPageExtender
 |  | PreviewPageExtender
 |  | WebEditPageExtender


PageExtender Constructor

PageExtender Constructor
Namespaces ► Sitecore.Layouts.PageExtenders ► PageExtender ► PageExtender()()()
Initializes a new instance of the PageExtender class
Declaration Syntax
C#
protected PageExtender()


Insert Method

Insert Method
Namespaces ► Sitecore.Layouts.PageExtenders ► PageExtender ► Insert()()()
Inserts the page extender into the page.
Declaration Syntax
C#
public abstract void Insert()


InsertControl Method (control)

InsertControl Method (control)
Namespaces ► Sitecore.Layouts.PageExtenders ► PageExtender ► InsertControl(Control)
Inserts the control.
Declaration Syntax
C#
protected void InsertControl(
    Control control
)
Parameters
control (Control)
The control.


PreviewPageExtender Class

PreviewPageExtender Class
Namespaces ► Sitecore.Layouts.PageExtenders ► PreviewPageExtender
Preview page extender.
Declaration Syntax
C#
public class PreviewPageExtender : PageExtender
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PreviewPageExtender()()() | Initializes a new instance of the PreviewPageExtender class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Insert()()() | Inserts the page extender into the page. (Overrides PageExtender.Insert()()().)
 | InsertControl(Control) | Inserts the control. (Inherited from PageExtender.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PageExtender
 |  | PreviewPageExtender


PreviewPageExtender Constructor

PreviewPageExtender Constructor
Namespaces ► Sitecore.Layouts.PageExtenders ► PreviewPageExtender ► PreviewPageExtender()()()
Initializes a new instance of the PreviewPageExtender class
Declaration Syntax
C#
public PreviewPageExtender()


Insert Method

Insert Method
Namespaces ► Sitecore.Layouts.PageExtenders ► PreviewPageExtender ► Insert()()()
Inserts the page extender into the page.
Declaration Syntax
C#
public override void Insert()


WebEditPageExtender Class

WebEditPageExtender Class
Namespaces ► Sitecore.Layouts.PageExtenders ► WebEditPageExtender
WebEdit page extender.
Declaration Syntax
C#
public class WebEditPageExtender : PageExtender
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WebEditPageExtender()()() | Initializes a new instance of the WebEditPageExtender class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Insert()()() | Inserts the page extender into the page. (Overrides PageExtender.Insert()()().)
 | InsertControl(Control) | Inserts the control. (Inherited from PageExtender.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PageExtender
 |  | WebEditPageExtender


WebEditPageExtender Constructor

WebEditPageExtender Constructor
Namespaces ► Sitecore.Layouts.PageExtenders ► WebEditPageExtender ► WebEditPageExtender()()()
Initializes a new instance of the WebEditPageExtender class
Declaration Syntax
C#
public WebEditPageExtender()


Insert Method

Insert Method
Namespaces ► Sitecore.Layouts.PageExtenders ► WebEditPageExtender ► Insert()()()
Inserts the page extender into the page.
Declaration Syntax
C#
public override void Insert()


Sitecore.layouts.testing Namespace

Sitecore.layouts.testing Namespace
Namespaces ► Sitecore.layouts.testing
Declaration Syntax
C#
namespace Sitecore.layouts.testing
Types
All Types Classes
Icon | Type | Description
 | test | test class.


test Class

test Class
Namespaces ► Sitecore.layouts.testing ► test
test class.
Declaration Syntax
C#
public class test : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | test()()() | Initializes a new instance of the test class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | AccountTest()()() | Accounts the test.
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | ArchiveTest()()() | Tests this instance.
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 | form1 control.
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | goButton | goButton control.
 | goButtonClick(Object, EventArgs) | Goes the button click.
 | goButtonClick2(Object, EventArgs) | Goes the button click.
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | old_goButtonClick(Object, EventArgs) | Goes the button click.
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | TestLinkParser()()() | Tests the link parser.
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Remarks
Auto-generated class.
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | test

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


test Constructor

test Constructor
Namespaces ► Sitecore.layouts.testing ► test ► test()()()
Initializes a new instance of the test class
Declaration Syntax
C#
public test()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AccountTest Method

AccountTest Method
Namespaces ► Sitecore.layouts.testing ► test ► AccountTest()()()
Accounts the test.
Declaration Syntax
C#
protected void AccountTest()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ArchiveTest Method

ArchiveTest Method
Namespaces ► Sitecore.layouts.testing ► test ► ArchiveTest()()()
Tests this instance.
Declaration Syntax
C#
protected void ArchiveTest()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


form1 Field

form1 Field
Namespaces ► Sitecore.layouts.testing ► test ► form1
form1 control.
Declaration Syntax
C#
protected HtmlForm form1
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


goButton Field

goButton Field
Namespaces ► Sitecore.layouts.testing ► test ► goButton
goButton control.
Declaration Syntax
C#
protected Button goButton
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


goButtonClick Method (sender, e)

goButtonClick Method (sender, e)
Namespaces ► Sitecore.layouts.testing ► test ► goButtonClick(Object, EventArgs)
Goes the button click.
Declaration Syntax
C#
protected void goButtonClick(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The sender.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


goButtonClick2 Method (sender, e)

goButtonClick2 Method (sender, e)
Namespaces ► Sitecore.layouts.testing ► test ► goButtonClick2(Object, EventArgs)
Goes the button click.
Declaration Syntax
C#
protected void goButtonClick2(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The sender.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


old_goButtonClick Method (sender, e)

old_goButtonClick Method (sender, e)
Namespaces ► Sitecore.layouts.testing ► test ► old_goButtonClick(Object, EventArgs)
Goes the button click.
Declaration Syntax
C#
protected void old_goButtonClick(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The sender.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TestLinkParser Method

TestLinkParser Method
Namespaces ► Sitecore.layouts.testing ► test ► TestLinkParser()()()
Tests the link parser.
Declaration Syntax
C#
protected void TestLinkParser()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Links Namespace

Sitecore.Links Namespace
Namespaces ► Sitecore.Links
Declaration Syntax
C#
namespace Sitecore.Links
Types
All Types Classes Enumerations
Icon | Type | Description
 | DynamicLink | DynamicLink
 | ItemEventHandler | Represents an item event handler.
 | ItemLink | Represents a item link.
 | ItemLinks | Represents the item links.
 | ItemLinkState | Represents the state of an item link.
 | LanguageEmbedding | Language embedding options
 | LanguageLocation | LanguageLocation enumeration
 | LinkProvider..::.LinkBuilder | LinkBuilder
 | LinkDatabase | Defines that basic methods and properties of a link database.
 | LinkDatabaseHelper | Represents a LinkDatabaseHelper.
 | LinkDatabaseProxy | Represents a link database proxy.
 | LinkDisabler | EventDisabler class
 | LinkDisablerState |
 | LinkManager | LinkManager
 | LinkProvider..::.LinkParser | LinkParser
 | LinkProvider | LinkProvider class LinkProvider LinkProvider
 | LinkProviderCollection | LinkProviderCollection class
 | LinksValidationResult | Represents a Links Validation Result.
 | LinkUpdaterJob |
 | LinkUrlOptions | Contains options for generating an Url from an item that is linked to.
 | SqlLinkDatabase | SqlLinkDatabase class
 | UrlOptions | UrlOptions


DynamicLink Class

DynamicLink Class
Namespaces ► Sitecore.Links ► DynamicLink
DynamicLink
Declaration Syntax
C#
public class DynamicLink
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DynamicLink()()() | Initializes a new instance of the DynamicLink class
 | BuildItemUrl(UrlOptions) | Builds the item URL.
 | BuildMediaUrl(UrlOptions) | Builds the media URL.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExpandLinks(String) | Expands the links.
 | ExpandLinks(String, Boolean) | Expands the links.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUrl(UrlOptions) | Gets a full URL.
 | Initialize(String) | Initializes this instance.
 | IsMediaLink()()() | Determines whether the item being pointed to is a media item.
 | ITEM_LINK_ID_KEY |
 | ITEM_LINK_LANGUAGE_KEY |
 | ITEM_LINK_SITE_KEY |
 | ITEM_LINK_TERMINATOR_KEY |
 | ITEM_LINK_TYPE_KEY |
 | ItemId | Gets the item id.
 | Language | Gets the language.
 | LinkText | Gets the link text.
 | LinkType | Gets the type of the link.
 | MEDIA_LINK_DATABASE_KEY |
 | MEDIA_LINK_LANGUAGE_KEY |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets the parameters.
 | Parse(String) | Parses the link.
 | ParseLinkText(String) | Parses the link text.
 | Site | Gets the site.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryParse(String, DynamicLink%) | Tries the parse.
Inheritance Hierarchy
Object
DynamicLink


DynamicLink Constructor

DynamicLink Constructor
Namespaces ► Sitecore.Links ► DynamicLink ► DynamicLink()()()
Initializes a new instance of the DynamicLink class
Declaration Syntax
C#
public DynamicLink()


BuildItemUrl Method (options)

BuildItemUrl Method (options)
Namespaces ► Sitecore.Links ► DynamicLink ► BuildItemUrl(UrlOptions)
Builds the item URL.
Declaration Syntax
C#
protected virtual string BuildItemUrl(
    UrlOptions options
)
Parameters
options (UrlOptions)
Return Value


BuildMediaUrl Method (options)

BuildMediaUrl Method (options)
Namespaces ► Sitecore.Links ► DynamicLink ► BuildMediaUrl(UrlOptions)
Builds the media URL.
Declaration Syntax
C#
protected virtual string BuildMediaUrl(
    UrlOptions options
)
Parameters
options (UrlOptions)
Return Value


ExpandLinks Method

ExpandLinks Method
Namespaces ► Sitecore.Links ► DynamicLink ► ExpandLinks()()()
Members
Icon | Member | Description
 | ExpandLinks(String) | Expands the links.
 | ExpandLinks(String, Boolean) | Expands the links.


ExpandLinks Method (text)

ExpandLinks Method (text)
Namespaces ► Sitecore.Links ► DynamicLink ► ExpandLinks(String)
Expands the links.
Declaration Syntax
C#
public static string ExpandLinks(
    string text
)
Parameters
text (String)
The text.
Return Value


ExpandLinks Method (text, resolveSites)

ExpandLinks Method (text, resolveSites)
Namespaces ► Sitecore.Links ► DynamicLink ► ExpandLinks(String, Boolean)
Expands the links.
Declaration Syntax
C#
public static string ExpandLinks(
    string text,
    bool resolveSites
)
Parameters
text (String)
The text.
resolveSites (Boolean)
Set this to true to resolve site information when expanding dynamic links.
Return Value


GetUrl Method (options)

GetUrl Method (options)
Namespaces ► Sitecore.Links ► DynamicLink ► GetUrl(UrlOptions)
Gets a full URL.
Declaration Syntax
C#
public virtual string GetUrl(
    UrlOptions options
)
Parameters
options (UrlOptions)
Return Value


Initialize Method (linkText)

Initialize Method (linkText)
Namespaces ► Sitecore.Links ► DynamicLink ► Initialize(String)
Initializes this instance.
Declaration Syntax
C#
public virtual void Initialize(
    string linkText
)
Parameters
linkText (String)
The link text.


IsMediaLink Method

IsMediaLink Method
Namespaces ► Sitecore.Links ► DynamicLink ► IsMediaLink()()()
Determines whether the item being pointed to is a media item.
Declaration Syntax
C#
public virtual bool IsMediaLink()
Return Value
true if it is a media item; otherwise, false.


ITEM_LINK_ID_KEY Field

ITEM_LINK_ID_KEY Field
Namespaces ► Sitecore.Links ► DynamicLink ► ITEM_LINK_ID_KEY
Declaration Syntax
C#
public const string ITEM_LINK_ID_KEY


ITEM_LINK_LANGUAGE_KEY Field

ITEM_LINK_LANGUAGE_KEY Field
Namespaces ► Sitecore.Links ► DynamicLink ► ITEM_LINK_LANGUAGE_KEY
Declaration Syntax
C#
public const string ITEM_LINK_LANGUAGE_KEY


ITEM_LINK_SITE_KEY Field

ITEM_LINK_SITE_KEY Field
Namespaces ► Sitecore.Links ► DynamicLink ► ITEM_LINK_SITE_KEY
Declaration Syntax
C#
public const string ITEM_LINK_SITE_KEY


ITEM_LINK_TERMINATOR_KEY Field

ITEM_LINK_TERMINATOR_KEY Field
Namespaces ► Sitecore.Links ► DynamicLink ► ITEM_LINK_TERMINATOR_KEY
Declaration Syntax
C#
public const string ITEM_LINK_TERMINATOR_KEY


ITEM_LINK_TYPE_KEY Field

ITEM_LINK_TYPE_KEY Field
Namespaces ► Sitecore.Links ► DynamicLink ► ITEM_LINK_TYPE_KEY
Declaration Syntax
C#
public const string ITEM_LINK_TYPE_KEY


ItemId Property

ItemId Property
Namespaces ► Sitecore.Links ► DynamicLink ► ItemId
Gets the item id.
Declaration Syntax
C#
public virtual ID ItemId { get; protected set; }
Value
The item id.


Language Property

Language Property
Namespaces ► Sitecore.Links ► DynamicLink ► Language
Gets the language.
Declaration Syntax
C#
public virtual Language Language { get; protected set; }
Value
The language.


LinkText Property

LinkText Property
Namespaces ► Sitecore.Links ► DynamicLink ► LinkText
Gets the link text.
Declaration Syntax
C#
public virtual string LinkText { get; protected set; }
Value
The link text.


LinkType Property

LinkType Property
Namespaces ► Sitecore.Links ► DynamicLink ► LinkType
Gets the type of the link.
Declaration Syntax
C#
public virtual string LinkType { get; protected set; }
Value
The type of the link.


MEDIA_LINK_DATABASE_KEY Field

MEDIA_LINK_DATABASE_KEY Field
Namespaces ► Sitecore.Links ► DynamicLink ► MEDIA_LINK_DATABASE_KEY
Declaration Syntax
C#
public const string MEDIA_LINK_DATABASE_KEY


MEDIA_LINK_LANGUAGE_KEY Field

MEDIA_LINK_LANGUAGE_KEY Field
Namespaces ► Sitecore.Links ► DynamicLink ► MEDIA_LINK_LANGUAGE_KEY
Declaration Syntax
C#
public const string MEDIA_LINK_LANGUAGE_KEY


Parameters Property

Parameters Property
Namespaces ► Sitecore.Links ► DynamicLink ► Parameters
Gets the parameters.
Declaration Syntax
C#
public virtual SafeDictionary<string> Parameters { get; }
Value
The parameters.


Parse Method (linkText)

Parse Method (linkText)
Namespaces ► Sitecore.Links ► DynamicLink ► Parse(String)
Parses the link.
Declaration Syntax
C#
public static DynamicLink Parse(
    string linkText
)
Parameters
linkText (String)
The link text.
Return Value


ParseLinkText Method (linkText)

ParseLinkText Method (linkText)
Namespaces ► Sitecore.Links ► DynamicLink ► ParseLinkText(String)
Parses the link text.
Declaration Syntax
C#
protected virtual void ParseLinkText(
    string linkText
)
Parameters
linkText (String)
The link text.
Return Value


Site Property

Site Property
Namespaces ► Sitecore.Links ► DynamicLink ► Site
Gets the site.
Declaration Syntax
C#
public virtual SiteContext Site { get; protected set; }
Value
The site.


TryParse Method (linkText, result)

TryParse Method (linkText, result)
Namespaces ► Sitecore.Links ► DynamicLink ► TryParse(String, DynamicLink%)
Tries the parse.
Declaration Syntax
C#
public static bool TryParse(
    string linkText,
    out DynamicLink result
)
Parameters
linkText (String)
The link text.
result ( DynamicLink %)
The result.
Return Value


ItemEventHandler Class

ItemEventHandler Class
Namespaces ► Sitecore.Links ► ItemEventHandler
Represents an item event handler.
Declaration Syntax
C#
public class ItemEventHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemEventHandler()()() | Initializes a new instance of the ItemEventHandler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnItemDeleted(Object, EventArgs) | Called when the item has been deleted.
 | OnItemSaved(Object, EventArgs) | Called when the item has saved.
 | OnVersionRemoved(Object, EventArgs) | Called when the version has been removed.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemEventHandler


ItemEventHandler Constructor

ItemEventHandler Constructor
Namespaces ► Sitecore.Links ► ItemEventHandler ► ItemEventHandler()()()
Initializes a new instance of the ItemEventHandler class
Declaration Syntax
C#
public ItemEventHandler()


OnItemDeleted Method (sender, args)

OnItemDeleted Method (sender, args)
Namespaces ► Sitecore.Links ► ItemEventHandler ► OnItemDeleted(Object, EventArgs)
Called when the item has been deleted.
Declaration Syntax
C#
protected void OnItemDeleted(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


OnItemSaved Method (sender, args)

OnItemSaved Method (sender, args)
Namespaces ► Sitecore.Links ► ItemEventHandler ► OnItemSaved(Object, EventArgs)
Called when the item has saved.
Declaration Syntax
C#
protected void OnItemSaved(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


OnVersionRemoved Method (sender, args)

OnVersionRemoved Method (sender, args)
Namespaces ► Sitecore.Links ► ItemEventHandler ► OnVersionRemoved(Object, EventArgs)
Called when the version has been removed.
Declaration Syntax
C#
protected void OnVersionRemoved(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


ItemLink Class

ItemLink Class
Namespaces ► Sitecore.Links ► ItemLink
Represents a item link.
Declaration Syntax
C#
public class ItemLink
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemLink(String, ID, ID, String, ID, String) | Initializes a new instance of the ItemLink class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSourceItem()()() | Gets the source item.
 | GetTargetItem()()() | Gets the target item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SourceDatabaseName | Gets the name of the source database.
 | SourceFieldID | Gets the source field ID.
 | SourceItemID | Gets the source item ID.
 | TargetDatabaseName | Gets the name of the target database.
 | TargetItemID | Gets the target item ID.
 | TargetPath | Gets the target path.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemLink


ItemLink Constructor (sourceDatabase, sourceItemID, sourceFieldID, targetDatabase, targetItemID, targetPath)

ItemLink Constructor (sourceDatabase, sourceItemID, sourceFieldID, targetDatabase, targetItemID, targetPath)
Namespaces ► Sitecore.Links ► ItemLink ► ItemLink(String, ID, ID, String, ID, String)
Initializes a new instance of the ItemLink class.
Declaration Syntax
C#
public ItemLink(
    string sourceDatabase,
    ID sourceItemID,
    ID sourceFieldID,
    string targetDatabase,
    ID targetItemID,
    string targetPath
)
Parameters
sourceDatabase (String)
The source database.
sourceItemID (ID)
The source item ID.
sourceFieldID (ID)
The source field ID.
targetDatabase (String)
The target database.
targetItemID (ID)
The target item ID.
targetPath (String)
The target path.


GetSourceItem Method

GetSourceItem Method
Namespaces ► Sitecore.Links ► ItemLink ► GetSourceItem()()()
Gets the source item.
Declaration Syntax
C#
public Item GetSourceItem()
Return Value
The source item.


GetTargetItem Method

GetTargetItem Method
Namespaces ► Sitecore.Links ► ItemLink ► GetTargetItem()()()
Gets the target item.
Declaration Syntax
C#
public Item GetTargetItem()
Return Value
The target item.


SourceDatabaseName Property

SourceDatabaseName Property
Namespaces ► Sitecore.Links ► ItemLink ► SourceDatabaseName
Gets the name of the source database.
Declaration Syntax
C#
public string SourceDatabaseName { get; }
Value
The name of the source database.


SourceFieldID Property

SourceFieldID Property
Namespaces ► Sitecore.Links ► ItemLink ► SourceFieldID
Gets the source field ID.
Declaration Syntax
C#
public ID SourceFieldID { get; }
Value
The source field ID.


SourceItemID Property

SourceItemID Property
Namespaces ► Sitecore.Links ► ItemLink ► SourceItemID
Gets the source item ID.
Declaration Syntax
C#
public ID SourceItemID { get; }
Value
The source item ID.


TargetDatabaseName Property

TargetDatabaseName Property
Namespaces ► Sitecore.Links ► ItemLink ► TargetDatabaseName
Gets the name of the target database.
Declaration Syntax
C#
public string TargetDatabaseName { get; }
Value
The name of the target database.


TargetItemID Property

TargetItemID Property
Namespaces ► Sitecore.Links ► ItemLink ► TargetItemID
Gets the target item ID.
Declaration Syntax
C#
public ID TargetItemID { get; }
Value
The target item ID.


TargetPath Property

TargetPath Property
Namespaces ► Sitecore.Links ► ItemLink ► TargetPath
Gets the target path.
Declaration Syntax
C#
public string TargetPath { get; }
Value
The target path.


ItemLinks Class

ItemLinks Class
Namespaces ► Sitecore.Links ► ItemLinks
Represents the item links.
Declaration Syntax
C#
public class ItemLinks
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemLinks(Item) | Initializes a new instance of the ItemLinks class.
 | Database | Gets the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllLinks()()() | Gets all links.
 | GetAllLinks(Boolean) | Gets all links.
 | GetBrokenLinks()()() | Gets the broken links.
 | GetBrokenLinks(Boolean) | Gets the broken links.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValidLinks()()() | Gets the valid links.
 | GetValidLinks(Boolean) | Gets the valid links.
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemLinks


ItemLinks Constructor (ownerItem)

ItemLinks Constructor (ownerItem)
Namespaces ► Sitecore.Links ► ItemLinks ► ItemLinks(Item)
Initializes a new instance of the ItemLinks class.
Declaration Syntax
C#
public ItemLinks(
    Item ownerItem
)
Parameters
ownerItem (Item)
The owner item.


Database Property

Database Property
Namespaces ► Sitecore.Links ► ItemLinks ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


GetAllLinks Method

GetAllLinks Method
Namespaces ► Sitecore.Links ► ItemLinks ► GetAllLinks()()()
Members
Icon | Member | Description
 | GetAllLinks()()() | Gets all links.
 | GetAllLinks(Boolean) | Gets all links.


GetAllLinks Method

GetAllLinks Method
Namespaces ► Sitecore.Links ► ItemLinks ► GetAllLinks()()()
Gets all links.
Declaration Syntax
C#
public ItemLink[] GetAllLinks()
Return Value
The all links.


GetAllLinks Method (allVersions)

GetAllLinks Method (allVersions)
Namespaces ► Sitecore.Links ► ItemLinks ► GetAllLinks(Boolean)
Gets all links.
Declaration Syntax
C#
public ItemLink[] GetAllLinks(
    bool allVersions
)
Parameters
allVersions (Boolean)
Return Value
The array of ItemLink.


GetBrokenLinks Method

GetBrokenLinks Method
Namespaces ► Sitecore.Links ► ItemLinks ► GetBrokenLinks()()()
Members
Icon | Member | Description
 | GetBrokenLinks()()() | Gets the broken links.
 | GetBrokenLinks(Boolean) | Gets the broken links.


GetBrokenLinks Method

GetBrokenLinks Method
Namespaces ► Sitecore.Links ► ItemLinks ► GetBrokenLinks()()()
Gets the broken links.
Declaration Syntax
C#
public ItemLink[] GetBrokenLinks()
Return Value
The array of ItemLink.


GetBrokenLinks Method (allVersions)

GetBrokenLinks Method (allVersions)
Namespaces ► Sitecore.Links ► ItemLinks ► GetBrokenLinks(Boolean)
Gets the broken links.
Declaration Syntax
C#
public ItemLink[] GetBrokenLinks(
    bool allVersions
)
Parameters
allVersions (Boolean)
if set to true this instance is all versions.
Return Value
The broken links.


GetValidLinks Method

GetValidLinks Method
Namespaces ► Sitecore.Links ► ItemLinks ► GetValidLinks()()()
Members
Icon | Member | Description
 | GetValidLinks()()() | Gets the valid links.
 | GetValidLinks(Boolean) | Gets the valid links.


GetValidLinks Method

GetValidLinks Method
Namespaces ► Sitecore.Links ► ItemLinks ► GetValidLinks()()()
Gets the valid links.
Declaration Syntax
C#
public ItemLink[] GetValidLinks()
Return Value
The array of ItemLink.


GetValidLinks Method (allVersions)

GetValidLinks Method (allVersions)
Namespaces ► Sitecore.Links ► ItemLinks ► GetValidLinks(Boolean)
Gets the valid links.
Declaration Syntax
C#
public ItemLink[] GetValidLinks(
    bool allVersions
)
Parameters
allVersions (Boolean)
Return Value
The array of ItemLink.


Item Property

Item Property
Namespaces ► Sitecore.Links ► ItemLinks ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


ItemLinkState Enumeration

ItemLinkState Enumeration
Namespaces ► Sitecore.Links ► ItemLinkState
Represents the state of an item link.
Declaration Syntax
C#
public enum ItemLinkState
Members
Member | Description
Any | Any.
Broken | Broken.
Valid | Valid.


LanguageEmbedding Enumeration

LanguageEmbedding Enumeration
Namespaces ► Sitecore.Links ► LanguageEmbedding
Language embedding options
Declaration Syntax
C#
public enum LanguageEmbedding
Members
Member | Description
AsNeeded | Only embed languages if the linked-to language differs from the context language.
Always | Always embed languages.
Never | Never embed languages.


LanguageLocation Enumeration

LanguageLocation Enumeration
Namespaces ► Sitecore.Links ► LanguageLocation
LanguageLocation enumeration
Declaration Syntax
C#
public enum LanguageLocation
Members
Member | Description
FilePath | Embed the language in the file path of the link/URL.
QueryString | Embed the language in the query string of the link/URL.


LinkDatabase Class

LinkDatabase Class
Namespaces ► Sitecore.Links ► LinkDatabase
Defines that basic methods and properties of a link database.
Declaration Syntax
C#
public abstract class LinkDatabase
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LinkDatabase()()() | Initializes a new instance of the LinkDatabase class
 | Compact(Database) | Compacts the specified database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBrokenLinks(Database) | Gets the broken links.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReferenceCount(Item) | Gets the reference count.
 | GetReferences(Item) | Gets the references.
 | GetRefererCount(Item) | Obsolete. Gets the referrer count.
 | GetReferers(Item) | Obsolete. Gets the referrers.
 | GetReferrerCount(Item) | Gets the referrer count.
 | GetReferrers(Item) | Gets the referrers.
 | GetReferrers(Item, Boolean) | Obsolete. Gets the referrers.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasExternalReferers(Item, Boolean) | Obsolete. Determines whether the specified item has external referrers.
 | HasExternalReferrers(Item, Boolean) | Determines whether the specified item has external referrers.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rebuild(Database) | Rebuilds the specified database.
 | RemoveReferences(Item) | Removes the references.
 | TargetExists(ID, String, Database) | Determines if the target exists.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLinks(Item, array<ItemLink>[]()[]) | Updates the links.
 | UpdateReferences(Item) | Updates the references.
Inheritance Hierarchy
Object
 | LinkDatabase
 |  | SqlLinkDatabase


LinkDatabase Constructor

LinkDatabase Constructor
Namespaces ► Sitecore.Links ► LinkDatabase ► LinkDatabase()()()
Initializes a new instance of the LinkDatabase class
Declaration Syntax
C#
protected LinkDatabase()


Compact Method (database)

Compact Method (database)
Namespaces ► Sitecore.Links ► LinkDatabase ► Compact(Database)
Compacts the specified database.
Declaration Syntax
C#
public abstract void Compact(
    Database database
)
Parameters
database (Database)
The database.


GetBrokenLinks Method (database)

GetBrokenLinks Method (database)
Namespaces ► Sitecore.Links ► LinkDatabase ► GetBrokenLinks(Database)
Gets the broken links.
Declaration Syntax
C#
public abstract ItemLink[] GetBrokenLinks(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The broken links.


GetReferenceCount Method (item)

GetReferenceCount Method (item)
Namespaces ► Sitecore.Links ► LinkDatabase ► GetReferenceCount(Item)
Gets the reference count.
Declaration Syntax
C#
public abstract int GetReferenceCount(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The count.


GetReferences Method (item)

GetReferences Method (item)
Namespaces ► Sitecore.Links ► LinkDatabase ► GetReferences(Item)
Gets the references.
Declaration Syntax
C#
public abstract ItemLink[] GetReferences(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The references.


GetRefererCount Method (item)

GetRefererCount Method (item)
Namespaces ► Sitecore.Links ► LinkDatabase ► GetRefererCount(Item)
Gets the referrer count.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use GetReferrerCount instead.")]
public int GetRefererCount(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The referrer count.


GetReferers Method (item)

GetReferers Method (item)
Namespaces ► Sitecore.Links ► LinkDatabase ► GetReferers(Item)
Gets the referrers.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use GetReferrers instead.")]
public ItemLink[] GetReferers(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The referrers.


GetReferrerCount Method (item)

GetReferrerCount Method (item)
Namespaces ► Sitecore.Links ► LinkDatabase ► GetReferrerCount(Item)
Gets the referrer count.
Declaration Syntax
C#
public abstract int GetReferrerCount(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The referrer count.


GetReferrers Method

GetReferrers Method
Namespaces ► Sitecore.Links ► LinkDatabase ► GetReferrers()()()
Members
Icon | Member | Description
 | GetReferrers(Item) | Gets the referrers.
 | GetReferrers(Item, Boolean) | Obsolete. Gets the referrers.


GetReferrers Method (item)

GetReferrers Method (item)
Namespaces ► Sitecore.Links ► LinkDatabase ► GetReferrers(Item)
Gets the referrers.
Declaration Syntax
C#
public abstract ItemLink[] GetReferrers(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The referrers.


GetReferrers Method (item, deep)

GetReferrers Method (item, deep)
Namespaces ► Sitecore.Links ► LinkDatabase ► GetReferrers(Item, Boolean)
Gets the referrers.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use GetReferrers(item) instead.")]
public abstract ItemLink[] GetReferrers(
    Item item,
    bool deep
)
Parameters
item (Item)
The item.
deep (Boolean)
if set to true this instance is deep.
Return Value
The referrers.


HasExternalReferers Method (item, deep)

HasExternalReferers Method (item, deep)
Namespaces ► Sitecore.Links ► LinkDatabase ► HasExternalReferers(Item, Boolean)
Determines whether the specified item has external referrers.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use HasExternalReferrers instead.")]
public bool HasExternalReferers(
    Item item,
    bool deep
)
Parameters
item (Item)
The item.
deep (Boolean)
if set to true this instance is deep.
Return Value
true if the specified item has external referrers; otherwise, false.


HasExternalReferrers Method (item, deep)

HasExternalReferrers Method (item, deep)
Namespaces ► Sitecore.Links ► LinkDatabase ► HasExternalReferrers(Item, Boolean)
Determines whether the specified item has external referrers.
Declaration Syntax
C#
public virtual bool HasExternalReferrers(
    Item item,
    bool deep
)
Parameters
item (Item)
The item.
deep (Boolean)
if set to true this instance is deep.
Return Value
true if the specified item has external referrers; otherwise, false.


Rebuild Method (database)

Rebuild Method (database)
Namespaces ► Sitecore.Links ► LinkDatabase ► Rebuild(Database)
Rebuilds the specified database.
Declaration Syntax
C#
public virtual void Rebuild(
    Database database
)
Parameters
database (Database)
The database.


RemoveReferences Method (item)

RemoveReferences Method (item)
Namespaces ► Sitecore.Links ► LinkDatabase ► RemoveReferences(Item)
Removes the references.
Declaration Syntax
C#
public abstract void RemoveReferences(
    Item item
)
Parameters
item (Item)
The item.


TargetExists Method (targetID, targetPath, database)

TargetExists Method (targetID, targetPath, database)
Namespaces ► Sitecore.Links ► LinkDatabase ► TargetExists(ID, String, Database)
Determines if the target exists.
Declaration Syntax
C#
protected virtual bool TargetExists(
    ID targetID,
    string targetPath,
    Database database
)
Parameters
targetID (ID)
The target ID.
targetPath (String)
The target path.
database (Database)
The database.
Return Value
true if the target exists, otherwise false.


UpdateLinks Method (item, links)

UpdateLinks Method (item, links)
Namespaces ► Sitecore.Links ► LinkDatabase ► UpdateLinks(Item, array<ItemLink>[]()[])
Updates the links.
Declaration Syntax
C#
protected abstract void UpdateLinks(
    Item item,
    ItemLink[] links
)
Parameters
item (Item)
The item.
links (array< ItemLink >[]()[])
The links.


UpdateReferences Method (item)

UpdateReferences Method (item)
Namespaces ► Sitecore.Links ► LinkDatabase ► UpdateReferences(Item)
Updates the references.
Declaration Syntax
C#
public virtual void UpdateReferences(
    Item item
)
Parameters
item (Item)
The item.


LinkDatabaseHelper Class

LinkDatabaseHelper Class
Namespaces ► Sitecore.Links ► LinkDatabaseHelper
Represents a LinkDatabaseHelper.
Declaration Syntax
C#
public static class LinkDatabaseHelper
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UpdateLink(Item) | Updates the links.
 | UpdateLink(Item, List<(Of <(ItemUri>)>)) | Updates the link.
Inheritance Hierarchy
Object
LinkDatabaseHelper


UpdateLink Method

UpdateLink Method
Namespaces ► Sitecore.Links ► LinkDatabaseHelper ► UpdateLink()()()
Members
Icon | Member | Description
 | UpdateLink(Item) | Updates the links.
 | UpdateLink(Item, List<(Of <(ItemUri>)>)) | Updates the link.


UpdateLink Method (item)

UpdateLink Method (item)
Namespaces ► Sitecore.Links ► LinkDatabaseHelper ► UpdateLink(Item)
Updates the links.
Declaration Syntax
C#
public static void UpdateLink(
    Item item
)
Parameters
item (Item)
The item.


UpdateLink Method (item, list)

UpdateLink Method (item, list)
Namespaces ► Sitecore.Links ► LinkDatabaseHelper ► UpdateLink(Item, List<(Of <(ItemUri>)>))
Updates the link.
Declaration Syntax
C#
public static void UpdateLink(
    Item item,
    List<ItemUri> list
)
Parameters
item (Item)
The item.
list (List<(Of <( ItemUri >)>))
The list of items that was updated.


LinkDatabaseProxy Class

LinkDatabaseProxy Class
Namespaces ► Sitecore.Links ► LinkDatabaseProxy
Represents a link database proxy.
Declaration Syntax
C#
public static class LinkDatabaseProxy
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetBrokenLinks(Database) | Gets the broken links.
 | GetStatus(Handle) | Gets the status.
Inheritance Hierarchy
Object
LinkDatabaseProxy


GetBrokenLinks Method (database)

GetBrokenLinks Method (database)
Namespaces ► Sitecore.Links ► LinkDatabaseProxy ► GetBrokenLinks(Database)
Gets the broken links.
Declaration Syntax
C#
public static Handle GetBrokenLinks(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The broken links.


GetStatus Method (handle)

GetStatus Method (handle)
Namespaces ► Sitecore.Links ► LinkDatabaseProxy ► GetStatus(Handle)
Gets the status.
Declaration Syntax
C#
public static JobStatus GetStatus(
    Handle handle
)
Parameters
handle (Handle)
The handle.
Return Value
The status.


LinkDisabler Class

LinkDisabler Class
Namespaces ► Sitecore.Links ► LinkDisabler
EventDisabler class
Declaration Syntax
C#
public sealed class LinkDisabler : Switcher<LinkDisablerState, LinkDisabler>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LinkDisabler()()() | Initializes a new instance of the LinkDisabler class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsActive | Gets a value indicating whether this instance is active.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <( LinkDisablerState, LinkDisabler>)>)
 |  | LinkDisabler


LinkDisabler Constructor

LinkDisabler Constructor
Namespaces ► Sitecore.Links ► LinkDisabler ► LinkDisabler()()()
Initializes a new instance of the LinkDisabler class.
Declaration Syntax
C#
public LinkDisabler()


IsActive Property

IsActive Property
Namespaces ► Sitecore.Links ► LinkDisabler ► IsActive
Gets a value indicating whether this instance is active.
Declaration Syntax
C#
public static bool IsActive { get; }
Value
true if this instance is active; otherwise, false.


LinkDisablerState Enumeration

LinkDisablerState Enumeration
Namespaces ► Sitecore.Links ► LinkDisablerState
Declaration Syntax
C#
public enum LinkDisablerState
Members
Member | Description
Disabled |
Enabled |


LinkManager Class

LinkManager Class
Namespaces ► Sitecore.Links ► LinkManager
LinkManager
Declaration Syntax
C#
public static class LinkManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddAspxExtension | Gets a value indicating whether to add the 'aspx' extension to generated URLs.
 | AlwaysIncludeServerUrl | Gets a value indicating whether to always add the current server URL to generated URLs.
 | ExpandDynamicLinks(String) | Expands all dynamic links embedded in a text.
 | ExpandDynamicLinks(String, Boolean) | Expands all dynamic links embedded in a text.
 | GetDefaultUrlOptions()()() | Gets (a clone of) the default URL options.
 | GetDynamicUrl(Item) | Gets the dynamic URL for an item.
 | GetDynamicUrl(Item, LinkUrlOptions) | Gets the dynamic URL for an item.
 | GetItemUrl(Item) | Gets the (friendly) URL of an item.
 | GetItemUrl(Item, UrlOptions) | Gets the (friendly) URL of an item.
 | IsDynamicLink(String) | Determines whether the specified link text represents a dynamic link.
 | LanguageEmbedding | Gets a value controlling if and how to embed language in the URL.
 | LanguageLocation | Gets the language location.
 | ParseDynamicLink(String) | Parses a dynamic link.
 | ParseRequestUrl(HttpRequest) | Parses a request URL.
 | Provider | Gets the provider.
 | Providers | Gets the providers.
 | ShortenUrls | Gets a value indicating whether to shorten generated URLs.
 | UseDisplayName | Gets a value indicating whether to use the DisplayName of items when generating URLs.
Inheritance Hierarchy
Object
LinkManager


AddAspxExtension Property

AddAspxExtension Property
Namespaces ► Sitecore.Links ► LinkManager ► AddAspxExtension
Gets a value indicating whether to add the 'aspx' extension to generated URLs.
Declaration Syntax
C#
public static bool AddAspxExtension { get; }
Value
true if the 'aspx' extension should be added to generated URLs; otherwise, false.


AlwaysIncludeServerUrl Property

AlwaysIncludeServerUrl Property
Namespaces ► Sitecore.Links ► LinkManager ► AlwaysIncludeServerUrl
Gets a value indicating whether to always add the current server URL to generated URLs.
Declaration Syntax
C#
public static bool AlwaysIncludeServerUrl { get; }
Value
true if the server URL should always be added to generated URLs; otherwise, false.


ExpandDynamicLinks Method

ExpandDynamicLinks Method
Namespaces ► Sitecore.Links ► LinkManager ► ExpandDynamicLinks()()()
Members
Icon | Member | Description
 | ExpandDynamicLinks(String) | Expands all dynamic links embedded in a text.
 | ExpandDynamicLinks(String, Boolean) | Expands all dynamic links embedded in a text.


ExpandDynamicLinks Method (text)

ExpandDynamicLinks Method (text)
Namespaces ► Sitecore.Links ► LinkManager ► ExpandDynamicLinks(String)
Expands all dynamic links embedded in a text.
Declaration Syntax
C#
public static string ExpandDynamicLinks(
    string text
)
Parameters
text (String)
The text.
Return Value


ExpandDynamicLinks Method (text, resolveSites)

ExpandDynamicLinks Method (text, resolveSites)
Namespaces ► Sitecore.Links ► LinkManager ► ExpandDynamicLinks(String, Boolean)
Expands all dynamic links embedded in a text.
Declaration Syntax
C#
public static string ExpandDynamicLinks(
    string text,
    bool resolveSites
)
Parameters
text (String)
The text.
resolveSites (Boolean)
Set this to true to resolve site information when expanding dynamic links.
Return Value


GetDefaultUrlOptions Method

GetDefaultUrlOptions Method
Namespaces ► Sitecore.Links ► LinkManager ► GetDefaultUrlOptions()()()
Gets (a clone of) the default URL options.
Declaration Syntax
C#
public static UrlOptions GetDefaultUrlOptions()
Return Value


GetDynamicUrl Method

GetDynamicUrl Method
Namespaces ► Sitecore.Links ► LinkManager ► GetDynamicUrl()()()
Members
Icon | Member | Description
 | GetDynamicUrl(Item) | Gets the dynamic URL for an item.
 | GetDynamicUrl(Item, LinkUrlOptions) | Gets the dynamic URL for an item.


GetDynamicUrl Method (item)

GetDynamicUrl Method (item)
Namespaces ► Sitecore.Links ► LinkManager ► GetDynamicUrl(Item)
Gets the dynamic URL for an item.
Declaration Syntax
C#
public static string GetDynamicUrl(
    Item item
)
Parameters
item (Item)
The item to create an URL to.
Return Value


GetDynamicUrl Method (item, options)

GetDynamicUrl Method (item, options)
Namespaces ► Sitecore.Links ► LinkManager ► GetDynamicUrl(Item, LinkUrlOptions)
Gets the dynamic URL for an item.
Declaration Syntax
C#
public static string GetDynamicUrl(
    Item item,
    LinkUrlOptions options
)
Parameters
item (Item)
The item to create an URL to.
options (LinkUrlOptions)
The options.
Return Value


GetItemUrl Method

GetItemUrl Method
Namespaces ► Sitecore.Links ► LinkManager ► GetItemUrl()()()
Members
Icon | Member | Description
 | GetItemUrl(Item) | Gets the (friendly) URL of an item.
 | GetItemUrl(Item, UrlOptions) | Gets the (friendly) URL of an item.


GetItemUrl Method (item)

GetItemUrl Method (item)
Namespaces ► Sitecore.Links ► LinkManager ► GetItemUrl(Item)
Gets the (friendly) URL of an item.
Declaration Syntax
C#
public static string GetItemUrl(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetItemUrl Method (item, options)

GetItemUrl Method (item, options)
Namespaces ► Sitecore.Links ► LinkManager ► GetItemUrl(Item, UrlOptions)
Gets the (friendly) URL of an item.
Declaration Syntax
C#
public static string GetItemUrl(
    Item item,
    UrlOptions options
)
Parameters
item (Item)
The item.
options (UrlOptions)
The options.
Return Value


IsDynamicLink Method (linkText)

IsDynamicLink Method (linkText)
Namespaces ► Sitecore.Links ► LinkManager ► IsDynamicLink(String)
Determines whether the specified link text represents a dynamic link.
Declaration Syntax
C#
public static bool IsDynamicLink(
    string linkText
)
Parameters
linkText (String)
The link text.
Return Value
true if [is dynamic link] [the specified link text]; otherwise, false.


LanguageEmbedding Property

LanguageEmbedding Property
Namespaces ► Sitecore.Links ► LinkManager ► LanguageEmbedding
Gets a value controlling if and how to embed language in the URL.
Declaration Syntax
C#
public static LanguageEmbedding LanguageEmbedding { get; }
Value
The embed language option.


LanguageLocation Property

LanguageLocation Property
Namespaces ► Sitecore.Links ► LinkManager ► LanguageLocation
Gets the language location.
Declaration Syntax
C#
public static LanguageLocation LanguageLocation { get; }
Value
The location within the URL where the language should be added.


ParseDynamicLink Method (linkText)

ParseDynamicLink Method (linkText)
Namespaces ► Sitecore.Links ► LinkManager ► ParseDynamicLink(String)
Parses a dynamic link.
Declaration Syntax
C#
public static DynamicLink ParseDynamicLink(
    string linkText
)
Parameters
linkText (String)
The link text.
Return Value


ParseRequestUrl Method (request)

ParseRequestUrl Method (request)
Namespaces ► Sitecore.Links ► LinkManager ► ParseRequestUrl(HttpRequest)
Parses a request URL.
Declaration Syntax
C#
public static RequestUrl ParseRequestUrl(
    HttpRequest request
)
Parameters
request (HttpRequest)
The request.
Return Value


Provider Property

Provider Property
Namespaces ► Sitecore.Links ► LinkManager ► Provider
Gets the provider.
Declaration Syntax
C#
public static LinkProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Links ► LinkManager ► Providers
Gets the providers.
Declaration Syntax
C#
public static LinkProviderCollection Providers { get; }
Value
The provider.


ShortenUrls Property

ShortenUrls Property
Namespaces ► Sitecore.Links ► LinkManager ► ShortenUrls
Gets a value indicating whether to shorten generated URLs.
Declaration Syntax
C#
public static bool ShortenUrls { get; }
Value
true if URLs should be shortened; otherwise, false.


UseDisplayName Property

UseDisplayName Property
Namespaces ► Sitecore.Links ► LinkManager ► UseDisplayName
Gets a value indicating whether to use the DisplayName of items when generating URLs.
Declaration Syntax
C#
public static bool UseDisplayName { get; }
Value
true if display names should be used; otherwise, false.


LinkProvider Class

LinkProvider Class
Namespaces ► Sitecore.Links ► LinkProvider
LinkProvider class
LinkProvider
LinkProvider
Declaration Syntax
C#
public class LinkProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LinkProvider()()() | Initializes a new instance of the LinkProvider class
 | AddAspxExtension | Gets a value indicating whether to add the 'aspx' extension to generated URLs.
 | AlwaysIncludeServerUrl | Gets a value indicating whether to always add the current server URL to generated URLs.
 | CreateLinkBuilder(UrlOptions) | Creates a link builder.
 | CreateLinkParser()()() | Creates a link parser.
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | EncodeNames | Gets or sets a value indicating whether to encode the names making up the URL of the link.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExpandDynamicLinks(String) | Obsolete. Expands all dynamic links embedded in a text.
 | ExpandDynamicLinks(String, Boolean) | Expands the dynamic links.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultUrlOptions()()() | Gets (a clone of) the default URL options.
 | GetDynamicUrl(Item, LinkUrlOptions) | Gets the dynamic URL for an item.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemUrl(Item, UrlOptions) | Gets the (friendly) URL of an item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | IsDynamicLink(String) | Determines whether the specified link text represents a dynamic link.
 | LanguageEmbedding | Gets a value controlling if and how to embed language in the URL.
 | LanguageLocation | Gets the language location.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ParseDynamicLink(String) | Parses a dynamic link.
 | ParseRequestUrl(HttpRequest) | Parses a request URL.
 | ShortenUrls | Gets a value indicating whether to shorten generated URLs.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseDisplayName | Gets a value indicating whether to use the DisplayName of items when generating URLs.
Inheritance Hierarchy
Object
 | ProviderBase
 |  | LinkProvider


LinkProvider Constructor

LinkProvider Constructor
Namespaces ► Sitecore.Links ► LinkProvider ► LinkProvider()()()
Initializes a new instance of the LinkProvider class
Declaration Syntax
C#
public LinkProvider()


AddAspxExtension Property

AddAspxExtension Property
Namespaces ► Sitecore.Links ► LinkProvider ► AddAspxExtension
Gets a value indicating whether to add the 'aspx' extension to generated URLs.
Declaration Syntax
C#
public virtual bool AddAspxExtension { get; }
Value
true if the 'aspx' extension should be added to generated URLs; otherwise, false.


AlwaysIncludeServerUrl Property

AlwaysIncludeServerUrl Property
Namespaces ► Sitecore.Links ► LinkProvider ► AlwaysIncludeServerUrl
Gets a value indicating whether to always add the current server URL to generated URLs.
Declaration Syntax
C#
public virtual bool AlwaysIncludeServerUrl { get; }
Value
true if the server URL should always be added to generated URLs; otherwise, false.


CreateLinkBuilder Method (options)

CreateLinkBuilder Method (options)
Namespaces ► Sitecore.Links ► LinkProvider ► CreateLinkBuilder(UrlOptions)
Creates a link builder.
Declaration Syntax
C#
protected virtual LinkProvider..::.LinkBuilder CreateLinkBuilder(
    UrlOptions options
)
Parameters
options (UrlOptions)
The options.
Return Value


CreateLinkParser Method

CreateLinkParser Method
Namespaces ► Sitecore.Links ► LinkProvider ► CreateLinkParser()()()
Creates a link parser.
Declaration Syntax
C#
protected virtual LinkProvider..::.LinkParser CreateLinkParser()
Return Value


EncodeNames Property

EncodeNames Property
Namespaces ► Sitecore.Links ► LinkProvider ► EncodeNames
Gets or sets a value indicating whether to encode the names making up the URL of the link.
Declaration Syntax
C#
public virtual bool EncodeNames { get; }
Value
true if encode names; otherwise, false.


ExpandDynamicLinks Method

ExpandDynamicLinks Method
Namespaces ► Sitecore.Links ► LinkProvider ► ExpandDynamicLinks()()()
Members
Icon | Member | Description
 | ExpandDynamicLinks(String) | Obsolete. Expands all dynamic links embedded in a text.
 | ExpandDynamicLinks(String, Boolean) | Expands the dynamic links.


ExpandDynamicLinks Method (text)

ExpandDynamicLinks Method (text)
Namespaces ► Sitecore.Links ► LinkProvider ► ExpandDynamicLinks(String)
Expands all dynamic links embedded in a text.
Declaration Syntax
C#
[ObsoleteAttribute("This method is never called by LinkManager. Implement ExpandDynamicLinks(string text, bool resolveSites) instead.")]
public virtual string ExpandDynamicLinks(
    string text
)
Parameters
text (String)
The text.
Return Value


ExpandDynamicLinks Method (text, resolveSites)

ExpandDynamicLinks Method (text, resolveSites)
Namespaces ► Sitecore.Links ► LinkProvider ► ExpandDynamicLinks(String, Boolean)
Expands the dynamic links.
Declaration Syntax
C#
public virtual string ExpandDynamicLinks(
    string text,
    bool resolveSites
)
Parameters
text (String)
The text.
resolveSites (Boolean)
Set this to true to resolve site information when expanding dynamic links.
Return Value


GetDefaultUrlOptions Method

GetDefaultUrlOptions Method
Namespaces ► Sitecore.Links ► LinkProvider ► GetDefaultUrlOptions()()()
Gets (a clone of) the default URL options.
Declaration Syntax
C#
public virtual UrlOptions GetDefaultUrlOptions()
Return Value


GetDynamicUrl Method (item, options)

GetDynamicUrl Method (item, options)
Namespaces ► Sitecore.Links ► LinkProvider ► GetDynamicUrl(Item, LinkUrlOptions)
Gets the dynamic URL for an item.
Declaration Syntax
C#
public virtual string GetDynamicUrl(
    Item item,
    LinkUrlOptions options
)
Parameters
item (Item)
The item to create an URL to.
options (LinkUrlOptions)
The options.
Return Value


GetItemUrl Method (item, options)

GetItemUrl Method (item, options)
Namespaces ► Sitecore.Links ► LinkProvider ► GetItemUrl(Item, UrlOptions)
Gets the (friendly) URL of an item.
Declaration Syntax
C#
public virtual string GetItemUrl(
    Item item,
    UrlOptions options
)
Parameters
item (Item)
The item.
options (UrlOptions)
The options.
Return Value


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Links ► LinkProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
ArgumentException | The name of the provider has a length of zero.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.


IsDynamicLink Method (linkText)

IsDynamicLink Method (linkText)
Namespaces ► Sitecore.Links ► LinkProvider ► IsDynamicLink(String)
Determines whether the specified link text represents a dynamic link.
Declaration Syntax
C#
public virtual bool IsDynamicLink(
    string linkText
)
Parameters
linkText (String)
The link text.
Return Value
true if [is dynamic link] [the specified link text]; otherwise, false.


LanguageEmbedding Property

LanguageEmbedding Property
Namespaces ► Sitecore.Links ► LinkProvider ► LanguageEmbedding
Gets a value controlling if and how to embed language in the URL.
Declaration Syntax
C#
public virtual LanguageEmbedding LanguageEmbedding { get; }
Value
The embed language option.


LanguageLocation Property

LanguageLocation Property
Namespaces ► Sitecore.Links ► LinkProvider ► LanguageLocation
Gets the language location.
Declaration Syntax
C#
public virtual LanguageLocation LanguageLocation { get; }
Value
The location within the URL where the language should be added.


ParseDynamicLink Method (linkText)

ParseDynamicLink Method (linkText)
Namespaces ► Sitecore.Links ► LinkProvider ► ParseDynamicLink(String)
Parses a dynamic link.
Declaration Syntax
C#
public virtual DynamicLink ParseDynamicLink(
    string linkText
)
Parameters
linkText (String)
The link text.
Return Value


ParseRequestUrl Method (request)

ParseRequestUrl Method (request)
Namespaces ► Sitecore.Links ► LinkProvider ► ParseRequestUrl(HttpRequest)
Parses a request URL.
Declaration Syntax
C#
public virtual RequestUrl ParseRequestUrl(
    HttpRequest request
)
Parameters
request (HttpRequest)
The request.
Return Value


ShortenUrls Property

ShortenUrls Property
Namespaces ► Sitecore.Links ► LinkProvider ► ShortenUrls
Gets a value indicating whether to shorten generated URLs.
Declaration Syntax
C#
public virtual bool ShortenUrls { get; }
Value
true if URLs should be shortened; otherwise, false.


UseDisplayName Property

UseDisplayName Property
Namespaces ► Sitecore.Links ► LinkProvider ► UseDisplayName
Gets a value indicating whether to use the DisplayName of items when generating URLs.
Declaration Syntax
C#
public virtual bool UseDisplayName { get; }
Value
true if display names should be used; otherwise, false.


LinkProvider.LinkBuilder Class

LinkProvider..::.LinkBuilder Class
Namespaces ► Sitecore.Links ► LinkProvider ► LinkProvider..::.LinkBuilder
LinkBuilder
Declaration Syntax
C#
public class LinkBuilder
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LinkProvider..::.LinkBuilder(UrlOptions) | Initializes a new instance of the LinkProvider..::.LinkBuilder class.
 | BuildItemUrl(Item) | Builds the item URL.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemUrl(Item) | Gets the URL.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveTargetSite(Item) | Resolves the target site.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LinkProvider..::.LinkBuilder


LinkProvider.LinkBuilder Constructor (options)

LinkProvider..::.LinkBuilder Constructor (options)
Namespaces ► Sitecore.Links ► LinkProvider..::.LinkBuilder ► LinkProvider..::.LinkBuilder(UrlOptions)
Initializes a new instance of the LinkProvider..::.LinkBuilder class.
Declaration Syntax
C#
public LinkBuilder(
    UrlOptions options
)
Parameters
options (UrlOptions)
The URL options.


BuildItemUrl Method (item)

BuildItemUrl Method (item)
Namespaces ► Sitecore.Links ► LinkProvider..::.LinkBuilder ► BuildItemUrl(Item)
Builds the item URL.
Declaration Syntax
C#
protected virtual string BuildItemUrl(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetItemUrl Method (item)

GetItemUrl Method (item)
Namespaces ► Sitecore.Links ► LinkProvider..::.LinkBuilder ► GetItemUrl(Item)
Gets the URL.
Declaration Syntax
C#
public string GetItemUrl(
    Item item
)
Parameters
item (Item)
The item.
Return Value


ResolveTargetSite Method (item)

ResolveTargetSite Method (item)
Namespaces ► Sitecore.Links ► LinkProvider..::.LinkBuilder ► ResolveTargetSite(Item)
Resolves the target site.
Declaration Syntax
C#
protected virtual SiteInfo ResolveTargetSite(
    Item item
)
Parameters
item (Item)
The item.
Return Value


LinkProvider.LinkParser Class

LinkProvider..::.LinkParser Class
Namespaces ► Sitecore.Links ► LinkProvider ► LinkProvider..::.LinkParser
LinkParser
Declaration Syntax
C#
public class LinkParser
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LinkProvider..::.LinkParser()()() | Initializes a new instance of the LinkProvider..::.LinkParser class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExpandDynamicLinks(String, UrlOptions) | Expands the dynamic links embedded in the text and returns the result.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LinkProvider..::.LinkParser


LinkProvider.LinkParser Constructor

LinkProvider..::.LinkParser Constructor
Namespaces ► Sitecore.Links ► LinkProvider..::.LinkParser ► LinkProvider..::.LinkParser()()()
Initializes a new instance of the LinkProvider..::.LinkParser class
Declaration Syntax
C#
public LinkParser()


ExpandDynamicLinks Method (text, options)

ExpandDynamicLinks Method (text, options)
Namespaces ► Sitecore.Links ► LinkProvider..::.LinkParser ► ExpandDynamicLinks(String, UrlOptions)
Expands the dynamic links embedded in the text and returns the result.
Declaration Syntax
C#
public string ExpandDynamicLinks(
    string text,
    UrlOptions options
)
Parameters
text (String)
options (UrlOptions)
Return Value


LinkProviderCollection Class

LinkProviderCollection Class
Namespaces ► Sitecore.Links ► LinkProviderCollection
LinkProviderCollection class
Declaration Syntax
C#
public class LinkProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LinkProviderCollection()()() | Initializes a new instance of the LinkProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the LinkProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | LinkProviderCollection


LinkProviderCollection Constructor

LinkProviderCollection Constructor
Namespaces ► Sitecore.Links ► LinkProviderCollection ► LinkProviderCollection()()()
Initializes a new instance of the LinkProviderCollection class
Declaration Syntax
C#
public LinkProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Links ► LinkProviderCollection ► Item[([(String])])
Gets the LinkProvider with the specified name.
Declaration Syntax
C#
public LinkProvider this[
    string name
] { get; }
Parameters
name (String)
Value


LinksValidationResult Class

LinksValidationResult Class
Namespaces ► Sitecore.Links ► LinksValidationResult
Represents a Links Validation Result.
Declaration Syntax
C#
public class LinksValidationResult
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LinksValidationResult(Field, ItemLinkState) | Initializes a new instance of the LinksValidationResult class.
 | AddBrokenLink(String) | Adds the broken link.
 | AddValidLink(Item, String) | Adds the valid link.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a value indicating whether this instance is empty.
 | Links | Gets the links.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LinksValidationResult


LinksValidationResult Constructor (field, linkState)

LinksValidationResult Constructor (field, linkState)
Namespaces ► Sitecore.Links ► LinksValidationResult ► LinksValidationResult(Field, ItemLinkState)
Initializes a new instance of the LinksValidationResult class.
Declaration Syntax
C#
public LinksValidationResult(
    Field field,
    ItemLinkState linkState
)
Parameters
field (Field)
The field.
linkState (ItemLinkState)
State of the link.


AddBrokenLink Method (targetPath)

AddBrokenLink Method (targetPath)
Namespaces ► Sitecore.Links ► LinksValidationResult ► AddBrokenLink(String)
Adds the broken link.
Declaration Syntax
C#
public ItemLink AddBrokenLink(
    string targetPath
)
Parameters
targetPath (String)
The target path.


AddValidLink Method (targetItem, targetPath)

AddValidLink Method (targetItem, targetPath)
Namespaces ► Sitecore.Links ► LinksValidationResult ► AddValidLink(Item, String)
Adds the valid link.
Declaration Syntax
C#
public ItemLink AddValidLink(
    Item targetItem,
    string targetPath
)
Parameters
targetItem (Item)
The target item.
targetPath (String)
The target path.
Return Value
The valid link.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Links ► LinksValidationResult ► IsEmpty
Gets a value indicating whether this instance is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this instance is empty; otherwise, false.


Links Property

Links Property
Namespaces ► Sitecore.Links ► LinksValidationResult ► Links
Gets the links.
Declaration Syntax
C#
public List<ItemLink> Links { get; }
Value
The links.


LinkUpdaterJob Class

LinkUpdaterJob Class
Namespaces ► Sitecore.Links ► LinkUpdaterJob
Declaration Syntax
C#
public class LinkUpdaterJob
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LinkUpdaterJob(Item) | Initializes a new instance of the LinkUpdaterJob class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update()()() | Updates this instance.
Inheritance Hierarchy
Object
LinkUpdaterJob


LinkUpdaterJob Constructor (item)

LinkUpdaterJob Constructor (item)
Namespaces ► Sitecore.Links ► LinkUpdaterJob ► LinkUpdaterJob(Item)
Initializes a new instance of the LinkUpdaterJob class.
Declaration Syntax
C#
public LinkUpdaterJob(
    Item item
)
Parameters
item (Item)


Update Method

Update Method
Namespaces ► Sitecore.Links ► LinkUpdaterJob ► Update()()()
Updates this instance.
Declaration Syntax
C#
protected void Update()


LinkUrlOptions Class

LinkUrlOptions Class
Namespaces ► Sitecore.Links ► LinkUrlOptions
Contains options for generating an Url from an item that is linked to.
Declaration Syntax
C#
public class LinkUrlOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LinkUrlOptions()()() | Initializes a new instance of the LinkUrlOptions class
 | Empty | Gets the empty.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Language | Gets or sets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Site | Gets or sets the site.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LinkUrlOptions


LinkUrlOptions Constructor

LinkUrlOptions Constructor
Namespaces ► Sitecore.Links ► LinkUrlOptions ► LinkUrlOptions()()()
Initializes a new instance of the LinkUrlOptions class
Declaration Syntax
C#
public LinkUrlOptions()


Empty Property

Empty Property
Namespaces ► Sitecore.Links ► LinkUrlOptions ► Empty
Gets the empty.
Declaration Syntax
C#
public static LinkUrlOptions Empty { get; }
Value
The empty.


Language Property

Language Property
Namespaces ► Sitecore.Links ► LinkUrlOptions ► Language
Gets or sets the language.
Declaration Syntax
C#
public Language Language { get; set; }
Value
The language.


Site Property

Site Property
Namespaces ► Sitecore.Links ► LinkUrlOptions ► Site
Gets or sets the site.
Declaration Syntax
C#
public string Site { get; set; }
Value
The site.


SqlLinkDatabase Class

SqlLinkDatabase Class
Namespaces ► Sitecore.Links ► SqlLinkDatabase
SqlLinkDatabase class
Declaration Syntax
C#
public class SqlLinkDatabase : LinkDatabase
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlLinkDatabase(SqlDataApi) | Initializes a new instance of the SqlLinkDatabase class.
 | _dataApi | data API
 | AddLink(Item, ItemLink) | Adds the link.
 | Compact(Database) | Compacts the specified database. (Overrides LinkDatabase.Compact(Database).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBrokenLinks(Database) | Gets the broken links. (Overrides LinkDatabase.GetBrokenLinks(Database).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReferenceCount(Item) | Gets the reference count. (Overrides LinkDatabase.GetReferenceCount(Item).)
 | GetReferences(Item) | Gets the references. (Overrides LinkDatabase.GetReferences(Item).)
 | GetRefererCount(Item) | Obsolete. Gets the referrer count. (Inherited from LinkDatabase.)
 | GetReferers(Item) | Obsolete. Gets the referrers. (Inherited from LinkDatabase.)
 | GetReferrerCount(Item) | Gets the referrer count. (Overrides LinkDatabase.GetReferrerCount(Item).)
 | GetReferrers(Item) | Gets the referrers. (Overrides LinkDatabase.GetReferrers(Item).)
 | GetReferrers(Item, Boolean) | Obsolete. Gets the referrers. (Overrides LinkDatabase.GetReferrers(Item, Boolean).)
 | GetString(String, Int32) | Gets a string.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasExternalReferers(Item, Boolean) | Obsolete. Determines whether the specified item has external referrers. (Inherited from LinkDatabase.)
 | HasExternalReferrers(Item, Boolean) | Determines whether the specified item has external referrers. (Inherited from LinkDatabase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rebuild(Database) | Rebuilds the specified database. (Inherited from LinkDatabase.)
 | RemoveLinks(Item) | Removes the links.
 | RemoveReferences(Item) | Removes the references. (Overrides LinkDatabase.RemoveReferences(Item).)
 | TargetExists(ID, String, Database) | Determines if the target exists. (Inherited from LinkDatabase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLinks(Item, array<ItemLink>[]()[]) | Updates the links. (Overrides LinkDatabase.UpdateLinks(Item, array<ItemLink>[]()[]).)
 | UpdateReferences(Item) | Updates the references. (Inherited from LinkDatabase.)
Inheritance Hierarchy
Object
 | LinkDatabase
 |  | SqlLinkDatabase
 |  |  | SqlServerLinkDatabase


SqlLinkDatabase Constructor (dataApi)

SqlLinkDatabase Constructor (dataApi)
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► SqlLinkDatabase(SqlDataApi)
Initializes a new instance of the SqlLinkDatabase class.
Declaration Syntax
C#
public SqlLinkDatabase(
    SqlDataApi dataApi
)
Parameters
dataApi (SqlDataApi)
The data API.


_dataApi Field

_dataApi Field
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► _dataApi
data API
Declaration Syntax
C#
protected readonly SqlDataApi _dataApi


AddLink Method (item, link)

AddLink Method (item, link)
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► AddLink(Item, ItemLink)
Adds the link.
Declaration Syntax
C#
protected virtual void AddLink(
    Item item,
    ItemLink link
)
Parameters
item (Item)
The item.
link (ItemLink)
The link.


Compact Method (database)

Compact Method (database)
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► Compact(Database)
Compacts the specified database.
Declaration Syntax
C#
public override void Compact(
    Database database
)
Parameters
database (Database)
The database.


GetBrokenLinks Method (database)

GetBrokenLinks Method (database)
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► GetBrokenLinks(Database)
Gets the broken links.
Declaration Syntax
C#
public override ItemLink[] GetBrokenLinks(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The broken links.


GetReferenceCount Method (item)

GetReferenceCount Method (item)
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► GetReferenceCount(Item)
Gets the reference count.
Declaration Syntax
C#
public override int GetReferenceCount(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The count.


GetReferences Method (item)

GetReferences Method (item)
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► GetReferences(Item)
Gets the references.
Declaration Syntax
C#
public override ItemLink[] GetReferences(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The references.


GetReferrerCount Method (item)

GetReferrerCount Method (item)
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► GetReferrerCount(Item)
Gets the referrer count.
Declaration Syntax
C#
public override int GetReferrerCount(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The referrer count.


GetReferrers Method

GetReferrers Method
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► GetReferrers()()()
Members
Icon | Member | Description
 | GetReferrers(Item) | Gets the referrers. (Overrides LinkDatabase.GetReferrers(Item).)
 | GetReferrers(Item, Boolean) | Obsolete. Gets the referrers. (Overrides LinkDatabase.GetReferrers(Item, Boolean).)


GetReferrers Method (item)

GetReferrers Method (item)
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► GetReferrers(Item)
Gets the referrers.
Declaration Syntax
C#
public override ItemLink[] GetReferrers(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The referrers.


GetReferrers Method (item, deep)

GetReferrers Method (item, deep)
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► GetReferrers(Item, Boolean)
Gets the referrers.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use GetReferers(Item) instead.")]
public override ItemLink[] GetReferrers(
    Item item,
    bool deep
)
Parameters
item (Item)
The item.
deep (Boolean)
if set to true this instance is deep.
Return Value
The referrers.


GetString Method (value, maxLength)

GetString Method (value, maxLength)
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► GetString(String, Int32)
Gets a string.
Declaration Syntax
C#
protected virtual string GetString(
    string value,
    int maxLength
)
Parameters
value (String)
The value.
maxLength (Int32)
The maximum allowed length.
Return Value


RemoveLinks Method (item)

RemoveLinks Method (item)
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► RemoveLinks(Item)
Removes the links.
Declaration Syntax
C#
protected virtual void RemoveLinks(
    Item item
)
Parameters
item (Item)
The item.


RemoveReferences Method (item)

RemoveReferences Method (item)
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► RemoveReferences(Item)
Removes the references.
Declaration Syntax
C#
public override void RemoveReferences(
    Item item
)
Parameters
item (Item)
The item.


UpdateLinks Method (item, links)

UpdateLinks Method (item, links)
Namespaces ► Sitecore.Links ► SqlLinkDatabase ► UpdateLinks(Item, array<ItemLink>[]()[])
Updates the links.
Declaration Syntax
C#
protected override void UpdateLinks(
    Item item,
    ItemLink[] links
)
Parameters
item (Item)
The item.
links (array< ItemLink >[]()[])
The links.


UrlOptions Class

UrlOptions Class
Namespaces ► Sitecore.Links ► UrlOptions
UrlOptions
Declaration Syntax
C#
public class UrlOptions : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UrlOptions()()() | Initializes a new instance of the UrlOptions class
 | AddAspxExtension | Gets a value indicating whether [add aspx extension].
 | AlwaysIncludeServerUrl | Gets or sets a value indicating whether to always include the server URL.
 | Clone()()() | Creates a new object that is a copy of the current instance.
 | DefaultOptions | Gets (a clone of) the default options.
 | EmbedLanguage(Language) | Returns a value indicating whether to embed the specified language.
 | EncodeNames | Gets or sets a value indicating whether to encode the names making up the URL of the link.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Language | Gets or sets the language.
 | LanguageEmbedding | Gets or sets a value controlling if and how to embed language in the URL.
 | LanguageLocation | Gets or sets the language location.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ShortenUrls | Gets or sets a value indicating whether to shorten URLs according to the site.
 | Site | Gets or sets the site.
 | SiteResolving | Gets or sets a value indicating whether site resolving is enabled.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseDisplayName | Gets or sets a value indicating whether to use the display name for urls.
Inheritance Hierarchy
Object
UrlOptions


UrlOptions Constructor

UrlOptions Constructor
Namespaces ► Sitecore.Links ► UrlOptions ► UrlOptions()()()
Initializes a new instance of the UrlOptions class
Declaration Syntax
C#
public UrlOptions()


AddAspxExtension Property

AddAspxExtension Property
Namespaces ► Sitecore.Links ► UrlOptions ► AddAspxExtension
Gets a value indicating whether [add aspx extension].
Declaration Syntax
C#
public virtual bool AddAspxExtension { get; set; }
Value
true if [add aspx extension]; otherwise, false.


AlwaysIncludeServerUrl Property

AlwaysIncludeServerUrl Property
Namespaces ► Sitecore.Links ► UrlOptions ► AlwaysIncludeServerUrl
Gets or sets a value indicating whether to always include the server URL.
Declaration Syntax
C#
public virtual bool AlwaysIncludeServerUrl { get; set; }
Value
true if [always include server URL]; otherwise, false.


Clone Method

Clone Method
Namespaces ► Sitecore.Links ► UrlOptions ► Clone()()()
Creates a new object that is a copy of the current instance.
Declaration Syntax
C#
public virtual Object Clone()
Return Value
A new object that is a copy of this instance.


DefaultOptions Property

DefaultOptions Property
Namespaces ► Sitecore.Links ► UrlOptions ► DefaultOptions
Gets (a clone of) the default options.
Declaration Syntax
C#
public static UrlOptions DefaultOptions { get; }
Value
The default options.


EmbedLanguage Method (language)

EmbedLanguage Method (language)
Namespaces ► Sitecore.Links ► UrlOptions ► EmbedLanguage(Language)
Returns a value indicating whether to embed the specified language.
Declaration Syntax
C#
public virtual bool EmbedLanguage(
    Language language
)
Parameters
language (Language)
The language.
Return Value


EncodeNames Property

EncodeNames Property
Namespaces ► Sitecore.Links ► UrlOptions ► EncodeNames
Gets or sets a value indicating whether to encode the names making up the URL of the link.
Declaration Syntax
C#
public bool EncodeNames { get; set; }
Value
true if encode names; otherwise, false.


Language Property

Language Property
Namespaces ► Sitecore.Links ► UrlOptions ► Language
Gets or sets the language.
Declaration Syntax
C#
public virtual Language Language { get; set; }
Value
The language.


LanguageEmbedding Property

LanguageEmbedding Property
Namespaces ► Sitecore.Links ► UrlOptions ► LanguageEmbedding
Gets or sets a value controlling if and how to embed language in the URL.
Declaration Syntax
C#
public virtual LanguageEmbedding LanguageEmbedding { get; set; }
Value
The embed language option.


LanguageLocation Property

LanguageLocation Property
Namespaces ► Sitecore.Links ► UrlOptions ► LanguageLocation
Gets or sets the language location.
Declaration Syntax
C#
public LanguageLocation LanguageLocation { get; set; }
Value
The location within the URL where the language should be added.


ShortenUrls Property

ShortenUrls Property
Namespaces ► Sitecore.Links ► UrlOptions ► ShortenUrls
Gets or sets a value indicating whether to shorten URLs according to the site.
Declaration Syntax
C#
public virtual bool ShortenUrls { get; set; }
Value
true if shorten; otherwise, false.


Site Property

Site Property
Namespaces ► Sitecore.Links ► UrlOptions ► Site
Gets or sets the site.
Declaration Syntax
C#
public virtual SiteContext Site { get; set; }
Value
The site.


SiteResolving Property

SiteResolving Property
Namespaces ► Sitecore.Links ► UrlOptions ► SiteResolving
Gets or sets a value indicating whether site resolving is enabled.
Declaration Syntax
C#
public bool SiteResolving { get; set; }
Value
true if site resolving is enabled; otherwise, false.


UseDisplayName Property

UseDisplayName Property
Namespaces ► Sitecore.Links ► UrlOptions ► UseDisplayName
Gets or sets a value indicating whether to use the display name for urls.
Declaration Syntax
C#
public virtual bool UseDisplayName { get; set; }
Value
true if use display name; otherwise, false.


Sitecore.Linq Namespace

Sitecore.Linq Namespace
Namespaces ► Sitecore.Linq
Declaration Syntax
C#
namespace Sitecore.Linq
Types
All Types Classes
Icon | Type | Description
 | Field |
 | Item |
 | Language |
 | Revision |
 | Template |
 | TemplateField |
 | TemplateFieldType |
 | Version |


Field Class

Field Class
Namespaces ► Sitecore.Linq ► Field
Declaration Syntax
C#
public class Field : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Field()()() | Initializes a new instance of the Field class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PropertyChanged |
 | PropertyChanging |
 | Revision |
 | RevisionId |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | TemplateField |
 | TemplateFieldId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
Field


Field Constructor

Field Constructor
Namespaces ► Sitecore.Linq ► Field ► Field()()()
Initializes a new instance of the Field class
Declaration Syntax
C#
public Field()


Id Property

Id Property
Namespaces ► Sitecore.Linq ► Field ► Id
Declaration Syntax
C#
public Guid Id { get; set; }


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Linq ► Field ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Linq ► Field ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging


Revision Property

Revision Property
Namespaces ► Sitecore.Linq ► Field ► Revision
Declaration Syntax
C#
public Revision Revision { get; set; }


RevisionId Property

RevisionId Property
Namespaces ► Sitecore.Linq ► Field ► RevisionId
Declaration Syntax
C#
public Guid RevisionId { get; set; }


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Linq ► Field ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Linq ► Field ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()


TemplateField Property

TemplateField Property
Namespaces ► Sitecore.Linq ► Field ► TemplateField
Declaration Syntax
C#
public TemplateField TemplateField { get; set; }


TemplateFieldId Property

TemplateFieldId Property
Namespaces ► Sitecore.Linq ► Field ► TemplateFieldId
Declaration Syntax
C#
public Guid TemplateFieldId { get; set; }


Value Property

Value Property
Namespaces ► Sitecore.Linq ► Field ► Value
Declaration Syntax
C#
public string Value { get; set; }


Item Class

Item Class
Namespaces ► Sitecore.Linq ► Item
Declaration Syntax
C#
public class Item : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Item()()() | Initializes a new instance of the Item class
 | Created |
 | CreatedBy |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | Template |
 | TemplateId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Updated |
 | UpdatedBy |
 | Versions |
Inheritance Hierarchy
Object
Item


Item Constructor

Item Constructor
Namespaces ► Sitecore.Linq ► Item ► Item()()()
Initializes a new instance of the Item class
Declaration Syntax
C#
public Item()


Created Property

Created Property
Namespaces ► Sitecore.Linq ► Item ► Created
Declaration Syntax
C#
public long Created { get; set; }


CreatedBy Property

CreatedBy Property
Namespaces ► Sitecore.Linq ► Item ► CreatedBy
Declaration Syntax
C#
public string CreatedBy { get; set; }


Id Property

Id Property
Namespaces ► Sitecore.Linq ► Item ► Id
Declaration Syntax
C#
public Guid Id { get; set; }


Name Property

Name Property
Namespaces ► Sitecore.Linq ► Item ► Name
Declaration Syntax
C#
public string Name { get; set; }


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Linq ► Item ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Linq ► Item ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Linq ► Item ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Linq ► Item ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()


Template Property

Template Property
Namespaces ► Sitecore.Linq ► Item ► Template
Declaration Syntax
C#
public Template Template { get; set; }


TemplateId Property

TemplateId Property
Namespaces ► Sitecore.Linq ► Item ► TemplateId
Declaration Syntax
C#
public Guid TemplateId { get; set; }


Updated Property

Updated Property
Namespaces ► Sitecore.Linq ► Item ► Updated
Declaration Syntax
C#
public long Updated { get; set; }


UpdatedBy Property

UpdatedBy Property
Namespaces ► Sitecore.Linq ► Item ► UpdatedBy
Declaration Syntax
C#
public string UpdatedBy { get; set; }


Versions Property

Versions Property
Namespaces ► Sitecore.Linq ► Item ► Versions
Declaration Syntax
C#
public EntitySet<Version> Versions { get; set; }


Language Class

Language Class
Namespaces ► Sitecore.Linq ► Language
Declaration Syntax
C#
public class Language : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Language()()() | Initializes a new instance of the Language class
 | Created |
 | CreatedBy |
 | CultureName |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Updated |
 | UpdatedBy |
 | Versions |
Inheritance Hierarchy
Object
Language


Language Constructor

Language Constructor
Namespaces ► Sitecore.Linq ► Language ► Language()()()
Initializes a new instance of the Language class
Declaration Syntax
C#
public Language()


Created Property

Created Property
Namespaces ► Sitecore.Linq ► Language ► Created
Declaration Syntax
C#
public long Created { get; set; }


CreatedBy Property

CreatedBy Property
Namespaces ► Sitecore.Linq ► Language ► CreatedBy
Declaration Syntax
C#
public string CreatedBy { get; set; }


CultureName Property

CultureName Property
Namespaces ► Sitecore.Linq ► Language ► CultureName
Declaration Syntax
C#
public string CultureName { get; set; }


Id Property

Id Property
Namespaces ► Sitecore.Linq ► Language ► Id
Declaration Syntax
C#
public Guid Id { get; set; }


Name Property

Name Property
Namespaces ► Sitecore.Linq ► Language ► Name
Declaration Syntax
C#
public string Name { get; set; }


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Linq ► Language ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Linq ► Language ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Linq ► Language ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Linq ► Language ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()


Updated Property

Updated Property
Namespaces ► Sitecore.Linq ► Language ► Updated
Declaration Syntax
C#
public long Updated { get; set; }


UpdatedBy Property

UpdatedBy Property
Namespaces ► Sitecore.Linq ► Language ► UpdatedBy
Declaration Syntax
C#
public string UpdatedBy { get; set; }


Versions Property

Versions Property
Namespaces ► Sitecore.Linq ► Language ► Versions
Declaration Syntax
C#
public EntitySet<Version> Versions { get; set; }


Revision Class

Revision Class
Namespaces ► Sitecore.Linq ► Revision
Declaration Syntax
C#
public class Revision : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Revision()()() | Initializes a new instance of the Revision class
 | Created |
 | CreatedBy |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fields |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version |
 | VersionId |
Inheritance Hierarchy
Object
Revision


Revision Constructor

Revision Constructor
Namespaces ► Sitecore.Linq ► Revision ► Revision()()()
Initializes a new instance of the Revision class
Declaration Syntax
C#
public Revision()


Created Property

Created Property
Namespaces ► Sitecore.Linq ► Revision ► Created
Declaration Syntax
C#
public long Created { get; set; }


CreatedBy Property

CreatedBy Property
Namespaces ► Sitecore.Linq ► Revision ► CreatedBy
Declaration Syntax
C#
public string CreatedBy { get; set; }


Fields Property

Fields Property
Namespaces ► Sitecore.Linq ► Revision ► Fields
Declaration Syntax
C#
public EntitySet<Field> Fields { get; set; }


Id Property

Id Property
Namespaces ► Sitecore.Linq ► Revision ► Id
Declaration Syntax
C#
public Guid Id { get; set; }


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Linq ► Revision ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Linq ► Revision ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Linq ► Revision ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Linq ► Revision ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()


Version Property

Version Property
Namespaces ► Sitecore.Linq ► Revision ► Version
Declaration Syntax
C#
public Version Version { get; set; }


VersionId Property

VersionId Property
Namespaces ► Sitecore.Linq ► Revision ► VersionId
Declaration Syntax
C#
public Guid VersionId { get; set; }


Template Class

Template Class
Namespaces ► Sitecore.Linq ► Template
Declaration Syntax
C#
public class Template : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Template()()() | Initializes a new instance of the Template class
 | Created |
 | CreatedBy |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | Items |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | TemplateFields |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Updated |
 | UpdatedBy |
Inheritance Hierarchy
Object
Template


Template Constructor

Template Constructor
Namespaces ► Sitecore.Linq ► Template ► Template()()()
Initializes a new instance of the Template class
Declaration Syntax
C#
public Template()


Created Property

Created Property
Namespaces ► Sitecore.Linq ► Template ► Created
Declaration Syntax
C#
public long Created { get; set; }


CreatedBy Property

CreatedBy Property
Namespaces ► Sitecore.Linq ► Template ► CreatedBy
Declaration Syntax
C#
public string CreatedBy { get; set; }


Id Property

Id Property
Namespaces ► Sitecore.Linq ► Template ► Id
Declaration Syntax
C#
public Guid Id { get; set; }


Items Property

Items Property
Namespaces ► Sitecore.Linq ► Template ► Items
Declaration Syntax
C#
public EntitySet<Item> Items { get; set; }


Name Property

Name Property
Namespaces ► Sitecore.Linq ► Template ► Name
Declaration Syntax
C#
public string Name { get; set; }


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Linq ► Template ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Linq ► Template ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Linq ► Template ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Linq ► Template ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()


TemplateFields Property

TemplateFields Property
Namespaces ► Sitecore.Linq ► Template ► TemplateFields
Declaration Syntax
C#
public EntitySet<TemplateField> TemplateFields { get; set; }


Updated Property

Updated Property
Namespaces ► Sitecore.Linq ► Template ► Updated
Declaration Syntax
C#
public long Updated { get; set; }


UpdatedBy Property

UpdatedBy Property
Namespaces ► Sitecore.Linq ► Template ► UpdatedBy
Declaration Syntax
C#
public string UpdatedBy { get; set; }


TemplateField Class

TemplateField Class
Namespaces ► Sitecore.Linq ► TemplateField
Declaration Syntax
C#
public class TemplateField : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateField()()() | Initializes a new instance of the TemplateField class
 | Created |
 | CreatedBy |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fields |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | Template |
 | TemplateFieldType |
 | TemplateFieldTypeId |
 | TemplateId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Updated |
 | UpdatedBy |
Inheritance Hierarchy
Object
TemplateField


TemplateField Constructor

TemplateField Constructor
Namespaces ► Sitecore.Linq ► TemplateField ► TemplateField()()()
Initializes a new instance of the TemplateField class
Declaration Syntax
C#
public TemplateField()


Created Property

Created Property
Namespaces ► Sitecore.Linq ► TemplateField ► Created
Declaration Syntax
C#
public long Created { get; set; }


CreatedBy Property

CreatedBy Property
Namespaces ► Sitecore.Linq ► TemplateField ► CreatedBy
Declaration Syntax
C#
public string CreatedBy { get; set; }


Fields Property

Fields Property
Namespaces ► Sitecore.Linq ► TemplateField ► Fields
Declaration Syntax
C#
public EntitySet<Field> Fields { get; set; }


Id Property

Id Property
Namespaces ► Sitecore.Linq ► TemplateField ► Id
Declaration Syntax
C#
public Guid Id { get; set; }


Name Property

Name Property
Namespaces ► Sitecore.Linq ► TemplateField ► Name
Declaration Syntax
C#
public string Name { get; set; }


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Linq ► TemplateField ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Linq ► TemplateField ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Linq ► TemplateField ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Linq ► TemplateField ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()


Template Property

Template Property
Namespaces ► Sitecore.Linq ► TemplateField ► Template
Declaration Syntax
C#
public Template Template { get; set; }


TemplateFieldType Property

TemplateFieldType Property
Namespaces ► Sitecore.Linq ► TemplateField ► TemplateFieldType
Declaration Syntax
C#
public TemplateFieldType TemplateFieldType { get; set; }


TemplateFieldTypeId Property

TemplateFieldTypeId Property
Namespaces ► Sitecore.Linq ► TemplateField ► TemplateFieldTypeId
Declaration Syntax
C#
public Guid TemplateFieldTypeId { get; set; }


TemplateId Property

TemplateId Property
Namespaces ► Sitecore.Linq ► TemplateField ► TemplateId
Declaration Syntax
C#
public Guid TemplateId { get; set; }


Updated Property

Updated Property
Namespaces ► Sitecore.Linq ► TemplateField ► Updated
Declaration Syntax
C#
public long Updated { get; set; }


UpdatedBy Property

UpdatedBy Property
Namespaces ► Sitecore.Linq ► TemplateField ► UpdatedBy
Declaration Syntax
C#
public string UpdatedBy { get; set; }


TemplateFieldType Class

TemplateFieldType Class
Namespaces ► Sitecore.Linq ► TemplateFieldType
Declaration Syntax
C#
public class TemplateFieldType : INotifyPropertyChanging,
    INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateFieldType()()() | Initializes a new instance of the TemplateFieldType class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | PropertyChanged |
 | PropertyChanging |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | TemplateFields |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TemplateFieldType


TemplateFieldType Constructor

TemplateFieldType Constructor
Namespaces ► Sitecore.Linq ► TemplateFieldType ► TemplateFieldType()()()
Initializes a new instance of the TemplateFieldType class
Declaration Syntax
C#
public TemplateFieldType()


Id Property

Id Property
Namespaces ► Sitecore.Linq ► TemplateFieldType ► Id
Declaration Syntax
C#
public Guid Id { get; set; }


Name Property

Name Property
Namespaces ► Sitecore.Linq ► TemplateFieldType ► Name
Declaration Syntax
C#
public string Name { get; set; }


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Linq ► TemplateFieldType ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Linq ► TemplateFieldType ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Linq ► TemplateFieldType ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Linq ► TemplateFieldType ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()


TemplateFields Property

TemplateFields Property
Namespaces ► Sitecore.Linq ► TemplateFieldType ► TemplateFields
Declaration Syntax
C#
public EntitySet<TemplateField> TemplateFields { get; set; }


Version Class

Version Class
Namespaces ► Sitecore.Linq ► Version
Declaration Syntax
C#
public class Version : INotifyPropertyChanging, INotifyPropertyChanged
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Version()()() | Initializes a new instance of the Version class
 | Created |
 | CreatedBy |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | Item |
 | ItemId |
 | Language |
 | LanguageId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PropertyChanged |
 | PropertyChanging |
 | Revisions |
 | SendPropertyChanged(String) |
 | SendPropertyChanging()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Updated |
 | UpdatedBy |
 | VersionName |
Inheritance Hierarchy
Object
Version


Version Constructor

Version Constructor
Namespaces ► Sitecore.Linq ► Version ► Version()()()
Initializes a new instance of the Version class
Declaration Syntax
C#
public Version()


Created Property

Created Property
Namespaces ► Sitecore.Linq ► Version ► Created
Declaration Syntax
C#
public long Created { get; set; }


CreatedBy Property

CreatedBy Property
Namespaces ► Sitecore.Linq ► Version ► CreatedBy
Declaration Syntax
C#
public string CreatedBy { get; set; }


Id Property

Id Property
Namespaces ► Sitecore.Linq ► Version ► Id
Declaration Syntax
C#
public Guid Id { get; set; }


Item Property

Item Property
Namespaces ► Sitecore.Linq ► Version ► Item
Declaration Syntax
C#
public Item Item { get; set; }


ItemId Property

ItemId Property
Namespaces ► Sitecore.Linq ► Version ► ItemId
Declaration Syntax
C#
public Guid ItemId { get; set; }


Language Property

Language Property
Namespaces ► Sitecore.Linq ► Version ► Language
Declaration Syntax
C#
public Language Language { get; set; }


LanguageId Property

LanguageId Property
Namespaces ► Sitecore.Linq ► Version ► LanguageId
Declaration Syntax
C#
public Guid LanguageId { get; set; }


PropertyChanged Event

PropertyChanged Event
Namespaces ► Sitecore.Linq ► Version ► PropertyChanged
Declaration Syntax
C#
public event PropertyChangedEventHandler PropertyChanged


PropertyChanging Event

PropertyChanging Event
Namespaces ► Sitecore.Linq ► Version ► PropertyChanging
Declaration Syntax
C#
public event PropertyChangingEventHandler PropertyChanging


Revisions Property

Revisions Property
Namespaces ► Sitecore.Linq ► Version ► Revisions
Declaration Syntax
C#
public EntitySet<Revision> Revisions { get; set; }


SendPropertyChanged Method (propertyName)

SendPropertyChanged Method (propertyName)
Namespaces ► Sitecore.Linq ► Version ► SendPropertyChanged(String)
Declaration Syntax
C#
protected virtual void SendPropertyChanged(
    string propertyName
)
Parameters
propertyName (String)


SendPropertyChanging Method

SendPropertyChanging Method
Namespaces ► Sitecore.Linq ► Version ► SendPropertyChanging()()()
Declaration Syntax
C#
protected virtual void SendPropertyChanging()


Updated Property

Updated Property
Namespaces ► Sitecore.Linq ► Version ► Updated
Declaration Syntax
C#
public long Updated { get; set; }


UpdatedBy Property

UpdatedBy Property
Namespaces ► Sitecore.Linq ► Version ► UpdatedBy
Declaration Syntax
C#
public string UpdatedBy { get; set; }


VersionName Property

VersionName Property
Namespaces ► Sitecore.Linq ► Version ► VersionName
Declaration Syntax
C#
public string VersionName { get; set; }


Sitecore.localhost Namespace

Sitecore.localhost Namespace
Namespaces ► Sitecore.localhost
Declaration Syntax
C#
namespace Sitecore.localhost
Types
All Types Classes Delegates
Icon | Type | Description
 | AboutCompletedEventArgs |
 | AboutCompletedEventHandler |
 | AddItemFromMasterCompletedEventArgs |
 | AddItemFromMasterCompletedEventHandler |
 | AddItemFromTemplateCompletedEventArgs |
 | AddItemFromTemplateCompletedEventHandler |
 | AddItemRevisionCompletedEventArgs |
 | AddItemRevisionCompletedEventHandler |
 | ApplyExtranetSecurityToChildrenCompletedEventArgs |
 | ApplyExtranetSecurityToChildrenCompletedEventHandler |
 | ApplySecurityToChildrenCompletedEventArgs |
 | ApplySecurityToChildrenCompletedEventHandler |
 | ApplySimpleUpdateCompletedEventArgs |
 | ApplySimpleUpdateCompletedEventHandler |
 | ApproveItemsCompletedEventArgs |
 | ApproveItemsCompletedEventHandler |
 | BackupDatabaseCompletedEventHandler |
 | BuildPackageCompletedEventArgs |
 | BuildPackageCompletedEventHandler |
 | CanLoginCompletedEventArgs |
 | CanLoginCompletedEventHandler |
 | CanPublishIncrementallyCompletedEventArgs |
 | CanPublishIncrementallyCompletedEventHandler |
 | CompactDatabaseCompletedEventArgs |
 | CompactDatabaseCompletedEventHandler |
 | CopyItemToCompletedEventArgs |
 | CopyItemToCompletedEventHandler |
 | CreateDocumentCompletedEventArgs |
 | CreateDocumentCompletedEventHandler |
 | CreateMasterCompletedEventArgs |
 | CreateMasterCompletedEventHandler |
 | CreateTemplateCompletedEventArgs |
 | CreateTemplateCompletedEventHandler |
 | DeleteChildrenCompletedEventArgs |
 | DeleteChildrenCompletedEventHandler |
 | DeleteDocumentCompletedEventHandler |
 | DeleteItemCompletedEventHandler |
 | DeleteItemVersionCompletedEventHandler |
 | DeleteItemVersionsCompletedEventHandler |
 | DuplicateCompletedEventArgs |
 | DuplicateCompletedEventHandler |
 | EmptyRecycleBinCompletedEventArgs |
 | EmptyRecycleBinCompletedEventHandler |
 | EndPreviewCompletedEventHandler |
 | EndWebEditCompletedEventHandler |
 | ExpandLinkedDatabasesCompletedEventHandler |
 | FindItemCompletedEventArgs |
 | FindItemCompletedEventHandler |
 | GetClientLanguageCompletedEventArgs |
 | GetClientLanguageCompletedEventHandler |
 | GetControlHtmlCompletedEventArgs |
 | GetControlHtmlCompletedEventHandler |
 | GetDotMenuCompletedEventArgs |
 | GetDotMenuCompletedEventHandler |
 | GetHomeItemCompletedEventArgs |
 | GetHomeItemCompletedEventHandler |
 | GetItemCompletedEventArgs |
 | GetItemCompletedEventHandler |
 | GetItemFieldCompletedEventArgs |
 | GetItemFieldCompletedEventHandler |
 | GetItemFieldsCompletedEventArgs |
 | GetItemFieldsCompletedEventHandler |
 | GetItemInfoCompletedEventArgs |
 | GetItemInfoCompletedEventHandler |
 | GetItemMastersCompletedEventArgs |
 | GetItemMastersCompletedEventHandler |
 | GetItemPathCompletedEventArgs |
 | GetItemPathCompletedEventHandler |
 | GetItemsInfoCompletedEventArgs |
 | GetItemsInfoCompletedEventHandler |
 | GetItemTreeCompletedEventArgs |
 | GetItemTreeCompletedEventHandler |
 | GetItemTreeXmlCompletedEventArgs |
 | GetItemTreeXmlCompletedEventHandler |
 | GetItemXmlCompletedEventArgs |
 | GetItemXmlCompletedEventHandler |
 | GetLocalizedStringCompletedEventArgs |
 | GetLocalizedStringCompletedEventHandler |
 | GetMediaInfoCompletedEventArgs |
 | GetMediaInfoCompletedEventHandler |
 | GetMediaItemsCompletedEventArgs |
 | GetMediaItemsCompletedEventHandler |
 | GetMethodHtmlCompletedEventArgs |
 | GetMethodHtmlCompletedEventHandler |
 | GetNewItemXmlCompletedEventArgs |
 | GetNewItemXmlCompletedEventHandler |
 | GetPackageInfoCompletedEventArgs |
 | GetPackageInfoCompletedEventHandler |
 | GetPackageXmlCompletedEventArgs |
 | GetPackageXmlCompletedEventHandler |
 | GetParentIDCompletedEventArgs |
 | GetParentIDCompletedEventHandler |
 | GetParentPathCompletedEventArgs |
 | GetParentPathCompletedEventHandler |
 | GetPublishingStatusCompletedEventArgs |
 | GetPublishingStatusCompletedEventHandler |
 | GetSiblingPathCompletedEventArgs |
 | GetSiblingPathCompletedEventHandler |
 | GetThreadErrorsCompletedEventArgs |
 | GetThreadErrorsCompletedEventHandler |
 | GetWebPageHtmlCompletedEventArgs |
 | GetWebPageHtmlCompletedEventHandler |
 | GetXslFileHtmlCompletedEventArgs |
 | GetXslFileHtmlCompletedEventHandler |
 | ImportPackageCompletedEventArgs |
 | ImportPackageCompletedEventHandler |
 | InsertItemTreeXmlCompletedEventArgs |
 | InsertItemTreeXmlCompletedEventHandler |
 | IsLoggedInCompletedEventArgs |
 | IsLoggedInCompletedEventHandler |
 | IsPreviewingCompletedEventArgs |
 | IsPreviewingCompletedEventHandler |
 | IsSessionValidCompletedEventArgs |
 | IsSessionValidCompletedEventHandler |
 | IsWebEditingCompletedEventArgs |
 | IsWebEditingCompletedEventHandler |
 | LoadLayoutCompletedEventArgs |
 | LoadLayoutCompletedEventHandler |
 | LoadPackageCompletedEventArgs |
 | LoadPackageCompletedEventHandler |
 | LoadPublishFileCompletedEventHandler |
 | LoadXslFileCompletedEventArgs |
 | LoadXslFileCompletedEventHandler |
 | LoginCompletedEventHandler |
 | LogoutCompletedEventHandler |
 | MoveItemToCompletedEventArgs |
 | MoveItemToCompletedEventHandler |
 | NewLayoutCompletedEventArgs |
 | NewLayoutCompletedEventHandler |
 | PingCompletedEventArgs |
 | PingCompletedEventHandler |
 | PublishCompletedEventArgs |
 | PublishCompletedEventHandler |
 | PublishItemCompletedEventArgs |
 | PublishItemCompletedEventHandler |
 | ReloadDatabaseCompletedEventHandler |
 | RenameItemCompletedEventHandler |
 | ResortChildrenCompletedEventHandler |
 | SaveDatabaseCompletedEventHandler |
 | SaveItemChangesCompletedEventArgs |
 | SaveItemChangesCompletedEventHandler |
 | SaveItemsCompletedEventHandler |
 | SaveLayoutCompletedEventArgs |
 | SaveLayoutCompletedEventHandler |
 | SavePackageCompletedEventHandler |
 | SavePageEditDataCompletedEventArgs |
 | SavePageEditDataCompletedEventHandler |
 | SaveXslFileCompletedEventArgs |
 | SaveXslFileCompletedEventHandler |
 | SetClientLanguageCompletedEventHandler |
 | SetLanguageCompletedEventHandler |
 | SitecoreClientAPI |
 | StartPreviewCompletedEventHandler |
 | StartWebEditCompletedEventHandler |
 | TidyHtmlCompletedEventArgs |
 | TidyHtmlCompletedEventHandler |
 | TidyHtmlExCompletedEventArgs |
 | TidyHtmlExCompletedEventHandler |
 | UpdateDocumentCompletedEventArgs |
 | UpdateDocumentCompletedEventHandler |
 | UpdateSortorderCompletedEventHandler |


AboutCompletedEventArgs Class

AboutCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► AboutCompletedEventArgs
Declaration Syntax
C#
public class AboutCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | AboutCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► AboutCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


AboutCompletedEventHandler Delegate

AboutCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► AboutCompletedEventHandler
Declaration Syntax
C#
public delegate void AboutCompletedEventHandler(
    Object sender,
    AboutCompletedEventArgs e
)
Parameters
sender (Object)
e (AboutCompletedEventArgs)
Remarks


AddItemFromMasterCompletedEventArgs Class

AddItemFromMasterCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► AddItemFromMasterCompletedEventArgs
Declaration Syntax
C#
public class AddItemFromMasterCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | AddItemFromMasterCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► AddItemFromMasterCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


AddItemFromMasterCompletedEventHandler Delegate

AddItemFromMasterCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► AddItemFromMasterCompletedEventHandler
Declaration Syntax
C#
public delegate void AddItemFromMasterCompletedEventHandler(
    Object sender,
    AddItemFromMasterCompletedEventArgs e
)
Parameters
sender (Object)
e (AddItemFromMasterCompletedEventArgs)
Remarks


AddItemFromTemplateCompletedEventArgs Class

AddItemFromTemplateCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► AddItemFromTemplateCompletedEventArgs
Declaration Syntax
C#
public class AddItemFromTemplateCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | AddItemFromTemplateCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► AddItemFromTemplateCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


AddItemFromTemplateCompletedEventHandler Delegate

AddItemFromTemplateCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► AddItemFromTemplateCompletedEventHandler
Declaration Syntax
C#
public delegate void AddItemFromTemplateCompletedEventHandler(
    Object sender,
    AddItemFromTemplateCompletedEventArgs e
)
Parameters
sender (Object)
e (AddItemFromTemplateCompletedEventArgs)
Remarks


AddItemRevisionCompletedEventArgs Class

AddItemRevisionCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► AddItemRevisionCompletedEventArgs
Declaration Syntax
C#
public class AddItemRevisionCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | AddItemRevisionCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► AddItemRevisionCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


AddItemRevisionCompletedEventHandler Delegate

AddItemRevisionCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► AddItemRevisionCompletedEventHandler
Declaration Syntax
C#
public delegate void AddItemRevisionCompletedEventHandler(
    Object sender,
    AddItemRevisionCompletedEventArgs e
)
Parameters
sender (Object)
e (AddItemRevisionCompletedEventArgs)
Remarks


ApplyExtranetSecurityToChildrenCompletedEventArgs Class

ApplyExtranetSecurityToChildrenCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► ApplyExtranetSecurityToChildrenCompletedEventArgs
Declaration Syntax
C#
public class ApplyExtranetSecurityToChildrenCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | ApplyExtranetSecurityToChildrenCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► ApplyExtranetSecurityToChildrenCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


ApplyExtranetSecurityToChildrenCompletedEventHandler Delegate

ApplyExtranetSecurityToChildrenCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► ApplyExtranetSecurityToChildrenCompletedEventHandler
Declaration Syntax
C#
public delegate void ApplyExtranetSecurityToChildrenCompletedEventHandler(
    Object sender,
    ApplyExtranetSecurityToChildrenCompletedEventArgs e
)
Parameters
sender (Object)
e (ApplyExtranetSecurityToChildrenCompletedEventArgs)
Remarks


ApplySecurityToChildrenCompletedEventArgs Class

ApplySecurityToChildrenCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► ApplySecurityToChildrenCompletedEventArgs
Declaration Syntax
C#
public class ApplySecurityToChildrenCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | ApplySecurityToChildrenCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► ApplySecurityToChildrenCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


ApplySecurityToChildrenCompletedEventHandler Delegate

ApplySecurityToChildrenCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► ApplySecurityToChildrenCompletedEventHandler
Declaration Syntax
C#
public delegate void ApplySecurityToChildrenCompletedEventHandler(
    Object sender,
    ApplySecurityToChildrenCompletedEventArgs e
)
Parameters
sender (Object)
e (ApplySecurityToChildrenCompletedEventArgs)
Remarks


ApplySimpleUpdateCompletedEventArgs Class

ApplySimpleUpdateCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► ApplySimpleUpdateCompletedEventArgs
Declaration Syntax
C#
public class ApplySimpleUpdateCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | ApplySimpleUpdateCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► ApplySimpleUpdateCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


ApplySimpleUpdateCompletedEventHandler Delegate

ApplySimpleUpdateCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► ApplySimpleUpdateCompletedEventHandler
Declaration Syntax
C#
public delegate void ApplySimpleUpdateCompletedEventHandler(
    Object sender,
    ApplySimpleUpdateCompletedEventArgs e
)
Parameters
sender (Object)
e (ApplySimpleUpdateCompletedEventArgs)
Remarks


ApproveItemsCompletedEventArgs Class

ApproveItemsCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► ApproveItemsCompletedEventArgs
Declaration Syntax
C#
public class ApproveItemsCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | ApproveItemsCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► ApproveItemsCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


ApproveItemsCompletedEventHandler Delegate

ApproveItemsCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► ApproveItemsCompletedEventHandler
Declaration Syntax
C#
public delegate void ApproveItemsCompletedEventHandler(
    Object sender,
    ApproveItemsCompletedEventArgs e
)
Parameters
sender (Object)
e (ApproveItemsCompletedEventArgs)
Remarks


BackupDatabaseCompletedEventHandler Delegate

BackupDatabaseCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► BackupDatabaseCompletedEventHandler
Declaration Syntax
C#
public delegate void BackupDatabaseCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


BuildPackageCompletedEventArgs Class

BuildPackageCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► BuildPackageCompletedEventArgs
Declaration Syntax
C#
public class BuildPackageCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | BuildPackageCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► BuildPackageCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


BuildPackageCompletedEventHandler Delegate

BuildPackageCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► BuildPackageCompletedEventHandler
Declaration Syntax
C#
public delegate void BuildPackageCompletedEventHandler(
    Object sender,
    BuildPackageCompletedEventArgs e
)
Parameters
sender (Object)
e (BuildPackageCompletedEventArgs)
Remarks


CanLoginCompletedEventArgs Class

CanLoginCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► CanLoginCompletedEventArgs
Declaration Syntax
C#
public class CanLoginCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | CanLoginCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► CanLoginCompletedEventArgs ► Result
Declaration Syntax
C#
public bool Result { get; }
Remarks


CanLoginCompletedEventHandler Delegate

CanLoginCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► CanLoginCompletedEventHandler
Declaration Syntax
C#
public delegate void CanLoginCompletedEventHandler(
    Object sender,
    CanLoginCompletedEventArgs e
)
Parameters
sender (Object)
e (CanLoginCompletedEventArgs)
Remarks


CanPublishIncrementallyCompletedEventArgs Class

CanPublishIncrementallyCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► CanPublishIncrementallyCompletedEventArgs
Declaration Syntax
C#
public class CanPublishIncrementallyCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | CanPublishIncrementallyCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► CanPublishIncrementallyCompletedEventArgs ► Result
Declaration Syntax
C#
public bool Result { get; }
Remarks


CanPublishIncrementallyCompletedEventHandler Delegate

CanPublishIncrementallyCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► CanPublishIncrementallyCompletedEventHandler
Declaration Syntax
C#
public delegate void CanPublishIncrementallyCompletedEventHandler(
    Object sender,
    CanPublishIncrementallyCompletedEventArgs e
)
Parameters
sender (Object)
e (CanPublishIncrementallyCompletedEventArgs)
Remarks


CompactDatabaseCompletedEventArgs Class

CompactDatabaseCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► CompactDatabaseCompletedEventArgs
Declaration Syntax
C#
public class CompactDatabaseCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | CompactDatabaseCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► CompactDatabaseCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


CompactDatabaseCompletedEventHandler Delegate

CompactDatabaseCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► CompactDatabaseCompletedEventHandler
Declaration Syntax
C#
public delegate void CompactDatabaseCompletedEventHandler(
    Object sender,
    CompactDatabaseCompletedEventArgs e
)
Parameters
sender (Object)
e (CompactDatabaseCompletedEventArgs)
Remarks


CopyItemToCompletedEventArgs Class

CopyItemToCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► CopyItemToCompletedEventArgs
Declaration Syntax
C#
public class CopyItemToCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | CopyItemToCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► CopyItemToCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


CopyItemToCompletedEventHandler Delegate

CopyItemToCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► CopyItemToCompletedEventHandler
Declaration Syntax
C#
public delegate void CopyItemToCompletedEventHandler(
    Object sender,
    CopyItemToCompletedEventArgs e
)
Parameters
sender (Object)
e (CopyItemToCompletedEventArgs)
Remarks


CreateDocumentCompletedEventArgs Class

CreateDocumentCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► CreateDocumentCompletedEventArgs
Declaration Syntax
C#
public class CreateDocumentCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | CreateDocumentCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► CreateDocumentCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


CreateDocumentCompletedEventHandler Delegate

CreateDocumentCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► CreateDocumentCompletedEventHandler
Declaration Syntax
C#
public delegate void CreateDocumentCompletedEventHandler(
    Object sender,
    CreateDocumentCompletedEventArgs e
)
Parameters
sender (Object)
e (CreateDocumentCompletedEventArgs)
Remarks


CreateMasterCompletedEventArgs Class

CreateMasterCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► CreateMasterCompletedEventArgs
Declaration Syntax
C#
public class CreateMasterCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | CreateMasterCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► CreateMasterCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


CreateMasterCompletedEventHandler Delegate

CreateMasterCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► CreateMasterCompletedEventHandler
Declaration Syntax
C#
public delegate void CreateMasterCompletedEventHandler(
    Object sender,
    CreateMasterCompletedEventArgs e
)
Parameters
sender (Object)
e (CreateMasterCompletedEventArgs)
Remarks


CreateTemplateCompletedEventArgs Class

CreateTemplateCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► CreateTemplateCompletedEventArgs
Declaration Syntax
C#
public class CreateTemplateCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | CreateTemplateCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► CreateTemplateCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


CreateTemplateCompletedEventHandler Delegate

CreateTemplateCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► CreateTemplateCompletedEventHandler
Declaration Syntax
C#
public delegate void CreateTemplateCompletedEventHandler(
    Object sender,
    CreateTemplateCompletedEventArgs e
)
Parameters
sender (Object)
e (CreateTemplateCompletedEventArgs)
Remarks


DeleteChildrenCompletedEventArgs Class

DeleteChildrenCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► DeleteChildrenCompletedEventArgs
Declaration Syntax
C#
public class DeleteChildrenCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | DeleteChildrenCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► DeleteChildrenCompletedEventArgs ► Result
Declaration Syntax
C#
public int Result { get; }
Remarks


DeleteChildrenCompletedEventHandler Delegate

DeleteChildrenCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► DeleteChildrenCompletedEventHandler
Declaration Syntax
C#
public delegate void DeleteChildrenCompletedEventHandler(
    Object sender,
    DeleteChildrenCompletedEventArgs e
)
Parameters
sender (Object)
e (DeleteChildrenCompletedEventArgs)
Remarks


DeleteDocumentCompletedEventHandler Delegate

DeleteDocumentCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► DeleteDocumentCompletedEventHandler
Declaration Syntax
C#
public delegate void DeleteDocumentCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


DeleteItemCompletedEventHandler Delegate

DeleteItemCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► DeleteItemCompletedEventHandler
Declaration Syntax
C#
public delegate void DeleteItemCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


DeleteItemVersionCompletedEventHandler Delegate

DeleteItemVersionCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► DeleteItemVersionCompletedEventHandler
Declaration Syntax
C#
public delegate void DeleteItemVersionCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


DeleteItemVersionsCompletedEventHandler Delegate

DeleteItemVersionsCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► DeleteItemVersionsCompletedEventHandler
Declaration Syntax
C#
public delegate void DeleteItemVersionsCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


DuplicateCompletedEventArgs Class

DuplicateCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► DuplicateCompletedEventArgs
Declaration Syntax
C#
public class DuplicateCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | DuplicateCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► DuplicateCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


DuplicateCompletedEventHandler Delegate

DuplicateCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► DuplicateCompletedEventHandler
Declaration Syntax
C#
public delegate void DuplicateCompletedEventHandler(
    Object sender,
    DuplicateCompletedEventArgs e
)
Parameters
sender (Object)
e (DuplicateCompletedEventArgs)
Remarks


EmptyRecycleBinCompletedEventArgs Class

EmptyRecycleBinCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► EmptyRecycleBinCompletedEventArgs
Declaration Syntax
C#
public class EmptyRecycleBinCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | EmptyRecycleBinCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► EmptyRecycleBinCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


EmptyRecycleBinCompletedEventHandler Delegate

EmptyRecycleBinCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► EmptyRecycleBinCompletedEventHandler
Declaration Syntax
C#
public delegate void EmptyRecycleBinCompletedEventHandler(
    Object sender,
    EmptyRecycleBinCompletedEventArgs e
)
Parameters
sender (Object)
e (EmptyRecycleBinCompletedEventArgs)
Remarks


EndPreviewCompletedEventHandler Delegate

EndPreviewCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► EndPreviewCompletedEventHandler
Declaration Syntax
C#
public delegate void EndPreviewCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


EndWebEditCompletedEventHandler Delegate

EndWebEditCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► EndWebEditCompletedEventHandler
Declaration Syntax
C#
public delegate void EndWebEditCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


ExpandLinkedDatabasesCompletedEventHandler Delegate

ExpandLinkedDatabasesCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► ExpandLinkedDatabasesCompletedEventHandler
Declaration Syntax
C#
public delegate void ExpandLinkedDatabasesCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


FindItemCompletedEventArgs Class

FindItemCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► FindItemCompletedEventArgs
Declaration Syntax
C#
public class FindItemCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | FindItemCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► FindItemCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


FindItemCompletedEventHandler Delegate

FindItemCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► FindItemCompletedEventHandler
Declaration Syntax
C#
public delegate void FindItemCompletedEventHandler(
    Object sender,
    FindItemCompletedEventArgs e
)
Parameters
sender (Object)
e (FindItemCompletedEventArgs)
Remarks


GetClientLanguageCompletedEventArgs Class

GetClientLanguageCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetClientLanguageCompletedEventArgs
Declaration Syntax
C#
public class GetClientLanguageCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetClientLanguageCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetClientLanguageCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


GetClientLanguageCompletedEventHandler Delegate

GetClientLanguageCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetClientLanguageCompletedEventHandler
Declaration Syntax
C#
public delegate void GetClientLanguageCompletedEventHandler(
    Object sender,
    GetClientLanguageCompletedEventArgs e
)
Parameters
sender (Object)
e (GetClientLanguageCompletedEventArgs)
Remarks


GetControlHtmlCompletedEventArgs Class

GetControlHtmlCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetControlHtmlCompletedEventArgs
Declaration Syntax
C#
public class GetControlHtmlCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetControlHtmlCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetControlHtmlCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


GetControlHtmlCompletedEventHandler Delegate

GetControlHtmlCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetControlHtmlCompletedEventHandler
Declaration Syntax
C#
public delegate void GetControlHtmlCompletedEventHandler(
    Object sender,
    GetControlHtmlCompletedEventArgs e
)
Parameters
sender (Object)
e (GetControlHtmlCompletedEventArgs)
Remarks


GetDotMenuCompletedEventArgs Class

GetDotMenuCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetDotMenuCompletedEventArgs
Declaration Syntax
C#
public class GetDotMenuCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetDotMenuCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetDotMenuCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


GetDotMenuCompletedEventHandler Delegate

GetDotMenuCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetDotMenuCompletedEventHandler
Declaration Syntax
C#
public delegate void GetDotMenuCompletedEventHandler(
    Object sender,
    GetDotMenuCompletedEventArgs e
)
Parameters
sender (Object)
e (GetDotMenuCompletedEventArgs)
Remarks


GetHomeItemCompletedEventArgs Class

GetHomeItemCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetHomeItemCompletedEventArgs
Declaration Syntax
C#
public class GetHomeItemCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetHomeItemCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetHomeItemCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


GetHomeItemCompletedEventHandler Delegate

GetHomeItemCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetHomeItemCompletedEventHandler
Declaration Syntax
C#
public delegate void GetHomeItemCompletedEventHandler(
    Object sender,
    GetHomeItemCompletedEventArgs e
)
Parameters
sender (Object)
e (GetHomeItemCompletedEventArgs)
Remarks


GetItemCompletedEventArgs Class

GetItemCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetItemCompletedEventArgs
Declaration Syntax
C#
public class GetItemCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetItemCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetItemCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


GetItemCompletedEventHandler Delegate

GetItemCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetItemCompletedEventHandler
Declaration Syntax
C#
public delegate void GetItemCompletedEventHandler(
    Object sender,
    GetItemCompletedEventArgs e
)
Parameters
sender (Object)
e (GetItemCompletedEventArgs)
Remarks


GetItemFieldCompletedEventArgs Class

GetItemFieldCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetItemFieldCompletedEventArgs
Declaration Syntax
C#
public class GetItemFieldCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetItemFieldCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetItemFieldCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


GetItemFieldCompletedEventHandler Delegate

GetItemFieldCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetItemFieldCompletedEventHandler
Declaration Syntax
C#
public delegate void GetItemFieldCompletedEventHandler(
    Object sender,
    GetItemFieldCompletedEventArgs e
)
Parameters
sender (Object)
e (GetItemFieldCompletedEventArgs)
Remarks


GetItemFieldsCompletedEventArgs Class

GetItemFieldsCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetItemFieldsCompletedEventArgs
Declaration Syntax
C#
public class GetItemFieldsCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetItemFieldsCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetItemFieldsCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


GetItemFieldsCompletedEventHandler Delegate

GetItemFieldsCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetItemFieldsCompletedEventHandler
Declaration Syntax
C#
public delegate void GetItemFieldsCompletedEventHandler(
    Object sender,
    GetItemFieldsCompletedEventArgs e
)
Parameters
sender (Object)
e (GetItemFieldsCompletedEventArgs)
Remarks


GetItemInfoCompletedEventArgs Class

GetItemInfoCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetItemInfoCompletedEventArgs
Declaration Syntax
C#
public class GetItemInfoCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetItemInfoCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetItemInfoCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


GetItemInfoCompletedEventHandler Delegate

GetItemInfoCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetItemInfoCompletedEventHandler
Declaration Syntax
C#
public delegate void GetItemInfoCompletedEventHandler(
    Object sender,
    GetItemInfoCompletedEventArgs e
)
Parameters
sender (Object)
e (GetItemInfoCompletedEventArgs)
Remarks


GetItemMastersCompletedEventArgs Class

GetItemMastersCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetItemMastersCompletedEventArgs
Declaration Syntax
C#
public class GetItemMastersCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetItemMastersCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetItemMastersCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


GetItemMastersCompletedEventHandler Delegate

GetItemMastersCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetItemMastersCompletedEventHandler
Declaration Syntax
C#
public delegate void GetItemMastersCompletedEventHandler(
    Object sender,
    GetItemMastersCompletedEventArgs e
)
Parameters
sender (Object)
e (GetItemMastersCompletedEventArgs)
Remarks


GetItemPathCompletedEventArgs Class

GetItemPathCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetItemPathCompletedEventArgs
Declaration Syntax
C#
public class GetItemPathCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetItemPathCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetItemPathCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


GetItemPathCompletedEventHandler Delegate

GetItemPathCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetItemPathCompletedEventHandler
Declaration Syntax
C#
public delegate void GetItemPathCompletedEventHandler(
    Object sender,
    GetItemPathCompletedEventArgs e
)
Parameters
sender (Object)
e (GetItemPathCompletedEventArgs)
Remarks


GetItemsInfoCompletedEventArgs Class

GetItemsInfoCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetItemsInfoCompletedEventArgs
Declaration Syntax
C#
public class GetItemsInfoCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetItemsInfoCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetItemsInfoCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


GetItemsInfoCompletedEventHandler Delegate

GetItemsInfoCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetItemsInfoCompletedEventHandler
Declaration Syntax
C#
public delegate void GetItemsInfoCompletedEventHandler(
    Object sender,
    GetItemsInfoCompletedEventArgs e
)
Parameters
sender (Object)
e (GetItemsInfoCompletedEventArgs)
Remarks


GetItemTreeCompletedEventArgs Class

GetItemTreeCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetItemTreeCompletedEventArgs
Declaration Syntax
C#
public class GetItemTreeCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetItemTreeCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetItemTreeCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


GetItemTreeCompletedEventHandler Delegate

GetItemTreeCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetItemTreeCompletedEventHandler
Declaration Syntax
C#
public delegate void GetItemTreeCompletedEventHandler(
    Object sender,
    GetItemTreeCompletedEventArgs e
)
Parameters
sender (Object)
e (GetItemTreeCompletedEventArgs)
Remarks


GetItemTreeXmlCompletedEventArgs Class

GetItemTreeXmlCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetItemTreeXmlCompletedEventArgs
Declaration Syntax
C#
public class GetItemTreeXmlCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetItemTreeXmlCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetItemTreeXmlCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


GetItemTreeXmlCompletedEventHandler Delegate

GetItemTreeXmlCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetItemTreeXmlCompletedEventHandler
Declaration Syntax
C#
public delegate void GetItemTreeXmlCompletedEventHandler(
    Object sender,
    GetItemTreeXmlCompletedEventArgs e
)
Parameters
sender (Object)
e (GetItemTreeXmlCompletedEventArgs)
Remarks


GetItemXmlCompletedEventArgs Class

GetItemXmlCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetItemXmlCompletedEventArgs
Declaration Syntax
C#
public class GetItemXmlCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetItemXmlCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetItemXmlCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


GetItemXmlCompletedEventHandler Delegate

GetItemXmlCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetItemXmlCompletedEventHandler
Declaration Syntax
C#
public delegate void GetItemXmlCompletedEventHandler(
    Object sender,
    GetItemXmlCompletedEventArgs e
)
Parameters
sender (Object)
e (GetItemXmlCompletedEventArgs)
Remarks


GetLocalizedStringCompletedEventArgs Class

GetLocalizedStringCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetLocalizedStringCompletedEventArgs
Declaration Syntax
C#
public class GetLocalizedStringCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetLocalizedStringCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetLocalizedStringCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


GetLocalizedStringCompletedEventHandler Delegate

GetLocalizedStringCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetLocalizedStringCompletedEventHandler
Declaration Syntax
C#
public delegate void GetLocalizedStringCompletedEventHandler(
    Object sender,
    GetLocalizedStringCompletedEventArgs e
)
Parameters
sender (Object)
e (GetLocalizedStringCompletedEventArgs)
Remarks


GetMediaInfoCompletedEventArgs Class

GetMediaInfoCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetMediaInfoCompletedEventArgs
Declaration Syntax
C#
public class GetMediaInfoCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetMediaInfoCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetMediaInfoCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


GetMediaInfoCompletedEventHandler Delegate

GetMediaInfoCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetMediaInfoCompletedEventHandler
Declaration Syntax
C#
public delegate void GetMediaInfoCompletedEventHandler(
    Object sender,
    GetMediaInfoCompletedEventArgs e
)
Parameters
sender (Object)
e (GetMediaInfoCompletedEventArgs)
Remarks


GetMediaItemsCompletedEventArgs Class

GetMediaItemsCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetMediaItemsCompletedEventArgs
Declaration Syntax
C#
public class GetMediaItemsCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetMediaItemsCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetMediaItemsCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


GetMediaItemsCompletedEventHandler Delegate

GetMediaItemsCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetMediaItemsCompletedEventHandler
Declaration Syntax
C#
public delegate void GetMediaItemsCompletedEventHandler(
    Object sender,
    GetMediaItemsCompletedEventArgs e
)
Parameters
sender (Object)
e (GetMediaItemsCompletedEventArgs)
Remarks


GetMethodHtmlCompletedEventArgs Class

GetMethodHtmlCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetMethodHtmlCompletedEventArgs
Declaration Syntax
C#
public class GetMethodHtmlCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetMethodHtmlCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetMethodHtmlCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


GetMethodHtmlCompletedEventHandler Delegate

GetMethodHtmlCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetMethodHtmlCompletedEventHandler
Declaration Syntax
C#
public delegate void GetMethodHtmlCompletedEventHandler(
    Object sender,
    GetMethodHtmlCompletedEventArgs e
)
Parameters
sender (Object)
e (GetMethodHtmlCompletedEventArgs)
Remarks


GetNewItemXmlCompletedEventArgs Class

GetNewItemXmlCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetNewItemXmlCompletedEventArgs
Declaration Syntax
C#
public class GetNewItemXmlCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetNewItemXmlCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetNewItemXmlCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


GetNewItemXmlCompletedEventHandler Delegate

GetNewItemXmlCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetNewItemXmlCompletedEventHandler
Declaration Syntax
C#
public delegate void GetNewItemXmlCompletedEventHandler(
    Object sender,
    GetNewItemXmlCompletedEventArgs e
)
Parameters
sender (Object)
e (GetNewItemXmlCompletedEventArgs)
Remarks


GetPackageInfoCompletedEventArgs Class

GetPackageInfoCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetPackageInfoCompletedEventArgs
Declaration Syntax
C#
public class GetPackageInfoCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetPackageInfoCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetPackageInfoCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


GetPackageInfoCompletedEventHandler Delegate

GetPackageInfoCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetPackageInfoCompletedEventHandler
Declaration Syntax
C#
public delegate void GetPackageInfoCompletedEventHandler(
    Object sender,
    GetPackageInfoCompletedEventArgs e
)
Parameters
sender (Object)
e (GetPackageInfoCompletedEventArgs)
Remarks


GetPackageXmlCompletedEventArgs Class

GetPackageXmlCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetPackageXmlCompletedEventArgs
Declaration Syntax
C#
public class GetPackageXmlCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetPackageXmlCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetPackageXmlCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


GetPackageXmlCompletedEventHandler Delegate

GetPackageXmlCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetPackageXmlCompletedEventHandler
Declaration Syntax
C#
public delegate void GetPackageXmlCompletedEventHandler(
    Object sender,
    GetPackageXmlCompletedEventArgs e
)
Parameters
sender (Object)
e (GetPackageXmlCompletedEventArgs)
Remarks


GetParentIDCompletedEventArgs Class

GetParentIDCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetParentIDCompletedEventArgs
Declaration Syntax
C#
public class GetParentIDCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetParentIDCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetParentIDCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


GetParentIDCompletedEventHandler Delegate

GetParentIDCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetParentIDCompletedEventHandler
Declaration Syntax
C#
public delegate void GetParentIDCompletedEventHandler(
    Object sender,
    GetParentIDCompletedEventArgs e
)
Parameters
sender (Object)
e (GetParentIDCompletedEventArgs)
Remarks


GetParentPathCompletedEventArgs Class

GetParentPathCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetParentPathCompletedEventArgs
Declaration Syntax
C#
public class GetParentPathCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetParentPathCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetParentPathCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


GetParentPathCompletedEventHandler Delegate

GetParentPathCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetParentPathCompletedEventHandler
Declaration Syntax
C#
public delegate void GetParentPathCompletedEventHandler(
    Object sender,
    GetParentPathCompletedEventArgs e
)
Parameters
sender (Object)
e (GetParentPathCompletedEventArgs)
Remarks


GetPublishingStatusCompletedEventArgs Class

GetPublishingStatusCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetPublishingStatusCompletedEventArgs
Declaration Syntax
C#
public class GetPublishingStatusCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetPublishingStatusCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetPublishingStatusCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


GetPublishingStatusCompletedEventHandler Delegate

GetPublishingStatusCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetPublishingStatusCompletedEventHandler
Declaration Syntax
C#
public delegate void GetPublishingStatusCompletedEventHandler(
    Object sender,
    GetPublishingStatusCompletedEventArgs e
)
Parameters
sender (Object)
e (GetPublishingStatusCompletedEventArgs)
Remarks


GetSiblingPathCompletedEventArgs Class

GetSiblingPathCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetSiblingPathCompletedEventArgs
Declaration Syntax
C#
public class GetSiblingPathCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetSiblingPathCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetSiblingPathCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


GetSiblingPathCompletedEventHandler Delegate

GetSiblingPathCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetSiblingPathCompletedEventHandler
Declaration Syntax
C#
public delegate void GetSiblingPathCompletedEventHandler(
    Object sender,
    GetSiblingPathCompletedEventArgs e
)
Parameters
sender (Object)
e (GetSiblingPathCompletedEventArgs)
Remarks


GetThreadErrorsCompletedEventArgs Class

GetThreadErrorsCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetThreadErrorsCompletedEventArgs
Declaration Syntax
C#
public class GetThreadErrorsCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetThreadErrorsCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetThreadErrorsCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


GetThreadErrorsCompletedEventHandler Delegate

GetThreadErrorsCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetThreadErrorsCompletedEventHandler
Declaration Syntax
C#
public delegate void GetThreadErrorsCompletedEventHandler(
    Object sender,
    GetThreadErrorsCompletedEventArgs e
)
Parameters
sender (Object)
e (GetThreadErrorsCompletedEventArgs)
Remarks


GetWebPageHtmlCompletedEventArgs Class

GetWebPageHtmlCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetWebPageHtmlCompletedEventArgs
Declaration Syntax
C#
public class GetWebPageHtmlCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetWebPageHtmlCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetWebPageHtmlCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


GetWebPageHtmlCompletedEventHandler Delegate

GetWebPageHtmlCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetWebPageHtmlCompletedEventHandler
Declaration Syntax
C#
public delegate void GetWebPageHtmlCompletedEventHandler(
    Object sender,
    GetWebPageHtmlCompletedEventArgs e
)
Parameters
sender (Object)
e (GetWebPageHtmlCompletedEventArgs)
Remarks


GetXslFileHtmlCompletedEventArgs Class

GetXslFileHtmlCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► GetXslFileHtmlCompletedEventArgs
Declaration Syntax
C#
public class GetXslFileHtmlCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | GetXslFileHtmlCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► GetXslFileHtmlCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


GetXslFileHtmlCompletedEventHandler Delegate

GetXslFileHtmlCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► GetXslFileHtmlCompletedEventHandler
Declaration Syntax
C#
public delegate void GetXslFileHtmlCompletedEventHandler(
    Object sender,
    GetXslFileHtmlCompletedEventArgs e
)
Parameters
sender (Object)
e (GetXslFileHtmlCompletedEventArgs)
Remarks


ImportPackageCompletedEventArgs Class

ImportPackageCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► ImportPackageCompletedEventArgs
Declaration Syntax
C#
public class ImportPackageCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | ImportPackageCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► ImportPackageCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


ImportPackageCompletedEventHandler Delegate

ImportPackageCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► ImportPackageCompletedEventHandler
Declaration Syntax
C#
public delegate void ImportPackageCompletedEventHandler(
    Object sender,
    ImportPackageCompletedEventArgs e
)
Parameters
sender (Object)
e (ImportPackageCompletedEventArgs)
Remarks


InsertItemTreeXmlCompletedEventArgs Class

InsertItemTreeXmlCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► InsertItemTreeXmlCompletedEventArgs
Declaration Syntax
C#
public class InsertItemTreeXmlCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | InsertItemTreeXmlCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► InsertItemTreeXmlCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


InsertItemTreeXmlCompletedEventHandler Delegate

InsertItemTreeXmlCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► InsertItemTreeXmlCompletedEventHandler
Declaration Syntax
C#
public delegate void InsertItemTreeXmlCompletedEventHandler(
    Object sender,
    InsertItemTreeXmlCompletedEventArgs e
)
Parameters
sender (Object)
e (InsertItemTreeXmlCompletedEventArgs)
Remarks


IsLoggedInCompletedEventArgs Class

IsLoggedInCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► IsLoggedInCompletedEventArgs
Declaration Syntax
C#
public class IsLoggedInCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | IsLoggedInCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► IsLoggedInCompletedEventArgs ► Result
Declaration Syntax
C#
public bool Result { get; }
Remarks


IsLoggedInCompletedEventHandler Delegate

IsLoggedInCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► IsLoggedInCompletedEventHandler
Declaration Syntax
C#
public delegate void IsLoggedInCompletedEventHandler(
    Object sender,
    IsLoggedInCompletedEventArgs e
)
Parameters
sender (Object)
e (IsLoggedInCompletedEventArgs)
Remarks


IsPreviewingCompletedEventArgs Class

IsPreviewingCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► IsPreviewingCompletedEventArgs
Declaration Syntax
C#
public class IsPreviewingCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | IsPreviewingCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► IsPreviewingCompletedEventArgs ► Result
Declaration Syntax
C#
public bool Result { get; }
Remarks


IsPreviewingCompletedEventHandler Delegate

IsPreviewingCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► IsPreviewingCompletedEventHandler
Declaration Syntax
C#
public delegate void IsPreviewingCompletedEventHandler(
    Object sender,
    IsPreviewingCompletedEventArgs e
)
Parameters
sender (Object)
e (IsPreviewingCompletedEventArgs)
Remarks


IsSessionValidCompletedEventArgs Class

IsSessionValidCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► IsSessionValidCompletedEventArgs
Declaration Syntax
C#
public class IsSessionValidCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | IsSessionValidCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► IsSessionValidCompletedEventArgs ► Result
Declaration Syntax
C#
public bool Result { get; }
Remarks


IsSessionValidCompletedEventHandler Delegate

IsSessionValidCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► IsSessionValidCompletedEventHandler
Declaration Syntax
C#
public delegate void IsSessionValidCompletedEventHandler(
    Object sender,
    IsSessionValidCompletedEventArgs e
)
Parameters
sender (Object)
e (IsSessionValidCompletedEventArgs)
Remarks


IsWebEditingCompletedEventArgs Class

IsWebEditingCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► IsWebEditingCompletedEventArgs
Declaration Syntax
C#
public class IsWebEditingCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | IsWebEditingCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► IsWebEditingCompletedEventArgs ► Result
Declaration Syntax
C#
public bool Result { get; }
Remarks


IsWebEditingCompletedEventHandler Delegate

IsWebEditingCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► IsWebEditingCompletedEventHandler
Declaration Syntax
C#
public delegate void IsWebEditingCompletedEventHandler(
    Object sender,
    IsWebEditingCompletedEventArgs e
)
Parameters
sender (Object)
e (IsWebEditingCompletedEventArgs)
Remarks


LoadLayoutCompletedEventArgs Class

LoadLayoutCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► LoadLayoutCompletedEventArgs
Declaration Syntax
C#
public class LoadLayoutCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | LoadLayoutCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► LoadLayoutCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


LoadLayoutCompletedEventHandler Delegate

LoadLayoutCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► LoadLayoutCompletedEventHandler
Declaration Syntax
C#
public delegate void LoadLayoutCompletedEventHandler(
    Object sender,
    LoadLayoutCompletedEventArgs e
)
Parameters
sender (Object)
e (LoadLayoutCompletedEventArgs)
Remarks


LoadPackageCompletedEventArgs Class

LoadPackageCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► LoadPackageCompletedEventArgs
Declaration Syntax
C#
public class LoadPackageCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | LoadPackageCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► LoadPackageCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


LoadPackageCompletedEventHandler Delegate

LoadPackageCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► LoadPackageCompletedEventHandler
Declaration Syntax
C#
public delegate void LoadPackageCompletedEventHandler(
    Object sender,
    LoadPackageCompletedEventArgs e
)
Parameters
sender (Object)
e (LoadPackageCompletedEventArgs)
Remarks


LoadPublishFileCompletedEventHandler Delegate

LoadPublishFileCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► LoadPublishFileCompletedEventHandler
Declaration Syntax
C#
public delegate void LoadPublishFileCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


LoadXslFileCompletedEventArgs Class

LoadXslFileCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► LoadXslFileCompletedEventArgs
Declaration Syntax
C#
public class LoadXslFileCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | LoadXslFileCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► LoadXslFileCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


LoadXslFileCompletedEventHandler Delegate

LoadXslFileCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► LoadXslFileCompletedEventHandler
Declaration Syntax
C#
public delegate void LoadXslFileCompletedEventHandler(
    Object sender,
    LoadXslFileCompletedEventArgs e
)
Parameters
sender (Object)
e (LoadXslFileCompletedEventArgs)
Remarks


LoginCompletedEventHandler Delegate

LoginCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► LoginCompletedEventHandler
Declaration Syntax
C#
public delegate void LoginCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


LogoutCompletedEventHandler Delegate

LogoutCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► LogoutCompletedEventHandler
Declaration Syntax
C#
public delegate void LogoutCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


MoveItemToCompletedEventArgs Class

MoveItemToCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► MoveItemToCompletedEventArgs
Declaration Syntax
C#
public class MoveItemToCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | MoveItemToCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► MoveItemToCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


MoveItemToCompletedEventHandler Delegate

MoveItemToCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► MoveItemToCompletedEventHandler
Declaration Syntax
C#
public delegate void MoveItemToCompletedEventHandler(
    Object sender,
    MoveItemToCompletedEventArgs e
)
Parameters
sender (Object)
e (MoveItemToCompletedEventArgs)
Remarks


NewLayoutCompletedEventArgs Class

NewLayoutCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► NewLayoutCompletedEventArgs
Declaration Syntax
C#
public class NewLayoutCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | NewLayoutCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► NewLayoutCompletedEventArgs ► Result
Declaration Syntax
C#
public XmlNode Result { get; }
Remarks


NewLayoutCompletedEventHandler Delegate

NewLayoutCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► NewLayoutCompletedEventHandler
Declaration Syntax
C#
public delegate void NewLayoutCompletedEventHandler(
    Object sender,
    NewLayoutCompletedEventArgs e
)
Parameters
sender (Object)
e (NewLayoutCompletedEventArgs)
Remarks


PingCompletedEventArgs Class

PingCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► PingCompletedEventArgs
Declaration Syntax
C#
public class PingCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | PingCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► PingCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


PingCompletedEventHandler Delegate

PingCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► PingCompletedEventHandler
Declaration Syntax
C#
public delegate void PingCompletedEventHandler(
    Object sender,
    PingCompletedEventArgs e
)
Parameters
sender (Object)
e (PingCompletedEventArgs)
Remarks


PublishCompletedEventArgs Class

PublishCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► PublishCompletedEventArgs
Declaration Syntax
C#
public class PublishCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | PublishCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► PublishCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


PublishCompletedEventHandler Delegate

PublishCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► PublishCompletedEventHandler
Declaration Syntax
C#
public delegate void PublishCompletedEventHandler(
    Object sender,
    PublishCompletedEventArgs e
)
Parameters
sender (Object)
e (PublishCompletedEventArgs)
Remarks


PublishItemCompletedEventArgs Class

PublishItemCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► PublishItemCompletedEventArgs
Declaration Syntax
C#
public class PublishItemCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | PublishItemCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► PublishItemCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


PublishItemCompletedEventHandler Delegate

PublishItemCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► PublishItemCompletedEventHandler
Declaration Syntax
C#
public delegate void PublishItemCompletedEventHandler(
    Object sender,
    PublishItemCompletedEventArgs e
)
Parameters
sender (Object)
e (PublishItemCompletedEventArgs)
Remarks


ReloadDatabaseCompletedEventHandler Delegate

ReloadDatabaseCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► ReloadDatabaseCompletedEventHandler
Declaration Syntax
C#
public delegate void ReloadDatabaseCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


RenameItemCompletedEventHandler Delegate

RenameItemCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► RenameItemCompletedEventHandler
Declaration Syntax
C#
public delegate void RenameItemCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


ResortChildrenCompletedEventHandler Delegate

ResortChildrenCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► ResortChildrenCompletedEventHandler
Declaration Syntax
C#
public delegate void ResortChildrenCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


SaveDatabaseCompletedEventHandler Delegate

SaveDatabaseCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► SaveDatabaseCompletedEventHandler
Declaration Syntax
C#
public delegate void SaveDatabaseCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


SaveItemChangesCompletedEventArgs Class

SaveItemChangesCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► SaveItemChangesCompletedEventArgs
Declaration Syntax
C#
public class SaveItemChangesCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | SaveItemChangesCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► SaveItemChangesCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


SaveItemChangesCompletedEventHandler Delegate

SaveItemChangesCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► SaveItemChangesCompletedEventHandler
Declaration Syntax
C#
public delegate void SaveItemChangesCompletedEventHandler(
    Object sender,
    SaveItemChangesCompletedEventArgs e
)
Parameters
sender (Object)
e (SaveItemChangesCompletedEventArgs)
Remarks


SaveItemsCompletedEventHandler Delegate

SaveItemsCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► SaveItemsCompletedEventHandler
Declaration Syntax
C#
public delegate void SaveItemsCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


SaveLayoutCompletedEventArgs Class

SaveLayoutCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► SaveLayoutCompletedEventArgs
Declaration Syntax
C#
public class SaveLayoutCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | SaveLayoutCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► SaveLayoutCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


SaveLayoutCompletedEventHandler Delegate

SaveLayoutCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► SaveLayoutCompletedEventHandler
Declaration Syntax
C#
public delegate void SaveLayoutCompletedEventHandler(
    Object sender,
    SaveLayoutCompletedEventArgs e
)
Parameters
sender (Object)
e (SaveLayoutCompletedEventArgs)
Remarks


SavePackageCompletedEventHandler Delegate

SavePackageCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► SavePackageCompletedEventHandler
Declaration Syntax
C#
public delegate void SavePackageCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


SavePageEditDataCompletedEventArgs Class

SavePageEditDataCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► SavePageEditDataCompletedEventArgs
Declaration Syntax
C#
public class SavePageEditDataCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | SavePageEditDataCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► SavePageEditDataCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


SavePageEditDataCompletedEventHandler Delegate

SavePageEditDataCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► SavePageEditDataCompletedEventHandler
Declaration Syntax
C#
public delegate void SavePageEditDataCompletedEventHandler(
    Object sender,
    SavePageEditDataCompletedEventArgs e
)
Parameters
sender (Object)
e (SavePageEditDataCompletedEventArgs)
Remarks


SaveXslFileCompletedEventArgs Class

SaveXslFileCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► SaveXslFileCompletedEventArgs
Declaration Syntax
C#
public class SaveXslFileCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | SaveXslFileCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► SaveXslFileCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


SaveXslFileCompletedEventHandler Delegate

SaveXslFileCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► SaveXslFileCompletedEventHandler
Declaration Syntax
C#
public delegate void SaveXslFileCompletedEventHandler(
    Object sender,
    SaveXslFileCompletedEventArgs e
)
Parameters
sender (Object)
e (SaveXslFileCompletedEventArgs)
Remarks


SetClientLanguageCompletedEventHandler Delegate

SetClientLanguageCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► SetClientLanguageCompletedEventHandler
Declaration Syntax
C#
public delegate void SetClientLanguageCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


SetLanguageCompletedEventHandler Delegate

SetLanguageCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► SetLanguageCompletedEventHandler
Declaration Syntax
C#
public delegate void SetLanguageCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


SitecoreClientAPI Class

SitecoreClientAPI Class
Namespaces ► Sitecore.localhost ► SitecoreClientAPI
Declaration Syntax
C#
public class SitecoreClientAPI : SoapHttpClientProtocol
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SitecoreClientAPI()()() | Initializes a new instance of the SitecoreClientAPI class
 | Abort()()() | Cancels a request to an XML Web service method. (Inherited from WebClientProtocol.)
 | About()()() |
 | AboutAsync()()() |
 | AboutAsync(Object) |
 | AboutCompleted |
 | AddItemFromMaster(String, String, String) |
 | AddItemFromMasterAsync(String, String, String) |
 | AddItemFromMasterAsync(String, String, String, Object) |
 | AddItemFromMasterCompleted |
 | AddItemFromTemplate(String, String, String) |
 | AddItemFromTemplateAsync(String, String, String) |
 | AddItemFromTemplateAsync(String, String, String, Object) |
 | AddItemFromTemplateCompleted |
 | AddItemRevision(String, String) |
 | AddItemRevisionAsync(String, String) |
 | AddItemRevisionAsync(String, String, Object) |
 | AddItemRevisionCompleted |
 | AllowAutoRedirect | Gets or sets whether the client automatically follows server redirects. (Inherited from HttpWebClientProtocol.)
 | ApplyExtranetSecurityToChildren(String, String, String, String) |
 | ApplyExtranetSecurityToChildrenAsync(String, String, String, String) |
 | ApplyExtranetSecurityToChildrenAsync(String, String, String, String, Object) |
 | ApplyExtranetSecurityToChildrenCompleted |
 | ApplySecurityToChildren(String, String, String, String) |
 | ApplySecurityToChildrenAsync(String, String, String, String) |
 | ApplySecurityToChildrenAsync(String, String, String, String, Object) |
 | ApplySecurityToChildrenCompleted |
 | ApplySimpleUpdate(String) |
 | ApplySimpleUpdateAsync(String) |
 | ApplySimpleUpdateAsync(String, Object) |
 | ApplySimpleUpdateCompleted |
 | ApproveItems(String) |
 | ApproveItemsAsync(String) |
 | ApproveItemsAsync(String, Object) |
 | ApproveItemsCompleted |
 | BackupDatabase()()() |
 | BackupDatabaseAsync()()() |
 | BackupDatabaseAsync(Object) |
 | BackupDatabaseCompleted |
 | BeginAbout(AsyncCallback, Object) |
 | BeginAddItemFromMaster(String, String, String, AsyncCallback, Object) |
 | BeginAddItemFromTemplate(String, String, String, AsyncCallback, Object) |
 | BeginAddItemRevision(String, String, AsyncCallback, Object) |
 | BeginApplyExtranetSecurityToChildren(String, String, String, String, AsyncCallback, Object) |
 | BeginApplySecurityToChildren(String, String, String, String, AsyncCallback, Object) |
 | BeginApplySimpleUpdate(String, AsyncCallback, Object) |
 | BeginApproveItems(String, AsyncCallback, Object) |
 | BeginBackupDatabase(AsyncCallback, Object) |
 | BeginBuildPackage(String, AsyncCallback, Object) |
 | BeginCanLogin(AsyncCallback, Object) |
 | BeginCanPublishIncrementally(AsyncCallback, Object) |
 | BeginCompactDatabase(AsyncCallback, Object) |
 | BeginCopyItemTo(String, String, AsyncCallback, Object) |
 | BeginCreateDocument(String, String, String, AsyncCallback, Object) |
 | BeginCreateMaster(String, String, AsyncCallback, Object) |
 | BeginCreateTemplate(String, AsyncCallback, Object) |
 | BeginDeleteChildren(String, AsyncCallback, Object) |
 | BeginDeleteDocument(String, AsyncCallback, Object) |
 | BeginDeleteItem(String, AsyncCallback, Object) |
 | BeginDeleteItemVersion(String, String, AsyncCallback, Object) |
 | BeginDeleteItemVersions(String, String, AsyncCallback, Object) |
 | BeginDuplicate(String, String, AsyncCallback, Object) |
 | BeginEmptyRecycleBin(AsyncCallback, Object) |
 | BeginEndPreview(AsyncCallback, Object) |
 | BeginEndWebEdit(AsyncCallback, Object) |
 | BeginExpandLinkedDatabases(String, AsyncCallback, Object) |
 | BeginFindItem(String, String, Boolean, String, AsyncCallback, Object) |
 | BeginGetClientLanguage(AsyncCallback, Object) |
 | BeginGetControlHtml(String, XmlNode, String, AsyncCallback, Object) |
 | BeginGetDotMenu(String, AsyncCallback, Object) |
 | BeginGetHomeItem(AsyncCallback, Object) |
 | BeginGetItem(String, AsyncCallback, Object) |
 | BeginGetItemField(String, String, AsyncCallback, Object) |
 | BeginGetItemFields(String, array<String>[]()[], AsyncCallback, Object) |
 | BeginGetItemInfo(String, AsyncCallback, Object) |
 | BeginGetItemMasters(String, String, String, AsyncCallback, Object) |
 | BeginGetItemPath(String, String, AsyncCallback, Object) |
 | BeginGetItemsInfo(String, AsyncCallback, Object) |
 | BeginGetItemTree(String, Int32, AsyncCallback, Object) |
 | BeginGetItemTreeXml(String, Int32, AsyncCallback, Object) |
 | BeginGetItemXml(String, String, String, AsyncCallback, Object) |
 | BeginGetLocalizedString(String, AsyncCallback, Object) |
 | BeginGetMediaInfo(String, String, String, AsyncCallback, Object) |
 | BeginGetMediaItems(String, String, AsyncCallback, Object) |
 | BeginGetMethodHtml(String, String, String, String, String, AsyncCallback, Object) |
 | BeginGetNewItemXml(String, String, AsyncCallback, Object) |
 | BeginGetPackageInfo(String, AsyncCallback, Object) |
 | BeginGetPackageXml(String, AsyncCallback, Object) |
 | BeginGetParentID(String, AsyncCallback, Object) |
 | BeginGetParentPath(String, AsyncCallback, Object) |
 | BeginGetPublishingStatus(String, AsyncCallback, Object) |
 | BeginGetSiblingPath(String, AsyncCallback, Object) |
 | BeginGetThreadErrors(Boolean, AsyncCallback, Object) |
 | BeginGetWebPageHtml(String, String, String, AsyncCallback, Object) |
 | BeginGetXslFileHtml(String, String, String, AsyncCallback, Object) |
 | BeginImportPackage(String, AsyncCallback, Object) |
 | BeginInsertItemTreeXml(String, String, Boolean, AsyncCallback, Object) |
 | BeginInvoke(String, array<Object>[]()[], AsyncCallback, Object) | Starts an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
 | BeginIsLoggedIn(AsyncCallback, Object) |
 | BeginIsPreviewing(AsyncCallback, Object) |
 | BeginIsSessionValid(AsyncCallback, Object) |
 | BeginIsWebEditing(AsyncCallback, Object) |
 | BeginLoadLayout(String, AsyncCallback, Object) |
 | BeginLoadPackage(String, AsyncCallback, Object) |
 | BeginLoadPublishFile(String, AsyncCallback, Object) |
 | BeginLoadXslFile(String, AsyncCallback, Object) |
 | BeginLogin(String, String, AsyncCallback, Object) |
 | BeginLogout(AsyncCallback, Object) |
 | BeginMoveItemTo(String, String, AsyncCallback, Object) |
 | BeginNewLayout(String, AsyncCallback, Object) |
 | BeginPing(AsyncCallback, Object) |
 | BeginPublish(Boolean, String, String, AsyncCallback, Object) |
 | BeginPublishItem(String, String, Boolean, AsyncCallback, Object) |
 | BeginReloadDatabase(AsyncCallback, Object) |
 | BeginRenameItem(String, String, AsyncCallback, Object) |
 | BeginResortChildren(String, AsyncCallback, Object) |
 | BeginSaveDatabase(AsyncCallback, Object) |
 | BeginSaveItemChanges(String, AsyncCallback, Object) |
 | BeginSaveItems(String, AsyncCallback, Object) |
 | BeginSaveLayout(String, String, String, Boolean, AsyncCallback, Object) |
 | BeginSavePackage(String, String, AsyncCallback, Object) |
 | BeginSavePageEditData(String, AsyncCallback, Object) |
 | BeginSaveXslFile(String, String, String, Boolean, AsyncCallback, Object) |
 | BeginSetClientLanguage(String, AsyncCallback, Object) |
 | BeginSetLanguage(String, AsyncCallback, Object) |
 | BeginStartPreview(String, String, AsyncCallback, Object) |
 | BeginStartWebEdit(AsyncCallback, Object) |
 | BeginTidyHtml(String, String, AsyncCallback, Object) |
 | BeginTidyHtmlEx(String, Boolean, Boolean, Boolean, String, AsyncCallback, Object) |
 | BeginUpdateDocument(String, String, AsyncCallback, Object) |
 | BeginUpdateSortorder(String, String, AsyncCallback, Object) |
 | BuildPackage(String) |
 | BuildPackageAsync(String) |
 | BuildPackageAsync(String, Object) |
 | BuildPackageCompleted |
 | CancelAsync(Object) |
 | CanLogin()()() |
 | CanLoginAsync()()() |
 | CanLoginAsync(Object) |
 | CanLoginCompleted |
 | CanPublishIncrementally()()() |
 | CanPublishIncrementallyAsync()()() |
 | CanPublishIncrementallyAsync(Object) |
 | CanPublishIncrementallyCompleted |
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | ClientCertificates | Gets the collection of client certificates. (Inherited from HttpWebClientProtocol.)
 | CompactDatabase()()() |
 | CompactDatabaseAsync()()() |
 | CompactDatabaseAsync(Object) |
 | CompactDatabaseCompleted |
 | ConnectionGroupName | Gets or sets the name of the connection group for the request. (Inherited from WebClientProtocol.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CookieContainer | Gets or sets the collection of cookies. (Inherited from HttpWebClientProtocol.)
 | CopyItemTo(String, String) |
 | CopyItemToAsync(String, String) |
 | CopyItemToAsync(String, String, Object) |
 | CopyItemToCompleted |
 | CreateDocument(String, String, String) |
 | CreateDocumentAsync(String, String, String) |
 | CreateDocumentAsync(String, String, String, Object) |
 | CreateDocumentCompleted |
 | CreateMaster(String, String) |
 | CreateMasterAsync(String, String) |
 | CreateMasterAsync(String, String, Object) |
 | CreateMasterCompleted |
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateTemplate(String) |
 | CreateTemplateAsync(String) |
 | CreateTemplateAsync(String, Object) |
 | CreateTemplateCompleted |
 | Credentials | Gets or sets security credentials for XML Web service client authentication. (Inherited from WebClientProtocol.)
 | DeleteChildren(String) |
 | DeleteChildrenAsync(String) |
 | DeleteChildrenAsync(String, Object) |
 | DeleteChildrenCompleted |
 | DeleteDocument(String) |
 | DeleteDocumentAsync(String) |
 | DeleteDocumentAsync(String, Object) |
 | DeleteDocumentCompleted |
 | DeleteItem(String) |
 | DeleteItemAsync(String) |
 | DeleteItemAsync(String, Object) |
 | DeleteItemCompleted |
 | DeleteItemVersion(String, String) |
 | DeleteItemVersionAsync(String, String) |
 | DeleteItemVersionAsync(String, String, Object) |
 | DeleteItemVersionCompleted |
 | DeleteItemVersions(String, String) |
 | DeleteItemVersionsAsync(String, String) |
 | DeleteItemVersionsAsync(String, String, Object) |
 | DeleteItemVersionsCompleted |
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Discover()()() | Dynamically binds to an XML Web service described in the discovery document at Url. (Inherited from SoapHttpClientProtocol.)
 | Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
 | Duplicate(String, String) |
 | DuplicateAsync(String, String) |
 | DuplicateAsync(String, String, Object) |
 | DuplicateCompleted |
 | EmptyRecycleBin()()() |
 | EmptyRecycleBinAsync()()() |
 | EmptyRecycleBinAsync(Object) |
 | EmptyRecycleBinCompleted |
 | EnableDecompression | Gets or sets a Boolean that indicates whether decompression is enabled for this HttpWebClientProtocol. (Inherited from HttpWebClientProtocol.)
 | EndAbout(IAsyncResult) |
 | EndAddItemFromMaster(IAsyncResult) |
 | EndAddItemFromTemplate(IAsyncResult) |
 | EndAddItemRevision(IAsyncResult) |
 | EndApplyExtranetSecurityToChildren(IAsyncResult) |
 | EndApplySecurityToChildren(IAsyncResult) |
 | EndApplySimpleUpdate(IAsyncResult) |
 | EndApproveItems(IAsyncResult) |
 | EndBackupDatabase(IAsyncResult) |
 | EndBuildPackage(IAsyncResult) |
 | EndCanLogin(IAsyncResult) |
 | EndCanPublishIncrementally(IAsyncResult) |
 | EndCompactDatabase(IAsyncResult) |
 | EndCopyItemTo(IAsyncResult) |
 | EndCreateDocument(IAsyncResult) |
 | EndCreateMaster(IAsyncResult) |
 | EndCreateTemplate(IAsyncResult) |
 | EndDeleteChildren(IAsyncResult) |
 | EndDeleteDocument(IAsyncResult) |
 | EndDeleteItem(IAsyncResult) |
 | EndDeleteItemVersion(IAsyncResult) |
 | EndDeleteItemVersions(IAsyncResult) |
 | EndDuplicate(IAsyncResult) |
 | EndEmptyRecycleBin(IAsyncResult) |
 | EndEndPreview(IAsyncResult) |
 | EndEndWebEdit(IAsyncResult) |
 | EndExpandLinkedDatabases(IAsyncResult) |
 | EndFindItem(IAsyncResult) |
 | EndGetClientLanguage(IAsyncResult) |
 | EndGetControlHtml(IAsyncResult) |
 | EndGetDotMenu(IAsyncResult) |
 | EndGetHomeItem(IAsyncResult) |
 | EndGetItem(IAsyncResult) |
 | EndGetItemField(IAsyncResult) |
 | EndGetItemFields(IAsyncResult) |
 | EndGetItemInfo(IAsyncResult) |
 | EndGetItemMasters(IAsyncResult) |
 | EndGetItemPath(IAsyncResult) |
 | EndGetItemsInfo(IAsyncResult) |
 | EndGetItemTree(IAsyncResult) |
 | EndGetItemTreeXml(IAsyncResult) |
 | EndGetItemXml(IAsyncResult) |
 | EndGetLocalizedString(IAsyncResult) |
 | EndGetMediaInfo(IAsyncResult) |
 | EndGetMediaItems(IAsyncResult) |
 | EndGetMethodHtml(IAsyncResult) |
 | EndGetNewItemXml(IAsyncResult) |
 | EndGetPackageInfo(IAsyncResult) |
 | EndGetPackageXml(IAsyncResult) |
 | EndGetParentID(IAsyncResult) |
 | EndGetParentPath(IAsyncResult) |
 | EndGetPublishingStatus(IAsyncResult) |
 | EndGetSiblingPath(IAsyncResult) |
 | EndGetThreadErrors(IAsyncResult) |
 | EndGetWebPageHtml(IAsyncResult) |
 | EndGetXslFileHtml(IAsyncResult) |
 | EndImportPackage(IAsyncResult) |
 | EndInsertItemTreeXml(IAsyncResult) |
 | EndInvoke(IAsyncResult) | Ends an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
 | EndIsLoggedIn(IAsyncResult) |
 | EndIsPreviewing(IAsyncResult) |
 | EndIsSessionValid(IAsyncResult) |
 | EndIsWebEditing(IAsyncResult) |
 | EndLoadLayout(IAsyncResult) |
 | EndLoadPackage(IAsyncResult) |
 | EndLoadPublishFile(IAsyncResult) |
 | EndLoadXslFile(IAsyncResult) |
 | EndLogin(IAsyncResult) |
 | EndLogout(IAsyncResult) |
 | EndMoveItemTo(IAsyncResult) |
 | EndNewLayout(IAsyncResult) |
 | EndPing(IAsyncResult) |
 | EndPreview()()() |
 | EndPreviewAsync()()() |
 | EndPreviewAsync(Object) |
 | EndPreviewCompleted |
 | EndPublish(IAsyncResult) |
 | EndPublishItem(IAsyncResult) |
 | EndReloadDatabase(IAsyncResult) |
 | EndRenameItem(IAsyncResult) |
 | EndResortChildren(IAsyncResult) |
 | EndSaveDatabase(IAsyncResult) |
 | EndSaveItemChanges(IAsyncResult) |
 | EndSaveItems(IAsyncResult) |
 | EndSaveLayout(IAsyncResult) |
 | EndSavePackage(IAsyncResult) |
 | EndSavePageEditData(IAsyncResult) |
 | EndSaveXslFile(IAsyncResult) |
 | EndSetClientLanguage(IAsyncResult) |
 | EndSetLanguage(IAsyncResult) |
 | EndStartPreview(IAsyncResult) |
 | EndStartWebEdit(IAsyncResult) |
 | EndTidyHtml(IAsyncResult) |
 | EndTidyHtmlEx(IAsyncResult) |
 | EndUpdateDocument(IAsyncResult) |
 | EndUpdateSortorder(IAsyncResult) |
 | EndWebEdit()()() |
 | EndWebEditAsync()()() |
 | EndWebEditAsync(Object) |
 | EndWebEditCompleted |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | ExpandLinkedDatabases(String) |
 | ExpandLinkedDatabasesAsync(String) |
 | ExpandLinkedDatabasesAsync(String, Object) |
 | ExpandLinkedDatabasesCompleted |
 | Finalize()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindItem(String, String, Boolean, String) |
 | FindItemAsync(String, String, Boolean, String) |
 | FindItemAsync(String, String, Boolean, String, Object) |
 | FindItemCompleted |
 | GetClientLanguage()()() |
 | GetClientLanguageAsync()()() |
 | GetClientLanguageAsync(Object) |
 | GetClientLanguageCompleted |
 | GetControlHtml(String, XmlNode, String) |
 | GetControlHtmlAsync(String, XmlNode, String) |
 | GetControlHtmlAsync(String, XmlNode, String, Object) |
 | GetControlHtmlCompleted |
 | GetDotMenu(String) |
 | GetDotMenuAsync(String) |
 | GetDotMenuAsync(String, Object) |
 | GetDotMenuCompleted |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHomeItem()()() |
 | GetHomeItemAsync()()() |
 | GetHomeItemAsync(Object) |
 | GetHomeItemCompleted |
 | GetItem(String) |
 | GetItemAsync(String) |
 | GetItemAsync(String, Object) |
 | GetItemCompleted |
 | GetItemField(String, String) |
 | GetItemFieldAsync(String, String) |
 | GetItemFieldAsync(String, String, Object) |
 | GetItemFieldCompleted |
 | GetItemFields(String, array<String>[]()[]) |
 | GetItemFieldsAsync(String, array<String>[]()[]) |
 | GetItemFieldsAsync(String, array<String>[]()[], Object) |
 | GetItemFieldsCompleted |
 | GetItemInfo(String) |
 | GetItemInfoAsync(String) |
 | GetItemInfoAsync(String, Object) |
 | GetItemInfoCompleted |
 | GetItemMasters(String, String, String) |
 | GetItemMastersAsync(String, String, String) |
 | GetItemMastersAsync(String, String, String, Object) |
 | GetItemMastersCompleted |
 | GetItemPath(String, String) |
 | GetItemPathAsync(String, String) |
 | GetItemPathAsync(String, String, Object) |
 | GetItemPathCompleted |
 | GetItemsInfo(String) |
 | GetItemsInfoAsync(String) |
 | GetItemsInfoAsync(String, Object) |
 | GetItemsInfoCompleted |
 | GetItemTree(String, Int32) |
 | GetItemTreeAsync(String, Int32) |
 | GetItemTreeAsync(String, Int32, Object) |
 | GetItemTreeCompleted |
 | GetItemTreeXml(String, Int32) |
 | GetItemTreeXmlAsync(String, Int32) |
 | GetItemTreeXmlAsync(String, Int32, Object) |
 | GetItemTreeXmlCompleted |
 | GetItemXml(String, String, String) |
 | GetItemXmlAsync(String, String, String) |
 | GetItemXmlAsync(String, String, String, Object) |
 | GetItemXmlCompleted |
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetLocalizedString(String) |
 | GetLocalizedStringAsync(String) |
 | GetLocalizedStringAsync(String, Object) |
 | GetLocalizedStringCompleted |
 | GetMediaInfo(String, String, String) |
 | GetMediaInfoAsync(String, String, String) |
 | GetMediaInfoAsync(String, String, String, Object) |
 | GetMediaInfoCompleted |
 | GetMediaItems(String, String) |
 | GetMediaItemsAsync(String, String) |
 | GetMediaItemsAsync(String, String, Object) |
 | GetMediaItemsCompleted |
 | GetMethodHtml(String, String, String, String, String) |
 | GetMethodHtmlAsync(String, String, String, String, String) |
 | GetMethodHtmlAsync(String, String, String, String, String, Object) |
 | GetMethodHtmlCompleted |
 | GetNewItemXml(String, String) |
 | GetNewItemXmlAsync(String, String) |
 | GetNewItemXmlAsync(String, String, Object) |
 | GetNewItemXmlCompleted |
 | GetPackageInfo(String) |
 | GetPackageInfoAsync(String) |
 | GetPackageInfoAsync(String, Object) |
 | GetPackageInfoCompleted |
 | GetPackageXml(String) |
 | GetPackageXmlAsync(String) |
 | GetPackageXmlAsync(String, Object) |
 | GetPackageXmlCompleted |
 | GetParentID(String) |
 | GetParentIDAsync(String) |
 | GetParentIDAsync(String, Object) |
 | GetParentIDCompleted |
 | GetParentPath(String) |
 | GetParentPathAsync(String) |
 | GetParentPathAsync(String, Object) |
 | GetParentPathCompleted |
 | GetPublishingStatus(String) |
 | GetPublishingStatusAsync(String) |
 | GetPublishingStatusAsync(String, Object) |
 | GetPublishingStatusCompleted |
 | GetReaderForMessage(SoapClientMessage, Int32) | Returns an XmlReader initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetSiblingPath(String) |
 | GetSiblingPathAsync(String) |
 | GetSiblingPathAsync(String, Object) |
 | GetSiblingPathCompleted |
 | GetThreadErrors(Boolean) |
 | GetThreadErrorsAsync(Boolean) |
 | GetThreadErrorsAsync(Boolean, Object) |
 | GetThreadErrorsCompleted |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWebPageHtml(String, String, String) |
 | GetWebPageHtmlAsync(String, String, String) |
 | GetWebPageHtmlAsync(String, String, String, Object) |
 | GetWebPageHtmlCompleted |
 | GetWebRequest(Uri) | Creates a WebRequest for the specified uri. (Inherited from SoapHttpClientProtocol.)
 | GetWebResponse(WebRequest) | Returns a response from a synchronous request to an XML Web service method. (Inherited from HttpWebClientProtocol.)
 | GetWebResponse(WebRequest, IAsyncResult) | Returns a response from an asynchronous request to an XML Web service method. (Inherited from HttpWebClientProtocol.)
 | GetWriterForMessage(SoapClientMessage, Int32) | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
 | GetXslFileHtml(String, String, String) |
 | GetXslFileHtmlAsync(String, String, String) |
 | GetXslFileHtmlAsync(String, String, String, Object) |
 | GetXslFileHtmlCompleted |
 | ImportPackage(String) |
 | ImportPackageAsync(String) |
 | ImportPackageAsync(String, Object) |
 | ImportPackageCompleted |
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InsertItemTreeXml(String, String, Boolean) |
 | InsertItemTreeXmlAsync(String, String, Boolean) |
 | InsertItemTreeXmlAsync(String, String, Boolean, Object) |
 | InsertItemTreeXmlCompleted |
 | Invoke(String, array<Object>[]()[]) | Invokes an XML Web service method synchronously using SOAP. (Inherited from SoapHttpClientProtocol.)
 | InvokeAsync(String, array<Object>[]()[], SendOrPostCallback) | Invokes the specified method asynchronously. (Inherited from SoapHttpClientProtocol.)
 | InvokeAsync(String, array<Object>[]()[], SendOrPostCallback, Object) | Invokes the specified method asynchronously. (Inherited from SoapHttpClientProtocol.)
 | IsLoggedIn()()() |
 | IsLoggedInAsync()()() |
 | IsLoggedInAsync(Object) |
 | IsLoggedInCompleted |
 | IsPreviewing()()() |
 | IsPreviewingAsync()()() |
 | IsPreviewingAsync(Object) |
 | IsPreviewingCompleted |
 | IsSessionValid()()() |
 | IsSessionValidAsync()()() |
 | IsSessionValidAsync(Object) |
 | IsSessionValidCompleted |
 | IsWebEditing()()() |
 | IsWebEditingAsync()()() |
 | IsWebEditingAsync(Object) |
 | IsWebEditingCompleted |
 | LoadLayout(String) |
 | LoadLayoutAsync(String) |
 | LoadLayoutAsync(String, Object) |
 | LoadLayoutCompleted |
 | LoadPackage(String) |
 | LoadPackageAsync(String) |
 | LoadPackageAsync(String, Object) |
 | LoadPackageCompleted |
 | LoadPublishFile(String) |
 | LoadPublishFileAsync(String) |
 | LoadPublishFileAsync(String, Object) |
 | LoadPublishFileCompleted |
 | LoadXslFile(String) |
 | LoadXslFileAsync(String) |
 | LoadXslFileAsync(String, Object) |
 | LoadXslFileCompleted |
 | Login(String, String) |
 | LoginAsync(String, String) |
 | LoginAsync(String, String, Object) |
 | LoginCompleted |
 | Logout()()() |
 | LogoutAsync()()() |
 | LogoutAsync(Object) |
 | LogoutCompleted |
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveItemTo(String, String) |
 | MoveItemToAsync(String, String) |
 | MoveItemToAsync(String, String, Object) |
 | MoveItemToCompleted |
 | NewLayout(String) |
 | NewLayoutAsync(String) |
 | NewLayoutAsync(String, Object) |
 | NewLayoutCompleted |
 | Ping()()() |
 | PingAsync()()() |
 | PingAsync(Object) |
 | PingCompleted |
 | PreAuthenticate | Gets or sets whether pre-authentication is enabled. (Inherited from WebClientProtocol.)
 | Proxy | Gets or sets proxy information for making an XML Web service request through a firewall. (Inherited from HttpWebClientProtocol.)
 | Publish(Boolean, String, String) |
 | PublishAsync(Boolean, String, String) |
 | PublishAsync(Boolean, String, String, Object) |
 | PublishCompleted |
 | PublishItem(String, String, Boolean) |
 | PublishItemAsync(String, String, Boolean) |
 | PublishItemAsync(String, String, Boolean, Object) |
 | PublishItemCompleted |
 | ReloadDatabase()()() |
 | ReloadDatabaseAsync()()() |
 | ReloadDatabaseAsync(Object) |
 | ReloadDatabaseCompleted |
 | RenameItem(String, String) |
 | RenameItemAsync(String, String) |
 | RenameItemAsync(String, String, Object) |
 | RenameItemCompleted |
 | RequestEncoding | The Encoding used to make the client request to the XML Web service. (Inherited from WebClientProtocol.)
 | ResortChildren(String) |
 | ResortChildrenAsync(String) |
 | ResortChildrenAsync(String, Object) |
 | ResortChildrenCompleted |
 | SaveDatabase()()() |
 | SaveDatabaseAsync()()() |
 | SaveDatabaseAsync(Object) |
 | SaveDatabaseCompleted |
 | SaveItemChanges(String) |
 | SaveItemChangesAsync(String) |
 | SaveItemChangesAsync(String, Object) |
 | SaveItemChangesCompleted |
 | SaveItems(String) |
 | SaveItemsAsync(String) |
 | SaveItemsAsync(String, Object) |
 | SaveItemsCompleted |
 | SaveLayout(String, String, String, Boolean) |
 | SaveLayoutAsync(String, String, String, Boolean) |
 | SaveLayoutAsync(String, String, String, Boolean, Object) |
 | SaveLayoutCompleted |
 | SavePackage(String, String) |
 | SavePackageAsync(String, String) |
 | SavePackageAsync(String, String, Object) |
 | SavePackageCompleted |
 | SavePageEditData(String) |
 | SavePageEditDataAsync(String) |
 | SavePageEditDataAsync(String, Object) |
 | SavePageEditDataCompleted |
 | SaveXslFile(String, String, String, Boolean) |
 | SaveXslFileAsync(String, String, String, Boolean) |
 | SaveXslFileAsync(String, String, String, Boolean, Object) |
 | SaveXslFileCompleted |
 | SetClientLanguage(String) |
 | SetClientLanguageAsync(String) |
 | SetClientLanguageAsync(String, Object) |
 | SetClientLanguageCompleted |
 | SetLanguage(String) |
 | SetLanguageAsync(String) |
 | SetLanguageAsync(String, Object) |
 | SetLanguageCompleted |
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | SoapVersion | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from SoapHttpClientProtocol.)
 | StartPreview(String, String) |
 | StartPreviewAsync(String, String) |
 | StartPreviewAsync(String, String, Object) |
 | StartPreviewCompleted |
 | StartWebEdit()()() |
 | StartWebEditAsync()()() |
 | StartWebEditAsync(Object) |
 | StartWebEditCompleted |
 | TidyHtml(String, String) |
 | TidyHtmlAsync(String, String) |
 | TidyHtmlAsync(String, String, Object) |
 | TidyHtmlCompleted |
 | TidyHtmlEx(String, Boolean, Boolean, Boolean, String) |
 | TidyHtmlExAsync(String, Boolean, Boolean, Boolean, String) |
 | TidyHtmlExAsync(String, Boolean, Boolean, Boolean, String, Object) |
 | TidyHtmlExCompleted |
 | Timeout | Indicates the time an XML Web service client waits for a synchronous XML Web service request to complete (in milliseconds). (Inherited from WebClientProtocol.)
 | ToString()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | UnsafeAuthenticatedConnectionSharing | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service. (Inherited from HttpWebClientProtocol.)
 | UpdateDocument(String, String) |
 | UpdateDocumentAsync(String, String) |
 | UpdateDocumentAsync(String, String, Object) |
 | UpdateDocumentCompleted |
 | UpdateSortorder(String, String) |
 | UpdateSortorderAsync(String, String) |
 | UpdateSortorderAsync(String, String, Object) |
 | UpdateSortorderCompleted |
 | Url |
 | UseDefaultCredentials |
 | UserAgent | Gets or sets the value for the user agent header that is sent with each request. (Inherited from HttpWebClientProtocol.)
Remarks
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | WebClientProtocol
 |  |  |  | HttpWebClientProtocol
 |  |  |  |  | SoapHttpClientProtocol
 |  |  |  |  |  | SitecoreClientAPI


SitecoreClientAPI Constructor

SitecoreClientAPI Constructor
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SitecoreClientAPI()()()
Initializes a new instance of the SitecoreClientAPI class
Declaration Syntax
C#
public SitecoreClientAPI()
Remarks


About Method

About Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► About()()()
Declaration Syntax
C#
public string About()
Remarks


AboutAsync Method

AboutAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AboutAsync()()()
Members
Icon | Member | Description
 | AboutAsync()()() |
 | AboutAsync(Object) |


AboutAsync Method

AboutAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AboutAsync()()()
Declaration Syntax
C#
public void AboutAsync()
Remarks


AboutAsync Method (userState)

AboutAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AboutAsync(Object)
Declaration Syntax
C#
public void AboutAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


AboutCompleted Event

AboutCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AboutCompleted
Declaration Syntax
C#
public event AboutCompletedEventHandler AboutCompleted
Remarks


AddItemFromMaster Method (sName, sParentItem, sMaster)

AddItemFromMaster Method (sName, sParentItem, sMaster)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemFromMaster(String, String, String)
Declaration Syntax
C#
public XmlNode AddItemFromMaster(
    string sName,
    string sParentItem,
    string sMaster
)
Parameters
sName (String)
sParentItem (String)
sMaster (String)
Remarks


AddItemFromMasterAsync Method

AddItemFromMasterAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemFromMasterAsync()()()
Members
Icon | Member | Description
 | AddItemFromMasterAsync(String, String, String) |
 | AddItemFromMasterAsync(String, String, String, Object) |


AddItemFromMasterAsync Method (sName, sParentItem, sMaster)

AddItemFromMasterAsync Method (sName, sParentItem, sMaster)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemFromMasterAsync(String, String, String)
Declaration Syntax
C#
public void AddItemFromMasterAsync(
    string sName,
    string sParentItem,
    string sMaster
)
Parameters
sName (String)
sParentItem (String)
sMaster (String)
Remarks


AddItemFromMasterAsync Method (sName, sParentItem, sMaster, userState)

AddItemFromMasterAsync Method (sName, sParentItem, sMaster, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemFromMasterAsync(String, String, String, Object)
Declaration Syntax
C#
public void AddItemFromMasterAsync(
    string sName,
    string sParentItem,
    string sMaster,
    Object userState
)
Parameters
sName (String)
sParentItem (String)
sMaster (String)
userState (Object)
Remarks


AddItemFromMasterCompleted Event

AddItemFromMasterCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemFromMasterCompleted
Declaration Syntax
C#
public event AddItemFromMasterCompletedEventHandler AddItemFromMasterCompleted
Remarks


AddItemFromTemplate Method (sName, sParentItem, sTemplate)

AddItemFromTemplate Method (sName, sParentItem, sTemplate)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemFromTemplate(String, String, String)
Declaration Syntax
C#
public XmlNode AddItemFromTemplate(
    string sName,
    string sParentItem,
    string sTemplate
)
Parameters
sName (String)
sParentItem (String)
sTemplate (String)
Remarks


AddItemFromTemplateAsync Method

AddItemFromTemplateAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemFromTemplateAsync()()()
Members
Icon | Member | Description
 | AddItemFromTemplateAsync(String, String, String) |
 | AddItemFromTemplateAsync(String, String, String, Object) |


AddItemFromTemplateAsync Method (sName, sParentItem, sTemplate)

AddItemFromTemplateAsync Method (sName, sParentItem, sTemplate)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemFromTemplateAsync(String, String, String)
Declaration Syntax
C#
public void AddItemFromTemplateAsync(
    string sName,
    string sParentItem,
    string sTemplate
)
Parameters
sName (String)
sParentItem (String)
sTemplate (String)
Remarks


AddItemFromTemplateAsync Method (sName, sParentItem, sTemplate, userState)

AddItemFromTemplateAsync Method (sName, sParentItem, sTemplate, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemFromTemplateAsync(String, String, String, Object)
Declaration Syntax
C#
public void AddItemFromTemplateAsync(
    string sName,
    string sParentItem,
    string sTemplate,
    Object userState
)
Parameters
sName (String)
sParentItem (String)
sTemplate (String)
userState (Object)
Remarks


AddItemFromTemplateCompleted Event

AddItemFromTemplateCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemFromTemplateCompleted
Declaration Syntax
C#
public event AddItemFromTemplateCompletedEventHandler AddItemFromTemplateCompleted
Remarks


AddItemRevision Method (sItemID, sRevision)

AddItemRevision Method (sItemID, sRevision)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemRevision(String, String)
Declaration Syntax
C#
public string AddItemRevision(
    string sItemID,
    string sRevision
)
Parameters
sItemID (String)
sRevision (String)
Remarks


AddItemRevisionAsync Method

AddItemRevisionAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemRevisionAsync()()()
Members
Icon | Member | Description
 | AddItemRevisionAsync(String, String) |
 | AddItemRevisionAsync(String, String, Object) |


AddItemRevisionAsync Method (sItemID, sRevision)

AddItemRevisionAsync Method (sItemID, sRevision)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemRevisionAsync(String, String)
Declaration Syntax
C#
public void AddItemRevisionAsync(
    string sItemID,
    string sRevision
)
Parameters
sItemID (String)
sRevision (String)
Remarks


AddItemRevisionAsync Method (sItemID, sRevision, userState)

AddItemRevisionAsync Method (sItemID, sRevision, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemRevisionAsync(String, String, Object)
Declaration Syntax
C#
public void AddItemRevisionAsync(
    string sItemID,
    string sRevision,
    Object userState
)
Parameters
sItemID (String)
sRevision (String)
userState (Object)
Remarks


AddItemRevisionCompleted Event

AddItemRevisionCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► AddItemRevisionCompleted
Declaration Syntax
C#
public event AddItemRevisionCompletedEventHandler AddItemRevisionCompleted
Remarks


ApplyExtranetSecurityToChildren Method (sItemID, sSecurity, sTemplate, sMaster)

ApplyExtranetSecurityToChildren Method (sItemID, sSecurity, sTemplate, sMaster)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplyExtranetSecurityToChildren(String, String, String, String)
Declaration Syntax
C#
public string ApplyExtranetSecurityToChildren(
    string sItemID,
    string sSecurity,
    string sTemplate,
    string sMaster
)
Parameters
sItemID (String)
sSecurity (String)
sTemplate (String)
sMaster (String)
Remarks


ApplyExtranetSecurityToChildrenAsync Method

ApplyExtranetSecurityToChildrenAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplyExtranetSecurityToChildrenAsync()()()
Members
Icon | Member | Description
 | ApplyExtranetSecurityToChildrenAsync(String, String, String, String) |
 | ApplyExtranetSecurityToChildrenAsync(String, String, String, String, Object) |


ApplyExtranetSecurityToChildrenAsync Method (sItemID, sSecurity, sTemplate, sMaster)

ApplyExtranetSecurityToChildrenAsync Method (sItemID, sSecurity, sTemplate, sMaster)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplyExtranetSecurityToChildrenAsync(String, String, String, String)
Declaration Syntax
C#
public void ApplyExtranetSecurityToChildrenAsync(
    string sItemID,
    string sSecurity,
    string sTemplate,
    string sMaster
)
Parameters
sItemID (String)
sSecurity (String)
sTemplate (String)
sMaster (String)
Remarks


ApplyExtranetSecurityToChildrenAsync Method (sItemID, sSecurity, sTemplate, sMaster, userState)

ApplyExtranetSecurityToChildrenAsync Method (sItemID, sSecurity, sTemplate, sMaster, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplyExtranetSecurityToChildrenAsync(String, String, String, String, Object)
Declaration Syntax
C#
public void ApplyExtranetSecurityToChildrenAsync(
    string sItemID,
    string sSecurity,
    string sTemplate,
    string sMaster,
    Object userState
)
Parameters
sItemID (String)
sSecurity (String)
sTemplate (String)
sMaster (String)
userState (Object)
Remarks


ApplyExtranetSecurityToChildrenCompleted Event

ApplyExtranetSecurityToChildrenCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplyExtranetSecurityToChildrenCompleted
Declaration Syntax
C#
public event ApplyExtranetSecurityToChildrenCompletedEventHandler ApplyExtranetSecurityToChildrenCompleted
Remarks


ApplySecurityToChildren Method (sItemID, sSecurity, sTemplate, sMaster)

ApplySecurityToChildren Method (sItemID, sSecurity, sTemplate, sMaster)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplySecurityToChildren(String, String, String, String)
Declaration Syntax
C#
public string ApplySecurityToChildren(
    string sItemID,
    string sSecurity,
    string sTemplate,
    string sMaster
)
Parameters
sItemID (String)
sSecurity (String)
sTemplate (String)
sMaster (String)
Remarks


ApplySecurityToChildrenAsync Method

ApplySecurityToChildrenAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplySecurityToChildrenAsync()()()
Members
Icon | Member | Description
 | ApplySecurityToChildrenAsync(String, String, String, String) |
 | ApplySecurityToChildrenAsync(String, String, String, String, Object) |


ApplySecurityToChildrenAsync Method (sItemID, sSecurity, sTemplate, sMaster)

ApplySecurityToChildrenAsync Method (sItemID, sSecurity, sTemplate, sMaster)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplySecurityToChildrenAsync(String, String, String, String)
Declaration Syntax
C#
public void ApplySecurityToChildrenAsync(
    string sItemID,
    string sSecurity,
    string sTemplate,
    string sMaster
)
Parameters
sItemID (String)
sSecurity (String)
sTemplate (String)
sMaster (String)
Remarks


ApplySecurityToChildrenAsync Method (sItemID, sSecurity, sTemplate, sMaster, userState)

ApplySecurityToChildrenAsync Method (sItemID, sSecurity, sTemplate, sMaster, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplySecurityToChildrenAsync(String, String, String, String, Object)
Declaration Syntax
C#
public void ApplySecurityToChildrenAsync(
    string sItemID,
    string sSecurity,
    string sTemplate,
    string sMaster,
    Object userState
)
Parameters
sItemID (String)
sSecurity (String)
sTemplate (String)
sMaster (String)
userState (Object)
Remarks


ApplySecurityToChildrenCompleted Event

ApplySecurityToChildrenCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplySecurityToChildrenCompleted
Declaration Syntax
C#
public event ApplySecurityToChildrenCompletedEventHandler ApplySecurityToChildrenCompleted
Remarks


ApplySimpleUpdate Method (sXml)

ApplySimpleUpdate Method (sXml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplySimpleUpdate(String)
Declaration Syntax
C#
public string ApplySimpleUpdate(
    string sXml
)
Parameters
sXml (String)
Remarks


ApplySimpleUpdateAsync Method

ApplySimpleUpdateAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplySimpleUpdateAsync()()()
Members
Icon | Member | Description
 | ApplySimpleUpdateAsync(String) |
 | ApplySimpleUpdateAsync(String, Object) |


ApplySimpleUpdateAsync Method (sXml)

ApplySimpleUpdateAsync Method (sXml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplySimpleUpdateAsync(String)
Declaration Syntax
C#
public void ApplySimpleUpdateAsync(
    string sXml
)
Parameters
sXml (String)
Remarks


ApplySimpleUpdateAsync Method (sXml, userState)

ApplySimpleUpdateAsync Method (sXml, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplySimpleUpdateAsync(String, Object)
Declaration Syntax
C#
public void ApplySimpleUpdateAsync(
    string sXml,
    Object userState
)
Parameters
sXml (String)
userState (Object)
Remarks


ApplySimpleUpdateCompleted Event

ApplySimpleUpdateCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApplySimpleUpdateCompleted
Declaration Syntax
C#
public event ApplySimpleUpdateCompletedEventHandler ApplySimpleUpdateCompleted
Remarks


ApproveItems Method (sXml)

ApproveItems Method (sXml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApproveItems(String)
Declaration Syntax
C#
public string ApproveItems(
    string sXml
)
Parameters
sXml (String)
Remarks


ApproveItemsAsync Method

ApproveItemsAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApproveItemsAsync()()()
Members
Icon | Member | Description
 | ApproveItemsAsync(String) |
 | ApproveItemsAsync(String, Object) |


ApproveItemsAsync Method (sXml)

ApproveItemsAsync Method (sXml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApproveItemsAsync(String)
Declaration Syntax
C#
public void ApproveItemsAsync(
    string sXml
)
Parameters
sXml (String)
Remarks


ApproveItemsAsync Method (sXml, userState)

ApproveItemsAsync Method (sXml, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApproveItemsAsync(String, Object)
Declaration Syntax
C#
public void ApproveItemsAsync(
    string sXml,
    Object userState
)
Parameters
sXml (String)
userState (Object)
Remarks


ApproveItemsCompleted Event

ApproveItemsCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ApproveItemsCompleted
Declaration Syntax
C#
public event ApproveItemsCompletedEventHandler ApproveItemsCompleted
Remarks


BackupDatabase Method

BackupDatabase Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BackupDatabase()()()
Declaration Syntax
C#
public void BackupDatabase()
Remarks


BackupDatabaseAsync Method

BackupDatabaseAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BackupDatabaseAsync()()()
Members
Icon | Member | Description
 | BackupDatabaseAsync()()() |
 | BackupDatabaseAsync(Object) |


BackupDatabaseAsync Method

BackupDatabaseAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BackupDatabaseAsync()()()
Declaration Syntax
C#
public void BackupDatabaseAsync()
Remarks


BackupDatabaseAsync Method (userState)

BackupDatabaseAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BackupDatabaseAsync(Object)
Declaration Syntax
C#
public void BackupDatabaseAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


BackupDatabaseCompleted Event

BackupDatabaseCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BackupDatabaseCompleted
Declaration Syntax
C#
public event BackupDatabaseCompletedEventHandler BackupDatabaseCompleted
Remarks


BeginAbout Method (callback, asyncState)

BeginAbout Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginAbout(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginAbout(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddItemFromMaster Method (sName, sParentItem, sMaster, callback, asyncState)

BeginAddItemFromMaster Method (sName, sParentItem, sMaster, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginAddItemFromMaster(String, String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginAddItemFromMaster(
    string sName,
    string sParentItem,
    string sMaster,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sName (String)
sParentItem (String)
sMaster (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddItemFromTemplate Method (sName, sParentItem, sTemplate, callback, asyncState)

BeginAddItemFromTemplate Method (sName, sParentItem, sTemplate, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginAddItemFromTemplate(String, String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginAddItemFromTemplate(
    string sName,
    string sParentItem,
    string sTemplate,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sName (String)
sParentItem (String)
sTemplate (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddItemRevision Method (sItemID, sRevision, callback, asyncState)

BeginAddItemRevision Method (sItemID, sRevision, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginAddItemRevision(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginAddItemRevision(
    string sItemID,
    string sRevision,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemID (String)
sRevision (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginApplyExtranetSecurityToChildren Method (sItemID, sSecurity, sTemplate, sMaster, callback, asyncState)

BeginApplyExtranetSecurityToChildren Method (sItemID, sSecurity, sTemplate, sMaster, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginApplyExtranetSecurityToChildren(String, String, String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginApplyExtranetSecurityToChildren(
    string sItemID,
    string sSecurity,
    string sTemplate,
    string sMaster,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemID (String)
sSecurity (String)
sTemplate (String)
sMaster (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginApplySecurityToChildren Method (sItemID, sSecurity, sTemplate, sMaster, callback, asyncState)

BeginApplySecurityToChildren Method (sItemID, sSecurity, sTemplate, sMaster, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginApplySecurityToChildren(String, String, String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginApplySecurityToChildren(
    string sItemID,
    string sSecurity,
    string sTemplate,
    string sMaster,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemID (String)
sSecurity (String)
sTemplate (String)
sMaster (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginApplySimpleUpdate Method (sXml, callback, asyncState)

BeginApplySimpleUpdate Method (sXml, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginApplySimpleUpdate(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginApplySimpleUpdate(
    string sXml,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sXml (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginApproveItems Method (sXml, callback, asyncState)

BeginApproveItems Method (sXml, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginApproveItems(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginApproveItems(
    string sXml,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sXml (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginBackupDatabase Method (callback, asyncState)

BeginBackupDatabase Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginBackupDatabase(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginBackupDatabase(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginBuildPackage Method (packageName, callback, asyncState)

BeginBuildPackage Method (packageName, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginBuildPackage(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginBuildPackage(
    string packageName,
    AsyncCallback callback,
    Object asyncState
)
Parameters
packageName (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginCanLogin Method (callback, asyncState)

BeginCanLogin Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginCanLogin(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginCanLogin(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginCanPublishIncrementally Method (callback, asyncState)

BeginCanPublishIncrementally Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginCanPublishIncrementally(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginCanPublishIncrementally(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginCompactDatabase Method (callback, asyncState)

BeginCompactDatabase Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginCompactDatabase(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginCompactDatabase(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginCopyItemTo Method (sItemID, sDestinationID, callback, asyncState)

BeginCopyItemTo Method (sItemID, sDestinationID, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginCopyItemTo(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginCopyItemTo(
    string sItemID,
    string sDestinationID,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemID (String)
sDestinationID (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginCreateDocument Method (sParent, sMaster, sXml, callback, asyncState)

BeginCreateDocument Method (sParent, sMaster, sXml, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginCreateDocument(String, String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginCreateDocument(
    string sParent,
    string sMaster,
    string sXml,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sParent (String)
sMaster (String)
sXml (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginCreateMaster Method (sName, sTemplate, callback, asyncState)

BeginCreateMaster Method (sName, sTemplate, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginCreateMaster(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginCreateMaster(
    string sName,
    string sTemplate,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sName (String)
sTemplate (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginCreateTemplate Method (sName, callback, asyncState)

BeginCreateTemplate Method (sName, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginCreateTemplate(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginCreateTemplate(
    string sName,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sName (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginDeleteChildren Method (path, callback, asyncState)

BeginDeleteChildren Method (path, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginDeleteChildren(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginDeleteChildren(
    string path,
    AsyncCallback callback,
    Object asyncState
)
Parameters
path (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginDeleteDocument Method (sPath, callback, asyncState)

BeginDeleteDocument Method (sPath, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginDeleteDocument(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginDeleteDocument(
    string sPath,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sPath (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginDeleteItem Method (sItemList, callback, asyncState)

BeginDeleteItem Method (sItemList, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginDeleteItem(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginDeleteItem(
    string sItemList,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemList (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginDeleteItemVersion Method (sItemID, sVersion, callback, asyncState)

BeginDeleteItemVersion Method (sItemID, sVersion, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginDeleteItemVersion(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginDeleteItemVersion(
    string sItemID,
    string sVersion,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemID (String)
sVersion (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginDeleteItemVersions Method (sItemID, sVersions, callback, asyncState)

BeginDeleteItemVersions Method (sItemID, sVersions, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginDeleteItemVersions(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginDeleteItemVersions(
    string sItemID,
    string sVersions,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemID (String)
sVersions (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginDuplicate Method (sItemID, sName, callback, asyncState)

BeginDuplicate Method (sItemID, sName, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginDuplicate(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginDuplicate(
    string sItemID,
    string sName,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemID (String)
sName (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginEmptyRecycleBin Method (callback, asyncState)

BeginEmptyRecycleBin Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginEmptyRecycleBin(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginEmptyRecycleBin(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginEndPreview Method (callback, asyncState)

BeginEndPreview Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginEndPreview(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginEndPreview(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginEndWebEdit Method (callback, asyncState)

BeginEndWebEdit Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginEndWebEdit(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginEndWebEdit(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginExpandLinkedDatabases Method (expanded, callback, asyncState)

BeginExpandLinkedDatabases Method (expanded, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginExpandLinkedDatabases(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginExpandLinkedDatabases(
    string expanded,
    AsyncCallback callback,
    Object asyncState
)
Parameters
expanded (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginFindItem Method (name, path, recurse, previousFound, callback, asyncState)

BeginFindItem Method (name, path, recurse, previousFound, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginFindItem(String, String, Boolean, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginFindItem(
    string name,
    string path,
    bool recurse,
    string previousFound,
    AsyncCallback callback,
    Object asyncState
)
Parameters
name (String)
path (String)
recurse (Boolean)
previousFound (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetClientLanguage Method (callback, asyncState)

BeginGetClientLanguage Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetClientLanguage(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetClientLanguage(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetControlHtml Method (controlName, properties, assemblyName, callback, asyncState)

BeginGetControlHtml Method (controlName, properties, assemblyName, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetControlHtml(String, XmlNode, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetControlHtml(
    string controlName,
    XmlNode properties,
    string assemblyName,
    AsyncCallback callback,
    Object asyncState
)
Parameters
controlName (String)
properties (XmlNode)
assemblyName (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetDotMenu Method (sItemID, callback, asyncState)

BeginGetDotMenu Method (sItemID, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetDotMenu(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetDotMenu(
    string sItemID,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemID (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetHomeItem Method (callback, asyncState)

BeginGetHomeItem Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetHomeItem(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetHomeItem(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetItem Method (sPath, callback, asyncState)

BeginGetItem Method (sPath, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetItem(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetItem(
    string sPath,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sPath (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetItemField Method (sItemPath, sField, callback, asyncState)

BeginGetItemField Method (sItemPath, sField, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetItemField(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetItemField(
    string sItemPath,
    string sField,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemPath (String)
sField (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetItemFields Method (sItemPath, vFields, callback, asyncState)

BeginGetItemFields Method (sItemPath, vFields, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetItemFields(String, array<String>[]()[], AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetItemFields(
    string sItemPath,
    string[] vFields,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemPath (String)
vFields (array< String >[]()[])
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetItemInfo Method (sPath, callback, asyncState)

BeginGetItemInfo Method (sPath, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetItemInfo(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetItemInfo(
    string sPath,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sPath (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetItemMasters Method (sItemID, sRevision, sLanguage, callback, asyncState)

BeginGetItemMasters Method (sItemID, sRevision, sLanguage, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetItemMasters(String, String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetItemMasters(
    string sItemID,
    string sRevision,
    string sLanguage,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemID (String)
sRevision (String)
sLanguage (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetItemPath Method (sItemID, sType, callback, asyncState)

BeginGetItemPath Method (sItemID, sType, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetItemPath(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetItemPath(
    string sItemID,
    string sType,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemID (String)
sType (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetItemsInfo Method (sItems, callback, asyncState)

BeginGetItemsInfo Method (sItems, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetItemsInfo(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetItemsInfo(
    string sItems,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItems (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetItemTree Method (sItemPath, nSublevels, callback, asyncState)

BeginGetItemTree Method (sItemPath, nSublevels, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetItemTree(String, Int32, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetItemTree(
    string sItemPath,
    int nSublevels,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemPath (String)
nSublevels (Int32)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetItemTreeXml Method (sPath, nLevels, callback, asyncState)

BeginGetItemTreeXml Method (sPath, nLevels, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetItemTreeXml(String, Int32, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetItemTreeXml(
    string sPath,
    int nLevels,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sPath (String)
nLevels (Int32)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetItemXml Method (sPath, sRevision, sLanguage, callback, asyncState)

BeginGetItemXml Method (sPath, sRevision, sLanguage, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetItemXml(String, String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetItemXml(
    string sPath,
    string sRevision,
    string sLanguage,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sPath (String)
sRevision (String)
sLanguage (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetLocalizedString Method (text, callback, asyncState)

BeginGetLocalizedString Method (text, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetLocalizedString(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetLocalizedString(
    string text,
    AsyncCallback callback,
    Object asyncState
)
Parameters
text (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetMediaInfo Method (sPath, sRevision, sLanguage, callback, asyncState)

BeginGetMediaInfo Method (sPath, sRevision, sLanguage, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetMediaInfo(String, String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetMediaInfo(
    string sPath,
    string sRevision,
    string sLanguage,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sPath (String)
sRevision (String)
sLanguage (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetMediaItems Method (sPath, sType, callback, asyncState)

BeginGetMediaItems Method (sPath, sType, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetMediaItems(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetMediaItems(
    string sPath,
    string sType,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sPath (String)
sType (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetMethodHtml Method (assemblyname, classname, methodname, datasource, parameters, callback, asyncState)

BeginGetMethodHtml Method (assemblyname, classname, methodname, datasource, parameters, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetMethodHtml(String, String, String, String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetMethodHtml(
    string assemblyname,
    string classname,
    string methodname,
    string datasource,
    string parameters,
    AsyncCallback callback,
    Object asyncState
)
Parameters
assemblyname (String)
classname (String)
methodname (String)
datasource (String)
parameters (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetNewItemXml Method (master, name, callback, asyncState)

BeginGetNewItemXml Method (master, name, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetNewItemXml(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetNewItemXml(
    string master,
    string name,
    AsyncCallback callback,
    Object asyncState
)
Parameters
master (String)
name (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetPackageInfo Method (packageName, callback, asyncState)

BeginGetPackageInfo Method (packageName, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetPackageInfo(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetPackageInfo(
    string packageName,
    AsyncCallback callback,
    Object asyncState
)
Parameters
packageName (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetPackageXml Method (packageName, callback, asyncState)

BeginGetPackageXml Method (packageName, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetPackageXml(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetPackageXml(
    string packageName,
    AsyncCallback callback,
    Object asyncState
)
Parameters
packageName (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetParentID Method (sItemID, callback, asyncState)

BeginGetParentID Method (sItemID, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetParentID(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetParentID(
    string sItemID,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemID (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetParentPath Method (path, callback, asyncState)

BeginGetParentPath Method (path, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetParentPath(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetParentPath(
    string path,
    AsyncCallback callback,
    Object asyncState
)
Parameters
path (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetPublishingStatus Method (handle, callback, asyncState)

BeginGetPublishingStatus Method (handle, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetPublishingStatus(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetPublishingStatus(
    string handle,
    AsyncCallback callback,
    Object asyncState
)
Parameters
handle (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSiblingPath Method (path, callback, asyncState)

BeginGetSiblingPath Method (path, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetSiblingPath(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetSiblingPath(
    string path,
    AsyncCallback callback,
    Object asyncState
)
Parameters
path (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetThreadErrors Method (resetListAfterUse, callback, asyncState)

BeginGetThreadErrors Method (resetListAfterUse, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetThreadErrors(Boolean, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetThreadErrors(
    bool resetListAfterUse,
    AsyncCallback callback,
    Object asyncState
)
Parameters
resetListAfterUse (Boolean)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetWebPageHtml Method (url, datasource, parameters, callback, asyncState)

BeginGetWebPageHtml Method (url, datasource, parameters, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetWebPageHtml(String, String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetWebPageHtml(
    string url,
    string datasource,
    string parameters,
    AsyncCallback callback,
    Object asyncState
)
Parameters
url (String)
datasource (String)
parameters (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetXslFileHtml Method (path, datasource, parameters, callback, asyncState)

BeginGetXslFileHtml Method (path, datasource, parameters, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginGetXslFileHtml(String, String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginGetXslFileHtml(
    string path,
    string datasource,
    string parameters,
    AsyncCallback callback,
    Object asyncState
)
Parameters
path (String)
datasource (String)
parameters (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginImportPackage Method (packageName, callback, asyncState)

BeginImportPackage Method (packageName, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginImportPackage(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginImportPackage(
    string packageName,
    AsyncCallback callback,
    Object asyncState
)
Parameters
packageName (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginInsertItemTreeXml Method (sParent, sXml, bChangeIDs, callback, asyncState)

BeginInsertItemTreeXml Method (sParent, sXml, bChangeIDs, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginInsertItemTreeXml(String, String, Boolean, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginInsertItemTreeXml(
    string sParent,
    string sXml,
    bool bChangeIDs,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sParent (String)
sXml (String)
bChangeIDs (Boolean)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginIsLoggedIn Method (callback, asyncState)

BeginIsLoggedIn Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginIsLoggedIn(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginIsLoggedIn(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginIsPreviewing Method (callback, asyncState)

BeginIsPreviewing Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginIsPreviewing(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginIsPreviewing(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginIsSessionValid Method (callback, asyncState)

BeginIsSessionValid Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginIsSessionValid(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginIsSessionValid(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginIsWebEditing Method (callback, asyncState)

BeginIsWebEditing Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginIsWebEditing(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginIsWebEditing(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginLoadLayout Method (sID, callback, asyncState)

BeginLoadLayout Method (sID, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginLoadLayout(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginLoadLayout(
    string sID,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sID (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginLoadPackage Method (sName, callback, asyncState)

BeginLoadPackage Method (sName, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginLoadPackage(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginLoadPackage(
    string sName,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sName (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginLoadPublishFile Method (filename, callback, asyncState)

BeginLoadPublishFile Method (filename, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginLoadPublishFile(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginLoadPublishFile(
    string filename,
    AsyncCallback callback,
    Object asyncState
)
Parameters
filename (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginLoadXslFile Method (sID, callback, asyncState)

BeginLoadXslFile Method (sID, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginLoadXslFile(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginLoadXslFile(
    string sID,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sID (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginLogin Method (sUserName, sPassword, callback, asyncState)

BeginLogin Method (sUserName, sPassword, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginLogin(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginLogin(
    string sUserName,
    string sPassword,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sUserName (String)
sPassword (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginLogout Method (callback, asyncState)

BeginLogout Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginLogout(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginLogout(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginMoveItemTo Method (sItemID, sDestinationID, callback, asyncState)

BeginMoveItemTo Method (sItemID, sDestinationID, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginMoveItemTo(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginMoveItemTo(
    string sItemID,
    string sDestinationID,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sItemID (String)
sDestinationID (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginNewLayout Method (sName, callback, asyncState)

BeginNewLayout Method (sName, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginNewLayout(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginNewLayout(
    string sName,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sName (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginPing Method (callback, asyncState)

BeginPing Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginPing(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginPing(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginPublish Method (publishAll, rootItemID, groups, callback, asyncState)

BeginPublish Method (publishAll, rootItemID, groups, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginPublish(Boolean, String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginPublish(
    bool publishAll,
    string rootItemID,
    string groups,
    AsyncCallback callback,
    Object asyncState
)
Parameters
publishAll (Boolean)
rootItemID (String)
groups (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginPublishItem Method (itemPath, groups, deep, callback, asyncState)

BeginPublishItem Method (itemPath, groups, deep, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginPublishItem(String, String, Boolean, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginPublishItem(
    string itemPath,
    string groups,
    bool deep,
    AsyncCallback callback,
    Object asyncState
)
Parameters
itemPath (String)
groups (String)
deep (Boolean)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginReloadDatabase Method (callback, asyncState)

BeginReloadDatabase Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginReloadDatabase(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginReloadDatabase(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginRenameItem Method (itemPath, name, callback, asyncState)

BeginRenameItem Method (itemPath, name, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginRenameItem(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginRenameItem(
    string itemPath,
    string name,
    AsyncCallback callback,
    Object asyncState
)
Parameters
itemPath (String)
name (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginResortChildren Method (path, callback, asyncState)

BeginResortChildren Method (path, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginResortChildren(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginResortChildren(
    string path,
    AsyncCallback callback,
    Object asyncState
)
Parameters
path (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSaveDatabase Method (callback, asyncState)

BeginSaveDatabase Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginSaveDatabase(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginSaveDatabase(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSaveItemChanges Method (sXml, callback, asyncState)

BeginSaveItemChanges Method (sXml, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginSaveItemChanges(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginSaveItemChanges(
    string sXml,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sXml (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSaveItems Method (xml, callback, asyncState)

BeginSaveItems Method (xml, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginSaveItems(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginSaveItems(
    string xml,
    AsyncCallback callback,
    Object asyncState
)
Parameters
xml (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSaveLayout Method (sID, sHtml, sTimestamp, bOverwrite, callback, asyncState)

BeginSaveLayout Method (sID, sHtml, sTimestamp, bOverwrite, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginSaveLayout(String, String, String, Boolean, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginSaveLayout(
    string sID,
    string sHtml,
    string sTimestamp,
    bool bOverwrite,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sID (String)
sHtml (String)
sTimestamp (String)
bOverwrite (Boolean)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSavePackage Method (sName, sXml, callback, asyncState)

BeginSavePackage Method (sName, sXml, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginSavePackage(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginSavePackage(
    string sName,
    string sXml,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sName (String)
sXml (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSavePageEditData Method (xml, callback, asyncState)

BeginSavePageEditData Method (xml, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginSavePageEditData(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginSavePageEditData(
    string xml,
    AsyncCallback callback,
    Object asyncState
)
Parameters
xml (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSaveXslFile Method (sID, sHtml, sTimestamp, bOverwrite, callback, asyncState)

BeginSaveXslFile Method (sID, sHtml, sTimestamp, bOverwrite, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginSaveXslFile(String, String, String, Boolean, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginSaveXslFile(
    string sID,
    string sHtml,
    string sTimestamp,
    bool bOverwrite,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sID (String)
sHtml (String)
sTimestamp (String)
bOverwrite (Boolean)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetClientLanguage Method (sLanguage, callback, asyncState)

BeginSetClientLanguage Method (sLanguage, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginSetClientLanguage(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginSetClientLanguage(
    string sLanguage,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sLanguage (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetLanguage Method (sLanguage, callback, asyncState)

BeginSetLanguage Method (sLanguage, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginSetLanguage(String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginSetLanguage(
    string sLanguage,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sLanguage (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginStartPreview Method (isoDate, groups, callback, asyncState)

BeginStartPreview Method (isoDate, groups, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginStartPreview(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginStartPreview(
    string isoDate,
    string groups,
    AsyncCallback callback,
    Object asyncState
)
Parameters
isoDate (String)
groups (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginStartWebEdit Method (callback, asyncState)

BeginStartWebEdit Method (callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginStartWebEdit(AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginStartWebEdit(
    AsyncCallback callback,
    Object asyncState
)
Parameters
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginTidyHtml Method (html, type, callback, asyncState)

BeginTidyHtml Method (html, type, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginTidyHtml(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginTidyHtml(
    string html,
    string type,
    AsyncCallback callback,
    Object asyncState
)
Parameters
html (String)
type (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginTidyHtmlEx Method (html, clean, filter, tidy, allowedTags, callback, asyncState)

BeginTidyHtmlEx Method (html, clean, filter, tidy, allowedTags, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginTidyHtmlEx(String, Boolean, Boolean, Boolean, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginTidyHtmlEx(
    string html,
    bool clean,
    bool filter,
    bool tidy,
    string allowedTags,
    AsyncCallback callback,
    Object asyncState
)
Parameters
html (String)
clean (Boolean)
filter (Boolean)
tidy (Boolean)
allowedTags (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginUpdateDocument Method (sPath, sXml, callback, asyncState)

BeginUpdateDocument Method (sPath, sXml, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginUpdateDocument(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginUpdateDocument(
    string sPath,
    string sXml,
    AsyncCallback callback,
    Object asyncState
)
Parameters
sPath (String)
sXml (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginUpdateSortorder Method (parentPath, list, callback, asyncState)

BeginUpdateSortorder Method (parentPath, list, callback, asyncState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BeginUpdateSortorder(String, String, AsyncCallback, Object)
Declaration Syntax
C#
public IAsyncResult BeginUpdateSortorder(
    string parentPath,
    string list,
    AsyncCallback callback,
    Object asyncState
)
Parameters
parentPath (String)
list (String)
callback (AsyncCallback)
asyncState (Object)
Remarks


BuildPackage Method (packageName)

BuildPackage Method (packageName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BuildPackage(String)
Declaration Syntax
C#
public XmlNode BuildPackage(
    string packageName
)
Parameters
packageName (String)
Remarks


BuildPackageAsync Method

BuildPackageAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BuildPackageAsync()()()
Members
Icon | Member | Description
 | BuildPackageAsync(String) |
 | BuildPackageAsync(String, Object) |


BuildPackageAsync Method (packageName)

BuildPackageAsync Method (packageName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BuildPackageAsync(String)
Declaration Syntax
C#
public void BuildPackageAsync(
    string packageName
)
Parameters
packageName (String)
Remarks


BuildPackageAsync Method (packageName, userState)

BuildPackageAsync Method (packageName, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BuildPackageAsync(String, Object)
Declaration Syntax
C#
public void BuildPackageAsync(
    string packageName,
    Object userState
)
Parameters
packageName (String)
userState (Object)
Remarks


BuildPackageCompleted Event

BuildPackageCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► BuildPackageCompleted
Declaration Syntax
C#
public event BuildPackageCompletedEventHandler BuildPackageCompleted
Remarks


CancelAsync Method (userState)

CancelAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CancelAsync(Object)
Declaration Syntax
C#
public void CancelAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


CanLogin Method

CanLogin Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CanLogin()()()
Declaration Syntax
C#
public bool CanLogin()
Remarks


CanLoginAsync Method

CanLoginAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CanLoginAsync()()()
Members
Icon | Member | Description
 | CanLoginAsync()()() |
 | CanLoginAsync(Object) |


CanLoginAsync Method

CanLoginAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CanLoginAsync()()()
Declaration Syntax
C#
public void CanLoginAsync()
Remarks


CanLoginAsync Method (userState)

CanLoginAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CanLoginAsync(Object)
Declaration Syntax
C#
public void CanLoginAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


CanLoginCompleted Event

CanLoginCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CanLoginCompleted
Declaration Syntax
C#
public event CanLoginCompletedEventHandler CanLoginCompleted
Remarks


CanPublishIncrementally Method

CanPublishIncrementally Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CanPublishIncrementally()()()
Declaration Syntax
C#
public bool CanPublishIncrementally()
Remarks


CanPublishIncrementallyAsync Method

CanPublishIncrementallyAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CanPublishIncrementallyAsync()()()
Members
Icon | Member | Description
 | CanPublishIncrementallyAsync()()() |
 | CanPublishIncrementallyAsync(Object) |


CanPublishIncrementallyAsync Method

CanPublishIncrementallyAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CanPublishIncrementallyAsync()()()
Declaration Syntax
C#
public void CanPublishIncrementallyAsync()
Remarks


CanPublishIncrementallyAsync Method (userState)

CanPublishIncrementallyAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CanPublishIncrementallyAsync(Object)
Declaration Syntax
C#
public void CanPublishIncrementallyAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


CanPublishIncrementallyCompleted Event

CanPublishIncrementallyCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CanPublishIncrementallyCompleted
Declaration Syntax
C#
public event CanPublishIncrementallyCompletedEventHandler CanPublishIncrementallyCompleted
Remarks


CompactDatabase Method

CompactDatabase Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CompactDatabase()()()
Declaration Syntax
C#
public string CompactDatabase()
Remarks


CompactDatabaseAsync Method

CompactDatabaseAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CompactDatabaseAsync()()()
Members
Icon | Member | Description
 | CompactDatabaseAsync()()() |
 | CompactDatabaseAsync(Object) |


CompactDatabaseAsync Method

CompactDatabaseAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CompactDatabaseAsync()()()
Declaration Syntax
C#
public void CompactDatabaseAsync()
Remarks


CompactDatabaseAsync Method (userState)

CompactDatabaseAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CompactDatabaseAsync(Object)
Declaration Syntax
C#
public void CompactDatabaseAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


CompactDatabaseCompleted Event

CompactDatabaseCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CompactDatabaseCompleted
Declaration Syntax
C#
public event CompactDatabaseCompletedEventHandler CompactDatabaseCompleted
Remarks


CopyItemTo Method (sItemID, sDestinationID)

CopyItemTo Method (sItemID, sDestinationID)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CopyItemTo(String, String)
Declaration Syntax
C#
public string CopyItemTo(
    string sItemID,
    string sDestinationID
)
Parameters
sItemID (String)
sDestinationID (String)
Remarks


CopyItemToAsync Method

CopyItemToAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CopyItemToAsync()()()
Members
Icon | Member | Description
 | CopyItemToAsync(String, String) |
 | CopyItemToAsync(String, String, Object) |


CopyItemToAsync Method (sItemID, sDestinationID)

CopyItemToAsync Method (sItemID, sDestinationID)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CopyItemToAsync(String, String)
Declaration Syntax
C#
public void CopyItemToAsync(
    string sItemID,
    string sDestinationID
)
Parameters
sItemID (String)
sDestinationID (String)
Remarks


CopyItemToAsync Method (sItemID, sDestinationID, userState)

CopyItemToAsync Method (sItemID, sDestinationID, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CopyItemToAsync(String, String, Object)
Declaration Syntax
C#
public void CopyItemToAsync(
    string sItemID,
    string sDestinationID,
    Object userState
)
Parameters
sItemID (String)
sDestinationID (String)
userState (Object)
Remarks


CopyItemToCompleted Event

CopyItemToCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CopyItemToCompleted
Declaration Syntax
C#
public event CopyItemToCompletedEventHandler CopyItemToCompleted
Remarks


CreateDocument Method (sParent, sMaster, sXml)

CreateDocument Method (sParent, sMaster, sXml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateDocument(String, String, String)
Declaration Syntax
C#
public string CreateDocument(
    string sParent,
    string sMaster,
    string sXml
)
Parameters
sParent (String)
sMaster (String)
sXml (String)
Remarks


CreateDocumentAsync Method

CreateDocumentAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateDocumentAsync()()()
Members
Icon | Member | Description
 | CreateDocumentAsync(String, String, String) |
 | CreateDocumentAsync(String, String, String, Object) |


CreateDocumentAsync Method (sParent, sMaster, sXml)

CreateDocumentAsync Method (sParent, sMaster, sXml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateDocumentAsync(String, String, String)
Declaration Syntax
C#
public void CreateDocumentAsync(
    string sParent,
    string sMaster,
    string sXml
)
Parameters
sParent (String)
sMaster (String)
sXml (String)
Remarks


CreateDocumentAsync Method (sParent, sMaster, sXml, userState)

CreateDocumentAsync Method (sParent, sMaster, sXml, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateDocumentAsync(String, String, String, Object)
Declaration Syntax
C#
public void CreateDocumentAsync(
    string sParent,
    string sMaster,
    string sXml,
    Object userState
)
Parameters
sParent (String)
sMaster (String)
sXml (String)
userState (Object)
Remarks


CreateDocumentCompleted Event

CreateDocumentCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateDocumentCompleted
Declaration Syntax
C#
public event CreateDocumentCompletedEventHandler CreateDocumentCompleted
Remarks


CreateMaster Method (sName, sTemplate)

CreateMaster Method (sName, sTemplate)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateMaster(String, String)
Declaration Syntax
C#
public XmlNode CreateMaster(
    string sName,
    string sTemplate
)
Parameters
sName (String)
sTemplate (String)
Remarks


CreateMasterAsync Method

CreateMasterAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateMasterAsync()()()
Members
Icon | Member | Description
 | CreateMasterAsync(String, String) |
 | CreateMasterAsync(String, String, Object) |


CreateMasterAsync Method (sName, sTemplate)

CreateMasterAsync Method (sName, sTemplate)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateMasterAsync(String, String)
Declaration Syntax
C#
public void CreateMasterAsync(
    string sName,
    string sTemplate
)
Parameters
sName (String)
sTemplate (String)
Remarks


CreateMasterAsync Method (sName, sTemplate, userState)

CreateMasterAsync Method (sName, sTemplate, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateMasterAsync(String, String, Object)
Declaration Syntax
C#
public void CreateMasterAsync(
    string sName,
    string sTemplate,
    Object userState
)
Parameters
sName (String)
sTemplate (String)
userState (Object)
Remarks


CreateMasterCompleted Event

CreateMasterCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateMasterCompleted
Declaration Syntax
C#
public event CreateMasterCompletedEventHandler CreateMasterCompleted
Remarks


CreateTemplate Method (sName)

CreateTemplate Method (sName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateTemplate(String)
Declaration Syntax
C#
public XmlNode CreateTemplate(
    string sName
)
Parameters
sName (String)
Remarks


CreateTemplateAsync Method

CreateTemplateAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateTemplateAsync()()()
Members
Icon | Member | Description
 | CreateTemplateAsync(String) |
 | CreateTemplateAsync(String, Object) |


CreateTemplateAsync Method (sName)

CreateTemplateAsync Method (sName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateTemplateAsync(String)
Declaration Syntax
C#
public void CreateTemplateAsync(
    string sName
)
Parameters
sName (String)
Remarks


CreateTemplateAsync Method (sName, userState)

CreateTemplateAsync Method (sName, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateTemplateAsync(String, Object)
Declaration Syntax
C#
public void CreateTemplateAsync(
    string sName,
    Object userState
)
Parameters
sName (String)
userState (Object)
Remarks


CreateTemplateCompleted Event

CreateTemplateCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► CreateTemplateCompleted
Declaration Syntax
C#
public event CreateTemplateCompletedEventHandler CreateTemplateCompleted
Remarks


DeleteChildren Method (path)

DeleteChildren Method (path)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteChildren(String)
Declaration Syntax
C#
public int DeleteChildren(
    string path
)
Parameters
path (String)
Remarks


DeleteChildrenAsync Method

DeleteChildrenAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteChildrenAsync()()()
Members
Icon | Member | Description
 | DeleteChildrenAsync(String) |
 | DeleteChildrenAsync(String, Object) |


DeleteChildrenAsync Method (path)

DeleteChildrenAsync Method (path)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteChildrenAsync(String)
Declaration Syntax
C#
public void DeleteChildrenAsync(
    string path
)
Parameters
path (String)
Remarks


DeleteChildrenAsync Method (path, userState)

DeleteChildrenAsync Method (path, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteChildrenAsync(String, Object)
Declaration Syntax
C#
public void DeleteChildrenAsync(
    string path,
    Object userState
)
Parameters
path (String)
userState (Object)
Remarks


DeleteChildrenCompleted Event

DeleteChildrenCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteChildrenCompleted
Declaration Syntax
C#
public event DeleteChildrenCompletedEventHandler DeleteChildrenCompleted
Remarks


DeleteDocument Method (sPath)

DeleteDocument Method (sPath)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteDocument(String)
Declaration Syntax
C#
public void DeleteDocument(
    string sPath
)
Parameters
sPath (String)
Remarks


DeleteDocumentAsync Method

DeleteDocumentAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteDocumentAsync()()()
Members
Icon | Member | Description
 | DeleteDocumentAsync(String) |
 | DeleteDocumentAsync(String, Object) |


DeleteDocumentAsync Method (sPath)

DeleteDocumentAsync Method (sPath)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteDocumentAsync(String)
Declaration Syntax
C#
public void DeleteDocumentAsync(
    string sPath
)
Parameters
sPath (String)
Remarks


DeleteDocumentAsync Method (sPath, userState)

DeleteDocumentAsync Method (sPath, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteDocumentAsync(String, Object)
Declaration Syntax
C#
public void DeleteDocumentAsync(
    string sPath,
    Object userState
)
Parameters
sPath (String)
userState (Object)
Remarks


DeleteDocumentCompleted Event

DeleteDocumentCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteDocumentCompleted
Declaration Syntax
C#
public event DeleteDocumentCompletedEventHandler DeleteDocumentCompleted
Remarks


DeleteItem Method (sItemList)

DeleteItem Method (sItemList)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItem(String)
Declaration Syntax
C#
public void DeleteItem(
    string sItemList
)
Parameters
sItemList (String)
Remarks


DeleteItemAsync Method

DeleteItemAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItemAsync()()()
Members
Icon | Member | Description
 | DeleteItemAsync(String) |
 | DeleteItemAsync(String, Object) |


DeleteItemAsync Method (sItemList)

DeleteItemAsync Method (sItemList)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItemAsync(String)
Declaration Syntax
C#
public void DeleteItemAsync(
    string sItemList
)
Parameters
sItemList (String)
Remarks


DeleteItemAsync Method (sItemList, userState)

DeleteItemAsync Method (sItemList, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItemAsync(String, Object)
Declaration Syntax
C#
public void DeleteItemAsync(
    string sItemList,
    Object userState
)
Parameters
sItemList (String)
userState (Object)
Remarks


DeleteItemCompleted Event

DeleteItemCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItemCompleted
Declaration Syntax
C#
public event DeleteItemCompletedEventHandler DeleteItemCompleted
Remarks


DeleteItemVersion Method (sItemID, sVersion)

DeleteItemVersion Method (sItemID, sVersion)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItemVersion(String, String)
Declaration Syntax
C#
public void DeleteItemVersion(
    string sItemID,
    string sVersion
)
Parameters
sItemID (String)
sVersion (String)
Remarks


DeleteItemVersionAsync Method

DeleteItemVersionAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItemVersionAsync()()()
Members
Icon | Member | Description
 | DeleteItemVersionAsync(String, String) |
 | DeleteItemVersionAsync(String, String, Object) |


DeleteItemVersionAsync Method (sItemID, sVersion)

DeleteItemVersionAsync Method (sItemID, sVersion)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItemVersionAsync(String, String)
Declaration Syntax
C#
public void DeleteItemVersionAsync(
    string sItemID,
    string sVersion
)
Parameters
sItemID (String)
sVersion (String)
Remarks


DeleteItemVersionAsync Method (sItemID, sVersion, userState)

DeleteItemVersionAsync Method (sItemID, sVersion, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItemVersionAsync(String, String, Object)
Declaration Syntax
C#
public void DeleteItemVersionAsync(
    string sItemID,
    string sVersion,
    Object userState
)
Parameters
sItemID (String)
sVersion (String)
userState (Object)
Remarks


DeleteItemVersionCompleted Event

DeleteItemVersionCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItemVersionCompleted
Declaration Syntax
C#
public event DeleteItemVersionCompletedEventHandler DeleteItemVersionCompleted
Remarks


DeleteItemVersions Method (sItemID, sVersions)

DeleteItemVersions Method (sItemID, sVersions)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItemVersions(String, String)
Declaration Syntax
C#
public void DeleteItemVersions(
    string sItemID,
    string sVersions
)
Parameters
sItemID (String)
sVersions (String)
Remarks


DeleteItemVersionsAsync Method

DeleteItemVersionsAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItemVersionsAsync()()()
Members
Icon | Member | Description
 | DeleteItemVersionsAsync(String, String) |
 | DeleteItemVersionsAsync(String, String, Object) |


DeleteItemVersionsAsync Method (sItemID, sVersions)

DeleteItemVersionsAsync Method (sItemID, sVersions)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItemVersionsAsync(String, String)
Declaration Syntax
C#
public void DeleteItemVersionsAsync(
    string sItemID,
    string sVersions
)
Parameters
sItemID (String)
sVersions (String)
Remarks


DeleteItemVersionsAsync Method (sItemID, sVersions, userState)

DeleteItemVersionsAsync Method (sItemID, sVersions, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItemVersionsAsync(String, String, Object)
Declaration Syntax
C#
public void DeleteItemVersionsAsync(
    string sItemID,
    string sVersions,
    Object userState
)
Parameters
sItemID (String)
sVersions (String)
userState (Object)
Remarks


DeleteItemVersionsCompleted Event

DeleteItemVersionsCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DeleteItemVersionsCompleted
Declaration Syntax
C#
public event DeleteItemVersionsCompletedEventHandler DeleteItemVersionsCompleted
Remarks


Duplicate Method (sItemID, sName)

Duplicate Method (sItemID, sName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► Duplicate(String, String)
Declaration Syntax
C#
public XmlNode Duplicate(
    string sItemID,
    string sName
)
Parameters
sItemID (String)
sName (String)
Remarks


DuplicateAsync Method

DuplicateAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DuplicateAsync()()()
Members
Icon | Member | Description
 | DuplicateAsync(String, String) |
 | DuplicateAsync(String, String, Object) |


DuplicateAsync Method (sItemID, sName)

DuplicateAsync Method (sItemID, sName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DuplicateAsync(String, String)
Declaration Syntax
C#
public void DuplicateAsync(
    string sItemID,
    string sName
)
Parameters
sItemID (String)
sName (String)
Remarks


DuplicateAsync Method (sItemID, sName, userState)

DuplicateAsync Method (sItemID, sName, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DuplicateAsync(String, String, Object)
Declaration Syntax
C#
public void DuplicateAsync(
    string sItemID,
    string sName,
    Object userState
)
Parameters
sItemID (String)
sName (String)
userState (Object)
Remarks


DuplicateCompleted Event

DuplicateCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► DuplicateCompleted
Declaration Syntax
C#
public event DuplicateCompletedEventHandler DuplicateCompleted
Remarks


EmptyRecycleBin Method

EmptyRecycleBin Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EmptyRecycleBin()()()
Declaration Syntax
C#
public string EmptyRecycleBin()
Remarks


EmptyRecycleBinAsync Method

EmptyRecycleBinAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EmptyRecycleBinAsync()()()
Members
Icon | Member | Description
 | EmptyRecycleBinAsync()()() |
 | EmptyRecycleBinAsync(Object) |


EmptyRecycleBinAsync Method

EmptyRecycleBinAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EmptyRecycleBinAsync()()()
Declaration Syntax
C#
public void EmptyRecycleBinAsync()
Remarks


EmptyRecycleBinAsync Method (userState)

EmptyRecycleBinAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EmptyRecycleBinAsync(Object)
Declaration Syntax
C#
public void EmptyRecycleBinAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


EmptyRecycleBinCompleted Event

EmptyRecycleBinCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EmptyRecycleBinCompleted
Declaration Syntax
C#
public event EmptyRecycleBinCompletedEventHandler EmptyRecycleBinCompleted
Remarks


EndAbout Method (asyncResult)

EndAbout Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndAbout(IAsyncResult)
Declaration Syntax
C#
public string EndAbout(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddItemFromMaster Method (asyncResult)

EndAddItemFromMaster Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndAddItemFromMaster(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndAddItemFromMaster(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddItemFromTemplate Method (asyncResult)

EndAddItemFromTemplate Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndAddItemFromTemplate(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndAddItemFromTemplate(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddItemRevision Method (asyncResult)

EndAddItemRevision Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndAddItemRevision(IAsyncResult)
Declaration Syntax
C#
public string EndAddItemRevision(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndApplyExtranetSecurityToChildren Method (asyncResult)

EndApplyExtranetSecurityToChildren Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndApplyExtranetSecurityToChildren(IAsyncResult)
Declaration Syntax
C#
public string EndApplyExtranetSecurityToChildren(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndApplySecurityToChildren Method (asyncResult)

EndApplySecurityToChildren Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndApplySecurityToChildren(IAsyncResult)
Declaration Syntax
C#
public string EndApplySecurityToChildren(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndApplySimpleUpdate Method (asyncResult)

EndApplySimpleUpdate Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndApplySimpleUpdate(IAsyncResult)
Declaration Syntax
C#
public string EndApplySimpleUpdate(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndApproveItems Method (asyncResult)

EndApproveItems Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndApproveItems(IAsyncResult)
Declaration Syntax
C#
public string EndApproveItems(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndBackupDatabase Method (asyncResult)

EndBackupDatabase Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndBackupDatabase(IAsyncResult)
Declaration Syntax
C#
public void EndBackupDatabase(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndBuildPackage Method (asyncResult)

EndBuildPackage Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndBuildPackage(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndBuildPackage(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndCanLogin Method (asyncResult)

EndCanLogin Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndCanLogin(IAsyncResult)
Declaration Syntax
C#
public bool EndCanLogin(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndCanPublishIncrementally Method (asyncResult)

EndCanPublishIncrementally Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndCanPublishIncrementally(IAsyncResult)
Declaration Syntax
C#
public bool EndCanPublishIncrementally(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndCompactDatabase Method (asyncResult)

EndCompactDatabase Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndCompactDatabase(IAsyncResult)
Declaration Syntax
C#
public string EndCompactDatabase(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndCopyItemTo Method (asyncResult)

EndCopyItemTo Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndCopyItemTo(IAsyncResult)
Declaration Syntax
C#
public string EndCopyItemTo(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndCreateDocument Method (asyncResult)

EndCreateDocument Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndCreateDocument(IAsyncResult)
Declaration Syntax
C#
public string EndCreateDocument(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndCreateMaster Method (asyncResult)

EndCreateMaster Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndCreateMaster(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndCreateMaster(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndCreateTemplate Method (asyncResult)

EndCreateTemplate Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndCreateTemplate(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndCreateTemplate(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndDeleteChildren Method (asyncResult)

EndDeleteChildren Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndDeleteChildren(IAsyncResult)
Declaration Syntax
C#
public int EndDeleteChildren(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndDeleteDocument Method (asyncResult)

EndDeleteDocument Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndDeleteDocument(IAsyncResult)
Declaration Syntax
C#
public void EndDeleteDocument(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndDeleteItem Method (asyncResult)

EndDeleteItem Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndDeleteItem(IAsyncResult)
Declaration Syntax
C#
public void EndDeleteItem(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndDeleteItemVersion Method (asyncResult)

EndDeleteItemVersion Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndDeleteItemVersion(IAsyncResult)
Declaration Syntax
C#
public void EndDeleteItemVersion(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndDeleteItemVersions Method (asyncResult)

EndDeleteItemVersions Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndDeleteItemVersions(IAsyncResult)
Declaration Syntax
C#
public void EndDeleteItemVersions(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndDuplicate Method (asyncResult)

EndDuplicate Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndDuplicate(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndDuplicate(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndEmptyRecycleBin Method (asyncResult)

EndEmptyRecycleBin Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndEmptyRecycleBin(IAsyncResult)
Declaration Syntax
C#
public string EndEmptyRecycleBin(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndEndPreview Method (asyncResult)

EndEndPreview Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndEndPreview(IAsyncResult)
Declaration Syntax
C#
public void EndEndPreview(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndEndWebEdit Method (asyncResult)

EndEndWebEdit Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndEndWebEdit(IAsyncResult)
Declaration Syntax
C#
public void EndEndWebEdit(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndExpandLinkedDatabases Method (asyncResult)

EndExpandLinkedDatabases Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndExpandLinkedDatabases(IAsyncResult)
Declaration Syntax
C#
public void EndExpandLinkedDatabases(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndFindItem Method (asyncResult)

EndFindItem Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndFindItem(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndFindItem(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetClientLanguage Method (asyncResult)

EndGetClientLanguage Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetClientLanguage(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndGetClientLanguage(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetControlHtml Method (asyncResult)

EndGetControlHtml Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetControlHtml(IAsyncResult)
Declaration Syntax
C#
public string EndGetControlHtml(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetDotMenu Method (asyncResult)

EndGetDotMenu Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetDotMenu(IAsyncResult)
Declaration Syntax
C#
public string EndGetDotMenu(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetHomeItem Method (asyncResult)

EndGetHomeItem Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetHomeItem(IAsyncResult)
Declaration Syntax
C#
public string EndGetHomeItem(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetItem Method (asyncResult)

EndGetItem Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetItem(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndGetItem(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetItemField Method (asyncResult)

EndGetItemField Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetItemField(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndGetItemField(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetItemFields Method (asyncResult)

EndGetItemFields Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetItemFields(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndGetItemFields(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetItemInfo Method (asyncResult)

EndGetItemInfo Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetItemInfo(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndGetItemInfo(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetItemMasters Method (asyncResult)

EndGetItemMasters Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetItemMasters(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndGetItemMasters(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetItemPath Method (asyncResult)

EndGetItemPath Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetItemPath(IAsyncResult)
Declaration Syntax
C#
public string EndGetItemPath(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetItemsInfo Method (asyncResult)

EndGetItemsInfo Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetItemsInfo(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndGetItemsInfo(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetItemTree Method (asyncResult)

EndGetItemTree Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetItemTree(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndGetItemTree(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetItemTreeXml Method (asyncResult)

EndGetItemTreeXml Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetItemTreeXml(IAsyncResult)
Declaration Syntax
C#
public string EndGetItemTreeXml(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetItemXml Method (asyncResult)

EndGetItemXml Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetItemXml(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndGetItemXml(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetLocalizedString Method (asyncResult)

EndGetLocalizedString Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetLocalizedString(IAsyncResult)
Declaration Syntax
C#
public string EndGetLocalizedString(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetMediaInfo Method (asyncResult)

EndGetMediaInfo Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetMediaInfo(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndGetMediaInfo(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetMediaItems Method (asyncResult)

EndGetMediaItems Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetMediaItems(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndGetMediaItems(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetMethodHtml Method (asyncResult)

EndGetMethodHtml Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetMethodHtml(IAsyncResult)
Declaration Syntax
C#
public string EndGetMethodHtml(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetNewItemXml Method (asyncResult)

EndGetNewItemXml Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetNewItemXml(IAsyncResult)
Declaration Syntax
C#
public string EndGetNewItemXml(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetPackageInfo Method (asyncResult)

EndGetPackageInfo Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetPackageInfo(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndGetPackageInfo(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetPackageXml Method (asyncResult)

EndGetPackageXml Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetPackageXml(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndGetPackageXml(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetParentID Method (asyncResult)

EndGetParentID Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetParentID(IAsyncResult)
Declaration Syntax
C#
public string EndGetParentID(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetParentPath Method (asyncResult)

EndGetParentPath Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetParentPath(IAsyncResult)
Declaration Syntax
C#
public string EndGetParentPath(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetPublishingStatus Method (asyncResult)

EndGetPublishingStatus Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetPublishingStatus(IAsyncResult)
Declaration Syntax
C#
public string EndGetPublishingStatus(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSiblingPath Method (asyncResult)

EndGetSiblingPath Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetSiblingPath(IAsyncResult)
Declaration Syntax
C#
public string EndGetSiblingPath(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetThreadErrors Method (asyncResult)

EndGetThreadErrors Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetThreadErrors(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndGetThreadErrors(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetWebPageHtml Method (asyncResult)

EndGetWebPageHtml Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetWebPageHtml(IAsyncResult)
Declaration Syntax
C#
public string EndGetWebPageHtml(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetXslFileHtml Method (asyncResult)

EndGetXslFileHtml Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndGetXslFileHtml(IAsyncResult)
Declaration Syntax
C#
public string EndGetXslFileHtml(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndImportPackage Method (asyncResult)

EndImportPackage Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndImportPackage(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndImportPackage(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndInsertItemTreeXml Method (asyncResult)

EndInsertItemTreeXml Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndInsertItemTreeXml(IAsyncResult)
Declaration Syntax
C#
public string EndInsertItemTreeXml(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndIsLoggedIn Method (asyncResult)

EndIsLoggedIn Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndIsLoggedIn(IAsyncResult)
Declaration Syntax
C#
public bool EndIsLoggedIn(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndIsPreviewing Method (asyncResult)

EndIsPreviewing Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndIsPreviewing(IAsyncResult)
Declaration Syntax
C#
public bool EndIsPreviewing(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndIsSessionValid Method (asyncResult)

EndIsSessionValid Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndIsSessionValid(IAsyncResult)
Declaration Syntax
C#
public bool EndIsSessionValid(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndIsWebEditing Method (asyncResult)

EndIsWebEditing Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndIsWebEditing(IAsyncResult)
Declaration Syntax
C#
public bool EndIsWebEditing(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndLoadLayout Method (asyncResult)

EndLoadLayout Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndLoadLayout(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndLoadLayout(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndLoadPackage Method (asyncResult)

EndLoadPackage Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndLoadPackage(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndLoadPackage(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndLoadPublishFile Method (asyncResult)

EndLoadPublishFile Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndLoadPublishFile(IAsyncResult)
Declaration Syntax
C#
public void EndLoadPublishFile(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndLoadXslFile Method (asyncResult)

EndLoadXslFile Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndLoadXslFile(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndLoadXslFile(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndLogin Method (asyncResult)

EndLogin Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndLogin(IAsyncResult)
Declaration Syntax
C#
public void EndLogin(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndLogout Method (asyncResult)

EndLogout Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndLogout(IAsyncResult)
Declaration Syntax
C#
public void EndLogout(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndMoveItemTo Method (asyncResult)

EndMoveItemTo Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndMoveItemTo(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndMoveItemTo(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndNewLayout Method (asyncResult)

EndNewLayout Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndNewLayout(IAsyncResult)
Declaration Syntax
C#
public XmlNode EndNewLayout(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndPing Method (asyncResult)

EndPing Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndPing(IAsyncResult)
Declaration Syntax
C#
public string EndPing(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndPreview Method

EndPreview Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndPreview()()()
Declaration Syntax
C#
public void EndPreview()
Remarks


EndPreviewAsync Method

EndPreviewAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndPreviewAsync()()()
Members
Icon | Member | Description
 | EndPreviewAsync()()() |
 | EndPreviewAsync(Object) |


EndPreviewAsync Method

EndPreviewAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndPreviewAsync()()()
Declaration Syntax
C#
public void EndPreviewAsync()
Remarks


EndPreviewAsync Method (userState)

EndPreviewAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndPreviewAsync(Object)
Declaration Syntax
C#
public void EndPreviewAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


EndPreviewCompleted Event

EndPreviewCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndPreviewCompleted
Declaration Syntax
C#
public event EndPreviewCompletedEventHandler EndPreviewCompleted
Remarks


EndPublish Method (asyncResult)

EndPublish Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndPublish(IAsyncResult)
Declaration Syntax
C#
public string EndPublish(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndPublishItem Method (asyncResult)

EndPublishItem Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndPublishItem(IAsyncResult)
Declaration Syntax
C#
public string EndPublishItem(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndReloadDatabase Method (asyncResult)

EndReloadDatabase Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndReloadDatabase(IAsyncResult)
Declaration Syntax
C#
public void EndReloadDatabase(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndRenameItem Method (asyncResult)

EndRenameItem Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndRenameItem(IAsyncResult)
Declaration Syntax
C#
public void EndRenameItem(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndResortChildren Method (asyncResult)

EndResortChildren Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndResortChildren(IAsyncResult)
Declaration Syntax
C#
public void EndResortChildren(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSaveDatabase Method (asyncResult)

EndSaveDatabase Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndSaveDatabase(IAsyncResult)
Declaration Syntax
C#
public void EndSaveDatabase(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSaveItemChanges Method (asyncResult)

EndSaveItemChanges Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndSaveItemChanges(IAsyncResult)
Declaration Syntax
C#
public string EndSaveItemChanges(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSaveItems Method (asyncResult)

EndSaveItems Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndSaveItems(IAsyncResult)
Declaration Syntax
C#
public void EndSaveItems(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSaveLayout Method (asyncResult)

EndSaveLayout Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndSaveLayout(IAsyncResult)
Declaration Syntax
C#
public string EndSaveLayout(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSavePackage Method (asyncResult)

EndSavePackage Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndSavePackage(IAsyncResult)
Declaration Syntax
C#
public void EndSavePackage(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSavePageEditData Method (asyncResult)

EndSavePageEditData Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndSavePageEditData(IAsyncResult)
Declaration Syntax
C#
public string EndSavePageEditData(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSaveXslFile Method (asyncResult)

EndSaveXslFile Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndSaveXslFile(IAsyncResult)
Declaration Syntax
C#
public string EndSaveXslFile(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetClientLanguage Method (asyncResult)

EndSetClientLanguage Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndSetClientLanguage(IAsyncResult)
Declaration Syntax
C#
public void EndSetClientLanguage(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetLanguage Method (asyncResult)

EndSetLanguage Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndSetLanguage(IAsyncResult)
Declaration Syntax
C#
public void EndSetLanguage(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndStartPreview Method (asyncResult)

EndStartPreview Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndStartPreview(IAsyncResult)
Declaration Syntax
C#
public void EndStartPreview(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndStartWebEdit Method (asyncResult)

EndStartWebEdit Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndStartWebEdit(IAsyncResult)
Declaration Syntax
C#
public void EndStartWebEdit(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndTidyHtml Method (asyncResult)

EndTidyHtml Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndTidyHtml(IAsyncResult)
Declaration Syntax
C#
public string EndTidyHtml(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndTidyHtmlEx Method (asyncResult)

EndTidyHtmlEx Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndTidyHtmlEx(IAsyncResult)
Declaration Syntax
C#
public string EndTidyHtmlEx(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndUpdateDocument Method (asyncResult)

EndUpdateDocument Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndUpdateDocument(IAsyncResult)
Declaration Syntax
C#
public string EndUpdateDocument(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndUpdateSortorder Method (asyncResult)

EndUpdateSortorder Method (asyncResult)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndUpdateSortorder(IAsyncResult)
Declaration Syntax
C#
public void EndUpdateSortorder(
    IAsyncResult asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndWebEdit Method

EndWebEdit Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndWebEdit()()()
Declaration Syntax
C#
public void EndWebEdit()
Remarks


EndWebEditAsync Method

EndWebEditAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndWebEditAsync()()()
Members
Icon | Member | Description
 | EndWebEditAsync()()() |
 | EndWebEditAsync(Object) |


EndWebEditAsync Method

EndWebEditAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndWebEditAsync()()()
Declaration Syntax
C#
public void EndWebEditAsync()
Remarks


EndWebEditAsync Method (userState)

EndWebEditAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndWebEditAsync(Object)
Declaration Syntax
C#
public void EndWebEditAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


EndWebEditCompleted Event

EndWebEditCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► EndWebEditCompleted
Declaration Syntax
C#
public event EndWebEditCompletedEventHandler EndWebEditCompleted
Remarks


ExpandLinkedDatabases Method (expanded)

ExpandLinkedDatabases Method (expanded)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ExpandLinkedDatabases(String)
Declaration Syntax
C#
public void ExpandLinkedDatabases(
    string expanded
)
Parameters
expanded (String)
Remarks


ExpandLinkedDatabasesAsync Method

ExpandLinkedDatabasesAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ExpandLinkedDatabasesAsync()()()
Members
Icon | Member | Description
 | ExpandLinkedDatabasesAsync(String) |
 | ExpandLinkedDatabasesAsync(String, Object) |


ExpandLinkedDatabasesAsync Method (expanded)

ExpandLinkedDatabasesAsync Method (expanded)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ExpandLinkedDatabasesAsync(String)
Declaration Syntax
C#
public void ExpandLinkedDatabasesAsync(
    string expanded
)
Parameters
expanded (String)
Remarks


ExpandLinkedDatabasesAsync Method (expanded, userState)

ExpandLinkedDatabasesAsync Method (expanded, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ExpandLinkedDatabasesAsync(String, Object)
Declaration Syntax
C#
public void ExpandLinkedDatabasesAsync(
    string expanded,
    Object userState
)
Parameters
expanded (String)
userState (Object)
Remarks


ExpandLinkedDatabasesCompleted Event

ExpandLinkedDatabasesCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ExpandLinkedDatabasesCompleted
Declaration Syntax
C#
public event ExpandLinkedDatabasesCompletedEventHandler ExpandLinkedDatabasesCompleted
Remarks


FindItem Method (name, path, recurse, previousFound)

FindItem Method (name, path, recurse, previousFound)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► FindItem(String, String, Boolean, String)
Declaration Syntax
C#
public XmlNode FindItem(
    string name,
    string path,
    bool recurse,
    string previousFound
)
Parameters
name (String)
path (String)
recurse (Boolean)
previousFound (String)
Remarks


FindItemAsync Method

FindItemAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► FindItemAsync()()()
Members
Icon | Member | Description
 | FindItemAsync(String, String, Boolean, String) |
 | FindItemAsync(String, String, Boolean, String, Object) |


FindItemAsync Method (name, path, recurse, previousFound)

FindItemAsync Method (name, path, recurse, previousFound)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► FindItemAsync(String, String, Boolean, String)
Declaration Syntax
C#
public void FindItemAsync(
    string name,
    string path,
    bool recurse,
    string previousFound
)
Parameters
name (String)
path (String)
recurse (Boolean)
previousFound (String)
Remarks


FindItemAsync Method (name, path, recurse, previousFound, userState)

FindItemAsync Method (name, path, recurse, previousFound, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► FindItemAsync(String, String, Boolean, String, Object)
Declaration Syntax
C#
public void FindItemAsync(
    string name,
    string path,
    bool recurse,
    string previousFound,
    Object userState
)
Parameters
name (String)
path (String)
recurse (Boolean)
previousFound (String)
userState (Object)
Remarks


FindItemCompleted Event

FindItemCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► FindItemCompleted
Declaration Syntax
C#
public event FindItemCompletedEventHandler FindItemCompleted
Remarks


GetClientLanguage Method

GetClientLanguage Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetClientLanguage()()()
Declaration Syntax
C#
public XmlNode GetClientLanguage()
Remarks


GetClientLanguageAsync Method

GetClientLanguageAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetClientLanguageAsync()()()
Members
Icon | Member | Description
 | GetClientLanguageAsync()()() |
 | GetClientLanguageAsync(Object) |


GetClientLanguageAsync Method

GetClientLanguageAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetClientLanguageAsync()()()
Declaration Syntax
C#
public void GetClientLanguageAsync()
Remarks


GetClientLanguageAsync Method (userState)

GetClientLanguageAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetClientLanguageAsync(Object)
Declaration Syntax
C#
public void GetClientLanguageAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


GetClientLanguageCompleted Event

GetClientLanguageCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetClientLanguageCompleted
Declaration Syntax
C#
public event GetClientLanguageCompletedEventHandler GetClientLanguageCompleted
Remarks


GetControlHtml Method (controlName, properties, assemblyName)

GetControlHtml Method (controlName, properties, assemblyName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetControlHtml(String, XmlNode, String)
Declaration Syntax
C#
public string GetControlHtml(
    string controlName,
    XmlNode properties,
    string assemblyName
)
Parameters
controlName (String)
properties (XmlNode)
assemblyName (String)
Remarks


GetControlHtmlAsync Method

GetControlHtmlAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetControlHtmlAsync()()()
Members
Icon | Member | Description
 | GetControlHtmlAsync(String, XmlNode, String) |
 | GetControlHtmlAsync(String, XmlNode, String, Object) |


GetControlHtmlAsync Method (controlName, properties, assemblyName)

GetControlHtmlAsync Method (controlName, properties, assemblyName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetControlHtmlAsync(String, XmlNode, String)
Declaration Syntax
C#
public void GetControlHtmlAsync(
    string controlName,
    XmlNode properties,
    string assemblyName
)
Parameters
controlName (String)
properties (XmlNode)
assemblyName (String)
Remarks


GetControlHtmlAsync Method (controlName, properties, assemblyName, userState)

GetControlHtmlAsync Method (controlName, properties, assemblyName, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetControlHtmlAsync(String, XmlNode, String, Object)
Declaration Syntax
C#
public void GetControlHtmlAsync(
    string controlName,
    XmlNode properties,
    string assemblyName,
    Object userState
)
Parameters
controlName (String)
properties (XmlNode)
assemblyName (String)
userState (Object)
Remarks


GetControlHtmlCompleted Event

GetControlHtmlCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetControlHtmlCompleted
Declaration Syntax
C#
public event GetControlHtmlCompletedEventHandler GetControlHtmlCompleted
Remarks


GetDotMenu Method (sItemID)

GetDotMenu Method (sItemID)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetDotMenu(String)
Declaration Syntax
C#
public string GetDotMenu(
    string sItemID
)
Parameters
sItemID (String)
Remarks


GetDotMenuAsync Method

GetDotMenuAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetDotMenuAsync()()()
Members
Icon | Member | Description
 | GetDotMenuAsync(String) |
 | GetDotMenuAsync(String, Object) |


GetDotMenuAsync Method (sItemID)

GetDotMenuAsync Method (sItemID)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetDotMenuAsync(String)
Declaration Syntax
C#
public void GetDotMenuAsync(
    string sItemID
)
Parameters
sItemID (String)
Remarks


GetDotMenuAsync Method (sItemID, userState)

GetDotMenuAsync Method (sItemID, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetDotMenuAsync(String, Object)
Declaration Syntax
C#
public void GetDotMenuAsync(
    string sItemID,
    Object userState
)
Parameters
sItemID (String)
userState (Object)
Remarks


GetDotMenuCompleted Event

GetDotMenuCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetDotMenuCompleted
Declaration Syntax
C#
public event GetDotMenuCompletedEventHandler GetDotMenuCompleted
Remarks


GetHomeItem Method

GetHomeItem Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetHomeItem()()()
Declaration Syntax
C#
public string GetHomeItem()
Remarks


GetHomeItemAsync Method

GetHomeItemAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetHomeItemAsync()()()
Members
Icon | Member | Description
 | GetHomeItemAsync()()() |
 | GetHomeItemAsync(Object) |


GetHomeItemAsync Method

GetHomeItemAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetHomeItemAsync()()()
Declaration Syntax
C#
public void GetHomeItemAsync()
Remarks


GetHomeItemAsync Method (userState)

GetHomeItemAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetHomeItemAsync(Object)
Declaration Syntax
C#
public void GetHomeItemAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


GetHomeItemCompleted Event

GetHomeItemCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetHomeItemCompleted
Declaration Syntax
C#
public event GetHomeItemCompletedEventHandler GetHomeItemCompleted
Remarks


GetItem Method (sPath)

GetItem Method (sPath)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItem(String)
Declaration Syntax
C#
public XmlNode GetItem(
    string sPath
)
Parameters
sPath (String)
Remarks


GetItemAsync Method

GetItemAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemAsync()()()
Members
Icon | Member | Description
 | GetItemAsync(String) |
 | GetItemAsync(String, Object) |


GetItemAsync Method (sPath)

GetItemAsync Method (sPath)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemAsync(String)
Declaration Syntax
C#
public void GetItemAsync(
    string sPath
)
Parameters
sPath (String)
Remarks


GetItemAsync Method (sPath, userState)

GetItemAsync Method (sPath, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemAsync(String, Object)
Declaration Syntax
C#
public void GetItemAsync(
    string sPath,
    Object userState
)
Parameters
sPath (String)
userState (Object)
Remarks


GetItemCompleted Event

GetItemCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemCompleted
Declaration Syntax
C#
public event GetItemCompletedEventHandler GetItemCompleted
Remarks


GetItemField Method (sItemPath, sField)

GetItemField Method (sItemPath, sField)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemField(String, String)
Declaration Syntax
C#
public XmlNode GetItemField(
    string sItemPath,
    string sField
)
Parameters
sItemPath (String)
sField (String)
Remarks


GetItemFieldAsync Method

GetItemFieldAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemFieldAsync()()()
Members
Icon | Member | Description
 | GetItemFieldAsync(String, String) |
 | GetItemFieldAsync(String, String, Object) |


GetItemFieldAsync Method (sItemPath, sField)

GetItemFieldAsync Method (sItemPath, sField)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemFieldAsync(String, String)
Declaration Syntax
C#
public void GetItemFieldAsync(
    string sItemPath,
    string sField
)
Parameters
sItemPath (String)
sField (String)
Remarks


GetItemFieldAsync Method (sItemPath, sField, userState)

GetItemFieldAsync Method (sItemPath, sField, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemFieldAsync(String, String, Object)
Declaration Syntax
C#
public void GetItemFieldAsync(
    string sItemPath,
    string sField,
    Object userState
)
Parameters
sItemPath (String)
sField (String)
userState (Object)
Remarks


GetItemFieldCompleted Event

GetItemFieldCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemFieldCompleted
Declaration Syntax
C#
public event GetItemFieldCompletedEventHandler GetItemFieldCompleted
Remarks


GetItemFields Method (sItemPath, vFields)

GetItemFields Method (sItemPath, vFields)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemFields(String, array<String>[]()[])
Declaration Syntax
C#
public XmlNode GetItemFields(
    string sItemPath,
    string[] vFields
)
Parameters
sItemPath (String)
vFields (array< String >[]()[])
Remarks


GetItemFieldsAsync Method

GetItemFieldsAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemFieldsAsync()()()
Members
Icon | Member | Description
 | GetItemFieldsAsync(String, array<String>[]()[]) |
 | GetItemFieldsAsync(String, array<String>[]()[], Object) |


GetItemFieldsAsync Method (sItemPath, vFields)

GetItemFieldsAsync Method (sItemPath, vFields)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemFieldsAsync(String, array<String>[]()[])
Declaration Syntax
C#
public void GetItemFieldsAsync(
    string sItemPath,
    string[] vFields
)
Parameters
sItemPath (String)
vFields (array< String >[]()[])
Remarks


GetItemFieldsAsync Method (sItemPath, vFields, userState)

GetItemFieldsAsync Method (sItemPath, vFields, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemFieldsAsync(String, array<String>[]()[], Object)
Declaration Syntax
C#
public void GetItemFieldsAsync(
    string sItemPath,
    string[] vFields,
    Object userState
)
Parameters
sItemPath (String)
vFields (array< String >[]()[])
userState (Object)
Remarks


GetItemFieldsCompleted Event

GetItemFieldsCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemFieldsCompleted
Declaration Syntax
C#
public event GetItemFieldsCompletedEventHandler GetItemFieldsCompleted
Remarks


GetItemInfo Method (sPath)

GetItemInfo Method (sPath)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemInfo(String)
Declaration Syntax
C#
public XmlNode GetItemInfo(
    string sPath
)
Parameters
sPath (String)
Remarks


GetItemInfoAsync Method

GetItemInfoAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemInfoAsync()()()
Members
Icon | Member | Description
 | GetItemInfoAsync(String) |
 | GetItemInfoAsync(String, Object) |


GetItemInfoAsync Method (sPath)

GetItemInfoAsync Method (sPath)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemInfoAsync(String)
Declaration Syntax
C#
public void GetItemInfoAsync(
    string sPath
)
Parameters
sPath (String)
Remarks


GetItemInfoAsync Method (sPath, userState)

GetItemInfoAsync Method (sPath, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemInfoAsync(String, Object)
Declaration Syntax
C#
public void GetItemInfoAsync(
    string sPath,
    Object userState
)
Parameters
sPath (String)
userState (Object)
Remarks


GetItemInfoCompleted Event

GetItemInfoCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemInfoCompleted
Declaration Syntax
C#
public event GetItemInfoCompletedEventHandler GetItemInfoCompleted
Remarks


GetItemMasters Method (sItemID, sRevision, sLanguage)

GetItemMasters Method (sItemID, sRevision, sLanguage)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemMasters(String, String, String)
Declaration Syntax
C#
public XmlNode GetItemMasters(
    string sItemID,
    string sRevision,
    string sLanguage
)
Parameters
sItemID (String)
sRevision (String)
sLanguage (String)
Remarks


GetItemMastersAsync Method

GetItemMastersAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemMastersAsync()()()
Members
Icon | Member | Description
 | GetItemMastersAsync(String, String, String) |
 | GetItemMastersAsync(String, String, String, Object) |


GetItemMastersAsync Method (sItemID, sRevision, sLanguage)

GetItemMastersAsync Method (sItemID, sRevision, sLanguage)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemMastersAsync(String, String, String)
Declaration Syntax
C#
public void GetItemMastersAsync(
    string sItemID,
    string sRevision,
    string sLanguage
)
Parameters
sItemID (String)
sRevision (String)
sLanguage (String)
Remarks


GetItemMastersAsync Method (sItemID, sRevision, sLanguage, userState)

GetItemMastersAsync Method (sItemID, sRevision, sLanguage, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemMastersAsync(String, String, String, Object)
Declaration Syntax
C#
public void GetItemMastersAsync(
    string sItemID,
    string sRevision,
    string sLanguage,
    Object userState
)
Parameters
sItemID (String)
sRevision (String)
sLanguage (String)
userState (Object)
Remarks


GetItemMastersCompleted Event

GetItemMastersCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemMastersCompleted
Declaration Syntax
C#
public event GetItemMastersCompletedEventHandler GetItemMastersCompleted
Remarks


GetItemPath Method (sItemID, sType)

GetItemPath Method (sItemID, sType)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemPath(String, String)
Declaration Syntax
C#
public string GetItemPath(
    string sItemID,
    string sType
)
Parameters
sItemID (String)
sType (String)
Remarks


GetItemPathAsync Method

GetItemPathAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemPathAsync()()()
Members
Icon | Member | Description
 | GetItemPathAsync(String, String) |
 | GetItemPathAsync(String, String, Object) |


GetItemPathAsync Method (sItemID, sType)

GetItemPathAsync Method (sItemID, sType)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemPathAsync(String, String)
Declaration Syntax
C#
public void GetItemPathAsync(
    string sItemID,
    string sType
)
Parameters
sItemID (String)
sType (String)
Remarks


GetItemPathAsync Method (sItemID, sType, userState)

GetItemPathAsync Method (sItemID, sType, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemPathAsync(String, String, Object)
Declaration Syntax
C#
public void GetItemPathAsync(
    string sItemID,
    string sType,
    Object userState
)
Parameters
sItemID (String)
sType (String)
userState (Object)
Remarks


GetItemPathCompleted Event

GetItemPathCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemPathCompleted
Declaration Syntax
C#
public event GetItemPathCompletedEventHandler GetItemPathCompleted
Remarks


GetItemsInfo Method (sItems)

GetItemsInfo Method (sItems)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemsInfo(String)
Declaration Syntax
C#
public XmlNode GetItemsInfo(
    string sItems
)
Parameters
sItems (String)
Remarks


GetItemsInfoAsync Method

GetItemsInfoAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemsInfoAsync()()()
Members
Icon | Member | Description
 | GetItemsInfoAsync(String) |
 | GetItemsInfoAsync(String, Object) |


GetItemsInfoAsync Method (sItems)

GetItemsInfoAsync Method (sItems)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemsInfoAsync(String)
Declaration Syntax
C#
public void GetItemsInfoAsync(
    string sItems
)
Parameters
sItems (String)
Remarks


GetItemsInfoAsync Method (sItems, userState)

GetItemsInfoAsync Method (sItems, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemsInfoAsync(String, Object)
Declaration Syntax
C#
public void GetItemsInfoAsync(
    string sItems,
    Object userState
)
Parameters
sItems (String)
userState (Object)
Remarks


GetItemsInfoCompleted Event

GetItemsInfoCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemsInfoCompleted
Declaration Syntax
C#
public event GetItemsInfoCompletedEventHandler GetItemsInfoCompleted
Remarks


GetItemTree Method (sItemPath, nSublevels)

GetItemTree Method (sItemPath, nSublevels)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemTree(String, Int32)
Declaration Syntax
C#
public XmlNode GetItemTree(
    string sItemPath,
    int nSublevels
)
Parameters
sItemPath (String)
nSublevels (Int32)
Remarks


GetItemTreeAsync Method

GetItemTreeAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemTreeAsync()()()
Members
Icon | Member | Description
 | GetItemTreeAsync(String, Int32) |
 | GetItemTreeAsync(String, Int32, Object) |


GetItemTreeAsync Method (sItemPath, nSublevels)

GetItemTreeAsync Method (sItemPath, nSublevels)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemTreeAsync(String, Int32)
Declaration Syntax
C#
public void GetItemTreeAsync(
    string sItemPath,
    int nSublevels
)
Parameters
sItemPath (String)
nSublevels (Int32)
Remarks


GetItemTreeAsync Method (sItemPath, nSublevels, userState)

GetItemTreeAsync Method (sItemPath, nSublevels, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemTreeAsync(String, Int32, Object)
Declaration Syntax
C#
public void GetItemTreeAsync(
    string sItemPath,
    int nSublevels,
    Object userState
)
Parameters
sItemPath (String)
nSublevels (Int32)
userState (Object)
Remarks


GetItemTreeCompleted Event

GetItemTreeCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemTreeCompleted
Declaration Syntax
C#
public event GetItemTreeCompletedEventHandler GetItemTreeCompleted
Remarks


GetItemTreeXml Method (sPath, nLevels)

GetItemTreeXml Method (sPath, nLevels)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemTreeXml(String, Int32)
Declaration Syntax
C#
public string GetItemTreeXml(
    string sPath,
    int nLevels
)
Parameters
sPath (String)
nLevels (Int32)
Remarks


GetItemTreeXmlAsync Method

GetItemTreeXmlAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemTreeXmlAsync()()()
Members
Icon | Member | Description
 | GetItemTreeXmlAsync(String, Int32) |
 | GetItemTreeXmlAsync(String, Int32, Object) |


GetItemTreeXmlAsync Method (sPath, nLevels)

GetItemTreeXmlAsync Method (sPath, nLevels)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemTreeXmlAsync(String, Int32)
Declaration Syntax
C#
public void GetItemTreeXmlAsync(
    string sPath,
    int nLevels
)
Parameters
sPath (String)
nLevels (Int32)
Remarks


GetItemTreeXmlAsync Method (sPath, nLevels, userState)

GetItemTreeXmlAsync Method (sPath, nLevels, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemTreeXmlAsync(String, Int32, Object)
Declaration Syntax
C#
public void GetItemTreeXmlAsync(
    string sPath,
    int nLevels,
    Object userState
)
Parameters
sPath (String)
nLevels (Int32)
userState (Object)
Remarks


GetItemTreeXmlCompleted Event

GetItemTreeXmlCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemTreeXmlCompleted
Declaration Syntax
C#
public event GetItemTreeXmlCompletedEventHandler GetItemTreeXmlCompleted
Remarks


GetItemXml Method (sPath, sRevision, sLanguage)

GetItemXml Method (sPath, sRevision, sLanguage)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemXml(String, String, String)
Declaration Syntax
C#
public XmlNode GetItemXml(
    string sPath,
    string sRevision,
    string sLanguage
)
Parameters
sPath (String)
sRevision (String)
sLanguage (String)
Remarks


GetItemXmlAsync Method

GetItemXmlAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemXmlAsync()()()
Members
Icon | Member | Description
 | GetItemXmlAsync(String, String, String) |
 | GetItemXmlAsync(String, String, String, Object) |


GetItemXmlAsync Method (sPath, sRevision, sLanguage)

GetItemXmlAsync Method (sPath, sRevision, sLanguage)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemXmlAsync(String, String, String)
Declaration Syntax
C#
public void GetItemXmlAsync(
    string sPath,
    string sRevision,
    string sLanguage
)
Parameters
sPath (String)
sRevision (String)
sLanguage (String)
Remarks


GetItemXmlAsync Method (sPath, sRevision, sLanguage, userState)

GetItemXmlAsync Method (sPath, sRevision, sLanguage, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemXmlAsync(String, String, String, Object)
Declaration Syntax
C#
public void GetItemXmlAsync(
    string sPath,
    string sRevision,
    string sLanguage,
    Object userState
)
Parameters
sPath (String)
sRevision (String)
sLanguage (String)
userState (Object)
Remarks


GetItemXmlCompleted Event

GetItemXmlCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetItemXmlCompleted
Declaration Syntax
C#
public event GetItemXmlCompletedEventHandler GetItemXmlCompleted
Remarks


GetLocalizedString Method (text)

GetLocalizedString Method (text)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetLocalizedString(String)
Declaration Syntax
C#
public string GetLocalizedString(
    string text
)
Parameters
text (String)
Remarks


GetLocalizedStringAsync Method

GetLocalizedStringAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetLocalizedStringAsync()()()
Members
Icon | Member | Description
 | GetLocalizedStringAsync(String) |
 | GetLocalizedStringAsync(String, Object) |


GetLocalizedStringAsync Method (text)

GetLocalizedStringAsync Method (text)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetLocalizedStringAsync(String)
Declaration Syntax
C#
public void GetLocalizedStringAsync(
    string text
)
Parameters
text (String)
Remarks


GetLocalizedStringAsync Method (text, userState)

GetLocalizedStringAsync Method (text, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetLocalizedStringAsync(String, Object)
Declaration Syntax
C#
public void GetLocalizedStringAsync(
    string text,
    Object userState
)
Parameters
text (String)
userState (Object)
Remarks


GetLocalizedStringCompleted Event

GetLocalizedStringCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetLocalizedStringCompleted
Declaration Syntax
C#
public event GetLocalizedStringCompletedEventHandler GetLocalizedStringCompleted
Remarks


GetMediaInfo Method (sPath, sRevision, sLanguage)

GetMediaInfo Method (sPath, sRevision, sLanguage)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMediaInfo(String, String, String)
Declaration Syntax
C#
public XmlNode GetMediaInfo(
    string sPath,
    string sRevision,
    string sLanguage
)
Parameters
sPath (String)
sRevision (String)
sLanguage (String)
Remarks


GetMediaInfoAsync Method

GetMediaInfoAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMediaInfoAsync()()()
Members
Icon | Member | Description
 | GetMediaInfoAsync(String, String, String) |
 | GetMediaInfoAsync(String, String, String, Object) |


GetMediaInfoAsync Method (sPath, sRevision, sLanguage)

GetMediaInfoAsync Method (sPath, sRevision, sLanguage)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMediaInfoAsync(String, String, String)
Declaration Syntax
C#
public void GetMediaInfoAsync(
    string sPath,
    string sRevision,
    string sLanguage
)
Parameters
sPath (String)
sRevision (String)
sLanguage (String)
Remarks


GetMediaInfoAsync Method (sPath, sRevision, sLanguage, userState)

GetMediaInfoAsync Method (sPath, sRevision, sLanguage, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMediaInfoAsync(String, String, String, Object)
Declaration Syntax
C#
public void GetMediaInfoAsync(
    string sPath,
    string sRevision,
    string sLanguage,
    Object userState
)
Parameters
sPath (String)
sRevision (String)
sLanguage (String)
userState (Object)
Remarks


GetMediaInfoCompleted Event

GetMediaInfoCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMediaInfoCompleted
Declaration Syntax
C#
public event GetMediaInfoCompletedEventHandler GetMediaInfoCompleted
Remarks


GetMediaItems Method (sPath, sType)

GetMediaItems Method (sPath, sType)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMediaItems(String, String)
Declaration Syntax
C#
public XmlNode GetMediaItems(
    string sPath,
    string sType
)
Parameters
sPath (String)
sType (String)
Remarks


GetMediaItemsAsync Method

GetMediaItemsAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMediaItemsAsync()()()
Members
Icon | Member | Description
 | GetMediaItemsAsync(String, String) |
 | GetMediaItemsAsync(String, String, Object) |


GetMediaItemsAsync Method (sPath, sType)

GetMediaItemsAsync Method (sPath, sType)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMediaItemsAsync(String, String)
Declaration Syntax
C#
public void GetMediaItemsAsync(
    string sPath,
    string sType
)
Parameters
sPath (String)
sType (String)
Remarks


GetMediaItemsAsync Method (sPath, sType, userState)

GetMediaItemsAsync Method (sPath, sType, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMediaItemsAsync(String, String, Object)
Declaration Syntax
C#
public void GetMediaItemsAsync(
    string sPath,
    string sType,
    Object userState
)
Parameters
sPath (String)
sType (String)
userState (Object)
Remarks


GetMediaItemsCompleted Event

GetMediaItemsCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMediaItemsCompleted
Declaration Syntax
C#
public event GetMediaItemsCompletedEventHandler GetMediaItemsCompleted
Remarks


GetMethodHtml Method (assemblyname, classname, methodname, datasource, parameters)

GetMethodHtml Method (assemblyname, classname, methodname, datasource, parameters)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMethodHtml(String, String, String, String, String)
Declaration Syntax
C#
public string GetMethodHtml(
    string assemblyname,
    string classname,
    string methodname,
    string datasource,
    string parameters
)
Parameters
assemblyname (String)
classname (String)
methodname (String)
datasource (String)
parameters (String)
Remarks


GetMethodHtmlAsync Method

GetMethodHtmlAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMethodHtmlAsync()()()
Members
Icon | Member | Description
 | GetMethodHtmlAsync(String, String, String, String, String) |
 | GetMethodHtmlAsync(String, String, String, String, String, Object) |


GetMethodHtmlAsync Method (assemblyname, classname, methodname, datasource, parameters)

GetMethodHtmlAsync Method (assemblyname, classname, methodname, datasource, parameters)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMethodHtmlAsync(String, String, String, String, String)
Declaration Syntax
C#
public void GetMethodHtmlAsync(
    string assemblyname,
    string classname,
    string methodname,
    string datasource,
    string parameters
)
Parameters
assemblyname (String)
classname (String)
methodname (String)
datasource (String)
parameters (String)
Remarks


GetMethodHtmlAsync Method (assemblyname, classname, methodname, datasource, parameters, userState)

GetMethodHtmlAsync Method (assemblyname, classname, methodname, datasource, parameters, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMethodHtmlAsync(String, String, String, String, String, Object)
Declaration Syntax
C#
public void GetMethodHtmlAsync(
    string assemblyname,
    string classname,
    string methodname,
    string datasource,
    string parameters,
    Object userState
)
Parameters
assemblyname (String)
classname (String)
methodname (String)
datasource (String)
parameters (String)
userState (Object)
Remarks


GetMethodHtmlCompleted Event

GetMethodHtmlCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetMethodHtmlCompleted
Declaration Syntax
C#
public event GetMethodHtmlCompletedEventHandler GetMethodHtmlCompleted
Remarks


GetNewItemXml Method (master, name)

GetNewItemXml Method (master, name)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetNewItemXml(String, String)
Declaration Syntax
C#
public string GetNewItemXml(
    string master,
    string name
)
Parameters
master (String)
name (String)
Remarks


GetNewItemXmlAsync Method

GetNewItemXmlAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetNewItemXmlAsync()()()
Members
Icon | Member | Description
 | GetNewItemXmlAsync(String, String) |
 | GetNewItemXmlAsync(String, String, Object) |


GetNewItemXmlAsync Method (master, name)

GetNewItemXmlAsync Method (master, name)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetNewItemXmlAsync(String, String)
Declaration Syntax
C#
public void GetNewItemXmlAsync(
    string master,
    string name
)
Parameters
master (String)
name (String)
Remarks


GetNewItemXmlAsync Method (master, name, userState)

GetNewItemXmlAsync Method (master, name, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetNewItemXmlAsync(String, String, Object)
Declaration Syntax
C#
public void GetNewItemXmlAsync(
    string master,
    string name,
    Object userState
)
Parameters
master (String)
name (String)
userState (Object)
Remarks


GetNewItemXmlCompleted Event

GetNewItemXmlCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetNewItemXmlCompleted
Declaration Syntax
C#
public event GetNewItemXmlCompletedEventHandler GetNewItemXmlCompleted
Remarks


GetPackageInfo Method (packageName)

GetPackageInfo Method (packageName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPackageInfo(String)
Declaration Syntax
C#
public XmlNode GetPackageInfo(
    string packageName
)
Parameters
packageName (String)
Remarks


GetPackageInfoAsync Method

GetPackageInfoAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPackageInfoAsync()()()
Members
Icon | Member | Description
 | GetPackageInfoAsync(String) |
 | GetPackageInfoAsync(String, Object) |


GetPackageInfoAsync Method (packageName)

GetPackageInfoAsync Method (packageName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPackageInfoAsync(String)
Declaration Syntax
C#
public void GetPackageInfoAsync(
    string packageName
)
Parameters
packageName (String)
Remarks


GetPackageInfoAsync Method (packageName, userState)

GetPackageInfoAsync Method (packageName, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPackageInfoAsync(String, Object)
Declaration Syntax
C#
public void GetPackageInfoAsync(
    string packageName,
    Object userState
)
Parameters
packageName (String)
userState (Object)
Remarks


GetPackageInfoCompleted Event

GetPackageInfoCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPackageInfoCompleted
Declaration Syntax
C#
public event GetPackageInfoCompletedEventHandler GetPackageInfoCompleted
Remarks


GetPackageXml Method (packageName)

GetPackageXml Method (packageName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPackageXml(String)
Declaration Syntax
C#
public XmlNode GetPackageXml(
    string packageName
)
Parameters
packageName (String)
Remarks


GetPackageXmlAsync Method

GetPackageXmlAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPackageXmlAsync()()()
Members
Icon | Member | Description
 | GetPackageXmlAsync(String) |
 | GetPackageXmlAsync(String, Object) |


GetPackageXmlAsync Method (packageName)

GetPackageXmlAsync Method (packageName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPackageXmlAsync(String)
Declaration Syntax
C#
public void GetPackageXmlAsync(
    string packageName
)
Parameters
packageName (String)
Remarks


GetPackageXmlAsync Method (packageName, userState)

GetPackageXmlAsync Method (packageName, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPackageXmlAsync(String, Object)
Declaration Syntax
C#
public void GetPackageXmlAsync(
    string packageName,
    Object userState
)
Parameters
packageName (String)
userState (Object)
Remarks


GetPackageXmlCompleted Event

GetPackageXmlCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPackageXmlCompleted
Declaration Syntax
C#
public event GetPackageXmlCompletedEventHandler GetPackageXmlCompleted
Remarks


GetParentID Method (sItemID)

GetParentID Method (sItemID)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetParentID(String)
Declaration Syntax
C#
public string GetParentID(
    string sItemID
)
Parameters
sItemID (String)
Remarks


GetParentIDAsync Method

GetParentIDAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetParentIDAsync()()()
Members
Icon | Member | Description
 | GetParentIDAsync(String) |
 | GetParentIDAsync(String, Object) |


GetParentIDAsync Method (sItemID)

GetParentIDAsync Method (sItemID)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetParentIDAsync(String)
Declaration Syntax
C#
public void GetParentIDAsync(
    string sItemID
)
Parameters
sItemID (String)
Remarks


GetParentIDAsync Method (sItemID, userState)

GetParentIDAsync Method (sItemID, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetParentIDAsync(String, Object)
Declaration Syntax
C#
public void GetParentIDAsync(
    string sItemID,
    Object userState
)
Parameters
sItemID (String)
userState (Object)
Remarks


GetParentIDCompleted Event

GetParentIDCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetParentIDCompleted
Declaration Syntax
C#
public event GetParentIDCompletedEventHandler GetParentIDCompleted
Remarks


GetParentPath Method (path)

GetParentPath Method (path)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetParentPath(String)
Declaration Syntax
C#
public string GetParentPath(
    string path
)
Parameters
path (String)
Remarks


GetParentPathAsync Method

GetParentPathAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetParentPathAsync()()()
Members
Icon | Member | Description
 | GetParentPathAsync(String) |
 | GetParentPathAsync(String, Object) |


GetParentPathAsync Method (path)

GetParentPathAsync Method (path)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetParentPathAsync(String)
Declaration Syntax
C#
public void GetParentPathAsync(
    string path
)
Parameters
path (String)
Remarks


GetParentPathAsync Method (path, userState)

GetParentPathAsync Method (path, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetParentPathAsync(String, Object)
Declaration Syntax
C#
public void GetParentPathAsync(
    string path,
    Object userState
)
Parameters
path (String)
userState (Object)
Remarks


GetParentPathCompleted Event

GetParentPathCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetParentPathCompleted
Declaration Syntax
C#
public event GetParentPathCompletedEventHandler GetParentPathCompleted
Remarks


GetPublishingStatus Method (handle)

GetPublishingStatus Method (handle)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPublishingStatus(String)
Declaration Syntax
C#
public string GetPublishingStatus(
    string handle
)
Parameters
handle (String)
Remarks


GetPublishingStatusAsync Method

GetPublishingStatusAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPublishingStatusAsync()()()
Members
Icon | Member | Description
 | GetPublishingStatusAsync(String) |
 | GetPublishingStatusAsync(String, Object) |


GetPublishingStatusAsync Method (handle)

GetPublishingStatusAsync Method (handle)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPublishingStatusAsync(String)
Declaration Syntax
C#
public void GetPublishingStatusAsync(
    string handle
)
Parameters
handle (String)
Remarks


GetPublishingStatusAsync Method (handle, userState)

GetPublishingStatusAsync Method (handle, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPublishingStatusAsync(String, Object)
Declaration Syntax
C#
public void GetPublishingStatusAsync(
    string handle,
    Object userState
)
Parameters
handle (String)
userState (Object)
Remarks


GetPublishingStatusCompleted Event

GetPublishingStatusCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetPublishingStatusCompleted
Declaration Syntax
C#
public event GetPublishingStatusCompletedEventHandler GetPublishingStatusCompleted
Remarks


GetSiblingPath Method (path)

GetSiblingPath Method (path)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetSiblingPath(String)
Declaration Syntax
C#
public string GetSiblingPath(
    string path
)
Parameters
path (String)
Remarks


GetSiblingPathAsync Method

GetSiblingPathAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetSiblingPathAsync()()()
Members
Icon | Member | Description
 | GetSiblingPathAsync(String) |
 | GetSiblingPathAsync(String, Object) |


GetSiblingPathAsync Method (path)

GetSiblingPathAsync Method (path)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetSiblingPathAsync(String)
Declaration Syntax
C#
public void GetSiblingPathAsync(
    string path
)
Parameters
path (String)
Remarks


GetSiblingPathAsync Method (path, userState)

GetSiblingPathAsync Method (path, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetSiblingPathAsync(String, Object)
Declaration Syntax
C#
public void GetSiblingPathAsync(
    string path,
    Object userState
)
Parameters
path (String)
userState (Object)
Remarks


GetSiblingPathCompleted Event

GetSiblingPathCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetSiblingPathCompleted
Declaration Syntax
C#
public event GetSiblingPathCompletedEventHandler GetSiblingPathCompleted
Remarks


GetThreadErrors Method (resetListAfterUse)

GetThreadErrors Method (resetListAfterUse)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetThreadErrors(Boolean)
Declaration Syntax
C#
public XmlNode GetThreadErrors(
    bool resetListAfterUse
)
Parameters
resetListAfterUse (Boolean)
Remarks


GetThreadErrorsAsync Method

GetThreadErrorsAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetThreadErrorsAsync()()()
Members
Icon | Member | Description
 | GetThreadErrorsAsync(Boolean) |
 | GetThreadErrorsAsync(Boolean, Object) |


GetThreadErrorsAsync Method (resetListAfterUse)

GetThreadErrorsAsync Method (resetListAfterUse)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetThreadErrorsAsync(Boolean)
Declaration Syntax
C#
public void GetThreadErrorsAsync(
    bool resetListAfterUse
)
Parameters
resetListAfterUse (Boolean)
Remarks


GetThreadErrorsAsync Method (resetListAfterUse, userState)

GetThreadErrorsAsync Method (resetListAfterUse, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetThreadErrorsAsync(Boolean, Object)
Declaration Syntax
C#
public void GetThreadErrorsAsync(
    bool resetListAfterUse,
    Object userState
)
Parameters
resetListAfterUse (Boolean)
userState (Object)
Remarks


GetThreadErrorsCompleted Event

GetThreadErrorsCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetThreadErrorsCompleted
Declaration Syntax
C#
public event GetThreadErrorsCompletedEventHandler GetThreadErrorsCompleted
Remarks


GetWebPageHtml Method (url, datasource, parameters)

GetWebPageHtml Method (url, datasource, parameters)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetWebPageHtml(String, String, String)
Declaration Syntax
C#
public string GetWebPageHtml(
    string url,
    string datasource,
    string parameters
)
Parameters
url (String)
datasource (String)
parameters (String)
Remarks


GetWebPageHtmlAsync Method

GetWebPageHtmlAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetWebPageHtmlAsync()()()
Members
Icon | Member | Description
 | GetWebPageHtmlAsync(String, String, String) |
 | GetWebPageHtmlAsync(String, String, String, Object) |


GetWebPageHtmlAsync Method (url, datasource, parameters)

GetWebPageHtmlAsync Method (url, datasource, parameters)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetWebPageHtmlAsync(String, String, String)
Declaration Syntax
C#
public void GetWebPageHtmlAsync(
    string url,
    string datasource,
    string parameters
)
Parameters
url (String)
datasource (String)
parameters (String)
Remarks


GetWebPageHtmlAsync Method (url, datasource, parameters, userState)

GetWebPageHtmlAsync Method (url, datasource, parameters, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetWebPageHtmlAsync(String, String, String, Object)
Declaration Syntax
C#
public void GetWebPageHtmlAsync(
    string url,
    string datasource,
    string parameters,
    Object userState
)
Parameters
url (String)
datasource (String)
parameters (String)
userState (Object)
Remarks


GetWebPageHtmlCompleted Event

GetWebPageHtmlCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetWebPageHtmlCompleted
Declaration Syntax
C#
public event GetWebPageHtmlCompletedEventHandler GetWebPageHtmlCompleted
Remarks


GetXslFileHtml Method (path, datasource, parameters)

GetXslFileHtml Method (path, datasource, parameters)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetXslFileHtml(String, String, String)
Declaration Syntax
C#
public string GetXslFileHtml(
    string path,
    string datasource,
    string parameters
)
Parameters
path (String)
datasource (String)
parameters (String)
Remarks


GetXslFileHtmlAsync Method

GetXslFileHtmlAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetXslFileHtmlAsync()()()
Members
Icon | Member | Description
 | GetXslFileHtmlAsync(String, String, String) |
 | GetXslFileHtmlAsync(String, String, String, Object) |


GetXslFileHtmlAsync Method (path, datasource, parameters)

GetXslFileHtmlAsync Method (path, datasource, parameters)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetXslFileHtmlAsync(String, String, String)
Declaration Syntax
C#
public void GetXslFileHtmlAsync(
    string path,
    string datasource,
    string parameters
)
Parameters
path (String)
datasource (String)
parameters (String)
Remarks


GetXslFileHtmlAsync Method (path, datasource, parameters, userState)

GetXslFileHtmlAsync Method (path, datasource, parameters, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetXslFileHtmlAsync(String, String, String, Object)
Declaration Syntax
C#
public void GetXslFileHtmlAsync(
    string path,
    string datasource,
    string parameters,
    Object userState
)
Parameters
path (String)
datasource (String)
parameters (String)
userState (Object)
Remarks


GetXslFileHtmlCompleted Event

GetXslFileHtmlCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► GetXslFileHtmlCompleted
Declaration Syntax
C#
public event GetXslFileHtmlCompletedEventHandler GetXslFileHtmlCompleted
Remarks


ImportPackage Method (packageName)

ImportPackage Method (packageName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ImportPackage(String)
Declaration Syntax
C#
public XmlNode ImportPackage(
    string packageName
)
Parameters
packageName (String)
Remarks


ImportPackageAsync Method

ImportPackageAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ImportPackageAsync()()()
Members
Icon | Member | Description
 | ImportPackageAsync(String) |
 | ImportPackageAsync(String, Object) |


ImportPackageAsync Method (packageName)

ImportPackageAsync Method (packageName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ImportPackageAsync(String)
Declaration Syntax
C#
public void ImportPackageAsync(
    string packageName
)
Parameters
packageName (String)
Remarks


ImportPackageAsync Method (packageName, userState)

ImportPackageAsync Method (packageName, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ImportPackageAsync(String, Object)
Declaration Syntax
C#
public void ImportPackageAsync(
    string packageName,
    Object userState
)
Parameters
packageName (String)
userState (Object)
Remarks


ImportPackageCompleted Event

ImportPackageCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ImportPackageCompleted
Declaration Syntax
C#
public event ImportPackageCompletedEventHandler ImportPackageCompleted
Remarks


InsertItemTreeXml Method (sParent, sXml, bChangeIDs)

InsertItemTreeXml Method (sParent, sXml, bChangeIDs)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► InsertItemTreeXml(String, String, Boolean)
Declaration Syntax
C#
public string InsertItemTreeXml(
    string sParent,
    string sXml,
    bool bChangeIDs
)
Parameters
sParent (String)
sXml (String)
bChangeIDs (Boolean)
Remarks


InsertItemTreeXmlAsync Method

InsertItemTreeXmlAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► InsertItemTreeXmlAsync()()()
Members
Icon | Member | Description
 | InsertItemTreeXmlAsync(String, String, Boolean) |
 | InsertItemTreeXmlAsync(String, String, Boolean, Object) |


InsertItemTreeXmlAsync Method (sParent, sXml, bChangeIDs)

InsertItemTreeXmlAsync Method (sParent, sXml, bChangeIDs)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► InsertItemTreeXmlAsync(String, String, Boolean)
Declaration Syntax
C#
public void InsertItemTreeXmlAsync(
    string sParent,
    string sXml,
    bool bChangeIDs
)
Parameters
sParent (String)
sXml (String)
bChangeIDs (Boolean)
Remarks


InsertItemTreeXmlAsync Method (sParent, sXml, bChangeIDs, userState)

InsertItemTreeXmlAsync Method (sParent, sXml, bChangeIDs, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► InsertItemTreeXmlAsync(String, String, Boolean, Object)
Declaration Syntax
C#
public void InsertItemTreeXmlAsync(
    string sParent,
    string sXml,
    bool bChangeIDs,
    Object userState
)
Parameters
sParent (String)
sXml (String)
bChangeIDs (Boolean)
userState (Object)
Remarks


InsertItemTreeXmlCompleted Event

InsertItemTreeXmlCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► InsertItemTreeXmlCompleted
Declaration Syntax
C#
public event InsertItemTreeXmlCompletedEventHandler InsertItemTreeXmlCompleted
Remarks


IsLoggedIn Method

IsLoggedIn Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsLoggedIn()()()
Declaration Syntax
C#
public bool IsLoggedIn()
Remarks


IsLoggedInAsync Method

IsLoggedInAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsLoggedInAsync()()()
Members
Icon | Member | Description
 | IsLoggedInAsync()()() |
 | IsLoggedInAsync(Object) |


IsLoggedInAsync Method

IsLoggedInAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsLoggedInAsync()()()
Declaration Syntax
C#
public void IsLoggedInAsync()
Remarks


IsLoggedInAsync Method (userState)

IsLoggedInAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsLoggedInAsync(Object)
Declaration Syntax
C#
public void IsLoggedInAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


IsLoggedInCompleted Event

IsLoggedInCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsLoggedInCompleted
Declaration Syntax
C#
public event IsLoggedInCompletedEventHandler IsLoggedInCompleted
Remarks


IsPreviewing Method

IsPreviewing Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsPreviewing()()()
Declaration Syntax
C#
public bool IsPreviewing()
Remarks


IsPreviewingAsync Method

IsPreviewingAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsPreviewingAsync()()()
Members
Icon | Member | Description
 | IsPreviewingAsync()()() |
 | IsPreviewingAsync(Object) |


IsPreviewingAsync Method

IsPreviewingAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsPreviewingAsync()()()
Declaration Syntax
C#
public void IsPreviewingAsync()
Remarks


IsPreviewingAsync Method (userState)

IsPreviewingAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsPreviewingAsync(Object)
Declaration Syntax
C#
public void IsPreviewingAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


IsPreviewingCompleted Event

IsPreviewingCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsPreviewingCompleted
Declaration Syntax
C#
public event IsPreviewingCompletedEventHandler IsPreviewingCompleted
Remarks


IsSessionValid Method

IsSessionValid Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsSessionValid()()()
Declaration Syntax
C#
public bool IsSessionValid()
Remarks


IsSessionValidAsync Method

IsSessionValidAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsSessionValidAsync()()()
Members
Icon | Member | Description
 | IsSessionValidAsync()()() |
 | IsSessionValidAsync(Object) |


IsSessionValidAsync Method

IsSessionValidAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsSessionValidAsync()()()
Declaration Syntax
C#
public void IsSessionValidAsync()
Remarks


IsSessionValidAsync Method (userState)

IsSessionValidAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsSessionValidAsync(Object)
Declaration Syntax
C#
public void IsSessionValidAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


IsSessionValidCompleted Event

IsSessionValidCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsSessionValidCompleted
Declaration Syntax
C#
public event IsSessionValidCompletedEventHandler IsSessionValidCompleted
Remarks


IsWebEditing Method

IsWebEditing Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsWebEditing()()()
Declaration Syntax
C#
public bool IsWebEditing()
Remarks


IsWebEditingAsync Method

IsWebEditingAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsWebEditingAsync()()()
Members
Icon | Member | Description
 | IsWebEditingAsync()()() |
 | IsWebEditingAsync(Object) |


IsWebEditingAsync Method

IsWebEditingAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsWebEditingAsync()()()
Declaration Syntax
C#
public void IsWebEditingAsync()
Remarks


IsWebEditingAsync Method (userState)

IsWebEditingAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsWebEditingAsync(Object)
Declaration Syntax
C#
public void IsWebEditingAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


IsWebEditingCompleted Event

IsWebEditingCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► IsWebEditingCompleted
Declaration Syntax
C#
public event IsWebEditingCompletedEventHandler IsWebEditingCompleted
Remarks


LoadLayout Method (sID)

LoadLayout Method (sID)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadLayout(String)
Declaration Syntax
C#
public XmlNode LoadLayout(
    string sID
)
Parameters
sID (String)
Remarks


LoadLayoutAsync Method

LoadLayoutAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadLayoutAsync()()()
Members
Icon | Member | Description
 | LoadLayoutAsync(String) |
 | LoadLayoutAsync(String, Object) |


LoadLayoutAsync Method (sID)

LoadLayoutAsync Method (sID)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadLayoutAsync(String)
Declaration Syntax
C#
public void LoadLayoutAsync(
    string sID
)
Parameters
sID (String)
Remarks


LoadLayoutAsync Method (sID, userState)

LoadLayoutAsync Method (sID, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadLayoutAsync(String, Object)
Declaration Syntax
C#
public void LoadLayoutAsync(
    string sID,
    Object userState
)
Parameters
sID (String)
userState (Object)
Remarks


LoadLayoutCompleted Event

LoadLayoutCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadLayoutCompleted
Declaration Syntax
C#
public event LoadLayoutCompletedEventHandler LoadLayoutCompleted
Remarks


LoadPackage Method (sName)

LoadPackage Method (sName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadPackage(String)
Declaration Syntax
C#
public XmlNode LoadPackage(
    string sName
)
Parameters
sName (String)
Remarks


LoadPackageAsync Method

LoadPackageAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadPackageAsync()()()
Members
Icon | Member | Description
 | LoadPackageAsync(String) |
 | LoadPackageAsync(String, Object) |


LoadPackageAsync Method (sName)

LoadPackageAsync Method (sName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadPackageAsync(String)
Declaration Syntax
C#
public void LoadPackageAsync(
    string sName
)
Parameters
sName (String)
Remarks


LoadPackageAsync Method (sName, userState)

LoadPackageAsync Method (sName, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadPackageAsync(String, Object)
Declaration Syntax
C#
public void LoadPackageAsync(
    string sName,
    Object userState
)
Parameters
sName (String)
userState (Object)
Remarks


LoadPackageCompleted Event

LoadPackageCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadPackageCompleted
Declaration Syntax
C#
public event LoadPackageCompletedEventHandler LoadPackageCompleted
Remarks


LoadPublishFile Method (filename)

LoadPublishFile Method (filename)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadPublishFile(String)
Declaration Syntax
C#
public void LoadPublishFile(
    string filename
)
Parameters
filename (String)
Remarks


LoadPublishFileAsync Method

LoadPublishFileAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadPublishFileAsync()()()
Members
Icon | Member | Description
 | LoadPublishFileAsync(String) |
 | LoadPublishFileAsync(String, Object) |


LoadPublishFileAsync Method (filename)

LoadPublishFileAsync Method (filename)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadPublishFileAsync(String)
Declaration Syntax
C#
public void LoadPublishFileAsync(
    string filename
)
Parameters
filename (String)
Remarks


LoadPublishFileAsync Method (filename, userState)

LoadPublishFileAsync Method (filename, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadPublishFileAsync(String, Object)
Declaration Syntax
C#
public void LoadPublishFileAsync(
    string filename,
    Object userState
)
Parameters
filename (String)
userState (Object)
Remarks


LoadPublishFileCompleted Event

LoadPublishFileCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadPublishFileCompleted
Declaration Syntax
C#
public event LoadPublishFileCompletedEventHandler LoadPublishFileCompleted
Remarks


LoadXslFile Method (sID)

LoadXslFile Method (sID)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadXslFile(String)
Declaration Syntax
C#
public XmlNode LoadXslFile(
    string sID
)
Parameters
sID (String)
Remarks


LoadXslFileAsync Method

LoadXslFileAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadXslFileAsync()()()
Members
Icon | Member | Description
 | LoadXslFileAsync(String) |
 | LoadXslFileAsync(String, Object) |


LoadXslFileAsync Method (sID)

LoadXslFileAsync Method (sID)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadXslFileAsync(String)
Declaration Syntax
C#
public void LoadXslFileAsync(
    string sID
)
Parameters
sID (String)
Remarks


LoadXslFileAsync Method (sID, userState)

LoadXslFileAsync Method (sID, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadXslFileAsync(String, Object)
Declaration Syntax
C#
public void LoadXslFileAsync(
    string sID,
    Object userState
)
Parameters
sID (String)
userState (Object)
Remarks


LoadXslFileCompleted Event

LoadXslFileCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoadXslFileCompleted
Declaration Syntax
C#
public event LoadXslFileCompletedEventHandler LoadXslFileCompleted
Remarks


Login Method (sUserName, sPassword)

Login Method (sUserName, sPassword)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► Login(String, String)
Declaration Syntax
C#
public void Login(
    string sUserName,
    string sPassword
)
Parameters
sUserName (String)
sPassword (String)
Remarks


LoginAsync Method

LoginAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoginAsync()()()
Members
Icon | Member | Description
 | LoginAsync(String, String) |
 | LoginAsync(String, String, Object) |


LoginAsync Method (sUserName, sPassword)

LoginAsync Method (sUserName, sPassword)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoginAsync(String, String)
Declaration Syntax
C#
public void LoginAsync(
    string sUserName,
    string sPassword
)
Parameters
sUserName (String)
sPassword (String)
Remarks


LoginAsync Method (sUserName, sPassword, userState)

LoginAsync Method (sUserName, sPassword, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoginAsync(String, String, Object)
Declaration Syntax
C#
public void LoginAsync(
    string sUserName,
    string sPassword,
    Object userState
)
Parameters
sUserName (String)
sPassword (String)
userState (Object)
Remarks


LoginCompleted Event

LoginCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LoginCompleted
Declaration Syntax
C#
public event LoginCompletedEventHandler LoginCompleted
Remarks


Logout Method

Logout Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► Logout()()()
Declaration Syntax
C#
public void Logout()
Remarks


LogoutAsync Method

LogoutAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LogoutAsync()()()
Members
Icon | Member | Description
 | LogoutAsync()()() |
 | LogoutAsync(Object) |


LogoutAsync Method

LogoutAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LogoutAsync()()()
Declaration Syntax
C#
public void LogoutAsync()
Remarks


LogoutAsync Method (userState)

LogoutAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LogoutAsync(Object)
Declaration Syntax
C#
public void LogoutAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


LogoutCompleted Event

LogoutCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► LogoutCompleted
Declaration Syntax
C#
public event LogoutCompletedEventHandler LogoutCompleted
Remarks


MoveItemTo Method (sItemID, sDestinationID)

MoveItemTo Method (sItemID, sDestinationID)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► MoveItemTo(String, String)
Declaration Syntax
C#
public XmlNode MoveItemTo(
    string sItemID,
    string sDestinationID
)
Parameters
sItemID (String)
sDestinationID (String)
Remarks


MoveItemToAsync Method

MoveItemToAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► MoveItemToAsync()()()
Members
Icon | Member | Description
 | MoveItemToAsync(String, String) |
 | MoveItemToAsync(String, String, Object) |


MoveItemToAsync Method (sItemID, sDestinationID)

MoveItemToAsync Method (sItemID, sDestinationID)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► MoveItemToAsync(String, String)
Declaration Syntax
C#
public void MoveItemToAsync(
    string sItemID,
    string sDestinationID
)
Parameters
sItemID (String)
sDestinationID (String)
Remarks


MoveItemToAsync Method (sItemID, sDestinationID, userState)

MoveItemToAsync Method (sItemID, sDestinationID, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► MoveItemToAsync(String, String, Object)
Declaration Syntax
C#
public void MoveItemToAsync(
    string sItemID,
    string sDestinationID,
    Object userState
)
Parameters
sItemID (String)
sDestinationID (String)
userState (Object)
Remarks


MoveItemToCompleted Event

MoveItemToCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► MoveItemToCompleted
Declaration Syntax
C#
public event MoveItemToCompletedEventHandler MoveItemToCompleted
Remarks


NewLayout Method (sName)

NewLayout Method (sName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► NewLayout(String)
Declaration Syntax
C#
public XmlNode NewLayout(
    string sName
)
Parameters
sName (String)
Remarks


NewLayoutAsync Method

NewLayoutAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► NewLayoutAsync()()()
Members
Icon | Member | Description
 | NewLayoutAsync(String) |
 | NewLayoutAsync(String, Object) |


NewLayoutAsync Method (sName)

NewLayoutAsync Method (sName)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► NewLayoutAsync(String)
Declaration Syntax
C#
public void NewLayoutAsync(
    string sName
)
Parameters
sName (String)
Remarks


NewLayoutAsync Method (sName, userState)

NewLayoutAsync Method (sName, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► NewLayoutAsync(String, Object)
Declaration Syntax
C#
public void NewLayoutAsync(
    string sName,
    Object userState
)
Parameters
sName (String)
userState (Object)
Remarks


NewLayoutCompleted Event

NewLayoutCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► NewLayoutCompleted
Declaration Syntax
C#
public event NewLayoutCompletedEventHandler NewLayoutCompleted
Remarks


Ping Method

Ping Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► Ping()()()
Declaration Syntax
C#
public string Ping()
Remarks


PingAsync Method

PingAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► PingAsync()()()
Members
Icon | Member | Description
 | PingAsync()()() |
 | PingAsync(Object) |


PingAsync Method

PingAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► PingAsync()()()
Declaration Syntax
C#
public void PingAsync()
Remarks


PingAsync Method (userState)

PingAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► PingAsync(Object)
Declaration Syntax
C#
public void PingAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


PingCompleted Event

PingCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► PingCompleted
Declaration Syntax
C#
public event PingCompletedEventHandler PingCompleted
Remarks


Publish Method (publishAll, rootItemID, groups)

Publish Method (publishAll, rootItemID, groups)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► Publish(Boolean, String, String)
Declaration Syntax
C#
public string Publish(
    bool publishAll,
    string rootItemID,
    string groups
)
Parameters
publishAll (Boolean)
rootItemID (String)
groups (String)
Remarks


PublishAsync Method

PublishAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► PublishAsync()()()
Members
Icon | Member | Description
 | PublishAsync(Boolean, String, String) |
 | PublishAsync(Boolean, String, String, Object) |


PublishAsync Method (publishAll, rootItemID, groups)

PublishAsync Method (publishAll, rootItemID, groups)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► PublishAsync(Boolean, String, String)
Declaration Syntax
C#
public void PublishAsync(
    bool publishAll,
    string rootItemID,
    string groups
)
Parameters
publishAll (Boolean)
rootItemID (String)
groups (String)
Remarks


PublishAsync Method (publishAll, rootItemID, groups, userState)

PublishAsync Method (publishAll, rootItemID, groups, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► PublishAsync(Boolean, String, String, Object)
Declaration Syntax
C#
public void PublishAsync(
    bool publishAll,
    string rootItemID,
    string groups,
    Object userState
)
Parameters
publishAll (Boolean)
rootItemID (String)
groups (String)
userState (Object)
Remarks


PublishCompleted Event

PublishCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► PublishCompleted
Declaration Syntax
C#
public event PublishCompletedEventHandler PublishCompleted
Remarks


PublishItem Method (itemPath, groups, deep)

PublishItem Method (itemPath, groups, deep)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► PublishItem(String, String, Boolean)
Declaration Syntax
C#
public string PublishItem(
    string itemPath,
    string groups,
    bool deep
)
Parameters
itemPath (String)
groups (String)
deep (Boolean)
Remarks


PublishItemAsync Method

PublishItemAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► PublishItemAsync()()()
Members
Icon | Member | Description
 | PublishItemAsync(String, String, Boolean) |
 | PublishItemAsync(String, String, Boolean, Object) |


PublishItemAsync Method (itemPath, groups, deep)

PublishItemAsync Method (itemPath, groups, deep)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► PublishItemAsync(String, String, Boolean)
Declaration Syntax
C#
public void PublishItemAsync(
    string itemPath,
    string groups,
    bool deep
)
Parameters
itemPath (String)
groups (String)
deep (Boolean)
Remarks


PublishItemAsync Method (itemPath, groups, deep, userState)

PublishItemAsync Method (itemPath, groups, deep, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► PublishItemAsync(String, String, Boolean, Object)
Declaration Syntax
C#
public void PublishItemAsync(
    string itemPath,
    string groups,
    bool deep,
    Object userState
)
Parameters
itemPath (String)
groups (String)
deep (Boolean)
userState (Object)
Remarks


PublishItemCompleted Event

PublishItemCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► PublishItemCompleted
Declaration Syntax
C#
public event PublishItemCompletedEventHandler PublishItemCompleted
Remarks


ReloadDatabase Method

ReloadDatabase Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ReloadDatabase()()()
Declaration Syntax
C#
public void ReloadDatabase()
Remarks


ReloadDatabaseAsync Method

ReloadDatabaseAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ReloadDatabaseAsync()()()
Members
Icon | Member | Description
 | ReloadDatabaseAsync()()() |
 | ReloadDatabaseAsync(Object) |


ReloadDatabaseAsync Method

ReloadDatabaseAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ReloadDatabaseAsync()()()
Declaration Syntax
C#
public void ReloadDatabaseAsync()
Remarks


ReloadDatabaseAsync Method (userState)

ReloadDatabaseAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ReloadDatabaseAsync(Object)
Declaration Syntax
C#
public void ReloadDatabaseAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


ReloadDatabaseCompleted Event

ReloadDatabaseCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ReloadDatabaseCompleted
Declaration Syntax
C#
public event ReloadDatabaseCompletedEventHandler ReloadDatabaseCompleted
Remarks


RenameItem Method (itemPath, name)

RenameItem Method (itemPath, name)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► RenameItem(String, String)
Declaration Syntax
C#
public void RenameItem(
    string itemPath,
    string name
)
Parameters
itemPath (String)
name (String)
Remarks


RenameItemAsync Method

RenameItemAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► RenameItemAsync()()()
Members
Icon | Member | Description
 | RenameItemAsync(String, String) |
 | RenameItemAsync(String, String, Object) |


RenameItemAsync Method (itemPath, name)

RenameItemAsync Method (itemPath, name)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► RenameItemAsync(String, String)
Declaration Syntax
C#
public void RenameItemAsync(
    string itemPath,
    string name
)
Parameters
itemPath (String)
name (String)
Remarks


RenameItemAsync Method (itemPath, name, userState)

RenameItemAsync Method (itemPath, name, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► RenameItemAsync(String, String, Object)
Declaration Syntax
C#
public void RenameItemAsync(
    string itemPath,
    string name,
    Object userState
)
Parameters
itemPath (String)
name (String)
userState (Object)
Remarks


RenameItemCompleted Event

RenameItemCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► RenameItemCompleted
Declaration Syntax
C#
public event RenameItemCompletedEventHandler RenameItemCompleted
Remarks


ResortChildren Method (path)

ResortChildren Method (path)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ResortChildren(String)
Declaration Syntax
C#
public void ResortChildren(
    string path
)
Parameters
path (String)
Remarks


ResortChildrenAsync Method

ResortChildrenAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ResortChildrenAsync()()()
Members
Icon | Member | Description
 | ResortChildrenAsync(String) |
 | ResortChildrenAsync(String, Object) |


ResortChildrenAsync Method (path)

ResortChildrenAsync Method (path)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ResortChildrenAsync(String)
Declaration Syntax
C#
public void ResortChildrenAsync(
    string path
)
Parameters
path (String)
Remarks


ResortChildrenAsync Method (path, userState)

ResortChildrenAsync Method (path, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ResortChildrenAsync(String, Object)
Declaration Syntax
C#
public void ResortChildrenAsync(
    string path,
    Object userState
)
Parameters
path (String)
userState (Object)
Remarks


ResortChildrenCompleted Event

ResortChildrenCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► ResortChildrenCompleted
Declaration Syntax
C#
public event ResortChildrenCompletedEventHandler ResortChildrenCompleted
Remarks


SaveDatabase Method

SaveDatabase Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveDatabase()()()
Declaration Syntax
C#
public void SaveDatabase()
Remarks


SaveDatabaseAsync Method

SaveDatabaseAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveDatabaseAsync()()()
Members
Icon | Member | Description
 | SaveDatabaseAsync()()() |
 | SaveDatabaseAsync(Object) |


SaveDatabaseAsync Method

SaveDatabaseAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveDatabaseAsync()()()
Declaration Syntax
C#
public void SaveDatabaseAsync()
Remarks


SaveDatabaseAsync Method (userState)

SaveDatabaseAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveDatabaseAsync(Object)
Declaration Syntax
C#
public void SaveDatabaseAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


SaveDatabaseCompleted Event

SaveDatabaseCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveDatabaseCompleted
Declaration Syntax
C#
public event SaveDatabaseCompletedEventHandler SaveDatabaseCompleted
Remarks


SaveItemChanges Method (sXml)

SaveItemChanges Method (sXml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveItemChanges(String)
Declaration Syntax
C#
public string SaveItemChanges(
    string sXml
)
Parameters
sXml (String)
Remarks


SaveItemChangesAsync Method

SaveItemChangesAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveItemChangesAsync()()()
Members
Icon | Member | Description
 | SaveItemChangesAsync(String) |
 | SaveItemChangesAsync(String, Object) |


SaveItemChangesAsync Method (sXml)

SaveItemChangesAsync Method (sXml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveItemChangesAsync(String)
Declaration Syntax
C#
public void SaveItemChangesAsync(
    string sXml
)
Parameters
sXml (String)
Remarks


SaveItemChangesAsync Method (sXml, userState)

SaveItemChangesAsync Method (sXml, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveItemChangesAsync(String, Object)
Declaration Syntax
C#
public void SaveItemChangesAsync(
    string sXml,
    Object userState
)
Parameters
sXml (String)
userState (Object)
Remarks


SaveItemChangesCompleted Event

SaveItemChangesCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveItemChangesCompleted
Declaration Syntax
C#
public event SaveItemChangesCompletedEventHandler SaveItemChangesCompleted
Remarks


SaveItems Method (xml)

SaveItems Method (xml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveItems(String)
Declaration Syntax
C#
public void SaveItems(
    string xml
)
Parameters
xml (String)
Remarks


SaveItemsAsync Method

SaveItemsAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveItemsAsync()()()
Members
Icon | Member | Description
 | SaveItemsAsync(String) |
 | SaveItemsAsync(String, Object) |


SaveItemsAsync Method (xml)

SaveItemsAsync Method (xml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveItemsAsync(String)
Declaration Syntax
C#
public void SaveItemsAsync(
    string xml
)
Parameters
xml (String)
Remarks


SaveItemsAsync Method (xml, userState)

SaveItemsAsync Method (xml, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveItemsAsync(String, Object)
Declaration Syntax
C#
public void SaveItemsAsync(
    string xml,
    Object userState
)
Parameters
xml (String)
userState (Object)
Remarks


SaveItemsCompleted Event

SaveItemsCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveItemsCompleted
Declaration Syntax
C#
public event SaveItemsCompletedEventHandler SaveItemsCompleted
Remarks


SaveLayout Method (sID, sHtml, sTimestamp, bOverwrite)

SaveLayout Method (sID, sHtml, sTimestamp, bOverwrite)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveLayout(String, String, String, Boolean)
Declaration Syntax
C#
public string SaveLayout(
    string sID,
    string sHtml,
    string sTimestamp,
    bool bOverwrite
)
Parameters
sID (String)
sHtml (String)
sTimestamp (String)
bOverwrite (Boolean)
Remarks


SaveLayoutAsync Method

SaveLayoutAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveLayoutAsync()()()
Members
Icon | Member | Description
 | SaveLayoutAsync(String, String, String, Boolean) |
 | SaveLayoutAsync(String, String, String, Boolean, Object) |


SaveLayoutAsync Method (sID, sHtml, sTimestamp, bOverwrite)

SaveLayoutAsync Method (sID, sHtml, sTimestamp, bOverwrite)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveLayoutAsync(String, String, String, Boolean)
Declaration Syntax
C#
public void SaveLayoutAsync(
    string sID,
    string sHtml,
    string sTimestamp,
    bool bOverwrite
)
Parameters
sID (String)
sHtml (String)
sTimestamp (String)
bOverwrite (Boolean)
Remarks


SaveLayoutAsync Method (sID, sHtml, sTimestamp, bOverwrite, userState)

SaveLayoutAsync Method (sID, sHtml, sTimestamp, bOverwrite, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveLayoutAsync(String, String, String, Boolean, Object)
Declaration Syntax
C#
public void SaveLayoutAsync(
    string sID,
    string sHtml,
    string sTimestamp,
    bool bOverwrite,
    Object userState
)
Parameters
sID (String)
sHtml (String)
sTimestamp (String)
bOverwrite (Boolean)
userState (Object)
Remarks


SaveLayoutCompleted Event

SaveLayoutCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveLayoutCompleted
Declaration Syntax
C#
public event SaveLayoutCompletedEventHandler SaveLayoutCompleted
Remarks


SavePackage Method (sName, sXml)

SavePackage Method (sName, sXml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SavePackage(String, String)
Declaration Syntax
C#
public void SavePackage(
    string sName,
    string sXml
)
Parameters
sName (String)
sXml (String)
Remarks


SavePackageAsync Method

SavePackageAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SavePackageAsync()()()
Members
Icon | Member | Description
 | SavePackageAsync(String, String) |
 | SavePackageAsync(String, String, Object) |


SavePackageAsync Method (sName, sXml)

SavePackageAsync Method (sName, sXml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SavePackageAsync(String, String)
Declaration Syntax
C#
public void SavePackageAsync(
    string sName,
    string sXml
)
Parameters
sName (String)
sXml (String)
Remarks


SavePackageAsync Method (sName, sXml, userState)

SavePackageAsync Method (sName, sXml, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SavePackageAsync(String, String, Object)
Declaration Syntax
C#
public void SavePackageAsync(
    string sName,
    string sXml,
    Object userState
)
Parameters
sName (String)
sXml (String)
userState (Object)
Remarks


SavePackageCompleted Event

SavePackageCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SavePackageCompleted
Declaration Syntax
C#
public event SavePackageCompletedEventHandler SavePackageCompleted
Remarks


SavePageEditData Method (xml)

SavePageEditData Method (xml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SavePageEditData(String)
Declaration Syntax
C#
public string SavePageEditData(
    string xml
)
Parameters
xml (String)
Remarks


SavePageEditDataAsync Method

SavePageEditDataAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SavePageEditDataAsync()()()
Members
Icon | Member | Description
 | SavePageEditDataAsync(String) |
 | SavePageEditDataAsync(String, Object) |


SavePageEditDataAsync Method (xml)

SavePageEditDataAsync Method (xml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SavePageEditDataAsync(String)
Declaration Syntax
C#
public void SavePageEditDataAsync(
    string xml
)
Parameters
xml (String)
Remarks


SavePageEditDataAsync Method (xml, userState)

SavePageEditDataAsync Method (xml, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SavePageEditDataAsync(String, Object)
Declaration Syntax
C#
public void SavePageEditDataAsync(
    string xml,
    Object userState
)
Parameters
xml (String)
userState (Object)
Remarks


SavePageEditDataCompleted Event

SavePageEditDataCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SavePageEditDataCompleted
Declaration Syntax
C#
public event SavePageEditDataCompletedEventHandler SavePageEditDataCompleted
Remarks


SaveXslFile Method (sID, sHtml, sTimestamp, bOverwrite)

SaveXslFile Method (sID, sHtml, sTimestamp, bOverwrite)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveXslFile(String, String, String, Boolean)
Declaration Syntax
C#
public string SaveXslFile(
    string sID,
    string sHtml,
    string sTimestamp,
    bool bOverwrite
)
Parameters
sID (String)
sHtml (String)
sTimestamp (String)
bOverwrite (Boolean)
Remarks


SaveXslFileAsync Method

SaveXslFileAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveXslFileAsync()()()
Members
Icon | Member | Description
 | SaveXslFileAsync(String, String, String, Boolean) |
 | SaveXslFileAsync(String, String, String, Boolean, Object) |


SaveXslFileAsync Method (sID, sHtml, sTimestamp, bOverwrite)

SaveXslFileAsync Method (sID, sHtml, sTimestamp, bOverwrite)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveXslFileAsync(String, String, String, Boolean)
Declaration Syntax
C#
public void SaveXslFileAsync(
    string sID,
    string sHtml,
    string sTimestamp,
    bool bOverwrite
)
Parameters
sID (String)
sHtml (String)
sTimestamp (String)
bOverwrite (Boolean)
Remarks


SaveXslFileAsync Method (sID, sHtml, sTimestamp, bOverwrite, userState)

SaveXslFileAsync Method (sID, sHtml, sTimestamp, bOverwrite, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveXslFileAsync(String, String, String, Boolean, Object)
Declaration Syntax
C#
public void SaveXslFileAsync(
    string sID,
    string sHtml,
    string sTimestamp,
    bool bOverwrite,
    Object userState
)
Parameters
sID (String)
sHtml (String)
sTimestamp (String)
bOverwrite (Boolean)
userState (Object)
Remarks


SaveXslFileCompleted Event

SaveXslFileCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SaveXslFileCompleted
Declaration Syntax
C#
public event SaveXslFileCompletedEventHandler SaveXslFileCompleted
Remarks


SetClientLanguage Method (sLanguage)

SetClientLanguage Method (sLanguage)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SetClientLanguage(String)
Declaration Syntax
C#
public void SetClientLanguage(
    string sLanguage
)
Parameters
sLanguage (String)
Remarks


SetClientLanguageAsync Method

SetClientLanguageAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SetClientLanguageAsync()()()
Members
Icon | Member | Description
 | SetClientLanguageAsync(String) |
 | SetClientLanguageAsync(String, Object) |


SetClientLanguageAsync Method (sLanguage)

SetClientLanguageAsync Method (sLanguage)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SetClientLanguageAsync(String)
Declaration Syntax
C#
public void SetClientLanguageAsync(
    string sLanguage
)
Parameters
sLanguage (String)
Remarks


SetClientLanguageAsync Method (sLanguage, userState)

SetClientLanguageAsync Method (sLanguage, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SetClientLanguageAsync(String, Object)
Declaration Syntax
C#
public void SetClientLanguageAsync(
    string sLanguage,
    Object userState
)
Parameters
sLanguage (String)
userState (Object)
Remarks


SetClientLanguageCompleted Event

SetClientLanguageCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SetClientLanguageCompleted
Declaration Syntax
C#
public event SetClientLanguageCompletedEventHandler SetClientLanguageCompleted
Remarks


SetLanguage Method (sLanguage)

SetLanguage Method (sLanguage)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SetLanguage(String)
Declaration Syntax
C#
public void SetLanguage(
    string sLanguage
)
Parameters
sLanguage (String)
Remarks


SetLanguageAsync Method

SetLanguageAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SetLanguageAsync()()()
Members
Icon | Member | Description
 | SetLanguageAsync(String) |
 | SetLanguageAsync(String, Object) |


SetLanguageAsync Method (sLanguage)

SetLanguageAsync Method (sLanguage)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SetLanguageAsync(String)
Declaration Syntax
C#
public void SetLanguageAsync(
    string sLanguage
)
Parameters
sLanguage (String)
Remarks


SetLanguageAsync Method (sLanguage, userState)

SetLanguageAsync Method (sLanguage, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SetLanguageAsync(String, Object)
Declaration Syntax
C#
public void SetLanguageAsync(
    string sLanguage,
    Object userState
)
Parameters
sLanguage (String)
userState (Object)
Remarks


SetLanguageCompleted Event

SetLanguageCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► SetLanguageCompleted
Declaration Syntax
C#
public event SetLanguageCompletedEventHandler SetLanguageCompleted
Remarks


StartPreview Method (isoDate, groups)

StartPreview Method (isoDate, groups)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► StartPreview(String, String)
Declaration Syntax
C#
public void StartPreview(
    string isoDate,
    string groups
)
Parameters
isoDate (String)
groups (String)
Remarks


StartPreviewAsync Method

StartPreviewAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► StartPreviewAsync()()()
Members
Icon | Member | Description
 | StartPreviewAsync(String, String) |
 | StartPreviewAsync(String, String, Object) |


StartPreviewAsync Method (isoDate, groups)

StartPreviewAsync Method (isoDate, groups)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► StartPreviewAsync(String, String)
Declaration Syntax
C#
public void StartPreviewAsync(
    string isoDate,
    string groups
)
Parameters
isoDate (String)
groups (String)
Remarks


StartPreviewAsync Method (isoDate, groups, userState)

StartPreviewAsync Method (isoDate, groups, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► StartPreviewAsync(String, String, Object)
Declaration Syntax
C#
public void StartPreviewAsync(
    string isoDate,
    string groups,
    Object userState
)
Parameters
isoDate (String)
groups (String)
userState (Object)
Remarks


StartPreviewCompleted Event

StartPreviewCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► StartPreviewCompleted
Declaration Syntax
C#
public event StartPreviewCompletedEventHandler StartPreviewCompleted
Remarks


StartWebEdit Method

StartWebEdit Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► StartWebEdit()()()
Declaration Syntax
C#
public void StartWebEdit()
Remarks


StartWebEditAsync Method

StartWebEditAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► StartWebEditAsync()()()
Members
Icon | Member | Description
 | StartWebEditAsync()()() |
 | StartWebEditAsync(Object) |


StartWebEditAsync Method

StartWebEditAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► StartWebEditAsync()()()
Declaration Syntax
C#
public void StartWebEditAsync()
Remarks


StartWebEditAsync Method (userState)

StartWebEditAsync Method (userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► StartWebEditAsync(Object)
Declaration Syntax
C#
public void StartWebEditAsync(
    Object userState
)
Parameters
userState (Object)
Remarks


StartWebEditCompleted Event

StartWebEditCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► StartWebEditCompleted
Declaration Syntax
C#
public event StartWebEditCompletedEventHandler StartWebEditCompleted
Remarks


TidyHtml Method (html, type)

TidyHtml Method (html, type)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► TidyHtml(String, String)
Declaration Syntax
C#
public string TidyHtml(
    string html,
    string type
)
Parameters
html (String)
type (String)
Remarks


TidyHtmlAsync Method

TidyHtmlAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► TidyHtmlAsync()()()
Members
Icon | Member | Description
 | TidyHtmlAsync(String, String) |
 | TidyHtmlAsync(String, String, Object) |


TidyHtmlAsync Method (html, type)

TidyHtmlAsync Method (html, type)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► TidyHtmlAsync(String, String)
Declaration Syntax
C#
public void TidyHtmlAsync(
    string html,
    string type
)
Parameters
html (String)
type (String)
Remarks


TidyHtmlAsync Method (html, type, userState)

TidyHtmlAsync Method (html, type, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► TidyHtmlAsync(String, String, Object)
Declaration Syntax
C#
public void TidyHtmlAsync(
    string html,
    string type,
    Object userState
)
Parameters
html (String)
type (String)
userState (Object)
Remarks


TidyHtmlCompleted Event

TidyHtmlCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► TidyHtmlCompleted
Declaration Syntax
C#
public event TidyHtmlCompletedEventHandler TidyHtmlCompleted
Remarks


TidyHtmlEx Method (html, clean, filter, tidy, allowedTags)

TidyHtmlEx Method (html, clean, filter, tidy, allowedTags)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► TidyHtmlEx(String, Boolean, Boolean, Boolean, String)
Declaration Syntax
C#
public string TidyHtmlEx(
    string html,
    bool clean,
    bool filter,
    bool tidy,
    string allowedTags
)
Parameters
html (String)
clean (Boolean)
filter (Boolean)
tidy (Boolean)
allowedTags (String)
Remarks


TidyHtmlExAsync Method

TidyHtmlExAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► TidyHtmlExAsync()()()
Members
Icon | Member | Description
 | TidyHtmlExAsync(String, Boolean, Boolean, Boolean, String) |
 | TidyHtmlExAsync(String, Boolean, Boolean, Boolean, String, Object) |


TidyHtmlExAsync Method (html, clean, filter, tidy, allowedTags)

TidyHtmlExAsync Method (html, clean, filter, tidy, allowedTags)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► TidyHtmlExAsync(String, Boolean, Boolean, Boolean, String)
Declaration Syntax
C#
public void TidyHtmlExAsync(
    string html,
    bool clean,
    bool filter,
    bool tidy,
    string allowedTags
)
Parameters
html (String)
clean (Boolean)
filter (Boolean)
tidy (Boolean)
allowedTags (String)
Remarks


TidyHtmlExAsync Method (html, clean, filter, tidy, allowedTags, userState)

TidyHtmlExAsync Method (html, clean, filter, tidy, allowedTags, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► TidyHtmlExAsync(String, Boolean, Boolean, Boolean, String, Object)
Declaration Syntax
C#
public void TidyHtmlExAsync(
    string html,
    bool clean,
    bool filter,
    bool tidy,
    string allowedTags,
    Object userState
)
Parameters
html (String)
clean (Boolean)
filter (Boolean)
tidy (Boolean)
allowedTags (String)
userState (Object)
Remarks


TidyHtmlExCompleted Event

TidyHtmlExCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► TidyHtmlExCompleted
Declaration Syntax
C#
public event TidyHtmlExCompletedEventHandler TidyHtmlExCompleted
Remarks


UpdateDocument Method (sPath, sXml)

UpdateDocument Method (sPath, sXml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► UpdateDocument(String, String)
Declaration Syntax
C#
public string UpdateDocument(
    string sPath,
    string sXml
)
Parameters
sPath (String)
sXml (String)
Remarks


UpdateDocumentAsync Method

UpdateDocumentAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► UpdateDocumentAsync()()()
Members
Icon | Member | Description
 | UpdateDocumentAsync(String, String) |
 | UpdateDocumentAsync(String, String, Object) |


UpdateDocumentAsync Method (sPath, sXml)

UpdateDocumentAsync Method (sPath, sXml)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► UpdateDocumentAsync(String, String)
Declaration Syntax
C#
public void UpdateDocumentAsync(
    string sPath,
    string sXml
)
Parameters
sPath (String)
sXml (String)
Remarks


UpdateDocumentAsync Method (sPath, sXml, userState)

UpdateDocumentAsync Method (sPath, sXml, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► UpdateDocumentAsync(String, String, Object)
Declaration Syntax
C#
public void UpdateDocumentAsync(
    string sPath,
    string sXml,
    Object userState
)
Parameters
sPath (String)
sXml (String)
userState (Object)
Remarks


UpdateDocumentCompleted Event

UpdateDocumentCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► UpdateDocumentCompleted
Declaration Syntax
C#
public event UpdateDocumentCompletedEventHandler UpdateDocumentCompleted
Remarks


UpdateSortorder Method (parentPath, list)

UpdateSortorder Method (parentPath, list)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► UpdateSortorder(String, String)
Declaration Syntax
C#
public void UpdateSortorder(
    string parentPath,
    string list
)
Parameters
parentPath (String)
list (String)
Remarks


UpdateSortorderAsync Method

UpdateSortorderAsync Method
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► UpdateSortorderAsync()()()
Members
Icon | Member | Description
 | UpdateSortorderAsync(String, String) |
 | UpdateSortorderAsync(String, String, Object) |


UpdateSortorderAsync Method (parentPath, list)

UpdateSortorderAsync Method (parentPath, list)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► UpdateSortorderAsync(String, String)
Declaration Syntax
C#
public void UpdateSortorderAsync(
    string parentPath,
    string list
)
Parameters
parentPath (String)
list (String)
Remarks


UpdateSortorderAsync Method (parentPath, list, userState)

UpdateSortorderAsync Method (parentPath, list, userState)
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► UpdateSortorderAsync(String, String, Object)
Declaration Syntax
C#
public void UpdateSortorderAsync(
    string parentPath,
    string list,
    Object userState
)
Parameters
parentPath (String)
list (String)
userState (Object)
Remarks


UpdateSortorderCompleted Event

UpdateSortorderCompleted Event
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► UpdateSortorderCompleted
Declaration Syntax
C#
public event UpdateSortorderCompletedEventHandler UpdateSortorderCompleted
Remarks


Url Property

Url Property
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► Url
Declaration Syntax
C#
public string Url { get; set; }


UseDefaultCredentials Property

UseDefaultCredentials Property
Namespaces ► Sitecore.localhost ► SitecoreClientAPI ► UseDefaultCredentials
Declaration Syntax
C#
public bool UseDefaultCredentials { get; set; }


StartPreviewCompletedEventHandler Delegate

StartPreviewCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► StartPreviewCompletedEventHandler
Declaration Syntax
C#
public delegate void StartPreviewCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


StartWebEditCompletedEventHandler Delegate

StartWebEditCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► StartWebEditCompletedEventHandler
Declaration Syntax
C#
public delegate void StartWebEditCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


TidyHtmlCompletedEventArgs Class

TidyHtmlCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► TidyHtmlCompletedEventArgs
Declaration Syntax
C#
public class TidyHtmlCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | TidyHtmlCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► TidyHtmlCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


TidyHtmlCompletedEventHandler Delegate

TidyHtmlCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► TidyHtmlCompletedEventHandler
Declaration Syntax
C#
public delegate void TidyHtmlCompletedEventHandler(
    Object sender,
    TidyHtmlCompletedEventArgs e
)
Parameters
sender (Object)
e (TidyHtmlCompletedEventArgs)
Remarks


TidyHtmlExCompletedEventArgs Class

TidyHtmlExCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► TidyHtmlExCompletedEventArgs
Declaration Syntax
C#
public class TidyHtmlExCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | TidyHtmlExCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► TidyHtmlExCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


TidyHtmlExCompletedEventHandler Delegate

TidyHtmlExCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► TidyHtmlExCompletedEventHandler
Declaration Syntax
C#
public delegate void TidyHtmlExCompletedEventHandler(
    Object sender,
    TidyHtmlExCompletedEventArgs e
)
Parameters
sender (Object)
e (TidyHtmlExCompletedEventArgs)
Remarks


UpdateDocumentCompletedEventArgs Class

UpdateDocumentCompletedEventArgs Class
Namespaces ► Sitecore.localhost ► UpdateDocumentCompletedEventArgs
Declaration Syntax
C#
public class UpdateDocumentCompletedEventArgs : AsyncCompletedEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseExceptionIfNecessary()()() | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Remarks
Inheritance Hierarchy
Object
 | EventArgs
 |  | AsyncCompletedEventArgs
 |  |  | UpdateDocumentCompletedEventArgs


Result Property

Result Property
Namespaces ► Sitecore.localhost ► UpdateDocumentCompletedEventArgs ► Result
Declaration Syntax
C#
public string Result { get; }
Remarks


UpdateDocumentCompletedEventHandler Delegate

UpdateDocumentCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► UpdateDocumentCompletedEventHandler
Declaration Syntax
C#
public delegate void UpdateDocumentCompletedEventHandler(
    Object sender,
    UpdateDocumentCompletedEventArgs e
)
Parameters
sender (Object)
e (UpdateDocumentCompletedEventArgs)
Remarks


UpdateSortorderCompletedEventHandler Delegate

UpdateSortorderCompletedEventHandler Delegate
Namespaces ► Sitecore.localhost ► UpdateSortorderCompletedEventHandler
Declaration Syntax
C#
public delegate void UpdateSortorderCompletedEventHandler(
    Object sender,
    AsyncCompletedEventArgs e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)
Remarks


Sitecore.Login Namespace

Sitecore.Login Namespace
Namespaces ► Sitecore.Login
Declaration Syntax
C#
namespace Sitecore.Login
Types
All Types Classes
Icon | Type | Description
 | ChangePasswordPage | Represents the Change Password Page.
 | LoginPage | Represents a LoginPage.
 | PasswordRecoveryPage | Represents a PasswordRecoveryPage. PasswordRecoveryPage class.


ChangePasswordPage Class

ChangePasswordPage Class
Namespaces ► Sitecore.Login ► ChangePasswordPage
Represents the Change Password Page.
Declaration Syntax
C#
public class ChangePasswordPage : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangePasswordPage()()() | Initializes a new instance of the ChangePasswordPage class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChangePassword | ChangePassword control.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginForm | LoginForm control.
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Page.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageScriptManager | Gets the page script manager. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PartnerLogo | PartnerLogo control.
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Page
 |  |  |  |  | ChangePasswordPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ChangePasswordPage Constructor

ChangePasswordPage Constructor
Namespaces ► Sitecore.Login ► ChangePasswordPage ► ChangePasswordPage()()()
Initializes a new instance of the ChangePasswordPage class
Declaration Syntax
C#
public ChangePasswordPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ChangePassword Field

ChangePassword Field
Namespaces ► Sitecore.Login ► ChangePasswordPage ► ChangePassword
ChangePassword control.
Declaration Syntax
C#
protected ChangePassword ChangePassword
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LoginForm Field

LoginForm Field
Namespaces ► Sitecore.Login ► ChangePasswordPage ► LoginForm
LoginForm control.
Declaration Syntax
C#
protected HtmlForm LoginForm
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Login ► ChangePasswordPage ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PartnerLogo Field

PartnerLogo Field
Namespaces ► Sitecore.Login ► ChangePasswordPage ► PartnerLogo
PartnerLogo control.
Declaration Syntax
C#
protected PlaceHolder PartnerLogo
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LoginPage Class

LoginPage Class
Namespaces ► Sitecore.Login ► LoginPage
Represents a LoginPage.
Declaration Syntax
C#
public class LoginPage : Page, IComparer
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoginPage()()() | Initializes a new instance of the LoginPage class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | ActiveTab | ActiveTab control.
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | AdvancedContentEditor | AdvancedContentEditor control.
 | AdvancedDesktop | AdvancedDesktop control.
 | AdvancedOptionsStartUrl | AdvancedOptionsStartUrl control.
 | AdvancedWebEdit | AdvancedWebEdit control.
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | CustomText | CustomText control.
 | CustomTextPanel | CustomTextPanel control.
 | DatabasePanel | DatabasePanel control.
 | DatabaseText | DatabaseText control.
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | ExpressStylesheet | ExpressStylesheet control.
 | FailureText2 | FailureText2 control.
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | Language | Language control.
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | LicenseText | LicenseText control.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | Login | Login control.
 | LoginForm | LoginForm control.
 | LoginTitleText | LoginTitleText control.
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Overrides Page.OnInit(EventArgs).)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Control.OnPreRender(EventArgs).)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | OptionBox | OptionBox control.
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PartnerLogo | PartnerLogo control.
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StartPage | StartPage control.
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | VersionText | VersionText control.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | LoginPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LoginPage Constructor

LoginPage Constructor
Namespaces ► Sitecore.Login ► LoginPage ► LoginPage()()()
Initializes a new instance of the LoginPage class
Declaration Syntax
C#
public LoginPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ActiveTab Field

ActiveTab Field
Namespaces ► Sitecore.Login ► LoginPage ► ActiveTab
ActiveTab control.
Declaration Syntax
C#
protected HtmlInputHidden ActiveTab
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AdvancedContentEditor Field

AdvancedContentEditor Field
Namespaces ► Sitecore.Login ► LoginPage ► AdvancedContentEditor
AdvancedContentEditor control.
Declaration Syntax
C#
protected HtmlButton AdvancedContentEditor
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AdvancedDesktop Field

AdvancedDesktop Field
Namespaces ► Sitecore.Login ► LoginPage ► AdvancedDesktop
AdvancedDesktop control.
Declaration Syntax
C#
protected HtmlButton AdvancedDesktop
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AdvancedOptionsStartUrl Field

AdvancedOptionsStartUrl Field
Namespaces ► Sitecore.Login ► LoginPage ► AdvancedOptionsStartUrl
AdvancedOptionsStartUrl control.
Declaration Syntax
C#
protected HtmlInputHidden AdvancedOptionsStartUrl
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AdvancedWebEdit Field

AdvancedWebEdit Field
Namespaces ► Sitecore.Login ► LoginPage ► AdvancedWebEdit
AdvancedWebEdit control.
Declaration Syntax
C#
protected HtmlButton AdvancedWebEdit
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CustomText Field

CustomText Field
Namespaces ► Sitecore.Login ► LoginPage ► CustomText
CustomText control.
Declaration Syntax
C#
protected PlaceHolder CustomText
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CustomTextPanel Field

CustomTextPanel Field
Namespaces ► Sitecore.Login ► LoginPage ► CustomTextPanel
CustomTextPanel control.
Declaration Syntax
C#
protected HtmlGenericControl CustomTextPanel
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DatabasePanel Field

DatabasePanel Field
Namespaces ► Sitecore.Login ► LoginPage ► DatabasePanel
DatabasePanel control.
Declaration Syntax
C#
protected HtmlGenericControl DatabasePanel
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DatabaseText Field

DatabaseText Field
Namespaces ► Sitecore.Login ► LoginPage ► DatabaseText
DatabaseText control.
Declaration Syntax
C#
protected PlaceHolder DatabaseText
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ExpressStylesheet Field

ExpressStylesheet Field
Namespaces ► Sitecore.Login ► LoginPage ► ExpressStylesheet
ExpressStylesheet control.
Declaration Syntax
C#
protected PlaceHolder ExpressStylesheet
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


FailureText2 Field

FailureText2 Field
Namespaces ► Sitecore.Login ► LoginPage ► FailureText2
FailureText2 control.
Declaration Syntax
C#
protected Literal FailureText2
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Language Field

Language Field
Namespaces ► Sitecore.Login ► LoginPage ► Language
Language control.
Declaration Syntax
C#
protected HtmlSelect Language
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LicenseText Field

LicenseText Field
Namespaces ► Sitecore.Login ► LoginPage ► LicenseText
LicenseText control.
Declaration Syntax
C#
protected PlaceHolder LicenseText
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Login Field

Login Field
Namespaces ► Sitecore.Login ► LoginPage ► Login
Login control.
Declaration Syntax
C#
protected Login Login
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LoginForm Field

LoginForm Field
Namespaces ► Sitecore.Login ► LoginPage ► LoginForm
LoginForm control.
Declaration Syntax
C#
protected HtmlForm LoginForm
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LoginTitleText Field

LoginTitleText Field
Namespaces ► Sitecore.Login ► LoginPage ► LoginTitleText
LoginTitleText control.
Declaration Syntax
C#
protected PlaceHolder LoginTitleText
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnInit Method (e)

OnInit Method (e)
Namespaces ► Sitecore.Login ► LoginPage ► OnInit(EventArgs)
Raises the Init event to initialize the page.
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Login ► LoginPage ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OptionBox Field

OptionBox Field
Namespaces ► Sitecore.Login ► LoginPage ► OptionBox
OptionBox control.
Declaration Syntax
C#
protected HtmlGenericControl OptionBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PartnerLogo Field

PartnerLogo Field
Namespaces ► Sitecore.Login ► LoginPage ► PartnerLogo
PartnerLogo control.
Declaration Syntax
C#
protected PlaceHolder PartnerLogo
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


StartPage Field

StartPage Field
Namespaces ► Sitecore.Login ► LoginPage ► StartPage
StartPage control.
Declaration Syntax
C#
protected HtmlGenericControl StartPage
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


VersionText Field

VersionText Field
Namespaces ► Sitecore.Login ► LoginPage ► VersionText
VersionText control.
Declaration Syntax
C#
protected PlaceHolder VersionText
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PasswordRecoveryPage Class

PasswordRecoveryPage Class
Namespaces ► Sitecore.Login ► PasswordRecoveryPage
Represents a PasswordRecoveryPage.
PasswordRecoveryPage class.
Declaration Syntax
C#
public class PasswordRecoveryPage : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PasswordRecoveryPage()()() | Initializes a new instance of the PasswordRecoveryPage class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginForm | LoginForm control.
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Page.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageScriptManager | Gets the page script manager. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PartnerLogo | PartnerLogo control.
 | PasswordRecovery | PasswordRecovery control.
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SendEmail(Object, MailMessageEventArgs) | Sends the email.
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Remarks
Auto-generated class.
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Page
 |  |  |  |  | PasswordRecoveryPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PasswordRecoveryPage Constructor

PasswordRecoveryPage Constructor
Namespaces ► Sitecore.Login ► PasswordRecoveryPage ► PasswordRecoveryPage()()()
Initializes a new instance of the PasswordRecoveryPage class
Declaration Syntax
C#
public PasswordRecoveryPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LoginForm Field

LoginForm Field
Namespaces ► Sitecore.Login ► PasswordRecoveryPage ► LoginForm
LoginForm control.
Declaration Syntax
C#
protected HtmlForm LoginForm
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Login ► PasswordRecoveryPage ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PartnerLogo Field

PartnerLogo Field
Namespaces ► Sitecore.Login ► PasswordRecoveryPage ► PartnerLogo
PartnerLogo control.
Declaration Syntax
C#
protected PlaceHolder PartnerLogo
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PasswordRecovery Field

PasswordRecovery Field
Namespaces ► Sitecore.Login ► PasswordRecoveryPage ► PasswordRecovery
PasswordRecovery control.
Declaration Syntax
C#
protected PasswordRecovery PasswordRecovery
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SendEmail Method (sender, e)

SendEmail Method (sender, e)
Namespaces ► Sitecore.Login ► PasswordRecoveryPage ► SendEmail(Object, MailMessageEventArgs)
Sends the email.
Declaration Syntax
C#
protected void SendEmail(
    Object sender,
    MailMessageEventArgs e
)
Parameters
sender (Object)
The sender.
e (MailMessageEventArgs)
The MailMessageEventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Pipelines Namespace

Sitecore.Pipelines Namespace
Namespaces ► Sitecore.Pipelines
Declaration Syntax
C#
namespace Sitecore.Pipelines
Types
All Types Classes Enumerations
Icon | Type | Description
 | CorePipeline | Represents a core pipeline.
 | CorePipelineFactory | Represents the pipeline factory (2).
 | CoreProcessor | Represents a processor (2).
 | ItemLinksPipelineArgs | Obsolete. Argument class for processor Item links.
 | ObjectScope | Represents an object scope.
 | Pipeline | Represents a pipeline.
 | PipelineArgs | Base argument class for processor implementations
 | PipelineFactory | Factory for instantiating processors defined in the web.config.
 | PipelineGroup | Represents a pipeline group.
 | PipelineMessage | Represents a pipeline message.
 | PipelineMessageFilter | Represents the filter for a pipeline message.
 | PipelineMessageType | Represents the type of a pipeline message.
 | PipelineMethod | Represents a pipeline method.
 | Pipeline..::.PipelineType | Represents the type of a pipeline.
 | Processor | Represents a single step in a pipeline.
 | ProcessorObject | Represents a processor object.


CorePipeline Class

CorePipeline Class
Namespaces ► Sitecore.Pipelines ► CorePipeline
Represents a core pipeline.
Declaration Syntax
C#
public class CorePipeline
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CorePipeline(String) | Initializes a new instance of the CorePipeline class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(XmlNode) | Initializes the pipeline from a config node.
 | IsEmpty | Gets a value indicating whether this pipeline is empty.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Run(PipelineArgs) | Runs the pipeline.
 | Run(String, PipelineArgs) | Runs the specified pipeline.
 | Run(String, PipelineArgs, String) | Runs the specified pipeline.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CorePipeline


CorePipeline Constructor (pipelineName)

CorePipeline Constructor (pipelineName)
Namespaces ► Sitecore.Pipelines ► CorePipeline ► CorePipeline(String)
Initializes a new instance of the CorePipeline class.
Declaration Syntax
C#
public CorePipeline(
    string pipelineName
)
Parameters
pipelineName (String)
Name of the pipeline.


Initialize Method (configNode)

Initialize Method (configNode)
Namespaces ► Sitecore.Pipelines ► CorePipeline ► Initialize(XmlNode)
Initializes the pipeline from a config node.
Declaration Syntax
C#
public void Initialize(
    XmlNode configNode
)
Parameters
configNode (XmlNode)
The config node.


IsEmpty Property

IsEmpty Property
Namespaces ► Sitecore.Pipelines ► CorePipeline ► IsEmpty
Gets a value indicating whether this pipeline is empty.
Declaration Syntax
C#
public bool IsEmpty { get; }
Value
true if this pipeline is empty; otherwise, false.


Name Property

Name Property
Namespaces ► Sitecore.Pipelines ► CorePipeline ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Run Method

Run Method
Namespaces ► Sitecore.Pipelines ► CorePipeline ► Run()()()
Members
Icon | Member | Description
 | Run(PipelineArgs) | Runs the pipeline.
 | Run(String, PipelineArgs) | Runs the specified pipeline.
 | Run(String, PipelineArgs, String) | Runs the specified pipeline.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Pipelines ► CorePipeline ► Run(PipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
public void Run(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The args.


Run Method (pipelineName, args)

Run Method (pipelineName, args)
Namespaces ► Sitecore.Pipelines ► CorePipeline ► Run(String, PipelineArgs)
Runs the specified pipeline.
Declaration Syntax
C#
public static void Run(
    string pipelineName,
    PipelineArgs args
)
Parameters
pipelineName (String)
Name of the pipeline.
args (PipelineArgs)
The args.


Run Method (pipelineName, args, pipelineDomain)

Run Method (pipelineName, args, pipelineDomain)
Namespaces ► Sitecore.Pipelines ► CorePipeline ► Run(String, PipelineArgs, String)
Runs the specified pipeline.
Declaration Syntax
C#
public static void Run(
    string pipelineName,
    PipelineArgs args,
    string pipelineDomain
)
Parameters
pipelineName (String)
Name of the pipeline.
args (PipelineArgs)
The arguments.
pipelineDomain (String)
The pipeline domain.


CorePipelineFactory Class

CorePipelineFactory Class
Namespaces ► Sitecore.Pipelines ► CorePipelineFactory
Represents the pipeline factory (2).
Declaration Syntax
C#
public static class CorePipelineFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClearCache()()() | Clears the cache.
 | GetPipeline(String, String) | Gets the pipeline.
Inheritance Hierarchy
Object
CorePipelineFactory


ClearCache Method

ClearCache Method
Namespaces ► Sitecore.Pipelines ► CorePipelineFactory ► ClearCache()()()
Clears the cache.
Declaration Syntax
C#
public static void ClearCache()


GetPipeline Method (pipelineName, pipelineGroup)

GetPipeline Method (pipelineName, pipelineGroup)
Namespaces ► Sitecore.Pipelines ► CorePipelineFactory ► GetPipeline(String, String)
Gets the pipeline.
Declaration Syntax
C#
public static CorePipeline GetPipeline(
    string pipelineName,
    string pipelineGroup
)
Parameters
pipelineName (String)
Name of the pipeline.
pipelineGroup (String)
The pipeline group.
Return Value
The pipeline.


CoreProcessor Class

CoreProcessor Class
Namespaces ► Sitecore.Pipelines ► CoreProcessor
Represents a processor (2).
Declaration Syntax
C#
public class CoreProcessor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CoreProcessor()()() | Initializes a new instance of the CoreProcessor class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(XmlNode) | Initializes the processor.
 | Invoke(array<Object>[]()[]) | Invokes the method.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | RunIfAborted | Gets a value indicating whether to run the processor even if the pipeline has been aborted.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CoreProcessor


CoreProcessor Constructor

CoreProcessor Constructor
Namespaces ► Sitecore.Pipelines ► CoreProcessor ► CoreProcessor()()()
Initializes a new instance of the CoreProcessor class.
Declaration Syntax
C#
public CoreProcessor()


Initialize Method (configNode)

Initialize Method (configNode)
Namespaces ► Sitecore.Pipelines ► CoreProcessor ► Initialize(XmlNode)
Initializes the processor.
Declaration Syntax
C#
public void Initialize(
    XmlNode configNode
)
Parameters
configNode (XmlNode)
The config node.


Invoke Method (parameters)

Invoke Method (parameters)
Namespaces ► Sitecore.Pipelines ► CoreProcessor ► Invoke(array<Object>[]()[])
Invokes the method.
Declaration Syntax
C#
public void Invoke(
    Object[] parameters
)
Parameters
parameters (array< Object >[]()[])
The parameters.


Name Property

Name Property
Namespaces ► Sitecore.Pipelines ► CoreProcessor ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


RunIfAborted Property

RunIfAborted Property
Namespaces ► Sitecore.Pipelines ► CoreProcessor ► RunIfAborted
Gets a value indicating whether to run the processor even if the pipeline has been aborted.
Declaration Syntax
C#
public bool RunIfAborted { get; }
Value
true if the processor should be run; otherwise, false.


ItemLinksPipelineArgs Class

ItemLinksPipelineArgs Class
Namespaces ► Sitecore.Pipelines ► ItemLinksPipelineArgs
Argument class for processor Item links.
Declaration Syntax
C#
[SerializableAttribute]
[ObsoleteAttribute("Deprecated.")]
public class ItemLinksPipelineArgs : ClientPipelineArgs,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemLinksPipelineArgs()()() | Initializes a new instance of the ItemLinksPipelineArgs class.
 | ItemLinksPipelineArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemLinksPipelineArgs class from a serialization context.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
 | ItemLinks | Gets or sets the links that are to be transfered between method invocations.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from ClientPipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
 | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitForPostBack()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ClientPipelineArgs
 |  |  |  | ItemLinksPipelineArgs


ItemLinksPipelineArgs Constructor

ItemLinksPipelineArgs Constructor
Namespaces ► Sitecore.Pipelines ► ItemLinksPipelineArgs ► ItemLinksPipelineArgs()()()
Members
Icon | Member | Description
 | ItemLinksPipelineArgs()()() | Initializes a new instance of the ItemLinksPipelineArgs class.
 | ItemLinksPipelineArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemLinksPipelineArgs class from a serialization context.


ItemLinksPipelineArgs Constructor

ItemLinksPipelineArgs Constructor
Namespaces ► Sitecore.Pipelines ► ItemLinksPipelineArgs ► ItemLinksPipelineArgs()()()
Initializes a new instance of the ItemLinksPipelineArgs class.
Declaration Syntax
C#
public ItemLinksPipelineArgs()


ItemLinksPipelineArgs Constructor (info, context)

ItemLinksPipelineArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines ► ItemLinksPipelineArgs ► ItemLinksPipelineArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the ItemLinksPipelineArgs class from a serialization context.
Declaration Syntax
C#
protected ItemLinksPipelineArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialized data.
context (StreamingContext)
The context.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines ► ItemLinksPipelineArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


ItemLinks Property

ItemLinks Property
Namespaces ► Sitecore.Pipelines ► ItemLinksPipelineArgs ► ItemLinks
Gets or sets the links that are to be transfered between method invocations.
Declaration Syntax
C#
public ItemLink[] ItemLinks { get; set; }
Value
The item links.


ObjectScope Enumeration

ObjectScope Enumeration
Namespaces ► Sitecore.Pipelines ► ObjectScope
Represents an object scope.
Declaration Syntax
C#
public enum ObjectScope
Members
Member | Description
Invocation | Invocation.
Processor | Processor.
Pipeline | Pipeline.
Group | Group.


Pipeline Class

Pipeline Class
Namespaces ► Sitecore.Pipelines ► Pipeline
Represents a pipeline.
Declaration Syntax
C#
[SerializableAttribute]
public class Pipeline : ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Pipeline(String, ArrayList) | Obsolete. Initializes a new instance of the Pipeline class.
 | Pipeline(String, ArrayList, Pipeline..::.PipelineType) | Initializes a new instance of the Pipeline class.
 | Pipeline(SerializationInfo, StreamingContext) | Initializes a new instance of the Pipeline class from a serialization context.
 | Add(Processor) | Adds the specified processor.
 | AddAt(Int32, Processor) | Adds the specified processor at the index.
 | Args | Gets the arguments.
 | CurrentProcessor | Gets or sets the current processor.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetProcessorByName(String) | Gets the name of the processor by name.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | NextProcessor | Gets or sets the next processor.
 | Processors | Gets the processors.
 | Remove(Processor) | Removes the specified processor.
 | Resume()()() | Runs the processors of a specific type.
 | Start(PipelineArgs) | Starts the pipeline using the specified argumentss.
 | Start(PipelineArgs, Boolean) | Starts the pipeline using the specified argumentss.
 | Start(String, PipelineArgs) | Starts the pipeline with the specified name.
 | Start(String, PipelineArgs, Boolean) | Starts the pipeline with the specified name.
 | Start(Item, PipelineArgs) | Starts the pipeline with the specified owner item.
 | Start(Item, PipelineArgs, Boolean) | Starts the pipeline with the specified owner item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Pipeline


Pipeline Constructor

Pipeline Constructor
Namespaces ► Sitecore.Pipelines ► Pipeline ► Pipeline()()()
Members
Icon | Member | Description
 | Pipeline(String, ArrayList) | Obsolete. Initializes a new instance of the Pipeline class.
 | Pipeline(String, ArrayList, Pipeline..::.PipelineType) | Initializes a new instance of the Pipeline class.
 | Pipeline(SerializationInfo, StreamingContext) | Initializes a new instance of the Pipeline class from a serialization context.


Pipeline Constructor (info, context)

Pipeline Constructor (info, context)
Namespaces ► Sitecore.Pipelines ► Pipeline ► Pipeline(SerializationInfo, StreamingContext)
Initializes a new instance of the Pipeline class from a serialization context.
Declaration Syntax
C#
protected Pipeline(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialized data.
context (StreamingContext)
The context.


Pipeline Constructor (name, processors)

Pipeline Constructor (name, processors)
Namespaces ► Sitecore.Pipelines ► Pipeline ► Pipeline(String, ArrayList)
Initializes a new instance of the Pipeline class.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Pipeline(name, processors, type) instead.")]
public Pipeline(
    string name,
    ArrayList processors
)
Parameters
name (String)
The name.
processors (ArrayList)
The processors.


Pipeline Constructor (name, processors, type)

Pipeline Constructor (name, processors, type)
Namespaces ► Sitecore.Pipelines ► Pipeline ► Pipeline(String, ArrayList, Pipeline..::.PipelineType)
Initializes a new instance of the Pipeline class.
Declaration Syntax
C#
public Pipeline(
    string name,
    ArrayList processors,
    Pipeline..::.PipelineType type
)
Parameters
name (String)
The name.
processors (ArrayList)
The processors.
type (Pipeline..::.PipelineType)
The type.


Add Method (processor)

Add Method (processor)
Namespaces ► Sitecore.Pipelines ► Pipeline ► Add(Processor)
Adds the specified processor.
Declaration Syntax
C#
public void Add(
    Processor processor
)
Parameters
processor (Processor)
The processor.


AddAt Method (index, processor)

AddAt Method (index, processor)
Namespaces ► Sitecore.Pipelines ► Pipeline ► AddAt(Int32, Processor)
Adds the specified processor at the index.
Declaration Syntax
C#
public void AddAt(
    int index,
    Processor processor
)
Parameters
index (Int32)
The index.
processor (Processor)
The processor.


Args Property

Args Property
Namespaces ► Sitecore.Pipelines ► Pipeline ► Args
Gets the arguments.
Declaration Syntax
C#
public PipelineArgs Args { get; }
Value
The arguments.


CurrentProcessor Property

CurrentProcessor Property
Namespaces ► Sitecore.Pipelines ► Pipeline ► CurrentProcessor
Gets or sets the current processor.
Declaration Syntax
C#
public Processor CurrentProcessor { get; set; }
Value
The current processor.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines ► Pipeline ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


GetProcessorByName Method (name)

GetProcessorByName Method (name)
Namespaces ► Sitecore.Pipelines ► Pipeline ► GetProcessorByName(String)
Gets the name of the processor by name.
Declaration Syntax
C#
public Processor GetProcessorByName(
    string name
)
Parameters
name (String)
The name.
Return Value
The Processor.


ID Property

ID Property
Namespaces ► Sitecore.Pipelines ► Pipeline ► ID
Gets or sets the ID.
Declaration Syntax
C#
public string ID { get; set; }
Value
The ID.


Name Property

Name Property
Namespaces ► Sitecore.Pipelines ► Pipeline ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


NextProcessor Property

NextProcessor Property
Namespaces ► Sitecore.Pipelines ► Pipeline ► NextProcessor
Gets or sets the next processor.
Declaration Syntax
C#
public Processor NextProcessor { get; set; }
Value
The next processor.


Processors Property

Processors Property
Namespaces ► Sitecore.Pipelines ► Pipeline ► Processors
Gets the processors.
Declaration Syntax
C#
public IList Processors { get; }
Value
The processors.


Remove Method (processor)

Remove Method (processor)
Namespaces ► Sitecore.Pipelines ► Pipeline ► Remove(Processor)
Removes the specified processor.
Declaration Syntax
C#
public void Remove(
    Processor processor
)
Parameters
processor (Processor)
The processor.


Resume Method

Resume Method
Namespaces ► Sitecore.Pipelines ► Pipeline ► Resume()()()
Runs the processors of a specific type.
Declaration Syntax
C#
public void Resume()


Start Method

Start Method
Namespaces ► Sitecore.Pipelines ► Pipeline ► Start()()()
Members
Icon | Member | Description
 | Start(PipelineArgs) | Starts the pipeline using the specified argumentss.
 | Start(PipelineArgs, Boolean) | Starts the pipeline using the specified argumentss.
 | Start(String, PipelineArgs) | Starts the pipeline with the specified name.
 | Start(String, PipelineArgs, Boolean) | Starts the pipeline with the specified name.
 | Start(Item, PipelineArgs) | Starts the pipeline with the specified owner item.
 | Start(Item, PipelineArgs, Boolean) | Starts the pipeline with the specified owner item.


Start Method (ownerItem, args)

Start Method (ownerItem, args)
Namespaces ► Sitecore.Pipelines ► Pipeline ► Start(Item, PipelineArgs)
Starts the pipeline with the specified owner item.
Declaration Syntax
C#
public static Pipeline Start(
    Item ownerItem,
    PipelineArgs args
)
Parameters
ownerItem (Item)
The owner item.
args (PipelineArgs)
The arguments.
Return Value
The Pipeline.


Start Method (ownerItem, args, atomic)

Start Method (ownerItem, args, atomic)
Namespaces ► Sitecore.Pipelines ► Pipeline ► Start(Item, PipelineArgs, Boolean)
Starts the pipeline with the specified owner item.
Declaration Syntax
C#
public static Pipeline Start(
    Item ownerItem,
    PipelineArgs args,
    bool atomic
)
Parameters
ownerItem (Item)
The owner item.
args (PipelineArgs)
The arguments.
atomic (Boolean)
if set to true this instance is atomic.
Return Value
The Pipeline.


Start Method (args)

Start Method (args)
Namespaces ► Sitecore.Pipelines ► Pipeline ► Start(PipelineArgs)
Starts the pipeline using the specified argumentss.
Declaration Syntax
C#
public void Start(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The arguments.


Start Method (args, atomic)

Start Method (args, atomic)
Namespaces ► Sitecore.Pipelines ► Pipeline ► Start(PipelineArgs, Boolean)
Starts the pipeline using the specified argumentss.
Declaration Syntax
C#
public void Start(
    PipelineArgs args,
    bool atomic
)
Parameters
args (PipelineArgs)
The arguments.
atomic (Boolean)
if set to true this instance is atomic.


Start Method (pipelineName, args)

Start Method (pipelineName, args)
Namespaces ► Sitecore.Pipelines ► Pipeline ► Start(String, PipelineArgs)
Starts the pipeline with the specified name.
Declaration Syntax
C#
public static Pipeline Start(
    string pipelineName,
    PipelineArgs args
)
Parameters
pipelineName (String)
Name of the pipeline.
args (PipelineArgs)
The arguments.
Return Value
The Pipeline.


Start Method (pipelineName, args, atomic)

Start Method (pipelineName, args, atomic)
Namespaces ► Sitecore.Pipelines ► Pipeline ► Start(String, PipelineArgs, Boolean)
Starts the pipeline with the specified name.
Declaration Syntax
C#
public static Pipeline Start(
    string pipelineName,
    PipelineArgs args,
    bool atomic
)
Parameters
pipelineName (String)
Name of the pipeline.
args (PipelineArgs)
The arguments.
atomic (Boolean)
if set to true this instance is atomic.
Return Value
The Pipeline.


Pipeline.PipelineType Enumeration

Pipeline..::.PipelineType Enumeration
Namespaces ► Sitecore.Pipelines ► Pipeline ► Pipeline..::.PipelineType
Represents the type of a pipeline.
Declaration Syntax
C#
public enum PipelineType
Members
Member | Description
Unknown | Unknown.
Predefined | Predefined.
ItemBased | Item based.
Dynamic | Dynamic.


PipelineArgs Class

PipelineArgs Class
Namespaces ► Sitecore.Pipelines ► PipelineArgs
Base argument class for processor implementations
Declaration Syntax
C#
[SerializableAttribute]
public class PipelineArgs : EventArgs,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PipelineArgs()()() | Initializes a new instance of the PipelineArgs class.
 | PipelineArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the PipelineArgs class from a serialization context.
 | Abort()()() | Obsolete. Aborts this pipeline.
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted.
 | AbortPipeline()()() | Aborts this pipeline.
 | AddMessage(String) | Adds the message.
 | AddMessage(String, PipelineMessageType) | Adds the message.
 | CustomData | Gets the custom data.
 | Data | Obsolete. Gets or sets the data.
 | Dispose()()() | Disposes this instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages.
 | GetMessages(PipelineMessageFilter) | Gets the messages.
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message.
 | ProcessorDone()()() | Called when the processor is done.
 | ProcessorItem | Gets or sets the processor item.
 | Resume()()() | Resumes a processor.
 | Suspend()()() | Suspends this instance.
 | Suspend(Boolean) | Suspends the specified resume last processor.
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | CreateSessionArgs
 |  |  | EvaluateConditionalsArgs
 |  |  | ParseReferrerArgs
 |  |  | RenderingConditionArgs
 |  |  | StartTrackingArgs
 |  |  | SubmitArgs
 |  |  | SubmitPageArgs
 |  |  | SubmitTestsArgs
 |  |  | JobArgs
 |  |  | AttachArgs
 |  |  | ConvertToDesignTimeHtmlArgs
 |  |  | ConvertToRuntimeHtmlArgs
 |  |  | ExpandBranchItemNameArgs
 |  |  | ExpandInitialFieldValueArgs
 |  |  | FixXHtmlArgs
 |  |  | GetAboutInformationArgs
 |  |  | GetContentEditorWarningsArgs
 |  |  | GetLookupSourceItemsArgs
 |  |  | ProcessDefaultSource
 |  |  | GetPlaceholderRenderingsArgs
 |  |  | GetQueryStateArgs
 |  |  | GetRenderingPreviewArgs
 |  |  | HttpRequestArgs
 |  |  | LoggedInArgs
 |  |  | LoggingInArgs
 |  |  | LoginArgs
 |  |  | PreprocessRequestArgs
 |  |  | RenderFieldArgs
 |  |  | RenderItemTileArgs
 |  |  | RenderLayoutArgs
 |  |  | SearchArgs
 |  |  | SessionEndArgs
 |  |  | SetupEditFrameArgs
 |  |  | PublishContext
 |  |  | PublishItemContext
 |  |  | GetMediaStreamPipelineArgs
 |  |  | ClientPipelineArgs
 |  |  | WorkflowPipelineArgs


PipelineArgs Constructor

PipelineArgs Constructor
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► PipelineArgs()()()
Members
Icon | Member | Description
 | PipelineArgs()()() | Initializes a new instance of the PipelineArgs class.
 | PipelineArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the PipelineArgs class from a serialization context.


PipelineArgs Constructor

PipelineArgs Constructor
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► PipelineArgs()()()
Initializes a new instance of the PipelineArgs class.
Declaration Syntax
C#
public PipelineArgs()


PipelineArgs Constructor (info, context)

PipelineArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► PipelineArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the PipelineArgs class from a serialization context.
Declaration Syntax
C#
protected PipelineArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialized data.
context (StreamingContext)
The context.


Abort Method

Abort Method
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► Abort()()()
Aborts this pipeline.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use AbortPipeline instead.")]
public void Abort()


Aborted Property

Aborted Property
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► Aborted
Gets a value indicating whether this PipelineArgs is aborted.
Declaration Syntax
C#
public bool Aborted { get; }
Value
true if aborted; otherwise, false.


AbortPipeline Method

AbortPipeline Method
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► AbortPipeline()()()
Aborts this pipeline.
Declaration Syntax
C#
public void AbortPipeline()


AddMessage Method

AddMessage Method
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► AddMessage()()()
Members
Icon | Member | Description
 | AddMessage(String) | Adds the message.
 | AddMessage(String, PipelineMessageType) | Adds the message.


AddMessage Method (text)

AddMessage Method (text)
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► AddMessage(String)
Adds the message.
Declaration Syntax
C#
public PipelineMessage AddMessage(
    string text
)
Parameters
text (String)
The text.
Return Value
Exceptions
Exception | Condition
NotSupportedException |


AddMessage Method (text, type)

AddMessage Method (text, type)
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► AddMessage(String, PipelineMessageType)
Adds the message.
Declaration Syntax
C#
public PipelineMessage AddMessage(
    string text,
    PipelineMessageType type
)
Parameters
text (String)
The text.
type (PipelineMessageType)
The type.
Return Value
The message.
Exceptions
Exception | Condition
NotSupportedException |


CustomData Property

CustomData Property
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► CustomData
Gets the custom data.
Declaration Syntax
C#
public SafeDictionary<string, Object> CustomData { get; }
Value
The custom data.


Data Property

Data Property
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► Data
Gets or sets the data.
Declaration Syntax
C#
[ObsoleteAttribute("The Data property has been deprecated.")]
public Object Data { get; set; }
Value
The data.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► Dispose()()()
Disposes this instance.
Declaration Syntax
C#
protected internal virtual void Dispose()


GetMessages Method

GetMessages Method
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► GetMessages()()()
Members
Icon | Member | Description
 | GetMessages()()() | Gets the messages.
 | GetMessages(PipelineMessageFilter) | Gets the messages.


GetMessages Method

GetMessages Method
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► GetMessages()()()
Gets the messages.
Declaration Syntax
C#
public PipelineMessage[] GetMessages()
Return Value
The messages.


GetMessages Method (filter)

GetMessages Method (filter)
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► GetMessages(PipelineMessageFilter)
Gets the messages.
Declaration Syntax
C#
public PipelineMessage[] GetMessages(
    PipelineMessageFilter filter
)
Parameters
filter (PipelineMessageFilter)
The filter.
Return Value
Exceptions
Exception | Condition
ArgumentNullException |
InvalidCastException |


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Initialize Method

Initialize Method
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► Initialize()()()
Initializes this instance.
Declaration Syntax
C#
protected internal virtual void Initialize()


Message Property

Message Property
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► Message
Gets the message.
Declaration Syntax
C#
public string Message { get; }
Value
The message.


ProcessorDone Method

ProcessorDone Method
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► ProcessorDone()()()
Called when the processor is done.
Declaration Syntax
C#
protected internal virtual void ProcessorDone()


ProcessorItem Property

ProcessorItem Property
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► ProcessorItem
Gets or sets the processor item.
Declaration Syntax
C#
public ProcessorItem ProcessorItem { get; set; }
Value
The processor item.


Resume Method

Resume Method
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► Resume()()()
Resumes a processor.
Declaration Syntax
C#
protected internal virtual void Resume()


Suspend Method

Suspend Method
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► Suspend()()()
Members
Icon | Member | Description
 | Suspend()()() | Suspends this instance.
 | Suspend(Boolean) | Suspends the specified resume last processor.


Suspend Method

Suspend Method
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► Suspend()()()
Suspends this instance.
Declaration Syntax
C#
public void Suspend()


Suspend Method (resumeLastProcessor)

Suspend Method (resumeLastProcessor)
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► Suspend(Boolean)
Suspends the specified resume last processor.
Declaration Syntax
C#
public void Suspend(
    bool resumeLastProcessor
)
Parameters
resumeLastProcessor (Boolean)
if set to true this instance is resume last processor.


Suspended Property

Suspended Property
Namespaces ► Sitecore.Pipelines ► PipelineArgs ► Suspended
Gets a value indicating whether this PipelineArgs is suspended.
Declaration Syntax
C#
public bool Suspended { get; }
Value
true if suspended; otherwise, false.


PipelineFactory Class

PipelineFactory Class
Namespaces ► Sitecore.Pipelines ► PipelineFactory
Factory for instantiating processors defined in the web.config.
Declaration Syntax
C#
public static class PipelineFactory
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreatePipeline(String) | Creates the pipeline.
 | GetPipeline(String) | Gets the pipeline.
 | GetPipeline(Item) | Gets the pipeline.
 | GetProcessors(String) | Gets the processors of a specific type.
 | GetSuspendedPipeline(String) | Gets the suspended pipeline.
 | GetSuspendedPipelines()()() | Gets the suspended pipelines.
 | UseCaching | Get processors of a specific type
Inheritance Hierarchy
Object
PipelineFactory


CreatePipeline Method (pipelineName)

CreatePipeline Method (pipelineName)
Namespaces ► Sitecore.Pipelines ► PipelineFactory ► CreatePipeline(String)
Creates the pipeline.
Declaration Syntax
C#
public static Pipeline CreatePipeline(
    string pipelineName
)
Parameters
pipelineName (String)
Name of the pipeline.
Return Value
The pipeline.


GetPipeline Method

GetPipeline Method
Namespaces ► Sitecore.Pipelines ► PipelineFactory ► GetPipeline()()()
Members
Icon | Member | Description
 | GetPipeline(String) | Gets the pipeline.
 | GetPipeline(Item) | Gets the pipeline.


GetPipeline Method (ownerItem)

GetPipeline Method (ownerItem)
Namespaces ► Sitecore.Pipelines ► PipelineFactory ► GetPipeline(Item)
Gets the pipeline.
Declaration Syntax
C#
public static Pipeline GetPipeline(
    Item ownerItem
)
Parameters
ownerItem (Item)
The owner item.
Return Value
The pipeline.


GetPipeline Method (pipelineName)

GetPipeline Method (pipelineName)
Namespaces ► Sitecore.Pipelines ► PipelineFactory ► GetPipeline(String)
Gets the pipeline.
Declaration Syntax
C#
public static Pipeline GetPipeline(
    string pipelineName
)
Parameters
pipelineName (String)
Name of the pipeline.
Return Value
The pipeline.


GetProcessors Method (pipelineName)

GetProcessors Method (pipelineName)
Namespaces ► Sitecore.Pipelines ► PipelineFactory ► GetProcessors(String)
Gets the processors of a specific type.
Declaration Syntax
C#
public static ArrayList GetProcessors(
    string pipelineName
)
Parameters
pipelineName (String)
Name of the pipeline.
Return Value
The processors.


GetSuspendedPipeline Method (pipelineID)

GetSuspendedPipeline Method (pipelineID)
Namespaces ► Sitecore.Pipelines ► PipelineFactory ► GetSuspendedPipeline(String)
Gets the suspended pipeline.
Declaration Syntax
C#
public static Pipeline GetSuspendedPipeline(
    string pipelineID
)
Parameters
pipelineID (String)
The pipeline ID.
Return Value
The suspended pipeline.


GetSuspendedPipelines Method

GetSuspendedPipelines Method
Namespaces ► Sitecore.Pipelines ► PipelineFactory ► GetSuspendedPipelines()()()
Gets the suspended pipelines.
Declaration Syntax
C#
public static Hashtable GetSuspendedPipelines()
Return Value
The suspended pipelines.


UseCaching Property

UseCaching Property
Namespaces ► Sitecore.Pipelines ► PipelineFactory ► UseCaching
Get processors of a specific type
Declaration Syntax
C#
public static bool UseCaching { get; set; }
Value
true if the PipelineFactory uses the caching; otherwise, false.


PipelineGroup Class

PipelineGroup Class
Namespaces ► Sitecore.Pipelines ► PipelineGroup
Represents a pipeline group.
Declaration Syntax
C#
public class PipelineGroup
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PipelineGroup(String) | Initializes a new instance of the PipelineGroup class.
 | AddPipeline(CorePipeline) | Adds the pipeline.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPipeline(String) | Gets the pipeline.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PipelineGroup


PipelineGroup Constructor (groupName)

PipelineGroup Constructor (groupName)
Namespaces ► Sitecore.Pipelines ► PipelineGroup ► PipelineGroup(String)
Initializes a new instance of the PipelineGroup class.
Declaration Syntax
C#
public PipelineGroup(
    string groupName
)
Parameters
groupName (String)
Name of the group.


AddPipeline Method (pipeline)

AddPipeline Method (pipeline)
Namespaces ► Sitecore.Pipelines ► PipelineGroup ► AddPipeline(CorePipeline)
Adds the pipeline.
Declaration Syntax
C#
public void AddPipeline(
    CorePipeline pipeline
)
Parameters
pipeline (CorePipeline)
The pipeline.


GetPipeline Method (name)

GetPipeline Method (name)
Namespaces ► Sitecore.Pipelines ► PipelineGroup ► GetPipeline(String)
Gets the pipeline.
Declaration Syntax
C#
public CorePipeline GetPipeline(
    string name
)
Parameters
name (String)
The name.
Return Value
The pipeline.


Name Property

Name Property
Namespaces ► Sitecore.Pipelines ► PipelineGroup ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


PipelineMessage Class

PipelineMessage Class
Namespaces ► Sitecore.Pipelines ► PipelineMessage
Represents a pipeline message.
Declaration Syntax
C#
public class PipelineMessage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PipelineMessage(String, PipelineMessageType) | Initializes a new instance of the PipelineMessage class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsMatch(PipelineMessageFilter) | Determines whether the specified filter is matched.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text | Gets the text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the type.
Inheritance Hierarchy
Object
PipelineMessage


PipelineMessage Constructor (text, type)

PipelineMessage Constructor (text, type)
Namespaces ► Sitecore.Pipelines ► PipelineMessage ► PipelineMessage(String, PipelineMessageType)
Initializes a new instance of the PipelineMessage class.
Declaration Syntax
C#
public PipelineMessage(
    string text,
    PipelineMessageType type
)
Parameters
text (String)
The text.
type (PipelineMessageType)
The type.


IsMatch Method (filter)

IsMatch Method (filter)
Namespaces ► Sitecore.Pipelines ► PipelineMessage ► IsMatch(PipelineMessageFilter)
Determines whether the specified filter is matched.
Declaration Syntax
C#
public bool IsMatch(
    PipelineMessageFilter filter
)
Parameters
filter (PipelineMessageFilter)
The filter.
Return Value
true if the specified filter is matched; otherwise, false.


Text Property

Text Property
Namespaces ► Sitecore.Pipelines ► PipelineMessage ► Text
Gets the text.
Declaration Syntax
C#
public string Text { get; }
Value
The text.


Type Property

Type Property
Namespaces ► Sitecore.Pipelines ► PipelineMessage ► Type
Gets the type.
Declaration Syntax
C#
public PipelineMessageType Type { get; }
Value
The type.


PipelineMessageFilter Enumeration

PipelineMessageFilter Enumeration
Namespaces ► Sitecore.Pipelines ► PipelineMessageFilter
Represents the filter for a pipeline message.
Declaration Syntax
C#
[FlagsAttribute]
public enum PipelineMessageFilter
Members
Member | Description
Informations | Informations.
Warnings | Warnings.
Errors | Errors.
All | All.


PipelineMessageType Enumeration

PipelineMessageType Enumeration
Namespaces ► Sitecore.Pipelines ► PipelineMessageType
Represents the type of a pipeline message.
Declaration Syntax
C#
public enum PipelineMessageType
Members
Member | Description
Information | Information.
Warning | Warning.
Error | Error.


PipelineMethod Class

PipelineMethod Class
Namespaces ► Sitecore.Pipelines ► PipelineMethod
Represents a pipeline method.
Declaration Syntax
C#
public class PipelineMethod
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PipelineMethod(Object, MethodInfo) | Initializes a new instance of the PipelineMethod class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Invoke(array<Object>[]()[]) | Invokes the method with the specified parameters.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PipelineMethod


PipelineMethod Constructor (obj, method)

PipelineMethod Constructor (obj, method)
Namespaces ► Sitecore.Pipelines ► PipelineMethod ► PipelineMethod(Object, MethodInfo)
Initializes a new instance of the PipelineMethod class.
Declaration Syntax
C#
public PipelineMethod(
    Object obj,
    MethodInfo method
)
Parameters
obj (Object)
The object.
method (MethodInfo)
The method.


Invoke Method (parameters)

Invoke Method (parameters)
Namespaces ► Sitecore.Pipelines ► PipelineMethod ► Invoke(array<Object>[]()[])
Invokes the method with the specified parameters.
Declaration Syntax
C#
public void Invoke(
    Object[] parameters
)
Parameters
parameters (array< Object >[]()[])
The parameters.


Processor Class

Processor Class
Namespaces ► Sitecore.Pipelines ► Processor
Represents a single step in a pipeline.
Declaration Syntax
C#
[SerializableAttribute]
public class Processor : ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Processor(String, String, String) | Initializes a new instance of the Processor class.
 | Processor(String, Object, String) | Initializes a new instance of the Processor class.
 | Processor(ProcessorItem) | Initializes a new instance of the Processor class.
 | Processor(String, String) | Initializes a new instance of the Processor class.
 | Processor(SerializationInfo, StreamingContext) | Initializes a new instance of the Processor class from a serialization context.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObject()()() | Gets the object.
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Invoke(PipelineArgs) | Invokes this processor with the specified arguments.
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Parse(XmlNode) | Parses the specified node.
 | Parse(ProcessorItem) | Parses the specified item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Processor


Processor Constructor

Processor Constructor
Namespaces ► Sitecore.Pipelines ► Processor ► Processor()()()
Members
Icon | Member | Description
 | Processor(String, String, String) | Initializes a new instance of the Processor class.
 | Processor(String, Object, String) | Initializes a new instance of the Processor class.
 | Processor(ProcessorItem) | Initializes a new instance of the Processor class.
 | Processor(String, String) | Initializes a new instance of the Processor class.
 | Processor(SerializationInfo, StreamingContext) | Initializes a new instance of the Processor class from a serialization context.


Processor Constructor (item)

Processor Constructor (item)
Namespaces ► Sitecore.Pipelines ► Processor ► Processor(ProcessorItem)
Initializes a new instance of the Processor class.
Declaration Syntax
C#
protected Processor(
    ProcessorItem item
)
Parameters
item (ProcessorItem)
The item.


Processor Constructor (info, context)

Processor Constructor (info, context)
Namespaces ► Sitecore.Pipelines ► Processor ► Processor(SerializationInfo, StreamingContext)
Initializes a new instance of the Processor class from a serialization context.
Declaration Syntax
C#
protected Processor(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialized data.
context (StreamingContext)
The context.


Processor Constructor (name, obj, methodName)

Processor Constructor (name, obj, methodName)
Namespaces ► Sitecore.Pipelines ► Processor ► Processor(String, Object, String)
Initializes a new instance of the Processor class.
Declaration Syntax
C#
public Processor(
    string name,
    Object obj,
    string methodName
)
Parameters
name (String)
The name.
obj (Object)
The object.
methodName (String)
Name of the method.


Processor Constructor (name, methodName)

Processor Constructor (name, methodName)
Namespaces ► Sitecore.Pipelines ► Processor ► Processor(String, String)
Initializes a new instance of the Processor class.
Declaration Syntax
C#
protected Processor(
    string name,
    string methodName
)
Parameters
name (String)
The name.
methodName (String)
Name of the method.


Processor Constructor (name, type, methodName)

Processor Constructor (name, type, methodName)
Namespaces ► Sitecore.Pipelines ► Processor ► Processor(String, String, String)
Initializes a new instance of the Processor class.
Declaration Syntax
C#
public Processor(
    string name,
    string type,
    string methodName
)
Parameters
name (String)
The name.
type (String)
The type.
methodName (String)
Name of the method.


GetObject Method

GetObject Method
Namespaces ► Sitecore.Pipelines ► Processor ► GetObject()()()
Gets the object.
Declaration Syntax
C#
protected virtual Object GetObject()
Return Value
The object upon which the processor is run.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines ► Processor ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Invoke Method (args)

Invoke Method (args)
Namespaces ► Sitecore.Pipelines ► Processor ► Invoke(PipelineArgs)
Invokes this processor with the specified arguments.
Declaration Syntax
C#
public virtual void Invoke(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The arguments.


Item Property

Item Property
Namespaces ► Sitecore.Pipelines ► Processor ► Item
Gets the item.
Declaration Syntax
C#
public virtual ProcessorItem Item { get; }
Value
The item.


Name Property

Name Property
Namespaces ► Sitecore.Pipelines ► Processor ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Parse Method

Parse Method
Namespaces ► Sitecore.Pipelines ► Processor ► Parse()()()
Members
Icon | Member | Description
 | Parse(XmlNode) | Parses the specified node.
 | Parse(ProcessorItem) | Parses the specified item.


Parse Method (item)

Parse Method (item)
Namespaces ► Sitecore.Pipelines ► Processor ► Parse(ProcessorItem)
Parses the specified item.
Declaration Syntax
C#
public static Processor Parse(
    ProcessorItem item
)
Parameters
item (ProcessorItem)
The item.
Return Value


Parse Method (node)

Parse Method (node)
Namespaces ► Sitecore.Pipelines ► Processor ► Parse(XmlNode)
Parses the specified node.
Declaration Syntax
C#
public static Processor Parse(
    XmlNode node
)
Parameters
node (XmlNode)
The node.
Return Value


ProcessorObject Class

ProcessorObject Class
Namespaces ► Sitecore.Pipelines ► ProcessorObject
Represents a processor object.
Declaration Syntax
C#
public class ProcessorObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProcessorObject(Object, ObjectScope) | Initializes a new instance of the ProcessorObject class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Object | Gets the object.
 | Scope | Gets the scope.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProcessorObject


ProcessorObject Constructor (obj, scope)

ProcessorObject Constructor (obj, scope)
Namespaces ► Sitecore.Pipelines ► ProcessorObject ► ProcessorObject(Object, ObjectScope)
Initializes a new instance of the ProcessorObject class.
Declaration Syntax
C#
public ProcessorObject(
    Object obj,
    ObjectScope scope
)
Parameters
obj (Object)
The object.
scope (ObjectScope)
The scope.


Object Property

Object Property
Namespaces ► Sitecore.Pipelines ► ProcessorObject ► Object
Gets the object.
Declaration Syntax
C#
public Object Object { get; }
Value
The object.


Scope Property

Scope Property
Namespaces ► Sitecore.Pipelines ► ProcessorObject ► Scope
Gets the scope.
Declaration Syntax
C#
public ObjectScope Scope { get; }
Value
The scope.


Sitecore.Pipelines.Attach Namespace

Sitecore.Pipelines.Attach Namespace
Namespaces ► Sitecore.Pipelines.Attach
Declaration Syntax
C#
namespace Sitecore.Pipelines.Attach
Types
All Types Classes
Icon | Type | Description
 | AttachArgs | Argument class for "attach" pipeline
 | CheckSize | CheckSize class
 | Save | Processor that is responsable for saving media stream
 | UpdatePath | UpdatePath class


AttachArgs Class

AttachArgs Class
Namespaces ► Sitecore.Pipelines.Attach ► AttachArgs
Argument class for "attach" pipeline
Declaration Syntax
C#
public class AttachArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AttachArgs(HttpPostedFile, MediaItem) | Initializes a new instance of the AttachArgs class.
 | _file |
 | _mediaItem |
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | File | Gets or sets the file.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MediaItem | Gets or sets the media item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | AttachArgs


AttachArgs Constructor (file, mediaItem)

AttachArgs Constructor (file, mediaItem)
Namespaces ► Sitecore.Pipelines.Attach ► AttachArgs ► AttachArgs(HttpPostedFile, MediaItem)
Initializes a new instance of the AttachArgs class.
Declaration Syntax
C#
public AttachArgs(
    HttpPostedFile file,
    MediaItem mediaItem
)
Parameters
file (HttpPostedFile)
The file.
mediaItem (MediaItem)
The media item.


_file Field

_file Field
Namespaces ► Sitecore.Pipelines.Attach ► AttachArgs ► _file
Declaration Syntax
C#
protected HttpPostedFile _file


_mediaItem Field

_mediaItem Field
Namespaces ► Sitecore.Pipelines.Attach ► AttachArgs ► _mediaItem
Declaration Syntax
C#
protected MediaItem _mediaItem


File Property

File Property
Namespaces ► Sitecore.Pipelines.Attach ► AttachArgs ► File
Gets or sets the file.
Declaration Syntax
C#
public virtual HttpPostedFile File { get; set; }
Value
The file.


MediaItem Property

MediaItem Property
Namespaces ► Sitecore.Pipelines.Attach ► AttachArgs ► MediaItem
Gets or sets the media item.
Declaration Syntax
C#
public virtual MediaItem MediaItem { get; set; }
Value
The media item.


CheckSize Class

CheckSize Class
Namespaces ► Sitecore.Pipelines.Attach ► CheckSize
CheckSize class
Declaration Syntax
C#
public class CheckSize
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckSize()()() | Initializes a new instance of the CheckSize class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(AttachArgs) | Processes the specified args.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CheckSize


CheckSize Constructor

CheckSize Constructor
Namespaces ► Sitecore.Pipelines.Attach ► CheckSize ► CheckSize()()()
Initializes a new instance of the CheckSize class
Declaration Syntax
C#
public CheckSize()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Attach ► CheckSize ► Process(AttachArgs)
Processes the specified args.
Declaration Syntax
C#
public void Process(
    AttachArgs args
)
Parameters
args (AttachArgs)
The args.


Save Class

Save Class
Namespaces ► Sitecore.Pipelines.Attach ► Save
Processor that is responsable for saving media stream
Declaration Syntax
C#
public class Save
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Save()()() | Initializes a new instance of the Save class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(AttachArgs) | Processes the specified args.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Save


Save Constructor

Save Constructor
Namespaces ► Sitecore.Pipelines.Attach ► Save ► Save()()()
Initializes a new instance of the Save class
Declaration Syntax
C#
public Save()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Attach ► Save ► Process(AttachArgs)
Processes the specified args.
Declaration Syntax
C#
public void Process(
    AttachArgs args
)
Parameters
args (AttachArgs)
The args.


UpdatePath Class

UpdatePath Class
Namespaces ► Sitecore.Pipelines.Attach ► UpdatePath
UpdatePath class
Declaration Syntax
C#
public class UpdatePath
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UpdatePath()()() | Initializes a new instance of the UpdatePath class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(AttachArgs) | Processes the specified args.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UpdatePath


UpdatePath Constructor

UpdatePath Constructor
Namespaces ► Sitecore.Pipelines.Attach ► UpdatePath ► UpdatePath()()()
Initializes a new instance of the UpdatePath class
Declaration Syntax
C#
public UpdatePath()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Attach ► UpdatePath ► Process(AttachArgs)
Processes the specified args.
Declaration Syntax
C#
public void Process(
    AttachArgs args
)
Parameters
args (AttachArgs)
The args.


Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace

Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml
Declaration Syntax
C#
namespace Sitecore.Pipelines.ConvertToDesignTimeHtml
Types
All Types Classes
Icon | Type | Description
 | ConvertToDesignTimeHtmlArgs | Implements the RenderField.
 | ConvertWebControls | Implements the ConvertWebControls.
 | FinalizeHtml | Implements the ShortenLinks.
 | FixBullets | Implements the FixBullets processor.
 | PrepareHtml | Implements the ShortenLinks.


ConvertToDesignTimeHtmlArgs Class

ConvertToDesignTimeHtmlArgs Class
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► ConvertToDesignTimeHtmlArgs
Implements the RenderField.
Declaration Syntax
C#
[SerializableAttribute]
public class ConvertToDesignTimeHtmlArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConvertToDesignTimeHtmlArgs()()() | Initializes a new instance of the ConvertToDesignTimeHtmlArgs class.
 | ConvertToDesignTimeHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ConvertToDesignTimeHtmlArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | ControlName | Gets or sets the name of the control.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeProcessing()()() | Finalizes the processing.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Html | Gets or sets the HTML.
 | HtmlDocument | Gets the HTML document.
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | InlineControls | Gets or sets a value indicating whether the pipeline generates inline controls.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | QueryString | Gets or sets the query string.
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ConvertToDesignTimeHtmlArgs


ConvertToDesignTimeHtmlArgs Constructor

ConvertToDesignTimeHtmlArgs Constructor
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► ConvertToDesignTimeHtmlArgs ► ConvertToDesignTimeHtmlArgs()()()
Members
Icon | Member | Description
 | ConvertToDesignTimeHtmlArgs()()() | Initializes a new instance of the ConvertToDesignTimeHtmlArgs class.
 | ConvertToDesignTimeHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ConvertToDesignTimeHtmlArgs class.


ConvertToDesignTimeHtmlArgs Constructor

ConvertToDesignTimeHtmlArgs Constructor
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► ConvertToDesignTimeHtmlArgs ► ConvertToDesignTimeHtmlArgs()()()
Initializes a new instance of the ConvertToDesignTimeHtmlArgs class.
Declaration Syntax
C#
public ConvertToDesignTimeHtmlArgs()


ConvertToDesignTimeHtmlArgs Constructor (info, context)

ConvertToDesignTimeHtmlArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► ConvertToDesignTimeHtmlArgs ► ConvertToDesignTimeHtmlArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the ConvertToDesignTimeHtmlArgs class.
Declaration Syntax
C#
protected ConvertToDesignTimeHtmlArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


ControlName Property

ControlName Property
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► ConvertToDesignTimeHtmlArgs ► ControlName
Gets or sets the name of the control.
Declaration Syntax
C#
public string ControlName { get; set; }
Value
The name of the control.


FinalizeProcessing Method

FinalizeProcessing Method
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► ConvertToDesignTimeHtmlArgs ► FinalizeProcessing()()()
Finalizes the processing.
Declaration Syntax
C#
public void FinalizeProcessing()
Return Value
The processing.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► ConvertToDesignTimeHtmlArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Html Property

Html Property
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► ConvertToDesignTimeHtmlArgs ► Html
Gets or sets the HTML.
Declaration Syntax
C#
public string Html { get; set; }
Value
The HTML.


HtmlDocument Property

HtmlDocument Property
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► ConvertToDesignTimeHtmlArgs ► HtmlDocument
Gets the HTML document.
Declaration Syntax
C#
public HtmlDocument HtmlDocument { get; }
Value
The HTML document.


InlineControls Property

InlineControls Property
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► ConvertToDesignTimeHtmlArgs ► InlineControls
Gets or sets a value indicating whether the pipeline generates inline controls.
Declaration Syntax
C#
public bool InlineControls { get; set; }
Value
true if the pipeline generates inline controls; otherwise, false.


QueryString Property

QueryString Property
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► ConvertToDesignTimeHtmlArgs ► QueryString
Gets or sets the query string.
Declaration Syntax
C#
public NameValueCollection QueryString { get; set; }
Value
The query string.


ConvertWebControls Class

ConvertWebControls Class
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► ConvertWebControls
Implements the ConvertWebControls.
Declaration Syntax
C#
public class ConvertWebControls
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConvertWebControls()()() | Initializes a new instance of the ConvertWebControls class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ConvertToDesignTimeHtmlArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConvertWebControls


ConvertWebControls Constructor

ConvertWebControls Constructor
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► ConvertWebControls ► ConvertWebControls()()()
Initializes a new instance of the ConvertWebControls class
Declaration Syntax
C#
public ConvertWebControls()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► ConvertWebControls ► Process(ConvertToDesignTimeHtmlArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    ConvertToDesignTimeHtmlArgs args
)
Parameters
args (ConvertToDesignTimeHtmlArgs)
The arguments.


FinalizeHtml Class

FinalizeHtml Class
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► FinalizeHtml
Implements the ShortenLinks.
Declaration Syntax
C#
public class FinalizeHtml
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FinalizeHtml()()() | Initializes a new instance of the FinalizeHtml class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ConvertToDesignTimeHtmlArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FinalizeHtml


FinalizeHtml Constructor

FinalizeHtml Constructor
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► FinalizeHtml ► FinalizeHtml()()()
Initializes a new instance of the FinalizeHtml class
Declaration Syntax
C#
public FinalizeHtml()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► FinalizeHtml ► Process(ConvertToDesignTimeHtmlArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    ConvertToDesignTimeHtmlArgs args
)
Parameters
args (ConvertToDesignTimeHtmlArgs)
The arguments.


FixBullets Class

FixBullets Class
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► FixBullets
Implements the FixBullets processor.
Declaration Syntax
C#
public class FixBullets
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FixBullets()()() | Initializes a new instance of the FixBullets class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ConvertToDesignTimeHtmlArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FixBullets


FixBullets Constructor

FixBullets Constructor
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► FixBullets ► FixBullets()()()
Initializes a new instance of the FixBullets class
Declaration Syntax
C#
public FixBullets()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► FixBullets ► Process(ConvertToDesignTimeHtmlArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    ConvertToDesignTimeHtmlArgs args
)
Parameters
args (ConvertToDesignTimeHtmlArgs)
The arguments.


PrepareHtml Class

PrepareHtml Class
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► PrepareHtml
Implements the ShortenLinks.
Declaration Syntax
C#
public class PrepareHtml
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PrepareHtml()()() | Initializes a new instance of the PrepareHtml class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ConvertToDesignTimeHtmlArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PrepareHtml


PrepareHtml Constructor

PrepareHtml Constructor
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► PrepareHtml ► PrepareHtml()()()
Initializes a new instance of the PrepareHtml class
Declaration Syntax
C#
public PrepareHtml()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ConvertToDesignTimeHtml ► PrepareHtml ► Process(ConvertToDesignTimeHtmlArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    ConvertToDesignTimeHtmlArgs args
)
Parameters
args (ConvertToDesignTimeHtmlArgs)
The arguments.


Sitecore.Pipelines.ConvertToRuntimeHtml Namespace

Sitecore.Pipelines.ConvertToRuntimeHtml Namespace
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml
Declaration Syntax
C#
namespace Sitecore.Pipelines.ConvertToRuntimeHtml
Types
All Types Classes
Icon | Type | Description
 | ConvertToRuntimeHtmlArgs | Implements the convert to runtime Html arguments.
 | ConvertWebControls | Implements the ShortenLinks.
 | FinalizeHtml | Implements the ShortenLinks.
 | FixBullets | Implements the ShortenLinks.
 | PrepareHtml | Implements the ShortenLinks.
 | SetImageSizes | Implements the ShortenLinks.
 | ShortenLinks | Implements the ShortenLinks.


ConvertToRuntimeHtmlArgs Class

ConvertToRuntimeHtmlArgs Class
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ConvertToRuntimeHtmlArgs
Implements the convert to runtime Html arguments.
Declaration Syntax
C#
[SerializableAttribute]
public class ConvertToRuntimeHtmlArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConvertToRuntimeHtmlArgs()()() | Initializes a new instance of the ConvertToRuntimeHtmlArgs class.
 | ConvertToRuntimeHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ConvertToRuntimeHtmlArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | ConvertWebControls | Gets or sets a value indicating whether the pipeline converts the web controls.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinalizeProcessing()()() | Finalizes the processing.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Html | Gets or sets the HTML.
 | HtmlDocument | Gets the HTML document.
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ConvertToRuntimeHtmlArgs


ConvertToRuntimeHtmlArgs Constructor

ConvertToRuntimeHtmlArgs Constructor
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ConvertToRuntimeHtmlArgs ► ConvertToRuntimeHtmlArgs()()()
Members
Icon | Member | Description
 | ConvertToRuntimeHtmlArgs()()() | Initializes a new instance of the ConvertToRuntimeHtmlArgs class.
 | ConvertToRuntimeHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ConvertToRuntimeHtmlArgs class.


ConvertToRuntimeHtmlArgs Constructor

ConvertToRuntimeHtmlArgs Constructor
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ConvertToRuntimeHtmlArgs ► ConvertToRuntimeHtmlArgs()()()
Initializes a new instance of the ConvertToRuntimeHtmlArgs class.
Declaration Syntax
C#
public ConvertToRuntimeHtmlArgs()


ConvertToRuntimeHtmlArgs Constructor (info, context)

ConvertToRuntimeHtmlArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ConvertToRuntimeHtmlArgs ► ConvertToRuntimeHtmlArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the ConvertToRuntimeHtmlArgs class.
Declaration Syntax
C#
protected ConvertToRuntimeHtmlArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


ConvertWebControls Property

ConvertWebControls Property
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ConvertToRuntimeHtmlArgs ► ConvertWebControls
Gets or sets a value indicating whether the pipeline converts the web controls.
Declaration Syntax
C#
public bool ConvertWebControls { get; set; }
Value
true if the pipeline converts the web controls; otherwise, false.


FinalizeProcessing Method

FinalizeProcessing Method
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ConvertToRuntimeHtmlArgs ► FinalizeProcessing()()()
Finalizes the processing.
Declaration Syntax
C#
public void FinalizeProcessing()
Return Value
The processing.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ConvertToRuntimeHtmlArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Html Property

Html Property
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ConvertToRuntimeHtmlArgs ► Html
Gets or sets the HTML.
Declaration Syntax
C#
public string Html { get; set; }
Value
The HTML.


HtmlDocument Property

HtmlDocument Property
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ConvertToRuntimeHtmlArgs ► HtmlDocument
Gets the HTML document.
Declaration Syntax
C#
public HtmlDocument HtmlDocument { get; }
Value
The HTML document.


ConvertWebControls Class

ConvertWebControls Class
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ConvertWebControls
Implements the ShortenLinks.
Declaration Syntax
C#
public class ConvertWebControls
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConvertWebControls()()() | Initializes a new instance of the ConvertWebControls class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ConvertToRuntimeHtmlArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConvertWebControls


ConvertWebControls Constructor

ConvertWebControls Constructor
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ConvertWebControls ► ConvertWebControls()()()
Initializes a new instance of the ConvertWebControls class
Declaration Syntax
C#
public ConvertWebControls()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ConvertWebControls ► Process(ConvertToRuntimeHtmlArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    ConvertToRuntimeHtmlArgs args
)
Parameters
args (ConvertToRuntimeHtmlArgs)
The arguments.


FinalizeHtml Class

FinalizeHtml Class
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► FinalizeHtml
Implements the ShortenLinks.
Declaration Syntax
C#
public class FinalizeHtml
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FinalizeHtml()()() | Initializes a new instance of the FinalizeHtml class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ConvertToRuntimeHtmlArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FinalizeHtml


FinalizeHtml Constructor

FinalizeHtml Constructor
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► FinalizeHtml ► FinalizeHtml()()()
Initializes a new instance of the FinalizeHtml class
Declaration Syntax
C#
public FinalizeHtml()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► FinalizeHtml ► Process(ConvertToRuntimeHtmlArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    ConvertToRuntimeHtmlArgs args
)
Parameters
args (ConvertToRuntimeHtmlArgs)
The arguments.


FixBullets Class

FixBullets Class
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► FixBullets
Implements the ShortenLinks.
Declaration Syntax
C#
public class FixBullets
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FixBullets()()() | Initializes a new instance of the FixBullets class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ConvertToRuntimeHtmlArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FixBullets


FixBullets Constructor

FixBullets Constructor
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► FixBullets ► FixBullets()()()
Initializes a new instance of the FixBullets class
Declaration Syntax
C#
public FixBullets()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► FixBullets ► Process(ConvertToRuntimeHtmlArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    ConvertToRuntimeHtmlArgs args
)
Parameters
args (ConvertToRuntimeHtmlArgs)
The arguments.


PrepareHtml Class

PrepareHtml Class
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► PrepareHtml
Implements the ShortenLinks.
Declaration Syntax
C#
public class PrepareHtml
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PrepareHtml()()() | Initializes a new instance of the PrepareHtml class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ConvertToRuntimeHtmlArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PrepareHtml


PrepareHtml Constructor

PrepareHtml Constructor
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► PrepareHtml ► PrepareHtml()()()
Initializes a new instance of the PrepareHtml class
Declaration Syntax
C#
public PrepareHtml()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► PrepareHtml ► Process(ConvertToRuntimeHtmlArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    ConvertToRuntimeHtmlArgs args
)
Parameters
args (ConvertToRuntimeHtmlArgs)
The arguments.


SetImageSizes Class

SetImageSizes Class
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► SetImageSizes
Implements the ShortenLinks.
Declaration Syntax
C#
public class SetImageSizes
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SetImageSizes()()() | Initializes a new instance of the SetImageSizes class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ConvertToRuntimeHtmlArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SetImageSizes


SetImageSizes Constructor

SetImageSizes Constructor
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► SetImageSizes ► SetImageSizes()()()
Initializes a new instance of the SetImageSizes class
Declaration Syntax
C#
public SetImageSizes()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► SetImageSizes ► Process(ConvertToRuntimeHtmlArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    ConvertToRuntimeHtmlArgs args
)
Parameters
args (ConvertToRuntimeHtmlArgs)
The arguments.


ShortenLinks Class

ShortenLinks Class
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ShortenLinks
Implements the ShortenLinks.
Declaration Syntax
C#
public class ShortenLinks
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ShortenLinks()()() | Initializes a new instance of the ShortenLinks class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ConvertToRuntimeHtmlArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ShortenLinks


ShortenLinks Constructor

ShortenLinks Constructor
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ShortenLinks ► ShortenLinks()()()
Initializes a new instance of the ShortenLinks class
Declaration Syntax
C#
public ShortenLinks()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ConvertToRuntimeHtml ► ShortenLinks ► Process(ConvertToRuntimeHtmlArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    ConvertToRuntimeHtmlArgs args
)
Parameters
args (ConvertToRuntimeHtmlArgs)
The arguments.


Sitecore.Pipelines.Dispatch Namespace

Sitecore.Pipelines.Dispatch Namespace
Namespaces ► Sitecore.Pipelines.Dispatch
Declaration Syntax
C#
namespace Sitecore.Pipelines.Dispatch
Types
All Types Classes
Icon | Type | Description
 | DispatchArgs | Argument class for Dispatch implementations.


DispatchArgs Class

DispatchArgs Class
Namespaces ► Sitecore.Pipelines.Dispatch ► DispatchArgs
Argument class for Dispatch implementations.
Declaration Syntax
C#
[SerializableAttribute]
public class DispatchArgs : ClientPipelineArgs,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DispatchArgs(Message) | Initializes a new instance of the DispatchArgs class.
 | DispatchArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the DispatchArgs class from a serialization context.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CancelBubble | Gets or sets a value indicating whether the DispatchArgs cancels the bubble.
 | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | InnerMessage | Gets the inner message.
 | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
 | Item[([(String])]) | Gets the String with the specified key.
 | Items | Gets or sets the items.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Name | Gets the name.
 | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
 | ProcessorDone()()() | A processor is done. (Overrides ClientPipelineArgs.ProcessorDone()()().)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
 | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitForPostBack()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ClientPipelineArgs
 |  |  |  | DispatchArgs


DispatchArgs Constructor

DispatchArgs Constructor
Namespaces ► Sitecore.Pipelines.Dispatch ► DispatchArgs ► DispatchArgs()()()
Members
Icon | Member | Description
 | DispatchArgs(Message) | Initializes a new instance of the DispatchArgs class.
 | DispatchArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the DispatchArgs class from a serialization context.


DispatchArgs Constructor (message)

DispatchArgs Constructor (message)
Namespaces ► Sitecore.Pipelines.Dispatch ► DispatchArgs ► DispatchArgs(Message)
Initializes a new instance of the DispatchArgs class.
Declaration Syntax
C#
public DispatchArgs(
    Message message
)
Parameters
message (Message)
The message.


DispatchArgs Constructor (info, context)

DispatchArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.Dispatch ► DispatchArgs ► DispatchArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the DispatchArgs class from a serialization context.
Declaration Syntax
C#
protected DispatchArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialized data.
context (StreamingContext)
The context.


CancelBubble Property

CancelBubble Property
Namespaces ► Sitecore.Pipelines.Dispatch ► DispatchArgs ► CancelBubble
Gets or sets a value indicating whether the DispatchArgs cancels the bubble.
Declaration Syntax
C#
public bool CancelBubble { get; set; }
Value
true if the DispatchArgs cancels the bubble; otherwise, false.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.Dispatch ► DispatchArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


InnerMessage Property

InnerMessage Property
Namespaces ► Sitecore.Pipelines.Dispatch ► DispatchArgs ► InnerMessage
Gets the inner message.
Declaration Syntax
C#
public Message InnerMessage { get; }
Value
The inner message.


Item Property (key)

Item Property (key)
Namespaces ► Sitecore.Pipelines.Dispatch ► DispatchArgs ► Item[([(String])])
Gets the String with the specified key.
Declaration Syntax
C#
public string this[
    string key
] { get; }
Parameters
key (String)
Value
The String.


Items Property

Items Property
Namespaces ► Sitecore.Pipelines.Dispatch ► DispatchArgs ► Items
Gets or sets the items.
Declaration Syntax
C#
public Item[] Items { get; set; }
Value
The items.


Name Property

Name Property
Namespaces ► Sitecore.Pipelines.Dispatch ► DispatchArgs ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


ProcessorDone Method

ProcessorDone Method
Namespaces ► Sitecore.Pipelines.Dispatch ► DispatchArgs ► ProcessorDone()()()
A processor is done.
Declaration Syntax
C#
protected internal override void ProcessorDone()


Sitecore.Pipelines.ExpandBranchItemName Namespace

Sitecore.Pipelines.ExpandBranchItemName Namespace
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName
Declaration Syntax
C#
namespace Sitecore.Pipelines.ExpandBranchItemName
Types
All Types Classes
Icon | Type | Description
 | ExpandBranchItemNameArgs | ExpandBranchItemNameArgs
 | ExpandBranchItemNameProcessor | ExpandBranchItemNameProcessor class
 | ReplaceVariables | ReplaceVariables


ExpandBranchItemNameArgs Class

ExpandBranchItemNameArgs Class
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ExpandBranchItemNameArgs
ExpandBranchItemNameArgs
Declaration Syntax
C#
[SerializableAttribute]
public class ExpandBranchItemNameArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExpandBranchItemNameArgs(Item, String) | Initializes a new instance of the ExpandBranchItemNameArgs class.
 | ExpandBranchItemNameArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ExpandBranchItemNameArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | BranchTemplateItem | Gets the item.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Result | Gets or sets the result.
 | ResultModified | Gets a value indicating whether [result modified].
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | RootItemName | Gets the name of the item.
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ExpandBranchItemNameArgs


ExpandBranchItemNameArgs Constructor

ExpandBranchItemNameArgs Constructor
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ExpandBranchItemNameArgs ► ExpandBranchItemNameArgs()()()
Members
Icon | Member | Description
 | ExpandBranchItemNameArgs(Item, String) | Initializes a new instance of the ExpandBranchItemNameArgs class.
 | ExpandBranchItemNameArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ExpandBranchItemNameArgs class.


ExpandBranchItemNameArgs Constructor (branchTemplateItem, rootItemName)

ExpandBranchItemNameArgs Constructor (branchTemplateItem, rootItemName)
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ExpandBranchItemNameArgs ► ExpandBranchItemNameArgs(Item, String)
Initializes a new instance of the ExpandBranchItemNameArgs class.
Declaration Syntax
C#
public ExpandBranchItemNameArgs(
    Item branchTemplateItem,
    string rootItemName
)
Parameters
branchTemplateItem (Item)
The branch template item.
rootItemName (String)
Name of the root item.


ExpandBranchItemNameArgs Constructor (info, context)

ExpandBranchItemNameArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ExpandBranchItemNameArgs ► ExpandBranchItemNameArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the ExpandBranchItemNameArgs class.
Declaration Syntax
C#
protected ExpandBranchItemNameArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


BranchTemplateItem Property

BranchTemplateItem Property
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ExpandBranchItemNameArgs ► BranchTemplateItem
Gets the item.
Declaration Syntax
C#
public Item BranchTemplateItem { get; }
Value
The item.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ExpandBranchItemNameArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Result Property

Result Property
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ExpandBranchItemNameArgs ► Result
Gets or sets the result.
Declaration Syntax
C#
public string Result { get; set; }
Value
The result.


ResultModified Property

ResultModified Property
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ExpandBranchItemNameArgs ► ResultModified
Gets a value indicating whether [result modified].
Declaration Syntax
C#
public bool ResultModified { get; }
Value
true if [result modified]; otherwise, false.


RootItemName Property

RootItemName Property
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ExpandBranchItemNameArgs ► RootItemName
Gets the name of the item.
Declaration Syntax
C#
public string RootItemName { get; }
Value
The name of the item.


ExpandBranchItemNameProcessor Class

ExpandBranchItemNameProcessor Class
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ExpandBranchItemNameProcessor
ExpandBranchItemNameProcessor class
Declaration Syntax
C#
public abstract class ExpandBranchItemNameProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExpandBranchItemNameProcessor()()() | Initializes a new instance of the ExpandBranchItemNameProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ExpandBranchItemNameArgs) | Processes the specified args.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ExpandBranchItemNameProcessor
 |  | ReplaceVariables


ExpandBranchItemNameProcessor Constructor

ExpandBranchItemNameProcessor Constructor
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ExpandBranchItemNameProcessor ► ExpandBranchItemNameProcessor()()()
Initializes a new instance of the ExpandBranchItemNameProcessor class
Declaration Syntax
C#
protected ExpandBranchItemNameProcessor()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ExpandBranchItemNameProcessor ► Process(ExpandBranchItemNameArgs)
Processes the specified args.
Declaration Syntax
C#
public abstract void Process(
    ExpandBranchItemNameArgs args
)
Parameters
args (ExpandBranchItemNameArgs)
The args.


ReplaceVariables Class

ReplaceVariables Class
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ReplaceVariables
ReplaceVariables
Declaration Syntax
C#
public class ReplaceVariables : ExpandBranchItemNameProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ReplaceVariables()()() | Initializes a new instance of the ReplaceVariables class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ExpandBranchItemNameArgs) | Processes the specified args. (Overrides ExpandBranchItemNameProcessor.Process(ExpandBranchItemNameArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ExpandBranchItemNameProcessor
 |  | ReplaceVariables


ReplaceVariables Constructor

ReplaceVariables Constructor
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ReplaceVariables ► ReplaceVariables()()()
Initializes a new instance of the ReplaceVariables class
Declaration Syntax
C#
public ReplaceVariables()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ExpandBranchItemName ► ReplaceVariables ► Process(ExpandBranchItemNameArgs)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    ExpandBranchItemNameArgs args
)
Parameters
args (ExpandBranchItemNameArgs)
The args.


Sitecore.Pipelines.ExpandInitialFieldValue Namespace

Sitecore.Pipelines.ExpandInitialFieldValue Namespace
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue
Declaration Syntax
C#
namespace Sitecore.Pipelines.ExpandInitialFieldValue
Types
All Types Classes
Icon | Type | Description
 | ExpandInitialFieldValueArgs | InitializeFieldValuesArgs
 | ExpandInitialFieldValueProcessor | ExpandInitialFieldValueProcessor class
 | ReplaceVariables | ReplaceVariables
 | SkipStandardValueItems | SkipStandardValueItems class


ExpandInitialFieldValueArgs Class

ExpandInitialFieldValueArgs Class
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ExpandInitialFieldValueArgs
InitializeFieldValuesArgs
Declaration Syntax
C#
[SerializableAttribute]
public class ExpandInitialFieldValueArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExpandInitialFieldValueArgs(Field, Item) | Initializes a new instance of the ExpandInitialFieldValueArgs class.
 | ExpandInitialFieldValueArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ExpandInitialFieldValueArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Result | Gets or sets the result.
 | ResultModified | Gets a value indicating whether [result modified].
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | SourceField | Gets the source field.
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | TargetItem | Gets the target item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ExpandInitialFieldValueArgs


ExpandInitialFieldValueArgs Constructor

ExpandInitialFieldValueArgs Constructor
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ExpandInitialFieldValueArgs ► ExpandInitialFieldValueArgs()()()
Members
Icon | Member | Description
 | ExpandInitialFieldValueArgs(Field, Item) | Initializes a new instance of the ExpandInitialFieldValueArgs class.
 | ExpandInitialFieldValueArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ExpandInitialFieldValueArgs class.


ExpandInitialFieldValueArgs Constructor (sourceField, targetItem)

ExpandInitialFieldValueArgs Constructor (sourceField, targetItem)
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ExpandInitialFieldValueArgs ► ExpandInitialFieldValueArgs(Field, Item)
Initializes a new instance of the ExpandInitialFieldValueArgs class.
Declaration Syntax
C#
public ExpandInitialFieldValueArgs(
    Field sourceField,
    Item targetItem
)
Parameters
sourceField (Field)
The source field.
targetItem (Item)
The target item.


ExpandInitialFieldValueArgs Constructor (info, context)

ExpandInitialFieldValueArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ExpandInitialFieldValueArgs ► ExpandInitialFieldValueArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the ExpandInitialFieldValueArgs class.
Declaration Syntax
C#
protected ExpandInitialFieldValueArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ExpandInitialFieldValueArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Result Property

Result Property
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ExpandInitialFieldValueArgs ► Result
Gets or sets the result.
Declaration Syntax
C#
public string Result { get; set; }
Value
The result.


ResultModified Property

ResultModified Property
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ExpandInitialFieldValueArgs ► ResultModified
Gets a value indicating whether [result modified].
Declaration Syntax
C#
public bool ResultModified { get; }
Value
true if [result modified]; otherwise, false.


SourceField Property

SourceField Property
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ExpandInitialFieldValueArgs ► SourceField
Gets the source field.
Declaration Syntax
C#
public Field SourceField { get; }
Value
The source field.


TargetItem Property

TargetItem Property
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ExpandInitialFieldValueArgs ► TargetItem
Gets the target item.
Declaration Syntax
C#
public Item TargetItem { get; }
Value
The target item.


ExpandInitialFieldValueProcessor Class

ExpandInitialFieldValueProcessor Class
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ExpandInitialFieldValueProcessor
ExpandInitialFieldValueProcessor class
Declaration Syntax
C#
public abstract class ExpandInitialFieldValueProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExpandInitialFieldValueProcessor()()() | Initializes a new instance of the ExpandInitialFieldValueProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ExpandInitialFieldValueArgs) | Processes the specified args.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ExpandInitialFieldValueProcessor
 |  | ReplaceVariables
 |  | SkipStandardValueItems


ExpandInitialFieldValueProcessor Constructor

ExpandInitialFieldValueProcessor Constructor
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ExpandInitialFieldValueProcessor ► ExpandInitialFieldValueProcessor()()()
Initializes a new instance of the ExpandInitialFieldValueProcessor class
Declaration Syntax
C#
protected ExpandInitialFieldValueProcessor()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ExpandInitialFieldValueProcessor ► Process(ExpandInitialFieldValueArgs)
Processes the specified args.
Declaration Syntax
C#
public abstract void Process(
    ExpandInitialFieldValueArgs args
)
Parameters
args (ExpandInitialFieldValueArgs)
The args.


ReplaceVariables Class

ReplaceVariables Class
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ReplaceVariables
ReplaceVariables
Declaration Syntax
C#
public class ReplaceVariables : ExpandInitialFieldValueProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ReplaceVariables()()() | Initializes a new instance of the ReplaceVariables class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ExpandInitialFieldValueArgs) | Processes the specified args. (Overrides ExpandInitialFieldValueProcessor.Process(ExpandInitialFieldValueArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ExpandInitialFieldValueProcessor
 |  | ReplaceVariables


ReplaceVariables Constructor

ReplaceVariables Constructor
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ReplaceVariables ► ReplaceVariables()()()
Initializes a new instance of the ReplaceVariables class
Declaration Syntax
C#
public ReplaceVariables()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► ReplaceVariables ► Process(ExpandInitialFieldValueArgs)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    ExpandInitialFieldValueArgs args
)
Parameters
args (ExpandInitialFieldValueArgs)
The args.


SkipStandardValueItems Class

SkipStandardValueItems Class
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► SkipStandardValueItems
SkipStandardValueItems class
Declaration Syntax
C#
public class SkipStandardValueItems : ExpandInitialFieldValueProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SkipStandardValueItems()()() | Initializes a new instance of the SkipStandardValueItems class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ExpandInitialFieldValueArgs) | Processes the specified args. (Overrides ExpandInitialFieldValueProcessor.Process(ExpandInitialFieldValueArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ExpandInitialFieldValueProcessor
 |  | SkipStandardValueItems


SkipStandardValueItems Constructor

SkipStandardValueItems Constructor
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► SkipStandardValueItems ► SkipStandardValueItems()()()
Initializes a new instance of the SkipStandardValueItems class
Declaration Syntax
C#
public SkipStandardValueItems()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.ExpandInitialFieldValue ► SkipStandardValueItems ► Process(ExpandInitialFieldValueArgs)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    ExpandInitialFieldValueArgs args
)
Parameters
args (ExpandInitialFieldValueArgs)
The args.


Sitecore.Pipelines.FixXHtml Namespace

Sitecore.Pipelines.FixXHtml Namespace
Namespaces ► Sitecore.Pipelines.FixXHtml
Declaration Syntax
C#
namespace Sitecore.Pipelines.FixXHtml
Types
All Types Classes
Icon | Type | Description
 | CheckSchema | Implements the ShortenLinks.
 | ConvertToXHtml |
 | FixXHtmlArgs | Implements the RenderField.
 | FixXHtmlProcessor | Implements the RenderField.
 | PrepareHtml | Implements the ShortenLinks.
 | RemoveEmptySpans | Implements the ShortenLinks.


CheckSchema Class

CheckSchema Class
Namespaces ► Sitecore.Pipelines.FixXHtml ► CheckSchema
Implements the ShortenLinks.
Declaration Syntax
C#
public class CheckSchema : FixXHtmlProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckSchema()()() | Initializes a new instance of the CheckSchema class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(FixXHtmlArgs) | Runs the processor. (Overrides FixXHtmlProcessor.Process(FixXHtmlArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FixXHtmlProcessor
 |  | CheckSchema


CheckSchema Constructor

CheckSchema Constructor
Namespaces ► Sitecore.Pipelines.FixXHtml ► CheckSchema ► CheckSchema()()()
Initializes a new instance of the CheckSchema class
Declaration Syntax
C#
public CheckSchema()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.FixXHtml ► CheckSchema ► Process(FixXHtmlArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    FixXHtmlArgs args
)
Parameters
args (FixXHtmlArgs)
The arguments.


ConvertToXHtml Class

ConvertToXHtml Class
Namespaces ► Sitecore.Pipelines.FixXHtml ► ConvertToXHtml
Declaration Syntax
C#
public class ConvertToXHtml : FixXHtmlProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConvertToXHtml()()() | Initializes a new instance of the ConvertToXHtml class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(FixXHtmlArgs) | Runs the processor. (Overrides FixXHtmlProcessor.Process(FixXHtmlArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FixXHtmlProcessor
 |  | ConvertToXHtml


ConvertToXHtml Constructor

ConvertToXHtml Constructor
Namespaces ► Sitecore.Pipelines.FixXHtml ► ConvertToXHtml ► ConvertToXHtml()()()
Initializes a new instance of the ConvertToXHtml class
Declaration Syntax
C#
public ConvertToXHtml()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.FixXHtml ► ConvertToXHtml ► Process(FixXHtmlArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    FixXHtmlArgs args
)
Parameters
args (FixXHtmlArgs)
The arguments.


FixXHtmlArgs Class

FixXHtmlArgs Class
Namespaces ► Sitecore.Pipelines.FixXHtml ► FixXHtmlArgs
Implements the RenderField.
Declaration Syntax
C#
[SerializableAttribute]
public class FixXHtmlArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FixXHtmlArgs(String) | Initializes a new instance of the RenderItemTileArgs class.
 | FixXHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the FixXHtmlArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Html | Gets or sets the HTML.
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | FixXHtmlArgs


FixXHtmlArgs Constructor

FixXHtmlArgs Constructor
Namespaces ► Sitecore.Pipelines.FixXHtml ► FixXHtmlArgs ► FixXHtmlArgs()()()
Members
Icon | Member | Description
 | FixXHtmlArgs(String) | Initializes a new instance of the RenderItemTileArgs class.
 | FixXHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the FixXHtmlArgs class.


FixXHtmlArgs Constructor (info, context)

FixXHtmlArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.FixXHtml ► FixXHtmlArgs ► FixXHtmlArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the FixXHtmlArgs class.
Declaration Syntax
C#
protected FixXHtmlArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


FixXHtmlArgs Constructor (html)

FixXHtmlArgs Constructor (html)
Namespaces ► Sitecore.Pipelines.FixXHtml ► FixXHtmlArgs ► FixXHtmlArgs(String)
Initializes a new instance of the RenderItemTileArgs class.
Declaration Syntax
C#
public FixXHtmlArgs(
    string html
)
Parameters
html (String)
The HTML.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.FixXHtml ► FixXHtmlArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Html Property

Html Property
Namespaces ► Sitecore.Pipelines.FixXHtml ► FixXHtmlArgs ► Html
Gets or sets the HTML.
Declaration Syntax
C#
public string Html { get; set; }
Value
The HTML.


FixXHtmlProcessor Class

FixXHtmlProcessor Class
Namespaces ► Sitecore.Pipelines.FixXHtml ► FixXHtmlProcessor
Implements the RenderField.
Declaration Syntax
C#
public abstract class FixXHtmlProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FixXHtmlProcessor()()() | Initializes a new instance of the FixXHtmlProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(FixXHtmlArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FixXHtmlProcessor
 |  | CheckSchema
 |  | ConvertToXHtml
 |  | PrepareHtml
 |  | RemoveEmptySpans


FixXHtmlProcessor Constructor

FixXHtmlProcessor Constructor
Namespaces ► Sitecore.Pipelines.FixXHtml ► FixXHtmlProcessor ► FixXHtmlProcessor()()()
Initializes a new instance of the FixXHtmlProcessor class
Declaration Syntax
C#
protected FixXHtmlProcessor()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.FixXHtml ► FixXHtmlProcessor ► Process(FixXHtmlArgs)
Runs the processor.
Declaration Syntax
C#
public abstract void Process(
    FixXHtmlArgs args
)
Parameters
args (FixXHtmlArgs)
The arguments.


PrepareHtml Class

PrepareHtml Class
Namespaces ► Sitecore.Pipelines.FixXHtml ► PrepareHtml
Implements the ShortenLinks.
Declaration Syntax
C#
public class PrepareHtml : FixXHtmlProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PrepareHtml()()() | Initializes a new instance of the PrepareHtml class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(FixXHtmlArgs) | Runs the processor. (Overrides FixXHtmlProcessor.Process(FixXHtmlArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FixXHtmlProcessor
 |  | PrepareHtml


PrepareHtml Constructor

PrepareHtml Constructor
Namespaces ► Sitecore.Pipelines.FixXHtml ► PrepareHtml ► PrepareHtml()()()
Initializes a new instance of the PrepareHtml class
Declaration Syntax
C#
public PrepareHtml()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.FixXHtml ► PrepareHtml ► Process(FixXHtmlArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    FixXHtmlArgs args
)
Parameters
args (FixXHtmlArgs)
The arguments.


RemoveEmptySpans Class

RemoveEmptySpans Class
Namespaces ► Sitecore.Pipelines.FixXHtml ► RemoveEmptySpans
Implements the ShortenLinks.
Declaration Syntax
C#
public class RemoveEmptySpans : FixXHtmlProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RemoveEmptySpans()()() | Initializes a new instance of the RemoveEmptySpans class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(FixXHtmlArgs) | Runs the processor. (Overrides FixXHtmlProcessor.Process(FixXHtmlArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FixXHtmlProcessor
 |  | RemoveEmptySpans


RemoveEmptySpans Constructor

RemoveEmptySpans Constructor
Namespaces ► Sitecore.Pipelines.FixXHtml ► RemoveEmptySpans ► RemoveEmptySpans()()()
Initializes a new instance of the RemoveEmptySpans class
Declaration Syntax
C#
public RemoveEmptySpans()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.FixXHtml ► RemoveEmptySpans ► Process(FixXHtmlArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    FixXHtmlArgs args
)
Parameters
args (FixXHtmlArgs)
The arguments.


Sitecore.Pipelines.GetAboutInformation Namespace

Sitecore.Pipelines.GetAboutInformation Namespace
Namespaces ► Sitecore.Pipelines.GetAboutInformation
Declaration Syntax
C#
namespace Sitecore.Pipelines.GetAboutInformation
Types
All Types Classes
Icon | Type | Description
 | GetAboutInformationArgs | Pipeline arguments for getAboutInformation pipeline.


GetAboutInformationArgs Class

GetAboutInformationArgs Class
Namespaces ► Sitecore.Pipelines.GetAboutInformation ► GetAboutInformationArgs
Pipeline arguments for getAboutInformation pipeline.
Declaration Syntax
C#
public class GetAboutInformationArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetAboutInformationArgs()()() | Initializes a new instance of the GetAboutInformationArgs class
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AboutText | Gets or sets the about text.
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | LoginPageText | Gets or sets the login screen text.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | GetAboutInformationArgs


GetAboutInformationArgs Constructor

GetAboutInformationArgs Constructor
Namespaces ► Sitecore.Pipelines.GetAboutInformation ► GetAboutInformationArgs ► GetAboutInformationArgs()()()
Initializes a new instance of the GetAboutInformationArgs class
Declaration Syntax
C#
public GetAboutInformationArgs()


AboutText Property

AboutText Property
Namespaces ► Sitecore.Pipelines.GetAboutInformation ► GetAboutInformationArgs ► AboutText
Gets or sets the about text.
Declaration Syntax
C#
public string AboutText { get; set; }
Value
The about text.


LoginPageText Property

LoginPageText Property
Namespaces ► Sitecore.Pipelines.GetAboutInformation ► GetAboutInformationArgs ► LoginPageText
Gets or sets the login screen text.
Declaration Syntax
C#
public string LoginPageText { get; set; }
Value
The login screen text.


Sitecore.Pipelines.GetContentEditorWarnings Namespace

Sitecore.Pipelines.GetContentEditorWarnings Namespace
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings
Declaration Syntax
C#
namespace Sitecore.Pipelines.GetContentEditorWarnings
Types
All Types Classes
Icon | Type | Description
 | CanReadLanguage | Implements the RenderField.
 | CanWrite | Implements the RenderField.
 | CanWriteLanguage | Implements the RenderField.
 | CanWriteWorkflow | Implements the RenderField.
 | GetContentEditorWarningsArgs..::.ContentEditorWarning |
 | GetContentEditorWarningsArgs | Implements the RenderField.
 | HasNoFields | Implements the RenderField.
 | HasNoVersions | Implements the RenderField.
 | IsLocked | Implements the RenderField.
 | IsReadOnly | Implements the RenderField.
 | ItemNotFound | Implements the RenderField.
 | ItemPublishingRestricted | Implements the RenderField.
 | LanguageNotFound | Implements the RenderField.
 | MissingMarketingProfiles | Defines the missing marketing profiles class.
 | NeverPublish | Implements the RenderField.
 | ShowingInputBoxes | Implements the RenderField.
 | VersionPublishingRestricted | Implements the RenderField.


CanReadLanguage Class

CanReadLanguage Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► CanReadLanguage
Implements the RenderField.
Declaration Syntax
C#
public class CanReadLanguage
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CanReadLanguage()()() | Initializes a new instance of the CanReadLanguage class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CanReadLanguage


CanReadLanguage Constructor

CanReadLanguage Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► CanReadLanguage ► CanReadLanguage()()()
Initializes a new instance of the CanReadLanguage class
Declaration Syntax
C#
public CanReadLanguage()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► CanReadLanguage ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


CanWrite Class

CanWrite Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► CanWrite
Implements the RenderField.
Declaration Syntax
C#
public class CanWrite
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CanWrite()()() | Initializes a new instance of the CanWrite class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CanWrite


CanWrite Constructor

CanWrite Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► CanWrite ► CanWrite()()()
Initializes a new instance of the CanWrite class
Declaration Syntax
C#
public CanWrite()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► CanWrite ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


CanWriteLanguage Class

CanWriteLanguage Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► CanWriteLanguage
Implements the RenderField.
Declaration Syntax
C#
public class CanWriteLanguage
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CanWriteLanguage()()() | Initializes a new instance of the CanWriteLanguage class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CanWriteLanguage


CanWriteLanguage Constructor

CanWriteLanguage Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► CanWriteLanguage ► CanWriteLanguage()()()
Initializes a new instance of the CanWriteLanguage class
Declaration Syntax
C#
public CanWriteLanguage()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► CanWriteLanguage ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


CanWriteWorkflow Class

CanWriteWorkflow Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► CanWriteWorkflow
Implements the RenderField.
Declaration Syntax
C#
public class CanWriteWorkflow
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CanWriteWorkflow()()() | Initializes a new instance of the CanWriteWorkflow class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CanWriteWorkflow


CanWriteWorkflow Constructor

CanWriteWorkflow Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► CanWriteWorkflow ► CanWriteWorkflow()()()
Initializes a new instance of the CanWriteWorkflow class
Declaration Syntax
C#
public CanWriteWorkflow()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► CanWriteWorkflow ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


GetContentEditorWarningsArgs Class

GetContentEditorWarningsArgs Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs
Implements the RenderField.
Declaration Syntax
C#
[SerializableAttribute]
public class GetContentEditorWarningsArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetContentEditorWarningsArgs(Item) | Initializes a new instance of the GetContentEditorWarningsArgs class.
 | GetContentEditorWarningsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetContentEditorWarningsArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | Add()()() | Adds this instance.
 | Add(String, String) | Adds the specified title.
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Empty | Gets the empty.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasFullscreenWarnings()()() | Determines whether there is a fullscreen warning.
 | HasSections | Gets or sets a value indicating whether this instance has sections.
 | HideFields()()() | Determines whether there is a fullscreen warning.
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | ShowInputBoxes | Gets or sets a value indicating whether the GetContentEditorWarningsArgs shows the input boxes.
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Warnings | Gets the warnings.
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | GetContentEditorWarningsArgs


GetContentEditorWarningsArgs Constructor

GetContentEditorWarningsArgs Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► GetContentEditorWarningsArgs()()()
Members
Icon | Member | Description
 | GetContentEditorWarningsArgs(Item) | Initializes a new instance of the GetContentEditorWarningsArgs class.
 | GetContentEditorWarningsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetContentEditorWarningsArgs class.


GetContentEditorWarningsArgs Constructor (item)

GetContentEditorWarningsArgs Constructor (item)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► GetContentEditorWarningsArgs(Item)
Initializes a new instance of the GetContentEditorWarningsArgs class.
Declaration Syntax
C#
public GetContentEditorWarningsArgs(
    Item item
)
Parameters
item (Item)
The item.


GetContentEditorWarningsArgs Constructor (info, context)

GetContentEditorWarningsArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► GetContentEditorWarningsArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the GetContentEditorWarningsArgs class.
Declaration Syntax
C#
protected GetContentEditorWarningsArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Add Method

Add Method
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► Add()()()
Members
Icon | Member | Description
 | Add()()() | Adds this instance.
 | Add(String, String) | Adds the specified title.


Add Method

Add Method
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► Add()()()
Adds this instance.
Declaration Syntax
C#
public GetContentEditorWarningsArgs..::.ContentEditorWarning Add()
Return Value
The add.


Add Method (title, text)

Add Method (title, text)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► Add(String, String)
Adds the specified title.
Declaration Syntax
C#
public void Add(
    string title,
    string text
)
Parameters
title (String)
The title.
text (String)
The text.


Empty Property

Empty Property
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► Empty
Gets the empty.
Declaration Syntax
C#
public static GetContentEditorWarningsArgs Empty { get; }
Value
The empty.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


HasFullscreenWarnings Method

HasFullscreenWarnings Method
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► HasFullscreenWarnings()()()
Determines whether there is a fullscreen warning.
Declaration Syntax
C#
public bool HasFullscreenWarnings()
Return Value
true if there is a fullscreen warning; otherwise, false.


HasSections Property

HasSections Property
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► HasSections
Gets or sets a value indicating whether this instance has sections.
Declaration Syntax
C#
public bool HasSections { get; set; }
Value
true if this instance has sections; otherwise, false.


HideFields Method

HideFields Method
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► HideFields()()()
Determines whether there is a fullscreen warning.
Declaration Syntax
C#
public bool HideFields()
Return Value
true if there is a fullscreen warning; otherwise, false.


Item Property

Item Property
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


ShowInputBoxes Property

ShowInputBoxes Property
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► ShowInputBoxes
Gets or sets a value indicating whether the GetContentEditorWarningsArgs shows the input boxes.
Declaration Syntax
C#
public bool ShowInputBoxes { get; set; }
Value
true if the GetContentEditorWarningsArgs shows the input boxes; otherwise, false.


Warnings Property

Warnings Property
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► Warnings
Gets the warnings.
Declaration Syntax
C#
public List<GetContentEditorWarningsArgs..::.ContentEditorWarning> Warnings { get; }
Value
The warnings.


GetContentEditorWarningsArgs.ContentEditorWarning Class

GetContentEditorWarningsArgs..::.ContentEditorWarning Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs ► GetContentEditorWarningsArgs..::.ContentEditorWarning
Declaration Syntax
C#
public class ContentEditorWarning
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetContentEditorWarningsArgs..::.ContentEditorWarning()()() | Initializes a new instance of the GetContentEditorWarningsArgs..::.ContentEditorWarning class
 | AddOption(String, String) | Adds the option.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HideFields | Gets or sets a value indicating whether the GetContentEditorWarningsArgs..::.ContentEditorWarning hides the fields.
 | Icon | Gets or sets the icon.
 | IsExclusive | Gets or sets a value indicating whether this GetContentEditorWarningsArgs..::.ContentEditorWarning is exclusive.
 | IsFullscreen | Gets or sets a value indicating whether this GetContentEditorWarningsArgs..::.ContentEditorWarning is fullscreen.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Options | Gets the options.
 | Text | Gets or sets the text.
 | Title | Gets or sets the title.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GetContentEditorWarningsArgs..::.ContentEditorWarning


GetContentEditorWarningsArgs.ContentEditorWarning Constructor

GetContentEditorWarningsArgs..::.ContentEditorWarning Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs..::.ContentEditorWarning ► GetContentEditorWarningsArgs..::.ContentEditorWarning()()()
Initializes a new instance of the GetContentEditorWarningsArgs..::.ContentEditorWarning class
Declaration Syntax
C#
public ContentEditorWarning()


AddOption Method (header, command)

AddOption Method (header, command)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs..::.ContentEditorWarning ► AddOption(String, String)
Adds the option.
Declaration Syntax
C#
public void AddOption(
    string header,
    string command
)
Parameters
header (String)
The header.
command (String)
The command.


HideFields Property

HideFields Property
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs..::.ContentEditorWarning ► HideFields
Gets or sets a value indicating whether the GetContentEditorWarningsArgs..::.ContentEditorWarning hides the fields.
Declaration Syntax
C#
public bool HideFields { get; set; }
Value
true if the GetContentEditorWarningsArgs..::.ContentEditorWarning hides the fields; otherwise, false.


Icon Property

Icon Property
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs..::.ContentEditorWarning ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


IsExclusive Property

IsExclusive Property
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs..::.ContentEditorWarning ► IsExclusive
Gets or sets a value indicating whether this GetContentEditorWarningsArgs..::.ContentEditorWarning is exclusive.
Declaration Syntax
C#
public bool IsExclusive { get; set; }
Value
true if exclusive; otherwise, false.


IsFullscreen Property

IsFullscreen Property
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs..::.ContentEditorWarning ► IsFullscreen
Gets or sets a value indicating whether this GetContentEditorWarningsArgs..::.ContentEditorWarning is fullscreen.
Declaration Syntax
C#
public bool IsFullscreen { get; set; }
Value
true if fullscreen; otherwise, false.


Options Property

Options Property
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs..::.ContentEditorWarning ► Options
Gets the options.
Declaration Syntax
C#
public List<Pair<string, string>> Options { get; }
Value
The options.


Text Property

Text Property
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs..::.ContentEditorWarning ► Text
Gets or sets the text.
Declaration Syntax
C#
public string Text { get; set; }
Value
The text.


Title Property

Title Property
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► GetContentEditorWarningsArgs..::.ContentEditorWarning ► Title
Gets or sets the title.
Declaration Syntax
C#
public string Title { get; set; }
Value
The title.


HasNoFields Class

HasNoFields Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► HasNoFields
Implements the RenderField.
Declaration Syntax
C#
public class HasNoFields
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HasNoFields()()() | Initializes a new instance of the HasNoFields class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HasNoFields


HasNoFields Constructor

HasNoFields Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► HasNoFields ► HasNoFields()()()
Initializes a new instance of the HasNoFields class
Declaration Syntax
C#
public HasNoFields()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► HasNoFields ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


HasNoVersions Class

HasNoVersions Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► HasNoVersions
Implements the RenderField.
Declaration Syntax
C#
public class HasNoVersions
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HasNoVersions()()() | Initializes a new instance of the HasNoVersions class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HasNoVersions


HasNoVersions Constructor

HasNoVersions Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► HasNoVersions ► HasNoVersions()()()
Initializes a new instance of the HasNoVersions class
Declaration Syntax
C#
public HasNoVersions()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► HasNoVersions ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


IsLocked Class

IsLocked Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► IsLocked
Implements the RenderField.
Declaration Syntax
C#
public class IsLocked
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsLocked()()() | Initializes a new instance of the IsLocked class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
IsLocked


IsLocked Constructor

IsLocked Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► IsLocked ► IsLocked()()()
Initializes a new instance of the IsLocked class
Declaration Syntax
C#
public IsLocked()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► IsLocked ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


IsReadOnly Class

IsReadOnly Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► IsReadOnly
Implements the RenderField.
Declaration Syntax
C#
public class IsReadOnly
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsReadOnly()()() | Initializes a new instance of the IsReadOnly class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
IsReadOnly


IsReadOnly Constructor

IsReadOnly Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► IsReadOnly ► IsReadOnly()()()
Initializes a new instance of the IsReadOnly class
Declaration Syntax
C#
public IsReadOnly()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► IsReadOnly ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


ItemNotFound Class

ItemNotFound Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► ItemNotFound
Implements the RenderField.
Declaration Syntax
C#
public class ItemNotFound
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemNotFound()()() | Initializes a new instance of the ItemNotFound class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemNotFound


ItemNotFound Constructor

ItemNotFound Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► ItemNotFound ► ItemNotFound()()()
Initializes a new instance of the ItemNotFound class
Declaration Syntax
C#
public ItemNotFound()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► ItemNotFound ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


ItemPublishingRestricted Class

ItemPublishingRestricted Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► ItemPublishingRestricted
Implements the RenderField.
Declaration Syntax
C#
public class ItemPublishingRestricted
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemPublishingRestricted()()() | Initializes a new instance of the ItemPublishingRestricted class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsPublishRestricted(Item) | Determines whether publish is restricted for the specified item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemPublishingRestricted


ItemPublishingRestricted Constructor

ItemPublishingRestricted Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► ItemPublishingRestricted ► ItemPublishingRestricted()()()
Initializes a new instance of the ItemPublishingRestricted class
Declaration Syntax
C#
public ItemPublishingRestricted()


IsPublishRestricted Method (item)

IsPublishRestricted Method (item)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► ItemPublishingRestricted ► IsPublishRestricted(Item)
Determines whether publish is restricted for the specified item.
Declaration Syntax
C#
public static bool IsPublishRestricted(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if publish is restricted for the specified item; otherwise, false.


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► ItemPublishingRestricted ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


LanguageNotFound Class

LanguageNotFound Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► LanguageNotFound
Implements the RenderField.
Declaration Syntax
C#
public class LanguageNotFound
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LanguageNotFound()()() | Initializes a new instance of the LanguageNotFound class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LanguageNotFound


LanguageNotFound Constructor

LanguageNotFound Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► LanguageNotFound ► LanguageNotFound()()()
Initializes a new instance of the LanguageNotFound class
Declaration Syntax
C#
public LanguageNotFound()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► LanguageNotFound ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


MissingMarketingProfiles Class

MissingMarketingProfiles Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► MissingMarketingProfiles
Defines the missing marketing profiles class.
Declaration Syntax
C#
public class MissingMarketingProfiles
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MissingMarketingProfiles()()() | Initializes a new instance of the MissingMarketingProfiles class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MissingMarketingProfiles


MissingMarketingProfiles Constructor

MissingMarketingProfiles Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► MissingMarketingProfiles ► MissingMarketingProfiles()()()
Initializes a new instance of the MissingMarketingProfiles class
Declaration Syntax
C#
public MissingMarketingProfiles()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► MissingMarketingProfiles ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


NeverPublish Class

NeverPublish Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► NeverPublish
Implements the RenderField.
Declaration Syntax
C#
public class NeverPublish
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NeverPublish()()() | Initializes a new instance of the NeverPublish class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NeverPublish


NeverPublish Constructor

NeverPublish Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► NeverPublish ► NeverPublish()()()
Initializes a new instance of the NeverPublish class
Declaration Syntax
C#
public NeverPublish()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► NeverPublish ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


ShowingInputBoxes Class

ShowingInputBoxes Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► ShowingInputBoxes
Implements the RenderField.
Declaration Syntax
C#
public class ShowingInputBoxes
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ShowingInputBoxes()()() | Initializes a new instance of the ShowingInputBoxes class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ShowingInputBoxes


ShowingInputBoxes Constructor

ShowingInputBoxes Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► ShowingInputBoxes ► ShowingInputBoxes()()()
Initializes a new instance of the ShowingInputBoxes class
Declaration Syntax
C#
public ShowingInputBoxes()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► ShowingInputBoxes ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


VersionPublishingRestricted Class

VersionPublishingRestricted Class
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► VersionPublishingRestricted
Implements the RenderField.
Declaration Syntax
C#
public class VersionPublishingRestricted
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | VersionPublishingRestricted()()() | Initializes a new instance of the VersionPublishingRestricted class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetContentEditorWarningsArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
VersionPublishingRestricted


VersionPublishingRestricted Constructor

VersionPublishingRestricted Constructor
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► VersionPublishingRestricted ► VersionPublishingRestricted()()()
Initializes a new instance of the VersionPublishingRestricted class
Declaration Syntax
C#
public VersionPublishingRestricted()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetContentEditorWarnings ► VersionPublishingRestricted ► Process(GetContentEditorWarningsArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    GetContentEditorWarningsArgs args
)
Parameters
args (GetContentEditorWarningsArgs)
The arguments.


Sitecore.Pipelines.GetLookupSourceItems Namespace

Sitecore.Pipelines.GetLookupSourceItems Namespace
Namespaces ► Sitecore.Pipelines.GetLookupSourceItems
Declaration Syntax
C#
namespace Sitecore.Pipelines.GetLookupSourceItems
Types
All Types Classes
Icon | Type | Description
 | GetLookupSourceItemsArgs | Argument class for getLookupSourceItems pipeline.
 | ProcessDefaultSource | Processes common query sources without well-known prefixes
 | ProcessQuerySource | Processes query sources that start with 'query:' prefix


GetLookupSourceItemsArgs Class

GetLookupSourceItemsArgs Class
Namespaces ► Sitecore.Pipelines.GetLookupSourceItems ► GetLookupSourceItemsArgs
Argument class for getLookupSourceItems pipeline.
Declaration Syntax
C#
public class GetLookupSourceItemsArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetLookupSourceItemsArgs()()() | Initializes a new instance of the GetLookupSourceItemsArgs class
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | Item | Gets or sets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Result | Gets the result.
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Source | Gets or sets the source.
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | GetLookupSourceItemsArgs


GetLookupSourceItemsArgs Constructor

GetLookupSourceItemsArgs Constructor
Namespaces ► Sitecore.Pipelines.GetLookupSourceItems ► GetLookupSourceItemsArgs ► GetLookupSourceItemsArgs()()()
Initializes a new instance of the GetLookupSourceItemsArgs class
Declaration Syntax
C#
public GetLookupSourceItemsArgs()


Item Property

Item Property
Namespaces ► Sitecore.Pipelines.GetLookupSourceItems ► GetLookupSourceItemsArgs ► Item
Gets or sets the item.
Declaration Syntax
C#
public Item Item { get; set; }
Value
The item.


Result Property

Result Property
Namespaces ► Sitecore.Pipelines.GetLookupSourceItems ► GetLookupSourceItemsArgs ► Result
Gets the result.
Declaration Syntax
C#
public ItemCollection Result { get; }
Value
The result.


Source Property

Source Property
Namespaces ► Sitecore.Pipelines.GetLookupSourceItems ► GetLookupSourceItemsArgs ► Source
Gets or sets the source.
Declaration Syntax
C#
public string Source { get; set; }
Value
The source.


ProcessDefaultSource Class

ProcessDefaultSource Class
Namespaces ► Sitecore.Pipelines.GetLookupSourceItems ► ProcessDefaultSource
Processes common query sources without well-known prefixes
Declaration Syntax
C#
public class ProcessDefaultSource : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProcessDefaultSource()()() | Initializes a new instance of the ProcessDefaultSource class
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | IsComplex(String) | Determines whether [is complex source] [the specified source].
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Process(GetLookupSourceItemsArgs) | Runs the processor.
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ProcessDefaultSource


ProcessDefaultSource Constructor

ProcessDefaultSource Constructor
Namespaces ► Sitecore.Pipelines.GetLookupSourceItems ► ProcessDefaultSource ► ProcessDefaultSource()()()
Initializes a new instance of the ProcessDefaultSource class
Declaration Syntax
C#
public ProcessDefaultSource()


IsComplex Method (source)

IsComplex Method (source)
Namespaces ► Sitecore.Pipelines.GetLookupSourceItems ► ProcessDefaultSource ► IsComplex(String)
Determines whether [is complex source] [the specified source].
Declaration Syntax
C#
protected virtual bool IsComplex(
    string source
)
Parameters
source (String)
The source.
Return Value
true if [is complex source] [the specified source]; otherwise, false.


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetLookupSourceItems ► ProcessDefaultSource ► Process(GetLookupSourceItemsArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    GetLookupSourceItemsArgs args
)
Parameters
args (GetLookupSourceItemsArgs)
The arguments.


ProcessQuerySource Class

ProcessQuerySource Class
Namespaces ► Sitecore.Pipelines.GetLookupSourceItems ► ProcessQuerySource
Processes query sources that start with 'query:' prefix
Declaration Syntax
C#
public class ProcessQuerySource
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProcessQuerySource()()() | Initializes a new instance of the ProcessQuerySource class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetLookupSourceItemsArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProcessQuerySource


ProcessQuerySource Constructor

ProcessQuerySource Constructor
Namespaces ► Sitecore.Pipelines.GetLookupSourceItems ► ProcessQuerySource ► ProcessQuerySource()()()
Initializes a new instance of the ProcessQuerySource class
Declaration Syntax
C#
public ProcessQuerySource()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetLookupSourceItems ► ProcessQuerySource ► Process(GetLookupSourceItemsArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    GetLookupSourceItemsArgs args
)
Parameters
args (GetLookupSourceItemsArgs)
The arguments.


Sitecore.Pipelines.GetMasters Namespace

Sitecore.Pipelines.GetMasters Namespace
Namespaces ► Sitecore.Pipelines.GetMasters
Declaration Syntax
C#
namespace Sitecore.Pipelines.GetMasters
Types
All Types Classes
Icon | Type | Description
 | CheckSecurity | Upload has finished.
 | GetInsertRules | Upload has finished.
 | GetItemMasters | Upload has finished.
 | GetMastersArgs | Argument class for the Upload pipeline.
 | RunRules | Upload has finished.


CheckSecurity Class

CheckSecurity Class
Namespaces ► Sitecore.Pipelines.GetMasters ► CheckSecurity
Upload has finished.
Declaration Syntax
C#
public class CheckSecurity
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckSecurity()()() | Initializes a new instance of the CheckSecurity class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetMastersArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CheckSecurity


CheckSecurity Constructor

CheckSecurity Constructor
Namespaces ► Sitecore.Pipelines.GetMasters ► CheckSecurity ► CheckSecurity()()()
Initializes a new instance of the CheckSecurity class
Declaration Syntax
C#
public CheckSecurity()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetMasters ► CheckSecurity ► Process(GetMastersArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    GetMastersArgs args
)
Parameters
args (GetMastersArgs)
The arguments.


GetInsertRules Class

GetInsertRules Class
Namespaces ► Sitecore.Pipelines.GetMasters ► GetInsertRules
Upload has finished.
Declaration Syntax
C#
public class GetInsertRules
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetInsertRules()()() | Initializes a new instance of the GetInsertRules class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetMastersArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GetInsertRules


GetInsertRules Constructor

GetInsertRules Constructor
Namespaces ► Sitecore.Pipelines.GetMasters ► GetInsertRules ► GetInsertRules()()()
Initializes a new instance of the GetInsertRules class
Declaration Syntax
C#
public GetInsertRules()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetMasters ► GetInsertRules ► Process(GetMastersArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    GetMastersArgs args
)
Parameters
args (GetMastersArgs)
The arguments.


GetItemMasters Class

GetItemMasters Class
Namespaces ► Sitecore.Pipelines.GetMasters ► GetItemMasters
Upload has finished.
Declaration Syntax
C#
public class GetItemMasters
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetItemMasters()()() | Initializes a new instance of the GetItemMasters class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetMastersArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GetItemMasters


GetItemMasters Constructor

GetItemMasters Constructor
Namespaces ► Sitecore.Pipelines.GetMasters ► GetItemMasters ► GetItemMasters()()()
Initializes a new instance of the GetItemMasters class
Declaration Syntax
C#
public GetItemMasters()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetMasters ► GetItemMasters ► Process(GetMastersArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    GetMastersArgs args
)
Parameters
args (GetMastersArgs)
The arguments.


GetMastersArgs Class

GetMastersArgs Class
Namespaces ► Sitecore.Pipelines.GetMasters ► GetMastersArgs
Argument class for the Upload pipeline.
Declaration Syntax
C#
[SerializableAttribute]
public class GetMastersArgs : ClientPipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMastersArgs()()() | Initializes a new instance of the GetMastersArgs class.
 | GetMastersArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetMastersArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
 | Item | Gets the item.
 | Masters | Gets the masters.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from ClientPipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
 | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitForPostBack()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ClientPipelineArgs
 |  |  |  | GetMastersArgs


GetMastersArgs Constructor

GetMastersArgs Constructor
Namespaces ► Sitecore.Pipelines.GetMasters ► GetMastersArgs ► GetMastersArgs()()()
Members
Icon | Member | Description
 | GetMastersArgs()()() | Initializes a new instance of the GetMastersArgs class.
 | GetMastersArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetMastersArgs class.


GetMastersArgs Constructor

GetMastersArgs Constructor
Namespaces ► Sitecore.Pipelines.GetMasters ► GetMastersArgs ► GetMastersArgs()()()
Initializes a new instance of the GetMastersArgs class.
Declaration Syntax
C#
public GetMastersArgs()


GetMastersArgs Constructor (info, context)

GetMastersArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.GetMasters ► GetMastersArgs ► GetMastersArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the GetMastersArgs class.
Declaration Syntax
C#
protected GetMastersArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.GetMasters ► GetMastersArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Item Property

Item Property
Namespaces ► Sitecore.Pipelines.GetMasters ► GetMastersArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; set; }
Value
The item.


Masters Property

Masters Property
Namespaces ► Sitecore.Pipelines.GetMasters ► GetMastersArgs ► Masters
Gets the masters.
Declaration Syntax
C#
public List<Item> Masters { get; }
Value
The masters.


RunRules Class

RunRules Class
Namespaces ► Sitecore.Pipelines.GetMasters ► RunRules
Upload has finished.
Declaration Syntax
C#
public class RunRules
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RunRules()()() | Initializes a new instance of the RunRules class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetMastersArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RunRules


RunRules Constructor

RunRules Constructor
Namespaces ► Sitecore.Pipelines.GetMasters ► RunRules ► RunRules()()()
Initializes a new instance of the RunRules class
Declaration Syntax
C#
public RunRules()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetMasters ► RunRules ► Process(GetMastersArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    GetMastersArgs args
)
Parameters
args (GetMastersArgs)
The arguments.


Sitecore.Pipelines.GetPlaceholderRenderings Namespace

Sitecore.Pipelines.GetPlaceholderRenderings Namespace
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings
Declaration Syntax
C#
namespace Sitecore.Pipelines.GetPlaceholderRenderings
Types
All Types Classes
Icon | Type | Description
 | GetAllowedRenderings | Fills placeholder renderings list.
 | GetPlaceholderRenderingsArgs | Arguments for GetPleceholderRenderings pipeline.
 | GetPlaceholderRenderingsDialogUrl | Chooses appropriate Dialog for selecting associated renderings.


GetAllowedRenderings Class

GetAllowedRenderings Class
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings ► GetAllowedRenderings
Fills placeholder renderings list.
Declaration Syntax
C#
public class GetAllowedRenderings
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetAllowedRenderings()()() | Initializes a new instance of the GetAllowedRenderings class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRenderings(String, String, Database) | Gets the allowed renderings.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetPlaceholderRenderingsArgs) | Fills placeholder renderings list.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GetAllowedRenderings


GetAllowedRenderings Constructor

GetAllowedRenderings Constructor
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings ► GetAllowedRenderings ► GetAllowedRenderings()()()
Initializes a new instance of the GetAllowedRenderings class
Declaration Syntax
C#
public GetAllowedRenderings()


GetRenderings Method (placeholderKey, layoutDefinition, contentDatabase)

GetRenderings Method (placeholderKey, layoutDefinition, contentDatabase)
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings ► GetAllowedRenderings ► GetRenderings(String, String, Database)
Gets the allowed renderings.
Declaration Syntax
C#
protected virtual List<Item> GetRenderings(
    string placeholderKey,
    string layoutDefinition,
    Database contentDatabase
)
Parameters
placeholderKey (String)
The placeholder key.
layoutDefinition (String)
The layout definition.
contentDatabase (Database)
The content database.
Return Value
The allowed renderings.


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings ► GetAllowedRenderings ► Process(GetPlaceholderRenderingsArgs)
Fills placeholder renderings list.
Declaration Syntax
C#
public void Process(
    GetPlaceholderRenderingsArgs args
)
Parameters
args (GetPlaceholderRenderingsArgs)
The arguments.


GetPlaceholderRenderingsArgs Class

GetPlaceholderRenderingsArgs Class
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings ► GetPlaceholderRenderingsArgs
Arguments for GetPleceholderRenderings pipeline.
Declaration Syntax
C#
public class GetPlaceholderRenderingsArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetPlaceholderRenderingsArgs(String, String, Database) | Initializes a new instance of the GetPlaceholderRenderingsArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | ContentDatabase | Gets the content database.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | DialogURL | Gets or sets the dialog URL.
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | LayoutDefinition | Gets the layout definition.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | PlaceholderKey | Gets the placeholder key.
 | PlaceholderRenderings | Gets or sets the rendering list that are allowed to be assigned to the placeholder.
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | GetPlaceholderRenderingsArgs


GetPlaceholderRenderingsArgs Constructor (placeholderKey, layoutDefinition, contentDatabase)

GetPlaceholderRenderingsArgs Constructor (placeholderKey, layoutDefinition, contentDatabase)
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings ► GetPlaceholderRenderingsArgs ► GetPlaceholderRenderingsArgs(String, String, Database)
Initializes a new instance of the GetPlaceholderRenderingsArgs class.
Declaration Syntax
C#
public GetPlaceholderRenderingsArgs(
    string placeholderKey,
    string layoutDefinition,
    Database contentDatabase
)
Parameters
placeholderKey (String)
The placeholder key.
layoutDefinition (String)
The layout definition.
contentDatabase (Database)
The content database.


ContentDatabase Property

ContentDatabase Property
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings ► GetPlaceholderRenderingsArgs ► ContentDatabase
Gets the content database.
Declaration Syntax
C#
public Database ContentDatabase { get; }
Value
The content database.


DialogURL Property

DialogURL Property
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings ► GetPlaceholderRenderingsArgs ► DialogURL
Gets or sets the dialog URL.
Declaration Syntax
C#
public string DialogURL { get; set; }
Value
The dialog URL.


LayoutDefinition Property

LayoutDefinition Property
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings ► GetPlaceholderRenderingsArgs ► LayoutDefinition
Gets the layout definition.
Declaration Syntax
C#
public string LayoutDefinition { get; }
Value
The layout definition.


PlaceholderKey Property

PlaceholderKey Property
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings ► GetPlaceholderRenderingsArgs ► PlaceholderKey
Gets the placeholder key.
Declaration Syntax
C#
public string PlaceholderKey { get; }
Value
The placeholder key.


PlaceholderRenderings Property

PlaceholderRenderings Property
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings ► GetPlaceholderRenderingsArgs ► PlaceholderRenderings
Gets or sets the rendering list that are allowed to be assigned to the placeholder.
Declaration Syntax
C#
public List<Item> PlaceholderRenderings { get; set; }
Value
The placeholder renderings.


GetPlaceholderRenderingsDialogUrl Class

GetPlaceholderRenderingsDialogUrl Class
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings ► GetPlaceholderRenderingsDialogUrl
Chooses appropriate Dialog for selecting associated renderings.
Declaration Syntax
C#
public class GetPlaceholderRenderingsDialogUrl
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetPlaceholderRenderingsDialogUrl()()() | Initializes a new instance of the GetPlaceholderRenderingsDialogUrl class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetPlaceholderRenderingsArgs) | Chooses appropriate Dialog for selecting associated renderings
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GetPlaceholderRenderingsDialogUrl


GetPlaceholderRenderingsDialogUrl Constructor

GetPlaceholderRenderingsDialogUrl Constructor
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings ► GetPlaceholderRenderingsDialogUrl ► GetPlaceholderRenderingsDialogUrl()()()
Initializes a new instance of the GetPlaceholderRenderingsDialogUrl class
Declaration Syntax
C#
public GetPlaceholderRenderingsDialogUrl()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetPlaceholderRenderings ► GetPlaceholderRenderingsDialogUrl ► Process(GetPlaceholderRenderingsArgs)
Chooses appropriate Dialog for selecting associated renderings
Declaration Syntax
C#
public void Process(
    GetPlaceholderRenderingsArgs args
)
Parameters
args (GetPlaceholderRenderingsArgs)
The arguments.


Sitecore.Pipelines.GetQueryState Namespace

Sitecore.Pipelines.GetQueryState Namespace
Namespaces ► Sitecore.Pipelines.GetQueryState
Declaration Syntax
C#
namespace Sitecore.Pipelines.GetQueryState
Types
All Types Classes
Icon | Type | Description
 | GetQueryStateArgs | Arguments for GetQueryState processors.


GetQueryStateArgs Class

GetQueryStateArgs Class
Namespaces ► Sitecore.Pipelines.GetQueryState ► GetQueryStateArgs
Arguments for GetQueryState processors.
Declaration Syntax
C#
public class GetQueryStateArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetQueryStateArgs(String, Item, CommandState, CommandContext) | Initializes a new instance of the GetQueryStateArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | Button | Gets the Command button, e.g. for Pannels.
 | CommandContext | Gets the command context.
 | CommandName | Gets the name of the command.
 | CommandState | Gets or sets the state of the command.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | GetQueryStateArgs


GetQueryStateArgs Constructor (commandName, button, state, context)

GetQueryStateArgs Constructor (commandName, button, state, context)
Namespaces ► Sitecore.Pipelines.GetQueryState ► GetQueryStateArgs ► GetQueryStateArgs(String, Item, CommandState, CommandContext)
Initializes a new instance of the GetQueryStateArgs class.
Declaration Syntax
C#
public GetQueryStateArgs(
    string commandName,
    Item button,
    CommandState state,
    CommandContext context
)
Parameters
commandName (String)
Name of the command.
button (Item)
The Command button.
state (CommandState)
State of the command.
context (CommandContext)
Command context.


Button Property

Button Property
Namespaces ► Sitecore.Pipelines.GetQueryState ► GetQueryStateArgs ► Button
Gets the Command button, e.g. for Pannels.
Declaration Syntax
C#
public Item Button { get; }
Value
The Command button.


CommandContext Property

CommandContext Property
Namespaces ► Sitecore.Pipelines.GetQueryState ► GetQueryStateArgs ► CommandContext
Gets the command context.
Declaration Syntax
C#
public CommandContext CommandContext { get; }
Value
The command context.


CommandName Property

CommandName Property
Namespaces ► Sitecore.Pipelines.GetQueryState ► GetQueryStateArgs ► CommandName
Gets the name of the command.
Declaration Syntax
C#
public string CommandName { get; }
Value
The name of the command.


CommandState Property

CommandState Property
Namespaces ► Sitecore.Pipelines.GetQueryState ► GetQueryStateArgs ► CommandState
Gets or sets the state of the command.
Declaration Syntax
C#
public CommandState CommandState { get; set; }
Value
The state of the command.


Sitecore.Pipelines.GetRenderingPreview Namespace

Sitecore.Pipelines.GetRenderingPreview Namespace
Namespaces ► Sitecore.Pipelines.GetRenderingPreview
Declaration Syntax
C#
namespace Sitecore.Pipelines.GetRenderingPreview
Types
All Types Classes
Icon | Type | Description
 | GetDefaultRenderingPreview | Get Rendering Preview Field.
 | GetRenderingPreviewArgs | The arguments for the Get Rendering Preview Pipeline
 | GetRenderingPreviewField | Get Rendering Preview Field.
 | GetRenderingPreviewProcessor | ExpandInitialFieldValueProcessor class
 | GetRenderingPreviewRunner | Runs the Get Rendering Preview Pipeline.
 | GetXslRenderingPreview | Get Rendering Preview Field.


GetDefaultRenderingPreview Class

GetDefaultRenderingPreview Class
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetDefaultRenderingPreview
Get Rendering Preview Field.
Declaration Syntax
C#
public class GetDefaultRenderingPreview : GetRenderingPreviewProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetDefaultRenderingPreview()()() | Initializes a new instance of the GetDefaultRenderingPreview class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetRenderingPreviewArgs) | Processes the specified arguments. (Overrides GetRenderingPreviewProcessor.Process(GetRenderingPreviewArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | GetRenderingPreviewProcessor
 |  | GetDefaultRenderingPreview


GetDefaultRenderingPreview Constructor

GetDefaultRenderingPreview Constructor
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetDefaultRenderingPreview ► GetDefaultRenderingPreview()()()
Initializes a new instance of the GetDefaultRenderingPreview class
Declaration Syntax
C#
public GetDefaultRenderingPreview()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetDefaultRenderingPreview ► Process(GetRenderingPreviewArgs)
Processes the specified arguments.
Declaration Syntax
C#
public override void Process(
    GetRenderingPreviewArgs args
)
Parameters
args (GetRenderingPreviewArgs)
The arguments.


GetRenderingPreviewArgs Class

GetRenderingPreviewArgs Class
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewArgs
The arguments for the Get Rendering Preview Pipeline
Declaration Syntax
C#
[SerializableAttribute]
public class GetRenderingPreviewArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetRenderingPreviewArgs(Item, Item) | Initializes a new instance of the GetRenderingPreviewArgs class.
 | GetRenderingPreviewArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetRenderingPreviewArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | RenderingItem | Gets the source item.
 | Result | Gets or sets the result.
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | SourceItem | Gets the source item.
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | GetRenderingPreviewArgs


GetRenderingPreviewArgs Constructor

GetRenderingPreviewArgs Constructor
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewArgs ► GetRenderingPreviewArgs()()()
Members
Icon | Member | Description
 | GetRenderingPreviewArgs(Item, Item) | Initializes a new instance of the GetRenderingPreviewArgs class.
 | GetRenderingPreviewArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetRenderingPreviewArgs class.


GetRenderingPreviewArgs Constructor (renderingItem, sourceItem)

GetRenderingPreviewArgs Constructor (renderingItem, sourceItem)
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewArgs ► GetRenderingPreviewArgs(Item, Item)
Initializes a new instance of the GetRenderingPreviewArgs class.
Declaration Syntax
C#
public GetRenderingPreviewArgs(
    Item renderingItem,
    Item sourceItem
)
Parameters
renderingItem (Item)
The rendering item.
sourceItem (Item)
The source item.


GetRenderingPreviewArgs Constructor (info, context)

GetRenderingPreviewArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewArgs ► GetRenderingPreviewArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the GetRenderingPreviewArgs class.
Declaration Syntax
C#
protected GetRenderingPreviewArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


RenderingItem Property

RenderingItem Property
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewArgs ► RenderingItem
Gets the source item.
Declaration Syntax
C#
public Item RenderingItem { get; }
Value
The source item.


Result Property

Result Property
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewArgs ► Result
Gets or sets the result.
Declaration Syntax
C#
public string Result { get; set; }
Value
The result.


SourceItem Property

SourceItem Property
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewArgs ► SourceItem
Gets the source item.
Declaration Syntax
C#
public Item SourceItem { get; }
Value
The source item.


GetRenderingPreviewField Class

GetRenderingPreviewField Class
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewField
Get Rendering Preview Field.
Declaration Syntax
C#
public class GetRenderingPreviewField : GetRenderingPreviewProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetRenderingPreviewField()()() | Initializes a new instance of the GetRenderingPreviewField class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetRenderingPreviewArgs) | Processes the specified args. (Overrides GetRenderingPreviewProcessor.Process(GetRenderingPreviewArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | GetRenderingPreviewProcessor
 |  | GetRenderingPreviewField


GetRenderingPreviewField Constructor

GetRenderingPreviewField Constructor
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewField ► GetRenderingPreviewField()()()
Initializes a new instance of the GetRenderingPreviewField class
Declaration Syntax
C#
public GetRenderingPreviewField()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewField ► Process(GetRenderingPreviewArgs)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    GetRenderingPreviewArgs args
)
Parameters
args (GetRenderingPreviewArgs)
The args.


GetRenderingPreviewProcessor Class

GetRenderingPreviewProcessor Class
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewProcessor
ExpandInitialFieldValueProcessor class
Declaration Syntax
C#
public abstract class GetRenderingPreviewProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetRenderingPreviewProcessor()()() | Initializes a new instance of the GetRenderingPreviewProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetRenderingPreviewArgs) | Processes the specified args.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | GetRenderingPreviewProcessor
 |  | GetDefaultRenderingPreview
 |  | GetRenderingPreviewField
 |  | GetXslRenderingPreview


GetRenderingPreviewProcessor Constructor

GetRenderingPreviewProcessor Constructor
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewProcessor ► GetRenderingPreviewProcessor()()()
Initializes a new instance of the GetRenderingPreviewProcessor class
Declaration Syntax
C#
protected GetRenderingPreviewProcessor()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewProcessor ► Process(GetRenderingPreviewArgs)
Processes the specified args.
Declaration Syntax
C#
public abstract void Process(
    GetRenderingPreviewArgs args
)
Parameters
args (GetRenderingPreviewArgs)
The args.


GetRenderingPreviewRunner Class

GetRenderingPreviewRunner Class
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewRunner
Runs the Get Rendering Preview Pipeline.
Declaration Syntax
C#
public static class GetRenderingPreviewRunner
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Run(Item) | Runs the specified rendering item.
 | Run(Item, Item) | Runs the specified rendering item.
Inheritance Hierarchy
Object
GetRenderingPreviewRunner


Run Method

Run Method
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewRunner ► Run()()()
Members
Icon | Member | Description
 | Run(Item) | Runs the specified rendering item.
 | Run(Item, Item) | Runs the specified rendering item.


Run Method (renderingItem)

Run Method (renderingItem)
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewRunner ► Run(Item)
Runs the specified rendering item.
Declaration Syntax
C#
public static string Run(
    Item renderingItem
)
Parameters
renderingItem (Item)
The rendering item.
Return Value


Run Method (renderingItem, sourceItem)

Run Method (renderingItem, sourceItem)
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetRenderingPreviewRunner ► Run(Item, Item)
Runs the specified rendering item.
Declaration Syntax
C#
public static string Run(
    Item renderingItem,
    Item sourceItem
)
Parameters
renderingItem (Item)
The rendering item.
sourceItem (Item)
The source item.
Return Value


GetXslRenderingPreview Class

GetXslRenderingPreview Class
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetXslRenderingPreview
Get Rendering Preview Field.
Declaration Syntax
C#
public class GetXslRenderingPreview : GetRenderingPreviewProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetXslRenderingPreview()()() | Initializes a new instance of the GetXslRenderingPreview class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetRenderingPreviewArgs) | Processes the specified args. (Overrides GetRenderingPreviewProcessor.Process(GetRenderingPreviewArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | GetRenderingPreviewProcessor
 |  | GetXslRenderingPreview


GetXslRenderingPreview Constructor

GetXslRenderingPreview Constructor
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetXslRenderingPreview ► GetXslRenderingPreview()()()
Initializes a new instance of the GetXslRenderingPreview class
Declaration Syntax
C#
public GetXslRenderingPreview()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.GetRenderingPreview ► GetXslRenderingPreview ► Process(GetRenderingPreviewArgs)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    GetRenderingPreviewArgs args
)
Parameters
args (GetRenderingPreviewArgs)
The args.


Sitecore.Pipelines.HealthMonitor Namespace

Sitecore.Pipelines.HealthMonitor Namespace
Namespaces ► Sitecore.Pipelines.HealthMonitor
Declaration Syntax
C#
namespace Sitecore.Pipelines.HealthMonitor
Types
All Types Classes
Icon | Type | Description
 | HealthMonitor | Main processor container for the HealthMonitor pipeline.


HealthMonitor Class

HealthMonitor Class
Namespaces ► Sitecore.Pipelines.HealthMonitor ► HealthMonitor
Main processor container for the HealthMonitor pipeline.
Declaration Syntax
C#
public class HealthMonitor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HealthMonitor()()() | Initializes a new instance of the HealthMonitor class
 | AddCounter(XmlNode) | Adds the counter.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LogCacheStatus(PipelineArgs) | Logs the cache status.
 | LogCounterStatus(PipelineArgs) | Logs the counter status.
 | LogMemoryStatus(PipelineArgs) | Logs the memory status.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HealthMonitor


HealthMonitor Constructor

HealthMonitor Constructor
Namespaces ► Sitecore.Pipelines.HealthMonitor ► HealthMonitor ► HealthMonitor()()()
Initializes a new instance of the HealthMonitor class
Declaration Syntax
C#
public HealthMonitor()


AddCounter Method (configNode)

AddCounter Method (configNode)
Namespaces ► Sitecore.Pipelines.HealthMonitor ► HealthMonitor ► AddCounter(XmlNode)
Adds the counter.
Declaration Syntax
C#
public virtual void AddCounter(
    XmlNode configNode
)
Parameters
configNode (XmlNode)
The config node.


LogCacheStatus Method (args)

LogCacheStatus Method (args)
Namespaces ► Sitecore.Pipelines.HealthMonitor ► HealthMonitor ► LogCacheStatus(PipelineArgs)
Logs the cache status.
Declaration Syntax
C#
public virtual void LogCacheStatus(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The pipeline args.


LogCounterStatus Method (args)

LogCounterStatus Method (args)
Namespaces ► Sitecore.Pipelines.HealthMonitor ► HealthMonitor ► LogCounterStatus(PipelineArgs)
Logs the counter status.
Declaration Syntax
C#
public virtual void LogCounterStatus(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The args.


LogMemoryStatus Method (args)

LogMemoryStatus Method (args)
Namespaces ► Sitecore.Pipelines.HealthMonitor ► HealthMonitor ► LogMemoryStatus(PipelineArgs)
Logs the memory status.
Declaration Syntax
C#
public virtual void LogMemoryStatus(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The pipeline args.


Sitecore.Pipelines.HttpRequest Namespace

Sitecore.Pipelines.HttpRequest Namespace
Namespaces ► Sitecore.Pipelines.HttpRequest
Declaration Syntax
C#
namespace Sitecore.Pipelines.HttpRequest
Types
All Types Classes Enumerations
Icon | Type | Description
 | AliasResolver | Resolves aliases.
 | BeginDiagnostics | Starts the diagnostics tools.
 | CustomHandlers | Filters Url extensions.
 | DatabaseResolver | Resolves the database.
 | DefaultResolver | Resolves the default item.
 | DeviceResolver | Resolves the device.
 | DynamicLinkResolver | DynamicLinkResolver class
 | EndDiagnostics | Ends the diagnostics tools.
 | ExecuteRequest | Executes the request.
 | FileResolver | Resolves files
 | FilterUrlExtensions | Obsolete. Filters Url extensions. Obsolete.
 | HttpRequestArgs | Argument class for HttpRequest pipeline
 | HttpRequestProcessor | HttpRequestProcessor class
 | HttpRequestType | Defines the phase of the Http request.
 | IgnoreList | Determines if the Url is ignored by Sitecore.
 | ItemResolver | Resolves the current item from the query string path.
 | LanguageResolver | Resolves the language.
 | LayoutResolver | Resolves the layout corresponding to the Url.
 | QueryStringResolver | Resolves the query string.
 | ResizePicture | Resizes the image.
 | SaveFormAction | Saves the form action.
 | SiteResolver | Resolves the current site.
 | StartMeasurements | Processor used for initiating timing of HTTP requests.
 | StopMeasurements | Processor used for stopping and evaluating timing of HTTP requests.
 | UserResolver | Resolves the database.


AliasResolver Class

AliasResolver Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► AliasResolver
Resolves aliases.
Declaration Syntax
C#
public class AliasResolver : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AliasResolver()()() | Initializes a new instance of the AliasResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | AliasResolver


AliasResolver Constructor

AliasResolver Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► AliasResolver ► AliasResolver()()()
Initializes a new instance of the AliasResolver class
Declaration Syntax
C#
public AliasResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► AliasResolver ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The arguments.


BeginDiagnostics Class

BeginDiagnostics Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► BeginDiagnostics
Starts the diagnostics tools.
Declaration Syntax
C#
public class BeginDiagnostics : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BeginDiagnostics()()() | Initializes a new instance of the BeginDiagnostics class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | BeginDiagnostics


BeginDiagnostics Constructor

BeginDiagnostics Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► BeginDiagnostics ► BeginDiagnostics()()()
Initializes a new instance of the BeginDiagnostics class
Declaration Syntax
C#
public BeginDiagnostics()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► BeginDiagnostics ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The args.


CustomHandlers Class

CustomHandlers Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► CustomHandlers
Filters Url extensions.
Declaration Syntax
C#
public class CustomHandlers : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CustomHandlers()()() | Initializes a new instance of the CustomHandlers class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Processes the specified args. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | CustomHandlers


CustomHandlers Constructor

CustomHandlers Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► CustomHandlers ► CustomHandlers()()()
Initializes a new instance of the CustomHandlers class
Declaration Syntax
C#
public CustomHandlers()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► CustomHandlers ► Process(HttpRequestArgs)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The args.


DatabaseResolver Class

DatabaseResolver Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► DatabaseResolver
Resolves the database.
Declaration Syntax
C#
public class DatabaseResolver : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DatabaseResolver()()() | Initializes a new instance of the DatabaseResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | DatabaseResolver


DatabaseResolver Constructor

DatabaseResolver Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► DatabaseResolver ► DatabaseResolver()()()
Initializes a new instance of the DatabaseResolver class
Declaration Syntax
C#
public DatabaseResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► DatabaseResolver ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The arguments.


DefaultResolver Class

DefaultResolver Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► DefaultResolver
Resolves the default item.
Declaration Syntax
C#
public class DefaultResolver : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DefaultResolver()()() | Initializes a new instance of the DefaultResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | DefaultResolver


DefaultResolver Constructor

DefaultResolver Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► DefaultResolver ► DefaultResolver()()()
Initializes a new instance of the DefaultResolver class
Declaration Syntax
C#
public DefaultResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► DefaultResolver ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The arguments.


DeviceResolver Class

DeviceResolver Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► DeviceResolver
Resolves the device.
Declaration Syntax
C#
public class DeviceResolver : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DeviceResolver()()() | Initializes a new instance of the DeviceResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | DeviceResolver


DeviceResolver Constructor

DeviceResolver Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► DeviceResolver ► DeviceResolver()()()
Initializes a new instance of the DeviceResolver class
Declaration Syntax
C#
public DeviceResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► DeviceResolver ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The args.


DynamicLinkResolver Class

DynamicLinkResolver Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► DynamicLinkResolver
DynamicLinkResolver class
Declaration Syntax
C#
public class DynamicLinkResolver : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DynamicLinkResolver()()() | Initializes a new instance of the DynamicLinkResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | DynamicLinkResolver


DynamicLinkResolver Constructor

DynamicLinkResolver Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► DynamicLinkResolver ► DynamicLinkResolver()()()
Initializes a new instance of the DynamicLinkResolver class
Declaration Syntax
C#
public DynamicLinkResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► DynamicLinkResolver ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The arguments.


EndDiagnostics Class

EndDiagnostics Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► EndDiagnostics
Ends the diagnostics tools.
Declaration Syntax
C#
public class EndDiagnostics : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EndDiagnostics()()() | Initializes a new instance of the EndDiagnostics class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | EndDiagnostics


EndDiagnostics Constructor

EndDiagnostics Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► EndDiagnostics ► EndDiagnostics()()()
Initializes a new instance of the EndDiagnostics class
Declaration Syntax
C#
public EndDiagnostics()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► EndDiagnostics ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The arguments.


ExecuteRequest Class

ExecuteRequest Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► ExecuteRequest
Executes the request.
Declaration Syntax
C#
public class ExecuteRequest : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExecuteRequest()()() | Initializes a new instance of the ExecuteRequest class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PerformRedirect(String) | Redirects request to the specified URL.
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | RedirectOnItemNotFound(String) | Preforms redirect on 'item not found' condition.
 | RedirectOnLayoutNotFound(String) | Redirects on 'layout not found' condition.
 | RedirectOnNoAccess(String) | Redirects on 'no access' condition.
 | RedirectOnSiteAccessDenied(String) | Redirects the on 'site access denied' condition.
 | RedirectToLoginPage(String) | Redirects to login page.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | ExecuteRequest


ExecuteRequest Constructor

ExecuteRequest Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► ExecuteRequest ► ExecuteRequest()()()
Initializes a new instance of the ExecuteRequest class
Declaration Syntax
C#
public ExecuteRequest()


PerformRedirect Method (url)

PerformRedirect Method (url)
Namespaces ► Sitecore.Pipelines.HttpRequest ► ExecuteRequest ► PerformRedirect(String)
Redirects request to the specified URL.
Declaration Syntax
C#
protected virtual void PerformRedirect(
    string url
)
Parameters
url (String)
The URL.


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► ExecuteRequest ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The arguments.


RedirectOnItemNotFound Method (url)

RedirectOnItemNotFound Method (url)
Namespaces ► Sitecore.Pipelines.HttpRequest ► ExecuteRequest ► RedirectOnItemNotFound(String)
Preforms redirect on 'item not found' condition.
Declaration Syntax
C#
protected virtual void RedirectOnItemNotFound(
    string url
)
Parameters
url (String)
The URL.


RedirectOnLayoutNotFound Method (url)

RedirectOnLayoutNotFound Method (url)
Namespaces ► Sitecore.Pipelines.HttpRequest ► ExecuteRequest ► RedirectOnLayoutNotFound(String)
Redirects on 'layout not found' condition.
Declaration Syntax
C#
protected virtual void RedirectOnLayoutNotFound(
    string url
)
Parameters
url (String)
The URL.


RedirectOnNoAccess Method (url)

RedirectOnNoAccess Method (url)
Namespaces ► Sitecore.Pipelines.HttpRequest ► ExecuteRequest ► RedirectOnNoAccess(String)
Redirects on 'no access' condition.
Declaration Syntax
C#
protected virtual void RedirectOnNoAccess(
    string url
)
Parameters
url (String)
The URL.


RedirectOnSiteAccessDenied Method (url)

RedirectOnSiteAccessDenied Method (url)
Namespaces ► Sitecore.Pipelines.HttpRequest ► ExecuteRequest ► RedirectOnSiteAccessDenied(String)
Redirects the on 'site access denied' condition.
Declaration Syntax
C#
protected virtual void RedirectOnSiteAccessDenied(
    string url
)
Parameters
url (String)
The URL.


RedirectToLoginPage Method (url)

RedirectToLoginPage Method (url)
Namespaces ► Sitecore.Pipelines.HttpRequest ► ExecuteRequest ► RedirectToLoginPage(String)
Redirects to login page.
Declaration Syntax
C#
protected virtual void RedirectToLoginPage(
    string url
)
Parameters
url (String)
The URL.


FileResolver Class

FileResolver Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► FileResolver
Resolves files
Declaration Syntax
C#
public class FileResolver : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FileResolver()()() | Initializes a new instance of the FileResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | FileResolver


FileResolver Constructor

FileResolver Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► FileResolver ► FileResolver()()()
Initializes a new instance of the FileResolver class
Declaration Syntax
C#
public FileResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► FileResolver ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The arguments.


FilterUrlExtensions Class

FilterUrlExtensions Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► FilterUrlExtensions
Filters Url extensions. Obsolete.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public class FilterUrlExtensions : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FilterUrlExtensions(String, String, String, String) | Initializes a new instance of the FilterUrlExtensions class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Processes the specified args. Obsolete method. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | FilterUrlExtensions


FilterUrlExtensions Constructor (allowed, blocked, streamFiles, doNotStreamFiles)

FilterUrlExtensions Constructor (allowed, blocked, streamFiles, doNotStreamFiles)
Namespaces ► Sitecore.Pipelines.HttpRequest ► FilterUrlExtensions ► FilterUrlExtensions(String, String, String, String)
Initializes a new instance of the FilterUrlExtensions class.
Declaration Syntax
C#
public FilterUrlExtensions(
    string allowed,
    string blocked,
    string streamFiles,
    string doNotStreamFiles
)
Parameters
allowed (String)
blocked (String)
streamFiles (String)
doNotStreamFiles (String)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► FilterUrlExtensions ► Process(HttpRequestArgs)
Processes the specified args. Obsolete method.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The args.


HttpRequestArgs Class

HttpRequestArgs Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs
Argument class for HttpRequest pipeline
Declaration Syntax
C#
[SerializableAttribute]
public class HttpRequestArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HttpRequestArgs(HttpContext, HttpRequestType) | Initializes a new instance of the HttpRequestArgs class.
 | HttpRequestArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the HttpRequestArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | ApplySecurity(Item) | Applies the security.
 | Context | Gets the context.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(ID) | Gets the item.
 | GetItem(String) | Gets the item.
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initialize. (Overrides PipelineArgs.Initialize()()().)
 | LocalPath | Gets the local path.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | PermissionDenied | Gets or sets a value indicating whether [permission denied].
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | RequestType | Is this a BeginRequest event? If not, it is an EndRequest event
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | StartPath | Gets or sets the start path.
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Url | Gets the request URL.
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | HttpRequestArgs


HttpRequestArgs Constructor

HttpRequestArgs Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► HttpRequestArgs()()()
Members
Icon | Member | Description
 | HttpRequestArgs(HttpContext, HttpRequestType) | Initializes a new instance of the HttpRequestArgs class.
 | HttpRequestArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the HttpRequestArgs class.


HttpRequestArgs Constructor (info, context)

HttpRequestArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► HttpRequestArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the HttpRequestArgs class.
Declaration Syntax
C#
protected HttpRequestArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


HttpRequestArgs Constructor (context, requestType)

HttpRequestArgs Constructor (context, requestType)
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► HttpRequestArgs(HttpContext, HttpRequestType)
Initializes a new instance of the HttpRequestArgs class.
Declaration Syntax
C#
public HttpRequestArgs(
    HttpContext context,
    HttpRequestType requestType
)
Parameters
context (HttpContext)
The context.
requestType (HttpRequestType)
Type of the request.


ApplySecurity Method (item)

ApplySecurity Method (item)
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► ApplySecurity(Item)
Applies the security.
Declaration Syntax
C#
public Item ApplySecurity(
    Item item
)
Parameters
item (Item)
The item.
Return Value


Context Property

Context Property
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► Context
Gets the context.
Declaration Syntax
C#
public HttpContext Context { get; }
Value
The context.


GetItem Method

GetItem Method
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► GetItem()()()
Members
Icon | Member | Description
 | GetItem(ID) | Gets the item.
 | GetItem(String) | Gets the item.


GetItem Method (itemID)

GetItem Method (itemID)
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► GetItem(ID)
Gets the item.
Declaration Syntax
C#
public Item GetItem(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value


GetItem Method (path)

GetItem Method (path)
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► GetItem(String)
Gets the item.
Declaration Syntax
C#
public Item GetItem(
    string path
)
Parameters
path (String)
The path.
Return Value


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Initialize Method

Initialize Method
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► Initialize()()()
Initialize.
Declaration Syntax
C#
protected internal override void Initialize()


LocalPath Property

LocalPath Property
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► LocalPath
Gets the local path.
Declaration Syntax
C#
public string LocalPath { get; }
Value
The local path.


PermissionDenied Property

PermissionDenied Property
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► PermissionDenied
Gets or sets a value indicating whether [permission denied].
Declaration Syntax
C#
public bool PermissionDenied { get; set; }
Value
true if [permission denied]; otherwise, false.


RequestType Property

RequestType Property
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► RequestType
Is this a BeginRequest event? If not, it is an EndRequest event
Declaration Syntax
C#
public HttpRequestType RequestType { get; }
Value
The type of the request.


StartPath Property

StartPath Property
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► StartPath
Gets or sets the start path.
Declaration Syntax
C#
public string StartPath { get; set; }
Value
The start path.


Url Property

Url Property
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestArgs ► Url
Gets the request URL.
Declaration Syntax
C#
public RequestUrl Url { get; }
Value
The URL.


HttpRequestProcessor Class

HttpRequestProcessor Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestProcessor
HttpRequestProcessor class
Declaration Syntax
C#
public abstract class HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HttpRequestProcessor()()() | Initializes a new instance of the HttpRequestProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Processes the specified args.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | EndAnalytics
 |  | StartDiagnostics
 |  | AliasResolver
 |  | BeginDiagnostics
 |  | CustomHandlers
 |  | DatabaseResolver
 |  | DefaultResolver
 |  | DeviceResolver
 |  | DynamicLinkResolver
 |  | EndDiagnostics
 |  | ExecuteRequest
 |  | FileResolver
 |  | FilterUrlExtensions
 |  | IgnoreList
 |  | ItemResolver
 |  | LanguageResolver
 |  | LayoutResolver
 |  | QueryStringResolver
 |  | ResizePicture
 |  | SaveFormAction
 |  | SiteResolver
 |  | StartMeasurements
 |  | StopMeasurements
 |  | UserResolver


HttpRequestProcessor Constructor

HttpRequestProcessor Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestProcessor ► HttpRequestProcessor()()()
Initializes a new instance of the HttpRequestProcessor class
Declaration Syntax
C#
protected HttpRequestProcessor()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestProcessor ► Process(HttpRequestArgs)
Processes the specified args.
Declaration Syntax
C#
public abstract void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The args.


HttpRequestType Enumeration

HttpRequestType Enumeration
Namespaces ► Sitecore.Pipelines.HttpRequest ► HttpRequestType
Defines the phase of the Http request.
Declaration Syntax
C#
public enum HttpRequestType
Members
Member | Description
Begin | Begin.
End | End.


IgnoreList Class

IgnoreList Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► IgnoreList
Determines if the Url is ignored by Sitecore.
Declaration Syntax
C#
public class IgnoreList : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IgnoreList()()() | Initializes a new instance of the IgnoreList class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | IgnoreList


IgnoreList Constructor

IgnoreList Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► IgnoreList ► IgnoreList()()()
Initializes a new instance of the IgnoreList class
Declaration Syntax
C#
public IgnoreList()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► IgnoreList ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The arguments.


ItemResolver Class

ItemResolver Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► ItemResolver
Resolves the current item from the query string path.
Declaration Syntax
C#
public class ItemResolver : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemResolver()()() | Initializes a new instance of the ItemResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | ItemResolver


ItemResolver Constructor

ItemResolver Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► ItemResolver ► ItemResolver()()()
Initializes a new instance of the ItemResolver class
Declaration Syntax
C#
public ItemResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► ItemResolver ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The arguments.


LanguageResolver Class

LanguageResolver Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► LanguageResolver
Resolves the language.
Declaration Syntax
C#
public class LanguageResolver : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LanguageResolver()()() | Initializes a new instance of the LanguageResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | LanguageResolver


LanguageResolver Constructor

LanguageResolver Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► LanguageResolver ► LanguageResolver()()()
Initializes a new instance of the LanguageResolver class
Declaration Syntax
C#
public LanguageResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► LanguageResolver ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The arguments.


LayoutResolver Class

LayoutResolver Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► LayoutResolver
Resolves the layout corresponding to the Url.
Declaration Syntax
C#
public class LayoutResolver : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LayoutResolver()()() | Initializes a new instance of the LayoutResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | LayoutResolver


LayoutResolver Constructor

LayoutResolver Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► LayoutResolver ► LayoutResolver()()()
Initializes a new instance of the LayoutResolver class
Declaration Syntax
C#
public LayoutResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► LayoutResolver ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The arguments.


QueryStringResolver Class

QueryStringResolver Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► QueryStringResolver
Resolves the query string.
Declaration Syntax
C#
public class QueryStringResolver : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | QueryStringResolver()()() | Initializes a new instance of the QueryStringResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | QueryStringResolver


QueryStringResolver Constructor

QueryStringResolver Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► QueryStringResolver ► QueryStringResolver()()()
Initializes a new instance of the QueryStringResolver class
Declaration Syntax
C#
public QueryStringResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► QueryStringResolver ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The arguments.


ResizePicture Class

ResizePicture Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► ResizePicture
Resizes the image.
Declaration Syntax
C#
public class ResizePicture : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ResizePicture()()() | Initializes a new instance of the ResizePicture class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | ResizePicture


ResizePicture Constructor

ResizePicture Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► ResizePicture ► ResizePicture()()()
Initializes a new instance of the ResizePicture class
Declaration Syntax
C#
public ResizePicture()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► ResizePicture ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The arguments.


SaveFormAction Class

SaveFormAction Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► SaveFormAction
Saves the form action.
Declaration Syntax
C#
public class SaveFormAction : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SaveFormAction()()() | Initializes a new instance of the SaveFormAction class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Processes the specified args. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | SaveFormAction


SaveFormAction Constructor

SaveFormAction Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► SaveFormAction ► SaveFormAction()()()
Initializes a new instance of the SaveFormAction class
Declaration Syntax
C#
public SaveFormAction()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► SaveFormAction ► Process(HttpRequestArgs)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The args.


SiteResolver Class

SiteResolver Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► SiteResolver
Resolves the current site.
Declaration Syntax
C#
public class SiteResolver : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SiteResolver()()() | Initializes a new instance of the SiteResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFilePath(HttpRequestArgs, SiteContext) | Gets the file path.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemPath(HttpRequestArgs, SiteContext) | Gets the item path.
 | GetPath(String, String, SiteContext) | Gets the path.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ResolveSiteContext(HttpRequestArgs) | Resolves the site context.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdatePaths(HttpRequestArgs, SiteContext) | Updates the paths.
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | SiteResolver


SiteResolver Constructor

SiteResolver Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► SiteResolver ► SiteResolver()()()
Initializes a new instance of the SiteResolver class
Declaration Syntax
C#
public SiteResolver()


GetFilePath Method (args, context)

GetFilePath Method (args, context)
Namespaces ► Sitecore.Pipelines.HttpRequest ► SiteResolver ► GetFilePath(HttpRequestArgs, SiteContext)
Gets the file path.
Declaration Syntax
C#
protected string GetFilePath(
    HttpRequestArgs args,
    SiteContext context
)
Parameters
args (HttpRequestArgs)
The args.
context (SiteContext)
The context.
Return Value


GetItemPath Method (args, context)

GetItemPath Method (args, context)
Namespaces ► Sitecore.Pipelines.HttpRequest ► SiteResolver ► GetItemPath(HttpRequestArgs, SiteContext)
Gets the item path.
Declaration Syntax
C#
protected string GetItemPath(
    HttpRequestArgs args,
    SiteContext context
)
Parameters
args (HttpRequestArgs)
The args.
context (SiteContext)
The context.
Return Value


GetPath Method (basePath, path, context)

GetPath Method (basePath, path, context)
Namespaces ► Sitecore.Pipelines.HttpRequest ► SiteResolver ► GetPath(String, String, SiteContext)
Gets the path.
Declaration Syntax
C#
protected string GetPath(
    string basePath,
    string path,
    SiteContext context
)
Parameters
basePath (String)
The base path.
path (String)
The path.
context (SiteContext)
The context.
Return Value


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► SiteResolver ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The args.


ResolveSiteContext Method (args)

ResolveSiteContext Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► SiteResolver ► ResolveSiteContext(HttpRequestArgs)
Resolves the site context.
Declaration Syntax
C#
protected virtual SiteContext ResolveSiteContext(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The args.
Return Value


UpdatePaths Method (args, site)

UpdatePaths Method (args, site)
Namespaces ► Sitecore.Pipelines.HttpRequest ► SiteResolver ► UpdatePaths(HttpRequestArgs, SiteContext)
Updates the paths.
Declaration Syntax
C#
protected virtual void UpdatePaths(
    HttpRequestArgs args,
    SiteContext site
)
Parameters
args (HttpRequestArgs)
The args.
site (SiteContext)
The site.


StartMeasurements Class

StartMeasurements Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► StartMeasurements
Processor used for initiating timing of HTTP requests.
Declaration Syntax
C#
public class StartMeasurements : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | StartMeasurements()()() | Initializes a new instance of the StartMeasurements class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Process method that starts the timer. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | StartMeasurements


StartMeasurements Constructor

StartMeasurements Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► StartMeasurements ► StartMeasurements()()()
Initializes a new instance of the StartMeasurements class
Declaration Syntax
C#
public StartMeasurements()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► StartMeasurements ► Process(HttpRequestArgs)
Process method that starts the timer.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The args.


StopMeasurements Class

StopMeasurements Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► StopMeasurements
Processor used for stopping and evaluating timing of HTTP requests.
Declaration Syntax
C#
public class StopMeasurements : HttpRequestProcessor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StopMeasurements()()() | Initializes a new instance of the StopMeasurements class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemThreshold | Gets or sets the 'no. of items' threshold.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MemoryThreshold | Gets or sets the 'memory used' threshold.
 | Process(HttpRequestArgs) | Process method that starts the timer. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | TimingThreshold | Gets or sets the timing threshold.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | StopMeasurements


StopMeasurements Constructor

StopMeasurements Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► StopMeasurements ► StopMeasurements()()()
Initializes a new instance of the StopMeasurements class
Declaration Syntax
C#
public StopMeasurements()


ItemThreshold Property

ItemThreshold Property
Namespaces ► Sitecore.Pipelines.HttpRequest ► StopMeasurements ► ItemThreshold
Gets or sets the 'no. of items' threshold.
Declaration Syntax
C#
public long ItemThreshold { get; set; }
Value
The 'no. of items' threshold.


MemoryThreshold Property

MemoryThreshold Property
Namespaces ► Sitecore.Pipelines.HttpRequest ► StopMeasurements ► MemoryThreshold
Gets or sets the 'memory used' threshold.
Declaration Syntax
C#
public long MemoryThreshold { get; set; }
Value
The 'memory used' threshold.


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► StopMeasurements ► Process(HttpRequestArgs)
Process method that starts the timer.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The args.


TimingThreshold Property

TimingThreshold Property
Namespaces ► Sitecore.Pipelines.HttpRequest ► StopMeasurements ► TimingThreshold
Gets or sets the timing threshold.
Declaration Syntax
C#
public long TimingThreshold { get; set; }
Value
The timing threshold.


UserResolver Class

UserResolver Class
Namespaces ► Sitecore.Pipelines.HttpRequest ► UserResolver
Resolves the database.
Declaration Syntax
C#
public class UserResolver : HttpRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UserResolver()()() | Initializes a new instance of the UserResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) | Runs the processor. (Overrides HttpRequestProcessor.Process(HttpRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | HttpRequestProcessor
 |  | UserResolver


UserResolver Constructor

UserResolver Constructor
Namespaces ► Sitecore.Pipelines.HttpRequest ► UserResolver ► UserResolver()()()
Initializes a new instance of the UserResolver class
Declaration Syntax
C#
public UserResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.HttpRequest ► UserResolver ► Process(HttpRequestArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)
The arguments.


Sitecore.Pipelines.Loader Namespace

Sitecore.Pipelines.Loader Namespace
Namespaces ► Sitecore.Pipelines.Loader
Declaration Syntax
C#
namespace Sitecore.Pipelines.Loader
Types
All Types Classes
Icon | Type | Description
 | EnsureAnonymousUsers | EnsureAnonymousUsers class
 | InitializeAgilityPack | Initializes the html agility pack, setting the default settings.
 | InitializeHeartbeat | Initializes the heartbeat.
 | InitializeManagers | Processor used for initializing static manager classes.
 | InitializeScheduler | Initializes the scheduler.
 | Loader | Sitecore loader.
 | LoadHooks | Loads hooks.
 | SetGlobals | Loads the global settings.
 | ShowHistory | Shows the history in the log file.
 | ShowVersion | Shows the version in the log file.


EnsureAnonymousUsers Class

EnsureAnonymousUsers Class
Namespaces ► Sitecore.Pipelines.Loader ► EnsureAnonymousUsers
EnsureAnonymousUsers class
Declaration Syntax
C#
public class EnsureAnonymousUsers
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EnsureAnonymousUsers()()() | Initializes a new instance of the EnsureAnonymousUsers class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PipelineArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
EnsureAnonymousUsers


EnsureAnonymousUsers Constructor

EnsureAnonymousUsers Constructor
Namespaces ► Sitecore.Pipelines.Loader ► EnsureAnonymousUsers ► EnsureAnonymousUsers()()()
Initializes a new instance of the EnsureAnonymousUsers class
Declaration Syntax
C#
public EnsureAnonymousUsers()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Loader ► EnsureAnonymousUsers ► Process(PipelineArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The arguments.


InitializeAgilityPack Class

InitializeAgilityPack Class
Namespaces ► Sitecore.Pipelines.Loader ► InitializeAgilityPack
Initializes the html agility pack, setting the default settings.
Declaration Syntax
C#
public class InitializeAgilityPack
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InitializeAgilityPack()()() | Initializes a new instance of the InitializeAgilityPack class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PipelineArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InitializeAgilityPack


InitializeAgilityPack Constructor

InitializeAgilityPack Constructor
Namespaces ► Sitecore.Pipelines.Loader ► InitializeAgilityPack ► InitializeAgilityPack()()()
Initializes a new instance of the InitializeAgilityPack class
Declaration Syntax
C#
public InitializeAgilityPack()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Loader ► InitializeAgilityPack ► Process(PipelineArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The arguments.


InitializeHeartbeat Class

InitializeHeartbeat Class
Namespaces ► Sitecore.Pipelines.Loader ► InitializeHeartbeat
Initializes the heartbeat.
Declaration Syntax
C#
public class InitializeHeartbeat
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InitializeHeartbeat()()() | Initializes a new instance of the InitializeHeartbeat class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PipelineArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InitializeHeartbeat


InitializeHeartbeat Constructor

InitializeHeartbeat Constructor
Namespaces ► Sitecore.Pipelines.Loader ► InitializeHeartbeat ► InitializeHeartbeat()()()
Initializes a new instance of the InitializeHeartbeat class
Declaration Syntax
C#
public InitializeHeartbeat()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Loader ► InitializeHeartbeat ► Process(PipelineArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The arguments.


InitializeManagers Class

InitializeManagers Class
Namespaces ► Sitecore.Pipelines.Loader ► InitializeManagers
Processor used for initializing static manager classes.
Declaration Syntax
C#
public class InitializeManagers
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InitializeManagers()()() | Initializes a new instance of the InitializeManagers class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PipelineArgs) | Initializes static manager classes.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InitializeManagers


InitializeManagers Constructor

InitializeManagers Constructor
Namespaces ► Sitecore.Pipelines.Loader ► InitializeManagers ► InitializeManagers()()()
Initializes a new instance of the InitializeManagers class
Declaration Syntax
C#
public InitializeManagers()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Loader ► InitializeManagers ► Process(PipelineArgs)
Initializes static manager classes.
Declaration Syntax
C#
public void Process(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The arguments.


InitializeScheduler Class

InitializeScheduler Class
Namespaces ► Sitecore.Pipelines.Loader ► InitializeScheduler
Initializes the scheduler.
Declaration Syntax
C#
public class InitializeScheduler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InitializeScheduler()()() | Initializes a new instance of the InitializeScheduler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PipelineArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InitializeScheduler


InitializeScheduler Constructor

InitializeScheduler Constructor
Namespaces ► Sitecore.Pipelines.Loader ► InitializeScheduler ► InitializeScheduler()()()
Initializes a new instance of the InitializeScheduler class
Declaration Syntax
C#
public InitializeScheduler()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Loader ► InitializeScheduler ► Process(PipelineArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The arguments.


Loader Class

Loader Class
Namespaces ► Sitecore.Pipelines.Loader ► Loader
Sitecore loader.
Declaration Syntax
C#
public sealed class Loader
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Loader()()() | Initializes a new instance of the Loader class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeSitecore()()() | Obsolete. Initializes the sitecore.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Loader


Loader Constructor

Loader Constructor
Namespaces ► Sitecore.Pipelines.Loader ► Loader ► Loader()()()
Initializes a new instance of the Loader class
Declaration Syntax
C#
public Loader()


InitializeSitecore Method

InitializeSitecore Method
Namespaces ► Sitecore.Pipelines.Loader ► Loader ► InitializeSitecore()()()
Initializes the sitecore.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated")]
public static void InitializeSitecore()


LoadHooks Class

LoadHooks Class
Namespaces ► Sitecore.Pipelines.Loader ► LoadHooks
Loads hooks.
Declaration Syntax
C#
public class LoadHooks
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LoadHooks()()() | Initializes a new instance of the LoadHooks class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PipelineArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LoadHooks


LoadHooks Constructor

LoadHooks Constructor
Namespaces ► Sitecore.Pipelines.Loader ► LoadHooks ► LoadHooks()()()
Initializes a new instance of the LoadHooks class
Declaration Syntax
C#
public LoadHooks()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Loader ► LoadHooks ► Process(PipelineArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The arguments.


SetGlobals Class

SetGlobals Class
Namespaces ► Sitecore.Pipelines.Loader ► SetGlobals
Loads the global settings.
Declaration Syntax
C#
public class SetGlobals
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SetGlobals()()() | Initializes a new instance of the SetGlobals class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PipelineArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SetGlobals


SetGlobals Constructor

SetGlobals Constructor
Namespaces ► Sitecore.Pipelines.Loader ► SetGlobals ► SetGlobals()()()
Initializes a new instance of the SetGlobals class
Declaration Syntax
C#
public SetGlobals()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Loader ► SetGlobals ► Process(PipelineArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The arguments.


ShowHistory Class

ShowHistory Class
Namespaces ► Sitecore.Pipelines.Loader ► ShowHistory
Shows the history in the log file.
Declaration Syntax
C#
public class ShowHistory
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ShowHistory()()() | Initializes a new instance of the ShowHistory class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PipelineArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ShowHistory


ShowHistory Constructor

ShowHistory Constructor
Namespaces ► Sitecore.Pipelines.Loader ► ShowHistory ► ShowHistory()()()
Initializes a new instance of the ShowHistory class
Declaration Syntax
C#
public ShowHistory()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Loader ► ShowHistory ► Process(PipelineArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The arguments.


ShowVersion Class

ShowVersion Class
Namespaces ► Sitecore.Pipelines.Loader ► ShowVersion
Shows the version in the log file.
Declaration Syntax
C#
public class ShowVersion
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShowVersion()()() | Initializes a new instance of the ShowVersion class
 | AddAssembly(String) | Adds the assembly.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PipelineArgs) | Runs the processor.
 | ShowDatabases | Gets or sets a value indicating whether the ShowVersion shows the databases.
 | ShowDebugWarning | Gets or sets a value indicating whether debug warning is enabled.
 | ShowDomains | Gets or sets a value indicating whether the ShowVersion shows the domains.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ShowVersion


ShowVersion Constructor

ShowVersion Constructor
Namespaces ► Sitecore.Pipelines.Loader ► ShowVersion ► ShowVersion()()()
Initializes a new instance of the ShowVersion class
Declaration Syntax
C#
public ShowVersion()


AddAssembly Method (filename)

AddAssembly Method (filename)
Namespaces ► Sitecore.Pipelines.Loader ► ShowVersion ► AddAssembly(String)
Adds the assembly.
Declaration Syntax
C#
public void AddAssembly(
    string filename
)
Parameters
filename (String)
The filename.


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Loader ► ShowVersion ► Process(PipelineArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The arguments.


ShowDatabases Property

ShowDatabases Property
Namespaces ► Sitecore.Pipelines.Loader ► ShowVersion ► ShowDatabases
Gets or sets a value indicating whether the ShowVersion shows the databases.
Declaration Syntax
C#
public bool ShowDatabases { get; set; }
Value
true if the ShowVersion shows the databases; otherwise, false.


ShowDebugWarning Property

ShowDebugWarning Property
Namespaces ► Sitecore.Pipelines.Loader ► ShowVersion ► ShowDebugWarning
Gets or sets a value indicating whether debug warning is enabled.
Declaration Syntax
C#
public bool ShowDebugWarning { get; set; }
Value
true if debug warning is enabled; otherwise, false.


ShowDomains Property

ShowDomains Property
Namespaces ► Sitecore.Pipelines.Loader ► ShowVersion ► ShowDomains
Gets or sets a value indicating whether the ShowVersion shows the domains.
Declaration Syntax
C#
public bool ShowDomains { get; set; }
Value
true if the ShowVersion shows the domains; otherwise, false.


Sitecore.Pipelines.LoadHtml Namespace

Sitecore.Pipelines.LoadHtml Namespace
Namespaces ► Sitecore.Pipelines.LoadHtml
Declaration Syntax
C#
namespace Sitecore.Pipelines.LoadHtml
Types
All Types Classes
Icon | Type | Description
 | ConvertToDesignTime | Converts the Html to design time Html.
 | LoadHtmlArgs | Argument class for the Load Html pipeline.
 | Parse | Parses the Html into Header, Body and Footer.


ConvertToDesignTime Class

ConvertToDesignTime Class
Namespaces ► Sitecore.Pipelines.LoadHtml ► ConvertToDesignTime
Converts the Html to design time Html.
Declaration Syntax
C#
public class ConvertToDesignTime
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConvertToDesignTime()()() | Initializes a new instance of the ConvertToDesignTime class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoadHtmlArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConvertToDesignTime


ConvertToDesignTime Constructor

ConvertToDesignTime Constructor
Namespaces ► Sitecore.Pipelines.LoadHtml ► ConvertToDesignTime ► ConvertToDesignTime()()()
Initializes a new instance of the ConvertToDesignTime class
Declaration Syntax
C#
public ConvertToDesignTime()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.LoadHtml ► ConvertToDesignTime ► Process(LoadHtmlArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LoadHtmlArgs args
)
Parameters
args (LoadHtmlArgs)
The arguments.


LoadHtmlArgs Class

LoadHtmlArgs Class
Namespaces ► Sitecore.Pipelines.LoadHtml ► LoadHtmlArgs
Argument class for the Load Html pipeline.
Declaration Syntax
C#
[SerializableAttribute]
public class LoadHtmlArgs : ClientPipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoadHtmlArgs(String, String) | Initializes a new instance of the LoadHtmlArgs class.
 | LoadHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoadHtmlArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | Body | Gets or sets the body.
 | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
 | ControlName | Gets the name of the control.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Footer | Gets or sets the footer.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
 | Header | Gets or sets the header.
 | Html | Gets or sets the HTML.
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
 | ProcessorDone()()() | A processor is done. (Overrides ClientPipelineArgs.ProcessorDone()()().)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
 | RawBody | Gets or sets the raw body.
 | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitForPostBack()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ClientPipelineArgs
 |  |  |  | LoadHtmlArgs


LoadHtmlArgs Constructor

LoadHtmlArgs Constructor
Namespaces ► Sitecore.Pipelines.LoadHtml ► LoadHtmlArgs ► LoadHtmlArgs()()()
Members
Icon | Member | Description
 | LoadHtmlArgs(String, String) | Initializes a new instance of the LoadHtmlArgs class.
 | LoadHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoadHtmlArgs class.


LoadHtmlArgs Constructor (info, context)

LoadHtmlArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.LoadHtml ► LoadHtmlArgs ► LoadHtmlArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the LoadHtmlArgs class.
Declaration Syntax
C#
protected LoadHtmlArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


LoadHtmlArgs Constructor (html, controlName)

LoadHtmlArgs Constructor (html, controlName)
Namespaces ► Sitecore.Pipelines.LoadHtml ► LoadHtmlArgs ► LoadHtmlArgs(String, String)
Initializes a new instance of the LoadHtmlArgs class.
Declaration Syntax
C#
public LoadHtmlArgs(
    string html,
    string controlName
)
Parameters
html (String)
The HTML.
controlName (String)
Name of the control.


Body Property

Body Property
Namespaces ► Sitecore.Pipelines.LoadHtml ► LoadHtmlArgs ► Body
Gets or sets the body.
Declaration Syntax
C#
public string Body { get; set; }
Value
The body.


ControlName Property

ControlName Property
Namespaces ► Sitecore.Pipelines.LoadHtml ► LoadHtmlArgs ► ControlName
Gets the name of the control.
Declaration Syntax
C#
public string ControlName { get; }
Value
The name of the control.


Footer Property

Footer Property
Namespaces ► Sitecore.Pipelines.LoadHtml ► LoadHtmlArgs ► Footer
Gets or sets the footer.
Declaration Syntax
C#
public string Footer { get; set; }
Value
The footer.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.LoadHtml ► LoadHtmlArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Header Property

Header Property
Namespaces ► Sitecore.Pipelines.LoadHtml ► LoadHtmlArgs ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Html Property

Html Property
Namespaces ► Sitecore.Pipelines.LoadHtml ► LoadHtmlArgs ► Html
Gets or sets the HTML.
Declaration Syntax
C#
public string Html { get; set; }
Value
The HTML.


ProcessorDone Method

ProcessorDone Method
Namespaces ► Sitecore.Pipelines.LoadHtml ► LoadHtmlArgs ► ProcessorDone()()()
A processor is done.
Declaration Syntax
C#
protected internal override void ProcessorDone()


RawBody Property

RawBody Property
Namespaces ► Sitecore.Pipelines.LoadHtml ► LoadHtmlArgs ► RawBody
Gets or sets the raw body.
Declaration Syntax
C#
public string RawBody { get; set; }
Value
The raw body.


Parse Class

Parse Class
Namespaces ► Sitecore.Pipelines.LoadHtml ► Parse
Parses the Html into Header, Body and Footer.
Declaration Syntax
C#
public class Parse
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Parse()()() | Initializes a new instance of the Parse class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoadHtmlArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Parse


Parse Constructor

Parse Constructor
Namespaces ► Sitecore.Pipelines.LoadHtml ► Parse ► Parse()()()
Initializes a new instance of the Parse class
Declaration Syntax
C#
public Parse()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.LoadHtml ► Parse ► Process(LoadHtmlArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LoadHtmlArgs args
)
Parameters
args (LoadHtmlArgs)
The arguments.


Sitecore.Pipelines.LoadLayout Namespace

Sitecore.Pipelines.LoadLayout Namespace
Namespaces ► Sitecore.Pipelines.LoadLayout
Declaration Syntax
C#
namespace Sitecore.Pipelines.LoadLayout
Types
All Types Classes Enumerations
Icon | Type | Description
 | ConvertToDesignTime | Converts the Html to design time Html.
 | LoadLayoutArgs..::.LayoutType | Defines the layout type.
 | Load | Loads the layout from the file.
 | LoadLayoutArgs | Argument class for Load Layout pipeline.
 | Parse | Parses the layout into Header, Body and Footer.


ConvertToDesignTime Class

ConvertToDesignTime Class
Namespaces ► Sitecore.Pipelines.LoadLayout ► ConvertToDesignTime
Converts the Html to design time Html.
Declaration Syntax
C#
public class ConvertToDesignTime
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConvertToDesignTime()()() | Initializes a new instance of the ConvertToDesignTime class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoadLayoutArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConvertToDesignTime


ConvertToDesignTime Constructor

ConvertToDesignTime Constructor
Namespaces ► Sitecore.Pipelines.LoadLayout ► ConvertToDesignTime ► ConvertToDesignTime()()()
Initializes a new instance of the ConvertToDesignTime class
Declaration Syntax
C#
public ConvertToDesignTime()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.LoadLayout ► ConvertToDesignTime ► Process(LoadLayoutArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LoadLayoutArgs args
)
Parameters
args (LoadLayoutArgs)
The arguments.


Load Class

Load Class
Namespaces ► Sitecore.Pipelines.LoadLayout ► Load
Loads the layout from the file.
Declaration Syntax
C#
public class Load
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Load()()() | Initializes a new instance of the Load class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoadLayoutArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Load


Load Constructor

Load Constructor
Namespaces ► Sitecore.Pipelines.LoadLayout ► Load ► Load()()()
Initializes a new instance of the Load class
Declaration Syntax
C#
public Load()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.LoadLayout ► Load ► Process(LoadLayoutArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LoadLayoutArgs args
)
Parameters
args (LoadLayoutArgs)
The arguments.


LoadLayoutArgs Class

LoadLayoutArgs Class
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs
Argument class for Load Layout pipeline.
Declaration Syntax
C#
[SerializableAttribute]
public class LoadLayoutArgs : ClientPipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoadLayoutArgs(String) | Initializes a new instance of the LoadLayoutArgs class.
 | LoadLayoutArgs(String, String) | Initializes a new instance of the LoadLayoutArgs class.
 | LoadLayoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoadLayoutArgs class from a serialization context.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | Body | Gets or sets the body.
 | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
 | ControlName | Gets the name of the control.
 | Create | Gets or sets a value indicating whether this LoadLayoutArgs is create.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Filename | Gets the filename.
 | FileTemplate | Gets or sets the file template.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Footer | Gets or sets the footer.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
 | Header | Gets or sets the header.
 | Html | Gets or sets the HTML.
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | InlineControls | Gets a value indicating whether controls are generated as inline or in an iframe.
 | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
 | LastWriteTime | Gets or sets the last write time.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
 | ProcessorDone()()() | A processor is done. (Overrides ClientPipelineArgs.ProcessorDone()()().)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
 | RawBody | Gets or sets the raw body.
 | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets or sets the type.
 | WaitForPostBack()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ClientPipelineArgs
 |  |  |  | LoadLayoutArgs


LoadLayoutArgs Constructor

LoadLayoutArgs Constructor
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► LoadLayoutArgs()()()
Members
Icon | Member | Description
 | LoadLayoutArgs(String) | Initializes a new instance of the LoadLayoutArgs class.
 | LoadLayoutArgs(String, String) | Initializes a new instance of the LoadLayoutArgs class.
 | LoadLayoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoadLayoutArgs class from a serialization context.


LoadLayoutArgs Constructor (info, context)

LoadLayoutArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► LoadLayoutArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the LoadLayoutArgs class from a serialization context.
Declaration Syntax
C#
protected LoadLayoutArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialized data.
context (StreamingContext)
The context.


LoadLayoutArgs Constructor (filename)

LoadLayoutArgs Constructor (filename)
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► LoadLayoutArgs(String)
Initializes a new instance of the LoadLayoutArgs class.
Declaration Syntax
C#
public LoadLayoutArgs(
    string filename
)
Parameters
filename (String)
The filename.


LoadLayoutArgs Constructor (filename, controlName)

LoadLayoutArgs Constructor (filename, controlName)
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► LoadLayoutArgs(String, String)
Initializes a new instance of the LoadLayoutArgs class.
Declaration Syntax
C#
public LoadLayoutArgs(
    string filename,
    string controlName
)
Parameters
filename (String)
The filename.
controlName (String)
Name of the control.


Body Property

Body Property
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► Body
Gets or sets the body.
Declaration Syntax
C#
public string Body { get; set; }
Value
The body.


ControlName Property

ControlName Property
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► ControlName
Gets the name of the control.
Declaration Syntax
C#
public string ControlName { get; set; }
Value
The name of the control.


Create Property

Create Property
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► Create
Gets or sets a value indicating whether this LoadLayoutArgs is create.
Declaration Syntax
C#
public bool Create { get; set; }
Value
true if create; otherwise, false.


Filename Property

Filename Property
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► Filename
Gets the filename.
Declaration Syntax
C#
public string Filename { get; private set; }
Value
The filename.


FileTemplate Property

FileTemplate Property
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► FileTemplate
Gets or sets the file template.
Declaration Syntax
C#
public string FileTemplate { get; set; }
Value
The file template.
Remarks
This is only used if Create is true.


Footer Property

Footer Property
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► Footer
Gets or sets the footer.
Declaration Syntax
C#
public string Footer { get; set; }
Value
The footer.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Header Property

Header Property
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Html Property

Html Property
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► Html
Gets or sets the HTML.
Declaration Syntax
C#
public string Html { get; set; }
Value
The HTML.


InlineControls Property

InlineControls Property
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► InlineControls
Gets a value indicating whether controls are generated as inline or in an iframe.
Declaration Syntax
C#
public bool InlineControls { get; set; }
Value
true if inline; otherwise, false.


LastWriteTime Property

LastWriteTime Property
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► LastWriteTime
Gets or sets the last write time.
Declaration Syntax
C#
public DateTime LastWriteTime { get; set; }
Value
The last write time.


ProcessorDone Method

ProcessorDone Method
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► ProcessorDone()()()
A processor is done.
Declaration Syntax
C#
protected internal override void ProcessorDone()


RawBody Property

RawBody Property
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► RawBody
Gets or sets the raw body.
Declaration Syntax
C#
public string RawBody { get; set; }
Value
The raw body.


Type Property

Type Property
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► Type
Gets or sets the type.
Declaration Syntax
C#
public LoadLayoutArgs..::.LayoutType Type { get; set; }
Value
The type.


LoadLayoutArgs.LayoutType Enumeration

LoadLayoutArgs..::.LayoutType Enumeration
Namespaces ► Sitecore.Pipelines.LoadLayout ► LoadLayoutArgs ► LoadLayoutArgs..::.LayoutType
Defines the layout type.
Declaration Syntax
C#
public enum LayoutType
Members
Member | Description
Layout | Layout.
Sublayout | Sublayout.


Parse Class

Parse Class
Namespaces ► Sitecore.Pipelines.LoadLayout ► Parse
Parses the layout into Header, Body and Footer.
Declaration Syntax
C#
public class Parse
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Parse()()() | Initializes a new instance of the Parse class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoadLayoutArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Parse


Parse Constructor

Parse Constructor
Namespaces ► Sitecore.Pipelines.LoadLayout ► Parse ► Parse()()()
Initializes a new instance of the Parse class
Declaration Syntax
C#
public Parse()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.LoadLayout ► Parse ► Process(LoadLayoutArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LoadLayoutArgs args
)
Parameters
args (LoadLayoutArgs)
The arguments.


Sitecore.Pipelines.LoggedIn Namespace

Sitecore.Pipelines.LoggedIn Namespace
Namespaces ► Sitecore.Pipelines.LoggedIn
Declaration Syntax
C#
namespace Sitecore.Pipelines.LoggedIn
Types
All Types Classes
Icon | Type | Description
 | LoggedInArgs | Argument class for ILoginProcessor implementations
 | LoggedInProcessor | LoggedInProcessor class
 | Ticket | Processor for storing a ticket.


LoggedInArgs Class

LoggedInArgs Class
Namespaces ► Sitecore.Pipelines.LoggedIn ► LoggedInArgs
Argument class for ILoginProcessor implementations
Declaration Syntax
C#
[SerializableAttribute]
public class LoggedInArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoggedInArgs()()() | Initializes a new instance of the LoggedInArgs class.
 | LoggedInArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoggedInArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Persist | Gets or sets a value indicating whether this LoggedInArgs is persist.
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | StartUrl | Gets or sets the start URL.
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Username | Gets or sets the username.
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | LoggedInArgs


LoggedInArgs Constructor

LoggedInArgs Constructor
Namespaces ► Sitecore.Pipelines.LoggedIn ► LoggedInArgs ► LoggedInArgs()()()
Members
Icon | Member | Description
 | LoggedInArgs()()() | Initializes a new instance of the LoggedInArgs class.
 | LoggedInArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoggedInArgs class.


LoggedInArgs Constructor

LoggedInArgs Constructor
Namespaces ► Sitecore.Pipelines.LoggedIn ► LoggedInArgs ► LoggedInArgs()()()
Initializes a new instance of the LoggedInArgs class.
Declaration Syntax
C#
public LoggedInArgs()


LoggedInArgs Constructor (info, context)

LoggedInArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.LoggedIn ► LoggedInArgs ► LoggedInArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the LoggedInArgs class.
Declaration Syntax
C#
protected LoggedInArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.LoggedIn ► LoggedInArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Persist Property

Persist Property
Namespaces ► Sitecore.Pipelines.LoggedIn ► LoggedInArgs ► Persist
Gets or sets a value indicating whether this LoggedInArgs is persist.
Declaration Syntax
C#
public bool Persist { get; set; }
Value
true if persist; otherwise, false.


StartUrl Property

StartUrl Property
Namespaces ► Sitecore.Pipelines.LoggedIn ► LoggedInArgs ► StartUrl
Gets or sets the start URL.
Declaration Syntax
C#
public string StartUrl { get; set; }
Value
The start URL.


Username Property

Username Property
Namespaces ► Sitecore.Pipelines.LoggedIn ► LoggedInArgs ► Username
Gets or sets the username.
Declaration Syntax
C#
public string Username { get; set; }
Value
The username.


LoggedInProcessor Class

LoggedInProcessor Class
Namespaces ► Sitecore.Pipelines.LoggedIn ► LoggedInProcessor
LoggedInProcessor class
Declaration Syntax
C#
public abstract class LoggedInProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LoggedInProcessor()()() | Initializes a new instance of the LoggedInProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoggedInArgs) | Processes the specified args.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | LoggedInProcessor
 |  | Ticket


LoggedInProcessor Constructor

LoggedInProcessor Constructor
Namespaces ► Sitecore.Pipelines.LoggedIn ► LoggedInProcessor ► LoggedInProcessor()()()
Initializes a new instance of the LoggedInProcessor class
Declaration Syntax
C#
protected LoggedInProcessor()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.LoggedIn ► LoggedInProcessor ► Process(LoggedInArgs)
Processes the specified args.
Declaration Syntax
C#
public abstract void Process(
    LoggedInArgs args
)
Parameters
args (LoggedInArgs)
The args.


Ticket Class

Ticket Class
Namespaces ► Sitecore.Pipelines.LoggedIn ► Ticket
Processor for storing a ticket.
Declaration Syntax
C#
public class Ticket : LoggedInProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Ticket()()() | Initializes a new instance of the Ticket class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoggedInArgs) | Runs the processor. (Overrides LoggedInProcessor.Process(LoggedInArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | LoggedInProcessor
 |  | Ticket


Ticket Constructor

Ticket Constructor
Namespaces ► Sitecore.Pipelines.LoggedIn ► Ticket ► Ticket()()()
Initializes a new instance of the Ticket class
Declaration Syntax
C#
public Ticket()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.LoggedIn ► Ticket ► Process(LoggedInArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    LoggedInArgs args
)
Parameters
args (LoggedInArgs)
The arguments.


Sitecore.Pipelines.LoggingIn Namespace

Sitecore.Pipelines.LoggingIn Namespace
Namespaces ► Sitecore.Pipelines.LoggingIn
Declaration Syntax
C#
namespace Sitecore.Pipelines.LoggingIn
Types
All Types Classes
Icon | Type | Description
 | CheckClientUser | Validates that the user has access to the start page.
 | CheckStartPage | Validates that the user has access to the start page.
 | ClearCache | Performs clear cache
 | LoggingInArgs | Argument class for ILoginProcessor implementations


CheckClientUser Class

CheckClientUser Class
Namespaces ► Sitecore.Pipelines.LoggingIn ► CheckClientUser
Validates that the user has access to the start page.
Declaration Syntax
C#
public class CheckClientUser
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckClientUser()()() | Initializes a new instance of the CheckClientUser class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoggingInArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CheckClientUser


CheckClientUser Constructor

CheckClientUser Constructor
Namespaces ► Sitecore.Pipelines.LoggingIn ► CheckClientUser ► CheckClientUser()()()
Initializes a new instance of the CheckClientUser class
Declaration Syntax
C#
public CheckClientUser()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.LoggingIn ► CheckClientUser ► Process(LoggingInArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LoggingInArgs args
)
Parameters
args (LoggingInArgs)
The arguments.


CheckStartPage Class

CheckStartPage Class
Namespaces ► Sitecore.Pipelines.LoggingIn ► CheckStartPage
Validates that the user has access to the start page.
Declaration Syntax
C#
public class CheckStartPage
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckStartPage()()() | Initializes a new instance of the CheckStartPage class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoggingInArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CheckStartPage


CheckStartPage Constructor

CheckStartPage Constructor
Namespaces ► Sitecore.Pipelines.LoggingIn ► CheckStartPage ► CheckStartPage()()()
Initializes a new instance of the CheckStartPage class
Declaration Syntax
C#
public CheckStartPage()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.LoggingIn ► CheckStartPage ► Process(LoggingInArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LoggingInArgs args
)
Parameters
args (LoggingInArgs)
The arguments.


ClearCache Class

ClearCache Class
Namespaces ► Sitecore.Pipelines.LoggingIn ► ClearCache
Performs clear cache
Declaration Syntax
C#
public class ClearCache
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClearCache()()() | Initializes a new instance of the ClearCache class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoggingInArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ClearCache


ClearCache Constructor

ClearCache Constructor
Namespaces ► Sitecore.Pipelines.LoggingIn ► ClearCache ► ClearCache()()()
Initializes a new instance of the ClearCache class
Declaration Syntax
C#
public ClearCache()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.LoggingIn ► ClearCache ► Process(LoggingInArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LoggingInArgs args
)
Parameters
args (LoggingInArgs)
The arguments.


LoggingInArgs Class

LoggingInArgs Class
Namespaces ► Sitecore.Pipelines.LoggingIn ► LoggingInArgs
Argument class for ILoginProcessor implementations
Declaration Syntax
C#
[SerializableAttribute]
public class LoggingInArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoggingInArgs()()() | Initializes a new instance of the LoggingInArgs class.
 | LoggingInArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoggingInArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Password | Gets or sets the password.
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | StartUrl | Gets or sets the start URL.
 | Success | Gets or sets a value indicating whether this LoggingInArgs is success.
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Username | Gets or sets the username.
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | LoggingInArgs


LoggingInArgs Constructor

LoggingInArgs Constructor
Namespaces ► Sitecore.Pipelines.LoggingIn ► LoggingInArgs ► LoggingInArgs()()()
Members
Icon | Member | Description
 | LoggingInArgs()()() | Initializes a new instance of the LoggingInArgs class.
 | LoggingInArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoggingInArgs class.


LoggingInArgs Constructor

LoggingInArgs Constructor
Namespaces ► Sitecore.Pipelines.LoggingIn ► LoggingInArgs ► LoggingInArgs()()()
Initializes a new instance of the LoggingInArgs class.
Declaration Syntax
C#
public LoggingInArgs()


LoggingInArgs Constructor (info, context)

LoggingInArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.LoggingIn ► LoggingInArgs ► LoggingInArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the LoggingInArgs class.
Declaration Syntax
C#
protected LoggingInArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.LoggingIn ► LoggingInArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Password Property

Password Property
Namespaces ► Sitecore.Pipelines.LoggingIn ► LoggingInArgs ► Password
Gets or sets the password.
Declaration Syntax
C#
public string Password { get; set; }
Value
The password.


StartUrl Property

StartUrl Property
Namespaces ► Sitecore.Pipelines.LoggingIn ► LoggingInArgs ► StartUrl
Gets or sets the start URL.
Declaration Syntax
C#
public string StartUrl { get; set; }
Value
The start URL.


Success Property

Success Property
Namespaces ► Sitecore.Pipelines.LoggingIn ► LoggingInArgs ► Success
Gets or sets a value indicating whether this LoggingInArgs is success.
Declaration Syntax
C#
public bool Success { get; set; }
Value
true if success; otherwise, false.


Username Property

Username Property
Namespaces ► Sitecore.Pipelines.LoggingIn ► LoggingInArgs ► Username
Gets or sets the username.
Declaration Syntax
C#
public string Username { get; set; }
Value
The username.


Sitecore.Pipelines.Login Namespace

Sitecore.Pipelines.Login Namespace
Namespaces ► Sitecore.Pipelines.Login
Declaration Syntax
C#
namespace Sitecore.Pipelines.Login
Types
All Types Classes
Icon | Type | Description
 | CheckStartPage | Obsolete. Validates that the user has access to the start page.
 | Login | Obsolete. Logins the user into the system.
 | LoginArgs | Obsolete. Argument class for ILoginProcessor implementations
 | LoginCookie | Obsolete. Stores login information is a cookie.
 | Settings | Obsolete. Loads the user settings.
 | Ticket | Obsolete. Processor for storing a ticket.


CheckStartPage Class

CheckStartPage Class
Namespaces ► Sitecore.Pipelines.Login ► CheckStartPage
Validates that the user has access to the start page.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public class CheckStartPage
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckStartPage()()() | Initializes a new instance of the CheckStartPage class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoginArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CheckStartPage


CheckStartPage Constructor

CheckStartPage Constructor
Namespaces ► Sitecore.Pipelines.Login ► CheckStartPage ► CheckStartPage()()()
Initializes a new instance of the CheckStartPage class
Declaration Syntax
C#
public CheckStartPage()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Login ► CheckStartPage ► Process(LoginArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LoginArgs args
)
Parameters
args (LoginArgs)
The arguments.


Login Class

Login Class
Namespaces ► Sitecore.Pipelines.Login ► Login
Logins the user into the system.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public class Login
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Login()()() | Initializes a new instance of the Login class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoginArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Login


Login Constructor

Login Constructor
Namespaces ► Sitecore.Pipelines.Login ► Login ► Login()()()
Initializes a new instance of the Login class
Declaration Syntax
C#
public Login()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Login ► Login ► Process(LoginArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LoginArgs args
)
Parameters
args (LoginArgs)
The arguments.


LoginArgs Class

LoginArgs Class
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs
Argument class for ILoginProcessor implementations
Declaration Syntax
C#
[SerializableAttribute]
[ObsoleteAttribute("Deprecated - Use LoggingInArgs or LoggedInArgs instead.")]
public class LoginArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoginArgs(String, String, String, String, Boolean) | Initializes a new instance of the LoginArgs class.
 | LoginArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoginArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | DisplayMode | Gets or sets the display mode.
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets or sets the error.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | IsPostBack | Gets a value indicating whether this instance is a post back.
 | IsRelogin | Gets or sets a value indicating whether this LoginArgs is relogin.
 | Language | Gets or sets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Password | Gets or sets the password.
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Redirect | Gets or sets the redirect URL.
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | StartUrl | Gets or sets the start URL.
 | Success | Gets or sets a value indicating whether this LoginArgs is success.
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Username | Gets or sets the username.
 | Warning | Gets or sets the warning.
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | LoginArgs


LoginArgs Constructor

LoginArgs Constructor
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► LoginArgs()()()
Members
Icon | Member | Description
 | LoginArgs(String, String, String, String, Boolean) | Initializes a new instance of the LoginArgs class.
 | LoginArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoginArgs class.


LoginArgs Constructor (info, context)

LoginArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► LoginArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the LoginArgs class.
Declaration Syntax
C#
protected LoginArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


LoginArgs Constructor (username, password, language, startUrl, isPostBack)

LoginArgs Constructor (username, password, language, startUrl, isPostBack)
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► LoginArgs(String, String, String, String, Boolean)
Initializes a new instance of the LoginArgs class.
Declaration Syntax
C#
public LoginArgs(
    string username,
    string password,
    string language,
    string startUrl,
    bool isPostBack
)
Parameters
username (String)
The username.
password (String)
The password.
language (String)
The language.
startUrl (String)
The start URL.
isPostBack (Boolean)
if set to true this instance is a post back.


DisplayMode Property

DisplayMode Property
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► DisplayMode
Gets or sets the display mode.
Declaration Syntax
C#
public string DisplayMode { get; set; }
Value
The display mode.


Error Property

Error Property
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► Error
Gets or sets the error.
Declaration Syntax
C#
public string Error { get; set; }
Value
The error.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


IsPostBack Property

IsPostBack Property
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► IsPostBack
Gets a value indicating whether this instance is a post back.
Declaration Syntax
C#
public bool IsPostBack { get; }
Value
true if this instance is a post back; otherwise, false.


IsRelogin Property

IsRelogin Property
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► IsRelogin
Gets or sets a value indicating whether this LoginArgs is relogin.
Declaration Syntax
C#
public bool IsRelogin { get; set; }
Value
true if relogin; otherwise, false.


Language Property

Language Property
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► Language
Gets or sets the language.
Declaration Syntax
C#
public string Language { get; set; }
Value
The language.


Password Property

Password Property
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► Password
Gets or sets the password.
Declaration Syntax
C#
public string Password { get; set; }
Value
The password.


Redirect Property

Redirect Property
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► Redirect
Gets or sets the redirect URL.
Declaration Syntax
C#
public string Redirect { get; set; }
Value
The redirect URL.


StartUrl Property

StartUrl Property
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► StartUrl
Gets or sets the start URL.
Declaration Syntax
C#
public string StartUrl { get; set; }
Value
The start URL.


Success Property

Success Property
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► Success
Gets or sets a value indicating whether this LoginArgs is success.
Declaration Syntax
C#
public bool Success { get; set; }
Value
true if success; otherwise, false.


Username Property

Username Property
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► Username
Gets or sets the username.
Declaration Syntax
C#
public string Username { get; set; }
Value
The username.


Warning Property

Warning Property
Namespaces ► Sitecore.Pipelines.Login ► LoginArgs ► Warning
Gets or sets the warning.
Declaration Syntax
C#
public string Warning { get; set; }
Value
The warning.


LoginCookie Class

LoginCookie Class
Namespaces ► Sitecore.Pipelines.Login ► LoginCookie
Stores login information is a cookie.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public class LoginCookie
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LoginCookie()()() | Initializes a new instance of the LoginCookie class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoginArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LoginCookie


LoginCookie Constructor

LoginCookie Constructor
Namespaces ► Sitecore.Pipelines.Login ► LoginCookie ► LoginCookie()()()
Initializes a new instance of the LoginCookie class
Declaration Syntax
C#
public LoginCookie()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Login ► LoginCookie ► Process(LoginArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LoginArgs args
)
Parameters
args (LoginArgs)
The arguments.


Settings Class

Settings Class
Namespaces ► Sitecore.Pipelines.Login ► Settings
Loads the user settings.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public class Settings
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Settings()()() | Initializes a new instance of the Settings class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoginArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Settings


Settings Constructor

Settings Constructor
Namespaces ► Sitecore.Pipelines.Login ► Settings ► Settings()()()
Initializes a new instance of the Settings class
Declaration Syntax
C#
public Settings()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Login ► Settings ► Process(LoginArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LoginArgs args
)
Parameters
args (LoginArgs)
The arguments.


Ticket Class

Ticket Class
Namespaces ► Sitecore.Pipelines.Login ► Ticket
Processor for storing a ticket.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public class Ticket
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Ticket()()() | Initializes a new instance of the Ticket class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoginArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Ticket


Ticket Constructor

Ticket Constructor
Namespaces ► Sitecore.Pipelines.Login ► Ticket ► Ticket()()()
Initializes a new instance of the Ticket class
Declaration Syntax
C#
public Ticket()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Login ► Ticket ► Process(LoginArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LoginArgs args
)
Parameters
args (LoginArgs)
The arguments.


Sitecore.Pipelines.Logout Namespace

Sitecore.Pipelines.Logout Namespace
Namespaces ► Sitecore.Pipelines.Logout
Declaration Syntax
C#
namespace Sitecore.Pipelines.Logout
Types
All Types Classes
Icon | Type | Description
 | CheckModified | Check for modified flag in Sheer.
 | ClearCache | Performs clear cache related to user
 | ClearSession | Clears the session.
 | GotoLogin | Redirects the browser to the login page.
 | LogoutArgs | Argument class for the Logout pipeline.
 | RemoveTicket | Removes a login ticket.


CheckModified Class

CheckModified Class
Namespaces ► Sitecore.Pipelines.Logout ► CheckModified
Check for modified flag in Sheer.
Declaration Syntax
C#
public class CheckModified
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckModified()()() | Initializes a new instance of the CheckModified class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LogoutArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CheckModified


CheckModified Constructor

CheckModified Constructor
Namespaces ► Sitecore.Pipelines.Logout ► CheckModified ► CheckModified()()()
Initializes a new instance of the CheckModified class
Declaration Syntax
C#
public CheckModified()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Logout ► CheckModified ► Process(LogoutArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LogoutArgs args
)
Parameters
args (LogoutArgs)
The arguments.


ClearCache Class

ClearCache Class
Namespaces ► Sitecore.Pipelines.Logout ► ClearCache
Performs clear cache related to user
Declaration Syntax
C#
public class ClearCache
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClearCache()()() | Initializes a new instance of the ClearCache class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LogoutArgs) | Processes the specified args.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ClearCache


ClearCache Constructor

ClearCache Constructor
Namespaces ► Sitecore.Pipelines.Logout ► ClearCache ► ClearCache()()()
Initializes a new instance of the ClearCache class
Declaration Syntax
C#
public ClearCache()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Logout ► ClearCache ► Process(LogoutArgs)
Processes the specified args.
Declaration Syntax
C#
public void Process(
    LogoutArgs args
)
Parameters
args (LogoutArgs)
The args.


ClearSession Class

ClearSession Class
Namespaces ► Sitecore.Pipelines.Logout ► ClearSession
Clears the session.
Declaration Syntax
C#
public class ClearSession
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClearSession()()() | Initializes a new instance of the ClearSession class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LogoutArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ClearSession


ClearSession Constructor

ClearSession Constructor
Namespaces ► Sitecore.Pipelines.Logout ► ClearSession ► ClearSession()()()
Initializes a new instance of the ClearSession class
Declaration Syntax
C#
public ClearSession()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Logout ► ClearSession ► Process(LogoutArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LogoutArgs args
)
Parameters
args (LogoutArgs)
The arguments.


GotoLogin Class

GotoLogin Class
Namespaces ► Sitecore.Pipelines.Logout ► GotoLogin
Redirects the browser to the login page.
Declaration Syntax
C#
public class GotoLogin
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GotoLogin()()() | Initializes a new instance of the GotoLogin class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LogoutArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GotoLogin


GotoLogin Constructor

GotoLogin Constructor
Namespaces ► Sitecore.Pipelines.Logout ► GotoLogin ► GotoLogin()()()
Initializes a new instance of the GotoLogin class
Declaration Syntax
C#
public GotoLogin()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Logout ► GotoLogin ► Process(LogoutArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LogoutArgs args
)
Parameters
args (LogoutArgs)
The arguments.


LogoutArgs Class

LogoutArgs Class
Namespaces ► Sitecore.Pipelines.Logout ► LogoutArgs
Argument class for the Logout pipeline.
Declaration Syntax
C#
[SerializableAttribute]
public class LogoutArgs : ClientPipelineArgs, ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LogoutArgs()()() | Initializes a new instance of the LogoutArgs class.
 | LogoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LogoutArgs class from a serialization context.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | IsFullscreen | Gets a value indicating whether this session is fullscreen.
 | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from ClientPipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
 | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitForPostBack()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ClientPipelineArgs
 |  |  |  | LogoutArgs


LogoutArgs Constructor

LogoutArgs Constructor
Namespaces ► Sitecore.Pipelines.Logout ► LogoutArgs ► LogoutArgs()()()
Members
Icon | Member | Description
 | LogoutArgs()()() | Initializes a new instance of the LogoutArgs class.
 | LogoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LogoutArgs class from a serialization context.


LogoutArgs Constructor

LogoutArgs Constructor
Namespaces ► Sitecore.Pipelines.Logout ► LogoutArgs ► LogoutArgs()()()
Initializes a new instance of the LogoutArgs class.
Declaration Syntax
C#
public LogoutArgs()


LogoutArgs Constructor (info, context)

LogoutArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.Logout ► LogoutArgs ► LogoutArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the LogoutArgs class from a serialization context.
Declaration Syntax
C#
protected LogoutArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialized data.
context (StreamingContext)
The context.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.Logout ► LogoutArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


IsFullscreen Property

IsFullscreen Property
Namespaces ► Sitecore.Pipelines.Logout ► LogoutArgs ► IsFullscreen
Gets a value indicating whether this session is fullscreen.
Declaration Syntax
C#
public bool IsFullscreen { get; }
Value
true if this session is fullscreen; otherwise, false.


RemoveTicket Class

RemoveTicket Class
Namespaces ► Sitecore.Pipelines.Logout ► RemoveTicket
Removes a login ticket.
Declaration Syntax
C#
public class RemoveTicket
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RemoveTicket()()() | Initializes a new instance of the RemoveTicket class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LogoutArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RemoveTicket


RemoveTicket Constructor

RemoveTicket Constructor
Namespaces ► Sitecore.Pipelines.Logout ► RemoveTicket ► RemoveTicket()()()
Initializes a new instance of the RemoveTicket class
Declaration Syntax
C#
public RemoveTicket()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Logout ► RemoveTicket ► Process(LogoutArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    LogoutArgs args
)
Parameters
args (LogoutArgs)
The arguments.


Sitecore.Pipelines.PreprocessRequest Namespace

Sitecore.Pipelines.PreprocessRequest Namespace
Namespaces ► Sitecore.Pipelines.PreprocessRequest
Declaration Syntax
C#
namespace Sitecore.Pipelines.PreprocessRequest
Types
All Types Classes
Icon | Type | Description
 | CheckIgnoreFlag | Check wherever to ignore whole pipeline
 | FilterUrlExtensions | Filters Url extensions.
 | IIS404Handler | IIS404Handler
 | NormalizeRawUrl | NormalizeRawUrl
 | PreprocessRequestArgs | PreprocessRequestPipelineArgs
 | PreprocessRequestPipeline | PreprocessRequestPipeline class
 | PreprocessRequestProcessor | PreprocessRequestProcessor
 | StripLanguage | StripLanguage class


CheckIgnoreFlag Class

CheckIgnoreFlag Class
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► CheckIgnoreFlag
Check wherever to ignore whole pipeline
Declaration Syntax
C#
public class CheckIgnoreFlag : PreprocessRequestProcessor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckIgnoreFlag()()() | Initializes a new instance of the CheckIgnoreFlag class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ignoreFlagName | Gets the name of the ignore key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PreprocessRequestArgs) | Processes the specified args. (Overrides PreprocessRequestProcessor.Process(PreprocessRequestArgs).)
 | Process(PipelineArgs) | Processes the specified args.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PreprocessRequestProcessor
 |  | CheckIgnoreFlag


CheckIgnoreFlag Constructor

CheckIgnoreFlag Constructor
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► CheckIgnoreFlag ► CheckIgnoreFlag()()()
Initializes a new instance of the CheckIgnoreFlag class
Declaration Syntax
C#
public CheckIgnoreFlag()


ignoreFlagName Property

ignoreFlagName Property
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► CheckIgnoreFlag ► ignoreFlagName
Gets the name of the ignore key.
Declaration Syntax
C#
protected virtual string ignoreFlagName { get; }
Value
The name of the ignore key.


Process Method

Process Method
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► CheckIgnoreFlag ► Process()()()
Members
Icon | Member | Description
 | Process(PreprocessRequestArgs) | Processes the specified args. (Overrides PreprocessRequestProcessor.Process(PreprocessRequestArgs).)
 | Process(PipelineArgs) | Processes the specified args.


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► CheckIgnoreFlag ► Process(PipelineArgs)
Processes the specified args.
Declaration Syntax
C#
public void Process(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The args.


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► CheckIgnoreFlag ► Process(PreprocessRequestArgs)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    PreprocessRequestArgs args
)
Parameters
args (PreprocessRequestArgs)
The args.


FilterUrlExtensions Class

FilterUrlExtensions Class
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► FilterUrlExtensions
Filters Url extensions.
Declaration Syntax
C#
public class FilterUrlExtensions : PreprocessRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FilterUrlExtensions(String, String, String, String) | Initializes a new instance of the FilterUrlExtensions class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PreprocessRequestArgs) | Processes the specified args. (Overrides PreprocessRequestProcessor.Process(PreprocessRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PreprocessRequestProcessor
 |  | FilterUrlExtensions


FilterUrlExtensions Constructor (allowed, blocked, streamFiles, doNotStreamFiles)

FilterUrlExtensions Constructor (allowed, blocked, streamFiles, doNotStreamFiles)
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► FilterUrlExtensions ► FilterUrlExtensions(String, String, String, String)
Initializes a new instance of the FilterUrlExtensions class.
Declaration Syntax
C#
public FilterUrlExtensions(
    string allowed,
    string blocked,
    string streamFiles,
    string doNotStreamFiles
)
Parameters
allowed (String)
blocked (String)
streamFiles (String)
doNotStreamFiles (String)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► FilterUrlExtensions ► Process(PreprocessRequestArgs)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    PreprocessRequestArgs args
)
Parameters
args (PreprocessRequestArgs)
The args.


IIS404Handler Class

IIS404Handler Class
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► IIS404Handler
IIS404Handler
Declaration Syntax
C#
public class IIS404Handler : PreprocessRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IIS404Handler()()() | Initializes a new instance of the IIS404Handler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PreprocessRequestArgs) | Processes this instance. (Overrides PreprocessRequestProcessor.Process(PreprocessRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PreprocessRequestProcessor
 |  | IIS404Handler


IIS404Handler Constructor

IIS404Handler Constructor
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► IIS404Handler ► IIS404Handler()()()
Initializes a new instance of the IIS404Handler class
Declaration Syntax
C#
public IIS404Handler()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► IIS404Handler ► Process(PreprocessRequestArgs)
Processes this instance.
Declaration Syntax
C#
public override void Process(
    PreprocessRequestArgs args
)
Parameters
args (PreprocessRequestArgs)


NormalizeRawUrl Class

NormalizeRawUrl Class
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► NormalizeRawUrl
NormalizeRawUrl
Declaration Syntax
C#
public class NormalizeRawUrl : PreprocessRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NormalizeRawUrl()()() | Initializes a new instance of the NormalizeRawUrl class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PreprocessRequestArgs) | Processes the specified args. (Overrides PreprocessRequestProcessor.Process(PreprocessRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PreprocessRequestProcessor
 |  | NormalizeRawUrl


NormalizeRawUrl Constructor

NormalizeRawUrl Constructor
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► NormalizeRawUrl ► NormalizeRawUrl()()()
Initializes a new instance of the NormalizeRawUrl class
Declaration Syntax
C#
public NormalizeRawUrl()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► NormalizeRawUrl ► Process(PreprocessRequestArgs)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    PreprocessRequestArgs args
)
Parameters
args (PreprocessRequestArgs)
The args.


PreprocessRequestArgs Class

PreprocessRequestArgs Class
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► PreprocessRequestArgs
PreprocessRequestPipelineArgs
Declaration Syntax
C#
[SerializableAttribute]
public class PreprocessRequestArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PreprocessRequestArgs(HttpContext) | Initializes a new instance of the PreprocessRequestArgs class.
 | PreprocessRequestArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the PreprocessRequestArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | Context | Gets the HTTP context.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | PreprocessRequestArgs


PreprocessRequestArgs Constructor

PreprocessRequestArgs Constructor
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► PreprocessRequestArgs ► PreprocessRequestArgs()()()
Members
Icon | Member | Description
 | PreprocessRequestArgs(HttpContext) | Initializes a new instance of the PreprocessRequestArgs class.
 | PreprocessRequestArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the PreprocessRequestArgs class.


PreprocessRequestArgs Constructor (info, context)

PreprocessRequestArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► PreprocessRequestArgs ► PreprocessRequestArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the PreprocessRequestArgs class.
Declaration Syntax
C#
protected PreprocessRequestArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


PreprocessRequestArgs Constructor (context)

PreprocessRequestArgs Constructor (context)
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► PreprocessRequestArgs ► PreprocessRequestArgs(HttpContext)
Initializes a new instance of the PreprocessRequestArgs class.
Declaration Syntax
C#
public PreprocessRequestArgs(
    HttpContext context
)
Parameters
context (HttpContext)


Context Property

Context Property
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► PreprocessRequestArgs ► Context
Gets the HTTP context.
Declaration Syntax
C#
public HttpContext Context { get; }
Value
The context.


PreprocessRequestPipeline Class

PreprocessRequestPipeline Class
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► PreprocessRequestPipeline
PreprocessRequestPipeline class
Declaration Syntax
C#
public class PreprocessRequestPipeline
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PreprocessRequestPipeline()()() | Initializes a new instance of the PreprocessRequestPipeline class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(PreprocessRequestArgs) | Runs the 'publish' pipeline with specified arguments.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PreprocessRequestPipeline


PreprocessRequestPipeline Constructor

PreprocessRequestPipeline Constructor
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► PreprocessRequestPipeline ► PreprocessRequestPipeline()()()
Initializes a new instance of the PreprocessRequestPipeline class
Declaration Syntax
C#
public PreprocessRequestPipeline()


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► PreprocessRequestPipeline ► Run(PreprocessRequestArgs)
Runs the 'publish' pipeline with specified arguments.
Declaration Syntax
C#
public static void Run(
    PreprocessRequestArgs args
)
Parameters
args (PreprocessRequestArgs)
The args.


PreprocessRequestProcessor Class

PreprocessRequestProcessor Class
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► PreprocessRequestProcessor
PreprocessRequestProcessor
Declaration Syntax
C#
public abstract class PreprocessRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PreprocessRequestProcessor()()() | Initializes a new instance of the PreprocessRequestProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PreprocessRequestArgs) | Processes the specified args.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PreprocessRequestProcessor
 |  | CheckIgnoreFlag
 |  | FilterUrlExtensions
 |  | IIS404Handler
 |  | NormalizeRawUrl
 |  | StripLanguage


PreprocessRequestProcessor Constructor

PreprocessRequestProcessor Constructor
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► PreprocessRequestProcessor ► PreprocessRequestProcessor()()()
Initializes a new instance of the PreprocessRequestProcessor class
Declaration Syntax
C#
protected PreprocessRequestProcessor()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► PreprocessRequestProcessor ► Process(PreprocessRequestArgs)
Processes the specified args.
Declaration Syntax
C#
public abstract void Process(
    PreprocessRequestArgs args
)
Parameters
args (PreprocessRequestArgs)
The args.


StripLanguage Class

StripLanguage Class
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► StripLanguage
StripLanguage class
Declaration Syntax
C#
public class StripLanguage : PreprocessRequestProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | StripLanguage()()() | Initializes a new instance of the StripLanguage class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PreprocessRequestArgs) | Processes the specified args. (Overrides PreprocessRequestProcessor.Process(PreprocessRequestArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PreprocessRequestProcessor
 |  | StripLanguage


StripLanguage Constructor

StripLanguage Constructor
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► StripLanguage ► StripLanguage()()()
Initializes a new instance of the StripLanguage class
Declaration Syntax
C#
public StripLanguage()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.PreprocessRequest ► StripLanguage ► Process(PreprocessRequestArgs)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    PreprocessRequestArgs args
)
Parameters
args (PreprocessRequestArgs)
The args.


Sitecore.Pipelines.RenderField Namespace

Sitecore.Pipelines.RenderField Namespace
Namespaces ► Sitecore.Pipelines.RenderField
Declaration Syntax
C#
namespace Sitecore.Pipelines.RenderField
Types
All Types Classes
Icon | Type | Description
 | AddBeforeAndAfterValues | Adds the before, after and enclosing tag.
 | ExpandLinks | ExpandLinks
 | GetDateFieldValue | Gets the value of date fields.
 | GetFieldValue | Implements the RenderField.
 | GetImageFieldValue | Implements the RenderField.
 | GetInternalLinkFieldValue | Implements the GetLinkFieldValue.
 | GetLinkFieldValue | Implements the GetLinkFieldValue.
 | GetMemoFieldValue | Implements the RenderField.
 | RenderFieldArgs | Implements the RenderField.
 | RenderWebEditing | Implements the Render Field pipeline processor for WebEdit.
 | SetParameters | Sets the renderField parameters.


AddBeforeAndAfterValues Class

AddBeforeAndAfterValues Class
Namespaces ► Sitecore.Pipelines.RenderField ► AddBeforeAndAfterValues
Adds the before, after and enclosing tag.
Declaration Syntax
C#
public class AddBeforeAndAfterValues
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddBeforeAndAfterValues()()() | Initializes a new instance of the AddBeforeAndAfterValues class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderFieldArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AddBeforeAndAfterValues


AddBeforeAndAfterValues Constructor

AddBeforeAndAfterValues Constructor
Namespaces ► Sitecore.Pipelines.RenderField ► AddBeforeAndAfterValues ► AddBeforeAndAfterValues()()()
Initializes a new instance of the AddBeforeAndAfterValues class
Declaration Syntax
C#
public AddBeforeAndAfterValues()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderField ► AddBeforeAndAfterValues ► Process(RenderFieldArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    RenderFieldArgs args
)
Parameters
args (RenderFieldArgs)
The arguments.


ExpandLinks Class

ExpandLinks Class
Namespaces ► Sitecore.Pipelines.RenderField ► ExpandLinks
ExpandLinks
Declaration Syntax
C#
public class ExpandLinks
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExpandLinks()()() | Initializes a new instance of the ExpandLinks class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderFieldArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ExpandLinks


ExpandLinks Constructor

ExpandLinks Constructor
Namespaces ► Sitecore.Pipelines.RenderField ► ExpandLinks ► ExpandLinks()()()
Initializes a new instance of the ExpandLinks class
Declaration Syntax
C#
public ExpandLinks()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderField ► ExpandLinks ► Process(RenderFieldArgs)
Gets the field value.
Declaration Syntax
C#
public virtual void Process(
    RenderFieldArgs args
)
Parameters
args (RenderFieldArgs)
The arguments.


GetDateFieldValue Class

GetDateFieldValue Class
Namespaces ► Sitecore.Pipelines.RenderField ► GetDateFieldValue
Gets the value of date fields.
Declaration Syntax
C#
public class GetDateFieldValue
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetDateFieldValue()()() | Initializes a new instance of the GetDateFieldValue class
 | CreateRenderer()()() | Creates the renderer.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderFieldArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GetDateFieldValue


GetDateFieldValue Constructor

GetDateFieldValue Constructor
Namespaces ► Sitecore.Pipelines.RenderField ► GetDateFieldValue ► GetDateFieldValue()()()
Initializes a new instance of the GetDateFieldValue class
Declaration Syntax
C#
public GetDateFieldValue()


CreateRenderer Method

CreateRenderer Method
Namespaces ► Sitecore.Pipelines.RenderField ► GetDateFieldValue ► CreateRenderer()()()
Creates the renderer.
Declaration Syntax
C#
protected virtual DateRenderer CreateRenderer()
Return Value
The renderer.


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderField ► GetDateFieldValue ► Process(RenderFieldArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    RenderFieldArgs args
)
Parameters
args (RenderFieldArgs)
The arguments.


GetFieldValue Class

GetFieldValue Class
Namespaces ► Sitecore.Pipelines.RenderField ► GetFieldValue
Implements the RenderField.
Declaration Syntax
C#
public class GetFieldValue
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetFieldValue()()() | Initializes a new instance of the GetFieldValue class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderFieldArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GetFieldValue


GetFieldValue Constructor

GetFieldValue Constructor
Namespaces ► Sitecore.Pipelines.RenderField ► GetFieldValue ► GetFieldValue()()()
Initializes a new instance of the GetFieldValue class
Declaration Syntax
C#
public GetFieldValue()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderField ► GetFieldValue ► Process(RenderFieldArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    RenderFieldArgs args
)
Parameters
args (RenderFieldArgs)
The arguments.


GetImageFieldValue Class

GetImageFieldValue Class
Namespaces ► Sitecore.Pipelines.RenderField ► GetImageFieldValue
Implements the RenderField.
Declaration Syntax
C#
public class GetImageFieldValue
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetImageFieldValue()()() | Initializes a new instance of the GetImageFieldValue class
 | CreateRenderer()()() | Creates the renderer.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderFieldArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GetImageFieldValue


GetImageFieldValue Constructor

GetImageFieldValue Constructor
Namespaces ► Sitecore.Pipelines.RenderField ► GetImageFieldValue ► GetImageFieldValue()()()
Initializes a new instance of the GetImageFieldValue class
Declaration Syntax
C#
public GetImageFieldValue()


CreateRenderer Method

CreateRenderer Method
Namespaces ► Sitecore.Pipelines.RenderField ► GetImageFieldValue ► CreateRenderer()()()
Creates the renderer.
Declaration Syntax
C#
protected virtual ImageRenderer CreateRenderer()
Return Value
The renderer.


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderField ► GetImageFieldValue ► Process(RenderFieldArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    RenderFieldArgs args
)
Parameters
args (RenderFieldArgs)
The arguments.


GetInternalLinkFieldValue Class

GetInternalLinkFieldValue Class
Namespaces ► Sitecore.Pipelines.RenderField ► GetInternalLinkFieldValue
Implements the GetLinkFieldValue.
Declaration Syntax
C#
public class GetInternalLinkFieldValue
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetInternalLinkFieldValue()()() | Initializes a new instance of the GetInternalLinkFieldValue class
 | CreateRenderer()()() | Creates the renderer.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderFieldArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GetInternalLinkFieldValue


GetInternalLinkFieldValue Constructor

GetInternalLinkFieldValue Constructor
Namespaces ► Sitecore.Pipelines.RenderField ► GetInternalLinkFieldValue ► GetInternalLinkFieldValue()()()
Initializes a new instance of the GetInternalLinkFieldValue class
Declaration Syntax
C#
public GetInternalLinkFieldValue()


CreateRenderer Method

CreateRenderer Method
Namespaces ► Sitecore.Pipelines.RenderField ► GetInternalLinkFieldValue ► CreateRenderer()()()
Creates the renderer.
Declaration Syntax
C#
protected virtual InternalLinkRenderer CreateRenderer()
Return Value
The renderer.


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderField ► GetInternalLinkFieldValue ► Process(RenderFieldArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    RenderFieldArgs args
)
Parameters
args (RenderFieldArgs)
The arguments.


GetLinkFieldValue Class

GetLinkFieldValue Class
Namespaces ► Sitecore.Pipelines.RenderField ► GetLinkFieldValue
Implements the GetLinkFieldValue.
Declaration Syntax
C#
public class GetLinkFieldValue
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetLinkFieldValue()()() | Initializes a new instance of the GetLinkFieldValue class
 | CreateRenderer(Item) | Creates the renderer.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderFieldArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GetLinkFieldValue


GetLinkFieldValue Constructor

GetLinkFieldValue Constructor
Namespaces ► Sitecore.Pipelines.RenderField ► GetLinkFieldValue ► GetLinkFieldValue()()()
Initializes a new instance of the GetLinkFieldValue class
Declaration Syntax
C#
public GetLinkFieldValue()


CreateRenderer Method (item)

CreateRenderer Method (item)
Namespaces ► Sitecore.Pipelines.RenderField ► GetLinkFieldValue ► CreateRenderer(Item)
Creates the renderer.
Declaration Syntax
C#
protected virtual LinkRenderer CreateRenderer(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The renderer.


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderField ► GetLinkFieldValue ► Process(RenderFieldArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    RenderFieldArgs args
)
Parameters
args (RenderFieldArgs)
The arguments.


GetMemoFieldValue Class

GetMemoFieldValue Class
Namespaces ► Sitecore.Pipelines.RenderField ► GetMemoFieldValue
Implements the RenderField.
Declaration Syntax
C#
public class GetMemoFieldValue
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetMemoFieldValue()()() | Initializes a new instance of the GetMemoFieldValue class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderFieldArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GetMemoFieldValue


GetMemoFieldValue Constructor

GetMemoFieldValue Constructor
Namespaces ► Sitecore.Pipelines.RenderField ► GetMemoFieldValue ► GetMemoFieldValue()()()
Initializes a new instance of the GetMemoFieldValue class
Declaration Syntax
C#
public GetMemoFieldValue()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderField ► GetMemoFieldValue ► Process(RenderFieldArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    RenderFieldArgs args
)
Parameters
args (RenderFieldArgs)
The arguments.


RenderFieldArgs Class

RenderFieldArgs Class
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs
Implements the RenderField.
Declaration Syntax
C#
[SerializableAttribute]
public class RenderFieldArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderFieldArgs()()() | Initializes a new instance of the RenderFieldArgs class.
 | RenderFieldArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderFieldArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | After | Gets or sets the after.
 | Before | Gets or sets the before.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | DisableWebEdit | Gets or sets a value indicating whether the RenderFieldArgs disables the web editing.
 | DisableWebEditContentEditing | Gets or sets a value indicating whether the RenderFieldArgs disables the web edit content editing.
 | DisableWebEditContentSelecting | Gets or sets a value indicating whether the RenderFieldArgs disables the web edit content selecting.
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | EnclosingTag | Gets or sets the enclosing tag.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldName | Gets or sets the name of the field.
 | FieldTypeKey | Gets the type of the field.
 | FieldValue | Gets or sets the field value.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetField()()() | Gets the field.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | Item | Gets or sets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Parameters | Gets the parameters.
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | RawParameters | Gets or sets the raw parameters.
 | RenderParameters | Gets render parameters. Render parameters are used to control renderer logic, but are not output themselves
 | Result | Gets or sets the result.
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WebEditClick | Gets or sets the web edit click.
 | WebEditParameters | The web edit parameters allow passing arbitrary data to web editing commands. This allows the commands to re-render the field using the same parameters that were used by the original rendering logic without a full page refresh.
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | RenderFieldArgs


RenderFieldArgs Constructor

RenderFieldArgs Constructor
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► RenderFieldArgs()()()
Members
Icon | Member | Description
 | RenderFieldArgs()()() | Initializes a new instance of the RenderFieldArgs class.
 | RenderFieldArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderFieldArgs class.


RenderFieldArgs Constructor

RenderFieldArgs Constructor
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► RenderFieldArgs()()()
Initializes a new instance of the RenderFieldArgs class.
Declaration Syntax
C#
public RenderFieldArgs()


RenderFieldArgs Constructor (info, context)

RenderFieldArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► RenderFieldArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the RenderFieldArgs class.
Declaration Syntax
C#
protected RenderFieldArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


After Property

After Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► After
Gets or sets the after.
Declaration Syntax
C#
public string After { get; set; }
Value
The after.


Before Property

Before Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► Before
Gets or sets the before.
Declaration Syntax
C#
public string Before { get; set; }
Value
The before.


DisableWebEdit Property

DisableWebEdit Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► DisableWebEdit
Gets or sets a value indicating whether the RenderFieldArgs disables the web editing.
Declaration Syntax
C#
public bool DisableWebEdit { get; set; }
Value
true if the RenderFieldArgs disables the web editing; otherwise, false.


DisableWebEditContentEditing Property

DisableWebEditContentEditing Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► DisableWebEditContentEditing
Gets or sets a value indicating whether the RenderFieldArgs disables the web edit content editing.
Declaration Syntax
C#
public bool DisableWebEditContentEditing { get; set; }
Value
true if the RenderFieldArgs disables the web edit content editing; otherwise, false.


DisableWebEditContentSelecting Property

DisableWebEditContentSelecting Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► DisableWebEditContentSelecting
Gets or sets a value indicating whether the RenderFieldArgs disables the web edit content selecting.
Declaration Syntax
C#
public bool DisableWebEditContentSelecting { get; set; }
Value
true if the RenderFieldArgs disables the web edit content selecting; otherwise, false.


EnclosingTag Property

EnclosingTag Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► EnclosingTag
Gets or sets the enclosing tag.
Declaration Syntax
C#
public string EnclosingTag { get; set; }
Value
The enclosing tag.


FieldName Property

FieldName Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► FieldName
Gets or sets the name of the field.
Declaration Syntax
C#
public string FieldName { get; set; }
Value
The name of the field.


FieldTypeKey Property

FieldTypeKey Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► FieldTypeKey
Gets the type of the field.
Declaration Syntax
C#
public string FieldTypeKey { get; }
Value
The type of the field.


FieldValue Property

FieldValue Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► FieldValue
Gets or sets the field value.
Declaration Syntax
C#
public string FieldValue { get; internal set; }
Value
The field value.


GetField Method

GetField Method
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► GetField()()()
Gets the field.
Declaration Syntax
C#
public Field GetField()
Return Value
The field.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Item Property

Item Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► Item
Gets or sets the item.
Declaration Syntax
C#
public Item Item { get; set; }
Value
The item.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► Parameters
Gets the parameters.
Declaration Syntax
C#
public SafeDictionary<string> Parameters { get; set; }
Value
The parameters.


RawParameters Property

RawParameters Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► RawParameters
Gets or sets the raw parameters.
Declaration Syntax
C#
public string RawParameters { get; set; }
Value
The raw parameters.


RenderParameters Property

RenderParameters Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► RenderParameters
Gets render parameters. Render parameters are used to control renderer logic, but are not output themselves
Declaration Syntax
C#
public SafeDictionary<string> RenderParameters { get; set; }


Result Property

Result Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► Result
Gets or sets the result.
Declaration Syntax
C#
public RenderFieldResult Result { get; set; }
Value
The result.


WebEditClick Property

WebEditClick Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► WebEditClick
Gets or sets the web edit click.
Declaration Syntax
C#
public string WebEditClick { get; set; }
Value
The web edit click.


WebEditParameters Property

WebEditParameters Property
Namespaces ► Sitecore.Pipelines.RenderField ► RenderFieldArgs ► WebEditParameters
The web edit parameters allow passing arbitrary data to web editing commands. This allows the commands to re-render the field using the same parameters that were used by the original rendering logic without a full page refresh.
Declaration Syntax
C#
public SafeDictionary<string> WebEditParameters { get; set; }
Value
The web edit parameters.


RenderWebEditing Class

RenderWebEditing Class
Namespaces ► Sitecore.Pipelines.RenderField ► RenderWebEditing
Implements the Render Field pipeline processor for WebEdit.
Declaration Syntax
C#
public class RenderWebEditing
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenderWebEditing()()() | Initializes a new instance of the RenderWebEditing class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderFieldArgs) | Gets the field value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RenderWebEditing


RenderWebEditing Constructor

RenderWebEditing Constructor
Namespaces ► Sitecore.Pipelines.RenderField ► RenderWebEditing ► RenderWebEditing()()()
Initializes a new instance of the RenderWebEditing class
Declaration Syntax
C#
public RenderWebEditing()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderField ► RenderWebEditing ► Process(RenderFieldArgs)
Gets the field value.
Declaration Syntax
C#
public void Process(
    RenderFieldArgs args
)
Parameters
args (RenderFieldArgs)
The arguments.


SetParameters Class

SetParameters Class
Namespaces ► Sitecore.Pipelines.RenderField ► SetParameters
Sets the renderField parameters.
Declaration Syntax
C#
public class SetParameters
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SetParameters()()() | Initializes a new instance of the SetParameters class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderFieldArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SetParameters


SetParameters Constructor

SetParameters Constructor
Namespaces ► Sitecore.Pipelines.RenderField ► SetParameters ► SetParameters()()()
Initializes a new instance of the SetParameters class
Declaration Syntax
C#
public SetParameters()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderField ► SetParameters ► Process(RenderFieldArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    RenderFieldArgs args
)
Parameters
args (RenderFieldArgs)
The arguments.


Sitecore.Pipelines.RenderItemTile Namespace

Sitecore.Pipelines.RenderItemTile Namespace
Namespaces ► Sitecore.Pipelines.RenderItemTile
Declaration Syntax
C#
namespace Sitecore.Pipelines.RenderItemTile
Types
All Types Classes
Icon | Type | Description
 | RenderDefaultTile | Implements the ShortenLinks.
 | RenderFolderTile |
 | RenderItemTileArgs | Implements the RenderField.
 | RenderTemplateTile | Implements the ShortenLinks.
 | RenderTileBase | Implements the ShortenLinks.


RenderDefaultTile Class

RenderDefaultTile Class
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderDefaultTile
Implements the ShortenLinks.
Declaration Syntax
C#
public class RenderDefaultTile : RenderTileBase
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenderDefaultTile()()() | Initializes a new instance of the RenderDefaultTile class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderItemTileArgs) | Runs the processor. (Inherited from RenderTileBase.)
 | RenderIcon(RenderItemTileArgs) | Renders the icon. (Inherited from RenderTileBase.)
 | RenderIconOnly(RenderItemTileArgs) | Renders the list. (Inherited from RenderTileBase.)
 | RenderList(RenderItemTileArgs) | Renders the list. (Inherited from RenderTileBase.)
 | RenderTile(RenderItemTileArgs) | Renders the tile. (Inherited from RenderTileBase.)
 | RenderTileDetails(HtmlTextWriter, RenderItemTileArgs) | Renders the tile details. (Inherited from RenderTileBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderTileBase
 |  | RenderDefaultTile


RenderDefaultTile Constructor

RenderDefaultTile Constructor
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderDefaultTile ► RenderDefaultTile()()()
Initializes a new instance of the RenderDefaultTile class
Declaration Syntax
C#
public RenderDefaultTile()


RenderFolderTile Class

RenderFolderTile Class
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderFolderTile
Declaration Syntax
C#
public class RenderFolderTile : RenderTileBase
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenderFolderTile()()() | Initializes a new instance of the RenderFolderTile class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderItemTileArgs) | Runs the processor. (Overrides RenderTileBase.Process(RenderItemTileArgs).)
 | RenderIcon(RenderItemTileArgs) | Renders the icon. (Inherited from RenderTileBase.)
 | RenderIconOnly(RenderItemTileArgs) | Renders the list. (Inherited from RenderTileBase.)
 | RenderList(RenderItemTileArgs) | Renders the list. (Inherited from RenderTileBase.)
 | RenderTile(RenderItemTileArgs) | Renders the tile. (Inherited from RenderTileBase.)
 | RenderTileDetails(HtmlTextWriter, RenderItemTileArgs) | Renders the tile details. (Overrides RenderTileBase.RenderTileDetails(HtmlTextWriter, RenderItemTileArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderTileBase
 |  | RenderFolderTile


RenderFolderTile Constructor

RenderFolderTile Constructor
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderFolderTile ► RenderFolderTile()()()
Initializes a new instance of the RenderFolderTile class
Declaration Syntax
C#
public RenderFolderTile()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderFolderTile ► Process(RenderItemTileArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    RenderItemTileArgs args
)
Parameters
args (RenderItemTileArgs)
The arguments.


RenderTileDetails Method (output, args)

RenderTileDetails Method (output, args)
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderFolderTile ► RenderTileDetails(HtmlTextWriter, RenderItemTileArgs)
Renders the tile details.
Declaration Syntax
C#
protected override void RenderTileDetails(
    HtmlTextWriter output,
    RenderItemTileArgs args
)
Parameters
output (HtmlTextWriter)
The output.
args (RenderItemTileArgs)
The arguments.


RenderItemTileArgs Class

RenderItemTileArgs Class
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderItemTileArgs
Implements the RenderField.
Declaration Syntax
C#
[SerializableAttribute]
public class RenderItemTileArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderItemTileArgs(Item, TileView, ImageDimension, String) | Initializes a new instance of the RenderItemTileArgs class.
 | RenderItemTileArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderItemTileArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | Click | Gets the Click event.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImageDimension | Gets the image dimension.
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | Item | Gets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | Tile | Gets or sets the tile.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | View | Gets the view.
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | RenderItemTileArgs


RenderItemTileArgs Constructor

RenderItemTileArgs Constructor
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderItemTileArgs ► RenderItemTileArgs()()()
Members
Icon | Member | Description
 | RenderItemTileArgs(Item, TileView, ImageDimension, String) | Initializes a new instance of the RenderItemTileArgs class.
 | RenderItemTileArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderItemTileArgs class.


RenderItemTileArgs Constructor (item, view, imageDimension, click)

RenderItemTileArgs Constructor (item, view, imageDimension, click)
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderItemTileArgs ► RenderItemTileArgs(Item, TileView, ImageDimension, String)
Initializes a new instance of the RenderItemTileArgs class.
Declaration Syntax
C#
public RenderItemTileArgs(
    Item item,
    TileView view,
    ImageDimension imageDimension,
    string click
)
Parameters
item (Item)
The item.
view (TileView)
The view.
imageDimension (ImageDimension)
The image dimension.
click (String)
The click.


RenderItemTileArgs Constructor (info, context)

RenderItemTileArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderItemTileArgs ► RenderItemTileArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the RenderItemTileArgs class.
Declaration Syntax
C#
protected RenderItemTileArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Click Property

Click Property
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderItemTileArgs ► Click
Gets the Click event.
Declaration Syntax
C#
public string Click { get; }
Value
The event to be executed.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderItemTileArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


ImageDimension Property

ImageDimension Property
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderItemTileArgs ► ImageDimension
Gets the image dimension.
Declaration Syntax
C#
public ImageDimension ImageDimension { get; }
Value
The image dimension.


Item Property

Item Property
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderItemTileArgs ► Item
Gets the item.
Declaration Syntax
C#
public Item Item { get; }
Value
The item.


Tile Property

Tile Property
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderItemTileArgs ► Tile
Gets or sets the tile.
Declaration Syntax
C#
public string Tile { get; set; }
Value
The tile.


View Property

View Property
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderItemTileArgs ► View
Gets the view.
Declaration Syntax
C#
public TileView View { get; }
Value
The view.


RenderTemplateTile Class

RenderTemplateTile Class
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderTemplateTile
Implements the ShortenLinks.
Declaration Syntax
C#
public class RenderTemplateTile : RenderTileBase
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenderTemplateTile()()() | Initializes a new instance of the RenderTemplateTile class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderItemTileArgs) | Runs the processor. (Overrides RenderTileBase.Process(RenderItemTileArgs).)
 | RenderIcon(RenderItemTileArgs) | Renders the icon. (Inherited from RenderTileBase.)
 | RenderIconOnly(RenderItemTileArgs) | Renders the list. (Inherited from RenderTileBase.)
 | RenderList(RenderItemTileArgs) | Renders the list. (Inherited from RenderTileBase.)
 | RenderTile(RenderItemTileArgs) | Renders the tile. (Inherited from RenderTileBase.)
 | RenderTileDetails(HtmlTextWriter, RenderItemTileArgs) | Renders the tile details. (Overrides RenderTileBase.RenderTileDetails(HtmlTextWriter, RenderItemTileArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderTileBase
 |  | RenderTemplateTile


RenderTemplateTile Constructor

RenderTemplateTile Constructor
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderTemplateTile ► RenderTemplateTile()()()
Initializes a new instance of the RenderTemplateTile class
Declaration Syntax
C#
public RenderTemplateTile()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderTemplateTile ► Process(RenderItemTileArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    RenderItemTileArgs args
)
Parameters
args (RenderItemTileArgs)
The arguments.


RenderTileDetails Method (output, args)

RenderTileDetails Method (output, args)
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderTemplateTile ► RenderTileDetails(HtmlTextWriter, RenderItemTileArgs)
Renders the tile details.
Declaration Syntax
C#
protected override void RenderTileDetails(
    HtmlTextWriter output,
    RenderItemTileArgs args
)
Parameters
output (HtmlTextWriter)
The output.
args (RenderItemTileArgs)
The arguments.


RenderTileBase Class

RenderTileBase Class
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderTileBase
Implements the ShortenLinks.
Declaration Syntax
C#
public abstract class RenderTileBase
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenderTileBase()()() | Initializes a new instance of the RenderTileBase class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderItemTileArgs) | Runs the processor.
 | RenderIcon(RenderItemTileArgs) | Renders the icon.
 | RenderIconOnly(RenderItemTileArgs) | Renders the list.
 | RenderList(RenderItemTileArgs) | Renders the list.
 | RenderTile(RenderItemTileArgs) | Renders the tile.
 | RenderTileDetails(HtmlTextWriter, RenderItemTileArgs) | Renders the tile details.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderTileBase
 |  | RenderDefaultTile
 |  | RenderFolderTile
 |  | RenderTemplateTile


RenderTileBase Constructor

RenderTileBase Constructor
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderTileBase ► RenderTileBase()()()
Initializes a new instance of the RenderTileBase class
Declaration Syntax
C#
protected RenderTileBase()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderTileBase ► Process(RenderItemTileArgs)
Runs the processor.
Declaration Syntax
C#
public virtual void Process(
    RenderItemTileArgs args
)
Parameters
args (RenderItemTileArgs)
The arguments.


RenderIcon Method (args)

RenderIcon Method (args)
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderTileBase ► RenderIcon(RenderItemTileArgs)
Renders the icon.
Declaration Syntax
C#
protected virtual void RenderIcon(
    RenderItemTileArgs args
)
Parameters
args (RenderItemTileArgs)
The arguments.
Exceptions
Exception | Condition
ArgumentNullException |
FormatException |


RenderIconOnly Method (args)

RenderIconOnly Method (args)
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderTileBase ► RenderIconOnly(RenderItemTileArgs)
Renders the list.
Declaration Syntax
C#
protected virtual void RenderIconOnly(
    RenderItemTileArgs args
)
Parameters
args (RenderItemTileArgs)
The arguments.


RenderList Method (args)

RenderList Method (args)
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderTileBase ► RenderList(RenderItemTileArgs)
Renders the list.
Declaration Syntax
C#
protected virtual void RenderList(
    RenderItemTileArgs args
)
Parameters
args (RenderItemTileArgs)
The arguments.


RenderTile Method (args)

RenderTile Method (args)
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderTileBase ► RenderTile(RenderItemTileArgs)
Renders the tile.
Declaration Syntax
C#
protected virtual void RenderTile(
    RenderItemTileArgs args
)
Parameters
args (RenderItemTileArgs)
The arguments.


RenderTileDetails Method (output, args)

RenderTileDetails Method (output, args)
Namespaces ► Sitecore.Pipelines.RenderItemTile ► RenderTileBase ► RenderTileDetails(HtmlTextWriter, RenderItemTileArgs)
Renders the tile details.
Declaration Syntax
C#
protected virtual void RenderTileDetails(
    HtmlTextWriter output,
    RenderItemTileArgs args
)
Parameters
output (HtmlTextWriter)
The output.
args (RenderItemTileArgs)
The arguments.


Sitecore.Pipelines.RenderLayout Namespace

Sitecore.Pipelines.RenderLayout Namespace
Namespaces ► Sitecore.Pipelines.RenderLayout
Declaration Syntax
C#
namespace Sitecore.Pipelines.RenderLayout
Types
All Types Classes
Icon | Type | Description
 | BrowserCaching | Sets the browser caching.
 | BuildTree | BuildTree
 | InsertRenderings | Inserts renderings.
 | InsertSystemControls | InsertSystemControls class
 | InsertUnusedControls | InsertUnusedControls class
 | PageExtenders | Inserts page extenders.
 | PageHandlers | Inserts page handlers.
 | RenderLayoutArgs | Argument class for IRenderLayoutProcessor implementations.
 | RenderLayoutProcessor | RenderLayoutProcessor class
 | SecurityCheck | Checks for security settings.


BrowserCaching Class

BrowserCaching Class
Namespaces ► Sitecore.Pipelines.RenderLayout ► BrowserCaching
Sets the browser caching.
Declaration Syntax
C#
public class BrowserCaching : RenderLayoutProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BrowserCaching()()() | Initializes a new instance of the BrowserCaching class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderLayoutArgs) | Set browser caching headers. (Overrides RenderLayoutProcessor.Process(RenderLayoutArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderLayoutProcessor
 |  | BrowserCaching


BrowserCaching Constructor

BrowserCaching Constructor
Namespaces ► Sitecore.Pipelines.RenderLayout ► BrowserCaching ► BrowserCaching()()()
Initializes a new instance of the BrowserCaching class
Declaration Syntax
C#
public BrowserCaching()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderLayout ► BrowserCaching ► Process(RenderLayoutArgs)
Set browser caching headers.
Declaration Syntax
C#
public override void Process(
    RenderLayoutArgs args
)
Parameters
args (RenderLayoutArgs)
The arguments.


BuildTree Class

BuildTree Class
Namespaces ► Sitecore.Pipelines.RenderLayout ► BuildTree
BuildTree
Declaration Syntax
C#
public class BuildTree : RenderLayoutProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BuildTree()()() | Initializes a new instance of the BuildTree class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderLayoutArgs) | Runs the processor. (Overrides RenderLayoutProcessor.Process(RenderLayoutArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderLayoutProcessor
 |  | BuildTree


BuildTree Constructor

BuildTree Constructor
Namespaces ► Sitecore.Pipelines.RenderLayout ► BuildTree ► BuildTree()()()
Initializes a new instance of the BuildTree class
Declaration Syntax
C#
public BuildTree()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderLayout ► BuildTree ► Process(RenderLayoutArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    RenderLayoutArgs args
)
Parameters
args (RenderLayoutArgs)
The arguments.


InsertRenderings Class

InsertRenderings Class
Namespaces ► Sitecore.Pipelines.RenderLayout ► InsertRenderings
Inserts renderings.
Declaration Syntax
C#
public class InsertRenderings : RenderLayoutProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InsertRenderings()()() | Initializes a new instance of the InsertRenderings class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderLayoutArgs) | Runs the processor. (Overrides RenderLayoutProcessor.Process(RenderLayoutArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderLayoutProcessor
 |  | InsertRenderings


InsertRenderings Constructor

InsertRenderings Constructor
Namespaces ► Sitecore.Pipelines.RenderLayout ► InsertRenderings ► InsertRenderings()()()
Initializes a new instance of the InsertRenderings class
Declaration Syntax
C#
public InsertRenderings()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderLayout ► InsertRenderings ► Process(RenderLayoutArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    RenderLayoutArgs args
)
Parameters
args (RenderLayoutArgs)
The arguments.


InsertSystemControls Class

InsertSystemControls Class
Namespaces ► Sitecore.Pipelines.RenderLayout ► InsertSystemControls
InsertSystemControls class
Declaration Syntax
C#
public class InsertSystemControls : RenderLayoutProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InsertSystemControls()()() | Initializes a new instance of the InsertSystemControls class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderLayoutArgs) | Processes the specified args. (Overrides RenderLayoutProcessor.Process(RenderLayoutArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderLayoutProcessor
 |  | InsertSystemControls


InsertSystemControls Constructor

InsertSystemControls Constructor
Namespaces ► Sitecore.Pipelines.RenderLayout ► InsertSystemControls ► InsertSystemControls()()()
Initializes a new instance of the InsertSystemControls class
Declaration Syntax
C#
public InsertSystemControls()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderLayout ► InsertSystemControls ► Process(RenderLayoutArgs)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    RenderLayoutArgs args
)
Parameters
args (RenderLayoutArgs)
The args.


InsertUnusedControls Class

InsertUnusedControls Class
Namespaces ► Sitecore.Pipelines.RenderLayout ► InsertUnusedControls
InsertUnusedControls class
Declaration Syntax
C#
public class InsertUnusedControls : RenderLayoutProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InsertUnusedControls()()() | Initializes a new instance of the InsertUnusedControls class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderLayoutArgs) | Processes the specified args. (Overrides RenderLayoutProcessor.Process(RenderLayoutArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderLayoutProcessor
 |  | InsertUnusedControls


InsertUnusedControls Constructor

InsertUnusedControls Constructor
Namespaces ► Sitecore.Pipelines.RenderLayout ► InsertUnusedControls ► InsertUnusedControls()()()
Initializes a new instance of the InsertUnusedControls class
Declaration Syntax
C#
public InsertUnusedControls()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderLayout ► InsertUnusedControls ► Process(RenderLayoutArgs)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    RenderLayoutArgs args
)
Parameters
args (RenderLayoutArgs)
The args.


PageExtenders Class

PageExtenders Class
Namespaces ► Sitecore.Pipelines.RenderLayout ► PageExtenders
Inserts page extenders.
Declaration Syntax
C#
public class PageExtenders : RenderLayoutProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PageExtenders()()() | Initializes a new instance of the PageExtenders class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderLayoutArgs) | Runs the processor. (Overrides RenderLayoutProcessor.Process(RenderLayoutArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderLayoutProcessor
 |  | PageExtenders


PageExtenders Constructor

PageExtenders Constructor
Namespaces ► Sitecore.Pipelines.RenderLayout ► PageExtenders ► PageExtenders()()()
Initializes a new instance of the PageExtenders class
Declaration Syntax
C#
public PageExtenders()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderLayout ► PageExtenders ► Process(RenderLayoutArgs)
Runs the processor.
Declaration Syntax
C#
public override void Process(
    RenderLayoutArgs args
)
Parameters
args (RenderLayoutArgs)
The arguments.


PageHandlers Class

PageHandlers Class
Namespaces ► Sitecore.Pipelines.RenderLayout ► PageHandlers
Inserts page handlers.
Declaration Syntax
C#
public class PageHandlers : RenderLayoutProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PageHandlers()()() | Initializes a new instance of the PageHandlers class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderLayoutArgs) | Call custom page handlers. (Overrides RenderLayoutProcessor.Process(RenderLayoutArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderLayoutProcessor
 |  | PageHandlers


PageHandlers Constructor

PageHandlers Constructor
Namespaces ► Sitecore.Pipelines.RenderLayout ► PageHandlers ► PageHandlers()()()
Initializes a new instance of the PageHandlers class
Declaration Syntax
C#
public PageHandlers()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderLayout ► PageHandlers ► Process(RenderLayoutArgs)
Call custom page handlers.
Declaration Syntax
C#
public override void Process(
    RenderLayoutArgs args
)
Parameters
args (RenderLayoutArgs)
The arguments.


RenderLayoutArgs Class

RenderLayoutArgs Class
Namespaces ► Sitecore.Pipelines.RenderLayout ► RenderLayoutArgs
Argument class for IRenderLayoutProcessor implementations.
Declaration Syntax
C#
[SerializableAttribute]
public class RenderLayoutArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderLayoutArgs(Page, Item) | Initializes a new instance of the RenderLayoutArgs class.
 | RenderLayoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderLayoutArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | RenderLayoutArgs


RenderLayoutArgs Constructor

RenderLayoutArgs Constructor
Namespaces ► Sitecore.Pipelines.RenderLayout ► RenderLayoutArgs ► RenderLayoutArgs()()()
Members
Icon | Member | Description
 | RenderLayoutArgs(Page, Item) | Initializes a new instance of the RenderLayoutArgs class.
 | RenderLayoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderLayoutArgs class.


RenderLayoutArgs Constructor (info, context)

RenderLayoutArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.RenderLayout ► RenderLayoutArgs ► RenderLayoutArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the RenderLayoutArgs class.
Declaration Syntax
C#
protected RenderLayoutArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


RenderLayoutArgs Constructor (page, currentItem)

RenderLayoutArgs Constructor (page, currentItem)
Namespaces ► Sitecore.Pipelines.RenderLayout ► RenderLayoutArgs ► RenderLayoutArgs(Page, Item)
Initializes a new instance of the RenderLayoutArgs class.
Declaration Syntax
C#
public RenderLayoutArgs(
    Page page,
    Item currentItem
)
Parameters
page (Page)
The page.
currentItem (Item)
The current item.


RenderLayoutProcessor Class

RenderLayoutProcessor Class
Namespaces ► Sitecore.Pipelines.RenderLayout ► RenderLayoutProcessor
RenderLayoutProcessor class
Declaration Syntax
C#
public abstract class RenderLayoutProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenderLayoutProcessor()()() | Initializes a new instance of the RenderLayoutProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderLayoutArgs) | Processes the specified args.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderLayoutProcessor
 |  | BrowserCaching
 |  | BuildTree
 |  | InsertRenderings
 |  | InsertSystemControls
 |  | InsertUnusedControls
 |  | PageExtenders
 |  | PageHandlers
 |  | SecurityCheck


RenderLayoutProcessor Constructor

RenderLayoutProcessor Constructor
Namespaces ► Sitecore.Pipelines.RenderLayout ► RenderLayoutProcessor ► RenderLayoutProcessor()()()
Initializes a new instance of the RenderLayoutProcessor class
Declaration Syntax
C#
protected RenderLayoutProcessor()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderLayout ► RenderLayoutProcessor ► Process(RenderLayoutArgs)
Processes the specified args.
Declaration Syntax
C#
public abstract void Process(
    RenderLayoutArgs args
)
Parameters
args (RenderLayoutArgs)
The args.


SecurityCheck Class

SecurityCheck Class
Namespaces ► Sitecore.Pipelines.RenderLayout ► SecurityCheck
Checks for security settings.
Declaration Syntax
C#
public class SecurityCheck : RenderLayoutProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SecurityCheck()()() | Initializes a new instance of the SecurityCheck class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLoginPage(SiteContext) | Gets the login page.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAccess()()() | Check credentials.
 | IsLoginPageRequest()()() | Determines whether current request addresses the login page of the site.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(RenderLayoutArgs) | Process query string. (Overrides RenderLayoutProcessor.Process(RenderLayoutArgs).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderLayoutProcessor
 |  | SecurityCheck


SecurityCheck Constructor

SecurityCheck Constructor
Namespaces ► Sitecore.Pipelines.RenderLayout ► SecurityCheck ► SecurityCheck()()()
Initializes a new instance of the SecurityCheck class
Declaration Syntax
C#
public SecurityCheck()


GetLoginPage Method (site)

GetLoginPage Method (site)
Namespaces ► Sitecore.Pipelines.RenderLayout ► SecurityCheck ► GetLoginPage(SiteContext)
Gets the login page.
Declaration Syntax
C#
protected virtual string GetLoginPage(
    SiteContext site
)
Parameters
site (SiteContext)
The site.
Return Value


HasAccess Method

HasAccess Method
Namespaces ► Sitecore.Pipelines.RenderLayout ► SecurityCheck ► HasAccess()()()
Check credentials.
Declaration Syntax
C#
protected virtual bool HasAccess()
Return Value
true if this instance has access; otherwise, false.


IsLoginPageRequest Method

IsLoginPageRequest Method
Namespaces ► Sitecore.Pipelines.RenderLayout ► SecurityCheck ► IsLoginPageRequest()()()
Determines whether current request addresses the login page of the site.
Declaration Syntax
C#
protected virtual bool IsLoginPageRequest()
Return Value
true if current request addresses the login page of the site; otherwise, false.


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.RenderLayout ► SecurityCheck ► Process(RenderLayoutArgs)
Process query string.
Declaration Syntax
C#
public override void Process(
    RenderLayoutArgs args
)
Parameters
args (RenderLayoutArgs)
The arguments.


Sitecore.Pipelines.Save Namespace

Sitecore.Pipelines.Save Namespace
Namespaces ► Sitecore.Pipelines.Save
Declaration Syntax
C#
namespace Sitecore.Pipelines.Save
Types
All Types Classes
Icon | Type | Description
 | BeforeSaveEvent | Fires the before save event.
 | CheckItemLock | Checks whether items to be saved are locked and if they are it aborts the pipeline.
 | CheckLinks | Checks for broken links.
 | CheckLock | Checks locking.
 | CheckRevision | Parses the Xml into the data structure.
 | CheckTemplateFieldChange | Checks for broken links.
 | ConvertLayoutField | Processor for saving data.
 | ConvertToXHtml | Represents a ConvertToXHtml processor.
 | HasWritePermission | Checks write permissions.
 | Lock | Locks the item.
 | NewVersion | Creates a new version if needed.
 | ParseXml | Parses the Xml into the data structure.
 | PostAction | Dispatches the post action message.
 | RenderingHack | Ugly hack.
 | Save | Processor for saving data.
 | SaveArgs | Argument class for Save pipeline. Argument class for Save pipeline. Argument class for Save pipeline.
 | SaveArgs..::.SaveField | Holds a field for saving.
 | SaveArgs..::.SaveItem | Holds an item for saving.
 | TightenRelativeImageLinks | Processor for saving Html image links.
 | Unlock | Unlocks the item.
 | ValidateFields | Validates the fields.
 | Validators | Validates the fields.
 | WorkflowSaveCommand | Unlocks the item.


BeforeSaveEvent Class

BeforeSaveEvent Class
Namespaces ► Sitecore.Pipelines.Save ► BeforeSaveEvent
Fires the before save event.
Declaration Syntax
C#
public class BeforeSaveEvent
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BeforeSaveEvent()()() | Initializes a new instance of the BeforeSaveEvent class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BeforeSaveEvent


BeforeSaveEvent Constructor

BeforeSaveEvent Constructor
Namespaces ► Sitecore.Pipelines.Save ► BeforeSaveEvent ► BeforeSaveEvent()()()
Initializes a new instance of the BeforeSaveEvent class
Declaration Syntax
C#
public BeforeSaveEvent()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► BeforeSaveEvent ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


CheckItemLock Class

CheckItemLock Class
Namespaces ► Sitecore.Pipelines.Save ► CheckItemLock
Checks whether items to be saved are locked and if they are it aborts the pipeline.
Declaration Syntax
C#
public class CheckItemLock
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckItemLock()()() | Initializes a new instance of the CheckItemLock class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CheckItemLock


CheckItemLock Constructor

CheckItemLock Constructor
Namespaces ► Sitecore.Pipelines.Save ► CheckItemLock ► CheckItemLock()()()
Initializes a new instance of the CheckItemLock class
Declaration Syntax
C#
public CheckItemLock()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► CheckItemLock ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


CheckLinks Class

CheckLinks Class
Namespaces ► Sitecore.Pipelines.Save ► CheckLinks
Checks for broken links.
Declaration Syntax
C#
public class CheckLinks
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckLinks()()() | Initializes a new instance of the CheckLinks class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CheckLinks


CheckLinks Constructor

CheckLinks Constructor
Namespaces ► Sitecore.Pipelines.Save ► CheckLinks ► CheckLinks()()()
Initializes a new instance of the CheckLinks class
Declaration Syntax
C#
public CheckLinks()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► CheckLinks ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


CheckLock Class

CheckLock Class
Namespaces ► Sitecore.Pipelines.Save ► CheckLock
Checks locking.
Declaration Syntax
C#
public class CheckLock
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckLock()()() | Initializes a new instance of the CheckLock class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CheckLock


CheckLock Constructor

CheckLock Constructor
Namespaces ► Sitecore.Pipelines.Save ► CheckLock ► CheckLock()()()
Initializes a new instance of the CheckLock class
Declaration Syntax
C#
public CheckLock()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► CheckLock ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


CheckRevision Class

CheckRevision Class
Namespaces ► Sitecore.Pipelines.Save ► CheckRevision
Parses the Xml into the data structure.
Declaration Syntax
C#
public class CheckRevision
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckRevision()()() | Initializes a new instance of the CheckRevision class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CheckRevision


CheckRevision Constructor

CheckRevision Constructor
Namespaces ► Sitecore.Pipelines.Save ► CheckRevision ► CheckRevision()()()
Initializes a new instance of the CheckRevision class
Declaration Syntax
C#
public CheckRevision()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► CheckRevision ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


CheckTemplateFieldChange Class

CheckTemplateFieldChange Class
Namespaces ► Sitecore.Pipelines.Save ► CheckTemplateFieldChange
Checks for broken links.
Declaration Syntax
C#
public class CheckTemplateFieldChange
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckTemplateFieldChange()()() | Initializes a new instance of the CheckTemplateFieldChange class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CheckTemplateFieldChange


CheckTemplateFieldChange Constructor

CheckTemplateFieldChange Constructor
Namespaces ► Sitecore.Pipelines.Save ► CheckTemplateFieldChange ► CheckTemplateFieldChange()()()
Initializes a new instance of the CheckTemplateFieldChange class
Declaration Syntax
C#
public CheckTemplateFieldChange()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► CheckTemplateFieldChange ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


ConvertLayoutField Class

ConvertLayoutField Class
Namespaces ► Sitecore.Pipelines.Save ► ConvertLayoutField
Processor for saving data.
Declaration Syntax
C#
public class ConvertLayoutField
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConvertLayoutField()()() | Initializes a new instance of the ConvertLayoutField class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConvertLayoutField


ConvertLayoutField Constructor

ConvertLayoutField Constructor
Namespaces ► Sitecore.Pipelines.Save ► ConvertLayoutField ► ConvertLayoutField()()()
Initializes a new instance of the ConvertLayoutField class
Declaration Syntax
C#
public ConvertLayoutField()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► ConvertLayoutField ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


ConvertToXHtml Class

ConvertToXHtml Class
Namespaces ► Sitecore.Pipelines.Save ► ConvertToXHtml
Represents a ConvertToXHtml processor.
Declaration Syntax
C#
public class ConvertToXHtml
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConvertToXHtml()()() | Initializes a new instance of the ConvertToXHtml class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConvertToXHtml


ConvertToXHtml Constructor

ConvertToXHtml Constructor
Namespaces ► Sitecore.Pipelines.Save ► ConvertToXHtml ► ConvertToXHtml()()()
Initializes a new instance of the ConvertToXHtml class
Declaration Syntax
C#
public ConvertToXHtml()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► ConvertToXHtml ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


HasWritePermission Class

HasWritePermission Class
Namespaces ► Sitecore.Pipelines.Save ► HasWritePermission
Checks write permissions.
Declaration Syntax
C#
public class HasWritePermission
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HasWritePermission()()() | Initializes a new instance of the HasWritePermission class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HasWritePermission


HasWritePermission Constructor

HasWritePermission Constructor
Namespaces ► Sitecore.Pipelines.Save ► HasWritePermission ► HasWritePermission()()()
Initializes a new instance of the HasWritePermission class
Declaration Syntax
C#
public HasWritePermission()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► HasWritePermission ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


Lock Class

Lock Class
Namespaces ► Sitecore.Pipelines.Save ► Lock
Locks the item.
Declaration Syntax
C#
public class Lock
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Lock()()() | Initializes a new instance of the Lock class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetField(SaveArgs..::.SaveItem, ID) | Gets the field.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Lock


Lock Constructor

Lock Constructor
Namespaces ► Sitecore.Pipelines.Save ► Lock ► Lock()()()
Initializes a new instance of the Lock class
Declaration Syntax
C#
public Lock()


GetField Method (item, fieldID)

GetField Method (item, fieldID)
Namespaces ► Sitecore.Pipelines.Save ► Lock ► GetField(SaveArgs..::.SaveItem, ID)
Gets the field.
Declaration Syntax
C#
protected virtual SaveArgs..::.SaveField GetField(
    SaveArgs..::.SaveItem item,
    ID fieldID
)
Parameters
item (SaveArgs..::.SaveItem)
The item.
fieldID (ID)
The field ID.
Return Value


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► Lock ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


NewVersion Class

NewVersion Class
Namespaces ► Sitecore.Pipelines.Save ► NewVersion
Creates a new version if needed.
Declaration Syntax
C#
public class NewVersion
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NewVersion()()() | Initializes a new instance of the NewVersion class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NewVersion


NewVersion Constructor

NewVersion Constructor
Namespaces ► Sitecore.Pipelines.Save ► NewVersion ► NewVersion()()()
Initializes a new instance of the NewVersion class
Declaration Syntax
C#
public NewVersion()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► NewVersion ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


ParseXml Class

ParseXml Class
Namespaces ► Sitecore.Pipelines.Save ► ParseXml
Parses the Xml into the data structure.
Declaration Syntax
C#
public class ParseXml
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ParseXml()()() | Initializes a new instance of the ParseXml class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ParseXml


ParseXml Constructor

ParseXml Constructor
Namespaces ► Sitecore.Pipelines.Save ► ParseXml ► ParseXml()()()
Initializes a new instance of the ParseXml class
Declaration Syntax
C#
public ParseXml()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► ParseXml ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


PostAction Class

PostAction Class
Namespaces ► Sitecore.Pipelines.Save ► PostAction
Dispatches the post action message.
Declaration Syntax
C#
public class PostAction
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PostAction()()() | Initializes a new instance of the PostAction class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PostAction


PostAction Constructor

PostAction Constructor
Namespaces ► Sitecore.Pipelines.Save ► PostAction ► PostAction()()()
Initializes a new instance of the PostAction class
Declaration Syntax
C#
public PostAction()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► PostAction ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


RenderingHack Class

RenderingHack Class
Namespaces ► Sitecore.Pipelines.Save ► RenderingHack
Ugly hack.
Declaration Syntax
C#
public class RenderingHack
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenderingHack()()() | Initializes a new instance of the RenderingHack class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RenderingHack


RenderingHack Constructor

RenderingHack Constructor
Namespaces ► Sitecore.Pipelines.Save ► RenderingHack ► RenderingHack()()()
Initializes a new instance of the RenderingHack class
Declaration Syntax
C#
public RenderingHack()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► RenderingHack ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


Save Class

Save Class
Namespaces ► Sitecore.Pipelines.Save ► Save
Processor for saving data.
Declaration Syntax
C#
public class Save
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Save()()() | Initializes a new instance of the Save class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Save


Save Constructor

Save Constructor
Namespaces ► Sitecore.Pipelines.Save ► Save ► Save()()()
Initializes a new instance of the Save class
Declaration Syntax
C#
public Save()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► Save ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


SaveArgs Class

SaveArgs Class
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs
Argument class for Save pipeline.
Argument class for Save pipeline.
Argument class for Save pipeline.
Declaration Syntax
C#
[SerializableAttribute]
public class SaveArgs : ClientPipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SaveArgs(XmlDocument) | Initializes a new instance of the SaveArgs class.
 | SaveArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SaveArgs class from a serialization context.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets or sets the error.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
 | HasSheerUI | Gets or sets a value indicating whether this instance has sheer UI.
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
 | Items | Gets or sets the items.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
 | PolicyBasedLocking | Gets or sets a value indicating whether [policy based check in].
 | PostAction | Gets or sets the post action.
 | ProcessorDone()()() | A processor is done. (Overrides ClientPipelineArgs.ProcessorDone()()().)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
 | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | SaveAnimation | Gets or sets a value indicating whether [save animation].
 | SavedItems | Gets the saved items.
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitForPostBack()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | Xml | Gets or sets the XML.
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ClientPipelineArgs
 |  |  |  | SaveArgs


SaveArgs Constructor

SaveArgs Constructor
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► SaveArgs()()()
Members
Icon | Member | Description
 | SaveArgs(XmlDocument) | Initializes a new instance of the SaveArgs class.
 | SaveArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SaveArgs class from a serialization context.


SaveArgs Constructor (info, context)

SaveArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► SaveArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the SaveArgs class from a serialization context.
Declaration Syntax
C#
protected SaveArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialized data.
context (StreamingContext)
The context.


SaveArgs Constructor (xml)

SaveArgs Constructor (xml)
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► SaveArgs(XmlDocument)
Initializes a new instance of the SaveArgs class.
Declaration Syntax
C#
public SaveArgs(
    XmlDocument xml
)
Parameters
xml (XmlDocument)
The XML.


Error Property

Error Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► Error
Gets or sets the error.
Declaration Syntax
C#
public string Error { get; set; }
Value
The error.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


HasSheerUI Property

HasSheerUI Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► HasSheerUI
Gets or sets a value indicating whether this instance has sheer UI.
Declaration Syntax
C#
public bool HasSheerUI { get; set; }
Value
true if this instance has sheer UI; otherwise, false.


Items Property

Items Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► Items
Gets or sets the items.
Declaration Syntax
C#
public SaveArgs..::.SaveItem[] Items { get; set; }
Value
The items.


PolicyBasedLocking Property

PolicyBasedLocking Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► PolicyBasedLocking
Gets or sets a value indicating whether [policy based check in].
Declaration Syntax
C#
public bool PolicyBasedLocking { get; set; }
Value
true if [policy based check in]; otherwise, false.


PostAction Property

PostAction Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► PostAction
Gets or sets the post action.
Declaration Syntax
C#
public string PostAction { get; set; }
Value
The post action.


ProcessorDone Method

ProcessorDone Method
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► ProcessorDone()()()
A processor is done.
Declaration Syntax
C#
protected internal override void ProcessorDone()


SaveAnimation Property

SaveAnimation Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► SaveAnimation
Gets or sets a value indicating whether [save animation].
Declaration Syntax
C#
public bool SaveAnimation { get; set; }
Value
true if [save animation]; otherwise, false.


SavedItems Property

SavedItems Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► SavedItems
Gets the saved items.
Declaration Syntax
C#
public ArrayList SavedItems { get; }
Value
The saved items.


Xml Property

Xml Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► Xml
Gets or sets the XML.
Declaration Syntax
C#
public XmlDocument Xml { get; set; }
Value
The XML.


SaveArgs.SaveField Class

SaveArgs..::.SaveField Class
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► SaveArgs..::.SaveField
Holds a field for saving.
Declaration Syntax
C#
[SerializableAttribute]
public class SaveField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SaveArgs..::.SaveField()()() | Initializes a new instance of the SaveArgs..::.SaveField class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | The ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OriginalValue | The value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | The value.
Inheritance Hierarchy
Object
SaveArgs..::.SaveField


SaveArgs.SaveField Constructor

SaveArgs..::.SaveField Constructor
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs..::.SaveField ► SaveArgs..::.SaveField()()()
Initializes a new instance of the SaveArgs..::.SaveField class
Declaration Syntax
C#
public SaveField()


ID Property

ID Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs..::.SaveField ► ID
The ID.
Declaration Syntax
C#
public ID ID { get; set; }
Value
The id.


OriginalValue Property

OriginalValue Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs..::.SaveField ► OriginalValue
The value.
Declaration Syntax
C#
public string OriginalValue { get; set; }
Value
The original value.


Value Property

Value Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs..::.SaveField ► Value
The value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.


SaveArgs.SaveItem Class

SaveArgs..::.SaveItem Class
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs ► SaveArgs..::.SaveItem
Holds an item for saving.
Declaration Syntax
C#
[SerializableAttribute]
public class SaveItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SaveArgs..::.SaveItem()()() | Initializes a new instance of the SaveArgs..::.SaveItem class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fields | The fields.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | The ID.
 | Language | The language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Revision | Gets or sets the revision.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | The version.
Inheritance Hierarchy
Object
SaveArgs..::.SaveItem


SaveArgs.SaveItem Constructor

SaveArgs..::.SaveItem Constructor
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs..::.SaveItem ► SaveArgs..::.SaveItem()()()
Initializes a new instance of the SaveArgs..::.SaveItem class
Declaration Syntax
C#
public SaveItem()


Fields Property

Fields Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs..::.SaveItem ► Fields
The fields.
Declaration Syntax
C#
public SaveArgs..::.SaveField[] Fields { get; set; }
Value
The fields.


ID Property

ID Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs..::.SaveItem ► ID
The ID.
Declaration Syntax
C#
public ID ID { get; set; }
Value
The id.


Language Property

Language Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs..::.SaveItem ► Language
The language.
Declaration Syntax
C#
public Language Language { get; set; }
Value
The language.


Revision Property

Revision Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs..::.SaveItem ► Revision
Gets or sets the revision.
Declaration Syntax
C#
public string Revision { get; set; }
Value
The revision.


Version Property

Version Property
Namespaces ► Sitecore.Pipelines.Save ► SaveArgs..::.SaveItem ► Version
The version.
Declaration Syntax
C#
public Version Version { get; set; }
Value
The version.


TightenRelativeImageLinks Class

TightenRelativeImageLinks Class
Namespaces ► Sitecore.Pipelines.Save ► TightenRelativeImageLinks
Processor for saving Html image links.
Declaration Syntax
C#
public class TightenRelativeImageLinks
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TightenRelativeImageLinks()()() | Initializes a new instance of the TightenRelativeImageLinks class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TightenRelativeImageLinks


TightenRelativeImageLinks Constructor

TightenRelativeImageLinks Constructor
Namespaces ► Sitecore.Pipelines.Save ► TightenRelativeImageLinks ► TightenRelativeImageLinks()()()
Initializes a new instance of the TightenRelativeImageLinks class
Declaration Syntax
C#
public TightenRelativeImageLinks()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► TightenRelativeImageLinks ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


Unlock Class

Unlock Class
Namespaces ► Sitecore.Pipelines.Save ► Unlock
Unlocks the item.
Declaration Syntax
C#
public class Unlock
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Unlock()()() | Initializes a new instance of the Unlock class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Unlock


Unlock Constructor

Unlock Constructor
Namespaces ► Sitecore.Pipelines.Save ► Unlock ► Unlock()()()
Initializes a new instance of the Unlock class
Declaration Syntax
C#
public Unlock()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► Unlock ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


ValidateFields Class

ValidateFields Class
Namespaces ► Sitecore.Pipelines.Save ► ValidateFields
Validates the fields.
Declaration Syntax
C#
public class ValidateFields
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ValidateFields()()() | Initializes a new instance of the ValidateFields class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ValidateFields


ValidateFields Constructor

ValidateFields Constructor
Namespaces ► Sitecore.Pipelines.Save ► ValidateFields ► ValidateFields()()()
Initializes a new instance of the ValidateFields class
Declaration Syntax
C#
public ValidateFields()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► ValidateFields ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


Validators Class

Validators Class
Namespaces ► Sitecore.Pipelines.Save ► Validators
Validates the fields.
Declaration Syntax
C#
public class Validators
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Validators()()() | Initializes a new instance of the Validators class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ProcessInternal(ClientPipelineArgs) | Processes the internal.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Validators
 |  | Validate


Validators Constructor

Validators Constructor
Namespaces ► Sitecore.Pipelines.Save ► Validators ► Validators()()()
Initializes a new instance of the Validators class
Declaration Syntax
C#
public Validators()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► Validators ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


ProcessInternal Method (args)

ProcessInternal Method (args)
Namespaces ► Sitecore.Pipelines.Save ► Validators ► ProcessInternal(ClientPipelineArgs)
Processes the internal.
Declaration Syntax
C#
protected void ProcessInternal(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


WorkflowSaveCommand Class

WorkflowSaveCommand Class
Namespaces ► Sitecore.Pipelines.Save ► WorkflowSaveCommand
Unlocks the item.
Declaration Syntax
C#
public class WorkflowSaveCommand
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WorkflowSaveCommand()()() | Initializes a new instance of the WorkflowSaveCommand class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WorkflowSaveCommand


WorkflowSaveCommand Constructor

WorkflowSaveCommand Constructor
Namespaces ► Sitecore.Pipelines.Save ► WorkflowSaveCommand ► WorkflowSaveCommand()()()
Initializes a new instance of the WorkflowSaveCommand class
Declaration Syntax
C#
public WorkflowSaveCommand()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Save ► WorkflowSaveCommand ► Process(SaveArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveArgs args
)
Parameters
args (SaveArgs)
The arguments.


Sitecore.Pipelines.SaveHtml Namespace

Sitecore.Pipelines.SaveHtml Namespace
Namespaces ► Sitecore.Pipelines.SaveHtml
Declaration Syntax
C#
namespace Sitecore.Pipelines.SaveHtml
Types
All Types Classes
Icon | Type | Description
 | Accept | Asks the user to accept.
 | ConvertToDesignTime | Converts the Html to design time Html.
 | SaveHtmlArgs | Argument class for the Save Html pipeline.


Accept Class

Accept Class
Namespaces ► Sitecore.Pipelines.SaveHtml ► Accept
Asks the user to accept.
Declaration Syntax
C#
public class Accept
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Accept()()() | Initializes a new instance of the Accept class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveHtmlArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Accept


Accept Constructor

Accept Constructor
Namespaces ► Sitecore.Pipelines.SaveHtml ► Accept ► Accept()()()
Initializes a new instance of the Accept class
Declaration Syntax
C#
public Accept()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.SaveHtml ► Accept ► Process(SaveHtmlArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveHtmlArgs args
)
Parameters
args (SaveHtmlArgs)
The arguments.


ConvertToDesignTime Class

ConvertToDesignTime Class
Namespaces ► Sitecore.Pipelines.SaveHtml ► ConvertToDesignTime
Converts the Html to design time Html.
Declaration Syntax
C#
public class ConvertToDesignTime
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConvertToDesignTime()()() | Initializes a new instance of the ConvertToDesignTime class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveHtmlArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConvertToDesignTime


ConvertToDesignTime Constructor

ConvertToDesignTime Constructor
Namespaces ► Sitecore.Pipelines.SaveHtml ► ConvertToDesignTime ► ConvertToDesignTime()()()
Initializes a new instance of the ConvertToDesignTime class
Declaration Syntax
C#
public ConvertToDesignTime()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.SaveHtml ► ConvertToDesignTime ► Process(SaveHtmlArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveHtmlArgs args
)
Parameters
args (SaveHtmlArgs)
The arguments.


SaveHtmlArgs Class

SaveHtmlArgs Class
Namespaces ► Sitecore.Pipelines.SaveHtml ► SaveHtmlArgs
Argument class for the Save Html pipeline.
Declaration Syntax
C#
[SerializableAttribute]
public class SaveHtmlArgs : ClientPipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SaveHtmlArgs(NameValueCollection) | Initializes a new instance of the SaveHtmlArgs class.
 | SaveHtmlArgs()()() | Initializes a new instance of the SaveHtmlArgs class.
 | SaveHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SaveHtmlArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | Body | Gets or sets the body.
 | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
 | Code | Gets or sets the code.
 | CodeFilename | Gets or sets the code filename.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Footer | Gets or sets the footer.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
 | Header | Gets or sets the header.
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
 | ProcessorDone()()() | A processor is done. (Overrides ClientPipelineArgs.ProcessorDone()()().)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
 | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitForPostBack()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ClientPipelineArgs
 |  |  |  | SaveHtmlArgs


SaveHtmlArgs Constructor

SaveHtmlArgs Constructor
Namespaces ► Sitecore.Pipelines.SaveHtml ► SaveHtmlArgs ► SaveHtmlArgs()()()
Members
Icon | Member | Description
 | SaveHtmlArgs(NameValueCollection) | Initializes a new instance of the SaveHtmlArgs class.
 | SaveHtmlArgs()()() | Initializes a new instance of the SaveHtmlArgs class.
 | SaveHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SaveHtmlArgs class.


SaveHtmlArgs Constructor

SaveHtmlArgs Constructor
Namespaces ► Sitecore.Pipelines.SaveHtml ► SaveHtmlArgs ► SaveHtmlArgs()()()
Initializes a new instance of the SaveHtmlArgs class.
Declaration Syntax
C#
public SaveHtmlArgs()


SaveHtmlArgs Constructor (parameters)

SaveHtmlArgs Constructor (parameters)
Namespaces ► Sitecore.Pipelines.SaveHtml ► SaveHtmlArgs ► SaveHtmlArgs(NameValueCollection)
Initializes a new instance of the SaveHtmlArgs class.
Declaration Syntax
C#
public SaveHtmlArgs(
    NameValueCollection parameters
)
Parameters
parameters (NameValueCollection)
The parameters.


SaveHtmlArgs Constructor (info, context)

SaveHtmlArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.SaveHtml ► SaveHtmlArgs ► SaveHtmlArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the SaveHtmlArgs class.
Declaration Syntax
C#
protected SaveHtmlArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


Body Property

Body Property
Namespaces ► Sitecore.Pipelines.SaveHtml ► SaveHtmlArgs ► Body
Gets or sets the body.
Declaration Syntax
C#
public string Body { get; set; }
Value
The body.


Code Property

Code Property
Namespaces ► Sitecore.Pipelines.SaveHtml ► SaveHtmlArgs ► Code
Gets or sets the code.
Declaration Syntax
C#
public string Code { get; set; }
Value
The code.


CodeFilename Property

CodeFilename Property
Namespaces ► Sitecore.Pipelines.SaveHtml ► SaveHtmlArgs ► CodeFilename
Gets or sets the code filename.
Declaration Syntax
C#
public string CodeFilename { get; set; }
Value
The code filename.


Footer Property

Footer Property
Namespaces ► Sitecore.Pipelines.SaveHtml ► SaveHtmlArgs ► Footer
Gets or sets the footer.
Declaration Syntax
C#
public string Footer { get; set; }
Value
The footer.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.SaveHtml ► SaveHtmlArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Header Property

Header Property
Namespaces ► Sitecore.Pipelines.SaveHtml ► SaveHtmlArgs ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


ProcessorDone Method

ProcessorDone Method
Namespaces ► Sitecore.Pipelines.SaveHtml ► SaveHtmlArgs ► ProcessorDone()()()
A processor is done.
Declaration Syntax
C#
protected internal override void ProcessorDone()


Sitecore.Pipelines.SaveLayout Namespace

Sitecore.Pipelines.SaveLayout Namespace
Namespaces ► Sitecore.Pipelines.SaveLayout
Declaration Syntax
C#
namespace Sitecore.Pipelines.SaveLayout
Types
All Types Classes Enumerations
Icon | Type | Description
 | ConvertToRuntime | Represents a ConvertToRuntime processor.
 | ConvertToXHtml | Converts the body to XHtml.
 | SaveLayoutArgs..::.LayoutType | Defines the type of layout.
 | NewFile | Creates a new file.
 | Overwrite | Overwrites and existing file.
 | Save | Saves the layout.
 | SaveLayoutArgs | Argument class for ILoginProcessor implementations


ConvertToRuntime Class

ConvertToRuntime Class
Namespaces ► Sitecore.Pipelines.SaveLayout ► ConvertToRuntime
Represents a ConvertToRuntime processor.
Declaration Syntax
C#
public class ConvertToRuntime
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConvertToRuntime()()() | Initializes a new instance of the ConvertToRuntime class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveLayoutArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConvertToRuntime


ConvertToRuntime Constructor

ConvertToRuntime Constructor
Namespaces ► Sitecore.Pipelines.SaveLayout ► ConvertToRuntime ► ConvertToRuntime()()()
Initializes a new instance of the ConvertToRuntime class
Declaration Syntax
C#
public ConvertToRuntime()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.SaveLayout ► ConvertToRuntime ► Process(SaveLayoutArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveLayoutArgs args
)
Parameters
args (SaveLayoutArgs)
The arguments.


ConvertToXHtml Class

ConvertToXHtml Class
Namespaces ► Sitecore.Pipelines.SaveLayout ► ConvertToXHtml
Converts the body to XHtml.
Declaration Syntax
C#
public class ConvertToXHtml
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConvertToXHtml()()() | Initializes a new instance of the ConvertToXHtml class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveLayoutArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConvertToXHtml


ConvertToXHtml Constructor

ConvertToXHtml Constructor
Namespaces ► Sitecore.Pipelines.SaveLayout ► ConvertToXHtml ► ConvertToXHtml()()()
Initializes a new instance of the ConvertToXHtml class
Declaration Syntax
C#
public ConvertToXHtml()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.SaveLayout ► ConvertToXHtml ► Process(SaveLayoutArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveLayoutArgs args
)
Parameters
args (SaveLayoutArgs)
The arguments.


NewFile Class

NewFile Class
Namespaces ► Sitecore.Pipelines.SaveLayout ► NewFile
Creates a new file.
Declaration Syntax
C#
public class NewFile
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NewFile()()() | Initializes a new instance of the NewFile class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveLayoutArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NewFile


NewFile Constructor

NewFile Constructor
Namespaces ► Sitecore.Pipelines.SaveLayout ► NewFile ► NewFile()()()
Initializes a new instance of the NewFile class
Declaration Syntax
C#
public NewFile()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.SaveLayout ► NewFile ► Process(SaveLayoutArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveLayoutArgs args
)
Parameters
args (SaveLayoutArgs)
The arguments.


Overwrite Class

Overwrite Class
Namespaces ► Sitecore.Pipelines.SaveLayout ► Overwrite
Overwrites and existing file.
Declaration Syntax
C#
public class Overwrite
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Overwrite()()() | Initializes a new instance of the Overwrite class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveLayoutArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Overwrite


Overwrite Constructor

Overwrite Constructor
Namespaces ► Sitecore.Pipelines.SaveLayout ► Overwrite ► Overwrite()()()
Initializes a new instance of the Overwrite class
Declaration Syntax
C#
public Overwrite()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.SaveLayout ► Overwrite ► Process(SaveLayoutArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveLayoutArgs args
)
Parameters
args (SaveLayoutArgs)
The arguments.


Save Class

Save Class
Namespaces ► Sitecore.Pipelines.SaveLayout ► Save
Saves the layout.
Declaration Syntax
C#
public class Save
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Save()()() | Initializes a new instance of the Save class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SaveLayoutArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Save


Save Constructor

Save Constructor
Namespaces ► Sitecore.Pipelines.SaveLayout ► Save ► Save()()()
Initializes a new instance of the Save class
Declaration Syntax
C#
public Save()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.SaveLayout ► Save ► Process(SaveLayoutArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SaveLayoutArgs args
)
Parameters
args (SaveLayoutArgs)
The arguments.


SaveLayoutArgs Class

SaveLayoutArgs Class
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs
Argument class for ILoginProcessor implementations
Declaration Syntax
C#
[SerializableAttribute]
public class SaveLayoutArgs : ClientPipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SaveLayoutArgs()()() | Initializes a new instance of the SaveLayoutArgs class.
 | SaveLayoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SaveLayoutArgs class from a serialization context.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | Body | Gets or sets the body.
 | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
 | Code | Gets or sets the code.
 | CodeFilename | Gets or sets the code filename.
 | ConvertToRuntime | Gets or sets a value indicating whether the layout should be converted to runtime HTML.
 | ConvertToXHtml | Gets or sets a value indicating whether the layout is converted to XHTML.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Filename | Gets or sets the filename.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Footer | Gets or sets the footer.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
 | Header | Gets or sets the header.
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
 | LastWriteTime | Gets or sets the last write time.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
 | ProcessorDone()()() | A processor is done. (Overrides ClientPipelineArgs.ProcessorDone()()().)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
 | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets or sets the type.
 | WaitForPostBack()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ClientPipelineArgs
 |  |  |  | SaveLayoutArgs


SaveLayoutArgs Constructor

SaveLayoutArgs Constructor
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► SaveLayoutArgs()()()
Members
Icon | Member | Description
 | SaveLayoutArgs()()() | Initializes a new instance of the SaveLayoutArgs class.
 | SaveLayoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SaveLayoutArgs class from a serialization context.


SaveLayoutArgs Constructor

SaveLayoutArgs Constructor
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► SaveLayoutArgs()()()
Initializes a new instance of the SaveLayoutArgs class.
Declaration Syntax
C#
public SaveLayoutArgs()


SaveLayoutArgs Constructor (info, context)

SaveLayoutArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► SaveLayoutArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the SaveLayoutArgs class from a serialization context.
Declaration Syntax
C#
protected SaveLayoutArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialized data.
context (StreamingContext)
The context.


Body Property

Body Property
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► Body
Gets or sets the body.
Declaration Syntax
C#
public string Body { get; set; }
Value
The body.


Code Property

Code Property
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► Code
Gets or sets the code.
Declaration Syntax
C#
public string Code { get; set; }
Value
The code.


CodeFilename Property

CodeFilename Property
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► CodeFilename
Gets or sets the code filename.
Declaration Syntax
C#
public string CodeFilename { get; set; }
Value
The code filename.


ConvertToRuntime Property

ConvertToRuntime Property
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► ConvertToRuntime
Gets or sets a value indicating whether the layout should be converted to runtime HTML.
Declaration Syntax
C#
public bool ConvertToRuntime { get; set; }
Value
true if the layout should be converted to runtime HTML; otherwise, false.


ConvertToXHtml Property

ConvertToXHtml Property
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► ConvertToXHtml
Gets or sets a value indicating whether the layout is converted to XHTML.
Declaration Syntax
C#
public bool ConvertToXHtml { get; set; }
Value
true if the layout is converted to XHTML; otherwise, false.


Filename Property

Filename Property
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► Filename
Gets or sets the filename.
Declaration Syntax
C#
public string Filename { get; set; }
Value
The filename.


Footer Property

Footer Property
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► Footer
Gets or sets the footer.
Declaration Syntax
C#
public string Footer { get; set; }
Value
The footer.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Header Property

Header Property
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


LastWriteTime Property

LastWriteTime Property
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► LastWriteTime
Gets or sets the last write time.
Declaration Syntax
C#
public DateTime LastWriteTime { get; set; }
Value
The last write time.


ProcessorDone Method

ProcessorDone Method
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► ProcessorDone()()()
A processor is done.
Declaration Syntax
C#
protected internal override void ProcessorDone()


Type Property

Type Property
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► Type
Gets or sets the type.
Declaration Syntax
C#
public SaveLayoutArgs..::.LayoutType Type { get; set; }
Value
The type.


SaveLayoutArgs.LayoutType Enumeration

SaveLayoutArgs..::.LayoutType Enumeration
Namespaces ► Sitecore.Pipelines.SaveLayout ► SaveLayoutArgs ► SaveLayoutArgs..::.LayoutType
Defines the type of layout.
Declaration Syntax
C#
public enum LayoutType
Members
Member | Description
Layout | Layout.
Sublayout | Sublayout.
Other | Other.


Sitecore.Pipelines.Search Namespace

Sitecore.Pipelines.Search Namespace
Namespaces ► Sitecore.Pipelines.Search
Declaration Syntax
C#
namespace Sitecore.Pipelines.Search
Types
All Types Classes
Icon | Type | Description
 | AddInstantOptions | Adds the instant search options.
 | CategorizeResults..::.Categorizer | Categorizes search results.
 | CategorizeResults | Categorizes the results. Categorizes the results. Categorizes the results. Categorizes the results. Categorizes the results.
 | CategorizeResults..::.Category | Represents a search result category
 | DatabaseResolver | Allows database switching in instant searches.
 | IDResolver | Resolves id searches.
 | CategorizeResults..::.PathCategory | Represents a path based category
 | PathResolver | Resolves path searches
 | SearchArgs | Arguments for search pipeline.
 | SearchSystemIndex | Searches the system index.
 | SecurityResolver | Resolves the security based searches, such as users and roles.
 | CategorizeResults..::.TemplateCategory | Represents a template based category.
 | UrlResolver | Resolves url searchers.


AddInstantOptions Class

AddInstantOptions Class
Namespaces ► Sitecore.Pipelines.Search ► AddInstantOptions
Adds the instant search options.
Declaration Syntax
C#
public class AddInstantOptions
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddInstantOptions()()() | Initializes a new instance of the AddInstantOptions class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SearchArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AddInstantOptions


AddInstantOptions Constructor

AddInstantOptions Constructor
Namespaces ► Sitecore.Pipelines.Search ► AddInstantOptions ► AddInstantOptions()()()
Initializes a new instance of the AddInstantOptions class
Declaration Syntax
C#
public AddInstantOptions()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Search ► AddInstantOptions ► Process(SearchArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SearchArgs args
)
Parameters
args (SearchArgs)
The arguments.


CategorizeResults Class

CategorizeResults Class
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults
Categorizes the results.
Categorizes the results.
Categorizes the results.
Categorizes the results.
Categorizes the results.
Declaration Syntax
C#
public class CategorizeResults
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CategorizeResults()()() | Initializes a new instance of the CategorizeResults class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SearchArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CategorizeResults


CategorizeResults Constructor

CategorizeResults Constructor
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults ► CategorizeResults()()()
Initializes a new instance of the CategorizeResults class
Declaration Syntax
C#
public CategorizeResults()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults ► Process(SearchArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SearchArgs args
)
Parameters
args (SearchArgs)
The arguments.


CategorizeResults.Categorizer Class

CategorizeResults..::.Categorizer Class
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults ► CategorizeResults..::.Categorizer
Categorizes search results.
Declaration Syntax
C#
public class Categorizer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CategorizeResults..::.Categorizer()()() | Initializes a new instance of the CategorizeResults..::.Categorizer class
 | AddCategory(CategorizeResults..::.Category) | Adds the category.
 | AddCategory(CategorizeResults..::.Category, Int32) | Adds the category.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCategory(Item) | Gets the category.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CategorizeResults..::.Categorizer


CategorizeResults.Categorizer Constructor

CategorizeResults..::.Categorizer Constructor
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.Categorizer ► CategorizeResults..::.Categorizer()()()
Initializes a new instance of the CategorizeResults..::.Categorizer class
Declaration Syntax
C#
public Categorizer()


AddCategory Method

AddCategory Method
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.Categorizer ► AddCategory()()()
Members
Icon | Member | Description
 | AddCategory(CategorizeResults..::.Category) | Adds the category.
 | AddCategory(CategorizeResults..::.Category, Int32) | Adds the category.


AddCategory Method (category)

AddCategory Method (category)
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.Categorizer ► AddCategory(CategorizeResults..::.Category)
Adds the category.
Declaration Syntax
C#
public void AddCategory(
    CategorizeResults..::.Category category
)
Parameters
category (CategorizeResults..::.Category)
The item.


AddCategory Method (category, index)

AddCategory Method (category, index)
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.Categorizer ► AddCategory(CategorizeResults..::.Category, Int32)
Adds the category.
Declaration Syntax
C#
public void AddCategory(
    CategorizeResults..::.Category category,
    int index
)
Parameters
category (CategorizeResults..::.Category)
The item.
index (Int32)
The index.


GetCategory Method (item)

GetCategory Method (item)
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.Categorizer ► GetCategory(Item)
Gets the category.
Declaration Syntax
C#
public virtual string GetCategory(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The category.


CategorizeResults.Category Class

CategorizeResults..::.Category Class
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults ► CategorizeResults..::.Category
Represents a search result category
Declaration Syntax
C#
public abstract class Category
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategorizeResults..::.Category()()() | Initializes a new instance of the CategorizeResults..::.Category class.
 | CategorizeResults..::.Category(String) | Initializes a new instance of the CategorizeResults..::.Category class.
 | DisplayName | Gets or sets the display name.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAutoDisplayName()()() | Gets the display name of the auto.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Matches(Item) | Matcheses the specified item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CategorizeResults..::.Category
 |  | CategorizeResults..::.PathCategory
 |  | CategorizeResults..::.TemplateCategory


CategorizeResults.Category Constructor

CategorizeResults..::.Category Constructor
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.Category ► CategorizeResults..::.Category()()()
Members
Icon | Member | Description
 | CategorizeResults..::.Category()()() | Initializes a new instance of the CategorizeResults..::.Category class.
 | CategorizeResults..::.Category(String) | Initializes a new instance of the CategorizeResults..::.Category class.


CategorizeResults.Category Constructor

CategorizeResults..::.Category Constructor
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.Category ► CategorizeResults..::.Category()()()
Initializes a new instance of the CategorizeResults..::.Category class.
Declaration Syntax
C#
public Category()


CategorizeResults.Category Constructor (displayName)

CategorizeResults..::.Category Constructor (displayName)
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.Category ► CategorizeResults..::.Category(String)
Initializes a new instance of the CategorizeResults..::.Category class.
Declaration Syntax
C#
public Category(
    string displayName
)
Parameters
displayName (String)
The display name.


DisplayName Property

DisplayName Property
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.Category ► DisplayName
Gets or sets the display name.
Declaration Syntax
C#
public string DisplayName { get; set; }
Value
The display name.


GetAutoDisplayName Method

GetAutoDisplayName Method
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.Category ► GetAutoDisplayName()()()
Gets the display name of the auto.
Declaration Syntax
C#
protected virtual string GetAutoDisplayName()
Return Value
The auto display name.


Matches Method (item)

Matches Method (item)
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.Category ► Matches(Item)
Matcheses the specified item.
Declaration Syntax
C#
public abstract bool Matches(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The matches.


CategorizeResults.PathCategory Class

CategorizeResults..::.PathCategory Class
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults ► CategorizeResults..::.PathCategory
Represents a path based category
Declaration Syntax
C#
public class PathCategory : CategorizeResults..::.Category
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategorizeResults..::.PathCategory(Item, String) | Initializes a new instance of the CategorizeResults..::.PathCategory class.
 | DisplayName | Gets or sets the display name. (Inherited from CategorizeResults..::.Category.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAutoDisplayName()()() | Gets the display name of the auto. (Overrides CategorizeResults..::.Category.GetAutoDisplayName()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Matches(Item) | Matcheses the specified item. (Overrides CategorizeResults..::.Category.Matches(Item).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Root | Gets or sets the root.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CategorizeResults..::.Category
 |  | CategorizeResults..::.PathCategory


CategorizeResults.PathCategory Constructor (root, displayName)

CategorizeResults..::.PathCategory Constructor (root, displayName)
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.PathCategory ► CategorizeResults..::.PathCategory(Item, String)
Initializes a new instance of the CategorizeResults..::.PathCategory class.
Declaration Syntax
C#
public PathCategory(
    Item root,
    string displayName
)
Parameters
root (Item)
The root.
displayName (String)
The display name.


GetAutoDisplayName Method

GetAutoDisplayName Method
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.PathCategory ► GetAutoDisplayName()()()
Gets the display name of the auto.
Declaration Syntax
C#
protected override string GetAutoDisplayName()
Return Value
The auto display name.


Matches Method (item)

Matches Method (item)
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.PathCategory ► Matches(Item)
Matcheses the specified item.
Declaration Syntax
C#
public override bool Matches(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The matches.


Root Property

Root Property
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.PathCategory ► Root
Gets or sets the root.
Declaration Syntax
C#
public Item Root { get; set; }
Value
The root.


CategorizeResults.TemplateCategory Class

CategorizeResults..::.TemplateCategory Class
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults ► CategorizeResults..::.TemplateCategory
Represents a template based category.
Declaration Syntax
C#
public class TemplateCategory : CategorizeResults..::.Category
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategorizeResults..::.TemplateCategory(IList<(Of <(ID>)>), String) | Initializes a new instance of the CategorizeResults..::.TemplateCategory class.
 | DisplayName | Gets or sets the display name. (Inherited from CategorizeResults..::.Category.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAutoDisplayName()()() | Gets the display name of the auto. (Inherited from CategorizeResults..::.Category.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Matches(Item) | Matcheses the specified item. (Overrides CategorizeResults..::.Category.Matches(Item).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TemplateIDs | Gets the template ID.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CategorizeResults..::.Category
 |  | CategorizeResults..::.TemplateCategory


CategorizeResults.TemplateCategory Constructor (templateIDs, displayName)

CategorizeResults..::.TemplateCategory Constructor (templateIDs, displayName)
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.TemplateCategory ► CategorizeResults..::.TemplateCategory(IList<(Of <(ID>)>), String)
Initializes a new instance of the CategorizeResults..::.TemplateCategory class.
Declaration Syntax
C#
public TemplateCategory(
    IList<ID> templateIDs,
    string displayName
)
Parameters
templateIDs (IList<(Of <( ID >)>))
The _template ID.
displayName (String)
The display name.


Matches Method (item)

Matches Method (item)
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.TemplateCategory ► Matches(Item)
Matcheses the specified item.
Declaration Syntax
C#
public override bool Matches(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The matches.


TemplateIDs Property

TemplateIDs Property
Namespaces ► Sitecore.Pipelines.Search ► CategorizeResults..::.TemplateCategory ► TemplateIDs
Gets the template ID.
Declaration Syntax
C#
public IList<ID> TemplateIDs { get; }
Value
The template ID.


DatabaseResolver Class

DatabaseResolver Class
Namespaces ► Sitecore.Pipelines.Search ► DatabaseResolver
Allows database switching in instant searches.
Declaration Syntax
C#
public class DatabaseResolver
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DatabaseResolver()()() | Initializes a new instance of the DatabaseResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SearchArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DatabaseResolver


DatabaseResolver Constructor

DatabaseResolver Constructor
Namespaces ► Sitecore.Pipelines.Search ► DatabaseResolver ► DatabaseResolver()()()
Initializes a new instance of the DatabaseResolver class
Declaration Syntax
C#
public DatabaseResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Search ► DatabaseResolver ► Process(SearchArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SearchArgs args
)
Parameters
args (SearchArgs)
The arguments.


IDResolver Class

IDResolver Class
Namespaces ► Sitecore.Pipelines.Search ► IDResolver
Resolves id searches.
Declaration Syntax
C#
public class IDResolver
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IDResolver()()() | Initializes a new instance of the IDResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SearchArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
IDResolver


IDResolver Constructor

IDResolver Constructor
Namespaces ► Sitecore.Pipelines.Search ► IDResolver ► IDResolver()()()
Initializes a new instance of the IDResolver class
Declaration Syntax
C#
public IDResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Search ► IDResolver ► Process(SearchArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SearchArgs args
)
Parameters
args (SearchArgs)
The arguments.


PathResolver Class

PathResolver Class
Namespaces ► Sitecore.Pipelines.Search ► PathResolver
Resolves path searches
Declaration Syntax
C#
public class PathResolver
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PathResolver()()() | Initializes a new instance of the PathResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SearchArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PathResolver


PathResolver Constructor

PathResolver Constructor
Namespaces ► Sitecore.Pipelines.Search ► PathResolver ► PathResolver()()()
Initializes a new instance of the PathResolver class
Declaration Syntax
C#
public PathResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Search ► PathResolver ► Process(SearchArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SearchArgs args
)
Parameters
args (SearchArgs)
The arguments.


SearchArgs Class

SearchArgs Class
Namespaces ► Sitecore.Pipelines.Search ► SearchArgs
Arguments for search pipeline.
Declaration Syntax
C#
[SerializableAttribute]
public class SearchArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchArgs(String) | Initializes a new instance of the SearchArgs class.
 | SearchArgs(QueryBase) | Initializes a new instance of the SearchArgs class.
 | SearchArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SearchArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Database | Gets or sets the database.
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | Limit | Gets or sets the limit.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Query | Gets or sets the query.
 | Result | Gets or sets the results.
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Root | Gets or sets the root.
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | TextQuery | Gets or sets the query.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets or sets the type.
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | SearchArgs


SearchArgs Constructor

SearchArgs Constructor
Namespaces ► Sitecore.Pipelines.Search ► SearchArgs ► SearchArgs()()()
Members
Icon | Member | Description
 | SearchArgs(String) | Initializes a new instance of the SearchArgs class.
 | SearchArgs(QueryBase) | Initializes a new instance of the SearchArgs class.
 | SearchArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SearchArgs class.


SearchArgs Constructor (query)

SearchArgs Constructor (query)
Namespaces ► Sitecore.Pipelines.Search ► SearchArgs ► SearchArgs(QueryBase)
Initializes a new instance of the SearchArgs class.
Declaration Syntax
C#
public SearchArgs(
    QueryBase query
)
Parameters
query (QueryBase)
The query.


SearchArgs Constructor (info, context)

SearchArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.Search ► SearchArgs ► SearchArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the SearchArgs class.
Declaration Syntax
C#
protected SearchArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


SearchArgs Constructor (query)

SearchArgs Constructor (query)
Namespaces ► Sitecore.Pipelines.Search ► SearchArgs ► SearchArgs(String)
Initializes a new instance of the SearchArgs class.
Declaration Syntax
C#
public SearchArgs(
    string query
)
Parameters
query (String)
The query.


Database Property

Database Property
Namespaces ► Sitecore.Pipelines.Search ► SearchArgs ► Database
Gets or sets the database.
Declaration Syntax
C#
public Database Database { get; set; }
Value
The database.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.Search ► SearchArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Limit Property

Limit Property
Namespaces ► Sitecore.Pipelines.Search ► SearchArgs ► Limit
Gets or sets the limit.
Declaration Syntax
C#
public int Limit { get; set; }
Value
The limit.


Query Property

Query Property
Namespaces ► Sitecore.Pipelines.Search ► SearchArgs ► Query
Gets or sets the query.
Declaration Syntax
C#
public QueryBase Query { get; set; }
Value
The query.


Result Property

Result Property
Namespaces ► Sitecore.Pipelines.Search ► SearchArgs ► Result
Gets or sets the results.
Declaration Syntax
C#
public SearchResultCollection Result { get; set; }
Value
The results.


Root Property

Root Property
Namespaces ► Sitecore.Pipelines.Search ► SearchArgs ► Root
Gets or sets the root.
Declaration Syntax
C#
public Item Root { get; set; }
Value
The root.


TextQuery Property

TextQuery Property
Namespaces ► Sitecore.Pipelines.Search ► SearchArgs ► TextQuery
Gets or sets the query.
Declaration Syntax
C#
public string TextQuery { get; }
Value
The query.


Type Property

Type Property
Namespaces ► Sitecore.Pipelines.Search ► SearchArgs ► Type
Gets or sets the type.
Declaration Syntax
C#
public SearchType Type { get; set; }
Value
The type.


SearchSystemIndex Class

SearchSystemIndex Class
Namespaces ► Sitecore.Pipelines.Search ► SearchSystemIndex
Searches the system index.
Declaration Syntax
C#
public class SearchSystemIndex
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SearchSystemIndex()()() | Initializes a new instance of the SearchSystemIndex class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SearchArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SearchSystemIndex


SearchSystemIndex Constructor

SearchSystemIndex Constructor
Namespaces ► Sitecore.Pipelines.Search ► SearchSystemIndex ► SearchSystemIndex()()()
Initializes a new instance of the SearchSystemIndex class
Declaration Syntax
C#
public SearchSystemIndex()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Search ► SearchSystemIndex ► Process(SearchArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SearchArgs args
)
Parameters
args (SearchArgs)
The arguments.


SecurityResolver Class

SecurityResolver Class
Namespaces ► Sitecore.Pipelines.Search ► SecurityResolver
Resolves the security based searches, such as users and roles.
Declaration Syntax
C#
public class SecurityResolver
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SecurityResolver()()() | Initializes a new instance of the SecurityResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SearchArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SecurityResolver


SecurityResolver Constructor

SecurityResolver Constructor
Namespaces ► Sitecore.Pipelines.Search ► SecurityResolver ► SecurityResolver()()()
Initializes a new instance of the SecurityResolver class
Declaration Syntax
C#
public SecurityResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Search ► SecurityResolver ► Process(SearchArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SearchArgs args
)
Parameters
args (SearchArgs)
The arguments.


UrlResolver Class

UrlResolver Class
Namespaces ► Sitecore.Pipelines.Search ► UrlResolver
Resolves url searchers.
Declaration Syntax
C#
public class UrlResolver
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UrlResolver()()() | Initializes a new instance of the UrlResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SearchArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UrlResolver


UrlResolver Constructor

UrlResolver Constructor
Namespaces ► Sitecore.Pipelines.Search ► UrlResolver ► UrlResolver()()()
Initializes a new instance of the UrlResolver class
Declaration Syntax
C#
public UrlResolver()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Search ► UrlResolver ► Process(SearchArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SearchArgs args
)
Parameters
args (SearchArgs)
The arguments.


Sitecore.Pipelines.SessionEnd Namespace

Sitecore.Pipelines.SessionEnd Namespace
Namespaces ► Sitecore.Pipelines.SessionEnd
Declaration Syntax
C#
namespace Sitecore.Pipelines.SessionEnd
Types
All Types Classes
Icon | Type | Description
 | SaveRecentDocuments | Saves the recent documents.
 | SessionEndArgs | Argument class for Session End pipeline.


SaveRecentDocuments Class

SaveRecentDocuments Class
Namespaces ► Sitecore.Pipelines.SessionEnd ► SaveRecentDocuments
Saves the recent documents.
Declaration Syntax
C#
public class SaveRecentDocuments
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SaveRecentDocuments()()() | Initializes a new instance of the SaveRecentDocuments class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SessionEndArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SaveRecentDocuments


SaveRecentDocuments Constructor

SaveRecentDocuments Constructor
Namespaces ► Sitecore.Pipelines.SessionEnd ► SaveRecentDocuments ► SaveRecentDocuments()()()
Initializes a new instance of the SaveRecentDocuments class
Declaration Syntax
C#
public SaveRecentDocuments()


Process Method (endArgs)

Process Method (endArgs)
Namespaces ► Sitecore.Pipelines.SessionEnd ► SaveRecentDocuments ► Process(SessionEndArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SessionEndArgs endArgs
)
Parameters
endArgs (SessionEndArgs)
The end args.


SessionEndArgs Class

SessionEndArgs Class
Namespaces ► Sitecore.Pipelines.SessionEnd ► SessionEndArgs
Argument class for Session End pipeline.
Declaration Syntax
C#
[SerializableAttribute]
public class SessionEndArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SessionEndArgs(HttpContext) | Initializes a new instance of the SessionEndArgs class.
 | SessionEndArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SessionEndArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | Context | Gets the context.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | SessionEndArgs


SessionEndArgs Constructor

SessionEndArgs Constructor
Namespaces ► Sitecore.Pipelines.SessionEnd ► SessionEndArgs ► SessionEndArgs()()()
Members
Icon | Member | Description
 | SessionEndArgs(HttpContext) | Initializes a new instance of the SessionEndArgs class.
 | SessionEndArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SessionEndArgs class.


SessionEndArgs Constructor (info, context)

SessionEndArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.SessionEnd ► SessionEndArgs ► SessionEndArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the SessionEndArgs class.
Declaration Syntax
C#
protected SessionEndArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


SessionEndArgs Constructor (context)

SessionEndArgs Constructor (context)
Namespaces ► Sitecore.Pipelines.SessionEnd ► SessionEndArgs ► SessionEndArgs(HttpContext)
Initializes a new instance of the SessionEndArgs class.
Declaration Syntax
C#
public SessionEndArgs(
    HttpContext context
)
Parameters
context (HttpContext)
The context.


Context Property

Context Property
Namespaces ► Sitecore.Pipelines.SessionEnd ► SessionEndArgs ► Context
Gets the context.
Declaration Syntax
C#
public HttpContext Context { get; }
Value
The context.


Sitecore.Pipelines.SetupEditFrame Namespace

Sitecore.Pipelines.SetupEditFrame Namespace
Namespaces ► Sitecore.Pipelines.SetupEditFrame
Declaration Syntax
C#
namespace Sitecore.Pipelines.SetupEditFrame
Types
All Types Classes
Icon | Type | Description
 | GetButtonRoot | Defines the get button root class.
 | GetButtons | Defines the get standard buttons class.
 | GetFrameParameters | Defines the get button root class.
 | SetupEditFrameArgs | Defines the render edit frame menu item args class.


GetButtonRoot Class

GetButtonRoot Class
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► GetButtonRoot
Defines the get button root class.
Declaration Syntax
C#
public class GetButtonRoot
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetButtonRoot()()() | Initializes a new instance of the GetButtonRoot class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SetupEditFrameArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GetButtonRoot


GetButtonRoot Constructor

GetButtonRoot Constructor
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► GetButtonRoot ► GetButtonRoot()()()
Initializes a new instance of the GetButtonRoot class
Declaration Syntax
C#
public GetButtonRoot()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► GetButtonRoot ► Process(SetupEditFrameArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SetupEditFrameArgs args
)
Parameters
args (SetupEditFrameArgs)
The arguments.


GetButtons Class

GetButtons Class
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► GetButtons
Defines the get standard buttons class.
Declaration Syntax
C#
public class GetButtons
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetButtons()()() | Initializes a new instance of the GetButtons class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SetupEditFrameArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GetButtons


GetButtons Constructor

GetButtons Constructor
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► GetButtons ► GetButtons()()()
Initializes a new instance of the GetButtons class
Declaration Syntax
C#
public GetButtons()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► GetButtons ► Process(SetupEditFrameArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SetupEditFrameArgs args
)
Parameters
args (SetupEditFrameArgs)
The arguments.


GetFrameParameters Class

GetFrameParameters Class
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► GetFrameParameters
Defines the get button root class.
Declaration Syntax
C#
public class GetFrameParameters
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetFrameParameters()()() | Initializes a new instance of the GetFrameParameters class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(SetupEditFrameArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GetFrameParameters


GetFrameParameters Constructor

GetFrameParameters Constructor
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► GetFrameParameters ► GetFrameParameters()()()
Initializes a new instance of the GetFrameParameters class
Declaration Syntax
C#
public GetFrameParameters()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► GetFrameParameters ► Process(SetupEditFrameArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    SetupEditFrameArgs args
)
Parameters
args (SetupEditFrameArgs)
The arguments.


SetupEditFrameArgs Class

SetupEditFrameArgs Class
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► SetupEditFrameArgs
Defines the render edit frame menu item args class.
Declaration Syntax
C#
public class SetupEditFrameArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetupEditFrameArgs()()() | Initializes a new instance of the SetupEditFrameArgs class
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | ButtonRoot | Gets or sets the button root.
 | ButtonsPath | Gets or sets the buttons path.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MenuItems | Gets or sets the menu items.
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | Title | Gets or sets the title.
 | ToolTip | Gets or sets the tooltip.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | SetupEditFrameArgs


SetupEditFrameArgs Constructor

SetupEditFrameArgs Constructor
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► SetupEditFrameArgs ► SetupEditFrameArgs()()()
Initializes a new instance of the SetupEditFrameArgs class
Declaration Syntax
C#
public SetupEditFrameArgs()


ButtonRoot Property

ButtonRoot Property
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► SetupEditFrameArgs ► ButtonRoot
Gets or sets the button root.
Declaration Syntax
C#
public Item ButtonRoot { get; set; }
Value
The button root.


ButtonsPath Property

ButtonsPath Property
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► SetupEditFrameArgs ► ButtonsPath
Gets or sets the buttons path.
Declaration Syntax
C#
public string ButtonsPath { get; set; }
Value
The buttons path.


MenuItems Property

MenuItems Property
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► SetupEditFrameArgs ► MenuItems
Gets or sets the menu items.
Declaration Syntax
C#
public ICollection<IEditFrameMenuItem> MenuItems { get; }
Value
The menu items.


Title Property

Title Property
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► SetupEditFrameArgs ► Title
Gets or sets the title.
Declaration Syntax
C#
public string Title { get; set; }
Value
The title.


ToolTip Property

ToolTip Property
Namespaces ► Sitecore.Pipelines.SetupEditFrame ► SetupEditFrameArgs ► ToolTip
Gets or sets the tooltip.
Declaration Syntax
C#
public string ToolTip { get; set; }
Value
The tooltip.


Sitecore.Pipelines.Shutdown Namespace

Sitecore.Pipelines.Shutdown Namespace
Namespaces ► Sitecore.Pipelines.Shutdown
Declaration Syntax
C#
namespace Sitecore.Pipelines.Shutdown
Types
All Types Classes
Icon | Type | Description
 | ShowReason | Show the reason for shutdown.


ShowReason Class

ShowReason Class
Namespaces ► Sitecore.Pipelines.Shutdown ► ShowReason
Show the reason for shutdown.
Declaration Syntax
C#
public class ShowReason
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ShowReason()()() | Initializes a new instance of the ShowReason class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PipelineArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ShowReason


ShowReason Constructor

ShowReason Constructor
Namespaces ► Sitecore.Pipelines.Shutdown ► ShowReason ► ShowReason()()()
Initializes a new instance of the ShowReason class
Declaration Syntax
C#
public ShowReason()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Shutdown ► ShowReason ► Process(PipelineArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    PipelineArgs args
)
Parameters
args (PipelineArgs)
The args.


Sitecore.Pipelines.Upload Namespace

Sitecore.Pipelines.Upload Namespace
Namespaces ► Sitecore.Pipelines.Upload
Declaration Syntax
C#
namespace Sitecore.Pipelines.Upload
Types
All Types Classes Enumerations
Icon | Type | Description
 | CheckSize | Resolves the folder.
 | Done | Upload has finished.
 | ResolveFolder | Resolves the folder.
 | Save | Saves the uploaded files.
 | Unzip | Obsolete. Unzips the files.
 | UploadArgs | Argument class for the Upload pipeline.
 | UploadDestination | Specifies the destination for the upload operation.
 | UploadProcessor | Represents a UploadProcessor.


CheckSize Class

CheckSize Class
Namespaces ► Sitecore.Pipelines.Upload ► CheckSize
Resolves the folder.
Declaration Syntax
C#
public class CheckSize : UploadProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckSize()()() | Initializes a new instance of the CheckSize class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(UploadArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | UploadProcessor
 |  | CheckSize


CheckSize Constructor

CheckSize Constructor
Namespaces ► Sitecore.Pipelines.Upload ► CheckSize ► CheckSize()()()
Initializes a new instance of the CheckSize class
Declaration Syntax
C#
public CheckSize()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Upload ► CheckSize ► Process(UploadArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    UploadArgs args
)
Parameters
args (UploadArgs)
The arguments.


Done Class

Done Class
Namespaces ► Sitecore.Pipelines.Upload ► Done
Upload has finished.
Declaration Syntax
C#
public class Done
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Done()()() | Initializes a new instance of the Done class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(UploadArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Done


Done Constructor

Done Constructor
Namespaces ► Sitecore.Pipelines.Upload ► Done ► Done()()()
Initializes a new instance of the Done class
Declaration Syntax
C#
public Done()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Upload ► Done ► Process(UploadArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    UploadArgs args
)
Parameters
args (UploadArgs)
The arguments.


ResolveFolder Class

ResolveFolder Class
Namespaces ► Sitecore.Pipelines.Upload ► ResolveFolder
Resolves the folder.
Declaration Syntax
C#
public class ResolveFolder
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ResolveFolder()()() | Initializes a new instance of the ResolveFolder class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(UploadArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ResolveFolder


ResolveFolder Constructor

ResolveFolder Constructor
Namespaces ► Sitecore.Pipelines.Upload ► ResolveFolder ► ResolveFolder()()()
Initializes a new instance of the ResolveFolder class
Declaration Syntax
C#
public ResolveFolder()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Upload ► ResolveFolder ► Process(UploadArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    UploadArgs args
)
Parameters
args (UploadArgs)
The arguments.


Save Class

Save Class
Namespaces ► Sitecore.Pipelines.Upload ► Save
Saves the uploaded files.
Declaration Syntax
C#
public class Save : UploadProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Save()()() | Initializes a new instance of the Save class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(UploadArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | UploadProcessor
 |  | Save


Save Constructor

Save Constructor
Namespaces ► Sitecore.Pipelines.Upload ► Save ► Save()()()
Initializes a new instance of the Save class
Declaration Syntax
C#
public Save()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Upload ► Save ► Process(UploadArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    UploadArgs args
)
Parameters
args (UploadArgs)
The arguments.
Exceptions
Exception | Condition
Exception | Exception.


Unzip Class

Unzip Class
Namespaces ► Sitecore.Pipelines.Upload ► Unzip
Unzips the files.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated. Unpacking is handled by the save processor")]
public class Unzip
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Unzip()()() | Initializes a new instance of the Unzip class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(UploadArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnzipFiles(String, Boolean) | Unzips the files.
 | UnZipMediaItem(String, Boolean, UploadArgs) | Unzips a media item.
Inheritance Hierarchy
Object
Unzip


Unzip Constructor

Unzip Constructor
Namespaces ► Sitecore.Pipelines.Upload ► Unzip ► Unzip()()()
Initializes a new instance of the Unzip class
Declaration Syntax
C#
public Unzip()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Pipelines.Upload ► Unzip ► Process(UploadArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    UploadArgs args
)
Parameters
args (UploadArgs)
The arguments.


UnzipFiles Method (zipFilename, overwrite)

UnzipFiles Method (zipFilename, overwrite)
Namespaces ► Sitecore.Pipelines.Upload ► Unzip ► UnzipFiles(String, Boolean)
Unzips the files.
Declaration Syntax
C#
public void UnzipFiles(
    string zipFilename,
    bool overwrite
)
Parameters
zipFilename (String)
The zip filename.
overwrite (Boolean)
if set to true this instance is overwrite.


UnZipMediaItem Method (zipFilename, overwrite, args)

UnZipMediaItem Method (zipFilename, overwrite, args)
Namespaces ► Sitecore.Pipelines.Upload ► Unzip ► UnZipMediaItem(String, Boolean, UploadArgs)
Unzips a media item.
Declaration Syntax
C#
public void UnZipMediaItem(
    string zipFilename,
    bool overwrite,
    UploadArgs args
)
Parameters
zipFilename (String)
The zip filename.
overwrite (Boolean)
if set to true this instance is overwrite.
args (UploadArgs)
The arguments.


UploadArgs Class

UploadArgs Class
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs
Argument class for the Upload pipeline.
Declaration Syntax
C#
[SerializableAttribute]
public class UploadArgs : ClientPipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UploadArgs()()() | Initializes a new instance of the UploadArgs class.
 | UploadArgs(HttpFileCollection, String, String, Boolean, Boolean) | Obsolete. Initializes a new instance of the UploadArgs class.
 | UploadArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the UploadArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AbortUpload(String) | Aborts the upload.
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
 | CloseDialogOnEnd | Gets or sets a value indicating whether the pipeline closes the dialog on end.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Destination | Gets or sets the destination.
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorText | Gets or sets the error text.
 | FileOnly | Gets or sets a value indicating whether the UploadArgs files the only.
 | Files | Gets the files.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Folder | Gets or sets the folder.
 | GetFileParameter(String, String) | Gets the file parameter.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
 | ID | Obsolete. Gets or sets the ID.
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
 | Language | Gets or sets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Overwrite | Gets or sets a value indicating whether this UploadArgs is overwrite.
 | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
 | ProcessorDone()()() | A processor is done. (Overrides ClientPipelineArgs.ProcessorDone()()().)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
 | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | SetFileParameter(String, String, String) | Sets the file parameter.
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unpack | Gets or sets a value indicating whether ZIP archives are unpacked.
 | Unzip | Obsolete. Gets or sets a value indicating whether this UploadArgs is unzip.
 | UploadedItems | Gets the items.
 | Versioned | Gets or sets a value indicating whether this UploadArgs is versioned.
 | WaitForPostBack()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ClientPipelineArgs
 |  |  |  | UploadArgs


UploadArgs Constructor

UploadArgs Constructor
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► UploadArgs()()()
Members
Icon | Member | Description
 | UploadArgs()()() | Initializes a new instance of the UploadArgs class.
 | UploadArgs(HttpFileCollection, String, String, Boolean, Boolean) | Obsolete. Initializes a new instance of the UploadArgs class.
 | UploadArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the UploadArgs class.


UploadArgs Constructor

UploadArgs Constructor
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► UploadArgs()()()
Initializes a new instance of the UploadArgs class.
Declaration Syntax
C#
public UploadArgs()


UploadArgs Constructor (info, context)

UploadArgs Constructor (info, context)
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► UploadArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the UploadArgs class.
Declaration Syntax
C#
protected UploadArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


UploadArgs Constructor (files, folder, id, overwrite, unpack)

UploadArgs Constructor (files, folder, id, overwrite, unpack)
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► UploadArgs(HttpFileCollection, String, String, Boolean, Boolean)
Initializes a new instance of the UploadArgs class.
Declaration Syntax
C#
[ObsoleteAttribute("Obsolete - use the parameterless constructor instead")]
public UploadArgs(
    HttpFileCollection files,
    string folder,
    string id,
    bool overwrite,
    bool unpack
)
Parameters
files (HttpFileCollection)
The files.
folder (String)
The folder.
id (String)
The id.
overwrite (Boolean)
if set to true this instance is overwrite.
unpack (Boolean)
if set to true this ZIP archives are unpacked.


AbortUpload Method (abortUploadReason)

AbortUpload Method (abortUploadReason)
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► AbortUpload(String)
Aborts the upload.
Declaration Syntax
C#
public void AbortUpload(
    string abortUploadReason
)
Parameters
abortUploadReason (String)
The abort upload reason.


CloseDialogOnEnd Property

CloseDialogOnEnd Property
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► CloseDialogOnEnd
Gets or sets a value indicating whether the pipeline closes the dialog on end.
Declaration Syntax
C#
public bool CloseDialogOnEnd { get; set; }
Value
true if the pipeline closes the dialog on end; otherwise, false.


Destination Property

Destination Property
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► Destination
Gets or sets the destination.
Declaration Syntax
C#
public UploadDestination Destination { get; set; }
Value
The destination.


ErrorText Property

ErrorText Property
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► ErrorText
Gets or sets the error text.
Declaration Syntax
C#
public string ErrorText { get; set; }
Value
The error text.


FileOnly Property

FileOnly Property
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► FileOnly
Gets or sets a value indicating whether the UploadArgs files the only.
Declaration Syntax
C#
public bool FileOnly { get; set; }
Value
true if the UploadArgs files the only; otherwise, false.


Files Property

Files Property
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► Files
Gets the files.
Declaration Syntax
C#
public HttpFileCollection Files { get; set; }
Value
The files.


Folder Property

Folder Property
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► Folder
Gets or sets the folder.
Declaration Syntax
C#
public string Folder { get; set; }
Value
The folder.


GetFileParameter Method (filename, key)

GetFileParameter Method (filename, key)
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► GetFileParameter(String, String)
Gets the file parameter.
Declaration Syntax
C#
public string GetFileParameter(
    string filename,
    string key
)
Parameters
filename (String)
The filename.
key (String)
The key.
Return Value
The file parameter.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


ID Property

ID Property
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► ID
Gets or sets the ID.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public string ID { get; set; }
Value
The ID.


Language Property

Language Property
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► Language
Gets or sets the language.
Declaration Syntax
C#
public Language Language { get; set; }
Value
The language.


Overwrite Property

Overwrite Property
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► Overwrite
Gets or sets a value indicating whether this UploadArgs is overwrite.
Declaration Syntax
C#
public bool Overwrite { get; set; }
Value
true if overwrite; otherwise, false.


ProcessorDone Method

ProcessorDone Method
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► ProcessorDone()()()
A processor is done.
Declaration Syntax
C#
protected internal override void ProcessorDone()


SetFileParameter Method (filename, key, value)

SetFileParameter Method (filename, key, value)
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► SetFileParameter(String, String, String)
Sets the file parameter.
Declaration Syntax
C#
public void SetFileParameter(
    string filename,
    string key,
    string value
)
Parameters
filename (String)
The filename.
key (String)
The key.
value (String)
The value.
Return Value
The file parameter.


Unpack Property

Unpack Property
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► Unpack
Gets or sets a value indicating whether ZIP archives are unpacked.
Declaration Syntax
C#
public bool Unpack { get; set; }
Value
true if ZIP archives are unpacked; otherwise, false.


Unzip Property

Unzip Property
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► Unzip
Gets or sets a value indicating whether this UploadArgs is unzip.
Declaration Syntax
C#
[ObsoleteAttribute("Obsolete - use the Unpack property instead")]
public bool Unzip { get; set; }
Value
true if unzip; otherwise, false.


UploadedItems Property

UploadedItems Property
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► UploadedItems
Gets the items.
Declaration Syntax
C#
public List<Item> UploadedItems { get; }
Value
The items.


Versioned Property

Versioned Property
Namespaces ► Sitecore.Pipelines.Upload ► UploadArgs ► Versioned
Gets or sets a value indicating whether this UploadArgs is versioned.
Declaration Syntax
C#
public bool Versioned { get; set; }
Value
true if versioned; otherwise, false.


UploadDestination Enumeration

UploadDestination Enumeration
Namespaces ► Sitecore.Pipelines.Upload ► UploadDestination
Specifies the destination for the upload operation.
Declaration Syntax
C#
public enum UploadDestination
Members
Member | Description
Database | Database.
File | File


UploadProcessor Class

UploadProcessor Class
Namespaces ► Sitecore.Pipelines.Upload ► UploadProcessor
Represents a UploadProcessor.
Declaration Syntax
C#
public abstract class UploadProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UploadProcessor()()() | Initializes a new instance of the UploadProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsUnpack(UploadArgs, HttpPostedFile) | Determines whether the specified args is zip.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | UploadProcessor
 |  | CheckSize
 |  | Save


UploadProcessor Constructor

UploadProcessor Constructor
Namespaces ► Sitecore.Pipelines.Upload ► UploadProcessor ► UploadProcessor()()()
Initializes a new instance of the UploadProcessor class
Declaration Syntax
C#
protected UploadProcessor()


IsUnpack Method (args, file)

IsUnpack Method (args, file)
Namespaces ► Sitecore.Pipelines.Upload ► UploadProcessor ► IsUnpack(UploadArgs, HttpPostedFile)
Determines whether the specified args is zip.
Declaration Syntax
C#
protected static bool IsUnpack(
    UploadArgs args,
    HttpPostedFile file
)
Parameters
args (UploadArgs)
The arguments.
file (HttpPostedFile)
The file.
Return Value
true if the specified args is zip; otherwise, false.


Sitecore.Platform Namespace

Sitecore.Platform Namespace
Namespaces ► Sitecore.Platform
Declaration Syntax
C#
namespace Sitecore.Platform
Types
All Types Classes Structures Interfaces Enumerations
Icon | Type | Description
 | Shell32..::.EIEIFLAG |
 | Shell32..::.ESFGAO |
 | Shell32..::.ESHCONTF |
 | Shell32..::.ESHGDN |
 | Shell32..::.ESTRRET |
 | Gdi32 | Represents the Gdi32 DLL.
 | Shell32..::.IEnumIDList |
 | Shell32..::.IExtractImage |
 | Shell32..::.IMalloc |
 | Shell32..::.IShellFolder |
 | Shell32..::.IUnknown |
 | Kernel32 | Represents a the Kernel dll.
 | Psapi..::.PROCESS_MEMORY_COUNTERS | Win32 memory struct.
 | Psapi | Represents the Shlwapi DLL.
 | Shell32 | Represents the Shell32 DLL.
 | Shell32..::.SHFILEINFO |
 | Shell32..::.SHGFI |
 | Shlwapi | Represents the Shlwapi DLL.
 | Shell32..::.SIZE |
 | Shell32..::.STRRET_ANY |
 | Shell32..::.STRRET_CSTR |


Gdi32 Class

Gdi32 Class
Namespaces ► Sitecore.Platform ► Gdi32
Represents the Gdi32 DLL.
Declaration Syntax
C#
public static class Gdi32
Inheritance Hierarchy
Object
Gdi32


Kernel32 Class

Kernel32 Class
Namespaces ► Sitecore.Platform ► Kernel32
Represents a the Kernel dll.
Declaration Syntax
C#
public static class Kernel32
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetCurrentProcessId()()() | Gets the current process id.
 | GetCurrentThreadId()()() | Gets the current thread id.
 | GetTickCount()()() | Gets the tick count.
 | QueryPerformanceCounter(Int64%) | Queries the performance counter.
 | QueryPerformanceFrequency(Int64%) | Queries the performance frequency.
 | SetEnvironmentVariable(String, String) | Sets the environment variable.
Inheritance Hierarchy
Object
Kernel32


GetCurrentProcessId Method

GetCurrentProcessId Method
Namespaces ► Sitecore.Platform ► Kernel32 ► GetCurrentProcessId()()()
Gets the current process id.
Declaration Syntax
C#
public static int GetCurrentProcessId()
Return Value


GetCurrentThreadId Method

GetCurrentThreadId Method
Namespaces ► Sitecore.Platform ► Kernel32 ► GetCurrentThreadId()()()
Gets the current thread id.
Declaration Syntax
C#
public static int GetCurrentThreadId()
Return Value


GetTickCount Method

GetTickCount Method
Namespaces ► Sitecore.Platform ► Kernel32 ► GetTickCount()()()
Gets the tick count.
Declaration Syntax
C#
public static long GetTickCount()
Return Value


QueryPerformanceCounter Method (x)

QueryPerformanceCounter Method (x)
Namespaces ► Sitecore.Platform ► Kernel32 ► QueryPerformanceCounter(Int64%)
Queries the performance counter.
Declaration Syntax
C#
public static short QueryPerformanceCounter(
    ref long x
)
Parameters
x ( Int64 %)
The x.
Return Value


QueryPerformanceFrequency Method (x)

QueryPerformanceFrequency Method (x)
Namespaces ► Sitecore.Platform ► Kernel32 ► QueryPerformanceFrequency(Int64%)
Queries the performance frequency.
Declaration Syntax
C#
public static short QueryPerformanceFrequency(
    ref long x
)
Parameters
x ( Int64 %)
The x.
Return Value


SetEnvironmentVariable Method (name, value)

SetEnvironmentVariable Method (name, value)
Namespaces ► Sitecore.Platform ► Kernel32 ► SetEnvironmentVariable(String, String)
Sets the environment variable.
Declaration Syntax
C#
public static bool SetEnvironmentVariable(
    string name,
    string value
)
Parameters
name (String)
The name.
value (String)
The value.
Return Value


Psapi Class

Psapi Class
Namespaces ► Sitecore.Platform ► Psapi
Represents the Shlwapi DLL.
Declaration Syntax
C#
public static class Psapi
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetProcessMemoryInfo(Int32, Psapi..::.PROCESS_MEMORY_COUNTERS, Int32) | Gets the process memory info.
Inheritance Hierarchy
Object
Psapi


GetProcessMemoryInfo Method (hProcess, counters, size)

GetProcessMemoryInfo Method (hProcess, counters, size)
Namespaces ► Sitecore.Platform ► Psapi ► GetProcessMemoryInfo(Int32, Psapi..::.PROCESS_MEMORY_COUNTERS, Int32)
Gets the process memory info.
Declaration Syntax
C#
public static int GetProcessMemoryInfo(
    int hProcess,
    Psapi..::.PROCESS_MEMORY_COUNTERS counters,
    int size
)
Parameters
hProcess (Int32)
The h process.
counters (Psapi..::.PROCESS_MEMORY_COUNTERS)
The counters.
size (Int32)
The size.
Return Value


Psapi.PROCESS_MEMORY_COUNTERS Class

Psapi..::.PROCESS_MEMORY_COUNTERS Class
Namespaces ► Sitecore.Platform ► Psapi ► Psapi..::.PROCESS_MEMORY_COUNTERS
Win32 memory struct.
Declaration Syntax
C#
public class PROCESS_MEMORY_COUNTERS
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Psapi..::.PROCESS_MEMORY_COUNTERS()()() | Initializes a new instance of the Psapi..::.PROCESS_MEMORY_COUNTERS class
 | cb | cb
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PageFaultCount | PageFaultCount
 | PagefileUsage | PagefileUsage
 | PeakPagefileUsage | PeakPagefileUsage
 | PeakWorkingSetSize | PeakWorkingSetSize
 | QuotaNonPagedPoolUsage | QuotaNonPagedPoolUsage
 | QuotaPagedPoolUsage | QuotaPagedPoolUsage
 | QuotaPeakNonPagedPoolUsage | QuotaPeakNonPagedPoolUsage
 | QuotaPeakPagedPoolUsage | QuotaPeakPagedPoolUsage
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WorkingSetSize | WorkingSetSize
Inheritance Hierarchy
Object
Psapi..::.PROCESS_MEMORY_COUNTERS


Psapi.PROCESS_MEMORY_COUNTERS Constructor

Psapi..::.PROCESS_MEMORY_COUNTERS Constructor
Namespaces ► Sitecore.Platform ► Psapi..::.PROCESS_MEMORY_COUNTERS ► Psapi..::.PROCESS_MEMORY_COUNTERS()()()
Initializes a new instance of the Psapi..::.PROCESS_MEMORY_COUNTERS class
Declaration Syntax
C#
public PROCESS_MEMORY_COUNTERS()


cb Field

cb Field
Namespaces ► Sitecore.Platform ► Psapi..::.PROCESS_MEMORY_COUNTERS ► cb
cb
Declaration Syntax
C#
public int cb


PageFaultCount Field

PageFaultCount Field
Namespaces ► Sitecore.Platform ► Psapi..::.PROCESS_MEMORY_COUNTERS ► PageFaultCount
PageFaultCount
Declaration Syntax
C#
public int PageFaultCount


PagefileUsage Field

PagefileUsage Field
Namespaces ► Sitecore.Platform ► Psapi..::.PROCESS_MEMORY_COUNTERS ► PagefileUsage
PagefileUsage
Declaration Syntax
C#
public int PagefileUsage


PeakPagefileUsage Field

PeakPagefileUsage Field
Namespaces ► Sitecore.Platform ► Psapi..::.PROCESS_MEMORY_COUNTERS ► PeakPagefileUsage
PeakPagefileUsage
Declaration Syntax
C#
public int PeakPagefileUsage


PeakWorkingSetSize Field

PeakWorkingSetSize Field
Namespaces ► Sitecore.Platform ► Psapi..::.PROCESS_MEMORY_COUNTERS ► PeakWorkingSetSize
PeakWorkingSetSize
Declaration Syntax
C#
public int PeakWorkingSetSize


QuotaNonPagedPoolUsage Field

QuotaNonPagedPoolUsage Field
Namespaces ► Sitecore.Platform ► Psapi..::.PROCESS_MEMORY_COUNTERS ► QuotaNonPagedPoolUsage
QuotaNonPagedPoolUsage
Declaration Syntax
C#
public int QuotaNonPagedPoolUsage


QuotaPagedPoolUsage Field

QuotaPagedPoolUsage Field
Namespaces ► Sitecore.Platform ► Psapi..::.PROCESS_MEMORY_COUNTERS ► QuotaPagedPoolUsage
QuotaPagedPoolUsage
Declaration Syntax
C#
public int QuotaPagedPoolUsage


QuotaPeakNonPagedPoolUsage Field

QuotaPeakNonPagedPoolUsage Field
Namespaces ► Sitecore.Platform ► Psapi..::.PROCESS_MEMORY_COUNTERS ► QuotaPeakNonPagedPoolUsage
QuotaPeakNonPagedPoolUsage
Declaration Syntax
C#
public int QuotaPeakNonPagedPoolUsage


QuotaPeakPagedPoolUsage Field

QuotaPeakPagedPoolUsage Field
Namespaces ► Sitecore.Platform ► Psapi..::.PROCESS_MEMORY_COUNTERS ► QuotaPeakPagedPoolUsage
QuotaPeakPagedPoolUsage
Declaration Syntax
C#
public int QuotaPeakPagedPoolUsage


WorkingSetSize Field

WorkingSetSize Field
Namespaces ► Sitecore.Platform ► Psapi..::.PROCESS_MEMORY_COUNTERS ► WorkingSetSize
WorkingSetSize
Declaration Syntax
C#
public int WorkingSetSize


Shell32 Class

Shell32 Class
Namespaces ► Sitecore.Platform ► Shell32
Represents the Shell32 DLL.
Declaration Syntax
C#
public static class Shell32
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SHGetFileInfo(String, Int32, Shell32..::.SHFILEINFO%, UInt32, Shell32..::.SHGFI) | SHs the get file info.
Inheritance Hierarchy
Object
Shell32


SHGetFileInfo Method (pszPath, dwFileAttributes, psfi, cbfileInfo, uFlags)

SHGetFileInfo Method (pszPath, dwFileAttributes, psfi, cbfileInfo, uFlags)
Namespaces ► Sitecore.Platform ► Shell32 ► SHGetFileInfo(String, Int32, Shell32..::.SHFILEINFO%, UInt32, Shell32..::.SHGFI)
SHs the get file info.
Declaration Syntax
C#
public static int SHGetFileInfo(
    string pszPath,
    int dwFileAttributes,
    out Shell32..::.SHFILEINFO psfi,
    uint cbfileInfo,
    Shell32..::.SHGFI uFlags
)
Parameters
pszPath (String)
The PSZ path.
dwFileAttributes (Int32)
The dw file attributes.
psfi ( Shell32..::.SHFILEINFO %)
The psfi.
cbfileInfo (UInt32)
The cbfile info.
uFlags (Shell32..::.SHGFI)
The u flags.
Return Value


Shell32.EIEIFLAG Enumeration

Shell32..::.EIEIFLAG Enumeration
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.EIEIFLAG
Declaration Syntax
C#
public enum EIEIFLAG
Members
Member | Description
IEIFLAG_ASYNC |
IEIFLAG_CACHE |
IEIFLAG_ASPECT |
IEIFLAG_OFFLINE |
IEIFLAG_GLEAM |
IEIFLAG_SCREEN |
IEIFLAG_ORIGSIZE |
IEIFLAG_NOSTAMP |
IEIFLAG_NOBORDER |
IEIFLAG_QUALITY |


Shell32.ESFGAO Enumeration

Shell32..::.ESFGAO Enumeration
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.ESFGAO
Declaration Syntax
C#
[FlagsAttribute]
public enum ESFGAO
Members
Member | Description
SFGAO_CANCOPY |
SFGAO_CANMOVE |
SFGAO_CANLINK |
SFGAO_CANRENAME |
SFGAO_CANDELETE |
SFGAO_HASPROPSHEET |
SFGAO_DROPTARGET |
SFGAO_CAPABILITYMASK |
SFGAO_LINK |
SFGAO_SHARE |
SFGAO_READONLY |
SFGAO_GHOSTED |
SFGAO_DISPLAYATTRMASK |
SFGAO_FILESYSANCESTOR |
SFGAO_FOLDER |
SFGAO_FILESYSTEM |
SFGAO_HASSUBFOLDER |
SFGAO_CONTENTSMASK |
SFGAO_VALIDATE |
SFGAO_REMOVABLE |
SFGAO_COMPRESSED |


Shell32.ESHCONTF Enumeration

Shell32..::.ESHCONTF Enumeration
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.ESHCONTF
Declaration Syntax
C#
[FlagsAttribute]
public enum ESHCONTF
Members
Member | Description
SHCONTF_FOLDERS |
SHCONTF_NONFOLDERS |
SHCONTF_INCLUDEHIDDEN |


Shell32.ESHGDN Enumeration

Shell32..::.ESHGDN Enumeration
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.ESHGDN
Declaration Syntax
C#
[FlagsAttribute]
public enum ESHGDN
Members
Member | Description
SHGDN_NORMAL |
SHGDN_INFOLDER |
SHGDN_FORADDRESSBAR |
SHGDN_FORPARSING |


Shell32.ESTRRET Enumeration

Shell32..::.ESTRRET Enumeration
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.ESTRRET
Declaration Syntax
C#
[FlagsAttribute]
public enum ESTRRET
Members
Member | Description
STRRET_WSTR |
STRRET_OFFSET |
STRRET_CSTR |


Shell32.IEnumIDList Interface

Shell32..::.IEnumIDList Interface
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.IEnumIDList
Declaration Syntax
C#
public interface IEnumIDList
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Clone(Shell32..::.IEnumIDList%) |
 | Next(Int32, IntPtr%, Int32%) |
 | Reset()()() |
 | Skip(Int32) |


Clone Method (ppenum)

Clone Method (ppenum)
Namespaces ► Sitecore.Platform ► Shell32..::.IEnumIDList ► Clone(Shell32..::.IEnumIDList%)
Declaration Syntax
C#
void Clone(
    ref Shell32..::.IEnumIDList ppenum
)
Parameters
ppenum ( Shell32..::.IEnumIDList %)


Next Method (celt, rgelt, pceltFetched)

Next Method (celt, rgelt, pceltFetched)
Namespaces ► Sitecore.Platform ► Shell32..::.IEnumIDList ► Next(Int32, IntPtr%, Int32%)
Declaration Syntax
C#
int Next(
    int celt,
    ref IntPtr rgelt,
    out int pceltFetched
)
Parameters
celt (Int32)
rgelt ( IntPtr %)
pceltFetched ( Int32 %)


Reset Method

Reset Method
Namespaces ► Sitecore.Platform ► Shell32..::.IEnumIDList ► Reset()()()
Declaration Syntax
C#
void Reset()


Skip Method (celt)

Skip Method (celt)
Namespaces ► Sitecore.Platform ► Shell32..::.IEnumIDList ► Skip(Int32)
Declaration Syntax
C#
void Skip(
    int celt
)
Parameters
celt (Int32)


Shell32.IExtractImage Interface

Shell32..::.IExtractImage Interface
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.IExtractImage
Declaration Syntax
C#
public interface IExtractImage
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Extract(IntPtr%) |
 | GetLocation(StringBuilder, Int32, Int32%, Shell32..::.SIZE%, Int32, Int32%) |


Extract Method (phBmpThumbnail)

Extract Method (phBmpThumbnail)
Namespaces ► Sitecore.Platform ► Shell32..::.IExtractImage ► Extract(IntPtr%)
Declaration Syntax
C#
void Extract(
    out IntPtr phBmpThumbnail
)
Parameters
phBmpThumbnail ( IntPtr %)


GetLocation Method (pszPathBuffer, cch, pdwPriority, prgSize, dwRecClrDepth, pdwFlags)

GetLocation Method (pszPathBuffer, cch, pdwPriority, prgSize, dwRecClrDepth, pdwFlags)
Namespaces ► Sitecore.Platform ► Shell32..::.IExtractImage ► GetLocation(StringBuilder, Int32, Int32%, Shell32..::.SIZE%, Int32, Int32%)
Declaration Syntax
C#
void GetLocation(
    StringBuilder pszPathBuffer,
    int cch,
    ref int pdwPriority,
    ref Shell32..::.SIZE prgSize,
    int dwRecClrDepth,
    ref int pdwFlags
)
Parameters
pszPathBuffer (StringBuilder)
cch (Int32)
pdwPriority ( Int32 %)
prgSize ( Shell32..::.SIZE %)
dwRecClrDepth (Int32)
pdwFlags ( Int32 %)


Shell32.IMalloc Interface

Shell32..::.IMalloc Interface
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.IMalloc
Declaration Syntax
C#
public interface IMalloc
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Alloc(Int32) |
 | DidAlloc(IntPtr) |
 | Free(IntPtr) |
 | GetSize(IntPtr) |
 | HeapMinimize()()() |
 | Realloc(IntPtr, Int32) |


Alloc Method (cb)

Alloc Method (cb)
Namespaces ► Sitecore.Platform ► Shell32..::.IMalloc ► Alloc(Int32)
Declaration Syntax
C#
IntPtr Alloc(
    int cb
)
Parameters
cb (Int32)


DidAlloc Method (pv)

DidAlloc Method (pv)
Namespaces ► Sitecore.Platform ► Shell32..::.IMalloc ► DidAlloc(IntPtr)
Declaration Syntax
C#
int DidAlloc(
    IntPtr pv
)
Parameters
pv (IntPtr)


Free Method (pv)

Free Method (pv)
Namespaces ► Sitecore.Platform ► Shell32..::.IMalloc ► Free(IntPtr)
Declaration Syntax
C#
void Free(
    IntPtr pv
)
Parameters
pv (IntPtr)


GetSize Method (pv)

GetSize Method (pv)
Namespaces ► Sitecore.Platform ► Shell32..::.IMalloc ► GetSize(IntPtr)
Declaration Syntax
C#
int GetSize(
    IntPtr pv
)
Parameters
pv (IntPtr)


HeapMinimize Method

HeapMinimize Method
Namespaces ► Sitecore.Platform ► Shell32..::.IMalloc ► HeapMinimize()()()
Declaration Syntax
C#
void HeapMinimize()


Realloc Method (pv, cb)

Realloc Method (pv, cb)
Namespaces ► Sitecore.Platform ► Shell32..::.IMalloc ► Realloc(IntPtr, Int32)
Declaration Syntax
C#
IntPtr Realloc(
    IntPtr pv,
    int cb
)
Parameters
pv (IntPtr)
cb (Int32)


Shell32.IShellFolder Interface

Shell32..::.IShellFolder Interface
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.IShellFolder
Declaration Syntax
C#
public interface IShellFolder
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BindToObject(IntPtr, IntPtr, Guid%, Shell32..::.IShellFolder%) |
 | BindToStorage(IntPtr, IntPtr, Guid%, IntPtr) |
 | CompareIDs(IntPtr, IntPtr, IntPtr) |
 | CreateViewObject(IntPtr, Guid%, IntPtr) |
 | EnumObjects(IntPtr, Shell32..::.ESHCONTF, Shell32..::.IEnumIDList%) |
 | GetAttributesOf(Int32, IntPtr, Shell32..::.ESFGAO%) |
 | GetDisplayNameOf(IntPtr, Shell32..::.ESHGDN, Shell32..::.STRRET_CSTR%) |
 | GetUIObjectOf(IntPtr, Int32, IntPtr%, Guid%, Int32%, Shell32..::.IUnknown%) |
 | ParseDisplayName(IntPtr, IntPtr, String, Int32%, IntPtr%, Int32%) |
 | SetNameOf(IntPtr, IntPtr, String, Shell32..::.ESHCONTF, IntPtr%) |


BindToObject Method (pidl, pbcReserved, riid, ppvOut)

BindToObject Method (pidl, pbcReserved, riid, ppvOut)
Namespaces ► Sitecore.Platform ► Shell32..::.IShellFolder ► BindToObject(IntPtr, IntPtr, Guid%, Shell32..::.IShellFolder%)
Declaration Syntax
C#
void BindToObject(
    IntPtr pidl,
    IntPtr pbcReserved,
    ref Guid riid,
    ref Shell32..::.IShellFolder ppvOut
)
Parameters
pidl (IntPtr)
pbcReserved (IntPtr)
riid ( Guid %)
ppvOut ( Shell32..::.IShellFolder %)


BindToStorage Method (pidl, pbcReserved, riid, ppvObj)

BindToStorage Method (pidl, pbcReserved, riid, ppvObj)
Namespaces ► Sitecore.Platform ► Shell32..::.IShellFolder ► BindToStorage(IntPtr, IntPtr, Guid%, IntPtr)
Declaration Syntax
C#
void BindToStorage(
    IntPtr pidl,
    IntPtr pbcReserved,
    ref Guid riid,
    IntPtr ppvObj
)
Parameters
pidl (IntPtr)
pbcReserved (IntPtr)
riid ( Guid %)
ppvObj (IntPtr)


CompareIDs Method (lParam, pidl1, pidl2)

CompareIDs Method (lParam, pidl1, pidl2)
Namespaces ► Sitecore.Platform ► Shell32..::.IShellFolder ► CompareIDs(IntPtr, IntPtr, IntPtr)
Declaration Syntax
C#
int CompareIDs(
    IntPtr lParam,
    IntPtr pidl1,
    IntPtr pidl2
)
Parameters
lParam (IntPtr)
pidl1 (IntPtr)
pidl2 (IntPtr)


CreateViewObject Method (hwndOwner, riid, ppvOut)

CreateViewObject Method (hwndOwner, riid, ppvOut)
Namespaces ► Sitecore.Platform ► Shell32..::.IShellFolder ► CreateViewObject(IntPtr, Guid%, IntPtr)
Declaration Syntax
C#
void CreateViewObject(
    IntPtr hwndOwner,
    ref Guid riid,
    IntPtr ppvOut
)
Parameters
hwndOwner (IntPtr)
riid ( Guid %)
ppvOut (IntPtr)


EnumObjects Method (hwndOwner, grfFlags, ppenumIDList)

EnumObjects Method (hwndOwner, grfFlags, ppenumIDList)
Namespaces ► Sitecore.Platform ► Shell32..::.IShellFolder ► EnumObjects(IntPtr, Shell32..::.ESHCONTF, Shell32..::.IEnumIDList%)
Declaration Syntax
C#
void EnumObjects(
    IntPtr hwndOwner,
    Shell32..::.ESHCONTF grfFlags,
    ref Shell32..::.IEnumIDList ppenumIDList
)
Parameters
hwndOwner (IntPtr)
grfFlags (Shell32..::.ESHCONTF)
ppenumIDList ( Shell32..::.IEnumIDList %)


GetAttributesOf Method (cidl, apidl, rgfInOut)

GetAttributesOf Method (cidl, apidl, rgfInOut)
Namespaces ► Sitecore.Platform ► Shell32..::.IShellFolder ► GetAttributesOf(Int32, IntPtr, Shell32..::.ESFGAO%)
Declaration Syntax
C#
void GetAttributesOf(
    int cidl,
    IntPtr apidl,
    ref Shell32..::.ESFGAO rgfInOut
)
Parameters
cidl (Int32)
apidl (IntPtr)
rgfInOut ( Shell32..::.ESFGAO %)


GetDisplayNameOf Method (pidl, uFlags, lpName)

GetDisplayNameOf Method (pidl, uFlags, lpName)
Namespaces ► Sitecore.Platform ► Shell32..::.IShellFolder ► GetDisplayNameOf(IntPtr, Shell32..::.ESHGDN, Shell32..::.STRRET_CSTR%)
Declaration Syntax
C#
void GetDisplayNameOf(
    IntPtr pidl,
    Shell32..::.ESHGDN uFlags,
    ref Shell32..::.STRRET_CSTR lpName
)
Parameters
pidl (IntPtr)
uFlags (Shell32..::.ESHGDN)
lpName ( Shell32..::.STRRET_CSTR %)


GetUIObjectOf Method (hwndOwner, cidl, apidl, riid, prgfInOut, ppvOut)

GetUIObjectOf Method (hwndOwner, cidl, apidl, riid, prgfInOut, ppvOut)
Namespaces ► Sitecore.Platform ► Shell32..::.IShellFolder ► GetUIObjectOf(IntPtr, Int32, IntPtr%, Guid%, Int32%, Shell32..::.IUnknown%)
Declaration Syntax
C#
void GetUIObjectOf(
    IntPtr hwndOwner,
    int cidl,
    ref IntPtr apidl,
    ref Guid riid,
    out int prgfInOut,
    ref Shell32..::.IUnknown ppvOut
)
Parameters
hwndOwner (IntPtr)
cidl (Int32)
apidl ( IntPtr %)
riid ( Guid %)
prgfInOut ( Int32 %)
ppvOut ( Shell32..::.IUnknown %)


ParseDisplayName Method (hwndOwner, pbcReserved, lpszDisplayName, pchEaten, ppidl, pdwAttributes)

ParseDisplayName Method (hwndOwner, pbcReserved, lpszDisplayName, pchEaten, ppidl, pdwAttributes)
Namespaces ► Sitecore.Platform ► Shell32..::.IShellFolder ► ParseDisplayName(IntPtr, IntPtr, String, Int32%, IntPtr%, Int32%)
Declaration Syntax
C#
void ParseDisplayName(
    IntPtr hwndOwner,
    IntPtr pbcReserved,
    string lpszDisplayName,
    out int pchEaten,
    out IntPtr ppidl,
    out int pdwAttributes
)
Parameters
hwndOwner (IntPtr)
pbcReserved (IntPtr)
lpszDisplayName (String)
pchEaten ( Int32 %)
ppidl ( IntPtr %)
pdwAttributes ( Int32 %)


SetNameOf Method (hwndOwner, pidl, lpszName, uFlags, ppidlOut)

SetNameOf Method (hwndOwner, pidl, lpszName, uFlags, ppidlOut)
Namespaces ► Sitecore.Platform ► Shell32..::.IShellFolder ► SetNameOf(IntPtr, IntPtr, String, Shell32..::.ESHCONTF, IntPtr%)
Declaration Syntax
C#
void SetNameOf(
    IntPtr hwndOwner,
    IntPtr pidl,
    string lpszName,
    Shell32..::.ESHCONTF uFlags,
    ref IntPtr ppidlOut
)
Parameters
hwndOwner (IntPtr)
pidl (IntPtr)
lpszName (String)
uFlags (Shell32..::.ESHCONTF)
ppidlOut ( IntPtr %)


Shell32.IUnknown Interface

Shell32..::.IUnknown Interface
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.IUnknown
Declaration Syntax
C#
public interface IUnknown
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddRef()()() |
 | QueryInterface(Guid%, IntPtr%) |
 | Release()()() |


AddRef Method

AddRef Method
Namespaces ► Sitecore.Platform ► Shell32..::.IUnknown ► AddRef()()()
Declaration Syntax
C#
IntPtr AddRef()


QueryInterface Method (riid, pVoid)

QueryInterface Method (riid, pVoid)
Namespaces ► Sitecore.Platform ► Shell32..::.IUnknown ► QueryInterface(Guid%, IntPtr%)
Declaration Syntax
C#
IntPtr QueryInterface(
    ref Guid riid,
    out IntPtr pVoid
)
Parameters
riid ( Guid %)
pVoid ( IntPtr %)


Release Method

Release Method
Namespaces ► Sitecore.Platform ► Shell32..::.IUnknown ► Release()()()
Declaration Syntax
C#
IntPtr Release()


Shell32.SHFILEINFO Structure

Shell32..::.SHFILEINFO Structure
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.SHFILEINFO
Declaration Syntax
C#
public struct SHFILEINFO
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Shell32..::.SHFILEINFO(Boolean) | Initializes a new instance of the Shell32..::.SHFILEINFO class
 | dwAttributes |
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | hIcon |
 | iIcon |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | szDisplayName |
 | szTypeName |
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


Shell32.SHFILEINFO Constructor (b)

Shell32..::.SHFILEINFO Constructor (b)
Namespaces ► Sitecore.Platform ► Shell32..::.SHFILEINFO ► Shell32..::.SHFILEINFO(Boolean)
Initializes a new instance of the Shell32..::.SHFILEINFO class
Declaration Syntax
C#
public SHFILEINFO(
    bool b
)
Parameters
b (Boolean)


dwAttributes Field

dwAttributes Field
Namespaces ► Sitecore.Platform ► Shell32..::.SHFILEINFO ► dwAttributes
Declaration Syntax
C#
public uint dwAttributes


hIcon Field

hIcon Field
Namespaces ► Sitecore.Platform ► Shell32..::.SHFILEINFO ► hIcon
Declaration Syntax
C#
public IntPtr hIcon


iIcon Field

iIcon Field
Namespaces ► Sitecore.Platform ► Shell32..::.SHFILEINFO ► iIcon
Declaration Syntax
C#
public int iIcon


szDisplayName Field

szDisplayName Field
Namespaces ► Sitecore.Platform ► Shell32..::.SHFILEINFO ► szDisplayName
Declaration Syntax
C#
public string szDisplayName


szTypeName Field

szTypeName Field
Namespaces ► Sitecore.Platform ► Shell32..::.SHFILEINFO ► szTypeName
Declaration Syntax
C#
public string szTypeName


Shell32.SHGFI Enumeration

Shell32..::.SHGFI Enumeration
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.SHGFI
Declaration Syntax
C#
[FlagsAttribute]
public enum SHGFI
Members
Member | Description
Icon | get icon
DisplayName | get display name
TypeName | get type name
Attributes | get attributes
IconLocation | get icon location
ExeType | return exe type
SysIconIndex | get system icon index
LinkOverlay | put a link overlay on icon
Selected | show icon in selected state
Attr_Specified | get only specified attributes
LargeIcon | get large icon
SmallIcon | get small icon
OpenIcon | get open icon
ShellIconize | get shell size icon
PIDL | pszPath is a pidl
UseFileAttributes | use passed dwFileAttribute
AddOverlays | apply the appropriate overlays
OverlayIndex | Get the index of the overlay in the upper 8 bits of the iIcon


Shell32.SIZE Structure

Shell32..::.SIZE Structure
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.SIZE
Declaration Syntax
C#
public struct SIZE
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | cx |
 | cy |
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


cx Field

cx Field
Namespaces ► Sitecore.Platform ► Shell32..::.SIZE ► cx
Declaration Syntax
C#
public int cx


cy Field

cy Field
Namespaces ► Sitecore.Platform ► Shell32..::.SIZE ► cy
Declaration Syntax
C#
public int cy


Shell32.STRRET_ANY Structure

Shell32..::.STRRET_ANY Structure
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.STRRET_ANY
Declaration Syntax
C#
public struct STRRET_ANY
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | pOLEString |
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | uType |


pOLEString Field

pOLEString Field
Namespaces ► Sitecore.Platform ► Shell32..::.STRRET_ANY ► pOLEString
Declaration Syntax
C#
public IntPtr pOLEString


uType Field

uType Field
Namespaces ► Sitecore.Platform ► Shell32..::.STRRET_ANY ► uType
Declaration Syntax
C#
public Shell32..::.ESTRRET uType


Shell32.STRRET_CSTR Structure

Shell32..::.STRRET_CSTR Structure
Namespaces ► Sitecore.Platform ► Shell32 ► Shell32..::.STRRET_CSTR
Declaration Syntax
C#
public struct STRRET_CSTR
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | cStr |
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | uType |


cStr Field

cStr Field
Namespaces ► Sitecore.Platform ► Shell32..::.STRRET_CSTR ► cStr
Declaration Syntax
C#
public byte[] cStr


uType Field

uType Field
Namespaces ► Sitecore.Platform ► Shell32..::.STRRET_CSTR ► uType
Declaration Syntax
C#
public Shell32..::.ESTRRET uType


Shlwapi Class

Shlwapi Class
Namespaces ► Sitecore.Platform ► Shlwapi
Represents the Shlwapi DLL.
Declaration Syntax
C#
public static class Shlwapi
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | StrCmpLogicalW(String, String) | STRs the CMP logical W.
Inheritance Hierarchy
Object
Shlwapi


StrCmpLogicalW Method (strA, strB)

StrCmpLogicalW Method (strA, strB)
Namespaces ► Sitecore.Platform ► Shlwapi ► StrCmpLogicalW(String, String)
STRs the CMP logical W.
Declaration Syntax
C#
public static int StrCmpLogicalW(
    string strA,
    string strB
)
Parameters
strA (String)
The STR A.
strB (String)
The STR B.
Return Value


Sitecore.Presentation Namespace

Sitecore.Presentation Namespace
Namespaces ► Sitecore.Presentation
Declaration Syntax
C#
namespace Sitecore.Presentation
Types
All Types Classes
Icon | Type | Description
 | ControlManager | ControlManager
 | ControlProvider | ControlProvider
 | ControlProviderCollection | ControlProviderCollection class
 | ControlUriParser | ControlUriParser
 | ItemPresentation | ItemPresentation class
 | PresentationManager | PresentationManager
 | PresentationProvider | PresentationProvider
 | PresentationProviderCollection | PresentationProviderCollection class
 | XslControlUriParser | XslControlUriParser class


ControlManager Class

ControlManager Class
Namespaces ► Sitecore.Presentation ► ControlManager
ControlManager
Declaration Syntax
C#
public static class ControlManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetControl(String, Dictionary<(Of <(String, String>)>)) | Gets a control matching the specified uri.
 | Provider | Gets the provider.
 | Providers | Gets the providers.
Inheritance Hierarchy
Object
ControlManager


GetControl Method (controlUri, parameters)

GetControl Method (controlUri, parameters)
Namespaces ► Sitecore.Presentation ► ControlManager ► GetControl(String, Dictionary<(Of <(String, String>)>))
Gets a control matching the specified uri.
Declaration Syntax
C#
public static IWebControl GetControl(
    string controlUri,
    Dictionary<string, string> parameters
)
Parameters
controlUri (String)
The control URI.
parameters (Dictionary<(Of <(String, String>)>))
The parameters.
Return Value


Provider Property

Provider Property
Namespaces ► Sitecore.Presentation ► ControlManager ► Provider
Gets the provider.
Declaration Syntax
C#
public static ControlProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Presentation ► ControlManager ► Providers
Gets the providers.
Declaration Syntax
C#
public static ControlProviderCollection Providers { get; }
Value
The provider.


ControlProvider Class

ControlProvider Class
Namespaces ► Sitecore.Presentation ► ControlProvider
ControlProvider
Declaration Syntax
C#
public class ControlProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ControlProvider()()() | Initializes a new instance of the ControlProvider class
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControl(String, Dictionary<(Of <(String, String>)>)) | Gets a control matching the specified uri.
 | GetControlUriParser(String, Dictionary<(Of <(String, String>)>)) | Gets the control URI parser.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | ControlProvider


ControlProvider Constructor

ControlProvider Constructor
Namespaces ► Sitecore.Presentation ► ControlProvider ► ControlProvider()()()
Initializes a new instance of the ControlProvider class
Declaration Syntax
C#
public ControlProvider()


GetControl Method (controlUri, parameters)

GetControl Method (controlUri, parameters)
Namespaces ► Sitecore.Presentation ► ControlProvider ► GetControl(String, Dictionary<(Of <(String, String>)>))
Gets a control matching the specified uri.
Declaration Syntax
C#
public virtual IWebControl GetControl(
    string controlUri,
    Dictionary<string, string> parameters
)
Parameters
controlUri (String)
The control URI.
parameters (Dictionary<(Of <(String, String>)>))
The parameters.
Return Value


GetControlUriParser Method (controlUri, parameters)

GetControlUriParser Method (controlUri, parameters)
Namespaces ► Sitecore.Presentation ► ControlProvider ► GetControlUriParser(String, Dictionary<(Of <(String, String>)>))
Gets the control URI parser.
Declaration Syntax
C#
protected virtual ControlUriParser GetControlUriParser(
    string controlUri,
    Dictionary<string, string> parameters
)
Parameters
controlUri (String)
The control URI.
parameters (Dictionary<(Of <(String, String>)>))
The parameters.
Return Value


ControlProviderCollection Class

ControlProviderCollection Class
Namespaces ► Sitecore.Presentation ► ControlProviderCollection
ControlProviderCollection class
Declaration Syntax
C#
public class ControlProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ControlProviderCollection()()() | Initializes a new instance of the ControlProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the ControlProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | ControlProviderCollection


ControlProviderCollection Constructor

ControlProviderCollection Constructor
Namespaces ► Sitecore.Presentation ► ControlProviderCollection ► ControlProviderCollection()()()
Initializes a new instance of the ControlProviderCollection class
Declaration Syntax
C#
public ControlProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Presentation ► ControlProviderCollection ► Item[([(String])])
Gets the ControlProvider with the specified name.
Declaration Syntax
C#
public ControlProvider this[
    string name
] { get; }
Parameters
name (String)
Value


ControlUriParser Class

ControlUriParser Class
Namespaces ► Sitecore.Presentation ► ControlUriParser
ControlUriParser
Declaration Syntax
C#
public abstract class ControlUriParser
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ControlUriParser()()() | Initializes a new instance of the ControlUriParser class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControl()()() | Gets the control represented by the uri.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlUriParser
 |  | XslControlUriParser


ControlUriParser Constructor

ControlUriParser Constructor
Namespaces ► Sitecore.Presentation ► ControlUriParser ► ControlUriParser()()()
Initializes a new instance of the ControlUriParser class
Declaration Syntax
C#
protected ControlUriParser()


GetControl Method

GetControl Method
Namespaces ► Sitecore.Presentation ► ControlUriParser ► GetControl()()()
Gets the control represented by the uri.
Declaration Syntax
C#
public abstract IWebControl GetControl()
Return Value


ItemPresentation Class

ItemPresentation Class
Namespaces ► Sitecore.Presentation ► ItemPresentation
ItemPresentation class
Declaration Syntax
C#
public class ItemPresentation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemPresentation()()() | Initializes a new instance of the ItemPresentation class
 | ControlUri | Gets or sets the control URI.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControl()()() | Gets the control used to render the presentation.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefault | Gets a value indicating whether this instance is the default.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name.
 | Parameters | Gets or sets the parameters.
 | Render()()() | Renders this instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemPresentation


ItemPresentation Constructor

ItemPresentation Constructor
Namespaces ► Sitecore.Presentation ► ItemPresentation ► ItemPresentation()()()
Initializes a new instance of the ItemPresentation class
Declaration Syntax
C#
public ItemPresentation()


ControlUri Property

ControlUri Property
Namespaces ► Sitecore.Presentation ► ItemPresentation ► ControlUri
Gets or sets the control URI.
Declaration Syntax
C#
public string ControlUri { get; set; }
Value
The control URI.
Examples

xsl:/xsl/document.xslt

ascx:/layouts/document.ascx

rendering:{A5F6A...} (guid of rendering)

rendering:document (name of rendering)

type:Sitecore.WebControls.Text, Sitecore.Kernel

xml:<header/><document/><footer/>

pipeline:renderItem


GetControl Method

GetControl Method
Namespaces ► Sitecore.Presentation ► ItemPresentation ► GetControl()()()
Gets the control used to render the presentation.
Declaration Syntax
C#
public virtual IWebControl GetControl()
Return Value


IsDefault Property

IsDefault Property
Namespaces ► Sitecore.Presentation ► ItemPresentation ► IsDefault
Gets a value indicating whether this instance is the default.
Declaration Syntax
C#
public bool IsDefault { get; set; }
Value
true if this instance is the default; otherwise, false.


Name Property

Name Property
Namespaces ► Sitecore.Presentation ► ItemPresentation ► Name
Gets or sets the name.
Declaration Syntax
C#
public string Name { get; set; }
Value
The name.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Presentation ► ItemPresentation ► Parameters
Gets or sets the parameters.
Declaration Syntax
C#
public Dictionary<string, string> Parameters { get; set; }
Value
The parameters.


Render Method

Render Method
Namespaces ► Sitecore.Presentation ► ItemPresentation ► Render()()()
Renders this instance.
Declaration Syntax
C#
public virtual string Render()
Return Value


PresentationManager Class

PresentationManager Class
Namespaces ► Sitecore.Presentation ► PresentationManager
PresentationManager
Declaration Syntax
C#
public static class PresentationManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetPresentation(Item) | Gets the presentation of the specified item.
 | GetPresentation(Item, String) | Gets a named presentation for the specified item.
 | Provider | Gets the provider.
 | Providers | Gets the providers.
Inheritance Hierarchy
Object
PresentationManager


GetPresentation Method

GetPresentation Method
Namespaces ► Sitecore.Presentation ► PresentationManager ► GetPresentation()()()
Members
Icon | Member | Description
 | GetPresentation(Item) | Gets the presentation of the specified item.
 | GetPresentation(Item, String) | Gets a named presentation for the specified item.


GetPresentation Method (item)

GetPresentation Method (item)
Namespaces ► Sitecore.Presentation ► PresentationManager ► GetPresentation(Item)
Gets the presentation of the specified item.
Declaration Syntax
C#
public static ItemPresentation GetPresentation(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetPresentation Method (item, presentationName)

GetPresentation Method (item, presentationName)
Namespaces ► Sitecore.Presentation ► PresentationManager ► GetPresentation(Item, String)
Gets a named presentation for the specified item.
Declaration Syntax
C#
public static ItemPresentation GetPresentation(
    Item item,
    string presentationName
)
Parameters
item (Item)
The item.
presentationName (String)
Name of the presentation (empty string => default presentation).
Return Value


Provider Property

Provider Property
Namespaces ► Sitecore.Presentation ► PresentationManager ► Provider
Gets the provider.
Declaration Syntax
C#
public static PresentationProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Presentation ► PresentationManager ► Providers
Gets the providers.
Declaration Syntax
C#
public static PresentationProviderCollection Providers { get; }
Value
The provider.


PresentationProvider Class

PresentationProvider Class
Namespaces ► Sitecore.Presentation ► PresentationProvider
PresentationProvider
Declaration Syntax
C#
public class PresentationProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PresentationProvider()()() | Initializes a new instance of the PresentationProvider class
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPresentation(Item, String) | Gets the presentation.
 | GetPresentation(Item, String, List<(Of <(ItemPresentation>)>)) | Gets the presentation.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | PresentationProvider


PresentationProvider Constructor

PresentationProvider Constructor
Namespaces ► Sitecore.Presentation ► PresentationProvider ► PresentationProvider()()()
Initializes a new instance of the PresentationProvider class
Declaration Syntax
C#
public PresentationProvider()


GetPresentation Method

GetPresentation Method
Namespaces ► Sitecore.Presentation ► PresentationProvider ► GetPresentation()()()
Members
Icon | Member | Description
 | GetPresentation(Item, String) | Gets the presentation.
 | GetPresentation(Item, String, List<(Of <(ItemPresentation>)>)) | Gets the presentation.


GetPresentation Method (item, presentationName)

GetPresentation Method (item, presentationName)
Namespaces ► Sitecore.Presentation ► PresentationProvider ► GetPresentation(Item, String)
Gets the presentation.
Declaration Syntax
C#
public virtual ItemPresentation GetPresentation(
    Item item,
    string presentationName
)
Parameters
item (Item)
The item.
presentationName (String)
Name of the presentation (empty string => default presentation).
Return Value


GetPresentation Method (item, presentationName, presentations)

GetPresentation Method (item, presentationName, presentations)
Namespaces ► Sitecore.Presentation ► PresentationProvider ► GetPresentation(Item, String, List<(Of <(ItemPresentation>)>))
Gets the presentation.
Declaration Syntax
C#
protected virtual ItemPresentation GetPresentation(
    Item item,
    string presentationName,
    List<ItemPresentation> presentations
)
Parameters
item (Item)
The item.
presentationName (String)
Name of the presentation.
presentations (List<(Of <( ItemPresentation >)>))
The presentations.
Return Value


PresentationProviderCollection Class

PresentationProviderCollection Class
Namespaces ► Sitecore.Presentation ► PresentationProviderCollection
PresentationProviderCollection class
Declaration Syntax
C#
public class PresentationProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PresentationProviderCollection()()() | Initializes a new instance of the PresentationProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the PresentationProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | PresentationProviderCollection


PresentationProviderCollection Constructor

PresentationProviderCollection Constructor
Namespaces ► Sitecore.Presentation ► PresentationProviderCollection ► PresentationProviderCollection()()()
Initializes a new instance of the PresentationProviderCollection class
Declaration Syntax
C#
public PresentationProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Presentation ► PresentationProviderCollection ► Item[([(String])])
Gets the PresentationProvider with the specified name.
Declaration Syntax
C#
public PresentationProvider this[
    string name
] { get; }
Parameters
name (String)
Value


XslControlUriParser Class

XslControlUriParser Class
Namespaces ► Sitecore.Presentation ► XslControlUriParser
XslControlUriParser class
Declaration Syntax
C#
public class XslControlUriParser : ControlUriParser
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | XslControlUriParser(String, Dictionary<(Of <(String, String>)>)) | Initializes a new instance of the XslControlUriParser class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControl()()() | Gets the control represented by the uri. (Overrides ControlUriParser.GetControl()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlUriParser
 |  | XslControlUriParser


XslControlUriParser Constructor (controlUri, parameters)

XslControlUriParser Constructor (controlUri, parameters)
Namespaces ► Sitecore.Presentation ► XslControlUriParser ► XslControlUriParser(String, Dictionary<(Of <(String, String>)>))
Initializes a new instance of the XslControlUriParser class.
Declaration Syntax
C#
public XslControlUriParser(
    string controlUri,
    Dictionary<string, string> parameters
)
Parameters
controlUri (String)
The control URI.
parameters (Dictionary<(Of <(String, String>)>))
The parameters.


GetControl Method

GetControl Method
Namespaces ► Sitecore.Presentation ► XslControlUriParser ► GetControl()()()
Gets the control represented by the uri.
Declaration Syntax
C#
public override IWebControl GetControl()
Return Value


Sitecore.Publishing Namespace

Sitecore.Publishing Namespace
Namespaces ► Sitecore.Publishing
Declaration Syntax
C#
namespace Sitecore.Publishing
Types
All Types Classes Enumerations
Icon | Type | Description
 | HtmlCacheClearer | Represents a Html Cache clearer.
 | PipelinePublishProvider | PipelinePublishProvider class
 | PreviewManager | PreviewManager class
 | PreviewProvider | PreviewProvider class
 | PreviewProviderCollection | PreviewProviderCollection class
 | PublishAction | PublishActionType enum.
 | PublishChildAction | PublishChildrenAction enum
 | PublishChildComparer | PublishChildComparer class
 | Publisher | Represents the publisher.
 | PublishHelper | PublishHelper class
 | PublishManager | Represents the Publish Manager.
 | PublishMode | Defines the publish mode.
 | PublishOperation | PublishActionType enum
 | PublishOptions | Represents a set of publishing options.
 | PublishProvider | PublishProvider
 | PublishProviderCollection | PublishProviderCollection class
 | PublishStatistics | PublishStatistics class
 | PublishStatus | Represents the status of a publish.


HtmlCacheClearer Class

HtmlCacheClearer Class
Namespaces ► Sitecore.Publishing ► HtmlCacheClearer
Represents a Html Cache clearer.
Declaration Syntax
C#
public class HtmlCacheClearer
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlCacheClearer()()() | Initializes a new instance of the HtmlCacheClearer class
 | ClearCache(Object, EventArgs) | Clears the cache.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Sites | Gets the sites.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HtmlCacheClearer


HtmlCacheClearer Constructor

HtmlCacheClearer Constructor
Namespaces ► Sitecore.Publishing ► HtmlCacheClearer ► HtmlCacheClearer()()()
Initializes a new instance of the HtmlCacheClearer class
Declaration Syntax
C#
public HtmlCacheClearer()


ClearCache Method (sender, args)

ClearCache Method (sender, args)
Namespaces ► Sitecore.Publishing ► HtmlCacheClearer ► ClearCache(Object, EventArgs)
Clears the cache.
Declaration Syntax
C#
public void ClearCache(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


Sites Property

Sites Property
Namespaces ► Sitecore.Publishing ► HtmlCacheClearer ► Sites
Gets the sites.
Declaration Syntax
C#
public ArrayList Sites { get; }
Value
The sites.


PipelinePublishProvider Class

PipelinePublishProvider Class
Namespaces ► Sitecore.Publishing ► PipelinePublishProvider
PipelinePublishProvider class
Declaration Syntax
C#
public class PipelinePublishProvider : PublishProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PipelinePublishProvider()()() | Initializes a new instance of the PipelinePublishProvider class
 | CreatePublishContext(PublishOptions) | Creates a context object for use in the PublishPipeline. (Inherited from PublishProvider.)
 | CreatePublishHelper(PublishOptions) | Creates a publish helper instance. (Inherited from PublishProvider.)
 | CreatePublishItemContext(ID, PublishOptions) | Creates a context object for use in the PublishItemPipeline. (Inherited from PublishProvider.)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | Publish(PublishOptions) | Performs a publish operation with the specified options. (Overrides PublishProvider.Publish(PublishOptions).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | PublishProvider
 |  |  | PipelinePublishProvider


PipelinePublishProvider Constructor

PipelinePublishProvider Constructor
Namespaces ► Sitecore.Publishing ► PipelinePublishProvider ► PipelinePublishProvider()()()
Initializes a new instance of the PipelinePublishProvider class
Declaration Syntax
C#
public PipelinePublishProvider()


Publish Method (options)

Publish Method (options)
Namespaces ► Sitecore.Publishing ► PipelinePublishProvider ► Publish(PublishOptions)
Performs a publish operation with the specified options.
Declaration Syntax
C#
public override void Publish(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.


PreviewManager Class

PreviewManager Class
Namespaces ► Sitecore.Publishing ► PreviewManager
PreviewManager class
Declaration Syntax
C#
public static class PreviewManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetShellUser()()() | Gets the current shell user.
 | Previewing | Gets a value indicating whether the system is in previewing mode.
 | Provider | Gets the provider.
 | Providers | Gets the providers.
 | ResetShellUser()()() | Resets the current shell user (i.e. removes the cookie).
 | RestoreUser()()() | Restores the previous user.
 | SetUserContext()()() | Sets up the user context for the current request.
 | StoreShellUser()()() | Stores the current shell user in preparation for switching to preview mode.
Inheritance Hierarchy
Object
PreviewManager


GetShellUser Method

GetShellUser Method
Namespaces ► Sitecore.Publishing ► PreviewManager ► GetShellUser()()()
Gets the current shell user.
Declaration Syntax
C#
public static string GetShellUser()
Return Value
Remarks
This user will be used when accessing the shell site during preview.


Previewing Property

Previewing Property
Namespaces ► Sitecore.Publishing ► PreviewManager ► Previewing
Gets a value indicating whether the system is in previewing mode.
Declaration Syntax
C#
public static bool Previewing { get; }
Value
true if previewing; otherwise, false.


Provider Property

Provider Property
Namespaces ► Sitecore.Publishing ► PreviewManager ► Provider
Gets the provider.
Declaration Syntax
C#
public static PreviewProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Publishing ► PreviewManager ► Providers
Gets the providers.
Declaration Syntax
C#
public static PreviewProviderCollection Providers { get; }
Value
The provider.


ResetShellUser Method

ResetShellUser Method
Namespaces ► Sitecore.Publishing ► PreviewManager ► ResetShellUser()()()
Resets the current shell user (i.e. removes the cookie).
Declaration Syntax
C#
public static void ResetShellUser()


RestoreUser Method

RestoreUser Method
Namespaces ► Sitecore.Publishing ► PreviewManager ► RestoreUser()()()
Restores the previous user.
Declaration Syntax
C#
public static void RestoreUser()


SetUserContext Method

SetUserContext Method
Namespaces ► Sitecore.Publishing ► PreviewManager ► SetUserContext()()()
Sets up the user context for the current request.
Declaration Syntax
C#
public static void SetUserContext()


StoreShellUser Method

StoreShellUser Method
Namespaces ► Sitecore.Publishing ► PreviewManager ► StoreShellUser()()()
Stores the current shell user in preparation for switching to preview mode.
Declaration Syntax
C#
public static void StoreShellUser()
Remarks
The user will be used when accessing the shell site during preview.


PreviewProvider Class

PreviewProvider Class
Namespaces ► Sitecore.Publishing ► PreviewProvider
PreviewProvider class
Declaration Syntax
C#
public class PreviewProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PreviewProvider()()() | Initializes a new instance of the PreviewProvider class
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetShellUser()()() | Gets the current shell user.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | Previewing | Gets a value indicating whether the system is in previewing mode.
 | ResetShellUser()()() | Resets the current shell user (i.e. removes the cookie).
 | RestoreUser()()() | Restores the previous user.
 | SetUserContext()()() | Sets up the user context for the current request.
 | StoreShellUser()()() | Stores the current user in preparation for switching to preview mode.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | PreviewProvider


PreviewProvider Constructor

PreviewProvider Constructor
Namespaces ► Sitecore.Publishing ► PreviewProvider ► PreviewProvider()()()
Initializes a new instance of the PreviewProvider class
Declaration Syntax
C#
public PreviewProvider()


GetShellUser Method

GetShellUser Method
Namespaces ► Sitecore.Publishing ► PreviewProvider ► GetShellUser()()()
Gets the current shell user.
Declaration Syntax
C#
public virtual string GetShellUser()
Return Value
Remarks
This user will be used when accessing the shell site during preview.


Previewing Property

Previewing Property
Namespaces ► Sitecore.Publishing ► PreviewProvider ► Previewing
Gets a value indicating whether the system is in previewing mode.
Declaration Syntax
C#
public virtual bool Previewing { get; }
Value
true if previewing; otherwise, false.


ResetShellUser Method

ResetShellUser Method
Namespaces ► Sitecore.Publishing ► PreviewProvider ► ResetShellUser()()()
Resets the current shell user (i.e. removes the cookie).
Declaration Syntax
C#
public virtual void ResetShellUser()


RestoreUser Method

RestoreUser Method
Namespaces ► Sitecore.Publishing ► PreviewProvider ► RestoreUser()()()
Restores the previous user.
Declaration Syntax
C#
public virtual void RestoreUser()


SetUserContext Method

SetUserContext Method
Namespaces ► Sitecore.Publishing ► PreviewProvider ► SetUserContext()()()
Sets up the user context for the current request.
Declaration Syntax
C#
public virtual void SetUserContext()


StoreShellUser Method

StoreShellUser Method
Namespaces ► Sitecore.Publishing ► PreviewProvider ► StoreShellUser()()()
Stores the current user in preparation for switching to preview mode.
Declaration Syntax
C#
public virtual void StoreShellUser()
Remarks
The user will be used when accessing the shell site during preview.


PreviewProviderCollection Class

PreviewProviderCollection Class
Namespaces ► Sitecore.Publishing ► PreviewProviderCollection
PreviewProviderCollection class
Declaration Syntax
C#
public class PreviewProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PreviewProviderCollection()()() | Initializes a new instance of the PreviewProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the PreviewProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | PreviewProviderCollection


PreviewProviderCollection Constructor

PreviewProviderCollection Constructor
Namespaces ► Sitecore.Publishing ► PreviewProviderCollection ► PreviewProviderCollection()()()
Initializes a new instance of the PreviewProviderCollection class
Declaration Syntax
C#
public PreviewProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Publishing ► PreviewProviderCollection ► Item[([(String])])
Gets the PreviewProvider with the specified name.
Declaration Syntax
C#
public PreviewProvider this[
    string name
] { get; }
Parameters
name (String)
Value


PublishAction Enumeration

PublishAction Enumeration
Namespaces ► Sitecore.Publishing ► PublishAction
PublishActionType enum.
Declaration Syntax
C#
public enum PublishAction
Members
Member | Description
None | Action type has not been set.
DeleteTargetItem | Delete the target item.
PublishSharedFields | Publish only shared fields. All versions in the publishing language will be deleted from the target item.
PublishVersion | Publish a version of the item.


PublishChildAction Enumeration

PublishChildAction Enumeration
Namespaces ► Sitecore.Publishing ► PublishChildAction
PublishChildrenAction enum
Declaration Syntax
C#
public enum PublishChildAction
Members
Member | Description
Skip | Do not publish the children.
Allow | Allow the children to be published.
Force | Force publishing of the children.


PublishChildComparer Class

PublishChildComparer Class
Namespaces ► Sitecore.Publishing ► PublishChildComparer
PublishChildComparer class
Declaration Syntax
C#
public class PublishChildComparer : IComparer<Item>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PublishChildComparer()()() | Initializes a new instance of the PublishChildComparer class
 | Compare(Item, Item) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. Templates are always less than regular Items Items with short paths are lesser than Items with long paths.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PublishChildComparer


PublishChildComparer Constructor

PublishChildComparer Constructor
Namespaces ► Sitecore.Publishing ► PublishChildComparer ► PublishChildComparer()()()
Initializes a new instance of the PublishChildComparer class
Declaration Syntax
C#
public PublishChildComparer()


Compare Method (itemX, itemY)

Compare Method (itemX, itemY)
Namespaces ► Sitecore.Publishing ► PublishChildComparer ► Compare(Item, Item)
Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. Templates are always less than regular Items Items with short paths are lesser than Items with long paths.
Declaration Syntax
C#
public int Compare(
    Item itemX,
    Item itemY
)
Parameters
itemX (Item)
The first item to compare.
itemY (Item)
The second item to compare.
Return Value
Value Condition: Less than zero if itemX is 'less' than itemY. Zero if itemX 'equals' itemY. Greater than zero if itemX is 'greater' than itemY.
Exceptions
Exception | Condition
ArgumentException | Neither x nor y implements the IComparable interface.-or- x and y are of different types and neither one can handle comparisons with the other.


Publisher Class

Publisher Class
Namespaces ► Sitecore.Publishing ► Publisher
Represents the publisher.
Declaration Syntax
C#
public class Publisher
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Publisher(PublishOptions) | Initializes a new instance of the Publisher class.
 | AssertState()()() | Asserts the state.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetJobName()()() | Gets the name of the job that will be used when publishing is run asynchronously.
 | GetPublishLock()()() | Gets a publish lock.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotifyBegin()()() | Notifies the begin.
 | NotifyEnd()()() | Notifies the end.
 | NotifyFailure(Exception) | Notifies the failure.
 | Options | Gets the options.
 | PerformPublish()()() | Executes the publish event.
 | Publish()()() | Publishes this instance.
 | PublishAsync()()() | Performs publishing asynchronously.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLastPublish()()() | Updates the last publish.
 | WillBeQueued | Gets a value indicating whether the Publisher wills the be queued.
Inheritance Hierarchy
Object
Publisher


Publisher Constructor (options)

Publisher Constructor (options)
Namespaces ► Sitecore.Publishing ► Publisher ► Publisher(PublishOptions)
Initializes a new instance of the Publisher class.
Declaration Syntax
C#
public Publisher(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.


AssertState Method

AssertState Method
Namespaces ► Sitecore.Publishing ► Publisher ► AssertState()()()
Asserts the state.
Declaration Syntax
C#
protected virtual void AssertState()
Exceptions
Exception | Condition
InvalidOperationException | Throws a InvalidOperationException if the Mode is unknown.


GetJobName Method

GetJobName Method
Namespaces ► Sitecore.Publishing ► Publisher ► GetJobName()()()
Gets the name of the job that will be used when publishing is run asynchronously.
Declaration Syntax
C#
public virtual string GetJobName()
Return Value


GetPublishLock Method

GetPublishLock Method
Namespaces ► Sitecore.Publishing ► Publisher ► GetPublishLock()()()
Gets a publish lock.
Declaration Syntax
C#
protected virtual Object GetPublishLock()
Return Value


NotifyBegin Method

NotifyBegin Method
Namespaces ► Sitecore.Publishing ► Publisher ► NotifyBegin()()()
Notifies the begin.
Declaration Syntax
C#
protected virtual void NotifyBegin()


NotifyEnd Method

NotifyEnd Method
Namespaces ► Sitecore.Publishing ► Publisher ► NotifyEnd()()()
Notifies the end.
Declaration Syntax
C#
protected virtual void NotifyEnd()


NotifyFailure Method (ex)

NotifyFailure Method (ex)
Namespaces ► Sitecore.Publishing ► Publisher ► NotifyFailure(Exception)
Notifies the failure.
Declaration Syntax
C#
protected virtual void NotifyFailure(
    Exception ex
)
Parameters
ex (Exception)
The ex.


Options Property

Options Property
Namespaces ► Sitecore.Publishing ► Publisher ► Options
Gets the options.
Declaration Syntax
C#
public virtual PublishOptions Options { get; }
Value
The options.


PerformPublish Method

PerformPublish Method
Namespaces ► Sitecore.Publishing ► Publisher ► PerformPublish()()()
Executes the publish event.
Declaration Syntax
C#
protected virtual void PerformPublish()


Publish Method

Publish Method
Namespaces ► Sitecore.Publishing ► Publisher ► Publish()()()
Publishes this instance.
Declaration Syntax
C#
public virtual void Publish()
Exceptions
Exception | Condition
Exception | Exception.


PublishAsync Method

PublishAsync Method
Namespaces ► Sitecore.Publishing ► Publisher ► PublishAsync()()()
Performs publishing asynchronously.
Declaration Syntax
C#
public virtual Job PublishAsync()


UpdateLastPublish Method

UpdateLastPublish Method
Namespaces ► Sitecore.Publishing ► Publisher ► UpdateLastPublish()()()
Updates the last publish.
Declaration Syntax
C#
protected virtual void UpdateLastPublish()


WillBeQueued Property

WillBeQueued Property
Namespaces ► Sitecore.Publishing ► Publisher ► WillBeQueued
Gets a value indicating whether the Publisher wills the be queued.
Declaration Syntax
C#
public virtual bool WillBeQueued { get; }
Value
true if the Publisher wills the be queued; otherwise, false.


PublishHelper Class

PublishHelper Class
Namespaces ► Sitecore.Publishing ► PublishHelper
PublishHelper class
Declaration Syntax
C#
public class PublishHelper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishHelper(PublishOptions) | Initializes a new instance of the PublishHelper class.
 | CanPublish(ID, User, String%) | Determines whether a user can publish the specified item id.
 | CopyToTarget(Item) | Copies the specified source version to the target.
 | DeleteTargetItem(ID) | Deletes the specified target item (if it exists).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemToPublish(ID) | Gets the item to publish.
 | GetSourceItem(ID) | Gets the source item.
 | GetTargetItem(ID) | Gets the target item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUnknownChildIds(ID) | Gets the unknown child ids (children that are in the target but not in the source).
 | GetVersionToPublish(Item) | Gets the version to publish.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Options | Gets the options.
 | PublishSharedFields(Item) | Publishes the shared fields.
 | PublishVersion(Item) | Publishes the version.
 | SourceItemExists(ID) | Determines if a source item exists.
 | TargetItemExists(ID) | Determines if a target item exists.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PublishHelper


PublishHelper Constructor (options)

PublishHelper Constructor (options)
Namespaces ► Sitecore.Publishing ► PublishHelper ► PublishHelper(PublishOptions)
Initializes a new instance of the PublishHelper class.
Declaration Syntax
C#
public PublishHelper(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.


CanPublish Method (itemId, user, explanation)

CanPublish Method (itemId, user, explanation)
Namespaces ► Sitecore.Publishing ► PublishHelper ► CanPublish(ID, User, String%)
Determines whether a user can publish the specified item id.
Declaration Syntax
C#
public bool CanPublish(
    ID itemId,
    User user,
    ref string explanation
)
Parameters
itemId (ID)
The item id.
user (User)
The user.
explanation ( String %)
A message explaining why the user can not publish the item.
Return Value
true if the user can publish the specified item id; otherwise, false.


CopyToTarget Method (sourceVersion)

CopyToTarget Method (sourceVersion)
Namespaces ► Sitecore.Publishing ► PublishHelper ► CopyToTarget(Item)
Copies the specified source version to the target.
Declaration Syntax
C#
protected virtual void CopyToTarget(
    Item sourceVersion
)
Parameters
sourceVersion (Item)
The source version.


DeleteTargetItem Method (itemId)

DeleteTargetItem Method (itemId)
Namespaces ► Sitecore.Publishing ► PublishHelper ► DeleteTargetItem(ID)
Deletes the specified target item (if it exists).
Declaration Syntax
C#
public virtual PublishItemResult DeleteTargetItem(
    ID itemId
)
Parameters
itemId (ID)
The item id.


GetItemToPublish Method (itemId)

GetItemToPublish Method (itemId)
Namespaces ► Sitecore.Publishing ► PublishHelper ► GetItemToPublish(ID)
Gets the item to publish.
Declaration Syntax
C#
public Item GetItemToPublish(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value
Remarks
This might not be the exact version that is to be published. This is found by calling GetVersionToPublish(Item).


GetSourceItem Method (itemId)

GetSourceItem Method (itemId)
Namespaces ► Sitecore.Publishing ► PublishHelper ► GetSourceItem(ID)
Gets the source item.
Declaration Syntax
C#
public virtual Item GetSourceItem(
    ID itemId
)
Parameters
itemId (ID)
Return Value


GetTargetItem Method (itemId)

GetTargetItem Method (itemId)
Namespaces ► Sitecore.Publishing ► PublishHelper ► GetTargetItem(ID)
Gets the target item.
Declaration Syntax
C#
public virtual Item GetTargetItem(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value


GetUnknownChildIds Method (itemId)

GetUnknownChildIds Method (itemId)
Namespaces ► Sitecore.Publishing ► PublishHelper ► GetUnknownChildIds(ID)
Gets the unknown child ids (children that are in the target but not in the source).
Declaration Syntax
C#
public virtual IEnumerable<ID> GetUnknownChildIds(
    ID itemId
)
Parameters
itemId (ID)
The source item id.
Return Value


GetVersionToPublish Method (sourceItem)

GetVersionToPublish Method (sourceItem)
Namespaces ► Sitecore.Publishing ► PublishHelper ► GetVersionToPublish(Item)
Gets the version to publish.
Declaration Syntax
C#
public virtual Item GetVersionToPublish(
    Item sourceItem
)
Parameters
sourceItem (Item)
The source item.
Return Value


Options Property

Options Property
Namespaces ► Sitecore.Publishing ► PublishHelper ► Options
Gets the options.
Declaration Syntax
C#
public virtual PublishOptions Options { get; }
Value
The options.


PublishSharedFields Method (sourceItem)

PublishSharedFields Method (sourceItem)
Namespaces ► Sitecore.Publishing ► PublishHelper ► PublishSharedFields(Item)
Publishes the shared fields.
Declaration Syntax
C#
public PublishItemResult PublishSharedFields(
    Item sourceItem
)
Parameters
sourceItem (Item)
The source item.


PublishVersion Method (sourceVersion)

PublishVersion Method (sourceVersion)
Namespaces ► Sitecore.Publishing ► PublishHelper ► PublishVersion(Item)
Publishes the version.
Declaration Syntax
C#
public PublishItemResult PublishVersion(
    Item sourceVersion
)
Parameters
sourceVersion (Item)
The source version.


SourceItemExists Method (itemId)

SourceItemExists Method (itemId)
Namespaces ► Sitecore.Publishing ► PublishHelper ► SourceItemExists(ID)
Determines if a source item exists.
Declaration Syntax
C#
public bool SourceItemExists(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value


TargetItemExists Method (itemId)

TargetItemExists Method (itemId)
Namespaces ► Sitecore.Publishing ► PublishHelper ► TargetItemExists(ID)
Determines if a target item exists.
Declaration Syntax
C#
public bool TargetItemExists(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value


PublishManager Class

PublishManager Class
Namespaces ► Sitecore.Publishing ► PublishManager
Represents the Publish Manager.
Declaration Syntax
C#
public class PublishManager
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishManager()()() | Initializes a new instance of the PublishManager class
 | AddToPublishQueue(Item, ItemUpdateType) | Updates the publish queue.
 | AddToPublishQueue(Item, ItemUpdateType, DateTime) | Updates the publish queue.
 | AddToPublishQueue(Item, String, DateTime) | Adds an item to the publish queue.
 | CleanupPublishQueue(DateTime, Database) | Cleans up the publish queue.
 | ClearPublishQueue(Database) | Clears the publish queue.
 | CreatePublishContext(PublishOptions) | Creates a context object for use in the PublishPipeline.
 | CreatePublishHelper(PublishOptions) | Gets a publish helper.
 | CreatePublishItemContext(ID, PublishOptions) | Creates a context object for use in the PublishItemPipeline.
 | DoPublish(array<PublishOptions>[]()[], PublishStatus) | Executes the publish event.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPublishingTargets(Database) | Gets the publishing targets defined in a specific database.
 | GetPublishQueue(Database) | Gets the publish queue.
 | GetPublishQueue(DateTime, DateTime, Database) | Gets the publish queue.
 | GetStatus(Handle) | Gets the status.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes event handlers.
 | IsSmartPublishScheduled(Database, String, Language) | Checks if a smart publish is scheduled.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Provider | Gets the provider.
 | Providers | Gets the providers.
 | Publish(PublishOptions) | Publishes with specified options.
 | Publish(array<PublishOptions>[]()[]) | Publishes with specified options.
 | PublishIncremental(Database, array<Database>[]()[], array<Language>[]()[]) | Publishes in incremental mode.
 | PublishItem(Item, array<Database>[]()[], array<Language>[]()[], Boolean, Boolean) | Publishes an item.
 | PublishSmart(Database, array<Database>[]()[], array<Language>[]()[]) | Publishes in smart mode.
 | RebuildDatabase(Database, array<Database>[]()[]) | Rebuilds the database.
 | Republish(Database, array<Database>[]()[], array<Language>[]()[]) | Republishes the specified source.
 | ScheduleSmartPublish(Database) | Schedules a smart publish for all targets and languages in a database.
 | ScheduleSmartPublish(Database, String, Language) | Schedules a smart publish.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnscheduleSmartPublish(Database, String, Language) | Unschedules a smart publish.
 | WaitFor(Handle) | Waits for the specified handle.
Inheritance Hierarchy
Object
PublishManager


PublishManager Constructor

PublishManager Constructor
Namespaces ► Sitecore.Publishing ► PublishManager ► PublishManager()()()
Initializes a new instance of the PublishManager class
Declaration Syntax
C#
public PublishManager()


AddToPublishQueue Method

AddToPublishQueue Method
Namespaces ► Sitecore.Publishing ► PublishManager ► AddToPublishQueue()()()
Members
Icon | Member | Description
 | AddToPublishQueue(Item, ItemUpdateType) | Updates the publish queue.
 | AddToPublishQueue(Item, ItemUpdateType, DateTime) | Updates the publish queue.
 | AddToPublishQueue(Item, String, DateTime) | Adds an item to the publish queue.


AddToPublishQueue Method (item, updateType)

AddToPublishQueue Method (item, updateType)
Namespaces ► Sitecore.Publishing ► PublishManager ► AddToPublishQueue(Item, ItemUpdateType)
Updates the publish queue.
Declaration Syntax
C#
public static void AddToPublishQueue(
    Item item,
    ItemUpdateType updateType
)
Parameters
item (Item)
The item that should be added.
updateType (ItemUpdateType)
Type of the update.


AddToPublishQueue Method (item, updateType, additionalDate)

AddToPublishQueue Method (item, updateType, additionalDate)
Namespaces ► Sitecore.Publishing ► PublishManager ► AddToPublishQueue(Item, ItemUpdateType, DateTime)
Updates the publish queue.
Declaration Syntax
C#
public static void AddToPublishQueue(
    Item item,
    ItemUpdateType updateType,
    DateTime additionalDate
)
Parameters
item (Item)
The item that should be added.
updateType (ItemUpdateType)
Type of the update.
additionalDate (DateTime)
An additional date to check.


AddToPublishQueue Method (item, action, date)

AddToPublishQueue Method (item, action, date)
Namespaces ► Sitecore.Publishing ► PublishManager ► AddToPublishQueue(Item, String, DateTime)
Adds an item to the publish queue.
Declaration Syntax
C#
public static bool AddToPublishQueue(
    Item item,
    string action,
    DateTime date
)
Parameters
item (Item)
The item.
action (String)
The action.
date (DateTime)
The date.
Return Value


CleanupPublishQueue Method (to, database)

CleanupPublishQueue Method (to, database)
Namespaces ► Sitecore.Publishing ► PublishManager ► CleanupPublishQueue(DateTime, Database)
Cleans up the publish queue.
Declaration Syntax
C#
public static bool CleanupPublishQueue(
    DateTime to,
    Database database
)
Parameters
to (DateTime)
To.
database (Database)
The database.
Return Value


ClearPublishQueue Method (database)

ClearPublishQueue Method (database)
Namespaces ► Sitecore.Publishing ► PublishManager ► ClearPublishQueue(Database)
Clears the publish queue.
Declaration Syntax
C#
public static void ClearPublishQueue(
    Database database
)
Parameters
database (Database)
The database.


CreatePublishContext Method (options)

CreatePublishContext Method (options)
Namespaces ► Sitecore.Publishing ► PublishManager ► CreatePublishContext(PublishOptions)
Creates a context object for use in the PublishPipeline.
Declaration Syntax
C#
public static PublishContext CreatePublishContext(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.
Return Value


CreatePublishHelper Method (options)

CreatePublishHelper Method (options)
Namespaces ► Sitecore.Publishing ► PublishManager ► CreatePublishHelper(PublishOptions)
Gets a publish helper.
Declaration Syntax
C#
public static PublishHelper CreatePublishHelper(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.
Return Value


CreatePublishItemContext Method (itemId, options)

CreatePublishItemContext Method (itemId, options)
Namespaces ► Sitecore.Publishing ► PublishManager ► CreatePublishItemContext(ID, PublishOptions)
Creates a context object for use in the PublishItemPipeline.
Declaration Syntax
C#
public static PublishItemContext CreatePublishItemContext(
    ID itemId,
    PublishOptions options
)
Parameters
itemId (ID)
The id of the item to publish.
options (PublishOptions)
The options.
Return Value


DoPublish Method (options, status)

DoPublish Method (options, status)
Namespaces ► Sitecore.Publishing ► PublishManager ► DoPublish(array<PublishOptions>[]()[], PublishStatus)
Executes the publish event.
Declaration Syntax
C#
protected void DoPublish(
    PublishOptions[] options,
    PublishStatus status
)
Parameters
options (array< PublishOptions >[]()[])
The options.
status (PublishStatus)
The status.


GetPublishingTargets Method (database)

GetPublishingTargets Method (database)
Namespaces ► Sitecore.Publishing ► PublishManager ► GetPublishingTargets(Database)
Gets the publishing targets defined in a specific database.
Declaration Syntax
C#
public static ItemList GetPublishingTargets(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The targets.


GetPublishQueue Method

GetPublishQueue Method
Namespaces ► Sitecore.Publishing ► PublishManager ► GetPublishQueue()()()
Members
Icon | Member | Description
 | GetPublishQueue(Database) | Gets the publish queue.
 | GetPublishQueue(DateTime, DateTime, Database) | Gets the publish queue.


GetPublishQueue Method (database)

GetPublishQueue Method (database)
Namespaces ► Sitecore.Publishing ► PublishManager ► GetPublishQueue(Database)
Gets the publish queue.
Declaration Syntax
C#
public static PublishQueue GetPublishQueue(
    Database database
)
Parameters
database (Database)
The database.
Return Value


GetPublishQueue Method (from, to, database)

GetPublishQueue Method (from, to, database)
Namespaces ► Sitecore.Publishing ► PublishManager ► GetPublishQueue(DateTime, DateTime, Database)
Gets the publish queue.
Declaration Syntax
C#
public static IdList GetPublishQueue(
    DateTime from,
    DateTime to,
    Database database
)
Parameters
from (DateTime)
From.
to (DateTime)
To.
database (Database)
The database.
Return Value


GetStatus Method (handle)

GetStatus Method (handle)
Namespaces ► Sitecore.Publishing ► PublishManager ► GetStatus(Handle)
Gets the status.
Declaration Syntax
C#
public static PublishStatus GetStatus(
    Handle handle
)
Parameters
handle (Handle)
The handle.
Return Value


Initialize Method

Initialize Method
Namespaces ► Sitecore.Publishing ► PublishManager ► Initialize()()()
Initializes event handlers.
Declaration Syntax
C#
public static void Initialize()


IsSmartPublishScheduled Method (database, targetDatabaseName, language)

IsSmartPublishScheduled Method (database, targetDatabaseName, language)
Namespaces ► Sitecore.Publishing ► PublishManager ► IsSmartPublishScheduled(Database, String, Language)
Checks if a smart publish is scheduled.
Declaration Syntax
C#
public static bool IsSmartPublishScheduled(
    Database database,
    string targetDatabaseName,
    Language language
)
Parameters
database (Database)
The database.
targetDatabaseName (String)
Name of the target database.
language (Language)
The language.
Return Value
true if smart publish is scheduled for the specified target database; otherwise, false.


Provider Property

Provider Property
Namespaces ► Sitecore.Publishing ► PublishManager ► Provider
Gets the provider.
Declaration Syntax
C#
public static PublishProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Publishing ► PublishManager ► Providers
Gets the providers.
Declaration Syntax
C#
public static PublishProviderCollection Providers { get; }
Value
The provider.


Publish Method

Publish Method
Namespaces ► Sitecore.Publishing ► PublishManager ► Publish()()()
Members
Icon | Member | Description
 | Publish(PublishOptions) | Publishes with specified options.
 | Publish(array<PublishOptions>[]()[]) | Publishes with specified options.


Publish Method (options)

Publish Method (options)
Namespaces ► Sitecore.Publishing ► PublishManager ► Publish(PublishOptions)
Publishes with specified options.
Declaration Syntax
C#
public static void Publish(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.
Return Value


Publish Method (options)

Publish Method (options)
Namespaces ► Sitecore.Publishing ► PublishManager ► Publish(array<PublishOptions>[]()[])
Publishes with specified options.
Declaration Syntax
C#
public static Handle Publish(
    PublishOptions[] options
)
Parameters
options (array< PublishOptions >[]()[])
The options.
Return Value


PublishIncremental Method (source, targets, languages)

PublishIncremental Method (source, targets, languages)
Namespaces ► Sitecore.Publishing ► PublishManager ► PublishIncremental(Database, array<Database>[]()[], array<Language>[]()[])
Publishes in incremental mode.
Declaration Syntax
C#
public static Handle PublishIncremental(
    Database source,
    Database[] targets,
    Language[] languages
)
Parameters
source (Database)
The source.
targets (array< Database >[]()[])
The targets.
languages (array< Language >[]()[])
The languages.
Return Value


PublishItem Method (item, targets, languages, deep, compareRevisions)

PublishItem Method (item, targets, languages, deep, compareRevisions)
Namespaces ► Sitecore.Publishing ► PublishManager ► PublishItem(Item, array<Database>[]()[], array<Language>[]()[], Boolean, Boolean)
Publishes an item.
Declaration Syntax
C#
public static Handle PublishItem(
    Item item,
    Database[] targets,
    Language[] languages,
    bool deep,
    bool compareRevisions
)
Parameters
item (Item)
The item.
targets (array< Database >[]()[])
The targets.
languages (array< Language >[]()[])
The languages.
deep (Boolean)
if set to true this instance is deep.
compareRevisions (Boolean)
if set to true this instance is compare revisions.
Return Value


PublishSmart Method (source, targets, languages)

PublishSmart Method (source, targets, languages)
Namespaces ► Sitecore.Publishing ► PublishManager ► PublishSmart(Database, array<Database>[]()[], array<Language>[]()[])
Publishes in smart mode.
Declaration Syntax
C#
public static Handle PublishSmart(
    Database source,
    Database[] targets,
    Language[] languages
)
Parameters
source (Database)
The source.
targets (array< Database >[]()[])
The targets.
languages (array< Language >[]()[])
The languages.
Return Value


RebuildDatabase Method (source, targets)

RebuildDatabase Method (source, targets)
Namespaces ► Sitecore.Publishing ► PublishManager ► RebuildDatabase(Database, array<Database>[]()[])
Rebuilds the database.
Declaration Syntax
C#
public static Handle RebuildDatabase(
    Database source,
    Database[] targets
)
Parameters
source (Database)
The source.
targets (array< Database >[]()[])
The targets.
Return Value
The database.


Republish Method (source, targets, languages)

Republish Method (source, targets, languages)
Namespaces ► Sitecore.Publishing ► PublishManager ► Republish(Database, array<Database>[]()[], array<Language>[]()[])
Republishes the specified source.
Declaration Syntax
C#
public static Handle Republish(
    Database source,
    Database[] targets,
    Language[] languages
)
Parameters
source (Database)
The source.
targets (array< Database >[]()[])
The targets.
languages (array< Language >[]()[])
The languages.
Return Value


ScheduleSmartPublish Method

ScheduleSmartPublish Method
Namespaces ► Sitecore.Publishing ► PublishManager ► ScheduleSmartPublish()()()
Members
Icon | Member | Description
 | ScheduleSmartPublish(Database) | Schedules a smart publish for all targets and languages in a database.
 | ScheduleSmartPublish(Database, String, Language) | Schedules a smart publish.


ScheduleSmartPublish Method (database)

ScheduleSmartPublish Method (database)
Namespaces ► Sitecore.Publishing ► PublishManager ► ScheduleSmartPublish(Database)
Schedules a smart publish for all targets and languages in a database.
Declaration Syntax
C#
public static void ScheduleSmartPublish(
    Database database
)
Parameters
database (Database)
The database.


ScheduleSmartPublish Method (database, targetName, language)

ScheduleSmartPublish Method (database, targetName, language)
Namespaces ► Sitecore.Publishing ► PublishManager ► ScheduleSmartPublish(Database, String, Language)
Schedules a smart publish.
Declaration Syntax
C#
public static void ScheduleSmartPublish(
    Database database,
    string targetName,
    Language language
)
Parameters
database (Database)
The database.
targetName (String)
Name of the target database.
language (Language)
The language.


UnscheduleSmartPublish Method (database, targetName, language)

UnscheduleSmartPublish Method (database, targetName, language)
Namespaces ► Sitecore.Publishing ► PublishManager ► UnscheduleSmartPublish(Database, String, Language)
Unschedules a smart publish.
Declaration Syntax
C#
public static void UnscheduleSmartPublish(
    Database database,
    string targetName,
    Language language
)
Parameters
database (Database)
The database.
targetName (String)
Name of the target database.
language (Language)
The language.


WaitFor Method (handle)

WaitFor Method (handle)
Namespaces ► Sitecore.Publishing ► PublishManager ► WaitFor(Handle)
Waits for the specified handle.
Declaration Syntax
C#
public static bool WaitFor(
    Handle handle
)
Parameters
handle (Handle)
The handle.
Return Value


PublishMode Enumeration

PublishMode Enumeration
Namespaces ► Sitecore.Publishing ► PublishMode
Defines the publish mode.
Declaration Syntax
C#
public enum PublishMode
Members
Member | Description
Unknown | Unknown.
Full | Full.
Incremental | Incremental.
SingleItem | Single item.
Smart | Smart.


PublishOperation Enumeration

PublishOperation Enumeration
Namespaces ► Sitecore.Publishing ► PublishOperation
PublishActionType enum
Declaration Syntax
C#
public enum PublishOperation
Members
Member | Description
None | Action type has not been set.
Skipped | Left the target item as it was.
Created | Created the target item.
Updated | Update the target item.
Deleted | Delete the target item.


PublishOptions Class

PublishOptions Class
Namespaces ► Sitecore.Publishing ► PublishOptions
Represents a set of publishing options.
Declaration Syntax
C#
public class PublishOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishOptions(Database, Database, PublishMode, Language, DateTime) | Initializes a new instance of the PublishOptions class.
 | ChildComparer | Gets or sets the child comparer.
 | CompareRevisions | Gets or sets a value indicating whether the PublishOptions compares the revisions.
 | Deep | Gets or sets a value indicating whether this PublishOptions is deep.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromDate | Gets or sets from date.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Language | Gets or sets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Mode | Gets or sets the mode.
 | PublishDate | Gets or sets the publish date.
 | PublishingTargets | The list of publishing targets selected for the current publish operation.
 | Replacer | Gets or sets the replacer.
 | RepublishAll | Gets a value indicating whether all data in all languages will be published.
 | RootItem | Gets or sets the root item.
 | SourceDatabase | Gets or sets the source database.
 | TargetDatabase | Gets or sets the target database.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PublishOptions


PublishOptions Constructor (sourceDatabase, targetDatabase, mode, language, publishDate)

PublishOptions Constructor (sourceDatabase, targetDatabase, mode, language, publishDate)
Namespaces ► Sitecore.Publishing ► PublishOptions ► PublishOptions(Database, Database, PublishMode, Language, DateTime)
Initializes a new instance of the PublishOptions class.
Declaration Syntax
C#
public PublishOptions(
    Database sourceDatabase,
    Database targetDatabase,
    PublishMode mode,
    Language language,
    DateTime publishDate
)
Parameters
sourceDatabase (Database)
The source database.
targetDatabase (Database)
The target database.
mode (PublishMode)
The mode.
language (Language)
The language.
publishDate (DateTime)
The publish date.


ChildComparer Property

ChildComparer Property
Namespaces ► Sitecore.Publishing ► PublishOptions ► ChildComparer
Gets or sets the child comparer.
Declaration Syntax
C#
public IComparer<Item> ChildComparer { get; set; }
Value
The child comparer.


CompareRevisions Property

CompareRevisions Property
Namespaces ► Sitecore.Publishing ► PublishOptions ► CompareRevisions
Gets or sets a value indicating whether the PublishOptions compares the revisions.
Declaration Syntax
C#
public bool CompareRevisions { get; set; }
Value
true if the PublishOptions compares the revisions; otherwise, false.


Deep Property

Deep Property
Namespaces ► Sitecore.Publishing ► PublishOptions ► Deep
Gets or sets a value indicating whether this PublishOptions is deep.
Declaration Syntax
C#
public bool Deep { get; set; }
Value
true if deep; otherwise, false.


FromDate Property

FromDate Property
Namespaces ► Sitecore.Publishing ► PublishOptions ► FromDate
Gets or sets from date.
Declaration Syntax
C#
public DateTime FromDate { get; set; }
Value
From date.


Language Property

Language Property
Namespaces ► Sitecore.Publishing ► PublishOptions ► Language
Gets or sets the language.
Declaration Syntax
C#
public Language Language { get; set; }
Value
The language.


Mode Property

Mode Property
Namespaces ► Sitecore.Publishing ► PublishOptions ► Mode
Gets or sets the mode.
Declaration Syntax
C#
public PublishMode Mode { get; set; }
Value
The mode.


PublishDate Property

PublishDate Property
Namespaces ► Sitecore.Publishing ► PublishOptions ► PublishDate
Gets or sets the publish date.
Declaration Syntax
C#
public DateTime PublishDate { get; set; }
Value
The publish date.


PublishingTargets Property

PublishingTargets Property
Namespaces ► Sitecore.Publishing ► PublishOptions ► PublishingTargets
The list of publishing targets selected for the current publish operation.
Declaration Syntax
C#
public List<string> PublishingTargets { get; }


Replacer Property

Replacer Property
Namespaces ► Sitecore.Publishing ► PublishOptions ► Replacer
Gets or sets the replacer.
Declaration Syntax
C#
public Replacer Replacer { get; set; }
Value
The replacer.


RepublishAll Property

RepublishAll Property
Namespaces ► Sitecore.Publishing ► PublishOptions ► RepublishAll
Gets a value indicating whether all data in all languages will be published.
Declaration Syntax
C#
public bool RepublishAll { get; set; }
Value
true if all languages will be published; otherwise, false.
Remarks
This is a special mode of publishing used for completely rebuilding a web database.


RootItem Property

RootItem Property
Namespaces ► Sitecore.Publishing ► PublishOptions ► RootItem
Gets or sets the root item.
Declaration Syntax
C#
public Item RootItem { get; set; }
Value
The root item.


SourceDatabase Property

SourceDatabase Property
Namespaces ► Sitecore.Publishing ► PublishOptions ► SourceDatabase
Gets or sets the source database.
Declaration Syntax
C#
public Database SourceDatabase { get; }
Value
The source database.


TargetDatabase Property

TargetDatabase Property
Namespaces ► Sitecore.Publishing ► PublishOptions ► TargetDatabase
Gets or sets the target database.
Declaration Syntax
C#
public Database TargetDatabase { get; }
Value
The target database.


PublishProvider Class

PublishProvider Class
Namespaces ► Sitecore.Publishing ► PublishProvider
PublishProvider
Declaration Syntax
C#
public abstract class PublishProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishProvider()()() | Initializes a new instance of the PublishProvider class
 | CreatePublishContext(PublishOptions) | Creates a context object for use in the PublishPipeline.
 | CreatePublishHelper(PublishOptions) | Creates a publish helper instance.
 | CreatePublishItemContext(ID, PublishOptions) | Creates a context object for use in the PublishItemPipeline.
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | Publish(PublishOptions) | Performs a publish operation with the specified options.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | PublishProvider
 |  |  | PipelinePublishProvider


PublishProvider Constructor

PublishProvider Constructor
Namespaces ► Sitecore.Publishing ► PublishProvider ► PublishProvider()()()
Initializes a new instance of the PublishProvider class
Declaration Syntax
C#
protected PublishProvider()


CreatePublishContext Method (options)

CreatePublishContext Method (options)
Namespaces ► Sitecore.Publishing ► PublishProvider ► CreatePublishContext(PublishOptions)
Creates a context object for use in the PublishPipeline.
Declaration Syntax
C#
public virtual PublishContext CreatePublishContext(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.
Return Value


CreatePublishHelper Method (options)

CreatePublishHelper Method (options)
Namespaces ► Sitecore.Publishing ► PublishProvider ► CreatePublishHelper(PublishOptions)
Creates a publish helper instance.
Declaration Syntax
C#
public virtual PublishHelper CreatePublishHelper(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.
Return Value


CreatePublishItemContext Method (itemId, options)

CreatePublishItemContext Method (itemId, options)
Namespaces ► Sitecore.Publishing ► PublishProvider ► CreatePublishItemContext(ID, PublishOptions)
Creates a context object for use in the PublishItemPipeline.
Declaration Syntax
C#
public virtual PublishItemContext CreatePublishItemContext(
    ID itemId,
    PublishOptions options
)
Parameters
itemId (ID)
The id of the item to publish.
options (PublishOptions)
The options.
Return Value


Publish Method (options)

Publish Method (options)
Namespaces ► Sitecore.Publishing ► PublishProvider ► Publish(PublishOptions)
Performs a publish operation with the specified options.
Declaration Syntax
C#
public abstract void Publish(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.


PublishProviderCollection Class

PublishProviderCollection Class
Namespaces ► Sitecore.Publishing ► PublishProviderCollection
PublishProviderCollection class
Declaration Syntax
C#
public class PublishProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishProviderCollection()()() | Initializes a new instance of the PublishProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the PublishProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | PublishProviderCollection


PublishProviderCollection Constructor

PublishProviderCollection Constructor
Namespaces ► Sitecore.Publishing ► PublishProviderCollection ► PublishProviderCollection()()()
Initializes a new instance of the PublishProviderCollection class
Declaration Syntax
C#
public PublishProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Publishing ► PublishProviderCollection ► Item[([(String])])
Gets the PublishProvider with the specified name.
Declaration Syntax
C#
public PublishProvider this[
    string name
] { get; }
Parameters
name (String)
Value


PublishStatistics Class

PublishStatistics Class
Namespaces ► Sitecore.Publishing ► PublishStatistics
PublishStatistics class
Declaration Syntax
C#
public class PublishStatistics
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishStatistics()()() | Initializes a new instance of the PublishStatistics class
 | Created | Gets or sets the number of created items.
 | Deleted | Gets or sets the number of deleted items.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Skipped | Gets or sets the number of skipped items.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Updated | Gets or sets the number of updated items.
Inheritance Hierarchy
Object
PublishStatistics


PublishStatistics Constructor

PublishStatistics Constructor
Namespaces ► Sitecore.Publishing ► PublishStatistics ► PublishStatistics()()()
Initializes a new instance of the PublishStatistics class
Declaration Syntax
C#
public PublishStatistics()


Created Property

Created Property
Namespaces ► Sitecore.Publishing ► PublishStatistics ► Created
Gets or sets the number of created items.
Declaration Syntax
C#
public int Created { get; set; }
Value
The created.


Deleted Property

Deleted Property
Namespaces ► Sitecore.Publishing ► PublishStatistics ► Deleted
Gets or sets the number of deleted items.
Declaration Syntax
C#
public int Deleted { get; set; }
Value
The deleted.


Skipped Property

Skipped Property
Namespaces ► Sitecore.Publishing ► PublishStatistics ► Skipped
Gets or sets the number of skipped items.
Declaration Syntax
C#
public int Skipped { get; set; }
Value
The skipped.


Updated Property

Updated Property
Namespaces ► Sitecore.Publishing ► PublishStatistics ► Updated
Gets or sets the number of updated items.
Declaration Syntax
C#
public int Updated { get; set; }
Value
The updated.


PublishStatus Class

PublishStatus Class
Namespaces ► Sitecore.Publishing ► PublishStatus
Represents the status of a publish.
Declaration Syntax
C#
public class PublishStatus
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishStatus()()() | Initializes a new instance of the PublishStatus class.
 | CurrentLanguage | Gets the current language.
 | CurrentTarget | Gets the current target.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Failed | Gets a value indicating whether this PublishStatus is failed.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDone | Gets a value indicating whether this instance is done.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Messages | Gets the messages.
 | Processed | Gets the processed.
 | SetCurrentLanguage(Language) | Sets the current language.
 | SetCurrentTarget(Database) | Sets the current target.
 | SetFailed(Boolean) | Sets the failed.
 | SetProcessed(Int64) | Sets the processed.
 | SetState(JobState) | Sets the state.
 | State | Gets the state.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitHandle | Gets the wait handle.
Inheritance Hierarchy
Object
PublishStatus


PublishStatus Constructor

PublishStatus Constructor
Namespaces ► Sitecore.Publishing ► PublishStatus ► PublishStatus()()()
Initializes a new instance of the PublishStatus class.
Declaration Syntax
C#
public PublishStatus()


CurrentLanguage Property

CurrentLanguage Property
Namespaces ► Sitecore.Publishing ► PublishStatus ► CurrentLanguage
Gets the current language.
Declaration Syntax
C#
public Language CurrentLanguage { get; }
Value
The current language.


CurrentTarget Property

CurrentTarget Property
Namespaces ► Sitecore.Publishing ► PublishStatus ► CurrentTarget
Gets the current target.
Declaration Syntax
C#
public Database CurrentTarget { get; }
Value
The current target.


Failed Property

Failed Property
Namespaces ► Sitecore.Publishing ► PublishStatus ► Failed
Gets a value indicating whether this PublishStatus is failed.
Declaration Syntax
C#
public bool Failed { get; }
Value
true if failed; otherwise, false.


IsDone Property

IsDone Property
Namespaces ► Sitecore.Publishing ► PublishStatus ► IsDone
Gets a value indicating whether this instance is done.
Declaration Syntax
C#
public bool IsDone { get; }
Value
true if this instance is done; otherwise, false.


Messages Property

Messages Property
Namespaces ► Sitecore.Publishing ► PublishStatus ► Messages
Gets the messages.
Declaration Syntax
C#
public StringCollection Messages { get; }
Value
The messages.


Processed Property

Processed Property
Namespaces ► Sitecore.Publishing ► PublishStatus ► Processed
Gets the processed.
Declaration Syntax
C#
public long Processed { get; }
Value
The processed.


SetCurrentLanguage Method (language)

SetCurrentLanguage Method (language)
Namespaces ► Sitecore.Publishing ► PublishStatus ► SetCurrentLanguage(Language)
Sets the current language.
Declaration Syntax
C#
public void SetCurrentLanguage(
    Language language
)
Parameters
language (Language)
The language.


SetCurrentTarget Method (target)

SetCurrentTarget Method (target)
Namespaces ► Sitecore.Publishing ► PublishStatus ► SetCurrentTarget(Database)
Sets the current target.
Declaration Syntax
C#
public void SetCurrentTarget(
    Database target
)
Parameters
target (Database)
The target.


SetFailed Method (failed)

SetFailed Method (failed)
Namespaces ► Sitecore.Publishing ► PublishStatus ► SetFailed(Boolean)
Sets the failed.
Declaration Syntax
C#
public void SetFailed(
    bool failed
)
Parameters
failed (Boolean)
if set to true this instance is failed.


SetProcessed Method (value)

SetProcessed Method (value)
Namespaces ► Sitecore.Publishing ► PublishStatus ► SetProcessed(Int64)
Sets the processed.
Declaration Syntax
C#
public void SetProcessed(
    long value
)
Parameters
value (Int64)
The value.


SetState Method (state)

SetState Method (state)
Namespaces ► Sitecore.Publishing ► PublishStatus ► SetState(JobState)
Sets the state.
Declaration Syntax
C#
public void SetState(
    JobState state
)
Parameters
state (JobState)
The state.


State Property

State Property
Namespaces ► Sitecore.Publishing ► PublishStatus ► State
Gets the state.
Declaration Syntax
C#
public JobState State { get; }
Value
The state.


WaitHandle Property

WaitHandle Property
Namespaces ► Sitecore.Publishing ► PublishStatus ► WaitHandle
Gets the wait handle.
Declaration Syntax
C#
public ManualResetEvent WaitHandle { get; }
Value
The wait handle.


Sitecore.Publishing.Pipelines.Publish Namespace

Sitecore.Publishing.Pipelines.Publish Namespace
Namespaces ► Sitecore.Publishing.Pipelines.Publish
Declaration Syntax
C#
namespace Sitecore.Publishing.Pipelines.Publish
Types
All Types Classes
Icon | Type | Description
 | AddItemsToQueue | PipelineSwitcher class
 | AddLanguagesToQueue | AddLanguagesToQueue class
 | AddTemplatesToQueue | AddTemplatesToQueue class
 | ProcessQueue | ProcessActions class
 | PublishContext | PublishPipelineArgs class
 | PublishingCandidate | PublishAction class
 | PublishPipeline | PublishPipeline class
 | PublishProcessor | PublishProcessor
 | PublishQueue | PublishIterator class
 | PublishResult | PublishItemResult class


AddItemsToQueue Class

AddItemsToQueue Class
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► AddItemsToQueue
PipelineSwitcher class
Declaration Syntax
C#
public class AddItemsToQueue : PublishProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddItemsToQueue()()() | Initializes a new instance of the AddItemsToQueue class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishContext) | Processes the specified args. (Overrides PublishProcessor.Process(PublishContext).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PublishProcessor
 |  | AddItemsToQueue


AddItemsToQueue Constructor

AddItemsToQueue Constructor
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► AddItemsToQueue ► AddItemsToQueue()()()
Initializes a new instance of the AddItemsToQueue class
Declaration Syntax
C#
public AddItemsToQueue()


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► AddItemsToQueue ► Process(PublishContext)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    PublishContext context
)
Parameters
context (PublishContext)
The args.


AddLanguagesToQueue Class

AddLanguagesToQueue Class
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► AddLanguagesToQueue
AddLanguagesToQueue class
Declaration Syntax
C#
public class AddLanguagesToQueue : PublishProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddLanguagesToQueue()()() | Initializes a new instance of the AddLanguagesToQueue class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishContext) | Processes the specified args. (Overrides PublishProcessor.Process(PublishContext).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PublishProcessor
 |  | AddLanguagesToQueue


AddLanguagesToQueue Constructor

AddLanguagesToQueue Constructor
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► AddLanguagesToQueue ► AddLanguagesToQueue()()()
Initializes a new instance of the AddLanguagesToQueue class
Declaration Syntax
C#
public AddLanguagesToQueue()


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► AddLanguagesToQueue ► Process(PublishContext)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    PublishContext context
)
Parameters
context (PublishContext)
The context.


AddTemplatesToQueue Class

AddTemplatesToQueue Class
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► AddTemplatesToQueue
AddTemplatesToQueue class
Declaration Syntax
C#
public class AddTemplatesToQueue : PublishProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddTemplatesToQueue()()() | Initializes a new instance of the AddTemplatesToQueue class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTemplateItems(PublishOptions) | Gets the template items.
 | GetTemplatesForFullPublish(PublishOptions) | Gets the templates for full publish.
 | GetTemplatesForIncrementalPublish(PublishOptions) | Gets the templates for incremental publish.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishContext) | Processes the specified args. (Overrides PublishProcessor.Process(PublishContext).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PublishProcessor
 |  | AddTemplatesToQueue


AddTemplatesToQueue Constructor

AddTemplatesToQueue Constructor
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► AddTemplatesToQueue ► AddTemplatesToQueue()()()
Initializes a new instance of the AddTemplatesToQueue class
Declaration Syntax
C#
public AddTemplatesToQueue()


GetTemplateItems Method (options)

GetTemplateItems Method (options)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► AddTemplatesToQueue ► GetTemplateItems(PublishOptions)
Gets the template items.
Declaration Syntax
C#
protected virtual IEnumerable<PublishingCandidate> GetTemplateItems(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.
Return Value


GetTemplatesForFullPublish Method (options)

GetTemplatesForFullPublish Method (options)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► AddTemplatesToQueue ► GetTemplatesForFullPublish(PublishOptions)
Gets the templates for full publish.
Declaration Syntax
C#
protected virtual IEnumerable<PublishingCandidate> GetTemplatesForFullPublish(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.
Return Value


GetTemplatesForIncrementalPublish Method (options)

GetTemplatesForIncrementalPublish Method (options)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► AddTemplatesToQueue ► GetTemplatesForIncrementalPublish(PublishOptions)
Gets the templates for incremental publish.
Declaration Syntax
C#
protected virtual IEnumerable<PublishingCandidate> GetTemplatesForIncrementalPublish(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.
Return Value


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► AddTemplatesToQueue ► Process(PublishContext)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    PublishContext context
)
Parameters
context (PublishContext)
The context.


ProcessQueue Class

ProcessQueue Class
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► ProcessQueue
ProcessActions class
Declaration Syntax
C#
public class ProcessQueue : PublishProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProcessQueue()()() | Initializes a new instance of the ProcessQueue class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishContext) | Processor entry point. (Overrides PublishProcessor.Process(PublishContext).)
 | ProcessEntries(IEnumerable<(Of <(PublishingCandidate>)>), PublishContext) | Processes the specified actions.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PublishProcessor
 |  | ProcessQueue


ProcessQueue Constructor

ProcessQueue Constructor
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► ProcessQueue ► ProcessQueue()()()
Initializes a new instance of the ProcessQueue class
Declaration Syntax
C#
public ProcessQueue()


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► ProcessQueue ► Process(PublishContext)
Processor entry point.
Declaration Syntax
C#
public override void Process(
    PublishContext context
)
Parameters
context (PublishContext)
The context.


ProcessEntries Method (entries, context)

ProcessEntries Method (entries, context)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► ProcessQueue ► ProcessEntries(IEnumerable<(Of <(PublishingCandidate>)>), PublishContext)
Processes the specified actions.
Declaration Syntax
C#
protected virtual void ProcessEntries(
    IEnumerable<PublishingCandidate> entries,
    PublishContext context
)
Parameters
entries (IEnumerable<(Of <( PublishingCandidate >)>))
The actions.
context (PublishContext)
The context.


PublishContext Class

PublishContext Class
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishContext
PublishPipelineArgs class
Declaration Syntax
C#
public class PublishContext : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishContext(PublishOptions) | Initializes a new instance of the PublishContext class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | Job | Gets or sets the job.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | PublishOptions | Gets the options.
 | Queue | Gets or sets the source item ids.
 | Result | Gets the result of the publishing operation.
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Statistics | Gets the statistics.
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | User | Gets or sets the user.
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | PublishContext


PublishContext Constructor (options)

PublishContext Constructor (options)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishContext ► PublishContext(PublishOptions)
Initializes a new instance of the PublishContext class.
Declaration Syntax
C#
public PublishContext(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.


Job Property

Job Property
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishContext ► Job
Gets or sets the job.
Declaration Syntax
C#
public Job Job { get; set; }
Value
The job.


PublishOptions Property

PublishOptions Property
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishContext ► PublishOptions
Gets the options.
Declaration Syntax
C#
public PublishOptions PublishOptions { get; }
Value
The options.


Queue Property

Queue Property
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishContext ► Queue
Gets or sets the source item ids.
Declaration Syntax
C#
public List<IEnumerable<PublishingCandidate>> Queue { get; }
Value
The source item ids.


Result Property

Result Property
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishContext ► Result
Gets the result of the publishing operation.
Declaration Syntax
C#
public PublishResult Result { get; set; }
Value
The result.


Statistics Property

Statistics Property
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishContext ► Statistics
Gets the statistics.
Declaration Syntax
C#
public PublishStatistics Statistics { get; }
Value
The statistics.


User Property

User Property
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishContext ► User
Gets or sets the user.
Declaration Syntax
C#
public virtual User User { get; set; }
Value
The user.


PublishingCandidate Class

PublishingCandidate Class
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishingCandidate
PublishAction class
Declaration Syntax
C#
public class PublishingCandidate
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishingCandidate(ID, PublishOptions) | Initializes a new instance of the PublishingCandidate class.
 | ChildEntries | Gets the child entries.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemId | Gets the item id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PublishingCandidate


PublishingCandidate Constructor (itemId, options)

PublishingCandidate Constructor (itemId, options)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishingCandidate ► PublishingCandidate(ID, PublishOptions)
Initializes a new instance of the PublishingCandidate class.
Declaration Syntax
C#
public PublishingCandidate(
    ID itemId,
    PublishOptions options
)
Parameters
itemId (ID)
The item id.
options (PublishOptions)
The options.


ChildEntries Property

ChildEntries Property
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishingCandidate ► ChildEntries
Gets the child entries.
Declaration Syntax
C#
public IEnumerable<PublishingCandidate> ChildEntries { get; }
Value
The child entries.


ItemId Property

ItemId Property
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishingCandidate ► ItemId
Gets the item id.
Declaration Syntax
C#
public ID ItemId { get; }
Value
The item id.


PublishPipeline Class

PublishPipeline Class
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishPipeline
PublishPipeline class
Declaration Syntax
C#
public class PublishPipeline
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PublishPipeline()()() | Initializes a new instance of the PublishPipeline class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(PublishContext) | Runs the 'publish' pipeline with specified arguments.
 | Run(PublishOptions) | Runs the 'publish' pipeline with specified arguments.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PublishPipeline


PublishPipeline Constructor

PublishPipeline Constructor
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishPipeline ► PublishPipeline()()()
Initializes a new instance of the PublishPipeline class
Declaration Syntax
C#
public PublishPipeline()


Run Method

Run Method
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishPipeline ► Run()()()
Members
Icon | Member | Description
 | Run(PublishContext) | Runs the 'publish' pipeline with specified arguments.
 | Run(PublishOptions) | Runs the 'publish' pipeline with specified arguments.


Run Method (context)

Run Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishPipeline ► Run(PublishContext)
Runs the 'publish' pipeline with specified arguments.
Declaration Syntax
C#
public static PublishResult Run(
    PublishContext context
)
Parameters
context (PublishContext)
The context.


Run Method (options)

Run Method (options)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishPipeline ► Run(PublishOptions)
Runs the 'publish' pipeline with specified arguments.
Declaration Syntax
C#
public static PublishResult Run(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.


PublishProcessor Class

PublishProcessor Class
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishProcessor
PublishProcessor
Declaration Syntax
C#
public abstract class PublishProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PublishProcessor()()() | Initializes a new instance of the PublishProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishContext) | Processes the specified args.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PublishProcessor
 |  | AddItemsToQueue
 |  | AddLanguagesToQueue
 |  | AddTemplatesToQueue
 |  | ProcessQueue


PublishProcessor Constructor

PublishProcessor Constructor
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishProcessor ► PublishProcessor()()()
Initializes a new instance of the PublishProcessor class
Declaration Syntax
C#
protected PublishProcessor()


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishProcessor ► Process(PublishContext)
Processes the specified args.
Declaration Syntax
C#
public abstract void Process(
    PublishContext context
)
Parameters
context (PublishContext)
The args.


PublishQueue Class

PublishQueue Class
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishQueue
PublishIterator class
Declaration Syntax
C#
public class PublishQueue
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PublishQueue(Database) | Initializes a new instance of the PublishQueue class.
 | Clear()()() | Removes all entries from the queue.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildIterator(ID, PublishOptions) | Gets an iterator for enumerating a (sub)tree.
 | GetContentBranch(PublishOptions) | Gets an iterator for enumerating a (sub)tree.
 | GetCount()()() | Gets the count.
 | GetEmptyIterator()()() | Gets the empty iterator.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPublishQueue(PublishOptions) | Gets an iterator for enumerating the publish queue.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PublishQueue


PublishQueue Constructor (database)

PublishQueue Constructor (database)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishQueue ► PublishQueue(Database)
Initializes a new instance of the PublishQueue class.
Declaration Syntax
C#
public PublishQueue(
    Database database
)
Parameters
database (Database)
The database.


Clear Method

Clear Method
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishQueue ► Clear()()()
Removes all entries from the queue.
Declaration Syntax
C#
public void Clear()


GetChildIterator Method (itemId, options)

GetChildIterator Method (itemId, options)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishQueue ► GetChildIterator(ID, PublishOptions)
Gets an iterator for enumerating a (sub)tree.
Declaration Syntax
C#
public static IEnumerable<PublishingCandidate> GetChildIterator(
    ID itemId,
    PublishOptions options
)
Parameters
itemId (ID)
The item id.
options (PublishOptions)
The options.
Return Value


GetContentBranch Method (options)

GetContentBranch Method (options)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishQueue ► GetContentBranch(PublishOptions)
Gets an iterator for enumerating a (sub)tree.
Declaration Syntax
C#
public static IEnumerable<PublishingCandidate> GetContentBranch(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.
Return Value


GetCount Method

GetCount Method
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishQueue ► GetCount()()()
Gets the count.
Declaration Syntax
C#
public int GetCount()
Return Value


GetEmptyIterator Method

GetEmptyIterator Method
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishQueue ► GetEmptyIterator()()()
Gets the empty iterator.
Declaration Syntax
C#
public static IEnumerable<PublishingCandidate> GetEmptyIterator()
Return Value


GetPublishQueue Method (options)

GetPublishQueue Method (options)
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishQueue ► GetPublishQueue(PublishOptions)
Gets an iterator for enumerating the publish queue.
Declaration Syntax
C#
public static IEnumerable<PublishingCandidate> GetPublishQueue(
    PublishOptions options
)
Parameters
options (PublishOptions)
The options.
Return Value


PublishResult Class

PublishResult Class
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishResult
PublishItemResult class
Declaration Syntax
C#
public class PublishResult
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PublishResult()()() | Initializes a new instance of the PublishResult class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PublishResult


PublishResult Constructor

PublishResult Constructor
Namespaces ► Sitecore.Publishing.Pipelines.Publish ► PublishResult ► PublishResult()()()
Initializes a new instance of the PublishResult class
Declaration Syntax
C#
public PublishResult()


Sitecore.Publishing.Pipelines.PublishItem Namespace

Sitecore.Publishing.Pipelines.PublishItem Namespace
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem
Declaration Syntax
C#
namespace Sitecore.Publishing.Pipelines.PublishItem
Types
All Types Classes
Icon | Type | Description
 | CheckSecurity | CheckSecurity class
 | CheckVirtualItem | CheckVirtualItem class
 | DetermineAction | HandleUnauthorized class
 | ItemProcessedEventArgs | Defines the arguments passed in a publish:itemProcessed event.
 | ItemProcessingEventArgs | Defines the arguments passed in a publish:item:processing event.
 | MoveItems | MoveItems class
 | PerformAction | HandleUnpublishable class
 | PublishItemContext | PublishItemArgs class
 | PublishItemPipeline | PublishItemPipeline class
 | PublishItemProcessor | PublishItemProcessor class
 | PublishItemResult | PublishItemResult class
 | RaiseProcessedEvent | RaiseEvents class
 | RaiseProcessingEvent | RaiseEvents class
 | RemoveUnknownChildren | RemoveUnknownChildren class
 | UpdateStatistics | UpdateJobStatus class


CheckSecurity Class

CheckSecurity Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► CheckSecurity
CheckSecurity class
Declaration Syntax
C#
public class CheckSecurity : PublishItemProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckSecurity()()() | Initializes a new instance of the CheckSecurity class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishItemContext) | Processes the specified context. (Overrides PublishItemProcessor.Process(PublishItemContext).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PublishItemProcessor
 |  | CheckSecurity


CheckSecurity Constructor

CheckSecurity Constructor
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► CheckSecurity ► CheckSecurity()()()
Initializes a new instance of the CheckSecurity class
Declaration Syntax
C#
public CheckSecurity()


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► CheckSecurity ► Process(PublishItemContext)
Processes the specified context.
Declaration Syntax
C#
public override void Process(
    PublishItemContext context
)
Parameters
context (PublishItemContext)
The context.


CheckVirtualItem Class

CheckVirtualItem Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► CheckVirtualItem
CheckVirtualItem class
Declaration Syntax
C#
public class CheckVirtualItem : PublishItemProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckVirtualItem()()() | Initializes a new instance of the CheckVirtualItem class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishItemContext) | Processes the specified context. (Overrides PublishItemProcessor.Process(PublishItemContext).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PublishItemProcessor
 |  | CheckVirtualItem


CheckVirtualItem Constructor

CheckVirtualItem Constructor
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► CheckVirtualItem ► CheckVirtualItem()()()
Initializes a new instance of the CheckVirtualItem class
Declaration Syntax
C#
public CheckVirtualItem()


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► CheckVirtualItem ► Process(PublishItemContext)
Processes the specified context.
Declaration Syntax
C#
public override void Process(
    PublishItemContext context
)
Parameters
context (PublishItemContext)
The context.


DetermineAction Class

DetermineAction Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► DetermineAction
HandleUnauthorized class
Declaration Syntax
C#
public class DetermineAction : PublishItemProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DetermineAction()()() | Initializes a new instance of the DetermineAction class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishItemContext) | Processes the specified context. (Overrides PublishItemProcessor.Process(PublishItemContext).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PublishItemProcessor
 |  | DetermineAction


DetermineAction Constructor

DetermineAction Constructor
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► DetermineAction ► DetermineAction()()()
Initializes a new instance of the DetermineAction class
Declaration Syntax
C#
public DetermineAction()


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► DetermineAction ► Process(PublishItemContext)
Processes the specified context.
Declaration Syntax
C#
public override void Process(
    PublishItemContext context
)
Parameters
context (PublishItemContext)
The context.


ItemProcessedEventArgs Class

ItemProcessedEventArgs Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► ItemProcessedEventArgs
Defines the arguments passed in a publish:itemProcessed event.
Declaration Syntax
C#
public class ItemProcessedEventArgs : EventArgs,
    IPassNativeEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemProcessedEventArgs(PublishItemContext) | Initializes a new instance of the ItemProcessedEventArgs class.
 | Context | Gets the context.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ItemProcessedEventArgs


ItemProcessedEventArgs Constructor (context)

ItemProcessedEventArgs Constructor (context)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► ItemProcessedEventArgs ► ItemProcessedEventArgs(PublishItemContext)
Initializes a new instance of the ItemProcessedEventArgs class.
Declaration Syntax
C#
public ItemProcessedEventArgs(
    PublishItemContext context
)
Parameters
context (PublishItemContext)
The context.


Context Property

Context Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► ItemProcessedEventArgs ► Context
Gets the context.
Declaration Syntax
C#
public PublishItemContext Context { get; }
Value
The context.


ItemProcessingEventArgs Class

ItemProcessingEventArgs Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► ItemProcessingEventArgs
Defines the arguments passed in a publish:item:processing event.
Declaration Syntax
C#
public class ItemProcessingEventArgs : CancelEventArgs,
    IPassNativeEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemProcessingEventArgs(PublishItemContext) | Initializes a new instance of the ItemProcessingEventArgs class.
 | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
 | Context | Gets the context.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CancelEventArgs
 |  |  | ItemProcessingEventArgs


ItemProcessingEventArgs Constructor (context)

ItemProcessingEventArgs Constructor (context)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► ItemProcessingEventArgs ► ItemProcessingEventArgs(PublishItemContext)
Initializes a new instance of the ItemProcessingEventArgs class.
Declaration Syntax
C#
public ItemProcessingEventArgs(
    PublishItemContext context
)
Parameters
context (PublishItemContext)
The context.


Context Property

Context Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► ItemProcessingEventArgs ► Context
Gets the context.
Declaration Syntax
C#
public PublishItemContext Context { get; }
Value
The context.


MoveItems Class

MoveItems Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► MoveItems
MoveItems class
Declaration Syntax
C#
public class MoveItems : PublishItemProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MoveItems()()() | Initializes a new instance of the MoveItems class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishItemContext) | Processes the specified args. (Overrides PublishItemProcessor.Process(PublishItemContext).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PublishItemProcessor
 |  | MoveItems


MoveItems Constructor

MoveItems Constructor
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► MoveItems ► MoveItems()()()
Initializes a new instance of the MoveItems class
Declaration Syntax
C#
public MoveItems()


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► MoveItems ► Process(PublishItemContext)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    PublishItemContext context
)
Parameters
context (PublishItemContext)
The args.


PerformAction Class

PerformAction Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PerformAction
HandleUnpublishable class
Declaration Syntax
C#
public class PerformAction : PublishItemProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PerformAction()()() | Initializes a new instance of the PerformAction class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishItemContext) | Processes the specified args. (Overrides PublishItemProcessor.Process(PublishItemContext).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PublishItemProcessor
 |  | PerformAction


PerformAction Constructor

PerformAction Constructor
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PerformAction ► PerformAction()()()
Initializes a new instance of the PerformAction class
Declaration Syntax
C#
public PerformAction()


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PerformAction ► Process(PublishItemContext)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    PublishItemContext context
)
Parameters
context (PublishItemContext)
The args.


PublishItemContext Class

PublishItemContext Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemContext
PublishItemArgs class
Declaration Syntax
C#
public class PublishItemContext : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishItemContext(ID, PublishOptions) | Initializes a new instance of the PublishItemContext class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline(PublishOperation, PublishChildAction, String) | Aborts the pipeline.
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | Action | Gets the type of the action.
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | Clone(ID) | Create a clone with the specified item id.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | ItemId | Gets the item id.
 | Job | Gets or sets the job.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | PublishContext | Gets the publish context.
 | PublishHelper | Gets or sets the publish helper.
 | PublishOptions | Gets the publish options.
 | Result | Gets or sets the result (i.e. the return value of the pipeline).
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | User | Gets or sets the user.
 | VersionToPublish | Gets or sets the version to publish.
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | PublishItemContext


PublishItemContext Constructor (itemId, publishOptions)

PublishItemContext Constructor (itemId, publishOptions)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemContext ► PublishItemContext(ID, PublishOptions)
Initializes a new instance of the PublishItemContext class.
Declaration Syntax
C#
public PublishItemContext(
    ID itemId,
    PublishOptions publishOptions
)
Parameters
itemId (ID)
The item id.
publishOptions (PublishOptions)
The publish options.


AbortPipeline Method (operation, childAction, explanation)

AbortPipeline Method (operation, childAction, explanation)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemContext ► AbortPipeline(PublishOperation, PublishChildAction, String)
Aborts the pipeline.
Declaration Syntax
C#
public virtual void AbortPipeline(
    PublishOperation operation,
    PublishChildAction childAction,
    string explanation
)
Parameters
operation (PublishOperation)
The operation that was performed.
childAction (PublishChildAction)
The action for children.
explanation (String)
A message explaining why the pipeline was aborted.


Action Property

Action Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemContext ► Action
Gets the type of the action.
Declaration Syntax
C#
public virtual PublishAction Action { get; set; }
Value
The type of the action.


Clone Method (itemId)

Clone Method (itemId)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemContext ► Clone(ID)
Create a clone with the specified item id.
Declaration Syntax
C#
public PublishItemContext Clone(
    ID itemId
)
Parameters
itemId (ID)
The item id.
Return Value


ItemId Property

ItemId Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemContext ► ItemId
Gets the item id.
Declaration Syntax
C#
public virtual ID ItemId { get; }
Value
The item id.


Job Property

Job Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemContext ► Job
Gets or sets the job.
Declaration Syntax
C#
public Job Job { get; set; }
Value
The job.


PublishContext Property

PublishContext Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemContext ► PublishContext
Gets the publish context.
Declaration Syntax
C#
public PublishContext PublishContext { get; set; }
Value
The publish context.


PublishHelper Property

PublishHelper Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemContext ► PublishHelper
Gets or sets the publish helper.
Declaration Syntax
C#
public virtual PublishHelper PublishHelper { get; set; }
Value
The publish helper.


PublishOptions Property

PublishOptions Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemContext ► PublishOptions
Gets the publish options.
Declaration Syntax
C#
public virtual PublishOptions PublishOptions { get; }
Value
The publish options.


Result Property

Result Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemContext ► Result
Gets or sets the result (i.e. the return value of the pipeline).
Declaration Syntax
C#
public virtual PublishItemResult Result { get; set; }
Value
The result.


User Property

User Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemContext ► User
Gets or sets the user.
Declaration Syntax
C#
public virtual User User { get; set; }
Value
The user.


VersionToPublish Property

VersionToPublish Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemContext ► VersionToPublish
Gets or sets the version to publish.
Declaration Syntax
C#
public virtual Item VersionToPublish { get; set; }
Value
The version to publish.


PublishItemPipeline Class

PublishItemPipeline Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemPipeline
PublishItemPipeline class
Declaration Syntax
C#
public class PublishItemPipeline
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PublishItemPipeline()()() | Initializes a new instance of the PublishItemPipeline class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(PublishItemContext) | Runs the 'publish' pipeline with specified arguments.
 | Run(ID, PublishOptions) | Runs the pipeline with the specified item id.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PublishItemPipeline


PublishItemPipeline Constructor

PublishItemPipeline Constructor
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemPipeline ► PublishItemPipeline()()()
Initializes a new instance of the PublishItemPipeline class
Declaration Syntax
C#
public PublishItemPipeline()


Run Method

Run Method
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemPipeline ► Run()()()
Members
Icon | Member | Description
 | Run(PublishItemContext) | Runs the 'publish' pipeline with specified arguments.
 | Run(ID, PublishOptions) | Runs the pipeline with the specified item id.


Run Method (itemId, options)

Run Method (itemId, options)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemPipeline ► Run(ID, PublishOptions)
Runs the pipeline with the specified item id.
Declaration Syntax
C#
public static PublishItemResult Run(
    ID itemId,
    PublishOptions options
)
Parameters
itemId (ID)
The item id.
options (PublishOptions)
The options.
Return Value


Run Method (context)

Run Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemPipeline ► Run(PublishItemContext)
Runs the 'publish' pipeline with specified arguments.
Declaration Syntax
C#
public static PublishItemResult Run(
    PublishItemContext context
)
Parameters
context (PublishItemContext)
The context.


PublishItemProcessor Class

PublishItemProcessor Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemProcessor
PublishItemProcessor class
Declaration Syntax
C#
public abstract class PublishItemProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PublishItemProcessor()()() | Initializes a new instance of the PublishItemProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishItemContext) | Processes the specified args.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PublishItemProcessor
 |  | CheckSecurity
 |  | CheckVirtualItem
 |  | DetermineAction
 |  | MoveItems
 |  | PerformAction
 |  | RaiseProcessedEvent
 |  | RaiseProcessingEvent
 |  | RemoveUnknownChildren
 |  | UpdateStatistics


PublishItemProcessor Constructor

PublishItemProcessor Constructor
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemProcessor ► PublishItemProcessor()()()
Initializes a new instance of the PublishItemProcessor class
Declaration Syntax
C#
protected PublishItemProcessor()


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemProcessor ► Process(PublishItemContext)
Processes the specified args.
Declaration Syntax
C#
public abstract void Process(
    PublishItemContext context
)
Parameters
context (PublishItemContext)
The args.


PublishItemResult Class

PublishItemResult Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemResult
PublishItemResult class
Declaration Syntax
C#
public class PublishItemResult
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishItemResult(PublishOperation, PublishChildAction) | Initializes a new instance of the PublishItemResult class.
 | PublishItemResult(PublishOperation, PublishChildAction, String) | Initializes a new instance of the PublishItemResult class.
 | ChildAction | Gets the action for children.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Explanation | Gets an explanation of the result (might be blank).
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Operation | Gets the type of operation that was performed.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PublishItemResult


PublishItemResult Constructor

PublishItemResult Constructor
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemResult ► PublishItemResult()()()
Members
Icon | Member | Description
 | PublishItemResult(PublishOperation, PublishChildAction) | Initializes a new instance of the PublishItemResult class.
 | PublishItemResult(PublishOperation, PublishChildAction, String) | Initializes a new instance of the PublishItemResult class.


PublishItemResult Constructor (operation, childAction)

PublishItemResult Constructor (operation, childAction)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemResult ► PublishItemResult(PublishOperation, PublishChildAction)
Initializes a new instance of the PublishItemResult class.
Declaration Syntax
C#
public PublishItemResult(
    PublishOperation operation,
    PublishChildAction childAction
)
Parameters
operation (PublishOperation)
The operation.
childAction (PublishChildAction)
The child action.


PublishItemResult Constructor (operation, childAction, explanation)

PublishItemResult Constructor (operation, childAction, explanation)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemResult ► PublishItemResult(PublishOperation, PublishChildAction, String)
Initializes a new instance of the PublishItemResult class.
Declaration Syntax
C#
public PublishItemResult(
    PublishOperation operation,
    PublishChildAction childAction,
    string explanation
)
Parameters
operation (PublishOperation)
Type of operation that was performed.
childAction (PublishChildAction)
The action for children.
explanation (String)
An optional explanation of the result.


ChildAction Property

ChildAction Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemResult ► ChildAction
Gets the action for children.
Declaration Syntax
C#
public PublishChildAction ChildAction { get; }
Value
The child action.


Explanation Property

Explanation Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemResult ► Explanation
Gets an explanation of the result (might be blank).
Declaration Syntax
C#
public string Explanation { get; }
Value
The explanation.


Operation Property

Operation Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► PublishItemResult ► Operation
Gets the type of operation that was performed.
Declaration Syntax
C#
public PublishOperation Operation { get; }
Value
The type of the action.


RaiseProcessedEvent Class

RaiseProcessedEvent Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► RaiseProcessedEvent
RaiseEvents class
Declaration Syntax
C#
public class RaiseProcessedEvent : PublishItemProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RaiseProcessedEvent()()() | Initializes a new instance of the RaiseProcessedEvent class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishItemContext) | Processes the specified context. (Overrides PublishItemProcessor.Process(PublishItemContext).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PublishItemProcessor
 |  | RaiseProcessedEvent


RaiseProcessedEvent Constructor

RaiseProcessedEvent Constructor
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► RaiseProcessedEvent ► RaiseProcessedEvent()()()
Initializes a new instance of the RaiseProcessedEvent class
Declaration Syntax
C#
public RaiseProcessedEvent()


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► RaiseProcessedEvent ► Process(PublishItemContext)
Processes the specified context.
Declaration Syntax
C#
public override void Process(
    PublishItemContext context
)
Parameters
context (PublishItemContext)
The context.


RaiseProcessingEvent Class

RaiseProcessingEvent Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► RaiseProcessingEvent
RaiseEvents class
Declaration Syntax
C#
public class RaiseProcessingEvent : PublishItemProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RaiseProcessingEvent()()() | Initializes a new instance of the RaiseProcessingEvent class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishItemContext) | Processes the specified context. (Overrides PublishItemProcessor.Process(PublishItemContext).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PublishItemProcessor
 |  | RaiseProcessingEvent


RaiseProcessingEvent Constructor

RaiseProcessingEvent Constructor
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► RaiseProcessingEvent ► RaiseProcessingEvent()()()
Initializes a new instance of the RaiseProcessingEvent class
Declaration Syntax
C#
public RaiseProcessingEvent()


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► RaiseProcessingEvent ► Process(PublishItemContext)
Processes the specified context.
Declaration Syntax
C#
public override void Process(
    PublishItemContext context
)
Parameters
context (PublishItemContext)
The context.


RemoveUnknownChildren Class

RemoveUnknownChildren Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► RemoveUnknownChildren
RemoveUnknownChildren class
Declaration Syntax
C#
public class RemoveUnknownChildren : PublishItemProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RemoveUnknownChildren()()() | Initializes a new instance of the RemoveUnknownChildren class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishItemContext) | Processes the specified args. (Overrides PublishItemProcessor.Process(PublishItemContext).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PublishItemProcessor
 |  | RemoveUnknownChildren


RemoveUnknownChildren Constructor

RemoveUnknownChildren Constructor
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► RemoveUnknownChildren ► RemoveUnknownChildren()()()
Initializes a new instance of the RemoveUnknownChildren class
Declaration Syntax
C#
public RemoveUnknownChildren()


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► RemoveUnknownChildren ► Process(PublishItemContext)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    PublishItemContext context
)
Parameters
context (PublishItemContext)
The context.


UpdateStatistics Class

UpdateStatistics Class
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► UpdateStatistics
UpdateJobStatus class
Declaration Syntax
C#
public class UpdateStatistics : PublishItemProcessor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UpdateStatistics()()() | Initializes a new instance of the UpdateStatistics class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PublishItemContext) | Processes the specified args. (Overrides PublishItemProcessor.Process(PublishItemContext).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TraceToLog | Gets or sets a value indicating whether to trace publishing information for every item to the log.
Inheritance Hierarchy
Object
 | PublishItemProcessor
 |  | UpdateStatistics


UpdateStatistics Constructor

UpdateStatistics Constructor
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► UpdateStatistics ► UpdateStatistics()()()
Initializes a new instance of the UpdateStatistics class
Declaration Syntax
C#
public UpdateStatistics()


Process Method (context)

Process Method (context)
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► UpdateStatistics ► Process(PublishItemContext)
Processes the specified args.
Declaration Syntax
C#
public override void Process(
    PublishItemContext context
)
Parameters
context (PublishItemContext)
The context.


TraceToLog Property

TraceToLog Property
Namespaces ► Sitecore.Publishing.Pipelines.PublishItem ► UpdateStatistics ► TraceToLog
Gets or sets a value indicating whether to trace publishing information for every item to the log.
Declaration Syntax
C#
public virtual bool TraceToLog { get; set; }
Value
true if trace to log; otherwise, false.


Sitecore.Reflection Namespace

Sitecore.Reflection Namespace
Namespaces ► Sitecore.Reflection
Declaration Syntax
C#
namespace Sitecore.Reflection
Types
All Types Classes Interfaces Delegates
Icon | Type | Description
 | FastInvoker | A delegate to invoke fast methods.
 | IFactory | IFactory
 | IInitializable | Defines the basic properties and functionality of an object that can be initialized.
 | INexusDataApi | INexusDataApi interface
 | INexusLicenseApi | INexusLicenseApi interface
 | INexusPipelineApi | INexusPipelineApi interface
 | INexusPlaceholderApi | INexusPlaceholderApi interface
 | MethodInstance | Represents a method instance.
 | Nexus | Nexus class
 | NexusHelper | NexusHelper class
 | PropertyTarget | Represents a property target.
 | ReflectionUtil | Implements a utility class for working with reflection.
 | TypeUtil | TypeUtil


FastInvoker Delegate

FastInvoker Delegate
Namespaces ► Sitecore.Reflection ► FastInvoker
A delegate to invoke fast methods.
Declaration Syntax
C#
public delegate Object FastInvoker(
    Object target,
    Object[] paramters
)
Parameters
target (Object)
paramters (array< Object >[]()[])


IFactory Interface

IFactory Interface
Namespaces ► Sitecore.Reflection ► IFactory
IFactory
Declaration Syntax
C#
public interface IFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetObject(String) | Gets the object.


GetObject Method (identifier)

GetObject Method (identifier)
Namespaces ► Sitecore.Reflection ► IFactory ► GetObject(String)
Gets the object.
Declaration Syntax
C#
Object GetObject(
    string identifier
)
Parameters
identifier (String)
The identifier.
Return Value


IInitializable Interface

IInitializable Interface
Namespaces ► Sitecore.Reflection ► IInitializable
Defines the basic properties and functionality of an object that can be initialized.
Declaration Syntax
C#
public interface IInitializable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AssignProperties | Gets a value indicating whether the IInitializable assigns the properties.
 | Initialize(XmlNode) | Initializes the object from the specified config node.


AssignProperties Property

AssignProperties Property
Namespaces ► Sitecore.Reflection ► IInitializable ► AssignProperties
Gets a value indicating whether the IInitializable assigns the properties.
Declaration Syntax
C#
bool AssignProperties { get; }
Value
true if the IInitializable assigns the properties; otherwise, false.


Initialize Method (configNode)

Initialize Method (configNode)
Namespaces ► Sitecore.Reflection ► IInitializable ► Initialize(XmlNode)
Initializes the object from the specified config node.
Declaration Syntax
C#
void Initialize(
    XmlNode configNode
)
Parameters
configNode (XmlNode)
The config node.


INexusDataApi Interface

INexusDataApi Interface
Namespaces ► Sitecore.Reflection ► INexusDataApi
INexusDataApi interface
Declaration Syntax
C#
public interface INexusDataApi
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddFromTemplate(ID, Item, String, ID) | Adds a new item from a template.
 | AddVersion(Item) | Adds a new version to an item.
 | BlobStreamExists(Guid, Database) | Determines whether the specified item field contains a BLOB value.
 | CopyItem(Item, Item, String, ID, Boolean) | Copies an item.
 | CreateItem(ID, String, ID, Item) | Creates an item.
 | DeleteItem(Item, ID) | Deletes an item.
 | GetBlobStream(Guid, Database) | Gets a BLOB stream from a field.
 | GetChildren(Item) | Gets the children of an item.
 | GetItem(ID, Language, Version, Database) | Gets an item.
 | GetParent(Item) | Gets the parent of an item.
 | GetRootItem(Language, Version, Database) | Gets the root item of a database.
 | GetVersions(Item, Language) | Gets the versions of an item.
 | HasChildren(Item) | Determines whether the specified item has any children.
 | MoveItem(Item, Item) | Moves an item.
 | RemoveData(ID, Language, Boolean, Database) | Removes the data associated with an item.
 | RemoveVersion(Item) | Removes a version from an item.
 | ResolvePath(String, Database) | Resolves an item path.
 | SaveItem(Item, ItemChanges) | Saves an item.
 | SetBlobStream(Stream, Guid, Database) | Gets a BLOB stream from a field.


AddFromTemplate Method (templateId, destination, itemName, newId)

AddFromTemplate Method (templateId, destination, itemName, newId)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► AddFromTemplate(ID, Item, String, ID)
Adds a new item from a template.
Declaration Syntax
C#
Item AddFromTemplate(
    ID templateId,
    Item destination,
    string itemName,
    ID newId
)
Parameters
templateId (ID)
The template id.
destination (Item)
The destination.
itemName (String)
Name of the item.
newId (ID)
The new id.
Return Value


AddVersion Method (item)

AddVersion Method (item)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► AddVersion(Item)
Adds a new version to an item.
Declaration Syntax
C#
Item AddVersion(
    Item item
)
Parameters
item (Item)
The item.
Return Value


BlobStreamExists Method (blobId, database)

BlobStreamExists Method (blobId, database)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► BlobStreamExists(Guid, Database)
Determines whether the specified item field contains a BLOB value.
Declaration Syntax
C#
bool BlobStreamExists(
    Guid blobId,
    Database database
)
Parameters
blobId (Guid)
The BLOB id.
database (Database)
The database.
Return Value
true if the field contains a BLOB value; otherwise, false.


CopyItem Method (source, destination, copyName, copyId, deep)

CopyItem Method (source, destination, copyName, copyId, deep)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► CopyItem(Item, Item, String, ID, Boolean)
Copies an item.
Declaration Syntax
C#
Item CopyItem(
    Item source,
    Item destination,
    string copyName,
    ID copyId,
    bool deep
)
Parameters
source (Item)
The source.
destination (Item)
The destination.
copyName (String)
Name of the copy.
copyId (ID)
The copy id.
deep (Boolean)
if set to true [deep].
Return Value


CreateItem Method (itemId, itemName, templateId, destination)

CreateItem Method (itemId, itemName, templateId, destination)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► CreateItem(ID, String, ID, Item)
Creates an item.
Declaration Syntax
C#
Item CreateItem(
    ID itemId,
    string itemName,
    ID templateId,
    Item destination
)
Parameters
itemId (ID)
The item id.
itemName (String)
Name of the item.
templateId (ID)
The template id.
destination (Item)
The destination.
Return Value


DeleteItem Method (item, parentId)

DeleteItem Method (item, parentId)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► DeleteItem(Item, ID)
Deletes an item.
Declaration Syntax
C#
bool DeleteItem(
    Item item,
    ID parentId
)
Parameters
item (Item)
The item.
parentId (ID)
The parent id.
Return Value


GetBlobStream Method (blobId, database)

GetBlobStream Method (blobId, database)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► GetBlobStream(Guid, Database)
Gets a BLOB stream from a field.
Declaration Syntax
C#
Stream GetBlobStream(
    Guid blobId,
    Database database
)
Parameters
blobId (Guid)
The BLOB id.
database (Database)
The database.
Return Value


GetChildren Method (item)

GetChildren Method (item)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► GetChildren(Item)
Gets the children of an item.
Declaration Syntax
C#
ItemList GetChildren(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetItem Method (itemId, language, version, database)

GetItem Method (itemId, language, version, database)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► GetItem(ID, Language, Version, Database)
Gets an item.
Declaration Syntax
C#
Item GetItem(
    ID itemId,
    Language language,
    Version version,
    Database database
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
version (Version)
The version.
database (Database)
The database.
Return Value


GetParent Method (item)

GetParent Method (item)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► GetParent(Item)
Gets the parent of an item.
Declaration Syntax
C#
Item GetParent(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetRootItem Method (language, version, database)

GetRootItem Method (language, version, database)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► GetRootItem(Language, Version, Database)
Gets the root item of a database.
Declaration Syntax
C#
Item GetRootItem(
    Language language,
    Version version,
    Database database
)
Parameters
language (Language)
The language.
version (Version)
The version.
database (Database)
The database.
Return Value


GetVersions Method (item, language)

GetVersions Method (item, language)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► GetVersions(Item, Language)
Gets the versions of an item.
Declaration Syntax
C#
VersionCollection GetVersions(
    Item item,
    Language language
)
Parameters
item (Item)
The item.
language (Language)
The language.
Return Value


HasChildren Method (item)

HasChildren Method (item)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► HasChildren(Item)
Determines whether the specified item has any children.
Declaration Syntax
C#
bool HasChildren(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item has children; otherwise, false.


MoveItem Method (item, destination)

MoveItem Method (item, destination)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► MoveItem(Item, Item)
Moves an item.
Declaration Syntax
C#
bool MoveItem(
    Item item,
    Item destination
)
Parameters
item (Item)
The item.
destination (Item)
The destination.
Return Value


RemoveData Method (itemId, language, removeSharedData, database)

RemoveData Method (itemId, language, removeSharedData, database)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► RemoveData(ID, Language, Boolean, Database)
Removes the data associated with an item.
Declaration Syntax
C#
bool RemoveData(
    ID itemId,
    Language language,
    bool removeSharedData,
    Database database
)
Parameters
itemId (ID)
The item id.
language (Language)
The language.
removeSharedData (Boolean)
If set to true, remove shared data.
database (Database)
The database.
Return Value


RemoveVersion Method (item)

RemoveVersion Method (item)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► RemoveVersion(Item)
Removes a version from an item.
Declaration Syntax
C#
bool RemoveVersion(
    Item item
)
Parameters
item (Item)
The item.
Return Value


ResolvePath Method (itemPath, database)

ResolvePath Method (itemPath, database)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► ResolvePath(String, Database)
Resolves an item path.
Declaration Syntax
C#
ID ResolvePath(
    string itemPath,
    Database database
)
Parameters
itemPath (String)
The item path.
database (Database)
The database.
Return Value


SaveItem Method (item, changes)

SaveItem Method (item, changes)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► SaveItem(Item, ItemChanges)
Saves an item.
Declaration Syntax
C#
bool SaveItem(
    Item item,
    ItemChanges changes
)
Parameters
item (Item)
The item.
changes (ItemChanges)
The changes.
Return Value


SetBlobStream Method (stream, blobId, database)

SetBlobStream Method (stream, blobId, database)
Namespaces ► Sitecore.Reflection ► INexusDataApi ► SetBlobStream(Stream, Guid, Database)
Gets a BLOB stream from a field.
Declaration Syntax
C#
bool SetBlobStream(
    Stream stream,
    Guid blobId,
    Database database
)
Parameters
stream (Stream)
The stream.
blobId (Guid)
The BLOB id.
database (Database)
The database.
Return Value


INexusLicenseApi Interface

INexusLicenseApi Interface
Namespaces ► Sitecore.Reflection ► INexusLicenseApi
INexusLicenseApi interface
Declaration Syntax
C#
public interface INexusLicenseApi
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Address | Gets the company address.
 | CompanyNo | Gets the company number.
 | DemandModule(String) | Demands the module.
 | Expiration | Gets the license expiration date.
 | GetModuleCount(String) | Gets the count value of a module.
 | GetSnapShot(Guid) | Gets a snap shot of the current license state.
 | HasModule(String) | Checks if a specific module has been licensed.
 | LastError | Gets the last error message.
 | LicenseAgreement | Gets the text of license agreement.
 | Licensee | Gets the name of the licensee.
 | LicenseID | Gets the license ID.
 | LicenseStatus(String) | Licenses the status.
 | Purpose | Gets the purpose string.
 | Reseller | Gets the name of the reseller.
 | ResellerUrl | Gets the URL of the reseller.
 | Reset()()() | Resets this instance.
 | Urls | Gets the company URLs.
 | VerifiedLicense()()() | Returns the verified license.
 | Version | Gets the version.


Address Property

Address Property
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► Address
Gets the company address.
Declaration Syntax
C#
string Address { get; }
Value
The company address.
Remarks
This information is provided when the license form is filled in.


CompanyNo Property

CompanyNo Property
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► CompanyNo
Gets the company number.
Declaration Syntax
C#
string CompanyNo { get; }
Value
The company number.
Remarks
This information is provided when the license form is filled in.


DemandModule Method (moduleName)

DemandModule Method (moduleName)
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► DemandModule(String)
Demands the module.
Declaration Syntax
C#
void DemandModule(
    string moduleName
)
Parameters
moduleName (String)
Name of the module.


Expiration Property

Expiration Property
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► Expiration
Gets the license expiration date.
Declaration Syntax
C#
string Expiration { get; }
Value
The license expiration date.
Remarks
The license is invalid when the expiration date has been exceeded.


GetModuleCount Method (name)

GetModuleCount Method (name)
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► GetModuleCount(String)
Gets the count value of a module.
Declaration Syntax
C#
int GetModuleCount(
    string name
)
Parameters
name (String)
The name of the module.
Return Value
The value of the count attribute for the module or 0 (zero) if no such attribute is available.


GetSnapShot Method (instance)

GetSnapShot Method (instance)
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► GetSnapShot(Guid)
Gets a snap shot of the current license state.
Declaration Syntax
C#
string GetSnapShot(
    Guid instance
)
Parameters
instance (Guid)
Return Value


HasModule Method (name)

HasModule Method (name)
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► HasModule(String)
Checks if a specific module has been licensed.
Declaration Syntax
C#
bool HasModule(
    string name
)
Parameters
name (String)
The name of the module.
Return Value
True, if the license for the module is valid, otherwise false.
Examples
The following example checks that a specific module has a valid license.
CopyC#
string requiredLicense = "SiteCore.MyModule";
Error.Assert(Sitecore.License.HasModule(requiredLicense), "Can not use the module without the following license: " + requiredLicense);


LastError Property

LastError Property
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► LastError
Gets the last error message.
Declaration Syntax
C#
string LastError { get; set; }
Value
The message of the last error.


LicenseAgreement Property

LicenseAgreement Property
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► LicenseAgreement
Gets the text of license agreement.
Declaration Syntax
C#
string LicenseAgreement { get; }
Value
The license agreement text.


Licensee Property

Licensee Property
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► Licensee
Gets the name of the licensee.
Declaration Syntax
C#
string Licensee { get; }
Value
The name of the licensee
Remarks
This information is provided when the license form is filled in.


LicenseID Property

LicenseID Property
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► LicenseID
Gets the license ID.
Declaration Syntax
C#
string LicenseID { get; }
Value
The ID of the license.


LicenseStatus Method (name)

LicenseStatus Method (name)
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► LicenseStatus(String)
Licenses the status.
Declaration Syntax
C#
CheckResult LicenseStatus(
    string name
)
Parameters
name (String)
The name.
Return Value
The status.


Purpose Property

Purpose Property
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► Purpose
Gets the purpose string.
Declaration Syntax
C#
string Purpose { get; }
Value
The purpose.
Remarks
This information is provided when the license form is filled in.


Reseller Property

Reseller Property
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► Reseller
Gets the name of the reseller.
Declaration Syntax
C#
string Reseller { get; }
Value
The name of the reseller.
Remarks
This information is provided when the license form is filled in.


ResellerUrl Property

ResellerUrl Property
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► ResellerUrl
Gets the URL of the reseller.
Declaration Syntax
C#
string ResellerUrl { get; }
Value
The URL of the reseller.
Remarks
This information is provided when the license form is filled in.


Reset Method

Reset Method
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► Reset()()()
Resets this instance.
Declaration Syntax
C#
void Reset()


Urls Property

Urls Property
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► Urls
Gets the company URLs.
Declaration Syntax
C#
string Urls { get; }
Value
The company URLs.
Remarks
This information is provided when the license form is filled in.


VerifiedLicense Method

VerifiedLicense Method
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► VerifiedLicense()()()
Returns the verified license.
Declaration Syntax
C#
XmlDocument VerifiedLicense()
Return Value
An XmlDocument containing the verified license.


Version Property

Version Property
Namespaces ► Sitecore.Reflection ► INexusLicenseApi ► Version
Gets the version.
Declaration Syntax
C#
string Version { get; }
Value
The version.


INexusPipelineApi Interface

INexusPipelineApi Interface
Namespaces ► Sitecore.Reflection ► INexusPipelineApi
INexusPipelineApi interface
Declaration Syntax
C#
public interface INexusPipelineApi
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Resume(PipelineArgs, Pipeline) | Resumes the specified pipeline.


Resume Method (args, pipeline)

Resume Method (args, pipeline)
Namespaces ► Sitecore.Reflection ► INexusPipelineApi ► Resume(PipelineArgs, Pipeline)
Resumes the specified pipeline.
Declaration Syntax
C#
void Resume(
    PipelineArgs args,
    Pipeline pipeline
)
Parameters
args (PipelineArgs)
The args.
pipeline (Pipeline)
The pipeline.


INexusPlaceholderApi Interface

INexusPlaceholderApi Interface
Namespaces ► Sitecore.Reflection ► INexusPlaceholderApi
INexusPlaceholderApi interface
Declaration Syntax
C#
public interface INexusPlaceholderApi
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreateChildControls(Placeholder) | Creates the child controls of a placeholder.


CreateChildControls Method (placeholder)

CreateChildControls Method (placeholder)
Namespaces ► Sitecore.Reflection ► INexusPlaceholderApi ► CreateChildControls(Placeholder)
Creates the child controls of a placeholder.
Declaration Syntax
C#
void CreateChildControls(
    Placeholder placeholder
)
Parameters
placeholder (Placeholder)
The placeholder.


MethodInstance Class

MethodInstance Class
Namespaces ► Sitecore.Reflection ► MethodInstance
Represents a method instance.
Declaration Syntax
C#
public class MethodInstance
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MethodInstance(Object, String, array<Object>[]()[]) | Initializes a new instance of the MethodInstance class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Invoke()()() | Invokes this instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Method | Gets the method.
 | Object | Gets the object.
 | Parameters | Gets the parameters.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MethodInstance


MethodInstance Constructor (obj, methodName, parameters)

MethodInstance Constructor (obj, methodName, parameters)
Namespaces ► Sitecore.Reflection ► MethodInstance ► MethodInstance(Object, String, array<Object>[]()[])
Initializes a new instance of the MethodInstance class.
Declaration Syntax
C#
public MethodInstance(
    Object obj,
    string methodName,
    Object[] parameters
)
Parameters
obj (Object)
The object.
methodName (String)
Name of the method.
parameters (array< Object >[]()[])
The parameters.


Invoke Method

Invoke Method
Namespaces ► Sitecore.Reflection ► MethodInstance ► Invoke()()()
Invokes this instance.
Declaration Syntax
C#
public Object Invoke()
Return Value


Method Property

Method Property
Namespaces ► Sitecore.Reflection ► MethodInstance ► Method
Gets the method.
Declaration Syntax
C#
public MethodInfo Method { get; }
Value
The method.


Object Property

Object Property
Namespaces ► Sitecore.Reflection ► MethodInstance ► Object
Gets the object.
Declaration Syntax
C#
public Object Object { get; }
Value
The object.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Reflection ► MethodInstance ► Parameters
Gets the parameters.
Declaration Syntax
C#
public Object[] Parameters { get; }
Value
The parameters.


Nexus Class

Nexus Class
Namespaces ► Sitecore.Reflection ► Nexus
Nexus class
Declaration Syntax
C#
public static class Nexus
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DataApi | Gets the data API.
 | LicenseApi | Gets the license API.
 | PipelineApi | Gets the pipeline API.
 | PlaceholderApi | Gets the placeholder API.
Inheritance Hierarchy
Object
Nexus


DataApi Property

DataApi Property
Namespaces ► Sitecore.Reflection ► Nexus ► DataApi
Gets the data API.
Declaration Syntax
C#
public static INexusDataApi DataApi { get; }
Value
The data API.


LicenseApi Property

LicenseApi Property
Namespaces ► Sitecore.Reflection ► Nexus ► LicenseApi
Gets the license API.
Declaration Syntax
C#
public static INexusLicenseApi LicenseApi { get; }
Value
The license API.


PipelineApi Property

PipelineApi Property
Namespaces ► Sitecore.Reflection ► Nexus ► PipelineApi
Gets the pipeline API.
Declaration Syntax
C#
public static INexusPipelineApi PipelineApi { get; }
Value
The pipeline API.


PlaceholderApi Property

PlaceholderApi Property
Namespaces ► Sitecore.Reflection ► Nexus ► PlaceholderApi
Gets the placeholder API.
Declaration Syntax
C#
public static INexusPlaceholderApi PlaceholderApi { get; }
Value
The placeholder API.


NexusHelper Class

NexusHelper Class
Namespaces ► Sitecore.Reflection ► NexusHelper
NexusHelper class
Declaration Syntax
C#
public static class NexusHelper
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetInvoker(String, String, Boolean) | Gets the invoker.
Inheritance Hierarchy
Object
NexusHelper


GetInvoker Method (typeName, methodName, isStatic)

GetInvoker Method (typeName, methodName, isStatic)
Namespaces ► Sitecore.Reflection ► NexusHelper ► GetInvoker(String, String, Boolean)
Gets the invoker.
Declaration Syntax
C#
public static FastInvoker GetInvoker(
    string typeName,
    string methodName,
    bool isStatic
)
Parameters
typeName (String)
Name of the type.
methodName (String)
Name of the method.
isStatic (Boolean)
If set to true, the method is static.
Return Value


PropertyTarget Class

PropertyTarget Class
Namespaces ► Sitecore.Reflection ► PropertyTarget
Represents a property target.
Declaration Syntax
C#
public class PropertyTarget
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PropertyTarget(Object, PropertyInfo) | Initializes a new instance of the PropertyTarget class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Object | Gets the object.
 | PropertyInfo | Gets the property info.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PropertyTarget


PropertyTarget Constructor (obj, info)

PropertyTarget Constructor (obj, info)
Namespaces ► Sitecore.Reflection ► PropertyTarget ► PropertyTarget(Object, PropertyInfo)
Initializes a new instance of the PropertyTarget class.
Declaration Syntax
C#
public PropertyTarget(
    Object obj,
    PropertyInfo info
)
Parameters
obj (Object)
The object.
info (PropertyInfo)
The info.


Object Property

Object Property
Namespaces ► Sitecore.Reflection ► PropertyTarget ► Object
Gets the object.
Declaration Syntax
C#
public Object Object { get; }
Value
The object.


PropertyInfo Property

PropertyInfo Property
Namespaces ► Sitecore.Reflection ► PropertyTarget ► PropertyInfo
Gets the property info.
Declaration Syntax
C#
public PropertyInfo PropertyInfo { get; }
Value
The property info.


ReflectionUtil Class

ReflectionUtil Class
Namespaces ► Sitecore.Reflection ► ReflectionUtil
Implements a utility class for working with reflection.
Declaration Syntax
C#
public static class ReflectionUtil
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CallMethod(Type, String) | Calls a method on a type.
 | CallMethod(Object, String) | Calls a method on an object.
 | CallMethod(Object, String, array<Object>[]()[]) | Calls a method on an object.
 | CallMethod(Object, String, Boolean, Boolean) | Calls a method on an object.
 | CallMethod(Object, String, Boolean, Boolean, array<Object>[]()[]) | Calls a method on an object.
 | CallMethod(Object, String, Boolean, Boolean, Boolean, array<Object>[]()[]) | Calls a method on an object.
 | CallMethod(Type, Object, String, Boolean, Boolean, array<Object>[]()[]) | Calls a method on an object.
 | CallMethod(Type, Object, String, Boolean, Boolean, Boolean, array<Object>[]()[]) | Calls a method on an object.
 | CallStaticMethod(String, String, array<Object>[]()[]) | Calls a method on an object.
 | CreateEventHandler(Object, String) | Creates the event handler.
 | CreateEventHandler(Type, String) | Creates the event handler.
 | CreateObject(String) | Creates an instance of an object from a web.config setting.
 | CreateObject(XmlNode) | Creates an instance of an object from a web.config setting.
 | CreateObject(String, array<Object>[]()[]) | Creates an instance of an object.
 | CreateObject(String, String, array<Object>[]()[]) | Creates an instance of an object.
 | CreateObject(Type) | Creates an instance of an object.
 | CreateObject(Type, array<Object>[]()[]) | Creates an instance of an object.
 | CreateObjectFromConfig(String) | Creates an instance of an object from a web.config setting.
 | CreateObjectFromConfig(String, array<Object>[]()[]) | Creates an instance of an object from a web.config setting.
 | CreateObjectFromConfig(String, String, array<Object>[]()[]) | Creates an instance of an object from a web.config setting.
 | GetAttribute(Object, Type) | Gets the attribute.
 | GetConstructorInfo(Type, array<Object>[]()[]) | Gets the constructor info.
 | GetField(Object, String) | Gets a field on an object.
 | GetField(Object, String, Object) | Gets a field on an object.
 | GetMethod(Object, String, array<Object>[]()[]) | Gets a method on an object.
 | GetMethod(Object, String, Boolean, Boolean, array<Object>[]()[]) | Gets a method on an object.
 | GetMethod(Type, String, Boolean, Boolean, array<Object>[]()[]) | Gets a method on an object.
 | GetMethod(Type, String, Boolean, Boolean, Boolean, array<Object>[]()[]) | Gets a method on an object.
 | GetMethod(Type, String, Boolean, Boolean, Boolean, array<Type>[]()[]) | Gets a method on an object.
 | GetMethodInvoker(MethodInfo) | Gets a fast method invoker.
 | GetProperty(Object, String) | Gets a property on an object.
 | GetProperty(Object, String, Object) | Gets a property on an object.
 | GetPropertyInfo(Object, String) | Gets property info on an object.
 | GetTypeInfo(String) | Gets type information for a class.
 | GetTypeInfo(String, String) | Gets type information for a class.
 | GetTypes(array<Object>[]()[]) | Gets the types.
 | GetTypeString(Type) | Gets the type string.
 | HasAttribute(Object, Type) | Determines whether the specified object has attribute.
 | HasAttribute(MethodInfo, Type) | Determines whether the specified method has attribute.
 | InvokeMethod(MethodInfo, array<Object>[]()[], Object) | Invokes a method on an object.
 | LoadAssembly(String) | Loads an assembly from disk.
 | ParseEnum<(Of <(T>)>)(String) | Parses an enum type from a string.
 | SetField(Object, String, Object) | Sets a field on an object.
 | SetProperties(Object, String) | Sets properties on an object from a list of parameters on the form: p1=value1&p2=value2&...
 | SetProperties(Object, String, Boolean) | Sets properties on an object from a list of parameters on the form: p1=value1&p2=value2&...
 | SetPropertiesFromConfig(Object, String, array<String>[]()[]) | Sets the properties from config.
 | SetProperty(Object, String, Object) | Sets a property on an object.
 | SetProperty(Object, PropertyInfo, Object) | Sets a property on an object.
 | SetStaticField(Type, String, Object) | Sets the static field.
Remarks
Inheritance Hierarchy
Object
ReflectionUtil
See Also
DateUtil
FileUtil
MainUtil
StringUtil
XmlUtil


CallMethod Method

CallMethod Method
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CallMethod()()()
Members
Icon | Member | Description
 | CallMethod(Type, String) | Calls a method on a type.
 | CallMethod(Object, String) | Calls a method on an object.
 | CallMethod(Object, String, array<Object>[]()[]) | Calls a method on an object.
 | CallMethod(Object, String, Boolean, Boolean) | Calls a method on an object.
 | CallMethod(Object, String, Boolean, Boolean, array<Object>[]()[]) | Calls a method on an object.
 | CallMethod(Object, String, Boolean, Boolean, Boolean, array<Object>[]()[]) | Calls a method on an object.
 | CallMethod(Type, Object, String, Boolean, Boolean, array<Object>[]()[]) | Calls a method on an object.
 | CallMethod(Type, Object, String, Boolean, Boolean, Boolean, array<Object>[]()[]) | Calls a method on an object.


CallMethod Method (obj, methodName)

CallMethod Method (obj, methodName)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CallMethod(Object, String)
Calls a method on an object.
Declaration Syntax
C#
public static Object CallMethod(
    Object obj,
    string methodName
)
Parameters
obj (Object)
The object.
methodName (String)
Name of the method.
Return Value


CallMethod Method (obj, methodName, includeNonPublic, includeInherited)

CallMethod Method (obj, methodName, includeNonPublic, includeInherited)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CallMethod(Object, String, Boolean, Boolean)
Calls a method on an object.
Declaration Syntax
C#
public static Object CallMethod(
    Object obj,
    string methodName,
    bool includeNonPublic,
    bool includeInherited
)
Parameters
obj (Object)
The object.
methodName (String)
Name of the method.
includeNonPublic (Boolean)
if set to true this instance is include non public.
includeInherited (Boolean)
if set to true this instance is include inherited.
Return Value


CallMethod Method (obj, methodName, includeNonPublic, includeInherited, includeStatic, parameters)

CallMethod Method (obj, methodName, includeNonPublic, includeInherited, includeStatic, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CallMethod(Object, String, Boolean, Boolean, Boolean, array<Object>[]()[])
Calls a method on an object.
Declaration Syntax
C#
public static Object CallMethod(
    Object obj,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    bool includeStatic,
    Object[] parameters
)
Parameters
obj (Object)
The object.
methodName (String)
Name of the method.
includeNonPublic (Boolean)
if set to true this instance is include non public.
includeInherited (Boolean)
if set to true this instance is include inherited.
includeStatic (Boolean)
if set to true this instance is include static.
parameters (array< Object >[]()[])
The parameters.
Return Value


CallMethod Method (obj, methodName, includeNonPublic, includeInherited, parameters)

CallMethod Method (obj, methodName, includeNonPublic, includeInherited, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CallMethod(Object, String, Boolean, Boolean, array<Object>[]()[])
Calls a method on an object.
Declaration Syntax
C#
public static Object CallMethod(
    Object obj,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    Object[] parameters
)
Parameters
obj (Object)
The object.
methodName (String)
Name of the method.
includeNonPublic (Boolean)
if set to true this instance is include non public.
includeInherited (Boolean)
if set to true this instance is include inherited.
parameters (array< Object >[]()[])
The parameters.
Return Value


CallMethod Method (obj, methodName, parameters)

CallMethod Method (obj, methodName, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CallMethod(Object, String, array<Object>[]()[])
Calls a method on an object.
Declaration Syntax
C#
public static Object CallMethod(
    Object obj,
    string methodName,
    Object[] parameters
)
Parameters
obj (Object)
The object.
methodName (String)
Name of the method.
parameters (array< Object >[]()[])
The parameters.
Return Value


CallMethod Method (type, obj, methodName, includeNonPublic, includeInherited, includeStatic, parameters)

CallMethod Method (type, obj, methodName, includeNonPublic, includeInherited, includeStatic, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CallMethod(Type, Object, String, Boolean, Boolean, Boolean, array<Object>[]()[])
Calls a method on an object.
Declaration Syntax
C#
public static Object CallMethod(
    Type type,
    Object obj,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    bool includeStatic,
    Object[] parameters
)
Parameters
type (Type)
The type.
obj (Object)
The object.
methodName (String)
Name of the method.
includeNonPublic (Boolean)
if set to true this instance is include non public.
includeInherited (Boolean)
if set to true this instance is include inherited.
includeStatic (Boolean)
if set to true this instance is include static.
parameters (array< Object >[]()[])
The parameters.
Return Value


CallMethod Method (type, obj, methodName, includeNonPublic, includeInherited, parameters)

CallMethod Method (type, obj, methodName, includeNonPublic, includeInherited, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CallMethod(Type, Object, String, Boolean, Boolean, array<Object>[]()[])
Calls a method on an object.
Declaration Syntax
C#
public static Object CallMethod(
    Type type,
    Object obj,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    Object[] parameters
)
Parameters
type (Type)
The type.
obj (Object)
The object.
methodName (String)
Name of the method.
includeNonPublic (Boolean)
if set to true this instance is include non public.
includeInherited (Boolean)
if set to true this instance is include inherited.
parameters (array< Object >[]()[])
The parameters.
Return Value


CallMethod Method (type, methodName)

CallMethod Method (type, methodName)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CallMethod(Type, String)
Calls a method on a type.
Declaration Syntax
C#
public static Object CallMethod(
    Type type,
    string methodName
)
Parameters
type (Type)
The type.
methodName (String)
Name of the method.
Return Value


CallStaticMethod Method (typeName, methodName, parameters)

CallStaticMethod Method (typeName, methodName, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CallStaticMethod(String, String, array<Object>[]()[])
Calls a method on an object.
Declaration Syntax
C#
public static Object CallStaticMethod(
    string typeName,
    string methodName,
    Object[] parameters
)
Parameters
typeName (String)
Name of the type.
methodName (String)
Name of the method.
parameters (array< Object >[]()[])
The parameters.
Return Value


CreateEventHandler Method

CreateEventHandler Method
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CreateEventHandler()()()
Members
Icon | Member | Description
 | CreateEventHandler(Object, String) | Creates the event handler.
 | CreateEventHandler(Type, String) | Creates the event handler.


CreateEventHandler Method (obj, method)

CreateEventHandler Method (obj, method)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CreateEventHandler(Object, String)
Creates the event handler.
Declaration Syntax
C#
public static EventHandler CreateEventHandler(
    Object obj,
    string method
)
Parameters
obj (Object)
The object.
method (String)
The method.
Return Value


CreateEventHandler Method (type, method)

CreateEventHandler Method (type, method)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CreateEventHandler(Type, String)
Creates the event handler.
Declaration Syntax
C#
public static EventHandler CreateEventHandler(
    Type type,
    string method
)
Parameters
type (Type)
The type.
method (String)
The method.
Return Value


CreateObject Method

CreateObject Method
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CreateObject()()()
Members
Icon | Member | Description
 | CreateObject(String) | Creates an instance of an object from a web.config setting.
 | CreateObject(XmlNode) | Creates an instance of an object from a web.config setting.
 | CreateObject(String, array<Object>[]()[]) | Creates an instance of an object.
 | CreateObject(String, String, array<Object>[]()[]) | Creates an instance of an object.
 | CreateObject(Type) | Creates an instance of an object.
 | CreateObject(Type, array<Object>[]()[]) | Creates an instance of an object.


CreateObject Method (name)

CreateObject Method (name)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CreateObject(String)
Creates an instance of an object from a web.config setting.
Declaration Syntax
C#
public static Object CreateObject(
    string name
)
Parameters
name (String)
Name setting in the web.config.
Return Value
The instantiated object or null if the object could not be instantiated.
Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).
Examples
CopyC#
object MyObject = MainUtil.CreateObject("ShellAPI");


CreateObject Method (typeName, parameters)

CreateObject Method (typeName, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CreateObject(String, array<Object>[]()[])
Creates an instance of an object.
Declaration Syntax
C#
public static Object CreateObject(
    string typeName,
    Object[] parameters
)
Parameters
typeName (String)
Name of type.
parameters (array< Object >[]()[])
Parameters.
Return Value
The instantiated object or null if the object could not be instantiated.
Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).
Examples
CopyC#
object MyObject = ReflectionUtil.CreateObject("/bin/MyAssembly.dll", "MyNamespace.MyObject");
object MyObject2 = ReflectionUtil.CreateObject("MyAssembly", "MyNamespace.MyObject2", parameter1, parameter2);


CreateObject Method (assembly, className, parameters)

CreateObject Method (assembly, className, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CreateObject(String, String, array<Object>[]()[])
Creates an instance of an object.
Declaration Syntax
C#
public static Object CreateObject(
    string assembly,
    string className,
    Object[] parameters
)
Parameters
assembly (String)
An assembly file name.
className (String)
A class name.
parameters (array< Object >[]()[])
Parameters.
Return Value
The instantiated object or null if the object could not be instantiated.
Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).
Examples
CopyC#
object MyObject = ReflectionUtil.CreateObject("/bin/MyAssembly.dll", "MyNamespace.MyObject");
object MyObject2 = ReflectionUtil.CreateObject("MyAssembly", "MyNamespace.MyObject2", parameter1, parameter2);


CreateObject Method (type)

CreateObject Method (type)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CreateObject(Type)
Creates an instance of an object.
Declaration Syntax
C#
public static Object CreateObject(
    Type type
)
Parameters
type (Type)
Name of both assembly and class of the object.
Return Value
The instantiated object or null if the object could not be instantiated.
Remarks
If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).
Examples
CopyC#
object MyObject = ReflectionUtil.CreateObject(myType);


CreateObject Method (type, parameters)

CreateObject Method (type, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CreateObject(Type, array<Object>[]()[])
Creates an instance of an object.
Declaration Syntax
C#
public static Object CreateObject(
    Type type,
    Object[] parameters
)
Parameters
type (Type)
Name of both assembly and class of the object.
parameters (array< Object >[]()[])
Parameters.
Return Value
The instantiated object or null if the object could not be instantiated.
Remarks
If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).
Examples
CopyC#
object MyObject = ReflectionUtil.CreateObject("MyAssembly.MyObject", parameter1, parameter2);


CreateObject Method (configNode)

CreateObject Method (configNode)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CreateObject(XmlNode)
Creates an instance of an object from a web.config setting.
Declaration Syntax
C#
public static Object CreateObject(
    XmlNode configNode
)
Parameters
configNode (XmlNode)
The config node.
Return Value
The instantiated object or null if the object could not be instantiated.
Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).
Examples
CopyC#
object MyObject = MainUtil.CreateObject("ShellAPI");


CreateObjectFromConfig Method

CreateObjectFromConfig Method
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CreateObjectFromConfig()()()
Members
Icon | Member | Description
 | CreateObjectFromConfig(String) | Creates an instance of an object from a web.config setting.
 | CreateObjectFromConfig(String, array<Object>[]()[]) | Creates an instance of an object from a web.config setting.
 | CreateObjectFromConfig(String, String, array<Object>[]()[]) | Creates an instance of an object from a web.config setting.


CreateObjectFromConfig Method (configPath)

CreateObjectFromConfig Method (configPath)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CreateObjectFromConfig(String)
Creates an instance of an object from a web.config setting.
Declaration Syntax
C#
public static Object CreateObjectFromConfig(
    string configPath
)
Parameters
configPath (String)
Path to node in web.config (relative to the sitecore section).
Return Value
The instantiated object or null if the object could not be instantiated.
Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).
Examples
CopyC#
object obj = ReflectionUtil.CreateObjectFromConfig("workflow/managers/simple");


CreateObjectFromConfig Method (configPath, parameters)

CreateObjectFromConfig Method (configPath, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CreateObjectFromConfig(String, array<Object>[]()[])
Creates an instance of an object from a web.config setting.
Declaration Syntax
C#
public static Object CreateObjectFromConfig(
    string configPath,
    Object[] parameters
)
Parameters
configPath (String)
Path to node in web.config (relative to the sitecore section).
parameters (array< Object >[]()[])
The parameters.
Return Value
The instantiated object or null if the object could not be instantiated.
Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).
Examples
CopyC#
object obj = ReflectionUtil.CreateObjectFromConfig("workflow/managers/simple");


CreateObjectFromConfig Method (configPath, typeAttribute, parameters)

CreateObjectFromConfig Method (configPath, typeAttribute, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► CreateObjectFromConfig(String, String, array<Object>[]()[])
Creates an instance of an object from a web.config setting.
Declaration Syntax
C#
public static Object CreateObjectFromConfig(
    string configPath,
    string typeAttribute,
    Object[] parameters
)
Parameters
configPath (String)
Path to node in web.config (relative to the sitecore section).
typeAttribute (String)
Name of attribute that contains type information (on the form: 'class, assembly')
parameters (array< Object >[]()[])
The parameters.
Return Value
The instantiated object or null if the object could not be instantiated.
Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).
Examples
CopyC#
object obj = ReflectionUtil.CreateObjectFromConfig("workflow", "managerFactory");


GetAttribute Method (obj, attributeType)

GetAttribute Method (obj, attributeType)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetAttribute(Object, Type)
Gets the attribute.
Declaration Syntax
C#
public static Attribute GetAttribute(
    Object obj,
    Type attributeType
)
Parameters
obj (Object)
The object.
attributeType (Type)
Type of the attribute.
Return Value


GetConstructorInfo Method (type, construtorParameters)

GetConstructorInfo Method (type, construtorParameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetConstructorInfo(Type, array<Object>[]()[])
Gets the constructor info.
Declaration Syntax
C#
public static ConstructorInfo GetConstructorInfo(
    Type type,
    Object[] construtorParameters
)
Parameters
type (Type)
The type.
construtorParameters (array< Object >[]()[])
The construtor parameters.
Return Value


GetField Method

GetField Method
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetField()()()
Members
Icon | Member | Description
 | GetField(Object, String) | Gets a field on an object.
 | GetField(Object, String, Object) | Gets a field on an object.


GetField Method (obj, name)

GetField Method (obj, name)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetField(Object, String)
Gets a field on an object.
Declaration Syntax
C#
public static Object GetField(
    Object obj,
    string name
)
Parameters
obj (Object)
The object.
name (String)
The name.
Return Value


GetField Method (obj, name, defaultValue)

GetField Method (obj, name, defaultValue)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetField(Object, String, Object)
Gets a field on an object.
Declaration Syntax
C#
public static Object GetField(
    Object obj,
    string name,
    Object defaultValue
)
Parameters
obj (Object)
The object.
name (String)
The name.
defaultValue (Object)
The _default.
Return Value


GetMethod Method

GetMethod Method
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetMethod()()()
Members
Icon | Member | Description
 | GetMethod(Object, String, array<Object>[]()[]) | Gets a method on an object.
 | GetMethod(Object, String, Boolean, Boolean, array<Object>[]()[]) | Gets a method on an object.
 | GetMethod(Type, String, Boolean, Boolean, array<Object>[]()[]) | Gets a method on an object.
 | GetMethod(Type, String, Boolean, Boolean, Boolean, array<Object>[]()[]) | Gets a method on an object.
 | GetMethod(Type, String, Boolean, Boolean, Boolean, array<Type>[]()[]) | Gets a method on an object.


GetMethod Method (obj, methodName, includeNonPublic, includeInherited, parameters)

GetMethod Method (obj, methodName, includeNonPublic, includeInherited, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetMethod(Object, String, Boolean, Boolean, array<Object>[]()[])
Gets a method on an object.
Declaration Syntax
C#
public static MethodInfo GetMethod(
    Object obj,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    Object[] parameters
)
Parameters
obj (Object)
The object.
methodName (String)
Name of the method.
includeNonPublic (Boolean)
if set to true this instance is include non public.
includeInherited (Boolean)
if set to true this instance is include inherited.
parameters (array< Object >[]()[])
The parameters.
Return Value


GetMethod Method (obj, methodName, parameters)

GetMethod Method (obj, methodName, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetMethod(Object, String, array<Object>[]()[])
Gets a method on an object.
Declaration Syntax
C#
public static MethodInfo GetMethod(
    Object obj,
    string methodName,
    Object[] parameters
)
Parameters
obj (Object)
The object.
methodName (String)
Name of the method.
parameters (array< Object >[]()[])
The parameters.
Return Value


GetMethod Method (type, methodName, includeNonPublic, includeInherited, includeStatic, parameters)

GetMethod Method (type, methodName, includeNonPublic, includeInherited, includeStatic, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetMethod(Type, String, Boolean, Boolean, Boolean, array<Object>[]()[])
Gets a method on an object.
Declaration Syntax
C#
public static MethodInfo GetMethod(
    Type type,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    bool includeStatic,
    Object[] parameters
)
Parameters
type (Type)
The type.
methodName (String)
Name of the method.
includeNonPublic (Boolean)
if set to true this instance is include non public.
includeInherited (Boolean)
if set to true this instance is include inherited.
includeStatic (Boolean)
if set to true this instance is include static.
parameters (array< Object >[]()[])
The parameters.
Return Value


GetMethod Method (type, methodName, includeNonPublic, includeInherited, includeStatic, types)

GetMethod Method (type, methodName, includeNonPublic, includeInherited, includeStatic, types)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetMethod(Type, String, Boolean, Boolean, Boolean, array<Type>[]()[])
Gets a method on an object.
Declaration Syntax
C#
public static MethodInfo GetMethod(
    Type type,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    bool includeStatic,
    Type[] types
)
Parameters
type (Type)
The type.
methodName (String)
Name of the method.
includeNonPublic (Boolean)
if set to true this instance is include non public.
includeInherited (Boolean)
if set to true this instance is include inherited.
includeStatic (Boolean)
if set to true this instance is include static.
types (array< Type >[]()[])
The types.
Return Value


GetMethod Method (type, methodName, includeNonPublic, includeInherited, parameters)

GetMethod Method (type, methodName, includeNonPublic, includeInherited, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetMethod(Type, String, Boolean, Boolean, array<Object>[]()[])
Gets a method on an object.
Declaration Syntax
C#
public static MethodInfo GetMethod(
    Type type,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    Object[] parameters
)
Parameters
type (Type)
The type.
methodName (String)
Name of the method.
includeNonPublic (Boolean)
if set to true this instance is include non public.
includeInherited (Boolean)
if set to true this instance is include inherited.
parameters (array< Object >[]()[])
The parameters.
Return Value


GetMethodInvoker Method (methodInfo)

GetMethodInvoker Method (methodInfo)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetMethodInvoker(MethodInfo)
Gets a fast method invoker.
Declaration Syntax
C#
public static FastInvoker GetMethodInvoker(
    MethodInfo methodInfo
)
Parameters
methodInfo (MethodInfo)
The method info.
Return Value


GetProperty Method

GetProperty Method
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetProperty()()()
Members
Icon | Member | Description
 | GetProperty(Object, String) | Gets a property on an object.
 | GetProperty(Object, String, Object) | Gets a property on an object.


GetProperty Method (obj, name)

GetProperty Method (obj, name)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetProperty(Object, String)
Gets a property on an object.
Declaration Syntax
C#
public static Object GetProperty(
    Object obj,
    string name
)
Parameters
obj (Object)
The object.
name (String)
The name.
Return Value


GetProperty Method (obj, name, defaultValue)

GetProperty Method (obj, name, defaultValue)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetProperty(Object, String, Object)
Gets a property on an object.
Declaration Syntax
C#
public static Object GetProperty(
    Object obj,
    string name,
    Object defaultValue
)
Parameters
obj (Object)
The object.
name (String)
The name.
defaultValue (Object)
The _default.
Return Value


GetPropertyInfo Method (obj, name)

GetPropertyInfo Method (obj, name)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetPropertyInfo(Object, String)
Gets property info on an object.
Declaration Syntax
C#
public static PropertyInfo GetPropertyInfo(
    Object obj,
    string name
)
Parameters
obj (Object)
The object.
name (String)
The name.
Return Value
Remarks
Declared properties are considered first.


GetTypeInfo Method

GetTypeInfo Method
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetTypeInfo()()()
Members
Icon | Member | Description
 | GetTypeInfo(String) | Gets type information for a class.
 | GetTypeInfo(String, String) | Gets type information for a class.


GetTypeInfo Method (typeName)

GetTypeInfo Method (typeName)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetTypeInfo(String)
Gets type information for a class.
Declaration Syntax
C#
public static Type GetTypeInfo(
    string typeName
)
Parameters
typeName (String)
Name of the type on the format 'Namespace.Class, Assembly'. Example: "Sitecore.Xml.Packet, Sitecore.Kernel".
Return Value
The type information or null if the type could not be found.
Remarks
The assembly name is expanded to a qualified path by:
  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".


GetTypeInfo Method (assembly, className)

GetTypeInfo Method (assembly, className)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetTypeInfo(String, String)
Gets type information for a class.
Declaration Syntax
C#
public static Type GetTypeInfo(
    string assembly,
    string className
)
Parameters
assembly (String)
An assembly file name.
className (String)
A class name.
Return Value
The type information or null if the type could not be found.
Remarks
The assembly name is expanded to a qualified path by:
  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".


GetTypes Method (parameters)

GetTypes Method (parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetTypes(array<Object>[]()[])
Gets the types.
Declaration Syntax
C#
public static Type[] GetTypes(
    Object[] parameters
)
Parameters
parameters (array< Object >[]()[])
The parameters.
Return Value


GetTypeString Method (type)

GetTypeString Method (type)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► GetTypeString(Type)
Gets the type string.
Declaration Syntax
C#
public static string GetTypeString(
    Type type
)
Parameters
type (Type)
The type.
Return Value


HasAttribute Method

HasAttribute Method
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► HasAttribute()()()
Members
Icon | Member | Description
 | HasAttribute(Object, Type) | Determines whether the specified object has attribute.
 | HasAttribute(MethodInfo, Type) | Determines whether the specified method has attribute.


HasAttribute Method (obj, attributeType)

HasAttribute Method (obj, attributeType)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► HasAttribute(Object, Type)
Determines whether the specified object has attribute.
Declaration Syntax
C#
public static bool HasAttribute(
    Object obj,
    Type attributeType
)
Parameters
obj (Object)
The object.
attributeType (Type)
Type of the attribute.
Return Value
true if the specified obj has attribute; otherwise, false.


HasAttribute Method (method, attributeType)

HasAttribute Method (method, attributeType)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► HasAttribute(MethodInfo, Type)
Determines whether the specified method has attribute.
Declaration Syntax
C#
public static bool HasAttribute(
    MethodInfo method,
    Type attributeType
)
Parameters
method (MethodInfo)
The method.
attributeType (Type)
Type of the attribute.
Return Value
true if the specified obj has attribute; otherwise, false.


InvokeMethod Method (method, parameters, obj)

InvokeMethod Method (method, parameters, obj)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► InvokeMethod(MethodInfo, array<Object>[]()[], Object)
Invokes a method on an object.
Declaration Syntax
C#
public static Object InvokeMethod(
    MethodInfo method,
    Object[] parameters,
    Object obj
)
Parameters
method (MethodInfo)
The method.
parameters (array< Object >[]()[])
The parameters.
obj (Object)
The object.
Return Value
The return value of the method.


LoadAssembly Method (name)

LoadAssembly Method (name)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► LoadAssembly(String)
Loads an assembly from disk.
Declaration Syntax
C#
public static Assembly LoadAssembly(
    string name
)
Parameters
name (String)
The name.
Return Value
The assembly.


ParseEnum Method (value)

ParseEnum<(Of <(T>)>) Method (value)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► ParseEnum<(Of <(T>)>)(String)
Parses an enum type from a string.
Declaration Syntax
C#
public static T ParseEnum<T>(
    string value
)
where T : struct, new()
Generic Template Parameters
T
Parameters
value (String)
The value.
Return Value


SetField Method (obj, name, value)

SetField Method (obj, name, value)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► SetField(Object, String, Object)
Sets a field on an object.
Declaration Syntax
C#
public static bool SetField(
    Object obj,
    string name,
    Object value
)
Parameters
obj (Object)
The object.
name (String)
The name.
value (Object)
The _value.
Return Value


SetProperties Method

SetProperties Method
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► SetProperties()()()
Members
Icon | Member | Description
 | SetProperties(Object, String) | Sets properties on an object from a list of parameters on the form: p1=value1&p2=value2&...
 | SetProperties(Object, String, Boolean) | Sets properties on an object from a list of parameters on the form: p1=value1&p2=value2&...


SetProperties Method (obj, parameters)

SetProperties Method (obj, parameters)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► SetProperties(Object, String)
Sets properties on an object from a list of parameters on the form: p1=value1&p2=value2&...
Declaration Syntax
C#
public static void SetProperties(
    Object obj,
    string parameters
)
Parameters
obj (Object)
The object.
parameters (String)
The parameters.


SetProperties Method (obj, parameters, ignoreErrors)

SetProperties Method (obj, parameters, ignoreErrors)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► SetProperties(Object, String, Boolean)
Sets properties on an object from a list of parameters on the form: p1=value1&p2=value2&...
Declaration Syntax
C#
public static void SetProperties(
    Object obj,
    string parameters,
    bool ignoreErrors
)
Parameters
obj (Object)
The object.
parameters (String)
The parameters.
ignoreErrors (Boolean)
if set to true this instance is ignore errors.


SetPropertiesFromConfig Method (obj, nodePath, exclude)

SetPropertiesFromConfig Method (obj, nodePath, exclude)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► SetPropertiesFromConfig(Object, String, array<String>[]()[])
Sets the properties from config.
Declaration Syntax
C#
public static void SetPropertiesFromConfig(
    Object obj,
    string nodePath,
    string[] exclude
)
Parameters
obj (Object)
The object.
nodePath (String)
The node path.
exclude (array< String >[]()[])
The exclude.


SetProperty Method

SetProperty Method
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► SetProperty()()()
Members
Icon | Member | Description
 | SetProperty(Object, String, Object) | Sets a property on an object.
 | SetProperty(Object, PropertyInfo, Object) | Sets a property on an object.


SetProperty Method (obj, property, value)

SetProperty Method (obj, property, value)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► SetProperty(Object, PropertyInfo, Object)
Sets a property on an object.
Declaration Syntax
C#
public static void SetProperty(
    Object obj,
    PropertyInfo property,
    Object value
)
Parameters
obj (Object)
The object.
property (PropertyInfo)
The property.
value (Object)
The value.


SetProperty Method (obj, name, value)

SetProperty Method (obj, name, value)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► SetProperty(Object, String, Object)
Sets a property on an object.
Declaration Syntax
C#
public static bool SetProperty(
    Object obj,
    string name,
    Object value
)
Parameters
obj (Object)
The object.
name (String)
The name.
value (Object)
The _value.
Return Value


SetStaticField Method (type, name, value)

SetStaticField Method (type, name, value)
Namespaces ► Sitecore.Reflection ► ReflectionUtil ► SetStaticField(Type, String, Object)
Sets the static field.
Declaration Syntax
C#
public static bool SetStaticField(
    Type type,
    string name,
    Object value
)
Parameters
type (Type)
The type.
name (String)
The name.
value (Object)
The value.
Return Value


TypeUtil Class

TypeUtil Class
Namespaces ► Sitecore.Reflection ► TypeUtil
TypeUtil
Declaration Syntax
C#
public static class TypeUtil
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SizeOfCultureInfo()()() | Gets the standard size of a CultureInfo.
 | SizeOfDictionary()()() | Gets the standard size of a Dictionary<(Of <(TKey, TValue>)>).
 | SizeOfEnum()()() | Gets the standard size of an Enum.
 | SizeOfGuid()()() | Gets the standard size of a Guid.
 | SizeOfHashtable()()() | Size of a hashtable.
 | SizeOfHashtableEntry()()() | Gets the standard size of a Hashtable entry.
 | SizeOfID()()() | Gets the standard size of an ID.
 | SizeOfInt32()()() | Gets the standard size of an Int32.
 | SizeOfInt64()()() | Gets the standard size of a Int64.
 | SizeOfLanguage()()() | Gets the standard size of a Language.
 | SizeOfObject()()() | Gets the standard size of an Object (ie. a pointer).
 | SizeOfString(String) | Gets the standard size of a String.
 | SizeOfString(Int32) | Gets the standard size of a String of a certain length.
 | SizeOfVersion()()() | Gets the standard size of a Version.
 | SizeOfVersionUri()()() | Gets the standard size of a VersionUri.
Inheritance Hierarchy
Object
TypeUtil


SizeOfCultureInfo Method

SizeOfCultureInfo Method
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfCultureInfo()()()
Gets the standard size of a CultureInfo.
Declaration Syntax
C#
public static int SizeOfCultureInfo()
Return Value
The size.


SizeOfDictionary Method

SizeOfDictionary Method
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfDictionary()()()
Gets the standard size of a Dictionary<(Of <(TKey, TValue>)>).
Declaration Syntax
C#
public static int SizeOfDictionary()
Return Value
The size.


SizeOfEnum Method

SizeOfEnum Method
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfEnum()()()
Gets the standard size of an Enum.
Declaration Syntax
C#
public static int SizeOfEnum()
Return Value
The size.


SizeOfGuid Method

SizeOfGuid Method
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfGuid()()()
Gets the standard size of a Guid.
Declaration Syntax
C#
public static int SizeOfGuid()
Return Value
The size.


SizeOfHashtable Method

SizeOfHashtable Method
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfHashtable()()()
Size of a hashtable.
Declaration Syntax
C#
public static int SizeOfHashtable()
Return Value


SizeOfHashtableEntry Method

SizeOfHashtableEntry Method
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfHashtableEntry()()()
Gets the standard size of a Hashtable entry.
Declaration Syntax
C#
public static int SizeOfHashtableEntry()
Return Value
The size.


SizeOfID Method

SizeOfID Method
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfID()()()
Gets the standard size of an ID.
Declaration Syntax
C#
public static int SizeOfID()
Return Value
The size.


SizeOfInt32 Method

SizeOfInt32 Method
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfInt32()()()
Gets the standard size of an Int32.
Declaration Syntax
C#
public static int SizeOfInt32()
Return Value
The size.


SizeOfInt64 Method

SizeOfInt64 Method
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfInt64()()()
Gets the standard size of a Int64.
Declaration Syntax
C#
public static int SizeOfInt64()
Return Value
The size.


SizeOfLanguage Method

SizeOfLanguage Method
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfLanguage()()()
Gets the standard size of a Language.
Declaration Syntax
C#
public static int SizeOfLanguage()
Return Value
The size.


SizeOfObject Method

SizeOfObject Method
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfObject()()()
Gets the standard size of an Object (ie. a pointer).
Declaration Syntax
C#
public static int SizeOfObject()
Return Value
The size.


SizeOfString Method

SizeOfString Method
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfString()()()
Members
Icon | Member | Description
 | SizeOfString(String) | Gets the standard size of a String.
 | SizeOfString(Int32) | Gets the standard size of a String of a certain length.


SizeOfString Method (stringLength)

SizeOfString Method (stringLength)
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfString(Int32)
Gets the standard size of a String of a certain length.
Declaration Syntax
C#
public static int SizeOfString(
    int stringLength
)
Parameters
stringLength (Int32)
Return Value
The size.


SizeOfString Method (value)

SizeOfString Method (value)
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfString(String)
Gets the standard size of a String.
Declaration Syntax
C#
public static int SizeOfString(
    string value
)
Parameters
value (String)
Return Value
The size.


SizeOfVersion Method

SizeOfVersion Method
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfVersion()()()
Gets the standard size of a Version.
Declaration Syntax
C#
public static int SizeOfVersion()
Return Value
The size.


SizeOfVersionUri Method

SizeOfVersionUri Method
Namespaces ► Sitecore.Reflection ► TypeUtil ► SizeOfVersionUri()()()
Gets the standard size of a VersionUri.
Declaration Syntax
C#
public static int SizeOfVersionUri()
Return Value
The size.


Sitecore.Reflection.Emit Namespace

Sitecore.Reflection.Emit Namespace
Namespaces ► Sitecore.Reflection.Emit
Declaration Syntax
C#
namespace Sitecore.Reflection.Emit
Types
All Types Classes
Icon | Type | Description
 | Argument | Represents an Argument.
 | EmitWriter | Represents a EmitWriter.
 | Local | Represents a Local.


Argument Class

Argument Class
Namespaces ► Sitecore.Reflection.Emit ► Argument
Represents an Argument.
Declaration Syntax
C#
public class Argument
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Argument()()() | Initializes a new instance of the Argument class.
 | Argument(Int32) | Initializes a new instance of the Argument class.
 | Argument0 | Gets the argument0.
 | Argument1 | Gets the argument1.
 | Argument2 | Gets the argument2.
 | Argument3 | Gets the argument3.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Index | Gets or sets the index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Argument


Argument Constructor

Argument Constructor
Namespaces ► Sitecore.Reflection.Emit ► Argument ► Argument()()()
Members
Icon | Member | Description
 | Argument()()() | Initializes a new instance of the Argument class.
 | Argument(Int32) | Initializes a new instance of the Argument class.


Argument Constructor

Argument Constructor
Namespaces ► Sitecore.Reflection.Emit ► Argument ► Argument()()()
Initializes a new instance of the Argument class.
Declaration Syntax
C#
public Argument()


Argument Constructor (index)

Argument Constructor (index)
Namespaces ► Sitecore.Reflection.Emit ► Argument ► Argument(Int32)
Initializes a new instance of the Argument class.
Declaration Syntax
C#
public Argument(
    int index
)
Parameters
index (Int32)
The index.


Argument0 Property

Argument0 Property
Namespaces ► Sitecore.Reflection.Emit ► Argument ► Argument0
Gets the argument0.
Declaration Syntax
C#
public static Argument Argument0 { get; }
Value
The argument0.


Argument1 Property

Argument1 Property
Namespaces ► Sitecore.Reflection.Emit ► Argument ► Argument1
Gets the argument1.
Declaration Syntax
C#
public static Argument Argument1 { get; }
Value
The argument1.


Argument2 Property

Argument2 Property
Namespaces ► Sitecore.Reflection.Emit ► Argument ► Argument2
Gets the argument2.
Declaration Syntax
C#
public static Argument Argument2 { get; }
Value
The argument2.


Argument3 Property

Argument3 Property
Namespaces ► Sitecore.Reflection.Emit ► Argument ► Argument3
Gets the argument3.
Declaration Syntax
C#
public static Argument Argument3 { get; }
Value
The argument3.


Index Property

Index Property
Namespaces ► Sitecore.Reflection.Emit ► Argument ► Index
Gets or sets the index.
Declaration Syntax
C#
public int Index { get; set; }
Value
The index.


EmitWriter Class

EmitWriter Class
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter
Represents a EmitWriter.
Declaration Syntax
C#
public class EmitWriter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EmitWriter(ILGenerator) | Initializes a new instance of the EmitWriter class.
 | BranchOnFalse(Label) | Branches on false.
 | BranchOnTrue(Label) | Branches on true.
 | Call(MethodInfo) | Emits the specified opcode.
 | CreateArray(Type) | Creates the array.
 | CreateObject(ConstructorInfo) | Creates the object.
 | CreateObject(NameValueCollection, Local) | Emits the specified collection.
 | CreateObject(List<(Of <(String>)>), Local) | Emits the specified collection.
 | DeclareLocal(Type) | Declares the local.
 | DefineLabel()()() | Declares the local.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ILGenerator | Gets the generator.
 | MarkLabel(Label) | Declares the local.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Pop()()() | Pops.
 | Push(String) | Pushes the string.
 | Push(Int32) | Pushes the integer.
 | Push(Boolean) | Pushes the value.
 | Push(Local) | Pushes the integer.
 | Push(Argument) | Pushes the argument.
 | Push(array<Object>[]()[]) | Pushes the specified parameters.
 | PushNull()()() | Pushes the string.
 | Return()()() | Emits the return.
 | Store(Local) | Stores the in local.
 | StoreAndPush(Local) | Performs a stores and push operation.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
EmitWriter


EmitWriter Constructor (generator)

EmitWriter Constructor (generator)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► EmitWriter(ILGenerator)
Initializes a new instance of the EmitWriter class.
Declaration Syntax
C#
public EmitWriter(
    ILGenerator generator
)
Parameters
generator (ILGenerator)
The generator.


BranchOnFalse Method (label)

BranchOnFalse Method (label)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► BranchOnFalse(Label)
Branches on false.
Declaration Syntax
C#
public void BranchOnFalse(
    Label label
)
Parameters
label (Label)
The label.


BranchOnTrue Method (label)

BranchOnTrue Method (label)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► BranchOnTrue(Label)
Branches on true.
Declaration Syntax
C#
public void BranchOnTrue(
    Label label
)
Parameters
label (Label)
The label.


Call Method (methodInfo)

Call Method (methodInfo)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► Call(MethodInfo)
Emits the specified opcode.
Declaration Syntax
C#
public void Call(
    MethodInfo methodInfo
)
Parameters
methodInfo (MethodInfo)
The method info.


CreateArray Method (type)

CreateArray Method (type)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► CreateArray(Type)
Creates the array.
Declaration Syntax
C#
public void CreateArray(
    Type type
)
Parameters
type (Type)
The type.


CreateObject Method

CreateObject Method
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► CreateObject()()()
Members
Icon | Member | Description
 | CreateObject(ConstructorInfo) | Creates the object.
 | CreateObject(NameValueCollection, Local) | Emits the specified collection.
 | CreateObject(List<(Of <(String>)>), Local) | Emits the specified collection.


CreateObject Method (collection, local)

CreateObject Method (collection, local)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► CreateObject(List<(Of <(String>)>), Local)
Emits the specified collection.
Declaration Syntax
C#
public void CreateObject(
    List<string> collection,
    Local local
)
Parameters
collection (List<(Of <(String>)>))
The collection.
local (Local)
The local.


CreateObject Method (collection, local)

CreateObject Method (collection, local)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► CreateObject(NameValueCollection, Local)
Emits the specified collection.
Declaration Syntax
C#
public void CreateObject(
    NameValueCollection collection,
    Local local
)
Parameters
collection (NameValueCollection)
The collection.
local (Local)
The local.


CreateObject Method (con)

CreateObject Method (con)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► CreateObject(ConstructorInfo)
Creates the object.
Declaration Syntax
C#
public void CreateObject(
    ConstructorInfo con
)
Parameters
con (ConstructorInfo)
The con.


DeclareLocal Method (localType)

DeclareLocal Method (localType)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► DeclareLocal(Type)
Declares the local.
Declaration Syntax
C#
public void DeclareLocal(
    Type localType
)
Parameters
localType (Type)
Type of the loca.


DefineLabel Method

DefineLabel Method
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► DefineLabel()()()
Declares the local.
Declaration Syntax
C#
public Label DefineLabel()
Return Value
The label.


ILGenerator Property

ILGenerator Property
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► ILGenerator
Gets the generator.
Declaration Syntax
C#
public ILGenerator ILGenerator { get; }
Value
The generator.


MarkLabel Method (label)

MarkLabel Method (label)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► MarkLabel(Label)
Declares the local.
Declaration Syntax
C#
public void MarkLabel(
    Label label
)
Parameters
label (Label)
The label.


Pop Method

Pop Method
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► Pop()()()
Pops.
Declaration Syntax
C#
public void Pop()


Push Method

Push Method
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► Push()()()
Members
Icon | Member | Description
 | Push(String) | Pushes the string.
 | Push(Int32) | Pushes the integer.
 | Push(Boolean) | Pushes the value.
 | Push(Local) | Pushes the integer.
 | Push(Argument) | Pushes the argument.
 | Push(array<Object>[]()[]) | Pushes the specified parameters.


Push Method (argument)

Push Method (argument)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► Push(Argument)
Pushes the argument.
Declaration Syntax
C#
public void Push(
    Argument argument
)
Parameters
argument (Argument)
The argument.


Push Method (local)

Push Method (local)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► Push(Local)
Pushes the integer.
Declaration Syntax
C#
public void Push(
    Local local
)
Parameters
local (Local)
The local storage.


Push Method (value)

Push Method (value)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► Push(Boolean)
Pushes the value.
Declaration Syntax
C#
public void Push(
    bool value
)
Parameters
value (Boolean)
The value.


Push Method (value)

Push Method (value)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► Push(Int32)
Pushes the integer.
Declaration Syntax
C#
public void Push(
    int value
)
Parameters
value (Int32)
The value.


Push Method (parameters)

Push Method (parameters)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► Push(array<Object>[]()[])
Pushes the specified parameters.
Declaration Syntax
C#
public void Push(
    params Object[] parameters
)
Parameters
parameters (array< Object >[]()[])
The parameters.
Exceptions
Exception | Condition
Exception | Invalid Parameter.


Push Method (value)

Push Method (value)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► Push(String)
Pushes the string.
Declaration Syntax
C#
public void Push(
    string value
)
Parameters
value (String)
The string.


PushNull Method

PushNull Method
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► PushNull()()()
Pushes the string.
Declaration Syntax
C#
public void PushNull()


Return Method

Return Method
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► Return()()()
Emits the return.
Declaration Syntax
C#
public void Return()


Store Method (local)

Store Method (local)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► Store(Local)
Stores the in local.
Declaration Syntax
C#
public void Store(
    Local local
)
Parameters
local (Local)
The local storage.


StoreAndPush Method (local)

StoreAndPush Method (local)
Namespaces ► Sitecore.Reflection.Emit ► EmitWriter ► StoreAndPush(Local)
Performs a stores and push operation.
Declaration Syntax
C#
public void StoreAndPush(
    Local local
)
Parameters
local (Local)
The local.


Local Class

Local Class
Namespaces ► Sitecore.Reflection.Emit ► Local
Represents a Local.
Declaration Syntax
C#
public class Local
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Local()()() | Initializes a new instance of the Local class.
 | Local(Int32) | Initializes a new instance of the Local class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Index | Gets or sets the index.
 | Local0 | Gets the local0.
 | Local1 | Gets the local1.
 | Local2 | Gets the local2.
 | Local3 | Gets the local3.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Local


Local Constructor

Local Constructor
Namespaces ► Sitecore.Reflection.Emit ► Local ► Local()()()
Members
Icon | Member | Description
 | Local()()() | Initializes a new instance of the Local class.
 | Local(Int32) | Initializes a new instance of the Local class.


Local Constructor

Local Constructor
Namespaces ► Sitecore.Reflection.Emit ► Local ► Local()()()
Initializes a new instance of the Local class.
Declaration Syntax
C#
public Local()


Local Constructor (index)

Local Constructor (index)
Namespaces ► Sitecore.Reflection.Emit ► Local ► Local(Int32)
Initializes a new instance of the Local class.
Declaration Syntax
C#
public Local(
    int index
)
Parameters
index (Int32)
The index.


Index Property

Index Property
Namespaces ► Sitecore.Reflection.Emit ► Local ► Index
Gets or sets the index.
Declaration Syntax
C#
public int Index { get; set; }
Value
The index.


Local0 Property

Local0 Property
Namespaces ► Sitecore.Reflection.Emit ► Local ► Local0
Gets the local0.
Declaration Syntax
C#
public static Local Local0 { get; }
Value
The local0.


Local1 Property

Local1 Property
Namespaces ► Sitecore.Reflection.Emit ► Local ► Local1
Gets the local1.
Declaration Syntax
C#
public static Local Local1 { get; }
Value
The local1.


Local2 Property

Local2 Property
Namespaces ► Sitecore.Reflection.Emit ► Local ► Local2
Gets the local2.
Declaration Syntax
C#
public static Local Local2 { get; }
Value
The local2.


Local3 Property

Local3 Property
Namespaces ► Sitecore.Reflection.Emit ► Local ► Local3
Gets the local3.
Declaration Syntax
C#
public static Local Local3 { get; }
Value
The local3.


Sitecore.Research Namespace

Sitecore.Research Namespace
Namespaces ► Sitecore.Research
Declaration Syntax
C#
namespace Sitecore.Research
Types
All Types Classes
Icon | Type | Description
 | MyControl | Represents a MyControl.
 | MyControlBuilder | Represents a MyControlBuilder.


MyControl Class

MyControl Class
Namespaces ► Sitecore.Research ► MyControl
Represents a MyControl.
Declaration Syntax
C#
public class MyControl : UserControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyControl()()() | Initializes a new instance of the MyControl class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Overrides Control.AddParsedSubObject(Object).)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Overrides Control.CreateChildControls()()().)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Overrides Control.CreateControlCollection()()().)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionState object for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | MyControl
 |  |  |  |  | Testontrol

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


MyControl Constructor

MyControl Constructor
Namespaces ► Sitecore.Research ► MyControl ► MyControl()()()
Initializes a new instance of the MyControl class
Declaration Syntax
C#
public MyControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AddParsedSubObject Method (obj)

AddParsedSubObject Method (obj)
Namespaces ► Sitecore.Research ► MyControl ► AddParsedSubObject(Object)
Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
Declaration Syntax
C#
protected override void AddParsedSubObject(
    Object obj
)
Parameters
obj (Object)
An Object that represents the parsed element.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CreateChildControls Method

CreateChildControls Method
Namespaces ► Sitecore.Research ► MyControl ► CreateChildControls()()()
Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
Declaration Syntax
C#
protected override void CreateChildControls()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CreateControlCollection Method

CreateControlCollection Method
Namespaces ► Sitecore.Research ► MyControl ► CreateControlCollection()()()
Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
Declaration Syntax
C#
protected override ControlCollection CreateControlCollection()
Return Value
A ControlCollection object to contain the current server control's child server controls.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


MyControlBuilder Class

MyControlBuilder Class
Namespaces ► Sitecore.Research ► MyControlBuilder
Represents a MyControlBuilder.
Declaration Syntax
C#
public class MyControlBuilder : FileLevelUserControlBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyControlBuilder()()() | Initializes a new instance of the MyControlBuilder class
 | AllowWhitespaceLiterals()()() | Determines whether white space literals are permitted in the content between a control's opening and closing tags. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
 | AppendLiteralString(String) | Adds the specified literal content to a control. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
 | AppendSubBuilder(ControlBuilder) | Adds builders to the ControlBuilder object for any child controls that belong to the container control. (Inherited from ControlBuilder.)
 | BindingContainerType | Gets the type of the binding container for the control that this builder creates. (Inherited from ControlBuilder.)
 | BuildObject()()() | Used during design time to build the template and its child controls. (Overrides TemplateBuilder.BuildObject()()().)
 | BuiltObjects | Gets a collection of the objects built by the root builder to be persisted. (Inherited from RootBuilder.)
 | CloseControl()()() | Called by the parser to inform the builder that the parsing of the control's opening and closing tags is complete. (Inherited from TemplateBuilder.)
 | ControlType | Gets the Type for the control to be created. (Inherited from ControlBuilder.)
 | CurrentFilterResolutionService | Gets an IFilterResolutionService object that is used to manage device-filter related services when parsing and persisting controls in the designer. (Inherited from ControlBuilder.)
 | DeclareType | Gets the type that will be used by code generation to declare the control. (Inherited from ControlBuilder.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FChildrenAsProperties | Determines whether the control has a ParseChildrenAttribute with ChildrenAsProperties set to true. (Inherited from ControlBuilder.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FIsNonParserAccessor | Determines whether the control implements the IParserAccessor interface. (Inherited from ControlBuilder.)
 | GetChildControlType(String, IDictionary) | Returns the control type of any parsed child controls. (Inherited from RootBuilder.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectPersistData()()() | Creates the ObjectPersistData object for this ControlBuilder object. (Inherited from ControlBuilder.)
 | GetResourceKey()()() | Retrieves the resource key for this ControlBuilder object. (Inherited from ControlBuilder.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAspCode | Gets a value indicating whether the control contains any code blocks. (Inherited from ControlBuilder.)
 | HasBody()()() | Determines if a control has both an opening and closing tag. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
 | HtmlDecodeLiterals()()() | Determines whether the literal string of an HTML control must be HTML decoded. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
 | ID | Gets or sets the identifier property for the control to be built. (Inherited from ControlBuilder.)
 | InDesigner | Returns whether the ControlBuilder is running in the designer. (Inherited from ControlBuilder.)
 | Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary) | Initializes the template builder when a Web request is made. (Overrides TemplateBuilder.Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary).)
 | InPageTheme | Gets a Boolean value indicating whether this ControlBuilder object is used to generate page themes. (Inherited from ControlBuilder.)
 | InstantiateIn(Control) | Defines the Control object that child controls and templates belong to in design time. (Inherited from TemplateBuilder.)
 | Localize | Gets a Boolean value indicating whether the control that is created by this ControlBuilder object is localized. (Inherited from ControlBuilder.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainerType | Gets the type of the naming container for the control that this builder creates. (Inherited from ControlBuilder.)
 | NeedsTagInnerText()()() | Determines if the control builder needs to get its inner text. (Inherited from TemplateBuilder.)
 | OnAppendToParentBuilder(ControlBuilder) | Notifies the ControlBuilder that it is being added to a parent control builder. (Inherited from ControlBuilder.)
 | Parser | Gets the TemplateParser responsible for parsing the control. (Inherited from ControlBuilder.)
 | ProcessGeneratedCode(CodeCompileUnit, CodeTypeDeclaration, CodeTypeDeclaration, CodeMemberMethod, CodeMemberMethod) | Enables custom control builders to access the generated Code Document Object Model (CodeDom) and insert and modify code during the process of parsing and building controls. (Inherited from ControlBuilder.)
 | ServiceProvider | Gets the service object for this ControlBuilder object. (Inherited from ControlBuilder.)
 | SetResourceKey(String) | Sets the resource key for this ControlBuilder object. (Inherited from ControlBuilder.)
 | SetServiceProvider(IServiceProvider) | Sets the service object for this ControlBuilder object. (Inherited from ControlBuilder.)
 | SetTagInnerText(String) | Saves the inner text of the template tag. (Inherited from TemplateBuilder.)
 | TagName | Gets the tag name for the control to be built. (Inherited from ControlBuilder.)
 | Text | Gets or sets the text between the opening and closing tags of the template. (Overrides TemplateBuilder.Text.)
 | ThemeResolutionService | Gets an IThemeResolutionService object that is used in design time to manage control themes and skins. (Inherited from ControlBuilder.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlBuilder
 |  | TemplateBuilder
 |  |  | RootBuilder
 |  |  |  | FileLevelUserControlBuilder
 |  |  |  |  | MyControlBuilder

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


MyControlBuilder Constructor

MyControlBuilder Constructor
Namespaces ► Sitecore.Research ► MyControlBuilder ► MyControlBuilder()()()
Initializes a new instance of the MyControlBuilder class
Declaration Syntax
C#
public MyControlBuilder()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


BuildObject Method

BuildObject Method
Namespaces ► Sitecore.Research ► MyControlBuilder ► BuildObject()()()
Used during design time to build the template and its child controls.
Declaration Syntax
C#
public override Object BuildObject()
Return Value
A reference to the instance of the TemplateBuilder class.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Init Method (parser, parentBuilder, type, tagName, ID, attribs)

Init Method (parser, parentBuilder, type, tagName, ID, attribs)
Namespaces ► Sitecore.Research ► MyControlBuilder ► Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary)
Initializes the template builder when a Web request is made.
Declaration Syntax
C#
public override void Init(
    TemplateParser parser,
    ControlBuilder parentBuilder,
    Type type,
    string tagName,
    string ID,
    IDictionary attribs
)
Parameters
parser (TemplateParser)
The TemplateParser responsible for parsing the control.
parentBuilder (ControlBuilder)
The ControlBuilder responsible for building the control.
type (Type)
The Type assigned to the control that the builder will create.
tagName (String)
The name of the tag to build. This allows the builder to support multiple tag types.
ID (String)
The ID assigned to the control.
attribs (IDictionary)
The IDictionary that holds all the specified tag attributes.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Text Property

Text Property
Namespaces ► Sitecore.Research ► MyControlBuilder ► Text
Gets or sets the text between the opening and closing tags of the template.
Declaration Syntax
C#
public override string Text { get; set; }
Value
Return Value
The text that appears between the opening and closing tags of the template.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Resources Namespace

Sitecore.Resources Namespace
Namespaces ► Sitecore.Resources
Declaration Syntax
C#
namespace Sitecore.Resources
Types
All Types Classes
Icon | Type | Description
 | FileIcon | Extracts an icon from a file.
 | ImageBuilder | Builds image Html tags.
 | Images | Provides methods for building image Html tags.
 | Resource | Creates resources.
 | ResourceContext | Specifies the current resource context.
 | ResourceItems | ResourceItems
 | ResourceUri | Represents an Uri to a resource.
 | Themes | Provides simple theming capabilities.


FileIcon Class

FileIcon Class
Namespaces ► Sitecore.Resources ► FileIcon
Extracts an icon from a file.
Declaration Syntax
C#
public sealed class FileIcon
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtractIcon(String, Int32) | Extracts the icon.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFileIcon(String, ImageDimension) | Gets the file icon.
 | GetFileIcon(String, Int32, Int32, Color) | Gets the icon.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FileIcon


ExtractIcon Method (extension, dimension)

ExtractIcon Method (extension, dimension)
Namespaces ► Sitecore.Resources ► FileIcon ► ExtractIcon(String, Int32)
Extracts the icon.
Declaration Syntax
C#
public static Icon ExtractIcon(
    string extension,
    int dimension
)
Parameters
extension (String)
The extension.
dimension (Int32)
The dimension.
Return Value


GetFileIcon Method

GetFileIcon Method
Namespaces ► Sitecore.Resources ► FileIcon ► GetFileIcon()()()
Members
Icon | Member | Description
 | GetFileIcon(String, ImageDimension) | Gets the file icon.
 | GetFileIcon(String, Int32, Int32, Color) | Gets the icon.


GetFileIcon Method (filename, dimension)

GetFileIcon Method (filename, dimension)
Namespaces ► Sitecore.Resources ► FileIcon ► GetFileIcon(String, ImageDimension)
Gets the file icon.
Declaration Syntax
C#
public static string GetFileIcon(
    string filename,
    ImageDimension dimension
)
Parameters
filename (String)
The filename.
dimension (ImageDimension)
The dimension.
Return Value


GetFileIcon Method (extension, width, height, backgroundColor)

GetFileIcon Method (extension, width, height, backgroundColor)
Namespaces ► Sitecore.Resources ► FileIcon ► GetFileIcon(String, Int32, Int32, Color)
Gets the icon.
Declaration Syntax
C#
public static string GetFileIcon(
    string extension,
    int width,
    int height,
    Color backgroundColor
)
Parameters
extension (String)
The extension.
width (Int32)
The width.
height (Int32)
The height.
backgroundColor (Color)
Color of the background.
Return Value
The file icon.


ImageBuilder Class

ImageBuilder Class
Namespaces ► Sitecore.Resources ► ImageBuilder
Builds image Html tags.
Declaration Syntax
C#
public class ImageBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImageBuilder()()() | Initializes a new instance of the ImageBuilder class.
 | Align | Gets or sets the align.
 | Alt | Gets or sets the alt text.
 | Attributes | Gets the attributes.
 | Border | Gets or sets the border.
 | Class | Gets or sets the class.
 | Disabled | Gets or sets a value indicating whether this ImageBuilder is disabled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Float | Gets or sets the float style.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetThemedSrc()()() | Gets the themed source.
 | GetThemedSrc(Int32, Int32) | Gets the themed source.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Height | Gets or sets the height.
 | ID | Gets or sets the ID.
 | Margin | Gets or sets the margin.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnClick | Gets or sets the click event.
 | OnContextMenu | Gets or sets the oncontextmenu.
 | OnDblClick | Gets or sets the double click event.
 | Overlay | Gets or sets the overlay.
 | Render(HtmlTextWriter) | Renders the image to the specified output.
 | Resize | Gets or sets a value indicating whether the image is resized.
 | ResizeImageSrc(String, Int32, Int32) | Resizes the image source.
 | RollOver | Gets or sets a value indicating whether the image has a roll over effect.
 | SizeRegex | Gets the size regex.
 | Src | Gets or sets the source.
 | Style | Gets or sets the style.
 | Title | Gets or sets the title.
 | ToString(HtmlTextWriter) | Converts the ImageBuilder to a String.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | Width | Gets or sets the width.
Inheritance Hierarchy
Object
ImageBuilder


ImageBuilder Constructor

ImageBuilder Constructor
Namespaces ► Sitecore.Resources ► ImageBuilder ► ImageBuilder()()()
Initializes a new instance of the ImageBuilder class.
Declaration Syntax
C#
public ImageBuilder()


Align Property

Align Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Align
Gets or sets the align.
Declaration Syntax
C#
public string Align { get; set; }
Value
The align.


Alt Property

Alt Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Alt
Gets or sets the alt text.
Declaration Syntax
C#
public string Alt { get; set; }
Value
The alt text.


Attributes Property

Attributes Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Attributes
Gets the attributes.
Declaration Syntax
C#
public NameValueCollection Attributes { get; }
Value
The attributes.


Border Property

Border Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Border
Gets or sets the border.
Declaration Syntax
C#
public string Border { get; set; }
Value
The border.


Class Property

Class Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Class
Gets or sets the class.
Declaration Syntax
C#
public string Class { get; set; }
Value
The class.


Disabled Property

Disabled Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Disabled
Gets or sets a value indicating whether this ImageBuilder is disabled.
Declaration Syntax
C#
public bool Disabled { get; set; }
Value
true if disabled; otherwise, false.


Float Property

Float Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Float
Gets or sets the float style.
Declaration Syntax
C#
public string Float { get; set; }
Value
The float style.


GetThemedSrc Method

GetThemedSrc Method
Namespaces ► Sitecore.Resources ► ImageBuilder ► GetThemedSrc()()()
Members
Icon | Member | Description
 | GetThemedSrc()()() | Gets the themed source.
 | GetThemedSrc(Int32, Int32) | Gets the themed source.


GetThemedSrc Method

GetThemedSrc Method
Namespaces ► Sitecore.Resources ► ImageBuilder ► GetThemedSrc()()()
Gets the themed source.
Declaration Syntax
C#
public string GetThemedSrc()
Return Value


GetThemedSrc Method (width, height)

GetThemedSrc Method (width, height)
Namespaces ► Sitecore.Resources ► ImageBuilder ► GetThemedSrc(Int32, Int32)
Gets the themed source.
Declaration Syntax
C#
public string GetThemedSrc(
    int width,
    int height
)
Parameters
width (Int32)
The width.
height (Int32)
The height.
Return Value


Height Property

Height Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Height
Gets or sets the height.
Declaration Syntax
C#
public int Height { get; set; }
Value
The height.


ID Property

ID Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► ID
Gets or sets the ID.
Declaration Syntax
C#
public string ID { get; set; }
Value
The ID.


Margin Property

Margin Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Margin
Gets or sets the margin.
Declaration Syntax
C#
public string Margin { get; set; }
Value
The margin.


OnClick Property

OnClick Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► OnClick
Gets or sets the click event.
Declaration Syntax
C#
public string OnClick { get; set; }
Value
The click event.


OnContextMenu Property

OnContextMenu Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► OnContextMenu
Gets or sets the oncontextmenu.
Declaration Syntax
C#
public string OnContextMenu { get; set; }
Value
The oncontextmenu.


OnDblClick Property

OnDblClick Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► OnDblClick
Gets or sets the double click event.
Declaration Syntax
C#
public string OnDblClick { get; set; }
Value
The double click event.


Overlay Property

Overlay Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Overlay
Gets or sets the overlay.
Declaration Syntax
C#
public string Overlay { get; set; }
Value
The overlay.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Resources ► ImageBuilder ► Render(HtmlTextWriter)
Renders the image to the specified output.
Declaration Syntax
C#
public void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


Resize Property

Resize Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Resize
Gets or sets a value indicating whether the image is resized.
Declaration Syntax
C#
public bool Resize { get; set; }
Value
true if resized; otherwise, false.


ResizeImageSrc Method (src, width, height)

ResizeImageSrc Method (src, width, height)
Namespaces ► Sitecore.Resources ► ImageBuilder ► ResizeImageSrc(String, Int32, Int32)
Resizes the image source.
Declaration Syntax
C#
public static string ResizeImageSrc(
    string src,
    int width,
    int height
)
Parameters
src (String)
The image source.
width (Int32)
The width.
height (Int32)
The height.
Return Value


RollOver Property

RollOver Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► RollOver
Gets or sets a value indicating whether the image has a roll over effect.
Declaration Syntax
C#
public bool RollOver { get; set; }
Value
true if the image has a roll over effect; otherwise, false.


SizeRegex Property

SizeRegex Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► SizeRegex
Gets the size regex.
Declaration Syntax
C#
public static Regex SizeRegex { get; }
Value
The size regex.


Src Property

Src Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Src
Gets or sets the source.
Declaration Syntax
C#
public string Src { get; set; }
Value
The source.


Style Property

Style Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Style
Gets or sets the style.
Declaration Syntax
C#
public string Style { get; set; }
Value
The style.


Title Property

Title Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Title
Gets or sets the title.
Declaration Syntax
C#
public string Title { get; set; }
Value
The title.


ToString Method

ToString Method
Namespaces ► Sitecore.Resources ► ImageBuilder ► ToString()()()
Members
Icon | Member | Description
 | ToString(HtmlTextWriter) | Converts the ImageBuilder to a String.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)


ToString Method

ToString Method
Namespaces ► Sitecore.Resources ► ImageBuilder ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


ToString Method (writer)

ToString Method (writer)
Namespaces ► Sitecore.Resources ► ImageBuilder ► ToString(HtmlTextWriter)
Converts the ImageBuilder to a String.
Declaration Syntax
C#
public void ToString(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)
The writer.


Width Property

Width Property
Namespaces ► Sitecore.Resources ► ImageBuilder ► Width
Gets or sets the width.
Declaration Syntax
C#
public int Width { get; set; }
Value
The width.


Images Class

Images Class
Namespaces ► Sitecore.Resources ► Images
Provides methods for building image Html tags.
Declaration Syntax
C#
public static class Images
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetImage(String, Int32, Int32) | Gets an Img tag.
 | GetImage(String, Int32, Int32, String) | Gets an Img tag.
 | GetImage(String, Int32, Int32, String, String) | Gets an Img tag.
 | GetImage(String, ImageDimension) | Gets an Img tag.
 | GetImage(String, ImageDimension, String) | Gets an Img tag.
 | GetImage(String, ImageDimension, String, String) | Gets an Img tag.
 | GetImage(String, ImageDimension, String, String, String) | Gets an Img tag.
 | GetImage(String, Int32, Int32, String, String, String) | Gets an Img tag.
 | GetImage(String, Int32, Int32, String, String, String, String, Boolean) | Gets an Img tag.
 | GetSpacer(Int32, Int32) | Gets an image HTML tag with a blank image.
 | GetSpacer(Int32, Int32, Boolean) | Gets an image HTML tag with a blank image.
 | GetThemedImageSource(String) | Gets a themed image path.
 | GetThemedImageSource(String, ImageDimension) | Gets a themed image path.
 | GetUncachedImageSrc(String) | Gets the uncached image src.
Inheritance Hierarchy
Object
Images


GetImage Method

GetImage Method
Namespaces ► Sitecore.Resources ► Images ► GetImage()()()
Members
Icon | Member | Description
 | GetImage(String, Int32, Int32) | Gets an Img tag.
 | GetImage(String, Int32, Int32, String) | Gets an Img tag.
 | GetImage(String, Int32, Int32, String, String) | Gets an Img tag.
 | GetImage(String, ImageDimension) | Gets an Img tag.
 | GetImage(String, ImageDimension, String) | Gets an Img tag.
 | GetImage(String, ImageDimension, String, String) | Gets an Img tag.
 | GetImage(String, ImageDimension, String, String, String) | Gets an Img tag.
 | GetImage(String, Int32, Int32, String, String, String) | Gets an Img tag.
 | GetImage(String, Int32, Int32, String, String, String, String, Boolean) | Gets an Img tag.


GetImage Method (src, dimension)

GetImage Method (src, dimension)
Namespaces ► Sitecore.Resources ► Images ► GetImage(String, ImageDimension)
Gets an Img tag.
Declaration Syntax
C#
public static string GetImage(
    string src,
    ImageDimension dimension
)
Parameters
src (String)
The SRC.
dimension (ImageDimension)
The dimension.
Return Value


GetImage Method (src, dimension, align)

GetImage Method (src, dimension, align)
Namespaces ► Sitecore.Resources ► Images ► GetImage(String, ImageDimension, String)
Gets an Img tag.
Declaration Syntax
C#
public static string GetImage(
    string src,
    ImageDimension dimension,
    string align
)
Parameters
src (String)
The SRC.
dimension (ImageDimension)
The dimension.
align (String)
The align.
Return Value


GetImage Method (src, dimension, align, margin)

GetImage Method (src, dimension, align, margin)
Namespaces ► Sitecore.Resources ► Images ► GetImage(String, ImageDimension, String, String)
Gets an Img tag.
Declaration Syntax
C#
public static string GetImage(
    string src,
    ImageDimension dimension,
    string align,
    string margin
)
Parameters
src (String)
The SRC.
dimension (ImageDimension)
The dimension.
align (String)
The align.
margin (String)
The margin.
Return Value


GetImage Method (src, dimension, align, margin, alt)

GetImage Method (src, dimension, align, margin, alt)
Namespaces ► Sitecore.Resources ► Images ► GetImage(String, ImageDimension, String, String, String)
Gets an Img tag.
Declaration Syntax
C#
public static string GetImage(
    string src,
    ImageDimension dimension,
    string align,
    string margin,
    string alt
)
Parameters
src (String)
The SRC.
dimension (ImageDimension)
The dimension.
align (String)
The align.
margin (String)
The margin.
alt (String)
The alt.
Return Value


GetImage Method (src, width, height)

GetImage Method (src, width, height)
Namespaces ► Sitecore.Resources ► Images ► GetImage(String, Int32, Int32)
Gets an Img tag.
Declaration Syntax
C#
public static string GetImage(
    string src,
    int width,
    int height
)
Parameters
src (String)
The SRC.
width (Int32)
The width.
height (Int32)
The height.
Return Value


GetImage Method (src, width, height, align)

GetImage Method (src, width, height, align)
Namespaces ► Sitecore.Resources ► Images ► GetImage(String, Int32, Int32, String)
Gets an Img tag.
Declaration Syntax
C#
public static string GetImage(
    string src,
    int width,
    int height,
    string align
)
Parameters
src (String)
The SRC.
width (Int32)
The width.
height (Int32)
The height.
align (String)
The align.
Return Value


GetImage Method (src, width, height, align, margin)

GetImage Method (src, width, height, align, margin)
Namespaces ► Sitecore.Resources ► Images ► GetImage(String, Int32, Int32, String, String)
Gets an Img tag.
Declaration Syntax
C#
public static string GetImage(
    string src,
    int width,
    int height,
    string align,
    string margin
)
Parameters
src (String)
The SRC.
width (Int32)
The width.
height (Int32)
The height.
align (String)
The align.
margin (String)
The margin.
Return Value


GetImage Method (src, width, height, align, margin, alt)

GetImage Method (src, width, height, align, margin, alt)
Namespaces ► Sitecore.Resources ► Images ► GetImage(String, Int32, Int32, String, String, String)
Gets an Img tag.
Declaration Syntax
C#
public static string GetImage(
    string src,
    int width,
    int height,
    string align,
    string margin,
    string alt
)
Parameters
src (String)
The SRC.
width (Int32)
The width.
height (Int32)
The height.
align (String)
The align.
margin (String)
The margin.
alt (String)
The alt.
Return Value


GetImage Method (src, width, height, align, margin, alt, id, resize)

GetImage Method (src, width, height, align, margin, alt, id, resize)
Namespaces ► Sitecore.Resources ► Images ► GetImage(String, Int32, Int32, String, String, String, String, Boolean)
Gets an Img tag.
Declaration Syntax
C#
public static string GetImage(
    string src,
    int width,
    int height,
    string align,
    string margin,
    string alt,
    string id,
    bool resize
)
Parameters
src (String)
The SRC.
width (Int32)
The width.
height (Int32)
The height.
align (String)
The align.
margin (String)
The margin.
alt (String)
The alt.
id (String)
The id.
resize (Boolean)
if set to true the image is resized.
Return Value


GetSpacer Method

GetSpacer Method
Namespaces ► Sitecore.Resources ► Images ► GetSpacer()()()
Members
Icon | Member | Description
 | GetSpacer(Int32, Int32) | Gets an image HTML tag with a blank image.
 | GetSpacer(Int32, Int32, Boolean) | Gets an image HTML tag with a blank image.


GetSpacer Method (width, height)

GetSpacer Method (width, height)
Namespaces ► Sitecore.Resources ► Images ► GetSpacer(Int32, Int32)
Gets an image HTML tag with a blank image.
Declaration Syntax
C#
public static string GetSpacer(
    int width,
    int height
)
Parameters
width (Int32)
Width of the image.
height (Int32)
Height of the image.
Return Value
The image HTML tag.
Examples
CopyC#
string spacer = Images.GetSpacer(10, 10); // <img src="/sitecore/images/blank.gif" border="0" height="10" width="10">


GetSpacer Method (width, height, verticalCenter)

GetSpacer Method (width, height, verticalCenter)
Namespaces ► Sitecore.Resources ► Images ► GetSpacer(Int32, Int32, Boolean)
Gets an image HTML tag with a blank image.
Declaration Syntax
C#
public static string GetSpacer(
    int width,
    int height,
    bool verticalCenter
)
Parameters
width (Int32)
Width of the image.
height (Int32)
Height of the image.
verticalCenter (Boolean)
Indicates if the image is centered vertically.
Return Value
The image HTML tag.
Examples
CopyC#
string spacer = Images.GetSpacer(10, 10, true); // <img src="/sitecore/images/blank.gif" border="0" height="10" width="10" style="vertical-align: middle;">


GetThemedImageSource Method

GetThemedImageSource Method
Namespaces ► Sitecore.Resources ► Images ► GetThemedImageSource()()()
Members
Icon | Member | Description
 | GetThemedImageSource(String) | Gets a themed image path.
 | GetThemedImageSource(String, ImageDimension) | Gets a themed image path.


GetThemedImageSource Method (image)

GetThemedImageSource Method (image)
Namespaces ► Sitecore.Resources ► Images ► GetThemedImageSource(String)
Gets a themed image path.
Declaration Syntax
C#
public static string GetThemedImageSource(
    string image
)
Parameters
image (String)
Image file name.
Return Value
A path the the themed image.
Remarks
The function takes in account the current desktop theme.
Examples
CopyC#
string image = MainUtil.GetThemedImageSource("save20x20.png");
// "/sitecore/client/themes/standard/save20x20.png"


GetThemedImageSource Method (image, dimension)

GetThemedImageSource Method (image, dimension)
Namespaces ► Sitecore.Resources ► Images ► GetThemedImageSource(String, ImageDimension)
Gets a themed image path.
Declaration Syntax
C#
public static string GetThemedImageSource(
    string image,
    ImageDimension dimension
)
Parameters
image (String)
Image file name.
dimension (ImageDimension)
Dimensions of the image.
Return Value
A path to the themed image.
Remarks
The function takes in account the current desktop theme. If the name of the image contains a size part, the size part is changed according to the dimensions.
Examples
CopyC#
string image = MainUtil.GetThemedImageSource("save20x20.png", ImageDimension.id32x32);
// "/sitecore/client/themes/standard/save32x32.png"


GetUncachedImageSrc Method (src)

GetUncachedImageSrc Method (src)
Namespaces ► Sitecore.Resources ► Images ► GetUncachedImageSrc(String)
Gets the uncached image src.
Declaration Syntax
C#
public static string GetUncachedImageSrc(
    string src
)
Parameters
src (String)
The path.
Return Value
Remarks
The source attribute is modified with a timestamp.


Resource Class

Resource Class
Namespaces ► Sitecore.Resources ► Resource
Creates resources.
Declaration Syntax
C#
public static class Resource
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetWebControl(String) | Gets the web control.
Inheritance Hierarchy
Object
Resource


GetWebControl Method (name)

GetWebControl Method (name)
Namespaces ► Sitecore.Resources ► Resource ► GetWebControl(String)
Gets the web control.
Declaration Syntax
C#
public static Control GetWebControl(
    string name
)
Parameters
name (String)
The name.
Return Value
The created web control.


ResourceContext Class

ResourceContext Class
Namespaces ► Sitecore.Resources ► ResourceContext
Specifies the current resource context.
Declaration Syntax
C#
public class ResourceContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResourceContext()()() | Initializes a new instance of the ResourceContext class
 | Devices | Gets the devices.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Layouts | Gets the layouts.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Renderings | Gets the renderings.
 | Sublayouts | Gets the sublayouts.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ResourceContext


ResourceContext Constructor

ResourceContext Constructor
Namespaces ► Sitecore.Resources ► ResourceContext ► ResourceContext()()()
Initializes a new instance of the ResourceContext class
Declaration Syntax
C#
public ResourceContext()


Devices Property

Devices Property
Namespaces ► Sitecore.Resources ► ResourceContext ► Devices
Gets the devices.
Declaration Syntax
C#
public DeviceRecords Devices { get; }
Value
The devices.


Layouts Property

Layouts Property
Namespaces ► Sitecore.Resources ► ResourceContext ► Layouts
Gets the layouts.
Declaration Syntax
C#
public LayoutRecords Layouts { get; }
Value
The layouts.


Renderings Property

Renderings Property
Namespaces ► Sitecore.Resources ► ResourceContext ► Renderings
Gets the renderings.
Declaration Syntax
C#
public RenderingRecords Renderings { get; }
Value
The renderings.


Sublayouts Property

Sublayouts Property
Namespaces ► Sitecore.Resources ► ResourceContext ► Sublayouts
Gets the sublayouts.
Declaration Syntax
C#
public SublayoutRecords Sublayouts { get; }
Value
The sublayouts.


ResourceItems Class

ResourceItems Class
Namespaces ► Sitecore.Resources ► ResourceItems
ResourceItems
Declaration Syntax
C#
public class ResourceItems
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResourceItems(Database) | Initializes a new instance of the ResourceItems class.
 | Devices | Gets the devices.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Layouts | Gets the layouts.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Renderings | Gets the renderings.
 | Sublayouts | Gets the sublayouts.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ResourceItems


ResourceItems Constructor (database)

ResourceItems Constructor (database)
Namespaces ► Sitecore.Resources ► ResourceItems ► ResourceItems(Database)
Initializes a new instance of the ResourceItems class.
Declaration Syntax
C#
public ResourceItems(
    Database database
)
Parameters
database (Database)
The database.


Devices Property

Devices Property
Namespaces ► Sitecore.Resources ► ResourceItems ► Devices
Gets the devices.
Declaration Syntax
C#
public DeviceRecords Devices { get; }
Value
The devices.


Layouts Property

Layouts Property
Namespaces ► Sitecore.Resources ► ResourceItems ► Layouts
Gets the layouts.
Declaration Syntax
C#
public LayoutRecords Layouts { get; }
Value
The layouts.


Renderings Property

Renderings Property
Namespaces ► Sitecore.Resources ► ResourceItems ► Renderings
Gets the renderings.
Declaration Syntax
C#
public RenderingRecords Renderings { get; }
Value
The renderings.


Sublayouts Property

Sublayouts Property
Namespaces ► Sitecore.Resources ► ResourceItems ► Sublayouts
Gets the sublayouts.
Declaration Syntax
C#
public SublayoutRecords Sublayouts { get; }
Value
The sublayouts.


ResourceUri Class

ResourceUri Class
Namespaces ► Sitecore.Resources ► ResourceUri
Represents an Uri to a resource.
Declaration Syntax
C#
public class ResourceUri
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResourceUri(String) | Initializes a new instance of the ResourceUri class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsControlUri | Gets a value indicating whether this instance is a control URI.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Parses the specified URI.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | ToUrlString()()() | Converts the Uri to a Url;
 | Uri | Gets the URI.
Inheritance Hierarchy
Object
ResourceUri


ResourceUri Constructor (uri)

ResourceUri Constructor (uri)
Namespaces ► Sitecore.Resources ► ResourceUri ► ResourceUri(String)
Initializes a new instance of the ResourceUri class.
Declaration Syntax
C#
protected ResourceUri(
    string uri
)
Parameters
uri (String)
The path.


IsControlUri Property

IsControlUri Property
Namespaces ► Sitecore.Resources ► ResourceUri ► IsControlUri
Gets a value indicating whether this instance is a control URI.
Declaration Syntax
C#
public bool IsControlUri { get; }
Value
true if this instance is a control URI; otherwise, false.


Parse Method (uri)

Parse Method (uri)
Namespaces ► Sitecore.Resources ► ResourceUri ► Parse(String)
Parses the specified URI.
Declaration Syntax
C#
public static ResourceUri Parse(
    string uri
)
Parameters
uri (String)
The URI.
Return Value
The parse.


ToString Method

ToString Method
Namespaces ► Sitecore.Resources ► ResourceUri ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


ToUrlString Method

ToUrlString Method
Namespaces ► Sitecore.Resources ► ResourceUri ► ToUrlString()()()
Converts the Uri to a Url;
Declaration Syntax
C#
public UrlString ToUrlString()
Return Value
The URL.


Uri Property

Uri Property
Namespaces ► Sitecore.Resources ► ResourceUri ► Uri
Gets the URI.
Declaration Syntax
C#
public string Uri { get; }
Value
The URI.


Themes Class

Themes Class
Namespaces ► Sitecore.Resources ► Themes
Provides simple theming capabilities.
Declaration Syntax
C#
public static class Themes
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Current | Gets or sets the current theme.
 | CurrentPath | Gets the current path.
 | GetCurrentTheme()()() | Gets the current theme.
 | MapTheme(String) | Maps a theme path.
 | MapTheme(String, String, Boolean) | Maps a theme path.
Inheritance Hierarchy
Object
Themes


Current Property

Current Property
Namespaces ► Sitecore.Resources ► Themes ► Current
Gets or sets the current theme.
Declaration Syntax
C#
public static string Current { get; set; }
Value
The current theme.


CurrentPath Property

CurrentPath Property
Namespaces ► Sitecore.Resources ► Themes ► CurrentPath
Gets the current path.
Declaration Syntax
C#
public static string CurrentPath { get; }
Value
The current path.


GetCurrentTheme Method

GetCurrentTheme Method
Namespaces ► Sitecore.Resources ► Themes ► GetCurrentTheme()()()
Gets the current theme.
Declaration Syntax
C#
public static string GetCurrentTheme()
Return Value


MapTheme Method

MapTheme Method
Namespaces ► Sitecore.Resources ► Themes ► MapTheme()()()
Members
Icon | Member | Description
 | MapTheme(String) | Maps a theme path.
 | MapTheme(String, String, Boolean) | Maps a theme path.


MapTheme Method (sourcePath)

MapTheme Method (sourcePath)
Namespaces ► Sitecore.Resources ► Themes ► MapTheme(String)
Maps a theme path.
Declaration Syntax
C#
public static string MapTheme(
    string sourcePath
)
Parameters
sourcePath (String)
The source path.
Return Value
The themed path.


MapTheme Method (sourcePath, overlay, disabled)

MapTheme Method (sourcePath, overlay, disabled)
Namespaces ► Sitecore.Resources ► Themes ► MapTheme(String, String, Boolean)
Maps a theme path.
Declaration Syntax
C#
public static string MapTheme(
    string sourcePath,
    string overlay,
    bool disabled
)
Parameters
sourcePath (String)
The source path.
overlay (String)
The overlay.
disabled (Boolean)
if set to true this instance is disabled.
Return Value
The theme.


Sitecore.Resources.Media Namespace

Sitecore.Resources.Media Namespace
Namespaces ► Sitecore.Resources.Media
Declaration Syntax
C#
namespace Sitecore.Resources.Media
Types
All Types Classes Enumerations
Icon | Type | Description
 | FastMediaCache | Obsolete. FastMediaCache class
 | GetMediaStreamPipelineArgs | GetMediaStreamPipelineArgs class
 | GrayscaleProcessor | GrayscaleProcessor class
 | ImageEffects | ImageEffects class
 | ImageEffectsResize | Represents a ImageEffectsResize.
 | ImageMedia | ImageMedia class
 | ImageThumbnailGenerator | ImageThumbnailCreator class
 | ImageValidator | Represents a Media Validator.
 | JpegMedia | ImageMedia class
 | MacromediaFlash | Parses header of a swf file.
 | Media | Media class
 | MediaCache | MediaCache class
 | MediaCacheRecord | MediaCacheRecord class
 | MediaConfig | MediaConfig class
 | MediaCreator | MediaCreator class
 | MediaCreatorOptions | MediaCreatorOptions class
 | MediaData | MediaData class
 | MediaFactory | Obsolete. Represents the media factory.
 | MediaHeaders | MediaHeaders class
 | MediaManager | MediaManager
 | MediaMetaDataCollection | Represents a collection of Media Meta Data.
 | MediaMetaDataFormatter | Represents a Media Meta Data Formatter.
 | MediaMetaDataFormatterOutput | Represents the output of a Media Meta Data Formatter.
 | MediaOptions | MediaOutputOptions class
 | MediaPathManager | Represents a Media Path.
 | MediaPathProvider | Represents a Media Path.
 | MediaPathProviderCollection | Collection of MediaPathProvider objects
 | MediaProvider | MediaProvider class
 | MediaRequest | MediaRequest class
 | MediaRequestHandler | MediaRequestHandler class
 | MediaStream | MediaStream class
 | MediaStreamInfo | MediaStreamInfo class
 | MediaThumbnailGenerator | ZipThumbnailCreator class
 | MediaTypeConfig | MediaTypeConfig class
 | MediaUploader | Represents a MediaUpload.
 | MediaUploadResult | Represents a MediaUploadResult.
 | MediaUri | MediaUri class
 | MediaUrlOptions | Represents a Media Query String.
 | MediaValidator | Represents a Media Validator.
 | MediaValidatorFormatter | Represents a Media Meta Data Formatter.
 | MediaValidatorFormatterOutput | Defines the output formatting of a Media Validator Formatter.
 | MediaValidatorResult | Represents a collection of Media Meta Data.
 | MimeResolver | MimeResolver class
 | Mp3Media | ImageMedia class
 | ResizeProcessor | ResizeProcessor class
 | SwfMedia | SwfMedia class
 | ThumbnailCreator | Summary description for ThumbnailCreator.
 | ThumbnailGenerator | Represents a Thumbnail Generator.
 | ThumbnailProcessor | ThumbnailProcessor class
 | TransformationOptions | ImageOptions class
 | UploadWatcher | Monitors the /Upload folder for changes for files.
 | ZipMedia | ImageMedia class
 | ZipMetaDataFormatter | Represents a Zip Meta Data Formatter.


FastMediaCache Class

FastMediaCache Class
Namespaces ► Sitecore.Resources.Media ► FastMediaCache
FastMediaCache class
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public class FastMediaCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FastMediaCache(String, String) | Initializes a new instance of the FastMediaCache class.
 | AddFilePath(HttpContext, String) | Add the path of a media file to the cache.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCache(HttpContext) | Gets the cache.
 | GetFilePath(HttpContext) | Gets the path of a cached media file.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MemoryCacheSize | Gets or sets the size of the memory cache.
 | SiteName | Gets or sets the name of the site context to use for default values etc.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UrlPrefix | Gets the URL prefix that the cache responds to.
Inheritance Hierarchy
Object
FastMediaCache


FastMediaCache Constructor (urlPrefix, siteName)

FastMediaCache Constructor (urlPrefix, siteName)
Namespaces ► Sitecore.Resources.Media ► FastMediaCache ► FastMediaCache(String, String)
Initializes a new instance of the FastMediaCache class.
Declaration Syntax
C#
public FastMediaCache(
    string urlPrefix,
    string siteName
)
Parameters
urlPrefix (String)
The URL prefix.
siteName (String)
Name of the site.


AddFilePath Method (context, filePath)

AddFilePath Method (context, filePath)
Namespaces ► Sitecore.Resources.Media ► FastMediaCache ► AddFilePath(HttpContext, String)
Add the path of a media file to the cache.
Declaration Syntax
C#
public virtual void AddFilePath(
    HttpContext context,
    string filePath
)
Parameters
context (HttpContext)
The context.
filePath (String)
Path of the file.


GetCache Method (context)

GetCache Method (context)
Namespaces ► Sitecore.Resources.Media ► FastMediaCache ► GetCache(HttpContext)
Gets the cache.
Declaration Syntax
C#
public static FastMediaCache GetCache(
    HttpContext context
)
Parameters
context (HttpContext)
The context.
Return Value


GetFilePath Method (context)

GetFilePath Method (context)
Namespaces ► Sitecore.Resources.Media ► FastMediaCache ► GetFilePath(HttpContext)
Gets the path of a cached media file.
Declaration Syntax
C#
public virtual string GetFilePath(
    HttpContext context
)
Parameters
context (HttpContext)
The context.
Return Value


MemoryCacheSize Property

MemoryCacheSize Property
Namespaces ► Sitecore.Resources.Media ► FastMediaCache ► MemoryCacheSize
Gets or sets the size of the memory cache.
Declaration Syntax
C#
public string MemoryCacheSize { get; set; }
Value
The size of the memory cache.


SiteName Property

SiteName Property
Namespaces ► Sitecore.Resources.Media ► FastMediaCache ► SiteName
Gets or sets the name of the site context to use for default values etc.
Declaration Syntax
C#
public string SiteName { get; }
Value
The site context.


UrlPrefix Property

UrlPrefix Property
Namespaces ► Sitecore.Resources.Media ► FastMediaCache ► UrlPrefix
Gets the URL prefix that the cache responds to.
Declaration Syntax
C#
public virtual string UrlPrefix { get; }
Value
The URL prefix.


GetMediaStreamPipelineArgs Class

GetMediaStreamPipelineArgs Class
Namespaces ► Sitecore.Resources.Media ► GetMediaStreamPipelineArgs
GetMediaStreamPipelineArgs class
Declaration Syntax
C#
[SerializableAttribute]
public class GetMediaStreamPipelineArgs : PipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMediaStreamPipelineArgs(MediaData, MediaOptions) | Initializes a new instance of the GetMediaStreamPipelineArgs class.
 | GetMediaStreamPipelineArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetMediaStreamPipelineArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | MediaData | Gets or sets the media.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Options | Gets or sets the options.
 | OutputStream | Gets or sets the stream.
 | ProcessorDone()()() | Called when the processor is done. (Inherited from PipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | GetMediaStreamPipelineArgs


GetMediaStreamPipelineArgs Constructor

GetMediaStreamPipelineArgs Constructor
Namespaces ► Sitecore.Resources.Media ► GetMediaStreamPipelineArgs ► GetMediaStreamPipelineArgs()()()
Members
Icon | Member | Description
 | GetMediaStreamPipelineArgs(MediaData, MediaOptions) | Initializes a new instance of the GetMediaStreamPipelineArgs class.
 | GetMediaStreamPipelineArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetMediaStreamPipelineArgs class.


GetMediaStreamPipelineArgs Constructor (mediaData, options)

GetMediaStreamPipelineArgs Constructor (mediaData, options)
Namespaces ► Sitecore.Resources.Media ► GetMediaStreamPipelineArgs ► GetMediaStreamPipelineArgs(MediaData, MediaOptions)
Initializes a new instance of the GetMediaStreamPipelineArgs class.
Declaration Syntax
C#
public GetMediaStreamPipelineArgs(
    MediaData mediaData,
    MediaOptions options
)
Parameters
mediaData (MediaData)
options (MediaOptions)


GetMediaStreamPipelineArgs Constructor (info, context)

GetMediaStreamPipelineArgs Constructor (info, context)
Namespaces ► Sitecore.Resources.Media ► GetMediaStreamPipelineArgs ► GetMediaStreamPipelineArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the GetMediaStreamPipelineArgs class.
Declaration Syntax
C#
protected GetMediaStreamPipelineArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


MediaData Property

MediaData Property
Namespaces ► Sitecore.Resources.Media ► GetMediaStreamPipelineArgs ► MediaData
Gets or sets the media.
Declaration Syntax
C#
public MediaData MediaData { get; set; }
Value
The media.


Options Property

Options Property
Namespaces ► Sitecore.Resources.Media ► GetMediaStreamPipelineArgs ► Options
Gets or sets the options.
Declaration Syntax
C#
public MediaOptions Options { get; set; }
Value
The options.


OutputStream Property

OutputStream Property
Namespaces ► Sitecore.Resources.Media ► GetMediaStreamPipelineArgs ► OutputStream
Gets or sets the stream.
Declaration Syntax
C#
public MediaStream OutputStream { get; set; }
Value
The stream.


GrayscaleProcessor Class

GrayscaleProcessor Class
Namespaces ► Sitecore.Resources.Media ► GrayscaleProcessor
GrayscaleProcessor class
Declaration Syntax
C#
public class GrayscaleProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GrayscaleProcessor()()() | Initializes a new instance of the GrayscaleProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetMediaStreamPipelineArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GrayscaleProcessor


GrayscaleProcessor Constructor

GrayscaleProcessor Constructor
Namespaces ► Sitecore.Resources.Media ► GrayscaleProcessor ► GrayscaleProcessor()()()
Initializes a new instance of the GrayscaleProcessor class
Declaration Syntax
C#
public GrayscaleProcessor()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Resources.Media ► GrayscaleProcessor ► Process(GetMediaStreamPipelineArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    GetMediaStreamPipelineArgs args
)
Parameters
args (GetMediaStreamPipelineArgs)


ImageEffects Class

ImageEffects Class
Namespaces ► Sitecore.Resources.Media ► ImageEffects
ImageEffects class
Declaration Syntax
C#
public class ImageEffects
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ImageEffects()()() | Initializes a new instance of the ImageEffects class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TransformFile(String, TransformationOptions, ImageFormat) | Gets a stream from a file.
 | TransformImageStream(Stream, TransformationOptions, ImageFormat) | Transforms an image stream.
Inheritance Hierarchy
Object
ImageEffects


ImageEffects Constructor

ImageEffects Constructor
Namespaces ► Sitecore.Resources.Media ► ImageEffects ► ImageEffects()()()
Initializes a new instance of the ImageEffects class
Declaration Syntax
C#
public ImageEffects()


TransformFile Method (filePath, options, outputFormat)

TransformFile Method (filePath, options, outputFormat)
Namespaces ► Sitecore.Resources.Media ► ImageEffects ► TransformFile(String, TransformationOptions, ImageFormat)
Gets a stream from a file.
Declaration Syntax
C#
public virtual Stream TransformFile(
    string filePath,
    TransformationOptions options,
    ImageFormat outputFormat
)
Parameters
filePath (String)
The file path.
options (TransformationOptions)
The options.
outputFormat (ImageFormat)
The output format.
Return Value
The file.


TransformImageStream Method (inputStream, options, outputFormat)

TransformImageStream Method (inputStream, options, outputFormat)
Namespaces ► Sitecore.Resources.Media ► ImageEffects ► TransformImageStream(Stream, TransformationOptions, ImageFormat)
Transforms an image stream.
Declaration Syntax
C#
public virtual Stream TransformImageStream(
    Stream inputStream,
    TransformationOptions options,
    ImageFormat outputFormat
)
Parameters
inputStream (Stream)
The stream containing the media data.
options (TransformationOptions)
The image options.
outputFormat (ImageFormat)
The image format of the resulting thumbnail image.
Return Value


ImageEffectsResize Class

ImageEffectsResize Class
Namespaces ► Sitecore.Resources.Media ► ImageEffectsResize
Represents a ImageEffectsResize.
Declaration Syntax
C#
public class ImageEffectsResize
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ImageEffectsResize()()() | Initializes a new instance of the ImageEffectsResize class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResizeImageStream(Stream, TransformationOptions, ImageFormat) | Resizes an image represented by a stream.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ImageEffectsResize


ImageEffectsResize Constructor

ImageEffectsResize Constructor
Namespaces ► Sitecore.Resources.Media ► ImageEffectsResize ► ImageEffectsResize()()()
Initializes a new instance of the ImageEffectsResize class
Declaration Syntax
C#
public ImageEffectsResize()


ResizeImageStream Method (inputStream, options, outputFormat)

ResizeImageStream Method (inputStream, options, outputFormat)
Namespaces ► Sitecore.Resources.Media ► ImageEffectsResize ► ResizeImageStream(Stream, TransformationOptions, ImageFormat)
Resizes an image represented by a stream.
Declaration Syntax
C#
public Stream ResizeImageStream(
    Stream inputStream,
    TransformationOptions options,
    ImageFormat outputFormat
)
Parameters
inputStream (Stream)
The input stream.
options (TransformationOptions)
The options.
outputFormat (ImageFormat)
The output format.
Return Value
The image stream.


ImageMedia Class

ImageMedia Class
Namespaces ► Sitecore.Resources.Media ► ImageMedia
ImageMedia class
Declaration Syntax
C#
public class ImageMedia : Media
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImageMedia()()() | Initializes a new instance of the ImageMedia class
 | AddMetaData(MediaMetaDataCollection) | Adds the meta data to the collection. (Inherited from Media.)
 | ClearFields(array<String>[]()[]) | Clears the specified fields in the inner item. (Inherited from Media.)
 | ClearMetaData()()() | Clears the meta data of a media item. (Overrides Media.ClearMetaData()()().)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides Media.Clone()()().)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extension | Gets the file extension of the media. (Inherited from Media.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetImage()()() | Gets the media data as an image.
 | GetImageStream(Image) | Gets a stream of the data contained in an image.
 | GetMetaData(MediaMetaDataCollection) | Gets the meta data. (Inherited from Media.)
 | GetStream()()() | Opens the stream associated with the media. (Inherited from Media.)
 | GetStream(MediaOptions) | Opens the stream associated with the media. (Inherited from Media.)
 | GetStreamFromPipeline(MediaOptions) | Gets the stream from the pipeline 'getMediaStream'. (Inherited from Media.)
 | GetThumbnailStream()()() | Gets a thumbnail for the media. (Inherited from Media.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(MediaData) | Initializes this instance. Used after cloning. (Inherited from Media.)
 | MediaData | Gets the media data. (Inherited from Media.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MimeType | Gets the MIME type of the media. (Inherited from Media.)
 | ReleaseStream()()() | Releases the stream. (Inherited from Media.)
 | SetImage(Image) | Sets the media data from an image.
 | SetStream(MediaStream) | Opens the stream associated with the media. (Inherited from Media.)
 | SetStream(Stream, String) | Sets the stream. (Inherited from Media.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateMetaData(MediaStream) | Updates the meta data of a media item. (Overrides Media.UpdateMetaData(MediaStream).)
Inheritance Hierarchy
Object
 | Media
 |  | ImageMedia
 |  |  | JpegMedia


ImageMedia Constructor

ImageMedia Constructor
Namespaces ► Sitecore.Resources.Media ► ImageMedia ► ImageMedia()()()
Initializes a new instance of the ImageMedia class
Declaration Syntax
C#
public ImageMedia()


ClearMetaData Method

ClearMetaData Method
Namespaces ► Sitecore.Resources.Media ► ImageMedia ► ClearMetaData()()()
Clears the meta data of a media item.
Declaration Syntax
C#
protected override void ClearMetaData()


Clone Method

Clone Method
Namespaces ► Sitecore.Resources.Media ► ImageMedia ► Clone()()()
Clones the source object. Has the same effect as creating a new instance of the type.
Declaration Syntax
C#
public override Media Clone()
Return Value


GetImage Method

GetImage Method
Namespaces ► Sitecore.Resources.Media ► ImageMedia ► GetImage()()()
Gets the media data as an image.
Declaration Syntax
C#
public virtual Image GetImage()
Return Value


GetImageStream Method (image)

GetImageStream Method (image)
Namespaces ► Sitecore.Resources.Media ► ImageMedia ► GetImageStream(Image)
Gets a stream of the data contained in an image.
Declaration Syntax
C#
protected virtual MediaStream GetImageStream(
    Image image
)
Parameters
image (Image)
The image.
Return Value


SetImage Method (image)

SetImage Method (image)
Namespaces ► Sitecore.Resources.Media ► ImageMedia ► SetImage(Image)
Sets the media data from an image.
Declaration Syntax
C#
public virtual void SetImage(
    Image image
)
Parameters
image (Image)
The image.


UpdateMetaData Method (mediaStream)

UpdateMetaData Method (mediaStream)
Namespaces ► Sitecore.Resources.Media ► ImageMedia ► UpdateMetaData(MediaStream)
Updates the meta data of a media item.
Declaration Syntax
C#
protected override void UpdateMetaData(
    MediaStream mediaStream
)
Parameters
mediaStream (MediaStream)


ImageThumbnailGenerator Class

ImageThumbnailGenerator Class
Namespaces ► Sitecore.Resources.Media ► ImageThumbnailGenerator
ImageThumbnailCreator class
Declaration Syntax
C#
public class ImageThumbnailGenerator : ThumbnailGenerator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImageThumbnailGenerator()()() | Initializes a new instance of the ImageThumbnailGenerator class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extension | Gets or sets the file extension describing the format of the thumbnail. (Inherited from ThumbnailGenerator.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFileStream(String, TransformationOptions) | Gets a stream from a file. (Inherited from ThumbnailGenerator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetImageFormat()()() | Gets the image format to use for generating streams. (Inherited from ThumbnailGenerator.)
 | GetImageStream(Stream, TransformationOptions) | Gets a stream from an image stream. (Inherited from ThumbnailGenerator.)
 | GetStream(MediaData, TransformationOptions) | Gets the stream of the thumbnail image. (Overrides ThumbnailGenerator.GetStream(MediaData, TransformationOptions).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MimeType | Gets the MIME type of the generated thumbnails. (Inherited from ThumbnailGenerator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ThumbnailGenerator
 |  | ImageThumbnailGenerator


ImageThumbnailGenerator Constructor

ImageThumbnailGenerator Constructor
Namespaces ► Sitecore.Resources.Media ► ImageThumbnailGenerator ► ImageThumbnailGenerator()()()
Initializes a new instance of the ImageThumbnailGenerator class
Declaration Syntax
C#
public ImageThumbnailGenerator()


GetStream Method (mediaData, options)

GetStream Method (mediaData, options)
Namespaces ► Sitecore.Resources.Media ► ImageThumbnailGenerator ► GetStream(MediaData, TransformationOptions)
Gets the stream of the thumbnail image.
Declaration Syntax
C#
public override MediaStream GetStream(
    MediaData mediaData,
    TransformationOptions options
)
Parameters
mediaData (MediaData)
The media data to generate a thumbnail for.
options (TransformationOptions)
Return Value


ImageValidator Class

ImageValidator Class
Namespaces ► Sitecore.Resources.Media ► ImageValidator
Represents a Media Validator.
Declaration Syntax
C#
public class ImageValidator : MediaValidator
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ImageValidator()()() | Initializes a new instance of the ImageValidator class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Validate(MediaItem, MediaValidatorResult) | Validates the specified item. (Inherited from MediaValidator.)
 | ValidateItem(MediaItem, MediaValidatorResult) | Validates the specified output. (Overrides MediaValidator.ValidateItem(MediaItem, MediaValidatorResult).)
Inheritance Hierarchy
Object
 | MediaValidator
 |  | ImageValidator


ImageValidator Constructor

ImageValidator Constructor
Namespaces ► Sitecore.Resources.Media ► ImageValidator ► ImageValidator()()()
Initializes a new instance of the ImageValidator class
Declaration Syntax
C#
public ImageValidator()


ValidateItem Method (item, results)

ValidateItem Method (item, results)
Namespaces ► Sitecore.Resources.Media ► ImageValidator ► ValidateItem(MediaItem, MediaValidatorResult)
Validates the specified output.
Declaration Syntax
C#
protected override void ValidateItem(
    MediaItem item,
    MediaValidatorResult results
)
Parameters
item (MediaItem)
The item.
results (MediaValidatorResult)
The warnings.


JpegMedia Class

JpegMedia Class
Namespaces ► Sitecore.Resources.Media ► JpegMedia
ImageMedia class
Declaration Syntax
C#
public class JpegMedia : ImageMedia
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JpegMedia()()() | Initializes a new instance of the JpegMedia class
 | AddMetaData(MediaMetaDataCollection) | Adds the meta data to the collection. (Inherited from Media.)
 | ClearFields(array<String>[]()[]) | Clears the specified fields in the inner item. (Inherited from Media.)
 | ClearMetaData()()() | Clears the meta data of a media item. (Overrides ImageMedia.ClearMetaData()()().)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides ImageMedia.Clone()()().)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extension | Gets the file extension of the media. (Inherited from Media.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetImage()()() | Gets the media data as an image. (Inherited from ImageMedia.)
 | GetImageStream(Image) | Gets a stream of the data contained in an image. (Inherited from ImageMedia.)
 | GetMetaData(MediaMetaDataCollection) | Gets the meta data. (Inherited from Media.)
 | GetStream()()() | Opens the stream associated with the media. (Inherited from Media.)
 | GetStream(MediaOptions) | Opens the stream associated with the media. (Inherited from Media.)
 | GetStreamFromPipeline(MediaOptions) | Gets the stream from the pipeline 'getMediaStream'. (Inherited from Media.)
 | GetThumbnailStream()()() | Gets a thumbnail for the media. (Inherited from Media.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(MediaData) | Initializes this instance. Used after cloning. (Inherited from Media.)
 | MediaData | Gets the media data. (Inherited from Media.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MimeType | Gets the MIME type of the media. (Inherited from Media.)
 | ReleaseStream()()() | Releases the stream. (Inherited from Media.)
 | SetImage(Image) | Sets the media data from an image. (Inherited from ImageMedia.)
 | SetStream(MediaStream) | Opens the stream associated with the media. (Inherited from Media.)
 | SetStream(Stream, String) | Sets the stream. (Inherited from Media.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateMetaData(MediaStream) | Updates the meta data of a media item. (Overrides ImageMedia.UpdateMetaData(MediaStream).)
Inheritance Hierarchy
Object
 | Media
 |  | ImageMedia
 |  |  | JpegMedia


JpegMedia Constructor

JpegMedia Constructor
Namespaces ► Sitecore.Resources.Media ► JpegMedia ► JpegMedia()()()
Initializes a new instance of the JpegMedia class
Declaration Syntax
C#
public JpegMedia()


ClearMetaData Method

ClearMetaData Method
Namespaces ► Sitecore.Resources.Media ► JpegMedia ► ClearMetaData()()()
Clears the meta data of a media item.
Declaration Syntax
C#
protected override void ClearMetaData()


Clone Method

Clone Method
Namespaces ► Sitecore.Resources.Media ► JpegMedia ► Clone()()()
Clones the source object. Has the same effect as creating a new instance of the type.
Declaration Syntax
C#
public override Media Clone()
Return Value


UpdateMetaData Method (mediaStream)

UpdateMetaData Method (mediaStream)
Namespaces ► Sitecore.Resources.Media ► JpegMedia ► UpdateMetaData(MediaStream)
Updates the meta data of a media item.
Declaration Syntax
C#
protected override void UpdateMetaData(
    MediaStream mediaStream
)
Parameters
mediaStream (MediaStream)


MacromediaFlash Class

MacromediaFlash Class
Namespaces ► Sitecore.Resources.Media ► MacromediaFlash
Parses header of a swf file.
Declaration Syntax
C#
public class MacromediaFlash
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileLength | Gets the length of the file.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FlashVersion | Gets the flash version.
 | FrameCount | Gets the frame count.
 | FrameRate | Gets the frame rate.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Height | Gets the height.
 | LoadData(Stream) | Loads the data.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Signature | Gets the signature.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Width | Gets the width.
Inheritance Hierarchy
Object
MacromediaFlash


FileLength Property

FileLength Property
Namespaces ► Sitecore.Resources.Media ► MacromediaFlash ► FileLength
Gets the length of the file.
Declaration Syntax
C#
public int FileLength { get; }
Value
The length of the file.


FlashVersion Property

FlashVersion Property
Namespaces ► Sitecore.Resources.Media ► MacromediaFlash ► FlashVersion
Gets the flash version.
Declaration Syntax
C#
public int FlashVersion { get; }
Value
The flash version.


FrameCount Property

FrameCount Property
Namespaces ► Sitecore.Resources.Media ► MacromediaFlash ► FrameCount
Gets the frame count.
Declaration Syntax
C#
public int FrameCount { get; }
Value
The frame count.


FrameRate Property

FrameRate Property
Namespaces ► Sitecore.Resources.Media ► MacromediaFlash ► FrameRate
Gets the frame rate.
Declaration Syntax
C#
public float FrameRate { get; }
Value
The frame rate.


Height Property

Height Property
Namespaces ► Sitecore.Resources.Media ► MacromediaFlash ► Height
Gets the height.
Declaration Syntax
C#
public int Height { get; }
Value
The height.


LoadData Method (stream)

LoadData Method (stream)
Namespaces ► Sitecore.Resources.Media ► MacromediaFlash ► LoadData(Stream)
Loads the data.
Declaration Syntax
C#
public static MacromediaFlash LoadData(
    Stream stream
)
Parameters
stream (Stream)
The stream.


Signature Property

Signature Property
Namespaces ► Sitecore.Resources.Media ► MacromediaFlash ► Signature
Gets the signature.
Declaration Syntax
C#
public string Signature { get; }
Value
The signature.


Width Property

Width Property
Namespaces ► Sitecore.Resources.Media ► MacromediaFlash ► Width
Gets the width.
Declaration Syntax
C#
public int Width { get; }
Value
The width.


Media Class

Media Class
Namespaces ► Sitecore.Resources.Media ► Media
Media class
Declaration Syntax
C#
public class Media : IPrototype<Media>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Media()()() | Initializes a new instance of the Media class.
 | Media(MediaData) | Initializes a new instance of the Media class.
 | AddMetaData(MediaMetaDataCollection) | Adds the meta data to the collection.
 | ClearFields(array<String>[]()[]) | Clears the specified fields in the inner item.
 | ClearMetaData()()() | Clears the meta data of a media item.
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the type.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extension | Gets the file extension of the media.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GET_STREAM_PIPELINE_NAME |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMetaData(MediaMetaDataCollection) | Gets the meta data.
 | GetStream()()() | Opens the stream associated with the media.
 | GetStream(MediaOptions) | Opens the stream associated with the media.
 | GetStreamFromPipeline(MediaOptions) | Gets the stream from the pipeline 'getMediaStream'.
 | GetThumbnailStream()()() | Gets a thumbnail for the media.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(MediaData) | Initializes this instance. Used after cloning.
 | MediaData | Gets the media data.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MimeType | Gets the MIME type of the media.
 | ReleaseStream()()() | Releases the stream.
 | SetStream(MediaStream) | Opens the stream associated with the media.
 | SetStream(Stream, String) | Sets the stream.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateMetaData(MediaStream) | Updates the meta data of a media item.
Inheritance Hierarchy
Object
 | Media
 |  | ImageMedia
 |  | Mp3Media
 |  | SwfMedia
 |  | ZipMedia


Media Constructor

Media Constructor
Namespaces ► Sitecore.Resources.Media ► Media ► Media()()()
Members
Icon | Member | Description
 | Media()()() | Initializes a new instance of the Media class.
 | Media(MediaData) | Initializes a new instance of the Media class.


Media Constructor

Media Constructor
Namespaces ► Sitecore.Resources.Media ► Media ► Media()()()
Initializes a new instance of the Media class.
Declaration Syntax
C#
public Media()
Remarks
For internal use only.


Media Constructor (mediaData)

Media Constructor (mediaData)
Namespaces ► Sitecore.Resources.Media ► Media ► Media(MediaData)
Initializes a new instance of the Media class.
Declaration Syntax
C#
public Media(
    MediaData mediaData
)
Parameters
mediaData (MediaData)
The media data.


AddMetaData Method (metaData)

AddMetaData Method (metaData)
Namespaces ► Sitecore.Resources.Media ► Media ► AddMetaData(MediaMetaDataCollection)
Adds the meta data to the collection.
Declaration Syntax
C#
protected virtual void AddMetaData(
    MediaMetaDataCollection metaData
)
Parameters
metaData (MediaMetaDataCollection)
The meta data.


ClearFields Method (fieldNames)

ClearFields Method (fieldNames)
Namespaces ► Sitecore.Resources.Media ► Media ► ClearFields(array<String>[]()[])
Clears the specified fields in the inner item.
Declaration Syntax
C#
protected void ClearFields(
    params string[] fieldNames
)
Parameters
fieldNames (array< String >[]()[])
The field names.


ClearMetaData Method

ClearMetaData Method
Namespaces ► Sitecore.Resources.Media ► Media ► ClearMetaData()()()
Clears the meta data of a media item.
Declaration Syntax
C#
protected virtual void ClearMetaData()


Clone Method

Clone Method
Namespaces ► Sitecore.Resources.Media ► Media ► Clone()()()
Clones the source object. Has the same effect as creating a new instance of the type.
Declaration Syntax
C#
public virtual Media Clone()
Return Value


Extension Property

Extension Property
Namespaces ► Sitecore.Resources.Media ► Media ► Extension
Gets the file extension of the media.
Declaration Syntax
C#
public virtual string Extension { get; }
Value
The extension.


GET_STREAM_PIPELINE_NAME Field

GET_STREAM_PIPELINE_NAME Field
Namespaces ► Sitecore.Resources.Media ► Media ► GET_STREAM_PIPELINE_NAME
Declaration Syntax
C#
protected const string GET_STREAM_PIPELINE_NAME


GetMetaData Method (metaData)

GetMetaData Method (metaData)
Namespaces ► Sitecore.Resources.Media ► Media ► GetMetaData(MediaMetaDataCollection)
Gets the meta data.
Declaration Syntax
C#
public virtual void GetMetaData(
    MediaMetaDataCollection metaData
)
Parameters
metaData (MediaMetaDataCollection)
The meta data.


GetStream Method

GetStream Method
Namespaces ► Sitecore.Resources.Media ► Media ► GetStream()()()
Members
Icon | Member | Description
 | GetStream()()() | Opens the stream associated with the media.
 | GetStream(MediaOptions) | Opens the stream associated with the media.


GetStream Method

GetStream Method
Namespaces ► Sitecore.Resources.Media ► Media ► GetStream()()()
Opens the stream associated with the media.
Declaration Syntax
C#
public virtual MediaStream GetStream()
Return Value


GetStream Method (options)

GetStream Method (options)
Namespaces ► Sitecore.Resources.Media ► Media ► GetStream(MediaOptions)
Opens the stream associated with the media.
Declaration Syntax
C#
public virtual MediaStream GetStream(
    MediaOptions options
)
Parameters
options (MediaOptions)
Return Value


GetStreamFromPipeline Method (options)

GetStreamFromPipeline Method (options)
Namespaces ► Sitecore.Resources.Media ► Media ► GetStreamFromPipeline(MediaOptions)
Gets the stream from the pipeline 'getMediaStream'.
Declaration Syntax
C#
protected virtual MediaStream GetStreamFromPipeline(
    MediaOptions options
)
Parameters
options (MediaOptions)
The options.
Return Value


GetThumbnailStream Method

GetThumbnailStream Method
Namespaces ► Sitecore.Resources.Media ► Media ► GetThumbnailStream()()()
Gets a thumbnail for the media.
Declaration Syntax
C#
public virtual MediaStream GetThumbnailStream()
Return Value


Initialize Method (mediaData)

Initialize Method (mediaData)
Namespaces ► Sitecore.Resources.Media ► Media ► Initialize(MediaData)
Initializes this instance. Used after cloning.
Declaration Syntax
C#
public virtual void Initialize(
    MediaData mediaData
)
Parameters
mediaData (MediaData)


MediaData Property

MediaData Property
Namespaces ► Sitecore.Resources.Media ► Media ► MediaData
Gets the media data.
Declaration Syntax
C#
public virtual MediaData MediaData { get; }
Value
The media data.


MimeType Property

MimeType Property
Namespaces ► Sitecore.Resources.Media ► Media ► MimeType
Gets the MIME type of the media.
Declaration Syntax
C#
public virtual string MimeType { get; }
Value
The type of the MIME.


ReleaseStream Method

ReleaseStream Method
Namespaces ► Sitecore.Resources.Media ► Media ► ReleaseStream()()()
Releases the stream.
Declaration Syntax
C#
public virtual void ReleaseStream()


SetStream Method

SetStream Method
Namespaces ► Sitecore.Resources.Media ► Media ► SetStream()()()
Members
Icon | Member | Description
 | SetStream(MediaStream) | Opens the stream associated with the media.
 | SetStream(Stream, String) | Sets the stream.


SetStream Method (mediaStream)

SetStream Method (mediaStream)
Namespaces ► Sitecore.Resources.Media ► Media ► SetStream(MediaStream)
Opens the stream associated with the media.
Declaration Syntax
C#
public virtual void SetStream(
    MediaStream mediaStream
)
Parameters
mediaStream (MediaStream)
Return Value


SetStream Method (stream, extension)

SetStream Method (stream, extension)
Namespaces ► Sitecore.Resources.Media ► Media ► SetStream(Stream, String)
Sets the stream.
Declaration Syntax
C#
public virtual void SetStream(
    Stream stream,
    string extension
)
Parameters
stream (Stream)
The stream.
extension (String)
The extension.


UpdateMetaData Method (mediaStream)

UpdateMetaData Method (mediaStream)
Namespaces ► Sitecore.Resources.Media ► Media ► UpdateMetaData(MediaStream)
Updates the meta data of a media item.
Declaration Syntax
C#
protected virtual void UpdateMetaData(
    MediaStream mediaStream
)
Parameters
mediaStream (MediaStream)


MediaCache Class

MediaCache Class
Namespaces ► Sitecore.Resources.Media ► MediaCache
MediaCache class
Declaration Syntax
C#
public class MediaCache
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaCache()()() | Initializes a new instance of the MediaCache class
 | Active | Gets or sets a value indicating whether this MediaCache is active.
 | AddStream(Media, MediaOptions, MediaStream, MediaStream%) | Adds a stream to the cache.
 | CanCache(Media, MediaOptions) | Determines whether the specified media can be cached.
 | Contains(Media, MediaOptions) | Checks if the cache contains a specific media instance.
 | CreateCacheRecord(Media, MediaOptions, MediaStream) | Creates a cache record for a media instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCacheRecord(Media, MediaOptions) | Gets the cache record.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStream(Media, MediaOptions) | Gets a stream from the cache.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseActiveList | Gets a value indicating whether to use the active list.
Inheritance Hierarchy
Object
MediaCache


MediaCache Constructor

MediaCache Constructor
Namespaces ► Sitecore.Resources.Media ► MediaCache ► MediaCache()()()
Initializes a new instance of the MediaCache class
Declaration Syntax
C#
public MediaCache()


Active Property

Active Property
Namespaces ► Sitecore.Resources.Media ► MediaCache ► Active
Gets or sets a value indicating whether this MediaCache is active.
Declaration Syntax
C#
public virtual bool Active { get; set; }
Value
true if active; otherwise, false.


AddStream Method (media, options, stream, cachedStream)

AddStream Method (media, options, stream, cachedStream)
Namespaces ► Sitecore.Resources.Media ► MediaCache ► AddStream(Media, MediaOptions, MediaStream, MediaStream%)
Adds a stream to the cache.
Declaration Syntax
C#
public virtual bool AddStream(
    Media media,
    MediaOptions options,
    MediaStream stream,
    out MediaStream cachedStream
)
Parameters
media (Media)
The media.
options (MediaOptions)
The options.
stream (MediaStream)
The stream.
cachedStream ( MediaStream %)
The cached stream (null if the stream was not cached).
Return Value
true if the stream was added to the ase; false otherwise.
Remarks

Note that if the stream is succesfully cached, the cache will take ownership of the stream.

Therefore, the caller must not perform any more operations on the stream and must not close it either.

The caller should use the returned cachedStream instead.


CanCache Method (media, options)

CanCache Method (media, options)
Namespaces ► Sitecore.Resources.Media ► MediaCache ► CanCache(Media, MediaOptions)
Determines whether the specified media can be cached.
Declaration Syntax
C#
protected virtual bool CanCache(
    Media media,
    MediaOptions options
)
Parameters
media (Media)
The media.
options (MediaOptions)
The options.
Return Value
true if this instance can cache the specified media; otherwise, false.


Contains Method (media, options)

Contains Method (media, options)
Namespaces ► Sitecore.Resources.Media ► MediaCache ► Contains(Media, MediaOptions)
Checks if the cache contains a specific media instance.
Declaration Syntax
C#
public virtual bool Contains(
    Media media,
    MediaOptions options
)
Parameters
media (Media)
The media.
options (MediaOptions)
The options.
Return Value


CreateCacheRecord Method (media, options, stream)

CreateCacheRecord Method (media, options, stream)
Namespaces ► Sitecore.Resources.Media ► MediaCache ► CreateCacheRecord(Media, MediaOptions, MediaStream)
Creates a cache record for a media instance.
Declaration Syntax
C#
protected virtual MediaCacheRecord CreateCacheRecord(
    Media media,
    MediaOptions options,
    MediaStream stream
)
Parameters
media (Media)
The media.
options (MediaOptions)
The options.
stream (MediaStream)
The stream.
Return Value


GetCacheRecord Method (media, options)

GetCacheRecord Method (media, options)
Namespaces ► Sitecore.Resources.Media ► MediaCache ► GetCacheRecord(Media, MediaOptions)
Gets the cache record.
Declaration Syntax
C#
protected virtual MediaCacheRecord GetCacheRecord(
    Media media,
    MediaOptions options
)
Parameters
media (Media)
The media.
options (MediaOptions)
The options.
Return Value


GetStream Method (media, options)

GetStream Method (media, options)
Namespaces ► Sitecore.Resources.Media ► MediaCache ► GetStream(Media, MediaOptions)
Gets a stream from the cache.
Declaration Syntax
C#
public virtual MediaStream GetStream(
    Media media,
    MediaOptions options
)
Parameters
media (Media)
The media.
options (MediaOptions)
The options.
Return Value


UseActiveList Property

UseActiveList Property
Namespaces ► Sitecore.Resources.Media ► MediaCache ► UseActiveList
Gets a value indicating whether to use the active list.
Declaration Syntax
C#
public virtual bool UseActiveList { get; }
Value
true if the active list should be used; otherwise, false.
See Also
StreamPartiallyCachedFiles


MediaCacheRecord Class

MediaCacheRecord Class
Namespaces ► Sitecore.Resources.Media ► MediaCacheRecord
MediaCacheRecord class
Declaration Syntax
C#
public class MediaCacheRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaCacheRecord(Media, MediaOptions, MediaStream) | Initializes a new instance of the MediaCacheRecord class.
 | MediaCacheRecord(Media, MediaOptions) | Initializes a new instance of the MediaCacheRecord class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStream()()() | Gets the stream associated with the cache record.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasStream | Gets a value indicating whether this record has access to a stream.
 | Media | Gets the media.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Options | Gets the options.
 | Persist()()() | Persists the cache record.
 | PersistAsync(Action) | Persists the cache record asynchronously.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MediaCacheRecord


MediaCacheRecord Constructor

MediaCacheRecord Constructor
Namespaces ► Sitecore.Resources.Media ► MediaCacheRecord ► MediaCacheRecord()()()
Members
Icon | Member | Description
 | MediaCacheRecord(Media, MediaOptions, MediaStream) | Initializes a new instance of the MediaCacheRecord class.
 | MediaCacheRecord(Media, MediaOptions) | Initializes a new instance of the MediaCacheRecord class.


MediaCacheRecord Constructor (media, options)

MediaCacheRecord Constructor (media, options)
Namespaces ► Sitecore.Resources.Media ► MediaCacheRecord ► MediaCacheRecord(Media, MediaOptions)
Initializes a new instance of the MediaCacheRecord class.
Declaration Syntax
C#
public MediaCacheRecord(
    Media media,
    MediaOptions options
)
Parameters
media (Media)
The media.
options (MediaOptions)
The options.


MediaCacheRecord Constructor (media, options, stream)

MediaCacheRecord Constructor (media, options, stream)
Namespaces ► Sitecore.Resources.Media ► MediaCacheRecord ► MediaCacheRecord(Media, MediaOptions, MediaStream)
Initializes a new instance of the MediaCacheRecord class.
Declaration Syntax
C#
public MediaCacheRecord(
    Media media,
    MediaOptions options,
    MediaStream stream
)
Parameters
media (Media)
The media.
options (MediaOptions)
The options.
stream (MediaStream)
The stream to cache.


GetStream Method

GetStream Method
Namespaces ► Sitecore.Resources.Media ► MediaCacheRecord ► GetStream()()()
Gets the stream associated with the cache record.
Declaration Syntax
C#
public MediaStream GetStream()
Return Value


HasStream Property

HasStream Property
Namespaces ► Sitecore.Resources.Media ► MediaCacheRecord ► HasStream
Gets a value indicating whether this record has access to a stream.
Declaration Syntax
C#
public bool HasStream { get; }
Value
true if this instance has a stream; otherwise, false.


Media Property

Media Property
Namespaces ► Sitecore.Resources.Media ► MediaCacheRecord ► Media
Gets the media.
Declaration Syntax
C#
public Media Media { get; }
Value
The media.


Options Property

Options Property
Namespaces ► Sitecore.Resources.Media ► MediaCacheRecord ► Options
Gets the options.
Declaration Syntax
C#
public MediaOptions Options { get; }
Value
The options.


Persist Method

Persist Method
Namespaces ► Sitecore.Resources.Media ► MediaCacheRecord ► Persist()()()
Persists the cache record.
Declaration Syntax
C#
public void Persist()


PersistAsync Method (completedHandler)

PersistAsync Method (completedHandler)
Namespaces ► Sitecore.Resources.Media ► MediaCacheRecord ► PersistAsync(Action)
Persists the cache record asynchronously.
Declaration Syntax
C#
public void PersistAsync(
    Action completedHandler
)
Parameters
completedHandler (Action)


MediaConfig Class

MediaConfig Class
Namespaces ► Sitecore.Resources.Media ► MediaConfig
MediaConfig class
Declaration Syntax
C#
public class MediaConfig
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaConfig()()() | Initializes a new instance of the MediaConfig class.
 | MediaConfig(XmlNode) | Initializes a new instance of the MediaConfig class.
 | ConstructMediaDataInstance(MediaItem) | Constructs an instance of the MediaData class.
 | ConstructMediaInstance(MediaData) | Constructs an instance of the Media class.
 | ConstructMediaRequestInstance(HttpRequest) | Constructs an instance of the MediaRequest class.
 | DefaultImageFormat | Gets the default image format.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetForceDownload(String) | Gets the force download flag for a file extension.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetImageFormat(String, ImageFormat) | Gets the image format for a specific extension.
 | GetImageFormat(String) | Gets the image format for a specific extension.
 | GetMediaDataPrototype(String) | Gets the media data prototype for a specific extension.
 | GetMediaPrototype(String) | Gets the media prototype for a specific extension.
 | GetMediaTypeConfig(String) | Gets the config for a specific media type.
 | GetMediaValidator(String) | Gets the media validator.
 | GetMetaDataFormatter(String) | Gets the meta data formatter.
 | GetMimeType(String) | Gets the MIME type of an extension.
 | GetTemplate(String, Boolean) | Gets the name (or id) of the template to use when creating items for a specific extension.
 | GetThumbnailBackgroundColor(String) | Gets the color of the thumbnail background.
 | GetThumbnailGenerator(String) | Gets a thumbnail generator for a specific extension.
 | GetThumbnailSize(String) | Gets the default thumbnail size for a specific extension.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUrlExtension(String) | Gets the extension to use in URLs.
 | Initialize(XmlNode) | Initializes the members from an XML fragment.
 | MediaRequestPrototype | Gets the type of the request parser.
 | MediaTypes | Gets the registered media types.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MediaConfig


MediaConfig Constructor

MediaConfig Constructor
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► MediaConfig()()()
Members
Icon | Member | Description
 | MediaConfig()()() | Initializes a new instance of the MediaConfig class.
 | MediaConfig(XmlNode) | Initializes a new instance of the MediaConfig class.


MediaConfig Constructor

MediaConfig Constructor
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► MediaConfig()()()
Initializes a new instance of the MediaConfig class.
Declaration Syntax
C#
public MediaConfig()


MediaConfig Constructor (configNode)

MediaConfig Constructor (configNode)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► MediaConfig(XmlNode)
Initializes a new instance of the MediaConfig class.
Declaration Syntax
C#
public MediaConfig(
    XmlNode configNode
)
Parameters
configNode (XmlNode)


ConstructMediaDataInstance Method (mediaItem)

ConstructMediaDataInstance Method (mediaItem)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► ConstructMediaDataInstance(MediaItem)
Constructs an instance of the MediaData class.
Declaration Syntax
C#
public virtual MediaData ConstructMediaDataInstance(
    MediaItem mediaItem
)
Parameters
mediaItem (MediaItem)
The item needed by the MediaData constructor.
Return Value


ConstructMediaInstance Method (mediaData)

ConstructMediaInstance Method (mediaData)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► ConstructMediaInstance(MediaData)
Constructs an instance of the Media class.
Declaration Syntax
C#
public virtual Media ConstructMediaInstance(
    MediaData mediaData
)
Parameters
mediaData (MediaData)
The media data needed by the Media constructor.
Return Value


ConstructMediaRequestInstance Method (httpRequest)

ConstructMediaRequestInstance Method (httpRequest)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► ConstructMediaRequestInstance(HttpRequest)
Constructs an instance of the MediaRequest class.
Declaration Syntax
C#
public virtual MediaRequest ConstructMediaRequestInstance(
    HttpRequest httpRequest
)
Parameters
httpRequest (HttpRequest)
The request data needed by the MediaRequest constructor.
Return Value


DefaultImageFormat Property

DefaultImageFormat Property
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► DefaultImageFormat
Gets the default image format.
Declaration Syntax
C#
protected virtual ImageFormat DefaultImageFormat { get; }
Value
The default image format.


GetForceDownload Method (extension)

GetForceDownload Method (extension)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetForceDownload(String)
Gets the force download flag for a file extension.
Declaration Syntax
C#
public Tristate GetForceDownload(
    string extension
)
Parameters
extension (String)
The extension.
Return Value


GetImageFormat Method

GetImageFormat Method
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetImageFormat()()()
Members
Icon | Member | Description
 | GetImageFormat(String, ImageFormat) | Gets the image format for a specific extension.
 | GetImageFormat(String) | Gets the image format for a specific extension.


GetImageFormat Method (extension)

GetImageFormat Method (extension)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetImageFormat(String)
Gets the image format for a specific extension.
Declaration Syntax
C#
public virtual ImageFormat GetImageFormat(
    string extension
)
Parameters
extension (String)
The file extension describing the media.
Return Value


GetImageFormat Method (extension, defaultValue)

GetImageFormat Method (extension, defaultValue)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetImageFormat(String, ImageFormat)
Gets the image format for a specific extension.
Declaration Syntax
C#
public virtual ImageFormat GetImageFormat(
    string extension,
    ImageFormat defaultValue
)
Parameters
extension (String)
The file extension describing the media.
defaultValue (ImageFormat)
The default value.
Return Value


GetMediaDataPrototype Method (extension)

GetMediaDataPrototype Method (extension)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetMediaDataPrototype(String)
Gets the media data prototype for a specific extension.
Declaration Syntax
C#
public virtual IPrototype<MediaData> GetMediaDataPrototype(
    string extension
)
Parameters
extension (String)
The extension.
Return Value


GetMediaPrototype Method (extension)

GetMediaPrototype Method (extension)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetMediaPrototype(String)
Gets the media prototype for a specific extension.
Declaration Syntax
C#
public virtual IPrototype<Media> GetMediaPrototype(
    string extension
)
Parameters
extension (String)
The extension.
Return Value


GetMediaTypeConfig Method (extension)

GetMediaTypeConfig Method (extension)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetMediaTypeConfig(String)
Gets the config for a specific media type.
Declaration Syntax
C#
public virtual MediaTypeConfig GetMediaTypeConfig(
    string extension
)
Parameters
extension (String)
The 'file' extension identifying the media.
Return Value


GetMediaValidator Method (extension)

GetMediaValidator Method (extension)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetMediaValidator(String)
Gets the media validator.
Declaration Syntax
C#
public MediaValidator GetMediaValidator(
    string extension
)
Parameters
extension (String)
The extension.
Return Value
The media validator.


GetMetaDataFormatter Method (extension)

GetMetaDataFormatter Method (extension)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetMetaDataFormatter(String)
Gets the meta data formatter.
Declaration Syntax
C#
public MediaMetaDataFormatter GetMetaDataFormatter(
    string extension
)
Parameters
extension (String)
The extension.
Return Value
The meta data formatter.


GetMimeType Method (extension)

GetMimeType Method (extension)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetMimeType(String)
Gets the MIME type of an extension.
Declaration Syntax
C#
public virtual string GetMimeType(
    string extension
)
Parameters
extension (String)
The extension.
Return Value


GetTemplate Method (extension, versioned)

GetTemplate Method (extension, versioned)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetTemplate(String, Boolean)
Gets the name (or id) of the template to use when creating items for a specific extension.
Declaration Syntax
C#
public virtual string GetTemplate(
    string extension,
    bool versioned
)
Parameters
extension (String)
The extension.
versioned (Boolean)
if set to true this instance is versioned.
Return Value
The template.


GetThumbnailBackgroundColor Method (extension)

GetThumbnailBackgroundColor Method (extension)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetThumbnailBackgroundColor(String)
Gets the color of the thumbnail background.
Declaration Syntax
C#
public Color GetThumbnailBackgroundColor(
    string extension
)
Parameters
extension (String)
The extension.
Return Value


GetThumbnailGenerator Method (extension)

GetThumbnailGenerator Method (extension)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetThumbnailGenerator(String)
Gets a thumbnail generator for a specific extension.
Declaration Syntax
C#
public virtual ThumbnailGenerator GetThumbnailGenerator(
    string extension
)
Parameters
extension (String)
The extension.
Return Value


GetThumbnailSize Method (extension)

GetThumbnailSize Method (extension)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetThumbnailSize(String)
Gets the default thumbnail size for a specific extension.
Declaration Syntax
C#
public virtual Size GetThumbnailSize(
    string extension
)
Parameters
extension (String)
The extension.
Return Value


GetUrlExtension Method (extension)

GetUrlExtension Method (extension)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► GetUrlExtension(String)
Gets the extension to use in URLs.
Declaration Syntax
C#
public virtual string GetUrlExtension(
    string extension
)
Parameters
extension (String)
The extension.
Return Value


Initialize Method (configNode)

Initialize Method (configNode)
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► Initialize(XmlNode)
Initializes the members from an XML fragment.
Declaration Syntax
C#
protected virtual void Initialize(
    XmlNode configNode
)
Parameters
configNode (XmlNode)
The root node of the configuration fragment.


MediaRequestPrototype Property

MediaRequestPrototype Property
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► MediaRequestPrototype
Gets the type of the request parser.
Declaration Syntax
C#
public virtual IPrototype<MediaRequest> MediaRequestPrototype { get; set; }
Value
The type of the request parser.
Remarks
This type must represent a class derived from MediaRequest.


MediaTypes Property

MediaTypes Property
Namespaces ► Sitecore.Resources.Media ► MediaConfig ► MediaTypes
Gets the registered media types.
Declaration Syntax
C#
public SafeDictionary<string, MediaTypeConfig> MediaTypes { get; }
Value
The media types.


MediaCreator Class

MediaCreator Class
Namespaces ► Sitecore.Resources.Media ► MediaCreator
MediaCreator class
Declaration Syntax
C#
public class MediaCreator
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaCreator()()() | Initializes a new instance of the MediaCreator class
 | CreateFolder(String, MediaCreatorOptions) | Creates a media folder in the content database.
 | CreateFromFile(String, MediaCreatorOptions) | Creates a new media item from a file.
 | CreateFromFolder(String, MediaCreatorOptions) | Creates a media folder from a file system folder.
 | CreateFromStream(Stream, String, MediaCreatorOptions) | Creates the media from a file.
 | CreateItem(String, String, MediaCreatorOptions) | Creates a media item in the content database.
 | DefaultSite |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileCreated(String) | A new file has been created.
 | FileDeleted(String) | A file has been deleted.
 | FileRenamed(String, String) | A file has been renamed.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemPath(String, MediaCreatorOptions) | Gets the item path corresponding to a file.
 | GetMediaStorageFolder(ID, String) | Gets private folder for media blob inside the Media.FileFolder.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MediaCreator


MediaCreator Constructor

MediaCreator Constructor
Namespaces ► Sitecore.Resources.Media ► MediaCreator ► MediaCreator()()()
Initializes a new instance of the MediaCreator class
Declaration Syntax
C#
public MediaCreator()


CreateFolder Method (itemPath, options)

CreateFolder Method (itemPath, options)
Namespaces ► Sitecore.Resources.Media ► MediaCreator ► CreateFolder(String, MediaCreatorOptions)
Creates a media folder in the content database.
Declaration Syntax
C#
protected virtual Item CreateFolder(
    string itemPath,
    MediaCreatorOptions options
)
Parameters
itemPath (String)
The item path.
options (MediaCreatorOptions)
The options.
Return Value


CreateFromFile Method (filePath, options)

CreateFromFile Method (filePath, options)
Namespaces ► Sitecore.Resources.Media ► MediaCreator ► CreateFromFile(String, MediaCreatorOptions)
Creates a new media item from a file.
Declaration Syntax
C#
public virtual MediaItem CreateFromFile(
    string filePath,
    MediaCreatorOptions options
)
Parameters
filePath (String)
The file path.
options (MediaCreatorOptions)
The options.
Return Value


CreateFromFolder Method (folderPath, options)

CreateFromFolder Method (folderPath, options)
Namespaces ► Sitecore.Resources.Media ► MediaCreator ► CreateFromFolder(String, MediaCreatorOptions)
Creates a media folder from a file system folder.
Declaration Syntax
C#
public virtual Item CreateFromFolder(
    string folderPath,
    MediaCreatorOptions options
)
Parameters
folderPath (String)
The folder path.
options (MediaCreatorOptions)
The options.
Return Value


CreateFromStream Method (stream, filePath, options)

CreateFromStream Method (stream, filePath, options)
Namespaces ► Sitecore.Resources.Media ► MediaCreator ► CreateFromStream(Stream, String, MediaCreatorOptions)
Creates the media from a file.
Declaration Syntax
C#
public virtual Item CreateFromStream(
    Stream stream,
    string filePath,
    MediaCreatorOptions options
)
Parameters
stream (Stream)
The stream.
filePath (String)
The file path.
options (MediaCreatorOptions)
The options.
Return Value


CreateItem Method (itemPath, filePath, options)

CreateItem Method (itemPath, filePath, options)
Namespaces ► Sitecore.Resources.Media ► MediaCreator ► CreateItem(String, String, MediaCreatorOptions)
Creates a media item in the content database.
Declaration Syntax
C#
protected virtual Item CreateItem(
    string itemPath,
    string filePath,
    MediaCreatorOptions options
)
Parameters
itemPath (String)
The item path.
filePath (String)
The file path.
options (MediaCreatorOptions)
The options.
Return Value


DefaultSite Field

DefaultSite Field
Namespaces ► Sitecore.Resources.Media ► MediaCreator ► DefaultSite
Declaration Syntax
C#
protected const string DefaultSite


FileCreated Method (filePath)

FileCreated Method (filePath)
Namespaces ► Sitecore.Resources.Media ► MediaCreator ► FileCreated(String)
A new file has been created.
Declaration Syntax
C#
public virtual void FileCreated(
    string filePath
)
Parameters
filePath (String)
The full path to the file.


FileDeleted Method (filePath)

FileDeleted Method (filePath)
Namespaces ► Sitecore.Resources.Media ► MediaCreator ► FileDeleted(String)
A file has been deleted.
Declaration Syntax
C#
public virtual void FileDeleted(
    string filePath
)
Parameters
filePath (String)
The full path to the file.


FileRenamed Method (filePath, oldFilePath)

FileRenamed Method (filePath, oldFilePath)
Namespaces ► Sitecore.Resources.Media ► MediaCreator ► FileRenamed(String, String)
A file has been renamed.
Declaration Syntax
C#
public virtual void FileRenamed(
    string filePath,
    string oldFilePath
)
Parameters
filePath (String)
The path to the file.
oldFilePath (String)
The old path to the file.


GetItemPath Method (filePath, options)

GetItemPath Method (filePath, options)
Namespaces ► Sitecore.Resources.Media ► MediaCreator ► GetItemPath(String, MediaCreatorOptions)
Gets the item path corresponding to a file.
Declaration Syntax
C#
public virtual string GetItemPath(
    string filePath,
    MediaCreatorOptions options
)
Parameters
filePath (String)
The file path.
options (MediaCreatorOptions)
The options.
Return Value
The item path.


GetMediaStorageFolder Method (itemID, fullPath)

GetMediaStorageFolder Method (itemID, fullPath)
Namespaces ► Sitecore.Resources.Media ► MediaCreator ► GetMediaStorageFolder(ID, String)
Gets private folder for media blob inside the Media.FileFolder.
Declaration Syntax
C#
protected virtual string GetMediaStorageFolder(
    ID itemID,
    string fullPath
)
Parameters
itemID (ID)
The item ID.
fullPath (String)
The full path.
Return Value
The short folder.


MediaCreatorOptions Class

MediaCreatorOptions Class
Namespaces ► Sitecore.Resources.Media ► MediaCreatorOptions
MediaCreatorOptions class
Declaration Syntax
C#
public class MediaCreatorOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaCreatorOptions()()() | Initializes a new instance of the MediaCreatorOptions class
 | AlternateText | Gets or sets the alternate text.
 | Database | Gets or sets the database.
 | Destination | Gets or sets the destination in the Sitecore tree.
 | Empty | Gets or sets the empty options.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileBased | Gets or sets a value indicating whether to create file based media.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IncludeExtensionInItemName | Gets or sets a value indicating whether to include a file extension when generating an item name from a file name.
 | KeepExisting | Gets or sets a value indicating whether to keep any existing items.
 | Language | Gets or sets the language of the item to create.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OutputFilePath | Gets or sets the file path to use for file based media.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Versioned | Gets or sets a value indicating whether to create an item with versioned media data.
Inheritance Hierarchy
Object
MediaCreatorOptions


MediaCreatorOptions Constructor

MediaCreatorOptions Constructor
Namespaces ► Sitecore.Resources.Media ► MediaCreatorOptions ► MediaCreatorOptions()()()
Initializes a new instance of the MediaCreatorOptions class
Declaration Syntax
C#
public MediaCreatorOptions()


AlternateText Property

AlternateText Property
Namespaces ► Sitecore.Resources.Media ► MediaCreatorOptions ► AlternateText
Gets or sets the alternate text.
Declaration Syntax
C#
public string AlternateText { get; set; }
Value
The alternate text.


Database Property

Database Property
Namespaces ► Sitecore.Resources.Media ► MediaCreatorOptions ► Database
Gets or sets the database.
Declaration Syntax
C#
public Database Database { get; set; }
Value
The database.


Destination Property

Destination Property
Namespaces ► Sitecore.Resources.Media ► MediaCreatorOptions ► Destination
Gets or sets the destination in the Sitecore tree.
Declaration Syntax
C#
public virtual string Destination { get; set; }
Value
The destination.


Empty Property

Empty Property
Namespaces ► Sitecore.Resources.Media ► MediaCreatorOptions ► Empty
Gets or sets the empty options.
Declaration Syntax
C#
public static MediaCreatorOptions Empty { get; set; }
Value
The empty.


FileBased Property

FileBased Property
Namespaces ► Sitecore.Resources.Media ► MediaCreatorOptions ► FileBased
Gets or sets a value indicating whether to create file based media.
Declaration Syntax
C#
public bool FileBased { get; set; }
Value
true if file based; otherwise, false.


IncludeExtensionInItemName Property

IncludeExtensionInItemName Property
Namespaces ► Sitecore.Resources.Media ► MediaCreatorOptions ► IncludeExtensionInItemName
Gets or sets a value indicating whether to include a file extension when generating an item name from a file name.
Declaration Syntax
C#
public virtual bool IncludeExtensionInItemName { get; set; }
Value
true if extansion should be included; otherwise, false.


KeepExisting Property

KeepExisting Property
Namespaces ► Sitecore.Resources.Media ► MediaCreatorOptions ► KeepExisting
Gets or sets a value indicating whether to keep any existing items.
Declaration Syntax
C#
public virtual bool KeepExisting { get; set; }
Value
true if overwrite; otherwise, false.
Remarks
If this property is false (default), existing items with the same path as the item being created will be overwritten.


Language Property

Language Property
Namespaces ► Sitecore.Resources.Media ► MediaCreatorOptions ► Language
Gets or sets the language of the item to create.
Declaration Syntax
C#
public virtual Language Language { get; set; }
Value
The language.


OutputFilePath Property

OutputFilePath Property
Namespaces ► Sitecore.Resources.Media ► MediaCreatorOptions ► OutputFilePath
Gets or sets the file path to use for file based media.
Declaration Syntax
C#
public string OutputFilePath { get; set; }
Value
The file path.


Versioned Property

Versioned Property
Namespaces ► Sitecore.Resources.Media ► MediaCreatorOptions ► Versioned
Gets or sets a value indicating whether to create an item with versioned media data.
Declaration Syntax
C#
public virtual bool Versioned { get; set; }
Value
true if versioned; otherwise, false.


MediaData Class

MediaData Class
Namespaces ► Sitecore.Resources.Media ► MediaData
MediaData class
Declaration Syntax
C#
public class MediaData : IPrototype<MediaData>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaData()()() | Initializes a new instance of the MediaData class.
 | MediaData(MediaItem) | Initializes a new instance of the MediaData class.
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the type.
 | DataFieldName | Gets or sets the name of the field holding the media data.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extension | Gets the 'file' extension of the media data.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBlobStream()()() | Gets a stream from the BLOB data.
 | GetFileStream()()() | Gets a stream from a file.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStream()()() | Gets the media data as a stream.
 | GetThumbnailStream()()() | Gets a thumbnail for the media.
 | GetThumbnailStream(TransformationOptions) | Gets the thumbnail stream for the media.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasContent | Gets a value indicating whether this instance has any content.
 | Initialize(MediaItem) | Initializes this instance. Used after cloning.
 | IsValidFilePath(String) | Determines whether the specified path is a valid file path for media item.
 | MediaId | Gets a string that uniquely identifies this media instance.
 | MediaItem | Gets the media item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MimeType | Gets the MIME type of the media data.
 | ReleaseStream()()() | Releases the stream.
 | SetBlobStream(MediaStream) | Sets the stream using the BLOB field.
 | SetFileStream(MediaStream) | Sets the stream using a file.
 | SetStream(MediaStream) | Sets the media data from a stream.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Updated | Gets the time of the latest update.
Inheritance Hierarchy
Object
MediaData


MediaData Constructor

MediaData Constructor
Namespaces ► Sitecore.Resources.Media ► MediaData ► MediaData()()()
Members
Icon | Member | Description
 | MediaData()()() | Initializes a new instance of the MediaData class.
 | MediaData(MediaItem) | Initializes a new instance of the MediaData class.


MediaData Constructor

MediaData Constructor
Namespaces ► Sitecore.Resources.Media ► MediaData ► MediaData()()()
Initializes a new instance of the MediaData class.
Declaration Syntax
C#
public MediaData()
Remarks
Use for prototyping only.


MediaData Constructor (mediaItem)

MediaData Constructor (mediaItem)
Namespaces ► Sitecore.Resources.Media ► MediaData ► MediaData(MediaItem)
Initializes a new instance of the MediaData class.
Declaration Syntax
C#
public MediaData(
    MediaItem mediaItem
)
Parameters
mediaItem (MediaItem)


Clone Method

Clone Method
Namespaces ► Sitecore.Resources.Media ► MediaData ► Clone()()()
Clones the source object. Has the same effect as creating a new instance of the type.
Declaration Syntax
C#
public virtual MediaData Clone()
Return Value


DataFieldName Property

DataFieldName Property
Namespaces ► Sitecore.Resources.Media ► MediaData ► DataFieldName
Gets or sets the name of the field holding the media data.
Declaration Syntax
C#
public virtual string DataFieldName { get; set; }
Value
The name of the data field.


Extension Property

Extension Property
Namespaces ► Sitecore.Resources.Media ► MediaData ► Extension
Gets the 'file' extension of the media data.
Declaration Syntax
C#
public virtual string Extension { get; }
Value
The extension.


GetBlobStream Method

GetBlobStream Method
Namespaces ► Sitecore.Resources.Media ► MediaData ► GetBlobStream()()()
Gets a stream from the BLOB data.
Declaration Syntax
C#
protected virtual MediaStream GetBlobStream()
Return Value


GetFileStream Method

GetFileStream Method
Namespaces ► Sitecore.Resources.Media ► MediaData ► GetFileStream()()()
Gets a stream from a file.
Declaration Syntax
C#
protected virtual MediaStream GetFileStream()
Return Value


GetStream Method

GetStream Method
Namespaces ► Sitecore.Resources.Media ► MediaData ► GetStream()()()
Gets the media data as a stream.
Declaration Syntax
C#
public virtual MediaStream GetStream()
Return Value


GetThumbnailStream Method

GetThumbnailStream Method
Namespaces ► Sitecore.Resources.Media ► MediaData ► GetThumbnailStream()()()
Members
Icon | Member | Description
 | GetThumbnailStream()()() | Gets a thumbnail for the media.
 | GetThumbnailStream(TransformationOptions) | Gets the thumbnail stream for the media.


GetThumbnailStream Method

GetThumbnailStream Method
Namespaces ► Sitecore.Resources.Media ► MediaData ► GetThumbnailStream()()()
Gets a thumbnail for the media.
Declaration Syntax
C#
public virtual MediaStream GetThumbnailStream()
Return Value


GetThumbnailStream Method (options)

GetThumbnailStream Method (options)
Namespaces ► Sitecore.Resources.Media ► MediaData ► GetThumbnailStream(TransformationOptions)
Gets the thumbnail stream for the media.
Declaration Syntax
C#
public virtual MediaStream GetThumbnailStream(
    TransformationOptions options
)
Parameters
options (TransformationOptions)
Return Value


HasContent Property

HasContent Property
Namespaces ► Sitecore.Resources.Media ► MediaData ► HasContent
Gets a value indicating whether this instance has any content.
Declaration Syntax
C#
public virtual bool HasContent { get; }
Value
true if this instance has content; otherwise, false.


Initialize Method (mediaItem)

Initialize Method (mediaItem)
Namespaces ► Sitecore.Resources.Media ► MediaData ► Initialize(MediaItem)
Initializes this instance. Used after cloning.
Declaration Syntax
C#
public virtual void Initialize(
    MediaItem mediaItem
)
Parameters
mediaItem (MediaItem)


IsValidFilePath Method (filePath)

IsValidFilePath Method (filePath)
Namespaces ► Sitecore.Resources.Media ► MediaData ► IsValidFilePath(String)
Determines whether the specified path is a valid file path for media item.
Declaration Syntax
C#
protected virtual bool IsValidFilePath(
    string filePath
)
Parameters
filePath (String)
The path.
Return Value
true if the specified path is valid file path; otherwise, false.


MediaId Property

MediaId Property
Namespaces ► Sitecore.Resources.Media ► MediaData ► MediaId
Gets a string that uniquely identifies this media instance.
Declaration Syntax
C#
public virtual string MediaId { get; }
Value
The media id.
Remarks

The id must not contain the following characters: \ / : * ? " < > |

Also, the id must not be more than 100 characters in length.

If it is not possible to produce an id, Empty()()() may be returned. This may stop media caching from working, however.


MediaItem Property

MediaItem Property
Namespaces ► Sitecore.Resources.Media ► MediaData ► MediaItem
Gets the media item.
Declaration Syntax
C#
public virtual MediaItem MediaItem { get; }
Value
The media item.


MimeType Property

MimeType Property
Namespaces ► Sitecore.Resources.Media ► MediaData ► MimeType
Gets the MIME type of the media data.
Declaration Syntax
C#
public virtual string MimeType { get; }
Value
The MIME type.


ReleaseStream Method

ReleaseStream Method
Namespaces ► Sitecore.Resources.Media ► MediaData ► ReleaseStream()()()
Releases the stream.
Declaration Syntax
C#
public virtual void ReleaseStream()


SetBlobStream Method (mediaStream)

SetBlobStream Method (mediaStream)
Namespaces ► Sitecore.Resources.Media ► MediaData ► SetBlobStream(MediaStream)
Sets the stream using the BLOB field.
Declaration Syntax
C#
protected virtual void SetBlobStream(
    MediaStream mediaStream
)
Parameters
mediaStream (MediaStream)
The media stream.


SetFileStream Method (mediaStream)

SetFileStream Method (mediaStream)
Namespaces ► Sitecore.Resources.Media ► MediaData ► SetFileStream(MediaStream)
Sets the stream using a file.
Declaration Syntax
C#
protected virtual void SetFileStream(
    MediaStream mediaStream
)
Parameters
mediaStream (MediaStream)
The media stream.


SetStream Method (mediaStream)

SetStream Method (mediaStream)
Namespaces ► Sitecore.Resources.Media ► MediaData ► SetStream(MediaStream)
Sets the media data from a stream.
Declaration Syntax
C#
public virtual void SetStream(
    MediaStream mediaStream
)
Parameters
mediaStream (MediaStream)
The media stream.


Updated Property

Updated Property
Namespaces ► Sitecore.Resources.Media ► MediaData ► Updated
Gets the time of the latest update.
Declaration Syntax
C#
public DateTime Updated { get; }
Value
The update time.


MediaFactory Class

MediaFactory Class
Namespaces ► Sitecore.Resources.Media ► MediaFactory
Represents the media factory.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use MediaManager instead.")]
public static class MediaFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetMediaInfo(String) | Gets the media info.
Inheritance Hierarchy
Object
MediaFactory


GetMediaInfo Method (file)

GetMediaInfo Method (file)
Namespaces ► Sitecore.Resources.Media ► MediaFactory ► GetMediaInfo(String)
Gets the media info.
Declaration Syntax
C#
public static MediaInfo GetMediaInfo(
    string file
)
Parameters
file (String)
The file.
Return Value
The media info.


MediaHeaders Class

MediaHeaders Class
Namespaces ► Sitecore.Resources.Media ► MediaHeaders
MediaHeaders class
Declaration Syntax
C#
public class MediaHeaders
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaHeaders(MediaStream) | Initializes a new instance of the MediaHeaders class.
 | Add(String, String) | Adds the specified value to the headers.
 | CopyTo(HttpResponse) | Copies the headers to an http response.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Headers | Gets the headers.
 | MediaStream | Gets the media stream owning the headers.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MediaHeaders


MediaHeaders Constructor (mediaStream)

MediaHeaders Constructor (mediaStream)
Namespaces ► Sitecore.Resources.Media ► MediaHeaders ► MediaHeaders(MediaStream)
Initializes a new instance of the MediaHeaders class.
Declaration Syntax
C#
public MediaHeaders(
    MediaStream mediaStream
)
Parameters
mediaStream (MediaStream)


Add Method (key, value)

Add Method (key, value)
Namespaces ► Sitecore.Resources.Media ► MediaHeaders ► Add(String, String)
Adds the specified value to the headers.
Declaration Syntax
C#
public virtual void Add(
    string key,
    string value
)
Parameters
key (String)
The key.
value (String)
The value.


CopyTo Method (httpResponse)

CopyTo Method (httpResponse)
Namespaces ► Sitecore.Resources.Media ► MediaHeaders ► CopyTo(HttpResponse)
Copies the headers to an http response.
Declaration Syntax
C#
public virtual void CopyTo(
    HttpResponse httpResponse
)
Parameters
httpResponse (HttpResponse)
The HTTP response.


Headers Property

Headers Property
Namespaces ► Sitecore.Resources.Media ► MediaHeaders ► Headers
Gets the headers.
Declaration Syntax
C#
public virtual StringDictionary Headers { get; }
Value
The headers.


MediaStream Property

MediaStream Property
Namespaces ► Sitecore.Resources.Media ► MediaHeaders ► MediaStream
Gets the media stream owning the headers.
Declaration Syntax
C#
public virtual MediaStream MediaStream { get; }
Value
The media stream.


MediaManager Class

MediaManager Class
Namespaces ► Sitecore.Resources.Media ► MediaManager
MediaManager
Declaration Syntax
C#
public static class MediaManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cache | Gets or sets the media cache.
 | Config | Gets or sets the media configuration handler.
 | Creator | Gets or sets the object used when creating new media items.
 | Effects | Gets or sets the object handling image effects and transformations.
 | GetMedia(MediaItem) | Gets media from a media item.
 | GetMedia(MediaUri) | Gets media from a media URI.
 | GetMediaUrl(MediaItem) | Gets a media URL.
 | GetMediaUrl(MediaItem, MediaUrlOptions) | Gets a media URL.
 | GetThumbnailUrl(MediaItem) | Gets a thumbnail URL.
 | HasMediaContent(Item) | Determines whether the specified item has a media stream with content.
 | IsMediaRequest(HttpRequest) | Determines whether the specified HTTP request is a media request.
 | IsMediaUrl(String) | Determines whether the specified URL is a media URL.
 | MimeResolver | Gets or sets the MIME resolver.
 | ParseMediaRequest(HttpRequest) | Gets a media request from a http request.
 | Provider | Gets or sets the provider.
Inheritance Hierarchy
Object
MediaManager


Cache Property

Cache Property
Namespaces ► Sitecore.Resources.Media ► MediaManager ► Cache
Gets or sets the media cache.
Declaration Syntax
C#
public static MediaCache Cache { get; set; }
Value
The media cache.


Config Property

Config Property
Namespaces ► Sitecore.Resources.Media ► MediaManager ► Config
Gets or sets the media configuration handler.
Declaration Syntax
C#
public static MediaConfig Config { get; set; }
Value
The media configuration.


Creator Property

Creator Property
Namespaces ► Sitecore.Resources.Media ► MediaManager ► Creator
Gets or sets the object used when creating new media items.
Declaration Syntax
C#
public static MediaCreator Creator { get; set; }
Value
The creator.


Effects Property

Effects Property
Namespaces ► Sitecore.Resources.Media ► MediaManager ► Effects
Gets or sets the object handling image effects and transformations.
Declaration Syntax
C#
public static ImageEffects Effects { get; set; }
Value
The effects.


GetMedia Method

GetMedia Method
Namespaces ► Sitecore.Resources.Media ► MediaManager ► GetMedia()()()
Members
Icon | Member | Description
 | GetMedia(MediaItem) | Gets media from a media item.
 | GetMedia(MediaUri) | Gets media from a media URI.


GetMedia Method (item)

GetMedia Method (item)
Namespaces ► Sitecore.Resources.Media ► MediaManager ► GetMedia(MediaItem)
Gets media from a media item.
Declaration Syntax
C#
public static Media GetMedia(
    MediaItem item
)
Parameters
item (MediaItem)
The item.
Return Value


GetMedia Method (mediaUri)

GetMedia Method (mediaUri)
Namespaces ► Sitecore.Resources.Media ► MediaManager ► GetMedia(MediaUri)
Gets media from a media URI.
Declaration Syntax
C#
public static Media GetMedia(
    MediaUri mediaUri
)
Parameters
mediaUri (MediaUri)
The media URI.
Return Value


GetMediaUrl Method

GetMediaUrl Method
Namespaces ► Sitecore.Resources.Media ► MediaManager ► GetMediaUrl()()()
Members
Icon | Member | Description
 | GetMediaUrl(MediaItem) | Gets a media URL.
 | GetMediaUrl(MediaItem, MediaUrlOptions) | Gets a media URL.


GetMediaUrl Method (item)

GetMediaUrl Method (item)
Namespaces ► Sitecore.Resources.Media ► MediaManager ► GetMediaUrl(MediaItem)
Gets a media URL.
Declaration Syntax
C#
public static string GetMediaUrl(
    MediaItem item
)
Parameters
item (MediaItem)
The item.
Return Value
The media URL.


GetMediaUrl Method (item, options)

GetMediaUrl Method (item, options)
Namespaces ► Sitecore.Resources.Media ► MediaManager ► GetMediaUrl(MediaItem, MediaUrlOptions)
Gets a media URL.
Declaration Syntax
C#
public static string GetMediaUrl(
    MediaItem item,
    MediaUrlOptions options
)
Parameters
item (MediaItem)
The item.
options (MediaUrlOptions)
The query string.
Return Value
The media URL.


GetThumbnailUrl Method (item)

GetThumbnailUrl Method (item)
Namespaces ► Sitecore.Resources.Media ► MediaManager ► GetThumbnailUrl(MediaItem)
Gets a thumbnail URL.
Declaration Syntax
C#
public static string GetThumbnailUrl(
    MediaItem item
)
Parameters
item (MediaItem)
The item.
Return Value
The media URL.


HasMediaContent Method (item)

HasMediaContent Method (item)
Namespaces ► Sitecore.Resources.Media ► MediaManager ► HasMediaContent(Item)
Determines whether the specified item has a media stream with content.
Declaration Syntax
C#
public static bool HasMediaContent(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item has a media stream with content; otherwise, false.


IsMediaRequest Method (httpRequest)

IsMediaRequest Method (httpRequest)
Namespaces ► Sitecore.Resources.Media ► MediaManager ► IsMediaRequest(HttpRequest)
Determines whether the specified HTTP request is a media request.
Declaration Syntax
C#
public static bool IsMediaRequest(
    HttpRequest httpRequest
)
Parameters
httpRequest (HttpRequest)
The HTTP request.
Return Value
true if the specified HTTP request is a media request; otherwise, false.


IsMediaUrl Method (url)

IsMediaUrl Method (url)
Namespaces ► Sitecore.Resources.Media ► MediaManager ► IsMediaUrl(String)
Determines whether the specified URL is a media URL.
Declaration Syntax
C#
public static bool IsMediaUrl(
    string url
)
Parameters
url (String)
The URL.
Return Value
true if the specified URL is a media URL; otherwise, false.


MimeResolver Property

MimeResolver Property
Namespaces ► Sitecore.Resources.Media ► MediaManager ► MimeResolver
Gets or sets the MIME resolver.
Declaration Syntax
C#
public static MimeResolver MimeResolver { get; set; }
Value
The MIME resolver.


ParseMediaRequest Method (request)

ParseMediaRequest Method (request)
Namespaces ► Sitecore.Resources.Media ► MediaManager ► ParseMediaRequest(HttpRequest)
Gets a media request from a http request.
Declaration Syntax
C#
public static MediaRequest ParseMediaRequest(
    HttpRequest request
)
Parameters
request (HttpRequest)
The http request.
Return Value
The media request. If the http request is not a valid media request, null is returned.
Remarks
If the http request is not a valid media request, null is returned.


Provider Property

Provider Property
Namespaces ► Sitecore.Resources.Media ► MediaManager ► Provider
Gets or sets the provider.
Declaration Syntax
C#
public static MediaProvider Provider { get; set; }
Value
The provider.


MediaMetaDataCollection Class

MediaMetaDataCollection Class
Namespaces ► Sitecore.Resources.Media ► MediaMetaDataCollection
Represents a collection of Media Meta Data.
Declaration Syntax
C#
public class MediaMetaDataCollection : SortedDictionary<string, string>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaMetaDataCollection()()() | Initializes a new instance of the MediaMetaDataCollection class
 | Add(TKey, TValue) | Adds an element with the specified key and value into the SortedDictionary<(Of <(TKey, TValue>)>). (Inherited from SortedDictionary<(Of <(String, String>)>).)
 | Clear()()() | Removes all elements from the SortedDictionary<(Of <(TKey, TValue>)>). (Inherited from SortedDictionary<(Of <(String, String>)>).)
 | Comparer | Gets the IComparer<(Of <(T>)>) used to order the elements of the SortedDictionary<(Of <(TKey, TValue>)>). (Inherited from SortedDictionary<(Of <(String, String>)>).)
 | ContainsKey(TKey) | Determines whether the SortedDictionary<(Of <(TKey, TValue>)>) contains an element with the specified key. (Inherited from SortedDictionary<(Of <(String, String>)>).)
 | ContainsValue(TValue) | Determines whether the SortedDictionary<(Of <(TKey, TValue>)>) contains an element with the specified value. (Inherited from SortedDictionary<(Of <(String, String>)>).)
 | CopyTo(array<KeyValuePair<(Of <(TKey, TValue>)>)>[]()[], Int32) | Copies the elements of the SortedDictionary<(Of <(TKey, TValue>)>) to the specified array of KeyValuePair<(Of <(TKey, TValue>)>) structures, starting at the specified index. (Inherited from SortedDictionary<(Of <(String, String>)>).)
 | Count | Gets the number of key/value pairs contained in the SortedDictionary<(Of <(TKey, TValue>)>). (Inherited from SortedDictionary<(Of <(String, String>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the SortedDictionary<(Of <(TKey, TValue>)>). (Inherited from SortedDictionary<(Of <(String, String>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(TKey])]) | Gets or sets the value associated with the specified key. (Inherited from SortedDictionary<(Of <(String, String>)>).)
 | Keys | Gets a collection containing the keys in the SortedDictionary<(Of <(TKey, TValue>)>). (Inherited from SortedDictionary<(Of <(String, String>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(TKey) | Removes the element with the specified key from the SortedDictionary<(Of <(TKey, TValue>)>). (Inherited from SortedDictionary<(Of <(String, String>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetValue(TKey, TValue%) | Gets the value associated with the specified key. (Inherited from SortedDictionary<(Of <(String, String>)>).)
 | Values | Gets a collection containing the values in the SortedDictionary<(Of <(TKey, TValue>)>). (Inherited from SortedDictionary<(Of <(String, String>)>).)
Inheritance Hierarchy
Object
 | SortedDictionary<(Of <(String, String>)>)
 |  | MediaMetaDataCollection


MediaMetaDataCollection Constructor

MediaMetaDataCollection Constructor
Namespaces ► Sitecore.Resources.Media ► MediaMetaDataCollection ► MediaMetaDataCollection()()()
Initializes a new instance of the MediaMetaDataCollection class
Declaration Syntax
C#
public MediaMetaDataCollection()


MediaMetaDataFormatter Class

MediaMetaDataFormatter Class
Namespaces ► Sitecore.Resources.Media ► MediaMetaDataFormatter
Represents a Media Meta Data Formatter.
Declaration Syntax
C#
public class MediaMetaDataFormatter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MediaMetaDataFormatter()()() | Initializes a new instance of the MediaMetaDataFormatter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Format(MediaMetaDataCollection, MediaMetaDataFormatterOutput) | Formats the specified meta data.
 | FormatCollection(MediaMetaDataCollection, MediaMetaDataFormatterOutput) | Formats the collection.
 | FormatValue(String, String, MediaMetaDataFormatterOutput) | Formats the specified key.
 | FormatValues(MediaMetaDataCollection, MediaMetaDataFormatterOutput) | Formats the values.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | MediaMetaDataFormatter
 |  | ZipMetaDataFormatter


MediaMetaDataFormatter Constructor

MediaMetaDataFormatter Constructor
Namespaces ► Sitecore.Resources.Media ► MediaMetaDataFormatter ► MediaMetaDataFormatter()()()
Initializes a new instance of the MediaMetaDataFormatter class
Declaration Syntax
C#
public MediaMetaDataFormatter()


Format Method (metaData, output)

Format Method (metaData, output)
Namespaces ► Sitecore.Resources.Media ► MediaMetaDataFormatter ► Format(MediaMetaDataCollection, MediaMetaDataFormatterOutput)
Formats the specified meta data.
Declaration Syntax
C#
public string Format(
    MediaMetaDataCollection metaData,
    MediaMetaDataFormatterOutput output
)
Parameters
metaData (MediaMetaDataCollection)
The meta data.
output (MediaMetaDataFormatterOutput)
The output.
Return Value
The format.


FormatCollection Method (data, output)

FormatCollection Method (data, output)
Namespaces ► Sitecore.Resources.Media ► MediaMetaDataFormatter ► FormatCollection(MediaMetaDataCollection, MediaMetaDataFormatterOutput)
Formats the collection.
Declaration Syntax
C#
protected virtual string FormatCollection(
    MediaMetaDataCollection data,
    MediaMetaDataFormatterOutput output
)
Parameters
data (MediaMetaDataCollection)
The data.
output (MediaMetaDataFormatterOutput)
The output.
Return Value
The collection.


FormatValue Method (key, value, output)

FormatValue Method (key, value, output)
Namespaces ► Sitecore.Resources.Media ► MediaMetaDataFormatter ► FormatValue(String, String, MediaMetaDataFormatterOutput)
Formats the specified key.
Declaration Syntax
C#
protected virtual string FormatValue(
    string key,
    string value,
    MediaMetaDataFormatterOutput output
)
Parameters
key (String)
The key.
value (String)
The value.
output (MediaMetaDataFormatterOutput)
The output.
Return Value
The format.


FormatValues Method (metaData, output)

FormatValues Method (metaData, output)
Namespaces ► Sitecore.Resources.Media ► MediaMetaDataFormatter ► FormatValues(MediaMetaDataCollection, MediaMetaDataFormatterOutput)
Formats the values.
Declaration Syntax
C#
protected virtual void FormatValues(
    MediaMetaDataCollection metaData,
    MediaMetaDataFormatterOutput output
)
Parameters
metaData (MediaMetaDataCollection)
The meta data.
output (MediaMetaDataFormatterOutput)
The output.


MediaMetaDataFormatterOutput Enumeration

MediaMetaDataFormatterOutput Enumeration
Namespaces ► Sitecore.Resources.Media ► MediaMetaDataFormatterOutput
Represents the output of a Media Meta Data Formatter.
Declaration Syntax
C#
public enum MediaMetaDataFormatterOutput
Members
Member | Description
Unformatted | Unformatted.
Html | Html.
HtmlNoKeys | Html with no keys.
Text | Text.


MediaOptions Class

MediaOptions Class
Namespaces ► Sitecore.Resources.Media ► MediaOptions
MediaOutputOptions class
Declaration Syntax
C#
public class MediaOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaOptions()()() | Initializes a new instance of the MediaOptions class
 | AllowStretch | Gets or sets a value indicating whether stretching is allowed.
 | BackgroundColor | Gets the background color to use when scaling images.
 | CustomOptions | Gets the custom options.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCacheKey()()() | Gets a cache key built from the options.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTransformationOptions()()() | Gets the image options.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Height | Gets or sets the requested height.
 | MaxHeight | Gets or sets the max height.
 | MaxWidth | Gets or sets the max width.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Scale | Gets the scale.
 | Thumbnail | Gets or sets a value indicating whether a thumbnail is requested.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseMediaCache | Gets or sets a value indicating whether to allow using the media cache.
 | Width | Gets or sets the requested width.
Inheritance Hierarchy
Object
MediaOptions


MediaOptions Constructor

MediaOptions Constructor
Namespaces ► Sitecore.Resources.Media ► MediaOptions ► MediaOptions()()()
Initializes a new instance of the MediaOptions class
Declaration Syntax
C#
public MediaOptions()


AllowStretch Property

AllowStretch Property
Namespaces ► Sitecore.Resources.Media ► MediaOptions ► AllowStretch
Gets or sets a value indicating whether stretching is allowed.
Declaration Syntax
C#
public bool AllowStretch { get; set; }
Value
true if stretching is allowed; otherwise, false.


BackgroundColor Property

BackgroundColor Property
Namespaces ► Sitecore.Resources.Media ► MediaOptions ► BackgroundColor
Gets the background color to use when scaling images.
Declaration Syntax
C#
public Color BackgroundColor { get; set; }
Value
The color of the background.


CustomOptions Property

CustomOptions Property
Namespaces ► Sitecore.Resources.Media ► MediaOptions ► CustomOptions
Gets the custom options.
Declaration Syntax
C#
public StringDictionary CustomOptions { get; }
Value
The custom options.


GetCacheKey Method

GetCacheKey Method
Namespaces ► Sitecore.Resources.Media ► MediaOptions ► GetCacheKey()()()
Gets a cache key built from the options.
Declaration Syntax
C#
public virtual string GetCacheKey()
Return Value
Remarks
Note that two MediaOptions instances with the same options set must return the same cache key.


GetTransformationOptions Method

GetTransformationOptions Method
Namespaces ► Sitecore.Resources.Media ► MediaOptions ► GetTransformationOptions()()()
Gets the image options.
Declaration Syntax
C#
public virtual TransformationOptions GetTransformationOptions()
Return Value


Height Property

Height Property
Namespaces ► Sitecore.Resources.Media ► MediaOptions ► Height
Gets or sets the requested height.
Declaration Syntax
C#
public int Height { get; set; }
Value
The height.


MaxHeight Property

MaxHeight Property
Namespaces ► Sitecore.Resources.Media ► MediaOptions ► MaxHeight
Gets or sets the max height.
Declaration Syntax
C#
public int MaxHeight { get; set; }
Value
The max height.


MaxWidth Property

MaxWidth Property
Namespaces ► Sitecore.Resources.Media ► MediaOptions ► MaxWidth
Gets or sets the max width.
Declaration Syntax
C#
public int MaxWidth { get; set; }
Value
The max width.


Scale Property

Scale Property
Namespaces ► Sitecore.Resources.Media ► MediaOptions ► Scale
Gets the scale.
Declaration Syntax
C#
public float Scale { get; set; }
Value
The scale.


Thumbnail Property

Thumbnail Property
Namespaces ► Sitecore.Resources.Media ► MediaOptions ► Thumbnail
Gets or sets a value indicating whether a thumbnail is requested.
Declaration Syntax
C#
public bool Thumbnail { get; set; }
Value
true if a thumbnail is requested; otherwise, false.


UseMediaCache Property

UseMediaCache Property
Namespaces ► Sitecore.Resources.Media ► MediaOptions ► UseMediaCache
Gets or sets a value indicating whether to allow using the media cache.
Declaration Syntax
C#
public bool UseMediaCache { get; set; }
Value
true if the media cache may be used; otherwise, false.


Width Property

Width Property
Namespaces ► Sitecore.Resources.Media ► MediaOptions ► Width
Gets or sets the requested width.
Declaration Syntax
C#
public int Width { get; set; }
Value
The width.


MediaPathManager Class

MediaPathManager Class
Namespaces ► Sitecore.Resources.Media ► MediaPathManager
Represents a Media Path.
Declaration Syntax
C#
public static class MediaPathManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreatePath(String) | Create a path of items
 | GetExtension(String) | Gets the extension.
 | GetMediaFilePath(String, String) | Gets the media file path.
 | GetMediaName(String) | Gets the name of the media.
 | GetOutputFilePath(String, String) | Gets the output file path.
 | MapPath(String) | Map from a physical path to a sitecore path
 | MapPath(String, String) | Map from a physical path to a sitecore path
 | ProposeValidMediaPath(String) | Proposes the valid media path.
 | ProposeValidMediaPath(String, Boolean) | Proposes the valid media path.
 | Provider | Gets the default provider.
 | Providers | Gets the providers.
 | UnmapPath(String) | Unmaps the path.
 | UnmapPath(String, String) | Unmaps the path.
Inheritance Hierarchy
Object
MediaPathManager


CreatePath Method (path)

CreatePath Method (path)
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► CreatePath(String)
Create a path of items
Declaration Syntax
C#
public static Item CreatePath(
    string path
)
Parameters
path (String)
The path.
Return Value
The path.


GetExtension Method (file)

GetExtension Method (file)
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► GetExtension(String)
Gets the extension.
Declaration Syntax
C#
public static string GetExtension(
    string file
)
Parameters
file (String)
The file.
Return Value
The extension.


GetMediaFilePath Method (itemPath, extension)

GetMediaFilePath Method (itemPath, extension)
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► GetMediaFilePath(String, String)
Gets the media file path.
Declaration Syntax
C#
public static string GetMediaFilePath(
    string itemPath,
    string extension
)
Parameters
itemPath (String)
The item path.
extension (String)
The extension.
Return Value


GetMediaName Method (file)

GetMediaName Method (file)
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► GetMediaName(String)
Gets the name of the media.
Declaration Syntax
C#
public static string GetMediaName(
    string file
)
Parameters
file (String)
The file.
Return Value
The String.


GetOutputFilePath Method (itemPath, extension)

GetOutputFilePath Method (itemPath, extension)
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► GetOutputFilePath(String, String)
Gets the output file path.
Declaration Syntax
C#
public static string GetOutputFilePath(
    string itemPath,
    string extension
)
Parameters
itemPath (String)
The item path.
extension (String)
The file extension.
Return Value


MapPath Method

MapPath Method
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► MapPath()()()
Members
Icon | Member | Description
 | MapPath(String) | Map from a physical path to a sitecore path
 | MapPath(String, String) | Map from a physical path to a sitecore path


MapPath Method (path)

MapPath Method (path)
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► MapPath(String)
Map from a physical path to a sitecore path
Declaration Syntax
C#
public static string MapPath(
    string path
)
Parameters
path (String)
The path.
Return Value
The path.


MapPath Method (path, newRoot)

MapPath Method (path, newRoot)
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► MapPath(String, String)
Map from a physical path to a sitecore path
Declaration Syntax
C#
public static string MapPath(
    string path,
    string newRoot
)
Parameters
path (String)
The path.
newRoot (String)
The new root.
Return Value
The path.


ProposeValidMediaPath Method

ProposeValidMediaPath Method
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► ProposeValidMediaPath()()()
Members
Icon | Member | Description
 | ProposeValidMediaPath(String) | Proposes the valid media path.
 | ProposeValidMediaPath(String, Boolean) | Proposes the valid media path.


ProposeValidMediaPath Method (path)

ProposeValidMediaPath Method (path)
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► ProposeValidMediaPath(String)
Proposes the valid media path.
Declaration Syntax
C#
public static string ProposeValidMediaPath(
    string path
)
Parameters
path (String)
The path.
Return Value
The valid media path.


ProposeValidMediaPath Method (path, alwaysKeepExtension)

ProposeValidMediaPath Method (path, alwaysKeepExtension)
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► ProposeValidMediaPath(String, Boolean)
Proposes the valid media path.
Declaration Syntax
C#
public static string ProposeValidMediaPath(
    string path,
    bool alwaysKeepExtension
)
Parameters
path (String)
The path.
alwaysKeepExtension (Boolean)
If set to true, the extension will always be kept in the result.
Return Value
The valid media path.


Provider Property

Provider Property
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► Provider
Gets the default provider.
Declaration Syntax
C#
public static MediaPathProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► Providers
Gets the providers.
Declaration Syntax
C#
public static MediaPathProviderCollection Providers { get; }
Value
The providers.


UnmapPath Method

UnmapPath Method
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► UnmapPath()()()
Members
Icon | Member | Description
 | UnmapPath(String) | Unmaps the path.
 | UnmapPath(String, String) | Unmaps the path.


UnmapPath Method (path)

UnmapPath Method (path)
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► UnmapPath(String)
Unmaps the path.
Declaration Syntax
C#
public static string UnmapPath(
    string path
)
Parameters
path (String)
The path.
Return Value
The path.


UnmapPath Method (path, folder)

UnmapPath Method (path, folder)
Namespaces ► Sitecore.Resources.Media ► MediaPathManager ► UnmapPath(String, String)
Unmaps the path.
Declaration Syntax
C#
public static string UnmapPath(
    string path,
    string folder
)
Parameters
path (String)
The path.
folder (String)
The folder.
Return Value
The path.


MediaPathProvider Class

MediaPathProvider Class
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider
Represents a Media Path.
Declaration Syntax
C#
public class MediaPathProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaPathProvider()()() | Initializes a new instance of the MediaPathProvider class
 | CreatePath(String) | Create a path of items
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetExtension(String) | Gets the extension.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMediaFilePath(String, String) | Gets the media file path.
 | GetMediaName(String) | Gets the name of the media.
 | GetOutputFilePath(String, String) | Gets the output file path.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | MapPath(String) | Map from a physical path to a sitecore path
 | MapPath(String, String) | Map from a physical path to a sitecore path
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ProposeValidMediaPath(String) | Proposes the valid media path.
 | ProposeValidMediaPath(String, Boolean) | Proposes the valid media path.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnmapPath(String) | Unmaps the path.
 | UnmapPath(String, String) | Unmaps the path.
Inheritance Hierarchy
Object
 | ProviderBase
 |  | MediaPathProvider


MediaPathProvider Constructor

MediaPathProvider Constructor
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► MediaPathProvider()()()
Initializes a new instance of the MediaPathProvider class
Declaration Syntax
C#
public MediaPathProvider()


CreatePath Method (path)

CreatePath Method (path)
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► CreatePath(String)
Create a path of items
Declaration Syntax
C#
public virtual Item CreatePath(
    string path
)
Parameters
path (String)
The path.
Return Value
The path.


GetExtension Method (file)

GetExtension Method (file)
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► GetExtension(String)
Gets the extension.
Declaration Syntax
C#
public virtual string GetExtension(
    string file
)
Parameters
file (String)
The file.
Return Value
The extension.


GetMediaFilePath Method (itemPath, extension)

GetMediaFilePath Method (itemPath, extension)
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► GetMediaFilePath(String, String)
Gets the media file path.
Declaration Syntax
C#
public virtual string GetMediaFilePath(
    string itemPath,
    string extension
)
Parameters
itemPath (String)
The item path.
extension (String)
The extension.
Return Value


GetMediaName Method (file)

GetMediaName Method (file)
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► GetMediaName(String)
Gets the name of the media.
Declaration Syntax
C#
public virtual string GetMediaName(
    string file
)
Parameters
file (String)
The file.
Return Value
The String.


GetOutputFilePath Method (itemPath, extension)

GetOutputFilePath Method (itemPath, extension)
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► GetOutputFilePath(String, String)
Gets the output file path.
Declaration Syntax
C#
public virtual string GetOutputFilePath(
    string itemPath,
    string extension
)
Parameters
itemPath (String)
The item path.
extension (String)
The file extension.
Return Value


MapPath Method

MapPath Method
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► MapPath()()()
Members
Icon | Member | Description
 | MapPath(String) | Map from a physical path to a sitecore path
 | MapPath(String, String) | Map from a physical path to a sitecore path


MapPath Method (path)

MapPath Method (path)
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► MapPath(String)
Map from a physical path to a sitecore path
Declaration Syntax
C#
public virtual string MapPath(
    string path
)
Parameters
path (String)
The path.
Return Value
The path.


MapPath Method (path, newRoot)

MapPath Method (path, newRoot)
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► MapPath(String, String)
Map from a physical path to a sitecore path
Declaration Syntax
C#
public virtual string MapPath(
    string path,
    string newRoot
)
Parameters
path (String)
The path.
newRoot (String)
The new root.
Return Value
The path.


ProposeValidMediaPath Method

ProposeValidMediaPath Method
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► ProposeValidMediaPath()()()
Members
Icon | Member | Description
 | ProposeValidMediaPath(String) | Proposes the valid media path.
 | ProposeValidMediaPath(String, Boolean) | Proposes the valid media path.


ProposeValidMediaPath Method (path)

ProposeValidMediaPath Method (path)
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► ProposeValidMediaPath(String)
Proposes the valid media path.
Declaration Syntax
C#
public virtual string ProposeValidMediaPath(
    string path
)
Parameters
path (String)
The path.
Return Value
The valid media path.


ProposeValidMediaPath Method (path, alwaysKeepExtension)

ProposeValidMediaPath Method (path, alwaysKeepExtension)
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► ProposeValidMediaPath(String, Boolean)
Proposes the valid media path.
Declaration Syntax
C#
public virtual string ProposeValidMediaPath(
    string path,
    bool alwaysKeepExtension
)
Parameters
path (String)
The path.
alwaysKeepExtension (Boolean)
If set to true, the extension will always be kept in the result.
Return Value
The valid media path.


UnmapPath Method

UnmapPath Method
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► UnmapPath()()()
Members
Icon | Member | Description
 | UnmapPath(String) | Unmaps the path.
 | UnmapPath(String, String) | Unmaps the path.


UnmapPath Method (path)

UnmapPath Method (path)
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► UnmapPath(String)
Unmaps the path.
Declaration Syntax
C#
public virtual string UnmapPath(
    string path
)
Parameters
path (String)
The path.
Return Value
The path.


UnmapPath Method (path, folder)

UnmapPath Method (path, folder)
Namespaces ► Sitecore.Resources.Media ► MediaPathProvider ► UnmapPath(String, String)
Unmaps the path.
Declaration Syntax
C#
public virtual string UnmapPath(
    string path,
    string folder
)
Parameters
path (String)
The path.
folder (String)
The folder.
Return Value
The path.


MediaPathProviderCollection Class

MediaPathProviderCollection Class
Namespaces ► Sitecore.Resources.Media ► MediaPathProviderCollection
Collection of MediaPathProvider objects
Declaration Syntax
C#
public class MediaPathProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaPathProviderCollection()()() | Initializes a new instance of the MediaPathProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the MediaPathProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | MediaPathProviderCollection


MediaPathProviderCollection Constructor

MediaPathProviderCollection Constructor
Namespaces ► Sitecore.Resources.Media ► MediaPathProviderCollection ► MediaPathProviderCollection()()()
Initializes a new instance of the MediaPathProviderCollection class
Declaration Syntax
C#
public MediaPathProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Resources.Media ► MediaPathProviderCollection ► Item[([(String])])
Gets the MediaPathProvider with the specified name.
Declaration Syntax
C#
public MediaPathProvider this[
    string name
] { get; }
Parameters
name (String)
Value
The MediaPathProvider.


MediaProvider Class

MediaProvider Class
Namespaces ► Sitecore.Resources.Media ► MediaProvider
MediaProvider class
Declaration Syntax
C#
public class MediaProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaProvider()()() | Initializes the MediaManager class.
 | Cache | Gets or sets the media cache.
 | Config | Gets or sets the media configuration handler.
 | Creator | Gets or sets the object used when creating new media items.
 | Effects | Gets or sets the object handling image effects and transformations.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMedia(MediaItem) | Gets media from a media item.
 | GetMedia(MediaUri) | Gets media from a media URI.
 | GetMedia(MediaData) | Constructs a Media instance from a MediaData.
 | GetMediaData(MediaItem) | Constructs a MediaData instance from a MediaItem.
 | GetMediaData(MediaUri) | Gets media data from a media URI.
 | GetMediaUrl(MediaItem) | Gets a media URL.
 | GetMediaUrl(MediaItem, MediaUrlOptions) | Gets a media URL.
 | GetThumbnailUrl(MediaItem) | Gets a thumbnail URL.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasMediaContent(Item) | Determines whether the specified item has a media stream with content.
 | IsMediaRequest(HttpRequest) | Determines whether the specified HTTP request is a media request.
 | IsMediaUrl(String) | Determines whether the specified URL is a media URL.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MimeResolver | Gets or sets the MIME resolver.
 | ParseMediaRequest(HttpRequest) | Gets a media request from a http request.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MediaProvider


MediaProvider Constructor

MediaProvider Constructor
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► MediaProvider()()()
Initializes the MediaManager class.
Declaration Syntax
C#
public MediaProvider()


Cache Property

Cache Property
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► Cache
Gets or sets the media cache.
Declaration Syntax
C#
public virtual MediaCache Cache { get; set; }
Value
The media cache.


Config Property

Config Property
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► Config
Gets or sets the media configuration handler.
Declaration Syntax
C#
public virtual MediaConfig Config { get; set; }
Value
The media configuration.


Creator Property

Creator Property
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► Creator
Gets or sets the object used when creating new media items.
Declaration Syntax
C#
public virtual MediaCreator Creator { get; set; }
Value
The creator.


Effects Property

Effects Property
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► Effects
Gets or sets the object handling image effects and transformations.
Declaration Syntax
C#
public virtual ImageEffects Effects { get; set; }
Value
The effects.


GetMedia Method

GetMedia Method
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► GetMedia()()()
Members
Icon | Member | Description
 | GetMedia(MediaItem) | Gets media from a media item.
 | GetMedia(MediaUri) | Gets media from a media URI.
 | GetMedia(MediaData) | Constructs a Media instance from a MediaData.


GetMedia Method (item)

GetMedia Method (item)
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► GetMedia(MediaItem)
Gets media from a media item.
Declaration Syntax
C#
public virtual Media GetMedia(
    MediaItem item
)
Parameters
item (MediaItem)
The item.
Return Value


GetMedia Method (mediaData)

GetMedia Method (mediaData)
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► GetMedia(MediaData)
Constructs a Media instance from a MediaData.
Declaration Syntax
C#
protected virtual Media GetMedia(
    MediaData mediaData
)
Parameters
mediaData (MediaData)
The media data.
Return Value


GetMedia Method (mediaUri)

GetMedia Method (mediaUri)
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► GetMedia(MediaUri)
Gets media from a media URI.
Declaration Syntax
C#
public virtual Media GetMedia(
    MediaUri mediaUri
)
Parameters
mediaUri (MediaUri)
The media URI.
Return Value


GetMediaData Method

GetMediaData Method
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► GetMediaData()()()
Members
Icon | Member | Description
 | GetMediaData(MediaItem) | Constructs a MediaData instance from a MediaItem.
 | GetMediaData(MediaUri) | Gets media data from a media URI.


GetMediaData Method (item)

GetMediaData Method (item)
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► GetMediaData(MediaItem)
Constructs a MediaData instance from a MediaItem.
Declaration Syntax
C#
protected virtual MediaData GetMediaData(
    MediaItem item
)
Parameters
item (MediaItem)
The item.
Return Value


GetMediaData Method (mediaUri)

GetMediaData Method (mediaUri)
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► GetMediaData(MediaUri)
Gets media data from a media URI.
Declaration Syntax
C#
protected virtual MediaData GetMediaData(
    MediaUri mediaUri
)
Parameters
mediaUri (MediaUri)
The media URI.
Return Value


GetMediaUrl Method

GetMediaUrl Method
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► GetMediaUrl()()()
Members
Icon | Member | Description
 | GetMediaUrl(MediaItem) | Gets a media URL.
 | GetMediaUrl(MediaItem, MediaUrlOptions) | Gets a media URL.


GetMediaUrl Method (item)

GetMediaUrl Method (item)
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► GetMediaUrl(MediaItem)
Gets a media URL.
Declaration Syntax
C#
public virtual string GetMediaUrl(
    MediaItem item
)
Parameters
item (MediaItem)
The item.
Return Value
The media URL.


GetMediaUrl Method (item, options)

GetMediaUrl Method (item, options)
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► GetMediaUrl(MediaItem, MediaUrlOptions)
Gets a media URL.
Declaration Syntax
C#
public virtual string GetMediaUrl(
    MediaItem item,
    MediaUrlOptions options
)
Parameters
item (MediaItem)
The item.
options (MediaUrlOptions)
The query string.
Return Value
The media URL.


GetThumbnailUrl Method (item)

GetThumbnailUrl Method (item)
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► GetThumbnailUrl(MediaItem)
Gets a thumbnail URL.
Declaration Syntax
C#
public virtual string GetThumbnailUrl(
    MediaItem item
)
Parameters
item (MediaItem)
The item.
Return Value
The media URL.


HasMediaContent Method (item)

HasMediaContent Method (item)
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► HasMediaContent(Item)
Determines whether the specified item has a media stream with content.
Declaration Syntax
C#
public virtual bool HasMediaContent(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item has a media stream with content; otherwise, false.


IsMediaRequest Method (httpRequest)

IsMediaRequest Method (httpRequest)
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► IsMediaRequest(HttpRequest)
Determines whether the specified HTTP request is a media request.
Declaration Syntax
C#
public virtual bool IsMediaRequest(
    HttpRequest httpRequest
)
Parameters
httpRequest (HttpRequest)
The HTTP request.
Return Value
true if the specified HTTP request is a media request; otherwise, false.


IsMediaUrl Method (url)

IsMediaUrl Method (url)
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► IsMediaUrl(String)
Determines whether the specified URL is a media URL.
Declaration Syntax
C#
public virtual bool IsMediaUrl(
    string url
)
Parameters
url (String)
The URL.
Return Value
true if the specified URL is a media URL; otherwise, false.


MimeResolver Property

MimeResolver Property
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► MimeResolver
Gets or sets the MIME resolver.
Declaration Syntax
C#
public virtual MimeResolver MimeResolver { get; set; }
Value
The MIME resolver.


ParseMediaRequest Method (request)

ParseMediaRequest Method (request)
Namespaces ► Sitecore.Resources.Media ► MediaProvider ► ParseMediaRequest(HttpRequest)
Gets a media request from a http request.
Declaration Syntax
C#
public virtual MediaRequest ParseMediaRequest(
    HttpRequest request
)
Parameters
request (HttpRequest)
The http request.
Return Value
The media request. If the http request is not a valid media request, null is returned.
Remarks
If the http request is not a valid media request, null is returned.


MediaRequest Class

MediaRequest Class
Namespaces ► Sitecore.Resources.Media ► MediaRequest
MediaRequest class
Declaration Syntax
C#
public class MediaRequest : IPrototype<MediaRequest>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaRequest()()() | Initializes a new instance of the MediaRequest class.
 | MediaRequest(HttpRequest) | Initializes a new instance of the MediaRequest class.
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the type.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDatabase()()() | Gets the database from the request URL.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLanguage()()() | Gets the language from the request URL.
 | GetMediaPath()()() | Gets the media path from the request URL.
 | GetMediaQueryString()()() | Gets the media query string.
 | GetOptions()()() | Gets the various options from the request URL.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersion()()() | Gets the version from the request URL.
 | Initialize(HttpRequest) | Initializes this instance. Used after cloning.
 | InnerRequest | Gets the inner request.
 | MediaUri | Gets the media URI.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Options | Gets the media options.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MediaRequest


MediaRequest Constructor

MediaRequest Constructor
Namespaces ► Sitecore.Resources.Media ► MediaRequest ► MediaRequest()()()
Members
Icon | Member | Description
 | MediaRequest()()() | Initializes a new instance of the MediaRequest class.
 | MediaRequest(HttpRequest) | Initializes a new instance of the MediaRequest class.


MediaRequest Constructor

MediaRequest Constructor
Namespaces ► Sitecore.Resources.Media ► MediaRequest ► MediaRequest()()()
Initializes a new instance of the MediaRequest class.
Declaration Syntax
C#
public MediaRequest()


MediaRequest Constructor (request)

MediaRequest Constructor (request)
Namespaces ► Sitecore.Resources.Media ► MediaRequest ► MediaRequest(HttpRequest)
Initializes a new instance of the MediaRequest class.
Declaration Syntax
C#
public MediaRequest(
    HttpRequest request
)
Parameters
request (HttpRequest)
The HTTP request.


Clone Method

Clone Method
Namespaces ► Sitecore.Resources.Media ► MediaRequest ► Clone()()()
Clones the source object. Has the same effect as creating a new instance of the type.
Declaration Syntax
C#
public virtual MediaRequest Clone()
Return Value


GetDatabase Method

GetDatabase Method
Namespaces ► Sitecore.Resources.Media ► MediaRequest ► GetDatabase()()()
Gets the database from the request URL.
Declaration Syntax
C#
protected virtual Database GetDatabase()
Return Value


GetLanguage Method

GetLanguage Method
Namespaces ► Sitecore.Resources.Media ► MediaRequest ► GetLanguage()()()
Gets the language from the request URL.
Declaration Syntax
C#
protected virtual Language GetLanguage()
Return Value


GetMediaPath Method

GetMediaPath Method
Namespaces ► Sitecore.Resources.Media ► MediaRequest ► GetMediaPath()()()
Gets the media path from the request URL.
Declaration Syntax
C#
protected virtual string GetMediaPath()
Return Value


GetMediaQueryString Method

GetMediaQueryString Method
Namespaces ► Sitecore.Resources.Media ► MediaRequest ► GetMediaQueryString()()()
Gets the media query string.
Declaration Syntax
C#
protected MediaUrlOptions GetMediaQueryString()
Return Value
The media query string.


GetOptions Method

GetOptions Method
Namespaces ► Sitecore.Resources.Media ► MediaRequest ► GetOptions()()()
Gets the various options from the request URL.
Declaration Syntax
C#
protected virtual MediaOptions GetOptions()
Return Value


GetVersion Method

GetVersion Method
Namespaces ► Sitecore.Resources.Media ► MediaRequest ► GetVersion()()()
Gets the version from the request URL.
Declaration Syntax
C#
protected virtual Version GetVersion()
Return Value


Initialize Method (request)

Initialize Method (request)
Namespaces ► Sitecore.Resources.Media ► MediaRequest ► Initialize(HttpRequest)
Initializes this instance. Used after cloning.
Declaration Syntax
C#
public virtual void Initialize(
    HttpRequest request
)
Parameters
request (HttpRequest)


InnerRequest Property

InnerRequest Property
Namespaces ► Sitecore.Resources.Media ► MediaRequest ► InnerRequest
Gets the inner request.
Declaration Syntax
C#
public virtual HttpRequest InnerRequest { get; }
Value
The inner request.


MediaUri Property

MediaUri Property
Namespaces ► Sitecore.Resources.Media ► MediaRequest ► MediaUri
Gets the media URI.
Declaration Syntax
C#
public virtual MediaUri MediaUri { get; }
Value
The media URI.


Options Property

Options Property
Namespaces ► Sitecore.Resources.Media ► MediaRequest ► Options
Gets the media options.
Declaration Syntax
C#
public virtual MediaOptions Options { get; }
Value
The options.


MediaRequestHandler Class

MediaRequestHandler Class
Namespaces ► Sitecore.Resources.Media ► MediaRequestHandler
MediaRequestHandler class
Declaration Syntax
C#
public class MediaRequestHandler : IHttpHandler
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaRequestHandler()()() | Initializes a new instance of the MediaRequestHandler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsReusable | Gets a value indicating whether another request can use the IHttpHandler instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessRequest(HttpContext) | Enables processing of HTTP Web requests by a custom HttpHandler that implements the IHttpHandler interface.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MediaRequestHandler


MediaRequestHandler Constructor

MediaRequestHandler Constructor
Namespaces ► Sitecore.Resources.Media ► MediaRequestHandler ► MediaRequestHandler()()()
Initializes a new instance of the MediaRequestHandler class
Declaration Syntax
C#
public MediaRequestHandler()


IsReusable Property

IsReusable Property
Namespaces ► Sitecore.Resources.Media ► MediaRequestHandler ► IsReusable
Gets a value indicating whether another request can use the IHttpHandler instance.
Declaration Syntax
C#
public virtual bool IsReusable { get; }
Value
Return Value
true if the IHttpHandler instance is reusable; otherwise, false.


ProcessRequest Method (context)

ProcessRequest Method (context)
Namespaces ► Sitecore.Resources.Media ► MediaRequestHandler ► ProcessRequest(HttpContext)
Enables processing of HTTP Web requests by a custom HttpHandler that implements the IHttpHandler interface.
Declaration Syntax
C#
public virtual void ProcessRequest(
    HttpContext context
)
Parameters
context (HttpContext)
An HttpContext object that provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.


MediaStream Class

MediaStream Class
Namespaces ► Sitecore.Resources.Media ► MediaStream
MediaStream class
Declaration Syntax
C#
public class MediaStream : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaStream(Stream, String, MediaItem) | Initializes a new instance of the MediaStream class.
 | AllowDatabaseStorage | Gets a value indicating whether to allow storing this stream in a database blob field.
 | AllowMemoryLoading | Gets a value indicating whether to allow loading this stream into memory.
 | Clone(Stream) | Clones the specified new stream.
 | CopyTo(Stream) | Copies the data to an output stream.
 | CopyTo(Stream, Int32) | Copies the data to an output stream.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extension | Gets the extension describing the media type.
 | FileName | Gets the file name describing the media.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | ForceDownload | Gets or sets a value indicating whether to force download of this type.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Headers | Gets the media headers.
 | Length | Gets the length of the stream data.
 | MakeStreamSeekable()()() | Makes the stream seekable.
 | MediaItem | Gets the media item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MimeType | Gets the MIME type of the current stream.
 | Stream | Gets the stream.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MediaStream


MediaStream Constructor (stream, extension, mediaItem)

MediaStream Constructor (stream, extension, mediaItem)
Namespaces ► Sitecore.Resources.Media ► MediaStream ► MediaStream(Stream, String, MediaItem)
Initializes a new instance of the MediaStream class.
Declaration Syntax
C#
public MediaStream(
    Stream stream,
    string extension,
    MediaItem mediaItem
)
Parameters
stream (Stream)
extension (String)
mediaItem (MediaItem)


AllowDatabaseStorage Property

AllowDatabaseStorage Property
Namespaces ► Sitecore.Resources.Media ► MediaStream ► AllowDatabaseStorage
Gets a value indicating whether to allow storing this stream in a database blob field.
Declaration Syntax
C#
public bool AllowDatabaseStorage { get; }
Value
true if database storage allowed; otherwise, false.


AllowMemoryLoading Property

AllowMemoryLoading Property
Namespaces ► Sitecore.Resources.Media ► MediaStream ► AllowMemoryLoading
Gets a value indicating whether to allow loading this stream into memory.
Declaration Syntax
C#
public bool AllowMemoryLoading { get; }
Value
true if memory loading allowed; otherwise, false.


Clone Method (newStream)

Clone Method (newStream)
Namespaces ► Sitecore.Resources.Media ► MediaStream ► Clone(Stream)
Clones the specified new stream.
Declaration Syntax
C#
public virtual MediaStream Clone(
    Stream newStream
)
Parameters
newStream (Stream)
The stream to use in the clone.
Return Value


CopyTo Method

CopyTo Method
Namespaces ► Sitecore.Resources.Media ► MediaStream ► CopyTo()()()
Members
Icon | Member | Description
 | CopyTo(Stream) | Copies the data to an output stream.
 | CopyTo(Stream, Int32) | Copies the data to an output stream.


CopyTo Method (outputStream)

CopyTo Method (outputStream)
Namespaces ► Sitecore.Resources.Media ► MediaStream ► CopyTo(Stream)
Copies the data to an output stream.
Declaration Syntax
C#
public void CopyTo(
    Stream outputStream
)
Parameters
outputStream (Stream)
The output stream.


CopyTo Method (outputStream, blockSize)

CopyTo Method (outputStream, blockSize)
Namespaces ► Sitecore.Resources.Media ► MediaStream ► CopyTo(Stream, Int32)
Copies the data to an output stream.
Declaration Syntax
C#
public void CopyTo(
    Stream outputStream,
    int blockSize
)
Parameters
outputStream (Stream)
The output stream.
blockSize (Int32)
Size of the block.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Resources.Media ► MediaStream ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


Extension Property

Extension Property
Namespaces ► Sitecore.Resources.Media ► MediaStream ► Extension
Gets the extension describing the media type.
Declaration Syntax
C#
public string Extension { get; }
Value
The extension.


FileName Property

FileName Property
Namespaces ► Sitecore.Resources.Media ► MediaStream ► FileName
Gets the file name describing the media.
Declaration Syntax
C#
public string FileName { get; }
Value
The name of the file.


ForceDownload Property

ForceDownload Property
Namespaces ► Sitecore.Resources.Media ► MediaStream ► ForceDownload
Gets or sets a value indicating whether to force download of this type.
Declaration Syntax
C#
public bool ForceDownload { get; }
Value
true if download should be forced; otherwise, false.
Remarks
Download is forced by setting the 'Content-Disposition' header of the response.


Headers Property

Headers Property
Namespaces ► Sitecore.Resources.Media ► MediaStream ► Headers
Gets the media headers.
Declaration Syntax
C#
public MediaHeaders Headers { get; }
Value
The headers.


Length Property

Length Property
Namespaces ► Sitecore.Resources.Media ► MediaStream ► Length
Gets the length of the stream data.
Declaration Syntax
C#
public long Length { get; }
Value
The length.


MakeStreamSeekable Method

MakeStreamSeekable Method
Namespaces ► Sitecore.Resources.Media ► MediaStream ► MakeStreamSeekable()()()
Makes the stream seekable.
Declaration Syntax
C#
public virtual void MakeStreamSeekable()


MediaItem Property

MediaItem Property
Namespaces ► Sitecore.Resources.Media ► MediaStream ► MediaItem
Gets the media item.
Declaration Syntax
C#
public MediaItem MediaItem { get; }
Value
The media item.


MimeType Property

MimeType Property
Namespaces ► Sitecore.Resources.Media ► MediaStream ► MimeType
Gets the MIME type of the current stream.
Declaration Syntax
C#
public string MimeType { get; }
Value
The type of the MIME.


Stream Property

Stream Property
Namespaces ► Sitecore.Resources.Media ► MediaStream ► Stream
Gets the stream.
Declaration Syntax
C#
public Stream Stream { get; }
Value
The stream.


MediaStreamInfo Class

MediaStreamInfo Class
Namespaces ► Sitecore.Resources.Media ► MediaStreamInfo
MediaStreamInfo class
Declaration Syntax
C#
public class MediaStreamInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaStreamInfo(String, String, StringDictionary) | Initializes a new instance of the MediaStreamInfo class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extension | Gets the extension.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Headers | Gets the headers.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StreamFileName | Gets the name of the stream file.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MediaStreamInfo


MediaStreamInfo Constructor (streamFileName, extension, headers)

MediaStreamInfo Constructor (streamFileName, extension, headers)
Namespaces ► Sitecore.Resources.Media ► MediaStreamInfo ► MediaStreamInfo(String, String, StringDictionary)
Initializes a new instance of the MediaStreamInfo class.
Declaration Syntax
C#
public MediaStreamInfo(
    string streamFileName,
    string extension,
    StringDictionary headers
)
Parameters
streamFileName (String)
extension (String)
headers (StringDictionary)


Extension Property

Extension Property
Namespaces ► Sitecore.Resources.Media ► MediaStreamInfo ► Extension
Gets the extension.
Declaration Syntax
C#
public string Extension { get; }
Value
The extension.


Headers Property

Headers Property
Namespaces ► Sitecore.Resources.Media ► MediaStreamInfo ► Headers
Gets the headers.
Declaration Syntax
C#
public StringDictionary Headers { get; }
Value
The headers.


StreamFileName Property

StreamFileName Property
Namespaces ► Sitecore.Resources.Media ► MediaStreamInfo ► StreamFileName
Gets the name of the stream file.
Declaration Syntax
C#
public string StreamFileName { get; }
Value
The name of the stream file.


MediaThumbnailGenerator Class

MediaThumbnailGenerator Class
Namespaces ► Sitecore.Resources.Media ► MediaThumbnailGenerator
ZipThumbnailCreator class
Declaration Syntax
C#
public class MediaThumbnailGenerator : ThumbnailGenerator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaThumbnailGenerator()()() | Initializes a new instance of the MediaThumbnailGenerator class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extension | Gets or sets the file extension describing the format of the thumbnail. (Inherited from ThumbnailGenerator.)
 | FilePath | Gets or sets the file path to the file containig the thumbnail image.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFileStream(String, TransformationOptions) | Gets a stream from a file. (Inherited from ThumbnailGenerator.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetImageFormat()()() | Gets the image format to use for generating streams. (Inherited from ThumbnailGenerator.)
 | GetImageStream(Stream, TransformationOptions) | Gets a stream from an image stream. (Inherited from ThumbnailGenerator.)
 | GetStream(MediaData, TransformationOptions) | Gets the stream of the thumbnail image. (Overrides ThumbnailGenerator.GetStream(MediaData, TransformationOptions).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MimeType | Gets the MIME type of the generated thumbnails. (Inherited from ThumbnailGenerator.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ThumbnailGenerator
 |  | MediaThumbnailGenerator


MediaThumbnailGenerator Constructor

MediaThumbnailGenerator Constructor
Namespaces ► Sitecore.Resources.Media ► MediaThumbnailGenerator ► MediaThumbnailGenerator()()()
Initializes a new instance of the MediaThumbnailGenerator class
Declaration Syntax
C#
public MediaThumbnailGenerator()


FilePath Property

FilePath Property
Namespaces ► Sitecore.Resources.Media ► MediaThumbnailGenerator ► FilePath
Gets or sets the file path to the file containig the thumbnail image.
Declaration Syntax
C#
public string FilePath { get; set; }
Value
The file path.


GetStream Method (mediaData, options)

GetStream Method (mediaData, options)
Namespaces ► Sitecore.Resources.Media ► MediaThumbnailGenerator ► GetStream(MediaData, TransformationOptions)
Gets the stream of the thumbnail image.
Declaration Syntax
C#
public override MediaStream GetStream(
    MediaData mediaData,
    TransformationOptions options
)
Parameters
mediaData (MediaData)
The media data to generate a thumbnail for.
options (TransformationOptions)
The options.
Return Value


MediaTypeConfig Class

MediaTypeConfig Class
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig
MediaTypeConfig class
Declaration Syntax
C#
public class MediaTypeConfig
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaTypeConfig(String, String) | Initializes a new instance of the MediaTypeConfig class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extensions | Gets the extensions covered by this config data.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | ForceDownload | Gets or sets a value indicating whether to force download of this type.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MediaDataPrototype | Gets a prototype for creating MediaData instances.
 | MediaPrototype | Gets a prototype for creating Media instances.
 | MediaValidator | Gets or sets the media validator.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MetaDataFormatter | Gets or sets the meta data formatter.
 | MimeType | Gets or sets the MIME type of the media.
 | Name | Gets the name of this media type.
 | SharedTemplate | Gets or sets the shared template name/id.
 | ThumbnailBackgroundColor | Gets or sets the default background color of thumbnails.
 | ThumbnailGenerator | Gets or sets the thumbnail generator.
 | ThumbnailHeight | Gets or sets the default height of thumbnails.
 | ThumbnailStaticFile | Gets or sets the static image file to use as thumbnail.
 | ThumbnailWidth | Gets or sets the default width of thumbnails.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UrlExtension | Gets or sets the extension to use in URLs for this media type.
 | VersionedTemplate | Gets or sets the versioned template name/id.
Inheritance Hierarchy
Object
MediaTypeConfig


MediaTypeConfig Constructor (name, extensions)

MediaTypeConfig Constructor (name, extensions)
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► MediaTypeConfig(String, String)
Initializes a new instance of the MediaTypeConfig class.
Declaration Syntax
C#
public MediaTypeConfig(
    string name,
    string extensions
)
Parameters
name (String)
extensions (String)


Extensions Property

Extensions Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► Extensions
Gets the extensions covered by this config data.
Declaration Syntax
C#
public string Extensions { get; }
Value
The extensions.


ForceDownload Property

ForceDownload Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► ForceDownload
Gets or sets a value indicating whether to force download of this type.
Declaration Syntax
C#
public Tristate ForceDownload { get; set; }
Value
true if download should be forced; otherwise, false.
Remarks
Download is forced by setting the 'Content-Disposition' header of the response.


MediaDataPrototype Property

MediaDataPrototype Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► MediaDataPrototype
Gets a prototype for creating MediaData instances.
Declaration Syntax
C#
public IPrototype<MediaData> MediaDataPrototype { get; set; }
Value
The exact type of MediaData to use.
Remarks
This type must represent a class derived from MediaData.


MediaPrototype Property

MediaPrototype Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► MediaPrototype
Gets a prototype for creating Media instances.
Declaration Syntax
C#
public IPrototype<Media> MediaPrototype { get; set; }
Value
The exact type of Media to use.
Remarks
This type must represent a class derived from Media.


MediaValidator Property

MediaValidator Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► MediaValidator
Gets or sets the media validator.
Declaration Syntax
C#
public MediaValidator MediaValidator { get; set; }
Value
The media validator.


MetaDataFormatter Property

MetaDataFormatter Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► MetaDataFormatter
Gets or sets the meta data formatter.
Declaration Syntax
C#
public MediaMetaDataFormatter MetaDataFormatter { get; set; }
Value
The meta data formatter.


MimeType Property

MimeType Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► MimeType
Gets or sets the MIME type of the media.
Declaration Syntax
C#
public string MimeType { get; set; }
Value
The MIME type of the media.


Name Property

Name Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► Name
Gets the name of this media type.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


SharedTemplate Property

SharedTemplate Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► SharedTemplate
Gets or sets the shared template name/id.
Declaration Syntax
C#
public string SharedTemplate { get; set; }
Value
The template.


ThumbnailBackgroundColor Property

ThumbnailBackgroundColor Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► ThumbnailBackgroundColor
Gets or sets the default background color of thumbnails.
Declaration Syntax
C#
public string ThumbnailBackgroundColor { get; set; }
Value
The color of the thumbnails background.


ThumbnailGenerator Property

ThumbnailGenerator Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► ThumbnailGenerator
Gets or sets the thumbnail generator.
Declaration Syntax
C#
public ThumbnailGenerator ThumbnailGenerator { get; set; }
Value
The thumbnail generator.


ThumbnailHeight Property

ThumbnailHeight Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► ThumbnailHeight
Gets or sets the default height of thumbnails.
Declaration Syntax
C#
public int ThumbnailHeight { get; set; }
Value
The height of the thumbnail.


ThumbnailStaticFile Property

ThumbnailStaticFile Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► ThumbnailStaticFile
Gets or sets the static image file to use as thumbnail.
Declaration Syntax
C#
public string ThumbnailStaticFile { get; set; }
Value
The thumbnail static file.


ThumbnailWidth Property

ThumbnailWidth Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► ThumbnailWidth
Gets or sets the default width of thumbnails.
Declaration Syntax
C#
public int ThumbnailWidth { get; set; }
Value
The width of the thumbnail.


UrlExtension Property

UrlExtension Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► UrlExtension
Gets or sets the extension to use in URLs for this media type.
Declaration Syntax
C#
public string UrlExtension { get; set; }


VersionedTemplate Property

VersionedTemplate Property
Namespaces ► Sitecore.Resources.Media ► MediaTypeConfig ► VersionedTemplate
Gets or sets the versioned template name/id.
Declaration Syntax
C#
public string VersionedTemplate { get; set; }
Value
The template.


MediaUploader Class

MediaUploader Class
Namespaces ► Sitecore.Resources.Media ► MediaUploader
Represents a MediaUpload.
Declaration Syntax
C#
public class MediaUploader
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaUploader()()() | Initializes a new instance of the MediaUploader class
 | AlternateText | Gets or sets the alternate text.
 | Database | Gets or sets the database to create media item in.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | File | Gets or sets the file.
 | FileBased | Gets or sets a value indicating whether the MediaUploader files the based.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Folder | Gets or sets the folder.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Language | Gets or sets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Overwrite | Gets or sets a value indicating whether this MediaUploader is overwrite.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unpack | Gets or sets a value indicating whether this MediaUploader is unpack.
 | Upload()()() | Uploads this instance.
 | Versioned | Gets or sets a value indicating whether this MediaUploader is versioned.
Inheritance Hierarchy
Object
MediaUploader


MediaUploader Constructor

MediaUploader Constructor
Namespaces ► Sitecore.Resources.Media ► MediaUploader ► MediaUploader()()()
Initializes a new instance of the MediaUploader class
Declaration Syntax
C#
public MediaUploader()


AlternateText Property

AlternateText Property
Namespaces ► Sitecore.Resources.Media ► MediaUploader ► AlternateText
Gets or sets the alternate text.
Declaration Syntax
C#
public string AlternateText { get; set; }
Value
The alternate text.


Database Property

Database Property
Namespaces ► Sitecore.Resources.Media ► MediaUploader ► Database
Gets or sets the database to create media item in.
Declaration Syntax
C#
public Database Database { get; set; }
Value
The database.


File Property

File Property
Namespaces ► Sitecore.Resources.Media ► MediaUploader ► File
Gets or sets the file.
Declaration Syntax
C#
public HttpPostedFile File { get; set; }
Value
The file.


FileBased Property

FileBased Property
Namespaces ► Sitecore.Resources.Media ► MediaUploader ► FileBased
Gets or sets a value indicating whether the MediaUploader files the based.
Declaration Syntax
C#
public bool FileBased { get; set; }
Value
true if the MediaUploader files the based; otherwise, false.


Folder Property

Folder Property
Namespaces ► Sitecore.Resources.Media ► MediaUploader ► Folder
Gets or sets the folder.
Declaration Syntax
C#
public string Folder { get; set; }
Value
The folder.


Language Property

Language Property
Namespaces ► Sitecore.Resources.Media ► MediaUploader ► Language
Gets or sets the language.
Declaration Syntax
C#
public Language Language { get; set; }
Value
The language.


Overwrite Property

Overwrite Property
Namespaces ► Sitecore.Resources.Media ► MediaUploader ► Overwrite
Gets or sets a value indicating whether this MediaUploader is overwrite.
Declaration Syntax
C#
public bool Overwrite { get; set; }
Value
true if overwrite; otherwise, false.


Unpack Property

Unpack Property
Namespaces ► Sitecore.Resources.Media ► MediaUploader ► Unpack
Gets or sets a value indicating whether this MediaUploader is unpack.
Declaration Syntax
C#
public bool Unpack { get; set; }
Value
true if unpack; otherwise, false.


Upload Method

Upload Method
Namespaces ► Sitecore.Resources.Media ► MediaUploader ► Upload()()()
Uploads this instance.
Declaration Syntax
C#
public List<MediaUploadResult> Upload()


Versioned Property

Versioned Property
Namespaces ► Sitecore.Resources.Media ► MediaUploader ► Versioned
Gets or sets a value indicating whether this MediaUploader is versioned.
Declaration Syntax
C#
public bool Versioned { get; set; }
Value
true if versioned; otherwise, false.


MediaUploadResult Class

MediaUploadResult Class
Namespaces ► Sitecore.Resources.Media ► MediaUploadResult
Represents a MediaUploadResult.
Declaration Syntax
C#
public class MediaUploadResult
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaUploadResult()()() | Initializes a new instance of the MediaUploadResult class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item | Gets or sets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets or sets the path.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidMediaPath | Gets or sets the valid media path.
Inheritance Hierarchy
Object
MediaUploadResult


MediaUploadResult Constructor

MediaUploadResult Constructor
Namespaces ► Sitecore.Resources.Media ► MediaUploadResult ► MediaUploadResult()()()
Initializes a new instance of the MediaUploadResult class
Declaration Syntax
C#
public MediaUploadResult()


Item Property

Item Property
Namespaces ► Sitecore.Resources.Media ► MediaUploadResult ► Item
Gets or sets the item.
Declaration Syntax
C#
public Item Item { get; internal set; }
Value
The item.


Path Property

Path Property
Namespaces ► Sitecore.Resources.Media ► MediaUploadResult ► Path
Gets or sets the path.
Declaration Syntax
C#
public string Path { get; internal set; }
Value
The path.


ValidMediaPath Property

ValidMediaPath Property
Namespaces ► Sitecore.Resources.Media ► MediaUploadResult ► ValidMediaPath
Gets or sets the valid media path.
Declaration Syntax
C#
public string ValidMediaPath { get; internal set; }
Value
The valid media path.


MediaUri Class

MediaUri Class
Namespaces ► Sitecore.Resources.Media ► MediaUri
MediaUri class
Declaration Syntax
C#
public class MediaUri
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaUri()()() | Initializes a new instance of the MediaUri class.
 | MediaUri(String, Language, Version, Database) | Initializes a new instance of the MediaUri class.
 | MediaUri(Item) | Initializes a new instance of the MediaUri class.
 | Database | Gets the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Language | Gets the language.
 | MediaPath | Gets the media path.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(Item) | Parses the specified item into a URI.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Version | Gets the version of the media.
Inheritance Hierarchy
Object
MediaUri


MediaUri Constructor

MediaUri Constructor
Namespaces ► Sitecore.Resources.Media ► MediaUri ► MediaUri()()()
Members
Icon | Member | Description
 | MediaUri()()() | Initializes a new instance of the MediaUri class.
 | MediaUri(String, Language, Version, Database) | Initializes a new instance of the MediaUri class.
 | MediaUri(Item) | Initializes a new instance of the MediaUri class.


MediaUri Constructor

MediaUri Constructor
Namespaces ► Sitecore.Resources.Media ► MediaUri ► MediaUri()()()
Initializes a new instance of the MediaUri class.
Declaration Syntax
C#
protected MediaUri()


MediaUri Constructor (item)

MediaUri Constructor (item)
Namespaces ► Sitecore.Resources.Media ► MediaUri ► MediaUri(Item)
Initializes a new instance of the MediaUri class.
Declaration Syntax
C#
public MediaUri(
    Item item
)
Parameters
item (Item)
The item.


MediaUri Constructor (mediaPath, language, version, database)

MediaUri Constructor (mediaPath, language, version, database)
Namespaces ► Sitecore.Resources.Media ► MediaUri ► MediaUri(String, Language, Version, Database)
Initializes a new instance of the MediaUri class.
Declaration Syntax
C#
public MediaUri(
    string mediaPath,
    Language language,
    Version version,
    Database database
)
Parameters
mediaPath (String)
The media path.
language (Language)
The language.
version (Version)
The version.
database (Database)
The database.


Database Property

Database Property
Namespaces ► Sitecore.Resources.Media ► MediaUri ► Database
Gets the database.
Declaration Syntax
C#
public virtual Database Database { get; set; }
Value
The database.


Language Property

Language Property
Namespaces ► Sitecore.Resources.Media ► MediaUri ► Language
Gets the language.
Declaration Syntax
C#
public virtual Language Language { get; set; }
Value
The language.


MediaPath Property

MediaPath Property
Namespaces ► Sitecore.Resources.Media ► MediaUri ► MediaPath
Gets the media path.
Declaration Syntax
C#
public virtual string MediaPath { get; set; }
Value
The media path.


Parse Method (item)

Parse Method (item)
Namespaces ► Sitecore.Resources.Media ► MediaUri ► Parse(Item)
Parses the specified item into a URI.
Declaration Syntax
C#
public static MediaUri Parse(
    Item item
)
Parameters
item (Item)
The item.
Return Value


Version Property

Version Property
Namespaces ► Sitecore.Resources.Media ► MediaUri ► Version
Gets the version of the media.
Declaration Syntax
C#
public virtual Version Version { get; set; }
Value
The version.


MediaUrlOptions Class

MediaUrlOptions Class
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions
Represents a Media Query String.
Declaration Syntax
C#
public class MediaUrlOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaUrlOptions()()() | Initializes a new instance of the MediaUrlOptions class.
 | MediaUrlOptions(Int32, Int32, Boolean) | Initializes a new instance of the MediaUrlOptions class.
 | MediaUrlOptions(Database) | Initializes a new instance of the MediaUrlOptions class.
 | MediaUrlOptions(Database, Boolean) | Initializes a new instance of the MediaUrlOptions class.
 | AbsolutePath | Gets or sets a value indicating whether to use a absolute or relative path.
 | AllowStretch | Gets or sets a value indicating whether stretching is allowed.
 | BackgroundColor | Gets or sets the color of the background.
 | Database | Gets or sets the database.
 | DefaultIcon | Gets or sets the default icon.
 | DisableBrowserCache | Gets or sets a value indicating whether the MediaUrlOptions disables the browser cache.
 | DisableMediaCache | Gets or sets a value indicating whether the MediaUrlOptions disables the media cache.
 | Empty | Gets the empty MediaQueryString.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDatabase(HttpRequest) | Gets the database from the request URL.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLanguage(HttpRequest) | Gets the language from the request URL.
 | GetThumbnailOptions(MediaItem) | Gets the thumbnail.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersion(HttpRequest) | Gets the version from the request URL.
 | Height | Gets or sets the height.
 | ItemRevision | Gets or sets the item revision.
 | Language | Gets or sets the language.
 | MaxHeight | Gets or sets the max height.
 | MaxWidth | Gets or sets the max width.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseQueryString(HttpRequest) | Parses the query string.
 | Scale | Gets or sets the scale.
 | Thumbnail | Gets or sets a value indicating whether this MediaUrlOptions is thumbnail.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | UseDefaultIcon | Gets or sets a value indicating whether the MediaUrlOptions uses the default icon.
 | UseItemPath | Gets or sets a value indicating whether t use the item path when building media URLs.
 | Version | Gets or sets the version.
 | Width | Gets or sets the width.
Inheritance Hierarchy
Object
MediaUrlOptions


MediaUrlOptions Constructor

MediaUrlOptions Constructor
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► MediaUrlOptions()()()
Members
Icon | Member | Description
 | MediaUrlOptions()()() | Initializes a new instance of the MediaUrlOptions class.
 | MediaUrlOptions(Int32, Int32, Boolean) | Initializes a new instance of the MediaUrlOptions class.
 | MediaUrlOptions(Database) | Initializes a new instance of the MediaUrlOptions class.
 | MediaUrlOptions(Database, Boolean) | Initializes a new instance of the MediaUrlOptions class.


MediaUrlOptions Constructor

MediaUrlOptions Constructor
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► MediaUrlOptions()()()
Initializes a new instance of the MediaUrlOptions class.
Declaration Syntax
C#
public MediaUrlOptions()


MediaUrlOptions Constructor (database)

MediaUrlOptions Constructor (database)
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► MediaUrlOptions(Database)
Initializes a new instance of the MediaUrlOptions class.
Declaration Syntax
C#
public MediaUrlOptions(
    Database database
)
Parameters
database (Database)
The database.


MediaUrlOptions Constructor (database, thumbnail)

MediaUrlOptions Constructor (database, thumbnail)
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► MediaUrlOptions(Database, Boolean)
Initializes a new instance of the MediaUrlOptions class.
Declaration Syntax
C#
public MediaUrlOptions(
    Database database,
    bool thumbnail
)
Parameters
database (Database)
The database.
thumbnail (Boolean)
if set to true this instance is thumbnail.


MediaUrlOptions Constructor (width, height, thumbnail)

MediaUrlOptions Constructor (width, height, thumbnail)
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► MediaUrlOptions(Int32, Int32, Boolean)
Initializes a new instance of the MediaUrlOptions class.
Declaration Syntax
C#
public MediaUrlOptions(
    int width,
    int height,
    bool thumbnail
)
Parameters
width (Int32)
The width.
height (Int32)
The height.
thumbnail (Boolean)
if set to true this instance is thumbnail.


AbsolutePath Property

AbsolutePath Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► AbsolutePath
Gets or sets a value indicating whether to use a absolute or relative path.
Declaration Syntax
C#
public bool AbsolutePath { get; set; }
Value
true if the path is absolute; otherwise, false.


AllowStretch Property

AllowStretch Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► AllowStretch
Gets or sets a value indicating whether stretching is allowed.
Declaration Syntax
C#
public bool AllowStretch { get; set; }
Value
true if stretching is allowed; otherwise, false.


BackgroundColor Property

BackgroundColor Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► BackgroundColor
Gets or sets the color of the background.
Declaration Syntax
C#
public Color BackgroundColor { get; set; }
Value
The color of the background.


Database Property

Database Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► Database
Gets or sets the database.
Declaration Syntax
C#
public Database Database { get; set; }
Value
The database.


DefaultIcon Property

DefaultIcon Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► DefaultIcon
Gets or sets the default icon.
Declaration Syntax
C#
public string DefaultIcon { get; set; }
Value
The default icon.


DisableBrowserCache Property

DisableBrowserCache Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► DisableBrowserCache
Gets or sets a value indicating whether the MediaUrlOptions disables the browser cache.
Declaration Syntax
C#
public bool DisableBrowserCache { get; set; }
Value
true if the MediaUrlOptions disables the browser cache; otherwise, false.


DisableMediaCache Property

DisableMediaCache Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► DisableMediaCache
Gets or sets a value indicating whether the MediaUrlOptions disables the media cache.
Declaration Syntax
C#
public bool DisableMediaCache { get; set; }
Value
true if the MediaUrlOptions disables the media cache; otherwise, false.


Empty Property

Empty Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► Empty
Gets the empty MediaQueryString.
Declaration Syntax
C#
public static MediaUrlOptions Empty { get; set; }
Value
The empty MediaQueryString.


GetDatabase Method (httpRequest)

GetDatabase Method (httpRequest)
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► GetDatabase(HttpRequest)
Gets the database from the request URL.
Declaration Syntax
C#
protected virtual Database GetDatabase(
    HttpRequest httpRequest
)
Parameters
httpRequest (HttpRequest)
Return Value


GetLanguage Method (httpRequest)

GetLanguage Method (httpRequest)
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► GetLanguage(HttpRequest)
Gets the language from the request URL.
Declaration Syntax
C#
protected virtual Language GetLanguage(
    HttpRequest httpRequest
)
Parameters
httpRequest (HttpRequest)
Return Value


GetThumbnailOptions Method (item)

GetThumbnailOptions Method (item)
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► GetThumbnailOptions(MediaItem)
Gets the thumbnail.
Declaration Syntax
C#
public static MediaUrlOptions GetThumbnailOptions(
    MediaItem item
)
Parameters
item (MediaItem)
The item.
Return Value
The thumbnail.


GetVersion Method (httpRequest)

GetVersion Method (httpRequest)
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► GetVersion(HttpRequest)
Gets the version from the request URL.
Declaration Syntax
C#
protected virtual Version GetVersion(
    HttpRequest httpRequest
)
Parameters
httpRequest (HttpRequest)
Return Value


Height Property

Height Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► Height
Gets or sets the height.
Declaration Syntax
C#
public int Height { get; set; }
Value
The height.


ItemRevision Property

ItemRevision Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► ItemRevision
Gets or sets the item revision.
Declaration Syntax
C#
public string ItemRevision { get; set; }
Value
The item revision.


Language Property

Language Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► Language
Gets or sets the language.
Declaration Syntax
C#
public Language Language { get; set; }
Value
The language.


MaxHeight Property

MaxHeight Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► MaxHeight
Gets or sets the max height.
Declaration Syntax
C#
public int MaxHeight { get; set; }
Value
The max height.


MaxWidth Property

MaxWidth Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► MaxWidth
Gets or sets the max width.
Declaration Syntax
C#
public int MaxWidth { get; set; }
Value
The max width.


ParseQueryString Method (httpRequest)

ParseQueryString Method (httpRequest)
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► ParseQueryString(HttpRequest)
Parses the query string.
Declaration Syntax
C#
public void ParseQueryString(
    HttpRequest httpRequest
)
Parameters
httpRequest (HttpRequest)


Scale Property

Scale Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► Scale
Gets or sets the scale.
Declaration Syntax
C#
public float Scale { get; set; }
Value
The scale.


Thumbnail Property

Thumbnail Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► Thumbnail
Gets or sets a value indicating whether this MediaUrlOptions is thumbnail.
Declaration Syntax
C#
public bool Thumbnail { get; set; }
Value
true if thumbnail; otherwise, false.


ToString Method

ToString Method
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


UseDefaultIcon Property

UseDefaultIcon Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► UseDefaultIcon
Gets or sets a value indicating whether the MediaUrlOptions uses the default icon.
Declaration Syntax
C#
public bool UseDefaultIcon { get; set; }
Value
true if the MediaUrlOptions uses the default icon; otherwise, false.


UseItemPath Property

UseItemPath Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► UseItemPath
Gets or sets a value indicating whether t use the item path when building media URLs.
Declaration Syntax
C#
public bool UseItemPath { get; set; }
Remarks
By default, the item (short) id will be used for the media URLs.


Version Property

Version Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► Version
Gets or sets the version.
Declaration Syntax
C#
public Version Version { get; set; }
Value
The version.


Width Property

Width Property
Namespaces ► Sitecore.Resources.Media ► MediaUrlOptions ► Width
Gets or sets the width.
Declaration Syntax
C#
public int Width { get; set; }
Value
The width.


MediaValidator Class

MediaValidator Class
Namespaces ► Sitecore.Resources.Media ► MediaValidator
Represents a Media Validator.
Declaration Syntax
C#
public class MediaValidator
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MediaValidator()()() | Initializes a new instance of the MediaValidator class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasField(Item, String) | Determines whether the specified item has field.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Validate(MediaItem, MediaValidatorResult) | Validates the specified item.
 | ValidateItem(MediaItem, MediaValidatorResult) | Validates the specified output.
Inheritance Hierarchy
Object
 | MediaValidator
 |  | ImageValidator


MediaValidator Constructor

MediaValidator Constructor
Namespaces ► Sitecore.Resources.Media ► MediaValidator ► MediaValidator()()()
Initializes a new instance of the MediaValidator class
Declaration Syntax
C#
public MediaValidator()


HasField Method (item, fieldName)

HasField Method (item, fieldName)
Namespaces ► Sitecore.Resources.Media ► MediaValidator ► HasField(Item, String)
Determines whether the specified item has field.
Declaration Syntax
C#
protected static bool HasField(
    Item item,
    string fieldName
)
Parameters
item (Item)
The item.
fieldName (String)
Name of the field.
Return Value
true if the specified item has field; otherwise, false.


Validate Method (item, results)

Validate Method (item, results)
Namespaces ► Sitecore.Resources.Media ► MediaValidator ► Validate(MediaItem, MediaValidatorResult)
Validates the specified item.
Declaration Syntax
C#
public void Validate(
    MediaItem item,
    MediaValidatorResult results
)
Parameters
item (MediaItem)
The item.
results (MediaValidatorResult)
The results.


ValidateItem Method (item, results)

ValidateItem Method (item, results)
Namespaces ► Sitecore.Resources.Media ► MediaValidator ► ValidateItem(MediaItem, MediaValidatorResult)
Validates the specified output.
Declaration Syntax
C#
protected virtual void ValidateItem(
    MediaItem item,
    MediaValidatorResult results
)
Parameters
item (MediaItem)
The item.
results (MediaValidatorResult)
The warnings.


MediaValidatorFormatter Class

MediaValidatorFormatter Class
Namespaces ► Sitecore.Resources.Media ► MediaValidatorFormatter
Represents a Media Meta Data Formatter.
Declaration Syntax
C#
public class MediaValidatorFormatter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MediaValidatorFormatter()()() | Initializes a new instance of the MediaValidatorFormatter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Format(MediaValidatorResult, MediaValidatorFormatterOutput) | Formats the specified meta data.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MediaValidatorFormatter


MediaValidatorFormatter Constructor

MediaValidatorFormatter Constructor
Namespaces ► Sitecore.Resources.Media ► MediaValidatorFormatter ► MediaValidatorFormatter()()()
Initializes a new instance of the MediaValidatorFormatter class
Declaration Syntax
C#
public MediaValidatorFormatter()


Format Method (results, output)

Format Method (results, output)
Namespaces ► Sitecore.Resources.Media ► MediaValidatorFormatter ► Format(MediaValidatorResult, MediaValidatorFormatterOutput)
Formats the specified meta data.
Declaration Syntax
C#
public string Format(
    MediaValidatorResult results,
    MediaValidatorFormatterOutput output
)
Parameters
results (MediaValidatorResult)
The warnings.
output (MediaValidatorFormatterOutput)
The output.
Return Value
The format.


MediaValidatorFormatterOutput Enumeration

MediaValidatorFormatterOutput Enumeration
Namespaces ► Sitecore.Resources.Media ► MediaValidatorFormatterOutput
Defines the output formatting of a Media Validator Formatter.
Declaration Syntax
C#
public enum MediaValidatorFormatterOutput
Members
Member | Description
Unformatted | Unformatted.
HtmlPopup | HTML with a popup.
HtmlWithMore | HTML as two rows.


MediaValidatorResult Class

MediaValidatorResult Class
Namespaces ► Sitecore.Resources.Media ► MediaValidatorResult
Represents a collection of Media Meta Data.
Declaration Syntax
C#
public class MediaValidatorResult
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaValidatorResult()()() | Initializes a new instance of the MediaValidatorResult class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Warnings | Gets the warnings.
Inheritance Hierarchy
Object
MediaValidatorResult


MediaValidatorResult Constructor

MediaValidatorResult Constructor
Namespaces ► Sitecore.Resources.Media ► MediaValidatorResult ► MediaValidatorResult()()()
Initializes a new instance of the MediaValidatorResult class
Declaration Syntax
C#
public MediaValidatorResult()


Warnings Property

Warnings Property
Namespaces ► Sitecore.Resources.Media ► MediaValidatorResult ► Warnings
Gets the warnings.
Declaration Syntax
C#
public List<string> Warnings { get; }
Value
The warnings.


MimeResolver Class

MimeResolver Class
Namespaces ► Sitecore.Resources.Media ► MimeResolver
MimeResolver class
Declaration Syntax
C#
public class MimeResolver
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MimeResolver()()() | Initializes a new instance of the MimeResolver class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMimeType(String) | Gets a MIME type from a 'file' extension.
 | GetMimeType(MediaItem) | Gets a MIME type from a media item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MimeResolver


MimeResolver Constructor

MimeResolver Constructor
Namespaces ► Sitecore.Resources.Media ► MimeResolver ► MimeResolver()()()
Initializes a new instance of the MimeResolver class
Declaration Syntax
C#
public MimeResolver()


GetMimeType Method

GetMimeType Method
Namespaces ► Sitecore.Resources.Media ► MimeResolver ► GetMimeType()()()
Members
Icon | Member | Description
 | GetMimeType(String) | Gets a MIME type from a 'file' extension.
 | GetMimeType(MediaItem) | Gets a MIME type from a media item.


GetMimeType Method (item)

GetMimeType Method (item)
Namespaces ► Sitecore.Resources.Media ► MimeResolver ► GetMimeType(MediaItem)
Gets a MIME type from a media item.
Declaration Syntax
C#
public virtual string GetMimeType(
    MediaItem item
)
Parameters
item (MediaItem)
The item.
Return Value


GetMimeType Method (extension)

GetMimeType Method (extension)
Namespaces ► Sitecore.Resources.Media ► MimeResolver ► GetMimeType(String)
Gets a MIME type from a 'file' extension.
Declaration Syntax
C#
public virtual string GetMimeType(
    string extension
)
Parameters
extension (String)
The extension.
Return Value


Mp3Media Class

Mp3Media Class
Namespaces ► Sitecore.Resources.Media ► Mp3Media
ImageMedia class
Declaration Syntax
C#
public class Mp3Media : Media
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Mp3Media()()() | Initializes a new instance of the Mp3Media class
 | AddMetaData(MediaMetaDataCollection) | Adds the meta data to the collection. (Inherited from Media.)
 | ClearFields(array<String>[]()[]) | Clears the specified fields in the inner item. (Inherited from Media.)
 | ClearMetaData()()() | Clears the meta data of a media item. (Overrides Media.ClearMetaData()()().)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides Media.Clone()()().)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extension | Gets the file extension of the media. (Inherited from Media.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMetaData(MediaMetaDataCollection) | Gets the meta data. (Inherited from Media.)
 | GetStream()()() | Opens the stream associated with the media. (Inherited from Media.)
 | GetStream(MediaOptions) | Opens the stream associated with the media. (Inherited from Media.)
 | GetStreamFromPipeline(MediaOptions) | Gets the stream from the pipeline 'getMediaStream'. (Inherited from Media.)
 | GetThumbnailStream()()() | Gets a thumbnail for the media. (Inherited from Media.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(MediaData) | Initializes this instance. Used after cloning. (Inherited from Media.)
 | MediaData | Gets the media data. (Inherited from Media.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MimeType | Gets the MIME type of the media. (Inherited from Media.)
 | ReleaseStream()()() | Releases the stream. (Inherited from Media.)
 | SetStream(MediaStream) | Opens the stream associated with the media. (Inherited from Media.)
 | SetStream(Stream, String) | Sets the stream. (Inherited from Media.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateMetaData(MediaStream) | Updates the meta data of a media item. (Overrides Media.UpdateMetaData(MediaStream).)
Inheritance Hierarchy
Object
 | Media
 |  | Mp3Media


Mp3Media Constructor

Mp3Media Constructor
Namespaces ► Sitecore.Resources.Media ► Mp3Media ► Mp3Media()()()
Initializes a new instance of the Mp3Media class
Declaration Syntax
C#
public Mp3Media()


ClearMetaData Method

ClearMetaData Method
Namespaces ► Sitecore.Resources.Media ► Mp3Media ► ClearMetaData()()()
Clears the meta data of a media item.
Declaration Syntax
C#
protected override void ClearMetaData()


Clone Method

Clone Method
Namespaces ► Sitecore.Resources.Media ► Mp3Media ► Clone()()()
Clones the source object. Has the same effect as creating a new instance of the type.
Declaration Syntax
C#
public override Media Clone()
Return Value


UpdateMetaData Method (mediaStream)

UpdateMetaData Method (mediaStream)
Namespaces ► Sitecore.Resources.Media ► Mp3Media ► UpdateMetaData(MediaStream)
Updates the meta data of a media item.
Declaration Syntax
C#
protected override void UpdateMetaData(
    MediaStream mediaStream
)
Parameters
mediaStream (MediaStream)


ResizeProcessor Class

ResizeProcessor Class
Namespaces ► Sitecore.Resources.Media ► ResizeProcessor
ResizeProcessor class
Declaration Syntax
C#
public class ResizeProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ResizeProcessor()()() | Initializes a new instance of the ResizeProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetMediaStreamPipelineArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ResizeProcessor


ResizeProcessor Constructor

ResizeProcessor Constructor
Namespaces ► Sitecore.Resources.Media ► ResizeProcessor ► ResizeProcessor()()()
Initializes a new instance of the ResizeProcessor class
Declaration Syntax
C#
public ResizeProcessor()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Resources.Media ► ResizeProcessor ► Process(GetMediaStreamPipelineArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    GetMediaStreamPipelineArgs args
)
Parameters
args (GetMediaStreamPipelineArgs)


SwfMedia Class

SwfMedia Class
Namespaces ► Sitecore.Resources.Media ► SwfMedia
SwfMedia class
Declaration Syntax
C#
public class SwfMedia : Media
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SwfMedia()()() | Initializes a new instance of the SwfMedia class
 | AddMetaData(MediaMetaDataCollection) | Adds the meta data to the collection. (Inherited from Media.)
 | ClearFields(array<String>[]()[]) | Clears the specified fields in the inner item. (Inherited from Media.)
 | ClearMetaData()()() | Clears the meta data of a media item. (Overrides Media.ClearMetaData()()().)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides Media.Clone()()().)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extension | Gets the file extension of the media. (Inherited from Media.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMetaData(MediaMetaDataCollection) | Gets the meta data. (Inherited from Media.)
 | GetStream()()() | Opens the stream associated with the media. (Inherited from Media.)
 | GetStream(MediaOptions) | Opens the stream associated with the media. (Inherited from Media.)
 | GetStreamFromPipeline(MediaOptions) | Gets the stream from the pipeline 'getMediaStream'. (Inherited from Media.)
 | GetThumbnailStream()()() | Gets a thumbnail for the media. (Inherited from Media.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(MediaData) | Initializes this instance. Used after cloning. (Inherited from Media.)
 | MediaData | Gets the media data. (Inherited from Media.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MimeType | Gets the MIME type of the media. (Inherited from Media.)
 | ReleaseStream()()() | Releases the stream. (Inherited from Media.)
 | SetStream(MediaStream) | Opens the stream associated with the media. (Overrides Media.SetStream(MediaStream).)
 | SetStream(Stream, String) | Sets the stream. (Inherited from Media.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateMetaData(MediaStream) | Updates the meta data of a media item. (Overrides Media.UpdateMetaData(MediaStream).)
Inheritance Hierarchy
Object
 | Media
 |  | SwfMedia


SwfMedia Constructor

SwfMedia Constructor
Namespaces ► Sitecore.Resources.Media ► SwfMedia ► SwfMedia()()()
Initializes a new instance of the SwfMedia class
Declaration Syntax
C#
public SwfMedia()


ClearMetaData Method

ClearMetaData Method
Namespaces ► Sitecore.Resources.Media ► SwfMedia ► ClearMetaData()()()
Clears the meta data of a media item.
Declaration Syntax
C#
protected override void ClearMetaData()


Clone Method

Clone Method
Namespaces ► Sitecore.Resources.Media ► SwfMedia ► Clone()()()
Clones the source object. Has the same effect as creating a new instance of the type.
Declaration Syntax
C#
public override Media Clone()
Return Value


SetStream Method (mediaStream)

SetStream Method (mediaStream)
Namespaces ► Sitecore.Resources.Media ► SwfMedia ► SetStream(MediaStream)
Opens the stream associated with the media.
Declaration Syntax
C#
public override void SetStream(
    MediaStream mediaStream
)
Parameters
mediaStream (MediaStream)


UpdateMetaData Method (mediaStream)

UpdateMetaData Method (mediaStream)
Namespaces ► Sitecore.Resources.Media ► SwfMedia ► UpdateMetaData(MediaStream)
Updates the meta data of a media item.
Declaration Syntax
C#
protected override void UpdateMetaData(
    MediaStream mediaStream
)
Parameters
mediaStream (MediaStream)


ThumbnailCreator Class

ThumbnailCreator Class
Namespaces ► Sitecore.Resources.Media ► ThumbnailCreator
Summary description for ThumbnailCreator.
Declaration Syntax
C#
public class ThumbnailCreator : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ThumbnailCreator()()() | Initializes a new instance of the ThumbnailCreator class.
 | DesiredSize | Gets or sets the size of the desired.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Releases unmanaged resources and performs other cleanup operations before the ThumbnailCreator is reclaimed by garbage collection. (Overrides Object.Finalize()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetThumbnail(String) | Gets the thumbnail.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ThumbNail | Gets the thumbnail.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ThumbnailCreator


ThumbnailCreator Constructor

ThumbnailCreator Constructor
Namespaces ► Sitecore.Resources.Media ► ThumbnailCreator ► ThumbnailCreator()()()
Initializes a new instance of the ThumbnailCreator class.
Declaration Syntax
C#
public ThumbnailCreator()


DesiredSize Property

DesiredSize Property
Namespaces ► Sitecore.Resources.Media ► ThumbnailCreator ► DesiredSize
Gets or sets the size of the desired.
Declaration Syntax
C#
public Size DesiredSize { get; set; }
Value
The size of the desired.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Resources.Media ► ThumbnailCreator ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


Finalize Method

Finalize Method
Namespaces ► Sitecore.Resources.Media ► ThumbnailCreator ► Finalize()()()
Releases unmanaged resources and performs other cleanup operations before the ThumbnailCreator is reclaimed by garbage collection.
Declaration Syntax
C#
protected override void Finalize()


GetThumbnail Method (file)

GetThumbnail Method (file)
Namespaces ► Sitecore.Resources.Media ► ThumbnailCreator ► GetThumbnail(String)
Gets the thumbnail.
Declaration Syntax
C#
public Bitmap GetThumbnail(
    string file
)
Parameters
file (String)
The file.
Return Value
The thumbnail.


ThumbNail Property

ThumbNail Property
Namespaces ► Sitecore.Resources.Media ► ThumbnailCreator ► ThumbNail
Gets the thumbnail.
Declaration Syntax
C#
public Bitmap ThumbNail { get; }
Value
The thumbnail.


ThumbnailGenerator Class

ThumbnailGenerator Class
Namespaces ► Sitecore.Resources.Media ► ThumbnailGenerator
Represents a Thumbnail Generator.
Declaration Syntax
C#
public abstract class ThumbnailGenerator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ThumbnailGenerator()()() | Initializes a new instance of the ThumbnailGenerator class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extension | Gets or sets the file extension describing the format of the thumbnail.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFileStream(String, TransformationOptions) | Gets a stream from a file.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetImageFormat()()() | Gets the image format to use for generating streams.
 | GetImageStream(Stream, TransformationOptions) | Gets a stream from an image stream.
 | GetStream(MediaData, TransformationOptions) | Gets the stream of the thumbnail image.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MimeType | Gets the MIME type of the generated thumbnails.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ThumbnailGenerator
 |  | ImageThumbnailGenerator
 |  | MediaThumbnailGenerator


ThumbnailGenerator Constructor

ThumbnailGenerator Constructor
Namespaces ► Sitecore.Resources.Media ► ThumbnailGenerator ► ThumbnailGenerator()()()
Initializes a new instance of the ThumbnailGenerator class
Declaration Syntax
C#
protected ThumbnailGenerator()


Extension Property

Extension Property
Namespaces ► Sitecore.Resources.Media ► ThumbnailGenerator ► Extension
Gets or sets the file extension describing the format of the thumbnail.
Declaration Syntax
C#
public virtual string Extension { get; set; }
Value
The extension.


GetFileStream Method (filePath, options)

GetFileStream Method (filePath, options)
Namespaces ► Sitecore.Resources.Media ► ThumbnailGenerator ► GetFileStream(String, TransformationOptions)
Gets a stream from a file.
Declaration Syntax
C#
protected virtual Stream GetFileStream(
    string filePath,
    TransformationOptions options
)
Parameters
filePath (String)
The file path.
options (TransformationOptions)
The options.
Return Value


GetImageFormat Method

GetImageFormat Method
Namespaces ► Sitecore.Resources.Media ► ThumbnailGenerator ► GetImageFormat()()()
Gets the image format to use for generating streams.
Declaration Syntax
C#
protected virtual ImageFormat GetImageFormat()
Return Value


GetImageStream Method (inputStream, options)

GetImageStream Method (inputStream, options)
Namespaces ► Sitecore.Resources.Media ► ThumbnailGenerator ► GetImageStream(Stream, TransformationOptions)
Gets a stream from an image stream.
Declaration Syntax
C#
protected Stream GetImageStream(
    Stream inputStream,
    TransformationOptions options
)
Parameters
inputStream (Stream)
The stream containing the image data.
options (TransformationOptions)
The options.
Return Value


GetStream Method (mediaData, options)

GetStream Method (mediaData, options)
Namespaces ► Sitecore.Resources.Media ► ThumbnailGenerator ► GetStream(MediaData, TransformationOptions)
Gets the stream of the thumbnail image.
Declaration Syntax
C#
public abstract MediaStream GetStream(
    MediaData mediaData,
    TransformationOptions options
)
Parameters
mediaData (MediaData)
The media data to generate a thumbnail for.
options (TransformationOptions)
The options.
Return Value


MimeType Property

MimeType Property
Namespaces ► Sitecore.Resources.Media ► ThumbnailGenerator ► MimeType
Gets the MIME type of the generated thumbnails.
Declaration Syntax
C#
public virtual string MimeType { get; }
Value
The type of the MIME.


ThumbnailProcessor Class

ThumbnailProcessor Class
Namespaces ► Sitecore.Resources.Media ► ThumbnailProcessor
ThumbnailProcessor class
Declaration Syntax
C#
public class ThumbnailProcessor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ThumbnailProcessor()()() | Initializes a new instance of the ThumbnailProcessor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(GetMediaStreamPipelineArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ThumbnailProcessor


ThumbnailProcessor Constructor

ThumbnailProcessor Constructor
Namespaces ► Sitecore.Resources.Media ► ThumbnailProcessor ► ThumbnailProcessor()()()
Initializes a new instance of the ThumbnailProcessor class
Declaration Syntax
C#
public ThumbnailProcessor()


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Resources.Media ► ThumbnailProcessor ► Process(GetMediaStreamPipelineArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    GetMediaStreamPipelineArgs args
)
Parameters
args (GetMediaStreamPipelineArgs)


TransformationOptions Class

TransformationOptions Class
Namespaces ► Sitecore.Resources.Media ► TransformationOptions
ImageOptions class
Declaration Syntax
C#
public class TransformationOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TransformationOptions()()() | Initializes a new instance of the TransformationOptions class
 | AllowStretch | Gets or sets a value indicating whether stretching is allowed.
 | BackgroundColor | Gets or sets the background color to use when scaling images.
 | Clone()()() | Clones this instance.
 | ContainsResizing()()() | Determines whether the options contains resizing.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MaxSize | Gets or sets the max size.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreserveResolution | Gets or sets a value indicating whether the TransformationOptions preserves the resolution from original image. When generating thumbnails, default resolution is used (96dpi), not the resolution from original image.
 | Scale | Gets the scale.
 | Size | Gets or sets the size.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TransformationOptions


TransformationOptions Constructor

TransformationOptions Constructor
Namespaces ► Sitecore.Resources.Media ► TransformationOptions ► TransformationOptions()()()
Initializes a new instance of the TransformationOptions class
Declaration Syntax
C#
public TransformationOptions()


AllowStretch Property

AllowStretch Property
Namespaces ► Sitecore.Resources.Media ► TransformationOptions ► AllowStretch
Gets or sets a value indicating whether stretching is allowed.
Declaration Syntax
C#
public bool AllowStretch { get; set; }
Value
true if stretching is allowed; otherwise, false.


BackgroundColor Property

BackgroundColor Property
Namespaces ► Sitecore.Resources.Media ► TransformationOptions ► BackgroundColor
Gets or sets the background color to use when scaling images.
Declaration Syntax
C#
public Color BackgroundColor { get; set; }
Value
The color of the background.


Clone Method

Clone Method
Namespaces ► Sitecore.Resources.Media ► TransformationOptions ► Clone()()()
Clones this instance.
Declaration Syntax
C#
public TransformationOptions Clone()
Return Value


ContainsResizing Method

ContainsResizing Method
Namespaces ► Sitecore.Resources.Media ► TransformationOptions ► ContainsResizing()()()
Determines whether the options contains resizing.
Declaration Syntax
C#
public bool ContainsResizing()
Return Value
true if this instance contains resizing; otherwise, false.


MaxSize Property

MaxSize Property
Namespaces ► Sitecore.Resources.Media ► TransformationOptions ► MaxSize
Gets or sets the max size.
Declaration Syntax
C#
public Size MaxSize { get; set; }
Value
The max size.


PreserveResolution Property

PreserveResolution Property
Namespaces ► Sitecore.Resources.Media ► TransformationOptions ► PreserveResolution
Gets or sets a value indicating whether the TransformationOptions preserves the resolution from original image. When generating thumbnails, default resolution is used (96dpi), not the resolution from original image.
Declaration Syntax
C#
public bool PreserveResolution { get; set; }
Value
true if the TransformationOptions preserves the resolution; otherwise, false. Default is true.


Scale Property

Scale Property
Namespaces ► Sitecore.Resources.Media ► TransformationOptions ► Scale
Gets the scale.
Declaration Syntax
C#
public float Scale { get; set; }
Value
The scale.
Remarks
Note that Scale takes precedence over Size, so after assigning a value to Scale, Size will be ignored.


Size Property

Size Property
Namespaces ► Sitecore.Resources.Media ► TransformationOptions ► Size
Gets or sets the size.
Declaration Syntax
C#
public Size Size { get; set; }
Value
The size.


UploadWatcher Class

UploadWatcher Class
Namespaces ► Sitecore.Resources.Media ► UploadWatcher
Monitors the /Upload folder for changes for files.
Declaration Syntax
C#
public class UploadWatcher : FileWatcher
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UploadWatcher()()() | Initializes a new instance of the UploadWatcher class.
 | Created(String) | Called when a file or folder has been created. (Overrides FileWatcher.Created(String).)
 | Deleted(String) | Called when a file has been deleted. (Overrides FileWatcher.Deleted(String).)
 | Dispose()()() | Application shutdown handler (Inherited from FileWatcher.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(HttpApplication) | Application startup handler (Inherited from FileWatcher.)
 | InitializeWatcher(String, String) | Initializes a file watcher. (Inherited from FileWatcher.)
 | InitializeWorker()()() | Initializes the worker. (Inherited from FileWatcher.)
 | MapPathToSiteCore(String, String, String) | Maps the path to a Sitecore path. (Inherited from FileWatcher.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnFileCreated(Object, FileSystemEventArgs) | File has been created. (Inherited from FileWatcher.)
 | OnFileDeleted(Object, FileSystemEventArgs) | File has been deleted. (Inherited from FileWatcher.)
 | OnFileRenamed(Object, RenamedEventArgs) | File has been renamed. (Inherited from FileWatcher.)
 | PathShouldBeIngnored(String) | Checks whether the pathes the should be ingnored. (Inherited from FileWatcher.)
 | Renamed(String, String) | Called when a file has been renamed. (Overrides FileWatcher.Renamed(String, String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FileWatcher
 |  | UploadWatcher


UploadWatcher Constructor

UploadWatcher Constructor
Namespaces ► Sitecore.Resources.Media ► UploadWatcher ► UploadWatcher()()()
Initializes a new instance of the UploadWatcher class.
Declaration Syntax
C#
public UploadWatcher()


Created Method (filePath)

Created Method (filePath)
Namespaces ► Sitecore.Resources.Media ► UploadWatcher ► Created(String)
Called when a file or folder has been created.
Declaration Syntax
C#
protected override void Created(
    string filePath
)
Parameters
filePath (String)
The path.


Deleted Method (filePath)

Deleted Method (filePath)
Namespaces ► Sitecore.Resources.Media ► UploadWatcher ► Deleted(String)
Called when a file has been deleted.
Declaration Syntax
C#
protected override void Deleted(
    string filePath
)
Parameters
filePath (String)
The full path.


Renamed Method (filePath, oldFilePath)

Renamed Method (filePath, oldFilePath)
Namespaces ► Sitecore.Resources.Media ► UploadWatcher ► Renamed(String, String)
Called when a file has been renamed.
Declaration Syntax
C#
protected override void Renamed(
    string filePath,
    string oldFilePath
)
Parameters
filePath (String)
The full path.
oldFilePath (String)
The old full path.


ZipMedia Class

ZipMedia Class
Namespaces ► Sitecore.Resources.Media ► ZipMedia
ImageMedia class
Declaration Syntax
C#
public class ZipMedia : Media
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZipMedia()()() | Initializes a new instance of the ZipMedia class
 | AddMetaData(MediaMetaDataCollection) | Adds the meta data to the collection. (Inherited from Media.)
 | ClearFields(array<String>[]()[]) | Clears the specified fields in the inner item. (Inherited from Media.)
 | ClearMetaData()()() | Clears the meta data of a media item. (Inherited from Media.)
 | Clone()()() | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides Media.Clone()()().)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extension | Gets the file extension of the media. (Inherited from Media.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMetaData(MediaMetaDataCollection) | Gets the meta data. (Inherited from Media.)
 | GetStream()()() | Opens the stream associated with the media. (Inherited from Media.)
 | GetStream(MediaOptions) | Opens the stream associated with the media. (Inherited from Media.)
 | GetStreamFromPipeline(MediaOptions) | Gets the stream from the pipeline 'getMediaStream'. (Inherited from Media.)
 | GetThumbnailStream()()() | Gets a thumbnail for the media. (Inherited from Media.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(MediaData) | Initializes this instance. Used after cloning. (Inherited from Media.)
 | MediaData | Gets the media data. (Inherited from Media.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MimeType | Gets the MIME type of the media. (Inherited from Media.)
 | ReleaseStream()()() | Releases the stream. (Inherited from Media.)
 | SetStream(MediaStream) | Opens the stream associated with the media. (Inherited from Media.)
 | SetStream(Stream, String) | Sets the stream. (Inherited from Media.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateMetaData(MediaStream) | Updates the meta data of a media item. (Inherited from Media.)
Inheritance Hierarchy
Object
 | Media
 |  | ZipMedia


ZipMedia Constructor

ZipMedia Constructor
Namespaces ► Sitecore.Resources.Media ► ZipMedia ► ZipMedia()()()
Initializes a new instance of the ZipMedia class
Declaration Syntax
C#
public ZipMedia()


Clone Method

Clone Method
Namespaces ► Sitecore.Resources.Media ► ZipMedia ► Clone()()()
Clones the source object. Has the same effect as creating a new instance of the type.
Declaration Syntax
C#
public override Media Clone()
Return Value


ZipMetaDataFormatter Class

ZipMetaDataFormatter Class
Namespaces ► Sitecore.Resources.Media ► ZipMetaDataFormatter
Represents a Zip Meta Data Formatter.
Declaration Syntax
C#
public class ZipMetaDataFormatter : MediaMetaDataFormatter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ZipMetaDataFormatter()()() | Initializes a new instance of the ZipMetaDataFormatter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Format(MediaMetaDataCollection, MediaMetaDataFormatterOutput) | Formats the specified meta data. (Inherited from MediaMetaDataFormatter.)
 | FormatCollection(MediaMetaDataCollection, MediaMetaDataFormatterOutput) | Formats the collection. (Inherited from MediaMetaDataFormatter.)
 | FormatValue(String, String, MediaMetaDataFormatterOutput) | Formats the specified key. (Overrides MediaMetaDataFormatter.FormatValue(String, String, MediaMetaDataFormatterOutput).)
 | FormatValues(MediaMetaDataCollection, MediaMetaDataFormatterOutput) | Formats the values. (Inherited from MediaMetaDataFormatter.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | MediaMetaDataFormatter
 |  | ZipMetaDataFormatter


ZipMetaDataFormatter Constructor

ZipMetaDataFormatter Constructor
Namespaces ► Sitecore.Resources.Media ► ZipMetaDataFormatter ► ZipMetaDataFormatter()()()
Initializes a new instance of the ZipMetaDataFormatter class
Declaration Syntax
C#
public ZipMetaDataFormatter()


FormatValue Method (key, value, output)

FormatValue Method (key, value, output)
Namespaces ► Sitecore.Resources.Media ► ZipMetaDataFormatter ► FormatValue(String, String, MediaMetaDataFormatterOutput)
Formats the specified key.
Declaration Syntax
C#
protected override string FormatValue(
    string key,
    string value,
    MediaMetaDataFormatterOutput output
)
Parameters
key (String)
The key.
value (String)
The value.
output (MediaMetaDataFormatterOutput)
The output.
Return Value
The format.


Sitecore.Resources.Media.Types Namespace

Sitecore.Resources.Media.Types Namespace
Namespaces ► Sitecore.Resources.Media.Types
Declaration Syntax
C#
namespace Sitecore.Resources.Media.Types
Types
All Types Classes
Icon | Type | Description
 | DetailedFileInfo |
 | MediaInfo | Obsolete. Represents information about a media item.


DetailedFileInfo Class

DetailedFileInfo Class
Namespaces ► Sitecore.Resources.Media.Types ► DetailedFileInfo
Declaration Syntax
C#
public class DetailedFileInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DetailedFileInfo(Int32, String) | Initializes a new instance of the DetailedFileInfo class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDetailedFileInfo(String) | Gets the detailed file info.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the value.
Inheritance Hierarchy
Object
DetailedFileInfo


DetailedFileInfo Constructor (id, value)

DetailedFileInfo Constructor (id, value)
Namespaces ► Sitecore.Resources.Media.Types ► DetailedFileInfo ► DetailedFileInfo(Int32, String)
Initializes a new instance of the DetailedFileInfo class.
Declaration Syntax
C#
public DetailedFileInfo(
    int id,
    string value
)
Parameters
id (Int32)
The ID.
value (String)
The value.


GetDetailedFileInfo Method (file)

GetDetailedFileInfo Method (file)
Namespaces ► Sitecore.Resources.Media.Types ► DetailedFileInfo ► GetDetailedFileInfo(String)
Gets the detailed file info.
Declaration Syntax
C#
public static DetailedFileInfo[] GetDetailedFileInfo(
    string file
)
Parameters
file (String)
Return Value


ID Property

ID Property
Namespaces ► Sitecore.Resources.Media.Types ► DetailedFileInfo ► ID
Gets or sets the ID.
Declaration Syntax
C#
public int ID { get; set; }
Value
The ID.


Value Property

Value Property
Namespaces ► Sitecore.Resources.Media.Types ► DetailedFileInfo ► Value
Gets or sets the value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.


MediaInfo Class

MediaInfo Class
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo
Represents information about a media item.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated. Use MediaManager instead")]
public abstract class MediaInfo : Disposable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaInfo(String, String) | Initializes a new instance of the MediaInfo class.
 | CreateThumbnail(String, Int32, Int32, String, ImageFormat) | Creates the thumbnail.
 | Destroy()()() | Destroys this instance. (Inherited from Disposable.)
 | DestroyUnmanagedResources()()() | Destroys the unmanaged resources. (Inherited from Disposable.)
 | Details | Gets the details.
 | Dispose()()() | Disposes the object. (Inherited from Disposable.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extension | Gets the extension.
 | File | Gets the file.
 | FileInfoAuthor | File info author.
 | FileInfoCategory | File info category.
 | FileInfoComment | File info comment.
 | FileInfoSubject | File info subject.
 | FileInfoTitle | File info title.
 | FileInfoType | File info type.
 | Finalize()()() | Releases unmanaged resources and performs other cleanup operations before the Disposable is reclaimed by garbage collection. (Inherited from Disposable.)
 | FullDetails | Gets the full details.
 | GetDetailedFileInfo()()() | Gets the detailed file info.
 | GetDetails()()() | Gets the details.
 | GetFullDetails()()() | Gets the full details.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeight()()() | Gets the height.
 | GetThumbnail(Int32, Int32) | Gets the thumbnail.
 | GetThumbnail(Int32, Int32, String, ImageFormat) | Gets the thumbnail.
 | GetThumbnail(Int32, Int32, String, ImageFormat, String) | Gets the thumbnail.
 | GetThumbnailFilename(String, Int32, Int32, ImageFormat) | Gets the thumbnail filename.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWidth()()() | Gets the width.
 | Height | Gets the height.
 | Master | Gets the master.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | SetFieldValues(Item) | Sets the field values.
 | ShortName | Gets the short name.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateItem(Item) | Updates the item.
 | Width | Gets the width.
Inheritance Hierarchy
Object
 | Disposable
 |  | MediaInfo


MediaInfo Constructor (file, master)

MediaInfo Constructor (file, master)
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► MediaInfo(String, String)
Initializes a new instance of the MediaInfo class.
Declaration Syntax
C#
protected MediaInfo(
    string file,
    string master
)
Parameters
file (String)
The file.
master (String)
The master.


CreateThumbnail Method (filename, width, height, dpi, format)

CreateThumbnail Method (filename, width, height, dpi, format)
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► CreateThumbnail(String, Int32, Int32, String, ImageFormat)
Creates the thumbnail.
Declaration Syntax
C#
protected virtual string CreateThumbnail(
    string filename,
    int width,
    int height,
    string dpi,
    ImageFormat format
)
Parameters
filename (String)
The filename.
width (Int32)
The width.
height (Int32)
The height.
dpi (String)
The dpi.
format (ImageFormat)
The format.
Return Value


Details Property

Details Property
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► Details
Gets the details.
Declaration Syntax
C#
public NameValueCollection Details { get; }
Value
The details.


Extension Property

Extension Property
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► Extension
Gets the extension.
Declaration Syntax
C#
public string Extension { get; }
Value
The extension.


File Property

File Property
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► File
Gets the file.
Declaration Syntax
C#
public string File { get; }
Value
The file.


FileInfoAuthor Field

FileInfoAuthor Field
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► FileInfoAuthor
File info author.
Declaration Syntax
C#
protected const int FileInfoAuthor


FileInfoCategory Field

FileInfoCategory Field
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► FileInfoCategory
File info category.
Declaration Syntax
C#
protected const int FileInfoCategory


FileInfoComment Field

FileInfoComment Field
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► FileInfoComment
File info comment.
Declaration Syntax
C#
protected const int FileInfoComment


FileInfoSubject Field

FileInfoSubject Field
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► FileInfoSubject
File info subject.
Declaration Syntax
C#
protected const int FileInfoSubject


FileInfoTitle Field

FileInfoTitle Field
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► FileInfoTitle
File info title.
Declaration Syntax
C#
protected const int FileInfoTitle


FileInfoType Field

FileInfoType Field
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► FileInfoType
File info type.
Declaration Syntax
C#
protected const int FileInfoType


FullDetails Property

FullDetails Property
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► FullDetails
Gets the full details.
Declaration Syntax
C#
public NameValueCollection FullDetails { get; }
Value
The full details.


GetDetailedFileInfo Method

GetDetailedFileInfo Method
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► GetDetailedFileInfo()()()
Gets the detailed file info.
Declaration Syntax
C#
protected DetailedFileInfo[] GetDetailedFileInfo()
Return Value


GetDetails Method

GetDetails Method
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► GetDetails()()()
Gets the details.
Declaration Syntax
C#
protected virtual NameValueCollection GetDetails()
Return Value


GetFullDetails Method

GetFullDetails Method
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► GetFullDetails()()()
Gets the full details.
Declaration Syntax
C#
protected virtual NameValueCollection GetFullDetails()
Return Value


GetHeight Method

GetHeight Method
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► GetHeight()()()
Gets the height.
Declaration Syntax
C#
protected virtual int GetHeight()
Return Value


GetThumbnail Method

GetThumbnail Method
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► GetThumbnail()()()
Members
Icon | Member | Description
 | GetThumbnail(Int32, Int32) | Gets the thumbnail.
 | GetThumbnail(Int32, Int32, String, ImageFormat) | Gets the thumbnail.
 | GetThumbnail(Int32, Int32, String, ImageFormat, String) | Gets the thumbnail.


GetThumbnail Method (width, height)

GetThumbnail Method (width, height)
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► GetThumbnail(Int32, Int32)
Gets the thumbnail.
Declaration Syntax
C#
public string GetThumbnail(
    int width,
    int height
)
Parameters
width (Int32)
The width.
height (Int32)
The height.
Return Value


GetThumbnail Method (width, height, dpi, format)

GetThumbnail Method (width, height, dpi, format)
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► GetThumbnail(Int32, Int32, String, ImageFormat)
Gets the thumbnail.
Declaration Syntax
C#
public string GetThumbnail(
    int width,
    int height,
    string dpi,
    ImageFormat format
)
Parameters
width (Int32)
The width.
height (Int32)
The height.
dpi (String)
The dpi.
format (ImageFormat)
The format.
Return Value


GetThumbnail Method (width, height, dpi, format, filename)

GetThumbnail Method (width, height, dpi, format, filename)
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► GetThumbnail(Int32, Int32, String, ImageFormat, String)
Gets the thumbnail.
Declaration Syntax
C#
public string GetThumbnail(
    int width,
    int height,
    string dpi,
    ImageFormat format,
    string filename
)
Parameters
width (Int32)
The width.
height (Int32)
The height.
dpi (String)
The dpi.
format (ImageFormat)
The format.
filename (String)
The filename.
Return Value


GetThumbnailFilename Method (file, width, height, format)

GetThumbnailFilename Method (file, width, height, format)
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► GetThumbnailFilename(String, Int32, Int32, ImageFormat)
Gets the thumbnail filename.
Declaration Syntax
C#
protected virtual string GetThumbnailFilename(
    string file,
    int width,
    int height,
    ImageFormat format
)
Parameters
file (String)
The file.
width (Int32)
The width.
height (Int32)
The height.
format (ImageFormat)
The format.
Return Value


GetWidth Method

GetWidth Method
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► GetWidth()()()
Gets the width.
Declaration Syntax
C#
protected virtual int GetWidth()
Return Value


Height Property

Height Property
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► Height
Gets the height.
Declaration Syntax
C#
public int Height { get; }
Value
The height.


Master Property

Master Property
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► Master
Gets the master.
Declaration Syntax
C#
public string Master { get; }
Value
The master.


Name Property

Name Property
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


SetFieldValues Method (item)

SetFieldValues Method (item)
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► SetFieldValues(Item)
Sets the field values.
Declaration Syntax
C#
protected virtual void SetFieldValues(
    Item item
)
Parameters
item (Item)
The item.


ShortName Property

ShortName Property
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► ShortName
Gets the short name.
Declaration Syntax
C#
public string ShortName { get; }
Value
The short name.


UpdateItem Method (item)

UpdateItem Method (item)
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► UpdateItem(Item)
Updates the item.
Declaration Syntax
C#
public void UpdateItem(
    Item item
)
Parameters
item (Item)
The item.


Width Property

Width Property
Namespaces ► Sitecore.Resources.Media.Types ► MediaInfo ► Width
Gets the width.
Declaration Syntax
C#
public int Width { get; }
Value
The width.


Sitecore.Rules Namespace

Sitecore.Rules Namespace
Namespaces ► Sitecore.Rules
Declaration Syntax
C#
namespace Sitecore.Rules
Types
All Types Classes Delegates
Icon | Type | Description
 | ItemEventHandler | Represents an item event handler.
 | Rule<(Of <(T>)>) | Defines the rule class.
 | RuleActionEventHandler<(Of <(T>)>) | The rule action event handler.
 | RuleConditionEventHandler<(Of <(T>)>) | The rule condition event handler.
 | RuleContext | Defines the rule context class.
 | RuleFactory | Defines the rule set factory class.
 | RuleIds | Defines the rule ids class.
 | RuleList<(Of <(T>)>) | Defines a set of rules.
 | RuleStack | Defines the rule stack class.


ItemEventHandler Class

ItemEventHandler Class
Namespaces ► Sitecore.Rules ► ItemEventHandler
Represents an item event handler.
Declaration Syntax
C#
public class ItemEventHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemEventHandler()()() | Initializes a new instance of the ItemEventHandler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnItemDeleted(Object, EventArgs) | Called when the item has been deleted.
 | OnItemSaved(Object, EventArgs) | Called when the item has been saved.
 | OnVersionRemoved(Object, EventArgs) | Called when the item has been deleted.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemEventHandler


ItemEventHandler Constructor

ItemEventHandler Constructor
Namespaces ► Sitecore.Rules ► ItemEventHandler ► ItemEventHandler()()()
Initializes a new instance of the ItemEventHandler class
Declaration Syntax
C#
public ItemEventHandler()


OnItemDeleted Method (sender, args)

OnItemDeleted Method (sender, args)
Namespaces ► Sitecore.Rules ► ItemEventHandler ► OnItemDeleted(Object, EventArgs)
Called when the item has been deleted.
Declaration Syntax
C#
protected void OnItemDeleted(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


OnItemSaved Method (sender, args)

OnItemSaved Method (sender, args)
Namespaces ► Sitecore.Rules ► ItemEventHandler ► OnItemSaved(Object, EventArgs)
Called when the item has been saved.
Declaration Syntax
C#
protected void OnItemSaved(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


OnVersionRemoved Method (sender, args)

OnVersionRemoved Method (sender, args)
Namespaces ► Sitecore.Rules ► ItemEventHandler ► OnVersionRemoved(Object, EventArgs)
Called when the item has been deleted.
Declaration Syntax
C#
protected void OnVersionRemoved(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


Rule(T) Class

Rule<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules ► Rule<(Of <(T>)>)
Defines the rule class.
Declaration Syntax
C#
public class Rule<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Rule<(Of <(T>)>)()()() | Initializes a new instance of the Rule class.
 | Rule<(Of <(T>)>)(RuleCondition<(Of <(T>)>)) | Initializes a new instance of the Rule class.
 | Rule<(Of <(T>)>)(RuleCondition<(Of <(T>)>), RuleAction<(Of <(T>)>)) | Initializes a new instance of the Rule class.
 | Rule<(Of <(T>)>)(RuleCondition<(Of <(T>)>), List<(Of <(RuleAction<(Of <(T>)>)>)>)) | Initializes a new instance of the Rule class.
 | Actions | Gets or sets the actions.
 | Condition | Gets or sets the rule condition.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetCondition(RuleCondition<(Of <(T>)>)) | Sets the condition.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Rule<(Of <(T>)>)


Rule(T) Constructor

Rule<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules ► Rule<(Of <(T>)>) ► Rule<(Of <(T>)>)()()()
Members
Icon | Member | Description
 | Rule<(Of <(T>)>)()()() | Initializes a new instance of the Rule class.
 | Rule<(Of <(T>)>)(RuleCondition<(Of <(T>)>)) | Initializes a new instance of the Rule class.
 | Rule<(Of <(T>)>)(RuleCondition<(Of <(T>)>), RuleAction<(Of <(T>)>)) | Initializes a new instance of the Rule class.
 | Rule<(Of <(T>)>)(RuleCondition<(Of <(T>)>), List<(Of <(RuleAction<(Of <(T>)>)>)>)) | Initializes a new instance of the Rule class.


Rule(T) Constructor

Rule<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules ► Rule<(Of <(T>)>) ► Rule<(Of <(T>)>)()()()
Initializes a new instance of the Rule class.
Declaration Syntax
C#
public Rule()


Rule(T) Constructor (ruleCondition)

Rule<(Of <(T>)>) Constructor (ruleCondition)
Namespaces ► Sitecore.Rules ► Rule<(Of <(T>)>) ► Rule<(Of <(T>)>)(RuleCondition<(Of <(T>)>))
Initializes a new instance of the Rule class.
Declaration Syntax
C#
public Rule(
    RuleCondition<T> ruleCondition
)
Parameters
ruleCondition (RuleCondition <(Of <( T >)>))
The condition.


Rule(T) Constructor (ruleCondition, ruleAction)

Rule<(Of <(T>)>) Constructor (ruleCondition, ruleAction)
Namespaces ► Sitecore.Rules ► Rule<(Of <(T>)>) ► Rule<(Of <(T>)>)(RuleCondition<(Of <(T>)>), RuleAction<(Of <(T>)>))
Initializes a new instance of the Rule class.
Declaration Syntax
C#
public Rule(
    RuleCondition<T> ruleCondition,
    RuleAction<T> ruleAction
)
Parameters
ruleCondition (RuleCondition <(Of <( T >)>))
The condition.
ruleAction (RuleAction <(Of <( T >)>))
The action.


Rule(T) Constructor (ruleCondition, actions)

Rule<(Of <(T>)>) Constructor (ruleCondition, actions)
Namespaces ► Sitecore.Rules ► Rule<(Of <(T>)>) ► Rule<(Of <(T>)>)(RuleCondition<(Of <(T>)>), List<(Of <(RuleAction<(Of <(T>)>)>)>))
Initializes a new instance of the Rule class.
Declaration Syntax
C#
public Rule(
    RuleCondition<T> ruleCondition,
    List<RuleAction<T>> actions
)
Parameters
ruleCondition (RuleCondition <(Of <( T >)>))
The condition.
actions (List<(Of <( RuleAction <(Of <( T >)>)>)>))
The actions.


Actions Property

Actions Property
Namespaces ► Sitecore.Rules ► Rule<(Of <(T>)>) ► Actions
Gets or sets the actions.
Declaration Syntax
C#
public List<RuleAction<T>> Actions { get; set; }
Value
The actions.


Condition Property

Condition Property
Namespaces ► Sitecore.Rules ► Rule<(Of <(T>)>) ► Condition
Gets or sets the rule condition.
Declaration Syntax
C#
public RuleCondition<T> Condition { get; set; }
Value
The rule condition.


SetCondition Method (ruleCondition)

SetCondition Method (ruleCondition)
Namespaces ► Sitecore.Rules ► Rule<(Of <(T>)>) ► SetCondition(RuleCondition<(Of <(T>)>))
Sets the condition.
Declaration Syntax
C#
public void SetCondition(
    RuleCondition<T> ruleCondition
)
Parameters
ruleCondition (RuleCondition <(Of <( T >)>))
The condition.


RuleActionEventHandler(T) Delegate

RuleActionEventHandler<(Of <(T>)>) Delegate
Namespaces ► Sitecore.Rules ► RuleActionEventHandler<(Of <(T>)>)
The rule action event handler.
Declaration Syntax
C#
public delegate void RuleActionEventHandler<T>(
    RuleList<T> ruleList,
    T ruleContext,
    RuleAction<T> action
)
where T : RuleContext
Generic Template Parameters
T
The type of rule context.
Parameters
ruleList (RuleList <(Of <(T>)>))
The rule set.
ruleContext (T)
The rule context.
action (RuleAction <(Of <(T>)>))
The current action.


RuleConditionEventHandler(T) Delegate

RuleConditionEventHandler<(Of <(T>)>) Delegate
Namespaces ► Sitecore.Rules ► RuleConditionEventHandler<(Of <(T>)>)
The rule condition event handler.
Declaration Syntax
C#
public delegate void RuleConditionEventHandler<T>(
    RuleList<T> ruleList,
    T ruleContext,
    Rule<T> rule
)
where T : RuleContext
Generic Template Parameters
T
The type of rule context.
Parameters
ruleList (RuleList <(Of <(T>)>))
The rule set.
ruleContext (T)
The rule context.
rule (Rule <(Of <(T>)>))
The current rule.


RuleContext Class

RuleContext Class
Namespaces ► Sitecore.Rules ► RuleContext
Defines the rule context class.
Declaration Syntax
C#
public class RuleContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RuleContext()()() | Initializes a new instance of the RuleContext class
 | Abort()()() | Aborts the current rule execution.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAborted | Gets a value indicating whether this rule execution is aborted.
 | Item | Gets or sets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleContext
 |  | ConditionalRenderingsRuleContext
 |  | InsertOptionsRuleContext


RuleContext Constructor

RuleContext Constructor
Namespaces ► Sitecore.Rules ► RuleContext ► RuleContext()()()
Initializes a new instance of the RuleContext class
Declaration Syntax
C#
public RuleContext()


Abort Method

Abort Method
Namespaces ► Sitecore.Rules ► RuleContext ► Abort()()()
Aborts the current rule execution.
Declaration Syntax
C#
public void Abort()


IsAborted Property

IsAborted Property
Namespaces ► Sitecore.Rules ► RuleContext ► IsAborted
Gets a value indicating whether this rule execution is aborted.
Declaration Syntax
C#
public bool IsAborted { get; }
Value
true if this rule execution is aborted; otherwise, false.


Item Property

Item Property
Namespaces ► Sitecore.Rules ► RuleContext ► Item
Gets or sets the item.
Declaration Syntax
C#
public Item Item { get; set; }
Value
The context item.


RuleFactory Class

RuleFactory Class
Namespaces ► Sitecore.Rules ► RuleFactory
Defines the rule set factory class.
Declaration Syntax
C#
public static class RuleFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetRules<(Of <(T>)>)(Item, String) | Gets the rule set.
 | GetRules<(Of <(T>)>)(IEnumerable<(Of <(Item>)>), String) | Gets the rule set.
 | InvalidateCache()()() | Invalidates the cache.
 | ParseRules<(Of <(T>)>)(Database, String) | Gets the rule set.
Inheritance Hierarchy
Object
RuleFactory


GetRules Method

GetRules Method
Namespaces ► Sitecore.Rules ► RuleFactory ► GetRules()()()
Members
Icon | Member | Description
 | GetRules<(Of <(T>)>)(Item, String) | Gets the rule set.
 | GetRules<(Of <(T>)>)(IEnumerable<(Of <(Item>)>), String) | Gets the rule set.


GetRules Method (parentItem, fieldName)

GetRules<(Of <(T>)>) Method (parentItem, fieldName)
Namespaces ► Sitecore.Rules ► RuleFactory ► GetRules<(Of <(T>)>)(Item, String)
Gets the rule set.
Declaration Syntax
C#
public static RuleList<T> GetRules<T>(
    Item parentItem,
    string fieldName
)
where T : RuleContext
Generic Template Parameters
T
The rule context.
Parameters
parentItem (Item)
The parent item.
fieldName (String)
Name of the field.
Return Value
The rule set.


GetRules Method (items, fieldName)

GetRules<(Of <(T>)>) Method (items, fieldName)
Namespaces ► Sitecore.Rules ► RuleFactory ► GetRules<(Of <(T>)>)(IEnumerable<(Of <(Item>)>), String)
Gets the rule set.
Declaration Syntax
C#
public static RuleList<T> GetRules<T>(
    IEnumerable<Item> items,
    string fieldName
)
where T : RuleContext
Generic Template Parameters
T
The rule context.
Parameters
items (IEnumerable<(Of <( Item >)>))
The items.
fieldName (String)
Name of the field.
Return Value
The rule set.


InvalidateCache Method

InvalidateCache Method
Namespaces ► Sitecore.Rules ► RuleFactory ► InvalidateCache()()()
Invalidates the cache.
Declaration Syntax
C#
public static void InvalidateCache()


ParseRules Method (database, rulesXml)

ParseRules<(Of <(T>)>) Method (database, rulesXml)
Namespaces ► Sitecore.Rules ► RuleFactory ► ParseRules<(Of <(T>)>)(Database, String)
Gets the rule set.
Declaration Syntax
C#
public static RuleList<T> ParseRules<T>(
    Database database,
    string rulesXml
)
where T : RuleContext
Generic Template Parameters
T
The rule context.
Parameters
database (Database)
The database.
rulesXml (String)
The rules XML.
Return Value
The rule set.


RuleIds Class

RuleIds Class
Namespaces ► Sitecore.Rules ► RuleIds
Defines the rule ids class.
Declaration Syntax
C#
public static class RuleIds
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Action | The ID for Action.
 | Condition | The ID for Condition.
 | Macro | The ID for Macro.
 | Rule | The ID for Rule.
Inheritance Hierarchy
Object
RuleIds


Action Field

Action Field
Namespaces ► Sitecore.Rules ► RuleIds ► Action
The ID for Action.
Declaration Syntax
C#
public static ID Action


Condition Field

Condition Field
Namespaces ► Sitecore.Rules ► RuleIds ► Condition
The ID for Condition.
Declaration Syntax
C#
public static ID Condition


Macro Field

Macro Field
Namespaces ► Sitecore.Rules ► RuleIds ► Macro
The ID for Macro.
Declaration Syntax
C#
public static ID Macro


Rule Field

Rule Field
Namespaces ► Sitecore.Rules ► RuleIds ► Rule
The ID for Rule.
Declaration Syntax
C#
public static ID Rule


RuleList(T) Class

RuleList<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules ► RuleList<(Of <(T>)>)
Defines a set of rules.
Declaration Syntax
C#
public class RuleList<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RuleList<(Of <(T>)>)()()() | Initializes a new instance of the RuleList class.
 | RuleList<(Of <(T>)>)(Rule<(Of <(T>)>)) | Initializes a new instance of the RuleList class.
 | RuleList<(Of <(T>)>)(IEnumerable<(Of <(Rule<(Of <(T>)>)>)>)) | Initializes a new instance of the RuleList class.
 | Add(Rule<(Of <(T>)>)) | Adds the specified rule.
 | AddRange(IEnumerable<(Of <(Rule<(Of <(T>)>)>)>)) | Adds the range.
 | Applied | Occurs when an action has been applied.
 | Count | Gets the count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluated | Occurs when evaluated.
 | Evaluating | Occurs when evaluating.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name.
 | Rules | Gets the rules.
 | Run(T) | Executes this rule set.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RuleList<(Of <(T>)>)


RuleList(T) Constructor

RuleList<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules ► RuleList<(Of <(T>)>) ► RuleList<(Of <(T>)>)()()()
Members
Icon | Member | Description
 | RuleList<(Of <(T>)>)()()() | Initializes a new instance of the RuleList class.
 | RuleList<(Of <(T>)>)(Rule<(Of <(T>)>)) | Initializes a new instance of the RuleList class.
 | RuleList<(Of <(T>)>)(IEnumerable<(Of <(Rule<(Of <(T>)>)>)>)) | Initializes a new instance of the RuleList class.


RuleList(T) Constructor

RuleList<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules ► RuleList<(Of <(T>)>) ► RuleList<(Of <(T>)>)()()()
Initializes a new instance of the RuleList class.
Declaration Syntax
C#
public RuleList()


RuleList(T) Constructor (rule)

RuleList<(Of <(T>)>) Constructor (rule)
Namespaces ► Sitecore.Rules ► RuleList<(Of <(T>)>) ► RuleList<(Of <(T>)>)(Rule<(Of <(T>)>))
Initializes a new instance of the RuleList class.
Declaration Syntax
C#
public RuleList(
    Rule<T> rule
)
Parameters
rule (Rule <(Of <( T >)>))
The new rule.


RuleList(T) Constructor (rules)

RuleList<(Of <(T>)>) Constructor (rules)
Namespaces ► Sitecore.Rules ► RuleList<(Of <(T>)>) ► RuleList<(Of <(T>)>)(IEnumerable<(Of <(Rule<(Of <(T>)>)>)>))
Initializes a new instance of the RuleList class.
Declaration Syntax
C#
public RuleList(
    IEnumerable<Rule<T>> rules
)
Parameters
rules (IEnumerable<(Of <( Rule <(Of <( T >)>)>)>))
The rule set.


Add Method (rule)

Add Method (rule)
Namespaces ► Sitecore.Rules ► RuleList<(Of <(T>)>) ► Add(Rule<(Of <(T>)>))
Adds the specified rule.
Declaration Syntax
C#
public void Add(
    Rule<T> rule
)
Parameters
rule (Rule <(Of <( T >)>))
The rule to add.


AddRange Method (actionRules)

AddRange Method (actionRules)
Namespaces ► Sitecore.Rules ► RuleList<(Of <(T>)>) ► AddRange(IEnumerable<(Of <(Rule<(Of <(T>)>)>)>))
Adds the range.
Declaration Syntax
C#
public void AddRange(
    IEnumerable<Rule<T>> actionRules
)
Parameters
actionRules (IEnumerable<(Of <( Rule <(Of <( T >)>)>)>))
The rules.


Applied Event

Applied Event
Namespaces ► Sitecore.Rules ► RuleList<(Of <(T>)>) ► Applied
Occurs when an action has been applied.
Declaration Syntax
C#
public event RuleActionEventHandler<T> Applied


Count Property

Count Property
Namespaces ► Sitecore.Rules ► RuleList<(Of <(T>)>) ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


Evaluated Event

Evaluated Event
Namespaces ► Sitecore.Rules ► RuleList<(Of <(T>)>) ► Evaluated
Occurs when evaluated.
Declaration Syntax
C#
public event RuleConditionEventHandler<T> Evaluated


Evaluating Event

Evaluating Event
Namespaces ► Sitecore.Rules ► RuleList<(Of <(T>)>) ► Evaluating
Occurs when evaluating.
Declaration Syntax
C#
public event RuleConditionEventHandler<T> Evaluating


Name Property

Name Property
Namespaces ► Sitecore.Rules ► RuleList<(Of <(T>)>) ► Name
Gets or sets the name.
Declaration Syntax
C#
public string Name { get; set; }
Value
The name of the rule set.


Rules Property

Rules Property
Namespaces ► Sitecore.Rules ► RuleList<(Of <(T>)>) ► Rules
Gets the rules.
Declaration Syntax
C#
public IEnumerable<Rule<T>> Rules { get; }
Value
The rules.


Run Method (ruleContext)

Run Method (ruleContext)
Namespaces ► Sitecore.Rules ► RuleList<(Of <(T>)>) ► Run(T)
Executes this rule set.
Declaration Syntax
C#
public void Run(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.


RuleStack Class

RuleStack Class
Namespaces ► Sitecore.Rules ► RuleStack
Defines the rule stack class.
Declaration Syntax
C#
public class RuleStack : Stack<Object>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RuleStack()()() | Initializes a new instance of the RuleStack class
 | Clear()()() | Removes all objects from the Stack<(Of <(T>)>). (Inherited from Stack<(Of <(Object>)>).)
 | Contains(T) | Determines whether an element is in the Stack<(Of <(T>)>). (Inherited from Stack<(Of <(Object>)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the Stack<(Of <(T>)>) to an existing one-dimensional Array, starting at the specified array index. (Inherited from Stack<(Of <(Object>)>).)
 | Count | Gets the number of elements contained in the Stack<(Of <(T>)>). (Inherited from Stack<(Of <(Object>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator for the Stack<(Of <(T>)>). (Inherited from Stack<(Of <(Object>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Peek()()() | Returns the object at the top of the Stack<(Of <(T>)>) without removing it. (Inherited from Stack<(Of <(Object>)>).)
 | Pop()()() | Removes and returns the object at the top of the Stack<(Of <(T>)>). (Inherited from Stack<(Of <(Object>)>).)
 | Push(T) | Inserts an object at the top of the Stack<(Of <(T>)>). (Inherited from Stack<(Of <(Object>)>).)
 | ToArray()()() | Copies the Stack<(Of <(T>)>) to a new array. (Inherited from Stack<(Of <(Object>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()()() | Sets the capacity to the actual number of elements in the Stack<(Of <(T>)>), if that number is less than 90 percent of current capacity. (Inherited from Stack<(Of <(Object>)>).)
Inheritance Hierarchy
Object
 | Stack<(Of <(Object>)>)
 |  | RuleStack


RuleStack Constructor

RuleStack Constructor
Namespaces ► Sitecore.Rules ► RuleStack ► RuleStack()()()
Initializes a new instance of the RuleStack class
Declaration Syntax
C#
public RuleStack()


Sitecore.Rules.Actions Namespace

Sitecore.Rules.Actions Namespace
Namespaces ► Sitecore.Rules.Actions
Declaration Syntax
C#
namespace Sitecore.Rules.Actions
Types
All Types Classes
Icon | Type | Description
 | RuleAction<(Of <(T>)>) | Defines the rule action class.
 | Run<(Of <(T>)>) | Defines the run class.
 | RunScript<(Of <(T>)>) | Defines the run class.


RuleAction(T) Class

RuleAction<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Actions ► RuleAction<(Of <(T>)>)
Defines the rule action class.
Declaration Syntax
C#
public abstract class RuleAction<T>
where T : RuleContext
Generic Template Parameters
T
The rule context type.
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RuleAction<(Of <(T>)>)()()() | Initializes a new instance of the RuleAction<(Of <(T>)>) class
 | Apply(T) | Executes the specified rule context.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleAction<(Of <(T>)>)
 |  | Run<(Of <(T>)>)
 |  | RunScript<(Of <(T>)>)
 |  | HideRenderingAction<(Of <(T>)>)
 |  | SetDataSource<(Of <(T>)>)
 |  | SetParametersAction<(Of <(T>)>)
 |  | SetPlaceholderAction<(Of <(T>)>)
 |  | AddInsertOption<(Of <(T>)>)


RuleAction(T) Constructor

RuleAction<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.Actions ► RuleAction<(Of <(T>)>) ► RuleAction<(Of <(T>)>)()()()
Initializes a new instance of the RuleAction<(Of <(T>)>) class
Declaration Syntax
C#
protected RuleAction()


Apply Method (ruleContext)

Apply Method (ruleContext)
Namespaces ► Sitecore.Rules.Actions ► RuleAction<(Of <(T>)>) ► Apply(T)
Executes the specified rule context.
Declaration Syntax
C#
public abstract void Apply(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.


Run(T) Class

Run<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Actions ► Run<(Of <(T>)>)
Defines the run class.
Declaration Syntax
C#
public class Run<T> : RuleAction<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Run<(Of <(T>)>)()()() | Initializes a new instance of the Run<(Of <(T>)>) class
 | Apply(T) | Executes the specified rule context.
 | Apply(T) | Executes the specified rule context. (Inherited from RuleAction<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RuleList | Gets or sets the name of the layout.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleAction <(Of <( T >)>)
 |  | Run<(Of <(T>)>)


Run(T) Constructor

Run<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.Actions ► Run<(Of <(T>)>) ► Run<(Of <(T>)>)()()()
Initializes a new instance of the Run<(Of <(T>)>) class
Declaration Syntax
C#
public Run()


Apply Method (ruleContext)

Apply Method (ruleContext)
Namespaces ► Sitecore.Rules.Actions ► Run<(Of <(T>)>) ► Apply(T)
Executes the specified rule context.
Declaration Syntax
C#
public virtual void Apply(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.


RuleList Property

RuleList Property
Namespaces ► Sitecore.Rules.Actions ► Run<(Of <(T>)>) ► RuleList
Gets or sets the name of the layout.
Declaration Syntax
C#
public RuleList<T> RuleList { get; set; }
Value
The name of the layout.


RunScript(T) Class

RunScript<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Actions ► RunScript<(Of <(T>)>)
Defines the run class.
Declaration Syntax
C#
public class RunScript<T> : RuleAction<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RunScript<(Of <(T>)>)()()() | Initializes a new instance of the RunScript<(Of <(T>)>) class
 | Apply(T) | Executes the specified rule context.
 | Apply(T) | Executes the specified rule context. (Inherited from RuleAction<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ScriptId | Gets or sets the script id.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleAction <(Of <( T >)>)
 |  | RunScript<(Of <(T>)>)


RunScript(T) Constructor

RunScript<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.Actions ► RunScript<(Of <(T>)>) ► RunScript<(Of <(T>)>)()()()
Initializes a new instance of the RunScript<(Of <(T>)>) class
Declaration Syntax
C#
public RunScript()


Apply Method (ruleContext)

Apply Method (ruleContext)
Namespaces ► Sitecore.Rules.Actions ► RunScript<(Of <(T>)>) ► Apply(T)
Executes the specified rule context.
Declaration Syntax
C#
public virtual void Apply(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.


ScriptId Property

ScriptId Property
Namespaces ► Sitecore.Rules.Actions ► RunScript<(Of <(T>)>) ► ScriptId
Gets or sets the script id.
Declaration Syntax
C#
public string ScriptId { get; set; }
Value
The script id.


Sitecore.Rules.ConditionalRenderings Namespace

Sitecore.Rules.ConditionalRenderings Namespace
Namespaces ► Sitecore.Rules.ConditionalRenderings
Declaration Syntax
C#
namespace Sitecore.Rules.ConditionalRenderings
Types
All Types Classes
Icon | Type | Description
 | ConditionalRenderingsRuleContext | Defines the conditional renderings rule context class.
 | HideRenderingAction<(Of <(T>)>) | Defines the hide rendering action class.
 | SetDataSource<(Of <(T>)>) | Defines the set data source action class.
 | SetDataSourceAction<(Of <(T>)>) | Defines the set data source action class.
 | SetParametersAction<(Of <(T>)>) |
 | SetPlaceholderAction<(Of <(T>)>) |


ConditionalRenderingsRuleContext Class

ConditionalRenderingsRuleContext Class
Namespaces ► Sitecore.Rules.ConditionalRenderings ► ConditionalRenderingsRuleContext
Defines the conditional renderings rule context class.
Declaration Syntax
C#
[SerializableAttribute]
public class ConditionalRenderingsRuleContext : RuleContext,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionalRenderingsRuleContext(List<(Of <(RenderingReference>)>), RenderingReference) | Initializes a new instance of the ConditionalRenderingsRuleContext class.
 | ConditionalRenderingsRuleContext(SerializationInfo, StreamingContext) | Initializes a new instance of the ConditionalRenderingsRuleContext class.
 | Abort()()() | Aborts the current rule execution. (Inherited from RuleContext.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAborted | Gets a value indicating whether this rule execution is aborted. (Inherited from RuleContext.)
 | Item | Gets or sets the item. (Inherited from RuleContext.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Reference | Gets the reference.
 | References | Gets the references.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleContext
 |  | ConditionalRenderingsRuleContext


ConditionalRenderingsRuleContext Constructor

ConditionalRenderingsRuleContext Constructor
Namespaces ► Sitecore.Rules.ConditionalRenderings ► ConditionalRenderingsRuleContext ► ConditionalRenderingsRuleContext()()()
Members
Icon | Member | Description
 | ConditionalRenderingsRuleContext(List<(Of <(RenderingReference>)>), RenderingReference) | Initializes a new instance of the ConditionalRenderingsRuleContext class.
 | ConditionalRenderingsRuleContext(SerializationInfo, StreamingContext) | Initializes a new instance of the ConditionalRenderingsRuleContext class.


ConditionalRenderingsRuleContext Constructor (references, reference)

ConditionalRenderingsRuleContext Constructor (references, reference)
Namespaces ► Sitecore.Rules.ConditionalRenderings ► ConditionalRenderingsRuleContext ► ConditionalRenderingsRuleContext(List<(Of <(RenderingReference>)>), RenderingReference)
Initializes a new instance of the ConditionalRenderingsRuleContext class.
Declaration Syntax
C#
public ConditionalRenderingsRuleContext(
    List<RenderingReference> references,
    RenderingReference reference
)
Parameters
references (List<(Of <( RenderingReference >)>))
The references.
reference (RenderingReference)
The reference.


ConditionalRenderingsRuleContext Constructor (info, context)

ConditionalRenderingsRuleContext Constructor (info, context)
Namespaces ► Sitecore.Rules.ConditionalRenderings ► ConditionalRenderingsRuleContext ► ConditionalRenderingsRuleContext(SerializationInfo, StreamingContext)
Initializes a new instance of the ConditionalRenderingsRuleContext class.
Declaration Syntax
C#
protected ConditionalRenderingsRuleContext(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialization info.
context (StreamingContext)
The context.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Rules.ConditionalRenderings ► ConditionalRenderingsRuleContext ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Reference Property

Reference Property
Namespaces ► Sitecore.Rules.ConditionalRenderings ► ConditionalRenderingsRuleContext ► Reference
Gets the reference.
Declaration Syntax
C#
public RenderingReference Reference { get; }
Value
The reference.


References Property

References Property
Namespaces ► Sitecore.Rules.ConditionalRenderings ► ConditionalRenderingsRuleContext ► References
Gets the references.
Declaration Syntax
C#
public List<RenderingReference> References { get; }
Value
The references.


HideRenderingAction(T) Class

HideRenderingAction<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.ConditionalRenderings ► HideRenderingAction<(Of <(T>)>)
Defines the hide rendering action class.
Declaration Syntax
C#
public class HideRenderingAction<T> : RuleAction<T>
where T : ConditionalRenderingsRuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HideRenderingAction<(Of <(T>)>)()()() | Initializes a new instance of the HideRenderingAction<(Of <(T>)>) class
 | Apply(T) | Executes the specified rule context.
 | Apply(T) | Executes the specified rule context. (Inherited from RuleAction<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleAction <(Of <( T >)>)
 |  | HideRenderingAction<(Of <(T>)>)


HideRenderingAction(T) Constructor

HideRenderingAction<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.ConditionalRenderings ► HideRenderingAction<(Of <(T>)>) ► HideRenderingAction<(Of <(T>)>)()()()
Initializes a new instance of the HideRenderingAction<(Of <(T>)>) class
Declaration Syntax
C#
public HideRenderingAction()


Apply Method (ruleContext)

Apply Method (ruleContext)
Namespaces ► Sitecore.Rules.ConditionalRenderings ► HideRenderingAction<(Of <(T>)>) ► Apply(T)
Executes the specified rule context.
Declaration Syntax
C#
public virtual void Apply(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.


SetDataSource(T) Class

SetDataSource<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetDataSource<(Of <(T>)>)
Defines the set data source action class.
Declaration Syntax
C#
public abstract class SetDataSource<T> : RuleAction<T>
where T : ConditionalRenderingsRuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SetDataSource<(Of <(T>)>)()()() | Initializes a new instance of the SetDataSource<(Of <(T>)>) class
 | Apply(T, String) | Executes the specified rule context.
 | Apply(T) | Executes the specified rule context. (Inherited from RuleAction<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleAction <(Of <(T>)>)
 |  | SetDataSource<(Of <(T>)>)
 |  |  | ProcessMultiVariateTestAction<(Of <(T>)>)
 |  |  | SetDataSourceAction<(Of <(T>)>)


SetDataSource(T) Constructor

SetDataSource<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetDataSource<(Of <(T>)>) ► SetDataSource<(Of <(T>)>)()()()
Initializes a new instance of the SetDataSource<(Of <(T>)>) class
Declaration Syntax
C#
protected SetDataSource()


Apply Method (ruleContext, dataSource)

Apply Method (ruleContext, dataSource)
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetDataSource<(Of <(T>)>) ► Apply(T, String)
Executes the specified rule context.
Declaration Syntax
C#
protected void Apply(
    T ruleContext,
    string dataSource
)
Parameters
ruleContext (T)
The rule context.
dataSource (String)
The data source.


SetDataSourceAction(T) Class

SetDataSourceAction<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetDataSourceAction<(Of <(T>)>)
Defines the set data source action class.
Declaration Syntax
C#
public class SetDataSourceAction<T> : SetDataSource<T>
where T : ConditionalRenderingsRuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetDataSourceAction<(Of <(T>)>)()()() | Initializes a new instance of the SetDataSourceAction<(Of <(T>)>) class
 | Apply(T) | Executes the specified rule context. (Overrides RuleAction <(Of <(T>)>).Apply(T).)
 | Apply(T, String) | Executes the specified rule context. (Inherited from SetDataSource<(Of <(T>)>).)
 | DataSource | Gets or sets the data source.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleAction <(Of <(T>)>)
 |  | SetDataSource <(Of <(T>)>)
 |  |  | SetDataSourceAction<(Of <(T>)>)


SetDataSourceAction(T) Constructor

SetDataSourceAction<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetDataSourceAction<(Of <(T>)>) ► SetDataSourceAction<(Of <(T>)>)()()()
Initializes a new instance of the SetDataSourceAction<(Of <(T>)>) class
Declaration Syntax
C#
public SetDataSourceAction()


Apply Method (ruleContext)

Apply Method (ruleContext)
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetDataSourceAction<(Of <(T>)>) ► Apply(T)
Executes the specified rule context.
Declaration Syntax
C#
public override void Apply(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.


DataSource Property

DataSource Property
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetDataSourceAction<(Of <(T>)>) ► DataSource
Gets or sets the data source.
Declaration Syntax
C#
public string DataSource { get; set; }
Value
The data source.


SetParametersAction(T) Class

SetParametersAction<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetParametersAction<(Of <(T>)>)
Declaration Syntax
C#
public class SetParametersAction<T> : RuleAction<T>
where T : ConditionalRenderingsRuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetParametersAction<(Of <(T>)>)()()() | Initializes a new instance of the SetParametersAction<(Of <(T>)>) class
 | Apply(T) | Executes the specified rule context.
 | Apply(T) | Executes the specified rule context. (Inherited from RuleAction<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets or sets the data source.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleAction <(Of <( T >)>)
 |  | SetParametersAction<(Of <(T>)>)


SetParametersAction(T) Constructor

SetParametersAction<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetParametersAction<(Of <(T>)>) ► SetParametersAction<(Of <(T>)>)()()()
Initializes a new instance of the SetParametersAction<(Of <(T>)>) class
Declaration Syntax
C#
public SetParametersAction()


Apply Method (ruleContext)

Apply Method (ruleContext)
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetParametersAction<(Of <(T>)>) ► Apply(T)
Executes the specified rule context.
Declaration Syntax
C#
public virtual void Apply(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetParametersAction<(Of <(T>)>) ► Parameters
Gets or sets the data source.
Declaration Syntax
C#
public string Parameters { get; set; }
Value
The data source.


SetPlaceholderAction(T) Class

SetPlaceholderAction<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetPlaceholderAction<(Of <(T>)>)
Declaration Syntax
C#
public class SetPlaceholderAction<T> : RuleAction<T>
where T : ConditionalRenderingsRuleContext
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetPlaceholderAction<(Of <(T>)>)()()() | Initializes a new instance of the SetPlaceholderAction<(Of <(T>)>) class
 | Apply(T) | Executes the specified rule context.
 | Apply(T) | Executes the specified rule context. (Inherited from RuleAction<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Placeholder | Gets or sets the data source.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleAction <(Of <( T >)>)
 |  | SetPlaceholderAction<(Of <(T>)>)


SetPlaceholderAction(T) Constructor

SetPlaceholderAction<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetPlaceholderAction<(Of <(T>)>) ► SetPlaceholderAction<(Of <(T>)>)()()()
Initializes a new instance of the SetPlaceholderAction<(Of <(T>)>) class
Declaration Syntax
C#
public SetPlaceholderAction()


Apply Method (ruleContext)

Apply Method (ruleContext)
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetPlaceholderAction<(Of <(T>)>) ► Apply(T)
Executes the specified rule context.
Declaration Syntax
C#
public virtual void Apply(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.


Placeholder Property

Placeholder Property
Namespaces ► Sitecore.Rules.ConditionalRenderings ► SetPlaceholderAction<(Of <(T>)>) ► Placeholder
Gets or sets the data source.
Declaration Syntax
C#
public string Placeholder { get; set; }
Value
The data source.


Sitecore.Rules.Conditions Namespace

Sitecore.Rules.Conditions Namespace
Namespaces ► Sitecore.Rules.Conditions
Declaration Syntax
C#
namespace Sitecore.Rules.Conditions
Types
All Types Classes Enumerations
Icon | Type | Description
 | AndCondition<(Of <(T>)>) | Defines the and condition class.
 | BinaryCondition<(Of <(T>)>) | Defines the binary condition class.
 | ConditionOperator | Condition operator enumeration.
 | NotCondition<(Of <(T>)>) | Defines the not condition class.
 | OperatorCondition<(Of <(T>)>) | Defines the operator condition class.
 | OrCondition<(Of <(T>)>) | Defines the or condition class.
 | RuleCondition<(Of <(T>)>) | Defines the rule condition class.
 | StringConditionOperator | Condition operator enumeration.
 | StringOperatorCondition<(Of <(T>)>) | Defines the operator condition class.
 | UnaryCondition<(Of <(T>)>) | Defines the unary condition class.
 | WhenCondition<(Of <(T>)>) | Defines the when condition class.
 | WhenField<(Of <(T>)>) | Defines the when field is value.
 | WhenIsDescendantOrSelf<(Of <(T>)>) | Defines the when subitem of class.
 | WhenQuery<(Of <(T>)>) | Defines the when subitem of class.
 | WhenRule<(Of <(T>)>) | Defines the when template is class.
 | WhenTemplateIs<(Of <(T>)>) | Defines the when template is class.


AndCondition(T) Class

AndCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Conditions ► AndCondition<(Of <(T>)>)
Defines the and condition class.
Declaration Syntax
C#
public class AndCondition<T> : BinaryCondition<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AndCondition<(Of <(T>)>)(RuleCondition<(Of <(T>)>), RuleCondition<(Of <(T>)>)) | Initializes a new instance of the AndCondition class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Overrides BinaryCondition <(Of <(T>)>).Evaluate(T, RuleStack).)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from RuleCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LeftOperand | Gets the left operand. (Inherited from BinaryCondition<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RightOperand | Gets the right operand. (Inherited from BinaryCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | BinaryCondition <(Of <(T>)>)
 |  |  | AndCondition<(Of <(T>)>)


AndCondition(T) Constructor (leftOperand, rightOperand)

AndCondition<(Of <(T>)>) Constructor (leftOperand, rightOperand)
Namespaces ► Sitecore.Rules.Conditions ► AndCondition<(Of <(T>)>) ► AndCondition<(Of <(T>)>)(RuleCondition<(Of <(T>)>), RuleCondition<(Of <(T>)>))
Initializes a new instance of the AndCondition class.
Declaration Syntax
C#
public AndCondition(
    RuleCondition<T> leftOperand,
    RuleCondition<T> rightOperand
)
Parameters
leftOperand (RuleCondition <(Of <( T >)>))
The left operand.
rightOperand (RuleCondition <(Of <( T >)>))
The right operand.


Evaluate Method (ruleContext, stack)

Evaluate Method (ruleContext, stack)
Namespaces ► Sitecore.Rules.Conditions ► AndCondition<(Of <(T>)>) ► Evaluate(T, RuleStack)
Executes the specified rule context.
Declaration Syntax
C#
public override void Evaluate(
    T ruleContext,
    RuleStack stack
)
Parameters
ruleContext (T)
The rule context.
stack (RuleStack)
The stack.


BinaryCondition(T) Class

BinaryCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Conditions ► BinaryCondition<(Of <(T>)>)
Defines the binary condition class.
Declaration Syntax
C#
public abstract class BinaryCondition<T> : RuleCondition<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BinaryCondition<(Of <(T>)>)(RuleCondition<(Of <(T>)>), RuleCondition<(Of <(T>)>)) | Initializes a new instance of the BinaryCondition class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context.
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from RuleCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LeftOperand | Gets the left operand.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RightOperand | Gets the right operand.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | BinaryCondition<(Of <(T>)>)
 |  |  | AndCondition<(Of <(T>)>)
 |  |  | OrCondition<(Of <(T>)>)


BinaryCondition(T) Constructor (leftOperand, rightOperand)

BinaryCondition<(Of <(T>)>) Constructor (leftOperand, rightOperand)
Namespaces ► Sitecore.Rules.Conditions ► BinaryCondition<(Of <(T>)>) ► BinaryCondition<(Of <(T>)>)(RuleCondition<(Of <(T>)>), RuleCondition<(Of <(T>)>))
Initializes a new instance of the BinaryCondition class.
Declaration Syntax
C#
protected BinaryCondition(
    RuleCondition<T> leftOperand,
    RuleCondition<T> rightOperand
)
Parameters
leftOperand (RuleCondition <(Of <( T >)>))
The left operand.
rightOperand (RuleCondition <(Of <( T >)>))
The right operand.


Evaluate Method (ruleContext, stack)

Evaluate Method (ruleContext, stack)
Namespaces ► Sitecore.Rules.Conditions ► BinaryCondition<(Of <(T>)>) ► Evaluate(T, RuleStack)
Executes the specified rule context.
Declaration Syntax
C#
public virtual void Evaluate(
    T ruleContext,
    RuleStack stack
)
Parameters
ruleContext (T)
The rule context.
stack (RuleStack)
The stack.


LeftOperand Property

LeftOperand Property
Namespaces ► Sitecore.Rules.Conditions ► BinaryCondition<(Of <(T>)>) ► LeftOperand
Gets the left operand.
Declaration Syntax
C#
public RuleCondition<T> LeftOperand { get; }
Value
The left operand.


RightOperand Property

RightOperand Property
Namespaces ► Sitecore.Rules.Conditions ► BinaryCondition<(Of <(T>)>) ► RightOperand
Gets the right operand.
Declaration Syntax
C#
public RuleCondition<T> RightOperand { get; }
Value
The right operand.


ConditionOperator Enumeration

ConditionOperator Enumeration
Namespaces ► Sitecore.Rules.Conditions ► ConditionOperator
Condition operator enumeration.
Declaration Syntax
C#
public enum ConditionOperator
Members
Member | Description
Unknown | Unknown operator
Equal | Equal operator.
GreaterThanOrEqual | Grater than or equal operator.
GreaterThan | Greater than operator.
LessThanOrEqual | Less than or equal operator.
LessThan | Less than operator.
NotEqual | Not equal operator.


NotCondition(T) Class

NotCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Conditions ► NotCondition<(Of <(T>)>)
Defines the not condition class.
Declaration Syntax
C#
public class NotCondition<T> : UnaryCondition<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotCondition<(Of <(T>)>)(RuleCondition<(Of <(T>)>)) | Initializes a new instance of the NotCondition class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Overrides UnaryCondition <(Of <(T>)>).Evaluate(T, RuleStack).)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from RuleCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Operand | Gets the left operand. (Inherited from UnaryCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | UnaryCondition <(Of <(T>)>)
 |  |  | NotCondition<(Of <(T>)>)


NotCondition(T) Constructor (operand)

NotCondition<(Of <(T>)>) Constructor (operand)
Namespaces ► Sitecore.Rules.Conditions ► NotCondition<(Of <(T>)>) ► NotCondition<(Of <(T>)>)(RuleCondition<(Of <(T>)>))
Initializes a new instance of the NotCondition class.
Declaration Syntax
C#
public NotCondition(
    RuleCondition<T> operand
)
Parameters
operand (RuleCondition <(Of <( T >)>))
The operand.


Evaluate Method (ruleContext, stack)

Evaluate Method (ruleContext, stack)
Namespaces ► Sitecore.Rules.Conditions ► NotCondition<(Of <(T>)>) ► Evaluate(T, RuleStack)
Executes the specified rule context.
Declaration Syntax
C#
public override void Evaluate(
    T ruleContext,
    RuleStack stack
)
Parameters
ruleContext (T)
The rule context.
stack (RuleStack)
The stack.


OperatorCondition(T) Class

OperatorCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Conditions ► OperatorCondition<(Of <(T>)>)
Defines the operator condition class.
Declaration Syntax
C#
public abstract class OperatorCondition<T> : WhenCondition<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OperatorCondition<(Of <(T>)>)()()() | Initializes a new instance of the OperatorCondition<(Of <(T>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | OperatorCondition<(Of <(T>)>)
 |  |  |  | GlobalVisitNoCondition<(Of <(T>)>)
 |  |  |  | PageIndexCondition<(Of <(T>)>)
 |  |  |  | ProfileCondition<(Of <(T>)>)
 |  |  |  | VisitorIdentificationCondition<(Of <(T>)>)


OperatorCondition(T) Constructor

OperatorCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.Conditions ► OperatorCondition<(Of <(T>)>) ► OperatorCondition<(Of <(T>)>)()()()
Initializes a new instance of the OperatorCondition<(Of <(T>)>) class
Declaration Syntax
C#
protected OperatorCondition()


GetOperator Method

GetOperator Method
Namespaces ► Sitecore.Rules.Conditions ► OperatorCondition<(Of <(T>)>) ► GetOperator()()()
Gets the operator.
Declaration Syntax
C#
protected ConditionOperator GetOperator()
Return Value
Returns the condition operator.


OperatorId Property

OperatorId Property
Namespaces ► Sitecore.Rules.Conditions ► OperatorCondition<(Of <(T>)>) ► OperatorId
Gets or sets the operator id.
Declaration Syntax
C#
public string OperatorId { get; set; }
Value
The operator id.


OrCondition(T) Class

OrCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Conditions ► OrCondition<(Of <(T>)>)
Defines the or condition class.
Declaration Syntax
C#
public class OrCondition<T> : BinaryCondition<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OrCondition<(Of <(T>)>)(RuleCondition<(Of <(T>)>), RuleCondition<(Of <(T>)>)) | Initializes a new instance of the OrCondition class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context.
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from BinaryCondition<(Of <(T>)>).)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from RuleCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LeftOperand | Gets the left operand. (Inherited from BinaryCondition<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RightOperand | Gets the right operand. (Inherited from BinaryCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | BinaryCondition <(Of <( T >)>)
 |  |  | OrCondition<(Of <(T>)>)


OrCondition(T) Constructor (leftOperand, rightOperand)

OrCondition<(Of <(T>)>) Constructor (leftOperand, rightOperand)
Namespaces ► Sitecore.Rules.Conditions ► OrCondition<(Of <(T>)>) ► OrCondition<(Of <(T>)>)(RuleCondition<(Of <(T>)>), RuleCondition<(Of <(T>)>))
Initializes a new instance of the OrCondition class.
Declaration Syntax
C#
public OrCondition(
    RuleCondition<T> leftOperand,
    RuleCondition<T> rightOperand
)
Parameters
leftOperand (RuleCondition <(Of <( T >)>))
The left operand.
rightOperand (RuleCondition <(Of <( T >)>))
The right operand.


Evaluate Method (ruleContext, stack)

Evaluate Method (ruleContext, stack)
Namespaces ► Sitecore.Rules.Conditions ► OrCondition<(Of <(T>)>) ► Evaluate(T, RuleStack)
Executes the specified rule context.
Declaration Syntax
C#
public virtual void Evaluate(
    T ruleContext,
    RuleStack stack
)
Parameters
ruleContext (T)
The rule context.
stack (RuleStack)
The stack.


RuleCondition(T) Class

RuleCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Conditions ► RuleCondition<(Of <(T>)>)
Defines the rule condition class.
Declaration Syntax
C#
public abstract class RuleCondition<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RuleCondition<(Of <(T>)>)()()() | Initializes a new instance of the RuleCondition<(Of <(T>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition<(Of <(T>)>)
 |  | BinaryCondition<(Of <(T>)>)
 |  | UnaryCondition<(Of <(T>)>)
 |  | WhenCondition<(Of <(T>)>)


RuleCondition(T) Constructor

RuleCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.Conditions ► RuleCondition<(Of <(T>)>) ► RuleCondition<(Of <(T>)>)()()()
Initializes a new instance of the RuleCondition<(Of <(T>)>) class
Declaration Syntax
C#
protected RuleCondition()


Evaluate Method (ruleContext, stack)

Evaluate Method (ruleContext, stack)
Namespaces ► Sitecore.Rules.Conditions ► RuleCondition<(Of <(T>)>) ► Evaluate(T, RuleStack)
Executes the specified rule context.
Declaration Syntax
C#
public abstract void Evaluate(
    T ruleContext,
    RuleStack stack
)
Parameters
ruleContext (T)
The rule context.
stack (RuleStack)
The stack.


StringConditionOperator Enumeration

StringConditionOperator Enumeration
Namespaces ► Sitecore.Rules.Conditions ► StringConditionOperator
Condition operator enumeration.
Declaration Syntax
C#
public enum StringConditionOperator
Members
Member | Description
Unknown | Unknown operator
Equals | Equal operator.
CaseInsensitivelyEquals | Grater than or equal operator.
NotEqual | Not equal operator.
NotCaseInsensitivelyEquals | Not equal operator.
Contains | Greater than operator.
ContainsRegex | Less than or equal operator.


StringOperatorCondition(T) Class

StringOperatorCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Conditions ► StringOperatorCondition<(Of <(T>)>)
Defines the operator condition class.
Declaration Syntax
C#
public abstract class StringOperatorCondition<T> : WhenCondition<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringOperatorCondition<(Of <(T>)>)()()() | Initializes a new instance of the StringOperatorCondition<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <(T>)>)
 |  | WhenCondition <(Of <(T>)>)
 |  |  | StringOperatorCondition<(Of <(T>)>)
 |  |  |  | IpBaseCondition<(Of <(T>)>)
 |  |  |  | IpOwnerBaseCondition<(Of <(T>)>)
 |  |  |  | KeywordsCondition<(Of <(T>)>)
 |  |  |  | WhenField<(Of <(T>)>)


StringOperatorCondition(T) Constructor

StringOperatorCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.Conditions ► StringOperatorCondition<(Of <(T>)>) ► StringOperatorCondition<(Of <(T>)>)()()()
Initializes a new instance of the StringOperatorCondition<(Of <(T>)>) class
Declaration Syntax
C#
protected StringOperatorCondition()


Compare Method (value0, value1)

Compare Method (value0, value1)
Namespaces ► Sitecore.Rules.Conditions ► StringOperatorCondition<(Of <(T>)>) ► Compare(String, String)
Compares the specified value0.
Declaration Syntax
C#
protected bool Compare(
    string value0,
    string value1
)
Parameters
value0 (String)
The value0.
value1 (String)
The value1.
Return Value
The boolean.


GetOperator Method

GetOperator Method
Namespaces ► Sitecore.Rules.Conditions ► StringOperatorCondition<(Of <(T>)>) ► GetOperator()()()
Gets the operator.
Declaration Syntax
C#
protected StringConditionOperator GetOperator()
Return Value
Returns the condition operator.


OperatorId Property

OperatorId Property
Namespaces ► Sitecore.Rules.Conditions ► StringOperatorCondition<(Of <(T>)>) ► OperatorId
Gets or sets the operator id.
Declaration Syntax
C#
public string OperatorId { get; set; }
Value
The operator id.


UnaryCondition(T) Class

UnaryCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Conditions ► UnaryCondition<(Of <(T>)>)
Defines the unary condition class.
Declaration Syntax
C#
public abstract class UnaryCondition<T> : RuleCondition<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnaryCondition<(Of <(T>)>)(RuleCondition<(Of <(T>)>)) | Initializes a new instance of the UnaryCondition class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context.
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from RuleCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Operand | Gets the left operand.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | UnaryCondition<(Of <(T>)>)
 |  |  | NotCondition<(Of <(T>)>)


UnaryCondition(T) Constructor (operand)

UnaryCondition<(Of <(T>)>) Constructor (operand)
Namespaces ► Sitecore.Rules.Conditions ► UnaryCondition<(Of <(T>)>) ► UnaryCondition<(Of <(T>)>)(RuleCondition<(Of <(T>)>))
Initializes a new instance of the UnaryCondition class.
Declaration Syntax
C#
protected UnaryCondition(
    RuleCondition<T> operand
)
Parameters
operand (RuleCondition <(Of <( T >)>))
The operand.


Evaluate Method (ruleContext, stack)

Evaluate Method (ruleContext, stack)
Namespaces ► Sitecore.Rules.Conditions ► UnaryCondition<(Of <(T>)>) ► Evaluate(T, RuleStack)
Executes the specified rule context.
Declaration Syntax
C#
public virtual void Evaluate(
    T ruleContext,
    RuleStack stack
)
Parameters
ruleContext (T)
The rule context.
stack (RuleStack)
The stack.


Operand Property

Operand Property
Namespaces ► Sitecore.Rules.Conditions ► UnaryCondition<(Of <(T>)>) ► Operand
Gets the left operand.
Declaration Syntax
C#
public RuleCondition<T> Operand { get; }
Value
The left operand.


WhenCondition(T) Class

WhenCondition<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Conditions ► WhenCondition<(Of <(T>)>)
Defines the when condition class.
Declaration Syntax
C#
public abstract class WhenCondition<T> : RuleCondition<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WhenCondition<(Of <(T>)>)()()() | Initializes a new instance of the WhenCondition<(Of <(T>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Overrides RuleCondition <(Of <(T>)>).Evaluate(T, RuleStack).)
 | Execute(T) | Executes the specified rule context.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <(T>)>)
 |  | WhenCondition<(Of <(T>)>)
 |  |  | IfMultiVariateTestEnabled<(Of <(T>)>)
 |  |  | OperatorCondition<(Of <(T>)>)
 |  |  | StringOperatorCondition<(Of <(T>)>)
 |  |  | WhenIsDescendantOrSelf<(Of <(T>)>)
 |  |  | WhenQuery<(Of <(T>)>)
 |  |  | WhenRule<(Of <(T>)>)
 |  |  | WhenTemplateIs<(Of <(T>)>)


WhenCondition(T) Constructor

WhenCondition<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.Conditions ► WhenCondition<(Of <(T>)>) ► WhenCondition<(Of <(T>)>)()()()
Initializes a new instance of the WhenCondition<(Of <(T>)>) class
Declaration Syntax
C#
protected WhenCondition()


Evaluate Method (ruleContext, stack)

Evaluate Method (ruleContext, stack)
Namespaces ► Sitecore.Rules.Conditions ► WhenCondition<(Of <(T>)>) ► Evaluate(T, RuleStack)
Executes the specified rule context.
Declaration Syntax
C#
public override void Evaluate(
    T ruleContext,
    RuleStack stack
)
Parameters
ruleContext (T)
The rule context.
stack (RuleStack)
The stack.


Execute Method (ruleContext)

Execute Method (ruleContext)
Namespaces ► Sitecore.Rules.Conditions ► WhenCondition<(Of <(T>)>) ► Execute(T)
Executes the specified rule context.
Declaration Syntax
C#
protected abstract bool Execute(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.
Return Value
True, if the condition succeeds, otherwise false.


WhenField(T) Class

WhenField<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Conditions ► WhenField<(Of <(T>)>)
Defines the when field is value.
Declaration Syntax
C#
public class WhenField<T> : StringOperatorCondition<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhenField<(Of <(T>)>)()()() | Initializes a new instance of the WhenField<(Of <(T>)>) class
 | Compare(String, String) | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | Executes the specified rule context. (Overrides WhenCondition <(Of <(T>)>).Execute(T).)
 | FieldName | Gets or sets the name of the field.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperator()()() | Gets the operator. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the value.
Inheritance Hierarchy
Object
 | RuleCondition <(Of <(T>)>)
 |  | WhenCondition <(Of <(T>)>)
 |  |  | StringOperatorCondition <(Of <(T>)>)
 |  |  |  | WhenField<(Of <(T>)>)


WhenField(T) Constructor

WhenField<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.Conditions ► WhenField<(Of <(T>)>) ► WhenField<(Of <(T>)>)()()()
Initializes a new instance of the WhenField<(Of <(T>)>) class
Declaration Syntax
C#
public WhenField()


Execute Method (ruleContext)

Execute Method (ruleContext)
Namespaces ► Sitecore.Rules.Conditions ► WhenField<(Of <(T>)>) ► Execute(T)
Executes the specified rule context.
Declaration Syntax
C#
protected override bool Execute(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.
Return Value
True, if the condition succeeds, otherwise false.


FieldName Property

FieldName Property
Namespaces ► Sitecore.Rules.Conditions ► WhenField<(Of <(T>)>) ► FieldName
Gets or sets the name of the field.
Declaration Syntax
C#
public string FieldName { get; set; }
Value
The name of the field.


Value Property

Value Property
Namespaces ► Sitecore.Rules.Conditions ► WhenField<(Of <(T>)>) ► Value
Gets or sets the value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.


WhenIsDescendantOrSelf(T) Class

WhenIsDescendantOrSelf<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Conditions ► WhenIsDescendantOrSelf<(Of <(T>)>)
Defines the when subitem of class.
Declaration Syntax
C#
public class WhenIsDescendantOrSelf<T> : WhenCondition<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhenIsDescendantOrSelf<(Of <(T>)>)()()() | Initializes a new instance of the WhenDescendsFrom class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | Executes the specified rule context.
 | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemId | Gets or sets the item id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | WhenIsDescendantOrSelf<(Of <(T>)>)


WhenIsDescendantOrSelf(T) Constructor

WhenIsDescendantOrSelf<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.Conditions ► WhenIsDescendantOrSelf<(Of <(T>)>) ► WhenIsDescendantOrSelf<(Of <(T>)>)()()()
Initializes a new instance of the WhenDescendsFrom class.
Declaration Syntax
C#
public WhenIsDescendantOrSelf()


Execute Method (ruleContext)

Execute Method (ruleContext)
Namespaces ► Sitecore.Rules.Conditions ► WhenIsDescendantOrSelf<(Of <(T>)>) ► Execute(T)
Executes the specified rule context.
Declaration Syntax
C#
protected virtual bool Execute(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.
Return Value
True, if the condition succeeds, otherwise false.


ItemId Property

ItemId Property
Namespaces ► Sitecore.Rules.Conditions ► WhenIsDescendantOrSelf<(Of <(T>)>) ► ItemId
Gets or sets the item id.
Declaration Syntax
C#
public ID ItemId { get; set; }
Value
The item id.


WhenQuery(T) Class

WhenQuery<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Conditions ► WhenQuery<(Of <(T>)>)
Defines the when subitem of class.
Declaration Syntax
C#
public class WhenQuery<T> : WhenCondition<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhenQuery<(Of <(T>)>)()()() | Initializes a new instance of the WhenQuery class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | Executes the specified rule context.
 | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Query | Gets or sets the item id.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | WhenQuery<(Of <(T>)>)


WhenQuery(T) Constructor

WhenQuery<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.Conditions ► WhenQuery<(Of <(T>)>) ► WhenQuery<(Of <(T>)>)()()()
Initializes a new instance of the WhenQuery class.
Declaration Syntax
C#
public WhenQuery()


Execute Method (ruleContext)

Execute Method (ruleContext)
Namespaces ► Sitecore.Rules.Conditions ► WhenQuery<(Of <(T>)>) ► Execute(T)
Executes the specified rule context.
Declaration Syntax
C#
protected virtual bool Execute(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.
Return Value
True, if the condition succeeds, otherwise false.


Query Property

Query Property
Namespaces ► Sitecore.Rules.Conditions ► WhenQuery<(Of <(T>)>) ► Query
Gets or sets the item id.
Declaration Syntax
C#
public string Query { get; set; }
Value
The item id.


WhenRule(T) Class

WhenRule<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Conditions ► WhenRule<(Of <(T>)>)
Defines the when template is class.
Declaration Syntax
C#
public class WhenRule<T> : WhenCondition<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhenRule<(Of <(T>)>)()()() | Initializes a new instance of the WhenRule class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | Executes the specified rule context.
 | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RulesId | Gets or sets the rule set id.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | WhenRule<(Of <(T>)>)


WhenRule(T) Constructor

WhenRule<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.Conditions ► WhenRule<(Of <(T>)>) ► WhenRule<(Of <(T>)>)()()()
Initializes a new instance of the WhenRule class.
Declaration Syntax
C#
public WhenRule()


Execute Method (ruleContext)

Execute Method (ruleContext)
Namespaces ► Sitecore.Rules.Conditions ► WhenRule<(Of <(T>)>) ► Execute(T)
Executes the specified rule context.
Declaration Syntax
C#
protected virtual bool Execute(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.
Return Value
True, if the condition succeeds, otherwise false.


RulesId Property

RulesId Property
Namespaces ► Sitecore.Rules.Conditions ► WhenRule<(Of <(T>)>) ► RulesId
Gets or sets the rule set id.
Declaration Syntax
C#
public ID RulesId { get; set; }
Value
The rule set id.


WhenTemplateIs(T) Class

WhenTemplateIs<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.Conditions ► WhenTemplateIs<(Of <(T>)>)
Defines the when template is class.
Declaration Syntax
C#
public class WhenTemplateIs<T> : WhenCondition<T>
where T : RuleContext
Generic Template Parameters
T
The rule context.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WhenTemplateIs<(Of <(T>)>)()()() | Initializes a new instance of the WhenTemplateIs class.
 | WhenTemplateIs<(Of <(T>)>)(ID) | Initializes a new instance of the WhenTemplateIs class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(T, RuleStack) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Execute(T) | Executes the specified rule context.
 | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(T>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TemplateId | Gets or sets the template id.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleCondition <(Of <( T >)>)
 |  | WhenCondition <(Of <( T >)>)
 |  |  | WhenTemplateIs<(Of <(T>)>)


WhenTemplateIs(T) Constructor

WhenTemplateIs<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.Conditions ► WhenTemplateIs<(Of <(T>)>) ► WhenTemplateIs<(Of <(T>)>)()()()
Members
Icon | Member | Description
 | WhenTemplateIs<(Of <(T>)>)()()() | Initializes a new instance of the WhenTemplateIs class.
 | WhenTemplateIs<(Of <(T>)>)(ID) | Initializes a new instance of the WhenTemplateIs class.


WhenTemplateIs(T) Constructor

WhenTemplateIs<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.Conditions ► WhenTemplateIs<(Of <(T>)>) ► WhenTemplateIs<(Of <(T>)>)()()()
Initializes a new instance of the WhenTemplateIs class.
Declaration Syntax
C#
public WhenTemplateIs()


WhenTemplateIs(T) Constructor (templateId)

WhenTemplateIs<(Of <(T>)>) Constructor (templateId)
Namespaces ► Sitecore.Rules.Conditions ► WhenTemplateIs<(Of <(T>)>) ► WhenTemplateIs<(Of <(T>)>)(ID)
Initializes a new instance of the WhenTemplateIs class.
Declaration Syntax
C#
public WhenTemplateIs(
    ID templateId
)
Parameters
templateId (ID)
The template id.


Execute Method (ruleContext)

Execute Method (ruleContext)
Namespaces ► Sitecore.Rules.Conditions ► WhenTemplateIs<(Of <(T>)>) ► Execute(T)
Executes the specified rule context.
Declaration Syntax
C#
protected virtual bool Execute(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.
Return Value
True, if the condition succeeds, otherwise false.


TemplateId Property

TemplateId Property
Namespaces ► Sitecore.Rules.Conditions ► WhenTemplateIs<(Of <(T>)>) ► TemplateId
Gets or sets the template id.
Declaration Syntax
C#
public ID TemplateId { get; set; }
Value
The template id.


Sitecore.Rules.InsertOptions Namespace

Sitecore.Rules.InsertOptions Namespace
Namespaces ► Sitecore.Rules.InsertOptions
Declaration Syntax
C#
namespace Sitecore.Rules.InsertOptions
Types
All Types Classes
Icon | Type | Description
 | AddInsertOption<(Of <(T>)>) | Add Insert Option
 | InsertOptionsRuleContext |


AddInsertOption(T) Class

AddInsertOption<(Of <(T>)>) Class
Namespaces ► Sitecore.Rules.InsertOptions ► AddInsertOption<(Of <(T>)>)
Add Insert Option
Declaration Syntax
C#
public class AddInsertOption<T> : RuleAction<T>
where T : InsertOptionsRuleContext
Generic Template Parameters
T
Insert Options Rule Context
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddInsertOption<(Of <(T>)>)()()() | Initializes a new instance of the AddInsertOption<(Of <(T>)>) class
 | Apply(T) | Executes the specified rule context.
 | Apply(T) | Executes the specified rule context. (Inherited from RuleAction<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InsertOptionId | Gets or sets the insert option id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleAction <(Of <( T >)>)
 |  | AddInsertOption<(Of <(T>)>)


AddInsertOption(T) Constructor

AddInsertOption<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Rules.InsertOptions ► AddInsertOption<(Of <(T>)>) ► AddInsertOption<(Of <(T>)>)()()()
Initializes a new instance of the AddInsertOption<(Of <(T>)>) class
Declaration Syntax
C#
public AddInsertOption()


Apply Method (ruleContext)

Apply Method (ruleContext)
Namespaces ► Sitecore.Rules.InsertOptions ► AddInsertOption<(Of <(T>)>) ► Apply(T)
Executes the specified rule context.
Declaration Syntax
C#
public virtual void Apply(
    T ruleContext
)
Parameters
ruleContext (T)
The rule context.


InsertOptionId Property

InsertOptionId Property
Namespaces ► Sitecore.Rules.InsertOptions ► AddInsertOption<(Of <(T>)>) ► InsertOptionId
Gets or sets the insert option id.
Declaration Syntax
C#
public ID InsertOptionId { get; set; }
Value
The insert option id.


InsertOptionsRuleContext Class

InsertOptionsRuleContext Class
Namespaces ► Sitecore.Rules.InsertOptions ► InsertOptionsRuleContext
Declaration Syntax
C#
public class InsertOptionsRuleContext : RuleContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InsertOptionsRuleContext()()() | Initializes a new instance of the InsertOptionsRuleContext class
 | Abort()()() | Aborts the current rule execution. (Inherited from RuleContext.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InsertOptions | Gets or sets the insert options.
 | IsAborted | Gets a value indicating whether this rule execution is aborted. (Inherited from RuleContext.)
 | Item | Gets or sets the item. (Inherited from RuleContext.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RuleContext
 |  | InsertOptionsRuleContext


InsertOptionsRuleContext Constructor

InsertOptionsRuleContext Constructor
Namespaces ► Sitecore.Rules.InsertOptions ► InsertOptionsRuleContext ► InsertOptionsRuleContext()()()
Initializes a new instance of the InsertOptionsRuleContext class
Declaration Syntax
C#
public InsertOptionsRuleContext()


InsertOptions Property

InsertOptions Property
Namespaces ► Sitecore.Rules.InsertOptions ► InsertOptionsRuleContext ► InsertOptions
Gets or sets the insert options.
Declaration Syntax
C#
public List<Item> InsertOptions { get; set; }
Value
The insert options.


Sitecore.Rules.RuleMacros Namespace

Sitecore.Rules.RuleMacros Namespace
Namespaces ► Sitecore.Rules.RuleMacros
Declaration Syntax
C#
namespace Sitecore.Rules.RuleMacros
Types
All Types Classes Interfaces
Icon | Type | Description
 | IRuleMacro | Defines the Rule Macro interface.
 | OperatorMacro | Defines the tree macro class.
 | ProfileKeyMacro | Defines the tree macro class.
 | ProfileMacro | Defines the tree macro class.
 | ScriptMacro | Defines the tree macro class.
 | StringOperatorMacro | Defines the tree macro class.
 | TemplateMacro | Defines the tree macro class.
 | TreeMacro | Defines the tree macro class.


IRuleMacro Interface

IRuleMacro Interface
Namespaces ► Sitecore.Rules.RuleMacros ► IRuleMacro
Defines the Rule Macro interface.
Declaration Syntax
C#
public interface IRuleMacro
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Execute(XElement, String, UrlString, String) | Executes the specified macro.


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Rules.RuleMacros ► IRuleMacro ► Execute(XElement, String, UrlString, String)
Executes the specified macro.
Declaration Syntax
C#
void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
The element.
name (String)
The name of the field.
parameters (UrlString)
The parameters.
value (String)
The value.


OperatorMacro Class

OperatorMacro Class
Namespaces ► Sitecore.Rules.RuleMacros ► OperatorMacro
Defines the tree macro class.
Declaration Syntax
C#
public class OperatorMacro : IRuleMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | OperatorMacro()()() | Initializes a new instance of the OperatorMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | Executes the specified macro.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
OperatorMacro


OperatorMacro Constructor

OperatorMacro Constructor
Namespaces ► Sitecore.Rules.RuleMacros ► OperatorMacro ► OperatorMacro()()()
Initializes a new instance of the OperatorMacro class
Declaration Syntax
C#
public OperatorMacro()


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Rules.RuleMacros ► OperatorMacro ► Execute(XElement, String, UrlString, String)
Executes the specified macro.
Declaration Syntax
C#
public void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
The element.
name (String)
The name of the field.
parameters (UrlString)
The parameters.
value (String)
The value.


ProfileKeyMacro Class

ProfileKeyMacro Class
Namespaces ► Sitecore.Rules.RuleMacros ► ProfileKeyMacro
Defines the tree macro class.
Declaration Syntax
C#
public class ProfileKeyMacro : IRuleMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProfileKeyMacro()()() | Initializes a new instance of the ProfileKeyMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | Executes the specified macro.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProfileKeyMacro


ProfileKeyMacro Constructor

ProfileKeyMacro Constructor
Namespaces ► Sitecore.Rules.RuleMacros ► ProfileKeyMacro ► ProfileKeyMacro()()()
Initializes a new instance of the ProfileKeyMacro class
Declaration Syntax
C#
public ProfileKeyMacro()


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Rules.RuleMacros ► ProfileKeyMacro ► Execute(XElement, String, UrlString, String)
Executes the specified macro.
Declaration Syntax
C#
public void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
The element.
name (String)
The name of the field.
parameters (UrlString)
The parameters.
value (String)
The value.


ProfileMacro Class

ProfileMacro Class
Namespaces ► Sitecore.Rules.RuleMacros ► ProfileMacro
Defines the tree macro class.
Declaration Syntax
C#
public class ProfileMacro : IRuleMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProfileMacro()()() | Initializes a new instance of the ProfileMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | Executes the specified macro.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProfileMacro


ProfileMacro Constructor

ProfileMacro Constructor
Namespaces ► Sitecore.Rules.RuleMacros ► ProfileMacro ► ProfileMacro()()()
Initializes a new instance of the ProfileMacro class
Declaration Syntax
C#
public ProfileMacro()


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Rules.RuleMacros ► ProfileMacro ► Execute(XElement, String, UrlString, String)
Executes the specified macro.
Declaration Syntax
C#
public void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
The element.
name (String)
The name of the field.
parameters (UrlString)
The parameters.
value (String)
The value.


ScriptMacro Class

ScriptMacro Class
Namespaces ► Sitecore.Rules.RuleMacros ► ScriptMacro
Defines the tree macro class.
Declaration Syntax
C#
public class ScriptMacro : IRuleMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ScriptMacro()()() | Initializes a new instance of the ScriptMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | Executes the specified macro.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ScriptMacro


ScriptMacro Constructor

ScriptMacro Constructor
Namespaces ► Sitecore.Rules.RuleMacros ► ScriptMacro ► ScriptMacro()()()
Initializes a new instance of the ScriptMacro class
Declaration Syntax
C#
public ScriptMacro()


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Rules.RuleMacros ► ScriptMacro ► Execute(XElement, String, UrlString, String)
Executes the specified macro.
Declaration Syntax
C#
public void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
The element.
name (String)
The name of the field.
parameters (UrlString)
The parameters.
value (String)
The value.


StringOperatorMacro Class

StringOperatorMacro Class
Namespaces ► Sitecore.Rules.RuleMacros ► StringOperatorMacro
Defines the tree macro class.
Declaration Syntax
C#
public class StringOperatorMacro : IRuleMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | StringOperatorMacro()()() | Initializes a new instance of the StringOperatorMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | Executes the specified macro.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
StringOperatorMacro


StringOperatorMacro Constructor

StringOperatorMacro Constructor
Namespaces ► Sitecore.Rules.RuleMacros ► StringOperatorMacro ► StringOperatorMacro()()()
Initializes a new instance of the StringOperatorMacro class
Declaration Syntax
C#
public StringOperatorMacro()


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Rules.RuleMacros ► StringOperatorMacro ► Execute(XElement, String, UrlString, String)
Executes the specified macro.
Declaration Syntax
C#
public void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
The element.
name (String)
The name of the field.
parameters (UrlString)
The parameters.
value (String)
The value.


TemplateMacro Class

TemplateMacro Class
Namespaces ► Sitecore.Rules.RuleMacros ► TemplateMacro
Defines the tree macro class.
Declaration Syntax
C#
public class TemplateMacro : IRuleMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TemplateMacro()()() | Initializes a new instance of the TemplateMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | Executes the specified macro.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TemplateMacro


TemplateMacro Constructor

TemplateMacro Constructor
Namespaces ► Sitecore.Rules.RuleMacros ► TemplateMacro ► TemplateMacro()()()
Initializes a new instance of the TemplateMacro class
Declaration Syntax
C#
public TemplateMacro()


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Rules.RuleMacros ► TemplateMacro ► Execute(XElement, String, UrlString, String)
Executes the specified macro.
Declaration Syntax
C#
public void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
The element.
name (String)
The name of the field.
parameters (UrlString)
The parameters.
value (String)
The value.


TreeMacro Class

TreeMacro Class
Namespaces ► Sitecore.Rules.RuleMacros ► TreeMacro
Defines the tree macro class.
Declaration Syntax
C#
public class TreeMacro : IRuleMacro
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TreeMacro()()() | Initializes a new instance of the TreeMacro class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(XElement, String, UrlString, String) | Executes the specified macro.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TreeMacro


TreeMacro Constructor

TreeMacro Constructor
Namespaces ► Sitecore.Rules.RuleMacros ► TreeMacro ► TreeMacro()()()
Initializes a new instance of the TreeMacro class
Declaration Syntax
C#
public TreeMacro()


Execute Method (element, name, parameters, value)

Execute Method (element, name, parameters, value)
Namespaces ► Sitecore.Rules.RuleMacros ► TreeMacro ► Execute(XElement, String, UrlString, String)
Executes the specified macro.
Declaration Syntax
C#
public void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Parameters
element (XElement)
The element.
name (String)
The name of the field.
parameters (UrlString)
The parameters.
value (String)
The value.


Sitecore.Runtime.Testing Namespace

Sitecore.Runtime.Testing Namespace
Namespaces ► Sitecore.Runtime.Testing
Declaration Syntax
C#
namespace Sitecore.Runtime.Testing
Types
All Types Classes
Icon | Type | Description
 | TestConstants | Global constants


TestConstants Class

TestConstants Class
Namespaces ► Sitecore.Runtime.Testing ► TestConstants
Global constants
Declaration Syntax
C#
public class TestConstants
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TestConstants()()() | Initializes a new instance of the TestConstants class
 | aliasesPath |
 | aliaseTemplate |
 | contentNodePath |
 | coreDbIndexName |
 | dbArchiveName |
 | dbCoreName |
 | dbMasterName |
 | dbTempName |
 | defaultDatabase |
 | defaultSite |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | fldDisplayName |
 | fldLnkItem |
 | fldTitle |
 | folderSysTemplate |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | homeId |
 | homeNodePath |
 | masterId |
 | masterName |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | scRootNodePath |
 | templateName |
 | templatesPath |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TestConstants

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TestConstants Constructor

TestConstants Constructor
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► TestConstants()()()
Initializes a new instance of the TestConstants class
Declaration Syntax
C#
public TestConstants()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


aliasesPath Field

aliasesPath Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► aliasesPath
Declaration Syntax
C#
public const string aliasesPath

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


aliaseTemplate Field

aliaseTemplate Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► aliaseTemplate
Declaration Syntax
C#
public const string aliaseTemplate

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


contentNodePath Field

contentNodePath Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► contentNodePath
Declaration Syntax
C#
public const string contentNodePath

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


coreDbIndexName Field

coreDbIndexName Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► coreDbIndexName
Declaration Syntax
C#
public const string coreDbIndexName

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


dbArchiveName Field

dbArchiveName Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► dbArchiveName
Declaration Syntax
C#
public const string dbArchiveName

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


dbCoreName Field

dbCoreName Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► dbCoreName
Declaration Syntax
C#
public const string dbCoreName

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


dbMasterName Field

dbMasterName Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► dbMasterName
Declaration Syntax
C#
public const string dbMasterName

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


dbTempName Field

dbTempName Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► dbTempName
Declaration Syntax
C#
public const string dbTempName

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


defaultDatabase Field

defaultDatabase Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► defaultDatabase
Declaration Syntax
C#
public const string defaultDatabase

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


defaultSite Field

defaultSite Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► defaultSite
Declaration Syntax
C#
public const string defaultSite

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


fldDisplayName Field

fldDisplayName Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► fldDisplayName
Declaration Syntax
C#
public const string fldDisplayName

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


fldLnkItem Field

fldLnkItem Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► fldLnkItem
Declaration Syntax
C#
public const string fldLnkItem

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


fldTitle Field

fldTitle Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► fldTitle
Declaration Syntax
C#
public const string fldTitle

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


folderSysTemplate Field

folderSysTemplate Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► folderSysTemplate
Declaration Syntax
C#
public const string folderSysTemplate

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


homeId Field

homeId Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► homeId
Declaration Syntax
C#
public const string homeId

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


homeNodePath Field

homeNodePath Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► homeNodePath
Declaration Syntax
C#
public const string homeNodePath

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


masterId Field

masterId Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► masterId
Declaration Syntax
C#
public const string masterId

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


masterName Field

masterName Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► masterName
Declaration Syntax
C#
public const string masterName

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


scRootNodePath Field

scRootNodePath Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► scRootNodePath
Declaration Syntax
C#
public const string scRootNodePath

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


templateName Field

templateName Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► templateName
Declaration Syntax
C#
public const string templateName

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


templatesPath Field

templatesPath Field
Namespaces ► Sitecore.Runtime.Testing ► TestConstants ► templatesPath
Declaration Syntax
C#
public const string templatesPath

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Search Namespace

Sitecore.Search Namespace
Namespaces ► Sitecore.Search
Declaration Syntax
C#
namespace Sitecore.Search
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | BuiltinFields | Internal fields of quick-search index.
 | CombinedQuery | Combines simpler queries into a more complex one adding clause attributes
 | FieldQuery | Encapsulates query to a single field
 | FullTextQuery | Represents full-text search query
 | ILuceneIndex | Interface for an object implementing a lucene index.
 | Index | Wraps Lucene Index
 | IndexDeleteContext | Context for deleting documents from the index. Cannot be nested in IndexUpdateContext and vice versa.
 | IndexSearchContext | Provides context for index search operations
 | IndexUpdateContext | Provides context for index update operations
 | ISearchContext | Adds supplementary information to the search operation.
 | PreparedQuery | Encapsulates Query object that has been rewritten and decorated
 | QueryBase | Base class for Sitecore search queries
 | QueryClause | Encapsulates a single close in a combined query.
 | QueryOccurance | Specifies how query will relate to index documents.
 | SearchConfiguration | Wraps the settings of Lucene search engine used by indexes and search drivers.
 | SearchContext | Adds context information to the query
 | SearchHit | Encapsulates information
 | SearchHits | Wraps Lucene.NET's search hits into a .NET friendly object.
 | SearchManager | Encapsulates search functionality in Sitecore.
 | SearchResult | Represents a single search result. Abstracts Lucene Document API.
 | SearchResultCategoryCollection | Collection of results in a specific category.
 | SearchResultCollection | Simple search results collection.
 | SearchType | Represents the search type.


BuiltinFields Class

BuiltinFields Class
Namespaces ► Sitecore.Search ► BuiltinFields
Internal fields of quick-search index.
Declaration Syntax
C#
public static class BuiltinFields
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Content | Content field. This field is searched by default.
 | Created | Date when the item was created.
 | Creator | Account that created the item.
 | Database | The database the item belongs to.
 | Editor | Account the last modified the item.
 | Group | ID of the group that the document belongs to. I.e. item id for different versions of the same item.
 | Hidden | Flag field whether the item is hidden in the UI.
 | Icon | Item icon.
 | ID | Internal document ID. This is used by index itself to maintain documents.
 | Language | Language of the indexed data.
 | LatestVersion | Flag field: whether this version of the item is the latest version in its language.
 | Links | Item's outoing links.
 | Name | Name of the item.
 | Path | Indexed path of the item.
 | Tags | Crawler-specific item tags.
 | Template | Item template id.
 | Updated | Date when the item was last modified.
 | Url | URL to invoke the object behind the document.
Inheritance Hierarchy
Object
BuiltinFields


Content Field

Content Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Content
Content field. This field is searched by default.
Declaration Syntax
C#
public static readonly string Content


Created Field

Created Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Created
Date when the item was created.
Declaration Syntax
C#
public static readonly string Created


Creator Field

Creator Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Creator
Account that created the item.
Declaration Syntax
C#
public static readonly string Creator


Database Field

Database Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Database
The database the item belongs to.
Declaration Syntax
C#
public static readonly string Database


Editor Field

Editor Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Editor
Account the last modified the item.
Declaration Syntax
C#
public static readonly string Editor


Group Field

Group Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Group
ID of the group that the document belongs to. I.e. item id for different versions of the same item.
Declaration Syntax
C#
public static readonly string Group


Hidden Field

Hidden Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Hidden
Flag field whether the item is hidden in the UI.
Declaration Syntax
C#
public static readonly string Hidden


Icon Field

Icon Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Icon
Item icon.
Declaration Syntax
C#
public static string Icon


ID Field

ID Field
Namespaces ► Sitecore.Search ► BuiltinFields ► ID
Internal document ID. This is used by index itself to maintain documents.
Declaration Syntax
C#
public static readonly string ID


Language Field

Language Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Language
Language of the indexed data.
Declaration Syntax
C#
public static readonly string Language


LatestVersion Field

LatestVersion Field
Namespaces ► Sitecore.Search ► BuiltinFields ► LatestVersion
Flag field: whether this version of the item is the latest version in its language.
Declaration Syntax
C#
public static readonly string LatestVersion


Links Field

Links Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Links
Item's outoing links.
Declaration Syntax
C#
public static string Links


Name Field

Name Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Name
Name of the item.
Declaration Syntax
C#
public static readonly string Name


Path Field

Path Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Path
Indexed path of the item.
Declaration Syntax
C#
public static readonly string Path


Tags Field

Tags Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Tags
Crawler-specific item tags.
Declaration Syntax
C#
public static string Tags


Template Field

Template Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Template
Item template id.
Declaration Syntax
C#
public static readonly string Template


Updated Field

Updated Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Updated
Date when the item was last modified.
Declaration Syntax
C#
public static readonly string Updated


Url Field

Url Field
Namespaces ► Sitecore.Search ► BuiltinFields ► Url
URL to invoke the object behind the document.
Declaration Syntax
C#
public static readonly string Url


CombinedQuery Class

CombinedQuery Class
Namespaces ► Sitecore.Search ► CombinedQuery
Combines simpler queries into a more complex one adding clause attributes
Declaration Syntax
C#
public class CombinedQuery : QueryBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CombinedQuery()()() | Initializes a new instance of the CombinedQuery class.
 | CombinedQuery(IEnumerable<(Of <(QueryBase>)>)) | Initializes a new instance of the CombinedQuery class.
 | CombinedQuery(IEnumerable<(Of <(QueryClause>)>)) | Initializes a new instance of the CombinedQuery class.
 | Add(QueryBase, QueryOccurance) | Adds the specified query.
 | Clauses | Gets the clauses.
 | Clone()()() | Clones this instance. (Overrides QueryBase.Clone()()().)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | QueryBase
 |  | CombinedQuery


CombinedQuery Constructor

CombinedQuery Constructor
Namespaces ► Sitecore.Search ► CombinedQuery ► CombinedQuery()()()
Members
Icon | Member | Description
 | CombinedQuery()()() | Initializes a new instance of the CombinedQuery class.
 | CombinedQuery(IEnumerable<(Of <(QueryBase>)>)) | Initializes a new instance of the CombinedQuery class.
 | CombinedQuery(IEnumerable<(Of <(QueryClause>)>)) | Initializes a new instance of the CombinedQuery class.


CombinedQuery Constructor

CombinedQuery Constructor
Namespaces ► Sitecore.Search ► CombinedQuery ► CombinedQuery()()()
Initializes a new instance of the CombinedQuery class.
Declaration Syntax
C#
public CombinedQuery()


CombinedQuery Constructor (queries)

CombinedQuery Constructor (queries)
Namespaces ► Sitecore.Search ► CombinedQuery ► CombinedQuery(IEnumerable<(Of <(QueryBase>)>))
Initializes a new instance of the CombinedQuery class.
Declaration Syntax
C#
public CombinedQuery(
    IEnumerable<QueryBase> queries
)
Parameters
queries (IEnumerable<(Of <( QueryBase >)>))
The queries.


CombinedQuery Constructor (clauses)

CombinedQuery Constructor (clauses)
Namespaces ► Sitecore.Search ► CombinedQuery ► CombinedQuery(IEnumerable<(Of <(QueryClause>)>))
Initializes a new instance of the CombinedQuery class.
Declaration Syntax
C#
public CombinedQuery(
    IEnumerable<QueryClause> clauses
)
Parameters
clauses (IEnumerable<(Of <( QueryClause >)>))
The clauses.


Add Method (query, occurance)

Add Method (query, occurance)
Namespaces ► Sitecore.Search ► CombinedQuery ► Add(QueryBase, QueryOccurance)
Adds the specified query.
Declaration Syntax
C#
public void Add(
    QueryBase query,
    QueryOccurance occurance
)
Parameters
query (QueryBase)
The query.
occurance (QueryOccurance)
The occurance.


Clauses Property

Clauses Property
Namespaces ► Sitecore.Search ► CombinedQuery ► Clauses
Gets the clauses.
Declaration Syntax
C#
public IList<QueryClause> Clauses { get; }
Value
The clauses.


Clone Method

Clone Method
Namespaces ► Sitecore.Search ► CombinedQuery ► Clone()()()
Clones this instance.
Declaration Syntax
C#
public override Object Clone()
Return Value
The clone.


FieldQuery Class

FieldQuery Class
Namespaces ► Sitecore.Search ► FieldQuery
Encapsulates query to a single field
Declaration Syntax
C#
public class FieldQuery : QueryBase
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldQuery()()() | Initializes a new instance of the FieldQuery class.
 | FieldQuery(String, String) | Initializes a new instance of the FieldQuery class.
 | Clone()()() | Clones this instance. (Overrides QueryBase.Clone()()().)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldName | Gets or sets the name of the field.
 | FieldValue | Gets or sets the field value.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WildcardField | A special field name meaning 'all' fields.
Inheritance Hierarchy
Object
 | QueryBase
 |  | FieldQuery


FieldQuery Constructor

FieldQuery Constructor
Namespaces ► Sitecore.Search ► FieldQuery ► FieldQuery()()()
Members
Icon | Member | Description
 | FieldQuery()()() | Initializes a new instance of the FieldQuery class.
 | FieldQuery(String, String) | Initializes a new instance of the FieldQuery class.


FieldQuery Constructor

FieldQuery Constructor
Namespaces ► Sitecore.Search ► FieldQuery ► FieldQuery()()()
Initializes a new instance of the FieldQuery class.
Declaration Syntax
C#
public FieldQuery()


FieldQuery Constructor (fieldName, fieldValue)

FieldQuery Constructor (fieldName, fieldValue)
Namespaces ► Sitecore.Search ► FieldQuery ► FieldQuery(String, String)
Initializes a new instance of the FieldQuery class.
Declaration Syntax
C#
public FieldQuery(
    string fieldName,
    string fieldValue
)
Parameters
fieldName (String)
Name of the field.
fieldValue (String)
The field value.


Clone Method

Clone Method
Namespaces ► Sitecore.Search ► FieldQuery ► Clone()()()
Clones this instance.
Declaration Syntax
C#
public override Object Clone()
Return Value
The clone.


FieldName Property

FieldName Property
Namespaces ► Sitecore.Search ► FieldQuery ► FieldName
Gets or sets the name of the field.
Declaration Syntax
C#
public string FieldName { get; set; }
Value
The name of the field.


FieldValue Property

FieldValue Property
Namespaces ► Sitecore.Search ► FieldQuery ► FieldValue
Gets or sets the field value.
Declaration Syntax
C#
public string FieldValue { get; set; }
Value
The field value.


WildcardField Field

WildcardField Field
Namespaces ► Sitecore.Search ► FieldQuery ► WildcardField
A special field name meaning 'all' fields.
Declaration Syntax
C#
public static string WildcardField


FullTextQuery Class

FullTextQuery Class
Namespaces ► Sitecore.Search ► FullTextQuery
Represents full-text search query
Declaration Syntax
C#
public class FullTextQuery : QueryBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FullTextQuery()()() | Initializes a new instance of the FullTextQuery class.
 | FullTextQuery(String) | Initializes a new instance of the FullTextQuery class.
 | Clone()()() | Clones this instance. (Overrides QueryBase.Clone()()().)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Query | Gets or sets the query text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | QueryBase
 |  | FullTextQuery


FullTextQuery Constructor

FullTextQuery Constructor
Namespaces ► Sitecore.Search ► FullTextQuery ► FullTextQuery()()()
Members
Icon | Member | Description
 | FullTextQuery()()() | Initializes a new instance of the FullTextQuery class.
 | FullTextQuery(String) | Initializes a new instance of the FullTextQuery class.


FullTextQuery Constructor

FullTextQuery Constructor
Namespaces ► Sitecore.Search ► FullTextQuery ► FullTextQuery()()()
Initializes a new instance of the FullTextQuery class.
Declaration Syntax
C#
public FullTextQuery()


FullTextQuery Constructor (query)

FullTextQuery Constructor (query)
Namespaces ► Sitecore.Search ► FullTextQuery ► FullTextQuery(String)
Initializes a new instance of the FullTextQuery class.
Declaration Syntax
C#
public FullTextQuery(
    string query
)
Parameters
query (String)
The query.


Clone Method

Clone Method
Namespaces ► Sitecore.Search ► FullTextQuery ► Clone()()()
Clones this instance.
Declaration Syntax
C#
public override Object Clone()
Return Value
The clone.


Query Property

Query Property
Namespaces ► Sitecore.Search ► FullTextQuery ► Query
Gets or sets the query text.
Declaration Syntax
C#
public string Query { get; set; }
Value
The query.


ILuceneIndex Interface

ILuceneIndex Interface
Namespaces ► Sitecore.Search ► ILuceneIndex
Interface for an object implementing a lucene index.
Declaration Syntax
C#
public interface ILuceneIndex
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Analyzer | Gets the analyzer.
 | CreateSearcher(Boolean) | Creates the searcher.
 | CreateWriter(Boolean) | Creates the writer.
 | Directory | Gets the directory.


Analyzer Property

Analyzer Property
Namespaces ► Sitecore.Search ► ILuceneIndex ► Analyzer
Gets the analyzer.
Declaration Syntax
C#
Analyzer Analyzer { get; }
Value
The analyzer.


CreateSearcher Method (close)

CreateSearcher Method (close)
Namespaces ► Sitecore.Search ► ILuceneIndex ► CreateSearcher(Boolean)
Creates the searcher.
Declaration Syntax
C#
IndexSearcher CreateSearcher(
    bool close
)
Parameters
close (Boolean)
if set to true this searcher will close underlying reader on Close().
Return Value
The searcher.


CreateWriter Method (recreate)

CreateWriter Method (recreate)
Namespaces ► Sitecore.Search ► ILuceneIndex ► CreateWriter(Boolean)
Creates the writer.
Declaration Syntax
C#
IndexWriter CreateWriter(
    bool recreate
)
Parameters
recreate (Boolean)
if set to true the write will recreate the index.
Return Value
The writer.


Directory Property

Directory Property
Namespaces ► Sitecore.Search ► ILuceneIndex ► Directory
Gets the directory.
Declaration Syntax
C#
Directory Directory { get; }
Value
The directory.


Index Class

Index Class
Namespaces ► Sitecore.Search ► Index
Wraps Lucene Index
Declaration Syntax
C#
public class Index : ILuceneIndex
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Index(String, String) | Initializes a new instance of the Index class.
 | AddCrawler(ICrawler) | Adds the crawler.
 | Analyzer | Sets the configuration for this index.
 | CreateDeleteContext()()() | Creates the delete context.
 | CreateDirectory(String) | Creates the directory.
 | CreateReader()()() | Creates the reader.
 | CreateSearchContext()()() | Creates the search context.
 | CreateSearcher(Boolean) | Creates the searcher.
 | CreateUpdateContext()()() | Creates the update context.
 | CreateWriter(Boolean) | Creates the writer.
 | Directory | Gets the directory.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDocumentCount()()() | Gets the document count.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Rebuild()()() | Rebuilds this index.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Index


Index Constructor (name, folder)

Index Constructor (name, folder)
Namespaces ► Sitecore.Search ► Index ► Index(String, String)
Initializes a new instance of the Index class.
Declaration Syntax
C#
public Index(
    string name,
    string folder
)
Parameters
name (String)
The name.
folder (String)
The folder.


AddCrawler Method (crawler)

AddCrawler Method (crawler)
Namespaces ► Sitecore.Search ► Index ► AddCrawler(ICrawler)
Adds the crawler.
Declaration Syntax
C#
public void AddCrawler(
    ICrawler crawler
)
Parameters
crawler (ICrawler)
The crawler.


Analyzer Property

Analyzer Property
Namespaces ► Sitecore.Search ► Index ► Analyzer
Sets the configuration for this index.
Declaration Syntax
C#
public Analyzer Analyzer { get; set; }
Value
The analyzer.


CreateDeleteContext Method

CreateDeleteContext Method
Namespaces ► Sitecore.Search ► Index ► CreateDeleteContext()()()
Creates the delete context.
Declaration Syntax
C#
public IndexDeleteContext CreateDeleteContext()
Return Value
The delete context.


CreateDirectory Method (folder)

CreateDirectory Method (folder)
Namespaces ► Sitecore.Search ► Index ► CreateDirectory(String)
Creates the directory.
Declaration Syntax
C#
protected virtual FSDirectory CreateDirectory(
    string folder
)
Parameters
folder (String)
The folder.
Return Value
The directory.


CreateReader Method

CreateReader Method
Namespaces ► Sitecore.Search ► Index ► CreateReader()()()
Creates the reader.
Declaration Syntax
C#
protected virtual IndexReader CreateReader()
Return Value
The reader.


CreateSearchContext Method

CreateSearchContext Method
Namespaces ► Sitecore.Search ► Index ► CreateSearchContext()()()
Creates the search context.
Declaration Syntax
C#
public IndexSearchContext CreateSearchContext()
Return Value
The search context.


CreateSearcher Method (close)

CreateSearcher Method (close)
Namespaces ► Sitecore.Search ► Index ► CreateSearcher(Boolean)
Creates the searcher.
Declaration Syntax
C#
protected virtual IndexSearcher CreateSearcher(
    bool close
)
Parameters
close (Boolean)
if set to true this instance is close.
Return Value
The searcher.


CreateUpdateContext Method

CreateUpdateContext Method
Namespaces ► Sitecore.Search ► Index ► CreateUpdateContext()()()
Creates the update context.
Declaration Syntax
C#
public IndexUpdateContext CreateUpdateContext()
Return Value
The update context.


CreateWriter Method (recreate)

CreateWriter Method (recreate)
Namespaces ► Sitecore.Search ► Index ► CreateWriter(Boolean)
Creates the writer.
Declaration Syntax
C#
protected virtual IndexWriter CreateWriter(
    bool recreate
)
Parameters
recreate (Boolean)
if set to true this instance is recreate.
Return Value
The writer.


Directory Property

Directory Property
Namespaces ► Sitecore.Search ► Index ► Directory
Gets the directory.
Declaration Syntax
C#
public Directory Directory { get; }
Value
The directory.


GetDocumentCount Method

GetDocumentCount Method
Namespaces ► Sitecore.Search ► Index ► GetDocumentCount()()()
Gets the document count.
Declaration Syntax
C#
public int GetDocumentCount()
Return Value
The document count.


Name Property

Name Property
Namespaces ► Sitecore.Search ► Index ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Rebuild Method

Rebuild Method
Namespaces ► Sitecore.Search ► Index ► Rebuild()()()
Rebuilds this index.
Declaration Syntax
C#
public void Rebuild()


IndexDeleteContext Class

IndexDeleteContext Class
Namespaces ► Sitecore.Search ► IndexDeleteContext
Context for deleting documents from the index. Cannot be nested in IndexUpdateContext and vice versa.
Declaration Syntax
C#
public class IndexDeleteContext : IndexSearchContext,
    IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexDeleteContext(ILuceneIndex) | Initializes a new instance of the IndexDeleteContext class.
 | Commit()()() | Commits this instance.
 | CreateBooleanQuery(Boolean, Single, array<Object>[]()[]) | Creates the boolean query. (Inherited from IndexSearchContext.)
 | CreateBooleanQuery(BooleanQuery, array<Object>[]()[]) | Creates the boolean query. (Inherited from IndexSearchContext.)
 | CreatePrefixQuery(String, String, Single) | Creates the prefix query. (Inherited from IndexSearchContext.)
 | CreatePrefixQuery(TermQuery) | Creates the prefix query. (Inherited from IndexSearchContext.)
 | CreateTermQuery(String, String, Single) | Creates the term query. (Inherited from IndexSearchContext.)
 | DeleteDocument(Int32) | Deletes the document.
 | DeleteDocuments(String, String) | Deletes the documents.
 | DeleteDocuments(IEnumerable<(Of <(Int32>)>)) | Deletes the documents.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Explain(PreparedQuery, Int32) | Explains the specified query. (Inherited from IndexSearchContext.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(ILuceneIndex, Boolean) | Initializes the specified index. For use in descendants' constructors. (Inherited from IndexSearchContext.)
 | InternalParse(String) | Internals the parse. (Inherited from IndexSearchContext.)
 | InternalParse(String, String) | Internals the parse. (Inherited from IndexSearchContext.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Parses the specified query. (Inherited from IndexSearchContext.)
 | Parse(String, ISearchContext) | Parses the specified query. (Inherited from IndexSearchContext.)
 | Prepare(QueryBase) | Prepares the specified query. (Inherited from IndexSearchContext.)
 | Prepare(QueryBase, ISearchContext) | Prepares the specified query. (Inherited from IndexSearchContext.)
 | Prepare(Query, ISearchContext) | Prepares the specified query. (Inherited from IndexSearchContext.)
 | Reader | Gets the reader.
 | Search(String) | Searches the specified query. (Inherited from IndexSearchContext.)
 | Search(String, ISearchContext) | Searches the specified query. (Inherited from IndexSearchContext.)
 | Search(Query) | Searches the specified query. (Inherited from IndexSearchContext.)
 | Search(Query, ISearchContext) | Searches the specified query. (Inherited from IndexSearchContext.)
 | Search(QueryBase) | Searches the specified query. (Inherited from IndexSearchContext.)
 | Search(QueryBase, ISearchContext) | Searches the specified query. (Inherited from IndexSearchContext.)
 | Search(PreparedQuery) | Searches the specified query. (Inherited from IndexSearchContext.)
 | Searcher | Gets the IndexSearcher instance incapsulated in the context. This is compatibility property for use with other Lucene-based components. (Inherited from IndexSearchContext.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Translate(QueryBase) | Translates the specified query. (Inherited from IndexSearchContext.)
Inheritance Hierarchy
Object
 | IndexSearchContext
 |  | IndexDeleteContext


IndexDeleteContext Constructor (index)

IndexDeleteContext Constructor (index)
Namespaces ► Sitecore.Search ► IndexDeleteContext ► IndexDeleteContext(ILuceneIndex)
Initializes a new instance of the IndexDeleteContext class.
Declaration Syntax
C#
public IndexDeleteContext(
    ILuceneIndex index
)
Parameters
index (ILuceneIndex)
The index.


Commit Method

Commit Method
Namespaces ► Sitecore.Search ► IndexDeleteContext ► Commit()()()
Commits this instance.
Declaration Syntax
C#
public void Commit()


DeleteDocument Method (id)

DeleteDocument Method (id)
Namespaces ► Sitecore.Search ► IndexDeleteContext ► DeleteDocument(Int32)
Deletes the document.
Declaration Syntax
C#
public void DeleteDocument(
    int id
)
Parameters
id (Int32)
The id.


DeleteDocuments Method

DeleteDocuments Method
Namespaces ► Sitecore.Search ► IndexDeleteContext ► DeleteDocuments()()()
Members
Icon | Member | Description
 | DeleteDocuments(String, String) | Deletes the documents.
 | DeleteDocuments(IEnumerable<(Of <(Int32>)>)) | Deletes the documents.


DeleteDocuments Method (ids)

DeleteDocuments Method (ids)
Namespaces ► Sitecore.Search ► IndexDeleteContext ► DeleteDocuments(IEnumerable<(Of <(Int32>)>))
Deletes the documents.
Declaration Syntax
C#
public void DeleteDocuments(
    IEnumerable<int> ids
)
Parameters
ids (IEnumerable<(Of <(Int32>)>))
The ids.


DeleteDocuments Method (field, value)

DeleteDocuments Method (field, value)
Namespaces ► Sitecore.Search ► IndexDeleteContext ► DeleteDocuments(String, String)
Deletes the documents.
Declaration Syntax
C#
public void DeleteDocuments(
    string field,
    string value
)
Parameters
field (String)
The field.
value (String)
The value.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Search ► IndexDeleteContext ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


Reader Property

Reader Property
Namespaces ► Sitecore.Search ► IndexDeleteContext ► Reader
Gets the reader.
Declaration Syntax
C#
public IndexReader Reader { get; }
Value
The reader.


IndexSearchContext Class

IndexSearchContext Class
Namespaces ► Sitecore.Search ► IndexSearchContext
Provides context for index search operations
Declaration Syntax
C#
public class IndexSearchContext : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexSearchContext(ILuceneIndex) | Initializes a new instance of the IndexSearchContext class.
 | IndexSearchContext()()() | Initializes a new instance of the IndexSearchContext class.
 | CreateBooleanQuery(Boolean, Single, array<Object>[]()[]) | Creates the boolean query.
 | CreateBooleanQuery(BooleanQuery, array<Object>[]()[]) | Creates the boolean query.
 | CreatePrefixQuery(String, String, Single) | Creates the prefix query.
 | CreatePrefixQuery(TermQuery) | Creates the prefix query.
 | CreateTermQuery(String, String, Single) | Creates the term query.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Explain(PreparedQuery, Int32) | Explains the specified query.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(ILuceneIndex, Boolean) | Initializes the specified index. For use in descendants' constructors.
 | InternalParse(String) | Internals the parse.
 | InternalParse(String, String) | Internals the parse.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Parses the specified query.
 | Parse(String, ISearchContext) | Parses the specified query.
 | Prepare(QueryBase) | Prepares the specified query.
 | Prepare(QueryBase, ISearchContext) | Prepares the specified query.
 | Prepare(Query, ISearchContext) | Prepares the specified query.
 | Search(String) | Searches the specified query.
 | Search(String, ISearchContext) | Searches the specified query.
 | Search(Query) | Searches the specified query.
 | Search(Query, ISearchContext) | Searches the specified query.
 | Search(QueryBase) | Searches the specified query.
 | Search(QueryBase, ISearchContext) | Searches the specified query.
 | Search(PreparedQuery) | Searches the specified query.
 | Searcher | Gets the IndexSearcher instance incapsulated in the context. This is compatibility property for use with other Lucene-based components.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Translate(QueryBase) | Translates the specified query.
Inheritance Hierarchy
Object
 | IndexSearchContext
 |  | IndexDeleteContext


IndexSearchContext Constructor

IndexSearchContext Constructor
Namespaces ► Sitecore.Search ► IndexSearchContext ► IndexSearchContext()()()
Members
Icon | Member | Description
 | IndexSearchContext(ILuceneIndex) | Initializes a new instance of the IndexSearchContext class.
 | IndexSearchContext()()() | Initializes a new instance of the IndexSearchContext class.


IndexSearchContext Constructor

IndexSearchContext Constructor
Namespaces ► Sitecore.Search ► IndexSearchContext ► IndexSearchContext()()()
Initializes a new instance of the IndexSearchContext class.
Declaration Syntax
C#
protected IndexSearchContext()


IndexSearchContext Constructor (index)

IndexSearchContext Constructor (index)
Namespaces ► Sitecore.Search ► IndexSearchContext ► IndexSearchContext(ILuceneIndex)
Initializes a new instance of the IndexSearchContext class.
Declaration Syntax
C#
public IndexSearchContext(
    ILuceneIndex index
)
Parameters
index (ILuceneIndex)
The index.


CreateBooleanQuery Method

CreateBooleanQuery Method
Namespaces ► Sitecore.Search ► IndexSearchContext ► CreateBooleanQuery()()()
Members
Icon | Member | Description
 | CreateBooleanQuery(Boolean, Single, array<Object>[]()[]) | Creates the boolean query.
 | CreateBooleanQuery(BooleanQuery, array<Object>[]()[]) | Creates the boolean query.


CreateBooleanQuery Method (prototype, args)

CreateBooleanQuery Method (prototype, args)
Namespaces ► Sitecore.Search ► IndexSearchContext ► CreateBooleanQuery(BooleanQuery, array<Object>[]()[])
Creates the boolean query.
Declaration Syntax
C#
protected BooleanQuery CreateBooleanQuery(
    BooleanQuery prototype,
    params Object[] args
)
Parameters
prototype (BooleanQuery)
The prototype.
args (array< Object >[]()[])
The arguments.
Return Value
The boolean query.


CreateBooleanQuery Method (disableCoord, boost, args)

CreateBooleanQuery Method (disableCoord, boost, args)
Namespaces ► Sitecore.Search ► IndexSearchContext ► CreateBooleanQuery(Boolean, Single, array<Object>[]()[])
Creates the boolean query.
Declaration Syntax
C#
protected BooleanQuery CreateBooleanQuery(
    bool disableCoord,
    float boost,
    params Object[] args
)
Parameters
disableCoord (Boolean)
if set to true this instance is disable coord.
boost (Single)
The boost.
args (array< Object >[]()[])
The arguments.
Return Value
The boolean query.


CreatePrefixQuery Method

CreatePrefixQuery Method
Namespaces ► Sitecore.Search ► IndexSearchContext ► CreatePrefixQuery()()()
Members
Icon | Member | Description
 | CreatePrefixQuery(String, String, Single) | Creates the prefix query.
 | CreatePrefixQuery(TermQuery) | Creates the prefix query.


CreatePrefixQuery Method (termQuery)

CreatePrefixQuery Method (termQuery)
Namespaces ► Sitecore.Search ► IndexSearchContext ► CreatePrefixQuery(TermQuery)
Creates the prefix query.
Declaration Syntax
C#
protected PrefixQuery CreatePrefixQuery(
    TermQuery termQuery
)
Parameters
termQuery (TermQuery)
The term query.
Return Value
The prefix query.


CreatePrefixQuery Method (name, value, boost)

CreatePrefixQuery Method (name, value, boost)
Namespaces ► Sitecore.Search ► IndexSearchContext ► CreatePrefixQuery(String, String, Single)
Creates the prefix query.
Declaration Syntax
C#
protected PrefixQuery CreatePrefixQuery(
    string name,
    string value,
    float boost
)
Parameters
name (String)
The name.
value (String)
The value.
boost (Single)
The boost.
Return Value
The prefix query.


CreateTermQuery Method (name, value, boost)

CreateTermQuery Method (name, value, boost)
Namespaces ► Sitecore.Search ► IndexSearchContext ► CreateTermQuery(String, String, Single)
Creates the term query.
Declaration Syntax
C#
protected TermQuery CreateTermQuery(
    string name,
    string value,
    float boost
)
Parameters
name (String)
The name.
value (String)
The value.
boost (Single)
The boost.
Return Value
The term query.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Search ► IndexSearchContext ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


Explain Method (query, doc)

Explain Method (query, doc)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Explain(PreparedQuery, Int32)
Explains the specified query.
Declaration Syntax
C#
public Explanation Explain(
    PreparedQuery query,
    int doc
)
Parameters
query (PreparedQuery)
The query.
doc (Int32)
The doc.
Return Value
The explanation.


Initialize Method (index, close)

Initialize Method (index, close)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Initialize(ILuceneIndex, Boolean)
Initializes the specified index. For use in descendants' constructors.
Declaration Syntax
C#
protected void Initialize(
    ILuceneIndex index,
    bool close
)
Parameters
index (ILuceneIndex)
The index.
close (Boolean)
If true create searcher that will close underlying reader.


InternalParse Method

InternalParse Method
Namespaces ► Sitecore.Search ► IndexSearchContext ► InternalParse()()()
Members
Icon | Member | Description
 | InternalParse(String) | Internals the parse.
 | InternalParse(String, String) | Internals the parse.


InternalParse Method (query)

InternalParse Method (query)
Namespaces ► Sitecore.Search ► IndexSearchContext ► InternalParse(String)
Internals the parse.
Declaration Syntax
C#
protected Query InternalParse(
    string query
)
Parameters
query (String)
The query.
Return Value
The parse.


InternalParse Method (query, defaultField)

InternalParse Method (query, defaultField)
Namespaces ► Sitecore.Search ► IndexSearchContext ► InternalParse(String, String)
Internals the parse.
Declaration Syntax
C#
protected Query InternalParse(
    string query,
    string defaultField
)
Parameters
query (String)
The query.
defaultField (String)
The default field.
Return Value
The parse.


Parse Method

Parse Method
Namespaces ► Sitecore.Search ► IndexSearchContext ► Parse()()()
Members
Icon | Member | Description
 | Parse(String) | Parses the specified query.
 | Parse(String, ISearchContext) | Parses the specified query.


Parse Method (query)

Parse Method (query)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Parse(String)
Parses the specified query.
Declaration Syntax
C#
public PreparedQuery Parse(
    string query
)
Parameters
query (String)
The query.
Return Value
The parse.


Parse Method (query, context)

Parse Method (query, context)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Parse(String, ISearchContext)
Parses the specified query.
Declaration Syntax
C#
public PreparedQuery Parse(
    string query,
    ISearchContext context
)
Parameters
query (String)
The query.
context (ISearchContext)
The context.
Return Value
Parsed and prepared query.


Prepare Method

Prepare Method
Namespaces ► Sitecore.Search ► IndexSearchContext ► Prepare()()()
Members
Icon | Member | Description
 | Prepare(QueryBase) | Prepares the specified query.
 | Prepare(QueryBase, ISearchContext) | Prepares the specified query.
 | Prepare(Query, ISearchContext) | Prepares the specified query.


Prepare Method (query, context)

Prepare Method (query, context)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Prepare(Query, ISearchContext)
Prepares the specified query.
Declaration Syntax
C#
protected PreparedQuery Prepare(
    Query query,
    ISearchContext context
)
Parameters
query (Query)
The query.
context (ISearchContext)
The context.
Return Value
The prepare.


Prepare Method (query)

Prepare Method (query)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Prepare(QueryBase)
Prepares the specified query.
Declaration Syntax
C#
public PreparedQuery Prepare(
    QueryBase query
)
Parameters
query (QueryBase)
The query.
Return Value
The prepare.


Prepare Method (query, context)

Prepare Method (query, context)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Prepare(QueryBase, ISearchContext)
Prepares the specified query.
Declaration Syntax
C#
public PreparedQuery Prepare(
    QueryBase query,
    ISearchContext context
)
Parameters
query (QueryBase)
The query.
context (ISearchContext)
The context.
Return Value
The prepare.


Search Method

Search Method
Namespaces ► Sitecore.Search ► IndexSearchContext ► Search()()()
Members
Icon | Member | Description
 | Search(String) | Searches the specified query.
 | Search(String, ISearchContext) | Searches the specified query.
 | Search(Query) | Searches the specified query.
 | Search(Query, ISearchContext) | Searches the specified query.
 | Search(QueryBase) | Searches the specified query.
 | Search(QueryBase, ISearchContext) | Searches the specified query.
 | Search(PreparedQuery) | Searches the specified query.


Search Method (query)

Search Method (query)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Search(Query)
Searches the specified query.
Declaration Syntax
C#
public SearchHits Search(
    Query query
)
Parameters
query (Query)
The query.
Return Value
The search.


Search Method (query, context)

Search Method (query, context)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Search(Query, ISearchContext)
Searches the specified query.
Declaration Syntax
C#
public SearchHits Search(
    Query query,
    ISearchContext context
)
Parameters
query (Query)
The query.
context (ISearchContext)
The context.
Return Value
The search.


Search Method (query)

Search Method (query)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Search(PreparedQuery)
Searches the specified query.
Declaration Syntax
C#
public SearchHits Search(
    PreparedQuery query
)
Parameters
query (PreparedQuery)
The query.
Return Value
The search.


Search Method (query)

Search Method (query)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Search(QueryBase)
Searches the specified query.
Declaration Syntax
C#
public SearchHits Search(
    QueryBase query
)
Parameters
query (QueryBase)
The query.
Return Value
The search.


Search Method (query, context)

Search Method (query, context)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Search(QueryBase, ISearchContext)
Searches the specified query.
Declaration Syntax
C#
public SearchHits Search(
    QueryBase query,
    ISearchContext context
)
Parameters
query (QueryBase)
The query.
context (ISearchContext)
The context.
Return Value
The search.


Search Method (query)

Search Method (query)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Search(String)
Searches the specified query.
Declaration Syntax
C#
public SearchHits Search(
    string query
)
Parameters
query (String)
The query.
Return Value
The search.


Search Method (query, context)

Search Method (query, context)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Search(String, ISearchContext)
Searches the specified query.
Declaration Syntax
C#
public SearchHits Search(
    string query,
    ISearchContext context
)
Parameters
query (String)
The query.
context (ISearchContext)
The context.
Return Value
The search.


Searcher Property

Searcher Property
Namespaces ► Sitecore.Search ► IndexSearchContext ► Searcher
Gets the IndexSearcher instance incapsulated in the context. This is compatibility property for use with other Lucene-based components.
Declaration Syntax
C#
public IndexSearcher Searcher { get; }
Value
An instance of IndexSearcher class.


Translate Method (query)

Translate Method (query)
Namespaces ► Sitecore.Search ► IndexSearchContext ► Translate(QueryBase)
Translates the specified query.
Declaration Syntax
C#
protected virtual Query Translate(
    QueryBase query
)
Parameters
query (QueryBase)
The query.
Return Value
Lucene query matching the specified query.


IndexUpdateContext Class

IndexUpdateContext Class
Namespaces ► Sitecore.Search ► IndexUpdateContext
Provides context for index update operations
Declaration Syntax
C#
public class IndexUpdateContext : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IndexUpdateContext(ILuceneIndex) | Initializes a new instance of the IndexUpdateContext class.
 | AddDocument(Document) | Adds the document.
 | Commit()()() | Commits changes in this instance.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
IndexUpdateContext


IndexUpdateContext Constructor (index)

IndexUpdateContext Constructor (index)
Namespaces ► Sitecore.Search ► IndexUpdateContext ► IndexUpdateContext(ILuceneIndex)
Initializes a new instance of the IndexUpdateContext class.
Declaration Syntax
C#
public IndexUpdateContext(
    ILuceneIndex index
)
Parameters
index (ILuceneIndex)
The index.


AddDocument Method (document)

AddDocument Method (document)
Namespaces ► Sitecore.Search ► IndexUpdateContext ► AddDocument(Document)
Adds the document.
Declaration Syntax
C#
public void AddDocument(
    Document document
)
Parameters
document (Document)
The document.


Commit Method

Commit Method
Namespaces ► Sitecore.Search ► IndexUpdateContext ► Commit()()()
Commits changes in this instance.
Declaration Syntax
C#
public void Commit()


Dispose Method

Dispose Method
Namespaces ► Sitecore.Search ► IndexUpdateContext ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


ISearchContext Interface

ISearchContext Interface
Namespaces ► Sitecore.Search ► ISearchContext
Adds supplementary information to the search operation.
Declaration Syntax
C#
public interface ISearchContext
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Decorate(Query) | Decorates the specified query adding context information.


Decorate Method (query)

Decorate Method (query)
Namespaces ► Sitecore.Search ► ISearchContext ► Decorate(Query)
Decorates the specified query adding context information.
Declaration Syntax
C#
Query Decorate(
    Query query
)
Parameters
query (Query)
The source query.
Return Value
The decorated query.


PreparedQuery Class

PreparedQuery Class
Namespaces ► Sitecore.Search ► PreparedQuery
Encapsulates Query object that has been rewritten and decorated
Declaration Syntax
C#
public class PreparedQuery
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PreparedQuery(Query) | Initializes a new instance of the PreparedQuery class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Query | Gets the query.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PreparedQuery


PreparedQuery Constructor (query)

PreparedQuery Constructor (query)
Namespaces ► Sitecore.Search ► PreparedQuery ► PreparedQuery(Query)
Initializes a new instance of the PreparedQuery class.
Declaration Syntax
C#
public PreparedQuery(
    Query query
)
Parameters
query (Query)
The query.


Query Property

Query Property
Namespaces ► Sitecore.Search ► PreparedQuery ► Query
Gets the query.
Declaration Syntax
C#
public Query Query { get; }
Value
The query.


QueryBase Class

QueryBase Class
Namespaces ► Sitecore.Search ► QueryBase
Base class for Sitecore search queries
Declaration Syntax
C#
public abstract class QueryBase : ICloneable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | QueryBase()()() | Initializes a new instance of the QueryBase class
 | Clone()()() | Creates a new object that is a copy of the current instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | QueryBase
 |  | CombinedQuery
 |  | FieldQuery
 |  | FullTextQuery


QueryBase Constructor

QueryBase Constructor
Namespaces ► Sitecore.Search ► QueryBase ► QueryBase()()()
Initializes a new instance of the QueryBase class
Declaration Syntax
C#
protected QueryBase()


Clone Method

Clone Method
Namespaces ► Sitecore.Search ► QueryBase ► Clone()()()
Creates a new object that is a copy of the current instance.
Declaration Syntax
C#
public abstract Object Clone()
Return Value
A new object that is a copy of this instance.


QueryClause Class

QueryClause Class
Namespaces ► Sitecore.Search ► QueryClause
Encapsulates a single close in a combined query.
Declaration Syntax
C#
public class QueryClause : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QueryClause()()() | Initializes a new instance of the QueryClause class.
 | QueryClause(QueryBase, QueryOccurance) | Initializes a new instance of the QueryClause class.
 | Clone()()() | Creates a new object that is a copy of the current instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Occurance | Gets or sets the occurance.
 | Query | Gets or sets the query.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
QueryClause


QueryClause Constructor

QueryClause Constructor
Namespaces ► Sitecore.Search ► QueryClause ► QueryClause()()()
Members
Icon | Member | Description
 | QueryClause()()() | Initializes a new instance of the QueryClause class.
 | QueryClause(QueryBase, QueryOccurance) | Initializes a new instance of the QueryClause class.


QueryClause Constructor

QueryClause Constructor
Namespaces ► Sitecore.Search ► QueryClause ► QueryClause()()()
Initializes a new instance of the QueryClause class.
Declaration Syntax
C#
public QueryClause()


QueryClause Constructor (query, occurance)

QueryClause Constructor (query, occurance)
Namespaces ► Sitecore.Search ► QueryClause ► QueryClause(QueryBase, QueryOccurance)
Initializes a new instance of the QueryClause class.
Declaration Syntax
C#
public QueryClause(
    QueryBase query,
    QueryOccurance occurance
)
Parameters
query (QueryBase)
The query.
occurance (QueryOccurance)
The occurance.


Clone Method

Clone Method
Namespaces ► Sitecore.Search ► QueryClause ► Clone()()()
Creates a new object that is a copy of the current instance.
Declaration Syntax
C#
public Object Clone()
Return Value
A new object that is a copy of this instance.


Occurance Property

Occurance Property
Namespaces ► Sitecore.Search ► QueryClause ► Occurance
Gets or sets the occurance.
Declaration Syntax
C#
public QueryOccurance Occurance { get; set; }
Value
The occurance.


Query Property

Query Property
Namespaces ► Sitecore.Search ► QueryClause ► Query
Gets or sets the query.
Declaration Syntax
C#
public QueryBase Query { get; set; }
Value
The query.


QueryOccurance Enumeration

QueryOccurance Enumeration
Namespaces ► Sitecore.Search ► QueryOccurance
Specifies how query will relate to index documents.
Declaration Syntax
C#
public enum QueryOccurance
Members
Member | Description
Must | Query must match the result documents.
MustNot | Query must not match the result documents
Should | Query may match the result documents, adding to the resulting score


SearchConfiguration Class

SearchConfiguration Class
Namespaces ► Sitecore.Search ► SearchConfiguration
Wraps the settings of Lucene search engine used by indexes and search drivers.
Declaration Syntax
C#
public class SearchConfiguration
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchConfiguration()()() | Initializes a new instance of the SearchConfiguration class
 | AddIndex(Index) | Adds the index.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Indexes | Gets the indexes.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SearchConfiguration


SearchConfiguration Constructor

SearchConfiguration Constructor
Namespaces ► Sitecore.Search ► SearchConfiguration ► SearchConfiguration()()()
Initializes a new instance of the SearchConfiguration class
Declaration Syntax
C#
public SearchConfiguration()


AddIndex Method (index)

AddIndex Method (index)
Namespaces ► Sitecore.Search ► SearchConfiguration ► AddIndex(Index)
Adds the index.
Declaration Syntax
C#
public void AddIndex(
    Index index
)
Parameters
index (Index)
The index.


Indexes Property

Indexes Property
Namespaces ► Sitecore.Search ► SearchConfiguration ► Indexes
Gets the indexes.
Declaration Syntax
C#
public Dictionary<string, Index> Indexes { get; }
Value
The indexes.


SearchContext Class

SearchContext Class
Namespaces ► Sitecore.Search ► SearchContext
Adds context information to the query
Declaration Syntax
C#
public class SearchContext : ISearchContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchContext()()() | Initializes a new instance of the SearchContext class.
 | SearchContext(Item) | Initializes a new instance of the SearchContext class.
 | SearchContext(User) | Initializes a new instance of the SearchContext class.
 | SearchContext(User, Item) | Initializes a new instance of the SearchContext class.
 | AddDecorations(BooleanQuery) | Adds the decorations to the BooleanQuery object. Override in derived class to change the way context affects queries.
 | Decorate(Query) | Decorates the specified query adding context information.
 | Empty | Returns empty SearchContext instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IgnoreContentEditorOptions | Gets or sets a value indicating whether the SearchContext ignores the content editor options.
 | Item | Gets or sets the context item for a search.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | User | Gets or sets the context user for a search.
Inheritance Hierarchy
Object
SearchContext


SearchContext Constructor

SearchContext Constructor
Namespaces ► Sitecore.Search ► SearchContext ► SearchContext()()()
Members
Icon | Member | Description
 | SearchContext()()() | Initializes a new instance of the SearchContext class.
 | SearchContext(Item) | Initializes a new instance of the SearchContext class.
 | SearchContext(User) | Initializes a new instance of the SearchContext class.
 | SearchContext(User, Item) | Initializes a new instance of the SearchContext class.


SearchContext Constructor

SearchContext Constructor
Namespaces ► Sitecore.Search ► SearchContext ► SearchContext()()()
Initializes a new instance of the SearchContext class.
Declaration Syntax
C#
public SearchContext()


SearchContext Constructor (item)

SearchContext Constructor (item)
Namespaces ► Sitecore.Search ► SearchContext ► SearchContext(Item)
Initializes a new instance of the SearchContext class.
Declaration Syntax
C#
public SearchContext(
    Item item
)
Parameters
item (Item)
The item.


SearchContext Constructor (user)

SearchContext Constructor (user)
Namespaces ► Sitecore.Search ► SearchContext ► SearchContext(User)
Initializes a new instance of the SearchContext class.
Declaration Syntax
C#
public SearchContext(
    User user
)
Parameters
user (User)
The user.


SearchContext Constructor (user, item)

SearchContext Constructor (user, item)
Namespaces ► Sitecore.Search ► SearchContext ► SearchContext(User, Item)
Initializes a new instance of the SearchContext class.
Declaration Syntax
C#
public SearchContext(
    User user,
    Item item
)
Parameters
user (User)
The user.
item (Item)
The item.


AddDecorations Method (result)

AddDecorations Method (result)
Namespaces ► Sitecore.Search ► SearchContext ► AddDecorations(BooleanQuery)
Adds the decorations to the BooleanQuery object. Override in derived class to change the way context affects queries.
Declaration Syntax
C#
protected virtual void AddDecorations(
    BooleanQuery result
)
Parameters
result (BooleanQuery)
The result.


Decorate Method (query)

Decorate Method (query)
Namespaces ► Sitecore.Search ► SearchContext ► Decorate(Query)
Decorates the specified query adding context information.
Declaration Syntax
C#
public Query Decorate(
    Query query
)
Parameters
query (Query)
The source query.
Return Value
The decorated query.


Empty Property

Empty Property
Namespaces ► Sitecore.Search ► SearchContext ► Empty
Returns empty SearchContext instance.
Declaration Syntax
C#
public static ISearchContext Empty { get; }
Value
Empty SearchContext instance.


IgnoreContentEditorOptions Property

IgnoreContentEditorOptions Property
Namespaces ► Sitecore.Search ► SearchContext ► IgnoreContentEditorOptions
Gets or sets a value indicating whether the SearchContext ignores the content editor options.
Declaration Syntax
C#
public bool IgnoreContentEditorOptions { get; set; }
Value
true if the SearchContext ignores the content editor options; otherwise, false.


Item Property

Item Property
Namespaces ► Sitecore.Search ► SearchContext ► Item
Gets or sets the context item for a search.
Declaration Syntax
C#
public Item Item { get; set; }
Value
The context item.


User Property

User Property
Namespaces ► Sitecore.Search ► SearchContext ► User
Gets or sets the context user for a search.
Declaration Syntax
C#
public User User { get; set; }
Value
The context user.


SearchHit Class

SearchHit Class
Namespaces ► Sitecore.Search ► SearchHit
Encapsulates information
Declaration Syntax
C#
public class SearchHit
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchHit(Int32, Hits) | Initializes a new instance of the SearchHit class.
 | Document | Gets the doc.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets the id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | Gets the position.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Url | Gets the URL.
Inheritance Hierarchy
Object
SearchHit


SearchHit Constructor (position, hits)

SearchHit Constructor (position, hits)
Namespaces ► Sitecore.Search ► SearchHit ► SearchHit(Int32, Hits)
Initializes a new instance of the SearchHit class.
Declaration Syntax
C#
public SearchHit(
    int position,
    Hits hits
)
Parameters
position (Int32)
The position.
hits (Hits)
The hits.


Document Property

Document Property
Namespaces ► Sitecore.Search ► SearchHit ► Document
Gets the doc.
Declaration Syntax
C#
public Document Document { get; }
Value
The doc.


Id Property

Id Property
Namespaces ► Sitecore.Search ► SearchHit ► Id
Gets the id.
Declaration Syntax
C#
public int Id { get; }
Value
The id.


Position Property

Position Property
Namespaces ► Sitecore.Search ► SearchHit ► Position
Gets the position.
Declaration Syntax
C#
public int Position { get; }
Value
The position.


Url Property

Url Property
Namespaces ► Sitecore.Search ► SearchHit ► Url
Gets the URL.
Declaration Syntax
C#
public string Url { get; }
Value
The URL.


SearchHits Class

SearchHits Class
Namespaces ► Sitecore.Search ► SearchHits
Wraps Lucene.NET's search hits into a .NET friendly object.
Declaration Syntax
C#
public class SearchHits
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchHits(Hits) | Initializes a new instance of the SearchHits class.
 | SearchHits()()() | Internal constructor to create empty instance of the class.
 | Documents | Gets the documents.
 | Empty | Gets the empty instance of SearchHits.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FetchResults(Int32, Int32) | Slices the result collection using specified start.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hits | Gets the hits.
 | Ids | Gets the document ids.
 | Item[([(Int32])]) | Gets the Document with the specified position.
 | Length | Gets the length.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Slice(Int32, Int32) | Extracts the specified range from the collection.
 | Slice(Int32) | Returns the collection starting with specified
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SearchHits


SearchHits Constructor

SearchHits Constructor
Namespaces ► Sitecore.Search ► SearchHits ► SearchHits()()()
Members
Icon | Member | Description
 | SearchHits(Hits) | Initializes a new instance of the SearchHits class.
 | SearchHits()()() | Internal constructor to create empty instance of the class.


SearchHits Constructor

SearchHits Constructor
Namespaces ► Sitecore.Search ► SearchHits ► SearchHits()()()
Internal constructor to create empty instance of the class.
Declaration Syntax
C#
protected SearchHits()


SearchHits Constructor (hits)

SearchHits Constructor (hits)
Namespaces ► Sitecore.Search ► SearchHits ► SearchHits(Hits)
Initializes a new instance of the SearchHits class.
Declaration Syntax
C#
public SearchHits(
    Hits hits
)
Parameters
hits (Hits)
The hits.


Documents Property

Documents Property
Namespaces ► Sitecore.Search ► SearchHits ► Documents
Gets the documents.
Declaration Syntax
C#
public virtual IEnumerable<Document> Documents { get; }
Value
The documents.


Empty Property

Empty Property
Namespaces ► Sitecore.Search ► SearchHits ► Empty
Gets the empty instance of SearchHits.
Declaration Syntax
C#
public static SearchHits Empty { get; }
Value
Empty instance of SearchHits class.


FetchResults Method (start, count)

FetchResults Method (start, count)
Namespaces ► Sitecore.Search ► SearchHits ► FetchResults(Int32, Int32)
Slices the result collection using specified start.
Declaration Syntax
C#
public virtual SearchResultCollection FetchResults(
    int start,
    int count
)
Parameters
start (Int32)
The start.
count (Int32)
The count.
Return Value
The slice.


Hits Property

Hits Property
Namespaces ► Sitecore.Search ► SearchHits ► Hits
Gets the hits.
Declaration Syntax
C#
public virtual IEnumerable<SearchHit> Hits { get; }
Value
The hits.


Ids Property

Ids Property
Namespaces ► Sitecore.Search ► SearchHits ► Ids
Gets the document ids.
Declaration Syntax
C#
public virtual IEnumerable<int> Ids { get; }
Value
The document ids.


Item Property (position)

Item Property (position)
Namespaces ► Sitecore.Search ► SearchHits ► Item[([(Int32])])
Gets the Document with the specified position.
Declaration Syntax
C#
public virtual Document this[
    int position
] { get; }
Parameters
position (Int32)
Value
The Document.


Length Property

Length Property
Namespaces ► Sitecore.Search ► SearchHits ► Length
Gets the length.
Declaration Syntax
C#
public virtual int Length { get; }
Value
The length.


Slice Method

Slice Method
Namespaces ► Sitecore.Search ► SearchHits ► Slice()()()
Members
Icon | Member | Description
 | Slice(Int32, Int32) | Extracts the specified range from the collection.
 | Slice(Int32) | Returns the collection starting with specified


Slice Method (start)

Slice Method (start)
Namespaces ► Sitecore.Search ► SearchHits ► Slice(Int32)
Returns the collection starting with specified
Declaration Syntax
C#
public virtual IEnumerable<SearchHit> Slice(
    int start
)
Parameters
start (Int32)
The start.
Return Value
The slice.


Slice Method (start, count)

Slice Method (start, count)
Namespaces ► Sitecore.Search ► SearchHits ► Slice(Int32, Int32)
Extracts the specified range from the collection.
Declaration Syntax
C#
public virtual IEnumerable<SearchHit> Slice(
    int start,
    int count
)
Parameters
start (Int32)
The start.
count (Int32)
The count.
Return Value
The slice.


SearchManager Class

SearchManager Class
Namespaces ► Sitecore.Search ► SearchManager
Encapsulates search functionality in Sitecore.
Declaration Syntax
C#
public static class SearchManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetIndex(String) | Gets the index.
 | GetObject(SearchResult) | Gets the object given the URL.
 | IndexCount | Gets the index count.
 | Initialize()()() | Initializes this instance.
 | SystemIndex | Gets the system index.
Inheritance Hierarchy
Object
SearchManager


GetIndex Method (id)

GetIndex Method (id)
Namespaces ► Sitecore.Search ► SearchManager ► GetIndex(String)
Gets the index.
Declaration Syntax
C#
public static Index GetIndex(
    string id
)
Parameters
id (String)
The id.
Return Value
The index.


GetObject Method (hit)

GetObject Method (hit)
Namespaces ► Sitecore.Search ► SearchManager ► GetObject(SearchResult)
Gets the object given the URL.
Declaration Syntax
C#
public static Object GetObject(
    SearchResult hit
)
Parameters
hit (SearchResult)
The hit.
Return Value
The object.


IndexCount Property

IndexCount Property
Namespaces ► Sitecore.Search ► SearchManager ► IndexCount
Gets the index count.
Declaration Syntax
C#
public static int IndexCount { get; }
Value
The index count.


Initialize Method

Initialize Method
Namespaces ► Sitecore.Search ► SearchManager ► Initialize()()()
Initializes this instance.
Declaration Syntax
C#
public static void Initialize()


SystemIndex Property

SystemIndex Property
Namespaces ► Sitecore.Search ► SearchManager ► SystemIndex
Gets the system index.
Declaration Syntax
C#
public static Index SystemIndex { get; }
Value
The system index.


SearchResult Class

SearchResult Class
Namespaces ► Sitecore.Search ► SearchResult
Represents a single search result. Abstracts Lucene Document API.
Declaration Syntax
C#
public class SearchResult : IEquatable<SearchResult>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchResult(SearchHit) | Initializes a new instance of the SearchResult class.
 | SearchResult(String, String, String) | Initializes a new instance of the SearchResult class.
 | _hit | Index Document behind this search result
 | Document | Gets the document.
 | Equals(SearchResult) | Equalses the specified search result.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromItem(Item) | Froms the item.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Overrides Object.GetHashCode()()().)
 | GetObject<(Of <(T>)>)()()() | Gets the object behind the document.
 | GetObject()()() | Gets the object.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets the icon.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Subresults | Gets the subresults.
 | Title | Gets the title.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Url | Gets the URL.
Inheritance Hierarchy
Object
SearchResult


SearchResult Constructor

SearchResult Constructor
Namespaces ► Sitecore.Search ► SearchResult ► SearchResult()()()
Members
Icon | Member | Description
 | SearchResult(SearchHit) | Initializes a new instance of the SearchResult class.
 | SearchResult(String, String, String) | Initializes a new instance of the SearchResult class.


SearchResult Constructor (hit)

SearchResult Constructor (hit)
Namespaces ► Sitecore.Search ► SearchResult ► SearchResult(SearchHit)
Initializes a new instance of the SearchResult class.
Declaration Syntax
C#
public SearchResult(
    SearchHit hit
)
Parameters
hit (SearchHit)
The hit.


SearchResult Constructor (title, icon, url)

SearchResult Constructor (title, icon, url)
Namespaces ► Sitecore.Search ► SearchResult ► SearchResult(String, String, String)
Initializes a new instance of the SearchResult class.
Declaration Syntax
C#
public SearchResult(
    string title,
    string icon,
    string url
)
Parameters
title (String)
The title.
icon (String)
The icon.
url (String)
The URL.


_hit Field

_hit Field
Namespaces ► Sitecore.Search ► SearchResult ► _hit
Index Document behind this search result
Declaration Syntax
C#
protected SearchHit _hit


Document Property

Document Property
Namespaces ► Sitecore.Search ► SearchResult ► Document
Gets the document.
Declaration Syntax
C#
public virtual Document Document { get; }
Value
The document.


Equals Method

Equals Method
Namespaces ► Sitecore.Search ► SearchResult ► Equals()()()
Members
Icon | Member | Description
 | Equals(SearchResult) | Equalses the specified search result.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)


Equals Method (searchResult)

Equals Method (searchResult)
Namespaces ► Sitecore.Search ► SearchResult ► Equals(SearchResult)
Equalses the specified search result.
Declaration Syntax
C#
public bool Equals(
    SearchResult searchResult
)
Parameters
searchResult (SearchResult)
The search result.
Return Value
The equals.


Equals Method (obj)

Equals Method (obj)
Namespaces ► Sitecore.Search ► SearchResult ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C#
public override bool Equals(
    Object obj
)
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.


FromItem Method (item)

FromItem Method (item)
Namespaces ► Sitecore.Search ► SearchResult ► FromItem(Item)
Froms the item.
Declaration Syntax
C#
public static SearchResult FromItem(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The item.


GetHashCode Method

GetHashCode Method
Namespaces ► Sitecore.Search ► SearchResult ► GetHashCode()()()
Serves as a hash function for a particular type.
Declaration Syntax
C#
public override int GetHashCode()
Return Value
A hash code for the current Object.


GetObject Method

GetObject Method
Namespaces ► Sitecore.Search ► SearchResult ► GetObject()()()
Members
Icon | Member | Description
 | GetObject<(Of <(T>)>)()()() | Gets the object behind the document.
 | GetObject()()() | Gets the object.


GetObject Method

GetObject Method
Namespaces ► Sitecore.Search ► SearchResult ► GetObject()()()
Gets the object.
Declaration Syntax
C#
protected virtual Object GetObject()
Return Value
The object.


GetObject Method

GetObject<(Of <(T>)>) Method
Namespaces ► Sitecore.Search ► SearchResult ► GetObject<(Of <(T>)>)()()()
Gets the object behind the document.
Declaration Syntax
C#
public T GetObject<T>()
where T : class
Generic Template Parameters
T
Expected type of the object
Return Value
The object instance activated by SearchManager.


Icon Property

Icon Property
Namespaces ► Sitecore.Search ► SearchResult ► Icon
Gets the icon.
Declaration Syntax
C#
public virtual string Icon { get; }
Value
The icon.


Subresults Property

Subresults Property
Namespaces ► Sitecore.Search ► SearchResult ► Subresults
Gets the subresults.
Declaration Syntax
C#
public IList<SearchResult> Subresults { get; }
Value
The subresults.


Title Property

Title Property
Namespaces ► Sitecore.Search ► SearchResult ► Title
Gets the title.
Declaration Syntax
C#
public virtual string Title { get; }
Value
The title.


Url Property

Url Property
Namespaces ► Sitecore.Search ► SearchResult ► Url
Gets the URL.
Declaration Syntax
C#
public virtual string Url { get; }
Value
The URL.


SearchResultCategoryCollection Class

SearchResultCategoryCollection Class
Namespaces ► Sitecore.Search ► SearchResultCategoryCollection
Collection of results in a specific category.
Declaration Syntax
C#
public class SearchResultCategoryCollection : IEnumerable<SearchResult>,
    IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchResultCategoryCollection(String, SearchResultCollection) | Initializes a new instance of the SearchResultCategoryCollection class.
 | Add(SearchResult) | Adds the specified result.
 | Count | Gets the count.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the SearchResult at the specified index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SearchResultCategoryCollection


SearchResultCategoryCollection Constructor (name, owner)

SearchResultCategoryCollection Constructor (name, owner)
Namespaces ► Sitecore.Search ► SearchResultCategoryCollection ► SearchResultCategoryCollection(String, SearchResultCollection)
Initializes a new instance of the SearchResultCategoryCollection class.
Declaration Syntax
C#
public SearchResultCategoryCollection(
    string name,
    SearchResultCollection owner
)
Parameters
name (String)
The name.
owner (SearchResultCollection)
The owner.


Add Method (result)

Add Method (result)
Namespaces ► Sitecore.Search ► SearchResultCategoryCollection ► Add(SearchResult)
Adds the specified result.
Declaration Syntax
C#
public void Add(
    SearchResult result
)
Parameters
result (SearchResult)
The result.


Count Property

Count Property
Namespaces ► Sitecore.Search ► SearchResultCategoryCollection ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


Item Property (index)

Item Property (index)
Namespaces ► Sitecore.Search ► SearchResultCategoryCollection ► Item[([(Int32])])
Gets the SearchResult at the specified index.
Declaration Syntax
C#
public SearchResult this[
    int index
] { get; }
Parameters
index (Int32)
Value
The SearchResult.


Name Property

Name Property
Namespaces ► Sitecore.Search ► SearchResultCategoryCollection ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


SearchResultCollection Class

SearchResultCollection Class
Namespaces ► Sitecore.Search ► SearchResultCollection
Simple search results collection.
Declaration Syntax
C#
public class SearchResultCollection : IEnumerable<SearchResult>,
    IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchResultCollection()()() | Initializes a new instance of the SearchResultCollection class
 | AddResult(SearchResult) | Adds the specified result.
 | AddResultToCategory(SearchResult, String) | Adds the result to category.
 | Categories | Gets the categories.
 | Contains(SearchResult) | Determines whether collection contains the specified result.
 | Count | Gets the number of results in the collection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCategory(String) | Gets the category results.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SearchResultCollection


SearchResultCollection Constructor

SearchResultCollection Constructor
Namespaces ► Sitecore.Search ► SearchResultCollection ► SearchResultCollection()()()
Initializes a new instance of the SearchResultCollection class
Declaration Syntax
C#
public SearchResultCollection()


AddResult Method (result)

AddResult Method (result)
Namespaces ► Sitecore.Search ► SearchResultCollection ► AddResult(SearchResult)
Adds the specified result.
Declaration Syntax
C#
public void AddResult(
    SearchResult result
)
Parameters
result (SearchResult)
The result.


AddResultToCategory Method (result, category)

AddResultToCategory Method (result, category)
Namespaces ► Sitecore.Search ► SearchResultCollection ► AddResultToCategory(SearchResult, String)
Adds the result to category.
Declaration Syntax
C#
public void AddResultToCategory(
    SearchResult result,
    string category
)
Parameters
result (SearchResult)
The result.
category (String)
The category.


Categories Property

Categories Property
Namespaces ► Sitecore.Search ► SearchResultCollection ► Categories
Gets the categories.
Declaration Syntax
C#
public IList<SearchResultCategoryCollection> Categories { get; }
Value
The categories.


Contains Method (result)

Contains Method (result)
Namespaces ► Sitecore.Search ► SearchResultCollection ► Contains(SearchResult)
Determines whether collection contains the specified result.
Declaration Syntax
C#
public bool Contains(
    SearchResult result
)
Parameters
result (SearchResult)
The result.
Return Value
true if collection contains the specified result; otherwise, false.


Count Property

Count Property
Namespaces ► Sitecore.Search ► SearchResultCollection ► Count
Gets the number of results in the collection.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


GetCategory Method (name)

GetCategory Method (name)
Namespaces ► Sitecore.Search ► SearchResultCollection ► GetCategory(String)
Gets the category results.
Declaration Syntax
C#
public SearchResultCategoryCollection GetCategory(
    string name
)
Parameters
name (String)
The name.
Return Value
The category.


SearchType Enumeration

SearchType Enumeration
Namespaces ► Sitecore.Search ► SearchType
Represents the search type.
Declaration Syntax
C#
public enum SearchType
Members
Member | Description
Instant | The instant search.
Classic | The classic search.
ContentEditor | Content editor search.


Sitecore.Search.Crawlers Namespace

Sitecore.Search.Crawlers Namespace
Namespaces ► Sitecore.Search.Crawlers
Declaration Syntax
C#
namespace Sitecore.Search.Crawlers
Types
All Types Classes Interfaces
Icon | Type | Description
 | BaseCrawler | Base class for ICrawler implementations
 | DatabaseCrawler | Implements crawler that scans and watches a specific location in the database
 | ICrawler | Interface of search crawler object


BaseCrawler Class

BaseCrawler Class
Namespaces ► Sitecore.Search.Crawlers ► BaseCrawler
Base class for ICrawler implementations
Declaration Syntax
C#
public class BaseCrawler
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseCrawler()()() | Initializes a new instance of the BaseCrawler class
 | Boost | Gets or sets the base boost of the crawler.
 | CreateDataField(String, String) | Creates the data field. Data field is not indexed but it stored in the index and can be retrieved during search. Typical sample of a data field is document URL.
 | CreateDataField(String, String, Single) | Creates the data field. Data field is not indexed but it stored in the index and can be retrieved during search. Typical sample of a data field is document URL.
 | CreateField(String, String, Boolean, Single) | Helper method to create fields.
 | CreateTextField(String, String) | Creates the text field. Text fields are not stored and are tokenized (split into words) when indexing.
 | CreateTextField(String, String, Single) | Creates the text field. Text fields are not stored and are tokenized (split into words) when indexing.
 | CreateValueField(String, String) | Creates the value field. Value fields are not stored, only indexed. Also, field value is interpreted as a whole, not as series of tokens.
 | CreateValueField(String, String, Single) | Creates the value field. Value fields are not stored, only indexed. Also, field value is interpreted as a whole, not as series of tokens.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Tags | Gets or sets the base tags of the crawler.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseCrawler
 |  | DatabaseCrawler


BaseCrawler Constructor

BaseCrawler Constructor
Namespaces ► Sitecore.Search.Crawlers ► BaseCrawler ► BaseCrawler()()()
Initializes a new instance of the BaseCrawler class
Declaration Syntax
C#
public BaseCrawler()


Boost Property

Boost Property
Namespaces ► Sitecore.Search.Crawlers ► BaseCrawler ► Boost
Gets or sets the base boost of the crawler.
Declaration Syntax
C#
public float Boost { get; set; }
Value
The boost.


CreateDataField Method

CreateDataField Method
Namespaces ► Sitecore.Search.Crawlers ► BaseCrawler ► CreateDataField()()()
Members
Icon | Member | Description
 | CreateDataField(String, String) | Creates the data field. Data field is not indexed but it stored in the index and can be retrieved during search. Typical sample of a data field is document URL.
 | CreateDataField(String, String, Single) | Creates the data field. Data field is not indexed but it stored in the index and can be retrieved during search. Typical sample of a data field is document URL.


CreateDataField Method (name, value)

CreateDataField Method (name, value)
Namespaces ► Sitecore.Search.Crawlers ► BaseCrawler ► CreateDataField(String, String)
Creates the data field. Data field is not indexed but it stored in the index and can be retrieved during search. Typical sample of a data field is document URL.
Declaration Syntax
C#
protected Field CreateDataField(
    string name,
    string value
)
Parameters
name (String)
The name.
value (String)
The value.
Return Value
The data field.


CreateDataField Method (name, value, weight)

CreateDataField Method (name, value, weight)
Namespaces ► Sitecore.Search.Crawlers ► BaseCrawler ► CreateDataField(String, String, Single)
Creates the data field. Data field is not indexed but it stored in the index and can be retrieved during search. Typical sample of a data field is document URL.
Declaration Syntax
C#
protected Field CreateDataField(
    string name,
    string value,
    float weight
)
Parameters
name (String)
The name.
value (String)
The value.
weight (Single)
Return Value
The data field.


CreateField Method (name, value, tokenize, boost)

CreateField Method (name, value, tokenize, boost)
Namespaces ► Sitecore.Search.Crawlers ► BaseCrawler ► CreateField(String, String, Boolean, Single)
Helper method to create fields.
Declaration Syntax
C#
protected Field CreateField(
    string name,
    string value,
    bool tokenize,
    float boost
)
Parameters
name (String)
The name.
value (String)
The value.
tokenize (Boolean)
if set to true this instance is tokenize.
boost (Single)
The boost.
Return Value
The field.


CreateTextField Method

CreateTextField Method
Namespaces ► Sitecore.Search.Crawlers ► BaseCrawler ► CreateTextField()()()
Members
Icon | Member | Description
 | CreateTextField(String, String) | Creates the text field. Text fields are not stored and are tokenized (split into words) when indexing.
 | CreateTextField(String, String, Single) | Creates the text field. Text fields are not stored and are tokenized (split into words) when indexing.


CreateTextField Method (name, value)

CreateTextField Method (name, value)
Namespaces ► Sitecore.Search.Crawlers ► BaseCrawler ► CreateTextField(String, String)
Creates the text field. Text fields are not stored and are tokenized (split into words) when indexing.
Declaration Syntax
C#
protected Field CreateTextField(
    string name,
    string value
)
Parameters
name (String)
The name.
value (String)
The value.
Return Value
The text field.


CreateTextField Method (name, value, boost)

CreateTextField Method (name, value, boost)
Namespaces ► Sitecore.Search.Crawlers ► BaseCrawler ► CreateTextField(String, String, Single)
Creates the text field. Text fields are not stored and are tokenized (split into words) when indexing.
Declaration Syntax
C#
protected Field CreateTextField(
    string name,
    string value,
    float boost
)
Parameters
name (String)
The name.
value (String)
The value.
boost (Single)
The boost.
Return Value
The text field.


CreateValueField Method

CreateValueField Method
Namespaces ► Sitecore.Search.Crawlers ► BaseCrawler ► CreateValueField()()()
Members
Icon | Member | Description
 | CreateValueField(String, String) | Creates the value field. Value fields are not stored, only indexed. Also, field value is interpreted as a whole, not as series of tokens.
 | CreateValueField(String, String, Single) | Creates the value field. Value fields are not stored, only indexed. Also, field value is interpreted as a whole, not as series of tokens.


CreateValueField Method (name, value)

CreateValueField Method (name, value)
Namespaces ► Sitecore.Search.Crawlers ► BaseCrawler ► CreateValueField(String, String)
Creates the value field. Value fields are not stored, only indexed. Also, field value is interpreted as a whole, not as series of tokens.
Declaration Syntax
C#
protected Field CreateValueField(
    string name,
    string value
)
Parameters
name (String)
The name.
value (String)
The value.
Return Value
The value field.


CreateValueField Method (name, value, boost)

CreateValueField Method (name, value, boost)
Namespaces ► Sitecore.Search.Crawlers ► BaseCrawler ► CreateValueField(String, String, Single)
Creates the value field. Value fields are not stored, only indexed. Also, field value is interpreted as a whole, not as series of tokens.
Declaration Syntax
C#
protected Field CreateValueField(
    string name,
    string value,
    float boost
)
Parameters
name (String)
The name.
value (String)
The value.
boost (Single)
The boost.
Return Value
The value field.


Tags Property

Tags Property
Namespaces ► Sitecore.Search.Crawlers ► BaseCrawler ► Tags
Gets or sets the base tags of the crawler.
Declaration Syntax
C#
public string Tags { get; set; }
Value
The tags.


DatabaseCrawler Class

DatabaseCrawler Class
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler
Implements crawler that scans and watches a specific location in the database
Declaration Syntax
C#
public class DatabaseCrawler : BaseCrawler,
    ICrawler
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatabaseCrawler()()() | Initializes a new instance of the DatabaseCrawler class
 | _shortenGuid | Regex to strip special symbols from a string of GUIDs
 | Add(IndexUpdateContext) | Crawls content and adds to the specified index.
 | AddAllFields(Document, Item, Boolean) | Adds all fields.
 | AddItem(Item) | Adds the item.
 | AddItem(Item, IndexUpdateContext) | Adds an item to the index.
 | AddMatchCriteria(BooleanQuery) | Adds the match criteria to deletion query. This method closely relates to IsMatch method.
 | AddSpecialFields(Document, Item) | Adds the boosted fields.
 | AddTextFieldType(String) | Adds specified field type to the list of 'textual' (tokenized) field types.
 | AddTree(Item) | Adds the tree.
 | AddTree(Item, IndexUpdateContext) | Adds a subtree to the index.
 | AddVersion(Item) | Adds the version.
 | AddVersion(Item, IndexUpdateContext) | Adds the specific version of an item to the index.
 | AdjustBoost(Document, Item) | Adjusts the boost.
 | Boost | Gets or sets the base boost of the crawler. (Inherited from BaseCrawler.)
 | CreateDataField(String, String) | Creates the data field. Data field is not indexed but it stored in the index and can be retrieved during search. Typical sample of a data field is document URL. (Inherited from BaseCrawler.)
 | CreateDataField(String, String, Single) | Creates the data field. Data field is not indexed but it stored in the index and can be retrieved during search. Typical sample of a data field is document URL. (Inherited from BaseCrawler.)
 | CreateField(String, String, Boolean, Single) | Helper method to create fields. (Inherited from BaseCrawler.)
 | CreateTextField(String, String) | Creates the text field. Text fields are not stored and are tokenized (split into words) when indexing. (Inherited from BaseCrawler.)
 | CreateTextField(String, String, Single) | Creates the text field. Text fields are not stored and are tokenized (split into words) when indexing. (Inherited from BaseCrawler.)
 | CreateValueField(String, String) | Creates the value field. Value fields are not stored, only indexed. Also, field value is interpreted as a whole, not as series of tokens. (Inherited from BaseCrawler.)
 | CreateValueField(String, String, Single) | Creates the value field. Value fields are not stored, only indexed. Also, field value is interpreted as a whole, not as series of tokens. (Inherited from BaseCrawler.)
 | Database | Gets or sets the database name to scan.
 | DeleteItem(Item) | Deletes the item.
 | DeleteItem(ID, IndexDeleteContext) | Deletes the item information from the index.
 | DeleteTree(Item) | Deletes the tree.
 | DeleteTree(ID, IndexDeleteContext) | Deletes the tree.
 | DeleteVersion(Item) | Deletes the version.
 | DeleteVersion(ID, String, String, IndexDeleteContext) | Deletes the specific version information from the index.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExcludeTemplate(String) | Excludes the template from the index scope.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDescendantsQuery(Item) | Gets the descendants query. This method must generate query to remove exactly the items matched by IsMatch method.
 | GetDescendantsQuery(ID) | Gets the descendants query.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemID(ID, String, String) | Gets the item ID.
 | GetItemLinks(Item) | Gets the item links.
 | GetItemPath(Item) | Gets the item path.
 | GetItemQuery(Item) | Gets the item query.
 | GetItemQuery(ID) | Gets the item query.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersionQuery(Item) | Gets the version query.
 | GetVersionQuery(ID, String, String) | Gets the version query.
 | GetWildcardItemID(ID) | Gets the wildcard item ID.
 | IncludeTemplate(String) | Narrows template filter scope to explicitly specified templates and includes the template into the scope.
 | IndexAllFields | Gets or sets a value indicating whether the DatabaseCrawler indexes all the fields.
 | IndexSharedData(Item, IndexUpdateContext) | Adds the item to the index.
 | IndexVersion(Item, Item, IndexUpdateContext) | Adds the item to the index.
 | Initialize(Index) | Initializes the specified crawler for the index.
 | IsMatch(Item) | Determines whether the specified item matches indexing criteria. Changing this method, AddMatchCriteria method must also be changed.
 | IsTextField(Field) | Determines whether [is text field] [the specified field].
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonitorChanges | Gets or sets a value indicating whether the DatabaseCrawler monitors the changes.
 | RemoveTextFieldType(String) | Removes the specified field type from the list of 'textual' (tokenized) field types.
 | Root | Gets or sets the root item of search area.
 | Tags | Gets or sets the base tags of the crawler. (Inherited from BaseCrawler.)
 | TextFieldTypes | Gets or sets the text field types.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateDatabase(Database) | Updates the database.
 | UpdateItem(Item) | Updates the item.
 | UpdateTree(Item) | Updates the tree.
 | UpdateVersion(Item) | Updates the version.
Inheritance Hierarchy
Object
 | BaseCrawler
 |  | DatabaseCrawler


DatabaseCrawler Constructor

DatabaseCrawler Constructor
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► DatabaseCrawler()()()
Initializes a new instance of the DatabaseCrawler class
Declaration Syntax
C#
public DatabaseCrawler()


_shortenGuid Field

_shortenGuid Field
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► _shortenGuid
Regex to strip special symbols from a string of GUIDs
Declaration Syntax
C#
protected static Regex _shortenGuid


Add Method (context)

Add Method (context)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► Add(IndexUpdateContext)
Crawls content and adds to the specified index.
Declaration Syntax
C#
public void Add(
    IndexUpdateContext context
)
Parameters
context (IndexUpdateContext)
Update context that identifies the index to modify.


AddAllFields Method (document, item, versionSpecific)

AddAllFields Method (document, item, versionSpecific)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► AddAllFields(Document, Item, Boolean)
Adds all fields.
Declaration Syntax
C#
protected virtual void AddAllFields(
    Document document,
    Item item,
    bool versionSpecific
)
Parameters
document (Document)
The document.
item (Item)
The item.
versionSpecific (Boolean)
if set to true this instance is version specific.


AddItem Method

AddItem Method
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► AddItem()()()
Members
Icon | Member | Description
 | AddItem(Item) | Adds the item.
 | AddItem(Item, IndexUpdateContext) | Adds an item to the index.


AddItem Method (item)

AddItem Method (item)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► AddItem(Item)
Adds the item.
Declaration Syntax
C#
public void AddItem(
    Item item
)
Parameters
item (Item)
The item.


AddItem Method (item, context)

AddItem Method (item, context)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► AddItem(Item, IndexUpdateContext)
Adds an item to the index.
Declaration Syntax
C#
protected void AddItem(
    Item item,
    IndexUpdateContext context
)
Parameters
item (Item)
The item.
context (IndexUpdateContext)
The context.


AddMatchCriteria Method (query)

AddMatchCriteria Method (query)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► AddMatchCriteria(BooleanQuery)
Adds the match criteria to deletion query. This method closely relates to IsMatch method.
Declaration Syntax
C#
protected virtual void AddMatchCriteria(
    BooleanQuery query
)
Parameters
query (BooleanQuery)
The query.


AddSpecialFields Method (document, item)

AddSpecialFields Method (document, item)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► AddSpecialFields(Document, Item)
Adds the boosted fields.
Declaration Syntax
C#
protected virtual void AddSpecialFields(
    Document document,
    Item item
)
Parameters
document (Document)
The document.
item (Item)
The item.


AddTextFieldType Method (type)

AddTextFieldType Method (type)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► AddTextFieldType(String)
Adds specified field type to the list of 'textual' (tokenized) field types.
Declaration Syntax
C#
public void AddTextFieldType(
    string type
)
Parameters
type (String)
The type.


AddTree Method

AddTree Method
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► AddTree()()()
Members
Icon | Member | Description
 | AddTree(Item) | Adds the tree.
 | AddTree(Item, IndexUpdateContext) | Adds a subtree to the index.


AddTree Method (root)

AddTree Method (root)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► AddTree(Item)
Adds the tree.
Declaration Syntax
C#
public void AddTree(
    Item root
)
Parameters
root (Item)
The root.


AddTree Method (root, context)

AddTree Method (root, context)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► AddTree(Item, IndexUpdateContext)
Adds a subtree to the index.
Declaration Syntax
C#
protected void AddTree(
    Item root,
    IndexUpdateContext context
)
Parameters
root (Item)
The root.
context (IndexUpdateContext)
The context.


AddVersion Method

AddVersion Method
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► AddVersion()()()
Members
Icon | Member | Description
 | AddVersion(Item) | Adds the version.
 | AddVersion(Item, IndexUpdateContext) | Adds the specific version of an item to the index.


AddVersion Method (version)

AddVersion Method (version)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► AddVersion(Item)
Adds the version.
Declaration Syntax
C#
public void AddVersion(
    Item version
)
Parameters
version (Item)
The version.


AddVersion Method (version, context)

AddVersion Method (version, context)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► AddVersion(Item, IndexUpdateContext)
Adds the specific version of an item to the index.
Declaration Syntax
C#
protected void AddVersion(
    Item version,
    IndexUpdateContext context
)
Parameters
version (Item)
The version.
context (IndexUpdateContext)
The context.


AdjustBoost Method (document, item)

AdjustBoost Method (document, item)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► AdjustBoost(Document, Item)
Adjusts the boost.
Declaration Syntax
C#
protected virtual void AdjustBoost(
    Document document,
    Item item
)
Parameters
document (Document)
The document.
item (Item)
The item.


Database Property

Database Property
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► Database
Gets or sets the database name to scan.
Declaration Syntax
C#
public string Database { get; set; }
Value
The database name.


DeleteItem Method

DeleteItem Method
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► DeleteItem()()()
Members
Icon | Member | Description
 | DeleteItem(Item) | Deletes the item.
 | DeleteItem(ID, IndexDeleteContext) | Deletes the item information from the index.


DeleteItem Method (itemId, context)

DeleteItem Method (itemId, context)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► DeleteItem(ID, IndexDeleteContext)
Deletes the item information from the index.
Declaration Syntax
C#
protected void DeleteItem(
    ID itemId,
    IndexDeleteContext context
)
Parameters
itemId (ID)
The item id.
context (IndexDeleteContext)
The context.


DeleteItem Method (item)

DeleteItem Method (item)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► DeleteItem(Item)
Deletes the item.
Declaration Syntax
C#
public void DeleteItem(
    Item item
)
Parameters
item (Item)
The item.


DeleteTree Method

DeleteTree Method
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► DeleteTree()()()
Members
Icon | Member | Description
 | DeleteTree(Item) | Deletes the tree.
 | DeleteTree(ID, IndexDeleteContext) | Deletes the tree.


DeleteTree Method (rootId, context)

DeleteTree Method (rootId, context)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► DeleteTree(ID, IndexDeleteContext)
Deletes the tree.
Declaration Syntax
C#
protected void DeleteTree(
    ID rootId,
    IndexDeleteContext context
)
Parameters
rootId (ID)
The root id.
context (IndexDeleteContext)
The context.


DeleteTree Method (root)

DeleteTree Method (root)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► DeleteTree(Item)
Deletes the tree.
Declaration Syntax
C#
public void DeleteTree(
    Item root
)
Parameters
root (Item)
The root.


DeleteVersion Method

DeleteVersion Method
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► DeleteVersion()()()
Members
Icon | Member | Description
 | DeleteVersion(Item) | Deletes the version.
 | DeleteVersion(ID, String, String, IndexDeleteContext) | Deletes the specific version information from the index.


DeleteVersion Method (id, language, version, context)

DeleteVersion Method (id, language, version, context)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► DeleteVersion(ID, String, String, IndexDeleteContext)
Deletes the specific version information from the index.
Declaration Syntax
C#
protected void DeleteVersion(
    ID id,
    string language,
    string version,
    IndexDeleteContext context
)
Parameters
id (ID)
The id.
language (String)
The language.
version (String)
The version.
context (IndexDeleteContext)
The context.


DeleteVersion Method (version)

DeleteVersion Method (version)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► DeleteVersion(Item)
Deletes the version.
Declaration Syntax
C#
public void DeleteVersion(
    Item version
)
Parameters
version (Item)
The version.


ExcludeTemplate Method (value)

ExcludeTemplate Method (value)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► ExcludeTemplate(String)
Excludes the template from the index scope.
Declaration Syntax
C#
public void ExcludeTemplate(
    string value
)
Parameters
value (String)
The value.


GetDescendantsQuery Method

GetDescendantsQuery Method
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► GetDescendantsQuery()()()
Members
Icon | Member | Description
 | GetDescendantsQuery(Item) | Gets the descendants query. This method must generate query to remove exactly the items matched by IsMatch method.
 | GetDescendantsQuery(ID) | Gets the descendants query.


GetDescendantsQuery Method (itemID)

GetDescendantsQuery Method (itemID)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► GetDescendantsQuery(ID)
Gets the descendants query.
Declaration Syntax
C#
protected virtual Query GetDescendantsQuery(
    ID itemID
)
Parameters
itemID (ID)
The item ID.
Return Value
The descendants query.


GetDescendantsQuery Method (root)

GetDescendantsQuery Method (root)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► GetDescendantsQuery(Item)
Gets the descendants query. This method must generate query to remove exactly the items matched by IsMatch method.
Declaration Syntax
C#
protected Query GetDescendantsQuery(
    Item root
)
Parameters
root (Item)
The root.
Return Value
The descendants query.


GetItemID Method (id, language, version)

GetItemID Method (id, language, version)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► GetItemID(ID, String, String)
Gets the item ID.
Declaration Syntax
C#
protected string GetItemID(
    ID id,
    string language,
    string version
)
Parameters
id (ID)
The id.
language (String)
The language.
version (String)
The version.
Return Value
The item ID.


GetItemLinks Method (item)

GetItemLinks Method (item)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► GetItemLinks(Item)
Gets the item links.
Declaration Syntax
C#
protected string GetItemLinks(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The item links.


GetItemPath Method (item)

GetItemPath Method (item)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► GetItemPath(Item)
Gets the item path.
Declaration Syntax
C#
protected string GetItemPath(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The item path.


GetItemQuery Method

GetItemQuery Method
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► GetItemQuery()()()
Members
Icon | Member | Description
 | GetItemQuery(Item) | Gets the item query.
 | GetItemQuery(ID) | Gets the item query.


GetItemQuery Method (id)

GetItemQuery Method (id)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► GetItemQuery(ID)
Gets the item query.
Declaration Syntax
C#
protected virtual Query GetItemQuery(
    ID id
)
Parameters
id (ID)
The id.
Return Value
The item query.


GetItemQuery Method (item)

GetItemQuery Method (item)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► GetItemQuery(Item)
Gets the item query.
Declaration Syntax
C#
protected Query GetItemQuery(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The item query.


GetVersionQuery Method

GetVersionQuery Method
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► GetVersionQuery()()()
Members
Icon | Member | Description
 | GetVersionQuery(Item) | Gets the version query.
 | GetVersionQuery(ID, String, String) | Gets the version query.


GetVersionQuery Method (id, language, version)

GetVersionQuery Method (id, language, version)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► GetVersionQuery(ID, String, String)
Gets the version query.
Declaration Syntax
C#
protected virtual Query GetVersionQuery(
    ID id,
    string language,
    string version
)
Parameters
id (ID)
The id.
language (String)
The language.
version (String)
The version.
Return Value
The version query.


GetVersionQuery Method (version)

GetVersionQuery Method (version)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► GetVersionQuery(Item)
Gets the version query.
Declaration Syntax
C#
protected Query GetVersionQuery(
    Item version
)
Parameters
version (Item)
The version.
Return Value
The version query.


GetWildcardItemID Method (id)

GetWildcardItemID Method (id)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► GetWildcardItemID(ID)
Gets the wildcard item ID.
Declaration Syntax
C#
protected string GetWildcardItemID(
    ID id
)
Parameters
id (ID)
The id.
Return Value
The wildcard item ID.


IncludeTemplate Method (value)

IncludeTemplate Method (value)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► IncludeTemplate(String)
Narrows template filter scope to explicitly specified templates and includes the template into the scope.
Declaration Syntax
C#
public void IncludeTemplate(
    string value
)
Parameters
value (String)
The value.


IndexAllFields Property

IndexAllFields Property
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► IndexAllFields
Gets or sets a value indicating whether the DatabaseCrawler indexes all the fields.
Declaration Syntax
C#
public bool IndexAllFields { get; set; }
Value
true if the DatabaseCrawler indexes all the fields; otherwise, false.


IndexSharedData Method (item, context)

IndexSharedData Method (item, context)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► IndexSharedData(Item, IndexUpdateContext)
Adds the item to the index.
Declaration Syntax
C#
protected void IndexSharedData(
    Item item,
    IndexUpdateContext context
)
Parameters
item (Item)
The item.
context (IndexUpdateContext)
The context.


IndexVersion Method (item, latestVersion, context)

IndexVersion Method (item, latestVersion, context)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► IndexVersion(Item, Item, IndexUpdateContext)
Adds the item to the index.
Declaration Syntax
C#
protected void IndexVersion(
    Item item,
    Item latestVersion,
    IndexUpdateContext context
)
Parameters
item (Item)
The item.
latestVersion (Item)
The latest version.
context (IndexUpdateContext)
The context.


Initialize Method (index)

Initialize Method (index)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► Initialize(Index)
Initializes the specified crawler for the index.
Declaration Syntax
C#
public void Initialize(
    Index index
)
Parameters
index (Index)
The index.


IsMatch Method (item)

IsMatch Method (item)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► IsMatch(Item)
Determines whether the specified item matches indexing criteria. Changing this method, AddMatchCriteria method must also be changed.
Declaration Syntax
C#
protected virtual bool IsMatch(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item is should be indexed; otherwise, false.


IsTextField Method (field)

IsTextField Method (field)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► IsTextField(Field)
Determines whether [is text field] [the specified field].
Declaration Syntax
C#
protected virtual bool IsTextField(
    Field field
)
Parameters
field (Field)
The field.
Return Value
true if [is text field] [the specified field]; otherwise, false.


MonitorChanges Property

MonitorChanges Property
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► MonitorChanges
Gets or sets a value indicating whether the DatabaseCrawler monitors the changes.
Declaration Syntax
C#
public bool MonitorChanges { get; set; }
Value
true if the DatabaseCrawler monitors the changes; otherwise, false.


RemoveTextFieldType Method (type)

RemoveTextFieldType Method (type)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► RemoveTextFieldType(String)
Removes the specified field type from the list of 'textual' (tokenized) field types.
Declaration Syntax
C#
public void RemoveTextFieldType(
    string type
)
Parameters
type (String)
The type.


Root Property

Root Property
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► Root
Gets or sets the root item of search area.
Declaration Syntax
C#
public string Root { get; set; }
Value
The root item id.


TextFieldTypes Property

TextFieldTypes Property
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► TextFieldTypes
Gets or sets the text field types.
Declaration Syntax
C#
protected List<string> TextFieldTypes { get; set; }
Value
The text field types.


UpdateDatabase Method (database)

UpdateDatabase Method (database)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► UpdateDatabase(Database)
Updates the database.
Declaration Syntax
C#
public void UpdateDatabase(
    Database database
)
Parameters
database (Database)
The database.


UpdateItem Method (item)

UpdateItem Method (item)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► UpdateItem(Item)
Updates the item.
Declaration Syntax
C#
public void UpdateItem(
    Item item
)
Parameters
item (Item)
The item.


UpdateTree Method (root)

UpdateTree Method (root)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► UpdateTree(Item)
Updates the tree.
Declaration Syntax
C#
public void UpdateTree(
    Item root
)
Parameters
root (Item)
The root.


UpdateVersion Method (version)

UpdateVersion Method (version)
Namespaces ► Sitecore.Search.Crawlers ► DatabaseCrawler ► UpdateVersion(Item)
Updates the version.
Declaration Syntax
C#
public void UpdateVersion(
    Item version
)
Parameters
version (Item)
The version.


ICrawler Interface

ICrawler Interface
Namespaces ► Sitecore.Search.Crawlers ► ICrawler
Interface of search crawler object
Declaration Syntax
C#
public interface ICrawler
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(IndexUpdateContext) | Crawls the location and adds data to the index using specified update context.
 | Initialize(Index) | Initializes the specified crawler for the index.


Add Method (context)

Add Method (context)
Namespaces ► Sitecore.Search.Crawlers ► ICrawler ► Add(IndexUpdateContext)
Crawls the location and adds data to the index using specified update context.
Declaration Syntax
C#
void Add(
    IndexUpdateContext context
)
Parameters
context (IndexUpdateContext)


Initialize Method (index)

Initialize Method (index)
Namespaces ► Sitecore.Search.Crawlers ► ICrawler ► Initialize(Index)
Initializes the specified crawler for the index.
Declaration Syntax
C#
void Initialize(
    Index index
)
Parameters
index (Index)
The index.


Sitecore.Security Namespace

Sitecore.Security Namespace
Namespaces ► Sitecore.Security
Declaration Syntax
C#
namespace Sitecore.Security
Types
All Types Classes
Icon | Type | Description
 | AccountsListString |
 | AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) | ProviderWrapper class
 | AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>) | ProviderWrapperList class
 | DomainMapHelper | DomainMapHelper class
 | MembershipProviderWrapper | MembershipProviderWrapper class
 | MembershipProviderWrapperList | MembershipProviderWrapperList class
 | ProfileProviderWrapper | ProfileProviderWrapper class
 | ProfileProviderWrapperList | ProfileProviderWrapperList class
 | ProfileSwitcher | ProfileSwitcher class
 | RoleProviderWrapper | RoleProviderWrapper class
 | RoleProviderWrapperList | RoleProviderWrapperList class
 | SecurityHelper | Security Helper
 | SecurityUtility | Represents a SecurityUtility.
 | SelectAccountOptions | Represents a SelectAccount.
 | SitecoreMembershipProvider | SitecoreMembershipProvider class
 | SitecoreRoleProvider | Provider for roles.
 | SwitchingMembershipProvider | SitecoreMembershipProvider class
 | SwitchingProfileProvider | SitecoreProfileProvider class
 | SwitchingRoleProvider | Provider for roles.
 | UserProfile | Profile class


AccountsListString Class

AccountsListString Class
Namespaces ► Sitecore.Security ► AccountsListString
Declaration Syntax
C#
public class AccountsListString
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AccountsListString()()() | Initializes a new instance of the AccountsListString class.
 | AccountsListString(String) | Initializes a new instance of the AccountsListString class.
 | Add(String, AccountType) | Adds the specified account name.
 | Add(Role) | Adds the specified role.
 | Add(User) | Adds the specified user.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToDisplayNames()()() | Converts the AccountsListString to a String.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | ToUnqualifiedNames()()() | Converts the AccountsListString to a String.
Inheritance Hierarchy
Object
AccountsListString


AccountsListString Constructor

AccountsListString Constructor
Namespaces ► Sitecore.Security ► AccountsListString ► AccountsListString()()()
Members
Icon | Member | Description
 | AccountsListString()()() | Initializes a new instance of the AccountsListString class.
 | AccountsListString(String) | Initializes a new instance of the AccountsListString class.


AccountsListString Constructor

AccountsListString Constructor
Namespaces ► Sitecore.Security ► AccountsListString ► AccountsListString()()()
Initializes a new instance of the AccountsListString class.
Declaration Syntax
C#
public AccountsListString()


AccountsListString Constructor (accounts)

AccountsListString Constructor (accounts)
Namespaces ► Sitecore.Security ► AccountsListString ► AccountsListString(String)
Initializes a new instance of the AccountsListString class.
Declaration Syntax
C#
public AccountsListString(
    string accounts
)
Parameters
accounts (String)
The accounts.


Add Method

Add Method
Namespaces ► Sitecore.Security ► AccountsListString ► Add()()()
Members
Icon | Member | Description
 | Add(String, AccountType) | Adds the specified account name.
 | Add(Role) | Adds the specified role.
 | Add(User) | Adds the specified user.


Add Method (role)

Add Method (role)
Namespaces ► Sitecore.Security ► AccountsListString ► Add(Role)
Adds the specified role.
Declaration Syntax
C#
public virtual AccountsListString Add(
    Role role
)
Parameters
role (Role)
The role.
Return Value
The add.


Add Method (user)

Add Method (user)
Namespaces ► Sitecore.Security ► AccountsListString ► Add(User)
Adds the specified user.
Declaration Syntax
C#
public virtual AccountsListString Add(
    User user
)
Parameters
user (User)
The user.
Return Value
The add.


Add Method (accountName, accountType)

Add Method (accountName, accountType)
Namespaces ► Sitecore.Security ► AccountsListString ► Add(String, AccountType)
Adds the specified account name.
Declaration Syntax
C#
public virtual AccountsListString Add(
    string accountName,
    AccountType accountType
)
Parameters
accountName (String)
Name of the account.
accountType (AccountType)
Type of the account.
Return Value
The add.


ToDisplayNames Method

ToDisplayNames Method
Namespaces ► Sitecore.Security ► AccountsListString ► ToDisplayNames()()()
Converts the AccountsListString to a String.
Declaration Syntax
C#
public virtual List<string> ToDisplayNames()
Return Value
The String.


ToString Method

ToString Method
Namespaces ► Sitecore.Security ► AccountsListString ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


ToUnqualifiedNames Method

ToUnqualifiedNames Method
Namespaces ► Sitecore.Security ► AccountsListString ► ToUnqualifiedNames()()()
Converts the AccountsListString to a String.
Declaration Syntax
C#
public virtual List<string> ToUnqualifiedNames()
Return Value
The String.


AspNetSecurityProviderWrapper(TProvider, TWrapper) Class

AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) Class
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>)
ProviderWrapper class
Declaration Syntax
C#
public class AspNetSecurityProviderWrapper<TProvider, TWrapper>
where TProvider : ProviderBase
where TWrapper : new(), AspNetSecurityProviderWrapper<TProvider, TWrapper>
Generic Template Parameters
TProvider
TWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>)()()() | Initializes a new instance of the AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) class
 | CorrectWildcard(String) | Corrects the wildcard.
 | DomainNames | Gets the domain names mapped to the provider.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Globalize(MembershipUser) | Makes a user object global (makes sure that the user name is fully qualified).
 | Globalize(MembershipUserCollection) | Gets a membership user collection with global user names.
 | Globalize(ProfileInfoCollection) | Gets a profile collection with global user names.
 | Globalize(ProfileInfo) | Globalizes the specified profile.
 | Globalize(array<String>[]()[]) | Gets a list of role names with global role names.
 | Globalize(String) | Makes the name global (makes sure that it is fully qualified).
 | Initialize(XmlNode, AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>), Func<(Of <(String, TProvider>)>)) | Initializes the specified config node.
 | Localize(String) | Gets the provider specific version of the specified user name.
 | Localize(array<String>[]()[]) | Gets the provider specific versions of the specified account names.
 | Localize(MembershipUser) | Gets a version of the user object that uses the provider specific user name.
 | Localize(ProfileInfo) | Localizes the specified profile.
 | Localize(ProfileInfoCollection) | Gets a profile collection with local user names.
 | Localize(SettingsContext) | Localizes the specified context.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Provider | Gets the provider.
 | StoreFullNames | Gets or sets a value indicating whether to use full names.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Wildcard | Gets or sets the wildcard.
Inheritance Hierarchy
Object
 | AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>)
 |  | MembershipProviderWrapper
 |  | ProfileProviderWrapper
 |  | RoleProviderWrapper


AspNetSecurityProviderWrapper(TProvider, TWrapper) Constructor

AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) Constructor
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>)()()()
Initializes a new instance of the AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) class
Declaration Syntax
C#
public AspNetSecurityProviderWrapper()


CorrectWildcard Method (value)

CorrectWildcard Method (value)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► CorrectWildcard(String)
Corrects the wildcard.
Declaration Syntax
C#
public virtual string CorrectWildcard(
    string value
)
Parameters
value (String)
The value.
Return Value


DomainNames Property

DomainNames Property
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► DomainNames
Gets the domain names mapped to the provider.
Declaration Syntax
C#
public virtual string[] DomainNames { get; }
Value
The names of the domains.


Globalize Method

Globalize Method
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Globalize()()()
Members
Icon | Member | Description
 | Globalize(MembershipUser) | Makes a user object global (makes sure that the user name is fully qualified).
 | Globalize(MembershipUserCollection) | Gets a membership user collection with global user names.
 | Globalize(ProfileInfoCollection) | Gets a profile collection with global user names.
 | Globalize(ProfileInfo) | Globalizes the specified profile.
 | Globalize(array<String>[]()[]) | Gets a list of role names with global role names.
 | Globalize(String) | Makes the name global (makes sure that it is fully qualified).


Globalize Method (userName)

Globalize Method (userName)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Globalize(String)
Makes the name global (makes sure that it is fully qualified).
Declaration Syntax
C#
public virtual string Globalize(
    string userName
)
Parameters
userName (String)
Name of the user.
Return Value


Globalize Method (names)

Globalize Method (names)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Globalize(array<String>[]()[])
Gets a list of role names with global role names.
Declaration Syntax
C#
public virtual string[] Globalize(
    string[] names
)
Parameters
names (array< String >[]()[])
The role names.
Return Value


Globalize Method (profile)

Globalize Method (profile)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Globalize(ProfileInfo)
Globalizes the specified profile.
Declaration Syntax
C#
public virtual ProfileInfo Globalize(
    ProfileInfo profile
)
Parameters
profile (ProfileInfo)
The profile.
Return Value


Globalize Method (profiles)

Globalize Method (profiles)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Globalize(ProfileInfoCollection)
Gets a profile collection with global user names.
Declaration Syntax
C#
public virtual ProfileInfoCollection Globalize(
    ProfileInfoCollection profiles
)
Parameters
profiles (ProfileInfoCollection)
The profiles.
Return Value


Globalize Method (user)

Globalize Method (user)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Globalize(MembershipUser)
Makes a user object global (makes sure that the user name is fully qualified).
Declaration Syntax
C#
public virtual MembershipUser Globalize(
    MembershipUser user
)
Parameters
user (MembershipUser)
The user.
Return Value


Globalize Method (users)

Globalize Method (users)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Globalize(MembershipUserCollection)
Gets a membership user collection with global user names.
Declaration Syntax
C#
public virtual MembershipUserCollection Globalize(
    MembershipUserCollection users
)
Parameters
users (MembershipUserCollection)
The users.
Return Value


Initialize Method (configNode, owner, getProvider)

Initialize Method (configNode, owner, getProvider)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Initialize(XmlNode, AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>), Func<(Of <(String, TProvider>)>))
Initializes the specified config node.
Declaration Syntax
C#
public virtual void Initialize(
    XmlNode configNode,
    AspNetSecurityProviderWrapperList<TProvider, TWrapper> owner,
    Func<string, TProvider> getProvider
)
Parameters
configNode (XmlNode)
The config node.
owner (AspNetSecurityProviderWrapperList <(Of <( TProvider, TWrapper >)>))
The owner.
getProvider (Func<(Of <(String, TProvider >)>))
The get provider delegate.


Localize Method

Localize Method
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Localize()()()
Members
Icon | Member | Description
 | Localize(String) | Gets the provider specific version of the specified user name.
 | Localize(array<String>[]()[]) | Gets the provider specific versions of the specified account names.
 | Localize(MembershipUser) | Gets a version of the user object that uses the provider specific user name.
 | Localize(ProfileInfo) | Localizes the specified profile.
 | Localize(ProfileInfoCollection) | Gets a profile collection with local user names.
 | Localize(SettingsContext) | Localizes the specified context.


Localize Method (context)

Localize Method (context)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Localize(SettingsContext)
Localizes the specified context.
Declaration Syntax
C#
public virtual SettingsContext Localize(
    SettingsContext context
)
Parameters
context (SettingsContext)
The context.
Return Value


Localize Method (userName)

Localize Method (userName)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Localize(String)
Gets the provider specific version of the specified user name.
Declaration Syntax
C#
public virtual string Localize(
    string userName
)
Parameters
userName (String)
Name of the user.
Return Value


Localize Method (accountNames)

Localize Method (accountNames)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Localize(array<String>[]()[])
Gets the provider specific versions of the specified account names.
Declaration Syntax
C#
public virtual string[] Localize(
    string[] accountNames
)
Parameters
accountNames (array< String >[]()[])
The account names.
Return Value


Localize Method (profile)

Localize Method (profile)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Localize(ProfileInfo)
Localizes the specified profile.
Declaration Syntax
C#
public virtual ProfileInfo Localize(
    ProfileInfo profile
)
Parameters
profile (ProfileInfo)
The profile.
Return Value


Localize Method (profiles)

Localize Method (profiles)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Localize(ProfileInfoCollection)
Gets a profile collection with local user names.
Declaration Syntax
C#
public virtual ProfileInfoCollection Localize(
    ProfileInfoCollection profiles
)
Parameters
profiles (ProfileInfoCollection)
The profiles.
Return Value


Localize Method (user)

Localize Method (user)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Localize(MembershipUser)
Gets a version of the user object that uses the provider specific user name.
Declaration Syntax
C#
public virtual MembershipUser Localize(
    MembershipUser user
)
Parameters
user (MembershipUser)
The user.
Return Value


Provider Property

Provider Property
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Provider
Gets the provider.
Declaration Syntax
C#
public virtual TProvider Provider { get; }
Value
The provider.


StoreFullNames Property

StoreFullNames Property
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► StoreFullNames
Gets or sets a value indicating whether to use full names.
Declaration Syntax
C#
public virtual bool StoreFullNames { get; }
Value
true if full names should be used; otherwise, false.


Wildcard Property

Wildcard Property
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>) ► Wildcard
Gets or sets the wildcard.
Declaration Syntax
C#
public virtual string Wildcard { get; }
Value
The wildcard.


AspNetSecurityProviderWrapperList(TProvider, TWrapper) Class

AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>) Class
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>)
ProviderWrapperList class
Declaration Syntax
C#
public class AspNetSecurityProviderWrapperList<TProvider, TWrapper> : List<TWrapper>
where TProvider : ProviderBase
where TWrapper : new(), AspNetSecurityProviderWrapper<TProvider, TWrapper>
Generic Template Parameters
TProvider
TWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>)(NameValueCollection, ProviderBase, Func<(Of <(String, TProvider>)>)) | Initializes a new instance of the AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>) class.
 | Add(T) | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | AddRange(IEnumerable<(Of <(T>)>)) | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | AsReadOnly()()() | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List<(Of <(TWrapper>)>).)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <(TWrapper>)>).)
 | BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List<(Of <(TWrapper>)>).)
 | BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <(TWrapper>)>).)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <(TWrapper>)>).)
 | Clear()()() | Removes all elements from the List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | Contains(T) | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | ConvertAll<(Of <(TOutput>)>)(Converter<(Of <(T, TOutput>)>)) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List<(Of <(TWrapper>)>).)
 | CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List<(Of <(TWrapper>)>).)
 | CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <(TWrapper>)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <(TWrapper>)>).)
 | Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | DefaultWrapper | Gets the default wrapper.
 | DomainMap | Gets the map of domain/wrappers.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <(T>)>)) | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(TWrapper>)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | FindAll(Predicate<(Of <(T>)>)) | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(TWrapper>)>).)
 | FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <(TWrapper>)>).)
 | FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <(TWrapper>)>).)
 | FindLast(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <(TWrapper>)>).)
 | FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <(TWrapper>)>).)
 | ForEach(Action<(Of <(T>)>)) | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWrapper(String) | Gets a provider wrapper for a specific user name.
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <(TWrapper>)>).)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <(TWrapper>)>).)
 | Insert(Int32, T) | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <(TWrapper>)>).)
 | InsertRange(Int32, IEnumerable<(Of <(T>)>)) | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <(TWrapper>)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from List<(Of <(TWrapper>)>).)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <(TWrapper>)>).)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <(TWrapper>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Owner | Gets the owner.
 | OwnerTypeName | Gets the name of the owner type.
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | RemoveAll(Predicate<(Of <(T>)>)) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(TWrapper>)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List<(Of <(TWrapper>)>).)
 | Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List<(Of <(TWrapper>)>).)
 | Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <(TWrapper>)>).)
 | Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <(TWrapper>)>).)
 | Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List<(Of <(TWrapper>)>).)
 | ToArray()()() | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List<(Of <(TWrapper>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()()() | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List<(Of <(TWrapper>)>).)
 | TrueForAll(Predicate<(Of <(T>)>)) | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List<(Of <(TWrapper>)>).)
Inheritance Hierarchy
Object
 | List<(Of <(TWrapper>)>)
 |  | AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>)
 |  |  | MembershipProviderWrapperList
 |  |  | ProfileProviderWrapperList
 |  |  | RoleProviderWrapperList


AspNetSecurityProviderWrapperList(TProvider, TWrapper) Constructor (config, owner, getProvider)

AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>) Constructor (config, owner, getProvider)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>) ► AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>)(NameValueCollection, ProviderBase, Func<(Of <(String, TProvider>)>))
Initializes a new instance of the AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>) class.
Declaration Syntax
C#
public AspNetSecurityProviderWrapperList(
    NameValueCollection config,
    ProviderBase owner,
    Func<string, TProvider> getProvider
)
Parameters
config (NameValueCollection)
The config.
owner (ProviderBase)
The owner.
getProvider (Func<(Of <(String, TProvider >)>))
The get provider.


DefaultWrapper Property

DefaultWrapper Property
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>) ► DefaultWrapper
Gets the default wrapper.
Declaration Syntax
C#
public virtual TWrapper DefaultWrapper { get; }
Value
The default wrapper.


DomainMap Property

DomainMap Property
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>) ► DomainMap
Gets the map of domain/wrappers.
Declaration Syntax
C#
public virtual SafeDictionary<string, TWrapper> DomainMap { get; }
Value
The map.


GetWrapper Method (userName)

GetWrapper Method (userName)
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>) ► GetWrapper(String)
Gets a provider wrapper for a specific user name.
Declaration Syntax
C#
public virtual TWrapper GetWrapper(
    string userName
)
Parameters
userName (String)
Name of the user.
Return Value


Owner Property

Owner Property
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>) ► Owner
Gets the owner.
Declaration Syntax
C#
public virtual ProviderBase Owner { get; }
Value
The owner.


OwnerTypeName Property

OwnerTypeName Property
Namespaces ► Sitecore.Security ► AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>) ► OwnerTypeName
Gets the name of the owner type.
Declaration Syntax
C#
public virtual string OwnerTypeName { get; }
Value
The name of the owner type.


DomainMapHelper Class

DomainMapHelper Class
Namespaces ► Sitecore.Security ► DomainMapHelper
DomainMapHelper class
Declaration Syntax
C#
public class DomainMapHelper
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DomainMapHelper(NameValueCollection) | Initializes a new instance of the DomainMapHelper class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProviderName(Domain) | Gets the name of the provider linked to a specific domain.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DomainMapHelper


DomainMapHelper Constructor (config)

DomainMapHelper Constructor (config)
Namespaces ► Sitecore.Security ► DomainMapHelper ► DomainMapHelper(NameValueCollection)
Initializes a new instance of the DomainMapHelper class.
Declaration Syntax
C#
public DomainMapHelper(
    NameValueCollection config
)
Parameters
config (NameValueCollection)
The config.


GetProviderName Method (domain)

GetProviderName Method (domain)
Namespaces ► Sitecore.Security ► DomainMapHelper ► GetProviderName(Domain)
Gets the name of the provider linked to a specific domain.
Declaration Syntax
C#
public virtual string GetProviderName(
    Domain domain
)
Parameters
domain (Domain)
The domain.
Return Value


MembershipProviderWrapper Class

MembershipProviderWrapper Class
Namespaces ► Sitecore.Security ► MembershipProviderWrapper
MembershipProviderWrapper class
Declaration Syntax
C#
public class MembershipProviderWrapper : AspNetSecurityProviderWrapper<MembershipProvider, MembershipProviderWrapper>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MembershipProviderWrapper()()() | Initializes a new instance of the MembershipProviderWrapper class
 | CorrectWildcard(String) | Corrects the wildcard. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | DomainNames | Gets the domain names mapped to the provider. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Globalize(MembershipUser) | Makes a user object global (makes sure that the user name is fully qualified). (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(MembershipUserCollection) | Gets a membership user collection with global user names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(ProfileInfoCollection) | Gets a profile collection with global user names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(ProfileInfo) | Globalizes the specified profile. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(array<String>[]()[]) | Gets a list of role names with global role names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(String) | Makes the name global (makes sure that it is fully qualified). (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Initialize(XmlNode, AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>), Func<(Of <(String, TProvider>)>)) | Initializes the specified config node. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(String) | Gets the provider specific version of the specified user name. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(array<String>[]()[]) | Gets the provider specific versions of the specified account names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(MembershipUser) | Gets a version of the user object that uses the provider specific user name. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(ProfileInfo) | Localizes the specified profile. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(ProfileInfoCollection) | Gets a profile collection with local user names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(SettingsContext) | Localizes the specified context. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Provider | Gets the provider. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | StoreFullNames | Gets or sets a value indicating whether to use full names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Wildcard | Gets or sets the wildcard. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
Inheritance Hierarchy
Object
 | AspNetSecurityProviderWrapper <(Of <(MembershipProvider, MembershipProviderWrapper>)>)
 |  | MembershipProviderWrapper


MembershipProviderWrapper Constructor

MembershipProviderWrapper Constructor
Namespaces ► Sitecore.Security ► MembershipProviderWrapper ► MembershipProviderWrapper()()()
Initializes a new instance of the MembershipProviderWrapper class
Declaration Syntax
C#
public MembershipProviderWrapper()


MembershipProviderWrapperList Class

MembershipProviderWrapperList Class
Namespaces ► Sitecore.Security ► MembershipProviderWrapperList
MembershipProviderWrapperList class
Declaration Syntax
C#
public class MembershipProviderWrapperList : AspNetSecurityProviderWrapperList<MembershipProvider, MembershipProviderWrapper>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MembershipProviderWrapperList(NameValueCollection, ProviderBase, Func<(Of <(String, MembershipProvider>)>)) | Initializes a new instance of the MembershipProviderWrapperList class.
 | Add(T) | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | AddRange(IEnumerable<(Of <(T>)>)) | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | AsReadOnly()()() | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | Clear()()() | Removes all elements from the List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | Contains(T) | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | ConvertAll<(Of <(TOutput>)>)(Converter<(Of <(T, TOutput>)>)) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | DefaultWrapper | Gets the default wrapper. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | DomainMap | Gets the map of domain/wrappers. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <(T>)>)) | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | FindAll(Predicate<(Of <(T>)>)) | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | FindLast(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | ForEach(Action<(Of <(T>)>)) | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWrapper(String) | Gets a provider wrapper for a specific user name. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | Insert(Int32, T) | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | InsertRange(Int32, IEnumerable<(Of <(T>)>)) | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Owner | Gets the owner. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | OwnerTypeName | Gets the name of the owner type. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | RemoveAll(Predicate<(Of <(T>)>)) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | ToArray()()() | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()()() | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
 | TrueForAll(Predicate<(Of <(T>)>)) | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List<(Of <( MembershipProviderWrapper >)>).)
Inheritance Hierarchy
Object
 | List<(Of <( MembershipProviderWrapper >)>)
 |  | AspNetSecurityProviderWrapperList <(Of <(MembershipProvider, MembershipProviderWrapper >)>)
 |  |  | MembershipProviderWrapperList


MembershipProviderWrapperList Constructor (config, owner, getProvider)

MembershipProviderWrapperList Constructor (config, owner, getProvider)
Namespaces ► Sitecore.Security ► MembershipProviderWrapperList ► MembershipProviderWrapperList(NameValueCollection, ProviderBase, Func<(Of <(String, MembershipProvider>)>))
Initializes a new instance of the MembershipProviderWrapperList class.
Declaration Syntax
C#
public MembershipProviderWrapperList(
    NameValueCollection config,
    ProviderBase owner,
    Func<string, MembershipProvider> getProvider
)
Parameters
config (NameValueCollection)
The config.
owner (ProviderBase)
The owner.
getProvider (Func<(Of <(String, MembershipProvider>)>))
The get provider.


ProfileProviderWrapper Class

ProfileProviderWrapper Class
Namespaces ► Sitecore.Security ► ProfileProviderWrapper
ProfileProviderWrapper class
Declaration Syntax
C#
public class ProfileProviderWrapper : AspNetSecurityProviderWrapper<ProfileProvider, ProfileProviderWrapper>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProfileProviderWrapper()()() | Initializes a new instance of the ProfileProviderWrapper class
 | CorrectWildcard(String) | Corrects the wildcard. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | DomainNames | Gets the domain names mapped to the provider. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Globalize(MembershipUser) | Makes a user object global (makes sure that the user name is fully qualified). (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(MembershipUserCollection) | Gets a membership user collection with global user names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(ProfileInfoCollection) | Gets a profile collection with global user names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(ProfileInfo) | Globalizes the specified profile. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(array<String>[]()[]) | Gets a list of role names with global role names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(String) | Makes the name global (makes sure that it is fully qualified). (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Initialize(XmlNode, AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>), Func<(Of <(String, TProvider>)>)) | Initializes the specified config node. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(String) | Gets the provider specific version of the specified user name. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(array<String>[]()[]) | Gets the provider specific versions of the specified account names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(MembershipUser) | Gets a version of the user object that uses the provider specific user name. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(ProfileInfo) | Localizes the specified profile. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(ProfileInfoCollection) | Gets a profile collection with local user names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(SettingsContext) | Localizes the specified context. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Provider | Gets the provider. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | StoreFullNames | Gets or sets a value indicating whether to use full names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Wildcard | Gets or sets the wildcard. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
Inheritance Hierarchy
Object
 | AspNetSecurityProviderWrapper <(Of <(ProfileProvider, ProfileProviderWrapper>)>)
 |  | ProfileProviderWrapper


ProfileProviderWrapper Constructor

ProfileProviderWrapper Constructor
Namespaces ► Sitecore.Security ► ProfileProviderWrapper ► ProfileProviderWrapper()()()
Initializes a new instance of the ProfileProviderWrapper class
Declaration Syntax
C#
public ProfileProviderWrapper()


ProfileProviderWrapperList Class

ProfileProviderWrapperList Class
Namespaces ► Sitecore.Security ► ProfileProviderWrapperList
ProfileProviderWrapperList class
Declaration Syntax
C#
public class ProfileProviderWrapperList : AspNetSecurityProviderWrapperList<ProfileProvider, ProfileProviderWrapper>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProfileProviderWrapperList(NameValueCollection, ProviderBase, Func<(Of <(String, ProfileProvider>)>)) | Initializes a new instance of the ProfileProviderWrapperList class.
 | Add(T) | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | AddRange(IEnumerable<(Of <(T>)>)) | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | AsReadOnly()()() | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | Clear()()() | Removes all elements from the List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | Contains(T) | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | ConvertAll<(Of <(TOutput>)>)(Converter<(Of <(T, TOutput>)>)) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | DefaultWrapper | Gets the default wrapper. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | DomainMap | Gets the map of domain/wrappers. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <(T>)>)) | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | FindAll(Predicate<(Of <(T>)>)) | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | FindLast(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | ForEach(Action<(Of <(T>)>)) | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWrapper(String) | Gets a provider wrapper for a specific user name. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | Insert(Int32, T) | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | InsertRange(Int32, IEnumerable<(Of <(T>)>)) | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Owner | Gets the owner. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | OwnerTypeName | Gets the name of the owner type. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | RemoveAll(Predicate<(Of <(T>)>)) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | ToArray()()() | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()()() | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
 | TrueForAll(Predicate<(Of <(T>)>)) | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List<(Of <( ProfileProviderWrapper >)>).)
Inheritance Hierarchy
Object
 | List<(Of <( ProfileProviderWrapper >)>)
 |  | AspNetSecurityProviderWrapperList <(Of <(ProfileProvider, ProfileProviderWrapper >)>)
 |  |  | ProfileProviderWrapperList


ProfileProviderWrapperList Constructor (config, owner, getProvider)

ProfileProviderWrapperList Constructor (config, owner, getProvider)
Namespaces ► Sitecore.Security ► ProfileProviderWrapperList ► ProfileProviderWrapperList(NameValueCollection, ProviderBase, Func<(Of <(String, ProfileProvider>)>))
Initializes a new instance of the ProfileProviderWrapperList class.
Declaration Syntax
C#
public ProfileProviderWrapperList(
    NameValueCollection config,
    ProviderBase owner,
    Func<string, ProfileProvider> getProvider
)
Parameters
config (NameValueCollection)
The config.
owner (ProviderBase)
The owner.
getProvider (Func<(Of <(String, ProfileProvider>)>))
The get provider.


ProfileSwitcher Class

ProfileSwitcher Class
Namespaces ► Sitecore.Security ► ProfileSwitcher
ProfileSwitcher class
Declaration Syntax
C#
public class ProfileSwitcher : Switcher<ProfileProvider>
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProfileSwitcher(ProfileProvider) | Initializes a new instance of the ProfileSwitcher class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <(ProfileProvider, ProfileProvider>)>)
 |  | Switcher <(Of <(ProfileProvider>)>)
 |  |  | ProfileSwitcher


ProfileSwitcher Constructor (provider)

ProfileSwitcher Constructor (provider)
Namespaces ► Sitecore.Security ► ProfileSwitcher ► ProfileSwitcher(ProfileProvider)
Initializes a new instance of the ProfileSwitcher class.
Declaration Syntax
C#
public ProfileSwitcher(
    ProfileProvider provider
)
Parameters
provider (ProfileProvider)
The provider.


RoleProviderWrapper Class

RoleProviderWrapper Class
Namespaces ► Sitecore.Security ► RoleProviderWrapper
RoleProviderWrapper class
Declaration Syntax
C#
public class RoleProviderWrapper : AspNetSecurityProviderWrapper<RoleProvider, RoleProviderWrapper>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RoleProviderWrapper()()() | Initializes a new instance of the RoleProviderWrapper class
 | CorrectWildcard(String) | Corrects the wildcard. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | DomainNames | Gets the domain names mapped to the provider. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Globalize(MembershipUser) | Makes a user object global (makes sure that the user name is fully qualified). (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(MembershipUserCollection) | Gets a membership user collection with global user names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(ProfileInfoCollection) | Gets a profile collection with global user names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(ProfileInfo) | Globalizes the specified profile. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(array<String>[]()[]) | Gets a list of role names with global role names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Globalize(String) | Makes the name global (makes sure that it is fully qualified). (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Initialize(XmlNode, AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>), Func<(Of <(String, TProvider>)>)) | Initializes the specified config node. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(String) | Gets the provider specific version of the specified user name. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(array<String>[]()[]) | Gets the provider specific versions of the specified account names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(MembershipUser) | Gets a version of the user object that uses the provider specific user name. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(ProfileInfo) | Localizes the specified profile. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(ProfileInfoCollection) | Gets a profile collection with local user names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | Localize(SettingsContext) | Localizes the specified context. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Provider | Gets the provider. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | StoreFullNames | Gets or sets a value indicating whether to use full names. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Wildcard | Gets or sets the wildcard. (Inherited from AspNetSecurityProviderWrapper<(Of <(TProvider, TWrapper>)>).)
Inheritance Hierarchy
Object
 | AspNetSecurityProviderWrapper <(Of <(RoleProvider, RoleProviderWrapper>)>)
 |  | RoleProviderWrapper


RoleProviderWrapper Constructor

RoleProviderWrapper Constructor
Namespaces ► Sitecore.Security ► RoleProviderWrapper ► RoleProviderWrapper()()()
Initializes a new instance of the RoleProviderWrapper class
Declaration Syntax
C#
public RoleProviderWrapper()


RoleProviderWrapperList Class

RoleProviderWrapperList Class
Namespaces ► Sitecore.Security ► RoleProviderWrapperList
RoleProviderWrapperList class
Declaration Syntax
C#
public class RoleProviderWrapperList : AspNetSecurityProviderWrapperList<RoleProvider, RoleProviderWrapper>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RoleProviderWrapperList(NameValueCollection, ProviderBase, Func<(Of <(String, RoleProvider>)>)) | Initializes a new instance of the RoleProviderWrapperList class.
 | Add(T) | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | AddRange(IEnumerable<(Of <(T>)>)) | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | AsReadOnly()()() | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | Clear()()() | Removes all elements from the List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | Contains(T) | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | ConvertAll<(Of <(TOutput>)>)(Converter<(Of <(T, TOutput>)>)) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | DefaultWrapper | Gets the default wrapper. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | DomainMap | Gets the map of domain/wrappers. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <(T>)>)) | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | FindAll(Predicate<(Of <(T>)>)) | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | FindLast(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | ForEach(Action<(Of <(T>)>)) | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWrapper(String) | Gets a provider wrapper for a specific user name. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | Insert(Int32, T) | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | InsertRange(Int32, IEnumerable<(Of <(T>)>)) | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Owner | Gets the owner. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | OwnerTypeName | Gets the name of the owner type. (Inherited from AspNetSecurityProviderWrapperList<(Of <(TProvider, TWrapper>)>).)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | RemoveAll(Predicate<(Of <(T>)>)) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | ToArray()()() | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()()() | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
 | TrueForAll(Predicate<(Of <(T>)>)) | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List<(Of <( RoleProviderWrapper >)>).)
Inheritance Hierarchy
Object
 | List<(Of <( RoleProviderWrapper >)>)
 |  | AspNetSecurityProviderWrapperList <(Of <(RoleProvider, RoleProviderWrapper >)>)
 |  |  | RoleProviderWrapperList


RoleProviderWrapperList Constructor (config, owner, getProvider)

RoleProviderWrapperList Constructor (config, owner, getProvider)
Namespaces ► Sitecore.Security ► RoleProviderWrapperList ► RoleProviderWrapperList(NameValueCollection, ProviderBase, Func<(Of <(String, RoleProvider>)>))
Initializes a new instance of the RoleProviderWrapperList class.
Declaration Syntax
C#
public RoleProviderWrapperList(
    NameValueCollection config,
    ProviderBase owner,
    Func<string, RoleProvider> getProvider
)
Parameters
config (NameValueCollection)
The config.
owner (ProviderBase)
The owner.
getProvider (Func<(Of <(String, RoleProvider>)>))
The get provider.


SecurityHelper Class

SecurityHelper Class
Namespaces ► Sitecore.Security ► SecurityHelper
Security Helper
Declaration Syntax
C#
public class SecurityHelper
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SecurityHelper()()() | Initializes a new instance of the SecurityHelper class
 | CanRunApplication(String) | Determines whether current user can run application.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SecurityHelper


SecurityHelper Constructor

SecurityHelper Constructor
Namespaces ► Sitecore.Security ► SecurityHelper ► SecurityHelper()()()
Initializes a new instance of the SecurityHelper class
Declaration Syntax
C#
public SecurityHelper()


CanRunApplication Method (applicationName)

CanRunApplication Method (applicationName)
Namespaces ► Sitecore.Security ► SecurityHelper ► CanRunApplication(String)
Determines whether current user can run application.
Declaration Syntax
C#
public static bool CanRunApplication(
    string applicationName
)
Parameters
applicationName (String)
Name of the application.
Return Value
true if current user can run application specified application; otherwise, false.


SecurityUtility Class

SecurityUtility Class
Namespaces ► Sitecore.Security ► SecurityUtility
Represents a SecurityUtility.
Declaration Syntax
C#
public static class SecurityUtility
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetAccount()()() | Gets the account.
 | GetAccount(String) | Gets the account.
 | GetAccountNameAndType(String%, AccountType%) | Gets the account.
 | GetAccountNameAndType(String, String%, AccountType%) | Gets the account.
 | GetDomainName()()() | Gets the name of the domain.
 | IsRole(String) | Determines whether the specified account is role.
 | IsUser(String) | Determines whether the specified account is user.
 | ParseAccountType(String) | Parses the type of the account.
Inheritance Hierarchy
Object
SecurityUtility


GetAccount Method

GetAccount Method
Namespaces ► Sitecore.Security ► SecurityUtility ► GetAccount()()()
Members
Icon | Member | Description
 | GetAccount()()() | Gets the account.
 | GetAccount(String) | Gets the account.


GetAccount Method

GetAccount Method
Namespaces ► Sitecore.Security ► SecurityUtility ► GetAccount()()()
Gets the account.
Declaration Syntax
C#
public static Account GetAccount()
Return Value


GetAccount Method (domainName)

GetAccount Method (domainName)
Namespaces ► Sitecore.Security ► SecurityUtility ► GetAccount(String)
Gets the account.
Declaration Syntax
C#
public static Account GetAccount(
    string domainName
)
Parameters
domainName (String)
Name of the domain.
Return Value
The account.


GetAccountNameAndType Method

GetAccountNameAndType Method
Namespaces ► Sitecore.Security ► SecurityUtility ► GetAccountNameAndType()()()
Members
Icon | Member | Description
 | GetAccountNameAndType(String%, AccountType%) | Gets the account.
 | GetAccountNameAndType(String, String%, AccountType%) | Gets the account.


GetAccountNameAndType Method (domainName, accountName, accountType)

GetAccountNameAndType Method (domainName, accountName, accountType)
Namespaces ► Sitecore.Security ► SecurityUtility ► GetAccountNameAndType(String, String%, AccountType%)
Gets the account.
Declaration Syntax
C#
public static void GetAccountNameAndType(
    string domainName,
    out string accountName,
    out AccountType accountType
)
Parameters
domainName (String)
Name of the domain.
accountName ( String %)
Name of the account.
accountType ( AccountType %)
Type of the account.


GetAccountNameAndType Method (accountName, accountType)

GetAccountNameAndType Method (accountName, accountType)
Namespaces ► Sitecore.Security ► SecurityUtility ► GetAccountNameAndType(String%, AccountType%)
Gets the account.
Declaration Syntax
C#
public static void GetAccountNameAndType(
    out string accountName,
    out AccountType accountType
)
Parameters
accountName ( String %)
Name of the account.
accountType ( AccountType %)
Type of the account.


GetDomainName Method

GetDomainName Method
Namespaces ► Sitecore.Security ► SecurityUtility ► GetDomainName()()()
Gets the name of the domain.
Declaration Syntax
C#
public static string GetDomainName()
Return Value
The String.


IsRole Method (accountName)

IsRole Method (accountName)
Namespaces ► Sitecore.Security ► SecurityUtility ► IsRole(String)
Determines whether the specified account is role.
Declaration Syntax
C#
public static bool IsRole(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value
true if the specified account name is role; otherwise, false.


IsUser Method (accountName)

IsUser Method (accountName)
Namespaces ► Sitecore.Security ► SecurityUtility ► IsUser(String)
Determines whether the specified account is user.
Declaration Syntax
C#
public static bool IsUser(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value
true if the specified account name is user; otherwise, false.


ParseAccountType Method (value)

ParseAccountType Method (value)
Namespaces ► Sitecore.Security ► SecurityUtility ► ParseAccountType(String)
Parses the type of the account.
Declaration Syntax
C#
public static AccountType ParseAccountType(
    string value
)
Parameters
value (String)
The value.
Return Value
The account type.


SelectAccountOptions Class

SelectAccountOptions Class
Namespaces ► Sitecore.Security ► SelectAccountOptions
Represents a SelectAccount.
Declaration Syntax
C#
public class SelectAccountOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelectAccountOptions()()() | Initializes a new instance of the SelectAccountOptions class
 | DomainName | Gets or sets the name of the domain.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExcludeRoles | Gets or sets a value indicating whether the SelectAccountOptions excludes the roles.
 | ExcludeUsers | Gets or sets a value indicating whether the SelectAccountOptions excludes the users.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IncludeEveryone | Gets or sets a value indicating whether the SelectAccountOptions includes the everyone roles.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Multiple | Gets or sets a value indicating whether this SelectAccountOptions supports multiple selections.
 | Parse()()() | Parses this instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToUrlString()()() | Converts the SelectAccountOptions to a UrlString.
Inheritance Hierarchy
Object
SelectAccountOptions


SelectAccountOptions Constructor

SelectAccountOptions Constructor
Namespaces ► Sitecore.Security ► SelectAccountOptions ► SelectAccountOptions()()()
Initializes a new instance of the SelectAccountOptions class
Declaration Syntax
C#
public SelectAccountOptions()


DomainName Property

DomainName Property
Namespaces ► Sitecore.Security ► SelectAccountOptions ► DomainName
Gets or sets the name of the domain.
Declaration Syntax
C#
public string DomainName { get; set; }
Value
The name of the domain.


ExcludeRoles Property

ExcludeRoles Property
Namespaces ► Sitecore.Security ► SelectAccountOptions ► ExcludeRoles
Gets or sets a value indicating whether the SelectAccountOptions excludes the roles.
Declaration Syntax
C#
public bool ExcludeRoles { get; set; }
Value
true if the SelectAccountOptions excludes the roles; otherwise, false.


ExcludeUsers Property

ExcludeUsers Property
Namespaces ► Sitecore.Security ► SelectAccountOptions ► ExcludeUsers
Gets or sets a value indicating whether the SelectAccountOptions excludes the users.
Declaration Syntax
C#
public bool ExcludeUsers { get; set; }
Value
true if the SelectAccountOptions excludes the users; otherwise, false.


IncludeEveryone Property

IncludeEveryone Property
Namespaces ► Sitecore.Security ► SelectAccountOptions ► IncludeEveryone
Gets or sets a value indicating whether the SelectAccountOptions includes the everyone roles.
Declaration Syntax
C#
public bool IncludeEveryone { get; set; }
Value
true if the SelectAccountOptions includes the everyone roles; otherwise, false.


Multiple Property

Multiple Property
Namespaces ► Sitecore.Security ► SelectAccountOptions ► Multiple
Gets or sets a value indicating whether this SelectAccountOptions supports multiple selections.
Declaration Syntax
C#
public bool Multiple { get; set; }
Value
true if multiple; otherwise, false.


Parse Method

Parse Method
Namespaces ► Sitecore.Security ► SelectAccountOptions ► Parse()()()
Parses this instance.
Declaration Syntax
C#
public static SelectAccountOptions Parse()
Return Value
The parse.


ToUrlString Method

ToUrlString Method
Namespaces ► Sitecore.Security ► SelectAccountOptions ► ToUrlString()()()
Converts the SelectAccountOptions to a UrlString.
Declaration Syntax
C#
public UrlString ToUrlString()
Return Value
The UrlString.


SitecoreMembershipProvider Class

SitecoreMembershipProvider Class
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider
SitecoreMembershipProvider class
Declaration Syntax
C#
public class SitecoreMembershipProvider : MembershipProvider
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SitecoreMembershipProvider()()() | Initializes a new instance of the SitecoreMembershipProvider class
 | ApplicationName | The name of the application using the custom membership provider. (Overrides MembershipProvider.ApplicationName.)
 | ChangePassword(String, String, String) | Processes a request to update the password for a membership user. (Overrides MembershipProvider.ChangePassword(String, String, String).)
 | ChangePasswordQuestionAndAnswer(String, String, String, String) | Processes a request to update the password question and answer for a membership user. (Overrides MembershipProvider.ChangePasswordQuestionAndAnswer(String, String, String, String).)
 | CreateUser(String, String, String, String, String, Boolean, Object, MembershipCreateStatus%) | Adds a new membership user to the data source. (Overrides MembershipProvider.CreateUser(String, String, String, String, String, Boolean, Object, MembershipCreateStatus%).)
 | DecryptPassword(array<Byte>[]()[]) | Decrypts an encrypted password. (Inherited from MembershipProvider.)
 | DeleteUser(String, Boolean) | Removes a user from the membership data source. (Overrides MembershipProvider.DeleteUser(String, Boolean).)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | EnablePasswordReset | Indicates whether the membership provider is configured to allow users to reset their passwords. (Overrides MembershipProvider.EnablePasswordReset.)
 | EnablePasswordRetrieval | Indicates whether the membership provider is configured to allow users to retrieve their passwords. (Overrides MembershipProvider.EnablePasswordRetrieval.)
 | EncryptPassword(array<Byte>[]()[]) | Encrypts a password. (Inherited from MembershipProvider.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindUsersByEmail(String, Int32, Int32, Int32%) | Gets a collection of membership users where the e-mail address contains the specified e-mail address to match. (Overrides MembershipProvider.FindUsersByEmail(String, Int32, Int32, Int32%).)
 | FindUsersByName(String, Int32, Int32, Int32%) | Gets a collection of membership users where the user name contains the specified user name to match. (Overrides MembershipProvider.FindUsersByName(String, Int32, Int32, Int32%).)
 | GetAllUsers(Int32, Int32, Int32%) | Gets a collection of all the users in the data source in pages of data. (Overrides MembershipProvider.GetAllUsers(Int32, Int32, Int32%).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNumberOfUsersOnline()()() | Gets the number of users currently accessing the application. (Overrides MembershipProvider.GetNumberOfUsersOnline()()().)
 | GetPassword(String, String) | Gets the password for the specified user name from the data source. (Overrides MembershipProvider.GetPassword(String, String).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUser(Object, Boolean) | Gets user information from the data source based on the unique identifier for the membership user. Provides an option to update the last-activity date/time stamp for the user. (Overrides MembershipProvider.GetUser(Object, Boolean).)
 | GetUser(String, Boolean) | Gets information from the data source for a user. Provides an option to update the last-activity date/time stamp for the user. (Overrides MembershipProvider.GetUser(String, Boolean).)
 | GetUserNameByEmail(String) | Gets the user name associated with the specified e-mail address. (Overrides MembershipProvider.GetUserNameByEmail(String).)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | MaxInvalidPasswordAttempts | Gets the number of invalid password or password-answer attempts allowed before the membership user is locked out. (Overrides MembershipProvider.MaxInvalidPasswordAttempts.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinRequiredNonAlphanumericCharacters | Gets the minimum number of special characters that must be present in a valid password. (Overrides MembershipProvider.MinRequiredNonAlphanumericCharacters.)
 | MinRequiredPasswordLength | Gets the minimum length required for a password. (Overrides MembershipProvider.MinRequiredPasswordLength.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | OnValidatingPassword(ValidatePasswordEventArgs) | Raises the ValidatingPassword event if an event handler has been defined. (Inherited from MembershipProvider.)
 | PasswordAttemptWindow | Gets the number of minutes in which a maximum number of invalid password or password-answer attempts are allowed before the membership user is locked out. (Overrides MembershipProvider.PasswordAttemptWindow.)
 | PasswordFormat | Gets a value indicating the format for storing passwords in the membership data store. (Overrides MembershipProvider.PasswordFormat.)
 | PasswordStrengthRegularExpression | Gets the regular expression used to evaluate a password. (Overrides MembershipProvider.PasswordStrengthRegularExpression.)
 | ProviderWildcard | Gets the provider wildcard.
 | RealProvider | Gets the real provider.
 | RequiresQuestionAndAnswer | Gets a value indicating whether the membership provider is configured to require the user to answer a password question for password reset and retrieval. (Overrides MembershipProvider.RequiresQuestionAndAnswer.)
 | RequiresUniqueEmail | Gets a value indicating whether the membership provider is configured to require a unique e-mail address for each user name. (Overrides MembershipProvider.RequiresUniqueEmail.)
 | ResetPassword(String, String) | Resets a user's password to a new, automatically generated password. (Overrides MembershipProvider.ResetPassword(String, String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnlockUser(String) | Clears a lock so that the membership user can be validated. (Overrides MembershipProvider.UnlockUser(String).)
 | UpdateUser(MembershipUser) | Updates information about a user in the data source. (Overrides MembershipProvider.UpdateUser(MembershipUser).)
 | ValidateUser(String, String) | Verifies that the specified user name and password exist in the data source. (Overrides MembershipProvider.ValidateUser(String, String).)
 | ValidatingPassword | Occurs when a user is created, a password is changed, or a password is reset. (Inherited from MembershipProvider.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | MembershipProvider
 |  |  | SitecoreMembershipProvider


SitecoreMembershipProvider Constructor

SitecoreMembershipProvider Constructor
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► SitecoreMembershipProvider()()()
Initializes a new instance of the SitecoreMembershipProvider class
Declaration Syntax
C#
public SitecoreMembershipProvider()


ApplicationName Property

ApplicationName Property
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► ApplicationName
The name of the application using the custom membership provider.
Declaration Syntax
C#
public override string ApplicationName { get; set; }
Value
Return Value
The name of the application using the custom membership provider.


ChangePassword Method (username, oldPassword, newPassword)

ChangePassword Method (username, oldPassword, newPassword)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► ChangePassword(String, String, String)
Processes a request to update the password for a membership user.
Declaration Syntax
C#
public override bool ChangePassword(
    string username,
    string oldPassword,
    string newPassword
)
Parameters
username (String)
The user to update the password for.
oldPassword (String)
The current password for the specified user.
newPassword (String)
The new password for the specified user.
Return Value
true if the password was updated successfully; otherwise, false.


ChangePasswordQuestionAndAnswer Method (username, password, newPasswordQuestion, newPasswordAnswer)

ChangePasswordQuestionAndAnswer Method (username, password, newPasswordQuestion, newPasswordAnswer)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► ChangePasswordQuestionAndAnswer(String, String, String, String)
Processes a request to update the password question and answer for a membership user.
Declaration Syntax
C#
public override bool ChangePasswordQuestionAndAnswer(
    string username,
    string password,
    string newPasswordQuestion,
    string newPasswordAnswer
)
Parameters
username (String)
The user to change the password question and answer for.
password (String)
The password for the specified user.
newPasswordQuestion (String)
The new password question for the specified user.
newPasswordAnswer (String)
The new password answer for the specified user.
Return Value
true if the password question and answer are updated successfully; otherwise, false.


CreateUser Method (username, password, email, passwordQuestion, passwordAnswer, isApproved, providerUserKey, status)

CreateUser Method (username, password, email, passwordQuestion, passwordAnswer, isApproved, providerUserKey, status)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► CreateUser(String, String, String, String, String, Boolean, Object, MembershipCreateStatus%)
Adds a new membership user to the data source.
Declaration Syntax
C#
public override MembershipUser CreateUser(
    string username,
    string password,
    string email,
    string passwordQuestion,
    string passwordAnswer,
    bool isApproved,
    Object providerUserKey,
    out MembershipCreateStatus status
)
Parameters
username (String)
The user name for the new user.
password (String)
The password for the new user.
email (String)
The e-mail address for the new user.
passwordQuestion (String)
The password question for the new user.
passwordAnswer (String)
The password answer for the new user
isApproved (Boolean)
Whether or not the new user is approved to be validated.
providerUserKey (Object)
The unique identifier from the membership data source for the user.
status ( MembershipCreateStatus %)
A MembershipCreateStatus enumeration value indicating whether the user was created successfully.
Return Value
A MembershipUser object populated with the information for the newly created user.


DeleteUser Method (userName, deleteAllRelatedData)

DeleteUser Method (userName, deleteAllRelatedData)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► DeleteUser(String, Boolean)
Removes a user from the membership data source.
Declaration Syntax
C#
public override bool DeleteUser(
    string userName,
    bool deleteAllRelatedData
)
Parameters
userName (String)
The name of the user to delete.
deleteAllRelatedData (Boolean)
true to delete data related to the user from the database; false to leave data related to the user in the database.
Return Value
true if the user was successfully deleted; otherwise, false.


EnablePasswordReset Property

EnablePasswordReset Property
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► EnablePasswordReset
Indicates whether the membership provider is configured to allow users to reset their passwords.
Declaration Syntax
C#
public override bool EnablePasswordReset { get; }
Value
Return Value
true if the membership provider supports password reset; otherwise, false. The default is true.


EnablePasswordRetrieval Property

EnablePasswordRetrieval Property
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► EnablePasswordRetrieval
Indicates whether the membership provider is configured to allow users to retrieve their passwords.
Declaration Syntax
C#
public override bool EnablePasswordRetrieval { get; }
Value
Return Value
true if the membership provider is configured to support password retrieval; otherwise, false. The default is false.


FindUsersByEmail Method (emailToMatch, pageIndex, pageSize, totalRecords)

FindUsersByEmail Method (emailToMatch, pageIndex, pageSize, totalRecords)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► FindUsersByEmail(String, Int32, Int32, Int32%)
Gets a collection of membership users where the e-mail address contains the specified e-mail address to match.
Declaration Syntax
C#
public override MembershipUserCollection FindUsersByEmail(
    string emailToMatch,
    int pageIndex,
    int pageSize,
    out int totalRecords
)
Parameters
emailToMatch (String)
The e-mail address to search for.
pageIndex (Int32)
The index of the page of results to return. pageIndex is zero-based.
pageSize (Int32)
The size of the page of results to return.
totalRecords ( Int32 %)
The total number of matched users.
Return Value
A MembershipUserCollection collection that contains a page of pageSizeMembershipUser objects beginning at the page specified by pageIndex.


FindUsersByName Method (userNameToMatch, pageIndex, pageSize, totalRecords)

FindUsersByName Method (userNameToMatch, pageIndex, pageSize, totalRecords)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► FindUsersByName(String, Int32, Int32, Int32%)
Gets a collection of membership users where the user name contains the specified user name to match.
Declaration Syntax
C#
public override MembershipUserCollection FindUsersByName(
    string userNameToMatch,
    int pageIndex,
    int pageSize,
    out int totalRecords
)
Parameters
userNameToMatch (String)
The user name to search for.
pageIndex (Int32)
The index of the page of results to return. pageIndex is zero-based.
pageSize (Int32)
The size of the page of results to return.
totalRecords ( Int32 %)
The total number of matched users.
Return Value
A MembershipUserCollection collection that contains a page of pageSizeMembershipUser objects beginning at the page specified by pageIndex.


GetAllUsers Method (pageIndex, pageSize, totalRecords)

GetAllUsers Method (pageIndex, pageSize, totalRecords)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► GetAllUsers(Int32, Int32, Int32%)
Gets a collection of all the users in the data source in pages of data.
Declaration Syntax
C#
public override MembershipUserCollection GetAllUsers(
    int pageIndex,
    int pageSize,
    out int totalRecords
)
Parameters
pageIndex (Int32)
The index of the page of results to return. pageIndex is zero-based.
pageSize (Int32)
The size of the page of results to return.
totalRecords ( Int32 %)
The total number of matched users.
Return Value
A MembershipUserCollection collection that contains a page of pageSizeMembershipUser objects beginning at the page specified by pageIndex.


GetNumberOfUsersOnline Method

GetNumberOfUsersOnline Method
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► GetNumberOfUsersOnline()()()
Gets the number of users currently accessing the application.
Declaration Syntax
C#
public override int GetNumberOfUsersOnline()
Return Value
The number of users currently accessing the application.


GetPassword Method (username, answer)

GetPassword Method (username, answer)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► GetPassword(String, String)
Gets the password for the specified user name from the data source.
Declaration Syntax
C#
public override string GetPassword(
    string username,
    string answer
)
Parameters
username (String)
The user to retrieve the password for.
answer (String)
The password answer for the user.
Return Value
The password for the specified user name.


GetUser Method

GetUser Method
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► GetUser()()()
Members
Icon | Member | Description
 | GetUser(Object, Boolean) | Gets user information from the data source based on the unique identifier for the membership user. Provides an option to update the last-activity date/time stamp for the user. (Overrides MembershipProvider.GetUser(Object, Boolean).)
 | GetUser(String, Boolean) | Gets information from the data source for a user. Provides an option to update the last-activity date/time stamp for the user. (Overrides MembershipProvider.GetUser(String, Boolean).)


GetUser Method (providerUserKey, userIsOnline)

GetUser Method (providerUserKey, userIsOnline)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► GetUser(Object, Boolean)
Gets user information from the data source based on the unique identifier for the membership user. Provides an option to update the last-activity date/time stamp for the user.
Declaration Syntax
C#
public override MembershipUser GetUser(
    Object providerUserKey,
    bool userIsOnline
)
Parameters
providerUserKey (Object)
The unique identifier for the membership user to get information for.
userIsOnline (Boolean)
true to update the last-activity date/time stamp for the user; false to return user information without updating the last-activity date/time stamp for the user.
Return Value
A MembershipUser object populated with the specified user's information from the data source.


GetUser Method (username, userIsOnline)

GetUser Method (username, userIsOnline)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► GetUser(String, Boolean)
Gets information from the data source for a user. Provides an option to update the last-activity date/time stamp for the user.
Declaration Syntax
C#
public override MembershipUser GetUser(
    string username,
    bool userIsOnline
)
Parameters
username (String)
The name of the user to get information for.
userIsOnline (Boolean)
true to update the last-activity date/time stamp for the user; false to return user information without updating the last-activity date/time stamp for the user.
Return Value
A MembershipUser object populated with the specified user's information from the data source.


GetUserNameByEmail Method (email)

GetUserNameByEmail Method (email)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► GetUserNameByEmail(String)
Gets the user name associated with the specified e-mail address.
Declaration Syntax
C#
public override string GetUserNameByEmail(
    string email
)
Parameters
email (String)
The e-mail address to search for.
Return Value
The user name associated with the specified e-mail address. If no match is found, return null.


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
ArgumentException | The name of the provider has a length of zero.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.


MaxInvalidPasswordAttempts Property

MaxInvalidPasswordAttempts Property
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► MaxInvalidPasswordAttempts
Gets the number of invalid password or password-answer attempts allowed before the membership user is locked out.
Declaration Syntax
C#
public override int MaxInvalidPasswordAttempts { get; }
Value
Return Value
The number of invalid password or password-answer attempts allowed before the membership user is locked out.


MinRequiredNonAlphanumericCharacters Property

MinRequiredNonAlphanumericCharacters Property
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► MinRequiredNonAlphanumericCharacters
Gets the minimum number of special characters that must be present in a valid password.
Declaration Syntax
C#
public override int MinRequiredNonAlphanumericCharacters { get; }
Value
Return Value
The minimum number of special characters that must be present in a valid password.


MinRequiredPasswordLength Property

MinRequiredPasswordLength Property
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► MinRequiredPasswordLength
Gets the minimum length required for a password.
Declaration Syntax
C#
public override int MinRequiredPasswordLength { get; }
Value
Return Value
The minimum length required for a password.


PasswordAttemptWindow Property

PasswordAttemptWindow Property
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► PasswordAttemptWindow
Gets the number of minutes in which a maximum number of invalid password or password-answer attempts are allowed before the membership user is locked out.
Declaration Syntax
C#
public override int PasswordAttemptWindow { get; }
Value
Return Value
The number of minutes in which a maximum number of invalid password or password-answer attempts are allowed before the membership user is locked out.


PasswordFormat Property

PasswordFormat Property
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► PasswordFormat
Gets a value indicating the format for storing passwords in the membership data store.
Declaration Syntax
C#
public override MembershipPasswordFormat PasswordFormat { get; }
Value
Return Value
One of the MembershipPasswordFormat values indicating the format for storing passwords in the data store.


PasswordStrengthRegularExpression Property

PasswordStrengthRegularExpression Property
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► PasswordStrengthRegularExpression
Gets the regular expression used to evaluate a password.
Declaration Syntax
C#
public override string PasswordStrengthRegularExpression { get; }
Value
Return Value
A regular expression used to evaluate a password.


ProviderWildcard Property

ProviderWildcard Property
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► ProviderWildcard
Gets the provider wildcard.
Declaration Syntax
C#
public virtual string ProviderWildcard { get; set; }
Value
The provider wildcard.


RealProvider Property

RealProvider Property
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► RealProvider
Gets the real provider.
Declaration Syntax
C#
public virtual MembershipProvider RealProvider { get; }
Value
The real provider.


RequiresQuestionAndAnswer Property

RequiresQuestionAndAnswer Property
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► RequiresQuestionAndAnswer
Gets a value indicating whether the membership provider is configured to require the user to answer a password question for password reset and retrieval.
Declaration Syntax
C#
public override bool RequiresQuestionAndAnswer { get; }
Value
Return Value
true if a password answer is required for password reset and retrieval; otherwise, false. The default is true.


RequiresUniqueEmail Property

RequiresUniqueEmail Property
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► RequiresUniqueEmail
Gets a value indicating whether the membership provider is configured to require a unique e-mail address for each user name.
Declaration Syntax
C#
public override bool RequiresUniqueEmail { get; }
Value
Return Value
true if the membership provider requires a unique e-mail address; otherwise, false. The default is true.


ResetPassword Method (username, answer)

ResetPassword Method (username, answer)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► ResetPassword(String, String)
Resets a user's password to a new, automatically generated password.
Declaration Syntax
C#
public override string ResetPassword(
    string username,
    string answer
)
Parameters
username (String)
The user to reset the password for.
answer (String)
The password answer for the specified user.
Return Value
The new password for the specified user.


UnlockUser Method (userName)

UnlockUser Method (userName)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► UnlockUser(String)
Clears a lock so that the membership user can be validated.
Declaration Syntax
C#
public override bool UnlockUser(
    string userName
)
Parameters
userName (String)
The membership user whose lock status you want to clear.
Return Value
true if the membership user was successfully unlocked; otherwise, false.


UpdateUser Method (user)

UpdateUser Method (user)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► UpdateUser(MembershipUser)
Updates information about a user in the data source.
Declaration Syntax
C#
public override void UpdateUser(
    MembershipUser user
)
Parameters
user (MembershipUser)
A MembershipUser object that represents the user to update and the updated information for the user.


ValidateUser Method (username, password)

ValidateUser Method (username, password)
Namespaces ► Sitecore.Security ► SitecoreMembershipProvider ► ValidateUser(String, String)
Verifies that the specified user name and password exist in the data source.
Declaration Syntax
C#
public override bool ValidateUser(
    string username,
    string password
)
Parameters
username (String)
The name of the user to validate.
password (String)
The password for the specified user.
Return Value
true if the specified username and password are valid; otherwise, false.


SitecoreRoleProvider Class

SitecoreRoleProvider Class
Namespaces ► Sitecore.Security ► SitecoreRoleProvider
Provider for roles.
Declaration Syntax
C#
public class SitecoreRoleProvider : RoleProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SitecoreRoleProvider()()() | Initializes a new instance of the SitecoreRoleProvider class
 | AddUsersToRoles(array<String>[]()[], array<String>[]()[]) | Adds the specified user names to the specified roles for the configured applicationName. (Overrides RoleProvider.AddUsersToRoles(array<String>[]()[], array<String>[]()[]).)
 | ApplicationName | Gets or sets the name of the application to store and retrieve role information for. (Overrides RoleProvider.ApplicationName.)
 | CreateRole(String) | Adds a new role to the data source for the configured applicationName. (Overrides RoleProvider.CreateRole(String).)
 | DeleteRole(String, Boolean) | Removes a role from the data source for the configured applicationName. (Overrides RoleProvider.DeleteRole(String, Boolean).)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindUsersInRole(String, String) | Gets an array of user names in a role where the user name contains the specified user name to match. (Overrides RoleProvider.FindUsersInRole(String, String).)
 | GetAllRoles()()() | Gets a list of all the roles for the configured applicationName. (Overrides RoleProvider.GetAllRoles()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRolesForUser(String) | Gets a list of the roles that a specified user is in for the configured applicationName. (Overrides RoleProvider.GetRolesForUser(String).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUsersInRole(String) | Gets a list of users in the specified role for the configured applicationName. (Overrides RoleProvider.GetUsersInRole(String).)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | IsUserInRole(String, String) | Gets a value indicating whether the specified user is in the specified role for the configured applicationName. (Overrides RoleProvider.IsUserInRole(String, String).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | RealProvider | Gets the real provider.
 | RemoveUsersFromRoles(array<String>[]()[], array<String>[]()[]) | Removes the specified user names from the specified roles for the configured applicationName. (Overrides RoleProvider.RemoveUsersFromRoles(array<String>[]()[], array<String>[]()[]).)
 | RoleExists(String) | Gets a value indicating whether the specified role name already exists in the role data source for the configured applicationName. (Overrides RoleProvider.RoleExists(String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | RoleProvider
 |  |  | SitecoreRoleProvider


SitecoreRoleProvider Constructor

SitecoreRoleProvider Constructor
Namespaces ► Sitecore.Security ► SitecoreRoleProvider ► SitecoreRoleProvider()()()
Initializes a new instance of the SitecoreRoleProvider class
Declaration Syntax
C#
public SitecoreRoleProvider()


AddUsersToRoles Method (userNames, roleNames)

AddUsersToRoles Method (userNames, roleNames)
Namespaces ► Sitecore.Security ► SitecoreRoleProvider ► AddUsersToRoles(array<String>[]()[], array<String>[]()[])
Adds the specified user names to the specified roles for the configured applicationName.
Declaration Syntax
C#
public override void AddUsersToRoles(
    string[] userNames,
    string[] roleNames
)
Parameters
userNames (array< String >[]()[])
A string array of user names to be added to the specified roles.
roleNames (array< String >[]()[])
A string array of the role names to add the specified user names to.


ApplicationName Property

ApplicationName Property
Namespaces ► Sitecore.Security ► SitecoreRoleProvider ► ApplicationName
Gets or sets the name of the application to store and retrieve role information for.
Declaration Syntax
C#
public override string ApplicationName { get; set; }
Value
Return Value
The name of the application to store and retrieve role information for.


CreateRole Method (roleName)

CreateRole Method (roleName)
Namespaces ► Sitecore.Security ► SitecoreRoleProvider ► CreateRole(String)
Adds a new role to the data source for the configured applicationName.
Declaration Syntax
C#
public override void CreateRole(
    string roleName
)
Parameters
roleName (String)
The name of the role to create.


DeleteRole Method (roleName, throwOnPopulatedRole)

DeleteRole Method (roleName, throwOnPopulatedRole)
Namespaces ► Sitecore.Security ► SitecoreRoleProvider ► DeleteRole(String, Boolean)
Removes a role from the data source for the configured applicationName.
Declaration Syntax
C#
public override bool DeleteRole(
    string roleName,
    bool throwOnPopulatedRole
)
Parameters
roleName (String)
The name of the role to delete.
throwOnPopulatedRole (Boolean)
If true, throw an exception if roleName has one or more members and do not delete roleName.
Return Value
true if the role was successfully deleted; otherwise, false.


FindUsersInRole Method (roleName, usernameToMatch)

FindUsersInRole Method (roleName, usernameToMatch)
Namespaces ► Sitecore.Security ► SitecoreRoleProvider ► FindUsersInRole(String, String)
Gets an array of user names in a role where the user name contains the specified user name to match.
Declaration Syntax
C#
public override string[] FindUsersInRole(
    string roleName,
    string usernameToMatch
)
Parameters
roleName (String)
The role to search in.
usernameToMatch (String)
The user name to search for.
Return Value
A string array containing the names of all the users where the user name matches usernameToMatch and the user is a member of the specified role.


GetAllRoles Method

GetAllRoles Method
Namespaces ► Sitecore.Security ► SitecoreRoleProvider ► GetAllRoles()()()
Gets a list of all the roles for the configured applicationName.
Declaration Syntax
C#
public override string[] GetAllRoles()
Return Value
A string array containing the names of all the roles stored in the data source for the configured applicationName.


GetRolesForUser Method (username)

GetRolesForUser Method (username)
Namespaces ► Sitecore.Security ► SitecoreRoleProvider ► GetRolesForUser(String)
Gets a list of the roles that a specified user is in for the configured applicationName.
Declaration Syntax
C#
public override string[] GetRolesForUser(
    string username
)
Parameters
username (String)
The user to return a list of roles for.
Return Value
A string array containing the names of all the roles that the specified user is in for the configured applicationName.


GetUsersInRole Method (roleName)

GetUsersInRole Method (roleName)
Namespaces ► Sitecore.Security ► SitecoreRoleProvider ► GetUsersInRole(String)
Gets a list of users in the specified role for the configured applicationName.
Declaration Syntax
C#
public override string[] GetUsersInRole(
    string roleName
)
Parameters
roleName (String)
The name of the role to get the list of users for.
Return Value
A string array containing the names of all the users who are members of the specified role for the configured applicationName.


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Security ► SitecoreRoleProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
ArgumentException | The name of the provider has a length of zero.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.


IsUserInRole Method (username, roleName)

IsUserInRole Method (username, roleName)
Namespaces ► Sitecore.Security ► SitecoreRoleProvider ► IsUserInRole(String, String)
Gets a value indicating whether the specified user is in the specified role for the configured applicationName.
Declaration Syntax
C#
public override bool IsUserInRole(
    string username,
    string roleName
)
Parameters
username (String)
The user name to search for.
roleName (String)
The role to search in.
Return Value
true if the specified user is in the specified role for the configured applicationName; otherwise, false.


RealProvider Property

RealProvider Property
Namespaces ► Sitecore.Security ► SitecoreRoleProvider ► RealProvider
Gets the real provider.
Declaration Syntax
C#
public virtual RoleProvider RealProvider { get; }
Value
The real provider.


RemoveUsersFromRoles Method (userNames, roleNames)

RemoveUsersFromRoles Method (userNames, roleNames)
Namespaces ► Sitecore.Security ► SitecoreRoleProvider ► RemoveUsersFromRoles(array<String>[]()[], array<String>[]()[])
Removes the specified user names from the specified roles for the configured applicationName.
Declaration Syntax
C#
public override void RemoveUsersFromRoles(
    string[] userNames,
    string[] roleNames
)
Parameters
userNames (array< String >[]()[])
A string array of user names to be removed from the specified roles.
roleNames (array< String >[]()[])
A string array of role names to remove the specified user names from.


RoleExists Method (roleName)

RoleExists Method (roleName)
Namespaces ► Sitecore.Security ► SitecoreRoleProvider ► RoleExists(String)
Gets a value indicating whether the specified role name already exists in the role data source for the configured applicationName.
Declaration Syntax
C#
public override bool RoleExists(
    string roleName
)
Parameters
roleName (String)
The name of the role to search for in the data source.
Return Value
true if the role name already exists in the data source for the configured applicationName; otherwise, false.


SwitchingMembershipProvider Class

SwitchingMembershipProvider Class
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider
SitecoreMembershipProvider class
Declaration Syntax
C#
public class SwitchingMembershipProvider : MembershipProvider
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SwitchingMembershipProvider()()() | Initializes a new instance of the SwitchingMembershipProvider class
 | ApplicationName | The name of the application using the custom membership provider. (Overrides MembershipProvider.ApplicationName.)
 | ChangePassword(String, String, String) | Processes a request to update the password for a membership user. (Overrides MembershipProvider.ChangePassword(String, String, String).)
 | ChangePasswordQuestionAndAnswer(String, String, String, String) | Processes a request to update the password question and answer for a membership user. (Overrides MembershipProvider.ChangePasswordQuestionAndAnswer(String, String, String, String).)
 | CreateUser(String, String, String, String, String, Boolean, Object, MembershipCreateStatus%) | Adds a new membership user to the data source. (Overrides MembershipProvider.CreateUser(String, String, String, String, String, Boolean, Object, MembershipCreateStatus%).)
 | DecryptPassword(array<Byte>[]()[]) | Decrypts an encrypted password. (Inherited from MembershipProvider.)
 | DeleteUser(String, Boolean) | Removes a user from the membership data source. (Overrides MembershipProvider.DeleteUser(String, Boolean).)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | EnablePasswordReset | Indicates whether the membership provider is configured to allow users to reset their passwords. (Overrides MembershipProvider.EnablePasswordReset.)
 | EnablePasswordRetrieval | Indicates whether the membership provider is configured to allow users to retrieve their passwords. (Overrides MembershipProvider.EnablePasswordRetrieval.)
 | EncryptPassword(array<Byte>[]()[]) | Encrypts a password. (Inherited from MembershipProvider.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindUsersByEmail(String, Int32, Int32, Int32%) | Gets a collection of membership users where the e-mail address contains the specified e-mail address to match. (Overrides MembershipProvider.FindUsersByEmail(String, Int32, Int32, Int32%).)
 | FindUsersByName(String, Int32, Int32, Int32%) | Gets a collection of membership users where the user name contains the specified user name to match. (Overrides MembershipProvider.FindUsersByName(String, Int32, Int32, Int32%).)
 | GetAllUsers(Int32, Int32, Int32%) | Gets a collection of all the users in the data source in pages of data. (Overrides MembershipProvider.GetAllUsers(Int32, Int32, Int32%).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNumberOfUsersOnline()()() | Gets the number of users currently accessing the application. (Overrides MembershipProvider.GetNumberOfUsersOnline()()().)
 | GetPassword(String, String) | Gets the password for the specified user name from the data source. (Overrides MembershipProvider.GetPassword(String, String).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUser(Object, Boolean) | Gets information from the data source for a user based on the unique identifier for the membership user. Provides an option to update the last-activity date/time stamp for the user. (Overrides MembershipProvider.GetUser(Object, Boolean).)
 | GetUser(String, Boolean) | Gets information from the data source for a user. Provides an option to update the last-activity date/time stamp for the user. (Overrides MembershipProvider.GetUser(String, Boolean).)
 | GetUserNameByEmail(String) | Gets the user name associated with the specified e-mail address. (Overrides MembershipProvider.GetUserNameByEmail(String).)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | MaxInvalidPasswordAttempts | Gets the number of invalid password or password-answer attempts allowed before the membership user is locked out. (Overrides MembershipProvider.MaxInvalidPasswordAttempts.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinRequiredNonAlphanumericCharacters | Gets the minimum number of special characters that must be present in a valid password. (Overrides MembershipProvider.MinRequiredNonAlphanumericCharacters.)
 | MinRequiredPasswordLength | Gets the minimum length required for a password. (Overrides MembershipProvider.MinRequiredPasswordLength.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | OnValidatingPassword(ValidatePasswordEventArgs) | Raises the ValidatingPassword event if an event handler has been defined. (Inherited from MembershipProvider.)
 | PasswordAttemptWindow | Gets the number of minutes in which a maximum number of invalid password or password-answer attempts are allowed before the membership user is locked out. (Overrides MembershipProvider.PasswordAttemptWindow.)
 | PasswordFormat | Gets a value indicating the format for storing passwords in the membership data store. (Overrides MembershipProvider.PasswordFormat.)
 | PasswordStrengthRegularExpression | Gets the regular expression used to evaluate a password. (Overrides MembershipProvider.PasswordStrengthRegularExpression.)
 | RequiresQuestionAndAnswer | Gets a value indicating whether the membership provider is configured to require the user to answer a password question for password reset and retrieval. (Overrides MembershipProvider.RequiresQuestionAndAnswer.)
 | RequiresUniqueEmail | Gets a value indicating whether the membership provider is configured to require a unique e-mail address for each user name. (Overrides MembershipProvider.RequiresUniqueEmail.)
 | ResetPassword(String, String) | Resets a user's password to a new, automatically generated password. (Overrides MembershipProvider.ResetPassword(String, String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnlockUser(String) | Clears a lock so that the membership user can be validated. (Overrides MembershipProvider.UnlockUser(String).)
 | UpdateUser(MembershipUser) | Updates information about a user in the data source. (Overrides MembershipProvider.UpdateUser(MembershipUser).)
 | ValidateUser(String, String) | Verifies that the specified user name and password exist in the data source. (Overrides MembershipProvider.ValidateUser(String, String).)
 | ValidatingPassword | Occurs when a user is created, a password is changed, or a password is reset. (Inherited from MembershipProvider.)
 | Wrappers | Gets the wrapper list.
Inheritance Hierarchy
Object
 | ProviderBase
 |  | MembershipProvider
 |  |  | SwitchingMembershipProvider


SwitchingMembershipProvider Constructor

SwitchingMembershipProvider Constructor
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► SwitchingMembershipProvider()()()
Initializes a new instance of the SwitchingMembershipProvider class
Declaration Syntax
C#
public SwitchingMembershipProvider()


ApplicationName Property

ApplicationName Property
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► ApplicationName
The name of the application using the custom membership provider.
Declaration Syntax
C#
public override string ApplicationName { get; set; }
Return Value
The name of the application using the custom membership provider.


ChangePassword Method (userName, oldPassword, newPassword)

ChangePassword Method (userName, oldPassword, newPassword)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► ChangePassword(String, String, String)
Processes a request to update the password for a membership user.
Declaration Syntax
C#
public override bool ChangePassword(
    string userName,
    string oldPassword,
    string newPassword
)
Parameters
userName (String)
The user to update the password for.
oldPassword (String)
The current password for the specified user.
newPassword (String)
The new password for the specified user.
Return Value
true if the password was updated successfully; otherwise, false.


ChangePasswordQuestionAndAnswer Method (userName, password, newPasswordQuestion, newPasswordAnswer)

ChangePasswordQuestionAndAnswer Method (userName, password, newPasswordQuestion, newPasswordAnswer)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► ChangePasswordQuestionAndAnswer(String, String, String, String)
Processes a request to update the password question and answer for a membership user.
Declaration Syntax
C#
public override bool ChangePasswordQuestionAndAnswer(
    string userName,
    string password,
    string newPasswordQuestion,
    string newPasswordAnswer
)
Parameters
userName (String)
The user to change the password question and answer for.
password (String)
The password for the specified user.
newPasswordQuestion (String)
The new password question for the specified user.
newPasswordAnswer (String)
The new password answer for the specified user.
Return Value
true if the password question and answer are updated successfully; otherwise, false.


CreateUser Method (userName, password, email, passwordQuestion, passwordAnswer, isApproved, providerUserKey, status)

CreateUser Method (userName, password, email, passwordQuestion, passwordAnswer, isApproved, providerUserKey, status)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► CreateUser(String, String, String, String, String, Boolean, Object, MembershipCreateStatus%)
Adds a new membership user to the data source.
Declaration Syntax
C#
public override MembershipUser CreateUser(
    string userName,
    string password,
    string email,
    string passwordQuestion,
    string passwordAnswer,
    bool isApproved,
    Object providerUserKey,
    out MembershipCreateStatus status
)
Parameters
userName (String)
The user name for the new user.
password (String)
The password for the new user.
email (String)
The e-mail address for the new user.
passwordQuestion (String)
The password question for the new user.
passwordAnswer (String)
The password answer for the new user
isApproved (Boolean)
Whether or not the new user is approved to be validated.
providerUserKey (Object)
The unique identifier from the membership data source for the user.
status ( MembershipCreateStatus %)
A MembershipCreateStatus enumeration value indicating whether the user was created successfully.
Return Value
A MembershipUser object populated with the information for the newly created user.


DeleteUser Method (userName, deleteAllRelatedData)

DeleteUser Method (userName, deleteAllRelatedData)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► DeleteUser(String, Boolean)
Removes a user from the membership data source.
Declaration Syntax
C#
public override bool DeleteUser(
    string userName,
    bool deleteAllRelatedData
)
Parameters
userName (String)
The name of the user to delete.
deleteAllRelatedData (Boolean)
true to delete data related to the user from the database; false to leave data related to the user in the database.
Return Value
true if the user was successfully deleted; otherwise, false.


EnablePasswordReset Property

EnablePasswordReset Property
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► EnablePasswordReset
Indicates whether the membership provider is configured to allow users to reset their passwords.
Declaration Syntax
C#
public override bool EnablePasswordReset { get; }
Return Value
true if the membership provider supports password reset; otherwise, false. The default is true.


EnablePasswordRetrieval Property

EnablePasswordRetrieval Property
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► EnablePasswordRetrieval
Indicates whether the membership provider is configured to allow users to retrieve their passwords.
Declaration Syntax
C#
public override bool EnablePasswordRetrieval { get; }
Return Value
true if the membership provider is configured to support password retrieval; otherwise, false. The default is false.


FindUsersByEmail Method (emailToMatch, pageIndex, pageSize, totalRecords)

FindUsersByEmail Method (emailToMatch, pageIndex, pageSize, totalRecords)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► FindUsersByEmail(String, Int32, Int32, Int32%)
Gets a collection of membership users where the e-mail address contains the specified e-mail address to match.
Declaration Syntax
C#
public override MembershipUserCollection FindUsersByEmail(
    string emailToMatch,
    int pageIndex,
    int pageSize,
    out int totalRecords
)
Parameters
emailToMatch (String)
The e-mail address to search for.
pageIndex (Int32)
The index of the page of results to return. pageIndex is zero-based.
pageSize (Int32)
The size of the page of results to return.
totalRecords ( Int32 %)
The total number of matched users.
Return Value
A MembershipUserCollection collection that contains a page of pageSizeMembershipUser objects beginning at the page specified by pageIndex.


FindUsersByName Method (userNameToMatch, pageIndex, pageSize, totalRecords)

FindUsersByName Method (userNameToMatch, pageIndex, pageSize, totalRecords)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► FindUsersByName(String, Int32, Int32, Int32%)
Gets a collection of membership users where the user name contains the specified user name to match.
Declaration Syntax
C#
public override MembershipUserCollection FindUsersByName(
    string userNameToMatch,
    int pageIndex,
    int pageSize,
    out int totalRecords
)
Parameters
userNameToMatch (String)
The user name to search for.
pageIndex (Int32)
The index of the page of results to return. pageIndex is zero-based.
pageSize (Int32)
The size of the page of results to return.
totalRecords ( Int32 %)
The total number of matched users.
Return Value
A MembershipUserCollection collection that contains a page of pageSizeMembershipUser objects beginning at the page specified by pageIndex.


GetAllUsers Method (pageIndex, pageSize, totalRecords)

GetAllUsers Method (pageIndex, pageSize, totalRecords)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► GetAllUsers(Int32, Int32, Int32%)
Gets a collection of all the users in the data source in pages of data.
Declaration Syntax
C#
public override MembershipUserCollection GetAllUsers(
    int pageIndex,
    int pageSize,
    out int totalRecords
)
Parameters
pageIndex (Int32)
The index of the page of results to return. pageIndex is zero-based.
pageSize (Int32)
The size of the page of results to return.
totalRecords ( Int32 %)
The total number of matched users.
Return Value
A MembershipUserCollection collection that contains a page of pageSizeMembershipUser objects beginning at the page specified by pageIndex.


GetNumberOfUsersOnline Method

GetNumberOfUsersOnline Method
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► GetNumberOfUsersOnline()()()
Gets the number of users currently accessing the application.
Declaration Syntax
C#
public override int GetNumberOfUsersOnline()
Return Value
The number of users currently accessing the application.


GetPassword Method (userName, answer)

GetPassword Method (userName, answer)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► GetPassword(String, String)
Gets the password for the specified user name from the data source.
Declaration Syntax
C#
public override string GetPassword(
    string userName,
    string answer
)
Parameters
userName (String)
The user to retrieve the password for.
answer (String)
The password answer for the user.
Return Value
The password for the specified user name.


GetUser Method

GetUser Method
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► GetUser()()()
Members
Icon | Member | Description
 | GetUser(Object, Boolean) | Gets information from the data source for a user based on the unique identifier for the membership user. Provides an option to update the last-activity date/time stamp for the user. (Overrides MembershipProvider.GetUser(Object, Boolean).)
 | GetUser(String, Boolean) | Gets information from the data source for a user. Provides an option to update the last-activity date/time stamp for the user. (Overrides MembershipProvider.GetUser(String, Boolean).)


GetUser Method (providerUserKey, userIsOnline)

GetUser Method (providerUserKey, userIsOnline)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► GetUser(Object, Boolean)
Gets information from the data source for a user based on the unique identifier for the membership user. Provides an option to update the last-activity date/time stamp for the user.
Declaration Syntax
C#
public override MembershipUser GetUser(
    Object providerUserKey,
    bool userIsOnline
)
Parameters
providerUserKey (Object)
The unique identifier for the membership user to get information for.
userIsOnline (Boolean)
true to update the last-activity date/time stamp for the user; false to return user information without updating the last-activity date/time stamp for the user.
Return Value
A MembershipUser object populated with the specified user's information from the data source.


GetUser Method (userName, userIsOnline)

GetUser Method (userName, userIsOnline)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► GetUser(String, Boolean)
Gets information from the data source for a user. Provides an option to update the last-activity date/time stamp for the user.
Declaration Syntax
C#
public override MembershipUser GetUser(
    string userName,
    bool userIsOnline
)
Parameters
userName (String)
The name of the user to get information for.
userIsOnline (Boolean)
true to update the last-activity date/time stamp for the user; false to return user information without updating the last-activity date/time stamp for the user.
Return Value
A MembershipUser object populated with the specified user's information from the data source.


GetUserNameByEmail Method (email)

GetUserNameByEmail Method (email)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► GetUserNameByEmail(String)
Gets the user name associated with the specified e-mail address.
Declaration Syntax
C#
public override string GetUserNameByEmail(
    string email
)
Parameters
email (String)
The e-mail address to search for.
Return Value
The user name associated with the specified e-mail address. If no match is found, return null.


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
ArgumentException | The name of the provider has a length of zero.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.


MaxInvalidPasswordAttempts Property

MaxInvalidPasswordAttempts Property
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► MaxInvalidPasswordAttempts
Gets the number of invalid password or password-answer attempts allowed before the membership user is locked out.
Declaration Syntax
C#
public override int MaxInvalidPasswordAttempts { get; }
Return Value
The number of invalid password or password-answer attempts allowed before the membership user is locked out.


MinRequiredNonAlphanumericCharacters Property

MinRequiredNonAlphanumericCharacters Property
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► MinRequiredNonAlphanumericCharacters
Gets the minimum number of special characters that must be present in a valid password.
Declaration Syntax
C#
public override int MinRequiredNonAlphanumericCharacters { get; }
Return Value
The minimum number of special characters that must be present in a valid password.


MinRequiredPasswordLength Property

MinRequiredPasswordLength Property
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► MinRequiredPasswordLength
Gets the minimum length required for a password.
Declaration Syntax
C#
public override int MinRequiredPasswordLength { get; }
Return Value
The minimum length required for a password.


PasswordAttemptWindow Property

PasswordAttemptWindow Property
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► PasswordAttemptWindow
Gets the number of minutes in which a maximum number of invalid password or password-answer attempts are allowed before the membership user is locked out.
Declaration Syntax
C#
public override int PasswordAttemptWindow { get; }
Return Value
The number of minutes in which a maximum number of invalid password or password-answer attempts are allowed before the membership user is locked out.


PasswordFormat Property

PasswordFormat Property
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► PasswordFormat
Gets a value indicating the format for storing passwords in the membership data store.
Declaration Syntax
C#
public override MembershipPasswordFormat PasswordFormat { get; }
Return Value
One of the MembershipPasswordFormat values indicating the format for storing passwords in the data store.


PasswordStrengthRegularExpression Property

PasswordStrengthRegularExpression Property
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► PasswordStrengthRegularExpression
Gets the regular expression used to evaluate a password.
Declaration Syntax
C#
public override string PasswordStrengthRegularExpression { get; }
Return Value
A regular expression used to evaluate a password.


RequiresQuestionAndAnswer Property

RequiresQuestionAndAnswer Property
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► RequiresQuestionAndAnswer
Gets a value indicating whether the membership provider is configured to require the user to answer a password question for password reset and retrieval.
Declaration Syntax
C#
public override bool RequiresQuestionAndAnswer { get; }
Return Value
true if a password answer is required for password reset and retrieval; otherwise, false. The default is true.


RequiresUniqueEmail Property

RequiresUniqueEmail Property
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► RequiresUniqueEmail
Gets a value indicating whether the membership provider is configured to require a unique e-mail address for each user name.
Declaration Syntax
C#
public override bool RequiresUniqueEmail { get; }
Return Value
true if the membership provider requires a unique e-mail address; otherwise, false. The default is true.


ResetPassword Method (userName, answer)

ResetPassword Method (userName, answer)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► ResetPassword(String, String)
Resets a user's password to a new, automatically generated password.
Declaration Syntax
C#
public override string ResetPassword(
    string userName,
    string answer
)
Parameters
userName (String)
The user to reset the password for.
answer (String)
The password answer for the specified user.
Return Value
The new password for the specified user.


UnlockUser Method (userName)

UnlockUser Method (userName)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► UnlockUser(String)
Clears a lock so that the membership user can be validated.
Declaration Syntax
C#
public override bool UnlockUser(
    string userName
)
Parameters
userName (String)
The membership user to clear the lock status for.
Return Value
true if the membership user was successfully unlocked; otherwise, false.


UpdateUser Method (user)

UpdateUser Method (user)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► UpdateUser(MembershipUser)
Updates information about a user in the data source.
Declaration Syntax
C#
public override void UpdateUser(
    MembershipUser user
)
Parameters
user (MembershipUser)
A MembershipUser object that represents the user to update and the updated information for the user.


ValidateUser Method (userName, password)

ValidateUser Method (userName, password)
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► ValidateUser(String, String)
Verifies that the specified user name and password exist in the data source.
Declaration Syntax
C#
public override bool ValidateUser(
    string userName,
    string password
)
Parameters
userName (String)
The name of the user to validate.
password (String)
The password for the specified user.
Return Value
true if the specified user name and password are valid; otherwise, false.


Wrappers Property

Wrappers Property
Namespaces ► Sitecore.Security ► SwitchingMembershipProvider ► Wrappers
Gets the wrapper list.
Declaration Syntax
C#
public virtual MembershipProviderWrapperList Wrappers { get; }
Value
The wrappers.


SwitchingProfileProvider Class

SwitchingProfileProvider Class
Namespaces ► Sitecore.Security ► SwitchingProfileProvider
SitecoreProfileProvider class
Declaration Syntax
C#
public class SwitchingProfileProvider : ProfileProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SwitchingProfileProvider()()() | Initializes a new instance of the SwitchingProfileProvider class
 | ApplicationName | Gets or sets the name of the currently running application. (Overrides SettingsProvider.ApplicationName.)
 | DeleteInactiveProfiles(ProfileAuthenticationOption, DateTime) | When overridden in a derived class, deletes all user-profile data for profiles in which the last activity date occurred before the specified date. (Overrides ProfileProvider.DeleteInactiveProfiles(ProfileAuthenticationOption, DateTime).)
 | DeleteProfiles(ProfileInfoCollection) | When overridden in a derived class, deletes profile properties and information for the supplied list of profiles. (Overrides ProfileProvider.DeleteProfiles(ProfileInfoCollection).)
 | DeleteProfiles(array<String>[]()[]) | When overridden in a derived class, deletes profile properties and information for profiles that match the supplied list of user names. (Overrides ProfileProvider.DeleteProfiles(array<String>[]()[]).)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindInactiveProfilesByUserName(ProfileAuthenticationOption, String, DateTime, Int32, Int32, Int32%) | When overridden in a derived class, retrieves profile information for profiles in which the last activity date occurred on or before the specified date and the user name matches the specified user name. (Overrides ProfileProvider.FindInactiveProfilesByUserName(ProfileAuthenticationOption, String, DateTime, Int32, Int32, Int32%).)
 | FindProfilesByUserName(ProfileAuthenticationOption, String, Int32, Int32, Int32%) | When overridden in a derived class, retrieves profile information for profiles in which the user name matches the specified user names. (Overrides ProfileProvider.FindProfilesByUserName(ProfileAuthenticationOption, String, Int32, Int32, Int32%).)
 | GetAllInactiveProfiles(ProfileAuthenticationOption, DateTime, Int32, Int32, Int32%) | When overridden in a derived class, retrieves user-profile data from the data source for profiles in which the last activity date occurred on or before the specified date. (Overrides ProfileProvider.GetAllInactiveProfiles(ProfileAuthenticationOption, DateTime, Int32, Int32, Int32%).)
 | GetAllProfiles(ProfileAuthenticationOption, Int32, Int32, Int32%) | When overridden in a derived class, retrieves user profile data for all profiles in the data source. (Overrides ProfileProvider.GetAllProfiles(ProfileAuthenticationOption, Int32, Int32, Int32%).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNumberOfInactiveProfiles(ProfileAuthenticationOption, DateTime) | When overridden in a derived class, returns the number of profiles in which the last activity date occurred on or before the specified date. (Overrides ProfileProvider.GetNumberOfInactiveProfiles(ProfileAuthenticationOption, DateTime).)
 | GetPropertyValues(SettingsContext, SettingsPropertyCollection) | Returns the collection of settings property values for the specified application instance and settings property group. (Overrides SettingsProvider.GetPropertyValues(SettingsContext, SettingsPropertyCollection).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | SetPropertyValues(SettingsContext, SettingsPropertyValueCollection) | Sets the values of the specified group of property settings. (Overrides SettingsProvider.SetPropertyValues(SettingsContext, SettingsPropertyValueCollection).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Wrappers | Gets the wrapper list.
Inheritance Hierarchy
Object
 | ProviderBase
 |  | SettingsProvider
 |  |  | ProfileProvider
 |  |  |  | SwitchingProfileProvider


SwitchingProfileProvider Constructor

SwitchingProfileProvider Constructor
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► SwitchingProfileProvider()()()
Initializes a new instance of the SwitchingProfileProvider class
Declaration Syntax
C#
public SwitchingProfileProvider()


ApplicationName Property

ApplicationName Property
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► ApplicationName
Gets or sets the name of the currently running application.
Declaration Syntax
C#
public override string ApplicationName { get; set; }
Return Value
A String that contains the application's shortened name, which does not contain a full path or extension, for example, SimpleAppSettings.


DeleteInactiveProfiles Method (authenticationOption, userInactiveSinceDate)

DeleteInactiveProfiles Method (authenticationOption, userInactiveSinceDate)
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► DeleteInactiveProfiles(ProfileAuthenticationOption, DateTime)
When overridden in a derived class, deletes all user-profile data for profiles in which the last activity date occurred before the specified date.
Declaration Syntax
C#
public override int DeleteInactiveProfiles(
    ProfileAuthenticationOption authenticationOption,
    DateTime userInactiveSinceDate
)
Parameters
authenticationOption (ProfileAuthenticationOption)
One of the ProfileAuthenticationOption values, specifying whether anonymous, authenticated, or both types of profiles are deleted.
userInactiveSinceDate (DateTime)
A DateTime that identifies which user profiles are considered inactive. If the LastActivityDate value of a user profile occurs on or before this date and time, the profile is considered inactive.
Return Value
The number of profiles deleted from the data source.


DeleteProfiles Method

DeleteProfiles Method
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► DeleteProfiles()()()
Members
Icon | Member | Description
 | DeleteProfiles(ProfileInfoCollection) | When overridden in a derived class, deletes profile properties and information for the supplied list of profiles. (Overrides ProfileProvider.DeleteProfiles(ProfileInfoCollection).)
 | DeleteProfiles(array<String>[]()[]) | When overridden in a derived class, deletes profile properties and information for profiles that match the supplied list of user names. (Overrides ProfileProvider.DeleteProfiles(array<String>[]()[]).)


DeleteProfiles Method (userNames)

DeleteProfiles Method (userNames)
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► DeleteProfiles(array<String>[]()[])
When overridden in a derived class, deletes profile properties and information for profiles that match the supplied list of user names.
Declaration Syntax
C#
public override int DeleteProfiles(
    string[] userNames
)
Parameters
userNames (array< String >[]()[])
A string array of user names for profiles to be deleted.
Return Value
The number of profiles deleted from the data source.


DeleteProfiles Method (profiles)

DeleteProfiles Method (profiles)
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► DeleteProfiles(ProfileInfoCollection)
When overridden in a derived class, deletes profile properties and information for the supplied list of profiles.
Declaration Syntax
C#
public override int DeleteProfiles(
    ProfileInfoCollection profiles
)
Parameters
profiles (ProfileInfoCollection)
A ProfileInfoCollection of information about profiles that are to be deleted.
Return Value
The number of profiles deleted from the data source.


FindInactiveProfilesByUserName Method (authenticationOption, userNameToMatch, userInactiveSinceDate, pageIndex, pageSize, totalRecords)

FindInactiveProfilesByUserName Method (authenticationOption, userNameToMatch, userInactiveSinceDate, pageIndex, pageSize, totalRecords)
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► FindInactiveProfilesByUserName(ProfileAuthenticationOption, String, DateTime, Int32, Int32, Int32%)
When overridden in a derived class, retrieves profile information for profiles in which the last activity date occurred on or before the specified date and the user name matches the specified user name.
Declaration Syntax
C#
public override ProfileInfoCollection FindInactiveProfilesByUserName(
    ProfileAuthenticationOption authenticationOption,
    string userNameToMatch,
    DateTime userInactiveSinceDate,
    int pageIndex,
    int pageSize,
    out int totalRecords
)
Parameters
authenticationOption (ProfileAuthenticationOption)
One of the ProfileAuthenticationOption values, specifying whether anonymous, authenticated, or both types of profiles are returned.
userNameToMatch (String)
The user name to search for.
userInactiveSinceDate (DateTime)
A DateTime that identifies which user profiles are considered inactive. If the LastActivityDate value of a user profile occurs on or before this date and time, the profile is considered inactive.
pageIndex (Int32)
The index of the page of results to return.
pageSize (Int32)
The size of the page of results to return.
totalRecords ( Int32 %)
When this method returns, contains the total number of profiles.
Return Value
A ProfileInfoCollection containing user profile information for inactive profiles where the user name matches the supplied userNameToMatch parameter.


FindProfilesByUserName Method (authenticationOption, userNameToMatch, pageIndex, pageSize, totalRecords)

FindProfilesByUserName Method (authenticationOption, userNameToMatch, pageIndex, pageSize, totalRecords)
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► FindProfilesByUserName(ProfileAuthenticationOption, String, Int32, Int32, Int32%)
When overridden in a derived class, retrieves profile information for profiles in which the user name matches the specified user names.
Declaration Syntax
C#
public override ProfileInfoCollection FindProfilesByUserName(
    ProfileAuthenticationOption authenticationOption,
    string userNameToMatch,
    int pageIndex,
    int pageSize,
    out int totalRecords
)
Parameters
authenticationOption (ProfileAuthenticationOption)
One of the ProfileAuthenticationOption values, specifying whether anonymous, authenticated, or both types of profiles are returned.
userNameToMatch (String)
The user name to search for.
pageIndex (Int32)
The index of the page of results to return.
pageSize (Int32)
The size of the page of results to return.
totalRecords ( Int32 %)
When this method returns, contains the total number of profiles.
Return Value
A ProfileInfoCollection containing user-profile information for profiles where the user name matches the supplied userNameToMatch parameter.


GetAllInactiveProfiles Method (authenticationOption, userInactiveSinceDate, pageIndex, pageSize, totalRecords)

GetAllInactiveProfiles Method (authenticationOption, userInactiveSinceDate, pageIndex, pageSize, totalRecords)
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► GetAllInactiveProfiles(ProfileAuthenticationOption, DateTime, Int32, Int32, Int32%)
When overridden in a derived class, retrieves user-profile data from the data source for profiles in which the last activity date occurred on or before the specified date.
Declaration Syntax
C#
public override ProfileInfoCollection GetAllInactiveProfiles(
    ProfileAuthenticationOption authenticationOption,
    DateTime userInactiveSinceDate,
    int pageIndex,
    int pageSize,
    out int totalRecords
)
Parameters
authenticationOption (ProfileAuthenticationOption)
One of the ProfileAuthenticationOption values, specifying whether anonymous, authenticated, or both types of profiles are returned.
userInactiveSinceDate (DateTime)
A DateTime that identifies which user profiles are considered inactive. If the LastActivityDate of a user profile occurs on or before this date and time, the profile is considered inactive.
pageIndex (Int32)
The index of the page of results to return.
pageSize (Int32)
The size of the page of results to return.
totalRecords ( Int32 %)
When this method returns, contains the total number of profiles.
Return Value
A ProfileInfoCollection containing user-profile information about the inactive profiles.


GetAllProfiles Method (authenticationOption, pageIndex, pageSize, totalRecords)

GetAllProfiles Method (authenticationOption, pageIndex, pageSize, totalRecords)
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► GetAllProfiles(ProfileAuthenticationOption, Int32, Int32, Int32%)
When overridden in a derived class, retrieves user profile data for all profiles in the data source.
Declaration Syntax
C#
public override ProfileInfoCollection GetAllProfiles(
    ProfileAuthenticationOption authenticationOption,
    int pageIndex,
    int pageSize,
    out int totalRecords
)
Parameters
authenticationOption (ProfileAuthenticationOption)
One of the ProfileAuthenticationOption values, specifying whether anonymous, authenticated, or both types of profiles are returned.
pageIndex (Int32)
The index of the page of results to return.
pageSize (Int32)
The size of the page of results to return.
totalRecords ( Int32 %)
When this method returns, contains the total number of profiles.
Return Value
A ProfileInfoCollection containing user-profile information for all profiles in the data source.


GetNumberOfInactiveProfiles Method (authenticationOption, userInactiveSinceDate)

GetNumberOfInactiveProfiles Method (authenticationOption, userInactiveSinceDate)
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► GetNumberOfInactiveProfiles(ProfileAuthenticationOption, DateTime)
When overridden in a derived class, returns the number of profiles in which the last activity date occurred on or before the specified date.
Declaration Syntax
C#
public override int GetNumberOfInactiveProfiles(
    ProfileAuthenticationOption authenticationOption,
    DateTime userInactiveSinceDate
)
Parameters
authenticationOption (ProfileAuthenticationOption)
One of the ProfileAuthenticationOption values, specifying whether anonymous, authenticated, or both types of profiles are returned.
userInactiveSinceDate (DateTime)
A DateTime that identifies which user profiles are considered inactive. If the LastActivityDate of a user profile occurs on or before this date and time, the profile is considered inactive.
Return Value
The number of profiles in which the last activity date occurred on or before the specified date.


GetPropertyValues Method (context, collection)

GetPropertyValues Method (context, collection)
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► GetPropertyValues(SettingsContext, SettingsPropertyCollection)
Returns the collection of settings property values for the specified application instance and settings property group.
Declaration Syntax
C#
public override SettingsPropertyValueCollection GetPropertyValues(
    SettingsContext context,
    SettingsPropertyCollection collection
)
Parameters
context (SettingsContext)
A SettingsContext describing the current application use.
collection (SettingsPropertyCollection)
A SettingsPropertyCollection containing the settings property group whose values are to be retrieved.
Return Value
A SettingsPropertyValueCollection containing the values for the specified settings property group.


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
ArgumentException | The name of the provider has a length of zero.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.


SetPropertyValues Method (context, collection)

SetPropertyValues Method (context, collection)
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► SetPropertyValues(SettingsContext, SettingsPropertyValueCollection)
Sets the values of the specified group of property settings.
Declaration Syntax
C#
public override void SetPropertyValues(
    SettingsContext context,
    SettingsPropertyValueCollection collection
)
Parameters
context (SettingsContext)
A SettingsContext describing the current application usage.
collection (SettingsPropertyValueCollection)
A SettingsPropertyValueCollection representing the group of property settings to set.


Wrappers Property

Wrappers Property
Namespaces ► Sitecore.Security ► SwitchingProfileProvider ► Wrappers
Gets the wrapper list.
Declaration Syntax
C#
public virtual ProfileProviderWrapperList Wrappers { get; }
Value
The wrappers.


SwitchingRoleProvider Class

SwitchingRoleProvider Class
Namespaces ► Sitecore.Security ► SwitchingRoleProvider
Provider for roles.
Declaration Syntax
C#
public class SwitchingRoleProvider : RoleProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SwitchingRoleProvider()()() | Initializes a new instance of the SwitchingRoleProvider class
 | AddUsersToRoles(array<String>[]()[], array<String>[]()[]) | Adds the users to roles. (Overrides RoleProvider.AddUsersToRoles(array<String>[]()[], array<String>[]()[]).)
 | ApplicationName | Gets or sets the name of the application to store and retrieve role information for. (Overrides RoleProvider.ApplicationName.)
 | CreateRole(String) | Adds a new role to the data source for the configured applicationName. (Overrides RoleProvider.CreateRole(String).)
 | DeleteRole(String, Boolean) | Removes a role from the data source for the configured applicationName. (Overrides RoleProvider.DeleteRole(String, Boolean).)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindUsersInRole(String, String) | Finds the users in role. (Overrides RoleProvider.FindUsersInRole(String, String).)
 | GetAllRoles()()() | Gets a list of all the roles for the configured applicationName. (Overrides RoleProvider.GetAllRoles()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRolesForUser(String) | Gets the roles for user. (Overrides RoleProvider.GetRolesForUser(String).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUsersInRole(String) | Gets a list of users in the specified role for the configured applicationName. (Overrides RoleProvider.GetUsersInRole(String).)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | IsUserInRole(String, String) | Determines whether the specified user is in the specified role. (Overrides RoleProvider.IsUserInRole(String, String).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | RemoveUsersFromRoles(array<String>[]()[], array<String>[]()[]) | Removes the users from roles. (Overrides RoleProvider.RemoveUsersFromRoles(array<String>[]()[], array<String>[]()[]).)
 | RoleExists(String) | Gets a value indicating whether the specified role name already exists in the role data source for the configured applicationName. (Overrides RoleProvider.RoleExists(String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Wrappers | Gets the wrapper list.
Inheritance Hierarchy
Object
 | ProviderBase
 |  | RoleProvider
 |  |  | SwitchingRoleProvider


SwitchingRoleProvider Constructor

SwitchingRoleProvider Constructor
Namespaces ► Sitecore.Security ► SwitchingRoleProvider ► SwitchingRoleProvider()()()
Initializes a new instance of the SwitchingRoleProvider class
Declaration Syntax
C#
public SwitchingRoleProvider()


AddUsersToRoles Method (userNames, roleNames)

AddUsersToRoles Method (userNames, roleNames)
Namespaces ► Sitecore.Security ► SwitchingRoleProvider ► AddUsersToRoles(array<String>[]()[], array<String>[]()[])
Adds the users to roles.
Declaration Syntax
C#
public override void AddUsersToRoles(
    string[] userNames,
    string[] roleNames
)
Parameters
userNames (array< String >[]()[])
The user names.
roleNames (array< String >[]()[])
The role names.


ApplicationName Property

ApplicationName Property
Namespaces ► Sitecore.Security ► SwitchingRoleProvider ► ApplicationName
Gets or sets the name of the application to store and retrieve role information for.
Declaration Syntax
C#
public override string ApplicationName { get; set; }
Value
Return Value
The name of the application to store and retrieve role information for.


CreateRole Method (roleName)

CreateRole Method (roleName)
Namespaces ► Sitecore.Security ► SwitchingRoleProvider ► CreateRole(String)
Adds a new role to the data source for the configured applicationName.
Declaration Syntax
C#
public override void CreateRole(
    string roleName
)
Parameters
roleName (String)
The name of the role to create.


DeleteRole Method (roleName, throwOnPopulatedRole)

DeleteRole Method (roleName, throwOnPopulatedRole)
Namespaces ► Sitecore.Security ► SwitchingRoleProvider ► DeleteRole(String, Boolean)
Removes a role from the data source for the configured applicationName.
Declaration Syntax
C#
public override bool DeleteRole(
    string roleName,
    bool throwOnPopulatedRole
)
Parameters
roleName (String)
The name of the role to delete.
throwOnPopulatedRole (Boolean)
If true, throw an exception if roleName has one or more members and do not delete roleName.
Return Value
true if the role was successfully deleted; otherwise, false.


FindUsersInRole Method (roleName, userNameToMatch)

FindUsersInRole Method (roleName, userNameToMatch)
Namespaces ► Sitecore.Security ► SwitchingRoleProvider ► FindUsersInRole(String, String)
Finds the users in role.
Declaration Syntax
C#
public override string[] FindUsersInRole(
    string roleName,
    string userNameToMatch
)
Parameters
roleName (String)
Name of the role.
userNameToMatch (String)
The user name to match.
Return Value


GetAllRoles Method

GetAllRoles Method
Namespaces ► Sitecore.Security ► SwitchingRoleProvider ► GetAllRoles()()()
Gets a list of all the roles for the configured applicationName.
Declaration Syntax
C#
public override string[] GetAllRoles()
Return Value
A string array containing the names of all the roles stored in the data source for the configured applicationName.


GetRolesForUser Method (userName)

GetRolesForUser Method (userName)
Namespaces ► Sitecore.Security ► SwitchingRoleProvider ► GetRolesForUser(String)
Gets the roles for user.
Declaration Syntax
C#
public override string[] GetRolesForUser(
    string userName
)
Parameters
userName (String)
Name of the user.
Return Value


GetUsersInRole Method (roleName)

GetUsersInRole Method (roleName)
Namespaces ► Sitecore.Security ► SwitchingRoleProvider ► GetUsersInRole(String)
Gets a list of users in the specified role for the configured applicationName.
Declaration Syntax
C#
public override string[] GetUsersInRole(
    string roleName
)
Parameters
roleName (String)
The name of the role to get the list of users for.
Return Value
A string array containing the names of all the users who are members of the specified role for the configured applicationName.


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Security ► SwitchingRoleProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
ArgumentException | The name of the provider has a length of zero.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.


IsUserInRole Method (userName, roleName)

IsUserInRole Method (userName, roleName)
Namespaces ► Sitecore.Security ► SwitchingRoleProvider ► IsUserInRole(String, String)
Determines whether the specified user is in the specified role.
Declaration Syntax
C#
public override bool IsUserInRole(
    string userName,
    string roleName
)
Parameters
userName (String)
Name of the user.
roleName (String)
Name of the role.
Return Value
true if [is user in role] [the specified user name]; otherwise, false.


RemoveUsersFromRoles Method (userNames, roleNames)

RemoveUsersFromRoles Method (userNames, roleNames)
Namespaces ► Sitecore.Security ► SwitchingRoleProvider ► RemoveUsersFromRoles(array<String>[]()[], array<String>[]()[])
Removes the users from roles.
Declaration Syntax
C#
public override void RemoveUsersFromRoles(
    string[] userNames,
    string[] roleNames
)
Parameters
userNames (array< String >[]()[])
The user names.
roleNames (array< String >[]()[])
The role names.


RoleExists Method (roleName)

RoleExists Method (roleName)
Namespaces ► Sitecore.Security ► SwitchingRoleProvider ► RoleExists(String)
Gets a value indicating whether the specified role name already exists in the role data source for the configured applicationName.
Declaration Syntax
C#
public override bool RoleExists(
    string roleName
)
Parameters
roleName (String)
The name of the role to search for in the data source.
Return Value
true if the role name already exists in the data source for the configured applicationName; otherwise, false.


Wrappers Property

Wrappers Property
Namespaces ► Sitecore.Security ► SwitchingRoleProvider ► Wrappers
Gets the wrapper list.
Declaration Syntax
C#
public virtual RoleProviderWrapperList Wrappers { get; }
Value
The wrappers.


UserProfile Class

UserProfile Class
Namespaces ► Sitecore.Security ► UserProfile
Profile class
Declaration Syntax
C#
public class UserProfile : ProfileBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserProfile()()() | Initializes a new instance of the UserProfile class
 | AssignableRoles | Obsolete. Gets or sets the assignable roles.
 | ClientLanguage | Gets the client language.
 | Comment | Gets or sets the comment.
 | ContentLanguage | Gets or sets the content language.
 | Context | Gets the associated settings context. (Inherited from SettingsBase.)
 | Culture | Gets the culture.
 | Email | Gets the email.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullName | Gets or sets the full name.
 | GetCustomProperty(String) | Gets a custom property.
 | GetCustomPropertyNames()()() | Gets the keys of all custom properties.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProfileGroup(String) | Gets a group of properties identified by a group name. (Inherited from ProfileBase.)
 | GetPropertyValue(String) | Gets the value of a profile property. (Inherited from ProfileBase.)
 | GetPropertyValueCore(String) | Gets a named property value.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets or sets the icon.
 | Initialize(String, Boolean) | Initializes the profile property values and information for the current user. (Inherited from ProfileBase.)
 | Initialize(SettingsContext, SettingsPropertyCollection, SettingsProviderCollection) | Initializes internal properties used by SettingsBase object. (Inherited from SettingsBase.)
 | IsAdministrator | Gets or sets a value indicating whether this user is an administrator.
 | IsAnonymous | Gets a value indicating whether the user profile is for an anonymous user. (Inherited from ProfileBase.)
 | IsDirty | Gets a value indicating whether any of the profile properties have been modified. (Inherited from ProfileBase.)
 | IsSynchronized | Gets a value indicating whether access to the object is synchronized (thread safe). (Inherited from SettingsBase.)
 | Item[([(String])]) | Gets or sets a profile property value indexed by the property name.
 | LastActivityDate | Gets the most recent date and time that the profile was read or modified. (Inherited from ProfileBase.)
 | LastUpdatedDate | Gets the most recent date and time that the profile was modified. (Inherited from ProfileBase.)
 | LegacyPassword | Gets or sets the legacy password. The value containg hash in format of Sitecore 5.3.1. Should be used only for migration reasons.
 | ManagedDomainNames | Gets or sets the domains to manage.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name.
 | Portrait | Gets or sets the portrait.
 | ProfileItemId | Gets or sets the profile item id.
 | Properties | Gets the collection of settings properties. (Inherited from SettingsBase.)
 | PropertyValues | Gets a collection of settings property values. (Inherited from SettingsBase.)
 | Providers | Gets a collection of settings providers. (Inherited from SettingsBase.)
 | RegionalIsoCode | Gets the regional iso code.
 | Reload()()() | Reloads all profile data for the user.
 | RemoveCustomProperty(String) | Removes a named custom property.
 | Save()()() | Updates the profile data source with changed profile property values. (Overrides ProfileBase.Save()()().)
 | SerializedData | Gets or sets the serialized data.
 | SetCustomProperty(String, String) | Sets the value of a custom property.
 | SetPropertyValue(String, Object) | Sets the value of a profile property. (Inherited from ProfileBase.)
 | SetPropertyValueCore(String, Object) | Sets a named property value.
 | StartUrl | Gets the start URL.
 | State | Gets the state.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserName | Gets the user name for the profile. (Inherited from ProfileBase.)
Inheritance Hierarchy
Object
 | SettingsBase
 |  | ProfileBase
 |  |  | UserProfile


UserProfile Constructor

UserProfile Constructor
Namespaces ► Sitecore.Security ► UserProfile ► UserProfile()()()
Initializes a new instance of the UserProfile class
Declaration Syntax
C#
public UserProfile()


AssignableRoles Property

AssignableRoles Property
Namespaces ► Sitecore.Security ► UserProfile ► AssignableRoles
Gets or sets the assignable roles.
Declaration Syntax
C#
[ObsoleteAttribute]
public virtual string AssignableRoles { get; set; }
Value
The assignable roles.


ClientLanguage Property

ClientLanguage Property
Namespaces ► Sitecore.Security ► UserProfile ► ClientLanguage
Gets the client language.
Declaration Syntax
C#
public virtual string ClientLanguage { get; set; }
Value
The client language.


Comment Property

Comment Property
Namespaces ► Sitecore.Security ► UserProfile ► Comment
Gets or sets the comment.
Declaration Syntax
C#
public virtual string Comment { get; set; }
Value
The comment.


ContentLanguage Property

ContentLanguage Property
Namespaces ► Sitecore.Security ► UserProfile ► ContentLanguage
Gets or sets the content language.
Declaration Syntax
C#
public virtual string ContentLanguage { get; set; }
Value
The content language.


Culture Property

Culture Property
Namespaces ► Sitecore.Security ► UserProfile ► Culture
Gets the culture.
Declaration Syntax
C#
public virtual CultureInfo Culture { get; }
Value
The culture.


Email Property

Email Property
Namespaces ► Sitecore.Security ► UserProfile ► Email
Gets the email.
Declaration Syntax
C#
public virtual string Email { get; set; }
Value
The email.


FullName Property

FullName Property
Namespaces ► Sitecore.Security ► UserProfile ► FullName
Gets or sets the full name.
Declaration Syntax
C#
public virtual string FullName { get; set; }
Value
The full name.


GetCustomProperty Method (propertyName)

GetCustomProperty Method (propertyName)
Namespaces ► Sitecore.Security ► UserProfile ► GetCustomProperty(String)
Gets a custom property.
Declaration Syntax
C#
public virtual string GetCustomProperty(
    string propertyName
)
Parameters
propertyName (String)
Name of the property.
Return Value


GetCustomPropertyNames Method

GetCustomPropertyNames Method
Namespaces ► Sitecore.Security ► UserProfile ► GetCustomPropertyNames()()()
Gets the keys of all custom properties.
Declaration Syntax
C#
public virtual List<string> GetCustomPropertyNames()
Return Value


GetPropertyValueCore Method (propertyName)

GetPropertyValueCore Method (propertyName)
Namespaces ► Sitecore.Security ► UserProfile ► GetPropertyValueCore(String)
Gets a named property value.
Declaration Syntax
C#
protected virtual Object GetPropertyValueCore(
    string propertyName
)
Parameters
propertyName (String)
Name of the property.
Return Value


Icon Property

Icon Property
Namespaces ► Sitecore.Security ► UserProfile ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public virtual string Icon { get; set; }
Value
The icon.


IsAdministrator Property

IsAdministrator Property
Namespaces ► Sitecore.Security ► UserProfile ► IsAdministrator
Gets or sets a value indicating whether this user is an administrator.
Declaration Syntax
C#
public virtual bool IsAdministrator { get; set; }
Value
true if this user is an administrator; otherwise, false.


Item Property (propertyName)

Item Property (propertyName)
Namespaces ► Sitecore.Security ► UserProfile ► Item[([(String])])
Gets or sets a profile property value indexed by the property name.
Declaration Syntax
C#
public virtual string this[
    string propertyName
] { get; set; }
Parameters
propertyName (String)
The name of the profile property.
Return Value
The value of the specified profile property, typed as object.
Exceptions
Exception | Condition
SettingsPropertyNotFoundException | There are no properties defined for the current profile.- or -The specified profile property name does not exist in the current profile.- or -The provider for the specified profile property did not recognize the specified property.
ProviderException | An attempt was made to set a property value on an anonymous profile where the property's allowAnonymous attribute is false.
SettingsPropertyIsReadOnlyException | An attempt was made to set a property value that was marked as read-only.
SettingsPropertyWrongTypeException | An attempt was made to assign a value to a property using an incompatible type.


LegacyPassword Property

LegacyPassword Property
Namespaces ► Sitecore.Security ► UserProfile ► LegacyPassword
Gets or sets the legacy password. The value containg hash in format of Sitecore 5.3.1. Should be used only for migration reasons.
Declaration Syntax
C#
public virtual string LegacyPassword { get; set; }
Value
The legacy password.


ManagedDomainNames Property

ManagedDomainNames Property
Namespaces ► Sitecore.Security ► UserProfile ► ManagedDomainNames
Gets or sets the domains to manage.
Declaration Syntax
C#
public virtual string ManagedDomainNames { get; set; }
Value
The domains to manage.


Name Property

Name Property
Namespaces ► Sitecore.Security ► UserProfile ► Name
Gets or sets the name.
Declaration Syntax
C#
public virtual string Name { get; set; }
Value
The name.


Portrait Property

Portrait Property
Namespaces ► Sitecore.Security ► UserProfile ► Portrait
Gets or sets the portrait.
Declaration Syntax
C#
public virtual string Portrait { get; set; }
Value
The portrait.


ProfileItemId Property

ProfileItemId Property
Namespaces ► Sitecore.Security ► UserProfile ► ProfileItemId
Gets or sets the profile item id.
Declaration Syntax
C#
public virtual string ProfileItemId { get; set; }
Value
The profile item id.


RegionalIsoCode Property

RegionalIsoCode Property
Namespaces ► Sitecore.Security ► UserProfile ► RegionalIsoCode
Gets the regional iso code.
Declaration Syntax
C#
public virtual string RegionalIsoCode { get; set; }
Value
The regional iso code.


Reload Method

Reload Method
Namespaces ► Sitecore.Security ► UserProfile ► Reload()()()
Reloads all profile data for the user.
Declaration Syntax
C#
public virtual void Reload()


RemoveCustomProperty Method (propertyName)

RemoveCustomProperty Method (propertyName)
Namespaces ► Sitecore.Security ► UserProfile ► RemoveCustomProperty(String)
Removes a named custom property.
Declaration Syntax
C#
public virtual void RemoveCustomProperty(
    string propertyName
)
Parameters
propertyName (String)
The key.


Save Method

Save Method
Namespaces ► Sitecore.Security ► UserProfile ► Save()()()
Updates the profile data source with changed profile property values.
Declaration Syntax
C#
public override void Save()


SerializedData Property

SerializedData Property
Namespaces ► Sitecore.Security ► UserProfile ► SerializedData
Gets or sets the serialized data.
Declaration Syntax
C#
public virtual Object SerializedData { get; set; }
Value
The serialized data.
Remarks
For internal use only.


SetCustomProperty Method (propertyName, value)

SetCustomProperty Method (propertyName, value)
Namespaces ► Sitecore.Security ► UserProfile ► SetCustomProperty(String, String)
Sets the value of a custom property.
Declaration Syntax
C#
public virtual void SetCustomProperty(
    string propertyName,
    string value
)
Parameters
propertyName (String)
Name of the property.
value (String)
The value.


SetPropertyValueCore Method (propertyName, value)

SetPropertyValueCore Method (propertyName, value)
Namespaces ► Sitecore.Security ► UserProfile ► SetPropertyValueCore(String, Object)
Sets a named property value.
Declaration Syntax
C#
protected virtual void SetPropertyValueCore(
    string propertyName,
    Object value
)
Parameters
propertyName (String)
Name of the property.
value (Object)
The value.


StartUrl Property

StartUrl Property
Namespaces ► Sitecore.Security ► UserProfile ► StartUrl
Gets the start URL.
Declaration Syntax
C#
public virtual string StartUrl { get; set; }
Value
The start URL.


State Property

State Property
Namespaces ► Sitecore.Security ► UserProfile ► State
Gets the state.
Declaration Syntax
C#
public virtual string State { get; }
Value
The state.


Sitecore.Security.AccessControl Namespace

Sitecore.Security.AccessControl Namespace
Namespaces ► Sitecore.Security.AccessControl
Declaration Syntax
C#
namespace Sitecore.Security.AccessControl
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | AccessExplanation | AccessExplanation class
 | AccessPermission | AccessControlType class
 | AccessResult | AccessInformation class
 | AccessResultCacheRecord | AccessResultCacheRecord class
 | AccessRight | AccessRight class
 | AccessRightCollection | AccessRightCollection class
 | AccessRightManager | AccessRightManager class
 | AccessRightProvider | AccessRightProvider class
 | AccessRightProviderCollection | AccessRightProviderCollection class
 | AccessRightRule | Defines the access rule for a right.
 | AccessRightRuleCollection | AccessRightRuleCollection class
 | AccessRule | AccessRule class
 | AccessRuleCollection | AccessRuleCollection class
 | AccessRuleCollectionHelper | AccessRuleCollectionHelper class
 | AccessRuleSerializer | AccessRuleSerializer class
 | AuthorizationCallContext | AuthorizationCallContext class
 | AuthorizationHelper<(Of <(T>)>) | AuthorizationHelper class
 | AuthorizationManager | Authorization class
 | AuthorizationProvider | AuthorizationProvider class
 | AuthorizationProviderCollection | AuthorizationProviderCollection class
 | AuthorizationSwitcher | AuthorizationSwitcher class
 | ConfigAccessRightProvider | ConfigAccessRightProvider class
 | FieldAuthorizationHelper | FieldAuthorizationHelper class
 | InheritancePermission | InheritanceRestriction class
 | ISecurable | ISecurable
 | ItemAccess | Represents access to an item.
 | ItemAuthorizationHelper | ItemAuthorizationHelper class
 | ItemSecurity | ItemSecurity class
 | PermissionType | RestrictionKind enum
 | PropagationType | PropagationType enum
 | SecurityPermission | SecurityRestriction class
 | SqlAuthorizationProvider | SqlAuthorizationProvider class
 | SqlServerAuthorizationProvider | SqlServerAuthorizationProvider class
 | WellknownRights | Rights class


AccessExplanation Class

AccessExplanation Class
Namespaces ► Sitecore.Security.AccessControl ► AccessExplanation
AccessExplanation class
Declaration Syntax
C#
public class AccessExplanation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessExplanation(String, array<Object>[]()[]) | Initializes a new instance of the AccessExplanation class.
 | AccessExplanation(ISecurable, Account, AccessRight, AccessRule) | Initializes a new instance of the AccessExplanation class.
 | AccessExplanation(Account, AccessRight, String, array<Object>[]()[]) | Initializes a new instance of the AccessExplanation class.
 | AccessExplanation(ISecurable, Account, AccessRight, String, array<Object>[]()[]) | Initializes a new instance of the AccessExplanation class.
 | AccessRight | Gets the access right.
 | AccessRule | Gets the access rule.
 | Account | Gets the account.
 | Entity | Gets the entity.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text | Gets the text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AccessExplanation


AccessExplanation Constructor

AccessExplanation Constructor
Namespaces ► Sitecore.Security.AccessControl ► AccessExplanation ► AccessExplanation()()()
Members
Icon | Member | Description
 | AccessExplanation(String, array<Object>[]()[]) | Initializes a new instance of the AccessExplanation class.
 | AccessExplanation(ISecurable, Account, AccessRight, AccessRule) | Initializes a new instance of the AccessExplanation class.
 | AccessExplanation(Account, AccessRight, String, array<Object>[]()[]) | Initializes a new instance of the AccessExplanation class.
 | AccessExplanation(ISecurable, Account, AccessRight, String, array<Object>[]()[]) | Initializes a new instance of the AccessExplanation class.


AccessExplanation Constructor (entity, account, accessRight, accessRule)

AccessExplanation Constructor (entity, account, accessRight, accessRule)
Namespaces ► Sitecore.Security.AccessControl ► AccessExplanation ► AccessExplanation(ISecurable, Account, AccessRight, AccessRule)
Initializes a new instance of the AccessExplanation class.
Declaration Syntax
C#
public AccessExplanation(
    ISecurable entity,
    Account account,
    AccessRight accessRight,
    AccessRule accessRule
)
Parameters
entity (ISecurable)
The entity.
account (Account)
The account.
accessRight (AccessRight)
The access right.
accessRule (AccessRule)
The rule used for resolving the access.


AccessExplanation Constructor (entity, account, accessRight, text, parameters)

AccessExplanation Constructor (entity, account, accessRight, text, parameters)
Namespaces ► Sitecore.Security.AccessControl ► AccessExplanation ► AccessExplanation(ISecurable, Account, AccessRight, String, array<Object>[]()[])
Initializes a new instance of the AccessExplanation class.
Declaration Syntax
C#
public AccessExplanation(
    ISecurable entity,
    Account account,
    AccessRight accessRight,
    string text,
    params Object[] parameters
)
Parameters
entity (ISecurable)
The entity.
account (Account)
The account.
accessRight (AccessRight)
The access right.
text (String)
The message describing the reasoning behind the permission.
parameters (array< Object >[]()[])
The parameters.


AccessExplanation Constructor (account, accessRight, text, parameters)

AccessExplanation Constructor (account, accessRight, text, parameters)
Namespaces ► Sitecore.Security.AccessControl ► AccessExplanation ► AccessExplanation(Account, AccessRight, String, array<Object>[]()[])
Initializes a new instance of the AccessExplanation class.
Declaration Syntax
C#
public AccessExplanation(
    Account account,
    AccessRight accessRight,
    string text,
    params Object[] parameters
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
text (String)
The message describing the reasoning behind the permission.
parameters (array< Object >[]()[])
The parameters.


AccessExplanation Constructor (text, parameters)

AccessExplanation Constructor (text, parameters)
Namespaces ► Sitecore.Security.AccessControl ► AccessExplanation ► AccessExplanation(String, array<Object>[]()[])
Initializes a new instance of the AccessExplanation class.
Declaration Syntax
C#
public AccessExplanation(
    string text,
    params Object[] parameters
)
Parameters
text (String)
The text.
parameters (array< Object >[]()[])
The parameters.


AccessRight Property

AccessRight Property
Namespaces ► Sitecore.Security.AccessControl ► AccessExplanation ► AccessRight
Gets the access right.
Declaration Syntax
C#
public virtual AccessRight AccessRight { get; }
Value
The access right (might be null).


AccessRule Property

AccessRule Property
Namespaces ► Sitecore.Security.AccessControl ► AccessExplanation ► AccessRule
Gets the access rule.
Declaration Syntax
C#
public virtual AccessRule AccessRule { get; }
Value
The rule used for resolving the access (might be null).


Account Property

Account Property
Namespaces ► Sitecore.Security.AccessControl ► AccessExplanation ► Account
Gets the account.
Declaration Syntax
C#
public virtual Account Account { get; }
Value
The account (might be null).


Entity Property

Entity Property
Namespaces ► Sitecore.Security.AccessControl ► AccessExplanation ► Entity
Gets the entity.
Declaration Syntax
C#
public virtual ISecurable Entity { get; }
Value
The entity (might be null).


Text Property

Text Property
Namespaces ► Sitecore.Security.AccessControl ► AccessExplanation ► Text
Gets the text.
Declaration Syntax
C#
public virtual string Text { get; }
Value
The text (might be String.Empty).


AccessPermission Enumeration

AccessPermission Enumeration
Namespaces ► Sitecore.Security.AccessControl ► AccessPermission
AccessControlType class
Declaration Syntax
C#
public enum AccessPermission
Members
Member | Description
NotSet | Unknown access.
Allow | Allow access.
Deny | Deny access.


AccessResult Class

AccessResult Class
Namespaces ► Sitecore.Security.AccessControl ► AccessResult
AccessInformation class
Declaration Syntax
C#
public class AccessResult
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessResult(AccessPermission, AccessExplanation) | Initializes a new instance of the AccessResult class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Explanation | Gets the explanation.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotSet | Gets the 'not set' AccessInformation.
 | Permission | Gets the access permission.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AccessResult


AccessResult Constructor (permission, explanation)

AccessResult Constructor (permission, explanation)
Namespaces ► Sitecore.Security.AccessControl ► AccessResult ► AccessResult(AccessPermission, AccessExplanation)
Initializes a new instance of the AccessResult class.
Declaration Syntax
C#
public AccessResult(
    AccessPermission permission,
    AccessExplanation explanation
)
Parameters
permission (AccessPermission)
The permission.
explanation (AccessExplanation)
The explanation.


Explanation Property

Explanation Property
Namespaces ► Sitecore.Security.AccessControl ► AccessResult ► Explanation
Gets the explanation.
Declaration Syntax
C#
public virtual AccessExplanation Explanation { get; }
Value
The explanation.


NotSet Property

NotSet Property
Namespaces ► Sitecore.Security.AccessControl ► AccessResult ► NotSet
Gets the 'not set' AccessInformation.
Declaration Syntax
C#
public static AccessResult NotSet { get; }
Value
The not set AccessInformation.


Permission Property

Permission Property
Namespaces ► Sitecore.Security.AccessControl ► AccessResult ► Permission
Gets the access permission.
Declaration Syntax
C#
public virtual AccessPermission Permission { get; }
Value
The access permission.


AccessResultCacheRecord Class

AccessResultCacheRecord Class
Namespaces ► Sitecore.Security.AccessControl ► AccessResultCacheRecord
AccessResultCacheRecord class
Declaration Syntax
C#
public class AccessResultCacheRecord : CacheableRecordBase<AccessResult>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessResultCacheRecord()()() | Initializes a new instance of the AccessResultCacheRecord class
 | AddAccessResult(Account, AccessRight, AccessResult) | Obsolete. Adds an access result to the record.
 | Cacheable | Gets or sets a value indicating whether this ICacheable is cacheable. (Inherited from CacheableRecordBase<(Of <(T>)>).)
 | DataLengthChanged | Length of the data changed (Inherited from CacheableRecordBase<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccessResult(Account, AccessRight) | Obsolete. Gets an access result.
 | GetDataLength()()() | Gets the size of the data to use when caching. (Overrides CacheableRecordBase <(Of <( AccessResult >)>).GetDataLength()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Immutable | Gets a value indicating whether this ICacheable is immutable. (Inherited from CacheableRecordBase<(Of <(T>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDataLengthChanged()()() | Length of the data changed (Inherited from CacheableRecordBase<(Of <(T>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Cached value (Inherited from CacheableRecordBase<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | CacheableRecordBase <(Of <( AccessResult >)>)
 |  | AccessResultCacheRecord


AccessResultCacheRecord Constructor

AccessResultCacheRecord Constructor
Namespaces ► Sitecore.Security.AccessControl ► AccessResultCacheRecord ► AccessResultCacheRecord()()()
Initializes a new instance of the AccessResultCacheRecord class
Declaration Syntax
C#
public AccessResultCacheRecord()


AddAccessResult Method (account, accessRight, accessResult)

AddAccessResult Method (account, accessRight, accessResult)
Namespaces ► Sitecore.Security.AccessControl ► AccessResultCacheRecord ► AddAccessResult(Account, AccessRight, AccessResult)
Adds an access result to the record.
Declaration Syntax
C#
[ObsoleteAttribute("Use AccessResultCache.AddRecord instead")]
public void AddAccessResult(
    Account account,
    AccessRight accessRight,
    AccessResult accessResult
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
accessResult (AccessResult)
The access result.


GetAccessResult Method (account, accessRight)

GetAccessResult Method (account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► AccessResultCacheRecord ► GetAccessResult(Account, AccessRight)
Gets an access result.
Declaration Syntax
C#
[ObsoleteAttribute("Use AccessResultCache.GetRecord instead")]
public AccessResult GetAccessResult(
    Account account,
    AccessRight accessRight
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
Return Value


GetDataLength Method

GetDataLength Method
Namespaces ► Sitecore.Security.AccessControl ► AccessResultCacheRecord ► GetDataLength()()()
Gets the size of the data to use when caching.
Declaration Syntax
C#
public override long GetDataLength()
Return Value


AccessRight Class

AccessRight Class
Namespaces ► Sitecore.Security.AccessControl ► AccessRight
AccessRight class
Declaration Syntax
C#
public class AccessRight
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessRight(String) | Initializes a new instance of the AccessRight class.
 | Any | Gets the access right representing 'anything'.
 | AppliesTo(ISecurable) | Determines whether the access right is applicable to the specified item.
 | Comment | Gets the comment.
 | Equality(AccessRight, AccessRight) | Implements the operator ==.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)
 | FieldRead | Gets the operation representing 'field read'.
 | FieldWrite | Gets the operation representing 'field write'.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromName(String) | Gets an access right definition from its name.
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Inequality(AccessRight, AccessRight) | Implements the operator !=.
 | Initialize(NameValueCollection) | Initializes the AccessRight with custom config values.
 | InsertShow | Gets the show in insert right.
 | IsFieldRight | Gets a value indicating whether this instance is an field right (ie. applies to fields).
 | IsItemRight | Gets a value indicating whether this instance is an item right (ie. applies to items).
 | IsLanguageRight | Gets a value indicating whether this instance is a language right.
 | IsMatch(AccessRight) | Determines whether the specified access right matches the current.
 | IsSiteRight | Gets a value indicating whether this instance is an site right (ie. applies to sites).
 | IsWildcard | Gets a value indicating whether access right indicates a wildcard.
 | IsWorkflowCommandRight | Gets a value indicating whether this instance is a workflow command right.
 | IsWorkflowStateRight | Gets a value indicating whether this instance is a workflow state right.
 | ItemAdmin | Gets the operation representing 'item admin'.
 | ItemCreate | Gets the operation representing 'item create'.
 | ItemDelete | Gets the operation representing 'item delete'.
 | ItemRead | Gets the operation representing 'item read'.
 | ItemRename | Gets the operation representing 'item rename'.
 | ItemWrite | Gets the operation representing 'item write'.
 | LanguageRead | Gets the operation representing 'language read'.
 | LanguageWrite | Gets the operation representing 'language write'.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModifiesData | Gets a value indicating whether this access right might modify the entities it is associated with.
 | Name | Gets the name.
 | SiteEnter | Gets the operation representing 'site enter'.
 | Title | Gets the title.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | WorkflowCommandExecute | Gets the operation representing 'workflow command execute'.
 | WorkflowStateDelete | Gets the operation representing 'workflow state delete'.
 | WorkflowStateWrite | Gets the operation representing 'workflow state write'.
Inheritance Hierarchy
Object
AccessRight


AccessRight Constructor (name)

AccessRight Constructor (name)
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► AccessRight(String)
Initializes a new instance of the AccessRight class.
Declaration Syntax
C#
public AccessRight(
    string name
)
Parameters
name (String)


Any Property

Any Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► Any
Gets the access right representing 'anything'.
Declaration Syntax
C#
public static AccessRight Any { get; }
Value
The operation.


AppliesTo Method (entity)

AppliesTo Method (entity)
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► AppliesTo(ISecurable)
Determines whether the access right is applicable to the specified item.
Declaration Syntax
C#
public virtual bool AppliesTo(
    ISecurable entity
)
Parameters
entity (ISecurable)
The securable entity.
Return Value
true if the access right is applicable to the specified item; otherwise, false.


Comment Property

Comment Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► Comment
Gets the comment.
Declaration Syntax
C#
public virtual string Comment { get; }
Value
The comment.


Equality Operator

Equality Operator
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► Equality(AccessRight, AccessRight)
Implements the operator ==.
Declaration Syntax
C#
public static bool operator ==(
    AccessRight right1,
    AccessRight right2
)
Parameters
right1 (AccessRight)
The right1.
right2 (AccessRight)
The right2.
Return Value
The result of the operator.


Equals Method (obj)

Equals Method (obj)
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C#
public override bool Equals(
    Object obj
)
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.


FieldRead Property

FieldRead Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► FieldRead
Gets the operation representing 'field read'.
Declaration Syntax
C#
public static AccessRight FieldRead { get; }
Value
The operation.


FieldWrite Property

FieldWrite Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► FieldWrite
Gets the operation representing 'field write'.
Declaration Syntax
C#
public static AccessRight FieldWrite { get; }
Value
The operation.


FromName Method (accessRightName)

FromName Method (accessRightName)
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► FromName(String)
Gets an access right definition from its name.
Declaration Syntax
C#
public static AccessRight FromName(
    string accessRightName
)
Parameters
accessRightName (String)
Name of the access right.
Return Value


GetHashCode Method

GetHashCode Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► GetHashCode()()()
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
Declaration Syntax
C#
public override int GetHashCode()
Return Value
A hash code for the current Object.


Inequality Operator

Inequality Operator
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► Inequality(AccessRight, AccessRight)
Implements the operator !=.
Declaration Syntax
C#
public static bool operator !=(
    AccessRight right1,
    AccessRight right2
)
Parameters
right1 (AccessRight)
The right1.
right2 (AccessRight)
The right2.
Return Value
The result of the operator.


Initialize Method (config)

Initialize Method (config)
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► Initialize(NameValueCollection)
Initializes the AccessRight with custom config values.
Declaration Syntax
C#
public virtual void Initialize(
    NameValueCollection config
)
Parameters
config (NameValueCollection)
The config.


InsertShow Property

InsertShow Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► InsertShow
Gets the show in insert right.
Declaration Syntax
C#
public static AccessRight InsertShow { get; }
Value
The show in insert right.


IsFieldRight Property

IsFieldRight Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► IsFieldRight
Gets a value indicating whether this instance is an field right (ie. applies to fields).
Declaration Syntax
C#
public virtual bool IsFieldRight { get; }
Value
true if this instance is field right; otherwise, false.


IsItemRight Property

IsItemRight Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► IsItemRight
Gets a value indicating whether this instance is an item right (ie. applies to items).
Declaration Syntax
C#
public virtual bool IsItemRight { get; }
Value
true if this instance is item right; otherwise, false.


IsLanguageRight Property

IsLanguageRight Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► IsLanguageRight
Gets a value indicating whether this instance is a language right.
Declaration Syntax
C#
public virtual bool IsLanguageRight { get; }
Value
true if this instance is a language right; otherwise, false.


IsMatch Method (accessRight)

IsMatch Method (accessRight)
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► IsMatch(AccessRight)
Determines whether the specified access right matches the current.
Declaration Syntax
C#
public virtual bool IsMatch(
    AccessRight accessRight
)
Parameters
accessRight (AccessRight)
The access right.
Return Value
true if the specified right is a match; otherwise, false.


IsSiteRight Property

IsSiteRight Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► IsSiteRight
Gets a value indicating whether this instance is an site right (ie. applies to sites).
Declaration Syntax
C#
public virtual bool IsSiteRight { get; }
Value
true if this instance is site right; otherwise, false.


IsWildcard Property

IsWildcard Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► IsWildcard
Gets a value indicating whether access right indicates a wildcard.
Declaration Syntax
C#
public virtual bool IsWildcard { get; }
Value
true if this instance is a wildcard; otherwise, false.


IsWorkflowCommandRight Property

IsWorkflowCommandRight Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► IsWorkflowCommandRight
Gets a value indicating whether this instance is a workflow command right.
Declaration Syntax
C#
public virtual bool IsWorkflowCommandRight { get; }
Value
true if this instance is workflow a command right; otherwise, false.


IsWorkflowStateRight Property

IsWorkflowStateRight Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► IsWorkflowStateRight
Gets a value indicating whether this instance is a workflow state right.
Declaration Syntax
C#
public virtual bool IsWorkflowStateRight { get; }
Value
true if this instance is a workflow state right; otherwise, false.


ItemAdmin Property

ItemAdmin Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► ItemAdmin
Gets the operation representing 'item admin'.
Declaration Syntax
C#
public static AccessRight ItemAdmin { get; }
Value
The operation.


ItemCreate Property

ItemCreate Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► ItemCreate
Gets the operation representing 'item create'.
Declaration Syntax
C#
public static AccessRight ItemCreate { get; }
Value
The operation.


ItemDelete Property

ItemDelete Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► ItemDelete
Gets the operation representing 'item delete'.
Declaration Syntax
C#
public static AccessRight ItemDelete { get; }
Value
The operation.


ItemRead Property

ItemRead Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► ItemRead
Gets the operation representing 'item read'.
Declaration Syntax
C#
public static AccessRight ItemRead { get; }
Value
The operation.


ItemRename Property

ItemRename Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► ItemRename
Gets the operation representing 'item rename'.
Declaration Syntax
C#
public static AccessRight ItemRename { get; }
Value
The operation.


ItemWrite Property

ItemWrite Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► ItemWrite
Gets the operation representing 'item write'.
Declaration Syntax
C#
public static AccessRight ItemWrite { get; }
Value
The operation.


LanguageRead Property

LanguageRead Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► LanguageRead
Gets the operation representing 'language read'.
Declaration Syntax
C#
public static AccessRight LanguageRead { get; }
Value
The operation.


LanguageWrite Property

LanguageWrite Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► LanguageWrite
Gets the operation representing 'language write'.
Declaration Syntax
C#
public static AccessRight LanguageWrite { get; }
Value
The operation.


ModifiesData Property

ModifiesData Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► ModifiesData
Gets a value indicating whether this access right might modify the entities it is associated with.
Declaration Syntax
C#
public virtual bool ModifiesData { get; }
Value
true if data might be modified; otherwise, false.


Name Property

Name Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► Name
Gets the name.
Declaration Syntax
C#
public virtual string Name { get; }
Value
The name.


SiteEnter Property

SiteEnter Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► SiteEnter
Gets the operation representing 'site enter'.
Declaration Syntax
C#
public static AccessRight SiteEnter { get; }
Value
The operation.


Title Property

Title Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► Title
Gets the title.
Declaration Syntax
C#
public virtual string Title { get; }
Value
The title.


ToString Method

ToString Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


WorkflowCommandExecute Property

WorkflowCommandExecute Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► WorkflowCommandExecute
Gets the operation representing 'workflow command execute'.
Declaration Syntax
C#
public static AccessRight WorkflowCommandExecute { get; }
Value
The operation.


WorkflowStateDelete Property

WorkflowStateDelete Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► WorkflowStateDelete
Gets the operation representing 'workflow state delete'.
Declaration Syntax
C#
public static AccessRight WorkflowStateDelete { get; }
Value
The operation.


WorkflowStateWrite Property

WorkflowStateWrite Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRight ► WorkflowStateWrite
Gets the operation representing 'workflow state write'.
Declaration Syntax
C#
public static AccessRight WorkflowStateWrite { get; }
Value
The operation.


AccessRightCollection Class

AccessRightCollection Class
Namespaces ► Sitecore.Security.AccessControl ► AccessRightCollection
AccessRightCollection class
Declaration Syntax
C#
public class AccessRightCollection : Collection<AccessRight>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessRightCollection()()() | Initializes a new instance of the AccessRightCollection class
 | Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRight >)>).)
 | Clear()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRight >)>).)
 | ClearItems()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRight >)>).)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRight >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( AccessRight >)>).)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRight >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRight >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRight >)>).)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( AccessRight >)>).)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( AccessRight >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( AccessRight >)>).)
 | Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRight >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRight >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRight >)>).)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRight >)>).)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection<(Of <( AccessRight >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection<(Of <( AccessRight >)>)
 |  | AccessRightCollection


AccessRightCollection Constructor

AccessRightCollection Constructor
Namespaces ► Sitecore.Security.AccessControl ► AccessRightCollection ► AccessRightCollection()()()
Initializes a new instance of the AccessRightCollection class
Declaration Syntax
C#
public AccessRightCollection()


AccessRightManager Class

AccessRightManager Class
Namespaces ► Sitecore.Security.AccessControl ► AccessRightManager
AccessRightManager class
Declaration Syntax
C#
public static class AccessRightManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetAccessRight(String) | Gets an access right definition from its name.
 | GetAccessRights()()() | Gets all known access rights.
 | IsApplicable(AccessRight, ISecurable) | Determines whether the specified access right is applicable for the given entity.
 | Provider | Gets the provider.
 | Providers | Gets all providers.
Inheritance Hierarchy
Object
AccessRightManager


GetAccessRight Method (accessRightName)

GetAccessRight Method (accessRightName)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightManager ► GetAccessRight(String)
Gets an access right definition from its name.
Declaration Syntax
C#
public static AccessRight GetAccessRight(
    string accessRightName
)
Parameters
accessRightName (String)
Name of the access right.
Return Value


GetAccessRights Method

GetAccessRights Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRightManager ► GetAccessRights()()()
Gets all known access rights.
Declaration Syntax
C#
public static AccessRightCollection GetAccessRights()
Return Value


IsApplicable Method (accessRight, entity)

IsApplicable Method (accessRight, entity)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightManager ► IsApplicable(AccessRight, ISecurable)
Determines whether the specified access right is applicable for the given entity.
Declaration Syntax
C#
public static bool IsApplicable(
    AccessRight accessRight,
    ISecurable entity
)
Parameters
accessRight (AccessRight)
The access right.
entity (ISecurable)
The entity.
Return Value
true if the specified access right is applicable; otherwise, false.


Provider Property

Provider Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRightManager ► Provider
Gets the provider.
Declaration Syntax
C#
public static AccessRightProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRightManager ► Providers
Gets all providers.
Declaration Syntax
C#
public static AccessRightProviderCollection Providers { get; }
Value
The providers.


AccessRightProvider Class

AccessRightProvider Class
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProvider
AccessRightProvider class
Declaration Syntax
C#
public abstract class AccessRightProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessRightProvider()()() | Initializes a new instance of the AccessRightProvider class
 | AccessRights | Gets the access rights.
 | ClearAccessRightRules()()() | Removes all access rules from the central dictionary.
 | ClearAccessRights()()() | Removes all access rights from the central dictionary.
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccessRight(String) | Gets the an access right from its name.
 | GetAccessRights()()() | Gets all known access rights.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | IsApplicable(AccessRight, ISecurable) | Determines whether the specified access right is applicable for the given entity.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | RegisterAccessRight(String, AccessRight) | Registers an access right in the central dictionary.
 | RegisterAccessRightRule(AccessRightRule) | Registers the access right rule.
 | Rules | Gets the access right rules.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnregisterAccessRight(String) | Removes an access right from the central dictionary.
 | UnregisterAccessRightRule(AccessRightRule) | Removes an access rule from the central dictionary.
Inheritance Hierarchy
Object
 | ProviderBase
 |  | AccessRightProvider
 |  |  | ConfigAccessRightProvider


AccessRightProvider Constructor

AccessRightProvider Constructor
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProvider ► AccessRightProvider()()()
Initializes a new instance of the AccessRightProvider class
Declaration Syntax
C#
protected AccessRightProvider()


AccessRights Property

AccessRights Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProvider ► AccessRights
Gets the access rights.
Declaration Syntax
C#
protected virtual SafeDictionary<string, AccessRight> AccessRights { get; }
Value
The access rights.


ClearAccessRightRules Method

ClearAccessRightRules Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProvider ► ClearAccessRightRules()()()
Removes all access rules from the central dictionary.
Declaration Syntax
C#
protected virtual void ClearAccessRightRules()


ClearAccessRights Method

ClearAccessRights Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProvider ► ClearAccessRights()()()
Removes all access rights from the central dictionary.
Declaration Syntax
C#
protected virtual void ClearAccessRights()


GetAccessRight Method (accessRightName)

GetAccessRight Method (accessRightName)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProvider ► GetAccessRight(String)
Gets the an access right from its name.
Declaration Syntax
C#
public virtual AccessRight GetAccessRight(
    string accessRightName
)
Parameters
accessRightName (String)
Name of the access right.
Return Value


GetAccessRights Method

GetAccessRights Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProvider ► GetAccessRights()()()
Gets all known access rights.
Declaration Syntax
C#
public virtual AccessRightCollection GetAccessRights()
Return Value


IsApplicable Method (accessRight, entity)

IsApplicable Method (accessRight, entity)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProvider ► IsApplicable(AccessRight, ISecurable)
Determines whether the specified access right is applicable for the given entity.
Declaration Syntax
C#
public virtual bool IsApplicable(
    AccessRight accessRight,
    ISecurable entity
)
Parameters
accessRight (AccessRight)
The access right.
entity (ISecurable)
The entity.
Return Value
true if the specified access right is applicable; otherwise, false.


RegisterAccessRight Method (accessRightName, accessRight)

RegisterAccessRight Method (accessRightName, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProvider ► RegisterAccessRight(String, AccessRight)
Registers an access right in the central dictionary.
Declaration Syntax
C#
protected virtual void RegisterAccessRight(
    string accessRightName,
    AccessRight accessRight
)
Parameters
accessRightName (String)
Name of the access right.
accessRight (AccessRight)
The access right.


RegisterAccessRightRule Method (rule)

RegisterAccessRightRule Method (rule)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProvider ► RegisterAccessRightRule(AccessRightRule)
Registers the access right rule.
Declaration Syntax
C#
protected virtual void RegisterAccessRightRule(
    AccessRightRule rule
)
Parameters
rule (AccessRightRule)
The rule.


Rules Property

Rules Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProvider ► Rules
Gets the access right rules.
Declaration Syntax
C#
protected virtual AccessRightRuleCollection Rules { get; }
Value
The rules.


UnregisterAccessRight Method (accessRightName)

UnregisterAccessRight Method (accessRightName)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProvider ► UnregisterAccessRight(String)
Removes an access right from the central dictionary.
Declaration Syntax
C#
protected virtual void UnregisterAccessRight(
    string accessRightName
)
Parameters
accessRightName (String)
Name of the access right.


UnregisterAccessRightRule Method (rule)

UnregisterAccessRightRule Method (rule)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProvider ► UnregisterAccessRightRule(AccessRightRule)
Removes an access rule from the central dictionary.
Declaration Syntax
C#
protected virtual void UnregisterAccessRightRule(
    AccessRightRule rule
)
Parameters
rule (AccessRightRule)
The rule.


AccessRightProviderCollection Class

AccessRightProviderCollection Class
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProviderCollection
AccessRightProviderCollection class
Declaration Syntax
C#
public class AccessRightProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessRightProviderCollection()()() | Initializes a new instance of the AccessRightProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the AuthorizationProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | AccessRightProviderCollection


AccessRightProviderCollection Constructor

AccessRightProviderCollection Constructor
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProviderCollection ► AccessRightProviderCollection()()()
Initializes a new instance of the AccessRightProviderCollection class
Declaration Syntax
C#
public AccessRightProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightProviderCollection ► Item[([(String])])
Gets the AuthorizationProvider with the specified name.
Declaration Syntax
C#
public virtual AccessRightProvider this[
    string name
] { get; }
Parameters
name (String)
Value


AccessRightRule Class

AccessRightRule Class
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule
Defines the access rule for a right.
Declaration Syntax
C#
public class AccessRightRule
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessRightRule()()() | Initializes a new instance of the AccessRightRule class
 | AppliesTo(AccessRight, ISecurable) | Tests if a right is applicable to an entity.
 | Comment | Gets the comment.
 | Descendants | Gets a value indicating whether this AccessRightRule applies to descendants (as well as to self). Can only be used along with Path.
 | Equality(AccessRightRule, AccessRightRule) | Implements the operator ==.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Inequality(AccessRightRule, AccessRightRule) | Implements the operator !=.
 | Initialize(NameValueCollection) | Initializes the object from the specified configuration data.
 | IsStopAction | Gets a value indicating whether this instance is a stop action.
 | MatchesPath(ISecurable) | Checks for a path match.
 | MatchesPrefix(AccessRight) | Checks for a prefix match.
 | MatchesTemplateId(ISecurable) | Checks for a template id match.
 | MatchesTypeName(ISecurable) | Checks for a type name match.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets the path.
 | Prefix | Gets the prefix.
 | TemplateId | Gets the template id.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeName | Gets the type name.
Inheritance Hierarchy
Object
AccessRightRule


AccessRightRule Constructor

AccessRightRule Constructor
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► AccessRightRule()()()
Initializes a new instance of the AccessRightRule class
Declaration Syntax
C#
public AccessRightRule()


AppliesTo Method (accessRight, entity)

AppliesTo Method (accessRight, entity)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► AppliesTo(AccessRight, ISecurable)
Tests if a right is applicable to an entity.
Declaration Syntax
C#
public virtual bool AppliesTo(
    AccessRight accessRight,
    ISecurable entity
)
Parameters
accessRight (AccessRight)
The access right.
entity (ISecurable)
The entity.
Return Value


Comment Property

Comment Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► Comment
Gets the comment.
Declaration Syntax
C#
public virtual string Comment { get; }
Value
The comment.


Descendants Property

Descendants Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► Descendants
Gets a value indicating whether this AccessRightRule applies to descendants (as well as to self). Can only be used along with Path.
Declaration Syntax
C#
public virtual bool Descendants { get; }
Value
true if this AccessRightRule applies to descendants; otherwise, false.


Equality Operator

Equality Operator
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► Equality(AccessRightRule, AccessRightRule)
Implements the operator ==.
Declaration Syntax
C#
public static bool operator ==(
    AccessRightRule rule1,
    AccessRightRule rule2
)
Parameters
rule1 (AccessRightRule)
The rule1.
rule2 (AccessRightRule)
The rule2.
Return Value
The result of the operator.


Equals Method (obj)

Equals Method (obj)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C#
public override bool Equals(
    Object obj
)
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.


GetHashCode Method

GetHashCode Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► GetHashCode()()()
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
Declaration Syntax
C#
public override int GetHashCode()
Return Value
A hash code for the current Object.


Inequality Operator

Inequality Operator
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► Inequality(AccessRightRule, AccessRightRule)
Implements the operator !=.
Declaration Syntax
C#
public static bool operator !=(
    AccessRightRule right1,
    AccessRightRule right2
)
Parameters
right1 (AccessRightRule)
The right1.
right2 (AccessRightRule)
The right2.
Return Value
The result of the operator.


Initialize Method (config)

Initialize Method (config)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► Initialize(NameValueCollection)
Initializes the object from the specified configuration data.
Declaration Syntax
C#
public virtual void Initialize(
    NameValueCollection config
)
Parameters
config (NameValueCollection)
The configuration data.


IsStopAction Property

IsStopAction Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► IsStopAction
Gets a value indicating whether this instance is a stop action.
Declaration Syntax
C#
public virtual bool IsStopAction { get; }
Value
true if this instance is a stop action; otherwise, false.


MatchesPath Method (entity)

MatchesPath Method (entity)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► MatchesPath(ISecurable)
Checks for a path match.
Declaration Syntax
C#
protected virtual bool MatchesPath(
    ISecurable entity
)
Parameters
entity (ISecurable)
The entity.
Return Value
The path.


MatchesPrefix Method (accessRight)

MatchesPrefix Method (accessRight)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► MatchesPrefix(AccessRight)
Checks for a prefix match.
Declaration Syntax
C#
protected virtual bool MatchesPrefix(
    AccessRight accessRight
)
Parameters
accessRight (AccessRight)
The access right.
Return Value


MatchesTemplateId Method (entity)

MatchesTemplateId Method (entity)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► MatchesTemplateId(ISecurable)
Checks for a template id match.
Declaration Syntax
C#
protected virtual bool MatchesTemplateId(
    ISecurable entity
)
Parameters
entity (ISecurable)
The securable entity.
Return Value


MatchesTypeName Method (entity)

MatchesTypeName Method (entity)
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► MatchesTypeName(ISecurable)
Checks for a type name match.
Declaration Syntax
C#
protected virtual bool MatchesTypeName(
    ISecurable entity
)
Parameters
entity (ISecurable)
The securable entity.
Return Value


Path Property

Path Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► Path
Gets the path.
Declaration Syntax
C#
public virtual string Path { get; }
Value
The path.


Prefix Property

Prefix Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► Prefix
Gets the prefix.
Declaration Syntax
C#
public virtual string Prefix { get; }
Value
The prefix.


TemplateId Property

TemplateId Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► TemplateId
Gets the template id.
Declaration Syntax
C#
public virtual ID TemplateId { get; }
Value
The template id.


TypeName Property

TypeName Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRule ► TypeName
Gets the type name.
Declaration Syntax
C#
public virtual string TypeName { get; }
Value
The name of the type.


AccessRightRuleCollection Class

AccessRightRuleCollection Class
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRuleCollection
AccessRightRuleCollection class
Declaration Syntax
C#
public class AccessRightRuleCollection : Collection<AccessRightRule>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessRightRuleCollection()()() | Initializes a new instance of the AccessRightRuleCollection class
 | Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | Clear()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | ClearItems()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection<(Of <( AccessRightRule >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection<(Of <( AccessRightRule >)>)
 |  | AccessRightRuleCollection


AccessRightRuleCollection Constructor

AccessRightRuleCollection Constructor
Namespaces ► Sitecore.Security.AccessControl ► AccessRightRuleCollection ► AccessRightRuleCollection()()()
Initializes a new instance of the AccessRightRuleCollection class
Declaration Syntax
C#
public AccessRightRuleCollection()


AccessRule Class

AccessRule Class
Namespaces ► Sitecore.Security.AccessControl ► AccessRule
AccessRule class
Declaration Syntax
C#
public class AccessRule
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessRule(Account, AccessRight, PropagationType, SecurityPermission) | Initializes a new instance of the AccessRuleCollection class.
 | AccessRight | Gets the access mask.
 | Account | Gets the account associated with the rule.
 | Create(Account, AccessRight, PropagationType, AccessPermission) | Creates an instance of an AccessRule.
 | Create(Account, AccessRight, PropagationType, InheritancePermission) | Creates an instance of an AccessRule.
 | Create(Account, AccessRight, PropagationType, SecurityPermission) | Creates an instance of an AccessRule.
 | Equality(AccessRule, AccessRule) | Implements the == operator.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Inequality(AccessRule, AccessRule) | Implements the != operator.
 | IsMatch(Account, AccessRight, PropagationType, AccessPermission, Boolean, Boolean) | Determines whether the specified access right matches an access type for the the specified account.
 | IsMatch(Account, AccessRight, PropagationType, InheritancePermission, Boolean, Boolean) | Determines whether the specified access right matches an access type for the the specified account.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PermissionType | Gets the kind of restriction associated with the rule.
 | PropagationType | Gets the propagation.
 | RuleApplies(Account, AccessRight, PropagationType, Boolean, Boolean) | Chekcs if a rule applies.
 | RuleAppliesToAccessRight(AccessRight) | Chekcs if a rule applies to an operation.
 | RuleAppliesToAccount(Account, Boolean, Boolean) | Chekcs if a rule applies to a user.
 | RuleAppliesToPropagationType(PropagationType) | Chekcs if a rule applies to an operation.
 | SecurityPermission | Gets the type of the access control.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryParse(String, AccessRule%) | Tries to parse a textual representation of an AccessRule.
Inheritance Hierarchy
Object
AccessRule


AccessRule Constructor (account, accessRight, propagation, permission)

AccessRule Constructor (account, accessRight, propagation, permission)
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► AccessRule(Account, AccessRight, PropagationType, SecurityPermission)
Initializes a new instance of the AccessRuleCollection class.
Declaration Syntax
C#
protected AccessRule(
    Account account,
    AccessRight accessRight,
    PropagationType propagation,
    SecurityPermission permission
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagation (PropagationType)
The propagation type.
permission (SecurityPermission)
The permission type (allow/deny).


AccessRight Property

AccessRight Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► AccessRight
Gets the access mask.
Declaration Syntax
C#
public virtual AccessRight AccessRight { get; }
Value
The access mask.


Account Property

Account Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► Account
Gets the account associated with the rule.
Declaration Syntax
C#
public virtual Account Account { get; }
Value
The account.


Create Method

Create Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► Create()()()
Members
Icon | Member | Description
 | Create(Account, AccessRight, PropagationType, AccessPermission) | Creates an instance of an AccessRule.
 | Create(Account, AccessRight, PropagationType, InheritancePermission) | Creates an instance of an AccessRule.
 | Create(Account, AccessRight, PropagationType, SecurityPermission) | Creates an instance of an AccessRule.


Create Method (account, accessRight, propagationType, permission)

Create Method (account, accessRight, propagationType, permission)
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► Create(Account, AccessRight, PropagationType, AccessPermission)
Creates an instance of an AccessRule.
Declaration Syntax
C#
public static AccessRule Create(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType,
    AccessPermission permission
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
The propagation.
permission (AccessPermission)
The permission type (allow/deny).
Return Value


Create Method (account, accessRight, propagationType, permission)

Create Method (account, accessRight, propagationType, permission)
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► Create(Account, AccessRight, PropagationType, InheritancePermission)
Creates an instance of an AccessRule.
Declaration Syntax
C#
public static AccessRule Create(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType,
    InheritancePermission permission
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
The propagation.
permission (InheritancePermission)
The permission type (allow/deny).
Return Value


Create Method (account, accessRight, propagationType, permission)

Create Method (account, accessRight, propagationType, permission)
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► Create(Account, AccessRight, PropagationType, SecurityPermission)
Creates an instance of an AccessRule.
Declaration Syntax
C#
public static AccessRule Create(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType,
    SecurityPermission permission
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
The propagation.
permission (SecurityPermission)
The permission type (allow/deny).
Return Value


Equality Operator

Equality Operator
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► Equality(AccessRule, AccessRule)
Implements the == operator.
Declaration Syntax
C#
public static bool operator ==(
    AccessRule rule1,
    AccessRule rule2
)
Parameters
rule1 (AccessRule)
The rule1.
rule2 (AccessRule)
The rule2.
Return Value
The result of the operator.


Equals Method (obj)

Equals Method (obj)
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C#
public override bool Equals(
    Object obj
)
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.


GetHashCode Method

GetHashCode Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► GetHashCode()()()
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
Declaration Syntax
C#
public override int GetHashCode()
Return Value
A hash code for the current Object.


Inequality Operator

Inequality Operator
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► Inequality(AccessRule, AccessRule)
Implements the != operator.
Declaration Syntax
C#
public static bool operator !=(
    AccessRule rule1,
    AccessRule rule2
)
Parameters
rule1 (AccessRule)
The rule1.
rule2 (AccessRule)
The rule2.
Return Value
The result of the operator.


IsMatch Method

IsMatch Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► IsMatch()()()
Members
Icon | Member | Description
 | IsMatch(Account, AccessRight, PropagationType, AccessPermission, Boolean, Boolean) | Determines whether the specified access right matches an access type for the the specified account.
 | IsMatch(Account, AccessRight, PropagationType, InheritancePermission, Boolean, Boolean) | Determines whether the specified access right matches an access type for the the specified account.


IsMatch Method (account, accessRight, propagationType, permission, includeRoleMembers, includeEveryoneMembers)

IsMatch Method (account, accessRight, propagationType, permission, includeRoleMembers, includeEveryoneMembers)
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► IsMatch(Account, AccessRight, PropagationType, AccessPermission, Boolean, Boolean)
Determines whether the specified access right matches an access type for the the specified account.
Declaration Syntax
C#
public virtual bool IsMatch(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType,
    AccessPermission permission,
    bool includeRoleMembers,
    bool includeEveryoneMembers
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
The type of propagation.
permission (AccessPermission)
The permission type (allow/deny).
includeRoleMembers (Boolean)
If set to true and this account is a role, the method will return true if account is a member of the role.
includeEveryoneMembers (Boolean)

If set to true and this account is the global 'everyone' role, the method will always return true.

If set to true and this account is a domain specific 'everyone' role, the method will return true if account belongs to the same domain.

Return Value
true if the rule matches the requirements; otherwise, false.


IsMatch Method (account, accessRight, propagationType, permission, includeRoleMembers, includeEveryoneMembers)

IsMatch Method (account, accessRight, propagationType, permission, includeRoleMembers, includeEveryoneMembers)
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► IsMatch(Account, AccessRight, PropagationType, InheritancePermission, Boolean, Boolean)
Determines whether the specified access right matches an access type for the the specified account.
Declaration Syntax
C#
public virtual bool IsMatch(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType,
    InheritancePermission permission,
    bool includeRoleMembers,
    bool includeEveryoneMembers
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
The type of propagation.
permission (InheritancePermission)
The permission type (allow/deny).
includeRoleMembers (Boolean)
If set to true and this account is a role, the method will return true if account is a member of the role.
includeEveryoneMembers (Boolean)

If set to true and this account is the global 'everyone' role, the method will always return true.

If set to true and this account is a domain specific 'everyone' role, the method will return true if account belongs to the same domain.

Return Value
true if the rule matches the requirements; otherwise, false.


PermissionType Property

PermissionType Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► PermissionType
Gets the kind of restriction associated with the rule.
Declaration Syntax
C#
public virtual PermissionType PermissionType { get; }
Value
The kind of restriction.


PropagationType Property

PropagationType Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► PropagationType
Gets the propagation.
Declaration Syntax
C#
public virtual PropagationType PropagationType { get; }
Value
The propagation.


RuleApplies Method (account, accessRight, propagationType, includeRoleMembers, includeEveryoneMembers)

RuleApplies Method (account, accessRight, propagationType, includeRoleMembers, includeEveryoneMembers)
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► RuleApplies(Account, AccessRight, PropagationType, Boolean, Boolean)
Chekcs if a rule applies.
Declaration Syntax
C#
protected virtual bool RuleApplies(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType,
    bool includeRoleMembers,
    bool includeEveryoneMembers
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The requested access right.
propagationType (PropagationType)
The type of propagation.
includeRoleMembers (Boolean)
If set to true and this account is a role, the method will return true if account is a member of the role.
includeEveryoneMembers (Boolean)

If set to true and this account is the global 'everyone' role, the method will always return true.

If set to true and this account is a domain specific 'everyone' role, the method will return true if account belongs to the same domain.

Return Value


RuleAppliesToAccessRight Method (accessRight)

RuleAppliesToAccessRight Method (accessRight)
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► RuleAppliesToAccessRight(AccessRight)
Chekcs if a rule applies to an operation.
Declaration Syntax
C#
protected virtual bool RuleAppliesToAccessRight(
    AccessRight accessRight
)
Parameters
accessRight (AccessRight)
The access right.
Return Value


RuleAppliesToAccount Method (account, includeRoleMembers, includeEveryoneMembers)

RuleAppliesToAccount Method (account, includeRoleMembers, includeEveryoneMembers)
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► RuleAppliesToAccount(Account, Boolean, Boolean)
Chekcs if a rule applies to a user.
Declaration Syntax
C#
protected virtual bool RuleAppliesToAccount(
    Account account,
    bool includeRoleMembers,
    bool includeEveryoneMembers
)
Parameters
account (Account)
The account.
includeRoleMembers (Boolean)
If set to true and this account is a role, the method will return true if account is a member of the role.
includeEveryoneMembers (Boolean)

If set to true and this account is the global 'everyone' role, the method will always return true.

If set to true and this account is a domain specific 'everyone' role, the method will return true if account belongs to the same domain.

Return Value


RuleAppliesToPropagationType Method (propagationType)

RuleAppliesToPropagationType Method (propagationType)
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► RuleAppliesToPropagationType(PropagationType)
Chekcs if a rule applies to an operation.
Declaration Syntax
C#
protected virtual bool RuleAppliesToPropagationType(
    PropagationType propagationType
)
Parameters
propagationType (PropagationType)
The type of propagation.
Return Value


SecurityPermission Property

SecurityPermission Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► SecurityPermission
Gets the type of the access control.
Declaration Syntax
C#
public virtual SecurityPermission SecurityPermission { get; }
Value
The type of the access control.


TryParse Method (text, rule)

TryParse Method (text, rule)
Namespaces ► Sitecore.Security.AccessControl ► AccessRule ► TryParse(String, AccessRule%)
Tries to parse a textual representation of an AccessRule.
Declaration Syntax
C#
public static bool TryParse(
    string text,
    out AccessRule rule
)
Parameters
text (String)
The text.
rule ( AccessRule %)
The rule.
Return Value
true if the text was successfully parsed; false otherwise.


AccessRuleCollection Class

AccessRuleCollection Class
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollection
AccessRuleCollection class
Declaration Syntax
C#
public class AccessRuleCollection : List<AccessRule>,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessRuleCollection()()() | Initializes a new instance of the AccessRuleCollection class
 | Add(T) | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | AddRange(IEnumerable<(Of <(T>)>)) | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | AsReadOnly()()() | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List<(Of <( AccessRule >)>).)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( AccessRule >)>).)
 | BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List<(Of <( AccessRule >)>).)
 | BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( AccessRule >)>).)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <( AccessRule >)>).)
 | Clear()()() | Removes all elements from the List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | Clone()()() | Creates a new object that is a shallow copy of the current instance.
 | Contains(T) | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | ConvertAll<(Of <(TOutput>)>)(Converter<(Of <(T, TOutput>)>)) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List<(Of <( AccessRule >)>).)
 | CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List<(Of <( AccessRule >)>).)
 | CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( AccessRule >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( AccessRule >)>).)
 | Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <(T>)>)) | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( AccessRule >)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | FindAll(Predicate<(Of <(T>)>)) | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( AccessRule >)>).)
 | FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( AccessRule >)>).)
 | FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( AccessRule >)>).)
 | FindLast(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( AccessRule >)>).)
 | FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( AccessRule >)>).)
 | ForEach(Action<(Of <(T>)>)) | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | FromString(String) | Parses a string into an .
 | GetEnumerator()()() | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Helper | Gets or sets the helper object used for advanced manipulation of the collection.
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( AccessRule >)>).)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( AccessRule >)>).)
 | Insert(Int32, T) | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( AccessRule >)>).)
 | InsertRange(Int32, IEnumerable<(Of <(T>)>)) | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( AccessRule >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from List<(Of <( AccessRule >)>).)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( AccessRule >)>).)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( AccessRule >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | RemoveAll(Predicate<(Of <(T>)>)) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( AccessRule >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List<(Of <( AccessRule >)>).)
 | Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List<(Of <( AccessRule >)>).)
 | Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( AccessRule >)>).)
 | Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( AccessRule >)>).)
 | Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List<(Of <( AccessRule >)>).)
 | ToArray()()() | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List<(Of <( AccessRule >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | TrimExcess()()() | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List<(Of <( AccessRule >)>).)
 | TrueForAll(Predicate<(Of <(T>)>)) | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List<(Of <( AccessRule >)>).)
Inheritance Hierarchy
Object
 | List<(Of <( AccessRule >)>)
 |  | AccessRuleCollection


AccessRuleCollection Constructor

AccessRuleCollection Constructor
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollection ► AccessRuleCollection()()()
Initializes a new instance of the AccessRuleCollection class
Declaration Syntax
C#
public AccessRuleCollection()


Clone Method

Clone Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollection ► Clone()()()
Creates a new object that is a shallow copy of the current instance.
Declaration Syntax
C#
public virtual Object Clone()
Return Value
A new object that is a shallow copy of this instance.


FromString Method (serializedRules)

FromString Method (serializedRules)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollection ► FromString(String)
Parses a string into an .
Declaration Syntax
C#
public static AccessRuleCollection FromString(
    string serializedRules
)
Parameters
serializedRules (String)
The serialized rules.
Return Value


Helper Property

Helper Property
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollection ► Helper
Gets or sets the helper object used for advanced manipulation of the collection.
Declaration Syntax
C#
public virtual AccessRuleCollectionHelper Helper { get; set; }
Value
The helper.


ToString Method

ToString Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollection ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


AccessRuleCollectionHelper Class

AccessRuleCollectionHelper Class
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper
AccessRuleCollectionHelper class
Declaration Syntax
C#
public class AccessRuleCollectionHelper
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AccessRuleCollectionHelper(AccessRuleCollection) | Initializes a new instance of the AccessRuleCollectionHelper class.
 | Add(Account, AccessRight, PropagationType, SecurityPermission) | Adds the specified security restriction.
 | AddAccessPermission(Account, AccessRight, PropagationType, AccessPermission) | Adds the specified access rule.
 | AddinheritancePermission(Account, AccessRight, PropagationType, InheritancePermission) | Adds the specified access rule.
 | ContainsAccount(Account) | Determines whether one or more of the rules are assigned explicitly to the specified account.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccessPermission(Account, AccessRight, PropagationType) | Gets the type of the access control associated with a specific access right for an account.
 | GetAccounts()()() | Gets a list of all accounts that are represented in the rules collection.
 | GetExplicitAccessPermission(Account, AccessRight, PropagationType) | Gets the type of the access control explicitly associated with a specific access right for an account.
 | GetExplicitInheritanceRestriction(Account, AccessRight, PropagationType) | Gets the explicit inheritance restriction associated with a specific access right for an account.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInheritanceRestriction(Account, AccessRight, PropagationType) | Gets the inheritance restriction associated with a specific access right for an account.
 | GetMatchingRule(Account, AccessRight, PropagationType) | Gets the type of the access control associated with a specific access right for an account.
 | GetMatchingRule(Account, AccessRight, PropagationType, AccessPermission, Boolean, Boolean) | Determines whether the specified access right matches an access type for the the specified account.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasSpecializedInheritance()()() | Determines whether the rules contains one or more specialized inheritance permissions.
 | IsInheritanceAllowed(Account, AccessRight, PropagationType) | Determines whether inheritance for the specified access right is allowed for the the specified account.
 | IsMatch(Account, AccessRight, PropagationType, InheritancePermission, Boolean, Boolean) | Determines whether the specified access right matches an inheritance restriction for the the specified account.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveExactMatches(Account) | Removes all rules that explicitly applies to the specified account.
 | RemoveExactMatches(Account, AccessRight) | Removes all rules that applies to the specified account, access right and propagation type.
 | RemoveExactMatches(Account, AccessRight, PropagationType) | Removes all rules that applies to the specified account, access right and propagation type.
 | RemoveExactMatches(Account, AccessRight, PropagationType, PermissionType) | Removes all rules that applies to the specified account, access right and propagation type.
 | RemoveWildcardMatches(Account) | Removes all rules that explicitly applies to the specified account.
 | RemoveWildcardMatches(Account, AccessRight) | Removes all rules that applies to the specified account, access right and propagation type.
 | RemoveWildcardMatches(Account, AccessRight, PropagationType) | Removes all rules that applies to the specified account, access right and propagation type.
 | RemoveWildcardMatches(Account, AccessRight, PropagationType, PermissionType) | Removes all rules that applies to the specified account, access right and propagation type.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AccessRuleCollectionHelper


AccessRuleCollectionHelper Constructor (collection)

AccessRuleCollectionHelper Constructor (collection)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► AccessRuleCollectionHelper(AccessRuleCollection)
Initializes a new instance of the AccessRuleCollectionHelper class.
Declaration Syntax
C#
public AccessRuleCollectionHelper(
    AccessRuleCollection collection
)
Parameters
collection (AccessRuleCollection)


Add Method (account, right, propagation, permission)

Add Method (account, right, propagation, permission)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► Add(Account, AccessRight, PropagationType, SecurityPermission)
Adds the specified security restriction.
Declaration Syntax
C#
protected virtual void Add(
    Account account,
    AccessRight right,
    PropagationType propagation,
    SecurityPermission permission
)
Parameters
account (Account)
The account.
right (AccessRight)
The right.
propagation (PropagationType)
The propagation.
permission (SecurityPermission)
The permission type (allow/deny).
Remarks
If a conflicting rule is already in the collection, the existing rule will be updated. If not, it will be added.


AddAccessPermission Method (account, accessRight, propagationType, permission)

AddAccessPermission Method (account, accessRight, propagationType, permission)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► AddAccessPermission(Account, AccessRight, PropagationType, AccessPermission)
Adds the specified access rule.
Declaration Syntax
C#
public virtual void AddAccessPermission(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType,
    AccessPermission permission
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The right.
propagationType (PropagationType)
The propagation.
permission (AccessPermission)
The permission type (allow/deny).
Remarks
If a conflicting rule is already in the collection, the existing rule will be updated. If not, it will be added.


AddinheritancePermission Method (account, accessRight, propagationType, permission)

AddinheritancePermission Method (account, accessRight, propagationType, permission)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► AddinheritancePermission(Account, AccessRight, PropagationType, InheritancePermission)
Adds the specified access rule.
Declaration Syntax
C#
public virtual void AddinheritancePermission(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType,
    InheritancePermission permission
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The right.
propagationType (PropagationType)
The propagation.
permission (InheritancePermission)
The permission type (allow/deny).
Remarks
If a conflicting rule is already in the collection, the existing rule will be updated. If not, it will be added.


ContainsAccount Method (account)

ContainsAccount Method (account)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► ContainsAccount(Account)
Determines whether one or more of the rules are assigned explicitly to the specified account.
Declaration Syntax
C#
public virtual bool ContainsAccount(
    Account account
)
Parameters
account (Account)
The account.
Return Value
true if the specified account has a rule; otherwise, false.


GetAccessPermission Method (account, accessRight, propagationType)

GetAccessPermission Method (account, accessRight, propagationType)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► GetAccessPermission(Account, AccessRight, PropagationType)
Gets the type of the access control associated with a specific access right for an account.
Declaration Syntax
C#
public virtual AccessPermission GetAccessPermission(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
The type of propagation.
Return Value


GetAccounts Method

GetAccounts Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► GetAccounts()()()
Gets a list of all accounts that are represented in the rules collection.
Declaration Syntax
C#
public virtual AccountCollection GetAccounts()
Return Value


GetExplicitAccessPermission Method (account, accessRight, propagationType)

GetExplicitAccessPermission Method (account, accessRight, propagationType)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► GetExplicitAccessPermission(Account, AccessRight, PropagationType)
Gets the type of the access control explicitly associated with a specific access right for an account.
Declaration Syntax
C#
public virtual AccessPermission GetExplicitAccessPermission(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
The type of propagation.
Return Value


GetExplicitInheritanceRestriction Method (account, accessRight, propagationType)

GetExplicitInheritanceRestriction Method (account, accessRight, propagationType)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► GetExplicitInheritanceRestriction(Account, AccessRight, PropagationType)
Gets the explicit inheritance restriction associated with a specific access right for an account.
Declaration Syntax
C#
public virtual InheritancePermission GetExplicitInheritanceRestriction(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
Type of the propagation.
Return Value
The inheritance restriction.


GetInheritanceRestriction Method (account, accessRight, propagationType)

GetInheritanceRestriction Method (account, accessRight, propagationType)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► GetInheritanceRestriction(Account, AccessRight, PropagationType)
Gets the inheritance restriction associated with a specific access right for an account.
Declaration Syntax
C#
public virtual InheritancePermission GetInheritanceRestriction(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
The type of propagation.
Return Value


GetMatchingRule Method

GetMatchingRule Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► GetMatchingRule()()()
Members
Icon | Member | Description
 | GetMatchingRule(Account, AccessRight, PropagationType) | Gets the type of the access control associated with a specific access right for an account.
 | GetMatchingRule(Account, AccessRight, PropagationType, AccessPermission, Boolean, Boolean) | Determines whether the specified access right matches an access type for the the specified account.


GetMatchingRule Method (account, accessRight, propagationType)

GetMatchingRule Method (account, accessRight, propagationType)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► GetMatchingRule(Account, AccessRight, PropagationType)
Gets the type of the access control associated with a specific access right for an account.
Declaration Syntax
C#
public virtual AccessRule GetMatchingRule(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
The type of propagation.
Return Value


GetMatchingRule Method (account, accessRight, propagationType, permission, includeRoleMembers, includeEveryoneMembers)

GetMatchingRule Method (account, accessRight, propagationType, permission, includeRoleMembers, includeEveryoneMembers)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► GetMatchingRule(Account, AccessRight, PropagationType, AccessPermission, Boolean, Boolean)
Determines whether the specified access right matches an access type for the the specified account.
Declaration Syntax
C#
protected virtual AccessRule GetMatchingRule(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType,
    AccessPermission permission,
    bool includeRoleMembers,
    bool includeEveryoneMembers
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
The type of propagation to use when resolving.
permission (AccessPermission)
The permission type (allow/deny).
includeRoleMembers (Boolean)
If set to true and this account is a role, the method will return true if account is a member of the role.
includeEveryoneMembers (Boolean)

If set to true and this account is the global 'everyone' role, the method will always return true.

If set to true and this account is a domain specific 'everyone' role, the method will return true if account belongs to the same domain.

Return Value
true if the specified access right is denied for the the specified account; otherwise, false.


HasSpecializedInheritance Method

HasSpecializedInheritance Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► HasSpecializedInheritance()()()
Determines whether the rules contains one or more specialized inheritance permissions.
Declaration Syntax
C#
public virtual bool HasSpecializedInheritance()
Return Value
true if the collection contains specialized inheritance restrictions; otherwise, false.


IsInheritanceAllowed Method (account, accessRight, propagationType)

IsInheritanceAllowed Method (account, accessRight, propagationType)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► IsInheritanceAllowed(Account, AccessRight, PropagationType)
Determines whether inheritance for the specified access right is allowed for the the specified account.
Declaration Syntax
C#
public virtual bool IsInheritanceAllowed(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
The type of propagation to use when resolving.
Return Value
true if inheritance for the specified access right is allowed for the the specified account; otherwise, false.


IsMatch Method (account, accessRight, propagationType, permission, includeRoleMembers, includeEveryoneMembers)

IsMatch Method (account, accessRight, propagationType, permission, includeRoleMembers, includeEveryoneMembers)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► IsMatch(Account, AccessRight, PropagationType, InheritancePermission, Boolean, Boolean)
Determines whether the specified access right matches an inheritance restriction for the the specified account.
Declaration Syntax
C#
protected virtual bool IsMatch(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType,
    InheritancePermission permission,
    bool includeRoleMembers,
    bool includeEveryoneMembers
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
The type of propagation to use when resolving.
permission (InheritancePermission)
The permission type (allow/deny).
includeRoleMembers (Boolean)
If set to true and this account is a role, the method will return true if account is a member of the role.
includeEveryoneMembers (Boolean)

If set to true and this account is the global 'everyone' role, the method will always return true.

If set to true and this account is a domain specific 'everyone' role, the method will return true if account belongs to the same domain.


RemoveExactMatches Method

RemoveExactMatches Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► RemoveExactMatches()()()
Members
Icon | Member | Description
 | RemoveExactMatches(Account) | Removes all rules that explicitly applies to the specified account.
 | RemoveExactMatches(Account, AccessRight) | Removes all rules that applies to the specified account, access right and propagation type.
 | RemoveExactMatches(Account, AccessRight, PropagationType) | Removes all rules that applies to the specified account, access right and propagation type.
 | RemoveExactMatches(Account, AccessRight, PropagationType, PermissionType) | Removes all rules that applies to the specified account, access right and propagation type.


RemoveExactMatches Method (account)

RemoveExactMatches Method (account)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► RemoveExactMatches(Account)
Removes all rules that explicitly applies to the specified account.
Declaration Syntax
C#
public virtual void RemoveExactMatches(
    Account account
)
Parameters
account (Account)
The account.


RemoveExactMatches Method (account, accessRight)

RemoveExactMatches Method (account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► RemoveExactMatches(Account, AccessRight)
Removes all rules that applies to the specified account, access right and propagation type.
Declaration Syntax
C#
public virtual void RemoveExactMatches(
    Account account,
    AccessRight accessRight
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.


RemoveExactMatches Method (account, accessRight, propagationType)

RemoveExactMatches Method (account, accessRight, propagationType)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► RemoveExactMatches(Account, AccessRight, PropagationType)
Removes all rules that applies to the specified account, access right and propagation type.
Declaration Syntax
C#
public virtual void RemoveExactMatches(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
Type of the propagation.


RemoveExactMatches Method (account, accessRight, propagationType, permissionType)

RemoveExactMatches Method (account, accessRight, propagationType, permissionType)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► RemoveExactMatches(Account, AccessRight, PropagationType, PermissionType)
Removes all rules that applies to the specified account, access right and propagation type.
Declaration Syntax
C#
public virtual void RemoveExactMatches(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType,
    PermissionType permissionType
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
Type of the propagation.
permissionType (PermissionType)
The kind of restriction to remove.


RemoveWildcardMatches Method

RemoveWildcardMatches Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► RemoveWildcardMatches()()()
Members
Icon | Member | Description
 | RemoveWildcardMatches(Account) | Removes all rules that explicitly applies to the specified account.
 | RemoveWildcardMatches(Account, AccessRight) | Removes all rules that applies to the specified account, access right and propagation type.
 | RemoveWildcardMatches(Account, AccessRight, PropagationType) | Removes all rules that applies to the specified account, access right and propagation type.
 | RemoveWildcardMatches(Account, AccessRight, PropagationType, PermissionType) | Removes all rules that applies to the specified account, access right and propagation type.


RemoveWildcardMatches Method (account)

RemoveWildcardMatches Method (account)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► RemoveWildcardMatches(Account)
Removes all rules that explicitly applies to the specified account.
Declaration Syntax
C#
public virtual void RemoveWildcardMatches(
    Account account
)
Parameters
account (Account)
The account.


RemoveWildcardMatches Method (account, accessRight)

RemoveWildcardMatches Method (account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► RemoveWildcardMatches(Account, AccessRight)
Removes all rules that applies to the specified account, access right and propagation type.
Declaration Syntax
C#
public virtual void RemoveWildcardMatches(
    Account account,
    AccessRight accessRight
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.


RemoveWildcardMatches Method (account, accessRight, propagationType)

RemoveWildcardMatches Method (account, accessRight, propagationType)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► RemoveWildcardMatches(Account, AccessRight, PropagationType)
Removes all rules that applies to the specified account, access right and propagation type.
Declaration Syntax
C#
public virtual void RemoveWildcardMatches(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
Type of the propagation.


RemoveWildcardMatches Method (account, accessRight, propagationType, permissionType)

RemoveWildcardMatches Method (account, accessRight, propagationType, permissionType)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleCollectionHelper ► RemoveWildcardMatches(Account, AccessRight, PropagationType, PermissionType)
Removes all rules that applies to the specified account, access right and propagation type.
Declaration Syntax
C#
public virtual void RemoveWildcardMatches(
    Account account,
    AccessRight accessRight,
    PropagationType propagationType,
    PermissionType permissionType
)
Parameters
account (Account)
The account.
accessRight (AccessRight)
The access right.
propagationType (PropagationType)
Type of the propagation.
permissionType (PermissionType)
The kind of restriction to remove.


AccessRuleSerializer Class

AccessRuleSerializer Class
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleSerializer
AccessRuleSerializer class
Declaration Syntax
C#
public class AccessRuleSerializer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AccessRuleSerializer()()() | Initializes a new instance of the AccessRuleSerializer class
 | Create()()() | Creates an instance of .
 | Deserialize(String) | Deserializes a rules collection from a string.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Serialize(AccessRuleCollection) | Serializes an access rule collection to a string.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AccessRuleSerializer


AccessRuleSerializer Constructor

AccessRuleSerializer Constructor
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleSerializer ► AccessRuleSerializer()()()
Initializes a new instance of the AccessRuleSerializer class
Declaration Syntax
C#
public AccessRuleSerializer()


Create Method

Create Method
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleSerializer ► Create()()()
Creates an instance of .
Declaration Syntax
C#
public static AccessRuleSerializer Create()
Return Value


Deserialize Method (serializedData)

Deserialize Method (serializedData)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleSerializer ► Deserialize(String)
Deserializes a rules collection from a string.
Declaration Syntax
C#
public virtual AccessRuleCollection Deserialize(
    string serializedData
)
Parameters
serializedData (String)
The serialized data.
Return Value


Serialize Method (accessRules)

Serialize Method (accessRules)
Namespaces ► Sitecore.Security.AccessControl ► AccessRuleSerializer ► Serialize(AccessRuleCollection)
Serializes an access rule collection to a string.
Declaration Syntax
C#
public virtual string Serialize(
    AccessRuleCollection accessRules
)
Parameters
accessRules (AccessRuleCollection)
The access rules.
Return Value


AuthorizationCallContext Class

AuthorizationCallContext Class
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationCallContext
AuthorizationCallContext class
Declaration Syntax
C#
public class AuthorizationCallContext
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AuthorizationCallContext()()() | Initializes a new instance of the AuthorizationCallContext class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AuthorizationCallContext


AuthorizationCallContext Constructor

AuthorizationCallContext Constructor
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationCallContext ► AuthorizationCallContext()()()
Initializes a new instance of the AuthorizationCallContext class
Declaration Syntax
C#
public AuthorizationCallContext()


AuthorizationHelper(T) Class

AuthorizationHelper<(Of <(T>)>) Class
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationHelper<(Of <(T>)>)
AuthorizationHelper class
Declaration Syntax
C#
public abstract class AuthorizationHelper<T>
Generic Template Parameters
T
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AuthorizationHelper<(Of <(T>)>)()()() | Initializes a new instance of the AuthorizationHelper<(Of <(T>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccess(T, Account, AccessRight) | Gets the allowed access for an operation on an entity.
 | GetAccessRules(T) | Gets the access rules for an entity.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStateAccess(Database, AccessRight, Account) | Gets the access type to a specific database given the current context state.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetAccessRules(T, AccessRuleCollection) | Sets the allowed access for an operation on an entity.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | AuthorizationHelper<(Of <(T>)>)
 |  | FieldAuthorizationHelper
 |  | ItemAuthorizationHelper


AuthorizationHelper(T) Constructor

AuthorizationHelper<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationHelper<(Of <(T>)>) ► AuthorizationHelper<(Of <(T>)>)()()()
Initializes a new instance of the AuthorizationHelper<(Of <(T>)>) class
Declaration Syntax
C#
protected AuthorizationHelper()


GetAccess Method (entity, account, accessRight)

GetAccess Method (entity, account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationHelper<(Of <(T>)>) ► GetAccess(T, Account, AccessRight)
Gets the allowed access for an operation on an entity.
Declaration Syntax
C#
public abstract AccessResult GetAccess(
    T entity,
    Account account,
    AccessRight accessRight
)
Parameters
entity (T)
The entity.
account (Account)
The account.
accessRight (AccessRight)
The operation.
Return Value


GetAccessRules Method (entity)

GetAccessRules Method (entity)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationHelper<(Of <(T>)>) ► GetAccessRules(T)
Gets the access rules for an entity.
Declaration Syntax
C#
public abstract AccessRuleCollection GetAccessRules(
    T entity
)
Parameters
entity (T)
The entity.
Return Value


GetStateAccess Method (database, accessRight, account)

GetStateAccess Method (database, accessRight, account)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationHelper<(Of <(T>)>) ► GetStateAccess(Database, AccessRight, Account)
Gets the access type to a specific database given the current context state.
Declaration Syntax
C#
protected virtual AccessResult GetStateAccess(
    Database database,
    AccessRight accessRight,
    Account account
)
Parameters
database (Database)
The database.
accessRight (AccessRight)
The access right.
account (Account)
The account.
Return Value


SetAccessRules Method (entity, rules)

SetAccessRules Method (entity, rules)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationHelper<(Of <(T>)>) ► SetAccessRules(T, AccessRuleCollection)
Sets the allowed access for an operation on an entity.
Declaration Syntax
C#
public abstract void SetAccessRules(
    T entity,
    AccessRuleCollection rules
)
Parameters
entity (T)
The entity.
rules (AccessRuleCollection)
The rules.


AuthorizationManager Class

AuthorizationManager Class
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationManager
Authorization class
Declaration Syntax
C#
public static class AuthorizationManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetAccess(ISecurable, Account, AccessRight) | Determines the kind of access control that is associated with the specified entity.
 | GetAccessRules(ISecurable) | Gets the access rules for an entity.
 | IsAllowed(ISecurable, AccessRight, Account) | Determines whether a specific operation on the specified entity is allowed.
 | IsDenied(ISecurable, AccessRight, Account) | Determines whether the specified operation on an entity is denied.
 | Provider | Gets the provider.
 | Providers | Gets all providers.
 | RemoveAccessRules(ISecurable) | Removes all access rules from a specific entity.
 | SetAccessRules(ISecurable, AccessRuleCollection) | Sets the access rules for an entity.
Inheritance Hierarchy
Object
AuthorizationManager


GetAccess Method (entity, account, accessRight)

GetAccess Method (entity, account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationManager ► GetAccess(ISecurable, Account, AccessRight)
Determines the kind of access control that is associated with the specified entity.
Declaration Syntax
C#
public static AccessResult GetAccess(
    ISecurable entity,
    Account account,
    AccessRight accessRight
)
Parameters
entity (ISecurable)
The entity.
account (Account)
The account.
accessRight (AccessRight)
The access right.
Return Value


GetAccessRules Method (entity)

GetAccessRules Method (entity)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationManager ► GetAccessRules(ISecurable)
Gets the access rules for an entity.
Declaration Syntax
C#
public static AccessRuleCollection GetAccessRules(
    ISecurable entity
)
Parameters
entity (ISecurable)
The object representing the entity.
Return Value
The list of rules. This is guaranteed never to be null.


IsAllowed Method (entity, right, account)

IsAllowed Method (entity, right, account)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationManager ► IsAllowed(ISecurable, AccessRight, Account)
Determines whether a specific operation on the specified entity is allowed.
Declaration Syntax
C#
public static bool IsAllowed(
    ISecurable entity,
    AccessRight right,
    Account account
)
Parameters
entity (ISecurable)
The entity.
right (AccessRight)
The operation.
account (Account)
The account.
Return Value
true if the operation is allowed; otherwise, false.


IsDenied Method (entity, right, account)

IsDenied Method (entity, right, account)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationManager ► IsDenied(ISecurable, AccessRight, Account)
Determines whether the specified operation on an entity is denied.
Declaration Syntax
C#
public static bool IsDenied(
    ISecurable entity,
    AccessRight right,
    Account account
)
Parameters
entity (ISecurable)
The entity.
right (AccessRight)
The operation.
account (Account)
The account.
Return Value
true if the specified operation is denied; otherwise, false.


Provider Property

Provider Property
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationManager ► Provider
Gets the provider.
Declaration Syntax
C#
public static AuthorizationProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationManager ► Providers
Gets all providers.
Declaration Syntax
C#
public static AuthorizationProviderCollection Providers { get; }
Value
The providers.


RemoveAccessRules Method (entity)

RemoveAccessRules Method (entity)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationManager ► RemoveAccessRules(ISecurable)
Removes all access rules from a specific entity.
Declaration Syntax
C#
public static void RemoveAccessRules(
    ISecurable entity
)
Parameters
entity (ISecurable)
The entity.


SetAccessRules Method (entity, rules)

SetAccessRules Method (entity, rules)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationManager ► SetAccessRules(ISecurable, AccessRuleCollection)
Sets the access rules for an entity.
Declaration Syntax
C#
public static void SetAccessRules(
    ISecurable entity,
    AccessRuleCollection rules
)
Parameters
entity (ISecurable)
The object representing the entity.
rules (AccessRuleCollection)
The rules.
Return Value


AuthorizationProvider Class

AuthorizationProvider Class
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationProvider
AuthorizationProvider class
Declaration Syntax
C#
public abstract class AuthorizationProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AuthorizationProvider()()() | Initializes a new instance of the AuthorizationProvider class
 | AddAccessResultToCache(ISecurable, Account, AccessRight, AccessResult, PropagationType) | Adds an access result to the cache.
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccess(ISecurable, Account, AccessRight) | Determines whether the specified operation is allowed.
 | GetAccessCore(ISecurable, Account, AccessRight) | Performs the get access operation.
 | GetAccessResultCache(ISecurable, Account, AccessRight) | Gets the access result cache for an entity. Returns null if the caching of the specifies data is not supported.
 | GetAccessResultFromCache(ISecurable, Account, AccessRight) | Gets an access result from the cache.
 | GetAccessRules(ISecurable) | Gets the access rules.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStateAccess(ISecurable, Account, AccessRight) | Gets the access type to a specific database given the current context state.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | SetAccessRules(ISecurable, AccessRuleCollection) | Sets the access rules.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | AuthorizationProvider
 |  |  | SqlAuthorizationProvider


AuthorizationProvider Constructor

AuthorizationProvider Constructor
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationProvider ► AuthorizationProvider()()()
Initializes a new instance of the AuthorizationProvider class
Declaration Syntax
C#
protected AuthorizationProvider()


AddAccessResultToCache Method (entity, account, accessRight, accessResult, propagationType)

AddAccessResultToCache Method (entity, account, accessRight, accessResult, propagationType)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationProvider ► AddAccessResultToCache(ISecurable, Account, AccessRight, AccessResult, PropagationType)
Adds an access result to the cache.
Declaration Syntax
C#
protected virtual void AddAccessResultToCache(
    ISecurable entity,
    Account account,
    AccessRight accessRight,
    AccessResult accessResult,
    PropagationType propagationType
)
Parameters
entity (ISecurable)
The entity.
account (Account)
The account.
accessRight (AccessRight)
The access right.
accessResult (AccessResult)
The access result.
propagationType (PropagationType)
The propagation ttpe


GetAccess Method (entity, account, accessRight)

GetAccess Method (entity, account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationProvider ► GetAccess(ISecurable, Account, AccessRight)
Determines whether the specified operation is allowed.
Declaration Syntax
C#
public virtual AccessResult GetAccess(
    ISecurable entity,
    Account account,
    AccessRight accessRight
)
Parameters
entity (ISecurable)
The entity.
account (Account)
The account.
accessRight (AccessRight)
The requested operation.
Return Value
true if the specified entity is allowed; otherwise, false.


GetAccessCore Method (entity, account, accessRight)

GetAccessCore Method (entity, account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationProvider ► GetAccessCore(ISecurable, Account, AccessRight)
Performs the get access operation.
Declaration Syntax
C#
protected abstract AccessResult GetAccessCore(
    ISecurable entity,
    Account account,
    AccessRight accessRight
)
Parameters
entity (ISecurable)
The entity.
account (Account)
The account.
accessRight (AccessRight)
The access right.
Return Value


GetAccessResultCache Method (entity, account, accessRight)

GetAccessResultCache Method (entity, account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationProvider ► GetAccessResultCache(ISecurable, Account, AccessRight)
Gets the access result cache for an entity. Returns null if the caching of the specifies data is not supported.
Declaration Syntax
C#
protected virtual AccessResultCache GetAccessResultCache(
    ISecurable entity,
    Account account,
    AccessRight accessRight
)
Parameters
entity (ISecurable)
The entity.
account (Account)
The account.
accessRight (AccessRight)
The access right.
Return Value


GetAccessResultFromCache Method (entity, account, accessRight)

GetAccessResultFromCache Method (entity, account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationProvider ► GetAccessResultFromCache(ISecurable, Account, AccessRight)
Gets an access result from the cache.
Declaration Syntax
C#
protected virtual AccessResult GetAccessResultFromCache(
    ISecurable entity,
    Account account,
    AccessRight accessRight
)
Parameters
entity (ISecurable)
The entity.
account (Account)
The account.
accessRight (AccessRight)
The access right.
Return Value


GetAccessRules Method (entity)

GetAccessRules Method (entity)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationProvider ► GetAccessRules(ISecurable)
Gets the access rules.
Declaration Syntax
C#
public abstract AccessRuleCollection GetAccessRules(
    ISecurable entity
)
Parameters
entity (ISecurable)
The entity.
Return Value


GetStateAccess Method (entity, account, accessRight)

GetStateAccess Method (entity, account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationProvider ► GetStateAccess(ISecurable, Account, AccessRight)
Gets the access type to a specific database given the current context state.
Declaration Syntax
C#
protected virtual AccessResult GetStateAccess(
    ISecurable entity,
    Account account,
    AccessRight accessRight
)
Parameters
entity (ISecurable)
The entity.
account (Account)
The account.
accessRight (AccessRight)
The access right.
Return Value


SetAccessRules Method (entity, rules)

SetAccessRules Method (entity, rules)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationProvider ► SetAccessRules(ISecurable, AccessRuleCollection)
Sets the access rules.
Declaration Syntax
C#
public abstract void SetAccessRules(
    ISecurable entity,
    AccessRuleCollection rules
)
Parameters
entity (ISecurable)
The entity.
rules (AccessRuleCollection)
The rules.


AuthorizationProviderCollection Class

AuthorizationProviderCollection Class
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationProviderCollection
AuthorizationProviderCollection class
Declaration Syntax
C#
public class AuthorizationProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AuthorizationProviderCollection()()() | Initializes a new instance of the AuthorizationProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the AuthorizationProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | AuthorizationProviderCollection


AuthorizationProviderCollection Constructor

AuthorizationProviderCollection Constructor
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationProviderCollection ► AuthorizationProviderCollection()()()
Initializes a new instance of the AuthorizationProviderCollection class
Declaration Syntax
C#
public AuthorizationProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationProviderCollection ► Item[([(String])])
Gets the AuthorizationProvider with the specified name.
Declaration Syntax
C#
public virtual AuthorizationProvider this[
    string name
] { get; }
Parameters
name (String)
Value


AuthorizationSwitcher Class

AuthorizationSwitcher Class
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationSwitcher
AuthorizationSwitcher class
Declaration Syntax
C#
public class AuthorizationSwitcher : Switcher<AuthorizationProvider>
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AuthorizationSwitcher(AuthorizationProvider) | Initializes a new instance of the AuthorizationSwitcher class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <( AuthorizationProvider, AuthorizationProvider >)>)
 |  | Switcher <(Of <( AuthorizationProvider >)>)
 |  |  | AuthorizationSwitcher


AuthorizationSwitcher Constructor (provider)

AuthorizationSwitcher Constructor (provider)
Namespaces ► Sitecore.Security.AccessControl ► AuthorizationSwitcher ► AuthorizationSwitcher(AuthorizationProvider)
Initializes a new instance of the AuthorizationSwitcher class.
Declaration Syntax
C#
public AuthorizationSwitcher(
    AuthorizationProvider provider
)
Parameters
provider (AuthorizationProvider)
The provider.


ConfigAccessRightProvider Class

ConfigAccessRightProvider Class
Namespaces ► Sitecore.Security.AccessControl ► ConfigAccessRightProvider
ConfigAccessRightProvider class
Declaration Syntax
C#
public class ConfigAccessRightProvider : AccessRightProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigAccessRightProvider()()() | Initializes a new instance of the ConfigAccessRightProvider class
 | AccessRights | Gets the access rights. (Inherited from AccessRightProvider.)
 | ClearAccessRightRules()()() | Removes all access rules from the central dictionary. (Inherited from AccessRightProvider.)
 | ClearAccessRights()()() | Removes all access rights from the central dictionary. (Inherited from AccessRightProvider.)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccessRight(String) | Gets the an access right from its name. (Inherited from AccessRightProvider.)
 | GetAccessRights()()() | Gets all known access rights. (Inherited from AccessRightProvider.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | IsApplicable(AccessRight, ISecurable) | Determines whether the specified access right is applicable for the given entity. (Inherited from AccessRightProvider.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | RegisterAccessRight(String, AccessRight) | Registers an access right in the central dictionary. (Inherited from AccessRightProvider.)
 | RegisterAccessRightRule(AccessRightRule) | Registers the access right rule. (Inherited from AccessRightProvider.)
 | Rules | Gets the access right rules. (Inherited from AccessRightProvider.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnregisterAccessRight(String) | Removes an access right from the central dictionary. (Inherited from AccessRightProvider.)
 | UnregisterAccessRightRule(AccessRightRule) | Removes an access rule from the central dictionary. (Inherited from AccessRightProvider.)
 | ValidateName(String) | Validates the name.
Inheritance Hierarchy
Object
 | ProviderBase
 |  | AccessRightProvider
 |  |  | ConfigAccessRightProvider


ConfigAccessRightProvider Constructor

ConfigAccessRightProvider Constructor
Namespaces ► Sitecore.Security.AccessControl ► ConfigAccessRightProvider ► ConfigAccessRightProvider()()()
Initializes a new instance of the ConfigAccessRightProvider class
Declaration Syntax
C#
public ConfigAccessRightProvider()


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Security.AccessControl ► ConfigAccessRightProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.
ArgumentException | The name of the provider has a length of zero.


ValidateName Method (name)

ValidateName Method (name)
Namespaces ► Sitecore.Security.AccessControl ► ConfigAccessRightProvider ► ValidateName(String)
Validates the name.
Declaration Syntax
C#
protected virtual bool ValidateName(
    string name
)
Parameters
name (String)
Name of the access right.
Return Value


FieldAuthorizationHelper Class

FieldAuthorizationHelper Class
Namespaces ► Sitecore.Security.AccessControl ► FieldAuthorizationHelper
FieldAuthorizationHelper class
Declaration Syntax
C#
public class FieldAuthorizationHelper : AuthorizationHelper<Field>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FieldAuthorizationHelper()()() | Initializes a new instance of the FieldAuthorizationHelper class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccess(Field, Account, AccessRight) | Gets the allowed access for an operation on an entity. (Overrides AuthorizationHelper <(Of <( Field >)>).GetAccess(T, Account, AccessRight).)
 | GetAccessRules(Field) | Gets the access rules. (Overrides AuthorizationHelper <(Of <( Field >)>).GetAccessRules(T).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStateAccess(Field, AccessRight, Account) | Gets the state access.
 | GetStateAccess(Database, AccessRight, Account) | Gets the access type to a specific database given the current context state. (Inherited from AuthorizationHelper<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetAccessRules(Field, AccessRuleCollection) | Sets the access rules. (Overrides AuthorizationHelper <(Of <( Field >)>).SetAccessRules(T, AccessRuleCollection).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | AuthorizationHelper <(Of <( Field >)>)
 |  | FieldAuthorizationHelper


FieldAuthorizationHelper Constructor

FieldAuthorizationHelper Constructor
Namespaces ► Sitecore.Security.AccessControl ► FieldAuthorizationHelper ► FieldAuthorizationHelper()()()
Initializes a new instance of the FieldAuthorizationHelper class
Declaration Syntax
C#
public FieldAuthorizationHelper()


GetAccess Method (field, account, accessRight)

GetAccess Method (field, account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► FieldAuthorizationHelper ► GetAccess(Field, Account, AccessRight)
Gets the allowed access for an operation on an entity.
Declaration Syntax
C#
public override AccessResult GetAccess(
    Field field,
    Account account,
    AccessRight accessRight
)
Parameters
field (Field)
The field.
account (Account)
The account.
accessRight (AccessRight)
The operation.
Return Value


GetAccessRules Method (field)

GetAccessRules Method (field)
Namespaces ► Sitecore.Security.AccessControl ► FieldAuthorizationHelper ► GetAccessRules(Field)
Gets the access rules.
Declaration Syntax
C#
public override AccessRuleCollection GetAccessRules(
    Field field
)
Parameters
field (Field)
The field.
Return Value


GetStateAccess Method (field, right, account)

GetStateAccess Method (field, right, account)
Namespaces ► Sitecore.Security.AccessControl ► FieldAuthorizationHelper ► GetStateAccess(Field, AccessRight, Account)
Gets the state access.
Declaration Syntax
C#
protected virtual AccessResult GetStateAccess(
    Field field,
    AccessRight right,
    Account account
)
Parameters
field (Field)
The field.
right (AccessRight)
The operation.
account (Account)
The account.
Return Value


SetAccessRules Method (field, rules)

SetAccessRules Method (field, rules)
Namespaces ► Sitecore.Security.AccessControl ► FieldAuthorizationHelper ► SetAccessRules(Field, AccessRuleCollection)
Sets the access rules.
Declaration Syntax
C#
public override void SetAccessRules(
    Field field,
    AccessRuleCollection rules
)
Parameters
field (Field)
The field.
rules (AccessRuleCollection)
The rules.


InheritancePermission Enumeration

InheritancePermission Enumeration
Namespaces ► Sitecore.Security.AccessControl ► InheritancePermission
InheritanceRestriction class
Declaration Syntax
C#
public enum InheritancePermission
Members
Member | Description
NotSet | Unknown access.
Allow | Allow access to inherited access rules.
Deny | Deny access to inherited access rules.


ISecurable Interface

ISecurable Interface
Namespaces ► Sitecore.Security.AccessControl ► ISecurable
ISecurable
Declaration Syntax
C#
public interface ISecurable
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetUniqueId()()() | Gets a unique id.


GetUniqueId Method

GetUniqueId Method
Namespaces ► Sitecore.Security.AccessControl ► ISecurable ► GetUniqueId()()()
Gets a unique id.
Declaration Syntax
C#
string GetUniqueId()
Return Value
Remarks

The id must be unique enough to use in a global cache.

For example, an Item might implement this as Database.Name + ID.

The resulting key used by Item might therefore be typeof(Item).FullName + divider + Database.Name + ID.


ItemAccess Class

ItemAccess Class
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess
Represents access to an item.
Declaration Syntax
C#
public class ItemAccess
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemAccess(Item) | Initializes a new instance of the ItemAccess class.
 | CanAdd(BranchId) | Determines whether this instance can add the specified branch.
 | CanAdd(TemplateID) | Determines whether this instance can add the specified template.
 | CanAdmin()()() | Determines whether this item can admin.
 | CanCopyTo(Item) | Determines whether this item can copy to the specified destination.
 | CanCreate()()() | Determines whether this item can create children.
 | CanDelete()()() | Determines whether this item can be deleted.
 | CanDuplicate()()() | Determines whether this item can be duplicated.
 | CanMoveTo(Item) | Determines whether this item can be moved to the specified destination.
 | CanRead()()() | Determines whether this item can be read.
 | CanReadLanguage()()() | Determines whether this item can be read in the current language.
 | CanRename()()() | Determines whether this item can be renamed.
 | CanWrite()()() | Determines whether this item can written.
 | CanWriteLanguage()()() | Determines whether this instance can be written in the current language.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemAccess


ItemAccess Constructor (item)

ItemAccess Constructor (item)
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► ItemAccess(Item)
Initializes a new instance of the ItemAccess class.
Declaration Syntax
C#
public ItemAccess(
    Item item
)
Parameters
item (Item)
The item.


CanAdd Method

CanAdd Method
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► CanAdd()()()
Members
Icon | Member | Description
 | CanAdd(BranchId) | Determines whether this instance can add the specified branch.
 | CanAdd(TemplateID) | Determines whether this instance can add the specified template.


CanAdd Method (branchId)

CanAdd Method (branchId)
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► CanAdd(BranchId)
Determines whether this instance can add the specified branch.
Declaration Syntax
C#
public virtual bool CanAdd(
    BranchId branchId
)
Parameters
branchId (BranchId)
The branch id.
Return Value
true if this instance can add the specified branch; otherwise, false.


CanAdd Method (templateID)

CanAdd Method (templateID)
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► CanAdd(TemplateID)
Determines whether this instance can add the specified template.
Declaration Syntax
C#
public virtual bool CanAdd(
    TemplateID templateID
)
Parameters
templateID (TemplateID)
The template ID.
Return Value
true if this instance can add the specified template; otherwise, false.


CanAdmin Method

CanAdmin Method
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► CanAdmin()()()
Determines whether this item can admin.
Declaration Syntax
C#
public virtual bool CanAdmin()
Return Value
true if this item can admin; otherwise, false.


CanCopyTo Method (destination)

CanCopyTo Method (destination)
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► CanCopyTo(Item)
Determines whether this item can copy to the specified destination.
Declaration Syntax
C#
public virtual bool CanCopyTo(
    Item destination
)
Parameters
destination (Item)
The destination.
Return Value
true if this item can copy to the specified destination; otherwise, false.


CanCreate Method

CanCreate Method
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► CanCreate()()()
Determines whether this item can create children.
Declaration Syntax
C#
public virtual bool CanCreate()
Return Value
true if this item can create childre; otherwise, false.


CanDelete Method

CanDelete Method
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► CanDelete()()()
Determines whether this item can be deleted.
Declaration Syntax
C#
public virtual bool CanDelete()
Return Value
true if this item can be deleted; otherwise, false.


CanDuplicate Method

CanDuplicate Method
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► CanDuplicate()()()
Determines whether this item can be duplicated.
Declaration Syntax
C#
public virtual bool CanDuplicate()
Return Value
true if this item can be duplicated; otherwise, false.


CanMoveTo Method (destination)

CanMoveTo Method (destination)
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► CanMoveTo(Item)
Determines whether this item can be moved to the specified destination.
Declaration Syntax
C#
public virtual bool CanMoveTo(
    Item destination
)
Parameters
destination (Item)
The destination.
Return Value
true if this item can be moved to the specified destination; otherwise, false.


CanRead Method

CanRead Method
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► CanRead()()()
Determines whether this item can be read.
Declaration Syntax
C#
public virtual bool CanRead()
Return Value
true if this item can be read; otherwise, false.


CanReadLanguage Method

CanReadLanguage Method
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► CanReadLanguage()()()
Determines whether this item can be read in the current language.
Declaration Syntax
C#
public virtual bool CanReadLanguage()
Return Value
true if this item can be read in the current language; otherwise, false.


CanRename Method

CanRename Method
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► CanRename()()()
Determines whether this item can be renamed.
Declaration Syntax
C#
public virtual bool CanRename()
Return Value
true if this item can be renamed; otherwise, false.


CanWrite Method

CanWrite Method
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► CanWrite()()()
Determines whether this item can written.
Declaration Syntax
C#
public virtual bool CanWrite()
Return Value
true if this item can written; otherwise, false.


CanWriteLanguage Method

CanWriteLanguage Method
Namespaces ► Sitecore.Security.AccessControl ► ItemAccess ► CanWriteLanguage()()()
Determines whether this instance can be written in the current language.
Declaration Syntax
C#
public virtual bool CanWriteLanguage()
Return Value
true if this instance can written in the current language; otherwise, false.


ItemAuthorizationHelper Class

ItemAuthorizationHelper Class
Namespaces ► Sitecore.Security.AccessControl ► ItemAuthorizationHelper
ItemAuthorizationHelper class
Declaration Syntax
C#
public class ItemAuthorizationHelper : AuthorizationHelper<Item>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemAuthorizationHelper()()() | Initializes a new instance of the ItemAuthorizationHelper class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccess(Item, Account, AccessRight) | Gets the allowed access for an operation on an entity. (Overrides AuthorizationHelper <(Of <( Item >)>).GetAccess(T, Account, AccessRight).)
 | GetAccessRules(Item) | Gets the access rules. (Overrides AuthorizationHelper <(Of <( Item >)>).GetAccessRules(T).)
 | GetAncestorAccess(Item, Account, AccessRight, PropagationType) | Gets the access control type for an item from its ancestors.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemAccess(Item, Account, AccessRight, PropagationType) | Determines whether the specified access right is allowed given to the security rights assigned to the item.
 | GetStateAccess(Item, Account, AccessRight) | Gets the state access.
 | GetStateAccess(Database, AccessRight, Account) | Gets the access type to a specific database given the current context state. (Inherited from AuthorizationHelper<(Of <(T>)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWorkflowAccess(Item, AccessRight, Account) | Determines whether the specified operation is allowed given the items current workflow state.
 | IsPropagationTypeSupportedForResolvingAccess(PropagationType) | Determines whether the specified propagation type is supported for resolving access.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetAccessRules(Item, AccessRuleCollection) | Sets the access rules. (Overrides AuthorizationHelper <(Of <( Item >)>).SetAccessRules(T, AccessRuleCollection).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | AuthorizationHelper <(Of <( Item >)>)
 |  | ItemAuthorizationHelper


ItemAuthorizationHelper Constructor

ItemAuthorizationHelper Constructor
Namespaces ► Sitecore.Security.AccessControl ► ItemAuthorizationHelper ► ItemAuthorizationHelper()()()
Initializes a new instance of the ItemAuthorizationHelper class
Declaration Syntax
C#
public ItemAuthorizationHelper()


GetAccess Method (item, account, accessRight)

GetAccess Method (item, account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► ItemAuthorizationHelper ► GetAccess(Item, Account, AccessRight)
Gets the allowed access for an operation on an entity.
Declaration Syntax
C#
public override AccessResult GetAccess(
    Item item,
    Account account,
    AccessRight accessRight
)
Parameters
item (Item)
The item.
account (Account)
The account.
accessRight (AccessRight)
The operation.
Return Value


GetAccessRules Method (item)

GetAccessRules Method (item)
Namespaces ► Sitecore.Security.AccessControl ► ItemAuthorizationHelper ► GetAccessRules(Item)
Gets the access rules.
Declaration Syntax
C#
public override AccessRuleCollection GetAccessRules(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetAncestorAccess Method (item, account, accessRight, propagationType)

GetAncestorAccess Method (item, account, accessRight, propagationType)
Namespaces ► Sitecore.Security.AccessControl ► ItemAuthorizationHelper ► GetAncestorAccess(Item, Account, AccessRight, PropagationType)
Gets the access control type for an item from its ancestors.
Declaration Syntax
C#
protected virtual AccessResult GetAncestorAccess(
    Item item,
    Account account,
    AccessRight accessRight,
    PropagationType propagationType
)
Parameters
item (Item)
The item.
account (Account)
The account.
accessRight (AccessRight)
The desired access right.
propagationType (PropagationType)
Type of propagation.
Return Value


GetItemAccess Method (item, account, accessRight, propagationType)

GetItemAccess Method (item, account, accessRight, propagationType)
Namespaces ► Sitecore.Security.AccessControl ► ItemAuthorizationHelper ► GetItemAccess(Item, Account, AccessRight, PropagationType)
Determines whether the specified access right is allowed given to the security rights assigned to the item.
Declaration Syntax
C#
protected virtual AccessResult GetItemAccess(
    Item item,
    Account account,
    AccessRight accessRight,
    PropagationType propagationType
)
Parameters
item (Item)
The item.
account (Account)
The account.
accessRight (AccessRight)
The desired access right.
propagationType (PropagationType)
The type of propagation.
Return Value


GetStateAccess Method (item, account, right)

GetStateAccess Method (item, account, right)
Namespaces ► Sitecore.Security.AccessControl ► ItemAuthorizationHelper ► GetStateAccess(Item, Account, AccessRight)
Gets the state access.
Declaration Syntax
C#
protected virtual AccessResult GetStateAccess(
    Item item,
    Account account,
    AccessRight right
)
Parameters
item (Item)
The item.
account (Account)
The account.
right (AccessRight)
The operation.
Return Value


GetWorkflowAccess Method (item, accessRight, account)

GetWorkflowAccess Method (item, accessRight, account)
Namespaces ► Sitecore.Security.AccessControl ► ItemAuthorizationHelper ► GetWorkflowAccess(Item, AccessRight, Account)
Determines whether the specified operation is allowed given the items current workflow state.
Declaration Syntax
C#
protected virtual AccessResult GetWorkflowAccess(
    Item item,
    AccessRight accessRight,
    Account account
)
Parameters
item (Item)
The item.
accessRight (AccessRight)
The operation.
account (Account)
The account.
Return Value


IsPropagationTypeSupportedForResolvingAccess Method (propagationType)

IsPropagationTypeSupportedForResolvingAccess Method (propagationType)
Namespaces ► Sitecore.Security.AccessControl ► ItemAuthorizationHelper ► IsPropagationTypeSupportedForResolvingAccess(PropagationType)
Determines whether the specified propagation type is supported for resolving access.
Declaration Syntax
C#
protected virtual bool IsPropagationTypeSupportedForResolvingAccess(
    PropagationType propagationType
)
Parameters
propagationType (PropagationType)
Type of the propagation.
Return Value
true if the specified propagation type is supported for resolving access; otherwise, false.


SetAccessRules Method (item, rules)

SetAccessRules Method (item, rules)
Namespaces ► Sitecore.Security.AccessControl ► ItemAuthorizationHelper ► SetAccessRules(Item, AccessRuleCollection)
Sets the access rules.
Declaration Syntax
C#
public override void SetAccessRules(
    Item item,
    AccessRuleCollection rules
)
Parameters
item (Item)
The item.
rules (AccessRuleCollection)
The rules.


ItemSecurity Class

ItemSecurity Class
Namespaces ► Sitecore.Security.AccessControl ► ItemSecurity
ItemSecurity class
Declaration Syntax
C#
public class ItemSecurity
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemSecurity(Item) | Initializes a new instance of the ItemSecurity class.
 | CanAdmin(Account) | Determines whether the specified account has admin access to the item.
 | CanCreate(Account) | Determines whether the specified account has create access to the item.
 | CanDelete(Account) | Determines whether the specified account has delete access to the item.
 | CanRead(Account) | Determines whether the specified account has read access to the item.
 | CanRename(Account) | Determines whether the specified account has rename access to the item.
 | CanWrite(Account) | Determines whether the specified account has write access to the item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromItem(Item) | Creates an instance from an item.
 | GetAccessRules()()() | Gets the access rules associated with the item.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOwner()()() | Gets the name of item owner.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetAccessRules(AccessRuleCollection) | Sets the access rules for the item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemSecurity


ItemSecurity Constructor (item)

ItemSecurity Constructor (item)
Namespaces ► Sitecore.Security.AccessControl ► ItemSecurity ► ItemSecurity(Item)
Initializes a new instance of the ItemSecurity class.
Declaration Syntax
C#
protected ItemSecurity(
    Item item
)
Parameters
item (Item)


CanAdmin Method (account)

CanAdmin Method (account)
Namespaces ► Sitecore.Security.AccessControl ► ItemSecurity ► CanAdmin(Account)
Determines whether the specified account has admin access to the item.
Declaration Syntax
C#
public virtual bool CanAdmin(
    Account account
)
Parameters
account (Account)
The account.
Return Value
true if the account can admin the item; otherwise, false.


CanCreate Method (account)

CanCreate Method (account)
Namespaces ► Sitecore.Security.AccessControl ► ItemSecurity ► CanCreate(Account)
Determines whether the specified account has create access to the item.
Declaration Syntax
C#
public virtual bool CanCreate(
    Account account
)
Parameters
account (Account)
The account.
Return Value
true if the account can create the item; otherwise, false.


CanDelete Method (account)

CanDelete Method (account)
Namespaces ► Sitecore.Security.AccessControl ► ItemSecurity ► CanDelete(Account)
Determines whether the specified account has delete access to the item.
Declaration Syntax
C#
public virtual bool CanDelete(
    Account account
)
Parameters
account (Account)
The account.
Return Value
true if the account can delete the item; otherwise, false.


CanRead Method (account)

CanRead Method (account)
Namespaces ► Sitecore.Security.AccessControl ► ItemSecurity ► CanRead(Account)
Determines whether the specified account has read access to the item.
Declaration Syntax
C#
public virtual bool CanRead(
    Account account
)
Parameters
account (Account)
The account.
Return Value
true if the account can read the item; otherwise, false.


CanRename Method (account)

CanRename Method (account)
Namespaces ► Sitecore.Security.AccessControl ► ItemSecurity ► CanRename(Account)
Determines whether the specified account has rename access to the item.
Declaration Syntax
C#
public virtual bool CanRename(
    Account account
)
Parameters
account (Account)
The account.
Return Value
true if the account can rename the item; otherwise, false.


CanWrite Method (account)

CanWrite Method (account)
Namespaces ► Sitecore.Security.AccessControl ► ItemSecurity ► CanWrite(Account)
Determines whether the specified account has write access to the item.
Declaration Syntax
C#
public virtual bool CanWrite(
    Account account
)
Parameters
account (Account)
The account.
Return Value
true if the account can write the item; otherwise, false.


FromItem Method (item)

FromItem Method (item)
Namespaces ► Sitecore.Security.AccessControl ► ItemSecurity ► FromItem(Item)
Creates an instance from an item.
Declaration Syntax
C#
public static ItemSecurity FromItem(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetAccessRules Method

GetAccessRules Method
Namespaces ► Sitecore.Security.AccessControl ► ItemSecurity ► GetAccessRules()()()
Gets the access rules associated with the item.
Declaration Syntax
C#
public virtual AccessRuleCollection GetAccessRules()
Return Value


GetOwner Method

GetOwner Method
Namespaces ► Sitecore.Security.AccessControl ► ItemSecurity ► GetOwner()()()
Gets the name of item owner.
Declaration Syntax
C#
public virtual string GetOwner()
Return Value
The name of item owner.


SetAccessRules Method (accessRules)

SetAccessRules Method (accessRules)
Namespaces ► Sitecore.Security.AccessControl ► ItemSecurity ► SetAccessRules(AccessRuleCollection)
Sets the access rules for the item.
Declaration Syntax
C#
public virtual void SetAccessRules(
    AccessRuleCollection accessRules
)
Parameters
accessRules (AccessRuleCollection)
The access rules.


PermissionType Enumeration

PermissionType Enumeration
Namespaces ► Sitecore.Security.AccessControl ► PermissionType
RestrictionKind enum
Declaration Syntax
C#
public enum PermissionType
Members
Member | Description
None | No kind.
Access | Access restrictions
Inheritance | Inheritance restrictions
Any | Any kind.


PropagationType Enumeration

PropagationType Enumeration
Namespaces ► Sitecore.Security.AccessControl ► PropagationType
PropagationType enum
Declaration Syntax
C#
public enum PropagationType
Members
Member | Description
Unknown |
Descendants |
Entity |
Any |


SecurityPermission Enumeration

SecurityPermission Enumeration
Namespaces ► Sitecore.Security.AccessControl ► SecurityPermission
SecurityRestriction class
Declaration Syntax
C#
public enum SecurityPermission
Members
Member | Description
NotSet | No restriction has been set.
AllowAccess | Allow access.
DenyAccess | Deny access.
AllowInheritance | Allow access to inherited access rules.
DenyInheritance | Deny access to inherited access rules.


SqlAuthorizationProvider Class

SqlAuthorizationProvider Class
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider
SqlAuthorizationProvider class
Declaration Syntax
C#
public class SqlAuthorizationProvider : AuthorizationProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlAuthorizationProvider(SqlDataApi) | Initializes a new instance of the SqlAuthorizationProvider class.
 | AddAccessResultToCache(ISecurable, Account, AccessRight, AccessResult, PropagationType) | Adds an access result to the cache. (Inherited from AuthorizationProvider.)
 | Api | Gets the API.
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | EmbedAclInItems | Gets a value indicating whether to embed access control lists in items (using a field).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldHelper | Gets or sets the field authorization helper.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccess(ISecurable, Account, AccessRight) | Determines whether the specified operation is allowed. (Inherited from AuthorizationProvider.)
 | GetAccessCore(ISecurable, Account, AccessRight) | Performs the get access operation. (Overrides AuthorizationProvider.GetAccessCore(ISecurable, Account, AccessRight).)
 | GetAccessResultCache(ISecurable, Account, AccessRight) | Gets the access result cache for an entity. Returns null if the caching of the specifies data is not supported. (Inherited from AuthorizationProvider.)
 | GetAccessResultFromCache(ISecurable, Account, AccessRight) | Gets an access result from the cache. (Inherited from AuthorizationProvider.)
 | GetAccessRules(ISecurable) | Gets the access rules. (Overrides AuthorizationProvider.GetAccessRules(ISecurable).)
 | GetEntityAccess(ISecurable, AccessRight, Account) | Reads the access.
 | GetFieldAccess(Field, Account, AccessRight) | Gets access for a field.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemAccess(Item, Account, AccessRight) | Gets access for an item.
 | GetSpecialAccess(ISecurable, Account, AccessRight) | Gets special access.
 | GetStateAccess(ISecurable, Account, AccessRight) | Gets the access type to a specific database given the current context state. (Inherited from AuthorizationProvider.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | ItemHelper | Gets or sets the item authorization helper.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ReadAccessRules(ISecurable) | Gets the access rules.
 | SetAccessRules(ISecurable, AccessRuleCollection) | Sets the access rules. (Overrides AuthorizationProvider.SetAccessRules(ISecurable, AccessRuleCollection).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteAccessRules(ISecurable, AccessRuleCollection) | Sets the access rules.
Inheritance Hierarchy
Object
 | ProviderBase
 |  | AuthorizationProvider
 |  |  | SqlAuthorizationProvider
 |  |  |  | SqlServerAuthorizationProvider


SqlAuthorizationProvider Constructor (api)

SqlAuthorizationProvider Constructor (api)
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► SqlAuthorizationProvider(SqlDataApi)
Initializes a new instance of the SqlAuthorizationProvider class.
Declaration Syntax
C#
public SqlAuthorizationProvider(
    SqlDataApi api
)
Parameters
api (SqlDataApi)
The API.


Api Property

Api Property
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► Api
Gets the API.
Declaration Syntax
C#
protected virtual SqlDataApi Api { get; }
Value
The API.


EmbedAclInItems Property

EmbedAclInItems Property
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► EmbedAclInItems
Gets a value indicating whether to embed access control lists in items (using a field).
Declaration Syntax
C#
protected virtual bool EmbedAclInItems { get; }
Value
true if ACL should be embedded in items; otherwise, false.


FieldHelper Property

FieldHelper Property
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► FieldHelper
Gets or sets the field authorization helper.
Declaration Syntax
C#
protected virtual FieldAuthorizationHelper FieldHelper { get; set; }
Value
The field authorization helper.


GetAccessCore Method (entity, account, accessRight)

GetAccessCore Method (entity, account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► GetAccessCore(ISecurable, Account, AccessRight)
Performs the get access operation.
Declaration Syntax
C#
protected override AccessResult GetAccessCore(
    ISecurable entity,
    Account account,
    AccessRight accessRight
)
Parameters
entity (ISecurable)
The entity.
account (Account)
The account.
accessRight (AccessRight)
The access right.
Return Value


GetAccessRules Method (entity)

GetAccessRules Method (entity)
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► GetAccessRules(ISecurable)
Gets the access rules.
Declaration Syntax
C#
public override AccessRuleCollection GetAccessRules(
    ISecurable entity
)
Parameters
entity (ISecurable)
The entity.
Return Value


GetEntityAccess Method (entity, right, account)

GetEntityAccess Method (entity, right, account)
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► GetEntityAccess(ISecurable, AccessRight, Account)
Reads the access.
Declaration Syntax
C#
protected virtual AccessResult GetEntityAccess(
    ISecurable entity,
    AccessRight right,
    Account account
)
Parameters
entity (ISecurable)
The entity.
right (AccessRight)
The operation.
account (Account)
The account.
Return Value


GetFieldAccess Method (field, account, accessRight)

GetFieldAccess Method (field, account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► GetFieldAccess(Field, Account, AccessRight)
Gets access for a field.
Declaration Syntax
C#
protected virtual AccessResult GetFieldAccess(
    Field field,
    Account account,
    AccessRight accessRight
)
Parameters
field (Field)
The field.
account (Account)
The account.
accessRight (AccessRight)
The access right.
Return Value


GetItemAccess Method (item, account, accessRight)

GetItemAccess Method (item, account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► GetItemAccess(Item, Account, AccessRight)
Gets access for an item.
Declaration Syntax
C#
protected virtual AccessResult GetItemAccess(
    Item item,
    Account account,
    AccessRight accessRight
)
Parameters
item (Item)
The item.
account (Account)
The account.
accessRight (AccessRight)
The access right.
Return Value


GetSpecialAccess Method (entity, account, accessRight)

GetSpecialAccess Method (entity, account, accessRight)
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► GetSpecialAccess(ISecurable, Account, AccessRight)
Gets special access.
Declaration Syntax
C#
protected virtual AccessResult GetSpecialAccess(
    ISecurable entity,
    Account account,
    AccessRight accessRight
)
Parameters
entity (ISecurable)
The entity.
account (Account)
The account.
accessRight (AccessRight)
The access right.
Return Value


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.
ArgumentException | The name of the provider has a length of zero.


ItemHelper Property

ItemHelper Property
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► ItemHelper
Gets or sets the item authorization helper.
Declaration Syntax
C#
protected virtual ItemAuthorizationHelper ItemHelper { get; set; }
Value
The item authorization helper.


ReadAccessRules Method (entity)

ReadAccessRules Method (entity)
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► ReadAccessRules(ISecurable)
Gets the access rules.
Declaration Syntax
C#
protected virtual AccessRuleCollection ReadAccessRules(
    ISecurable entity
)
Parameters
entity (ISecurable)
The entity.
Return Value


SetAccessRules Method (entity, rules)

SetAccessRules Method (entity, rules)
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► SetAccessRules(ISecurable, AccessRuleCollection)
Sets the access rules.
Declaration Syntax
C#
public override void SetAccessRules(
    ISecurable entity,
    AccessRuleCollection rules
)
Parameters
entity (ISecurable)
The entity.
rules (AccessRuleCollection)
The rules.


WriteAccessRules Method (entity, rules)

WriteAccessRules Method (entity, rules)
Namespaces ► Sitecore.Security.AccessControl ► SqlAuthorizationProvider ► WriteAccessRules(ISecurable, AccessRuleCollection)
Sets the access rules.
Declaration Syntax
C#
protected virtual void WriteAccessRules(
    ISecurable entity,
    AccessRuleCollection rules
)
Parameters
entity (ISecurable)
The entity.
rules (AccessRuleCollection)
The rules.


SqlServerAuthorizationProvider Class

SqlServerAuthorizationProvider Class
Namespaces ► Sitecore.Security.AccessControl ► SqlServerAuthorizationProvider
SqlServerAuthorizationProvider class
Declaration Syntax
C#
public class SqlServerAuthorizationProvider : SqlAuthorizationProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerAuthorizationProvider()()() | Initializes a new instance of the SqlServerAuthorizationProvider class.
 | AddAccessResultToCache(ISecurable, Account, AccessRight, AccessResult, PropagationType) | Adds an access result to the cache. (Inherited from AuthorizationProvider.)
 | Api | Gets the API. (Inherited from SqlAuthorizationProvider.)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | EmbedAclInItems | Gets a value indicating whether to embed access control lists in items (using a field). (Inherited from SqlAuthorizationProvider.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldHelper | Gets or sets the field authorization helper. (Inherited from SqlAuthorizationProvider.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccess(ISecurable, Account, AccessRight) | Determines whether the specified operation is allowed. (Inherited from AuthorizationProvider.)
 | GetAccessCore(ISecurable, Account, AccessRight) | Performs the get access operation. (Inherited from SqlAuthorizationProvider.)
 | GetAccessResultCache(ISecurable, Account, AccessRight) | Gets the access result cache for an entity. Returns null if the caching of the specifies data is not supported. (Inherited from AuthorizationProvider.)
 | GetAccessResultFromCache(ISecurable, Account, AccessRight) | Gets an access result from the cache. (Inherited from AuthorizationProvider.)
 | GetAccessRules(ISecurable) | Gets the access rules. (Inherited from SqlAuthorizationProvider.)
 | GetEntityAccess(ISecurable, AccessRight, Account) | Reads the access. (Inherited from SqlAuthorizationProvider.)
 | GetFieldAccess(Field, Account, AccessRight) | Gets access for a field. (Inherited from SqlAuthorizationProvider.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemAccess(Item, Account, AccessRight) | Gets access for an item. (Inherited from SqlAuthorizationProvider.)
 | GetSpecialAccess(ISecurable, Account, AccessRight) | Gets special access. (Inherited from SqlAuthorizationProvider.)
 | GetStateAccess(ISecurable, Account, AccessRight) | Gets the access type to a specific database given the current context state. (Inherited from AuthorizationProvider.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides SqlAuthorizationProvider.Initialize(String, NameValueCollection).)
 | ItemHelper | Gets or sets the item authorization helper. (Inherited from SqlAuthorizationProvider.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ReadAccessRules(ISecurable) | Gets the access rules. (Inherited from SqlAuthorizationProvider.)
 | SetAccessRules(ISecurable, AccessRuleCollection) | Sets the access rules. (Inherited from SqlAuthorizationProvider.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteAccessRules(ISecurable, AccessRuleCollection) | Sets the access rules. (Inherited from SqlAuthorizationProvider.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | AuthorizationProvider
 |  |  | SqlAuthorizationProvider
 |  |  |  | SqlServerAuthorizationProvider


SqlServerAuthorizationProvider Constructor

SqlServerAuthorizationProvider Constructor
Namespaces ► Sitecore.Security.AccessControl ► SqlServerAuthorizationProvider ► SqlServerAuthorizationProvider()()()
Initializes a new instance of the SqlServerAuthorizationProvider class.
Declaration Syntax
C#
public SqlServerAuthorizationProvider()


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Security.AccessControl ► SqlServerAuthorizationProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.
ArgumentException | The name of the provider has a length of zero.


WellknownRights Class

WellknownRights Class
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights
Rights class
Declaration Syntax
C#
public class WellknownRights
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WellknownRights()()() | Initializes a new instance of the WellknownRights class
 | Any | The string used to represent the 'any' right.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldRead | The string used to represent the 'read' right for fields.
 | FieldWrite | The string used to represent the 'write' right for fields.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InsertShow | The string used to represent the 'show in insert' right.
 | ItemAdmin | The string used to represent the 'admin' right for an item.
 | ItemCreate | The string used to represent the 'create' right for an item.
 | ItemDelete | The string used to represent the 'delete' right for an item.
 | ItemRead | The string used to represent the 'read' right for an item.
 | ItemRename | The string used to represent the 'rename' right for an item.
 | ItemWrite | The string used to represent the 'write' right for an item.
 | LanguageRead | The string used to represent the 'read' right for languages.
 | LanguageWrite | The string used to represent the 'write' right for languages.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SiteEnter | The string used to represent the 'enter' right for sites.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WorkflowCommandExecute | The string used to represent the 'read' right for workflow states.
 | WorkflowStateDelete | The string used to represent the 'delete' right for workflow states.
 | WorkflowStateWrite | The string used to represent the 'write' right for workflow states.
Inheritance Hierarchy
Object
WellknownRights


WellknownRights Constructor

WellknownRights Constructor
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► WellknownRights()()()
Initializes a new instance of the WellknownRights class
Declaration Syntax
C#
public WellknownRights()


Any Field

Any Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► Any
The string used to represent the 'any' right.
Declaration Syntax
C#
public const string Any


FieldRead Field

FieldRead Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► FieldRead
The string used to represent the 'read' right for fields.
Declaration Syntax
C#
public const string FieldRead


FieldWrite Field

FieldWrite Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► FieldWrite
The string used to represent the 'write' right for fields.
Declaration Syntax
C#
public const string FieldWrite


InsertShow Field

InsertShow Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► InsertShow
The string used to represent the 'show in insert' right.
Declaration Syntax
C#
public const string InsertShow


ItemAdmin Field

ItemAdmin Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► ItemAdmin
The string used to represent the 'admin' right for an item.
Declaration Syntax
C#
public const string ItemAdmin


ItemCreate Field

ItemCreate Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► ItemCreate
The string used to represent the 'create' right for an item.
Declaration Syntax
C#
public const string ItemCreate


ItemDelete Field

ItemDelete Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► ItemDelete
The string used to represent the 'delete' right for an item.
Declaration Syntax
C#
public const string ItemDelete


ItemRead Field

ItemRead Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► ItemRead
The string used to represent the 'read' right for an item.
Declaration Syntax
C#
public const string ItemRead


ItemRename Field

ItemRename Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► ItemRename
The string used to represent the 'rename' right for an item.
Declaration Syntax
C#
public const string ItemRename


ItemWrite Field

ItemWrite Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► ItemWrite
The string used to represent the 'write' right for an item.
Declaration Syntax
C#
public const string ItemWrite


LanguageRead Field

LanguageRead Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► LanguageRead
The string used to represent the 'read' right for languages.
Declaration Syntax
C#
public const string LanguageRead


LanguageWrite Field

LanguageWrite Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► LanguageWrite
The string used to represent the 'write' right for languages.
Declaration Syntax
C#
public const string LanguageWrite


SiteEnter Field

SiteEnter Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► SiteEnter
The string used to represent the 'enter' right for sites.
Declaration Syntax
C#
public const string SiteEnter


WorkflowCommandExecute Field

WorkflowCommandExecute Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► WorkflowCommandExecute
The string used to represent the 'read' right for workflow states.
Declaration Syntax
C#
public const string WorkflowCommandExecute


WorkflowStateDelete Field

WorkflowStateDelete Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► WorkflowStateDelete
The string used to represent the 'delete' right for workflow states.
Declaration Syntax
C#
public const string WorkflowStateDelete


WorkflowStateWrite Field

WorkflowStateWrite Field
Namespaces ► Sitecore.Security.AccessControl ► WellknownRights ► WorkflowStateWrite
The string used to represent the 'write' right for workflow states.
Declaration Syntax
C#
public const string WorkflowStateWrite


Sitecore.Security.Accounts Namespace

Sitecore.Security.Accounts Namespace
Namespaces ► Sitecore.Security.Accounts
Declaration Syntax
C#
namespace Sitecore.Security.Accounts
Types
All Types Classes Enumerations
Icon | Type | Description
 | Account | Account class
 | AccountCollection | AccountCollection class
 | AccountList | AccountList class
 | AccountString | Account information, convenience wrapper around full account names. Ex: sitecore\Guest^User
 | AccountType | AccountType enumeration
 | MembershipUserWrapper | MetaMembershipUser class
 | ProfileInfoWrapper | MetaProfileInfo class
 | Role | Role class
 | RoleList | RoleList class
 | RolesInRolesManager | RolesInRolesManager class
 | RolesInRolesProvider | RolesInRolesProvider class
 | RolesInRolesProviderCollection | RolesInRolesProviderCollection class
 | SqlRolesInRolesProvider | SqlRolesInRolesProvider class
 | SqlServerRolesInRolesProvider | SqlServerRolesInRolesProvider class
 | User | User class
 | UserDelegation | UserDelegation class
 | UserList | UserList class
 | UserManager | UserManager
 | UserProvider | UserProvider
 | UserProviderCollection | UserProviderCollection class
 | UserRoles | UserRoles class
 | UserSwitcher | UserSwitcher class


Account Class

Account Class
Namespaces ► Sitecore.Security.Accounts ► Account
Account class
Declaration Syntax
C#
public abstract class Account
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Account(String, AccountType) | Initializes a new instance of the Account class.
 | AccountType | Gets the type of the account.
 | Description | Gets the description.
 | DisplayName | Gets the display name.
 | Domain | Gets the domain owning the account.
 | Equality(Account, Account) | Implements the == operator.
 | Equals(Object) | Determines whether the specified Object is equal to the current Account. (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromName(String, AccountType) | Froms the name.
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Inequality(Account, Account) | Implements the != operator.
 | LocalName | Gets the name of the local.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the account.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Account
 |  | Role
 |  | User


Account Constructor (name, accountType)

Account Constructor (name, accountType)
Namespaces ► Sitecore.Security.Accounts ► Account ► Account(String, AccountType)
Initializes a new instance of the Account class.
Declaration Syntax
C#
protected Account(
    string name,
    AccountType accountType
)
Parameters
name (String)
The name.
accountType (AccountType)
Type of the account.


AccountType Property

AccountType Property
Namespaces ► Sitecore.Security.Accounts ► Account ► AccountType
Gets the type of the account.
Declaration Syntax
C#
public virtual AccountType AccountType { get; }
Value
The type of the account.


Description Property

Description Property
Namespaces ► Sitecore.Security.Accounts ► Account ► Description
Gets the description.
Declaration Syntax
C#
public virtual string Description { get; }
Value
The description.


DisplayName Property

DisplayName Property
Namespaces ► Sitecore.Security.Accounts ► Account ► DisplayName
Gets the display name.
Declaration Syntax
C#
public virtual string DisplayName { get; }
Value
The display name.


Domain Property

Domain Property
Namespaces ► Sitecore.Security.Accounts ► Account ► Domain
Gets the domain owning the account.
Declaration Syntax
C#
public abstract Domain Domain { get; }
Value
The domain (or null).


Equality Operator

Equality Operator
Namespaces ► Sitecore.Security.Accounts ► Account ► Equality(Account, Account)
Implements the == operator.
Declaration Syntax
C#
public static bool operator ==(
    Account account1,
    Account account2
)
Parameters
account1 (Account)
The first role to compare.
account2 (Account)
The second role to compare.
Return Value


Equals Method (obj)

Equals Method (obj)
Namespaces ► Sitecore.Security.Accounts ► Account ► Equals(Object)
Determines whether the specified Object is equal to the current Account.
Declaration Syntax
C#
public override bool Equals(
    Object obj
)
Parameters
obj (Object)
The Object to compare with the current Account.
Return Value
true if the specified Object is equal to the current Account; otherwise, false.


FromName Method (accountName, accountType)

FromName Method (accountName, accountType)
Namespaces ► Sitecore.Security.Accounts ► Account ► FromName(String, AccountType)
Froms the name.
Declaration Syntax
C#
public static Account FromName(
    string accountName,
    AccountType accountType
)
Parameters
accountName (String)
Name of the account.
accountType (AccountType)
Type of the account.
Return Value


GetHashCode Method

GetHashCode Method
Namespaces ► Sitecore.Security.Accounts ► Account ► GetHashCode()()()
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
Declaration Syntax
C#
public override int GetHashCode()
Return Value
A hash code for the current Object.


Inequality Operator

Inequality Operator
Namespaces ► Sitecore.Security.Accounts ► Account ► Inequality(Account, Account)
Implements the != operator.
Declaration Syntax
C#
public static bool operator !=(
    Account account1,
    Account account2
)
Parameters
account1 (Account)
The first role to compare.
account2 (Account)
The second role to compare.
Return Value


LocalName Property

LocalName Property
Namespaces ► Sitecore.Security.Accounts ► Account ► LocalName
Gets the name of the local.
Declaration Syntax
C#
public virtual string LocalName { get; }
Value
The name of the local.


Name Property

Name Property
Namespaces ► Sitecore.Security.Accounts ► Account ► Name
Gets the name of the account.
Declaration Syntax
C#
public virtual string Name { get; }
Value
The name.


AccountCollection Class

AccountCollection Class
Namespaces ► Sitecore.Security.Accounts ► AccountCollection
AccountCollection class
Declaration Syntax
C#
public class AccountCollection : Collection<Account>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccountCollection()()() | Initializes a new instance of the AccountCollection class
 | Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Account >)>).)
 | Clear()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Account >)>).)
 | ClearItems()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Account >)>).)
 | CompareItems(Account, Account) | Compares the items.
 | Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Account >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Account >)>).)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Account >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Account >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Account >)>).)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Account >)>).)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Account >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Account >)>).)
 | Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Account >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Account >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Account >)>).)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Account >)>).)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection<(Of <( Account >)>).)
 | Sort()()() | Sorts this instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection<(Of <( Account >)>)
 |  | AccountCollection


AccountCollection Constructor

AccountCollection Constructor
Namespaces ► Sitecore.Security.Accounts ► AccountCollection ► AccountCollection()()()
Initializes a new instance of the AccountCollection class
Declaration Syntax
C#
public AccountCollection()


CompareItems Method (left, right)

CompareItems Method (left, right)
Namespaces ► Sitecore.Security.Accounts ► AccountCollection ► CompareItems(Account, Account)
Compares the items.
Declaration Syntax
C#
protected virtual int CompareItems(
    Account left,
    Account right
)
Parameters
left (Account)
The left.
right (Account)
The right.
Return Value
The items.


Sort Method

Sort Method
Namespaces ► Sitecore.Security.Accounts ► AccountCollection ► Sort()()()
Sorts this instance.
Declaration Syntax
C#
public virtual void Sort()


AccountList Class

AccountList Class
Namespaces ► Sitecore.Security.Accounts ► AccountList
AccountList class
Declaration Syntax
C#
public class AccountList : ReadOnlyList<Account>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccountList(IEnumerable<(Of <(Account>)>)) | Initializes a new instance of the AccountList class.
 | AccountList()()() | Initializes a new instance of the AccountList class.
 | Contains(TElement) | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToArray()()() | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ReadOnlyList <(Of <( Account >)>)
 |  | AccountList


AccountList Constructor

AccountList Constructor
Namespaces ► Sitecore.Security.Accounts ► AccountList ► AccountList()()()
Members
Icon | Member | Description
 | AccountList(IEnumerable<(Of <(Account>)>)) | Initializes a new instance of the AccountList class.
 | AccountList()()() | Initializes a new instance of the AccountList class.


AccountList Constructor

AccountList Constructor
Namespaces ► Sitecore.Security.Accounts ► AccountList ► AccountList()()()
Initializes a new instance of the AccountList class.
Declaration Syntax
C#
public AccountList()


AccountList Constructor (entries)

AccountList Constructor (entries)
Namespaces ► Sitecore.Security.Accounts ► AccountList ► AccountList(IEnumerable<(Of <(Account>)>))
Initializes a new instance of the AccountList class.
Declaration Syntax
C#
public AccountList(
    IEnumerable<Account> entries
)
Parameters
entries (IEnumerable<(Of <( Account >)>))
The entries.


AccountString Class

AccountString Class
Namespaces ► Sitecore.Security.Accounts ► AccountString
Account information, convenience wrapper around full account names. Ex: sitecore\Guest^User
Declaration Syntax
C#
public class AccountString
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccountString(String, AccountType) | Initializes a new instance of the AccountString class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Parse(String) | Parses the specified account.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | Type | Gets the type.
Inheritance Hierarchy
Object
AccountString


AccountString Constructor (name, type)

AccountString Constructor (name, type)
Namespaces ► Sitecore.Security.Accounts ► AccountString ► AccountString(String, AccountType)
Initializes a new instance of the AccountString class.
Declaration Syntax
C#
public AccountString(
    string name,
    AccountType type
)
Parameters
name (String)
The name.
type (AccountType)
The type.


Name Property

Name Property
Namespaces ► Sitecore.Security.Accounts ► AccountString ► Name
Gets the name.
Declaration Syntax
C#
public virtual string Name { get; }
Value
The name.


Parse Method (account)

Parse Method (account)
Namespaces ► Sitecore.Security.Accounts ► AccountString ► Parse(String)
Parses the specified account.
Declaration Syntax
C#
public static AccountString Parse(
    string account
)
Parameters
account (String)
The account.
Return Value
The parsed account info.


ToString Method

ToString Method
Namespaces ► Sitecore.Security.Accounts ► AccountString ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Type Property

Type Property
Namespaces ► Sitecore.Security.Accounts ► AccountString ► Type
Gets the type.
Declaration Syntax
C#
public virtual AccountType Type { get; }
Value
The type.


AccountType Enumeration

AccountType Enumeration
Namespaces ► Sitecore.Security.Accounts ► AccountType
AccountType enumeration
Declaration Syntax
C#
public enum AccountType
Members
Member | Description
Unknown | The account type is not known.
Role | The account represents a role.
User | The account represents a user.


MembershipUserWrapper Class

MembershipUserWrapper Class
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper
MetaMembershipUser class
Declaration Syntax
C#
public class MembershipUserWrapper : MembershipUser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MembershipUserWrapper(MembershipUser, String) | Initializes a new instance of the MembershipUserWrapper class.
 | MembershipUserWrapper(MembershipUser, String, String) | Initializes a new instance of the MembershipUserWrapper class.
 | ChangePassword(String, String) | Updates the password for the membership user in the membership data store. (Overrides MembershipUser.ChangePassword(String, String).)
 | ChangePasswordQuestionAndAnswer(String, String, String) | Updates the password question and answer for the membership user in the membership data store. (Overrides MembershipUser.ChangePasswordQuestionAndAnswer(String, String, String).)
 | Comment | Gets or sets application-specific information for the membership user. (Overrides MembershipUser.Comment.)
 | CreationDate | Gets the date and time when the user was added to the membership data store. (Overrides MembershipUser.CreationDate.)
 | Email | Gets or sets the e-mail address for the membership user. (Overrides MembershipUser.Email.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPassword()()() | Gets the password for the membership user from the membership data store. (Overrides MembershipUser.GetPassword()()().)
 | GetPassword(String) | Gets the password for the membership user from the membership data store. (Overrides MembershipUser.GetPassword(String).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerUser | Gets the inner user object.
 | IsApproved | Gets or sets whether the membership user can be authenticated. (Overrides MembershipUser.IsApproved.)
 | IsLockedOut | Gets a value indicating whether the membership user is locked out and unable to be validated. (Overrides MembershipUser.IsLockedOut.)
 | IsOnline | Gets whether the user is currently online. (Inherited from MembershipUser.)
 | LastActivityDate | Gets or sets the date and time when the membership user was last authenticated or accessed the application. (Overrides MembershipUser.LastActivityDate.)
 | LastLockoutDate | Gets the most recent date and time that the membership user was locked out. (Overrides MembershipUser.LastLockoutDate.)
 | LastLoginDate | Gets or sets the date and time when the user was last authenticated. (Overrides MembershipUser.LastLoginDate.)
 | LastPasswordChangedDate | Gets the date and time when the membership user's password was last updated. (Overrides MembershipUser.LastPasswordChangedDate.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PasswordQuestion | Gets the password question for the membership user. (Overrides MembershipUser.PasswordQuestion.)
 | ProviderName | Gets the name of the membership provider that stores and retrieves user information for the membership user. (Overrides MembershipUser.ProviderName.)
 | ProviderUserKey | Gets the user identifier from the membership data source for the user. (Overrides MembershipUser.ProviderUserKey.)
 | ResetPassword(String) | Resets a user's password to a new, automatically generated password. (Overrides MembershipUser.ResetPassword(String).)
 | ResetPassword()()() | Resets a user's password to a new, automatically generated password. (Overrides MembershipUser.ResetPassword()()().)
 | ToString()()() | Returns the user name for the membership user. (Overrides MembershipUser.ToString()()().)
 | UnlockUser()()() | Clears the locked-out state of the user so that the membership user can be validated. (Overrides MembershipUser.UnlockUser()()().)
 | UserName | Gets the logon name of the membership user. (Overrides MembershipUser.UserName.)
Inheritance Hierarchy
Object
 | MembershipUser
 |  | MembershipUserWrapper


MembershipUserWrapper Constructor

MembershipUserWrapper Constructor
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► MembershipUserWrapper()()()
Members
Icon | Member | Description
 | MembershipUserWrapper(MembershipUser, String) | Initializes a new instance of the MembershipUserWrapper class.
 | MembershipUserWrapper(MembershipUser, String, String) | Initializes a new instance of the MembershipUserWrapper class.


MembershipUserWrapper Constructor (innerUser, providerName)

MembershipUserWrapper Constructor (innerUser, providerName)
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► MembershipUserWrapper(MembershipUser, String)
Initializes a new instance of the MembershipUserWrapper class.
Declaration Syntax
C#
public MembershipUserWrapper(
    MembershipUser innerUser,
    string providerName
)
Parameters
innerUser (MembershipUser)
The inner user.
providerName (String)
Name of the provider.


MembershipUserWrapper Constructor (innerUser, fullName, providerName)

MembershipUserWrapper Constructor (innerUser, fullName, providerName)
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► MembershipUserWrapper(MembershipUser, String, String)
Initializes a new instance of the MembershipUserWrapper class.
Declaration Syntax
C#
public MembershipUserWrapper(
    MembershipUser innerUser,
    string fullName,
    string providerName
)
Parameters
innerUser (MembershipUser)
The inner user.
fullName (String)
The full name.
providerName (String)
Name of the provider.


ChangePassword Method (oldPassword, newPassword)

ChangePassword Method (oldPassword, newPassword)
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► ChangePassword(String, String)
Updates the password for the membership user in the membership data store.
Declaration Syntax
C#
public override bool ChangePassword(
    string oldPassword,
    string newPassword
)
Parameters
oldPassword (String)
The current password for the membership user.
newPassword (String)
The new password for the membership user.
Return Value
true if the update was successful; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | oldPassword is an empty string.-or-newPassword is an empty string.
ArgumentNullException | oldPassword is null.-or-newPassword is null.


ChangePasswordQuestionAndAnswer Method (password, newPasswordQuestion, newPasswordAnswer)

ChangePasswordQuestionAndAnswer Method (password, newPasswordQuestion, newPasswordAnswer)
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► ChangePasswordQuestionAndAnswer(String, String, String)
Updates the password question and answer for the membership user in the membership data store.
Declaration Syntax
C#
public override bool ChangePasswordQuestionAndAnswer(
    string password,
    string newPasswordQuestion,
    string newPasswordAnswer
)
Parameters
password (String)
The current password for the membership user.
newPasswordQuestion (String)
The new password question value for the membership user.
newPasswordAnswer (String)
The new password answer value for the membership user.
Return Value
true if the update was successful; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | password is an empty string.-or-newPasswordQuestion is an empty string.-or-newPasswordAnswer is an empty string.
ArgumentNullException | password is null.


Comment Property

Comment Property
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► Comment
Gets or sets application-specific information for the membership user.
Declaration Syntax
C#
public override string Comment { get; set; }
Return Value
Application-specific information for the membership user.


CreationDate Property

CreationDate Property
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► CreationDate
Gets the date and time when the user was added to the membership data store.
Declaration Syntax
C#
public override DateTime CreationDate { get; }
Return Value
The date and time when the user was added to the membership data store.


Email Property

Email Property
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► Email
Gets or sets the e-mail address for the membership user.
Declaration Syntax
C#
public override string Email { get; set; }
Return Value
The e-mail address for the membership user.


GetPassword Method

GetPassword Method
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► GetPassword()()()
Members
Icon | Member | Description
 | GetPassword()()() | Gets the password for the membership user from the membership data store. (Overrides MembershipUser.GetPassword()()().)
 | GetPassword(String) | Gets the password for the membership user from the membership data store. (Overrides MembershipUser.GetPassword(String).)


GetPassword Method

GetPassword Method
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► GetPassword()()()
Gets the password for the membership user from the membership data store.
Declaration Syntax
C#
public override string GetPassword()
Return Value
The password for the membership user.


GetPassword Method (passwordAnswer)

GetPassword Method (passwordAnswer)
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► GetPassword(String)
Gets the password for the membership user from the membership data store.
Declaration Syntax
C#
public override string GetPassword(
    string passwordAnswer
)
Parameters
passwordAnswer (String)
The password answer for the membership user.
Return Value
The password for the membership user.


InnerUser Property

InnerUser Property
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► InnerUser
Gets the inner user object.
Declaration Syntax
C#
public virtual MembershipUser InnerUser { get; }
Value
The inner user.


IsApproved Property

IsApproved Property
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► IsApproved
Gets or sets whether the membership user can be authenticated.
Declaration Syntax
C#
public override bool IsApproved { get; set; }
Return Value
true if the user can be authenticated; otherwise, false.


IsLockedOut Property

IsLockedOut Property
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► IsLockedOut
Gets a value indicating whether the membership user is locked out and unable to be validated.
Declaration Syntax
C#
public override bool IsLockedOut { get; }
Return Value
true if the membership user is locked out and unable to be validated; otherwise, false.


LastActivityDate Property

LastActivityDate Property
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► LastActivityDate
Gets or sets the date and time when the membership user was last authenticated or accessed the application.
Declaration Syntax
C#
public override DateTime LastActivityDate { get; set; }
Return Value
The date and time when the membership user was last authenticated or accessed the application.


LastLockoutDate Property

LastLockoutDate Property
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► LastLockoutDate
Gets the most recent date and time that the membership user was locked out.
Declaration Syntax
C#
public override DateTime LastLockoutDate { get; }
Return Value
A DateTime object that represents the most recent date and time that the membership user was locked out.


LastLoginDate Property

LastLoginDate Property
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► LastLoginDate
Gets or sets the date and time when the user was last authenticated.
Declaration Syntax
C#
public override DateTime LastLoginDate { get; set; }
Return Value
The date and time when the user was last authenticated.


LastPasswordChangedDate Property

LastPasswordChangedDate Property
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► LastPasswordChangedDate
Gets the date and time when the membership user's password was last updated.
Declaration Syntax
C#
public override DateTime LastPasswordChangedDate { get; }
Return Value
The date and time when the membership user's password was last updated.


PasswordQuestion Property

PasswordQuestion Property
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► PasswordQuestion
Gets the password question for the membership user.
Declaration Syntax
C#
public override string PasswordQuestion { get; }
Return Value
The password question for the membership user.


ProviderName Property

ProviderName Property
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► ProviderName
Gets the name of the membership provider that stores and retrieves user information for the membership user.
Declaration Syntax
C#
public override string ProviderName { get; }
Return Value
The name of the membership provider that stores and retrieves user information for the membership user.


ProviderUserKey Property

ProviderUserKey Property
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► ProviderUserKey
Gets the user identifier from the membership data source for the user.
Declaration Syntax
C#
public override Object ProviderUserKey { get; }
Return Value
The user identifier from the membership data source for the user.


ResetPassword Method

ResetPassword Method
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► ResetPassword()()()
Members
Icon | Member | Description
 | ResetPassword(String) | Resets a user's password to a new, automatically generated password. (Overrides MembershipUser.ResetPassword(String).)
 | ResetPassword()()() | Resets a user's password to a new, automatically generated password. (Overrides MembershipUser.ResetPassword()()().)


ResetPassword Method

ResetPassword Method
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► ResetPassword()()()
Resets a user's password to a new, automatically generated password.
Declaration Syntax
C#
public override string ResetPassword()
Return Value
The new password for the membership user.


ResetPassword Method (passwordAnswer)

ResetPassword Method (passwordAnswer)
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► ResetPassword(String)
Resets a user's password to a new, automatically generated password.
Declaration Syntax
C#
public override string ResetPassword(
    string passwordAnswer
)
Parameters
passwordAnswer (String)
The password answer for the membership user.
Return Value
The new password for the membership user.


ToString Method

ToString Method
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► ToString()()()
Returns the user name for the membership user.
Declaration Syntax
C#
public override string ToString()
Return Value
The UserName for the membership user.


UnlockUser Method

UnlockUser Method
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► UnlockUser()()()
Clears the locked-out state of the user so that the membership user can be validated.
Declaration Syntax
C#
public override bool UnlockUser()
Return Value
true if the membership user was successfully unlocked; otherwise, false.


UserName Property

UserName Property
Namespaces ► Sitecore.Security.Accounts ► MembershipUserWrapper ► UserName
Gets the logon name of the membership user.
Declaration Syntax
C#
public override string UserName { get; }
Return Value
The logon name of the membership user.


ProfileInfoWrapper Class

ProfileInfoWrapper Class
Namespaces ► Sitecore.Security.Accounts ► ProfileInfoWrapper
MetaProfileInfo class
Declaration Syntax
C#
public class ProfileInfoWrapper : ProfileInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProfileInfoWrapper(ProfileInfo, String) | Initializes a new instance of the ProfileInfoWrapper class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerProfile | Gets the inner profile.
 | IsAnonymous | Gets whether the user name for the profile is anonymous. (Overrides ProfileInfo.IsAnonymous.)
 | LastActivityDate | Gets the last date and time when the profile was read or updated. (Overrides ProfileInfo.LastActivityDate.)
 | LastUpdatedDate | Gets the last date and time when the profile was updated. (Overrides ProfileInfo.LastUpdatedDate.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Size | Gets the size of the profile property names and values stored in the data source. (Overrides ProfileInfo.Size.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserName | Gets the user name for the profile. (Overrides ProfileInfo.UserName.)
Inheritance Hierarchy
Object
 | ProfileInfo
 |  | ProfileInfoWrapper


ProfileInfoWrapper Constructor (innerProfile, fullName)

ProfileInfoWrapper Constructor (innerProfile, fullName)
Namespaces ► Sitecore.Security.Accounts ► ProfileInfoWrapper ► ProfileInfoWrapper(ProfileInfo, String)
Initializes a new instance of the ProfileInfoWrapper class.
Declaration Syntax
C#
public ProfileInfoWrapper(
    ProfileInfo innerProfile,
    string fullName
)
Parameters
innerProfile (ProfileInfo)
The inner profile.
fullName (String)
The full name.


InnerProfile Property

InnerProfile Property
Namespaces ► Sitecore.Security.Accounts ► ProfileInfoWrapper ► InnerProfile
Gets the inner profile.
Declaration Syntax
C#
public virtual ProfileInfo InnerProfile { get; }
Value
The inner profile.


IsAnonymous Property

IsAnonymous Property
Namespaces ► Sitecore.Security.Accounts ► ProfileInfoWrapper ► IsAnonymous
Gets whether the user name for the profile is anonymous.
Declaration Syntax
C#
public override bool IsAnonymous { get; }
Return Value
true if the user name for the profile is anonymous; otherwise, false.


LastActivityDate Property

LastActivityDate Property
Namespaces ► Sitecore.Security.Accounts ► ProfileInfoWrapper ► LastActivityDate
Gets the last date and time when the profile was read or updated.
Declaration Syntax
C#
public override DateTime LastActivityDate { get; }
Return Value
A DateTime that represents the last date and time when the profile was read or updated.


LastUpdatedDate Property

LastUpdatedDate Property
Namespaces ► Sitecore.Security.Accounts ► ProfileInfoWrapper ► LastUpdatedDate
Gets the last date and time when the profile was updated.
Declaration Syntax
C#
public override DateTime LastUpdatedDate { get; }
Return Value
A DateTime that represents the last date and time when the profile was updated.


Size Property

Size Property
Namespaces ► Sitecore.Security.Accounts ► ProfileInfoWrapper ► Size
Gets the size of the profile property names and values stored in the data source.
Declaration Syntax
C#
public override int Size { get; }
Return Value
The size of the profile property names and values stored in the data source.


UserName Property

UserName Property
Namespaces ► Sitecore.Security.Accounts ► ProfileInfoWrapper ► UserName
Gets the user name for the profile.
Declaration Syntax
C#
public override string UserName { get; }
Return Value
The user name for the profile.


Role Class

Role Class
Namespaces ► Sitecore.Security.Accounts ► Role
Role class
Declaration Syntax
C#
public class Role : Account
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Role(String) | Initializes a new instance of the Role class.
 | AccountType | Gets the type of the account. (Inherited from Account.)
 | Description | Gets the description. (Inherited from Account.)
 | DisplayName | Gets the display name. (Inherited from Account.)
 | Domain | Gets the domain associated with the account (if any). (Overrides Account.Domain.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Account. (Inherited from Account.)
 | Exists(String) | Checks wheter the specified role exists.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromName(String) | Instantiate a role from a name.
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Account.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEveryone | Gets a value indicating whether this role represents an 'everyone' role.
 | IsGlobal | Gets a value indicating whether this role is global.
 | IsMember(Account, Boolean, Boolean) | Determines whether the specified account is a member of the role.
 | LocalName | Gets the name of the local. (Inherited from Account.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the account. (Inherited from Account.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Account
 |  | Role


Role Constructor (roleName)

Role Constructor (roleName)
Namespaces ► Sitecore.Security.Accounts ► Role ► Role(String)
Initializes a new instance of the Role class.
Declaration Syntax
C#
protected Role(
    string roleName
)
Parameters
roleName (String)


Domain Property

Domain Property
Namespaces ► Sitecore.Security.Accounts ► Role ► Domain
Gets the domain associated with the account (if any).
Declaration Syntax
C#
public override Domain Domain { get; }
Value
The domain (or null).


Exists Method (roleName)

Exists Method (roleName)
Namespaces ► Sitecore.Security.Accounts ► Role ► Exists(String)
Checks wheter the specified role exists.
Declaration Syntax
C#
public static bool Exists(
    string roleName
)
Parameters
roleName (String)
The name of the role.


FromName Method (roleName)

FromName Method (roleName)
Namespaces ► Sitecore.Security.Accounts ► Role ► FromName(String)
Instantiate a role from a name.
Declaration Syntax
C#
public static Role FromName(
    string roleName
)
Parameters
roleName (String)
Name of the role.
Return Value


IsEveryone Property

IsEveryone Property
Namespaces ► Sitecore.Security.Accounts ► Role ► IsEveryone
Gets a value indicating whether this role represents an 'everyone' role.
Declaration Syntax
C#
public virtual bool IsEveryone { get; }
Value
true if this instance is everyone; otherwise, false.
Remarks

If it is the global 'everyone' role, the Domain will be null.

Otherwise, it is a domain specific 'everyone' role.


IsGlobal Property

IsGlobal Property
Namespaces ► Sitecore.Security.Accounts ► Role ► IsGlobal
Gets a value indicating whether this role is global.
Declaration Syntax
C#
public virtual bool IsGlobal { get; }
Value
true if this role is global; otherwise, false.


IsMember Method (account, includeRoleMembers, includeEveryoneMembers)

IsMember Method (account, includeRoleMembers, includeEveryoneMembers)
Namespaces ► Sitecore.Security.Accounts ► Role ► IsMember(Account, Boolean, Boolean)
Determines whether the specified account is a member of the role.
Declaration Syntax
C#
public virtual bool IsMember(
    Account account,
    bool includeRoleMembers,
    bool includeEveryoneMembers
)
Parameters
account (Account)
The account.
includeRoleMembers (Boolean)
If set to true and this account is a role, the method will return true if account is a member of the role.
includeEveryoneMembers (Boolean)

If set to true and this account is the global 'everyone' role, the method will always return true.

If set to true and this account is a domain specific 'everyone' role, the method will return true if account belongs to the same domain.

Return Value
true if the specified account is a match; otherwise, false.
Remarks
If the role is passed to itself, true will be returned.


RoleList Class

RoleList Class
Namespaces ► Sitecore.Security.Accounts ► RoleList
RoleList class
Declaration Syntax
C#
public class RoleList : ReadOnlyList<Role>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RoleList(IEnumerable<(Of <(Role>)>)) | Initializes a new instance of the RoleList class.
 | RoleList(array<Role>[]()[]) | Initializes a new instance of the RoleList class.
 | RoleList()()() | Initializes a new instance of the RoleList class.
 | Contains(TElement) | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromNames(IEnumerable<(Of <(String>)>)) | Instantiates from a list of names.
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Names | Gets the names of all roles in the list.
 | ToArray()()() | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ReadOnlyList <(Of <( Role >)>)
 |  | RoleList


RoleList Constructor

RoleList Constructor
Namespaces ► Sitecore.Security.Accounts ► RoleList ► RoleList()()()
Members
Icon | Member | Description
 | RoleList(IEnumerable<(Of <(Role>)>)) | Initializes a new instance of the RoleList class.
 | RoleList(array<Role>[]()[]) | Initializes a new instance of the RoleList class.
 | RoleList()()() | Initializes a new instance of the RoleList class.


RoleList Constructor

RoleList Constructor
Namespaces ► Sitecore.Security.Accounts ► RoleList ► RoleList()()()
Initializes a new instance of the RoleList class.
Declaration Syntax
C#
public RoleList()


RoleList Constructor (entries)

RoleList Constructor (entries)
Namespaces ► Sitecore.Security.Accounts ► RoleList ► RoleList(array<Role>[]()[])
Initializes a new instance of the RoleList class.
Declaration Syntax
C#
public RoleList(
    params Role[] entries
)
Parameters
entries (array< Role >[]()[])
The entries.


RoleList Constructor (entries)

RoleList Constructor (entries)
Namespaces ► Sitecore.Security.Accounts ► RoleList ► RoleList(IEnumerable<(Of <(Role>)>))
Initializes a new instance of the RoleList class.
Declaration Syntax
C#
public RoleList(
    IEnumerable<Role> entries
)
Parameters
entries (IEnumerable<(Of <( Role >)>))
The entries.


FromNames Method (names)

FromNames Method (names)
Namespaces ► Sitecore.Security.Accounts ► RoleList ► FromNames(IEnumerable<(Of <(String>)>))
Instantiates from a list of names.
Declaration Syntax
C#
public static RoleList FromNames(
    IEnumerable<string> names
)
Parameters
names (IEnumerable<(Of <(String>)>))
The names.
Return Value


Names Property

Names Property
Namespaces ► Sitecore.Security.Accounts ► RoleList ► Names
Gets the names of all roles in the list.
Declaration Syntax
C#
public virtual StringList Names { get; }
Value
The names.


RolesInRolesManager Class

RolesInRolesManager Class
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager
RolesInRolesManager class
Declaration Syntax
C#
public static class RolesInRolesManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddRolesToRole(IEnumerable<(Of <(Role>)>), Role) | Adds the specified roles to the specified role.
 | AddRolesToRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>)) | Adds the specified roles to the specified roles.
 | AddRoleToRole(Role, Role) | Adds the specified role to the specified target role.
 | AddRoleToRoles(Role, IEnumerable<(Of <(Role>)>)) | Adds the specified role to the specified target roles.
 | ApplicationName | Gets or sets the name of the application to store and retrieve role information for.
 | FindRolesInRole(Role, String, Boolean) | Gets a list of roles in a specified target role where the role name contains the specified name to match.
 | FindUsersInRole(Role, String, Boolean) | Gets a list of users that are directly or indirectly members of the specified target role. The user name must contain the specified name to match.
 | GetAllRoles()()() | Gets all roles.
 | GetAllRoles(Boolean) | Gets all roles.
 | GetCreatorOwnerRole()()() | Gets the creator-owner role.
 | GetEveryoneRole()()() | Gets the everyone role.
 | GetEveryoneRole(Domain) | Gets the everyone role for the specified domain.
 | GetEveryoneRoles()()() | Gets the everyone roles.
 | GetGlobalRoles()()() | Gets the global roles.
 | GetRoleMembers(Role, Boolean) | Gets a list of member accounts for the specified target role.
 | GetRoleMembers(Role, Boolean, IEnumerable<(Of <(Domain>)>)) | Gets a list of member accounts for the specified target role for domain.
 | GetRolesForRole(Role, Boolean) | Gets a list of the roles that a role is in.
 | GetRolesForUser(User, Boolean) | Gets a list of the roles that a user is directly or indirectly member of.
 | GetRolesInRole(Role, Boolean) | Gets a list of member roles for the specified target role.
 | GetSystemRoles()()() | Gets the system roles.
 | GetUsersInRole(Role, Boolean) | Gets a list of member users for the specified target role. Both direct and indirect members (ie. members of member roles) are returned.
 | IsCreatorOwnerRole(String) | Determines whether the specified account name is the system role 'creator-owner'.
 | IsEveryoneRole(String) | Determines whether the specified account name is the global 'everyone' role.
 | IsEveryoneRole(String, Domain) | Determines whether the specified account name is the 'everyone' role within the specified domain.
 | IsGlobalRole(Role) | Determines whether [is global role] [the specified role].
 | IsRoleInRole(Role, Role, Boolean) | Gets a value indicating whether the specified role is in the specified target role.
 | IsSystemRole(String) | Determines whether the specified account name represents one of the system roles (ex. everyone or creator-owner).
 | IsUserInRole(User, Role, Boolean) | Gets a value indicating whether the specified user is directly or indrectly a member of the specified target role.
 | Provider | Gets the provider.
 | Providers | Gets all providers.
 | RemoveRoleFromRole(Role, Role) | Removes the specified member role from the specified target role.
 | RemoveRoleFromRoles(Role, IEnumerable<(Of <(Role>)>)) | Removes the specified member role from the specified target roles.
 | RemoveRolesFromRole(IEnumerable<(Of <(Role>)>), Role) | Removes the specified member roles from the specified target roles.
 | RemoveRolesFromRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>)) | Removes the specified member roles from the specified target roles.
 | RolesInRolesSupported | Gets a value indicating whether roles in roles support is enabled.
Inheritance Hierarchy
Object
RolesInRolesManager


AddRolesToRole Method (memberRoles, targetRole)

AddRolesToRole Method (memberRoles, targetRole)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► AddRolesToRole(IEnumerable<(Of <(Role>)>), Role)
Adds the specified roles to the specified role.
Declaration Syntax
C#
public static void AddRolesToRole(
    IEnumerable<Role> memberRoles,
    Role targetRole
)
Parameters
memberRoles (IEnumerable<(Of <( Role >)>))
The member roles.
targetRole (Role)
The target role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


AddRolesToRoles Method (memberRoles, targetRoles)

AddRolesToRoles Method (memberRoles, targetRoles)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► AddRolesToRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>))
Adds the specified roles to the specified roles.
Declaration Syntax
C#
public static void AddRolesToRoles(
    IEnumerable<Role> memberRoles,
    IEnumerable<Role> targetRoles
)
Parameters
memberRoles (IEnumerable<(Of <( Role >)>))
The member roles.
targetRoles (IEnumerable<(Of <( Role >)>))
The target roles.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


AddRoleToRole Method (memberRole, targetRole)

AddRoleToRole Method (memberRole, targetRole)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► AddRoleToRole(Role, Role)
Adds the specified role to the specified target role.
Declaration Syntax
C#
public static void AddRoleToRole(
    Role memberRole,
    Role targetRole
)
Parameters
memberRole (Role)
The member role.
targetRole (Role)
The target role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


AddRoleToRoles Method (memberRole, targetRoles)

AddRoleToRoles Method (memberRole, targetRoles)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► AddRoleToRoles(Role, IEnumerable<(Of <(Role>)>))
Adds the specified role to the specified target roles.
Declaration Syntax
C#
public static void AddRoleToRoles(
    Role memberRole,
    IEnumerable<Role> targetRoles
)
Parameters
memberRole (Role)
The member role.
targetRoles (IEnumerable<(Of <( Role >)>))
The target roles.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


ApplicationName Property

ApplicationName Property
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► ApplicationName
Gets or sets the name of the application to store and retrieve role information for.
Declaration Syntax
C#
public static string ApplicationName { get; set; }
Value
The name of the application to store and retrieve role information for.


FindRolesInRole Method (targetRole, roleNameToMatch, includeIndirectMembership)

FindRolesInRole Method (targetRole, roleNameToMatch, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► FindRolesInRole(Role, String, Boolean)
Gets a list of roles in a specified target role where the role name contains the specified name to match.
Declaration Syntax
C#
public static IEnumerable<Role> FindRolesInRole(
    Role targetRole,
    string roleNameToMatch,
    bool includeIndirectMembership
)
Parameters
targetRole (Role)
The target role.
roleNameToMatch (String)
The role name to search for.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
A string array containing the names of all the roles whose name matches roleNameToMatch and who are members of the specified target role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


FindUsersInRole Method (targetRole, userNameToMatch, includeIndirectMembership)

FindUsersInRole Method (targetRole, userNameToMatch, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► FindUsersInRole(Role, String, Boolean)
Gets a list of users that are directly or indirectly members of the specified target role. The user name must contain the specified name to match.
Declaration Syntax
C#
public static IEnumerable<Role> FindUsersInRole(
    Role targetRole,
    string userNameToMatch,
    bool includeIndirectMembership
)
Parameters
targetRole (Role)
The target role.
userNameToMatch (String)
The user name to search for.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
A string array containing the names of all the users whose name matches userNameToMatch and who are members of the specified target role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


GetAllRoles Method

GetAllRoles Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetAllRoles()()()
Members
Icon | Member | Description
 | GetAllRoles()()() | Gets all roles.
 | GetAllRoles(Boolean) | Gets all roles.


GetAllRoles Method

GetAllRoles Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetAllRoles()()()
Gets all roles.
Declaration Syntax
C#
public static IEnumerable<Role> GetAllRoles()
Return Value


GetAllRoles Method (includeSystemRoles)

GetAllRoles Method (includeSystemRoles)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetAllRoles(Boolean)
Gets all roles.
Declaration Syntax
C#
public static IEnumerable<Role> GetAllRoles(
    bool includeSystemRoles
)
Parameters
includeSystemRoles (Boolean)
If set to true, system roles (such as Everyone and Creator-Owner) are included.
Return Value
The list of roles.


GetCreatorOwnerRole Method

GetCreatorOwnerRole Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetCreatorOwnerRole()()()
Gets the creator-owner role.
Declaration Syntax
C#
public static Role GetCreatorOwnerRole()
Return Value
The creator-owner role.


GetEveryoneRole Method

GetEveryoneRole Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetEveryoneRole()()()
Members
Icon | Member | Description
 | GetEveryoneRole()()() | Gets the everyone role.
 | GetEveryoneRole(Domain) | Gets the everyone role for the specified domain.


GetEveryoneRole Method

GetEveryoneRole Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetEveryoneRole()()()
Gets the everyone role.
Declaration Syntax
C#
public static Role GetEveryoneRole()
Return Value
The everyone role.


GetEveryoneRole Method (domain)

GetEveryoneRole Method (domain)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetEveryoneRole(Domain)
Gets the everyone role for the specified domain.
Declaration Syntax
C#
public static Role GetEveryoneRole(
    Domain domain
)
Parameters
domain (Domain)
The domain.
Return Value
The everyone role.


GetEveryoneRoles Method

GetEveryoneRoles Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetEveryoneRoles()()()
Gets the everyone roles.
Declaration Syntax
C#
public static IEnumerable<Role> GetEveryoneRoles()
Return Value
The everyone roles.


GetGlobalRoles Method

GetGlobalRoles Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetGlobalRoles()()()
Gets the global roles.
Declaration Syntax
C#
public static IEnumerable<Role> GetGlobalRoles()
Return Value


GetRoleMembers Method

GetRoleMembers Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetRoleMembers()()()
Members
Icon | Member | Description
 | GetRoleMembers(Role, Boolean) | Gets a list of member accounts for the specified target role.
 | GetRoleMembers(Role, Boolean, IEnumerable<(Of <(Domain>)>)) | Gets a list of member accounts for the specified target role for domain.


GetRoleMembers Method (role, includeIndirectMembership)

GetRoleMembers Method (role, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetRoleMembers(Role, Boolean)
Gets a list of member accounts for the specified target role.
Declaration Syntax
C#
public static IEnumerable<Account> GetRoleMembers(
    Role role,
    bool includeIndirectMembership
)
Parameters
role (Role)
The role.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
A list containing the names of all the accounts who are members of the specified role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


GetRoleMembers Method (role, includeIndirectMembership, domains)

GetRoleMembers Method (role, includeIndirectMembership, domains)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetRoleMembers(Role, Boolean, IEnumerable<(Of <(Domain>)>))
Gets a list of member accounts for the specified target role for domain.
Declaration Syntax
C#
public static IEnumerable<Account> GetRoleMembers(
    Role role,
    bool includeIndirectMembership,
    IEnumerable<Domain> domains
)
Parameters
role (Role)
The role.
includeIndirectMembership (Boolean)
if set to true this instance is include indirect membership.
domains (IEnumerable<(Of <( Domain >)>))
The domains.
Return Value
The role members.


GetRolesForRole Method (role, includeIndirectMembership)

GetRolesForRole Method (role, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetRolesForRole(Role, Boolean)
Gets a list of the roles that a role is in.
Declaration Syntax
C#
public static IEnumerable<Role> GetRolesForRole(
    Role role,
    bool includeIndirectMembership
)
Parameters
role (Role)
The role.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
A string array containing the names of all the roles that the specified role is in.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


GetRolesForUser Method (user, includeIndirectMembership)

GetRolesForUser Method (user, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetRolesForUser(User, Boolean)
Gets a list of the roles that a user is directly or indirectly member of.
Declaration Syntax
C#
public static IEnumerable<Role> GetRolesForUser(
    User user,
    bool includeIndirectMembership
)
Parameters
user (User)
The user.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
A string array containing the names of all the roles that the specified user is in.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


GetRolesInRole Method (targetRole, includeIndirectMembership)

GetRolesInRole Method (targetRole, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetRolesInRole(Role, Boolean)
Gets a list of member roles for the specified target role.
Declaration Syntax
C#
public static IEnumerable<Role> GetRolesInRole(
    Role targetRole,
    bool includeIndirectMembership
)
Parameters
targetRole (Role)
The role to get the list of member roles for.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
A string array containing the names of all the roles who are members of the specified role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


GetSystemRoles Method

GetSystemRoles Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetSystemRoles()()()
Gets the system roles.
Declaration Syntax
C#
public static IEnumerable<Role> GetSystemRoles()
Return Value


GetUsersInRole Method (targetRole, includeIndirectMembership)

GetUsersInRole Method (targetRole, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► GetUsersInRole(Role, Boolean)
Gets a list of member users for the specified target role. Both direct and indirect members (ie. members of member roles) are returned.
Declaration Syntax
C#
public static IEnumerable<User> GetUsersInRole(
    Role targetRole,
    bool includeIndirectMembership
)
Parameters
targetRole (Role)
The target role.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
A string array containing the names of all the users who are members of the specified role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


IsCreatorOwnerRole Method (accountName)

IsCreatorOwnerRole Method (accountName)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► IsCreatorOwnerRole(String)
Determines whether the specified account name is the system role 'creator-owner'.
Declaration Syntax
C#
public static bool IsCreatorOwnerRole(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value
true if it is the creator-owner role; otherwise, false.


IsEveryoneRole Method

IsEveryoneRole Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► IsEveryoneRole()()()
Members
Icon | Member | Description
 | IsEveryoneRole(String) | Determines whether the specified account name is the global 'everyone' role.
 | IsEveryoneRole(String, Domain) | Determines whether the specified account name is the 'everyone' role within the specified domain.


IsEveryoneRole Method (accountName)

IsEveryoneRole Method (accountName)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► IsEveryoneRole(String)
Determines whether the specified account name is the global 'everyone' role.
Declaration Syntax
C#
public static bool IsEveryoneRole(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value
true if it is the everyone role; otherwise, false.


IsEveryoneRole Method (accountName, domain)

IsEveryoneRole Method (accountName, domain)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► IsEveryoneRole(String, Domain)
Determines whether the specified account name is the 'everyone' role within the specified domain.
Declaration Syntax
C#
public static bool IsEveryoneRole(
    string accountName,
    Domain domain
)
Parameters
accountName (String)
Name of the account.
domain (Domain)
The domain.
Return Value
true if it is the everyone role; otherwise, false.


IsGlobalRole Method (role)

IsGlobalRole Method (role)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► IsGlobalRole(Role)
Determines whether [is global role] [the specified role].
Declaration Syntax
C#
public static bool IsGlobalRole(
    Role role
)
Parameters
role (Role)
The role.
Return Value
true if [is global role] [the specified role]; otherwise, false.


IsRoleInRole Method (memberRole, targetRole, includeIndirectMembership)

IsRoleInRole Method (memberRole, targetRole, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► IsRoleInRole(Role, Role, Boolean)
Gets a value indicating whether the specified role is in the specified target role.
Declaration Syntax
C#
public static bool IsRoleInRole(
    Role memberRole,
    Role targetRole,
    bool includeIndirectMembership
)
Parameters
memberRole (Role)
The member role.
targetRole (Role)
The target role.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
true if the specified role is in the specified target role; otherwise, false.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


IsSystemRole Method (accountName)

IsSystemRole Method (accountName)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► IsSystemRole(String)
Determines whether the specified account name represents one of the system roles (ex. everyone or creator-owner).
Declaration Syntax
C#
public static bool IsSystemRole(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value
true if it is a system role; otherwise, false.


IsUserInRole Method (user, targetRole, includeIndirectMembership)

IsUserInRole Method (user, targetRole, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► IsUserInRole(User, Role, Boolean)
Gets a value indicating whether the specified user is directly or indrectly a member of the specified target role.
Declaration Syntax
C#
public static bool IsUserInRole(
    User user,
    Role targetRole,
    bool includeIndirectMembership
)
Parameters
user (User)
The user.
targetRole (Role)
The target role.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
true if the specified user is in the specified target role; otherwise, false.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


Provider Property

Provider Property
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► Provider
Gets the provider.
Declaration Syntax
C#
public static RolesInRolesProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► Providers
Gets all providers.
Declaration Syntax
C#
public static RolesInRolesProviderCollection Providers { get; }
Value
The providers.


RemoveRoleFromRole Method (memberRole, targetRole)

RemoveRoleFromRole Method (memberRole, targetRole)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► RemoveRoleFromRole(Role, Role)
Removes the specified member role from the specified target role.
Declaration Syntax
C#
public static void RemoveRoleFromRole(
    Role memberRole,
    Role targetRole
)
Parameters
memberRole (Role)
The member role.
targetRole (Role)
The target role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


RemoveRoleFromRoles Method (memberRole, targetRoles)

RemoveRoleFromRoles Method (memberRole, targetRoles)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► RemoveRoleFromRoles(Role, IEnumerable<(Of <(Role>)>))
Removes the specified member role from the specified target roles.
Declaration Syntax
C#
public static void RemoveRoleFromRoles(
    Role memberRole,
    IEnumerable<Role> targetRoles
)
Parameters
memberRole (Role)
The member role.
targetRoles (IEnumerable<(Of <( Role >)>))
The target roles.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


RemoveRolesFromRole Method (memberRoles, targetRole)

RemoveRolesFromRole Method (memberRoles, targetRole)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► RemoveRolesFromRole(IEnumerable<(Of <(Role>)>), Role)
Removes the specified member roles from the specified target roles.
Declaration Syntax
C#
public static void RemoveRolesFromRole(
    IEnumerable<Role> memberRoles,
    Role targetRole
)
Parameters
memberRoles (IEnumerable<(Of <( Role >)>))
The member roles.
targetRole (Role)
The target role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


RemoveRolesFromRoles Method (memberRoles, targetRoles)

RemoveRolesFromRoles Method (memberRoles, targetRoles)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► RemoveRolesFromRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>))
Removes the specified member roles from the specified target roles.
Declaration Syntax
C#
public static void RemoveRolesFromRoles(
    IEnumerable<Role> memberRoles,
    IEnumerable<Role> targetRoles
)
Parameters
memberRoles (IEnumerable<(Of <( Role >)>))
The member roles.
targetRoles (IEnumerable<(Of <( Role >)>))
The target roles.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


RolesInRolesSupported Property

RolesInRolesSupported Property
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesManager ► RolesInRolesSupported
Gets a value indicating whether roles in roles support is enabled.
Declaration Syntax
C#
public static bool RolesInRolesSupported { get; }
Value
true if enabled; otherwise, false.


RolesInRolesProvider Class

RolesInRolesProvider Class
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider
RolesInRolesProvider class
Declaration Syntax
C#
public abstract class RolesInRolesProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RolesInRolesProvider()()() | Initializes a new instance of the RolesInRolesProvider class
 | AddRolesToRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>)) | Adds the specified member roles to the specified target roles.
 | ApplicationName | Gets or sets the name of the application to store and retrieve role information for.
 | AssertEnabled()()() | Asserts that roles in roles support is enabled.
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindRolesInRole(Role, String, Boolean) | Gets a list of roles in a specified target role where the role name contains the specified name to match.
 | FindRolesInRole(String, String) | Gets a list of direct member roles in a specified target role where the role name contains the specified name to match (indirect members are not included in the list).
 | FindUsersInRole(Role, String, Boolean) | Gets a list of users in a specified target role where the role name contains the specified name to match.
 | GetAllRoles(Boolean) | Gets all roles.
 | GetCreatorOwnerRole()()() | Gets the global 'Creator-owner' role.
 | GetEveryoneRole()()() | Gets the global 'Everyone' account (a custom role that contains all accounts in all domains).
 | GetEveryoneRole(Domain) | Gets the 'Everyone' account for a specific domain (a custom role that contains all accounts in the domain).
 | GetEveryoneRoles()()() | Gets a list of all 'everyone' account names.
 | GetGlobalRoles()()() | Gets all global roles.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRoleMembers(Role, Boolean) | Gets a list of member accounts for the specified target role.
 | GetRolesForRole(Role, Boolean) | Gets a list of the roles that a role is member of.
 | GetRolesForRole(String) | Gets a set of the roles that a role is a direct member of (ie. indirect memberships is not included in the result).
 | GetRolesForRoles(IEnumerable<(Of <(Role>)>), List<(Of <(Role>)>)) | Gets the roles for role recursive.
 | GetRolesForUser(User, Boolean) | Gets a list of the roles that a user is directly or indirectly member of.
 | GetRolesInRole(Role, Boolean) | Gets a list of member roles for the specified target role.
 | GetRolesInRole(String) | Gets a list of direct member roles for the specified target role (indirect members are not included in the list).
 | GetSystemRoles()()() | Gets the system roles.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUsersInRole(Role, Boolean) | Gets a list of member users for the specified target role. Both direct and indirect members (ie. members of member roles) are returned.
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | IsCreatorOwnerRole(String) | Determines whether the specified account name is the system role 'creator-owner'.
 | IsEveryoneRole(String) | Determines whether the specified account name is the global 'everyone' role.
 | IsEveryoneRole(String, Domain) | Determines whether the specified account name is the 'everyone' role within the specified domain.
 | IsGlobalRole(Role) | Determines whether [is global role] [the specified role].
 | IsRoleInRole(Role, Role, Boolean) | Gets a value indicating whether the specified role is in the specified target role.
 | IsRoleInRole(String, String) | Gets a value indicating whether the specified role is a direct member of the specified target role (indirect membership is not considered).
 | IsSystemRole(String) | Determines whether the specified account name represents one of the system roles (ex. everyone or creator-owner).
 | IsUserInRole(User, Role, Boolean) | Gets a value indicating whether the specified user is directly or indirectly a member of the specified target role.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | RaiseEvent(String, array<Object>[]()[]) | Raises an event (if _raiseEvents is true).
 | RemoveRoleRelations(String) | Removes all relations for a role.
 | RemoveRolesFromRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>)) | Removes the specified member roles from the specified target roles.
 | RolesInRolesSupported | Gets a value indicating whether roles-in-roles is supported by the provider.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | RolesInRolesProvider
 |  |  | SqlRolesInRolesProvider


RolesInRolesProvider Constructor

RolesInRolesProvider Constructor
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► RolesInRolesProvider()()()
Initializes a new instance of the RolesInRolesProvider class
Declaration Syntax
C#
protected RolesInRolesProvider()


AddRolesToRoles Method (memberRoles, targetRoles)

AddRolesToRoles Method (memberRoles, targetRoles)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► AddRolesToRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>))
Adds the specified member roles to the specified target roles.
Declaration Syntax
C#
public abstract void AddRolesToRoles(
    IEnumerable<Role> memberRoles,
    IEnumerable<Role> targetRoles
)
Parameters
memberRoles (IEnumerable<(Of <( Role >)>))
The member roles.
targetRoles (IEnumerable<(Of <( Role >)>))
The target roles.
Remarks
The implementation must call RaiseEvent("roles:rolesAdded", memberRoles, targetRoles); to notify the system that role assignments were changed.


ApplicationName Property

ApplicationName Property
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► ApplicationName
Gets or sets the name of the application to store and retrieve role information for.
Declaration Syntax
C#
public virtual string ApplicationName { get; set; }
Value
The name of the application to store and retrieve role information for.


AssertEnabled Method

AssertEnabled Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► AssertEnabled()()()
Asserts that roles in roles support is enabled.
Declaration Syntax
C#
protected virtual void AssertEnabled()
Exceptions
Exception | Condition
ProviderException |


FindRolesInRole Method

FindRolesInRole Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► FindRolesInRole()()()
Members
Icon | Member | Description
 | FindRolesInRole(Role, String, Boolean) | Gets a list of roles in a specified target role where the role name contains the specified name to match.
 | FindRolesInRole(String, String) | Gets a list of direct member roles in a specified target role where the role name contains the specified name to match (indirect members are not included in the list).


FindRolesInRole Method (targetRole, roleNameToMatch, includeIndirectMembership)

FindRolesInRole Method (targetRole, roleNameToMatch, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► FindRolesInRole(Role, String, Boolean)
Gets a list of roles in a specified target role where the role name contains the specified name to match.
Declaration Syntax
C#
public virtual IEnumerable<Role> FindRolesInRole(
    Role targetRole,
    string roleNameToMatch,
    bool includeIndirectMembership
)
Parameters
targetRole (Role)
The target role.
roleNameToMatch (String)
The role name to search for.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
A string array containing the names of all the roles whose name matches roleNameToMatch and who are members of the specified target role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


FindRolesInRole Method (targetRoleName, roleNameToMatch)

FindRolesInRole Method (targetRoleName, roleNameToMatch)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► FindRolesInRole(String, String)
Gets a list of direct member roles in a specified target role where the role name contains the specified name to match (indirect members are not included in the list).
Declaration Syntax
C#
protected abstract IEnumerable<Role> FindRolesInRole(
    string targetRoleName,
    string roleNameToMatch
)
Parameters
targetRoleName (String)
The role to search in.
roleNameToMatch (String)
The role name to search for.
Return Value
A string array containing the names of all the roles whose name matches roleNameToMatch and who are members of the specified target role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


FindUsersInRole Method (targetRole, userNameToMatch, includeIndirectMembership)

FindUsersInRole Method (targetRole, userNameToMatch, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► FindUsersInRole(Role, String, Boolean)
Gets a list of users in a specified target role where the role name contains the specified name to match.
Declaration Syntax
C#
public virtual IEnumerable<Role> FindUsersInRole(
    Role targetRole,
    string userNameToMatch,
    bool includeIndirectMembership
)
Parameters
targetRole (Role)
The target role.
userNameToMatch (String)
The user name to search for.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
A string array containing the names of all the users whose name matches userNameToMatch and who are members of the specified target role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


GetAllRoles Method (includeSystemRoles)

GetAllRoles Method (includeSystemRoles)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetAllRoles(Boolean)
Gets all roles.
Declaration Syntax
C#
public virtual IEnumerable<Role> GetAllRoles(
    bool includeSystemRoles
)
Parameters
includeSystemRoles (Boolean)
If set to true, system roles (such as Everyone and Creator-Owner) are included.
Return Value
The list of roles.


GetCreatorOwnerRole Method

GetCreatorOwnerRole Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetCreatorOwnerRole()()()
Gets the global 'Creator-owner' role.
Declaration Syntax
C#
public virtual Role GetCreatorOwnerRole()
Return Value
The creator-owner role.


GetEveryoneRole Method

GetEveryoneRole Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetEveryoneRole()()()
Members
Icon | Member | Description
 | GetEveryoneRole()()() | Gets the global 'Everyone' account (a custom role that contains all accounts in all domains).
 | GetEveryoneRole(Domain) | Gets the 'Everyone' account for a specific domain (a custom role that contains all accounts in the domain).


GetEveryoneRole Method

GetEveryoneRole Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetEveryoneRole()()()
Gets the global 'Everyone' account (a custom role that contains all accounts in all domains).
Declaration Syntax
C#
public virtual Role GetEveryoneRole()
Value
Any.


GetEveryoneRole Method (domain)

GetEveryoneRole Method (domain)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetEveryoneRole(Domain)
Gets the 'Everyone' account for a specific domain (a custom role that contains all accounts in the domain).
Declaration Syntax
C#
public virtual Role GetEveryoneRole(
    Domain domain
)
Parameters
domain (Domain)
The domain.
Value
Any.
Return Value


GetEveryoneRoles Method

GetEveryoneRoles Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetEveryoneRoles()()()
Gets a list of all 'everyone' account names.
Declaration Syntax
C#
public virtual IEnumerable<Role> GetEveryoneRoles()
Return Value
The everyone account names.


GetGlobalRoles Method

GetGlobalRoles Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetGlobalRoles()()()
Gets all global roles.
Declaration Syntax
C#
public virtual IEnumerable<Role> GetGlobalRoles()
Return Value


GetRoleMembers Method (role, includeIndirectMembership)

GetRoleMembers Method (role, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetRoleMembers(Role, Boolean)
Gets a list of member accounts for the specified target role.
Declaration Syntax
C#
public virtual IEnumerable<Account> GetRoleMembers(
    Role role,
    bool includeIndirectMembership
)
Parameters
role (Role)
The role.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
A list containing the names of all the accounts who are members of the specified role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


GetRolesForRole Method

GetRolesForRole Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetRolesForRole()()()
Members
Icon | Member | Description
 | GetRolesForRole(Role, Boolean) | Gets a list of the roles that a role is member of.
 | GetRolesForRole(String) | Gets a set of the roles that a role is a direct member of (ie. indirect memberships is not included in the result).


GetRolesForRole Method (memberRole, includeIndirectMembership)

GetRolesForRole Method (memberRole, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetRolesForRole(Role, Boolean)
Gets a list of the roles that a role is member of.
Declaration Syntax
C#
public virtual IEnumerable<Role> GetRolesForRole(
    Role memberRole,
    bool includeIndirectMembership
)
Parameters
memberRole (Role)
The member role.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
A string array containing the names of all the roles that the specified role is in.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


GetRolesForRole Method (memberRoleName)

GetRolesForRole Method (memberRoleName)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetRolesForRole(String)
Gets a set of the roles that a role is a direct member of (ie. indirect memberships is not included in the result).
Declaration Syntax
C#
protected abstract IEnumerable<Role> GetRolesForRole(
    string memberRoleName
)
Parameters
memberRoleName (String)
The role to return a list of roles for.
Return Value
A string array containing the names of all the roles that the specified role is in.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


GetRolesForRoles Method (memberRoles, result)

GetRolesForRoles Method (memberRoles, result)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetRolesForRoles(IEnumerable<(Of <(Role>)>), List<(Of <(Role>)>))
Gets the roles for role recursive.
Declaration Syntax
C#
protected virtual void GetRolesForRoles(
    IEnumerable<Role> memberRoles,
    List<Role> result
)
Parameters
memberRoles (IEnumerable<(Of <( Role >)>))
The roles.
result (List<(Of <( Role >)>))
The result.


GetRolesForUser Method (user, includeIndirectMembership)

GetRolesForUser Method (user, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetRolesForUser(User, Boolean)
Gets a list of the roles that a user is directly or indirectly member of.
Declaration Syntax
C#
public virtual IEnumerable<Role> GetRolesForUser(
    User user,
    bool includeIndirectMembership
)
Parameters
user (User)
The user.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
A string array containing the names of all the roles that the specified user is in.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


GetRolesInRole Method

GetRolesInRole Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetRolesInRole()()()
Members
Icon | Member | Description
 | GetRolesInRole(Role, Boolean) | Gets a list of member roles for the specified target role.
 | GetRolesInRole(String) | Gets a list of direct member roles for the specified target role (indirect members are not included in the list).


GetRolesInRole Method (targetRole, includeIndirectMembership)

GetRolesInRole Method (targetRole, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetRolesInRole(Role, Boolean)
Gets a list of member roles for the specified target role.
Declaration Syntax
C#
public virtual IEnumerable<Role> GetRolesInRole(
    Role targetRole,
    bool includeIndirectMembership
)
Parameters
targetRole (Role)
The target role.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
A string array containing the names of all the roles who are members of the specified role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


GetRolesInRole Method (targetRoleName)

GetRolesInRole Method (targetRoleName)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetRolesInRole(String)
Gets a list of direct member roles for the specified target role (indirect members are not included in the list).
Declaration Syntax
C#
protected abstract IEnumerable<Role> GetRolesInRole(
    string targetRoleName
)
Parameters
targetRoleName (String)
The role to get the list of member roles for.
Return Value
A string array containing the names of all the roles who are members of the specified role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


GetSystemRoles Method

GetSystemRoles Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetSystemRoles()()()
Gets the system roles.
Declaration Syntax
C#
public virtual IEnumerable<Role> GetSystemRoles()
Return Value
The system roles.


GetUsersInRole Method (targetRole, includeIndirectMembership)

GetUsersInRole Method (targetRole, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► GetUsersInRole(Role, Boolean)
Gets a list of member users for the specified target role. Both direct and indirect members (ie. members of member roles) are returned.
Declaration Syntax
C#
public virtual IEnumerable<User> GetUsersInRole(
    Role targetRole,
    bool includeIndirectMembership
)
Parameters
targetRole (Role)
The target role.
includeIndirectMembership (Boolean)
if set to true include indirect role memberships.
Return Value
A string array containing the names of all the users who are members of the specified role.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.
ArgumentException | The name of the provider has a length of zero.


IsCreatorOwnerRole Method (accountName)

IsCreatorOwnerRole Method (accountName)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► IsCreatorOwnerRole(String)
Determines whether the specified account name is the system role 'creator-owner'.
Declaration Syntax
C#
public virtual bool IsCreatorOwnerRole(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value
true if it is the creator-owner role; otherwise, false.


IsEveryoneRole Method

IsEveryoneRole Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► IsEveryoneRole()()()
Members
Icon | Member | Description
 | IsEveryoneRole(String) | Determines whether the specified account name is the global 'everyone' role.
 | IsEveryoneRole(String, Domain) | Determines whether the specified account name is the 'everyone' role within the specified domain.


IsEveryoneRole Method (accountName)

IsEveryoneRole Method (accountName)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► IsEveryoneRole(String)
Determines whether the specified account name is the global 'everyone' role.
Declaration Syntax
C#
public virtual bool IsEveryoneRole(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value
true if it is the everyone role; otherwise, false.


IsEveryoneRole Method (accountName, domain)

IsEveryoneRole Method (accountName, domain)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► IsEveryoneRole(String, Domain)
Determines whether the specified account name is the 'everyone' role within the specified domain.
Declaration Syntax
C#
public virtual bool IsEveryoneRole(
    string accountName,
    Domain domain
)
Parameters
accountName (String)
Name of the account.
domain (Domain)
The domain.
Return Value
true if it is the everyone role; otherwise, false.


IsGlobalRole Method (role)

IsGlobalRole Method (role)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► IsGlobalRole(Role)
Determines whether [is global role] [the specified role].
Declaration Syntax
C#
public virtual bool IsGlobalRole(
    Role role
)
Parameters
role (Role)
The role.
Return Value
true if [is global role] [the specified role]; otherwise, false.


IsRoleInRole Method

IsRoleInRole Method
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► IsRoleInRole()()()
Members
Icon | Member | Description
 | IsRoleInRole(Role, Role, Boolean) | Gets a value indicating whether the specified role is in the specified target role.
 | IsRoleInRole(String, String) | Gets a value indicating whether the specified role is a direct member of the specified target role (indirect membership is not considered).


IsRoleInRole Method (memberRole, targetRole, includeIndirectMembership)

IsRoleInRole Method (memberRole, targetRole, includeIndirectMembership)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► IsRoleInRole(Role, Role, Boolean)
Gets a value indicating whether the specified role is in the specified target role.
Declaration Syntax
C#
public virtual bool IsRoleInRole(
    Role memberRole,
    Role targetRole,
    bool includeIndirectMembership
)
Parameters
memberRole (Role)
The member role.
targetRole (Role)
The target role.
includeIndirectMembership (Boolean)
if set to true include indirect roles membership.
Return Value
true if the specified role is in the specified target role; otherwise, false.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


IsRoleInRole Method (memberRoleName, targetRoleName)

IsRoleInRole Method (memberRoleName, targetRoleName)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► IsRoleInRole(String, String)
Gets a value indicating whether the specified role is a direct member of the specified target role (indirect membership is not considered).
Declaration Syntax
C#
protected abstract bool IsRoleInRole(
    string memberRoleName,
    string targetRoleName
)
Parameters
memberRoleName (String)
The name of the role to search for.
targetRoleName (String)
The name of the role to search in.
Return Value
true if the specified role is in the specified target role; otherwise, false.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


IsSystemRole Method (accountName)

IsSystemRole Method (accountName)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► IsSystemRole(String)
Determines whether the specified account name represents one of the system roles (ex. everyone or creator-owner).
Declaration Syntax
C#
public virtual bool IsSystemRole(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value
true if it is a system role; otherwise, false.


IsUserInRole Method (user, targetRole, includeIndirectMemberships)

IsUserInRole Method (user, targetRole, includeIndirectMemberships)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► IsUserInRole(User, Role, Boolean)
Gets a value indicating whether the specified user is directly or indirectly a member of the specified target role.
Declaration Syntax
C#
public virtual bool IsUserInRole(
    User user,
    Role targetRole,
    bool includeIndirectMemberships
)
Parameters
user (User)
The user.
targetRole (Role)
The target role.
includeIndirectMemberships (Boolean)
if set to true include indirect roles membership.
Return Value
true if the specified user is in the specified target role; otherwise, false.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


RaiseEvent Method (eventName, parameters)

RaiseEvent Method (eventName, parameters)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► RaiseEvent(String, array<Object>[]()[])
Raises an event (if _raiseEvents is true).
Declaration Syntax
C#
protected virtual void RaiseEvent(
    string eventName,
    params Object[] parameters
)
Parameters
eventName (String)
Name of the event.
parameters (array< Object >[]()[])
The parameters.


RemoveRoleRelations Method (roleName)

RemoveRoleRelations Method (roleName)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► RemoveRoleRelations(String)
Removes all relations for a role.
Declaration Syntax
C#
public abstract void RemoveRoleRelations(
    string roleName
)
Parameters
roleName (String)
Name of the role.
Remarks
The implementation must call RaiseEvent("roles:relationsRemoved", roleName); to notify the system that role assignments were changed.


RemoveRolesFromRoles Method (memberRoles, targetRoles)

RemoveRolesFromRoles Method (memberRoles, targetRoles)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► RemoveRolesFromRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>))
Removes the specified member roles from the specified target roles.
Declaration Syntax
C#
public abstract void RemoveRolesFromRoles(
    IEnumerable<Role> memberRoles,
    IEnumerable<Role> targetRoles
)
Parameters
memberRoles (IEnumerable<(Of <( Role >)>))
The roles to remove from the specified target role.
targetRoles (IEnumerable<(Of <( Role >)>))
The roles to remove the specified member role from.
Remarks
The implementation must call RaiseEvent("roles:rolesRemoved", memberRoles, targetRoles); to notify the system that role assignments were changed.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


RolesInRolesSupported Property

RolesInRolesSupported Property
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProvider ► RolesInRolesSupported
Gets a value indicating whether roles-in-roles is supported by the provider.
Declaration Syntax
C#
public virtual bool RolesInRolesSupported { get; }
Value
true if [roles in roles supported]; otherwise, false.


RolesInRolesProviderCollection Class

RolesInRolesProviderCollection Class
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProviderCollection
RolesInRolesProviderCollection class
Declaration Syntax
C#
public class RolesInRolesProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RolesInRolesProviderCollection()()() | Initializes a new instance of the RolesInRolesProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the RolesInRolesProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | RolesInRolesProviderCollection


RolesInRolesProviderCollection Constructor

RolesInRolesProviderCollection Constructor
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProviderCollection ► RolesInRolesProviderCollection()()()
Initializes a new instance of the RolesInRolesProviderCollection class
Declaration Syntax
C#
public RolesInRolesProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Security.Accounts ► RolesInRolesProviderCollection ► Item[([(String])])
Gets the RolesInRolesProvider with the specified name.
Declaration Syntax
C#
public virtual RolesInRolesProvider this[
    string name
] { get; }
Parameters
name (String)
Value


SqlRolesInRolesProvider Class

SqlRolesInRolesProvider Class
Namespaces ► Sitecore.Security.Accounts ► SqlRolesInRolesProvider
SqlRolesInRolesProvider class
Declaration Syntax
C#
public class SqlRolesInRolesProvider : RolesInRolesProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlRolesInRolesProvider(SqlDataApi) | Initializes a new instance of the SqlRolesInRolesProvider class.
 | AddRolesToRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>)) | Adds the specified member roles to the specified target roles. (Overrides RolesInRolesProvider.AddRolesToRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>)).)
 | AddRoleToRole(String, String) | Adds the specified member role to the specified target role.
 | Api | Gets the data API to the physical database.
 | ApplicationName | Gets or sets the name of the application to store and retrieve role information for. (Inherited from RolesInRolesProvider.)
 | AssertEnabled()()() | Asserts that roles in roles support is enabled. (Inherited from RolesInRolesProvider.)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindRolesInRole(String, String) | Gets a list of roles in a specified target role where the role name contains the specified name to match. (Overrides RolesInRolesProvider.FindRolesInRole(String, String).)
 | FindRolesInRole(Role, String, Boolean) | Gets a list of roles in a specified target role where the role name contains the specified name to match. (Inherited from RolesInRolesProvider.)
 | FindUsersInRole(Role, String, Boolean) | Gets a list of users in a specified target role where the role name contains the specified name to match. (Inherited from RolesInRolesProvider.)
 | GetAllRoles(Boolean) | Gets all roles. (Inherited from RolesInRolesProvider.)
 | GetCreatorOwnerRole()()() | Gets the global 'Creator-owner' role. (Inherited from RolesInRolesProvider.)
 | GetEveryoneRole()()() | Gets the global 'Everyone' account (a custom role that contains all accounts in all domains). (Inherited from RolesInRolesProvider.)
 | GetEveryoneRole(Domain) | Gets the 'Everyone' account for a specific domain (a custom role that contains all accounts in the domain). (Inherited from RolesInRolesProvider.)
 | GetEveryoneRoles()()() | Gets a list of all 'everyone' account names. (Inherited from RolesInRolesProvider.)
 | GetGlobalRoles()()() | Gets all global roles. (Inherited from RolesInRolesProvider.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRoleMembers(Role, Boolean) | Gets a list of member accounts for the specified target role. (Inherited from RolesInRolesProvider.)
 | GetRolesForRole(String) | Gets a list of the roles that a role is in. (Overrides RolesInRolesProvider.GetRolesForRole(String).)
 | GetRolesForRole(Role, Boolean) | Gets a list of the roles that a role is member of. (Inherited from RolesInRolesProvider.)
 | GetRolesForRoles(IEnumerable<(Of <(Role>)>), List<(Of <(Role>)>)) | Gets the roles for role recursive. (Inherited from RolesInRolesProvider.)
 | GetRolesForUser(User, Boolean) | Gets a list of the roles that a user is directly or indirectly member of. (Inherited from RolesInRolesProvider.)
 | GetRolesInRole(String) | Gets a list of member roles for the specified target role. (Overrides RolesInRolesProvider.GetRolesInRole(String).)
 | GetRolesInRole(Role, Boolean) | Gets a list of member roles for the specified target role. (Inherited from RolesInRolesProvider.)
 | GetSystemRoles()()() | Gets the system roles. (Inherited from RolesInRolesProvider.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUsersInRole(Role, Boolean) | Gets a list of member users for the specified target role. Both direct and indirect members (ie. members of member roles) are returned. (Inherited from RolesInRolesProvider.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from RolesInRolesProvider.)
 | IsCreatorOwnerRole(String) | Determines whether the specified account name is the system role 'creator-owner'. (Inherited from RolesInRolesProvider.)
 | IsEveryoneRole(String) | Determines whether the specified account name is the global 'everyone' role. (Inherited from RolesInRolesProvider.)
 | IsEveryoneRole(String, Domain) | Determines whether the specified account name is the 'everyone' role within the specified domain. (Inherited from RolesInRolesProvider.)
 | IsGlobalRole(Role) | Determines whether [is global role] [the specified role]. (Inherited from RolesInRolesProvider.)
 | IsRoleInRole(String, String) | Gets a value indicating whether the specified role is in the specified target role. (Overrides RolesInRolesProvider.IsRoleInRole(String, String).)
 | IsRoleInRole(Role, Role, Boolean) | Gets a value indicating whether the specified role is in the specified target role. (Inherited from RolesInRolesProvider.)
 | IsSystemRole(String) | Determines whether the specified account name represents one of the system roles (ex. everyone or creator-owner). (Inherited from RolesInRolesProvider.)
 | IsUserInRole(User, Role, Boolean) | Gets a value indicating whether the specified user is directly or indirectly a member of the specified target role. (Inherited from RolesInRolesProvider.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | RaiseEvent(String, array<Object>[]()[]) | Raises an event (if _raiseEvents is true). (Inherited from RolesInRolesProvider.)
 | RemoveRoleFromRole(String, String) | Removes a member role from a target role.
 | RemoveRoleRelations(String) | Removes all relations for a role. (Overrides RolesInRolesProvider.RemoveRoleRelations(String).)
 | RemoveRolesFromRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>)) | Removes the specified member roles from the specified target roles. (Overrides RolesInRolesProvider.RemoveRolesFromRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>)).)
 | RolesInRolesSupported | Gets a value indicating whether roles-in-roles is supported by the provider. (Inherited from RolesInRolesProvider.)
 | SyncRoot | Gets the sync root.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | RolesInRolesProvider
 |  |  | SqlRolesInRolesProvider
 |  |  |  | SqlServerRolesInRolesProvider


SqlRolesInRolesProvider Constructor (api)

SqlRolesInRolesProvider Constructor (api)
Namespaces ► Sitecore.Security.Accounts ► SqlRolesInRolesProvider ► SqlRolesInRolesProvider(SqlDataApi)
Initializes a new instance of the SqlRolesInRolesProvider class.
Declaration Syntax
C#
public SqlRolesInRolesProvider(
    SqlDataApi api
)
Parameters
api (SqlDataApi)
The API.


AddRolesToRoles Method (memberRoles, targetRoles)

AddRolesToRoles Method (memberRoles, targetRoles)
Namespaces ► Sitecore.Security.Accounts ► SqlRolesInRolesProvider ► AddRolesToRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>))
Adds the specified member roles to the specified target roles.
Declaration Syntax
C#
public override void AddRolesToRoles(
    IEnumerable<Role> memberRoles,
    IEnumerable<Role> targetRoles
)
Parameters
memberRoles (IEnumerable<(Of <( Role >)>))
The member roles.
targetRoles (IEnumerable<(Of <( Role >)>))
The target roles.
Remarks
The implementation must call RaiseEvent("roles:rolesAdded", memberRoles, targetRoles); to notify the system that role assignments were changed.


AddRoleToRole Method (memberRoleName, targetRoleName)

AddRoleToRole Method (memberRoleName, targetRoleName)
Namespaces ► Sitecore.Security.Accounts ► SqlRolesInRolesProvider ► AddRoleToRole(String, String)
Adds the specified member role to the specified target role.
Declaration Syntax
C#
protected virtual void AddRoleToRole(
    string memberRoleName,
    string targetRoleName
)
Parameters
memberRoleName (String)
Name of a role to add to the specified target role.
targetRoleName (String)
Name of a role to add the specified member names to.


Api Property

Api Property
Namespaces ► Sitecore.Security.Accounts ► SqlRolesInRolesProvider ► Api
Gets the data API to the physical database.
Declaration Syntax
C#
protected virtual SqlDataApi Api { get; }
Value
The data API.


FindRolesInRole Method (targetRoleName, roleNameToMatch)

FindRolesInRole Method (targetRoleName, roleNameToMatch)
Namespaces ► Sitecore.Security.Accounts ► SqlRolesInRolesProvider ► FindRolesInRole(String, String)
Gets a list of roles in a specified target role where the role name contains the specified name to match.
Declaration Syntax
C#
protected override IEnumerable<Role> FindRolesInRole(
    string targetRoleName,
    string roleNameToMatch
)
Parameters
targetRoleName (String)
The role to search in.
roleNameToMatch (String)
The role name to search for.
Return Value
A string array containing the names of all the roles whose name matches roleNameToMatch and who are members of the specified target role.


GetRolesForRole Method (memberRoleName)

GetRolesForRole Method (memberRoleName)
Namespaces ► Sitecore.Security.Accounts ► SqlRolesInRolesProvider ► GetRolesForRole(String)
Gets a list of the roles that a role is in.
Declaration Syntax
C#
protected override IEnumerable<Role> GetRolesForRole(
    string memberRoleName
)
Parameters
memberRoleName (String)
The role to return a list of roles for.
Return Value
A string array containing the names of all the roles that the specified role is in.


GetRolesInRole Method (targetRoleName)

GetRolesInRole Method (targetRoleName)
Namespaces ► Sitecore.Security.Accounts ► SqlRolesInRolesProvider ► GetRolesInRole(String)
Gets a list of member roles for the specified target role.
Declaration Syntax
C#
protected override IEnumerable<Role> GetRolesInRole(
    string targetRoleName
)
Parameters
targetRoleName (String)
The role to get the list of member roles for.
Return Value
A string array containing the names of all the roles who are members of the specified role.


IsRoleInRole Method (memberRoleName, targetRoleName)

IsRoleInRole Method (memberRoleName, targetRoleName)
Namespaces ► Sitecore.Security.Accounts ► SqlRolesInRolesProvider ► IsRoleInRole(String, String)
Gets a value indicating whether the specified role is in the specified target role.
Declaration Syntax
C#
protected override bool IsRoleInRole(
    string memberRoleName,
    string targetRoleName
)
Parameters
memberRoleName (String)
The name of the role to search for.
targetRoleName (String)
The name of the role to search in.
Return Value
true if the specified role is in the specified target role; otherwise, false.


RemoveRoleFromRole Method (memberRoleName, targetRoleName)

RemoveRoleFromRole Method (memberRoleName, targetRoleName)
Namespaces ► Sitecore.Security.Accounts ► SqlRolesInRolesProvider ► RemoveRoleFromRole(String, String)
Removes a member role from a target role.
Declaration Syntax
C#
protected virtual void RemoveRoleFromRole(
    string memberRoleName,
    string targetRoleName
)
Parameters
memberRoleName (String)
Name of the role to remove from the target role.
targetRoleName (String)
Name of the role to remove the member from.


RemoveRoleRelations Method (roleName)

RemoveRoleRelations Method (roleName)
Namespaces ► Sitecore.Security.Accounts ► SqlRolesInRolesProvider ► RemoveRoleRelations(String)
Removes all relations for a role.
Declaration Syntax
C#
public override void RemoveRoleRelations(
    string roleName
)
Parameters
roleName (String)
Name of the role.
Remarks
The implementation must call RaiseEvent("roles:relationsRemoved", roleName); to notify the system that role assignments were changed.


RemoveRolesFromRoles Method (memberRoles, targetRoles)

RemoveRolesFromRoles Method (memberRoles, targetRoles)
Namespaces ► Sitecore.Security.Accounts ► SqlRolesInRolesProvider ► RemoveRolesFromRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>))
Removes the specified member roles from the specified target roles.
Declaration Syntax
C#
public override void RemoveRolesFromRoles(
    IEnumerable<Role> memberRoles,
    IEnumerable<Role> targetRoles
)
Parameters
memberRoles (IEnumerable<(Of <( Role >)>))
The roles to remove from the specified target role.
targetRoles (IEnumerable<(Of <( Role >)>))
The roles to remove the specified member role from.
Remarks
The implementation must call RaiseEvent("roles:rolesRemoved", memberRoles, targetRoles); to notify the system that role assignments were changed.
Exceptions
Exception | Condition
ProviderException | Roles in roles management is not enabled.


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Security.Accounts ► SqlRolesInRolesProvider ► SyncRoot
Gets the sync root.
Declaration Syntax
C#
public virtual Object SyncRoot { get; }
Value
The sync root.


SqlServerRolesInRolesProvider Class

SqlServerRolesInRolesProvider Class
Namespaces ► Sitecore.Security.Accounts ► SqlServerRolesInRolesProvider
SqlServerRolesInRolesProvider class
Declaration Syntax
C#
public class SqlServerRolesInRolesProvider : SqlRolesInRolesProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerRolesInRolesProvider()()() | Initializes a new instance of the SqlServerRolesInRolesProvider class.
 | AddRolesToRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>)) | Adds the specified member roles to the specified target roles. (Inherited from SqlRolesInRolesProvider.)
 | AddRoleToRole(String, String) | Adds the specified member role to the specified target role. (Inherited from SqlRolesInRolesProvider.)
 | Api | Gets the data API to the physical database. (Inherited from SqlRolesInRolesProvider.)
 | ApplicationName | Gets or sets the name of the application to store and retrieve role information for. (Inherited from RolesInRolesProvider.)
 | AssertEnabled()()() | Asserts that roles in roles support is enabled. (Inherited from RolesInRolesProvider.)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindRolesInRole(String, String) | Gets a list of roles in a specified target role where the role name contains the specified name to match. (Inherited from SqlRolesInRolesProvider.)
 | FindRolesInRole(Role, String, Boolean) | Gets a list of roles in a specified target role where the role name contains the specified name to match. (Inherited from RolesInRolesProvider.)
 | FindUsersInRole(Role, String, Boolean) | Gets a list of users in a specified target role where the role name contains the specified name to match. (Inherited from RolesInRolesProvider.)
 | GetAllRoles(Boolean) | Gets all roles. (Inherited from RolesInRolesProvider.)
 | GetCreatorOwnerRole()()() | Gets the global 'Creator-owner' role. (Inherited from RolesInRolesProvider.)
 | GetEveryoneRole()()() | Gets the global 'Everyone' account (a custom role that contains all accounts in all domains). (Inherited from RolesInRolesProvider.)
 | GetEveryoneRole(Domain) | Gets the 'Everyone' account for a specific domain (a custom role that contains all accounts in the domain). (Inherited from RolesInRolesProvider.)
 | GetEveryoneRoles()()() | Gets a list of all 'everyone' account names. (Inherited from RolesInRolesProvider.)
 | GetGlobalRoles()()() | Gets all global roles. (Inherited from RolesInRolesProvider.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRoleMembers(Role, Boolean) | Gets a list of member accounts for the specified target role. (Inherited from RolesInRolesProvider.)
 | GetRolesForRole(String) | Gets a list of the roles that a role is in. (Inherited from SqlRolesInRolesProvider.)
 | GetRolesForRole(Role, Boolean) | Gets a list of the roles that a role is member of. (Inherited from RolesInRolesProvider.)
 | GetRolesForRoles(IEnumerable<(Of <(Role>)>), List<(Of <(Role>)>)) | Gets the roles for role recursive. (Inherited from RolesInRolesProvider.)
 | GetRolesForUser(User, Boolean) | Gets a list of the roles that a user is directly or indirectly member of. (Inherited from RolesInRolesProvider.)
 | GetRolesInRole(String) | Gets a list of member roles for the specified target role. (Inherited from SqlRolesInRolesProvider.)
 | GetRolesInRole(Role, Boolean) | Gets a list of member roles for the specified target role. (Inherited from RolesInRolesProvider.)
 | GetSystemRoles()()() | Gets the system roles. (Inherited from RolesInRolesProvider.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUsersInRole(Role, Boolean) | Gets a list of member users for the specified target role. Both direct and indirect members (ie. members of member roles) are returned. (Inherited from RolesInRolesProvider.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides RolesInRolesProvider.Initialize(String, NameValueCollection).)
 | IsCreatorOwnerRole(String) | Determines whether the specified account name is the system role 'creator-owner'. (Inherited from RolesInRolesProvider.)
 | IsEveryoneRole(String) | Determines whether the specified account name is the global 'everyone' role. (Inherited from RolesInRolesProvider.)
 | IsEveryoneRole(String, Domain) | Determines whether the specified account name is the 'everyone' role within the specified domain. (Inherited from RolesInRolesProvider.)
 | IsGlobalRole(Role) | Determines whether [is global role] [the specified role]. (Inherited from RolesInRolesProvider.)
 | IsRoleInRole(String, String) | Gets a value indicating whether the specified role is in the specified target role. (Inherited from SqlRolesInRolesProvider.)
 | IsRoleInRole(Role, Role, Boolean) | Gets a value indicating whether the specified role is in the specified target role. (Inherited from RolesInRolesProvider.)
 | IsSystemRole(String) | Determines whether the specified account name represents one of the system roles (ex. everyone or creator-owner). (Inherited from RolesInRolesProvider.)
 | IsUserInRole(User, Role, Boolean) | Gets a value indicating whether the specified user is directly or indirectly a member of the specified target role. (Inherited from RolesInRolesProvider.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | RaiseEvent(String, array<Object>[]()[]) | Raises an event (if _raiseEvents is true). (Inherited from RolesInRolesProvider.)
 | RemoveRoleFromRole(String, String) | Removes a member role from a target role. (Inherited from SqlRolesInRolesProvider.)
 | RemoveRoleRelations(String) | Removes all relations for a role. (Inherited from SqlRolesInRolesProvider.)
 | RemoveRolesFromRoles(IEnumerable<(Of <(Role>)>), IEnumerable<(Of <(Role>)>)) | Removes the specified member roles from the specified target roles. (Inherited from SqlRolesInRolesProvider.)
 | RolesInRolesSupported | Gets a value indicating whether roles-in-roles is supported by the provider. (Inherited from RolesInRolesProvider.)
 | SyncRoot | Gets the sync root. (Inherited from SqlRolesInRolesProvider.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | RolesInRolesProvider
 |  |  | SqlRolesInRolesProvider
 |  |  |  | SqlServerRolesInRolesProvider


SqlServerRolesInRolesProvider Constructor

SqlServerRolesInRolesProvider Constructor
Namespaces ► Sitecore.Security.Accounts ► SqlServerRolesInRolesProvider ► SqlServerRolesInRolesProvider()()()
Initializes a new instance of the SqlServerRolesInRolesProvider class.
Declaration Syntax
C#
public SqlServerRolesInRolesProvider()


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Security.Accounts ► SqlServerRolesInRolesProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.
ArgumentException | The name of the provider has a length of zero.


User Class

User Class
Namespaces ► Sitecore.Security.Accounts ► User
User class
Declaration Syntax
C#
public class User : Account, IPrincipal
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | User(IPrincipal) | Initializes a new instance of the User class.
 | User(String, Boolean) | Initializes a new instance of the User class.
 | AccountType | Gets the type of the account. (Inherited from Account.)
 | Create(String, String) | Creates a new user with the specified user name and stores it in the underlying membership database.
 | Current | Gets the current user.
 | Delegation | Gets the delegation.
 | Delete()()() | Deletes the user from the underlying membership database.
 | Description | Gets the description. (Inherited from Account.)
 | DisplayName | Gets the display name. (Inherited from Account.)
 | Domain | Gets the domain to which the user belongs. (Overrides Account.Domain.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Account. (Inherited from Account.)
 | Exists(String) | Existses the specified username.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromName(String, Boolean) | Instantiate a user from a name.
 | FromPrincipal(IPrincipal) | Instantiate a user from an IPrincipal.
 | GetDomainName()()() | Gets the name of the domain.
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Account.)
 | GetLocalName()()() | Gets the local name of the user.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Identity | Gets the identity of the current principal.
 | IsAdministrator | Gets a value indicating whether the user is an administrator.
 | IsAuthenticated | Gets a value indicating whether the user has been authenticated.
 | IsInRole(Role) | Determines whether the user belongs to the specified role.
 | IsInRole(String) | Determines whether the current principal belongs to the specified role.
 | LocalName | Gets the name of the local. (Overrides Account.LocalName.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the account. (Inherited from Account.)
 | Profile | Gets the profile.
 | Roles | Gets the roles that the user is a member of.
 | RuntimeSettings | Gets the runtime settings.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Account
 |  | User


User Constructor

User Constructor
Namespaces ► Sitecore.Security.Accounts ► User ► User()()()
Members
Icon | Member | Description
 | User(IPrincipal) | Initializes a new instance of the User class.
 | User(String, Boolean) | Initializes a new instance of the User class.


User Constructor (innerUser)

User Constructor (innerUser)
Namespaces ► Sitecore.Security.Accounts ► User ► User(IPrincipal)
Initializes a new instance of the User class.
Declaration Syntax
C#
protected User(
    IPrincipal innerUser
)
Parameters
innerUser (IPrincipal)


User Constructor (userName, isAuthenticated)

User Constructor (userName, isAuthenticated)
Namespaces ► Sitecore.Security.Accounts ► User ► User(String, Boolean)
Initializes a new instance of the User class.
Declaration Syntax
C#
protected User(
    string userName,
    bool isAuthenticated
)
Parameters
userName (String)
Name of the user.
isAuthenticated (Boolean)
If set to true the user has been authenticated.


Create Method (userName, password)

Create Method (userName, password)
Namespaces ► Sitecore.Security.Accounts ► User ► Create(String, String)
Creates a new user with the specified user name and stores it in the underlying membership database.
Declaration Syntax
C#
public static User Create(
    string userName,
    string password
)
Parameters
userName (String)
Name of the user.
password (String)
The password.
Return Value


Current Property

Current Property
Namespaces ► Sitecore.Security.Accounts ► User ► Current
Gets the current user.
Declaration Syntax
C#
public static User Current { get; }
Value
The current user.


Delegation Property

Delegation Property
Namespaces ► Sitecore.Security.Accounts ► User ► Delegation
Gets the delegation.
Declaration Syntax
C#
public virtual UserDelegation Delegation { get; }
Value
The delegation.


Delete Method

Delete Method
Namespaces ► Sitecore.Security.Accounts ► User ► Delete()()()
Deletes the user from the underlying membership database.
Declaration Syntax
C#
public virtual void Delete()


Domain Property

Domain Property
Namespaces ► Sitecore.Security.Accounts ► User ► Domain
Gets the domain to which the user belongs.
Declaration Syntax
C#
public override Domain Domain { get; }
Value
The domain.


Exists Method (username)

Exists Method (username)
Namespaces ► Sitecore.Security.Accounts ► User ► Exists(String)
Existses the specified username.
Declaration Syntax
C#
public static bool Exists(
    string username
)
Parameters
username (String)
The username.


FromName Method (userName, isAuthenticated)

FromName Method (userName, isAuthenticated)
Namespaces ► Sitecore.Security.Accounts ► User ► FromName(String, Boolean)
Instantiate a user from a name.
Declaration Syntax
C#
public static User FromName(
    string userName,
    bool isAuthenticated
)
Parameters
userName (String)
Name of the user.
isAuthenticated (Boolean)
If set to true, the user has been authenticated.
Return Value


FromPrincipal Method (principal)

FromPrincipal Method (principal)
Namespaces ► Sitecore.Security.Accounts ► User ► FromPrincipal(IPrincipal)
Instantiate a user from an IPrincipal.
Declaration Syntax
C#
public static User FromPrincipal(
    IPrincipal principal
)
Parameters
principal (IPrincipal)
The principal.
Return Value


GetDomainName Method

GetDomainName Method
Namespaces ► Sitecore.Security.Accounts ► User ► GetDomainName()()()
Gets the name of the domain.
Declaration Syntax
C#
public virtual string GetDomainName()
Return Value
The String.


GetLocalName Method

GetLocalName Method
Namespaces ► Sitecore.Security.Accounts ► User ► GetLocalName()()()
Gets the local name of the user.
Declaration Syntax
C#
public virtual string GetLocalName()
Return Value
The name of the user without the domain.


Identity Property

Identity Property
Namespaces ► Sitecore.Security.Accounts ► User ► Identity
Gets the identity of the current principal.
Declaration Syntax
C#
public virtual IIdentity Identity { get; }
Return Value
The IIdentity object associated with the current principal.


IsAdministrator Property

IsAdministrator Property
Namespaces ► Sitecore.Security.Accounts ► User ► IsAdministrator
Gets a value indicating whether the user is an administrator.
Declaration Syntax
C#
public virtual bool IsAdministrator { get; }
Value
true if the user is an administrator; otherwise, false.


IsAuthenticated Property

IsAuthenticated Property
Namespaces ► Sitecore.Security.Accounts ► User ► IsAuthenticated
Gets a value indicating whether the user has been authenticated.
Declaration Syntax
C#
public virtual bool IsAuthenticated { get; }
Value
true if the user has been authenticated; otherwise, false.


IsInRole Method

IsInRole Method
Namespaces ► Sitecore.Security.Accounts ► User ► IsInRole()()()
Members
Icon | Member | Description
 | IsInRole(Role) | Determines whether the user belongs to the specified role.
 | IsInRole(String) | Determines whether the current principal belongs to the specified role.


IsInRole Method (role)

IsInRole Method (role)
Namespaces ► Sitecore.Security.Accounts ► User ► IsInRole(Role)
Determines whether the user belongs to the specified role.
Declaration Syntax
C#
public virtual bool IsInRole(
    Role role
)
Parameters
role (Role)
The role.
Return Value
true if the user is a member of the specified role; otherwise, false.


IsInRole Method (roleName)

IsInRole Method (roleName)
Namespaces ► Sitecore.Security.Accounts ► User ► IsInRole(String)
Determines whether the current principal belongs to the specified role.
Declaration Syntax
C#
public virtual bool IsInRole(
    string roleName
)
Parameters
roleName (String)
The name of the role for which to check membership.
Return Value
true if the current principal is a member of the specified role; otherwise, false.


LocalName Property

LocalName Property
Namespaces ► Sitecore.Security.Accounts ► User ► LocalName
Gets the name of the local.
Declaration Syntax
C#
public override string LocalName { get; }
Value
The name of the local.


Profile Property

Profile Property
Namespaces ► Sitecore.Security.Accounts ► User ► Profile
Gets the profile.
Declaration Syntax
C#
public virtual UserProfile Profile { get; }
Value
The profile.


Roles Property

Roles Property
Namespaces ► Sitecore.Security.Accounts ► User ► Roles
Gets the roles that the user is a member of.
Declaration Syntax
C#
public virtual UserRoles Roles { get; }
Value
The roles.


RuntimeSettings Property

RuntimeSettings Property
Namespaces ► Sitecore.Security.Accounts ► User ► RuntimeSettings
Gets the runtime settings.
Declaration Syntax
C#
public virtual UserRuntimeSettings RuntimeSettings { get; }
Value
The runtime settings.


UserDelegation Class

UserDelegation Class
Namespaces ► Sitecore.Security.Accounts ► UserDelegation
UserDelegation class
Declaration Syntax
C#
public class UserDelegation
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UserDelegation(User) | Initializes a new instance of the UserDelegation class.
 | CanManage(Domain) | Determines whether the user can manage the specified domain.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetManagedAccounts()()() | Gets the managed accounts (ie. the accounts for which the user is local administrator).
 | GetManagedDomains()()() | Gets the domains managed by the user.
 | GetManagedRoles()()() | Gets the roles managed by this user.
 | GetManagedRoles(Boolean) | Gets the roles managed by this user.
 | GetManagedUsers()()() | Gets the users managed by this user.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UserDelegation


UserDelegation Constructor (user)

UserDelegation Constructor (user)
Namespaces ► Sitecore.Security.Accounts ► UserDelegation ► UserDelegation(User)
Initializes a new instance of the UserDelegation class.
Declaration Syntax
C#
public UserDelegation(
    User user
)
Parameters
user (User)
The user.


CanManage Method (domain)

CanManage Method (domain)
Namespaces ► Sitecore.Security.Accounts ► UserDelegation ► CanManage(Domain)
Determines whether the user can manage the specified domain.
Declaration Syntax
C#
public virtual bool CanManage(
    Domain domain
)
Parameters
domain (Domain)
The domain.
Return Value
true if the user can manage the specified domain; otherwise, false.


GetManagedAccounts Method

GetManagedAccounts Method
Namespaces ► Sitecore.Security.Accounts ► UserDelegation ► GetManagedAccounts()()()
Gets the managed accounts (ie. the accounts for which the user is local administrator).
Declaration Syntax
C#
public virtual IEnumerable<Account> GetManagedAccounts()
Return Value


GetManagedDomains Method

GetManagedDomains Method
Namespaces ► Sitecore.Security.Accounts ► UserDelegation ► GetManagedDomains()()()
Gets the domains managed by the user.
Declaration Syntax
C#
public virtual IEnumerable<Domain> GetManagedDomains()
Return Value


GetManagedRoles Method

GetManagedRoles Method
Namespaces ► Sitecore.Security.Accounts ► UserDelegation ► GetManagedRoles()()()
Members
Icon | Member | Description
 | GetManagedRoles()()() | Gets the roles managed by this user.
 | GetManagedRoles(Boolean) | Gets the roles managed by this user.


GetManagedRoles Method

GetManagedRoles Method
Namespaces ► Sitecore.Security.Accounts ► UserDelegation ► GetManagedRoles()()()
Gets the roles managed by this user.
Declaration Syntax
C#
public virtual IEnumerable<Role> GetManagedRoles()
Return Value
The managed roles.


GetManagedRoles Method (includeSystemRoles)

GetManagedRoles Method (includeSystemRoles)
Namespaces ► Sitecore.Security.Accounts ► UserDelegation ► GetManagedRoles(Boolean)
Gets the roles managed by this user.
Declaration Syntax
C#
public virtual IEnumerable<Role> GetManagedRoles(
    bool includeSystemRoles
)
Parameters
includeSystemRoles (Boolean)
if set to true this instance is include system roles.
Return Value
The managed roles.


GetManagedUsers Method

GetManagedUsers Method
Namespaces ► Sitecore.Security.Accounts ► UserDelegation ► GetManagedUsers()()()
Gets the users managed by this user.
Declaration Syntax
C#
public virtual IEnumerable<User> GetManagedUsers()
Return Value


UserList Class

UserList Class
Namespaces ► Sitecore.Security.Accounts ► UserList
UserList class
Declaration Syntax
C#
public class UserList : ReadOnlyList<User>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserList(IEnumerable<(Of <(User>)>)) | Initializes a new instance of the UserList class.
 | UserList()()() | Initializes a new instance of the UserList class.
 | Contains(TElement) | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromNames(IEnumerable<(Of <(String>)>), Boolean) | Instantiate a user from a name.
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Names | Gets the names of all roles in the list.
 | ToArray()()() | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ReadOnlyList <(Of <( User >)>)
 |  | UserList


UserList Constructor

UserList Constructor
Namespaces ► Sitecore.Security.Accounts ► UserList ► UserList()()()
Members
Icon | Member | Description
 | UserList(IEnumerable<(Of <(User>)>)) | Initializes a new instance of the UserList class.
 | UserList()()() | Initializes a new instance of the UserList class.


UserList Constructor

UserList Constructor
Namespaces ► Sitecore.Security.Accounts ► UserList ► UserList()()()
Initializes a new instance of the UserList class.
Declaration Syntax
C#
public UserList()


UserList Constructor (entries)

UserList Constructor (entries)
Namespaces ► Sitecore.Security.Accounts ► UserList ► UserList(IEnumerable<(Of <(User>)>))
Initializes a new instance of the UserList class.
Declaration Syntax
C#
public UserList(
    IEnumerable<User> entries
)
Parameters
entries (IEnumerable<(Of <( User >)>))
The entries.


FromNames Method (userNames, areAuthenticated)

FromNames Method (userNames, areAuthenticated)
Namespaces ► Sitecore.Security.Accounts ► UserList ► FromNames(IEnumerable<(Of <(String>)>), Boolean)
Instantiate a user from a name.
Declaration Syntax
C#
public static UserList FromNames(
    IEnumerable<string> userNames,
    bool areAuthenticated
)
Parameters
userNames (IEnumerable<(Of <(String>)>))
The user names.
areAuthenticated (Boolean)
if set to true the users have been are authenticated.
Return Value


Names Property

Names Property
Namespaces ► Sitecore.Security.Accounts ► UserList ► Names
Gets the names of all roles in the list.
Declaration Syntax
C#
public virtual StringList Names { get; }
Value
The names.


UserManager Class

UserManager Class
Namespaces ► Sitecore.Security.Accounts ► UserManager
UserManager
Declaration Syntax
C#
public static class UserManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetUserCount()()() | Gets number of users.
 | GetUsers()()() | Gets all users.
 | Provider | Gets the provider.
 | Providers | Gets the providers.
Inheritance Hierarchy
Object
UserManager


GetUserCount Method

GetUserCount Method
Namespaces ► Sitecore.Security.Accounts ► UserManager ► GetUserCount()()()
Gets number of users.
Declaration Syntax
C#
public static int GetUserCount()
Return Value


GetUsers Method

GetUsers Method
Namespaces ► Sitecore.Security.Accounts ► UserManager ► GetUsers()()()
Gets all users.
Declaration Syntax
C#
public static IFilterable<User> GetUsers()
Return Value


Provider Property

Provider Property
Namespaces ► Sitecore.Security.Accounts ► UserManager ► Provider
Gets the provider.
Declaration Syntax
C#
public static UserProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Security.Accounts ► UserManager ► Providers
Gets the providers.
Declaration Syntax
C#
public static UserProviderCollection Providers { get; }
Value
The provider.


UserProvider Class

UserProvider Class
Namespaces ► Sitecore.Security.Accounts ► UserProvider
UserProvider
Declaration Syntax
C#
public class UserProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserProvider()()() | Initializes a new instance of the UserProvider class
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllUsers()()() | Gets all users.
 | GetAllUsers(Int32, Int32) | Gets all users.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserCount()()() | Gets number of users.
 | GetUsers()()() | Gets all users.
 | GetUsersByName(Int32, Int32, String) | Gets all users matching a specific name.
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | UserProvider


UserProvider Constructor

UserProvider Constructor
Namespaces ► Sitecore.Security.Accounts ► UserProvider ► UserProvider()()()
Initializes a new instance of the UserProvider class
Declaration Syntax
C#
public UserProvider()


GetAllUsers Method

GetAllUsers Method
Namespaces ► Sitecore.Security.Accounts ► UserProvider ► GetAllUsers()()()
Members
Icon | Member | Description
 | GetAllUsers()()() | Gets all users.
 | GetAllUsers(Int32, Int32) | Gets all users.


GetAllUsers Method

GetAllUsers Method
Namespaces ► Sitecore.Security.Accounts ► UserProvider ► GetAllUsers()()()
Gets all users.
Declaration Syntax
C#
protected virtual IEnumerable<User> GetAllUsers()
Return Value


GetAllUsers Method (pageIndex, pageSize)

GetAllUsers Method (pageIndex, pageSize)
Namespaces ► Sitecore.Security.Accounts ► UserProvider ► GetAllUsers(Int32, Int32)
Gets all users.
Declaration Syntax
C#
protected virtual IEnumerable<User> GetAllUsers(
    int pageIndex,
    int pageSize
)
Parameters
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
Return Value


GetUserCount Method

GetUserCount Method
Namespaces ► Sitecore.Security.Accounts ► UserProvider ► GetUserCount()()()
Gets number of users.
Declaration Syntax
C#
public virtual int GetUserCount()
Return Value


GetUsers Method

GetUsers Method
Namespaces ► Sitecore.Security.Accounts ► UserProvider ► GetUsers()()()
Gets all users.
Declaration Syntax
C#
public virtual IFilterable<User> GetUsers()
Return Value


GetUsersByName Method (pageIndex, pageSize, userNameToMatch)

GetUsersByName Method (pageIndex, pageSize, userNameToMatch)
Namespaces ► Sitecore.Security.Accounts ► UserProvider ► GetUsersByName(Int32, Int32, String)
Gets all users matching a specific name.
Declaration Syntax
C#
protected virtual IEnumerable<User> GetUsersByName(
    int pageIndex,
    int pageSize,
    string userNameToMatch
)
Parameters
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
userNameToMatch (String)
The (partial) user name to match.
Return Value


UserProviderCollection Class

UserProviderCollection Class
Namespaces ► Sitecore.Security.Accounts ► UserProviderCollection
UserProviderCollection class
Declaration Syntax
C#
public class UserProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserProviderCollection()()() | Initializes a new instance of the UserProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the UserProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | UserProviderCollection


UserProviderCollection Constructor

UserProviderCollection Constructor
Namespaces ► Sitecore.Security.Accounts ► UserProviderCollection ► UserProviderCollection()()()
Initializes a new instance of the UserProviderCollection class
Declaration Syntax
C#
public UserProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Security.Accounts ► UserProviderCollection ► Item[([(String])])
Gets the UserProvider with the specified name.
Declaration Syntax
C#
public virtual UserProvider this[
    string name
] { get; }
Parameters
name (String)
Value


UserRoles Class

UserRoles Class
Namespaces ► Sitecore.Security.Accounts ► UserRoles
UserRoles class
Declaration Syntax
C#
public class UserRoles : IEnumerable<Role>,
    IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserRoles(User) | Initializes a new instance of the UserRoles class.
 | Add(Role) | Adds the specified role to the list of roles of which the user is a member.
 | Contains(Role) | Determines whether the roles collection contains the specified role.
 | Count | Gets the number of roles that the user is member of.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromUser(User) | Creates an instance from a user.
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets the Role with the specified role name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(Role) | Removes the specified role.
 | RemoveAll()()() | Removes all.
 | Replace(IEnumerable<(Of <(Role>)>)) | Replaces the specified roles.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | User | Gets the user.
Inheritance Hierarchy
Object
UserRoles


UserRoles Constructor (user)

UserRoles Constructor (user)
Namespaces ► Sitecore.Security.Accounts ► UserRoles ► UserRoles(User)
Initializes a new instance of the UserRoles class.
Declaration Syntax
C#
protected UserRoles(
    User user
)
Parameters
user (User)


Add Method (role)

Add Method (role)
Namespaces ► Sitecore.Security.Accounts ► UserRoles ► Add(Role)
Adds the specified role to the list of roles of which the user is a member.
Declaration Syntax
C#
public virtual void Add(
    Role role
)
Parameters
role (Role)
The role.


Contains Method (role)

Contains Method (role)
Namespaces ► Sitecore.Security.Accounts ► UserRoles ► Contains(Role)
Determines whether the roles collection contains the specified role.
Declaration Syntax
C#
public virtual bool Contains(
    Role role
)
Parameters
role (Role)
The role.
Return Value
true if the collection contains the specified role; otherwise, false.


Count Property

Count Property
Namespaces ► Sitecore.Security.Accounts ► UserRoles ► Count
Gets the number of roles that the user is member of.
Declaration Syntax
C#
public virtual int Count { get; }
Value
The count.


FromUser Method (user)

FromUser Method (user)
Namespaces ► Sitecore.Security.Accounts ► UserRoles ► FromUser(User)
Creates an instance from a user.
Declaration Syntax
C#
public static UserRoles FromUser(
    User user
)
Parameters
user (User)
The user.
Return Value


GetEnumerator Method

GetEnumerator Method
Namespaces ► Sitecore.Security.Accounts ► UserRoles ► GetEnumerator()()()
Returns an enumerator that iterates through the collection.
Declaration Syntax
C#
public virtual IEnumerator<Role> GetEnumerator()
Return Value
A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.


Item Property (roleName)

Item Property (roleName)
Namespaces ► Sitecore.Security.Accounts ► UserRoles ► Item[([(String])])
Gets the Role with the specified role name.
Declaration Syntax
C#
public virtual Role this[
    string roleName
] { get; }
Parameters
roleName (String)
Value
The role (or null).


Remove Method (role)

Remove Method (role)
Namespaces ► Sitecore.Security.Accounts ► UserRoles ► Remove(Role)
Removes the specified role.
Declaration Syntax
C#
public virtual void Remove(
    Role role
)
Parameters
role (Role)
The role.


RemoveAll Method

RemoveAll Method
Namespaces ► Sitecore.Security.Accounts ► UserRoles ► RemoveAll()()()
Removes all.
Declaration Syntax
C#
public virtual void RemoveAll()


Replace Method (roles)

Replace Method (roles)
Namespaces ► Sitecore.Security.Accounts ► UserRoles ► Replace(IEnumerable<(Of <(Role>)>))
Replaces the specified roles.
Declaration Syntax
C#
public virtual void Replace(
    IEnumerable<Role> roles
)
Parameters
roles (IEnumerable<(Of <( Role >)>))
The roles.


User Property

User Property
Namespaces ► Sitecore.Security.Accounts ► UserRoles ► User
Gets the user.
Declaration Syntax
C#
public virtual User User { get; }
Value
The user.


UserSwitcher Class

UserSwitcher Class
Namespaces ► Sitecore.Security.Accounts ► UserSwitcher
UserSwitcher class
Declaration Syntax
C#
public class UserSwitcher : Switcher<User>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserSwitcher(User) | Initializes a new instance of the UserSwitcher class.
 | UserSwitcher(IPrincipal) | Initializes a new instance of the UserSwitcher class.
 | UserSwitcher(String, Boolean) | Initializes a new instance of the UserSwitcher class.
 | UserSwitcher(String, Boolean, array<String>[]()[]) | Initializes a new instance of the UserSwitcher class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Enter(User) | Enters the specified user.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exit()()() | Exits the current user.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDisposed(Object, EventArgs) | Called when disposed.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | User | Gets the user.
Inheritance Hierarchy
Object
 | Switcher <(Of <( User, User >)>)
 |  | Switcher <(Of <( User >)>)
 |  |  | UserSwitcher


UserSwitcher Constructor

UserSwitcher Constructor
Namespaces ► Sitecore.Security.Accounts ► UserSwitcher ► UserSwitcher()()()
Members
Icon | Member | Description
 | UserSwitcher(User) | Initializes a new instance of the UserSwitcher class.
 | UserSwitcher(IPrincipal) | Initializes a new instance of the UserSwitcher class.
 | UserSwitcher(String, Boolean) | Initializes a new instance of the UserSwitcher class.
 | UserSwitcher(String, Boolean, array<String>[]()[]) | Initializes a new instance of the UserSwitcher class.


UserSwitcher Constructor (user)

UserSwitcher Constructor (user)
Namespaces ► Sitecore.Security.Accounts ► UserSwitcher ► UserSwitcher(User)
Initializes a new instance of the UserSwitcher class.
Declaration Syntax
C#
public UserSwitcher(
    User user
)
Parameters
user (User)
The user object.


UserSwitcher Constructor (user)

UserSwitcher Constructor (user)
Namespaces ► Sitecore.Security.Accounts ► UserSwitcher ► UserSwitcher(IPrincipal)
Initializes a new instance of the UserSwitcher class.
Declaration Syntax
C#
public UserSwitcher(
    IPrincipal user
)
Parameters
user (IPrincipal)
The user principal.


UserSwitcher Constructor (userName, isAuthenticated)

UserSwitcher Constructor (userName, isAuthenticated)
Namespaces ► Sitecore.Security.Accounts ► UserSwitcher ► UserSwitcher(String, Boolean)
Initializes a new instance of the UserSwitcher class.
Declaration Syntax
C#
public UserSwitcher(
    string userName,
    bool isAuthenticated
)
Parameters
userName (String)
Name of the user.
isAuthenticated (Boolean)
If set to true, the user has been authenticated.


UserSwitcher Constructor (userName, isAuthenticated, roles)

UserSwitcher Constructor (userName, isAuthenticated, roles)
Namespaces ► Sitecore.Security.Accounts ► UserSwitcher ► UserSwitcher(String, Boolean, array<String>[]()[])
Initializes a new instance of the UserSwitcher class.
Declaration Syntax
C#
public UserSwitcher(
    string userName,
    bool isAuthenticated,
    string[] roles
)
Parameters
userName (String)
Name of the user.
isAuthenticated (Boolean)
If set to true, the user has been authenticated.
roles (array< String >[]()[])
The roles.


Enter Method (user)

Enter Method (user)
Namespaces ► Sitecore.Security.Accounts ► UserSwitcher ► Enter(User)
Enters the specified user.
Declaration Syntax
C#
public static void Enter(
    User user
)
Parameters
user (User)
The user to be switched to.


Exit Method

Exit Method
Namespaces ► Sitecore.Security.Accounts ► UserSwitcher ► Exit()()()
Exits the current user.
Declaration Syntax
C#
public static void Exit()


OnDisposed Method (sender, args)

OnDisposed Method (sender, args)
Namespaces ► Sitecore.Security.Accounts ► UserSwitcher ► OnDisposed(Object, EventArgs)
Called when disposed.
Declaration Syntax
C#
protected void OnDisposed(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


User Property

User Property
Namespaces ► Sitecore.Security.Accounts ► UserSwitcher ► User
Gets the user.
Declaration Syntax
C#
protected User User { get; }
Value
The user object.


Sitecore.Security.Authentication Namespace

Sitecore.Security.Authentication Namespace
Namespaces ► Sitecore.Security.Authentication
Declaration Syntax
C#
namespace Sitecore.Security.Authentication
Types
All Types Classes
Icon | Type | Description
 | AuthenticationHelper | AuthenticationHelper class
 | AuthenticationManager | Authentication class
 | AuthenticationProvider | AuthenticationProvider class
 | AuthenticationProviderCollection | AuthenticationProviderCollection class
 | AuthenticationSwitcher | AuthenticationSwitcher class
 | FormsAuthenticationProvider | FormsAuthenticationProvider
 | MembershipAuthenticationProvider | MembershipAuthenticationProvider class
 | SwitchingAuthenticationProvider | SitecoreAuthenticationProvider class


AuthenticationHelper Class

AuthenticationHelper Class
Namespaces ► Sitecore.Security.Authentication ► AuthenticationHelper
AuthenticationHelper class
Declaration Syntax
C#
public class AuthenticationHelper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AuthenticationHelper(AuthenticationProvider) | Initializes a new instance of the AuthenticationHelper class.
 | CheckLegacyPassword(User, String) | Checks the legacy password, converts it to the new format.
 | EnsureActiveUser(User) | Ensures the active user.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetActiveUser()()() | Gets the active user.
 | GetCurrentUser()()() | Gets the name of the current user.
 | GetDefaultUser()()() | Gets the default user.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPasswordHashes(String) | Gets the password hashes.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Provider | Gets the provider.
 | SetActiveUser(String) | Sets the active user.
 | SetActiveUser(User) | Sets the active user.
 | SetAnonymousUserActive()()() | Sets the anonymous user active.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateUser(String, String) | Validates a user.
Inheritance Hierarchy
Object
AuthenticationHelper


AuthenticationHelper Constructor (provider)

AuthenticationHelper Constructor (provider)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationHelper ► AuthenticationHelper(AuthenticationProvider)
Initializes a new instance of the AuthenticationHelper class.
Declaration Syntax
C#
public AuthenticationHelper(
    AuthenticationProvider provider
)
Parameters
provider (AuthenticationProvider)
The provider.


CheckLegacyPassword Method (user, password)

CheckLegacyPassword Method (user, password)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationHelper ► CheckLegacyPassword(User, String)
Checks the legacy password, converts it to the new format.
Declaration Syntax
C#
public virtual bool CheckLegacyPassword(
    User user,
    string password
)
Parameters
user (User)
The user.
password (String)
The password.
Return Value
true, if user have a legacy password


EnsureActiveUser Method (user)

EnsureActiveUser Method (user)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationHelper ► EnsureActiveUser(User)
Ensures the active user.
Declaration Syntax
C#
protected void EnsureActiveUser(
    User user
)
Parameters
user (User)
The user object.


GetActiveUser Method

GetActiveUser Method
Namespaces ► Sitecore.Security.Authentication ► AuthenticationHelper ► GetActiveUser()()()
Gets the active user.
Declaration Syntax
C#
public virtual User GetActiveUser()
Return Value
Active User.


GetCurrentUser Method

GetCurrentUser Method
Namespaces ► Sitecore.Security.Authentication ► AuthenticationHelper ► GetCurrentUser()()()
Gets the name of the current user.
Declaration Syntax
C#
protected User GetCurrentUser()
Return Value
Current user. Null if user is not defined (anonymous).


GetDefaultUser Method

GetDefaultUser Method
Namespaces ► Sitecore.Security.Authentication ► AuthenticationHelper ► GetDefaultUser()()()
Gets the default user.
Declaration Syntax
C#
protected User GetDefaultUser()
Return Value


GetPasswordHashes Method (password)

GetPasswordHashes Method (password)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationHelper ► GetPasswordHashes(String)
Gets the password hashes.
Declaration Syntax
C#
protected virtual string[] GetPasswordHashes(
    string password
)
Parameters
password (String)
The password.
Return Value


Provider Property

Provider Property
Namespaces ► Sitecore.Security.Authentication ► AuthenticationHelper ► Provider
Gets the provider.
Declaration Syntax
C#
protected virtual AuthenticationProvider Provider { get; }
Value
The provider.


SetActiveUser Method

SetActiveUser Method
Namespaces ► Sitecore.Security.Authentication ► AuthenticationHelper ► SetActiveUser()()()
Members
Icon | Member | Description
 | SetActiveUser(String) | Sets the active user.
 | SetActiveUser(User) | Sets the active user.


SetActiveUser Method (user)

SetActiveUser Method (user)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationHelper ► SetActiveUser(User)
Sets the active user.
Declaration Syntax
C#
public virtual void SetActiveUser(
    User user
)
Parameters
user (User)
The user object.


SetActiveUser Method (userName)

SetActiveUser Method (userName)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationHelper ► SetActiveUser(String)
Sets the active user.
Declaration Syntax
C#
public virtual void SetActiveUser(
    string userName
)
Parameters
userName (String)
Name of the user.


SetAnonymousUserActive Method

SetAnonymousUserActive Method
Namespaces ► Sitecore.Security.Authentication ► AuthenticationHelper ► SetAnonymousUserActive()()()
Sets the anonymous user active.
Declaration Syntax
C#
public virtual void SetAnonymousUserActive()


ValidateUser Method (userName, password)

ValidateUser Method (userName, password)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationHelper ► ValidateUser(String, String)
Validates a user.
Declaration Syntax
C#
public virtual bool ValidateUser(
    string userName,
    string password
)
Parameters
userName (String)
Name of the user.
password (String)
The password.
Return Value
true if user is valid, otherwice - false.


AuthenticationManager Class

AuthenticationManager Class
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager
Authentication class
Declaration Syntax
C#
public static class AuthenticationManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BuildVirtualUser(String, Boolean) | Builds a virtual user.
 | CheckLegacyPassword(User, String) | Checks the legacy password, converts it to the new format.
 | GetActiveUser()()() | Gets the active user.
 | Login(User) | Logs a user into the system without checking a password.
 | Login(String) | Logs a user into the system without checking a password.
 | Login(String, String) | Logs a user into the system if the password is valid.
 | Login(String, Boolean) | Logs a user into the system without checking a password.
 | Login(String, String, Boolean) | Logs a user into the system if the password is valid.
 | Logout()()() | Logs out the current user.
 | Provider | Gets the provider.
 | Providers | Gets all providers.
 | SetActiveUser(String) | Sets the active user.
 | SetActiveUser(User) | Sets the active user.
Inheritance Hierarchy
Object
AuthenticationManager


BuildVirtualUser Method (userName, isAuthenticated)

BuildVirtualUser Method (userName, isAuthenticated)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► BuildVirtualUser(String, Boolean)
Builds a virtual user.
Declaration Syntax
C#
public static User BuildVirtualUser(
    string userName,
    bool isAuthenticated
)
Parameters
userName (String)
Name of the user.
isAuthenticated (Boolean)
If set to true, consider the user as authenticated.
Return Value
The virtual user.


CheckLegacyPassword Method (user, password)

CheckLegacyPassword Method (user, password)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► CheckLegacyPassword(User, String)
Checks the legacy password, converts it to the new format.
Declaration Syntax
C#
public static bool CheckLegacyPassword(
    User user,
    string password
)
Parameters
user (User)
The user object.
password (String)
The password.
Return Value
True, if user had a format in the old representation.


GetActiveUser Method

GetActiveUser Method
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► GetActiveUser()()()
Gets the active user.
Declaration Syntax
C#
public static User GetActiveUser()
Return Value
Active User.


Login Method

Login Method
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► Login()()()
Members
Icon | Member | Description
 | Login(User) | Logs a user into the system without checking a password.
 | Login(String) | Logs a user into the system without checking a password.
 | Login(String, String) | Logs a user into the system if the password is valid.
 | Login(String, Boolean) | Logs a user into the system without checking a password.
 | Login(String, String, Boolean) | Logs a user into the system if the password is valid.


Login Method (user)

Login Method (user)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► Login(User)
Logs a user into the system without checking a password.
Declaration Syntax
C#
public static bool Login(
    User user
)
Parameters
user (User)
The user.
Return Value


Login Method (userName)

Login Method (userName)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► Login(String)
Logs a user into the system without checking a password.
Declaration Syntax
C#
public static bool Login(
    string userName
)
Parameters
userName (String)
Name of the user.
Return Value
true if user was logged in, otherwise - false.


Login Method (userName, persistent)

Login Method (userName, persistent)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► Login(String, Boolean)
Logs a user into the system without checking a password.
Declaration Syntax
C#
public static bool Login(
    string userName,
    bool persistent
)
Parameters
userName (String)
Name of the user.
persistent (Boolean)
If set to true (and the provider supports it), the login will be persisted.
Return Value
true if user was logged in, otherwise - false.


Login Method (userName, password)

Login Method (userName, password)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► Login(String, String)
Logs a user into the system if the password is valid.
Declaration Syntax
C#
public static bool Login(
    string userName,
    string password
)
Parameters
userName (String)
Name of the user.
password (String)
The password.
Return Value
true if user was logged in, otherwise - false.


Login Method (userName, password, persistent)

Login Method (userName, password, persistent)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► Login(String, String, Boolean)
Logs a user into the system if the password is valid.
Declaration Syntax
C#
public static bool Login(
    string userName,
    string password,
    bool persistent
)
Parameters
userName (String)
Name of the user.
password (String)
The password.
persistent (Boolean)
If set to true (and the provider supports it), the login will be persisted.
Return Value
true if user was logged in, otherwise - false.


Logout Method

Logout Method
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► Logout()()()
Logs out the current user.
Declaration Syntax
C#
public static void Logout()


Provider Property

Provider Property
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► Provider
Gets the provider.
Declaration Syntax
C#
public static AuthenticationProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► Providers
Gets all providers.
Declaration Syntax
C#
public static AuthenticationProviderCollection Providers { get; }
Value
The providers.


SetActiveUser Method

SetActiveUser Method
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► SetActiveUser()()()
Members
Icon | Member | Description
 | SetActiveUser(String) | Sets the active user.
 | SetActiveUser(User) | Sets the active user.


SetActiveUser Method (user)

SetActiveUser Method (user)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► SetActiveUser(User)
Sets the active user.
Declaration Syntax
C#
public static void SetActiveUser(
    User user
)
Parameters
user (User)
The user object.


SetActiveUser Method (userName)

SetActiveUser Method (userName)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationManager ► SetActiveUser(String)
Sets the active user.
Declaration Syntax
C#
public static void SetActiveUser(
    string userName
)
Parameters
userName (String)
Name of the user.


AuthenticationProvider Class

AuthenticationProvider Class
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider
AuthenticationProvider class
Declaration Syntax
C#
public abstract class AuthenticationProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AuthenticationProvider()()() | Initializes a new instance of the AuthenticationProvider class
 | BuildVirtualUser(String, Boolean) | Builds a virtual user.
 | CheckLegacyPassword(User, String) | Checks the legacy password, converts it to the new format.
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetActiveUser()()() | Gets the active user.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Helper | Gets the helper object.
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | Login(User) | Logs in the specified user.
 | Login(String, String, Boolean) | Logs the specified user into the system.
 | Login(String, Boolean) | Logs the specified user into the system without checking password.
 | Logout()()() | Logs out the current user.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | SetActiveUser(String) | Sets the active user.
 | SetActiveUser(User) | Sets the active user.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | AuthenticationProvider
 |  |  | MembershipAuthenticationProvider
 |  |  | SwitchingAuthenticationProvider


AuthenticationProvider Constructor

AuthenticationProvider Constructor
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider ► AuthenticationProvider()()()
Initializes a new instance of the AuthenticationProvider class
Declaration Syntax
C#
protected AuthenticationProvider()


BuildVirtualUser Method (userName, isAuthenticated)

BuildVirtualUser Method (userName, isAuthenticated)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider ► BuildVirtualUser(String, Boolean)
Builds a virtual user.
Declaration Syntax
C#
public virtual User BuildVirtualUser(
    string userName,
    bool isAuthenticated
)
Parameters
userName (String)
Name of the user.
isAuthenticated (Boolean)
If set to true, consider the user as authenticated.
Return Value
The virtual user.


CheckLegacyPassword Method (user, password)

CheckLegacyPassword Method (user, password)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider ► CheckLegacyPassword(User, String)
Checks the legacy password, converts it to the new format.
Declaration Syntax
C#
public virtual bool CheckLegacyPassword(
    User user,
    string password
)
Parameters
user (User)
The user object.
password (String)
The password.
Return Value
True, if user had a format in the old representation.


GetActiveUser Method

GetActiveUser Method
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider ► GetActiveUser()()()
Gets the active user.
Declaration Syntax
C#
public virtual User GetActiveUser()
Return Value
Active User.


Helper Property

Helper Property
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider ► Helper
Gets the helper object.
Declaration Syntax
C#
protected virtual AuthenticationHelper Helper { get; }
Value
The helper.


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.
ArgumentException | The name of the provider has a length of zero.


Login Method

Login Method
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider ► Login()()()
Members
Icon | Member | Description
 | Login(User) | Logs in the specified user.
 | Login(String, String, Boolean) | Logs the specified user into the system.
 | Login(String, Boolean) | Logs the specified user into the system without checking password.


Login Method (user)

Login Method (user)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider ► Login(User)
Logs in the specified user.
Declaration Syntax
C#
public abstract bool Login(
    User user
)
Parameters
user (User)
The user.
Return Value


Login Method (userName, persistent)

Login Method (userName, persistent)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider ► Login(String, Boolean)
Logs the specified user into the system without checking password.
Declaration Syntax
C#
public abstract bool Login(
    string userName,
    bool persistent
)
Parameters
userName (String)
Name of the user.
persistent (Boolean)
If set to true (and the provider supports it), the login will be persisted.
Return Value
true if user was logged in. Otherwise false.


Login Method (userName, password, persistent)

Login Method (userName, password, persistent)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider ► Login(String, String, Boolean)
Logs the specified user into the system.
Declaration Syntax
C#
public abstract bool Login(
    string userName,
    string password,
    bool persistent
)
Parameters
userName (String)
Name of the user.
password (String)
The password.
persistent (Boolean)
If set to true (and the provider supports it), the login will be persisted.
Return Value
true if user was logged in. Otherwise false.


Logout Method

Logout Method
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider ► Logout()()()
Logs out the current user.
Declaration Syntax
C#
public abstract void Logout()


SetActiveUser Method

SetActiveUser Method
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider ► SetActiveUser()()()
Members
Icon | Member | Description
 | SetActiveUser(String) | Sets the active user.
 | SetActiveUser(User) | Sets the active user.


SetActiveUser Method (user)

SetActiveUser Method (user)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider ► SetActiveUser(User)
Sets the active user.
Declaration Syntax
C#
public abstract void SetActiveUser(
    User user
)
Parameters
user (User)
The user object.


SetActiveUser Method (userName)

SetActiveUser Method (userName)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProvider ► SetActiveUser(String)
Sets the active user.
Declaration Syntax
C#
public abstract void SetActiveUser(
    string userName
)
Parameters
userName (String)
Name of the user.


AuthenticationProviderCollection Class

AuthenticationProviderCollection Class
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProviderCollection
AuthenticationProviderCollection class
Declaration Syntax
C#
public class AuthenticationProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AuthenticationProviderCollection()()() | Initializes a new instance of the AuthenticationProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the AuthenticationProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | AuthenticationProviderCollection


AuthenticationProviderCollection Constructor

AuthenticationProviderCollection Constructor
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProviderCollection ► AuthenticationProviderCollection()()()
Initializes a new instance of the AuthenticationProviderCollection class
Declaration Syntax
C#
public AuthenticationProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationProviderCollection ► Item[([(String])])
Gets the AuthenticationProvider with the specified name.
Declaration Syntax
C#
public virtual AuthenticationProvider this[
    string name
] { get; }
Parameters
name (String)
Value


AuthenticationSwitcher Class

AuthenticationSwitcher Class
Namespaces ► Sitecore.Security.Authentication ► AuthenticationSwitcher
AuthenticationSwitcher class
Declaration Syntax
C#
public class AuthenticationSwitcher : Switcher<AuthenticationProvider>
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AuthenticationSwitcher(AuthenticationProvider) | Initializes a new instance of the AuthenticationSwitcher class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <( AuthenticationProvider, AuthenticationProvider >)>)
 |  | Switcher <(Of <( AuthenticationProvider >)>)
 |  |  | AuthenticationSwitcher


AuthenticationSwitcher Constructor (provider)

AuthenticationSwitcher Constructor (provider)
Namespaces ► Sitecore.Security.Authentication ► AuthenticationSwitcher ► AuthenticationSwitcher(AuthenticationProvider)
Initializes a new instance of the AuthenticationSwitcher class.
Declaration Syntax
C#
public AuthenticationSwitcher(
    AuthenticationProvider provider
)
Parameters
provider (AuthenticationProvider)
The provider.


FormsAuthenticationProvider Class

FormsAuthenticationProvider Class
Namespaces ► Sitecore.Security.Authentication ► FormsAuthenticationProvider
FormsAuthenticationProvider
Declaration Syntax
C#
public class FormsAuthenticationProvider : MembershipAuthenticationProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FormsAuthenticationProvider()()() | Initializes a new instance of the FormsAuthenticationProvider class
 | BuildVirtualUser(String, Boolean) | Builds a virtual user. (Inherited from AuthenticationProvider.)
 | CheckLegacyPassword(User, String) | Checks the legacy password, converts it to the new format. (Inherited from AuthenticationProvider.)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetActiveUser()()() | Gets the active user. (Inherited from AuthenticationProvider.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Helper | Gets the helper object. (Inherited from AuthenticationProvider.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from AuthenticationProvider.)
 | Login(String, Boolean) | Logs the specified user into the system. (Overrides MembershipAuthenticationProvider.Login(String, Boolean).)
 | Login(User) | Logs the specified user into the system. (Overrides MembershipAuthenticationProvider.Login(User).)
 | Login(String, String, Boolean) | Logs the specified user into the system if the password is valid. (Inherited from MembershipAuthenticationProvider.)
 | Logout()()() | Logs out the current user. (Overrides MembershipAuthenticationProvider.Logout()()().)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | SetActiveUser(String) | Sets the active user. (Inherited from MembershipAuthenticationProvider.)
 | SetActiveUser(User) | Sets the active user. (Inherited from MembershipAuthenticationProvider.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | AuthenticationProvider
 |  |  | MembershipAuthenticationProvider
 |  |  |  | FormsAuthenticationProvider


FormsAuthenticationProvider Constructor

FormsAuthenticationProvider Constructor
Namespaces ► Sitecore.Security.Authentication ► FormsAuthenticationProvider ► FormsAuthenticationProvider()()()
Initializes a new instance of the FormsAuthenticationProvider class
Declaration Syntax
C#
public FormsAuthenticationProvider()


Login Method

Login Method
Namespaces ► Sitecore.Security.Authentication ► FormsAuthenticationProvider ► Login()()()
Members
Icon | Member | Description
 | Login(String, Boolean) | Logs the specified user into the system. (Overrides MembershipAuthenticationProvider.Login(String, Boolean).)
 | Login(User) | Logs the specified user into the system. (Overrides MembershipAuthenticationProvider.Login(User).)
 | Login(String, String, Boolean) | Logs the specified user into the system if the password is valid. (Overrides AuthenticationProvider.Login(String, String, Boolean).)


Login Method (user)

Login Method (user)
Namespaces ► Sitecore.Security.Authentication ► FormsAuthenticationProvider ► Login(User)
Logs the specified user into the system.
Declaration Syntax
C#
public override bool Login(
    User user
)
Parameters
user (User)
The user.
Return Value


Login Method (userName, persistent)

Login Method (userName, persistent)
Namespaces ► Sitecore.Security.Authentication ► FormsAuthenticationProvider ► Login(String, Boolean)
Logs the specified user into the system.
Declaration Syntax
C#
public override bool Login(
    string userName,
    bool persistent
)
Parameters
userName (String)
Name of the user.
persistent (Boolean)
If set to true (and the provider supports it), the login will be persisted.
Return Value


Logout Method

Logout Method
Namespaces ► Sitecore.Security.Authentication ► FormsAuthenticationProvider ► Logout()()()
Logs out the current user.
Declaration Syntax
C#
public override void Logout()


MembershipAuthenticationProvider Class

MembershipAuthenticationProvider Class
Namespaces ► Sitecore.Security.Authentication ► MembershipAuthenticationProvider
MembershipAuthenticationProvider class
Declaration Syntax
C#
public class MembershipAuthenticationProvider : AuthenticationProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MembershipAuthenticationProvider()()() | Initializes a new instance of the MembershipAuthenticationProvider class
 | BuildVirtualUser(String, Boolean) | Builds a virtual user. (Inherited from AuthenticationProvider.)
 | CheckLegacyPassword(User, String) | Checks the legacy password, converts it to the new format. (Inherited from AuthenticationProvider.)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetActiveUser()()() | Gets the active user. (Inherited from AuthenticationProvider.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Helper | Gets the helper object. (Inherited from AuthenticationProvider.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from AuthenticationProvider.)
 | Login(String, Boolean) | Logs the specified user into the system without checking password. (Overrides AuthenticationProvider.Login(String, Boolean).)
 | Login(User) | Logs in the specified user. (Overrides AuthenticationProvider.Login(User).)
 | Login(String, String, Boolean) | Logs the specified user into the system if the password is valid. (Overrides AuthenticationProvider.Login(String, String, Boolean).)
 | Logout()()() | Logs out the current user. (Overrides AuthenticationProvider.Logout()()().)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | SetActiveUser(String) | Sets the active user. (Overrides AuthenticationProvider.SetActiveUser(String).)
 | SetActiveUser(User) | Sets the active user. (Overrides AuthenticationProvider.SetActiveUser(User).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | AuthenticationProvider
 |  |  | MembershipAuthenticationProvider
 |  |  |  | FormsAuthenticationProvider


MembershipAuthenticationProvider Constructor

MembershipAuthenticationProvider Constructor
Namespaces ► Sitecore.Security.Authentication ► MembershipAuthenticationProvider ► MembershipAuthenticationProvider()()()
Initializes a new instance of the MembershipAuthenticationProvider class
Declaration Syntax
C#
public MembershipAuthenticationProvider()


Login Method

Login Method
Namespaces ► Sitecore.Security.Authentication ► MembershipAuthenticationProvider ► Login()()()
Members
Icon | Member | Description
 | Login(String, Boolean) | Logs the specified user into the system without checking password. (Overrides AuthenticationProvider.Login(String, Boolean).)
 | Login(User) | Logs in the specified user. (Overrides AuthenticationProvider.Login(User).)
 | Login(String, String, Boolean) | Logs the specified user into the system if the password is valid. (Overrides AuthenticationProvider.Login(String, String, Boolean).)


Login Method (user)

Login Method (user)
Namespaces ► Sitecore.Security.Authentication ► MembershipAuthenticationProvider ► Login(User)
Logs in the specified user.
Declaration Syntax
C#
public override bool Login(
    User user
)
Parameters
user (User)
The user.
Return Value


Login Method (userName, persistent)

Login Method (userName, persistent)
Namespaces ► Sitecore.Security.Authentication ► MembershipAuthenticationProvider ► Login(String, Boolean)
Logs the specified user into the system without checking password.
Declaration Syntax
C#
public override bool Login(
    string userName,
    bool persistent
)
Parameters
userName (String)
Name of the user.
persistent (Boolean)
If set to true (and the provider supports it), the login will be persisted.
Return Value


Login Method (userName, password, persistent)

Login Method (userName, password, persistent)
Namespaces ► Sitecore.Security.Authentication ► MembershipAuthenticationProvider ► Login(String, String, Boolean)
Logs the specified user into the system if the password is valid.
Declaration Syntax
C#
public override bool Login(
    string userName,
    string password,
    bool persistent
)
Parameters
userName (String)
Name of the user.
password (String)
The password.
persistent (Boolean)
If set to true (and the provider supports it), the login will be persisted.
Return Value


Logout Method

Logout Method
Namespaces ► Sitecore.Security.Authentication ► MembershipAuthenticationProvider ► Logout()()()
Logs out the current user.
Declaration Syntax
C#
public override void Logout()


SetActiveUser Method

SetActiveUser Method
Namespaces ► Sitecore.Security.Authentication ► MembershipAuthenticationProvider ► SetActiveUser()()()
Members
Icon | Member | Description
 | SetActiveUser(String) | Sets the active user. (Overrides AuthenticationProvider.SetActiveUser(String).)
 | SetActiveUser(User) | Sets the active user. (Overrides AuthenticationProvider.SetActiveUser(User).)


SetActiveUser Method (user)

SetActiveUser Method (user)
Namespaces ► Sitecore.Security.Authentication ► MembershipAuthenticationProvider ► SetActiveUser(User)
Sets the active user.
Declaration Syntax
C#
public override void SetActiveUser(
    User user
)
Parameters
user (User)
The user object.


SetActiveUser Method (userName)

SetActiveUser Method (userName)
Namespaces ► Sitecore.Security.Authentication ► MembershipAuthenticationProvider ► SetActiveUser(String)
Sets the active user.
Declaration Syntax
C#
public override void SetActiveUser(
    string userName
)
Parameters
userName (String)
Name of the user.


SwitchingAuthenticationProvider Class

SwitchingAuthenticationProvider Class
Namespaces ► Sitecore.Security.Authentication ► SwitchingAuthenticationProvider
SitecoreAuthenticationProvider class
Declaration Syntax
C#
public class SwitchingAuthenticationProvider : AuthenticationProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SwitchingAuthenticationProvider()()() | Initializes a new instance of the SwitchingAuthenticationProvider class
 | BuildVirtualUser(String, Boolean) | Builds a virtual user. (Inherited from AuthenticationProvider.)
 | CheckLegacyPassword(User, String) | Checks the legacy password, converts it to the new format. (Inherited from AuthenticationProvider.)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetActiveUser()()() | Gets the active user. (Inherited from AuthenticationProvider.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Helper | Gets the helper object. (Inherited from AuthenticationProvider.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides AuthenticationProvider.Initialize(String, NameValueCollection).)
 | Login(User) | Logs the specified user into the system without checking password. (Overrides AuthenticationProvider.Login(User).)
 | Login(String, Boolean) | Logs the specified user into the system without checking password. (Overrides AuthenticationProvider.Login(String, Boolean).)
 | Login(String, String, Boolean) | Logs the specified user into the system. (Overrides AuthenticationProvider.Login(String, String, Boolean).)
 | Logout()()() | Logs out the current user. (Overrides AuthenticationProvider.Logout()()().)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | SetActiveUser(String) | Sets the active user. (Overrides AuthenticationProvider.SetActiveUser(String).)
 | SetActiveUser(User) | Sets the active user. (Overrides AuthenticationProvider.SetActiveUser(User).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | AuthenticationProvider
 |  |  | SwitchingAuthenticationProvider


SwitchingAuthenticationProvider Constructor

SwitchingAuthenticationProvider Constructor
Namespaces ► Sitecore.Security.Authentication ► SwitchingAuthenticationProvider ► SwitchingAuthenticationProvider()()()
Initializes a new instance of the SwitchingAuthenticationProvider class
Declaration Syntax
C#
public SwitchingAuthenticationProvider()


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Security.Authentication ► SwitchingAuthenticationProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.
ArgumentException | The name of the provider has a length of zero.


Login Method

Login Method
Namespaces ► Sitecore.Security.Authentication ► SwitchingAuthenticationProvider ► Login()()()
Members
Icon | Member | Description
 | Login(User) | Logs the specified user into the system without checking password. (Overrides AuthenticationProvider.Login(User).)
 | Login(String, Boolean) | Logs the specified user into the system without checking password. (Overrides AuthenticationProvider.Login(String, Boolean).)
 | Login(String, String, Boolean) | Logs the specified user into the system. (Overrides AuthenticationProvider.Login(String, String, Boolean).)


Login Method (user)

Login Method (user)
Namespaces ► Sitecore.Security.Authentication ► SwitchingAuthenticationProvider ► Login(User)
Logs the specified user into the system without checking password.
Declaration Syntax
C#
public override bool Login(
    User user
)
Parameters
user (User)
The user.
Return Value


Login Method (userName, persistent)

Login Method (userName, persistent)
Namespaces ► Sitecore.Security.Authentication ► SwitchingAuthenticationProvider ► Login(String, Boolean)
Logs the specified user into the system without checking password.
Declaration Syntax
C#
public override bool Login(
    string userName,
    bool persistent
)
Parameters
userName (String)
Name of the user.
persistent (Boolean)
If set to true (and the provider supports it), the login will be persisted.
Return Value


Login Method (userName, password, persistent)

Login Method (userName, password, persistent)
Namespaces ► Sitecore.Security.Authentication ► SwitchingAuthenticationProvider ► Login(String, String, Boolean)
Logs the specified user into the system.
Declaration Syntax
C#
public override bool Login(
    string userName,
    string password,
    bool persistent
)
Parameters
userName (String)
Name of the user.
password (String)
The password.
persistent (Boolean)
If set to true (and the provider supports it), the login will be persisted.
Return Value


Logout Method

Logout Method
Namespaces ► Sitecore.Security.Authentication ► SwitchingAuthenticationProvider ► Logout()()()
Logs out the current user.
Declaration Syntax
C#
public override void Logout()


SetActiveUser Method

SetActiveUser Method
Namespaces ► Sitecore.Security.Authentication ► SwitchingAuthenticationProvider ► SetActiveUser()()()
Members
Icon | Member | Description
 | SetActiveUser(String) | Sets the active user. (Overrides AuthenticationProvider.SetActiveUser(String).)
 | SetActiveUser(User) | Sets the active user. (Overrides AuthenticationProvider.SetActiveUser(User).)


SetActiveUser Method (user)

SetActiveUser Method (user)
Namespaces ► Sitecore.Security.Authentication ► SwitchingAuthenticationProvider ► SetActiveUser(User)
Sets the active user.
Declaration Syntax
C#
public override void SetActiveUser(
    User user
)
Parameters
user (User)
The user.


SetActiveUser Method (userName)

SetActiveUser Method (userName)
Namespaces ► Sitecore.Security.Authentication ► SwitchingAuthenticationProvider ► SetActiveUser(String)
Sets the active user.
Declaration Syntax
C#
public override void SetActiveUser(
    string userName
)
Parameters
userName (String)
Name of the user.


Sitecore.Security.Domains Namespace

Sitecore.Security.Domains Namespace
Namespaces ► Sitecore.Security.Domains
Declaration Syntax
C#
namespace Sitecore.Security.Domains
Types
All Types Classes
Icon | Type | Description
 | ConfigStoreDomainProvider | ConfigDomainProvider class
 | Domain | Represents a domain.
 | DomainConfiguration | DomainConfig class
 | DomainList | DomainList class
 | DomainRecord | DomainRecord class


ConfigStoreDomainProvider Class

ConfigStoreDomainProvider Class
Namespaces ► Sitecore.Security.Domains ► ConfigStoreDomainProvider
ConfigDomainProvider class
Declaration Syntax
C#
public class ConfigStoreDomainProvider : DomainProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigStoreDomainProvider()()() | Initializes a new instance of the ConfigStoreDomainProvider class
 | AddDomain(String, Boolean) | Adds a new domain to the system. (Overrides DomainProvider.AddDomain(String, Boolean).)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | DomainExists(String) | Determines if a domain with the specified name exists. (Inherited from DomainProvider.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConfiguration()()() | Gets the configuration. (Overrides DomainProvider.GetConfiguration()()().)
 | GetDefaultDomain()()() | Gets the default domain. (Overrides DomainProvider.GetDefaultDomain()()().)
 | GetDomain(String) | Gets a named domain. (Overrides DomainProvider.GetDomain(String).)
 | GetDomainNames()()() | Gets the domain names. (Inherited from DomainProvider.)
 | GetDomains()()() | Gets all domains handled by the provider. (Overrides DomainProvider.GetDomains()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | RemoveDomain(String) | Removes an existing domain from the system. (Overrides DomainProvider.RemoveDomain(String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | DomainProvider
 |  |  | ConfigStoreDomainProvider


ConfigStoreDomainProvider Constructor

ConfigStoreDomainProvider Constructor
Namespaces ► Sitecore.Security.Domains ► ConfigStoreDomainProvider ► ConfigStoreDomainProvider()()()
Initializes a new instance of the ConfigStoreDomainProvider class
Declaration Syntax
C#
public ConfigStoreDomainProvider()


AddDomain Method (domainName, locallyManaged)

AddDomain Method (domainName, locallyManaged)
Namespaces ► Sitecore.Security.Domains ► ConfigStoreDomainProvider ► AddDomain(String, Boolean)
Adds a new domain to the system.
Declaration Syntax
C#
public override void AddDomain(
    string domainName,
    bool locallyManaged
)
Parameters
domainName (String)
Name of the domain.
locallyManaged (Boolean)
If set to true, the domain is locally managed.


GetConfiguration Method

GetConfiguration Method
Namespaces ► Sitecore.Security.Domains ► ConfigStoreDomainProvider ► GetConfiguration()()()
Gets the configuration.
Declaration Syntax
C#
public override DomainConfiguration GetConfiguration()
Return Value


GetDefaultDomain Method

GetDefaultDomain Method
Namespaces ► Sitecore.Security.Domains ► ConfigStoreDomainProvider ► GetDefaultDomain()()()
Gets the default domain.
Declaration Syntax
C#
public override Domain GetDefaultDomain()


GetDomain Method (name)

GetDomain Method (name)
Namespaces ► Sitecore.Security.Domains ► ConfigStoreDomainProvider ► GetDomain(String)
Gets a named domain.
Declaration Syntax
C#
public override Domain GetDomain(
    string name
)
Parameters
name (String)


GetDomains Method

GetDomains Method
Namespaces ► Sitecore.Security.Domains ► ConfigStoreDomainProvider ► GetDomains()()()
Gets all domains handled by the provider.
Declaration Syntax
C#
public override IEnumerable<Domain> GetDomains()


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Security.Domains ► ConfigStoreDomainProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.
ArgumentException | The name of the provider has a length of zero.


RemoveDomain Method (domainName)

RemoveDomain Method (domainName)
Namespaces ► Sitecore.Security.Domains ► ConfigStoreDomainProvider ► RemoveDomain(String)
Removes an existing domain from the system.
Declaration Syntax
C#
public override void RemoveDomain(
    string domainName
)
Parameters
domainName (String)
Name of the domain.


Domain Class

Domain Class
Namespaces ► Sitecore.Security.Domains ► Domain
Represents a domain.
Declaration Syntax
C#
public class Domain : IEquatable<Domain>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Domain()()() | Initializes a new instance of the Domain class.
 | Domain(String) | Initializes a new instance of the Domain class.
 | AccountNameValidation | Gets the account name validation (regex).
 | AccountPrefix | Gets the account prefix (i.e. Name\).
 | AnonymousUserEmailPattern | Gets or sets the anonymous user email pattern.
 | AnonymousUserName | Gets or sets the name of the 'anonymous' user. Empty string if the feature is not supported by the domain.
 | Appearance | Gets the appearance.
 | CreateAnonymousUser()()() | Creates the anonymous user in the Membership database.
 | CreateAnonymousUserIfNeeded()()() | Creates the anonymous user if needed.
 | Current | Gets the current/active domain.
 | DefaultProfileItemID | Gets the default profile item ID.
 | EnsureAnonymousUser | Gets a value indicating whether to ensure that an anonymous user exists for the domain.
 | Equality(Domain, Domain) | Implements the operator ==.
 | Equals(Domain) | Equals implementation.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)
 | EveryoneRoleName | Gets or sets the name of the 'everyone' role. Empty string if the feature is not supported by the domain.
 | ExtractDomainName(String) | Extracts the name of the domain from a full account name.
 | ExtractShortName(String) | Extracts the short name of an account from a full account name.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccountDomain(String) | Finds the domain of a specific account.
 | GetAccounts()()() | Gets all accounts in the domain.
 | GetAnonymousUser()()() | Gets the anonymous user.
 | GetDefaultAnonymousUser()()() | Gets the default anonymous user.
 | GetDefaultDomain()()() | Gets the default domain.
 | GetDomain(String) | Gets a domain from its name.
 | GetEveryoneRole()()() | Gets the everyone role.
 | GetFullName(String) | Gets the full-name corresponding to an account name (i.e. the short name prefixed by the domain name).
 | GetFullName(String, Boolean) | Gets the full-name corresponding to an account name (i.e. the short name prefixed by the domain name).
 | GetHashCode()()() | Serves as a hash function for a particular type. (Overrides Object.GetHashCode()()().)
 | GetRoles()()() | Gets all roles in the domain.
 | GetShortName(String) | Gets the short-name corresponding to an account name (i.e. the account name without the domain name prefix).
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserCount()()() | Gets the number of users in the domain.
 | GetUsers()()() | Gets all users in the domain.
 | GetUsers(Int32, Int32) | Gets a specific page of users in the domain.
 | HandlesAccount(String) | Determines if the domain handles a specific user (identified by name).
 | Inequality(Domain, Domain) | Implements the operator !=.
 | IsAnonymousUser(String) | Determines whether the specified account name represents the 'anonymous' user for the domain.
 | IsDefault | Gets a value indicating whether this instance is default.
 | IsEveryoneRole(String) | Determines whether the specified account name represents the everyone role for the domain.
 | IsFullName(String) | Determines if a specific account name is fully qualified (i.e. is prefixed with the domain name).
 | IsValidAccountName(String) | Determines whether the specified account name is valid.
 | LocallyManaged | Gets or sets a value indicating whether the domain is locally managed.
 | MemberPattern | Gets the pattern string for members of this domain.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
Domain


Domain Constructor

Domain Constructor
Namespaces ► Sitecore.Security.Domains ► Domain ► Domain()()()
Members
Icon | Member | Description
 | Domain()()() | Initializes a new instance of the Domain class.
 | Domain(String) | Initializes a new instance of the Domain class.


Domain Constructor

Domain Constructor
Namespaces ► Sitecore.Security.Domains ► Domain ► Domain()()()
Initializes a new instance of the Domain class.
Declaration Syntax
C#
public Domain()


Domain Constructor (domainName)

Domain Constructor (domainName)
Namespaces ► Sitecore.Security.Domains ► Domain ► Domain(String)
Initializes a new instance of the Domain class.
Declaration Syntax
C#
public Domain(
    string domainName
)
Parameters
domainName (String)
Name of the domain.


AccountNameValidation Property

AccountNameValidation Property
Namespaces ► Sitecore.Security.Domains ► Domain ► AccountNameValidation
Gets the account name validation (regex).
Declaration Syntax
C#
public virtual string AccountNameValidation { get; set; }
Value
The account name validation.


AccountPrefix Property

AccountPrefix Property
Namespaces ► Sitecore.Security.Domains ► Domain ► AccountPrefix
Gets the account prefix (i.e. Name\).
Declaration Syntax
C#
public virtual string AccountPrefix { get; }
Value
The account prefix.


AnonymousUserEmailPattern Property

AnonymousUserEmailPattern Property
Namespaces ► Sitecore.Security.Domains ► Domain ► AnonymousUserEmailPattern
Gets or sets the anonymous user email pattern.
Declaration Syntax
C#
public virtual string AnonymousUserEmailPattern { get; set; }
Value
The anonymous user email pattern.


AnonymousUserName Property

AnonymousUserName Property
Namespaces ► Sitecore.Security.Domains ► Domain ► AnonymousUserName
Gets or sets the name of the 'anonymous' user. Empty string if the feature is not supported by the domain.
Declaration Syntax
C#
public virtual string AnonymousUserName { get; set; }
Value
The name of the anonymous user.


Appearance Property

Appearance Property
Namespaces ► Sitecore.Security.Domains ► Domain ► Appearance
Gets the appearance.
Declaration Syntax
C#
public virtual Appearance Appearance { get; }
Value
The appearance.


CreateAnonymousUser Method

CreateAnonymousUser Method
Namespaces ► Sitecore.Security.Domains ► Domain ► CreateAnonymousUser()()()
Creates the anonymous user in the Membership database.
Declaration Syntax
C#
protected virtual void CreateAnonymousUser()


CreateAnonymousUserIfNeeded Method

CreateAnonymousUserIfNeeded Method
Namespaces ► Sitecore.Security.Domains ► Domain ► CreateAnonymousUserIfNeeded()()()
Creates the anonymous user if needed.
Declaration Syntax
C#
public virtual void CreateAnonymousUserIfNeeded()


Current Property

Current Property
Namespaces ► Sitecore.Security.Domains ► Domain ► Current
Gets the current/active domain.
Declaration Syntax
C#
public static Domain Current { get; }
Value
The current domain.


DefaultProfileItemID Property

DefaultProfileItemID Property
Namespaces ► Sitecore.Security.Domains ► Domain ► DefaultProfileItemID
Gets the default profile item ID.
Declaration Syntax
C#
public virtual string DefaultProfileItemID { get; set; }
Value
The default profile item ID.


EnsureAnonymousUser Property

EnsureAnonymousUser Property
Namespaces ► Sitecore.Security.Domains ► Domain ► EnsureAnonymousUser
Gets a value indicating whether to ensure that an anonymous user exists for the domain.
Declaration Syntax
C#
public virtual bool EnsureAnonymousUser { get; set; }
Value
true if it should be ensured; otherwise, false.


Equality Operator

Equality Operator
Namespaces ► Sitecore.Security.Domains ► Domain ► Equality(Domain, Domain)
Implements the operator ==.
Declaration Syntax
C#
public static bool operator ==(
    Domain domain1,
    Domain domain2
)
Parameters
domain1 (Domain)
The domain1.
domain2 (Domain)
The domain2.
Return Value
The result of the operator.


Equals Method

Equals Method
Namespaces ► Sitecore.Security.Domains ► Domain ► Equals()()()
Members
Icon | Member | Description
 | Equals(Domain) | Equals implementation.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object.Equals(Object).)


Equals Method (domain)

Equals Method (domain)
Namespaces ► Sitecore.Security.Domains ► Domain ► Equals(Domain)
Equals implementation.
Declaration Syntax
C#
public virtual bool Equals(
    Domain domain
)
Parameters
domain (Domain)
The domain.
Return Value


Equals Method (obj)

Equals Method (obj)
Namespaces ► Sitecore.Security.Domains ► Domain ► Equals(Object)
Determines whether the specified Object is equal to the current Object.
Declaration Syntax
C#
public override bool Equals(
    Object obj
)
Parameters
obj (Object)
The Object to compare with the current Object.
Return Value
true if the specified Object is equal to the current Object; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.


EveryoneRoleName Property

EveryoneRoleName Property
Namespaces ► Sitecore.Security.Domains ► Domain ► EveryoneRoleName
Gets or sets the name of the 'everyone' role. Empty string if the feature is not supported by the domain.
Declaration Syntax
C#
public virtual string EveryoneRoleName { get; set; }
Value
The name of the everyone role.


ExtractDomainName Method (accountName)

ExtractDomainName Method (accountName)
Namespaces ► Sitecore.Security.Domains ► Domain ► ExtractDomainName(String)
Extracts the name of the domain from a full account name.
Declaration Syntax
C#
public static string ExtractDomainName(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value


ExtractShortName Method (accountName)

ExtractShortName Method (accountName)
Namespaces ► Sitecore.Security.Domains ► Domain ► ExtractShortName(String)
Extracts the short name of an account from a full account name.
Declaration Syntax
C#
public static string ExtractShortName(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value


GetAccountDomain Method (accountName)

GetAccountDomain Method (accountName)
Namespaces ► Sitecore.Security.Domains ► Domain ► GetAccountDomain(String)
Finds the domain of a specific account.
Declaration Syntax
C#
public static Domain GetAccountDomain(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value


GetAccounts Method

GetAccounts Method
Namespaces ► Sitecore.Security.Domains ► Domain ► GetAccounts()()()
Gets all accounts in the domain.
Declaration Syntax
C#
public virtual IEnumerable<Account> GetAccounts()
Return Value


GetAnonymousUser Method

GetAnonymousUser Method
Namespaces ► Sitecore.Security.Domains ► Domain ► GetAnonymousUser()()()
Gets the anonymous user.
Declaration Syntax
C#
public virtual User GetAnonymousUser()
Return Value
The anonymous user.


GetDefaultAnonymousUser Method

GetDefaultAnonymousUser Method
Namespaces ► Sitecore.Security.Domains ► Domain ► GetDefaultAnonymousUser()()()
Gets the default anonymous user.
Declaration Syntax
C#
public static User GetDefaultAnonymousUser()
Return Value


GetDefaultDomain Method

GetDefaultDomain Method
Namespaces ► Sitecore.Security.Domains ► Domain ► GetDefaultDomain()()()
Gets the default domain.
Declaration Syntax
C#
public static Domain GetDefaultDomain()
Return Value


GetDomain Method (domainName)

GetDomain Method (domainName)
Namespaces ► Sitecore.Security.Domains ► Domain ► GetDomain(String)
Gets a domain from its name.
Declaration Syntax
C#
public static Domain GetDomain(
    string domainName
)
Parameters
domainName (String)
Name of the domain.
Return Value


GetEveryoneRole Method

GetEveryoneRole Method
Namespaces ► Sitecore.Security.Domains ► Domain ► GetEveryoneRole()()()
Gets the everyone role.
Declaration Syntax
C#
public virtual Role GetEveryoneRole()
Return Value
The everyone user.


GetFullName Method

GetFullName Method
Namespaces ► Sitecore.Security.Domains ► Domain ► GetFullName()()()
Members
Icon | Member | Description
 | GetFullName(String) | Gets the full-name corresponding to an account name (i.e. the short name prefixed by the domain name).
 | GetFullName(String, Boolean) | Gets the full-name corresponding to an account name (i.e. the short name prefixed by the domain name).


GetFullName Method (accountName)

GetFullName Method (accountName)
Namespaces ► Sitecore.Security.Domains ► Domain ► GetFullName(String)
Gets the full-name corresponding to an account name (i.e. the short name prefixed by the domain name).
Declaration Syntax
C#
public virtual string GetFullName(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value
The full name.


GetFullName Method (accountName, processFullNames)

GetFullName Method (accountName, processFullNames)
Namespaces ► Sitecore.Security.Domains ► Domain ► GetFullName(String, Boolean)
Gets the full-name corresponding to an account name (i.e. the short name prefixed by the domain name).
Declaration Syntax
C#
public virtual string GetFullName(
    string accountName,
    bool processFullNames
)
Parameters
accountName (String)
Name of the account.
processFullNames (Boolean)
If set to true, process the account name even if it appears to be a full name already.
Return Value
The full name.


GetHashCode Method

GetHashCode Method
Namespaces ► Sitecore.Security.Domains ► Domain ► GetHashCode()()()
Serves as a hash function for a particular type.
Declaration Syntax
C#
public override int GetHashCode()
Return Value
A hash code for the current Object.


GetRoles Method

GetRoles Method
Namespaces ► Sitecore.Security.Domains ► Domain ► GetRoles()()()
Gets all roles in the domain.
Declaration Syntax
C#
public virtual IEnumerable<Role> GetRoles()
Return Value


GetShortName Method (accountName)

GetShortName Method (accountName)
Namespaces ► Sitecore.Security.Domains ► Domain ► GetShortName(String)
Gets the short-name corresponding to an account name (i.e. the account name without the domain name prefix).
Declaration Syntax
C#
public virtual string GetShortName(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value
The full name.


GetUserCount Method

GetUserCount Method
Namespaces ► Sitecore.Security.Domains ► Domain ► GetUserCount()()()
Gets the number of users in the domain.
Declaration Syntax
C#
public virtual int GetUserCount()
Return Value


GetUsers Method

GetUsers Method
Namespaces ► Sitecore.Security.Domains ► Domain ► GetUsers()()()
Members
Icon | Member | Description
 | GetUsers()()() | Gets all users in the domain.
 | GetUsers(Int32, Int32) | Gets a specific page of users in the domain.


GetUsers Method

GetUsers Method
Namespaces ► Sitecore.Security.Domains ► Domain ► GetUsers()()()
Gets all users in the domain.
Declaration Syntax
C#
public virtual IEnumerable<User> GetUsers()
Return Value


GetUsers Method (pageIndex, pageSize)

GetUsers Method (pageIndex, pageSize)
Namespaces ► Sitecore.Security.Domains ► Domain ► GetUsers(Int32, Int32)
Gets a specific page of users in the domain.
Declaration Syntax
C#
public virtual IEnumerable<User> GetUsers(
    int pageIndex,
    int pageSize
)
Parameters
pageIndex (Int32)
pageSize (Int32)
Return Value


HandlesAccount Method (accountName)

HandlesAccount Method (accountName)
Namespaces ► Sitecore.Security.Domains ► Domain ► HandlesAccount(String)
Determines if the domain handles a specific user (identified by name).
Declaration Syntax
C#
public virtual bool HandlesAccount(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value


Inequality Operator

Inequality Operator
Namespaces ► Sitecore.Security.Domains ► Domain ► Inequality(Domain, Domain)
Implements the operator !=.
Declaration Syntax
C#
public static bool operator !=(
    Domain domain1,
    Domain domain2
)
Parameters
domain1 (Domain)
The domain1.
domain2 (Domain)
The domain2.
Return Value
The result of the operator.


IsAnonymousUser Method (accountName)

IsAnonymousUser Method (accountName)
Namespaces ► Sitecore.Security.Domains ► Domain ► IsAnonymousUser(String)
Determines whether the specified account name represents the 'anonymous' user for the domain.
Declaration Syntax
C#
public virtual bool IsAnonymousUser(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value
true if it is the name of the anonymous user; otherwise, false.


IsDefault Property

IsDefault Property
Namespaces ► Sitecore.Security.Domains ► Domain ► IsDefault
Gets a value indicating whether this instance is default.
Declaration Syntax
C#
public virtual bool IsDefault { get; set; }
Value
true if this instance is default; otherwise, false.


IsEveryoneRole Method (accountName)

IsEveryoneRole Method (accountName)
Namespaces ► Sitecore.Security.Domains ► Domain ► IsEveryoneRole(String)
Determines whether the specified account name represents the everyone role for the domain.
Declaration Syntax
C#
public virtual bool IsEveryoneRole(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value
true if it is the everyone role name; otherwise, false.


IsFullName Method (userName)

IsFullName Method (userName)
Namespaces ► Sitecore.Security.Domains ► Domain ► IsFullName(String)
Determines if a specific account name is fully qualified (i.e. is prefixed with the domain name).
Declaration Syntax
C#
public virtual bool IsFullName(
    string userName
)
Parameters
userName (String)
Name of the user.
Return Value


IsValidAccountName Method (accountName)

IsValidAccountName Method (accountName)
Namespaces ► Sitecore.Security.Domains ► Domain ► IsValidAccountName(String)
Determines whether the specified account name is valid.
Declaration Syntax
C#
public virtual bool IsValidAccountName(
    string accountName
)
Parameters
accountName (String)
Name of the account.
Return Value
true if the specified account name is valid; otherwise, false.


LocallyManaged Property

LocallyManaged Property
Namespaces ► Sitecore.Security.Domains ► Domain ► LocallyManaged
Gets or sets a value indicating whether the domain is locally managed.
Declaration Syntax
C#
public virtual bool LocallyManaged { get; set; }
Value
true if locally managed; otherwise, false.


MemberPattern Property

MemberPattern Property
Namespaces ► Sitecore.Security.Domains ► Domain ► MemberPattern
Gets the pattern string for members of this domain.
Declaration Syntax
C#
public virtual string MemberPattern { get; }
Value
The member pattern.
Remarks
The pattern is used when querying the Membership API.


Name Property

Name Property
Namespaces ► Sitecore.Security.Domains ► Domain ► Name
Gets the name.
Declaration Syntax
C#
public virtual string Name { get; set; }
Value
The name.
Exceptions
Exception | Condition
DomainException | A domain was not initialized properly. The Name property is null.


ToString Method

ToString Method
Namespaces ► Sitecore.Security.Domains ► Domain ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


DomainConfiguration Class

DomainConfiguration Class
Namespaces ► Sitecore.Security.Domains ► DomainConfiguration
DomainConfig class
Declaration Syntax
C#
public class DomainConfiguration
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DomainConfiguration(ConfigStore) | Initializes a new instance of the DomainConfiguration class.
 | AddDomain(String) | Adds a domain.
 | CommitChanges()()() | Commits the changes.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDomain(String) | Gets a domain record.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveDomain(String) | Removes a domain.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DomainConfiguration


DomainConfiguration Constructor (configStore)

DomainConfiguration Constructor (configStore)
Namespaces ► Sitecore.Security.Domains ► DomainConfiguration ► DomainConfiguration(ConfigStore)
Initializes a new instance of the DomainConfiguration class.
Declaration Syntax
C#
public DomainConfiguration(
    ConfigStore configStore
)
Parameters
configStore (ConfigStore)
The config store.


AddDomain Method (domainName)

AddDomain Method (domainName)
Namespaces ► Sitecore.Security.Domains ► DomainConfiguration ► AddDomain(String)
Adds a domain.
Declaration Syntax
C#
public virtual DomainRecord AddDomain(
    string domainName
)
Parameters
domainName (String)
Name of the domain.
Return Value


CommitChanges Method

CommitChanges Method
Namespaces ► Sitecore.Security.Domains ► DomainConfiguration ► CommitChanges()()()
Commits the changes.
Declaration Syntax
C#
public virtual void CommitChanges()


GetDomain Method (domainName)

GetDomain Method (domainName)
Namespaces ► Sitecore.Security.Domains ► DomainConfiguration ► GetDomain(String)
Gets a domain record.
Declaration Syntax
C#
public virtual DomainRecord GetDomain(
    string domainName
)
Parameters
domainName (String)
Name of the domain.
Return Value


RemoveDomain Method (domainName)

RemoveDomain Method (domainName)
Namespaces ► Sitecore.Security.Domains ► DomainConfiguration ► RemoveDomain(String)
Removes a domain.
Declaration Syntax
C#
public virtual void RemoveDomain(
    string domainName
)
Parameters
domainName (String)
Name of the domain.
Exceptions
Exception | Condition
ConfigurationException |


DomainList Class

DomainList Class
Namespaces ► Sitecore.Security.Domains ► DomainList
DomainList class
Declaration Syntax
C#
public class DomainList : ReadOnlyList<Domain>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainList(IEnumerable<(Of <(Domain>)>)) | Initializes a new instance of the DomainList class.
 | DomainList()()() | Initializes a new instance of the DomainList class.
 | Contains(TElement) | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToArray()()() | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(TElement>)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ReadOnlyList <(Of <( Domain >)>)
 |  | DomainList


DomainList Constructor

DomainList Constructor
Namespaces ► Sitecore.Security.Domains ► DomainList ► DomainList()()()
Members
Icon | Member | Description
 | DomainList(IEnumerable<(Of <(Domain>)>)) | Initializes a new instance of the DomainList class.
 | DomainList()()() | Initializes a new instance of the DomainList class.


DomainList Constructor

DomainList Constructor
Namespaces ► Sitecore.Security.Domains ► DomainList ► DomainList()()()
Initializes a new instance of the DomainList class.
Declaration Syntax
C#
public DomainList()


DomainList Constructor (entries)

DomainList Constructor (entries)
Namespaces ► Sitecore.Security.Domains ► DomainList ► DomainList(IEnumerable<(Of <(Domain>)>))
Initializes a new instance of the DomainList class.
Declaration Syntax
C#
public DomainList(
    IEnumerable<Domain> entries
)
Parameters
entries (IEnumerable<(Of <( Domain >)>))
The entries.


DomainRecord Class

DomainRecord Class
Namespaces ► Sitecore.Security.Domains ► DomainRecord
DomainRecord class
Declaration Syntax
C#
public class DomainRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainRecord(String) | Initializes a new instance of the DomainRecord class.
 | DomainRecord(ConfigRecord) | Initializes a new instance of the DomainRecord class.
 | DomainName | Gets the name of the domain.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefault | Gets or sets a value indicating whether this domain is the default.
 | LocallyManaged | Gets or sets a value indicating whether the domain is locally managed.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DomainRecord


DomainRecord Constructor

DomainRecord Constructor
Namespaces ► Sitecore.Security.Domains ► DomainRecord ► DomainRecord()()()
Members
Icon | Member | Description
 | DomainRecord(String) | Initializes a new instance of the DomainRecord class.
 | DomainRecord(ConfigRecord) | Initializes a new instance of the DomainRecord class.


DomainRecord Constructor (configRecord)

DomainRecord Constructor (configRecord)
Namespaces ► Sitecore.Security.Domains ► DomainRecord ► DomainRecord(ConfigRecord)
Initializes a new instance of the DomainRecord class.
Declaration Syntax
C#
public DomainRecord(
    ConfigRecord configRecord
)
Parameters
configRecord (ConfigRecord)
The record.


DomainRecord Constructor (domainName)

DomainRecord Constructor (domainName)
Namespaces ► Sitecore.Security.Domains ► DomainRecord ► DomainRecord(String)
Initializes a new instance of the DomainRecord class.
Declaration Syntax
C#
public DomainRecord(
    string domainName
)
Parameters
domainName (String)
Name of the domain.


DomainName Property

DomainName Property
Namespaces ► Sitecore.Security.Domains ► DomainRecord ► DomainName
Gets the name of the domain.
Declaration Syntax
C#
public virtual string DomainName { get; }
Value
The name of the domain.


IsDefault Property

IsDefault Property
Namespaces ► Sitecore.Security.Domains ► DomainRecord ► IsDefault
Gets or sets a value indicating whether this domain is the default.
Declaration Syntax
C#
public virtual bool IsDefault { get; set; }
Value
true if this domain is the default; otherwise, false.


LocallyManaged Property

LocallyManaged Property
Namespaces ► Sitecore.Security.Domains ► DomainRecord ► LocallyManaged
Gets or sets a value indicating whether the domain is locally managed.
Declaration Syntax
C#
public virtual bool LocallyManaged { get; set; }
Value
true if it is locally managed; otherwise, false.


Sitecore.Security.Principal Namespace

Sitecore.Security.Principal Namespace
Namespaces ► Sitecore.Security.Principal
Declaration Syntax
C#
namespace Sitecore.Security.Principal
Types
All Types Classes
Icon | Type | Description
 | SitecoreIdentity | SitecoreIdentity class


SitecoreIdentity Class

SitecoreIdentity Class
Namespaces ► Sitecore.Security.Principal ► SitecoreIdentity
SitecoreIdentity class
Declaration Syntax
C#
public class SitecoreIdentity : IIdentity
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SitecoreIdentity(String, Boolean) | Initializes a new instance of the SitecoreIdentity class.
 | AuthenticationType | Gets the type of authentication used.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromName(String, Boolean) | Froms the name.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAuthenticated | Gets a value that indicates whether the user has been authenticated.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the current user.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SitecoreIdentity


SitecoreIdentity Constructor (name, isAuthenticated)

SitecoreIdentity Constructor (name, isAuthenticated)
Namespaces ► Sitecore.Security.Principal ► SitecoreIdentity ► SitecoreIdentity(String, Boolean)
Initializes a new instance of the SitecoreIdentity class.
Declaration Syntax
C#
protected SitecoreIdentity(
    string name,
    bool isAuthenticated
)
Parameters
name (String)
isAuthenticated (Boolean)


AuthenticationType Property

AuthenticationType Property
Namespaces ► Sitecore.Security.Principal ► SitecoreIdentity ► AuthenticationType
Gets the type of authentication used.
Declaration Syntax
C#
public virtual string AuthenticationType { get; }
Return Value
The type of authentication used to identify the user.


FromName Method (name, authenticated)

FromName Method (name, authenticated)
Namespaces ► Sitecore.Security.Principal ► SitecoreIdentity ► FromName(String, Boolean)
Froms the name.
Declaration Syntax
C#
public static IIdentity FromName(
    string name,
    bool authenticated
)
Parameters
name (String)
The name.
authenticated (Boolean)
if set to true [authenticated].
Return Value


IsAuthenticated Property

IsAuthenticated Property
Namespaces ► Sitecore.Security.Principal ► SitecoreIdentity ► IsAuthenticated
Gets a value that indicates whether the user has been authenticated.
Declaration Syntax
C#
public virtual bool IsAuthenticated { get; }
Return Value
true if the user was authenticated; otherwise, false.


Name Property

Name Property
Namespaces ► Sitecore.Security.Principal ► SitecoreIdentity ► Name
Gets the name of the current user.
Declaration Syntax
C#
public virtual string Name { get; }
Return Value
The name of the user on whose behalf the code is running.


Sitecore.Security.Serialization Namespace

Sitecore.Security.Serialization Namespace
Namespaces ► Sitecore.Security.Serialization
Declaration Syntax
C#
namespace Sitecore.Security.Serialization
Types
All Types Classes
Icon | Type | Description
 | RoleReference | Path-based role reference with uniqueness support.
 | RoleSynchronization | Implements Role <-> File synchronization
 | SecuritySerializationUtils | Utils for serialization security
 | UserReference | Path-based user reference with uniqueness support.
 | UserSynchronization | Implements User <-> File synchronization


RoleReference Class

RoleReference Class
Namespaces ► Sitecore.Security.Serialization ► RoleReference
Path-based role reference with uniqueness support.
Declaration Syntax
C#
public class RoleReference
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RoleReference(String) | Initializes a new instance of the RoleReference class from role name.
 | RoleReference(Role) | Initializes a new instance of the RoleReference class from role instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRoleInDatabase(String) | Gets the role in database.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Role | Gets the role.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
RoleReference


RoleReference Constructor

RoleReference Constructor
Namespaces ► Sitecore.Security.Serialization ► RoleReference ► RoleReference()()()
Members
Icon | Member | Description
 | RoleReference(String) | Initializes a new instance of the RoleReference class from role name.
 | RoleReference(Role) | Initializes a new instance of the RoleReference class from role instance.


RoleReference Constructor (role)

RoleReference Constructor (role)
Namespaces ► Sitecore.Security.Serialization ► RoleReference ► RoleReference(Role)
Initializes a new instance of the RoleReference class from role instance.
Declaration Syntax
C#
public RoleReference(
    Role role
)
Parameters
role (Role)
The role.


RoleReference Constructor (rolename)

RoleReference Constructor (rolename)
Namespaces ► Sitecore.Security.Serialization ► RoleReference ► RoleReference(String)
Initializes a new instance of the RoleReference class from role name.
Declaration Syntax
C#
public RoleReference(
    string rolename
)
Parameters
rolename (String)
The name of the role.


GetRoleInDatabase Method (rolename)

GetRoleInDatabase Method (rolename)
Namespaces ► Sitecore.Security.Serialization ► RoleReference ► GetRoleInDatabase(String)
Gets the role in database.
Declaration Syntax
C#
public Role GetRoleInDatabase(
    string rolename
)
Parameters
rolename (String)
The name of the role.
Return Value
The role in database.


Role Property

Role Property
Namespaces ► Sitecore.Security.Serialization ► RoleReference ► Role
Gets the role.
Declaration Syntax
C#
public Role Role { get; }
Return Value
The role.


ToString Method

ToString Method
Namespaces ► Sitecore.Security.Serialization ► RoleReference ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


RoleSynchronization Class

RoleSynchronization Class
Namespaces ► Sitecore.Security.Serialization ► RoleSynchronization
Implements Role <-> File synchronization
Declaration Syntax
C#
public static class RoleSynchronization
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BuildSyncRole(Role) | Builds the dump role object from role.
 | PasteSyncRole(SyncRole) | Pastes SyncRole into the database.
 | ReadRole(TextReader) | Reads the role from TextReader.
 | WriteRole(Role, TextWriter) | Writes the role to TextWriter.
Inheritance Hierarchy
Object
RoleSynchronization


BuildSyncRole Method (role)

BuildSyncRole Method (role)
Namespaces ► Sitecore.Security.Serialization ► RoleSynchronization ► BuildSyncRole(Role)
Builds the dump role object from role.
Declaration Syntax
C#
public static SyncRole BuildSyncRole(
    Role role
)
Parameters
role (Role)
The role.
Return Value
The dump role.


PasteSyncRole Method (syncRole)

PasteSyncRole Method (syncRole)
Namespaces ► Sitecore.Security.Serialization ► RoleSynchronization ► PasteSyncRole(SyncRole)
Pastes SyncRole into the database.
Declaration Syntax
C#
public static Role PasteSyncRole(
    SyncRole syncRole
)
Parameters
syncRole (SyncRole)
The sync role.
Return Value
The role in database.


ReadRole Method (reader)

ReadRole Method (reader)
Namespaces ► Sitecore.Security.Serialization ► RoleSynchronization ► ReadRole(TextReader)
Reads the role from TextReader.
Declaration Syntax
C#
public static Role ReadRole(
    TextReader reader
)
Parameters
reader (TextReader)
The reader.
Return Value
The role.


WriteRole Method (role, writer)

WriteRole Method (role, writer)
Namespaces ► Sitecore.Security.Serialization ► RoleSynchronization ► WriteRole(Role, TextWriter)
Writes the role to TextWriter.
Declaration Syntax
C#
public static void WriteRole(
    Role role,
    TextWriter writer
)
Parameters
role (Role)
The role.
writer (TextWriter)
The writer.


SecuritySerializationUtils Class

SecuritySerializationUtils Class
Namespaces ► Sitecore.Security.Serialization ► SecuritySerializationUtils
Utils for serialization security
Declaration Syntax
C#
public class SecuritySerializationUtils
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecuritySerializationUtils()()() | Initializes a new instance of the SecuritySerializationUtils class
 | CleanRoles(List<(Of <(String>)>)) | Removes roles which was not restored by serialization.
 | CleanRoles(List<(Of <(String>)>), String) | Removes roles which was not restored by serialization.
 | CleanUsers(List<(Of <(String>)>)) | Removes users which was not restored by serialization.
 | CleanUsers(List<(Of <(String>)>), String) | Removes roles which was not restored by serialization.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PathToSerialization | Gets the path to serialization.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SecuritySerializationUtils


SecuritySerializationUtils Constructor

SecuritySerializationUtils Constructor
Namespaces ► Sitecore.Security.Serialization ► SecuritySerializationUtils ► SecuritySerializationUtils()()()
Initializes a new instance of the SecuritySerializationUtils class
Declaration Syntax
C#
public SecuritySerializationUtils()


CleanRoles Method

CleanRoles Method
Namespaces ► Sitecore.Security.Serialization ► SecuritySerializationUtils ► CleanRoles()()()
Members
Icon | Member | Description
 | CleanRoles(List<(Of <(String>)>)) | Removes roles which was not restored by serialization.
 | CleanRoles(List<(Of <(String>)>), String) | Removes roles which was not restored by serialization.


CleanRoles Method (loadedRoles)

CleanRoles Method (loadedRoles)
Namespaces ► Sitecore.Security.Serialization ► SecuritySerializationUtils ► CleanRoles(List<(Of <(String>)>))
Removes roles which was not restored by serialization.
Declaration Syntax
C#
public static void CleanRoles(
    List<string> loadedRoles
)
Parameters
loadedRoles (List<(Of <(String>)>))
The loaded roles.


CleanRoles Method (loadedRoles, domainName)

CleanRoles Method (loadedRoles, domainName)
Namespaces ► Sitecore.Security.Serialization ► SecuritySerializationUtils ► CleanRoles(List<(Of <(String>)>), String)
Removes roles which was not restored by serialization.
Declaration Syntax
C#
public static void CleanRoles(
    List<string> loadedRoles,
    string domainName
)
Parameters
loadedRoles (List<(Of <(String>)>))
The loaded roles.
domainName (String)
Name of the domain.


CleanUsers Method

CleanUsers Method
Namespaces ► Sitecore.Security.Serialization ► SecuritySerializationUtils ► CleanUsers()()()
Members
Icon | Member | Description
 | CleanUsers(List<(Of <(String>)>)) | Removes users which was not restored by serialization.
 | CleanUsers(List<(Of <(String>)>), String) | Removes roles which was not restored by serialization.


CleanUsers Method (loadedUsers)

CleanUsers Method (loadedUsers)
Namespaces ► Sitecore.Security.Serialization ► SecuritySerializationUtils ► CleanUsers(List<(Of <(String>)>))
Removes users which was not restored by serialization.
Declaration Syntax
C#
public static void CleanUsers(
    List<string> loadedUsers
)
Parameters
loadedUsers (List<(Of <(String>)>))
The loaded users.


CleanUsers Method (loadedUsers, domainName)

CleanUsers Method (loadedUsers, domainName)
Namespaces ► Sitecore.Security.Serialization ► SecuritySerializationUtils ► CleanUsers(List<(Of <(String>)>), String)
Removes roles which was not restored by serialization.
Declaration Syntax
C#
public static void CleanUsers(
    List<string> loadedUsers,
    string domainName
)
Parameters
loadedUsers (List<(Of <(String>)>))
The loaded users.
domainName (String)
Name of the domain.


PathToSerialization Property

PathToSerialization Property
Namespaces ► Sitecore.Security.Serialization ► SecuritySerializationUtils ► PathToSerialization
Gets the path to serialization.
Declaration Syntax
C#
public static string PathToSerialization { get; }
Value
The path to serialization.


UserReference Class

UserReference Class
Namespaces ► Sitecore.Security.Serialization ► UserReference
Path-based user reference with uniqueness support.
Declaration Syntax
C#
public class UserReference
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserReference(String) | Initializes a new instance of the UserReference class from user name.
 | UserReference(User) | Initializes a new instance of the UserReference class from user instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserInDatabase(String) | Gets the user in database.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | User | Gets the user.
Inheritance Hierarchy
Object
UserReference


UserReference Constructor

UserReference Constructor
Namespaces ► Sitecore.Security.Serialization ► UserReference ► UserReference()()()
Members
Icon | Member | Description
 | UserReference(String) | Initializes a new instance of the UserReference class from user name.
 | UserReference(User) | Initializes a new instance of the UserReference class from user instance.


UserReference Constructor (user)

UserReference Constructor (user)
Namespaces ► Sitecore.Security.Serialization ► UserReference ► UserReference(User)
Initializes a new instance of the UserReference class from user instance.
Declaration Syntax
C#
public UserReference(
    User user
)
Parameters
user (User)
The user.


UserReference Constructor (username)

UserReference Constructor (username)
Namespaces ► Sitecore.Security.Serialization ► UserReference ► UserReference(String)
Initializes a new instance of the UserReference class from user name.
Declaration Syntax
C#
public UserReference(
    string username
)
Parameters
username (String)
The name of the user.


GetUserInDatabase Method (username)

GetUserInDatabase Method (username)
Namespaces ► Sitecore.Security.Serialization ► UserReference ► GetUserInDatabase(String)
Gets the user in database.
Declaration Syntax
C#
public MembershipUser GetUserInDatabase(
    string username
)
Parameters
username (String)
The name of the user.
Return Value
The user in database.


ToString Method

ToString Method
Namespaces ► Sitecore.Security.Serialization ► UserReference ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


User Property

User Property
Namespaces ► Sitecore.Security.Serialization ► UserReference ► User
Gets the user.
Declaration Syntax
C#
public MembershipUser User { get; }
Return Value
The user.


UserSynchronization Class

UserSynchronization Class
Namespaces ► Sitecore.Security.Serialization ► UserSynchronization
Implements User <-> File synchronization
Declaration Syntax
C#
public static class UserSynchronization
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BuildSyncUser(MembershipUser) | Builds the dump user object from user.
 | PasteSyncUser(SyncUser) | Pastes SyncUser into the database.
 | ReadUser(TextReader) | Reads the user from TextReader.
 | WriteUser(MembershipUser, TextWriter) | Writes the user to TextWriter.
Inheritance Hierarchy
Object
UserSynchronization


BuildSyncUser Method (user)

BuildSyncUser Method (user)
Namespaces ► Sitecore.Security.Serialization ► UserSynchronization ► BuildSyncUser(MembershipUser)
Builds the dump user object from user.
Declaration Syntax
C#
public static SyncUser BuildSyncUser(
    MembershipUser user
)
Parameters
user (MembershipUser)
The user.
Return Value
The dump user.


PasteSyncUser Method (syncUser)

PasteSyncUser Method (syncUser)
Namespaces ► Sitecore.Security.Serialization ► UserSynchronization ► PasteSyncUser(SyncUser)
Pastes SyncUser into the database.
Declaration Syntax
C#
public static User PasteSyncUser(
    SyncUser syncUser
)
Parameters
syncUser (SyncUser)
The sync user.
Return Value
The user in database.


ReadUser Method (reader)

ReadUser Method (reader)
Namespaces ► Sitecore.Security.Serialization ► UserSynchronization ► ReadUser(TextReader)
Reads the user from TextReader.
Declaration Syntax
C#
public static User ReadUser(
    TextReader reader
)
Parameters
reader (TextReader)
The reader.
Return Value
The user.


WriteUser Method (user, writer)

WriteUser Method (user, writer)
Namespaces ► Sitecore.Security.Serialization ► UserSynchronization ► WriteUser(MembershipUser, TextWriter)
Writes the user to TextWriter.
Declaration Syntax
C#
public static void WriteUser(
    MembershipUser user,
    TextWriter writer
)
Parameters
user (MembershipUser)
The user.
writer (TextWriter)
The writer.


Sitecore.Security.Serialization.ObjectModel Namespace

Sitecore.Security.Serialization.ObjectModel Namespace
Namespaces ► Sitecore.Security.Serialization.ObjectModel
Declaration Syntax
C#
namespace Sitecore.Security.Serialization.ObjectModel
Types
All Types Classes
Icon | Type | Description
 | SyncProfileProperty | Represents user profile property in ProfilePropertyDom.
 | SyncRole | Represents Sitecore role in RoleDom.
 | SyncUser | Represents Sitecore user in UserDom.


SyncProfileProperty Class

SyncProfileProperty Class
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncProfileProperty
Represents user profile property in ProfilePropertyDom.
Declaration Syntax
C#
public class SyncProfileProperty
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SyncProfileProperty(String, Object) | Creates an instance of the dump profile property.
 | SyncProfileProperty(String, Object, Boolean) | Creates an instance of the dump profile property.
 | Content | The content of the profile property.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsCustomProperty | Is the profile property a custom profile property
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Name of the profile property.
 | ReadProperty(Tokenizer) | Reads profile property.
 | Serialize(TextWriter) | Serializes the profile property to the specified writer.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SyncProfileProperty


SyncProfileProperty Constructor

SyncProfileProperty Constructor
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncProfileProperty ► SyncProfileProperty()()()
Members
Icon | Member | Description
 | SyncProfileProperty(String, Object) | Creates an instance of the dump profile property.
 | SyncProfileProperty(String, Object, Boolean) | Creates an instance of the dump profile property.


SyncProfileProperty Constructor (profilePropertyName, profilePropertyContent)

SyncProfileProperty Constructor (profilePropertyName, profilePropertyContent)
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncProfileProperty ► SyncProfileProperty(String, Object)
Creates an instance of the dump profile property.
Declaration Syntax
C#
public SyncProfileProperty(
    string profilePropertyName,
    Object profilePropertyContent
)
Parameters
profilePropertyName (String)
The name of the profile property.
profilePropertyContent (Object)
The content of the profile property


SyncProfileProperty Constructor (profilePropertyName, profilePropertyContent, isCustom)

SyncProfileProperty Constructor (profilePropertyName, profilePropertyContent, isCustom)
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncProfileProperty ► SyncProfileProperty(String, Object, Boolean)
Creates an instance of the dump profile property.
Declaration Syntax
C#
public SyncProfileProperty(
    string profilePropertyName,
    Object profilePropertyContent,
    bool isCustom
)
Parameters
profilePropertyName (String)
The name of the profile property.
profilePropertyContent (Object)
The content of the profile property
isCustom (Boolean)
Is custom profile property


Content Property

Content Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncProfileProperty ► Content
The content of the profile property.
Declaration Syntax
C#
public Object Content { get; private set; }


IsCustomProperty Property

IsCustomProperty Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncProfileProperty ► IsCustomProperty
Is the profile property a custom profile property
Declaration Syntax
C#
public bool IsCustomProperty { get; private set; }


Name Property

Name Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncProfileProperty ► Name
Name of the profile property.
Declaration Syntax
C#
public string Name { get; private set; }


ReadProperty Method (reader)

ReadProperty Method (reader)
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncProfileProperty ► ReadProperty(Tokenizer)
Reads profile property.
Declaration Syntax
C#
public static SyncProfileProperty ReadProperty(
    Tokenizer reader
)
Parameters
reader (Tokenizer)
The reader.
Return Value
The profile property.
Exceptions
Exception | Condition
Exception | The file was generated using a newer version of Serialization.


Serialize Method (writer)

Serialize Method (writer)
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncProfileProperty ► Serialize(TextWriter)
Serializes the profile property to the specified writer.
Declaration Syntax
C#
public void Serialize(
    TextWriter writer
)
Parameters
writer (TextWriter)
The writer.


SyncRole Class

SyncRole Class
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncRole
Represents Sitecore role in RoleDom.
Declaration Syntax
C#
public class SyncRole
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SyncRole(String) | Creates an instance of a role dump.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Name of the role dump.
 | ReadRole(Tokenizer) | Reads the role.
 | RolesInRole | List of role members for role dump.
 | Serialize(TextWriter) | Serializes role to specified writer.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SyncRole


SyncRole Constructor (name)

SyncRole Constructor (name)
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncRole ► SyncRole(String)
Creates an instance of a role dump.
Declaration Syntax
C#
public SyncRole(
    string name
)
Parameters
name (String)
Role dump name.


Name Property

Name Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncRole ► Name
Name of the role dump.
Declaration Syntax
C#
public string Name { get; private set; }


ReadRole Method (reader)

ReadRole Method (reader)
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncRole ► ReadRole(Tokenizer)
Reads the role.
Declaration Syntax
C#
public static SyncRole ReadRole(
    Tokenizer reader
)
Parameters
reader (Tokenizer)
The reader.
Return Value
The role.
Exceptions
Exception | Condition
Exception | The file was generated using a newer version of Serialization.


RolesInRole Property

RolesInRole Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncRole ► RolesInRole
List of role members for role dump.
Declaration Syntax
C#
public List<string> RolesInRole { get; private set; }


Serialize Method (writer)

Serialize Method (writer)
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncRole ► Serialize(TextWriter)
Serializes role to specified writer.
Declaration Syntax
C#
public void Serialize(
    TextWriter writer
)
Parameters
writer (TextWriter)
The writer.


SyncUser Class

SyncUser Class
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser
Represents Sitecore user in UserDom.
Declaration Syntax
C#
public class SyncUser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SyncUser()()() | Creates an instance of the dump user
 | Comment | Shows the user comment.
 | CreationDate | Creation date of the user.
 | CustomProfileProperties | List of custom profile properties for the user
 | Email | Email address of the user.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApproved | Shows whether user is approved or not.
 | IsLockedOut | Shows whether user is locked out or not.
 | LastActivityDate | Last activity date of the user.
 | LastLockoutDate | Last lockout date of the user.
 | LastLoginDate | Last login date of the user.
 | LastPasswordChanged | Last password changed date of the user.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProfileProperties | List of profile properties for the user
 | ReadUser(Tokenizer) | Reads the user.
 | Roles | List of the roles the user is in
 | Serialize(TextWriter) | Serializes the user to specified writer.
 | SerializeRoles(TextWriter) | Serializes the roles user is member of to specified writer.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserName | Name of the user.
Inheritance Hierarchy
Object
SyncUser


SyncUser Constructor

SyncUser Constructor
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► SyncUser()()()
Creates an instance of the dump user
Declaration Syntax
C#
public SyncUser()


Comment Property

Comment Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► Comment
Shows the user comment.
Declaration Syntax
C#
public string Comment { get; set; }


CreationDate Property

CreationDate Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► CreationDate
Creation date of the user.
Declaration Syntax
C#
public DateTime CreationDate { get; set; }


CustomProfileProperties Property

CustomProfileProperties Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► CustomProfileProperties
List of custom profile properties for the user
Declaration Syntax
C#
public List<SyncProfileProperty> CustomProfileProperties { get; private set; }


Email Property

Email Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► Email
Email address of the user.
Declaration Syntax
C#
public string Email { get; set; }


IsApproved Property

IsApproved Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► IsApproved
Shows whether user is approved or not.
Declaration Syntax
C#
public bool IsApproved { get; set; }


IsLockedOut Property

IsLockedOut Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► IsLockedOut
Shows whether user is locked out or not.
Declaration Syntax
C#
public bool IsLockedOut { get; set; }


LastActivityDate Property

LastActivityDate Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► LastActivityDate
Last activity date of the user.
Declaration Syntax
C#
public DateTime LastActivityDate { get; set; }


LastLockoutDate Property

LastLockoutDate Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► LastLockoutDate
Last lockout date of the user.
Declaration Syntax
C#
public DateTime LastLockoutDate { get; set; }


LastLoginDate Property

LastLoginDate Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► LastLoginDate
Last login date of the user.
Declaration Syntax
C#
public DateTime LastLoginDate { get; set; }


LastPasswordChanged Property

LastPasswordChanged Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► LastPasswordChanged
Last password changed date of the user.
Declaration Syntax
C#
public DateTime LastPasswordChanged { get; set; }


ProfileProperties Property

ProfileProperties Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► ProfileProperties
List of profile properties for the user
Declaration Syntax
C#
public List<SyncProfileProperty> ProfileProperties { get; private set; }


ReadUser Method (reader)

ReadUser Method (reader)
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► ReadUser(Tokenizer)
Reads the user.
Declaration Syntax
C#
public static SyncUser ReadUser(
    Tokenizer reader
)
Parameters
reader (Tokenizer)
The reader.
Return Value
The user.
Exceptions
Exception | Condition
Exception | The file was generated using a newer version of Serialization.


Roles Property

Roles Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► Roles
List of the roles the user is in
Declaration Syntax
C#
public List<string> Roles { get; private set; }


Serialize Method (writer)

Serialize Method (writer)
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► Serialize(TextWriter)
Serializes the user to specified writer.
Declaration Syntax
C#
public void Serialize(
    TextWriter writer
)
Parameters
writer (TextWriter)
The writer.


SerializeRoles Method (writer)

SerializeRoles Method (writer)
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► SerializeRoles(TextWriter)
Serializes the roles user is member of to specified writer.
Declaration Syntax
C#
protected void SerializeRoles(
    TextWriter writer
)
Parameters
writer (TextWriter)
The writer.


UserName Property

UserName Property
Namespaces ► Sitecore.Security.Serialization.ObjectModel ► SyncUser ► UserName
Name of the user.
Declaration Syntax
C#
public string UserName { get; set; }


Sitecore.SecurityModel Namespace

Sitecore.SecurityModel Namespace
Namespaces ► Sitecore.SecurityModel
Declaration Syntax
C#
namespace Sitecore.SecurityModel
Types
All Types Classes Structures Enumerations Delegates
Icon | Type | Description
 | ConfigDomainProvider | ConfigDomainProvider class
 | Credentials | Represents a set of credentials.
 | DatabaseDomainProvider | ItemBasedDomainProvider class
 | DomainAccessArgs | Represents a set of domain access arguments.
 | DomainAccessDelegate |
 | DomainAccessResult | Represents a domain access result.
 | DomainCollection | DomainCollection class
 | DomainManager | DomainManager class
 | DomainProvider | DomainProvider class
 | DomainProviderCollection | DomainProviderCollection class
 | EntityType | EntityType class
 | Policy | Represents a Policy.
 | SecurityCheck | Represents a security check.
 | SecurityContext | Holds the current security context.
 | SecurityDisabler | Disables security temporarily.
 | SecurityEnabler | Enables security temporarily.
 | SecurityState | Represents the current state of security.
 | SecurityStateSwitcher | StateSwitcher class
 | UserRuntimeSettings | UserRuntimeSettings class


ConfigDomainProvider Class

ConfigDomainProvider Class
Namespaces ► Sitecore.SecurityModel ► ConfigDomainProvider
ConfigDomainProvider class
Declaration Syntax
C#
public class ConfigDomainProvider : DomainProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigDomainProvider()()() | Initializes a new instance of the ConfigDomainProvider class
 | AddDomain(String, Boolean) | Adds a new domain to the system. (Overrides DomainProvider.AddDomain(String, Boolean).)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | DomainExists(String) | Determines if a domain with the specified name exists. (Inherited from DomainProvider.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConfiguration()()() | Gets the configuration. (Inherited from DomainProvider.)
 | GetDefaultDomain()()() | Gets the default domain. (Overrides DomainProvider.GetDefaultDomain()()().)
 | GetDomain(String) | Gets a named domain. (Overrides DomainProvider.GetDomain(String).)
 | GetDomainNames()()() | Gets the domain names. (Inherited from DomainProvider.)
 | GetDomains()()() | Gets all domains handled by the provider. (Overrides DomainProvider.GetDomains()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | RemoveDomain(String) | Removes an existing domain from the system. (Overrides DomainProvider.RemoveDomain(String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | DomainProvider
 |  |  | ConfigDomainProvider


ConfigDomainProvider Constructor

ConfigDomainProvider Constructor
Namespaces ► Sitecore.SecurityModel ► ConfigDomainProvider ► ConfigDomainProvider()()()
Initializes a new instance of the ConfigDomainProvider class
Declaration Syntax
C#
public ConfigDomainProvider()


AddDomain Method (domainName, locallyManaged)

AddDomain Method (domainName, locallyManaged)
Namespaces ► Sitecore.SecurityModel ► ConfigDomainProvider ► AddDomain(String, Boolean)
Adds a new domain to the system.
Declaration Syntax
C#
public override void AddDomain(
    string domainName,
    bool locallyManaged
)
Parameters
domainName (String)
Name of the domain.
locallyManaged (Boolean)
If set to true, the domain is locally managed.


GetDefaultDomain Method

GetDefaultDomain Method
Namespaces ► Sitecore.SecurityModel ► ConfigDomainProvider ► GetDefaultDomain()()()
Gets the default domain.
Declaration Syntax
C#
public override Domain GetDefaultDomain()


GetDomain Method (name)

GetDomain Method (name)
Namespaces ► Sitecore.SecurityModel ► ConfigDomainProvider ► GetDomain(String)
Gets a named domain.
Declaration Syntax
C#
public override Domain GetDomain(
    string name
)
Parameters
name (String)


GetDomains Method

GetDomains Method
Namespaces ► Sitecore.SecurityModel ► ConfigDomainProvider ► GetDomains()()()
Gets all domains handled by the provider.
Declaration Syntax
C#
public override IEnumerable<Domain> GetDomains()


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.SecurityModel ► ConfigDomainProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.
ArgumentException | The name of the provider has a length of zero.


RemoveDomain Method (domainName)

RemoveDomain Method (domainName)
Namespaces ► Sitecore.SecurityModel ► ConfigDomainProvider ► RemoveDomain(String)
Removes an existing domain from the system.
Declaration Syntax
C#
public override void RemoveDomain(
    string domainName
)
Parameters
domainName (String)
Name of the domain.


Credentials Class

Credentials Class
Namespaces ► Sitecore.SecurityModel ► Credentials
Represents a set of credentials.
Declaration Syntax
C#
public sealed class Credentials
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Credentials()()() | Initializes a new instance of the Credentials class
 | CustomData | Gets or sets the custom data.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Password | Gets or sets the password.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserName | Gets or sets the name of the user.
Inheritance Hierarchy
Object
Credentials


Credentials Constructor

Credentials Constructor
Namespaces ► Sitecore.SecurityModel ► Credentials ► Credentials()()()
Initializes a new instance of the Credentials class
Declaration Syntax
C#
public Credentials()


CustomData Property

CustomData Property
Namespaces ► Sitecore.SecurityModel ► Credentials ► CustomData
Gets or sets the custom data.
Declaration Syntax
C#
public string CustomData { get; set; }
Value
The custom data.


Password Property

Password Property
Namespaces ► Sitecore.SecurityModel ► Credentials ► Password
Gets or sets the password.
Declaration Syntax
C#
public string Password { get; set; }
Value
The password.


UserName Property

UserName Property
Namespaces ► Sitecore.SecurityModel ► Credentials ► UserName
Gets or sets the name of the user.
Declaration Syntax
C#
public string UserName { get; set; }
Value
The name of the user.


DatabaseDomainProvider Class

DatabaseDomainProvider Class
Namespaces ► Sitecore.SecurityModel ► DatabaseDomainProvider
ItemBasedDomainProvider class
Declaration Syntax
C#
public class DatabaseDomainProvider : DomainProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatabaseDomainProvider(String, String) | Initializes a new instance of the DatabaseDomainProvider class.
 | AddDomain(String, Boolean) | Adds a new domain to the system. (Overrides DomainProvider.AddDomain(String, Boolean).)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | DomainExists(String) | Determines if a domain with the specified name exists. (Inherited from DomainProvider.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConfiguration()()() | Gets the configuration. (Inherited from DomainProvider.)
 | GetDefaultDomain()()() | Gets the default domain. (Overrides DomainProvider.GetDefaultDomain()()().)
 | GetDomain(String) | Gets a named domain. (Overrides DomainProvider.GetDomain(String).)
 | GetDomainNames()()() | Gets the domain names. (Inherited from DomainProvider.)
 | GetDomains()()() | Gets all domains handled by the provider. (Overrides DomainProvider.GetDomains()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | RemoveDomain(String) | Removes an existing domain from the system. (Overrides DomainProvider.RemoveDomain(String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | DomainProvider
 |  |  | DatabaseDomainProvider


DatabaseDomainProvider Constructor (databaseName, rootPath)

DatabaseDomainProvider Constructor (databaseName, rootPath)
Namespaces ► Sitecore.SecurityModel ► DatabaseDomainProvider ► DatabaseDomainProvider(String, String)
Initializes a new instance of the DatabaseDomainProvider class.
Declaration Syntax
C#
public DatabaseDomainProvider(
    string databaseName,
    string rootPath
)
Parameters
databaseName (String)
Name of the database.
rootPath (String)
The root path.


AddDomain Method (domainName, locallyManaged)

AddDomain Method (domainName, locallyManaged)
Namespaces ► Sitecore.SecurityModel ► DatabaseDomainProvider ► AddDomain(String, Boolean)
Adds a new domain to the system.
Declaration Syntax
C#
public override void AddDomain(
    string domainName,
    bool locallyManaged
)
Parameters
domainName (String)
Name of the domain.
locallyManaged (Boolean)
If set to true, the domain is locally managed.


GetDefaultDomain Method

GetDefaultDomain Method
Namespaces ► Sitecore.SecurityModel ► DatabaseDomainProvider ► GetDefaultDomain()()()
Gets the default domain.
Declaration Syntax
C#
public override Domain GetDefaultDomain()


GetDomain Method (name)

GetDomain Method (name)
Namespaces ► Sitecore.SecurityModel ► DatabaseDomainProvider ► GetDomain(String)
Gets a named domain.
Declaration Syntax
C#
public override Domain GetDomain(
    string name
)
Parameters
name (String)


GetDomains Method

GetDomains Method
Namespaces ► Sitecore.SecurityModel ► DatabaseDomainProvider ► GetDomains()()()
Gets all domains handled by the provider.
Declaration Syntax
C#
public override IEnumerable<Domain> GetDomains()


RemoveDomain Method (domainName)

RemoveDomain Method (domainName)
Namespaces ► Sitecore.SecurityModel ► DatabaseDomainProvider ► RemoveDomain(String)
Removes an existing domain from the system.
Declaration Syntax
C#
public override void RemoveDomain(
    string domainName
)
Parameters
domainName (String)
Name of the domain.
Exceptions
Exception | Condition
ProviderIsReadOnlyException | The DatabaseDomainProvider does not support removing domains programmatically. Please edit the config files instead.


DomainAccessArgs Class

DomainAccessArgs Class
Namespaces ► Sitecore.SecurityModel ► DomainAccessArgs
Represents a set of domain access arguments.
Declaration Syntax
C#
public class DomainAccessArgs : CancelEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainAccessArgs(User) | Initializes a new instance of the DomainAccessArgs class.
 | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets or sets the message.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | User | Gets the user.
Inheritance Hierarchy
Object
 | EventArgs
 |  | CancelEventArgs
 |  |  | DomainAccessArgs


DomainAccessArgs Constructor (user)

DomainAccessArgs Constructor (user)
Namespaces ► Sitecore.SecurityModel ► DomainAccessArgs ► DomainAccessArgs(User)
Initializes a new instance of the DomainAccessArgs class.
Declaration Syntax
C#
public DomainAccessArgs(
    User user
)
Parameters
user (User)
The user.


Message Property

Message Property
Namespaces ► Sitecore.SecurityModel ► DomainAccessArgs ► Message
Gets or sets the message.
Declaration Syntax
C#
public virtual string Message { get; set; }
Value
The message.


User Property

User Property
Namespaces ► Sitecore.SecurityModel ► DomainAccessArgs ► User
Gets the user.
Declaration Syntax
C#
public virtual User User { get; }
Value
The user.


DomainAccessDelegate Delegate

DomainAccessDelegate Delegate
Namespaces ► Sitecore.SecurityModel ► DomainAccessDelegate
Declaration Syntax
C#
public delegate void DomainAccessDelegate(
    Object sender,
    DomainAccessArgs args
)
Parameters
sender (Object)
args (DomainAccessArgs)


DomainAccessResult Structure

DomainAccessResult Structure
Namespaces ► Sitecore.SecurityModel ► DomainAccessResult
Represents a domain access result.
Declaration Syntax
C#
public struct DomainAccessResult
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainAccessResult(Boolean, String) | Initializes a new instance of the DomainAccessResult class.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message.
 | Success | Gets a value indicating whether this DomainAccessResult is success.
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


DomainAccessResult Constructor (success, message)

DomainAccessResult Constructor (success, message)
Namespaces ► Sitecore.SecurityModel ► DomainAccessResult ► DomainAccessResult(Boolean, String)
Initializes a new instance of the DomainAccessResult class.
Declaration Syntax
C#
public DomainAccessResult(
    bool success,
    string message
)
Parameters
success (Boolean)
if set to true this instance is success.
message (String)
The message.


Message Property

Message Property
Namespaces ► Sitecore.SecurityModel ► DomainAccessResult ► Message
Gets the message.
Declaration Syntax
C#
public string Message { get; }
Value
The message.


Success Property

Success Property
Namespaces ► Sitecore.SecurityModel ► DomainAccessResult ► Success
Gets a value indicating whether this DomainAccessResult is success.
Declaration Syntax
C#
public bool Success { get; }
Value
true if success; otherwise, false.


DomainCollection Class

DomainCollection Class
Namespaces ► Sitecore.SecurityModel ► DomainCollection
DomainCollection class
Declaration Syntax
C#
public class DomainCollection : Collection<Domain>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainCollection()()() | Initializes a new instance of the DomainCollection class
 | Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Domain >)>).)
 | Clear()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Domain >)>).)
 | ClearItems()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Domain >)>).)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Domain >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Domain >)>).)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Domain >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Domain >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Domain >)>).)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Domain >)>).)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Domain >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Domain >)>).)
 | Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Domain >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Domain >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Domain >)>).)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Domain >)>).)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection<(Of <( Domain >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection<(Of <( Domain >)>)
 |  | DomainCollection


DomainCollection Constructor

DomainCollection Constructor
Namespaces ► Sitecore.SecurityModel ► DomainCollection ► DomainCollection()()()
Initializes a new instance of the DomainCollection class
Declaration Syntax
C#
public DomainCollection()


DomainManager Class

DomainManager Class
Namespaces ► Sitecore.SecurityModel ► DomainManager
DomainManager class
Declaration Syntax
C#
public static class DomainManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddDomain(String) | Adds a new domain to the system.
 | AddDomain(String, Boolean) | Adds a domain.
 | DomainExists(String) | Determines if a domain with the specified name exists.
 | GetConfiguration()()() | Gets the configuration.
 | GetDefaultDomain()()() | Gets the default domain.
 | GetDomain(String) | Gets a named domain.
 | GetDomainForUser(String) | Gets the domain handling the user.
 | GetDomainNames()()() | Gets all domains handled by the current provider.
 | GetDomains()()() | Gets all domains handled by the current provider.
 | Provider | Gets the providers.
 | Providers | Gets the providers.
 | RemoveDomain(String) | Removes a domain.
Inheritance Hierarchy
Object
DomainManager


AddDomain Method

AddDomain Method
Namespaces ► Sitecore.SecurityModel ► DomainManager ► AddDomain()()()
Members
Icon | Member | Description
 | AddDomain(String) | Adds a new domain to the system.
 | AddDomain(String, Boolean) | Adds a domain.


AddDomain Method (domainName)

AddDomain Method (domainName)
Namespaces ► Sitecore.SecurityModel ► DomainManager ► AddDomain(String)
Adds a new domain to the system.
Declaration Syntax
C#
public static void AddDomain(
    string domainName
)
Parameters
domainName (String)
Name of the domain.


AddDomain Method (domainName, locallyManaged)

AddDomain Method (domainName, locallyManaged)
Namespaces ► Sitecore.SecurityModel ► DomainManager ► AddDomain(String, Boolean)
Adds a domain.
Declaration Syntax
C#
public static void AddDomain(
    string domainName,
    bool locallyManaged
)
Parameters
domainName (String)
Name of the domain.
locallyManaged (Boolean)
If set to true, the domain is locally managed.


DomainExists Method (domainName)

DomainExists Method (domainName)
Namespaces ► Sitecore.SecurityModel ► DomainManager ► DomainExists(String)
Determines if a domain with the specified name exists.
Declaration Syntax
C#
public static bool DomainExists(
    string domainName
)
Parameters
domainName (String)
Name of the domain.
Return Value


GetConfiguration Method

GetConfiguration Method
Namespaces ► Sitecore.SecurityModel ► DomainManager ► GetConfiguration()()()
Gets the configuration.
Declaration Syntax
C#
public static DomainConfiguration GetConfiguration()
Return Value


GetDefaultDomain Method

GetDefaultDomain Method
Namespaces ► Sitecore.SecurityModel ► DomainManager ► GetDefaultDomain()()()
Gets the default domain.
Declaration Syntax
C#
public static Domain GetDefaultDomain()


GetDomain Method (name)

GetDomain Method (name)
Namespaces ► Sitecore.SecurityModel ► DomainManager ► GetDomain(String)
Gets a named domain.
Declaration Syntax
C#
public static Domain GetDomain(
    string name
)
Parameters
name (String)


GetDomainForUser Method (userName)

GetDomainForUser Method (userName)
Namespaces ► Sitecore.SecurityModel ► DomainManager ► GetDomainForUser(String)
Gets the domain handling the user.
Declaration Syntax
C#
public static Domain GetDomainForUser(
    string userName
)
Parameters
userName (String)
Name of the user.
Return Value
The domain for user.


GetDomainNames Method

GetDomainNames Method
Namespaces ► Sitecore.SecurityModel ► DomainManager ► GetDomainNames()()()
Gets all domains handled by the current provider.
Declaration Syntax
C#
public static IEnumerable<string> GetDomainNames()


GetDomains Method

GetDomains Method
Namespaces ► Sitecore.SecurityModel ► DomainManager ► GetDomains()()()
Gets all domains handled by the current provider.
Declaration Syntax
C#
public static IEnumerable<Domain> GetDomains()


Provider Property

Provider Property
Namespaces ► Sitecore.SecurityModel ► DomainManager ► Provider
Gets the providers.
Declaration Syntax
C#
public static DomainProvider Provider { get; }
Value
The providers.


Providers Property

Providers Property
Namespaces ► Sitecore.SecurityModel ► DomainManager ► Providers
Gets the providers.
Declaration Syntax
C#
public static DomainProviderCollection Providers { get; }
Value
The providers.


RemoveDomain Method (domainName)

RemoveDomain Method (domainName)
Namespaces ► Sitecore.SecurityModel ► DomainManager ► RemoveDomain(String)
Removes a domain.
Declaration Syntax
C#
public static void RemoveDomain(
    string domainName
)
Parameters
domainName (String)
Name of the domain.


DomainProvider Class

DomainProvider Class
Namespaces ► Sitecore.SecurityModel ► DomainProvider
DomainProvider class
Declaration Syntax
C#
public abstract class DomainProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainProvider()()() | Initializes a new instance of the DomainProvider class
 | AddDomain(String, Boolean) | Adds a new domain to the system.
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | DomainExists(String) | Determines if a domain with the specified name exists.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConfiguration()()() | Gets the configuration.
 | GetDefaultDomain()()() | Gets the default domain.
 | GetDomain(String) | Gets a named domain.
 | GetDomainNames()()() | Gets the domain names.
 | GetDomains()()() | Gets all domains handled by the provider.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Inherited from ProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | RemoveDomain(String) | Removes an existing domain from the system.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | DomainProvider
 |  |  | ConfigStoreDomainProvider
 |  |  | ConfigDomainProvider
 |  |  | DatabaseDomainProvider


DomainProvider Constructor

DomainProvider Constructor
Namespaces ► Sitecore.SecurityModel ► DomainProvider ► DomainProvider()()()
Initializes a new instance of the DomainProvider class
Declaration Syntax
C#
protected DomainProvider()


AddDomain Method (domainName, locallyManaged)

AddDomain Method (domainName, locallyManaged)
Namespaces ► Sitecore.SecurityModel ► DomainProvider ► AddDomain(String, Boolean)
Adds a new domain to the system.
Declaration Syntax
C#
public abstract void AddDomain(
    string domainName,
    bool locallyManaged
)
Parameters
domainName (String)
Name of the domain.
locallyManaged (Boolean)
If set to true, the domain is locally managed.


DomainExists Method (domainName)

DomainExists Method (domainName)
Namespaces ► Sitecore.SecurityModel ► DomainProvider ► DomainExists(String)
Determines if a domain with the specified name exists.
Declaration Syntax
C#
public virtual bool DomainExists(
    string domainName
)
Parameters
domainName (String)
Name of the domain.
Return Value


GetConfiguration Method

GetConfiguration Method
Namespaces ► Sitecore.SecurityModel ► DomainProvider ► GetConfiguration()()()
Gets the configuration.
Declaration Syntax
C#
public virtual DomainConfiguration GetConfiguration()
Return Value


GetDefaultDomain Method

GetDefaultDomain Method
Namespaces ► Sitecore.SecurityModel ► DomainProvider ► GetDefaultDomain()()()
Gets the default domain.
Declaration Syntax
C#
public virtual Domain GetDefaultDomain()


GetDomain Method (name)

GetDomain Method (name)
Namespaces ► Sitecore.SecurityModel ► DomainProvider ► GetDomain(String)
Gets a named domain.
Declaration Syntax
C#
public abstract Domain GetDomain(
    string name
)
Parameters
name (String)


GetDomainNames Method

GetDomainNames Method
Namespaces ► Sitecore.SecurityModel ► DomainProvider ► GetDomainNames()()()
Gets the domain names.
Declaration Syntax
C#
public virtual IEnumerable<string> GetDomainNames()
Return Value


GetDomains Method

GetDomains Method
Namespaces ► Sitecore.SecurityModel ► DomainProvider ► GetDomains()()()
Gets all domains handled by the provider.
Declaration Syntax
C#
public abstract IEnumerable<Domain> GetDomains()


RemoveDomain Method (domainName)

RemoveDomain Method (domainName)
Namespaces ► Sitecore.SecurityModel ► DomainProvider ► RemoveDomain(String)
Removes an existing domain from the system.
Declaration Syntax
C#
public abstract void RemoveDomain(
    string domainName
)
Parameters
domainName (String)
Name of the domain.


DomainProviderCollection Class

DomainProviderCollection Class
Namespaces ► Sitecore.SecurityModel ► DomainProviderCollection
DomainProviderCollection class
Declaration Syntax
C#
public class DomainProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainProviderCollection()()() | Initializes a new instance of the DomainProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Overrides ProviderCollection.Add(ProviderBase).)
 | Add(DomainProvider) | Adds a provider to the collection.
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the DomainProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | DomainProviderCollection


DomainProviderCollection Constructor

DomainProviderCollection Constructor
Namespaces ► Sitecore.SecurityModel ► DomainProviderCollection ► DomainProviderCollection()()()
Initializes a new instance of the DomainProviderCollection class
Declaration Syntax
C#
public DomainProviderCollection()


Add Method

Add Method
Namespaces ► Sitecore.SecurityModel ► DomainProviderCollection ► Add()()()
Members
Icon | Member | Description
 | Add(ProviderBase) | Adds a provider to the collection. (Overrides ProviderCollection.Add(ProviderBase).)
 | Add(DomainProvider) | Adds a provider to the collection.


Add Method (provider)

Add Method (provider)
Namespaces ► Sitecore.SecurityModel ► DomainProviderCollection ► Add(DomainProvider)
Adds a provider to the collection.
Declaration Syntax
C#
public virtual void Add(
    DomainProvider provider
)
Parameters
provider (DomainProvider)
The provider to be added.
Exceptions
Exception | Condition
ArgumentException | The Name of provider is null.- or -The length of the Name of provider is less than 1.
ArgumentNullException | provider is null.
NotSupportedException | The collection is read-only.


Add Method (provider)

Add Method (provider)
Namespaces ► Sitecore.SecurityModel ► DomainProviderCollection ► Add(ProviderBase)
Adds a provider to the collection.
Declaration Syntax
C#
public override void Add(
    ProviderBase provider
)
Parameters
provider (ProviderBase)
The provider to be added.
Exceptions
Exception | Condition
ArgumentException | The Name of provider is null.- or -The length of the Name of provider is less than 1.
ArgumentNullException | provider is null.
NotSupportedException | The collection is read-only.


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.SecurityModel ► DomainProviderCollection ► Item[([(String])])
Gets the DomainProvider with the specified name.
Declaration Syntax
C#
public virtual DomainProvider this[
    string name
] { get; }
Parameters
name (String)
Value


EntityType Enumeration

EntityType Enumeration
Namespaces ► Sitecore.SecurityModel ► EntityType
EntityType class
Declaration Syntax
C#
public enum EntityType
Members
Member | Description
Unknown | Unknown type.
User | A user.
Role | A role.


Policy Class

Policy Class
Namespaces ► Sitecore.SecurityModel ► Policy
Represents a Policy.
Declaration Syntax
C#
public static class Policy
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsAllowed(String) | Determines whether the specified name is allowed.
Inheritance Hierarchy
Object
Policy


IsAllowed Method (name)

IsAllowed Method (name)
Namespaces ► Sitecore.SecurityModel ► Policy ► IsAllowed(String)
Determines whether the specified name is allowed.
Declaration Syntax
C#
public static bool IsAllowed(
    string name
)
Parameters
name (String)
The name.
Return Value
true if the specified name is allowed; otherwise, false.


SecurityCheck Enumeration

SecurityCheck Enumeration
Namespaces ► Sitecore.SecurityModel ► SecurityCheck
Represents a security check.
Declaration Syntax
C#
public enum SecurityCheck
Members
Member | Description
Enable | Enabled.
Disable | Disabled.


SecurityContext Class

SecurityContext Class
Namespaces ► Sitecore.SecurityModel ► SecurityContext
Holds the current security context.
Declaration Syntax
C#
public class SecurityContext
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SecurityContext(Context..::.ContextData) | Initializes a new instance of the SecurityContext class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SecurityContext


SecurityContext Constructor (context)

SecurityContext Constructor (context)
Namespaces ► Sitecore.SecurityModel ► SecurityContext ► SecurityContext(Context..::.ContextData)
Initializes a new instance of the SecurityContext class.
Declaration Syntax
C#
public SecurityContext(
    Context..::.ContextData context
)
Parameters
context (Context..::.ContextData)
The context.


SecurityDisabler Class

SecurityDisabler Class
Namespaces ► Sitecore.SecurityModel ► SecurityDisabler
Disables security temporarily.
Declaration Syntax
C#
public class SecurityDisabler : SecurityStateSwitcher
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecurityDisabler()()() | Initializes a new instance of the SecurityDisabler class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <( SecurityState, SecurityState >)>)
 |  | Switcher <(Of <( SecurityState >)>)
 |  |  | SecurityStateSwitcher
 |  |  |  | SecurityDisabler


SecurityDisabler Constructor

SecurityDisabler Constructor
Namespaces ► Sitecore.SecurityModel ► SecurityDisabler ► SecurityDisabler()()()
Initializes a new instance of the SecurityDisabler class.
Declaration Syntax
C#
public SecurityDisabler()


SecurityEnabler Class

SecurityEnabler Class
Namespaces ► Sitecore.SecurityModel ► SecurityEnabler
Enables security temporarily.
Declaration Syntax
C#
public class SecurityEnabler : SecurityStateSwitcher
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecurityEnabler()()() | Initializes a new instance of the SecurityDisabler class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <( SecurityState, SecurityState >)>)
 |  | Switcher <(Of <( SecurityState >)>)
 |  |  | SecurityStateSwitcher
 |  |  |  | SecurityEnabler


SecurityEnabler Constructor

SecurityEnabler Constructor
Namespaces ► Sitecore.SecurityModel ► SecurityEnabler ► SecurityEnabler()()()
Initializes a new instance of the SecurityDisabler class.
Declaration Syntax
C#
public SecurityEnabler()


SecurityState Enumeration

SecurityState Enumeration
Namespaces ► Sitecore.SecurityModel ► SecurityState
Represents the current state of security.
Declaration Syntax
C#
public enum SecurityState
Members
Member | Description
Default |
Disabled |
Enabled |


SecurityStateSwitcher Class

SecurityStateSwitcher Class
Namespaces ► Sitecore.SecurityModel ► SecurityStateSwitcher
StateSwitcher class
Declaration Syntax
C#
public class SecurityStateSwitcher : Switcher<SecurityState>
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecurityStateSwitcher(SecurityState) | Initializes a new instance of the UserSwitcher class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <( SecurityState, SecurityState >)>)
 |  | Switcher <(Of <( SecurityState >)>)
 |  |  | SecurityStateSwitcher
 |  |  |  | SecurityDisabler
 |  |  |  | SecurityEnabler


SecurityStateSwitcher Constructor (state)

SecurityStateSwitcher Constructor (state)
Namespaces ► Sitecore.SecurityModel ► SecurityStateSwitcher ► SecurityStateSwitcher(SecurityState)
Initializes a new instance of the UserSwitcher class.
Declaration Syntax
C#
public SecurityStateSwitcher(
    SecurityState state
)
Parameters
state (SecurityState)
The state to switch to.


UserRuntimeSettings Class

UserRuntimeSettings Class
Namespaces ► Sitecore.SecurityModel ► UserRuntimeSettings
UserRuntimeSettings class
Declaration Syntax
C#
public class UserRuntimeSettings
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserRuntimeSettings()()() | Initializes a new instance of the UserRuntimeSettings class
 | AddedRoles | Gets the added roles.
 | Deserialize(String) | Serializes this instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAdministrator | Gets or sets a value indicating whether this user is an administrator.
 | IsVirtual | Gets or sets a value indicating whether this instance is virtual.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemovedRoles | Gets the removed roles.
 | Serialize()()() | Serializes this instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UserRuntimeSettings


UserRuntimeSettings Constructor

UserRuntimeSettings Constructor
Namespaces ► Sitecore.SecurityModel ► UserRuntimeSettings ► UserRuntimeSettings()()()
Initializes a new instance of the UserRuntimeSettings class
Declaration Syntax
C#
public UserRuntimeSettings()


AddedRoles Property

AddedRoles Property
Namespaces ► Sitecore.SecurityModel ► UserRuntimeSettings ► AddedRoles
Gets the added roles.
Declaration Syntax
C#
public virtual Set<string> AddedRoles { get; }
Value
The added roles.


Deserialize Method (data)

Deserialize Method (data)
Namespaces ► Sitecore.SecurityModel ► UserRuntimeSettings ► Deserialize(String)
Serializes this instance.
Declaration Syntax
C#
public virtual void Deserialize(
    string data
)
Parameters
data (String)
Return Value


IsAdministrator Property

IsAdministrator Property
Namespaces ► Sitecore.SecurityModel ► UserRuntimeSettings ► IsAdministrator
Gets or sets a value indicating whether this user is an administrator.
Declaration Syntax
C#
public virtual bool IsAdministrator { get; set; }
Value
true if this user is an administrator; otherwise, false.


IsVirtual Property

IsVirtual Property
Namespaces ► Sitecore.SecurityModel ► UserRuntimeSettings ► IsVirtual
Gets or sets a value indicating whether this instance is virtual.
Declaration Syntax
C#
public virtual bool IsVirtual { get; set; }
Value
true if this instance is virtual; otherwise, false.


RemovedRoles Property

RemovedRoles Property
Namespaces ► Sitecore.SecurityModel ► UserRuntimeSettings ► RemovedRoles
Gets the removed roles.
Declaration Syntax
C#
public virtual Set<string> RemovedRoles { get; }
Value
The removed roles.


Serialize Method

Serialize Method
Namespaces ► Sitecore.SecurityModel ► UserRuntimeSettings ► Serialize()()()
Serializes this instance.
Declaration Syntax
C#
public virtual string Serialize()
Return Value


Sitecore.SecurityModel.Cryptography Namespace

Sitecore.SecurityModel.Cryptography Namespace
Namespaces ► Sitecore.SecurityModel.Cryptography
Declaration Syntax
C#
namespace Sitecore.SecurityModel.Cryptography
Types
All Types Classes Enumerations
Icon | Type | Description
 | HashEncryption..::.EncryptionProvider | Type of encryption provider.
 | HashEncryption | Represents a class for hash encryption.
 | PasswordGenerator | Represents a password generator.


HashEncryption Class

HashEncryption Class
Namespaces ► Sitecore.SecurityModel.Cryptography ► HashEncryption
Represents a class for hash encryption.
Declaration Syntax
C#
public class HashEncryption
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HashEncryption()()() | Initializes a new instance of the HashEncryption class.
 | HashEncryption(HashEncryption..::.EncryptionProvider) | Initializes a new instance of the HashEncryption class.
 | HashEncryption(HashAlgorithm) | Constructor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hash(String) | Encrypt a string
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HashEncryption


HashEncryption Constructor

HashEncryption Constructor
Namespaces ► Sitecore.SecurityModel.Cryptography ► HashEncryption ► HashEncryption()()()
Members
Icon | Member | Description
 | HashEncryption()()() | Initializes a new instance of the HashEncryption class.
 | HashEncryption(HashEncryption..::.EncryptionProvider) | Initializes a new instance of the HashEncryption class.
 | HashEncryption(HashAlgorithm) | Constructor


HashEncryption Constructor

HashEncryption Constructor
Namespaces ► Sitecore.SecurityModel.Cryptography ► HashEncryption ► HashEncryption()()()
Initializes a new instance of the HashEncryption class.
Declaration Syntax
C#
public HashEncryption()


HashEncryption Constructor (provider)

HashEncryption Constructor (provider)
Namespaces ► Sitecore.SecurityModel.Cryptography ► HashEncryption ► HashEncryption(HashEncryption..::.EncryptionProvider)
Initializes a new instance of the HashEncryption class.
Declaration Syntax
C#
public HashEncryption(
    HashEncryption..::.EncryptionProvider provider
)
Parameters
provider (HashEncryption..::.EncryptionProvider)
The provider.


HashEncryption Constructor (provider)

HashEncryption Constructor (provider)
Namespaces ► Sitecore.SecurityModel.Cryptography ► HashEncryption ► HashEncryption(HashAlgorithm)
Constructor
Declaration Syntax
C#
public HashEncryption(
    HashAlgorithm provider
)
Parameters
provider (HashAlgorithm)
The provider.


Hash Method (sData)

Hash Method (sData)
Namespaces ► Sitecore.SecurityModel.Cryptography ► HashEncryption ► Hash(String)
Encrypt a string
Declaration Syntax
C#
public string Hash(
    string sData
)
Parameters
sData (String)
The s data.
Return Value
The String.


HashEncryption.EncryptionProvider Enumeration

HashEncryption..::.EncryptionProvider Enumeration
Namespaces ► Sitecore.SecurityModel.Cryptography ► HashEncryption ► HashEncryption..::.EncryptionProvider
Type of encryption provider.
Declaration Syntax
C#
public enum EncryptionProvider
Members
Member | Description
MD5 | MD5.
SHA1 | SHA1.
SHA256 | SHA256.
SHA384 | SHA384.
SHA512 | SHA512.


PasswordGenerator Class

PasswordGenerator Class
Namespaces ► Sitecore.SecurityModel.Cryptography ► PasswordGenerator
Represents a password generator.
Declaration Syntax
C#
public class PasswordGenerator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PasswordGenerator()()() | Initializes a new instance of the PasswordGenerator class.
 | ConsecutiveCharacters | Gets or sets a value indicating whether the PasswordGenerator allows consecutive characters.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExcludeSymbols | Gets or sets a value indicating whether the PasswordGenerator excludes the symbols.
 | Exclusions | Gets or sets the exclusions.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Generate()()() | Generates a password.
 | GetCryptographicRandomNumber(Int32, Int32) | Gets the cryptographic random number.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRandomCharacter()()() | Gets the random character.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MaximumCharacters | Gets or sets the maximum characters.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumCharacters | Gets or sets the minimum characters.
 | RepeatCharacters | Gets or sets a value indicating whether the PasswordGenerator allows repeating characters.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PasswordGenerator


PasswordGenerator Constructor

PasswordGenerator Constructor
Namespaces ► Sitecore.SecurityModel.Cryptography ► PasswordGenerator ► PasswordGenerator()()()
Initializes a new instance of the PasswordGenerator class.
Declaration Syntax
C#
public PasswordGenerator()


ConsecutiveCharacters Property

ConsecutiveCharacters Property
Namespaces ► Sitecore.SecurityModel.Cryptography ► PasswordGenerator ► ConsecutiveCharacters
Gets or sets a value indicating whether the PasswordGenerator allows consecutive characters.
Declaration Syntax
C#
public bool ConsecutiveCharacters { get; set; }
Value
true if the PasswordGenerator allows consecutive characters; otherwise, false.


ExcludeSymbols Property

ExcludeSymbols Property
Namespaces ► Sitecore.SecurityModel.Cryptography ► PasswordGenerator ► ExcludeSymbols
Gets or sets a value indicating whether the PasswordGenerator excludes the symbols.
Declaration Syntax
C#
public bool ExcludeSymbols { get; set; }
Value
true if the PasswordGenerator excludes the symbols; otherwise, false.


Exclusions Property

Exclusions Property
Namespaces ► Sitecore.SecurityModel.Cryptography ► PasswordGenerator ► Exclusions
Gets or sets the exclusions.
Declaration Syntax
C#
public string Exclusions { get; set; }
Value
The exclusions.


Generate Method

Generate Method
Namespaces ► Sitecore.SecurityModel.Cryptography ► PasswordGenerator ► Generate()()()
Generates a password.
Declaration Syntax
C#
public string Generate()
Return Value
The String.


GetCryptographicRandomNumber Method (lower, upper)

GetCryptographicRandomNumber Method (lower, upper)
Namespaces ► Sitecore.SecurityModel.Cryptography ► PasswordGenerator ► GetCryptographicRandomNumber(Int32, Int32)
Gets the cryptographic random number.
Declaration Syntax
C#
protected int GetCryptographicRandomNumber(
    int lower,
    int upper
)
Parameters
lower (Int32)
The lower.
upper (Int32)
The upper.
Return Value
The cryptographic random number.


GetRandomCharacter Method

GetRandomCharacter Method
Namespaces ► Sitecore.SecurityModel.Cryptography ► PasswordGenerator ► GetRandomCharacter()()()
Gets the random character.
Declaration Syntax
C#
protected char GetRandomCharacter()
Return Value
The random character.


MaximumCharacters Property

MaximumCharacters Property
Namespaces ► Sitecore.SecurityModel.Cryptography ► PasswordGenerator ► MaximumCharacters
Gets or sets the maximum characters.
Declaration Syntax
C#
public int MaximumCharacters { get; set; }
Value
The maximum characters.


MinimumCharacters Property

MinimumCharacters Property
Namespaces ► Sitecore.SecurityModel.Cryptography ► PasswordGenerator ► MinimumCharacters
Gets or sets the minimum characters.
Declaration Syntax
C#
public int MinimumCharacters { get; set; }
Value
The minimum characters.


RepeatCharacters Property

RepeatCharacters Property
Namespaces ► Sitecore.SecurityModel.Cryptography ► PasswordGenerator ► RepeatCharacters
Gets or sets a value indicating whether the PasswordGenerator allows repeating characters.
Declaration Syntax
C#
public bool RepeatCharacters { get; set; }
Value
true if the PasswordGenerator allows repeating characters; otherwise, false.


Sitecore.SecurityModel.License Namespace

Sitecore.SecurityModel.License Namespace
Namespaces ► Sitecore.SecurityModel.License
Declaration Syntax
C#
namespace Sitecore.SecurityModel.License
Types
All Types Classes Enumerations
Icon | Type | Description
 | CheckResult | Defines possible return values.
 | License | Implements a static class that encapsulates the Sitecore license file.
 | LicenseException | LicenseException class
 | LicenseManager | LicenseManager class
 | LicenseWatcher | Implements a file watcher that monitors changes in the license file.


CheckResult Enumeration

CheckResult Enumeration
Namespaces ► Sitecore.SecurityModel.License ► CheckResult
Defines possible return values.
Declaration Syntax
C#
public enum CheckResult
Members
Member | Description
Valid | Valid.
NotPresent | Not present.
NoExpiration | No expiration.
Expired | Expired
Corrupt | Corrupt


License Class

License Class
Namespaces ► Sitecore.SecurityModel.License ► License
Implements a static class that encapsulates the Sitecore license file.
Declaration Syntax
C#
public sealed class License
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | License()()() | Initializes a new instance of the License class
 | Address | Gets the company address.
 | CompanyNo | Gets the company number.
 | ContentManagerName | name of ContentManager license.
 | DemandModule(String) | Demands the module.
 | EditorUserName | name of EditorUser license.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Expiration | Gets the license expiration date.
 | ExpressName | name of Express license.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetModuleCount(String) | Gets the count value of a module.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasModule(String) | Checks if a specific module has been licensed.
 | LastError | Gets the last error message.
 | LicenseAgreement | Gets the text of license agreement.
 | Licensee | Gets the name of the licensee.
 | LicenseID | Gets the license ID.
 | LicenseStatus(String) | Licenses the status.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Purpose | Gets the purpose string.
 | Reseller | Gets the name of the reseller.
 | ResellerUrl | Gets the URL of the reseller.
 | Reset()()() | Resets this instance.
 | RuntimeName | name of Runtime license.
 | SizeLimitName | name of SizeLimit license.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Urls | Gets the company URLs.
 | VerifiedLicense()()() | Returns the verified license.
 | Version | Gets the version.
Examples
The following example checks that a specific module has a valid license.
CopyC#
string requiredLicense = "SiteCore.MyModule";
Error.Assert(Sitecore.License.HasModule(requiredLicense), "Can not use the module without the following license: " + requiredLicense);
Inheritance Hierarchy
Object
License


License Constructor

License Constructor
Namespaces ► Sitecore.SecurityModel.License ► License ► License()()()
Initializes a new instance of the License class
Declaration Syntax
C#
public License()


Address Property

Address Property
Namespaces ► Sitecore.SecurityModel.License ► License ► Address
Gets the company address.
Declaration Syntax
C#
public static string Address { get; }
Value
The company address.
Remarks
This information is provided when the license form is filled in.


CompanyNo Property

CompanyNo Property
Namespaces ► Sitecore.SecurityModel.License ► License ► CompanyNo
Gets the company number.
Declaration Syntax
C#
public static string CompanyNo { get; }
Value
The company number.
Remarks
This information is provided when the license form is filled in.


ContentManagerName Field

ContentManagerName Field
Namespaces ► Sitecore.SecurityModel.License ► License ► ContentManagerName
name of ContentManager license.
Declaration Syntax
C#
public const string ContentManagerName


DemandModule Method (moduleName)

DemandModule Method (moduleName)
Namespaces ► Sitecore.SecurityModel.License ► License ► DemandModule(String)
Demands the module.
Declaration Syntax
C#
public static void DemandModule(
    string moduleName
)
Parameters
moduleName (String)
Name of the module.


EditorUserName Field

EditorUserName Field
Namespaces ► Sitecore.SecurityModel.License ► License ► EditorUserName
name of EditorUser license.
Declaration Syntax
C#
public const string EditorUserName


Expiration Property

Expiration Property
Namespaces ► Sitecore.SecurityModel.License ► License ► Expiration
Gets the license expiration date.
Declaration Syntax
C#
public static string Expiration { get; }
Value
The license expiration date.
Remarks
The license is invalid when the expiration date has been exceeded.


ExpressName Field

ExpressName Field
Namespaces ► Sitecore.SecurityModel.License ► License ► ExpressName
name of Express license.
Declaration Syntax
C#
public const string ExpressName


GetModuleCount Method (name)

GetModuleCount Method (name)
Namespaces ► Sitecore.SecurityModel.License ► License ► GetModuleCount(String)
Gets the count value of a module.
Declaration Syntax
C#
public static int GetModuleCount(
    string name
)
Parameters
name (String)
The name of the module.
Return Value
The value of the count attribute for the module or 0 (zero) if no such attribute is available.


HasModule Method (name)

HasModule Method (name)
Namespaces ► Sitecore.SecurityModel.License ► License ► HasModule(String)
Checks if a specific module has been licensed.
Declaration Syntax
C#
public static bool HasModule(
    string name
)
Parameters
name (String)
The name of the module.
Return Value
True, if the license for the module is valid, otherwise false.
Examples
The following example checks that a specific module has a valid license.
CopyC#
string requiredLicense = "SiteCore.MyModule";
Error.Assert(Sitecore.License.HasModule(requiredLicense), "Can not use the module without the following license: " + requiredLicense);


LastError Property

LastError Property
Namespaces ► Sitecore.SecurityModel.License ► License ► LastError
Gets the last error message.
Declaration Syntax
C#
public static string LastError { get; set; }
Value
The message of the last error.


LicenseAgreement Property

LicenseAgreement Property
Namespaces ► Sitecore.SecurityModel.License ► License ► LicenseAgreement
Gets the text of license agreement.
Declaration Syntax
C#
public static string LicenseAgreement { get; }
Value
The license agreement text.


Licensee Property

Licensee Property
Namespaces ► Sitecore.SecurityModel.License ► License ► Licensee
Gets the name of the licensee.
Declaration Syntax
C#
public static string Licensee { get; }
Value
The name of the licensee
Remarks
This information is provided when the license form is filled in.


LicenseID Property

LicenseID Property
Namespaces ► Sitecore.SecurityModel.License ► License ► LicenseID
Gets the license ID.
Declaration Syntax
C#
public static string LicenseID { get; }
Value
The ID of the license.


LicenseStatus Method (name)

LicenseStatus Method (name)
Namespaces ► Sitecore.SecurityModel.License ► License ► LicenseStatus(String)
Licenses the status.
Declaration Syntax
C#
public static CheckResult LicenseStatus(
    string name
)
Parameters
name (String)
The name.
Return Value
The status.


Purpose Property

Purpose Property
Namespaces ► Sitecore.SecurityModel.License ► License ► Purpose
Gets the purpose string.
Declaration Syntax
C#
public static string Purpose { get; }
Value
The purpose.
Remarks
This information is provided when the license form is filled in.


Reseller Property

Reseller Property
Namespaces ► Sitecore.SecurityModel.License ► License ► Reseller
Gets the name of the reseller.
Declaration Syntax
C#
public static string Reseller { get; }
Value
The name of the reseller.
Remarks
This information is provided when the license form is filled in.


ResellerUrl Property

ResellerUrl Property
Namespaces ► Sitecore.SecurityModel.License ► License ► ResellerUrl
Gets the URL of the reseller.
Declaration Syntax
C#
public static string ResellerUrl { get; }
Value
The URL of the reseller.
Remarks
This information is provided when the license form is filled in.


Reset Method

Reset Method
Namespaces ► Sitecore.SecurityModel.License ► License ► Reset()()()
Resets this instance.
Declaration Syntax
C#
public static void Reset()


RuntimeName Field

RuntimeName Field
Namespaces ► Sitecore.SecurityModel.License ► License ► RuntimeName
name of Runtime license.
Declaration Syntax
C#
public const string RuntimeName


SizeLimitName Field

SizeLimitName Field
Namespaces ► Sitecore.SecurityModel.License ► License ► SizeLimitName
name of SizeLimit license.
Declaration Syntax
C#
public const string SizeLimitName


Urls Property

Urls Property
Namespaces ► Sitecore.SecurityModel.License ► License ► Urls
Gets the company URLs.
Declaration Syntax
C#
public static string Urls { get; }
Value
The company URLs.
Remarks
This information is provided when the license form is filled in.


VerifiedLicense Method

VerifiedLicense Method
Namespaces ► Sitecore.SecurityModel.License ► License ► VerifiedLicense()()()
Returns the verified license.
Declaration Syntax
C#
public static XmlDocument VerifiedLicense()
Return Value
An XmlDocument containing the verified license.


Version Property

Version Property
Namespaces ► Sitecore.SecurityModel.License ► License ► Version
Gets the version.
Declaration Syntax
C#
public static string Version { get; }
Value
The version.


LicenseException Class

LicenseException Class
Namespaces ► Sitecore.SecurityModel.License ► LicenseException
LicenseException class
Declaration Syntax
C#
[SerializableAttribute]
public class LicenseException : SitecoreException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LicenseException()()() | Initializes a new instance of the LicenseException class.
 | LicenseException(String) | Initializes a new instance of the LicenseException class.
 | LicenseException(String, Exception) | Initializes a new instance of the LicenseException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SitecoreException
 |  |  | LicenseException


LicenseException Constructor

LicenseException Constructor
Namespaces ► Sitecore.SecurityModel.License ► LicenseException ► LicenseException()()()
Members
Icon | Member | Description
 | LicenseException()()() | Initializes a new instance of the LicenseException class.
 | LicenseException(String) | Initializes a new instance of the LicenseException class.
 | LicenseException(String, Exception) | Initializes a new instance of the LicenseException class.


LicenseException Constructor

LicenseException Constructor
Namespaces ► Sitecore.SecurityModel.License ► LicenseException ► LicenseException()()()
Initializes a new instance of the LicenseException class.
Declaration Syntax
C#
public LicenseException()


LicenseException Constructor (message)

LicenseException Constructor (message)
Namespaces ► Sitecore.SecurityModel.License ► LicenseException ► LicenseException(String)
Initializes a new instance of the LicenseException class.
Declaration Syntax
C#
public LicenseException(
    string message
)
Parameters
message (String)
The message.


LicenseException Constructor (message, innerException)

LicenseException Constructor (message, innerException)
Namespaces ► Sitecore.SecurityModel.License ► LicenseException ► LicenseException(String, Exception)
Initializes a new instance of the LicenseException class.
Declaration Syntax
C#
public LicenseException(
    string message,
    Exception innerException
)
Parameters
message (String)
The message.
innerException (Exception)
The inner exception.


LicenseManager Class

LicenseManager Class
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager
LicenseManager class
Declaration Syntax
C#
public static class LicenseManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AssertDictionaryEntriesLimit()()() | Asserts the current dictionary entry limit.
 | AssertSizeLimit()()() | Asserts the current size limit.
 | AssertSystemNotBlocked()()() | Asserts that the system has not been blocked.
 | BlockSystem(String) | Blocks the system.
 | DemandRuntime()()() | Demands the runtime license.
 | DemandRuntime(Boolean) | Demands the runtime license.
 | GetBaseDataSize()()() | Gets the size of the base data.
 | GetBaseDictionaryEntryCount()()() | Gets base number of dictionary entries.
 | GetDatabaseSize(Database) | Gets the size of a database.
 | GetDatabaseSizes()()() | Gets the sizes of all databases in the system.
 | GetEditorUserCount()()() | Gets the editor user count.
 | GetMinMaxEntitySize()()() | Gets the min and max entity sizes.
 | GetSizeLimit()()() | Gets the size limit.
 | GetTotalDataSize()()() | Gets the total size of all data in the system.
 | HasContentManager | Determines whether the current license includes ContentManager.
 | HasExpress | Determines whether the current license includes Express.
 | HasRuntime | Determines whether the current license includes Runtime.
 | Initialize()()() | Initializes class.
 | IsSystemBlocked()()() | Determines whether the system is blocked.
 | ResetLicense()()() | Resets the license.
Inheritance Hierarchy
Object
LicenseManager


AssertDictionaryEntriesLimit Method

AssertDictionaryEntriesLimit Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► AssertDictionaryEntriesLimit()()()
Asserts the current dictionary entry limit.
Declaration Syntax
C#
public static void AssertDictionaryEntriesLimit()


AssertSizeLimit Method

AssertSizeLimit Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► AssertSizeLimit()()()
Asserts the current size limit.
Declaration Syntax
C#
public static void AssertSizeLimit()


AssertSystemNotBlocked Method

AssertSystemNotBlocked Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► AssertSystemNotBlocked()()()
Asserts that the system has not been blocked.
Declaration Syntax
C#
public static void AssertSystemNotBlocked()


BlockSystem Method (reason)

BlockSystem Method (reason)
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► BlockSystem(String)
Blocks the system.
Declaration Syntax
C#
public static void BlockSystem(
    string reason
)
Parameters
reason (String)
The reason.


DemandRuntime Method

DemandRuntime Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► DemandRuntime()()()
Members
Icon | Member | Description
 | DemandRuntime()()() | Demands the runtime license.
 | DemandRuntime(Boolean) | Demands the runtime license.


DemandRuntime Method

DemandRuntime Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► DemandRuntime()()()
Demands the runtime license.
Declaration Syntax
C#
public static void DemandRuntime()


DemandRuntime Method (acceptExpress)

DemandRuntime Method (acceptExpress)
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► DemandRuntime(Boolean)
Demands the runtime license.
Declaration Syntax
C#
public static void DemandRuntime(
    bool acceptExpress
)
Parameters
acceptExpress (Boolean)


GetBaseDataSize Method

GetBaseDataSize Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► GetBaseDataSize()()()
Gets the size of the base data.
Declaration Syntax
C#
public static long GetBaseDataSize()
Return Value


GetBaseDictionaryEntryCount Method

GetBaseDictionaryEntryCount Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► GetBaseDictionaryEntryCount()()()
Gets base number of dictionary entries.
Declaration Syntax
C#
public static long GetBaseDictionaryEntryCount()
Return Value


GetDatabaseSize Method (database)

GetDatabaseSize Method (database)
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► GetDatabaseSize(Database)
Gets the size of a database.
Declaration Syntax
C#
public static long GetDatabaseSize(
    Database database
)
Parameters
database (Database)


GetDatabaseSizes Method

GetDatabaseSizes Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► GetDatabaseSizes()()()
Gets the sizes of all databases in the system.
Declaration Syntax
C#
public static SafeDictionary<Database, long> GetDatabaseSizes()


GetEditorUserCount Method

GetEditorUserCount Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► GetEditorUserCount()()()
Gets the editor user count.
Declaration Syntax
C#
public static int GetEditorUserCount()
Return Value


GetMinMaxEntitySize Method

GetMinMaxEntitySize Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► GetMinMaxEntitySize()()()
Gets the min and max entity sizes.
Declaration Syntax
C#
public static Pair<int, int> GetMinMaxEntitySize()
Return Value


GetSizeLimit Method

GetSizeLimit Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► GetSizeLimit()()()
Gets the size limit.
Declaration Syntax
C#
public static long GetSizeLimit()
Return Value


GetTotalDataSize Method

GetTotalDataSize Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► GetTotalDataSize()()()
Gets the total size of all data in the system.
Declaration Syntax
C#
public static long GetTotalDataSize()
Return Value


HasContentManager Property

HasContentManager Property
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► HasContentManager
Determines whether the current license includes ContentManager.
Declaration Syntax
C#
public static bool HasContentManager { get; }
Return Value
true if the current license includes ContentManager; otherwise, false.


HasExpress Property

HasExpress Property
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► HasExpress
Determines whether the current license includes Express.
Declaration Syntax
C#
public static bool HasExpress { get; }
Value
true if the current license includes Express; otherwise, false.


HasRuntime Property

HasRuntime Property
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► HasRuntime
Determines whether the current license includes Runtime.
Declaration Syntax
C#
public static bool HasRuntime { get; }
Value
true if the current license includes Runtime; otherwise, false.


Initialize Method

Initialize Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► Initialize()()()
Initializes class.
Declaration Syntax
C#
public static void Initialize()


IsSystemBlocked Method

IsSystemBlocked Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► IsSystemBlocked()()()
Determines whether the system is blocked.
Declaration Syntax
C#
public static bool IsSystemBlocked()
Return Value
true if the system is blocked; otherwise, false.


ResetLicense Method

ResetLicense Method
Namespaces ► Sitecore.SecurityModel.License ► LicenseManager ► ResetLicense()()()
Resets the license.
Declaration Syntax
C#
public static void ResetLicense()


LicenseWatcher Class

LicenseWatcher Class
Namespaces ► Sitecore.SecurityModel.License ► LicenseWatcher
Implements a file watcher that monitors changes in the license file.
Declaration Syntax
C#
public class LicenseWatcher : FileWatcher
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LicenseWatcher()()() | Initializes a new instance of the LicenseWatcher class.
 | Created(String) | Called when a file has been created. (Overrides FileWatcher.Created(String).)
 | Deleted(String) | Called when a file has been deleted. (Overrides FileWatcher.Deleted(String).)
 | Dispose()()() | Application shutdown handler (Inherited from FileWatcher.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(HttpApplication) | Application startup handler (Inherited from FileWatcher.)
 | InitializeWatcher(String, String) | Initializes a file watcher. (Inherited from FileWatcher.)
 | InitializeWorker()()() | Initializes the worker. (Inherited from FileWatcher.)
 | MapPathToSiteCore(String, String, String) | Maps the path to a Sitecore path. (Inherited from FileWatcher.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnFileCreated(Object, FileSystemEventArgs) | File has been created. (Inherited from FileWatcher.)
 | OnFileDeleted(Object, FileSystemEventArgs) | File has been deleted. (Inherited from FileWatcher.)
 | OnFileRenamed(Object, RenamedEventArgs) | File has been renamed. (Inherited from FileWatcher.)
 | PathShouldBeIngnored(String) | Checks whether the pathes the should be ingnored. (Inherited from FileWatcher.)
 | Renamed(String, String) | Called when a file has been renamed. (Overrides FileWatcher.Renamed(String, String).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Is initialized from Nexus.
Inheritance Hierarchy
Object
 | FileWatcher
 |  | LicenseWatcher


LicenseWatcher Constructor

LicenseWatcher Constructor
Namespaces ► Sitecore.SecurityModel.License ► LicenseWatcher ► LicenseWatcher()()()
Initializes a new instance of the LicenseWatcher class.
Declaration Syntax
C#
public LicenseWatcher()


Created Method (filePath)

Created Method (filePath)
Namespaces ► Sitecore.SecurityModel.License ► LicenseWatcher ► Created(String)
Called when a file has been created.
Declaration Syntax
C#
protected override void Created(
    string filePath
)
Parameters
filePath (String)
The file path.


Deleted Method (filePath)

Deleted Method (filePath)
Namespaces ► Sitecore.SecurityModel.License ► LicenseWatcher ► Deleted(String)
Called when a file has been deleted.
Declaration Syntax
C#
protected override void Deleted(
    string filePath
)
Parameters
filePath (String)
The full path.


Renamed Method (filePath, oldFilePath)

Renamed Method (filePath, oldFilePath)
Namespaces ► Sitecore.SecurityModel.License ► LicenseWatcher ► Renamed(String, String)
Called when a file has been renamed.
Declaration Syntax
C#
protected override void Renamed(
    string filePath,
    string oldFilePath
)
Parameters
filePath (String)
The full path.
oldFilePath (String)
The old full path.


Sitecore.Services Namespace

Sitecore.Services Namespace
Namespaces ► Sitecore.Services
Declaration Syntax
C#
namespace Sitecore.Services
Types
All Types Classes
Icon | Type | Description
 | AlarmClock | Represents the alarm clock.
 | Heartbeat | Implements a heartbeat.


AlarmClock Class

AlarmClock Class
Namespaces ► Sitecore.Services ► AlarmClock
Represents the alarm clock.
Declaration Syntax
C#
public class AlarmClock : IDisposable
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AlarmClock(TimeSpan) | Constructs an instance of AlarmClock
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interval | Gets the interval at which the alarm rings.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Ring |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AlarmClock


AlarmClock Constructor (interval)

AlarmClock Constructor (interval)
Namespaces ► Sitecore.Services ► AlarmClock ► AlarmClock(TimeSpan)
Constructs an instance of AlarmClock
Declaration Syntax
C#
public AlarmClock(
    TimeSpan interval
)
Parameters
interval (TimeSpan)
The interval.


Dispose Method

Dispose Method
Namespaces ► Sitecore.Services ► AlarmClock ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C#
public void Dispose()


Interval Property

Interval Property
Namespaces ► Sitecore.Services ► AlarmClock ► Interval
Gets the interval at which the alarm rings.
Declaration Syntax
C#
public TimeSpan Interval { get; }
Value
The interval.


Ring Event

Ring Event
Namespaces ► Sitecore.Services ► AlarmClock ► Ring
Declaration Syntax
C#
public event EventHandler<EventArgs> Ring


Heartbeat Class

Heartbeat Class
Namespaces ► Sitecore.Services ► Heartbeat
Implements a heartbeat.
Declaration Syntax
C#
public static class Heartbeat
Members
All Members | Methods | Events
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Beat |
 | Initialize()()() | Initializes this instance.
Inheritance Hierarchy
Object
Heartbeat


Beat Event

Beat Event
Namespaces ► Sitecore.Services ► Heartbeat ► Beat
Declaration Syntax
C#
public static event EventHandler<EventArgs> Beat


Initialize Method

Initialize Method
Namespaces ► Sitecore.Services ► Heartbeat ► Initialize()()()
Initializes this instance.
Declaration Syntax
C#
public static void Initialize()


Sitecore.Shell Namespace

Sitecore.Shell Namespace
Namespaces ► Sitecore.Shell
Declaration Syntax
C#
namespace Sitecore.Shell
Types
All Types Classes Enumerations
Icon | Type | Description
 | UserOptions..::.ContentEditor |
 | DefaultPage |
 | DownloadPage | Represents the Download Page.
 | EditorConstants | Represents constants in the content editor.
 | ErrorPage | Summary description for error.
 | UserOptions..::.Favorites | Contains user options related to favorites
 | UserOptions..::.HtmlEditor |
 | InvokePage |
 | UserOptions..::.HtmlEditor..::.Mode |
 | UserOptions |
 | UserOptions..::.View |
 | UserOptions..::.WebEdit | Contains user options related to WebEdit
 | UserOptions..::.Wizards |
 | XmlControlPage |


DefaultPage Class

DefaultPage Class
Namespaces ► Sitecore.Shell ► DefaultPage
Declaration Syntax
C#
public class DefaultPage : SecurePage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultPage()()() | Initializes a new instance of the DefaultPage class
 | AbortPipeline(ClientPipelineArgs) | Aborts the pipeline identified by the args parameter. (Inherited from ClientPage.)
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddControl(Control, Control) | Adds a control while ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | AddControl(Control, Control, String) | Adds the control. (Inherited from ClientPage.)
 | AddControlAt(Int32, Control, Control) | Adds a control at a certain position while ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddLiteral(Control, String) | Adds literal text to a control. (Inherited from ClientPage.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindControls()()() | Binds the controls. (Inherited from ClientPage.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientRequest | Gets the request parameters for the current request. (Inherited from ClientPage.)
 | ClientResponse | Provides means for generating a response to the client. (Inherited from ClientPage.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodeBeside | Gets the current CodeBeside object. (Inherited from ClientPage.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControls()()() | Creates the controls. (Inherited from ClientPage.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | CurrentPipelineArgs | Gets the pipeline arguments, if a pipeline is active. (Inherited from ClientPage.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DecrementEventState()()() | Decrements the state of the event. (Inherited from ClientPage.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispatch(String) | Sends a client event message to the control hierachy. (Inherited from ClientPage.)
 | DispatchMessage(Message) | Obsolete. Dispatches the message. (Inherited from ClientPage.)
 | DispatchMessage(Message, Control) | Obsolete. Dispatches the message. (Inherited from ClientPage.)
 | DispatchMethod(String) | Obsolete. Dispatches the method. (Inherited from ClientPage.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindSubControl(String) | Finds the sub control with the specified name. (Inherited from ClientPage.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetClientDragEvent(String) | Builds a JavaScript statement for handling Drag actions. (Inherited from ClientPage.)
 | GetClientDropEvent(String) | Builds a JavaScript statement for handling Drop actions. (Inherited from ClientPage.)
 | GetClientEvent(String) | Builds a JavaScript statement for making a Sheer event. (Inherited from ClientPage.)
 | GetClientHelpEvent(String) | Builds a JavaScript statement for handling context sensitive help in the browser. (Inherited from ClientPage.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPageKey()()() | Gets the page key. (Inherited from ClientPage.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetViewStateStore()()() | Gets the view state store. (Inherited from ClientPage.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | IncrementEventState()()() | Increments the state of the event. (Inherited from ClientPage.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | Initialized | Gets a value indicating whether this ClientPage is initialized. (Inherited from ClientPage.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsEvent | Gets a value that indicates if the page is running in Event or Result mode. (Inherited from ClientPage.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsResult | Gets a value that indicates if the page is running in Result mode. (Inherited from ClientPage.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | Keymap | Gets the keymap. (Inherited from ClientPage.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from ClientPage.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MaxRequestLengthExceeded | Gets a value indicating whether the ClientPage maxs the request length exceeded. (Inherited from ClientPage.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Modified | Gets a value that indicates if the fields on page has been modified. (Inherited from ClientPage.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(Exception) | Called when an exception is thrown. (Inherited from ClientPage.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides ClientPage.OnInit(EventArgs).)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from SecurePage.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from ClientPage.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from ClientPage.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageKey | Gets the page key. (Inherited from ClientPage.)
 | PageScriptManager | Gets the page script manager. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PersistViewStateToClient | Gets a value that indicates if ViewState should be persisted on the client in the __VIEWSTATE field. (Inherited from ClientPage.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaiseEvent()()() | Raises the event. (Inherited from ClientPage.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterKey(String, String, String) | Registers the key. (Inherited from ClientPage.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from ClientPage.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | ReplaceControl(Control, Control) | Replaces a control with another control ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | RunPipelines()()() | Runs the pipelines. (Inherited from ClientPage.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves the page state to persistence medium. (Inherited from ClientPage.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ClientPage.)
 | SendMessage(Object, String) | Sends a message to the control hierachy. (Inherited from ClientPage.)
 | SendMessage(Message) | Sends a message to the control hierachy. (Inherited from ClientPage.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | ServerProperties | Exposes the ClientPage ViewState protected property. (Inherited from ClientPage.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | Start(String) | Starts a new pipeline. (Inherited from ClientPage.)
 | Start(String, ClientPipelineArgs) | Starts a new pipeline. (Inherited from ClientPage.)
 | Start(String, NameValueCollection) | Starts a pipeline. (Inherited from ClientPage.)
 | Start(Object, String) | Starts a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Object, String, NameValueCollection) | Start a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Object, String, ClientPipelineArgs) | Start a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Pipeline, PipelineArgs) | Starts a pipeline with a set of arguments. (Inherited from ClientPage.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from ClientPage.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteCommands()()() | Writes the commands. (Inherited from ClientPage.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Page
 |  |  |  |  | ClientPage
 |  |  |  |  |  | SecurePage
 |  |  |  |  |  |  | DefaultPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DefaultPage Constructor

DefaultPage Constructor
Namespaces ► Sitecore.Shell ► DefaultPage ► DefaultPage()()()
Initializes a new instance of the DefaultPage class
Declaration Syntax
C#
public DefaultPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnInit Method (e)

OnInit Method (e)
Namespaces ► Sitecore.Shell ► DefaultPage ► OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DownloadPage Class

DownloadPage Class
Namespaces ► Sitecore.Shell ► DownloadPage
Represents the Download Page.
Declaration Syntax
C#
public class DownloadPage : SecurePage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DownloadPage()()() | Initializes a new instance of the DownloadPage class
 | AbortPipeline(ClientPipelineArgs) | Aborts the pipeline identified by the args parameter. (Inherited from ClientPage.)
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddControl(Control, Control) | Adds a control while ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | AddControl(Control, Control, String) | Adds the control. (Inherited from ClientPage.)
 | AddControlAt(Int32, Control, Control) | Adds a control at a certain position while ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddLiteral(Control, String) | Adds literal text to a control. (Inherited from ClientPage.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindControls()()() | Binds the controls. (Inherited from ClientPage.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientRequest | Gets the request parameters for the current request. (Inherited from ClientPage.)
 | ClientResponse | Provides means for generating a response to the client. (Inherited from ClientPage.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodeBeside | Gets the current CodeBeside object. (Inherited from ClientPage.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControls()()() | Creates the controls. (Inherited from ClientPage.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | CurrentPipelineArgs | Gets the pipeline arguments, if a pipeline is active. (Inherited from ClientPage.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DecrementEventState()()() | Decrements the state of the event. (Inherited from ClientPage.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispatch(String) | Sends a client event message to the control hierachy. (Inherited from ClientPage.)
 | DispatchMessage(Message) | Obsolete. Dispatches the message. (Inherited from ClientPage.)
 | DispatchMessage(Message, Control) | Obsolete. Dispatches the message. (Inherited from ClientPage.)
 | DispatchMethod(String) | Obsolete. Dispatches the method. (Inherited from ClientPage.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindSubControl(String) | Finds the sub control with the specified name. (Inherited from ClientPage.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetClientDragEvent(String) | Builds a JavaScript statement for handling Drag actions. (Inherited from ClientPage.)
 | GetClientDropEvent(String) | Builds a JavaScript statement for handling Drop actions. (Inherited from ClientPage.)
 | GetClientEvent(String) | Builds a JavaScript statement for making a Sheer event. (Inherited from ClientPage.)
 | GetClientHelpEvent(String) | Builds a JavaScript statement for handling context sensitive help in the browser. (Inherited from ClientPage.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPageKey()()() | Gets the page key. (Inherited from ClientPage.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetViewStateStore()()() | Gets the view state store. (Inherited from ClientPage.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | IncrementEventState()()() | Increments the state of the event. (Inherited from ClientPage.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | Initialized | Gets a value indicating whether this ClientPage is initialized. (Inherited from ClientPage.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsEvent | Gets a value that indicates if the page is running in Event or Result mode. (Inherited from ClientPage.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsResult | Gets a value that indicates if the page is running in Result mode. (Inherited from ClientPage.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | Keymap | Gets the keymap. (Inherited from ClientPage.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from ClientPage.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MaxRequestLengthExceeded | Gets a value indicating whether the ClientPage maxs the request length exceeded. (Inherited from ClientPage.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Modified | Gets a value that indicates if the fields on page has been modified. (Inherited from ClientPage.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(Exception) | Called when an exception is thrown. (Inherited from ClientPage.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from ClientPage.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides SecurePage.OnLoad(EventArgs).)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from ClientPage.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from ClientPage.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageKey | Gets the page key. (Inherited from ClientPage.)
 | PageScriptManager | Gets the page script manager. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PersistViewStateToClient | Gets a value that indicates if ViewState should be persisted on the client in the __VIEWSTATE field. (Inherited from ClientPage.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaiseEvent()()() | Raises the event. (Inherited from ClientPage.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterKey(String, String, String) | Registers the key. (Inherited from ClientPage.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from ClientPage.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | ReplaceControl(Control, Control) | Replaces a control with another control ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | RunPipelines()()() | Runs the pipelines. (Inherited from ClientPage.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves the page state to persistence medium. (Inherited from ClientPage.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ClientPage.)
 | SendMessage(Object, String) | Sends a message to the control hierachy. (Inherited from ClientPage.)
 | SendMessage(Message) | Sends a message to the control hierachy. (Inherited from ClientPage.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | ServerProperties | Exposes the ClientPage ViewState protected property. (Inherited from ClientPage.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | Start(String) | Starts a new pipeline. (Inherited from ClientPage.)
 | Start(String, ClientPipelineArgs) | Starts a new pipeline. (Inherited from ClientPage.)
 | Start(String, NameValueCollection) | Starts a pipeline. (Inherited from ClientPage.)
 | Start(Object, String) | Starts a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Object, String, NameValueCollection) | Start a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Object, String, ClientPipelineArgs) | Start a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Pipeline, PipelineArgs) | Starts a pipeline with a set of arguments. (Inherited from ClientPage.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from ClientPage.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteCommands()()() | Writes the commands. (Inherited from ClientPage.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Page
 |  |  |  |  | ClientPage
 |  |  |  |  |  | SecurePage
 |  |  |  |  |  |  | DownloadPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DownloadPage Constructor

DownloadPage Constructor
Namespaces ► Sitecore.Shell ► DownloadPage ► DownloadPage()()()
Initializes a new instance of the DownloadPage class
Declaration Syntax
C#
public DownloadPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell ► DownloadPage ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


EditorConstants Class

EditorConstants Class
Namespaces ► Sitecore.Shell ► EditorConstants
Represents constants in the content editor.
Declaration Syntax
C#
public class EditorConstants
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditorConstants()()() | Initializes a new instance of the EditorConstants class
 | DefaultFieldEditorSectionID | ID of the single section field editor shows by default. There is no corresponding item in the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IgnoreRevision | Field value that indicates that the field has no value.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NoValue | Field value that indicates that the field has no value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
EditorConstants


EditorConstants Constructor

EditorConstants Constructor
Namespaces ► Sitecore.Shell ► EditorConstants ► EditorConstants()()()
Initializes a new instance of the EditorConstants class
Declaration Syntax
C#
public EditorConstants()


DefaultFieldEditorSectionID Field

DefaultFieldEditorSectionID Field
Namespaces ► Sitecore.Shell ► EditorConstants ► DefaultFieldEditorSectionID
ID of the single section field editor shows by default. There is no corresponding item in the database.
Declaration Syntax
C#
public static readonly ID DefaultFieldEditorSectionID


IgnoreRevision Field

IgnoreRevision Field
Namespaces ► Sitecore.Shell ► EditorConstants ► IgnoreRevision
Field value that indicates that the field has no value.
Declaration Syntax
C#
public const string IgnoreRevision


NoValue Field

NoValue Field
Namespaces ► Sitecore.Shell ► EditorConstants ► NoValue
Field value that indicates that the field has no value.
Declaration Syntax
C#
public const string NoValue


ErrorPage Class

ErrorPage Class
Namespaces ► Sitecore.Shell ► ErrorPage
Summary description for error.
Declaration Syntax
C#
public class ErrorPage : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorPage()()() | Initializes a new instance of the ErrorPage class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | errorLabel |
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | Label1 |
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Overrides Page.OnInit(EventArgs).)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | ErrorPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ErrorPage Constructor

ErrorPage Constructor
Namespaces ► Sitecore.Shell ► ErrorPage ► ErrorPage()()()
Initializes a new instance of the ErrorPage class
Declaration Syntax
C#
public ErrorPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


errorLabel Field

errorLabel Field
Namespaces ► Sitecore.Shell ► ErrorPage ► errorLabel
Declaration Syntax
C#
protected Label errorLabel

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Label1 Field

Label1 Field
Namespaces ► Sitecore.Shell ► ErrorPage ► Label1
Declaration Syntax
C#
protected Label Label1

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnInit Method (e)

OnInit Method (e)
Namespaces ► Sitecore.Shell ► ErrorPage ► OnInit(EventArgs)
Raises the Init event to initialize the page.
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


InvokePage Class

InvokePage Class
Namespaces ► Sitecore.Shell ► InvokePage
Declaration Syntax
C#
public class InvokePage : SecurePage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InvokePage()()() | Initializes a new instance of the InvokePage class
 | AbortPipeline(ClientPipelineArgs) | Aborts the pipeline identified by the args parameter. (Inherited from ClientPage.)
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddControl(Control, Control) | Adds a control while ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | AddControl(Control, Control, String) | Adds the control. (Inherited from ClientPage.)
 | AddControlAt(Int32, Control, Control) | Adds a control at a certain position while ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddLiteral(Control, String) | Adds literal text to a control. (Inherited from ClientPage.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindControls()()() | Binds the controls. (Inherited from ClientPage.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientRequest | Gets the request parameters for the current request. (Inherited from ClientPage.)
 | ClientResponse | Provides means for generating a response to the client. (Inherited from ClientPage.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodeBeside | Gets the current CodeBeside object. (Inherited from ClientPage.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControls()()() | Creates the controls. (Inherited from ClientPage.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | CurrentPipelineArgs | Gets the pipeline arguments, if a pipeline is active. (Inherited from ClientPage.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DecrementEventState()()() | Decrements the state of the event. (Inherited from ClientPage.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispatch(String) | Sends a client event message to the control hierachy. (Inherited from ClientPage.)
 | DispatchMessage(Message) | Obsolete. Dispatches the message. (Inherited from ClientPage.)
 | DispatchMessage(Message, Control) | Obsolete. Dispatches the message. (Inherited from ClientPage.)
 | DispatchMethod(String) | Obsolete. Dispatches the method. (Inherited from ClientPage.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindSubControl(String) | Finds the sub control with the specified name. (Inherited from ClientPage.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetClientDragEvent(String) | Builds a JavaScript statement for handling Drag actions. (Inherited from ClientPage.)
 | GetClientDropEvent(String) | Builds a JavaScript statement for handling Drop actions. (Inherited from ClientPage.)
 | GetClientEvent(String) | Builds a JavaScript statement for making a Sheer event. (Inherited from ClientPage.)
 | GetClientHelpEvent(String) | Builds a JavaScript statement for handling context sensitive help in the browser. (Inherited from ClientPage.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPageKey()()() | Gets the page key. (Inherited from ClientPage.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetViewStateStore()()() | Gets the view state store. (Inherited from ClientPage.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | IncrementEventState()()() | Increments the state of the event. (Inherited from ClientPage.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | Initialized | Gets a value indicating whether this ClientPage is initialized. (Inherited from ClientPage.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsEvent | Gets a value that indicates if the page is running in Event or Result mode. (Inherited from ClientPage.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsResult | Gets a value that indicates if the page is running in Result mode. (Inherited from ClientPage.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | Keymap | Gets the keymap. (Inherited from ClientPage.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from ClientPage.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MaxRequestLengthExceeded | Gets a value indicating whether the ClientPage maxs the request length exceeded. (Inherited from ClientPage.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Modified | Gets a value that indicates if the fields on page has been modified. (Inherited from ClientPage.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(Exception) | Called when an exception is thrown. (Inherited from ClientPage.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from ClientPage.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | (Overrides SecurePage.OnLoad(EventArgs).)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from ClientPage.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from ClientPage.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageKey | Gets the page key. (Inherited from ClientPage.)
 | PageScriptManager | Gets the page script manager. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PersistViewStateToClient | Gets a value that indicates if ViewState should be persisted on the client in the __VIEWSTATE field. (Inherited from ClientPage.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaiseEvent()()() | Raises the event. (Inherited from ClientPage.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterKey(String, String, String) | Registers the key. (Inherited from ClientPage.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from ClientPage.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | ReplaceControl(Control, Control) | Replaces a control with another control ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | RunPipelines()()() | Runs the pipelines. (Inherited from ClientPage.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves the page state to persistence medium. (Inherited from ClientPage.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ClientPage.)
 | SendMessage(Object, String) | Sends a message to the control hierachy. (Inherited from ClientPage.)
 | SendMessage(Message) | Sends a message to the control hierachy. (Inherited from ClientPage.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | ServerProperties | Exposes the ClientPage ViewState protected property. (Inherited from ClientPage.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | Start(String) | Starts a new pipeline. (Inherited from ClientPage.)
 | Start(String, ClientPipelineArgs) | Starts a new pipeline. (Inherited from ClientPage.)
 | Start(String, NameValueCollection) | Starts a pipeline. (Inherited from ClientPage.)
 | Start(Object, String) | Starts a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Object, String, NameValueCollection) | Start a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Object, String, ClientPipelineArgs) | Start a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Pipeline, PipelineArgs) | Starts a pipeline with a set of arguments. (Inherited from ClientPage.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from ClientPage.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteCommands()()() | Writes the commands. (Inherited from ClientPage.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Page
 |  |  |  |  | ClientPage
 |  |  |  |  |  | SecurePage
 |  |  |  |  |  |  | InvokePage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


InvokePage Constructor

InvokePage Constructor
Namespaces ► Sitecore.Shell ► InvokePage ► InvokePage()()()
Initializes a new instance of the InvokePage class
Declaration Syntax
C#
public InvokePage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell ► InvokePage ► OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


UserOptions Class

UserOptions Class
Namespaces ► Sitecore.Shell ► UserOptions
Declaration Syntax
C#
public static class UserOptions
Inheritance Hierarchy
Object
UserOptions


UserOptions.ContentEditor Class

UserOptions..::.ContentEditor Class
Namespaces ► Sitecore.Shell ► UserOptions ► UserOptions..::.ContentEditor
Declaration Syntax
C#
public static class ContentEditor
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenderCollapsedSections | Gets a value indicating whether the content editor renders collapsed sections.
 | ShowGutter | Gets or sets a value indicating whether the UserOptions..::.ContentEditor shows the gutter.
 | ShowHeader | Gets or sets a value indicating whether the Content Editor shows the header.
 | ShowPages | Gets or sets a value indicating whether the Content Editor shows the pages.
 | ShowQuickInfo | Gets or sets a value indicating whether the Content Editor shows the quick info section.
 | ShowRawValues | Gets or sets a value indicating whether the Content Editor shows the raw values.
 | ShowSearchPanel | Gets or sets a value indicating whether the UserOptions..::.ContentEditor shows the search panel.
 | ShowSections | Gets or sets a value indicating whether the Content Editor shows the sections.
 | ShowSystemFields | Gets or sets a value indicating whether the Content Editor shows the system fields.
 | ShowValidatorBar | Gets a value indicating whether the UserOptions..::.ContentEditor shows the validator bar.
 | VisibleStrips | Gets or sets the visible strips.
Inheritance Hierarchy
Object
UserOptions..::.ContentEditor


RenderCollapsedSections Property

RenderCollapsedSections Property
Namespaces ► Sitecore.Shell ► UserOptions..::.ContentEditor ► RenderCollapsedSections
Gets a value indicating whether the content editor renders collapsed sections.
Declaration Syntax
C#
public static bool RenderCollapsedSections { get; set; }
Value
true if the content editor renders collapsed sections; otherwise, false.


ShowGutter Property

ShowGutter Property
Namespaces ► Sitecore.Shell ► UserOptions..::.ContentEditor ► ShowGutter
Gets or sets a value indicating whether the UserOptions..::.ContentEditor shows the gutter.
Declaration Syntax
C#
public static bool ShowGutter { get; set; }
Value
true if the UserOptions..::.ContentEditor shows the gutter; otherwise, false.


ShowHeader Property

ShowHeader Property
Namespaces ► Sitecore.Shell ► UserOptions..::.ContentEditor ► ShowHeader
Gets or sets a value indicating whether the Content Editor shows the header.
Declaration Syntax
C#
public static bool ShowHeader { get; set; }
Value
true if Content Editor shows the header; otherwise, false.


ShowPages Property

ShowPages Property
Namespaces ► Sitecore.Shell ► UserOptions..::.ContentEditor ► ShowPages
Gets or sets a value indicating whether the Content Editor shows the pages.
Declaration Syntax
C#
public static bool ShowPages { get; set; }
Value
true if Content Editor shows the pages; otherwise, false.


ShowQuickInfo Property

ShowQuickInfo Property
Namespaces ► Sitecore.Shell ► UserOptions..::.ContentEditor ► ShowQuickInfo
Gets or sets a value indicating whether the Content Editor shows the quick info section.
Declaration Syntax
C#
public static bool ShowQuickInfo { get; set; }
Value
true if Content Editor shows the quick info section; otherwise, false.


ShowRawValues Property

ShowRawValues Property
Namespaces ► Sitecore.Shell ► UserOptions..::.ContentEditor ► ShowRawValues
Gets or sets a value indicating whether the Content Editor shows the raw values.
Declaration Syntax
C#
public static bool ShowRawValues { get; set; }
Value
true if Content Editor shows the raw values; otherwise, false.


ShowSearchPanel Property

ShowSearchPanel Property
Namespaces ► Sitecore.Shell ► UserOptions..::.ContentEditor ► ShowSearchPanel
Gets or sets a value indicating whether the UserOptions..::.ContentEditor shows the search panel.
Declaration Syntax
C#
public static bool ShowSearchPanel { get; set; }
Value
true if the UserOptions..::.ContentEditor shows the search panel; otherwise, false.


ShowSections Property

ShowSections Property
Namespaces ► Sitecore.Shell ► UserOptions..::.ContentEditor ► ShowSections
Gets or sets a value indicating whether the Content Editor shows the sections.
Declaration Syntax
C#
public static bool ShowSections { get; set; }
Value
true if Content Editor shows the sections; otherwise, false.


ShowSystemFields Property

ShowSystemFields Property
Namespaces ► Sitecore.Shell ► UserOptions..::.ContentEditor ► ShowSystemFields
Gets or sets a value indicating whether the Content Editor shows the system fields.
Declaration Syntax
C#
public static bool ShowSystemFields { get; set; }
Value
true if Content Editor shows the system fields; otherwise, false.


ShowValidatorBar Property

ShowValidatorBar Property
Namespaces ► Sitecore.Shell ► UserOptions..::.ContentEditor ► ShowValidatorBar
Gets a value indicating whether the UserOptions..::.ContentEditor shows the validator bar.
Declaration Syntax
C#
public static bool ShowValidatorBar { get; set; }
Value
true if the UserOptions..::.ContentEditor shows the validator bar; otherwise, false.


VisibleStrips Property

VisibleStrips Property
Namespaces ► Sitecore.Shell ► UserOptions..::.ContentEditor ► VisibleStrips
Gets or sets the visible strips.
Declaration Syntax
C#
public static string VisibleStrips { get; set; }
Value
The visible strips.


UserOptions.Favorites Class

UserOptions..::.Favorites Class
Namespaces ► Sitecore.Shell ► UserOptions ► UserOptions..::.Favorites
Contains user options related to favorites
Declaration Syntax
C#
public static class Favorites
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Path | Gets the favorites root item path.
 | Root | Gets the favorites root item
Inheritance Hierarchy
Object
UserOptions..::.Favorites


Path Property

Path Property
Namespaces ► Sitecore.Shell ► UserOptions..::.Favorites ► Path
Gets the favorites root item path.
Declaration Syntax
C#
public static string Path { get; }
Value
The path.


Root Property

Root Property
Namespaces ► Sitecore.Shell ► UserOptions..::.Favorites ► Root
Gets the favorites root item
Declaration Syntax
C#
public static Item Root { get; }
Value
The favorites root item.


UserOptions.HtmlEditor Class

UserOptions..::.HtmlEditor Class
Namespaces ► Sitecore.Shell ► UserOptions ► UserOptions..::.HtmlEditor
Declaration Syntax
C#
public static class HtmlEditor
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ContentEditorMode | Gets or sets the content editor mode.
Inheritance Hierarchy
Object
UserOptions..::.HtmlEditor


ContentEditorMode Property

ContentEditorMode Property
Namespaces ► Sitecore.Shell ► UserOptions..::.HtmlEditor ► ContentEditorMode
Gets or sets the content editor mode.
Declaration Syntax
C#
public static UserOptions..::.HtmlEditor..::.Mode ContentEditorMode { get; set; }
Value
The content editor mode.


UserOptions.HtmlEditor.Mode Enumeration

UserOptions..::.HtmlEditor..::.Mode Enumeration
Namespaces ► Sitecore.Shell ► UserOptions..::.HtmlEditor ► UserOptions..::.HtmlEditor..::.Mode
Declaration Syntax
C#
public enum Mode
Members
Member | Description
Editable |
Preview |


UserOptions.View Class

UserOptions..::.View Class
Namespaces ► Sitecore.Shell ► UserOptions ► UserOptions..::.View
Declaration Syntax
C#
public static class View
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ShowEntireTree | Gets or sets a value indicating whether the system shows the entire tree.
 | ShowHiddenItems | Gets or sets a value indicating whether the system shows the hidden items.
 | ShowTree | Gets or sets a value indicating whether the content tree is shown in the content editor.
 | UseDisplayName | Gets or sets a value indicating whether the system uses the display name.
 | UseSmartTags | Gets a value indicating whether the UserOptions..::.View uses the smart tags.
Inheritance Hierarchy
Object
UserOptions..::.View


ShowEntireTree Property

ShowEntireTree Property
Namespaces ► Sitecore.Shell ► UserOptions..::.View ► ShowEntireTree
Gets or sets a value indicating whether the system shows the entire tree.
Declaration Syntax
C#
public static bool ShowEntireTree { get; set; }
Value
true if the system shows the entire tree; otherwise, false.


ShowHiddenItems Property

ShowHiddenItems Property
Namespaces ► Sitecore.Shell ► UserOptions..::.View ► ShowHiddenItems
Gets or sets a value indicating whether the system shows the hidden items.
Declaration Syntax
C#
public static bool ShowHiddenItems { get; set; }
Value
true if system shows the hidden items; otherwise, false.


ShowTree Property

ShowTree Property
Namespaces ► Sitecore.Shell ► UserOptions..::.View ► ShowTree
Gets or sets a value indicating whether the content tree is shown in the content editor.
Declaration Syntax
C#
public static bool ShowTree { get; set; }
Value
true if the content tree is shown in the content editor; otherwise, false.


UseDisplayName Property

UseDisplayName Property
Namespaces ► Sitecore.Shell ► UserOptions..::.View ► UseDisplayName
Gets or sets a value indicating whether the system uses the display name.
Declaration Syntax
C#
public static bool UseDisplayName { get; set; }
Value
true if system uses the display name; otherwise, false.


UseSmartTags Property

UseSmartTags Property
Namespaces ► Sitecore.Shell ► UserOptions..::.View ► UseSmartTags
Gets a value indicating whether the UserOptions..::.View uses the smart tags.
Declaration Syntax
C#
public static bool UseSmartTags { get; set; }
Value
true if the UserOptions..::.View uses the smart tags; otherwise, false.


UserOptions.WebEdit Class

UserOptions..::.WebEdit Class
Namespaces ► Sitecore.Shell ► UserOptions ► UserOptions..::.WebEdit
Contains user options related to WebEdit
Declaration Syntax
C#
public static class WebEdit
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UsePopupContentEditor | Gets a value indicating whether WebEdit uses the popup content editor.
Inheritance Hierarchy
Object
UserOptions..::.WebEdit


UsePopupContentEditor Property

UsePopupContentEditor Property
Namespaces ► Sitecore.Shell ► UserOptions..::.WebEdit ► UsePopupContentEditor
Gets a value indicating whether WebEdit uses the popup content editor.
Declaration Syntax
C#
public static bool UsePopupContentEditor { get; set; }
Value
true if WebEdit uses the popup content editor; otherwise, false.


UserOptions.Wizards Class

UserOptions..::.Wizards Class
Namespaces ► Sitecore.Shell ► UserOptions ► UserOptions..::.Wizards
Declaration Syntax
C#
public static class Wizards
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ShowFirstPage | Gets or sets a value indicating whether the UserOptions..::.Wizards shows the first page.
Inheritance Hierarchy
Object
UserOptions..::.Wizards


ShowFirstPage Property

ShowFirstPage Property
Namespaces ► Sitecore.Shell ► UserOptions..::.Wizards ► ShowFirstPage
Gets or sets a value indicating whether the UserOptions..::.Wizards shows the first page.
Declaration Syntax
C#
public static bool ShowFirstPage { get; set; }
Value
true if the UserOptions..::.Wizards shows the first page; otherwise, false.


XmlControlPage Class

XmlControlPage Class
Namespaces ► Sitecore.Shell ► XmlControlPage
Declaration Syntax
C#
public class XmlControlPage : ClientPage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlControlPage()()() | Initializes a new instance of the XmlControlPage class
 | AbortPipeline(ClientPipelineArgs) | Aborts the pipeline identified by the args parameter. (Inherited from ClientPage.)
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddControl(Control, Control) | Adds a control while ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | AddControl(Control, Control, String) | Adds the control. (Inherited from ClientPage.)
 | AddControlAt(Int32, Control, Control) | Adds a control at a certain position while ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddLiteral(Control, String) | Adds literal text to a control. (Inherited from ClientPage.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindControls()()() | Binds the controls. (Inherited from ClientPage.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientRequest | Gets the request parameters for the current request. (Inherited from ClientPage.)
 | ClientResponse | Provides means for generating a response to the client. (Inherited from ClientPage.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodeBeside | Gets the current CodeBeside object. (Inherited from ClientPage.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControls()()() | Creates the controls. (Inherited from ClientPage.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | CurrentPipelineArgs | Gets the pipeline arguments, if a pipeline is active. (Inherited from ClientPage.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DecrementEventState()()() | Decrements the state of the event. (Inherited from ClientPage.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispatch(String) | Sends a client event message to the control hierachy. (Inherited from ClientPage.)
 | DispatchMessage(Message) | Obsolete. Dispatches the message. (Inherited from ClientPage.)
 | DispatchMessage(Message, Control) | Obsolete. Dispatches the message. (Inherited from ClientPage.)
 | DispatchMethod(String) | Obsolete. Dispatches the method. (Inherited from ClientPage.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindSubControl(String) | Finds the sub control with the specified name. (Inherited from ClientPage.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetClientDragEvent(String) | Builds a JavaScript statement for handling Drag actions. (Inherited from ClientPage.)
 | GetClientDropEvent(String) | Builds a JavaScript statement for handling Drop actions. (Inherited from ClientPage.)
 | GetClientEvent(String) | Builds a JavaScript statement for making a Sheer event. (Inherited from ClientPage.)
 | GetClientHelpEvent(String) | Builds a JavaScript statement for handling context sensitive help in the browser. (Inherited from ClientPage.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPageKey()()() | Gets the page key. (Inherited from ClientPage.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetViewStateStore()()() | Gets the view state store. (Inherited from ClientPage.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | IncrementEventState()()() | Increments the state of the event. (Inherited from ClientPage.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | Initialized | Gets a value indicating whether this ClientPage is initialized. (Inherited from ClientPage.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsEvent | Gets a value that indicates if the page is running in Event or Result mode. (Inherited from ClientPage.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsResult | Gets a value that indicates if the page is running in Result mode. (Inherited from ClientPage.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | Keymap | Gets the keymap. (Inherited from ClientPage.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from ClientPage.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MaxRequestLengthExceeded | Gets a value indicating whether the ClientPage maxs the request length exceeded. (Inherited from ClientPage.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Modified | Gets a value that indicates if the fields on page has been modified. (Inherited from ClientPage.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(Exception) | Called when an exception is thrown. (Inherited from ClientPage.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides ClientPage.OnInit(EventArgs).)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from ClientPage.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from ClientPage.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from ClientPage.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageKey | Gets the page key. (Inherited from ClientPage.)
 | PageScriptManager | Gets the page script manager. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PersistViewStateToClient | Gets a value that indicates if ViewState should be persisted on the client in the __VIEWSTATE field. (Inherited from ClientPage.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaiseEvent()()() | Raises the event. (Inherited from ClientPage.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterKey(String, String, String) | Registers the key. (Inherited from ClientPage.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from ClientPage.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | ReplaceControl(Control, Control) | Replaces a control with another control ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | RunPipelines()()() | Runs the pipelines. (Inherited from ClientPage.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves the page state to persistence medium. (Inherited from ClientPage.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ClientPage.)
 | SendMessage(Object, String) | Sends a message to the control hierachy. (Inherited from ClientPage.)
 | SendMessage(Message) | Sends a message to the control hierachy. (Inherited from ClientPage.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | ServerProperties | Exposes the ClientPage ViewState protected property. (Inherited from ClientPage.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | Start(String) | Starts a new pipeline. (Inherited from ClientPage.)
 | Start(String, ClientPipelineArgs) | Starts a new pipeline. (Inherited from ClientPage.)
 | Start(String, NameValueCollection) | Starts a pipeline. (Inherited from ClientPage.)
 | Start(Object, String) | Starts a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Object, String, NameValueCollection) | Start a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Object, String, ClientPipelineArgs) | Start a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Pipeline, PipelineArgs) | Starts a pipeline with a set of arguments. (Inherited from ClientPage.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from ClientPage.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteCommands()()() | Writes the commands. (Inherited from ClientPage.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Page
 |  |  |  |  | ClientPage
 |  |  |  |  |  | XmlControlPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


XmlControlPage Constructor

XmlControlPage Constructor
Namespaces ► Sitecore.Shell ► XmlControlPage ► XmlControlPage()()()
Initializes a new instance of the XmlControlPage class
Declaration Syntax
C#
public XmlControlPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnInit Method (e)

OnInit Method (e)
Namespaces ► Sitecore.Shell ► XmlControlPage ► OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.Analytics Namespace

Sitecore.Shell.Applications.Analytics Namespace
Namespaces ► Sitecore.Shell.Applications.Analytics
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.Analytics
Types
All Types Classes
Icon | Type | Description
 | DefaultPage | Defines the default page class.
 | VisitorCssPage | Defines the sitecore CSS page class.


DefaultPage Class

DefaultPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics ► DefaultPage
Defines the default page class.
Declaration Syntax
C#
public class DefaultPage : SecurePage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultPage()()() | Initializes a new instance of the DefaultPage class
 | AbortPipeline(ClientPipelineArgs) | Aborts the pipeline identified by the args parameter. (Inherited from ClientPage.)
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddControl(Control, Control) | Adds a control while ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | AddControl(Control, Control, String) | Adds the control. (Inherited from ClientPage.)
 | AddControlAt(Int32, Control, Control) | Adds a control at a certain position while ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddLiteral(Control, String) | Adds literal text to a control. (Inherited from ClientPage.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindControls()()() | Binds the controls. (Inherited from ClientPage.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientRequest | Gets the request parameters for the current request. (Inherited from ClientPage.)
 | ClientResponse | Provides means for generating a response to the client. (Inherited from ClientPage.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodeBeside | Gets the current CodeBeside object. (Inherited from ClientPage.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControls()()() | Creates the controls. (Inherited from ClientPage.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | CurrentPipelineArgs | Gets the pipeline arguments, if a pipeline is active. (Inherited from ClientPage.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DecrementEventState()()() | Decrements the state of the event. (Inherited from ClientPage.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispatch(String) | Sends a client event message to the control hierachy. (Inherited from ClientPage.)
 | DispatchMessage(Message) | Obsolete. Dispatches the message. (Inherited from ClientPage.)
 | DispatchMessage(Message, Control) | Obsolete. Dispatches the message. (Inherited from ClientPage.)
 | DispatchMethod(String) | Obsolete. Dispatches the method. (Inherited from ClientPage.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindSubControl(String) | Finds the sub control with the specified name. (Inherited from ClientPage.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetClientDragEvent(String) | Builds a JavaScript statement for handling Drag actions. (Inherited from ClientPage.)
 | GetClientDropEvent(String) | Builds a JavaScript statement for handling Drop actions. (Inherited from ClientPage.)
 | GetClientEvent(String) | Builds a JavaScript statement for making a Sheer event. (Inherited from ClientPage.)
 | GetClientHelpEvent(String) | Builds a JavaScript statement for handling context sensitive help in the browser. (Inherited from ClientPage.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPageKey()()() | Gets the page key. (Inherited from ClientPage.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetViewStateStore()()() | Gets the view state store. (Inherited from ClientPage.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | IncrementEventState()()() | Increments the state of the event. (Inherited from ClientPage.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | Initialized | Gets a value indicating whether this ClientPage is initialized. (Inherited from ClientPage.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsEvent | Gets a value that indicates if the page is running in Event or Result mode. (Inherited from ClientPage.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsResult | Gets a value that indicates if the page is running in Result mode. (Inherited from ClientPage.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | Keymap | Gets the keymap. (Inherited from ClientPage.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from ClientPage.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MaxRequestLengthExceeded | Gets a value indicating whether the ClientPage maxs the request length exceeded. (Inherited from ClientPage.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Modified | Gets a value that indicates if the fields on page has been modified. (Inherited from ClientPage.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(Exception) | Called when an exception is thrown. (Inherited from ClientPage.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Overrides ClientPage.OnInit(EventArgs).)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from SecurePage.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from ClientPage.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from ClientPage.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageKey | Gets the page key. (Inherited from ClientPage.)
 | PageScriptManager | Gets the page script manager. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PersistViewStateToClient | Gets a value that indicates if ViewState should be persisted on the client in the __VIEWSTATE field. (Inherited from ClientPage.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaiseEvent()()() | Raises the event. (Inherited from ClientPage.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterKey(String, String, String) | Registers the key. (Inherited from ClientPage.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from ClientPage.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | ReplaceControl(Control, Control) | Replaces a control with another control ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | RunPipelines()()() | Runs the pipelines. (Inherited from ClientPage.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves the page state to persistence medium. (Inherited from ClientPage.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ClientPage.)
 | SendMessage(Object, String) | Sends a message to the control hierachy. (Inherited from ClientPage.)
 | SendMessage(Message) | Sends a message to the control hierachy. (Inherited from ClientPage.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | ServerProperties | Exposes the ClientPage ViewState protected property. (Inherited from ClientPage.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | Start(String) | Starts a new pipeline. (Inherited from ClientPage.)
 | Start(String, ClientPipelineArgs) | Starts a new pipeline. (Inherited from ClientPage.)
 | Start(String, NameValueCollection) | Starts a pipeline. (Inherited from ClientPage.)
 | Start(Object, String) | Starts a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Object, String, NameValueCollection) | Start a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Object, String, ClientPipelineArgs) | Start a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Pipeline, PipelineArgs) | Starts a pipeline with a set of arguments. (Inherited from ClientPage.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from ClientPage.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteCommands()()() | Writes the commands. (Inherited from ClientPage.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Page
 |  |  |  |  | ClientPage
 |  |  |  |  |  | SecurePage
 |  |  |  |  |  |  | DefaultPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DefaultPage Constructor

DefaultPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics ► DefaultPage ► DefaultPage()()()
Initializes a new instance of the DefaultPage class
Declaration Syntax
C#
public DefaultPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnInit Method (e)

OnInit Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics ► DefaultPage ► OnInit(EventArgs)
Raises the Init event to initialize the page.
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


VisitorCssPage Class

VisitorCssPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics ► VisitorCssPage
Defines the sitecore CSS page class.
Declaration Syntax
C#
public class VisitorCssPage : Page
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VisitorCssPage()()() | Initializes a new instance of the VisitorCssPage class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Overrides Page.OnInit(EventArgs).)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | VisitorCssPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


VisitorCssPage Constructor

VisitorCssPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics ► VisitorCssPage ► VisitorCssPage()()()
Initializes a new instance of the VisitorCssPage class
Declaration Syntax
C#
public VisitorCssPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnInit Method (e)

OnInit Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics ► VisitorCssPage ► OnInit(EventArgs)
Raises the Init event to initialize the page.
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.Analytics.AuthoringFeedback Namespace

Sitecore.Shell.Applications.Analytics.AuthoringFeedback Namespace
Namespaces ► Sitecore.Shell.Applications.Analytics.AuthoringFeedback
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.Analytics.AuthoringFeedback
Types
All Types Classes
Icon | Type | Description
 | AuthoringFeedback | Defines the authoring feedback class.
 | AuthoringFeedbackPage |


AuthoringFeedback Class

AuthoringFeedback Class
Namespaces ► Sitecore.Shell.Applications.Analytics.AuthoringFeedback ► AuthoringFeedback
Defines the authoring feedback class.
Declaration Syntax
C#
[SerializableAttribute]
public class AuthoringFeedback : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AuthoringFeedback()()() | Initializes a new instance of the AuthoringFeedback class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AuthoringFeedback

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AuthoringFeedback Constructor

AuthoringFeedback Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.AuthoringFeedback ► AuthoringFeedback ► AuthoringFeedback()()()
Initializes a new instance of the AuthoringFeedback class
Declaration Syntax
C#
public AuthoringFeedback()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.AuthoringFeedback ► AuthoringFeedback ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.AuthoringFeedback ► AuthoringFeedback ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AuthoringFeedbackPage Class

AuthoringFeedbackPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics.AuthoringFeedback ► AuthoringFeedbackPage
Declaration Syntax
C#
public class AuthoringFeedbackPage : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AuthoringFeedbackPage()()() | Initializes a new instance of the AuthoringFeedbackPage class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DateSelector |
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 | form1 control.
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemId | ItemId control.
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Handles the Load event of the Page control. (Overrides Control.OnLoad(EventArgs).)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | ScriptManager | ScriptManager control.
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | Viewer | Viewer control.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | AuthoringFeedbackPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AuthoringFeedbackPage Constructor

AuthoringFeedbackPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.AuthoringFeedback ► AuthoringFeedbackPage ► AuthoringFeedbackPage()()()
Initializes a new instance of the AuthoringFeedbackPage class
Declaration Syntax
C#
public AuthoringFeedbackPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DateSelector Field

DateSelector Field
Namespaces ► Sitecore.Shell.Applications.Analytics.AuthoringFeedback ► AuthoringFeedbackPage ► DateSelector
Declaration Syntax
C#
protected DateSelector DateSelector

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


form1 Field

form1 Field
Namespaces ► Sitecore.Shell.Applications.Analytics.AuthoringFeedback ► AuthoringFeedbackPage ► form1
form1 control.
Declaration Syntax
C#
protected HtmlForm form1
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ItemId Field

ItemId Field
Namespaces ► Sitecore.Shell.Applications.Analytics.AuthoringFeedback ► AuthoringFeedbackPage ► ItemId
ItemId control.
Declaration Syntax
C#
protected PlaceHolder ItemId
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.AuthoringFeedback ► AuthoringFeedbackPage ► OnLoad(EventArgs)
Handles the Load event of the Page control.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs instance containing the event data.
Exceptions
Exception | Condition
Exception | Exception.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ScriptManager Field

ScriptManager Field
Namespaces ► Sitecore.Shell.Applications.Analytics.AuthoringFeedback ► AuthoringFeedbackPage ► ScriptManager
ScriptManager control.
Declaration Syntax
C#
protected ScriptManager ScriptManager
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Viewer Field

Viewer Field
Namespaces ► Sitecore.Shell.Applications.Analytics.AuthoringFeedback ► AuthoringFeedbackPage ► Viewer
Viewer control.
Declaration Syntax
C#
protected StiWebViewer Viewer
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.Analytics.CampaignField Namespace

Sitecore.Shell.Applications.Analytics.CampaignField Namespace
Namespaces ► Sitecore.Shell.Applications.Analytics.CampaignField
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.Analytics.CampaignField
Types
All Types Classes
Icon | Type | Description
 | CampaignFieldPage | Defines the campaign field page class.


CampaignFieldPage Class

CampaignFieldPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics.CampaignField ► CampaignFieldPage
Defines the campaign field page class.
Declaration Syntax
C#
public class CampaignFieldPage : DialogPage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CampaignFieldPage()()() | Initializes a new instance of the CampaignFieldPage class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets or sets the application. (Inherited from XamlMainControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cancel_Click()()() | Handles a click on the OK button. (Inherited from DialogPage.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from DialogPage.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | Message | Gets or sets the message.
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OK_Click()()() | Handles a click on the OK button. (Inherited from DialogPage.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides XamlMainControl.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text. (Inherited from DialogPage.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | XamlMainControl
 |  |  |  |  | DialogPage
 |  |  |  |  |  | CampaignFieldPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CampaignFieldPage Constructor

CampaignFieldPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.CampaignField ► CampaignFieldPage ► CampaignFieldPage()()()
Initializes a new instance of the CampaignFieldPage class
Declaration Syntax
C#
public CampaignFieldPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Message Property

Message Property
Namespaces ► Sitecore.Shell.Applications.Analytics.CampaignField ► CampaignFieldPage ► Message
Gets or sets the message.
Declaration Syntax
C#
protected Scrollbox Message { get; set; }
Value
The message.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.CampaignField ► CampaignFieldPage ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.Analytics.Filters Namespace

Sitecore.Shell.Applications.Analytics.Filters Namespace
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.Analytics.Filters
Types
All Types Classes
Icon | Type | Description
 | FilterDescriptionRenderer | Defines the filter description class.
 | FilterEditorPage | Defines the rule set editor page class.
 | SelectDatabaseRowPage | Defines the select database row page class.


FilterDescriptionRenderer Class

FilterDescriptionRenderer Class
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterDescriptionRenderer
Defines the filter description class.
Declaration Syntax
C#
public class FilterDescriptionRenderer
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FilterDescriptionRenderer(String) | Initializes a new instance of the FilterDescriptionRenderer class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Filter | Gets the filter.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEditable | Gets or sets a value indicating whether this instance is editable.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(HtmlTextWriter) | Renders the filter.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FilterDescriptionRenderer

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


FilterDescriptionRenderer Constructor (filter)

FilterDescriptionRenderer Constructor (filter)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterDescriptionRenderer ► FilterDescriptionRenderer(String)
Initializes a new instance of the FilterDescriptionRenderer class.
Declaration Syntax
C#
public FilterDescriptionRenderer(
    string filter
)
Parameters
filter (String)
The filter.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Filter Property

Filter Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterDescriptionRenderer ► Filter
Gets the filter.
Declaration Syntax
C#
public string Filter { get; }
Value
The filter.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


IsEditable Property

IsEditable Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterDescriptionRenderer ► IsEditable
Gets or sets a value indicating whether this instance is editable.
Declaration Syntax
C#
public bool IsEditable { get; set; }
Value
true if this instance is editable; otherwise, false.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterDescriptionRenderer ► Render(HtmlTextWriter)
Renders the filter.
Declaration Syntax
C#
public void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


FilterEditorPage Class

FilterEditorPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterEditorPage
Defines the rule set editor page class.
Declaration Syntax
C#
public class FilterEditorPage : DialogPage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FilterEditorPage()()() | Initializes a new instance of the FilterEditorPage class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddFilter(String) | Adds the condition.
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets or sets the application. (Inherited from XamlMainControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cancel_Click()()() | Handles a click on the OK button. (Inherited from DialogPage.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | Description | Gets or sets the description.
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Edit(String, String, String, String) | Edits the field.
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Filters | Gets or sets the conditions.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from DialogPage.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OK_Click()()() | Handles a click on the OK button. (Overrides DialogPage.OK_Click()()().)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from XamlMainControl.)
 | OnPreRender(EventArgs) | Raises the load event. (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | RemoveFilter(String) | Removes the filter.
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderDescription(String) | Renders the rule set.
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text. (Inherited from DialogPage.)
 | TogglePrefix(String) | Changes the prefixEdits the field.
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | XamlMainControl
 |  |  |  |  | DialogPage
 |  |  |  |  |  | FilterEditorPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


FilterEditorPage Constructor

FilterEditorPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterEditorPage ► FilterEditorPage()()()
Initializes a new instance of the FilterEditorPage class
Declaration Syntax
C#
public FilterEditorPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AddFilter Method (filterId)

AddFilter Method (filterId)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterEditorPage ► AddFilter(String)
Adds the condition.
Declaration Syntax
C#
protected void AddFilter(
    string filterId
)
Parameters
filterId (String)
The filter id.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Description Property

Description Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterEditorPage ► Description
Gets or sets the description.
Declaration Syntax
C#
public Scrollbox Description { get; set; }
Value
The description.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Edit Method (uid, name, control, parameters)

Edit Method (uid, name, control, parameters)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterEditorPage ► Edit(String, String, String, String)
Edits the field.
Declaration Syntax
C#
protected void Edit(
    string uid,
    string name,
    string control,
    string parameters
)
Parameters
uid (String)
The unique id.
name (String)
The field name.
control (String)
The control.
parameters (String)
The field data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Filters Property

Filters Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterEditorPage ► Filters
Gets or sets the conditions.
Declaration Syntax
C#
public Scrollbox Filters { get; set; }
Value
The conditions.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OK_Click Method

OK_Click Method
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterEditorPage ► OK_Click()()()
Handles a click on the OK button.
Declaration Syntax
C#
protected override void OK_Click()
Remarks
When the user clicks OK, the dialog is closed by calling the CloseWindow method.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterEditorPage ► OnPreRender(EventArgs)
Raises the load event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs instance containing the event data.
Remarks
This method notifies the server control that it should perform actions common to each HTTP request for the page it is associated with, such as setting up a database query. At this stage in the page lifecycle, server controls in the hierarchy are created and initialized, view state is restored, and form controls reflect client-side data. Use the IsPostBack property to determine whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RemoveFilter Method (uid)

RemoveFilter Method (uid)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterEditorPage ► RemoveFilter(String)
Removes the filter.
Declaration Syntax
C#
protected void RemoveFilter(
    string uid
)
Parameters
uid (String)
The unique id field.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RenderDescription Method (value)

RenderDescription Method (value)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterEditorPage ► RenderDescription(String)
Renders the rule set.
Declaration Syntax
C#
protected void RenderDescription(
    string value
)
Parameters
value (String)
The value.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TogglePrefix Method (uid)

TogglePrefix Method (uid)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► FilterEditorPage ► TogglePrefix(String)
Changes the prefixEdits the field.
Declaration Syntax
C#
protected void TogglePrefix(
    string uid
)
Parameters
uid (String)
The unique id.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SelectDatabaseRowPage Class

SelectDatabaseRowPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► SelectDatabaseRowPage
Defines the select database row page class.
Declaration Syntax
C#
public class SelectDatabaseRowPage : DialogPage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelectDatabaseRowPage()()() | Initializes a new instance of the SelectDatabaseRowPage class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets or sets the application. (Inherited from XamlMainControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cancel_Click()()() | Handles a click on the OK button. (Overrides DialogPage.Cancel_Click()()().)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from DialogPage.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OK_Click()()() | Handles a click on the OK button. (Overrides DialogPage.OK_Click()()().)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Overrides Control.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides XamlMainControl.OnLoad(EventArgs).)
 | OnNeedDataSource(Object, EventArgs) | Called when [need data source].
 | OnNeedRebind(Object, EventArgs) | Called when [need rebind].
 | OnPageChanged(Object, GridPageIndexChangedEventArgs) | Called when [page changed].
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSort(Object, GridSortCommandEventArgs) | Called when [sort].
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Rows | Gets or sets the roles.
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SelectedValues | Gets or sets the selected values.
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text. (Inherited from DialogPage.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | XamlMainControl
 |  |  |  |  | DialogPage
 |  |  |  |  |  | SelectDatabaseRowPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SelectDatabaseRowPage Constructor

SelectDatabaseRowPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► SelectDatabaseRowPage ► SelectDatabaseRowPage()()()
Initializes a new instance of the SelectDatabaseRowPage class
Declaration Syntax
C#
public SelectDatabaseRowPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Cancel_Click Method

Cancel_Click Method
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► SelectDatabaseRowPage ► Cancel_Click()()()
Handles a click on the OK button.
Declaration Syntax
C#
protected override void Cancel_Click()
Remarks
When the user clicks OK, the dialog is closed by calling the CloseWindow method.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OK_Click Method

OK_Click Method
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► SelectDatabaseRowPage ► OK_Click()()()
Handles a click on the OK button.
Declaration Syntax
C#
protected override void OK_Click()
Remarks
When the user clicks OK, the dialog is closed by calling the CloseWindow method.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnInit Method (e)

OnInit Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► SelectDatabaseRowPage ► OnInit(EventArgs)
Raises the Init event.
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► SelectDatabaseRowPage ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnNeedDataSource Method (sender, oArgs)

OnNeedDataSource Method (sender, oArgs)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► SelectDatabaseRowPage ► OnNeedDataSource(Object, EventArgs)
Called when [need data source].
Declaration Syntax
C#
public void OnNeedDataSource(
    Object sender,
    EventArgs oArgs
)
Parameters
sender (Object)
The sender.
oArgs (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnNeedRebind Method (sender, oArgs)

OnNeedRebind Method (sender, oArgs)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► SelectDatabaseRowPage ► OnNeedRebind(Object, EventArgs)
Called when [need rebind].
Declaration Syntax
C#
public void OnNeedRebind(
    Object sender,
    EventArgs oArgs
)
Parameters
sender (Object)
The sender.
oArgs (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnPageChanged Method (sender, oArgs)

OnPageChanged Method (sender, oArgs)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► SelectDatabaseRowPage ► OnPageChanged(Object, GridPageIndexChangedEventArgs)
Called when [page changed].
Declaration Syntax
C#
public void OnPageChanged(
    Object sender,
    GridPageIndexChangedEventArgs oArgs
)
Parameters
sender (Object)
The sender.
oArgs (GridPageIndexChangedEventArgs)
The GridPageIndexChangedEventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnSort Method (sender, oArgs)

OnSort Method (sender, oArgs)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► SelectDatabaseRowPage ► OnSort(Object, GridSortCommandEventArgs)
Called when [sort].
Declaration Syntax
C#
public void OnSort(
    Object sender,
    GridSortCommandEventArgs oArgs
)
Parameters
sender (Object)
The sender.
oArgs (GridSortCommandEventArgs)
The GridSortCommandEventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Rows Property

Rows Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► SelectDatabaseRowPage ► Rows
Gets or sets the roles.
Declaration Syntax
C#
protected Grid Rows { get; set; }
Value
The roles.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SelectedValues Property

SelectedValues Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters ► SelectDatabaseRowPage ► SelectedValues
Gets or sets the selected values.
Declaration Syntax
C#
protected HtmlInputHidden SelectedValues { get; set; }
Value
The selected values.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.Analytics.Filters.FilterDetails Namespace

Sitecore.Shell.Applications.Analytics.Filters.FilterDetails Namespace
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters.FilterDetails
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.Analytics.Filters.FilterDetails
Types
All Types Classes
Icon | Type | Description
 | FilterDetailsPage | Defines the rule set details page class.


FilterDetailsPage Class

FilterDetailsPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters.FilterDetails ► FilterDetailsPage
Defines the rule set details page class.
Declaration Syntax
C#
public class FilterDetailsPage : DialogPage,
    IHasCommandContext
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FilterDetailsPage()()() | Initializes a new instance of the FilterDetailsPage class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets or sets the application. (Inherited from XamlMainControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cancel_Click()()() | Handles a click on the OK button. (Inherited from DialogPage.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Filters | Gets or sets the rule set.
 | FiltersValue | Gets or sets the rule set value.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetCommandContext()()() | Gets the command context.
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from DialogPage.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OK_Click()()() | Handles a click on the OK button. (Inherited from DialogPage.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides XamlMainControl.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text. (Inherited from DialogPage.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | XamlMainControl
 |  |  |  |  | DialogPage
 |  |  |  |  |  | FilterDetailsPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


FilterDetailsPage Constructor

FilterDetailsPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters.FilterDetails ► FilterDetailsPage ► FilterDetailsPage()()()
Initializes a new instance of the FilterDetailsPage class
Declaration Syntax
C#
public FilterDetailsPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Filters Property

Filters Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters.FilterDetails ► FilterDetailsPage ► Filters
Gets or sets the rule set.
Declaration Syntax
C#
protected Scrollbox Filters { get; set; }
Value
The rule set.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


FiltersValue Property

FiltersValue Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters.FilterDetails ► FilterDetailsPage ► FiltersValue
Gets or sets the rule set value.
Declaration Syntax
C#
protected HtmlInputHidden FiltersValue { get; set; }
Value
The rule set value.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetCommandContext Method

GetCommandContext Method
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters.FilterDetails ► FilterDetailsPage ► GetCommandContext()()()
Gets the command context.
Declaration Syntax
C#
public CommandContext GetCommandContext()
Return Value
The command context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.Filters.FilterDetails ► FilterDetailsPage ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.Analytics.Lookups Namespace

Sitecore.Shell.Applications.Analytics.Lookups Namespace
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.Analytics.Lookups
Types
All Types Classes
Icon | Type | Description
 | RunLookupForm..::.LookupRunner | Defines the lookup runner class.
 | RunLookup | Defines the run lookup class.
 | RunLookupForm | Defines the run lookup form class.


RunLookup Class

RunLookup Class
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookup
Defines the run lookup class.
Declaration Syntax
C#
[SerializableAttribute]
public class RunLookup : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RunLookup()()() | Initializes a new instance of the RunLookup class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | RunLookup

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RunLookup Constructor

RunLookup Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookup ► RunLookup()()()
Initializes a new instance of the RunLookup class
Declaration Syntax
C#
public RunLookup()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookup ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookup ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RunLookupForm Class

RunLookupForm Class
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm
Defines the run lookup form class.
Declaration Syntax
C#
public class RunLookupForm : WizardForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RunLookupForm()()() | Initializes a new instance of the RunLookupForm class
 | ActionText | Gets or sets the action text.
 | Active | Gets or sets the active. (Inherited from WizardForm.)
 | ActivePageChanged(String, String) | Called when the active page has been changed. (Overrides WizardForm.ActivePageChanged(String, String).)
 | ActivePageChanging(String, String%) | Called when the active page is changing. (Overrides WizardForm.ActivePageChanging(String, String%).)
 | AllButton | Gets or sets all button.
 | Back()()() | Back. (Inherited from WizardForm.)
 | BackButton | (Inherited from WizardForm.)
 | Cancel()()() | Cancel. (Inherited from WizardForm.)
 | CancelButton | (Inherited from WizardForm.)
 | CheckStatus()()() | Checks the status.
 | Confirmation(ClientPipelineArgs) | Presents a confirmation box to the user when the Cancel button has been clicked. (Inherited from WizardForm.)
 | EndWizard()()() | Ends the wizard. (Inherited from WizardForm.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorText | Gets or sets the error text.
 | EventsEnabled | Gets or sets a value indicating whether events are enabled. (Inherited from BaseForm.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from BaseForm.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Next()()() | Moves the wizard to the next page. (Inherited from WizardForm.)
 | NextButton | (Inherited from WizardForm.)
 | OnBack(Object, EventArgs) | Called when the user clicks the Back button. (Inherited from WizardForm.)
 | OnCancel(Object, EventArgs) | Called when the user clicks the Cancel button. (Inherited from WizardForm.)
 | OnLoad(EventArgs) | Raises the load event. (Overrides WizardForm.OnLoad(EventArgs).)
 | OnlyBlanksButton | Gets or sets the only blanks button.
 | OnNext(Object, EventArgs) | Called when the user clicks the Next button. (Inherited from WizardForm.)
 | OnPreRender(EventArgs) | Raises the pre render event. (Inherited from BaseForm.)
 | Pages | Gets the pages. (Inherited from WizardForm.)
 | ResultText | Gets or sets the result text.
 | ServerProperties | Gets the server properties. (Inherited from BaseForm.)
 | StartRunning()()() | Starts the rebuilding.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | WizardForm
 |  |  | RunLookupForm

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RunLookupForm Constructor

RunLookupForm Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm ► RunLookupForm()()()
Initializes a new instance of the RunLookupForm class
Declaration Syntax
C#
public RunLookupForm()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ActionText Property

ActionText Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm ► ActionText
Gets or sets the action text.
Declaration Syntax
C#
protected Literal ActionText { get; set; }
Value
The action text.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ActivePageChanged Method (page, oldPage)

ActivePageChanged Method (page, oldPage)
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm ► ActivePageChanged(String, String)
Called when the active page has been changed.
Declaration Syntax
C#
protected override void ActivePageChanged(
    string page,
    string oldPage
)
Parameters
page (String)
The page that has been entered.
oldPage (String)
The page that was left.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ActivePageChanging Method (page, newPage)

ActivePageChanging Method (page, newPage)
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm ► ActivePageChanging(String, String%)
Called when the active page is changing.
Declaration Syntax
C#
protected override bool ActivePageChanging(
    string page,
    ref string newPage
)
Parameters
page (String)
The page that is being left.
newPage ( String %)
The new page that is being entered.
Return Value
True, if the change is allowed, otherwise false.
Remarks
Set the newpage parameter to another page ID to control the path through the wizard pages.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AllButton Property

AllButton Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm ► AllButton
Gets or sets all button.
Declaration Syntax
C#
protected Radiobutton AllButton { get; set; }
Value
All button.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CheckStatus Method

CheckStatus Method
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm ► CheckStatus()()()
Checks the status.
Declaration Syntax
C#
protected void CheckStatus()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ErrorText Property

ErrorText Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm ► ErrorText
Gets or sets the error text.
Declaration Syntax
C#
protected Memo ErrorText { get; set; }
Value
The error text.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm ► OnLoad(EventArgs)
Raises the load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs instance containing the event data.
Remarks
This method notifies the server control that it should perform actions common to each HTTP request for the page it is associated with, such as setting up a database query. At this stage in the page life-cycle, server controls in the hierarchy are created and initialized, view state is restored, and form controls reflect client-side data. Use the IsPostBack property to determine whether the page is being loaded in response to a client post-back, or if it is being loaded and accessed for the first time.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnlyBlanksButton Property

OnlyBlanksButton Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm ► OnlyBlanksButton
Gets or sets the only blanks button.
Declaration Syntax
C#
protected Radiobutton OnlyBlanksButton { get; set; }
Value
The only blanks button.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ResultText Property

ResultText Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm ► ResultText
Gets or sets the result text.
Declaration Syntax
C#
protected Memo ResultText { get; set; }
Value
The result text.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


StartRunning Method

StartRunning Method
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm ► StartRunning()()()
Starts the rebuilding.
Declaration Syntax
C#
protected void StartRunning()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RunLookupForm.LookupRunner Class

RunLookupForm..::.LookupRunner Class
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm ► RunLookupForm..::.LookupRunner
Defines the lookup runner class.
Declaration Syntax
C#
public class LookupRunner
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RunLookupForm..::.LookupRunner(Boolean) | Initializes a new instance of the RunLookupForm..::.LookupRunner class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run()()() | Exports this instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RunLookupForm..::.LookupRunner

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RunLookupForm.LookupRunner Constructor (onlyBlanks)

RunLookupForm..::.LookupRunner Constructor (onlyBlanks)
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm..::.LookupRunner ► RunLookupForm..::.LookupRunner(Boolean)
Initializes a new instance of the RunLookupForm..::.LookupRunner class.
Declaration Syntax
C#
public LookupRunner(
    bool onlyBlanks
)
Parameters
onlyBlanks (Boolean)
if set to true [all].

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Run Method

Run Method
Namespaces ► Sitecore.Shell.Applications.Analytics.Lookups ► RunLookupForm..::.LookupRunner ► Run()()()
Exports this instance.
Declaration Syntax
C#
protected void Run()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.Analytics.ReportRunner Namespace

Sitecore.Shell.Applications.Analytics.ReportRunner Namespace
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.Analytics.ReportRunner
Types
All Types Classes
Icon | Type | Description
 | CrmPage | Defines the CRM class.
 | DateSelector | Defines the date selector class.
 | EmailReport | Defines the email report class.
 | OpenAnalyticsReports | Defines the open reports class.
 | ReportPage | Defines the report page class.
 | ReportRunnerForm | Defines the report runner form class.


CrmPage Class

CrmPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► CrmPage
Defines the CRM class.
Declaration Syntax
C#
public class CrmPage : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CrmPage()()() | Initializes a new instance of the CrmPage class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 | form1 control.
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) | Handles the Load event of the Page control.
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | CrmPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CrmPage Constructor

CrmPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► CrmPage ► CrmPage()()()
Initializes a new instance of the CrmPage class
Declaration Syntax
C#
public CrmPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


form1 Field

form1 Field
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► CrmPage ► form1
form1 control.
Declaration Syntax
C#
protected HtmlForm form1
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► CrmPage ► Page_Load(Object, EventArgs)
Handles the Load event of the Page control.
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DateSelector Class

DateSelector Class
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► DateSelector
Defines the date selector class.
Declaration Syntax
C#
public class DateSelector : UserControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DateSelector()()() | Initializes a new instance of the DateSelector class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Dates | The Dates field.
 | DesignerInitialize()()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EndDatePicker | The End Date Picker field.
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDates(DateTime%, DateTime%) | Gets the dates.
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Init event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionState object for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | StartDatePicker | The Start Date Picker field.
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | DateSelector

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DateSelector Constructor

DateSelector Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► DateSelector ► DateSelector()()()
Initializes a new instance of the DateSelector class
Declaration Syntax
C#
public DateSelector()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Dates Field

Dates Field
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► DateSelector ► Dates
The Dates field.
Declaration Syntax
C#
protected Literal Dates

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


EndDatePicker Field

EndDatePicker Field
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► DateSelector ► EndDatePicker
The End Date Picker field.
Declaration Syntax
C#
protected RadDatePicker EndDatePicker

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetDates Method (startDate, endDate)

GetDates Method (startDate, endDate)
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► DateSelector ► GetDates(DateTime%, DateTime%)
Gets the dates.
Declaration Syntax
C#
public void GetDates(
    out DateTime startDate,
    out DateTime endDate
)
Parameters
startDate ( DateTime %)
The start date.
endDate ( DateTime %)
The end date.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► DateSelector ► OnLoad(EventArgs)
Raises the Init event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


StartDatePicker Field

StartDatePicker Field
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► DateSelector ► StartDatePicker
The Start Date Picker field.
Declaration Syntax
C#
protected RadDatePicker StartDatePicker

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


EmailReport Class

EmailReport Class
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► EmailReport
Defines the email report class.
Declaration Syntax
C#
[SerializableAttribute]
public class EmailReport : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EmailReport()()() | Initializes a new instance of the EmailReport class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | EmailReport

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


EmailReport Constructor

EmailReport Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► EmailReport ► EmailReport()()()
Initializes a new instance of the EmailReport class
Declaration Syntax
C#
public EmailReport()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► EmailReport ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► EmailReport ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected static void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OpenAnalyticsReports Class

OpenAnalyticsReports Class
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► OpenAnalyticsReports
Defines the open reports class.
Declaration Syntax
C#
[SerializableAttribute]
public class OpenAnalyticsReports : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OpenAnalyticsReports()()() | Initializes a new instance of the OpenAnalyticsReports class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | OpenAnalyticsReports

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OpenAnalyticsReports Constructor

OpenAnalyticsReports Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► OpenAnalyticsReports ► OpenAnalyticsReports()()()
Initializes a new instance of the OpenAnalyticsReports class
Declaration Syntax
C#
public OpenAnalyticsReports()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► OpenAnalyticsReports ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► OpenAnalyticsReports ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ReportPage Class

ReportPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage
Defines the report page class.
Declaration Syntax
C#
public class ReportPage : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReportPage()()() | Initializes a new instance of the ReportPage class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DateSelector | DateSelector control.
 | Design | Design control.
 | Design_Click(Object, EventArgs) | Handles the Click event of the Design control.
 | Designer | Designer control.
 | Designer_SaveReport(Object, StiSaveReportEventArgs) | Handles the SaveReport event of the Designer control.
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 | form1 control.
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemId | ItemId control.
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | ReportFileName | Gets or sets the name of the report file.
 | ReportItemId | Gets or sets the report item id.
 | ReportViewer | ReportViewer control.
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | ScriptManager | ScriptManager control.
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | Toolbar | Toolbar control.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | ReportPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ReportPage Constructor

ReportPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage ► ReportPage()()()
Initializes a new instance of the ReportPage class
Declaration Syntax
C#
public ReportPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DateSelector Field

DateSelector Field
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage ► DateSelector
DateSelector control.
Declaration Syntax
C#
protected DateSelector DateSelector
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Design Field

Design Field
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage ► Design
Design control.
Declaration Syntax
C#
protected Button Design
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Design_Click Method (sender, e)

Design_Click Method (sender, e)
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage ► Design_Click(Object, EventArgs)
Handles the Click event of the Design control.
Declaration Syntax
C#
protected void Design_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Designer Field

Designer Field
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage ► Designer
Designer control.
Declaration Syntax
C#
protected StiWebDesigner Designer
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Designer_SaveReport Method (sender, e)

Designer_SaveReport Method (sender, e)
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage ► Designer_SaveReport(Object, StiSaveReportEventArgs)
Handles the SaveReport event of the Designer control.
Declaration Syntax
C#
protected void Designer_SaveReport(
    Object sender,
    StiSaveReportEventArgs e
)
Parameters
sender (Object)
The source of the event.
e (StiSaveReportEventArgs)
The StiSaveReportEventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


form1 Field

form1 Field
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage ► form1
form1 control.
Declaration Syntax
C#
protected HtmlForm form1
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ItemId Field

ItemId Field
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage ► ItemId
ItemId control.
Declaration Syntax
C#
protected PlaceHolder ItemId
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ReportFileName Property

ReportFileName Property
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage ► ReportFileName
Gets or sets the name of the report file.
Declaration Syntax
C#
public string ReportFileName { get; set; }
Value
The name of the report file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ReportItemId Property

ReportItemId Property
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage ► ReportItemId
Gets or sets the report item id.
Declaration Syntax
C#
protected string ReportItemId { get; set; }
Value
The report item id.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ReportViewer Field

ReportViewer Field
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage ► ReportViewer
ReportViewer control.
Declaration Syntax
C#
protected StiWebViewer ReportViewer
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ScriptManager Field

ScriptManager Field
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage ► ScriptManager
ScriptManager control.
Declaration Syntax
C#
protected ScriptManager ScriptManager
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Toolbar Field

Toolbar Field
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportPage ► Toolbar
Toolbar control.
Declaration Syntax
C#
protected HtmlTableCell Toolbar
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ReportRunnerForm Class

ReportRunnerForm Class
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportRunnerForm
Defines the report runner form class.
Declaration Syntax
C#
public class ReportRunnerForm : BaseForm
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReportRunnerForm()()() | Initializes a new instance of the ReportRunnerForm class
 | CurrentReportId | Gets or sets the current report id.
 | DataContext | Gets or sets the data context.
 | Design_Click()()() | Handles the Design click.
 | Email_Click()()() | Selects the report.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled | Gets or sets a value indicating whether events are enabled. (Inherited from BaseForm.)
 | Filter | Gets or sets the filter.
 | Filter_Click()()() | Handles the Filter click button.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Overrides BaseForm.HandleMessage(Message).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnLoad(EventArgs) | Raises the load event. (Overrides BaseForm.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the pre render event. (Inherited from BaseForm.)
 | Refresh()()() | Selects the report.
 | ReportFrame | Gets or sets the report frame.
 | SaveFilter_Click()()() | Handles the Save Filter click.
 | ServerProperties | Gets the server properties. (Inherited from BaseForm.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Treeview | Gets or sets the tree view.
Inheritance Hierarchy
Object
 | BaseForm
 |  | ReportRunnerForm

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ReportRunnerForm Constructor

ReportRunnerForm Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportRunnerForm ► ReportRunnerForm()()()
Initializes a new instance of the ReportRunnerForm class
Declaration Syntax
C#
public ReportRunnerForm()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CurrentReportId Property

CurrentReportId Property
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportRunnerForm ► CurrentReportId
Gets or sets the current report id.
Declaration Syntax
C#
protected string CurrentReportId { get; set; }
Value
The current report id.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DataContext Property

DataContext Property
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportRunnerForm ► DataContext
Gets or sets the data context.
Declaration Syntax
C#
protected DataContext DataContext { get; set; }
Value
The data context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Design_Click Method

Design_Click Method
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportRunnerForm ► Design_Click()()()
Handles the Design click.
Declaration Syntax
C#
protected void Design_Click()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Email_Click Method

Email_Click Method
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportRunnerForm ► Email_Click()()()
Selects the report.
Declaration Syntax
C#
protected void Email_Click()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Filter Property

Filter Property
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportRunnerForm ► Filter
Gets or sets the filter.
Declaration Syntax
C#
protected string Filter { get; set; }
Value
The filter.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Filter_Click Method

Filter_Click Method
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportRunnerForm ► Filter_Click()()()
Handles the Filter click button.
Declaration Syntax
C#
protected void Filter_Click()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportRunnerForm ► HandleMessage(Message)
Handles the message.
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)
The message.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportRunnerForm ► OnLoad(EventArgs)
Raises the load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs instance containing the event data.
Remarks
This method notifies the server control that it should perform actions common to each HTTP request for the page it is associated with, such as setting up a database query. At this stage in the page life cycle, server controls in the hierarchy are created and initialized, view state is restored, and form controls reflect client-side data. Use the IsPostBack property to determine whether the page is being loaded in response to a client post back, or if it is being loaded and accessed for the first time.
Exceptions
Exception | Condition
InvalidOperationException | Report does not exist

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Refresh Method

Refresh Method
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportRunnerForm ► Refresh()()()
Selects the report.
Declaration Syntax
C#
protected void Refresh()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ReportFrame Property

ReportFrame Property
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportRunnerForm ► ReportFrame
Gets or sets the report frame.
Declaration Syntax
C#
protected Frame ReportFrame { get; set; }
Value
The report frame.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SaveFilter_Click Method

SaveFilter_Click Method
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportRunnerForm ► SaveFilter_Click()()()
Handles the Save Filter click.
Declaration Syntax
C#
protected void SaveFilter_Click()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Treeview Property

Treeview Property
Namespaces ► Sitecore.Shell.Applications.Analytics.ReportRunner ► ReportRunnerForm ► Treeview
Gets or sets the tree view.
Declaration Syntax
C#
protected TreeviewEx Treeview { get; set; }
Value
The tree view.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.Analytics.Status Namespace

Sitecore.Shell.Applications.Analytics.Status Namespace
Namespaces ► Sitecore.Shell.Applications.Analytics.Status
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.Analytics.Status
Types
All Types Classes
Icon | Type | Description
 | Status | Defines the status class.
 | StatusPage | Defines the status page class.


Status Class

Status Class
Namespaces ► Sitecore.Shell.Applications.Analytics.Status ► Status
Defines the status class.
Declaration Syntax
C#
[SerializableAttribute]
public class Status : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Status()()() | Initializes a new instance of the Status class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Status

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Status Constructor

Status Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.Status ► Status ► Status()()()
Initializes a new instance of the Status class
Declaration Syntax
C#
public Status()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.Status ► Status ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.Status ► Status ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


StatusPage Class

StatusPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics.Status ► StatusPage
Defines the status page class.
Declaration Syntax
C#
public class StatusPage : XamlMainControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StatusPage()()() | Initializes a new instance of the StatusPage class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets or sets the application. (Inherited from XamlMainControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LastFailedLookup | Gets or sets the last failed lookup.
 | LastFailedTracking | Gets or sets the last failed tracking.
 | LastQueueFull | Gets or sets the last queue full.
 | LastSuccessfulLookup | Gets or sets the last successful lookup.
 | LastSuccessfulTracking | Gets or sets the last successful tracking.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides XamlMainControl.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | XamlMainControl
 |  |  |  |  | StatusPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


StatusPage Constructor

StatusPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.Status ► StatusPage ► StatusPage()()()
Initializes a new instance of the StatusPage class
Declaration Syntax
C#
public StatusPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LastFailedLookup Property

LastFailedLookup Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Status ► StatusPage ► LastFailedLookup
Gets or sets the last failed lookup.
Declaration Syntax
C#
protected Literal LastFailedLookup { get; set; }
Value
The last failed lookup.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LastFailedTracking Property

LastFailedTracking Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Status ► StatusPage ► LastFailedTracking
Gets or sets the last failed tracking.
Declaration Syntax
C#
protected Literal LastFailedTracking { get; set; }
Value
The last failed tracking.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LastQueueFull Property

LastQueueFull Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Status ► StatusPage ► LastQueueFull
Gets or sets the last queue full.
Declaration Syntax
C#
protected Literal LastQueueFull { get; set; }
Value
The last queue full.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LastSuccessfulLookup Property

LastSuccessfulLookup Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Status ► StatusPage ► LastSuccessfulLookup
Gets or sets the last successful lookup.
Declaration Syntax
C#
protected Literal LastSuccessfulLookup { get; set; }
Value
The last successful lookup.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LastSuccessfulTracking Property

LastSuccessfulTracking Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Status ► StatusPage ► LastSuccessfulTracking
Gets or sets the last successful tracking.
Declaration Syntax
C#
protected Literal LastSuccessfulTracking { get; set; }
Value
The last successful tracking.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.Status ► StatusPage ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.Analytics.Subscription Namespace

Sitecore.Shell.Applications.Analytics.Subscription Namespace
Namespaces ► Sitecore.Shell.Applications.Analytics.Subscription
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.Analytics.Subscription
Types
All Types Classes
Icon | Type | Description
 | SubscriptionPage | Defines the visitor identification page class.


SubscriptionPage Class

SubscriptionPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics.Subscription ► SubscriptionPage
Defines the visitor identification page class.
Declaration Syntax
C#
public class SubscriptionPage : ModalDialogPage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubscriptionPage()()() | Initializes a new instance of the SubscriptionPage class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets or sets the application. (Inherited from XamlMainControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Close_Click()()() | Handles a click on the OK button. (Inherited from ModalDialogPage.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | Message | Gets or sets the message.
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides XamlMainControl.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | XamlMainControl
 |  |  |  |  | ModalDialogPage
 |  |  |  |  |  | SubscriptionPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SubscriptionPage Constructor

SubscriptionPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.Subscription ► SubscriptionPage ► SubscriptionPage()()()
Initializes a new instance of the SubscriptionPage class
Declaration Syntax
C#
public SubscriptionPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Message Property

Message Property
Namespaces ► Sitecore.Shell.Applications.Analytics.Subscription ► SubscriptionPage ► Message
Gets or sets the message.
Declaration Syntax
C#
protected Literal Message { get; set; }
Value
The message.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.Subscription ► SubscriptionPage ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.Analytics.SynchronizeDatabase Namespace

Sitecore.Shell.Applications.Analytics.SynchronizeDatabase Namespace
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.Analytics.SynchronizeDatabase
Types
All Types Classes
Icon | Type | Description
 | SynchronizeDatabase | Defines the synchronize database class.
 | SynchronizeDatabaseForm | Defines the synchronize database form class.
 | SynchronizeDatabaseForm..::.Synchronizer | Defines the synchronizer class.


SynchronizeDatabase Class

SynchronizeDatabase Class
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabase
Defines the synchronize database class.
Declaration Syntax
C#
[SerializableAttribute]
public class SynchronizeDatabase : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SynchronizeDatabase()()() | Initializes a new instance of the SynchronizeDatabase class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SynchronizeDatabase

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SynchronizeDatabase Constructor

SynchronizeDatabase Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabase ► SynchronizeDatabase()()()
Initializes a new instance of the SynchronizeDatabase class
Declaration Syntax
C#
public SynchronizeDatabase()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabase ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabase ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SynchronizeDatabaseForm Class

SynchronizeDatabaseForm Class
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabaseForm
Defines the synchronize database form class.
Declaration Syntax
C#
public class SynchronizeDatabaseForm : WizardForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SynchronizeDatabaseForm()()() | Initializes a new instance of the SynchronizeDatabaseForm class
 | ActionText | Gets or sets the action text.
 | Active | Gets or sets the active. (Inherited from WizardForm.)
 | ActivePageChanged(String, String) | Called when the active page has been changed. (Overrides WizardForm.ActivePageChanged(String, String).)
 | ActivePageChanging(String, String%) | Called when the active page is changing. (Overrides WizardForm.ActivePageChanging(String, String%).)
 | Back()()() | Back. (Inherited from WizardForm.)
 | BackButton | (Inherited from WizardForm.)
 | Cancel()()() | Cancel. (Inherited from WizardForm.)
 | CancelButton | (Inherited from WizardForm.)
 | CheckStatus()()() | Checks the status.
 | Confirmation(ClientPipelineArgs) | Presents a confirmation box to the user when the Cancel button has been clicked. (Inherited from WizardForm.)
 | EndWizard()()() | Ends the wizard. (Inherited from WizardForm.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorText | Gets or sets the error text.
 | EventsEnabled | Gets or sets a value indicating whether events are enabled. (Inherited from BaseForm.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from BaseForm.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Next()()() | Moves the wizard to the next page. (Inherited from WizardForm.)
 | NextButton | (Inherited from WizardForm.)
 | OnBack(Object, EventArgs) | Called when the user clicks the Back button. (Inherited from WizardForm.)
 | OnCancel(Object, EventArgs) | Called when the user clicks the Cancel button. (Inherited from WizardForm.)
 | OnLoad(EventArgs) | Raises the load event. (Overrides WizardForm.OnLoad(EventArgs).)
 | OnNext(Object, EventArgs) | Called when the user clicks the Next button. (Inherited from WizardForm.)
 | OnPreRender(EventArgs) | Raises the pre render event. (Inherited from BaseForm.)
 | Pages | Gets the pages. (Inherited from WizardForm.)
 | ResultText | Gets or sets the result text.
 | ServerProperties | Gets the server properties. (Inherited from BaseForm.)
 | StartRunning()()() | Starts the running.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | WizardForm
 |  |  | SynchronizeDatabaseForm

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SynchronizeDatabaseForm Constructor

SynchronizeDatabaseForm Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabaseForm ► SynchronizeDatabaseForm()()()
Initializes a new instance of the SynchronizeDatabaseForm class
Declaration Syntax
C#
public SynchronizeDatabaseForm()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ActionText Property

ActionText Property
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabaseForm ► ActionText
Gets or sets the action text.
Declaration Syntax
C#
protected Literal ActionText { get; set; }
Value
The action text.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ActivePageChanged Method (page, oldPage)

ActivePageChanged Method (page, oldPage)
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabaseForm ► ActivePageChanged(String, String)
Called when the active page has been changed.
Declaration Syntax
C#
protected override void ActivePageChanged(
    string page,
    string oldPage
)
Parameters
page (String)
The page that has been entered.
oldPage (String)
The page that was left.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ActivePageChanging Method (page, newPage)

ActivePageChanging Method (page, newPage)
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabaseForm ► ActivePageChanging(String, String%)
Called when the active page is changing.
Declaration Syntax
C#
protected override bool ActivePageChanging(
    string page,
    ref string newPage
)
Parameters
page (String)
The page that is being left.
newPage ( String %)
The new page that is being entered.
Return Value
True, if the change is allowed, otherwise false.
Remarks
Set the newpage parameter to another page ID to control the path through the wizard pages.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CheckStatus Method

CheckStatus Method
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabaseForm ► CheckStatus()()()
Checks the status.
Declaration Syntax
C#
protected void CheckStatus()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ErrorText Property

ErrorText Property
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabaseForm ► ErrorText
Gets or sets the error text.
Declaration Syntax
C#
protected Memo ErrorText { get; set; }
Value
The error text.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabaseForm ► OnLoad(EventArgs)
Raises the load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs instance containing the event data.
Remarks
This method notifies the server control that it should perform actions common to each HTTP request for the page it is associated with, such as setting up a database query. At this stage in the page life-cycle, server controls in the hierarchy are created and initialized, view state is restored, and form controls reflect client-side data. Use the IsPostBack property to determine whether the page is being loaded in response to a client post-back, or if it is being loaded and accessed for the first time.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ResultText Property

ResultText Property
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabaseForm ► ResultText
Gets or sets the result text.
Declaration Syntax
C#
protected Memo ResultText { get; set; }
Value
The result text.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


StartRunning Method

StartRunning Method
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabaseForm ► StartRunning()()()
Starts the running.
Declaration Syntax
C#
protected void StartRunning()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SynchronizeDatabaseForm.Synchronizer Class

SynchronizeDatabaseForm..::.Synchronizer Class
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabaseForm ► SynchronizeDatabaseForm..::.Synchronizer
Defines the synchronizer class.
Declaration Syntax
C#
public class Synchronizer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SynchronizeDatabaseForm..::.Synchronizer()()() | Initializes a new instance of the SynchronizeDatabaseForm..::.Synchronizer class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run()()() | Exports this instance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SynchronizeDatabaseForm..::.Synchronizer

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SynchronizeDatabaseForm.Synchronizer Constructor

SynchronizeDatabaseForm..::.Synchronizer Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabaseForm..::.Synchronizer ► SynchronizeDatabaseForm..::.Synchronizer()()()
Initializes a new instance of the SynchronizeDatabaseForm..::.Synchronizer class
Declaration Syntax
C#
public Synchronizer()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Run Method

Run Method
Namespaces ► Sitecore.Shell.Applications.Analytics.SynchronizeDatabase ► SynchronizeDatabaseForm..::.Synchronizer ► Run()()()
Exports this instance.
Declaration Syntax
C#
protected void Run()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.Analytics.TrackingField Namespace

Sitecore.Shell.Applications.Analytics.TrackingField Namespace
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.Analytics.TrackingField
Types
All Types Classes
Icon | Type | Description
 | CheckBox | Defines the stars class.
 | GoalsPage | Defines the goals page class.
 | OpenGoals | Defines the open goals class.
 | OpenProfiles | Defines the open profiles class.
 | OpenTrackingField | Defines the open tracking field class.
 | ProfilesPage | Defines the tracking field page class.
 | Slider | Defines the stars class.
 | Smileys | Defines the Smileys class.
 | Stars | Defines the stars class.
 | TrackingFieldDetailsPage | Defines the tracking field details page class.
 | TrackingFieldPage | Defines the tracking field page class.
 | TrackingFieldPageBase | Defines the tracking field page class.
 | ViewTrackingDetails | Defines the open tracking field class.


CheckBox Class

CheckBox Class
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► CheckBox
Defines the stars class.
Declaration Syntax
C#
public class CheckBox : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckBox()()() | Initializes a new instance of the CheckBox class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | CheckBox

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CheckBox Constructor

CheckBox Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► CheckBox ► CheckBox()()()
Initializes a new instance of the CheckBox class
Declaration Syntax
C#
public CheckBox()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► CheckBox ► Render(HtmlTextWriter)
Renders the control to the specified HTML writer.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the control content.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Value Property

Value Property
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► CheckBox ► Value
Gets or sets the value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GoalsPage Class

GoalsPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► GoalsPage
Defines the goals page class.
Declaration Syntax
C#
public class GoalsPage : TrackingFieldPageBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GoalsPage()()() | Initializes a new instance of the GoalsPage class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddExistingCampaigns(Packet) | Adds the existing campaigns. (Inherited from TrackingFieldPageBase.)
 | AddExistingEvents(Packet) | Adds the existing events. (Inherited from TrackingFieldPageBase.)
 | AddExistingGoals(Packet, List<(Of <(PageEventDefinition>)>)) | Adds the existing goals. (Inherited from TrackingFieldPageBase.)
 | AddExistingNoneGoals(Packet, List<(Of <(PageEventDefinition>)>)) | Adds the existing none goals. (Inherited from TrackingFieldPageBase.)
 | AddExistingProfiles(Packet) | Adds the existing profiles. (Inherited from TrackingFieldPageBase.)
 | AddIgnoreFlag(Packet) | Adds the ignore flag. (Inherited from TrackingFieldPageBase.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets or sets the application. (Inherited from XamlMainControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cancel_Click()()() | Handles a click on the OK button. (Inherited from DialogPage.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetCommandContext()()() | Gets the command context. (Inherited from TrackingFieldPageBase.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GoalsList | Gets or sets the goals list.
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from DialogPage.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OK_Click()()() | Handles a click on the OK button. (Overrides DialogPage.OK_Click()()().)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from TrackingFieldPageBase.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(XDocument) | Renders the specified doc. (Overrides TrackingFieldPageBase.Render(XDocument).)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text. (Inherited from DialogPage.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | XamlMainControl
 |  |  |  |  | DialogPage
 |  |  |  |  |  | TrackingFieldPageBase
 |  |  |  |  |  |  | GoalsPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GoalsPage Constructor

GoalsPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► GoalsPage ► GoalsPage()()()
Initializes a new instance of the GoalsPage class
Declaration Syntax
C#
public GoalsPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GoalsList Property

GoalsList Property
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► GoalsPage ► GoalsList
Gets or sets the goals list.
Declaration Syntax
C#
protected Scrollbox GoalsList { get; set; }
Value
The goals list.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OK_Click Method

OK_Click Method
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► GoalsPage ► OK_Click()()()
Handles a click on the OK button.
Declaration Syntax
C#
protected override void OK_Click()
Remarks
When the user clicks OK, the dialog is closed by calling the CloseWindow method.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Render Method (doc)

Render Method (doc)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► GoalsPage ► Render(XDocument)
Renders the specified doc.
Declaration Syntax
C#
protected override void Render(
    XDocument doc
)
Parameters
doc (XDocument)
The doc.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OpenGoals Class

OpenGoals Class
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► OpenGoals
Defines the open goals class.
Declaration Syntax
C#
public class OpenGoals : OpenTrackingField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OpenGoals()()() | Initializes a new instance of the OpenGoals class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Inherited from OpenTrackingField.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUrl()()() | Gets the URL. (Overrides OpenTrackingField.GetUrl()()().)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from OpenTrackingField.)
 | Run(ClientPipelineArgs) | Runs the pipeline. (Inherited from OpenTrackingField.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | OpenTrackingField
 |  |  | OpenGoals

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OpenGoals Constructor

OpenGoals Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► OpenGoals ► OpenGoals()()()
Initializes a new instance of the OpenGoals class
Declaration Syntax
C#
public OpenGoals()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetUrl Method

GetUrl Method
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► OpenGoals ► GetUrl()()()
Gets the URL.
Declaration Syntax
C#
protected override string GetUrl()
Return Value
The URL of the dialog.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OpenProfiles Class

OpenProfiles Class
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► OpenProfiles
Defines the open profiles class.
Declaration Syntax
C#
public class OpenProfiles : OpenTrackingField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OpenProfiles()()() | Initializes a new instance of the OpenProfiles class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Inherited from OpenTrackingField.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUrl()()() | Gets the URL. (Overrides OpenTrackingField.GetUrl()()().)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from OpenTrackingField.)
 | Run(ClientPipelineArgs) | Runs the pipeline. (Inherited from OpenTrackingField.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | OpenTrackingField
 |  |  | OpenProfiles

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OpenProfiles Constructor

OpenProfiles Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► OpenProfiles ► OpenProfiles()()()
Initializes a new instance of the OpenProfiles class
Declaration Syntax
C#
public OpenProfiles()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetUrl Method

GetUrl Method
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► OpenProfiles ► GetUrl()()()
Gets the URL.
Declaration Syntax
C#
protected override string GetUrl()
Return Value
The URL of the dialog.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OpenTrackingField Class

OpenTrackingField Class
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► OpenTrackingField
Defines the open tracking field class.
Declaration Syntax
C#
[SerializableAttribute]
public class OpenTrackingField : Command,
    ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OpenTrackingField()()() | Initializes a new instance of the OpenTrackingField class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUrl()()() | Gets the URL.
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | OpenTrackingField
 |  |  | OpenGoals
 |  |  | OpenProfiles

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OpenTrackingField Constructor

OpenTrackingField Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► OpenTrackingField ► OpenTrackingField()()()
Initializes a new instance of the OpenTrackingField class
Declaration Syntax
C#
public OpenTrackingField()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► OpenTrackingField ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetUrl Method

GetUrl Method
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► OpenTrackingField ► GetUrl()()()
Gets the URL.
Declaration Syntax
C#
protected virtual string GetUrl()
Return Value
The URL of the dialog.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► OpenTrackingField ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► OpenTrackingField ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ProfilesPage Class

ProfilesPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► ProfilesPage
Defines the tracking field page class.
Declaration Syntax
C#
public class ProfilesPage : TrackingFieldPageBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProfilesPage()()() | Initializes a new instance of the ProfilesPage class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddExistingCampaigns(Packet) | Adds the existing campaigns. (Inherited from TrackingFieldPageBase.)
 | AddExistingEvents(Packet) | Adds the existing events. (Inherited from TrackingFieldPageBase.)
 | AddExistingGoals(Packet, List<(Of <(PageEventDefinition>)>)) | Adds the existing goals. (Inherited from TrackingFieldPageBase.)
 | AddExistingNoneGoals(Packet, List<(Of <(PageEventDefinition>)>)) | Adds the existing none goals. (Inherited from TrackingFieldPageBase.)
 | AddExistingProfiles(Packet) | Adds the existing profiles. (Inherited from TrackingFieldPageBase.)
 | AddIgnoreFlag(Packet) | Adds the ignore flag. (Inherited from TrackingFieldPageBase.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets or sets the application. (Inherited from XamlMainControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cancel_Click()()() | Handles a click on the OK button. (Inherited from DialogPage.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetCommandContext()()() | Gets the command context. (Inherited from TrackingFieldPageBase.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from DialogPage.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OK_Click()()() | Handles a click on the OK button. (Overrides DialogPage.OK_Click()()().)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from TrackingFieldPageBase.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | ProfilesList | Gets or sets the profiles list.
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(XDocument) | Renders the specified doc. (Overrides TrackingFieldPageBase.Render(XDocument).)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text. (Inherited from DialogPage.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | XamlMainControl
 |  |  |  |  | DialogPage
 |  |  |  |  |  | TrackingFieldPageBase
 |  |  |  |  |  |  | ProfilesPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ProfilesPage Constructor

ProfilesPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► ProfilesPage ► ProfilesPage()()()
Initializes a new instance of the ProfilesPage class
Declaration Syntax
C#
public ProfilesPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OK_Click Method

OK_Click Method
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► ProfilesPage ► OK_Click()()()
Handles a click on the OK button.
Declaration Syntax
C#
protected override void OK_Click()
Remarks
When the user clicks OK, the dialog is closed by calling the CloseWindow method.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ProfilesList Property

ProfilesList Property
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► ProfilesPage ► ProfilesList
Gets or sets the profiles list.
Declaration Syntax
C#
protected Scrollbox ProfilesList { get; set; }
Value
The profiles list.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Render Method (doc)

Render Method (doc)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► ProfilesPage ► Render(XDocument)
Renders the specified doc.
Declaration Syntax
C#
protected override void Render(
    XDocument doc
)
Parameters
doc (XDocument)
The doc.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Slider Class

Slider Class
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► Slider
Defines the stars class.
Declaration Syntax
C#
public class Slider : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Slider()()() | Initializes a new instance of the Slider class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | Data | Gets or sets the data.
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | ProfileKeyDefinition | Gets or sets the profile key definition.
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Slider

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Slider Constructor

Slider Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► Slider ► Slider()()()
Initializes a new instance of the Slider class
Declaration Syntax
C#
public Slider()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Data Property

Data Property
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► Slider ► Data
Gets or sets the data.
Declaration Syntax
C#
public string Data { get; set; }
Value
The control data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ProfileKeyDefinition Property

ProfileKeyDefinition Property
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► Slider ► ProfileKeyDefinition
Gets or sets the profile key definition.
Declaration Syntax
C#
public Item ProfileKeyDefinition { get; set; }
Value
The profile key definition.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► Slider ► Render(HtmlTextWriter)
Renders the control to the specified HTML writer.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the control content.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Value Property

Value Property
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► Slider ► Value
Gets or sets the value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Smileys Class

Smileys Class
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► Smileys
Defines the Smileys class.
Declaration Syntax
C#
public class Smileys : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Smileys()()() | Initializes a new instance of the Smileys class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Smileys

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Smileys Constructor

Smileys Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► Smileys ► Smileys()()()
Initializes a new instance of the Smileys class
Declaration Syntax
C#
public Smileys()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► Smileys ► Render(HtmlTextWriter)
Renders the control to the specified HTML writer.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the control content.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Value Property

Value Property
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► Smileys ► Value
Gets or sets the value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Stars Class

Stars Class
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► Stars
Defines the stars class.
Declaration Syntax
C#
public class Stars : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Stars()()() | Initializes a new instance of the Stars class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Stars

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Stars Constructor

Stars Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► Stars ► Stars()()()
Initializes a new instance of the Stars class
Declaration Syntax
C#
public Stars()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► Stars ► Render(HtmlTextWriter)
Renders the control to the specified HTML writer.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the control content.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Value Property

Value Property
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► Stars ► Value
Gets or sets the value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TrackingFieldDetailsPage Class

TrackingFieldDetailsPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldDetailsPage
Defines the tracking field details page class.
Declaration Syntax
C#
public class TrackingFieldDetailsPage : DialogPage,
    IHasCommandContext
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TrackingFieldDetailsPage()()() | Initializes a new instance of the TrackingFieldDetailsPage class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets or sets the application. (Inherited from XamlMainControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cancel_Click()()() | Handles a click on the OK button. (Inherited from DialogPage.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the Ajax command. (Overrides XamlControl.ExecuteAjaxCommand(AjaxCommandEventArgs).)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetCommandContext()()() | Gets the command context.
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from DialogPage.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OK_Click()()() | Handles a click on the OK button. (Inherited from DialogPage.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides XamlMainControl.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text. (Inherited from DialogPage.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Tracking | Gets or sets the tracking.
 | TrackingValue | Gets or sets the tracking value.
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | XamlMainControl
 |  |  |  |  | DialogPage
 |  |  |  |  |  | TrackingFieldDetailsPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TrackingFieldDetailsPage Constructor

TrackingFieldDetailsPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldDetailsPage ► TrackingFieldDetailsPage()()()
Initializes a new instance of the TrackingFieldDetailsPage class
Declaration Syntax
C#
public TrackingFieldDetailsPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ExecuteAjaxCommand Method (e)

ExecuteAjaxCommand Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldDetailsPage ► ExecuteAjaxCommand(AjaxCommandEventArgs)
Executes the Ajax command.
Declaration Syntax
C#
protected override void ExecuteAjaxCommand(
    AjaxCommandEventArgs e
)
Parameters
e (AjaxCommandEventArgs)
The AjaxCommandEventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetCommandContext Method

GetCommandContext Method
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldDetailsPage ► GetCommandContext()()()
Gets the command context.
Declaration Syntax
C#
public CommandContext GetCommandContext()
Return Value
The command context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldDetailsPage ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Tracking Property

Tracking Property
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldDetailsPage ► Tracking
Gets or sets the tracking.
Declaration Syntax
C#
protected Scrollbox Tracking { get; set; }
Value
The tracking.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TrackingValue Property

TrackingValue Property
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldDetailsPage ► TrackingValue
Gets or sets the tracking value.
Declaration Syntax
C#
protected HtmlInputHidden TrackingValue { get; set; }
Value
The tracking value.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TrackingFieldPage Class

TrackingFieldPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPage
Defines the tracking field page class.
Declaration Syntax
C#
public class TrackingFieldPage : TrackingFieldPageBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TrackingFieldPage()()() | Initializes a new instance of the TrackingFieldPage class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddExistingCampaigns(Packet) | Adds the existing campaigns. (Inherited from TrackingFieldPageBase.)
 | AddExistingEvents(Packet) | Adds the existing events. (Inherited from TrackingFieldPageBase.)
 | AddExistingGoals(Packet, List<(Of <(PageEventDefinition>)>)) | Adds the existing goals. (Inherited from TrackingFieldPageBase.)
 | AddExistingNoneGoals(Packet, List<(Of <(PageEventDefinition>)>)) | Adds the existing none goals. (Inherited from TrackingFieldPageBase.)
 | AddExistingProfiles(Packet) | Adds the existing profiles. (Inherited from TrackingFieldPageBase.)
 | AddIgnoreFlag(Packet) | Adds the ignore flag. (Inherited from TrackingFieldPageBase.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets or sets the application. (Inherited from XamlMainControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CampaignList | Gets or sets the campaign list.
 | Cancel_Click()()() | Handles a click on the OK button. (Inherited from DialogPage.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | EventsList | Gets or sets the events list.
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | FailuresList | Gets or sets the goals list.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetCommandContext()()() | Gets the command context. (Inherited from TrackingFieldPageBase.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from DialogPage.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Ignore | Gets or sets the profiles list.
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OK_Click()()() | Handles a click on the OK button. (Overrides DialogPage.OK_Click()()().)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from TrackingFieldPageBase.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(XDocument) | Renders the specified doc. (Overrides TrackingFieldPageBase.Render(XDocument).)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text. (Inherited from DialogPage.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | XamlMainControl
 |  |  |  |  | DialogPage
 |  |  |  |  |  | TrackingFieldPageBase
 |  |  |  |  |  |  | TrackingFieldPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TrackingFieldPage Constructor

TrackingFieldPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPage ► TrackingFieldPage()()()
Initializes a new instance of the TrackingFieldPage class
Declaration Syntax
C#
public TrackingFieldPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CampaignList Property

CampaignList Property
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPage ► CampaignList
Gets or sets the campaign list.
Declaration Syntax
C#
protected Scrollbox CampaignList { get; set; }
Value
The campaign list.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


EventsList Property

EventsList Property
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPage ► EventsList
Gets or sets the events list.
Declaration Syntax
C#
protected Scrollbox EventsList { get; set; }
Value
The events list.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


FailuresList Property

FailuresList Property
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPage ► FailuresList
Gets or sets the goals list.
Declaration Syntax
C#
protected Scrollbox FailuresList { get; set; }
Value
The goals list.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Ignore Property

Ignore Property
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPage ► Ignore
Gets or sets the profiles list.
Declaration Syntax
C#
protected CheckBox Ignore { get; set; }
Value
The profiles list.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OK_Click Method

OK_Click Method
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPage ► OK_Click()()()
Handles a click on the OK button.
Declaration Syntax
C#
protected override void OK_Click()
Remarks
When the user clicks OK, the dialog is closed by calling the CloseWindow method.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Render Method (doc)

Render Method (doc)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPage ► Render(XDocument)
Renders the specified doc.
Declaration Syntax
C#
protected override void Render(
    XDocument doc
)
Parameters
doc (XDocument)
The doc.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TrackingFieldPageBase Class

TrackingFieldPageBase Class
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPageBase
Defines the tracking field page class.
Declaration Syntax
C#
public abstract class TrackingFieldPageBase : DialogPage,
    IHasCommandContext
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TrackingFieldPageBase()()() | Initializes a new instance of the TrackingFieldPageBase class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddExistingCampaigns(Packet) | Adds the existing campaigns.
 | AddExistingEvents(Packet) | Adds the existing events.
 | AddExistingGoals(Packet, List<(Of <(PageEventDefinition>)>)) | Adds the existing goals.
 | AddExistingNoneGoals(Packet, List<(Of <(PageEventDefinition>)>)) | Adds the existing none goals.
 | AddExistingProfiles(Packet) | Adds the existing profiles.
 | AddIgnoreFlag(Packet) | Adds the ignore flag.
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets or sets the application. (Inherited from XamlMainControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cancel_Click()()() | Handles a click on the OK button. (Inherited from DialogPage.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetCommandContext()()() | Gets the command context.
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetEvents(Packet, List<(Of <(PageEventDefinition>)>), CheckBoxList) | Gets the events.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPage()()() | Gets the page.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from DialogPage.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OK_Click()()() | Handles a click on the OK button. (Inherited from DialogPage.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides XamlMainControl.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(XDocument) | Renders the specified doc.
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderCheckBoxList(CheckBoxList, IQueryable<(Of <(PageEventDefinition>)>), List<(Of <(String>)>)) | Renders the check box list.
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text. (Inherited from DialogPage.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | XamlMainControl
 |  |  |  |  | DialogPage
 |  |  |  |  |  | TrackingFieldPageBase
 |  |  |  |  |  |  | GoalsPage
 |  |  |  |  |  |  | ProfilesPage
 |  |  |  |  |  |  | TrackingFieldPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TrackingFieldPageBase Constructor

TrackingFieldPageBase Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPageBase ► TrackingFieldPageBase()()()
Initializes a new instance of the TrackingFieldPageBase class
Declaration Syntax
C#
protected TrackingFieldPageBase()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AddExistingCampaigns Method (packet)

AddExistingCampaigns Method (packet)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPageBase ► AddExistingCampaigns(Packet)
Adds the existing campaigns.
Declaration Syntax
C#
protected void AddExistingCampaigns(
    Packet packet
)
Parameters
packet (Packet)
The packet.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AddExistingEvents Method (packet)

AddExistingEvents Method (packet)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPageBase ► AddExistingEvents(Packet)
Adds the existing events.
Declaration Syntax
C#
protected void AddExistingEvents(
    Packet packet
)
Parameters
packet (Packet)
The packet.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AddExistingGoals Method (packet, pageEventDefinitions)

AddExistingGoals Method (packet, pageEventDefinitions)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPageBase ► AddExistingGoals(Packet, List<(Of <(PageEventDefinition>)>))
Adds the existing goals.
Declaration Syntax
C#
protected void AddExistingGoals(
    Packet packet,
    List<PageEventDefinition> pageEventDefinitions
)
Parameters
packet (Packet)
The packet.
pageEventDefinitions (List<(Of <( PageEventDefinition >)>))
The page event definitions.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AddExistingNoneGoals Method (packet, pageEventDefinitions)

AddExistingNoneGoals Method (packet, pageEventDefinitions)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPageBase ► AddExistingNoneGoals(Packet, List<(Of <(PageEventDefinition>)>))
Adds the existing none goals.
Declaration Syntax
C#
protected void AddExistingNoneGoals(
    Packet packet,
    List<PageEventDefinition> pageEventDefinitions
)
Parameters
packet (Packet)
The packet.
pageEventDefinitions (List<(Of <( PageEventDefinition >)>))
The page event definitions.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AddExistingProfiles Method (packet)

AddExistingProfiles Method (packet)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPageBase ► AddExistingProfiles(Packet)
Adds the existing profiles.
Declaration Syntax
C#
protected void AddExistingProfiles(
    Packet packet
)
Parameters
packet (Packet)
The packet.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AddIgnoreFlag Method (packet)

AddIgnoreFlag Method (packet)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPageBase ► AddIgnoreFlag(Packet)
Adds the ignore flag.
Declaration Syntax
C#
protected void AddIgnoreFlag(
    Packet packet
)
Parameters
packet (Packet)
The packet.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetCommandContext Method

GetCommandContext Method
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPageBase ► GetCommandContext()()()
Gets the command context.
Declaration Syntax
C#
public CommandContext GetCommandContext()
Return Value
The command context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetEvents Method (packet, pageEventDefinitions, checkBoxList)

GetEvents Method (packet, pageEventDefinitions, checkBoxList)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPageBase ► GetEvents(Packet, List<(Of <(PageEventDefinition>)>), CheckBoxList)
Gets the events.
Declaration Syntax
C#
protected static void GetEvents(
    Packet packet,
    List<PageEventDefinition> pageEventDefinitions,
    CheckBoxList checkBoxList
)
Parameters
packet (Packet)
The packet.
pageEventDefinitions (List<(Of <( PageEventDefinition >)>))
The page event definitions.
checkBoxList (CheckBoxList)
The check box list.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetPage Method

GetPage Method
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPageBase ► GetPage()()()
Gets the page.
Declaration Syntax
C#
protected static Page GetPage()
Return Value
The current page.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPageBase ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Render Method (doc)

Render Method (doc)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPageBase ► Render(XDocument)
Renders the specified doc.
Declaration Syntax
C#
protected abstract void Render(
    XDocument doc
)
Parameters
doc (XDocument)
The doc.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RenderCheckBoxList Method (checkBoxList, query, selected)

RenderCheckBoxList Method (checkBoxList, query, selected)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► TrackingFieldPageBase ► RenderCheckBoxList(CheckBoxList, IQueryable<(Of <(PageEventDefinition>)>), List<(Of <(String>)>))
Renders the check box list.
Declaration Syntax
C#
protected static void RenderCheckBoxList(
    CheckBoxList checkBoxList,
    IQueryable<PageEventDefinition> query,
    List<string> selected
)
Parameters
checkBoxList (CheckBoxList)
The check box list.
query (IQueryable<(Of <( PageEventDefinition >)>))
The query.
selected (List<(Of <(String>)>))
The selected.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ViewTrackingDetails Class

ViewTrackingDetails Class
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► ViewTrackingDetails
Defines the open tracking field class.
Declaration Syntax
C#
[SerializableAttribute]
public class ViewTrackingDetails : Command,
    ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ViewTrackingDetails()()() | Initializes a new instance of the ViewTrackingDetails class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ViewTrackingDetails

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ViewTrackingDetails Constructor

ViewTrackingDetails Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► ViewTrackingDetails ► ViewTrackingDetails()()()
Initializes a new instance of the ViewTrackingDetails class
Declaration Syntax
C#
public ViewTrackingDetails()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► ViewTrackingDetails ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.TrackingField ► ViewTrackingDetails ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.Analytics.VisitorIdentification Namespace

Sitecore.Shell.Applications.Analytics.VisitorIdentification Namespace
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.Analytics.VisitorIdentification
Types
All Types Classes Enumerations
Icon | Type | Description
 | VisitorIdentificationPage..::.SectionType | The type of section.
 | VisitorIdentificationPage | Defines the visitor identification page class.


VisitorIdentificationPage Class

VisitorIdentificationPage Class
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification ► VisitorIdentificationPage
Defines the visitor identification page class.
Declaration Syntax
C#
public class VisitorIdentificationPage : DialogPage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VisitorIdentificationPage()()() | Initializes a new instance of the VisitorIdentificationPage class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets or sets the application. (Inherited from XamlMainControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | BusinessIdentification | Gets or sets the business.
 | Cancel_Click()()() | Handles a click on the OK button. (Inherited from DialogPage.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Definition | Gets the definition. (Inherited from XamlControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DnsIdentification | Gets or sets the DNS.
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteAjaxCommand(AjaxCommandEventArgs) | Executes the ajax command. (Inherited from XamlControl.)
 | ExecuteAjaxMethod(AjaxMethodEventArgs) | Executes the ajax method. (Inherited from XamlControl.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
 | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from DialogPage.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IpIdentification | Gets or sets the ip identification.
 | IpOwnerId | Gets or sets the ip owner id.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OK_Click()()() | Handles a click on the OK button. (Overrides DialogPage.OK_Click()()().)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides XamlMainControl.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | OverriddenVisitorIdentification | Gets or sets the overridden visitor identification.
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Panel | Gets or sets the panel.
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewAjaxCommand(AjaxCommandEventArgs) | Previews the Ajax command. (Inherited from XamlControl.)
 | PreviewAjaxMethod(AjaxMethodEventArgs) | Previews the Ajax method. (Inherited from XamlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SessionId | Gets or sets the session id.
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text. (Inherited from DialogPage.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UserAgentIdentification | Gets or sets the user agent identification.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | VisitorIdentification | Gets or sets the visitor identification.
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | XamlControl
 |  |  |  | XamlMainControl
 |  |  |  |  | DialogPage
 |  |  |  |  |  | VisitorIdentificationPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


VisitorIdentificationPage Constructor

VisitorIdentificationPage Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification ► VisitorIdentificationPage ► VisitorIdentificationPage()()()
Initializes a new instance of the VisitorIdentificationPage class
Declaration Syntax
C#
public VisitorIdentificationPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


BusinessIdentification Property

BusinessIdentification Property
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification ► VisitorIdentificationPage ► BusinessIdentification
Gets or sets the business.
Declaration Syntax
C#
public int BusinessIdentification { get; set; }
Value
The business.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DnsIdentification Property

DnsIdentification Property
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification ► VisitorIdentificationPage ► DnsIdentification
Gets or sets the DNS.
Declaration Syntax
C#
public int DnsIdentification { get; set; }
Value
The DNS name.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


IpIdentification Property

IpIdentification Property
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification ► VisitorIdentificationPage ► IpIdentification
Gets or sets the ip identification.
Declaration Syntax
C#
public int IpIdentification { get; set; }
Value
The ip identification.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


IpOwnerId Property

IpOwnerId Property
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification ► VisitorIdentificationPage ► IpOwnerId
Gets or sets the ip owner id.
Declaration Syntax
C#
public string IpOwnerId { get; set; }
Value
The ip owner id.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OK_Click Method

OK_Click Method
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification ► VisitorIdentificationPage ► OK_Click()()()
Handles a click on the OK button.
Declaration Syntax
C#
protected override void OK_Click()
Remarks
When the user clicks OK, the dialog is closed by calling the CloseWindow method.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification ► VisitorIdentificationPage ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OverriddenVisitorIdentification Property

OverriddenVisitorIdentification Property
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification ► VisitorIdentificationPage ► OverriddenVisitorIdentification
Gets or sets the overridden visitor identification.
Declaration Syntax
C#
public int OverriddenVisitorIdentification { get; set; }
Value
The overridden visitor identification.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Panel Property

Panel Property
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification ► VisitorIdentificationPage ► Panel
Gets or sets the panel.
Declaration Syntax
C#
public Border Panel { get; set; }
Value
The panel.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SessionId Property

SessionId Property
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification ► VisitorIdentificationPage ► SessionId
Gets or sets the session id.
Declaration Syntax
C#
public string SessionId { get; set; }
Value
The session id.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


UserAgentIdentification Property

UserAgentIdentification Property
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification ► VisitorIdentificationPage ► UserAgentIdentification
Gets or sets the user agent identification.
Declaration Syntax
C#
public int UserAgentIdentification { get; set; }
Value
The user agent identification.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


VisitorIdentification Property

VisitorIdentification Property
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification ► VisitorIdentificationPage ► VisitorIdentification
Gets or sets the visitor identification.
Declaration Syntax
C#
public int VisitorIdentification { get; set; }
Value
The visitor identification.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


VisitorIdentificationPage.SectionType Enumeration

VisitorIdentificationPage..::.SectionType Enumeration
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentification ► VisitorIdentificationPage ► VisitorIdentificationPage..::.SectionType
The type of section.
Declaration Syntax
C#
public enum SectionType
Members
Member | Description
Business | The Business section.
IP | The IP section.
UserAgent | The User Agent section.
Dns | The DNS section.
Visitor | The visitor section.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.Analytics.VisitorIdentifications Namespace

Sitecore.Shell.Applications.Analytics.VisitorIdentifications Namespace
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentifications
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.Analytics.VisitorIdentifications
Types
All Types Classes
Icon | Type | Description
 | RunVisitorIdentifications | Defines the run lookup class.
 | RunVisitorIdentificationsForm | Defines the run lookup form class.


RunVisitorIdentifications Class

RunVisitorIdentifications Class
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentifications ► RunVisitorIdentifications
Defines the run lookup class.
Declaration Syntax
C#
[SerializableAttribute]
public class RunVisitorIdentifications : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RunVisitorIdentifications()()() | Initializes a new instance of the RunVisitorIdentifications class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | RunVisitorIdentifications

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RunVisitorIdentifications Constructor

RunVisitorIdentifications Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentifications ► RunVisitorIdentifications ► RunVisitorIdentifications()()()
Initializes a new instance of the RunVisitorIdentifications class
Declaration Syntax
C#
public RunVisitorIdentifications()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentifications ► RunVisitorIdentifications ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentifications ► RunVisitorIdentifications ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RunVisitorIdentificationsForm Class

RunVisitorIdentificationsForm Class
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentifications ► RunVisitorIdentificationsForm
Defines the run lookup form class.
Declaration Syntax
C#
public class RunVisitorIdentificationsForm : WizardForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RunVisitorIdentificationsForm()()() | Initializes a new instance of the RunVisitorIdentificationsForm class
 | Active | Gets or sets the active. (Inherited from WizardForm.)
 | ActivePageChanged(String, String) | Called when the active page has been changed. (Overrides WizardForm.ActivePageChanged(String, String).)
 | ActivePageChanging(String, String%) | Called when the active page is changing. (Overrides WizardForm.ActivePageChanging(String, String%).)
 | Back()()() | Back. (Inherited from WizardForm.)
 | BackButton | (Inherited from WizardForm.)
 | Cancel()()() | Cancel. (Inherited from WizardForm.)
 | CancelButton | (Inherited from WizardForm.)
 | CheckStatus()()() | Checks the status.
 | Confirmation(ClientPipelineArgs) | Presents a confirmation box to the user when the Cancel button has been clicked. (Inherited from WizardForm.)
 | EndWizard()()() | Ends the wizard. (Inherited from WizardForm.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorText | Gets or sets the error text.
 | EventsEnabled | Gets or sets a value indicating whether events are enabled. (Inherited from BaseForm.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from BaseForm.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Next()()() | Moves the wizard to the next page. (Inherited from WizardForm.)
 | NextButton | (Inherited from WizardForm.)
 | OnBack(Object, EventArgs) | Called when the user clicks the Back button. (Inherited from WizardForm.)
 | OnCancel(Object, EventArgs) | Called when the user clicks the Cancel button. (Inherited from WizardForm.)
 | OnLoad(EventArgs) | Raises the load event. (Overrides WizardForm.OnLoad(EventArgs).)
 | OnNext(Object, EventArgs) | Called when the user clicks the Next button. (Inherited from WizardForm.)
 | OnPreRender(EventArgs) | Raises the pre render event. (Inherited from BaseForm.)
 | Pages | Gets the pages. (Inherited from WizardForm.)
 | ResultText | Gets or sets the result text.
 | ServerProperties | Gets the server properties. (Inherited from BaseForm.)
 | StartRunning()()() | Starts the rebuilding.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | WizardForm
 |  |  | RunVisitorIdentificationsForm

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RunVisitorIdentificationsForm Constructor

RunVisitorIdentificationsForm Constructor
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentifications ► RunVisitorIdentificationsForm ► RunVisitorIdentificationsForm()()()
Initializes a new instance of the RunVisitorIdentificationsForm class
Declaration Syntax
C#
public RunVisitorIdentificationsForm()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ActivePageChanged Method (page, oldPage)

ActivePageChanged Method (page, oldPage)
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentifications ► RunVisitorIdentificationsForm ► ActivePageChanged(String, String)
Called when the active page has been changed.
Declaration Syntax
C#
protected override void ActivePageChanged(
    string page,
    string oldPage
)
Parameters
page (String)
The page that has been entered.
oldPage (String)
The page that was left.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ActivePageChanging Method (page, newPage)

ActivePageChanging Method (page, newPage)
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentifications ► RunVisitorIdentificationsForm ► ActivePageChanging(String, String%)
Called when the active page is changing.
Declaration Syntax
C#
protected override bool ActivePageChanging(
    string page,
    ref string newPage
)
Parameters
page (String)
The page that is being left.
newPage ( String %)
The new page that is being entered.
Return Value
True, if the change is allowed, otherwise false.
Remarks
Set the newpage parameter to another page ID to control the path through the wizard pages.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CheckStatus Method

CheckStatus Method
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentifications ► RunVisitorIdentificationsForm ► CheckStatus()()()
Checks the status.
Declaration Syntax
C#
protected void CheckStatus()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ErrorText Property

ErrorText Property
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentifications ► RunVisitorIdentificationsForm ► ErrorText
Gets or sets the error text.
Declaration Syntax
C#
protected Memo ErrorText { get; set; }
Value
The error text.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentifications ► RunVisitorIdentificationsForm ► OnLoad(EventArgs)
Raises the load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs instance containing the event data.
Remarks
This method notifies the server control that it should perform actions common to each HTTP request for the page it is associated with, such as setting up a database query. At this stage in the page life-cycle, server controls in the hierarchy are created and initialized, view state is restored, and form controls reflect client-side data. Use the IsPostBack property to determine whether the page is being loaded in response to a client post-back, or if it is being loaded and accessed for the first time.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ResultText Property

ResultText Property
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentifications ► RunVisitorIdentificationsForm ► ResultText
Gets or sets the result text.
Declaration Syntax
C#
protected Memo ResultText { get; set; }
Value
The result text.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


StartRunning Method

StartRunning Method
Namespaces ► Sitecore.Shell.Applications.Analytics.VisitorIdentifications ► RunVisitorIdentificationsForm ► StartRunning()()()
Starts the rebuilding.
Declaration Syntax
C#
protected void StartRunning()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues Namespace

Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues Namespace
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues
Types
All Types Classes
Icon | Type | Description
 | RegexValidate | Defines the validate class.
 | ReturnAndClose | Defines the validate class.
 | ReturnFieldEditorValuesArgs | Defines the return mini editor values args class.
 | SetValues | Defines the validate class.
 | Validate | Defines the validate class.


RegexValidate Class

RegexValidate Class
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► RegexValidate
Defines the validate class.
Declaration Syntax
C#
public class RegexValidate
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RegexValidate()()() | Initializes a new instance of the RegexValidate class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ReturnFieldEditorValuesArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RegexValidate

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RegexValidate Constructor

RegexValidate Constructor
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► RegexValidate ► RegexValidate()()()
Initializes a new instance of the RegexValidate class
Declaration Syntax
C#
public RegexValidate()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► RegexValidate ► Process(ReturnFieldEditorValuesArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    ReturnFieldEditorValuesArgs args
)
Parameters
args (ReturnFieldEditorValuesArgs)
The arguments.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ReturnAndClose Class

ReturnAndClose Class
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► ReturnAndClose
Defines the validate class.
Declaration Syntax
C#
public class ReturnAndClose
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ReturnAndClose()()() | Initializes a new instance of the ReturnAndClose class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ReturnFieldEditorValuesArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ReturnAndClose

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ReturnAndClose Constructor

ReturnAndClose Constructor
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► ReturnAndClose ► ReturnAndClose()()()
Initializes a new instance of the ReturnAndClose class
Declaration Syntax
C#
public ReturnAndClose()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► ReturnAndClose ► Process(ReturnFieldEditorValuesArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    ReturnFieldEditorValuesArgs args
)
Parameters
args (ReturnFieldEditorValuesArgs)
The arguments.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ReturnFieldEditorValuesArgs Class

ReturnFieldEditorValuesArgs Class
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► ReturnFieldEditorValuesArgs
Defines the return mini editor values args class.
Declaration Syntax
C#
public class ReturnFieldEditorValuesArgs : ClientPipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReturnFieldEditorValuesArgs(FieldEditorOptions, Hashtable) | Initializes a new instance of the ReturnFieldEditorValuesArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldInfo | Gets the field info.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ClientPipelineArgs.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Options | Gets the options.
 | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from ClientPipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
 | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitForPostBack()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ClientPipelineArgs
 |  |  |  | ReturnFieldEditorValuesArgs

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ReturnFieldEditorValuesArgs Constructor (options, fieldInfo)

ReturnFieldEditorValuesArgs Constructor (options, fieldInfo)
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► ReturnFieldEditorValuesArgs ► ReturnFieldEditorValuesArgs(FieldEditorOptions, Hashtable)
Initializes a new instance of the ReturnFieldEditorValuesArgs class.
Declaration Syntax
C#
public ReturnFieldEditorValuesArgs(
    FieldEditorOptions options,
    Hashtable fieldInfo
)
Parameters
options (FieldEditorOptions)
The options.
fieldInfo (Hashtable)
The field info.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


FieldInfo Property

FieldInfo Property
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► ReturnFieldEditorValuesArgs ► FieldInfo
Gets the field info.
Declaration Syntax
C#
public Hashtable FieldInfo { get; }
Value
The field info.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Options Property

Options Property
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► ReturnFieldEditorValuesArgs ► Options
Gets the options.
Declaration Syntax
C#
public FieldEditorOptions Options { get; }
Value
The options.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SetValues Class

SetValues Class
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► SetValues
Defines the validate class.
Declaration Syntax
C#
public class SetValues
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SetValues()()() | Initializes a new instance of the SetValues class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ReturnFieldEditorValuesArgs) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SetValues

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SetValues Constructor

SetValues Constructor
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► SetValues ► SetValues()()()
Initializes a new instance of the SetValues class
Declaration Syntax
C#
public SetValues()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► SetValues ► Process(ReturnFieldEditorValuesArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    ReturnFieldEditorValuesArgs args
)
Parameters
args (ReturnFieldEditorValuesArgs)
The arguments.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Validate Class

Validate Class
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► Validate
Defines the validate class.
Declaration Syntax
C#
public class Validate : Validators
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Validate()()() | Initializes a new instance of the Validate class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(ReturnFieldEditorValuesArgs) | Runs the processor.
 | Process(SaveArgs) | Runs the processor. (Inherited from Validators.)
 | ProcessInternal(ClientPipelineArgs) | Processes the internal. (Inherited from Validators.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Validators
 |  | Validate

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Validate Constructor

Validate Constructor
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► Validate ► Validate()()()
Initializes a new instance of the Validate class
Declaration Syntax
C#
public Validate()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Shell.Applications.ContentManager.ReturnFieldEditorValues ► Validate ► Process(ReturnFieldEditorValuesArgs)
Runs the processor.
Declaration Syntax
C#
public void Process(
    ReturnFieldEditorValuesArgs args
)
Parameters
args (ReturnFieldEditorValuesArgs)
The arguments.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Applications.Dialogs.FilterEditor Namespace

Sitecore.Shell.Applications.Dialogs.FilterEditor Namespace
Namespaces ► Sitecore.Shell.Applications.Dialogs.FilterEditor
Declaration Syntax
C#
namespace Sitecore.Shell.Applications.Dialogs.FilterEditor
Types
All Types Classes
Icon | Type | Description
 | FilterEditorOptions | Defines the rule set editor options class.


FilterEditorOptions Class

FilterEditorOptions Class
Namespaces ► Sitecore.Shell.Applications.Dialogs.FilterEditor ► FilterEditorOptions
Defines the rule set editor options class.
Declaration Syntax
C#
public class FilterEditorOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FilterEditorOptions()()() | Initializes a new instance of the FilterEditorOptions class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IncludePersonas | Gets or sets a value indicating whether to include personas.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnlyApplicable | Gets or sets a value indicating whether [only applicable].
 | Parse()()() | Parses this instance.
 | ReportFileName | Gets or sets the name of the report file.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToUrlString()()() | Builds a UrlString from the settings.
 | Value | Gets or sets the value.
Inheritance Hierarchy
Object
FilterEditorOptions


FilterEditorOptions Constructor

FilterEditorOptions Constructor
Namespaces ► Sitecore.Shell.Applications.Dialogs.FilterEditor ► FilterEditorOptions ► FilterEditorOptions()()()
Initializes a new instance of the FilterEditorOptions class
Declaration Syntax
C#
public FilterEditorOptions()


IncludePersonas Property

IncludePersonas Property
Namespaces ► Sitecore.Shell.Applications.Dialogs.FilterEditor ► FilterEditorOptions ► IncludePersonas
Gets or sets a value indicating whether to include personas.
Declaration Syntax
C#
public bool IncludePersonas { get; set; }
Value
true if to include personas; otherwise, false.


OnlyApplicable Property

OnlyApplicable Property
Namespaces ► Sitecore.Shell.Applications.Dialogs.FilterEditor ► FilterEditorOptions ► OnlyApplicable
Gets or sets a value indicating whether [only applicable].
Declaration Syntax
C#
public bool OnlyApplicable { get; set; }
Value
true if [only applicable]; otherwise, false.


Parse Method

Parse Method
Namespaces ► Sitecore.Shell.Applications.Dialogs.FilterEditor ► FilterEditorOptions ► Parse()()()
Parses this instance.
Declaration Syntax
C#
public static FilterEditorOptions Parse()
Return Value
Returns the rule set editor options.


ReportFileName Property

ReportFileName Property
Namespaces ► Sitecore.Shell.Applications.Dialogs.FilterEditor ► FilterEditorOptions ► ReportFileName
Gets or sets the name of the report file.
Declaration Syntax
C#
public string ReportFileName { get; set; }
Value
The name of the report file.


ToUrlString Method

ToUrlString Method
Namespaces ► Sitecore.Shell.Applications.Dialogs.FilterEditor ► FilterEditorOptions ► ToUrlString()()()
Builds a UrlString from the settings.
Declaration Syntax
C#
public UrlString ToUrlString()
Return Value
Returns the URL string.


Value Property

Value Property
Namespaces ► Sitecore.Shell.Applications.Dialogs.FilterEditor ► FilterEditorOptions ► Value
Gets or sets the value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.


Sitecore.Shell.Controls.Applications Namespace

Sitecore.Shell.Controls.Applications Namespace
Namespaces ► Sitecore.Shell.Controls.Applications
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.Applications
Types
All Types Classes
Icon | Type | Description
 | ApplicationForm | Represents a ApplicationForm.


ApplicationForm Class

ApplicationForm Class
Namespaces ► Sitecore.Shell.Controls.Applications ► ApplicationForm
Represents a ApplicationForm.
Declaration Syntax
C#
public class ApplicationForm : BaseForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApplicationForm()()() | Initializes a new instance of the ApplicationForm class
 | Body |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled | Gets or sets a value indicating whether events are enabled. (Inherited from BaseForm.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormPage |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from BaseForm.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnLoad(EventArgs) | Raises the load event. (Overrides BaseForm.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the pre render event. (Inherited from BaseForm.)
 | ServerProperties | Gets the server properties. (Inherited from BaseForm.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | ApplicationForm

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ApplicationForm Constructor

ApplicationForm Constructor
Namespaces ► Sitecore.Shell.Controls.Applications ► ApplicationForm ► ApplicationForm()()()
Initializes a new instance of the ApplicationForm class
Declaration Syntax
C#
public ApplicationForm()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Body Field

Body Field
Namespaces ► Sitecore.Shell.Controls.Applications ► ApplicationForm ► Body
Declaration Syntax
C#
protected Border Body

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


FormPage Field

FormPage Field
Namespaces ► Sitecore.Shell.Controls.Applications ► ApplicationForm ► FormPage
Declaration Syntax
C#
protected XmlControl FormPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Applications ► ApplicationForm ► OnLoad(EventArgs)
Raises the load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs instance containing the event data.
Remarks
This method notifies the server control that it should perform actions common to each HTTP request for the page it is associated with, such as setting up a database query. At this stage in the page lifecycle, server controls in the hierarchy are created and initialized, view state is restored, and form controls reflect client-side data. Use the IsPostBack property to determine whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.Commandbars Namespace

Sitecore.Shell.Controls.Commandbars Namespace
Namespaces ► Sitecore.Shell.Controls.Commandbars
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.Commandbars
Types
All Types Classes
Icon | Type | Description
 | CommandbarXmlControl | Represents a CommandbarXmlControl.


CommandbarXmlControl Class

CommandbarXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Commandbars ► CommandbarXmlControl
Represents a CommandbarXmlControl.
Declaration Syntax
C#
public class CommandbarXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandbarXmlControl()()() | Initializes a new instance of the CommandbarXmlControl class.
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | CommandbarDescription |
 | CommandbarIcon |
 | CommandbarTitle |
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | More()()() | Mores this instance.
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | Preview | Gets or sets the preview.
 | PreviewPane |
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | Tasks |
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toolbar |
 | ToolbarIcon |
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | CommandbarXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CommandbarXmlControl Constructor

CommandbarXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Commandbars ► CommandbarXmlControl ► CommandbarXmlControl()()()
Initializes a new instance of the CommandbarXmlControl class.
Declaration Syntax
C#
public CommandbarXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CommandbarDescription Field

CommandbarDescription Field
Namespaces ► Sitecore.Shell.Controls.Commandbars ► CommandbarXmlControl ► CommandbarDescription
Declaration Syntax
C#
protected Literal CommandbarDescription

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CommandbarIcon Field

CommandbarIcon Field
Namespaces ► Sitecore.Shell.Controls.Commandbars ► CommandbarXmlControl ► CommandbarIcon
Declaration Syntax
C#
protected ThemedImage CommandbarIcon

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CommandbarTitle Field

CommandbarTitle Field
Namespaces ► Sitecore.Shell.Controls.Commandbars ► CommandbarXmlControl ► CommandbarTitle
Declaration Syntax
C#
protected Literal CommandbarTitle

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


More Method

More Method
Namespaces ► Sitecore.Shell.Controls.Commandbars ► CommandbarXmlControl ► More()()()
Mores this instance.
Declaration Syntax
C#
protected void More()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Commandbars ► CommandbarXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Preview Property

Preview Property
Namespaces ► Sitecore.Shell.Controls.Commandbars ► CommandbarXmlControl ► Preview
Gets or sets the preview.
Declaration Syntax
C#
public string Preview { get; set; }
Value
The preview.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PreviewPane Field

PreviewPane Field
Namespaces ► Sitecore.Shell.Controls.Commandbars ► CommandbarXmlControl ► PreviewPane
Declaration Syntax
C#
protected Border PreviewPane

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Tasks Field

Tasks Field
Namespaces ► Sitecore.Shell.Controls.Commandbars ► CommandbarXmlControl ► Tasks
Declaration Syntax
C#
protected GridPanel Tasks

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Toolbar Field

Toolbar Field
Namespaces ► Sitecore.Shell.Controls.Commandbars ► CommandbarXmlControl ► Toolbar
Declaration Syntax
C#
protected Border Toolbar

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ToolbarIcon Field

ToolbarIcon Field
Namespaces ► Sitecore.Shell.Controls.Commandbars ► CommandbarXmlControl ► ToolbarIcon
Declaration Syntax
C#
protected ThemedImage ToolbarIcon

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.CommandPortal.Portlets.CommandsSimpleInfo Namespace

Sitecore.Shell.Controls.CommandPortal.Portlets.CommandsSimpleInfo Namespace
Namespaces ► Sitecore.Shell.Controls.CommandPortal.Portlets.CommandsSimpleInfo
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.CommandPortal.Portlets.CommandsSimpleInfo
Types
All Types Classes
Icon | Type | Description
 | CommandsSimpleInfoPortletXmlControl | Represents a CommandsSimpleInfoPortletXmlControl.


CommandsSimpleInfoPortletXmlControl Class

CommandsSimpleInfoPortletXmlControl Class
Namespaces ► Sitecore.Shell.Controls.CommandPortal.Portlets.CommandsSimpleInfo ► CommandsSimpleInfoPortletXmlControl
Represents a CommandsSimpleInfoPortletXmlControl.
Declaration Syntax
C#
public class CommandsSimpleInfoPortletXmlControl : PortletXmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandsSimpleInfoPortletXmlControl()()() | Initializes a new instance of the CommandsSimpleInfoPortletXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Body |
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides PortletXmlControl.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text |
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | PortletXmlControl
 |  |  |  |  |  | CommandsSimpleInfoPortletXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CommandsSimpleInfoPortletXmlControl Constructor

CommandsSimpleInfoPortletXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.CommandPortal.Portlets.CommandsSimpleInfo ► CommandsSimpleInfoPortletXmlControl ► CommandsSimpleInfoPortletXmlControl()()()
Initializes a new instance of the CommandsSimpleInfoPortletXmlControl class
Declaration Syntax
C#
public CommandsSimpleInfoPortletXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Body Field

Body Field
Namespaces ► Sitecore.Shell.Controls.CommandPortal.Portlets.CommandsSimpleInfo ► CommandsSimpleInfoPortletXmlControl ► Body
Declaration Syntax
C#
protected Border Body

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.CommandPortal.Portlets.CommandsSimpleInfo ► CommandsSimpleInfoPortletXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Text Field

Text Field
Namespaces ► Sitecore.Shell.Controls.CommandPortal.Portlets.CommandsSimpleInfo ► CommandsSimpleInfoPortletXmlControl ► Text
Declaration Syntax
C#
protected Literal Text

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.InformationBar Namespace

Sitecore.Shell.Controls.InformationBar Namespace
Namespaces ► Sitecore.Shell.Controls.InformationBar
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.InformationBar
Types
All Types Classes
Icon | Type | Description
 | InformationBarXmlControl | Represents a InformationBarXmlControl.


InformationBarXmlControl Class

InformationBarXmlControl Class
Namespaces ► Sitecore.Shell.Controls.InformationBar ► InformationBarXmlControl
Represents a InformationBarXmlControl.
Declaration Syntax
C#
public class InformationBarXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InformationBarXmlControl()()() | Initializes a new instance of the InformationBarXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | Bar |
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Close |
 | CloseBar()()() | Closes the bar.
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | InformationBarXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


InformationBarXmlControl Constructor

InformationBarXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.InformationBar ► InformationBarXmlControl ► InformationBarXmlControl()()()
Initializes a new instance of the InformationBarXmlControl class
Declaration Syntax
C#
public InformationBarXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Bar Field

Bar Field
Namespaces ► Sitecore.Shell.Controls.InformationBar ► InformationBarXmlControl ► Bar
Declaration Syntax
C#
protected Border Bar

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Close Field

Close Field
Namespaces ► Sitecore.Shell.Controls.InformationBar ► InformationBarXmlControl ► Close
Declaration Syntax
C#
protected ImageButton Close

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CloseBar Method

CloseBar Method
Namespaces ► Sitecore.Shell.Controls.InformationBar ► InformationBarXmlControl ► CloseBar()()()
Closes the bar.
Declaration Syntax
C#
protected void CloseBar()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.InformationBar ► InformationBarXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.MDI Namespace

Sitecore.Shell.Controls.MDI Namespace
Namespaces ► Sitecore.Shell.Controls.MDI
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.MDI
Types
All Types Classes
Icon | Type | Description
 | MDIXmlControl | Represents a MDIXmlControl.


MDIXmlControl Class

MDIXmlControl Class
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl
Represents a MDIXmlControl.
Declaration Syntax
C#
public class MDIXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MDIXmlControl()()() | Initializes a new instance of the MDIXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Active | Gets or sets the active.
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CloseButton |
 | CloseTab()()() | Closes the tab.
 | CloseTab(String) | Closes the tab.
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu.
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateTab(String, String, String) | Creates the tab.
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoCloseTab(ClientPipelineArgs) | Executes the close tab event.
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus(String) | Focuses the specified id.
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTabByUri(String) | Gets the tab by URI.
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header |
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | HideTabs | Gets or sets a value indicating whether the MDIXmlControl hides the tabs.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | ListButton |
 | ListTabs()()() | Lists the tabs.
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MDIFrames |
 | MDITabs |
 | MDIWorkspace |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RefreshTabs()()() | Refreshes the tabs.
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | SetTabHeader(String, String) | Sets the tab header.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIDs | Gets or sets the tab I ds.
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | TopSeparator |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | MDIXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


MDIXmlControl Constructor

MDIXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► MDIXmlControl()()()
Initializes a new instance of the MDIXmlControl class
Declaration Syntax
C#
public MDIXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Active Property

Active Property
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► Active
Gets or sets the active.
Declaration Syntax
C#
public string Active { get; set; }
Value
The active.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CloseButton Field

CloseButton Field
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► CloseButton
Declaration Syntax
C#
protected ImageButton CloseButton

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CloseTab Method

CloseTab Method
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► CloseTab()()()
Members
Icon | Member | Description
 | CloseTab()()() | Closes the tab.
 | CloseTab(String) | Closes the tab.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CloseTab Method

CloseTab Method
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► CloseTab()()()
Closes the tab.
Declaration Syntax
C#
public void CloseTab()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CloseTab Method (tab)

CloseTab Method (tab)
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► CloseTab(String)
Closes the tab.
Declaration Syntax
C#
public void CloseTab(
    string tab
)
Parameters
tab (String)
The tab.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ContextMenu Property

ContextMenu Property
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► ContextMenu
Gets or sets the context menu.
Declaration Syntax
C#
public string ContextMenu { get; set; }
Value
The context menu.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CreateTab Method (id, header, uri)

CreateTab Method (id, header, uri)
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► CreateTab(String, String, String)
Creates the tab.
Declaration Syntax
C#
public void CreateTab(
    string id,
    string header,
    string uri
)
Parameters
id (String)
The id.
header (String)
The header.
uri (String)
The URI.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DoCloseTab Method (args)

DoCloseTab Method (args)
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► DoCloseTab(ClientPipelineArgs)
Executes the close tab event.
Declaration Syntax
C#
public void DoCloseTab(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Focus Method (id)

Focus Method (id)
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► Focus(String)
Focuses the specified id.
Declaration Syntax
C#
public void Focus(
    string id
)
Parameters
id (String)
The id.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetTabByUri Method (uri)

GetTabByUri Method (uri)
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► GetTabByUri(String)
Gets the tab by URI.
Declaration Syntax
C#
public string GetTabByUri(
    string uri
)
Parameters
uri (String)
The URI.
Return Value
The tab by URI.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Header Field

Header Field
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► Header
Declaration Syntax
C#
protected GridPanel Header

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


HideTabs Property

HideTabs Property
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► HideTabs
Gets or sets a value indicating whether the MDIXmlControl hides the tabs.
Declaration Syntax
C#
public bool HideTabs { get; set; }
Value
true if the MDIXmlControl hides the tabs; otherwise, false.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ListButton Field

ListButton Field
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► ListButton
Declaration Syntax
C#
protected ImageButton ListButton

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ListTabs Method

ListTabs Method
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► ListTabs()()()
Lists the tabs.
Declaration Syntax
C#
public void ListTabs()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


MDIFrames Field

MDIFrames Field
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► MDIFrames
Declaration Syntax
C#
protected Border MDIFrames

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


MDITabs Field

MDITabs Field
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► MDITabs
Declaration Syntax
C#
protected Border MDITabs

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


MDIWorkspace Field

MDIWorkspace Field
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► MDIWorkspace
Declaration Syntax
C#
protected Border MDIWorkspace

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RefreshTabs Method

RefreshTabs Method
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► RefreshTabs()()()
Refreshes the tabs.
Declaration Syntax
C#
public void RefreshTabs()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SetTabHeader Method (id, name)

SetTabHeader Method (id, name)
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► SetTabHeader(String, String)
Sets the tab header.
Declaration Syntax
C#
public void SetTabHeader(
    string id,
    string name
)
Parameters
id (String)
The id.
name (String)
The name.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TabIDs Property

TabIDs Property
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► TabIDs
Gets or sets the tab I ds.
Declaration Syntax
C#
public string TabIDs { get; set; }
Value
The tab I ds.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TopSeparator Field

TopSeparator Field
Namespaces ► Sitecore.Shell.Controls.MDI ► MDIXmlControl ► TopSeparator
Declaration Syntax
C#
protected Border TopSeparator

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.Panes Namespace

Sitecore.Shell.Controls.Panes Namespace
Namespaces ► Sitecore.Shell.Controls.Panes
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.Panes
Types
All Types Classes
Icon | Type | Description
 | HiddenPaneXmlControl | Represents a HiddenPaneXmlControl.
 | PaneXmlControl | Represents a PaneXmlControl.


HiddenPaneXmlControl Class

HiddenPaneXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Panes ► HiddenPaneXmlControl
Represents a HiddenPaneXmlControl.
Declaration Syntax
C#
public class HiddenPaneXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HiddenPaneXmlControl()()() | Initializes a new instance of the HiddenPaneXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Pane |
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | ShowPane()()() | Shows the pane.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | HiddenPaneXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


HiddenPaneXmlControl Constructor

HiddenPaneXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Panes ► HiddenPaneXmlControl ► HiddenPaneXmlControl()()()
Initializes a new instance of the HiddenPaneXmlControl class
Declaration Syntax
C#
public HiddenPaneXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Panes ► HiddenPaneXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Pane Field

Pane Field
Namespaces ► Sitecore.Shell.Controls.Panes ► HiddenPaneXmlControl ► Pane
Declaration Syntax
C#
protected Border Pane

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ShowPane Method

ShowPane Method
Namespaces ► Sitecore.Shell.Controls.Panes ► HiddenPaneXmlControl ► ShowPane()()()
Shows the pane.
Declaration Syntax
C#
public void ShowPane()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PaneXmlControl Class

PaneXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl
Represents a PaneXmlControl.
Declaration Syntax
C#
public class PaneXmlControl : XmlControl,
    IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaneXmlControl()()() | Initializes a new instance of the PaneXmlControl class.
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Body |
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Caption |
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click()()() | Clicks this instance.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CloseButton |
 | CollapseButton |
 | Collapsed | Gets or sets the collapsed.
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Control |
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableClose | Gets or sets a value indicating whether the PaneXmlControl disables the close.
 | DisableCollapse | Gets or sets a value indicating whether the PaneXmlControl disables the collapse.
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Overrides XmlControl.HandleMessage(Message).)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | HidePane()()() | Hides the pane.
 | HideToolbar | Gets or sets a value indicating whether the PaneXmlControl hides the toolbar.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnHide |
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Control.OnPreRender(EventArgs).)
 | OnShow |
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PaneContent |
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | ShowPane()()() | Shows the pane.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toolbar |
 | ToolbarPlaceholder |
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | PaneXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PaneXmlControl Constructor

PaneXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► PaneXmlControl()()()
Initializes a new instance of the PaneXmlControl class.
Declaration Syntax
C#
public PaneXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Body Field

Body Field
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► Body
Declaration Syntax
C#
protected Control Body

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Caption Field

Caption Field
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► Caption
Declaration Syntax
C#
protected Border Caption

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Click Method

Click Method
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► Click()()()
Clicks this instance.
Declaration Syntax
C#
protected virtual void Click()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CloseButton Field

CloseButton Field
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► CloseButton
Declaration Syntax
C#
protected ImageButton CloseButton

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CollapseButton Field

CollapseButton Field
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► CollapseButton
Declaration Syntax
C#
protected ImageButton CollapseButton

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Collapsed Property

Collapsed Property
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► Collapsed
Gets or sets the collapsed.
Declaration Syntax
C#
public string Collapsed { get; set; }
Value
The collapsed.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Control Field

Control Field
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► Control
Declaration Syntax
C#
protected Border Control

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DisableClose Property

DisableClose Property
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► DisableClose
Gets or sets a value indicating whether the PaneXmlControl disables the close.
Declaration Syntax
C#
public bool DisableClose { get; set; }
Value
true if the PaneXmlControl disables the close; otherwise, false.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DisableCollapse Property

DisableCollapse Property
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► DisableCollapse
Gets or sets a value indicating whether the PaneXmlControl disables the collapse.
Declaration Syntax
C#
public bool DisableCollapse { get; set; }
Value
true if the PaneXmlControl disables the collapse; otherwise, false.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► HandleMessage(Message)
Handles the message.
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)
The message.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


HidePane Method

HidePane Method
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► HidePane()()()
Hides the pane.
Declaration Syntax
C#
public void HidePane()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


HideToolbar Property

HideToolbar Property
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► HideToolbar
Gets or sets a value indicating whether the PaneXmlControl hides the toolbar.
Declaration Syntax
C#
public bool HideToolbar { get; set; }
Value
true if the PaneXmlControl hides the toolbar; otherwise, false.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnHide Event

OnHide Event
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► OnHide
Declaration Syntax
C#
public event EventHandler OnHide

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnShow Event

OnShow Event
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► OnShow
Declaration Syntax
C#
public event EventHandler OnShow

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PaneContent Field

PaneContent Field
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► PaneContent
Declaration Syntax
C#
protected Control PaneContent

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ShowPane Method

ShowPane Method
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► ShowPane()()()
Shows the pane.
Declaration Syntax
C#
public void ShowPane()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Toolbar Field

Toolbar Field
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► Toolbar
Declaration Syntax
C#
protected Control Toolbar

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ToolbarPlaceholder Field

ToolbarPlaceholder Field
Namespaces ► Sitecore.Shell.Controls.Panes ► PaneXmlControl ► ToolbarPlaceholder
Declaration Syntax
C#
protected Control ToolbarPlaceholder

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.Portal Namespace

Sitecore.Shell.Controls.Portal Namespace
Namespaces ► Sitecore.Shell.Controls.Portal
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.Portal
Types
All Types Classes
Icon | Type | Description
 | DefaultPortletWindowXmlControl |
 | PortalConfiguratorForm | Represents a PortalConfiguratorForm.
 | PortalSidebarForm2 | Represents a PortalSidebarForm2.
 | PortletWindowXmlControl | Represents a PortletWindowXmlControl.


DefaultPortletWindowXmlControl Class

DefaultPortletWindowXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Portal ► DefaultPortletWindowXmlControl
Declaration Syntax
C#
public class DefaultPortletWindowXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultPortletWindowXmlControl()()() | Initializes a new instance of the DefaultPortletWindowXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header |
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon |
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | DefaultPortletWindowXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DefaultPortletWindowXmlControl Constructor

DefaultPortletWindowXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Portal ► DefaultPortletWindowXmlControl ► DefaultPortletWindowXmlControl()()()
Initializes a new instance of the DefaultPortletWindowXmlControl class
Declaration Syntax
C#
public DefaultPortletWindowXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Header Property

Header Property
Namespaces ► Sitecore.Shell.Controls.Portal ► DefaultPortletWindowXmlControl ► Header
Declaration Syntax
C#
public string Header { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Controls.Portal ► DefaultPortletWindowXmlControl ► Icon
Declaration Syntax
C#
public string Icon { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Portal ► DefaultPortletWindowXmlControl ► OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PortalConfiguratorForm Class

PortalConfiguratorForm Class
Namespaces ► Sitecore.Shell.Controls.Portal ► PortalConfiguratorForm
Represents a PortalConfiguratorForm.
Declaration Syntax
C#
public class PortalConfiguratorForm : DialogForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PortalConfiguratorForm()()() | Initializes a new instance of the PortalConfiguratorForm class
 | Cancel | (Inherited from DialogForm.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled | Gets or sets a value indicating whether events are enabled. (Inherited from BaseForm.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from BaseForm.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OK | (Inherited from DialogForm.)
 | OnCancel(Object, EventArgs) | Handles a click on the Cancel button. (Inherited from DialogForm.)
 | OnLoad(EventArgs) | Raises the load event. (Overrides DialogForm.OnLoad(EventArgs).)
 | OnOK(Object, EventArgs) | Handles a click on the OK button. (Overrides DialogForm.OnOK(Object, EventArgs).)
 | OnPreRender(EventArgs) | Raises the pre render event. (Inherited from BaseForm.)
 | Portal |
 | Portlets |
 | ServerProperties | Gets the server properties. (Inherited from BaseForm.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | DialogForm
 |  |  | PortalConfiguratorForm

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PortalConfiguratorForm Constructor

PortalConfiguratorForm Constructor
Namespaces ► Sitecore.Shell.Controls.Portal ► PortalConfiguratorForm ► PortalConfiguratorForm()()()
Initializes a new instance of the PortalConfiguratorForm class
Declaration Syntax
C#
public PortalConfiguratorForm()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Portal ► PortalConfiguratorForm ► OnLoad(EventArgs)
Raises the load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs instance containing the event data.
Remarks
This method notifies the server control that it should perform actions common to each HTTP request for the page it is associated with, such as setting up a database query. At this stage in the page lifecycle, server controls in the hierarchy are created and initialized, view state is restored, and form controls reflect client-side data. Use the IsPostBack property to determine whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnOK Method (sender, args)

OnOK Method (sender, args)
Namespaces ► Sitecore.Shell.Controls.Portal ► PortalConfiguratorForm ► OnOK(Object, EventArgs)
Handles a click on the OK button.
Declaration Syntax
C#
protected override void OnOK(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
args (EventArgs)
Remarks
When the user clicks OK, the dialog is closed by calling the CloseWindow method.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Portal Field

Portal Field
Namespaces ► Sitecore.Shell.Controls.Portal ► PortalConfiguratorForm ► Portal
Declaration Syntax
C#
protected XmlControl Portal

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Portlets Field

Portlets Field
Namespaces ► Sitecore.Shell.Controls.Portal ► PortalConfiguratorForm ► Portlets
Declaration Syntax
C#
protected GridPanel Portlets

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PortalSidebarForm2 Class

PortalSidebarForm2 Class
Namespaces ► Sitecore.Shell.Controls.Portal ► PortalSidebarForm2
Represents a PortalSidebarForm2.
Declaration Syntax
C#
public class PortalSidebarForm2 : BaseForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PortalSidebarForm2()()() | Initializes a new instance of the PortalSidebarForm2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled | Gets or sets a value indicating whether events are enabled. (Inherited from BaseForm.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from BaseForm.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnLoad(EventArgs) | Raises the load event. (Overrides BaseForm.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the pre render event. (Inherited from BaseForm.)
 | Portal |
 | ServerProperties | Gets the server properties. (Inherited from BaseForm.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | PortalSidebarForm2

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PortalSidebarForm2 Constructor

PortalSidebarForm2 Constructor
Namespaces ► Sitecore.Shell.Controls.Portal ► PortalSidebarForm2 ► PortalSidebarForm2()()()
Initializes a new instance of the PortalSidebarForm2 class
Declaration Syntax
C#
public PortalSidebarForm2()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Portal ► PortalSidebarForm2 ► OnLoad(EventArgs)
Raises the load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs instance containing the event data.
Remarks
This method notifies the server control that it should perform actions common to each HTTP request for the page it is associated with, such as setting up a database query. At this stage in the page lifecycle, server controls in the hierarchy are created and initialized, view state is restored, and form controls reflect client-side data. Use the IsPostBack property to determine whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Portal Field

Portal Field
Namespaces ► Sitecore.Shell.Controls.Portal ► PortalSidebarForm2 ► Portal
Declaration Syntax
C#
protected XmlControl Portal

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PortletWindowXmlControl Class

PortletWindowXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Portal ► PortletWindowXmlControl
Represents a PortletWindowXmlControl.
Declaration Syntax
C#
public class PortletWindowXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PortletWindowXmlControl()()() | Initializes a new instance of the PortletWindowXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddContent()()() | Adds the content.
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click()()() | Clicks this instance.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Close()()() | Closes this instance.
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | Down()()() | Executes the event.
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Menu |
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NextColumn()()() | Nexts the column.
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviousColumn()()() | Previouses the column.
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Up()()() | Ups this instance.
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | PortletWindowXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PortletWindowXmlControl Constructor

PortletWindowXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Portal ► PortletWindowXmlControl ► PortletWindowXmlControl()()()
Initializes a new instance of the PortletWindowXmlControl class
Declaration Syntax
C#
public PortletWindowXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AddContent Method

AddContent Method
Namespaces ► Sitecore.Shell.Controls.Portal ► PortletWindowXmlControl ► AddContent()()()
Adds the content.
Declaration Syntax
C#
protected void AddContent()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Click Method

Click Method
Namespaces ► Sitecore.Shell.Controls.Portal ► PortletWindowXmlControl ► Click()()()
Clicks this instance.
Declaration Syntax
C#
protected void Click()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Close Method

Close Method
Namespaces ► Sitecore.Shell.Controls.Portal ► PortletWindowXmlControl ► Close()()()
Closes this instance.
Declaration Syntax
C#
protected void Close()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Down Method

Down Method
Namespaces ► Sitecore.Shell.Controls.Portal ► PortletWindowXmlControl ► Down()()()
Executes the event.
Declaration Syntax
C#
protected void Down()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Menu Field

Menu Field
Namespaces ► Sitecore.Shell.Controls.Portal ► PortletWindowXmlControl ► Menu
Declaration Syntax
C#
protected ImageButton Menu

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


NextColumn Method

NextColumn Method
Namespaces ► Sitecore.Shell.Controls.Portal ► PortletWindowXmlControl ► NextColumn()()()
Nexts the column.
Declaration Syntax
C#
protected void NextColumn()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Portal ► PortletWindowXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PreviousColumn Method

PreviousColumn Method
Namespaces ► Sitecore.Shell.Controls.Portal ► PortletWindowXmlControl ► PreviousColumn()()()
Previouses the column.
Declaration Syntax
C#
protected void PreviousColumn()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Up Method

Up Method
Namespaces ► Sitecore.Shell.Controls.Portal ► PortletWindowXmlControl ► Up()()()
Ups this instance.
Declaration Syntax
C#
protected void Up()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.RADEditor Namespace

Sitecore.Shell.Controls.RADEditor Namespace
Namespaces ► Sitecore.Shell.Controls.RADEditor
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.RADEditor
Types
All Types Classes
Icon | Type | Description
 | Preview |
 | RADEditor | Represents a RADEditor.


Preview Class

Preview Class
Namespaces ► Sitecore.Shell.Controls.RADEditor ► Preview
Declaration Syntax
C#
public class Preview : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Preview()()() | Initializes a new instance of the Preview class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Content | Content control.
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | DisabledFlag | DisabledFlag control.
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | HelpText | HelpText control.
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitialValue | InitialValue control.
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Page.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageScriptManager | Gets the page script manager. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | Stylesheets | Stylesheets control.
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Page
 |  |  |  |  | Preview

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Preview Constructor

Preview Constructor
Namespaces ► Sitecore.Shell.Controls.RADEditor ► Preview ► Preview()()()
Initializes a new instance of the Preview class
Declaration Syntax
C#
public Preview()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Content Field

Content Field
Namespaces ► Sitecore.Shell.Controls.RADEditor ► Preview ► Content
Content control.
Declaration Syntax
C#
protected PlaceHolder Content
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DisabledFlag Field

DisabledFlag Field
Namespaces ► Sitecore.Shell.Controls.RADEditor ► Preview ► DisabledFlag
DisabledFlag control.
Declaration Syntax
C#
protected PlaceHolder DisabledFlag
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


HelpText Field

HelpText Field
Namespaces ► Sitecore.Shell.Controls.RADEditor ► Preview ► HelpText
HelpText control.
Declaration Syntax
C#
protected PlaceHolder HelpText
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


InitialValue Field

InitialValue Field
Namespaces ► Sitecore.Shell.Controls.RADEditor ► Preview ► InitialValue
InitialValue control.
Declaration Syntax
C#
protected PlaceHolder InitialValue
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.RADEditor ► Preview ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Stylesheets Field

Stylesheets Field
Namespaces ► Sitecore.Shell.Controls.RADEditor ► Preview ► Stylesheets
Stylesheets control.
Declaration Syntax
C#
protected PlaceHolder Stylesheets
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RADEditor Class

RADEditor Class
Namespaces ► Sitecore.Shell.Controls.RADEditor ► RADEditor
Represents a RADEditor.
Declaration Syntax
C#
public class RADEditor : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RADEditor()()() | Initializes a new instance of the RADEditor class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Editor |
 | EditorClientScripts |
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemID |
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | Language |
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) | Handles the Load event of the Page control.
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | RichText | Gets the rich text.
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | SpecificLanguage |
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | RADEditor

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RADEditor Constructor

RADEditor Constructor
Namespaces ► Sitecore.Shell.Controls.RADEditor ► RADEditor ► RADEditor()()()
Initializes a new instance of the RADEditor class
Declaration Syntax
C#
public RADEditor()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Editor Field

Editor Field
Namespaces ► Sitecore.Shell.Controls.RADEditor ► RADEditor ► Editor
Declaration Syntax
C#
protected RadEditor Editor

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


EditorClientScripts Field

EditorClientScripts Field
Namespaces ► Sitecore.Shell.Controls.RADEditor ► RADEditor ► EditorClientScripts
Declaration Syntax
C#
protected PlaceHolder EditorClientScripts

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ItemID Field

ItemID Field
Namespaces ► Sitecore.Shell.Controls.RADEditor ► RADEditor ► ItemID
Declaration Syntax
C#
protected PlaceHolder ItemID

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Language Field

Language Field
Namespaces ► Sitecore.Shell.Controls.RADEditor ► RADEditor ► Language
Declaration Syntax
C#
protected PlaceHolder Language

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore.Shell.Controls.RADEditor ► RADEditor ► Page_Load(Object, EventArgs)
Handles the Load event of the Page control.
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RichText Property

RichText Property
Namespaces ► Sitecore.Shell.Controls.RADEditor ► RADEditor ► RichText
Gets the rich text.
Declaration Syntax
C#
protected RadEditor RichText { get; }
Value
The rich text.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SpecificLanguage Field

SpecificLanguage Field
Namespaces ► Sitecore.Shell.Controls.RADEditor ► RADEditor ► SpecificLanguage
Declaration Syntax
C#
protected PlaceHolder SpecificLanguage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.RichTextEditor Namespace

Sitecore.Shell.Controls.RichTextEditor Namespace
Namespaces ► Sitecore.Shell.Controls.RichTextEditor
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.RichTextEditor
Types
All Types Classes
Icon | Type | Description
 | DBContentProvider | Represents a DBContentProvider.
 | ToolFontNames | Represents a ToolFontNames.
 | ToolFontSizes | Represents a ToolFontSizes.


DBContentProvider Class

DBContentProvider Class
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► DBContentProvider
Represents a DBContentProvider.
Declaration Syntax
C#
public class DBContentProvider : FileBrowserContentProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DBContentProvider(HttpContext, array<String>[]()[], array<String>[]()[], array<String>[]()[], array<String>[]()[], String, String) | Initializes a new instance of the DBContentProvider class.
 | CanCreateDirectory | Gets a value indicating whether this instance can create directory. (Overrides FileBrowserContentProvider.CanCreateDirectory()()().)
 | Context()()() | (Inherited from FileBrowserContentProvider.)
 | CreateDirectory(String, String) | Creates the directory. (Overrides FileBrowserContentProvider.CreateDirectory(String, String).)
 | DeleteDirectory(String) | Deletes the directory. (Overrides FileBrowserContentProvider.DeleteDirectory(String).)
 | DeleteFile(String) | Deletes the file. (Overrides FileBrowserContentProvider.DeleteFile(String).)
 | DeletePaths()()() | (Inherited from FileBrowserContentProvider.)
 | DisplayMode()()() | (Inherited from FileBrowserContentProvider.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFile(String) | Gets the file. (Overrides FileBrowserContentProvider.GetFile(String).)
 | GetFileName(String) | Gets the name of the file. (Overrides FileBrowserContentProvider.GetFileName(String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPath(String) | Gets the path. (Overrides FileBrowserContentProvider.GetPath(String).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveProtocolNameAndServerName(String) | (Inherited from FileBrowserContentProvider.)
 | ResolveDirectory(String) | Resolves the directory. (Overrides FileBrowserContentProvider.ResolveDirectory(String).)
 | ResolveRootDirectoryAsList(String) | Resolves the root directory as list. (Overrides FileBrowserContentProvider.ResolveRootDirectoryAsList(String).)
 | ResolveRootDirectoryAsTree(String) | Loads a root directory with given path, where all subdirectories contained in the SelectedUrl property are loaded (Overrides FileBrowserContentProvider.ResolveRootDirectoryAsTree(String).)
 | SearchPatterns()()() | (Inherited from FileBrowserContentProvider.)
 | SelectedItemTag()()() | (Inherited from FileBrowserContentProvider.)
 | SelectedUrl()()() | (Inherited from FileBrowserContentProvider.)
 | StoreBitmap(Bitmap, String, ImageFormat) | Stores the bitmap. (Overrides FileBrowserContentProvider.StoreBitmap(Bitmap, String, ImageFormat).)
 | StoreFile(HttpPostedFile, String, String, array<String>[]()[]) | Stores the file. (Overrides FileBrowserContentProvider.StoreFile(HttpPostedFile, String, String, array<String>[]()[]).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UploadPaths()()() | (Inherited from FileBrowserContentProvider.)
 | ViewPaths()()() | (Inherited from FileBrowserContentProvider.)
Inheritance Hierarchy
Object
 | FileBrowserContentProvider
 |  | DBContentProvider

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DBContentProvider Constructor (context, searchPatterns, viewPaths, uploadPaths, deletePaths, selectedUrl, selectedItemTag)

DBContentProvider Constructor (context, searchPatterns, viewPaths, uploadPaths, deletePaths, selectedUrl, selectedItemTag)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► DBContentProvider ► DBContentProvider(HttpContext, array<String>[]()[], array<String>[]()[], array<String>[]()[], array<String>[]()[], String, String)
Initializes a new instance of the DBContentProvider class.
Declaration Syntax
C#
public DBContentProvider(
    HttpContext context,
    string[] searchPatterns,
    string[] viewPaths,
    string[] uploadPaths,
    string[] deletePaths,
    string selectedUrl,
    string selectedItemTag
)
Parameters
context (HttpContext)
The context.
searchPatterns (array< String >[]()[])
The search patterns.
viewPaths (array< String >[]()[])
The view paths.
uploadPaths (array< String >[]()[])
The upload paths.
deletePaths (array< String >[]()[])
The delete paths.
selectedUrl (String)
The selected URL.
selectedItemTag (String)
The selected item tag.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CanCreateDirectory Property

CanCreateDirectory Property
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► DBContentProvider ► CanCreateDirectory
Gets a value indicating whether this instance can create directory.
Declaration Syntax
C#
public override bool CanCreateDirectory { get; }
Value
true if this instance can create directory; otherwise, false.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CreateDirectory Method (path, name)

CreateDirectory Method (path, name)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► DBContentProvider ► CreateDirectory(String, String)
Creates the directory.
Declaration Syntax
C#
public override string CreateDirectory(
    string path,
    string name
)
Parameters
path (String)
The path.
name (String)
The name.
Return Value

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DeleteDirectory Method (path)

DeleteDirectory Method (path)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► DBContentProvider ► DeleteDirectory(String)
Deletes the directory.
Declaration Syntax
C#
public override string DeleteDirectory(
    string path
)
Parameters
path (String)
The path.
Return Value

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DeleteFile Method (path)

DeleteFile Method (path)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► DBContentProvider ► DeleteFile(String)
Deletes the file.
Declaration Syntax
C#
public override string DeleteFile(
    string path
)
Parameters
path (String)
The path.
Return Value

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetFile Method (url)

GetFile Method (url)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► DBContentProvider ► GetFile(String)
Gets the file.
Declaration Syntax
C#
public override Stream GetFile(
    string url
)
Parameters
url (String)
The URL.
Return Value

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetFileName Method (url)

GetFileName Method (url)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► DBContentProvider ► GetFileName(String)
Gets the name of the file.
Declaration Syntax
C#
public override string GetFileName(
    string url
)
Parameters
url (String)
The URL.
Return Value

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetPath Method (url)

GetPath Method (url)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► DBContentProvider ► GetPath(String)
Gets the path.
Declaration Syntax
C#
public override string GetPath(
    string url
)
Parameters
url (String)
The URL.
Return Value

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ResolveDirectory Method (path)

ResolveDirectory Method (path)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► DBContentProvider ► ResolveDirectory(String)
Resolves the directory.
Declaration Syntax
C#
public override DirectoryItem ResolveDirectory(
    string path
)
Parameters
path (String)
The path.
Return Value

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ResolveRootDirectoryAsList Method (path)

ResolveRootDirectoryAsList Method (path)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► DBContentProvider ► ResolveRootDirectoryAsList(String)
Resolves the root directory as list.
Declaration Syntax
C#
public override DirectoryItem[] ResolveRootDirectoryAsList(
    string path
)
Parameters
path (String)
The path.
Return Value

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ResolveRootDirectoryAsTree Method (path)

ResolveRootDirectoryAsTree Method (path)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► DBContentProvider ► ResolveRootDirectoryAsTree(String)
Loads a root directory with given path, where all subdirectories contained in the SelectedUrl property are loaded
Declaration Syntax
C#
public override DirectoryItem ResolveRootDirectoryAsTree(
    string path
)
Parameters
path (String)
the root directory path, passed by the FileBrowser
Return Value
The root DirectoryItem or null if such does not exist
Remarks
The ImagesPaths, DocumentsPaths, etc properties of RadEditor allow multiple root items to be specified, separated by comma, e.g. Photos,Paintings,Diagrams. The FileBrowser class calls the ResolveRootDirectoryAsTree method for each of them.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


StoreBitmap Method (bitmap, url, format)

StoreBitmap Method (bitmap, url, format)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► DBContentProvider ► StoreBitmap(Bitmap, String, ImageFormat)
Stores the bitmap.
Declaration Syntax
C#
public override string StoreBitmap(
    Bitmap bitmap,
    string url,
    ImageFormat format
)
Parameters
bitmap (Bitmap)
The bitmap.
url (String)
The URL.
format (ImageFormat)
The format.
Return Value
Exceptions
Exception | Condition
NotImplementedException | StoreBitmap is not implemented.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


StoreFile Method (file, path, name, arguments)

StoreFile Method (file, path, name, arguments)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► DBContentProvider ► StoreFile(HttpPostedFile, String, String, array<String>[]()[])
Stores the file.
Declaration Syntax
C#
public override string StoreFile(
    HttpPostedFile file,
    string path,
    string name,
    params string[] arguments
)
Parameters
file (HttpPostedFile)
The file.
path (String)
The path.
name (String)
The name.
arguments (array< String >[]()[])
The arguments.
Return Value

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ToolFontNames Class

ToolFontNames Class
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► ToolFontNames
Represents a ToolFontNames.
Declaration Syntax
C#
public class ToolFontNames : CustomControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToolFontNames(Item, CommandContext) | Initializes a new instance of the ToolFontNames class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Button | Gets the button. (Inherited from CustomControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommandContext | Gets the command context. (Inherited from CustomControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | CustomControl
 |  |  |  | ToolFontNames

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ToolFontNames Constructor (button, context)

ToolFontNames Constructor (button, context)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► ToolFontNames ► ToolFontNames(Item, CommandContext)
Initializes a new instance of the ToolFontNames class.
Declaration Syntax
C#
public ToolFontNames(
    Item button,
    CommandContext context
)
Parameters
button (Item)
The button.
context (CommandContext)
The context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► ToolFontNames ► Render(HtmlTextWriter)
Renders the control to the specified HTML writer.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the control content.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ToolFontSizes Class

ToolFontSizes Class
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► ToolFontSizes
Represents a ToolFontSizes.
Declaration Syntax
C#
public class ToolFontSizes : CustomControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToolFontSizes(Item, CommandContext) | Initializes a new instance of the ToolFontNames class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Button | Gets the button. (Inherited from CustomControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommandContext | Gets the command context. (Inherited from CustomControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | CustomControl
 |  |  |  | ToolFontSizes

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ToolFontSizes Constructor (button, context)

ToolFontSizes Constructor (button, context)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► ToolFontSizes ► ToolFontSizes(Item, CommandContext)
Initializes a new instance of the ToolFontNames class.
Declaration Syntax
C#
public ToolFontSizes(
    Item button,
    CommandContext context
)
Parameters
button (Item)
The button.
context (CommandContext)
The context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor ► ToolFontSizes ► Render(HtmlTextWriter)
Renders the control to the specified HTML writer.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the control content.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.RichTextEditor.InsertImage Namespace

Sitecore.Shell.Controls.RichTextEditor.InsertImage Namespace
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.RichTextEditor.InsertImage
Types
All Types Classes
Icon | Type | Description
 | InsertImageForm | Represents a Insert Image Form.


InsertImageForm Class

InsertImageForm Class
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage ► InsertImageForm
Represents a Insert Image Form.
Declaration Syntax
C#
public class InsertImageForm : DialogForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InsertImageForm()()() | Initializes a new instance of the InsertImageForm class
 | Cancel | (Inherited from DialogForm.)
 | DataContext |
 | Edit()()() | Edits this instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled | Gets or sets a value indicating whether events are enabled. (Inherited from BaseForm.)
 | Filename |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Overrides BaseForm.HandleMessage(Message).)
 | Listview |
 | Listview_Click(String) | Handles the Listview click event.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Mode | Gets or sets the mode.
 | OK | (Inherited from DialogForm.)
 | OnCancel(Object, EventArgs) | Handles a click on the Cancel button. (Inherited from DialogForm.)
 | OnLoad(EventArgs) | Raises the load event. (Overrides DialogForm.OnLoad(EventArgs).)
 | OnOK(Object, EventArgs) | Handles a click on the OK button. (Overrides DialogForm.OnOK(Object, EventArgs).)
 | OnPreRender(EventArgs) | Raises the pre render event. (Inherited from BaseForm.)
 | SelectTreeNode()()() | Selects the tree node.
 | ServerProperties | Gets the server properties. (Inherited from BaseForm.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Treeview |
 | Upload |
Inheritance Hierarchy
Object
 | BaseForm
 |  | DialogForm
 |  |  | InsertImageForm

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


InsertImageForm Constructor

InsertImageForm Constructor
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage ► InsertImageForm ► InsertImageForm()()()
Initializes a new instance of the InsertImageForm class
Declaration Syntax
C#
public InsertImageForm()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DataContext Field

DataContext Field
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage ► InsertImageForm ► DataContext
Declaration Syntax
C#
protected DataContext DataContext

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Edit Method

Edit Method
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage ► InsertImageForm ► Edit()()()
Edits this instance.
Declaration Syntax
C#
protected void Edit()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Filename Field

Filename Field
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage ► InsertImageForm ► Filename
Declaration Syntax
C#
protected Edit Filename

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage ► InsertImageForm ► HandleMessage(Message)
Handles the message.
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)
The message.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Listview Field

Listview Field
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage ► InsertImageForm ► Listview
Declaration Syntax
C#
protected Scrollbox Listview

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Listview_Click Method (id)

Listview_Click Method (id)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage ► InsertImageForm ► Listview_Click(String)
Handles the Listview click event.
Declaration Syntax
C#
protected void Listview_Click(
    string id
)
Parameters
id (String)
The id.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Mode Property

Mode Property
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage ► InsertImageForm ► Mode
Gets or sets the mode.
Declaration Syntax
C#
protected string Mode { get; set; }
Value
The mode.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage ► InsertImageForm ► OnLoad(EventArgs)
Raises the load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs instance containing the event data.
Remarks
This method notifies the server control that it should perform actions common to each HTTP request for the page it is associated with, such as setting up a database query. At this stage in the page lifecycle, server controls in the hierarchy are created and initialized, view state is restored, and form controls reflect client-side data. Use the IsPostBack property to determine whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnOK Method (sender, args)

OnOK Method (sender, args)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage ► InsertImageForm ► OnOK(Object, EventArgs)
Handles a click on the OK button.
Declaration Syntax
C#
protected override void OnOK(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
args (EventArgs)
Remarks
When the user clicks OK, the dialog is closed by calling the CloseWindow method.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SelectTreeNode Method

SelectTreeNode Method
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage ► InsertImageForm ► SelectTreeNode()()()
Selects the tree node.
Declaration Syntax
C#
protected void SelectTreeNode()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Treeview Field

Treeview Field
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage ► InsertImageForm ► Treeview
Declaration Syntax
C#
protected TreeviewEx Treeview

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Upload Field

Upload Field
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertImage ► InsertImageForm ► Upload
Declaration Syntax
C#
protected Button Upload

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.RichTextEditor.InsertLink Namespace

Sitecore.Shell.Controls.RichTextEditor.InsertLink Namespace
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertLink
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.RichTextEditor.InsertLink
Types
All Types Classes
Icon | Type | Description
 | InsertLinkForm | Represents a InsertLinkForm.


InsertLinkForm Class

InsertLinkForm Class
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertLink ► InsertLinkForm
Represents a InsertLinkForm.
Declaration Syntax
C#
public class InsertLinkForm : DialogForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InsertLinkForm()()() | Initializes a new instance of the InsertLinkForm class
 | Cancel | (Inherited from DialogForm.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled | Gets or sets a value indicating whether events are enabled. (Inherited from BaseForm.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Overrides BaseForm.HandleMessage(Message).)
 | InternalLinkDataContext |
 | InternalLinkTab |
 | InternalLinkTreeview |
 | MediaDataContext |
 | MediaTab |
 | MediaTreeview |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Mode | Gets or sets the mode.
 | OK | (Inherited from DialogForm.)
 | OnCancel(Object, EventArgs) | Handles a click on the Cancel button. (Inherited from DialogForm.)
 | OnLoad(EventArgs) | Raises the load event. (Overrides DialogForm.OnLoad(EventArgs).)
 | OnOK(Object, EventArgs) | Handles a click on the OK button. (Overrides DialogForm.OnOK(Object, EventArgs).)
 | OnPreRender(EventArgs) | Raises the pre render event. (Inherited from BaseForm.)
 | ServerProperties | Gets the server properties. (Inherited from BaseForm.)
 | Tabs |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | DialogForm
 |  |  | InsertLinkForm

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


InsertLinkForm Constructor

InsertLinkForm Constructor
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertLink ► InsertLinkForm ► InsertLinkForm()()()
Initializes a new instance of the InsertLinkForm class
Declaration Syntax
C#
public InsertLinkForm()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertLink ► InsertLinkForm ► HandleMessage(Message)
Handles the message.
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)
The message.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


InternalLinkDataContext Field

InternalLinkDataContext Field
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertLink ► InsertLinkForm ► InternalLinkDataContext
Declaration Syntax
C#
protected DataContext InternalLinkDataContext

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


InternalLinkTab Field

InternalLinkTab Field
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertLink ► InsertLinkForm ► InternalLinkTab
Declaration Syntax
C#
protected Tab InternalLinkTab

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


InternalLinkTreeview Field

InternalLinkTreeview Field
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertLink ► InsertLinkForm ► InternalLinkTreeview
Declaration Syntax
C#
protected TreeviewEx InternalLinkTreeview

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


MediaDataContext Field

MediaDataContext Field
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertLink ► InsertLinkForm ► MediaDataContext
Declaration Syntax
C#
protected DataContext MediaDataContext

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


MediaTab Field

MediaTab Field
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertLink ► InsertLinkForm ► MediaTab
Declaration Syntax
C#
protected Tab MediaTab

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


MediaTreeview Field

MediaTreeview Field
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertLink ► InsertLinkForm ► MediaTreeview
Declaration Syntax
C#
protected TreeviewEx MediaTreeview

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Mode Property

Mode Property
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertLink ► InsertLinkForm ► Mode
Gets or sets the mode.
Declaration Syntax
C#
protected string Mode { get; set; }
Value
The mode.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertLink ► InsertLinkForm ► OnLoad(EventArgs)
Raises the load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs instance containing the event data.
Remarks
This method notifies the server control that it should perform actions common to each HTTP request for the page it is associated with, such as setting up a database query. At this stage in the page lifecycle, server controls in the hierarchy are created and initialized, view state is restored, and form controls reflect client-side data. Use the IsPostBack property to determine whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnOK Method (sender, args)

OnOK Method (sender, args)
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertLink ► InsertLinkForm ► OnOK(Object, EventArgs)
Handles a click on the OK button.
Declaration Syntax
C#
protected override void OnOK(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
args (EventArgs)
Remarks
When the user clicks OK, the dialog is closed by calling the CloseWindow method.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Tabs Field

Tabs Field
Namespaces ► Sitecore.Shell.Controls.RichTextEditor.InsertLink ► InsertLinkForm ► Tabs
Declaration Syntax
C#
protected Tabstrip Tabs

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.Sidebar Namespace

Sitecore.Shell.Controls.Sidebar Namespace
Namespaces ► Sitecore.Shell.Controls.Sidebar
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.Sidebar
Types
All Types Classes
Icon | Type | Description
 | SidebarContentEditorSectionsXmlControl | Represents a SidebarContentEditorSectionsXmlControl.
 | SidebarContentEditorViewersXmlControl | Represents a SidebarContentEditorViewersXmlControl.


SidebarContentEditorSectionsXmlControl Class

SidebarContentEditorSectionsXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorSectionsXmlControl
Represents a SidebarContentEditorSectionsXmlControl.
Declaration Syntax
C#
public class SidebarContentEditorSectionsXmlControl : XmlControl,
    IComparer
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SidebarContentEditorSectionsXmlControl()()() | Initializes a new instance of the SidebarContentEditorSectionsXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context.
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus(String) | Focuses the specified id.
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Hidden | Gets or sets a value indicating whether this SidebarContentEditorSectionsXmlControl is hidden.
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Sections |
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TileHeader |
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | SidebarContentEditorSectionsXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SidebarContentEditorSectionsXmlControl Constructor

SidebarContentEditorSectionsXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorSectionsXmlControl ► SidebarContentEditorSectionsXmlControl()()()
Initializes a new instance of the SidebarContentEditorSectionsXmlControl class
Declaration Syntax
C#
public SidebarContentEditorSectionsXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Compare Method (x, y)

Compare Method (x, y)
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorSectionsXmlControl ► Compare(Object, Object)
Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Declaration Syntax
C#
public int Compare(
    Object x,
    Object y
)
Parameters
x (Object)
The first object to compare.
y (Object)
The second object to compare.
Return Value
Value Condition Less than zero x is less than y. Zero x equals y. Greater than zero x is greater than y.
Exceptions
Exception | Condition
ArgumentException | Neither x nor y implements the IComparable interface.-or- x and y are of different types and neither one can handle comparisons with the other.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DataContext Property

DataContext Property
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorSectionsXmlControl ► DataContext
Gets or sets the data context.
Declaration Syntax
C#
public string DataContext { get; set; }
Value
The data context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Focus Method (id)

Focus Method (id)
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorSectionsXmlControl ► Focus(String)
Focuses the specified id.
Declaration Syntax
C#
protected void Focus(
    string id
)
Parameters
id (String)
The id.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Header Property

Header Property
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorSectionsXmlControl ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Hidden Property

Hidden Property
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorSectionsXmlControl ► Hidden
Gets or sets a value indicating whether this SidebarContentEditorSectionsXmlControl is hidden.
Declaration Syntax
C#
public bool Hidden { get; set; }
Value
true if hidden; otherwise, false.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorSectionsXmlControl ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorSectionsXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sections Field

Sections Field
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorSectionsXmlControl ► Sections
Declaration Syntax
C#
protected XmlControl Sections

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TileHeader Field

TileHeader Field
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorSectionsXmlControl ► TileHeader
Declaration Syntax
C#
protected XmlControl TileHeader

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SidebarContentEditorViewersXmlControl Class

SidebarContentEditorViewersXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorViewersXmlControl
Represents a SidebarContentEditorViewersXmlControl.
Declaration Syntax
C#
public class SidebarContentEditorViewersXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SidebarContentEditorViewersXmlControl()()() | Initializes a new instance of the SidebarContentEditorViewersXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context.
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | Viewers |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | SidebarContentEditorViewersXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SidebarContentEditorViewersXmlControl Constructor

SidebarContentEditorViewersXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorViewersXmlControl ► SidebarContentEditorViewersXmlControl()()()
Initializes a new instance of the SidebarContentEditorViewersXmlControl class
Declaration Syntax
C#
public SidebarContentEditorViewersXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DataContext Property

DataContext Property
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorViewersXmlControl ► DataContext
Gets or sets the data context.
Declaration Syntax
C#
public string DataContext { get; set; }
Value
The data context.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorViewersXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Viewers Field

Viewers Field
Namespaces ► Sitecore.Shell.Controls.Sidebar ► SidebarContentEditorViewersXmlControl ► Viewers
Declaration Syntax
C#
protected XmlControl Viewers

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.Splitters Namespace

Sitecore.Shell.Controls.Splitters Namespace
Namespaces ► Sitecore.Shell.Controls.Splitters
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.Splitters
Types
All Types Classes
Icon | Type | Description
 | HSplitterXmlControl | Represents a HSplitterXmlControl.
 | VSplitterXmlControl | Represents a VSplitterXmlControl.


HSplitterXmlControl Class

HSplitterXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Splitters ► HSplitterXmlControl
Represents a HSplitterXmlControl.
Declaration Syntax
C#
public class HSplitterXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HSplitterXmlControl()()() | Initializes a new instance of the HSplitterXmlControl class.
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Image |
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the Load event. (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | Release(String, String) | Releases the specified top.
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | Target | Gets or sets the target.
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | HSplitterXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


HSplitterXmlControl Constructor

HSplitterXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Splitters ► HSplitterXmlControl ► HSplitterXmlControl()()()
Initializes a new instance of the HSplitterXmlControl class.
Declaration Syntax
C#
public HSplitterXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Image Field

Image Field
Namespaces ► Sitecore.Shell.Controls.Splitters ► HSplitterXmlControl ► Image
Declaration Syntax
C#
protected Image Image

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Shell.Controls.Splitters ► HSplitterXmlControl ► OnPreRender(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Release Method (top, bottom)

Release Method (top, bottom)
Namespaces ► Sitecore.Shell.Controls.Splitters ► HSplitterXmlControl ► Release(String, String)
Releases the specified top.
Declaration Syntax
C#
protected void Release(
    string top,
    string bottom
)
Parameters
top (String)
The top.
bottom (String)
The bottom.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Target Property

Target Property
Namespaces ► Sitecore.Shell.Controls.Splitters ► HSplitterXmlControl ► Target
Gets or sets the target.
Declaration Syntax
C#
public string Target { get; set; }
Value
The target.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


VSplitterXmlControl Class

VSplitterXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Splitters ► VSplitterXmlControl
Represents a VSplitterXmlControl.
Declaration Syntax
C#
public class VSplitterXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VSplitterXmlControl()()() | Initializes a new instance of the VSplitterXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Image |
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | Release(String, String) | Releases the specified left.
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | Target | Gets or sets the target.
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | VSplitterXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


VSplitterXmlControl Constructor

VSplitterXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Splitters ► VSplitterXmlControl ► VSplitterXmlControl()()()
Initializes a new instance of the VSplitterXmlControl class
Declaration Syntax
C#
public VSplitterXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Image Field

Image Field
Namespaces ► Sitecore.Shell.Controls.Splitters ► VSplitterXmlControl ► Image
Declaration Syntax
C#
protected Image Image

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Splitters ► VSplitterXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Release Method (left, right)

Release Method (left, right)
Namespaces ► Sitecore.Shell.Controls.Splitters ► VSplitterXmlControl ► Release(String, String)
Releases the specified left.
Declaration Syntax
C#
protected void Release(
    string left,
    string right
)
Parameters
left (String)
The left.
right (String)
The right.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Target Property

Target Property
Namespaces ► Sitecore.Shell.Controls.Splitters ► VSplitterXmlControl ► Target
Gets or sets the target.
Declaration Syntax
C#
public string Target { get; set; }
Value
The target.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.Standard Namespace

Sitecore.Shell.Controls.Standard Namespace
Namespaces ► Sitecore.Shell.Controls.Standard
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.Standard
Types
All Types Classes
Icon | Type | Description
 | FormPageXmlControl | Represents a FormPageXmlControl.


FormPageXmlControl Class

FormPageXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Standard ► FormPageXmlControl
Represents a FormPageXmlControl.
Declaration Syntax
C#
public class FormPageXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FormPageXmlControl()()() | Initializes a new instance of the FormPageXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | Application | Gets or sets the application.
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style.
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Body |
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | Enctype | Gets or sets the enctype.
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | Form |
 | FormTarget | Gets or sets the form target.
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnLoadEvent | Gets or sets the on load event.
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Overflow | Gets or sets a value indicating whether this FormPageXmlControl is overflow.
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Scroll | Gets or sets the scroll.
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | Submittable | Gets or sets a value indicating whether this FormPageXmlControl is submittable.
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | FormPageXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


FormPageXmlControl Constructor

FormPageXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Standard ► FormPageXmlControl ► FormPageXmlControl()()()
Initializes a new instance of the FormPageXmlControl class
Declaration Syntax
C#
public FormPageXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Application Property

Application Property
Namespaces ► Sitecore.Shell.Controls.Standard ► FormPageXmlControl ► Application
Gets or sets the application.
Declaration Syntax
C#
public string Application { get; set; }
Value
The application.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Background Property

Background Property
Namespaces ► Sitecore.Shell.Controls.Standard ► FormPageXmlControl ► Background
Gets or sets the background style.
Declaration Syntax
C#
public string Background { get; set; }
Value
The background.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Body Field

Body Field
Namespaces ► Sitecore.Shell.Controls.Standard ► FormPageXmlControl ► Body
Declaration Syntax
C#
protected Control Body

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Enctype Property

Enctype Property
Namespaces ► Sitecore.Shell.Controls.Standard ► FormPageXmlControl ► Enctype
Gets or sets the enctype.
Declaration Syntax
C#
public string Enctype { get; set; }
Value
The enctype.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Form Field

Form Field
Namespaces ► Sitecore.Shell.Controls.Standard ► FormPageXmlControl ► Form
Declaration Syntax
C#
protected Control Form

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


FormTarget Property

FormTarget Property
Namespaces ► Sitecore.Shell.Controls.Standard ► FormPageXmlControl ► FormTarget
Gets or sets the form target.
Declaration Syntax
C#
public string FormTarget { get; set; }
Value
The form target.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Standard ► FormPageXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoadEvent Property

OnLoadEvent Property
Namespaces ► Sitecore.Shell.Controls.Standard ► FormPageXmlControl ► OnLoadEvent
Gets or sets the on load event.
Declaration Syntax
C#
public string OnLoadEvent { get; set; }
Value
The on load event.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Overflow Property

Overflow Property
Namespaces ► Sitecore.Shell.Controls.Standard ► FormPageXmlControl ► Overflow
Gets or sets a value indicating whether this FormPageXmlControl is overflow.
Declaration Syntax
C#
public bool Overflow { get; set; }
Value
true if overflow; otherwise, false.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Scroll Property

Scroll Property
Namespaces ► Sitecore.Shell.Controls.Standard ► FormPageXmlControl ► Scroll
Gets or sets the scroll.
Declaration Syntax
C#
public string Scroll { get; set; }
Value
The scroll.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Submittable Property

Submittable Property
Namespaces ► Sitecore.Shell.Controls.Standard ► FormPageXmlControl ► Submittable
Gets or sets a value indicating whether this FormPageXmlControl is submittable.
Declaration Syntax
C#
public bool Submittable { get; set; }
Value
true if submittable; otherwise, false.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.Tasks Namespace

Sitecore.Shell.Controls.Tasks Namespace
Namespaces ► Sitecore.Shell.Controls.Tasks
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.Tasks
Types
All Types Classes
Icon | Type | Description
 | TaskWhatDoYoWantToDoXmlControl |


TaskWhatDoYoWantToDoXmlControl Class

TaskWhatDoYoWantToDoXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Tasks ► TaskWhatDoYoWantToDoXmlControl
Declaration Syntax
C#
public class TaskWhatDoYoWantToDoXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskWhatDoYoWantToDoXmlControl()()() | Initializes a new instance of the TaskWhatDoYoWantToDoXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | TaskWhatDoYoWantToDoXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TaskWhatDoYoWantToDoXmlControl Constructor

TaskWhatDoYoWantToDoXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Tasks ► TaskWhatDoYoWantToDoXmlControl ► TaskWhatDoYoWantToDoXmlControl()()()
Initializes a new instance of the TaskWhatDoYoWantToDoXmlControl class
Declaration Syntax
C#
public TaskWhatDoYoWantToDoXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Tasks ► TaskWhatDoYoWantToDoXmlControl ► OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.Toolbars Namespace

Sitecore.Shell.Controls.Toolbars Namespace
Namespaces ► Sitecore.Shell.Controls.Toolbars
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.Toolbars
Types
All Types Classes
Icon | Type | Description
 | ToolTasksXmlControl | Represents a ToolTasksXmlControl.


ToolTasksXmlControl Class

ToolTasksXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Toolbars ► ToolTasksXmlControl
Represents a ToolTasksXmlControl.
Declaration Syntax
C#
public class ToolTasksXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToolTasksXmlControl()()() | Initializes a new instance of the ToolTasksXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Options |
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | ToolTasksXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ToolTasksXmlControl Constructor

ToolTasksXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Toolbars ► ToolTasksXmlControl ► ToolTasksXmlControl()()()
Initializes a new instance of the ToolTasksXmlControl class
Declaration Syntax
C#
public ToolTasksXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Toolbars ► ToolTasksXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Options Field

Options Field
Namespaces ► Sitecore.Shell.Controls.Toolbars ► ToolTasksXmlControl ► Options
Declaration Syntax
C#
protected GridPanel Options

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.TreeviewEx Namespace

Sitecore.Shell.Controls.TreeviewEx Namespace
Namespaces ► Sitecore.Shell.Controls.TreeviewEx
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.TreeviewEx
Types
All Types Classes
Icon | Type | Description
 | TreeviewExPage |


TreeviewExPage Class

TreeviewExPage Class
Namespaces ► Sitecore.Shell.Controls.TreeviewEx ► TreeviewExPage
Declaration Syntax
C#
public class TreeviewExPage : Page
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TreeviewExPage()()() | Initializes a new instance of the TreeviewExPage class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) | Handles the Load event of the Page control.
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | TreeviewExPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TreeviewExPage Constructor

TreeviewExPage Constructor
Namespaces ► Sitecore.Shell.Controls.TreeviewEx ► TreeviewExPage ► TreeviewExPage()()()
Initializes a new instance of the TreeviewExPage class
Declaration Syntax
C#
public TreeviewExPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore.Shell.Controls.TreeviewEx ► TreeviewExPage ► Page_Load(Object, EventArgs)
Handles the Load event of the Page control.
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Controls.Windows Namespace

Sitecore.Shell.Controls.Windows Namespace
Namespaces ► Sitecore.Shell.Controls.Windows
Declaration Syntax
C#
namespace Sitecore.Shell.Controls.Windows
Types
All Types Classes
Icon | Type | Description
 | PopupChromeXmlControl |
 | StandardWindowButtonsXmlControl | Represents a StandardWindowButtonsXmlControl.
 | ToolWindowChromeXmlControl | Represents a ToolWindowChromeXmlControl.
 | WindowChromeXmlControl | Represents a WindowChromeXmlControl.


PopupChromeXmlControl Class

PopupChromeXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Windows ► PopupChromeXmlControl
Declaration Syntax
C#
public class PopupChromeXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PopupChromeXmlControl()()() | Initializes a new instance of the PopupChromeXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | PopupChromeXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


PopupChromeXmlControl Constructor

PopupChromeXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Windows ► PopupChromeXmlControl ► PopupChromeXmlControl()()()
Initializes a new instance of the PopupChromeXmlControl class
Declaration Syntax
C#
public PopupChromeXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


StandardWindowButtonsXmlControl Class

StandardWindowButtonsXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Windows ► StandardWindowButtonsXmlControl
Represents a StandardWindowButtonsXmlControl.
Declaration Syntax
C#
public class StandardWindowButtonsXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StandardWindowButtonsXmlControl()()() | Initializes a new instance of the StandardWindowButtonsXmlControl class.
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Close | Gets or sets the close.
 | CloseButton |
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | Maximize | Gets or sets the maximize.
 | MaximizeButton |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | Minimize | Gets or sets the minimize.
 | MinimizeButton |
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | StandardWindowButtonsXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


StandardWindowButtonsXmlControl Constructor

StandardWindowButtonsXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Windows ► StandardWindowButtonsXmlControl ► StandardWindowButtonsXmlControl()()()
Initializes a new instance of the StandardWindowButtonsXmlControl class.
Declaration Syntax
C#
public StandardWindowButtonsXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Close Property

Close Property
Namespaces ► Sitecore.Shell.Controls.Windows ► StandardWindowButtonsXmlControl ► Close
Gets or sets the close.
Declaration Syntax
C#
public string Close { get; set; }
Value
The close.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CloseButton Field

CloseButton Field
Namespaces ► Sitecore.Shell.Controls.Windows ► StandardWindowButtonsXmlControl ► CloseButton
Declaration Syntax
C#
protected XmlControl CloseButton

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Maximize Property

Maximize Property
Namespaces ► Sitecore.Shell.Controls.Windows ► StandardWindowButtonsXmlControl ► Maximize
Gets or sets the maximize.
Declaration Syntax
C#
public string Maximize { get; set; }
Value
The maximize.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


MaximizeButton Field

MaximizeButton Field
Namespaces ► Sitecore.Shell.Controls.Windows ► StandardWindowButtonsXmlControl ► MaximizeButton
Declaration Syntax
C#
protected XmlControl MaximizeButton

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Minimize Property

Minimize Property
Namespaces ► Sitecore.Shell.Controls.Windows ► StandardWindowButtonsXmlControl ► Minimize
Gets or sets the minimize.
Declaration Syntax
C#
public string Minimize { get; set; }
Value
The minimize.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


MinimizeButton Field

MinimizeButton Field
Namespaces ► Sitecore.Shell.Controls.Windows ► StandardWindowButtonsXmlControl ► MinimizeButton
Declaration Syntax
C#
protected XmlControl MinimizeButton

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Windows ► StandardWindowButtonsXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ToolWindowChromeXmlControl Class

ToolWindowChromeXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Windows ► ToolWindowChromeXmlControl
Represents a ToolWindowChromeXmlControl.
Declaration Syntax
C#
public class ToolWindowChromeXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToolWindowChromeXmlControl()()() | Initializes a new instance of the ToolWindowChromeXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Caption |
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Close | Gets or sets the close.
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | Maximize | Gets or sets the maximize.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | Minimize | Gets or sets the minimize.
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | Resize | Gets or sets the resize.
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | WindowHandle |
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | ToolWindowChromeXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ToolWindowChromeXmlControl Constructor

ToolWindowChromeXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Windows ► ToolWindowChromeXmlControl ► ToolWindowChromeXmlControl()()()
Initializes a new instance of the ToolWindowChromeXmlControl class
Declaration Syntax
C#
public ToolWindowChromeXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Caption Field

Caption Field
Namespaces ► Sitecore.Shell.Controls.Windows ► ToolWindowChromeXmlControl ► Caption
Declaration Syntax
C#
protected XmlControl Caption

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Close Property

Close Property
Namespaces ► Sitecore.Shell.Controls.Windows ► ToolWindowChromeXmlControl ► Close
Gets or sets the close.
Declaration Syntax
C#
public string Close { get; set; }
Value
The close.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Maximize Property

Maximize Property
Namespaces ► Sitecore.Shell.Controls.Windows ► ToolWindowChromeXmlControl ► Maximize
Gets or sets the maximize.
Declaration Syntax
C#
public string Maximize { get; set; }
Value
The maximize.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Minimize Property

Minimize Property
Namespaces ► Sitecore.Shell.Controls.Windows ► ToolWindowChromeXmlControl ► Minimize
Gets or sets the minimize.
Declaration Syntax
C#
public string Minimize { get; set; }
Value
The minimize.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Windows ► ToolWindowChromeXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Resize Property

Resize Property
Namespaces ► Sitecore.Shell.Controls.Windows ► ToolWindowChromeXmlControl ► Resize
Gets or sets the resize.
Declaration Syntax
C#
public string Resize { get; set; }
Value
The resize.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


WindowHandle Field

WindowHandle Field
Namespaces ► Sitecore.Shell.Controls.Windows ► ToolWindowChromeXmlControl ► WindowHandle
Declaration Syntax
C#
protected GridPanel WindowHandle

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


WindowChromeXmlControl Class

WindowChromeXmlControl Class
Namespaces ► Sitecore.Shell.Controls.Windows ► WindowChromeXmlControl
Represents a WindowChromeXmlControl.
Declaration Syntax
C#
public class WindowChromeXmlControl : XmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WindowChromeXmlControl()()() | Initializes a new instance of the WindowChromeXmlControl class
 | _ControlName | Gets or sets the name of the control. (Inherited from XmlControl.)
 | _Mode | Gets or sets the mode. (Inherited from XmlControl.)
 | _NamespacePrefix | Gets or sets the namespace prefix. (Inherited from XmlControl.)
 | _Placeholders | Gets the placeholders. (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | Adds the attribute subscriber. (Inherited from XmlControl.)
 | AddControl(Control) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, String) | Adds the control. (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()[]) | Adds the control. (Inherited from XmlControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()[]) | Adds the generic control. (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()[]) | Adds the literal control. (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()[]) | Adds the placeholder. (Inherited from XmlControl.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | Called when the Attributes are changed. (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Caption |
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Close | Gets or sets the close.
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from XmlControl.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetPlaceholders()()() | Gets the placeholders. (Inherited from XmlControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | Handles the message. (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | References to the id; (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()()() | Initializes this instance. (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item[([(String])]) | Gets or sets the Object with the specified name. (Inherited from XmlControl.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | Maximize | Gets or sets the maximize.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | Minimize | Gets or sets the minimize.
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | qs(String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | qs(String, String) | Gets the QueryString parameter. (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | Resize | Gets or sets the resize.
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | Sets the attribute. (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperties(Control, array<String>[]()[]) | Sets the extensible properties. (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | Sets the property. (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | Sets the style. (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateIDRefs()()() | Updates the ID refs. (Inherited from XmlControl.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | WindowHandle |
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | WindowChromeXmlControl

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


WindowChromeXmlControl Constructor

WindowChromeXmlControl Constructor
Namespaces ► Sitecore.Shell.Controls.Windows ► WindowChromeXmlControl ► WindowChromeXmlControl()()()
Initializes a new instance of the WindowChromeXmlControl class
Declaration Syntax
C#
public WindowChromeXmlControl()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Caption Field

Caption Field
Namespaces ► Sitecore.Shell.Controls.Windows ► WindowChromeXmlControl ► Caption
Declaration Syntax
C#
protected XmlControl Caption

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Close Property

Close Property
Namespaces ► Sitecore.Shell.Controls.Windows ► WindowChromeXmlControl ► Close
Gets or sets the close.
Declaration Syntax
C#
public string Close { get; set; }
Value
The close.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Maximize Property

Maximize Property
Namespaces ► Sitecore.Shell.Controls.Windows ► WindowChromeXmlControl ► Maximize
Gets or sets the maximize.
Declaration Syntax
C#
public string Maximize { get; set; }
Value
The maximize.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Minimize Property

Minimize Property
Namespaces ► Sitecore.Shell.Controls.Windows ► WindowChromeXmlControl ► Minimize
Gets or sets the minimize.
Declaration Syntax
C#
public string Minimize { get; set; }
Value
The minimize.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Controls.Windows ► WindowChromeXmlControl ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Resize Property

Resize Property
Namespaces ► Sitecore.Shell.Controls.Windows ► WindowChromeXmlControl ► Resize
Gets or sets the resize.
Declaration Syntax
C#
public string Resize { get; set; }
Value
The resize.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


WindowHandle Field

WindowHandle Field
Namespaces ► Sitecore.Shell.Controls.Windows ► WindowChromeXmlControl ► WindowHandle
Declaration Syntax
C#
protected GridPanel WindowHandle

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Data Namespace

Sitecore.Shell.Data Namespace
Namespaces ► Sitecore.Shell.Data
Declaration Syntax
C#
namespace Sitecore.Shell.Data
Types
All Types Classes
Icon | Type | Description
 | RootSections | Finds the root section of an item.


RootSections Class

RootSections Class
Namespaces ► Sitecore.Shell.Data ► RootSections
Finds the root section of an item.
Declaration Syntax
C#
public class RootSections
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RootSections()()() | Initializes a new instance of the RootSections class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSection(Item) | Gets the section.
 | GetSectionID(ItemUri) | Gets the section ID.
 | GetSectionID(String) | Gets the section ID.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RootSectionPath | Path to the defined sections.
 | Sections | Obsolete. Gets the sections.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RootSections


RootSections Constructor

RootSections Constructor
Namespaces ► Sitecore.Shell.Data ► RootSections ► RootSections()()()
Initializes a new instance of the RootSections class
Declaration Syntax
C#
public RootSections()


GetSection Method (item)

GetSection Method (item)
Namespaces ► Sitecore.Shell.Data ► RootSections ► GetSection(Item)
Gets the section.
Declaration Syntax
C#
public static string GetSection(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetSectionID Method

GetSectionID Method
Namespaces ► Sitecore.Shell.Data ► RootSections ► GetSectionID()()()
Members
Icon | Member | Description
 | GetSectionID(ItemUri) | Gets the section ID.
 | GetSectionID(String) | Gets the section ID.


GetSectionID Method (uri)

GetSectionID Method (uri)
Namespaces ► Sitecore.Shell.Data ► RootSections ► GetSectionID(ItemUri)
Gets the section ID.
Declaration Syntax
C#
public static string GetSectionID(
    ItemUri uri
)
Parameters
uri (ItemUri)
The URI.
Return Value


GetSectionID Method (id)

GetSectionID Method (id)
Namespaces ► Sitecore.Shell.Data ► RootSections ► GetSectionID(String)
Gets the section ID.
Declaration Syntax
C#
public static string GetSectionID(
    string id
)
Parameters
id (String)
The id.
Return Value


RootSectionPath Field

RootSectionPath Field
Namespaces ► Sitecore.Shell.Data ► RootSections ► RootSectionPath
Path to the defined sections.
Declaration Syntax
C#
public const string RootSectionPath


Sections Property

Sections Property
Namespaces ► Sitecore.Shell.Data ► RootSections ► Sections
Gets the sections.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public static Item[] Sections { get; }
Value
The sections.


Sitecore.Shell.Framework Namespace

Sitecore.Shell.Framework Namespace
Namespaces ► Sitecore.Shell.Framework
Declaration Syntax
C#
namespace Sitecore.Shell.Framework
Types
All Types Classes Enumerations
Icon | Type | Description
 | CloseMethod | Defines how close window is done.
 | Codebehind |
 | ContextMenu | Represents a Context Menu.
 | Dialogs | Provides utility methods for working with dialogs.
 | Dispatcher |
 | Files | Provides utility functions for working with files.
 | History | Represents a history of visited items.
 | Items |
 | Preferences | Defines and API for working with preferences.
 | Security | Defines the utility functions for working with security.
 | Sorting |
 | Templates | Defines utility functions for working with templates.
 | UrlOptionsBase<(Of <(T>)>) | Represents URL options.
 | UserHistory | Represents a history of visited items.
 | Windows | Defines utility functions for working with windows.


CloseMethod Enumeration

CloseMethod Enumeration
Namespaces ► Sitecore.Shell.Framework ► CloseMethod
Defines how close window is done.
Declaration Syntax
C#
public enum CloseMethod
Members
Member | Description
CloseWindow | Close window.
Logout | Logout.


Codebehind Class

Codebehind Class
Namespaces ► Sitecore.Shell.Framework ► Codebehind
Declaration Syntax
C#
public class Codebehind
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Codebehind(String) | Initializes a new instance of the Codebehind class.
 | Create()()() | Creates this instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(String, Boolean) | Runs the processor.
 | Process(String, Boolean, String%) | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Codebehind


Codebehind Constructor (filename)

Codebehind Constructor (filename)
Namespaces ► Sitecore.Shell.Framework ► Codebehind ► Codebehind(String)
Initializes a new instance of the Codebehind class.
Declaration Syntax
C#
public Codebehind(
    string filename
)
Parameters
filename (String)
The filename.


Create Method

Create Method
Namespaces ► Sitecore.Shell.Framework ► Codebehind ► Create()()()
Creates this instance.
Declaration Syntax
C#
public string Create()
Return Value
The create.


Process Method

Process Method
Namespaces ► Sitecore.Shell.Framework ► Codebehind ► Process()()()
Members
Icon | Member | Description
 | Process(String, Boolean) | Runs the processor.
 | Process(String, Boolean, String%) | Runs the processor.


Process Method (header, setCodeBehind)

Process Method (header, setCodeBehind)
Namespaces ► Sitecore.Shell.Framework ► Codebehind ► Process(String, Boolean)
Runs the processor.
Declaration Syntax
C#
public string Process(
    string header,
    bool setCodeBehind
)
Parameters
header (String)
The header.
setCodeBehind (Boolean)
if set to true this instance is set code behind.
Return Value
The result.


Process Method (header, setCodeBehind, codebehind)

Process Method (header, setCodeBehind, codebehind)
Namespaces ► Sitecore.Shell.Framework ► Codebehind ► Process(String, Boolean, String%)
Runs the processor.
Declaration Syntax
C#
public string Process(
    string header,
    bool setCodeBehind,
    ref string codebehind
)
Parameters
header (String)
The header.
setCodeBehind (Boolean)
if set to true this instance is set code behind.
codebehind ( String %)
The codebehind.
Return Value
The result.


ContextMenu Class

ContextMenu Class
Namespaces ► Sitecore.Shell.Framework ► ContextMenu
Represents a Context Menu.
Declaration Syntax
C#
public class ContextMenu
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContextMenu()()() | Initializes a new instance of the ContextMenu class
 | Build(CommandContext) | Builds the context menu.
 | Build(CommandContext, Menu) | Builds the context menu.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ContextMenu


ContextMenu Constructor

ContextMenu Constructor
Namespaces ► Sitecore.Shell.Framework ► ContextMenu ► ContextMenu()()()
Initializes a new instance of the ContextMenu class
Declaration Syntax
C#
public ContextMenu()


Build Method

Build Method
Namespaces ► Sitecore.Shell.Framework ► ContextMenu ► Build()()()
Members
Icon | Member | Description
 | Build(CommandContext) | Builds the context menu.
 | Build(CommandContext, Menu) | Builds the context menu.


Build Method (context)

Build Method (context)
Namespaces ► Sitecore.Shell.Framework ► ContextMenu ► Build(CommandContext)
Builds the context menu.
Declaration Syntax
C#
public Menu Build(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


Build Method (context, menu)

Build Method (context, menu)
Namespaces ► Sitecore.Shell.Framework ► ContextMenu ► Build(CommandContext, Menu)
Builds the context menu.
Declaration Syntax
C#
public void Build(
    CommandContext context,
    Menu menu
)
Parameters
context (CommandContext)
The context.
menu (Menu)
The menu.


ID Property

ID Property
Namespaces ► Sitecore.Shell.Framework ► ContextMenu ► ID
Gets or sets the ID.
Declaration Syntax
C#
public string ID { get; set; }
Value
The ID.


Dialogs Class

Dialogs Class
Namespaces ► Sitecore.Shell.Framework ► Dialogs
Provides utility methods for working with dialogs.
Declaration Syntax
C#
public class Dialogs
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Dialogs()()() | Initializes a new instance of the Dialogs class
 | BrokenLinks()()() | Open Broken Links report.
 | BrowseImage(String, String) | Browses the image.
 | BrowseImage(String, String, Language) | Browses the image.
 | BrowseItem(String, String) | Browses the item.
 | BrowseItem(String, String, String, String, String, String) | Browses the item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExportLanguage()()() | Exports the language.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImportLanguage()()() | Imports the language.
 | MasterLister(String) | Masters the lister.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnBrokenLinks(Message) | Obsolete. Called when the broken has links.
 | OnExportLanguage(Message) | Obsolete. Called when the export has language.
 | OnImportLanguage(Message) | Obsolete. Called when the import has language.
 | OnRebuildLinkDatabase(Message) | Obsolete. Called when the rebuild link has database.
 | OnRebuildSearchIndex(Message) | Obsolete. Called when the rebuild search has index.
 | OnShowAbout(Message) | Obsolete. Called when the show has about.
 | OnShowLicenses(Message) | Obsolete. Called when the show has licenses.
 | OnUntranslatedFields(Message) | Obsolete. Called when the untranslated has fields.
 | RebuildLinkDatabase()()() | Rebuilds the link database.
 | RebuildSearchIndex()()() | Rebuilds the index of the search.
 | ShowAbout()()() | Shows the about.
 | ShowLicenses()()() | Shows the licenses.
 | TemplateLister(String) | Templates the lister.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UntranslatedFields()()() | Untranslateds the fields.
 | UntranslatedFieldsPipeline(ClientPipelineArgs) | Untranslateds the fields pipeline.
Inheritance Hierarchy
Object
Dialogs


Dialogs Constructor

Dialogs Constructor
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► Dialogs()()()
Initializes a new instance of the Dialogs class
Declaration Syntax
C#
public Dialogs()


BrokenLinks Method

BrokenLinks Method
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► BrokenLinks()()()
Open Broken Links report.
Declaration Syntax
C#
public static void BrokenLinks()


BrowseImage Method

BrowseImage Method
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► BrowseImage()()()
Members
Icon | Member | Description
 | BrowseImage(String, String) | Browses the image.
 | BrowseImage(String, String, Language) | Browses the image.


BrowseImage Method (id, root)

BrowseImage Method (id, root)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► BrowseImage(String, String)
Browses the image.
Declaration Syntax
C#
public static void BrowseImage(
    string id,
    string root
)
Parameters
id (String)
The id.
root (String)
The root.


BrowseImage Method (id, root, language)

BrowseImage Method (id, root, language)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► BrowseImage(String, String, Language)
Browses the image.
Declaration Syntax
C#
public static void BrowseImage(
    string id,
    string root,
    Language language
)
Parameters
id (String)
The id.
root (String)
The root.
language (Language)
The language.


BrowseItem Method

BrowseItem Method
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► BrowseItem()()()
Members
Icon | Member | Description
 | BrowseItem(String, String) | Browses the item.
 | BrowseItem(String, String, String, String, String, String) | Browses the item.


BrowseItem Method (selected, root)

BrowseItem Method (selected, root)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► BrowseItem(String, String)
Browses the item.
Declaration Syntax
C#
public static void BrowseItem(
    string selected,
    string root
)
Parameters
selected (String)
The selected.
root (String)
The root.


BrowseItem Method (header, text, icon, button, root, selected)

BrowseItem Method (header, text, icon, button, root, selected)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► BrowseItem(String, String, String, String, String, String)
Browses the item.
Declaration Syntax
C#
public static void BrowseItem(
    string header,
    string text,
    string icon,
    string button,
    string root,
    string selected
)
Parameters
header (String)
The header.
text (String)
The text.
icon (String)
The icon.
button (String)
The button.
root (String)
The root.
selected (String)
The selected.


ExportLanguage Method

ExportLanguage Method
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► ExportLanguage()()()
Exports the language.
Declaration Syntax
C#
public static void ExportLanguage()


ImportLanguage Method

ImportLanguage Method
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► ImportLanguage()()()
Imports the language.
Declaration Syntax
C#
public static void ImportLanguage()


MasterLister Method (lastMaster)

MasterLister Method (lastMaster)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► MasterLister(String)
Masters the lister.
Declaration Syntax
C#
public static void MasterLister(
    string lastMaster
)
Parameters
lastMaster (String)
The last master.


OnBrokenLinks Method (message)

OnBrokenLinks Method (message)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► OnBrokenLinks(Message)
Called when the broken has links.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnBrokenLinks(
    Message message
)
Parameters
message (Message)
The message.


OnExportLanguage Method (message)

OnExportLanguage Method (message)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► OnExportLanguage(Message)
Called when the export has language.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnExportLanguage(
    Message message
)
Parameters
message (Message)
The message.


OnImportLanguage Method (message)

OnImportLanguage Method (message)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► OnImportLanguage(Message)
Called when the import has language.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnImportLanguage(
    Message message
)
Parameters
message (Message)
The message.


OnRebuildLinkDatabase Method (message)

OnRebuildLinkDatabase Method (message)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► OnRebuildLinkDatabase(Message)
Called when the rebuild link has database.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnRebuildLinkDatabase(
    Message message
)
Parameters
message (Message)
The message.


OnRebuildSearchIndex Method (message)

OnRebuildSearchIndex Method (message)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► OnRebuildSearchIndex(Message)
Called when the rebuild search has index.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnRebuildSearchIndex(
    Message message
)
Parameters
message (Message)
The message.


OnShowAbout Method (message)

OnShowAbout Method (message)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► OnShowAbout(Message)
Called when the show has about.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnShowAbout(
    Message message
)
Parameters
message (Message)
The message.


OnShowLicenses Method (message)

OnShowLicenses Method (message)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► OnShowLicenses(Message)
Called when the show has licenses.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnShowLicenses(
    Message message
)
Parameters
message (Message)
The message.


OnUntranslatedFields Method (message)

OnUntranslatedFields Method (message)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► OnUntranslatedFields(Message)
Called when the untranslated has fields.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnUntranslatedFields(
    Message message
)
Parameters
message (Message)
The message.


RebuildLinkDatabase Method

RebuildLinkDatabase Method
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► RebuildLinkDatabase()()()
Rebuilds the link database.
Declaration Syntax
C#
public static void RebuildLinkDatabase()


RebuildSearchIndex Method

RebuildSearchIndex Method
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► RebuildSearchIndex()()()
Rebuilds the index of the search.
Declaration Syntax
C#
public static void RebuildSearchIndex()


ShowAbout Method

ShowAbout Method
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► ShowAbout()()()
Shows the about.
Declaration Syntax
C#
public static void ShowAbout()


ShowLicenses Method

ShowLicenses Method
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► ShowLicenses()()()
Shows the licenses.
Declaration Syntax
C#
public static void ShowLicenses()


TemplateLister Method (lastTemplate)

TemplateLister Method (lastTemplate)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► TemplateLister(String)
Templates the lister.
Declaration Syntax
C#
public static void TemplateLister(
    string lastTemplate
)
Parameters
lastTemplate (String)
The last template.


UntranslatedFields Method

UntranslatedFields Method
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► UntranslatedFields()()()
Untranslateds the fields.
Declaration Syntax
C#
public static void UntranslatedFields()


UntranslatedFieldsPipeline Method (args)

UntranslatedFieldsPipeline Method (args)
Namespaces ► Sitecore.Shell.Framework ► Dialogs ► UntranslatedFieldsPipeline(ClientPipelineArgs)
Untranslateds the fields pipeline.
Declaration Syntax
C#
public void UntranslatedFieldsPipeline(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Dispatcher Class

Dispatcher Class
Namespaces ► Sitecore.Shell.Framework ► Dispatcher
Declaration Syntax
C#
public class Dispatcher
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Dispatcher()()() | Initializes a new instance of the Dispatcher class
 | Dispatch(Message) | Dispatches the specified message.
 | Dispatch(Message, Item) | Dispatches the specified message.
 | Dispatch(Message, array<Item>[]()[]) | Dispatches the specified message.
 | Dispatch(Message, CommandContext) | Dispatches the specified message.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Dispatcher


Dispatcher Constructor

Dispatcher Constructor
Namespaces ► Sitecore.Shell.Framework ► Dispatcher ► Dispatcher()()()
Initializes a new instance of the Dispatcher class
Declaration Syntax
C#
public Dispatcher()


Dispatch Method

Dispatch Method
Namespaces ► Sitecore.Shell.Framework ► Dispatcher ► Dispatch()()()
Members
Icon | Member | Description
 | Dispatch(Message) | Dispatches the specified message.
 | Dispatch(Message, Item) | Dispatches the specified message.
 | Dispatch(Message, array<Item>[]()[]) | Dispatches the specified message.
 | Dispatch(Message, CommandContext) | Dispatches the specified message.


Dispatch Method (message)

Dispatch Method (message)
Namespaces ► Sitecore.Shell.Framework ► Dispatcher ► Dispatch(Message)
Dispatches the specified message.
Declaration Syntax
C#
public static void Dispatch(
    Message message
)
Parameters
message (Message)
The message.


Dispatch Method (message, item)

Dispatch Method (message, item)
Namespaces ► Sitecore.Shell.Framework ► Dispatcher ► Dispatch(Message, Item)
Dispatches the specified message.
Declaration Syntax
C#
public static void Dispatch(
    Message message,
    Item item
)
Parameters
message (Message)
The message.
item (Item)
The item.


Dispatch Method (message, items)

Dispatch Method (message, items)
Namespaces ► Sitecore.Shell.Framework ► Dispatcher ► Dispatch(Message, array<Item>[]()[])
Dispatches the specified message.
Declaration Syntax
C#
public static void Dispatch(
    Message message,
    Item[] items
)
Parameters
message (Message)
The message.
items (array< Item >[]()[])
The items.


Dispatch Method (message, context)

Dispatch Method (message, context)
Namespaces ► Sitecore.Shell.Framework ► Dispatcher ► Dispatch(Message, CommandContext)
Dispatches the specified message.
Declaration Syntax
C#
public static void Dispatch(
    Message message,
    CommandContext context
)
Parameters
message (Message)
The message.
context (CommandContext)
The context.


Files Class

Files Class
Namespaces ► Sitecore.Shell.Framework ► Files
Provides utility functions for working with files.
Declaration Syntax
C#
public class Files
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Files()()() | Initializes a new instance of the Files class
 | Delete(array<String>[]()[]) | Deletes the specified files.
 | Delete(array<String>[]()[], String) | Deletes the specified files.
 | Download(String) | Executes the event.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InstallPackage()()() | Installs the package.
 | ListFiles(String, String, String, String, String, String) | Lists the files.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewFolder(String) | News the folder.
 | NewFolder(String, String) | News the folder.
 | OpenFile(String, String, String, String, String, String, String, String) | Opens the file.
 | Rename(String) | Obsolete. Renames the specified filename.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Upload(Item) | Uploads the specified parent.
 | UploadToDirectory(String) | Uploads to directory.
 | Zip(String, array<String>[]()[]) | Zips the specified zip filename.
 | ZipAndDownLoad(String, array<String>[]()[]) | Zips the and down load.
Inheritance Hierarchy
Object
Files


Files Constructor

Files Constructor
Namespaces ► Sitecore.Shell.Framework ► Files ► Files()()()
Initializes a new instance of the Files class
Declaration Syntax
C#
public Files()


Delete Method

Delete Method
Namespaces ► Sitecore.Shell.Framework ► Files ► Delete()()()
Members
Icon | Member | Description
 | Delete(array<String>[]()[]) | Deletes the specified files.
 | Delete(array<String>[]()[], String) | Deletes the specified files.


Delete Method (files)

Delete Method (files)
Namespaces ► Sitecore.Shell.Framework ► Files ► Delete(array<String>[]()[])
Deletes the specified files.
Declaration Syntax
C#
public static void Delete(
    string[] files
)
Parameters
files (array< String >[]()[])
The files.


Delete Method (files, message)

Delete Method (files, message)
Namespaces ► Sitecore.Shell.Framework ► Files ► Delete(array<String>[]()[], String)
Deletes the specified files.
Declaration Syntax
C#
public static void Delete(
    string[] files,
    string message
)
Parameters
files (array< String >[]()[])
The files.
message (String)
The message.


Download Method (filename)

Download Method (filename)
Namespaces ► Sitecore.Shell.Framework ► Files ► Download(String)
Executes the event.
Declaration Syntax
C#
public static void Download(
    string filename
)
Parameters
filename (String)
The filename.


InstallPackage Method

InstallPackage Method
Namespaces ► Sitecore.Shell.Framework ► Files ► InstallPackage()()()
Installs the package.
Declaration Syntax
C#
public static void InstallPackage()


ListFiles Method (header, text, icon, button, directory, filter)

ListFiles Method (header, text, icon, button, directory, filter)
Namespaces ► Sitecore.Shell.Framework ► Files ► ListFiles(String, String, String, String, String, String)
Lists the files.
Declaration Syntax
C#
public static void ListFiles(
    string header,
    string text,
    string icon,
    string button,
    string directory,
    string filter
)
Parameters
header (String)
The header.
text (String)
The text.
icon (String)
The icon.
button (String)
The button.
directory (String)
The directory.
filter (String)
The filter.


NewFolder Method

NewFolder Method
Namespaces ► Sitecore.Shell.Framework ► Files ► NewFolder()()()
Members
Icon | Member | Description
 | NewFolder(String) | News the folder.
 | NewFolder(String, String) | News the folder.


NewFolder Method (parentFolder)

NewFolder Method (parentFolder)
Namespaces ► Sitecore.Shell.Framework ► Files ► NewFolder(String)
News the folder.
Declaration Syntax
C#
public static void NewFolder(
    string parentFolder
)
Parameters
parentFolder (String)
The parent folder.


NewFolder Method (parentFolder, message)

NewFolder Method (parentFolder, message)
Namespaces ► Sitecore.Shell.Framework ► Files ► NewFolder(String, String)
News the folder.
Declaration Syntax
C#
public static void NewFolder(
    string parentFolder,
    string message
)
Parameters
parentFolder (String)
The parent folder.
message (String)
The message.


OpenFile Method (header, text, icon, button, root, directory, selected, filter)

OpenFile Method (header, text, icon, button, root, directory, selected, filter)
Namespaces ► Sitecore.Shell.Framework ► Files ► OpenFile(String, String, String, String, String, String, String, String)
Opens the file.
Declaration Syntax
C#
public static void OpenFile(
    string header,
    string text,
    string icon,
    string button,
    string root,
    string directory,
    string selected,
    string filter
)
Parameters
header (String)
The header.
text (String)
The text.
icon (String)
The icon.
button (String)
The button.
root (String)
The root.
directory (String)
The directory.
selected (String)
The selected.
filter (String)
The filter.


Rename Method (filename)

Rename Method (filename)
Namespaces ► Sitecore.Shell.Framework ► Files ► Rename(String)
Renames the specified filename.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void Rename(
    string filename
)
Parameters
filename (String)
The filename.


Upload Method (parent)

Upload Method (parent)
Namespaces ► Sitecore.Shell.Framework ► Files ► Upload(Item)
Uploads the specified parent.
Declaration Syntax
C#
public static void Upload(
    Item parent
)
Parameters
parent (Item)
The parent.


UploadToDirectory Method (directory)

UploadToDirectory Method (directory)
Namespaces ► Sitecore.Shell.Framework ► Files ► UploadToDirectory(String)
Uploads to directory.
Declaration Syntax
C#
public static void UploadToDirectory(
    string directory
)
Parameters
directory (String)
The directory.


Zip Method (zipFilename, files)

Zip Method (zipFilename, files)
Namespaces ► Sitecore.Shell.Framework ► Files ► Zip(String, array<String>[]()[])
Zips the specified zip filename.
Declaration Syntax
C#
public static string Zip(
    string zipFilename,
    string[] files
)
Parameters
zipFilename (String)
The zip filename.
files (array< String >[]()[])
The files.
Return Value
The zip.


ZipAndDownLoad Method (zipFilename, files)

ZipAndDownLoad Method (zipFilename, files)
Namespaces ► Sitecore.Shell.Framework ► Files ► ZipAndDownLoad(String, array<String>[]()[])
Zips the and down load.
Declaration Syntax
C#
public static void ZipAndDownLoad(
    string zipFilename,
    string[] files
)
Parameters
zipFilename (String)
The zip filename.
files (array< String >[]()[])
The files.


History Class

History Class
Namespaces ► Sitecore.Shell.Framework ► History
Represents a history of visited items.
Declaration Syntax
C#
public class History
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | History()()() | Initializes a new instance of the History class
 | Add(ItemUri) | Adds the specified item URI.
 | Back()()() | Backs this instance.
 | CanBack | Gets a value indicating whether this instance can back.
 | CanForward | Gets a value indicating whether this instance can forward.
 | Clear()()() | Clears this instance.
 | Count | Gets the count.
 | Current | Gets or sets the current.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Forward()()() | Forwards this instance.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHistory()()() | Gets the history.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HistoryLength |
 | Master | Gets or sets the master.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Template | Gets or sets the template.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
History


History Constructor

History Constructor
Namespaces ► Sitecore.Shell.Framework ► History ► History()()()
Initializes a new instance of the History class
Declaration Syntax
C#
public History()


Add Method (itemUri)

Add Method (itemUri)
Namespaces ► Sitecore.Shell.Framework ► History ► Add(ItemUri)
Adds the specified item URI.
Declaration Syntax
C#
public static void Add(
    ItemUri itemUri
)
Parameters
itemUri (ItemUri)
The item URI.


Back Method

Back Method
Namespaces ► Sitecore.Shell.Framework ► History ► Back()()()
Backs this instance.
Declaration Syntax
C#
public static ItemUri Back()
Return Value
The back.


CanBack Property

CanBack Property
Namespaces ► Sitecore.Shell.Framework ► History ► CanBack
Gets a value indicating whether this instance can back.
Declaration Syntax
C#
public static bool CanBack { get; }
Value
true if this instance can back; otherwise, false.


CanForward Property

CanForward Property
Namespaces ► Sitecore.Shell.Framework ► History ► CanForward
Gets a value indicating whether this instance can forward.
Declaration Syntax
C#
public static bool CanForward { get; }
Value
true if this instance can forward; otherwise, false.


Clear Method

Clear Method
Namespaces ► Sitecore.Shell.Framework ► History ► Clear()()()
Clears this instance.
Declaration Syntax
C#
public static void Clear()


Count Property

Count Property
Namespaces ► Sitecore.Shell.Framework ► History ► Count
Gets the count.
Declaration Syntax
C#
public static int Count { get; }
Value
The count.


Current Property

Current Property
Namespaces ► Sitecore.Shell.Framework ► History ► Current
Gets or sets the current.
Declaration Syntax
C#
public static int Current { get; set; }
Value
The current.


Forward Method

Forward Method
Namespaces ► Sitecore.Shell.Framework ► History ► Forward()()()
Forwards this instance.
Declaration Syntax
C#
public static ItemUri Forward()
Return Value
The forward.


GetHistory Method

GetHistory Method
Namespaces ► Sitecore.Shell.Framework ► History ► GetHistory()()()
Gets the history.
Declaration Syntax
C#
public static ItemUri[] GetHistory()
Return Value
The history.


HistoryLength Field

HistoryLength Field
Namespaces ► Sitecore.Shell.Framework ► History ► HistoryLength
Declaration Syntax
C#
public const int HistoryLength


Master Property

Master Property
Namespaces ► Sitecore.Shell.Framework ► History ► Master
Gets or sets the master.
Declaration Syntax
C#
public static string Master { get; set; }
Value
The master.


Template Property

Template Property
Namespaces ► Sitecore.Shell.Framework ► History ► Template
Gets or sets the template.
Declaration Syntax
C#
public static string Template { get; set; }
Value
The template.


Items Class

Items Class
Namespaces ► Sitecore.Shell.Framework ► Items
Declaration Syntax
C#
public class Items
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Items()()() | Initializes a new instance of the Items class
 | AddFromMaster(Item) | Adds from master.
 | AddFromTemplate(Item) | Adds from template.
 | CopyTo(array<Item>[]()[]) | Copies to.
 | Delete(array<Item>[]()[]) | Deletes the specified items.
 | Delete(array<Item>[]()[], String) | Deletes the specified items.
 | DeleteChildren(array<Item>[]()[]) | Deletes the children.
 | DeleteChildren(array<Item>[]()[], String) | Deletes the children.
 | DragTo(Item, Item, Boolean, Boolean) | Drags to.
 | DragTo(Item, Item, Boolean, Boolean, Boolean) | Drags to.
 | Duplicate(Item) | Duplicates the specified item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveDown(array<Item>[]()[]) | Moves the items down.
 | MoveFirst(array<Item>[]()[]) | Moves the items first.
 | MoveLast(array<Item>[]()[]) | Moves the items last.
 | MoveTo(array<Item>[]()[]) | Moves to.
 | MoveUp(array<Item>[]()[]) | Moves the items up.
 | NewFolder(Item) | Creates a new folder.
 | NewFolder(Item, String) | Creates a new folder.
 | OnPreview(Message) | Obsolete. Called when this instance has preview.
 | OnPublish(Message) | Obsolete. Called when this instance has publish.
 | OnSearch(Message) | Obsolete. Called when this instance has search.
 | Preview()()() | Previews.
 | Preview(Item) | Previews the specified item.
 | Publish()()() | Publishes.
 | Publish(Item) | Publishes the specified item.
 | Rename(Item) | Renames the specified item.
 | Search(String) | Searches the specified query.
 | SetDisplayName(Item) | Sets the name of the display.
 | SetIcon(Item) | Obsolete. Sets the icon.
 | SortByName(Item) | Sorts by name.
 | SortByUpdated(Item) | Sorts by updated.
 | SortReset(Item) | Resets the sort order.
 | SortReverse(Item) | Sorts in reverse.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TransferToDatabase(Item) | Transfers to database.
Inheritance Hierarchy
Object
Items


Items Constructor

Items Constructor
Namespaces ► Sitecore.Shell.Framework ► Items ► Items()()()
Initializes a new instance of the Items class
Declaration Syntax
C#
public Items()


AddFromMaster Method (parent)

AddFromMaster Method (parent)
Namespaces ► Sitecore.Shell.Framework ► Items ► AddFromMaster(Item)
Adds from master.
Declaration Syntax
C#
public static void AddFromMaster(
    Item parent
)
Parameters
parent (Item)
The parent.


AddFromTemplate Method (parent)

AddFromTemplate Method (parent)
Namespaces ► Sitecore.Shell.Framework ► Items ► AddFromTemplate(Item)
Adds from template.
Declaration Syntax
C#
public static void AddFromTemplate(
    Item parent
)
Parameters
parent (Item)
The parent.


CopyTo Method (items)

CopyTo Method (items)
Namespaces ► Sitecore.Shell.Framework ► Items ► CopyTo(array<Item>[]()[])
Copies to.
Declaration Syntax
C#
public static void CopyTo(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.


Delete Method

Delete Method
Namespaces ► Sitecore.Shell.Framework ► Items ► Delete()()()
Members
Icon | Member | Description
 | Delete(array<Item>[]()[]) | Deletes the specified items.
 | Delete(array<Item>[]()[], String) | Deletes the specified items.


Delete Method (items)

Delete Method (items)
Namespaces ► Sitecore.Shell.Framework ► Items ► Delete(array<Item>[]()[])
Deletes the specified items.
Declaration Syntax
C#
public static void Delete(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.


Delete Method (items, message)

Delete Method (items, message)
Namespaces ► Sitecore.Shell.Framework ► Items ► Delete(array<Item>[]()[], String)
Deletes the specified items.
Declaration Syntax
C#
public static void Delete(
    Item[] items,
    string message
)
Parameters
items (array< Item >[]()[])
The items.
message (String)
The message.


DeleteChildren Method

DeleteChildren Method
Namespaces ► Sitecore.Shell.Framework ► Items ► DeleteChildren()()()
Members
Icon | Member | Description
 | DeleteChildren(array<Item>[]()[]) | Deletes the children.
 | DeleteChildren(array<Item>[]()[], String) | Deletes the children.


DeleteChildren Method (items)

DeleteChildren Method (items)
Namespaces ► Sitecore.Shell.Framework ► Items ► DeleteChildren(array<Item>[]()[])
Deletes the children.
Declaration Syntax
C#
public static void DeleteChildren(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.


DeleteChildren Method (items, message)

DeleteChildren Method (items, message)
Namespaces ► Sitecore.Shell.Framework ► Items ► DeleteChildren(array<Item>[]()[], String)
Deletes the children.
Declaration Syntax
C#
public static void DeleteChildren(
    Item[] items,
    string message
)
Parameters
items (array< Item >[]()[])
The items.
message (String)
The message.


DragTo Method

DragTo Method
Namespaces ► Sitecore.Shell.Framework ► Items ► DragTo()()()
Members
Icon | Member | Description
 | DragTo(Item, Item, Boolean, Boolean) | Drags to.
 | DragTo(Item, Item, Boolean, Boolean, Boolean) | Drags to.


DragTo Method (item, target, copy, confirm)

DragTo Method (item, target, copy, confirm)
Namespaces ► Sitecore.Shell.Framework ► Items ► DragTo(Item, Item, Boolean, Boolean)
Drags to.
Declaration Syntax
C#
public static void DragTo(
    Item item,
    Item target,
    bool copy,
    bool confirm
)
Parameters
item (Item)
The item.
target (Item)
The target.
copy (Boolean)
if set to true this instance is copy.
confirm (Boolean)
if set to true this instance is confirm.


DragTo Method (item, target, copy, confirm, appendAsChild)

DragTo Method (item, target, copy, confirm, appendAsChild)
Namespaces ► Sitecore.Shell.Framework ► Items ► DragTo(Item, Item, Boolean, Boolean, Boolean)
Drags to.
Declaration Syntax
C#
public static void DragTo(
    Item item,
    Item target,
    bool copy,
    bool confirm,
    bool appendAsChild
)
Parameters
item (Item)
The item.
target (Item)
The target.
copy (Boolean)
if set to true this instance is copy.
confirm (Boolean)
if set to true this instance is confirm.
appendAsChild (Boolean)
if set to true this instance is append as child.


Duplicate Method (item)

Duplicate Method (item)
Namespaces ► Sitecore.Shell.Framework ► Items ► Duplicate(Item)
Duplicates the specified item.
Declaration Syntax
C#
public static void Duplicate(
    Item item
)
Parameters
item (Item)
The item.


MoveDown Method (items)

MoveDown Method (items)
Namespaces ► Sitecore.Shell.Framework ► Items ► MoveDown(array<Item>[]()[])
Moves the items down.
Declaration Syntax
C#
public static void MoveDown(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.


MoveFirst Method (items)

MoveFirst Method (items)
Namespaces ► Sitecore.Shell.Framework ► Items ► MoveFirst(array<Item>[]()[])
Moves the items first.
Declaration Syntax
C#
public static void MoveFirst(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.


MoveLast Method (items)

MoveLast Method (items)
Namespaces ► Sitecore.Shell.Framework ► Items ► MoveLast(array<Item>[]()[])
Moves the items last.
Declaration Syntax
C#
public static void MoveLast(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.


MoveTo Method (items)

MoveTo Method (items)
Namespaces ► Sitecore.Shell.Framework ► Items ► MoveTo(array<Item>[]()[])
Moves to.
Declaration Syntax
C#
public static void MoveTo(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.


MoveUp Method (items)

MoveUp Method (items)
Namespaces ► Sitecore.Shell.Framework ► Items ► MoveUp(array<Item>[]()[])
Moves the items up.
Declaration Syntax
C#
public static void MoveUp(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.


NewFolder Method

NewFolder Method
Namespaces ► Sitecore.Shell.Framework ► Items ► NewFolder()()()
Members
Icon | Member | Description
 | NewFolder(Item) | Creates a new folder.
 | NewFolder(Item, String) | Creates a new folder.


NewFolder Method (parent)

NewFolder Method (parent)
Namespaces ► Sitecore.Shell.Framework ► Items ► NewFolder(Item)
Creates a new folder.
Declaration Syntax
C#
public static void NewFolder(
    Item parent
)
Parameters
parent (Item)
The parent.


NewFolder Method (parent, master)

NewFolder Method (parent, master)
Namespaces ► Sitecore.Shell.Framework ► Items ► NewFolder(Item, String)
Creates a new folder.
Declaration Syntax
C#
public static void NewFolder(
    Item parent,
    string master
)
Parameters
parent (Item)
The parent.
master (String)
The master.


OnPreview Method (message)

OnPreview Method (message)
Namespaces ► Sitecore.Shell.Framework ► Items ► OnPreview(Message)
Called when this instance has preview.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public void OnPreview(
    Message message
)
Parameters
message (Message)
The message.


OnPublish Method (message)

OnPublish Method (message)
Namespaces ► Sitecore.Shell.Framework ► Items ► OnPublish(Message)
Called when this instance has publish.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public void OnPublish(
    Message message
)
Parameters
message (Message)
The message.


OnSearch Method (message)

OnSearch Method (message)
Namespaces ► Sitecore.Shell.Framework ► Items ► OnSearch(Message)
Called when this instance has search.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public void OnSearch(
    Message message
)
Parameters
message (Message)
The message.


Preview Method

Preview Method
Namespaces ► Sitecore.Shell.Framework ► Items ► Preview()()()
Members
Icon | Member | Description
 | Preview()()() | Previews.
 | Preview(Item) | Previews the specified item.


Preview Method

Preview Method
Namespaces ► Sitecore.Shell.Framework ► Items ► Preview()()()
Previews.
Declaration Syntax
C#
public static void Preview()


Preview Method (item)

Preview Method (item)
Namespaces ► Sitecore.Shell.Framework ► Items ► Preview(Item)
Previews the specified item.
Declaration Syntax
C#
public static void Preview(
    Item item
)
Parameters
item (Item)
The item.


Publish Method

Publish Method
Namespaces ► Sitecore.Shell.Framework ► Items ► Publish()()()
Members
Icon | Member | Description
 | Publish()()() | Publishes.
 | Publish(Item) | Publishes the specified item.


Publish Method

Publish Method
Namespaces ► Sitecore.Shell.Framework ► Items ► Publish()()()
Publishes.
Declaration Syntax
C#
public static void Publish()


Publish Method (item)

Publish Method (item)
Namespaces ► Sitecore.Shell.Framework ► Items ► Publish(Item)
Publishes the specified item.
Declaration Syntax
C#
public static void Publish(
    Item item
)
Parameters
item (Item)
The item.


Rename Method (item)

Rename Method (item)
Namespaces ► Sitecore.Shell.Framework ► Items ► Rename(Item)
Renames the specified item.
Declaration Syntax
C#
public static void Rename(
    Item item
)
Parameters
item (Item)
The item.


Search Method (query)

Search Method (query)
Namespaces ► Sitecore.Shell.Framework ► Items ► Search(String)
Searches the specified query.
Declaration Syntax
C#
public static void Search(
    string query
)
Parameters
query (String)
The query.


SetDisplayName Method (item)

SetDisplayName Method (item)
Namespaces ► Sitecore.Shell.Framework ► Items ► SetDisplayName(Item)
Sets the name of the display.
Declaration Syntax
C#
public static void SetDisplayName(
    Item item
)
Parameters
item (Item)
The item.


SetIcon Method (item)

SetIcon Method (item)
Namespaces ► Sitecore.Shell.Framework ► Items ► SetIcon(Item)
Sets the icon.
Declaration Syntax
C#
[ObsoleteAttribute("This methods is deprecated.", true)]
public static void SetIcon(
    Item item
)
Parameters
item (Item)
The item.


SortByName Method (parent)

SortByName Method (parent)
Namespaces ► Sitecore.Shell.Framework ► Items ► SortByName(Item)
Sorts by name.
Declaration Syntax
C#
public static void SortByName(
    Item parent
)
Parameters
parent (Item)
The parent.


SortByUpdated Method (parent)

SortByUpdated Method (parent)
Namespaces ► Sitecore.Shell.Framework ► Items ► SortByUpdated(Item)
Sorts by updated.
Declaration Syntax
C#
public static void SortByUpdated(
    Item parent
)
Parameters
parent (Item)
The parent.


SortReset Method (parent)

SortReset Method (parent)
Namespaces ► Sitecore.Shell.Framework ► Items ► SortReset(Item)
Resets the sort order.
Declaration Syntax
C#
public static void SortReset(
    Item parent
)
Parameters
parent (Item)
The parent.


SortReverse Method (parent)

SortReverse Method (parent)
Namespaces ► Sitecore.Shell.Framework ► Items ► SortReverse(Item)
Sorts in reverse.
Declaration Syntax
C#
public static void SortReverse(
    Item parent
)
Parameters
parent (Item)
The parent.


TransferToDatabase Method (item)

TransferToDatabase Method (item)
Namespaces ► Sitecore.Shell.Framework ► Items ► TransferToDatabase(Item)
Transfers to database.
Declaration Syntax
C#
public static void TransferToDatabase(
    Item item
)
Parameters
item (Item)
The item.


Preferences Class

Preferences Class
Namespaces ► Sitecore.Shell.Framework ► Preferences
Defines and API for working with preferences.
Declaration Syntax
C#
public class Preferences
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Preferences()()() | Initializes a new instance of the Preferences class
 | ChangeRegionalSettings()()() | Changes the regional settings.
 | ChangeUserInformation()()() | Changes the user information.
 | ChangeWallpaper()()() | Changes the wallpaper.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnChangeRegionalSettings(Message) | Obsolete. Called when the change regional has settings.
 | OnChangeUserInformation(Message) | Obsolete. Called when the change user has information.
 | OnChangeWallpaper(Message) | Obsolete. Called when the change has wallpaper.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Preferences


Preferences Constructor

Preferences Constructor
Namespaces ► Sitecore.Shell.Framework ► Preferences ► Preferences()()()
Initializes a new instance of the Preferences class
Declaration Syntax
C#
public Preferences()


ChangeRegionalSettings Method

ChangeRegionalSettings Method
Namespaces ► Sitecore.Shell.Framework ► Preferences ► ChangeRegionalSettings()()()
Changes the regional settings.
Declaration Syntax
C#
public static void ChangeRegionalSettings()


ChangeUserInformation Method

ChangeUserInformation Method
Namespaces ► Sitecore.Shell.Framework ► Preferences ► ChangeUserInformation()()()
Changes the user information.
Declaration Syntax
C#
public static void ChangeUserInformation()


ChangeWallpaper Method

ChangeWallpaper Method
Namespaces ► Sitecore.Shell.Framework ► Preferences ► ChangeWallpaper()()()
Changes the wallpaper.
Declaration Syntax
C#
public static void ChangeWallpaper()


OnChangeRegionalSettings Method (message)

OnChangeRegionalSettings Method (message)
Namespaces ► Sitecore.Shell.Framework ► Preferences ► OnChangeRegionalSettings(Message)
Called when the change regional has settings.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnChangeRegionalSettings(
    Message message
)
Parameters
message (Message)
The message.


OnChangeUserInformation Method (message)

OnChangeUserInformation Method (message)
Namespaces ► Sitecore.Shell.Framework ► Preferences ► OnChangeUserInformation(Message)
Called when the change user has information.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnChangeUserInformation(
    Message message
)
Parameters
message (Message)
The message.


OnChangeWallpaper Method (message)

OnChangeWallpaper Method (message)
Namespaces ► Sitecore.Shell.Framework ► Preferences ► OnChangeWallpaper(Message)
Called when the change has wallpaper.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnChangeWallpaper(
    Message message
)
Parameters
message (Message)
The message.


Security Class

Security Class
Namespaces ► Sitecore.Shell.Framework ► Security
Defines the utility functions for working with security.
Declaration Syntax
C#
public class Security
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Security()()() | Initializes a new instance of the Security class
 | Abandon()()() | Abandons this instance.
 | ChangePassword()()() | Changes the password.
 | CreateNewRole(Domain) | Creates the new role.
 | CreateNewUser(Domain) | Creates the new user.
 | EditUser(Domain, ID) | Edits the user.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Logout()()() | Logouts this instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnChangePassword(Message) | Obsolete. Called when the change has password.
 | OnCreateNewRole(Message) | Obsolete. Called when the create new has role.
 | OnCreateNewUser(Message) | Obsolete. Called when the create new has user.
 | OnLogout(Message) | Obsolete. Called when this instance has logout.
 | OnOpenSecurityManager(Message) | Obsolete. Called when the open security has manager.
 | OpenSecurityManager()()() | Opens the security manager.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Security


Security Constructor

Security Constructor
Namespaces ► Sitecore.Shell.Framework ► Security ► Security()()()
Initializes a new instance of the Security class
Declaration Syntax
C#
public Security()


Abandon Method

Abandon Method
Namespaces ► Sitecore.Shell.Framework ► Security ► Abandon()()()
Abandons this instance.
Declaration Syntax
C#
public static void Abandon()


ChangePassword Method

ChangePassword Method
Namespaces ► Sitecore.Shell.Framework ► Security ► ChangePassword()()()
Changes the password.
Declaration Syntax
C#
public static void ChangePassword()


CreateNewRole Method (domain)

CreateNewRole Method (domain)
Namespaces ► Sitecore.Shell.Framework ► Security ► CreateNewRole(Domain)
Creates the new role.
Declaration Syntax
C#
public static void CreateNewRole(
    Domain domain
)
Parameters
domain (Domain)
The domain.


CreateNewUser Method (domain)

CreateNewUser Method (domain)
Namespaces ► Sitecore.Shell.Framework ► Security ► CreateNewUser(Domain)
Creates the new user.
Declaration Syntax
C#
public static void CreateNewUser(
    Domain domain
)
Parameters
domain (Domain)
The domain.


EditUser Method (domain, user)

EditUser Method (domain, user)
Namespaces ► Sitecore.Shell.Framework ► Security ► EditUser(Domain, ID)
Edits the user.
Declaration Syntax
C#
public static void EditUser(
    Domain domain,
    ID user
)
Parameters
domain (Domain)
The domain.
user (ID)
The user.


Logout Method

Logout Method
Namespaces ► Sitecore.Shell.Framework ► Security ► Logout()()()
Logouts this instance.
Declaration Syntax
C#
public static void Logout()


OnChangePassword Method (message)

OnChangePassword Method (message)
Namespaces ► Sitecore.Shell.Framework ► Security ► OnChangePassword(Message)
Called when the change has password.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnChangePassword(
    Message message
)
Parameters
message (Message)
The message.


OnCreateNewRole Method (message)

OnCreateNewRole Method (message)
Namespaces ► Sitecore.Shell.Framework ► Security ► OnCreateNewRole(Message)
Called when the create new has role.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnCreateNewRole(
    Message message
)
Parameters
message (Message)
The message.


OnCreateNewUser Method (message)

OnCreateNewUser Method (message)
Namespaces ► Sitecore.Shell.Framework ► Security ► OnCreateNewUser(Message)
Called when the create new has user.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnCreateNewUser(
    Message message
)
Parameters
message (Message)
The message.


OnLogout Method (message)

OnLogout Method (message)
Namespaces ► Sitecore.Shell.Framework ► Security ► OnLogout(Message)
Called when this instance has logout.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnLogout(
    Message message
)
Parameters
message (Message)
The message.


OnOpenSecurityManager Method (message)

OnOpenSecurityManager Method (message)
Namespaces ► Sitecore.Shell.Framework ► Security ► OnOpenSecurityManager(Message)
Called when the open security has manager.
Declaration Syntax
C#
[ObsoleteAttribute("This method has been deprecated.")]
public static void OnOpenSecurityManager(
    Message message
)
Parameters
message (Message)
The message.


OpenSecurityManager Method

OpenSecurityManager Method
Namespaces ► Sitecore.Shell.Framework ► Security ► OpenSecurityManager()()()
Opens the security manager.
Declaration Syntax
C#
public static void OpenSecurityManager()


Sorting Class

Sorting Class
Namespaces ► Sitecore.Shell.Framework ► Sorting
Declaration Syntax
C#
public class Sorting
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Sorting()()() | Initializes a new instance of the Sorting class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveDown(array<Item>[]()[]) | Moves the items down.
 | MoveFirst(array<Item>[]()[]) | Moves the items first.
 | MoveLast(array<Item>[]()[]) | Moves the items last.
 | MoveUp(array<Item>[]()[]) | Moves the items up.
 | SortByName(Item) | Sorts by name.
 | SortByUpdated(Item) | Sorts by updated.
 | SortReset(Item) | Resets sort order.
 | SortReverse(Item) | Sorts reverse.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Sorting


Sorting Constructor

Sorting Constructor
Namespaces ► Sitecore.Shell.Framework ► Sorting ► Sorting()()()
Initializes a new instance of the Sorting class
Declaration Syntax
C#
public Sorting()


MoveDown Method (items)

MoveDown Method (items)
Namespaces ► Sitecore.Shell.Framework ► Sorting ► MoveDown(array<Item>[]()[])
Moves the items down.
Declaration Syntax
C#
public static void MoveDown(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.


MoveFirst Method (items)

MoveFirst Method (items)
Namespaces ► Sitecore.Shell.Framework ► Sorting ► MoveFirst(array<Item>[]()[])
Moves the items first.
Declaration Syntax
C#
public static void MoveFirst(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.


MoveLast Method (items)

MoveLast Method (items)
Namespaces ► Sitecore.Shell.Framework ► Sorting ► MoveLast(array<Item>[]()[])
Moves the items last.
Declaration Syntax
C#
public static void MoveLast(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.


MoveUp Method (items)

MoveUp Method (items)
Namespaces ► Sitecore.Shell.Framework ► Sorting ► MoveUp(array<Item>[]()[])
Moves the items up.
Declaration Syntax
C#
public static void MoveUp(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.


SortByName Method (parent)

SortByName Method (parent)
Namespaces ► Sitecore.Shell.Framework ► Sorting ► SortByName(Item)
Sorts by name.
Declaration Syntax
C#
public static void SortByName(
    Item parent
)
Parameters
parent (Item)
The parent.


SortByUpdated Method (parent)

SortByUpdated Method (parent)
Namespaces ► Sitecore.Shell.Framework ► Sorting ► SortByUpdated(Item)
Sorts by updated.
Declaration Syntax
C#
public static void SortByUpdated(
    Item parent
)
Parameters
parent (Item)
The parent.


SortReset Method (parent)

SortReset Method (parent)
Namespaces ► Sitecore.Shell.Framework ► Sorting ► SortReset(Item)
Resets sort order.
Declaration Syntax
C#
public static void SortReset(
    Item parent
)
Parameters
parent (Item)
The parent.


SortReverse Method (parent)

SortReverse Method (parent)
Namespaces ► Sitecore.Shell.Framework ► Sorting ► SortReverse(Item)
Sorts reverse.
Declaration Syntax
C#
public static void SortReverse(
    Item parent
)
Parameters
parent (Item)
The parent.


Templates Class

Templates Class
Namespaces ► Sitecore.Shell.Framework ► Templates
Defines utility functions for working with templates.
Declaration Syntax
C#
public class Templates
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Templates()()() | Initializes a new instance of the Templates class
 | Edit(TemplateItem) | Edits the specified template.
 | Edit(TemplateItem, Boolean) | Edits the specified template.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Templates


Templates Constructor

Templates Constructor
Namespaces ► Sitecore.Shell.Framework ► Templates ► Templates()()()
Initializes a new instance of the Templates class
Declaration Syntax
C#
public Templates()


Edit Method

Edit Method
Namespaces ► Sitecore.Shell.Framework ► Templates ► Edit()()()
Members
Icon | Member | Description
 | Edit(TemplateItem) | Edits the specified template.
 | Edit(TemplateItem, Boolean) | Edits the specified template.


Edit Method (template)

Edit Method (template)
Namespaces ► Sitecore.Shell.Framework ► Templates ► Edit(TemplateItem)
Edits the specified template.
Declaration Syntax
C#
public static void Edit(
    TemplateItem template
)
Parameters
template (TemplateItem)
The template.


Edit Method (template, advanced)

Edit Method (template, advanced)
Namespaces ► Sitecore.Shell.Framework ► Templates ► Edit(TemplateItem, Boolean)
Edits the specified template.
Declaration Syntax
C#
public static void Edit(
    TemplateItem template,
    bool advanced
)
Parameters
template (TemplateItem)
The template.
advanced (Boolean)
if set to true this instance is advanced.


UrlOptionsBase(T) Class

UrlOptionsBase<(Of <(T>)>) Class
Namespaces ► Sitecore.Shell.Framework ► UrlOptionsBase<(Of <(T>)>)
Represents URL options.
Declaration Syntax
C#
public abstract class UrlOptionsBase<T>
where T : new(), UrlOptionsBase<T>
Generic Template Parameters
T
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UrlOptionsBase<(Of <(T>)>)()()() | Initializes a new instance of the UrlOptionsBase<(Of <(T>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Gets the specified key.
 | GetBool(String, Boolean) | Gets the bool.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Parses the given query string.
 | Parse()()() | Parses the current query string.
 | Set(String, String) | Sets the specified key.
 | SetBool(String, Boolean) | Sets the bool.
 | ToString()()() | ToString. (Overrides Object.ToString()()().)
 | Url |
Inheritance Hierarchy
Object
UrlOptionsBase<(Of <(T>)>)


UrlOptionsBase(T) Constructor

UrlOptionsBase<(Of <(T>)>) Constructor
Namespaces ► Sitecore.Shell.Framework ► UrlOptionsBase<(Of <(T>)>) ► UrlOptionsBase<(Of <(T>)>)()()()
Initializes a new instance of the UrlOptionsBase<(Of <(T>)>) class
Declaration Syntax
C#
protected UrlOptionsBase()


Get Method (key)

Get Method (key)
Namespaces ► Sitecore.Shell.Framework ► UrlOptionsBase<(Of <(T>)>) ► Get(String)
Gets the specified key.
Declaration Syntax
C#
protected string Get(
    string key
)
Parameters
key (String)
The key.
Return Value
The get.


GetBool Method (key, default)

GetBool Method (key, default)
Namespaces ► Sitecore.Shell.Framework ► UrlOptionsBase<(Of <(T>)>) ► GetBool(String, Boolean)
Gets the bool.
Declaration Syntax
C#
protected bool GetBool(
    string key,
    bool default
)
Parameters
key (String)
The key.
default (Boolean)
The default value.
Return Value
The bool.


Parse Method

Parse Method
Namespaces ► Sitecore.Shell.Framework ► UrlOptionsBase<(Of <(T>)>) ► Parse()()()
Members
Icon | Member | Description
 | Parse(String) | Parses the given query string.
 | Parse()()() | Parses the current query string.


Parse Method

Parse Method
Namespaces ► Sitecore.Shell.Framework ► UrlOptionsBase<(Of <(T>)>) ► Parse()()()
Parses the current query string.
Declaration Syntax
C#
public static T Parse()
Return Value
Parsed url options


Parse Method (value)

Parse Method (value)
Namespaces ► Sitecore.Shell.Framework ► UrlOptionsBase<(Of <(T>)>) ► Parse(String)
Parses the given query string.
Declaration Syntax
C#
public static T Parse(
    string value
)
Parameters
value (String)
Return Value
Parsed url options


Set Method (key, value)

Set Method (key, value)
Namespaces ► Sitecore.Shell.Framework ► UrlOptionsBase<(Of <(T>)>) ► Set(String, String)
Sets the specified key.
Declaration Syntax
C#
protected void Set(
    string key,
    string value
)
Parameters
key (String)
The key.
value (String)
The value.


SetBool Method (key, value)

SetBool Method (key, value)
Namespaces ► Sitecore.Shell.Framework ► UrlOptionsBase<(Of <(T>)>) ► SetBool(String, Boolean)
Sets the bool.
Declaration Syntax
C#
protected void SetBool(
    string key,
    bool value
)
Parameters
key (String)
The key.
value (Boolean)
if set to true this instance is value.


ToString Method

ToString Method
Namespaces ► Sitecore.Shell.Framework ► UrlOptionsBase<(Of <(T>)>) ► ToString()()()
ToString.
Declaration Syntax
C#
public override string ToString()
Return Value


Url Property

Url Property
Namespaces ► Sitecore.Shell.Framework ► UrlOptionsBase<(Of <(T>)>) ► Url
Declaration Syntax
C#
protected UrlString Url { get; set; }


UserHistory Class

UserHistory Class
Namespaces ► Sitecore.Shell.Framework ► UserHistory
Represents a history of visited items.
Declaration Syntax
C#
public class UserHistory
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserHistory()()() | Initializes the History class.
 | Add(String) | Adds the specified name.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccounts()()() | Converts the list to an array.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HISTORYLENGTH |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UserHistory


UserHistory Constructor

UserHistory Constructor
Namespaces ► Sitecore.Shell.Framework ► UserHistory ► UserHistory()()()
Initializes the History class.
Declaration Syntax
C#
public UserHistory()


Add Method (accountName)

Add Method (accountName)
Namespaces ► Sitecore.Shell.Framework ► UserHistory ► Add(String)
Adds the specified name.
Declaration Syntax
C#
public void Add(
    string accountName
)
Parameters
accountName (String)
Name of the account.


GetAccounts Method

GetAccounts Method
Namespaces ► Sitecore.Shell.Framework ► UserHistory ► GetAccounts()()()
Converts the list to an array.
Declaration Syntax
C#
public List<string> GetAccounts()
Return Value
The array.


HISTORYLENGTH Field

HISTORYLENGTH Field
Namespaces ► Sitecore.Shell.Framework ► UserHistory ► HISTORYLENGTH
Declaration Syntax
C#
public const int HISTORYLENGTH


Windows Class

Windows Class
Namespaces ► Sitecore.Shell.Framework ► Windows
Defines utility functions for working with windows.
Declaration Syntax
C#
public static class Windows
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ApplicationOffsetX | Gets or sets the application offset X.
 | ApplicationOffsetY | Gets or sets the application offset Y.
 | Close()()() | Closes this instance.
 | Close(CloseMethod) | Closes the specified method.
 | Debug()()() | Debugs this instance.
 | Run(String) | Runs the specified URL.
 | RunApplication(String) | Runs the application.
 | RunApplication(String, String) | Runs the application.
 | RunApplication(Item) | Runs the application.
 | RunApplication(Item, String) | Runs the application.
 | RunApplication(Item, String, String, String) | Runs the application.
 | RunExternal(String, String, String, String) | Runs the external.
 | RunShortcut(ID) | Runs the shortcut.
 | RunUri(String, String, String) | Runs the URI.
Inheritance Hierarchy
Object
Windows


ApplicationOffsetX Property

ApplicationOffsetX Property
Namespaces ► Sitecore.Shell.Framework ► Windows ► ApplicationOffsetX
Gets or sets the application offset X.
Declaration Syntax
C#
public static int ApplicationOffsetX { get; set; }
Value
The application offset X.


ApplicationOffsetY Property

ApplicationOffsetY Property
Namespaces ► Sitecore.Shell.Framework ► Windows ► ApplicationOffsetY
Gets or sets the application offset Y.
Declaration Syntax
C#
public static int ApplicationOffsetY { get; set; }
Value
The application offset Y.


Close Method

Close Method
Namespaces ► Sitecore.Shell.Framework ► Windows ► Close()()()
Members
Icon | Member | Description
 | Close()()() | Closes this instance.
 | Close(CloseMethod) | Closes the specified method.


Close Method

Close Method
Namespaces ► Sitecore.Shell.Framework ► Windows ► Close()()()
Closes this instance.
Declaration Syntax
C#
public static void Close()


Close Method (method)

Close Method (method)
Namespaces ► Sitecore.Shell.Framework ► Windows ► Close(CloseMethod)
Closes the specified method.
Declaration Syntax
C#
public static void Close(
    CloseMethod method
)
Parameters
method (CloseMethod)
The method.


Debug Method

Debug Method
Namespaces ► Sitecore.Shell.Framework ► Windows ► Debug()()()
Debugs this instance.
Declaration Syntax
C#
public static void Debug()


Run Method (url)

Run Method (url)
Namespaces ► Sitecore.Shell.Framework ► Windows ► Run(String)
Runs the specified URL.
Declaration Syntax
C#
public static ClientCommand Run(
    string url
)
Parameters
url (String)
The URL.
Return Value
The run.


RunApplication Method

RunApplication Method
Namespaces ► Sitecore.Shell.Framework ► Windows ► RunApplication()()()
Members
Icon | Member | Description
 | RunApplication(String) | Runs the application.
 | RunApplication(String, String) | Runs the application.
 | RunApplication(Item) | Runs the application.
 | RunApplication(Item, String) | Runs the application.
 | RunApplication(Item, String, String, String) | Runs the application.


RunApplication Method (application)

RunApplication Method (application)
Namespaces ► Sitecore.Shell.Framework ► Windows ► RunApplication(Item)
Runs the application.
Declaration Syntax
C#
public static ClientCommand RunApplication(
    Item application
)
Parameters
application (Item)
The application.
Return Value
The application.


RunApplication Method (application, parameters)

RunApplication Method (application, parameters)
Namespaces ► Sitecore.Shell.Framework ► Windows ► RunApplication(Item, String)
Runs the application.
Declaration Syntax
C#
public static ClientCommand RunApplication(
    Item application,
    string parameters
)
Parameters
application (Item)
The application.
parameters (String)
The parameters.
Return Value
The application.


RunApplication Method (application, icon, displayName, parameters)

RunApplication Method (application, icon, displayName, parameters)
Namespaces ► Sitecore.Shell.Framework ► Windows ► RunApplication(Item, String, String, String)
Runs the application.
Declaration Syntax
C#
public static ClientCommand RunApplication(
    Item application,
    string icon,
    string displayName,
    string parameters
)
Parameters
application (Item)
The application.
icon (String)
The icon.
displayName (String)
Name of the display.
parameters (String)
The parameters.
Return Value
The application.


RunApplication Method (application)

RunApplication Method (application)
Namespaces ► Sitecore.Shell.Framework ► Windows ► RunApplication(String)
Runs the application.
Declaration Syntax
C#
public static ClientCommand RunApplication(
    string application
)
Parameters
application (String)
The application.
Return Value
The application.


RunApplication Method (application, parameters)

RunApplication Method (application, parameters)
Namespaces ► Sitecore.Shell.Framework ► Windows ► RunApplication(String, String)
Runs the application.
Declaration Syntax
C#
public static ClientCommand RunApplication(
    string application,
    string parameters
)
Parameters
application (String)
The application.
parameters (String)
The parameters.
Return Value
The application.


RunExternal Method (url, parameters, icon, header)

RunExternal Method (url, parameters, icon, header)
Namespaces ► Sitecore.Shell.Framework ► Windows ► RunExternal(String, String, String, String)
Runs the external.
Declaration Syntax
C#
public static ClientCommand RunExternal(
    string url,
    string parameters,
    string icon,
    string header
)
Parameters
url (String)
The URL.
parameters (String)
The parameters.
icon (String)
The icon.
header (String)
The header.
Return Value
The external.


RunShortcut Method (id)

RunShortcut Method (id)
Namespaces ► Sitecore.Shell.Framework ► Windows ► RunShortcut(ID)
Runs the shortcut.
Declaration Syntax
C#
public static ClientCommand RunShortcut(
    ID id
)
Parameters
id (ID)
The id.
Return Value
The shortcut.


RunUri Method (uri, icon, header)

RunUri Method (uri, icon, header)
Namespaces ► Sitecore.Shell.Framework ► Windows ► RunUri(String, String, String)
Runs the URI.
Declaration Syntax
C#
public static ClientCommand RunUri(
    string uri,
    string icon,
    string header
)
Parameters
uri (String)
The URI.
icon (String)
The icon.
header (String)
The header.
Return Value
The external.


Sitecore.Shell.Framework.CommandBuilders Namespace

Sitecore.Shell.Framework.CommandBuilders Namespace
Namespaces ► Sitecore.Shell.Framework.CommandBuilders
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.CommandBuilders
Types
All Types Classes
Icon | Type | Description
 | CommandBuilder | Base class for all command builders
 | WorkflowCommandBuilder | Builds the workflow command


CommandBuilder Class

CommandBuilder Class
Namespaces ► Sitecore.Shell.Framework.CommandBuilders ► CommandBuilder
Base class for all command builders
Declaration Syntax
C#
public class CommandBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandBuilder(String) | Initializes a new instance of the CommandBuilder class.
 | Add(String, String) | Adds the specified argument.
 | Add(String, Boolean) | Adds the bool argument
 | Arguments | Gets the arguments.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsCommand(String) | Determines whether the specified command is command.
 | Item[([(String])]) | Gets or sets the command argument with the specified key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the command name.
 | Parse(String) | Parses the specified input.
 | ToString()()() | Returns a String representation of the command (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
 | CommandBuilder
 |  | WorkflowCommandBuilder


CommandBuilder Constructor (commandName)

CommandBuilder Constructor (commandName)
Namespaces ► Sitecore.Shell.Framework.CommandBuilders ► CommandBuilder ► CommandBuilder(String)
Initializes a new instance of the CommandBuilder class.
Declaration Syntax
C#
public CommandBuilder(
    string commandName
)
Parameters
commandName (String)
Name of the command.


Add Method

Add Method
Namespaces ► Sitecore.Shell.Framework.CommandBuilders ► CommandBuilder ► Add()()()
Members
Icon | Member | Description
 | Add(String, String) | Adds the specified argument.
 | Add(String, Boolean) | Adds the bool argument


Add Method (key, value)

Add Method (key, value)
Namespaces ► Sitecore.Shell.Framework.CommandBuilders ► CommandBuilder ► Add(String, Boolean)
Adds the bool argument
Declaration Syntax
C#
public CommandBuilder Add(
    string key,
    bool value
)
Parameters
key (String)
The argument name.
value (Boolean)
The value.


Add Method (key, value)

Add Method (key, value)
Namespaces ► Sitecore.Shell.Framework.CommandBuilders ► CommandBuilder ► Add(String, String)
Adds the specified argument.
Declaration Syntax
C#
public CommandBuilder Add(
    string key,
    string value
)
Parameters
key (String)
The argument name.
value (String)
The value.


Arguments Property

Arguments Property
Namespaces ► Sitecore.Shell.Framework.CommandBuilders ► CommandBuilder ► Arguments
Gets the arguments.
Declaration Syntax
C#
public SafeDictionary<string> Arguments { get; }
Value
The arguments.


IsCommand Method (command)

IsCommand Method (command)
Namespaces ► Sitecore.Shell.Framework.CommandBuilders ► CommandBuilder ► IsCommand(String)
Determines whether the specified command is command.
Declaration Syntax
C#
public static bool IsCommand(
    string command
)
Parameters
command (String)
The command.
Return Value
true if the specified command is command; otherwise, false.


Item Property (key)

Item Property (key)
Namespaces ► Sitecore.Shell.Framework.CommandBuilders ► CommandBuilder ► Item[([(String])])
Gets or sets the command argument with the specified key.
Declaration Syntax
C#
public string this[
    string key
] { get; set; }
Parameters
key (String)
Value
The command argument


Name Property

Name Property
Namespaces ► Sitecore.Shell.Framework.CommandBuilders ► CommandBuilder ► Name
Gets or sets the command name.
Declaration Syntax
C#
public string Name { get; set; }
Value
The name.


Parse Method (input)

Parse Method (input)
Namespaces ► Sitecore.Shell.Framework.CommandBuilders ► CommandBuilder ► Parse(String)
Parses the specified input.
Declaration Syntax
C#
public static CommandBuilder Parse(
    string input
)
Parameters
input (String)
The input.
Return Value
The parse.
Remarks
Parses command strings of the following form: foo:bar(key=value, key2=value2)


ToString Method

ToString Method
Namespaces ► Sitecore.Shell.Framework.CommandBuilders ► CommandBuilder ► ToString()()()
Returns a String representation of the command
Declaration Syntax
C#
public override string ToString()
Return Value
A String representation of the commandObject.


WorkflowCommandBuilder Class

WorkflowCommandBuilder Class
Namespaces ► Sitecore.Shell.Framework.CommandBuilders ► WorkflowCommandBuilder
Builds the workflow command
Declaration Syntax
C#
public class WorkflowCommandBuilder : CommandBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WorkflowCommandBuilder(Item, IWorkflow, WorkflowCommand) | Initializes a new instance of the WorkflowCommandBuilder class.
 | Add(String, String) | Adds the specified argument. (Inherited from CommandBuilder.)
 | Add(String, Boolean) | Adds the bool argument (Inherited from CommandBuilder.)
 | Arguments | Gets the arguments. (Inherited from CommandBuilder.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets or sets the command argument with the specified key. (Inherited from CommandBuilder.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the command name. (Inherited from CommandBuilder.)
 | ToString()()() | Returns a String representation of the command (Inherited from CommandBuilder.)
Inheritance Hierarchy
Object
 | CommandBuilder
 |  | WorkflowCommandBuilder


WorkflowCommandBuilder Constructor (item, workflow, command)

WorkflowCommandBuilder Constructor (item, workflow, command)
Namespaces ► Sitecore.Shell.Framework.CommandBuilders ► WorkflowCommandBuilder ► WorkflowCommandBuilder(Item, IWorkflow, WorkflowCommand)
Initializes a new instance of the WorkflowCommandBuilder class.
Declaration Syntax
C#
public WorkflowCommandBuilder(
    Item item,
    IWorkflow workflow,
    WorkflowCommand command
)
Parameters
item (Item)
The item.
workflow (IWorkflow)
The workflow.
command (WorkflowCommand)
The command.


Sitecore.Shell.Framework.Commands Namespace

Sitecore.Shell.Framework.Commands Namespace
Namespaces ► Sitecore.Shell.Framework.Commands
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | AddFromMaster | Represents the AddFromMaster command.
 | AddFromTemplate | Represents the AddFromTemplate command.
 | AddMaster | Represents the AddMaster command.
 | AddTemplateField | Represents the AddTemplateField command.
 | AddVersion | Represents the AddVersion command.
 | Archive | Represents the Archive command.
 | ArchiveDateClear | Represents the ArchiveDateClear command.
 | ArchiveDateSet | Represents the ArchiveDateSet command.
 | ChangePassword | Represents the ChangePassword command.
 | ChangeTemplate | Represents the ChangeTemplate command.
 | CheckIn | Represents the CheckIn command.
 | CheckOut | Represents the CheckOut command.
 | ClientEventCommand | Represents a client event command.
 | ClipboardCommand | Represents the CopyToClipboard command.
 | Command | Defines the basic properties and functionality of a command.
 | CommandContext | Represents the context in which a command is executes.
 | CommandManager | Manages commands.
 | Commands | Represents a list of commands.
 | CommandState | Represents the state of a command.
 | CompareVersions | Represents the CompareVersions command.
 | CopyTo | Represents the CopyTo command.
 | CopyToClipboard | Represents the CopyToClipboard command.
 | Create | Represents the Create command.
 | CreateNewRole | Represents the CreateNewRole command.
 | CreateNewUser | Obsolete. Represents the CreateNewUser command.
 | CutToClipboard | Represents the CutToClipboard command.
 | Delete | Represents the Delete command.
 | DeleteChildren | Represents the DeleteChildren command.
 | DeleteTemplateField | Represents the DeleteTemplateField command.
 | DeleteVersion | Removes a version
 | DesignItem | Represents the Preview Item command.
 | Download | Represents the Download command.
 | Duplicate | Represents the Duplicate command.
 | Edit | Represents the Edit command.
 | Empty | Represents the Empty command.
 | ExportLanguage | Represents the ExportLanguage command.
 | GotoMaster | Represents the Set Icon command.
 | GotoTemplate | Represents the Set Icon command.
 | IHasCommandContext | Represents a IHasCommandContext.
 | ImportLanguage | Represents the ImportLanguage command.
 | ItemNew | Represents the ItemNew command.
 | MessageCommand | Represents a Message command.
 | MethodCommand | Represents the MethodCommand command.
 | MethodCommandArgs | Represents the arguments of a Method Command.
 | MoveDown | Sorts the items after next.
 | MoveFirst | Sorts the item first.
 | MoveLast | Sorts the item last.
 | MoveTo | Represents the Move To command.
 | MoveUp | Sorts the items before previous.
 | MyItems | Represents a ResetSortorder command.
 | NewFolder | Represents the NewFolder command.
 | OpenSecurityEditor | Represents the Open Security Editor command.
 | OpenSecurityManager | Represents the Open Security Manager command.
 | PasteFromClipboard | Represents the Paste From Clipboard command.
 | PreviewItem | Represents the Preview Item command.
 | PublishingViewer | Represents the Publishing Viewer command.
 | PublishItem | Represents the Publish Item command.
 | PublishNow | Represents the Publish Now command.
 | ReminderClear | Represents the Reminder Clear command.
 | ReminderSet | Represents the Reminder Set command.
 | RemoveLanguage | Represents the Remove Language command.
 | Rename | Represents the Rename command.
 | ResetDefaultWorkflow | Represents the Reset Default Workflow command.
 | ResetFields | Represents a ResetSortorder command.
 | ResetSortorder | Represents a ResetSortorder command.
 | SecurityPreset | Implements the SecurityPreset.
 | SelectIcon | Represents the Select Icon command.
 | SelectLanguage | Represents the Archive command.
 | SetAliases | Represents the Set Aliases command.
 | SetContextMenu | Represents the Set Context Menu command.
 | SetCustomEditors | Represents the Set Custom Editor command.
 | SetDefaultWorkflow | Represents the Set Default Workflow command.
 | SetDisplayName | Represents the Set Display Name command.
 | SetHelp | Represents the Set Help command.
 | SetIcon | Represents the Set Icon command.
 | SetLayoutDetails | Represents the Set Aliases command.
 | SetMasters | Represents the SetMasters command.
 | SetOwner | Represents the Set Owner command.
 | SetPublishing | Represents the Set Publishing command.
 | SetRibbon | Represents the Set Ribbon command.
 | SetSubitemsSorting | Represents the Set Subitems Sorting command.
 | SetTreeNodeStyle | Represents the Set Tree Node Style command.
 | ShowVersions | Shows the versions.
 | ToggleHidden | Represents the Toggle Hidden command.
 | ToggleReadOnly | Represents the Toggle Read Only command.
 | TransferToDatabase | Represents the Transfer To Database command.
 | UntranslatedFields | Represents the Untranslated Fields command.
 | Upload | Represents the Upload command.
 | Workflow | Represents the Workflow command.


AddFromMaster Class

AddFromMaster Class
Namespaces ► Sitecore.Shell.Framework.Commands ► AddFromMaster
Represents the AddFromMaster command.
Declaration Syntax
C#
[SerializableAttribute]
public class AddFromMaster : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddFromMaster()()() | Initializes a new instance of the AddFromMaster class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AddFromMaster


AddFromMaster Constructor

AddFromMaster Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► AddFromMaster ► AddFromMaster()()()
Initializes a new instance of the AddFromMaster class
Declaration Syntax
C#
public AddFromMaster()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► AddFromMaster ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► AddFromMaster ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


AddFromTemplate Class

AddFromTemplate Class
Namespaces ► Sitecore.Shell.Framework.Commands ► AddFromTemplate
Represents the AddFromTemplate command.
Declaration Syntax
C#
[SerializableAttribute]
public class AddFromTemplate : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddFromTemplate()()() | Initializes a new instance of the AddFromTemplate class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AddFromTemplate


AddFromTemplate Constructor

AddFromTemplate Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► AddFromTemplate ► AddFromTemplate()()()
Initializes a new instance of the AddFromTemplate class
Declaration Syntax
C#
public AddFromTemplate()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► AddFromTemplate ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► AddFromTemplate ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


AddMaster Class

AddMaster Class
Namespaces ► Sitecore.Shell.Framework.Commands ► AddMaster
Represents the AddMaster command.
Declaration Syntax
C#
[SerializableAttribute]
public class AddMaster : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMaster()()() | Initializes a new instance of the AddMaster class
 | Add(ClientPipelineArgs) | Adds the specified args.
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AddMaster


AddMaster Constructor

AddMaster Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► AddMaster ► AddMaster()()()
Initializes a new instance of the AddMaster class
Declaration Syntax
C#
public AddMaster()


Add Method (args)

Add Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► AddMaster ► Add(ClientPipelineArgs)
Adds the specified args.
Declaration Syntax
C#
protected void Add(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► AddMaster ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► AddMaster ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


AddTemplateField Class

AddTemplateField Class
Namespaces ► Sitecore.Shell.Framework.Commands ► AddTemplateField
Represents the AddTemplateField command.
Declaration Syntax
C#
[SerializableAttribute]
public class AddTemplateField : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddTemplateField()()() | Initializes a new instance of the AddTemplateField class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AddTemplateField


AddTemplateField Constructor

AddTemplateField Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► AddTemplateField ► AddTemplateField()()()
Initializes a new instance of the AddTemplateField class
Declaration Syntax
C#
public AddTemplateField()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► AddTemplateField ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► AddTemplateField ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► AddTemplateField ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


AddVersion Class

AddVersion Class
Namespaces ► Sitecore.Shell.Framework.Commands ► AddVersion
Represents the AddVersion command.
Declaration Syntax
C#
[SerializableAttribute]
public class AddVersion : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddVersion()()() | Initializes a new instance of the AddVersion class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AddVersion


AddVersion Constructor

AddVersion Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► AddVersion ► AddVersion()()()
Initializes a new instance of the AddVersion class
Declaration Syntax
C#
public AddVersion()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► AddVersion ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► AddVersion ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► AddVersion ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Archive Class

Archive Class
Namespaces ► Sitecore.Shell.Framework.Commands ► Archive
Represents the Archive command.
Declaration Syntax
C#
[SerializableAttribute]
public class Archive : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Archive()()() | Initializes a new instance of the Archive class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Archive


Archive Constructor

Archive Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► Archive ► Archive()()()
Initializes a new instance of the Archive class
Declaration Syntax
C#
public Archive()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Archive ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Archive ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► Archive ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected static void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


ArchiveDateClear Class

ArchiveDateClear Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ArchiveDateClear
Represents the ArchiveDateClear command.
Declaration Syntax
C#
[SerializableAttribute]
public class ArchiveDateClear : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveDateClear()()() | Initializes a new instance of the ArchiveDateClear class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ArchiveDateClear


ArchiveDateClear Constructor

ArchiveDateClear Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ArchiveDateClear ► ArchiveDateClear()()()
Initializes a new instance of the ArchiveDateClear class
Declaration Syntax
C#
public ArchiveDateClear()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ArchiveDateClear ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ArchiveDateClear ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


ArchiveDateSet Class

ArchiveDateSet Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ArchiveDateSet
Represents the ArchiveDateSet command.
Declaration Syntax
C#
[SerializableAttribute]
public class ArchiveDateSet : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveDateSet()()() | Initializes a new instance of the ArchiveDateSet class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ArchiveDateSet


ArchiveDateSet Constructor

ArchiveDateSet Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ArchiveDateSet ► ArchiveDateSet()()()
Initializes a new instance of the ArchiveDateSet class
Declaration Syntax
C#
public ArchiveDateSet()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ArchiveDateSet ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ArchiveDateSet ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► ArchiveDateSet ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


ChangePassword Class

ChangePassword Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ChangePassword
Represents the ChangePassword command.
Declaration Syntax
C#
[SerializableAttribute]
public class ChangePassword : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangePassword()()() | Initializes a new instance of the ChangePassword class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ChangePassword


ChangePassword Constructor

ChangePassword Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ChangePassword ► ChangePassword()()()
Initializes a new instance of the ChangePassword class
Declaration Syntax
C#
public ChangePassword()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ChangePassword ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


ChangeTemplate Class

ChangeTemplate Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ChangeTemplate
Represents the ChangeTemplate command.
Declaration Syntax
C#
[SerializableAttribute]
public class ChangeTemplate : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangeTemplate()()() | Initializes a new instance of the ChangeTemplate class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ChangeTemplate


ChangeTemplate Constructor

ChangeTemplate Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ChangeTemplate ► ChangeTemplate()()()
Initializes a new instance of the ChangeTemplate class
Declaration Syntax
C#
public ChangeTemplate()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ChangeTemplate ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ChangeTemplate ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► ChangeTemplate ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CheckIn Class

CheckIn Class
Namespaces ► Sitecore.Shell.Framework.Commands ► CheckIn
Represents the CheckIn command.
Declaration Syntax
C#
[SerializableAttribute]
public class CheckIn : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckIn()()() | Initializes a new instance of the CheckIn class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | CheckIn


CheckIn Constructor

CheckIn Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► CheckIn ► CheckIn()()()
Initializes a new instance of the CheckIn class
Declaration Syntax
C#
public CheckIn()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CheckIn ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CheckIn ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► CheckIn ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CheckOut Class

CheckOut Class
Namespaces ► Sitecore.Shell.Framework.Commands ► CheckOut
Represents the CheckOut command.
Declaration Syntax
C#
[SerializableAttribute]
public class CheckOut : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckOut()()() | Initializes a new instance of the CheckOut class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | CheckOut


CheckOut Constructor

CheckOut Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► CheckOut ► CheckOut()()()
Initializes a new instance of the CheckOut class
Declaration Syntax
C#
public CheckOut()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CheckOut ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CheckOut ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


ClientEventCommand Class

ClientEventCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ClientEventCommand
Represents a client event command.
Declaration Syntax
C#
[SerializableAttribute]
public class ClientEventCommand : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientEventCommand()()() | Initializes a new instance of the ClientEventCommand class
 | CancelDispatch | Gets a value indicating whether the ClientEventCommand cancels dispatches.
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets or sets the message.
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ClientEventCommand


ClientEventCommand Constructor

ClientEventCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ClientEventCommand ► ClientEventCommand()()()
Initializes a new instance of the ClientEventCommand class
Declaration Syntax
C#
public ClientEventCommand()


CancelDispatch Property

CancelDispatch Property
Namespaces ► Sitecore.Shell.Framework.Commands ► ClientEventCommand ► CancelDispatch
Gets a value indicating whether the ClientEventCommand cancels dispatches.
Declaration Syntax
C#
public bool CancelDispatch { get; }
Value
true if the ClientEventCommand cancels dispatches; otherwise, false.


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ClientEventCommand ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Message Property

Message Property
Namespaces ► Sitecore.Shell.Framework.Commands ► ClientEventCommand ► Message
Gets or sets the message.
Declaration Syntax
C#
public Message Message { get; set; }
Value
The message.


ClipboardCommand Class

ClipboardCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ClipboardCommand
Represents the CopyToClipboard command.
Declaration Syntax
C#
[SerializableAttribute]
public abstract class ClipboardCommand : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClipboardCommand()()() | Initializes a new instance of the ClipboardCommand class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Inherited from Command.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | IsSupported(Boolean) | Determines whether this instance is supported.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ClipboardCommand
 |  |  | CopyToClipboard
 |  |  | CutToClipboard
 |  |  | PasteFromClipboard


ClipboardCommand Constructor

ClipboardCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ClipboardCommand ► ClipboardCommand()()()
Initializes a new instance of the ClipboardCommand class
Declaration Syntax
C#
protected ClipboardCommand()


IsSupported Method (alert)

IsSupported Method (alert)
Namespaces ► Sitecore.Shell.Framework.Commands ► ClipboardCommand ► IsSupported(Boolean)
Determines whether this instance is supported.
Declaration Syntax
C#
protected static bool IsSupported(
    bool alert
)
Parameters
alert (Boolean)
Return Value
true if this instance is supported; otherwise, false.


Command Class

Command Class
Namespaces ► Sitecore.Shell.Framework.Commands ► Command
Defines the basic properties and functionality of a command.
Declaration Syntax
C#
[SerializableAttribute]
public abstract class Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Command()()() | Initializes a new instance of the Command class
 | CanWriteField(Item, ID) | Determines whether the specified field can be written to.
 | CanWriteField(Item, String) | Determines whether the specified field can be written to.
 | DeserializeItems(String) | Deserializes the item from a string list.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header.
 | GetIcon(CommandContext, String) | Gets the icon.
 | GetSubmenuItems(CommandContext) | Gets the submenu items.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value.
 | HasField(Item, ID) | Determines whether the specified item has the specified field.
 | HasField(Item, String) | Determines whether the specified item has the specified field.
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client.
 | IsLockedByOther(Item) | Determines whether [is lock by other] [the specified item].
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name.
 | QueryState(CommandContext) | Queries the state of the command.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list.
 | Start(String, Item) | Starts the specified pipeline.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AuthoringFeedback
 |  | RunLookup
 |  | EmailReport
 |  | OpenAnalyticsReports
 |  | Status
 |  | SynchronizeDatabase
 |  | OpenTrackingField
 |  | ViewTrackingDetails
 |  | RunVisitorIdentifications
 |  | SelectColumns
 |  | AddFromMaster
 |  | AddFromTemplate
 |  | AddMaster
 |  | AddTemplateField
 |  | AddVersion
 |  | Archive
 |  | ArchiveDateClear
 |  | ArchiveDateSet
 |  | Delete
 |  | Empty
 |  | Refresh
 |  | Restore
 |  | ShowSystemItems
 |  | Home
 |  | Refresh
 |  | ChangePassword
 |  | ChangeTemplate
 |  | CheckIn
 |  | CheckOut
 |  | ClientEventCommand
 |  | CopyIDToClipboard
 |  | CopyPathToClipboard
 |  | ClipboardCommand
 |  | CompareVersions
 |  | Archive
 |  | Back
 |  | Close
 |  | ClosePreview
 |  | EditImage
 |  | Edit
 |  | Forward
 |  | Home
 |  | IncrementMark
 |  | OpenItem
 |  | OpenSecurity
 |  | PageDesigner
 |  | Preview
 |  | Properties
 |  | Reminder
 |  | Save
 |  | SaveAndClose
 |  | SetIcon
 |  | ShowFavorites
 |  | ShowLinks
 |  | ShowValidationResult
 |  | ShowWorkflowCommands
 |  | Subitems
 |  | ToggleEntireTree
 |  | ToggleFolders
 |  | ToggleHiddenItems
 |  | ToggleRawValues
 |  | ToggleStandardFields
 |  | ToggleTranslate
 |  | Up
 |  | ValidatorCommand
 |  | CopyTo
 |  | Create
 |  | CreateNewRole
 |  | CreateNewUser
 |  | CleanUp
 |  | Delete
 |  | DeleteChildren
 |  | DeleteTemplateField
 |  | DeleteVersion
 |  | DesignItem
 |  | DeleteDomain
 |  | EditDomain
 |  | NewDomain
 |  | Download
 |  | Duplicate
 |  | Edit
 |  | Empty
 |  | ExportLanguage
 |  | Add
 |  | Organize
 |  | ShowMenu
 |  | GotoMaster
 |  | GotoTemplate
 |  | CreateFile
 |  | Crop
 |  | FlipHorizontal
 |  | FlipVertical
 |  | Open
 |  | Redo
 |  | Resize
 |  | RotateLeft
 |  | RotateRight
 |  | Save
 |  | Undo
 |  | ImportLanguage
 |  | ItemNew
 |  | ChangeDomain
 |  | New
 |  | Reset
 |  | BatchUpload
 |  | Download
 |  | MultiUpload
 |  | NewFolder
 |  | Play
 |  | Upload
 |  | View
 |  | MessageCommand
 |  | MethodCommand
 |  | MoveDown
 |  | MoveFirst
 |  | MoveLast
 |  | MoveTo
 |  | MoveUp
 |  | MyItems
 |  | NewFolder
 |  | OpenSecurityEditor
 |  | OpenSecurityManager
 |  | ChangeRegionalSettings
 |  | ChangeUserInformation
 |  | ChangeWallPaper
 |  | PreviewItem
 |  | PublishingViewer
 |  | PublishItem
 |  | PublishNow
 |  | ReminderClear
 |  | ReminderSet
 |  | RemoveLanguage
 |  | Rename
 |  | ResetDefaultWorkflow
 |  | ResetFields
 |  | ResetSortorder
 |  | Customize
 |  | Languages
 |  | Layout
 |  | New
 |  | Security
 |  | AddMember
 |  | AddMemberOf
 |  | Delete
 |  | NewRole
 |  | RemoveMember
 |  | RemoveMemberOf
 |  | ViewMembers
 |  | ViewParentRoles
 |  | ChangeDomain
 |  | ChangeUser
 |  | SelectColumns
 |  | SecurityPreset
 |  | SelectIcon
 |  | SelectLanguage
 |  | BaseLoadCommand
 |  | DumpItemCommand
 |  | DumpRoleCommand
 |  | DumpTemplatesCommand
 |  | DumpUserCommand
 |  | LoadAllRolesCommand
 |  | RestoreDatabaseCommand
 |  | SetAliases
 |  | SetContextMenu
 |  | SetCustomEditors
 |  | SetDefaultWorkflow
 |  | SetDisplayName
 |  | SetHelp
 |  | SetIcon
 |  | SetLayoutDetails
 |  | SetMasters
 |  | SetOwner
 |  | SetPublishing
 |  | SetRibbon
 |  | SetSubitemsSorting
 |  | SetTreeNodeStyle
 |  | AccessViewer
 |  | Audit
 |  | AutoDoc
 |  | DomainManager
 |  | EditImage
 |  | EditTemplate
 |  | LogViewer
 |  | RoleManager
 |  | Search
 |  | SecurityEditor
 |  | UserManager
 |  | UserOptions
 |  | ShowVersions
 |  | AddLanguage
 |  | BrokenLinks
 |  | CompareDatabases
 |  | DatabaseUsage
 |  | Debug
 |  | DeleteLanguage
 |  | InstallPackage
 |  | Logout
 |  | OpenWebSite
 |  | Preview
 |  | Publish
 |  | RebuildDatabase
 |  | RebuildLinkDatabase
 |  | RebuildSearchIndex
 |  | RunProgram
 |  | Search
 |  | ShowAbout
 |  | ShowLicenses
 |  | WebEdit
 |  | Build
 |  | MoveDown
 |  | MoveFirst
 |  | MoveLast
 |  | MoveUp
 |  | NewMaster
 |  | Remove
 |  | SetBaseTemplates
 |  | SetStandardValues
 |  | AddField
 |  | AddMaster
 |  | AddSection
 |  | CreateStandardValues
 |  | New
 |  | NewFolder
 |  | ToggleHidden
 |  | ToggleReadOnly
 |  | TransferToDatabase
 |  | UntranslatedFields
 |  | Upload
 |  | ChangeAccount
 |  | ChangeDomain
 |  | Delete
 |  | Disable
 |  | EditUser
 |  | Enable
 |  | NewUser
 |  | OpenItemSecurityEditor
 |  | ResetMySettings
 |  | ResetSettings
 |  | SelectAccount
 |  | SetPassword
 |  | Unlock
 |  | ChangeLanguage
 |  | Logout
 |  | Preview
 |  | Logout
 |  | Workflow


Command Constructor

Command Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► Command()()()
Initializes a new instance of the Command class
Declaration Syntax
C#
protected Command()


CanWriteField Method

CanWriteField Method
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► CanWriteField()()()
Members
Icon | Member | Description
 | CanWriteField(Item, ID) | Determines whether the specified field can be written to.
 | CanWriteField(Item, String) | Determines whether the specified field can be written to.


CanWriteField Method (item, fieldID)

CanWriteField Method (item, fieldID)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► CanWriteField(Item, ID)
Determines whether the specified field can be written to.
Declaration Syntax
C#
protected static bool CanWriteField(
    Item item,
    ID fieldID
)
Parameters
item (Item)
The item.
fieldID (ID)
The date.
Return Value
true if the specified field can be written to; otherwise, false.


CanWriteField Method (item, fieldName)

CanWriteField Method (item, fieldName)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► CanWriteField(Item, String)
Determines whether the specified field can be written to.
Declaration Syntax
C#
protected static bool CanWriteField(
    Item item,
    string fieldName
)
Parameters
item (Item)
The item.
fieldName (String)
Name of the field.
Return Value
true if the specified field can be written to; otherwise, false.


DeserializeItems Method (list)

DeserializeItems Method (list)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► DeserializeItems(String)
Deserializes the item from a string list.
Declaration Syntax
C#
protected Item[] DeserializeItems(
    string list
)
Parameters
list (String)
The list.
Return Value
The items.


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public abstract void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public virtual string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


GetHeader Method (context, header)

GetHeader Method (context, header)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► GetHeader(CommandContext, String)
Gets the header.
Declaration Syntax
C#
public virtual string GetHeader(
    CommandContext context,
    string header
)
Parameters
context (CommandContext)
The context.
header (String)
The default header.
Return Value
The header.


GetIcon Method (context, icon)

GetIcon Method (context, icon)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► GetIcon(CommandContext, String)
Gets the icon.
Declaration Syntax
C#
public virtual string GetIcon(
    CommandContext context,
    string icon
)
Parameters
context (CommandContext)
The context.
icon (String)
The default icon.
Return Value
The icon.


GetSubmenuItems Method (context)

GetSubmenuItems Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► GetSubmenuItems(CommandContext)
Gets the submenu items.
Declaration Syntax
C#
public virtual Control[] GetSubmenuItems(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The submenu.


GetValue Method (context, value)

GetValue Method (context, value)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► GetValue(CommandContext, String)
Gets the value.
Declaration Syntax
C#
public virtual string GetValue(
    CommandContext context,
    string value
)
Parameters
context (CommandContext)
The context.
value (String)
The value.
Return Value
The value.


HasField Method

HasField Method
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► HasField()()()
Members
Icon | Member | Description
 | HasField(Item, ID) | Determines whether the specified item has the specified field.
 | HasField(Item, String) | Determines whether the specified item has the specified field.


HasField Method (item, fieldID)

HasField Method (item, fieldID)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► HasField(Item, ID)
Determines whether the specified item has the specified field.
Declaration Syntax
C#
protected bool HasField(
    Item item,
    ID fieldID
)
Parameters
item (Item)
The item.
fieldID (ID)
The field ID.
Return Value
true if the specified item has the specified field; otherwise, false.


HasField Method (item, fieldName)

HasField Method (item, fieldName)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► HasField(Item, String)
Determines whether the specified item has the specified field.
Declaration Syntax
C#
protected bool HasField(
    Item item,
    string fieldName
)
Parameters
item (Item)
The item.
fieldName (String)
Name of the field.
Return Value
true if the specified item has the specified field; otherwise, false.


IsAdvancedClient Method

IsAdvancedClient Method
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► IsAdvancedClient()()()
Determines whether this browser is an advanced client.
Declaration Syntax
C#
protected bool IsAdvancedClient()
Return Value
true if this browser is an advanced client; otherwise, false.


IsLockedByOther Method (item)

IsLockedByOther Method (item)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► IsLockedByOther(Item)
Determines whether [is lock by other] [the specified item].
Declaration Syntax
C#
protected static bool IsLockedByOther(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if [is lock by other] [the specified item]; otherwise, false.


Name Property

Name Property
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► Name
Gets or sets the name.
Declaration Syntax
C#
public string Name { get; internal set; }
Value
The name.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public virtual CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


SerializeItems Method (items)

SerializeItems Method (items)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► SerializeItems(array<Item>[]()[])
Serializes the items to a string list.
Declaration Syntax
C#
protected string SerializeItems(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.
Return Value
A string representing the items.


Start Method (pipelineName, item)

Start Method (pipelineName, item)
Namespaces ► Sitecore.Shell.Framework.Commands ► Command ► Start(String, Item)
Starts the specified pipeline.
Declaration Syntax
C#
protected NameValueCollection Start(
    string pipelineName,
    Item item
)
Parameters
pipelineName (String)
Name of the pipeline.
item (Item)
The item.
Return Value
A NameValueCollection of parameters.


CommandContext Class

CommandContext Class
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandContext
Represents the context in which a command is executes.
Declaration Syntax
C#
public class CommandContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandContext()()() | Initializes a new instance of the CommandContext class.
 | CommandContext(Item) | Initializes a new instance of the CommandContext class.
 | CommandContext(array<Item>[]()[]) | Initializes a new instance of the CommandContext class.
 | CustomData | Gets or sets the custom data.
 | Empty | Gets the empty command context.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Folder | Gets or sets the folder.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItems()()() | Gets the items.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsContextMenu | Gets or sets a value indicating whether this instance is context menu.
 | Items | Gets the items.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets the parameters.
 | RibbonSourceUri | Gets or sets the ribbon source URI.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CommandContext


CommandContext Constructor

CommandContext Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandContext ► CommandContext()()()
Members
Icon | Member | Description
 | CommandContext()()() | Initializes a new instance of the CommandContext class.
 | CommandContext(Item) | Initializes a new instance of the CommandContext class.
 | CommandContext(array<Item>[]()[]) | Initializes a new instance of the CommandContext class.


CommandContext Constructor

CommandContext Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandContext ► CommandContext()()()
Initializes a new instance of the CommandContext class.
Declaration Syntax
C#
public CommandContext()


CommandContext Constructor (item)

CommandContext Constructor (item)
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandContext ► CommandContext(Item)
Initializes a new instance of the CommandContext class.
Declaration Syntax
C#
public CommandContext(
    Item item
)
Parameters
item (Item)
The item.


CommandContext Constructor (items)

CommandContext Constructor (items)
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandContext ► CommandContext(array<Item>[]()[])
Initializes a new instance of the CommandContext class.
Declaration Syntax
C#
public CommandContext(
    Item[] items
)
Parameters
items (array< Item >[]()[])
The items.


CustomData Property

CustomData Property
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandContext ► CustomData
Gets or sets the custom data.
Declaration Syntax
C#
public Object CustomData { get; set; }
Value
The custom data.


Empty Property

Empty Property
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandContext ► Empty
Gets the empty command context.
Declaration Syntax
C#
public static CommandContext Empty { get; }
Value
The empty command context.


Folder Property

Folder Property
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandContext ► Folder
Gets or sets the folder.
Declaration Syntax
C#
public Item Folder { get; set; }
Value
The folder.


GetItems Method

GetItems Method
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandContext ► GetItems()()()
Gets the items.
Declaration Syntax
C#
protected virtual Item[] GetItems()
Return Value


IsContextMenu Property

IsContextMenu Property
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandContext ► IsContextMenu
Gets or sets a value indicating whether this instance is context menu.
Declaration Syntax
C#
public bool IsContextMenu { get; set; }
Value
true if this instance is context menu; otherwise, false.


Items Property

Items Property
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandContext ► Items
Gets the items.
Declaration Syntax
C#
public Item[] Items { get; }
Value
The items.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandContext ► Parameters
Gets the parameters.
Declaration Syntax
C#
public NameValueCollection Parameters { get; }
Value
The parameters.


RibbonSourceUri Property

RibbonSourceUri Property
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandContext ► RibbonSourceUri
Gets or sets the ribbon source URI.
Declaration Syntax
C#
public ItemUri RibbonSourceUri { get; set; }
Value
The ribbon source URI.


CommandManager Class

CommandManager Class
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandManager
Manages commands.
Declaration Syntax
C#
public static class CommandManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Empty | Gets the empty command.
 | GetCommand(String) | Gets the command.
 | GetCommandName(Command) | Gets the name of the command.
 | QueryState(String, Item) | Queries the state of a named command.
 | QueryState(String, array<Item>[]()[]) | Queries the state of a named command.
 | QueryState(Command, CommandContext) | Queries the state of a command.
 | QueryStateForButton(Item, CommandContext) | Queries the state for command buttons that don't have command assigned.
 | RegisterCommand(String, Command) | Registers a new command.
Inheritance Hierarchy
Object
CommandManager


Empty Property

Empty Property
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandManager ► Empty
Gets the empty command.
Declaration Syntax
C#
public static Command Empty { get; }
Value
The empty command.


GetCommand Method (name)

GetCommand Method (name)
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandManager ► GetCommand(String)
Gets the command.
Declaration Syntax
C#
public static Command GetCommand(
    string name
)
Parameters
name (String)
The name.
Return Value


GetCommandName Method (command)

GetCommandName Method (command)
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandManager ► GetCommandName(Command)
Gets the name of the command.
Declaration Syntax
C#
public static string GetCommandName(
    Command command
)
Parameters
command (Command)
The command.
Return Value
The String.


QueryState Method

QueryState Method
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandManager ► QueryState()()()
Members
Icon | Member | Description
 | QueryState(String, Item) | Queries the state of a named command.
 | QueryState(String, array<Item>[]()[]) | Queries the state of a named command.
 | QueryState(Command, CommandContext) | Queries the state of a command.


QueryState Method (command, context)

QueryState Method (command, context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandManager ► QueryState(Command, CommandContext)
Queries the state of a command.
Declaration Syntax
C#
public static CommandState QueryState(
    Command command,
    CommandContext context
)
Parameters
command (Command)
The command.
context (CommandContext)
The command context.
Return Value
The Command State.


QueryState Method (command, item)

QueryState Method (command, item)
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandManager ► QueryState(String, Item)
Queries the state of a named command.
Declaration Syntax
C#
public static CommandState QueryState(
    string command,
    Item item
)
Parameters
command (String)
The command.
item (Item)
The item.
Return Value


QueryState Method (command, items)

QueryState Method (command, items)
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandManager ► QueryState(String, array<Item>[]()[])
Queries the state of a named command.
Declaration Syntax
C#
public static CommandState QueryState(
    string command,
    Item[] items
)
Parameters
command (String)
The command.
items (array< Item >[]()[])
The items.
Return Value


QueryStateForButton Method (button, context)

QueryStateForButton Method (button, context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandManager ► QueryStateForButton(Item, CommandContext)
Queries the state for command buttons that don't have command assigned.
Declaration Syntax
C#
public static CommandState QueryStateForButton(
    Item button,
    CommandContext context
)
Parameters
button (Item)
The command button.
context (CommandContext)
The command context.
Return Value
The Command State.


RegisterCommand Method (name, command)

RegisterCommand Method (name, command)
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandManager ► RegisterCommand(String, Command)
Registers a new command.
Declaration Syntax
C#
public static void RegisterCommand(
    string name,
    Command command
)
Parameters
name (String)
The name.
command (Command)
The command.


Commands Class

Commands Class
Namespaces ► Sitecore.Shell.Framework.Commands ► Commands
Represents a list of commands.
Declaration Syntax
C#
public class Commands : List<Command>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Commands()()() | Initializes a new instance of the Commands class
 | Add(T) | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | AddRange(IEnumerable<(Of <(T>)>)) | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | AsReadOnly()()() | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List<(Of <( Command >)>).)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( Command >)>).)
 | BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List<(Of <( Command >)>).)
 | BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( Command >)>).)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <( Command >)>).)
 | Clear()()() | Removes all elements from the List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | Contains(T) | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | ConvertAll<(Of <(TOutput>)>)(Converter<(Of <(T, TOutput>)>)) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List<(Of <( Command >)>).)
 | CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List<(Of <( Command >)>).)
 | CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( Command >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( Command >)>).)
 | Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <(T>)>)) | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( Command >)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | FindAll(Predicate<(Of <(T>)>)) | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( Command >)>).)
 | FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( Command >)>).)
 | FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( Command >)>).)
 | FindLast(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( Command >)>).)
 | FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( Command >)>).)
 | ForEach(Action<(Of <(T>)>)) | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( Command >)>).)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( Command >)>).)
 | Insert(Int32, T) | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( Command >)>).)
 | InsertRange(Int32, IEnumerable<(Of <(T>)>)) | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( Command >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from List<(Of <( Command >)>).)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( Command >)>).)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( Command >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | RemoveAll(Predicate<(Of <(T>)>)) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( Command >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List<(Of <( Command >)>).)
 | Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List<(Of <( Command >)>).)
 | Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( Command >)>).)
 | Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( Command >)>).)
 | Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List<(Of <( Command >)>).)
 | ToArray()()() | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List<(Of <( Command >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()()() | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List<(Of <( Command >)>).)
 | TrueForAll(Predicate<(Of <(T>)>)) | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List<(Of <( Command >)>).)
Inheritance Hierarchy
Object
 | List<(Of <( Command >)>)
 |  | Commands


Commands Constructor

Commands Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► Commands ► Commands()()()
Initializes a new instance of the Commands class
Declaration Syntax
C#
public Commands()


CommandState Enumeration

CommandState Enumeration
Namespaces ► Sitecore.Shell.Framework.Commands ► CommandState
Represents the state of a command.
Declaration Syntax
C#
public enum CommandState
Members
Member | Description
Enabled | Enabled.
Down | Down (enabled).
Disabled | Disabled.
Hidden | Hidden.


CompareVersions Class

CompareVersions Class
Namespaces ► Sitecore.Shell.Framework.Commands ► CompareVersions
Represents the CompareVersions command.
Declaration Syntax
C#
[SerializableAttribute]
public class CompareVersions : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompareVersions()()() | Initializes a new instance of the CompareVersions class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | CompareVersions


CompareVersions Constructor

CompareVersions Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► CompareVersions ► CompareVersions()()()
Initializes a new instance of the CompareVersions class
Declaration Syntax
C#
public CompareVersions()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CompareVersions ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CompareVersions ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


CopyTo Class

CopyTo Class
Namespaces ► Sitecore.Shell.Framework.Commands ► CopyTo
Represents the CopyTo command.
Declaration Syntax
C#
[SerializableAttribute]
public class CopyTo : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CopyTo()()() | Initializes a new instance of the CopyTo class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | CopyTo


CopyTo Constructor

CopyTo Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► CopyTo ► CopyTo()()()
Initializes a new instance of the CopyTo class
Declaration Syntax
C#
public CopyTo()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CopyTo ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CopyTo ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


CopyToClipboard Class

CopyToClipboard Class
Namespaces ► Sitecore.Shell.Framework.Commands ► CopyToClipboard
Represents the CopyToClipboard command.
Declaration Syntax
C#
[SerializableAttribute]
public class CopyToClipboard : ClipboardCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CopyToClipboard()()() | Initializes a new instance of the CopyToClipboard class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ClipboardCommand
 |  |  | CopyToClipboard


CopyToClipboard Constructor

CopyToClipboard Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► CopyToClipboard ► CopyToClipboard()()()
Initializes a new instance of the CopyToClipboard class
Declaration Syntax
C#
public CopyToClipboard()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CopyToClipboard ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CopyToClipboard ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Create Class

Create Class
Namespaces ► Sitecore.Shell.Framework.Commands ► Create
Represents the Create command.
Declaration Syntax
C#
[SerializableAttribute]
public class Create : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Create()()() | Initializes a new instance of the Create class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Create


Create Constructor

Create Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► Create ► Create()()()
Initializes a new instance of the Create class
Declaration Syntax
C#
public Create()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Create ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Create ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► Create ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CreateNewRole Class

CreateNewRole Class
Namespaces ► Sitecore.Shell.Framework.Commands ► CreateNewRole
Represents the CreateNewRole command.
Declaration Syntax
C#
[SerializableAttribute]
public class CreateNewRole : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateNewRole()()() | Initializes a new instance of the CreateNewRole class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | CreateNewRole


CreateNewRole Constructor

CreateNewRole Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► CreateNewRole ► CreateNewRole()()()
Initializes a new instance of the CreateNewRole class
Declaration Syntax
C#
public CreateNewRole()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CreateNewRole ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


CreateNewUser Class

CreateNewUser Class
Namespaces ► Sitecore.Shell.Framework.Commands ► CreateNewUser
Represents the CreateNewUser command.
Declaration Syntax
C#
[SerializableAttribute]
[ObsoleteAttribute("Sitecore.Shell.Framework.Commands.UserManager.NewUser is used instead")]
public class CreateNewUser : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateNewUser()()() | Initializes a new instance of the CreateNewUser class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | CreateNewUser


CreateNewUser Constructor

CreateNewUser Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► CreateNewUser ► CreateNewUser()()()
Initializes a new instance of the CreateNewUser class
Declaration Syntax
C#
public CreateNewUser()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CreateNewUser ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


CutToClipboard Class

CutToClipboard Class
Namespaces ► Sitecore.Shell.Framework.Commands ► CutToClipboard
Represents the CutToClipboard command.
Declaration Syntax
C#
[SerializableAttribute]
public class CutToClipboard : ClipboardCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CutToClipboard()()() | Initializes a new instance of the CutToClipboard class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ClipboardCommand
 |  |  | CutToClipboard


CutToClipboard Constructor

CutToClipboard Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► CutToClipboard ► CutToClipboard()()()
Initializes a new instance of the CutToClipboard class
Declaration Syntax
C#
public CutToClipboard()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CutToClipboard ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► CutToClipboard ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Delete Class

Delete Class
Namespaces ► Sitecore.Shell.Framework.Commands ► Delete
Represents the Delete command.
Declaration Syntax
C#
[SerializableAttribute]
public class Delete : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Delete()()() | Initializes a new instance of the Delete class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Delete


Delete Constructor

Delete Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► Delete ► Delete()()()
Initializes a new instance of the Delete class
Declaration Syntax
C#
public Delete()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Delete ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Delete ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


DeleteChildren Class

DeleteChildren Class
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteChildren
Represents the DeleteChildren command.
Declaration Syntax
C#
[SerializableAttribute]
public class DeleteChildren : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteChildren()()() | Initializes a new instance of the DeleteChildren class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | DeleteChildren


DeleteChildren Constructor

DeleteChildren Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteChildren ► DeleteChildren()()()
Initializes a new instance of the DeleteChildren class
Declaration Syntax
C#
public DeleteChildren()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteChildren ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteChildren ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


DeleteTemplateField Class

DeleteTemplateField Class
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteTemplateField
Represents the DeleteTemplateField command.
Declaration Syntax
C#
[SerializableAttribute]
public class DeleteTemplateField : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteTemplateField()()() | Initializes a new instance of the DeleteTemplateField class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | DeleteTemplateField


DeleteTemplateField Constructor

DeleteTemplateField Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteTemplateField ► DeleteTemplateField()()()
Initializes a new instance of the DeleteTemplateField class
Declaration Syntax
C#
public DeleteTemplateField()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteTemplateField ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteTemplateField ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteTemplateField ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


DeleteVersion Class

DeleteVersion Class
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteVersion
Removes a version
Declaration Syntax
C#
[SerializableAttribute]
public class DeleteVersion : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteVersion()()() | Initializes a new instance of the DeleteVersion class
 | Confirmation(ClientPipelineArgs) | Asks for confirmation before removing.
 | DeleteVersions(ClientPipelineArgs) | Deletes the versions.
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | DeleteVersion


DeleteVersion Constructor

DeleteVersion Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteVersion ► DeleteVersion()()()
Initializes a new instance of the DeleteVersion class
Declaration Syntax
C#
public DeleteVersion()


Confirmation Method (args)

Confirmation Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteVersion ► Confirmation(ClientPipelineArgs)
Asks for confirmation before removing.
Declaration Syntax
C#
protected void Confirmation(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


DeleteVersions Method (args)

DeleteVersions Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteVersion ► DeleteVersions(ClientPipelineArgs)
Deletes the versions.
Declaration Syntax
C#
protected void DeleteVersions(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteVersion ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► DeleteVersion ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


DesignItem Class

DesignItem Class
Namespaces ► Sitecore.Shell.Framework.Commands ► DesignItem
Represents the Preview Item command.
Declaration Syntax
C#
[SerializableAttribute]
public class DesignItem : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DesignItem()()() | Initializes a new instance of the DesignItem class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | DesignItem


DesignItem Constructor

DesignItem Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► DesignItem ► DesignItem()()()
Initializes a new instance of the DesignItem class
Declaration Syntax
C#
public DesignItem()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► DesignItem ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► DesignItem ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► DesignItem ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Download Class

Download Class
Namespaces ► Sitecore.Shell.Framework.Commands ► Download
Represents the Download command.
Declaration Syntax
C#
[SerializableAttribute]
public class Download : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Download()()() | Initializes a new instance of the Download class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Download


Download Constructor

Download Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► Download ► Download()()()
Initializes a new instance of the Download class
Declaration Syntax
C#
public Download()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Download ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Duplicate Class

Duplicate Class
Namespaces ► Sitecore.Shell.Framework.Commands ► Duplicate
Represents the Duplicate command.
Declaration Syntax
C#
[SerializableAttribute]
public class Duplicate : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Duplicate()()() | Initializes a new instance of the Duplicate class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Duplicate


Duplicate Constructor

Duplicate Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► Duplicate ► Duplicate()()()
Initializes a new instance of the Duplicate class
Declaration Syntax
C#
public Duplicate()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Duplicate ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Duplicate ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Edit Class

Edit Class
Namespaces ► Sitecore.Shell.Framework.Commands ► Edit
Represents the Edit command.
Declaration Syntax
C#
[SerializableAttribute]
public class Edit : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Edit()()() | Initializes a new instance of the Edit class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Edit


Edit Constructor

Edit Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► Edit ► Edit()()()
Initializes a new instance of the Edit class
Declaration Syntax
C#
public Edit()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Edit ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Edit ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Empty Class

Empty Class
Namespaces ► Sitecore.Shell.Framework.Commands ► Empty
Represents the Empty command.
Declaration Syntax
C#
[SerializableAttribute]
public class Empty : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Empty()()() | Initializes a new instance of the Empty class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Empty


Empty Constructor

Empty Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► Empty ► Empty()()()
Initializes a new instance of the Empty class
Declaration Syntax
C#
public Empty()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Empty ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


ExportLanguage Class

ExportLanguage Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ExportLanguage
Represents the ExportLanguage command.
Declaration Syntax
C#
[SerializableAttribute]
public class ExportLanguage : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExportLanguage()()() | Initializes a new instance of the ExportLanguage class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ExportLanguage


ExportLanguage Constructor

ExportLanguage Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ExportLanguage ► ExportLanguage()()()
Initializes a new instance of the ExportLanguage class
Declaration Syntax
C#
public ExportLanguage()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ExportLanguage ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GotoMaster Class

GotoMaster Class
Namespaces ► Sitecore.Shell.Framework.Commands ► GotoMaster
Represents the Set Icon command.
Declaration Syntax
C#
[SerializableAttribute]
public class GotoMaster : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GotoMaster()()() | Initializes a new instance of the GotoMaster class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | GotoMaster


GotoMaster Constructor

GotoMaster Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► GotoMaster ► GotoMaster()()()
Initializes a new instance of the GotoMaster class
Declaration Syntax
C#
public GotoMaster()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► GotoMaster ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► GotoMaster ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


GotoTemplate Class

GotoTemplate Class
Namespaces ► Sitecore.Shell.Framework.Commands ► GotoTemplate
Represents the Set Icon command.
Declaration Syntax
C#
[SerializableAttribute]
public class GotoTemplate : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GotoTemplate()()() | Initializes a new instance of the GotoTemplate class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | GotoTemplate


GotoTemplate Constructor

GotoTemplate Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► GotoTemplate ► GotoTemplate()()()
Initializes a new instance of the GotoTemplate class
Declaration Syntax
C#
public GotoTemplate()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► GotoTemplate ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► GotoTemplate ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


IHasCommandContext Interface

IHasCommandContext Interface
Namespaces ► Sitecore.Shell.Framework.Commands ► IHasCommandContext
Represents a IHasCommandContext.
Declaration Syntax
C#
public interface IHasCommandContext
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetCommandContext()()() | Gets the command context.


GetCommandContext Method

GetCommandContext Method
Namespaces ► Sitecore.Shell.Framework.Commands ► IHasCommandContext ► GetCommandContext()()()
Gets the command context.
Declaration Syntax
C#
CommandContext GetCommandContext()
Return Value
The command context.


ImportLanguage Class

ImportLanguage Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ImportLanguage
Represents the ImportLanguage command.
Declaration Syntax
C#
[SerializableAttribute]
public class ImportLanguage : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImportLanguage()()() | Initializes a new instance of the ImportLanguage class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ImportLanguage


ImportLanguage Constructor

ImportLanguage Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ImportLanguage ► ImportLanguage()()()
Initializes a new instance of the ImportLanguage class
Declaration Syntax
C#
public ImportLanguage()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ImportLanguage ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


ItemNew Class

ItemNew Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ItemNew
Represents the ItemNew command.
Declaration Syntax
C#
[SerializableAttribute]
public class ItemNew : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemNew()()() | Initializes a new instance of the ItemNew class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Overrides Command.GetSubmenuItems(CommandContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ItemNew


ItemNew Constructor

ItemNew Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ItemNew ► ItemNew()()()
Initializes a new instance of the ItemNew class
Declaration Syntax
C#
public ItemNew()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ItemNew ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands ► ItemNew ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


GetSubmenuItems Method (context)

GetSubmenuItems Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ItemNew ► GetSubmenuItems(CommandContext)
Gets the submenu items.
Declaration Syntax
C#
public override Control[] GetSubmenuItems(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The submenu.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ItemNew ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


MessageCommand Class

MessageCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands ► MessageCommand
Represents a Message command.
Declaration Syntax
C#
[SerializableAttribute]
public class MessageCommand : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MessageCommand(Message) | Initializes a new instance of the MessageCommand class.
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message.
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | MessageCommand


MessageCommand Constructor (message)

MessageCommand Constructor (message)
Namespaces ► Sitecore.Shell.Framework.Commands ► MessageCommand ► MessageCommand(Message)
Initializes a new instance of the MessageCommand class.
Declaration Syntax
C#
public MessageCommand(
    Message message
)
Parameters
message (Message)
The message.


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MessageCommand ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Message Property

Message Property
Namespaces ► Sitecore.Shell.Framework.Commands ► MessageCommand ► Message
Gets the message.
Declaration Syntax
C#
public Message Message { get; }
Value
The message.


MethodCommand Class

MethodCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands ► MethodCommand
Represents the MethodCommand command.
Declaration Syntax
C#
[SerializableAttribute]
public class MethodCommand : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MethodCommand(Object, MethodInfo, array<String>[]()[]) | Initializes a new instance of the MethodCommand class.
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Method | Gets the method.
 | Name | Gets or sets the name. (Inherited from Command.)
 | Parameters | Gets the parameters.
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | Target | Gets the target.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | MethodCommand


MethodCommand Constructor (target, method, parameters)

MethodCommand Constructor (target, method, parameters)
Namespaces ► Sitecore.Shell.Framework.Commands ► MethodCommand ► MethodCommand(Object, MethodInfo, array<String>[]()[])
Initializes a new instance of the MethodCommand class.
Declaration Syntax
C#
public MethodCommand(
    Object target,
    MethodInfo method,
    string[] parameters
)
Parameters
target (Object)
The target.
method (MethodInfo)
The method.
parameters (array< String >[]()[])
The parameters.


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MethodCommand ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Method Property

Method Property
Namespaces ► Sitecore.Shell.Framework.Commands ► MethodCommand ► Method
Gets the method.
Declaration Syntax
C#
public MethodInfo Method { get; }
Value
The method.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Shell.Framework.Commands ► MethodCommand ► Parameters
Gets the parameters.
Declaration Syntax
C#
public string[] Parameters { get; }
Value
The parameters.


Target Property

Target Property
Namespaces ► Sitecore.Shell.Framework.Commands ► MethodCommand ► Target
Gets the target.
Declaration Syntax
C#
public Object Target { get; }
Value
The target.


MethodCommandArgs Class

MethodCommandArgs Class
Namespaces ► Sitecore.Shell.Framework.Commands ► MethodCommandArgs
Represents the arguments of a Method Command.
Declaration Syntax
C#
[SerializableAttribute]
public class MethodCommandArgs : ClientPipelineArgs,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MethodCommandArgs()()() | Initializes a new instance of the MethodCommandArgs class.
 | MethodCommandArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemLinksPipelineArgs class from a serialization context.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | MethodParameters | Gets or sets the method parameters.
 | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from ClientPipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
 | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitForPostBack()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ClientPipelineArgs
 |  |  |  | MethodCommandArgs


MethodCommandArgs Constructor

MethodCommandArgs Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► MethodCommandArgs ► MethodCommandArgs()()()
Members
Icon | Member | Description
 | MethodCommandArgs()()() | Initializes a new instance of the MethodCommandArgs class.
 | MethodCommandArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemLinksPipelineArgs class from a serialization context.


MethodCommandArgs Constructor

MethodCommandArgs Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► MethodCommandArgs ► MethodCommandArgs()()()
Initializes a new instance of the MethodCommandArgs class.
Declaration Syntax
C#
public MethodCommandArgs()


MethodCommandArgs Constructor (info, context)

MethodCommandArgs Constructor (info, context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MethodCommandArgs ► MethodCommandArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the ItemLinksPipelineArgs class from a serialization context.
Declaration Syntax
C#
protected MethodCommandArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialized data.
context (StreamingContext)
The context.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MethodCommandArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


MethodParameters Property

MethodParameters Property
Namespaces ► Sitecore.Shell.Framework.Commands ► MethodCommandArgs ► MethodParameters
Gets or sets the method parameters.
Declaration Syntax
C#
public string[] MethodParameters { get; set; }
Value
The method parameters.


MoveDown Class

MoveDown Class
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveDown
Sorts the items after next.
Declaration Syntax
C#
[SerializableAttribute]
public class MoveDown : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MoveDown()()() | Initializes a new instance of the MoveDown class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | MoveDown


MoveDown Constructor

MoveDown Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveDown ► MoveDown()()()
Initializes a new instance of the MoveDown class
Declaration Syntax
C#
public MoveDown()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveDown ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveDown ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveDown ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


MoveFirst Class

MoveFirst Class
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveFirst
Sorts the item first.
Declaration Syntax
C#
[SerializableAttribute]
public class MoveFirst : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MoveFirst()()() | Initializes a new instance of the MoveFirst class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | MoveFirst


MoveFirst Constructor

MoveFirst Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveFirst ► MoveFirst()()()
Initializes a new instance of the MoveFirst class
Declaration Syntax
C#
public MoveFirst()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveFirst ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveFirst ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveFirst ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


MoveLast Class

MoveLast Class
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveLast
Sorts the item last.
Declaration Syntax
C#
[SerializableAttribute]
public class MoveLast : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MoveLast()()() | Initializes a new instance of the MoveLast class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | MoveLast


MoveLast Constructor

MoveLast Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveLast ► MoveLast()()()
Initializes a new instance of the MoveLast class
Declaration Syntax
C#
public MoveLast()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveLast ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveLast ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveLast ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


MoveTo Class

MoveTo Class
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveTo
Represents the Move To command.
Declaration Syntax
C#
[SerializableAttribute]
public class MoveTo : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MoveTo()()() | Initializes a new instance of the MoveTo class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | MoveTo


MoveTo Constructor

MoveTo Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveTo ► MoveTo()()()
Initializes a new instance of the MoveTo class
Declaration Syntax
C#
public MoveTo()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveTo ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveTo ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


MoveUp Class

MoveUp Class
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveUp
Sorts the items before previous.
Declaration Syntax
C#
[SerializableAttribute]
public class MoveUp : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MoveUp()()() | Initializes a new instance of the MoveUp class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | MoveUp


MoveUp Constructor

MoveUp Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveUp ► MoveUp()()()
Initializes a new instance of the MoveUp class
Declaration Syntax
C#
public MoveUp()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveUp ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveUp ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► MoveUp ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


MyItems Class

MyItems Class
Namespaces ► Sitecore.Shell.Framework.Commands ► MyItems
Represents a ResetSortorder command.
Declaration Syntax
C#
[SerializableAttribute]
public class MyItems : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyItems()()() | Initializes a new instance of the MyItems class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | MyItems


MyItems Constructor

MyItems Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► MyItems ► MyItems()()()
Initializes a new instance of the MyItems class
Declaration Syntax
C#
public MyItems()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► MyItems ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


NewFolder Class

NewFolder Class
Namespaces ► Sitecore.Shell.Framework.Commands ► NewFolder
Represents the NewFolder command.
Declaration Syntax
C#
[SerializableAttribute]
public class NewFolder : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NewFolder()()() | Initializes a new instance of the NewFolder class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | NewFolder


NewFolder Constructor

NewFolder Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► NewFolder ► NewFolder()()()
Initializes a new instance of the NewFolder class
Declaration Syntax
C#
public NewFolder()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► NewFolder ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► NewFolder ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


OpenSecurityEditor Class

OpenSecurityEditor Class
Namespaces ► Sitecore.Shell.Framework.Commands ► OpenSecurityEditor
Represents the Open Security Editor command.
Declaration Syntax
C#
[SerializableAttribute]
public class OpenSecurityEditor : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OpenSecurityEditor()()() | Initializes a new instance of the OpenSecurityEditor class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | OpenSecurityEditor


OpenSecurityEditor Constructor

OpenSecurityEditor Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► OpenSecurityEditor ► OpenSecurityEditor()()()
Initializes a new instance of the OpenSecurityEditor class
Declaration Syntax
C#
public OpenSecurityEditor()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► OpenSecurityEditor ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► OpenSecurityEditor ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


OpenSecurityManager Class

OpenSecurityManager Class
Namespaces ► Sitecore.Shell.Framework.Commands ► OpenSecurityManager
Represents the Open Security Manager command.
Declaration Syntax
C#
[SerializableAttribute]
public class OpenSecurityManager : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OpenSecurityManager()()() | Initializes a new instance of the OpenSecurityManager class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | OpenSecurityManager


OpenSecurityManager Constructor

OpenSecurityManager Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► OpenSecurityManager ► OpenSecurityManager()()()
Initializes a new instance of the OpenSecurityManager class
Declaration Syntax
C#
public OpenSecurityManager()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► OpenSecurityManager ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► OpenSecurityManager ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


PasteFromClipboard Class

PasteFromClipboard Class
Namespaces ► Sitecore.Shell.Framework.Commands ► PasteFromClipboard
Represents the Paste From Clipboard command.
Declaration Syntax
C#
[SerializableAttribute]
public class PasteFromClipboard : ClipboardCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PasteFromClipboard()()() | Initializes a new instance of the PasteFromClipboard class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ClipboardCommand
 |  |  | PasteFromClipboard


PasteFromClipboard Constructor

PasteFromClipboard Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► PasteFromClipboard ► PasteFromClipboard()()()
Initializes a new instance of the PasteFromClipboard class
Declaration Syntax
C#
public PasteFromClipboard()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► PasteFromClipboard ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► PasteFromClipboard ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► PasteFromClipboard ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


PreviewItem Class

PreviewItem Class
Namespaces ► Sitecore.Shell.Framework.Commands ► PreviewItem
Represents the Preview Item command.
Declaration Syntax
C#
[SerializableAttribute]
public class PreviewItem : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PreviewItem()()() | Initializes a new instance of the PreviewItem class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | PreviewItem


PreviewItem Constructor

PreviewItem Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► PreviewItem ► PreviewItem()()()
Initializes a new instance of the PreviewItem class
Declaration Syntax
C#
public PreviewItem()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► PreviewItem ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► PreviewItem ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► PreviewItem ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


PublishingViewer Class

PublishingViewer Class
Namespaces ► Sitecore.Shell.Framework.Commands ► PublishingViewer
Represents the Publishing Viewer command.
Declaration Syntax
C#
[SerializableAttribute]
public class PublishingViewer : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishingViewer()()() | Initializes a new instance of the PublishingViewer class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | PublishingViewer


PublishingViewer Constructor

PublishingViewer Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► PublishingViewer ► PublishingViewer()()()
Initializes a new instance of the PublishingViewer class
Declaration Syntax
C#
public PublishingViewer()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► PublishingViewer ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► PublishingViewer ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


PublishItem Class

PublishItem Class
Namespaces ► Sitecore.Shell.Framework.Commands ► PublishItem
Represents the Publish Item command.
Declaration Syntax
C#
[SerializableAttribute]
public class PublishItem : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishItem()()() | Initializes a new instance of the PublishItem class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | PublishItem


PublishItem Constructor

PublishItem Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► PublishItem ► PublishItem()()()
Initializes a new instance of the PublishItem class
Declaration Syntax
C#
public PublishItem()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► PublishItem ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► PublishItem ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► PublishItem ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


PublishNow Class

PublishNow Class
Namespaces ► Sitecore.Shell.Framework.Commands ► PublishNow
Represents the Publish Now command.
Declaration Syntax
C#
[SerializableAttribute]
public class PublishNow : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishNow()()() | Initializes a new instance of the PublishNow class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | PublishNow


PublishNow Constructor

PublishNow Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► PublishNow ► PublishNow()()()
Initializes a new instance of the PublishNow class
Declaration Syntax
C#
public PublishNow()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► PublishNow ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► PublishNow ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► PublishNow ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


ReminderClear Class

ReminderClear Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ReminderClear
Represents the Reminder Clear command.
Declaration Syntax
C#
[SerializableAttribute]
public class ReminderClear : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReminderClear()()() | Initializes a new instance of the ReminderClear class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ReminderClear


ReminderClear Constructor

ReminderClear Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ReminderClear ► ReminderClear()()()
Initializes a new instance of the ReminderClear class
Declaration Syntax
C#
public ReminderClear()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ReminderClear ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ReminderClear ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


ReminderSet Class

ReminderSet Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ReminderSet
Represents the Reminder Set command.
Declaration Syntax
C#
[SerializableAttribute]
public class ReminderSet : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReminderSet()()() | Initializes a new instance of the ReminderSet class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ReminderSet


ReminderSet Constructor

ReminderSet Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ReminderSet ► ReminderSet()()()
Initializes a new instance of the ReminderSet class
Declaration Syntax
C#
public ReminderSet()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ReminderSet ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ReminderSet ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► ReminderSet ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


RemoveLanguage Class

RemoveLanguage Class
Namespaces ► Sitecore.Shell.Framework.Commands ► RemoveLanguage
Represents the Remove Language command.
Declaration Syntax
C#
[SerializableAttribute]
public class RemoveLanguage : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RemoveLanguage()()() | Initializes a new instance of the RemoveLanguage class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | RemoveLanguage


RemoveLanguage Constructor

RemoveLanguage Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► RemoveLanguage ► RemoveLanguage()()()
Initializes a new instance of the RemoveLanguage class
Declaration Syntax
C#
public RemoveLanguage()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► RemoveLanguage ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► RemoveLanguage ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► RemoveLanguage ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Rename Class

Rename Class
Namespaces ► Sitecore.Shell.Framework.Commands ► Rename
Represents the Rename command.
Declaration Syntax
C#
[SerializableAttribute]
public class Rename : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Rename()()() | Initializes a new instance of the Rename class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Rename


Rename Constructor

Rename Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► Rename ► Rename()()()
Initializes a new instance of the Rename class
Declaration Syntax
C#
public Rename()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Rename ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Rename ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


ResetDefaultWorkflow Class

ResetDefaultWorkflow Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetDefaultWorkflow
Represents the Reset Default Workflow command.
Declaration Syntax
C#
[SerializableAttribute]
public class ResetDefaultWorkflow : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResetDefaultWorkflow()()() | Initializes a new instance of the ResetDefaultWorkflow class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ResetDefaultWorkflow


ResetDefaultWorkflow Constructor

ResetDefaultWorkflow Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetDefaultWorkflow ► ResetDefaultWorkflow()()()
Initializes a new instance of the ResetDefaultWorkflow class
Declaration Syntax
C#
public ResetDefaultWorkflow()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetDefaultWorkflow ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetDefaultWorkflow ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetDefaultWorkflow ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


ResetFields Class

ResetFields Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetFields
Represents a ResetSortorder command.
Declaration Syntax
C#
[SerializableAttribute]
public class ResetFields : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResetFields()()() | Initializes a new instance of the ResetFields class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ResetFields


ResetFields Constructor

ResetFields Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetFields ► ResetFields()()()
Initializes a new instance of the ResetFields class
Declaration Syntax
C#
public ResetFields()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetFields ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetFields ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetFields ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


ResetSortorder Class

ResetSortorder Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetSortorder
Represents a ResetSortorder command.
Declaration Syntax
C#
[SerializableAttribute]
public class ResetSortorder : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResetSortorder()()() | Initializes a new instance of the ResetSortorder class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ResetSortorder


ResetSortorder Constructor

ResetSortorder Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetSortorder ► ResetSortorder()()()
Initializes a new instance of the ResetSortorder class
Declaration Syntax
C#
public ResetSortorder()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetSortorder ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetSortorder ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► ResetSortorder ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


SecurityPreset Class

SecurityPreset Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SecurityPreset
Implements the SecurityPreset.
Declaration Syntax
C#
[SerializableAttribute]
public class SecurityPreset : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecurityPreset()()() | Initializes a new instance of the SecurityPreset class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SecurityPreset


SecurityPreset Constructor

SecurityPreset Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SecurityPreset ► SecurityPreset()()()
Initializes a new instance of the SecurityPreset class
Declaration Syntax
C#
public SecurityPreset()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SecurityPreset ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SecurityPreset ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


SelectIcon Class

SelectIcon Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SelectIcon
Represents the Select Icon command.
Declaration Syntax
C#
[SerializableAttribute]
public class SelectIcon : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelectIcon()()() | Initializes a new instance of the SelectIcon class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Overrides Command.GetIcon(CommandContext, String).)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SelectIcon


SelectIcon Constructor

SelectIcon Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SelectIcon ► SelectIcon()()()
Initializes a new instance of the SelectIcon class
Declaration Syntax
C#
public SelectIcon()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SelectIcon ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetIcon Method (context, defaultValue)

GetIcon Method (context, defaultValue)
Namespaces ► Sitecore.Shell.Framework.Commands ► SelectIcon ► GetIcon(CommandContext, String)
Gets the icon.
Declaration Syntax
C#
public override string GetIcon(
    CommandContext context,
    string defaultValue
)
Parameters
context (CommandContext)
The context.
defaultValue (String)
The default value.
Return Value


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SelectIcon ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► SelectIcon ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


SelectLanguage Class

SelectLanguage Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SelectLanguage
Represents the Archive command.
Declaration Syntax
C#
[SerializableAttribute]
public class SelectLanguage : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelectLanguage()()() | Initializes a new instance of the SelectLanguage class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SelectLanguage


SelectLanguage Constructor

SelectLanguage Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SelectLanguage ► SelectLanguage()()()
Initializes a new instance of the SelectLanguage class
Declaration Syntax
C#
public SelectLanguage()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SelectLanguage ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► SelectLanguage ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


SetAliases Class

SetAliases Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SetAliases
Represents the Set Aliases command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetAliases : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetAliases()()() | Initializes a new instance of the SetAliases class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetAliases


SetAliases Constructor

SetAliases Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SetAliases ► SetAliases()()()
Initializes a new instance of the SetAliases class
Declaration Syntax
C#
public SetAliases()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetAliases ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetAliases ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


SetContextMenu Class

SetContextMenu Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SetContextMenu
Represents the Set Context Menu command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetContextMenu : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetContextMenu()()() | Initializes a new instance of the SetContextMenu class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetContextMenu


SetContextMenu Constructor

SetContextMenu Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SetContextMenu ► SetContextMenu()()()
Initializes a new instance of the SetContextMenu class
Declaration Syntax
C#
public SetContextMenu()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetContextMenu ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetContextMenu ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetContextMenu ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


SetCustomEditors Class

SetCustomEditors Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SetCustomEditors
Represents the Set Custom Editor command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetCustomEditors : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetCustomEditors()()() | Initializes a new instance of the SetCustomEditors class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified arguments.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetCustomEditors


SetCustomEditors Constructor

SetCustomEditors Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SetCustomEditors ► SetCustomEditors()()()
Initializes a new instance of the SetCustomEditors class
Declaration Syntax
C#
public SetCustomEditors()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetCustomEditors ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetCustomEditors ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetCustomEditors ► Run(ClientPipelineArgs)
Runs the specified arguments.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


SetDefaultWorkflow Class

SetDefaultWorkflow Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SetDefaultWorkflow
Represents the Set Default Workflow command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetDefaultWorkflow : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetDefaultWorkflow()()() | Initializes a new instance of the SetDefaultWorkflow class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetDefaultWorkflow


SetDefaultWorkflow Constructor

SetDefaultWorkflow Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SetDefaultWorkflow ► SetDefaultWorkflow()()()
Initializes a new instance of the SetDefaultWorkflow class
Declaration Syntax
C#
public SetDefaultWorkflow()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetDefaultWorkflow ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetDefaultWorkflow ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetDefaultWorkflow ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


SetDisplayName Class

SetDisplayName Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SetDisplayName
Represents the Set Display Name command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetDisplayName : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetDisplayName()()() | Initializes a new instance of the SetDisplayName class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Execute(Item) | Executes the specified item.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetDisplayName


SetDisplayName Constructor

SetDisplayName Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SetDisplayName ► SetDisplayName()()()
Initializes a new instance of the SetDisplayName class
Declaration Syntax
C#
public SetDisplayName()


Execute Method

Execute Method
Namespaces ► Sitecore.Shell.Framework.Commands ► SetDisplayName ► Execute()()()
Members
Icon | Member | Description
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Execute(Item) | Executes the specified item.


Execute Method (item)

Execute Method (item)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetDisplayName ► Execute(Item)
Executes the specified item.
Declaration Syntax
C#
public void Execute(
    Item item
)
Parameters
item (Item)
The item.


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetDisplayName ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetDisplayName ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetDisplayName ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


SetHelp Class

SetHelp Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SetHelp
Represents the Set Help command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetHelp : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetHelp()()() | Initializes a new instance of the SetHelp class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetHelp


SetHelp Constructor

SetHelp Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SetHelp ► SetHelp()()()
Initializes a new instance of the SetHelp class
Declaration Syntax
C#
public SetHelp()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetHelp ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetHelp ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetHelp ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


SetIcon Class

SetIcon Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SetIcon
Represents the Set Icon command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetIcon : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetIcon()()() | Initializes a new instance of the SetIcon class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Overrides Command.GetIcon(CommandContext, String).)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetIcon


SetIcon Constructor

SetIcon Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SetIcon ► SetIcon()()()
Initializes a new instance of the SetIcon class
Declaration Syntax
C#
public SetIcon()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetIcon ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetIcon Method (context, defaultValue)

GetIcon Method (context, defaultValue)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetIcon ► GetIcon(CommandContext, String)
Gets the icon.
Declaration Syntax
C#
public override string GetIcon(
    CommandContext context,
    string defaultValue
)
Parameters
context (CommandContext)
The context.
defaultValue (String)
The default value.
Return Value


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetIcon ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


SetLayoutDetails Class

SetLayoutDetails Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SetLayoutDetails
Represents the Set Aliases command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetLayoutDetails : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetLayoutDetails()()() | Initializes a new instance of the SetLayoutDetails class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetLayoutDetails


SetLayoutDetails Constructor

SetLayoutDetails Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SetLayoutDetails ► SetLayoutDetails()()()
Initializes a new instance of the SetLayoutDetails class
Declaration Syntax
C#
public SetLayoutDetails()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetLayoutDetails ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetLayoutDetails ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetLayoutDetails ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


SetMasters Class

SetMasters Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SetMasters
Represents the SetMasters command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetMasters : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetMasters()()() | Initializes a new instance of the SetMasters class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetMasters


SetMasters Constructor

SetMasters Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SetMasters ► SetMasters()()()
Initializes a new instance of the SetMasters class
Declaration Syntax
C#
public SetMasters()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetMasters ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetMasters ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetMasters ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


SetOwner Class

SetOwner Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SetOwner
Represents the Set Owner command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetOwner : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetOwner()()() | Initializes a new instance of the SetOwner class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetOwner


SetOwner Constructor

SetOwner Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SetOwner ► SetOwner()()()
Initializes a new instance of the SetOwner class
Declaration Syntax
C#
public SetOwner()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetOwner ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetOwner ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetOwner ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


SetPublishing Class

SetPublishing Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SetPublishing
Represents the Set Publishing command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetPublishing : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetPublishing()()() | Initializes a new instance of the SetPublishing class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Execute(Item) | Executes the specified item.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Overrides Command.GetHeader(CommandContext, String).)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetPublishing


SetPublishing Constructor

SetPublishing Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SetPublishing ► SetPublishing()()()
Initializes a new instance of the SetPublishing class
Declaration Syntax
C#
public SetPublishing()


Execute Method

Execute Method
Namespaces ► Sitecore.Shell.Framework.Commands ► SetPublishing ► Execute()()()
Members
Icon | Member | Description
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Execute(Item) | Executes the specified item.


Execute Method (item)

Execute Method (item)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetPublishing ► Execute(Item)
Executes the specified item.
Declaration Syntax
C#
public void Execute(
    Item item
)
Parameters
item (Item)
The item.


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetPublishing ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetHeader Method (context, header)

GetHeader Method (context, header)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetPublishing ► GetHeader(CommandContext, String)
Gets the header.
Declaration Syntax
C#
public override string GetHeader(
    CommandContext context,
    string header
)
Parameters
context (CommandContext)
The context.
header (String)
The default header.
Return Value
The header.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetPublishing ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetPublishing ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


SetRibbon Class

SetRibbon Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SetRibbon
Represents the Set Ribbon command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetRibbon : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetRibbon()()() | Initializes a new instance of the SetRibbon class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetRibbon


SetRibbon Constructor

SetRibbon Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SetRibbon ► SetRibbon()()()
Initializes a new instance of the SetRibbon class
Declaration Syntax
C#
public SetRibbon()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetRibbon ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetRibbon ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetRibbon ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


SetSubitemsSorting Class

SetSubitemsSorting Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SetSubitemsSorting
Represents the Set Subitems Sorting command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetSubitemsSorting : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetSubitemsSorting()()() | Initializes a new instance of the SetSubitemsSorting class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Execute(Item) | Executes the specified item.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetSubitemsSorting


SetSubitemsSorting Constructor

SetSubitemsSorting Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SetSubitemsSorting ► SetSubitemsSorting()()()
Initializes a new instance of the SetSubitemsSorting class
Declaration Syntax
C#
public SetSubitemsSorting()


Execute Method

Execute Method
Namespaces ► Sitecore.Shell.Framework.Commands ► SetSubitemsSorting ► Execute()()()
Members
Icon | Member | Description
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Execute(Item) | Executes the specified item.


Execute Method (item)

Execute Method (item)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetSubitemsSorting ► Execute(Item)
Executes the specified item.
Declaration Syntax
C#
public void Execute(
    Item item
)
Parameters
item (Item)
The item.


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetSubitemsSorting ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetSubitemsSorting ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


SetTreeNodeStyle Class

SetTreeNodeStyle Class
Namespaces ► Sitecore.Shell.Framework.Commands ► SetTreeNodeStyle
Represents the Set Tree Node Style command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetTreeNodeStyle : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetTreeNodeStyle()()() | Initializes a new instance of the SetTreeNodeStyle class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetTreeNodeStyle


SetTreeNodeStyle Constructor

SetTreeNodeStyle Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► SetTreeNodeStyle ► SetTreeNodeStyle()()()
Initializes a new instance of the SetTreeNodeStyle class
Declaration Syntax
C#
public SetTreeNodeStyle()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetTreeNodeStyle ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetTreeNodeStyle ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► SetTreeNodeStyle ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


ShowVersions Class

ShowVersions Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ShowVersions
Shows the versions.
Declaration Syntax
C#
[SerializableAttribute]
public class ShowVersions : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShowVersions()()() | Initializes a new instance of the ShowVersions class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ShowVersions


ShowVersions Constructor

ShowVersions Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ShowVersions ► ShowVersions()()()
Initializes a new instance of the ShowVersions class
Declaration Syntax
C#
public ShowVersions()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ShowVersions ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands ► ShowVersions ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ShowVersions ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


ToggleHidden Class

ToggleHidden Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ToggleHidden
Represents the Toggle Hidden command.
Declaration Syntax
C#
[SerializableAttribute]
public class ToggleHidden : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToggleHidden()()() | Initializes a new instance of the ToggleHidden class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Overrides Command.GetHeader(CommandContext, String).)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ToggleHidden


ToggleHidden Constructor

ToggleHidden Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ToggleHidden ► ToggleHidden()()()
Initializes a new instance of the ToggleHidden class
Declaration Syntax
C#
public ToggleHidden()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ToggleHidden ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetHeader Method (context, header)

GetHeader Method (context, header)
Namespaces ► Sitecore.Shell.Framework.Commands ► ToggleHidden ► GetHeader(CommandContext, String)
Gets the header.
Declaration Syntax
C#
public override string GetHeader(
    CommandContext context,
    string header
)
Parameters
context (CommandContext)
The context.
header (String)
The header.
Return Value


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ToggleHidden ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


ToggleReadOnly Class

ToggleReadOnly Class
Namespaces ► Sitecore.Shell.Framework.Commands ► ToggleReadOnly
Represents the Toggle Read Only command.
Declaration Syntax
C#
[SerializableAttribute]
public class ToggleReadOnly : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToggleReadOnly()()() | Initializes a new instance of the ToggleReadOnly class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Overrides Command.GetHeader(CommandContext, String).)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ToggleReadOnly


ToggleReadOnly Constructor

ToggleReadOnly Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► ToggleReadOnly ► ToggleReadOnly()()()
Initializes a new instance of the ToggleReadOnly class
Declaration Syntax
C#
public ToggleReadOnly()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ToggleReadOnly ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetHeader Method (context, header)

GetHeader Method (context, header)
Namespaces ► Sitecore.Shell.Framework.Commands ► ToggleReadOnly ► GetHeader(CommandContext, String)
Gets the header.
Declaration Syntax
C#
public override string GetHeader(
    CommandContext context,
    string header
)
Parameters
context (CommandContext)
The context.
header (String)
The default header.
Return Value
The header.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► ToggleReadOnly ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


TransferToDatabase Class

TransferToDatabase Class
Namespaces ► Sitecore.Shell.Framework.Commands ► TransferToDatabase
Represents the Transfer To Database command.
Declaration Syntax
C#
[SerializableAttribute]
public class TransferToDatabase : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TransferToDatabase()()() | Initializes a new instance of the TransferToDatabase class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | TransferToDatabase


TransferToDatabase Constructor

TransferToDatabase Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► TransferToDatabase ► TransferToDatabase()()()
Initializes a new instance of the TransferToDatabase class
Declaration Syntax
C#
public TransferToDatabase()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► TransferToDatabase ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► TransferToDatabase ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


UntranslatedFields Class

UntranslatedFields Class
Namespaces ► Sitecore.Shell.Framework.Commands ► UntranslatedFields
Represents the Untranslated Fields command.
Declaration Syntax
C#
[SerializableAttribute]
public class UntranslatedFields : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UntranslatedFields()()() | Initializes a new instance of the UntranslatedFields class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | UntranslatedFields


UntranslatedFields Constructor

UntranslatedFields Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► UntranslatedFields ► UntranslatedFields()()()
Initializes a new instance of the UntranslatedFields class
Declaration Syntax
C#
public UntranslatedFields()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► UntranslatedFields ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Upload Class

Upload Class
Namespaces ► Sitecore.Shell.Framework.Commands ► Upload
Represents the Upload command.
Declaration Syntax
C#
[SerializableAttribute]
public class Upload : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Upload()()() | Initializes a new instance of the Upload class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Upload


Upload Constructor

Upload Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► Upload ► Upload()()()
Initializes a new instance of the Upload class
Declaration Syntax
C#
public Upload()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Upload ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Upload ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Workflow Class

Workflow Class
Namespaces ► Sitecore.Shell.Framework.Commands ► Workflow
Represents the Workflow command.
Declaration Syntax
C#
[SerializableAttribute]
public class Workflow : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Workflow()()() | Initializes a new instance of the Workflow class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Workflow


Workflow Constructor

Workflow Constructor
Namespaces ► Sitecore.Shell.Framework.Commands ► Workflow ► Workflow()()()
Initializes a new instance of the Workflow class
Declaration Syntax
C#
public Workflow()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands ► Workflow ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands ► Workflow ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Sitecore.Shell.Framework.Commands.AccessViewer Namespace

Sitecore.Shell.Framework.Commands.AccessViewer Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.AccessViewer
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.AccessViewer
Types
All Types Classes
Icon | Type | Description
 | SelectColumns | Represents a ChangeUser command.


SelectColumns Class

SelectColumns Class
Namespaces ► Sitecore.Shell.Framework.Commands.AccessViewer ► SelectColumns
Represents a ChangeUser command.
Declaration Syntax
C#
[SerializableAttribute]
public class SelectColumns : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelectColumns()()() | Initializes a new instance of the SelectColumns class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SelectColumns


SelectColumns Constructor

SelectColumns Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.AccessViewer ► SelectColumns ► SelectColumns()()()
Initializes a new instance of the SelectColumns class
Declaration Syntax
C#
public SelectColumns()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.AccessViewer ► SelectColumns ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.AccessViewer ► SelectColumns ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected static void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


Sitecore.Shell.Framework.Commands.Archives Namespace

Sitecore.Shell.Framework.Commands.Archives Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.Archives
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.Archives
Types
All Types Classes
Icon | Type | Description
 | Delete | Represents the Archive command.
 | Empty | Represents the Archive command.
 | Refresh | Represents the Archive command.
 | Restore | Represents the Archive command.


Delete Class

Delete Class
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Delete
Represents the Archive command.
Declaration Syntax
C#
[SerializableAttribute]
public class Delete : Command, ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Delete()()() | Initializes a new instance of the Delete class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Delete


Delete Constructor

Delete Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Delete ► Delete()()()
Initializes a new instance of the Delete class
Declaration Syntax
C#
public Delete()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Delete ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Delete ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Empty Class

Empty Class
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Empty
Represents the Archive command.
Declaration Syntax
C#
[SerializableAttribute]
public class Empty : Command, ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Empty()()() | Initializes a new instance of the Empty class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Empty


Empty Constructor

Empty Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Empty ► Empty()()()
Initializes a new instance of the Empty class
Declaration Syntax
C#
public Empty()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Empty ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Empty ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Refresh Class

Refresh Class
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Refresh
Represents the Archive command.
Declaration Syntax
C#
[SerializableAttribute]
public class Refresh : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Refresh()()() | Initializes a new instance of the Refresh class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Refresh


Refresh Constructor

Refresh Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Refresh ► Refresh()()()
Initializes a new instance of the Refresh class
Declaration Syntax
C#
public Refresh()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Refresh ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Restore Class

Restore Class
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Restore
Represents the Archive command.
Declaration Syntax
C#
[SerializableAttribute]
public class Restore : Command, ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Restore()()() | Initializes a new instance of the Restore class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Restore


Restore Constructor

Restore Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Restore ► Restore()()()
Initializes a new instance of the Restore class
Declaration Syntax
C#
public Restore()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Restore ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Archives ► Restore ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Sitecore.Shell.Framework.Commands.BrokenLinks Namespace

Sitecore.Shell.Framework.Commands.BrokenLinks Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.BrokenLinks
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.BrokenLinks
Types
All Types Classes
Icon | Type | Description
 | ShowSystemItems | Represents the AddFromMaster command.


ShowSystemItems Class

ShowSystemItems Class
Namespaces ► Sitecore.Shell.Framework.Commands.BrokenLinks ► ShowSystemItems
Represents the AddFromMaster command.
Declaration Syntax
C#
[SerializableAttribute]
public class ShowSystemItems : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShowSystemItems()()() | Initializes a new instance of the ShowSystemItems class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ShowSystemItems


ShowSystemItems Constructor

ShowSystemItems Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.BrokenLinks ► ShowSystemItems ► ShowSystemItems()()()
Initializes a new instance of the ShowSystemItems class
Declaration Syntax
C#
public ShowSystemItems()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.BrokenLinks ► ShowSystemItems ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.BrokenLinks ► ShowSystemItems ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.BrokenLinks ► ShowSystemItems ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Sitecore.Shell.Framework.Commands.Carousel Namespace

Sitecore.Shell.Framework.Commands.Carousel Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.Carousel
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.Carousel
Types
All Types Classes
Icon | Type | Description
 | Home | Represents the Home command.
 | Refresh | Represents the Refresh command.


Home Class

Home Class
Namespaces ► Sitecore.Shell.Framework.Commands.Carousel ► Home
Represents the Home command.
Declaration Syntax
C#
[SerializableAttribute]
public class Home : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Home()()() | Initializes a new instance of the Home class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Home


Home Constructor

Home Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Carousel ► Home ► Home()()()
Initializes a new instance of the Home class
Declaration Syntax
C#
public Home()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Carousel ► Home ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Carousel ► Home ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Refresh Class

Refresh Class
Namespaces ► Sitecore.Shell.Framework.Commands.Carousel ► Refresh
Represents the Refresh command.
Declaration Syntax
C#
[SerializableAttribute]
public class Refresh : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Refresh()()() | Initializes a new instance of the Refresh class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Refresh


Refresh Constructor

Refresh Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Carousel ► Refresh ► Refresh()()()
Initializes a new instance of the Refresh class
Declaration Syntax
C#
public Refresh()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Carousel ► Refresh ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Sitecore.Shell.Framework.Commands.Clipboard Namespace

Sitecore.Shell.Framework.Commands.Clipboard Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.Clipboard
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.Clipboard
Types
All Types Classes
Icon | Type | Description
 | CopyIDToClipboard | Represents the AddMaster command.
 | CopyPathToClipboard | Represents the AddMaster command.


CopyIDToClipboard Class

CopyIDToClipboard Class
Namespaces ► Sitecore.Shell.Framework.Commands.Clipboard ► CopyIDToClipboard
Represents the AddMaster command.
Declaration Syntax
C#
[SerializableAttribute]
public class CopyIDToClipboard : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CopyIDToClipboard()()() | Initializes a new instance of the CopyIDToClipboard class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | CopyIDToClipboard


CopyIDToClipboard Constructor

CopyIDToClipboard Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Clipboard ► CopyIDToClipboard ► CopyIDToClipboard()()()
Initializes a new instance of the CopyIDToClipboard class
Declaration Syntax
C#
public CopyIDToClipboard()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Clipboard ► CopyIDToClipboard ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Clipboard ► CopyIDToClipboard ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Clipboard ► CopyIDToClipboard ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CopyPathToClipboard Class

CopyPathToClipboard Class
Namespaces ► Sitecore.Shell.Framework.Commands.Clipboard ► CopyPathToClipboard
Represents the AddMaster command.
Declaration Syntax
C#
[SerializableAttribute]
public class CopyPathToClipboard : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CopyPathToClipboard()()() | Initializes a new instance of the CopyPathToClipboard class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | CopyPathToClipboard


CopyPathToClipboard Constructor

CopyPathToClipboard Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Clipboard ► CopyPathToClipboard ► CopyPathToClipboard()()()
Initializes a new instance of the CopyPathToClipboard class
Declaration Syntax
C#
public CopyPathToClipboard()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Clipboard ► CopyPathToClipboard ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Clipboard ► CopyPathToClipboard ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Clipboard ► CopyPathToClipboard ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Sitecore.Shell.Framework.Commands.ContentEditor Namespace

Sitecore.Shell.Framework.Commands.ContentEditor Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.ContentEditor
Types
All Types Classes
Icon | Type | Description
 | Archive | Represents the Reminder command.
 | Back | Represents the Back command.
 | Close | Represents the Close command.
 | ClosePreview | Represents the Close Preview command.
 | Edit | Represents the Edit command.
 | Forward | Represents the Forward command.
 | Home | Returns the user to the home item.
 | IncrementMark | Represents the Forward command.
 | OpenItem | Opens the selected item.
 | OpenItemSecurityEditorContextAware | Open item security editor. Used in Content Editor and therefore is context aware and is disabled on non-editable items.
 | OpenSecurity | Represents the Reminder command.
 | PageDesigner | Opens the Page Designer.
 | Preview | Represents a Preview.
 | Properties | Opens the Page Designer.
 | Reminder | Represents the Reminder command.
 | Save | Represents the Save command.
 | SaveAndClose | Represents the Close command.
 | SetIcon | Represents the Set Icon command.
 | ShowFavorites | Is used for manage the comamnd query state.
 | ShowLinks | Is used for manage the comamnd query state.
 | ShowValidationResult | Shows the item validation result.
 | ShowWorkflowCommands | Represents the Set Icon command.
 | Subitems | Represents the Subitems command.
 | ToggleEntireTree | Represents the Toggle Entire Tree command.
 | ToggleFolders | Represents the Toggle Folders command.
 | ToggleHiddenItems | Represents the Toggle Hidden Items command.
 | ToggleRawValues | Represents the Toggle Raw Values command.
 | ToggleStandardFields | Represents the Toggle Standard Fields command.
 | ToggleTranslate | Represents the Toggle Translate command.
 | Up | Selects the parent item.


Archive Class

Archive Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Archive
Represents the Reminder command.
Declaration Syntax
C#
[SerializableAttribute]
public class Archive : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Archive()()() | Initializes a new instance of the Archive class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Archive


Archive Constructor

Archive Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Archive ► Archive()()()
Initializes a new instance of the Archive class
Declaration Syntax
C#
public Archive()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Archive ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Archive ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Archive ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Back Class

Back Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Back
Represents the Back command.
Declaration Syntax
C#
[SerializableAttribute]
public class Back : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Back()()() | Initializes a new instance of the Back class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Back


Back Constructor

Back Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Back ► Back()()()
Initializes a new instance of the Back class
Declaration Syntax
C#
public Back()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Back ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Back ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Close Class

Close Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Close
Represents the Close command.
Declaration Syntax
C#
[SerializableAttribute]
public class Close : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Close()()() | Initializes a new instance of the Close class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Close


Close Constructor

Close Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Close ► Close()()()
Initializes a new instance of the Close class
Declaration Syntax
C#
public Close()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Close ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Close ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


ClosePreview Class

ClosePreview Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ClosePreview
Represents the Close Preview command.
Declaration Syntax
C#
[SerializableAttribute]
public class ClosePreview : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClosePreview()()() | Initializes a new instance of the ClosePreview class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ClosePreview


ClosePreview Constructor

ClosePreview Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ClosePreview ► ClosePreview()()()
Initializes a new instance of the ClosePreview class
Declaration Syntax
C#
public ClosePreview()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ClosePreview ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ClosePreview ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Edit Class

Edit Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Edit
Represents the Edit command.
Declaration Syntax
C#
[SerializableAttribute]
public class Edit : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Edit()()() | Initializes a new instance of the Edit class
 | CanCheckIn(Item) | Determines whether this instance can check in the specified item.
 | CanEdit(Item) | Determines whether this instance can edit the specified item.
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasWriteAccess(Item) | Determines whether context user has write access to the specified item.
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Edit


Edit Constructor

Edit Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Edit ► Edit()()()
Initializes a new instance of the Edit class
Declaration Syntax
C#
public Edit()


CanCheckIn Method (item)

CanCheckIn Method (item)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Edit ► CanCheckIn(Item)
Determines whether this instance can check in the specified item.
Declaration Syntax
C#
protected static bool CanCheckIn(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if this instance can check in the specified item; otherwise, false.


CanEdit Method (item)

CanEdit Method (item)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Edit ► CanEdit(Item)
Determines whether this instance can edit the specified item.
Declaration Syntax
C#
protected static bool CanEdit(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if this instance can edit the specified item; otherwise, false.


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Edit ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


HasWriteAccess Method (item)

HasWriteAccess Method (item)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Edit ► HasWriteAccess(Item)
Determines whether context user has write access to the specified item.
Declaration Syntax
C#
protected static bool HasWriteAccess(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if context user has write access to the specified item; otherwise, false.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Edit ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


Forward Class

Forward Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Forward
Represents the Forward command.
Declaration Syntax
C#
[SerializableAttribute]
public class Forward : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Forward()()() | Initializes a new instance of the Forward class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Forward


Forward Constructor

Forward Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Forward ► Forward()()()
Initializes a new instance of the Forward class
Declaration Syntax
C#
public Forward()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Forward ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Forward ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Home Class

Home Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Home
Returns the user to the home item.
Declaration Syntax
C#
[SerializableAttribute]
public class Home : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Home()()() | Initializes a new instance of the Home class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Home


Home Constructor

Home Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Home ► Home()()()
Initializes a new instance of the Home class
Declaration Syntax
C#
public Home()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Home ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Home ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


IncrementMark Class

IncrementMark Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► IncrementMark
Represents the Forward command.
Declaration Syntax
C#
[SerializableAttribute]
public class IncrementMark : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IncrementMark()()() | Initializes a new instance of the IncrementMark class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | IncrementMark


IncrementMark Constructor

IncrementMark Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► IncrementMark ► IncrementMark()()()
Initializes a new instance of the IncrementMark class
Declaration Syntax
C#
public IncrementMark()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► IncrementMark ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


OpenItem Class

OpenItem Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► OpenItem
Opens the selected item.
Declaration Syntax
C#
public class OpenItem : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OpenItem()()() | Initializes a new instance of the OpenItem class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | OpenItem


OpenItem Constructor

OpenItem Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► OpenItem ► OpenItem()()()
Initializes a new instance of the OpenItem class
Declaration Syntax
C#
public OpenItem()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► OpenItem ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► OpenItem ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► OpenItem ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


OpenItemSecurityEditorContextAware Class

OpenItemSecurityEditorContextAware Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► OpenItemSecurityEditorContextAware
Open item security editor. Used in Content Editor and therefore is context aware and is disabled on non-editable items.
Declaration Syntax
C#
[SerializableAttribute]
public class OpenItemSecurityEditorContextAware : OpenItemSecurityEditor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OpenItemSecurityEditorContextAware()()() | Initializes a new instance of the OpenItemSecurityEditorContextAware class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Inherited from OpenItemSecurityEditor.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline. (Inherited from OpenItemSecurityEditor.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | OpenItemSecurityEditor
 |  |  | OpenItemSecurityEditorContextAware


OpenItemSecurityEditorContextAware Constructor

OpenItemSecurityEditorContextAware Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► OpenItemSecurityEditorContextAware ► OpenItemSecurityEditorContextAware()()()
Initializes a new instance of the OpenItemSecurityEditorContextAware class
Declaration Syntax
C#
public OpenItemSecurityEditorContextAware()


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► OpenItemSecurityEditorContextAware ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


OpenSecurity Class

OpenSecurity Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► OpenSecurity
Represents the Reminder command.
Declaration Syntax
C#
[SerializableAttribute]
public class OpenSecurity : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OpenSecurity()()() | Initializes a new instance of the OpenSecurity class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | OpenSecurity


OpenSecurity Constructor

OpenSecurity Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► OpenSecurity ► OpenSecurity()()()
Initializes a new instance of the OpenSecurity class
Declaration Syntax
C#
public OpenSecurity()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► OpenSecurity ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


PageDesigner Class

PageDesigner Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► PageDesigner
Opens the Page Designer.
Declaration Syntax
C#
[SerializableAttribute]
public class PageDesigner : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PageDesigner()()() | Initializes a new instance of the PageDesigner class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | PageDesigner


PageDesigner Constructor

PageDesigner Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► PageDesigner ► PageDesigner()()()
Initializes a new instance of the PageDesigner class
Declaration Syntax
C#
public PageDesigner()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► PageDesigner ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► PageDesigner ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Preview Class

Preview Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Preview
Represents a Preview.
Declaration Syntax
C#
[SerializableAttribute]
public class Preview : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Preview()()() | Initializes a new instance of the Preview class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Preview


Preview Constructor

Preview Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Preview ► Preview()()()
Initializes a new instance of the Preview class
Declaration Syntax
C#
public Preview()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Preview ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Preview ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Properties Class

Properties Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Properties
Opens the Page Designer.
Declaration Syntax
C#
[SerializableAttribute]
public class Properties : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Properties()()() | Initializes a new instance of the Properties class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Properties


Properties Constructor

Properties Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Properties ► Properties()()()
Initializes a new instance of the Properties class
Declaration Syntax
C#
public Properties()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Properties ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Reminder Class

Reminder Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Reminder
Represents the Reminder command.
Declaration Syntax
C#
[SerializableAttribute]
public class Reminder : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Reminder()()() | Initializes a new instance of the Reminder class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Reminder


Reminder Constructor

Reminder Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Reminder ► Reminder()()()
Initializes a new instance of the Reminder class
Declaration Syntax
C#
public Reminder()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Reminder ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Reminder ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Reminder ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Save Class

Save Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Save
Represents the Save command.
Declaration Syntax
C#
[SerializableAttribute]
public class Save : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Save()()() | Initializes a new instance of the Save class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Save


Save Constructor

Save Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Save ► Save()()()
Initializes a new instance of the Save class
Declaration Syntax
C#
public Save()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Save ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Save ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


SaveAndClose Class

SaveAndClose Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► SaveAndClose
Represents the Close command.
Declaration Syntax
C#
[SerializableAttribute]
public class SaveAndClose : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SaveAndClose()()() | Initializes a new instance of the SaveAndClose class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SaveAndClose


SaveAndClose Constructor

SaveAndClose Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► SaveAndClose ► SaveAndClose()()()
Initializes a new instance of the SaveAndClose class
Declaration Syntax
C#
public SaveAndClose()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► SaveAndClose ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► SaveAndClose ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


SetIcon Class

SetIcon Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► SetIcon
Represents the Set Icon command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetIcon : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetIcon()()() | Initializes a new instance of the SetIcon class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Execute(Item) | Executes the specified item.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click action. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Overrides Command.GetIcon(CommandContext, String).)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetIcon


SetIcon Constructor

SetIcon Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► SetIcon ► SetIcon()()()
Initializes a new instance of the SetIcon class
Declaration Syntax
C#
public SetIcon()


Execute Method

Execute Method
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► SetIcon ► Execute()()()
Members
Icon | Member | Description
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Execute(Item) | Executes the specified item.


Execute Method (item)

Execute Method (item)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► SetIcon ► Execute(Item)
Executes the specified item.
Declaration Syntax
C#
public void Execute(
    Item item
)
Parameters
item (Item)
The item.


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► SetIcon ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► SetIcon ► GetClick(CommandContext, String)
Gets the click action.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click action.
Return Value


GetIcon Method (context, defaultValue)

GetIcon Method (context, defaultValue)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► SetIcon ► GetIcon(CommandContext, String)
Gets the icon.
Declaration Syntax
C#
public override string GetIcon(
    CommandContext context,
    string defaultValue
)
Parameters
context (CommandContext)
The context.
defaultValue (String)
The default value.
Return Value


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► SetIcon ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


ShowFavorites Class

ShowFavorites Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ShowFavorites
Is used for manage the comamnd query state.
Declaration Syntax
C#
public class ShowFavorites : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShowFavorites()()() | Initializes a new instance of the ShowFavorites class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ShowFavorites


ShowFavorites Constructor

ShowFavorites Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ShowFavorites ► ShowFavorites()()()
Initializes a new instance of the ShowFavorites class
Declaration Syntax
C#
public ShowFavorites()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ShowFavorites ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


ShowLinks Class

ShowLinks Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ShowLinks
Is used for manage the comamnd query state.
Declaration Syntax
C#
public class ShowLinks : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShowLinks()()() | Initializes a new instance of the ShowLinks class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ShowLinks


ShowLinks Constructor

ShowLinks Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ShowLinks ► ShowLinks()()()
Initializes a new instance of the ShowLinks class
Declaration Syntax
C#
public ShowLinks()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ShowLinks ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


ShowValidationResult Class

ShowValidationResult Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ShowValidationResult
Shows the item validation result.
Declaration Syntax
C#
public class ShowValidationResult : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShowValidationResult()()() | Initializes a new instance of the ShowValidationResult class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ShowValidationResult


ShowValidationResult Constructor

ShowValidationResult Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ShowValidationResult ► ShowValidationResult()()()
Initializes a new instance of the ShowValidationResult class
Declaration Syntax
C#
public ShowValidationResult()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ShowValidationResult ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ShowValidationResult ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


ShowWorkflowCommands Class

ShowWorkflowCommands Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ShowWorkflowCommands
Represents the Set Icon command.
Declaration Syntax
C#
[SerializableAttribute]
public class ShowWorkflowCommands : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShowWorkflowCommands()()() | Initializes a new instance of the ShowWorkflowCommands class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ShowWorkflowCommands


ShowWorkflowCommands Constructor

ShowWorkflowCommands Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ShowWorkflowCommands ► ShowWorkflowCommands()()()
Initializes a new instance of the ShowWorkflowCommands class
Declaration Syntax
C#
public ShowWorkflowCommands()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ShowWorkflowCommands ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Subitems Class

Subitems Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Subitems
Represents the Subitems command.
Declaration Syntax
C#
[SerializableAttribute]
public class Subitems : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Subitems()()() | Initializes a new instance of the Subitems class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click action. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Subitems


Subitems Constructor

Subitems Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Subitems ► Subitems()()()
Initializes a new instance of the Subitems class
Declaration Syntax
C#
public Subitems()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Subitems ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Subitems ► GetClick(CommandContext, String)
Gets the click action.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click action.
Return Value


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Subitems ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


ToggleEntireTree Class

ToggleEntireTree Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleEntireTree
Represents the Toggle Entire Tree command.
Declaration Syntax
C#
[SerializableAttribute]
public class ToggleEntireTree : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToggleEntireTree()()() | Initializes a new instance of the ToggleEntireTree class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click action. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ToggleEntireTree


ToggleEntireTree Constructor

ToggleEntireTree Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleEntireTree ► ToggleEntireTree()()()
Initializes a new instance of the ToggleEntireTree class
Declaration Syntax
C#
public ToggleEntireTree()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleEntireTree ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleEntireTree ► GetClick(CommandContext, String)
Gets the click action.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click action.
Return Value


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleEntireTree ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


ToggleFolders Class

ToggleFolders Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleFolders
Represents the Toggle Folders command.
Declaration Syntax
C#
[SerializableAttribute]
public class ToggleFolders : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToggleFolders()()() | Initializes a new instance of the ToggleFolders class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ToggleFolders


ToggleFolders Constructor

ToggleFolders Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleFolders ► ToggleFolders()()()
Initializes a new instance of the ToggleFolders class
Declaration Syntax
C#
public ToggleFolders()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleFolders ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleFolders ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleFolders ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


ToggleHiddenItems Class

ToggleHiddenItems Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleHiddenItems
Represents the Toggle Hidden Items command.
Declaration Syntax
C#
[SerializableAttribute]
public class ToggleHiddenItems : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToggleHiddenItems()()() | Initializes a new instance of the ToggleHiddenItems class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click action. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ToggleHiddenItems


ToggleHiddenItems Constructor

ToggleHiddenItems Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleHiddenItems ► ToggleHiddenItems()()()
Initializes a new instance of the ToggleHiddenItems class
Declaration Syntax
C#
public ToggleHiddenItems()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleHiddenItems ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleHiddenItems ► GetClick(CommandContext, String)
Gets the click action.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click action.
Return Value


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleHiddenItems ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


ToggleRawValues Class

ToggleRawValues Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleRawValues
Represents the Toggle Raw Values command.
Declaration Syntax
C#
[SerializableAttribute]
public class ToggleRawValues : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToggleRawValues()()() | Initializes a new instance of the ToggleRawValues class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click action. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ToggleRawValues


ToggleRawValues Constructor

ToggleRawValues Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleRawValues ► ToggleRawValues()()()
Initializes a new instance of the ToggleRawValues class
Declaration Syntax
C#
public ToggleRawValues()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleRawValues ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleRawValues ► GetClick(CommandContext, String)
Gets the click action.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click action.
Return Value


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleRawValues ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


ToggleStandardFields Class

ToggleStandardFields Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleStandardFields
Represents the Toggle Standard Fields command.
Declaration Syntax
C#
[SerializableAttribute]
public class ToggleStandardFields : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToggleStandardFields()()() | Initializes a new instance of the ToggleStandardFields class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click action. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ToggleStandardFields


ToggleStandardFields Constructor

ToggleStandardFields Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleStandardFields ► ToggleStandardFields()()()
Initializes a new instance of the ToggleStandardFields class
Declaration Syntax
C#
public ToggleStandardFields()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleStandardFields ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleStandardFields ► GetClick(CommandContext, String)
Gets the click action.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click action.
Return Value


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleStandardFields ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


ToggleTranslate Class

ToggleTranslate Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleTranslate
Represents the Toggle Translate command.
Declaration Syntax
C#
[SerializableAttribute]
public class ToggleTranslate : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToggleTranslate()()() | Initializes a new instance of the ToggleTranslate class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ToggleTranslate


ToggleTranslate Constructor

ToggleTranslate Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleTranslate ► ToggleTranslate()()()
Initializes a new instance of the ToggleTranslate class
Declaration Syntax
C#
public ToggleTranslate()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleTranslate ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleTranslate ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► ToggleTranslate ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Up Class

Up Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Up
Selects the parent item.
Declaration Syntax
C#
[SerializableAttribute]
public class Up : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Up()()() | Initializes a new instance of the Up class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Up


Up Constructor

Up Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Up ► Up()()()
Initializes a new instance of the Up class
Declaration Syntax
C#
public Up()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Up ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor ► Up ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


Sitecore.Shell.Framework.Commands.ContentEditor.ContentImage Namespace

Sitecore.Shell.Framework.Commands.ContentEditor.ContentImage Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.ContentImage
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.ContentEditor.ContentImage
Types
All Types Classes
Icon | Type | Description
 | EditImage | Represents the EditImage command.


EditImage Class

EditImage Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.ContentImage ► EditImage
Represents the EditImage command.
Declaration Syntax
C#
[SerializableAttribute]
public class EditImage : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditImage()()() | Initializes a new instance of the EditImage class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | EditImage


EditImage Constructor

EditImage Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.ContentImage ► EditImage ► EditImage()()()
Initializes a new instance of the EditImage class
Declaration Syntax
C#
public EditImage()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.ContentImage ► EditImage ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.ContentImage ► EditImage ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.ContentImage ► EditImage ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Sitecore.Shell.Framework.Commands.ContentEditor.Validators Namespace

Sitecore.Shell.Framework.Commands.ContentEditor.Validators Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.Validators
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.ContentEditor.Validators
Types
All Types Classes
Icon | Type | Description
 | Trim | Represents a Trim.
 | ValidatorCommand |
 | ViewXhtml | Represents a Trim.


Trim Class

Trim Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.Validators ► Trim
Represents a Trim.
Declaration Syntax
C#
public class Trim : ValidatorCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Trim()()() | Initializes a new instance of the Trim class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ValidatorCommand
 |  |  | Trim


Trim Constructor

Trim Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.Validators ► Trim ► Trim()()()
Initializes a new instance of the Trim class
Declaration Syntax
C#
public Trim()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.Validators ► Trim ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


ValidatorCommand Class

ValidatorCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.Validators ► ValidatorCommand
Declaration Syntax
C#
public abstract class ValidatorCommand : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidatorCommand()()() | Initializes a new instance of the ValidatorCommand class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Inherited from Command.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetControlToValidate(BaseValidator) | Gets the control to validate.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValidator(CommandContext) | Gets the validator.
 | GetValidators()()() | Gets the validators.
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Validate()()() | Validates this instance.
Inheritance Hierarchy
Object
 | Command
 |  | ValidatorCommand
 |  |  | Trim
 |  |  | ViewXhtml


ValidatorCommand Constructor

ValidatorCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.Validators ► ValidatorCommand ► ValidatorCommand()()()
Initializes a new instance of the ValidatorCommand class
Declaration Syntax
C#
protected ValidatorCommand()


GetControlToValidate Method (validator)

GetControlToValidate Method (validator)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.Validators ► ValidatorCommand ► GetControlToValidate(BaseValidator)
Gets the control to validate.
Declaration Syntax
C#
protected static Control GetControlToValidate(
    BaseValidator validator
)
Parameters
validator (BaseValidator)
The validator.
Return Value
The control to validate.


GetValidator Method (context)

GetValidator Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.Validators ► ValidatorCommand ► GetValidator(CommandContext)
Gets the validator.
Declaration Syntax
C#
protected static BaseValidator GetValidator(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The validator.


GetValidators Method

GetValidators Method
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.Validators ► ValidatorCommand ► GetValidators()()()
Gets the validators.
Declaration Syntax
C#
protected static ValidatorCollection GetValidators()
Return Value
The validators.


Validate Method

Validate Method
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.Validators ► ValidatorCommand ► Validate()()()
Validates this instance.
Declaration Syntax
C#
protected static void Validate()


ViewXhtml Class

ViewXhtml Class
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.Validators ► ViewXhtml
Represents a Trim.
Declaration Syntax
C#
public class ViewXhtml : ValidatorCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ViewXhtml()()() | Initializes a new instance of the ViewXhtml class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ValidatorCommand
 |  |  | ViewXhtml


ViewXhtml Constructor

ViewXhtml Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.Validators ► ViewXhtml ► ViewXhtml()()()
Initializes a new instance of the ViewXhtml class
Declaration Syntax
C#
public ViewXhtml()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ContentEditor.Validators ► ViewXhtml ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Sitecore.Shell.Framework.Commands.Databases Namespace

Sitecore.Shell.Framework.Commands.Databases Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.Databases
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.Databases
Types
All Types Classes
Icon | Type | Description
 | CleanUp | Represents the Clean Up Databases command.


CleanUp Class

CleanUp Class
Namespaces ► Sitecore.Shell.Framework.Commands.Databases ► CleanUp
Represents the Clean Up Databases command.
Declaration Syntax
C#
[SerializableAttribute]
public class CleanUp : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CleanUp()()() | Initializes a new instance of the CleanUp class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | CleanUp


CleanUp Constructor

CleanUp Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Databases ► CleanUp ► CleanUp()()()
Initializes a new instance of the CleanUp class
Declaration Syntax
C#
public CleanUp()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Databases ► CleanUp ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Sitecore.Shell.Framework.Commands.DomainManager Namespace

Sitecore.Shell.Framework.Commands.DomainManager Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.DomainManager
Types
All Types Classes
Icon | Type | Description
 | DeleteDomain | Represents the New User command.
 | EditDomain | Represents the New User command.
 | NewDomain | Represents the New User command.


DeleteDomain Class

DeleteDomain Class
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► DeleteDomain
Represents the New User command.
Declaration Syntax
C#
[SerializableAttribute]
public class DeleteDomain : Command,
    ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteDomain()()() | Initializes a new instance of the DeleteDomain class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | RemoveDomains(String) | Removes the domains.
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | DeleteDomain


DeleteDomain Constructor

DeleteDomain Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► DeleteDomain ► DeleteDomain()()()
Initializes a new instance of the DeleteDomain class
Declaration Syntax
C#
public DeleteDomain()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► DeleteDomain ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


RemoveDomains Method (names)

RemoveDomains Method (names)
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► DeleteDomain ► RemoveDomains(String)
Removes the domains.
Declaration Syntax
C#
protected void RemoveDomains(
    string names
)
Parameters
names (String)
The names.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► DeleteDomain ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


EditDomain Class

EditDomain Class
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► EditDomain
Represents the New User command.
Declaration Syntax
C#
[SerializableAttribute]
public class EditDomain : Command, ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditDomain()()() | Initializes a new instance of the EditDomain class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | EditDomain


EditDomain Constructor

EditDomain Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► EditDomain ► EditDomain()()()
Initializes a new instance of the EditDomain class
Declaration Syntax
C#
public EditDomain()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► EditDomain ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► EditDomain ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► EditDomain ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


NewDomain Class

NewDomain Class
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► NewDomain
Represents the New User command.
Declaration Syntax
C#
[SerializableAttribute]
public class NewDomain : Command, ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NewDomain()()() | Initializes a new instance of the NewDomain class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | NewDomain


NewDomain Constructor

NewDomain Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► NewDomain ► NewDomain()()()
Initializes a new instance of the NewDomain class
Declaration Syntax
C#
public NewDomain()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► NewDomain ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► NewDomain ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.DomainManager ► NewDomain ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


Sitecore.Shell.Framework.Commands.Favorites Namespace

Sitecore.Shell.Framework.Commands.Favorites Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.Favorites
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.Favorites
Types
All Types Classes
Icon | Type | Description
 | Add | Represents the Add command.
 | Organize | Represents the Organize command.
 | ShowMenu | Represents the Show Menu command.


Add Class

Add Class
Namespaces ► Sitecore.Shell.Framework.Commands.Favorites ► Add
Represents the Add command.
Declaration Syntax
C#
[SerializableAttribute]
public class Add : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Add()()() | Initializes a new instance of the Add class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Add


Add Constructor

Add Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Favorites ► Add ► Add()()()
Initializes a new instance of the Add class
Declaration Syntax
C#
public Add()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Favorites ► Add ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Organize Class

Organize Class
Namespaces ► Sitecore.Shell.Framework.Commands.Favorites ► Organize
Represents the Organize command.
Declaration Syntax
C#
[SerializableAttribute]
public class Organize : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Organize()()() | Initializes a new instance of the Organize class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Organize


Organize Constructor

Organize Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Favorites ► Organize ► Organize()()()
Initializes a new instance of the Organize class
Declaration Syntax
C#
public Organize()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Favorites ► Organize ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


ShowMenu Class

ShowMenu Class
Namespaces ► Sitecore.Shell.Framework.Commands.Favorites ► ShowMenu
Represents the Show Menu command.
Declaration Syntax
C#
[SerializableAttribute]
public class ShowMenu : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShowMenu()()() | Initializes a new instance of the ShowMenu class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ShowMenu


ShowMenu Constructor

ShowMenu Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Favorites ► ShowMenu ► ShowMenu()()()
Initializes a new instance of the ShowMenu class
Declaration Syntax
C#
public ShowMenu()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Favorites ► ShowMenu ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Sitecore.Shell.Framework.Commands.IDE Namespace

Sitecore.Shell.Framework.Commands.IDE Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.IDE
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.IDE
Types
All Types Classes
Icon | Type | Description
 | CreateFile | Represents the AddFromMaster command.


CreateFile Class

CreateFile Class
Namespaces ► Sitecore.Shell.Framework.Commands.IDE ► CreateFile
Represents the AddFromMaster command.
Declaration Syntax
C#
[SerializableAttribute]
public class CreateFile : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateFile()()() | Initializes a new instance of the CreateFile class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | CreateFile


CreateFile Constructor

CreateFile Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.IDE ► CreateFile ► CreateFile()()()
Initializes a new instance of the CreateFile class
Declaration Syntax
C#
public CreateFile()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.IDE ► CreateFile ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.IDE ► CreateFile ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.IDE ► CreateFile ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Sitecore.Shell.Framework.Commands.Imager Namespace

Sitecore.Shell.Framework.Commands.Imager Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.Imager
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.Imager
Types
All Types Classes
Icon | Type | Description
 | Crop | Represents the Open command.
 | FlipHorizontal | Represents the Open command.
 | FlipVertical | Represents the Open command.
 | Open | Represents the Open command.
 | Redo | Represents the Open command.
 | Resize | Represents the Open command.
 | RotateLeft | Represents the Open command.
 | RotateRight | Represents the Open command.
 | Save | Represents the Save command.
 | Undo | Represents the Open command.


Crop Class

Crop Class
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Crop
Represents the Open command.
Declaration Syntax
C#
[SerializableAttribute]
public class Crop : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Crop()()() | Initializes a new instance of the Crop class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Crop


Crop Constructor

Crop Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Crop ► Crop()()()
Initializes a new instance of the Crop class
Declaration Syntax
C#
public Crop()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Crop ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Crop ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


FlipHorizontal Class

FlipHorizontal Class
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► FlipHorizontal
Represents the Open command.
Declaration Syntax
C#
[SerializableAttribute]
public class FlipHorizontal : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FlipHorizontal()()() | Initializes a new instance of the FlipHorizontal class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | FlipHorizontal


FlipHorizontal Constructor

FlipHorizontal Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► FlipHorizontal ► FlipHorizontal()()()
Initializes a new instance of the FlipHorizontal class
Declaration Syntax
C#
public FlipHorizontal()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► FlipHorizontal ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► FlipHorizontal ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


FlipVertical Class

FlipVertical Class
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► FlipVertical
Represents the Open command.
Declaration Syntax
C#
[SerializableAttribute]
public class FlipVertical : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FlipVertical()()() | Initializes a new instance of the FlipVertical class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | FlipVertical


FlipVertical Constructor

FlipVertical Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► FlipVertical ► FlipVertical()()()
Initializes a new instance of the FlipVertical class
Declaration Syntax
C#
public FlipVertical()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► FlipVertical ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► FlipVertical ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Open Class

Open Class
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Open
Represents the Open command.
Declaration Syntax
C#
[SerializableAttribute]
public class Open : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Open()()() | Initializes a new instance of the Open class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Open


Open Constructor

Open Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Open ► Open()()()
Initializes a new instance of the Open class
Declaration Syntax
C#
public Open()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Open ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Open ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Redo Class

Redo Class
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Redo
Represents the Open command.
Declaration Syntax
C#
[SerializableAttribute]
public class Redo : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Redo()()() | Initializes a new instance of the Redo class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Redo


Redo Constructor

Redo Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Redo ► Redo()()()
Initializes a new instance of the Redo class
Declaration Syntax
C#
public Redo()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Redo ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Redo ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Resize Class

Resize Class
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Resize
Represents the Open command.
Declaration Syntax
C#
[SerializableAttribute]
public class Resize : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Resize()()() | Initializes a new instance of the Resize class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Resize


Resize Constructor

Resize Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Resize ► Resize()()()
Initializes a new instance of the Resize class
Declaration Syntax
C#
public Resize()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Resize ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Resize ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


RotateLeft Class

RotateLeft Class
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► RotateLeft
Represents the Open command.
Declaration Syntax
C#
[SerializableAttribute]
public class RotateLeft : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RotateLeft()()() | Initializes a new instance of the RotateLeft class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | RotateLeft


RotateLeft Constructor

RotateLeft Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► RotateLeft ► RotateLeft()()()
Initializes a new instance of the RotateLeft class
Declaration Syntax
C#
public RotateLeft()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► RotateLeft ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► RotateLeft ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


RotateRight Class

RotateRight Class
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► RotateRight
Represents the Open command.
Declaration Syntax
C#
[SerializableAttribute]
public class RotateRight : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RotateRight()()() | Initializes a new instance of the RotateRight class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | RotateRight


RotateRight Constructor

RotateRight Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► RotateRight ► RotateRight()()()
Initializes a new instance of the RotateRight class
Declaration Syntax
C#
public RotateRight()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► RotateRight ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► RotateRight ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Save Class

Save Class
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Save
Represents the Save command.
Declaration Syntax
C#
[SerializableAttribute]
public class Save : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Save()()() | Initializes a new instance of the Save class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Save


Save Constructor

Save Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Save ► Save()()()
Initializes a new instance of the Save class
Declaration Syntax
C#
public Save()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Save ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Save ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Undo Class

Undo Class
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Undo
Represents the Open command.
Declaration Syntax
C#
[SerializableAttribute]
public class Undo : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Undo()()() | Initializes a new instance of the Undo class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Undo


Undo Constructor

Undo Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Undo ► Undo()()()
Initializes a new instance of the Undo class
Declaration Syntax
C#
public Undo()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Undo ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Imager ► Undo ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Sitecore.Shell.Framework.Commands.ItemSecurityEditor Namespace

Sitecore.Shell.Framework.Commands.ItemSecurityEditor Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.ItemSecurityEditor
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.ItemSecurityEditor
Types
All Types Classes
Icon | Type | Description
 | ChangeDomain | Represents the Change Domain command.


ChangeDomain Class

ChangeDomain Class
Namespaces ► Sitecore.Shell.Framework.Commands.ItemSecurityEditor ► ChangeDomain
Represents the Change Domain command.
Declaration Syntax
C#
[SerializableAttribute]
public class ChangeDomain : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangeDomain()()() | Initializes a new instance of the ChangeDomain class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Overrides Command.GetHeader(CommandContext, String).)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ChangeDomain


ChangeDomain Constructor

ChangeDomain Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.ItemSecurityEditor ► ChangeDomain ► ChangeDomain()()()
Initializes a new instance of the ChangeDomain class
Declaration Syntax
C#
public ChangeDomain()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.ItemSecurityEditor ► ChangeDomain ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetHeader Method (context, header)

GetHeader Method (context, header)
Namespaces ► Sitecore.Shell.Framework.Commands.ItemSecurityEditor ► ChangeDomain ► GetHeader(CommandContext, String)
Gets the header.
Declaration Syntax
C#
public override string GetHeader(
    CommandContext context,
    string header
)
Parameters
context (CommandContext)
The context.
header (String)
The header.
Return Value


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.ItemSecurityEditor ► ChangeDomain ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


Sitecore.Shell.Framework.Commands.Masters Namespace

Sitecore.Shell.Framework.Commands.Masters Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.Masters
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.Masters
Types
All Types Classes
Icon | Type | Description
 | New | Represents the New command.
 | Reset | Represents the New command.


New Class

New Class
Namespaces ► Sitecore.Shell.Framework.Commands.Masters ► New
Represents the New command.
Declaration Syntax
C#
[SerializableAttribute]
public class New : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | New()()() | Initializes a new instance of the New class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | New


New Constructor

New Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Masters ► New ► New()()()
Initializes a new instance of the New class
Declaration Syntax
C#
public New()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Masters ► New ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Masters ► New ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Reset Class

Reset Class
Namespaces ► Sitecore.Shell.Framework.Commands.Masters ► Reset
Represents the New command.
Declaration Syntax
C#
[SerializableAttribute]
public class Reset : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Reset()()() | Initializes a new instance of the Reset class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the specified page designer. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Reset


Reset Constructor

Reset Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Masters ► Reset ► Reset()()()
Initializes a new instance of the Reset class
Declaration Syntax
C#
public Reset()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Masters ► Reset ► Execute(CommandContext)
Executes the specified page designer.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Masters ► Reset ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Masters ► Reset ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Sitecore.Shell.Framework.Commands.Media Namespace

Sitecore.Shell.Framework.Commands.Media Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.Media
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.Media
Types
All Types Classes
Icon | Type | Description
 | BatchUpload | Represents the Upload command.
 | Download | Represents the Upload command.
 | MultiUpload | Activates the flash based upload.
 | NewFolder | Represents the New Folder command.
 | Play | Represents the Upload command.
 | Upload | Represents the Upload command.
 | View | Represents the Upload command.


BatchUpload Class

BatchUpload Class
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► BatchUpload
Represents the Upload command.
Declaration Syntax
C#
[SerializableAttribute]
public class BatchUpload : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BatchUpload()()() | Initializes a new instance of the BatchUpload class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | BatchUpload


BatchUpload Constructor

BatchUpload Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► BatchUpload ► BatchUpload()()()
Initializes a new instance of the BatchUpload class
Declaration Syntax
C#
public BatchUpload()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► BatchUpload ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► BatchUpload ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► BatchUpload ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Download Class

Download Class
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► Download
Represents the Upload command.
Declaration Syntax
C#
[SerializableAttribute]
public class Download : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Download()()() | Initializes a new instance of the Download class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Download


Download Constructor

Download Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► Download ► Download()()()
Initializes a new instance of the Download class
Declaration Syntax
C#
public Download()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► Download ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► Download ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


MultiUpload Class

MultiUpload Class
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► MultiUpload
Activates the flash based upload.
Declaration Syntax
C#
public class MultiUpload : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiUpload()()() | Initializes a new instance of the MultiUpload class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | MultiUpload


MultiUpload Constructor

MultiUpload Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► MultiUpload ► MultiUpload()()()
Initializes a new instance of the MultiUpload class
Declaration Syntax
C#
public MultiUpload()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► MultiUpload ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► MultiUpload ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


NewFolder Class

NewFolder Class
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► NewFolder
Represents the New Folder command.
Declaration Syntax
C#
[SerializableAttribute]
public class NewFolder : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NewFolder()()() | Initializes a new instance of the NewFolder class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | NewFolder


NewFolder Constructor

NewFolder Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► NewFolder ► NewFolder()()()
Initializes a new instance of the NewFolder class
Declaration Syntax
C#
public NewFolder()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► NewFolder ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► NewFolder ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Play Class

Play Class
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► Play
Represents the Upload command.
Declaration Syntax
C#
[SerializableAttribute]
public class Play : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Play()()() | Initializes a new instance of the Play class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Play


Play Constructor

Play Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► Play ► Play()()()
Initializes a new instance of the Play class
Declaration Syntax
C#
public Play()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► Play ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► Play ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Upload Class

Upload Class
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► Upload
Represents the Upload command.
Declaration Syntax
C#
[SerializableAttribute]
public class Upload : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Upload()()() | Initializes a new instance of the Upload class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Upload


Upload Constructor

Upload Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► Upload ► Upload()()()
Initializes a new instance of the Upload class
Declaration Syntax
C#
public Upload()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► Upload ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► Upload ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► Upload ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


View Class

View Class
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► View
Represents the Upload command.
Declaration Syntax
C#
[SerializableAttribute]
public class View : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | View()()() | Initializes a new instance of the View class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | View


View Constructor

View Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► View ► View()()()
Initializes a new instance of the View class
Declaration Syntax
C#
public View()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► View ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Media ► View ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Sitecore.Shell.Framework.Commands.Preferences Namespace

Sitecore.Shell.Framework.Commands.Preferences Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.Preferences
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.Preferences
Types
All Types Classes
Icon | Type | Description
 | ChangeRegionalSettings | Represents the Change Regional Settings command.
 | ChangeUserInformation | Represents the Change User Information command.
 | ChangeWallPaper | Represents the Change WallPaper command.


ChangeRegionalSettings Class

ChangeRegionalSettings Class
Namespaces ► Sitecore.Shell.Framework.Commands.Preferences ► ChangeRegionalSettings
Represents the Change Regional Settings command.
Declaration Syntax
C#
[SerializableAttribute]
public class ChangeRegionalSettings : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangeRegionalSettings()()() | Initializes a new instance of the ChangeRegionalSettings class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ChangeRegionalSettings


ChangeRegionalSettings Constructor

ChangeRegionalSettings Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Preferences ► ChangeRegionalSettings ► ChangeRegionalSettings()()()
Initializes a new instance of the ChangeRegionalSettings class
Declaration Syntax
C#
public ChangeRegionalSettings()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Preferences ► ChangeRegionalSettings ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


ChangeUserInformation Class

ChangeUserInformation Class
Namespaces ► Sitecore.Shell.Framework.Commands.Preferences ► ChangeUserInformation
Represents the Change User Information command.
Declaration Syntax
C#
[SerializableAttribute]
public class ChangeUserInformation : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangeUserInformation()()() | Initializes a new instance of the ChangeUserInformation class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ChangeUserInformation


ChangeUserInformation Constructor

ChangeUserInformation Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Preferences ► ChangeUserInformation ► ChangeUserInformation()()()
Initializes a new instance of the ChangeUserInformation class
Declaration Syntax
C#
public ChangeUserInformation()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Preferences ► ChangeUserInformation ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


ChangeWallPaper Class

ChangeWallPaper Class
Namespaces ► Sitecore.Shell.Framework.Commands.Preferences ► ChangeWallPaper
Represents the Change WallPaper command.
Declaration Syntax
C#
[SerializableAttribute]
public class ChangeWallPaper : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangeWallPaper()()() | Initializes a new instance of the ChangeWallPaper class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ChangeWallPaper


ChangeWallPaper Constructor

ChangeWallPaper Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Preferences ► ChangeWallPaper ► ChangeWallPaper()()()
Initializes a new instance of the ChangeWallPaper class
Declaration Syntax
C#
public ChangeWallPaper()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Preferences ► ChangeWallPaper ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Sitecore.Shell.Framework.Commands.Ribbon Namespace

Sitecore.Shell.Framework.Commands.Ribbon Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.Ribbon
Types
All Types Classes
Icon | Type | Description
 | Customize | Represents the Security command.
 | Languages | Represents the Languages command.
 | Layout | Represents the Layout command.
 | New | Represents the New command.
 | Security | Represents the Security command.


Customize Class

Customize Class
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Customize
Represents the Security command.
Declaration Syntax
C#
[SerializableAttribute]
public class Customize : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Customize()()() | Initializes a new instance of the Customize class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Customize


Customize Constructor

Customize Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Customize ► Customize()()()
Initializes a new instance of the Customize class
Declaration Syntax
C#
public Customize()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Customize ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Customize ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Languages Class

Languages Class
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Languages
Represents the Languages command.
Declaration Syntax
C#
[SerializableAttribute]
public class Languages : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Languages()()() | Initializes a new instance of the Languages class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click action. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Overrides Command.GetHeader(CommandContext, String).)
 | GetIcon(CommandContext, String) | Gets the icon. (Overrides Command.GetIcon(CommandContext, String).)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Languages


Languages Constructor

Languages Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Languages ► Languages()()()
Initializes a new instance of the Languages class
Declaration Syntax
C#
public Languages()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Languages ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Remarks
Does nothing.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Languages ► GetClick(CommandContext, String)
Gets the click action.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click action.
Return Value


GetHeader Method (context, header)

GetHeader Method (context, header)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Languages ► GetHeader(CommandContext, String)
Gets the header.
Declaration Syntax
C#
public override string GetHeader(
    CommandContext context,
    string header
)
Parameters
context (CommandContext)
The context.
header (String)
The header.
Return Value
The header.


GetIcon Method (context, icon)

GetIcon Method (context, icon)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Languages ► GetIcon(CommandContext, String)
Gets the icon.
Declaration Syntax
C#
public override string GetIcon(
    CommandContext context,
    string icon
)
Parameters
context (CommandContext)
The context.
icon (String)
The icon.
Return Value


Layout Class

Layout Class
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Layout
Represents the Layout command.
Declaration Syntax
C#
[SerializableAttribute]
public class Layout : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Layout()()() | Initializes a new instance of the Layout class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Layout


Layout Constructor

Layout Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Layout ► Layout()()()
Initializes a new instance of the Layout class
Declaration Syntax
C#
public Layout()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Layout ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Layout ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Layout ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


New Class

New Class
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► New
Represents the New command.
Declaration Syntax
C#
[SerializableAttribute]
public class New : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | New()()() | Initializes a new instance of the New class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | New


New Constructor

New Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► New ► New()()()
Initializes a new instance of the New class
Declaration Syntax
C#
public New()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► New ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► New ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► New ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Security Class

Security Class
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Security
Represents the Security command.
Declaration Syntax
C#
[SerializableAttribute]
public class Security : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Security()()() | Initializes a new instance of the Security class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Security


Security Constructor

Security Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Security ► Security()()()
Initializes a new instance of the Security class
Declaration Syntax
C#
public Security()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Security ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Security ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Ribbon ► Security ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Sitecore.Shell.Framework.Commands.RoleManager Namespace

Sitecore.Shell.Framework.Commands.RoleManager Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.RoleManager
Types
All Types Classes
Icon | Type | Description
 | AddMember |
 | AddMemberOf |
 | Delete | Represents the New User command.
 | NewRole | Represents the New User command.
 | RemoveMember | Represents the New User command.
 | RemoveMemberOf | Represents the New User command.
 | ViewMembers | Represents the Edit User command.
 | ViewParentRoles |


AddMember Class

AddMember Class
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► AddMember
Declaration Syntax
C#
[SerializableAttribute]
public class AddMember : Command, ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMember()()() | Initializes a new instance of the AddMember class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AddMember


AddMember Constructor

AddMember Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► AddMember ► AddMember()()()
Initializes a new instance of the AddMember class
Declaration Syntax
C#
public AddMember()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► AddMember ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► AddMember ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


AddMemberOf Class

AddMemberOf Class
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► AddMemberOf
Declaration Syntax
C#
[SerializableAttribute]
public class AddMemberOf : Command,
    ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMemberOf()()() | Initializes a new instance of the AddMemberOf class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AddMemberOf


AddMemberOf Constructor

AddMemberOf Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► AddMemberOf ► AddMemberOf()()()
Initializes a new instance of the AddMemberOf class
Declaration Syntax
C#
public AddMemberOf()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► AddMemberOf ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► AddMemberOf ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


Delete Class

Delete Class
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► Delete
Represents the New User command.
Declaration Syntax
C#
[SerializableAttribute]
public class Delete : Command, ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Delete()()() | Initializes a new instance of the Delete class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | RemoveRoles(String) | Jobs the test.
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Delete


Delete Constructor

Delete Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► Delete ► Delete()()()
Initializes a new instance of the Delete class
Declaration Syntax
C#
public Delete()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► Delete ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


RemoveRoles Method (name)

RemoveRoles Method (name)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► Delete ► RemoveRoles(String)
Jobs the test.
Declaration Syntax
C#
protected void RemoveRoles(
    string name
)
Parameters
name (String)


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► Delete ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


NewRole Class

NewRole Class
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► NewRole
Represents the New User command.
Declaration Syntax
C#
[SerializableAttribute]
public class NewRole : Command, ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NewRole()()() | Initializes a new instance of the NewRole class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | NewRole


NewRole Constructor

NewRole Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► NewRole ► NewRole()()()
Initializes a new instance of the NewRole class
Declaration Syntax
C#
public NewRole()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► NewRole ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► NewRole ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► NewRole ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected static void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


RemoveMember Class

RemoveMember Class
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► RemoveMember
Represents the New User command.
Declaration Syntax
C#
[SerializableAttribute]
public class RemoveMember : Command,
    ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RemoveMember()()() | Initializes a new instance of the RemoveMember class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | RemoveMember


RemoveMember Constructor

RemoveMember Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► RemoveMember ► RemoveMember()()()
Initializes a new instance of the RemoveMember class
Declaration Syntax
C#
public RemoveMember()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► RemoveMember ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► RemoveMember ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


RemoveMemberOf Class

RemoveMemberOf Class
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► RemoveMemberOf
Represents the New User command.
Declaration Syntax
C#
[SerializableAttribute]
public class RemoveMemberOf : Command,
    ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RemoveMemberOf()()() | Initializes a new instance of the RemoveMemberOf class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | RemoveMemberOf


RemoveMemberOf Constructor

RemoveMemberOf Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► RemoveMemberOf ► RemoveMemberOf()()()
Initializes a new instance of the RemoveMemberOf class
Declaration Syntax
C#
public RemoveMemberOf()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► RemoveMemberOf ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► RemoveMemberOf ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


ViewMembers Class

ViewMembers Class
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► ViewMembers
Represents the Edit User command.
Declaration Syntax
C#
[SerializableAttribute]
public class ViewMembers : Command,
    ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ViewMembers()()() | Initializes a new instance of the ViewMembers class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ViewMembers


ViewMembers Constructor

ViewMembers Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► ViewMembers ► ViewMembers()()()
Initializes a new instance of the ViewMembers class
Declaration Syntax
C#
public ViewMembers()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► ViewMembers ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► ViewMembers ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected static void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


ViewParentRoles Class

ViewParentRoles Class
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► ViewParentRoles
Declaration Syntax
C#
[SerializableAttribute]
public class ViewParentRoles : Command,
    ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ViewParentRoles()()() | Initializes a new instance of the ViewParentRoles class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ViewParentRoles


ViewParentRoles Constructor

ViewParentRoles Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► ViewParentRoles ► ViewParentRoles()()()
Initializes a new instance of the ViewParentRoles class
Declaration Syntax
C#
public ViewParentRoles()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► ViewParentRoles ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► ViewParentRoles ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.RoleManager ► ViewParentRoles ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected static void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


Sitecore.Shell.Framework.Commands.SecurityEditor Namespace

Sitecore.Shell.Framework.Commands.SecurityEditor Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.SecurityEditor
Types
All Types Classes
Icon | Type | Description
 | ChangeDomain | Represents the Change Domain command.
 | ChangeUser | Represents a ChangeUser command.
 | SelectColumns | Represents a ChangeUser command.


ChangeDomain Class

ChangeDomain Class
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor ► ChangeDomain
Represents the Change Domain command.
Declaration Syntax
C#
[SerializableAttribute]
public class ChangeDomain : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangeDomain()()() | Initializes a new instance of the ChangeDomain class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Overrides Command.GetHeader(CommandContext, String).)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ChangeDomain


ChangeDomain Constructor

ChangeDomain Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor ► ChangeDomain ► ChangeDomain()()()
Initializes a new instance of the ChangeDomain class
Declaration Syntax
C#
public ChangeDomain()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor ► ChangeDomain ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetHeader Method (context, header)

GetHeader Method (context, header)
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor ► ChangeDomain ► GetHeader(CommandContext, String)
Gets the header.
Declaration Syntax
C#
public override string GetHeader(
    CommandContext context,
    string header
)
Parameters
context (CommandContext)
The context.
header (String)
The header.
Return Value


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor ► ChangeDomain ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


ChangeUser Class

ChangeUser Class
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor ► ChangeUser
Represents a ChangeUser command.
Declaration Syntax
C#
[SerializableAttribute]
public class ChangeUser : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangeUser()()() | Initializes a new instance of the ChangeUser class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Overrides Command.GetHeader(CommandContext, String).)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ChangeUser


ChangeUser Constructor

ChangeUser Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor ► ChangeUser ► ChangeUser()()()
Initializes a new instance of the ChangeUser class
Declaration Syntax
C#
public ChangeUser()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor ► ChangeUser ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetHeader Method (context, header)

GetHeader Method (context, header)
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor ► ChangeUser ► GetHeader(CommandContext, String)
Gets the header.
Declaration Syntax
C#
public override string GetHeader(
    CommandContext context,
    string header
)
Parameters
context (CommandContext)
The context.
header (String)
The header.
Return Value


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor ► ChangeUser ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


SelectColumns Class

SelectColumns Class
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor ► SelectColumns
Represents a ChangeUser command.
Declaration Syntax
C#
[SerializableAttribute]
public class SelectColumns : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelectColumns()()() | Initializes a new instance of the SelectColumns class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SelectColumns


SelectColumns Constructor

SelectColumns Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor ► SelectColumns ► SelectColumns()()()
Initializes a new instance of the SelectColumns class
Declaration Syntax
C#
public SelectColumns()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor ► SelectColumns ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.SecurityEditor ► SelectColumns ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected static void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


Sitecore.Shell.Framework.Commands.Serialization Namespace

Sitecore.Shell.Framework.Commands.Serialization Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.Serialization
Types
All Types Classes
Icon | Type | Description
 | BaseLoadCommand | Base class for all loading commands
 | DumpItemCommand | Dumps single item.
 | DumpRoleCommand | Dumps single role.
 | DumpTemplatesCommand | Dumps templates to disk.
 | DumpTreeCommand | Dumps subtree to disk.
 | DumpUserCommand | Dumps single user.
 | LoadAllDatabasesCommand | Loads all databases for dump.
 | LoadAllRolesCommand | LoadAllRolesCommand
 | LoadDatabaseCommand | Loads single database from dump. Database is pointed to by the context item.
 | LoadItemCommand | Loads single item from dump
 | LoadTreeCommand | Loads subtree from dump
 | RestoreDatabaseCommand | Description of RestoreDatabaseCommand.


BaseLoadCommand Class

BaseLoadCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► BaseLoadCommand
Base class for all loading commands
Declaration Syntax
C#
public abstract class BaseLoadCommand : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseLoadCommand()()() | Initializes a new instance of the BaseLoadCommand class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Inherited from Command.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetOptions(CommandContext) | Gets the loading options.
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | BaseLoadCommand
 |  |  | LoadAllDatabasesCommand
 |  |  | LoadDatabaseCommand
 |  |  | LoadItemCommand


BaseLoadCommand Constructor

BaseLoadCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► BaseLoadCommand ► BaseLoadCommand()()()
Initializes a new instance of the BaseLoadCommand class
Declaration Syntax
C#
protected BaseLoadCommand()


GetOptions Method (context)

GetOptions Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► BaseLoadCommand ► GetOptions(CommandContext)
Gets the loading options.
Declaration Syntax
C#
protected virtual LoadOptions GetOptions(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The options.


DumpItemCommand Class

DumpItemCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpItemCommand
Dumps single item.
Declaration Syntax
C#
public class DumpItemCommand : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DumpItemCommand()()() | Initializes a new instance of the DumpItemCommand class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Dump(Item) | Dumps the specified item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetName()()() | Gets the name.
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | DumpItemCommand
 |  |  | DumpTreeCommand


DumpItemCommand Constructor

DumpItemCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpItemCommand ► DumpItemCommand()()()
Initializes a new instance of the DumpItemCommand class
Declaration Syntax
C#
public DumpItemCommand()


Dump Method (item)

Dump Method (item)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpItemCommand ► Dump(Item)
Dumps the specified item.
Declaration Syntax
C#
protected virtual void Dump(
    Item item
)
Parameters
item (Item)
The item.


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpItemCommand ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetName Method

GetName Method
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpItemCommand ► GetName()()()
Gets the name.
Declaration Syntax
C#
protected virtual string GetName()
Return Value
The name.


DumpRoleCommand Class

DumpRoleCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpRoleCommand
Dumps single role.
Declaration Syntax
C#
public class DumpRoleCommand : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DumpRoleCommand()()() | Initializes a new instance of the DumpRoleCommand class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | DumpRole(String) | Dumps the specified role.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | DumpRoleCommand


DumpRoleCommand Constructor

DumpRoleCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpRoleCommand ► DumpRoleCommand()()()
Initializes a new instance of the DumpRoleCommand class
Declaration Syntax
C#
public DumpRoleCommand()


DumpRole Method (rolename)

DumpRole Method (rolename)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpRoleCommand ► DumpRole(String)
Dumps the specified role.
Declaration Syntax
C#
protected void DumpRole(
    string rolename
)
Parameters
rolename (String)
The role name.


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpRoleCommand ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


DumpTemplatesCommand Class

DumpTemplatesCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpTemplatesCommand
Dumps templates to disk.
Declaration Syntax
C#
public class DumpTemplatesCommand : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DumpTemplatesCommand()()() | Initializes a new instance of the DumpTemplatesCommand class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Runs the command (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | DumpTemplatesCommand


DumpTemplatesCommand Constructor

DumpTemplatesCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpTemplatesCommand ► DumpTemplatesCommand()()()
Initializes a new instance of the DumpTemplatesCommand class
Declaration Syntax
C#
public DumpTemplatesCommand()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpTemplatesCommand ► Execute(CommandContext)
Runs the command
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)


DumpTreeCommand Class

DumpTreeCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpTreeCommand
Dumps subtree to disk.
Declaration Syntax
C#
public class DumpTreeCommand : DumpItemCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DumpTreeCommand()()() | Initializes a new instance of the DumpTreeCommand class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Dump(Item) | Dumps the specified item. (Overrides DumpItemCommand.Dump(Item).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Inherited from DumpItemCommand.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetName()()() | Gets the name. (Overrides DumpItemCommand.GetName()()().)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | DumpItemCommand
 |  |  | DumpTreeCommand


DumpTreeCommand Constructor

DumpTreeCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpTreeCommand ► DumpTreeCommand()()()
Initializes a new instance of the DumpTreeCommand class
Declaration Syntax
C#
public DumpTreeCommand()


Dump Method (item)

Dump Method (item)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpTreeCommand ► Dump(Item)
Dumps the specified item.
Declaration Syntax
C#
protected override void Dump(
    Item item
)
Parameters
item (Item)
The item.


GetName Method

GetName Method
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpTreeCommand ► GetName()()()
Gets the name.
Declaration Syntax
C#
protected override string GetName()
Return Value
The name.


DumpUserCommand Class

DumpUserCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpUserCommand
Dumps single user.
Declaration Syntax
C#
public class DumpUserCommand : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DumpUserCommand()()() | Initializes a new instance of the DumpUserCommand class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | DumpUser(String) | Dumps the specified user.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetName()()() | Gets the name.
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | DumpUserCommand


DumpUserCommand Constructor

DumpUserCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpUserCommand ► DumpUserCommand()()()
Initializes a new instance of the DumpUserCommand class
Declaration Syntax
C#
public DumpUserCommand()


DumpUser Method (username)

DumpUser Method (username)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpUserCommand ► DumpUser(String)
Dumps the specified user.
Declaration Syntax
C#
protected void DumpUser(
    string username
)
Parameters
username (String)
The user name.


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpUserCommand ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetName Method

GetName Method
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► DumpUserCommand ► GetName()()()
Gets the name.
Declaration Syntax
C#
protected virtual string GetName()
Return Value
The name.


LoadAllDatabasesCommand Class

LoadAllDatabasesCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadAllDatabasesCommand
Loads all databases for dump.
Declaration Syntax
C#
public class LoadAllDatabasesCommand : BaseLoadCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoadAllDatabasesCommand()()() | Initializes a new instance of the LoadAllDatabasesCommand class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetOptions(CommandContext) | Gets the loading options. (Inherited from BaseLoadCommand.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | BaseLoadCommand
 |  |  | LoadAllDatabasesCommand


LoadAllDatabasesCommand Constructor

LoadAllDatabasesCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadAllDatabasesCommand ► LoadAllDatabasesCommand()()()
Initializes a new instance of the LoadAllDatabasesCommand class
Declaration Syntax
C#
public LoadAllDatabasesCommand()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadAllDatabasesCommand ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


LoadAllRolesCommand Class

LoadAllRolesCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadAllRolesCommand
LoadAllRolesCommand
Declaration Syntax
C#
public class LoadAllRolesCommand : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoadAllRolesCommand()()() | Initializes a new instance of the LoadAllRolesCommand class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | LoadAllRoles(array<Object>[]()[]) | Methods the specified parameters.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | LoadAllRolesCommand


LoadAllRolesCommand Constructor

LoadAllRolesCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadAllRolesCommand ► LoadAllRolesCommand()()()
Initializes a new instance of the LoadAllRolesCommand class
Declaration Syntax
C#
public LoadAllRolesCommand()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadAllRolesCommand ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


LoadAllRoles Method (parameters)

LoadAllRoles Method (parameters)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadAllRolesCommand ► LoadAllRoles(array<Object>[]()[])
Methods the specified parameters.
Declaration Syntax
C#
public void LoadAllRoles(
    Object[] parameters
)
Parameters
parameters (array< Object >[]()[])
The parameters.


LoadDatabaseCommand Class

LoadDatabaseCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadDatabaseCommand
Loads single database from dump. Database is pointed to by the context item.
Declaration Syntax
C#
public class LoadDatabaseCommand : BaseLoadCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoadDatabaseCommand()()() | Initializes a new instance of the LoadDatabaseCommand class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetOptions(CommandContext) | Gets the loading options. (Inherited from BaseLoadCommand.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | BaseLoadCommand
 |  |  | LoadDatabaseCommand


LoadDatabaseCommand Constructor

LoadDatabaseCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadDatabaseCommand ► LoadDatabaseCommand()()()
Initializes a new instance of the LoadDatabaseCommand class
Declaration Syntax
C#
public LoadDatabaseCommand()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadDatabaseCommand ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


LoadItemCommand Class

LoadItemCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadItemCommand
Loads single item from dump
Declaration Syntax
C#
public class LoadItemCommand : BaseLoadCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoadItemCommand()()() | Initializes a new instance of the LoadItemCommand class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetOptions(CommandContext) | Gets the loading options. (Inherited from BaseLoadCommand.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | LoadItem(Item, LoadOptions) | Loads the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | BaseLoadCommand
 |  |  | LoadItemCommand
 |  |  |  | LoadTreeCommand


LoadItemCommand Constructor

LoadItemCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadItemCommand ► LoadItemCommand()()()
Initializes a new instance of the LoadItemCommand class
Declaration Syntax
C#
public LoadItemCommand()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadItemCommand ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


LoadItem Method (item, options)

LoadItem Method (item, options)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadItemCommand ► LoadItem(Item, LoadOptions)
Loads the item.
Declaration Syntax
C#
protected virtual Item LoadItem(
    Item item,
    LoadOptions options
)
Parameters
item (Item)
The item.
options (LoadOptions)
The options.
Return Value
The item.


LoadTreeCommand Class

LoadTreeCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadTreeCommand
Loads subtree from dump
Declaration Syntax
C#
public class LoadTreeCommand : LoadItemCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoadTreeCommand()()() | Initializes a new instance of the LoadTreeCommand class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Inherited from LoadItemCommand.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetOptions(CommandContext) | Gets the loading options. (Inherited from BaseLoadCommand.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | LoadItem(Item, LoadOptions) | Loads the item and all descendants. (Overrides LoadItemCommand.LoadItem(Item, LoadOptions).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | BaseLoadCommand
 |  |  | LoadItemCommand
 |  |  |  | LoadTreeCommand


LoadTreeCommand Constructor

LoadTreeCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadTreeCommand ► LoadTreeCommand()()()
Initializes a new instance of the LoadTreeCommand class
Declaration Syntax
C#
public LoadTreeCommand()


LoadItem Method (item, options)

LoadItem Method (item, options)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► LoadTreeCommand ► LoadItem(Item, LoadOptions)
Loads the item and all descendants.
Declaration Syntax
C#
protected override Item LoadItem(
    Item item,
    LoadOptions options
)
Parameters
item (Item)
The item.
options (LoadOptions)
The options.
Return Value
The item.


RestoreDatabaseCommand Class

RestoreDatabaseCommand Class
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► RestoreDatabaseCommand
Description of RestoreDatabaseCommand.
Declaration Syntax
C#
[SerializableAttribute]
public class RestoreDatabaseCommand : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RestoreDatabaseCommand()()() | Initializes a new instance of the RestoreDatabaseCommand class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Runs the action for the command. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | RestoreDatabaseCommand


RestoreDatabaseCommand Constructor

RestoreDatabaseCommand Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► RestoreDatabaseCommand ► RestoreDatabaseCommand()()()
Initializes a new instance of the RestoreDatabaseCommand class
Declaration Syntax
C#
public RestoreDatabaseCommand()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Serialization ► RestoreDatabaseCommand ► Execute(CommandContext)
Runs the action for the command.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)


Sitecore.Shell.Framework.Commands.Shell Namespace

Sitecore.Shell.Framework.Commands.Shell Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.Shell
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.Shell
Types
All Types Classes
Icon | Type | Description
 | AccessViewer | Represents the Access Viewer command.
 | Audit | Represents the Audit command.
 | AutoDoc | Represents the AutoDoc command.
 | DomainManager | Represents the Role Manager command.
 | EditImage | Represents the EditImage command.
 | EditTemplate | Represents the Edit Template command.
 | LogViewer | Represents the Log Viewer command.
 | RoleManager | Represents the Role Manager command.
 | Search | Represents the Search command.
 | SecurityEditor | Represents the Security Editor command.
 | UserManager | Represents the User Manager command.
 | UserOptions | Represents the User Options command.


AccessViewer Class

AccessViewer Class
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► AccessViewer
Represents the Access Viewer command.
Declaration Syntax
C#
[SerializableAttribute]
public class AccessViewer : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessViewer()()() | Initializes a new instance of the AccessViewer class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AccessViewer


AccessViewer Constructor

AccessViewer Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► AccessViewer ► AccessViewer()()()
Initializes a new instance of the AccessViewer class
Declaration Syntax
C#
public AccessViewer()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► AccessViewer ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► AccessViewer ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Audit Class

Audit Class
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► Audit
Represents the Audit command.
Declaration Syntax
C#
[SerializableAttribute]
public class Audit : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Audit()()() | Initializes a new instance of the Audit class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Audit


Audit Constructor

Audit Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► Audit ► Audit()()()
Initializes a new instance of the Audit class
Declaration Syntax
C#
public Audit()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► Audit ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► Audit ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


AutoDoc Class

AutoDoc Class
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► AutoDoc
Represents the AutoDoc command.
Declaration Syntax
C#
[SerializableAttribute]
public class AutoDoc : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AutoDoc()()() | Initializes a new instance of the AutoDoc class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AutoDoc


AutoDoc Constructor

AutoDoc Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► AutoDoc ► AutoDoc()()()
Initializes a new instance of the AutoDoc class
Declaration Syntax
C#
public AutoDoc()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► AutoDoc ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► AutoDoc ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


DomainManager Class

DomainManager Class
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► DomainManager
Represents the Role Manager command.
Declaration Syntax
C#
[SerializableAttribute]
public class DomainManager : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainManager()()() | Initializes a new instance of the DomainManager class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | DomainManager


DomainManager Constructor

DomainManager Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► DomainManager ► DomainManager()()()
Initializes a new instance of the DomainManager class
Declaration Syntax
C#
public DomainManager()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► DomainManager ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► DomainManager ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


EditImage Class

EditImage Class
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► EditImage
Represents the EditImage command.
Declaration Syntax
C#
[SerializableAttribute]
public class EditImage : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditImage()()() | Initializes a new instance of the EditImage class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | EditImage


EditImage Constructor

EditImage Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► EditImage ► EditImage()()()
Initializes a new instance of the EditImage class
Declaration Syntax
C#
public EditImage()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► EditImage ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► EditImage ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


EditTemplate Class

EditTemplate Class
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► EditTemplate
Represents the Edit Template command.
Declaration Syntax
C#
[SerializableAttribute]
public class EditTemplate : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditTemplate()()() | Initializes a new instance of the EditTemplate class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | EditTemplate


EditTemplate Constructor

EditTemplate Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► EditTemplate ► EditTemplate()()()
Initializes a new instance of the EditTemplate class
Declaration Syntax
C#
public EditTemplate()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► EditTemplate ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► EditTemplate ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


LogViewer Class

LogViewer Class
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► LogViewer
Represents the Log Viewer command.
Declaration Syntax
C#
[SerializableAttribute]
public class LogViewer : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LogViewer()()() | Initializes a new instance of the LogViewer class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | LogViewer


LogViewer Constructor

LogViewer Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► LogViewer ► LogViewer()()()
Initializes a new instance of the LogViewer class
Declaration Syntax
C#
public LogViewer()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► LogViewer ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► LogViewer ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


RoleManager Class

RoleManager Class
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► RoleManager
Represents the Role Manager command.
Declaration Syntax
C#
[SerializableAttribute]
public class RoleManager : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RoleManager()()() | Initializes a new instance of the RoleManager class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | RoleManager


RoleManager Constructor

RoleManager Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► RoleManager ► RoleManager()()()
Initializes a new instance of the RoleManager class
Declaration Syntax
C#
public RoleManager()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► RoleManager ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► RoleManager ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Search Class

Search Class
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► Search
Represents the Search command.
Declaration Syntax
C#
[SerializableAttribute]
public class Search : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Search()()() | Initializes a new instance of the Search class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Search


Search Constructor

Search Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► Search ► Search()()()
Initializes a new instance of the Search class
Declaration Syntax
C#
public Search()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► Search ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► Search ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


SecurityEditor Class

SecurityEditor Class
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► SecurityEditor
Represents the Security Editor command.
Declaration Syntax
C#
[SerializableAttribute]
public class SecurityEditor : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecurityEditor()()() | Initializes a new instance of the SecurityEditor class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SecurityEditor


SecurityEditor Constructor

SecurityEditor Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► SecurityEditor ► SecurityEditor()()()
Initializes a new instance of the SecurityEditor class
Declaration Syntax
C#
public SecurityEditor()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► SecurityEditor ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► SecurityEditor ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


UserManager Class

UserManager Class
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► UserManager
Represents the User Manager command.
Declaration Syntax
C#
[SerializableAttribute]
public class UserManager : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserManager()()() | Initializes a new instance of the UserManager class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | UserManager


UserManager Constructor

UserManager Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► UserManager ► UserManager()()()
Initializes a new instance of the UserManager class
Declaration Syntax
C#
public UserManager()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► UserManager ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► UserManager ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


UserOptions Class

UserOptions Class
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► UserOptions
Represents the User Options command.
Declaration Syntax
C#
[SerializableAttribute]
public class UserOptions : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserOptions()()() | Initializes a new instance of the UserOptions class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | UserOptions


UserOptions Constructor

UserOptions Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► UserOptions ► UserOptions()()()
Initializes a new instance of the UserOptions class
Declaration Syntax
C#
public UserOptions()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► UserOptions ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► UserOptions ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Shell ► UserOptions ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


Sitecore.Shell.Framework.Commands.System Namespace

Sitecore.Shell.Framework.Commands.System Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.System
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.System
Types
All Types Classes
Icon | Type | Description
 | AddLanguage | Represents the Add Language command.
 | BrokenLinks | Represents the Broken Links command.
 | CompareDatabases | Obsolete. Represents the Compare Databases command.
 | DatabaseUsage | Represents the Delete Language command.
 | Debug | Represents the Debug command.
 | DeleteLanguage | Represents the Delete Language command.
 | InstallPackage | Represents the Install Package command.
 | Logout | Represents the Logout command.
 | OpenWebSite | Represents the Open WebSite command.
 | Preview | Represents the Preview command.
 | Publish | Represents the Publish command.
 | RebuildDatabase | Represents the Rebuild Database command.
 | RebuildLinkDatabase | Represents the Rebuild Link Database command.
 | RebuildSearchIndex | Represents the Rebuild Search Index command.
 | RunProgram | Represents the Run Program command.
 | Search | Represents the Search command.
 | ShowAbout | Represents the Show About command.
 | ShowLicenses | Represents the Show Licenses command.
 | WebEdit | Represents the WebEdit command.


AddLanguage Class

AddLanguage Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► AddLanguage
Represents the Add Language command.
Declaration Syntax
C#
[SerializableAttribute]
public class AddLanguage : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddLanguage()()() | Initializes a new instance of the AddLanguage class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | Process(ClientPipelineArgs) | Runs the processor.
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AddLanguage


AddLanguage Constructor

AddLanguage Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► AddLanguage ► AddLanguage()()()
Initializes a new instance of the AddLanguage class
Declaration Syntax
C#
public AddLanguage()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► AddLanguage ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Process Method (args)

Process Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► AddLanguage ► Process(ClientPipelineArgs)
Runs the processor.
Declaration Syntax
C#
protected void Process(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


BrokenLinks Class

BrokenLinks Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► BrokenLinks
Represents the Broken Links command.
Declaration Syntax
C#
[SerializableAttribute]
public class BrokenLinks : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BrokenLinks()()() | Initializes a new instance of the BrokenLinks class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | BrokenLinks


BrokenLinks Constructor

BrokenLinks Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► BrokenLinks ► BrokenLinks()()()
Initializes a new instance of the BrokenLinks class
Declaration Syntax
C#
public BrokenLinks()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► BrokenLinks ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


CompareDatabases Class

CompareDatabases Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► CompareDatabases
Represents the Compare Databases command.
Declaration Syntax
C#
[SerializableAttribute]
[ObsoleteAttribute("Compare databases is no longer supported.")]
public class CompareDatabases : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompareDatabases()()() | Initializes a new instance of the CompareDatabases class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | CompareDatabases


CompareDatabases Constructor

CompareDatabases Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► CompareDatabases ► CompareDatabases()()()
Initializes a new instance of the CompareDatabases class
Declaration Syntax
C#
public CompareDatabases()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► CompareDatabases ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


DatabaseUsage Class

DatabaseUsage Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► DatabaseUsage
Represents the Delete Language command.
Declaration Syntax
C#
[SerializableAttribute]
public class DatabaseUsage : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatabaseUsage()()() | Initializes a new instance of the DatabaseUsage class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | DatabaseUsage


DatabaseUsage Constructor

DatabaseUsage Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► DatabaseUsage ► DatabaseUsage()()()
Initializes a new instance of the DatabaseUsage class
Declaration Syntax
C#
public DatabaseUsage()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► DatabaseUsage ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Debug Class

Debug Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Debug
Represents the Debug command.
Declaration Syntax
C#
[SerializableAttribute]
public class Debug : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Debug()()() | Initializes a new instance of the Debug class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Debug


Debug Constructor

Debug Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Debug ► Debug()()()
Initializes a new instance of the Debug class
Declaration Syntax
C#
public Debug()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Debug ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


DeleteLanguage Class

DeleteLanguage Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► DeleteLanguage
Represents the Delete Language command.
Declaration Syntax
C#
[SerializableAttribute]
public class DeleteLanguage : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteLanguage()()() | Initializes a new instance of the DeleteLanguage class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | DeleteLanguage


DeleteLanguage Constructor

DeleteLanguage Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► DeleteLanguage ► DeleteLanguage()()()
Initializes a new instance of the DeleteLanguage class
Declaration Syntax
C#
public DeleteLanguage()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► DeleteLanguage ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


InstallPackage Class

InstallPackage Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► InstallPackage
Represents the Install Package command.
Declaration Syntax
C#
[SerializableAttribute]
public class InstallPackage : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstallPackage()()() | Initializes a new instance of the InstallPackage class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | InstallPackage


InstallPackage Constructor

InstallPackage Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► InstallPackage ► InstallPackage()()()
Initializes a new instance of the InstallPackage class
Declaration Syntax
C#
public InstallPackage()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► InstallPackage ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Logout Class

Logout Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Logout
Represents the Logout command.
Declaration Syntax
C#
[SerializableAttribute]
public class Logout : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Logout()()() | Initializes a new instance of the Logout class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Logout


Logout Constructor

Logout Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Logout ► Logout()()()
Initializes a new instance of the Logout class
Declaration Syntax
C#
public Logout()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Logout ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


OpenWebSite Class

OpenWebSite Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► OpenWebSite
Represents the Open WebSite command.
Declaration Syntax
C#
[SerializableAttribute]
public class OpenWebSite : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OpenWebSite()()() | Initializes a new instance of the OpenWebSite class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | OpenWebSite


OpenWebSite Constructor

OpenWebSite Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► OpenWebSite ► OpenWebSite()()()
Initializes a new instance of the OpenWebSite class
Declaration Syntax
C#
public OpenWebSite()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► OpenWebSite ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Preview Class

Preview Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Preview
Represents the Preview command.
Declaration Syntax
C#
[SerializableAttribute]
public class Preview : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Preview()()() | Initializes a new instance of the Preview class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Preview


Preview Constructor

Preview Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Preview ► Preview()()()
Initializes a new instance of the Preview class
Declaration Syntax
C#
public Preview()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Preview ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Preview ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Publish Class

Publish Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Publish
Represents the Publish command.
Declaration Syntax
C#
[SerializableAttribute]
public class Publish : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Publish()()() | Initializes a new instance of the Publish class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Publish


Publish Constructor

Publish Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Publish ► Publish()()()
Initializes a new instance of the Publish class
Declaration Syntax
C#
public Publish()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Publish ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Publish ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Publish ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected static void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


RebuildDatabase Class

RebuildDatabase Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► RebuildDatabase
Represents the Rebuild Database command.
Declaration Syntax
C#
[SerializableAttribute]
public class RebuildDatabase : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RebuildDatabase()()() | Initializes a new instance of the RebuildDatabase class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | RebuildDatabase


RebuildDatabase Constructor

RebuildDatabase Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► RebuildDatabase ► RebuildDatabase()()()
Initializes a new instance of the RebuildDatabase class
Declaration Syntax
C#
public RebuildDatabase()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► RebuildDatabase ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


RebuildLinkDatabase Class

RebuildLinkDatabase Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► RebuildLinkDatabase
Represents the Rebuild Link Database command.
Declaration Syntax
C#
[SerializableAttribute]
public class RebuildLinkDatabase : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RebuildLinkDatabase()()() | Initializes a new instance of the RebuildLinkDatabase class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | RebuildLinkDatabase


RebuildLinkDatabase Constructor

RebuildLinkDatabase Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► RebuildLinkDatabase ► RebuildLinkDatabase()()()
Initializes a new instance of the RebuildLinkDatabase class
Declaration Syntax
C#
public RebuildLinkDatabase()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► RebuildLinkDatabase ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


RebuildSearchIndex Class

RebuildSearchIndex Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► RebuildSearchIndex
Represents the Rebuild Search Index command.
Declaration Syntax
C#
[SerializableAttribute]
public class RebuildSearchIndex : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RebuildSearchIndex()()() | Initializes a new instance of the RebuildSearchIndex class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | RebuildSearchIndex


RebuildSearchIndex Constructor

RebuildSearchIndex Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► RebuildSearchIndex ► RebuildSearchIndex()()()
Initializes a new instance of the RebuildSearchIndex class
Declaration Syntax
C#
public RebuildSearchIndex()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► RebuildSearchIndex ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


RunProgram Class

RunProgram Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► RunProgram
Represents the Run Program command.
Declaration Syntax
C#
[SerializableAttribute]
public class RunProgram : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RunProgram()()() | Initializes a new instance of the RunProgram class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | RunProgram


RunProgram Constructor

RunProgram Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► RunProgram ► RunProgram()()()
Initializes a new instance of the RunProgram class
Declaration Syntax
C#
public RunProgram()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► RunProgram ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Search Class

Search Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Search
Represents the Search command.
Declaration Syntax
C#
[SerializableAttribute]
public class Search : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Search()()() | Initializes a new instance of the Search class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Search


Search Constructor

Search Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Search ► Search()()()
Initializes a new instance of the Search class
Declaration Syntax
C#
public Search()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► Search ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


ShowAbout Class

ShowAbout Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► ShowAbout
Represents the Show About command.
Declaration Syntax
C#
[SerializableAttribute]
public class ShowAbout : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShowAbout()()() | Initializes a new instance of the ShowAbout class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ShowAbout


ShowAbout Constructor

ShowAbout Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► ShowAbout ► ShowAbout()()()
Initializes a new instance of the ShowAbout class
Declaration Syntax
C#
public ShowAbout()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► ShowAbout ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


ShowLicenses Class

ShowLicenses Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► ShowLicenses
Represents the Show Licenses command.
Declaration Syntax
C#
[SerializableAttribute]
public class ShowLicenses : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShowLicenses()()() | Initializes a new instance of the ShowLicenses class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ShowLicenses


ShowLicenses Constructor

ShowLicenses Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► ShowLicenses ► ShowLicenses()()()
Initializes a new instance of the ShowLicenses class
Declaration Syntax
C#
public ShowLicenses()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► ShowLicenses ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


WebEdit Class

WebEdit Class
Namespaces ► Sitecore.Shell.Framework.Commands.System ► WebEdit
Represents the WebEdit command.
Declaration Syntax
C#
[SerializableAttribute]
public class WebEdit : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WebEdit()()() | Initializes a new instance of the WebEdit class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | WebEdit


WebEdit Constructor

WebEdit Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.System ► WebEdit ► WebEdit()()()
Initializes a new instance of the WebEdit class
Declaration Syntax
C#
public WebEdit()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► WebEdit ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.System ► WebEdit ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Sitecore.Shell.Framework.Commands.TemplateBuilder Namespace

Sitecore.Shell.Framework.Commands.TemplateBuilder Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.TemplateBuilder
Types
All Types Classes
Icon | Type | Description
 | Build | Represents the Add Field command.
 | MoveDown | Represents the Add Field command.
 | MoveFirst | Represents the Add Field command.
 | MoveLast | Represents the Add Field command.
 | MoveUp | Represents the Add Field command.
 | NewMaster | Represents the Add Field command.
 | Remove | Represents the Add Field command.
 | SetBaseTemplates | Represents the Add Field command.
 | SetStandardValues | Represents a SetStandardValues.


Build Class

Build Class
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► Build
Represents the Add Field command.
Declaration Syntax
C#
[SerializableAttribute]
public class Build : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Build()()() | Initializes a new instance of the Build class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Build


Build Constructor

Build Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► Build ► Build()()()
Initializes a new instance of the Build class
Declaration Syntax
C#
public Build()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► Build ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► Build ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► Build ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


MoveDown Class

MoveDown Class
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveDown
Represents the Add Field command.
Declaration Syntax
C#
[SerializableAttribute]
public class MoveDown : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MoveDown()()() | Initializes a new instance of the MoveDown class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | MoveDown


MoveDown Constructor

MoveDown Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveDown ► MoveDown()()()
Initializes a new instance of the MoveDown class
Declaration Syntax
C#
public MoveDown()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveDown ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveDown ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveDown ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


MoveFirst Class

MoveFirst Class
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveFirst
Represents the Add Field command.
Declaration Syntax
C#
[SerializableAttribute]
public class MoveFirst : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MoveFirst()()() | Initializes a new instance of the MoveFirst class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | MoveFirst


MoveFirst Constructor

MoveFirst Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveFirst ► MoveFirst()()()
Initializes a new instance of the MoveFirst class
Declaration Syntax
C#
public MoveFirst()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveFirst ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveFirst ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveFirst ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


MoveLast Class

MoveLast Class
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveLast
Represents the Add Field command.
Declaration Syntax
C#
[SerializableAttribute]
public class MoveLast : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MoveLast()()() | Initializes a new instance of the MoveLast class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | MoveLast


MoveLast Constructor

MoveLast Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveLast ► MoveLast()()()
Initializes a new instance of the MoveLast class
Declaration Syntax
C#
public MoveLast()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveLast ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveLast ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveLast ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


MoveUp Class

MoveUp Class
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveUp
Represents the Add Field command.
Declaration Syntax
C#
[SerializableAttribute]
public class MoveUp : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MoveUp()()() | Initializes a new instance of the MoveUp class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | MoveUp


MoveUp Constructor

MoveUp Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveUp ► MoveUp()()()
Initializes a new instance of the MoveUp class
Declaration Syntax
C#
public MoveUp()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveUp ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveUp ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► MoveUp ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


NewMaster Class

NewMaster Class
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► NewMaster
Represents the Add Field command.
Declaration Syntax
C#
[SerializableAttribute]
public class NewMaster : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NewMaster()()() | Initializes a new instance of the NewMaster class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | NewMaster


NewMaster Constructor

NewMaster Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► NewMaster ► NewMaster()()()
Initializes a new instance of the NewMaster class
Declaration Syntax
C#
public NewMaster()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► NewMaster ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► NewMaster ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► NewMaster ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Remove Class

Remove Class
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► Remove
Represents the Add Field command.
Declaration Syntax
C#
[SerializableAttribute]
public class Remove : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Remove()()() | Initializes a new instance of the Remove class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Remove


Remove Constructor

Remove Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► Remove ► Remove()()()
Initializes a new instance of the Remove class
Declaration Syntax
C#
public Remove()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► Remove ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► Remove ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► Remove ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


SetBaseTemplates Class

SetBaseTemplates Class
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► SetBaseTemplates
Represents the Add Field command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetBaseTemplates : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetBaseTemplates()()() | Initializes a new instance of the SetBaseTemplates class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetBaseTemplates


SetBaseTemplates Constructor

SetBaseTemplates Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► SetBaseTemplates ► SetBaseTemplates()()()
Initializes a new instance of the SetBaseTemplates class
Declaration Syntax
C#
public SetBaseTemplates()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► SetBaseTemplates ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► SetBaseTemplates ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► SetBaseTemplates ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


SetStandardValues Class

SetStandardValues Class
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► SetStandardValues
Represents a SetStandardValues.
Declaration Syntax
C#
[SerializableAttribute]
public class SetStandardValues : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetStandardValues()()() | Initializes a new instance of the SetStandardValues class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetStandardValues


SetStandardValues Constructor

SetStandardValues Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► SetStandardValues ► SetStandardValues()()()
Initializes a new instance of the SetStandardValues class
Declaration Syntax
C#
public SetStandardValues()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► SetStandardValues ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► SetStandardValues ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.TemplateBuilder ► SetStandardValues ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected static void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Sitecore.Shell.Framework.Commands.Templates Namespace

Sitecore.Shell.Framework.Commands.Templates Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.Templates
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.Templates
Types
All Types Classes
Icon | Type | Description
 | AddField | Represents the Add Field command.
 | AddMaster | Represents the Add Master command.
 | AddSection | Represents the Add Section command.
 | CreateStandardValues | Represents the Create Standard Values command.
 | New | Represents the New command.
 | NewFolder | Represents the New Folder command.


AddField Class

AddField Class
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddField
Represents the Add Field command.
Declaration Syntax
C#
[SerializableAttribute]
public class AddField : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddField()()() | Initializes a new instance of the AddField class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AddField


AddField Constructor

AddField Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddField ► AddField()()()
Initializes a new instance of the AddField class
Declaration Syntax
C#
public AddField()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddField ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddField ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddField ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


AddMaster Class

AddMaster Class
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddMaster
Represents the Add Master command.
Declaration Syntax
C#
[SerializableAttribute]
public class AddMaster : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMaster()()() | Initializes a new instance of the AddMaster class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AddMaster


AddMaster Constructor

AddMaster Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddMaster ► AddMaster()()()
Initializes a new instance of the AddMaster class
Declaration Syntax
C#
public AddMaster()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddMaster ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddMaster ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddMaster ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


AddSection Class

AddSection Class
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddSection
Represents the Add Section command.
Declaration Syntax
C#
[SerializableAttribute]
public class AddSection : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddSection()()() | Initializes a new instance of the AddSection class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | AddSection


AddSection Constructor

AddSection Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddSection ► AddSection()()()
Initializes a new instance of the AddSection class
Declaration Syntax
C#
public AddSection()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddSection ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddSection ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► AddSection ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CreateStandardValues Class

CreateStandardValues Class
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► CreateStandardValues
Represents the Create Standard Values command.
Declaration Syntax
C#
[SerializableAttribute]
public class CreateStandardValues : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateStandardValues()()() | Initializes a new instance of the CreateStandardValues class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | CreateStandardValues


CreateStandardValues Constructor

CreateStandardValues Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► CreateStandardValues ► CreateStandardValues()()()
Initializes a new instance of the CreateStandardValues class
Declaration Syntax
C#
public CreateStandardValues()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► CreateStandardValues ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► CreateStandardValues ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


New Class

New Class
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► New
Represents the New command.
Declaration Syntax
C#
[SerializableAttribute]
public class New : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | New()()() | Initializes a new instance of the New class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the specified args.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | New


New Constructor

New Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► New ► New()()()
Initializes a new instance of the New class
Declaration Syntax
C#
public New()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► New ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► New ► Run(ClientPipelineArgs)
Runs the specified args.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


NewFolder Class

NewFolder Class
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► NewFolder
Represents the New Folder command.
Declaration Syntax
C#
[SerializableAttribute]
public class NewFolder : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NewFolder()()() | Initializes a new instance of the NewFolder class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | NewFolder


NewFolder Constructor

NewFolder Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► NewFolder ► NewFolder()()()
Initializes a new instance of the NewFolder class
Declaration Syntax
C#
public NewFolder()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► NewFolder ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Templates ► NewFolder ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Sitecore.Shell.Framework.Commands.UserManager Namespace

Sitecore.Shell.Framework.Commands.UserManager Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.UserManager
Types
All Types Classes
Icon | Type | Description
 | ChangeAccount | Represents the Change Domain command.
 | ChangeDomain | Represents the Change Domain command.
 | Delete | Represents the New User command.
 | Disable | Represents the Edit User command.
 | EditUser | Represents the Edit User command.
 | Enable | Represents the Edit User command.
 | NewUser | Represents the New User command.
 | OpenItemSecurityEditor | Represents the Edit User command.
 | ResetMySettings | Represents the Edit User command.
 | ResetSettings | Represents the Edit User command.
 | SelectAccount | Represents the Change Domain command.
 | SetPassword | Represents the Edit User command.
 | Unlock | Represents the Edit User command.


ChangeAccount Class

ChangeAccount Class
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► ChangeAccount
Represents the Change Domain command.
Declaration Syntax
C#
[SerializableAttribute]
public class ChangeAccount : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangeAccount()()() | Initializes a new instance of the ChangeAccount class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ChangeAccount


ChangeAccount Constructor

ChangeAccount Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► ChangeAccount ► ChangeAccount()()()
Initializes a new instance of the ChangeAccount class
Declaration Syntax
C#
public ChangeAccount()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► ChangeAccount ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


ChangeDomain Class

ChangeDomain Class
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► ChangeDomain
Represents the Change Domain command.
Declaration Syntax
C#
[SerializableAttribute]
public class ChangeDomain : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangeDomain()()() | Initializes a new instance of the ChangeDomain class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ChangeDomain


ChangeDomain Constructor

ChangeDomain Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► ChangeDomain ► ChangeDomain()()()
Initializes a new instance of the ChangeDomain class
Declaration Syntax
C#
public ChangeDomain()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► ChangeDomain ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Delete Class

Delete Class
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Delete
Represents the New User command.
Declaration Syntax
C#
[SerializableAttribute]
public class Delete : Command, ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Delete()()() | Initializes a new instance of the Delete class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Delete


Delete Constructor

Delete Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Delete ► Delete()()()
Initializes a new instance of the Delete class
Declaration Syntax
C#
public Delete()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Delete ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Delete ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


Disable Class

Disable Class
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Disable
Represents the Edit User command.
Declaration Syntax
C#
[SerializableAttribute]
public class Disable : Command, ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Disable()()() | Initializes a new instance of the Disable class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Disable


Disable Constructor

Disable Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Disable ► Disable()()()
Initializes a new instance of the Disable class
Declaration Syntax
C#
public Disable()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Disable ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Disable ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


EditUser Class

EditUser Class
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► EditUser
Represents the Edit User command.
Declaration Syntax
C#
[SerializableAttribute]
public class EditUser : Command, ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditUser()()() | Initializes a new instance of the EditUser class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | EditUser


EditUser Constructor

EditUser Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► EditUser ► EditUser()()()
Initializes a new instance of the EditUser class
Declaration Syntax
C#
public EditUser()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► EditUser ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► EditUser ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► EditUser ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected static void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


Enable Class

Enable Class
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Enable
Represents the Edit User command.
Declaration Syntax
C#
[SerializableAttribute]
public class Enable : Command, ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Enable()()() | Initializes a new instance of the Enable class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Enable


Enable Constructor

Enable Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Enable ► Enable()()()
Initializes a new instance of the Enable class
Declaration Syntax
C#
public Enable()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Enable ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Enable ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


NewUser Class

NewUser Class
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► NewUser
Represents the New User command.
Declaration Syntax
C#
[SerializableAttribute]
public class NewUser : Command, ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NewUser()()() | Initializes a new instance of the NewUser class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | NewUser


NewUser Constructor

NewUser Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► NewUser ► NewUser()()()
Initializes a new instance of the NewUser class
Declaration Syntax
C#
public NewUser()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► NewUser ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► NewUser ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► NewUser ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected static void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


OpenItemSecurityEditor Class

OpenItemSecurityEditor Class
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► OpenItemSecurityEditor
Represents the Edit User command.
Declaration Syntax
C#
[SerializableAttribute]
public class OpenItemSecurityEditor : Command,
    ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OpenItemSecurityEditor()()() | Initializes a new instance of the OpenItemSecurityEditor class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | OpenItemSecurityEditor
 |  |  | OpenItemSecurityEditorContextAware


OpenItemSecurityEditor Constructor

OpenItemSecurityEditor Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► OpenItemSecurityEditor ► OpenItemSecurityEditor()()()
Initializes a new instance of the OpenItemSecurityEditor class
Declaration Syntax
C#
public OpenItemSecurityEditor()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► OpenItemSecurityEditor ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► OpenItemSecurityEditor ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


ResetMySettings Class

ResetMySettings Class
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► ResetMySettings
Represents the Edit User command.
Declaration Syntax
C#
[SerializableAttribute]
public class ResetMySettings : Command,
    ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResetMySettings()()() | Initializes a new instance of the ResetMySettings class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ResetMySettings


ResetMySettings Constructor

ResetMySettings Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► ResetMySettings ► ResetMySettings()()()
Initializes a new instance of the ResetMySettings class
Declaration Syntax
C#
public ResetMySettings()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► ResetMySettings ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► ResetMySettings ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


ResetSettings Class

ResetSettings Class
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► ResetSettings
Represents the Edit User command.
Declaration Syntax
C#
[SerializableAttribute]
public class ResetSettings : Command,
    ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResetSettings()()() | Initializes a new instance of the ResetSettings class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ResetSettings


ResetSettings Constructor

ResetSettings Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► ResetSettings ► ResetSettings()()()
Initializes a new instance of the ResetSettings class
Declaration Syntax
C#
public ResetSettings()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► ResetSettings ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► ResetSettings ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


SelectAccount Class

SelectAccount Class
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► SelectAccount
Represents the Change Domain command.
Declaration Syntax
C#
[SerializableAttribute]
public class SelectAccount : Command,
    ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelectAccount()()() | Initializes a new instance of the SelectAccount class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SelectAccount


SelectAccount Constructor

SelectAccount Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► SelectAccount ► SelectAccount()()()
Initializes a new instance of the SelectAccount class
Declaration Syntax
C#
public SelectAccount()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► SelectAccount ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► SelectAccount ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected static void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


SetPassword Class

SetPassword Class
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► SetPassword
Represents the Edit User command.
Declaration Syntax
C#
[SerializableAttribute]
public class SetPassword : Command,
    ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetPassword()()() | Initializes a new instance of the SetPassword class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | SetPassword


SetPassword Constructor

SetPassword Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► SetPassword ► SetPassword()()()
Initializes a new instance of the SetPassword class
Declaration Syntax
C#
public SetPassword()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► SetPassword ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► SetPassword ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected static void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


Unlock Class

Unlock Class
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Unlock
Represents the Edit User command.
Declaration Syntax
C#
[SerializableAttribute]
public class Unlock : Command, ISupportsContinuation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Unlock()()() | Initializes a new instance of the Unlock class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Inherited from Command.)
 | Run(ClientPipelineArgs) | Runs the pipeline.
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Unlock


Unlock Constructor

Unlock Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Unlock ► Unlock()()()
Initializes a new instance of the Unlock class
Declaration Syntax
C#
public Unlock()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Unlock ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


Run Method (args)

Run Method (args)
Namespaces ► Sitecore.Shell.Framework.Commands.UserManager ► Unlock ► Run(ClientPipelineArgs)
Runs the pipeline.
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


Sitecore.Shell.Framework.Commands.WebEdit Namespace

Sitecore.Shell.Framework.Commands.WebEdit Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.WebEdit
Types
All Types Classes
Icon | Type | Description
 | ChangeLanguage | Represents the Add Field command.
 | Logout | Represents the Add Field command.
 | Preview | Represents the Add Field command.


ChangeLanguage Class

ChangeLanguage Class
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► ChangeLanguage
Represents the Add Field command.
Declaration Syntax
C#
[SerializableAttribute]
public class ChangeLanguage : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangeLanguage()()() | Initializes a new instance of the ChangeLanguage class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Overrides Command.GetHeader(CommandContext, String).)
 | GetIcon(CommandContext, String) | Gets the icon. (Overrides Command.GetIcon(CommandContext, String).)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | ChangeLanguage


ChangeLanguage Constructor

ChangeLanguage Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► ChangeLanguage ► ChangeLanguage()()()
Initializes a new instance of the ChangeLanguage class
Declaration Syntax
C#
public ChangeLanguage()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► ChangeLanguage ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► ChangeLanguage ► GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.


GetHeader Method (context, header)

GetHeader Method (context, header)
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► ChangeLanguage ► GetHeader(CommandContext, String)
Gets the header.
Declaration Syntax
C#
public override string GetHeader(
    CommandContext context,
    string header
)
Parameters
context (CommandContext)
The context.
header (String)
The default header.
Return Value
The header.


GetIcon Method (context, icon)

GetIcon Method (context, icon)
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► ChangeLanguage ► GetIcon(CommandContext, String)
Gets the icon.
Declaration Syntax
C#
public override string GetIcon(
    CommandContext context,
    string icon
)
Parameters
context (CommandContext)
The context.
icon (String)
The default icon.
Return Value
The icon.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► ChangeLanguage ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Logout Class

Logout Class
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► Logout
Represents the Add Field command.
Declaration Syntax
C#
[SerializableAttribute]
public class Logout : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Logout()()() | Initializes a new instance of the Logout class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Logout


Logout Constructor

Logout Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► Logout ► Logout()()()
Initializes a new instance of the Logout class
Declaration Syntax
C#
public Logout()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► Logout ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► Logout ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Preview Class

Preview Class
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► Preview
Represents the Add Field command.
Declaration Syntax
C#
[SerializableAttribute]
public class Preview : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Preview()()() | Initializes a new instance of the Preview class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Preview


Preview Constructor

Preview Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► Preview ► Preview()()()
Initializes a new instance of the Preview class
Declaration Syntax
C#
public Preview()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► Preview ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.WebEdit ► Preview ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Sitecore.Shell.Framework.Commands.Workbox Namespace

Sitecore.Shell.Framework.Commands.Workbox Namespace
Namespaces ► Sitecore.Shell.Framework.Commands.Workbox
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Commands.Workbox
Types
All Types Classes
Icon | Type | Description
 | Logout | Represents the Change Domain command.


Logout Class

Logout Class
Namespaces ► Sitecore.Shell.Framework.Commands.Workbox ► Logout
Represents the Change Domain command.
Declaration Syntax
C#
[SerializableAttribute]
public class Logout : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Logout()()() | Initializes a new instance of the Logout class
 | DeserializeItems(String) | Deserializes the item from a string list. (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command in the specified context. (Overrides Command.Execute(CommandContext).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Inherited from Command.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHeader(CommandContext, String) | Gets the header. (Inherited from Command.)
 | GetIcon(CommandContext, String) | Gets the icon. (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | Gets the submenu items. (Inherited from Command.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(CommandContext, String) | Gets the value. (Inherited from Command.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | HasField(Item, String) | Determines whether the specified item has the specified field. (Inherited from Command.)
 | IsAdvancedClient()()() | Determines whether this browser is an advanced client. (Inherited from Command.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()[]) | Serializes the items to a string list. (Inherited from Command.)
 | Start(String, Item) | Starts the specified pipeline. (Inherited from Command.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Logout


Logout Constructor

Logout Constructor
Namespaces ► Sitecore.Shell.Framework.Commands.Workbox ► Logout ► Logout()()()
Initializes a new instance of the Logout class
Declaration Syntax
C#
public Logout()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Workbox ► Logout ► Execute(CommandContext)
Executes the command in the specified context.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.


QueryState Method (context)

QueryState Method (context)
Namespaces ► Sitecore.Shell.Framework.Commands.Workbox ► Logout ► QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.


Sitecore.Shell.Framework.Jobs Namespace

Sitecore.Shell.Framework.Jobs Namespace
Namespaces ► Sitecore.Shell.Framework.Jobs
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Jobs
Types
All Types Classes
Icon | Type | Description
 | LongRunningOptions | Options for providing progress indication of long running jobs.


LongRunningOptions Class

LongRunningOptions Class
Namespaces ► Sitecore.Shell.Framework.Jobs ► LongRunningOptions
Options for providing progress indication of long running jobs.
Declaration Syntax
C#
public class LongRunningOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LongRunningOptions()()() | Initializes a new instance of the LongRunningOptions class.
 | LongRunningOptions(String) | Initializes a new instance of the LongRunningOptions class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle | Gets or sets the handle.
 | Icon | Gets or sets the icon.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets or sets the message.
 | Parse()()() | Parses this instance.
 | ShowModal()()() | Shows the progress dialog in modal form.
 | Threshold | Gets or sets the threshold.
 | Title | Gets or sets the title.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
LongRunningOptions


LongRunningOptions Constructor

LongRunningOptions Constructor
Namespaces ► Sitecore.Shell.Framework.Jobs ► LongRunningOptions ► LongRunningOptions()()()
Members
Icon | Member | Description
 | LongRunningOptions()()() | Initializes a new instance of the LongRunningOptions class.
 | LongRunningOptions(String) | Initializes a new instance of the LongRunningOptions class.


LongRunningOptions Constructor

LongRunningOptions Constructor
Namespaces ► Sitecore.Shell.Framework.Jobs ► LongRunningOptions ► LongRunningOptions()()()
Initializes a new instance of the LongRunningOptions class.
Declaration Syntax
C#
public LongRunningOptions()


LongRunningOptions Constructor (handle)

LongRunningOptions Constructor (handle)
Namespaces ► Sitecore.Shell.Framework.Jobs ► LongRunningOptions ► LongRunningOptions(String)
Initializes a new instance of the LongRunningOptions class.
Declaration Syntax
C#
public LongRunningOptions(
    string handle
)
Parameters
handle (String)
The handle.


Handle Property

Handle Property
Namespaces ► Sitecore.Shell.Framework.Jobs ► LongRunningOptions ► Handle
Gets or sets the handle.
Declaration Syntax
C#
public string Handle { get; set; }
Value
The handle.


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Framework.Jobs ► LongRunningOptions ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


Message Property

Message Property
Namespaces ► Sitecore.Shell.Framework.Jobs ► LongRunningOptions ► Message
Gets or sets the message.
Declaration Syntax
C#
public string Message { get; set; }
Value
The message.


Parse Method

Parse Method
Namespaces ► Sitecore.Shell.Framework.Jobs ► LongRunningOptions ► Parse()()()
Parses this instance.
Declaration Syntax
C#
public static LongRunningOptions Parse()
Return Value
The parse.


ShowModal Method

ShowModal Method
Namespaces ► Sitecore.Shell.Framework.Jobs ► LongRunningOptions ► ShowModal()()()
Shows the progress dialog in modal form.
Declaration Syntax
C#
public void ShowModal()


Threshold Property

Threshold Property
Namespaces ► Sitecore.Shell.Framework.Jobs ► LongRunningOptions ► Threshold
Gets or sets the threshold.
Declaration Syntax
C#
public int Threshold { get; set; }
Value
The threshold.


Title Property

Title Property
Namespaces ► Sitecore.Shell.Framework.Jobs ► LongRunningOptions ► Title
Gets or sets the title.
Declaration Syntax
C#
public string Title { get; set; }
Value
The title.


ToString Method

ToString Method
Namespaces ► Sitecore.Shell.Framework.Jobs ► LongRunningOptions ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


Sitecore.Shell.Framework.Pipelines Namespace

Sitecore.Shell.Framework.Pipelines Namespace
Namespaces ► Sitecore.Shell.Framework.Pipelines
Declaration Syntax
C#
namespace Sitecore.Shell.Framework.Pipelines
Types
All Types Classes
Icon | Type | Description
 | AddFromMaster | Represents the Add From Master pipeline.
 | AddFromTemplate | Represents the Add From Template pipeline.
 | ArchiveItems | Contains methods to called during the Delete Item pipeline.
 | CopyItems | Represents the Copy Items UI pipeline.
 | CopyItemsArgs | Represents a the arguments to the Copy Items pipeline.
 | DeleteFiles | Represents the Delete Files pipeline.
 | DeleteItems | Contains methods to called during the Delete Item pipeline.
 | DragItemTo | Represents the Drag Item To pipeline.
 | DuplicateItem | Represents the Duplicate pipeline.
 | ItemOperation | Represents the Rename Item pipeline.
 | LaunchSearchResult | Launches the instant search results.
 | LaunchSearchResultArgs | Launch search result pipeline arguments.
 | MoveItems | Contains methods to be called during the Move Item pipeline.
 | NewFileFolder | Represents the New File Folder pipeline.
 | NewFolderItem | Represents the New Folder Item pipeline.
 | RenameItem | Represents the Rename Item pipeline.


AddFromMaster Class

AddFromMaster Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► AddFromMaster
Represents the Add From Master pipeline.
Declaration Syntax
C#
public class AddFromMaster
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddFromMaster()()() | Initializes a new instance of the AddFromMaster class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ClientPipelineArgs) | Executes the specified args.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMaster(ClientPipelineArgs) | Gets the master.
 | GetName(ClientPipelineArgs) | Obsolete. Gets the name.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AddFromMaster


AddFromMaster Constructor

AddFromMaster Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► AddFromMaster ► AddFromMaster()()()
Initializes a new instance of the AddFromMaster class
Declaration Syntax
C#
public AddFromMaster()


Execute Method (args)

Execute Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► AddFromMaster ► Execute(ClientPipelineArgs)
Executes the specified args.
Declaration Syntax
C#
public void Execute(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


GetMaster Method (args)

GetMaster Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► AddFromMaster ► GetMaster(ClientPipelineArgs)
Gets the master.
Declaration Syntax
C#
public void GetMaster(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


GetName Method (args)

GetName Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► AddFromMaster ► GetName(ClientPipelineArgs)
Gets the name.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated")]
public void GetName(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


AddFromTemplate Class

AddFromTemplate Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► AddFromTemplate
Represents the Add From Template pipeline.
Declaration Syntax
C#
public class AddFromTemplate
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddFromTemplate()()() | Initializes a new instance of the AddFromTemplate class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ClientPipelineArgs) | Executes the action.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTemplate(ClientPipelineArgs) | Gets the template.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AddFromTemplate


AddFromTemplate Constructor

AddFromTemplate Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► AddFromTemplate ► AddFromTemplate()()()
Initializes a new instance of the AddFromTemplate class
Declaration Syntax
C#
public AddFromTemplate()


Execute Method (args)

Execute Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► AddFromTemplate ► Execute(ClientPipelineArgs)
Executes the action.
Declaration Syntax
C#
public void Execute(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


GetTemplate Method (args)

GetTemplate Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► AddFromTemplate ► GetTemplate(ClientPipelineArgs)
Gets the template.
Declaration Syntax
C#
public void GetTemplate(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.


ArchiveItems Class

ArchiveItems Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► ArchiveItems
Contains methods to called during the Delete Item pipeline.
Declaration Syntax
C#
public class ArchiveItems
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ArchiveItems()()() | Initializes a new instance of the ArchiveItems class
 | Confirm(ClientPipelineArgs) | Confirms that the items are to be deleted.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ClientPipelineArgs) | Deletes the items.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ArchiveItems


ArchiveItems Constructor

ArchiveItems Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► ArchiveItems ► ArchiveItems()()()
Initializes a new instance of the ArchiveItems class
Declaration Syntax
C#
public ArchiveItems()


Confirm Method (args)

Confirm Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► ArchiveItems ► Confirm(ClientPipelineArgs)
Confirms that the items are to be deleted.
Declaration Syntax
C#
public void Confirm(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Execute Method (args)

Execute Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► ArchiveItems ► Execute(ClientPipelineArgs)
Deletes the items.
Declaration Syntax
C#
public void Execute(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CopyItems Class

CopyItems Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► CopyItems
Represents the Copy Items UI pipeline.
Declaration Syntax
C#
public class CopyItems
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CopyItems()()() | Initializes a new instance of the CopyItems class
 | CheckDestination(CopyItemsArgs) | Checks the language.
 | CheckLanguage(CopyItemsArgs) | Checks the language.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CopyItemsArgs) | Executes the specified args.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDestination(CopyItemsArgs) | Gets the destination.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CopyItems


CopyItems Constructor

CopyItems Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► CopyItems ► CopyItems()()()
Initializes a new instance of the CopyItems class
Declaration Syntax
C#
public CopyItems()


CheckDestination Method (args)

CheckDestination Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► CopyItems ► CheckDestination(CopyItemsArgs)
Checks the language.
Declaration Syntax
C#
public void CheckDestination(
    CopyItemsArgs args
)
Parameters
args (CopyItemsArgs)
The arguments.


CheckLanguage Method (args)

CheckLanguage Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► CopyItems ► CheckLanguage(CopyItemsArgs)
Checks the language.
Declaration Syntax
C#
public void CheckLanguage(
    CopyItemsArgs args
)
Parameters
args (CopyItemsArgs)
The arguments.


Execute Method (args)

Execute Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► CopyItems ► Execute(CopyItemsArgs)
Executes the specified args.
Declaration Syntax
C#
public void Execute(
    CopyItemsArgs args
)
Parameters
args (CopyItemsArgs)
The arguments.


GetDestination Method (args)

GetDestination Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► CopyItems ► GetDestination(CopyItemsArgs)
Gets the destination.
Declaration Syntax
C#
public void GetDestination(
    CopyItemsArgs args
)
Parameters
args (CopyItemsArgs)
The arguments.


CopyItemsArgs Class

CopyItemsArgs Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► CopyItemsArgs
Represents a the arguments to the Copy Items pipeline.
Declaration Syntax
C#
[SerializableAttribute]
public class CopyItemsArgs : ClientPipelineArgs,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CopyItemsArgs()()() | Initializes a new instance of the CopyItemsArgs class.
 | CopyItemsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the CopyItemsArgs class from a serialization context.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
 | Copies | Gets or sets the copies.
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from ClientPipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
 | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitForPostBack()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ClientPipelineArgs
 |  |  |  | CopyItemsArgs


CopyItemsArgs Constructor

CopyItemsArgs Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► CopyItemsArgs ► CopyItemsArgs()()()
Members
Icon | Member | Description
 | CopyItemsArgs()()() | Initializes a new instance of the CopyItemsArgs class.
 | CopyItemsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the CopyItemsArgs class from a serialization context.


CopyItemsArgs Constructor

CopyItemsArgs Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► CopyItemsArgs ► CopyItemsArgs()()()
Initializes a new instance of the CopyItemsArgs class.
Declaration Syntax
C#
public CopyItemsArgs()


CopyItemsArgs Constructor (info, context)

CopyItemsArgs Constructor (info, context)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► CopyItemsArgs ► CopyItemsArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the CopyItemsArgs class from a serialization context.
Declaration Syntax
C#
protected CopyItemsArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialized data.
context (StreamingContext)
The context.


Copies Property

Copies Property
Namespaces ► Sitecore.Shell.Framework.Pipelines ► CopyItemsArgs ► Copies
Gets or sets the copies.
Declaration Syntax
C#
public Item[] Copies { get; set; }
Value
The copies.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► CopyItemsArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


DeleteFiles Class

DeleteFiles Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DeleteFiles
Represents the Delete Files pipeline.
Declaration Syntax
C#
public class DeleteFiles
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DeleteFiles()()() | Initializes a new instance of the DeleteFiles class
 | Confirm(ClientPipelineArgs) | Confirms the specified args.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ClientPipelineArgs) | Executes the specified args.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DeleteFiles


DeleteFiles Constructor

DeleteFiles Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DeleteFiles ► DeleteFiles()()()
Initializes a new instance of the DeleteFiles class
Declaration Syntax
C#
public DeleteFiles()


Confirm Method (args)

Confirm Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DeleteFiles ► Confirm(ClientPipelineArgs)
Confirms the specified args.
Declaration Syntax
C#
public void Confirm(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Execute Method (args)

Execute Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DeleteFiles ► Execute(ClientPipelineArgs)
Executes the specified args.
Declaration Syntax
C#
public void Execute(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


DeleteItems Class

DeleteItems Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DeleteItems
Contains methods to called during the Delete Item pipeline.
Declaration Syntax
C#
public class DeleteItems : ItemOperation
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DeleteItems()()() | Initializes a new instance of the DeleteItems class
 | CheckLanguage(ClientPipelineArgs) | Checks the permissions.
 | CheckLinks(ClientPipelineArgs) | Checks the links.
 | CheckPermissions(ClientPipelineArgs) | Checks the permissions.
 | CheckTemplateLinks(ClientPipelineArgs) | If the item that is about to be deleted is a template, and there are Items that are based on it, the pipeline is aborted.
 | Confirm(ClientPipelineArgs) | Confirms that the items are to be deleted.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ClientPipelineArgs) | Deletes the items.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ItemOperation
 |  | DeleteItems


DeleteItems Constructor

DeleteItems Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DeleteItems ► DeleteItems()()()
Initializes a new instance of the DeleteItems class
Declaration Syntax
C#
public DeleteItems()


CheckLanguage Method (args)

CheckLanguage Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DeleteItems ► CheckLanguage(ClientPipelineArgs)
Checks the permissions.
Declaration Syntax
C#
public void CheckLanguage(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CheckLinks Method (args)

CheckLinks Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DeleteItems ► CheckLinks(ClientPipelineArgs)
Checks the links.
Declaration Syntax
C#
public void CheckLinks(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CheckPermissions Method (args)

CheckPermissions Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DeleteItems ► CheckPermissions(ClientPipelineArgs)
Checks the permissions.
Declaration Syntax
C#
public void CheckPermissions(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CheckTemplateLinks Method (args)

CheckTemplateLinks Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DeleteItems ► CheckTemplateLinks(ClientPipelineArgs)
If the item that is about to be deleted is a template, and there are Items that are based on it, the pipeline is aborted.
Declaration Syntax
C#
public void CheckTemplateLinks(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Confirm Method (args)

Confirm Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DeleteItems ► Confirm(ClientPipelineArgs)
Confirms that the items are to be deleted.
Declaration Syntax
C#
public void Confirm(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Execute Method (args)

Execute Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DeleteItems ► Execute(ClientPipelineArgs)
Deletes the items.
Declaration Syntax
C#
public void Execute(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


DragItemTo Class

DragItemTo Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DragItemTo
Represents the Drag Item To pipeline.
Declaration Syntax
C#
public class DragItemTo : ItemOperation
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DragItemTo()()() | Initializes a new instance of the DragItemTo class
 | CheckLanguage(ClientPipelineArgs) | Checks the language.
 | CheckLinks(ClientPipelineArgs) | Checks the links.
 | CheckPermissions(ClientPipelineArgs) | Checks the permissions.
 | CheckShadows(ClientPipelineArgs) | Checks the shadows.
 | Confirm(ClientPipelineArgs) | Confirm.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ClientPipelineArgs) | Executes the specified args.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RepairLinks(ClientPipelineArgs) | Repairs the links.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ItemOperation
 |  | DragItemTo


DragItemTo Constructor

DragItemTo Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DragItemTo ► DragItemTo()()()
Initializes a new instance of the DragItemTo class
Declaration Syntax
C#
public DragItemTo()


CheckLanguage Method (args)

CheckLanguage Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DragItemTo ► CheckLanguage(ClientPipelineArgs)
Checks the language.
Declaration Syntax
C#
public void CheckLanguage(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CheckLinks Method (args)

CheckLinks Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DragItemTo ► CheckLinks(ClientPipelineArgs)
Checks the links.
Declaration Syntax
C#
public void CheckLinks(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CheckPermissions Method (args)

CheckPermissions Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DragItemTo ► CheckPermissions(ClientPipelineArgs)
Checks the permissions.
Declaration Syntax
C#
public void CheckPermissions(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CheckShadows Method (args)

CheckShadows Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DragItemTo ► CheckShadows(ClientPipelineArgs)
Checks the shadows.
Declaration Syntax
C#
public void CheckShadows(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Confirm Method (args)

Confirm Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DragItemTo ► Confirm(ClientPipelineArgs)
Confirm.
Declaration Syntax
C#
public void Confirm(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Execute Method (args)

Execute Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DragItemTo ► Execute(ClientPipelineArgs)
Executes the specified args.
Declaration Syntax
C#
public void Execute(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


RepairLinks Method (args)

RepairLinks Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DragItemTo ► RepairLinks(ClientPipelineArgs)
Repairs the links.
Declaration Syntax
C#
public void RepairLinks(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


DuplicateItem Class

DuplicateItem Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DuplicateItem
Represents the Duplicate pipeline.
Declaration Syntax
C#
public class DuplicateItem
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DuplicateItem()()() | Initializes a new instance of the DuplicateItem class
 | CheckPermissions(ClientPipelineArgs) | Checks the permissions.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ClientPipelineArgs) | Executes the specified args.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetName(ClientPipelineArgs) | Gets the name.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DuplicateItem


DuplicateItem Constructor

DuplicateItem Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DuplicateItem ► DuplicateItem()()()
Initializes a new instance of the DuplicateItem class
Declaration Syntax
C#
public DuplicateItem()


CheckPermissions Method (args)

CheckPermissions Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DuplicateItem ► CheckPermissions(ClientPipelineArgs)
Checks the permissions.
Declaration Syntax
C#
public void CheckPermissions(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Execute Method (args)

Execute Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DuplicateItem ► Execute(ClientPipelineArgs)
Executes the specified args.
Declaration Syntax
C#
public void Execute(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


GetName Method (args)

GetName Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► DuplicateItem ► GetName(ClientPipelineArgs)
Gets the name.
Declaration Syntax
C#
public void GetName(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


ItemOperation Class

ItemOperation Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► ItemOperation
Represents the Rename Item pipeline.
Declaration Syntax
C#
public abstract class ItemOperation
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemOperation()()() | Initializes a new instance of the ItemOperation class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLinks(Item) | Gets the links.
 | GetLinks(Item, Int32) | Gets the links.
 | GetLinks(List<(Of <(ItemLink>)>), Item, Int32) | Gets the links.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LINKTHRESHOLD |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ItemOperation
 |  | DeleteItems
 |  | DragItemTo
 |  | MoveItems
 |  | RenameItem


ItemOperation Constructor

ItemOperation Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► ItemOperation ► ItemOperation()()()
Initializes a new instance of the ItemOperation class
Declaration Syntax
C#
protected ItemOperation()


GetLinks Method

GetLinks Method
Namespaces ► Sitecore.Shell.Framework.Pipelines ► ItemOperation ► GetLinks()()()
Members
Icon | Member | Description
 | GetLinks(Item) | Gets the links.
 | GetLinks(Item, Int32) | Gets the links.
 | GetLinks(List<(Of <(ItemLink>)>), Item, Int32) | Gets the links.


GetLinks Method (item)

GetLinks Method (item)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► ItemOperation ► GetLinks(Item)
Gets the links.
Declaration Syntax
C#
protected static int GetLinks(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The links.


GetLinks Method (item, threshold)

GetLinks Method (item, threshold)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► ItemOperation ► GetLinks(Item, Int32)
Gets the links.
Declaration Syntax
C#
protected static int GetLinks(
    Item item,
    int threshold
)
Parameters
item (Item)
The item.
threshold (Int32)
The threshold.
Return Value
The links.


GetLinks Method (links, item, threshold)

GetLinks Method (links, item, threshold)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► ItemOperation ► GetLinks(List<(Of <(ItemLink>)>), Item, Int32)
Gets the links.
Declaration Syntax
C#
protected static void GetLinks(
    List<ItemLink> links,
    Item item,
    int threshold
)
Parameters
links (List<(Of <( ItemLink >)>))
The links.
item (Item)
The item.
threshold (Int32)
The threshold.


LINKTHRESHOLD Field

LINKTHRESHOLD Field
Namespaces ► Sitecore.Shell.Framework.Pipelines ► ItemOperation ► LINKTHRESHOLD
Declaration Syntax
C#
protected const int LINKTHRESHOLD


LaunchSearchResult Class

LaunchSearchResult Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► LaunchSearchResult
Launches the instant search results.
Declaration Syntax
C#
public class LaunchSearchResult
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LaunchSearchResult()()() | Initializes a new instance of the LaunchSearchResult class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OpenItem(LaunchSearchResultArgs) | Opens the item.
 | SendMessage(LaunchSearchResultArgs) | Sends the message.
 | SetLocation(LaunchSearchResultArgs) | Sets the location.
 | ShowModalDialog(LaunchSearchResultArgs) | Shows the modal dialog.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LaunchSearchResult


LaunchSearchResult Constructor

LaunchSearchResult Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► LaunchSearchResult ► LaunchSearchResult()()()
Initializes a new instance of the LaunchSearchResult class
Declaration Syntax
C#
public LaunchSearchResult()


OpenItem Method (args)

OpenItem Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► LaunchSearchResult ► OpenItem(LaunchSearchResultArgs)
Opens the item.
Declaration Syntax
C#
public void OpenItem(
    LaunchSearchResultArgs args
)
Parameters
args (LaunchSearchResultArgs)
The arguments.


SendMessage Method (args)

SendMessage Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► LaunchSearchResult ► SendMessage(LaunchSearchResultArgs)
Sends the message.
Declaration Syntax
C#
public void SendMessage(
    LaunchSearchResultArgs args
)
Parameters
args (LaunchSearchResultArgs)
The arguments.


SetLocation Method (args)

SetLocation Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► LaunchSearchResult ► SetLocation(LaunchSearchResultArgs)
Sets the location.
Declaration Syntax
C#
public void SetLocation(
    LaunchSearchResultArgs args
)
Parameters
args (LaunchSearchResultArgs)
The arguments.


ShowModalDialog Method (args)

ShowModalDialog Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► LaunchSearchResult ► ShowModalDialog(LaunchSearchResultArgs)
Shows the modal dialog.
Declaration Syntax
C#
public void ShowModalDialog(
    LaunchSearchResultArgs args
)
Parameters
args (LaunchSearchResultArgs)
The arguments.


LaunchSearchResultArgs Class

LaunchSearchResultArgs Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► LaunchSearchResultArgs
Launch search result pipeline arguments.
Declaration Syntax
C#
[SerializableAttribute]
public class LaunchSearchResultArgs : ClientPipelineArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LaunchSearchResultArgs(String) | Initializes a new instance of the LaunchSearchResultArgs class.
 | LaunchSearchResultArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LaunchSearchResultArgs class.
 | Abort()()() | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
 | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
 | AbortPipeline()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
 | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
 | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
 | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
 | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
 | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Dispose()()() | Disposes this instance. (Inherited from PipelineArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessages()()() | Gets the messages. (Inherited from PipelineArgs.)
 | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
 | Initialize()()() | Initializes this instance. (Inherited from PipelineArgs.)
 | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the message. (Inherited from PipelineArgs.)
 | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
 | ProcessorDone()()() | Called when the processor is done. (Inherited from ClientPipelineArgs.)
 | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
 | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
 | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
 | Resume()()() | Resumes a processor. (Inherited from PipelineArgs.)
 | Suspend()()() | Suspends this instance. (Inherited from PipelineArgs.)
 | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
 | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Url | Gets the URL.
 | WaitForPostBack()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
 | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PipelineArgs
 |  |  | ClientPipelineArgs
 |  |  |  | LaunchSearchResultArgs


LaunchSearchResultArgs Constructor

LaunchSearchResultArgs Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► LaunchSearchResultArgs ► LaunchSearchResultArgs()()()
Members
Icon | Member | Description
 | LaunchSearchResultArgs(String) | Initializes a new instance of the LaunchSearchResultArgs class.
 | LaunchSearchResultArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LaunchSearchResultArgs class.


LaunchSearchResultArgs Constructor (info, context)

LaunchSearchResultArgs Constructor (info, context)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► LaunchSearchResultArgs ► LaunchSearchResultArgs(SerializationInfo, StreamingContext)
Initializes a new instance of the LaunchSearchResultArgs class.
Declaration Syntax
C#
protected LaunchSearchResultArgs(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The info.
context (StreamingContext)
The context.


LaunchSearchResultArgs Constructor (url)

LaunchSearchResultArgs Constructor (url)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► LaunchSearchResultArgs ► LaunchSearchResultArgs(String)
Initializes a new instance of the LaunchSearchResultArgs class.
Declaration Syntax
C#
public LaunchSearchResultArgs(
    string url
)
Parameters
url (String)
The URL.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► LaunchSearchResultArgs ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo with the data needed to serialize the target object.
Declaration Syntax
C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo to populate with data.
context (StreamingContext)
The destination (see StreamingContext) for this serialization.
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.


Url Property

Url Property
Namespaces ► Sitecore.Shell.Framework.Pipelines ► LaunchSearchResultArgs ► Url
Gets the URL.
Declaration Syntax
C#
public string Url { get; }
Value
The URL.


MoveItems Class

MoveItems Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► MoveItems
Contains methods to be called during the Move Item pipeline.
Declaration Syntax
C#
public class MoveItems : ItemOperation
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MoveItems()()() | Initializes a new instance of the MoveItems class
 | CheckLinks(ClientPipelineArgs) | Checks the links.
 | CheckPermissions(ClientPipelineArgs) | Checks the permissions.
 | CheckShadows(ClientPipelineArgs) | Checks for shadow items.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ClientPipelineArgs) | Moves the items.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDestination(ClientPipelineArgs) | Gets the destination.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RepairLinks(ClientPipelineArgs) | Repairs the links.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ItemOperation
 |  | MoveItems


MoveItems Constructor

MoveItems Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► MoveItems ► MoveItems()()()
Initializes a new instance of the MoveItems class
Declaration Syntax
C#
public MoveItems()


CheckLinks Method (args)

CheckLinks Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► MoveItems ► CheckLinks(ClientPipelineArgs)
Checks the links.
Declaration Syntax
C#
public void CheckLinks(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CheckPermissions Method (args)

CheckPermissions Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► MoveItems ► CheckPermissions(ClientPipelineArgs)
Checks the permissions.
Declaration Syntax
C#
public void CheckPermissions(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CheckShadows Method (args)

CheckShadows Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► MoveItems ► CheckShadows(ClientPipelineArgs)
Checks for shadow items.
Declaration Syntax
C#
public void CheckShadows(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Execute Method (args)

Execute Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► MoveItems ► Execute(ClientPipelineArgs)
Moves the items.
Declaration Syntax
C#
public void Execute(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


GetDestination Method (args)

GetDestination Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► MoveItems ► GetDestination(ClientPipelineArgs)
Gets the destination.
Declaration Syntax
C#
public void GetDestination(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


RepairLinks Method (args)

RepairLinks Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► MoveItems ► RepairLinks(ClientPipelineArgs)
Repairs the links.
Declaration Syntax
C#
public void RepairLinks(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


NewFileFolder Class

NewFileFolder Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► NewFileFolder
Represents the New File Folder pipeline.
Declaration Syntax
C#
public class NewFileFolder
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NewFileFolder()()() | Initializes a new instance of the NewFileFolder class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ClientPipelineArgs) | Executes the specified args.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetName(ClientPipelineArgs) | Gets the name.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NewFileFolder


NewFileFolder Constructor

NewFileFolder Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► NewFileFolder ► NewFileFolder()()()
Initializes a new instance of the NewFileFolder class
Declaration Syntax
C#
public NewFileFolder()


Execute Method (args)

Execute Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► NewFileFolder ► Execute(ClientPipelineArgs)
Executes the specified args.
Declaration Syntax
C#
public void Execute(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


GetName Method (args)

GetName Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► NewFileFolder ► GetName(ClientPipelineArgs)
Gets the name.
Declaration Syntax
C#
public void GetName(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


NewFolderItem Class

NewFolderItem Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► NewFolderItem
Represents the New Folder Item pipeline.
Declaration Syntax
C#
public class NewFolderItem
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NewFolderItem()()() | Initializes a new instance of the NewFolderItem class
 | CheckPermissions(ClientPipelineArgs) | Checks the permissions.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ClientPipelineArgs) | Executes the specified args.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetName(ClientPipelineArgs) | Gets the name.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NewFolderItem


NewFolderItem Constructor

NewFolderItem Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► NewFolderItem ► NewFolderItem()()()
Initializes a new instance of the NewFolderItem class
Declaration Syntax
C#
public NewFolderItem()


CheckPermissions Method (args)

CheckPermissions Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► NewFolderItem ► CheckPermissions(ClientPipelineArgs)
Checks the permissions.
Declaration Syntax
C#
public void CheckPermissions(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Execute Method (args)

Execute Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► NewFolderItem ► Execute(ClientPipelineArgs)
Executes the specified args.
Declaration Syntax
C#
public void Execute(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


GetName Method (args)

GetName Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► NewFolderItem ► GetName(ClientPipelineArgs)
Gets the name.
Declaration Syntax
C#
public void GetName(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


RenameItem Class

RenameItem Class
Namespaces ► Sitecore.Shell.Framework.Pipelines ► RenameItem
Represents the Rename Item pipeline.
Declaration Syntax
C#
public class RenameItem : ItemOperation
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenameItem()()() | Initializes a new instance of the RenameItem class
 | CheckLinks(ClientPipelineArgs) | Checks the links.
 | CheckPermissions(ClientPipelineArgs) | Checks the permissions.
 | CheckShadows(ClientPipelineArgs) | Checks the shadows.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(ClientPipelineArgs) | Executes the specified args.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNewName(ClientPipelineArgs) | Gets the new name.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RepairLinks(ClientPipelineArgs) | Repairs the links.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ItemOperation
 |  | RenameItem


RenameItem Constructor

RenameItem Constructor
Namespaces ► Sitecore.Shell.Framework.Pipelines ► RenameItem ► RenameItem()()()
Initializes a new instance of the RenameItem class
Declaration Syntax
C#
public RenameItem()


CheckLinks Method (args)

CheckLinks Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► RenameItem ► CheckLinks(ClientPipelineArgs)
Checks the links.
Declaration Syntax
C#
public void CheckLinks(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CheckPermissions Method (args)

CheckPermissions Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► RenameItem ► CheckPermissions(ClientPipelineArgs)
Checks the permissions.
Declaration Syntax
C#
public void CheckPermissions(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


CheckShadows Method (args)

CheckShadows Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► RenameItem ► CheckShadows(ClientPipelineArgs)
Checks the shadows.
Declaration Syntax
C#
public void CheckShadows(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Execute Method (args)

Execute Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► RenameItem ► Execute(ClientPipelineArgs)
Executes the specified args.
Declaration Syntax
C#
public void Execute(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


GetNewName Method (args)

GetNewName Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► RenameItem ► GetNewName(ClientPipelineArgs)
Gets the new name.
Declaration Syntax
C#
public void GetNewName(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


RepairLinks Method (args)

RepairLinks Method (args)
Namespaces ► Sitecore.Shell.Framework.Pipelines ► RenameItem ► RepairLinks(ClientPipelineArgs)
Repairs the links.
Declaration Syntax
C#
public void RepairLinks(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.


Sitecore.Shell.Research Namespace

Sitecore.Shell.Research Namespace
Namespaces ► Sitecore.Shell.Research
Declaration Syntax
C#
namespace Sitecore.Shell.Research
Types
All Types Classes
Icon | Type | Description
 | Tester | Represents a Tester.
 | Testontrol | Represents a Testontrol. Designer generated source file containing control field declarations and event validation.


Tester Class

Tester Class
Namespaces ► Sitecore.Shell.Research ► Tester
Represents a Tester.
Declaration Syntax
C#
public class Tester : Page
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Tester()()() | Initializes a new instance of the Tester class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) | Handles the Load event of the Page control.
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Tester

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Tester Constructor

Tester Constructor
Namespaces ► Sitecore.Shell.Research ► Tester ► Tester()()()
Initializes a new instance of the Tester class
Declaration Syntax
C#
public Tester()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore.Shell.Research ► Tester ► Page_Load(Object, EventArgs)
Handles the Load event of the Page control.
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Testontrol Class

Testontrol Class
Namespaces ► Sitecore.Shell.Research ► Testontrol
Represents a Testontrol.
Designer generated source file containing control field declarations and event validation.
Declaration Syntax
C#
public class Testontrol : MyControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Testontrol()()() | Initializes a new instance of the Testontrol class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from MyControl.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from MyControl.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from MyControl.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) | Handles the Load event of the Page control.
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionState object for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | MyControl
 |  |  |  |  | Testontrol

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Testontrol Constructor

Testontrol Constructor
Namespaces ► Sitecore.Shell.Research ► Testontrol ► Testontrol()()()
Initializes a new instance of the Testontrol class
Declaration Syntax
C#
public Testontrol()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore.Shell.Research ► Testontrol ► Page_Load(Object, EventArgs)
Handles the Load event of the Page control.
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Upgrades Namespace

Sitecore.Shell.Upgrades Namespace
Namespaces ► Sitecore.Shell.Upgrades
Declaration Syntax
C#
namespace Sitecore.Shell.Upgrades
Types
All Types Classes
Icon | Type | Description
 | SR1Update0 | Sitecore 6.0.0 SR1 upgrade


SR1Update0 Class

SR1Update0 Class
Namespaces ► Sitecore.Shell.Upgrades ► SR1Update0
Sitecore 6.0.0 SR1 upgrade
Declaration Syntax
C#
public class SR1Update0 : IPostStep
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SR1Update0()()() | Initializes a new instance of the SR1Update0 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(ITaskOutput, NameValueCollection) | Runs this post step
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SR1Update0

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


SR1Update0 Constructor

SR1Update0 Constructor
Namespaces ► Sitecore.Shell.Upgrades ► SR1Update0 ► SR1Update0()()()
Initializes a new instance of the SR1Update0 class
Declaration Syntax
C#
public SR1Update0()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Run Method (output, metaData)

Run Method (output, metaData)
Namespaces ► Sitecore.Shell.Upgrades ► SR1Update0 ► Run(ITaskOutput, NameValueCollection)
Runs this post step
Declaration Syntax
C#
public void Run(
    ITaskOutput output,
    NameValueCollection metaData
)
Parameters
output (ITaskOutput)
The output.
metaData (NameValueCollection)
The meta data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Shell.Web Namespace

Sitecore.Shell.Web Namespace
Namespaces ► Sitecore.Shell.Web
Declaration Syntax
C#
namespace Sitecore.Shell.Web
Types
All Types Classes
Icon | Type | Description
 | ShellPage | Represents a SecurePage.


ShellPage Class

ShellPage Class
Namespaces ► Sitecore.Shell.Web ► ShellPage
Represents a SecurePage.
Declaration Syntax
C#
public sealed class ShellPage
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ShellPage()()() | Initializes a new instance of the ShellPage class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsLoggedIn()()() | Determines whether this instance has license.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ShellPage


ShellPage Constructor

ShellPage Constructor
Namespaces ► Sitecore.Shell.Web ► ShellPage ► ShellPage()()()
Initializes a new instance of the ShellPage class
Declaration Syntax
C#
public ShellPage()


IsLoggedIn Method

IsLoggedIn Method
Namespaces ► Sitecore.Shell.Web ► ShellPage ► IsLoggedIn()()()
Determines whether this instance has license.
Declaration Syntax
C#
public static bool IsLoggedIn()


Sitecore.Shell.Web.UI Namespace

Sitecore.Shell.Web.UI Namespace
Namespaces ► Sitecore.Shell.Web.UI
Declaration Syntax
C#
namespace Sitecore.Shell.Web.UI
Types
All Types Classes Enumerations
Icon | Type | Description
 | HtmlEditorControls | Implements the HtmlEditorControls.
 | ItemTileService | Service for providing tiles for items.
 | LayoutGridBuilder |
 | SecurePage | Represents a client page that requires login.
 | TileView | Tile View.


HtmlEditorControls Class

HtmlEditorControls Class
Namespaces ► Sitecore.Shell.Web.UI ► HtmlEditorControls
Implements the HtmlEditorControls.
Declaration Syntax
C#
public static class HtmlEditorControls
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetToolTip(String, UrlString, Boolean) | Gets the tool tip.
Inheritance Hierarchy
Object
HtmlEditorControls


GetToolTip Method (tagName, parameters, hasError)

GetToolTip Method (tagName, parameters, hasError)
Namespaces ► Sitecore.Shell.Web.UI ► HtmlEditorControls ► GetToolTip(String, UrlString, Boolean)
Gets the tool tip.
Declaration Syntax
C#
public static string GetToolTip(
    string tagName,
    UrlString parameters,
    bool hasError
)
Parameters
tagName (String)
Name of the tag.
parameters (UrlString)
The parameters.
hasError (Boolean)
if set to true this instance is is error.
Return Value
The tool tip.


ItemTileService Class

ItemTileService Class
Namespaces ► Sitecore.Shell.Web.UI ► ItemTileService
Service for providing tiles for items.
Declaration Syntax
C#
public static class ItemTileService
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenderTile(Item, TileView, ImageDimension) | Gets the tile.
 | RenderTile(Item, TileView, ImageDimension, String) | Gets the tile.
Inheritance Hierarchy
Object
ItemTileService


RenderTile Method

RenderTile Method
Namespaces ► Sitecore.Shell.Web.UI ► ItemTileService ► RenderTile()()()
Members
Icon | Member | Description
 | RenderTile(Item, TileView, ImageDimension) | Gets the tile.
 | RenderTile(Item, TileView, ImageDimension, String) | Gets the tile.


RenderTile Method (item, view, imageDimension)

RenderTile Method (item, view, imageDimension)
Namespaces ► Sitecore.Shell.Web.UI ► ItemTileService ► RenderTile(Item, TileView, ImageDimension)
Gets the tile.
Declaration Syntax
C#
public static string RenderTile(
    Item item,
    TileView view,
    ImageDimension imageDimension
)
Parameters
item (Item)
The item.
view (TileView)
The view.
imageDimension (ImageDimension)
The image dimension.
Return Value
The tile.


RenderTile Method (item, view, imageDimension, click)

RenderTile Method (item, view, imageDimension, click)
Namespaces ► Sitecore.Shell.Web.UI ► ItemTileService ► RenderTile(Item, TileView, ImageDimension, String)
Gets the tile.
Declaration Syntax
C#
public static string RenderTile(
    Item item,
    TileView view,
    ImageDimension imageDimension,
    string click
)
Parameters
item (Item)
The item.
view (TileView)
The view.
imageDimension (ImageDimension)
The image dimension.
click (String)
The click.
Return Value
The tile.


LayoutGridBuilder Class

LayoutGridBuilder Class
Namespaces ► Sitecore.Shell.Web.UI ► LayoutGridBuilder
Declaration Syntax
C#
public class LayoutGridBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayoutGridBuilder()()() | Initializes a new instance of the LayoutGridBuilder class
 | BuildGrid(Control) | Builds the grid.
 | Class | Gets or sets the class.
 | CopyToClick | Gets or sets the copy to click.
 | EditPlaceholderClick | Gets or sets the edit placeholder click.
 | EditRenderingClick | Gets or sets the edit rendering click.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OpenDeviceClick | Gets or sets the open device click.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the value.
Inheritance Hierarchy
Object
LayoutGridBuilder


LayoutGridBuilder Constructor

LayoutGridBuilder Constructor
Namespaces ► Sitecore.Shell.Web.UI ► LayoutGridBuilder ► LayoutGridBuilder()()()
Initializes a new instance of the LayoutGridBuilder class
Declaration Syntax
C#
public LayoutGridBuilder()


BuildGrid Method (parent)

BuildGrid Method (parent)
Namespaces ► Sitecore.Shell.Web.UI ► LayoutGridBuilder ► BuildGrid(Control)
Builds the grid.
Declaration Syntax
C#
public void BuildGrid(
    Control parent
)
Parameters
parent (Control)
The parent.


Class Property

Class Property
Namespaces ► Sitecore.Shell.Web.UI ► LayoutGridBuilder ► Class
Gets or sets the class.
Declaration Syntax
C#
public string Class { get; set; }
Value
The class.


CopyToClick Property

CopyToClick Property
Namespaces ► Sitecore.Shell.Web.UI ► LayoutGridBuilder ► CopyToClick
Gets or sets the copy to click.
Declaration Syntax
C#
public string CopyToClick { get; set; }
Value
The copy to click.


EditPlaceholderClick Property

EditPlaceholderClick Property
Namespaces ► Sitecore.Shell.Web.UI ► LayoutGridBuilder ► EditPlaceholderClick
Gets or sets the edit placeholder click.
Declaration Syntax
C#
public string EditPlaceholderClick { get; set; }
Value
The edit placeholder click.


EditRenderingClick Property

EditRenderingClick Property
Namespaces ► Sitecore.Shell.Web.UI ► LayoutGridBuilder ► EditRenderingClick
Gets or sets the edit rendering click.
Declaration Syntax
C#
public string EditRenderingClick { get; set; }
Value
The edit rendering click.


ID Property

ID Property
Namespaces ► Sitecore.Shell.Web.UI ► LayoutGridBuilder ► ID
Gets or sets the ID.
Declaration Syntax
C#
public string ID { get; set; }
Value
The ID.


OpenDeviceClick Property

OpenDeviceClick Property
Namespaces ► Sitecore.Shell.Web.UI ► LayoutGridBuilder ► OpenDeviceClick
Gets or sets the open device click.
Declaration Syntax
C#
public string OpenDeviceClick { get; set; }
Value
The open device click.


Value Property

Value Property
Namespaces ► Sitecore.Shell.Web.UI ► LayoutGridBuilder ► Value
Gets or sets the value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.


SecurePage Class

SecurePage Class
Namespaces ► Sitecore.Shell.Web.UI ► SecurePage
Represents a client page that requires login.
Declaration Syntax
C#
public class SecurePage : ClientPage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecurePage()()() | Initializes a new instance of the SecurePage class
 | AbortPipeline(ClientPipelineArgs) | Aborts the pipeline identified by the args parameter. (Inherited from ClientPage.)
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddControl(Control, Control) | Adds a control while ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | AddControl(Control, Control, String) | Adds the control. (Inherited from ClientPage.)
 | AddControlAt(Int32, Control, Control) | Adds a control at a certain position while ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddLiteral(Control, String) | Adds literal text to a control. (Inherited from ClientPage.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindControls()()() | Binds the controls. (Inherited from ClientPage.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientRequest | Gets the request parameters for the current request. (Inherited from ClientPage.)
 | ClientResponse | Provides means for generating a response to the client. (Inherited from ClientPage.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodeBeside | Gets the current CodeBeside object. (Inherited from ClientPage.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControls()()() | Creates the controls. (Inherited from ClientPage.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | CurrentPipelineArgs | Gets the pipeline arguments, if a pipeline is active. (Inherited from ClientPage.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DecrementEventState()()() | Decrements the state of the event. (Inherited from ClientPage.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispatch(String) | Sends a client event message to the control hierachy. (Inherited from ClientPage.)
 | DispatchMessage(Message) | Obsolete. Dispatches the message. (Inherited from ClientPage.)
 | DispatchMessage(Message, Control) | Obsolete. Dispatches the message. (Inherited from ClientPage.)
 | DispatchMethod(String) | Obsolete. Dispatches the method. (Inherited from ClientPage.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindSubControl(String) | Finds the sub control with the specified name. (Inherited from ClientPage.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetClientDragEvent(String) | Builds a JavaScript statement for handling Drag actions. (Inherited from ClientPage.)
 | GetClientDropEvent(String) | Builds a JavaScript statement for handling Drop actions. (Inherited from ClientPage.)
 | GetClientEvent(String) | Builds a JavaScript statement for making a Sheer event. (Inherited from ClientPage.)
 | GetClientHelpEvent(String) | Builds a JavaScript statement for handling context sensitive help in the browser. (Inherited from ClientPage.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPageKey()()() | Gets the page key. (Inherited from ClientPage.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetViewStateStore()()() | Gets the view state store. (Inherited from ClientPage.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | IncrementEventState()()() | Increments the state of the event. (Inherited from ClientPage.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | Initialized | Gets a value indicating whether this ClientPage is initialized. (Inherited from ClientPage.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsEvent | Gets a value that indicates if the page is running in Event or Result mode. (Inherited from ClientPage.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsResult | Gets a value that indicates if the page is running in Result mode. (Inherited from ClientPage.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | Keymap | Gets the keymap. (Inherited from ClientPage.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from ClientPage.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MaxRequestLengthExceeded | Gets a value indicating whether the ClientPage maxs the request length exceeded. (Inherited from ClientPage.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Modified | Gets a value that indicates if the fields on page has been modified. (Inherited from ClientPage.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(Exception) | Called when an exception is thrown. (Inherited from ClientPage.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from ClientPage.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides ClientPage.OnLoad(EventArgs).)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from ClientPage.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from ClientPage.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageKey | Gets the page key. (Inherited from ClientPage.)
 | PageScriptManager | Gets the page script manager. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PersistViewStateToClient | Gets a value that indicates if ViewState should be persisted on the client in the __VIEWSTATE field. (Inherited from ClientPage.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaiseEvent()()() | Raises the event. (Inherited from ClientPage.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterKey(String, String, String) | Registers the key. (Inherited from ClientPage.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from ClientPage.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | ReplaceControl(Control, Control) | Replaces a control with another control ensuring that the ASP.NET control life-cycle is executed. (Inherited from ClientPage.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | RunPipelines()()() | Runs the pipelines. (Inherited from ClientPage.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves the page state to persistence medium. (Inherited from ClientPage.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ClientPage.)
 | SendMessage(Object, String) | Sends a message to the control hierachy. (Inherited from ClientPage.)
 | SendMessage(Message) | Sends a message to the control hierachy. (Inherited from ClientPage.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | ServerProperties | Exposes the ClientPage ViewState protected property. (Inherited from ClientPage.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | Start(String) | Starts a new pipeline. (Inherited from ClientPage.)
 | Start(String, ClientPipelineArgs) | Starts a new pipeline. (Inherited from ClientPage.)
 | Start(String, NameValueCollection) | Starts a pipeline. (Inherited from ClientPage.)
 | Start(Object, String) | Starts a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Object, String, NameValueCollection) | Start a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Object, String, ClientPipelineArgs) | Start a pipeline on a method in an object. (Inherited from ClientPage.)
 | Start(Pipeline, PipelineArgs) | Starts a pipeline with a set of arguments. (Inherited from ClientPage.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from ClientPage.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteCommands()()() | Writes the commands. (Inherited from ClientPage.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Page
 |  |  |  |  | ClientPage
 |  |  |  |  |  | SecurePage
 |  |  |  |  |  |  | DefaultPage
 |  |  |  |  |  |  | DefaultPage
 |  |  |  |  |  |  | DownloadPage
 |  |  |  |  |  |  | InvokePage
 |  |  |  |  |  |  | AttachPage
 |  |  |  |  |  |  | UploadPage


SecurePage Constructor

SecurePage Constructor
Namespaces ► Sitecore.Shell.Web.UI ► SecurePage ► SecurePage()()()
Initializes a new instance of the SecurePage class
Declaration Syntax
C#
public SecurePage()


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Web.UI ► SecurePage ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


TileView Enumeration

TileView Enumeration
Namespaces ► Sitecore.Shell.Web.UI ► TileView
Tile View.
Declaration Syntax
C#
public enum TileView
Members
Member | Description
Tiles | Tiles.
List | List.
SmallIcons | Small icons.
MediumIcons | Medium Icons.
LargeIcons | Large Icons.
IconOnly | Only Icon.


Sitecore.Shell.Web.UI.WebControls Namespace

Sitecore.Shell.Web.UI.WebControls Namespace
Namespaces ► Sitecore.Shell.Web.UI.WebControls
Declaration Syntax
C#
namespace Sitecore.Shell.Web.UI.WebControls
Types
All Types Classes
Icon | Type | Description
 | AccessViewerTreeview | Represents a treeview that shows security settings.
 | ContentDataContext | Represents the data context of the Content Editor.
 | ContentTreeview | Represents the treeview in the Content Editor.
 | CustomControl |
 | LargeButton | Represents a large button.
 | LargeComboButton |
 | LargeGalleryButton | Represents a Large Gallery button.
 | LargeIconButton | Represents a Large Icon button.
 | LargeMenuComboButton |
 | LargeTextButton | Represents a Large Text Button.
 | MediaListview | Obsolete. Represents a listview of media items.
 | MediaListviewItem | Obsolete. Represents an item in a media listview.
 | MyStrip | Represents a MyStrip.
 | RecycleBinListview | Represents the recycle bin listview.
 | RenderingTreeview | Represents a treeview that shows renderings.
 | RibbonPanel | Represents a ribbon panel.
 | RibbonStrip | Represents a ribbon panel.
 | ScrollPanel | Represents a scrolling panel.
 | SecurityTreeview | Represents a treeview that shows security settings. Represents a treeview that shows security settings.
 | SmallButton | Represents a small button.
 | SmallCheckButton | Represents a small button with a checkbox.
 | SmallComboButton | Represents a small combo button.
 | SmallDatePicker | Represents a small gallery button.
 | SmallDropDownBox | Represents a small button with a checkbox.
 | SmallGalleryButton | Represents a small gallery button.
 | SmallInputBox | Represents a small button with a checkbox.
 | SmallMenuComboButton | Represents a small combo button.
 | StartMenu |
 | Text | Represents a text control in the ribbon.
 | ToolButton | Representa a toolbutton.
 | TranslatorTreeview | Represents a treeview in the translator.


AccessViewerTreeview Class

AccessViewerTreeview Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► AccessViewerTreeview
Represents a treeview that shows security settings.
Declaration Syntax
C#
public class AccessViewerTreeview : DataTreeview
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccessViewerTreeview()()() | Initializes a new instance of the AccessViewerTreeview class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | AccountName | Gets or sets the entity IDs.
 | AccountType | Gets or sets the type of the account.
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddChecked(String) | Adds the node with the specified id to the checked set. (Inherited from Treeview.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddSelected(String) | Adds the node with the specified id to the selected set. (Inherited from Treeview.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | AllowDragging | Gets or sets a value indicating whether the DataTreeview allows the dragging. (Inherited from DataTreeview.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoUpdateDataContext | Gets or sets a value indicating whether the DataTreeview automatically updates the data context. (Inherited from DataTreeview.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Checked | Gets the checked nodes. (Inherited from Treeview.)
 | CheckParents | Gets or sets a value indicating whether the Treeview checks off the parents. (Inherited from Treeview.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChecked()()() | Clears the checked nodes. (Inherited from Treeview.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearNodes()()() | Clears the nodes. (Inherited from Treeview.)
 | ClearSelection()()() | Clears the selection. (Inherited from Treeview.)
 | Click | Gets or sets the click. (Inherited from Treeview.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Collapse(TreeNode) | Collapses the specified node. (Inherited from Treeview.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnNames | Gets or sets the column names. (Inherited from Treeview.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click. (Inherited from Treeview.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | Depth | Gets or sets the depth. (Inherited from Treeview.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableEvents()()() | Disables the events. (Inherited from DataTreeview.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from Treeview.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the dblclick event. (Inherited from Treeview.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Treeview.)
 | DomainName | Gets or sets the domain.
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Treeview.)
 | Drag | Gets or sets the drag event. (Inherited from Treeview.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event. (Inherited from Treeview.)
 | DropItem(String) | Handles a drop event. (Inherited from DataTreeview.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableEvents()()() | Enables the events. (Inherited from DataTreeview.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Expand(TreeNode, Boolean) | Expands the specified node. (Inherited from DataTreeview.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindNode(String) | Finds the node. (Inherited from Treeview.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetContextMenu(String) | Gets the context menu. (Overrides DataTreeview.GetContextMenu(String).)
 | GetContextMenu()()() | Gets the context menu. (Inherited from DataTreeview.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetNewMenu(String) | Gets the new menu. (Inherited from DataTreeview.)
 | GetNodeByItemID(String) | Gets the node by long item ID. (Inherited from DataTreeview.)
 | GetSelectionItem()()() | Gets the selection item. (Inherited from DataTreeview.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetTreeNode(Item, Control) | Gets the tree node. (Overrides DataTreeview.GetTreeNode(Item, Control).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | IgnoreSorting | Gets or sets a value indicating whether the DataTreeview ignores sorting. (Inherited from DataTreeview.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemsOnly | Gets or sets a value indicating whether the Treeview only renders the items and not the header. (Inherited from Treeview.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | MultiSelect | Gets or sets a value indicating whether the Treeview allows multiselection. (Inherited from Treeview.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NodeClicked(Message, TreeNode) | Handles a click on the node. (Inherited from DataTreeview.)
 | Nodes | Gets the nodes. (Inherited from Treeview.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the treeview is clicked. (Inherited from Treeview.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context has changed. (Inherited from DataTreeview.)
 | OnDblClick | Called when the treeview is double clicked. (Inherited from Treeview.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from DataTreeview.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from DataTreeview.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Populate(Control, Int32) | Populates the specified control. (Inherited from DataTreeview.)
 | Populate(Control, DataContext) | Populates the specified control. (Inherited from DataTreeview.)
 | Populate(DataContext, Control, Item, Item, String) | Populates the specified data context. (Inherited from DataTreeview.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | Refresh()()() | Refreshes this instance. (Inherited from DataTreeview.)
 | Refresh(TreeNode) | Refreshes the specified node. (Inherited from DataTreeview.)
 | Refresh(String) | Refreshes the specified id. (Inherited from DataTreeview.)
 | Refresh(ID) | Refreshes the specified id. (Inherited from DataTreeview.)
 | RefreshNode(TreeNode) | Refreshes the node. (Inherited from DataTreeview.)
 | RefreshRoot()()() | Refreshes the root. (Inherited from DataTreeview.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | Root | Obsolete. Gets or sets a value indicating whether this DataTreeview shows the root. (Inherited from DataTreeview.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Selected | Gets the selected nodes. (Inherited from Treeview.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowCheckboxes | Gets or sets a value indicating whether the Treeview shows the checkboxes. (Inherited from Treeview.)
 | ShowRoot | Gets or sets a value indicating whether the DataTreeview shows the root. (Inherited from DataTreeview.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle(String) | Toggles the node with the specified id. (Inherited from Treeview.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateNode(Item) | Updates the node.
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Treeview
 |  |  |  |  |  |  | DataTreeview
 |  |  |  |  |  |  |  | AccessViewerTreeview


AccessViewerTreeview Constructor

AccessViewerTreeview Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► AccessViewerTreeview ► AccessViewerTreeview()()()
Initializes a new instance of the AccessViewerTreeview class
Declaration Syntax
C#
public AccessViewerTreeview()


AccountName Property

AccountName Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► AccessViewerTreeview ► AccountName
Gets or sets the entity IDs.
Declaration Syntax
C#
public string AccountName { get; set; }
Value
The entity IDs.


AccountType Property

AccountType Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► AccessViewerTreeview ► AccountType
Gets or sets the type of the account.
Declaration Syntax
C#
public AccountType AccountType { get; set; }
Value
The type of the account.


DomainName Property

DomainName Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► AccessViewerTreeview ► DomainName
Gets or sets the domain.
Declaration Syntax
C#
public string DomainName { get; set; }
Value
The domain.


GetContextMenu Method (where)

GetContextMenu Method (where)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► AccessViewerTreeview ► GetContextMenu(String)
Gets the context menu.
Declaration Syntax
C#
protected override void GetContextMenu(
    string where
)
Parameters
where (String)
The position.


GetTreeNode Method (item, parent)

GetTreeNode Method (item, parent)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► AccessViewerTreeview ► GetTreeNode(Item, Control)
Gets the tree node.
Declaration Syntax
C#
protected override TreeNode GetTreeNode(
    Item item,
    Control parent
)
Parameters
item (Item)
The item.
parent (Control)
The parent.
Return Value


UpdateNode Method (item)

UpdateNode Method (item)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► AccessViewerTreeview ► UpdateNode(Item)
Updates the node.
Declaration Syntax
C#
public void UpdateNode(
    Item item
)
Parameters
item (Item)
The item.


ContentDataContext Class

ContentDataContext Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ContentDataContext
Represents the data context of the Content Editor.
Declaration Syntax
C#
public class ContentDataContext : DataContext
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContentDataContext()()() | Initializes a new instance of the ContentDataContext class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddSelected(DataUri) | Adds the item to the selected set. (Inherited from DataContext.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | AtRoot | Gets a value indicating whether the selected item is at the root. (Inherited from DataContext.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BeginUpdate()()() | Begins the update. (Inherited from DataContext.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Changed | (Inherited from DataContext.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearSelected()()() | Clears the selected set. (Inherited from DataContext.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | CurrentItem | Gets the current item. (Inherited from DataContext.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DataView | Gets the data view. (Inherited from DataContext.)
 | DataViewName | Gets or sets the name of the data view. (Inherited from DataContext.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DefaultItem | Gets or sets the default item. (Inherited from DataContext.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableEvents()()() | Disables the events. (Inherited from DataContext.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Component.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableEvents()()() | Enables the events. (Inherited from DataContext.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EndUpdate()()() | Ends the update. (Inherited from DataContext.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Filter | Gets or sets the filter. (Inherited from DataContext.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Folder | Gets or sets the folder. (Inherited from DataContext.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetChildren(Item) | Gets the children. (Inherited from DataContext.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFolder()()() | Gets the folder. (Inherited from DataContext.)
 | GetFromQueryString()()() | Gets the state from query string. (Inherited from DataContext.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem(ID) | Gets the item. (Inherited from DataContext.)
 | GetItem(DataUri) | Gets the item. (Inherited from DataContext.)
 | GetItem(String) | Gets the item. (Inherited from DataContext.)
 | GetItem(String, Language, Version) | Gets the item. (Inherited from DataContext.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetItems()()() | Gets the items. (Inherited from DataContext.)
 | GetParent(Item) | Gets the parent. (Inherited from DataContext.)
 | GetRoot()()() | Gets the root. (Inherited from DataContext.)
 | GetSelected()()() | Gets the selected items. (Inherited from DataContext.)
 | GetState(Item%, Item%) | Gets the state. (Inherited from DataContext.)
 | GetState(Item%, Item%, array<Item>[]()[]%) | Gets the state. (Inherited from DataContext.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from DataContext.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildren(Item) | Determines whether the specified item has children. (Inherited from DataContext.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsAncestorOf(Item, Item) | Determines if the ancestor is an ancestor of the item. (Inherited from DataContext.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemAdded | (Inherited from DataContext.)
 | ItemDeleted | (Inherited from DataContext.)
 | ItemRenamed | (Inherited from DataContext.)
 | ItemSaved | (Inherited from DataContext.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | Language | Gets or sets the language. (Inherited from DataContext.)
 | LastGoodFolder | Gets or sets the last good folder. (Inherited from DataContext.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | Offset | Gets or sets the offset. (Inherited from DataContext.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChanged()()() | Called when changed has occured. (Inherited from DataContext.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context has changed. (Inherited from DataContext.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(ID) | Called when an item has been added. (Inherited from DataContext.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(ID) | Called when an item has been deleted. (Inherited from DataContext.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(ID) | Called when the item has been renamed. (Inherited from DataContext.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(ID) | Called when the item has been saved. (Inherited from DataContext.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from DataContext.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSelectionChanged()()() | Called when the selection has changed. (Inherited from DataContext.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Parameters to pass to element (Inherited from DataContext.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | Range | Gets or sets the range. (Inherited from DataContext.)
 | Refresh()()() | Refreshes this instance. (Inherited from DataContext.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | RemoveSelected(DataUri) | Removes the selected. (Inherited from DataContext.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | Root | Gets or sets the root. (Inherited from DataContext.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Selected | Gets or sets the selected items. (Inherited from DataContext.)
 | SelectionChanged | (Inherited from DataContext.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetFolder(ItemUri) | Sets the folder. (Inherited from DataContext.)
 | SetFolderFromEvent(ItemUri) | Sets the folder from event. (Overrides DataContext.SetFolderFromEvent(ItemUri).)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetRootAndFolder(String, ItemUri) | Sets the root and folder. (Inherited from DataContext.)
 | SetSorting(String, Boolean) | Sets the sorting. (Inherited from DataContext.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowRoot | Gets or sets a value indicating whether the root is shown. (Inherited from DataContext.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | SortAscending | Gets or sets a value indicating whether the item are sorted ascending. (Inherited from DataContext.)
 | SortBy | Gets or sets the sort by. (Inherited from DataContext.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Up()()() | Sets the folder to the parent of the current folder. (Inherited from DataContext.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | Version | Gets or sets the version. (Inherited from DataContext.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | DataContext
 |  |  |  |  |  |  | ContentDataContext


ContentDataContext Constructor

ContentDataContext Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ContentDataContext ► ContentDataContext()()()
Initializes a new instance of the ContentDataContext class
Declaration Syntax
C#
public ContentDataContext()


SetFolderFromEvent Method (uri)

SetFolderFromEvent Method (uri)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ContentDataContext ► SetFolderFromEvent(ItemUri)
Sets the folder from event.
Declaration Syntax
C#
protected override void SetFolderFromEvent(
    ItemUri uri
)
Parameters
uri (ItemUri)
The URI.


ContentTreeview Class

ContentTreeview Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ContentTreeview
Represents the treeview in the Content Editor.
Declaration Syntax
C#
public class ContentTreeview : DataTreeview
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContentTreeview()()() | Initializes a new instance of the ContentTreeview class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddChecked(String) | Adds the node with the specified id to the checked set. (Inherited from Treeview.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddSelected(String) | Adds the node with the specified id to the selected set. (Inherited from Treeview.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | AllowDragging | Gets or sets a value indicating whether the DataTreeview allows the dragging. (Inherited from DataTreeview.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoUpdateDataContext | Gets or sets a value indicating whether the DataTreeview automatically updates the data context. (Inherited from DataTreeview.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Checked | Gets the checked nodes. (Inherited from Treeview.)
 | CheckParents | Gets or sets a value indicating whether the Treeview checks off the parents. (Inherited from Treeview.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChecked()()() | Clears the checked nodes. (Inherited from Treeview.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearNodes()()() | Clears the nodes. (Inherited from Treeview.)
 | ClearSelection()()() | Clears the selection. (Inherited from Treeview.)
 | Click | Gets or sets the click. (Inherited from Treeview.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Collapse(TreeNode) | Collapses the specified node. (Inherited from Treeview.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnNames | Gets or sets the column names. (Inherited from Treeview.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click. (Inherited from Treeview.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | Depth | Gets or sets the depth. (Inherited from Treeview.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableEvents()()() | Disables the events. (Inherited from DataTreeview.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from Treeview.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the dblclick event. (Inherited from Treeview.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Treeview.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Treeview.)
 | Drag | Gets or sets the drag event. (Inherited from Treeview.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event. (Inherited from Treeview.)
 | DropItem(String) | Handles a drop event. (Inherited from DataTreeview.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableEvents()()() | Enables the events. (Inherited from DataTreeview.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Expand(TreeNode, Boolean) | Expands the specified node. (Inherited from DataTreeview.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindNode(String) | Finds the node. (Inherited from Treeview.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetContextMenu()()() | Gets the context menu. (Inherited from DataTreeview.)
 | GetContextMenu(String) | Gets the context menu. (Inherited from DataTreeview.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetNewMenu(String) | Gets the new menu. (Inherited from DataTreeview.)
 | GetNodeByItemID(String) | Gets the node by long item ID. (Inherited from DataTreeview.)
 | GetSelectionItem()()() | Gets the selection item. (Inherited from DataTreeview.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetTreeNode(Item, Control) | Gets the tree node. (Inherited from DataTreeview.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | IgnoreSorting | Gets or sets a value indicating whether the DataTreeview ignores sorting. (Inherited from DataTreeview.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemsOnly | Gets or sets a value indicating whether the Treeview only renders the items and not the header. (Inherited from Treeview.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | MultiSelect | Gets or sets a value indicating whether the Treeview allows multiselection. (Inherited from Treeview.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NodeClicked(Message, TreeNode) | Handles a click on the node. (Overrides DataTreeview.NodeClicked(Message, TreeNode).)
 | Nodes | Gets the nodes. (Inherited from Treeview.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the treeview is clicked. (Inherited from Treeview.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context has changed. (Inherited from DataTreeview.)
 | OnDblClick | Called when the treeview is double clicked. (Inherited from Treeview.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from DataTreeview.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from DataTreeview.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Populate(Control, Int32) | Populates the specified control. (Inherited from DataTreeview.)
 | Populate(Control, DataContext) | Populates the specified control. (Inherited from DataTreeview.)
 | Populate(DataContext, Control, Item, Item, String) | Populates the specified data context. (Inherited from DataTreeview.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | Refresh()()() | Refreshes this instance. (Inherited from DataTreeview.)
 | Refresh(TreeNode) | Refreshes the specified node. (Inherited from DataTreeview.)
 | Refresh(String) | Refreshes the specified id. (Inherited from DataTreeview.)
 | Refresh(ID) | Refreshes the specified id. (Inherited from DataTreeview.)
 | RefreshNode(TreeNode) | Refreshes the node. (Inherited from DataTreeview.)
 | RefreshRoot()()() | Refreshes the root. (Inherited from DataTreeview.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | Root | Obsolete. Gets or sets a value indicating whether this DataTreeview shows the root. (Inherited from DataTreeview.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Selected | Gets the selected nodes. (Inherited from Treeview.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowCheckboxes | Gets or sets a value indicating whether the Treeview shows the checkboxes. (Inherited from Treeview.)
 | ShowRoot | Gets or sets a value indicating whether the DataTreeview shows the root. (Inherited from DataTreeview.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle(String) | Toggles the node with the specified id. (Inherited from Treeview.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Treeview
 |  |  |  |  |  |  | DataTreeview
 |  |  |  |  |  |  |  | ContentTreeview


ContentTreeview Constructor

ContentTreeview Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ContentTreeview ► ContentTreeview()()()
Initializes a new instance of the ContentTreeview class.
Declaration Syntax
C#
public ContentTreeview()


NodeClicked Method (message, node)

NodeClicked Method (message, node)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ContentTreeview ► NodeClicked(Message, TreeNode)
Handles a click on the node.
Declaration Syntax
C#
protected override void NodeClicked(
    Message message,
    TreeNode node
)
Parameters
message (Message)
The message.
node (TreeNode)
The node.


CustomControl Class

CustomControl Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► CustomControl
Declaration Syntax
C#
public abstract class CustomControl : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomControl(Item, CommandContext) | Initializes a new instance of the CustomControl class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Button | Gets the button.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommandContext | Gets the command context.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | CustomControl
 |  |  |  | ToolFontNames
 |  |  |  | ToolFontSizes


CustomControl Constructor (button, context)

CustomControl Constructor (button, context)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► CustomControl ► CustomControl(Item, CommandContext)
Initializes a new instance of the CustomControl class.
Declaration Syntax
C#
protected CustomControl(
    Item button,
    CommandContext context
)
Parameters
button (Item)
The button.
context (CommandContext)
The context.


Button Property

Button Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► CustomControl ► Button
Gets the button.
Declaration Syntax
C#
public Item Button { get; }
Value
The button.


CommandContext Property

CommandContext Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► CustomControl ► CommandContext
Gets the command context.
Declaration Syntax
C#
public CommandContext CommandContext { get; }
Value
The command context.


LargeButton Class

LargeButton Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeButton
Represents a large button.
Declaration Syntax
C#
public class LargeButton : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LargeButton()()() | Initializes a new instance of the LargeButton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Down | Gets or sets a value indicating whether this LargeButton is down.
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | LargeButton


LargeButton Constructor

LargeButton Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeButton ► LargeButton()()()
Initializes a new instance of the LargeButton class
Declaration Syntax
C#
public LargeButton()


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeButton ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Down Property

Down Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeButton ► Down
Gets or sets a value indicating whether this LargeButton is down.
Declaration Syntax
C#
public bool Down { get; set; }
Value
true if down; otherwise, false.


Header Property

Header Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeButton ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeButton ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeButton ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeButton ► Render(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


LargeComboButton Class

LargeComboButton Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeComboButton
Declaration Syntax
C#
public class LargeComboButton : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LargeComboButton()()() | Initializes a new instance of the LargeComboButton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Down | Gets or sets a value indicating whether this LargeComboButton is down.
 | DropDownDisabled | Gets or sets a value indicating whether the LargeComboButton drops the down disabled.
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Gallery | Gets or sets the gallery.
 | GalleryHeight | Gets or sets the height of the gallery.
 | GalleryUrl | Gets or sets the gallery URL.
 | GalleryWidth | Gets or sets the width of the gallery.
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the specified output. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | LargeComboButton


LargeComboButton Constructor

LargeComboButton Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeComboButton ► LargeComboButton()()()
Initializes a new instance of the LargeComboButton class
Declaration Syntax
C#
public LargeComboButton()


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeComboButton ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Down Property

Down Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeComboButton ► Down
Gets or sets a value indicating whether this LargeComboButton is down.
Declaration Syntax
C#
public bool Down { get; set; }
Value
true if down; otherwise, false.


DropDownDisabled Property

DropDownDisabled Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeComboButton ► DropDownDisabled
Gets or sets a value indicating whether the LargeComboButton drops the down disabled.
Declaration Syntax
C#
public bool DropDownDisabled { get; set; }
Value
true if the LargeComboButton drops the down disabled; otherwise, false.


Gallery Property

Gallery Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeComboButton ► Gallery
Gets or sets the gallery.
Declaration Syntax
C#
public string Gallery { get; set; }
Value
The gallery.


GalleryHeight Property

GalleryHeight Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeComboButton ► GalleryHeight
Gets or sets the height of the gallery.
Declaration Syntax
C#
public string GalleryHeight { get; set; }
Value
The height of the gallery.


GalleryUrl Property

GalleryUrl Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeComboButton ► GalleryUrl
Gets or sets the gallery URL.
Declaration Syntax
C#
public string GalleryUrl { get; set; }
Value
The gallery URL.


GalleryWidth Property

GalleryWidth Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeComboButton ► GalleryWidth
Gets or sets the width of the gallery.
Declaration Syntax
C#
public string GalleryWidth { get; set; }
Value
The width of the gallery.


Header Property

Header Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeComboButton ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeComboButton ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeComboButton ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeComboButton ► Render(HtmlTextWriter)
Renders the specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


LargeGalleryButton Class

LargeGalleryButton Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeGalleryButton
Represents a Large Gallery button.
Declaration Syntax
C#
public class LargeGalleryButton : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LargeGalleryButton()()() | Initializes a new instance of the LargeGalleryButton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Gallery | Gets or sets the gallery.
 | GalleryHeight | Gets or sets the height of the gallery.
 | GalleryUrl | Gets or sets the gallery URL.
 | GalleryWidth | Gets or sets the width of the gallery.
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the specified output. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | LargeGalleryButton


LargeGalleryButton Constructor

LargeGalleryButton Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeGalleryButton ► LargeGalleryButton()()()
Initializes a new instance of the LargeGalleryButton class
Declaration Syntax
C#
public LargeGalleryButton()


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeGalleryButton ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Gallery Property

Gallery Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeGalleryButton ► Gallery
Gets or sets the gallery.
Declaration Syntax
C#
public string Gallery { get; set; }
Value
The gallery.


GalleryHeight Property

GalleryHeight Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeGalleryButton ► GalleryHeight
Gets or sets the height of the gallery.
Declaration Syntax
C#
public string GalleryHeight { get; set; }
Value
The height of the gallery.


GalleryUrl Property

GalleryUrl Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeGalleryButton ► GalleryUrl
Gets or sets the gallery URL.
Declaration Syntax
C#
public string GalleryUrl { get; set; }
Value
The gallery URL.


GalleryWidth Property

GalleryWidth Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeGalleryButton ► GalleryWidth
Gets or sets the width of the gallery.
Declaration Syntax
C#
public string GalleryWidth { get; set; }
Value
The width of the gallery.


Header Property

Header Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeGalleryButton ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeGalleryButton ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeGalleryButton ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeGalleryButton ► Render(HtmlTextWriter)
Renders the specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


LargeIconButton Class

LargeIconButton Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeIconButton
Represents a Large Icon button.
Declaration Syntax
C#
public class LargeIconButton : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LargeIconButton()()() | Initializes a new instance of the LargeIconButton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Down | Gets or sets a value indicating whether this LargeButton is down.
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | LargeIconButton


LargeIconButton Constructor

LargeIconButton Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeIconButton ► LargeIconButton()()()
Initializes a new instance of the LargeIconButton class
Declaration Syntax
C#
public LargeIconButton()


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeIconButton ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Down Property

Down Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeIconButton ► Down
Gets or sets a value indicating whether this LargeButton is down.
Declaration Syntax
C#
public bool Down { get; set; }
Value
true if down; otherwise, false.


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeIconButton ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeIconButton ► Render(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


LargeMenuComboButton Class

LargeMenuComboButton Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeMenuComboButton
Declaration Syntax
C#
public class LargeMenuComboButton : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LargeMenuComboButton()()() | Initializes a new instance of the LargeMenuComboButton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Down | Gets or sets a value indicating whether this LargeMenuComboButton is down.
 | DropDownDisabled | Gets or sets a value indicating whether the LargeMenuComboButton drops the down disabled.
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Menu | Gets or sets the menu.
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the specified output. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | LargeMenuComboButton


LargeMenuComboButton Constructor

LargeMenuComboButton Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeMenuComboButton ► LargeMenuComboButton()()()
Initializes a new instance of the LargeMenuComboButton class
Declaration Syntax
C#
public LargeMenuComboButton()


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeMenuComboButton ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Down Property

Down Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeMenuComboButton ► Down
Gets or sets a value indicating whether this LargeMenuComboButton is down.
Declaration Syntax
C#
public bool Down { get; set; }
Value
true if down; otherwise, false.


DropDownDisabled Property

DropDownDisabled Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeMenuComboButton ► DropDownDisabled
Gets or sets a value indicating whether the LargeMenuComboButton drops the down disabled.
Declaration Syntax
C#
public bool DropDownDisabled { get; set; }
Value
true if the LargeMenuComboButton drops the down disabled; otherwise, false.


Header Property

Header Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeMenuComboButton ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeMenuComboButton ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeMenuComboButton ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


Menu Property

Menu Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeMenuComboButton ► Menu
Gets or sets the menu.
Declaration Syntax
C#
public string Menu { get; set; }
Value
The menu.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeMenuComboButton ► Render(HtmlTextWriter)
Renders the specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


LargeTextButton Class

LargeTextButton Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeTextButton
Represents a Large Text Button.
Declaration Syntax
C#
public class LargeTextButton : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LargeTextButton()()() | Initializes a new instance of the LargeTextButton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Down | Gets or sets a value indicating whether this LargeButton is down.
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text.
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | LargeTextButton


LargeTextButton Constructor

LargeTextButton Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeTextButton ► LargeTextButton()()()
Initializes a new instance of the LargeTextButton class
Declaration Syntax
C#
public LargeTextButton()


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeTextButton ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Down Property

Down Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeTextButton ► Down
Gets or sets a value indicating whether this LargeButton is down.
Declaration Syntax
C#
public bool Down { get; set; }
Value
true if down; otherwise, false.


Header Property

Header Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeTextButton ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeTextButton ► Render(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


Text Property

Text Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► LargeTextButton ► Text
Gets or sets the text.
Declaration Syntax
C#
public string Text { get; set; }
Value
The text.


MediaListview Class

MediaListview Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► MediaListview
Represents a listview of media items.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public class MediaListview : DataListview
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaListview()()() | Initializes a new instance of the MediaListview class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AddViewsMenu(Menu) | Adds the views menu. (Inherited from Listview.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | AllowDragging | Gets or sets a value indicating whether the DataListview allows dragging. (Inherited from DataListview.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | AtRoot | Gets a value indicating whether the DataListview is at the root. (Inherited from DataListview.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearSelection()()() | Clears the selection. (Inherited from Listview.)
 | Click | Gets or sets the click event. (Inherited from Listview.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnNames | Gets the column names. (Inherited from Listview.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateListviewItem(Item) | Creates the listview item. (Overrides DataListview.CreateListviewItem(Item).)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click event. (Inherited from Listview.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from DataListview.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the dblclick event. (Inherited from Listview.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Listview.)
 | DoSetView(String) | Executes the set view event. (Inherited from Listview.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event. (Inherited from Listview.)
 | DropItem(String) | Handles a drop event. (Inherited from DataListview.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetColumnValues(Item, DataListviewItem) | Gets the column values. (Inherited from DataListview.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetContextMenu()()() | Gets the context menu. (Inherited from DataListview.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemByID(String) | Gets the item by ID. (Inherited from Listview.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetSelectedItem()()() | Gets the selected item. (Inherited from DataListview.)
 | GetSelectedItems()()() | Gets the selected items. (Inherited from Listview.)
 | GetShellViewsMenu(String) | Gets the shell views menu. (Inherited from Listview.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewsMenu(String) | Gets the views menu. (Inherited from Listview.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets the items. (Inherited from Listview.)
 | ItemsOnly | Gets or sets a value indicating whether the Listview renders the items only and not the header. (Inherited from Listview.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | MultiSelect | Gets or sets a value indicating whether the Listview supports multiselect. (Inherited from Listview.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the control is clicked; (Inherited from Listview.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context has changed. (Inherited from DataListview.)
 | OnDblClick | Called when the control is double clicked; (Inherited from Listview.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when an item has been added. (Inherited from DataListview.)
 | OnItemDeleted(DataContext, ID) | Called when an item has been deleted. (Inherited from DataListview.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from DataListview.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSelectionChanged | Called when the selection is changed; (Inherited from Listview.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OnViewChanged | Called when the view is changed. (Inherited from Listview.)
 | Open()()() | Opens clicked item. (Inherited from DataListview.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Populate()()() | Populates the listview. (Inherited from DataListview.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | Refresh()()() | Refreshes this Listview. (Inherited from DataListview.)
 | Refresh(DataContext) | Refreshes the specified data context. (Inherited from DataListview.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFooter(HtmlTextWriter) | Renders the footer. (Inherited from Listview.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderHeader(HtmlTextWriter) | Renders the header. (Inherited from Listview.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from Listview.)
 | Selected | Gets or sets the selected. (Inherited from DataListview.)
 | SelectedItems | Gets the selected items. (Inherited from Listview.)
 | SelectionChanged()()() | Called whrn the selection has been changed. (Inherited from DataListview.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowCheckboxes | Gets or sets a value indicating whether the Listview shows the checkboxes. (Inherited from Listview.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | SortAscending | Gets or sets a value indicating whether the Listview sorts ascending. (Inherited from Listview.)
 | SortBy | Gets or sets the sort by column. (Inherited from Listview.)
 | SortByColumn(Int32) | Sorts by the column. (Inherited from DataListview.)
 | Src | Obsolete. Gets or sets the source. (Inherited from DataListview.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | View | Gets or sets the view. (Inherited from Listview.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Listview
 |  |  |  |  |  |  | DataListview
 |  |  |  |  |  |  |  | MediaListview


MediaListview Constructor

MediaListview Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► MediaListview ► MediaListview()()()
Initializes a new instance of the MediaListview class
Declaration Syntax
C#
public MediaListview()


CreateListviewItem Method (item)

CreateListviewItem Method (item)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► MediaListview ► CreateListviewItem(Item)
Creates the listview item.
Declaration Syntax
C#
protected override DataListviewItem CreateListviewItem(
    Item item
)
Parameters
item (Item)
The item.
Return Value


MediaListviewItem Class

MediaListviewItem Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► MediaListviewItem
Represents an item in a media listview.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public class MediaListviewItem : DataListviewItem
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaListviewItem()()() | Initializes a new instance of the MediaListviewItem class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Checked | Gets or sets a value indicating whether this ListviewItem is checked. (Inherited from ListviewItem.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | ClassPrefix | Gets or sets the class prefix. (Inherited from ListviewItem.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnValues | Gets the column values. (Inherited from ListviewItem.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | Created | Gets or sets the created timestamp. (Inherited from DataListviewItem.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DocumentText | Gets or sets the document text. (Inherited from DataListviewItem.)
 | DocumentTitle | Gets or sets the document title. (Inherited from DataListviewItem.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides DataListviewItem.DoRender(HtmlTextWriter).)
 | Drag | Gets or sets the drag event. (Inherited from ListviewItem.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event. (Inherited from DataListviewItem.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetCurrentView()()() | Gets the current view. (Inherited from ListviewItem.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetListview()()() | Gets the listview. (Inherited from ListviewItem.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildren | Gets or sets the has children string. (Inherited from DataListviewItem.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon. (Inherited from ListviewItem.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item | Gets or sets the item.
 | ItemID | Gets or sets the item ID. (Inherited from DataListviewItem.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MediaInfo | Gets or sets the media info.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from DataListviewItem.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from DataListviewItem.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has been deleted. (Inherited from DataListviewItem.)
 | OnItemRenamed(DataContext, ID) | Called when the item has been renamed. (Inherited from DataListviewItem.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from ListviewItem.)
 | Selected | Gets or sets a value indicating whether this ListviewItem is selected. (Inherited from ListviewItem.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | Template | Gets or sets the template. (Inherited from DataListviewItem.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from ListviewItem.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Updated | Gets or sets the updated. (Inherited from DataListviewItem.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | ListviewItem
 |  |  |  |  |  |  |  | DataListviewItem
 |  |  |  |  |  |  |  |  | MediaListviewItem


MediaListviewItem Constructor

MediaListviewItem Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► MediaListviewItem ► MediaListviewItem()()()
Initializes a new instance of the MediaListviewItem class
Declaration Syntax
C#
public MediaListviewItem()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► MediaListviewItem ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Item Property

Item Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► MediaListviewItem ► Item
Gets or sets the item.
Declaration Syntax
C#
public Item Item { get; set; }
Value
The item.


MediaInfo Property

MediaInfo Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► MediaListviewItem ► MediaInfo
Gets or sets the media info.
Declaration Syntax
C#
public MediaInfo MediaInfo { get; set; }
Value
The media info.


MyStrip Class

MyStrip Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► MyStrip
Represents a MyStrip.
Declaration Syntax
C#
public class MyStrip : RibbonStrip
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MyStrip()()() | Initializes a new instance of the MyStrip class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(HtmlTextWriter, Ribbon, Item, CommandContext) | Renders the toolbar panel. (Overrides RibbonStrip.Render(HtmlTextWriter, Ribbon, Item, CommandContext).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RibbonStrip
 |  | MyStrip


MyStrip Constructor

MyStrip Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► MyStrip ► MyStrip()()()
Initializes a new instance of the MyStrip class
Declaration Syntax
C#
public MyStrip()


Render Method (output, ribbon, strip, context)

Render Method (output, ribbon, strip, context)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► MyStrip ► Render(HtmlTextWriter, Ribbon, Item, CommandContext)
Renders the toolbar panel.
Declaration Syntax
C#
public override void Render(
    HtmlTextWriter output,
    Ribbon ribbon,
    Item strip,
    CommandContext context
)
Parameters
output (HtmlTextWriter)
The output.
ribbon (Ribbon)
The ribbon.
strip (Item)
The strip.
context (CommandContext)
The context.


RecycleBinListview Class

RecycleBinListview Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RecycleBinListview
Represents the recycle bin listview.
Declaration Syntax
C#
public class RecycleBinListview : DataListview
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RecycleBinListview()()() | Initializes a new instance of the RecycleBinListview class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AddViewsMenu(Menu) | Adds the views menu. (Inherited from Listview.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | AllowDragging | Gets or sets a value indicating whether the DataListview allows dragging. (Inherited from DataListview.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | AtRoot | Gets a value indicating whether the DataListview is at the root. (Inherited from DataListview.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearSelection()()() | Clears the selection. (Inherited from Listview.)
 | Click | Gets or sets the click event. (Inherited from Listview.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnNames | Gets the column names. (Inherited from Listview.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateListviewItem(Item) | Creates the listview item. (Inherited from DataListview.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click event. (Inherited from Listview.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from DataListview.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the dblclick event. (Inherited from Listview.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Listview.)
 | DoSetView(String) | Executes the set view event. (Inherited from Listview.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event. (Inherited from Listview.)
 | DropItem(String) | Handles a drop event. (Inherited from DataListview.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetColumnValues(Item, DataListviewItem) | Gets the column values. (Overrides DataListview.GetColumnValues(Item, DataListviewItem).)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetContextMenu()()() | Gets the context menu. (Inherited from DataListview.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemByID(String) | Gets the item by ID. (Inherited from Listview.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetSelectedItem()()() | Gets the selected item. (Inherited from DataListview.)
 | GetSelectedItems()()() | Gets the selected items. (Inherited from Listview.)
 | GetShellViewsMenu(String) | Gets the shell views menu. (Inherited from Listview.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewsMenu(String) | Gets the views menu. (Inherited from Listview.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets the items. (Inherited from Listview.)
 | ItemsOnly | Gets or sets a value indicating whether the Listview renders the items only and not the header. (Inherited from Listview.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | MultiSelect | Gets or sets a value indicating whether the Listview supports multiselect. (Inherited from Listview.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the control is clicked; (Inherited from Listview.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context has changed. (Inherited from DataListview.)
 | OnDblClick | Called when the control is double clicked; (Inherited from Listview.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when an item has been added. (Inherited from DataListview.)
 | OnItemDeleted(DataContext, ID) | Called when an item has been deleted. (Inherited from DataListview.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from DataListview.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSelectionChanged | Called when the selection is changed; (Inherited from Listview.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OnViewChanged | Called when the view is changed. (Inherited from Listview.)
 | Open()()() | Opens clicked item. (Inherited from DataListview.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Populate()()() | Populates the listview. (Inherited from DataListview.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | Refresh()()() | Refreshes this Listview. (Inherited from DataListview.)
 | Refresh(DataContext) | Refreshes the specified data context. (Inherited from DataListview.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFooter(HtmlTextWriter) | Renders the footer. (Inherited from Listview.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderHeader(HtmlTextWriter) | Renders the header. (Inherited from Listview.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from Listview.)
 | Selected | Gets or sets the selected. (Inherited from DataListview.)
 | SelectedItems | Gets the selected items. (Inherited from Listview.)
 | SelectionChanged()()() | Called whrn the selection has been changed. (Inherited from DataListview.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowCheckboxes | Gets or sets a value indicating whether the Listview shows the checkboxes. (Inherited from Listview.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | SortAscending | Gets or sets a value indicating whether the Listview sorts ascending. (Inherited from Listview.)
 | SortBy | Gets or sets the sort by column. (Inherited from Listview.)
 | SortByColumn(Int32) | Sorts by the column. (Inherited from DataListview.)
 | Src | Obsolete. Gets or sets the source. (Inherited from DataListview.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | View | Gets or sets the view. (Inherited from Listview.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Listview
 |  |  |  |  |  |  | DataListview
 |  |  |  |  |  |  |  | RecycleBinListview


RecycleBinListview Constructor

RecycleBinListview Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RecycleBinListview ► RecycleBinListview()()()
Initializes a new instance of the RecycleBinListview class
Declaration Syntax
C#
public RecycleBinListview()


GetColumnValues Method (item, ctl)

GetColumnValues Method (item, ctl)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RecycleBinListview ► GetColumnValues(Item, DataListviewItem)
Gets the column values.
Declaration Syntax
C#
protected override void GetColumnValues(
    Item item,
    DataListviewItem ctl
)
Parameters
item (Item)
The item.
ctl (DataListviewItem)
The CTL.


RenderingTreeview Class

RenderingTreeview Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RenderingTreeview
Represents a treeview that shows renderings.
Declaration Syntax
C#
public class RenderingTreeview : DataTreeview
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderingTreeview()()() | Initializes a new instance of the RenderingTreeview class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddChecked(String) | Adds the node with the specified id to the checked set. (Inherited from Treeview.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddSelected(String) | Adds the node with the specified id to the selected set. (Inherited from Treeview.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | AllowDragging | Gets or sets a value indicating whether the DataTreeview allows the dragging. (Inherited from DataTreeview.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoUpdateDataContext | Gets or sets a value indicating whether the DataTreeview automatically updates the data context. (Inherited from DataTreeview.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Checked | Gets the checked nodes. (Inherited from Treeview.)
 | CheckParents | Gets or sets a value indicating whether the Treeview checks off the parents. (Inherited from Treeview.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChecked()()() | Clears the checked nodes. (Inherited from Treeview.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearNodes()()() | Clears the nodes. (Inherited from Treeview.)
 | ClearSelection()()() | Clears the selection. (Inherited from Treeview.)
 | Click | Gets or sets the click. (Inherited from Treeview.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Collapse(TreeNode) | Collapses the specified node. (Inherited from Treeview.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnNames | Gets or sets the column names. (Inherited from Treeview.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click. (Inherited from Treeview.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | Depth | Gets or sets the depth. (Inherited from Treeview.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableEvents()()() | Disables the events. (Inherited from DataTreeview.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from Treeview.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the dblclick event. (Inherited from Treeview.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Treeview.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Treeview.)
 | Drag | Gets or sets the drag event. (Inherited from Treeview.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event. (Inherited from Treeview.)
 | DropItem(String) | Handles a drop event. (Inherited from DataTreeview.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableEvents()()() | Enables the events. (Inherited from DataTreeview.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Expand(TreeNode, Boolean) | Expands the specified node. (Inherited from DataTreeview.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindNode(String) | Finds the node. (Inherited from Treeview.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetContextMenu()()() | Gets the context menu. (Inherited from DataTreeview.)
 | GetContextMenu(String) | Gets the context menu. (Inherited from DataTreeview.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetNewMenu(String) | Gets the new menu. (Inherited from DataTreeview.)
 | GetNodeByItemID(String) | Gets the node by long item ID. (Inherited from DataTreeview.)
 | GetSelectionItem()()() | Gets the selection item. (Inherited from DataTreeview.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetTreeNode(Item, Control) | Gets the tree node. (Inherited from DataTreeview.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | IgnoreSorting | Gets or sets a value indicating whether the DataTreeview ignores sorting. (Inherited from DataTreeview.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemsOnly | Gets or sets a value indicating whether the Treeview only renders the items and not the header. (Inherited from Treeview.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | MultiSelect | Gets or sets a value indicating whether the Treeview allows multiselection. (Inherited from Treeview.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NodeClicked(Message, TreeNode) | Handles a click on the node. (Inherited from DataTreeview.)
 | Nodes | Gets the nodes. (Inherited from Treeview.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the treeview is clicked. (Inherited from Treeview.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context has changed. (Inherited from DataTreeview.)
 | OnDblClick | Called when the treeview is double clicked. (Inherited from Treeview.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from DataTreeview.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from DataTreeview.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Populate(Control, DataContext) | Populates the specified control. (Overrides DataTreeview.Populate(Control, DataContext).)
 | Populate(Control, Int32) | Populates the specified control. (Inherited from DataTreeview.)
 | Populate(DataContext, Control, Item, Item, String) | Populates the specified data context. (Inherited from DataTreeview.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | Refresh()()() | Refreshes this instance. (Inherited from DataTreeview.)
 | Refresh(TreeNode) | Refreshes the specified node. (Inherited from DataTreeview.)
 | Refresh(String) | Refreshes the specified id. (Inherited from DataTreeview.)
 | Refresh(ID) | Refreshes the specified id. (Inherited from DataTreeview.)
 | RefreshNode(TreeNode) | Refreshes the node. (Inherited from DataTreeview.)
 | RefreshRoot()()() | Refreshes the root. (Inherited from DataTreeview.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | Root | Obsolete. Gets or sets a value indicating whether this DataTreeview shows the root. (Inherited from DataTreeview.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Selected | Gets the selected nodes. (Inherited from Treeview.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowCheckboxes | Gets or sets a value indicating whether the Treeview shows the checkboxes. (Inherited from Treeview.)
 | ShowRoot | Gets or sets a value indicating whether the DataTreeview shows the root. (Inherited from DataTreeview.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle(String) | Toggles the node with the specified id. (Inherited from Treeview.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Treeview
 |  |  |  |  |  |  | DataTreeview
 |  |  |  |  |  |  |  | RenderingTreeview


RenderingTreeview Constructor

RenderingTreeview Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RenderingTreeview ► RenderingTreeview()()()
Initializes a new instance of the RenderingTreeview class
Declaration Syntax
C#
public RenderingTreeview()


Populate Method (control, dataContext)

Populate Method (control, dataContext)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RenderingTreeview ► Populate(Control, DataContext)
Populates the specified control.
Declaration Syntax
C#
protected override Control Populate(
    Control control,
    DataContext dataContext
)
Parameters
control (Control)
The control.
dataContext (DataContext)
The data context.
Return Value


RibbonPanel Class

RibbonPanel Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RibbonPanel
Represents a ribbon panel.
Declaration Syntax
C#
public abstract class RibbonPanel
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RibbonPanel()()() | Initializes a new instance of the RibbonPanel class
 | Enabled | Gets or sets a value indicating whether this RibbonPanel is enabled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasField(Item, ID) | Determines whether the specified item has the specified field.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(HtmlTextWriter, Ribbon, Item, CommandContext) | Renders the panel.
 | RenderPanelButtons(HtmlTextWriter, String, String) | Renders the panel buttons.
 | RenderPanelScrollButtons(HtmlTextWriter, String) | Renders the panel scroll buttons.
 | RenderSmallButton(HtmlTextWriter, Ribbon, String, String, String, String, String, Boolean, Boolean) | Renders the small button.
 | RenderText(HtmlTextWriter, String) | Renders the text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RibbonPanel


RibbonPanel Constructor

RibbonPanel Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RibbonPanel ► RibbonPanel()()()
Initializes a new instance of the RibbonPanel class
Declaration Syntax
C#
protected RibbonPanel()


Enabled Property

Enabled Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RibbonPanel ► Enabled
Gets or sets a value indicating whether this RibbonPanel is enabled.
Declaration Syntax
C#
public bool Enabled { get; set; }
Value
true if enabled; otherwise, false.


HasField Method (item, fieldID)

HasField Method (item, fieldID)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RibbonPanel ► HasField(Item, ID)
Determines whether the specified item has the specified field.
Declaration Syntax
C#
protected bool HasField(
    Item item,
    ID fieldID
)
Parameters
item (Item)
The item.
fieldID (ID)
The field ID.
Return Value
true if the specified item has the specified field; otherwise, false.


Render Method (output, ribbon, button, context)

Render Method (output, ribbon, button, context)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RibbonPanel ► Render(HtmlTextWriter, Ribbon, Item, CommandContext)
Renders the panel.
Declaration Syntax
C#
public abstract void Render(
    HtmlTextWriter output,
    Ribbon ribbon,
    Item button,
    CommandContext context
)
Parameters
output (HtmlTextWriter)
The output.
ribbon (Ribbon)
The ribbon.
button (Item)
The button.
context (CommandContext)
The context.


RenderPanelButtons Method (output, id, click)

RenderPanelButtons Method (output, id, click)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RibbonPanel ► RenderPanelButtons(HtmlTextWriter, String, String)
Renders the panel buttons.
Declaration Syntax
C#
protected void RenderPanelButtons(
    HtmlTextWriter output,
    string id,
    string click
)
Parameters
output (HtmlTextWriter)
The output.
id (String)
The id.
click (String)
The click.


RenderPanelScrollButtons Method (output, id)

RenderPanelScrollButtons Method (output, id)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RibbonPanel ► RenderPanelScrollButtons(HtmlTextWriter, String)
Renders the panel scroll buttons.
Declaration Syntax
C#
protected void RenderPanelScrollButtons(
    HtmlTextWriter output,
    string id
)
Parameters
output (HtmlTextWriter)
The output.
id (String)
The id.


RenderSmallButton Method (output, ribbon, id, header, icon, tooltip, command, enabled, down)

RenderSmallButton Method (output, ribbon, id, header, icon, tooltip, command, enabled, down)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RibbonPanel ► RenderSmallButton(HtmlTextWriter, Ribbon, String, String, String, String, String, Boolean, Boolean)
Renders the small button.
Declaration Syntax
C#
public void RenderSmallButton(
    HtmlTextWriter output,
    Ribbon ribbon,
    string id,
    string header,
    string icon,
    string tooltip,
    string command,
    bool enabled,
    bool down
)
Parameters
output (HtmlTextWriter)
The output.
ribbon (Ribbon)
The ribbon.
id (String)
ID.
header (String)
The header.
icon (String)
The icon.
tooltip (String)
The tooltip.
command (String)
The command.
enabled (Boolean)
if set to true the small button is enabled.
down (Boolean)
if set to true this instance is down.


RenderText Method (output, text)

RenderText Method (output, text)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RibbonPanel ► RenderText(HtmlTextWriter, String)
Renders the text.
Declaration Syntax
C#
protected void RenderText(
    HtmlTextWriter output,
    string text
)
Parameters
output (HtmlTextWriter)
The output.
text (String)
The text.


RibbonStrip Class

RibbonStrip Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RibbonStrip
Represents a ribbon panel.
Declaration Syntax
C#
public abstract class RibbonStrip
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RibbonStrip()()() | Initializes a new instance of the RibbonStrip class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Render(HtmlTextWriter, Ribbon, Item, CommandContext) | Renders the panel.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RibbonStrip
 |  | MyStrip


RibbonStrip Constructor

RibbonStrip Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RibbonStrip ► RibbonStrip()()()
Initializes a new instance of the RibbonStrip class
Declaration Syntax
C#
protected RibbonStrip()


Render Method (output, ribbon, strip, context)

Render Method (output, ribbon, strip, context)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► RibbonStrip ► Render(HtmlTextWriter, Ribbon, Item, CommandContext)
Renders the panel.
Declaration Syntax
C#
public abstract void Render(
    HtmlTextWriter output,
    Ribbon ribbon,
    Item strip,
    CommandContext context
)
Parameters
output (HtmlTextWriter)
The output.
ribbon (Ribbon)
The ribbon.
strip (Item)
The strip.
context (CommandContext)
The context.


ScrollPanel Class

ScrollPanel Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ScrollPanel
Represents a scrolling panel.
Declaration Syntax
C#
public class ScrollPanel : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ScrollPanel()()() | Initializes a new instance of the ScrollPanel class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InnerHtml | Gets or sets the inner HTML.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the specified output. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | ScrollPanel


ScrollPanel Constructor

ScrollPanel Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ScrollPanel ► ScrollPanel()()()
Initializes a new instance of the ScrollPanel class
Declaration Syntax
C#
public ScrollPanel()


InnerHtml Property

InnerHtml Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ScrollPanel ► InnerHtml
Gets or sets the inner HTML.
Declaration Syntax
C#
public string InnerHtml { get; set; }
Value
The inner HTML.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ScrollPanel ► Render(HtmlTextWriter)
Renders the specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


SecurityTreeview Class

SecurityTreeview Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SecurityTreeview
Represents a treeview that shows security settings.
Represents a treeview that shows security settings.
Declaration Syntax
C#
public class SecurityTreeview : DataTreeview
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecurityTreeview()()() | Initializes a new instance of the SecurityTreeview class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | AccountName | Gets or sets the name of the account.
 | AccountType | Gets or sets the type of the account.
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddChecked(String) | Adds the node with the specified id to the checked set. (Inherited from Treeview.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddSelected(String) | Adds the node with the specified id to the selected set. (Inherited from Treeview.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | AllowDragging | Gets or sets a value indicating whether the DataTreeview allows the dragging. (Inherited from DataTreeview.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoUpdateDataContext | Gets or sets a value indicating whether the DataTreeview automatically updates the data context. (Inherited from DataTreeview.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Checked | Gets the checked nodes. (Inherited from Treeview.)
 | CheckParents | Gets or sets a value indicating whether the Treeview checks off the parents. (Inherited from Treeview.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChecked()()() | Clears the checked nodes. (Inherited from Treeview.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearNodes()()() | Clears the nodes. (Inherited from Treeview.)
 | ClearSelection()()() | Clears the selection. (Inherited from Treeview.)
 | Click | Gets or sets the click. (Inherited from Treeview.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Collapse(TreeNode) | Collapses the specified node. (Inherited from Treeview.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnNames | Gets or sets the column names. (Inherited from Treeview.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click. (Inherited from Treeview.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | Depth | Gets or sets the depth. (Inherited from Treeview.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableEvents()()() | Disables the events. (Inherited from DataTreeview.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Overrides Treeview.DoClick(Message).)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the dblclick event. (Overrides Treeview.DoDblclick(Message).)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Treeview.)
 | DomainName | Gets or sets the domain.
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Treeview.)
 | Drag | Gets or sets the drag event. (Inherited from Treeview.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event. (Inherited from Treeview.)
 | DropItem(String) | Handles a drop event. (Inherited from DataTreeview.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableEvents()()() | Enables the events. (Inherited from DataTreeview.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Expand(TreeNode, Boolean) | Expands the specified node. (Inherited from DataTreeview.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindNode(String) | Finds the node. (Inherited from Treeview.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetContextMenu(String) | Gets the context menu. (Overrides DataTreeview.GetContextMenu(String).)
 | GetContextMenu()()() | Gets the context menu. (Inherited from DataTreeview.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetNewMenu(String) | Gets the new menu. (Inherited from DataTreeview.)
 | GetNodeByItemID(String) | Gets the node by long item ID. (Inherited from DataTreeview.)
 | GetSelectionItem()()() | Gets the selection item. (Inherited from DataTreeview.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetTreeNode(Item, Control) | Gets the tree node. (Overrides DataTreeview.GetTreeNode(Item, Control).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | IgnoreSorting | Gets or sets a value indicating whether the DataTreeview ignores sorting. (Inherited from DataTreeview.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemsOnly | Gets or sets a value indicating whether the Treeview only renders the items and not the header. (Inherited from Treeview.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | MultiSelect | Gets or sets a value indicating whether the Treeview allows multiselection. (Inherited from Treeview.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NodeClicked(Message, TreeNode) | Handles a click on the node. (Inherited from DataTreeview.)
 | Nodes | Gets the nodes. (Inherited from Treeview.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the treeview is clicked. (Inherited from Treeview.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context has changed. (Inherited from DataTreeview.)
 | OnDblClick | Called when the treeview is double clicked. (Inherited from Treeview.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides DataTreeview.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from DataTreeview.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Populate(Control, Int32) | Populates the specified control. (Inherited from DataTreeview.)
 | Populate(Control, DataContext) | Populates the specified control. (Inherited from DataTreeview.)
 | Populate(DataContext, Control, Item, Item, String) | Populates the specified data context. (Inherited from DataTreeview.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | Refresh()()() | Refreshes this instance. (Inherited from DataTreeview.)
 | Refresh(TreeNode) | Refreshes the specified node. (Inherited from DataTreeview.)
 | Refresh(String) | Refreshes the specified id. (Inherited from DataTreeview.)
 | Refresh(ID) | Refreshes the specified id. (Inherited from DataTreeview.)
 | RefreshNode(TreeNode) | Refreshes the node. (Inherited from DataTreeview.)
 | RefreshRoot()()() | Refreshes the root. (Inherited from DataTreeview.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | Root | Obsolete. Gets or sets a value indicating whether this DataTreeview shows the root. (Inherited from DataTreeview.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Selected | Gets the selected nodes. (Inherited from Treeview.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowCheckboxes | Gets or sets a value indicating whether the Treeview shows the checkboxes. (Inherited from Treeview.)
 | ShowRoot | Gets or sets a value indicating whether the DataTreeview shows the root. (Inherited from DataTreeview.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle(String) | Toggles the node with the specified id. (Inherited from Treeview.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateNode(Item) | Updates the node.
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Treeview
 |  |  |  |  |  |  | DataTreeview
 |  |  |  |  |  |  |  | SecurityTreeview


SecurityTreeview Constructor

SecurityTreeview Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SecurityTreeview ► SecurityTreeview()()()
Initializes a new instance of the SecurityTreeview class
Declaration Syntax
C#
public SecurityTreeview()


AccountName Property

AccountName Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SecurityTreeview ► AccountName
Gets or sets the name of the account.
Declaration Syntax
C#
public string AccountName { get; set; }
Value
The name of the account.


AccountType Property

AccountType Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SecurityTreeview ► AccountType
Gets or sets the type of the account.
Declaration Syntax
C#
public AccountType AccountType { get; set; }
Value
The type of the account.


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SecurityTreeview ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected override void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DoDblclick Method (message)

DoDblclick Method (message)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SecurityTreeview ► DoDblclick(Message)
Executes the dblclick event.
Declaration Syntax
C#
protected override void DoDblclick(
    Message message
)
Parameters
message (Message)
The message.


DomainName Property

DomainName Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SecurityTreeview ► DomainName
Gets or sets the domain.
Declaration Syntax
C#
public string DomainName { get; set; }
Value
The domain.


GetContextMenu Method (where)

GetContextMenu Method (where)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SecurityTreeview ► GetContextMenu(String)
Gets the context menu.
Declaration Syntax
C#
protected override void GetContextMenu(
    string where
)
Parameters
where (String)
The position.


GetTreeNode Method (item, parent)

GetTreeNode Method (item, parent)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SecurityTreeview ► GetTreeNode(Item, Control)
Gets the tree node.
Declaration Syntax
C#
protected override TreeNode GetTreeNode(
    Item item,
    Control parent
)
Parameters
item (Item)
The item.
parent (Control)
The parent.
Return Value


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SecurityTreeview ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


UpdateNode Method (item)

UpdateNode Method (item)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SecurityTreeview ► UpdateNode(Item)
Updates the node.
Declaration Syntax
C#
public void UpdateNode(
    Item item
)
Parameters
item (Item)
The item.


SmallButton Class

SmallButton Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallButton
Represents a small button.
Declaration Syntax
C#
public class SmallButton : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SmallButton()()() | Initializes a new instance of the SmallButton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Down | Gets or sets a value indicating whether this SmallButton is down.
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the specified output. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | SmallButton


SmallButton Constructor

SmallButton Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallButton ► SmallButton()()()
Initializes a new instance of the SmallButton class
Declaration Syntax
C#
public SmallButton()


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallButton ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Down Property

Down Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallButton ► Down
Gets or sets a value indicating whether this SmallButton is down.
Declaration Syntax
C#
public bool Down { get; set; }
Value
true if down; otherwise, false.


Header Property

Header Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallButton ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallButton ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallButton ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallButton ► Render(HtmlTextWriter)
Renders the specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


SmallCheckButton Class

SmallCheckButton Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallCheckButton
Represents a small button with a checkbox.
Declaration Syntax
C#
public class SmallCheckButton : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SmallCheckButton()()() | Initializes a new instance of the SmallCheckButton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Checked | Gets or sets a value indicating whether this SmallCheckButton is checked.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the specified output. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | SmallCheckButton


SmallCheckButton Constructor

SmallCheckButton Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallCheckButton ► SmallCheckButton()()()
Initializes a new instance of the SmallCheckButton class
Declaration Syntax
C#
public SmallCheckButton()


Checked Property

Checked Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallCheckButton ► Checked
Gets or sets a value indicating whether this SmallCheckButton is checked.
Declaration Syntax
C#
public bool Checked { get; set; }
Value
true if checked; otherwise, false.


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallCheckButton ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Header Property

Header Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallCheckButton ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallCheckButton ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallCheckButton ► Render(HtmlTextWriter)
Renders the specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


SmallComboButton Class

SmallComboButton Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallComboButton
Represents a small combo button.
Declaration Syntax
C#
public class SmallComboButton : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SmallComboButton()()() | Initializes a new instance of the SmallComboButton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Gallery | Gets or sets the gallery.
 | GalleryHeight | Gets or sets the height of the gallery.
 | GalleryUrl | Gets or sets the gallery URL.
 | GalleryWidth | Gets or sets the width of the gallery.
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the button to specified output. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | SmallComboButton


SmallComboButton Constructor

SmallComboButton Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallComboButton ► SmallComboButton()()()
Initializes a new instance of the SmallComboButton class
Declaration Syntax
C#
public SmallComboButton()


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallComboButton ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Gallery Property

Gallery Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallComboButton ► Gallery
Gets or sets the gallery.
Declaration Syntax
C#
public string Gallery { get; set; }
Value
The gallery.


GalleryHeight Property

GalleryHeight Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallComboButton ► GalleryHeight
Gets or sets the height of the gallery.
Declaration Syntax
C#
public string GalleryHeight { get; set; }
Value
The height of the gallery.


GalleryUrl Property

GalleryUrl Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallComboButton ► GalleryUrl
Gets or sets the gallery URL.
Declaration Syntax
C#
public string GalleryUrl { get; set; }
Value
The gallery URL.


GalleryWidth Property

GalleryWidth Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallComboButton ► GalleryWidth
Gets or sets the width of the gallery.
Declaration Syntax
C#
public string GalleryWidth { get; set; }
Value
The width of the gallery.


Header Property

Header Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallComboButton ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallComboButton ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallComboButton ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallComboButton ► Render(HtmlTextWriter)
Renders the button to specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


SmallDatePicker Class

SmallDatePicker Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDatePicker
Represents a small gallery button.
Declaration Syntax
C#
public class SmallDatePicker : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SmallDatePicker()()() | Initializes a new instance of the SmallDatePicker class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | Date | Gets or sets the header.
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Format | Gets or sets the format.
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the specified output. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | SmallDatePicker


SmallDatePicker Constructor

SmallDatePicker Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDatePicker ► SmallDatePicker()()()
Initializes a new instance of the SmallDatePicker class
Declaration Syntax
C#
public SmallDatePicker()


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDatePicker ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Date Property

Date Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDatePicker ► Date
Gets or sets the header.
Declaration Syntax
C#
public DateTime Date { get; set; }
Value
The header.


Format Property

Format Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDatePicker ► Format
Gets or sets the format.
Declaration Syntax
C#
public string Format { get; set; }
Value
The format.


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDatePicker ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDatePicker ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDatePicker ► Render(HtmlTextWriter)
Renders the specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


SmallDropDownBox Class

SmallDropDownBox Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDropDownBox
Represents a small button with a checkbox.
Declaration Syntax
C#
public class SmallDropDownBox : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SmallDropDownBox()()() | Initializes a new instance of the SmallDropDownBox class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets the items.
 | KeyCode | Gets or sets the key code.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the specified output. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | SmallDropDownBox


SmallDropDownBox Constructor

SmallDropDownBox Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDropDownBox ► SmallDropDownBox()()()
Initializes a new instance of the SmallDropDownBox class
Declaration Syntax
C#
public SmallDropDownBox()


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDropDownBox ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Header Property

Header Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDropDownBox ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDropDownBox ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


Items Property

Items Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDropDownBox ► Items
Gets the items.
Declaration Syntax
C#
public List<string> Items { get; }
Value
The items.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDropDownBox ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDropDownBox ► Render(HtmlTextWriter)
Renders the specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


Value Property

Value Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallDropDownBox ► Value
Gets or sets the value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.


SmallGalleryButton Class

SmallGalleryButton Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallGalleryButton
Represents a small gallery button.
Declaration Syntax
C#
public class SmallGalleryButton : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SmallGalleryButton()()() | Initializes a new instance of the SmallGalleryButton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Gallery | Gets or sets the gallery.
 | GalleryHeight | Gets or sets the height of the gallery.
 | GalleryUrl | Gets or sets the gallery URL.
 | GalleryWidth | Gets or sets the width of the gallery.
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the specified output. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | SmallGalleryButton


SmallGalleryButton Constructor

SmallGalleryButton Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallGalleryButton ► SmallGalleryButton()()()
Initializes a new instance of the SmallGalleryButton class
Declaration Syntax
C#
public SmallGalleryButton()


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallGalleryButton ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Gallery Property

Gallery Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallGalleryButton ► Gallery
Gets or sets the gallery.
Declaration Syntax
C#
public string Gallery { get; set; }
Value
The gallery.


GalleryHeight Property

GalleryHeight Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallGalleryButton ► GalleryHeight
Gets or sets the height of the gallery.
Declaration Syntax
C#
public string GalleryHeight { get; set; }
Value
The height of the gallery.


GalleryUrl Property

GalleryUrl Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallGalleryButton ► GalleryUrl
Gets or sets the gallery URL.
Declaration Syntax
C#
public string GalleryUrl { get; set; }
Value
The gallery URL.


GalleryWidth Property

GalleryWidth Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallGalleryButton ► GalleryWidth
Gets or sets the width of the gallery.
Declaration Syntax
C#
public string GalleryWidth { get; set; }
Value
The width of the gallery.


Header Property

Header Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallGalleryButton ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallGalleryButton ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallGalleryButton ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallGalleryButton ► Render(HtmlTextWriter)
Renders the specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


SmallInputBox Class

SmallInputBox Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallInputBox
Represents a small button with a checkbox.
Declaration Syntax
C#
public class SmallInputBox : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SmallInputBox()()() | Initializes a new instance of the SmallInputBox class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the specified output. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | SmallInputBox


SmallInputBox Constructor

SmallInputBox Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallInputBox ► SmallInputBox()()()
Initializes a new instance of the SmallInputBox class
Declaration Syntax
C#
public SmallInputBox()


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallInputBox ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Header Property

Header Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallInputBox ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallInputBox ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallInputBox ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallInputBox ► Render(HtmlTextWriter)
Renders the specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


Value Property

Value Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallInputBox ► Value
Gets or sets the value.
Declaration Syntax
C#
public string Value { get; set; }
Value
The value.


SmallMenuComboButton Class

SmallMenuComboButton Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallMenuComboButton
Represents a small combo button.
Declaration Syntax
C#
public class SmallMenuComboButton : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SmallMenuComboButton()()() | Initializes a new instance of the SmallMenuComboButton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | CommandContext | Gets or sets the command context.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DropDownDisabled | Gets or sets a value indicating whether the LargeMenuComboButton drops the down disabled.
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Menu | Gets or sets the menu.
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the button to specified output. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | SmallMenuComboButton


SmallMenuComboButton Constructor

SmallMenuComboButton Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallMenuComboButton ► SmallMenuComboButton()()()
Initializes a new instance of the SmallMenuComboButton class
Declaration Syntax
C#
public SmallMenuComboButton()


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallMenuComboButton ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


CommandContext Property

CommandContext Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallMenuComboButton ► CommandContext
Gets or sets the command context.
Declaration Syntax
C#
public CommandContext CommandContext { get; set; }
Value
The command context.


DropDownDisabled Property

DropDownDisabled Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallMenuComboButton ► DropDownDisabled
Gets or sets a value indicating whether the LargeMenuComboButton drops the down disabled.
Declaration Syntax
C#
public bool DropDownDisabled { get; set; }
Value
true if the LargeMenuComboButton drops the down disabled; otherwise, false.


Header Property

Header Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallMenuComboButton ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallMenuComboButton ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallMenuComboButton ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


Menu Property

Menu Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallMenuComboButton ► Menu
Gets or sets the menu.
Declaration Syntax
C#
public string Menu { get; set; }
Value
The menu.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► SmallMenuComboButton ► Render(HtmlTextWriter)
Renders the button to specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


StartMenu Class

StartMenu Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► StartMenu
Declaration Syntax
C#
public class StartMenu : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StartMenu()()() | Initializes a new instance of the StartMenu class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | StartMenu


StartMenu Constructor

StartMenu Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► StartMenu ► StartMenu()()()
Initializes a new instance of the StartMenu class
Declaration Syntax
C#
public StartMenu()


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► StartMenu ► Render(HtmlTextWriter)
Renders the control to the specified HTML writer.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


Text Class

Text Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► Text
Represents a text control in the ribbon.
Declaration Syntax
C#
public class Text : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Text()()() | Initializes a new instance of the Text class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the specified output. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Text


Text Constructor

Text Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► Text ► Text()()()
Initializes a new instance of the Text class
Declaration Syntax
C#
public Text()


Header Property

Header Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► Text ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► Text ► Render(HtmlTextWriter)
Renders the specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


ToolButton Class

ToolButton Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ToolButton
Representa a toolbutton.
Declaration Syntax
C#
public class ToolButton : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToolButton()()() | Initializes a new instance of the ToolButton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the specified output. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | ToolButton


ToolButton Constructor

ToolButton Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ToolButton ► ToolButton()()()
Initializes a new instance of the ToolButton class
Declaration Syntax
C#
public ToolButton()


Command Property

Command Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ToolButton ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Header Property

Header Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ToolButton ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Icon Property

Icon Property
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ToolButton ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► ToolButton ► Render(HtmlTextWriter)
Renders the specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


TranslatorTreeview Class

TranslatorTreeview Class
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► TranslatorTreeview
Represents a treeview in the translator.
Declaration Syntax
C#
public class TranslatorTreeview : DataTreeview
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TranslatorTreeview()()() | Initializes a new instance of the TranslatorTreeview class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddChecked(String) | Adds the node with the specified id to the checked set. (Inherited from Treeview.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddSelected(String) | Adds the node with the specified id to the selected set. (Inherited from Treeview.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | AllowDragging | Gets or sets a value indicating whether the DataTreeview allows the dragging. (Inherited from DataTreeview.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoUpdateDataContext | Gets or sets a value indicating whether the DataTreeview automatically updates the data context. (Inherited from DataTreeview.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Checked | Gets the checked nodes. (Inherited from Treeview.)
 | CheckParents | Gets or sets a value indicating whether the Treeview checks off the parents. (Inherited from Treeview.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChecked()()() | Clears the checked nodes. (Inherited from Treeview.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearNodes()()() | Clears the nodes. (Inherited from Treeview.)
 | ClearSelection()()() | Clears the selection. (Inherited from Treeview.)
 | Click | Gets or sets the click. (Inherited from Treeview.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Collapse(TreeNode) | Collapses the specified node. (Inherited from Treeview.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnNames | Gets or sets the column names. (Inherited from Treeview.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click. (Inherited from Treeview.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | Depth | Gets or sets the depth. (Inherited from Treeview.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableEvents()()() | Disables the events. (Inherited from DataTreeview.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from Treeview.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the dblclick event. (Inherited from Treeview.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Treeview.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Treeview.)
 | Drag | Gets or sets the drag event. (Inherited from Treeview.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event. (Inherited from Treeview.)
 | DropItem(String) | Handles a drop event. (Inherited from DataTreeview.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableEvents()()() | Enables the events. (Inherited from DataTreeview.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Expand(TreeNode, Boolean) | Expands the specified node. (Inherited from DataTreeview.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindNode(String) | Finds the node. (Inherited from Treeview.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetContextMenu()()() | Gets the context menu. (Inherited from DataTreeview.)
 | GetContextMenu(String) | Gets the context menu. (Inherited from DataTreeview.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetNewMenu(String) | Gets the new menu. (Inherited from DataTreeview.)
 | GetNodeByItemID(String) | Gets the node by long item ID. (Inherited from DataTreeview.)
 | GetSelectionItem()()() | Gets the selection item. (Inherited from DataTreeview.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetTreeNode(Item, Control) | Gets the tree node. (Overrides DataTreeview.GetTreeNode(Item, Control).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | IgnoreSorting | Gets or sets a value indicating whether the DataTreeview ignores sorting. (Inherited from DataTreeview.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemsOnly | Gets or sets a value indicating whether the Treeview only renders the items and not the header. (Inherited from Treeview.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | MultiSelect | Gets or sets a value indicating whether the Treeview allows multiselection. (Inherited from Treeview.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NodeClicked(Message, TreeNode) | Handles a click on the node. (Inherited from DataTreeview.)
 | Nodes | Gets the nodes. (Inherited from Treeview.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the treeview is clicked. (Inherited from Treeview.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context has changed. (Inherited from DataTreeview.)
 | OnDblClick | Called when the treeview is double clicked. (Inherited from Treeview.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from DataTreeview.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from DataTreeview.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Populate(Control, Int32) | Populates the specified control. (Inherited from DataTreeview.)
 | Populate(Control, DataContext) | Populates the specified control. (Inherited from DataTreeview.)
 | Populate(DataContext, Control, Item, Item, String) | Populates the specified data context. (Inherited from DataTreeview.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | Refresh()()() | Refreshes this instance. (Inherited from DataTreeview.)
 | Refresh(TreeNode) | Refreshes the specified node. (Inherited from DataTreeview.)
 | Refresh(String) | Refreshes the specified id. (Inherited from DataTreeview.)
 | Refresh(ID) | Refreshes the specified id. (Inherited from DataTreeview.)
 | RefreshNode(TreeNode) | Refreshes the node. (Inherited from DataTreeview.)
 | RefreshRoot()()() | Refreshes the root. (Inherited from DataTreeview.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | Root | Obsolete. Gets or sets a value indicating whether this DataTreeview shows the root. (Inherited from DataTreeview.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Selected | Gets the selected nodes. (Inherited from Treeview.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowCheckboxes | Gets or sets a value indicating whether the Treeview shows the checkboxes. (Inherited from Treeview.)
 | ShowRoot | Gets or sets a value indicating whether the DataTreeview shows the root. (Inherited from DataTreeview.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle(String) | Toggles the node with the specified id. (Inherited from Treeview.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Treeview
 |  |  |  |  |  |  | DataTreeview
 |  |  |  |  |  |  |  | TranslatorTreeview


TranslatorTreeview Constructor

TranslatorTreeview Constructor
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► TranslatorTreeview ► TranslatorTreeview()()()
Initializes a new instance of the TranslatorTreeview class
Declaration Syntax
C#
public TranslatorTreeview()


GetTreeNode Method (item, parent)

GetTreeNode Method (item, parent)
Namespaces ► Sitecore.Shell.Web.UI.WebControls ► TranslatorTreeview ► GetTreeNode(Item, Control)
Gets the tree node.
Declaration Syntax
C#
protected override TreeNode GetTreeNode(
    Item item,
    Control parent
)
Parameters
item (Item)
The item.
parent (Control)
The parent.
Return Value


Sitecore.sitecore.admin Namespace

Sitecore.sitecore.admin Namespace
Namespaces ► Sitecore.sitecore.admin
Declaration Syntax
C#
namespace Sitecore.sitecore.admin
Types
All Types Classes
Icon | Type | Description
 | CacheAdmin | Summary description for Cache.
 | CompareSubtrees | A page that allows item subtrees comparing
 | CompareSubtrees..::.SubtreeComparer..::.Difference |
 | CompareSubtrees..::.SubtreeComparer..::.FieldValueChangedDifference |
 | CompareSubtrees..::.SubtreeComparer..::.ItemHasNoAssociationDifference |
 | CompareSubtrees..::.SubtreeComparer..::.ItemNameChangedDifference |
 | CompareSubtrees..::.SubtreeComparer..::.ItemTemplateChangedDifference |
 | restore | Restore page
 | ShowConfig | ShowConfig class
 | stats | stats
 | CompareSubtrees..::.SubtreeComparer | SubtreeComparer


CacheAdmin Class

CacheAdmin Class
Namespaces ► Sitecore.sitecore.admin ► CacheAdmin
Summary description for Cache.
Declaration Syntax
C#
public class CacheAdmin : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CacheAdmin()()() | Initializes a new instance of the CacheAdmin class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | c_caches |
 | c_cacheTitle |
 | c_clearAll |
 | c_refresh |
 | c_totals |
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | Caches |
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | Label1 |
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Overrides Page.OnInit(EventArgs).)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | CacheAdmin

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CacheAdmin Constructor

CacheAdmin Constructor
Namespaces ► Sitecore.sitecore.admin ► CacheAdmin ► CacheAdmin()()()
Initializes a new instance of the CacheAdmin class
Declaration Syntax
C#
public CacheAdmin()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_caches Field

c_caches Field
Namespaces ► Sitecore.sitecore.admin ► CacheAdmin ► c_caches
Declaration Syntax
C#
protected PlaceHolder c_caches

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_cacheTitle Field

c_cacheTitle Field
Namespaces ► Sitecore.sitecore.admin ► CacheAdmin ► c_cacheTitle
Declaration Syntax
C#
protected Label c_cacheTitle

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_clearAll Field

c_clearAll Field
Namespaces ► Sitecore.sitecore.admin ► CacheAdmin ► c_clearAll
Declaration Syntax
C#
protected Button c_clearAll

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_refresh Field

c_refresh Field
Namespaces ► Sitecore.sitecore.admin ► CacheAdmin ► c_refresh
Declaration Syntax
C#
protected Button c_refresh

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_totals Field

c_totals Field
Namespaces ► Sitecore.sitecore.admin ► CacheAdmin ► c_totals
Declaration Syntax
C#
protected Label c_totals

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Caches Field

Caches Field
Namespaces ► Sitecore.sitecore.admin ► CacheAdmin ► Caches
Declaration Syntax
C#
protected Label Caches

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Label1 Field

Label1 Field
Namespaces ► Sitecore.sitecore.admin ► CacheAdmin ► Label1
Declaration Syntax
C#
protected Label Label1

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


OnInit Method (e)

OnInit Method (e)
Namespaces ► Sitecore.sitecore.admin ► CacheAdmin ► OnInit(EventArgs)
Raises the Init event to initialize the page.
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs that contains the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CompareSubtrees Class

CompareSubtrees Class
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees
A page that allows item subtrees comparing
Declaration Syntax
C#
public class CompareSubtrees : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompareSubtrees()()() | Initializes a new instance of the CompareSubtrees class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | btnGo | btnGo control.
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | form | form control.
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | Go(Object, EventArgs) | Executes subtrees comparing
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | lstDatabase1 | lstDatabase1 control.
 | lstDatabase2 | lstDatabase2 control.
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) | Handles the Load event of the Page control.
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | pnlResult | pnlResult control.
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | tblResult | tblResult control.
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | txtId1 | txtId1 control.
 | txtId2 | txtId2 control.
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | CompareSubtrees

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CompareSubtrees Constructor

CompareSubtrees Constructor
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees ► CompareSubtrees()()()
Initializes a new instance of the CompareSubtrees class
Declaration Syntax
C#
public CompareSubtrees()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


btnGo Field

btnGo Field
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees ► btnGo
btnGo control.
Declaration Syntax
C#
protected Button btnGo
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


form Field

form Field
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees ► form
form control.
Declaration Syntax
C#
protected HtmlForm form
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Go Method (sender, e)

Go Method (sender, e)
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees ► Go(Object, EventArgs)
Executes subtrees comparing
Declaration Syntax
C#
protected void Go(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


lstDatabase1 Field

lstDatabase1 Field
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees ► lstDatabase1
lstDatabase1 control.
Declaration Syntax
C#
protected DropDownList lstDatabase1
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


lstDatabase2 Field

lstDatabase2 Field
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees ► lstDatabase2
lstDatabase2 control.
Declaration Syntax
C#
protected DropDownList lstDatabase2
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees ► Page_Load(Object, EventArgs)
Handles the Load event of the Page control.
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


pnlResult Field

pnlResult Field
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees ► pnlResult
pnlResult control.
Declaration Syntax
C#
protected Panel pnlResult
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


tblResult Field

tblResult Field
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees ► tblResult
tblResult control.
Declaration Syntax
C#
protected HtmlTable tblResult
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


txtId1 Field

txtId1 Field
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees ► txtId1
txtId1 control.
Declaration Syntax
C#
protected TextBox txtId1
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


txtId2 Field

txtId2 Field
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees ► txtId2
txtId2 control.
Declaration Syntax
C#
protected TextBox txtId2
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CompareSubtrees.SubtreeComparer Class

CompareSubtrees..::.SubtreeComparer Class
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees ► CompareSubtrees..::.SubtreeComparer
SubtreeComparer
Declaration Syntax
C#
public static class SubtreeComparer
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CompareItemTree(Item, Item) | Compares two item trees
Inheritance Hierarchy
Object
CompareSubtrees..::.SubtreeComparer

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CompareItemTree Method (oldVersion, newVersion)

CompareItemTree Method (oldVersion, newVersion)
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer ► CompareItemTree(Item, Item)
Compares two item trees
Declaration Syntax
C#
public static List<CompareSubtrees..::.SubtreeComparer..::.Difference> CompareItemTree(
    Item oldVersion,
    Item newVersion
)
Parameters
oldVersion (Item)
The old version.
newVersion (Item)
The new version.
Return Value

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CompareSubtrees.SubtreeComparer.Difference Class

CompareSubtrees..::.SubtreeComparer..::.Difference Class
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer ► CompareSubtrees..::.SubtreeComparer..::.Difference
Declaration Syntax
C#
public abstract class Difference
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CompareSubtrees..::.SubtreeComparer..::.Difference()()() | Initializes a new instance of the CompareSubtrees..::.SubtreeComparer..::.Difference class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CompareSubtrees..::.SubtreeComparer..::.Difference
 |  | CompareSubtrees..::.SubtreeComparer..::.FieldValueChangedDifference
 |  | CompareSubtrees..::.SubtreeComparer..::.ItemHasNoAssociationDifference
 |  | CompareSubtrees..::.SubtreeComparer..::.ItemNameChangedDifference
 |  | CompareSubtrees..::.SubtreeComparer..::.ItemTemplateChangedDifference

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CompareSubtrees.SubtreeComparer.Difference Constructor

CompareSubtrees..::.SubtreeComparer..::.Difference Constructor
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer..::.Difference ► CompareSubtrees..::.SubtreeComparer..::.Difference()()()
Initializes a new instance of the CompareSubtrees..::.SubtreeComparer..::.Difference class
Declaration Syntax
C#
protected Difference()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CompareSubtrees.SubtreeComparer.FieldValueChangedDifference Class

CompareSubtrees..::.SubtreeComparer..::.FieldValueChangedDifference Class
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer ► CompareSubtrees..::.SubtreeComparer..::.FieldValueChangedDifference
Declaration Syntax
C#
public class FieldValueChangedDifference : CompareSubtrees..::.SubtreeComparer..::.Difference
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompareSubtrees..::.SubtreeComparer..::.FieldValueChangedDifference(Item, Field, String) | Initializes a new instance of the CompareSubtrees..::.SubtreeComparer..::.FieldValueChangedDifference class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Field |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewValue |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CompareSubtrees..::.SubtreeComparer..::.Difference
 |  | CompareSubtrees..::.SubtreeComparer..::.FieldValueChangedDifference

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CompareSubtrees.SubtreeComparer.FieldValueChangedDifference Constructor (item, field, newValue)

CompareSubtrees..::.SubtreeComparer..::.FieldValueChangedDifference Constructor (item, field, newValue)
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer..::.FieldValueChangedDifference ► CompareSubtrees..::.SubtreeComparer..::.FieldValueChangedDifference(Item, Field, String)
Initializes a new instance of the CompareSubtrees..::.SubtreeComparer..::.FieldValueChangedDifference class
Declaration Syntax
C#
public FieldValueChangedDifference(
    Item item,
    Field field,
    string newValue
)
Parameters
item (Item)
field (Field)
newValue (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Field Property

Field Property
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer..::.FieldValueChangedDifference ► Field
Declaration Syntax
C#
public Field Field { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Item Property

Item Property
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer..::.FieldValueChangedDifference ► Item
Declaration Syntax
C#
public Item Item { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


NewValue Property

NewValue Property
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer..::.FieldValueChangedDifference ► NewValue
Declaration Syntax
C#
public string NewValue { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CompareSubtrees.SubtreeComparer.ItemHasNoAssociationDifference Class

CompareSubtrees..::.SubtreeComparer..::.ItemHasNoAssociationDifference Class
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer ► CompareSubtrees..::.SubtreeComparer..::.ItemHasNoAssociationDifference
Declaration Syntax
C#
public class ItemHasNoAssociationDifference : CompareSubtrees..::.SubtreeComparer..::.Difference
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompareSubtrees..::.SubtreeComparer..::.ItemHasNoAssociationDifference(Item, Boolean) | Initializes a new instance of the CompareSubtrees..::.SubtreeComparer..::.ItemHasNoAssociationDifference class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item |
 | LeftSubtree |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CompareSubtrees..::.SubtreeComparer..::.Difference
 |  | CompareSubtrees..::.SubtreeComparer..::.ItemHasNoAssociationDifference

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CompareSubtrees.SubtreeComparer.ItemHasNoAssociationDifference Constructor (item, leftSubtree)

CompareSubtrees..::.SubtreeComparer..::.ItemHasNoAssociationDifference Constructor (item, leftSubtree)
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer..::.ItemHasNoAssociationDifference ► CompareSubtrees..::.SubtreeComparer..::.ItemHasNoAssociationDifference(Item, Boolean)
Initializes a new instance of the CompareSubtrees..::.SubtreeComparer..::.ItemHasNoAssociationDifference class
Declaration Syntax
C#
public ItemHasNoAssociationDifference(
    Item item,
    bool leftSubtree
)
Parameters
item (Item)
leftSubtree (Boolean)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Item Property

Item Property
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer..::.ItemHasNoAssociationDifference ► Item
Declaration Syntax
C#
public Item Item { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


LeftSubtree Property

LeftSubtree Property
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer..::.ItemHasNoAssociationDifference ► LeftSubtree
Declaration Syntax
C#
public bool LeftSubtree { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CompareSubtrees.SubtreeComparer.ItemNameChangedDifference Class

CompareSubtrees..::.SubtreeComparer..::.ItemNameChangedDifference Class
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer ► CompareSubtrees..::.SubtreeComparer..::.ItemNameChangedDifference
Declaration Syntax
C#
public class ItemNameChangedDifference : CompareSubtrees..::.SubtreeComparer..::.Difference
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompareSubtrees..::.SubtreeComparer..::.ItemNameChangedDifference(Item, String) | Initializes a new instance of the CompareSubtrees..::.SubtreeComparer..::.ItemNameChangedDifference class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewName |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CompareSubtrees..::.SubtreeComparer..::.Difference
 |  | CompareSubtrees..::.SubtreeComparer..::.ItemNameChangedDifference

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CompareSubtrees.SubtreeComparer.ItemNameChangedDifference Constructor (item, newName)

CompareSubtrees..::.SubtreeComparer..::.ItemNameChangedDifference Constructor (item, newName)
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer..::.ItemNameChangedDifference ► CompareSubtrees..::.SubtreeComparer..::.ItemNameChangedDifference(Item, String)
Initializes a new instance of the CompareSubtrees..::.SubtreeComparer..::.ItemNameChangedDifference class
Declaration Syntax
C#
public ItemNameChangedDifference(
    Item item,
    string newName
)
Parameters
item (Item)
newName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Item Property

Item Property
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer..::.ItemNameChangedDifference ► Item
Declaration Syntax
C#
public Item Item { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


NewName Property

NewName Property
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer..::.ItemNameChangedDifference ► NewName
Declaration Syntax
C#
public string NewName { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CompareSubtrees.SubtreeComparer.ItemTemplateChangedDifference Class

CompareSubtrees..::.SubtreeComparer..::.ItemTemplateChangedDifference Class
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer ► CompareSubtrees..::.SubtreeComparer..::.ItemTemplateChangedDifference
Declaration Syntax
C#
public class ItemTemplateChangedDifference : CompareSubtrees..::.SubtreeComparer..::.Difference
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompareSubtrees..::.SubtreeComparer..::.ItemTemplateChangedDifference(Item, String) | Initializes a new instance of the CompareSubtrees..::.SubtreeComparer..::.ItemTemplateChangedDifference class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewTemplateName |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CompareSubtrees..::.SubtreeComparer..::.Difference
 |  | CompareSubtrees..::.SubtreeComparer..::.ItemTemplateChangedDifference

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CompareSubtrees.SubtreeComparer.ItemTemplateChangedDifference Constructor (item, newTemplateName)

CompareSubtrees..::.SubtreeComparer..::.ItemTemplateChangedDifference Constructor (item, newTemplateName)
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer..::.ItemTemplateChangedDifference ► CompareSubtrees..::.SubtreeComparer..::.ItemTemplateChangedDifference(Item, String)
Initializes a new instance of the CompareSubtrees..::.SubtreeComparer..::.ItemTemplateChangedDifference class
Declaration Syntax
C#
public ItemTemplateChangedDifference(
    Item item,
    string newTemplateName
)
Parameters
item (Item)
newTemplateName (String)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Item Property

Item Property
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer..::.ItemTemplateChangedDifference ► Item
Declaration Syntax
C#
public Item Item { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


NewTemplateName Property

NewTemplateName Property
Namespaces ► Sitecore.sitecore.admin ► CompareSubtrees..::.SubtreeComparer..::.ItemTemplateChangedDifference ► NewTemplateName
Declaration Syntax
C#
public string NewTemplateName { get; set; }

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


restore Class

restore Class
Namespaces ► Sitecore.sitecore.admin ► restore
Restore page
Declaration Syntax
C#
public class restore : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | restore()()() | Initializes a new instance of the restore class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | btnGo |
 | btnGo_Click(Object, EventArgs) | Handles the Click event of the btnGo control.
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | ctlArchive |
 | ctlDatabase |
 | ctlPath |
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 |
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) | Handles the Load event of the Page control.
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | restore

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


restore Constructor

restore Constructor
Namespaces ► Sitecore.sitecore.admin ► restore ► restore()()()
Initializes a new instance of the restore class
Declaration Syntax
C#
public restore()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


btnGo Field

btnGo Field
Namespaces ► Sitecore.sitecore.admin ► restore ► btnGo
Declaration Syntax
C#
protected Button btnGo

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


btnGo_Click Method (sender, e)

btnGo_Click Method (sender, e)
Namespaces ► Sitecore.sitecore.admin ► restore ► btnGo_Click(Object, EventArgs)
Handles the Click event of the btnGo control.
Declaration Syntax
C#
protected void btnGo_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ctlArchive Field

ctlArchive Field
Namespaces ► Sitecore.sitecore.admin ► restore ► ctlArchive
Declaration Syntax
C#
protected TextBox ctlArchive

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ctlDatabase Field

ctlDatabase Field
Namespaces ► Sitecore.sitecore.admin ► restore ► ctlDatabase
Declaration Syntax
C#
protected TextBox ctlDatabase

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ctlPath Field

ctlPath Field
Namespaces ► Sitecore.sitecore.admin ► restore ► ctlPath
Declaration Syntax
C#
protected TextBox ctlPath

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


form1 Field

form1 Field
Namespaces ► Sitecore.sitecore.admin ► restore ► form1
Declaration Syntax
C#
protected HtmlForm form1

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore.sitecore.admin ► restore ► Page_Load(Object, EventArgs)
Handles the Load event of the Page control.
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ShowConfig Class

ShowConfig Class
Namespaces ► Sitecore.sitecore.admin ► ShowConfig
ShowConfig class
Declaration Syntax
C#
public class ShowConfig : Page
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShowConfig()()() | Initializes a new instance of the ShowConfig class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) | Handles the Load event of the Page control.
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | ShowConfig

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


ShowConfig Constructor

ShowConfig Constructor
Namespaces ► Sitecore.sitecore.admin ► ShowConfig ► ShowConfig()()()
Initializes a new instance of the ShowConfig class
Declaration Syntax
C#
public ShowConfig()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore.sitecore.admin ► ShowConfig ► Page_Load(Object, EventArgs)
Handles the Load event of the Page control.
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


stats Class

stats Class
Namespaces ► Sitecore.sitecore.admin ► stats
stats
Declaration Syntax
C#
public class stats : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | stats()()() | Initializes a new instance of the stats class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | c_reset | c_reset control.
 | c_reset_Click(Object, EventArgs) | Handles the C_reset_ click event.
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 | form1 control.
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) | Page load event handler.
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | renderings | renderings control.
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | siteSelector | siteSelector control.
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | stats

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


stats Constructor

stats Constructor
Namespaces ► Sitecore.sitecore.admin ► stats ► stats()()()
Initializes a new instance of the stats class
Declaration Syntax
C#
public stats()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_reset Field

c_reset Field
Namespaces ► Sitecore.sitecore.admin ► stats ► c_reset
c_reset control.
Declaration Syntax
C#
protected Button c_reset
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


c_reset_Click Method (sender, e)

c_reset_Click Method (sender, e)
Namespaces ► Sitecore.sitecore.admin ► stats ► c_reset_Click(Object, EventArgs)
Handles the C_reset_ click event.
Declaration Syntax
C#
protected void c_reset_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The sender.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


form1 Field

form1 Field
Namespaces ► Sitecore.sitecore.admin ► stats ► form1
form1 control.
Declaration Syntax
C#
protected HtmlForm form1
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore.sitecore.admin ► stats ► Page_Load(Object, EventArgs)
Page load event handler.
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The sender.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


renderings Field

renderings Field
Namespaces ► Sitecore.sitecore.admin ► stats ► renderings
renderings control.
Declaration Syntax
C#
protected PlaceHolder renderings
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


siteSelector Field

siteSelector Field
Namespaces ► Sitecore.sitecore.admin ► stats ► siteSelector
siteSelector control.
Declaration Syntax
C#
protected HtmlGenericControl siteSelector
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.sitecore.shell.Applications.Floatie Namespace

Sitecore.sitecore.shell.Applications.Floatie Namespace
Namespaces ► Sitecore.sitecore.shell.Applications.Floatie
Declaration Syntax
C#
namespace Sitecore.sitecore.shell.Applications.Floatie
Types
All Types Classes
Icon | Type | Description
 | FloatieFrame | Represents a Floatie.


FloatieFrame Class

FloatieFrame Class
Namespaces ► Sitecore.sitecore.shell.Applications.Floatie ► FloatieFrame
Represents a Floatie.
Declaration Syntax
C#
public class FloatieFrame : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FloatieFrame()()() | Initializes a new instance of the FloatieFrame class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Hidden | Gets or sets a value indicating whether this FloatieFrame is hidden.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets the parameters.
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | FloatieFrame


FloatieFrame Constructor

FloatieFrame Constructor
Namespaces ► Sitecore.sitecore.shell.Applications.Floatie ► FloatieFrame ► FloatieFrame()()()
Initializes a new instance of the FloatieFrame class
Declaration Syntax
C#
public FloatieFrame()


Hidden Property

Hidden Property
Namespaces ► Sitecore.sitecore.shell.Applications.Floatie ► FloatieFrame ► Hidden
Gets or sets a value indicating whether this FloatieFrame is hidden.
Declaration Syntax
C#
public bool Hidden { get; set; }
Value
true if hidden; otherwise, false.


Parameters Property

Parameters Property
Namespaces ► Sitecore.sitecore.shell.Applications.Floatie ► FloatieFrame ► Parameters
Gets the parameters.
Declaration Syntax
C#
public NameValueCollection Parameters { get; }
Value
The parameters.


Render Method (writer)

Render Method (writer)
Namespaces ► Sitecore.sitecore.shell.Applications.Floatie ► FloatieFrame ► Render(HtmlTextWriter)
Renders the control to the specified HTML writer.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)
The HtmlTextWriter object that receives the control content.


Sitecore.sitecore.shell.Templates Namespace

Sitecore.sitecore.shell.Templates Namespace
Namespaces ► Sitecore.sitecore.shell.Templates
Declaration Syntax
C#
namespace Sitecore.sitecore.shell.Templates
Types
All Types Classes
Icon | Type | Description
 | XHTMLPage | Represents a XHTMLPage.


XHTMLPage Class

XHTMLPage Class
Namespaces ► Sitecore.sitecore.shell.Templates ► XHTMLPage
Represents a XHTMLPage.
Declaration Syntax
C#
public class XHTMLPage : Page
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XHTMLPage()()() | Initializes a new instance of the XHTMLPage class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | XHTMLPage

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


XHTMLPage Constructor

XHTMLPage Constructor
Namespaces ► Sitecore.sitecore.shell.Templates ► XHTMLPage ► XHTMLPage()()()
Initializes a new instance of the XHTMLPage class
Declaration Syntax
C#
public XHTMLPage()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore.sitecore.shell.Templates ► XHTMLPage ► Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.sitecore.testing Namespace

Sitecore.sitecore.testing Namespace
Namespaces ► Sitecore.sitecore.testing
Declaration Syntax
C#
namespace Sitecore.sitecore.testing
Types
All Types Classes
Icon | Type | Description
 | Reflect | Represents a Reflect.


Reflect Class

Reflect Class
Namespaces ► Sitecore.sitecore.testing ► Reflect
Represents a Reflect.
Declaration Syntax
C#
public class Reflect : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Reflect()()() | Initializes a new instance of the Reflect class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 |
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Head1 |
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) | Handles the Load event of the Page control.
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Test | Gets or sets the test.
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Reflect

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Reflect Constructor

Reflect Constructor
Namespaces ► Sitecore.sitecore.testing ► Reflect ► Reflect()()()
Initializes a new instance of the Reflect class
Declaration Syntax
C#
public Reflect()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


form1 Field

form1 Field
Namespaces ► Sitecore.sitecore.testing ► Reflect ► form1
Declaration Syntax
C#
protected HtmlForm form1

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Head1 Field

Head1 Field
Namespaces ► Sitecore.sitecore.testing ► Reflect ► Head1
Declaration Syntax
C#
protected HtmlHead Head1

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces ► Sitecore.sitecore.testing ► Reflect ► Page_Load(Object, EventArgs)
Handles the Load event of the Page control.
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Test Property

Test Property
Namespaces ► Sitecore.sitecore.testing ► Reflect ► Test
Gets or sets the test.
Declaration Syntax
C#
public string Test { get; set; }
Value
The test.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Sites Namespace

Sitecore.Sites Namespace
Namespaces ► Sitecore.Sites
Declaration Syntax
C#
namespace Sitecore.Sites
Types
All Types Classes Enumerations
Icon | Type | Description
 | ConfigSiteProvider | ConfigSiteProvider class
 | DisplayMode | Defines the current display mode.
 | DisplayModeDuration | Defines the duration of the display mode.
 | Site | Site class
 | SiteCaches | Represents a cache of SiteInfo definitions.
 | SiteCollection | SiteCollection class
 | SiteContext | Represents the current Site Context.
 | SiteContextFactory | Creates objects related to the SiteContext.
 | SiteContextSwitcher | SiteContextSwitcher class
 | SiteManager | SiteManager class
 | SiteProvider | SiteProvider class
 | SiteProviderCollection | SiteProviderCollection class
 | SiteRequest | Represents a SiteRequest.
 | SiteResponse | Represents a SiteResponse.


ConfigSiteProvider Class

ConfigSiteProvider Class
Namespaces ► Sitecore.Sites ► ConfigSiteProvider
ConfigSiteProvider class
Declaration Syntax
C#
public class ConfigSiteProvider : SiteProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigSiteProvider()()() | Initializes a new instance of the ConfigSiteProvider class.
 | CanEnter(Site, Account) | Determines whether an account can enter the specified site. (Inherited from SiteProvider.)
 | CheckSecurity | Gets a value indicating whether to check security (usually the site:enter right). (Inherited from SiteProvider.)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSite(String) | Gets a site. (Overrides SiteProvider.GetSite(String).)
 | GetSites()()() | Gets the list of all known sites. (Overrides SiteProvider.GetSites()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides SiteProvider.Initialize(String, NameValueCollection).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | SiteProvider
 |  |  | ConfigSiteProvider


ConfigSiteProvider Constructor

ConfigSiteProvider Constructor
Namespaces ► Sitecore.Sites ► ConfigSiteProvider ► ConfigSiteProvider()()()
Initializes a new instance of the ConfigSiteProvider class.
Declaration Syntax
C#
public ConfigSiteProvider()


GetSite Method (siteName)

GetSite Method (siteName)
Namespaces ► Sitecore.Sites ► ConfigSiteProvider ► GetSite(String)
Gets a site.
Declaration Syntax
C#
public override Site GetSite(
    string siteName
)
Parameters
siteName (String)
Name of the site.
Return Value


GetSites Method

GetSites Method
Namespaces ► Sitecore.Sites ► ConfigSiteProvider ► GetSites()()()
Gets the list of all known sites.
Declaration Syntax
C#
public override SiteCollection GetSites()
Return Value


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Sites ► ConfigSiteProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.
ArgumentException | The name of the provider has a length of zero.


DisplayMode Enumeration

DisplayMode Enumeration
Namespaces ► Sitecore.Sites ► DisplayMode
Defines the current display mode.
Declaration Syntax
C#
public enum DisplayMode
Members
Member | Description
Normal | Normal.
Edit | Web Edit.
Preview | Preview.


DisplayModeDuration Enumeration

DisplayModeDuration Enumeration
Namespaces ► Sitecore.Sites ► DisplayModeDuration
Defines the duration of the display mode.
Declaration Syntax
C#
public enum DisplayModeDuration
Members
Member | Description
Remember | Remember.
Temporary | Temporary.
ResetAfterRequest | Reset after request.


Site Class

Site Class
Namespaces ► Sitecore.Sites ► Site
Site class
Declaration Syntax
C#
public class Site : ISecurable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Site(String) | Initializes a new instance of the Site class.
 | Site(String, StringDictionary) | Initializes a new instance of the Site class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniqueId()()() | Gets a unique id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the site.
 | Properties | Gets the properties.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Site


Site Constructor

Site Constructor
Namespaces ► Sitecore.Sites ► Site ► Site()()()
Members
Icon | Member | Description
 | Site(String) | Initializes a new instance of the Site class.
 | Site(String, StringDictionary) | Initializes a new instance of the Site class.


Site Constructor (name)

Site Constructor (name)
Namespaces ► Sitecore.Sites ► Site ► Site(String)
Initializes a new instance of the Site class.
Declaration Syntax
C#
public Site(
    string name
)
Parameters
name (String)


Site Constructor (name, properties)

Site Constructor (name, properties)
Namespaces ► Sitecore.Sites ► Site ► Site(String, StringDictionary)
Initializes a new instance of the Site class.
Declaration Syntax
C#
public Site(
    string name,
    StringDictionary properties
)
Parameters
name (String)
The name.
properties (StringDictionary)
The properties.


GetUniqueId Method

GetUniqueId Method
Namespaces ► Sitecore.Sites ► Site ► GetUniqueId()()()
Gets a unique id.
Declaration Syntax
C#
public string GetUniqueId()
Return Value
Remarks

The id must be unique enough to be used in a global cache.

For example, an Item might implement this as Database.Name + ID.

The resulting key used by Item might therefore be typeof(Item).FullName + divider + Database.Name + ID.


Name Property

Name Property
Namespaces ► Sitecore.Sites ► Site ► Name
Gets the name of the site.
Declaration Syntax
C#
public virtual string Name { get; }
Value
The name.


Properties Property

Properties Property
Namespaces ► Sitecore.Sites ► Site ► Properties
Gets the properties.
Declaration Syntax
C#
public virtual StringDictionary Properties { get; }
Value
The properties.


SiteCaches Class

SiteCaches Class
Namespaces ► Sitecore.Sites ► SiteCaches
Represents a cache of SiteInfo definitions.
Declaration Syntax
C#
public class SiteCaches
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteCaches(SiteContext) | Initializes a new instance of the SiteCaches class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilteredItemsCache | Gets the filtered items cache.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HtmlCache | Gets the HTML cache.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegistryCache | Gets the registry cache.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ViewStateCache | Gets the view state cache.
 | XslCache | Gets the XSL cache.
Inheritance Hierarchy
Object
SiteCaches


SiteCaches Constructor (site)

SiteCaches Constructor (site)
Namespaces ► Sitecore.Sites ► SiteCaches ► SiteCaches(SiteContext)
Initializes a new instance of the SiteCaches class.
Declaration Syntax
C#
public SiteCaches(
    SiteContext site
)
Parameters
site (SiteContext)
The site.


FilteredItemsCache Property

FilteredItemsCache Property
Namespaces ► Sitecore.Sites ► SiteCaches ► FilteredItemsCache
Gets the filtered items cache.
Declaration Syntax
C#
public FilteredItemsCache FilteredItemsCache { get; }
Value
The filtered items cache.


HtmlCache Property

HtmlCache Property
Namespaces ► Sitecore.Sites ► SiteCaches ► HtmlCache
Gets the HTML cache.
Declaration Syntax
C#
public HtmlCache HtmlCache { get; }
Value
The HTML cache.


RegistryCache Property

RegistryCache Property
Namespaces ► Sitecore.Sites ► SiteCaches ► RegistryCache
Gets the registry cache.
Declaration Syntax
C#
public RegistryCache RegistryCache { get; }
Value
The registry cache.


ViewStateCache Property

ViewStateCache Property
Namespaces ► Sitecore.Sites ► SiteCaches ► ViewStateCache
Gets the view state cache.
Declaration Syntax
C#
public ViewStateCache ViewStateCache { get; }
Value
The view state cache.


XslCache Property

XslCache Property
Namespaces ► Sitecore.Sites ► SiteCaches ► XslCache
Gets the XSL cache.
Declaration Syntax
C#
public XslCache XslCache { get; }
Value
The XSL cache.


SiteCollection Class

SiteCollection Class
Namespaces ► Sitecore.Sites ► SiteCollection
SiteCollection class
Declaration Syntax
C#
public class SiteCollection : Collection<Site>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteCollection()()() | Initializes a new instance of the SiteCollection class
 | Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Site >)>).)
 | AddRange(IEnumerable<(Of <(Site>)>)) | Adds the range.
 | Clear()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Site >)>).)
 | ClearItems()()() | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Site >)>).)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Site >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Site >)>).)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Site >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Site >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Site >)>).)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Site >)>).)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Site >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Site >)>).)
 | Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Site >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Site >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Site >)>).)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Site >)>).)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection<(Of <( Site >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection<(Of <( Site >)>)
 |  | SiteCollection


SiteCollection Constructor

SiteCollection Constructor
Namespaces ► Sitecore.Sites ► SiteCollection ► SiteCollection()()()
Initializes a new instance of the SiteCollection class
Declaration Syntax
C#
public SiteCollection()


AddRange Method (sites)

AddRange Method (sites)
Namespaces ► Sitecore.Sites ► SiteCollection ► AddRange(IEnumerable<(Of <(Site>)>))
Adds the range.
Declaration Syntax
C#
public void AddRange(
    IEnumerable<Site> sites
)
Parameters
sites (IEnumerable<(Of <( Site >)>))
The sites.


SiteContext Class

SiteContext Class
Namespaces ► Sitecore.Sites ► SiteContext
Represents the current Site Context.
Declaration Syntax
C#
public class SiteContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteContext(SiteInfo, Boolean) | A light version of constructor, initializes minimum amount of data.
 | SiteContext(SiteInfo) | Initializes a new instance of the SiteContext class.
 | AllowDebug | Gets a value indicating whether the SiteContext allows debugging.
 | BrowserTitle | Gets the browser title.
 | CacheHtml | Gets a value indicating whether the SiteContext caches the HTML.
 | CacheMedia | Gets a value indicating whether to cache media.
 | Caches | Gets the caches.
 | ContentDatabase | Gets the content database.
 | ContentLanguage | Gets the content language.
 | ContentStartItem | Gets the content start item.
 | ContentStartPath | Gets the content start path.
 | Current | Gets the current site (same as Site).
 | Database | Gets the database.
 | DefaultDevice | Gets the default device.
 | Device | Gets the device.
 | DisableClientData | Gets a value indicating whether client data is disabled for the site.
 | DisableFiltering | Gets or sets a value indicating whether the SiteContext disables the filtering.
 | DisableWebEditEditing | Gets a value indicating whether the webedit mode is editable.
 | DisableWebEditSelecting | Gets a value indicating whether selecting in web edit mode is disabled.
 | DisableXmlControls | Gets a value indicating whether XML controls are disabled for this site.
 | DisplayDate | Gets the display date.
 | DisplayMode | Gets the display mode.
 | Domain | Gets the domain.
 | DrawDots | Gets a value indicating whether the SiteContext draws the dots.
 | EnableAnalytics | Gets a value indicating whether analytics is enabled.
 | EnableDebugger | Gets a value indicating whether the SiteContext enables the debugger.
 | EnableLinkedItems | Obsolete. Gets a value indicating whether the SiteContext enables the linked items.
 | EnablePreview | Gets a value indicating whether the SiteContext enables previewing.
 | EnableWebEdit | Gets a value indicating whether the SiteContext enables web editing.
 | EnableWorkflow | Gets a value indicating whether the SiteContext enables workflowing.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterItems | Gets a value indicating whether the SiteContext filters the items.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindWebSite(Database) | Finds the web site based on a specific master database.
 | GetCookieKey(String) | Gets the cookie key.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSite(String) | Gets a site.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWebSiteUrl()()() | Gets the web site URL.
 | GetWebSiteUrl(Database) | Gets the web site URL.
 | HostName | Gets the host name.
 | Language | Gets the language.
 | LoginPage | Gets the login page.
 | MasterDatabase | Gets the master database associated with the site.
 | MediaCachePath | Gets the path to the media cache.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | Notifications | Gets the notifications.
 | Page | Gets the page.
 | PhysicalFolder | Gets the physical folder.
 | Properties | Gets the properties.
 | Request | Gets the request.
 | RequireLogin | Gets a value indicating whether the SiteContext requires login.
 | Resources | Gets the resources.
 | Response | Gets the response.
 | RootPath | Gets the root path.
 | SetDisplayDate(DateTime) | Sets the display date.
 | SetDisplayMode(DisplayMode, DisplayModeDuration) | Sets the display mode.
 | SiteInfo | Gets the site info.
 | StartItem | Gets the start item.
 | StartPath | Gets the start path.
 | TargetHostName | Gets the name of the target host.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VirtualFolder | Gets the virtual folder.
 | XmlControlPage | Gets the XML control page.
Inheritance Hierarchy
Object
SiteContext


SiteContext Constructor

SiteContext Constructor
Namespaces ► Sitecore.Sites ► SiteContext ► SiteContext()()()
Members
Icon | Member | Description
 | SiteContext(SiteInfo, Boolean) | A light version of constructor, initializes minimum amount of data.
 | SiteContext(SiteInfo) | Initializes a new instance of the SiteContext class.


SiteContext Constructor (info)

SiteContext Constructor (info)
Namespaces ► Sitecore.Sites ► SiteContext ► SiteContext(SiteInfo)
Initializes a new instance of the SiteContext class.
Declaration Syntax
C#
public SiteContext(
    SiteInfo info
)
Parameters
info (SiteInfo)
The info.


SiteContext Constructor (info, processQueryString)

SiteContext Constructor (info, processQueryString)
Namespaces ► Sitecore.Sites ► SiteContext ► SiteContext(SiteInfo, Boolean)
A light version of constructor, initializes minimum amount of data.
Declaration Syntax
C#
protected internal SiteContext(
    SiteInfo info,
    bool processQueryString
)
Parameters
info (SiteInfo)
The info.
processQueryString (Boolean)
if set to true query string will be processed.


AllowDebug Property

AllowDebug Property
Namespaces ► Sitecore.Sites ► SiteContext ► AllowDebug
Gets a value indicating whether the SiteContext allows debugging.
Declaration Syntax
C#
public bool AllowDebug { get; }
Value
true if the SiteContext allows debugging; otherwise, false.


BrowserTitle Property

BrowserTitle Property
Namespaces ► Sitecore.Sites ► SiteContext ► BrowserTitle
Gets the browser title.
Declaration Syntax
C#
public string BrowserTitle { get; }
Value
The browser title.


CacheHtml Property

CacheHtml Property
Namespaces ► Sitecore.Sites ► SiteContext ► CacheHtml
Gets a value indicating whether the SiteContext caches the HTML.
Declaration Syntax
C#
public bool CacheHtml { get; }
Value
true if the SiteContext caches the HTML; otherwise, false.


CacheMedia Property

CacheMedia Property
Namespaces ► Sitecore.Sites ► SiteContext ► CacheMedia
Gets a value indicating whether to cache media.
Declaration Syntax
C#
public bool CacheMedia { get; }
Value
true if media should be cached; otherwise, false.


Caches Property

Caches Property
Namespaces ► Sitecore.Sites ► SiteContext ► Caches
Gets the caches.
Declaration Syntax
C#
public SiteCaches Caches { get; }
Value
The caches.


ContentDatabase Property

ContentDatabase Property
Namespaces ► Sitecore.Sites ► SiteContext ► ContentDatabase
Gets the content database.
Declaration Syntax
C#
public Database ContentDatabase { get; }
Value
The content database.


ContentLanguage Property

ContentLanguage Property
Namespaces ► Sitecore.Sites ► SiteContext ► ContentLanguage
Gets the content language.
Declaration Syntax
C#
public Language ContentLanguage { get; }
Value
The content language.


ContentStartItem Property

ContentStartItem Property
Namespaces ► Sitecore.Sites ► SiteContext ► ContentStartItem
Gets the content start item.
Declaration Syntax
C#
public string ContentStartItem { get; }
Value
The content start item.


ContentStartPath Property

ContentStartPath Property
Namespaces ► Sitecore.Sites ► SiteContext ► ContentStartPath
Gets the content start path.
Declaration Syntax
C#
public string ContentStartPath { get; }
Value
The content start path.


Current Property

Current Property
Namespaces ► Sitecore.Sites ► SiteContext ► Current
Gets the current site (same as Site).
Declaration Syntax
C#
public static SiteContext Current { get; }
Value
The current.


Database Property

Database Property
Namespaces ► Sitecore.Sites ► SiteContext ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; set; }
Value
The database.


DefaultDevice Property

DefaultDevice Property
Namespaces ► Sitecore.Sites ► SiteContext ► DefaultDevice
Gets the default device.
Declaration Syntax
C#
public string DefaultDevice { get; }
Value
The default device.


Device Property

Device Property
Namespaces ► Sitecore.Sites ► SiteContext ► Device
Gets the device.
Declaration Syntax
C#
public string Device { get; }
Value
The device.


DisableClientData Property

DisableClientData Property
Namespaces ► Sitecore.Sites ► SiteContext ► DisableClientData
Gets a value indicating whether client data is disabled for the site.
Declaration Syntax
C#
public bool DisableClientData { get; }
Value
true if disabled; otherwise, false.


DisableFiltering Property

DisableFiltering Property
Namespaces ► Sitecore.Sites ► SiteContext ► DisableFiltering
Gets or sets a value indicating whether the SiteContext disables the filtering.
Declaration Syntax
C#
public bool DisableFiltering { get; set; }
Value
true if the SiteContext disables the filtering; otherwise, false.


DisableWebEditEditing Property

DisableWebEditEditing Property
Namespaces ► Sitecore.Sites ► SiteContext ► DisableWebEditEditing
Gets a value indicating whether the webedit mode is editable.
Declaration Syntax
C#
public bool DisableWebEditEditing { get; }
Value
true if the webedit mode is editable; otherwise, false.


DisableWebEditSelecting Property

DisableWebEditSelecting Property
Namespaces ► Sitecore.Sites ► SiteContext ► DisableWebEditSelecting
Gets a value indicating whether selecting in web edit mode is disabled.
Declaration Syntax
C#
public bool DisableWebEditSelecting { get; }
Value
true if selecting in web edit mode is disabled; otherwise, false.


DisableXmlControls Property

DisableXmlControls Property
Namespaces ► Sitecore.Sites ► SiteContext ► DisableXmlControls
Gets a value indicating whether XML controls are disabled for this site.
Declaration Syntax
C#
public bool DisableXmlControls { get; }
Value
true if disabled; otherwise, false.


DisplayDate Property

DisplayDate Property
Namespaces ► Sitecore.Sites ► SiteContext ► DisplayDate
Gets the display date.
Declaration Syntax
C#
public DateTime DisplayDate { get; }
Value
The display date.


DisplayMode Property

DisplayMode Property
Namespaces ► Sitecore.Sites ► SiteContext ► DisplayMode
Gets the display mode.
Declaration Syntax
C#
public DisplayMode DisplayMode { get; }
Value
The display mode.


Domain Property

Domain Property
Namespaces ► Sitecore.Sites ► SiteContext ► Domain
Gets the domain.
Declaration Syntax
C#
public Domain Domain { get; }
Value
The domain.


DrawDots Property

DrawDots Property
Namespaces ► Sitecore.Sites ► SiteContext ► DrawDots
Gets a value indicating whether the SiteContext draws the dots.
Declaration Syntax
C#
public bool DrawDots { get; }
Value
true if the SiteContext draws the dots; otherwise, false.


EnableAnalytics Property

EnableAnalytics Property
Namespaces ► Sitecore.Sites ► SiteContext ► EnableAnalytics
Gets a value indicating whether analytics is enabled.
Declaration Syntax
C#
public bool EnableAnalytics { get; }
Value
true if analytics is enabled; otherwise, false.


EnableDebugger Property

EnableDebugger Property
Namespaces ► Sitecore.Sites ► SiteContext ► EnableDebugger
Gets a value indicating whether the SiteContext enables the debugger.
Declaration Syntax
C#
public bool EnableDebugger { get; }
Value
true if the SiteContext enables the debugger; otherwise, false.


EnableLinkedItems Property

EnableLinkedItems Property
Namespaces ► Sitecore.Sites ► SiteContext ► EnableLinkedItems
Gets a value indicating whether the SiteContext enables the linked items.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public bool EnableLinkedItems { get; }
Value
true if the SiteContext enables the linked items; otherwise, false.


EnablePreview Property

EnablePreview Property
Namespaces ► Sitecore.Sites ► SiteContext ► EnablePreview
Gets a value indicating whether the SiteContext enables previewing.
Declaration Syntax
C#
public bool EnablePreview { get; }
Value
true if the SiteContext enables previewing; otherwise, false.


EnableWebEdit Property

EnableWebEdit Property
Namespaces ► Sitecore.Sites ► SiteContext ► EnableWebEdit
Gets a value indicating whether the SiteContext enables web editing.
Declaration Syntax
C#
public bool EnableWebEdit { get; }
Value
true if the SiteContext enables web editing; otherwise, false.


EnableWorkflow Property

EnableWorkflow Property
Namespaces ► Sitecore.Sites ► SiteContext ► EnableWorkflow
Gets a value indicating whether the SiteContext enables workflowing.
Declaration Syntax
C#
public bool EnableWorkflow { get; }
Value
true if the SiteContext enables workflowing; otherwise, false.


FilterItems Property

FilterItems Property
Namespaces ► Sitecore.Sites ► SiteContext ► FilterItems
Gets a value indicating whether the SiteContext filters the items.
Declaration Syntax
C#
public bool FilterItems { get; }
Value
true if the SiteContext filters the items; otherwise, false.


FindWebSite Method (masterDatabase)

FindWebSite Method (masterDatabase)
Namespaces ► Sitecore.Sites ► SiteContext ► FindWebSite(Database)
Finds the web site based on a specific master database.
Declaration Syntax
C#
public static SiteContext FindWebSite(
    Database masterDatabase
)
Parameters
masterDatabase (Database)
The master database.


GetCookieKey Method (name)

GetCookieKey Method (name)
Namespaces ► Sitecore.Sites ► SiteContext ► GetCookieKey(String)
Gets the cookie key.
Declaration Syntax
C#
public string GetCookieKey(
    string name
)
Parameters
name (String)
The name.
Return Value


GetSite Method (siteName)

GetSite Method (siteName)
Namespaces ► Sitecore.Sites ► SiteContext ► GetSite(String)
Gets a site.
Declaration Syntax
C#
public static SiteContext GetSite(
    string siteName
)
Parameters
siteName (String)
Name of the site.
Return Value


GetWebSiteUrl Method

GetWebSiteUrl Method
Namespaces ► Sitecore.Sites ► SiteContext ► GetWebSiteUrl()()()
Members
Icon | Member | Description
 | GetWebSiteUrl()()() | Gets the web site URL.
 | GetWebSiteUrl(Database) | Gets the web site URL.


GetWebSiteUrl Method

GetWebSiteUrl Method
Namespaces ► Sitecore.Sites ► SiteContext ► GetWebSiteUrl()()()
Gets the web site URL.
Declaration Syntax
C#
public static UrlString GetWebSiteUrl()
Return Value
The web site URL.


GetWebSiteUrl Method (database)

GetWebSiteUrl Method (database)
Namespaces ► Sitecore.Sites ► SiteContext ► GetWebSiteUrl(Database)
Gets the web site URL.
Declaration Syntax
C#
public static UrlString GetWebSiteUrl(
    Database database
)
Parameters
database (Database)
Return Value
The web site URL.


HostName Property

HostName Property
Namespaces ► Sitecore.Sites ► SiteContext ► HostName
Gets the host name.
Declaration Syntax
C#
public string HostName { get; }
Value
The host name.


Language Property

Language Property
Namespaces ► Sitecore.Sites ► SiteContext ► Language
Gets the language.
Declaration Syntax
C#
public string Language { get; }
Value
The language.


LoginPage Property

LoginPage Property
Namespaces ► Sitecore.Sites ► SiteContext ► LoginPage
Gets the login page.
Declaration Syntax
C#
public string LoginPage { get; }
Value
The login page.


MasterDatabase Property

MasterDatabase Property
Namespaces ► Sitecore.Sites ► SiteContext ► MasterDatabase
Gets the master database associated with the site.
Declaration Syntax
C#
public Database MasterDatabase { get; }
Value
The master database.
Remarks
This database is used as the data source when previewing and web editing.


MediaCachePath Property

MediaCachePath Property
Namespaces ► Sitecore.Sites ► SiteContext ► MediaCachePath
Gets the path to the media cache.
Declaration Syntax
C#
public string MediaCachePath { get; }
Value
The media cache path.


Name Property

Name Property
Namespaces ► Sitecore.Sites ► SiteContext ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Notifications Property

Notifications Property
Namespaces ► Sitecore.Sites ► SiteContext ► Notifications
Gets the notifications.
Declaration Syntax
C#
public NotificationContext Notifications { get; }
Value
The notifications.


Page Property

Page Property
Namespaces ► Sitecore.Sites ► SiteContext ► Page
Gets the page.
Declaration Syntax
C#
public PageContext Page { get; }
Value
The page.


PhysicalFolder Property

PhysicalFolder Property
Namespaces ► Sitecore.Sites ► SiteContext ► PhysicalFolder
Gets the physical folder.
Declaration Syntax
C#
public string PhysicalFolder { get; }
Value
The physical folder.


Properties Property

Properties Property
Namespaces ► Sitecore.Sites ► SiteContext ► Properties
Gets the properties.
Declaration Syntax
C#
public NameValueCollection Properties { get; }
Value
The properties.


Request Property

Request Property
Namespaces ► Sitecore.Sites ► SiteContext ► Request
Gets the request.
Declaration Syntax
C#
public SiteRequest Request { get; }
Value
The request.


RequireLogin Property

RequireLogin Property
Namespaces ► Sitecore.Sites ► SiteContext ► RequireLogin
Gets a value indicating whether the SiteContext requires login.
Declaration Syntax
C#
public bool RequireLogin { get; }
Value
true if the SiteContext requires login; otherwise, false.


Resources Property

Resources Property
Namespaces ► Sitecore.Sites ► SiteContext ► Resources
Gets the resources.
Declaration Syntax
C#
public ResourceContext Resources { get; }
Value
The resources.


Response Property

Response Property
Namespaces ► Sitecore.Sites ► SiteContext ► Response
Gets the response.
Declaration Syntax
C#
public SiteResponse Response { get; }
Value
The response.


RootPath Property

RootPath Property
Namespaces ► Sitecore.Sites ► SiteContext ► RootPath
Gets the root path.
Declaration Syntax
C#
public string RootPath { get; }
Value
The root path.


SetDisplayDate Method (value)

SetDisplayDate Method (value)
Namespaces ► Sitecore.Sites ► SiteContext ► SetDisplayDate(DateTime)
Sets the display date.
Declaration Syntax
C#
public void SetDisplayDate(
    DateTime value
)
Parameters
value (DateTime)
The value.


SetDisplayMode Method (mode, duration)

SetDisplayMode Method (mode, duration)
Namespaces ► Sitecore.Sites ► SiteContext ► SetDisplayMode(DisplayMode, DisplayModeDuration)
Sets the display mode.
Declaration Syntax
C#
public void SetDisplayMode(
    DisplayMode mode,
    DisplayModeDuration duration
)
Parameters
mode (DisplayMode)
The mode.
duration (DisplayModeDuration)
The duration.


SiteInfo Property

SiteInfo Property
Namespaces ► Sitecore.Sites ► SiteContext ► SiteInfo
Gets the site info.
Declaration Syntax
C#
public SiteInfo SiteInfo { get; }
Value
The site info.


StartItem Property

StartItem Property
Namespaces ► Sitecore.Sites ► SiteContext ► StartItem
Gets the start item.
Declaration Syntax
C#
public string StartItem { get; }
Value
The start item.


StartPath Property

StartPath Property
Namespaces ► Sitecore.Sites ► SiteContext ► StartPath
Gets the start path.
Declaration Syntax
C#
public string StartPath { get; }
Value
The start path.


TargetHostName Property

TargetHostName Property
Namespaces ► Sitecore.Sites ► SiteContext ► TargetHostName
Gets the name of the target host.
Declaration Syntax
C#
public string TargetHostName { get; }
Value
The name of the target host.


VirtualFolder Property

VirtualFolder Property
Namespaces ► Sitecore.Sites ► SiteContext ► VirtualFolder
Gets the virtual folder.
Declaration Syntax
C#
public string VirtualFolder { get; }
Value
The virtual folder.


XmlControlPage Property

XmlControlPage Property
Namespaces ► Sitecore.Sites ► SiteContext ► XmlControlPage
Gets the XML control page.
Declaration Syntax
C#
public string XmlControlPage { get; }
Value
The XML control page.


SiteContextFactory Class

SiteContextFactory Class
Namespaces ► Sitecore.Sites ► SiteContextFactory
Creates objects related to the SiteContext.
Declaration Syntax
C#
public static class SiteContextFactory
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetSiteContext(String) | Gets the site context.
 | GetSiteContext(String, String) | Gets the site context.
 | GetSiteContext(String, String, Int32) | Gets the site context.
 | GetSiteContextFromFile(String) | Gets the site context from file.
 | GetSiteInfo(String) | Gets the site info.
 | GetSiteNames()()() | Gets the site names.
 | Reset()()() | Resets this instance.
 | Sites | Gets the sites.
Inheritance Hierarchy
Object
SiteContextFactory


GetSiteContext Method

GetSiteContext Method
Namespaces ► Sitecore.Sites ► SiteContextFactory ► GetSiteContext()()()
Members
Icon | Member | Description
 | GetSiteContext(String) | Gets the site context.
 | GetSiteContext(String, String) | Gets the site context.
 | GetSiteContext(String, String, Int32) | Gets the site context.


GetSiteContext Method (name)

GetSiteContext Method (name)
Namespaces ► Sitecore.Sites ► SiteContextFactory ► GetSiteContext(String)
Gets the site context.
Declaration Syntax
C#
public static SiteContext GetSiteContext(
    string name
)
Parameters
name (String)
The name.
Return Value


GetSiteContext Method (hostName, fullPath)

GetSiteContext Method (hostName, fullPath)
Namespaces ► Sitecore.Sites ► SiteContextFactory ► GetSiteContext(String, String)
Gets the site context.
Declaration Syntax
C#
public static SiteContext GetSiteContext(
    string hostName,
    string fullPath
)
Parameters
hostName (String)
Name of the host.
fullPath (String)
The full path.
Return Value


GetSiteContext Method (hostName, fullPath, portNumber)

GetSiteContext Method (hostName, fullPath, portNumber)
Namespaces ► Sitecore.Sites ► SiteContextFactory ► GetSiteContext(String, String, Int32)
Gets the site context.
Declaration Syntax
C#
public static SiteContext GetSiteContext(
    string hostName,
    string fullPath,
    int portNumber
)
Parameters
hostName (String)
Name of the host.
fullPath (String)
The full path.
portNumber (Int32)
The port number.
Return Value


GetSiteContextFromFile Method (filename)

GetSiteContextFromFile Method (filename)
Namespaces ► Sitecore.Sites ► SiteContextFactory ► GetSiteContextFromFile(String)
Gets the site context from file.
Declaration Syntax
C#
public static SiteContext GetSiteContextFromFile(
    string filename
)
Parameters
filename (String)
The filename.
Return Value


GetSiteInfo Method (name)

GetSiteInfo Method (name)
Namespaces ► Sitecore.Sites ► SiteContextFactory ► GetSiteInfo(String)
Gets the site info.
Declaration Syntax
C#
public static SiteInfo GetSiteInfo(
    string name
)
Parameters
name (String)
The name.
Return Value


GetSiteNames Method

GetSiteNames Method
Namespaces ► Sitecore.Sites ► SiteContextFactory ► GetSiteNames()()()
Gets the site names.
Declaration Syntax
C#
public static string[] GetSiteNames()
Return Value


Reset Method

Reset Method
Namespaces ► Sitecore.Sites ► SiteContextFactory ► Reset()()()
Resets this instance.
Declaration Syntax
C#
public static void Reset()


Sites Property

Sites Property
Namespaces ► Sitecore.Sites ► SiteContextFactory ► Sites
Gets the sites.
Declaration Syntax
C#
public static List<SiteInfo> Sites { get; }
Value
The sites.


SiteContextSwitcher Class

SiteContextSwitcher Class
Namespaces ► Sitecore.Sites ► SiteContextSwitcher
SiteContextSwitcher class
Declaration Syntax
C#
public class SiteContextSwitcher : Switcher<SiteContext, SiteContextSwitcher>
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteContextSwitcher(SiteContext) | Initializes a new instance of the SiteContextSwitcher class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <( SiteContext, SiteContextSwitcher>)>)
 |  | SiteContextSwitcher


SiteContextSwitcher Constructor (site)

SiteContextSwitcher Constructor (site)
Namespaces ► Sitecore.Sites ► SiteContextSwitcher ► SiteContextSwitcher(SiteContext)
Initializes a new instance of the SiteContextSwitcher class.
Declaration Syntax
C#
public SiteContextSwitcher(
    SiteContext site
)
Parameters
site (SiteContext)


SiteManager Class

SiteManager Class
Namespaces ► Sitecore.Sites ► SiteManager
SiteManager class
Declaration Syntax
C#
public static class SiteManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CanEnter(String, Account) | Determines whether an account can enter the specified site.
 | GetSite(String) | Gets a site.
 | GetSites()()() | Gets the list of all known sites.
 | Provider | Gets the provider.
 | Providers | Gets the providers.
Inheritance Hierarchy
Object
SiteManager


CanEnter Method (siteName, account)

CanEnter Method (siteName, account)
Namespaces ► Sitecore.Sites ► SiteManager ► CanEnter(String, Account)
Determines whether an account can enter the specified site.
Declaration Syntax
C#
public static bool CanEnter(
    string siteName,
    Account account
)
Parameters
siteName (String)
Name of the site.
account (Account)
The account.
Return Value
true if the account can enter the specified site; otherwise, false.


GetSite Method (siteName)

GetSite Method (siteName)
Namespaces ► Sitecore.Sites ► SiteManager ► GetSite(String)
Gets a site.
Declaration Syntax
C#
public static Site GetSite(
    string siteName
)
Parameters
siteName (String)
Name of the site.
Return Value


GetSites Method

GetSites Method
Namespaces ► Sitecore.Sites ► SiteManager ► GetSites()()()
Gets the list of all known sites.
Declaration Syntax
C#
public static SiteCollection GetSites()
Return Value


Provider Property

Provider Property
Namespaces ► Sitecore.Sites ► SiteManager ► Provider
Gets the provider.
Declaration Syntax
C#
public static SiteProvider Provider { get; }
Value
The provider.


Providers Property

Providers Property
Namespaces ► Sitecore.Sites ► SiteManager ► Providers
Gets the providers.
Declaration Syntax
C#
public static SiteProviderCollection Providers { get; }
Value
The provider.


SiteProvider Class

SiteProvider Class
Namespaces ► Sitecore.Sites ► SiteProvider
SiteProvider class
Declaration Syntax
C#
public abstract class SiteProvider : ProviderBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteProvider()()() | Initializes a new instance of the SiteProvider class
 | CanEnter(Site, Account) | Determines whether an account can enter the specified site.
 | CheckSecurity | Gets a value indicating whether to check security (usually the site:enter right).
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSite(String) | Gets a site.
 | GetSites()()() | Gets the list of all known sites.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(String, NameValueCollection) | Initializes the provider. (Overrides ProviderBase.Initialize(String, NameValueCollection).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | SiteProvider
 |  |  | ConfigSiteProvider


SiteProvider Constructor

SiteProvider Constructor
Namespaces ► Sitecore.Sites ► SiteProvider ► SiteProvider()()()
Initializes a new instance of the SiteProvider class
Declaration Syntax
C#
protected SiteProvider()


CanEnter Method (site, account)

CanEnter Method (site, account)
Namespaces ► Sitecore.Sites ► SiteProvider ► CanEnter(Site, Account)
Determines whether an account can enter the specified site.
Declaration Syntax
C#
public virtual bool CanEnter(
    Site site,
    Account account
)
Parameters
site (Site)
The site.
account (Account)
The account.
Return Value
true if the account can enter the specified site; otherwise, false.


CheckSecurity Property

CheckSecurity Property
Namespaces ► Sitecore.Sites ► SiteProvider ► CheckSecurity
Gets a value indicating whether to check security (usually the site:enter right).
Declaration Syntax
C#
public virtual bool CheckSecurity { get; }
Value
true if check security; otherwise, false.


GetSite Method (siteName)

GetSite Method (siteName)
Namespaces ► Sitecore.Sites ► SiteProvider ► GetSite(String)
Gets a site.
Declaration Syntax
C#
public abstract Site GetSite(
    string siteName
)
Parameters
siteName (String)
Name of the site.
Return Value


GetSites Method

GetSites Method
Namespaces ► Sitecore.Sites ► SiteProvider ► GetSites()()()
Gets the list of all known sites.
Declaration Syntax
C#
public abstract SiteCollection GetSites()
Return Value


Initialize Method (name, config)

Initialize Method (name, config)
Namespaces ► Sitecore.Sites ► SiteProvider ► Initialize(String, NameValueCollection)
Initializes the provider.
Declaration Syntax
C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Parameters
name (String)
The friendly name of the provider.
config (NameValueCollection)
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.
Exceptions
Exception | Condition
ArgumentNullException | The name of the provider is null.
ArgumentException | The name of the provider has a length of zero.
InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.


SiteProviderCollection Class

SiteProviderCollection Class
Namespaces ► Sitecore.Sites ► SiteProviderCollection
SiteProviderCollection class
Declaration Syntax
C#
public class SiteProviderCollection : ProviderCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteProviderCollection()()() | Initializes a new instance of the SiteProviderCollection class
 | Add(ProviderBase) | Adds a provider to the collection. (Inherited from ProviderCollection.)
 | Clear()()() | Removes all items from the collection. (Inherited from ProviderCollection.)
 | CopyTo(array<ProviderBase>[]()[], Int32) | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
 | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
 | Item[([(String])]) | Gets the SiteProvider with the specified name.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a provider from the collection. (Inherited from ProviderCollection.)
 | SetReadOnly()()() | Sets the collection to be read-only. (Inherited from ProviderCollection.)
 | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderCollection
 |  | SiteProviderCollection


SiteProviderCollection Constructor

SiteProviderCollection Constructor
Namespaces ► Sitecore.Sites ► SiteProviderCollection ► SiteProviderCollection()()()
Initializes a new instance of the SiteProviderCollection class
Declaration Syntax
C#
public SiteProviderCollection()


Item Property (name)

Item Property (name)
Namespaces ► Sitecore.Sites ► SiteProviderCollection ► Item[([(String])])
Gets the SiteProvider with the specified name.
Declaration Syntax
C#
public SiteProvider this[
    string name
] { get; }
Parameters
name (String)
Value


SiteRequest Class

SiteRequest Class
Namespaces ► Sitecore.Sites ► SiteRequest
Represents a SiteRequest.
Declaration Syntax
C#
public class SiteRequest
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteRequest(SiteContext) | Initializes a new instance of the SiteRequest class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath | Gets or sets the file path.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCookie(String) | Gets the cookie.
 | GetCookie(String, String) | Gets the cookie.
 | GetCookieDate(String, DateTime) | Gets the cookie date.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetQueryString(String) | Gets the query string.
 | GetQueryString(String, String) | Gets the query string.
 | GetQueryStringOrCookie(String) | Gets the query string or cookie.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemPath | Gets or sets the item path.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | QueryString | Gets the query string.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SiteRequest


SiteRequest Constructor (siteContext)

SiteRequest Constructor (siteContext)
Namespaces ► Sitecore.Sites ► SiteRequest ► SiteRequest(SiteContext)
Initializes a new instance of the SiteRequest class.
Declaration Syntax
C#
public SiteRequest(
    SiteContext siteContext
)
Parameters
siteContext (SiteContext)
The site context.


FilePath Property

FilePath Property
Namespaces ► Sitecore.Sites ► SiteRequest ► FilePath
Gets or sets the file path.
Declaration Syntax
C#
public string FilePath { get; set; }
Value
The file path.


GetCookie Method

GetCookie Method
Namespaces ► Sitecore.Sites ► SiteRequest ► GetCookie()()()
Members
Icon | Member | Description
 | GetCookie(String) | Gets the cookie.
 | GetCookie(String, String) | Gets the cookie.


GetCookie Method (name)

GetCookie Method (name)
Namespaces ► Sitecore.Sites ► SiteRequest ► GetCookie(String)
Gets the cookie.
Declaration Syntax
C#
public string GetCookie(
    string name
)
Parameters
name (String)
The name.
Return Value


GetCookie Method (name, defaultValue)

GetCookie Method (name, defaultValue)
Namespaces ► Sitecore.Sites ► SiteRequest ► GetCookie(String, String)
Gets the cookie.
Declaration Syntax
C#
public string GetCookie(
    string name,
    string defaultValue
)
Parameters
name (String)
The name.
defaultValue (String)
The default value.
Return Value


GetCookieDate Method (name, defaultValue)

GetCookieDate Method (name, defaultValue)
Namespaces ► Sitecore.Sites ► SiteRequest ► GetCookieDate(String, DateTime)
Gets the cookie date.
Declaration Syntax
C#
public DateTime GetCookieDate(
    string name,
    DateTime defaultValue
)
Parameters
name (String)
The name.
defaultValue (DateTime)
The default value.
Return Value


GetQueryString Method

GetQueryString Method
Namespaces ► Sitecore.Sites ► SiteRequest ► GetQueryString()()()
Members
Icon | Member | Description
 | GetQueryString(String) | Gets the query string.
 | GetQueryString(String, String) | Gets the query string.


GetQueryString Method (name)

GetQueryString Method (name)
Namespaces ► Sitecore.Sites ► SiteRequest ► GetQueryString(String)
Gets the query string.
Declaration Syntax
C#
public string GetQueryString(
    string name
)
Parameters
name (String)
The name.
Return Value


GetQueryString Method (name, defaultValue)

GetQueryString Method (name, defaultValue)
Namespaces ► Sitecore.Sites ► SiteRequest ► GetQueryString(String, String)
Gets the query string.
Declaration Syntax
C#
public string GetQueryString(
    string name,
    string defaultValue
)
Parameters
name (String)
The name.
defaultValue (String)
The default value.
Return Value


GetQueryStringOrCookie Method (key)

GetQueryStringOrCookie Method (key)
Namespaces ► Sitecore.Sites ► SiteRequest ► GetQueryStringOrCookie(String)
Gets the query string or cookie.
Declaration Syntax
C#
public string GetQueryStringOrCookie(
    string key
)
Parameters
key (String)
The key.
Return Value


ItemPath Property

ItemPath Property
Namespaces ► Sitecore.Sites ► SiteRequest ► ItemPath
Gets or sets the item path.
Declaration Syntax
C#
public string ItemPath { get; set; }
Value
The item path.


QueryString Property

QueryString Property
Namespaces ► Sitecore.Sites ► SiteRequest ► QueryString
Gets the query string.
Declaration Syntax
C#
public NameValueCollection QueryString { get; }
Value
The query string.


SiteResponse Class

SiteResponse Class
Namespaces ► Sitecore.Sites ► SiteResponse
Represents a SiteResponse.
Declaration Syntax
C#
public class SiteResponse
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteResponse(SiteContext) | Initializes a new instance of the SiteResponse class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Page | Gets the page.
 | SetCookie(String, String) | Sets the cookie.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Write(String) | Writes the specified text.
 | WriteLine(String) | Writes the line.
Inheritance Hierarchy
Object
SiteResponse


SiteResponse Constructor (siteContext)

SiteResponse Constructor (siteContext)
Namespaces ► Sitecore.Sites ► SiteResponse ► SiteResponse(SiteContext)
Initializes a new instance of the SiteResponse class.
Declaration Syntax
C#
public SiteResponse(
    SiteContext siteContext
)
Parameters
siteContext (SiteContext)
The site context.


Page Property

Page Property
Namespaces ► Sitecore.Sites ► SiteResponse ► Page
Gets the page.
Declaration Syntax
C#
public Page Page { get; }
Value
The page.


SetCookie Method (name, value)

SetCookie Method (name, value)
Namespaces ► Sitecore.Sites ► SiteResponse ► SetCookie(String, String)
Sets the cookie.
Declaration Syntax
C#
public void SetCookie(
    string name,
    string value
)
Parameters
name (String)
The name.
value (String)
The value.


Write Method (text)

Write Method (text)
Namespaces ► Sitecore.Sites ► SiteResponse ► Write(String)
Writes the specified text.
Declaration Syntax
C#
public void Write(
    string text
)
Parameters
text (String)
The text.


WriteLine Method (text)

WriteLine Method (text)
Namespaces ► Sitecore.Sites ► SiteResponse ► WriteLine(String)
Writes the line.
Declaration Syntax
C#
public void WriteLine(
    string text
)
Parameters
text (String)
The text.


Sitecore.Sites.Rendering Namespace

Sitecore.Sites.Rendering Namespace
Namespaces ► Sitecore.Sites.Rendering
Declaration Syntax
C#
namespace Sitecore.Sites.Rendering
Types
All Types Classes
Icon | Type | Description
 | Layout | Represents a Layout.
 | LayoutFactory | Factory for accessing layout definitions.
 | RenderingFactory | Factory for accessing rendering definitions.


Layout Class

Layout Class
Namespaces ► Sitecore.Sites.Rendering ► Layout
Represents a Layout.
Declaration Syntax
C#
public class Layout
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Layout(String) | Initializes a new instance of the Layout class.
 | Layout(String, Control) | Initializes a new instance of the Layout class.
 | AddControlsFromItem(Page, Item) | Expand layout.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExpandSublayout(Control) | Expands sublayouts to real user controls.
 | File | Gets the file.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Owner | Gets or sets the owner.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Layout


Layout Constructor

Layout Constructor
Namespaces ► Sitecore.Sites.Rendering ► Layout ► Layout()()()
Members
Icon | Member | Description
 | Layout(String) | Initializes a new instance of the Layout class.
 | Layout(String, Control) | Initializes a new instance of the Layout class.


Layout Constructor (file)

Layout Constructor (file)
Namespaces ► Sitecore.Sites.Rendering ► Layout ► Layout(String)
Initializes a new instance of the Layout class.
Declaration Syntax
C#
public Layout(
    string file
)
Parameters
file (String)
The file.


Layout Constructor (file, owner)

Layout Constructor (file, owner)
Namespaces ► Sitecore.Sites.Rendering ► Layout ► Layout(String, Control)
Initializes a new instance of the Layout class.
Declaration Syntax
C#
public Layout(
    string file,
    Control owner
)
Parameters
file (String)
The file.
owner (Control)
The owner.


AddControlsFromItem Method (page, item)

AddControlsFromItem Method (page, item)
Namespaces ► Sitecore.Sites.Rendering ► Layout ► AddControlsFromItem(Page, Item)
Expand layout.
Declaration Syntax
C#
public void AddControlsFromItem(
    Page page,
    Item item
)
Parameters
page (Page)
The page.
item (Item)
The item.


ExpandSublayout Method (sublayout)

ExpandSublayout Method (sublayout)
Namespaces ► Sitecore.Sites.Rendering ► Layout ► ExpandSublayout(Control)
Expands sublayouts to real user controls.
Declaration Syntax
C#
public void ExpandSublayout(
    Control sublayout
)
Parameters
sublayout (Control)
The sublayout.


File Property

File Property
Namespaces ► Sitecore.Sites.Rendering ► Layout ► File
Gets the file.
Declaration Syntax
C#
public string File { get; }
Value
The file.


Owner Property

Owner Property
Namespaces ► Sitecore.Sites.Rendering ► Layout ► Owner
Gets or sets the owner.
Declaration Syntax
C#
public Control Owner { get; set; }
Value
The owner.


LayoutFactory Class

LayoutFactory Class
Namespaces ► Sitecore.Sites.Rendering ► LayoutFactory
Factory for accessing layout definitions.
Declaration Syntax
C#
public static class LayoutFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetLayout(String) | Gets the layout.
 | GetLayout(Item, Boolean) | Gets the layout.
 | GetLayoutDefinition(Item) | Get layout definition node for an item
 | GetLoginLayout()()() | Get path to login page..
Inheritance Hierarchy
Object
LayoutFactory


GetLayout Method

GetLayout Method
Namespaces ► Sitecore.Sites.Rendering ► LayoutFactory ► GetLayout()()()
Members
Icon | Member | Description
 | GetLayout(String) | Gets the layout.
 | GetLayout(Item, Boolean) | Gets the layout.


GetLayout Method (item, useDefaultLayout)

GetLayout Method (item, useDefaultLayout)
Namespaces ► Sitecore.Sites.Rendering ► LayoutFactory ► GetLayout(Item, Boolean)
Gets the layout.
Declaration Syntax
C#
public static Layout GetLayout(
    Item item,
    bool useDefaultLayout
)
Parameters
item (Item)
The item.
useDefaultLayout (Boolean)
if set to true this instance is use default layout.
Return Value


GetLayout Method (file)

GetLayout Method (file)
Namespaces ► Sitecore.Sites.Rendering ► LayoutFactory ► GetLayout(String)
Gets the layout.
Declaration Syntax
C#
public static Layout GetLayout(
    string file
)
Parameters
file (String)
The file.
Return Value


GetLayoutDefinition Method (itm)

GetLayoutDefinition Method (itm)
Namespaces ► Sitecore.Sites.Rendering ► LayoutFactory ► GetLayoutDefinition(Item)
Get layout definition node for an item
Declaration Syntax
C#
public static XmlNode GetLayoutDefinition(
    Item itm
)
Parameters
itm (Item)
The itm.
Return Value


GetLoginLayout Method

GetLoginLayout Method
Namespaces ► Sitecore.Sites.Rendering ► LayoutFactory ► GetLoginLayout()()()
Get path to login page..
Declaration Syntax
C#
public static Layout GetLoginLayout()
Return Value


RenderingFactory Class

RenderingFactory Class
Namespaces ► Sitecore.Sites.Rendering ► RenderingFactory
Factory for accessing rendering definitions.
Declaration Syntax
C#
public static class RenderingFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetItemControl(Item) | Gets the control used for rendering an item.
 | GetItemControl(Item, String) | Gets the control used for rendering an item.
Inheritance Hierarchy
Object
RenderingFactory


GetItemControl Method

GetItemControl Method
Namespaces ► Sitecore.Sites.Rendering ► RenderingFactory ► GetItemControl()()()
Members
Icon | Member | Description
 | GetItemControl(Item) | Gets the control used for rendering an item.
 | GetItemControl(Item, String) | Gets the control used for rendering an item.


GetItemControl Method (item)

GetItemControl Method (item)
Namespaces ► Sitecore.Sites.Rendering ► RenderingFactory ► GetItemControl(Item)
Gets the control used for rendering an item.
Declaration Syntax
C#
public static Control GetItemControl(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetItemControl Method (item, datasource)

GetItemControl Method (item, datasource)
Namespaces ► Sitecore.Sites.Rendering ► RenderingFactory ► GetItemControl(Item, String)
Gets the control used for rendering an item.
Declaration Syntax
C#
public static Control GetItemControl(
    Item item,
    string datasource
)
Parameters
item (Item)
The item.
datasource (String)
The datasource.
Return Value


Sitecore.StringExtensions Namespace

Sitecore.StringExtensions Namespace
Namespaces ► Sitecore.StringExtensions
Declaration Syntax
C#
namespace Sitecore.StringExtensions
Types
All Types Classes
Icon | Type | Description
 | StringExtensions | StringExtensions class


StringExtensions Class

StringExtensions Class
Namespaces ► Sitecore.StringExtensions ► StringExtensions
StringExtensions class
Declaration Syntax
C#
public static class StringExtensions
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FormatWith(String, array<Object>[]()[]) | Replaces the format item in a specified string with the text equivalent of the value of a corresponding Object instance in a specified array.
 | IsNullOrEmpty(String) | Determines whether the specified STR is null or empty.
 | StartsWith(String, String, Boolean) | Determines whether beginning of this string mathces the specified string.
Inheritance Hierarchy
Object
StringExtensions


FormatWith Method (format, parameters)

FormatWith Method (format, parameters)
Namespaces ► Sitecore.StringExtensions ► StringExtensions ► FormatWith(String, array<Object>[]()[])
Replaces the format item in a specified string with the text equivalent of the value of a corresponding Object instance in a specified array.
Declaration Syntax
C#
public static string FormatWith(
    string format,
    params Object[] parameters
)
Parameters
format (String)
The format.
parameters (array< Object >[]()[])
The parameters.
Return Value


IsNullOrEmpty Method (string)

IsNullOrEmpty Method (string)
Namespaces ► Sitecore.StringExtensions ► StringExtensions ► IsNullOrEmpty(String)
Determines whether the specified STR is null or empty.
Declaration Syntax
C#
public static bool IsNullOrEmpty(
    string string
)
Parameters
string (String)
The string.
Return Value
true if the specified STR is null or empty; otherwise, false.


StartsWith Method (str, value, ignoreCase)

StartsWith Method (str, value, ignoreCase)
Namespaces ► Sitecore.StringExtensions ► StringExtensions ► StartsWith(String, String, Boolean)
Determines whether beginning of this string mathces the specified string.
Declaration Syntax
C#
public static bool StartsWith(
    string str,
    string value,
    bool ignoreCase
)
Parameters
str (String)
"this" object.
value (String)
The value.
ignoreCase (Boolean)
if set to true case will be ignored.
Return Value


Sitecore.Tasks Namespace

Sitecore.Tasks Namespace
Namespaces ► Sitecore.Tasks
Declaration Syntax
C#
namespace Sitecore.Tasks
Types
All Types Classes
Icon | Type | Description
 | Scheduler..::.Agent | Represents an Agent.
 | ArchiveTask | Represents a Archive task.
 | CleanupAgent | Represents the Cleanup agent.
 | CleanupHistory | Represents a CompactClientData agent.
 | CleanupPublishQueue | CleanupPublishQueue class
 | CommandItem | Represents a Command item.
 | CompactClientDataAgent | Represents a CompactClientData agent.
 | CounterDumpAgent | Represents a CounterDump agent.
 | DatabaseAgent | Represents a Database agent.
 | EmailReminderTask | Sends an email when the reminder triggers.
 | FileCleaner | Wrapper for file cleaner
 | HtmlCacheClearAgent | Represents a HtmlCacheClear agent.
 | ItemEventHandler | Represents a ItemEvent handler.
 | PublishAgent | Represents a Publish agent.
 | Recurrence | Represents Recurrence.
 | ScheduleField | Represents a Schedule field.
 | ScheduleItem | Represents a Schedule item.
 | Scheduler | Represents the Scheduler.
 | Status | Represents the Status of a task.
 | Task | Defines the basic properties and functionality of a task.
 | TaskContext | Represents a TaskContext.
 | TaskDatabase | Defines the basic methods of a database that supports tasks.
 | TaskDatabaseAgent | Represents a TaskDatabase agent.
 | UrlAgent | Represents a UrlAgent.


ArchiveTask Class

ArchiveTask Class
Namespaces ► Sitecore.Tasks ► ArchiveTask
Represents a Archive task.
Declaration Syntax
C#
public class ArchiveTask : Task
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveTask(DateTime) | Initializes a new instance of the ArchiveTask class.
 | DatabaseName | Gets or sets the name of the database. (Inherited from Task.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes this task. (Overrides Task.Execute()()().)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from Task.)
 | GetNextRecurrence()()() | Gets the next recurrence. (Inherited from Task.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the ID. (Inherited from Task.)
 | ItemID | Gets or sets the item ID. (Inherited from Task.)
 | LogActivity | Gets or sets a value indicating whether the Task logs the activity. (Inherited from Task.)
 | LogError(String) | Logs the error. (Inherited from Task.)
 | LogInfo(String) | Logs the info. (Inherited from Task.)
 | LogWarn(String) | Logs the warning. (Inherited from Task.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets or sets the parameters. (Inherited from Task.)
 | RecurrencePattern | Gets or sets the recurrence pattern. (Inherited from Task.)
 | TaskDate | Gets or sets the task date. (Inherited from Task.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Task
 |  | ArchiveTask


ArchiveTask Constructor (taskDate)

ArchiveTask Constructor (taskDate)
Namespaces ► Sitecore.Tasks ► ArchiveTask ► ArchiveTask(DateTime)
Initializes a new instance of the ArchiveTask class.
Declaration Syntax
C#
public ArchiveTask(
    DateTime taskDate
)
Parameters
taskDate (DateTime)
The task date.


Execute Method

Execute Method
Namespaces ► Sitecore.Tasks ► ArchiveTask ► Execute()()()
Executes this task.
Declaration Syntax
C#
public override void Execute()


CleanupAgent Class

CleanupAgent Class
Namespaces ► Sitecore.Tasks ► CleanupAgent
Represents the Cleanup agent.
Declaration Syntax
C#
public class CleanupAgent
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CleanupAgent()()() | Initializes a new instance of the CleanupAgent class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LogActivity | Gets or sets a value indicating whether the CleanupAgent logs the activity.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run()()() | Runs the pipeline.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CleanupAgent


CleanupAgent Constructor

CleanupAgent Constructor
Namespaces ► Sitecore.Tasks ► CleanupAgent ► CleanupAgent()()()
Initializes a new instance of the CleanupAgent class
Declaration Syntax
C#
public CleanupAgent()


LogActivity Property

LogActivity Property
Namespaces ► Sitecore.Tasks ► CleanupAgent ► LogActivity
Gets or sets a value indicating whether the CleanupAgent logs the activity.
Declaration Syntax
C#
public bool LogActivity { get; set; }
Value
true if the CleanupAgent logs the activity; otherwise, false.


Run Method

Run Method
Namespaces ► Sitecore.Tasks ► CleanupAgent ► Run()()()
Runs the pipeline.
Declaration Syntax
C#
public void Run()


CleanupHistory Class

CleanupHistory Class
Namespaces ► Sitecore.Tasks ► CleanupHistory
Represents a CompactClientData agent.
Declaration Syntax
C#
public class CleanupHistory
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CleanupHistory()()() | Initializes a new instance of the CleanupHistory class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run()()() | Runs the pipeline.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CleanupHistory


CleanupHistory Constructor

CleanupHistory Constructor
Namespaces ► Sitecore.Tasks ► CleanupHistory ► CleanupHistory()()()
Initializes a new instance of the CleanupHistory class
Declaration Syntax
C#
public CleanupHistory()


Run Method

Run Method
Namespaces ► Sitecore.Tasks ► CleanupHistory ► Run()()()
Runs the pipeline.
Declaration Syntax
C#
public void Run()


CleanupPublishQueue Class

CleanupPublishQueue Class
Namespaces ► Sitecore.Tasks ► CleanupPublishQueue
CleanupPublishQueue class
Declaration Syntax
C#
public class CleanupPublishQueue
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CleanupPublishQueue()()() | Initializes a new instance of the CleanupPublishQueue class
 | DaysToKeep | Gets or sets the days to keep old data (zero means indefinitely).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run()()() | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CleanupPublishQueue


CleanupPublishQueue Constructor

CleanupPublishQueue Constructor
Namespaces ► Sitecore.Tasks ► CleanupPublishQueue ► CleanupPublishQueue()()()
Initializes a new instance of the CleanupPublishQueue class
Declaration Syntax
C#
public CleanupPublishQueue()


DaysToKeep Property

DaysToKeep Property
Namespaces ► Sitecore.Tasks ► CleanupPublishQueue ► DaysToKeep
Gets or sets the days to keep old data (zero means indefinitely).
Declaration Syntax
C#
public int DaysToKeep { get; set; }
Value
The days to keep.


Run Method

Run Method
Namespaces ► Sitecore.Tasks ► CleanupPublishQueue ► Run()()()
Runs the processor.
Declaration Syntax
C#
public void Run()


CommandItem Class

CommandItem Class
Namespaces ► Sitecore.Tasks ► CommandItem
Represents a Command item.
Declaration Syntax
C#
public class CommandItem : CustomItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandItem(Item) | Initializes a new instance of the CommandItem class.
 | BeginEdit()()() | Begins editing the item. (Inherited from CustomItemBase.)
 | Database | Gets the database. (Inherited from CustomItemBase.)
 | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
 | EndEdit()()() | Ends editing the item. (Inherited from CustomItemBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(array<Item>[]()[], ScheduleItem) | Executes the specified items.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets the icon. (Inherited from CustomItemBase.)
 | ID | Gets the ID. (Inherited from CustomItemBase.)
 | Implicit(Item) | Implements an implicit conversion operator.
 | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
 | Item[([(ID])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
 | Item[([(Int32])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
 | Item[([(String])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomItemBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomItemBase
 |  | CustomItem
 |  |  | CommandItem


CommandItem Constructor (innerItem)

CommandItem Constructor (innerItem)
Namespaces ► Sitecore.Tasks ► CommandItem ► CommandItem(Item)
Initializes a new instance of the CommandItem class.
Declaration Syntax
C#
public CommandItem(
    Item innerItem
)
Parameters
innerItem (Item)
Inner item.


Execute Method (items, schedule)

Execute Method (items, schedule)
Namespaces ► Sitecore.Tasks ► CommandItem ► Execute(array<Item>[]()[], ScheduleItem)
Executes the specified items.
Declaration Syntax
C#
public void Execute(
    Item[] items,
    ScheduleItem schedule
)
Parameters
items (array< Item >[]()[])
The items.
schedule (ScheduleItem)
The schedule.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Tasks ► CommandItem ► Implicit(Item)
Implements an implicit conversion operator.
Declaration Syntax
C#
public static implicit operator CommandItem (
    Item item
)
Parameters
item (Item)
The item.
Return Value


CompactClientDataAgent Class

CompactClientDataAgent Class
Namespaces ► Sitecore.Tasks ► CompactClientDataAgent
Represents a CompactClientData agent.
Declaration Syntax
C#
public class CompactClientDataAgent
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CompactClientDataAgent()()() | Initializes a new instance of the CompactClientDataAgent class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run()()() | Runs the pipeline.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CompactClientDataAgent


CompactClientDataAgent Constructor

CompactClientDataAgent Constructor
Namespaces ► Sitecore.Tasks ► CompactClientDataAgent ► CompactClientDataAgent()()()
Initializes a new instance of the CompactClientDataAgent class
Declaration Syntax
C#
public CompactClientDataAgent()


Run Method

Run Method
Namespaces ► Sitecore.Tasks ► CompactClientDataAgent ► Run()()()
Runs the pipeline.
Declaration Syntax
C#
public void Run()


CounterDumpAgent Class

CounterDumpAgent Class
Namespaces ► Sitecore.Tasks ► CounterDumpAgent
Represents a CounterDump agent.
Declaration Syntax
C#
public class CounterDumpAgent
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CounterDumpAgent()()() | Constructs an instance of CounterDumpAgent.
 | DumpFile | Gets or sets the file name used for dumping the counter data.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run()()() | Agent used for clearing HTML caches.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CounterDumpAgent


CounterDumpAgent Constructor

CounterDumpAgent Constructor
Namespaces ► Sitecore.Tasks ► CounterDumpAgent ► CounterDumpAgent()()()
Constructs an instance of CounterDumpAgent.
Declaration Syntax
C#
public CounterDumpAgent()


DumpFile Property

DumpFile Property
Namespaces ► Sitecore.Tasks ► CounterDumpAgent ► DumpFile
Gets or sets the file name used for dumping the counter data.
Declaration Syntax
C#
public string DumpFile { get; set; }
Value
The dump file.


Run Method

Run Method
Namespaces ► Sitecore.Tasks ► CounterDumpAgent ► Run()()()
Agent used for clearing HTML caches.
Declaration Syntax
C#
public void Run()


DatabaseAgent Class

DatabaseAgent Class
Namespaces ► Sitecore.Tasks ► DatabaseAgent
Represents a Database agent.
Declaration Syntax
C#
public class DatabaseAgent
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatabaseAgent(String, String) | Initializes a new instance of the DatabaseAgent class.
 | Database | Gets the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LogActivity | Gets or sets a value indicating whether the DatabaseAgent logs the activity.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run()()() | Runs the pipeline.
 | ScheduleRoot | Gets the schedule root.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DatabaseAgent


DatabaseAgent Constructor (databaseName, scheduleRoot)

DatabaseAgent Constructor (databaseName, scheduleRoot)
Namespaces ► Sitecore.Tasks ► DatabaseAgent ► DatabaseAgent(String, String)
Initializes a new instance of the DatabaseAgent class.
Declaration Syntax
C#
public DatabaseAgent(
    string databaseName,
    string scheduleRoot
)
Parameters
databaseName (String)
Name of the database.
scheduleRoot (String)
The schedule root.


Database Property

Database Property
Namespaces ► Sitecore.Tasks ► DatabaseAgent ► Database
Gets the database.
Declaration Syntax
C#
public Database Database { get; }
Value
The database.


LogActivity Property

LogActivity Property
Namespaces ► Sitecore.Tasks ► DatabaseAgent ► LogActivity
Gets or sets a value indicating whether the DatabaseAgent logs the activity.
Declaration Syntax
C#
public bool LogActivity { get; set; }
Value
true if the DatabaseAgent logs the activity; otherwise, false.


Run Method

Run Method
Namespaces ► Sitecore.Tasks ► DatabaseAgent ► Run()()()
Runs the pipeline.
Declaration Syntax
C#
public void Run()


ScheduleRoot Property

ScheduleRoot Property
Namespaces ► Sitecore.Tasks ► DatabaseAgent ► ScheduleRoot
Gets the schedule root.
Declaration Syntax
C#
public string ScheduleRoot { get; }
Value
The schedule root.


EmailReminderTask Class

EmailReminderTask Class
Namespaces ► Sitecore.Tasks ► EmailReminderTask
Sends an email when the reminder triggers.
Declaration Syntax
C#
public class EmailReminderTask : Task
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EmailReminderTask(DateTime) | Initializes a new instance of the EmailReminderTask class.
 | DatabaseName | Gets or sets the name of the database. (Inherited from Task.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes this task. (Overrides Task.Execute()()().)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from Task.)
 | GetNextRecurrence()()() | Gets the next recurrence. (Inherited from Task.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the ID. (Inherited from Task.)
 | ItemID | Gets or sets the item ID. (Inherited from Task.)
 | LogActivity | Gets or sets a value indicating whether the Task logs the activity. (Inherited from Task.)
 | LogError(String) | Logs the error. (Inherited from Task.)
 | LogInfo(String) | Logs the info. (Inherited from Task.)
 | LogWarn(String) | Logs the warning. (Inherited from Task.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets or sets the parameters. (Inherited from Task.)
 | RecurrencePattern | Gets or sets the recurrence pattern. (Inherited from Task.)
 | TaskDate | Gets or sets the task date. (Inherited from Task.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Task
 |  | EmailReminderTask


EmailReminderTask Constructor (taskDate)

EmailReminderTask Constructor (taskDate)
Namespaces ► Sitecore.Tasks ► EmailReminderTask ► EmailReminderTask(DateTime)
Initializes a new instance of the EmailReminderTask class.
Declaration Syntax
C#
public EmailReminderTask(
    DateTime taskDate
)
Parameters
taskDate (DateTime)


Execute Method

Execute Method
Namespaces ► Sitecore.Tasks ► EmailReminderTask ► Execute()()()
Executes this task.
Declaration Syntax
C#
public override void Execute()


FileCleaner Class

FileCleaner Class
Namespaces ► Sitecore.Tasks ► FileCleaner
Wrapper for file cleaner
Declaration Syntax
C#
public class FileCleaner
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileCleaner(XmlNode) | Initializes a new instance of the FileCleaner class.
 | Active | Check if handler is active
 | AddFileToGroup(FileInfo, String, Hashtable) | Add file to group slot
 | CleanupGroups(Hashtable) | Cleanup file groups
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Execute cleanup operation
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Folder | Gets the folder.
 | GetCandidateFiles(DirectoryInfo) | Execute rolling cleanup operation
 | GetFileAge(FileInfo) | Get file age (time since last write or creation)
 | GetFileTime(FileInfo) | Get file time (max of last write and created)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSlotCounts(String) | Get allowed file count for each time slot in rolling cleanups
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Get handler name
 | ReportDeletion(FileInfo, String) | Report deletion (and reason for cleanup)
 | RollingCleanup()()() | Execute rolling cleanup operation
 | SimpleCleanup()()() | Execute simple cleanup operation
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FileCleaner


FileCleaner Constructor (configNode)

FileCleaner Constructor (configNode)
Namespaces ► Sitecore.Tasks ► FileCleaner ► FileCleaner(XmlNode)
Initializes a new instance of the FileCleaner class.
Declaration Syntax
C#
public FileCleaner(
    XmlNode configNode
)
Parameters
configNode (XmlNode)
The config node.


Active Property

Active Property
Namespaces ► Sitecore.Tasks ► FileCleaner ► Active
Check if handler is active
Declaration Syntax
C#
public bool Active { get; }
Value
true if active; otherwise, false.


AddFileToGroup Method (file, groupName, fileGroups)

AddFileToGroup Method (file, groupName, fileGroups)
Namespaces ► Sitecore.Tasks ► FileCleaner ► AddFileToGroup(FileInfo, String, Hashtable)
Add file to group slot
Declaration Syntax
C#
public void AddFileToGroup(
    FileInfo file,
    string groupName,
    Hashtable fileGroups
)
Parameters
file (FileInfo)
The file.
groupName (String)
Name of the group.
fileGroups (Hashtable)
The file groups.


CleanupGroups Method (fileGroups)

CleanupGroups Method (fileGroups)
Namespaces ► Sitecore.Tasks ► FileCleaner ► CleanupGroups(Hashtable)
Cleanup file groups
Declaration Syntax
C#
public void CleanupGroups(
    Hashtable fileGroups
)
Parameters
fileGroups (Hashtable)
The file groups.


Execute Method

Execute Method
Namespaces ► Sitecore.Tasks ► FileCleaner ► Execute()()()
Execute cleanup operation
Declaration Syntax
C#
public void Execute()


Folder Property

Folder Property
Namespaces ► Sitecore.Tasks ► FileCleaner ► Folder
Gets the folder.
Declaration Syntax
C#
public string Folder { get; }
Value
The folder.


GetCandidateFiles Method (folder)

GetCandidateFiles Method (folder)
Namespaces ► Sitecore.Tasks ► FileCleaner ► GetCandidateFiles(DirectoryInfo)
Execute rolling cleanup operation
Declaration Syntax
C#
public SortedList GetCandidateFiles(
    DirectoryInfo folder
)
Parameters
folder (DirectoryInfo)
The folder.
Return Value


GetFileAge Method (file)

GetFileAge Method (file)
Namespaces ► Sitecore.Tasks ► FileCleaner ► GetFileAge(FileInfo)
Get file age (time since last write or creation)
Declaration Syntax
C#
public TimeSpan GetFileAge(
    FileInfo file
)
Parameters
file (FileInfo)
The file.
Return Value


GetFileTime Method (file)

GetFileTime Method (file)
Namespaces ► Sitecore.Tasks ► FileCleaner ► GetFileTime(FileInfo)
Get file time (max of last write and created)
Declaration Syntax
C#
public DateTime GetFileTime(
    FileInfo file
)
Parameters
file (FileInfo)
The file.
Return Value


GetSlotCounts Method (strategy)

GetSlotCounts Method (strategy)
Namespaces ► Sitecore.Tasks ► FileCleaner ► GetSlotCounts(String)
Get allowed file count for each time slot in rolling cleanups
Declaration Syntax
C#
public Hashtable GetSlotCounts(
    string strategy
)
Parameters
strategy (String)
The strategy.
Return Value


Name Property

Name Property
Namespaces ► Sitecore.Tasks ► FileCleaner ► Name
Get handler name
Declaration Syntax
C#
public string Name { get; }
Value
The name.


ReportDeletion Method (file, reason)

ReportDeletion Method (file, reason)
Namespaces ► Sitecore.Tasks ► FileCleaner ► ReportDeletion(FileInfo, String)
Report deletion (and reason for cleanup)
Declaration Syntax
C#
public void ReportDeletion(
    FileInfo file,
    string reason
)
Parameters
file (FileInfo)
The file.
reason (String)
The reason.


RollingCleanup Method

RollingCleanup Method
Namespaces ► Sitecore.Tasks ► FileCleaner ► RollingCleanup()()()
Execute rolling cleanup operation
Declaration Syntax
C#
public void RollingCleanup()


SimpleCleanup Method

SimpleCleanup Method
Namespaces ► Sitecore.Tasks ► FileCleaner ► SimpleCleanup()()()
Execute simple cleanup operation
Declaration Syntax
C#
public void SimpleCleanup()


HtmlCacheClearAgent Class

HtmlCacheClearAgent Class
Namespaces ► Sitecore.Tasks ► HtmlCacheClearAgent
Represents a HtmlCacheClear agent.
Declaration Syntax
C#
public class HtmlCacheClearAgent
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HtmlCacheClearAgent()()() | Initializes a new instance of the HtmlCacheClearAgent class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run()()() | Agent used for clearing HTML caches.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HtmlCacheClearAgent


HtmlCacheClearAgent Constructor

HtmlCacheClearAgent Constructor
Namespaces ► Sitecore.Tasks ► HtmlCacheClearAgent ► HtmlCacheClearAgent()()()
Initializes a new instance of the HtmlCacheClearAgent class
Declaration Syntax
C#
public HtmlCacheClearAgent()


Run Method

Run Method
Namespaces ► Sitecore.Tasks ► HtmlCacheClearAgent ► Run()()()
Agent used for clearing HTML caches.
Declaration Syntax
C#
public void Run()


ItemEventHandler Class

ItemEventHandler Class
Namespaces ► Sitecore.Tasks ► ItemEventHandler
Represents a ItemEvent handler.
Declaration Syntax
C#
public class ItemEventHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemEventHandler()()() | Initializes a new instance of the ItemEventHandler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnItemCopied(Object, EventArgs) | Called when an item has been copied.
 | OnItemDeleted(Object, EventArgs) | Called when the item has been deleted.
 | OnItemSaved(Object, EventArgs) | Called when the item has been saved.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemEventHandler


ItemEventHandler Constructor

ItemEventHandler Constructor
Namespaces ► Sitecore.Tasks ► ItemEventHandler ► ItemEventHandler()()()
Initializes a new instance of the ItemEventHandler class
Declaration Syntax
C#
public ItemEventHandler()


OnItemCopied Method (sender, args)

OnItemCopied Method (sender, args)
Namespaces ► Sitecore.Tasks ► ItemEventHandler ► OnItemCopied(Object, EventArgs)
Called when an item has been copied.
Declaration Syntax
C#
protected void OnItemCopied(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


OnItemDeleted Method (sender, args)

OnItemDeleted Method (sender, args)
Namespaces ► Sitecore.Tasks ► ItemEventHandler ► OnItemDeleted(Object, EventArgs)
Called when the item has been deleted.
Declaration Syntax
C#
protected void OnItemDeleted(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


OnItemSaved Method (sender, args)

OnItemSaved Method (sender, args)
Namespaces ► Sitecore.Tasks ► ItemEventHandler ► OnItemSaved(Object, EventArgs)
Called when the item has been saved.
Declaration Syntax
C#
protected void OnItemSaved(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The arguments.


PublishAgent Class

PublishAgent Class
Namespaces ► Sitecore.Tasks ► PublishAgent
Represents a Publish agent.
Declaration Syntax
C#
public class PublishAgent
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishAgent(String, String, String, String) | Initializes a new instance of the PublishAgent class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Language | Obsolete. Gets the language.
 | Languages | Gets the languages.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Mode | Gets the mode.
 | Run()()() | Runs this instance.
 | SourceDatabase | Gets the source database.
 | TargetDatabase | Gets the target database.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PublishAgent


PublishAgent Constructor (sourceDatabase, targetDatabase, mode, languages)

PublishAgent Constructor (sourceDatabase, targetDatabase, mode, languages)
Namespaces ► Sitecore.Tasks ► PublishAgent ► PublishAgent(String, String, String, String)
Initializes a new instance of the PublishAgent class.
Declaration Syntax
C#
public PublishAgent(
    string sourceDatabase,
    string targetDatabase,
    string mode,
    string languages
)
Parameters
sourceDatabase (String)
The source database.
targetDatabase (String)
The target database.
mode (String)
The mode.
languages (String)
The languages.


Language Property

Language Property
Namespaces ► Sitecore.Tasks ► PublishAgent ► Language
Gets the language.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated - Use Languages instead.")]
public Language Language { get; }
Value
The language.


Languages Property

Languages Property
Namespaces ► Sitecore.Tasks ► PublishAgent ► Languages
Gets the languages.
Declaration Syntax
C#
public List<Language> Languages { get; }
Value
The languages.


Mode Property

Mode Property
Namespaces ► Sitecore.Tasks ► PublishAgent ► Mode
Gets the mode.
Declaration Syntax
C#
public PublishMode Mode { get; }
Value
The mode.


Run Method

Run Method
Namespaces ► Sitecore.Tasks ► PublishAgent ► Run()()()
Runs this instance.
Declaration Syntax
C#
public void Run()


SourceDatabase Property

SourceDatabase Property
Namespaces ► Sitecore.Tasks ► PublishAgent ► SourceDatabase
Gets the source database.
Declaration Syntax
C#
public string SourceDatabase { get; }
Value
The source database.


TargetDatabase Property

TargetDatabase Property
Namespaces ► Sitecore.Tasks ► PublishAgent ► TargetDatabase
Gets the target database.
Declaration Syntax
C#
public string TargetDatabase { get; }
Value
The target database.


Recurrence Class

Recurrence Class
Namespaces ► Sitecore.Tasks ► Recurrence
Represents Recurrence.
Declaration Syntax
C#
public class Recurrence
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Recurrence(String) | Initializes a new instance of the Recurrence class.
 | Days | Gets the days.
 | EndDate | Gets the end date.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNext(DateTime) | Gets the next date.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InRange(DateTime) | Determines if the specified date is in range.
 | Interval | Gets the interval.
 | IsValidDay(DateTime) | Determines whether the specified date is valid a day.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StartDate | Gets the start date.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
Recurrence


Recurrence Constructor (pattern)

Recurrence Constructor (pattern)
Namespaces ► Sitecore.Tasks ► Recurrence ► Recurrence(String)
Initializes a new instance of the Recurrence class.
Declaration Syntax
C#
public Recurrence(
    string pattern
)
Parameters
pattern (String)
The pattern.


Days Property

Days Property
Namespaces ► Sitecore.Tasks ► Recurrence ► Days
Gets the days.
Declaration Syntax
C#
public DaysOfWeek Days { get; }
Value
The days.


EndDate Property

EndDate Property
Namespaces ► Sitecore.Tasks ► Recurrence ► EndDate
Gets the end date.
Declaration Syntax
C#
public DateTime EndDate { get; }
Value
The end date.


GetNext Method (previous)

GetNext Method (previous)
Namespaces ► Sitecore.Tasks ► Recurrence ► GetNext(DateTime)
Gets the next date.
Declaration Syntax
C#
public DateTime GetNext(
    DateTime previous
)
Parameters
previous (DateTime)
The previous.
Return Value


InRange Method (date)

InRange Method (date)
Namespaces ► Sitecore.Tasks ► Recurrence ► InRange(DateTime)
Determines if the specified date is in range.
Declaration Syntax
C#
public bool InRange(
    DateTime date
)
Parameters
date (DateTime)
The date.
Return Value


Interval Property

Interval Property
Namespaces ► Sitecore.Tasks ► Recurrence ► Interval
Gets the interval.
Declaration Syntax
C#
public TimeSpan Interval { get; }
Value
The interval.


IsValidDay Method (date)

IsValidDay Method (date)
Namespaces ► Sitecore.Tasks ► Recurrence ► IsValidDay(DateTime)
Determines whether the specified date is valid a day.
Declaration Syntax
C#
public bool IsValidDay(
    DateTime date
)
Parameters
date (DateTime)
The date.
Return Value
true if the specified date is valid a day; otherwise, false.


StartDate Property

StartDate Property
Namespaces ► Sitecore.Tasks ► Recurrence ► StartDate
Gets the start date.
Declaration Syntax
C#
public DateTime StartDate { get; }
Value
The start date.


ToString Method

ToString Method
Namespaces ► Sitecore.Tasks ► Recurrence ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


ScheduleField Class

ScheduleField Class
Namespaces ► Sitecore.Tasks ► ScheduleField
Represents a Schedule field.
Declaration Syntax
C#
public class ScheduleField : CustomField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ScheduleField(Field) | Initializes a new instance of the ScheduleField class.
 | Days | Gets the days.
 | EndDate | Gets the end date.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNext(DateTime) | Gets the estimated date/time of the next run.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()()() | Gets the value. (Inherited from CustomField.)
 | GetWebEditButtons()()() | Gets the web edit buttons. (Inherited from CustomField.)
 | Implicit(Field) | Implements an implicit conversion operator.
 | InnerField | Gets the inner field. (Inherited from CustomField.)
 | Interval | Gets the interval.
 | IsDue(DateTime) | Determines whether the specified last run is due.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from CustomField.)
 | RemoveLink(ItemLink) | Removes the link. (Inherited from CustomField.)
 | Repeating | Gets a value indicating whether this ScheduleField is repeating.
 | SetValue(String) | Sets the value. (Inherited from CustomField.)
 | StartDate | Gets the start date.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLink(ItemLink) | Updates the link. (Inherited from CustomField.)
 | ValidateLinks(LinksValidationResult) | Validates the links. (Inherited from CustomField.)
 | Value | Gets or sets the field value. (Inherited from CustomField.)
Inheritance Hierarchy
Object
 | CustomField
 |  | ScheduleField


ScheduleField Constructor (innerField)

ScheduleField Constructor (innerField)
Namespaces ► Sitecore.Tasks ► ScheduleField ► ScheduleField(Field)
Initializes a new instance of the ScheduleField class.
Declaration Syntax
C#
public ScheduleField(
    Field innerField
)
Parameters
innerField (Field)
Inner field.


Days Property

Days Property
Namespaces ► Sitecore.Tasks ► ScheduleField ► Days
Gets the days.
Declaration Syntax
C#
public DaysOfWeek Days { get; }
Value
The days.


EndDate Property

EndDate Property
Namespaces ► Sitecore.Tasks ► ScheduleField ► EndDate
Gets the end date.
Declaration Syntax
C#
public DateTime EndDate { get; }
Value
The end date.


GetNext Method (lastRun)

GetNext Method (lastRun)
Namespaces ► Sitecore.Tasks ► ScheduleField ► GetNext(DateTime)
Gets the estimated date/time of the next run.
Declaration Syntax
C#
public DateTime GetNext(
    DateTime lastRun
)
Parameters
lastRun (DateTime)
The last time task was run (or 'now').
Return Value
The next date time the task is going to be run or MinValue if task is never going to be run again.


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Tasks ► ScheduleField ► Implicit(Field)
Implements an implicit conversion operator.
Declaration Syntax
C#
public static implicit operator ScheduleField (
    Field field
)
Parameters
field (Field)
The field.
Return Value


Interval Property

Interval Property
Namespaces ► Sitecore.Tasks ► ScheduleField ► Interval
Gets the interval.
Declaration Syntax
C#
public TimeSpan Interval { get; }
Value
The interval.


IsDue Method (lastRun)

IsDue Method (lastRun)
Namespaces ► Sitecore.Tasks ► ScheduleField ► IsDue(DateTime)
Determines whether the specified last run is due.
Declaration Syntax
C#
public bool IsDue(
    DateTime lastRun
)
Parameters
lastRun (DateTime)
The last run.
Return Value
true if the specified last run is due; otherwise, false.


Repeating Property

Repeating Property
Namespaces ► Sitecore.Tasks ► ScheduleField ► Repeating
Gets a value indicating whether this ScheduleField is repeating.
Declaration Syntax
C#
public bool Repeating { get; }
Value
true if repeating; otherwise, false.


StartDate Property

StartDate Property
Namespaces ► Sitecore.Tasks ► ScheduleField ► StartDate
Gets the start date.
Declaration Syntax
C#
public DateTime StartDate { get; }
Value
The start date.


ScheduleItem Class

ScheduleItem Class
Namespaces ► Sitecore.Tasks ► ScheduleItem
Represents a Schedule item.
Declaration Syntax
C#
public class ScheduleItem : CustomItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ScheduleItem(Item) | Initializes a new instance of the ScheduleItem class.
 | Active | Gets a value indicating whether this ScheduleItem is active.
 | Asynchronous | Gets a value indicating whether the command should be run asynchronously.
 | AutoRemove | Gets a value indicating whether the ScheduleItem auto-removes.
 | BeginEdit()()() | Begins editing the item. (Inherited from CustomItemBase.)
 | CommandItem | Gets the command item.
 | Database | Gets the database. (Inherited from CustomItemBase.)
 | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
 | EndEdit()()() | Ends editing the item. (Inherited from CustomItemBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes this instance.
 | Expired | Gets a value indicating whether this ScheduleItem is expired (will never run).
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetJobName(CommandItem) | Gets the name of the job that will be used when a command is run asynchronously.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon | Gets the icon. (Inherited from CustomItemBase.)
 | ID | Gets the ID. (Inherited from CustomItemBase.)
 | Implicit(Item) | Implements an implicit conversion operator.
 | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
 | IsCompleted | Gets a value indicating whether this instance is completed.
 | IsDue | Gets a value indicating whether this instance is due.
 | Item[([(ID])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
 | Item[([(Int32])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
 | Item[([(String])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
 | Items | Gets the items.
 | LastRun | Gets or sets the last run.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name. (Inherited from CustomItemBase.)
 | NextRun | Gets the datetime the schedule is going to be executed next time.
 | Remove()()() | Removes this instance.
 | Schedule | Gets the schedule.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | CustomItemBase
 |  | CustomItem
 |  |  | ScheduleItem


ScheduleItem Constructor (innerItem)

ScheduleItem Constructor (innerItem)
Namespaces ► Sitecore.Tasks ► ScheduleItem ► ScheduleItem(Item)
Initializes a new instance of the ScheduleItem class.
Declaration Syntax
C#
public ScheduleItem(
    Item innerItem
)
Parameters
innerItem (Item)
Inner item.


Active Property

Active Property
Namespaces ► Sitecore.Tasks ► ScheduleItem ► Active
Gets a value indicating whether this ScheduleItem is active.
Declaration Syntax
C#
public bool Active { get; }
Value
true if active; otherwise, false.


Asynchronous Property

Asynchronous Property
Namespaces ► Sitecore.Tasks ► ScheduleItem ► Asynchronous
Gets a value indicating whether the command should be run asynchronously.
Declaration Syntax
C#
public bool Asynchronous { get; }
Value
true if the the command should be run asynchronously; otherwise, false.


AutoRemove Property

AutoRemove Property
Namespaces ► Sitecore.Tasks ► ScheduleItem ► AutoRemove
Gets a value indicating whether the ScheduleItem auto-removes.
Declaration Syntax
C#
public bool AutoRemove { get; }
Value
true if the ScheduleItem auto-removes; otherwise, false.


CommandItem Property

CommandItem Property
Namespaces ► Sitecore.Tasks ► ScheduleItem ► CommandItem
Gets the command item.
Declaration Syntax
C#
public CommandItem CommandItem { get; }
Value
The command item.


Execute Method

Execute Method
Namespaces ► Sitecore.Tasks ► ScheduleItem ► Execute()()()
Executes this instance.
Declaration Syntax
C#
public void Execute()


Expired Property

Expired Property
Namespaces ► Sitecore.Tasks ► ScheduleItem ► Expired
Gets a value indicating whether this ScheduleItem is expired (will never run).
Declaration Syntax
C#
public bool Expired { get; }
Value
true if expired; otherwise, false.


GetJobName Method (command)

GetJobName Method (command)
Namespaces ► Sitecore.Tasks ► ScheduleItem ► GetJobName(CommandItem)
Gets the name of the job that will be used when a command is run asynchronously.
Declaration Syntax
C#
public string GetJobName(
    CommandItem command
)
Parameters
command (CommandItem)
Return Value


Implicit Operator

Implicit Operator
Namespaces ► Sitecore.Tasks ► ScheduleItem ► Implicit(Item)
Implements an implicit conversion operator.
Declaration Syntax
C#
public static implicit operator ScheduleItem (
    Item item
)
Parameters
item (Item)
The item.
Return Value


IsCompleted Property

IsCompleted Property
Namespaces ► Sitecore.Tasks ► ScheduleItem ► IsCompleted
Gets a value indicating whether this instance is completed.
Declaration Syntax
C#
public bool IsCompleted { get; }
Value
true if this instance is completed; otherwise, false.


IsDue Property

IsDue Property
Namespaces ► Sitecore.Tasks ► ScheduleItem ► IsDue
Gets a value indicating whether this instance is due.
Declaration Syntax
C#
public bool IsDue { get; }
Value
true if this instance is due; otherwise, false.


Items Property

Items Property
Namespaces ► Sitecore.Tasks ► ScheduleItem ► Items
Gets the items.
Declaration Syntax
C#
public Item[] Items { get; }
Value
The items.


LastRun Property

LastRun Property
Namespaces ► Sitecore.Tasks ► ScheduleItem ► LastRun
Gets or sets the last run.
Declaration Syntax
C#
public DateTime LastRun { get; set; }
Value
The last run.


NextRun Property

NextRun Property
Namespaces ► Sitecore.Tasks ► ScheduleItem ► NextRun
Gets the datetime the schedule is going to be executed next time.
Declaration Syntax
C#
public DateTime NextRun { get; }
Value
The datetime of next execution of the schedule.


Remove Method

Remove Method
Namespaces ► Sitecore.Tasks ► ScheduleItem ► Remove()()()
Removes this instance.
Declaration Syntax
C#
public void Remove()


Schedule Property

Schedule Property
Namespaces ► Sitecore.Tasks ► ScheduleItem ► Schedule
Gets the schedule.
Declaration Syntax
C#
public ScheduleField Schedule { get; }
Value
The schedule.


Scheduler Class

Scheduler Class
Namespaces ► Sitecore.Tasks ► Scheduler
Represents the Scheduler.
Declaration Syntax
C#
public class Scheduler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Scheduler()()() | Initializes a new instance of the Scheduler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()()() | Initializes this instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process()()() | Runs the processor.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Scheduler


Scheduler Constructor

Scheduler Constructor
Namespaces ► Sitecore.Tasks ► Scheduler ► Scheduler()()()
Initializes a new instance of the Scheduler class
Declaration Syntax
C#
public Scheduler()


Initialize Method

Initialize Method
Namespaces ► Sitecore.Tasks ► Scheduler ► Initialize()()()
Initializes this instance.
Declaration Syntax
C#
public static void Initialize()


Process Method

Process Method
Namespaces ► Sitecore.Tasks ► Scheduler ► Process()()()
Runs the processor.
Declaration Syntax
C#
public static void Process()


Scheduler.Agent Class

Scheduler..::.Agent Class
Namespaces ► Sitecore.Tasks ► Scheduler ► Scheduler..::.Agent
Represents an Agent.
Declaration Syntax
C#
protected class Agent
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Scheduler..::.Agent(String, Object, String, TimeSpan, DateTime) | Initializes a new instance of the Scheduler..::.Agent class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes this instance.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDue | Gets a value indicating whether this instance is due.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Scheduler..::.Agent


Scheduler.Agent Constructor (name, obj, method, interval, lastRun)

Scheduler..::.Agent Constructor (name, obj, method, interval, lastRun)
Namespaces ► Sitecore.Tasks ► Scheduler..::.Agent ► Scheduler..::.Agent(String, Object, String, TimeSpan, DateTime)
Initializes a new instance of the Scheduler..::.Agent class.
Declaration Syntax
C#
public Agent(
    string name,
    Object obj,
    string method,
    TimeSpan interval,
    DateTime lastRun
)
Parameters
name (String)
The name.
obj (Object)
The object.
method (String)
The method.
interval (TimeSpan)
The interval.
lastRun (DateTime)
The last run.


Execute Method

Execute Method
Namespaces ► Sitecore.Tasks ► Scheduler..::.Agent ► Execute()()()
Executes this instance.
Declaration Syntax
C#
public void Execute()


IsDue Property

IsDue Property
Namespaces ► Sitecore.Tasks ► Scheduler..::.Agent ► IsDue
Gets a value indicating whether this instance is due.
Declaration Syntax
C#
public bool IsDue { get; }
Value
true if this instance is due; otherwise, false.


Name Property

Name Property
Namespaces ► Sitecore.Tasks ► Scheduler..::.Agent ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


Status Class

Status Class
Namespaces ► Sitecore.Tasks ► Status
Represents the Status of a task.
Declaration Syntax
C#
public class Status
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Status()()() | Initializes a new instance of the Status class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LogCacheSize(array<Item>[]()[], CommandItem, ScheduleItem) | Logs the size of the cache.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Status


Status Constructor

Status Constructor
Namespaces ► Sitecore.Tasks ► Status ► Status()()()
Initializes a new instance of the Status class
Declaration Syntax
C#
public Status()


LogCacheSize Method (items, command, schedule)

LogCacheSize Method (items, command, schedule)
Namespaces ► Sitecore.Tasks ► Status ► LogCacheSize(array<Item>[]()[], CommandItem, ScheduleItem)
Logs the size of the cache.
Declaration Syntax
C#
public void LogCacheSize(
    Item[] items,
    CommandItem command,
    ScheduleItem schedule
)
Parameters
items (array< Item >[]()[])
The items.
command (CommandItem)
The command.
schedule (ScheduleItem)
The schedule.


Task Class

Task Class
Namespaces ► Sitecore.Tasks ► Task
Defines the basic properties and functionality of a task.
Declaration Syntax
C#
public abstract class Task
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Task(DateTime) | Initializes a new instance of the Task class.
 | DatabaseName | Gets or sets the name of the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes this task.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item.
 | GetNextRecurrence()()() | Gets the next recurrence.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the ID.
 | ItemID | Gets or sets the item ID.
 | LogActivity | Gets or sets a value indicating whether the Task logs the activity.
 | LogError(String) | Logs the error.
 | LogInfo(String) | Logs the info.
 | LogWarn(String) | Logs the warning.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets or sets the parameters.
 | RecurrencePattern | Gets or sets the recurrence pattern.
 | SyncRoot | Gets the sync root.
 | TaskDate | Gets or sets the task date.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Task
 |  | ArchiveTask
 |  | EmailReminderTask


Task Constructor (taskDate)

Task Constructor (taskDate)
Namespaces ► Sitecore.Tasks ► Task ► Task(DateTime)
Initializes a new instance of the Task class.
Declaration Syntax
C#
protected Task(
    DateTime taskDate
)
Parameters
taskDate (DateTime)
The task date.


DatabaseName Property

DatabaseName Property
Namespaces ► Sitecore.Tasks ► Task ► DatabaseName
Gets or sets the name of the database.
Declaration Syntax
C#
public string DatabaseName { get; set; }
Value
The name of the database.


Execute Method

Execute Method
Namespaces ► Sitecore.Tasks ► Task ► Execute()()()
Executes this task.
Declaration Syntax
C#
public abstract void Execute()


GetItem Method

GetItem Method
Namespaces ► Sitecore.Tasks ► Task ► GetItem()()()
Gets the item.
Declaration Syntax
C#
public Item GetItem()
Return Value


GetNextRecurrence Method

GetNextRecurrence Method
Namespaces ► Sitecore.Tasks ► Task ► GetNextRecurrence()()()
Gets the next recurrence.
Declaration Syntax
C#
public DateTime GetNextRecurrence()
Return Value


ID Property

ID Property
Namespaces ► Sitecore.Tasks ► Task ► ID
Gets or sets the ID.
Declaration Syntax
C#
public ID ID { get; set; }
Value
The ID.


ItemID Property

ItemID Property
Namespaces ► Sitecore.Tasks ► Task ► ItemID
Gets or sets the item ID.
Declaration Syntax
C#
public ID ItemID { get; set; }
Value
The item ID.


LogActivity Property

LogActivity Property
Namespaces ► Sitecore.Tasks ► Task ► LogActivity
Gets or sets a value indicating whether the Task logs the activity.
Declaration Syntax
C#
public bool LogActivity { get; set; }
Value
true if the Task logs the activity; otherwise, false.


LogError Method (message)

LogError Method (message)
Namespaces ► Sitecore.Tasks ► Task ► LogError(String)
Logs the error.
Declaration Syntax
C#
protected virtual void LogError(
    string message
)
Parameters
message (String)
The message.


LogInfo Method (message)

LogInfo Method (message)
Namespaces ► Sitecore.Tasks ► Task ► LogInfo(String)
Logs the info.
Declaration Syntax
C#
protected virtual void LogInfo(
    string message
)
Parameters
message (String)
The message.


LogWarn Method (message)

LogWarn Method (message)
Namespaces ► Sitecore.Tasks ► Task ► LogWarn(String)
Logs the warning.
Declaration Syntax
C#
protected virtual void LogWarn(
    string message
)
Parameters
message (String)
The message.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Tasks ► Task ► Parameters
Gets or sets the parameters.
Declaration Syntax
C#
public string Parameters { get; set; }
Value
The parameters.


RecurrencePattern Property

RecurrencePattern Property
Namespaces ► Sitecore.Tasks ► Task ► RecurrencePattern
Gets or sets the recurrence pattern.
Declaration Syntax
C#
public string RecurrencePattern { get; set; }
Value
The recurrence pattern.


SyncRoot Property

SyncRoot Property
Namespaces ► Sitecore.Tasks ► Task ► SyncRoot
Gets the sync root.
Declaration Syntax
C#
public static Object SyncRoot { get; }
Value
The sync root.


TaskDate Property

TaskDate Property
Namespaces ► Sitecore.Tasks ► Task ► TaskDate
Gets or sets the task date.
Declaration Syntax
C#
public DateTime TaskDate { get; set; }
Value
The task date.


TaskContext Class

TaskContext Class
Namespaces ► Sitecore.Tasks ► TaskContext
Represents a TaskContext.
Declaration Syntax
C#
public class TaskContext : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskContext(String) | Initializes a new instance of the TaskContext class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the task.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskContext


TaskContext Constructor (name)

TaskContext Constructor (name)
Namespaces ► Sitecore.Tasks ► TaskContext ► TaskContext(String)
Initializes a new instance of the TaskContext class.
Declaration Syntax
C#
public TaskContext(
    string name
)
Parameters
name (String)
The name.


Name Property

Name Property
Namespaces ► Sitecore.Tasks ► TaskContext ► Name
Gets the name of the task.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


TaskDatabase Class

TaskDatabase Class
Namespaces ► Sitecore.Tasks ► TaskDatabase
Defines the basic methods of a database that supports tasks.
Declaration Syntax
C#
public abstract class TaskDatabase
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TaskDatabase()()() | Initializes a new instance of the TaskDatabase class
 | Disable(Task) | Disables the specified task.
 | Enable(Task) | Enables the specified task.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPendingTasks()()() | Gets the pending tasks.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MarkDone(Task) | Marks the task as done.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(Task) | Removes the specified task.
 | RemoveItemTasks(Item) | Removes the item tasks.
 | RemoveItemTasks(Item, Type) | Removes the item tasks.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(Task, Boolean) | Updates the specified task.
 | UpdateItemTask(Task, Boolean) | Updates the item task.
Inheritance Hierarchy
Object
 | TaskDatabase
 |  | SqlServerTaskDatabase


TaskDatabase Constructor

TaskDatabase Constructor
Namespaces ► Sitecore.Tasks ► TaskDatabase ► TaskDatabase()()()
Initializes a new instance of the TaskDatabase class
Declaration Syntax
C#
protected TaskDatabase()


Disable Method (task)

Disable Method (task)
Namespaces ► Sitecore.Tasks ► TaskDatabase ► Disable(Task)
Disables the specified task.
Declaration Syntax
C#
public abstract void Disable(
    Task task
)
Parameters
task (Task)
The task.


Enable Method (task)

Enable Method (task)
Namespaces ► Sitecore.Tasks ► TaskDatabase ► Enable(Task)
Enables the specified task.
Declaration Syntax
C#
public abstract void Enable(
    Task task
)
Parameters
task (Task)
The task.


GetPendingTasks Method

GetPendingTasks Method
Namespaces ► Sitecore.Tasks ► TaskDatabase ► GetPendingTasks()()()
Gets the pending tasks.
Declaration Syntax
C#
public abstract Task[] GetPendingTasks()
Return Value


MarkDone Method (task)

MarkDone Method (task)
Namespaces ► Sitecore.Tasks ► TaskDatabase ► MarkDone(Task)
Marks the task as done.
Declaration Syntax
C#
public abstract void MarkDone(
    Task task
)
Parameters
task (Task)
The task.


Remove Method (task)

Remove Method (task)
Namespaces ► Sitecore.Tasks ► TaskDatabase ► Remove(Task)
Removes the specified task.
Declaration Syntax
C#
public abstract void Remove(
    Task task
)
Parameters
task (Task)
The task.


RemoveItemTasks Method

RemoveItemTasks Method
Namespaces ► Sitecore.Tasks ► TaskDatabase ► RemoveItemTasks()()()
Members
Icon | Member | Description
 | RemoveItemTasks(Item) | Removes the item tasks.
 | RemoveItemTasks(Item, Type) | Removes the item tasks.


RemoveItemTasks Method (item)

RemoveItemTasks Method (item)
Namespaces ► Sitecore.Tasks ► TaskDatabase ► RemoveItemTasks(Item)
Removes the item tasks.
Declaration Syntax
C#
public abstract void RemoveItemTasks(
    Item item
)
Parameters
item (Item)
The item.


RemoveItemTasks Method (item, taskType)

RemoveItemTasks Method (item, taskType)
Namespaces ► Sitecore.Tasks ► TaskDatabase ► RemoveItemTasks(Item, Type)
Removes the item tasks.
Declaration Syntax
C#
public abstract void RemoveItemTasks(
    Item item,
    Type taskType
)
Parameters
item (Item)
The item.
taskType (Type)
Type of the task.


Update Method (task, insertIfNotFound)

Update Method (task, insertIfNotFound)
Namespaces ► Sitecore.Tasks ► TaskDatabase ► Update(Task, Boolean)
Updates the specified task.
Declaration Syntax
C#
public abstract void Update(
    Task task,
    bool insertIfNotFound
)
Parameters
task (Task)
The task.
insertIfNotFound (Boolean)
if set to true this instance is insert if not found.


UpdateItemTask Method (task, insertIfNotFound)

UpdateItemTask Method (task, insertIfNotFound)
Namespaces ► Sitecore.Tasks ► TaskDatabase ► UpdateItemTask(Task, Boolean)
Updates the item task.
Declaration Syntax
C#
public abstract void UpdateItemTask(
    Task task,
    bool insertIfNotFound
)
Parameters
task (Task)
The task.
insertIfNotFound (Boolean)
if set to true this instance is insert if not found.


TaskDatabaseAgent Class

TaskDatabaseAgent Class
Namespaces ► Sitecore.Tasks ► TaskDatabaseAgent
Represents a TaskDatabase agent.
Declaration Syntax
C#
public class TaskDatabaseAgent
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskDatabaseAgent()()() | Initializes a new instance of the TaskDatabaseAgent class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LogActivity | Gets or sets a value indicating whether the TaskDatabaseAgent logs the activity.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run()()() | Runs the pipeline.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskDatabaseAgent


TaskDatabaseAgent Constructor

TaskDatabaseAgent Constructor
Namespaces ► Sitecore.Tasks ► TaskDatabaseAgent ► TaskDatabaseAgent()()()
Initializes a new instance of the TaskDatabaseAgent class
Declaration Syntax
C#
public TaskDatabaseAgent()


LogActivity Property

LogActivity Property
Namespaces ► Sitecore.Tasks ► TaskDatabaseAgent ► LogActivity
Gets or sets a value indicating whether the TaskDatabaseAgent logs the activity.
Declaration Syntax
C#
public bool LogActivity { get; set; }
Value
true if the TaskDatabaseAgent logs the activity; otherwise, false.


Run Method

Run Method
Namespaces ► Sitecore.Tasks ► TaskDatabaseAgent ► Run()()()
Runs the pipeline.
Declaration Syntax
C#
public void Run()


UrlAgent Class

UrlAgent Class
Namespaces ► Sitecore.Tasks ► UrlAgent
Represents a UrlAgent.
Declaration Syntax
C#
public class UrlAgent
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UrlAgent(String) | Initializes a new instance of the UrlAgent class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LogActivity | Gets or sets a value indicating whether the UrlAgent logs the activity.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run()()() | Runs the pipeline.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UrlAgent


UrlAgent Constructor (url)

UrlAgent Constructor (url)
Namespaces ► Sitecore.Tasks ► UrlAgent ► UrlAgent(String)
Initializes a new instance of the UrlAgent class.
Declaration Syntax
C#
public UrlAgent(
    string url
)
Parameters
url (String)
The URL.


LogActivity Property

LogActivity Property
Namespaces ► Sitecore.Tasks ► UrlAgent ► LogActivity
Gets or sets a value indicating whether the UrlAgent logs the activity.
Declaration Syntax
C#
public bool LogActivity { get; set; }
Value
true if the UrlAgent logs the activity; otherwise, false.


Run Method

Run Method
Namespaces ► Sitecore.Tasks ► UrlAgent ► Run()()()
Runs the pipeline.
Declaration Syntax
C#
public void Run()


Sitecore.Text.Diff Namespace

Sitecore.Text.Diff Namespace
Namespaces ► Sitecore.Text.Diff
Declaration Syntax
C#
namespace Sitecore.Text.Diff
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | DiffEngine | Represents the DiffEngine.
 | DiffEngineLevel | Represents a diff engine level.
 | DiffListHtml |
 | DiffResultSpan |
 | DiffResultSpanStatus |
 | IDiffList | Represents a IDiffList.


DiffEngine Class

DiffEngine Class
Namespaces ► Sitecore.Text.Diff ► DiffEngine
Represents the DiffEngine.
Declaration Syntax
C#
public class DiffEngine
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DiffEngine()()() | Initializes a new instance of the DiffEngine class.
 | DiffReport()()() | Diffs the report.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessDiff(IDiffList, IDiffList, DiffEngineLevel) | Processes the diff.
 | ProcessDiff(IDiffList, IDiffList) | Processes the diff.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DiffEngine


DiffEngine Constructor

DiffEngine Constructor
Namespaces ► Sitecore.Text.Diff ► DiffEngine ► DiffEngine()()()
Initializes a new instance of the DiffEngine class.
Declaration Syntax
C#
public DiffEngine()


DiffReport Method

DiffReport Method
Namespaces ► Sitecore.Text.Diff ► DiffEngine ► DiffReport()()()
Diffs the report.
Declaration Syntax
C#
public ArrayList DiffReport()
Return Value


ProcessDiff Method

ProcessDiff Method
Namespaces ► Sitecore.Text.Diff ► DiffEngine ► ProcessDiff()()()
Members
Icon | Member | Description
 | ProcessDiff(IDiffList, IDiffList, DiffEngineLevel) | Processes the diff.
 | ProcessDiff(IDiffList, IDiffList) | Processes the diff.


ProcessDiff Method (source, destination)

ProcessDiff Method (source, destination)
Namespaces ► Sitecore.Text.Diff ► DiffEngine ► ProcessDiff(IDiffList, IDiffList)
Processes the diff.
Declaration Syntax
C#
public double ProcessDiff(
    IDiffList source,
    IDiffList destination
)
Parameters
source (IDiffList)
The source.
destination (IDiffList)
The destination.
Return Value


ProcessDiff Method (source, destination, level)

ProcessDiff Method (source, destination, level)
Namespaces ► Sitecore.Text.Diff ► DiffEngine ► ProcessDiff(IDiffList, IDiffList, DiffEngineLevel)
Processes the diff.
Declaration Syntax
C#
public double ProcessDiff(
    IDiffList source,
    IDiffList destination,
    DiffEngineLevel level
)
Parameters
source (IDiffList)
The source.
destination (IDiffList)
The destination.
level (DiffEngineLevel)
The level.
Return Value


DiffEngineLevel Enumeration

DiffEngineLevel Enumeration
Namespaces ► Sitecore.Text.Diff ► DiffEngineLevel
Represents a diff engine level.
Declaration Syntax
C#
public enum DiffEngineLevel
Members
Member | Description
FastImperfect | Fast imperfect.
Medium | Medium.
SlowPerfect | Slow perfect.


DiffListHtml Class

DiffListHtml Class
Namespaces ► Sitecore.Text.Diff ► DiffListHtml
Declaration Syntax
C#
public class DiffListHtml : IDiffList
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DiffListHtml(String) | Initializes a new instance of the DiffListHtml class.
 | Count()()() | Counts this instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetByIndex(Int32) | Gets the DiffList by index.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReplaceTags(String) | Replaces the tags.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DiffListHtml


DiffListHtml Constructor (text)

DiffListHtml Constructor (text)
Namespaces ► Sitecore.Text.Diff ► DiffListHtml ► DiffListHtml(String)
Initializes a new instance of the DiffListHtml class.
Declaration Syntax
C#
public DiffListHtml(
    string text
)
Parameters
text (String)
The text.


Count Method

Count Method
Namespaces ► Sitecore.Text.Diff ► DiffListHtml ► Count()()()
Counts this instance.
Declaration Syntax
C#
public int Count()
Return Value
The count.


GetByIndex Method (index)

GetByIndex Method (index)
Namespaces ► Sitecore.Text.Diff ► DiffListHtml ► GetByIndex(Int32)
Gets the DiffList by index.
Declaration Syntax
C#
public IComparable GetByIndex(
    int index
)
Parameters
index (Int32)
The index.
Return Value
The IComparable.


ReplaceTags Method (text)

ReplaceTags Method (text)
Namespaces ► Sitecore.Text.Diff ► DiffListHtml ► ReplaceTags(String)
Replaces the tags.
Declaration Syntax
C#
public virtual string ReplaceTags(
    string text
)
Parameters
text (String)
The text.
Return Value
The tags.


DiffResultSpan Class

DiffResultSpan Class
Namespaces ► Sitecore.Text.Diff ► DiffResultSpan
Declaration Syntax
C#
public class DiffResultSpan : IComparable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DiffResultSpan(DiffResultSpanStatus, Int32, Int32, Int32) | Initializes a new instance of the DiffResultSpan class.
 | AddLength(Int32) | Adds the length.
 | CompareTo(Object) | Compares the current instance with another object of the same type.
 | CreateAddDestination(Int32, Int32) | Creates the add destination.
 | CreateDeleteSource(Int32, Int32) | Creates the delete source.
 | CreateNoChange(Int32, Int32, Int32) | Creates the no change.
 | CreateReplace(Int32, Int32, Int32) | Creates the replace.
 | DestIndex | Gets the index of the dest.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Length | Gets the length.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SourceIndex | Gets the index of the source.
 | Status | Gets the status.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
DiffResultSpan


DiffResultSpan Constructor (status, destIndex, sourceIndex, length)

DiffResultSpan Constructor (status, destIndex, sourceIndex, length)
Namespaces ► Sitecore.Text.Diff ► DiffResultSpan ► DiffResultSpan(DiffResultSpanStatus, Int32, Int32, Int32)
Initializes a new instance of the DiffResultSpan class.
Declaration Syntax
C#
protected DiffResultSpan(
    DiffResultSpanStatus status,
    int destIndex,
    int sourceIndex,
    int length
)
Parameters
status (DiffResultSpanStatus)
The status.
destIndex (Int32)
Index of the dest.
sourceIndex (Int32)
Index of the source.
length (Int32)
The length.


AddLength Method (i)

AddLength Method (i)
Namespaces ► Sitecore.Text.Diff ► DiffResultSpan ► AddLength(Int32)
Adds the length.
Declaration Syntax
C#
public void AddLength(
    int i
)
Parameters
i (Int32)
The i.


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces ► Sitecore.Text.Diff ► DiffResultSpan ► CompareTo(Object)
Compares the current instance with another object of the same type.
Declaration Syntax
C#
public int CompareTo(
    Object obj
)
Parameters
obj (Object)
An object to compare with this instance.
Return Value
A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.
Exceptions
Exception | Condition
ArgumentException | obj is not the same type as this instance.


CreateAddDestination Method (destIndex, length)

CreateAddDestination Method (destIndex, length)
Namespaces ► Sitecore.Text.Diff ► DiffResultSpan ► CreateAddDestination(Int32, Int32)
Creates the add destination.
Declaration Syntax
C#
public static DiffResultSpan CreateAddDestination(
    int destIndex,
    int length
)
Parameters
destIndex (Int32)
Index of the dest.
length (Int32)
The length.
Return Value
The add destination.


CreateDeleteSource Method (sourceIndex, length)

CreateDeleteSource Method (sourceIndex, length)
Namespaces ► Sitecore.Text.Diff ► DiffResultSpan ► CreateDeleteSource(Int32, Int32)
Creates the delete source.
Declaration Syntax
C#
public static DiffResultSpan CreateDeleteSource(
    int sourceIndex,
    int length
)
Parameters
sourceIndex (Int32)
Index of the source.
length (Int32)
The length.
Return Value
The delete source.


CreateNoChange Method (destIndex, sourceIndex, length)

CreateNoChange Method (destIndex, sourceIndex, length)
Namespaces ► Sitecore.Text.Diff ► DiffResultSpan ► CreateNoChange(Int32, Int32, Int32)
Creates the no change.
Declaration Syntax
C#
public static DiffResultSpan CreateNoChange(
    int destIndex,
    int sourceIndex,
    int length
)
Parameters
destIndex (Int32)
Index of the dest.
sourceIndex (Int32)
Index of the source.
length (Int32)
The length.
Return Value
The no change.


CreateReplace Method (destIndex, sourceIndex, length)

CreateReplace Method (destIndex, sourceIndex, length)
Namespaces ► Sitecore.Text.Diff ► DiffResultSpan ► CreateReplace(Int32, Int32, Int32)
Creates the replace.
Declaration Syntax
C#
public static DiffResultSpan CreateReplace(
    int destIndex,
    int sourceIndex,
    int length
)
Parameters
destIndex (Int32)
Index of the dest.
sourceIndex (Int32)
Index of the source.
length (Int32)
The length.
Return Value
The replace.


DestIndex Property

DestIndex Property
Namespaces ► Sitecore.Text.Diff ► DiffResultSpan ► DestIndex
Gets the index of the dest.
Declaration Syntax
C#
public int DestIndex { get; }
Value
The index of the dest.


Length Property

Length Property
Namespaces ► Sitecore.Text.Diff ► DiffResultSpan ► Length
Gets the length.
Declaration Syntax
C#
public int Length { get; }
Value
The length.


SourceIndex Property

SourceIndex Property
Namespaces ► Sitecore.Text.Diff ► DiffResultSpan ► SourceIndex
Gets the index of the source.
Declaration Syntax
C#
public int SourceIndex { get; }
Value
The index of the source.


Status Property

Status Property
Namespaces ► Sitecore.Text.Diff ► DiffResultSpan ► Status
Gets the status.
Declaration Syntax
C#
public DiffResultSpanStatus Status { get; }
Value
The status.


ToString Method

ToString Method
Namespaces ► Sitecore.Text.Diff ► DiffResultSpan ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


DiffResultSpanStatus Enumeration

DiffResultSpanStatus Enumeration
Namespaces ► Sitecore.Text.Diff ► DiffResultSpanStatus
Declaration Syntax
C#
public enum DiffResultSpanStatus
Members
Member | Description
NoChange |
Replace |
DeleteSource |
AddDestination |


IDiffList Interface

IDiffList Interface
Namespaces ► Sitecore.Text.Diff ► IDiffList
Represents a IDiffList.
Declaration Syntax
C#
public interface IDiffList
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Count()()() | Counts this instance.
 | GetByIndex(Int32) | Gets the DiffList by index.


Count Method

Count Method
Namespaces ► Sitecore.Text.Diff ► IDiffList ► Count()()()
Counts this instance.
Declaration Syntax
C#
int Count()
Return Value
The count.


GetByIndex Method (index)

GetByIndex Method (index)
Namespaces ► Sitecore.Text.Diff ► IDiffList ► GetByIndex(Int32)
Gets the DiffList by index.
Declaration Syntax
C#
IComparable GetByIndex(
    int index
)
Parameters
index (Int32)
The index.
Return Value
The IComparable.


Sitecore.Text.Diff.View Namespace

Sitecore.Text.Diff.View Namespace
Namespaces ► Sitecore.Text.Diff.View
Declaration Syntax
C#
namespace Sitecore.Text.Diff.View
Types
All Types Classes
Icon | Type | Description
 | DiffView | Represents a DiffView.
 | OneColumnDiffView | Represents a OneColumnDiffView.
 | TwoCoumnsDiffView | Represents a TwoCoumnsDiffView.


DiffView Class

DiffView Class
Namespaces ► Sitecore.Text.Diff.View ► DiffView
Represents a DiffView.
Declaration Syntax
C#
public abstract class DiffView
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DiffView()()() | Initializes a new instance of the DiffView class
 | Append(StringBuilder, String, Int32, Int32, String) | Appends the specified builder.
 | Append(StringBuilder, String, Int32, Int32) | Appends the specified builder.
 | Compare(Control, Item, Item, String) | Compares the specified items.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(String) | Gets the value.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ShowField(Field) | Shows the field.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DiffView
 |  | OneColumnDiffView
 |  | TwoCoumnsDiffView


DiffView Constructor

DiffView Constructor
Namespaces ► Sitecore.Text.Diff.View ► DiffView ► DiffView()()()
Initializes a new instance of the DiffView class
Declaration Syntax
C#
protected DiffView()


Append Method

Append Method
Namespaces ► Sitecore.Text.Diff.View ► DiffView ► Append()()()
Members
Icon | Member | Description
 | Append(StringBuilder, String, Int32, Int32, String) | Appends the specified builder.
 | Append(StringBuilder, String, Int32, Int32) | Appends the specified builder.


Append Method (builder, value, index, length)

Append Method (builder, value, index, length)
Namespaces ► Sitecore.Text.Diff.View ► DiffView ► Append(StringBuilder, String, Int32, Int32)
Appends the specified builder.
Declaration Syntax
C#
protected void Append(
    StringBuilder builder,
    string value,
    int index,
    int length
)
Parameters
builder (StringBuilder)
The builder.
value (String)
The value.
index (Int32)
The index.
length (Int32)
The length.


Append Method (builder, value, index, length, color)

Append Method (builder, value, index, length, color)
Namespaces ► Sitecore.Text.Diff.View ► DiffView ► Append(StringBuilder, String, Int32, Int32, String)
Appends the specified builder.
Declaration Syntax
C#
protected void Append(
    StringBuilder builder,
    string value,
    int index,
    int length,
    string color
)
Parameters
builder (StringBuilder)
The builder.
value (String)
The value.
index (Int32)
The index.
length (Int32)
The length.
color (String)
The color.


Compare Method (parent, item1, item2, click)

Compare Method (parent, item1, item2, click)
Namespaces ► Sitecore.Text.Diff.View ► DiffView ► Compare(Control, Item, Item, String)
Compares the specified items.
Declaration Syntax
C#
public abstract int Compare(
    Control parent,
    Item item1,
    Item item2,
    string click
)
Parameters
parent (Control)
The parent.
item1 (Item)
The item1.
item2 (Item)
The item2.
click (String)
The click.
Return Value
The result of the comparison.


GetValue Method (value)

GetValue Method (value)
Namespaces ► Sitecore.Text.Diff.View ► DiffView ► GetValue(String)
Gets the value.
Declaration Syntax
C#
protected string GetValue(
    string value
)
Parameters
value (String)
The value.
Return Value
The value.


ShowField Method (field)

ShowField Method (field)
Namespaces ► Sitecore.Text.Diff.View ► DiffView ► ShowField(Field)
Shows the field.
Declaration Syntax
C#
protected virtual bool ShowField(
    Field field
)
Parameters
field (Field)
The field.
Return Value
The field.


OneColumnDiffView Class

OneColumnDiffView Class
Namespaces ► Sitecore.Text.Diff.View ► OneColumnDiffView
Represents a OneColumnDiffView.
Declaration Syntax
C#
public class OneColumnDiffView : DiffView
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | OneColumnDiffView()()() | Initializes a new instance of the OneColumnDiffView class
 | Append(StringBuilder, String, Int32, Int32, String) | Appends the specified builder. (Inherited from DiffView.)
 | Append(StringBuilder, String, Int32, Int32) | Appends the specified builder. (Inherited from DiffView.)
 | Compare(Control, Item, Item, String) | Compares the specified items. (Overrides DiffView.Compare(Control, Item, Item, String).)
 | Compare(String, String) | Compares the specified value1.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(String) | Gets the value. (Inherited from DiffView.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ShowField(Field) | Shows the field. (Overrides DiffView.ShowField(Field).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DiffView
 |  | OneColumnDiffView


OneColumnDiffView Constructor

OneColumnDiffView Constructor
Namespaces ► Sitecore.Text.Diff.View ► OneColumnDiffView ► OneColumnDiffView()()()
Initializes a new instance of the OneColumnDiffView class
Declaration Syntax
C#
public OneColumnDiffView()


Compare Method

Compare Method
Namespaces ► Sitecore.Text.Diff.View ► OneColumnDiffView ► Compare()()()
Members
Icon | Member | Description
 | Compare(Control, Item, Item, String) | Compares the specified items. (Overrides DiffView.Compare(Control, Item, Item, String).)
 | Compare(String, String) | Compares the specified value1.


Compare Method (value1, value2)

Compare Method (value1, value2)
Namespaces ► Sitecore.Text.Diff.View ► OneColumnDiffView ► Compare(String, String)
Compares the specified value1.
Declaration Syntax
C#
protected string Compare(
    string value1,
    string value2
)
Parameters
value1 (String)
The value1.
value2 (String)
The value2.
Return Value
The String.


Compare Method (parent, item1, item2, click)

Compare Method (parent, item1, item2, click)
Namespaces ► Sitecore.Text.Diff.View ► OneColumnDiffView ► Compare(Control, Item, Item, String)
Compares the specified items.
Declaration Syntax
C#
public override int Compare(
    Control parent,
    Item item1,
    Item item2,
    string click
)
Parameters
parent (Control)
The parent.
item1 (Item)
The item1.
item2 (Item)
The item2.
click (String)
The click.
Return Value
The result of the comparison.


ShowField Method (field)

ShowField Method (field)
Namespaces ► Sitecore.Text.Diff.View ► OneColumnDiffView ► ShowField(Field)
Shows the field.
Declaration Syntax
C#
protected override bool ShowField(
    Field field
)
Parameters
field (Field)
The field.
Return Value
The field.


TwoCoumnsDiffView Class

TwoCoumnsDiffView Class
Namespaces ► Sitecore.Text.Diff.View ► TwoCoumnsDiffView
Represents a TwoCoumnsDiffView.
Declaration Syntax
C#
public class TwoCoumnsDiffView : DiffView
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TwoCoumnsDiffView()()() | Initializes a new instance of the TwoCoumnsDiffView class
 | Append(StringBuilder, String, Int32, Int32, String) | Appends the specified builder. (Inherited from DiffView.)
 | Append(StringBuilder, String, Int32, Int32) | Appends the specified builder. (Inherited from DiffView.)
 | Compare(Control, Item, Item, String) | Compares the specified items. (Overrides DiffView.Compare(Control, Item, Item, String).)
 | Compare(String%, String%) | Compares the specified value1.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(String) | Gets the value. (Inherited from DiffView.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ShowField(Field) | Shows the field. (Inherited from DiffView.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DiffView
 |  | TwoCoumnsDiffView


TwoCoumnsDiffView Constructor

TwoCoumnsDiffView Constructor
Namespaces ► Sitecore.Text.Diff.View ► TwoCoumnsDiffView ► TwoCoumnsDiffView()()()
Initializes a new instance of the TwoCoumnsDiffView class
Declaration Syntax
C#
public TwoCoumnsDiffView()


Compare Method

Compare Method
Namespaces ► Sitecore.Text.Diff.View ► TwoCoumnsDiffView ► Compare()()()
Members
Icon | Member | Description
 | Compare(Control, Item, Item, String) | Compares the specified items. (Overrides DiffView.Compare(Control, Item, Item, String).)
 | Compare(String%, String%) | Compares the specified value1.


Compare Method (value1, value2)

Compare Method (value1, value2)
Namespaces ► Sitecore.Text.Diff.View ► TwoCoumnsDiffView ► Compare(String%, String%)
Compares the specified value1.
Declaration Syntax
C#
protected virtual void Compare(
    ref string value1,
    ref string value2
)
Parameters
value1 ( String %)
The value1.
value2 ( String %)
The value2.


Compare Method (parent, item1, item2, click)

Compare Method (parent, item1, item2, click)
Namespaces ► Sitecore.Text.Diff.View ► TwoCoumnsDiffView ► Compare(Control, Item, Item, String)
Compares the specified items.
Declaration Syntax
C#
public override int Compare(
    Control parent,
    Item item1,
    Item item2,
    string click
)
Parameters
parent (Control)
The parent.
item1 (Item)
The item1.
item2 (Item)
The item2.
click (String)
The click.
Return Value
The result of the comparison.


Sitecore.Text.NVelocity Namespace

Sitecore.Text.NVelocity Namespace
Namespaces ► Sitecore.Text.NVelocity
Declaration Syntax
C#
namespace Sitecore.Text.NVelocity
Types
All Types Classes
Icon | Type | Description
 | VelocityHelper | Velocity helper methods


VelocityHelper Class

VelocityHelper Class
Namespaces ► Sitecore.Text.NVelocity ► VelocityHelper
Velocity helper methods
Declaration Syntax
C#
public static class VelocityHelper
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Evaluate(VelocityContext, String, String) | Processes velocity template and returns the rendering result
 | PopulateFromSitecoreContext(VelocityContext) | Populates velocity context with Sitecore.Context properties
Inheritance Hierarchy
Object
VelocityHelper


Evaluate Method (context, template, logName)

Evaluate Method (context, template, logName)
Namespaces ► Sitecore.Text.NVelocity ► VelocityHelper ► Evaluate(VelocityContext, String, String)
Processes velocity template and returns the rendering result
Declaration Syntax
C#
public static string Evaluate(
    VelocityContext context,
    string template,
    string logName
)
Parameters
context (VelocityContext)
Populated velocity context
template (String)
Velocity template to process
logName (String)
Name that will be used to log the event
Return Value
Rendered template


PopulateFromSitecoreContext Method (context)

PopulateFromSitecoreContext Method (context)
Namespaces ► Sitecore.Text.NVelocity ► VelocityHelper ► PopulateFromSitecoreContext(VelocityContext)
Populates velocity context with Sitecore.Context properties
Declaration Syntax
C#
public static void PopulateFromSitecoreContext(
    VelocityContext context
)
Parameters
context (VelocityContext)
Velocity context to populate


Sitecore.Threading Namespace

Sitecore.Threading Namespace
Namespaces ► Sitecore.Threading
Declaration Syntax
C#
namespace Sitecore.Threading
Types
All Types Classes
Icon | Type | Description
 | BackgroundStatus | Represents the background thread status.
 | ThreadData..::.Keys | Represents the keys.
 | ManagedThreadPool | Managed thread pool.
 | Semaphore | Implementation of Dijkstra's PV Semaphore based on the Monitor class.
 | ThreadData | Represents the data of a thread.


BackgroundStatus Class

BackgroundStatus Class
Namespaces ► Sitecore.Threading ► BackgroundStatus
Represents the background thread status.
Declaration Syntax
C#
public class BackgroundStatus
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BackgroundStatus(Delegate) | Initializes a new instance of the BackgroundStatus class.
 | Delegate | Gets the delegate.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BackgroundStatus


BackgroundStatus Constructor (delegate)

BackgroundStatus Constructor (delegate)
Namespaces ► Sitecore.Threading ► BackgroundStatus ► BackgroundStatus(Delegate)
Initializes a new instance of the BackgroundStatus class.
Declaration Syntax
C#
public BackgroundStatus(
    Delegate delegate
)
Parameters
delegate (Delegate)
The _delegate.


Delegate Property

Delegate Property
Namespaces ► Sitecore.Threading ► BackgroundStatus ► Delegate
Gets the delegate.
Declaration Syntax
C#
public Object Delegate { get; }
Value
The delegate.


ManagedThreadPool Class

ManagedThreadPool Class
Namespaces ► Sitecore.Threading ► ManagedThreadPool
Managed thread pool.
Declaration Syntax
C#
public class ManagedThreadPool
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ManagedThreadPool()()() | Initializes a new instance of the ManagedThreadPool class
 | ActiveThreads | Gets the number of currently active threads in the thread pool.
 | EmptyQueue()()() | Empties the work queue of any queued work items.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MaxThreads | Gets the number of threads at the disposal of the thread pool.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MethodCallback(Object) | Callback for queued methods.
 | MethodCallback<(Of <(T>)>)(Object) | Callback for queued methods.
 | QueueUserWorkItem(WaitCallback) | Queues a user work item to the thread pool.
 | QueueUserWorkItem(WaitCallback, Object) | Queues a user work item to the thread pool.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitingCallbacks | Gets the number of callback delegates currently waiting in the thread pool.
Inheritance Hierarchy
Object
ManagedThreadPool


ManagedThreadPool Constructor

ManagedThreadPool Constructor
Namespaces ► Sitecore.Threading ► ManagedThreadPool ► ManagedThreadPool()()()
Initializes a new instance of the ManagedThreadPool class
Declaration Syntax
C#
public ManagedThreadPool()


ActiveThreads Property

ActiveThreads Property
Namespaces ► Sitecore.Threading ► ManagedThreadPool ► ActiveThreads
Gets the number of currently active threads in the thread pool.
Declaration Syntax
C#
public static int ActiveThreads { get; }


EmptyQueue Method

EmptyQueue Method
Namespaces ► Sitecore.Threading ► ManagedThreadPool ► EmptyQueue()()()
Empties the work queue of any queued work items.
Declaration Syntax
C#
public static void EmptyQueue()


MaxThreads Property

MaxThreads Property
Namespaces ► Sitecore.Threading ► ManagedThreadPool ► MaxThreads
Gets the number of threads at the disposal of the thread pool.
Declaration Syntax
C#
public static int MaxThreads { get; }


MethodCallback Method

MethodCallback Method
Namespaces ► Sitecore.Threading ► ManagedThreadPool ► MethodCallback()()()
Members
Icon | Member | Description
 | MethodCallback(Object) | Callback for queued methods.
 | MethodCallback<(Of <(T>)>)(Object) | Callback for queued methods.


MethodCallback Method (state)

MethodCallback<(Of <(T>)>) Method (state)
Namespaces ► Sitecore.Threading ► ManagedThreadPool ► MethodCallback<(Of <(T>)>)(Object)
Callback for queued methods.
Declaration Syntax
C#
public static void MethodCallback<T>(
    Object state
)
Generic Template Parameters
T
Parameters
state (Object)
The state.


MethodCallback Method (state)

MethodCallback Method (state)
Namespaces ► Sitecore.Threading ► ManagedThreadPool ► MethodCallback(Object)
Callback for queued methods.
Declaration Syntax
C#
public static void MethodCallback(
    Object state
)
Parameters
state (Object)
The state.


QueueUserWorkItem Method

QueueUserWorkItem Method
Namespaces ► Sitecore.Threading ► ManagedThreadPool ► QueueUserWorkItem()()()
Members
Icon | Member | Description
 | QueueUserWorkItem(WaitCallback) | Queues a user work item to the thread pool.
 | QueueUserWorkItem(WaitCallback, Object) | Queues a user work item to the thread pool.


QueueUserWorkItem Method (callback)

QueueUserWorkItem Method (callback)
Namespaces ► Sitecore.Threading ► ManagedThreadPool ► QueueUserWorkItem(WaitCallback)
Queues a user work item to the thread pool.
Declaration Syntax
C#
public static void QueueUserWorkItem(
    WaitCallback callback
)
Parameters
callback (WaitCallback)
A WaitCallback representing the delegate to invoke when the thread in the thread pool picks up the work item.


QueueUserWorkItem Method (callback, state)

QueueUserWorkItem Method (callback, state)
Namespaces ► Sitecore.Threading ► ManagedThreadPool ► QueueUserWorkItem(WaitCallback, Object)
Queues a user work item to the thread pool.
Declaration Syntax
C#
public static void QueueUserWorkItem(
    WaitCallback callback,
    Object state
)
Parameters
callback (WaitCallback)
A WaitCallback representing the delegate to invoke when the thread in the thread pool picks up the work item.
state (Object)
The object that is passed to the delegate when serviced from the thread pool.


WaitingCallbacks Property

WaitingCallbacks Property
Namespaces ► Sitecore.Threading ► ManagedThreadPool ► WaitingCallbacks
Gets the number of callback delegates currently waiting in the thread pool.
Declaration Syntax
C#
public static int WaitingCallbacks { get; }


Semaphore Class

Semaphore Class
Namespaces ► Sitecore.Threading ► Semaphore
Implementation of Dijkstra's PV Semaphore based on the Monitor class.
Declaration Syntax
C#
public class Semaphore
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Semaphore()()() | Initialize the semaphore as a binary semaphore.
 | Semaphore(Int32) | Initialize the semaphore as a counting semaphore.
 | AddOne()()() | V the semaphore (add 1 unit to it).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | P()()() | P the semaphore (take out 1 unit from it).
 | Reset(Int32) | Resets the semaphore to the specified count. Should be used cautiously.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | V()()() | V the semaphore (add 1 unit to it).
 | WaitOne()()() | P the semaphore (take out 1 unit from it).
Inheritance Hierarchy
Object
Semaphore


Semaphore Constructor

Semaphore Constructor
Namespaces ► Sitecore.Threading ► Semaphore ► Semaphore()()()
Members
Icon | Member | Description
 | Semaphore()()() | Initialize the semaphore as a binary semaphore.
 | Semaphore(Int32) | Initialize the semaphore as a counting semaphore.


Semaphore Constructor

Semaphore Constructor
Namespaces ► Sitecore.Threading ► Semaphore ► Semaphore()()()
Initialize the semaphore as a binary semaphore.
Declaration Syntax
C#
public Semaphore()


Semaphore Constructor (count)

Semaphore Constructor (count)
Namespaces ► Sitecore.Threading ► Semaphore ► Semaphore(Int32)
Initialize the semaphore as a counting semaphore.
Declaration Syntax
C#
public Semaphore(
    int count
)
Parameters
count (Int32)
Initial number of threads that can take out units from this semaphore.
Exceptions
Exception | Condition
ArgumentException | Throws if the count argument is less than 1.


AddOne Method

AddOne Method
Namespaces ► Sitecore.Threading ► Semaphore ► AddOne()()()
V the semaphore (add 1 unit to it).
Declaration Syntax
C#
public void AddOne()


P Method

P Method
Namespaces ► Sitecore.Threading ► Semaphore ► P()()()
P the semaphore (take out 1 unit from it).
Declaration Syntax
C#
public void P()


Reset Method (count)

Reset Method (count)
Namespaces ► Sitecore.Threading ► Semaphore ► Reset(Int32)
Resets the semaphore to the specified count. Should be used cautiously.
Declaration Syntax
C#
public void Reset(
    int count
)
Parameters
count (Int32)


V Method

V Method
Namespaces ► Sitecore.Threading ► Semaphore ► V()()()
V the semaphore (add 1 unit to it).
Declaration Syntax
C#
public void V()


WaitOne Method

WaitOne Method
Namespaces ► Sitecore.Threading ► Semaphore ► WaitOne()()()
P the semaphore (take out 1 unit from it).
Declaration Syntax
C#
public void WaitOne()


ThreadData Class

ThreadData Class
Namespaces ► Sitecore.Threading ► ThreadData
Represents the data of a thread.
Declaration Syntax
C#
public class ThreadData
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ThreadData()()() | Initializes a new instance of the ThreadData class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetData(String) | Gets the data.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetData(String, Object) | Sets the data.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ThreadData


ThreadData Constructor

ThreadData Constructor
Namespaces ► Sitecore.Threading ► ThreadData ► ThreadData()()()
Initializes a new instance of the ThreadData class
Declaration Syntax
C#
public ThreadData()


GetData Method (key)

GetData Method (key)
Namespaces ► Sitecore.Threading ► ThreadData ► GetData(String)
Gets the data.
Declaration Syntax
C#
public static Object GetData(
    string key
)
Parameters
key (String)
The key.
Return Value
The data.


SetData Method (key, data)

SetData Method (key, data)
Namespaces ► Sitecore.Threading ► ThreadData ► SetData(String, Object)
Sets the data.
Declaration Syntax
C#
public static void SetData(
    string key,
    Object data
)
Parameters
key (String)
The key.
data (Object)
The data.


ThreadData.Keys Class

ThreadData..::.Keys Class
Namespaces ► Sitecore.Threading ► ThreadData ► ThreadData..::.Keys
Represents the keys.
Declaration Syntax
C#
public class Keys
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ThreadData..::.Keys()()() | Initializes a new instance of the ThreadData..::.Keys class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Items | "sc_items".
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ThreadData..::.Keys


ThreadData.Keys Constructor

ThreadData..::.Keys Constructor
Namespaces ► Sitecore.Threading ► ThreadData..::.Keys ► ThreadData..::.Keys()()()
Initializes a new instance of the ThreadData..::.Keys class
Declaration Syntax
C#
public Keys()


Items Field

Items Field
Namespaces ► Sitecore.Threading ► ThreadData..::.Keys ► Items
"sc_items".
Declaration Syntax
C#
public const string Items


Sitecore.UnitTest Namespace

Sitecore.UnitTest Namespace
Namespaces ► Sitecore.UnitTest
Declaration Syntax
C#
namespace Sitecore.UnitTest
Types
All Types Classes
Icon | Type | Description
 | TestRunner | Test runner page


TestRunner Class

TestRunner Class
Namespaces ► Sitecore.UnitTest ► TestRunner
Test runner page
Declaration Syntax
C#
public class TestRunner : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TestRunner()()() | Initializes a new instance of the TestRunner class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | main | main control.
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | Result | Result control.
 | RunButton | RunButton control.
 | RunButton_Click(Object, EventArgs) | Handles the Click event of the RunButton control.
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | TestName | TestName control.
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | TestRunner

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TestRunner Constructor

TestRunner Constructor
Namespaces ► Sitecore.UnitTest ► TestRunner ► TestRunner()()()
Initializes a new instance of the TestRunner class
Declaration Syntax
C#
public TestRunner()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


main Field

main Field
Namespaces ► Sitecore.UnitTest ► TestRunner ► main
main control.
Declaration Syntax
C#
protected HtmlForm main
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Result Field

Result Field
Namespaces ► Sitecore.UnitTest ► TestRunner ► Result
Result control.
Declaration Syntax
C#
protected HtmlGenericControl Result
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RunButton Field

RunButton Field
Namespaces ► Sitecore.UnitTest ► TestRunner ► RunButton
RunButton control.
Declaration Syntax
C#
protected Button RunButton
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RunButton_Click Method (sender, e)

RunButton_Click Method (sender, e)
Namespaces ► Sitecore.UnitTest ► TestRunner ► RunButton_Click(Object, EventArgs)
Handles the Click event of the RunButton control.
Declaration Syntax
C#
protected void RunButton_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


TestName Field

TestName Field
Namespaces ► Sitecore.UnitTest ► TestRunner ► TestName
TestName control.
Declaration Syntax
C#
protected TextBox TestName
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Visual Namespace

Sitecore.Visual Namespace
Namespaces ► Sitecore.Visual
Declaration Syntax
C#
namespace Sitecore.Visual
Types
All Types Classes
Icon | Type | Description
 | Service |


Service Class

Service Class
Namespaces ► Sitecore.Visual ► Service
Declaration Syntax
C#
public class Service : WebService
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Service()()() | Initializes a new instance of the Service class
 | AddFromMaster(String, String, String, String, Credentials) |
 | AddFromTemplate(String, String, String, String, Credentials) |
 | AddVersion(String, String, String, Credentials) |
 | Application | Gets the application object for the current HTTP request. (Inherited from WebService.)
 | Container | Gets the container for the component. (Inherited from MarshalByValueComponent.)
 | Context | Gets the ASP.NET HttpContext for the current request, which encapsulates all HTTP-specific context used by the HTTP server to process Web requests. (Inherited from WebService.)
 | CopyTo(String, String, String, String, Credentials) |
 | Delete(String, Boolean, String, Credentials) |
 | DeleteChildren(String, String, Credentials) |
 | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | (Overrides MarshalByValueComponent.Dispose(Boolean).)
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent. (Inherited from MarshalByValueComponent.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from MarshalByValueComponent.)
 | Duplicate(String, String, String, Credentials) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this component. (Inherited from MarshalByValueComponent.)
 | Finalize()()() | [To be supplied.] (Inherited from MarshalByValueComponent.)
 | GetChildren(String, String, Credentials) |
 | GetDatabases(Credentials) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemFields(String, String, String, Boolean, String, Credentials) |
 | GetItemMasters(String, String, Credentials) |
 | GetLanguages(String, Credentials) |
 | GetMasters(String, Credentials) |
 | GetService(Type) | Gets the implementer of the IServiceProvider. (Inherited from MarshalByValueComponent.)
 | GetTemplates(String, Credentials) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXML(String, Boolean, String, Credentials) |
 | InsertXML(String, String, Boolean, String, Credentials) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveTo(String, String, String, Credentials) |
 | RemoveVersion(String, String, String, String, Credentials) |
 | Rename(String, String, String, Credentials) |
 | Save(String, String, Credentials) |
 | Server | Gets the HttpServerUtility for the current request. (Inherited from WebService.)
 | Session | Gets the HttpSessionState instance for the current request. (Inherited from WebService.)
 | Site | Gets or sets the site of the component. (Inherited from MarshalByValueComponent.)
 | SoapVersion | Gets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from WebService.)
 | ToString()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from MarshalByValueComponent.)
 | User | Gets the ASP.NET server User object. Can be used to authenticate whether a user is authorized to execute the request. (Inherited from WebService.)
 | VerifyCredentials(Credentials) |
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | WebService
 |  |  | Service

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Service Constructor

Service Constructor
Namespaces ► Sitecore.Visual ► Service ► Service()()()
Initializes a new instance of the Service class
Declaration Syntax
C#
public Service()

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AddFromMaster Method (id, masterID, name, databaseName, credentials)

AddFromMaster Method (id, masterID, name, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► AddFromMaster(String, String, String, String, Credentials)
Declaration Syntax
C#
public XmlDocument AddFromMaster(
    string id,
    string masterID,
    string name,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
masterID (String)
name (String)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AddFromTemplate Method (id, templateID, name, databaseName, credentials)

AddFromTemplate Method (id, templateID, name, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► AddFromTemplate(String, String, String, String, Credentials)
Declaration Syntax
C#
public XmlDocument AddFromTemplate(
    string id,
    string templateID,
    string name,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
templateID (String)
name (String)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


AddVersion Method (id, language, databaseName, credentials)

AddVersion Method (id, language, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► AddVersion(String, String, String, Credentials)
Declaration Syntax
C#
public XmlDocument AddVersion(
    string id,
    string language,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
language (String)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


CopyTo Method (id, newParent, name, databaseName, credentials)

CopyTo Method (id, newParent, name, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► CopyTo(String, String, String, String, Credentials)
Declaration Syntax
C#
public XmlDocument CopyTo(
    string id,
    string newParent,
    string name,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
newParent (String)
name (String)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Delete Method (id, recycle, databaseName, credentials)

Delete Method (id, recycle, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► Delete(String, Boolean, String, Credentials)
Declaration Syntax
C#
public XmlDocument Delete(
    string id,
    bool recycle,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
recycle (Boolean)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


DeleteChildren Method (id, databaseName, credentials)

DeleteChildren Method (id, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► DeleteChildren(String, String, Credentials)
Declaration Syntax
C#
public XmlDocument DeleteChildren(
    string id,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Sitecore.Visual ► Service ► Dispose(Boolean)
Declaration Syntax
C#
protected override void Dispose(
    bool disposing
)
Parameters
disposing (Boolean)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Duplicate Method (id, name, databaseName, credentials)

Duplicate Method (id, name, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► Duplicate(String, String, String, Credentials)
Declaration Syntax
C#
public XmlDocument Duplicate(
    string id,
    string name,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
name (String)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetChildren Method (id, databaseName, credentials)

GetChildren Method (id, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► GetChildren(String, String, Credentials)
Declaration Syntax
C#
public XmlDocument GetChildren(
    string id,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetDatabases Method (credentials)

GetDatabases Method (credentials)
Namespaces ► Sitecore.Visual ► Service ► GetDatabases(Credentials)
Declaration Syntax
C#
public XmlDocument GetDatabases(
    Credentials credentials
)
Parameters
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetItemFields Method (id, language, version, allFields, databaseName, credentials)

GetItemFields Method (id, language, version, allFields, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► GetItemFields(String, String, String, Boolean, String, Credentials)
Declaration Syntax
C#
public XmlDocument GetItemFields(
    string id,
    string language,
    string version,
    bool allFields,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
language (String)
version (String)
allFields (Boolean)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetItemMasters Method (id, databaseName, credentials)

GetItemMasters Method (id, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► GetItemMasters(String, String, Credentials)
Declaration Syntax
C#
public XmlDocument GetItemMasters(
    string id,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetLanguages Method (databaseName, credentials)

GetLanguages Method (databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► GetLanguages(String, Credentials)
Declaration Syntax
C#
public XmlDocument GetLanguages(
    string databaseName,
    Credentials credentials
)
Parameters
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetMasters Method (databaseName, credentials)

GetMasters Method (databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► GetMasters(String, Credentials)
Declaration Syntax
C#
public XmlDocument GetMasters(
    string databaseName,
    Credentials credentials
)
Parameters
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetTemplates Method (databaseName, credentials)

GetTemplates Method (databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► GetTemplates(String, Credentials)
Declaration Syntax
C#
public XmlDocument GetTemplates(
    string databaseName,
    Credentials credentials
)
Parameters
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


GetXML Method (id, deep, databaseName, credentials)

GetXML Method (id, deep, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► GetXML(String, Boolean, String, Credentials)
Declaration Syntax
C#
public XmlDocument GetXML(
    string id,
    bool deep,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
deep (Boolean)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


InsertXML Method (id, xml, changeIDs, databaseName, credentials)

InsertXML Method (id, xml, changeIDs, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► InsertXML(String, String, Boolean, String, Credentials)
Declaration Syntax
C#
public XmlDocument InsertXML(
    string id,
    string xml,
    bool changeIDs,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
xml (String)
changeIDs (Boolean)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


MoveTo Method (id, newParent, databaseName, credentials)

MoveTo Method (id, newParent, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► MoveTo(String, String, String, Credentials)
Declaration Syntax
C#
public XmlDocument MoveTo(
    string id,
    string newParent,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
newParent (String)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


RemoveVersion Method (id, language, version, databaseName, credentials)

RemoveVersion Method (id, language, version, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► RemoveVersion(String, String, String, String, Credentials)
Declaration Syntax
C#
public XmlDocument RemoveVersion(
    string id,
    string language,
    string version,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
language (String)
version (String)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Rename Method (id, newName, databaseName, credentials)

Rename Method (id, newName, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► Rename(String, String, String, Credentials)
Declaration Syntax
C#
public XmlDocument Rename(
    string id,
    string newName,
    string databaseName,
    Credentials credentials
)
Parameters
id (String)
newName (String)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Save Method (xml, databaseName, credentials)

Save Method (xml, databaseName, credentials)
Namespaces ► Sitecore.Visual ► Service ► Save(String, String, Credentials)
Declaration Syntax
C#
public XmlDocument Save(
    string xml,
    string databaseName,
    Credentials credentials
)
Parameters
xml (String)
databaseName (String)
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


VerifyCredentials Method (credentials)

VerifyCredentials Method (credentials)
Namespaces ► Sitecore.Visual ► Service ► VerifyCredentials(Credentials)
Declaration Syntax
C#
public XmlDocument VerifyCredentials(
    Credentials credentials
)
Parameters
credentials (Credentials)

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.

Assembly: Sitecore.Client (Module: Sitecore.Client) Version: 6.0.0.0 (6.1.0.3011)


Sitecore.Visualization Namespace

Sitecore.Visualization Namespace
Namespaces ► Sitecore.Visualization
Declaration Syntax
C#
namespace Sitecore.Visualization
Types
All Types Classes
Icon | Type | Description
 | ItemPainter | ItemPainter
 | LayoutManager | LayoutManager
 | Rendering | Rendering
 | Rule | Rule
 | RuleExecution | RuleExecution
 | RuleManager | RulesManager
 | RuleSet | RuleSet


ItemPainter Class

ItemPainter Class
Namespaces ► Sitecore.Visualization ► ItemPainter
ItemPainter
Declaration Syntax
C#
public class ItemPainter : WebControl,
    IHasDynamicChildControls
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemPainter()()() | Initializes a new instance of the ItemPainter class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextItem | Gets the current context item.
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Overrides Control.CreateChildControls()()().)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control to the specified HTML writer. (Overrides WebControl.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureDynamicChildControls()()() | Ensures that any dynamic child controls has been created.
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | Mode | Gets or sets the rendering mode.
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Overrides WebControl.RenderingName.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | ItemPainter


ItemPainter Constructor

ItemPainter Constructor
Namespaces ► Sitecore.Visualization ► ItemPainter ► ItemPainter()()()
Initializes a new instance of the ItemPainter class
Declaration Syntax
C#
public ItemPainter()


ContextItem Property

ContextItem Property
Namespaces ► Sitecore.Visualization ► ItemPainter ► ContextItem
Gets the current context item.
Declaration Syntax
C#
protected virtual Item ContextItem { get; }
Value
The context item.


CreateChildControls Method

CreateChildControls Method
Namespaces ► Sitecore.Visualization ► ItemPainter ► CreateChildControls()()()
Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
Declaration Syntax
C#
protected override void CreateChildControls()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Visualization ► ItemPainter ► DoRender(HtmlTextWriter)
Renders the control to the specified HTML writer.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the control content.


EnsureDynamicChildControls Method

EnsureDynamicChildControls Method
Namespaces ► Sitecore.Visualization ► ItemPainter ► EnsureDynamicChildControls()()()
Ensures that any dynamic child controls has been created.
Declaration Syntax
C#
public virtual void EnsureDynamicChildControls()


Mode Property

Mode Property
Namespaces ► Sitecore.Visualization ► ItemPainter ► Mode
Gets or sets the rendering mode.
Declaration Syntax
C#
public string Mode { get; set; }
Value
The mode.


RenderingName Property

RenderingName Property
Namespaces ► Sitecore.Visualization ► ItemPainter ► RenderingName
Gets or sets the name of the rendering.
Declaration Syntax
C#
public override string RenderingName { get; }
Value
The name of the rendering.


LayoutManager Class

LayoutManager Class
Namespaces ► Sitecore.Visualization ► LayoutManager
LayoutManager
Declaration Syntax
C#
public static class LayoutManager
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetRendering(String, Database) | Gets the rendering.
Inheritance Hierarchy
Object
LayoutManager


GetRendering Method (fullName, database)

GetRendering Method (fullName, database)
Namespaces ► Sitecore.Visualization ► LayoutManager ► GetRendering(String, Database)
Gets the rendering.
Declaration Syntax
C#
public static Rendering GetRendering(
    string fullName,
    Database database
)
Parameters
fullName (String)
The full name.
database (Database)
The database.
Return Value


Rendering Class

Rendering Class
Namespaces ► Sitecore.Visualization ► Rendering
Rendering
Declaration Syntax
C#
public class Rendering
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Rendering(Item) | Initializes a new instance of the Rendering class.
 | DataSource | Gets or sets the data source.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetControl()()() | Gets the control associated with the rendering.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Rendering


Rendering Constructor (definition)

Rendering Constructor (definition)
Namespaces ► Sitecore.Visualization ► Rendering ► Rendering(Item)
Initializes a new instance of the Rendering class.
Declaration Syntax
C#
public Rendering(
    Item definition
)
Parameters
definition (Item)


DataSource Property

DataSource Property
Namespaces ► Sitecore.Visualization ► Rendering ► DataSource
Gets or sets the data source.
Declaration Syntax
C#
public string DataSource { get; set; }
Value
The data source.


GetControl Method

GetControl Method
Namespaces ► Sitecore.Visualization ► Rendering ► GetControl()()()
Gets the control associated with the rendering.
Declaration Syntax
C#
public Control GetControl()
Return Value


Rule Class

Rule Class
Namespaces ► Sitecore.Visualization ► Rule
Rule
Declaration Syntax
C#
public class Rule
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Rule()()() | Initializes a new instance of the Rule class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Rule


Rule Constructor

Rule Constructor
Namespaces ► Sitecore.Visualization ► Rule ► Rule()()()
Initializes a new instance of the Rule class
Declaration Syntax
C#
public Rule()


RuleExecution Class

RuleExecution Class
Namespaces ► Sitecore.Visualization ► RuleExecution
RuleExecution
Declaration Syntax
C#
public class RuleExecution
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RuleExecution(Object) | Initializes a new instance of the RuleExecution class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ThisObject | Gets the current object to be executed.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RuleExecution


RuleExecution Constructor (thisObject)

RuleExecution Constructor (thisObject)
Namespaces ► Sitecore.Visualization ► RuleExecution ► RuleExecution(Object)
Initializes a new instance of the RuleExecution class.
Declaration Syntax
C#
public RuleExecution(
    Object thisObject
)
Parameters
thisObject (Object)
The this object.


ThisObject Property

ThisObject Property
Namespaces ► Sitecore.Visualization ► RuleExecution ► ThisObject
Gets the current object to be executed.
Declaration Syntax
C#
public Object ThisObject { get; }
Value
The current object to be executed.


RuleManager Class

RuleManager Class
Namespaces ► Sitecore.Visualization ► RuleManager
RulesManager
Declaration Syntax
C#
public static class RuleManager
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Execute(Object) | Executes the rules associated with the specified object.
 | GetRuleSet(Object) | Gets a rule set.
Inheritance Hierarchy
Object
RuleManager


Execute Method (thisObject)

Execute Method (thisObject)
Namespaces ► Sitecore.Visualization ► RuleManager ► Execute(Object)
Executes the rules associated with the specified object.
Declaration Syntax
C#
public static void Execute(
    Object thisObject
)
Parameters
thisObject (Object)
The object to execute rules for.


GetRuleSet Method (thisObject)

GetRuleSet Method (thisObject)
Namespaces ► Sitecore.Visualization ► RuleManager ► GetRuleSet(Object)
Gets a rule set.
Declaration Syntax
C#
public static RuleSet GetRuleSet(
    Object thisObject
)
Parameters
thisObject (Object)
The object to be executed.
Return Value


RuleSet Class

RuleSet Class
Namespaces ► Sitecore.Visualization ► RuleSet
RuleSet
Declaration Syntax
C#
public class RuleSet
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RuleSet()()() | Initializes a new instance of the RuleSet class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(RuleExecution) | Executes the rule set with the specified context.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RuleSet


RuleSet Constructor

RuleSet Constructor
Namespaces ► Sitecore.Visualization ► RuleSet ► RuleSet()()()
Initializes a new instance of the RuleSet class
Declaration Syntax
C#
public RuleSet()


Execute Method (context)

Execute Method (context)
Namespaces ► Sitecore.Visualization ► RuleSet ► Execute(RuleExecution)
Executes the rule set with the specified context.
Declaration Syntax
C#
public void Execute(
    RuleExecution context
)
Parameters
context (RuleExecution)
The context.


Sitecore.Web Namespace

Sitecore.Web Namespace
Namespaces ► Sitecore.Web
Declaration Syntax
C#
namespace Sitecore.Web
Types
All Types Classes Interfaces
Icon | Type | Description
 | CustomHandler | RequestHandler
 | FormAdapter | FormAdapter class
 | FormAdapter..::.FormAdapterHtmlWriter | FormAdapterHtmlWriter class
 | HtmlUtil | Implements a utility class for manipulating HTML.
 | InvalidLinkFormatException | InvalidLinkFormatException
 | IPageHandler | Interface for a page handler
 | PathData | PathData
 | RequestFilter | RequestFilter class
 | RequestUrl | RequestUrl
 | ShutdownDetector | Class used for detecting AppDomain shutdown.
 | SiteInfo | Information about site (used when specifying multiple sites in web.config).
 | UrlHandle | Represents a UrlHandle.
 | WebUtil | Implements a library of standard utility functions relating to Web operations.


CustomHandler Class

CustomHandler Class
Namespaces ► Sitecore.Web ► CustomHandler
RequestHandler
Declaration Syntax
C#
public class CustomHandler
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomHandler(String, String) | Initializes a new instance of the CustomHandler class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Handler | The actual handler.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trigger | Gets the trigger string.
Inheritance Hierarchy
Object
CustomHandler


CustomHandler Constructor (trigger, handler)

CustomHandler Constructor (trigger, handler)
Namespaces ► Sitecore.Web ► CustomHandler ► CustomHandler(String, String)
Initializes a new instance of the CustomHandler class.
Declaration Syntax
C#
public CustomHandler(
    string trigger,
    string handler
)
Parameters
trigger (String)
handler (String)


Handler Property

Handler Property
Namespaces ► Sitecore.Web ► CustomHandler ► Handler
The actual handler.
Declaration Syntax
C#
public string Handler { get; }
Value
The handler.
Remarks
This will typically be the name of an ASHX (ex. 'sitecore_media.ashx').


Trigger Property

Trigger Property
Namespaces ► Sitecore.Web ► CustomHandler ► Trigger
Gets the trigger string.
Declaration Syntax
C#
public string Trigger { get; }
Value
The trigger.
Remarks
If this string is contained in an incoming URL, the handler should be called.


FormAdapter Class

FormAdapter Class
Namespaces ► Sitecore.Web ► FormAdapter
FormAdapter class
Declaration Syntax
C#
public class FormAdapter : ControlAdapter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FormAdapter()()() | Initializes a new instance of the FormAdapter class
 | BeginRender(HtmlTextWriter) | Called prior to the rendering of a control. In a derived adapter class, generates opening tags that are required by a specific target but not needed by HTML browsers. (Inherited from ControlAdapter.)
 | Browser | Gets a reference to the browser capabilities of the client making the current HTTP request. (Inherited from ControlAdapter.)
 | Control | Gets a reference to the control to which this control adapter is attached. (Inherited from ControlAdapter.)
 | CreateChildControls()()() | Creates the target-specific child controls for a composite control. (Inherited from ControlAdapter.)
 | EndRender(HtmlTextWriter) | Called after the rendering of a control. In a derived adapter class, generates closing tags that are required by a specific target but not needed by HTML browsers. (Inherited from ControlAdapter.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoadAdapterControlState(Object) | Loads adapter control state information that was saved by SaveAdapterControlState()()() during a previous request to the page where the control associated with this control adapter resides. (Inherited from ControlAdapter.)
 | LoadAdapterViewState(Object) | Loads adapter view state information that was saved by SaveAdapterViewState()()() during a previous request to the page where the control associated with this control adapter resides. (Inherited from ControlAdapter.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnInit(EventArgs) | Overrides the OnInit(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | OnLoad(EventArgs) | Overrides the OnLoad(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | OnPreRender(EventArgs) | Overrides the OnPreRender(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | OnUnload(EventArgs) | Overrides the OnUnload(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | Page | Gets a reference to the page where the control associated with this adapter resides. (Inherited from ControlAdapter.)
 | PageAdapter | Gets a reference to the page adapter for the page where the associated control resides. (Inherited from ControlAdapter.)
 | Render(HtmlTextWriter) | Generates the target-specific markup for the control to which the control adapter is attached. (Overrides ControlAdapter.Render(HtmlTextWriter).)
 | RenderChildren(HtmlTextWriter) | Generates the target-specific markup for the child controls in a composite control to which the control adapter is attached. (Inherited from ControlAdapter.)
 | SaveAdapterControlState()()() | Saves control state information for the control adapter. (Inherited from ControlAdapter.)
 | SaveAdapterViewState()()() | Saves view state information for the control adapter. (Inherited from ControlAdapter.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlAdapter
 |  | FormAdapter


FormAdapter Constructor

FormAdapter Constructor
Namespaces ► Sitecore.Web ► FormAdapter ► FormAdapter()()()
Initializes a new instance of the FormAdapter class
Declaration Syntax
C#
public FormAdapter()


Render Method (writer)

Render Method (writer)
Namespaces ► Sitecore.Web ► FormAdapter ► Render(HtmlTextWriter)
Generates the target-specific markup for the control to which the control adapter is attached.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)
The HtmlTextWriter to use to render the target-specific output.


FormAdapter.FormAdapterHtmlWriter Class

FormAdapter..::.FormAdapterHtmlWriter Class
Namespaces ► Sitecore.Web ► FormAdapter ► FormAdapter..::.FormAdapterHtmlWriter
FormAdapterHtmlWriter class
Declaration Syntax
C#
public class FormAdapterHtmlWriter : HtmlTextWriter
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FormAdapter..::.FormAdapterHtmlWriter(TextWriter) | Initializes a new instance of the FormAdapter..::.FormAdapterHtmlWriter class.
 | AddAttribute(String, String) | Adds the specified markup attribute and value to the opening tag of the element that the HtmlTextWriter object creates with a subsequent call to the RenderBeginTag()()() method. (Inherited from HtmlTextWriter.)
 | AddAttribute(String, String, Boolean) | Adds the specified markup attribute and value to the opening tag of the element that the HtmlTextWriter object creates with a subsequent call to the RenderBeginTag()()() method, with optional encoding. (Inherited from HtmlTextWriter.)
 | AddAttribute(HtmlTextWriterAttribute, String) | Adds the markup attribute and the attribute value to the opening tag of the element that the HtmlTextWriter object creates with a subsequent call to the RenderBeginTag()()() method. (Inherited from HtmlTextWriter.)
 | AddAttribute(HtmlTextWriterAttribute, String, Boolean) | Adds the markup attribute and the attribute value to the opening tag of the element that the HtmlTextWriter object creates with a subsequent call to the RenderBeginTag()()() method, with optional encoding. (Inherited from HtmlTextWriter.)
 | AddAttribute(String, String, HtmlTextWriterAttribute) | Adds the specified markup attribute and value, along with an HtmlTextWriterAttribute enumeration value, to the opening tag of the element that the HtmlTextWriter object creates with a subsequent call to the RenderBeginTag()()() method. (Inherited from HtmlTextWriter.)
 | AddStyleAttribute(String, String) | Adds the specified markup style attribute and the attribute value to the opening markup tag created by a subsequent call to the RenderBeginTag()()() method. (Inherited from HtmlTextWriter.)
 | AddStyleAttribute(HtmlTextWriterStyle, String) | Adds the markup style attribute associated with the specified HtmlTextWriterStyle value and the attribute value to the opening markup tag created by a subsequent call to the RenderBeginTag()()() method. (Inherited from HtmlTextWriter.)
 | AddStyleAttribute(String, String, HtmlTextWriterStyle) | Adds the specified markup style attribute and the attribute value, along with an HtmlTextWriterStyle enumeration value, to the opening markup tag created by a subsequent call to the RenderBeginTag()()() method. (Inherited from HtmlTextWriter.)
 | BeginRender()()() | Notifies an HtmlTextWriter object, or an object of a derived class, that a control is about to be rendered. (Inherited from HtmlTextWriter.)
 | Close()()() | Closes the HtmlTextWriter object and releases any system resources associated with it. (Inherited from HtmlTextWriter.)
 | CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from TextWriter.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the TextWriter and optionally releases the managed resources. (Inherited from TextWriter.)
 | Dispose()()() | Releases all resources used by the TextWriter object. (Inherited from TextWriter.)
 | EncodeAttributeValue(String, Boolean) | Encodes the value of the specified markup attribute based on the requirements of the HttpRequest object of the current context. (Inherited from HtmlTextWriter.)
 | EncodeAttributeValue(HtmlTextWriterAttribute, String) | Encodes the value of the specified markup attribute based on the requirements of the HttpRequest object of the current context. (Inherited from HtmlTextWriter.)
 | EncodeUrl(String) | Performs minimal URL encoding by converting spaces in the specified URL to the string "%20". (Inherited from HtmlTextWriter.)
 | Encoding | Gets the encoding that the HtmlTextWriter object uses to write content to the page. (Inherited from HtmlTextWriter.)
 | EndRender()()() | Notifies an HtmlTextWriter object, or an object of a derived class, that a control has finished rendering. You can use this method to close any markup elements opened in the BeginRender()()() method. (Inherited from HtmlTextWriter.)
 | EnterStyle(Style, HtmlTextWriterTag) | Writes the opening tag of a markup element that contains attributes that implement the layout and character formatting of the specified style. (Inherited from HtmlTextWriter.)
 | EnterStyle(Style) | Writes the opening tag of a <span> element that contains attributes that implement the layout and character formatting of the specified style. (Inherited from HtmlTextWriter.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExitStyle(Style, HtmlTextWriterTag) | Writes the closing tag of the specified markup element to end the specified layout and character formatting. (Inherited from HtmlTextWriter.)
 | ExitStyle(Style) | Writes the closing tag of a <span> element to end the specified layout and character formatting. (Inherited from HtmlTextWriter.)
 | FilterAttributes()()() | Removes all the markup and style attributes on all properties of the page or Web server control. (Inherited from HtmlTextWriter.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()() | Clears all buffers for the current HtmlTextWriter object and causes any buffered data to be written to the output stream. (Inherited from HtmlTextWriter.)
 | FormatProvider | Gets an object that controls formatting. (Inherited from TextWriter.)
 | GetAttributeKey(String) | Obtains the corresponding HtmlTextWriterAttribute enumeration value for the specified attribute. (Inherited from HtmlTextWriter.)
 | GetAttributeName(HtmlTextWriterAttribute) | Obtains the name of the markup attribute associated with the specified HtmlTextWriterAttribute value. (Inherited from HtmlTextWriter.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetStyleKey(String) | Obtains the HtmlTextWriterStyle enumeration value for the specified style. (Inherited from HtmlTextWriter.)
 | GetStyleName(HtmlTextWriterStyle) | Obtains the markup style attribute name associated with the specified HtmlTextWriterStyle enumeration value. (Inherited from HtmlTextWriter.)
 | GetTagKey(String) | Obtains the HtmlTextWriterTag enumeration value associated with the specified markup element. (Inherited from HtmlTextWriter.)
 | GetTagName(HtmlTextWriterTag) | Obtains the markup element associated with the specified HtmlTextWriterTag enumeration value. (Inherited from HtmlTextWriter.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Indent | Gets or sets the number of tab positions to indent the beginning of each line of markup. (Inherited from HtmlTextWriter.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InnerWriter | Gets or sets the text writer that writes the inner content of the markup element. (Inherited from HtmlTextWriter.)
 | IsAttributeDefined(HtmlTextWriterAttribute) | Determines whether the specified markup attribute and its value are rendered during the next call to the RenderBeginTag()()() method. (Inherited from HtmlTextWriter.)
 | IsAttributeDefined(HtmlTextWriterAttribute, String%) | Determines whether the specified markup attribute and its value are rendered during the next call to the RenderBeginTag()()() method. (Inherited from HtmlTextWriter.)
 | IsStyleAttributeDefined(HtmlTextWriterStyle) | Determines whether the specified markup style attribute is rendered during the next call to the RenderBeginTag()()() method. (Inherited from HtmlTextWriter.)
 | IsStyleAttributeDefined(HtmlTextWriterStyle, String%) | Determines whether the specified markup style attribute and its value are rendered during the next call to the RenderBeginTag()()() method. (Inherited from HtmlTextWriter.)
 | IsValidFormAttribute(String) | Checks an attribute to ensure that it can be rendered in the opening tag of a <form> markup element. (Inherited from HtmlTextWriter.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewLine | Gets or sets the line terminator string used by the HtmlTextWriter object. (Inherited from HtmlTextWriter.)
 | OnAttributeRender(String, String, HtmlTextWriterAttribute) | Determines whether the specified markup attribute and its value can be rendered to the current markup element. (Inherited from HtmlTextWriter.)
 | OnStyleAttributeRender(String, String, HtmlTextWriterStyle) | Determines whether the specified markup style attribute and its value can be rendered to the current markup element. (Inherited from HtmlTextWriter.)
 | OnTagRender(String, HtmlTextWriterTag) | Determines whether the specified markup element will be rendered to the requesting page. (Inherited from HtmlTextWriter.)
 | OutputTabs()()() | Writes a series of tab strings that represent the indentation level for a line of markup characters. (Inherited from HtmlTextWriter.)
 | PopEndTag()()() | Removes the most recently saved markup element from the list of rendered elements. (Inherited from HtmlTextWriter.)
 | PushEndTag(String) | Saves the specified markup element for later use when generating the end tag for a markup element. (Inherited from HtmlTextWriter.)
 | RenderAfterContent()()() | Writes any text or spacing that occurs after the content and before the closing tag of the markup element to the markup output stream. (Inherited from HtmlTextWriter.)
 | RenderAfterTag()()() | Writes any spacing or text that occurs after the closing tag for a markup element. (Inherited from HtmlTextWriter.)
 | RenderBeforeContent()()() | Writes any text or spacing before the content and after the opening tag of a markup element. (Inherited from HtmlTextWriter.)
 | RenderBeforeTag()()() | Writes any text or spacing that occurs before the opening tag of a markup element. (Inherited from HtmlTextWriter.)
 | RenderBeginTag(String) | Writes the opening tag of the specified markup element to the output stream. (Inherited from HtmlTextWriter.)
 | RenderBeginTag(HtmlTextWriterTag) | Writes the opening tag of the markup element associated with the specified HtmlTextWriterTag enumeration value to the output stream. (Inherited from HtmlTextWriter.)
 | RenderEndTag()()() | Writes the end tag of a markup element to the output stream. (Inherited from HtmlTextWriter.)
 | TagKey | Gets or sets the HtmlTextWriterTag value for the specified markup element. (Inherited from HtmlTextWriter.)
 | TagName | Gets or sets the tag name of the markup element being rendered. (Inherited from HtmlTextWriter.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Write(String) | Writes the specified string to the output stream, along with any pending tab spacing. (Inherited from HtmlTextWriter.)
 | Write(Boolean) | Writes the text representation of a Boolean value to the output stream, along with any pending tab spacing. (Inherited from HtmlTextWriter.)
 | Write(Char) | Writes the text representation of a Unicode character to the output stream, along with any pending tab spacing. (Inherited from HtmlTextWriter.)
 | Write(array<Char>[]()[]) | Writes the text representation of an array of Unicode characters to the output stream, along with any pending tab spacing. (Inherited from HtmlTextWriter.)
 | Write(array<Char>[]()[], Int32, Int32) | Writes the text representation of a subarray of Unicode characters to the output stream, along with any pending tab spacing. (Inherited from HtmlTextWriter.)
 | Write(Double) | Writes the text representation of a double-precision floating-point number to the output stream, along with any pending tab spacing. (Inherited from HtmlTextWriter.)
 | Write(Single) | Writes the text representation of a single-precision floating-point number to the output stream, along with any pending tab spacing. (Inherited from HtmlTextWriter.)
 | Write(Int32) | Writes the text representation of a 32-byte signed integer to the output stream, along with any pending tab spacing. (Inherited from HtmlTextWriter.)
 | Write(Int64) | Writes the text representation of a 64-byte signed integer to the output stream, along with any pending tab spacing. (Inherited from HtmlTextWriter.)
 | Write(Object) | Writes the text representation of an object to the output stream, along with any pending tab spacing. (Inherited from HtmlTextWriter.)
 | Write(String, Object) | Writes a tab string and a formatted string to the output stream, using the same semantics as the Format(String, Object) method, along with any pending tab spacing. (Inherited from HtmlTextWriter.)
 | Write(String, Object, Object) | Writes a formatted string that contains the text representation of two objects to the output stream, along with any pending tab spacing. This method uses the same semantics as the Format(String, Object, Object) method. (Inherited from HtmlTextWriter.)
 | Write(String, array<Object>[]()[]) | Writes a formatted string that contains the text representation of an object array to the output stream, along with any pending tab spacing. This method uses the same semantics as the Format(String, array<Object>[]()[]) method. (Inherited from HtmlTextWriter.)
 | Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from TextWriter.)
 | Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from TextWriter.)
 | Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from TextWriter.)
 | Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
 | WriteAttribute(String, String, Boolean) | Writes the specified markup attribute and value to the output stream, and, if specified, writes the value encoded. (Overrides HtmlTextWriter.WriteAttribute(String, String, Boolean).)
 | WriteAttribute(String, String) | Writes the specified markup attribute and value to the output stream. (Inherited from HtmlTextWriter.)
 | WriteBeginTag(String) | Writes any tab spacing and the opening tag of the specified markup element to the output stream. (Inherited from HtmlTextWriter.)
 | WriteBreak()()() | Writes a <br /> markup element to the output stream. (Inherited from HtmlTextWriter.)
 | WriteEncodedText(String) | Encodes the specified text for the requesting device, and then writes it to the output stream. (Inherited from HtmlTextWriter.)
 | WriteEncodedUrl(String) | Encodes the specified URL, and then writes it to the output stream. The URL might include parameters. (Inherited from HtmlTextWriter.)
 | WriteEncodedUrlParameter(String) | Encodes the specified URL parameter for the requesting device, and then writes it to the output stream. (Inherited from HtmlTextWriter.)
 | WriteEndTag(String) | Writes any tab spacing and the closing tag of the specified markup element. (Inherited from HtmlTextWriter.)
 | WriteFullBeginTag(String) | Writes any tab spacing and the opening tag of the specified markup element to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(String) | Writes any pending tab spacing and a text string, followed by a line terminator string, to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine()()() | Writes a line terminator string to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(Boolean) | Writes any pending tab spacing and the text representation of a Boolean value, followed by a line terminator string, to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(Char) | Writes any pending tab spacing and a Unicode character, followed by a line terminator string, to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(array<Char>[]()[]) | Writes any pending tab spacing and an array of Unicode characters, followed by a line terminator string, to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(array<Char>[]()[], Int32, Int32) | Writes any pending tab spacing and a subarray of Unicode characters, followed by a line terminator string, to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(Double) | Writes any pending tab spacing and the text representation of a double-precision floating-point number, followed by a line terminator string, to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(Single) | Writes any pending tab spacing and the text representation of a single-precision floating-point number, followed by a line terminator string, to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(Int32) | Writes any pending tab spacing and the text representation of a 32-byte signed integer, followed by a line terminator string, to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(Int64) | Writes any pending tab spacing and the text representation of a 64-byte signed integer, followed by a line terminator string, to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(Object) | Writes any pending tab spacing and the text representation of an object, followed by a line terminator string, to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(String, Object) | Writes any pending tab spacing and a formatted string containing the text representation of an object, followed by a line terminator string, to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(String, Object, Object) | Writes any pending tab spacing and a formatted string that contains the text representation of two objects, followed by a line terminator string, to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(String, array<Object>[]()[]) | Writes any pending tab spacing and a formatted string that contains the text representation of an object array, followed by a line terminator string, to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(UInt32) | Writes any pending tab spacing and the text representation of a 4-byte unsigned integer, followed by a line terminator string, to the output stream. (Inherited from HtmlTextWriter.)
 | WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
 | WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from TextWriter.)
 | WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
 | WriteLineNoTabs(String) | Writes a string, followed by a line terminator string, to the output stream. This method ignores any specified tab spacing. (Inherited from HtmlTextWriter.)
 | WriteStyleAttribute(String, String) | Writes the specified style attribute to the output stream. (Inherited from HtmlTextWriter.)
 | WriteStyleAttribute(String, String, Boolean) | Writes the specified style attribute and value to the output stream, and encodes the value, if specified. (Inherited from HtmlTextWriter.)
 | WriteUrlEncodedString(String, Boolean) | Writes the specified string, encoding it according to URL requirements. (Inherited from HtmlTextWriter.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | TextWriter
 |  |  | HtmlTextWriter
 |  |  |  | FormAdapter..::.FormAdapterHtmlWriter


FormAdapter.FormAdapterHtmlWriter Constructor (writer)

FormAdapter..::.FormAdapterHtmlWriter Constructor (writer)
Namespaces ► Sitecore.Web ► FormAdapter..::.FormAdapterHtmlWriter ► FormAdapter..::.FormAdapterHtmlWriter(TextWriter)
Initializes a new instance of the FormAdapter..::.FormAdapterHtmlWriter class.
Declaration Syntax
C#
public FormAdapterHtmlWriter(
    TextWriter writer
)
Parameters
writer (TextWriter)


WriteAttribute Method (name, value, fEncode)

WriteAttribute Method (name, value, fEncode)
Namespaces ► Sitecore.Web ► FormAdapter..::.FormAdapterHtmlWriter ► WriteAttribute(String, String, Boolean)
Writes the specified markup attribute and value to the output stream, and, if specified, writes the value encoded.
Declaration Syntax
C#
public override void WriteAttribute(
    string name,
    string value,
    bool fEncode
)
Parameters
name (String)
The markup attribute to write to the output stream.
value (String)
The value assigned to the attribute.
fEncode (Boolean)
true to encode the attribute and its assigned value; otherwise, false.


HtmlUtil Class

HtmlUtil Class
Namespaces ► Sitecore.Web ► HtmlUtil
Implements a utility class for manipulating HTML.
Declaration Syntax
C#
public static class HtmlUtil
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddCell(HtmlTableRow) | Adds a cell to a HTML table row.
 | AddCell(HtmlTableRow, array<HtmlControl>[]()[]) | Adds the cell.
 | AddControl(Control, Control) | Adds a control to a parent control.
 | AddRow(HtmlTable) | Adds a row to a HTML table.
 | AddRow(HtmlTable, array<HtmlControl>[]()[]) | Adds a row to a HTML table and inserts cells into the row.
 | AddRow(HtmlTable, array<String>[]()[]) | Adds a row to a HTML table and inserts cells into the row.
 | AddRow(HtmlTable, array<Object>[]()[]) | Adds a row to a HTML table and inserts cells into the row.
 | CreateAnchor(String, String) | Creates an HTML anchor.
 | CreateRow(array<String>[]()[]) | Creates a standalone HTML table row and inserts cells into it.
 | CreateTable(Int32, Int32) | Creates an HTML table.
 | FindEndTag(String, String) | Finds an end tag in a string.
 | FindStartTag(String, String) | Finds a start tag in a string.
 | GetCheckBox(Boolean) | Creates a checkbox input control.
 | GetCheckBox(Boolean, String) | Creates a checkbox input control.
 | GetHidden(String) | Creates a hidden input control.
 | GetHidden(String, String) | Creates a hidden input control.
 | GetImageLink(String, String) | Creates clickable image. The control consists of an anchor tag with an image inside.
 | GetImageLink(String, String, NameValueCollection, NameValueCollection) | Creates clickable image. The control consists of an anchor tag with an image inside.
 | GetRootControl(Control) | Gets the root control.
 | InsertRow(Int32, HtmlTable) | Inserts a row in an HTML table at a specified index.
 | InsertRow(Int32, HtmlTable, array<HtmlControl>[]()[]) | Inserts a row in an HTML table at a specified index and inserts cells into it..
 | InsertRow(Int32, HtmlTable, array<String>[]()[]) | Inserts a row in an HTML table at a specified index and inserts cells into it..
 | InsertRow(Int32, HtmlTable, array<Object>[]()[]) | Inserts a row in an HTML table at a specified index and inserts cells into it..
 | ParseTagAttributes(String) | Parses the attributes of a tag.
 | RenderControl(Control) | Renders a web control to a string.
 | SetAttributes(HtmlControl, NameValueCollection) | Sets the attributes on a HTML control.
Remarks
Inheritance Hierarchy
Object
HtmlUtil
See Also
DateUtil
MainUtil
StringUtil
WebUtil


AddCell Method

AddCell Method
Namespaces ► Sitecore.Web ► HtmlUtil ► AddCell()()()
Members
Icon | Member | Description
 | AddCell(HtmlTableRow) | Adds a cell to a HTML table row.
 | AddCell(HtmlTableRow, array<HtmlControl>[]()[]) | Adds the cell.


AddCell Method (row)

AddCell Method (row)
Namespaces ► Sitecore.Web ► HtmlUtil ► AddCell(HtmlTableRow)
Adds a cell to a HTML table row.
Declaration Syntax
C#
public static HtmlTableCell AddCell(
    HtmlTableRow row
)
Parameters
row (HtmlTableRow)
A row.
Return Value
The added cell.
Remarks
The cell is added to the end of the row.
Examples
CopyC#
HtmlTable table = new HtmlTable();
HtmlTableRow row = HtmlUtil.AddRow(table);
HtmlTableCell cell = HtmlUtil.AddCell(row);


AddCell Method (row, controls)

AddCell Method (row, controls)
Namespaces ► Sitecore.Web ► HtmlUtil ► AddCell(HtmlTableRow, array<HtmlControl>[]()[])
Adds the cell.
Declaration Syntax
C#
public static HtmlTableCell AddCell(
    HtmlTableRow row,
    params HtmlControl[] controls
)
Parameters
row (HtmlTableRow)
The row.
controls (array< HtmlControl >[]()[])
The controls.
Return Value
The cell.


AddControl Method (ctl, ctlParent)

AddControl Method (ctl, ctlParent)
Namespaces ► Sitecore.Web ► HtmlUtil ► AddControl(Control, Control)
Adds a control to a parent control.
Declaration Syntax
C#
public static Control AddControl(
    Control ctl,
    Control ctlParent
)
Parameters
ctl (Control)
A control to be added to a parent.
ctlParent (Control)
A parent control.
Return Value
The added control.
Remarks
The control is added to the end of the parent child control list. An exception is thrown if the parent control is null.
Examples
CopyC#
HtmlTable table = new HtmlTable();
HtmlTableRow row = new HtmlTableRow();
HtmlUtil.AddControl(row, table);


AddRow Method

AddRow Method
Namespaces ► Sitecore.Web ► HtmlUtil ► AddRow()()()
Members
Icon | Member | Description
 | AddRow(HtmlTable) | Adds a row to a HTML table.
 | AddRow(HtmlTable, array<HtmlControl>[]()[]) | Adds a row to a HTML table and inserts cells into the row.
 | AddRow(HtmlTable, array<String>[]()[]) | Adds a row to a HTML table and inserts cells into the row.
 | AddRow(HtmlTable, array<Object>[]()[]) | Adds a row to a HTML table and inserts cells into the row.


AddRow Method (table)

AddRow Method (table)
Namespaces ► Sitecore.Web ► HtmlUtil ► AddRow(HtmlTable)
Adds a row to a HTML table.
Declaration Syntax
C#
public static HtmlTableRow AddRow(
    HtmlTable table
)
Parameters
table (HtmlTable)
A HTML table.
Return Value
The added row.
Remarks
The row is added to the bottom of the table. If the table parameter is null, a new table is created.
Examples
CopyC#
HtmlTable table = new HtmlTable();
HtmlTableRow row = HtmlUtil.AddRow(table);
See Also
InsertRow(Int32, HtmlTable)
CreateRow(array<String>[]()[])


AddRow Method (table, values)

AddRow Method (table, values)
Namespaces ► Sitecore.Web ► HtmlUtil ► AddRow(HtmlTable, array<Object>[]()[])
Adds a row to a HTML table and inserts cells into the row.
Declaration Syntax
C#
public static HtmlTableRow AddRow(
    HtmlTable table,
    params Object[] values
)
Parameters
table (HtmlTable)
A HTML table.
values (array< Object >[]()[])
Cell values.
Return Value
The added row.
Remarks
The row is added to the bottom of the table. If the table parameter is null, a new table is created.
Examples
CopyC#
HtmlTable table = new HtmlTable();
HtmlTableRow row = HtmlUtil.AddRow(table, "Cell 1", DateTime.Now);
See Also
InsertRow(Int32, HtmlTable)
CreateRow(array<String>[]()[])


AddRow Method (table, texts)

AddRow Method (table, texts)
Namespaces ► Sitecore.Web ► HtmlUtil ► AddRow(HtmlTable, array<String>[]()[])
Adds a row to a HTML table and inserts cells into the row.
Declaration Syntax
C#
public static HtmlTableRow AddRow(
    HtmlTable table,
    params string[] texts
)
Parameters
table (HtmlTable)
A HTML table.
texts (array< String >[]()[])
Cell values.
Return Value
The added row.
Remarks
The row is added to the bottom of the table. If the table parameter is null, a new table is created.
Examples
CopyC#
HtmlTable table = new HtmlTable();
HtmlTableRow row = HtmlUtil.AddRow(table, "Cell 1", "Cell 2");
See Also
InsertRow(Int32, HtmlTable)
CreateRow(array<String>[]()[])


AddRow Method (table, controls)

AddRow Method (table, controls)
Namespaces ► Sitecore.Web ► HtmlUtil ► AddRow(HtmlTable, array<HtmlControl>[]()[])
Adds a row to a HTML table and inserts cells into the row.
Declaration Syntax
C#
public static HtmlTableRow AddRow(
    HtmlTable table,
    params HtmlControl[] controls
)
Parameters
table (HtmlTable)
A HTML table.
controls (array< HtmlControl >[]()[])
Cell controls.
Return Value
The added row.
Remarks
The row is added to the bottom of the table. If the table parameter is null, a new table is created.
Examples
CopyC#
HtmlTable table = new HtmlTable();
HtmlTableRow row = HtmlUtil.AddRow(table, control1, control2);
See Also
InsertRow(Int32, HtmlTable)
CreateRow(array<String>[]()[])


CreateAnchor Method (text, href)

CreateAnchor Method (text, href)
Namespaces ► Sitecore.Web ► HtmlUtil ► CreateAnchor(String, String)
Creates an HTML anchor.
Declaration Syntax
C#
public static HtmlAnchor CreateAnchor(
    string text,
    string href
)
Parameters
text (String)
Inner text of the anchor.
href (String)
An URL.
Return Value
The create HtmlAnchor object.
Examples
CopyC#
HtmlAnchor anchor = HtmlUtil.CreateAnchor("Hello world", "http://www.helloworld.net");


CreateRow Method (texts)

CreateRow Method (texts)
Namespaces ► Sitecore.Web ► HtmlUtil ► CreateRow(array<String>[]()[])
Creates a standalone HTML table row and inserts cells into it.
Declaration Syntax
C#
public static HtmlTableRow CreateRow(
    string[] texts
)
Parameters
texts (array< String >[]()[])
A string array of cell values.
Return Value
The added row.
Remarks
The row is not added to a HTML table. If the table parameter is null, a new table is created.
Examples
CopyC#
HtmlTableRow row = HtmlUtil.CreateRow(new string[] {"Cell 1", "Cell 2"});
See Also
AddRow(HtmlTable)
InsertRow(Int32, HtmlTable)


CreateTable Method (rows, columns)

CreateTable Method (rows, columns)
Namespaces ► Sitecore.Web ► HtmlUtil ► CreateTable(Int32, Int32)
Creates an HTML table.
Declaration Syntax
C#
public static HtmlTable CreateTable(
    int rows,
    int columns
)
Parameters
rows (Int32)
Number of rows.
columns (Int32)
Number of columns.
Return Value
The table.
Examples
CopyC#
HtmlTable table = HtmlUtil.CreateTable(3, 3);


FindEndTag Method (sTagName, sText)

FindEndTag Method (sTagName, sText)
Namespaces ► Sitecore.Web ► HtmlUtil ► FindEndTag(String, String)
Finds an end tag in a string.
Declaration Syntax
C#
public static Match FindEndTag(
    string sTagName,
    string sText
)
Parameters
sTagName (String)
A tag name, e.g. "div".
sText (String)
A string.
Return Value
A regular expression Match object.
Examples
CopyC#
Match match = HtmlUtil.FindEndTag("div", "<div>This is my HTML</div>");
See Also
FindStartTag(String, String)


FindStartTag Method (sTagName, sText)

FindStartTag Method (sTagName, sText)
Namespaces ► Sitecore.Web ► HtmlUtil ► FindStartTag(String, String)
Finds a start tag in a string.
Declaration Syntax
C#
public static Match FindStartTag(
    string sTagName,
    string sText
)
Parameters
sTagName (String)
A tag name, e.g. "div".
sText (String)
A string.
Return Value
A regular expression Match object.
Examples
CopyC#
Match match = HtmlUtil.FindStartTag("div", "<div>This is my HTML</div>");
See Also
FindEndTag(String, String)


GetCheckBox Method

GetCheckBox Method
Namespaces ► Sitecore.Web ► HtmlUtil ► GetCheckBox()()()
Members
Icon | Member | Description
 | GetCheckBox(Boolean) | Creates a checkbox input control.
 | GetCheckBox(Boolean, String) | Creates a checkbox input control.


GetCheckBox Method (isChecked)

GetCheckBox Method (isChecked)
Namespaces ► Sitecore.Web ► HtmlUtil ► GetCheckBox(Boolean)
Creates a checkbox input control.
Declaration Syntax
C#
public static HtmlInputCheckBox GetCheckBox(
    bool isChecked
)
Parameters
isChecked (Boolean)
A boolean indicating if the checkbox is checked or not.
Return Value
The created checkbox control.
Examples
CopyC#
HtmlInputCheckBox cb = HtmlUtil.GetCheckBox(true);


GetCheckBox Method (isChecked, id)

GetCheckBox Method (isChecked, id)
Namespaces ► Sitecore.Web ► HtmlUtil ► GetCheckBox(Boolean, String)
Creates a checkbox input control.
Declaration Syntax
C#
public static HtmlInputCheckBox GetCheckBox(
    bool isChecked,
    string id
)
Parameters
isChecked (Boolean)
A boolean indicating if the checkbox is checked or not.
id (String)
The ID of the control.
Return Value
The created checkbox control.
Examples
CopyC#
HtmlInputCheckBox cb = HtmlUtil.GetCheckBox(true, "MyControlID");


GetHidden Method

GetHidden Method
Namespaces ► Sitecore.Web ► HtmlUtil ► GetHidden()()()
Members
Icon | Member | Description
 | GetHidden(String) | Creates a hidden input control.
 | GetHidden(String, String) | Creates a hidden input control.


GetHidden Method (value)

GetHidden Method (value)
Namespaces ► Sitecore.Web ► HtmlUtil ► GetHidden(String)
Creates a hidden input control.
Declaration Syntax
C#
public static HtmlInputHidden GetHidden(
    string value
)
Parameters
value (String)
The value of the hidden control.
Return Value
The created hidden control.
Examples
CopyC#
HtmlInputHidden hidden = HtmlUtil.GetHidden("My Value");


GetHidden Method (value, id)

GetHidden Method (value, id)
Namespaces ► Sitecore.Web ► HtmlUtil ► GetHidden(String, String)
Creates a hidden input control.
Declaration Syntax
C#
public static HtmlInputHidden GetHidden(
    string value,
    string id
)
Parameters
value (String)
The value of the hidden control.
id (String)
The ID of the hidden control
Return Value
The created hidden control.
Examples
CopyC#
HtmlInputHidden hidden = HtmlUtil.GetHidden("My Value", "MyControlID");


GetImageLink Method

GetImageLink Method
Namespaces ► Sitecore.Web ► HtmlUtil ► GetImageLink()()()
Members
Icon | Member | Description
 | GetImageLink(String, String) | Creates clickable image. The control consists of an anchor tag with an image inside.
 | GetImageLink(String, String, NameValueCollection, NameValueCollection) | Creates clickable image. The control consists of an anchor tag with an image inside.


GetImageLink Method (linkUrl, imageUrl)

GetImageLink Method (linkUrl, imageUrl)
Namespaces ► Sitecore.Web ► HtmlUtil ► GetImageLink(String, String)
Creates clickable image. The control consists of an anchor tag with an image inside.
Declaration Syntax
C#
public static HtmlAnchor GetImageLink(
    string linkUrl,
    string imageUrl
)
Parameters
linkUrl (String)
The target URL of the anchor.
imageUrl (String)
The URL of the image.
Return Value
The created anchor control.
Examples
CopyC#
HtmlAnchor image = HtmlUtil.GetImageLink("http://www.sitecore.net", "/images/logo.gif");


GetImageLink Method (linkUrl, imageUrl, linkAttributes, imageAttributes)

GetImageLink Method (linkUrl, imageUrl, linkAttributes, imageAttributes)
Namespaces ► Sitecore.Web ► HtmlUtil ► GetImageLink(String, String, NameValueCollection, NameValueCollection)
Creates clickable image. The control consists of an anchor tag with an image inside.
Declaration Syntax
C#
public static HtmlAnchor GetImageLink(
    string linkUrl,
    string imageUrl,
    NameValueCollection linkAttributes,
    NameValueCollection imageAttributes
)
Parameters
linkUrl (String)
The target URL of the anchor.
imageUrl (String)
The URL of the image.
linkAttributes (NameValueCollection)
A collection of attributes for the anchor tag.
imageAttributes (NameValueCollection)
A collection of attributes for the image tag.
Return Value
The created anchor control.


GetRootControl Method (control)

GetRootControl Method (control)
Namespaces ► Sitecore.Web ► HtmlUtil ► GetRootControl(Control)
Gets the root control.
Declaration Syntax
C#
public static Control GetRootControl(
    Control control
)
Parameters
control (Control)
A control in the control hieraki.
Return Value
The root control.
Remarks
The root control is the ultimate ancestor of all controls.
Examples
CopyC#
Control root = HtmlUtil.GetRootControl(myControl);


InsertRow Method

InsertRow Method
Namespaces ► Sitecore.Web ► HtmlUtil ► InsertRow()()()
Members
Icon | Member | Description
 | InsertRow(Int32, HtmlTable) | Inserts a row in an HTML table at a specified index.
 | InsertRow(Int32, HtmlTable, array<HtmlControl>[]()[]) | Inserts a row in an HTML table at a specified index and inserts cells into it..
 | InsertRow(Int32, HtmlTable, array<String>[]()[]) | Inserts a row in an HTML table at a specified index and inserts cells into it..
 | InsertRow(Int32, HtmlTable, array<Object>[]()[]) | Inserts a row in an HTML table at a specified index and inserts cells into it..


InsertRow Method (index, table)

InsertRow Method (index, table)
Namespaces ► Sitecore.Web ► HtmlUtil ► InsertRow(Int32, HtmlTable)
Inserts a row in an HTML table at a specified index.
Declaration Syntax
C#
public static HtmlTableRow InsertRow(
    int index,
    HtmlTable table
)
Parameters
index (Int32)
A index in the HTML table.
table (HtmlTable)
A HTML table.
Return Value
The added row.
Remarks
If the table parameter is null, a new table is created.
Examples
CopyC#
HtmlTable table = new HtmlTable();
HtmlTableRow row1 = HtmlUtil.AddRow(table);
HtmlTableRow row0 = HtmlUtil.InsertRow(0, table);
See Also
AddRow(HtmlTable)
CreateRow(array<String>[]()[])


InsertRow Method (index, table, values)

InsertRow Method (index, table, values)
Namespaces ► Sitecore.Web ► HtmlUtil ► InsertRow(Int32, HtmlTable, array<Object>[]()[])
Inserts a row in an HTML table at a specified index and inserts cells into it..
Declaration Syntax
C#
public static HtmlTableRow InsertRow(
    int index,
    HtmlTable table,
    params Object[] values
)
Parameters
index (Int32)
A index in the HTML table.
table (HtmlTable)
A HTML table.
values (array< Object >[]()[])
Cell values.
Return Value
The added row.
Remarks
If the table parameter is null, a new table is created.
Examples
CopyC#
HtmlTable table = new HtmlTable();
HtmlTableRow row1 = HtmlUtil.AddRow(table);
HtmlTableRow row0 = HtmlUtil.InsertRow(0, table, "Cell 1", DateTime.Now);
See Also
AddRow(HtmlTable)
CreateRow(array<String>[]()[])


InsertRow Method (index, table, texts)

InsertRow Method (index, table, texts)
Namespaces ► Sitecore.Web ► HtmlUtil ► InsertRow(Int32, HtmlTable, array<String>[]()[])
Inserts a row in an HTML table at a specified index and inserts cells into it..
Declaration Syntax
C#
public static HtmlTableRow InsertRow(
    int index,
    HtmlTable table,
    params string[] texts
)
Parameters
index (Int32)
A index in the HTML table.
table (HtmlTable)
A HTML table.
texts (array< String >[]()[])
Cell values.
Return Value
The added row.
Remarks
If the table parameter is null, a new table is created.
Examples
CopyC#
HtmlTable table = new HtmlTable();
HtmlTableRow row1 = HtmlUtil.AddRow(table);
HtmlTableRow row0 = HtmlUtil.InsertRow(0, table, "Cell 1", "Cell 2");
See Also
AddRow(HtmlTable)
CreateRow(array<String>[]()[])


InsertRow Method (index, table, controls)

InsertRow Method (index, table, controls)
Namespaces ► Sitecore.Web ► HtmlUtil ► InsertRow(Int32, HtmlTable, array<HtmlControl>[]()[])
Inserts a row in an HTML table at a specified index and inserts cells into it..
Declaration Syntax
C#
public static HtmlTableRow InsertRow(
    int index,
    HtmlTable table,
    params HtmlControl[] controls
)
Parameters
index (Int32)
A index in the HTML table.
table (HtmlTable)
A HTML table.
controls (array< HtmlControl >[]()[])
Cell controls.
Return Value
The added row.
Remarks
If the table parameter is null, a new table is created.
Examples
CopyC#
HtmlTable table = new HtmlTable();
HtmlTableRow row1 = HtmlUtil.AddRow(table);
HtmlTableRow row0 = HtmlUtil.InsertRow(0, table, control1, control2);
See Also
AddRow(HtmlTable)
CreateRow(array<String>[]()[])


ParseTagAttributes Method (tag)

ParseTagAttributes Method (tag)
Namespaces ► Sitecore.Web ► HtmlUtil ► ParseTagAttributes(String)
Parses the attributes of a tag.
Declaration Syntax
C#
public static NameValueCollection ParseTagAttributes(
    string tag
)
Parameters
tag (String)
A tag string.
Return Value
A collection of attributes.
Remarks
The collection will not include attributes that do not have a value, e.g. "checked" and "nowrap".
Examples
CopyC#
string tag = "<div align=\"right\">";
NameValueCollection attributes = HtmlUtil.ParseTagAttributes(tag);
string align = attributes["align"]; // right


RenderControl Method (ctl)

RenderControl Method (ctl)
Namespaces ► Sitecore.Web ► HtmlUtil ► RenderControl(Control)
Renders a web control to a string.
Declaration Syntax
C#
public static string RenderControl(
    Control ctl
)
Parameters
ctl (Control)
A control to be rendered.
Return Value
The HTML of the rendered control.
Examples
CopyC#
HtmlAnchor image = HtmlUtil.GetImageLink("http://www.sitecore.net", "/images/logo.gif");
string html = HtmlUtil.RenderControl(image);


SetAttributes Method (ctl, attributes)

SetAttributes Method (ctl, attributes)
Namespaces ► Sitecore.Web ► HtmlUtil ► SetAttributes(HtmlControl, NameValueCollection)
Sets the attributes on a HTML control.
Declaration Syntax
C#
public static void SetAttributes(
    HtmlControl ctl,
    NameValueCollection attributes
)
Parameters
ctl (HtmlControl)
A HTML control.
attributes (NameValueCollection)
A collection of attributes.


InvalidLinkFormatException Class

InvalidLinkFormatException Class
Namespaces ► Sitecore.Web ► InvalidLinkFormatException
InvalidLinkFormatException
Declaration Syntax
C#
[SerializableAttribute]
public class InvalidLinkFormatException : Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InvalidLinkFormatException(String) | Initializes a new instance of the InvalidLinkFormatException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | InvalidLinkFormatException


InvalidLinkFormatException Constructor (message)

InvalidLinkFormatException Constructor (message)
Namespaces ► Sitecore.Web ► InvalidLinkFormatException ► InvalidLinkFormatException(String)
Initializes a new instance of the InvalidLinkFormatException class.
Declaration Syntax
C#
public InvalidLinkFormatException(
    string message
)
Parameters
message (String)
The message.


IPageHandler Interface

IPageHandler Interface
Namespaces ► Sitecore.Web ► IPageHandler
Interface for a page handler
Declaration Syntax
C#
public interface IPageHandler
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Execute(NameValueCollection) | This method is called whenever a page is being generated
Remarks
A page handler is registered in web.config under the <pageHandlers> section
Examples
The following example shows how a page handler might be registered in web.config
CopyC#
<pageHandlers>
  <handler mode="on" name="Statistics" assembly="Sitecore.Kernel" type="Sitecore.Logging" expectedResult="" />
</pageHandlers>
 The attributes of the <handler> tag is:
  • mode=on|off - Determines if the handler is active. Inactive handlers are never called
  • name=name - Descriptive name of the page handler. This value is not used by Sitecore, but might be useful for people reading web.config
  • assembly=name - Name of assembly containing the page handler class. This value is case-sensitive
  • type=name - Type name of the page handler class. This value is case-sensitive
  • expectedResult=value - This is the expected return value of the page handler Execute(NameValueCollection) method. If the return value is different, an error message will be sent to the current PageTrace.
The page handler is free to add additional attributes if this is needed. All attributes of the <handler> tag are passed to the Execute(NameValueCollection) method.


Execute Method (configSettings)

Execute Method (configSettings)
Namespaces ► Sitecore.Web ► IPageHandler ► Execute(NameValueCollection)
This method is called whenever a page is being generated
Declaration Syntax
C#
string Execute(
    NameValueCollection configSettings
)
Parameters
configSettings (NameValueCollection)
The config settings.
Return Value
A status message that is compared to the value of 'expectedResult' from web.config.
Remarks
The call is being made during the Init phase of the page life cycle


PathData Class

PathData Class
Namespaces ► Sitecore.Web ► PathData
PathData
Declaration Syntax
C#
public class PathData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PathData()()() | Initializes a new instance of the PathData class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath | Gets or sets the file path.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Language | Gets or sets the language.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PathData


PathData Constructor

PathData Constructor
Namespaces ► Sitecore.Web ► PathData ► PathData()()()
Initializes a new instance of the PathData class
Declaration Syntax
C#
public PathData()


FilePath Property

FilePath Property
Namespaces ► Sitecore.Web ► PathData ► FilePath
Gets or sets the file path.
Declaration Syntax
C#
public string FilePath { get; set; }
Value
The file path.


Language Property

Language Property
Namespaces ► Sitecore.Web ► PathData ► Language
Gets or sets the language.
Declaration Syntax
C#
public Language Language { get; set; }
Value
The language.


RequestFilter Class

RequestFilter Class
Namespaces ► Sitecore.Web ► RequestFilter
RequestFilter class
Declaration Syntax
C#
public class RequestFilter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RequestFilter(String, String, String, String) | Initializes a new instance of the RequestFilter class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequest, HttpResponse, Boolean%) | Obsolete. Processes the specified request.
 | Process(HttpRequest, HttpResponse, Boolean%, Boolean%) | Processes the specified request.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RequestFilter


RequestFilter Constructor (allowed, blocked, streamFiles, doNotStreamFiles)

RequestFilter Constructor (allowed, blocked, streamFiles, doNotStreamFiles)
Namespaces ► Sitecore.Web ► RequestFilter ► RequestFilter(String, String, String, String)
Initializes a new instance of the RequestFilter class.
Declaration Syntax
C#
public RequestFilter(
    string allowed,
    string blocked,
    string streamFiles,
    string doNotStreamFiles
)
Parameters
allowed (String)
The allowed extensions (comma separated).
blocked (String)
The blocked extensions (comma separated).
streamFiles (String)
The extensions for which to stream files (comma separated).
doNotStreamFiles (String)
The extensions for which not to stream files (comma separated).


Process Method

Process Method
Namespaces ► Sitecore.Web ► RequestFilter ► Process()()()
Members
Icon | Member | Description
 | Process(HttpRequest, HttpResponse, Boolean%) | Obsolete. Processes the specified request.
 | Process(HttpRequest, HttpResponse, Boolean%, Boolean%) | Processes the specified request.


Process Method (request, response, blocked)

Process Method (request, response, blocked)
Namespaces ► Sitecore.Web ► RequestFilter ► Process(HttpRequest, HttpResponse, Boolean%)
Processes the specified request.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public void Process(
    HttpRequest request,
    HttpResponse response,
    out bool blocked
)
Parameters
request (HttpRequest)
The request.
response (HttpResponse)
The response.
blocked ( Boolean %)
If set to true the request is blocked.
Remarks
If a request is blocked and the configuration is set to stream the request type, then End()()() will be called after processing.


Process Method (request, response, blocked, sitecoreOn)

Process Method (request, response, blocked, sitecoreOn)
Namespaces ► Sitecore.Web ► RequestFilter ► Process(HttpRequest, HttpResponse, Boolean%, Boolean%)
Processes the specified request.
Declaration Syntax
C#
public void Process(
    HttpRequest request,
    HttpResponse response,
    out bool blocked,
    out bool sitecoreOn
)
Parameters
request (HttpRequest)
The request.
response (HttpResponse)
The response.
blocked ( Boolean %)
If set to true the request is blocked.
sitecoreOn ( Boolean %)
If set to false request should be passed directly to ASP.Net process.
Remarks
If a request is blocked and the configuration is set to stream the request type, then End()()() will be called after processing.


RequestUrl Class

RequestUrl Class
Namespaces ► Sitecore.Web ► RequestUrl
RequestUrl
Declaration Syntax
C#
public class RequestUrl
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RequestUrl(HttpRequest) | Initializes a new instance of the RequestUrl class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath | Gets the file path.
 | FilePathWithQueryString | Gets the path and query string.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ItemPath | Gets the item path.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(HttpRequest) | Parses the specified URL.
 | QueryString | Gets or sets the query string.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryParse(HttpRequest, RequestUrl%) | Attempts to parse the specified URL.
Inheritance Hierarchy
Object
RequestUrl


RequestUrl Constructor (request)

RequestUrl Constructor (request)
Namespaces ► Sitecore.Web ► RequestUrl ► RequestUrl(HttpRequest)
Initializes a new instance of the RequestUrl class.
Declaration Syntax
C#
public RequestUrl(
    HttpRequest request
)
Parameters
request (HttpRequest)
The request.


FilePath Property

FilePath Property
Namespaces ► Sitecore.Web ► RequestUrl ► FilePath
Gets the file path.
Declaration Syntax
C#
public string FilePath { get; set; }
Value
The file path.


FilePathWithQueryString Property

FilePathWithQueryString Property
Namespaces ► Sitecore.Web ► RequestUrl ► FilePathWithQueryString
Gets the path and query string.
Declaration Syntax
C#
public string FilePathWithQueryString { get; }
Value
The path and query string.


ItemPath Property

ItemPath Property
Namespaces ► Sitecore.Web ► RequestUrl ► ItemPath
Gets the item path.
Declaration Syntax
C#
public string ItemPath { get; set; }
Value
The item path.


Parse Method (request)

Parse Method (request)
Namespaces ► Sitecore.Web ► RequestUrl ► Parse(HttpRequest)
Parses the specified URL.
Declaration Syntax
C#
public static RequestUrl Parse(
    HttpRequest request
)
Parameters
request (HttpRequest)
The request.
Return Value


QueryString Property

QueryString Property
Namespaces ► Sitecore.Web ► RequestUrl ► QueryString
Gets or sets the query string.
Declaration Syntax
C#
public string QueryString { get; set; }
Value
The query string.


TryParse Method (request, result)

TryParse Method (request, result)
Namespaces ► Sitecore.Web ► RequestUrl ► TryParse(HttpRequest, RequestUrl%)
Attempts to parse the specified URL.
Declaration Syntax
C#
public static bool TryParse(
    HttpRequest request,
    out RequestUrl result
)
Parameters
request (HttpRequest)
The request.
result ( RequestUrl %)
The result.
Return Value


ShutdownDetector Class

ShutdownDetector Class
Namespaces ► Sitecore.Web ► ShutdownDetector
Class used for detecting AppDomain shutdown.
Declaration Syntax
C#
public class ShutdownDetector : IRegisteredObject
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ShutdownDetector(IHttpModule) | Initializes a new instance of the ShutdownDetector class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Stop(Boolean) | Requests a registered object to unregister.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ShutdownDetector


ShutdownDetector Constructor (httpModule)

ShutdownDetector Constructor (httpModule)
Namespaces ► Sitecore.Web ► ShutdownDetector ► ShutdownDetector(IHttpModule)
Initializes a new instance of the ShutdownDetector class.
Declaration Syntax
C#
public ShutdownDetector(
    IHttpModule httpModule
)
Parameters
httpModule (IHttpModule)
The HTTP module.


Stop Method (immediate)

Stop Method (immediate)
Namespaces ► Sitecore.Web ► ShutdownDetector ► Stop(Boolean)
Requests a registered object to unregister.
Declaration Syntax
C#
public void Stop(
    bool immediate
)
Parameters
immediate (Boolean)
true to indicate the registered object should unregister from the hosting environment before returning; otherwise, false.


SiteInfo Class

SiteInfo Class
Namespaces ► Sitecore.Web ► SiteInfo
Information about site (used when specifying multiple sites in web.config).
Declaration Syntax
C#
public class SiteInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteInfo(XmlNode) | Constructor
 | SiteInfo(StringDictionary) | Initializes a new instance of the SiteInfo class.
 | AllowDebug | Gets a value indicating whether the SiteInfo allows the debugging.
 | BrowserTitle | Gets the browser title.
 | CacheHtml | Gets a value indicating whether the SiteInfo caches HTML.
 | CacheMedia | Gets a value indicating whether to cache media.
 | ContentLanguage | Gets the content language.
 | ContentStartItem | Gets the content start item.
 | Create(StringDictionary) | Creates the specified properties.
 | Database | Gets the database.
 | DefaultDevice | Gets the default device.
 | Device | Gets the device.
 | DisableClientData | Gets a value indicating whether client data is disabled for the site.
 | DisableXmlControls | Gets a value indicating whether XML controls are disabled for this site.
 | Domain | Gets the domain.
 | EnableAnalytics | Gets a value indicating whether analytics is enabled.
 | EnableDebugger | Gets a value indicating whether the SiteInfo enables the debugger.
 | EnableLinkedItems | Obsolete. Gets a value indicating whether the SiteInfo enables the linked items.
 | EnablePreview | Gets a value indicating whether the SiteInfo enables preview.
 | EnableWebEdit | Gets a value indicating whether the SiteInfo enables web edit.
 | EnableWorkflow | Gets a value indicating whether the SiteInfo enables workflowing.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilteredItemsCache | Gets the filtered items cache.
 | FilterItems | Checks if data is valid.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostName | Gets the name of the host.
 | HtmlCache | Gets the HTML cache.
 | HtmlCacheClearLatency | Gets the HTML cache clear latency.
 | IsActive | Gets a value indicating whether this instance is active.
 | Language | Gets the language.
 | LoginPage | Gets the login page.
 | MasterDatabase | Gets the master database name.
 | Matches(String, String) | Checks if a server name is a match.
 | Matches(String, String, Int32) | Checks if a server name is a match.
 | MediaCachePath | Gets the path to the media cache.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | PhysicalFolder | Gets the physical folder.
 | Port | Gets the port number.
 | Properties | Gets the properties.
 | RegistryCache | Gets the registry cache.
 | RequireLogin | Gets a value indicating whether the SiteInfo requires login.
 | RootPath | Path to root item in the database
 | Scheme | Gets the scheme (ie. http or https).
 | StartItem | Gets the start item.
 | TargetHostName | Gets the name of the target host.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ViewStateCache | Gets the view state cache.
 | VirtualFolder | Gets the virtual folder.
 | XmlControlPage | Gets the XML control page.
 | XslCache | Gets the XSL cache.
Inheritance Hierarchy
Object
SiteInfo


SiteInfo Constructor

SiteInfo Constructor
Namespaces ► Sitecore.Web ► SiteInfo ► SiteInfo()()()
Members
Icon | Member | Description
 | SiteInfo(XmlNode) | Constructor
 | SiteInfo(StringDictionary) | Initializes a new instance of the SiteInfo class.


SiteInfo Constructor (properties)

SiteInfo Constructor (properties)
Namespaces ► Sitecore.Web ► SiteInfo ► SiteInfo(StringDictionary)
Initializes a new instance of the SiteInfo class.
Declaration Syntax
C#
public SiteInfo(
    StringDictionary properties
)
Parameters
properties (StringDictionary)
The properties.


SiteInfo Constructor (configNode)

SiteInfo Constructor (configNode)
Namespaces ► Sitecore.Web ► SiteInfo ► SiteInfo(XmlNode)
Constructor
Declaration Syntax
C#
public SiteInfo(
    XmlNode configNode
)
Parameters
configNode (XmlNode)
The config node.


AllowDebug Property

AllowDebug Property
Namespaces ► Sitecore.Web ► SiteInfo ► AllowDebug
Gets a value indicating whether the SiteInfo allows the debugging.
Declaration Syntax
C#
public bool AllowDebug { get; }
Value
true if the SiteInfo allows debugging; otherwise, false.


BrowserTitle Property

BrowserTitle Property
Namespaces ► Sitecore.Web ► SiteInfo ► BrowserTitle
Gets the browser title.
Declaration Syntax
C#
public string BrowserTitle { get; }
Value
The browser title.


CacheHtml Property

CacheHtml Property
Namespaces ► Sitecore.Web ► SiteInfo ► CacheHtml
Gets a value indicating whether the SiteInfo caches HTML.
Declaration Syntax
C#
public bool CacheHtml { get; }
Value
true if the SiteInfo caches HTML; otherwise, false.


CacheMedia Property

CacheMedia Property
Namespaces ► Sitecore.Web ► SiteInfo ► CacheMedia
Gets a value indicating whether to cache media.
Declaration Syntax
C#
public bool CacheMedia { get; }
Value
true if media should be cached; otherwise, false.


ContentLanguage Property

ContentLanguage Property
Namespaces ► Sitecore.Web ► SiteInfo ► ContentLanguage
Gets the content language.
Declaration Syntax
C#
public string ContentLanguage { get; }
Value
The content language.


ContentStartItem Property

ContentStartItem Property
Namespaces ► Sitecore.Web ► SiteInfo ► ContentStartItem
Gets the content start item.
Declaration Syntax
C#
public string ContentStartItem { get; }
Value
The content start item.


Create Method (properties)

Create Method (properties)
Namespaces ► Sitecore.Web ► SiteInfo ► Create(StringDictionary)
Creates the specified properties.
Declaration Syntax
C#
public static SiteInfo Create(
    StringDictionary properties
)
Parameters
properties (StringDictionary)
The properties.
Return Value


Database Property

Database Property
Namespaces ► Sitecore.Web ► SiteInfo ► Database
Gets the database.
Declaration Syntax
C#
public string Database { get; }
Value
The database.


DefaultDevice Property

DefaultDevice Property
Namespaces ► Sitecore.Web ► SiteInfo ► DefaultDevice
Gets the default device.
Declaration Syntax
C#
public string DefaultDevice { get; }
Value
The default device.


Device Property

Device Property
Namespaces ► Sitecore.Web ► SiteInfo ► Device
Gets the device.
Declaration Syntax
C#
public string Device { get; }
Value
The device.


DisableClientData Property

DisableClientData Property
Namespaces ► Sitecore.Web ► SiteInfo ► DisableClientData
Gets a value indicating whether client data is disabled for the site.
Declaration Syntax
C#
public bool DisableClientData { get; }
Value
true if disabled; otherwise, false.


DisableXmlControls Property

DisableXmlControls Property
Namespaces ► Sitecore.Web ► SiteInfo ► DisableXmlControls
Gets a value indicating whether XML controls are disabled for this site.
Declaration Syntax
C#
public bool DisableXmlControls { get; }
Value
true if disabled; otherwise, false.


Domain Property

Domain Property
Namespaces ► Sitecore.Web ► SiteInfo ► Domain
Gets the domain.
Declaration Syntax
C#
public string Domain { get; }
Value
The domain.


EnableAnalytics Property

EnableAnalytics Property
Namespaces ► Sitecore.Web ► SiteInfo ► EnableAnalytics
Gets a value indicating whether analytics is enabled.
Declaration Syntax
C#
public bool EnableAnalytics { get; }
Value
true if analytics is enabled; otherwise, false.


EnableDebugger Property

EnableDebugger Property
Namespaces ► Sitecore.Web ► SiteInfo ► EnableDebugger
Gets a value indicating whether the SiteInfo enables the debugger.
Declaration Syntax
C#
public bool EnableDebugger { get; }
Value
true if the SiteInfo enables the debugger; otherwise, false.


EnableLinkedItems Property

EnableLinkedItems Property
Namespaces ► Sitecore.Web ► SiteInfo ► EnableLinkedItems
Gets a value indicating whether the SiteInfo enables the linked items.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public bool EnableLinkedItems { get; }
Value
true if the SiteInfo enables the linked items; otherwise, false.


EnablePreview Property

EnablePreview Property
Namespaces ► Sitecore.Web ► SiteInfo ► EnablePreview
Gets a value indicating whether the SiteInfo enables preview.
Declaration Syntax
C#
public bool EnablePreview { get; }
Value
true if the SiteInfo enables preview; otherwise, false.


EnableWebEdit Property

EnableWebEdit Property
Namespaces ► Sitecore.Web ► SiteInfo ► EnableWebEdit
Gets a value indicating whether the SiteInfo enables web edit.
Declaration Syntax
C#
public bool EnableWebEdit { get; }
Value
true if the SiteInfo enables web edit; otherwise, false.


EnableWorkflow Property

EnableWorkflow Property
Namespaces ► Sitecore.Web ► SiteInfo ► EnableWorkflow
Gets a value indicating whether the SiteInfo enables workflowing.
Declaration Syntax
C#
public bool EnableWorkflow { get; }
Value
true if the SiteInfo enables workflowing; otherwise, false.


FilteredItemsCache Property

FilteredItemsCache Property
Namespaces ► Sitecore.Web ► SiteInfo ► FilteredItemsCache
Gets the filtered items cache.
Declaration Syntax
C#
public FilteredItemsCache FilteredItemsCache { get; }
Value
The filtered items cache.


FilterItems Property

FilterItems Property
Namespaces ► Sitecore.Web ► SiteInfo ► FilterItems
Checks if data is valid.
Declaration Syntax
C#
public bool FilterItems { get; }
Value
true if the SiteInfo filters the items; otherwise, false.


HostName Property

HostName Property
Namespaces ► Sitecore.Web ► SiteInfo ► HostName
Gets the name of the host.
Declaration Syntax
C#
public string HostName { get; }
Value
The name of the host.


HtmlCache Property

HtmlCache Property
Namespaces ► Sitecore.Web ► SiteInfo ► HtmlCache
Gets the HTML cache.
Declaration Syntax
C#
public HtmlCache HtmlCache { get; }
Value
The HTML cache.


HtmlCacheClearLatency Property

HtmlCacheClearLatency Property
Namespaces ► Sitecore.Web ► SiteInfo ► HtmlCacheClearLatency
Gets the HTML cache clear latency.
Declaration Syntax
C#
public string HtmlCacheClearLatency { get; }
Value
The HTML cache clear latency.


IsActive Property

IsActive Property
Namespaces ► Sitecore.Web ► SiteInfo ► IsActive
Gets a value indicating whether this instance is active.
Declaration Syntax
C#
public bool IsActive { get; }
Value
true if this instance is active; otherwise, false.


Language Property

Language Property
Namespaces ► Sitecore.Web ► SiteInfo ► Language
Gets the language.
Declaration Syntax
C#
public string Language { get; }
Value
The language.


LoginPage Property

LoginPage Property
Namespaces ► Sitecore.Web ► SiteInfo ► LoginPage
Gets the login page.
Declaration Syntax
C#
public string LoginPage { get; }
Value
The login page.


MasterDatabase Property

MasterDatabase Property
Namespaces ► Sitecore.Web ► SiteInfo ► MasterDatabase
Gets the master database name.
Declaration Syntax
C#
public string MasterDatabase { get; }
Value
The master database name.


Matches Method

Matches Method
Namespaces ► Sitecore.Web ► SiteInfo ► Matches()()()
Members
Icon | Member | Description
 | Matches(String, String) | Checks if a server name is a match.
 | Matches(String, String, Int32) | Checks if a server name is a match.


Matches Method (hostName, folder)

Matches Method (hostName, folder)
Namespaces ► Sitecore.Web ► SiteInfo ► Matches(String, String)
Checks if a server name is a match.
Declaration Syntax
C#
public bool Matches(
    string hostName,
    string folder
)
Parameters
hostName (String)
Name of the host.
folder (String)
The folder.
Return Value


Matches Method (hostName, folder, portNumber)

Matches Method (hostName, folder, portNumber)
Namespaces ► Sitecore.Web ► SiteInfo ► Matches(String, String, Int32)
Checks if a server name is a match.
Declaration Syntax
C#
public bool Matches(
    string hostName,
    string folder,
    int portNumber
)
Parameters
hostName (String)
Name of the host.
folder (String)
The folder.
portNumber (Int32)
The port number.
Return Value


MediaCachePath Property

MediaCachePath Property
Namespaces ► Sitecore.Web ► SiteInfo ► MediaCachePath
Gets the path to the media cache.
Declaration Syntax
C#
public string MediaCachePath { get; }
Value
The media cache path.


Name Property

Name Property
Namespaces ► Sitecore.Web ► SiteInfo ► Name
Gets the name.
Declaration Syntax
C#
public string Name { get; }
Value
The name.


PhysicalFolder Property

PhysicalFolder Property
Namespaces ► Sitecore.Web ► SiteInfo ► PhysicalFolder
Gets the physical folder.
Declaration Syntax
C#
public string PhysicalFolder { get; }
Value
The physical folder.


Port Property

Port Property
Namespaces ► Sitecore.Web ► SiteInfo ► Port
Gets the port number.
Declaration Syntax
C#
public int Port { get; }
Value
The port number.


Properties Property

Properties Property
Namespaces ► Sitecore.Web ► SiteInfo ► Properties
Gets the properties.
Declaration Syntax
C#
public NameValueCollection Properties { get; }
Value
The properties.


RegistryCache Property

RegistryCache Property
Namespaces ► Sitecore.Web ► SiteInfo ► RegistryCache
Gets the registry cache.
Declaration Syntax
C#
public RegistryCache RegistryCache { get; }
Value
The registry cache.


RequireLogin Property

RequireLogin Property
Namespaces ► Sitecore.Web ► SiteInfo ► RequireLogin
Gets a value indicating whether the SiteInfo requires login.
Declaration Syntax
C#
public bool RequireLogin { get; }
Value
true if the SiteInfo requires login; otherwise, false.


RootPath Property

RootPath Property
Namespaces ► Sitecore.Web ► SiteInfo ► RootPath
Path to root item in the database
Declaration Syntax
C#
public string RootPath { get; }
Value
The root path.


Scheme Property

Scheme Property
Namespaces ► Sitecore.Web ► SiteInfo ► Scheme
Gets the scheme (ie. http or https).
Declaration Syntax
C#
public string Scheme { get; }
Value
The scheme.


StartItem Property

StartItem Property
Namespaces ► Sitecore.Web ► SiteInfo ► StartItem
Gets the start item.
Declaration Syntax
C#
public string StartItem { get; }
Value
The start item.


TargetHostName Property

TargetHostName Property
Namespaces ► Sitecore.Web ► SiteInfo ► TargetHostName
Gets the name of the target host.
Declaration Syntax
C#
public string TargetHostName { get; }
Value
The name of the target host.


ViewStateCache Property

ViewStateCache Property
Namespaces ► Sitecore.Web ► SiteInfo ► ViewStateCache
Gets the view state cache.
Declaration Syntax
C#
public ViewStateCache ViewStateCache { get; }
Value
The view state cache.


VirtualFolder Property

VirtualFolder Property
Namespaces ► Sitecore.Web ► SiteInfo ► VirtualFolder
Gets the virtual folder.
Declaration Syntax
C#
public string VirtualFolder { get; }
Value
The virtual folder.


XmlControlPage Property

XmlControlPage Property
Namespaces ► Sitecore.Web ► SiteInfo ► XmlControlPage
Gets the XML control page.
Declaration Syntax
C#
public string XmlControlPage { get; }
Value
The XML control page.


XslCache Property

XslCache Property
Namespaces ► Sitecore.Web ► SiteInfo ► XslCache
Gets the XSL cache.
Declaration Syntax
C#
public XslCache XslCache { get; }
Value
The XSL cache.


UrlHandle Class

UrlHandle Class
Namespaces ► Sitecore.Web ► UrlHandle
Represents a UrlHandle.
Declaration Syntax
C#
public class UrlHandle
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UrlHandle()()() | Initializes a new instance of the UrlHandle class.
 | Add(UrlString) | Adds the specified URL string.
 | Add(UrlString, String) | Adds the specified URL string.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get()()() | Gets this instance.
 | Get(UrlString) | Gets the specified URL string.
 | Get(UrlString, String) | Gets the specified URL string.
 | Get(UrlString, String, Boolean) | Gets the specified URL string.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle | Gets or sets the handle.
 | Item[([(String])]) | Gets the String with the specified key.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToHandleString()()() | Converts the UrlHandle to a String.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UrlHandle


UrlHandle Constructor

UrlHandle Constructor
Namespaces ► Sitecore.Web ► UrlHandle ► UrlHandle()()()
Initializes a new instance of the UrlHandle class.
Declaration Syntax
C#
public UrlHandle()


Add Method

Add Method
Namespaces ► Sitecore.Web ► UrlHandle ► Add()()()
Members
Icon | Member | Description
 | Add(UrlString) | Adds the specified URL string.
 | Add(UrlString, String) | Adds the specified URL string.


Add Method (urlString)

Add Method (urlString)
Namespaces ► Sitecore.Web ► UrlHandle ► Add(UrlString)
Adds the specified URL string.
Declaration Syntax
C#
public void Add(
    UrlString urlString
)
Parameters
urlString (UrlString)
The URL string.


Add Method (urlString, handleName)

Add Method (urlString, handleName)
Namespaces ► Sitecore.Web ► UrlHandle ► Add(UrlString, String)
Adds the specified URL string.
Declaration Syntax
C#
public void Add(
    UrlString urlString,
    string handleName
)
Parameters
urlString (UrlString)
The URL string.
handleName (String)
Name of the handle.


Get Method

Get Method
Namespaces ► Sitecore.Web ► UrlHandle ► Get()()()
Members
Icon | Member | Description
 | Get()()() | Gets this instance.
 | Get(UrlString) | Gets the specified URL string.
 | Get(UrlString, String) | Gets the specified URL string.
 | Get(UrlString, String, Boolean) | Gets the specified URL string.


Get Method

Get Method
Namespaces ► Sitecore.Web ► UrlHandle ► Get()()()
Gets this instance.
Declaration Syntax
C#
public static UrlHandle Get()


Get Method (urlString)

Get Method (urlString)
Namespaces ► Sitecore.Web ► UrlHandle ► Get(UrlString)
Gets the specified URL string.
Declaration Syntax
C#
public static UrlHandle Get(
    UrlString urlString
)
Parameters
urlString (UrlString)
The URL string.


Get Method (urlString, handleName)

Get Method (urlString, handleName)
Namespaces ► Sitecore.Web ► UrlHandle ► Get(UrlString, String)
Gets the specified URL string.
Declaration Syntax
C#
public static UrlHandle Get(
    UrlString urlString,
    string handleName
)
Parameters
urlString (UrlString)
The URL string.
handleName (String)
Name of the handle.


Get Method (urlString, handleName, removeSessionValue)

Get Method (urlString, handleName, removeSessionValue)
Namespaces ► Sitecore.Web ► UrlHandle ► Get(UrlString, String, Boolean)
Gets the specified URL string.
Declaration Syntax
C#
public static UrlHandle Get(
    UrlString urlString,
    string handleName,
    bool removeSessionValue
)
Parameters
urlString (UrlString)
The URL string.
handleName (String)
Name of the handle.
removeSessionValue (Boolean)
if set to true this instance is remove session value.


Handle Property

Handle Property
Namespaces ► Sitecore.Web ► UrlHandle ► Handle
Gets or sets the handle.
Declaration Syntax
C#
public string Handle { get; set; }
Value
The handle.


Item Property (key)

Item Property (key)
Namespaces ► Sitecore.Web ► UrlHandle ► Item[([(String])])
Gets the String with the specified key.
Declaration Syntax
C#
public string this[
    string key
] { get; set; }
Parameters
key (String)
Value
The String.


ToHandleString Method

ToHandleString Method
Namespaces ► Sitecore.Web ► UrlHandle ► ToHandleString()()()
Converts the UrlHandle to a String.
Declaration Syntax
C#
public string ToHandleString()
Return Value
The String.


WebUtil Class

WebUtil Class
Namespaces ► Sitecore.Web ► WebUtil
Implements a library of standard utility functions relating to Web operations.
Declaration Syntax
C#
public class WebUtil
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WebUtil()()() | Initializes a new instance of the WebUtil class
 | AddPageControl(Page, Control) | Add control to page
 | AddQueryString(String, array<String>[]()[]) | Adds a parameter to an URL.
 | AddQueryString(String, Boolean, array<String>[]()[]) | Adds a parameter to an URL.
 | BuildQueryString(SafeDictionary<(Of <(String>)>), Boolean) | Builds the query string.
 | CurrentPage | Gets the current page.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteWebPage(String) | Executes a web page.
 | ExecuteWebPage(String, NameValueCollection) | Executes a web page.
 | ExtractFilePath(String) | Extracts the file path from an URL.
 | ExtractUrlParm(String, String) | Extracts a parameter from an URL.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindAncestorOfType(Control, Type, Boolean) | Finds the ancestor of the specified type.
 | FindAncestorOfType(Control, String, Boolean) | Finds the ancestor of the specified type.
 | FindControl(Control, String) | Finds the control.
 | FindControlOfType(Control, Type) | Finds the control of the specified type.
 | FindControlOfType(Control, Type, String) | Finds the control of the specified type.
 | FindControlsOfType(Type, Control) | Finds all controls of the specified type.
 | FindPlaceholder(String, Control) | Finds a placeholder below a root control.
 | FindSubControls<(Of <(T>)>)(Control) | Finds all controls of the specified type.
 | GetAnchor(Item, String) | Creates an anchor control from a link field.
 | GetAnchor(Item, String, String) | Creates an anchor control from a link field.
 | GetBrowserCapabilities()()() | Gets the browser capabilities.
 | GetCookieBool(String, Boolean) | Gets a boolean cookie value.
 | GetCookieDateTime(String, DateTime) | Gets a date/time cookie value.
 | GetCookieValue(String) | Gets the cookie value.
 | GetCookieValue(String, String, String) | Gets the cookie value.
 | GetCookieValue(String, String) | Gets a cookie value.
 | GetErrorControl(String, String) | Gets the control to display an error message.
 | GetFormControl(Page) | Get the form control of a page
 | GetFormValue(String) | Gets a value posted with a form.
 | GetFullUrl(String) | Expands an URL path to include the protocol, host and port.
 | GetFullUrl(String, String) | Expands an URL path to include the protocol, host and port.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHostIPAddress()()() | Gets the IP address of the server host.
 | GetHostName()()() | Gets the DNS name of the server host.
 | GetIISName()()() | Gets the IIS name of the web site.
 | GetItemsBool(String, Boolean) | Gets an boolean value from the Items collection.
 | GetItemsString(String) | Gets an string value from the Items collection.
 | GetItemsValue(String) | Gets an object from the Items collection.
 | GetLocalPath(String) | Gets the local path of an URL (ie. no query string).
 | GetOriginalCookieValue(String) | Gets the original value of a cookie.
 | GetPathAndQuery(String) | Gets the path and query of a URL.
 | GetPlaceholders(Type) | Gets the all placeholders on the current page.
 | GetPort()()() | Gets the port number of the server host.
 | GetQueryString()()() | Gets the entire query string of the current HTTP request.
 | GetQueryString(String) | Gets a safe query string value from the current HTTP request.
 | GetQueryString(String, String) | Gets a safe query string value from the current HTTP request.
 | GetQueryStringOrCookie(String) | Gets the query string or cookie.
 | GetQueryStringOrCookie(String, String) | Gets the query string or cookie.
 | GetRawUrl()()() | Gets the raw URL.
 | GetRequestFlag(String, Boolean) | Gets a boolean flag from the current HTTP request query string.
 | GetRequestHeader(String) | Gets a header value from the current HTTP request.
 | GetRequestInt(String, Int32) | Gets an integer value from the current HTTP request query string.
 | GetRequestUri()()() | Gets the Uri the current HTTP request.
 | GetRequestUri404(String) | Gets the request Uri. Can handle requests which performed without aspx extention.
 | GetScheme()()() | Gets the current scheme (ie. http or https).
 | GetServer()()() | Gets the server.
 | GetServerUrl()()() | Gets the current server URL.
 | GetServerUrl(Boolean) | Gets the current server URL.
 | GetServerUrl(Uri, Boolean) | Gets the current server URL.
 | GetSessionBool(String, Boolean) | Gets a boolean value from the current session.
 | GetSessionDateTime(String, DateTime) | Gets a date/time value from the current session.
 | GetSessionID()()() | Gets the current session ID.
 | GetSessionString(String) | Gets a string value from the current session.
 | GetSessionString(String, String) | Gets a string value from the current session.
 | GetSessionTimeout()()() | Sets the session timeout.
 | GetSessionValue(String) | Gets an object from the current session.
 | GetSessionValue(String, HttpContext) | Gets an object from the current session.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUrl(Item, String) | Generates an URL path from a link field.
 | GetUrlName(Int32) | Gets an item name as specified in the current URL path.
 | GetWebItemSource()()() | Gets the item source path of the current HTTP request.
 | InsertControl(Control, String, Type, Page) | Insert control in a placeholder on the page
 | Is404Request(String) | Is404s the request.
 | IsExternalUrl(String) | Determines if a path is an external URL path.
 | IsInternalUrl(String) | Determines if a path is an internal URL path.
 | IsOnAspxPage()()() | Determines whether the current page is an aspx page.
 | IsOnPage(String) | Checks if the current page matches a path.
 | IsPostBack()()() | Determines whether the current request is a post back.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NormalizeUrl(String) | Normalizes a URL.
 | ParseQueryString(String) | Parses a query string into a dictionary of key/value pairs.
 | ParseUrlParameters(String) | Parses a list of URL parameters into a Hashtable of key/value pairs.
 | ParseUrlParameters(String, Char) | Parses a list of URL parameters into a Hashtable of key/value pairs.
 | PostFile(String, String, String, Int32, array<String>[]()[]) | Posts a file to a web page.
 | PostWebPage(String, ArrayList) | Posts data to a web page.
 | Redirect(String) | Redirects to another page.
 | Redirect(String, Boolean) | Redirects to another page.
 | RedirectToErrorPage(String) | Redirects to the error page.
 | RedirectToErrorPage(String, Boolean) | Redirects to the error page.
 | ReloadPage()()() | Reloads the current page.
 | RemoveItemsValue(String) | Removes an object from the current items.
 | RemoveQueryString(String) | Removes the query string from a Url.
 | RemoveSessionValue(String) | Removes an object from the current session.
 | ReplaceControl(Control, Control) | Replaces the control.
 | ReplaceUrlParameter(String, String, String, Boolean) | Replaces the URL parameter.
 | RewriteUrl(String) | Rewrites the current URL.
 | SafeEncode(String) | Encodes user input so that it is safe to use as output. Use to prevent XSS attacks.
 | SetCookieBool(String, Boolean) | Sets a boolean value in a cookie.
 | SetCookieDateTime(String, DateTime) | Sets a date/time value in a cookie.
 | SetCookieValue(String, String) | Sets a string value in a cookie.
 | SetCookieValue(String, String, DateTime) | Sets a string value in a cookie.
 | SetHtmlAttribute(HtmlControl, String, String) | Sets an attribute value on an HTML control.
 | SetItemsValue(String, Object) | Sets an object in the Items collection.
 | SetSessionTimeout(TimeSpan) | Sets the session timeout.
 | SetSessionValue(String, Object) | Sets an object value in the current session.
 | ShowControlTree(Control, Int32) | Show a control tree.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TransmitStream(Stream, HttpResponse, Int32) | Writes a stream to the output stream of the HTTP response object.
Remarks
Inheritance Hierarchy
Object
WebUtil
See Also
DateUtil
FileUtil
HtmlUtil
MainUtil
StringUtil


WebUtil Constructor

WebUtil Constructor
Namespaces ► Sitecore.Web ► WebUtil ► WebUtil()()()
Initializes a new instance of the WebUtil class
Declaration Syntax
C#
public WebUtil()


AddPageControl Method (page, control)

AddPageControl Method (page, control)
Namespaces ► Sitecore.Web ► WebUtil ► AddPageControl(Page, Control)
Add control to page
Declaration Syntax
C#
public static void AddPageControl(
    Page page,
    Control control
)
Parameters
page (Page)
The page.
control (Control)
The control.
Remarks
Control is appended to the main form control


AddQueryString Method

AddQueryString Method
Namespaces ► Sitecore.Web ► WebUtil ► AddQueryString()()()
Members
Icon | Member | Description
 | AddQueryString(String, array<String>[]()[]) | Adds a parameter to an URL.
 | AddQueryString(String, Boolean, array<String>[]()[]) | Adds a parameter to an URL.


AddQueryString Method (url, xhtml, parameters)

AddQueryString Method (url, xhtml, parameters)
Namespaces ► Sitecore.Web ► WebUtil ► AddQueryString(String, Boolean, array<String>[]()[])
Adds a parameter to an URL.
Declaration Syntax
C#
public static string AddQueryString(
    string url,
    bool xhtml,
    params string[] parameters
)
Parameters
url (String)
An URL path.
xhtml (Boolean)
If set to true '&' will be encoded as '&amp;'.
parameters (array< String >[]()[])
An array of parameter pairs.
Return Value
An URL path with the new parameters added.
Remarks
The parameters are added in pairs: name and value. The value is URL encoded.
Examples
CopyC#
string url0 = WebUtil.AddQueryString("http://www.mysite.net", "print", "1"); // "http://www.mysite.net?print=1"
string url1 = WebUtil.AddQueryString("http://www.mysite.net", "print", "1", "lg", "print"); // "http://www.mysite.net?print=1&lg=print"
See Also
UrlEncode(String)


AddQueryString Method (url, parameters)

AddQueryString Method (url, parameters)
Namespaces ► Sitecore.Web ► WebUtil ► AddQueryString(String, array<String>[]()[])
Adds a parameter to an URL.
Declaration Syntax
C#
public static string AddQueryString(
    string url,
    params string[] parameters
)
Parameters
url (String)
An URL path.
parameters (array< String >[]()[])
An array of parameter pairs.
Return Value
An URL path with the new parameters added.
Remarks
The parameters are added in pairs: name and value. The value is URL encoded.
Examples
CopyC#
string url0 = WebUtil.AddQueryString("http://www.mysite.net", "print", "1"); // "http://www.mysite.net?print=1"
string url1 = WebUtil.AddQueryString("http://www.mysite.net", "print", "1", "lg", "print"); // "http://www.mysite.net?print=1&lg=print"
See Also
UrlEncode(String)


BuildQueryString Method (parameters, xhtml)

BuildQueryString Method (parameters, xhtml)
Namespaces ► Sitecore.Web ► WebUtil ► BuildQueryString(SafeDictionary<(Of <(String>)>), Boolean)
Builds the query string.
Declaration Syntax
C#
public static string BuildQueryString(
    SafeDictionary<string> parameters,
    bool xhtml
)
Parameters
parameters (SafeDictionary <(Of <(String>)>))
The parameters.
xhtml (Boolean)
If set to true, return an XHTML compliant query string.
Return Value


CurrentPage Property

CurrentPage Property
Namespaces ► Sitecore.Web ► WebUtil ► CurrentPage
Gets the current page.
Declaration Syntax
C#
public static Page CurrentPage { get; }
Value
The current page.


ExecuteWebPage Method

ExecuteWebPage Method
Namespaces ► Sitecore.Web ► WebUtil ► ExecuteWebPage()()()
Members
Icon | Member | Description
 | ExecuteWebPage(String) | Executes a web page.
 | ExecuteWebPage(String, NameValueCollection) | Executes a web page.


ExecuteWebPage Method (url)

ExecuteWebPage Method (url)
Namespaces ► Sitecore.Web ► WebUtil ► ExecuteWebPage(String)
Executes a web page.
Declaration Syntax
C#
public static string ExecuteWebPage(
    string url
)
Parameters
url (String)
An URL path.
Return Value
The content of the web page.
Remarks
If URL does not contain a protocol ("protocol://", e.g. "http://" or "https://"), the page is assumed to be local, and the current server URL will be prepended.
Examples
CopyC#
string content = WebUtil.Execute("http://www.mysite.net");
See Also
WebClient


ExecuteWebPage Method (url, headers)

ExecuteWebPage Method (url, headers)
Namespaces ► Sitecore.Web ► WebUtil ► ExecuteWebPage(String, NameValueCollection)
Executes a web page.
Declaration Syntax
C#
public static string ExecuteWebPage(
    string url,
    NameValueCollection headers
)
Parameters
url (String)
An URL path.
headers (NameValueCollection)
A collection of HTTP headers values.
Return Value
The content of the web page.
Remarks
If URL does not contain a protocol ("protocol://", e.g. "http://" or "https://"), the page is assumed to be local, and the current server URL will be prepended.
Examples
CopyC#
string content = WebUtil.Execute("http://www.mysite.net");
See Also
WebClient


ExtractFilePath Method (url)

ExtractFilePath Method (url)
Namespaces ► Sitecore.Web ► WebUtil ► ExtractFilePath(String)
Extracts the file path from an URL.
Declaration Syntax
C#
public static string ExtractFilePath(
    string url
)
Parameters
url (String)
The URL.
Return Value
The url without server and query string
Examples
http://www.server.com/news.aspx?id=10 returns /news.aspx


ExtractUrlParm Method (name, url)

ExtractUrlParm Method (name, url)
Namespaces ► Sitecore.Web ► WebUtil ► ExtractUrlParm(String, String)
Extracts a parameter from an URL.
Declaration Syntax
C#
public static string ExtractUrlParm(
    string name,
    string url
)
Parameters
name (String)
Name of the parameter.
url (String)
An URL path.
Return Value
The value of the parameter.
Remarks
If the parameter does not exist, blank is returned. The parameters are URL decoded.
Examples
CopyC#
string print = WebUtil.ExtractUrlParm("print", "http://www.mysite.net?print=1&lg=print"); // "1"
See Also
UrlDecode(String)


FindAncestorOfType Method

FindAncestorOfType Method
Namespaces ► Sitecore.Web ► WebUtil ► FindAncestorOfType()()()
Members
Icon | Member | Description
 | FindAncestorOfType(Control, Type, Boolean) | Finds the ancestor of the specified type.
 | FindAncestorOfType(Control, String, Boolean) | Finds the ancestor of the specified type.


FindAncestorOfType Method (control, typeName, includeSelf)

FindAncestorOfType Method (control, typeName, includeSelf)
Namespaces ► Sitecore.Web ► WebUtil ► FindAncestorOfType(Control, String, Boolean)
Finds the ancestor of the specified type.
Declaration Syntax
C#
public static Control FindAncestorOfType(
    Control control,
    string typeName,
    bool includeSelf
)
Parameters
control (Control)
The control.
typeName (String)
Name of the type.
includeSelf (Boolean)
if set to true this instance is include self.
Return Value


FindAncestorOfType Method (control, type, includeSelf)

FindAncestorOfType Method (control, type, includeSelf)
Namespaces ► Sitecore.Web ► WebUtil ► FindAncestorOfType(Control, Type, Boolean)
Finds the ancestor of the specified type.
Declaration Syntax
C#
public static Control FindAncestorOfType(
    Control control,
    Type type,
    bool includeSelf
)
Parameters
control (Control)
The control.
type (Type)
The type.
includeSelf (Boolean)
if set to true this instance is include self.
Return Value


FindControl Method (parent, name)

FindControl Method (parent, name)
Namespaces ► Sitecore.Web ► WebUtil ► FindControl(Control, String)
Finds the control.
Declaration Syntax
C#
public static Control FindControl(
    Control parent,
    string name
)
Parameters
parent (Control)
The parent.
name (String)
The name.
Return Value


FindControlOfType Method

FindControlOfType Method
Namespaces ► Sitecore.Web ► WebUtil ► FindControlOfType()()()
Members
Icon | Member | Description
 | FindControlOfType(Control, Type) | Finds the control of the specified type.
 | FindControlOfType(Control, Type, String) | Finds the control of the specified type.


FindControlOfType Method (parentControl, targetType)

FindControlOfType Method (parentControl, targetType)
Namespaces ► Sitecore.Web ► WebUtil ► FindControlOfType(Control, Type)
Finds the control of the specified type.
Declaration Syntax
C#
public static Control FindControlOfType(
    Control parentControl,
    Type targetType
)
Parameters
parentControl (Control)
The parent control.
targetType (Type)
Type of the target.
Return Value


FindControlOfType Method (parentControl, targetType, targetID)

FindControlOfType Method (parentControl, targetType, targetID)
Namespaces ► Sitecore.Web ► WebUtil ► FindControlOfType(Control, Type, String)
Finds the control of the specified type.
Declaration Syntax
C#
public static Control FindControlOfType(
    Control parentControl,
    Type targetType,
    string targetID
)
Parameters
parentControl (Control)
The parent control.
targetType (Type)
Type of the target.
targetID (String)
The target ID.
Return Value


FindControlsOfType Method (type, parentControl)

FindControlsOfType Method (type, parentControl)
Namespaces ► Sitecore.Web ► WebUtil ► FindControlsOfType(Type, Control)
Finds all controls of the specified type.
Declaration Syntax
C#
public static Control[] FindControlsOfType(
    Type type,
    Control parentControl
)
Parameters
type (Type)
The type.
parentControl (Control)
The parent control.
Return Value


FindPlaceholder Method (key, root)

FindPlaceholder Method (key, root)
Namespaces ► Sitecore.Web ► WebUtil ► FindPlaceholder(String, Control)
Finds a placeholder below a root control.
Declaration Syntax
C#
public static Placeholder FindPlaceholder(
    string key,
    Control root
)
Parameters
key (String)
The key.
root (Control)
The root control.
Return Value


FindSubControls Method (parentControl)

FindSubControls<(Of <(T>)>) Method (parentControl)
Namespaces ► Sitecore.Web ► WebUtil ► FindSubControls<(Of <(T>)>)(Control)
Finds all controls of the specified type.
Declaration Syntax
C#
public static List<T> FindSubControls<T>(
    Control parentControl
)
where T : Control
Generic Template Parameters
T
Parameters
parentControl (Control)
The parent control.
Return Value


GetAnchor Method

GetAnchor Method
Namespaces ► Sitecore.Web ► WebUtil ► GetAnchor()()()
Members
Icon | Member | Description
 | GetAnchor(Item, String) | Creates an anchor control from a link field.
 | GetAnchor(Item, String, String) | Creates an anchor control from a link field.


GetAnchor Method (itm, linkField)

GetAnchor Method (itm, linkField)
Namespaces ► Sitecore.Web ► WebUtil ► GetAnchor(Item, String)
Creates an anchor control from a link field.
Declaration Syntax
C#
public static HtmlAnchor GetAnchor(
    Item itm,
    string linkField
)
Parameters
itm (Item)
An item.
linkField (String)
Name of the link field in the item.
Return Value
The created HtmlAnchor control.
Remarks
The inner text of the anchor control is blank.
Examples
CopyC#
IMasterItem item = MasterFactory.GetItem("/sitecore/content/Home");
HtmlAnchor anchor = WebUtil.GetAnchor(item, "Link");
See Also
HtmlAnchor


GetAnchor Method (itm, linkFieldName, text)

GetAnchor Method (itm, linkFieldName, text)
Namespaces ► Sitecore.Web ► WebUtil ► GetAnchor(Item, String, String)
Creates an anchor control from a link field.
Declaration Syntax
C#
public static HtmlAnchor GetAnchor(
    Item itm,
    string linkFieldName,
    string text
)
Parameters
itm (Item)
An item.
linkFieldName (String)
Name of the link field in the item.
text (String)
Inner text of the anchor control.
Return Value
The created HtmlAnchor control.
Examples
CopyC#
IMasterItem item = MasterFactory.GetItem("/sitecore/content/Home");
HtmlAnchor anchor = WebUtil.GetAnchor(item, "Link", "Click me");
See Also
HtmlAnchor


GetBrowserCapabilities Method

GetBrowserCapabilities Method
Namespaces ► Sitecore.Web ► WebUtil ► GetBrowserCapabilities()()()
Gets the browser capabilities.
Declaration Syntax
C#
public static HttpBrowserCapabilities GetBrowserCapabilities()
Return Value
The browser capabilities.


GetCookieBool Method (key, defaultValue)

GetCookieBool Method (key, defaultValue)
Namespaces ► Sitecore.Web ► WebUtil ► GetCookieBool(String, Boolean)
Gets a boolean cookie value.
Declaration Syntax
C#
public static bool GetCookieBool(
    string key,
    bool defaultValue
)
Parameters
key (String)
Cookie key.
defaultValue (Boolean)
A default value.
Return Value
The value of the cookie as a boolean.
Remarks
If the cookie was not found, the default value is returned.
Examples
CopyC#
bool val = WebUtil.GetCookieBool("mykey", true);
See Also
Cookies


GetCookieDateTime Method (key, defaultValue)

GetCookieDateTime Method (key, defaultValue)
Namespaces ► Sitecore.Web ► WebUtil ► GetCookieDateTime(String, DateTime)
Gets a date/time cookie value.
Declaration Syntax
C#
public static DateTime GetCookieDateTime(
    string key,
    DateTime defaultValue
)
Parameters
key (String)
Cookie key.
defaultValue (DateTime)
A default value.
Return Value
The value of the cookie as a date/time.
Remarks
If the cookie was not found, the default value is returned.
Examples
CopyC#
DateTime val = WebUtil.GetCookieDateTime("mykey", DateTime.Now);
See Also
Cookies


GetCookieValue Method

GetCookieValue Method
Namespaces ► Sitecore.Web ► WebUtil ► GetCookieValue()()()
Members
Icon | Member | Description
 | GetCookieValue(String) | Gets the cookie value.
 | GetCookieValue(String, String, String) | Gets the cookie value.
 | GetCookieValue(String, String) | Gets a cookie value.


GetCookieValue Method (key)

GetCookieValue Method (key)
Namespaces ► Sitecore.Web ► WebUtil ► GetCookieValue(String)
Gets the cookie value.
Declaration Syntax
C#
public static string GetCookieValue(
    string key
)
Parameters
key (String)
The key.
Return Value


GetCookieValue Method (key, defaultValue)

GetCookieValue Method (key, defaultValue)
Namespaces ► Sitecore.Web ► WebUtil ► GetCookieValue(String, String)
Gets a cookie value.
Declaration Syntax
C#
public static string GetCookieValue(
    string key,
    string defaultValue
)
Parameters
key (String)
Cookie key.
defaultValue (String)
The default value.
Return Value
The value of the cookie.
Remarks
If the cookie was not found, null is returned.
Examples
CopyC#
string val = WebUtil.GetCookieValue("mykey");
See Also
Cookies


GetCookieValue Method (siteName, key, defaultValue)

GetCookieValue Method (siteName, key, defaultValue)
Namespaces ► Sitecore.Web ► WebUtil ► GetCookieValue(String, String, String)
Gets the cookie value.
Declaration Syntax
C#
public static string GetCookieValue(
    string siteName,
    string key,
    string defaultValue
)
Parameters
siteName (String)
Name of the site.
key (String)
The key.
defaultValue (String)
The default value.
Return Value
The cookie value.


GetErrorControl Method (error, details)

GetErrorControl Method (error, details)
Namespaces ► Sitecore.Web ► WebUtil ► GetErrorControl(String, String)
Gets the control to display an error message.
Declaration Syntax
C#
public static Control GetErrorControl(
    string error,
    string details
)
Parameters
error (String)
The error.
details (String)
The details.
Return Value


GetFormControl Method (page)

GetFormControl Method (page)
Namespaces ► Sitecore.Web ► WebUtil ► GetFormControl(Page)
Get the form control of a page
Declaration Syntax
C#
public static Control GetFormControl(
    Page page
)
Parameters
page (Page)
The page.
Return Value


GetFormValue Method (fieldName)

GetFormValue Method (fieldName)
Namespaces ► Sitecore.Web ► WebUtil ► GetFormValue(String)
Gets a value posted with a form.
Declaration Syntax
C#
public static string GetFormValue(
    string fieldName
)
Parameters
fieldName (String)
Name of the field.
Return Value


GetFullUrl Method

GetFullUrl Method
Namespaces ► Sitecore.Web ► WebUtil ► GetFullUrl()()()
Members
Icon | Member | Description
 | GetFullUrl(String) | Expands an URL path to include the protocol, host and port.
 | GetFullUrl(String, String) | Expands an URL path to include the protocol, host and port.


GetFullUrl Method (url)

GetFullUrl Method (url)
Namespaces ► Sitecore.Web ► WebUtil ► GetFullUrl(String)
Expands an URL path to include the protocol, host and port.
Declaration Syntax
C#
public static string GetFullUrl(
    string url
)
Parameters
url (String)
An URL path.
Return Value
The URL with protocol, host and port.
Remarks
The port part is omitted, if the port is 80 (the HTTP port).
Examples
CopyC#
string url = WebUtil.GetFullUrl("/home.aspx"); // "http//www.mysite.net/home.aspx"


GetFullUrl Method (url, serverUrl)

GetFullUrl Method (url, serverUrl)
Namespaces ► Sitecore.Web ► WebUtil ► GetFullUrl(String, String)
Expands an URL path to include the protocol, host and port.
Declaration Syntax
C#
public static string GetFullUrl(
    string url,
    string serverUrl
)
Parameters
url (String)
An URL path.
serverUrl (String)
A server part consisting of protocol, host and port.
Return Value
The URL with protocol, host and port.
Remarks

The serverUrl parameter is ignore, if the URL path contains a protocol part identified by the string "://".

The port part is omitted, if the port is 80 (the HTTP port).

Examples
CopyC#
string url = WebUtil.GetFullUrl("/home.aspx", "http//www.mysite.net"); // "http//www.mysite.net/home.aspx"


GetHostIPAddress Method

GetHostIPAddress Method
Namespaces ► Sitecore.Web ► WebUtil ► GetHostIPAddress()()()
Gets the IP address of the server host.
Declaration Syntax
C#
public static string GetHostIPAddress()
Return Value
The IP address of the host.
Remarks
If the host address cannot be converted to an IP address, blank is returned.
Examples
CopyC#
string host = WebUtil.GetHostIPAddress(); // "127.0.0.1"
See Also
Url


GetHostName Method

GetHostName Method
Namespaces ► Sitecore.Web ► WebUtil ► GetHostName()()()
Gets the DNS name of the server host.
Declaration Syntax
C#
public static string GetHostName()
Return Value
The DNS name of the server host.
Remarks
If the host cannot be obtained, blank is returned.
Examples
CopyC#
string host = WebUtil.GetHostName(); // "www.mysite.net"
See Also
Url


GetIISName Method

GetIISName Method
Namespaces ► Sitecore.Web ► WebUtil ► GetIISName()()()
Gets the IIS name of the web site.
Declaration Syntax
C#
public static string GetIISName()
Return Value
The path to the web site on the IIS server.
Remarks
This method can be used to identify the web site on the IIS server.
Examples
CopyC#
string name = Webutil.GetIISName(); / "c:\inetpub\wwwroot\mysite"


GetItemsBool Method (key, defaultValue)

GetItemsBool Method (key, defaultValue)
Namespaces ► Sitecore.Web ► WebUtil ► GetItemsBool(String, Boolean)
Gets an boolean value from the Items collection.
Declaration Syntax
C#
public static bool GetItemsBool(
    string key,
    bool defaultValue
)
Parameters
key (String)
Name of the value.
defaultValue (Boolean)
A default value.
Return Value
The value of the item in the Items collection.
Remarks
If the key was not found, the default is returned.
Examples
CopyC#
bool b = WebUtil.GetItemsBool("mykey", true);
See Also
Items


GetItemsString Method (key)

GetItemsString Method (key)
Namespaces ► Sitecore.Web ► WebUtil ► GetItemsString(String)
Gets an string value from the Items collection.
Declaration Syntax
C#
public static string GetItemsString(
    string key
)
Parameters
key (String)
Name of the value.
Return Value
The value of the item in the Items collection.
Remarks
If the key was not found, the blank is returned.
Examples
CopyC#
string s = WebUtil.GetItemsString("mykey");
See Also
Items


GetItemsValue Method (key)

GetItemsValue Method (key)
Namespaces ► Sitecore.Web ► WebUtil ► GetItemsValue(String)
Gets an object from the Items collection.
Declaration Syntax
C#
public static Object GetItemsValue(
    string key
)
Parameters
key (String)
Name of the object.
Return Value
The named object in the Items collection.
Remarks
If the key was not found, the null is returned.
Examples
CopyC#
object o = WebUtil.GetItemsValue("mykey");
See Also
Items


GetLocalPath Method (rawUrl)

GetLocalPath Method (rawUrl)
Namespaces ► Sitecore.Web ► WebUtil ► GetLocalPath(String)
Gets the local path of an URL (ie. no query string).
Declaration Syntax
C#
public static string GetLocalPath(
    string rawUrl
)
Parameters
rawUrl (String)
The raw URL.
Return Value


GetOriginalCookieValue Method (cookieName)

GetOriginalCookieValue Method (cookieName)
Namespaces ► Sitecore.Web ► WebUtil ► GetOriginalCookieValue(String)
Gets the original value of a cookie.
Declaration Syntax
C#
public static string GetOriginalCookieValue(
    string cookieName
)
Parameters
cookieName (String)
Name of the cookie.
Return Value


GetPathAndQuery Method (url)

GetPathAndQuery Method (url)
Namespaces ► Sitecore.Web ► WebUtil ► GetPathAndQuery(String)
Gets the path and query of a URL.
Declaration Syntax
C#
public static string GetPathAndQuery(
    string url
)
Parameters
url (String)
The URL.
Return Value


GetPlaceholders Method (placeholderType)

GetPlaceholders Method (placeholderType)
Namespaces ► Sitecore.Web ► WebUtil ► GetPlaceholders(Type)
Gets the all placeholders on the current page.
Declaration Syntax
C#
public static HashList<string, Object> GetPlaceholders(
    Type placeholderType
)
Parameters
placeholderType (Type)
Type of the placeholder.
Return Value


GetPort Method

GetPort Method
Namespaces ► Sitecore.Web ► WebUtil ► GetPort()()()
Gets the port number of the server host.
Declaration Syntax
C#
public static int GetPort()
Return Value
The port number of the server host.
Remarks
If the host cannot be obtained, 80.


GetQueryString Method

GetQueryString Method
Namespaces ► Sitecore.Web ► WebUtil ► GetQueryString()()()
Members
Icon | Member | Description
 | GetQueryString()()() | Gets the entire query string of the current HTTP request.
 | GetQueryString(String) | Gets a safe query string value from the current HTTP request.
 | GetQueryString(String, String) | Gets a safe query string value from the current HTTP request.


GetQueryString Method

GetQueryString Method
Namespaces ► Sitecore.Web ► WebUtil ► GetQueryString()()()
Gets the entire query string of the current HTTP request.
Declaration Syntax
C#
public static string GetQueryString()
Return Value
The raw URL path.
Remarks
The parameters are URL decoded.
Examples
CopyC#
string url = WebUtil.GetQueryString(); // "http://www.mysite.net/home.aspx?print=1"
See Also
RawUrl
UrlDecode(String)


GetQueryString Method (key)

GetQueryString Method (key)
Namespaces ► Sitecore.Web ► WebUtil ► GetQueryString(String)
Gets a safe query string value from the current HTTP request.
Declaration Syntax
C#
public static string GetQueryString(
    string key
)
Parameters
key (String)
Name of value to get.
Return Value
The value of the parameter.
Remarks

This method is a work-around to a bug in ASP.NET.

Direct access to an empty QueryString collection will cause the RewritePath method in the HttpModule to fail after exactly 50 calls.

This methods avoids direct access to QueryString collection.

If the parameter was not found, blank is returned.

Examples
CopyC#
// query string = "/home.aspx?print=1"
string print = WebUtil.GetQueryString("print"); / "1"
string target = WebUtil.GetQueryString("target"); / ""
See Also
QueryString
Url


GetQueryString Method (key, defaultValue)

GetQueryString Method (key, defaultValue)
Namespaces ► Sitecore.Web ► WebUtil ► GetQueryString(String, String)
Gets a safe query string value from the current HTTP request.
Declaration Syntax
C#
public static string GetQueryString(
    string key,
    string defaultValue
)
Parameters
key (String)
Name of value to get.
defaultValue (String)
A default value.
Return Value
The value of the parameter.
Remarks

This method is a work-around to a bug in ASP.NET.

Direct access to an empty QueryString collection will cause the RewritePath method in the HttpModule to fail after exactly 50 calls.

This methods avoids direct access to QueryString collection.

If the parameter was not found, the default value is returned.

Examples
CopyC#
// query string = "/home.aspx?print=1"
string print = WebUtil.GetQueryString("print", "0"); // "1"
string target = WebUtil.GetQueryString("target", "0"); // "0"
See Also
QueryString


GetQueryStringOrCookie Method

GetQueryStringOrCookie Method
Namespaces ► Sitecore.Web ► WebUtil ► GetQueryStringOrCookie()()()
Members
Icon | Member | Description
 | GetQueryStringOrCookie(String) | Gets the query string or cookie.
 | GetQueryStringOrCookie(String, String) | Gets the query string or cookie.


GetQueryStringOrCookie Method (key)

GetQueryStringOrCookie Method (key)
Namespaces ► Sitecore.Web ► WebUtil ► GetQueryStringOrCookie(String)
Gets the query string or cookie.
Declaration Syntax
C#
public static string GetQueryStringOrCookie(
    string key
)
Parameters
key (String)
The key.
Return Value


GetQueryStringOrCookie Method (key, defaultValue)

GetQueryStringOrCookie Method (key, defaultValue)
Namespaces ► Sitecore.Web ► WebUtil ► GetQueryStringOrCookie(String, String)
Gets the query string or cookie.
Declaration Syntax
C#
public static string GetQueryStringOrCookie(
    string key,
    string defaultValue
)
Parameters
key (String)
The key.
defaultValue (String)
The _default.
Return Value


GetRawUrl Method

GetRawUrl Method
Namespaces ► Sitecore.Web ► WebUtil ► GetRawUrl()()()
Gets the raw URL.
Declaration Syntax
C#
public static string GetRawUrl()
Return Value


GetRequestFlag Method (sName, defaultValue)

GetRequestFlag Method (sName, defaultValue)
Namespaces ► Sitecore.Web ► WebUtil ► GetRequestFlag(String, Boolean)
Gets a boolean flag from the current HTTP request query string.
Declaration Syntax
C#
public static bool GetRequestFlag(
    string sName,
    bool defaultValue
)
Parameters
sName (String)
Name of the flag
defaultValue (Boolean)
A default value.
Return Value
True, if the parameter is "1", otherwise false.
Remarks

The flag is true, if the query string value is "1".

If the name was not found in the query string, the default is returned.

Examples
CopyC#
// query string = "/home.aspx?print=1"
bool b0 = WebUtil.GetRequestFlag("print", false); // true
bool b1 = WebUtil.GetRequestFlag("group", false); // false
bool b2 = WebUtil.GetRequestFlag("target", true); // true
See Also
QueryString


GetRequestHeader Method (name)

GetRequestHeader Method (name)
Namespaces ► Sitecore.Web ► WebUtil ► GetRequestHeader(String)
Gets a header value from the current HTTP request.
Declaration Syntax
C#
public static string GetRequestHeader(
    string name
)
Parameters
name (String)
Name of the header.
Return Value
The value of the header.
Remarks
If the header value was not found, blank is returned.
Examples
CopyC#
string header = WebUtil.GetRequestHeader("myHeader");
See Also
Headers


GetRequestInt Method (sName, nDefault)

GetRequestInt Method (sName, nDefault)
Namespaces ► Sitecore.Web ► WebUtil ► GetRequestInt(String, Int32)
Gets an integer value from the current HTTP request query string.
Declaration Syntax
C#
public static int GetRequestInt(
    string sName,
    int nDefault
)
Parameters
sName (String)
Name of parameter.
nDefault (Int32)
A default value
Return Value
The value of the parameter.
Examples
CopyC#
// query string = "/home.aspx?print=1"
int i0 = WebUtil.GetQueryString("print", 0); // 1
int i1 = WebUtil.GetQueryString("target", 0); // 0
See Also
QueryString


GetRequestUri Method

GetRequestUri Method
Namespaces ► Sitecore.Web ► WebUtil ► GetRequestUri()()()
Gets the Uri the current HTTP request.
Declaration Syntax
C#
public static Uri GetRequestUri()
Return Value
The DNS name of the server host.
Remarks
If the host cannot be obtained, blank is returned.
Examples
CopyC#
string host = WebUtil.GetHostName(); // "www.mysite.net"
See Also
Url


GetRequestUri404 Method (url)

GetRequestUri404 Method (url)
Namespaces ► Sitecore.Web ► WebUtil ► GetRequestUri404(String)
Gets the request Uri. Can handle requests which performed without aspx extention.
Declaration Syntax
C#
public static string GetRequestUri404(
    string url
)
Parameters
url (String)
Return Value
The request Uri.


GetScheme Method

GetScheme Method
Namespaces ► Sitecore.Web ► WebUtil ► GetScheme()()()
Gets the current scheme (ie. http or https).
Declaration Syntax
C#
public static string GetScheme()
Return Value
The scheme of the current request url.
Examples
CopyC#
string scheme = WebUtil.GetScheme(); // "http"
See Also
Url


GetServer Method

GetServer Method
Namespaces ► Sitecore.Web ► WebUtil ► GetServer()()()
Gets the server.
Declaration Syntax
C#
public static HttpServerUtility GetServer()
Return Value


GetServerUrl Method

GetServerUrl Method
Namespaces ► Sitecore.Web ► WebUtil ► GetServerUrl()()()
Members
Icon | Member | Description
 | GetServerUrl()()() | Gets the current server URL.
 | GetServerUrl(Boolean) | Gets the current server URL.
 | GetServerUrl(Uri, Boolean) | Gets the current server URL.


GetServerUrl Method

GetServerUrl Method
Namespaces ► Sitecore.Web ► WebUtil ► GetServerUrl()()()
Gets the current server URL.
Declaration Syntax
C#
public static string GetServerUrl()
Return Value
The URL of the server.
Remarks
The server URL contains the port, if the port is not "80" (the default HTTP port).
Examples
CopyC#
string server = WebUtil.GetServerURL(); // "http://www.mysite.net:81"
See Also
Url


GetServerUrl Method (forcePort)

GetServerUrl Method (forcePort)
Namespaces ► Sitecore.Web ► WebUtil ► GetServerUrl(Boolean)
Gets the current server URL.
Declaration Syntax
C#
public static string GetServerUrl(
    bool forcePort
)
Parameters
forcePort (Boolean)
A boolean flag indicating if the port must be present.
Return Value
The URL of the server.
Remarks
The server URL contains the port, if the port is not "80" (the default HTTP port).
Examples
CopyC#
string server = WebUtil.GetServerURL(true); // "http://www.mysite.net:80"
string server = WebUtil.GetServerURL(false); // "http://www.mysite.net"
See Also
Url


GetServerUrl Method (url, forcePort)

GetServerUrl Method (url, forcePort)
Namespaces ► Sitecore.Web ► WebUtil ► GetServerUrl(Uri, Boolean)
Gets the current server URL.
Declaration Syntax
C#
public static string GetServerUrl(
    Uri url,
    bool forcePort
)
Parameters
url (Uri)
The URL.
forcePort (Boolean)
if set to true this instance is force port.
Return Value


GetSessionBool Method (key, defaultValue)

GetSessionBool Method (key, defaultValue)
Namespaces ► Sitecore.Web ► WebUtil ► GetSessionBool(String, Boolean)
Gets a boolean value from the current session.
Declaration Syntax
C#
public static bool GetSessionBool(
    string key,
    bool defaultValue
)
Parameters
key (String)
Name of the boolean value.
defaultValue (Boolean)
A default value.
Return Value
The value of the named session variable.
Remarks
If the session variable was not found, the default value is returned.
Examples
CopyC#
bool b = WebUtil.GetSessionBool("myBoolean", false);
See Also
HttpSessionState


GetSessionDateTime Method (key, defaultValue)

GetSessionDateTime Method (key, defaultValue)
Namespaces ► Sitecore.Web ► WebUtil ► GetSessionDateTime(String, DateTime)
Gets a date/time value from the current session.
Declaration Syntax
C#
public static DateTime GetSessionDateTime(
    string key,
    DateTime defaultValue
)
Parameters
key (String)
Name of the date/time value.
defaultValue (DateTime)
A default value.
Return Value
The value of the named session variable.
Remarks
If the session variable was not found, the default value is returned.
Examples
CopyC#
DateTime dt = WebUtil.GetSessionDateTime("myBoolean", DateTime.Now);
See Also
HttpSessionState


GetSessionID Method

GetSessionID Method
Namespaces ► Sitecore.Web ► WebUtil ► GetSessionID()()()
Gets the current session ID.
Declaration Syntax
C#
public static string GetSessionID()
Return Value
The current session ID.
Remarks
If there is no current session, the value of the ASP.NET session id cookie (default: asp.net_sessionid) is returned.
Examples
CopyC#
string sessionID = WebUtil.GetSessionID();
See Also
SessionID


GetSessionString Method

GetSessionString Method
Namespaces ► Sitecore.Web ► WebUtil ► GetSessionString()()()
Members
Icon | Member | Description
 | GetSessionString(String) | Gets a string value from the current session.
 | GetSessionString(String, String) | Gets a string value from the current session.


GetSessionString Method (key)

GetSessionString Method (key)
Namespaces ► Sitecore.Web ► WebUtil ► GetSessionString(String)
Gets a string value from the current session.
Declaration Syntax
C#
public static string GetSessionString(
    string key
)
Parameters
key (String)
Name of value.
Return Value
The value of the named session variable.
Remarks
If the session variable was not found, blank is returned.
Examples
CopyC#
string val = WebUtil.GetSessionString("myValue");
See Also
HttpSessionState


GetSessionString Method (key, defaultValue)

GetSessionString Method (key, defaultValue)
Namespaces ► Sitecore.Web ► WebUtil ► GetSessionString(String, String)
Gets a string value from the current session.
Declaration Syntax
C#
public static string GetSessionString(
    string key,
    string defaultValue
)
Parameters
key (String)
Name of value.
defaultValue (String)
A default value.
Return Value
The value of the named session variable.
Remarks
If the session variable was not found, the default value is returned.
Examples
CopyC#
string val = WebUtil.GetSessionString("myValue", "1");
See Also
HttpSessionState


GetSessionTimeout Method

GetSessionTimeout Method
Namespaces ► Sitecore.Web ► WebUtil ► GetSessionTimeout()()()
Sets the session timeout.
Declaration Syntax
C#
public static TimeSpan GetSessionTimeout()
Return Value


GetSessionValue Method

GetSessionValue Method
Namespaces ► Sitecore.Web ► WebUtil ► GetSessionValue()()()
Members
Icon | Member | Description
 | GetSessionValue(String) | Gets an object from the current session.
 | GetSessionValue(String, HttpContext) | Gets an object from the current session.


GetSessionValue Method (key)

GetSessionValue Method (key)
Namespaces ► Sitecore.Web ► WebUtil ► GetSessionValue(String)
Gets an object from the current session.
Declaration Syntax
C#
public static Object GetSessionValue(
    string key
)
Parameters
key (String)
Name of object.
Return Value
The object of the named session variable.
Remarks
If the session variable was not found, null is returned.
Examples
CopyC#
object o = WebUtil.GetSessionValue("myObject");
See Also
HttpSessionState


GetSessionValue Method (key, context)

GetSessionValue Method (key, context)
Namespaces ► Sitecore.Web ► WebUtil ► GetSessionValue(String, HttpContext)
Gets an object from the current session.
Declaration Syntax
C#
public static Object GetSessionValue(
    string key,
    HttpContext context
)
Parameters
key (String)
Name of object.
context (HttpContext)
The context.
Return Value
The object of the named session variable.
Remarks
If the session variable was not found, null is returned.
Examples
CopyC#
object o = WebUtil.GetSessionValue("myObject");
See Also
HttpSessionState


GetUrl Method (item, linkFieldName)

GetUrl Method (item, linkFieldName)
Namespaces ► Sitecore.Web ► WebUtil ► GetUrl(Item, String)
Generates an URL path from a link field.
Declaration Syntax
C#
public static string GetUrl(
    Item item,
    string linkFieldName
)
Parameters
item (Item)
An item.
linkFieldName (String)
Name of a Link field in the item.
Return Value
An URL path.
Examples
CopyC#
IMasterItem item = MasterFactory.GetItem("/sitecore/content/Home");
string url = WebUtil.GetUrl(item, "Link"); // "/Home/Products.aspx"


GetUrlName Method (index)

GetUrlName Method (index)
Namespaces ► Sitecore.Web ► WebUtil ► GetUrlName(Int32)
Gets an item name as specified in the current URL path.
Declaration Syntax
C#
public static string GetUrlName(
    int index
)
Parameters
index (Int32)
Index of the URL part. Counted from the right starting with zero.
Return Value
The specified part of the current URL path including the .aspx extension.
Examples
CopyC#
string url = "http://localhost/home/news/test+winner.aspx";
string p0 = WebUtil.GetUrlName(0); // "test winner"
string p1 = WebUtil.GetUrlName(1); // "news"
See Also
QueryString
UrlDecode(String)


GetWebItemSource Method

GetWebItemSource Method
Namespaces ► Sitecore.Web ► WebUtil ► GetWebItemSource()()()
Gets the item source path of the current HTTP request.
Declaration Syntax
C#
public static string GetWebItemSource()
Return Value
The path to the current item.
Remarks
If there is no current item, the path to the default item is returned. The default item is configured in the web.config setting "DefaultItem". If the path is a GUID and the closing brace is missing, the brace is added.
Examples
CopyC#
// query string: "http://www.mysite.net/?path=/home.aspx"
string source = WebUtil.GetWebItemSource(); // "/home.aspx"
See Also
DefaultItem
QueryString


InsertControl Method (control, placeholderID, placeholderType, page)

InsertControl Method (control, placeholderID, placeholderType, page)
Namespaces ► Sitecore.Web ► WebUtil ► InsertControl(Control, String, Type, Page)
Insert control in a placeholder on the page
Declaration Syntax
C#
public static bool InsertControl(
    Control control,
    string placeholderID,
    Type placeholderType,
    Page page
)
Parameters
control (Control)
The control.
placeholderID (String)
The placeholder ID.
placeholderType (Type)
Type of the placeholder.
page (Page)
The page.
Return Value


Is404Request Method (url)

Is404Request Method (url)
Namespaces ► Sitecore.Web ► WebUtil ► Is404Request(String)
Is404s the request.
Declaration Syntax
C#
public static bool Is404Request(
    string url
)
Parameters
url (String)
Return Value
The true if request performed without aspx extention.


IsExternalUrl Method (path)

IsExternalUrl Method (path)
Namespaces ► Sitecore.Web ► WebUtil ► IsExternalUrl(String)
Determines if a path is an external URL path.
Declaration Syntax
C#
public static bool IsExternalUrl(
    string path
)
Parameters
path (String)
An URL path.
Return Value
True, if the path is external, otherwise false.
Remarks
An URL path is external if it contains a protocol identified by the string "://".


IsInternalUrl Method (path)

IsInternalUrl Method (path)
Namespaces ► Sitecore.Web ► WebUtil ► IsInternalUrl(String)
Determines if a path is an internal URL path.
Declaration Syntax
C#
public static bool IsInternalUrl(
    string path
)
Parameters
path (String)
An URL path.
Return Value
True, if the path is internal, otherwise false.
Remarks
An URL path is internal if it does not contain a protocol (identified by the string "://").


IsOnAspxPage Method

IsOnAspxPage Method
Namespaces ► Sitecore.Web ► WebUtil ► IsOnAspxPage()()()
Determines whether the current page is an aspx page.
Declaration Syntax
C#
public static bool IsOnAspxPage()
Return Value
true if it is an aspx page; otherwise, false.


IsOnPage Method (path)

IsOnPage Method (path)
Namespaces ► Sitecore.Web ► WebUtil ► IsOnPage(String)
Checks if the current page matches a path.
Declaration Syntax
C#
public static bool IsOnPage(
    string path
)
Parameters
path (String)
The path.
Return Value
true if [is on page] [the specified path]; otherwise, false.


IsPostBack Method

IsPostBack Method
Namespaces ► Sitecore.Web ► WebUtil ► IsPostBack()()()
Determines whether the current request is a post back.
Declaration Syntax
C#
public static bool IsPostBack()
Return Value
true if it is post back; otherwise, false.


NormalizeUrl Method (url)

NormalizeUrl Method (url)
Namespaces ► Sitecore.Web ► WebUtil ► NormalizeUrl(String)
Normalizes a URL.
Declaration Syntax
C#
public static string NormalizeUrl(
    string url
)
Parameters
url (String)
The URL.
Return Value
Remarks

Replaces &amp; with &.

Url decodes query string parameters (see UrlDecode(String)).

Removes empty parameters.


ParseQueryString Method (queryString)

ParseQueryString Method (queryString)
Namespaces ► Sitecore.Web ► WebUtil ► ParseQueryString(String)
Parses a query string into a dictionary of key/value pairs.
Declaration Syntax
C#
public static SafeDictionary<string> ParseQueryString(
    string queryString
)
Parameters
queryString (String)
The query string.
Return Value
A dictionary containing the query string parameters.
Remarks
The parameter list must have the format: "key1=value1&key2=value2&...".
Examples
CopyC#
SafeDictionary<string> values = WebUtil.ParseQueryString("print=1&target=me&group=first");
string s0 = values["print"]; // "1";
string s1 = values["target"]; // "me";
string s2 = values["group"]; // "first";
string s3 = values["non-existing"]; // null;
See Also
QueryString


ParseUrlParameters Method

ParseUrlParameters Method
Namespaces ► Sitecore.Web ► WebUtil ► ParseUrlParameters()()()
Members
Icon | Member | Description
 | ParseUrlParameters(String) | Parses a list of URL parameters into a Hashtable of key/value pairs.
 | ParseUrlParameters(String, Char) | Parses a list of URL parameters into a Hashtable of key/value pairs.


ParseUrlParameters Method (url)

ParseUrlParameters Method (url)
Namespaces ► Sitecore.Web ► WebUtil ► ParseUrlParameters(String)
Parses a list of URL parameters into a Hashtable of key/value pairs.
Declaration Syntax
C#
public static NameValueCollection ParseUrlParameters(
    string url
)
Parameters
url (String)
An URL parameter list.
Return Value
A Hashtable containing the URL parameters.
Remarks
The parameter list must have the format: "key1=value1&key2=value2&...".
Examples
CopyC#
Hashtable table = WebUtil.ParseUrlParameters("print=1&target=me&group=first");
string s0 = table["print"]; // "1";
string s1 = table["target"]; // "me";
string s2 = table["group"]; // "first";
See Also
QueryString


ParseUrlParameters Method (urlOrQueryString, separator)

ParseUrlParameters Method (urlOrQueryString, separator)
Namespaces ► Sitecore.Web ► WebUtil ► ParseUrlParameters(String, Char)
Parses a list of URL parameters into a Hashtable of key/value pairs.
Declaration Syntax
C#
public static NameValueCollection ParseUrlParameters(
    string urlOrQueryString,
    char separator
)
Parameters
urlOrQueryString (String)
A complete URL or a query string.
separator (Char)
The separator.
Return Value
A Hashtable containing the URL parameters.
Remarks
The parameter list must have the format: "key1=value1&key2=value2&...".
Examples
CopyC#
Hashtable table = WebUtil.ParseUrlParameters("print=1&target=me&group=first");
string s0 = table["print"]; // "1";
string s1 = table["target"]; // "me";
string s2 = table["group"]; // "first";
See Also
QueryString


PostFile Method (url, name, filePath, timeout, values)

PostFile Method (url, name, filePath, timeout, values)
Namespaces ► Sitecore.Web ► WebUtil ► PostFile(String, String, String, Int32, array<String>[]()[])
Posts a file to a web page.
Declaration Syntax
C#
public static string PostFile(
    string url,
    string name,
    string filePath,
    int timeout,
    params string[] values
)
Parameters
url (String)
An URL path to post to.
name (String)
Form name of file data - same as the name attribute on an HTML input element.
filePath (String)
A path to a file.
timeout (Int32)
Timeout in seconds.
values (array< String >[]()[])
Field values to include in the form post. Format is: name,value,name,value,...
Return Value
The response from the web page posted to.
Remarks
If an error occurs, the string "##Error:" and a error message is returned.
Examples
Post a file to a web server:
CopyC#
string filename = FileUtil.MapPath("/data.txt");
string response = WebUtil.PostFile("http://myserver/process.aspx", "data", filename, 60, "date", "20031019", "author", "ku");
MainUtil.Out("Response: " + response);
 Outputs: OK


PostWebPage Method (url, formData)

PostWebPage Method (url, formData)
Namespaces ► Sitecore.Web ► WebUtil ► PostWebPage(String, ArrayList)
Posts data to a web page.
Declaration Syntax
C#
public static string PostWebPage(
    string url,
    ArrayList formData
)
Parameters
url (String)
An URL path to post to.
formData (ArrayList)
List of alternating names and values.
Return Value
The content of the web page.
Remarks
The values are URL encoded before posting. The parameters are sent as ASCII encoded.
See Also
WebRequest


Redirect Method

Redirect Method
Namespaces ► Sitecore.Web ► WebUtil ► Redirect()()()
Members
Icon | Member | Description
 | Redirect(String) | Redirects to another page.
 | Redirect(String, Boolean) | Redirects to another page.


Redirect Method (path)

Redirect Method (path)
Namespaces ► Sitecore.Web ► WebUtil ► Redirect(String)
Redirects to another page.
Declaration Syntax
C#
public static void Redirect(
    string path
)
Parameters
path (String)
The path.


Redirect Method (path, allowSame)

Redirect Method (path, allowSame)
Namespaces ► Sitecore.Web ► WebUtil ► Redirect(String, Boolean)
Redirects to another page.
Declaration Syntax
C#
public static void Redirect(
    string path,
    bool allowSame
)
Parameters
path (String)
The path.
allowSame (Boolean)
if set to true this instance is allow same.


RedirectToErrorPage Method

RedirectToErrorPage Method
Namespaces ► Sitecore.Web ► WebUtil ► RedirectToErrorPage()()()
Members
Icon | Member | Description
 | RedirectToErrorPage(String) | Redirects to the error page.
 | RedirectToErrorPage(String, Boolean) | Redirects to the error page.


RedirectToErrorPage Method (text)

RedirectToErrorPage Method (text)
Namespaces ► Sitecore.Web ► WebUtil ► RedirectToErrorPage(String)
Redirects to the error page.
Declaration Syntax
C#
public static void RedirectToErrorPage(
    string text
)
Parameters
text (String)
The text.


RedirectToErrorPage Method (text, allowSame)

RedirectToErrorPage Method (text, allowSame)
Namespaces ► Sitecore.Web ► WebUtil ► RedirectToErrorPage(String, Boolean)
Redirects to the error page.
Declaration Syntax
C#
public static void RedirectToErrorPage(
    string text,
    bool allowSame
)
Parameters
text (String)
The text.
allowSame (Boolean)
if set to true this instance is allow same.


ReloadPage Method

ReloadPage Method
Namespaces ► Sitecore.Web ► WebUtil ► ReloadPage()()()
Reloads the current page.
Declaration Syntax
C#
public static void ReloadPage()
Remarks
The page reloads by redirecting to the URL of the current Sitecore item. The current Sitecore item is located in Context.Item.
Examples
CopyC#
WebUtil.ReloadPage();
See Also
Redirect(String)
Item


RemoveItemsValue Method (key)

RemoveItemsValue Method (key)
Namespaces ► Sitecore.Web ► WebUtil ► RemoveItemsValue(String)
Removes an object from the current items.
Declaration Syntax
C#
public static void RemoveItemsValue(
    string key
)
Parameters
key (String)
The key.


RemoveQueryString Method (url)

RemoveQueryString Method (url)
Namespaces ► Sitecore.Web ► WebUtil ► RemoveQueryString(String)
Removes the query string from a Url.
Declaration Syntax
C#
public static string RemoveQueryString(
    string url
)
Parameters
url (String)
The URL.
Return Value


RemoveSessionValue Method (key)

RemoveSessionValue Method (key)
Namespaces ► Sitecore.Web ► WebUtil ► RemoveSessionValue(String)
Removes an object from the current session.
Declaration Syntax
C#
public static void RemoveSessionValue(
    string key
)
Parameters
key (String)
The key.


ReplaceControl Method (oldControl, newControl)

ReplaceControl Method (oldControl, newControl)
Namespaces ► Sitecore.Web ► WebUtil ► ReplaceControl(Control, Control)
Replaces the control.
Declaration Syntax
C#
public static void ReplaceControl(
    Control oldControl,
    Control newControl
)
Parameters
oldControl (Control)
The old control.
newControl (Control)
The new control.


ReplaceUrlParameter Method (url, replace, withtext, append)

ReplaceUrlParameter Method (url, replace, withtext, append)
Namespaces ► Sitecore.Web ► WebUtil ► ReplaceUrlParameter(String, String, String, Boolean)
Replaces the URL parameter.
Declaration Syntax
C#
public static string ReplaceUrlParameter(
    string url,
    string replace,
    string withtext,
    bool append
)
Parameters
url (String)
The URL.
replace (String)
The replace.
withtext (String)
The withtext.
append (Boolean)
if set to true this instance is append.
Return Value


RewriteUrl Method (pathAndQuery)

RewriteUrl Method (pathAndQuery)
Namespaces ► Sitecore.Web ► WebUtil ► RewriteUrl(String)
Rewrites the current URL.
Declaration Syntax
C#
public static void RewriteUrl(
    string pathAndQuery
)
Parameters
pathAndQuery (String)
The path and query.


SafeEncode Method (value)

SafeEncode Method (value)
Namespaces ► Sitecore.Web ► WebUtil ► SafeEncode(String)
Encodes user input so that it is safe to use as output. Use to prevent XSS attacks.
Declaration Syntax
C#
public static string SafeEncode(
    string value
)
Parameters
value (String)
The value to encode.
Return Value


SetCookieBool Method (cookieName, cookieValue)

SetCookieBool Method (cookieName, cookieValue)
Namespaces ► Sitecore.Web ► WebUtil ► SetCookieBool(String, Boolean)
Sets a boolean value in a cookie.
Declaration Syntax
C#
public static void SetCookieBool(
    string cookieName,
    bool cookieValue
)
Parameters
cookieName (String)
Name of a cookie.
cookieValue (Boolean)
A boolean value.
Examples
CopyC#
WebUtil.SetCookieBool("myCookie", true);
See Also
HttpCookie


SetCookieDateTime Method (cookieName, cookieValue)

SetCookieDateTime Method (cookieName, cookieValue)
Namespaces ► Sitecore.Web ► WebUtil ► SetCookieDateTime(String, DateTime)
Sets a date/time value in a cookie.
Declaration Syntax
C#
public static void SetCookieDateTime(
    string cookieName,
    DateTime cookieValue
)
Parameters
cookieName (String)
Name of a cookie.
cookieValue (DateTime)
A date/time value.
Remarks
The date/time is converted to ISO format.
Examples
CopyC#
WebUtil.SetCookieDateTime("myCookie", DateTime.Now);
See Also
HttpCookie
ToIsoDate(DateTime)


SetCookieValue Method

SetCookieValue Method
Namespaces ► Sitecore.Web ► WebUtil ► SetCookieValue()()()
Members
Icon | Member | Description
 | SetCookieValue(String, String) | Sets a string value in a cookie.
 | SetCookieValue(String, String, DateTime) | Sets a string value in a cookie.


SetCookieValue Method (cookieName, cookieValue)

SetCookieValue Method (cookieName, cookieValue)
Namespaces ► Sitecore.Web ► WebUtil ► SetCookieValue(String, String)
Sets a string value in a cookie.
Declaration Syntax
C#
public static void SetCookieValue(
    string cookieName,
    string cookieValue
)
Parameters
cookieName (String)
Name of a cookie.
cookieValue (String)
A string value.
Examples
CopyC#
WebUtil.SetCookieValue("myCookie", "myValue");
See Also
HttpCookie


SetCookieValue Method (cookieName, cookieValue, expiryDate)

SetCookieValue Method (cookieName, cookieValue, expiryDate)
Namespaces ► Sitecore.Web ► WebUtil ► SetCookieValue(String, String, DateTime)
Sets a string value in a cookie.
Declaration Syntax
C#
public static void SetCookieValue(
    string cookieName,
    string cookieValue,
    DateTime expiryDate
)
Parameters
cookieName (String)
Name of a cookie.
cookieValue (String)
A string value.
expiryDate (DateTime)
The expiry date for the cookie.
Examples
CopyC#
WebUtil.SetCookieValue("myCookie", "myValue");
See Also
HttpCookie


SetHtmlAttribute Method (control, attribute, value)

SetHtmlAttribute Method (control, attribute, value)
Namespaces ► Sitecore.Web ► WebUtil ► SetHtmlAttribute(HtmlControl, String, String)
Sets an attribute value on an HTML control.
Declaration Syntax
C#
public static void SetHtmlAttribute(
    HtmlControl control,
    string attribute,
    string value
)
Parameters
control (HtmlControl)
An HTML control.
attribute (String)
Name of an attribute.
value (String)
Value of the attribute.
Remarks
The attribute is not set, if the value is null or blank.
Examples
CopyC#
WebUtil.SetHtmlAttribute(control, "myAttribute", "myValue");
See Also
HtmlControl


SetItemsValue Method (key, value)

SetItemsValue Method (key, value)
Namespaces ► Sitecore.Web ► WebUtil ► SetItemsValue(String, Object)
Sets an object in the Items collection.
Declaration Syntax
C#
public static void SetItemsValue(
    string key,
    Object value
)
Parameters
key (String)
Name of the value.
value (Object)
An object.
Examples
CopyC#
object myValue;
WebUtil.SetItemsValue("myKey", myValue);
See Also
Items


SetSessionTimeout Method (timeout)

SetSessionTimeout Method (timeout)
Namespaces ► Sitecore.Web ► WebUtil ► SetSessionTimeout(TimeSpan)
Sets the session timeout.
Declaration Syntax
C#
public static void SetSessionTimeout(
    TimeSpan timeout
)
Parameters
timeout (TimeSpan)
The timeout.


SetSessionValue Method (key, value)

SetSessionValue Method (key, value)
Namespaces ► Sitecore.Web ► WebUtil ► SetSessionValue(String, Object)
Sets an object value in the current session.
Declaration Syntax
C#
public static void SetSessionValue(
    string key,
    Object value
)
Parameters
key (String)
Name of the object value.
value (Object)
An object.
Examples
CopyC#
object myValue;
WebUtil.SetSessionValue("myKey", myValue);
See Also
HttpSessionState


ShowControlTree Method (ctl, indent)

ShowControlTree Method (ctl, indent)
Namespaces ► Sitecore.Web ► WebUtil ► ShowControlTree(Control, Int32)
Show a control tree.
Declaration Syntax
C#
public static void ShowControlTree(
    Control ctl,
    int indent
)
Parameters
ctl (Control)
The CTL.
indent (Int32)
The indent.


TransmitStream Method (stream, response, blockSize)

TransmitStream Method (stream, response, blockSize)
Namespaces ► Sitecore.Web ► WebUtil ► TransmitStream(Stream, HttpResponse, Int32)
Writes a stream to the output stream of the HTTP response object.
Declaration Syntax
C#
public static void TransmitStream(
    Stream stream,
    HttpResponse response,
    int blockSize
)
Parameters
stream (Stream)
The stream.
response (HttpResponse)
The response object.
blockSize (Int32)
Size of individual blocks that will be transmitted.


Sitecore.Web.Authentication Namespace

Sitecore.Web.Authentication Namespace
Namespaces ► Sitecore.Web.Authentication
Declaration Syntax
C#
namespace Sitecore.Web.Authentication
Types
All Types Classes
Icon | Type | Description
 | Boost | Represents the boost fuctionality.
 | DomainAccessGuard | Protects the access to a domain.
 | DomainAccessGuard..::.Session | Represents a user.
 | Ticket | Represents a login ticket.
 | TicketCollection | Represents a list of tickets.
 | TicketManager | Defines the ticket manager class.


Boost Class

Boost Class
Namespaces ► Sitecore.Web.Authentication ► Boost
Represents the boost fuctionality.
Declaration Syntax
C#
public sealed class Boost
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Boost()()() | Initializes a new instance of the Boost class
 | BoostedUsers | Gets the list of sessions
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Invalidate()()() | Invalidates this instance.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Boost


Boost Constructor

Boost Constructor
Namespaces ► Sitecore.Web.Authentication ► Boost ► Boost()()()
Initializes a new instance of the Boost class
Declaration Syntax
C#
public Boost()


BoostedUsers Property

BoostedUsers Property
Namespaces ► Sitecore.Web.Authentication ► Boost ► BoostedUsers
Gets the list of sessions
Declaration Syntax
C#
public static int BoostedUsers { get; }
Value
The boosted users.


Invalidate Method

Invalidate Method
Namespaces ► Sitecore.Web.Authentication ► Boost ► Invalidate()()()
Invalidates this instance.
Declaration Syntax
C#
public static void Invalidate()


DomainAccessGuard Class

DomainAccessGuard Class
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard
Protects the access to a domain.
Declaration Syntax
C#
public sealed class DomainAccessGuard
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainAccessGuard()()() | Initializes a new instance of the DomainAccessGuard class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccess()()() | Check if a user can be logged in
 | GetAccess(User) | Check if a user can be logged in
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAccess()()() | Check if a user is logged in
 | IsNewUserAllowed()()() | Checks if a user can be logged in
 | Kick(String) | Kick out another user session
 | Login(String, String) | Log a user in
 | Logout()()() | Check if a user is logged in
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Sessions | Gets the list of sessions
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DomainAccessGuard


DomainAccessGuard Constructor

DomainAccessGuard Constructor
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard ► DomainAccessGuard()()()
Initializes a new instance of the DomainAccessGuard class
Declaration Syntax
C#
public DomainAccessGuard()


GetAccess Method

GetAccess Method
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard ► GetAccess()()()
Members
Icon | Member | Description
 | GetAccess()()() | Check if a user can be logged in
 | GetAccess(User) | Check if a user can be logged in


GetAccess Method

GetAccess Method
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard ► GetAccess()()()
Check if a user can be logged in
Declaration Syntax
C#
public static bool GetAccess()
Return Value
The access.


GetAccess Method (domainUser)

GetAccess Method (domainUser)
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard ► GetAccess(User)
Check if a user can be logged in
Declaration Syntax
C#
public static bool GetAccess(
    User domainUser
)
Parameters
domainUser (User)
The domain user.
Return Value
The access.


HasAccess Method

HasAccess Method
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard ► HasAccess()()()
Check if a user is logged in
Declaration Syntax
C#
public static bool HasAccess()
Return Value
true if this instance has access; otherwise, false.


IsNewUserAllowed Method

IsNewUserAllowed Method
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard ► IsNewUserAllowed()()()
Checks if a user can be logged in
Declaration Syntax
C#
public static bool IsNewUserAllowed()
Value
true if this instance is new user allowed; otherwise, false.


Kick Method (sessionID)

Kick Method (sessionID)
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard ► Kick(String)
Kick out another user session
Declaration Syntax
C#
public static void Kick(
    string sessionID
)
Parameters
sessionID (String)
The session ID.


Login Method (sessionID, userName)

Login Method (sessionID, userName)
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard ► Login(String, String)
Log a user in
Declaration Syntax
C#
public static void Login(
    string sessionID,
    string userName
)
Parameters
sessionID (String)
The session ID.
userName (String)
Name of the user.


Logout Method

Logout Method
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard ► Logout()()()
Check if a user is logged in
Declaration Syntax
C#
public static void Logout()


Sessions Property

Sessions Property
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard ► Sessions
Gets the list of sessions
Declaration Syntax
C#
public static List<DomainAccessGuard..::.Session> Sessions { get; }
Value
The users.


DomainAccessGuard.Session Class

DomainAccessGuard..::.Session Class
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard ► DomainAccessGuard..::.Session
Represents a user.
Declaration Syntax
C#
public sealed class Session
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainAccessGuard..::.Session(String, String) | Initializes a new instance of the DomainAccessGuard..::.Session class.
 | Created | Gets the created.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LastRequest | Gets or sets the last request.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SessionID | Gets the session ID.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserName | Gets the name of the user.
Inheritance Hierarchy
Object
DomainAccessGuard..::.Session


DomainAccessGuard.Session Constructor (sessionID, userName)

DomainAccessGuard..::.Session Constructor (sessionID, userName)
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard..::.Session ► DomainAccessGuard..::.Session(String, String)
Initializes a new instance of the DomainAccessGuard..::.Session class.
Declaration Syntax
C#
public Session(
    string sessionID,
    string userName
)
Parameters
sessionID (String)
The session ID.
userName (String)
Name of the user.


Created Property

Created Property
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard..::.Session ► Created
Gets the created.
Declaration Syntax
C#
public DateTime Created { get; }
Value
The created.


LastRequest Property

LastRequest Property
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard..::.Session ► LastRequest
Gets or sets the last request.
Declaration Syntax
C#
public DateTime LastRequest { get; set; }
Value
The last request.


SessionID Property

SessionID Property
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard..::.Session ► SessionID
Gets the session ID.
Declaration Syntax
C#
public string SessionID { get; }
Value
The session ID.


UserName Property

UserName Property
Namespaces ► Sitecore.Web.Authentication ► DomainAccessGuard..::.Session ► UserName
Gets the name of the user.
Declaration Syntax
C#
public string UserName { get; }
Value
The name of the user.


Ticket Class

Ticket Class
Namespaces ► Sitecore.Web.Authentication ► Ticket
Represents a login ticket.
Declaration Syntax
C#
public sealed class Ticket
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Ticket()()() | Initializes a new instance of the Ticket class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets the id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Parses the specified ticket string.
 | StartUrl | Gets or sets the URL that the user is redirected to after login
 | TimeStamp | Gets or sets the login time.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
 | UserName | Gets or sets the name of the user.
Inheritance Hierarchy
Object
Ticket


Ticket Constructor

Ticket Constructor
Namespaces ► Sitecore.Web.Authentication ► Ticket ► Ticket()()()
Initializes a new instance of the Ticket class
Declaration Syntax
C#
public Ticket()


Id Property

Id Property
Namespaces ► Sitecore.Web.Authentication ► Ticket ► Id
Gets or sets the id.
Declaration Syntax
C#
public string Id { get; set; }
Value
The id.


Parse Method (ticket)

Parse Method (ticket)
Namespaces ► Sitecore.Web.Authentication ► Ticket ► Parse(String)
Parses the specified ticket string.
Declaration Syntax
C#
public static Ticket Parse(
    string ticket
)
Parameters
ticket (String)
The ticket string.
Return Value
The ticket represented by the ticket string.
Exceptions
Exception | Condition
TicketParseException | ticketString has an invalid format.


StartUrl Property

StartUrl Property
Namespaces ► Sitecore.Web.Authentication ► Ticket ► StartUrl
Gets or sets the URL that the user is redirected to after login
Declaration Syntax
C#
public string StartUrl { get; set; }
Value
The start URL.


TimeStamp Property

TimeStamp Property
Namespaces ► Sitecore.Web.Authentication ► Ticket ► TimeStamp
Gets or sets the login time.
Declaration Syntax
C#
public DateTime TimeStamp { get; set; }
Value
The login time.


ToString Method

ToString Method
Namespaces ► Sitecore.Web.Authentication ► Ticket ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


UserName Property

UserName Property
Namespaces ► Sitecore.Web.Authentication ► Ticket ► UserName
Gets or sets the name of the user.
Declaration Syntax
C#
public string UserName { get; set; }
Value
The name of the user.


TicketCollection Class

TicketCollection Class
Namespaces ► Sitecore.Web.Authentication ► TicketCollection
Represents a list of tickets.
Declaration Syntax
C#
public sealed class TicketCollection : List<Ticket>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TicketCollection()()() | Initializes a new instance of the TicketCollection class
 | Add(T) | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | AddRange(IEnumerable<(Of <(T>)>)) | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | AsReadOnly()()() | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List<(Of <( Ticket >)>).)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( Ticket >)>).)
 | BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List<(Of <( Ticket >)>).)
 | BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <( Ticket >)>).)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <( Ticket >)>).)
 | Clear()()() | Removes all elements from the List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | Contains(T) | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | ConvertAll<(Of <(TOutput>)>)(Converter<(Of <(T, TOutput>)>)) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List<(Of <( Ticket >)>).)
 | CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List<(Of <( Ticket >)>).)
 | CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( Ticket >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <( Ticket >)>).)
 | Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <(T>)>)) | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( Ticket >)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | FindAll(Predicate<(Of <(T>)>)) | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( Ticket >)>).)
 | FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( Ticket >)>).)
 | FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( Ticket >)>).)
 | FindLast(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( Ticket >)>).)
 | FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( Ticket >)>).)
 | ForEach(Action<(Of <(T>)>)) | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List<(Of <( Ticket >)>).)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <( Ticket >)>).)
 | Insert(Int32, T) | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( Ticket >)>).)
 | InsertRange(Int32, IEnumerable<(Of <(T>)>)) | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List<(Of <( Ticket >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from List<(Of <( Ticket >)>).)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List<(Of <( Ticket >)>).)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <( Ticket >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | RemoveAll(Predicate<(Of <(T>)>)) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <( Ticket >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List<(Of <( Ticket >)>).)
 | Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List<(Of <( Ticket >)>).)
 | Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( Ticket >)>).)
 | Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List<(Of <( Ticket >)>).)
 | Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List<(Of <( Ticket >)>).)
 | ToArray()()() | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List<(Of <( Ticket >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()()() | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List<(Of <( Ticket >)>).)
 | TrueForAll(Predicate<(Of <(T>)>)) | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List<(Of <( Ticket >)>).)
Inheritance Hierarchy
Object
 | List<(Of <( Ticket >)>)
 |  | TicketCollection


TicketCollection Constructor

TicketCollection Constructor
Namespaces ► Sitecore.Web.Authentication ► TicketCollection ► TicketCollection()()()
Initializes a new instance of the TicketCollection class
Declaration Syntax
C#
public TicketCollection()


TicketManager Class

TicketManager Class
Namespaces ► Sitecore.Web.Authentication ► TicketManager
Defines the ticket manager class.
Declaration Syntax
C#
public static class TicketManager
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ChangePassword(String, String) | Obsolete. Changes the password.
 | CookieName | Specifies the name of the cookie where the ticket id is stored.
 | CreateTicket(String, String) | Creates the ticket.
 | GetCurrentTicketId()()() | Gets the ticket Id from the cookie.
 | Relogin(String) | Relogins the user with the specified ticket.
 | Relogin(String, Boolean) | Relogins the user with the specified ticket.
 | RemoveTicket(String) | Removes the ticket with the specified id.
Inheritance Hierarchy
Object
TicketManager


ChangePassword Method (ticketId, password)

ChangePassword Method (ticketId, password)
Namespaces ► Sitecore.Web.Authentication ► TicketManager ► ChangePassword(String, String)
Changes the password.
Declaration Syntax
C#
[ObsoleteAttribute("Tickets no longer store passwords")]
public static bool ChangePassword(
    string ticketId,
    string password
)
Parameters
ticketId (String)
The ticket id.
password (String)
The password.
Return Value
true, if the ticket was found, otherwise false.


CookieName Field

CookieName Field
Namespaces ► Sitecore.Web.Authentication ► TicketManager ► CookieName
Specifies the name of the cookie where the ticket id is stored.
Declaration Syntax
C#
public const string CookieName


CreateTicket Method (userName, startUrl)

CreateTicket Method (userName, startUrl)
Namespaces ► Sitecore.Web.Authentication ► TicketManager ► CreateTicket(String, String)
Creates the ticket.
Declaration Syntax
C#
public static string CreateTicket(
    string userName,
    string startUrl
)
Parameters
userName (String)
Name of the user.
startUrl (String)
The start URL.
Return Value
The ticket ID.


GetCurrentTicketId Method

GetCurrentTicketId Method
Namespaces ► Sitecore.Web.Authentication ► TicketManager ► GetCurrentTicketId()()()
Gets the ticket Id from the cookie.
Declaration Syntax
C#
public static string GetCurrentTicketId()
Return Value
The ticket Id from the cookie.


Relogin Method

Relogin Method
Namespaces ► Sitecore.Web.Authentication ► TicketManager ► Relogin()()()
Members
Icon | Member | Description
 | Relogin(String) | Relogins the user with the specified ticket.
 | Relogin(String, Boolean) | Relogins the user with the specified ticket.


Relogin Method (ticketId)

Relogin Method (ticketId)
Namespaces ► Sitecore.Web.Authentication ► TicketManager ► Relogin(String)
Relogins the user with the specified ticket.
Declaration Syntax
C#
public static bool Relogin(
    string ticketId
)
Parameters
ticketId (String)
The ticket id.
Return Value
The boolean.


Relogin Method (ticketId, redirect)

Relogin Method (ticketId, redirect)
Namespaces ► Sitecore.Web.Authentication ► TicketManager ► Relogin(String, Boolean)
Relogins the user with the specified ticket.
Declaration Syntax
C#
public static bool Relogin(
    string ticketId,
    bool redirect
)
Parameters
ticketId (String)
The ticket ID.
redirect (Boolean)
if set to true a user is redirected to the start URL.
Return Value
true, if the login was successfull, otherwise false.


RemoveTicket Method (ticketId)

RemoveTicket Method (ticketId)
Namespaces ► Sitecore.Web.Authentication ► TicketManager ► RemoveTicket(String)
Removes the ticket with the specified id.
Declaration Syntax
C#
public static bool RemoveTicket(
    string ticketId
)
Parameters
ticketId (String)
The ticket ID.
Return Value
true, if the ticket was found, otherwise false.


Sitecore.Web.Authentication.DI Namespace

Sitecore.Web.Authentication.DI Namespace
Namespaces ► Sitecore.Web.Authentication.DI
Declaration Syntax
C#
namespace Sitecore.Web.Authentication.DI
Types
All Types Classes
Icon | Type | Description
 | RPCATokenRedirect | Represents a RPCA Token Redirect.
 | RPCBase |


RPCATokenRedirect Class

RPCATokenRedirect Class
Namespaces ► Sitecore.Web.Authentication.DI ► RPCATokenRedirect
Represents a RPCA Token Redirect.
Declaration Syntax
C#
public class RPCATokenRedirect
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RPCATokenRedirect()()() | Initializes a new instance of the RPCATokenRedirect class
 | ATokenRedirect(String, String) | As the token redirect.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RPCATokenRedirect


RPCATokenRedirect Constructor

RPCATokenRedirect Constructor
Namespaces ► Sitecore.Web.Authentication.DI ► RPCATokenRedirect ► RPCATokenRedirect()()()
Initializes a new instance of the RPCATokenRedirect class
Declaration Syntax
C#
public RPCATokenRedirect()


ATokenRedirect Method (sDiDomain, sReturnUrl)

ATokenRedirect Method (sDiDomain, sReturnUrl)
Namespaces ► Sitecore.Web.Authentication.DI ► RPCATokenRedirect ► ATokenRedirect(String, String)
As the token redirect.
Declaration Syntax
C#
public int ATokenRedirect(
    string sDiDomain,
    string sReturnUrl
)
Parameters
sDiDomain (String)
The s di domain.
sReturnUrl (String)
The s return URL.
Return Value
The token redirect.


RPCBase Class

RPCBase Class
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase
Declaration Syntax
C#
public class RPCBase
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RPCBase()()() | Initializes a new instance of the RPCBase class
 | ATokenTest(String) |
 | DiPost(String, String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPagePost(String, NameValueCollection) |
 | GetServerDomain()()() |
 | GetServerDomainPath()()() |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXmlValue(String) | Gets the XML value.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | param_BToken |
 | param_DI |
 | param_DIS |
 | param_Guid |
 | param_ReturnDescription |
 | param_ReturnValue |
 | param_Secure |
 | param_VersionProtocol |
 | param_VersionServer |
 | ProtocolString(Boolean, String, String) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RPCBase


RPCBase Constructor

RPCBase Constructor
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► RPCBase()()()
Initializes a new instance of the RPCBase class
Declaration Syntax
C#
public RPCBase()


ATokenTest Method (sReturnUrl)

ATokenTest Method (sReturnUrl)
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► ATokenTest(String)
Declaration Syntax
C#
public string ATokenTest(
    string sReturnUrl
)
Parameters
sReturnUrl (String)


DiPost Method (url, sXml)

DiPost Method (url, sXml)
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► DiPost(String, String)
Declaration Syntax
C#
public void DiPost(
    string url,
    string sXml
)
Parameters
url (String)
sXml (String)


GetPagePost Method (url, pNameValueCollection)

GetPagePost Method (url, pNameValueCollection)
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► GetPagePost(String, NameValueCollection)
Declaration Syntax
C#
public string GetPagePost(
    string url,
    NameValueCollection pNameValueCollection
)
Parameters
url (String)
pNameValueCollection (NameValueCollection)


GetServerDomain Method

GetServerDomain Method
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► GetServerDomain()()()
Declaration Syntax
C#
public string GetServerDomain()


GetServerDomainPath Method

GetServerDomainPath Method
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► GetServerDomainPath()()()
Declaration Syntax
C#
public string GetServerDomainPath()


GetXmlValue Method (sPath)

GetXmlValue Method (sPath)
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► GetXmlValue(String)
Gets the XML value.
Declaration Syntax
C#
public string GetXmlValue(
    string sPath
)
Parameters
sPath (String)
The s path.
Return Value
The XML value.


param_BToken Field

param_BToken Field
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► param_BToken
Declaration Syntax
C#
public const string param_BToken


param_DI Field

param_DI Field
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► param_DI
Declaration Syntax
C#
public const string param_DI


param_DIS Field

param_DIS Field
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► param_DIS
Declaration Syntax
C#
public const string param_DIS


param_Guid Field

param_Guid Field
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► param_Guid
Declaration Syntax
C#
public const string param_Guid


param_ReturnDescription Field

param_ReturnDescription Field
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► param_ReturnDescription
Declaration Syntax
C#
public const string param_ReturnDescription


param_ReturnValue Field

param_ReturnValue Field
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► param_ReturnValue
Declaration Syntax
C#
public const string param_ReturnValue


param_Secure Field

param_Secure Field
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► param_Secure
Declaration Syntax
C#
public const string param_Secure


param_VersionProtocol Field

param_VersionProtocol Field
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► param_VersionProtocol
Declaration Syntax
C#
public const string param_VersionProtocol


param_VersionServer Field

param_VersionServer Field
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► param_VersionServer
Declaration Syntax
C#
public const string param_VersionServer


ProtocolString Method (bSSLRequired, sDiDomain, sDisDomain)

ProtocolString Method (bSSLRequired, sDiDomain, sDisDomain)
Namespaces ► Sitecore.Web.Authentication.DI ► RPCBase ► ProtocolString(Boolean, String, String)
Declaration Syntax
C#
public string ProtocolString(
    bool bSSLRequired,
    string sDiDomain,
    string sDisDomain
)
Parameters
bSSLRequired (Boolean)
sDiDomain (String)
sDisDomain (String)


Sitecore.Web.Configuration Namespace

Sitecore.Web.Configuration Namespace
Namespaces ► Sitecore.Web.Configuration
Declaration Syntax
C#
namespace Sitecore.Web.Configuration
Types
All Types Classes
Icon | Type | Description
 | DeviceCapabilities | Defines the methods and properties of a class that defines the capabilities of a device.
 | FirefoxCapabilities | Provide a device handler for Internet Explorer.
 | InternetExplorerCapabilities | Provide a device handler for Internet Explorer.
 | SitecoreClientDeviceCapabilities | Provide a base device handler for the Sitecore Client.


DeviceCapabilities Class

DeviceCapabilities Class
Namespaces ► Sitecore.Web.Configuration ► DeviceCapabilities
Defines the methods and properties of a class that defines the capabilities of a device.
Declaration Syntax
C#
public abstract class DeviceCapabilities
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeviceCapabilities()()() | Initializes a new instance of the DeviceCapabilities class
 | Browser | Gets the browser capabilities.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultDocumentType()()() | Gets the type of the HTML document.
 | GetFlashVersion()()() | Gets the flash version.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTransparencyStyle(Double) | Gets the transparency style.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Properties | Gets the properties.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DeviceCapabilities
 |  | SitecoreClientDeviceCapabilities


DeviceCapabilities Constructor

DeviceCapabilities Constructor
Namespaces ► Sitecore.Web.Configuration ► DeviceCapabilities ► DeviceCapabilities()()()
Initializes a new instance of the DeviceCapabilities class
Declaration Syntax
C#
protected DeviceCapabilities()


Browser Property

Browser Property
Namespaces ► Sitecore.Web.Configuration ► DeviceCapabilities ► Browser
Gets the browser capabilities.
Declaration Syntax
C#
public HttpBrowserCapabilities Browser { get; }
Value
The browser capabilities.
Remarks
Enables the server to gather information on the capabilities of the browser that is running on the client.


GetDefaultDocumentType Method

GetDefaultDocumentType Method
Namespaces ► Sitecore.Web.Configuration ► DeviceCapabilities ► GetDefaultDocumentType()()()
Gets the type of the HTML document.
Declaration Syntax
C#
public virtual string GetDefaultDocumentType()
Return Value
The document type.
Remarks
The returned string contains the entire document type, e.g. "<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.0 Transitional//EN\">"


GetFlashVersion Method

GetFlashVersion Method
Namespaces ► Sitecore.Web.Configuration ► DeviceCapabilities ► GetFlashVersion()()()
Gets the flash version.
Declaration Syntax
C#
protected virtual Version GetFlashVersion()
Return Value
The flash version.


GetTransparencyStyle Method (opacity)

GetTransparencyStyle Method (opacity)
Namespaces ► Sitecore.Web.Configuration ► DeviceCapabilities ► GetTransparencyStyle(Double)
Gets the transparency style.
Declaration Syntax
C#
public virtual string GetTransparencyStyle(
    double opacity
)
Parameters
opacity (Double)
The opacity.
Return Value
The transparency style.


Properties Property

Properties Property
Namespaces ► Sitecore.Web.Configuration ► DeviceCapabilities ► Properties
Gets the properties.
Declaration Syntax
C#
public NameValueCollection Properties { get; }
Value
The properties.


FirefoxCapabilities Class

FirefoxCapabilities Class
Namespaces ► Sitecore.Web.Configuration ► FirefoxCapabilities
Provide a device handler for Internet Explorer.
Declaration Syntax
C#
public class FirefoxCapabilities : SitecoreClientDeviceCapabilities
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FirefoxCapabilities()()() | Initializes a new instance of the FirefoxCapabilities class
 | Browser | Gets the browser capabilities. (Inherited from DeviceCapabilities.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultDocumentType()()() | Gets the type of the HTML document. (Overrides DeviceCapabilities.GetDefaultDocumentType()()().)
 | GetFlashVersion()()() | Gets the flash version. (Inherited from DeviceCapabilities.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTransparencyStyle(Double) | Gets the transparency style. (Inherited from DeviceCapabilities.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAdvancedClient | Gets a value indicating whether this device is an advanced client. (Inherited from SitecoreClientDeviceCapabilities.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Properties | Gets the properties. (Inherited from DeviceCapabilities.)
 | RequiresScrollbarsOnWindowOpen | Gets a value indicating whether the browser requires scrollbars on opened windows. (Inherited from SitecoreClientDeviceCapabilities.)
 | SupportsClipboard | Gets a value indicating whether the browser supports clipboard functions. (Inherited from SitecoreClientDeviceCapabilities.)
 | SupportsFlashUpload | Gets a value indicating whether the browser supports flash upload. (Inherited from SitecoreClientDeviceCapabilities.)
 | SupportsInlineEditing | Obsolete. Gets a value indicating whether the browser supports inline editing. (Inherited from SitecoreClientDeviceCapabilities.)
 | SupportsOutOfFramePopup | Gets a value indicating whether the browser supports an out of frame popup window. (Inherited from SitecoreClientDeviceCapabilities.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DeviceCapabilities
 |  | SitecoreClientDeviceCapabilities
 |  |  | FirefoxCapabilities


FirefoxCapabilities Constructor

FirefoxCapabilities Constructor
Namespaces ► Sitecore.Web.Configuration ► FirefoxCapabilities ► FirefoxCapabilities()()()
Initializes a new instance of the FirefoxCapabilities class
Declaration Syntax
C#
public FirefoxCapabilities()


GetDefaultDocumentType Method

GetDefaultDocumentType Method
Namespaces ► Sitecore.Web.Configuration ► FirefoxCapabilities ► GetDefaultDocumentType()()()
Gets the type of the HTML document.
Declaration Syntax
C#
public override string GetDefaultDocumentType()
Return Value
The document type.
Remarks
The returned string contains the entire document type, e.g. "<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.0 Transitional//EN\">"


InternetExplorerCapabilities Class

InternetExplorerCapabilities Class
Namespaces ► Sitecore.Web.Configuration ► InternetExplorerCapabilities
Provide a device handler for Internet Explorer.
Declaration Syntax
C#
public class InternetExplorerCapabilities : SitecoreClientDeviceCapabilities
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InternetExplorerCapabilities()()() | Initializes a new instance of the InternetExplorerCapabilities class
 | Browser | Gets the browser capabilities. (Inherited from DeviceCapabilities.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultDocumentType()()() | Gets the type of the HTML document. (Inherited from DeviceCapabilities.)
 | GetFlashVersion()()() | Gets the flash version. (Inherited from DeviceCapabilities.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTransparencyStyle(Double) | Gets the transparency style. (Overrides DeviceCapabilities.GetTransparencyStyle(Double).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAdvancedClient | Gets a value indicating whether this device is an advanced client. (Overrides SitecoreClientDeviceCapabilities.IsAdvancedClient.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Properties | Gets the properties. (Inherited from DeviceCapabilities.)
 | RequiresScrollbarsOnWindowOpen | Gets a value indicating whether the browser requires scrollbars on opened windows. (Overrides SitecoreClientDeviceCapabilities.RequiresScrollbarsOnWindowOpen.)
 | SupportsClipboard | Gets a value indicating whether the browser supports clipboard functions. (Overrides SitecoreClientDeviceCapabilities.SupportsClipboard.)
 | SupportsFlashUpload | Gets a value indicating whether the browser supports flash upload. (Inherited from SitecoreClientDeviceCapabilities.)
 | SupportsInlineEditing | Obsolete. Gets a value indicating whether the browser supports inline editing. (Inherited from SitecoreClientDeviceCapabilities.)
 | SupportsOutOfFramePopup | Gets a value indicating whether the browser supports an out of frame popup window. (Overrides SitecoreClientDeviceCapabilities.SupportsOutOfFramePopup.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DeviceCapabilities
 |  | SitecoreClientDeviceCapabilities
 |  |  | InternetExplorerCapabilities


InternetExplorerCapabilities Constructor

InternetExplorerCapabilities Constructor
Namespaces ► Sitecore.Web.Configuration ► InternetExplorerCapabilities ► InternetExplorerCapabilities()()()
Initializes a new instance of the InternetExplorerCapabilities class
Declaration Syntax
C#
public InternetExplorerCapabilities()


GetTransparencyStyle Method (opacity)

GetTransparencyStyle Method (opacity)
Namespaces ► Sitecore.Web.Configuration ► InternetExplorerCapabilities ► GetTransparencyStyle(Double)
Gets the transparency style.
Declaration Syntax
C#
public override string GetTransparencyStyle(
    double opacity
)
Parameters
opacity (Double)
The opacity.
Return Value
The transparency style.


IsAdvancedClient Property

IsAdvancedClient Property
Namespaces ► Sitecore.Web.Configuration ► InternetExplorerCapabilities ► IsAdvancedClient
Gets a value indicating whether this device is an advanced client.
Declaration Syntax
C#
public override bool IsAdvancedClient { get; }
Value
true if this instance is advanced client; otherwise, false.


RequiresScrollbarsOnWindowOpen Property

RequiresScrollbarsOnWindowOpen Property
Namespaces ► Sitecore.Web.Configuration ► InternetExplorerCapabilities ► RequiresScrollbarsOnWindowOpen
Gets a value indicating whether the browser requires scrollbars on opened windows.
Declaration Syntax
C#
public override bool RequiresScrollbarsOnWindowOpen { get; }
Value
true if the browser requires scrollbars on opened windows; otherwise, false.


SupportsClipboard Property

SupportsClipboard Property
Namespaces ► Sitecore.Web.Configuration ► InternetExplorerCapabilities ► SupportsClipboard
Gets a value indicating whether the browser supports clipboard functions.
Declaration Syntax
C#
public override bool SupportsClipboard { get; }
Value
true if the browser supports clipboard functions; otherwise, false.


SupportsOutOfFramePopup Property

SupportsOutOfFramePopup Property
Namespaces ► Sitecore.Web.Configuration ► InternetExplorerCapabilities ► SupportsOutOfFramePopup
Gets a value indicating whether the browser supports an out of frame popup window.
Declaration Syntax
C#
public override bool SupportsOutOfFramePopup { get; }
Value
true if the browser supports an out of frame popup window; otherwise, false.


SitecoreClientDeviceCapabilities Class

SitecoreClientDeviceCapabilities Class
Namespaces ► Sitecore.Web.Configuration ► SitecoreClientDeviceCapabilities
Provide a base device handler for the Sitecore Client.
Declaration Syntax
C#
public abstract class SitecoreClientDeviceCapabilities : DeviceCapabilities
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SitecoreClientDeviceCapabilities()()() | Initializes a new instance of the SitecoreClientDeviceCapabilities class
 | Browser | Gets the browser capabilities. (Inherited from DeviceCapabilities.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultDocumentType()()() | Gets the type of the HTML document. (Inherited from DeviceCapabilities.)
 | GetFlashVersion()()() | Gets the flash version. (Inherited from DeviceCapabilities.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTransparencyStyle(Double) | Gets the transparency style. (Inherited from DeviceCapabilities.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAdvancedClient | Gets a value indicating whether this device is an advanced client.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Properties | Gets the properties. (Inherited from DeviceCapabilities.)
 | RequiresScrollbarsOnWindowOpen | Gets a value indicating whether the browser requires scrollbars on opened windows.
 | SupportsClipboard | Gets a value indicating whether the browser supports clipboard functions.
 | SupportsFlashUpload | Gets a value indicating whether the browser supports flash upload.
 | SupportsInlineEditing | Obsolete. Gets a value indicating whether the browser supports inline editing.
 | SupportsOutOfFramePopup | Gets a value indicating whether the browser supports an out of frame popup window.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DeviceCapabilities
 |  | SitecoreClientDeviceCapabilities
 |  |  | FirefoxCapabilities
 |  |  | InternetExplorerCapabilities


SitecoreClientDeviceCapabilities Constructor

SitecoreClientDeviceCapabilities Constructor
Namespaces ► Sitecore.Web.Configuration ► SitecoreClientDeviceCapabilities ► SitecoreClientDeviceCapabilities()()()
Initializes a new instance of the SitecoreClientDeviceCapabilities class
Declaration Syntax
C#
protected SitecoreClientDeviceCapabilities()


IsAdvancedClient Property

IsAdvancedClient Property
Namespaces ► Sitecore.Web.Configuration ► SitecoreClientDeviceCapabilities ► IsAdvancedClient
Gets a value indicating whether this device is an advanced client.
Declaration Syntax
C#
public virtual bool IsAdvancedClient { get; }
Value
true if this instance is advanced client; otherwise, false.


RequiresScrollbarsOnWindowOpen Property

RequiresScrollbarsOnWindowOpen Property
Namespaces ► Sitecore.Web.Configuration ► SitecoreClientDeviceCapabilities ► RequiresScrollbarsOnWindowOpen
Gets a value indicating whether the browser requires scrollbars on opened windows.
Declaration Syntax
C#
public virtual bool RequiresScrollbarsOnWindowOpen { get; }
Value
true if the browser requires scrollbars on opened windows; otherwise, false.


SupportsClipboard Property

SupportsClipboard Property
Namespaces ► Sitecore.Web.Configuration ► SitecoreClientDeviceCapabilities ► SupportsClipboard
Gets a value indicating whether the browser supports clipboard functions.
Declaration Syntax
C#
public virtual bool SupportsClipboard { get; }
Value
true if the browser supports clipboard functions; otherwise, false.


SupportsFlashUpload Property

SupportsFlashUpload Property
Namespaces ► Sitecore.Web.Configuration ► SitecoreClientDeviceCapabilities ► SupportsFlashUpload
Gets a value indicating whether the browser supports flash upload.
Declaration Syntax
C#
public virtual bool SupportsFlashUpload { get; }
Value
true if the browser supports flash upload; otherwise, false.


SupportsInlineEditing Property

SupportsInlineEditing Property
Namespaces ► Sitecore.Web.Configuration ► SitecoreClientDeviceCapabilities ► SupportsInlineEditing
Gets a value indicating whether the browser supports inline editing.
Declaration Syntax
C#
[ObsoleteAttribute("Use UIUtil.SupportsInlineEditing()")]
public virtual bool SupportsInlineEditing { get; }
Value
true if the browser supports inline editing; otherwise, false.


SupportsOutOfFramePopup Property

SupportsOutOfFramePopup Property
Namespaces ► Sitecore.Web.Configuration ► SitecoreClientDeviceCapabilities ► SupportsOutOfFramePopup
Gets a value indicating whether the browser supports an out of frame popup window.
Declaration Syntax
C#
public virtual bool SupportsOutOfFramePopup { get; }
Value
true if the browser supports an out of frame popup window; otherwise, false.


Sitecore.Web.Services Namespace

Sitecore.Web.Services Namespace
Namespaces ► Sitecore.Web.Services
Declaration Syntax
C#
namespace Sitecore.Web.Services
Types
All Types Classes
Icon | Type | Description
 | ApiExtension | Obsolete. API Soap extension.
 | ApiExtensionAttribute | Obsolete. API extension attribute.


ApiExtension Class

ApiExtension Class
Namespaces ► Sitecore.Web.Services ► ApiExtension
API Soap extension.
Declaration Syntax
C#
[ObsoleteAttribute("This class has been deprecated.")]
public class ApiExtension : SoapExtension
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ApiExtension()()() | Initializes a new instance of the ApiExtension class
 | ChainStream(Stream) | When overridden in a derived class, allows a SOAP extension access to the memory buffer containing the SOAP request or response. (Overrides SoapExtension.ChainStream(Stream).)
 | CheckLogin(String) | Assure login policy for method is followed
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtractSoapMethodName(SoapMessage) | Extract method name from soap message
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInitializer(LogicalMethodInfo, SoapExtensionAttribute) | When overridden in a derived class, allows a SOAP extension to initialize data specific to an XML Web service method using an attribute applied to the XML Web service method at a one time performance cost. (Overrides SoapExtension.GetInitializer(LogicalMethodInfo, SoapExtensionAttribute).)
 | GetInitializer(Type) | Gets the initializer. (Overrides SoapExtension.GetInitializer(Type).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Object) | When overridden in a derived class, allows a SOAP extension to initialize itself using the data cached in the GetInitializer(LogicalMethodInfo, SoapExtensionAttribute) method. (Overrides SoapExtension.Initialize(Object).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessMessage(SoapMessage) | When overridden in a derived class, allows a SOAP extension to receive a SoapMessage to process at each SoapMessageStage. (Overrides SoapExtension.ProcessMessage(SoapMessage).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SoapExtension
 |  | ApiExtension


ApiExtension Constructor

ApiExtension Constructor
Namespaces ► Sitecore.Web.Services ► ApiExtension ► ApiExtension()()()
Initializes a new instance of the ApiExtension class
Declaration Syntax
C#
public ApiExtension()


ChainStream Method (stream)

ChainStream Method (stream)
Namespaces ► Sitecore.Web.Services ► ApiExtension ► ChainStream(Stream)
When overridden in a derived class, allows a SOAP extension access to the memory buffer containing the SOAP request or response.
Declaration Syntax
C#
public override Stream ChainStream(
    Stream stream
)
Parameters
stream (Stream)
A memory buffer containing the SOAP request or response.
Return Value
A Stream representing a new memory buffer that this SOAP extension can modify.


CheckLogin Method (sMethod)

CheckLogin Method (sMethod)
Namespaces ► Sitecore.Web.Services ► ApiExtension ► CheckLogin(String)
Assure login policy for method is followed
Declaration Syntax
C#
protected void CheckLogin(
    string sMethod
)
Parameters
sMethod (String)
The s method.
Exceptions
Exception | Condition
SoapException | Thrown if a client is not logged in and RequireLogin is true


ExtractSoapMethodName Method (message)

ExtractSoapMethodName Method (message)
Namespaces ► Sitecore.Web.Services ► ApiExtension ► ExtractSoapMethodName(SoapMessage)
Extract method name from soap message
Declaration Syntax
C#
public static string ExtractSoapMethodName(
    SoapMessage message
)
Parameters
message (SoapMessage)
The message.
Return Value
The String.


GetInitializer Method

GetInitializer Method
Namespaces ► Sitecore.Web.Services ► ApiExtension ► GetInitializer()()()
Members
Icon | Member | Description
 | GetInitializer(LogicalMethodInfo, SoapExtensionAttribute) | When overridden in a derived class, allows a SOAP extension to initialize data specific to an XML Web service method using an attribute applied to the XML Web service method at a one time performance cost. (Overrides SoapExtension.GetInitializer(LogicalMethodInfo, SoapExtensionAttribute).)
 | GetInitializer(Type) | Gets the initializer. (Overrides SoapExtension.GetInitializer(Type).)


GetInitializer Method (webServiceType)

GetInitializer Method (webServiceType)
Namespaces ► Sitecore.Web.Services ► ApiExtension ► GetInitializer(Type)
Gets the initializer.
Declaration Syntax
C#
public override Object GetInitializer(
    Type webServiceType
)
Parameters
webServiceType (Type)
Type of the web service.
Return Value
The initializer.


GetInitializer Method (methodInfo, attribute)

GetInitializer Method (methodInfo, attribute)
Namespaces ► Sitecore.Web.Services ► ApiExtension ► GetInitializer(LogicalMethodInfo, SoapExtensionAttribute)
When overridden in a derived class, allows a SOAP extension to initialize data specific to an XML Web service method using an attribute applied to the XML Web service method at a one time performance cost.
Declaration Syntax
C#
public override Object GetInitializer(
    LogicalMethodInfo methodInfo,
    SoapExtensionAttribute attribute
)
Parameters
methodInfo (LogicalMethodInfo)
A LogicalMethodInfo representing the specific function prototype for the XML Web service method to which the SOAP extension is applied.
attribute (SoapExtensionAttribute)
The SoapExtensionAttribute applied to the XML Web service method.
Return Value
The Object that the SOAP extension initializes for caching.


Initialize Method (initializer)

Initialize Method (initializer)
Namespaces ► Sitecore.Web.Services ► ApiExtension ► Initialize(Object)
When overridden in a derived class, allows a SOAP extension to initialize itself using the data cached in the GetInitializer(LogicalMethodInfo, SoapExtensionAttribute) method.
Declaration Syntax
C#
public override void Initialize(
    Object initializer
)
Parameters
initializer (Object)
The Object returned from GetInitializer(LogicalMethodInfo, SoapExtensionAttribute) cached by ASP.NET.


ProcessMessage Method (message)

ProcessMessage Method (message)
Namespaces ► Sitecore.Web.Services ► ApiExtension ► ProcessMessage(SoapMessage)
When overridden in a derived class, allows a SOAP extension to receive a SoapMessage to process at each SoapMessageStage.
Declaration Syntax
C#
public override void ProcessMessage(
    SoapMessage message
)
Parameters
message (SoapMessage)
The SoapMessage to process.


ApiExtensionAttribute Class

ApiExtensionAttribute Class
Namespaces ► Sitecore.Web.Services ► ApiExtensionAttribute
API extension attribute.
Declaration Syntax
C#
[ObsoleteAttribute("This class has been deprecated.")]
public sealed class ApiExtensionAttribute : SoapExtensionAttribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApiExtensionAttribute()()() | Initializes a new instance of the ApiExtensionAttribute class
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | ExtensionType | When overridden in a derived class, gets the Type of the SOAP extension. (Overrides SoapExtensionAttribute.ExtensionType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Priority | When overridden in a derived class, gets or set the priority of the SOAP extension. (Overrides SoapExtensionAttribute.Priority.)
 | RequireLogin | Gets or sets a value indicating whether the ApiExtensionAttribute requires the login.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | SoapExtensionAttribute
 |  |  | ApiExtensionAttribute


ApiExtensionAttribute Constructor

ApiExtensionAttribute Constructor
Namespaces ► Sitecore.Web.Services ► ApiExtensionAttribute ► ApiExtensionAttribute()()()
Initializes a new instance of the ApiExtensionAttribute class
Declaration Syntax
C#
public ApiExtensionAttribute()


ExtensionType Property

ExtensionType Property
Namespaces ► Sitecore.Web.Services ► ApiExtensionAttribute ► ExtensionType
When overridden in a derived class, gets the Type of the SOAP extension.
Declaration Syntax
C#
public override Type ExtensionType { get; }
Value
Return Value
The Type of the SOAP extension.


Priority Property

Priority Property
Namespaces ► Sitecore.Web.Services ► ApiExtensionAttribute ► Priority
When overridden in a derived class, gets or set the priority of the SOAP extension.
Declaration Syntax
C#
public override int Priority { get; set; }
Value
Return Value
The priority of the SOAP extension.


RequireLogin Property

RequireLogin Property
Namespaces ► Sitecore.Web.Services ► ApiExtensionAttribute ► RequireLogin
Gets or sets a value indicating whether the ApiExtensionAttribute requires the login.
Declaration Syntax
C#
public bool RequireLogin { get; set; }
Value
true if the ApiExtensionAttribute requires the login; otherwise, false.


Sitecore.Web.UI Namespace

Sitecore.Web.UI Namespace
Namespaces ► Sitecore.Web.UI
Declaration Syntax
C#
namespace Sitecore.Web.UI
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | WebControl..::.ContentGetter | Represents a Content Getter.
 | IHasExtensibleProperties | Represents a IHasExtensibleProperties.
 | ImageDimension | Image dimension enumeration.
 | IRenderingType | Defines the basic properties and functionality of a type of renderings.
 | Keyboard | Represents a Keyboard.
 | RenderAs | Defines how a webcontrol is optimized by Sheer UI.
 | RenderingType | Defines the basic properties and functionality of a type of renderings.
 | ScriptInvokationBuilder | Builds javascript method invocation strings
 | ScriptMethodBase | Represents a base script method.
 | SublayoutRenderingType | Handles Sublayouts.
 | ViewState | Implements utility functions for working with ViewState.
 | ViewStateDisabler | EventDisabler class
 | WebControl | Serves as the base class that defines the methods, properties and events common to all controls in Sitecore.
 | WebControlRenderingType |
 | XmlControlRenderingType |
 | XslControlRenderingType |


IHasExtensibleProperties Interface

IHasExtensibleProperties Interface
Namespaces ► Sitecore.Web.UI ► IHasExtensibleProperties
Represents a IHasExtensibleProperties.
Declaration Syntax
C#
public interface IHasExtensibleProperties
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property.


SetExtensibleProperty Method (control, name, value)

SetExtensibleProperty Method (control, name, value)
Namespaces ► Sitecore.Web.UI ► IHasExtensibleProperties ► SetExtensibleProperty(Control, String, String)
Sets the extensible property.
Declaration Syntax
C#
void SetExtensibleProperty(
    Control control,
    string name,
    string value
)
Parameters
control (Control)
The control.
name (String)
The name.
value (String)
The value.


ImageDimension Enumeration

ImageDimension Enumeration
Namespaces ► Sitecore.Web.UI ► ImageDimension
Image dimension enumeration.
Declaration Syntax
C#
public enum ImageDimension
Members
Member | Description
idDefault | Default dimension
id16x16 | 16 by 16 pixels.
id24x24 | 24 by 24 pixels.
id32x32 | 32 by 32 pixels.
id48x48 | 48 by 48 pixels.


IRenderingType Interface

IRenderingType Interface
Namespaces ► Sitecore.Web.UI ► IRenderingType
Defines the basic properties and functionality of a type of renderings.
Declaration Syntax
C#
public interface IRenderingType
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetAttributes(NameValueCollection, NameValueCollection) | Gets the attributes.
 | GetControl(NameValueCollection, Boolean) | Gets the control.
 | GetDesignTimeHtmlParameters(NameValueCollection, Boolean) | Gets the design time HTML parameters.
 | GetDesignTimeLiveControl(NameValueCollection, Boolean) | Gets the design time live control.
Remarks
Examples of rendering types are Xslt, WebControls and Sublayouts.


GetAttributes Method (properties, attributes)

GetAttributes Method (properties, attributes)
Namespaces ► Sitecore.Web.UI ► IRenderingType ► GetAttributes(NameValueCollection, NameValueCollection)
Gets the attributes.
Declaration Syntax
C#
void GetAttributes(
    NameValueCollection properties,
    NameValueCollection attributes
)
Parameters
properties (NameValueCollection)
The properties.
attributes (NameValueCollection)
The attributes.


GetControl Method (parameters, assert)

GetControl Method (parameters, assert)
Namespaces ► Sitecore.Web.UI ► IRenderingType ► GetControl(NameValueCollection, Boolean)
Gets the control.
Declaration Syntax
C#
Control GetControl(
    NameValueCollection parameters,
    bool assert
)
Parameters
parameters (NameValueCollection)
The parameters.
assert (Boolean)
if set to true this instance is assert.
Return Value


GetDesignTimeHtmlParameters Method (parameters, assert)

GetDesignTimeHtmlParameters Method (parameters, assert)
Namespaces ► Sitecore.Web.UI ► IRenderingType ► GetDesignTimeHtmlParameters(NameValueCollection, Boolean)
Gets the design time HTML parameters.
Declaration Syntax
C#
string GetDesignTimeHtmlParameters(
    NameValueCollection parameters,
    bool assert
)
Parameters
parameters (NameValueCollection)
The parameters.
assert (Boolean)
if set to true this instance is assert.
Return Value


GetDesignTimeLiveControl Method (parameters, assert)

GetDesignTimeLiveControl Method (parameters, assert)
Namespaces ► Sitecore.Web.UI ► IRenderingType ► GetDesignTimeLiveControl(NameValueCollection, Boolean)
Gets the design time live control.
Declaration Syntax
C#
Control GetDesignTimeLiveControl(
    NameValueCollection parameters,
    bool assert
)
Parameters
parameters (NameValueCollection)
The parameters.
assert (Boolean)
if set to true this instance is assert.
Return Value


Keyboard Class

Keyboard Class
Namespaces ► Sitecore.Web.UI ► Keyboard
Represents a Keyboard.
Declaration Syntax
C#
public static class Keyboard
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetKeyCodeText(String) | Gets the keycode text.
 | GetToolTip(String) | Gets the tool tip.
Inheritance Hierarchy
Object
Keyboard


GetKeyCodeText Method (keyCode)

GetKeyCodeText Method (keyCode)
Namespaces ► Sitecore.Web.UI ► Keyboard ► GetKeyCodeText(String)
Gets the keycode text.
Declaration Syntax
C#
public static string GetKeyCodeText(
    string keyCode
)
Parameters
keyCode (String)
The key code.
Return Value
The keycode text.


GetToolTip Method (keycode)

GetToolTip Method (keycode)
Namespaces ► Sitecore.Web.UI ► Keyboard ► GetToolTip(String)
Gets the tool tip.
Declaration Syntax
C#
public static string GetToolTip(
    string keycode
)
Parameters
keycode (String)
The keycode.


RenderAs Enumeration

RenderAs Enumeration
Namespaces ► Sitecore.Web.UI ► RenderAs
Defines how a webcontrol is optimized by Sheer UI.
Declaration Syntax
C#
public enum RenderAs
Members
Member | Description
WebControl | WebControl.
Literal | Literal.
PersistedLiteral | Persisted literal.
LiteralIfChildrenLiteral | Literal if children literal.


RenderingType Class

RenderingType Class
Namespaces ► Sitecore.Web.UI ► RenderingType
Defines the basic properties and functionality of a type of renderings.
Declaration Syntax
C#
public abstract class RenderingType : IRenderingType
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RenderingType()()() | Initializes a new instance of the RenderingType class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttributes(NameValueCollection, NameValueCollection) | Gets the attributes.
 | GetControl(NameValueCollection, Boolean) | Gets the control.
 | GetDesignTimeHtmlParameters(NameValueCollection, Boolean) | Gets the design time HTML parameters.
 | GetDesignTimeLiveControl(NameValueCollection, Boolean) | Gets the design time live control.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderingType
 |  | SublayoutRenderingType
 |  | WebControlRenderingType
 |  | XmlControlRenderingType
 |  | XslControlRenderingType


RenderingType Constructor

RenderingType Constructor
Namespaces ► Sitecore.Web.UI ► RenderingType ► RenderingType()()()
Initializes a new instance of the RenderingType class
Declaration Syntax
C#
protected RenderingType()


GetAttributes Method (properties, attributes)

GetAttributes Method (properties, attributes)
Namespaces ► Sitecore.Web.UI ► RenderingType ► GetAttributes(NameValueCollection, NameValueCollection)
Gets the attributes.
Declaration Syntax
C#
public virtual void GetAttributes(
    NameValueCollection properties,
    NameValueCollection attributes
)
Parameters
properties (NameValueCollection)
The properties.
attributes (NameValueCollection)
The attributes.


GetControl Method (parameters, assert)

GetControl Method (parameters, assert)
Namespaces ► Sitecore.Web.UI ► RenderingType ► GetControl(NameValueCollection, Boolean)
Gets the control.
Declaration Syntax
C#
public abstract Control GetControl(
    NameValueCollection parameters,
    bool assert
)
Parameters
parameters (NameValueCollection)
The parameters.
assert (Boolean)
if set to true this instance performs asserts.
Return Value
The created control.


GetDesignTimeHtmlParameters Method (parameters, assert)

GetDesignTimeHtmlParameters Method (parameters, assert)
Namespaces ► Sitecore.Web.UI ► RenderingType ► GetDesignTimeHtmlParameters(NameValueCollection, Boolean)
Gets the design time HTML parameters.
Declaration Syntax
C#
public virtual string GetDesignTimeHtmlParameters(
    NameValueCollection parameters,
    bool assert
)
Parameters
parameters (NameValueCollection)
The parameters.
assert (Boolean)
if set to true this instance performs asserts.
Return Value


GetDesignTimeLiveControl Method (parameters, assert)

GetDesignTimeLiveControl Method (parameters, assert)
Namespaces ► Sitecore.Web.UI ► RenderingType ► GetDesignTimeLiveControl(NameValueCollection, Boolean)
Gets the design time live control.
Declaration Syntax
C#
public virtual Control GetDesignTimeLiveControl(
    NameValueCollection parameters,
    bool assert
)
Parameters
parameters (NameValueCollection)
The parameters.
assert (Boolean)
if set to true this instance performs asserts.
Return Value


ScriptInvokationBuilder Class

ScriptInvokationBuilder Class
Namespaces ► Sitecore.Web.UI ► ScriptInvokationBuilder
Builds javascript method invocation strings
Declaration Syntax
C#
public class ScriptInvokationBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ScriptInvokationBuilder(String) | Initializes a new instance of the ScriptInvokationBuilder class.
 | ScriptInvokationBuilder(String, String) | Initializes a new instance of the ScriptInvokationBuilder class.
 | Add(String) | Adds the argument.
 | Add(Boolean) | Adds the specified value.
 | AddString(String, array<Object>[]()[]) | Adds the string argument
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Method | Gets the name.
 | Object |
 | Reset()()() | Resets all arguments.
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
ScriptInvokationBuilder


ScriptInvokationBuilder Constructor

ScriptInvokationBuilder Constructor
Namespaces ► Sitecore.Web.UI ► ScriptInvokationBuilder ► ScriptInvokationBuilder()()()
Members
Icon | Member | Description
 | ScriptInvokationBuilder(String) | Initializes a new instance of the ScriptInvokationBuilder class.
 | ScriptInvokationBuilder(String, String) | Initializes a new instance of the ScriptInvokationBuilder class.


ScriptInvokationBuilder Constructor (method)

ScriptInvokationBuilder Constructor (method)
Namespaces ► Sitecore.Web.UI ► ScriptInvokationBuilder ► ScriptInvokationBuilder(String)
Initializes a new instance of the ScriptInvokationBuilder class.
Declaration Syntax
C#
public ScriptInvokationBuilder(
    string method
)
Parameters
method (String)
Method name.


ScriptInvokationBuilder Constructor (object, method)

ScriptInvokationBuilder Constructor (object, method)
Namespaces ► Sitecore.Web.UI ► ScriptInvokationBuilder ► ScriptInvokationBuilder(String, String)
Initializes a new instance of the ScriptInvokationBuilder class.
Declaration Syntax
C#
public ScriptInvokationBuilder(
    string object,
    string method
)
Parameters
object (String)
The @object.
method (String)
The method.


Add Method

Add Method
Namespaces ► Sitecore.Web.UI ► ScriptInvokationBuilder ► Add()()()
Members
Icon | Member | Description
 | Add(String) | Adds the argument.
 | Add(Boolean) | Adds the specified value.


Add Method (value)

Add Method (value)
Namespaces ► Sitecore.Web.UI ► ScriptInvokationBuilder ► Add(Boolean)
Adds the specified value.
Declaration Syntax
C#
public void Add(
    bool value
)
Parameters
value (Boolean)
if set to true this instance is value.


Add Method (value)

Add Method (value)
Namespaces ► Sitecore.Web.UI ► ScriptInvokationBuilder ► Add(String)
Adds the argument.
Declaration Syntax
C#
public void Add(
    string value
)
Parameters
value (String)
The value.


AddString Method (value, args)

AddString Method (value, args)
Namespaces ► Sitecore.Web.UI ► ScriptInvokationBuilder ► AddString(String, array<Object>[]()[])
Adds the string argument
Declaration Syntax
C#
public ScriptInvokationBuilder AddString(
    string value,
    params Object[] args
)
Parameters
value (String)
The value.
args (array< Object >[]()[])
The args.


Method Property

Method Property
Namespaces ► Sitecore.Web.UI ► ScriptInvokationBuilder ► Method
Gets the name.
Declaration Syntax
C#
public string Method { get; }
Value
The name.


Object Property

Object Property
Namespaces ► Sitecore.Web.UI ► ScriptInvokationBuilder ► Object
Declaration Syntax
C#
public string Object { get; set; }


Reset Method

Reset Method
Namespaces ► Sitecore.Web.UI ► ScriptInvokationBuilder ► Reset()()()
Resets all arguments.
Declaration Syntax
C#
public void Reset()


ToString Method

ToString Method
Namespaces ► Sitecore.Web.UI ► ScriptInvokationBuilder ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


ScriptMethodBase Class

ScriptMethodBase Class
Namespaces ► Sitecore.Web.UI ► ScriptMethodBase
Represents a base script method.
Declaration Syntax
C#
public abstract class ScriptMethodBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ScriptMethodBase(String) | Initializes a new instance of the ScriptMethodBase class.
 | ScriptMethodBase(String, String) | Initializes a new instance of the ScriptMethodBase class.
 | Builder | Gets or sets the builder.
 | DoPopulate(ScriptInvokationBuilder) | Executes the populate event.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
 | ScriptMethodBase
 |  | ShowEditorTab


ScriptMethodBase Constructor

ScriptMethodBase Constructor
Namespaces ► Sitecore.Web.UI ► ScriptMethodBase ► ScriptMethodBase()()()
Members
Icon | Member | Description
 | ScriptMethodBase(String) | Initializes a new instance of the ScriptMethodBase class.
 | ScriptMethodBase(String, String) | Initializes a new instance of the ScriptMethodBase class.


ScriptMethodBase Constructor (method)

ScriptMethodBase Constructor (method)
Namespaces ► Sitecore.Web.UI ► ScriptMethodBase ► ScriptMethodBase(String)
Initializes a new instance of the ScriptMethodBase class.
Declaration Syntax
C#
protected ScriptMethodBase(
    string method
)
Parameters
method (String)
The method.


ScriptMethodBase Constructor (object, method)

ScriptMethodBase Constructor (object, method)
Namespaces ► Sitecore.Web.UI ► ScriptMethodBase ► ScriptMethodBase(String, String)
Initializes a new instance of the ScriptMethodBase class.
Declaration Syntax
C#
protected ScriptMethodBase(
    string object,
    string method
)
Parameters
object (String)
The @object.
method (String)
The method.


Builder Property

Builder Property
Namespaces ► Sitecore.Web.UI ► ScriptMethodBase ► Builder
Gets or sets the builder.
Declaration Syntax
C#
protected ScriptInvokationBuilder Builder { get; set; }
Value
The builder.


DoPopulate Method (builder)

DoPopulate Method (builder)
Namespaces ► Sitecore.Web.UI ► ScriptMethodBase ► DoPopulate(ScriptInvokationBuilder)
Executes the populate event.
Declaration Syntax
C#
protected abstract void DoPopulate(
    ScriptInvokationBuilder builder
)
Parameters
builder (ScriptInvokationBuilder)
The builder.


ToString Method

ToString Method
Namespaces ► Sitecore.Web.UI ► ScriptMethodBase ► ToString()()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.


SublayoutRenderingType Class

SublayoutRenderingType Class
Namespaces ► Sitecore.Web.UI ► SublayoutRenderingType
Handles Sublayouts.
Declaration Syntax
C#
public class SublayoutRenderingType : RenderingType
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SublayoutRenderingType()()() | Initializes a new instance of the SublayoutRenderingType class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttributes(NameValueCollection, NameValueCollection) | Gets the attributes. (Inherited from RenderingType.)
 | GetControl(NameValueCollection, Boolean) | Gets the control. (Overrides RenderingType.GetControl(NameValueCollection, Boolean).)
 | GetDesignTimeHtmlParameters(NameValueCollection, Boolean) | Gets the design time HTML parameters. (Overrides RenderingType.GetDesignTimeHtmlParameters(NameValueCollection, Boolean).)
 | GetDesignTimeLiveControl(NameValueCollection, Boolean) | Gets the design time live control. (Overrides RenderingType.GetDesignTimeLiveControl(NameValueCollection, Boolean).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderingType
 |  | SublayoutRenderingType


SublayoutRenderingType Constructor

SublayoutRenderingType Constructor
Namespaces ► Sitecore.Web.UI ► SublayoutRenderingType ► SublayoutRenderingType()()()
Initializes a new instance of the SublayoutRenderingType class
Declaration Syntax
C#
public SublayoutRenderingType()


GetControl Method (parameters, assert)

GetControl Method (parameters, assert)
Namespaces ► Sitecore.Web.UI ► SublayoutRenderingType ► GetControl(NameValueCollection, Boolean)
Gets the control.
Declaration Syntax
C#
public override Control GetControl(
    NameValueCollection parameters,
    bool assert
)
Parameters
parameters (NameValueCollection)
The parameters.
assert (Boolean)
if set to true this instance performs asserts.
Return Value


GetDesignTimeHtmlParameters Method (parameters, assert)

GetDesignTimeHtmlParameters Method (parameters, assert)
Namespaces ► Sitecore.Web.UI ► SublayoutRenderingType ► GetDesignTimeHtmlParameters(NameValueCollection, Boolean)
Gets the design time HTML parameters.
Declaration Syntax
C#
public override string GetDesignTimeHtmlParameters(
    NameValueCollection parameters,
    bool assert
)
Parameters
parameters (NameValueCollection)
The parameters.
assert (Boolean)
if set to true this instance performs asserts.
Return Value


GetDesignTimeLiveControl Method (parameters, assert)

GetDesignTimeLiveControl Method (parameters, assert)
Namespaces ► Sitecore.Web.UI ► SublayoutRenderingType ► GetDesignTimeLiveControl(NameValueCollection, Boolean)
Gets the design time live control.
Declaration Syntax
C#
public override Control GetDesignTimeLiveControl(
    NameValueCollection parameters,
    bool assert
)
Parameters
parameters (NameValueCollection)
The parameters.
assert (Boolean)
if set to true this instance performs asserts.
Return Value


ViewState Class

ViewState Class
Namespaces ► Sitecore.Web.UI ► ViewState
Implements utility functions for working with ViewState.
Declaration Syntax
C#
public static class ViewState
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetKey()()() | Gets the key.
Inheritance Hierarchy
Object
ViewState


GetKey Method

GetKey Method
Namespaces ► Sitecore.Web.UI ► ViewState ► GetKey()()()
Gets the key.
Declaration Syntax
C#
public static string GetKey()
Return Value
The key.


ViewStateDisabler Class

ViewStateDisabler Class
Namespaces ► Sitecore.Web.UI ► ViewStateDisabler
EventDisabler class
Declaration Syntax
C#
public sealed class ViewStateDisabler : Switcher<bool, ViewStateDisabler>
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ViewStateDisabler()()() | Initializes a new instance of the ViewStateDisabler class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(TValue, TSwitchType>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsActive | Gets a value indicating whether this instance is active.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Switcher <(Of <(Boolean, ViewStateDisabler>)>)
 |  | ViewStateDisabler


ViewStateDisabler Constructor

ViewStateDisabler Constructor
Namespaces ► Sitecore.Web.UI ► ViewStateDisabler ► ViewStateDisabler()()()
Initializes a new instance of the ViewStateDisabler class.
Declaration Syntax
C#
public ViewStateDisabler()


IsActive Property

IsActive Property
Namespaces ► Sitecore.Web.UI ► ViewStateDisabler ► IsActive
Gets a value indicating whether this instance is active.
Declaration Syntax
C#
public static bool IsActive { get; }
Value
true if this instance is active; otherwise, false.


WebControl Class

WebControl Class
Namespaces ► Sitecore.Web.UI ► WebControl
Serves as the base class that defines the methods, properties and events common to all controls in Sitecore.
Declaration Syntax
C#
public abstract class WebControl : WebControl,
    IHasExtensibleProperties, ISupportInitialize
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WebControl()()() | Initializes a new instance of the WebControl class.
 | WebControl(String) | Initializes a new instance of the WebControl class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value.
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache.
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered.
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style.
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered.
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style.
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered.
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable.
 | CacheKey | Caching identifier (used in key generation)
 | CacheTimeout | Caching identifier (used in key generation)
 | CachingID | Caching identifier (used in key generation)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags
 | Clear | Gets or sets the clear style property.
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style.
 | Cursor | Gets or sets the cursor style.
 | Database | Gets or sets the name of the database to be used for rendering the control.
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source.
 | DesignMode | Gets a value indicating whether a control is being used on a design surface.
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging.
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots.
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security.
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
 | DrawDots | Gets a value indicating whether the WebControl draws the dots.
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script.
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property.
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style.
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item.
 | GetCachedHtml(String) | Gets the cached HTML.
 | GetCacheKey()()() | Gets the cache key.
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching.
 | GetContextItem()()() | Gets the context item.
 | GetDatabase()()() | Gets the database to use.
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML.
 | GetErrorControl(String, String) | Get control to display an error message.
 | GetExtensibleProperties(Control) | Gets the extensible properties.
 | GetExtensibleProperty(Control, String) | Gets the extensible property.
 | GetFieldValue(String) | Get field value from current data source.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item.
 | GetTraceName()()() | Gets the text used when tracing.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in)
 | MakeEditable(HtmlControl, String) | Makes the control editable.
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable.
 | MakeEditable(HtmlControl, String, String) | Makes the control editable.
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another.
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property.
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters.
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script.
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderAs | Determines how the control is optimized by Sheer UI.
 | RenderAsText()()() | Renders the control as text.
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control.
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error.
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html.
 | RenderingID | Gets or sets the rendering ID.
 | RenderingName | Gets or sets the name of the rendering.
 | RenderXml(XmlNode, TextWriter) | Renders the XML.
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute.
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property.
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute.
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control.
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data.
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device.
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login.
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters.
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string.
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | ItemPainter
 |  |  |  | Component
 |  |  |  | RenderLiteral
 |  |  |  | UserControlRenderer
 |  |  |  | PortletSelector
 |  |  |  | ContentDot
 |  |  |  | ControlRenderer
 |  |  |  | Document
 |  |  |  | EditFrame
 |  |  |  | ErrorControl
 |  |  |  | FieldControl
 |  |  |  | FieldRenderer
 |  |  |  | GridPanel
 |  |  |  | ItemList
 |  |  |  | ItemRenderer
 |  |  |  | LanguageMeta
 |  |  |  | Method
 |  |  |  | MultiVarianceTestRenderer
 |  |  |  | Placeholder
 |  |  |  | Item
 |  |  |  | ItemList
 |  |  |  | Rendering
 |  |  |  | Sublayout
 |  |  |  | VisitorIdentification
 |  |  |  | WebEditControl
 |  |  |  | WebPage
 |  |  |  | XslFile
 |  |  |  | GenericControl
 |  |  |  | Repeater
 |  |  |  | XmlControl


WebControl Constructor

WebControl Constructor
Namespaces ► Sitecore.Web.UI ► WebControl ► WebControl()()()
Members
Icon | Member | Description
 | WebControl()()() | Initializes a new instance of the WebControl class.
 | WebControl(String) | Initializes a new instance of the WebControl class.


WebControl Constructor

WebControl Constructor
Namespaces ► Sitecore.Web.UI ► WebControl ► WebControl()()()
Initializes a new instance of the WebControl class.
Declaration Syntax
C#
protected WebControl()


WebControl Constructor (tag)

WebControl Constructor (tag)
Namespaces ► Sitecore.Web.UI ► WebControl ► WebControl(String)
Initializes a new instance of the WebControl class.
Declaration Syntax
C#
protected WebControl(
    string tag
)
Parameters
tag (String)
An HTML tag.


AddDebugValue Method (key, value)

AddDebugValue Method (key, value)
Namespaces ► Sitecore.Web.UI ► WebControl ► AddDebugValue(String, String)
Adds the debug value.
Declaration Syntax
C#
protected void AddDebugValue(
    string key,
    string value
)
Parameters
key (String)
The key.
value (String)
The value.


AddToCache Method (cacheKey, html)

AddToCache Method (cacheKey, html)
Namespaces ► Sitecore.Web.UI ► WebControl ► AddToCache(String, String)
Adds to cache.
Declaration Syntax
C#
protected virtual void AddToCache(
    string cacheKey,
    string html
)
Parameters
cacheKey (String)
The cache key.
html (String)
The HTML.


AfterRender Method (output)

AfterRender Method (output)
Namespaces ► Sitecore.Web.UI ► WebControl ► AfterRender(HtmlTextWriter)
Executes afters the control has been rendered.
Declaration Syntax
C#
protected virtual void AfterRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


Background Property

Background Property
Namespaces ► Sitecore.Web.UI ► WebControl ► Background
Gets or sets the background style.
Declaration Syntax
C#
public virtual string Background { get; set; }
Value
The background.


BeforeRender Method (output)

BeforeRender Method (output)
Namespaces ► Sitecore.Web.UI ► WebControl ► BeforeRender(HtmlTextWriter)
Executes befores the control is rendered.
Declaration Syntax
C#
protected virtual void BeforeRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


Border Property

Border Property
Namespaces ► Sitecore.Web.UI ► WebControl ► Border
Gets or sets the border style.
Declaration Syntax
C#
public virtual string Border { get; set; }
Value
The border.


Bordered Property

Bordered Property
Namespaces ► Sitecore.Web.UI ► WebControl ► Bordered
Gets or sets a value indicating whether this WebControl is bordered.
Declaration Syntax
C#
public virtual bool Bordered { get; set; }
Value
true if bordered; otherwise, false.


Cacheable Property

Cacheable Property
Namespaces ► Sitecore.Web.UI ► WebControl ► Cacheable
Gets or sets a value indicating whether this WebControl is cacheable.
Declaration Syntax
C#
public virtual bool Cacheable { get; set; }
Value
true if cacheable; otherwise, false.


CacheKey Property

CacheKey Property
Namespaces ► Sitecore.Web.UI ► WebControl ► CacheKey
Caching identifier (used in key generation)
Declaration Syntax
C#
public virtual string CacheKey { get; set; }
Value
The caching ID.


CacheTimeout Property

CacheTimeout Property
Namespaces ► Sitecore.Web.UI ► WebControl ► CacheTimeout
Caching identifier (used in key generation)
Declaration Syntax
C#
public virtual TimeSpan CacheTimeout { get; set; }
Value
The caching ID.


CachingID Property

CachingID Property
Namespaces ► Sitecore.Web.UI ► WebControl ► CachingID
Caching identifier (used in key generation)
Declaration Syntax
C#
public virtual string CachingID { get; }
Value
The caching ID.


ClassAttribute Property

ClassAttribute Property
Namespaces ► Sitecore.Web.UI ► WebControl ► ClassAttribute
Css class attribute for use in tags
Declaration Syntax
C#
public virtual string ClassAttribute { get; }
Value
The class attribute.


Clear Property

Clear Property
Namespaces ► Sitecore.Web.UI ► WebControl ► Clear
Gets or sets the clear style property.
Declaration Syntax
C#
public virtual string Clear { get; set; }
Value
The clear.


CollectDebugInformation Method

CollectDebugInformation Method
Namespaces ► Sitecore.Web.UI ► WebControl ► CollectDebugInformation()()()
Collects the debug information.
Declaration Syntax
C#
protected virtual void CollectDebugInformation()


ControlInfo Property

ControlInfo Property
Namespaces ► Sitecore.Web.UI ► WebControl ► ControlInfo
Control info (for use in explaindots)
Declaration Syntax
C#
[ObsoleteAttribute("The recommended alternative is AddDebugValue(string key, string value)")]
public virtual string ControlInfo { get; }
Value
The control info.


CssStyle Property

CssStyle Property
Namespaces ► Sitecore.Web.UI ► WebControl ► CssStyle
Gets or sets the CSS style.
Declaration Syntax
C#
public virtual string CssStyle { get; set; }
Value
The CSS style.


Cursor Property

Cursor Property
Namespaces ► Sitecore.Web.UI ► WebControl ► Cursor
Gets or sets the cursor style.
Declaration Syntax
C#
public virtual string Cursor { get; set; }
Value
The cursor.


Database Property

Database Property
Namespaces ► Sitecore.Web.UI ► WebControl ► Database
Gets or sets the name of the database to be used for rendering the control.
Declaration Syntax
C#
public virtual string Database { get; set; }
Value
The database name.


DataSource Property

DataSource Property
Namespaces ► Sitecore.Web.UI ► WebControl ► DataSource
Gets or sets the data source.
Declaration Syntax
C#
public virtual string DataSource { get; set; }
Value
The data source.


DesignMode Property

DesignMode Property
Namespaces ► Sitecore.Web.UI ► WebControl ► DesignMode
Gets a value indicating whether a control is being used on a design surface.
Declaration Syntax
C#
public virtual bool DesignMode { get; }
Value
Return Value
true if the control is being used in a designer; otherwise, false.


DisableDebug Property

DisableDebug Property
Namespaces ► Sitecore.Web.UI ► WebControl ► DisableDebug
Gets or sets a value indicating whether the WebControl disables debugging.
Declaration Syntax
C#
public virtual bool DisableDebug { get; set; }
Value
true if the WebControl disables debugging; otherwise, false.


DisableDots Property

DisableDots Property
Namespaces ► Sitecore.Web.UI ► WebControl ► DisableDots
Gets or sets a value indicating whether the WebControl disables the dots.
Declaration Syntax
C#
public virtual bool DisableDots { get; set; }
Value
true if the WebControl disables the dots; otherwise, false.


DisableSecurity Property

DisableSecurity Property
Namespaces ► Sitecore.Web.UI ► WebControl ► DisableSecurity
Gets or sets a value indicating whether the WebControl disables the security.
Declaration Syntax
C#
public virtual bool DisableSecurity { get; set; }
Value
true if the WebControl disables the security; otherwise, false.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI ► WebControl ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected abstract void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.
Remarks
When developing custom server controls, you can override this method to generate content for an ASP.NET page.


DrawDots Property

DrawDots Property
Namespaces ► Sitecore.Web.UI ► WebControl ► DrawDots
Gets a value indicating whether the WebControl draws the dots.
Declaration Syntax
C#
public virtual bool DrawDots { get; }
Value
true if the WebControl draws the dots; otherwise, false.


EmitRenderingInfoScript Method

EmitRenderingInfoScript Method
Namespaces ► Sitecore.Web.UI ► WebControl ► EmitRenderingInfoScript()()()
Emits the rendering info script.
Declaration Syntax
C#
[ObsoleteAttribute("The recommended alternative is RegisterDebugScript()")]
protected virtual void EmitRenderingInfoScript()


Float Property

Float Property
Namespaces ► Sitecore.Web.UI ► WebControl ► Float
Gets or sets the float style property.
Declaration Syntax
C#
public virtual string Float { get; set; }
Value
The float style property.


Foreground Property

Foreground Property
Namespaces ► Sitecore.Web.UI ► WebControl ► Foreground
Gets or sets the foreground color style.
Declaration Syntax
C#
public virtual string Foreground { get; set; }
Value
The foreground.


GetAncestorItem Method (templates, item)

GetAncestorItem Method (templates, item)
Namespaces ► Sitecore.Web.UI ► WebControl ► GetAncestorItem(array<String>[]()[], Item)
Gets the ancestor item.
Declaration Syntax
C#
protected virtual Item GetAncestorItem(
    string[] templates,
    Item item
)
Parameters
templates (array< String >[]()[])
The templates.
item (Item)
The item.
Return Value


GetCachedHtml Method (cacheKey)

GetCachedHtml Method (cacheKey)
Namespaces ► Sitecore.Web.UI ► WebControl ► GetCachedHtml(String)
Gets the cached HTML.
Declaration Syntax
C#
protected string GetCachedHtml(
    string cacheKey
)
Parameters
cacheKey (String)
The cache key.
Return Value
The cached HTML.


GetCacheKey Method

GetCacheKey Method
Namespaces ► Sitecore.Web.UI ► WebControl ► GetCacheKey()()()
Gets the cache key.
Declaration Syntax
C#
public virtual string GetCacheKey()
Return Value


GetCachingID Method

GetCachingID Method
Namespaces ► Sitecore.Web.UI ► WebControl ► GetCachingID()()()
Get caching identifier. Must be implemented by controls that supports caching.
Declaration Syntax
C#
protected virtual string GetCachingID()
Return Value
Remarks
If an empty string is returned, the control will not be cached.


GetContextItem Method

GetContextItem Method
Namespaces ► Sitecore.Web.UI ► WebControl ► GetContextItem()()()
Gets the context item.
Declaration Syntax
C#
public virtual Item GetContextItem()
Return Value
The context item.


GetDatabase Method

GetDatabase Method
Namespaces ► Sitecore.Web.UI ► WebControl ► GetDatabase()()()
Gets the database to use.
Declaration Syntax
C#
public Database GetDatabase()
Return Value


GetDesignTimeHtml Method (xml)

GetDesignTimeHtml Method (xml)
Namespaces ► Sitecore.Web.UI ► WebControl ► GetDesignTimeHtml(XmlNode)
Gets the design time HTML.
Declaration Syntax
C#
public virtual string GetDesignTimeHtml(
    XmlNode xml
)
Parameters
xml (XmlNode)
The XML.
Return Value


GetErrorControl Method (errorMessage, details)

GetErrorControl Method (errorMessage, details)
Namespaces ► Sitecore.Web.UI ► WebControl ► GetErrorControl(String, String)
Get control to display an error message.
Declaration Syntax
C#
public static Control GetErrorControl(
    string errorMessage,
    string details
)
Parameters
errorMessage (String)
The error message.
details (String)
The details.
Return Value


GetExtensibleProperties Method (control)

GetExtensibleProperties Method (control)
Namespaces ► Sitecore.Web.UI ► WebControl ► GetExtensibleProperties(Control)
Gets the extensible properties.
Declaration Syntax
C#
public virtual Hashtable GetExtensibleProperties(
    Control control
)
Parameters
control (Control)
The control.
Return Value


GetExtensibleProperty Method (control, name)

GetExtensibleProperty Method (control, name)
Namespaces ► Sitecore.Web.UI ► WebControl ► GetExtensibleProperty(Control, String)
Gets the extensible property.
Declaration Syntax
C#
public virtual string GetExtensibleProperty(
    Control control,
    string name
)
Parameters
control (Control)
The control.
name (String)
The name.
Return Value


GetFieldValue Method (field)

GetFieldValue Method (field)
Namespaces ► Sitecore.Web.UI ► WebControl ► GetFieldValue(String)
Get field value from current data source.
Declaration Syntax
C#
protected virtual string GetFieldValue(
    string field
)
Parameters
field (String)
The field.
Return Value
Remarks
Support attributes by prefixing with @ (ex. @name)


GetItem Method

GetItem Method
Namespaces ► Sitecore.Web.UI ► WebControl ► GetItem()()()
Gets the item.
Declaration Syntax
C#
protected virtual Item GetItem()
Return Value


GetTraceName Method

GetTraceName Method
Namespaces ► Sitecore.Web.UI ► WebControl ► GetTraceName()()()
Gets the text used when tracing.
Declaration Syntax
C#
public virtual string GetTraceName()
Return Value
The ID or the rendering name with the type name of the control.


LiveDisplay Property

LiveDisplay Property
Namespaces ► Sitecore.Web.UI ► WebControl ► LiveDisplay
Gets or sets a value indicating whether the WebControl displays in live mode at design time.
Declaration Syntax
C#
public virtual bool LiveDisplay { get; set; }
Value
true if the WebControl displays in live mode at design time; otherwise, false.


LoginRendering Property

LoginRendering Property
Namespaces ► Sitecore.Web.UI ► WebControl ► LoginRendering
Name or id of rendering/sublayout to show for protected items (when not logged in)
Declaration Syntax
C#
public virtual string LoginRendering { get; set; }
Value
The login rendering.
Remarks
To uniquely identify a rendering or a sublayout, prefix the name with either rendering# or sublayout#. For example, to specify the rendering Document, use: LoginRendering = "rendering#document"


MakeEditable Method

MakeEditable Method
Namespaces ► Sitecore.Web.UI ► WebControl ► MakeEditable()()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) | Makes the control editable.
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable.
 | MakeEditable(HtmlControl, String, String) | Makes the control editable.


MakeEditable Method (control, field)

MakeEditable Method (control, field)
Namespaces ► Sitecore.Web.UI ► WebControl ► MakeEditable(HtmlControl, String)
Makes the control editable.
Declaration Syntax
C#
protected void MakeEditable(
    HtmlControl control,
    string field
)
Parameters
control (HtmlControl)
The control.
field (String)
The field.


MakeEditable Method (control, field, getter)

MakeEditable Method (control, field, getter)
Namespaces ► Sitecore.Web.UI ► WebControl ► MakeEditable(HtmlControl, String, WebControl..::.ContentGetter)
Makes the control editable.
Declaration Syntax
C#
protected void MakeEditable(
    HtmlControl control,
    string field,
    WebControl..::.ContentGetter getter
)
Parameters
control (HtmlControl)
The control.
field (String)
The field.
getter (WebControl..::.ContentGetter)
The getter.


MakeEditable Method (control, field, getMethod)

MakeEditable Method (control, field, getMethod)
Namespaces ► Sitecore.Web.UI ► WebControl ► MakeEditable(HtmlControl, String, String)
Makes the control editable.
Declaration Syntax
C#
protected void MakeEditable(
    HtmlControl control,
    string field,
    string getMethod
)
Parameters
control (HtmlControl)
The control.
field (String)
The field.
getMethod (String)
The get method.


Margin Property

Margin Property
Namespaces ► Sitecore.Web.UI ► WebControl ► Margin
Gets or sets the margin style property.
Declaration Syntax
C#
public virtual string Margin { get; set; }
Value
The margin.


MoveExtensibleProperties Method (destination, source)

MoveExtensibleProperties Method (destination, source)
Namespaces ► Sitecore.Web.UI ► WebControl ► MoveExtensibleProperties(Control, Control)
Moves the extensible properties set on one control to another.
Declaration Syntax
C#
public virtual void MoveExtensibleProperties(
    Control destination,
    Control source
)
Parameters
destination (Control)
The destination.
source (Control)
The source.


Padding Property

Padding Property
Namespaces ► Sitecore.Web.UI ► WebControl ► Padding
Gets or sets the padding style property.
Declaration Syntax
C#
public virtual string Padding { get; set; }
Value
The padding.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Web.UI ► WebControl ► Parameters
Gets or sets the parameters.
Declaration Syntax
C#
public virtual string Parameters { get; set; }
Value
The parameters.


RegisterDebugScript Method

RegisterDebugScript Method
Namespaces ► Sitecore.Web.UI ► WebControl ► RegisterDebugScript()()()
Registers the debug script.
Declaration Syntax
C#
protected virtual void RegisterDebugScript()


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Web.UI ► WebControl ► Render(HtmlTextWriter)
Renders the control to the specified HTML writer.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the control content.
Remarks
When developing custom server controls, you can override this method to generate content for an ASP.NET page.


RenderAs Property

RenderAs Property
Namespaces ► Sitecore.Web.UI ► WebControl ► RenderAs
Determines how the control is optimized by Sheer UI.
Declaration Syntax
C#
public RenderAs RenderAs { get; set; }


RenderAsText Method

RenderAsText Method
Namespaces ► Sitecore.Web.UI ► WebControl ► RenderAsText()()()
Renders the control as text.
Declaration Syntax
C#
public virtual string RenderAsText()
Return Value
The text.


RenderControl Method (properties)

RenderControl Method (properties)
Namespaces ► Sitecore.Web.UI ► WebControl ► RenderControl(XmlNode)
Renders the control.
Declaration Syntax
C#
public virtual string RenderControl(
    XmlNode properties
)
Parameters
properties (XmlNode)
The properties.
Return Value


RenderError Method (errorMessage, details, output)

RenderError Method (errorMessage, details, output)
Namespaces ► Sitecore.Web.UI ► WebControl ► RenderError(String, String, HtmlTextWriter)
Renders the error.
Declaration Syntax
C#
public virtual void RenderError(
    string errorMessage,
    string details,
    HtmlTextWriter output
)
Parameters
errorMessage (String)
The error message.
details (String)
The details.
output (HtmlTextWriter)
The output.


RenderFromCache Method (cacheKey, output)

RenderFromCache Method (cacheKey, output)
Namespaces ► Sitecore.Web.UI ► WebControl ► RenderFromCache(String, HtmlTextWriter)
Renders the control from cached Html.
Declaration Syntax
C#
protected bool RenderFromCache(
    string cacheKey,
    HtmlTextWriter output
)
Parameters
cacheKey (String)
The cache key.
output (HtmlTextWriter)
The output.
Return Value


RenderingID Property

RenderingID Property
Namespaces ► Sitecore.Web.UI ► WebControl ► RenderingID
Gets or sets the rendering ID.
Declaration Syntax
C#
public virtual string RenderingID { get; set; }
Value
The rendering ID.


RenderingName Property

RenderingName Property
Namespaces ► Sitecore.Web.UI ► WebControl ► RenderingName
Gets or sets the name of the rendering.
Declaration Syntax
C#
public virtual string RenderingName { get; set; }
Value
The name of the rendering.


RenderXml Method (xml, output)

RenderXml Method (xml, output)
Namespaces ► Sitecore.Web.UI ► WebControl ► RenderXml(XmlNode, TextWriter)
Renders the XML.
Declaration Syntax
C#
public virtual void RenderXml(
    XmlNode xml,
    TextWriter output
)
Parameters
xml (XmlNode)
The XML.
output (TextWriter)
The output.


SetControlAttribute Method (attribute, value, control)

SetControlAttribute Method (attribute, value, control)
Namespaces ► Sitecore.Web.UI ► WebControl ► SetControlAttribute(String, String, HtmlControl)
Sets the control attribute.
Declaration Syntax
C#
public virtual void SetControlAttribute(
    string attribute,
    string value,
    HtmlControl control
)
Parameters
attribute (String)
The attribute.
value (String)
The value.
control (HtmlControl)
The control.


SetExtensibleProperty Method (control, name, value)

SetExtensibleProperty Method (control, name, value)
Namespaces ► Sitecore.Web.UI ► WebControl ► SetExtensibleProperty(Control, String, String)
Sets the extensible property.
Declaration Syntax
C#
public virtual void SetExtensibleProperty(
    Control control,
    string name,
    string value
)
Parameters
control (Control)
The control.
name (String)
The name.
value (String)
The value.


SkipCaching Method

SkipCaching Method
Namespaces ► Sitecore.Web.UI ► WebControl ► SkipCaching()()()
Flags control to skip caching based on rendering context.
Declaration Syntax
C#
protected virtual bool SkipCaching()
Return Value
True is caching should be (is going to be) skipped.


StyleAttribute Property

StyleAttribute Property
Namespaces ► Sitecore.Web.UI ► WebControl ► StyleAttribute
Gets the style attribute.
Declaration Syntax
C#
public virtual string StyleAttribute { get; }
Value
The style attribute.


TransferAttributes Method (control)

TransferAttributes Method (control)
Namespaces ► Sitecore.Web.UI ► WebControl ► TransferAttributes(Control)
Transfers the attributes to another control.
Declaration Syntax
C#
protected void TransferAttributes(
    Control control
)
Parameters
control (Control)
The control.


VaryByData Property

VaryByData Property
Namespaces ► Sitecore.Web.UI ► WebControl ► VaryByData
Gets or sets a value indicating whether the WebControl varies by data.
Declaration Syntax
C#
public virtual bool VaryByData { get; set; }
Value
true if the WebControl varies by data; otherwise, false.


VaryByDevice Property

VaryByDevice Property
Namespaces ► Sitecore.Web.UI ► WebControl ► VaryByDevice
Gets or sets a value indicating whether the WebControl varies by device.
Declaration Syntax
C#
public virtual bool VaryByDevice { get; set; }
Value
true if the WebControl varies by device; otherwise, false.


VaryByLogin Property

VaryByLogin Property
Namespaces ► Sitecore.Web.UI ► WebControl ► VaryByLogin
Gets or sets a value indicating whether the WebControl variess by login.
Declaration Syntax
C#
public virtual bool VaryByLogin { get; set; }
Value
true if the WebControl variess by login; otherwise, false.


VaryByParm Property

VaryByParm Property
Namespaces ► Sitecore.Web.UI ► WebControl ► VaryByParm
Gets or sets a value indicating whether the WebControl varies by parameters.
Declaration Syntax
C#
public virtual bool VaryByParm { get; set; }
Value
true if the WebControl variess by parameters; otherwise, false.


VaryByQueryString Property

VaryByQueryString Property
Namespaces ► Sitecore.Web.UI ► WebControl ► VaryByQueryString
Gets or sets a value indicating whether the WebControl variess by query string.
Declaration Syntax
C#
public virtual bool VaryByQueryString { get; set; }
Value
true if the WebControl varies by query string; otherwise, false.


VaryByUser Property

VaryByUser Property
Namespaces ► Sitecore.Web.UI ► WebControl ► VaryByUser
Gets or sets a value indicating whether the WebControl variess by user.
Declaration Syntax
C#
public virtual bool VaryByUser { get; set; }
Value
true if the WebControl variess the by user; otherwise, false.


WebControl.ContentGetter Enumeration

WebControl..::.ContentGetter Enumeration
Namespaces ► Sitecore.Web.UI ► WebControl ► WebControl..::.ContentGetter
Represents a Content Getter.
Declaration Syntax
C#
protected enum ContentGetter
Members
Member | Description
InnerHtml | xxx
InnerText | xxx
Value | xxx


WebControlRenderingType Class

WebControlRenderingType Class
Namespaces ► Sitecore.Web.UI ► WebControlRenderingType
Declaration Syntax
C#
public class WebControlRenderingType : RenderingType
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WebControlRenderingType()()() | Initializes a new instance of the WebControlRenderingType class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttributes(NameValueCollection, NameValueCollection) | Gets the attributes. (Inherited from RenderingType.)
 | GetControl(NameValueCollection, Boolean) | Gets the control. (Overrides RenderingType.GetControl(NameValueCollection, Boolean).)
 | GetDesignTimeHtmlParameters(NameValueCollection, Boolean) | Gets the design time HTML parameters. (Overrides RenderingType.GetDesignTimeHtmlParameters(NameValueCollection, Boolean).)
 | GetDesignTimeLiveControl(NameValueCollection, Boolean) | Gets the design time live control. (Inherited from RenderingType.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderingType
 |  | WebControlRenderingType


WebControlRenderingType Constructor

WebControlRenderingType Constructor
Namespaces ► Sitecore.Web.UI ► WebControlRenderingType ► WebControlRenderingType()()()
Initializes a new instance of the WebControlRenderingType class
Declaration Syntax
C#
public WebControlRenderingType()


GetControl Method (parameters, assert)

GetControl Method (parameters, assert)
Namespaces ► Sitecore.Web.UI ► WebControlRenderingType ► GetControl(NameValueCollection, Boolean)
Gets the control.
Declaration Syntax
C#
public override Control GetControl(
    NameValueCollection parameters,
    bool assert
)
Parameters
parameters (NameValueCollection)
The parameters.
assert (Boolean)
if set to true this instance performs asserts.
Return Value
The created control.


GetDesignTimeHtmlParameters Method (parameters, assert)

GetDesignTimeHtmlParameters Method (parameters, assert)
Namespaces ► Sitecore.Web.UI ► WebControlRenderingType ► GetDesignTimeHtmlParameters(NameValueCollection, Boolean)
Gets the design time HTML parameters.
Declaration Syntax
C#
public override string GetDesignTimeHtmlParameters(
    NameValueCollection parameters,
    bool assert
)
Parameters
parameters (NameValueCollection)
The parameters.
assert (Boolean)
if set to true this instance performs asserts.
Return Value


XmlControlRenderingType Class

XmlControlRenderingType Class
Namespaces ► Sitecore.Web.UI ► XmlControlRenderingType
Declaration Syntax
C#
public class XmlControlRenderingType : RenderingType
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | XmlControlRenderingType()()() | Initializes a new instance of the XmlControlRenderingType class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttributes(NameValueCollection, NameValueCollection) | Gets the attributes. (Inherited from RenderingType.)
 | GetControl(NameValueCollection, Boolean) | Gets the control. (Overrides RenderingType.GetControl(NameValueCollection, Boolean).)
 | GetDesignTimeHtmlParameters(NameValueCollection, Boolean) | Gets the design time HTML parameters. (Inherited from RenderingType.)
 | GetDesignTimeLiveControl(NameValueCollection, Boolean) | Gets the design time live control. (Inherited from RenderingType.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderingType
 |  | XmlControlRenderingType


XmlControlRenderingType Constructor

XmlControlRenderingType Constructor
Namespaces ► Sitecore.Web.UI ► XmlControlRenderingType ► XmlControlRenderingType()()()
Initializes a new instance of the XmlControlRenderingType class
Declaration Syntax
C#
public XmlControlRenderingType()


GetControl Method (parameters, assert)

GetControl Method (parameters, assert)
Namespaces ► Sitecore.Web.UI ► XmlControlRenderingType ► GetControl(NameValueCollection, Boolean)
Gets the control.
Declaration Syntax
C#
public override Control GetControl(
    NameValueCollection parameters,
    bool assert
)
Parameters
parameters (NameValueCollection)
The parameters.
assert (Boolean)
if set to true this instance performs asserts.
Return Value
The created control.


XslControlRenderingType Class

XslControlRenderingType Class
Namespaces ► Sitecore.Web.UI ► XslControlRenderingType
Declaration Syntax
C#
public class XslControlRenderingType : RenderingType
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | XslControlRenderingType()()() | Initializes a new instance of the XslControlRenderingType class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttributes(NameValueCollection, NameValueCollection) | Gets the attributes. (Overrides RenderingType.GetAttributes(NameValueCollection, NameValueCollection).)
 | GetControl(NameValueCollection, Boolean) | Gets the control. (Overrides RenderingType.GetControl(NameValueCollection, Boolean).)
 | GetDesignTimeHtmlParameters(NameValueCollection, Boolean) | Gets the design time HTML parameters. (Inherited from RenderingType.)
 | GetDesignTimeLiveControl(NameValueCollection, Boolean) | Gets the design time live control. (Inherited from RenderingType.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | RenderingType
 |  | XslControlRenderingType


XslControlRenderingType Constructor

XslControlRenderingType Constructor
Namespaces ► Sitecore.Web.UI ► XslControlRenderingType ► XslControlRenderingType()()()
Initializes a new instance of the XslControlRenderingType class
Declaration Syntax
C#
public XslControlRenderingType()


GetAttributes Method (properties, attributes)

GetAttributes Method (properties, attributes)
Namespaces ► Sitecore.Web.UI ► XslControlRenderingType ► GetAttributes(NameValueCollection, NameValueCollection)
Gets the attributes.
Declaration Syntax
C#
public override void GetAttributes(
    NameValueCollection properties,
    NameValueCollection attributes
)
Parameters
properties (NameValueCollection)
The properties.
attributes (NameValueCollection)
The attributes.


GetControl Method (parameters, assert)

GetControl Method (parameters, assert)
Namespaces ► Sitecore.Web.UI ► XslControlRenderingType ► GetControl(NameValueCollection, Boolean)
Gets the control.
Declaration Syntax
C#
public override Control GetControl(
    NameValueCollection parameters,
    bool assert
)
Parameters
parameters (NameValueCollection)
The parameters.
assert (Boolean)
if set to true this instance performs asserts.
Return Value
The created control.


Sitecore.Web.UI.Framework.Scripts Namespace

Sitecore.Web.UI.Framework.Scripts Namespace
Namespaces ► Sitecore.Web.UI.Framework.Scripts
Declaration Syntax
C#
namespace Sitecore.Web.UI.Framework.Scripts
Types
All Types Classes
Icon | Type | Description
 | ShowEditorTab | Creates a new editor tab or focuses on the existing one.


ShowEditorTab Class

ShowEditorTab Class
Namespaces ► Sitecore.Web.UI.Framework.Scripts ► ShowEditorTab
Creates a new editor tab or focuses on the existing one.
Declaration Syntax
C#
public class ShowEditorTab : ScriptMethodBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShowEditorTab()()() | Initializes a new instance of the ShowEditorTab class.
 | Activate | Gets or sets a value indicating whether this ShowEditorTab is activate.
 | Builder | Gets or sets the builder. (Inherited from ScriptMethodBase.)
 | Closeable | Gets or sets a value indicating whether this ShowEditorTab is closeable.
 | Command | Gets or sets the command.
 | DoPopulate(ScriptInvokationBuilder) | Returns a String that represents the current Object. (Overrides ScriptMethodBase.DoPopulate(ScriptInvokationBuilder).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Header | Gets or sets the header.
 | Icon | Gets or sets the icon.
 | Id | Gets or sets the id.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Object | Gets or sets the object.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from ScriptMethodBase.)
 | Url | Gets or sets the URL.
Inheritance Hierarchy
Object
 | ScriptMethodBase
 |  | ShowEditorTab


ShowEditorTab Constructor

ShowEditorTab Constructor
Namespaces ► Sitecore.Web.UI.Framework.Scripts ► ShowEditorTab ► ShowEditorTab()()()
Initializes a new instance of the ShowEditorTab class.
Declaration Syntax
C#
public ShowEditorTab()


Activate Property

Activate Property
Namespaces ► Sitecore.Web.UI.Framework.Scripts ► ShowEditorTab ► Activate
Gets or sets a value indicating whether this ShowEditorTab is activate.
Declaration Syntax
C#
public bool Activate { get; set; }
Value
true if activate; otherwise, false.


Closeable Property

Closeable Property
Namespaces ► Sitecore.Web.UI.Framework.Scripts ► ShowEditorTab ► Closeable
Gets or sets a value indicating whether this ShowEditorTab is closeable.
Declaration Syntax
C#
public bool Closeable { get; set; }
Value
true if closeable; otherwise, false.


Command Property

Command Property
Namespaces ► Sitecore.Web.UI.Framework.Scripts ► ShowEditorTab ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


DoPopulate Method (builder)

DoPopulate Method (builder)
Namespaces ► Sitecore.Web.UI.Framework.Scripts ► ShowEditorTab ► DoPopulate(ScriptInvokationBuilder)
Returns a String that represents the current Object.
Declaration Syntax
C#
protected override void DoPopulate(
    ScriptInvokationBuilder builder
)
Parameters
builder (ScriptInvokationBuilder)
Return Value
A String that represents the current Object.


Header Property

Header Property
Namespaces ► Sitecore.Web.UI.Framework.Scripts ► ShowEditorTab ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Icon Property

Icon Property
Namespaces ► Sitecore.Web.UI.Framework.Scripts ► ShowEditorTab ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


Id Property

Id Property
Namespaces ► Sitecore.Web.UI.Framework.Scripts ► ShowEditorTab ► Id
Gets or sets the id.
Declaration Syntax
C#
public string Id { get; set; }
Value
The id.


Object Property

Object Property
Namespaces ► Sitecore.Web.UI.Framework.Scripts ► ShowEditorTab ► Object
Gets or sets the object.
Declaration Syntax
C#
public string Object { get; set; }
Value
The object.


Url Property

Url Property
Namespaces ► Sitecore.Web.UI.Framework.Scripts ► ShowEditorTab ► Url
Gets or sets the URL.
Declaration Syntax
C#
public string Url { get; set; }
Value
The URL.


Sitecore.Web.UI.Grids Namespace

Sitecore.Web.UI.Grids Namespace
Namespaces ► Sitecore.Web.UI.Grids
Declaration Syntax
C#
namespace Sitecore.Web.UI.Grids
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | ComponentArtGridHandler<(Of <(TElement>)>) | ComponentArtGridSource
 | GridFilter..::.FilterOperator | Operator
 | GridFilter | GridFilter
 | GridSource<(Of <(TElement>)>) | GridSource
 | GridUtil | Utility methods for Component Art Grid.
 | IGridSource<(Of <(TElement>)>) | IGridSource


ComponentArtGridHandler(TElement) Class

ComponentArtGridHandler<(Of <(TElement>)>) Class
Namespaces ► Sitecore.Web.UI.Grids ► ComponentArtGridHandler<(Of <(TElement>)>)
ComponentArtGridSource
Declaration Syntax
C#
public class ComponentArtGridHandler<TElement>
Generic Template Parameters
TElement
The type of the element.
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ComponentArtGridHandler<(Of <(TElement>)>)(Grid, IGridSource<(Of <(TElement>)>), Boolean) | Initializes a new instance of the ComponentArtGridHandler<(Of <(TElement>)>) class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Manage(Grid, IGridSource<(Of <(TElement>)>), Boolean) | Binds the specified grid.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ComponentArtGridHandler<(Of <(TElement>)>)


ComponentArtGridHandler(TElement) Constructor (grid, source, dataBind)

ComponentArtGridHandler<(Of <(TElement>)>) Constructor (grid, source, dataBind)
Namespaces ► Sitecore.Web.UI.Grids ► ComponentArtGridHandler<(Of <(TElement>)>) ► ComponentArtGridHandler<(Of <(TElement>)>)(Grid, IGridSource<(Of <(TElement>)>), Boolean)
Initializes a new instance of the ComponentArtGridHandler<(Of <(TElement>)>) class.
Declaration Syntax
C#
public ComponentArtGridHandler(
    Grid grid,
    IGridSource<TElement> source,
    bool dataBind
)
Parameters
grid (Grid)
The grid.
source (IGridSource <(Of <( TElement >)>))
The source.
dataBind (Boolean)
if set to true, data binding will be performed immediately.


Manage Method (grid, source, dataBind)

Manage Method (grid, source, dataBind)
Namespaces ► Sitecore.Web.UI.Grids ► ComponentArtGridHandler<(Of <(TElement>)>) ► Manage(Grid, IGridSource<(Of <(TElement>)>), Boolean)
Binds the specified grid.
Declaration Syntax
C#
public static void Manage(
    Grid grid,
    IGridSource<TElement> source,
    bool dataBind
)
Parameters
grid (Grid)
The grid.
source (IGridSource <(Of <( TElement >)>))
The source.
dataBind (Boolean)
if set to true, data binding will be performed immediately.


GridFilter Class

GridFilter Class
Namespaces ► Sitecore.Web.UI.Grids ► GridFilter
GridFilter
Declaration Syntax
C#
public class GridFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GridFilter(String, String, GridFilter..::.FilterOperator) | Initializes a new instance of the GridFilter class.
 | Criteria | Gets the criteria.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldName | Gets the name of the field.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Operator | Gets the operator.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GridFilter


GridFilter Constructor (fieldName, criteria, operator)

GridFilter Constructor (fieldName, criteria, operator)
Namespaces ► Sitecore.Web.UI.Grids ► GridFilter ► GridFilter(String, String, GridFilter..::.FilterOperator)
Initializes a new instance of the GridFilter class.
Declaration Syntax
C#
public GridFilter(
    string fieldName,
    string criteria,
    GridFilter..::.FilterOperator operator
)
Parameters
fieldName (String)
Name of the field.
criteria (String)
The criteria.
operator (GridFilter..::.FilterOperator)
The @operator.


Criteria Property

Criteria Property
Namespaces ► Sitecore.Web.UI.Grids ► GridFilter ► Criteria
Gets the criteria.
Declaration Syntax
C#
public string Criteria { get; }
Value
The criteria.


FieldName Property

FieldName Property
Namespaces ► Sitecore.Web.UI.Grids ► GridFilter ► FieldName
Gets the name of the field.
Declaration Syntax
C#
public string FieldName { get; }
Value
The name of the field.


Operator Property

Operator Property
Namespaces ► Sitecore.Web.UI.Grids ► GridFilter ► Operator
Gets the operator.
Declaration Syntax
C#
public GridFilter..::.FilterOperator Operator { get; }
Value
The operator.


GridFilter.FilterOperator Enumeration

GridFilter..::.FilterOperator Enumeration
Namespaces ► Sitecore.Web.UI.Grids ► GridFilter ► GridFilter..::.FilterOperator
Operator
Declaration Syntax
C#
public enum FilterOperator
Members
Member | Description
Contains |


GridSource(TElement) Class

GridSource<(Of <(TElement>)>) Class
Namespaces ► Sitecore.Web.UI.Grids ► GridSource<(Of <(TElement>)>)
GridSource
Declaration Syntax
C#
public class GridSource<TElement> : IGridSource<TElement>
Generic Template Parameters
TElement
The type of the element.
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GridSource<(Of <(TElement>)>)(IPageable<(Of <(TElement>)>)) | Initializes a new instance of the GridSource<(Of <(TElement>)>) class.
 | GridSource<(Of <(TElement>)>)(IEnumerable<(Of <(TElement>)>)) | Initializes a new instance of the GridSource<(Of <(TElement>)>) class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Filter(IList<(Of <(GridFilter>)>)) | Filters the entries.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEntries(Int32, Int32) | Gets the entries.
 | GetEntryCount()()() | Gets the number of entries.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Sort(IList<(Of <(SortCriteria>)>)) | Sorts using the specified field name.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GridSource<(Of <(TElement>)>)


GridSource(TElement) Constructor

GridSource<(Of <(TElement>)>) Constructor
Namespaces ► Sitecore.Web.UI.Grids ► GridSource<(Of <(TElement>)>) ► GridSource<(Of <(TElement>)>)()()()
Members
Icon | Member | Description
 | GridSource<(Of <(TElement>)>)(IPageable<(Of <(TElement>)>)) | Initializes a new instance of the GridSource<(Of <(TElement>)>) class.
 | GridSource<(Of <(TElement>)>)(IEnumerable<(Of <(TElement>)>)) | Initializes a new instance of the GridSource<(Of <(TElement>)>) class.


GridSource(TElement) Constructor (elements)

GridSource<(Of <(TElement>)>) Constructor (elements)
Namespaces ► Sitecore.Web.UI.Grids ► GridSource<(Of <(TElement>)>) ► GridSource<(Of <(TElement>)>)(IPageable<(Of <(TElement>)>))
Initializes a new instance of the GridSource<(Of <(TElement>)>) class.
Declaration Syntax
C#
public GridSource(
    IPageable<TElement> elements
)
Parameters
elements (IPageable <(Of <( TElement >)>))
The entries.


GridSource(TElement) Constructor (elements)

GridSource<(Of <(TElement>)>) Constructor (elements)
Namespaces ► Sitecore.Web.UI.Grids ► GridSource<(Of <(TElement>)>) ► GridSource<(Of <(TElement>)>)(IEnumerable<(Of <(TElement>)>))
Initializes a new instance of the GridSource<(Of <(TElement>)>) class.
Declaration Syntax
C#
public GridSource(
    IEnumerable<TElement> elements
)
Parameters
elements (IEnumerable<(Of <( TElement >)>))
The entries.


Filter Method (filters)

Filter Method (filters)
Namespaces ► Sitecore.Web.UI.Grids ► GridSource<(Of <(TElement>)>) ► Filter(IList<(Of <(GridFilter>)>))
Filters the entries.
Declaration Syntax
C#
public void Filter(
    IList<GridFilter> filters
)
Parameters
filters (IList<(Of <( GridFilter >)>))
The filters.


GetEntries Method (pageIndex, pageSize)

GetEntries Method (pageIndex, pageSize)
Namespaces ► Sitecore.Web.UI.Grids ► GridSource<(Of <(TElement>)>) ► GetEntries(Int32, Int32)
Gets the entries.
Declaration Syntax
C#
public IEnumerable<TElement> GetEntries(
    int pageIndex,
    int pageSize
)
Parameters
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
Return Value


GetEntryCount Method

GetEntryCount Method
Namespaces ► Sitecore.Web.UI.Grids ► GridSource<(Of <(TElement>)>) ► GetEntryCount()()()
Gets the number of entries.
Declaration Syntax
C#
public int GetEntryCount()
Return Value


Sort Method (sorting)

Sort Method (sorting)
Namespaces ► Sitecore.Web.UI.Grids ► GridSource<(Of <(TElement>)>) ► Sort(IList<(Of <(SortCriteria>)>))
Sorts using the specified field name.
Declaration Syntax
C#
public void Sort(
    IList<SortCriteria> sorting
)
Parameters
sorting (IList<(Of <( SortCriteria >)>))
The sorting.


GridUtil Class

GridUtil Class
Namespaces ► Sitecore.Web.UI.Grids ► GridUtil
Utility methods for Component Art Grid.
Declaration Syntax
C#
public static class GridUtil
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetSelectedValue(String) | Gets the selected value.
Inheritance Hierarchy
Object
GridUtil


GetSelectedValue Method (gridID)

GetSelectedValue Method (gridID)
Namespaces ► Sitecore.Web.UI.Grids ► GridUtil ► GetSelectedValue(String)
Gets the selected value.
Declaration Syntax
C#
public static string GetSelectedValue(
    string gridID
)
Parameters
gridID (String)
The grid ID.
Return Value
The selected value.


IGridSource(TElement) Interface

IGridSource<(Of <(TElement>)>) Interface
Namespaces ► Sitecore.Web.UI.Grids ► IGridSource<(Of <(TElement>)>)
IGridSource
Declaration Syntax
C#
public interface IGridSource<TElement>
Generic Template Parameters
TElement
The type of the element.
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Filter(IList<(Of <(GridFilter>)>)) | Filters the entries.
 | GetEntries(Int32, Int32) | Gets the entries.
 | GetEntryCount()()() | Gets the number of entries.
 | Sort(IList<(Of <(SortCriteria>)>)) | Sorts using the specified field name.


Filter Method (filters)

Filter Method (filters)
Namespaces ► Sitecore.Web.UI.Grids ► IGridSource<(Of <(TElement>)>) ► Filter(IList<(Of <(GridFilter>)>))
Filters the entries.
Declaration Syntax
C#
void Filter(
    IList<GridFilter> filters
)
Parameters
filters (IList<(Of <( GridFilter >)>))
The filters.


GetEntries Method (pageIndex, pageSize)

GetEntries Method (pageIndex, pageSize)
Namespaces ► Sitecore.Web.UI.Grids ► IGridSource<(Of <(TElement>)>) ► GetEntries(Int32, Int32)
Gets the entries.
Declaration Syntax
C#
IEnumerable<TElement> GetEntries(
    int pageIndex,
    int pageSize
)
Parameters
pageIndex (Int32)
Index of the page.
pageSize (Int32)
Size of the page.
Return Value


GetEntryCount Method

GetEntryCount Method
Namespaces ► Sitecore.Web.UI.Grids ► IGridSource<(Of <(TElement>)>) ► GetEntryCount()()()
Gets the number of entries.
Declaration Syntax
C#
int GetEntryCount()
Return Value


Sort Method (sorting)

Sort Method (sorting)
Namespaces ► Sitecore.Web.UI.Grids ► IGridSource<(Of <(TElement>)>) ► Sort(IList<(Of <(SortCriteria>)>))
Sorts using the specified field name.
Declaration Syntax
C#
void Sort(
    IList<SortCriteria> sorting
)
Parameters
sorting (IList<(Of <( SortCriteria >)>))
The sorting.


Sitecore.Web.UI.HtmlControls Namespace

Sitecore.Web.UI.HtmlControls Namespace
Namespaces ► Sitecore.Web.UI.HtmlControls
Declaration Syntax
C#
namespace Sitecore.Web.UI.HtmlControls
Types
All Types Classes Interfaces Enumerations Delegates
Icon | Type | Description
 | Action | Represents an action.
 | Action..::.ActionChangedDelegate | Called when the action is changed.
 | AutoToolmenu | Represents a toolmenu that is generated from an item specified on the querystring.
 | AutoToolmenubutton | Represents a toolbutton that opens a menu from an item specified on the querystring.
 | Bevel | Represens a Bevel.
 | BevelType | Type of bevel.
 | Border | Represents a panel.
 | Button | Represents a button.
 | Checkbox | Represents a checkbox.
 | Checklist | Represents a list of checkboxes.
 | ChecklistItem | Represents an item in a checklist.
 | ClientCommand |
 | ClientCommands | Holds a collection of ClientCommand.
 | CodeBeside | Specifies the CodeBeside object for a Sheer UI page.
 | Combobox | Represents a combobox.
 | ComboboxBase | Defines the basic properties and functionality of a Combobox.
 | Combobutton | Represents a toolbuton with a drop down glyph.
 | ComboEdit | Represents an editable combobox.
 | Component | Serves as the base class that defines the methods, properties and events common to all controls in the Sitecore.Web.UI.HtmlControls namespace.
 | ContextMenu | Represents a context menu.
 | Control | Serves as the base class that defines the methods, properties and events common to all controls in the Sitecore.Web.UI.HtmlControls namespace.
 | ControlLiteral |
 | DataCheckbox | Represents a data-aware checkbox.
 | DataContext | Represents a data context.
 | DataContext..::.DataContextChangedDelegate |
 | DataContextMenu | Represents
 | DataEdit | Represents a data-aware edit box.
 | DataListview | Represents a listview that pulls its items from a data context.
 | DataListviewItem | Represents an item in a listview.
 | DataMemo | Represents a data-aware memo field.
 | DataToolbar | Represents a toolbar that is generated from a data source.
 | DataToolbutton | Represents a toolbutton that loads its data from a data source.
 | DataToolmenu | Represents a toolmenu that loads its items from a data source.
 | DataToolmenubutton | Represents a tool menu buttons that loads its items from a data source.
 | DataTreecrumb | Represents a treecrumb.
 | DataTreeNode | Represents a node in a treeview.
 | DataTreeview | Displays hierarchical data, such as a table of contents, in a tree structure.
 | DataViewBase |
 | DateCalendar | Represents a data aware calendar.
 | DateCalendarPopup | Represents a data-aware popup calendar.
 | DatePicker | Represents a Date picker.
 | DateTimePicker | Represents a Date time picker.
 | DomainDataView | Represents a DomainDataView.
 | Dropbutton | Represents a toolbutton that shows a popup.
 | Edit |
 | FileSystemDataView | Represents a File System data view.
 | Frame | Represents an IFrame Html tag.
 | GalleryMenu | Represents a menu in a gallery from the ribbon.
 | Groupbox | Represents a groupbox.
 | Head | Represents a menu in a gallery from the ribbon.
 | HeaderedItemsControl | Serves as the base class that defines the header and style common to all controls that have a header.
 | IDataView |
 | Image | Represents an image.
 | ImageButton | Represents a clickable image.
 | Inline | Represents a Span tag.
 | Input | Defines the basic properties and functionality of an input control.
 | IReportFormatter | Represents a report formatter.
 | IReportSource | Represents a report source.
 | DataContext..::.ItemEventDelegate |
 | KeyMap |
 | Label | Represents a label.
 | Listbox | Represents a Listbox.
 | ListboxItem | Represents an item in a listbox.
 | ListItem | Represents an item in a list control.
 | Listview | Represents a listview.
 | ListviewHeader | Represents a header in a listview control.
 | ListviewHeaderItem | Represents an item in a listview header.
 | ListviewItem | Represents an item in a list view.
 | ListviewNavigator | Obsolete. Represents a pager in a list view control.
 | Listview..::.ListviewViewChangedDelegate | Called when the view is changed.
 | Literal | Represents a literal text.
 | MasterDataView | Represents the data view of the master database.
 | Memo | Represents a memo field.
 | Menu | Represents a menu.
 | Menubar | Represents a top menu bar.
 | MenubarItem | Represents an item in a menu bar.
 | MenuDivider | Represents a divider in a menu.
 | MenuHeader | Represents a menu header.
 | MenuItem | Represents an item in a menu.
 | MenuItemType | Specifies the type of menu item.
 | MenuLine | Represents a line in a menu.
 | MenuPanel | Represents a panel for containing subcontrols in a menu.
 | Navigator | Represents a Navigator that enables paging.
 | Navigator..::.NavigatorDelegate |
 | Page | Represents an .aspx file, also known as a Web Forms page, requested from a server that hosts an ASP.NET Web application.
 | PageScriptManager | Represents an .aspx file, also known as a Web Forms page, requested from a server that hosts an ASP.NET Web application.
 | Panel | Represents a panel.
 | Popup | Represents a control thar can popup.
 | PropertyCollection | Represents a collection of properties.
 | QuickFind |
 | Radiobutton | Represents a radio button.
 | Radiogroup | Represents a radio group.
 | RadioItem | Represents an item in a radio group.
 | RecycleBinDataView | Represents the Recycle Bin data view.
 | RegisterKey | Makes a registration in the KeyMap collection.
 | Registry | Implements a store for keeping name/value pairs for each user.
 | RenderItem | Renders the item.
 | RenderList | Renders a list of items.
 | RenderLiteral | Renders a control as a literal.
 | Reporter | Builds a report from a source and a formatter.
 | ReportFileSource | Represents a file reporter source.
 | ReportXslFormatter | Represents a Xslt reporter formatter.
 | Script | Represents a script block.
 | ScriptFile | Script file.
 | Scrollbox | Represents a panel with scrollbars.
 | Scroller | Represents a panel with small scroll arrows.
 | Section | Represents a Section control.
 | Space | Represents a spacer image.
 | StandardTreeDataView | Represents a Standard Tree Data View.
 | Stylesheet | Represents a style block.
 | StylesheetFile | Script file.
 | SubmittableEdit | Represents an Edit box that submits if the Enter key is pressed.
 | Tab | Represents a tab in a tabstrip.
 | TabSection | A tab section.
 | Tabstrip | Represents a tab strip.
 | Tag | HTML tag builder
 | TagBuilder | Obsolete. HTML tag builder
 | Taskbox | Obsolete. Implements a task box.
 | TaskboxItem | Obsolete. Represents an item in a taskbox.
 | TaskboxItems | Obsolete. Represents a list of options.
 | TemplateFilteredDataContext | Represents a template filtered data context.
 | ThemedImage | Represents an image with a themed source.
 | TimePicker | Represents a time picker.
 | TimePickerPopup | Time picker
 | Toolbar | Represents a toolbar.
 | Toolbutton | Represents a clickable button on a toolbar.
 | Tooldivider | Represents a divider in a toolbar.
 | Toolmenu | Represents a toolbutton with a drop down menu.
 | Toolmenubutton | Represents a toolbutton that shows a toolmenu.
 | Treecrumb | Represents a treecrumb.
 | TreecrumbNode | Represents a node in a treecrumb.
 | TreeHeader | Represents a header in a treeview.
 | TreeHeaderItem | Represents an item in the header of a treeview.
 | TreeNode | Represents a node in a treeview.
 | TreePicker | Represents a combobox with treeview dropdown.
 | Treeview | Represents a treeview.
 | TreeviewNavigator | Represents a navigator in a treeview.
 | UpAction | Represents an action that controls the Up action in a DataContext.
 | UserControlRenderer | Renders a user control.
 | VerticalTabstrip | A tabstrip with tabs organized vertically.
 | WebPanel | Represents a panel.
 | Xsl |


Action Class

Action Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action
Represents an action.
Declaration Syntax
C#
public class Action : HeaderedItemsControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Action()()() | Initializes a new instance of the Action class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Changed | Called when the action is changed.
 | Checked | Gets or sets a value indicating whether this Action is checked.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the Double Click event.
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Overrides Control.Disabled.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Overrides HeaderedItemsControl.Header.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChanged()()() | Called when this instance has changed.
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | Root | Gets or sets the root.
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Overrides WebControl.ToolTip.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Overrides Control.Visible.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Action
 |  |  |  |  |  |  |  | UpAction


Action Constructor

Action Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action ► Action()()()
Initializes a new instance of the Action class.
Declaration Syntax
C#
public Action()


Changed Event

Changed Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action ► Changed
Called when the action is changed.
Declaration Syntax
C#
public event Action..::.ActionChangedDelegate Changed


Checked Property

Checked Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action ► Checked
Gets or sets a value indicating whether this Action is checked.
Declaration Syntax
C#
public bool Checked { get; set; }
Value
true if checked; otherwise, false.


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action ► Click
Gets or sets the Click event.
Declaration Syntax
C#
public string Click { get; set; }
Value
The event to be executed.


DblClick Property

DblClick Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action ► DblClick
Gets or sets the Double Click event.
Declaration Syntax
C#
public string DblClick { get; set; }
Value
The event to be executed.


Disabled Property

Disabled Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action ► Disabled
Gets or sets a value indicating whether this Control is disabled.
Declaration Syntax
C#
public override bool Disabled { get; set; }
Value
true if disabled; otherwise, false.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Header Property

Header Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action ► Header
Gets or sets the header.
Declaration Syntax
C#
public override string Header { get; set; }
Value
The header.


Icon Property

Icon Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


OnChanged Method

OnChanged Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action ► OnChanged()()()
Called when this instance has changed.
Declaration Syntax
C#
protected virtual void OnChanged()


Root Property

Root Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action ► Root
Gets or sets the root.
Declaration Syntax
C#
public string Root { get; set; }
Value
The root.


ToolTip Property

ToolTip Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action ► ToolTip
Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Declaration Syntax
C#
public override string ToolTip { get; set; }
Value
Return Value
The text displayed when the mouse pointer hovers over the Web server control. The default is Empty()()().


Visible Property

Visible Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action ► Visible
Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Declaration Syntax
C#
public override bool Visible { get; set; }
Value
Return Value
true if the control is visible on the page; otherwise false.


Action.ActionChangedDelegate Delegate

Action..::.ActionChangedDelegate Delegate
Namespaces ► Sitecore.Web.UI.HtmlControls ► Action ► Action..::.ActionChangedDelegate
Called when the action is changed.
Declaration Syntax
C#
public delegate void ActionChangedDelegate(
    Object sender
)
Parameters
sender (Object)


AutoToolmenu Class

AutoToolmenu Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► AutoToolmenu
Represents a toolmenu that is generated from an item specified on the querystring.
Declaration Syntax
C#
public class AutoToolmenu : DataToolmenu
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AutoToolmenu()()() | Initializes a new instance of the AutoToolmenu class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddItems(Menu) | Adds the items. (Inherited from DataToolmenu.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the click. (Inherited from Button.)
 | ClickButton()()() | Clicks the button. (Inherited from Button.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click. (Inherited from Button.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Toolbutton.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from Toolmenubutton.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Toolbutton.)
 | Down | Gets or sets a value indicating whether this Toolbutton is down. (Inherited from Toolbutton.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | Glyph | Gets or sets the glyph. (Inherited from Toolbutton.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon. (Inherited from Toolbutton.)
 | IconSize | Gets or sets the size of the icon. (Inherited from Toolbutton.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code. (Inherited from Button.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadFromItem(Item) | Loads data from an item. (Inherited from Toolbutton.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | (Inherited from Button.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Toolmenubutton.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Toolmenubutton.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PopupControl | Gets or sets the popup control. (Inherited from Dropbutton.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RadioGroup | Gets or sets the radio group. (Inherited from Toolbutton.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | Target | Gets or sets the target. (Inherited from DataToolmenu.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle | Gets or sets a value indicating whether this Toolbutton is a toggle button. (Inherited from Toolbutton.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Button
 |  |  |  |  |  |  |  | Toolbutton
 |  |  |  |  |  |  |  |  | Dropbutton
 |  |  |  |  |  |  |  |  |  | Toolmenubutton
 |  |  |  |  |  |  |  |  |  |  | Toolmenu
 |  |  |  |  |  |  |  |  |  |  |  | DataToolmenu
 |  |  |  |  |  |  |  |  |  |  |  |  | AutoToolmenu


AutoToolmenu Constructor

AutoToolmenu Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► AutoToolmenu ► AutoToolmenu()()()
Initializes a new instance of the AutoToolmenu class.
Declaration Syntax
C#
public AutoToolmenu()


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► AutoToolmenu ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


AutoToolmenubutton Class

AutoToolmenubutton Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► AutoToolmenubutton
Represents a toolbutton that opens a menu from an item specified on the querystring.
Declaration Syntax
C#
public class AutoToolmenubutton : DataToolmenubutton
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AutoToolmenubutton()()() | Initializes a new instance of the AutoToolmenubutton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddItems(Menu) | Adds the items. (Inherited from DataToolmenubutton.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the click. (Inherited from Button.)
 | ClickButton()()() | Clicks the button. (Inherited from Button.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click. (Inherited from Button.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Toolbutton.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from Toolmenubutton.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Toolbutton.)
 | Down | Gets or sets a value indicating whether this Toolbutton is down. (Inherited from Toolbutton.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | Glyph | Gets or sets the glyph. (Inherited from Toolbutton.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon. (Inherited from Toolbutton.)
 | IconSize | Gets or sets the size of the icon. (Inherited from Toolbutton.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code. (Inherited from Button.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadFromItem(Item) | Loads data from an item. (Inherited from Toolbutton.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | (Inherited from Button.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Toolmenubutton.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Toolmenubutton.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PopupControl | Gets or sets the popup control. (Inherited from Dropbutton.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RadioGroup | Gets or sets the radio group. (Inherited from Toolbutton.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | Target | Gets or sets the target. (Inherited from DataToolmenubutton.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle | Gets or sets a value indicating whether this Toolbutton is a toggle button. (Inherited from Toolbutton.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Button
 |  |  |  |  |  |  |  | Toolbutton
 |  |  |  |  |  |  |  |  | Dropbutton
 |  |  |  |  |  |  |  |  |  | Toolmenubutton
 |  |  |  |  |  |  |  |  |  |  | DataToolmenubutton
 |  |  |  |  |  |  |  |  |  |  |  | AutoToolmenubutton


AutoToolmenubutton Constructor

AutoToolmenubutton Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► AutoToolmenubutton ► AutoToolmenubutton()()()
Initializes a new instance of the AutoToolmenubutton class
Declaration Syntax
C#
public AutoToolmenubutton()


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► AutoToolmenubutton ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


Bevel Class

Bevel Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Bevel
Represens a Bevel.
Declaration Syntax
C#
public class Bevel : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Bevel()()() | Initializes a new instance of the Bevel class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | Type | Gets or sets the type.
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Bevel


Bevel Constructor

Bevel Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Bevel ► Bevel()()()
Initializes a new instance of the Bevel class
Declaration Syntax
C#
public Bevel()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Bevel ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Type Property

Type Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Bevel ► Type
Gets or sets the type.
Declaration Syntax
C#
public virtual BevelType Type { get; set; }
Value
The type.


BevelType Enumeration

BevelType Enumeration
Namespaces ► Sitecore.Web.UI.HtmlControls ► BevelType
Type of bevel.
Declaration Syntax
C#
public enum BevelType
Members
Member | Description
VerticalLine | Vertical line.
HorizontalLine | Horizontal line.
RaisedBox | Raised box.
LoweredBox | Lowered box.


Border Class

Border Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border
Represents a panel.
Declaration Syntax
C#
public class Border : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Border()()() | Initializes a new instance of the Border class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the click.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click.
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event.
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the DblClick event.
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Overrides Component.DoRender(HtmlTextWriter).)
 | Drag | Gets or sets the drag event.
 | DragOverCursor | Gets or sets the drag over cursor.
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event.
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Overrides WebControl.Height.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InnerHtml | Gets or sets the inner HTML.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the control is clicked.
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDblClick | Called when the control is double clicked.
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Overrides WebControl.Width.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Border
 |  |  |  |  |  |  | DateTimePicker
 |  |  |  |  |  |  | QuickFind


Border Constructor

Border Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border ► Border()()()
Initializes a new instance of the Border class
Declaration Syntax
C#
public Border()


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border ► Click
Gets or sets the click.
Declaration Syntax
C#
public string Click { get; set; }
Value
The click.


DblClick Property

DblClick Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border ► DblClick
Gets or sets the double click.
Declaration Syntax
C#
public string DblClick { get; set; }
Value
The double click.


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected virtual void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DoDblclick Method (message)

DoDblclick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border ► DoDblclick(Message)
Executes the DblClick event.
Declaration Syntax
C#
protected virtual void DoDblclick(
    Message message
)
Parameters
message (Message)
The message.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border ► DoRender(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


Drag Property

Drag Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border ► Drag
Gets or sets the drag event.
Declaration Syntax
C#
public string Drag { get; set; }
Value
The drag event.


DragOverCursor Property

DragOverCursor Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border ► DragOverCursor
Gets or sets the drag over cursor.
Declaration Syntax
C#
public string DragOverCursor { get; set; }
Value
The drag over cursor.


Drop Property

Drop Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border ► Drop
Gets or sets the drop event.
Declaration Syntax
C#
public string Drop { get; set; }
Value
The drop event.


Height Property

Height Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border ► Height
Gets or sets the height of the Web server control.
Declaration Syntax
C#
public override Unit Height { get; set; }
Value
Return Value
A Unit that represents the height of the control. The default is Empty.
Exceptions
Exception | Condition
ArgumentException | The height was set to a negative value.


InnerHtml Property

InnerHtml Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border ► InnerHtml
Gets or sets the inner HTML.
Declaration Syntax
C#
public string InnerHtml { get; set; }
Value
The inner HTML.


OnClick Event

OnClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border ► OnClick
Called when the control is clicked.
Declaration Syntax
C#
public event EventHandler OnClick


OnDblClick Event

OnDblClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border ► OnDblClick
Called when the control is double clicked.
Declaration Syntax
C#
public event EventHandler OnDblClick


Width Property

Width Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Border ► Width
Gets or sets the width of the Web server control.
Declaration Syntax
C#
public override Unit Width { get; set; }
Value
Return Value
A Unit that represents the width of the control. The default is Empty.
Exceptions
Exception | Condition
ArgumentException | The width of the Web server control was set to a negative value.


Button Class

Button Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Button
Represents a button.
Declaration Syntax
C#
public class Button : HeaderedItemsControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Button()()() | Initializes a new instance of the Button class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the click.
 | ClickButton()()() | Clicks the button.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click.
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event.
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code.
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick |
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Button
 |  |  |  |  |  |  |  | Toolbutton


Button Constructor

Button Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Button ► Button()()()
Initializes a new instance of the Button class.
Declaration Syntax
C#
public Button()


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Button ► Click
Gets or sets the click.
Declaration Syntax
C#
public string Click { get; set; }
Value
The click.


ClickButton Method

ClickButton Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Button ► ClickButton()()()
Clicks the button.
Declaration Syntax
C#
protected void ClickButton()


DblClick Property

DblClick Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Button ► DblClick
Gets or sets the double click.
Declaration Syntax
C#
public string DblClick { get; set; }
Value
The double click.


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Button ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected virtual void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Button ► DoRender(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Button ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


OnClick Event

OnClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Button ► OnClick
Declaration Syntax
C#
public event EventHandler OnClick


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Button ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


Checkbox Class

Checkbox Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox
Represents a checkbox.
Declaration Syntax
C#
public class Checkbox : Input
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Checkbox()()() | Initializes a new instance of the Checkbox class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event. (Inherited from Input.)
 | Checked | Gets or sets a value indicating whether this Checkbox is checked.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Executes the Change event. (Overrides Input.DoChange(Message).)
 | DoClick(Message) | Executes the click event.
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | HeaderStyle | Gets or sets the header CSS style.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Overrides Component.LoadPostData(String).)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Overrides Component.LoadPostData(String, NameValueCollection).)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange | Called when the input is changed by the user. (Inherited from Input.)
 | OnClick |
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether this instance is read only. (Inherited from Input.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag. (Inherited from Input.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether modifications are tracked. (Inherited from Input.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Overrides Control.Value.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Input
 |  |  |  |  |  |  | Checkbox
 |  |  |  |  |  |  |  | DataCheckbox


Checkbox Constructor

Checkbox Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► Checkbox()()()
Initializes a new instance of the Checkbox class.
Declaration Syntax
C#
public Checkbox()


Checked Property

Checked Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► Checked
Gets or sets a value indicating whether this Checkbox is checked.
Declaration Syntax
C#
public bool Checked { get; set; }
Value
true if checked; otherwise, false.


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► Click
Gets or sets the click event.
Declaration Syntax
C#
public string Click { get; set; }
Value
The click event.


DoChange Method (message)

DoChange Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► DoChange(Message)
Executes the Change event.
Declaration Syntax
C#
protected override void DoChange(
    Message message
)
Parameters
message (Message)
The message.


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected virtual void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► DoRender(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


Header Property

Header Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► Header
Gets or sets the header.
Declaration Syntax
C#
public virtual string Header { get; set; }
Value
The header.


HeaderStyle Property

HeaderStyle Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► HeaderStyle
Gets or sets the header CSS style.
Declaration Syntax
C#
public virtual string HeaderStyle { get; set; }
Value
The header CSS style.


LoadPostData Method

LoadPostData Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► LoadPostData()()()
Members
Icon | Member | Description
 | LoadPostData(String) | Loads the post data. (Overrides Component.LoadPostData(String).)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Overrides Component.LoadPostData(String, NameValueCollection).)


LoadPostData Method (value)

LoadPostData Method (value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► LoadPostData(String)
Loads the post data.
Declaration Syntax
C#
protected override bool LoadPostData(
    string value
)
Parameters
value (String)
The value.
Return Value


LoadPostData Method (postDataKey, postCollection)

LoadPostData Method (postDataKey, postCollection)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► LoadPostData(String, NameValueCollection)
When implemented by a class, processes postback data for an ASP.NET server control.
Declaration Syntax
C#
public override bool LoadPostData(
    string postDataKey,
    NameValueCollection postCollection
)
Parameters
postDataKey (String)
The key identifier for the control.
postCollection (NameValueCollection)
The collection of all incoming name values.
Return Value
true if the server control's state changes as a result of the postback; otherwise, false.


OnClick Event

OnClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► OnClick
Declaration Syntax
C#
public event EventHandler OnClick


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


Value Property

Value Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checkbox ► Value
Gets or sets the value.
Declaration Syntax
C#
public override string Value { get; set; }
Value
The value.


Checklist Class

Checklist Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checklist
Represents a list of checkboxes.
Declaration Syntax
C#
public class Checklist : HeaderedItemsControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Checklist()()() | Initializes a new instance of the Checklist class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CheckAll()()() | Checks all chechboxes.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetItemValue(ChecklistItem) | Gets the item value.
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Invert()()() | Inverts the state of all checkboxes.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets the items.
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UncheckAll()()() | Unchecks all checkboxes.
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Checklist


Checklist Constructor

Checklist Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checklist ► Checklist()()()
Initializes a new instance of the Checklist class.
Declaration Syntax
C#
public Checklist()


CheckAll Method

CheckAll Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checklist ► CheckAll()()()
Checks all chechboxes.
Declaration Syntax
C#
public void CheckAll()


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checklist ► Click
Gets or sets the Click event.
Declaration Syntax
C#
public string Click { get; set; }
Value
The event to be executed.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checklist ► DoRender(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


GetItemValue Method (item)

GetItemValue Method (item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checklist ► GetItemValue(ChecklistItem)
Gets the item value.
Declaration Syntax
C#
protected virtual string GetItemValue(
    ChecklistItem item
)
Parameters
item (ChecklistItem)
The item.
Return Value


Invert Method

Invert Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checklist ► Invert()()()
Inverts the state of all checkboxes.
Declaration Syntax
C#
public void Invert()


Items Property

Items Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checklist ► Items
Gets the items.
Declaration Syntax
C#
public ChecklistItem[] Items { get; }
Value
The items.


UncheckAll Method

UncheckAll Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Checklist ► UncheckAll()()()
Unchecks all checkboxes.
Declaration Syntax
C#
public void UncheckAll()


ChecklistItem Class

ChecklistItem Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► ChecklistItem
Represents an item in a checklist.
Declaration Syntax
C#
public class ChecklistItem : HeaderedItemsControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChecklistItem()()() | Initializes a new instance of the ChecklistItem class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Checked | Gets or sets a value indicating whether this ChecklistItem is checked.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LineBreak | Gets or sets a value indicating whether the ChecklistItem has a following line break.
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Overrides Component.LoadPostData(String).)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | ChecklistItem


ChecklistItem Constructor

ChecklistItem Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► ChecklistItem ► ChecklistItem()()()
Initializes a new instance of the ChecklistItem class
Declaration Syntax
C#
public ChecklistItem()


Checked Property

Checked Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ChecklistItem ► Checked
Gets or sets a value indicating whether this ChecklistItem is checked.
Declaration Syntax
C#
public bool Checked { get; set; }
Value
true if checked; otherwise, false.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ChecklistItem ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


LineBreak Property

LineBreak Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ChecklistItem ► LineBreak
Gets or sets a value indicating whether the ChecklistItem has a following line break.
Declaration Syntax
C#
public bool LineBreak { get; set; }
Value
true if the ChecklistItem has a following line break; otherwise, false.


LoadPostData Method (value)

LoadPostData Method (value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ChecklistItem ► LoadPostData(String)
Loads the post data.
Declaration Syntax
C#
protected override bool LoadPostData(
    string value
)
Parameters
value (String)
The value.
Return Value


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ChecklistItem ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


ClientCommand Class

ClientCommand Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► ClientCommand
Declaration Syntax
C#
public class ClientCommand : HtmlContainerControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientCommand()()() | Initializes a new instance of the ClientCommand class.
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets a collection of all attribute name and value pairs expressed on a server control tag within the ASP.NET page. (Inherited from HtmlControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Gets or sets the command.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | (Inherited from HtmlContainerControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Disabled | Gets or sets a value indicating whether the HTML server control is disabled. (Inherited from HtmlControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from Control.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | GetAttribute(String) | Gets the value of the named attribute on the HtmlControl control. (Inherited from HtmlControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InnerHtml | Gets or sets the content found between the opening and closing tags of the specified HTML server control. (Inherited from HtmlContainerControl.)
 | InnerText | Gets or sets the text between the opening and closing tags of the specified HTML server control. (Inherited from HtmlContainerControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores the HtmlContainerControl control's view state from a previous page request that was saved by the SaveViewState()()() method. (Inherited from HtmlContainerControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the specified output. (Overrides HtmlContainerControl.Render(HtmlTextWriter).)
 | RenderAttributes(HtmlTextWriter) | (Inherited from HtmlContainerControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the opening HTML tag of the control into the specified HtmlTextWriter object. (Inherited from HtmlControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the closing tag for the HtmlContainerControl control to the specified HtmlTextWriter object. (Inherited from HtmlContainerControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SetAttribute(String, String) | Sets the value of the named attribute on the HtmlControl control. (Inherited from HtmlControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SourceControl | Gets or sets the source control.
 | Style | Gets a collection of all cascading style sheet (CSS) properties applied to a specified HTML server control in the ASP.NET file. (Inherited from HtmlControl.)
 | TagName | Gets the element name of a tag that contains a runat=server attribute and value pair. (Inherited from HtmlControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the HtmlControl view state is case-sensitive. (Inherited from HtmlControl.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlContainerControl
 |  |  |  | ClientCommand


ClientCommand Constructor

ClientCommand Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► ClientCommand ► ClientCommand()()()
Initializes a new instance of the ClientCommand class.
Declaration Syntax
C#
public ClientCommand()


Command Property

Command Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ClientCommand ► Command
Gets or sets the command.
Declaration Syntax
C#
public string Command { get; set; }
Value
The command.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ClientCommand ► Render(HtmlTextWriter)
Renders the specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


SourceControl Property

SourceControl Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ClientCommand ► SourceControl
Gets or sets the source control.
Declaration Syntax
C#
public Control SourceControl { get; set; }
Value
The source control.


ClientCommands Class

ClientCommands Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► ClientCommands
Holds a collection of ClientCommand.
Declaration Syntax
C#
public class ClientCommands : HtmlContainerControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientCommands()()() | Initializes a new instance of the ClientCommands class
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets a collection of all attribute name and value pairs expressed on a server control tag within the ASP.NET page. (Inherited from HtmlControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | (Inherited from HtmlContainerControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Disabled | Gets or sets a value indicating whether the HTML server control is disabled. (Inherited from HtmlControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from Control.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | GetAttribute(String) | Gets the value of the named attribute on the HtmlControl control. (Inherited from HtmlControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InnerHtml | Gets or sets the content found between the opening and closing tags of the specified HTML server control. (Inherited from HtmlContainerControl.)
 | InnerText | Gets or sets the text between the opening and closing tags of the specified HTML server control. (Inherited from HtmlContainerControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores the HtmlContainerControl control's view state from a previous page request that was saved by the SaveViewState()()() method. (Inherited from HtmlContainerControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the specified output. (Overrides HtmlContainerControl.Render(HtmlTextWriter).)
 | RenderAttributes(HtmlTextWriter) | (Inherited from HtmlContainerControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the opening HTML tag of the control into the specified HtmlTextWriter object. (Inherited from HtmlControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the closing tag for the HtmlContainerControl control to the specified HtmlTextWriter object. (Inherited from HtmlContainerControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SetAttribute(String, String) | Sets the value of the named attribute on the HtmlControl control. (Inherited from HtmlControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | Style | Gets a collection of all cascading style sheet (CSS) properties applied to a specified HTML server control in the ASP.NET file. (Inherited from HtmlControl.)
 | TagName | Gets the element name of a tag that contains a runat=server attribute and value pair. (Inherited from HtmlControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the HtmlControl view state is case-sensitive. (Inherited from HtmlControl.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlContainerControl
 |  |  |  | ClientCommands


ClientCommands Constructor

ClientCommands Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► ClientCommands ► ClientCommands()()()
Initializes a new instance of the ClientCommands class
Declaration Syntax
C#
public ClientCommands()


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ClientCommands ► Render(HtmlTextWriter)
Renders the specified output.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


CodeBeside Class

CodeBeside Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► CodeBeside
Specifies the CodeBeside object for a Sheer UI page.
Declaration Syntax
C#
public class CodeBeside : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CodeBeside()()() | Initializes a new instance of the CodeBeside class
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from Control.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | FrameName | Gets or sets the name of the frame.
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Overrides Control.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Control.Render(HtmlTextWriter).)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | Type | Gets or sets the type.
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Inheritance Hierarchy
Object
 | Control
 |  | CodeBeside


CodeBeside Constructor

CodeBeside Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► CodeBeside ► CodeBeside()()()
Initializes a new instance of the CodeBeside class
Declaration Syntax
C#
public CodeBeside()


FrameName Property

FrameName Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► CodeBeside ► FrameName
Gets or sets the name of the frame.
Declaration Syntax
C#
public string FrameName { get; set; }
Value
The name of the frame.


OnInit Method (e)

OnInit Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► CodeBeside ► OnInit(EventArgs)
Raises the Init event.
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► CodeBeside ► Render(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Type Property

Type Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► CodeBeside ► Type
Gets or sets the type.
Declaration Syntax
C#
public string Type { get; set; }
Value
The type.


Combobox Class

Combobox Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Combobox
Represents a combobox.
Declaration Syntax
C#
public class Combobox : Listbox
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Combobox()()() | Initializes a new instance of the Combobox class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event. (Inherited from Listbox.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event. (Inherited from Listbox.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click event. (Inherited from Listbox.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Executes the change event. (Inherited from Listbox.)
 | DoClick(Message) | Executes the click event. (Inherited from Listbox.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblClick(Message) | Executes the Double Click event. (Inherited from Listbox.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Listbox.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets the items. (Inherited from Listbox.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Listbox.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Multiple | Gets or sets a value indicating whether this Listbox supports multiple selection. (Inherited from Listbox.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange | (Inherited from Listbox.)
 | OnClick | (Inherited from Listbox.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDblClick | (Inherited from Listbox.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Listbox.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Selected | Gets the selected items. (Inherited from Listbox.)
 | SelectedItem | Gets the selected item. (Inherited from Listbox.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag. (Inherited from Listbox.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | Size | Gets or sets the size. (Inherited from Listbox.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether the Listbox tracks modification. (Inherited from Listbox.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Listbox.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Listbox
 |  |  |  |  |  |  | Combobox


Combobox Constructor

Combobox Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Combobox ► Combobox()()()
Initializes a new instance of the Combobox class.
Declaration Syntax
C#
public Combobox()


ComboboxBase Class

ComboboxBase Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboboxBase
Defines the basic properties and functionality of a Combobox.
Declaration Syntax
C#
public abstract class ComboboxBase : Input
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ComboboxBase()()() | Initializes a new instance of the ComboboxBase class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event. (Inherited from Input.)
 | Changed()()() | Called when the combobox has changed.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click()()() | Handles a click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Raises the Change event. (Inherited from Input.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | DropDown()()() | Called when the dropdown glyph is clicked.
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetDisplayValue()()() | Gets the display value.
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | Glyph | Gets or sets the glyph.
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Overrides Component.LoadPostData(String).)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange | Called when the input is changed by the user. (Inherited from Input.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether this instance is read only. (Inherited from Input.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SelectOnly | Gets or sets a value indicating whether the ComboboxBase is select-only.
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag. (Inherited from Input.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether modifications are tracked. (Inherited from Input.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Overrides Control.Value.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Input
 |  |  |  |  |  |  | ComboboxBase
 |  |  |  |  |  |  |  | DatePicker
 |  |  |  |  |  |  |  | TimePicker
 |  |  |  |  |  |  |  | TreePicker


ComboboxBase Constructor

ComboboxBase Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboboxBase ► ComboboxBase()()()
Initializes a new instance of the ComboboxBase class.
Declaration Syntax
C#
protected ComboboxBase()


Changed Method

Changed Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboboxBase ► Changed()()()
Called when the combobox has changed.
Declaration Syntax
C#
protected virtual void Changed()


Click Method

Click Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboboxBase ► Click()()()
Handles a click event.
Declaration Syntax
C#
protected virtual void Click()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboboxBase ► DoRender(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


DropDown Method

DropDown Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboboxBase ► DropDown()()()
Called when the dropdown glyph is clicked.
Declaration Syntax
C#
protected virtual void DropDown()


GetDisplayValue Method

GetDisplayValue Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboboxBase ► GetDisplayValue()()()
Gets the display value.
Declaration Syntax
C#
protected virtual string GetDisplayValue()
Return Value
The value in display format.


Glyph Property

Glyph Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboboxBase ► Glyph
Gets or sets the glyph.
Declaration Syntax
C#
public string Glyph { get; set; }
Value
The glyph.


LoadPostData Method (value)

LoadPostData Method (value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboboxBase ► LoadPostData(String)
Loads the post data.
Declaration Syntax
C#
protected override bool LoadPostData(
    string value
)
Parameters
value (String)
The value.
Return Value


SelectOnly Property

SelectOnly Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboboxBase ► SelectOnly
Gets or sets a value indicating whether the ComboboxBase is select-only.
Declaration Syntax
C#
public bool SelectOnly { get; set; }
Value
true if the ComboboxBase is select-only; otherwise, false.


Value Property

Value Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboboxBase ► Value
Gets or sets the value.
Declaration Syntax
C#
public override string Value { get; set; }
Value
The value.


Combobutton Class

Combobutton Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Combobutton
Represents a toolbuton with a drop down glyph.
Declaration Syntax
C#
public class Combobutton : Toolbutton
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Combobutton()()() | Initializes a new instance of the Combobutton class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the click. (Inherited from Button.)
 | ClickButton()()() | Clicks the button. (Inherited from Button.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click. (Inherited from Button.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Toolbutton.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Overrides Button.DoClick(Message).)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Overrides Toolbutton.DoRender(HtmlTextWriter).)
 | Down | Gets or sets a value indicating whether this Toolbutton is down. (Inherited from Toolbutton.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | Glyph | Gets or sets the glyph. (Inherited from Toolbutton.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon. (Inherited from Toolbutton.)
 | IconSize | Gets or sets the size of the icon. (Inherited from Toolbutton.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code. (Inherited from Button.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadFromItem(Item) | Loads data from an item. (Inherited from Toolbutton.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | (Inherited from Button.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnDropDown |
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Button.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PopupControl | Gets or sets the popup control.
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RadioGroup | Gets or sets the radio group. (Inherited from Toolbutton.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle | Gets or sets a value indicating whether this Toolbutton is a toggle button. (Inherited from Toolbutton.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Button
 |  |  |  |  |  |  |  | Toolbutton
 |  |  |  |  |  |  |  |  | Combobutton


Combobutton Constructor

Combobutton Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Combobutton ► Combobutton()()()
Initializes a new instance of the Combobutton class.
Declaration Syntax
C#
public Combobutton()


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Combobutton ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected override void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Combobutton ► DoRender(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


OnDropDown Event

OnDropDown Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Combobutton ► OnDropDown
Declaration Syntax
C#
public event EventHandler OnDropDown


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Combobutton ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


PopupControl Property

PopupControl Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Combobutton ► PopupControl
Gets or sets the popup control.
Declaration Syntax
C#
public string PopupControl { get; set; }
Value
The popup control.


ComboEdit Class

ComboEdit Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboEdit
Represents an editable combobox.
Declaration Syntax
C#
public abstract class ComboEdit : Edit
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ComboEdit()()() | Initializes a new instance of the ComboEdit class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event. (Inherited from Input.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Raises the Change event. (Inherited from Input.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Edit.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Hidden | Gets or sets a value indicating whether this Edit is hidden. (Inherited from Edit.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InputClass | Gets or sets the input class.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Edit.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange | Called when the input is changed by the user. (Inherited from Input.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Password | Gets or sets a value indicating whether this Edit is password. (Inherited from Edit.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether this instance is read only. (Inherited from Input.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderCombo(HtmlTextWriter) | Renders the combo.
 | RenderComboCell(HtmlTextWriter) | Renders the combo cell.
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag. (Inherited from Edit.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether modifications are tracked. (Inherited from Input.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Edit.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Input
 |  |  |  |  |  |  | Edit
 |  |  |  |  |  |  |  | ComboEdit


ComboEdit Constructor

ComboEdit Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboEdit ► ComboEdit()()()
Initializes a new instance of the ComboEdit class
Declaration Syntax
C#
protected ComboEdit()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboEdit ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


InputClass Property

InputClass Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboEdit ► InputClass
Gets or sets the input class.
Declaration Syntax
C#
public string InputClass { get; set; }
Value
The input class.


RenderCombo Method (output)

RenderCombo Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboEdit ► RenderCombo(HtmlTextWriter)
Renders the combo.
Declaration Syntax
C#
protected virtual void RenderCombo(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


RenderComboCell Method (output)

RenderComboCell Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ComboEdit ► RenderComboCell(HtmlTextWriter)
Renders the combo cell.
Declaration Syntax
C#
protected virtual void RenderComboCell(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


Component Class

Component Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component
Serves as the base class that defines the methods, properties and events common to all controls in the Sitecore.Web.UI.HtmlControls namespace.
Declaration Syntax
C#
public class Component : WebControl, IMessageHandler,
    IPostBackDataHandler
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Component()()() | Initializes a new instance of the Component class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property.
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides WebControl.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute.
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string.
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID.
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string.
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean.
 | GetViewStateBool(String, Boolean) | Gets the view state boolean.
 | GetViewStateInt(String) | Gets the view state integer.
 | GetViewStateInt(String, Int32) | Gets the view state integer.
 | GetViewStateProperty(String, Object) | Gets the view state property.
 | GetViewStateString(String) | Gets the view state string.
 | GetViewStateString(String, String) | Gets the view state string.
 | HandleMessage(Message) | Handles the message.
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data.
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control.
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed.
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties.
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean.
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean.
 | SetViewStateInt(String, Int32) | Sets the view state integer.
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int.
 | SetViewStateProperty(String, Object, Object) | Sets the view state property.
 | SetViewStateString(String, String) | Sets the view state string.
 | SetViewStateString(String, String, String) | Sets the view state string.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  | KeyMap
 |  |  |  |  | RegisterKey
 |  |  |  |  | Script
 |  |  |  |  | Space
 |  |  |  |  | Stylesheet


Component Constructor

Component Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► Component()()()
Initializes a new instance of the Component class
Declaration Syntax
C#
public Component()


AssertLoadOnlyProperty Method (propertyName)

AssertLoadOnlyProperty Method (propertyName)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► AssertLoadOnlyProperty(String)
Asserts the load only property.
Declaration Syntax
C#
protected void AssertLoadOnlyProperty(
    string propertyName
)
Parameters
propertyName (String)
Name of the property.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


FormatAttribute Method (name, val)

FormatAttribute Method (name, val)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► FormatAttribute(String, String)
Formats the attribute.
Declaration Syntax
C#
protected string FormatAttribute(
    string name,
    string val
)
Parameters
name (String)
The name.
val (String)
The val.
Return Value


GetContentItemFromQueryString Method

GetContentItemFromQueryString Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► GetContentItemFromQueryString()()()
Gets the content item from query string.
Declaration Syntax
C#
protected Item GetContentItemFromQueryString()
Return Value


GetID Method (sID)

GetID Method (sID)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► GetID(String)
Gets the ID.
Declaration Syntax
C#
protected string GetID(
    string sID
)
Parameters
sID (String)
The IDs.
Return Value


GetItemFromQueryString Method

GetItemFromQueryString Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► GetItemFromQueryString()()()
Gets the item from query string.
Declaration Syntax
C#
protected Item GetItemFromQueryString()
Return Value


GetViewStateBool Method

GetViewStateBool Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► GetViewStateBool()()()
Members
Icon | Member | Description
 | GetViewStateBool(String) | Gets the view state boolean.
 | GetViewStateBool(String, Boolean) | Gets the view state boolean.


GetViewStateBool Method (name)

GetViewStateBool Method (name)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► GetViewStateBool(String)
Gets the view state boolean.
Declaration Syntax
C#
protected bool GetViewStateBool(
    string name
)
Parameters
name (String)
The name.
Return Value


GetViewStateBool Method (name, defaultValue)

GetViewStateBool Method (name, defaultValue)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► GetViewStateBool(String, Boolean)
Gets the view state boolean.
Declaration Syntax
C#
protected bool GetViewStateBool(
    string name,
    bool defaultValue
)
Parameters
name (String)
The name.
defaultValue (Boolean)
if set to true [default value].
Return Value


GetViewStateInt Method

GetViewStateInt Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► GetViewStateInt()()()
Members
Icon | Member | Description
 | GetViewStateInt(String) | Gets the view state integer.
 | GetViewStateInt(String, Int32) | Gets the view state integer.


GetViewStateInt Method (name)

GetViewStateInt Method (name)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► GetViewStateInt(String)
Gets the view state integer.
Declaration Syntax
C#
protected int GetViewStateInt(
    string name
)
Parameters
name (String)
The name.
Return Value


GetViewStateInt Method (name, defaultValue)

GetViewStateInt Method (name, defaultValue)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► GetViewStateInt(String, Int32)
Gets the view state integer.
Declaration Syntax
C#
protected int GetViewStateInt(
    string name,
    int defaultValue
)
Parameters
name (String)
The name.
defaultValue (Int32)
The default value.
Return Value


GetViewStateProperty Method (name, defaultValue)

GetViewStateProperty Method (name, defaultValue)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► GetViewStateProperty(String, Object)
Gets the view state property.
Declaration Syntax
C#
protected Object GetViewStateProperty(
    string name,
    Object defaultValue
)
Parameters
name (String)
The name.
defaultValue (Object)
The default value.
Return Value


GetViewStateString Method

GetViewStateString Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► GetViewStateString()()()
Members
Icon | Member | Description
 | GetViewStateString(String) | Gets the view state string.
 | GetViewStateString(String, String) | Gets the view state string.


GetViewStateString Method (name)

GetViewStateString Method (name)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► GetViewStateString(String)
Gets the view state string.
Declaration Syntax
C#
protected string GetViewStateString(
    string name
)
Parameters
name (String)
The name.
Return Value


GetViewStateString Method (name, defaultValue)

GetViewStateString Method (name, defaultValue)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► GetViewStateString(String, String)
Gets the view state string.
Declaration Syntax
C#
protected string GetViewStateString(
    string name,
    string defaultValue
)
Parameters
name (String)
The name.
defaultValue (String)
The default value.
Return Value


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► HandleMessage(Message)
Handles the message.
Declaration Syntax
C#
public virtual void HandleMessage(
    Message message
)
Parameters
message (Message)
The message.


LoadPostData Method

LoadPostData Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► LoadPostData()()()
Members
Icon | Member | Description
 | LoadPostData(String) | Loads the post data.
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control.


LoadPostData Method (value)

LoadPostData Method (value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► LoadPostData(String)
Loads the post data.
Declaration Syntax
C#
protected virtual bool LoadPostData(
    string value
)
Parameters
value (String)
The value.
Return Value
Returns true, if a change has occurred, otherwise false.


LoadPostData Method (postDataKey, postCollection)

LoadPostData Method (postDataKey, postCollection)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► LoadPostData(String, NameValueCollection)
When implemented by a class, processes postback data for an ASP.NET server control.
Declaration Syntax
C#
public virtual bool LoadPostData(
    string postDataKey,
    NameValueCollection postCollection
)
Parameters
postDataKey (String)
The key identifier for the control.
postCollection (NameValueCollection)
The collection of all incoming name values.
Return Value
true if the server control's state changes as a result of the postback; otherwise, false.


RaisePostDataChangedEvent Method

RaisePostDataChangedEvent Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► RaisePostDataChangedEvent()()()
When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed.
Declaration Syntax
C#
public virtual void RaisePostDataChangedEvent()


ServerProperties Property

ServerProperties Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► ServerProperties
Gets the server properties.
Declaration Syntax
C#
public StateBag ServerProperties { get; }
Value
The server properties.


SetViewStateBool Method

SetViewStateBool Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► SetViewStateBool()()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) | Sets the view state boolean.
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean.


SetViewStateBool Method (name, value)

SetViewStateBool Method (name, value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► SetViewStateBool(String, Boolean)
Sets the view state boolean.
Declaration Syntax
C#
protected void SetViewStateBool(
    string name,
    bool value
)
Parameters
name (String)
The name.
value (Boolean)
if set to true [value].


SetViewStateBool Method (name, value, defaultValue)

SetViewStateBool Method (name, value, defaultValue)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► SetViewStateBool(String, Boolean, Boolean)
Sets the view state boolean.
Declaration Syntax
C#
protected void SetViewStateBool(
    string name,
    bool value,
    bool defaultValue
)
Parameters
name (String)
The name.
value (Boolean)
if set to true [value].
defaultValue (Boolean)
if set to true [default value].


SetViewStateInt Method

SetViewStateInt Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► SetViewStateInt()()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) | Sets the view state integer.
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int.


SetViewStateInt Method (name, value)

SetViewStateInt Method (name, value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► SetViewStateInt(String, Int32)
Sets the view state integer.
Declaration Syntax
C#
protected void SetViewStateInt(
    string name,
    int value
)
Parameters
name (String)
The name.
value (Int32)
The value.


SetViewStateInt Method (name, value, defaultValue)

SetViewStateInt Method (name, value, defaultValue)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► SetViewStateInt(String, Int32, Int32)
Sets the view state int.
Declaration Syntax
C#
protected void SetViewStateInt(
    string name,
    int value,
    int defaultValue
)
Parameters
name (String)
The name.
value (Int32)
The value.
defaultValue (Int32)
The default value.


SetViewStateProperty Method (name, value, defaultValue)

SetViewStateProperty Method (name, value, defaultValue)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► SetViewStateProperty(String, Object, Object)
Sets the view state property.
Declaration Syntax
C#
protected void SetViewStateProperty(
    string name,
    Object value,
    Object defaultValue
)
Parameters
name (String)
The name.
value (Object)
The value.
defaultValue (Object)
The default value.


SetViewStateString Method

SetViewStateString Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► SetViewStateString()()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) | Sets the view state string.
 | SetViewStateString(String, String, String) | Sets the view state string.


SetViewStateString Method (name, value)

SetViewStateString Method (name, value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► SetViewStateString(String, String)
Sets the view state string.
Declaration Syntax
C#
protected void SetViewStateString(
    string name,
    string value
)
Parameters
name (String)
The name.
value (String)
The value.


SetViewStateString Method (name, value, defaultValue)

SetViewStateString Method (name, value, defaultValue)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Component ► SetViewStateString(String, String, String)
Sets the view state string.
Declaration Syntax
C#
protected void SetViewStateString(
    string name,
    string value,
    string defaultValue
)
Parameters
name (String)
The name.
value (String)
The value.
defaultValue (String)
The default value.


ContextMenu Class

ContextMenu Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► ContextMenu
Represents a context menu.
Declaration Syntax
C#
public class ContextMenu : Menu
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContextMenu()()() | Initializes a new instance of the ContextMenu class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | Add(String, String, String) | Adds the specified header. (Inherited from Menu.)
 | Add(String, String, String, String, String, Boolean, String, MenuItemType) | Adds the specified id. (Inherited from Menu.)
 | Add(Control, String, String, String, String, String, Boolean, String, MenuItemType, String, String, String, Boolean) | Adds the specified parent. (Inherited from Menu.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddDivider()()() | Adds the divider. (Inherited from Menu.)
 | AddDivider(Control) | Adds the divider. (Inherited from Menu.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddFromDataSource(String, String) | Adds from data source. (Inherited from Menu.)
 | AddFromDataSource(Item, String) | Adds from data source. (Inherited from Menu.)
 | AddFromDataSource(Item, String, CommandContext) | Adds from data source. (Inherited from Menu.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Menu.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Show(String, String) | Shows the menu at the specified tag id. (Overrides Menu.Show(String, String).)
 | Show()()() | Shows this instance. (Inherited from Menu.)
 | Show(String) | Shows the menu at the specified position. (Inherited from Menu.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Menu
 |  |  |  |  |  |  | ContextMenu
 |  |  |  |  |  |  |  | DataContextMenu


ContextMenu Constructor

ContextMenu Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► ContextMenu ► ContextMenu()()()
Initializes a new instance of the ContextMenu class.
Declaration Syntax
C#
public ContextMenu()


Show Method (id, where)

Show Method (id, where)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ContextMenu ► Show(String, String)
Shows the menu at the specified tag id.
Declaration Syntax
C#
public override void Show(
    string id,
    string where
)
Parameters
id (String)
The id.
where (String)
The where.


Control Class

Control Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control
Serves as the base class that defines the methods, properties and events common to all controls in the Sitecore.Web.UI.HtmlControls namespace.
Declaration Syntax
C#
public class Control : Component, IIsAjaxEventHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Control()()() | Initializes a new instance of the Control class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action.
 | Activate | Gets or sets the activate message.
 | Activation | Gets or sets a value indicating whether this Control supports activation.
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | AttributeNameOnly |
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Overrides WebControl.Background.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name.
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu.
 | ControlAttributes | Gets the control attributes.
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context.
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message.
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled.
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event.
 | DoContextmenu(Message) | Executes the contextmenu event.
 | DoDeactivate(Message) | Executes the deactivate event.
 | DoKeydown(Message) | Executes the keydown event.
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Component.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font.
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font.
 | FontName | Gets or sets the name of the font.
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font.
 | FontSize | Gets or sets the size of the font.
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font.
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font.
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes.
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context.
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniqueID(String) | Gets the unique ID.
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Overrides Component.HandleMessage(Message).)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down.
 | KeyFilter | Gets or sets the key filter.
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name.
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed.
 | OnActivate |
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu |
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed.
 | OnDeactivate |
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added.
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted.
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed.
 | OnItemSaved(DataContext, ID) | Called when the item has saved.
 | OnKeyDown |
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect.
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes.
 | SetWidthAndHeightStyle()()() | Sets the width and height style.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop.
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value.
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | JobMonitor
 |  |  |  |  |  | Bevel
 |  |  |  |  |  | Border
 |  |  |  |  |  | DataContext
 |  |  |  |  |  | Frame
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  | Image
 |  |  |  |  |  | Inline
 |  |  |  |  |  | Input
 |  |  |  |  |  | Listbox
 |  |  |  |  |  | ListboxItem
 |  |  |  |  |  | ListItem
 |  |  |  |  |  | Listview
 |  |  |  |  |  | ListviewHeader
 |  |  |  |  |  | Literal
 |  |  |  |  |  | Menu
 |  |  |  |  |  | Menubar
 |  |  |  |  |  | MenuDivider
 |  |  |  |  |  | MenuLine
 |  |  |  |  |  | MenuPanel
 |  |  |  |  |  | Panel
 |  |  |  |  |  | Popup
 |  |  |  |  |  | RenderItem
 |  |  |  |  |  | RenderList
 |  |  |  |  |  | Reporter
 |  |  |  |  |  | Tabstrip
 |  |  |  |  |  | TaskboxItems
 |  |  |  |  |  | Tooldivider
 |  |  |  |  |  | Treecrumb
 |  |  |  |  |  | TreeHeader
 |  |  |  |  |  | Treeview
 |  |  |  |  |  | VerticalTabstrip
 |  |  |  |  |  | WebPanel
 |  |  |  |  |  | Xsl
 |  |  |  |  |  | Portal


Control Constructor

Control Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► Control()()()
Initializes a new instance of the Control class.
Declaration Syntax
C#
public Control()


Action Property

Action Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► Action
Gets or sets the action.
Declaration Syntax
C#
public virtual string Action { get; set; }
Value
The action.


Activate Property

Activate Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► Activate
Gets or sets the activate message.
Declaration Syntax
C#
public virtual string Activate { get; set; }
Value
The activate mesage.


Activation Property

Activation Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► Activation
Gets or sets a value indicating whether this Control supports activation.
Declaration Syntax
C#
public bool Activation { get; set; }
Value
true if activation; otherwise, false.


AttributeNameOnly Field

AttributeNameOnly Field
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► AttributeNameOnly
Declaration Syntax
C#
public const string AttributeNameOnly


Background Property

Background Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► Background
Gets or sets the background style.
Declaration Syntax
C#
public override string Background { get; set; }
Value


Class Property

Class Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► Class
Gets or sets the CSS class name.
Declaration Syntax
C#
public virtual string Class { get; set; }
Value
The CSS class name.


ContextMenu Property

ContextMenu Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► ContextMenu
Gets or sets the context menu.
Declaration Syntax
C#
public virtual string ContextMenu { get; set; }
Value
The context menu.


ControlAttributes Property

ControlAttributes Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► ControlAttributes
Gets the control attributes.
Declaration Syntax
C#
public string ControlAttributes { get; }
Value
The control attributes.


DataContext Property

DataContext Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► DataContext
Gets or sets the data context.
Declaration Syntax
C#
public virtual string DataContext { get; set; }
Value
The data context.


Deactivate Property

Deactivate Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► Deactivate
Gets or sets the deactivate message.
Declaration Syntax
C#
public virtual string Deactivate { get; set; }
Value
The deactivate message.


Disabled Property

Disabled Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► Disabled
Gets or sets a value indicating whether this Control is disabled.
Declaration Syntax
C#
public virtual bool Disabled { get; set; }
Value
true if disabled; otherwise, false.


DoActivate Method (message)

DoActivate Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► DoActivate(Message)
Executes the activate event.
Declaration Syntax
C#
protected virtual void DoActivate(
    Message message
)
Parameters
message (Message)
The message.


DoContextmenu Method (message)

DoContextmenu Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► DoContextmenu(Message)
Executes the contextmenu event.
Declaration Syntax
C#
protected virtual void DoContextmenu(
    Message message
)
Parameters
message (Message)
The message.


DoDeactivate Method (message)

DoDeactivate Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► DoDeactivate(Message)
Executes the deactivate event.
Declaration Syntax
C#
protected virtual void DoDeactivate(
    Message message
)
Parameters
message (Message)
The message.


DoKeydown Method (message)

DoKeydown Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► DoKeydown(Message)
Executes the keydown event.
Declaration Syntax
C#
protected virtual void DoKeydown(
    Message message
)
Parameters
message (Message)
The message.


FontBold Property

FontBold Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► FontBold
Gets or sets a value indicating whether the Control uses bold font.
Declaration Syntax
C#
public bool FontBold { get; set; }
Value
true if the Control uses bold font; otherwise, false.


FontItalic Property

FontItalic Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► FontItalic
Gets or sets a value indicating whether the Control uses italics font.
Declaration Syntax
C#
public bool FontItalic { get; set; }
Value
true if the Control uses italics font; otherwise, false.


FontName Property

FontName Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► FontName
Gets or sets the name of the font.
Declaration Syntax
C#
public string FontName { get; set; }
Value
The name of the font.


FontOverline Property

FontOverline Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► FontOverline
Gets or sets a value indicating whether the Control uses overline font.
Declaration Syntax
C#
public bool FontOverline { get; set; }
Value
true if the Control uses overline font; otherwise, false.


FontSize Property

FontSize Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► FontSize
Gets or sets the size of the font.
Declaration Syntax
C#
public FontUnit FontSize { get; set; }
Value
The size of the font.


FontStrikeout Property

FontStrikeout Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► FontStrikeout
Gets or sets a value indicating whether the Control uses strikeout font.
Declaration Syntax
C#
public bool FontStrikeout { get; set; }
Value
true if the Control uses strikeout font; otherwise, false.


FontUnderline Property

FontUnderline Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► FontUnderline
Gets or sets a value indicating whether the Control uses underline font.
Declaration Syntax
C#
public bool FontUnderline { get; set; }
Value
true if the Control uses underline font; otherwise, false.


GetControlAttributes Method

GetControlAttributes Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► GetControlAttributes()()()
Gets the control attributes.
Declaration Syntax
C#
protected virtual string GetControlAttributes()
Return Value


GetDataContext Method

GetDataContext Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► GetDataContext()()()
Gets the data context.
Declaration Syntax
C#
protected DataContext GetDataContext()
Return Value


GetUniqueID Method (prefix)

GetUniqueID Method (prefix)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► GetUniqueID(String)
Gets the unique ID.
Declaration Syntax
C#
public static string GetUniqueID(
    string prefix
)
Parameters
prefix (String)
The prefix.
Return Value


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► HandleMessage(Message)
Handles the message.
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)
The message.


KeyDown Property

KeyDown Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► KeyDown
Gets or sets the key down.
Declaration Syntax
C#
public string KeyDown { get; set; }
Value
The key down.


KeyFilter Property

KeyFilter Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► KeyFilter
Gets or sets the key filter.
Declaration Syntax
C#
public string KeyFilter { get; set; }
Value
The key filter.


Name Property

Name Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► Name
Gets or sets the name.
Declaration Syntax
C#
public virtual string Name { get; set; }
Value
The name.


OnActionChanged Method (action)

OnActionChanged Method (action)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► OnActionChanged(Action)
Called when an action has changed.
Declaration Syntax
C#
protected virtual void OnActionChanged(
    Action action
)
Parameters
action (Action)
The action.


OnActivate Event

OnActivate Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► OnActivate
Declaration Syntax
C#
public event EventHandler OnActivate


OnContextMenu Event

OnContextMenu Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► OnContextMenu
Declaration Syntax
C#
public event EventHandler OnContextMenu


OnDataContextChanged Method (dataContext)

OnDataContextChanged Method (dataContext)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► OnDataContextChanged(DataContext)
Called when the data context changed.
Declaration Syntax
C#
protected virtual void OnDataContextChanged(
    DataContext dataContext
)
Parameters
dataContext (DataContext)
The data context.


OnDeactivate Event

OnDeactivate Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► OnDeactivate
Declaration Syntax
C#
public event EventHandler OnDeactivate


OnItemAdded Method (context, id)

OnItemAdded Method (context, id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► OnItemAdded(DataContext, ID)
Called when the item has added.
Declaration Syntax
C#
protected virtual void OnItemAdded(
    DataContext context,
    ID id
)
Parameters
context (DataContext)
The context.
id (ID)
The id.


OnItemDeleted Method (context, id)

OnItemDeleted Method (context, id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► OnItemDeleted(DataContext, ID)
Called when the item has deleted.
Declaration Syntax
C#
protected virtual void OnItemDeleted(
    DataContext context,
    ID id
)
Parameters
context (DataContext)
The context.
id (ID)
The id.


OnItemRenamed Method (context, id)

OnItemRenamed Method (context, id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► OnItemRenamed(DataContext, ID)
Called when the item has renamed.
Declaration Syntax
C#
protected virtual void OnItemRenamed(
    DataContext context,
    ID id
)
Parameters
context (DataContext)
The context.
id (ID)
The id.


OnItemSaved Method (context, id)

OnItemSaved Method (context, id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► OnItemSaved(DataContext, ID)
Called when the item has saved.
Declaration Syntax
C#
protected virtual void OnItemSaved(
    DataContext context,
    ID id
)
Parameters
context (DataContext)
The context.
id (ID)
The id.


OnKeyDown Event

OnKeyDown Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► OnKeyDown
Declaration Syntax
C#
public event EventHandler OnKeyDown


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


RollOver Property

RollOver Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► RollOver
Gets or sets a value indicating whether the control has a roll over effect.
Declaration Syntax
C#
public bool RollOver { get; set; }
Value
true if the control has a roll over effect; otherwise, false.


SetWidthAndHeightAttributes Method

SetWidthAndHeightAttributes Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► SetWidthAndHeightAttributes()()()
Sets the width and height attributes.
Declaration Syntax
C#
protected void SetWidthAndHeightAttributes()


SetWidthAndHeightStyle Method

SetWidthAndHeightStyle Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► SetWidthAndHeightStyle()()()
Sets the width and height style.
Declaration Syntax
C#
protected void SetWidthAndHeightStyle()


TabStop Property

TabStop Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► TabStop
Gets or sets a value indicating whether this control is a tab stop.
Declaration Syntax
C#
public bool TabStop { get; set; }
Value
true if this control is a tab stop; otherwise, false.


Value Property

Value Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► Value
Gets or sets the value.
Declaration Syntax
C#
public virtual string Value { get; set; }
Value
The value.


Visible Property

Visible Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Control ► Visible
Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Declaration Syntax
C#
public virtual bool Visible { get; set; }
Value
Return Value
true if the control is visible on the page; otherwise false.


ControlLiteral Class

ControlLiteral Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► ControlLiteral
Declaration Syntax
C#
public class ControlLiteral : LiteralControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ControlLiteral()()() | Initializes a new instance of the ControlLiteral class.
 | ControlLiteral(String) | Initializes a new instance of the ControlLiteral class.
 | ControlLiteral(String, Boolean) | Initializes a new instance of the ControlLiteral class.
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates an EmptyControlCollection object for the current instance of the LiteralControl class. (Overrides LiteralControl.CreateControlCollection()()().)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from Control.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Writes the content of the LiteralControl object to the ASP.NET page. (Overrides LiteralControl.Render(HtmlTextWriter).)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text content of the LiteralControl object. (Inherited from LiteralControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Inheritance Hierarchy
Object
 | Control
 |  | LiteralControl
 |  |  | ControlLiteral


ControlLiteral Constructor

ControlLiteral Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► ControlLiteral ► ControlLiteral()()()
Members
Icon | Member | Description
 | ControlLiteral()()() | Initializes a new instance of the ControlLiteral class.
 | ControlLiteral(String) | Initializes a new instance of the ControlLiteral class.
 | ControlLiteral(String, Boolean) | Initializes a new instance of the ControlLiteral class.


ControlLiteral Constructor

ControlLiteral Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► ControlLiteral ► ControlLiteral()()()
Initializes a new instance of the ControlLiteral class.
Declaration Syntax
C#
public ControlLiteral()


ControlLiteral Constructor (text)

ControlLiteral Constructor (text)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ControlLiteral ► ControlLiteral(String)
Initializes a new instance of the ControlLiteral class.
Declaration Syntax
C#
public ControlLiteral(
    string text
)
Parameters
text (String)
The text to be rendered on the requested Web page.


ControlLiteral Constructor (text, persisted)

ControlLiteral Constructor (text, persisted)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ControlLiteral ► ControlLiteral(String, Boolean)
Initializes a new instance of the ControlLiteral class.
Declaration Syntax
C#
public ControlLiteral(
    string text,
    bool persisted
)
Parameters
text (String)
The text.
persisted (Boolean)
if set to true this instance is persisted.


CreateControlCollection Method

CreateControlCollection Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► ControlLiteral ► CreateControlCollection()()()
Creates an EmptyControlCollection object for the current instance of the LiteralControl class.
Declaration Syntax
C#
protected override ControlCollection CreateControlCollection()
Return Value
The EmptyControlCollection for the current control.


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ControlLiteral ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ControlLiteral ► Render(HtmlTextWriter)
Writes the content of the LiteralControl object to the ASP.NET page.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
An HtmlTextWriter that renders the content of the LiteralControl to the requesting client.


DataCheckbox Class

DataCheckbox Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataCheckbox
Represents a data-aware checkbox.
Declaration Syntax
C#
public class DataCheckbox : Checkbox
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCheckbox()()() | Initializes a new instance of the DataCheckbox class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event. (Inherited from Input.)
 | Checked | Gets or sets a value indicating whether this Checkbox is checked. (Inherited from Checkbox.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the click event. (Inherited from Checkbox.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Executes the Change event. (Inherited from Checkbox.)
 | DoClick(Message) | Executes the click event. (Inherited from Checkbox.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Checkbox.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | FieldName | Gets or sets the name of the field.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from Checkbox.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from Checkbox.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Checkbox.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Checkbox.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange | Called when the input is changed by the user. (Inherited from Input.)
 | OnClick | (Inherited from Checkbox.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Checkbox.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Checkbox.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether this instance is read only. (Inherited from Input.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag. (Inherited from Input.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether modifications are tracked. (Inherited from Input.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Checkbox.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Input
 |  |  |  |  |  |  | Checkbox
 |  |  |  |  |  |  |  | DataCheckbox


DataCheckbox Constructor

DataCheckbox Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataCheckbox ► DataCheckbox()()()
Initializes a new instance of the DataCheckbox class
Declaration Syntax
C#
public DataCheckbox()


FieldName Property

FieldName Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataCheckbox ► FieldName
Gets or sets the name of the field.
Declaration Syntax
C#
public string FieldName { get; set; }
Value
The name of the field.


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataCheckbox ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


DataContext Class

DataContext Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext
Represents a data context.
Declaration Syntax
C#
public class DataContext : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataContext()()() | Initializes a new instance of the DataContext class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddSelected(DataUri) | Adds the item to the selected set.
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | AtRoot | Gets a value indicating whether the selected item is at the root.
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BeginUpdate()()() | Begins the update.
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Changed |
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearSelected()()() | Clears the selected set.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | CurrentItem | Gets the current item.
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DataView | Gets the data view.
 | DataViewName | Gets or sets the name of the data view.
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DefaultItem | Gets or sets the default item.
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableEvents()()() | Disables the events.
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Component.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableEvents()()() | Enables the events.
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EndUpdate()()() | Ends the update.
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Filter | Gets or sets the filter.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Folder | Gets or sets the folder.
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetChildren(Item) | Gets the children.
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFolder()()() | Gets the folder.
 | GetFromQueryString()()() | Gets the state from query string.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem(ID) | Gets the item.
 | GetItem(DataUri) | Gets the item.
 | GetItem(String) | Gets the item.
 | GetItem(String, Language, Version) | Gets the item.
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetItems()()() | Gets the items.
 | GetParent(Item) | Gets the parent.
 | GetRoot()()() | Gets the root.
 | GetSelected()()() | Gets the selected items.
 | GetState(Item%, Item%) | Gets the state.
 | GetState(Item%, Item%, array<Item>[]()[]%) | Gets the state.
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Overrides Control.HandleMessage(Message).)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildren(Item) | Determines whether the specified item has children.
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsAncestorOf(Item, Item) | Determines if the ancestor is an ancestor of the item.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemAdded |
 | ItemDeleted |
 | ItemRenamed |
 | ItemSaved |
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | Language | Gets or sets the language.
 | LastGoodFolder | Gets or sets the last good folder.
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | Offset | Gets or sets the offset.
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChanged()()() | Called when changed has occured.
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context has changed. (Overrides Control.OnDataContextChanged(DataContext).)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(ID) | Called when an item has been added.
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(ID) | Called when an item has been deleted.
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(ID) | Called when the item has been renamed.
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(ID) | Called when the item has been saved.
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSelectionChanged()()() | Called when the selection has changed.
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Parameters to pass to element
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | Range | Gets or sets the range.
 | Refresh()()() | Refreshes this instance.
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | RemoveSelected(DataUri) | Removes the selected.
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | Root | Gets or sets the root.
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Selected | Gets or sets the selected items.
 | SelectionChanged |
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetFolder(ItemUri) | Sets the folder.
 | SetFolderFromEvent(ItemUri) | Sets the folder from event.
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetRootAndFolder(String, ItemUri) | Sets the root and folder.
 | SetSorting(String, Boolean) | Sets the sorting.
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowRoot | Gets or sets a value indicating whether the root is shown.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | SortAscending | Gets or sets a value indicating whether the item are sorted ascending.
 | SortBy | Gets or sets the sort by.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Up()()() | Sets the folder to the parent of the current folder.
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | Version | Gets or sets the version.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | DataContext
 |  |  |  |  |  |  | ContentDataContext
 |  |  |  |  |  |  | TemplateFilteredDataContext


DataContext Constructor

DataContext Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► DataContext()()()
Initializes a new instance of the DataContext class.
Declaration Syntax
C#
public DataContext()


AddSelected Method (item)

AddSelected Method (item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► AddSelected(DataUri)
Adds the item to the selected set.
Declaration Syntax
C#
public void AddSelected(
    DataUri item
)
Parameters
item (DataUri)
The item.


AtRoot Property

AtRoot Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► AtRoot
Gets a value indicating whether the selected item is at the root.
Declaration Syntax
C#
public virtual bool AtRoot { get; }
Value
true if the selected item at root; otherwise, false.


BeginUpdate Method

BeginUpdate Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► BeginUpdate()()()
Begins the update.
Declaration Syntax
C#
public void BeginUpdate()


Changed Event

Changed Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► Changed
Declaration Syntax
C#
public event DataContext..::.DataContextChangedDelegate Changed


ClearSelected Method

ClearSelected Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► ClearSelected()()()
Clears the selected set.
Declaration Syntax
C#
public void ClearSelected()


CurrentItem Property

CurrentItem Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► CurrentItem
Gets the current item.
Declaration Syntax
C#
public Item CurrentItem { get; }
Value
The current item.


DataView Property

DataView Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► DataView
Gets the data view.
Declaration Syntax
C#
public IDataView DataView { get; }
Value
The data view.


DataViewName Property

DataViewName Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► DataViewName
Gets or sets the name of the data view.
Declaration Syntax
C#
public string DataViewName { get; set; }
Value
The name of the data view.


DefaultItem Property

DefaultItem Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► DefaultItem
Gets or sets the default item.
Declaration Syntax
C#
public string DefaultItem { get; set; }
Value
The default item.


DisableEvents Method

DisableEvents Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► DisableEvents()()()
Disables the events.
Declaration Syntax
C#
public void DisableEvents()


EnableEvents Method

EnableEvents Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► EnableEvents()()()
Enables the events.
Declaration Syntax
C#
public void EnableEvents()


EndUpdate Method

EndUpdate Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► EndUpdate()()()
Ends the update.
Declaration Syntax
C#
public void EndUpdate()


Filter Property

Filter Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► Filter
Gets or sets the filter.
Declaration Syntax
C#
public string Filter { get; set; }
Value
The filter.


Folder Property

Folder Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► Folder
Gets or sets the folder.
Declaration Syntax
C#
public string Folder { get; set; }
Value
The folder.


GetChildren Method (item)

GetChildren Method (item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetChildren(Item)
Gets the children.
Declaration Syntax
C#
public ItemCollection GetChildren(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetFolder Method

GetFolder Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetFolder()()()
Gets the folder.
Declaration Syntax
C#
public Item GetFolder()
Return Value


GetFromQueryString Method

GetFromQueryString Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetFromQueryString()()()
Gets the state from query string.
Declaration Syntax
C#
public void GetFromQueryString()


GetItem Method

GetItem Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetItem()()()
Members
Icon | Member | Description
 | GetItem(ID) | Gets the item.
 | GetItem(DataUri) | Gets the item.
 | GetItem(String) | Gets the item.
 | GetItem(String, Language, Version) | Gets the item.
 | GetItem()()() | Gets the item.


GetItem Method (id)

GetItem Method (id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetItem(DataUri)
Gets the item.
Declaration Syntax
C#
public Item GetItem(
    DataUri id
)
Parameters
id (DataUri)
The id.
Return Value


GetItem Method (id)

GetItem Method (id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetItem(ID)
Gets the item.
Declaration Syntax
C#
public Item GetItem(
    ID id
)
Parameters
id (ID)
The id.
Return Value


GetItem Method (id)

GetItem Method (id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetItem(String)
Gets the item.
Declaration Syntax
C#
public Item GetItem(
    string id
)
Parameters
id (String)
The id.
Return Value


GetItem Method (id, language, version)

GetItem Method (id, language, version)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetItem(String, Language, Version)
Gets the item.
Declaration Syntax
C#
public Item GetItem(
    string id,
    Language language,
    Version version
)
Parameters
id (String)
The id.
language (Language)
The language.
version (Version)
The version.
Return Value


GetItems Method

GetItems Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetItems()()()
Gets the items.
Declaration Syntax
C#
public Item[] GetItems()
Return Value


GetParent Method (item)

GetParent Method (item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetParent(Item)
Gets the parent.
Declaration Syntax
C#
public Item GetParent(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetRoot Method

GetRoot Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetRoot()()()
Gets the root.
Declaration Syntax
C#
public Item GetRoot()
Return Value


GetSelected Method

GetSelected Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetSelected()()()
Gets the selected items.
Declaration Syntax
C#
public Item[] GetSelected()
Return Value


GetState Method

GetState Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetState()()()
Members
Icon | Member | Description
 | GetState(Item%, Item%) | Gets the state.
 | GetState(Item%, Item%, array<Item>[]()[]%) | Gets the state.


GetState Method (root, folder)

GetState Method (root, folder)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetState(Item%, Item%)
Gets the state.
Declaration Syntax
C#
public void GetState(
    out Item root,
    out Item folder
)
Parameters
root ( Item %)
The root.
folder ( Item %)
The folder.


GetState Method (root, folder, selected)

GetState Method (root, folder, selected)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► GetState(Item%, Item%, array<Item>[]()[]%)
Gets the state.
Declaration Syntax
C#
public void GetState(
    out Item root,
    out Item folder,
    out Item[] selected
)
Parameters
root ( Item %)
The root.
folder ( Item %)
The folder.
selected ( array< Item >[]()[] %)
The selected.


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► HandleMessage(Message)
Handles the message.
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)
The message.


HasChildren Method (item)

HasChildren Method (item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► HasChildren(Item)
Determines whether the specified item has children.
Declaration Syntax
C#
public bool HasChildren(
    Item item
)
Parameters
item (Item)
The item.
Return Value
true if the specified item has children; otherwise, false.


IsAncestorOf Method (ancestor, item)

IsAncestorOf Method (ancestor, item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► IsAncestorOf(Item, Item)
Determines if the ancestor is an ancestor of the item.
Declaration Syntax
C#
public bool IsAncestorOf(
    Item ancestor,
    Item item
)
Parameters
ancestor (Item)
The ancestor.
item (Item)
The item.
Return Value
true if the ancestor is an ancestor of the item; otherwise, false.


ItemAdded Event

ItemAdded Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► ItemAdded
Declaration Syntax
C#
public event DataContext..::.ItemEventDelegate ItemAdded


ItemDeleted Event

ItemDeleted Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► ItemDeleted
Declaration Syntax
C#
public event DataContext..::.ItemEventDelegate ItemDeleted


ItemRenamed Event

ItemRenamed Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► ItemRenamed
Declaration Syntax
C#
public event DataContext..::.ItemEventDelegate ItemRenamed


ItemSaved Event

ItemSaved Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► ItemSaved
Declaration Syntax
C#
public event DataContext..::.ItemEventDelegate ItemSaved


Language Property

Language Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► Language
Gets or sets the language.
Declaration Syntax
C#
public Language Language { get; set; }
Value
The language.


LastGoodFolder Property

LastGoodFolder Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► LastGoodFolder
Gets or sets the last good folder.
Declaration Syntax
C#
protected ID LastGoodFolder { get; set; }
Value
The last good folder.


Offset Property

Offset Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► Offset
Gets or sets the offset.
Declaration Syntax
C#
public int Offset { get; set; }
Value
The offset.


OnChanged Method

OnChanged Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► OnChanged()()()
Called when changed has occured.
Declaration Syntax
C#
protected virtual void OnChanged()


OnDataContextChanged Method (dataContext)

OnDataContextChanged Method (dataContext)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► OnDataContextChanged(DataContext)
Called when the data context has changed.
Declaration Syntax
C#
protected override void OnDataContextChanged(
    DataContext dataContext
)
Parameters
dataContext (DataContext)
The data context.


OnItemAdded Method (id)

OnItemAdded Method (id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► OnItemAdded(ID)
Called when an item has been added.
Declaration Syntax
C#
protected virtual void OnItemAdded(
    ID id
)
Parameters
id (ID)
The id.


OnItemDeleted Method (id)

OnItemDeleted Method (id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► OnItemDeleted(ID)
Called when an item has been deleted.
Declaration Syntax
C#
protected virtual void OnItemDeleted(
    ID id
)
Parameters
id (ID)
The id.


OnItemRenamed Method (id)

OnItemRenamed Method (id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► OnItemRenamed(ID)
Called when the item has been renamed.
Declaration Syntax
C#
protected virtual void OnItemRenamed(
    ID id
)
Parameters
id (ID)
The id.


OnItemSaved Method (id)

OnItemSaved Method (id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► OnItemSaved(ID)
Called when the item has been saved.
Declaration Syntax
C#
protected virtual void OnItemSaved(
    ID id
)
Parameters
id (ID)
The id.


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


OnSelectionChanged Method

OnSelectionChanged Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► OnSelectionChanged()()()
Called when the selection has changed.
Declaration Syntax
C#
protected virtual void OnSelectionChanged()


Parameters Property

Parameters Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► Parameters
Parameters to pass to element
Declaration Syntax
C#
public string Parameters { get; set; }
Value


Range Property

Range Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► Range
Gets or sets the range.
Declaration Syntax
C#
public int Range { get; set; }
Value
The range.


Refresh Method

Refresh Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► Refresh()()()
Refreshes this instance.
Declaration Syntax
C#
public void Refresh()


RemoveSelected Method (item)

RemoveSelected Method (item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► RemoveSelected(DataUri)
Removes the selected.
Declaration Syntax
C#
public void RemoveSelected(
    DataUri item
)
Parameters
item (DataUri)
The item.


Root Property

Root Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► Root
Gets or sets the root.
Declaration Syntax
C#
public string Root { get; set; }
Value
The root.


Selected Property

Selected Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► Selected
Gets or sets the selected items.
Declaration Syntax
C#
public DataUri[] Selected { get; set; }
Value
The selected items.


SelectionChanged Event

SelectionChanged Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► SelectionChanged
Declaration Syntax
C#
public event EventHandler SelectionChanged


SetFolder Method (uri)

SetFolder Method (uri)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► SetFolder(ItemUri)
Sets the folder.
Declaration Syntax
C#
public void SetFolder(
    ItemUri uri
)
Parameters
uri (ItemUri)
The URI.


SetFolderFromEvent Method (uri)

SetFolderFromEvent Method (uri)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► SetFolderFromEvent(ItemUri)
Sets the folder from event.
Declaration Syntax
C#
protected virtual void SetFolderFromEvent(
    ItemUri uri
)
Parameters
uri (ItemUri)
The URI.


SetRootAndFolder Method (root, uri)

SetRootAndFolder Method (root, uri)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► SetRootAndFolder(String, ItemUri)
Sets the root and folder.
Declaration Syntax
C#
public void SetRootAndFolder(
    string root,
    ItemUri uri
)
Parameters
root (String)
The root.
uri (ItemUri)
The URI.


SetSorting Method (sortBy, sortAscending)

SetSorting Method (sortBy, sortAscending)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► SetSorting(String, Boolean)
Sets the sorting.
Declaration Syntax
C#
public void SetSorting(
    string sortBy,
    bool sortAscending
)
Parameters
sortBy (String)
The sort by.
sortAscending (Boolean)
if set to true [sort ascending].


ShowRoot Property

ShowRoot Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► ShowRoot
Gets or sets a value indicating whether the root is shown.
Declaration Syntax
C#
public bool ShowRoot { get; set; }
Value
true if the root is shown; otherwise, false.


SortAscending Property

SortAscending Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► SortAscending
Gets or sets a value indicating whether the item are sorted ascending.
Declaration Syntax
C#
public bool SortAscending { get; set; }
Value
true if the item are sorted ascending; otherwise, false.


SortBy Property

SortBy Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► SortBy
Gets or sets the sort by.
Declaration Syntax
C#
public string SortBy { get; set; }
Value
The sort by.


Up Method

Up Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► Up()()()
Sets the folder to the parent of the current folder.
Declaration Syntax
C#
public void Up()


Version Property

Version Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► Version
Gets or sets the version.
Declaration Syntax
C#
public Version Version { get; set; }
Value
The version.


DataContext.DataContextChangedDelegate Delegate

DataContext..::.DataContextChangedDelegate Delegate
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► DataContext..::.DataContextChangedDelegate
Declaration Syntax
C#
public delegate void DataContextChangedDelegate(
    Object sender
)
Parameters
sender (Object)


DataContext.ItemEventDelegate Delegate

DataContext..::.ItemEventDelegate Delegate
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContext ► DataContext..::.ItemEventDelegate
Declaration Syntax
C#
public delegate void ItemEventDelegate(
    Object sender,
    ID id
)
Parameters
sender (Object)
id (ID)


DataContextMenu Class

DataContextMenu Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContextMenu
Represents
Declaration Syntax
C#
public class DataContextMenu : ContextMenu
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataContextMenu()()() | Initializes a new instance of the DataContextMenu class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | Add(String, String, String) | Adds the specified header. (Inherited from Menu.)
 | Add(String, String, String, String, String, Boolean, String, MenuItemType) | Adds the specified id. (Inherited from Menu.)
 | Add(Control, String, String, String, String, String, Boolean, String, MenuItemType, String, String, String, Boolean) | Adds the specified parent. (Inherited from Menu.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddDivider()()() | Adds the divider. (Inherited from Menu.)
 | AddDivider(Control) | Adds the divider. (Inherited from Menu.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddFromDataSource(String, String) | Adds from data source. (Inherited from Menu.)
 | AddFromDataSource(Item, String) | Adds from data source. (Inherited from Menu.)
 | AddFromDataSource(Item, String, CommandContext) | Adds from data source. (Inherited from Menu.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Menu.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Show(String, String) | Shows the menu at the specified tag id. (Inherited from ContextMenu.)
 | Show()()() | Shows this instance. (Inherited from Menu.)
 | Show(String) | Shows the menu at the specified position. (Inherited from Menu.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | Target | Gets or sets the target.
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Menu
 |  |  |  |  |  |  | ContextMenu
 |  |  |  |  |  |  |  | DataContextMenu


DataContextMenu Constructor

DataContextMenu Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContextMenu ► DataContextMenu()()()
Initializes a new instance of the DataContextMenu class
Declaration Syntax
C#
public DataContextMenu()


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContextMenu ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


Target Property

Target Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataContextMenu ► Target
Gets or sets the target.
Declaration Syntax
C#
public string Target { get; set; }
Value
The target.


DataEdit Class

DataEdit Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataEdit
Represents a data-aware edit box.
Declaration Syntax
C#
public class DataEdit : Edit
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataEdit()()() | Initializes a new instance of the DataEdit class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event. (Inherited from Input.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Raises the Change event. (Inherited from Input.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Edit.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | FieldName | Gets or sets the name of the field.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Hidden | Gets or sets a value indicating whether this Edit is hidden. (Inherited from Edit.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Edit.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange | Called when the input is changed by the user. (Inherited from Input.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Password | Gets or sets a value indicating whether this Edit is password. (Inherited from Edit.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether this instance is read only. (Inherited from Input.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag. (Inherited from Edit.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether modifications are tracked. (Inherited from Input.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Edit.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Input
 |  |  |  |  |  |  | Edit
 |  |  |  |  |  |  |  | DataEdit


DataEdit Constructor

DataEdit Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataEdit ► DataEdit()()()
Initializes a new instance of the DataEdit class
Declaration Syntax
C#
public DataEdit()


FieldName Property

FieldName Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataEdit ► FieldName
Gets or sets the name of the field.
Declaration Syntax
C#
public string FieldName { get; set; }
Value
The name of the field.


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataEdit ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


DataListview Class

DataListview Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview
Represents a listview that pulls its items from a data context.
Declaration Syntax
C#
public class DataListview : Listview
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataListview()()() | Initializes a new instance of the DataListview class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AddViewsMenu(Menu) | Adds the views menu. (Inherited from Listview.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | AllowDragging | Gets or sets a value indicating whether the DataListview allows dragging.
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | AtRoot | Gets a value indicating whether the DataListview is at the root.
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearSelection()()() | Clears the selection. (Inherited from Listview.)
 | Click | Gets or sets the click event. (Inherited from Listview.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnNames | Gets the column names. (Inherited from Listview.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateListviewItem(Item) | Creates the listview item.
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click event. (Inherited from Listview.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Overrides Listview.DoClick(Message).)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the dblclick event. (Inherited from Listview.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Listview.)
 | DoSetView(String) | Executes the set view event. (Inherited from Listview.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event. (Inherited from Listview.)
 | DropItem(String) | Handles a drop event.
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetColumnValues(Item, DataListviewItem) | Gets the column values.
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetContextMenu()()() | Gets the context menu.
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemByID(String) | Gets the item by ID. (Inherited from Listview.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetSelectedItem()()() | Gets the selected item.
 | GetSelectedItems()()() | Gets the selected items. (Inherited from Listview.)
 | GetShellViewsMenu(String) | Gets the shell views menu. (Inherited from Listview.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewsMenu(String) | Gets the views menu. (Inherited from Listview.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets the items. (Inherited from Listview.)
 | ItemsOnly | Gets or sets a value indicating whether the Listview renders the items only and not the header. (Inherited from Listview.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | MultiSelect | Gets or sets a value indicating whether the Listview supports multiselect. (Inherited from Listview.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the control is clicked; (Inherited from Listview.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context has changed. (Overrides Control.OnDataContextChanged(DataContext).)
 | OnDblClick | Called when the control is double clicked; (Inherited from Listview.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when an item has been added. (Overrides Control.OnItemAdded(DataContext, ID).)
 | OnItemDeleted(DataContext, ID) | Called when an item has been deleted. (Overrides Control.OnItemDeleted(DataContext, ID).)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Listview.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSelectionChanged | Called when the selection is changed; (Inherited from Listview.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OnViewChanged | Called when the view is changed. (Inherited from Listview.)
 | Open()()() | Opens clicked item.
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Populate()()() | Populates the listview.
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | Refresh()()() | Refreshes this Listview. (Overrides Listview.Refresh()()().)
 | Refresh(DataContext) | Refreshes the specified data context.
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFooter(HtmlTextWriter) | Renders the footer. (Inherited from Listview.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderHeader(HtmlTextWriter) | Renders the header. (Inherited from Listview.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from Listview.)
 | Selected | Gets or sets the selected.
 | SelectedItems | Gets the selected items. (Inherited from Listview.)
 | SelectionChanged()()() | Called whrn the selection has been changed. (Overrides Listview.SelectionChanged()()().)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowCheckboxes | Gets or sets a value indicating whether the Listview shows the checkboxes. (Inherited from Listview.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | SortAscending | Gets or sets a value indicating whether the Listview sorts ascending. (Inherited from Listview.)
 | SortBy | Gets or sets the sort by column. (Inherited from Listview.)
 | SortByColumn(Int32) | Sorts by the column.
 | Src | Obsolete. Gets or sets the source.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | View | Gets or sets the view. (Inherited from Listview.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Listview
 |  |  |  |  |  |  | DataListview
 |  |  |  |  |  |  |  | MediaListview
 |  |  |  |  |  |  |  | RecycleBinListview


DataListview Constructor

DataListview Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► DataListview()()()
Initializes a new instance of the DataListview class.
Declaration Syntax
C#
public DataListview()


AllowDragging Property

AllowDragging Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► AllowDragging
Gets or sets a value indicating whether the DataListview allows dragging.
Declaration Syntax
C#
public bool AllowDragging { get; set; }
Value
true if the DataListview allows dragging; otherwise, false.


AtRoot Property

AtRoot Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► AtRoot
Gets a value indicating whether the DataListview is at the root.
Declaration Syntax
C#
public bool AtRoot { get; }
Value
true if the DataListview is at the root; otherwise, false.


CreateListviewItem Method (item)

CreateListviewItem Method (item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► CreateListviewItem(Item)
Creates the listview item.
Declaration Syntax
C#
protected virtual DataListviewItem CreateListviewItem(
    Item item
)
Parameters
item (Item)
The item.
Return Value


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected override void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DropItem Method (data)

DropItem Method (data)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► DropItem(String)
Handles a drop event.
Declaration Syntax
C#
protected virtual void DropItem(
    string data
)
Parameters
data (String)
The data.


GetColumnValues Method (child, ctl)

GetColumnValues Method (child, ctl)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► GetColumnValues(Item, DataListviewItem)
Gets the column values.
Declaration Syntax
C#
protected virtual void GetColumnValues(
    Item child,
    DataListviewItem ctl
)
Parameters
child (Item)
The child.
ctl (DataListviewItem)
The CTL.


GetContextMenu Method

GetContextMenu Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► GetContextMenu()()()
Gets the context menu.
Declaration Syntax
C#
protected virtual void GetContextMenu()


GetSelectedItem Method

GetSelectedItem Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► GetSelectedItem()()()
Gets the selected item.
Declaration Syntax
C#
public Item GetSelectedItem()
Return Value


OnDataContextChanged Method (dataContext)

OnDataContextChanged Method (dataContext)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► OnDataContextChanged(DataContext)
Called when the data context has changed.
Declaration Syntax
C#
protected override void OnDataContextChanged(
    DataContext dataContext
)
Parameters
dataContext (DataContext)
The data context.


OnItemAdded Method (context, id)

OnItemAdded Method (context, id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► OnItemAdded(DataContext, ID)
Called when an item has been added.
Declaration Syntax
C#
protected override void OnItemAdded(
    DataContext context,
    ID id
)
Parameters
context (DataContext)
The context.
id (ID)
The id.


OnItemDeleted Method (context, id)

OnItemDeleted Method (context, id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► OnItemDeleted(DataContext, ID)
Called when an item has been deleted.
Declaration Syntax
C#
protected override void OnItemDeleted(
    DataContext context,
    ID id
)
Parameters
context (DataContext)
The context.
id (ID)
The id.


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


Open Method

Open Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► Open()()()
Opens clicked item.
Declaration Syntax
C#
public void Open()


Populate Method

Populate Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► Populate()()()
Populates the listview.
Declaration Syntax
C#
protected virtual void Populate()


Refresh Method

Refresh Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► Refresh()()()
Members
Icon | Member | Description
 | Refresh()()() | Refreshes this Listview. (Overrides Listview.Refresh()()().)
 | Refresh(DataContext) | Refreshes the specified data context.


Refresh Method

Refresh Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► Refresh()()()
Refreshes this Listview.
Declaration Syntax
C#
public override void Refresh()


Refresh Method (dataContext)

Refresh Method (dataContext)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► Refresh(DataContext)
Refreshes the specified data context.
Declaration Syntax
C#
protected virtual void Refresh(
    DataContext dataContext
)
Parameters
dataContext (DataContext)
The data context.


Selected Property

Selected Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► Selected
Gets or sets the selected.
Declaration Syntax
C#
public string Selected { get; set; }
Value
The selected.


SelectionChanged Method

SelectionChanged Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► SelectionChanged()()()
Called whrn the selection has been changed.
Declaration Syntax
C#
protected override void SelectionChanged()


SortByColumn Method (index)

SortByColumn Method (index)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► SortByColumn(Int32)
Sorts by the column.
Declaration Syntax
C#
protected virtual void SortByColumn(
    int index
)
Parameters
index (Int32)
The index.


Src Property

Src Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListview ► Src
Gets or sets the source.
Declaration Syntax
C#
[ObsoleteAttribute]
public string Src { get; set; }
Value
The source.


DataListviewItem Class

DataListviewItem Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem
Represents an item in a listview.
Declaration Syntax
C#
public class DataListviewItem : ListviewItem
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataListviewItem()()() | Initializes a new instance of the DataListviewItem class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Checked | Gets or sets a value indicating whether this ListviewItem is checked. (Inherited from ListviewItem.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | ClassPrefix | Gets or sets the class prefix. (Inherited from ListviewItem.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnValues | Gets the column values. (Inherited from ListviewItem.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | Created | Gets or sets the created timestamp.
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DocumentText | Gets or sets the document text.
 | DocumentTitle | Gets or sets the document title.
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides ListviewItem.DoRender(HtmlTextWriter).)
 | Drag | Gets or sets the drag event. (Inherited from ListviewItem.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event.
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetCurrentView()()() | Gets the current view. (Inherited from ListviewItem.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetListview()()() | Gets the listview. (Inherited from ListviewItem.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildren | Gets or sets the has children string.
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon. (Inherited from ListviewItem.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemID | Gets or sets the item ID.
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Overrides Control.Name.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Overrides Control.OnInit(EventArgs).)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has been deleted. (Overrides Control.OnItemDeleted(DataContext, ID).)
 | OnItemRenamed(DataContext, ID) | Called when the item has been renamed. (Overrides Control.OnItemRenamed(DataContext, ID).)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from ListviewItem.)
 | Selected | Gets or sets a value indicating whether this ListviewItem is selected. (Inherited from ListviewItem.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | Template | Gets or sets the template.
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from ListviewItem.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Updated | Gets or sets the updated.
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | ListviewItem
 |  |  |  |  |  |  |  | DataListviewItem
 |  |  |  |  |  |  |  |  | MediaListviewItem


DataListviewItem Constructor

DataListviewItem Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem ► DataListviewItem()()()
Initializes a new instance of the DataListviewItem class
Declaration Syntax
C#
public DataListviewItem()


Created Property

Created Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem ► Created
Gets or sets the created timestamp.
Declaration Syntax
C#
public DateTime Created { get; set; }
Value
The created timestamp.


DocumentText Property

DocumentText Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem ► DocumentText
Gets or sets the document text.
Declaration Syntax
C#
public string DocumentText { get; set; }
Value
The document text.


DocumentTitle Property

DocumentTitle Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem ► DocumentTitle
Gets or sets the document title.
Declaration Syntax
C#
public string DocumentTitle { get; set; }
Value
The document title.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Drop Property

Drop Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem ► Drop
Gets or sets the drop event.
Declaration Syntax
C#
public string Drop { get; set; }
Value
The drop event.


HasChildren Property

HasChildren Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem ► HasChildren
Gets or sets the has children string.
Declaration Syntax
C#
public string HasChildren { get; set; }
Value
The has children string.


ItemID Property

ItemID Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem ► ItemID
Gets or sets the item ID.
Declaration Syntax
C#
public string ItemID { get; set; }
Value
The item ID.


Name Property

Name Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem ► Name
Gets or sets the name.
Declaration Syntax
C#
public override string Name { get; set; }
Value
The name.


OnInit Method (e)

OnInit Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem ► OnInit(EventArgs)
Raises the Init event.
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


OnItemDeleted Method (context, id)

OnItemDeleted Method (context, id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem ► OnItemDeleted(DataContext, ID)
Called when the item has been deleted.
Declaration Syntax
C#
protected override void OnItemDeleted(
    DataContext context,
    ID id
)
Parameters
context (DataContext)
The context.
id (ID)
The id.


OnItemRenamed Method (context, id)

OnItemRenamed Method (context, id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem ► OnItemRenamed(DataContext, ID)
Called when the item has been renamed.
Declaration Syntax
C#
protected override void OnItemRenamed(
    DataContext context,
    ID id
)
Parameters
context (DataContext)
The context.
id (ID)
The id.


Template Property

Template Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem ► Template
Gets or sets the template.
Declaration Syntax
C#
public string Template { get; set; }
Value
The template.


Updated Property

Updated Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataListviewItem ► Updated
Gets or sets the updated.
Declaration Syntax
C#
public DateTime Updated { get; set; }
Value
The updated.


DataMemo Class

DataMemo Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataMemo
Represents a data-aware memo field.
Declaration Syntax
C#
public class DataMemo : Memo
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataMemo()()() | Initializes a new instance of the DataMemo class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event. (Inherited from Input.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Raises the Change event. (Inherited from Input.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Memo.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | FieldName | Gets or sets the name of the field.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Memo.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange | Called when the input is changed by the user. (Inherited from Input.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Memo.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether this instance is read only. (Inherited from Input.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag. (Inherited from Memo.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether modifications are tracked. (Inherited from Input.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Memo.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | Wrap | Gets or sets the wrap. (Inherited from Memo.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Input
 |  |  |  |  |  |  | Memo
 |  |  |  |  |  |  |  | DataMemo


DataMemo Constructor

DataMemo Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataMemo ► DataMemo()()()
Initializes a new instance of the DataMemo class
Declaration Syntax
C#
public DataMemo()


FieldName Property

FieldName Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataMemo ► FieldName
Gets or sets the name of the field.
Declaration Syntax
C#
public string FieldName { get; set; }
Value
The name of the field.


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataMemo ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


DataToolbar Class

DataToolbar Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolbar
Represents a toolbar that is generated from a data source.
Declaration Syntax
C#
public class DataToolbar : Toolbar
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataToolbar()()() | Initializes a new instance of the DataToolbar class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | Align | Gets or sets the align. (Inherited from Panel.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event. (Inherited from Panel.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the Double Click event. (Inherited from Panel.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from Panel.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the dblclick event. (Inherited from Panel.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Toolbar.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | IconSize | Gets or sets the size of the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InnerHtml | Gets or sets the inner HTML. (Inherited from Panel.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the panel is clicked. (Inherited from Panel.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDblClick | Called when the panel is double clicked. (Inherited from Panel.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Panel
 |  |  |  |  |  |  | Toolbar
 |  |  |  |  |  |  |  | DataToolbar


DataToolbar Constructor

DataToolbar Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolbar ► DataToolbar()()()
Initializes a new instance of the DataToolbar class.
Declaration Syntax
C#
public DataToolbar()


IconSize Property

IconSize Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolbar ► IconSize
Gets or sets the size of the icon.
Declaration Syntax
C#
public ImageDimension IconSize { get; set; }
Value
The size of the icon.


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolbar ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


DataToolbutton Class

DataToolbutton Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolbutton
Represents a toolbutton that loads its data from a data source.
Declaration Syntax
C#
public class DataToolbutton : Toolbutton
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataToolbutton()()() | Initializes a new instance of the DataToolbutton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the click. (Inherited from Button.)
 | ClickButton()()() | Clicks the button. (Inherited from Button.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click. (Inherited from Button.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Toolbutton.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from Button.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Toolbutton.)
 | Down | Gets or sets a value indicating whether this Toolbutton is down. (Inherited from Toolbutton.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | Glyph | Gets or sets the glyph. (Inherited from Toolbutton.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon. (Inherited from Toolbutton.)
 | IconSize | Gets or sets the size of the icon. (Inherited from Toolbutton.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code. (Inherited from Button.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadFromItem(Item) | Loads data from an item. (Inherited from Toolbutton.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | (Inherited from Button.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Button.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RadioGroup | Gets or sets the radio group. (Inherited from Toolbutton.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle | Gets or sets a value indicating whether this Toolbutton is a toggle button. (Inherited from Toolbutton.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Button
 |  |  |  |  |  |  |  | Toolbutton
 |  |  |  |  |  |  |  |  | DataToolbutton


DataToolbutton Constructor

DataToolbutton Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolbutton ► DataToolbutton()()()
Initializes a new instance of the DataToolbutton class
Declaration Syntax
C#
public DataToolbutton()


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolbutton ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


DataToolmenu Class

DataToolmenu Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolmenu
Represents a toolmenu that loads its items from a data source.
Declaration Syntax
C#
public class DataToolmenu : Toolmenu
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataToolmenu()()() | Initializes a new instance of the DataToolmenu class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddItems(Menu) | Adds the items. (Overrides Toolmenubutton.AddItems(Menu).)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the click. (Inherited from Button.)
 | ClickButton()()() | Clicks the button. (Inherited from Button.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click. (Inherited from Button.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Toolbutton.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from Toolmenubutton.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Toolbutton.)
 | Down | Gets or sets a value indicating whether this Toolbutton is down. (Inherited from Toolbutton.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | Glyph | Gets or sets the glyph. (Inherited from Toolbutton.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon. (Inherited from Toolbutton.)
 | IconSize | Gets or sets the size of the icon. (Inherited from Toolbutton.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code. (Inherited from Button.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadFromItem(Item) | Loads data from an item. (Inherited from Toolbutton.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | (Inherited from Button.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Toolmenubutton.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Toolmenubutton.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PopupControl | Gets or sets the popup control. (Inherited from Dropbutton.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RadioGroup | Gets or sets the radio group. (Inherited from Toolbutton.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | Target | Gets or sets the target.
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle | Gets or sets a value indicating whether this Toolbutton is a toggle button. (Inherited from Toolbutton.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Button
 |  |  |  |  |  |  |  | Toolbutton
 |  |  |  |  |  |  |  |  | Dropbutton
 |  |  |  |  |  |  |  |  |  | Toolmenubutton
 |  |  |  |  |  |  |  |  |  |  | Toolmenu
 |  |  |  |  |  |  |  |  |  |  |  | DataToolmenu
 |  |  |  |  |  |  |  |  |  |  |  |  | AutoToolmenu


DataToolmenu Constructor

DataToolmenu Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolmenu ► DataToolmenu()()()
Initializes a new instance of the DataToolmenu class
Declaration Syntax
C#
public DataToolmenu()


AddItems Method (menu)

AddItems Method (menu)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolmenu ► AddItems(Menu)
Adds the items.
Declaration Syntax
C#
protected override void AddItems(
    Menu menu
)
Parameters
menu (Menu)
The menu.


Target Property

Target Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolmenu ► Target
Gets or sets the target.
Declaration Syntax
C#
public string Target { get; set; }
Value
The target.


DataToolmenubutton Class

DataToolmenubutton Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolmenubutton
Represents a tool menu buttons that loads its items from a data source.
Declaration Syntax
C#
public class DataToolmenubutton : Toolmenubutton
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataToolmenubutton()()() | Initializes a new instance of the DataToolmenubutton class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddItems(Menu) | Adds the items. (Overrides Toolmenubutton.AddItems(Menu).)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the click. (Inherited from Button.)
 | ClickButton()()() | Clicks the button. (Inherited from Button.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click. (Inherited from Button.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Toolbutton.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from Toolmenubutton.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Toolbutton.)
 | Down | Gets or sets a value indicating whether this Toolbutton is down. (Inherited from Toolbutton.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | Glyph | Gets or sets the glyph. (Inherited from Toolbutton.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon. (Inherited from Toolbutton.)
 | IconSize | Gets or sets the size of the icon. (Inherited from Toolbutton.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code. (Inherited from Button.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadFromItem(Item) | Loads data from an item. (Inherited from Toolbutton.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | (Inherited from Button.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Toolmenubutton.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Toolmenubutton.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PopupControl | Gets or sets the popup control. (Inherited from Dropbutton.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RadioGroup | Gets or sets the radio group. (Inherited from Toolbutton.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | Target | Gets or sets the target.
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle | Gets or sets a value indicating whether this Toolbutton is a toggle button. (Inherited from Toolbutton.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Button
 |  |  |  |  |  |  |  | Toolbutton
 |  |  |  |  |  |  |  |  | Dropbutton
 |  |  |  |  |  |  |  |  |  | Toolmenubutton
 |  |  |  |  |  |  |  |  |  |  | DataToolmenubutton
 |  |  |  |  |  |  |  |  |  |  |  | AutoToolmenubutton


DataToolmenubutton Constructor

DataToolmenubutton Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolmenubutton ► DataToolmenubutton()()()
Initializes a new instance of the DataToolmenubutton class
Declaration Syntax
C#
public DataToolmenubutton()


AddItems Method (menu)

AddItems Method (menu)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolmenubutton ► AddItems(Menu)
Adds the items.
Declaration Syntax
C#
protected override void AddItems(
    Menu menu
)
Parameters
menu (Menu)
The menu.


Target Property

Target Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataToolmenubutton ► Target
Gets or sets the target.
Declaration Syntax
C#
public string Target { get; set; }
Value
The target.


DataTreecrumb Class

DataTreecrumb Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreecrumb
Represents a treecrumb.
Declaration Syntax
C#
public class DataTreecrumb : Treecrumb
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataTreecrumb()()() | Initializes a new instance of the DataTreecrumb class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddNode(Control, String, String, String, String, String) | Adds the node.
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildMenus | Gets or sets a value indicating whether the DataTreecrumb builds the menus.
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event. (Overrides Treecrumb.Click.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Treecrumb.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetItems()()() | Gets the items.
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | Glyph | Gets or sets the glyph. (Inherited from Treecrumb.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemsOnly | Gets or sets a value indicating whether the Treecrumb renders the items only. (Inherited from Treecrumb.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Treecrumb.OnLoad(EventArgs).)
 | OnPopup | Gets or sets the on popup event.
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Src | Gets or sets the SRC.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Treecrumb
 |  |  |  |  |  |  | DataTreecrumb


DataTreecrumb Constructor

DataTreecrumb Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreecrumb ► DataTreecrumb()()()
Initializes a new instance of the DataTreecrumb class.
Declaration Syntax
C#
public DataTreecrumb()


AddNode Method (node, itemID, id, header, icon, click)

AddNode Method (node, itemID, id, header, icon, click)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreecrumb ► AddNode(Control, String, String, String, String, String)
Adds the node.
Declaration Syntax
C#
protected TreecrumbNode AddNode(
    Control node,
    string itemID,
    string id,
    string header,
    string icon,
    string click
)
Parameters
node (Control)
The node.
itemID (String)
The item ID.
id (String)
The id.
header (String)
The header.
icon (String)
The icon.
click (String)
The click.
Return Value


BuildMenus Property

BuildMenus Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreecrumb ► BuildMenus
Gets or sets a value indicating whether the DataTreecrumb builds the menus.
Declaration Syntax
C#
public bool BuildMenus { get; set; }
Value
true if the DataTreecrumb builds the menus; otherwise, false.


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreecrumb ► Click
Gets or sets the Click event.
Declaration Syntax
C#
public override string Click { get; set; }
Value
The event to be executed.


GetItems Method

GetItems Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreecrumb ► GetItems()()()
Gets the items.
Declaration Syntax
C#
protected virtual void GetItems()


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreecrumb ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


OnPopup Property

OnPopup Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreecrumb ► OnPopup
Gets or sets the on popup event.
Declaration Syntax
C#
public string OnPopup { get; set; }
Value
The on popup event.


Src Property

Src Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreecrumb ► Src
Gets or sets the SRC.
Declaration Syntax
C#
public string Src { get; set; }
Value
The SRC.


DataTreeNode Class

DataTreeNode Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeNode
Represents a node in a treeview.
Declaration Syntax
C#
public class DataTreeNode : TreeNode
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataTreeNode()()() | Initializes a new instance of the DataTreeNode class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Check()()() | Checks this instance. (Inherited from TreeNode.)
 | Checked | Gets or sets a value indicating whether this TreeNode is checked. (Inherited from TreeNode.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ChildrenOnly | Gets or sets a value indicating whether the TreeNode renders the children only. (Inherited from TreeNode.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event. (Inherited from TreeNode.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Collapse(Control) | Collapses the specified control. (Overrides TreeNode.Collapse(Control).)
 | Collapse()()() | Collapses this instance. (Inherited from TreeNode.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnValues | Gets or sets the column values. (Inherited from TreeNode.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the Double Click event. (Inherited from TreeNode.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | Depth | Gets or sets the depth. (Inherited from TreeNode.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from TreeNode.)
 | Drag | Gets or sets the drag event.
 | DragSort | Gets or sets the drag sort.
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event.
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Expand()()() | Expands this instance. (Inherited from TreeNode.)
 | Expandable | Gets or sets a value indicating whether this TreeNode is expandable. (Inherited from TreeNode.)
 | Expanded | Gets or sets a value indicating whether this TreeNode is expanded. (Inherited from TreeNode.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetTreeview()()() | Gets the treeview. (Inherited from TreeNode.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from TreeNode.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon. (Inherited from TreeNode.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemID | Gets or sets the item ID.
 | ItemStyle | Gets or sets the item CSS style. (Inherited from TreeNode.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from TreeNode.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NodeOnly | Gets or sets a value indicating whether the TreeNode renders the node only. (Inherited from TreeNode.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Overrides Control.OnItemDeleted(DataContext, ID).)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Overrides Control.OnItemRenamed(DataContext, ID).)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Overrides Control.OnItemSaved(DataContext, ID).)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from TreeNode.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Selected | Gets or sets a value indicating whether this TreeNode is selected. (Inherited from TreeNode.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowCheckBox | Gets or sets a value indicating whether the TreeNode shows the check box. (Inherited from TreeNode.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle()()() | Toggles this instance. (Inherited from TreeNode.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | TreeNode
 |  |  |  |  |  |  |  | DataTreeNode


DataTreeNode Constructor

DataTreeNode Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeNode ► DataTreeNode()()()
Initializes a new instance of the DataTreeNode class
Declaration Syntax
C#
public DataTreeNode()


Collapse Method (control)

Collapse Method (control)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeNode ► Collapse(Control)
Collapses the specified control.
Declaration Syntax
C#
protected override void Collapse(
    Control control
)
Parameters
control (Control)
The control.


Drag Property

Drag Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeNode ► Drag
Gets or sets the drag event.
Declaration Syntax
C#
public string Drag { get; set; }
Value
The drag event.


DragSort Property

DragSort Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeNode ► DragSort
Gets or sets the drag sort.
Declaration Syntax
C#
public string DragSort { get; set; }
Value
The drag sort.


Drop Property

Drop Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeNode ► Drop
Gets or sets the drop event.
Declaration Syntax
C#
public string Drop { get; set; }
Value
The drop event.


ItemID Property

ItemID Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeNode ► ItemID
Gets or sets the item ID.
Declaration Syntax
C#
public string ItemID { get; set; }
Value
The item ID.


OnItemDeleted Method (context, id)

OnItemDeleted Method (context, id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeNode ► OnItemDeleted(DataContext, ID)
Called when the item has deleted.
Declaration Syntax
C#
protected override void OnItemDeleted(
    DataContext context,
    ID id
)
Parameters
context (DataContext)
The context.
id (ID)
The id.


OnItemRenamed Method (context, id)

OnItemRenamed Method (context, id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeNode ► OnItemRenamed(DataContext, ID)
Called when the item has renamed.
Declaration Syntax
C#
protected override void OnItemRenamed(
    DataContext context,
    ID id
)
Parameters
context (DataContext)
The context.
id (ID)
The id.


OnItemSaved Method (context, id)

OnItemSaved Method (context, id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeNode ► OnItemSaved(DataContext, ID)
Called when the item has saved.
Declaration Syntax
C#
protected override void OnItemSaved(
    DataContext context,
    ID id
)
Parameters
context (DataContext)
The context.
id (ID)
The id.


DataTreeview Class

DataTreeview Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview
Displays hierarchical data, such as a table of contents, in a tree structure.
Declaration Syntax
C#
public class DataTreeview : Treeview
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataTreeview()()() | Initializes a new instance of the DataTreeview class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddChecked(String) | Adds the node with the specified id to the checked set. (Inherited from Treeview.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddSelected(String) | Adds the node with the specified id to the selected set. (Inherited from Treeview.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | AllowDragging | Gets or sets a value indicating whether the DataTreeview allows the dragging.
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoUpdateDataContext | Gets or sets a value indicating whether the DataTreeview automatically updates the data context.
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Checked | Gets the checked nodes. (Inherited from Treeview.)
 | CheckParents | Gets or sets a value indicating whether the Treeview checks off the parents. (Inherited from Treeview.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChecked()()() | Clears the checked nodes. (Inherited from Treeview.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearNodes()()() | Clears the nodes. (Inherited from Treeview.)
 | ClearSelection()()() | Clears the selection. (Inherited from Treeview.)
 | Click | Gets or sets the click. (Inherited from Treeview.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Collapse(TreeNode) | Collapses the specified node. (Inherited from Treeview.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnNames | Gets or sets the column names. (Inherited from Treeview.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click. (Inherited from Treeview.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | Depth | Gets or sets the depth. (Inherited from Treeview.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableEvents()()() | Disables the events.
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from Treeview.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the dblclick event. (Inherited from Treeview.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Treeview.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Treeview.)
 | Drag | Gets or sets the drag event. (Inherited from Treeview.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event. (Inherited from Treeview.)
 | DropItem(String) | Handles a drop event.
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableEvents()()() | Enables the events.
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Expand(TreeNode, Boolean) | Expands the specified node. (Overrides Treeview.Expand(TreeNode, Boolean).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | FindNode(String) | Finds the node. (Inherited from Treeview.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetContextMenu()()() | Gets the context menu.
 | GetContextMenu(String) | Gets the context menu.
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetNewMenu(String) | Gets the new menu.
 | GetNodeByItemID(String) | Gets the node by long item ID.
 | GetSelectionItem()()() | Gets the selection item.
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetTreeNode(Item, Control) | Gets the tree node.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | IgnoreSorting | Gets or sets a value indicating whether the DataTreeview ignores sorting.
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemsOnly | Gets or sets a value indicating whether the Treeview only renders the items and not the header. (Inherited from Treeview.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | MultiSelect | Gets or sets a value indicating whether the Treeview allows multiselection. (Inherited from Treeview.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NodeClicked(Message, TreeNode) | Handles a click on the node. (Overrides Treeview.NodeClicked(Message, TreeNode).)
 | Nodes | Gets the nodes. (Inherited from Treeview.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the treeview is clicked. (Inherited from Treeview.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context has changed. (Overrides Control.OnDataContextChanged(DataContext).)
 | OnDblClick | Called when the treeview is double clicked. (Inherited from Treeview.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Treeview.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Treeview.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Populate(Control, Int32) | Populates the specified control.
 | Populate(Control, DataContext) | Populates the specified control.
 | Populate(DataContext, Control, Item, Item, String) | Populates the specified data context.
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | Refresh()()() | Refreshes this instance.
 | Refresh(TreeNode) | Refreshes the specified node.
 | Refresh(String) | Refreshes the specified id.
 | Refresh(ID) | Refreshes the specified id.
 | RefreshNode(TreeNode) | Refreshes the node.
 | RefreshRoot()()() | Refreshes the root.
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | Root | Obsolete. Gets or sets a value indicating whether this DataTreeview shows the root.
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Selected | Gets the selected nodes. (Inherited from Treeview.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowCheckboxes | Gets or sets a value indicating whether the Treeview shows the checkboxes. (Inherited from Treeview.)
 | ShowRoot | Gets or sets a value indicating whether the DataTreeview shows the root.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle(String) | Toggles the node with the specified id. (Inherited from Treeview.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Treeview
 |  |  |  |  |  |  | DataTreeview
 |  |  |  |  |  |  |  | AccessViewerTreeview
 |  |  |  |  |  |  |  | ContentTreeview
 |  |  |  |  |  |  |  | RenderingTreeview
 |  |  |  |  |  |  |  | SecurityTreeview
 |  |  |  |  |  |  |  | TranslatorTreeview


DataTreeview Constructor

DataTreeview Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► DataTreeview()()()
Initializes a new instance of the DataTreeview class.
Declaration Syntax
C#
public DataTreeview()


AllowDragging Property

AllowDragging Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► AllowDragging
Gets or sets a value indicating whether the DataTreeview allows the dragging.
Declaration Syntax
C#
public bool AllowDragging { get; set; }
Value
true if DataTreeviewallows the dragging; otherwise, false.


AutoUpdateDataContext Property

AutoUpdateDataContext Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► AutoUpdateDataContext
Gets or sets a value indicating whether the DataTreeview automatically updates the data context.
Declaration Syntax
C#
public bool AutoUpdateDataContext { get; set; }
Value
true if DataTreeview automatically updates the data context; otherwise, false.


DisableEvents Method

DisableEvents Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► DisableEvents()()()
Disables the events.
Declaration Syntax
C#
public void DisableEvents()


DropItem Method (data)

DropItem Method (data)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► DropItem(String)
Handles a drop event.
Declaration Syntax
C#
protected virtual void DropItem(
    string data
)
Parameters
data (String)
The data.


EnableEvents Method

EnableEvents Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► EnableEvents()()()
Enables the events.
Declaration Syntax
C#
public void EnableEvents()


Expand Method (node, refresh)

Expand Method (node, refresh)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► Expand(TreeNode, Boolean)
Expands the specified node.
Declaration Syntax
C#
protected override void Expand(
    TreeNode node,
    bool refresh
)
Parameters
node (TreeNode)
The node.
refresh (Boolean)
if set to true this instance is refresh.


GetContextMenu Method

GetContextMenu Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► GetContextMenu()()()
Members
Icon | Member | Description
 | GetContextMenu()()() | Gets the context menu.
 | GetContextMenu(String) | Gets the context menu.


GetContextMenu Method

GetContextMenu Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► GetContextMenu()()()
Gets the context menu.
Declaration Syntax
C#
protected virtual void GetContextMenu()


GetContextMenu Method (where)

GetContextMenu Method (where)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► GetContextMenu(String)
Gets the context menu.
Declaration Syntax
C#
protected virtual void GetContextMenu(
    string where
)
Parameters
where (String)
The position.


GetNewMenu Method (id)

GetNewMenu Method (id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► GetNewMenu(String)
Gets the new menu.
Declaration Syntax
C#
protected virtual void GetNewMenu(
    string id
)
Parameters
id (String)
The id.


GetNodeByItemID Method (id)

GetNodeByItemID Method (id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► GetNodeByItemID(String)
Gets the node by long item ID.
Declaration Syntax
C#
public TreeNode GetNodeByItemID(
    string id
)
Parameters
id (String)
The id.
Return Value
The node by item ID.
Remarks
Please note that the method accepts long item id


GetSelectionItem Method

GetSelectionItem Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► GetSelectionItem()()()
Gets the selection item.
Declaration Syntax
C#
public Item GetSelectionItem()
Return Value


GetTreeNode Method (item, parent)

GetTreeNode Method (item, parent)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► GetTreeNode(Item, Control)
Gets the tree node.
Declaration Syntax
C#
protected virtual TreeNode GetTreeNode(
    Item item,
    Control parent
)
Parameters
item (Item)
The item.
parent (Control)
The parent.
Return Value


IgnoreSorting Property

IgnoreSorting Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► IgnoreSorting
Gets or sets a value indicating whether the DataTreeview ignores sorting.
Declaration Syntax
C#
public bool IgnoreSorting { get; set; }
Value
true if DataTreeviewignores sorting; otherwise, false.


NodeClicked Method (message, node)

NodeClicked Method (message, node)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► NodeClicked(Message, TreeNode)
Handles a click on the node.
Declaration Syntax
C#
protected override void NodeClicked(
    Message message,
    TreeNode node
)
Parameters
message (Message)
The message.
node (TreeNode)
The node.


OnDataContextChanged Method (dataContext)

OnDataContextChanged Method (dataContext)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► OnDataContextChanged(DataContext)
Called when the data context has changed.
Declaration Syntax
C#
protected override void OnDataContextChanged(
    DataContext dataContext
)
Parameters
dataContext (DataContext)
The data context.


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


Populate Method

Populate Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► Populate()()()
Members
Icon | Member | Description
 | Populate(Control, Int32) | Populates the specified control.
 | Populate(Control, DataContext) | Populates the specified control.
 | Populate(DataContext, Control, Item, Item, String) | Populates the specified data context.


Populate Method (dataContext, control, root, folder, selectedIDs)

Populate Method (dataContext, control, root, folder, selectedIDs)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► Populate(DataContext, Control, Item, Item, String)
Populates the specified data context.
Declaration Syntax
C#
protected virtual void Populate(
    DataContext dataContext,
    Control control,
    Item root,
    Item folder,
    string selectedIDs
)
Parameters
dataContext (DataContext)
The data context.
control (Control)
The control.
root (Item)
The root.
folder (Item)
The folder.
selectedIDs (String)
The selected Ids.


Populate Method (control, dataContext)

Populate Method (control, dataContext)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► Populate(Control, DataContext)
Populates the specified control.
Declaration Syntax
C#
protected virtual Control Populate(
    Control control,
    DataContext dataContext
)
Parameters
control (Control)
The control.
dataContext (DataContext)
The data context.
Return Value


Populate Method (control, depth)

Populate Method (control, depth)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► Populate(Control, Int32)
Populates the specified control.
Declaration Syntax
C#
protected virtual Control Populate(
    Control control,
    int depth
)
Parameters
control (Control)
The control.
depth (Int32)
The depth.
Return Value


Refresh Method

Refresh Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► Refresh()()()
Members
Icon | Member | Description
 | Refresh()()() | Refreshes this instance.
 | Refresh(TreeNode) | Refreshes the specified node.
 | Refresh(String) | Refreshes the specified id.
 | Refresh(ID) | Refreshes the specified id.


Refresh Method

Refresh Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► Refresh()()()
Refreshes this instance.
Declaration Syntax
C#
public void Refresh()


Refresh Method (id)

Refresh Method (id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► Refresh(ID)
Refreshes the specified id.
Declaration Syntax
C#
protected void Refresh(
    ID id
)
Parameters
id (ID)
The id.


Refresh Method (node)

Refresh Method (node)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► Refresh(TreeNode)
Refreshes the specified node.
Declaration Syntax
C#
public virtual void Refresh(
    TreeNode node
)
Parameters
node (TreeNode)
The node.


Refresh Method (id)

Refresh Method (id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► Refresh(String)
Refreshes the specified id.
Declaration Syntax
C#
protected virtual void Refresh(
    string id
)
Parameters
id (String)
The id.


RefreshNode Method (node)

RefreshNode Method (node)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► RefreshNode(TreeNode)
Refreshes the node.
Declaration Syntax
C#
public virtual void RefreshNode(
    TreeNode node
)
Parameters
node (TreeNode)
The node.


RefreshRoot Method

RefreshRoot Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► RefreshRoot()()()
Refreshes the root.
Declaration Syntax
C#
public void RefreshRoot()


Root Property

Root Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► Root
Gets or sets a value indicating whether this DataTreeview shows the root.
Declaration Syntax
C#
[ObsoleteAttribute("Use the ShowRoot property instead")]
public bool Root { get; set; }
Value
true if the root is shown; otherwise, false.


ShowRoot Property

ShowRoot Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataTreeview ► ShowRoot
Gets or sets a value indicating whether the DataTreeview shows the root.
Declaration Syntax
C#
public bool ShowRoot { get; set; }
Value
true if DataTreeviewshows the root; otherwise, false.


DataViewBase Class

DataViewBase Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase
Declaration Syntax
C#
public abstract class DataViewBase : IDataView,
    IComparer
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataViewBase()()() | Initializes a new instance of the DataViewBase class
 | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterItems(ArrayList%, String) | Filters the items.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildItems(ItemCollection, Item) | Gets the child items.
 | GetChildren(Item, String, Boolean, Int32, Int32, String) | Gets the children.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(String) | Gets the item.
 | GetItem(String, Language, Version) | Gets the item.
 | GetItemFromID(String, Language, Version) | Gets the item from ID.
 | GetParent(Item) | Gets the parent.
 | GetParentItem(Item) | Gets the parent item.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildren(Item, String) | Determines whether the specified item has children.
 | Initialize(String) | Initializes the view from a data context.
 | IsAncestorOf(Item, Item) | Determines whether the ancestor is an ancestor of the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets the parameters.
 | SortItems(ArrayList, String, Boolean) | Sorts the items.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataViewBase
 |  | DomainDataView
 |  | FileSystemDataView
 |  | MasterDataView
 |  | StandardTreeDataView


DataViewBase Constructor

DataViewBase Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► DataViewBase()()()
Initializes a new instance of the DataViewBase class
Declaration Syntax
C#
protected DataViewBase()


Compare Method (x, y)

Compare Method (x, y)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► Compare(Object, Object)
Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Declaration Syntax
C#
public int Compare(
    Object x,
    Object y
)
Parameters
x (Object)
The first object to compare.
y (Object)
The second object to compare.
Return Value
Value Condition Less than zero x is less than y. Zero x equals y. Greater than zero x is greater than y.
Exceptions
Exception | Condition
ArgumentException | Neither x nor y implements the IComparable interface.-or- x and y are of different types and neither one can handle comparisons with the other.


FilterItems Method (children, filter)

FilterItems Method (children, filter)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► FilterItems(ArrayList%, String)
Filters the items.
Declaration Syntax
C#
protected virtual void FilterItems(
    ref ArrayList children,
    string filter
)
Parameters
children ( ArrayList %)
The children.
filter (String)
The filter.


GetChildItems Method (items, item)

GetChildItems Method (items, item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► GetChildItems(ItemCollection, Item)
Gets the child items.
Declaration Syntax
C#
protected virtual void GetChildItems(
    ItemCollection items,
    Item item
)
Parameters
items (ItemCollection)
The items.
item (Item)
The item.


GetChildren Method (item, sortBy, sortAscending, offset, range, filter)

GetChildren Method (item, sortBy, sortAscending, offset, range, filter)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► GetChildren(Item, String, Boolean, Int32, Int32, String)
Gets the children.
Declaration Syntax
C#
public ItemCollection GetChildren(
    Item item,
    string sortBy,
    bool sortAscending,
    int offset,
    int range,
    string filter
)
Parameters
item (Item)
The item.
sortBy (String)
The sort by.
sortAscending (Boolean)
if set to true sorts the children ascending.
offset (Int32)
The offset.
range (Int32)
The range.
filter (String)
The filter.
Return Value


GetItem Method

GetItem Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► GetItem()()()
Members
Icon | Member | Description
 | GetItem(String) | Gets the item.
 | GetItem(String, Language, Version) | Gets the item.


GetItem Method (id)

GetItem Method (id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► GetItem(String)
Gets the item.
Declaration Syntax
C#
public Item GetItem(
    string id
)
Parameters
id (String)
The id.
Return Value


GetItem Method (id, language, version)

GetItem Method (id, language, version)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► GetItem(String, Language, Version)
Gets the item.
Declaration Syntax
C#
public Item GetItem(
    string id,
    Language language,
    Version version
)
Parameters
id (String)
The id.
language (Language)
The language.
version (Version)
The version.
Return Value


GetItemFromID Method (id, language, version)

GetItemFromID Method (id, language, version)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► GetItemFromID(String, Language, Version)
Gets the item from ID.
Declaration Syntax
C#
protected virtual Item GetItemFromID(
    string id,
    Language language,
    Version version
)
Parameters
id (String)
The id.
language (Language)
The language.
version (Version)
The version.
Return Value


GetParent Method (item)

GetParent Method (item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► GetParent(Item)
Gets the parent.
Declaration Syntax
C#
public Item GetParent(
    Item item
)
Parameters
item (Item)
The item.
Return Value


GetParentItem Method (item)

GetParentItem Method (item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► GetParentItem(Item)
Gets the parent item.
Declaration Syntax
C#
protected virtual Item GetParentItem(
    Item item
)
Parameters
item (Item)
The item.
Return Value


HasChildren Method (item, filter)

HasChildren Method (item, filter)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► HasChildren(Item, String)
Determines whether the specified item has children.
Declaration Syntax
C#
public virtual bool HasChildren(
    Item item,
    string filter
)
Parameters
item (Item)
The item.
filter (String)
The filter.
Return Value
true if the specified item has children; otherwise, false.


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► Initialize(String)
Initializes the view from a data context.
Declaration Syntax
C#
public virtual void Initialize(
    string parameters
)
Parameters
parameters (String)
The parameters.


IsAncestorOf Method (ancestor, item)

IsAncestorOf Method (ancestor, item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► IsAncestorOf(Item, Item)
Determines whether the ancestor is an ancestor of the item.
Declaration Syntax
C#
public virtual bool IsAncestorOf(
    Item ancestor,
    Item item
)
Parameters
ancestor (Item)
The ancestor.
item (Item)
The item.
Return Value
true if the ancestor is an ancestor of the item; otherwise, false.


Parameters Property

Parameters Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► Parameters
Gets the parameters.
Declaration Syntax
C#
public string Parameters { get; }
Value
The parameters.


SortItems Method (children, sortBy, sortAscending)

SortItems Method (children, sortBy, sortAscending)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DataViewBase ► SortItems(ArrayList, String, Boolean)
Sorts the items.
Declaration Syntax
C#
protected virtual void SortItems(
    ArrayList children,
    string sortBy,
    bool sortAscending
)
Parameters
children (ArrayList)
The children.
sortBy (String)
The sort by.
sortAscending (Boolean)
if set to true [sort ascending].


DateCalendar Class

DateCalendar Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar
Represents a data aware calendar.
Declaration Syntax
C#
public class DateCalendar : Input
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DateCalendar()()() | Initializes a new instance of the DateCalendar class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event. (Inherited from Input.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Current | Gets or sets the current date and time.
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DateTime | Gets or sets the date and time.
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Raises the Change event. (Inherited from Input.)
 | DoClick(Message) | Executes the click event.
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NextMonth | Called when the next month button is clicked.
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange | Called when the input is changed by the user. (Inherited from Input.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnNextMonth()()() | Called when the next month button is clicked.
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Control.OnPreRender(EventArgs).)
 | OnPreviousMonth()()() | Called when the previous month button is clicked.
 | OnSelect()()() | Called when a date is selected.
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviousMonth | Called when the previous month button is clicked.
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether this instance is read only. (Inherited from Input.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Select | Called when a date is selected.
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag. (Inherited from Input.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowDays | Gets or sets a value indicating whether the DateCalendar shows the days.
 | ShowToday | Gets or sets a value indicating whether the DateCalendar shows today.
 | ShowYear | Gets or sets a value indicating whether the DateCalendar shows the year.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether modifications are tracked. (Inherited from Input.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Update(Boolean) | Updates the control.
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Input
 |  |  |  |  |  |  | DateCalendar
 |  |  |  |  |  |  |  | DateCalendarPopup


DateCalendar Constructor

DateCalendar Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► DateCalendar()()()
Initializes a new instance of the DateCalendar class.
Declaration Syntax
C#
public DateCalendar()


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► Click
Gets or sets the Click event.
Declaration Syntax
C#
public string Click { get; set; }
Value
The event to be executed.


Current Property

Current Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► Current
Gets or sets the current date and time.
Declaration Syntax
C#
protected DateTime Current { get; set; }
Value
The current date and time.


DateTime Property

DateTime Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► DateTime
Gets or sets the date and time.
Declaration Syntax
C#
public DateTime DateTime { get; set; }
Value
The date and time.


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected virtual void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


NextMonth Event

NextMonth Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► NextMonth
Called when the next month button is clicked.
Declaration Syntax
C#
public event EventHandler NextMonth


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


OnNextMonth Method

OnNextMonth Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► OnNextMonth()()()
Called when the next month button is clicked.
Declaration Syntax
C#
protected virtual void OnNextMonth()


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


OnPreviousMonth Method

OnPreviousMonth Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► OnPreviousMonth()()()
Called when the previous month button is clicked.
Declaration Syntax
C#
protected virtual void OnPreviousMonth()


OnSelect Method

OnSelect Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► OnSelect()()()
Called when a date is selected.
Declaration Syntax
C#
protected virtual void OnSelect()


PreviousMonth Event

PreviousMonth Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► PreviousMonth
Called when the previous month button is clicked.
Declaration Syntax
C#
public event EventHandler PreviousMonth


Select Event

Select Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► Select
Called when a date is selected.
Declaration Syntax
C#
public event EventHandler Select


ShowDays Property

ShowDays Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► ShowDays
Gets or sets a value indicating whether the DateCalendar shows the days.
Declaration Syntax
C#
public bool ShowDays { get; set; }
Value
true if the DateCalendar shows the days; otherwise, false.


ShowToday Property

ShowToday Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► ShowToday
Gets or sets a value indicating whether the DateCalendar shows today.
Declaration Syntax
C#
public bool ShowToday { get; set; }
Value
true if the DateCalendar shows today; otherwise, false.


ShowYear Property

ShowYear Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► ShowYear
Gets or sets a value indicating whether the DateCalendar shows the year.
Declaration Syntax
C#
public bool ShowYear { get; set; }
Value
true if the DateCalendar shows the year; otherwise, false.


Update Method (selected)

Update Method (selected)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendar ► Update(Boolean)
Updates the control.
Declaration Syntax
C#
protected virtual void Update(
    bool selected
)
Parameters
selected (Boolean)
if set to true this instance is selected.


DateCalendarPopup Class

DateCalendarPopup Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendarPopup
Represents a data-aware popup calendar.
Declaration Syntax
C#
public class DateCalendarPopup : DateCalendar
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DateCalendarPopup()()() | Initializes a new instance of the DateCalendarPopup class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event. (Inherited from Input.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event. (Inherited from DateCalendar.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Current | Gets or sets the current date and time. (Inherited from DateCalendar.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DateTime | Gets or sets the date and time. (Inherited from DateCalendar.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Raises the Change event. (Inherited from Input.)
 | DoClick(Message) | Executes the click event. (Inherited from DateCalendar.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from DateCalendar.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NextMonth | Called when the next month button is clicked. (Inherited from DateCalendar.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange | Called when the input is changed by the user. (Inherited from Input.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from DateCalendar.)
 | OnNextMonth()()() | Called when the next month button is clicked. (Inherited from DateCalendar.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from DateCalendar.)
 | OnPreviousMonth()()() | Called when the previous month button is clicked. (Inherited from DateCalendar.)
 | OnSelect()()() | Called when a date is selected. (Inherited from DateCalendar.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviousMonth | Called when the previous month button is clicked. (Inherited from DateCalendar.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether this instance is read only. (Inherited from Input.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Select | Called when a date is selected. (Inherited from DateCalendar.)
 | SendOnClose | Gets or sets the message to send on close.
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag. (Inherited from Input.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowDays | Gets or sets a value indicating whether the DateCalendar shows the days. (Inherited from DateCalendar.)
 | ShowToday | Gets or sets a value indicating whether the DateCalendar shows today. (Inherited from DateCalendar.)
 | ShowYear | Gets or sets a value indicating whether the DateCalendar shows the year. (Inherited from DateCalendar.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether modifications are tracked. (Inherited from Input.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Update(Boolean) | Updates the control. (Overrides DateCalendar.Update(Boolean).)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Input
 |  |  |  |  |  |  | DateCalendar
 |  |  |  |  |  |  |  | DateCalendarPopup


DateCalendarPopup Constructor

DateCalendarPopup Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendarPopup ► DateCalendarPopup()()()
Initializes a new instance of the DateCalendarPopup class
Declaration Syntax
C#
public DateCalendarPopup()


SendOnClose Property

SendOnClose Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendarPopup ► SendOnClose
Gets or sets the message to send on close.
Declaration Syntax
C#
public string SendOnClose { get; set; }
Value
The message to send on close.


Update Method (selected)

Update Method (selected)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateCalendarPopup ► Update(Boolean)
Updates the control.
Declaration Syntax
C#
protected override void Update(
    bool selected
)
Parameters
selected (Boolean)
if set to true this instance is selected.


DatePicker Class

DatePicker Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DatePicker
Represents a Date picker.
Declaration Syntax
C#
public class DatePicker : ComboboxBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatePicker()()() | Initializes a new instance of the DatePicker class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event. (Inherited from Input.)
 | Changed()()() | Called when the combobox has changed. (Overrides ComboboxBase.Changed()()().)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click()()() | Handles a click event. (Inherited from ComboboxBase.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Raises the Change event. (Inherited from Input.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from ComboboxBase.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | DropDown()()() | Called when the dropdown glyph is clicked. (Overrides ComboboxBase.DropDown()()().)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | Format | Gets or sets the format.
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetDisplayValue()()() | Gets the display value. (Overrides ComboboxBase.GetDisplayValue()()().)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | Glyph | Gets or sets the glyph. (Inherited from ComboboxBase.)
 | HandleMessage(Message) | Handles the message. (Overrides Control.HandleMessage(Message).)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Overrides ComboboxBase.LoadPostData(String).)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange | Called when the input is changed by the user. (Inherited from Input.)
 | OnChanged | Called when the date picker is changed.
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether this instance is read only. (Inherited from Input.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SelectOnly | Gets or sets a value indicating whether the ComboboxBase is select-only. (Inherited from ComboboxBase.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag. (Inherited from Input.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether modifications are tracked. (Inherited from Input.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from ComboboxBase.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Input
 |  |  |  |  |  |  | ComboboxBase
 |  |  |  |  |  |  |  | DatePicker


DatePicker Constructor

DatePicker Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DatePicker ► DatePicker()()()
Initializes a new instance of the DatePicker class.
Declaration Syntax
C#
public DatePicker()


Changed Method

Changed Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DatePicker ► Changed()()()
Called when the combobox has changed.
Declaration Syntax
C#
protected override void Changed()


DropDown Method

DropDown Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DatePicker ► DropDown()()()
Called when the dropdown glyph is clicked.
Declaration Syntax
C#
protected override void DropDown()


Format Property

Format Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DatePicker ► Format
Gets or sets the format.
Declaration Syntax
C#
public string Format { get; set; }
Value
The format.


GetDisplayValue Method

GetDisplayValue Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DatePicker ► GetDisplayValue()()()
Gets the display value.
Declaration Syntax
C#
protected override string GetDisplayValue()
Return Value
The value in display format.


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DatePicker ► HandleMessage(Message)
Handles the message.
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)
The message.


LoadPostData Method (value)

LoadPostData Method (value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DatePicker ► LoadPostData(String)
Loads the post data.
Declaration Syntax
C#
protected override bool LoadPostData(
    string value
)
Parameters
value (String)
The value.
Return Value


OnChanged Event

OnChanged Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► DatePicker ► OnChanged
Called when the date picker is changed.
Declaration Syntax
C#
public event EventHandler OnChanged


DateTimePicker Class

DateTimePicker Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateTimePicker
Represents a Date time picker.
Declaration Syntax
C#
public class DateTimePicker : Border
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DateTimePicker()()() | Initializes a new instance of the DateTimePicker class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Changed | Occurs when date or time changes as a results of user input.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the click. (Inherited from Border.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Date | Gets or sets the date.
 | DblClick | Gets or sets the double click. (Inherited from Border.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from Border.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the DblClick event. (Inherited from Border.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Overrides Border.DoRender(HtmlTextWriter).)
 | Drag | Gets or sets the drag event. (Inherited from Border.)
 | DragOverCursor | Gets or sets the drag over cursor. (Inherited from Border.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event. (Inherited from Border.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from Border.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InnerHtml | Gets or sets the inner HTML. (Inherited from Border.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChanged()()() | Called when this instance has changed.
 | OnClick | Called when the control is clicked. (Inherited from Border.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDblClick | Called when the control is double clicked. (Inherited from Border.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Overrides Control.OnInit(EventArgs).)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowTime | Gets or sets a value indicating whether the DateTimePicker shows the time.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Time | Gets or sets the time.
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Overrides Control.Value.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from Border.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Border
 |  |  |  |  |  |  | DateTimePicker


DateTimePicker Constructor

DateTimePicker Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateTimePicker ► DateTimePicker()()()
Initializes a new instance of the DateTimePicker class
Declaration Syntax
C#
public DateTimePicker()


Changed Event

Changed Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateTimePicker ► Changed
Occurs when date or time changes as a results of user input.
Declaration Syntax
C#
public event EventHandler Changed


Date Property

Date Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateTimePicker ► Date
Gets or sets the date.
Declaration Syntax
C#
public string Date { get; set; }
Value
The date.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateTimePicker ► DoRender(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


OnChanged Method

OnChanged Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateTimePicker ► OnChanged()()()
Called when this instance has changed.
Declaration Syntax
C#
protected void OnChanged()


OnInit Method (e)

OnInit Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateTimePicker ► OnInit(EventArgs)
Raises the Init event.
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


ShowTime Property

ShowTime Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateTimePicker ► ShowTime
Gets or sets a value indicating whether the DateTimePicker shows the time.
Declaration Syntax
C#
public bool ShowTime { get; set; }
Value
true if the DateTimePicker shows the time; otherwise, false.


Time Property

Time Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateTimePicker ► Time
Gets or sets the time.
Declaration Syntax
C#
public string Time { get; set; }
Value
The time.


Value Property

Value Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► DateTimePicker ► Value
Gets or sets the value.
Declaration Syntax
C#
public override string Value { get; set; }
Value
The value.


DomainDataView Class

DomainDataView Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► DomainDataView
Represents a DomainDataView.
Declaration Syntax
C#
public class DomainDataView : DataViewBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DomainDataView()()() | Initializes a new instance of the DomainDataView class
 | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from DataViewBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterItems(ArrayList%, String) | Filters the items. (Inherited from DataViewBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildItems(ItemCollection, Item) | Gets the child items. (Overrides DataViewBase.GetChildItems(ItemCollection, Item).)
 | GetChildren(Item, String, Boolean, Int32, Int32, String) | Gets the children. (Inherited from DataViewBase.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(String) | Gets the item. (Inherited from DataViewBase.)
 | GetItem(String, Language, Version) | Gets the item. (Inherited from DataViewBase.)
 | GetItemFromID(String, Language, Version) | Gets the item from ID. (Overrides DataViewBase.GetItemFromID(String, Language, Version).)
 | GetParent(Item) | Gets the parent. (Inherited from DataViewBase.)
 | GetParentItem(Item) | Gets the parent item. (Overrides DataViewBase.GetParentItem(Item).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildren(Item, String) | Determines whether the specified item has children. (Inherited from DataViewBase.)
 | Initialize(String) | Initializes the view from a data context. (Overrides DataViewBase.Initialize(String).)
 | IsAncestorOf(Item, Item) | Determines whether the ancestor is an ancestor of the item. (Overrides DataViewBase.IsAncestorOf(Item, Item).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets the parameters. (Inherited from DataViewBase.)
 | SortItems(ArrayList, String, Boolean) | Sorts the items. (Inherited from DataViewBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataViewBase
 |  | DomainDataView


DomainDataView Constructor

DomainDataView Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► DomainDataView ► DomainDataView()()()
Initializes a new instance of the DomainDataView class
Declaration Syntax
C#
public DomainDataView()


GetChildItems Method (items, item)

GetChildItems Method (items, item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DomainDataView ► GetChildItems(ItemCollection, Item)
Gets the child items.
Declaration Syntax
C#
protected override void GetChildItems(
    ItemCollection items,
    Item item
)
Parameters
items (ItemCollection)
The items.
item (Item)
The item.


GetItemFromID Method (id, language, version)

GetItemFromID Method (id, language, version)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DomainDataView ► GetItemFromID(String, Language, Version)
Gets the item from ID.
Declaration Syntax
C#
protected override Item GetItemFromID(
    string id,
    Language language,
    Version version
)
Parameters
id (String)
The id.
language (Language)
The language.
version (Version)
The version.
Return Value


GetParentItem Method (item)

GetParentItem Method (item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DomainDataView ► GetParentItem(Item)
Gets the parent item.
Declaration Syntax
C#
protected override Item GetParentItem(
    Item item
)
Parameters
item (Item)
The item.
Return Value


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DomainDataView ► Initialize(String)
Initializes the view from a data context.
Declaration Syntax
C#
public override void Initialize(
    string parameters
)
Parameters
parameters (String)
The parameters.


IsAncestorOf Method (ancestor, item)

IsAncestorOf Method (ancestor, item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► DomainDataView ► IsAncestorOf(Item, Item)
Determines whether the ancestor is an ancestor of the item.
Declaration Syntax
C#
public override bool IsAncestorOf(
    Item ancestor,
    Item item
)
Parameters
ancestor (Item)
The ancestor.
item (Item)
The item.
Return Value
true if the ancestor is an ancestor of the item; otherwise, false.


Dropbutton Class

Dropbutton Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Dropbutton
Represents a toolbutton that shows a popup.
Declaration Syntax
C#
public class Dropbutton : Toolbutton
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Dropbutton()()() | Initializes a new instance of the Dropbutton class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the click. (Inherited from Button.)
 | ClickButton()()() | Clicks the button. (Inherited from Button.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click. (Inherited from Button.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Toolbutton.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from Button.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Inherited from Toolbutton.)
 | Down | Gets or sets a value indicating whether this Toolbutton is down. (Inherited from Toolbutton.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | Glyph | Gets or sets the glyph. (Inherited from Toolbutton.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon. (Inherited from Toolbutton.)
 | IconSize | Gets or sets the size of the icon. (Inherited from Toolbutton.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code. (Inherited from Button.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadFromItem(Item) | Loads data from an item. (Inherited from Toolbutton.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | (Inherited from Button.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Button.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PopupControl | Gets or sets the popup control.
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RadioGroup | Gets or sets the radio group. (Inherited from Toolbutton.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle | Gets or sets a value indicating whether this Toolbutton is a toggle button. (Inherited from Toolbutton.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Button
 |  |  |  |  |  |  |  | Toolbutton
 |  |  |  |  |  |  |  |  | Dropbutton
 |  |  |  |  |  |  |  |  |  | Toolmenubutton


Dropbutton Constructor

Dropbutton Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Dropbutton ► Dropbutton()()()
Initializes a new instance of the Dropbutton class.
Declaration Syntax
C#
public Dropbutton()


PopupControl Property

PopupControl Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Dropbutton ► PopupControl
Gets or sets the popup control.
Declaration Syntax
C#
public string PopupControl { get; set; }
Value
The popup control.


Edit Class

Edit Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Edit
Declaration Syntax
C#
public class Edit : Input
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Edit()()() | Initializes a new instance of the Edit class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event. (Inherited from Input.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Raises the Change event. (Inherited from Input.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Hidden | Gets or sets a value indicating whether this Edit is hidden.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Overrides Component.LoadPostData(String).)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange | Called when the input is changed by the user. (Inherited from Input.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Password | Gets or sets a value indicating whether this Edit is password.
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether this instance is read only. (Inherited from Input.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag. (Overrides Input.SetModified()()().)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether modifications are tracked. (Inherited from Input.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Overrides Control.Value.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Input
 |  |  |  |  |  |  | Edit
 |  |  |  |  |  |  |  | ComboEdit
 |  |  |  |  |  |  |  | DataEdit
 |  |  |  |  |  |  |  | SubmittableEdit


Edit Constructor

Edit Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Edit ► Edit()()()
Initializes a new instance of the Edit class
Declaration Syntax
C#
public Edit()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Edit ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Hidden Property

Hidden Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Edit ► Hidden
Gets or sets a value indicating whether this Edit is hidden.
Declaration Syntax
C#
public bool Hidden { get; set; }
Value
true if hidden; otherwise, false.


LoadPostData Method (value)

LoadPostData Method (value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Edit ► LoadPostData(String)
Loads the post data.
Declaration Syntax
C#
protected override bool LoadPostData(
    string value
)
Parameters
value (String)
The value.
Return Value


Password Property

Password Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Edit ► Password
Gets or sets a value indicating whether this Edit is password.
Declaration Syntax
C#
public bool Password { get; set; }
Value
true if password; otherwise, false.


SetModified Method

SetModified Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Edit ► SetModified()()()
Sets the modified flag.
Declaration Syntax
C#
protected override void SetModified()


Value Property

Value Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Edit ► Value
Gets or sets the value.
Declaration Syntax
C#
public override string Value { get; set; }
Value
The value.


FileSystemDataView Class

FileSystemDataView Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► FileSystemDataView
Represents a File System data view.
Declaration Syntax
C#
public class FileSystemDataView : DataViewBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileSystemDataView()()() | Initializes a new instance of the FileSystemDataView class
 | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from DataViewBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterItems(ArrayList%, String) | Filters the items. (Inherited from DataViewBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildItems(ItemCollection, Item) | Gets the child items. (Overrides DataViewBase.GetChildItems(ItemCollection, Item).)
 | GetChildren(Item, String, Boolean, Int32, Int32, String) | Gets the children. (Inherited from DataViewBase.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(String) | Gets the item. (Inherited from DataViewBase.)
 | GetItem(String, Language, Version) | Gets the item. (Inherited from DataViewBase.)
 | GetItemFromID(String, Language, Version) | Gets the item from ID. (Overrides DataViewBase.GetItemFromID(String, Language, Version).)
 | GetParent(Item) | Gets the parent. (Inherited from DataViewBase.)
 | GetParentItem(Item) | Gets the parent item. (Overrides DataViewBase.GetParentItem(Item).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildren(Item, String) | Determines whether the specified item has children. (Inherited from DataViewBase.)
 | Initialize(String) | Initializes the view from a data context. (Overrides DataViewBase.Initialize(String).)
 | IsAncestorOf(Item, Item) | Determines whether the ancestor is an ancestor of the item. (Inherited from DataViewBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets the parameters. (Inherited from DataViewBase.)
 | SortItems(ArrayList, String, Boolean) | Sorts the items. (Inherited from DataViewBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataViewBase
 |  | FileSystemDataView


FileSystemDataView Constructor

FileSystemDataView Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► FileSystemDataView ► FileSystemDataView()()()
Initializes a new instance of the FileSystemDataView class
Declaration Syntax
C#
public FileSystemDataView()


GetChildItems Method (items, item)

GetChildItems Method (items, item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► FileSystemDataView ► GetChildItems(ItemCollection, Item)
Gets the child items.
Declaration Syntax
C#
protected override void GetChildItems(
    ItemCollection items,
    Item item
)
Parameters
items (ItemCollection)
The items.
item (Item)
The item.


GetItemFromID Method (id, language, version)

GetItemFromID Method (id, language, version)
Namespaces ► Sitecore.Web.UI.HtmlControls ► FileSystemDataView ► GetItemFromID(String, Language, Version)
Gets the item from ID.
Declaration Syntax
C#
protected override Item GetItemFromID(
    string id,
    Language language,
    Version version
)
Parameters
id (String)
The id.
language (Language)
The language.
version (Version)
The version.
Return Value


GetParentItem Method (item)

GetParentItem Method (item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► FileSystemDataView ► GetParentItem(Item)
Gets the parent item.
Declaration Syntax
C#
protected override Item GetParentItem(
    Item item
)
Parameters
item (Item)
The item.
Return Value


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces ► Sitecore.Web.UI.HtmlControls ► FileSystemDataView ► Initialize(String)
Initializes the view from a data context.
Declaration Syntax
C#
public override void Initialize(
    string parameters
)
Parameters
parameters (String)
The parameters.


Frame Class

Frame Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Frame
Represents an IFrame Html tag.
Declaration Syntax
C#
public class Frame : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Frame()()() | Initializes a new instance of the Frame class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | AllowTransparency | Gets or sets a value indicating whether the Frame allows transparency.
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Overrides WebControl.Height.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Scrolling | Gets or sets the scrolling attribute.
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetSource(String, String) | Sets the source.
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | SourceUri | Gets or sets the source URI.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Overrides WebControl.Width.)
 | XmlControl | Gets or sets the XML control.
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Frame


Frame Constructor

Frame Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Frame ► Frame()()()
Initializes a new instance of the Frame class.
Declaration Syntax
C#
public Frame()


AllowTransparency Property

AllowTransparency Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Frame ► AllowTransparency
Gets or sets a value indicating whether the Frame allows transparency.
Declaration Syntax
C#
public bool AllowTransparency { get; set; }
Value
true if the Frame allows transparency; otherwise, false.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Frame ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Height Property

Height Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Frame ► Height
Gets or sets the height of the Web server control.
Declaration Syntax
C#
public override Unit Height { get; set; }
Value
Return Value
A Unit that represents the height of the control. The default is Empty.
Exceptions
Exception | Condition
ArgumentException | The height was set to a negative value.


Scrolling Property

Scrolling Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Frame ► Scrolling
Gets or sets the scrolling attribute.
Declaration Syntax
C#
public string Scrolling { get; set; }
Value
The scrolling attribute.


SetSource Method (sourceUri, parameters)

SetSource Method (sourceUri, parameters)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Frame ► SetSource(String, String)
Sets the source.
Declaration Syntax
C#
public void SetSource(
    string sourceUri,
    string parameters
)
Parameters
sourceUri (String)
The source URI.
parameters (String)
The parameters.


SourceUri Property

SourceUri Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Frame ► SourceUri
Gets or sets the source URI.
Declaration Syntax
C#
public string SourceUri { get; set; }
Value
The source URI.


Width Property

Width Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Frame ► Width
Gets or sets the width of the Web server control.
Declaration Syntax
C#
public override Unit Width { get; set; }
Value
Return Value
A Unit that represents the width of the control. The default is Empty.
Exceptions
Exception | Condition
ArgumentException | The width of the Web server control was set to a negative value.


XmlControl Property

XmlControl Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Frame ► XmlControl
Gets or sets the XML control.
Declaration Syntax
C#
public string XmlControl { get; set; }
Value
The XML control.


GalleryMenu Class

GalleryMenu Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► GalleryMenu
Represents a menu in a gallery from the ribbon.
Declaration Syntax
C#
public class GalleryMenu : Menu
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GalleryMenu()()() | Initializes a new instance of the GalleryMenu class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | Add(String, String, String) | Adds the specified header. (Inherited from Menu.)
 | Add(String, String, String, String, String, Boolean, String, MenuItemType) | Adds the specified id. (Inherited from Menu.)
 | Add(Control, String, String, String, String, String, Boolean, String, MenuItemType, String, String, String, Boolean) | Adds the specified parent. (Inherited from Menu.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddDivider()()() | Adds the divider. (Inherited from Menu.)
 | AddDivider(Control) | Adds the divider. (Inherited from Menu.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddFromDataSource(String, String) | Adds from data source. (Inherited from Menu.)
 | AddFromDataSource(Item, String) | Adds from data source. (Inherited from Menu.)
 | AddFromDataSource(Item, String, CommandContext) | Adds from data source. (Inherited from Menu.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Menu.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Fill | Gets or sets a value indicating whether this GalleryMenu fills the area.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Show()()() | Shows this instance. (Inherited from Menu.)
 | Show(String) | Shows the menu at the specified position. (Inherited from Menu.)
 | Show(String, String) | Shows the menu at the specified tag id. (Inherited from Menu.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Menu
 |  |  |  |  |  |  | GalleryMenu


GalleryMenu Constructor

GalleryMenu Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► GalleryMenu ► GalleryMenu()()()
Initializes a new instance of the GalleryMenu class.
Declaration Syntax
C#
public GalleryMenu()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► GalleryMenu ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Fill Property

Fill Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► GalleryMenu ► Fill
Gets or sets a value indicating whether this GalleryMenu fills the area.
Declaration Syntax
C#
public bool Fill { get; set; }
Value
true if fills the area; otherwise, false.


Groupbox Class

Groupbox Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Groupbox
Represents a groupbox.
Declaration Syntax
C#
public class Groupbox : HeaderedItemsControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Groupbox()()() | Initializes a new instance of the Groupbox class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Groupbox


Groupbox Constructor

Groupbox Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Groupbox ► Groupbox()()()
Initializes a new instance of the Groupbox class
Declaration Syntax
C#
public Groupbox()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Groupbox ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Head Class

Head Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Head
Represents a menu in a gallery from the ribbon.
Declaration Syntax
C#
public class Head : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Head()()() | Initializes a new instance of the Head class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Head


Head Constructor

Head Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Head ► Head()()()
Initializes a new instance of the Head class
Declaration Syntax
C#
public Head()


Render Method (output)

Render Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Head ► Render(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


HeaderedItemsControl Class

HeaderedItemsControl Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► HeaderedItemsControl
Serves as the base class that defines the header and style common to all controls that have a header.
Declaration Syntax
C#
public abstract class HeaderedItemsControl : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HeaderedItemsControl()()() | Initializes a new instance of the HeaderedItemsControl class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Component.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header.
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header.
 | GetFormattedHeader(Boolean) | Gets the formatted header.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | HeaderStyle | Gets or sets the header CSS style.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Action
 |  |  |  |  |  |  | Button
 |  |  |  |  |  |  | Checklist
 |  |  |  |  |  |  | ChecklistItem
 |  |  |  |  |  |  | Groupbox
 |  |  |  |  |  |  | Label
 |  |  |  |  |  |  | ListviewHeaderItem
 |  |  |  |  |  |  | ListviewItem
 |  |  |  |  |  |  | MenuHeader
 |  |  |  |  |  |  | MenuItem
 |  |  |  |  |  |  | Navigator
 |  |  |  |  |  |  | Radiogroup
 |  |  |  |  |  |  | RadioItem
 |  |  |  |  |  |  | Tab
 |  |  |  |  |  |  | TabSection
 |  |  |  |  |  |  | Taskbox
 |  |  |  |  |  |  | TaskboxItem
 |  |  |  |  |  |  | TreecrumbNode
 |  |  |  |  |  |  | TreeHeaderItem
 |  |  |  |  |  |  | TreeNode


HeaderedItemsControl Constructor

HeaderedItemsControl Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► HeaderedItemsControl ► HeaderedItemsControl()()()
Initializes a new instance of the HeaderedItemsControl class
Declaration Syntax
C#
protected HeaderedItemsControl()


FormattedHeader Property

FormattedHeader Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► HeaderedItemsControl ► FormattedHeader
Gets the formatted header.
Declaration Syntax
C#
[ObsoleteAttribute("Use the GetFormattedHeader method instead.")]
public string FormattedHeader { get; }
Value
The formatted header.


GetFormattedHeader Method

GetFormattedHeader Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► HeaderedItemsControl ► GetFormattedHeader()()()
Members
Icon | Member | Description
 | GetFormattedHeader()()() | Gets the formatted header.
 | GetFormattedHeader(Boolean) | Gets the formatted header.


GetFormattedHeader Method

GetFormattedHeader Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► HeaderedItemsControl ► GetFormattedHeader()()()
Gets the formatted header.
Declaration Syntax
C#
public string GetFormattedHeader()
Return Value


GetFormattedHeader Method (translate)

GetFormattedHeader Method (translate)
Namespaces ► Sitecore.Web.UI.HtmlControls ► HeaderedItemsControl ► GetFormattedHeader(Boolean)
Gets the formatted header.
Declaration Syntax
C#
public string GetFormattedHeader(
    bool translate
)
Parameters
translate (Boolean)
if set to true the header is translated.
Return Value


Header Property

Header Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► HeaderedItemsControl ► Header
Gets or sets the header.
Declaration Syntax
C#
public virtual string Header { get; set; }
Value
The header.


HeaderStyle Property

HeaderStyle Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► HeaderedItemsControl ► HeaderStyle
Gets or sets the header CSS style.
Declaration Syntax
C#
public virtual string HeaderStyle { get; set; }
Value
The header CSS style.


IDataView Interface

IDataView Interface
Namespaces ► Sitecore.Web.UI.HtmlControls ► IDataView
Declaration Syntax
C#
public interface IDataView
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetChildren(Item, String, Boolean, Int32, Int32, String) | Gets the children.
 | GetItem(String) | Gets the item.
 | GetItem(String, Language, Version) | Gets the item.
 | GetParent(Item) | Gets the parent.
 | HasChildren(Item, String) | Determines whether the specified item has children.
 | Initialize(String) | Initializes the view from a data context.
 | IsAncestorOf(Item, Item) | Determines whether the ancestor is an ancestor of the item.


GetChildren Method (item, sortBy, sortAscending, offset, range, filter)

GetChildren Method (item, sortBy, sortAscending, offset, range, filter)
Namespaces ► Sitecore.Web.UI.HtmlControls ► IDataView ► GetChildren(Item, String, Boolean, Int32, Int32, String)
Gets the children.
Declaration Syntax
C#
ItemCollection GetChildren(
    Item item,
    string sortBy,
    bool sortAscending,
    int offset,
    int range,
    string filter
)
Parameters
item (Item)
The item.
sortBy (String)
The sort by.
sortAscending (Boolean)
if set to true sorts the children ascending.
offset (Int32)
The offset.
range (Int32)
The range.
filter (String)
The filter.
Return Value


GetItem Method

GetItem Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► IDataView ► GetItem()()()
Members
Icon | Member | Description
 | GetItem(String) | Gets the item.
 | GetItem(String, Language, Version) | Gets the item.


GetItem Method (id)

GetItem Method (id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► IDataView ► GetItem(String)
Gets the item.
Declaration Syntax
C#
Item GetItem(
    string id
)
Parameters
id (String)
The id.
Return Value


GetItem Method (id, language, version)

GetItem Method (id, language, version)
Namespaces ► Sitecore.Web.UI.HtmlControls ► IDataView ► GetItem(String, Language, Version)
Gets the item.
Declaration Syntax
C#
Item GetItem(
    string id,
    Language language,
    Version version
)
Parameters
id (String)
The id.
language (Language)
The language.
version (Version)
The version.
Return Value


GetParent Method (item)

GetParent Method (item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► IDataView ► GetParent(Item)
Gets the parent.
Declaration Syntax
C#
Item GetParent(
    Item item
)
Parameters
item (Item)
The item.
Return Value


HasChildren Method (item, filter)

HasChildren Method (item, filter)
Namespaces ► Sitecore.Web.UI.HtmlControls ► IDataView ► HasChildren(Item, String)
Determines whether the specified item has children.
Declaration Syntax
C#
bool HasChildren(
    Item item,
    string filter
)
Parameters
item (Item)
The item.
filter (String)
The filter.
Return Value
true if the specified item has children; otherwise, false.


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces ► Sitecore.Web.UI.HtmlControls ► IDataView ► Initialize(String)
Initializes the view from a data context.
Declaration Syntax
C#
void Initialize(
    string parameters
)
Parameters
parameters (String)
The parameters.


IsAncestorOf Method (ancestor, item)

IsAncestorOf Method (ancestor, item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► IDataView ► IsAncestorOf(Item, Item)
Determines whether the ancestor is an ancestor of the item.
Declaration Syntax
C#
bool IsAncestorOf(
    Item ancestor,
    Item item
)
Parameters
ancestor (Item)
The ancestor.
item (Item)
The item.
Return Value
true if the ancestor is an ancestor of the item; otherwise, false.


Image Class

Image Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Image
Represents an image.
Declaration Syntax
C#
public class Image : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Image()()() | Initializes a new instance of the Image class.
 | Image(String) | Initializes a new instance of the Image class.
 | Image(String, String, String) | Initializes a new instance of the Image class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | Align | Gets or sets the alignment.
 | Alt | Gets or sets the alt text.
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border. (Overrides WebControl.Border.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Src | Gets or sets the source.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Image
 |  |  |  |  |  |  | ImageButton
 |  |  |  |  |  |  | ThemedImage


Image Constructor

Image Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Image ► Image()()()
Members
Icon | Member | Description
 | Image()()() | Initializes a new instance of the Image class.
 | Image(String) | Initializes a new instance of the Image class.
 | Image(String, String, String) | Initializes a new instance of the Image class.


Image Constructor

Image Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Image ► Image()()()
Initializes a new instance of the Image class.
Declaration Syntax
C#
public Image()


Image Constructor (src)

Image Constructor (src)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Image ► Image(String)
Initializes a new instance of the Image class.
Declaration Syntax
C#
public Image(
    string src
)
Parameters
src (String)
The source.


Image Constructor (src, width, height)

Image Constructor (src, width, height)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Image ► Image(String, String, String)
Initializes a new instance of the Image class.
Declaration Syntax
C#
public Image(
    string src,
    string width,
    string height
)
Parameters
src (String)
The source.
width (String)
The width.
height (String)
The height.


Align Property

Align Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Image ► Align
Gets or sets the alignment.
Declaration Syntax
C#
public string Align { get; set; }
Value
The alignment.


Alt Property

Alt Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Image ► Alt
Gets or sets the alt text.
Declaration Syntax
C#
public string Alt { get; set; }
Value
The alt text.


Border Property

Border Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Image ► Border
Gets or sets the border.
Declaration Syntax
C#
public override string Border { get; set; }
Value
The border.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Image ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Src Property

Src Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Image ► Src
Gets or sets the source.
Declaration Syntax
C#
public string Src { get; set; }
Value
The source.


ImageButton Class

ImageButton Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► ImageButton
Represents a clickable image.
Declaration Syntax
C#
public class ImageButton : Image
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImageButton()()() | Initializes a new instance of the ImageButton class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | Align | Gets or sets the alignment. (Inherited from Image.)
 | Alt | Gets or sets the alt text. (Inherited from Image.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border. (Inherited from Image.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event.
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Image.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the image is clicked.
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Src | Gets or sets the source. (Inherited from Image.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Image
 |  |  |  |  |  |  | ImageButton


ImageButton Constructor

ImageButton Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► ImageButton ► ImageButton()()()
Initializes a new instance of the ImageButton class.
Declaration Syntax
C#
public ImageButton()


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ImageButton ► Click
Gets or sets the Click event.
Declaration Syntax
C#
public string Click { get; set; }
Value
The event to be executed.


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ImageButton ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected virtual void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ImageButton ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


OnClick Event

OnClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► ImageButton ► OnClick
Called when the image is clicked.
Declaration Syntax
C#
public event EventHandler OnClick


Inline Class

Inline Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Inline
Represents a Span tag.
Declaration Syntax
C#
public class Inline : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Inline()()() | Initializes a new instance of the Inline class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the Double Click event.
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event.
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the double click event.
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the control is clicked.
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDblClick | Called when the control is double clicked.
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Inline


Inline Constructor

Inline Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Inline ► Inline()()()
Initializes a new instance of the Inline class
Declaration Syntax
C#
public Inline()


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Inline ► Click
Gets or sets the Click event.
Declaration Syntax
C#
public string Click { get; set; }
Value
The event to be executed.


DblClick Property

DblClick Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Inline ► DblClick
Gets or sets the Double Click event.
Declaration Syntax
C#
public string DblClick { get; set; }
Value
The event to be executed.


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Inline ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected virtual void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DoDblclick Method (message)

DoDblclick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Inline ► DoDblclick(Message)
Executes the double click event.
Declaration Syntax
C#
protected virtual void DoDblclick(
    Message message
)
Parameters
message (Message)
The message.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Inline ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


OnClick Event

OnClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Inline ► OnClick
Called when the control is clicked.
Declaration Syntax
C#
public event EventHandler OnClick


OnDblClick Event

OnDblClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Inline ► OnDblClick
Called when the control is double clicked.
Declaration Syntax
C#
public event EventHandler OnDblClick


Input Class

Input Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Input
Defines the basic properties and functionality of an input control.
Declaration Syntax
C#
public abstract class Input : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Input()()() | Initializes a new instance of the Input class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Raises the Change event.
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Component.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange | Called when the input is changed by the user.
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether this instance is read only.
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag.
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether modifications are tracked.
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Input
 |  |  |  |  |  |  | Checkbox
 |  |  |  |  |  |  | ComboboxBase
 |  |  |  |  |  |  | DateCalendar
 |  |  |  |  |  |  | Edit
 |  |  |  |  |  |  | Memo
 |  |  |  |  |  |  | Radiobutton
 |  |  |  |  |  |  | TimePickerPopup


Input Constructor

Input Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Input ► Input()()()
Initializes a new instance of the Input class
Declaration Syntax
C#
protected Input()


Change Property

Change Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Input ► Change
Gets or sets the change event.
Declaration Syntax
C#
public string Change { get; set; }
Value
The change.


DoChange Method (message)

DoChange Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Input ► DoChange(Message)
Raises the Change event.
Declaration Syntax
C#
protected virtual void DoChange(
    Message message
)
Parameters
message (Message)
The message.


OnChange Event

OnChange Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Input ► OnChange
Called when the input is changed by the user.
Declaration Syntax
C#
public event EventHandler OnChange


ReadOnly Property

ReadOnly Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Input ► ReadOnly
Gets or sets a value indicating whether this instance is read only.
Declaration Syntax
C#
public virtual bool ReadOnly { get; set; }
Value
true if this instance is read only; otherwise, false.


SetModified Method

SetModified Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Input ► SetModified()()()
Sets the modified flag.
Declaration Syntax
C#
protected virtual void SetModified()


TrackModified Property

TrackModified Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Input ► TrackModified
Gets or sets a value indicating whether modifications are tracked.
Declaration Syntax
C#
public bool TrackModified { get; set; }
Value
true if modifications are tracked; otherwise, false.


IReportFormatter Interface

IReportFormatter Interface
Namespaces ► Sitecore.Web.UI.HtmlControls ► IReportFormatter
Represents a report formatter.
Declaration Syntax
C#
public interface IReportFormatter
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Format(XmlDocument, NameValueCollection) | Formats the specified source.


Format Method (source, parameters)

Format Method (source, parameters)
Namespaces ► Sitecore.Web.UI.HtmlControls ► IReportFormatter ► Format(XmlDocument, NameValueCollection)
Formats the specified source.
Declaration Syntax
C#
string Format(
    XmlDocument source,
    NameValueCollection parameters
)
Parameters
source (XmlDocument)
The source.
parameters (NameValueCollection)
The parameters.
Return Value
The formatted output.


IReportSource Interface

IReportSource Interface
Namespaces ► Sitecore.Web.UI.HtmlControls ► IReportSource
Represents a report source.
Declaration Syntax
C#
public interface IReportSource
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetSource(NameValueCollection) | Gets the source.


GetSource Method (parameters)

GetSource Method (parameters)
Namespaces ► Sitecore.Web.UI.HtmlControls ► IReportSource ► GetSource(NameValueCollection)
Gets the source.
Declaration Syntax
C#
XmlDocument GetSource(
    NameValueCollection parameters
)
Parameters
parameters (NameValueCollection)
The parameters.
Return Value
The source as an Xml Document.


KeyMap Class

KeyMap Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► KeyMap
Declaration Syntax
C#
public class KeyMap : Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KeyMap()()() | Initializes a new instance of the KeyMap class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Component.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | KeyMap


KeyMap Constructor

KeyMap Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► KeyMap ► KeyMap()()()
Initializes a new instance of the KeyMap class.
Declaration Syntax
C#
public KeyMap()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► KeyMap ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Label Class

Label Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Label
Represents a label.
Declaration Syntax
C#
public class Label : HeaderedItemsControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Label()()() | Initializes a new instance of the Label class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | For | Gets or sets the target of the label.
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Label


Label Constructor

Label Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Label ► Label()()()
Initializes a new instance of the Label class
Declaration Syntax
C#
public Label()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Label ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


For Property

For Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Label ► For
Gets or sets the target of the label.
Declaration Syntax
C#
public string For { get; set; }
Value
the target of the label.


Listbox Class

Listbox Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox
Represents a Listbox.
Declaration Syntax
C#
public class Listbox : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Listbox()()() | Initializes a new instance of the Listbox class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click event.
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Executes the change event.
 | DoClick(Message) | Executes the click event.
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblClick(Message) | Executes the Double Click event.
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets the items.
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Overrides Component.LoadPostData(String).)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Multiple | Gets or sets a value indicating whether this Listbox supports multiple selection.
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange |
 | OnClick |
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDblClick |
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Selected | Gets the selected items.
 | SelectedItem | Gets the selected item.
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag.
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | Size | Gets or sets the size.
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether the Listbox tracks modification.
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Overrides Control.Value.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Listbox
 |  |  |  |  |  |  | Combobox


Listbox Constructor

Listbox Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► Listbox()()()
Initializes a new instance of the Listbox class.
Declaration Syntax
C#
public Listbox()


Change Property

Change Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► Change
Gets or sets the change event.
Declaration Syntax
C#
public string Change { get; set; }
Value
The change.


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► Click
Gets or sets the Click event.
Declaration Syntax
C#
public string Click { get; set; }
Value
The event to be executed.


DblClick Property

DblClick Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► DblClick
Gets or sets the double click event.
Declaration Syntax
C#
public string DblClick { get; set; }
Value
The event to be executed.


DoChange Method (message)

DoChange Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► DoChange(Message)
Executes the change event.
Declaration Syntax
C#
protected virtual void DoChange(
    Message message
)
Parameters
message (Message)
The message.


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected virtual void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DoDblClick Method (message)

DoDblClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► DoDblClick(Message)
Executes the Double Click event.
Declaration Syntax
C#
protected virtual void DoDblClick(
    Message message
)
Parameters
message (Message)
The message.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► DoRender(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


Items Property

Items Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► Items
Gets the items.
Declaration Syntax
C#
public ListItem[] Items { get; }
Value
The items.


LoadPostData Method (value)

LoadPostData Method (value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► LoadPostData(String)
Loads the post data.
Declaration Syntax
C#
protected override bool LoadPostData(
    string value
)
Parameters
value (String)
The value.
Return Value


Multiple Property

Multiple Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► Multiple
Gets or sets a value indicating whether this Listbox supports multiple selection.
Declaration Syntax
C#
public bool Multiple { get; set; }
Value
true if multiple; otherwise, false.


OnChange Event

OnChange Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► OnChange
Declaration Syntax
C#
public event EventHandler OnChange


OnClick Event

OnClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► OnClick
Declaration Syntax
C#
public event EventHandler OnClick


OnDblClick Event

OnDblClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► OnDblClick
Declaration Syntax
C#
public event EventHandler OnDblClick


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


Selected Property

Selected Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► Selected
Gets the selected items.
Declaration Syntax
C#
public ListItem[] Selected { get; }
Value
The selected.


SelectedItem Property

SelectedItem Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► SelectedItem
Gets the selected item.
Declaration Syntax
C#
public ListItem SelectedItem { get; }
Value
The selected item.


SetModified Method

SetModified Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► SetModified()()()
Sets the modified flag.
Declaration Syntax
C#
protected virtual void SetModified()


Size Property

Size Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► Size
Gets or sets the size.
Declaration Syntax
C#
public string Size { get; set; }
Value
The size.


TrackModified Property

TrackModified Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► TrackModified
Gets or sets a value indicating whether the Listbox tracks modification.
Declaration Syntax
C#
public bool TrackModified { get; set; }
Value
true if the Listbox tracks modification; otherwise, false.


Value Property

Value Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listbox ► Value
Gets or sets the value.
Declaration Syntax
C#
public override string Value { get; set; }
Value
The value.


ListboxItem Class

ListboxItem Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListboxItem
Represents an item in a listbox.
Declaration Syntax
C#
public class ListboxItem : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListboxItem()()() | Initializes a new instance of the ListboxItem class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Selected | Gets or sets a value indicating whether this ListboxItem is selected.
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Overrides Control.Value.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | ListboxItem


ListboxItem Constructor

ListboxItem Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListboxItem ► ListboxItem()()()
Initializes a new instance of the ListboxItem class.
Declaration Syntax
C#
public ListboxItem()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListboxItem ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Header Property

Header Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListboxItem ► Header
Gets or sets the header.
Declaration Syntax
C#
public string Header { get; set; }
Value
The header.


Selected Property

Selected Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListboxItem ► Selected
Gets or sets a value indicating whether this ListboxItem is selected.
Declaration Syntax
C#
public bool Selected { get; set; }
Value
true if selected; otherwise, false.


Value Property

Value Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListboxItem ► Value
Gets or sets the value.
Declaration Syntax
C#
public override string Value { get; set; }
Value
The value.


ListItem Class

ListItem Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListItem
Represents an item in a list control.
Declaration Syntax
C#
public class ListItem : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListItem()()() | Initializes a new instance of the ListItem class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | Selected | Gets or sets a value indicating whether this ListItem is selected.
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Overrides Control.Value.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | ListItem


ListItem Constructor

ListItem Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListItem ► ListItem()()()
Initializes a new instance of the ListItem class
Declaration Syntax
C#
public ListItem()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListItem ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Header Property

Header Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListItem ► Header
Gets or sets the header.
Declaration Syntax
C#
public virtual string Header { get; set; }
Value
The header.


Selected Property

Selected Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListItem ► Selected
Gets or sets a value indicating whether this ListItem is selected.
Declaration Syntax
C#
public bool Selected { get; set; }
Value
true if selected; otherwise, false.


Value Property

Value Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListItem ► Value
Gets or sets the value.
Declaration Syntax
C#
public override string Value { get; set; }
Value
The value.


Listview Class

Listview Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview
Represents a listview.
Declaration Syntax
C#
public class Listview : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Listview()()() | Initializes a new instance of the Listview class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AddViewsMenu(Menu) | Adds the views menu.
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearSelection()()() | Clears the selection.
 | Click | Gets or sets the click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnNames | Gets the column names.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click event.
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event.
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the dblclick event.
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Overrides Component.DoRender(HtmlTextWriter).)
 | DoSetView(String) | Executes the set view event.
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event.
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemByID(String) | Gets the item by ID.
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetSelectedItems()()() | Gets the selected items.
 | GetShellViewsMenu(String) | Gets the shell views menu.
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewsMenu(String) | Gets the views menu.
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets the items.
 | ItemsOnly | Gets or sets a value indicating whether the Listview renders the items only and not the header.
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | MultiSelect | Gets or sets a value indicating whether the Listview supports multiselect.
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the control is clicked;
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDblClick | Called when the control is double clicked;
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSelectionChanged | Called when the selection is changed;
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OnViewChanged | Called when the view is changed.
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | Refresh()()() | Refreshes this Listview.
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFooter(HtmlTextWriter) | Renders the footer.
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderHeader(HtmlTextWriter) | Renders the header.
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Overrides WebControl.SaveViewState()()().)
 | SelectedItems | Gets the selected items.
 | SelectionChanged()()() | Called whrn the selection has been changed.
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | ShowCheckboxes | Gets or sets a value indicating whether the Listview shows the checkboxes.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | SortAscending | Gets or sets a value indicating whether the Listview sorts ascending.
 | SortBy | Gets or sets the sort by column.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | View | Gets or sets the view.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Listview
 |  |  |  |  |  |  | DataListview


Listview Constructor

Listview Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► Listview()()()
Initializes a new instance of the Listview class.
Declaration Syntax
C#
public Listview()


AddViewsMenu Method (menu)

AddViewsMenu Method (menu)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► AddViewsMenu(Menu)
Adds the views menu.
Declaration Syntax
C#
public void AddViewsMenu(
    Menu menu
)
Parameters
menu (Menu)
The menu.


ClearSelection Method

ClearSelection Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► ClearSelection()()()
Clears the selection.
Declaration Syntax
C#
public void ClearSelection()


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► Click
Gets or sets the click event.
Declaration Syntax
C#
public string Click { get; set; }
Value
The click event.


ColumnNames Property

ColumnNames Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► ColumnNames
Gets the column names.
Declaration Syntax
C#
public HashList<string, Object> ColumnNames { get; }
Value
The column names.


DblClick Property

DblClick Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► DblClick
Gets or sets the double click event.
Declaration Syntax
C#
public string DblClick { get; set; }
Value
The double click event.


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected virtual void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DoDblclick Method (message)

DoDblclick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► DoDblclick(Message)
Executes the dblclick event.
Declaration Syntax
C#
protected virtual void DoDblclick(
    Message message
)
Parameters
message (Message)
The message.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► DoRender(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


DoSetView Method (name)

DoSetView Method (name)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► DoSetView(String)
Executes the set view event.
Declaration Syntax
C#
protected virtual void DoSetView(
    string name
)
Parameters
name (String)
The name.


Drop Property

Drop Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► Drop
Gets or sets the drop event.
Declaration Syntax
C#
public string Drop { get; set; }
Value
The drop event.


GetItemByID Method (id)

GetItemByID Method (id)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► GetItemByID(String)
Gets the item by ID.
Declaration Syntax
C#
public ListviewItem GetItemByID(
    string id
)
Parameters
id (String)
The id.
Return Value


GetSelectedItems Method

GetSelectedItems Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► GetSelectedItems()()()
Gets the selected items.
Declaration Syntax
C#
public ListviewItem[] GetSelectedItems()
Return Value


GetShellViewsMenu Method (where)

GetShellViewsMenu Method (where)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► GetShellViewsMenu(String)
Gets the shell views menu.
Declaration Syntax
C#
public virtual void GetShellViewsMenu(
    string where
)
Parameters
where (String)
The where.


GetViewsMenu Method (where)

GetViewsMenu Method (where)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► GetViewsMenu(String)
Gets the views menu.
Declaration Syntax
C#
public virtual void GetViewsMenu(
    string where
)
Parameters
where (String)
The where.


Items Property

Items Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► Items
Gets the items.
Declaration Syntax
C#
public ListviewItem[] Items { get; }
Value
The items.


ItemsOnly Property

ItemsOnly Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► ItemsOnly
Gets or sets a value indicating whether the Listview renders the items only and not the header.
Declaration Syntax
C#
public bool ItemsOnly { get; set; }
Value
true if the Listview renders the items only; otherwise, false.


MultiSelect Property

MultiSelect Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► MultiSelect
Gets or sets a value indicating whether the Listview supports multiselect.
Declaration Syntax
C#
public bool MultiSelect { get; set; }
Value
true if the Listview supports multiselect; otherwise, false.


OnClick Event

OnClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► OnClick
Called when the control is clicked;
Declaration Syntax
C#
public event EventHandler OnClick


OnDblClick Event

OnDblClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► OnDblClick
Called when the control is double clicked;
Declaration Syntax
C#
public event EventHandler OnDblClick


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


OnSelectionChanged Event

OnSelectionChanged Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► OnSelectionChanged
Called when the selection is changed;
Declaration Syntax
C#
public event EventHandler OnSelectionChanged


OnViewChanged Event

OnViewChanged Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► OnViewChanged
Called when the view is changed.
Declaration Syntax
C#
public event Listview..::.ListviewViewChangedDelegate OnViewChanged


Refresh Method

Refresh Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► Refresh()()()
Refreshes this Listview.
Declaration Syntax
C#
public virtual void Refresh()


RenderFooter Method (output)

RenderFooter Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► RenderFooter(HtmlTextWriter)
Renders the footer.
Declaration Syntax
C#
protected virtual void RenderFooter(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


RenderHeader Method (output)

RenderHeader Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► RenderHeader(HtmlTextWriter)
Renders the header.
Declaration Syntax
C#
protected virtual void RenderHeader(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


SaveViewState Method

SaveViewState Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► SaveViewState()()()
Saves any state that was modified after the TrackViewState()()() method was invoked.
Declaration Syntax
C#
protected override Object SaveViewState()
Return Value
An object that contains the current view state of the control; otherwise, if there is no view state associated with the control, null.


SelectedItems Property

SelectedItems Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► SelectedItems
Gets the selected items.
Declaration Syntax
C#
public ListviewItem[] SelectedItems { get; }
Value
The selected items.


SelectionChanged Method

SelectionChanged Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► SelectionChanged()()()
Called whrn the selection has been changed.
Declaration Syntax
C#
protected virtual void SelectionChanged()


ShowCheckboxes Property

ShowCheckboxes Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► ShowCheckboxes
Gets or sets a value indicating whether the Listview shows the checkboxes.
Declaration Syntax
C#
public bool ShowCheckboxes { get; set; }
Value
true if the Listview shows the checkboxes; otherwise, false.


SortAscending Property

SortAscending Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► SortAscending
Gets or sets a value indicating whether the Listview sorts ascending.
Declaration Syntax
C#
public bool SortAscending { get; set; }
Value
true if the Listview sorts ascending; otherwise, false.


SortBy Property

SortBy Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► SortBy
Gets or sets the sort by column.
Declaration Syntax
C#
public string SortBy { get; set; }
Value
The sort by column.


View Property

View Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► View
Gets or sets the view.
Declaration Syntax
C#
public string View { get; set; }
Value
The view.


Listview.ListviewViewChangedDelegate Delegate

Listview..::.ListviewViewChangedDelegate Delegate
Namespaces ► Sitecore.Web.UI.HtmlControls ► Listview ► Listview..::.ListviewViewChangedDelegate
Called when the view is changed.
Declaration Syntax
C#
public delegate void ListviewViewChangedDelegate(
    Object sender
)
Parameters
sender (Object)


ListviewHeader Class

ListviewHeader Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewHeader
Represents a header in a listview control.
Declaration Syntax
C#
public class ListviewHeader : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListviewHeader()()() | Initializes a new instance of the ListviewHeader class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | ListviewHeader


ListviewHeader Constructor

ListviewHeader Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewHeader ► ListviewHeader()()()
Initializes a new instance of the ListviewHeader class.
Declaration Syntax
C#
public ListviewHeader()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewHeader ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


ListviewHeaderItem Class

ListviewHeaderItem Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewHeaderItem
Represents an item in a listview header.
Declaration Syntax
C#
public class ListviewHeaderItem : HeaderedItemsControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListviewHeaderItem()()() | Initializes a new instance of the ListviewHeaderItem class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | ListviewHeaderItem


ListviewHeaderItem Constructor

ListviewHeaderItem Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewHeaderItem ► ListviewHeaderItem()()()
Initializes a new instance of the ListviewHeaderItem class.
Declaration Syntax
C#
public ListviewHeaderItem()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewHeaderItem ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


ListviewItem Class

ListviewItem Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewItem
Represents an item in a list view.
Declaration Syntax
C#
public class ListviewItem : HeaderedItemsControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListviewItem()()() | Initializes a new instance of the ListviewItem class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Checked | Gets or sets a value indicating whether this ListviewItem is checked.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | ClassPrefix | Gets or sets the class prefix.
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnValues | Gets the column values.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | Drag | Gets or sets the drag event.
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetCurrentView()()() | Gets the current view.
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetListview()()() | Gets the listview.
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Overrides WebControl.SaveViewState()()().)
 | Selected | Gets or sets a value indicating whether this ListviewItem is selected.
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Overrides WebControl.ToolTip.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | ListviewItem
 |  |  |  |  |  |  |  | DataListviewItem
 |  |  |  |  |  |  |  | ListviewNavigator


ListviewItem Constructor

ListviewItem Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewItem ► ListviewItem()()()
Initializes a new instance of the ListviewItem class
Declaration Syntax
C#
public ListviewItem()


Checked Property

Checked Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewItem ► Checked
Gets or sets a value indicating whether this ListviewItem is checked.
Declaration Syntax
C#
public bool Checked { get; set; }
Value
true if checked; otherwise, false.


ClassPrefix Property

ClassPrefix Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewItem ► ClassPrefix
Gets or sets the class prefix.
Declaration Syntax
C#
public virtual string ClassPrefix { get; set; }
Value
The class prefix.


ColumnValues Property

ColumnValues Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewItem ► ColumnValues
Gets the column values.
Declaration Syntax
C#
public HashList<string, Object> ColumnValues { get; }
Value
The column values.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewItem ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Drag Property

Drag Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewItem ► Drag
Gets or sets the drag event.
Declaration Syntax
C#
public string Drag { get; set; }
Value
The drag event.


GetCurrentView Method

GetCurrentView Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewItem ► GetCurrentView()()()
Gets the current view.
Declaration Syntax
C#
protected string GetCurrentView()
Return Value


GetListview Method

GetListview Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewItem ► GetListview()()()
Gets the listview.
Declaration Syntax
C#
protected Listview GetListview()
Return Value


Icon Property

Icon Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewItem ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public virtual string Icon { get; set; }
Value
The icon.


SaveViewState Method

SaveViewState Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewItem ► SaveViewState()()()
Saves any state that was modified after the TrackViewState()()() method was invoked.
Declaration Syntax
C#
protected override Object SaveViewState()
Return Value
An object that contains the current view state of the control; otherwise, if there is no view state associated with the control, null.


Selected Property

Selected Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewItem ► Selected
Gets or sets a value indicating whether this ListviewItem is selected.
Declaration Syntax
C#
public virtual bool Selected { get; set; }
Value
true if selected; otherwise, false.


ToolTip Property

ToolTip Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewItem ► ToolTip
Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Declaration Syntax
C#
public override string ToolTip { get; set; }
Value
Return Value
The text displayed when the mouse pointer hovers over the Web server control. The default is Empty()()().


ListviewNavigator Class

ListviewNavigator Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewNavigator
Represents a pager in a list view control.
Declaration Syntax
C#
[ObsoleteAttribute("Deprecated.")]
public class ListviewNavigator : ListviewItem
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListviewNavigator(Int32, Int32, Int32) | Initializes a new instance of the ListviewNavigator class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Checked | Gets or sets a value indicating whether this ListviewItem is checked. (Inherited from ListviewItem.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | ClassPrefix | Gets or sets the class prefix. (Inherited from ListviewItem.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | ColumnValues | Gets the column values. (Inherited from ListviewItem.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | Count | Gets or sets the count.
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides ListviewItem.DoRender(HtmlTextWriter).)
 | Drag | Gets or sets the drag event. (Inherited from ListviewItem.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetCurrentView()()() | Gets the current view. (Inherited from ListviewItem.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetListview()()() | Gets the listview. (Inherited from ListviewItem.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon. (Inherited from ListviewItem.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | Offset | Gets or sets the offset.
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageSize | Gets or sets the size of the page.
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from ListviewItem.)
 | Selected | Gets or sets a value indicating whether this ListviewItem is selected. (Inherited from ListviewItem.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from ListviewItem.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | ListviewItem
 |  |  |  |  |  |  |  | ListviewNavigator


ListviewNavigator Constructor (offset, count, pageSize)

ListviewNavigator Constructor (offset, count, pageSize)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewNavigator ► ListviewNavigator(Int32, Int32, Int32)
Initializes a new instance of the ListviewNavigator class.
Declaration Syntax
C#
public ListviewNavigator(
    int offset,
    int count,
    int pageSize
)
Parameters
offset (Int32)
The offset.
count (Int32)
The count.
pageSize (Int32)
Size of the page.


Count Property

Count Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewNavigator ► Count
Gets or sets the count.
Declaration Syntax
C#
public int Count { get; set; }
Value
The count.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewNavigator ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Offset Property

Offset Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewNavigator ► Offset
Gets or sets the offset.
Declaration Syntax
C#
public int Offset { get; set; }
Value
The offset.


PageSize Property

PageSize Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► ListviewNavigator ► PageSize
Gets or sets the size of the page.
Declaration Syntax
C#
public int PageSize { get; set; }
Value
The size of the page.


Literal Class

Literal Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Literal
Represents a literal text.
Declaration Syntax
C#
public class Literal : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Literal()()() | Initializes a new instance of the Literal class.
 | Literal(String) | Initializes a new instance of the Literal class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text.
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Literal


Literal Constructor

Literal Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Literal ► Literal()()()
Members
Icon | Member | Description
 | Literal()()() | Initializes a new instance of the Literal class.
 | Literal(String) | Initializes a new instance of the Literal class.


Literal Constructor

Literal Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Literal ► Literal()()()
Initializes a new instance of the Literal class.
Declaration Syntax
C#
public Literal()


Literal Constructor (text)

Literal Constructor (text)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Literal ► Literal(String)
Initializes a new instance of the Literal class.
Declaration Syntax
C#
public Literal(
    string text
)
Parameters
text (String)
The text.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Literal ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Literal ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


Text Property

Text Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Literal ► Text
Gets or sets the text.
Declaration Syntax
C#
public string Text { get; set; }
Value
The text.


MasterDataView Class

MasterDataView Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► MasterDataView
Represents the data view of the master database.
Declaration Syntax
C#
public class MasterDataView : DataViewBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MasterDataView()()() | Initializes a new instance of the MasterDataView class
 | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from DataViewBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterItems(ArrayList%, String) | Filters the items. (Inherited from DataViewBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildItems(ItemCollection, Item) | Gets the child items. (Overrides DataViewBase.GetChildItems(ItemCollection, Item).)
 | GetChildren(Item, String, Boolean, Int32, Int32, String) | Gets the children. (Inherited from DataViewBase.)
 | GetDatabase()()() | Gets the database.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(String) | Gets the item. (Inherited from DataViewBase.)
 | GetItem(String, Language, Version) | Gets the item. (Inherited from DataViewBase.)
 | GetItemFromID(String, Language, Version) | Gets the item from ID. (Overrides DataViewBase.GetItemFromID(String, Language, Version).)
 | GetParent(Item) | Gets the parent. (Inherited from DataViewBase.)
 | GetParentItem(Item) | Gets the parent item. (Overrides DataViewBase.GetParentItem(Item).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildren(Item, String) | Determines whether the specified item has children. (Inherited from DataViewBase.)
 | Initialize(String) | Initializes the view from a data context. (Overrides DataViewBase.Initialize(String).)
 | IsAncestorOf(Item, Item) | Determines whether the ancestor is an ancestor of the item. (Overrides DataViewBase.IsAncestorOf(Item, Item).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets the parameters. (Inherited from DataViewBase.)
 | SortItems(ArrayList, String, Boolean) | Sorts the items. (Inherited from DataViewBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataViewBase
 |  | MasterDataView
 |  |  | RecycleBinDataView


MasterDataView Constructor

MasterDataView Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► MasterDataView ► MasterDataView()()()
Initializes a new instance of the MasterDataView class
Declaration Syntax
C#
public MasterDataView()


GetChildItems Method (items, item)

GetChildItems Method (items, item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► MasterDataView ► GetChildItems(ItemCollection, Item)
Gets the child items.
Declaration Syntax
C#
protected override void GetChildItems(
    ItemCollection items,
    Item item
)
Parameters
items (ItemCollection)
The items.
item (Item)
The item.


GetDatabase Method

GetDatabase Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► MasterDataView ► GetDatabase()()()
Gets the database.
Declaration Syntax
C#
protected virtual Database GetDatabase()
Return Value


GetItemFromID Method (id, language, version)

GetItemFromID Method (id, language, version)
Namespaces ► Sitecore.Web.UI.HtmlControls ► MasterDataView ► GetItemFromID(String, Language, Version)
Gets the item from ID.
Declaration Syntax
C#
protected override Item GetItemFromID(
    string id,
    Language language,
    Version version
)
Parameters
id (String)
The id.
language (Language)
The language.
version (Version)
The version.
Return Value


GetParentItem Method (item)

GetParentItem Method (item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► MasterDataView ► GetParentItem(Item)
Gets the parent item.
Declaration Syntax
C#
protected override Item GetParentItem(
    Item item
)
Parameters
item (Item)
The item.
Return Value


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces ► Sitecore.Web.UI.HtmlControls ► MasterDataView ► Initialize(String)
Initializes the view from a data context.
Declaration Syntax
C#
public override void Initialize(
    string parameters
)
Parameters
parameters (String)
The parameters.


IsAncestorOf Method (ancestor, item)

IsAncestorOf Method (ancestor, item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► MasterDataView ► IsAncestorOf(Item, Item)
Determines whether the ancestor is an ancestor of the item.
Declaration Syntax
C#
public override bool IsAncestorOf(
    Item ancestor,
    Item item
)
Parameters
ancestor (Item)
The ancestor.
item (Item)
The item.
Return Value
true if the ancestor is an ancestor of the item; otherwise, false.


Memo Class

Memo Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Memo
Represents a memo field.
Declaration Syntax
C#
public class Memo : Input
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Memo()()() | Initializes a new instance of the Memo class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event. (Inherited from Input.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Raises the Change event. (Inherited from Input.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Overrides Component.LoadPostData(String).)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange | Called when the input is changed by the user. (Inherited from Input.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether this instance is read only. (Inherited from Input.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag. (Overrides Input.SetModified()()().)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether modifications are tracked. (Inherited from Input.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Overrides Control.Value.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | Wrap | Gets or sets the wrap.
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Input
 |  |  |  |  |  |  | Memo
 |  |  |  |  |  |  |  | DataMemo


Memo Constructor

Memo Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Memo ► Memo()()()
Initializes a new instance of the Memo class
Declaration Syntax
C#
public Memo()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Memo ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


LoadPostData Method (value)

LoadPostData Method (value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Memo ► LoadPostData(String)
Loads the post data.
Declaration Syntax
C#
protected override bool LoadPostData(
    string value
)
Parameters
value (String)
The value.
Return Value


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Memo ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


SetModified Method

SetModified Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Memo ► SetModified()()()
Sets the modified flag.
Declaration Syntax
C#
protected override void SetModified()


Value Property

Value Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Memo ► Value
Gets or sets the value.
Declaration Syntax
C#
public override string Value { get; set; }
Value
The value.


Wrap Property

Wrap Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Memo ► Wrap
Gets or sets the wrap.
Declaration Syntax
C#
public string Wrap { get; set; }
Value
The wrap.


Menu Class

Menu Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu
Represents a menu.
Declaration Syntax
C#
public class Menu : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Menu()()() | Initializes a new instance of the Menu class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | Add(String, String, String) | Adds the specified header.
 | Add(String, String, String, String, String, Boolean, String, MenuItemType) | Adds the specified id.
 | Add(Control, String, String, String, String, String, Boolean, String, MenuItemType, String, String, String, Boolean) | Adds the specified parent.
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddDivider()()() | Adds the divider.
 | AddDivider(Control) | Adds the divider.
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddFromDataSource(String, String) | Adds from data source.
 | AddFromDataSource(Item, String) | Adds from data source.
 | AddFromDataSource(Item, String, CommandContext) | Adds from data source.
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Show()()() | Shows this instance.
 | Show(String) | Shows the menu at the specified position.
 | Show(String, String) | Shows the menu at the specified tag id.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Menu
 |  |  |  |  |  |  | ContextMenu
 |  |  |  |  |  |  | GalleryMenu
 |  |  |  |  |  |  | MenubarItem


Menu Constructor

Menu Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► Menu()()()
Initializes a new instance of the Menu class.
Declaration Syntax
C#
public Menu()


Add Method

Add Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► Add()()()
Members
Icon | Member | Description
 | Add(String, String, String) | Adds the specified header.
 | Add(String, String, String, String, String, Boolean, String, MenuItemType) | Adds the specified id.
 | Add(Control, String, String, String, String, String, Boolean, String, MenuItemType, String, String, String, Boolean) | Adds the specified parent.


Add Method (header, icon, click)

Add Method (header, icon, click)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► Add(String, String, String)
Adds the specified header.
Declaration Syntax
C#
public MenuItem Add(
    string header,
    string icon,
    string click
)
Parameters
header (String)
The header.
icon (String)
The icon.
click (String)
The click.
Return Value


Add Method (id, header, icon, hotkey, click, check, radiogroup, type)

Add Method (id, header, icon, hotkey, click, check, radiogroup, type)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► Add(String, String, String, String, String, Boolean, String, MenuItemType)
Adds the specified id.
Declaration Syntax
C#
public MenuItem Add(
    string id,
    string header,
    string icon,
    string hotkey,
    string click,
    bool check,
    string radiogroup,
    MenuItemType type
)
Parameters
id (String)
The id.
header (String)
The header.
icon (String)
The icon.
hotkey (String)
The hotkey.
click (String)
The click.
check (Boolean)
if set to true this instance has a checkbox.
radiogroup (String)
The radiogroup.
type (MenuItemType)
The type.
Return Value


Add Method (parent, id, header, icon, hotkey, click, check, radiogroup, type, submenu, action, onPopup, createPopupOnce)

Add Method (parent, id, header, icon, hotkey, click, check, radiogroup, type, submenu, action, onPopup, createPopupOnce)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► Add(Control, String, String, String, String, String, Boolean, String, MenuItemType, String, String, String, Boolean)
Adds the specified parent.
Declaration Syntax
C#
public MenuItem Add(
    Control parent,
    string id,
    string header,
    string icon,
    string hotkey,
    string click,
    bool check,
    string radiogroup,
    MenuItemType type,
    string submenu,
    string action,
    string onPopup,
    bool createPopupOnce
)
Parameters
parent (Control)
The parent.
id (String)
The id.
header (String)
The header.
icon (String)
The icon.
hotkey (String)
The hotkey.
click (String)
The click.
check (Boolean)
if set to true this instance has a checkbox.
radiogroup (String)
The radiogroup.
type (MenuItemType)
The type.
submenu (String)
The submenu.
action (String)
The action.
onPopup (String)
The on popup.
createPopupOnce (Boolean)
if set to true this instance is create popup once.
Return Value


AddDivider Method

AddDivider Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► AddDivider()()()
Members
Icon | Member | Description
 | AddDivider()()() | Adds the divider.
 | AddDivider(Control) | Adds the divider.


AddDivider Method

AddDivider Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► AddDivider()()()
Adds the divider.
Declaration Syntax
C#
public MenuDivider AddDivider()
Return Value


AddDivider Method (parent)

AddDivider Method (parent)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► AddDivider(Control)
Adds the divider.
Declaration Syntax
C#
public MenuDivider AddDivider(
    Control parent
)
Parameters
parent (Control)
The parent.
Return Value


AddFromDataSource Method

AddFromDataSource Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► AddFromDataSource()()()
Members
Icon | Member | Description
 | AddFromDataSource(String, String) | Adds from data source.
 | AddFromDataSource(Item, String) | Adds from data source.
 | AddFromDataSource(Item, String, CommandContext) | Adds from data source.


AddFromDataSource Method (item, target)

AddFromDataSource Method (item, target)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► AddFromDataSource(Item, String)
Adds from data source.
Declaration Syntax
C#
public void AddFromDataSource(
    Item item,
    string target
)
Parameters
item (Item)
The item.
target (String)
The target.


AddFromDataSource Method (item, target, commandContext)

AddFromDataSource Method (item, target, commandContext)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► AddFromDataSource(Item, String, CommandContext)
Adds from data source.
Declaration Syntax
C#
public void AddFromDataSource(
    Item item,
    string target,
    CommandContext commandContext
)
Parameters
item (Item)
The item.
target (String)
The target.
commandContext (CommandContext)
The command context.


AddFromDataSource Method (itemID, target)

AddFromDataSource Method (itemID, target)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► AddFromDataSource(String, String)
Adds from data source.
Declaration Syntax
C#
public void AddFromDataSource(
    string itemID,
    string target
)
Parameters
itemID (String)
The item ID.
target (String)
The target.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Show Method

Show Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► Show()()()
Members
Icon | Member | Description
 | Show()()() | Shows this instance.
 | Show(String) | Shows the menu at the specified position.
 | Show(String, String) | Shows the menu at the specified tag id.


Show Method

Show Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► Show()()()
Shows this instance.
Declaration Syntax
C#
public void Show()


Show Method (where)

Show Method (where)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► Show(String)
Shows the menu at the specified position.
Declaration Syntax
C#
public void Show(
    string where
)
Parameters
where (String)
The position.


Show Method (id, where)

Show Method (id, where)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menu ► Show(String, String)
Shows the menu at the specified tag id.
Declaration Syntax
C#
public virtual void Show(
    string id,
    string where
)
Parameters
id (String)
The id.
where (String)
The position.


Menubar Class

Menubar Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menubar
Represents a top menu bar.
Declaration Syntax
C#
public class Menubar : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Menubar()()() | Initializes a new instance of the Menubar class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Menubar


Menubar Constructor

Menubar Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menubar ► Menubar()()()
Initializes a new instance of the Menubar class.
Declaration Syntax
C#
public Menubar()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Menubar ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


MenubarItem Class

MenubarItem Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenubarItem
Represents an item in a menu bar.
Declaration Syntax
C#
public class MenubarItem : Menu
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MenubarItem()()() | Initializes a new instance of the MenubarItem class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | Add(String, String, String) | Adds the specified header. (Inherited from Menu.)
 | Add(String, String, String, String, String, Boolean, String, MenuItemType) | Adds the specified id. (Inherited from Menu.)
 | Add(Control, String, String, String, String, String, Boolean, String, MenuItemType, String, String, String, Boolean) | Adds the specified parent. (Inherited from Menu.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddDivider()()() | Adds the divider. (Inherited from Menu.)
 | AddDivider(Control) | Adds the divider. (Inherited from Menu.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddFromDataSource(String, String) | Adds from data source. (Inherited from Menu.)
 | AddFromDataSource(Item, String) | Adds from data source. (Inherited from Menu.)
 | AddFromDataSource(Item, String, CommandContext) | Adds from data source. (Inherited from Menu.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Menu.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Gets the formatted header.
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | HeaderStyle | Gets or sets the header style.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Show()()() | Shows this instance. (Inherited from Menu.)
 | Show(String) | Shows the menu at the specified position. (Inherited from Menu.)
 | Show(String, String) | Shows the menu at the specified tag id. (Inherited from Menu.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Menu
 |  |  |  |  |  |  | MenubarItem


MenubarItem Constructor

MenubarItem Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenubarItem ► MenubarItem()()()
Initializes a new instance of the MenubarItem class.
Declaration Syntax
C#
public MenubarItem()


FormattedHeader Property

FormattedHeader Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenubarItem ► FormattedHeader
Gets the formatted header.
Declaration Syntax
C#
public string FormattedHeader { get; }
Value
The formatted header.


Header Property

Header Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenubarItem ► Header
Gets or sets the header.
Declaration Syntax
C#
public virtual string Header { get; set; }
Value
The header.


HeaderStyle Property

HeaderStyle Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenubarItem ► HeaderStyle
Gets or sets the header style.
Declaration Syntax
C#
public virtual string HeaderStyle { get; set; }
Value
The header style.


MenuDivider Class

MenuDivider Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuDivider
Represents a divider in a menu.
Declaration Syntax
C#
public class MenuDivider : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MenuDivider()()() | Initializes a new instance of the MenuDivider class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | MenuDivider


MenuDivider Constructor

MenuDivider Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuDivider ► MenuDivider()()()
Initializes a new instance of the MenuDivider class.
Declaration Syntax
C#
public MenuDivider()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuDivider ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


MenuHeader Class

MenuHeader Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuHeader
Represents a menu header.
Declaration Syntax
C#
public class MenuHeader : HeaderedItemsControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MenuHeader()()() | Initializes a new instance of the MenuHeader class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | MenuHeader


MenuHeader Constructor

MenuHeader Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuHeader ► MenuHeader()()()
Initializes a new instance of the MenuHeader class.
Declaration Syntax
C#
public MenuHeader()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuHeader ► DoRender(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


MenuItem Class

MenuItem Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem
Represents an item in a menu.
Declaration Syntax
C#
public class MenuItem : HeaderedItemsControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MenuItem()()() | Initializes a new instance of the MenuItem class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Checked | Gets or sets a value indicating whether this MenuItem is checked.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Overrides Control.Disabled.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event.
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | Drag | Gets or sets the drag event.
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Hotkey | Gets or sets the hotkey.
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code.
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the menu item is clicked.
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | Radiogroup | Gets or sets the radiogroup.
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | Submenu | Gets or sets the submenu.
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | Type | Gets or sets the type.
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | MenuItem


MenuItem Constructor

MenuItem Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► MenuItem()()()
Initializes a new instance of the MenuItem class.
Declaration Syntax
C#
public MenuItem()


Checked Property

Checked Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► Checked
Gets or sets a value indicating whether this MenuItem is checked.
Declaration Syntax
C#
public bool Checked { get; set; }
Value
true if checked; otherwise, false.


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► Click
Gets or sets the Click event.
Declaration Syntax
C#
public string Click { get; set; }
Value
The event to be executed.


Disabled Property

Disabled Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► Disabled
Gets or sets a value indicating whether this Control is disabled.
Declaration Syntax
C#
public override bool Disabled { get; set; }
Value
true if disabled; otherwise, false.


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected virtual void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Drag Property

Drag Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► Drag
Gets or sets the drag event.
Declaration Syntax
C#
public string Drag { get; set; }
Value
The drag event.


Hotkey Property

Hotkey Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► Hotkey
Gets or sets the hotkey.
Declaration Syntax
C#
public string Hotkey { get; set; }
Value
The hotkey.


Icon Property

Icon Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon { get; set; }
Value
The icon.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


OnClick Event

OnClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► OnClick
Called when the menu item is clicked.
Declaration Syntax
C#
public event EventHandler OnClick


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


Radiogroup Property

Radiogroup Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► Radiogroup
Gets or sets the radiogroup.
Declaration Syntax
C#
public string Radiogroup { get; set; }
Value
The radiogroup.


Submenu Property

Submenu Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► Submenu
Gets or sets the submenu.
Declaration Syntax
C#
public string Submenu { get; set; }
Value
The submenu.


Type Property

Type Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItem ► Type
Gets or sets the type.
Declaration Syntax
C#
public MenuItemType Type { get; set; }
Value
The type.


MenuItemType Enumeration

MenuItemType Enumeration
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuItemType
Specifies the type of menu item.
Declaration Syntax
C#
public enum MenuItemType
Members
Member | Description
Normal | Normal.
Check | Checkmark.
Radiogroup | Radiomark.
Submenu | Has a submenu.


MenuLine Class

MenuLine Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuLine
Represents a line in a menu.
Declaration Syntax
C#
public class MenuLine : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MenuLine()()() | Initializes a new instance of the MenuLine class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | MenuLine


MenuLine Constructor

MenuLine Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuLine ► MenuLine()()()
Initializes a new instance of the MenuLine class.
Declaration Syntax
C#
public MenuLine()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuLine ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


MenuPanel Class

MenuPanel Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuPanel
Represents a panel for containing subcontrols in a menu.
Declaration Syntax
C#
public class MenuPanel : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MenuPanel()()() | Initializes a new instance of the MenuPanel class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | MenuPanel


MenuPanel Constructor

MenuPanel Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuPanel ► MenuPanel()()()
Initializes a new instance of the MenuPanel class
Declaration Syntax
C#
public MenuPanel()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► MenuPanel ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Navigator Class

Navigator Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator
Represents a Navigator that enables paging.
Declaration Syntax
C#
public class Navigator : HeaderedItemsControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Navigator()()() | Initializes a new instance of the Navigator class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | Count | Gets or sets the count.
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event.
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Jump | Jump.
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | Next | Next.
 | Offset | Gets or sets the offset.
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnJump(Message, Int32) | Called when this instance makes a jump.
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnNext(Message) | Called when the Next button is clicked.
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPrevious(Message) | Called when the Previous button is clicked.
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageSize | Gets or sets the size of the page.
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | Previous | Previous.
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Navigator


Navigator Constructor

Navigator Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator ► Navigator()()()
Initializes a new instance of the Navigator class.
Declaration Syntax
C#
public Navigator()


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator ► Click
Gets or sets the Click event.
Declaration Syntax
C#
public string Click { get; set; }
Value
The event to be executed.


Count Property

Count Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator ► Count
Gets or sets the count.
Declaration Syntax
C#
public int Count { get; set; }
Value
The count.


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected virtual void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator ► DoRender(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


Jump Event

Jump Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator ► Jump
Jump.
Declaration Syntax
C#
public event Navigator..::.NavigatorDelegate Jump


Next Event

Next Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator ► Next
Next.
Declaration Syntax
C#
public event Navigator..::.NavigatorDelegate Next


Offset Property

Offset Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator ► Offset
Gets or sets the offset.
Declaration Syntax
C#
public int Offset { get; set; }
Value
The offset.


OnJump Method (message, jump)

OnJump Method (message, jump)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator ► OnJump(Message, Int32)
Called when this instance makes a jump.
Declaration Syntax
C#
protected virtual void OnJump(
    Message message,
    int jump
)
Parameters
message (Message)
The message.
jump (Int32)
The jump.


OnNext Method (message)

OnNext Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator ► OnNext(Message)
Called when the Next button is clicked.
Declaration Syntax
C#
protected virtual void OnNext(
    Message message
)
Parameters
message (Message)
The message.


OnPrevious Method (message)

OnPrevious Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator ► OnPrevious(Message)
Called when the Previous button is clicked.
Declaration Syntax
C#
protected virtual void OnPrevious(
    Message message
)
Parameters
message (Message)
The message.


PageSize Property

PageSize Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator ► PageSize
Gets or sets the size of the page.
Declaration Syntax
C#
public int PageSize { get; set; }
Value
The size of the page.


Previous Event

Previous Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator ► Previous
Previous.
Declaration Syntax
C#
public event Navigator..::.NavigatorDelegate Previous


Navigator.NavigatorDelegate Delegate

Navigator..::.NavigatorDelegate Delegate
Namespaces ► Sitecore.Web.UI.HtmlControls ► Navigator ► Navigator..::.NavigatorDelegate
Declaration Syntax
C#
public delegate void NavigatorDelegate(
    Object sender,
    Message args,
    int offset
)
Parameters
sender (Object)
args (Message)
offset (Int32)


Page Class

Page Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Page
Represents an .aspx file, also known as a Web Forms page, requested from a server that hosts an ASP.NET Web application.
Declaration Syntax
C#
public class Page : Page
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Page()()() | Initializes a new instance of the Page class
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | AutoPostBackControl()()() | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()[]) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsPostBackEventControlRegistered()()() | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Overrides Page.OnInit(EventArgs).)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Control.OnPreRender(EventArgs).)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageScriptManager | Gets the page script manager.
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()()() | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Page
 |  |  |  |  | ChangePasswordPage
 |  |  |  |  | PasswordRecoveryPage
 |  |  |  |  | Preview
 |  |  |  |  | ClientPage


Page Constructor

Page Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Page ► Page()()()
Initializes a new instance of the Page class
Declaration Syntax
C#
public Page()


OnInit Method (e)

OnInit Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Page ► OnInit(EventArgs)
Raises the Init event to initialize the page.
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs that contains the event data.


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Page ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


PageScriptManager Property

PageScriptManager Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Page ► PageScriptManager
Gets the page script manager.
Declaration Syntax
C#
public PageScriptManager PageScriptManager { get; }
Value
The page script manager.


PageScriptManager Class

PageScriptManager Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► PageScriptManager
Represents an .aspx file, also known as a Web Forms page, requested from a server that hosts an ASP.NET Web application.
Declaration Syntax
C#
public class PageScriptManager
Members
All Members | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddScripts | Gets or sets a value indicating whether the PageScriptManager adds the scripts.
 | AddStylesheets | Gets or sets a value indicating whether the PageScriptManager adds the stylesheets.
 | Create()()() | Creates this instance.
 | Current | Gets the current.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnInit()()() | Initializes this instance.
 | OnPreRender()()() | Called when prerendering.
 | Script |
 | ScriptFiles | Gets the script files.
 | Stylesheet |
 | StylesheetFiles | Gets the stylesheet files.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PageScriptManager


AddScripts Property

AddScripts Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► PageScriptManager ► AddScripts
Gets or sets a value indicating whether the PageScriptManager adds the scripts.
Declaration Syntax
C#
public bool AddScripts { get; set; }
Value
true if the PageScriptManager adds the scripts; otherwise, false.


AddStylesheets Property

AddStylesheets Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► PageScriptManager ► AddStylesheets
Gets or sets a value indicating whether the PageScriptManager adds the stylesheets.
Declaration Syntax
C#
public bool AddStylesheets { get; set; }
Value
true if the PageScriptManager adds the stylesheets; otherwise, false.


Create Method

Create Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► PageScriptManager ► Create()()()
Creates this instance.
Declaration Syntax
C#
public static PageScriptManager Create()
Return Value
The create.


Current Property

Current Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► PageScriptManager ► Current
Gets the current.
Declaration Syntax
C#
public static PageScriptManager Current { get; }
Value
The current.


OnInit Method

OnInit Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► PageScriptManager ► OnInit()()()
Initializes this instance.
Declaration Syntax
C#
public void OnInit()


OnPreRender Method

OnPreRender Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► PageScriptManager ► OnPreRender()()()
Called when prerendering.
Declaration Syntax
C#
public void OnPreRender()


Script Field

Script Field
Namespaces ► Sitecore.Web.UI.HtmlControls ► PageScriptManager ► Script
Declaration Syntax
C#
public static readonly ID Script


ScriptFiles Property

ScriptFiles Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► PageScriptManager ► ScriptFiles
Gets the script files.
Declaration Syntax
C#
public List<ScriptFile> ScriptFiles { get; }
Value
The script files.


Stylesheet Field

Stylesheet Field
Namespaces ► Sitecore.Web.UI.HtmlControls ► PageScriptManager ► Stylesheet
Declaration Syntax
C#
public static readonly ID Stylesheet


StylesheetFiles Property

StylesheetFiles Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► PageScriptManager ► StylesheetFiles
Gets the stylesheet files.
Declaration Syntax
C#
public List<StylesheetFile> StylesheetFiles { get; }
Value
The stylesheet files.


Panel Class

Panel Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Panel
Represents a panel.
Declaration Syntax
C#
public class Panel : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Panel()()() | Initializes a new instance of the Panel class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | Align | Gets or sets the align.
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the Double Click event.
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event.
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the dblclick event.
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InnerHtml | Gets or sets the inner HTML.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the panel is clicked.
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDblClick | Called when the panel is double clicked.
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Panel
 |  |  |  |  |  |  | Scrollbox
 |  |  |  |  |  |  | Scroller
 |  |  |  |  |  |  | Section
 |  |  |  |  |  |  | Toolbar


Panel Constructor

Panel Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Panel ► Panel()()()
Initializes a new instance of the Panel class.
Declaration Syntax
C#
public Panel()


Align Property

Align Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Panel ► Align
Gets or sets the align.
Declaration Syntax
C#
public string Align { get; set; }
Value
The align.


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Panel ► Click
Gets or sets the Click event.
Declaration Syntax
C#
public string Click { get; set; }
Value
The event to be executed.


DblClick Property

DblClick Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Panel ► DblClick
Gets or sets the Double Click event.
Declaration Syntax
C#
public string DblClick { get; set; }
Value
The event to be executed.


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Panel ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected virtual void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DoDblclick Method (message)

DoDblclick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Panel ► DoDblclick(Message)
Executes the dblclick event.
Declaration Syntax
C#
protected virtual void DoDblclick(
    Message message
)
Parameters
message (Message)
The message.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Panel ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


InnerHtml Property

InnerHtml Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Panel ► InnerHtml
Gets or sets the inner HTML.
Declaration Syntax
C#
public string InnerHtml { get; set; }
Value
The inner HTML.


OnClick Event

OnClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Panel ► OnClick
Called when the panel is clicked.
Declaration Syntax
C#
public event EventHandler OnClick


OnDblClick Event

OnDblClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Panel ► OnDblClick
Called when the panel is double clicked.
Declaration Syntax
C#
public event EventHandler OnDblClick


Popup Class

Popup Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Popup
Represents a control thar can popup.
Declaration Syntax
C#
public class Popup : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Popup()()() | Initializes a new instance of the Popup class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Popup


Popup Constructor

Popup Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Popup ► Popup()()()
Initializes a new instance of the Popup class.
Declaration Syntax
C#
public Popup()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Popup ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


PropertyCollection Class

PropertyCollection Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection
Represents a collection of properties.
Declaration Syntax
C#
public class PropertyCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PropertyCollection()()() | Initializes a new instance of the PropertyCollection class.
 | PropertyCollection(StateBag, CssStyleCollection) | Initializes a new instance of the PropertyCollection class.
 | Add(String, String) | Adds the specified key.
 | Add(String, Boolean) | Adds the specified key.
 | Add(PropertyCollection) | Adds the specified collection.
 | Clear()()() | Clears this collection.
 | Count | Gets the count.
 | CssStyle | Gets or sets the CSS style.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBool(String) | Gets the boolean value with the specified key.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(String) | Gets the value with the specified key.
 | Item[([(String])]) | Gets or sets the String with the specified key.
 | Keys | Gets the keys.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes the specified key.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PropertyCollection


PropertyCollection Constructor

PropertyCollection Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► PropertyCollection()()()
Members
Icon | Member | Description
 | PropertyCollection()()() | Initializes a new instance of the PropertyCollection class.
 | PropertyCollection(StateBag, CssStyleCollection) | Initializes a new instance of the PropertyCollection class.


PropertyCollection Constructor

PropertyCollection Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► PropertyCollection()()()
Initializes a new instance of the PropertyCollection class.
Declaration Syntax
C#
public PropertyCollection()


PropertyCollection Constructor (stateBag, cssStyle)

PropertyCollection Constructor (stateBag, cssStyle)
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► PropertyCollection(StateBag, CssStyleCollection)
Initializes a new instance of the PropertyCollection class.
Declaration Syntax
C#
public PropertyCollection(
    StateBag stateBag,
    CssStyleCollection cssStyle
)
Parameters
stateBag (StateBag)
The state bag.
cssStyle (CssStyleCollection)
The CSS style.


Add Method

Add Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► Add()()()
Members
Icon | Member | Description
 | Add(String, String) | Adds the specified key.
 | Add(String, Boolean) | Adds the specified key.
 | Add(PropertyCollection) | Adds the specified collection.


Add Method (collection)

Add Method (collection)
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► Add(PropertyCollection)
Adds the specified collection.
Declaration Syntax
C#
public void Add(
    PropertyCollection collection
)
Parameters
collection (PropertyCollection)
The collection.


Add Method (key, value)

Add Method (key, value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► Add(String, Boolean)
Adds the specified key.
Declaration Syntax
C#
public void Add(
    string key,
    bool value
)
Parameters
key (String)
The key.
value (Boolean)
The value.


Add Method (key, value)

Add Method (key, value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► Add(String, String)
Adds the specified key.
Declaration Syntax
C#
public void Add(
    string key,
    string value
)
Parameters
key (String)
The key.
value (String)
The value.


Clear Method

Clear Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► Clear()()()
Clears this collection.
Declaration Syntax
C#
public void Clear()


Count Property

Count Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► Count
Gets the count.
Declaration Syntax
C#
public int Count { get; }
Value
The count.


CssStyle Property

CssStyle Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► CssStyle
Gets or sets the CSS style.
Declaration Syntax
C#
public CssStyleCollection CssStyle { get; set; }
Value
The CSS style.


GetBool Method (key)

GetBool Method (key)
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► GetBool(String)
Gets the boolean value with the specified key.
Declaration Syntax
C#
public bool GetBool(
    string key
)
Parameters
key (String)
The key.
Return Value


GetValue Method (key)

GetValue Method (key)
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► GetValue(String)
Gets the value with the specified key.
Declaration Syntax
C#
public string GetValue(
    string key
)
Parameters
key (String)
The key.
Return Value


Item Property (key)

Item Property (key)
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► Item[([(String])])
Gets or sets the String with the specified key.
Declaration Syntax
C#
public string this[
    string key
] { get; set; }
Parameters
key (String)
Value


Keys Property

Keys Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► Keys
Gets the keys.
Declaration Syntax
C#
public ICollection Keys { get; }
Value
The keys.


Remove Method (key)

Remove Method (key)
Namespaces ► Sitecore.Web.UI.HtmlControls ► PropertyCollection ► Remove(String)
Removes the specified key.
Declaration Syntax
C#
public void Remove(
    string key
)
Parameters
key (String)
The key.


QuickFind Class

QuickFind Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► QuickFind
Declaration Syntax
C#
public class QuickFind : Border
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QuickFind()()() | Initializes a new instance of the QuickFind class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the click. (Inherited from Border.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DblClick | Gets or sets the double click. (Inherited from Border.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoClick(Message) | Executes the click event. (Inherited from Border.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDblclick(Message) | Executes the DblClick event. (Inherited from Border.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Renders the control. (Overrides Border.DoRender(HtmlTextWriter).)
 | Drag | Gets or sets the drag event. (Inherited from Border.)
 | DragOverCursor | Gets or sets the drag over cursor. (Inherited from Border.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | Drop | Gets or sets the drop event. (Inherited from Border.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleKey()()() | Handles the key.
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from Border.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InnerHtml | Gets or sets the inner HTML. (Inherited from Border.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick | Called when the control is clicked. (Inherited from Border.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDblClick | Called when the control is double clicked. (Inherited from Border.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSelect()()() | Called when this selection has changed.
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Show()()() | Shows this instance.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from Border.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Border
 |  |  |  |  |  |  | QuickFind


QuickFind Constructor

QuickFind Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► QuickFind ► QuickFind()()()
Initializes a new instance of the QuickFind class
Declaration Syntax
C#
public QuickFind()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► QuickFind ► DoRender(HtmlTextWriter)
Renders the control.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The output.


HandleKey Method

HandleKey Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► QuickFind ► HandleKey()()()
Handles the key.
Declaration Syntax
C#
public void HandleKey()


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► QuickFind ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


OnSelect Method

OnSelect Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► QuickFind ► OnSelect()()()
Called when this selection has changed.
Declaration Syntax
C#
public void OnSelect()


Show Method

Show Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► QuickFind ► Show()()()
Shows this instance.
Declaration Syntax
C#
public void Show()


Radiobutton Class

Radiobutton Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiobutton
Represents a radio button.
Declaration Syntax
C#
public class Radiobutton : Input
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Radiobutton()()() | Initializes a new instance of the Radiobutton class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Change | Gets or sets the change event. (Inherited from Input.)
 | Checked | Gets or sets a value indicating whether this Radiobutton is checked.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoChange(Message) | Raises the Change event. (Overrides Input.DoChange(Message).)
 | DoClick(Message) | Executes the click event.
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header.
 | HeaderStyle | Gets or sets the header style.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange | Called when the input is changed by the user. (Inherited from Input.)
 | OnClick | Called when the control is clicked.
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether this instance is read only. (Inherited from Input.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetModified()()() | Sets the modified flag. (Inherited from Input.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified | Gets or sets a value indicating whether modifications are tracked. (Inherited from Input.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Overrides Control.Value.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Input
 |  |  |  |  |  |  | Radiobutton


Radiobutton Constructor

Radiobutton Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiobutton ► Radiobutton()()()
Initializes a new instance of the Radiobutton class.
Declaration Syntax
C#
public Radiobutton()


Checked Property

Checked Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiobutton ► Checked
Gets or sets a value indicating whether this Radiobutton is checked.
Declaration Syntax
C#
public bool Checked { get; set; }
Value
true if checked; otherwise, false.


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiobutton ► Click
Gets or sets the Click event.
Declaration Syntax
C#
public string Click { get; set; }
Value
The event to be executed.


DoChange Method (message)

DoChange Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiobutton ► DoChange(Message)
Raises the Change event.
Declaration Syntax
C#
protected override void DoChange(
    Message message
)
Parameters
message (Message)
The message.


DoClick Method (message)

DoClick Method (message)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiobutton ► DoClick(Message)
Executes the click event.
Declaration Syntax
C#
protected void DoClick(
    Message message
)
Parameters
message (Message)
The message.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiobutton ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


Header Property

Header Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiobutton ► Header
Gets or sets the header.
Declaration Syntax
C#
public virtual string Header { get; set; }
Value
The header.


HeaderStyle Property

HeaderStyle Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiobutton ► HeaderStyle
Gets or sets the header style.
Declaration Syntax
C#
public virtual string HeaderStyle { get; set; }
Value
The header style.


OnClick Event

OnClick Event
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiobutton ► OnClick
Called when the control is clicked.
Declaration Syntax
C#
public event EventHandler OnClick


Value Property

Value Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiobutton ► Value
Gets or sets the value.
Declaration Syntax
C#
public override string Value { get; set; }
Value
The value.


Radiogroup Class

Radiogroup Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiogroup
Represents a radio group.
Declaration Syntax
C#
public class Radiogroup : HeaderedItemsControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Radiogroup()()() | Initializes a new instance of the Radiogroup class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | Radiogroup


Radiogroup Constructor

Radiogroup Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiogroup ► Radiogroup()()()
Initializes a new instance of the Radiogroup class
Declaration Syntax
C#
public Radiogroup()


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiogroup ► Click
Gets or sets the Click event.
Declaration Syntax
C#
public string Click { get; set; }
Value
The event to be executed.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Radiogroup ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


RadioItem Class

RadioItem Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► RadioItem
Represents an item in a radio group.
Declaration Syntax
C#
public class RadioItem : HeaderedItemsControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RadioItem()()() | Initializes a new instance of the RadioItem class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | Checked | Gets or sets a value indicating whether this RadioItem is checked.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormattedHeader | Obsolete. Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetFormattedHeader()()() | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | Gets the formatted header. (Inherited from HeaderedItemsControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets or sets the header. (Inherited from HeaderedItemsControl.)
 | HeaderStyle | Gets or sets the header CSS style. (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | RadioItem


RadioItem Constructor

RadioItem Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► RadioItem ► RadioItem()()()
Initializes a new instance of the RadioItem class
Declaration Syntax
C#
public RadioItem()


Checked Property

Checked Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► RadioItem ► Checked
Gets or sets a value indicating whether this RadioItem is checked.
Declaration Syntax
C#
public bool Checked { get; set; }
Value
true if checked; otherwise, false.


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► RadioItem ► DoRender(HtmlTextWriter)
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


RecycleBinDataView Class

RecycleBinDataView Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► RecycleBinDataView
Represents the Recycle Bin data view.
Declaration Syntax
C#
public class RecycleBinDataView : MasterDataView
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RecycleBinDataView()()() | Initializes a new instance of the RecycleBinDataView class
 | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from DataViewBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterItems(ArrayList%, String) | Filters the items. (Inherited from DataViewBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildItems(ItemCollection, Item) | Gets the child items. (Inherited from MasterDataView.)
 | GetChildren(Item, String, Boolean, Int32, Int32, String) | Gets the children. (Inherited from DataViewBase.)
 | GetDatabase()()() | Gets the database. (Overrides MasterDataView.GetDatabase()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(String) | Gets the item. (Inherited from DataViewBase.)
 | GetItem(String, Language, Version) | Gets the item. (Inherited from DataViewBase.)
 | GetItemFromID(String, Language, Version) | Gets the item from ID. (Inherited from MasterDataView.)
 | GetParent(Item) | Gets the parent. (Inherited from DataViewBase.)
 | GetParentItem(Item) | Gets the parent item. (Inherited from MasterDataView.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildren(Item, String) | Determines whether the specified item has children. (Inherited from DataViewBase.)
 | Initialize(String) | Initializes the view from a data context. (Inherited from MasterDataView.)
 | IsAncestorOf(Item, Item) | Determines whether the ancestor is an ancestor of the item. (Inherited from MasterDataView.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters | Gets the parameters. (Inherited from DataViewBase.)
 | SortItems(ArrayList, String, Boolean) | Sorts the items. (Inherited from DataViewBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataViewBase
 |  | MasterDataView
 |  |  | RecycleBinDataView


RecycleBinDataView Constructor

RecycleBinDataView Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► RecycleBinDataView ► RecycleBinDataView()()()
Initializes a new instance of the RecycleBinDataView class
Declaration Syntax
C#
public RecycleBinDataView()


GetDatabase Method

GetDatabase Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► RecycleBinDataView ► GetDatabase()()()
Gets the database.
Declaration Syntax
C#
protected override Database GetDatabase()
Return Value


RegisterKey Class

RegisterKey Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► RegisterKey
Makes a registration in the KeyMap collection.
Declaration Syntax
C#
public class RegisterKey : Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegisterKey()()() | Initializes a new instance of the RegisterKey class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Gets or sets the Click event.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Component.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | Group | Gets or sets the group.
 | HandleMessage(Message) | Handles the message. (Inherited from Component.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyCode | Gets or sets the key code.
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | RegisterKey


RegisterKey Constructor

RegisterKey Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► RegisterKey ► RegisterKey()()()
Initializes a new instance of the RegisterKey class.
Declaration Syntax
C#
public RegisterKey()


Click Property

Click Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► RegisterKey ► Click
Gets or sets the Click event.
Declaration Syntax
C#
public string Click { get; set; }
Value
The event to be executed.


Group Property

Group Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► RegisterKey ► Group
Gets or sets the group.
Declaration Syntax
C#
public string Group { get; set; }
Value
The group.


KeyCode Property

KeyCode Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► RegisterKey ► KeyCode
Gets or sets the key code.
Declaration Syntax
C#
public string KeyCode { get; set; }
Value
The key code.


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► RegisterKey ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


Registry Class

Registry Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry
Implements a store for keeping name/value pairs for each user.
Declaration Syntax
C#
public static class Registry
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetBool(String) | Gets the boolean value with the specified key.
 | GetBool(String, Boolean) | Gets the boolean value with the specified key.
 | GetInt(String) | Gets the integer value with the specified key.
 | GetInt(String, Int32) | Gets the integer value with the specified key.
 | GetString(String) | Gets the string.
 | GetString(String, String) | Gets the string.
 | GetValue(String) | Gets the value.
 | SetBool(String, Boolean) | Sets the boolean value.
 | SetInt(String, Int32) | Sets the integer value.
 | SetString(String, String) | Sets the string.
 | SetValue(String, String) | Sets the value.
Inheritance Hierarchy
Object
Registry


GetBool Method

GetBool Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry ► GetBool()()()
Members
Icon | Member | Description
 | GetBool(String) | Gets the boolean value with the specified key.
 | GetBool(String, Boolean) | Gets the boolean value with the specified key.


GetBool Method (key)

GetBool Method (key)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry ► GetBool(String)
Gets the boolean value with the specified key.
Declaration Syntax
C#
public static bool GetBool(
    string key
)
Parameters
key (String)
The key.
Return Value


GetBool Method (key, defaultvalue)

GetBool Method (key, defaultvalue)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry ► GetBool(String, Boolean)
Gets the boolean value with the specified key.
Declaration Syntax
C#
public static bool GetBool(
    string key,
    bool defaultvalue
)
Parameters
key (String)
The key.
defaultvalue (Boolean)
The default value.
Return Value


GetInt Method

GetInt Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry ► GetInt()()()
Members
Icon | Member | Description
 | GetInt(String) | Gets the integer value with the specified key.
 | GetInt(String, Int32) | Gets the integer value with the specified key.


GetInt Method (key)

GetInt Method (key)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry ► GetInt(String)
Gets the integer value with the specified key.
Declaration Syntax
C#
public static int GetInt(
    string key
)
Parameters
key (String)
The key.
Return Value


GetInt Method (key, defaultvalue)

GetInt Method (key, defaultvalue)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry ► GetInt(String, Int32)
Gets the integer value with the specified key.
Declaration Syntax
C#
public static int GetInt(
    string key,
    int defaultvalue
)
Parameters
key (String)
The key.
defaultvalue (Int32)
The default value.
Return Value


GetString Method

GetString Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry ► GetString()()()
Members
Icon | Member | Description
 | GetString(String) | Gets the string.
 | GetString(String, String) | Gets the string.


GetString Method (key)

GetString Method (key)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry ► GetString(String)
Gets the string.
Declaration Syntax
C#
public static string GetString(
    string key
)
Parameters
key (String)
The key.
Return Value


GetString Method (key, defaultvalue)

GetString Method (key, defaultvalue)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry ► GetString(String, String)
Gets the string.
Declaration Syntax
C#
public static string GetString(
    string key,
    string defaultvalue
)
Parameters
key (String)
The key.
defaultvalue (String)
The default value.
Return Value


GetValue Method (key)

GetValue Method (key)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry ► GetValue(String)
Gets the value.
Declaration Syntax
C#
public static string GetValue(
    string key
)
Parameters
key (String)
The key.
Return Value


SetBool Method (key, val)

SetBool Method (key, val)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry ► SetBool(String, Boolean)
Sets the boolean value.
Declaration Syntax
C#
public static void SetBool(
    string key,
    bool val
)
Parameters
key (String)
The key.
val (Boolean)
The value.


SetInt Method (key, val)

SetInt Method (key, val)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry ► SetInt(String, Int32)
Sets the integer value.
Declaration Syntax
C#
public static void SetInt(
    string key,
    int val
)
Parameters
key (String)
The key.
val (Int32)
The val.


SetString Method (key, value)

SetString Method (key, value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry ► SetString(String, String)
Sets the string.
Declaration Syntax
C#
public static void SetString(
    string key,
    string value
)
Parameters
key (String)
The key.
value (String)
The value.


SetValue Method (key, value)

SetValue Method (key, value)
Namespaces ► Sitecore.Web.UI.HtmlControls ► Registry ► SetValue(String, String)
Sets the value.
Declaration Syntax
C#
public static void SetValue(
    string key,
    string value
)
Parameters
key (String)
The key.
value (String)
The value.


RenderItem Class

RenderItem Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderItem
Renders the item.
Declaration Syntax
C#
public class RenderItem : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderItem()()() | Initializes a new instance of the RenderItem class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DefinitionSource | Definition source (path to item containing visualizer xml to use for display of item). If empty, DataSource is used.
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | DisplayMode | Display mode (rendering type to use for display of item)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Component.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Get item from current data source (Overrides WebControl.GetItem()()().)
 | GetItemControl(Item) | Get rendering for an item
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Render control (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | RenderItem


RenderItem Constructor

RenderItem Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderItem ► RenderItem()()()
Initializes a new instance of the RenderItem class
Declaration Syntax
C#
public RenderItem()


DefinitionSource Property

DefinitionSource Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderItem ► DefinitionSource
Definition source (path to item containing visualizer xml to use for display of item). If empty, DataSource is used.
Declaration Syntax
C#
public string DefinitionSource { get; set; }
Value
The definition source.


DisplayMode Property

DisplayMode Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderItem ► DisplayMode
Display mode (rendering type to use for display of item)
Declaration Syntax
C#
public string DisplayMode { get; set; }
Value
The display mode.


GetItem Method

GetItem Method
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderItem ► GetItem()()()
Get item from current data source
Declaration Syntax
C#
protected override Item GetItem()
Return Value


GetItemControl Method (item)

GetItemControl Method (item)
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderItem ► GetItemControl(Item)
Get rendering for an item
Declaration Syntax
C#
protected Control GetItemControl(
    Item item
)
Parameters
item (Item)
The item.
Return Value


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderItem ► OnLoad(EventArgs)
Render control
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


RenderList Class

RenderList Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderList
Renders a list of items.
Declaration Syntax
C#
public class RenderList : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderList()()() | Initializes a new instance of the RenderList class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CheckFilter(Item) | Checks if an item complies with the current filter
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | DisplayMode | Display mode (rendering type to use for display of individual items)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Component.)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Filter | Filter - enables filtering of items based on field values. Currently only supports filtering on one field value
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemControl(Item) | Get single item control
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | RenderList


RenderList Constructor

RenderList Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderList ► RenderList()()()
Initializes a new instance of the RenderList class
Declaration Syntax
C#
public RenderList()


CheckFilter Method (itm)

CheckFilter Method (itm)
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderList ► CheckFilter(Item)
Checks if an item complies with the current filter
Declaration Syntax
C#
protected bool CheckFilter(
    Item itm
)
Parameters
itm (Item)
The itm.
Return Value


DisplayMode Property

DisplayMode Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderList ► DisplayMode
Display mode (rendering type to use for display of individual items)
Declaration Syntax
C#
public string DisplayMode { get; set; }
Value
The display mode.


Filter Property

Filter Property
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderList ► Filter
Filter - enables filtering of items based on field values. Currently only supports filtering on one field value
Declaration Syntax
C#
public string Filter { get; set; }
Value
The filter.
Remarks
Format: fieldname=condition


GetItemControl Method (itm)

GetItemControl Method (itm)
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderList ► GetItemControl(Item)
Get single item control
Declaration Syntax
C#
protected Control GetItemControl(
    Item itm
)
Parameters
itm (Item)
The itm.
Return Value


OnLoad Method (e)

OnLoad Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderList ► OnLoad(EventArgs)
Raises the Load event.
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)
The EventArgs object that contains the event data.


RenderLiteral Class

RenderLiteral Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderLiteral
Renders a control as a literal.
Declaration Syntax
C#
public class RenderLiteral : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderLiteral()()() | Initializes a new instance of the RenderLiteral class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Render control (Overrides WebControl.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | RenderLiteral


RenderLiteral Constructor

RenderLiteral Constructor
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderLiteral ► RenderLiteral()()()
Initializes a new instance of the RenderLiteral class
Declaration Syntax
C#
public RenderLiteral()


DoRender Method (output)

DoRender Method (output)
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderLiteral ► DoRender(HtmlTextWriter)
Render control
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)
The HtmlTextWriter object that receives the server control content.


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces ► Sitecore.Web.UI.HtmlControls ► RenderLiteral ► OnPreRender(EventArgs)
Raises the PreRender event.
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)
An EventArgs object that contains the event data.


Reporter Class

Reporter Class
Namespaces ► Sitecore.Web.UI.HtmlControls ► Reporter
Builds a report from a source and a formatter.
Declaration Syntax
C#
public class Reporter : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Reporter()()() | Initializes a new instance of the Reporter class
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action | Gets or sets the action. (Inherited from Control.)
 | Activate | Gets or sets the activate message. (Inherited from Control.)
 | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | Adds the debug value. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | Adds to cache. (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | Executes afters the control has been rendered. (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | Asserts the load only property. (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background | Gets or sets the background style. (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | Executes befores the control is rendered. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border | Gets or sets the border style. (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
 | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
 | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class | Gets or sets the CSS class name. (Inherited from Control.)
 | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
 | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
 | ClearChildControlState()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()()() | Collects the debug information. (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
 | ControlAttributes | Gets the control attributes. (Inherited from Control.)
 | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
 | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
 | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
 | DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext | Gets or sets the data context. (Inherited from Control.)
 | DataSource | Gets or sets the data source. (Inherited from WebControl.)
 | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
 | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
 | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
 | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
 | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
 | Dispose()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | Executes the activate event. (Inherited from Control.)
 | DoContextmenu(Message) | Executes the contextmenu event. (Inherited from Control.)
 | DoDeactivate(Message) | Executes the deactivate event. (Inherited from Control.)
 | DoKeydown(Message) | Executes the keydown event. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
 | EmitRenderingInfoScript()()() | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)
 | Float | Gets or sets the float style property. (Inherited from WebControl.)
 | Focus()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
 | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
 | FontName | Gets or sets the name of the font. (Inherited from Control.)
 | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
 | FontSize | Gets or sets the size of the font. (Inherited from Control.)
 | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
 | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
 | FormatAttribute(String, String) | Formats the attribute. (Inherited from Component.)
 | FormatterParameters | Gets or sets the formatter parameters.
 | FormatterType | Gets or sets the type of the formatter.
 | GetAncestorItem(array<String>[]()[], Item) | Gets the ancestor item. (Inherited from WebControl.)
 | GetCachedHtml(String) | Gets the cached HTML. (Inherited from WebControl.)
 | GetCacheKey()()() | Gets the cache key. (Inherited from WebControl.)
 | GetCachingID()()() | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
 | GetContentItemFromQueryString()()() | Gets the content item from query string. (Inherited from Component.)
 | GetContextItem()()() | Gets the context item. (Inherited from WebControl.)
 | GetControlAttributes()()() | Gets the control attributes. (Inherited from Control.)
 | GetDatabase()()() | Gets the database to use. (Inherited from WebControl.)
 | GetDataContext()()() | Gets the data context. (Inherited from Control.)
 | GetDesignModeState()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | Gets the design time HTML. (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | Gets the extensible properties. (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | Gets the extensible property. (Inherited from WebControl.)
 | GetFieldValue(String) | Get field value from current data source. (Inherited from WebControl.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID(String) | Gets the ID. (Inherited from Component.)
 | GetItem()()() | Gets the item. (Inherited from WebControl.)
 | GetItemFromQueryString()()() | Gets the item from query string. (Inherited from Component.)
 | GetTraceName()()() | Gets the text used when tracing. (Inherited from WebControl.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
 | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
 | GetViewStateProperty(String, Object) | Gets the view state property. (Inherited from Component.)
 | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
 | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
 | HandleMessage(Message) | Handles the message. (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown | Gets or sets the key down. (Inherited from Control.)
 | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
 | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
 | LoadPostData(String) | Loads the post data. (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, WebControl..::.ContentGetter) | Makes the control editable. (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
 | Name | Gets or sets the name. (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | Called when an action has changed. (Inherited from Control.)
 | OnActivate | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | Called when the data context changed. (Inherited from Control.)
 | OnDeactivate | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | Called when the item has added. (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | Called when the item has deleted. (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | Called when the item has renamed. (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | Called when the item has saved. (Inherited from Control.)
 | OnKeyDown | (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()() | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
 | RegisterDebugScript()()() | Registers the debug script. (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
 | RenderAsText()()() | Renders the control as text. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | Renders the control from cached Html. (Inherited from WebControl.)
 | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
 | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | Renders the XML. (Inherited from WebControl.)
 | ResolveAdapter()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
 | SaveControlState()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()() | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | Gets the server properties. (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | Sets the control attribute. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetExtensibleProperty(Control, String, String) | Sets the extensible property. (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
 | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | Sets the view state property. (Inherited from Component.)
 | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
 | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
 | SetWidthAndHeightAttributes()()() | Sets the width and height attributes. (Inherited from Control.)
 | SetWidthAndHeightStyle()()() | Sets the width and height style. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SkipCaching()()() | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
 | SourceParameters | Gets or sets the source parameters.
 | SourceType | Gets or sets the type of the source.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | Transfers the attributes to another control. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Value | Gets or sets the value. (Inherited from Control.)
 | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
 | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
 | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
 | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
 | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
 | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Reporter